Re: [openstack-dev] Problem installing devstack

2015-01-06 Thread Rajdeep Dua
Thanks for the responses RECLONE=yes worked for me.

On Tue, Jan 6, 2015 at 11:14 AM, Dr. Jens Rosenboom j.rosenb...@x-ion.de
wrote:

 Am 06/01/15 um 04:40 schrieb Rajdeep Dua:

  Getting this error while running stack.sh in devstack

 Could not find a version that satisfies the requirement
 SQLAlchemy=0.8.99,=0.9.99,=0.8.4,=0.9.7 (from
 keystone==2014.2.dev114)
 (from versions: 0.4.2p3, 0.4.7p1, 0.5.4p1, 0.5.4p2, 0.1.0, 0.1.1, 0.1.2,
 0.1.3, 0.1.4, 0.1.5, 0.1.6, 0.1.7, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4,
 0.2.5, 0.2.6, 0.2.7, 0.2.8, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.3.5,
 0.3.6, 0.3.7, 0.3.8, 0.3.9, 0.3.10, 0.3.11, 0.4.0b1, 0.4.0b2, 0.4.0b3,
 0.4.0b4, 0.4.0b5, 0.4.0b6, 0.4.0, 0.4.1, 0.4.2a0, 0.4.2b0, 0.4.2, 0.4.3,
 0.4.4, 0.4.5, 0.4.6, 0.4.7, 0.4.8, 0.5.0b1, 0.5.0b2, 0.5.0b3, 0.5.0rc1,
 0.5.0rc2, 0.5.0rc3, 0.5.0rc4, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.5.5,
 0.5.6, 0.5.7, 0.5.8, 0.6b1, 0.6b2, 0.6b3, 0.6.0, 0.6.1, 0.6.2, 0.6.3,
 0.6.4, 0.6.5, 0.6.6, 0.6.7, 0.6.8, 0.6.9, 0.7.0, 0.7.1, 0.7.2, 0.7.3,
 0.7.4, 0.7.5, 0.7.6, 0.7.7, 0.7.8, 0.7.9, 0.7.10, 0.8.0b2, 0.8.0, 0.8.1,
 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.9.0, 0.9.1, 0.9.2, 0.9.3,
 0.9.4, 0.9.5, 0.9.6, 0.9.7, 0.9.8)
No distributions matching the version for
 SQLAlchemy=0.8.99,=0.9.99,=0.8.4,=0.9.7 (from
 keystone==2014.2.dev114)

 I saw a couple of bugs filed and patches going in.

 Please clarify if this is fixed and how to get the latest changes in.


 I would assume that you are trying to reuse an older devstack
 installation, as this bug should have been fixed a couple of weeks ago.

 However, running stack.sh by default does not update the source repos once
 they exist, so you can either add RECLONE=yes to your config or go
 manually through the repos in /opt/stack and update them.



 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] Problem installing devstack

2015-01-05 Thread Abhishek Shrivastava
Hi Rajdeep,

Can you tell me the exact configuration (i.e;OS) you are using for
installing devstack.

On Tue, Jan 6, 2015 at 10:16 AM, Rajdeep Dua rajdeep@gmail.com wrote:

 Thanks for the response, in my case i am still getting the same error..

 On Tue, Jan 6, 2015 at 9:28 AM, Ken'ichi Ohmichi ken1ohmi...@gmail.com
 wrote:

 2015-01-06 12:40 GMT+09:00 Rajdeep Dua rajdeep@gmail.com:
  Getting this error while running stack.sh in devstack
 
  Could not find a version that satisfies the requirement
  SQLAlchemy=0.8.99,=0.9.99,=0.8.4,=0.9.7 (from
 keystone==2014.2.dev114)
  (from versions: 0.4.2p3, 0.4.7p1, 0.5.4p1, 0.5.4p2, 0.1.0, 0.1.1, 0.1.2,
  0.1.3, 0.1.4, 0.1.5, 0.1.6, 0.1.7, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4,
 0.2.5,
  0.2.6, 0.2.7, 0.2.8, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.3.5, 0.3.6,
 0.3.7,
  0.3.8, 0.3.9, 0.3.10, 0.3.11, 0.4.0b1, 0.4.0b2, 0.4.0b3, 0.4.0b4,
 0.4.0b5,
  0.4.0b6, 0.4.0, 0.4.1, 0.4.2a0, 0.4.2b0, 0.4.2, 0.4.3, 0.4.4, 0.4.5,
 0.4.6,
  0.4.7, 0.4.8, 0.5.0b1, 0.5.0b2, 0.5.0b3, 0.5.0rc1, 0.5.0rc2, 0.5.0rc3,
  0.5.0rc4, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.5.5, 0.5.6, 0.5.7, 0.5.8,
  0.6b1, 0.6b2, 0.6b3, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.6.6,
 0.6.7,
  0.6.8, 0.6.9, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.5, 0.7.6, 0.7.7,
 0.7.8,
  0.7.9, 0.7.10, 0.8.0b2, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6,
  0.8.7, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.9.4, 0.9.5, 0.9.6, 0.9.7, 0.9.8)
No distributions matching the version for
  SQLAlchemy=0.8.99,=0.9.99,=0.8.4,=0.9.7 (from
 keystone==2014.2.dev114)
 
  I saw a couple of bugs filed and patches going in.
 
  Please clarify if this is fixed and how to get the latest changes in.


 I faced the similar problem, and I could avoid it by removing
 /usr/local/lib/python2.7/dist-packages directory and ./stack.sh again.

 Hope that helps,
 Ken Ohmichi

 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev



 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev




-- 
Thanks  Regards,
Abhishek
___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] Problem installing devstack

2015-01-05 Thread Dr. Jens Rosenboom

Am 06/01/15 um 04:40 schrieb Rajdeep Dua:

Getting this error while running stack.sh in devstack

Could not find a version that satisfies the requirement
SQLAlchemy=0.8.99,=0.9.99,=0.8.4,=0.9.7 (from keystone==2014.2.dev114)
(from versions: 0.4.2p3, 0.4.7p1, 0.5.4p1, 0.5.4p2, 0.1.0, 0.1.1, 0.1.2,
0.1.3, 0.1.4, 0.1.5, 0.1.6, 0.1.7, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4,
0.2.5, 0.2.6, 0.2.7, 0.2.8, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.3.5,
0.3.6, 0.3.7, 0.3.8, 0.3.9, 0.3.10, 0.3.11, 0.4.0b1, 0.4.0b2, 0.4.0b3,
0.4.0b4, 0.4.0b5, 0.4.0b6, 0.4.0, 0.4.1, 0.4.2a0, 0.4.2b0, 0.4.2, 0.4.3,
0.4.4, 0.4.5, 0.4.6, 0.4.7, 0.4.8, 0.5.0b1, 0.5.0b2, 0.5.0b3, 0.5.0rc1,
0.5.0rc2, 0.5.0rc3, 0.5.0rc4, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.5.5,
0.5.6, 0.5.7, 0.5.8, 0.6b1, 0.6b2, 0.6b3, 0.6.0, 0.6.1, 0.6.2, 0.6.3,
0.6.4, 0.6.5, 0.6.6, 0.6.7, 0.6.8, 0.6.9, 0.7.0, 0.7.1, 0.7.2, 0.7.3,
0.7.4, 0.7.5, 0.7.6, 0.7.7, 0.7.8, 0.7.9, 0.7.10, 0.8.0b2, 0.8.0, 0.8.1,
0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.9.0, 0.9.1, 0.9.2, 0.9.3,
0.9.4, 0.9.5, 0.9.6, 0.9.7, 0.9.8)
   No distributions matching the version for
SQLAlchemy=0.8.99,=0.9.99,=0.8.4,=0.9.7 (from keystone==2014.2.dev114)

I saw a couple of bugs filed and patches going in.

Please clarify if this is fixed and how to get the latest changes in.


I would assume that you are trying to reuse an older devstack 
installation, as this bug should have been fixed a couple of weeks ago.


However, running stack.sh by default does not update the source repos 
once they exist, so you can either add RECLONE=yes to your config or 
go manually through the repos in /opt/stack and update them.



___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] Problem installing devstack

2015-01-05 Thread Rajdeep Dua
Thanks for the response, in my case i am still getting the same error..

On Tue, Jan 6, 2015 at 9:28 AM, Ken'ichi Ohmichi ken1ohmi...@gmail.com
wrote:

 2015-01-06 12:40 GMT+09:00 Rajdeep Dua rajdeep@gmail.com:
  Getting this error while running stack.sh in devstack
 
  Could not find a version that satisfies the requirement
  SQLAlchemy=0.8.99,=0.9.99,=0.8.4,=0.9.7 (from
 keystone==2014.2.dev114)
  (from versions: 0.4.2p3, 0.4.7p1, 0.5.4p1, 0.5.4p2, 0.1.0, 0.1.1, 0.1.2,
  0.1.3, 0.1.4, 0.1.5, 0.1.6, 0.1.7, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4,
 0.2.5,
  0.2.6, 0.2.7, 0.2.8, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.3.5, 0.3.6,
 0.3.7,
  0.3.8, 0.3.9, 0.3.10, 0.3.11, 0.4.0b1, 0.4.0b2, 0.4.0b3, 0.4.0b4,
 0.4.0b5,
  0.4.0b6, 0.4.0, 0.4.1, 0.4.2a0, 0.4.2b0, 0.4.2, 0.4.3, 0.4.4, 0.4.5,
 0.4.6,
  0.4.7, 0.4.8, 0.5.0b1, 0.5.0b2, 0.5.0b3, 0.5.0rc1, 0.5.0rc2, 0.5.0rc3,
  0.5.0rc4, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.5.5, 0.5.6, 0.5.7, 0.5.8,
  0.6b1, 0.6b2, 0.6b3, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.6.6,
 0.6.7,
  0.6.8, 0.6.9, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.5, 0.7.6, 0.7.7,
 0.7.8,
  0.7.9, 0.7.10, 0.8.0b2, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6,
  0.8.7, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.9.4, 0.9.5, 0.9.6, 0.9.7, 0.9.8)
No distributions matching the version for
  SQLAlchemy=0.8.99,=0.9.99,=0.8.4,=0.9.7 (from
 keystone==2014.2.dev114)
 
  I saw a couple of bugs filed and patches going in.
 
  Please clarify if this is fixed and how to get the latest changes in.


 I faced the similar problem, and I could avoid it by removing
 /usr/local/lib/python2.7/dist-packages directory and ./stack.sh again.

 Hope that helps,
 Ken Ohmichi

 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] Problem installing devstack

2015-01-05 Thread Amit Das
Can you check the /opt/stack/requirements folder  check if thats updated
 (git status, git log) after doing unstack  stack.

One of the *-requirements.txt has the entry which makes all the projects to
fail.

We had removed the /opt/stack/requirements project  then did a unstack 
stack.

Regards,
Amit
*CloudByte Inc.* http://www.cloudbyte.com/

On Tue, Jan 6, 2015 at 10:40 AM, Abhishek Shrivastava 
abhis...@cloudbyte.com wrote:

 Hi Rajdeep,

 Can you tell me the exact configuration (i.e;OS) you are using for
 installing devstack.

 On Tue, Jan 6, 2015 at 10:16 AM, Rajdeep Dua rajdeep@gmail.com
 wrote:

 Thanks for the response, in my case i am still getting the same error..

 On Tue, Jan 6, 2015 at 9:28 AM, Ken'ichi Ohmichi ken1ohmi...@gmail.com
 wrote:

 2015-01-06 12:40 GMT+09:00 Rajdeep Dua rajdeep@gmail.com:
  Getting this error while running stack.sh in devstack
 
  Could not find a version that satisfies the requirement
  SQLAlchemy=0.8.99,=0.9.99,=0.8.4,=0.9.7 (from
 keystone==2014.2.dev114)
  (from versions: 0.4.2p3, 0.4.7p1, 0.5.4p1, 0.5.4p2, 0.1.0, 0.1.1,
 0.1.2,
  0.1.3, 0.1.4, 0.1.5, 0.1.6, 0.1.7, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4,
 0.2.5,
  0.2.6, 0.2.7, 0.2.8, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.3.5, 0.3.6,
 0.3.7,
  0.3.8, 0.3.9, 0.3.10, 0.3.11, 0.4.0b1, 0.4.0b2, 0.4.0b3, 0.4.0b4,
 0.4.0b5,
  0.4.0b6, 0.4.0, 0.4.1, 0.4.2a0, 0.4.2b0, 0.4.2, 0.4.3, 0.4.4, 0.4.5,
 0.4.6,
  0.4.7, 0.4.8, 0.5.0b1, 0.5.0b2, 0.5.0b3, 0.5.0rc1, 0.5.0rc2, 0.5.0rc3,
  0.5.0rc4, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.5.5, 0.5.6, 0.5.7,
 0.5.8,
  0.6b1, 0.6b2, 0.6b3, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.6.6,
 0.6.7,
  0.6.8, 0.6.9, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.5, 0.7.6, 0.7.7,
 0.7.8,
  0.7.9, 0.7.10, 0.8.0b2, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5,
 0.8.6,
  0.8.7, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.9.4, 0.9.5, 0.9.6, 0.9.7, 0.9.8)
No distributions matching the version for
  SQLAlchemy=0.8.99,=0.9.99,=0.8.4,=0.9.7 (from
 keystone==2014.2.dev114)
 
  I saw a couple of bugs filed and patches going in.
 
  Please clarify if this is fixed and how to get the latest changes in.


 I faced the similar problem, and I could avoid it by removing
 /usr/local/lib/python2.7/dist-packages directory and ./stack.sh again.

 Hope that helps,
 Ken Ohmichi

 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev



 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev




 --
 Thanks  Regards,
 Abhishek

 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev