Re: [openstack-dev] oslo.db 1.2.1 release coming to fix stable/juno

2014-12-17 Thread Thomas Goirand
On 12/16/2014 04:21 AM, Doug Hellmann wrote: The issue with stable/juno jobs failing because of the difference in the SQLAlchemy requirements between the older applications and the newer oslo.db is being addressed with a new release of the 1.2.x series. We will then cap the requirements for

Re: [openstack-dev] oslo.db 1.2.1 release coming to fix stable/juno

2014-12-17 Thread Jeremy Stanley
On 2014-12-17 22:02:26 +0800 (+0800), Thomas Goirand wrote: I'm not sure I get it. Is this related to newer versions of SQLAlchemy? It's related to how Setuptools 8 failed to parse our requirements line for SQLAlchemy because it contained multiple version ranges. That was fixed by converting it

Re: [openstack-dev] oslo.db 1.2.1 release coming to fix stable/juno

2014-12-16 Thread Doug Hellmann
On Dec 15, 2014, at 5:58 PM, Doug Hellmann d...@doughellmann.com wrote: On Dec 15, 2014, at 3:21 PM, Doug Hellmann d...@doughellmann.com wrote: The issue with stable/juno jobs failing because of the difference in the SQLAlchemy requirements between the older applications and the newer

Re: [openstack-dev] oslo.db 1.2.1 release coming to fix stable/juno

2014-12-16 Thread Doug Hellmann
On Dec 16, 2014, at 8:15 AM, Doug Hellmann d...@doughellmann.com wrote: On Dec 15, 2014, at 5:58 PM, Doug Hellmann d...@doughellmann.com wrote: On Dec 15, 2014, at 3:21 PM, Doug Hellmann d...@doughellmann.com wrote: The issue with stable/juno jobs failing because of the difference in

Re: [openstack-dev] oslo.db 1.2.1 release coming to fix stable/juno

2014-12-15 Thread Doug Hellmann
On Dec 15, 2014, at 3:21 PM, Doug Hellmann d...@doughellmann.com wrote: The issue with stable/juno jobs failing because of the difference in the SQLAlchemy requirements between the older applications and the newer oslo.db is being addressed with a new release of the 1.2.x series. We will