commit polkit for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package polkit for openSUSE:Factory checked 
in at 2012-11-18 09:11:43

Comparing /work/SRC/openSUSE:Factory/polkit (Old)
 and  /work/SRC/openSUSE:Factory/.polkit.new (New)


Package is polkit, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/polkit/polkit.changes2012-11-13 
10:18:23.0 +0100
+++ /work/SRC/openSUSE:Factory/.polkit.new/polkit.changes   2012-11-18 
09:11:45.0 +0100
@@ -1,0 +2,25 @@
+Thu Nov 15 21:31:19 UTC 2012 - dims...@opensuse.org
+
+- Update to version 0.108:
+  + PolkitAgent: Avoid crashing if initializing the server object
+fails
+  + Fall back to authenticating as uid 0 if the list of admin
+identities is empty
+  + Dynamically load libmozjs185.so and cope with it not being
+available
+  + docs: mention the audience for authorization rules
+  + build: Fix .gir generation for parallel make
+- Only conditionally Require ConsoleKit when with_systemd is 0:
+  systemd support obsoletes ConsoleKit.
+- Add polkit-link-gmodule.patch: Link against gmodule-2.0.
+- Change libpolkit0 to require polkit = %version instead of the
+  exact version. This will ease upgrade problems should there ever
+  be a soname bump of libpolkit0.
+
+---
+Wed Nov 14 09:26:14 UTC 2012 - dims...@opensuse.org
+
+- Enable systemd inetegration (change with_systemd to 1): As an
+  agreed target for 12.3, systemd integration will be enabled.
+
+---

Old:

  polkit-0.107.tar.gz

New:

  polkit-0.108.tar.gz
  polkit-link-gmodule.patch



Other differences:
--
++ polkit.spec ++
--- /var/tmp/diff_new_pack.Smilww/_old  2012-11-18 09:11:47.0 +0100
+++ /var/tmp/diff_new_pack.Smilww/_new  2012-11-18 09:11:47.0 +0100
@@ -16,13 +16,16 @@
 #
 
 
-%define with_systemd 0
+%define with_systemd 1
+%if 0%{with_systemd}
+%define systemdsystemunitdir %(pkg-config --variable systemdsystemunitdir 
systemd)
+%endif
 
 Name:   polkit
 Summary:PolicyKit Authorization Framework
 License:LGPL-2.1+
 Group:  System/Libraries
-Version:0.107
+Version:0.108
 Release:0
 Url:http://www.freedesktop.org/wiki/Software/PolicyKit
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -34,6 +37,8 @@
 Patch1: polkit-suid_flags.patch
 # PATCH-FIX-UPSTREAM polkit-no-systemd.patch bnc#782395 fdo#55377 
vu...@opensuse.org -- Do not reference non-existing polkit.service file for 
systemd (only applied if not built with systemd support)
 Patch2: polkit-no-systemd.patch
+# PATCH-FIX-UPSTREAM polkit-link-gmodule.patch dims...@opensuse.org -- Link 
against gmodule-2.0. Patch taken from upstream git.
+Patch3: polkit-link-gmodule.patch
 # needed for patch1
 BuildRequires:  autoconf
 # needed for patch1
@@ -45,7 +50,7 @@
 #!BuildIgnore:  ruby
 BuildRequires:  intltool
 BuildRequires:  libexpat-devel
-# needed for patch1
+# needed for patch1 and patch3
 BuildRequires:  libtool
 BuildRequires:  pam-devel
 %if 0%{?with_systemd}
@@ -53,9 +58,14 @@
 %endif
 BuildRequires:  pkgconfig(mozjs185)
 PreReq: permissions pwdutils
+%if ! %{with_systemd}
 Requires:   ConsoleKit
+%endif
 Requires:   dbus-1
 Requires:   libpolkit0 = %{version}-%{release}
+%if %{with_systemd}
+%systemd_requires
+%endif
 
 # Upstream First - Policy:
 # Never add any patches to this package without the upstream commit id
@@ -91,7 +101,7 @@
 %package -n libpolkit0
 Summary:PolicyKit Authorization Framework -- Libraries
 Group:  System/Libraries
-Requires:   %{name} = %{version}
+Requires:   %{name} = %{version}
 
 %description -n libpolkit0
 PolicyKit is a toolkit for defining and handling authorizations.
@@ -118,10 +128,11 @@
 %if !(0%{?with_systemd})
 %patch2 -p1
 %endif
+%patch3 -p1
 
 %build
 export V=1
-# needed for patch1
+# needed for patch1 and patch3
 autoreconf -fi
 export SUID_CFLAGS=-fPIE
 export SUID_LDFLAGS=-z now -pie
@@ -153,11 +164,25 @@
 %pre
 getent group polkitd  /dev/null || groupadd -r polkitd
 getent passwd polkitd  /dev/null || useradd -r -g polkitd -d 
%{_localstatedir}/lib/polkit -s /sbin/nologin -c User for polkitd polkitd
+%if %{with_systemd}
+%service_add_pre polkit.service
+%endif
 exit 0
 
+%if %{with_systemd}
+%preun
+%service_del_preun polkit.service
+
+%postun
+%service_del_postun polkit.service
+%endif
+
 %post
 %set_permissions %{_bindir}/pkexec
 %set_permissions %{_prefix}/lib/polkit-1/polkit-agent-helper-1
+%if %{with_systemd}
+%service_add_post polkit.service
+%endif
 
 %verifyscript
 %verify_permissions -e %{_bindir}/pkexec
@@ -209,6 +234,9 @@
 

commit opera for openSUSE:Factory:NonFree

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package opera for openSUSE:Factory:NonFree 
checked in at 2012-11-18 09:13:44

Comparing /work/SRC/openSUSE:Factory:NonFree/opera (Old)
 and  /work/SRC/openSUSE:Factory:NonFree/.opera.new (New)


Package is opera, Maintainer is orpha...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory:NonFree/opera/opera.changes  2012-11-08 
21:51:21.0 +0100
+++ /work/SRC/openSUSE:Factory:NonFree/.opera.new/opera.changes 2012-11-18 
09:13:46.0 +0100
@@ -1,0 +2,5 @@
+Fri Nov 16 09:07:12 UTC 2012 - dli...@suse.com
+
+- Add the icon cache update to the spec file (bnc#783934) 
+
+---



Other differences:
--
++ opera.spec ++
--- /var/tmp/diff_new_pack.tuYp0q/_old  2012-11-18 09:13:48.0 +0100
+++ /var/tmp/diff_new_pack.tuYp0q/_new  2012-11-18 09:13:48.0 +0100
@@ -36,6 +36,8 @@
 BuildRequires:  fdupes
 BuildRequires:  update-desktop-files
 BuildRequires:  xz
+Requires(post):   coreutils shared-mime-info desktop-file-utils 
hicolor-icon-theme
+Requires(postun): shared-mime-info desktop-file-utils hicolor-icon-theme
 Recommends: %{name}-gtk = %{version}
 Recommends: %{name}-kde4 = %{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -94,6 +96,37 @@
 %suse_update_desktop_file opera-browser
 %fdupes %{buildroot}%{_datadir}
 
+%post
+# update mime and desktop database
+%if 0%{?suse_version}  1130
+%mime_database_post
+%desktop_database_post
+%icon_theme_cache_post
+%else
+if [ -f usr/bin/update-mime-database ] ; then
+  usr/bin/update-mime-database %{_datadir}/mime  /dev/null || :
+fi
+if [ -f usr/bin/update-desktop-database ] ; then
+  usr/bin/update-desktop-database  /dev/null || :
+fi
+%endif
+exit 0
+
+%postun
+%if 0%{?suse_version}  1130
+%icon_theme_cache_postun
+%desktop_database_postun
+%mime_database_postun
+%else
+if [ -f usr/bin/update-mime-database ] ; then
+  usr/bin/update-mime-database %{_datadir}/mime  /dev/null || :
+fi
+if [ -f usr/bin/update-desktop-database ] ; then
+  usr/bin/update-desktop-database  /dev/null || :
+fi
+%endif
+exit 0
+
 %files
 %defattr(-,root,root)
 %doc %{_mandir}/man1/opera*



-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit compiz for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package compiz for openSUSE:Factory checked 
in at 2012-11-18 20:25:21

Comparing /work/SRC/openSUSE:Factory/compiz (Old)
 and  /work/SRC/openSUSE:Factory/.compiz.new (New)


Package is compiz, Maintainer is jzh...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/compiz/compiz.changes2012-06-06 
16:05:59.0 +0200
+++ /work/SRC/openSUSE:Factory/.compiz.new/compiz.changes   2012-11-18 
20:25:22.0 +0100
@@ -1,0 +2,6 @@
+Sat Nov 17 11:36:47 CET 2012 - r...@suse.de
+
+- compiz-kde-4.9.patch:
+  taken from gentoo to fix compilation with kde-4.9 
+
+---

New:

  compiz-kde-4.9.patch



Other differences:
--
++ compiz.spec ++
--- /var/tmp/diff_new_pack.XUlZEQ/_old  2012-11-18 20:25:23.0 +0100
+++ /var/tmp/diff_new_pack.XUlZEQ/_new  2012-11-18 20:25:23.0 +0100
@@ -16,25 +16,24 @@
 #
 
 
-
 Name:   compiz
 Version:0.8.8
-Release:1
-License:HPND and GPL-2.0+
+Release:0
 Url:http://www.compiz.org
-Group:  System/GUI/Other
 PreReq: %fillup_prereq
 %if 0%{suse_version} = 01100
 Enhances:   xgl = git_070104
 %endif
 Summary:OpenGL window and compositing manager
+License:HPND and GPL-2.0+
+Group:  System/GUI/Other
 BuildRequires:  Mesa-devel
 BuildRequires:  freeglut-devel
 BuildRequires:  fuse-devel
 BuildRequires:  gcc-c++
 BuildRequires:  gconf2-devel
-BuildRequires:  libgnome-desktop-2-devel
 BuildRequires:  gtk2-devel
+BuildRequires:  libgnome-desktop-2-devel
 #BuildRequires:gtk-devel
 BuildRequires:  intltool
 %if 0%{suse_version}  01120
@@ -45,14 +44,14 @@
 BuildRequires:  librsvg-devel
 BuildRequires:  libwnck-devel
 %if 0%{suse_version}  01140
-BuildRequires:  libwnck2-devel
 BuildRequires:  dbus-1-glib-devel
+BuildRequires:  libwnck2-devel
 %endif
 BuildRequires:  libxslt-devel
 BuildRequires:  metacity
-BuildRequires:  pkg-config
 BuildRequires:  pango-devel
 BuildRequires:  perl-XML-Parser
+BuildRequires:  pkg-config
 BuildRequires:  update-desktop-files
 BuildRequires:  xorg-x11-devel
 %if %_repository == SUSE_Linux_10.1 || %_repository == SLE_10
@@ -74,8 +73,8 @@
 #
 %if 0%{suse_version} == 01030 || 0%{suse_version}  1120
 BuildRequires:  kde4-kwin
-BuildRequires:  kwin
 BuildRequires:  kdebase4-workspace-devel
+BuildRequires:  kwin
 BuildRequires:  libkde4-devel
 %endif
 #BuildRequires:  libgnome-window-settings-devel
@@ -103,6 +102,8 @@
 Patch6: compiz-unmanaged-window-position.patch
 # PATCH-FIX-UPSTREAM compiz-global_Region_define.patch 
kai-uwe.behrm...@opensuse.org -- Fix compiler irritation about X11 ::Region 
versus KDecorationDefines::Region
 Patch7: compiz-global_Region_define.patch
+# PATCH-FIX-OPENSUSE r...@suse.de -- kde-4.9 buildfix taken from gentoo
+Patch8: compiz-kde-4.9.patch
 Requires:   compiz-branding = %{version}
 Requires:   compiz-decorator = %{version}
 Provides:   windowmanager
@@ -130,8 +131,8 @@
 to run well on most graphics hardware.
 
 %package gnome
-License:GPL-2.0+ and HPND
 Summary:OpenGL window and compositing manager configuration utilities
+License:GPL-2.0+ and HPND
 Group:  System/GUI/GNOME
 Requires:   %name = %version
 Requires:   3ddiag
@@ -161,8 +162,8 @@
 %if 0%want_kde3
 
 %package kde
-License:GPL-2.0+ and HPND
 Summary:OpenGL window and compositing managerdecorator
+License:GPL-2.0+ and HPND
 Group:  System/GUI/KDE
 Requires:   %name = %version
 Provides:   compiz-decorator = %version
@@ -173,8 +174,8 @@
 %endif
 
 %package kde4
-License:HPND and GPL-2.0+ and LGPL-2.1+
 Summary:OpenGL window and compositing managerdecorator for kde4
+License:HPND and GPL-2.0+ and LGPL-2.1+
 Group:  System/GUI/KDE
 Requires:   %name = %version
 %if 0%{suse_version}  1130
@@ -198,8 +199,8 @@
 compositing manager.
 
 %package devel
-License:HPND and GPL-2.0+ and LGPL-2.1+
 Summary:OpenGL window and compositing manager
+License:HPND and GPL-2.0+ and LGPL-2.1+
 Group:  System/GUI/Other
 Requires:   %name = %version
 Requires:   Mesa-devel
@@ -207,6 +208,7 @@
 Requires:   fuse-devel
 Requires:   gcc-c++
 Requires:   gconf2-devel
+Requires:   gnome-control-center-devel
 Requires:   gtk2-devel
 Requires:   intltool
 Requires:   librsvg-devel
@@ -219,7 +221,6 @@
 Requires:   startup-notification-devel
 Requires:   update-desktop-files
 Requires:   xorg-x11-devel
-Requires:   gnome-control-center-devel
 
 %description devel
 Compiz is an OpenGL 

commit erlang for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package erlang for openSUSE:Factory checked 
in at 2012-11-18 20:25:27

Comparing /work/SRC/openSUSE:Factory/erlang (Old)
 and  /work/SRC/openSUSE:Factory/.erlang.new (New)


Package is erlang, Maintainer is cth...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/erlang/erlang.changes2012-10-13 
19:55:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.erlang.new/erlang.changes   2012-11-18 
20:25:35.0 +0100
@@ -2 +2 @@
-Thu Oct 11 11:34:36 UTC 2012 - sasc...@suse.de
+Fri Nov 16 22:51:00 MSK 2012 - matwey.korni...@gmail.com
@@ -4 +4,21 @@
-- Install man-pages into /usr/share/man, not a erlang-private directory
+- directory /usr/share/man/man1 is handled by filesystem package,
+  we don't have to package it twice
+
+---
+Fri Nov  9 11:54:55 UTC 2012 - sasc...@suse.de
+
+- Symlink man-pages for binaries (1) into %_mandir (bnc#788027)
+
+---
+Tue Nov  6 14:00:09 UTC 2012 - sasc...@suse.de
+
+- Use SPDX-style license (ErlPL-1.1)
+- Merge changes from devel:languages:misc/erlang, which is still the 
+  devel project for Factory.
+
+---
+Wed Oct 31 14:55:39 UTC 2012 - sasc...@suse.de
+
+- Set same permissions for the following files (bnc#784670):
+  /usr/lib64/erlang/bin/start_erl
+  /usr/lib64/erlang/erts-5.8.5/bin/start_erl.src
@@ -16 +36 @@
-Wed Jul 25 14:05:47 UTC 2012 - dval...@suse.com
+Thu Sep 27 01:16:22 UTC 2012 - mrueck...@suse.de
@@ -18 +38,5 @@
-- Add erlang-ppc.patch: Fix PPC architecture detection 
+- epmd should not run under the service that needs it first:
+  - add init script to launch epmd under the newly added epmd
+user/group.
+  - added /etc/sysconfig/erlang to configure the port and the
+listening IP
@@ -21 +45 @@
-Fri Jun 29 09:54:00 UTC 2012 - idon...@suse.com
+Mon Sep 10 09:26:31 UTC 2012 - kru...@zib.de
@@ -23,2 +47,28 @@
-- Fix build with OpenDJK7, -target parameter no longer sets 
-  -source so we have to do it manually.
+- require generic java-devel package for all distros (= 1.5.0)
+- fixed javac define for openjdk7
+- enabled parallel build again
+
+---
+Thu Sep  6 09:00:14 UTC 2012 - kru...@zib.de
+
+- update to R15B02 release:
+ + Highlights:
+  * Dialyzer: The type analysis tool Dialyzer is optimized to be
+generally faster. - It can now also run in parallel (default)
+on SMP systems and by this perform the analysis significantly
+faster (Thanks to Stavros Aronis and Kostis Sagonas)
+  * The SSL application now has experimental support for the
+TLS 1.1 and 1.2 standards as well (Thanks to Andreas Schultz).
+  * CommonTest: It is now possible to sort the generated html
+tables. A Netconf client (ct_netconf) which support basic
+netconf over ssh is added
+  * Diameter: Statistics counters related to Diameter messages can
+now be retrieved by calling the diameter:service_info/2 function.
+  * Various smaller optimizations in the Erlang VM
+  * This release also contains 66 contributions from users outside
+the Ericsson team
+
+---
+Wed Jul 25 14:05:47 UTC 2012 - dval...@suse.com
+
+- Add erlang-ppc.patch: Fix PPC architecture detection 
@@ -32,0 +83,44 @@
+Mon Apr 16 16:15:13 UTC 2012 - kru...@zib.de
+
+- updated to R15B01 release:
+ + Highlights from R15B01:
+  * Added erlang:statistics(scheduler_wall_time) to ensure correct
+determination of scheduler utilization. Measuring scheduler
+utilization is strongly preferred over CPU utilization, since
+CPU utilization gives very poor indications of actual
+scheduler/vm usage.
+  * Changed ssh implementation to use the public_key application
+for all public key handling. This is also a first step for
+enabling a callback API for supplying public keys and handling
+keys protected with password phrases. Additionally the test
+suites where improved so that they do not copy the users keys
+to test server directories as this is a security liability.
+Also ipv6 and file access issues found in the process has been
+fixed.
+  * When an escript ends now all printout to standard output and
+standard error gets out on the terminal. This bug has been
+corrected by changing the behaviour of erlang:halt/0,1, which
+should fix the same problem for other escript-like applications,
+i.e. that data stored in the output port driver buffers got
+lost when printing on a TTY and exiting through erlang:halt/0,1.
+The BIF:s erlang:halt/0,1 has gotten improved semantics and
+there is a new BIF erlang:halt/2 to 

commit gsoap for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package gsoap for openSUSE:Factory checked 
in at 2012-11-18 20:25:32

Comparing /work/SRC/openSUSE:Factory/gsoap (Old)
 and  /work/SRC/openSUSE:Factory/.gsoap.new (New)


Package is gsoap, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/gsoap/gsoap.changes  2012-09-04 
12:51:21.0 +0200
+++ /work/SRC/openSUSE:Factory/.gsoap.new/gsoap.changes 2012-11-18 
20:25:45.0 +0100
@@ -1,0 +2,12 @@
+Wed Nov 14 22:36:29 UTC 2012 - jeng...@inai.de
+
+- Update to new upstream release 2.8.11
+* Added soapcpp2 -0 option to remove SOAP bindings when applicable
+* Changed wsdl2h output for the few cases that multiple service
+  bindings are defined, use wsdl2h -Nns for backward compatibility
+- Update to new upstream release 2.8.10
+* Added soapcpp2 -Q option (C++ namespaces)
+* Added wsdl2h -b option (bi-directional operations for duplex services)
+- Removed gsoap-03-initext.diff, merged upstream
+
+---

Old:

  gsoap-03-initext.diff
  gsoap-2.8.10.tar.xz

New:

  gsoap-2.8.11.tar.xz



Other differences:
--
++ gsoap.spec ++
--- /var/tmp/diff_new_pack.jENqNm/_old  2012-11-18 20:25:46.0 +0100
+++ /var/tmp/diff_new_pack.jENqNm/_new  2012-11-18 20:25:46.0 +0100
@@ -21,16 +21,15 @@
 Summary:Toolkit for C/C++ server and client web service applications
 License:SUSE-GPL-2.0+-with-openssl-exception
 Group:  Development/Libraries/C and C++
-Version:2.8.10
+Version:2.8.11
 Release:0
 Url:http://gsoap2.sf.net/
 
-#DL-URL:   http://downloads.sf.net/gsoap2/gsoap_2.8.10.zip
+#DL-URL:   http://downloads.sf.net/gsoap2/gsoap_2.8.11.zip
 Source: gsoap-%version.tar.xz
 Source2:sanitize_source.sh
 Patch1: gsoap-01-sharedlibs.diff
 Patch2: gsoap-02-typepuns.diff
-Patch3: gsoap-03-initext.diff
 Patch4: gsoap-04-strerror.diff
 Patch5: gsoap-05-ipv6.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -111,7 +110,7 @@
 tar -xf %{S:0} --use=xz;
 %setup -DTq
 %endif
-%patch -P 1 -P 2 -P 3 -P 4 -P 5 -p1
+%patch -P 1 -P 2 -P 4 -P 5 -p1
 
 %build
 # Rebuild configure - fix that utterly long mktime test.

++ sanitize_source.sh ++
--- /var/tmp/diff_new_pack.jENqNm/_old  2012-11-18 20:25:46.0 +0100
+++ /var/tmp/diff_new_pack.jENqNm/_new  2012-11-18 20:25:46.0 +0100
@@ -13,7 +13,7 @@
exit 1;
 fi;
 
-version=2.8.10;
+version=2.8.11;
 shortver=2.8; # agh...
 
 rm -Rf gsoap-$shortver gsoap-$version;

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit irc-otr for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package irc-otr for openSUSE:Factory checked 
in at 2012-11-18 20:25:51

Comparing /work/SRC/openSUSE:Factory/irc-otr (Old)
 and  /work/SRC/openSUSE:Factory/.irc-otr.new (New)


Package is irc-otr, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/irc-otr/irc-otr.changes  2012-07-24 
15:02:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.irc-otr.new/irc-otr.changes 2012-11-18 
20:25:53.0 +0100
@@ -1,0 +2,7 @@
+Sun Nov 11 20:01:13 UTC 2012 - andreas.stie...@gmx.de
+
+- The package currently does not build against libotr 4.0.0.
+  For openSUSE Factory, build against older version of the library 
+  be provided by libotr2, [bnc#789175]
+
+---



Other differences:
--
++ irc-otr.spec ++
--- /var/tmp/diff_new_pack.dgbhE4/_old  2012-11-18 20:25:54.0 +0100
+++ /var/tmp/diff_new_pack.dgbhE4/_new  2012-11-18 20:25:54.0 +0100
@@ -28,7 +28,13 @@
 BuildRequires:  gcc-c++
 BuildRequires:  glib2-devel = 2.12
 BuildRequires:  irssi-devel
+# Package does not build against libotr 4.0.0 in factory
+%if 0%{?suse_version}  1220
+BuildRequires:  libotr2-devel = 3.1.0
+BuildConflicts:libotr-devel = 4.0.0
+%else
 BuildRequires:  libotr-devel = 3.1.0
+%endif
 BuildRequires:  pkg-config
 BuildRequires:  python = 2.5
 Source0:irssi-otr-%{version}.tar.bz2

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit nut for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package nut for openSUSE:Factory checked in 
at 2012-11-18 20:26:02

Comparing /work/SRC/openSUSE:Factory/nut (Old)
 and  /work/SRC/openSUSE:Factory/.nut.new (New)


Package is nut, Maintainer is sbra...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/nut/nut.changes  2012-09-05 09:46:15.0 
+0200
+++ /work/SRC/openSUSE:Factory/.nut.new/nut.changes 2012-11-18 
20:26:04.0 +0100
@@ -1,0 +2,7 @@
+Sat Nov 17 09:54:35 UTC 2012 - a...@suse.de
+
+- Fix useradd invocation: -o is useless without -u and newer
+  versions of pwdutils/shadowutils fail on this now.
+- Fix provides/obsoletes
+
+---



Other differences:
--
++ nut.spec ++
--- /var/tmp/diff_new_pack.0XTfH1/_old  2012-11-18 20:26:06.0 +0100
+++ /var/tmp/diff_new_pack.0XTfH1/_new  2012-11-18 20:26:06.0 +0100
@@ -75,9 +75,9 @@
 Requires:   usbutils
 Requires(post): udev
 # for update from openSUSE = 11.3, SLE = 11
-Provides:   nut-classic = %{version}
-Obsoletes:  nut-classic = %{version}
-Obsoletes:  nut-hal = %{version}
+Provides:   nut-classic = %{version}
+Obsoletes:  nut-classic  %{version}
+Obsoletes:  nut-hal  %{version}
 %define apache_serverroot %(%{_sbindir}/apxs2 -q datadir 2/dev/null || 
%{_sbindir}/apxs -q PREFIX)
 %define CGIPATH%{apache_serverroot}/cgi-bin
 %define HTMLPATH   %{apache_serverroot}/htdocs
@@ -259,7 +259,7 @@
 install -m0644 scripts/misc/nut.bash_completion 
$RPM_BUILD_ROOT/etc/bash_completion.d/
 
 %pre
-usr/sbin/useradd -r -o -g %{GROUP} -s /bin/false \
+usr/sbin/useradd -r -g %{GROUP} -s /bin/false \
   -c UPS daemon -d /sbin %{USER} 2/dev/null || :
 
 %post

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit osdlyrics for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package osdlyrics for openSUSE:Factory 
checked in at 2012-11-18 20:26:10

Comparing /work/SRC/openSUSE:Factory/osdlyrics (Old)
 and  /work/SRC/openSUSE:Factory/.osdlyrics.new (New)


Package is osdlyrics, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/osdlyrics/osdlyrics.changes  2012-06-05 
15:33:45.0 +0200
+++ /work/SRC/openSUSE:Factory/.osdlyrics.new/osdlyrics.changes 2012-11-18 
20:26:12.0 +0100
@@ -1,0 +2,5 @@
+Fri Nov 16 19:26:26 UTC 2012 - a...@suse.de
+
+- Fix missing include (add patch patches/osdlyrics-includes.patch).
+
+---

New:

  osdlyrics-includes.patch



Other differences:
--
++ osdlyrics.spec ++
--- /var/tmp/diff_new_pack.rYbrxl/_old  2012-11-18 20:26:12.0 +0100
+++ /var/tmp/diff_new_pack.rYbrxl/_new  2012-11-18 20:26:12.0 +0100
@@ -16,7 +16,6 @@
 #
 
 
-
 Name:   osdlyrics
 Version:0.4.3
 Release:0
@@ -25,6 +24,7 @@
 Group:  Productivity/Multimedia/Sound/Visualization
 Url:http://code.google.com/p/osd-lyrics/
 Source0:
http://osd-lyrics.googlecode.com/files/%{name}-%{version}.tar.gz
+Patch1: osdlyrics-includes.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  autoconf
 BuildRequires:  automake
@@ -47,11 +47,13 @@
 %else
 BuildRequires:  xmms2-devel
 %endif
-Requires:   sqlite3
 Requires:   gtk2
+Requires:   sqlite3
 
 # These package are all in home:hillwood
-Obsoletes:  osd-lyrics osdlyrics-beta osdlyrics-git
+Obsoletes:  osd-lyrics
+Obsoletes:  osdlyrics-beta
+Obsoletes:  osdlyrics-git
 
 %lang_package 
 
@@ -96,6 +98,7 @@
 
 %prep
 %setup -q -n osdlyrics-%{version}
+%patch1 -p1
 
 %build
 %configure --disable-mpd \

++ osdlyrics-includes.patch ++
Index: osdlyrics-0.4.3/src/ol_singleton.c
===
--- osdlyrics-0.4.3.orig/src/ol_singleton.c
+++ osdlyrics-0.4.3/src/ol_singleton.c
@@ -24,6 +24,7 @@
 #include errno.h
 #include sys/stat.h
 #include stdio.h
+#include stdint.h
 #include ol_singleton.h
 #include config.h
 #include ol_debug.h
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rpmlint for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package rpmlint for openSUSE:Factory checked 
in at 2012-11-18 20:26:25

Comparing /work/SRC/openSUSE:Factory/rpmlint (Old)
 and  /work/SRC/openSUSE:Factory/.rpmlint.new (New)


Package is rpmlint, Maintainer is dmuel...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/rpmlint/rpmlint.changes  2012-11-16 
14:21:04.0 +0100
+++ /work/SRC/openSUSE:Factory/.rpmlint.new/rpmlint.changes 2012-11-18 
20:26:27.0 +0100
@@ -1,0 +2,6 @@
+Fri Nov 16 17:51:20 UTC 2012 - asterios.dra...@gmail.com
+
+- Added a patch (python3_magic_number_fix.diff) to update the magic number for
+  python 3 (patch taken from upstream).
+
+---

New:

  python3_magic_number_fix.diff



Other differences:
--
++ rpmlint.spec ++
--- /var/tmp/diff_new_pack.VwbgUq/_old  2012-11-18 20:26:29.0 +0100
+++ /var/tmp/diff_new_pack.VwbgUq/_new  2012-11-18 20:26:29.0 +0100
@@ -116,19 +116,13 @@
 # accepted upstream
 Patch88:suse-speccheck-utf8.diff
 Patch89:suse-python-abi-check.diff
+Patch90:python3_magic_number_fix.diff
 %py_requires
 
 %description
 Rpmlint is a tool to check common errors on rpm packages. Binary and
 source packages can be checked.
 
-
-
-Authors:
-
-Frederic Lepied flep...@mandriva.com
-Gwenole Beauchesne gbeauche...@mandriva.com
-
 %prep
 %setup -q -n rpmlint-%{version} -a1
 %patch0
@@ -195,6 +189,7 @@
 #patch87 -p1
 %patch88
 %patch89
+%patch90
 cp -p %{SOURCE2} .
 # Only move top-level python files 
 chmod 0755 rpmlint-checks-master/*.py

++ python3_magic_number_fix.diff ++
--- FilesCheck.py
+++ FilesCheck.py
@@ -286,7 +286,7 @@
 istext = float(len(t))/len(chunk) = 0.30
 return (chunk, istext)
 
-# See Python/import.c (in the trunk and py3k branches) for a full list of
+# See Python/import.c (in the default and 2.x branches) for a full list of
 # the values here.
 _python_magic_values = {
 '2.2': 60717,
@@ -298,7 +298,7 @@
 '3.0': 3130,
 '3.1': 3150,
 '3.2': 3180,
-'3.3': 3190,
+'3.3': 3230,
 }
 
 def get_expected_pyc_magic(path):

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rubygem-amqp for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package rubygem-amqp for openSUSE:Factory 
checked in at 2012-11-18 20:26:34

Comparing /work/SRC/openSUSE:Factory/rubygem-amqp (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-amqp.new (New)


Package is rubygem-amqp, Maintainer is cth...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-amqp/rubygem-amqp.changes
2012-07-16 09:38:33.0 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-amqp.new/rubygem-amqp.changes   
2012-11-18 20:26:38.0 +0100
@@ -1,0 +2,13 @@
+Wed Nov  7 08:27:14 UTC 2012 - cfarr...@suse.com
+
+- license update: BSD-2-Clause or Ruby
+  Package claims to be under the same license as Ruby and even points to
+  the URL for the Ruby license. In the past couple of months the license of
+  Ruby changed from GPL-2.0 or Ruby to BSD-2-Clause or Ruby
+
+---
+Sun Oct 28 05:52:28 UTC 2012 - co...@suse.com
+
+- updated to version 0.9.8, basically rewritten - see CHANGELOG
+
+---

Old:

  amqp-0.6.7.gem

New:

  amqp-0.9.8.gem



Other differences:
--
++ rubygem-amqp.spec ++
--- /var/tmp/diff_new_pack.kmEgOW/_old  2012-11-18 20:26:39.0 +0100
+++ /var/tmp/diff_new_pack.kmEgOW/_new  2012-11-18 20:26:39.0 +0100
@@ -17,41 +17,64 @@
 
 
 Name:   rubygem-amqp
-Version:0.6.7
+Version:0.9.8
 Release:0
 %define mod_name amqp
-#
-#
-Provides:   rubygem-%{mod_name}-0_6 = %{version}
+%define mod_full_name %{mod_name}-%{version}
+
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  rubygems_with_buildroot_patch
-%rubygems_requires
-BuildRequires:  rubygem-eventmachine = 0.12.4
-Requires:   rubygem-eventmachine = 0.12.4
-#
-Url:http://amqp.rubyforge.org/
-Source: %{mod_name}-%{version}.gem
-#
-Summary:AMQP client implementation in Ruby/EventMachine
-License:GPL-2.0+ or Ruby
+BuildRequires:  ruby-macros = 1
+BuildRequires:  rubygem(rdoc)  3.10
+Url:http://github.com/ruby-amqp/amqp
+Source: %{mod_full_name}.gem
+Summary:Widely used, feature-rich asynchronous AMQP 0.9.1 client with
+License:BSD-2-Clause or Ruby
 Group:  Development/Languages/Ruby
 
 %description
-An implementation of the AMQP protocol in Ruby/EventMachine for writing 
clients to the RabbitMQ message broker
+Widely used, feature-rich asynchronous AMQP 0.9.1 client with batteries
+included.
+
+%package doc
+Summary:RDoc documentation for %{mod_name}
+Group:  Development/Languages/Ruby
+Requires:   %{name} = %{version}
+
+%description doc
+Documentation generated at gem installation time.
+Usually in RDoc and RI formats.
+
+%package testsuite
+Summary:Test suite for %{mod_name}
+Group:  Development/Languages/Ruby
+Requires:   %{name} = %{version}
+
+%description testsuite
+Test::Unit or RSpec files, useful for developers.
 
 %prep
+#gem_unpack
+#if you need patches, apply them here and replace the # with a % sign in the 
surrounding lines
+#gem_build
+
 %build
-%install
-%gem_install %{S:0}
 
-%clean
-%{__rm} -rf %{buildroot}
+%install
+%gem_install -f
 
 %files
 %defattr(-,root,root,-)
-%{_libdir}/ruby/gems/%{rb_ver}/cache/%{mod_name}-%{version}.gem
-%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_name}-%{version}/
-%{_libdir}/ruby/gems/%{rb_ver}/specifications/%{mod_name}-%{version}.gemspec
-%doc %{_libdir}/ruby/gems/%{rb_ver}/doc/%{mod_name}-%{version}/
+%{_libdir}/ruby/gems/%{rb_ver}/cache/%{mod_full_name}.gem
+%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/
+%exclude %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/spec
+%{_libdir}/ruby/gems/%{rb_ver}/specifications/%{mod_full_name}.gemspec
+
+%files doc
+%defattr(-,root,root,-)
+%doc %{_libdir}/ruby/gems/%{rb_ver}/doc/%{mod_full_name}/
+
+%files testsuite
+%defattr(-,root,root,-)
+%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/spec
 
 %changelog

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit spice for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package spice for openSUSE:Factory checked 
in at 2012-11-18 20:26:55

Comparing /work/SRC/openSUSE:Factory/spice (Old)
 and  /work/SRC/openSUSE:Factory/.spice.new (New)


Package is spice, Maintainer is posta...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/spice/spice.changes  2012-04-12 
09:52:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.spice.new/spice.changes 2012-11-18 
20:26:56.0 +0100
@@ -1,0 +2,5 @@
+Sat Nov 17 08:05:49 UTC 2012 - a...@suse.de
+
+- Fix build with glibc 2.17 (add patch spice-glibc217.patch).
+
+---

New:

  spice-glibc217.patch



Other differences:
--
++ spice.spec ++
--- /var/tmp/diff_new_pack.TXmNNZ/_old  2012-11-18 20:26:57.0 +0100
+++ /var/tmp/diff_new_pack.TXmNNZ/_new  2012-11-18 20:26:57.0 +0100
@@ -47,6 +47,7 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source: %{realname}-%{realver}%{?extraver}.%{srcext}
 Patch0: spice-gcc47.patch
+Patch1: spice-glibc217.patch
 ExclusiveArch:  %ix86 x86_64
 
 %description
@@ -101,6 +102,7 @@
 %prep
 %setup -q -n %{realname}-%{realver}%{?extraver}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %configure \

++ spice-glibc217.patch ++
Index: spice-0.10.1/common/backtrace.c
===
--- spice-0.10.1.orig/common/backtrace.c
+++ spice-0.10.1/common/backtrace.c
@@ -75,7 +75,8 @@ static int spice_backtrace_gstack(void)
 /* CHILD */
 char parent[16];
 
-seteuid(0);
+if (seteuid(0)  1)
+ exit(1);
 close(STDIN_FILENO);
 close(STDOUT_FILENO);
 dup2(pipefd[1],STDOUT_FILENO);
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit squid for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package squid for openSUSE:Factory checked 
in at 2012-11-18 20:27:02

Comparing /work/SRC/openSUSE:Factory/squid (Old)
 and  /work/SRC/openSUSE:Factory/.squid.new (New)


Package is squid, Maintainer is dr...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/squid/squid.changes  2012-10-24 
10:24:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.squid.new/squid.changes 2012-11-18 
20:27:04.0 +0100
@@ -1,0 +2,5 @@
+Sat Nov 17 09:38:19 UTC 2012 - a...@suse.de
+
+- Fix build with glibc 2.17 (add patch squid-glibc217.patch).
+
+---

New:

  squid-glibc217.patch



Other differences:
--
++ squid.spec ++
--- /var/tmp/diff_new_pack.O0Zsfx/_old  2012-11-18 20:27:05.0 +0100
+++ /var/tmp/diff_new_pack.O0Zsfx/_new  2012-11-18 20:27:05.0 +0100
@@ -60,7 +60,8 @@
 ## File is compiled without RPM_OPT_FLAGS
 # squid3 no-rpm-opt-flags cmdline:./cf_gen.cc
 Patch102:   %{name}-compiled_without_RPM_OPT_FLAGS.patch
-
+# Handle setuid/setgid failure
+Patch103:   squid-glibc217.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 PreReq: %fillup_prereq
 PreReq: %insserv_prereq
@@ -149,6 +150,7 @@
 chmod a-x CREDITS
 %patch101
 %patch102
+%patch103 -p1
 
 %build
 export CFLAGS=%{optflags} -fPIE -fPIC -DOPENSSL_LOAD_CONF

++ squid-glibc217.patch ++
Index: squid-3.2.3/src/icmp/pinger.cc
===
--- squid-3.2.3.orig/src/icmp/pinger.cc
+++ squid-3.2.3/src/icmp/pinger.cc
@@ -180,8 +180,18 @@ main(int argc, char *argv[])
 }
 max_fd = max(max_fd, squid_link);
 
-setgid(getgid());
-setuid(getuid());
+if (setgid(getgid())  0) {
+debugs(42, 0, FATAL: pinger: setgid failed.);
+icmp4.Close();
+icmp6.Close();
+   exit (1);
+}
+if (setuid(getuid())  0) {
+debugs(42, 0, FATAL: pinger: setuid failed.);
+icmp4.Close();
+icmp6.Close();
+exit (1);
+}
 
 last_check_time = squid_curtime;
 
Index: squid-3.2.3/src/tools.cc
===
--- squid-3.2.3.orig/src/tools.cc
+++ squid-3.2.3/src/tools.cc
@@ -757,7 +757,8 @@ enter_suid(void)
 debugs(21, 3, enter_suid: PID   getpid()   taking root priveleges);
 #if HAVE_SETRESUID
 
-setresuid((uid_t)-1, 0, (uid_t)-1);
+if (setresuid((uid_t)-1, 0, (uid_t)-1)  0)
+   debugs (21, 3, enter_suid: setresuid failed  xstrerror ());
 #else
 
 setuid(0);
@@ -782,7 +783,8 @@ no_suid(void)
 uid = geteuid();
 debugs(21, 3, no_suid: PID   getpid()   giving up root priveleges 
forever);
 
-setuid(0);
+if (setuid(0)  0)
+   debugs(50, 1, no_suid: setuid (0):   xstrerror());
 
 if (setuid(uid)  0)
 debugs(50, 1, no_suid: setuid:   xstrerror());
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit strongswan for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package strongswan for openSUSE:Factory 
checked in at 2012-11-18 20:27:10

Comparing /work/SRC/openSUSE:Factory/strongswan (Old)
 and  /work/SRC/openSUSE:Factory/.strongswan.new (New)


Package is strongswan, Maintainer is m...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/strongswan/strongswan.changes2012-11-08 
21:54:07.0 +0100
+++ /work/SRC/openSUSE:Factory/.strongswan.new/strongswan.changes   
2012-11-18 20:27:11.0 +0100
@@ -1,0 +2,5 @@
+Fri Nov 16 04:02:32 UTC 2012 - crrodrig...@opensuse.org
+
+- Fix systemd unit dir 
+
+---



Other differences:
--
++ strongswan.spec ++
--- /var/tmp/diff_new_pack.mF6RXb/_old  2012-11-18 20:27:12.0 +0100
+++ /var/tmp/diff_new_pack.mF6RXb/_new  2012-11-18 20:27:12.0 +0100
@@ -411,7 +411,7 @@
 %dir %{_sysconfdir}/ipsec.d/ocspcerts
 %dir %attr(700,root,root) %{_sysconfdir}/ipsec.d/private
 %if %{with systemd}
-/lib/systemd/system/strongswan.service
+%{_unitdir}/strongswan.service
 %else
 %config %{_sysconfdir}/init.d/ipsec
 %{_sbindir}/rcipsec


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit syslog-ng for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package syslog-ng for openSUSE:Factory 
checked in at 2012-11-18 20:27:20

Comparing /work/SRC/openSUSE:Factory/syslog-ng (Old)
 and  /work/SRC/openSUSE:Factory/.syslog-ng.new (New)


Package is syslog-ng, Maintainer is m...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/syslog-ng/syslog-ng.changes  2012-10-26 
17:33:41.0 +0200
+++ /work/SRC/openSUSE:Factory/.syslog-ng.new/syslog-ng.changes 2012-11-18 
20:27:24.0 +0100
@@ -1,0 +2,40 @@
+Mon Nov 12 17:30:32 UTC 2012 - m...@suse.com
+
+- Fixed build requires / deps to work on 12.x and SLE-11-SP2.
+- Initialized SYSLOG_NG_PARAMS env variable in service file.
+- Marked additional log sockets file as ghost.
+
+---
+Mon Nov 12 10:33:15 UTC 2012 - m...@suse.com
+
+- Added syslog-ng.service and prepare script to spec file sources.
+
+---
+Fri Nov  9 17:09:24 UTC 2012 - m...@suse.com
+
+- Changed to provide a specific syslog-ng.service file which
+  creates an alias to syslog.service while activation instead
+  of using a SYSLOG_DAEMON to choose the syslog daemon.
+  A short pre-exec script is used to generate the additional
+  (chroot) log socket config (bnc#788330).
+- Updated syslog provides/requires and added a conflict with
+  otherproviders(syslog).
+- Dropped all ifdef-s and cleaned up to specify all relevant
+  directories via rpm macros.
+- Changed to install in /usr/sbin, compatibility link in /sbin.
+
+---
+Tue Nov  6 17:06:14 CET 2012 - cza...@balabit.hu
+
+- remove ifdef-s related to 11.X support except for systemd
+  (so SLES support could be fixed)
+- remove no more used parts from spec
+- remove syslog-ng.rc-script from sources
+
+---
+Tue Oct 31 12:18:36 CET 2012 - cza...@balabit.hu
+
+- update to 3.3.7 release
+- some last minute bugfixes
+
+---

Old:

  syslog-ng.rc-script
  syslog-ng_3.3.6.91.tar.gz

New:

  syslog-ng-service-prepare
  syslog-ng.service
  syslog-ng_3.3.7.tar.gz



Other differences:
--
++ syslog-ng.spec ++
 636 lines (skipped)
 between /work/SRC/openSUSE:Factory/syslog-ng/syslog-ng.spec
 and /work/SRC/openSUSE:Factory/.syslog-ng.new/syslog-ng.spec

++ syslog-ng-service-prepare ++
#!/bin/sh

test -s /etc/sysconfig/syslog  \
  . /etc/sysconfig/syslog

run_dir=RUN_DIR
cfg_file=ADDITIONAL_SOCKETS

umask 0022
/bin/mkdir -p -m 0755 ${run_dir}

#
# Prepare include with sockets in chroot's
#
echo 'source chroots {'  ${cfg_file}
for variable in ${!SYSLOGD_ADDITIONAL_SOCKET*}; do
eval value=\$$variable
test -z $value  continue
test -d ${value%/*} || continue
echo unix-dgram(\$value\);
done  ${cfg_file}
echo '};'  ${cfg_file}

#
# make sure xconsole exists and is a pipe
#
if test -e /dev/xconsole -a ! -p /dev/xconsole ; then
/bin/rm -f /dev/xconsole
fi
if test ! -e /dev/xconsole ; then
/bin/mknod -m 0600  /dev/xconsole p
/bin/chown root:tty /dev/xconsole
fi

exit 0

++ syslog-ng.conf.default ++
--- /var/tmp/diff_new_pack.jTrD4u/_old  2012-11-18 20:27:25.0 +0100
+++ /var/tmp/diff_new_pack.jTrD4u/_new  2012-11-18 20:27:25.0 +0100
@@ -48,7 +48,7 @@
#udp(ip(0.0.0.0) port(514));
 };
 
-include /var/run/syslog-ng/additional-log-sockets.conf;
+include ADDITIONAL_SOCKETS;
 
 #
 # Filter definitions

++ syslog-ng.service ++
[Unit]
Description=System Logging Service
Requires=var-run.mount
Requires=syslog.target
After=var-run.mount
Before=syslog.target
Conflicts=rsyslog.service syslogd.service

[Service]
Environment=SYSLOG_NG_PARAMS=
ExecStartPre=@sbindir@/syslog-ng-service-prepare
EnvironmentFile=-/etc/sysconfig/syslog
ExecStart=@sbindir@/syslog-ng -F $SYSLOG_NG_PARAMS
ExecReload=/bin/kill -HUP $MAINPID
Sockets=syslog.socket
StandardOutput=null

[Install]
WantedBy=multi-user.target
Alias=syslog.service
++ syslog-ng_3.3.6.91.tar.gz - syslog-ng_3.3.7.tar.gz ++
 87566 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit whohas for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package whohas for openSUSE:Factory checked 
in at 2012-11-18 20:27:43

Comparing /work/SRC/openSUSE:Factory/whohas (Old)
 and  /work/SRC/openSUSE:Factory/.whohas.new (New)


Package is whohas, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/whohas/whohas.changes2012-02-07 
14:47:05.0 +0100
+++ /work/SRC/openSUSE:Factory/.whohas.new/whohas.changes   2012-11-18 
20:27:45.0 +0100
@@ -1,0 +2,23 @@
+Thu Nov 15 19:11:52 UTC 2012 - asterios.dra...@gmail.com
+
+- Replaced the following patches:
+  * debian-versions-511364.patch with debian-versions.patch (updated the fix to
+correctly show all Debian versions - taken from Debian).
+  * opensuse-searchpath-585596.patch with opensuse.patch (updated the fix to
+make it work with http://software.opensuse.org/search).
+  * ubuntu-versions-510203.patch with ubuntu-versions.patch (updated the fix to
+correctly show all Ubuntu versions - taken from Debian).
+- Updated the following patches (taken from Debian):
+  * help-param-513476.patch (added patch description).
+  * manpage-0.24.patch (added patch description).
+  * strictness-510020-510524.patch (added patch description, update man pages).
+- Renamed and Rebased the following patches (taken from Debian):
+  * fedora-search-619873 with fedora-search-619873.patch
+  * openbsd-cache-results-557724 with openbsd-cache-results-557724.patch
+- Rebased the following patches (taken from Debian):
+  * archlinux-url-561536.patch.
+  * dont-mask-vars-560891.patch.
+  * gentoo-result-url-516071.patch.
+  * improve-fetchdoc.patch.
+
+---

Old:

  debian-versions-511364.patch
  fedora-search-619873
  openbsd-cache-results-557724
  opensuse-searchpath-585596.patch
  ubuntu-versions-510203.patch

New:

  debian-versions.patch
  fedora-search-619873.patch
  openbsd-cache-results-557724.patch
  opensuse.patch
  ubuntu-versions.patch



Other differences:
--
++ whohas.spec ++
--- /var/tmp/diff_new_pack.eEvQdb/_old  2012-11-18 20:27:46.0 +0100
+++ /var/tmp/diff_new_pack.eEvQdb/_new  2012-11-18 20:27:46.0 +0100
@@ -17,6 +17,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   whohas
 Version:0.29
 Release:0
@@ -31,10 +32,10 @@
 Patch1: manpage-0.23.patch
 # PATCH-FIX-UPSTREAM manpage-0.24.patch asterios.dra...@gmail.com -- Update 
the version number in the manual from 0.23 to 0.24
 Patch2: manpage-0.24.patch
-# PATCH-FIX-UPSTREAM ubuntu-versions-510203.patch deb#510203 
asterios.dra...@gmail.com -- Show all versions of a package from Ubuntu, not 
just the earliest
-Patch3: ubuntu-versions-510203.patch
-# PATCH-FIX-UPSTREAM debian-versions-511364.patch deb#511364 
asterios.dra...@gmail.com -- Providing output for all Debian distributions
-Patch4: debian-versions-511364.patch
+# PATCH-FIX-UPSTREAM ubuntu-versions.patch deb#670675 
asterios.dra...@gmail.com -- Show all versions of a package from Ubuntu, not 
just the earliest
+Patch3: ubuntu-versions.patch
+# PATCH-FIX-UPSTREAM debian-versions.patch deb#655497 
asterios.dra...@gmail.com -- Providing output for all Debian distributions
+Patch4: debian-versions.patch
 # PATCH-FIX-UPSTREAM help-param-513476.patch deb#513476 
asterios.dra...@gmail.com -- Handle the --help parameter instead of assuming it 
is a package name
 Patch5: help-param-513476.patch
 # PATCH-FIX-UPSTREAM strictness-510020-510524.patch deb#510020 deb#510524 
asterios.dra...@gmail.com -- Add a --strict option to output only exactly 
matching package names
@@ -43,21 +44,21 @@
 Patch7: gentoo-result-url-516071.patch
 # PATCH-FIX-OPENSUSE improve-fetchdoc.patch asterios.dra...@gmail.com -- Shift 
some of the burden in sub fetchdoc onto the LWP::UserAgent class. This also 
allows us to process XML files without breaking the first line
 Patch8: improve-fetchdoc.patch
-# PATCH-FIX-UPSTREAM openbsd-cache-results-557724 deb#557724 
asterios.dra...@gmail.com -- For OpenBSD, use @name to loop through a cached 
list, not @repos which is never populated
-Patch9: openbsd-cache-results-557724
+# PATCH-FIX-UPSTREAM openbsd-cache-results-557724.patch deb#557724 
asterios.dra...@gmail.com -- For OpenBSD, use @name to loop through a cached 
list, not @repos which is never populated
+Patch9: openbsd-cache-results-557724.patch
 # PATCH-FIX-UPSTREAM dont-mask-vars-560891.patch deb#560891 
asterios.dra...@gmail.com -- Remove a double-declaration of @dates
 Patch10:dont-mask-vars-560891.patch
-# PATCH-FIX-OPENSUSE opensuse-searchpath-585596.patch deb#585596 

commit kdelibs4 for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package kdelibs4 for openSUSE:Factory 
checked in at 2012-11-18 20:30:05

Comparing /work/SRC/openSUSE:Factory/kdelibs4 (Old)
 and  /work/SRC/openSUSE:Factory/.kdelibs4.new (New)


Package is kdelibs4, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/kdelibs4/kdelibs4.changes2012-11-08 
07:43:26.0 +0100
+++ /work/SRC/openSUSE:Factory/.kdelibs4.new/kdelibs4.changes   2012-11-18 
20:30:07.0 +0100
@@ -1,0 +2,6 @@
+Sun Nov 18 16:52:05 UTC 2012 - hrvoje.sen...@gmail.com
+
+- Explicitly require pkgconfig(bzip2) for 12.3
+- Recommend media-player-info for kde#269447, kde#269451
+
+---



Other differences:
--
++ kdelibs4.spec ++
--- /var/tmp/diff_new_pack.a8p4im/_old  2012-11-18 20:30:09.0 +0100
+++ /var/tmp/diff_new_pack.a8p4im/_new  2012-11-18 20:30:09.0 +0100
@@ -68,6 +68,7 @@
 BuildRequires:  strigi-devel
 BuildRequires:  unzip
 BuildRequires:  update-desktop-files
+BuildRequires:  pkgconfig(bzip2)
 %if 0%{?suse_version}  1130
 BuildRequires:  utempter-devel
 %else
@@ -121,6 +122,7 @@
 PreReq: permissions
 Requires:   soprano = %( echo `rpm -q --queryformat '%{VERSION}' 
libsoprano-devel`)
 Recommends: strigi = %( echo `rpm -q --queryformat '%{VERSION}' 
strigi-devel`)
+Recommends: media-player-info
 Requires:   kdelibs4-core = %{version}
 Requires:   libkde4 = %{version}
 %if %{suse_version}  1220



-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libevent for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package libevent for openSUSE:Factory 
checked in at 2012-11-18 20:30:16

Comparing /work/SRC/openSUSE:Factory/libevent (Old)
 and  /work/SRC/openSUSE:Factory/.libevent.new (New)


Package is libevent, Maintainer is meiss...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/libevent/libevent.changes2012-08-04 
09:20:52.0 +0200
+++ /work/SRC/openSUSE:Factory/.libevent.new/libevent.changes   2012-11-18 
20:30:18.0 +0100
@@ -1,0 +2,13 @@
+Fri Nov 16 21:24:42 UTC 2012 - andreas.stie...@gmx.de
+
+- update to 2.0.20
+  * core: Make event_pending() threadsafe
+  * evhttp: Fix a memory leak on error in evhttp_uriencode
+  * evbuffer: Avoid possible needless call to writev
+  * evdns: memset sockaddr_in before using it
+  * evhttp: Check more setsockopt return values when binding sockets
+  * evdns: Avoid segfault on weird timeout during name lookup
+  * bufferevent_ssl: Correctly invoke callbacks when a SSL
+bufferevent reads some and then blocks
+
+---

Old:

  libevent-2.0.19-stable.tar.gz

New:

  libevent-2.0.20-stable.tar.gz



Other differences:
--
++ libevent.spec ++
--- /var/tmp/diff_new_pack.PlXZjH/_old  2012-11-18 20:30:19.0 +0100
+++ /var/tmp/diff_new_pack.PlXZjH/_new  2012-11-18 20:30:19.0 +0100
@@ -19,13 +19,13 @@
 Name:   libevent
 %define libsoname %{name}-2_0-5
 
-Version:2.0.19
+Version:2.0.20
 Release:0
 Summary:Library Providing an Event Handling API
 License:BSD-3-Clause
 Group:  Development/Libraries/C and C++
-Url:http://monkey.org/~provos/libevent/
-Source0:
http://cloud.github.com/downloads/libevent/libevent/%{name}-%{version}-stable.tar.gz
+Url:http://libevent.org/
+Source0:
https://github.com/downloads/libevent/libevent/%{name}-%{version}-stable.tar.gz
 Source1:baselibs.conf 
 BuildRequires:  openssl-devel
 BuildRequires:  pkgconfig

++ libevent-2.0.19-stable.tar.gz - libevent-2.0.20-stable.tar.gz ++
 2025 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/libevent-2.0.19-stable/ChangeLog new/libevent-2.0.20-stable/ChangeLog
--- old/libevent-2.0.19-stable/ChangeLog2012-05-03 18:26:20.0 
+0200
+++ new/libevent-2.0.20-stable/ChangeLog2012-08-23 18:40:49.0 
+0200
@@ -1,3 +1,39 @@
+Changes in version 2.0.20-stable (?? Aug 2012)
+BUGFIXES:
+ o core: Make event_pending() threadsafe. (be7a95c Simon Liu)
+ o win32: avoid crash when waiting forever on zero fds. (160e58b)
+ o evhttp: Fix a memory leak on error in evhttp_uriencode (11c8b31)
+ o evbuffer: Avoid possible needless call to writev. Found by coverity. 
(6a4ec5c)
+ o evdns: memset sockaddr_in before using it. Found by coverity. (a1a0e67)
+ o evhttp: Check more setsockopt return values when binding sockets. Found by 
coverity (a0912e3)
+ o evdns: Avoid segfault on weird timeout during name lookup. (dc32077 Greg 
Hazel)
+ o bufferevent_ssl: Correctly invoke callbacks when a SSL bufferevent reads 
some and then blocks. (606ac43)
+
+
+PORTABILITY FIXES:
+ o check for arc4random_buf at runtime, on OS X (bff5f94 Greg Hazel)
+ o Correctly check for arc4random_buf (fcec3e8 Sebastian Hahn)
+ o Add explicit AC_PROG_SED to configure.in so all autoconfs will expose 
$(SED) (ca80ea6)
+
+BUILD FIXES:
+ o Add GCC annotations so that the vsprintf functions get checked properly 
(117e327)
+ o Fix an unused variable warning on *BSD. (c0720c1)
+
+UNIT TEST FIXES:
+ o Fix a couple of memory leaks (found with Valgrind). (3b2529a Ross Lagerwall)
+ o Remove deadcode in http regression tests. Found by coverity. (5553346)
+ o Fix possible uninitialized read in dns regression tests. Found by coverity. 
(2259777)
+ o Set umask before calling mkstemp in unit tests. Found by coverity (f1ce15d)
+ o Fix various check-after-dereference issues in unit tests: found by coverity 
(4f3732d)
+ o Fix resource leaks in the unit tests; found by coverity (270f279)
+ o Add some missing null checks to unit tests; found by coverity (f021c3d)
+ o Avoid more crashes/bad calls in unit tests; found by coverity (3cde5bf)
+ o Remove unused variable; spotted by coverity (6355b2a)
+ o Add checks to various return values in unit tests. Found by coverity 
(b9e7329)
+ o Move assignment outside tt_assert in ssl 

commit pulseaudio for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package pulseaudio for openSUSE:Factory 
checked in at 2012-11-18 20:30:28

Comparing /work/SRC/openSUSE:Factory/pulseaudio (Old)
 and  /work/SRC/openSUSE:Factory/.pulseaudio.new (New)


Package is pulseaudio, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/pulseaudio/pulseaudio.changes2012-11-17 
07:27:12.0 +0100
+++ /work/SRC/openSUSE:Factory/.pulseaudio.new/pulseaudio.changes   
2012-11-18 20:30:30.0 +0100
@@ -1,0 +2,5 @@
+Sat Nov 17 02:01:24 UTC 2012 - crrodrig...@opensuse.org
+
+- disable all HAL compat/support since it is long gone. 
+
+---



Other differences:
--
++ pulseaudio.spec ++
--- /var/tmp/diff_new_pack.HQIX0E/_old  2012-11-18 20:30:31.0 +0100
+++ /var/tmp/diff_new_pack.HQIX0E/_new  2012-11-18 20:30:31.0 +0100
@@ -265,7 +265,7 @@
 %patch2
 
 %build
-autoreconf
+autoreconf -fiv
 export CFLAGS=%{optflags} -fno-strict-aliasing
 # libpulse and libpulsecommon need each other - no way with as-needed
 export SUSE_ASNEEDED=0
@@ -277,6 +277,7 @@
 --with-system-group=pulse \
 --with-access-group=pulse-access \
 --disable-hal \
+   --disable-hal-compat \
--with-udev-rules-dir=%{_udevrulesdir}
 make %{?_smp_mflags} V=1
 make doxygen
@@ -382,7 +383,6 @@
 %{_libdir}/pulse-%{drvver}/modules/module-equalizer-sink.so
 %{_libdir}/pulse-%{drvver}/modules/module-filter-apply.so
 %{_libdir}/pulse-%{drvver}/modules/module-filter-heuristics.so
-%{_libdir}/pulse-%{drvver}/modules/module-hal-detect.so
 %{_libdir}/pulse-%{drvver}/modules/module-http-protocol-tcp.so
 %{_libdir}/pulse-%{drvver}/modules/module-http-protocol-unix.so
 %{_libdir}/pulse-%{drvver}/modules/module-intended-roles.so


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-Sphinx for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package python-Sphinx for openSUSE:Factory 
checked in at 2012-11-18 21:38:25

Comparing /work/SRC/openSUSE:Factory/python-Sphinx (Old)
 and  /work/SRC/openSUSE:Factory/.python-Sphinx.new (New)


Package is python-Sphinx, Maintainer is cth...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/python-Sphinx/python-Sphinx.changes  
2012-11-13 09:43:18.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-Sphinx.new/python-Sphinx.changes 
2012-11-18 21:38:25.0 +0100
@@ -1,0 +2,5 @@
+Thu Nov 15 05:29:16 UTC 2012 - sasc...@suse.de
+
+- Revert last locale change, it was a false positive 
+
+---



Other differences:
--
++ python-Sphinx.spec ++
--- /var/tmp/diff_new_pack.9JbFd6/_old  2012-11-18 21:38:27.0 +0100
+++ /var/tmp/diff_new_pack.9JbFd6/_new  2012-11-18 21:38:27.0 +0100
@@ -89,7 +89,6 @@
 %doc AUTHORS CHANGES LICENSE README TODO
 %{_bindir}/sphinx-*
 %{python_sitelib}/*
-%exclude %{python_sitelib}/sphinx/locale/
 
 %files doc
 %defattr(-,root,root,-)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit accountsservice for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package accountsservice for openSUSE:Factory 
checked in at 2012-11-19 07:01:31

Comparing /work/SRC/openSUSE:Factory/accountsservice (Old)
 and  /work/SRC/openSUSE:Factory/.accountsservice.new (New)


Package is accountsservice, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/accountsservice/accountsservice.changes  
2012-11-12 12:30:29.0 +0100
+++ /work/SRC/openSUSE:Factory/.accountsservice.new/accountsservice.changes 
2012-11-19 07:01:32.0 +0100
@@ -1,0 +2,10 @@
+Wed Nov 14 13:08:48 UTC 2012 - dims...@opensuse.org
+
+- Update to version 0.6.26:
+  + Require libsystemd-login 186.
+  + Protect against deleting root user.
+  + Add LoginTime and LoginHistory properties.
+  + Fix crash consolekit code.
+  + Fix has_multiple_user property after removing user.
+
+---

Old:

  accountsservice-0.6.25.tar.xz

New:

  accountsservice-0.6.26.tar.xz



Other differences:
--
++ accountsservice.spec ++
--- /var/tmp/diff_new_pack.4hCUDA/_old  2012-11-19 07:01:35.0 +0100
+++ /var/tmp/diff_new_pack.4hCUDA/_new  2012-11-19 07:01:35.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   accountsservice
-Version:0.6.25
+Version:0.6.26
 Release:0
 Summary:D-Bus Service to Manipulate User Account Information
 License:GPL-3.0+
@@ -37,7 +37,7 @@
 BuildRequires:  vala
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(libsystemd-daemon)
-BuildRequires:  pkgconfig(libsystemd-login) = 43
+BuildRequires:  pkgconfig(libsystemd-login) = 186
 BuildRequires:  pkgconfig(polkit-gobject-1)
 BuildRequires:  pkgconfig(systemd)
 Recommends: %{name}-lang

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit anjuta for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package anjuta for openSUSE:Factory checked 
in at 2012-11-19 07:01:55

Comparing /work/SRC/openSUSE:Factory/anjuta (Old)
 and  /work/SRC/openSUSE:Factory/.anjuta.new (New)


Package is anjuta, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/anjuta/anjuta.changes2012-10-22 
21:44:36.0 +0200
+++ /work/SRC/openSUSE:Factory/.anjuta.new/anjuta.changes   2012-11-19 
07:01:57.0 +0100
@@ -1,0 +2,14 @@
+Tue Nov 13 12:56:20 UTC 2012 - dims...@opensuse.org
+
+- Update to version 3.6.2:
+  + indentation-c-style:
+- be more picky when completing braces.
+- remove java_indentation() method
+- When removing opening bracket also remove the closing one.
+  + sourceview: don't emit change events after doing an undo
+  + build-basic-autotools:
+- Configuration name combo box should be editable
+  + Do not use GDL members deprecated in version 3.6
+  + Updated translations.
+
+---

Old:

  anjuta-3.6.1.tar.xz

New:

  anjuta-3.6.2.tar.xz



Other differences:
--
++ anjuta.spec ++
--- /var/tmp/diff_new_pack.2xM8Bw/_old  2012-11-19 07:01:58.0 +0100
+++ /var/tmp/diff_new_pack.2xM8Bw/_new  2012-11-19 07:01:58.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   anjuta
-Version:3.6.1
+Version:3.6.2
 Release:0
 Summary:Versatile Integrated Development Environment for GNOME
 License:GPL-2.0+
@@ -49,7 +49,7 @@
 BuildRequires:  valgrind-devel
 %endif
 BuildRequires:  pkgconfig(gdk-pixbuf-2.0) = 2.0.0
-BuildRequires:  pkgconfig(gdl-3.0) = 3.5.4
+BuildRequires:  pkgconfig(gdl-3.0) = 3.5.5
 BuildRequires:  pkgconfig(gladeui-2.0) = 3.12.0
 BuildRequires:  pkgconfig(glib-2.0) = 2.32.0
 BuildRequires:  pkgconfig(gtk+-3.0) = 3.4.0

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit balsa for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package balsa for openSUSE:Factory checked 
in at 2012-11-19 07:02:27

Comparing /work/SRC/openSUSE:Factory/balsa (Old)
 and  /work/SRC/openSUSE:Factory/.balsa.new (New)


Package is balsa, Maintainer is sbra...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/balsa/balsa.changes  2012-05-22 
08:12:20.0 +0200
+++ /work/SRC/openSUSE:Factory/.balsa.new/balsa.changes 2012-11-19 
07:02:29.0 +0100
@@ -1,0 +2,8 @@
+Wed Oct 31 12:06:57 UTC 2012 - dims...@opensuse.org
+
+- Update to version 2.4.13:
+  + Fix long-line POP3 bug.
+  + Bugs fixed: bgo#684124.
+  + Updated translations.
+
+---

Old:

  balsa-2.4.12.tar.bz2

New:

  balsa-2.4.13.tar.bz2



Other differences:
--
++ balsa.spec ++
--- /var/tmp/diff_new_pack.FA57ZL/_old  2012-11-19 07:02:31.0 +0100
+++ /var/tmp/diff_new_pack.FA57ZL/_new  2012-11-19 07:02:31.0 +0100
@@ -19,7 +19,7 @@
 Name:   balsa
 %define TOUCHSCREEN_OPTIMIZATION %(echo %{name} | grep -qv touchscreen ; echo 
$?)
 %define base_name balsa
-Version:2.4.12
+Version:2.4.13
 Release:0
 Summary:The GNOME Mail Program
 License:GPL-2.0+

++ balsa-2.4.12.tar.bz2 - balsa-2.4.13.tar.bz2 ++
 33680 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit baobab for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package baobab for openSUSE:Factory checked 
in at 2012-11-19 07:02:59

Comparing /work/SRC/openSUSE:Factory/baobab (Old)
 and  /work/SRC/openSUSE:Factory/.baobab.new (New)


Package is baobab, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/baobab/baobab.changes2012-10-19 
08:44:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.baobab.new/baobab.changes   2012-11-19 
07:03:01.0 +0100
@@ -1,0 +2,7 @@
+Thu Nov 15 19:33:18 UTC 2012 - dims...@opensuse.org
+
+- Update to version 3.6.3:
+  + Fix crash in the about dialog.
+  + Updated translations.
+
+---

Old:

  baobab-3.6.2.tar.xz

New:

  baobab-3.6.3.tar.xz



Other differences:
--
++ baobab.spec ++
--- /var/tmp/diff_new_pack.a211H0/_old  2012-11-19 07:03:04.0 +0100
+++ /var/tmp/diff_new_pack.a211H0/_new  2012-11-19 07:03:04.0 +0100
@@ -18,7 +18,7 @@
 
 
 Name:   baobab
-Version:3.6.2
+Version:3.6.3
 Release:0
 Summary:Disk Usage Analyzer
 License:GPL-2.0+

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit goffice-0_8 for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package goffice-0_8 for openSUSE:Factory 
checked in at 2012-11-19 07:05:07

Comparing /work/SRC/openSUSE:Factory/goffice-0_8 (Old)
 and  /work/SRC/openSUSE:Factory/.goffice-0_8.new (New)


Package is goffice-0_8, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/goffice-0_8/goffice-0_8.changes  2012-02-20 
16:12:18.0 +0100
+++ /work/SRC/openSUSE:Factory/.goffice-0_8.new/goffice-0_8.changes 
2012-11-19 07:05:08.0 +0100
@@ -1,0 +2,10 @@
+Wed Nov 14 11:44:05 UTC 2012 - dims...@opensuse.org
+
+- Add goffice-0_8-pcre16.patch: fix build when using pcre that was
+  built with --enable-pcre16. In this case, the output of
+  pcretest -C is UTF-8 and UTF-16 support, which was not cought
+  by the original regex in configure.in.
+- Add gnome-common BuildRequires and call to gnome-autogen.sh, as
+  above patch touches the build system.
+
+---

New:

  goffice-0_8-pcre16.patch



Other differences:
--
++ goffice-0_8.spec ++
--- /var/tmp/diff_new_pack.JUzRl1/_old  2012-11-19 07:05:09.0 +0100
+++ /var/tmp/diff_new_pack.JUzRl1/_new  2012-11-19 07:05:09.0 +0100
@@ -28,8 +28,11 @@
 Source: 
http://download.gnome.org/sources/goffice/0.8/%{_name}-%{version}.tar.bz2
 # PATCH-FIX-UPSTREAM goffice-0_8-pcre-8_30.patch bgo#670316 
dims...@opensuse.org -- Port pcre_info to pcre_fullinfo to support pcre 8.30.
 Patch0: goffice-0_8-pcre-8_30.patch
+# PATCH-FIX-UPSTREAM goffice-0_8-pcre16.patch dims...@opensuse.org -- Fix 
build against pcre16 enabled pcre. Not submitted upstream, as goffice 0.8 is 
unmaintained and 0.9.x does not suffer from this issue.
+Patch1: goffice-0_8-pcre16.patch
 BuildRequires:  fdupes
 BuildRequires:  gconf2-devel
+BuildRequires:  gnome-common
 BuildRequires:  gtk2-devel
 BuildRequires:  intltool
 BuildRequires:  libgsf-devel
@@ -89,9 +92,11 @@
 %prep
 %setup -q -n %{_name}-%{version}
 %patch0 -p1
+%patch1 -p1
 translation-update-upstream
 
 %build
+NOCONFIGURE=1 gnome-autogen.sh
 %configure --disable-static --with-pic
 make %{?jobs:-j%jobs}
 

++ goffice-0_8-pcre16.patch ++
Index: goffice-0.8.17/configure.in
===
--- goffice-0.8.17.orig/configure.in
+++ goffice-0.8.17/configure.in
@@ -516,7 +516,7 @@ if test x$glib_has_G_REGEX_ERROR_STRAY_
   AC_CHECK_HEADER(pcre.h,[], AC_MSG_ERROR([Header files for PCRE were not 
found]))
   AC_CHECK_LIB(pcre,pcre_compile2,[], AC_MSG_ERROR([The PCRE library is 
missing or too old]))
   AC_MSG_CHECKING([for UTF-8 support in pcre])
-  if (pcretest -C 21) | grep -i ^ *UTF-8 support /dev/null; then
+  if (pcretest -C 21) | grep -i ^ *UTF-8 .*support /dev/null; then
   AC_MSG_RESULT(yes)
   LIBS=$LIBS -lpcre
   EXTRA_LIBS=$EXTRA_LIBS -lpcre
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gramps for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package gramps for openSUSE:Factory checked 
in at 2012-11-19 07:05:18

Comparing /work/SRC/openSUSE:Factory/gramps (Old)
 and  /work/SRC/openSUSE:Factory/.gramps.new (New)


Package is gramps, Maintainer is j...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/gramps/gramps.changes2012-09-23 
21:04:03.0 +0200
+++ /work/SRC/openSUSE:Factory/.gramps.new/gramps.changes   2012-11-19 
07:05:20.0 +0100
@@ -1,0 +2,17 @@
+Wed Oct 31 12:06:35 UTC 2012 - dims...@opensuse.org
+
+- Update to version 3.4.2:
+  + Some fixes on NarrativeWeb report.
+  + Some fixes on book report.
+  + Improvement on database path interface and user's preferences.
+  + Consistency on Name display and regex support.
+  + Some platform-specific fixes for Windows system environment.
+  + Better support for media links on Gedcom file format.
+  + Fix possible incorrect family relations on Gedcom file format.
+  + Various fixes on citation records.
+  + Fix and improve places handling on Geography views.
+  + Fix on command line arguments.
+  + Consistency on PDF file format.
+  + Updated translations.
+
+---

Old:

  gramps-3.4.1.tar.gz

New:

  gramps-3.4.2.tar.gz



Other differences:
--
++ gramps.spec ++
--- /var/tmp/diff_new_pack.gGn8O5/_old  2012-11-19 07:05:22.0 +0100
+++ /var/tmp/diff_new_pack.gGn8O5/_new  2012-11-19 07:05:22.0 +0100
@@ -18,14 +18,14 @@
 
 
 Name:   gramps
-Version:3.4.1
+Version:3.4.2
 Release:0
 # FIXME: missing recommends because of missing packages: python-exiv2, 
osm-gps-map
 Summary:Genealogical Research Software
 License:GPL-2.0+
 Group:  Productivity/Other
 Url:http://www.gramps-project.org/
-Source: 
http://downloads.sourceforge.net/project/gramps/Stable/3.4.1/%{name}-%{version}.tar.gz
+Source: 
http://downloads.sourceforge.net/project/gramps/Stable/3.4.2/%{name}-%{version}.tar.gz
 BuildRequires:  fdupes
 BuildRequires:  intltool
 # For directory ownership

++ gramps-3.4.1.tar.gz - gramps-3.4.2.tar.gz ++
/work/SRC/openSUSE:Factory/gramps/gramps-3.4.1.tar.gz 
/work/SRC/openSUSE:Factory/.gramps.new/gramps-3.4.2.tar.gz differ: char 5, line 
1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kio_audiocd for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package kio_audiocd for openSUSE:Factory 
checked in at 2012-11-19 07:05:42

Comparing /work/SRC/openSUSE:Factory/kio_audiocd (Old)
 and  /work/SRC/openSUSE:Factory/.kio_audiocd.new (New)


Package is kio_audiocd, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/kio_audiocd/kio_audiocd.changes  2012-11-08 
07:44:38.0 +0100
+++ /work/SRC/openSUSE:Factory/.kio_audiocd.new/kio_audiocd.changes 
2012-11-19 07:05:43.0 +0100
@@ -1,0 +2,5 @@
+Sun Nov 18 19:46:05 UTC 2012 - hrvoje.sen...@gmail.com
+
+- Enable flac and ogg encoders
+
+---



Other differences:
--
++ kio_audiocd.spec ++
--- /var/tmp/diff_new_pack.n0dQTC/_old  2012-11-19 07:05:43.0 +0100
+++ /var/tmp/diff_new_pack.n0dQTC/_new  2012-11-19 07:05:43.0 +0100
@@ -18,9 +18,11 @@
 
 Name:   kio_audiocd
 BuildRequires:  cdparanoia-devel
+BuildRequires:  flac-devel
 BuildRequires:  libkcddb4-devel
 BuildRequires:  libkcompactdisc4-devel
 BuildRequires:  libkde4-devel
+BuildRequires:  libvorbis-devel
 BuildRequires:  xz
 Summary:KDE I/O Slave for Audio CDs
 License:GPL-2.0+
@@ -62,12 +64,15 @@
 %{_kde4_appsdir}/konqsidebartng/
 %{_kde4_appsdir}/solid/actions/solid_audiocd.desktop
 %config %{_kde4_configkcfgdir}/audiocd_lame_encoder.kcfg
+%config %{_kde4_configkcfgdir}/audiocd_vorbis_encoder.kcfg
 %{_kde4_htmldir}/en/kioslave/
 %{_kde4_includedir}/audiocdencoder.h
 %{_kde4_libdir}/libaudiocdplugins.*
 %{_kde4_modulesdir}/kcm_audiocd.so
 %{_kde4_modulesdir}/kio_audiocd.so
+%{_kde4_modulesdir}/libaudiocd_encoder_flac.so
 %{_kde4_modulesdir}/libaudiocd_encoder_lame.so
+%{_kde4_modulesdir}/libaudiocd_encoder_vorbis.so
 %{_kde4_modulesdir}/libaudiocd_encoder_wav.so
 %{_kde4_servicesdir}/audiocd.desktop
 %{_kde4_servicesdir}/audiocd.protocol


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libkcddb4 for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package libkcddb4 for openSUSE:Factory 
checked in at 2012-11-19 07:05:59

Comparing /work/SRC/openSUSE:Factory/libkcddb4 (Old)
 and  /work/SRC/openSUSE:Factory/.libkcddb4.new (New)


Package is libkcddb4, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/libkcddb4/libkcddb4.changes  2012-11-08 
07:46:17.0 +0100
+++ /work/SRC/openSUSE:Factory/.libkcddb4.new/libkcddb4.changes 2012-11-19 
07:06:02.0 +0100
@@ -1,0 +2,6 @@
+Sun Nov 18 19:09:48 UTC 2012 - hrvoje.sen...@gmail.com
+
+- Enable musicbrainz support
+- Remove obsolete BuildRequires
+
+---



Other differences:
--
++ libkcddb4.spec ++
--- /var/tmp/diff_new_pack.MVQA9n/_old  2012-11-19 07:06:03.0 +0100
+++ /var/tmp/diff_new_pack.MVQA9n/_new  2012-11-19 07:06:03.0 +0100
@@ -18,8 +18,9 @@
 
 Name:   libkcddb4
 BuildRequires:  libkde4-devel
-BuildRequires:  libmusicbrainz-devel
-BuildRequires:  libmusicbrainz3-devel
+%if %{?suse_version}  1220
+BuildRequires:  libmusicbrainz5-devel
+%endif
 BuildRequires:  xz
 Summary:KDE CDDB Library
 License:GPL-2.0+


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit meld for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package meld for openSUSE:Factory checked in 
at 2012-11-19 07:06:11

Comparing /work/SRC/openSUSE:Factory/meld (Old)
 and  /work/SRC/openSUSE:Factory/.meld.new (New)


Package is meld, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/meld/meld.changes2012-10-24 
17:13:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.meld.new/meld.changes   2012-11-19 
07:06:13.0 +0100
@@ -1,0 +2,20 @@
+Wed Nov  7 09:10:08 UTC 2012 - dims...@opensuse.org
+
+- Update to version 1.7.0:
+  + File comparisons are faster! Meld now has a smarter
+pre-processing step for inline highlighting of differences and
+does its highlighting calculations asynchronously, leading to
+better overall performance and interactivity.
+  + Auto-merge mode is now available from the command-line.
+  + Comparisons can be opened in new tabs (rather than in a new
+window) from the command line.
+  + Custom colours can now be configured for all Meld drawing.
+  + Improved behaviour when opening many tabs at once.
+  + Notification of searches wrapping around the buffer.
+  + Better compatibility with non-standard keyboard layouts.
+  + Better error reporting for failed VC comparisons.
+  + Version control compatibility updates and fixes.
+  + Other miscellaneous bug fixes.
+  + Updated translations.
+
+---

Old:

  meld-1.6.1.tar.xz

New:

  meld-1.7.0.tar.xz



Other differences:
--
++ meld.spec ++
--- /var/tmp/diff_new_pack.Gg8aMO/_old  2012-11-19 07:06:14.0 +0100
+++ /var/tmp/diff_new_pack.Gg8aMO/_new  2012-11-19 07:06:14.0 +0100
@@ -17,13 +17,13 @@
 
 
 Name:   meld
-Version:1.6.1
+Version:1.7.0
 Release:0
 Summary:Visual diff and merge tool
 License:GPL-2.0+
 Group:  Development/Tools/Other
 Url:http://meld.sourceforge.net/
-Source: 
http://download.gnome.org/sources/meld/1.6/%{name}-%{version}.tar.xz
+Source: 
http://download.gnome.org/sources/meld/1.7/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE meld-1.3.0-scrollkeeper.patch prus...@suse.cz -- don't 
use env
 Patch1: %{name}-1.3.0-env.patch
 BuildRequires:  fdupes

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit memprof for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package memprof for openSUSE:Factory checked 
in at 2012-11-19 07:06:35

Comparing /work/SRC/openSUSE:Factory/memprof (Old)
 and  /work/SRC/openSUSE:Factory/.memprof.new (New)


Package is memprof, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/memprof/memprof.changes  2012-09-25 
14:17:51.0 +0200
+++ /work/SRC/openSUSE:Factory/.memprof.new/memprof.changes 2012-11-19 
07:06:36.0 +0100
@@ -1,0 +2,6 @@
+Thu Nov 15 14:05:21 UTC 2012 - dims...@opensuse.org
+
+- Add memprof-bfd-headers.patch: binutils newly forces the
+  inclusion of config.h.
+
+---

New:

  memprof-bfd-headers.patch



Other differences:
--
++ memprof.spec ++
--- /var/tmp/diff_new_pack.bh6WhB/_old  2012-11-19 07:06:37.0 +0100
+++ /var/tmp/diff_new_pack.bh6WhB/_new  2012-11-19 07:06:37.0 +0100
@@ -24,6 +24,8 @@
 Group:  Development/Tools/Debuggers
 Url:http://www.gnome.org/projects/memprof/
 Source: %{name}-%{version}.tar.bz2
+# PATCH-FIX-UPSTREAM memprof-bfd-headers.patch bgo#688398 dmis...@opensuse.org 
-- Fix new binutils requirement to include config.h
+Patch2: memprof-bfd-headers.patch
 # PATCH-MISSING-TAG -- See http://en.opensuse.org/Packaging/Patches
 Patch3: memprof-0.5.1-desktop.patch
 # PATCH-FIX-UPSTREAM memprof-arch-neutral.patch bgo#663253 r...@wi.rr.com -- 
Fix build on different archs than x86_64 and i586.
@@ -50,6 +52,7 @@
 translation-update-upstream
 %patch3
 %patch4 -p1
+%patch2 -p1
 
 %build
 export CFLAGS=%{optflags} -fno-strict-aliasing CXXFLAGS=%{optflags} 
-fno-strict-aliasing

++ memprof-bfd-headers.patch ++
From cadd5f72c61e3fe974b20a44316feb22d31f0533 Mon Sep 17 00:00:00 2001
From: Dominique Leuenberger dims...@opensuse.org
Date: Thu, 15 Nov 2012 14:58:50 +0100
Subject: [PATCH] include config.h

As per binutils, we are FORCED to include config.h when we want
to make use of bfd.h

See http://sourceware.org/bugzilla/show_bug.cgi?id=14243
---
 src/memprof.h |1 +
 1 file changed, 1 insertion(+)

diff --git a/src/memprof.h b/src/memprof.h
index 9d04a1a..9fc7cf0 100644
--- a/src/memprof.h
+++ b/src/memprof.h
@@ -20,6 +20,7 @@
  */
 /**/
 
+#include config.h
 #include glib.h
 #include gtk/gtkwidget.h
 #include stdio.h
-- 
1.7.10.4

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit PackageKit for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package PackageKit for openSUSE:Factory 
checked in at 2012-11-19 07:07:07

Comparing /work/SRC/openSUSE:Factory/PackageKit (Old)
 and  /work/SRC/openSUSE:Factory/.PackageKit.new (New)


Package is PackageKit, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/PackageKit/PackageKit.changes2012-10-04 
18:41:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.PackageKit.new/PackageKit.changes   
2012-11-19 07:07:09.0 +0100
@@ -1,0 +2,6 @@
+Fri Nov 16 23:33:08 UTC 2012 - dims...@opensuse.org
+
+- Add PackageKit-no-polkit-backend-1.patch: Do not look for no
+  longer existing polkit-backend-1. Fixes build with polkit = 106.
+
+---

New:

  PackageKit-no-polkit-backend-1.patch



Other differences:
--
++ PackageKit.spec ++
--- /var/tmp/diff_new_pack.31f5m0/_old  2012-11-19 07:07:10.0 +0100
+++ /var/tmp/diff_new_pack.31f5m0/_new  2012-11-19 07:07:10.0 +0100
@@ -76,6 +76,8 @@
 Patch11:PackageKit-bnc780058-zypp-backend-match-patches.patch
 # PATCH-FIX-UPSTREAM PackageKit-gstreamer-1.0.patch dims...@opensuse.org -- 
Support GStreamer 1.0, taken from upstream git.
 Patch12:PackageKit-gstreamer-1.0.patch
+# PATCH-FIX-UPSTREAM PackageKit-no-polkit-backend-1.patch dims...@opensuse.org 
-- Drop unused polkit-backend-1 dependency.
+Patch13:PackageKit-no-polkit-backend-1.patch
 BuildRequires:  NetworkManager-devel
 BuildRequires:  automake
 BuildRequires:  docbook-utils
@@ -335,9 +337,10 @@
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
+%patch13 -p1
 
 %build
-# Needed due to patch 3
+# Needed due to patch3 and patch13
 autoreconf -fi
 %configure \
--disable-static \


++ PackageKit-no-polkit-backend-1.patch ++
From 1ae66042cb0ded1455617aba4b82fe8053794ca1 Mon Sep 17 00:00:00 2001
From: Richard Hughes rich...@hughsie.com
Date: Fri, 8 Jun 2012 12:22:17 +0100
Subject: [PATCH] Drop the unused polkit-backend-1 check from configure as
 it's gone upstream

---
 configure.ac | 1 -
 1 file changed, 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 93af2d7..734681d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -584,7 +584,6 @@ AC_SUBST(security_framework, $with_security_framework)
 
 if test x$with_security_framework = xpolkit; then
PKG_CHECK_MODULES(POLKIT, \
- polkit-backend-1 \
  polkit-gobject-1 = $POLKIT_GOBJECT_REQUIRED)
AC_DEFINE(USE_SECURITY_POLKIT, 1, [if we should use PolicyKit])
 elif test x$with_security_framework = xdummy; then
-- 
1.8.0


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rednotebook for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package rednotebook for openSUSE:Factory 
checked in at 2012-11-19 07:07:31

Comparing /work/SRC/openSUSE:Factory/rednotebook (Old)
 and  /work/SRC/openSUSE:Factory/.rednotebook.new (New)


Package is rednotebook, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/rednotebook/rednotebook.changes  2012-07-22 
22:00:24.0 +0200
+++ /work/SRC/openSUSE:Factory/.rednotebook.new/rednotebook.changes 
2012-11-19 07:07:33.0 +0100
@@ -1,0 +2,8 @@
+Thu Nov  1 12:44:14 UTC 2012 - dims...@opensuse.org
+
+- Update to version 1.6.0:
+  + Add inline #hashtagging.
+  + Allow for automatic switching between edit and preview mode.
+  + Many other new features and bugfixes.
+
+---

Old:

  rednotebook-1.5.0.tar.gz

New:

  rednotebook-1.6.0.tar.gz



Other differences:
--
++ rednotebook.spec ++
--- /var/tmp/diff_new_pack.NVptZG/_old  2012-11-19 07:07:34.0 +0100
+++ /var/tmp/diff_new_pack.NVptZG/_new  2012-11-19 07:07:34.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   rednotebook
-Version:1.5.0
+Version:1.6.0
 Release:0
 # See note at the end of README: code is using some LGPL-3.0+ module, so the 
resulting work is GPL-3.0+.
 Summary:Graphical diary and journal
@@ -86,8 +86,6 @@
 %doc AUTHORS CHANGELOG LICENSE README
 %{_bindir}/%{name}
 %{_datadir}/applications/%{name}.desktop
-%{_datadir}/pixmaps/%{name}.png
-%{_datadir}/icons/hicolor/*/apps/%{name}.png
 %{_datadir}/icons/hicolor/*/apps/%{name}.svg
 %{python_sitelib}/%{name}/
 %{python_sitelib}/%{name}-%{version}-py%{python_version}.egg-info

++ rednotebook-1.5.0.tar.gz - rednotebook-1.6.0.tar.gz ++
 37001 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rygel for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package rygel for openSUSE:Factory checked 
in at 2012-11-19 07:07:56

Comparing /work/SRC/openSUSE:Factory/rygel (Old)
 and  /work/SRC/openSUSE:Factory/.rygel.new (New)


Package is rygel, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/rygel/rygel.changes  2012-10-19 
08:52:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.rygel.new/rygel.changes 2012-11-19 
07:07:58.0 +0100
@@ -1,0 +2,24 @@
+Thu Nov 15 08:07:24 UTC 2012 - dims...@opensuse.org
+
+- Update to version 0.16.3:
+  + Really fix the Content-Length: header handling and fix a
+regression introduced in 0.16.2 on the first try fixing that.
+
+---
+Tue Nov 13 10:37:35 UTC 2012 - dims...@opensuse.org
+
+- Update to version 0.16.2:
+  + Skip modules in hidden directories to fix issues with certain
+distribution's debug symbols.
+  + Ignore seek requests that request everything. Should fix issues
+with transcoding.
+  + Fix thumbnails for transcoded videos on XBox 360. Also fixes
+No transcoder available for WMVHIGH_FULL.wmv messages.
+  + Add missing Content-Length header.
+  + Playbin:
+- Add AAC mime types as supported.
+- Only report duration if it's really known.
+- Add missing buffering and lost clock handling.
+  + Updated translations.
+
+---

Old:

  rygel-0.16.1.tar.xz

New:

  rygel-0.16.3.tar.xz



Other differences:
--
++ rygel.spec ++
--- /var/tmp/diff_new_pack.ebZlbf/_old  2012-11-19 07:08:00.0 +0100
+++ /var/tmp/diff_new_pack.ebZlbf/_new  2012-11-19 07:08:00.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   rygel
-Version:0.16.1
+Version:0.16.3
 Release:0
 Summary:Home Media Solution for GNOME based on UPnP/DLNA
 License:LGPL-2.0+

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit telepathy-idle for openSUSE:Factory

2012-11-18 Thread h_root
Hello community,

here is the log from the commit of package telepathy-idle for openSUSE:Factory 
checked in at 2012-11-19 07:08:04

Comparing /work/SRC/openSUSE:Factory/telepathy-idle (Old)
 and  /work/SRC/openSUSE:Factory/.telepathy-idle.new (New)


Package is telepathy-idle, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/telepathy-idle/telepathy-idle.changes
2012-08-23 16:06:39.0 +0200
+++ /work/SRC/openSUSE:Factory/.telepathy-idle.new/telepathy-idle.changes   
2012-11-19 07:08:06.0 +0100
@@ -1,0 +2,24 @@
+Sun Nov 18 17:02:56 UTC 2012 - zai...@opensuse.org
+
+- Update to version 0.1.14:
+  + Parse PONG replies more leniently. bip's PONGs were rejected by
+0.1.13.
+
+---
+Thu Nov 15 21:45:23 UTC 2012 - dims...@opensuse.org
+
+- Update to version 0.1.13:
+  + Enhancements:
+- Initial support for listing rooms (fdo#23005).
+- Chat room channels now respawn if you Close() them
+  (fdo#24614).
+  + Fixes:
+- Fix for make -j safety (fdo#54016).
+- Sending well-formed but invalid UTF-8 no longer gets Idle
+  kicked off the bus (fdo#30741).
+- Idle now disconnects if it doesn't get a reply to its pings
+  after a while (fdo#56589).
+- Don't wedge and stop sending messages in a situation we
+  believe was triggered by a short-lived GIO bug (fdo#49163).
+
+---

Old:

  telepathy-idle-0.1.12.tar.gz

New:

  telepathy-idle-0.1.14.tar.gz



Other differences:
--
++ telepathy-idle.spec ++
--- /var/tmp/diff_new_pack.Z8wwCS/_old  2012-11-19 07:08:07.0 +0100
+++ /var/tmp/diff_new_pack.Z8wwCS/_new  2012-11-19 07:08:07.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   telepathy-idle
-Version:0.1.12
+Version:0.1.14
 Release:0
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  libopenssl-devel

++ telepathy-idle-0.1.12.tar.gz - telepathy-idle-0.1.14.tar.gz ++
 2989 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org