commit dynamips for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package dynamips for openSUSE:Factory 
checked in at 2018-02-20 17:55:06

Comparing /work/SRC/openSUSE:Factory/dynamips (Old)
 and  /work/SRC/openSUSE:Factory/.dynamips.new (New)


Package is "dynamips"

Tue Feb 20 17:55:06 2018 rev:23 rq:578018 version:0.2.17

Changes:

--- /work/SRC/openSUSE:Factory/dynamips/dynamips.changes2017-03-03 
17:44:27.341802376 +0100
+++ /work/SRC/openSUSE:Factory/.dynamips.new/dynamips.changes   2018-02-20 
17:55:16.426035588 +0100
@@ -1,0 +2,9 @@
+Sun Feb 18 08:54:40 UTC 2018 - avin...@opensuse.org
+
+- new upstream version 0.2.17
+  * Set nonblocking I/O for UDP sockets
+  * NM-16ESW: process packets even if MAC address table is full
+- remove dos2unix, no longer needed
+- use cmake macros to build
+
+---

Old:

  dynamips-0.2.16.tar.gz

New:

  dynamips-0.2.17.tar.gz



Other differences:
--
++ dynamips.spec ++
--- /var/tmp/diff_new_pack.pcc5il/_old  2018-02-20 17:55:17.901982444 +0100
+++ /var/tmp/diff_new_pack.pcc5il/_new  2018-02-20 17:55:17.905982300 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package dynamips
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,26 +17,23 @@
 
 
 Name:   dynamips
-Version:0.2.16
+Version:0.2.17
 Release:0
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+Summary:Cisco router Emulator
+License:GPL-2.0+
+Group:  System/Emulators/Other
+Url:https://www.gns3.net
+Source: 
https://github.com/GNS3/%{name}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
+Patch1: define-s390x-arch.patch
 BuildRequires:  cmake
-BuildRequires:  dos2unix
 BuildRequires:  libelf-devel
 BuildRequires:  libpcap-devel
-Url:http://www.gns3.net
 %ifarch x86_64
 %if %{undefined fedora}
 BuildRequires:  glibc-32bit
 BuildRequires:  glibc-devel-32bit
 %endif
 %endif
-Source: %{name}-%{version}.tar.gz
-Patch1: define-s390x-arch.patch
-
-Summary:Cisco router Emulator
-License:GPL-2.0+
-Group:  System/Emulators/Other
 
 %description
 Cisco Router Emulator supported by GNS3 Community
@@ -52,28 +49,22 @@
 %patch1 -p1
 
 %build
-mkdir build
-cd build
-CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ;
-CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ;
+%cmake \
 %ifarch x86_64
-cmake -DYNAMIPS_ARCH=amd64 -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} ..
-%else
-cmake -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} ..
+   -DYNAMIPS_ARCH=amd64 \
 %endif
-%__make %{?_smp_mflags}
+..
+%make_jobs
 
 %install
-cd build
-make DESTDIR=%{buildroot} install
-cd ..
-dos2unix COPYING README.md README.hypervisor TODO
+%cmake_install
 
 %files
-%defattr(-,root,root)
 %{_bindir}/%{name}
 %{_bindir}/nvram_export
-%{_mandir}/man*/*
+%{_mandir}/man1/%{name}.1%{ext_man}
+%{_mandir}/man1/nvram_export.1%{ext_man}
+%{_mandir}/man7/hypervisor_mode.7%{ext_man}
 %{_datadir}/doc/%{name}
 
 %changelog

++ dynamips-0.2.16.tar.gz -> dynamips-0.2.17.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dynamips-0.2.16/CMakeLists.txt 
new/dynamips-0.2.17/CMakeLists.txt
--- old/dynamips-0.2.16/CMakeLists.txt  2016-03-16 10:05:47.0 +0100
+++ new/dynamips-0.2.17/CMakeLists.txt  2017-07-24 13:37:51.0 +0200
@@ -25,14 +25,14 @@
 message ( STATUS "CMAKE_MODULE_PATH=${CMAKE_MODULE_PATH}" )
 
 project ( dynamips C )
-set ( DYNAMIPS_VERSION_TRAIN 0.2.16 )
+set ( DYNAMIPS_VERSION_TRAIN 0.2.17 )
 set ( DYNAMIPS_VERSION_SUB )
 
 include ( utils )
 include ( dependencies )
 include ( configure )
 
-if(APPLE)
+if( APPLE OR (CMAKE_SYSTEM_NAME MATCHES "FreeBSD") )
 include_directories(include /usr/local/include/)
 include_directories(include /opt/local/include/)
 endif()
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dynamips-0.2.16/ChangeLog 
new/dynamips-0.2.17/ChangeLog
--- old/dynamips-0.2.16/ChangeLog   2016-03-16 10:05:47.0 +0100
+++ new/dynamips-0.2.17/ChangeLog   2017-07-24 13:37:51.0 +0200
@@ -2970,3 +2970,16 @@
 * Add instructions to build on Windows.
 * Remove libuuid dependency and NIO Multicast implementation that depends on 
it. NIO Multicast is never used and maybe not even functional. This will 
simplify the compilation requirements, especially on Windows with Cygwin.
 * EthernetSwitch: Allow to choose ethertype for QinQ outer 

commit eog-plugins for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package eog-plugins for openSUSE:Factory 
checked in at 2018-02-20 17:55:17

Comparing /work/SRC/openSUSE:Factory/eog-plugins (Old)
 and  /work/SRC/openSUSE:Factory/.eog-plugins.new (New)


Package is "eog-plugins"

Tue Feb 20 17:55:17 2018 rev:47 rq:578043 version:3.26.2

Changes:

--- /work/SRC/openSUSE:Factory/eog-plugins/eog-plugins.changes  2017-10-06 
10:57:54.751584268 +0200
+++ /work/SRC/openSUSE:Factory/.eog-plugins.new/eog-plugins.changes 
2018-02-20 17:55:29.237574283 +0100
@@ -1,0 +2,6 @@
+Tue Feb 13 16:33:28 UTC 2018 - dims...@opensuse.org
+
+- Update to version 3.26.2:
+  + Updated translations.
+
+---

Old:

  eog-plugins-3.26.1.tar.xz

New:

  eog-plugins-3.26.2.tar.xz



Other differences:
--
++ eog-plugins.spec ++
--- /var/tmp/diff_new_pack.tnzmWv/_old  2018-02-20 17:55:30.217538997 +0100
+++ /var/tmp/diff_new_pack.tnzmWv/_new  2018-02-20 17:55:30.221538853 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package eog-plugins
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   eog-plugins
-Version:3.26.1
+Version:3.26.2
 Release:0
 #FIXME: add postr BuildRequires when we have a package
 Summary:A collection of plugins for Eye of GNOME

++ eog-plugins-3.26.1.tar.xz -> eog-plugins-3.26.2.tar.xz ++
 3172 lines of diff (skipped)




commit fio for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package fio for openSUSE:Factory checked in 
at 2018-02-20 17:55:12

Comparing /work/SRC/openSUSE:Factory/fio (Old)
 and  /work/SRC/openSUSE:Factory/.fio.new (New)


Package is "fio"

Tue Feb 20 17:55:12 2018 rev:43 rq:578033 version:3.4

Changes:

--- /work/SRC/openSUSE:Factory/fio/fio.changes  2018-01-10 23:34:48.557033304 
+0100
+++ /work/SRC/openSUSE:Factory/.fio.new/fio.changes 2018-02-20 
17:55:25.809697710 +0100
@@ -1,0 +2,8 @@
+Sun Feb 18 09:07:00 UTC 2018 - avin...@opensuse.org
+
+- Update to version 3.4:
+  * For detailed list of changes see:
+http://brick.kernel.dk/snaps/fio-3.4.shortlog.txt
+- simplify build and install
+
+---

Old:

  fio-3.3.tar.bz2

New:

  fio-3.4.tar.bz2



Other differences:
--
++ fio.spec ++
--- /var/tmp/diff_new_pack.1uh77d/_old  2018-02-20 17:55:26.685666169 +0100
+++ /var/tmp/diff_new_pack.1uh77d/_new  2018-02-20 17:55:26.689666025 +0100
@@ -18,12 +18,12 @@
 
 
 Name:   fio
-Version:3.3
+Version:3.4
 Release:0
 Summary:Flexible I/O tester
 License:GPL-2.0
 Group:  System/Benchmark
-URL:http://git.kernel.dk/?p=fio.git;a=summary
+Url:http://git.kernel.dk/?p=fio.git;a=summary
 Source: http://brick.kernel.dk/snaps/fio-%{version}.tar.bz2
 BuildRequires:  gtk2-devel
 BuildRequires:  libaio-devel
@@ -73,21 +73,12 @@
   %{?_smp_mflags} \
   V=1 \
   OPTFLAGS="%{optflags}" \
-  CC="cc" \
-  prefix="%{_prefix}" \
-  libdir="%{_libdir}/fio" \
-  mandir="%{_mandir}"
+  CC="cc"
 
 %install
-make \
-  %{?_smp_mflags} \
-  V=1 \
-  DESTDIR=%{buildroot} \
+%make_install \
   prefix="%{_prefix}" \
-  bindir="%{_bindir}" \
-  libdir="%{_libdir}/fio" \
-  mandir="%{_mandir}" \
-  install
+   mandir="%{_mandir}"
 
 %check
 make %{?_smp_mflags} test

++ fio-3.3.tar.bz2 -> fio-3.4.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fio-3.3/HOWTO new/fio-3.4/HOWTO
--- old/fio-3.3/HOWTO   2017-12-19 21:16:36.0 +0100
+++ new/fio-3.4/HOWTO   2018-02-12 18:55:07.0 +0100
@@ -1093,8 +1093,9 @@
 
 .. option:: fadvise_hint=str
 
-   Use :manpage:`posix_fadvise(2)` to advise the kernel on what I/O 
patterns
-   are likely to be issued.  Accepted values are:
+   Use :manpage:`posix_fadvise(2)` or :manpage:`posix_fadvise(2)` to
+   advise the kernel on what I/O patterns are likely to be issued.
+   Accepted values are:
 
**0**
Backwards-compatible hint for "no hint".
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fio-3.3/README new/fio-3.4/README
--- old/fio-3.3/README  2017-12-19 21:16:36.0 +0100
+++ new/fio-3.4/README  2018-02-12 18:55:07.0 +0100
@@ -120,7 +120,9 @@
 
 Windows:
Rebecca Cran  has fio packages for Windows at
-   http://www.bluestop.org/fio/ .
+   https://www.bluestop.org/fio/ . The latest builds for Windows can also
+   be grabbed from https://ci.appveyor.com/project/axboe/fio by clicking
+   the latest x86 or x64 build, then selecting the ARTIFACTS tab.
 
 BSDs:
Packages for BSDs may be available from their binary package 
repositories.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fio-3.3/client.c new/fio-3.4/client.c
--- old/fio-3.3/client.c2017-12-19 21:16:36.0 +0100
+++ new/fio-3.4/client.c2018-02-12 18:55:07.0 +0100
@@ -1024,6 +1024,7 @@
client_ts.thread_number = p->ts.thread_number;
client_ts.groupid = p->ts.groupid;
client_ts.unified_rw_rep = p->ts.unified_rw_rep;
+   client_ts.sig_figs = p->ts.sig_figs;
 
if (++sum_stat_nr == sum_stat_clients) {
strcpy(client_ts.name, "All clients");
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fio-3.3/debug.c new/fio-3.4/debug.c
--- old/fio-3.3/debug.c 2017-12-19 21:16:36.0 +0100
+++ new/fio-3.4/debug.c 2018-02-12 18:55:07.0 +0100
@@ -7,20 +7,11 @@
 void __dprint(int type, const char *str, ...)
 {
va_list args;
-   pid_t pid;
 
assert(type < FD_DEBUG_MAX);
 
-   pid = getpid();
-   if (fio_debug_jobp && *fio_debug_jobp != -1U
-   && pid != *fio_debug_jobp)
-   return;
-
-   log_info("%-8s ", debug_levels[type].name);
-   log_info("%-5u ", (int) pid);
-
va_start(args, str);
-   log_valist(str, args);
+   log_prevalist(type, str, args);
va_end(args);

commit perl-Perl-Critic-Freenode for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package perl-Perl-Critic-Freenode for 
openSUSE:Factory checked in at 2018-02-20 17:54:29

Comparing /work/SRC/openSUSE:Factory/perl-Perl-Critic-Freenode (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Perl-Critic-Freenode.new (New)


Package is "perl-Perl-Critic-Freenode"

Tue Feb 20 17:54:29 2018 rev:6 rq:577951 version:0.026

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Perl-Critic-Freenode/perl-Perl-Critic-Freenode.changes
  2018-02-16 21:45:29.189325858 +0100
+++ 
/work/SRC/openSUSE:Factory/.perl-Perl-Critic-Freenode.new/perl-Perl-Critic-Freenode.changes
 2018-02-20 17:54:32.919602130 +0100
@@ -1,0 +2,9 @@
+Sat Feb 17 06:54:09 UTC 2018 - co...@suse.com
+
+- updated to 0.026
+   see /usr/share/doc/packages/perl-Perl-Critic-Freenode/Changes
+
+  0.026 2018-02-16 20:50:14 EST
+- Update Prototypes policy to recognize more ways of activating the 
signatures feature
+
+---

Old:

  Perl-Critic-Freenode-0.025.tar.gz

New:

  Perl-Critic-Freenode-0.026.tar.gz



Other differences:
--
++ perl-Perl-Critic-Freenode.spec ++
--- /var/tmp/diff_new_pack.2v2221/_old  2018-02-20 17:54:33.795570589 +0100
+++ /var/tmp/diff_new_pack.2v2221/_new  2018-02-20 17:54:33.795570589 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Perl-Critic-Freenode
-Version:0.025
+Version:0.026
 Release:0
 %define cpan_name Perl-Critic-Freenode
 Summary:Perl::Critic policies inspired by #perl on

++ Perl-Critic-Freenode-0.025.tar.gz -> Perl-Critic-Freenode-0.026.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Perl-Critic-Freenode-0.025/Build.PL 
new/Perl-Critic-Freenode-0.026/Build.PL
--- old/Perl-Critic-Freenode-0.025/Build.PL 2018-02-11 07:32:01.0 
+0100
+++ new/Perl-Critic-Freenode-0.026/Build.PL 2018-02-17 02:50:16.0 
+0100
@@ -68,7 +68,7 @@
 }
 
 
-# This section was automatically generated by 
Dist::Zilla::Plugin::ModuleBuild v6.010.
+# This section was automatically generated by 
Dist::Zilla::Plugin::ModuleBuild v6.011.
 use strict;
 use warnings;
 
@@ -84,7 +84,7 @@
 "Dan Book "
   ],
   "dist_name" => "Perl-Critic-Freenode",
-  "dist_version" => "0.025",
+  "dist_version" => "0.026",
   "license" => "artistic_2",
   "module_name" => "Perl::Critic::Freenode",
   "recursive_test_files" => 1,
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Perl-Critic-Freenode-0.025/Changes 
new/Perl-Critic-Freenode-0.026/Changes
--- old/Perl-Critic-Freenode-0.025/Changes  2018-02-11 07:32:01.0 
+0100
+++ new/Perl-Critic-Freenode-0.026/Changes  2018-02-17 02:50:16.0 
+0100
@@ -1,3 +1,6 @@
+0.026 2018-02-16 20:50:14 EST
+  - Update Prototypes policy to recognize more ways of activating the 
signatures feature
+
 0.025 2018-02-11 01:31:58 EST
   - Fix DeprecatedFeatures to recognize correctly-parsed postderef in PPI 
1.237+
   - Avoid warning from running PackageMatchesFilename policy on a document 
without a filename (willt #29)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Perl-Critic-Freenode-0.025/MANIFEST 
new/Perl-Critic-Freenode-0.026/MANIFEST
--- old/Perl-Critic-Freenode-0.025/MANIFEST 2018-02-11 07:32:01.0 
+0100
+++ new/Perl-Critic-Freenode-0.026/MANIFEST 2018-02-17 02:50:16.0 
+0100
@@ -1,4 +1,4 @@
-# This file was automatically generated by Dist::Zilla::Plugin::Manifest 
v6.010.
+# This file was automatically generated by Dist::Zilla::Plugin::Manifest 
v6.011.
 Build.PL
 CONTRIBUTING.md
 Changes
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Perl-Critic-Freenode-0.025/META.json 
new/Perl-Critic-Freenode-0.026/META.json
--- old/Perl-Critic-Freenode-0.025/META.json2018-02-11 07:32:01.0 
+0100
+++ new/Perl-Critic-Freenode-0.026/META.json2018-02-17 02:50:16.0 
+0100
@@ -4,7 +4,7 @@
   "Dan Book "
],
"dynamic_config" : 0,
-   "generated_by" : "Dist::Zilla version 6.010, CPAN::Meta::Converter version 
2.150010",
+   "generated_by" : "Dist::Zilla version 6.011, CPAN::Meta::Converter version 
2.150010",
"license" : [
   "artistic_2"
],
@@ -68,99 +68,99 @@
"provides" : {
   "Perl::Critic::Freenode" : {
  "file" : "lib/Perl/Critic/Freenode.pm",
- "version" : "0.025"
+ "version" : "0.026"
   },
   "Perl::Critic::Freenode::Utils" : {
  "file" : 

commit suil for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package suil for openSUSE:Factory checked in 
at 2018-02-20 17:54:33

Comparing /work/SRC/openSUSE:Factory/suil (Old)
 and  /work/SRC/openSUSE:Factory/.suil.new (New)


Package is "suil"

Tue Feb 20 17:54:33 2018 rev:3 rq:577956 version:0.10.0

Changes:

--- /work/SRC/openSUSE:Factory/suil/suil.changes2018-02-18 
11:42:26.977417097 +0100
+++ /work/SRC/openSUSE:Factory/.suil.new/suil.changes   2018-02-20 
17:54:38.515400641 +0100
@@ -1,0 +2,5 @@
+Sun Feb 18 10:48:05 UTC 2018 - jeng...@inai.de
+
+- Fix SRPM group.
+
+---



Other differences:
--
++ suil.spec ++
--- /var/tmp/diff_new_pack.v8bMf4/_old  2018-02-20 17:54:39.359370252 +0100
+++ /var/tmp/diff_new_pack.v8bMf4/_new  2018-02-20 17:54:39.359370252 +0100
@@ -33,7 +33,7 @@
 Release:0
 Summary:Lightweight C library for loading and wrapping LV2 plugin UIs
 License:ISC
-Group:  System/Libraries
+Group:  Development/Libraries/C and C++
 Url:https://drobilla.net/software/suil/
 Source: https://download.drobilla.net/suil-%{version}.tar.bz2
 BuildRequires:  gcc-c++




commit raspberrypi-firmware for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package raspberrypi-firmware for 
openSUSE:Factory checked in at 2018-02-20 17:55:33

Comparing /work/SRC/openSUSE:Factory/raspberrypi-firmware (Old)
 and  /work/SRC/openSUSE:Factory/.raspberrypi-firmware.new (New)


Package is "raspberrypi-firmware"

Tue Feb 20 17:55:33 2018 rev:30 rq:578147 version:2018.02.09

Changes:

--- 
/work/SRC/openSUSE:Factory/raspberrypi-firmware/raspberrypi-firmware-config.changes
 2018-02-19 13:01:15.013466201 +0100
+++ 
/work/SRC/openSUSE:Factory/.raspberrypi-firmware.new/raspberrypi-firmware-config.changes
2018-02-20 17:55:43.901046296 +0100
@@ -1,0 +2,6 @@
+Mon Feb 19 10:48:28 UTC 2018 - ag...@suse.com
+
+- Add overlays to match previous U-Boot provided DT
+- Add Recommends: on dt and config packages
+
+---
raspberrypi-firmware.changes: same change



Other differences:
--
++ raspberrypi-firmware.spec ++
--- /var/tmp/diff_new_pack.iMjPT2/_old  2018-02-20 17:55:45.165000786 +0100
+++ /var/tmp/diff_new_pack.iMjPT2/_new  2018-02-20 17:55:45.169000641 +0100
@@ -29,6 +29,8 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
 Requires(post): util-linux
+Recommends: raspberrypi-firmware-dt
+Recommends: raspberrypi-firmware-config
 
 %description
 Binary bootloader and firmware files for Raspberry Pi

++ config.txt ++
--- /var/tmp/diff_new_pack.iMjPT2/_old  2018-02-20 17:55:45.216998913 +0100
+++ /var/tmp/diff_new_pack.iMjPT2/_new  2018-02-20 17:55:45.216998913 +0100
@@ -22,6 +22,18 @@
 # Disable warning overlays as they don't work well together with linux's 
graphical output
 avoid_warnings=1
 
+# These are not applied automatically? Needed to use respective upstream 
drivers.
+dtoverlay=vc4-kms-v3d
+dtoverlay=dwc2
+
+# This overlay fixes divergences between the RPi device tree and what
+# upstream provides
+dtoverlay=upstream-mmc
+dtoverlay=upstream-aux-interrupt
+
+# Older kernels didn't support HDMI connection detection on the rpi3, so force
+# HDMI to always plugged in there. This overlay is only effective on rpi3.
+dtoverlay=rpi3-hdmi
 
 [pi1]
 
@@ -39,3 +51,4 @@
 
 # Boot in AArch64 (64-bit) mode
 arm_control=0x200
+




commit python-SQLAlchemy-Utils for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package python-SQLAlchemy-Utils for 
openSUSE:Factory checked in at 2018-02-20 17:55:43

Comparing /work/SRC/openSUSE:Factory/python-SQLAlchemy-Utils (Old)
 and  /work/SRC/openSUSE:Factory/.python-SQLAlchemy-Utils.new (New)


Package is "python-SQLAlchemy-Utils"

Tue Feb 20 17:55:43 2018 rev:8 rq:578202 version:0.33.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-SQLAlchemy-Utils/python-SQLAlchemy-Utils.changes
  2017-11-15 16:58:15.107040572 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-SQLAlchemy-Utils.new/python-SQLAlchemy-Utils.changes
 2018-02-20 17:55:52.476737512 +0100
@@ -1,0 +2,14 @@
+Mon Feb 19 17:16:09 UTC 2018 - a...@gmx.de
+
+- specfile:
+  * update copyright year
+
+- update to version 0.33.0:
+  * Added support for materialized views in PostgreSQL
+  * Added Ltree.descendant_of and Ltree.ancestor_of (#311, pull
+request courtesy of kageurufu)
+  * Dropped Python 3.3 support
+  * Fixed EncryptedType padding (#301, pull request courtesy of
+konstantinoskostis)
+
+---

Old:

  SQLAlchemy-Utils-0.32.21.tar.gz

New:

  SQLAlchemy-Utils-0.33.0.tar.gz



Other differences:
--
++ python-SQLAlchemy-Utils.spec ++
--- /var/tmp/diff_new_pack.24qcZ9/_old  2018-02-20 17:55:54.904650091 +0100
+++ /var/tmp/diff_new_pack.24qcZ9/_new  2018-02-20 17:55:54.904650091 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-SQLAlchemy-Utils
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-SQLAlchemy-Utils
-Version:0.32.21
+Version:0.33.0
 Release:0
 Summary:Various utility functions for SQLAlchemy
 License:BSD-3-Clause

++ SQLAlchemy-Utils-0.32.21.tar.gz -> SQLAlchemy-Utils-0.33.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/SQLAlchemy-Utils-0.32.21/CHANGES.rst 
new/SQLAlchemy-Utils-0.33.0/CHANGES.rst
--- old/SQLAlchemy-Utils-0.32.21/CHANGES.rst2017-11-11 18:53:06.0 
+0100
+++ new/SQLAlchemy-Utils-0.33.0/CHANGES.rst 2018-02-18 15:42:06.0 
+0100
@@ -4,6 +4,15 @@
 Here you can see the full list of changes between each SQLAlchemy-Utils 
release.
 
 
+0.33.0 (2018-02-18)
+^^^
+
+- Added support for materialized views in PostgreSQL
+- Added Ltree.descendant_of and Ltree.ancestor_of (#311, pull request courtesy 
of kageurufu)
+- Dropped Python 3.3 support
+- Fixed EncryptedType padding (#301, pull request courtesy of 
konstantinoskostis)
+
+
 0.32.21 (2017-11-11)
 
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/SQLAlchemy-Utils-0.32.21/PKG-INFO 
new/SQLAlchemy-Utils-0.33.0/PKG-INFO
--- old/SQLAlchemy-Utils-0.32.21/PKG-INFO   2017-11-11 19:41:23.0 
+0100
+++ new/SQLAlchemy-Utils-0.33.0/PKG-INFO2018-02-18 15:47:12.0 
+0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: SQLAlchemy-Utils
-Version: 0.32.21
+Version: 0.33.0
 Summary: Various utility functions for SQLAlchemy.
 Home-page: https://github.com/kvesteri/sqlalchemy-utils
 Author: Konsta Vesterinen, Ryan Leckey, Janne Vanhala, Vesa Uimonen
@@ -21,7 +21,6 @@
 Classifier: Programming Language :: Python :: 2
 Classifier: Programming Language :: Python :: 2.7
 Classifier: Programming Language :: Python :: 3
-Classifier: Programming Language :: Python :: 3.3
 Classifier: Programming Language :: Python :: 3.4
 Classifier: Programming Language :: Python :: 3.5
 Classifier: Programming Language :: Python :: 3.6
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/SQLAlchemy-Utils-0.32.21/SQLAlchemy_Utils.egg-info/PKG-INFO 
new/SQLAlchemy-Utils-0.33.0/SQLAlchemy_Utils.egg-info/PKG-INFO
--- old/SQLAlchemy-Utils-0.32.21/SQLAlchemy_Utils.egg-info/PKG-INFO 
2017-11-11 19:41:23.0 +0100
+++ new/SQLAlchemy-Utils-0.33.0/SQLAlchemy_Utils.egg-info/PKG-INFO  
2018-02-18 15:47:12.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: SQLAlchemy-Utils
-Version: 0.32.21
+Version: 0.33.0
 Summary: Various utility functions for SQLAlchemy.
 Home-page: https://github.com/kvesteri/sqlalchemy-utils
 Author: Konsta Vesterinen, Ryan Leckey, Janne Vanhala, Vesa Uimonen
@@ -21,7 +21,6 @@
 Classifier: Programming Language :: Python :: 2
 Classifier: Programming Language :: 

commit mkosi for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package mkosi for openSUSE:Factory checked 
in at 2018-02-20 17:55:46

Comparing /work/SRC/openSUSE:Factory/mkosi (Old)
 and  /work/SRC/openSUSE:Factory/.mkosi.new (New)


Package is "mkosi"

Tue Feb 20 17:55:46 2018 rev:2 rq:578207 version:4

Changes:

--- /work/SRC/openSUSE:Factory/mkosi/mkosi.changes  2017-09-07 
22:16:09.958016967 +0200
+++ /work/SRC/openSUSE:Factory/.mkosi.new/mkosi.changes 2018-02-20 
17:55:55.724620566 +0100
@@ -1,0 +2,7 @@
+Mon Feb 12 19:22:30 UTC 2018 - sebix+novell@sebix.at
+
+- update to version 4
+ * no changelog available
+ * removed 109.patch, merged upstream
+
+---

Old:

  109.patch
  mkosi-3.tar.gz

New:

  mkosi-4.tar.gz



Other differences:
--
++ mkosi.spec ++
--- /var/tmp/diff_new_pack.Vg6At6/_old  2018-02-20 17:55:56.508592338 +0100
+++ /var/tmp/diff_new_pack.Vg6At6/_new  2018-02-20 17:55:56.512592194 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package mkosi
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,16 +17,15 @@
 
 
 Name:   mkosi
-Version:3
+Version:4
 Release:0
 Summary:Build Legacy-Free OS Images
-License:LGPL-2.1
+License:LGPL-2.1+
 Group:  System/Management
 Url:https://github.com/systemd/mkosi
 Source: 
https://github.com/systemd/mkosi/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
-#PATCH-FIX-UPSTREAM 109.patch boo#1049997 sebix+novell@sebix.at -- fixes 
opensuse specific calls
-Patch0: https://github.com/systemd/mkosi/pull/109.patch
 BuildRequires:  python3 >= 3.5
+BuildRequires:  python3-setuptools
 Requires:   python3 >= 3.5
 Requires:   squashfs
 Recommends: btrfs-progs
@@ -41,6 +40,7 @@
 Recommends: dnf
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 ExclusiveArch:  x86_64
+BuildArch:  noarch
 
 %description
 A fancy wrapper around dnf --installroot, debootstrap, pacstrap and zypper that
@@ -53,25 +53,26 @@
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
-# not required
+python3 setup.py build
 
 %install
-install -Dpt %{buildroot}%{_bindir}/ mkosi
+python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
 
 %check
 %{buildroot}%{_bindir}/mkosi -h
 
 %files
 %defattr(-,root,root)
-%doc README
+%doc README.md
 %if 0%{?leap_version} >= 420200 || 0%{?suse_version} > 1320
 %license LICENSE
 %else
 %doc LICENSE
 %endif
 %{_bindir}/%{name}
+%doc mkosi.default
+%{python3_sitelib}/
 
 %changelog

++ mkosi-3.tar.gz -> mkosi-4.tar.gz ++
 2694 lines of diff (skipped)




commit smplayer for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package smplayer for openSUSE:Factory 
checked in at 2018-02-20 17:55:08

Comparing /work/SRC/openSUSE:Factory/smplayer (Old)
 and  /work/SRC/openSUSE:Factory/.smplayer.new (New)


Package is "smplayer"

Tue Feb 20 17:55:08 2018 rev:29 rq:578029 version:18.2.2

Changes:

--- /work/SRC/openSUSE:Factory/smplayer/smplayer.changes2018-02-01 
21:31:50.326196036 +0100
+++ /work/SRC/openSUSE:Factory/.smplayer.new/smplayer.changes   2018-02-20 
17:55:18.797950182 +0100
@@ -1,0 +2,15 @@
+Mon Feb 19 11:29:11 UTC 2018 - sor.ale...@meowr.ru
+
+- Update to version 18.2.2:
+  * The options to select the preferred number of track for audio
+and subtitles are back.
+  * Add an option in Preferences -> Subtitles to select the opacity
+of the background of the subtitles.
+  * Prevent the skins to be added to the themes combobox if the
+user and the config directories are the same (happens in the
+portable version).
+  * Disable the screenshot actions if the screenshot directory is
+set to an empty string.
+  * The option Open -> URL can now also load YouTube playlists.
+
+---

Old:

  smplayer-18.2.0.tar.bz2

New:

  smplayer-18.2.2.tar.bz2



Other differences:
--
++ smplayer.spec ++
--- /var/tmp/diff_new_pack.EdTeYj/_old  2018-02-20 17:55:20.953872554 +0100
+++ /var/tmp/diff_new_pack.EdTeYj/_new  2018-02-20 17:55:20.957872410 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   smplayer
-Version:18.2.0
+Version:18.2.2
 Release:0
 Summary:Complete frontend for MPV
 License:GPL-2.0+

++ smplayer-18.2.0.tar.bz2 -> smplayer-18.2.2.tar.bz2 ++
 91558 lines of diff (skipped)




commit wxWidgets-3_2 for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package wxWidgets-3_2 for openSUSE:Factory 
checked in at 2018-02-20 17:54:50

Comparing /work/SRC/openSUSE:Factory/wxWidgets-3_2 (Old)
 and  /work/SRC/openSUSE:Factory/.wxWidgets-3_2.new (New)


Package is "wxWidgets-3_2"

Tue Feb 20 17:54:50 2018 rev:4 rq:577995 version:3.1.1.g3

Changes:

--- /work/SRC/openSUSE:Factory/wxWidgets-3_2/wxGTK3-3_2.changes 2018-01-28 
00:39:52.980239569 +0100
+++ /work/SRC/openSUSE:Factory/.wxWidgets-3_2.new/wxGTK3-3_2.changes
2018-02-20 17:54:52.874883596 +0100
@@ -1,0 +2,22 @@
+Mon Feb 19 00:24:12 UTC 2018 - jeng...@inai.de
+
+- Update to new upstream release 3.1.1
+  * wxRibbonButtonBar::DeleteButton() now deletes and not just
+removes the button.
+  * Using invalid flags with wxBoxSizer or wxGridSizer items now
+triggers asserts
+  * wxWS_EX_VALIDATE_RECURSIVELY is now the default behaviour.
+  * wxListCtrl::HasCheckboxes() and EnableCheckboxes(), which
+were added in 3.1.0, have been renamed to HasCheckBoxes and
+EnableCheckBoxes respectively for consistency with wxCheckBox
+naming.
+  * wxZipOutputStream will now automatically convert filenames to
+UTF-8, if the wxMBConv used when calling the constructor
+supports UTF-8 encoding.
+
+---
+Sat Feb 17 10:31:37 UTC 2018 - martin.koeg...@chello.at
+
+- Update to 3.1.1-rc (3.1.1~2807)
+
+---
wxQt-3_2.changes: same change
wxWidgets-3_2.changes: same change

Old:

  wxWidgets-3.1.1~2640.tar.xz

New:

  wxWidgets-3.1.1.g3.tar.xz



Other differences:
--
++ wxGTK3-3_2.spec ++
--- /var/tmp/diff_new_pack.eh1h4j/_old  2018-02-20 17:55:09.502284892 +0100
+++ /var/tmp/diff_new_pack.eh1h4j/_new  2018-02-20 17:55:09.506284748 +0100
@@ -20,8 +20,8 @@
 %define base_name wxWidgets-3_2
 %define tarball_name wxWidgets
 %define variant suse
-%define sonum 5
-Version:3.1.1~2640
+%define sonum 6
+Version:3.1.1.g3
 Release:0
 %define wx_minor 3.1
 %define wx_micro 3.1.1

wxQt-3_2.spec: same change
++ wxWidgets-3_2.spec ++
--- /var/tmp/diff_new_pack.eh1h4j/_old  2018-02-20 17:55:09.582282011 +0100
+++ /var/tmp/diff_new_pack.eh1h4j/_new  2018-02-20 17:55:09.582282011 +0100
@@ -20,8 +20,8 @@
 %define base_name wxWidgets-3_2
 %define tarball_name wxWidgets
 %define variant suse
-%define sonum 5
-Version:3.1.1~2640
+%define sonum 6
+Version:3.1.1.g3
 Release:0
 %define wx_minor 3.1
 %define wx_micro 3.1.1

++ _service ++
--- /var/tmp/diff_new_pack.eh1h4j/_old  2018-02-20 17:55:09.662279131 +0100
+++ /var/tmp/diff_new_pack.eh1h4j/_new  2018-02-20 17:55:09.666278987 +0100
@@ -3,7 +3,7 @@
git
git://github.com/wxWidgets/wxWidgets
master
-   3.1.1~@TAG_OFFSET@
+   3.1.1.g@TAG_OFFSET@
v(.*)



++ soversion.diff ++
--- /var/tmp/diff_new_pack.eh1h4j/_old  2018-02-20 17:55:09.694277979 +0100
+++ /var/tmp/diff_new_pack.eh1h4j/_new  2018-02-20 17:55:09.698277835 +0100
@@ -15,7 +15,8 @@
wxWidgets 3.0.2: libwx_*-suse.so.1
wxWidgets 3.1.0~g61143(dp only): libwx_*-suse.so.2
wxWidgets 3.1.0.g2244(dp only): libwx_*-suse.so.4
-   wxWidgets 3.1.1~2640(dp only): libwx_*-suse.so.5
+   wxWidgets 3.1.1~2640: libwx_*-suse.so.5
+   wxWidgets 3.1.1.g3: libwx_*-suse.so.6
 
 Since SOVERLINUX does not support TWOSYMLINKS=0, patch and use
 a bit on SOVERSOLARIS instead.
@@ -50,7 +51,7 @@
  @COND_USE_SOVERCYGWIN_1_USE_SOVERSION_1@dll___targetsuf3 = -1.$(SO_SUFFIX)
  @COND_USE_SOVERSION_0@dll___targetsuf3 = .$(SO_SUFFIX)
 -@COND_USE_SOVERSION_1_USE_SOVERSOLARIS_1@dll___targetsuf3 = .$(SO_SUFFIX).1
-+@COND_USE_SOVERSION_1_USE_SOVERSOLARIS_1@dll___targetsuf3 = .$(SO_SUFFIX).5
++@COND_USE_SOVERSION_1_USE_SOVERSOLARIS_1@dll___targetsuf3 = .$(SO_SUFFIX).6
  @COND_TOOLKIT_MSW@__RCDEFDIR_p = --include-dir \
  @COND_TOOLKIT_MSW@$(LIBDIRNAME)/wx/include/$(TOOLCHAIN_FULLNAME)
  @COND_wxUSE_LIBTIFF_builtin@__INC_TIFF_BUILD_p_66 \




commit 389-ds for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package 389-ds for openSUSE:Factory checked 
in at 2018-02-20 17:55:15

Comparing /work/SRC/openSUSE:Factory/389-ds (Old)
 and  /work/SRC/openSUSE:Factory/.389-ds.new (New)


Package is "389-ds"

Tue Feb 20 17:55:15 2018 rev:15 rq:578038 version:1.4.0.3

Changes:

--- /work/SRC/openSUSE:Factory/389-ds/389-ds.changes2018-02-09 
15:52:14.073288180 +0100
+++ /work/SRC/openSUSE:Factory/.389-ds.new/389-ds.changes   2018-02-20 
17:55:27.237646294 +0100
@@ -1,0 +2,6 @@
+Mon Feb 19 13:01:04 UTC 2018 - h...@suse.com
+
+- Explicitly generate dirsrv sysconfig file as it is necessary for
+  SLES 15 (bsc#1081324).
+
+---



Other differences:
--
++ 389-ds.spec ++
--- /var/tmp/diff_new_pack.sOjx0z/_old  2018-02-20 17:55:28.157613169 +0100
+++ /var/tmp/diff_new_pack.sOjx0z/_new  2018-02-20 17:55:28.157613169 +0100
@@ -274,6 +274,9 @@
   %{_sbindir}/useradd  -r -g %{user_group} -s /sbin/nologin -r -d %{homedir} 
-c "User for 389 directory server" %{user_group}
 fi
 
+%post
+%fillup_only -n dirsrv
+
 %postun
 output=/dev/null
 # reload to pick up any changes to systemd files




commit python-SQLAlchemy for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package python-SQLAlchemy for 
openSUSE:Factory checked in at 2018-02-20 17:54:38

Comparing /work/SRC/openSUSE:Factory/python-SQLAlchemy (Old)
 and  /work/SRC/openSUSE:Factory/.python-SQLAlchemy.new (New)


Package is "python-SQLAlchemy"

Tue Feb 20 17:54:38 2018 rev:46 rq:577965 version:1.2.3

Changes:

--- /work/SRC/openSUSE:Factory/python-SQLAlchemy/python-SQLAlchemy.changes  
2018-01-29 15:00:40.737491773 +0100
+++ /work/SRC/openSUSE:Factory/.python-SQLAlchemy.new/python-SQLAlchemy.changes 
2018-02-20 17:54:42.747248264 +0100
@@ -1,0 +2,114 @@
+Sun Feb 18 17:09:28 UTC 2018 - a...@gmx.de
+
+- update to version 1.2.3:
+  * orm
++ [orm] [feature] Added new argument
+  attributes.set_attribute.inititator to the
+  attributes.set_attribute() function, allowing an event token
+  received from a listener function to be propagated to subsequent
+  set events.
++ [orm] [bug] Fixed issue in post_update feature where an UPDATE
+  is emitted when the parent object has been deleted but the
+  dependent object is not. This issue has existed for a long time
+  however since 1.2 now asserts rows matched for post_update, this
+  was raising an error.  This change is also backported to: 1.1.16
+  References: #4187
++ [orm] [bug] Fixed regression caused by fix for issue #4116
+  affecting versions 1.2.2 as well as 1.1.15, which had the effect
+  of mis-calculation of the “owning class” of an AssociationProxy
+  as the NoneType class in some declarative mixin/inheritance
+  situations as well as if the association proxy were accessed off
+  of an un-mapped class. The “figure out the owner” logic has been
+  replaced by an in-depth routine that searches through the
+  complete mapper hierarchy assigned to the class or subclass to
+  determine the correct (we hope) match; will not assign the owner
+  if no match is found. An exception is now raised if the proxy is
+  used against an un-mapped instance.  This change is also
+  backported to: 1.1.16 References: #4185
++ [orm] [bug] Fixed bug where the Bundle object did not correctly
+  report upon the primary Mapper object represened by the bundle,
+  if any. An immediate side effect of this issue was that the new
+  selectinload loader strategy wouldn’t work with the horizontal
+  sharding extension.  References: #4175
++ [orm] [bug] Fixed bug in concrete inheritance mapping where
+  user-defined attributes such as hybrid properties that mirror
+  the names of mapped attributes from sibling classes would be
+  overwritten by the mapper as non-accessible at the instance
+  level. Additionally ensured that user-bound descriptors are not
+  implicitly invoked at the class level during the mapper
+  configuration stage.  References: #4188
++ [orm] [bug] Fixed bug where the orm.reconstructor() event helper
+  would not be recognized if it were applied to the __init__()
+  method of the mapped class.  References: #4178
+  * engine
++ [engine] [bug] Fixed bug where events associated with an Engine
+  at the class level would be doubled when the
+  Engine.execution_options() method were used. To achieve this,
+  the semi-private class OptionEngine no longer accepts events
+  directly at the class level and will raise an error; the class
+  only propagates class-level events from its parent
+  Engine. Instance-level events continue to work as before.
+  References: #4181
++ [engine] [bug] The URL object now allows query keys to be
+  specified multiple times where their values will be joined into
+  a list. This is to support the plugins feature documented at
+  CreateEnginePlugin which documents that “plugin” can be passed
+  multiple times. Additionally, the plugin names can be passed to
+  create_engine() outside of the URL using the new
+  create_engine.plugins parameter.  References: #4170
+  * sql
++ [sql] [feature] Added support for Enum to persist the values of
+  the enumeration, rather than the keys, when using a Python
+  pep-435 style enumerated object. The user supplies a callable
+  function that will return the string values to be
+  persisted. This allows enumerations against non-string values to
+  be value-persistable as well. Pull request courtesy Jon Snyder.
+  References: #3906
++ [sql] [bug] Fixed bug where the Enum type wouldn’t handle enum
+  “aliases” correctly, when more than one key refers to the same
+  value. Pull request courtesy Daniel Knell.  References: #4180
+  * postgresql
++ [postgresql] [bug] Added “SSL SYSCALL error: Operation timed
+  out” to the list of messages that trigger a 

commit nsd for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package nsd for openSUSE:Factory checked in 
at 2018-02-20 17:54:54

Comparing /work/SRC/openSUSE:Factory/nsd (Old)
 and  /work/SRC/openSUSE:Factory/.nsd.new (New)


Package is "nsd"

Tue Feb 20 17:54:54 2018 rev:2 rq:577998 version:4.1.19

Changes:

--- /work/SRC/openSUSE:Factory/nsd/nsd.changes  2018-02-16 21:45:13.585888604 
+0100
+++ /work/SRC/openSUSE:Factory/.nsd.new/nsd.changes 2018-02-20 
17:55:11.782202799 +0100
@@ -1,0 +2,5 @@
+Mon Feb 19 10:17:15 UTC 2018 - adam.ma...@suse.de
+
+- Own missing ownership for %_tmpfilesdir
+
+---



Other differences:
--
++ nsd.spec ++
--- /var/tmp/diff_new_pack.BAmTrf/_old  2018-02-20 17:55:13.102155271 +0100
+++ /var/tmp/diff_new_pack.BAmTrf/_new  2018-02-20 17:55:13.106155127 +0100
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define home   %{_localstatedir}/lib/%{name}
 %define configdir  %{_sysconfdir}/%{name}
 %define configfile %{configdir}/nsdc.conf
@@ -27,10 +28,10 @@
 #
 Summary:An authoritative-only domain name server
 #
+#
 License:BSD-3-Clause
 Group:  Productivity/Networking/DNS/Servers
-#
-URL:http://open.nlnetlabs.nl/nsd/
+Url:http://open.nlnetlabs.nl/nsd/
 Source: http://open.nlnetlabs.nl/downloads/nsd/nsd-%{version}.tar.gz
 Source1:nsd.service
 Source2:tmpfiles-nsd.conf
@@ -129,6 +130,7 @@
 %{configdir}/nsd.conf.sample
 %doc contrib/
 %{_unitdir}/nsd.service
+%dir %{_tmpfilesdir}
 %{_tmpfilesdir}/nsd.conf
 %{_sbindir}/rcnsd
 %{_sbindir}/nsd






commit perl-Mojo-RabbitMQ-Client for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package perl-Mojo-RabbitMQ-Client for 
openSUSE:Factory checked in at 2018-02-20 17:54:31

Comparing /work/SRC/openSUSE:Factory/perl-Mojo-RabbitMQ-Client (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Mojo-RabbitMQ-Client.new (New)


Package is "perl-Mojo-RabbitMQ-Client"

Tue Feb 20 17:54:31 2018 rev:5 rq:577953 version:0.1.0

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Mojo-RabbitMQ-Client/perl-Mojo-RabbitMQ-Client.changes
  2017-02-21 13:51:45.576453262 +0100
+++ 
/work/SRC/openSUSE:Factory/.perl-Mojo-RabbitMQ-Client.new/perl-Mojo-RabbitMQ-Client.changes
 2018-02-20 17:54:34.283553018 +0100
@@ -1,0 +2,17 @@
+Sat Feb 17 06:40:40 UTC 2018 - co...@suse.com
+
+- updated to 0.1.0
+   see /usr/share/doc/packages/perl-Mojo-RabbitMQ-Client/Changes
+
+  0.1.0 2018-02-16T10:15:32Z
+- Make Mojo::RabbitMQ::Client::Consumer use promises #23 (@christopherraa)
+- Fix circular includes by #20 (@christopherraa)
+- Start implementing Mojo::Promise, drop support for Mojolicious <7.53
+- Implement DEBUG on Client as suggested in #11
+- Fix early success event from ->publish #16
+- Fix query parameter naming in Publisher
+- Fix missing imports in Publisher #15
+- Fix #14
+- Implement Publisher API #5
+
+---

Old:

  Mojo-RabbitMQ-Client-0.0.9.tar.gz

New:

  Mojo-RabbitMQ-Client-0.1.0.tar.gz



Other differences:
--
++ perl-Mojo-RabbitMQ-Client.spec ++
--- /var/tmp/diff_new_pack.VEyfgQ/_old  2018-02-20 17:54:36.131486479 +0100
+++ /var/tmp/diff_new_pack.VEyfgQ/_new  2018-02-20 17:54:36.131486479 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Mojo-RabbitMQ-Client
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Mojo-RabbitMQ-Client
-Version:0.0.9
+Version:0.1.0
 Release:0
 %define cpan_name Mojo-RabbitMQ-Client
 Summary:Mojo::IOLoop based RabbitMQ client
@@ -33,13 +33,13 @@
 BuildRequires:  perl(File::ShareDir)
 BuildRequires:  perl(List::Util) >= 1.33
 BuildRequires:  perl(Module::Build::Tiny) >= 0.035
-BuildRequires:  perl(Mojolicious) >= 6.10
+BuildRequires:  perl(Mojolicious) >= 7.53
 BuildRequires:  perl(Net::AMQP) >= 0.06
 BuildRequires:  perl(Test::Exception) >= 0.43
 BuildRequires:  perl(Test::More) >= 0.98
 Requires:   perl(File::ShareDir)
 Requires:   perl(List::Util) >= 1.33
-Requires:   perl(Mojolicious) >= 6.10
+Requires:   perl(Mojolicious) >= 7.53
 Requires:   perl(Net::AMQP) >= 0.06
 %{perl_requires}
 # MANUAL BEGIN

++ Mojo-RabbitMQ-Client-0.0.9.tar.gz -> Mojo-RabbitMQ-Client-0.1.0.tar.gz 
++
 2009 lines of diff (skipped)




commit xf86-video-vesa for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package xf86-video-vesa for openSUSE:Factory 
checked in at 2018-02-20 17:53:40

Comparing /work/SRC/openSUSE:Factory/xf86-video-vesa (Old)
 and  /work/SRC/openSUSE:Factory/.xf86-video-vesa.new (New)


Package is "xf86-video-vesa"

Tue Feb 20 17:53:40 2018 rev:15 rq:577290 version:2.4.0

Changes:

--- /work/SRC/openSUSE:Factory/xf86-video-vesa/xf86-video-vesa.changes  
2017-06-04 01:45:39.348347590 +0200
+++ /work/SRC/openSUSE:Factory/.xf86-video-vesa.new/xf86-video-vesa.changes 
2018-02-20 17:53:44.881331863 +0100
@@ -1,0 +2,8 @@
+Fri Feb 16 14:46:06 UTC 2018 - sndir...@suse.com
+
+- Update to version 2.4.0
+  * Nothing terribly exciting, but enough bug fixes to justify a
+release.
+- supersedes u_Enable-DefaultRefresh-by-default.patch
+
+---

Old:

  u_Enable-DefaultRefresh-by-default.patch
  xf86-video-vesa-2.3.4.tar.bz2
  xf86-video-vesa-2.3.4.tar.bz2.sig

New:

  xf86-video-vesa-2.4.0.tar.bz2
  xf86-video-vesa-2.4.0.tar.bz2.sig



Other differences:
--
++ xf86-video-vesa.spec ++
--- /var/tmp/diff_new_pack.SkViHm/_old  2018-02-20 17:53:45.653304066 +0100
+++ /var/tmp/diff_new_pack.SkViHm/_new  2018-02-20 17:53:45.657303922 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package xf86-video-vesa
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   xf86-video-vesa
-Version:2.3.4
+Version:2.4.0
 Release:0
 Summary:Generic VESA video driver for the Xorg X server
 License:MIT
@@ -26,7 +26,6 @@
 Source0:
http://xorg.freedesktop.org/releases/individual/driver/%{name}-%{version}.tar.bz2
 Source1:
http://xorg.freedesktop.org/releases/individual/driver/%{name}-%{version}.tar.bz2.sig
 Source2:%{name}.keyring
-Patch0: u_Enable-DefaultRefresh-by-default.patch
 Patch1: u_Restore-palette-on-LeaveVT.patch
 Patch2: 
u_DPMS-Query-DPMS-capabilites-and-query-current-state-before-changing.patch
 Patch3: u_DPMS-Check-for-broken-DPMSGet.patch
@@ -56,7 +55,6 @@
 
 %prep
 %setup -q
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1

++ xf86-video-vesa-2.3.4.tar.bz2 -> xf86-video-vesa-2.4.0.tar.bz2 ++
 21675 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/xf86-video-vesa-2.3.4/ChangeLog new/xf86-video-vesa-2.4.0/ChangeLog
--- old/xf86-video-vesa-2.3.4/ChangeLog 2015-06-16 18:00:08.0 +0200
+++ new/xf86-video-vesa-2.4.0/ChangeLog 2018-02-15 20:34:14.0 +0100
@@ -1,3 +1,126 @@
+commit 07e4a0f0b3bd6308da2e000c12230b1e171e65a7
+Author: Adam Jackson 
+Date:   Thu Feb 15 14:33:38 2018 -0500
+
+vesa 2.4.0
+
+Signed-off-by: Adam Jackson 
+
+commit f7876ce62c751c9b28d5750e1d01def877e666fb
+Author: Ian Lepore 
+Date:   Wed Jan 31 10:48:09 2018 -0500
+
+Honor Option "NoDDC" correctly
+
+Move xf86CollectOptions before the DDC code so it can actually hear us
+when we ask to disable DDC.
+
+Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=46541
+Signed-off-by: Adam Jackson 
+
+commit 2cb984533fd7a36151bb8be18a63f678a552ad71
+Author: Adam Jackson 
+Date:   Wed Jan 31 10:48:08 2018 -0500
+
+Use VBEFreeVBEInfo not free
+
+A VbeInfoBlock has substructure, just freeing the object will leak.
+Unfortunately VBEFreeVBEInfo does not check for NULL first so we have
+to.
+
+Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=25029
+Signed-off-by: Adam Jackson 
+
+commit 9c4f6c7ab011435a492dd5cb1847bf00f290c219
+Author: Adam Jackson 
+Date:   Wed Jan 31 10:48:07 2018 -0500
+
+Fall back to VGA if the palette API isn't supported
+
+I ported vesa to use the VBE service back in:
+
+commit 55f585a15f42ffe028ff37ea1f63543795dbf56e
+Author: Adam Jackson 
+Date:   Fri Sep 18 17:02:16 2009 -0400
+
+Use VBE palette load, not VGA banging.
+
+I'm reasonably sure that worked on all the hardware I had handy 

commit vacuum-im for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package vacuum-im for openSUSE:Factory 
checked in at 2018-02-20 17:54:12

Comparing /work/SRC/openSUSE:Factory/vacuum-im (Old)
 and  /work/SRC/openSUSE:Factory/.vacuum-im.new (New)


Package is "vacuum-im"

Tue Feb 20 17:54:12 2018 rev:21 rq:576959 version:1.3.0+git1517014020.58ad802c

Changes:

--- /work/SRC/openSUSE:Factory/vacuum-im/vacuum-im.changes  2018-01-03 
13:39:15.832738543 +0100
+++ /work/SRC/openSUSE:Factory/.vacuum-im.new/vacuum-im.changes 2018-02-20 
17:54:20.336055230 +0100
@@ -1,0 +2,6 @@
+Sun Feb 11 15:02:00 UTC 2018 - egdf...@opensuse.org
+
+- use system provided qxtglobalshortcut
+- update source to revision 58ad802cdfb34ef920afdfff9a2627dbd837d38d
+
+---

Old:

  vacuum-im-r4b48e972.tar.xz

New:

  vacuum-im-r58ad802c.tar.xz



Other differences:
--
++ vacuum-im.spec ++
--- /var/tmp/diff_new_pack.VCXfi1/_old  2018-02-20 17:54:22.163989411 +0100
+++ /var/tmp/diff_new_pack.VCXfi1/_new  2018-02-20 17:54:22.167989267 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package vacuum-im
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,8 @@
 
 
 %define sname vacuum
-%define rtime 1512173040
-%define rhash 4b48e972
+%define rtime 1517014020
+%define rhash 58ad802c
 Name:   %{sname}-im
 Version:1.3.0+git%{rtime}.%{rhash}
 Release:0
@@ -42,9 +42,9 @@
 BuildRequires:  libqt5-qtbase-devel
 BuildRequires:  libqt5-qttools-devel
 BuildRequires:  libqt5-qtx11extras-devel
-#BuildRequires:  qxtglobalshortcut-devel
 BuildRequires:  minizip-devel
 BuildRequires:  openssl-devel
+BuildRequires:  qxtglobalshortcut-devel
 BuildRequires:  sqlite3-devel
 BuildRequires:  update-desktop-files
 BuildRequires:  zlib-devel

++ vacuum-im-r4b48e972.tar.xz -> vacuum-im-r58ad802c.tar.xz ++
/work/SRC/openSUSE:Factory/vacuum-im/vacuum-im-r4b48e972.tar.xz 
/work/SRC/openSUSE:Factory/.vacuum-im.new/vacuum-im-r58ad802c.tar.xz differ: 
char 25, line 1




commit thunar for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package thunar for openSUSE:Factory checked 
in at 2018-02-20 17:54:25

Comparing /work/SRC/openSUSE:Factory/thunar (Old)
 and  /work/SRC/openSUSE:Factory/.thunar.new (New)


Package is "thunar"

Tue Feb 20 17:54:25 2018 rev:71 rq:577881 version:1.6.14

Changes:

--- /work/SRC/openSUSE:Factory/thunar/thunar.changes2018-01-13 
21:40:17.918626532 +0100
+++ /work/SRC/openSUSE:Factory/.thunar.new/thunar.changes   2018-02-20 
17:54:28.643756092 +0100
@@ -1,0 +2,16 @@
+Sun Feb 18 12:30:31 UTC 2018 - jeng...@inai.de
+
+- Ensure neutrality of description.
+
+---
+Sat Feb 17 11:48:30 UTC 2018 - seife+...@b1-systems.com
+
+- update to 1.6.14:
+  * Do not translate "Trash" files and folders (bxo#14211)
+  * Crash in thunar_file_is_gfile_ancestor (bxo#14202)
+  * Fix potential buffer overflow (bxo#12444)
+  * Fix crash on unavailable file move copy (bxo#14056)
+  * Translation updates
+- partly spec-cleaner fixes
+
+---

Old:

  Thunar-1.6.13.tar.bz2

New:

  Thunar-1.6.14.tar.bz2



Other differences:
--
++ thunar.spec ++
--- /var/tmp/diff_new_pack.Sc5s95/_old  2018-02-20 17:54:30.335695170 +0100
+++ /var/tmp/diff_new_pack.Sc5s95/_new  2018-02-20 17:54:30.339695026 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package thunar
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,9 +18,9 @@
 
 %define libname libthunarx-2-0
 Name:   thunar
-Version:1.6.13
+Version:1.6.14
 Release:0
-Summary:Fast and Easy to Use File Manager for the Xfce Desktop 
Environment
+Summary:File Manager for the Xfce Desktop Environment
 License:GPL-2.0+
 Group:  Productivity/File utilities
 Url:http://thunar.xfce.org/
@@ -33,6 +33,7 @@
 BuildRequires:  fdupes
 BuildRequires:  intltool
 BuildRequires:  perl-XML-Parser
+BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
 BuildRequires:  xfce4-dev-tools
 BuildRequires:  xfconf
@@ -64,14 +65,12 @@
 Recommends: tumbler
 Provides:   thunar-doc = %{version}
 Obsoletes:  thunar-doc <= 1.2.3
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-Thunar a file manager for the Xfce desktop environment which has been designed
-from the ground up to be fast and easy to use. It provides a clean, intuitive,
-and fully accessible user interface and does not include any confusing or
-useless options by default. Thunar is fast and responsive with good startup and
-folder load times.
+Thunar is a file manager for the Xfce desktop environment. Its
+functionality can be extended through plugins. Thunar can also be
+extended by writing scripts to be placed in the context menu for
+various file types.
 
 %package -n %{libname}
 Summary:Thunar Extension Library
@@ -140,9 +139,7 @@
 %fdupes %{buildroot}%{_datadir}
 
 %post -n %{libname} -p /sbin/ldconfig
-
 %postun -n %{libname} -p /sbin/ldconfig
-
 %post
 %desktop_database_post
 %icon_theme_cache_post
@@ -152,7 +149,6 @@
 %icon_theme_cache_postun
 
 %files
-%defattr(-,root,root)
 %doc README NEWS ChangeLog COPYING AUTHORS FAQ HACKING THANKS TODO 
docs/README.*
 %dir %{_sysconfdir}/xdg/Thunar
 %config %{_sysconfdir}/xdg/Thunar/uca.xml
@@ -176,15 +172,13 @@
 %{_datadir}/pixmaps/Thunar
 %{_datadir}/xfce4/panel/plugins/thunar-tpa.desktop
 %{_datadir}/Thunar/sendto
-%doc %{_mandir}/man1/Thunar.1*
-%doc %{_mandir}/man1/thunar.1*
+%{_mandir}/man1/Thunar.1*
+%{_mandir}/man1/thunar.1*
 
 %files -n %{libname}
-%defattr(-,root,root)
 %{_libdir}/libthunarx-2.so.*
 
 %files devel
-%defattr(-,root,root)
 # temporarily disabled
 #%doc %{_datadir}/gtk-doc/html/thunarx
 %dir %{_includedir}/thunarx-2
@@ -194,6 +188,5 @@
 %{_libdir}/pkgconfig/thunarx-2.pc
 
 %files lang -f Thunar.lang
-%defattr(-,root,root)
 
 %changelog

++ Thunar-1.6.13.tar.bz2 -> Thunar-1.6.14.tar.bz2 ++
 9886 lines of diff (skipped)




commit exo for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package exo for openSUSE:Factory checked in 
at 2018-02-20 17:54:23

Comparing /work/SRC/openSUSE:Factory/exo (Old)
 and  /work/SRC/openSUSE:Factory/.exo.new (New)


Package is "exo"

Tue Feb 20 17:54:23 2018 rev:57 rq:577660 version:0.12.0

Changes:

--- /work/SRC/openSUSE:Factory/exo/exo.changes  2017-12-09 20:33:52.023318797 
+0100
+++ /work/SRC/openSUSE:Factory/.exo.new/exo.changes 2018-02-20 
17:54:25.599865694 +0100
@@ -1,0 +2,12 @@
+Sat Feb 17 12:07:54 UTC 2018 - seife+...@b1-systems.com
+
+- update to 0.12.0 (Stable Release)
+  * Add google-chrome-stable binary for the google-chrome helper
+(bxo#13876)
+  * Requirements updated: GTK 2.24, GTK 3.22, GLib 2.42,
+libxfce4ui 4.12, libxfce4util 4.12
+  * Translation updates
+- add exo-revert-gnome-3.22-req.diff for Leap < 15 to allow build
+- spec-cleaner suggestions (but not the braindead ones)
+
+---

Old:

  exo-0.11.5.tar.bz2

New:

  exo-0.12.0.tar.bz2
  exo-revert-gnome-3.22-req.diff



Other differences:
--
++ exo.spec ++
--- /var/tmp/diff_new_pack.ZN320L/_old  2018-02-20 17:54:26.803822343 +0100
+++ /var/tmp/diff_new_pack.ZN320L/_new  2018-02-20 17:54:26.807822199 +0100
@@ -19,31 +19,35 @@
 %define libname_gtk2 libexo-1-0
 %define libname_gtk3 libexo-2-0
 Name:   exo
-Version:0.11.5
+Version:0.12.0
 Release:0
 Summary:Application Development Library for Xfce
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0+ AND LGPL-2.1+
 Group:  Development/Libraries/C and C++
 Url:http://docs.xfce.org/xfce/exo/start
-Source0:
http://archive.xfce.org/src/xfce/exo/0.11/%{name}-%{version}.tar.bz2
+Source0:
http://archive.xfce.org/src/xfce/exo/0.12/%{name}-%{version}.tar.bz2
 # icons taken from tango-icon-theme 0.8.90
 Source1:%{name}-icons.tar.bz2
+# for building on Leap 42.3 - the requirements have bumped, but the code is 
identical to 0.11.5
+# which was working with gnome 3.20
+Patch1: exo-revert-gnome-3.22-req.diff
 BuildRequires:  fdupes
 BuildRequires:  intltool
 BuildRequires:  perl-URI
+BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(dbus-1)
 BuildRequires:  pkgconfig(glib-2.0) >= 2.42
 BuildRequires:  pkgconfig(gtk+-2.0) >= 2.24
+# >= 3.22
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.20
 BuildRequires:  pkgconfig(gtk-doc)
 BuildRequires:  pkgconfig(libstartup-notification-1.0)
 BuildRequires:  pkgconfig(libxfce4ui-1) >= 4.12.0
 BuildRequires:  pkgconfig(libxfce4ui-2) >= 4.12.0
-BuildRequires:  pkgconfig(libxfce4util-1.0)
+BuildRequires:  pkgconfig(libxfce4util-1.0) >= 4.12.0
 # Prevent dependency cycle exo -> libxfce4ui-devel -> libxfce4ui-1-0 -> 
exo-tools
 #!BuildIgnore:  exo-tools
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 Exo is an extension library to Xfce which is targeted at application
@@ -51,7 +55,7 @@
 
 %package tools
 Summary:Tools for exo
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0+ AND LGPL-2.1+
 Group:  System/GUI/XFCE
 Provides:   exo:%{_bindir}/exo-csource
 Provides:   exo:%{_bindir}/exo-desktop-item-edit
@@ -63,7 +67,7 @@
 
 %package data
 Summary:Helpers Data for exo
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0+ AND LGPL-2.1+
 Group:  System/GUI/XFCE
 Requires:   %{name}-branding = %{version}
 Requires:   %{name}-helpers = %{version}
@@ -73,7 +77,7 @@
 
 %package helpers
 Summary:Helpers for exo
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0+ AND LGPL-2.1+
 Group:  System/GUI/XFCE
 
 %description helpers
@@ -81,7 +85,7 @@
 
 %package -n %{libname_gtk2}
 Summary:Application Development Library for Xfce
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0+ AND LGPL-2.1+
 Group:  System/Libraries
 Requires:   %{name}-branding = %{version}
 # >= because of crazy rpmlint stuff
@@ -100,7 +104,7 @@
 
 %package -n %{libname_gtk3}
 Summary:Application Development Library for Xfce
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0+ AND LGPL-2.1+
 Group:  System/Libraries
 Requires:   %{name}-branding = %{version}
 Requires:   %{name}-data >= %{version}
@@ -118,7 +122,7 @@
 
 %package devel
 Summary:Development Files for exo
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0+ AND LGPL-2.1+
 Group:  Development/Libraries/C and C++
 Requires:   %{libname_gtk2} = %{version}
 Requires:   %{libname_gtk3} = %{version}
@@ -135,7 +139,7 @@
 Supplements:

commit xfce4-panel-plugin-timer for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package xfce4-panel-plugin-timer for 
openSUSE:Factory checked in at 2018-02-20 17:54:20

Comparing /work/SRC/openSUSE:Factory/xfce4-panel-plugin-timer (Old)
 and  /work/SRC/openSUSE:Factory/.xfce4-panel-plugin-timer.new (New)


Package is "xfce4-panel-plugin-timer"

Tue Feb 20 17:54:20 2018 rev:20 rq:577659 version:1.7.0

Changes:

--- 
/work/SRC/openSUSE:Factory/xfce4-panel-plugin-timer/xfce4-panel-plugin-timer.changes
2014-06-06 14:36:47.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.xfce4-panel-plugin-timer.new/xfce4-panel-plugin-timer.changes
   2018-02-20 17:54:23.259949948 +0100
@@ -1,0 +2,12 @@
+Sat Feb 17 13:22:19 UTC 2018 - seife+...@b1-systems.com
+
+- update to version 1.7.0
+  * port to GTK+3
+  * new icon (bxo #13517)
+  * add "keep above" for Beep dialog (bxo#13514)
+  * when paused show all menu timers (bxo#13516)
+  * small UI improvements (bxo#13515)
+  * translation updates
+- package NEWS file instead of huge ChangeLog
+
+---
@@ -6,0 +19 @@
+

Old:

  xfce4-timer-plugin-1.6.0.tar.bz2

New:

  xfce4-timer-plugin-1.7.0.tar.bz2



Other differences:
--
++ xfce4-panel-plugin-timer.spec ++
--- /var/tmp/diff_new_pack.ZayVyT/_old  2018-02-20 17:54:24.667899252 +0100
+++ /var/tmp/diff_new_pack.ZayVyT/_new  2018-02-20 17:54:24.671899108 +0100
@@ -16,25 +16,25 @@
 #
 
 
-%define panel_version 4.8.0
+%define panel_version 4.12.0
 %define plugin_name xfce4-timer-plugin
 
 Name:   xfce4-panel-plugin-timer
-Version:1.6.0
+Version:1.7.0
 Release:0
 Summary:Alarm Clock Plugin for the Xfce Panel
 License:GPL-2.0+
 Group:  System/GUI/XFCE
 Url:
http://goodies.xfce.org/projects/panel-plugins/xfce4-timer-plugin
-Source0:
http://archive.xfce.org/src/panel-plugins/%{plugin_name}/1.6/%{plugin_name}-%{version}.tar.bz2
+Source0:
http://archive.xfce.org/src/panel-plugins/%{plugin_name}/1.7/%{plugin_name}-%{version}.tar.bz2
 BuildRequires:  fdupes
 BuildRequires:  intltool
 Recommends: %{name}-lang = %{version}
-BuildRequires:  pkgconfig(gthread-2.0)
-BuildRequires:  pkgconfig(gtk+-2.0)
-BuildRequires:  pkgconfig(libxfce4panel-1.0)
-BuildRequires:  pkgconfig(libxfce4ui-1)
-BuildRequires:  pkgconfig(libxfce4util-1.0)
+BuildRequires:  pkgconfig(gthread-2.0) >= 2.4.0
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.20.0
+BuildRequires:  pkgconfig(libxfce4panel-2.0) >= %{panel_version}
+BuildRequires:  pkgconfig(libxfce4ui-2) >= 4.12.0
+BuildRequires:  pkgconfig(libxfce4util-1.0) >= 4.12.0
 Requires:   xfce4-panel >= %{panel_version}
 Recommends: %{name}-lang = %{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -54,6 +54,7 @@
 
 %install
 %make_install
+rm -fv %{buildroot}%{_libdir}/xfce4/panel/plugins/*.la
 
 %find_lang %{plugin_name} %{name}.lang %{?no_lang_C}
 
@@ -67,10 +68,10 @@
 
 %files
 %defattr(-,root,root)
-%doc AUTHORS ChangeLog COPYING README TODO
-%{_libexecdir}/xfce4/panel-plugins/xfce4-timer
-%{_datadir}/xfce4/panel-plugins/xfce4-timer.desktop
-%{_datadir}/icons/hicolor/*/apps/xfce4-timer.png
+%doc AUTHORS NEWS COPYING README TODO
+%{_libdir}/xfce4/panel/plugins/libxfcetimer.so
+%{_datadir}/icons/hicolor/*/*/xfce4-timer-plugin.*
+%{_datadir}/xfce4/panel/plugins/xfce4-timer-plugin.desktop
 
 %files lang -f %{name}.lang
 

++ xfce4-timer-plugin-1.6.0.tar.bz2 -> xfce4-timer-plugin-1.7.0.tar.bz2 
++
 68496 lines of diff (skipped)




commit java-11-openjdk for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package java-11-openjdk for openSUSE:Factory 
checked in at 2018-02-20 17:56:28

Comparing /work/SRC/openSUSE:Factory/java-11-openjdk (Old)
 and  /work/SRC/openSUSE:Factory/.java-11-openjdk.new (New)


Package is "java-11-openjdk"

Tue Feb 20 17:56:28 2018 rev:2 rq:578271 version:11.0.0.0~1

Changes:

--- /work/SRC/openSUSE:Factory/java-11-openjdk/java-11-openjdk.changes  
2018-01-30 15:45:10.776431506 +0100
+++ /work/SRC/openSUSE:Factory/.java-11-openjdk.new/java-11-openjdk.changes 
2018-02-20 17:57:59.844151454 +0100
@@ -1,0 +2,12 @@
+Mon Feb 19 05:07:10 UTC 2018 - fst...@suse.com
+
+- Update to upstream tag jdk-11+1
+- Removed patches:
+  * JDK-8194739-zero.patch
+  * aarch64-form_address.patch
++ Integrated upstream
+- Modified patch:
+  * system-pcsclite.patch
++ Rediff to changed context
+
+---

Old:

  JDK-8194739-zero.patch
  aarch64-form_address.patch
  e321560ac819.tar.bz2

New:

  dfa46cfe5634.tar.bz2



Other differences:
--
++ java-11-openjdk.spec ++
--- /var/tmp/diff_new_pack.dhfcak/_old  2018-02-20 17:58:03.808008730 +0100
+++ /var/tmp/diff_new_pack.dhfcak/_new  2018-02-20 17:58:03.812008586 +0100
@@ -1,5 +1,5 @@
 #
-# spec file for package java-11-openjdk
+# spec file for package java
 #
 # Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
@@ -33,10 +33,10 @@
 %global updatever   0
 %global patchver0
 %global datever 2018-03-20
-%global buildver0
+%global buildver1
 %global hg_project  jdk
 %global hg_repository   jdk
-%global hg_revision e321560ac819
+%global hg_revision dfa46cfe5634
 %global icedtea_sound_version 1.0.1
 %global java_atk_wrapper_version 0.33.2
 # priority must be 6 digits in total
@@ -128,7 +128,7 @@
 Summary:OpenJDK %{featurever} Runtime Environment
 License:Apache-1.1 AND Apache-2.0 AND GPL-1.0+ AND GPL-2.0 AND 
GPL-2.0-with-classpath-exception AND LGPL-2.0 AND MPL-1.0 AND MPL-1.1 AND 
SUSE-Public-Domain AND W3C
 Group:  Development/Languages/Java
-URL:http://openjdk.java.net/
+Url:http://openjdk.java.net/
 # Sources from upstream OpenJDK project.
 Source0:
http://hg.openjdk.java.net/%{hg_project}/%{hg_repository}/archive/%{hg_revision}.tar.bz2
 # Accessibility support
@@ -181,8 +181,6 @@
 Patch105:   boot_jdk_version.patch
 #
 Patch200:   ppc_stack_overflow_fix.patch
-Patch201:   JDK-8194739-zero.patch
-Patch202:   aarch64-form_address.patch
 #
 Patch301:   bootcycle_jobs.patch
 Patch302:   disable-doclint-by-default.patch
@@ -453,8 +451,6 @@
 %patch105 -p1
 
 %patch200 -p1
-%patch201 -p1
-%patch202 -p1
 
 %patch301 -p1
 %patch302 -p1
@@ -522,10 +518,6 @@
 EXTRA_CPP_FLAGS="$EXTRA_CPP_FLAGS -Wno-error -std=gnu++98 
-fno-delete-null-pointer-checks -fno-lifetime-dse"
 %endif
 
-(cd make/autoconf
- bash ./autogen.sh
-)
-
 mkdir -p %{buildoutputdir}
 
 pushd %{buildoutputdir}
@@ -790,32 +782,20 @@
 update-alternatives \
   --install %{_bindir}/java java %{jrebindir}/java %{priority} \
   --slave %{_jvmdir}/jre jre %{_jvmdir}/%{jrelnk} \
-  --slave %{_bindir}/idlj idlj %{jrebindir}/idlj \
   --slave %{_bindir}/jjs jjs %{jrebindir}/jjs \
   --slave %{_bindir}/keytool keytool %{jrebindir}/keytool \
-  --slave %{_bindir}/orbd orbd %{jrebindir}/orbd \
   --slave %{_bindir}/rmid rmid %{jrebindir}/rmid \
   --slave %{_bindir}/rmiregistry rmiregistry %{jrebindir}/rmiregistry \
-  --slave %{_bindir}/servertool servertool %{jrebindir}/servertool \
-  --slave %{_bindir}/tnameserv tnameserv %{jrebindir}/tnameserv \
   --slave %{_mandir}/man1/java.1$ext java.1$ext \
   %{_mandir}/man1/java-%{sdklnk}.1$ext \
-  --slave %{_mandir}/man1/idlj.1$ext idlj.1$ext \
-  %{_mandir}/man1/idlj-%{sdklnk}.1$ext \
   --slave %{_mandir}/man1/jjs.1$ext jjs.1$ext \
   %{_mandir}/man1/jjs-%{sdklnk}.1$ext \
   --slave %{_mandir}/man1/keytool.1$ext keytool.1$ext \
   %{_mandir}/man1/keytool-%{sdklnk}.1$ext \
-  --slave %{_mandir}/man1/orbd.1$ext orbd.1$ext \
-  %{_mandir}/man1/orbd-%{sdklnk}.1$ext \
   --slave %{_mandir}/man1/rmid.1$ext rmid.1$ext \
   %{_mandir}/man1/rmid-%{sdklnk}.1$ext \
   --slave %{_mandir}/man1/rmiregistry.1$ext rmiregistry.1$ext \
-  %{_mandir}/man1/rmiregistry-%{sdklnk}.1$ext \
-  --slave %{_mandir}/man1/servertool.1$ext servertool.1$ext \
-  %{_mandir}/man1/servertool-%{sdklnk}.1$ext \
-  --slave %{_mandir}/man1/tnameserv.1$ext tnameserv.1$ext \
-  %{_mandir}/man1/tnameserv-%{sdklnk}.1$ext
+  %{_mandir}/man1/rmiregistry-%{sdklnk}.1$ext
 
 update-alternatives \
   --install %{_jvmdir}/jre-openjdk \
@@ -899,12 +879,8 @@
   --slave %{_bindir}/jstatd jstatd 

commit imgp for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package imgp for openSUSE:Factory checked in 
at 2018-02-20 17:56:32

Comparing /work/SRC/openSUSE:Factory/imgp (Old)
 and  /work/SRC/openSUSE:Factory/.imgp.new (New)


Package is "imgp"

Tue Feb 20 17:56:32 2018 rev:3 rq:578273 version:2.5

Changes:

--- /work/SRC/openSUSE:Factory/imgp/imgp.changes2017-10-13 
14:19:31.591156447 +0200
+++ /work/SRC/openSUSE:Factory/.imgp.new/imgp.changes   2018-02-20 
17:58:05.951931536 +0100
@@ -1,0 +2,8 @@
+Tue Feb 20 07:50:48 UTC 2018 - aloi...@gmx.com
+
+- Update to version 2.5
+  * New option --nn to use nearest neighbour interpolation for PNG
+files
+  * Identify Multi Picture Object (MPO) files
+
+---

Old:

  imgp-2.4.1.tar.gz

New:

  imgp-2.5.tar.gz



Other differences:
--
++ imgp.spec ++
--- /var/tmp/diff_new_pack.jNsrQU/_old  2018-02-20 17:58:06.847899276 +0100
+++ /var/tmp/diff_new_pack.jNsrQU/_new  2018-02-20 17:58:06.847899276 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package imgp
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   imgp
-Version:2.4.1
+Version:2.5
 Release:0
 Summary:Image resizer and rotator
 License:GPL-3.0+
@@ -86,21 +86,18 @@
 install -m0644 auto-completion/zsh/_%{name} -t 
%{buildroot}%{_datadir}/zsh/site-functions
 
 %files
-%defattr(-,root,root)
-%doc CHANGELOG LICENSE README.md
+%doc CHANGELOG README.md
+%license LICENSE
 %{_bindir}/%{name}
 %{_mandir}/man1/%{name}.1%{ext_man}
 
 %files bash-completion
-%defattr(-,root,root)
 %{_datadir}/bash-completion/completions/%{name}-completion.bash
 
 %files fish-completion
-%defattr(-,root,root)
 %{_datadir}/fish/completions/%{name}.fish
 
 %files zsh-completion
-%defattr(-,root,root)
 %{_datadir}/zsh/site-functions/_%{name}
 
 %changelog

++ imgp-2.4.1.tar.gz -> imgp-2.5.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/imgp-2.4.1/CHANGELOG new/imgp-2.5/CHANGELOG
--- old/imgp-2.4.1/CHANGELOG2017-08-29 17:50:07.0 +0200
+++ new/imgp-2.5/CHANGELOG  2018-02-19 04:29:45.0 +0100
@@ -1,3 +1,12 @@
+imgp v2.5
+2018-02-19
+
+What's in?
+- New option `--nn` to use nearest neighbour interpolation for PNG files
+- Identify Multi Picture Object (MPO) files
+
+---
+
 imgp v2.4.1
 2017-08-29
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/imgp-2.4.1/README.md new/imgp-2.5/README.md
--- old/imgp-2.4.1/README.md2017-08-29 17:50:07.0 +0200
+++ new/imgp-2.5/README.md  2018-02-19 04:29:45.0 +0100
@@ -3,8 +3,10 @@
 
 https://github.com/jarun/imgp/releases/latest;>https://img.shields.io/github/release/jarun/imgp.svg?maxAge=600; 
alt="Latest release" />
 https://aur.archlinux.org/packages/imgp;>https://img.shields.io/aur/version/imgp.svg?maxAge=600; alt="AUR" />
-https://packages.debian.org/search?keywords=imgp=names=1;>https://img.shields.io/badge/debian-9+-blue.svg?maxAge=2592000; 
alt="Debian Strech+" />
-http://packages.ubuntu.com/search?keywords=imgp=names=1;>https://img.shields.io/badge/ubuntu-17.04+-blue.svg?maxAge=2592000; 
alt="Ubuntu Zesty+" />
+https://github.com/jarun/homebrew-imgp;>https://img.shields.io/badge/homebrew-TAP-blue.svg?maxAge=2592000; 
alt="Homebrew TAP" />
+https://packages.debian.org/search?keywords=imgp=names=1;>https://img.shields.io/badge/debian-9+-blue.svg?maxAge=2592000; 
alt="Debian Stretch+" />
+https://packages.ubuntu.com/search?keywords=imgp=names=1;>https://img.shields.io/badge/ubuntu-17.04+-blue.svg?maxAge=2592000; 
alt="Ubuntu Zesty+" />
+https://launchpad.net/~twodopeshaggy/+archive/ubuntu/jarun/;>https://img.shields.io/badge/ubuntu-PPA-blue.svg?maxAge=2592000; 
alt="Ubuntu PPA" />
 https://github.com/jarun/imgp/blob/master/LICENSE;>https://img.shields.io/badge/license-GPLv3-yellow.svg?maxAge=2592000; 
alt="License" />
 
 
@@ -12,15 +14,19 @@
 https://asciinema.org/a/e5qa0mipgg23v70hdn6i99b8q;>https://asciinema.org/a/e5qa0mipgg23v70hdn6i99b8q.png; 
alt="imgp_asciicast" width="734"/>
 
 
-`imgp` is a command line image resizer and rotator for JPEG and PNG images. If 
you have tons of images you want to resize adaptively to a screen resolution or 
rotate by an angle using a single command, `imgp` is the utility for you. It 
can save a lot on storage too.
+Watch imgp 

commit rmt-server for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package rmt-server for openSUSE:Factory 
checked in at 2018-02-20 17:56:40

Comparing /work/SRC/openSUSE:Factory/rmt-server (Old)
 and  /work/SRC/openSUSE:Factory/.rmt-server.new (New)


Package is "rmt-server"

Tue Feb 20 17:56:40 2018 rev:5 rq:578277 version:0.0.3

Changes:

--- /work/SRC/openSUSE:Factory/rmt-server/rmt-server.changes2018-02-14 
10:51:22.110231256 +0100
+++ /work/SRC/openSUSE:Factory/.rmt-server.new/rmt-server.changes   
2018-02-20 17:58:19.47962 +0100
@@ -1,0 +2,17 @@
+Fri Feb 16 11:20:33 UTC 2018 - tmunta...@suse.com
+
+- Use correct service for systemd timers
+
+---
+Fri Feb 16 09:44:26 UTC 2018 - tschm...@suse.com
+
+- RMT on SLE12 also uses ruby 2.5
+  - Removed use-ruby-2.4-in-rails.patch and use-ruby-2.4-in-rmt-cli.patch as
+they are no longer needed.
+
+---
+Wed Feb 14 18:19:19 UTC 2018 - tmunta...@suse.com
+
+- Fixed systemd timers for SLES 12 and Leap
+
+---

Old:

  use-ruby-2.4-in-rails.patch
  use-ruby-2.4-in-rmt-cli.patch

New:

  rmt-server-mirror-sles12.timer
  rmt-server-sync-sles12.timer



Other differences:
--
++ rmt-server.spec ++
--- /var/tmp/diff_new_pack.AUyNas/_old  2018-02-20 17:58:20.847395208 +0100
+++ /var/tmp/diff_new_pack.AUyNas/_new  2018-02-20 17:58:20.855394920 +0100
@@ -16,8 +16,8 @@
 #
 
 
-%if (0%{?suse_version} > 0 && 0%{?suse_version} <= 1320) || (0%{?sle_version} 
> 0 && 0%{?sle_version} <= 120300)
-%define use_ruby_2_4 1
+%if 0%{?suse_version} == 1315
+%define is_sle_12_family 1
 %endif
 
 %define app_dir /usr/share/rmt/
@@ -48,39 +48,28 @@
 Source9:rmt.service
 Source10:   rmt.target
 Source11:   rmt-migration.service
+Source12:   rmt-server-sync-sles12.timer
+Source13:   rmt-server-mirror-sles12.timer
 
-Patch0: use-ruby-2.4-in-rmt-cli.patch
-Patch1: use-ruby-2.4-in-rails.patch
-Patch2: use-ruby-2.5-in-rmt-cli.patch
-Patch3: use-ruby-2.5-in-rails.patch
+Patch0: use-ruby-2.5-in-rmt-cli.patch
+Patch1: use-ruby-2.5-in-rails.patch
 
+BuildRequires:  fdupes
 BuildRequires:  gcc
 BuildRequires:  libcurl-devel
 BuildRequires:  libffi-devel
 BuildRequires:  libmysqlclient-devel
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
-BuildRequires:  systemd
-%if 0%{?use_ruby_2_4}
-BuildRequires:  ruby2.4
-BuildRequires:  ruby2.4-devel
-BuildRequires:  ruby2.4-rubygem-bundler
-%else
 BuildRequires:  ruby2.5
 BuildRequires:  ruby2.5-devel
 BuildRequires:  ruby2.5-rubygem-bundler
-%endif
-BuildRequires:  fdupes
+BuildRequires:  systemd
 
 Requires:   mariadb
 Requires:   nginx
-%if 0%{?use_ruby_2_4}
-Requires(post): ruby2.4
-Requires(post): ruby2.4-rubygem-bundler
-%else
 Requires(post): ruby2.5
 Requires(post): ruby2.5-rubygem-bundler
-%endif
 Requires(post): timezone
 Requires(post): util-linux
 Requires(post): shadow
@@ -103,20 +92,11 @@
 
 %setup -q
 
-%if 0%{?use_ruby_2_4}
 %patch0 -p1
 %patch1 -p1
-%else
-%patch2 -p1
-%patch3 -p1
-%endif
 
 %build
-%if 0%{?use_ruby_2_4}
-bundle.ruby2.4 install %{?jobs:--jobs %jobs} --without test development 
--deployment --standalone
-%else
 bundle.ruby2.5 install %{?jobs:--jobs %jobs} --without test development 
--deployment --standalone
-%endif
 
 %install
 mkdir -p %{buildroot}%{data_dir}
@@ -138,10 +118,17 @@
 
 # systemd
 mkdir -p %{buildroot}%{_unitdir}
-install -m 444 %{SOURCE5} %{buildroot}%{_unitdir}
+
+%if 0%{?is_sle_12_family}
+install -m 444 %{SOURCE12} %{buildroot}%{_unitdir}/rmt-server-sync.timer
+install -m 444 %{SOURCE13} %{buildroot}%{_unitdir}/rmt-server-mirror.timer
+%else
 install -m 444 %{SOURCE6} %{buildroot}%{_unitdir}
-install -m 444 %{SOURCE7} %{buildroot}%{_unitdir}
 install -m 444 %{SOURCE8} %{buildroot}%{_unitdir}
+%endif
+
+install -m 444 %{SOURCE5} %{buildroot}%{_unitdir}
+install -m 444 %{SOURCE7} %{buildroot}%{_unitdir}
 install -m 444 %{SOURCE9} %{buildroot}%{_unitdir}
 install -m 444 %{SOURCE10} %{buildroot}%{_unitdir}
 install -m 444 %{SOURCE11} %{buildroot}%{_unitdir}
@@ -162,16 +149,9 @@
 %{buildroot}%{app_dir}/.bundle/config
 
 # cleanup of /usr/bin/env commands
-%if 0%{?use_ruby_2_4}
-grep -rl '\/usr\/bin\/env ruby' %{buildroot}%{lib_dir}/vendor/bundle/ruby | 
xargs \
-sed -i -e's@\/usr\/bin\/env ruby.ruby2\.4@\/usr\/bin\/ruby\.ruby2\.4@g' \
--e 's@\/usr\/bin\/env ruby@\/usr\/bin\/ruby\.ruby2\.4@g'
-%else
 grep -rl '\/usr\/bin\/env ruby' %{buildroot}%{lib_dir}/vendor/bundle/ruby | 
xargs \
 sed -i -e 's@\/usr\/bin\/env ruby.ruby2\.5@\/usr\/bin\/ruby\.ruby2\.5@g' \
  

commit libstfl for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package libstfl for openSUSE:Factory checked 
in at 2018-02-20 17:57:11

Comparing /work/SRC/openSUSE:Factory/libstfl (Old)
 and  /work/SRC/openSUSE:Factory/.libstfl.new (New)


Package is "libstfl"

Tue Feb 20 17:57:11 2018 rev:11 rq:578319 version:0.24

Changes:

--- /work/SRC/openSUSE:Factory/libstfl/libstfl.changes  2015-05-15 
07:44:41.0 +0200
+++ /work/SRC/openSUSE:Factory/.libstfl.new/libstfl.changes 2018-02-20 
17:58:41.534650576 +0100
@@ -1,0 +2,17 @@
+Sun Feb 18 06:53:38 UTC 2018 - avin...@opensuse.org
+
+- update to 0.24
+  * increased table MAX_ROWS and MAX_COLS
+  * Added "process" variable
+  * Added stfl_redraw API
+  * Added example2
+  * Fixed updating of "pos_name" in list widget
+  * Added stfl_text() function
+  * removed unimplemented stfl_lookup() function
+  * Fixed compiler warning in wt_list.c
+  * cosmetic changes in parser.c
+- cleanup spec file with spec-cleaner
+- rebase stfl-optflags.patch
+  * version number removed from context for better reusability
+
+---

Old:

  stfl-0.23.tar.gz

New:

  stfl-0.24.tar.gz



Other differences:
--
++ libstfl.spec ++
--- /var/tmp/diff_new_pack.7nN3Ib/_old  2018-02-20 17:58:42.882602062 +0100
+++ /var/tmp/diff_new_pack.7nN3Ib/_new  2018-02-20 17:58:42.886601918 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libstfl
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %define soname 0
 Name:   libstfl
-Version:0.23
+Version:0.24
 Release:0
 Summary:Structured Terminal Forms Library
 License:LGPL-3.0+
@@ -28,10 +28,8 @@
 Source99:   libstfl-rpmlintrc
 Patch1: stfl-optflags.patch
 Patch2: stfl-ncurses.patch
-#BuildRequires:swig perl python python-devel ruby ruby-devel
 BuildRequires:  ncurses-devel
-BuildRequires:  pkg-config
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  pkgconfig
 
 %description
 .
@@ -75,10 +73,8 @@
 
 %build
 make %{?_smp_mflags} \
-prefix="%{_prefix}" \
-   libdir="%{_lib}" \
CC="gcc" \
-   OPTFLAGS="%{optflags}" \
+   OPTFLAGS="%{optflags}"\
FOUND_SPL=0 \
FOUND_SWIG=0 \
FOUND_RUBY=0 \
@@ -86,14 +82,9 @@
FOUND_PYTHON=0
 
 %install
-make DESTDIR=%{buildroot} install %{?_smp_mflags} \
-   prefix="%{_prefix}" \
+%make_install \
libdir="%{_lib}" \
-   FOUND_SPL=0 \
-   FOUND_SWIG=0 \
-   FOUND_RUBY=0 \
-   FOUND_PERL=0 \
-   FOUND_PYTHON=0
+   prefix="%{_prefix}"
 
 [ -e "%{buildroot}%{_libdir}/libstfl.so.%{soname}" ] || {
 pushd "%{buildroot}%{_libdir}/"
@@ -102,17 +93,14 @@
 }
 
 %post   -n libstfl%{soname} -p /sbin/ldconfig
-
 %postun -n libstfl%{soname} -p /sbin/ldconfig
 
 %files -n libstfl%{soname}
-%defattr(-,root,root)
 %doc COPYING README
 %{_libdir}/libstfl.so.%{soname}
 %{_libdir}/libstfl.so.%{soname}.*
 
 %files -n libstfl-devel
-%defattr(-,root,root)
 %{_includedir}/stfl.h
 %{_libdir}/libstfl.so
 %{_libdir}/libstfl.a

++ stfl-0.23.tar.gz -> stfl-0.24.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/stfl-0.23/Makefile new/stfl-0.24/Makefile
--- old/stfl-0.23/Makefile  2014-10-13 20:13:08.0 +0200
+++ new/stfl-0.24/Makefile  2015-02-12 14:14:33.0 +0100
@@ -25,7 +25,7 @@
 export LDLIBS += -lncursesw
 
 SONAME  := libstfl.so.0
-VERSION := 0.23
+VERSION := 0.24
 
 all: libstfl.so.$(VERSION) libstfl.a example
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/stfl-0.23/README new/stfl-0.24/README
--- old/stfl-0.23/README2014-04-25 13:51:13.0 +0200
+++ new/stfl-0.24/README2015-01-05 11:50:54.0 +0100
@@ -51,7 +51,7 @@
ncursesw
The wide-character ncurses library. On some distributions
this might be part of the ncurses package, on other
-   distrubutions this might be an extra package.
+   distributions this might be an extra package.
 
SWIG
STFL is using SWIG for generating the Perl, Python and Ruby
@@ -59,7 +59,7 @@
 
Perl, Python, Ruby, SPL
In order to create the language bindings you need to have
-   the languages themself installed.
+   

commit python-arrow for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package python-arrow for openSUSE:Factory 
checked in at 2018-02-20 17:56:37

Comparing /work/SRC/openSUSE:Factory/python-arrow (Old)
 and  /work/SRC/openSUSE:Factory/.python-arrow.new (New)


Package is "python-arrow"

Tue Feb 20 17:56:37 2018 rev:2 rq:578276 version:0.12.1

Changes:

--- /work/SRC/openSUSE:Factory/python-arrow/python-arrow.changes
2017-08-24 18:43:13.018995845 +0200
+++ /work/SRC/openSUSE:Factory/.python-arrow.new/python-arrow.changes   
2018-02-20 17:58:08.295847141 +0100
@@ -1,0 +2,24 @@
+Sat Feb 17 18:29:14 UTC 2018 - a...@gmx.de
+
+- specfile:
+  * update copyright year
+  * require python-backports.functools_lru_cache for python2
+
+- update to version 0.12.1:
+  * Allow wheels to determine the required dependencies
+  * Makes the only_distance paramter value equivalent to value given
+to function when granularity paramter is also provided by user
+
+- changes from version 0.12.0:
+  * [FIX] Compatibility fix for Python 2.x
+
+- changes from version 0.11.0:
+  * [FIX] Fix grammar of ArabicLocale
+  * [NEW] Add Nepali Locale
+  * [FIX] Fix month name + rename AustriaLocale -> AustrianLocale
+  * [FIX] Fix typo in Basque Locale
+  * [FIX] Fix grammar in PortugueseBrazilian locale
+  * [FIX] Remove pip --user-mirrors flag
+  * [NEW] Add Indonesian Locale
+
+---

Old:

  arrow-0.10.0.tar.gz

New:

  arrow-0.12.1.tar.gz



Other differences:
--
++ python-arrow.spec ++
--- /var/tmp/diff_new_pack.5l0mKv/_old  2018-02-20 17:58:11.191742870 +0100
+++ /var/tmp/diff_new_pack.5l0mKv/_new  2018-02-20 17:58:11.191742870 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-arrow
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,9 @@
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%bcond_without python2
 Name:   python-arrow
-Version:0.10.0
+Version:0.12.1
 Release:0
 Summary:Better dates and times for Python
 License:Apache-2.0
@@ -32,6 +33,9 @@
 BuildRequires:  %{python_module simplejson}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
+%if %{with python2}
+BuildRequires:  python-backports.functools_lru_cache
+%endif
 Requires:   python-python-dateutil
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch

++ arrow-0.10.0.tar.gz -> arrow-0.12.1.tar.gz ++
 1822 lines of diff (skipped)




commit modglue for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package modglue for openSUSE:Factory checked 
in at 2018-02-20 17:57:05

Comparing /work/SRC/openSUSE:Factory/modglue (Old)
 and  /work/SRC/openSUSE:Factory/.modglue.new (New)


Package is "modglue"

Tue Feb 20 17:57:05 2018 rev:3 rq:578315 version:1.19

Changes:

--- /work/SRC/openSUSE:Factory/modglue/modglue.changes  2014-04-25 
16:09:57.0 +0200
+++ /work/SRC/openSUSE:Factory/.modglue.new/modglue.changes 2018-02-20 
17:58:40.194698802 +0100
@@ -1,0 +2,5 @@
+Tue Feb 20 09:36:37 UTC 2018 - bwiedem...@suse.com
+
+- Add modglue-1.19-reproducible.patch to make build reproducible
+
+---

New:

  modglue-1.19-reproducible.patch



Other differences:
--
++ modglue.spec ++
--- /var/tmp/diff_new_pack.Ge4hYd/_old  2018-02-20 17:58:41.374656334 +0100
+++ /var/tmp/diff_new_pack.Ge4hYd/_new  2018-02-20 17:58:41.374656334 +0100
@@ -26,6 +26,8 @@
 Group:  Development/Libraries/C and C++ 
 Url:http://cadabra.phi-sci.com/index.html 
 Source: http://cadabra.phi-sci.com/%{name}-%{version}.tar.gz  
+# PATCH-FIX-OPENSUSE -- dont add build date (boo#1047218)
+Patch0: modglue-1.19-reproducible.patch
 BuildRequires:  gcc-c++
 BuildRequires:  libtool
 BuildRequires:  pkg-config
@@ -90,6 +92,7 @@
 
 %prep
 %setup -q 
+%patch0 -p1
 
 %build
 ./configure --prefix=%{_prefix} --libdir=/%{_lib}

++ modglue-1.19-reproducible.patch ++
Index: modglue-1.19/src/Makefile.in
===
--- modglue-1.19.orig/src/Makefile.in
+++ modglue-1.19/src/Makefile.in
@@ -27,7 +27,7 @@ MPHASE = ${LIBTOOL} --tag=CXX --mode=lin
 IPHASE = ${LIBTOOL} --mode=install @INSTALL@
 FPHASE = ${LIBTOOL} --mode=finish @prefix@/@libdir@
 
-TIMESTAMP = -D"DATETIME=\"`date | sed -e 's/  / /'`\"" 
-DHOSTNAME=\"`hostname`\"
+TIMESTAMP = -D"DATETIME=\"`date -u -d @$${SOURCE_DATE_EPOCH:-$$(date +%s)} | 
sed -e 's/  / /'`\"" -DHOSTNAME=\"`hostname`\"
 
 all: library tests tools
 



commit ypserv for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package ypserv for openSUSE:Factory checked 
in at 2018-02-20 17:57:18

Comparing /work/SRC/openSUSE:Factory/ypserv (Old)
 and  /work/SRC/openSUSE:Factory/.ypserv.new (New)


Package is "ypserv"

Tue Feb 20 17:57:18 2018 rev:41 rq:578344 version:4.0

Changes:

--- /work/SRC/openSUSE:Factory/ypserv/ypserv.changes2017-11-23 
09:43:58.777465495 +0100
+++ /work/SRC/openSUSE:Factory/.ypserv.new/ypserv.changes   2018-02-20 
17:58:45.302514966 +0100
@@ -1,0 +2,8 @@
+Thu Feb  8 17:29:38 UTC 2018 - matthias.gerst...@suse.com
+
+- support specification of fixed ports for ypserv, ypxfrd, ypppasswd via
+  /etc/sysconfig/ypserv. This is necessary to support the migration to
+  firewalld. firewalld does not support dynamic rpc ports like SuSEfirewall2
+  did. One way around this is to assign fixed port numbers for all services.
+
+---



Other differences:
--
++ sysconfig.ypserv ++
--- /var/tmp/diff_new_pack.eRl05X/_old  2018-02-20 17:58:46.738463286 +0100
+++ /var/tmp/diff_new_pack.eRl05X/_new  2018-02-20 17:58:46.738463286 +0100
@@ -38,3 +38,25 @@
 # for possible options.
 #
 YPXFRD_ARGS=""
+
+## Path:Network/NIS/NIS server
+## Description: 
+## Type:string
+## Default: ""
+## ServiceRestart: ypserv
+#
+# Additonal arguments for ypserv. See manual page
+# for possible options.
+#
+YPSERV_ARGS=""
+
+## Path:Network/NIS/NIS server
+## Description: 
+## Type:string
+## Default: ""
+## ServiceRestart: yppasswdd
+#
+# Additonal arguments for rpc.yppasswdd. See manual page
+# for possible options.
+#
+YPPASSWDD_ARGS=""

++ yppasswdd-systemd-exec ++
--- /var/tmp/diff_new_pack.eRl05X/_old  2018-02-20 17:58:46.754462710 +0100
+++ /var/tmp/diff_new_pack.eRl05X/_new  2018-02-20 17:58:46.754462710 +0100
@@ -11,4 +11,4 @@
 test "$YPPWD_CHSH" = "yes" && YPPASSWDD_OPTS="$YPPASSWDD_OPTS -e chsh"
 test x"$YPPWD_SRCDIR" = "x" && YPPWD_SRCDIR="/etc"
 
-exec /usr/sbin/rpc.yppasswdd -f -D $YPPWD_SRCDIR $YPPASSWDD_OPTS
+exec /usr/sbin/rpc.yppasswdd -f -D $YPPWD_SRCDIR $YPPASSWDD_OPTS 
$YPPASSWDD_ARGS

++ ypserv.service ++
--- /var/tmp/diff_new_pack.eRl05X/_old  2018-02-20 17:58:46.806460839 +0100
+++ /var/tmp/diff_new_pack.eRl05X/_new  2018-02-20 17:58:46.810460695 +0100
@@ -6,7 +6,8 @@
 [Service]
 Type=notify
 NotifyAccess=all
-ExecStart=/usr/sbin/ypserv -f
+EnvironmentFile=-/etc/sysconfig/ypserv
+ExecStart=/usr/sbin/ypserv -f $YPSERV_ARGS
 
 [Install]
 WantedBy=multi-user.target




commit zutils for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package zutils for openSUSE:Factory checked 
in at 2018-02-20 17:56:25

Comparing /work/SRC/openSUSE:Factory/zutils (Old)
 and  /work/SRC/openSUSE:Factory/.zutils.new (New)


Package is "zutils"

Tue Feb 20 17:56:25 2018 rev:3 rq:578269 version:1.6

Changes:

--- /work/SRC/openSUSE:Factory/zutils/zutils.changes2016-01-04 
09:22:30.0 +0100
+++ /work/SRC/openSUSE:Factory/.zutils.new/zutils.changes   2018-02-20 
17:56:36.303159466 +0100
@@ -1,0 +2,16 @@
+Mon Feb 19 12:07:34 UTC 2018 - aloi...@gmx.com
+
+  - Update to version 1.6
+  * zcmp.cc: Accept 'B' suffix in '--ignore-initial=1kB:1234B'.
+  * zutils.cc (feed_data): Show input filename in error messages.
+  Version 1.5
+  * zupdate.cc (zupdate_file): Pass '-q' to zcmp if verbosity < 0.
+  * zcat.cc zgrep.cc ztest.cc (main): Don't use stdin more than
+once.
+  * zdiff.cc (set_fifonames): Use '_' if both names are different.
+  * configure: Avoid warning on some shells when testing for g++.
+  * Makefile.in: Detect the existence of install-info.
+  * testsuite/check.sh: A POSIX shell is required to run the
+tests.
+
+---

Old:

  zutils-1.4.tar.lz
  zutils-1.4.tar.lz.sig

New:

  zutils-1.6.tar.lz
  zutils-1.6.tar.lz.sig



Other differences:
--
++ zutils.spec ++
--- /var/tmp/diff_new_pack.EHeTdc/_old  2018-02-20 17:56:37.655110787 +0100
+++ /var/tmp/diff_new_pack.EHeTdc/_new  2018-02-20 17:56:37.659110643 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package zutils
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,25 +17,30 @@
 
 
 Name:   zutils
-Version:1.4
+Version:1.6
 Release:0
 Summary:Collection of utilities for dealing with compressed files
 License:GPL-2.0+
 Group:  Productivity/Archiving/Compression
-Url:http://www.nongnu.org/zutils/zutils.html
-Source0:
http://download.savannah.gnu.org/releases/zutils/zutils-%{version}.tar.lz
-Source1:
http://download.savannah.gnu.org/releases/zutils/zutils-%{version}.tar.lz.sig
+URL:https://www.nongnu.org/zutils/zutils.html
+Source0:
https://download.savannah.gnu.org/releases/zutils/zutils-%{version}.tar.lz
+Source1:
https://download.savannah.gnu.org/releases/zutils/zutils-%{version}.tar.lz.sig
 Source2:%{name}.keyring
 BuildRequires:  gcc-c++
 BuildRequires:  lzip
 Requires(post): %{install_info_prereq}
 Requires(preun): %{install_info_prereq}
 Conflicts:  gzip
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-Zutils is a collection of utilities able to deal with any combination of 
compressed and uncompressed files transparently. If any given file, including 
standard input, is compressed, its decompressed content is used. Compressed 
files are decompressed on the fly; no temporary files are created.
-These utilities are not wrapper scripts but safer and more efficient C++ 
programs. In particular the "--recursive" option is very efficient in those 
utilities supporting it.
+Zutils is a collection of utilities able to deal with any combination
+of compressed and uncompressed files transparently. If any given file,
+including standard input, is compressed, its decompressed content is
+used. Compressed files are decompressed on the fly; no temporary files
+are created.
+These utilities are not wrapper scripts but safer and more efficient
+C++ programs. In particular the "--recursive" option is very efficient
+in those utilities supporting it.
 
 %prep
 %setup -q
@@ -54,8 +59,8 @@
 %install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz
 
 %files
-%defattr(-,root,root)
-%doc ChangeLog README COPYING
+%doc ChangeLog README
+%license COPYING
 %config %{_sysconfdir}/zutilsrc
 %{_bindir}/zcat
 %{_bindir}/zcmp





commit xfce4-volumed-pulse for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package xfce4-volumed-pulse for 
openSUSE:Factory checked in at 2018-02-20 17:57:38

Comparing /work/SRC/openSUSE:Factory/xfce4-volumed-pulse (Old)
 and  /work/SRC/openSUSE:Factory/.xfce4-volumed-pulse.new (New)


Package is "xfce4-volumed-pulse"

Tue Feb 20 17:57:38 2018 rev:3 rq:578386 version:0.2.3

Changes:

--- /work/SRC/openSUSE:Factory/xfce4-volumed-pulse/xfce4-volumed-pulse.changes  
2017-02-03 20:07:13.944415593 +0100
+++ 
/work/SRC/openSUSE:Factory/.xfce4-volumed-pulse.new/xfce4-volumed-pulse.changes 
2018-02-20 17:59:43.228430161 +0100
@@ -1,0 +2,8 @@
+Sat Feb 17 11:36:19 UTC 2018 - seife+...@b1-systems.com
+
+- update to 0.2.3:
+  * Switch to Gtk3 by default
+  * Set the transient hint on audio notifications
+- partially applied spec-cleaner hints
+
+---

Old:

  xfce4-volumed-pulse-0.2.2.tar.bz2

New:

  xfce4-volumed-pulse-0.2.3.tar.bz2



Other differences:
--
++ xfce4-volumed-pulse.spec ++
--- /var/tmp/diff_new_pack.GPZSQj/_old  2018-02-20 17:59:44.064400074 +0100
+++ /var/tmp/diff_new_pack.GPZSQj/_new  2018-02-20 17:59:44.068399930 +0100
@@ -17,21 +17,21 @@
 
 
 Name:   xfce4-volumed-pulse
-Version:0.2.2
+Version:0.2.3
 Release:0
 Summary:Daemon Providing Support for Sound Volume Keys
 License:GPL-3.0+
 Group:  Productivity/Multimedia/Sound/Utilities
 Url:http://git.xfce.org/apps/xfce4-volumed
 Source: 
http://archive.xfce.org/src/apps/xfce4-volumed-pulse/0.2/%{name}-%{version}.tar.bz2
+BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(glib-2.0)
-BuildRequires:  pkgconfig(gtk+-2.0)
-BuildRequires:  pkgconfig(keybinder)
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.20
+BuildRequires:  pkgconfig(keybinder-3.0) >= 0.2.0
 BuildRequires:  pkgconfig(libnotify) >= 0.1.3
 BuildRequires:  pkgconfig(libpulse-mainloop-glib) >= 0.9.19
 BuildRequires:  pkgconfig(libxfconf-0)
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 xfce4-volumed-pulse is a daemon providing support for sound volume keys 
present on
@@ -53,7 +53,6 @@
 %suse_update_desktop_file xfce4-volumed-pulse
 
 %files
-%defattr(-,root,root)
 %doc AUTHORS COPYING NEWS README THANKS
 %config %{_sysconfdir}/xdg/autostart/%{name}.desktop
 %{_bindir}/%{name}

++ xfce4-volumed-pulse-0.2.2.tar.bz2 -> xfce4-volumed-pulse-0.2.3.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/xfce4-volumed-pulse-0.2.2/ChangeLog 
new/xfce4-volumed-pulse-0.2.3/ChangeLog
--- old/xfce4-volumed-pulse-0.2.2/ChangeLog 2016-09-14 03:22:52.0 
+0200
+++ new/xfce4-volumed-pulse-0.2.3/ChangeLog 2018-02-13 22:45:14.0 
+0100
@@ -1,3 +1,36 @@
+commit 65561422f91cab9164e427a5b7934a9795f1c0e3
+Author: Simon Steinbeiss 
+Date:   Tue Feb 13 22:43:10 2018 +0100
+
+Update for release
+
+commit faec2e8a55f2f1191e0015e699aacffd27759b6c
+Author: Simon Steinbeiss 
+Date:   Wed Aug 16 23:57:39 2017 +0200
+
+Also bump libkeybinder to Gtk3
+
+commit ce3d7f2961447dd7321b528593abd14bd6b4695c
+Author: Simon Steinbeiss 
+Date:   Wed Aug 16 13:57:20 2017 +0200
+
+Switch to Gtk3 by default
+
+commit 468c3a748c6dfa306b232421d95e942047c101e3
+Author: Simon Steinbeiss 
+Date:   Wed Aug 16 13:49:11 2017 +0200
+
+Set the transient hint on audio notifications
+
+This means that the audio notifications are not logged by daemons with
+the persistence feature as described in the fd.org notification spec.
+
+commit 6fadb81c4188052b264da437705012150ad93975
+Author: Sean Davis 
+Date:   Tue Sep 13 21:27:38 2016 -0400
+
+Post release version bump
+
 commit b46042847f52768bd29f92e6af89f852781cdae2
 Author: Sean Davis 
 Date:   Tue Sep 13 21:20:26 2016 -0400
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/xfce4-volumed-pulse-0.2.2/config.guess 
new/xfce4-volumed-pulse-0.2.3/config.guess
--- old/xfce4-volumed-pulse-0.2.2/config.guess  2016-09-14 03:22:44.0 
+0200
+++ new/xfce4-volumed-pulse-0.2.3/config.guess  2018-02-13 22:45:08.0 
+0100
@@ -1,8 +1,8 @@
 #! /bin/sh
 # Attempt to guess a canonical system name.
-#   Copyright 1992-2015 Free Software Foundation, Inc.
+#   Copyright 1992-2016 Free Software Foundation, Inc.
 
-timestamp='2015-08-20'
+timestamp='2016-10-02'
 
 # This file is free software; you can redistribute it and/or modify it
 

commit 96BoardsGPIO for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package 96BoardsGPIO for openSUSE:Factory 
checked in at 2018-02-20 17:56:15

Comparing /work/SRC/openSUSE:Factory/96BoardsGPIO (Old)
 and  /work/SRC/openSUSE:Factory/.96BoardsGPIO.new (New)


Package is "96BoardsGPIO"

Tue Feb 20 17:56:15 2018 rev:3 rq:578263 version:0.0+git.20170225

Changes:

--- /work/SRC/openSUSE:Factory/96BoardsGPIO/96BoardsGPIO.changes
2018-02-07 18:43:05.391472939 +0100
+++ /work/SRC/openSUSE:Factory/.96BoardsGPIO.new/96BoardsGPIO.changes   
2018-02-20 17:56:21.111706459 +0100
@@ -1,0 +2,5 @@
+Sun Feb 18 12:06:40 UTC 2018 - jeng...@inai.de
+
+- Compact description.
+
+---



Other differences:
--
++ 96BoardsGPIO.spec ++
--- /var/tmp/diff_new_pack.eBJa8b/_old  2018-02-20 17:56:22.679650003 +0100
+++ /var/tmp/diff_new_pack.eBJa8b/_new  2018-02-20 17:56:22.683649859 +0100
@@ -23,7 +23,7 @@
 Summary:A library to make GPIO use across 96Boards uniform
 License:LGPL-2.1
 Group:  Development/Libraries/C and C++
-URL:https://github.com/96boards/96BoardsGPIO
+Url:https://github.com/96boards/96BoardsGPIO
 Source: %{name}-%{version}.tar.xz
 Patch0: 96BoardsGPIO-implicit-declaration.patch
 BuildRequires:  autoconf
@@ -32,24 +32,18 @@
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(libsoc)
 BuildRequires:  pkgconfig(python3)
-# Usefull only on arm but x86_64 is faster for building/testing
+# Useful only on ARM, but x86_64 is faster for building/testing
 ExclusiveArch:  aarch64 x86_64
 
 %description
-This is the rudimentary beginnings of the 96BoardGPIO library to control
-real world hardware via the GPIO on the 96Boards family of boards that
-confirm to the CE spec.
-
-One of the cool things about the 96Boards CE project is that all of the
-boards use the same pins for the Low Speed Expansion Connector so you can
-plug any expansion board into any 96Board and it will connect electrically
-BUT there is an issue where GPIO is concerned. Different SoC's have
-different GPIO pins. So even though electrically the pins are in the same
-place it takes different code to enable and use the GPIO on pins 23 - 34.
-Not so fun.
+This is 96BoardGPIO library, which controls hardware via the GPIO on
+the 96Boards family of boards that confirm to the CE spec. These
+boards have the same Low Speed Expansion Connector, but different
+SOCs have different GPIO pins for which different code needs to be
+used to enable pins 23-34 on the connector.
 
-The 96BoardGPIO library tries to abstract the info so that you can just
-tell it what board you are using and what pins you want to use and the
+The 96BoardGPIO library abstracts the info so that it can be told
+what board is being used and what pins are to be used, and the
 library does the rest.
 
 %package -n lib%{name}%{sover}
@@ -58,20 +52,18 @@
 Recommends: %{name}-common
 
 %description -n lib%{name}%{sover}
-This is the rudimentary beginnings of the 96BoardGPIO library to control
-real world hardware via the GPIO on the 96Boards family of boards that
-confirm to the CE spec.
-
-One of the cool things about the 96Boards CE project is that all of the
-boards use the same pins for the Low Speed Expansion Connector so you can
-plug any expansion board into any 96Board and it will connect electrically
-BUT there is an issue where GPIO is concerned. Different SoC's have
-different GPIO pins. So even though electrically the pins are in the same
-place it takes different code to enable and use the GPIO on pins 23 - 34.
-Not so fun.
+This is 96BoardGPIO library, which controls hardware via the GPIO on
+the 96Boards family of boards that confirm to the CE spec.
 
-The 96BoardGPIO library tries to abstract the info so that you can just
-tell it what board you are using and what pins you want to use and the
+All such boards use the same pins for the Low Speed Expansion
+Connector, so any expansion board can be plugged into any 96Board,
+and it will connect electrically. However, different SoCs have
+different GPIO pins. Even though, electrically, the pins are in the
+same place, it takes different code to enable and use the GPIO on
+pins 23-34.
+
+The 96BoardGPIO library abstracts the info so that it can be told
+what board is being used and what pins are to be used, and the
 library does the rest.
 
 This package contains shared library for %{name}.
@@ -81,20 +73,14 @@
 Group:  Development/Languages/C and C++
 
 %description -n %{name}-common
-This is the rudimentary beginnings of the 96BoardGPIO library to control
-real world hardware via the GPIO on the 96Boards family of boards that
-confirm to the CE spec.
-
-One of 

commit rubygem-loofah for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package rubygem-loofah for openSUSE:Factory 
checked in at 2018-02-20 17:56:02

Comparing /work/SRC/openSUSE:Factory/rubygem-loofah (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-loofah.new (New)


Package is "rubygem-loofah"

Tue Feb 20 17:56:02 2018 rev:5 rq:578226 version:2.2.0

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-loofah/rubygem-loofah.changes
2017-12-07 13:51:13.574977140 +0100
+++ /work/SRC/openSUSE:Factory/.rubygem-loofah.new/rubygem-loofah.changes   
2018-02-20 17:56:07.676190228 +0100
@@ -1,0 +2,22 @@
+Thu Feb 15 14:13:37 UTC 2018 - mrueck...@suse.de
+
+- also set a description again
+
+---
+Mon Feb 12 10:11:44 UTC 2018 - bgeu...@suse.com
+
+- Update to version 2.2.0
+
+  Features:
+
+  * Support HTML5  tag. #133 (Thanks, @MothOnMars!)
+  * Recognize HTML5 block elements. #136 (Thanks, @MothOnMars!)
+  * Support SVG  tag. #131 (Thanks, @baopham!)
+  * Support for whitelisting CSS functions, initially just calc and rgb. 
#122/#123/#129 (Thanks, @NikoRoberts!)
+  * Whitelist CSS property list-style-type. #68/#137/#142 (Thanks, 
@andela-ysanni and @NikoRoberts!)
+
+  Bugfixes:
+
+  * Properly handle nested script tags. #127.
+
+---

Old:

  loofah-2.1.1.gem

New:

  loofah-2.2.0.gem



Other differences:
--
++ rubygem-loofah.spec ++
--- /var/tmp/diff_new_pack.EPeYAs/_old  2018-02-20 17:56:08.932145006 +0100
+++ /var/tmp/diff_new_pack.EPeYAs/_new  2018-02-20 17:56:08.944144574 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package rubygem-loofah
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,41 +24,34 @@
 #
 
 Name:   rubygem-loofah
-Version:2.1.1
+Version:2.2.0
 Release:0
 %define mod_name loofah
 %define mod_full_name %{mod_name}-%{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  ruby-macros >= 5
+BuildRequires:  %{ruby}
 BuildRequires:  %{rubygem gem2rpm}
 BuildRequires:  %{rubygem rdoc > 3.10}
-BuildRequires:  %{ruby}
-BuildRequires:  ruby-macros >= 5
-Url:https://github.com/flavorjones/loofah
 Source: https://rubygems.org/gems/%{mod_full_name}.gem
 Source1:gem2rpm.yml
-Summary:Loofah is a general library for manipulating and transforming
+Summary:HTML/XML manipulation and sanitization based on Nokogiri
 License:MIT
 Group:  Development/Languages/Ruby
 
 %description
-Loofah is a general library for manipulating and transforming HTML/XML
-documents and fragments. It's built on top of Nokogiri and libxml2, so
-it's fast and has a nice API.
-Loofah excels at HTML sanitization (XSS prevention). It includes some
-nice HTML sanitizers, which are based on HTML5lib's whitelist, so it
-most likely won't make your codes less secure. (These statements have
-not been evaluated by Netexperts.)
-ActiveRecord extensions for sanitization are available in the
-`loofah-activerecord` gem (see
-https://github.com/flavorjones/loofah-activerecord).
+Loofah is a general library for manipulating and transforming HTML/XML 
documents and fragments.
+It's built on top of Nokogiri and libxml2, so it's fast and has a nice API.
 
+Loofah excels at HTML sanitization (XSS prevention). It includes some nice 
HTML sanitizers,
+which are based on HTML5lib's whitelist, so it most likely won't make your 
codes less secure.
 %prep
 
 %build
 
 %install
 %gem_install \
-  --doc-files="CHANGELOG.md MIT-LICENSE.txt README.rdoc" \
+  --doc-files="CHANGELOG.md MIT-LICENSE.txt README.md" \
   -f
 
 %gem_packages

++ gem2rpm.yml ++
--- /var/tmp/diff_new_pack.EPeYAs/_old  2018-02-20 17:56:09.008142269 +0100
+++ /var/tmp/diff_new_pack.EPeYAs/_new  2018-02-20 17:56:09.008142269 +0100
@@ -1,11 +1,13 @@
 # ---
 # ## used by gem2rpm
-# :summary: this is a custom summary
+:summary: HTML/XML manipulation and sanitization based on Nokogiri
 # ## used by gem2rpm
-# :description: |-
-#   this is a custom description
-#
-#   it can be multiline
+:description: |-
+ Loofah is a general library for manipulating and transforming HTML/XML 
documents and fragments.
+ It's built on top of Nokogiri and libxml2, so it's fast and has a nice API.
+
+ Loofah excels at HTML sanitization (XSS prevention). It includes some nice 
HTML sanitizers,
+ which are based on HTML5lib's whitelist, so it most likely won't make your 
codes less secure.
 # ## used by 

commit lzfse for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package lzfse for openSUSE:Factory checked 
in at 2018-02-20 17:56:19

Comparing /work/SRC/openSUSE:Factory/lzfse (Old)
 and  /work/SRC/openSUSE:Factory/.lzfse.new (New)


Package is "lzfse"

Tue Feb 20 17:56:19 2018 rev:4 rq:578266 version:1.0

Changes:

--- /work/SRC/openSUSE:Factory/lzfse/lzfse.changes  2016-12-22 
15:56:50.119934718 +0100
+++ /work/SRC/openSUSE:Factory/.lzfse.new/lzfse.changes 2018-02-20 
17:56:28.079455574 +0100
@@ -1,0 +2,10 @@
+Mon Feb 19 11:30:05 UTC 2018 - aloi...@gmx.com
+
+- Update to stable version 1.0, see
+  https://github.com/lzfse/lzfse/commits/lzfse-1.0 for details
+
+- Dropped _service
+
+- Spec cleanup
+
+---

Old:

  _service
  _servicedata
  lzfse-0.0+git.20161117.tar.xz

New:

  lzfse-1.0.tar.gz



Other differences:
--
++ lzfse.spec ++
--- /var/tmp/diff_new_pack.cENFmv/_old  2018-02-20 17:56:29.435406750 +0100
+++ /var/tmp/diff_new_pack.cENFmv/_new  2018-02-20 17:56:29.439406606 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package lzfse
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,16 +17,14 @@
 
 
 Name:   lzfse
-Version:0.0+git.20161117
+Version:1.0
 Release:0
 Summary:Reference C implementation of the LZFSE compressor
 License:BSD-3-Clause
 Group:  Productivity/Archiving/Compression
-Url:https://github.com/lzfse/lzfse
-Source: %{name}-%{version}.tar.xz
+URL:https://github.com/lzfse/lzfse
+Source: 
https://github.com/lzfse/lzfse/archive/%{name}-%{version}.tar.gz
 BuildRequires:  cmake
-BuildRequires:  xz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 LZFSE is a Lempel-Ziv style data compression algorithm using Finite State
@@ -46,7 +44,7 @@
 This package contains devel files.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{name}-%{version}
 
 %build
 %cmake
@@ -56,13 +54,12 @@
 %cmake_install
 
 %files
-%defattr(-,root,root)
-%doc LICENSE README.md
+%doc README.md
+%license LICENSE
 %{_bindir}/lzfse
 %{_libdir}/liblzfse.so
 
 %files devel
-%defattr(-,root,root)
 %{_includedir}/lzfse.h
 
 %changelog




commit openbabel for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package openbabel for openSUSE:Factory 
checked in at 2018-02-20 17:56:09

Comparing /work/SRC/openSUSE:Factory/openbabel (Old)
 and  /work/SRC/openSUSE:Factory/.openbabel.new (New)


Package is "openbabel"

Tue Feb 20 17:56:09 2018 rev:32 rq:578245 version:2.4.1

Changes:

--- /work/SRC/openSUSE:Factory/openbabel/openbabel.changes  2016-06-21 
12:29:19.0 +0200
+++ /work/SRC/openSUSE:Factory/.openbabel.new/openbabel.changes 2018-02-20 
17:56:13.727972324 +0100
@@ -1,0 +2,35 @@
+Sun Feb 18 12:18:20 UTC 2018 - jeng...@inai.de
+
+- Fix RPM groups. Update descriptions.
+
+---
+Sat Feb  3 21:54:05 UTC 2018 - wba...@tmo.at
+
+- Force python2 by passing -DPYTHON_EXECUTABLE=%{_bindir}/python2
+  to cmake to fix build on Tumbleweed
+
+---
+Mon Feb  6 12:34:16 UTC 2017 - mailaen...@opensuse.org
+
+- build with wxWidgets support
+- add baselibs.conf
+- enable python support (for real now)
+- add libinchi0 and openbabel sub packages
+- correct the .so version suffix for libopenbabel
+- Drop openbabel-2.3.1-no-build-date.patch
+
+---
+Sun Nov 20 08:29:20 UTC 2016 - aloi...@gmx.com
+
+- Update to version 2.4.1, see
+  https://sourceforge.net/projects/openbabel/files/openbabel/2.4.0
+  for changelog
+- Dropped cripple_source.sh
+- Replaced openbabel-2.2.3-no-build-date.patch with
+  sed regex
+- Dropped build-checks.diff due to significant source
+  changes
+- Dropped python-installdir.patch (included upstream)
+- Dropped openbabel-gcc5.patch (included upstream)
+
+---

Old:

  cripple_source.sh
  openbabel-2.3.1-no-build-date.patch
  openbabel-2.3.2-crippled.tar.bz2
  openbabel-gcc5.patch
  openbabel-gcc6.patch
  python-installdir.patch

New:

  openbabel-2.4.1.tar.gz



Other differences:
--
++ openbabel.spec ++
--- /var/tmp/diff_new_pack.I7jC4n/_old  2018-02-20 17:56:16.115886343 +0100
+++ /var/tmp/diff_new_pack.I7jC4n/_new  2018-02-20 17:56:16.119886199 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package openbabel
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,116 +17,140 @@
 
 
 Name:   openbabel
-Version:2.3.2
-Release:0
-Summary:Open Babel - The Open Source Chemistry Toolbox
+Version:2.4.1
+Release:1.5
+Summary:A chemistry toolbox
 License:GPL-2.0
 Group:  Development/Libraries/C and C++
 Url:http://openbabel.sourceforge.net/
-Source: %{name}-%{version}-crippled.tar.bz2
-Source1:baselibs.conf
-Source99:   cripple_source.sh
-# PATCH-FIX-OPENSUSE -- No build date
-Patch0: openbabel-2.3.1-no-build-date.patch
-# PATCH-FIX-UPSTREAM openbabel-gcc5.patch dims...@opensuse.org -- Fix build 
with GCC5, taken from git
-Patch1: openbabel-gcc5.patch
-# PATCH-FIX-UPSTREAM openbabel-gcc6.patch mli...@suse.cz -- Fix build with GCC6
-Patch2: openbabel-gcc6.patch
-# PATCH-MERGED-UPSTREAM python-installdir.patch tchva...@suse.com -- Fix 
bindings install dir
-Patch3: python-installdir.patch
-BuildRequires:  cmake
+Source0:
https://sourceforge.net/projects/openbabel/files/openbabel/%{version}/%{name}-%{version}.tar.gz
+Source1:%{name}.changes
+Source2:baselibs.conf
+BuildRequires:  cairo-devel
+BuildRequires:  cmake >= 2.4.8
+BuildRequires:  eigen3-devel
 BuildRequires:  gcc-c++
-BuildRequires:  libeigen2-devel
+BuildRequires:  libxml2-devel
 BuildRequires:  pkgconfig
 BuildRequires:  python-devel
 BuildRequires:  swig
 BuildRequires:  zlib-devel
-BuildRequires:  pkgconfig(cairo)
-BuildRequires:  pkgconfig(libxml-2.0)
+BuildRequires:  wxWidgets-devel
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-Open Babel is a chemical toolbox designed to speak the many languages
-of chemical data. It's an open, collaborative project allowing anyone
-to search, convert, analyze, or store data from molecular modeling,
-chemistry, solid-state materials, biochemistry, or related areas.
-
-%package -n libopenbabel4
-Summary:Open Babel - The Open Source Chemistry Toolbox
-Group:  Development/Libraries/C and C++
-
-%description -n libopenbabel4
-Open Babel is a chemical toolbox designed to speak the many languages
-of chemical data. It's an open, collaborative 

commit hiawatha for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package hiawatha for openSUSE:Factory 
checked in at 2018-02-20 17:55:36

Comparing /work/SRC/openSUSE:Factory/hiawatha (Old)
 and  /work/SRC/openSUSE:Factory/.hiawatha.new (New)


Package is "hiawatha"

Tue Feb 20 17:55:36 2018 rev:21 rq:578148 version:10.7

Changes:

--- /work/SRC/openSUSE:Factory/hiawatha/hiawatha.changes2017-11-09 
14:00:15.513735691 +0100
+++ /work/SRC/openSUSE:Factory/.hiawatha.new/hiawatha.changes   2018-02-20 
17:55:45.448990560 +0100
@@ -1,0 +2,5 @@
+Sat Feb 17 20:21:12 UTC 2018 - fi...@opensuse.org
+
+- Fix build with mbedtls 2.7.0.
+
+---



Other differences:
--
++ hiawatha.spec ++
--- /var/tmp/diff_new_pack.TVcrmC/_old  2018-02-20 17:55:46.524951817 +0100
+++ /var/tmp/diff_new_pack.TVcrmC/_new  2018-02-20 17:55:46.528951673 +0100
@@ -1,8 +1,8 @@
 #
 # spec file for package hiawatha
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
-# Copyright (c) 2013-2017 Mariusz Fik .
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2013-2018 Mariusz Fik .
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,6 +18,7 @@
 
 
 %define webroot /srv/www
+%define mbedtls_version %(rpm -q mbedtls-devel --qf "%%{VERSION}")
 
 Name:   hiawatha
 Version:10.7
@@ -60,6 +61,11 @@
 # Remove bundled source for mbedtls, we use system version
 rm -rv mbedtls
 
+# mbedtls 2.7.0 and its backward comaptybility...
+%if "%{mbedtls_version}" >= "2.7.0"
+sed -i 's/MBEDTLS_DHM_RFC5114_MODP_2048_P/MBEDTLS_DHM_RFC5114_MODP_P/' 
src/tls.c
+%endif
+
 %build
 %cmake \
 -DCONFIG_DIR="%{_sysconfdir}/hiawatha" \




commit tboot for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package tboot for openSUSE:Factory checked 
in at 2018-02-20 17:55:30

Comparing /work/SRC/openSUSE:Factory/tboot (Old)
 and  /work/SRC/openSUSE:Factory/.tboot.new (New)


Package is "tboot"

Tue Feb 20 17:55:30 2018 rev:30 rq:578146 version:20170711_1.9.6

Changes:

--- /work/SRC/openSUSE:Factory/tboot/tboot.changes  2017-11-16 
14:04:31.529990698 +0100
+++ /work/SRC/openSUSE:Factory/.tboot.new/tboot.changes 2018-02-20 
17:55:42.417099729 +0100
@@ -1,0 +2,8 @@
+Mon Feb 12 13:27:20 UTC 2018 - matthias.gerst...@suse.com
+
+- tboot-distributor.patch: don't add GNU/Linux to grub menu entries. SUSE's
+  grub2 itself doesn't do it as well. (bnc#1078262)
+- perform update of bootloader configuration after installation via
+  %posttrans. (bnc#1078262)
+
+---

New:

  tboot-distributor.patch



Other differences:
--
++ tboot.spec ++
--- /var/tmp/diff_new_pack.GBApMh/_old  2018-02-20 17:55:43.729052489 +0100
+++ /var/tmp/diff_new_pack.GBApMh/_new  2018-02-20 17:55:43.733052345 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package tboot
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -29,11 +29,22 @@
 Patch4: tboot-grub2-fix-xen-submenu-name.patch
 Patch5: tboot-openssl-1-1-0.patch
 Patch6: tboot-CVE-2017-16837.patch
+Patch7: tboot-distributor.patch
 # PATCH-FIX-UPSTREAM -- https://sourceforge.net/p/tboot/code/merge-requests/1/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+ExclusiveArch:  %{ix86} x86_64
 BuildRequires:  openssl-devel
 BuildRequires:  trousers-devel
-ExclusiveArch:  %{ix86} x86_64
+
+%if 0%{?suse_version} > 1320
+BuildRequires:  update-bootloader-rpm-macros
+%endif
+
+%if 0%{?update_bootloader_requires:1}
+%update_bootloader_requires
+%else
+Requires:   perl-Bootloader
+%endif
 
 %description
 Trusted Boot (tboot) is a pre-kernel/VMM module that uses Intel(R)
@@ -46,6 +57,7 @@
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 %build
 export CFLAGS="%{optflags}"
@@ -85,4 +97,14 @@
 %{_sysconfdir}/grub.d/20_linux_tboot
 %{_sysconfdir}/grub.d/20_linux_xen_tboot
 
+%post
+%if 0%{?update_bootloader_check_type_reinit_post:1} 
+%update_bootloader_check_type_reinit_post grub2 grub2-efi
+%else
+/sbin/update-bootloader --reinit || true
+%endif
+
+%posttrans
+%{?update_bootloader_posttrans}
+
 %changelog

++ tboot-distributor.patch ++
Index: tboot-1.9.6/tboot/20_linux_tboot
===
--- tboot-1.9.6.orig/tboot/20_linux_tboot
+++ tboot-1.9.6/tboot/20_linux_tboot
@@ -72,7 +72,7 @@ CLASS="--class gnu-linux --class gnu --c
 if [ "x${GRUB_DISTRIBUTOR}" = "x" ] ; then
   OS=GNU/Linux
 else
-  OS="${GRUB_DISTRIBUTOR} GNU/Linux"
+  OS="${GRUB_DISTRIBUTOR}"
   CLASS="--class $(echo ${GRUB_DISTRIBUTOR} | tr '[A-Z]' '[a-z]' | cut -d' ' 
-f1) ${CLASS}"
 fi
 
Index: tboot-1.9.6/tboot/20_linux_xen_tboot
===
--- tboot-1.9.6.orig/tboot/20_linux_xen_tboot
+++ tboot-1.9.6/tboot/20_linux_xen_tboot
@@ -63,7 +63,7 @@ CLASS="--class gnu-linux --class gnu --c
 if [ "x${GRUB_DISTRIBUTOR}" = "x" ] ; then
   OS=GNU/Linux
 else
-  OS="${GRUB_DISTRIBUTOR} GNU/Linux"
+  OS="${GRUB_DISTRIBUTOR}"
   CLASS="--class $(echo ${GRUB_DISTRIBUTOR} | tr 'A-Z' 'a-z' | cut -d' ' -f1) 
${CLASS}"
 fi
 



commit squid for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package squid for openSUSE:Factory checked 
in at 2018-02-20 17:56:11

Comparing /work/SRC/openSUSE:Factory/squid (Old)
 and  /work/SRC/openSUSE:Factory/.squid.new (New)


Package is "squid"

Tue Feb 20 17:56:11 2018 rev:56 rq:578257 version:4.0.23

Changes:

--- /work/SRC/openSUSE:Factory/squid/squid.changes  2018-02-06 
16:47:38.636308336 +0100
+++ /work/SRC/openSUSE:Factory/.squid.new/squid.changes 2018-02-20 
17:56:17.275844576 +0100
@@ -1,0 +2,13 @@
+Mon Feb 19 08:08:14 UTC 2018 - adam.ma...@suse.de
+
+- Spec file cleanup:
+  + Drop unused fillup template - it's not used by systemd script
+  + Drop %pretrans section which is only used to upgrade from
+version 3.4 of squid - no supported codestream has that version.
+  + Drop explicit BR: on systemd-rpm-macros
+- Update squid.service systemd file
+  + Don't need to use squid to manage squid anymore
+  + Drop references to default config file, since it's default
+- Drop reference to nonexistent EnvironmentFile in the service file
+
+---

Old:

  squid.sysconfig



Other differences:
--
++ squid.spec ++
--- /var/tmp/diff_new_pack.AOc9uX/_old  2018-02-20 17:56:18.903785959 +0100
+++ /var/tmp/diff_new_pack.AOc9uX/_new  2018-02-20 17:56:18.907785815 +0100
@@ -18,10 +18,6 @@
 
 %define squidlibdir %{_libdir}/squid
 %define squidconfdir %{_sysconfdir}/squid
-#Compat macro for new _fillupdir macro introduced in Nov 2017
-%if ! %{defined _fillupdir}
-  %define _fillupdir %{_localstatedir}/adm/fillup-templates
-%endif
 Name:   squid
 Version:4.0.23
 Release:0
@@ -31,7 +27,6 @@
 Url:http://www.squid-cache.org
 Source0:http://www.squid-cache.org/Versions/v4/squid-%{version}.tar.xz
 Source1:
http://www.squid-cache.org/Versions/v4/squid-%{version}.tar.xz.asc
-Source4:squid.sysconfig
 Source5:pam.squid
 Source6:unsquid.pl
 Source7:%{name}.logrotate
@@ -58,7 +53,6 @@
 BuildRequires:  pkgconfig
 BuildRequires:  samba-winbind
 BuildRequires:  sharutils
-BuildRequires:  systemd-rpm-macros
 BuildRequires:  pkgconfig(expat)
 BuildRequires:  pkgconfig(gssrpc)
 BuildRequires:  pkgconfig(kdb)
@@ -66,7 +60,6 @@
 BuildRequires:  pkgconfig(libsasl2)
 BuildRequires:  pkgconfig(libxml-2.0)
 Requires:   logrotate
-Requires(post): %fillup_prereq
 Requires(pre):  permissions
 Requires(pre):  shadow
 Provides:   http_proxy
@@ -186,7 +179,6 @@
 install -D -m 755 %{SOURCE16} 
%{buildroot}%{squidlibdir}/initialize_cache_if_needed.sh
 sed -i -e 's!%%{_libdir}!%{_libdir}!' %{buildroot}%{_unitdir}/%{name}.service
 ln -sf %{_sbindir}/service %{buildroot}%{_sbindir}/rc%{name}
-install -Dpm 644 %{SOURCE4} %{buildroot}%{_fillupdir}/sysconfig.%{name}
 
 # Move the MIB definition to the proper place (and name)
 mkdir -p %{buildroot}%{_datadir}/snmp/mibs
@@ -226,21 +218,6 @@
   fi
 fi
 
-%pretrans -p 
--- Directory to symlink is not working in RPM so workaround it
--- Occurs when updating from 3.4 to 3.5
-error_dir="%{_datadir}/%{name}/errors/"
-bad_ones={"zh-cn","zh-tw"}
-print("cleaning up old directories")
-for i,f in pairs(bad_ones) do
-  pstat = posix.stat(error_dir..f)
-  if pstat and pstat.type == "directory" then
- print ("moving away "..error_dir..f.." to "..error_dir..f .. ".rpmmoved")
- --posix.rmdir(error_dir..f)
- os.rename(error_dir..f, error_dir..f .. ".rpmmoved")
-  end
-end
-
 %post
 %set_permissions %{_sbindir}/basic_pam_auth
 %set_permissions %{_sbindir}/pinger
@@ -340,7 +317,6 @@
 %{_sbindir}/url_lfs_rewrite
 %{_sbindir}/ext_time_quota_acl
 %{_sbindir}/rc%{name}
-%{_fillupdir}/sysconfig.%{name}
 %dir %{_libdir}/%{name}
 %{_libdir}/%{name}/cachemgr.cgi
 

++ initialize_cache_if_needed.sh ++
--- /var/tmp/diff_new_pack.AOc9uX/_old  2018-02-20 17:56:18.963783799 +0100
+++ /var/tmp/diff_new_pack.AOc9uX/_new  2018-02-20 17:56:18.963783799 +0100
@@ -8,6 +8,6 @@
 
 if ! test -d $CACHE_DIR; then
 echo "Initializing cache directories..."
-exec /usr/sbin/squid -z -F --foreground -S -f /etc/squid/squid.conf
+exec /usr/sbin/squid -z -F --foreground -S
 fi
 


++ squid.service ++
--- /var/tmp/diff_new_pack.AOc9uX/_old  2018-02-20 17:56:19.055780487 +0100
+++ /var/tmp/diff_new_pack.AOc9uX/_new  2018-02-20 17:56:19.055780487 +0100
@@ -1,14 +1,13 @@
 [Unit]
 Description=Squid caching proxy
+Documentation=man:squid(8)
 After=network.target named.service nss-lookup.service
 
 [Service]
 Type=forking
-EnvironmentFile=-/etc/sysconfig/squid
 ExecStartPre=%{_libdir}/squid/initialize_cache_if_needed.sh
-ExecStart=/usr/sbin/squid -F $SQUID_START_OPTIONS  -f /etc/squid/squid.conf

commit pixd for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package pixd for openSUSE:Factory checked in 
at 2018-02-20 17:56:13

Comparing /work/SRC/openSUSE:Factory/pixd (Old)
 and  /work/SRC/openSUSE:Factory/.pixd.new (New)


Package is "pixd"

Tue Feb 20 17:56:13 2018 rev:2 rq:578261 version:1.0.0

Changes:

--- /work/SRC/openSUSE:Factory/pixd/pixd.changes2017-07-04 
09:10:49.602960921 +0200
+++ /work/SRC/openSUSE:Factory/.pixd.new/pixd.changes   2018-02-20 
17:56:19.227774294 +0100
@@ -1,0 +2,6 @@
+Sat Feb 17 14:15:41 UTC 2018 - mar...@gmx.de
+
+- Update to version 1.0.0 (no upstream changelog)
+- Specfile cleanup
+
+---

Old:

  _service
  _servicedata
  pixd-0.0.0+git.20170527.tar.xz

New:

  pixd-1.0.0.tar.gz



Other differences:
--
++ pixd.spec ++
--- /var/tmp/diff_new_pack.b7NZHb/_old  2018-02-20 17:56:20.291735984 +0100
+++ /var/tmp/diff_new_pack.b7NZHb/_new  2018-02-20 17:56:20.295735840 +0100
@@ -1,6 +1,7 @@
 #
 # spec file for package pixd
 #
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2017, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
@@ -17,13 +18,13 @@
 
 
 Name:   pixd
-Version:0.0.0+git.20170527
+Version:1.0.0
 Release:0
 Summary:Colourful visualization tool for binary files
 License:MIT
 Group:  Development/Tools/Debuggers
 Url:https://github.com/FireyFly/pixd.git
-Source: %{name}-%{version}.tar.xz
+Source: 
https://github.com/FireyFly/pixd/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
 
 %description
 pixd is a tool for visualizing binary data using a colour palette.
@@ -42,8 +43,8 @@
 install -m 0644 pixd.1 %{buildroot}%{_mandir}/man1/pixd.1
 
 %files
-%defattr(-,root,root)
-%doc LICENSE README.md
+%license LICENSE
+%doc README.md
 %{_bindir}/pixd
 %{_mandir}/man1/pixd.1%{ext_man}
 




commit stalonetray for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package stalonetray for openSUSE:Factory 
checked in at 2018-02-20 17:55:50

Comparing /work/SRC/openSUSE:Factory/stalonetray (Old)
 and  /work/SRC/openSUSE:Factory/.stalonetray.new (New)


Package is "stalonetray"

Tue Feb 20 17:55:50 2018 rev:3 rq:578209 version:0.8.3

Changes:

--- /work/SRC/openSUSE:Factory/stalonetray/stalonetray.changes  2015-07-23 
15:22:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.stalonetray.new/stalonetray.changes 
2018-02-20 17:55:56.752583553 +0100
@@ -1,0 +2,5 @@
+Mon Feb 19 19:52:29 UTC 2018 - crrodrig...@opensuse.org
+
+- remove xorg-x11-devel buildrequires 
+
+---



Other differences:
--
++ stalonetray.spec ++
--- /var/tmp/diff_new_pack.rf9l4E/_old  2018-02-20 17:55:57.820545099 +0100
+++ /var/tmp/diff_new_pack.rf9l4E/_new  2018-02-20 17:55:57.820545099 +0100
@@ -30,8 +30,8 @@
 Patch0: stalonetray-fix-compile-error.diff
 BuildRequires:  gcc-c++
 BuildRequires:  pkgconfig
-BuildRequires:  xorg-x11-devel
-BuildRequires:  pkgconfig(freetype2)
+BuildRequires:  pkgconfig(x11)
+BuildRequires:  pkgconfig(xpm)
 #
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 




commit lzlib for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package lzlib for openSUSE:Factory checked 
in at 2018-02-20 17:55:54

Comparing /work/SRC/openSUSE:Factory/lzlib (Old)
 and  /work/SRC/openSUSE:Factory/.lzlib.new (New)


Package is "lzlib"

Tue Feb 20 17:55:54 2018 rev:9 rq:578212 version:1.10

Changes:

--- /work/SRC/openSUSE:Factory/lzlib/lzlib.changes  2016-06-02 
09:38:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.lzlib.new/lzlib.changes 2018-02-20 
17:55:58.112534585 +0100
@@ -1,0 +2,21 @@
+Sun Feb 18 21:41:57 UTC 2018 - avin...@opensuse.org
+
+- Update to version 1.10:
+  * LZ_compress_finish now adjusts dictionary size for each member.
+  * lzlib.c (LZ_decompress_read): Detect corrupt header with HD=3.
+  * main.c: Added new option '--loose-trailing'.
+  * main.c (main): Option '-S, --volume-size' now keeps input files.
+  * main.c: Replaced 'bits/byte' with inverse compression ratio.
+  * main.c: Show final diagnostic when testing multiple files.
+  * main.c: Do not add a second .lz extension to the arg of -o.
+  * main.c: Show dictionary size at verbosity level 4 (-).
+  * lzlib.texi: Added chapter 'Invoking minilzip'.
+- Includes 1.9:
+  * Compression time of option '-0' has been reduced by 3%.
+  * Compression time of options -1 to -9 has been reduced by 1%.
+  * Decompression time has been reduced by 3%.
+  * main.c: Continue testing if any input file is a terminal.
+  * License of the library changed to "2-clause BSD".
+- partial cleanup with spec-cleaner
+
+---

Old:

  lzlib-1.8.tar.gz
  lzlib-1.8.tar.gz.sig

New:

  lzlib-1.10.tar.gz
  lzlib-1.10.tar.gz.sig



Other differences:
--
++ lzlib.spec ++
--- /var/tmp/diff_new_pack.sFQLTs/_old  2018-02-20 17:55:59.244493827 +0100
+++ /var/tmp/diff_new_pack.sFQLTs/_new  2018-02-20 17:55:59.248493683 +0100
@@ -2,7 +2,7 @@
 #
 # spec file for package lzlib
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2012 Pascal Bleser 
 #
 # All modifications and additions to the file contributed by third parties
@@ -18,19 +18,17 @@
 #
 
 
-Name:   lzlib
 %define lname liblz1
-Version:1.8
+Name:   lzlib
+Version:1.10
 Release:0
 Summary:LZMA Compression and Decompression Library
-License:GPL-2.0+
+License:BSD-2-Clause
 Group:  Development/Libraries/C and C++
-Url:http://www.nongnu.org/lzip/lzlib.html
-
-Source: 
http://download.savannah.gnu.org/releases/lzip/lzlib/%name-%version.tar.gz
-Source2:
http://download.savannah.gnu.org/releases/lzip/lzlib/%name-%version.tar.gz.sig
+Url:https://www.nongnu.org/lzip/lzlib.html
+Source: 
https://download.savannah.gnu.org/releases/lzip/lzlib/%name-%version.tar.gz
+Source2:
https://download.savannah.gnu.org/releases/lzip/lzlib/%name-%version.tar.gz.sig
 Source3:%name.keyring
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 PreReq: %install_info_prereq
 
 %description
@@ -82,19 +80,19 @@
 --mandir="%{_mandir}" \
 --sysconfdir="%{_sysconfdir}" \
 --enable-shared \
-CXX="%__cxx" \
+CXX="g++" \
 CPPFLAGS="%{optflags}" \
 CXXFLAGS="%{optflags}"
 
-make %{?_smp_flags}
+make %{?_smp_mflags}
 
 %install
-make DESTDIR="%{buildroot}" LDCONFIG=echo install
+%make_install LDCONFIG=echo
 # configure had no --disable-static
 rm -f "%buildroot/%_libdir"/*.a
 
 %check
-make check
+make %{?_smp_mflags} check
 
 %post   -n %lname -p /sbin/ldconfig
 %postun -n %lname -p /sbin/ldconfig
@@ -106,14 +104,12 @@
 %install_info_delete --info-dir="%_infodir" "%_infodir/%name.info%ext_info"
 
 %files -n %lname
-%defattr(-,root,root)
 %doc AUTHORS ChangeLog COPYING NEWS README
 %{_libdir}/liblz.so.*
 
 %files devel
-%defattr(-,root,root)
 %{_includedir}/lzlib.h
 %{_libdir}/liblz.so
-%doc %{_infodir}/lzlib.info%{ext_info}
+%{_infodir}/lzlib.info%{ext_info}
 
 %changelog

++ lzlib-1.8.tar.gz -> lzlib-1.10.tar.gz ++
 5759 lines of diff (skipped)




commit geary for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package geary for openSUSE:Factory checked 
in at 2018-02-20 17:55:20

Comparing /work/SRC/openSUSE:Factory/geary (Old)
 and  /work/SRC/openSUSE:Factory/.geary.new (New)


Package is "geary"

Tue Feb 20 17:55:20 2018 rev:34 rq:578044 version:0.12.1

Changes:

--- /work/SRC/openSUSE:Factory/geary/geary.changes  2017-10-05 
12:07:11.665597512 +0200
+++ /work/SRC/openSUSE:Factory/.geary.new/geary.changes 2018-02-20 
17:55:30.681522290 +0100
@@ -1,0 +2,9 @@
+Tue Feb 13 16:27:00 UTC 2018 - dims...@opensuse.org
+
+- Update to version 0.12.1:
+  + Bugs fixed: bgo#713607, bgo#754802, bgo#770618, bgo#771504,
+bgo#778720, bgo#779369, bgo#781178, bgo#781488, bgo#784300,
+bgo#788494, bgo#788637, bgo#788797.
+  + Updated translations.
+
+---

Old:

  geary-0.12.0.tar.xz

New:

  geary-0.12.1.tar.xz



Other differences:
--
++ geary.spec ++
--- /var/tmp/diff_new_pack.K1OBqn/_old  2018-02-20 17:55:31.589489597 +0100
+++ /var/tmp/diff_new_pack.K1OBqn/_new  2018-02-20 17:55:31.593489453 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package geary
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,13 +17,13 @@
 
 
 Name:   geary
-Version:0.12.0
+Version:0.12.1
 Release:0
 Summary:A lightweight email reader for the GNOME desktop
 License:LGPL-2.0+
 Group:  Productivity/Networking/Email/Clients
 Url:https://wiki.gnome.org/Apps/Geary
-Source: 
https://download.gnome.org/sources/geary/0.12/%{name}-%{version}.tar.xz
+Source: 
http://download.gnome.org/sources/geary/0.12/%{name}-%{version}.tar.xz
 BuildRequires:  cmake
 BuildRequires:  fdupes
 BuildRequires:  intltool

++ geary-0.12.0.tar.xz -> geary-0.12.1.tar.xz ++
 6136 lines of diff (skipped)




commit perl-Mojo-IOLoop-ReadWriteProcess for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package perl-Mojo-IOLoop-ReadWriteProcess 
for openSUSE:Factory checked in at 2018-02-20 17:55:22

Comparing /work/SRC/openSUSE:Factory/perl-Mojo-IOLoop-ReadWriteProcess (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Mojo-IOLoop-ReadWriteProcess.new 
(New)


Package is "perl-Mojo-IOLoop-ReadWriteProcess"

Tue Feb 20 17:55:22 2018 rev:2 rq:578056 version:0.16

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Mojo-IOLoop-ReadWriteProcess/perl-Mojo-IOLoop-ReadWriteProcess.changes
  2018-02-12 14:46:10.448627754 +0100
+++ 
/work/SRC/openSUSE:Factory/.perl-Mojo-IOLoop-ReadWriteProcess.new/perl-Mojo-IOLoop-ReadWriteProcess.changes
 2018-02-20 17:55:33.637415858 +0100
@@ -1,0 +2,28 @@
+Mon Feb 19 13:54:50 UTC 2018 - edigiaci...@suse.com
+
+- updated to 0.16
+   see /usr/share/doc/packages/perl-Mojo-IOLoop-ReadWriteProcess/Changes
+
+  0.16 2018-02-19T13:32:54Z
+
+ - Fix minor issue in event test that made them unstable
+
+  0.15 2018-02-19T10:13:22Z
+
+ - Fix skipping subreaper tests on unsupported platforms
+ - Reset session before invoking child callback
+
+  0.14 2018-02-18T21:08:17Z
+
+ - Fix race condition in Mojo::IOLoop::ReadWriteProcess::Queue
+
+  0.13 2018-02-17T19:34:51Z
+ - Move subreaper and subprocess logics to 
Mojo::IOLoop::ReadWriteProcess::Session
+ - Use Mojo::IOLoop::ReadWriteProcess::Session as global collector handler
+
+  0.12 2018-02-16T12:53:26Z
+
+ - Enhance tests
+ - Add experimental subreaper and subprocess support
+
+---

Old:

  Mojo-IOLoop-ReadWriteProcess-0.11.tar.gz

New:

  Mojo-IOLoop-ReadWriteProcess-0.16.tar.gz



Other differences:
--
++ perl-Mojo-IOLoop-ReadWriteProcess.spec ++
--- /var/tmp/diff_new_pack.2hRyWd/_old  2018-02-20 17:55:34.693377836 +0100
+++ /var/tmp/diff_new_pack.2hRyWd/_new  2018-02-20 17:55:34.697377692 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Mojo-IOLoop-ReadWriteProcess
-Version:0.11
+Version:0.16
 Release:0
 %define cpan_name Mojo-IOLoop-ReadWriteProcess
 Summary:Execute external programs or internal code blocks as separate 
process

++ Mojo-IOLoop-ReadWriteProcess-0.11.tar.gz -> 
Mojo-IOLoop-ReadWriteProcess-0.16.tar.gz ++
 2547 lines of diff (skipped)




commit psgml for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package psgml for openSUSE:Factory checked 
in at 2018-02-20 17:55:58

Comparing /work/SRC/openSUSE:Factory/psgml (Old)
 and  /work/SRC/openSUSE:Factory/.psgml.new (New)


Package is "psgml"

Tue Feb 20 17:55:58 2018 rev:22 rq:578221 version:1.4.1

Changes:

--- /work/SRC/openSUSE:Factory/psgml/psgml.changes  2014-12-16 
14:50:19.0 +0100
+++ /work/SRC/openSUSE:Factory/.psgml.new/psgml.changes 2018-02-20 
17:56:05.552266704 +0100
@@ -1,0 +2,6 @@
+Mon Feb 19 12:53:44 UTC 2018 - k...@suse.com
+
+- Stop loading psgml automatically because of conflicts with js-mode.el;
+  bsc#1080086.
+
+---



Other differences:
--
++ psgml.spec ++
--- /var/tmp/diff_new_pack.iVKFhA/_old  2018-02-20 17:56:07.296203911 +0100
+++ /var/tmp/diff_new_pack.iVKFhA/_new  2018-02-20 17:56:07.300203766 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package psgml
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -129,8 +129,8 @@
 make install-info prefix="$RPM_BUILD_ROOT%{_prefix}" \
   
lispdir="$RPM_BUILD_ROOT%{_prefix}/share/emacs/site-lisp/psgml" \
   infodir="$RPM_BUILD_ROOT%{_infodir}"
-install -p -m644 suse-start-psgml.el \
-$RPM_BUILD_ROOT%{_prefix}/share/emacs/site-lisp/suse-start-psgml.el
+#install -p -m644 suse-start-psgml.el \
+#$RPM_BUILD_ROOT%{_prefix}/share/emacs/site-lisp/suse-start-psgml.el
 install -p -m644 iso88591.map \
 $RPM_BUILD_ROOT%{_prefix}/share/emacs/site-lisp/psgml/iso88591.map
 install -p -m644 tdtd-font.el tdtd-font.elc \
@@ -165,9 +165,10 @@
 %defattr(644,root,root,755)
 %doc README.psgml README.openSUSE
 %doc README.xxml THANKS.xxml
+%doc suse-start-psgml.el
 %doc psgml-jade
 %doc tdtd-readme.txt tdtd-tutorial.txt tdtd.dot.emacs
-%config %{_prefix}/share/emacs/site-lisp/suse-start-psgml.el
+# %config %{_prefix}/share/emacs/site-lisp/suse-start-psgml.el
 %{_prefix}/share/emacs/site-lisp/psgml
 %doc %{_infodir}/psgml-api.info*
 %doc %{_infodir}/psgml.info*

++ psgml-README.openSUSE ++
--- /var/tmp/diff_new_pack.iVKFhA/_old  2018-02-20 17:56:07.408199878 +0100
+++ /var/tmp/diff_new_pack.iVKFhA/_new  2018-02-20 17:56:07.408199878 +0100
@@ -1,3 +1,16 @@
+Warning:
+
+
+suse-start-psgml.el is no longer installed by default, and thus, psgml
+does not start automatically because psgml now sometimes conflicts with
+shipped Emacs modes such as js-mode.el.  If you want to continue using
+suse-start-psgml.el copy it to the site-lisp directory:
+
+cp /usr/share/doc/packages/psgml/suse-start-psgml.el \
+/usr/share/emacs/site-lisp/
+
+
+
 Patches:
 
 
@@ -18,18 +31,17 @@
 Configuration:
 ==
 
-Configuration is done /usr/share/emacs/site-lisp/suse-start-psgml.el;
-The Emacs default installation on SuSE Linux make use of it
-automatically.  If you don't use
-/usr/share/emacs/site-lisp/site-start.el coming with SuSE Linux add to
+Configuration is done with suse-start-psgml.el in
+/usr/share/emacs/site-lisp/ (see the Warning above where you can find it);
+If you do not use
+/usr/share/emacs/site-lisp/site-start.el coming with SUSE Linux add to
 your ~/.emacs:
 
  (load "suse-start-psgml")
 
-or copy the contents of /usr/share/emacs/site-lisp/suse-start-psgml.el
-to your ~/.emacs.
+or copy the contents of suse-start-psgml.el to your ~/.emacs.
+
 
-2001-07-16 12:48:21 CEST -ke-
 
 Comments
 
@@ -45,5 +57,5 @@
 End:
 -->
 
-2001-07-16 12:48:21 CEST -ke-
+
 





commit DisplayCAL for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package DisplayCAL for openSUSE:Factory 
checked in at 2018-02-20 17:55:56

Comparing /work/SRC/openSUSE:Factory/DisplayCAL (Old)
 and  /work/SRC/openSUSE:Factory/.DisplayCAL.new (New)


Package is "DisplayCAL"

Tue Feb 20 17:55:56 2018 rev:17 rq:578213 version:3.5.0.0

Changes:

--- /work/SRC/openSUSE:Factory/DisplayCAL/DisplayCAL.changes2017-12-09 
20:29:33.999608620 +0100
+++ /work/SRC/openSUSE:Factory/.DisplayCAL.new/DisplayCAL.changes   
2018-02-20 17:56:02.452378321 +0100
@@ -1,0 +2,21 @@
+Sun Feb 18 15:09:40 UTC 2018 - o...@hoech.net
+
+- Update to 3.5.0.0:
+  * Maintenance/bugfixes
+  * New application icons and slightly refreshed theme
+  * See README.html#changelog-3.5
+
+---
+Sat Dec 30 15:46:14 UTC 2017 - o...@hoech.net
+
+- Update to 3.4.0.0:
+  * Critical: Prevent bad clipping in case of non-monotonic device
+response
+  * Fix consistency of device to profile mapping accross external
+APIs (this fix is required to match how ArgyllCMS 2.0
+enumerates displays)
+  * HDR improvements
+  * Added simplified chinese translation
+  * See README.html#changelog-3.4
+
+---

Old:

  DisplayCAL-3.3.5.0.tar.gz

New:

  DisplayCAL-3.5.0.0.tar.gz



Other differences:
--
++ DisplayCAL.spec ++
--- /var/tmp/diff_new_pack.kKnKkZ/_old  2018-02-20 17:56:04.536303286 +0100
+++ /var/tmp/diff_new_pack.kKnKkZ/_new  2018-02-20 17:56:04.544302997 +0100
@@ -28,7 +28,7 @@
 License:GPL-3.0+
 Group:  Productivity/Graphics/Other
 Name:   DisplayCAL
-Version:3.3.5.0
+Version:3.5.0.0
 Release:0
 Source0:http://displaycal.net/download/%{name}-%version.tar.gz
 Url:https://displaycal.net/

++ DisplayCAL-3.3.5.0.tar.gz -> DisplayCAL-3.5.0.0.tar.gz ++
/work/SRC/openSUSE:Factory/DisplayCAL/DisplayCAL-3.3.5.0.tar.gz 
/work/SRC/openSUSE:Factory/.DisplayCAL.new/DisplayCAL-3.5.0.0.tar.gz differ: 
char 5, line 1




commit avfs for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package avfs for openSUSE:Factory checked in 
at 2018-02-20 17:56:17

Comparing /work/SRC/openSUSE:Factory/avfs (Old)
 and  /work/SRC/openSUSE:Factory/.avfs.new (New)


Package is "avfs"

Tue Feb 20 17:56:17 2018 rev:5 rq:578264 version:1.0.5

Changes:

--- /work/SRC/openSUSE:Factory/avfs/avfs.changes2017-01-10 
10:43:44.313183813 +0100
+++ /work/SRC/openSUSE:Factory/.avfs.new/avfs.changes   2018-02-20 
17:56:23.479621199 +0100
@@ -1,0 +2,13 @@
+Mon Feb 19 11:24:28 UTC 2018 - aloi...@gmx.com
+
+- Update to version 1.0.5
+  * limit the file cache to 50 elements and age of 10 minutes to
+avoid endless grow of internal cache
+  * allow reproducable builds
+  * fixed crash in parsing ls output for modules which need to
+handle ls-like output
+  * fix urar module when external rar/unrar tool crashed
+
+- Spec cleanup
+
+---

Old:

  avfs-1.0.4.tar.bz2
  avfs-1.0.4.tar.bz2.asc

New:

  avfs-1.0.5.tar.bz2
  avfs-1.0.5.tar.bz2.asc



Other differences:
--
++ avfs.spec ++
--- /var/tmp/diff_new_pack.n3duj2/_old  2018-02-20 17:56:25.887534497 +0100
+++ /var/tmp/diff_new_pack.n3duj2/_new  2018-02-20 17:56:25.891534353 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package avfs
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,14 @@
 
 
 Name:   avfs
-Version:1.0.4
+Version:1.0.5
 Release:0
 Summary:AVFS - an archive look-inside filesystem
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0+ AND LGPL-2.1+
 Group:  Productivity/Archiving/Compression
-Url:http://avf.sourceforge.net/
-Source0:http://downloads.sf.net/avf/%{name}-%{version}.tar.bz2
-Source1:http://downloads.sf.net/avf/%{name}-%{version}.tar.bz2.asc
+URL:http://avf.sourceforge.net/
+Source0:https://downloads.sf.net/avf/%{name}-%{version}.tar.bz2
+Source1:https://downloads.sf.net/avf/%{name}-%{version}.tar.bz2.asc
 Source2:%{name}.keyring
 BuildRequires:  emacs-nox
 BuildRequires:  help2man
@@ -40,7 +40,6 @@
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(neon)
 BuildRequires:  pkgconfig(openssl)
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 AVFS is a filesystem which enables all programs to look inside archived or
@@ -108,8 +107,8 @@
 %postun -n libavfs0 -p /sbin/ldconfig
 
 %files
-%defattr(-,root,root,0755)
-%doc ChangeLog README COPYING NEWS TODO
+%doc ChangeLog README NEWS TODO
+%license COPYING
 %doc doc/api-overview
 %doc doc/background
 %doc doc/FORMAT
@@ -125,14 +124,12 @@
 %{_mandir}/man1/avfsd.1%{ext_man}
 
 %files devel
-%defattr(-,root,root,0755)
 %{_bindir}/avfs-config
 %{_includedir}/avfs.h
 %{_includedir}/virtual.h
 %{_libdir}/libavfs.so
 
 %files -n libavfs0
-%defattr(-,root,root,0755)
 %{_libdir}/libavfs.so.0
 %{_libdir}/libavfs.so.0.0.2
 

++ avfs-1.0.4.tar.bz2 -> avfs-1.0.5.tar.bz2 ++
 21683 lines of diff (skipped)





commit rubygem-devise-i18n for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package rubygem-devise-i18n for 
openSUSE:Factory checked in at 2018-02-20 17:56:07

Comparing /work/SRC/openSUSE:Factory/rubygem-devise-i18n (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-devise-i18n.new (New)


Package is "rubygem-devise-i18n"

Tue Feb 20 17:56:07 2018 rev:31 rq:578241 version:1.6.0

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-devise-i18n/rubygem-devise-i18n.changes  
2018-02-10 17:59:55.772304381 +0100
+++ 
/work/SRC/openSUSE:Factory/.rubygem-devise-i18n.new/rubygem-devise-i18n.changes 
2018-02-20 17:56:11.800041742 +0100
@@ -1,0 +2,6 @@
+Sun Feb 18 05:29:11 UTC 2018 - factory-a...@kulow.org
+
+- updated to version 1.6.0
+  no changelog found
+
+---

Old:

  devise-i18n-1.5.1.gem

New:

  devise-i18n-1.6.0.gem



Other differences:
--
++ rubygem-devise-i18n.spec ++
--- /var/tmp/diff_new_pack.u656wa/_old  2018-02-20 17:56:12.948000408 +0100
+++ /var/tmp/diff_new_pack.u656wa/_new  2018-02-20 17:56:12.948000408 +0100
@@ -24,7 +24,7 @@
 #
 
 Name:   rubygem-devise-i18n
-Version:1.5.1
+Version:1.6.0
 Release:0
 %define mod_name devise-i18n
 %define mod_full_name %{mod_name}-%{version}

++ devise-i18n-1.5.1.gem -> devise-i18n-1.6.0.gem ++
 1744 lines of diff (skipped)




commit zpaq for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package zpaq for openSUSE:Factory checked in 
at 2018-02-20 17:56:22

Comparing /work/SRC/openSUSE:Factory/zpaq (Old)
 and  /work/SRC/openSUSE:Factory/.zpaq.new (New)


Package is "zpaq"

Tue Feb 20 17:56:22 2018 rev:6 rq:578267 version:7.15

Changes:

--- /work/SRC/openSUSE:Factory/zpaq/zpaq.changes2016-10-31 
09:54:59.0 +0100
+++ /work/SRC/openSUSE:Factory/.zpaq.new/zpaq.changes   2018-02-20 
17:56:32.851283756 +0100
@@ -1,0 +2,11 @@
+Mon Feb 19 11:57:39 UTC 2018 - aloi...@gmx.com
+
+- Update to version 7.15
+  * Fixes incorrect JIT assembly of "a+= 128" in libzpaq.
+  version 7.14
+  * Faster backup to a network drive.
+
+- Upstream removed separate shared library and so we drop
+  -devel and libzpaq subpackages
+
+---

Old:

  zpaq713.zip

New:

  zpaq715.zip



Other differences:
--
++ zpaq.spec ++
--- /var/tmp/diff_new_pack.BA2l8N/_old  2018-02-20 17:56:36.011169979 +0100
+++ /var/tmp/diff_new_pack.BA2l8N/_new  2018-02-20 17:56:36.015169835 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package zpaq
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,23 +16,19 @@
 #
 
 
-%define soname   lib%{name}
-%define sover0.1
-%define sonum0_1
-%define dversion 713
+%define dversion 715
 Name:   zpaq
-Version:7.13
+Version:7.15
 Release:0
 Summary:A journaling, incremental, deduplicating archiver for Windows 
and Linux
-License:SUSE-Public-Domain and MIT
+License:SUSE-Public-Domain AND MIT
 Group:  Productivity/Archiving/Compression
-Url:http://mattmahoney.net/dc/zpaq.html
+URL:http://mattmahoney.net/dc/zpaq.html
 Source0:http://mattmahoney.net/dc/zpaq%{dversion}.zip
 Source1:%{name}.changes
 BuildRequires:  dos2unix
 BuildRequires:  gcc-c++
 BuildRequires:  unzip
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 zpaq is a journaling, incremental, deduplicating archiver for Windows and
@@ -49,51 +45,6 @@
 that identical files or fragments are stored only once to save time and
 space.
 
-%package -n %{soname}%{sonum}
-Summary:Shared library for zpaq
-Group:  System/Libraries
-
-%description -n %{soname}%{sonum}
-zpaq is a journaling, incremental, deduplicating archiver for Windows and
-Linux. "Journaling" means that when you update a file or directory, both
-the old and new versions are saved. You can extract from the archive as it
-existed at any time in the past. "Incremental", means that when you back up
-your entire hard drive, for example:
-
-  zpaq -add e:backup.zpaq c:\*
-
-that only those files whose last-modified date has changed since the
-previous backup are added. For 100 GB of files, this typically takes 1-2
-minutes, vs. a few hours to create the first version. "Deduplicating" means
-that identical files or fragments are stored only once to save time and
-space.
-
-This package contains shared library
-
-%packagedevel
-Summary:Development files for zpaq
-Group:  Development/Languages/C and C++
-Requires:   %{soname}%{sonum} = %{version}-%{release}
-Provides:   %{soname}-devel = %{version}
-Obsoletes:  %{soname}-devel < %{version}
-
-%description devel
-zpaq is a journaling, incremental, deduplicating archiver for Windows and
-Linux. "Journaling" means that when you update a file or directory, both
-the old and new versions are saved. You can extract from the archive as it
-existed at any time in the past. "Incremental", means that when you back up
-your entire hard drive, for example:
-
-  zpaq -add e:backup.zpaq c:\*
-
-that only those files whose last-modified date has changed since the
-previous backup are added. For 100 GB of files, this typically takes 1-2
-minutes, vs. a few hours to create the first version. "Deduplicating" means
-that identical files or fragments are stored only once to save time and
-space.
-
-This package contains development files
-
 %prep
 %setup -q -c %{name}%{dversion}
 dos2unix readme.txt COPYING
@@ -116,24 +67,10 @@
   MANDIR="%{_mandir}" \
   INCLUDEDIR="%{_includedir}" \
 
-%post -n %{soname}%{sonum} -p /sbin/ldconfig
-%postun -n %{soname}%{sonum} -p /sbin/ldconfig
-
 %files
-%defattr(-,root,root,-)
-%doc COPYING readme.txt
+%doc readme.txt
+%license COPYING
 %{_bindir}/%{name}
 %{_mandir}/man1/%{name}.1%{ext_man}
 
-%files -n 

commit par for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package par for openSUSE:Factory checked in 
at 2018-02-20 17:55:27

Comparing /work/SRC/openSUSE:Factory/par (Old)
 and  /work/SRC/openSUSE:Factory/.par.new (New)


Package is "par"

Tue Feb 20 17:55:27 2018 rev:18 rq:578144 version:0.8.0

Changes:

--- /work/SRC/openSUSE:Factory/par/par.changes  2016-11-24 21:24:43.0 
+0100
+++ /work/SRC/openSUSE:Factory/.par.new/par.changes 2018-02-20 
17:55:40.185180094 +0100
@@ -1,0 +2,42 @@
+Mon Feb 19 11:37:23 UTC 2018 - aloi...@gmx.com
+
+- Update to version 0.8.0
+  * improved parallelisation on input files
+  version 0.7.4
+  * performance improvement when not using quiet mode
+  version 0.7.3
+  * fixed critical issue on windows where created parfiles were
+corrupt
+  version 0.7.2
+  * fixed tests on NetBSD, #102
+  * fixed failing tests when dir contains whitespace, #103
+  * added automake.sh to the files, #104
+  * changed some flags related to windows build, #94
+  * cleaned up compiler warnings for mingw build
+  version 0.7.1
+  * fixed basepath issues #93
+  * made distcheck behaviour consistent with different
+--srcdir #96
+  * properly package distribution package #98
+  * cross compile for windows to get redistributable exe #94
+  * change distribution format to tar.gz and tar.bz2 for unix
+and keep zip for windows #97
+  version 0.7.0
+  * Merged OpenMP version and so enabled multithreading
++ added -t flag to set the number of threads (all possible
+  threads used by default)
+  * Added -B flag to set the basepath for difficult to guess
+situations
+  * bugfixes
+  version 0.6.5
+  * fix blocksize calculation
+  * lintian warning spelling fix
+  * add manfile for par2
+  * README in Markdown
+  * add spelling fixes to cmdline output
+  * fixed some spelling
+  * simplify FindFiles
+
+- Spec cleanup
+
+---

Old:

  par-0.6.14.tar.gz

New:

  par-0.8.0.tar.gz



Other differences:
--
++ par.spec ++
--- /var/tmp/diff_new_pack.D7hFZQ/_old  2018-02-20 17:55:41.737124212 +0100
+++ /var/tmp/diff_new_pack.D7hFZQ/_new  2018-02-20 17:55:41.741124068 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package par
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,19 +17,18 @@
 
 
 Name:   par
-Version:0.6.14
+Version:0.8.0
 Release:0
 Summary:Parity File Generator
 License:GPL-2.0+
 Group:  System/Filesystems
-Url:https://github.com/Parchive/par2cmdline
+URL:https://github.com/Parchive/par2cmdline
 Source0:
https://github.com/Parchive/par2cmdline/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  gcc-c++
 Provides:   %{name} = 1.1
 Obsoletes:  %{name} = 1.1
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 Parchive creates extra parity data over several volumes. These can be
@@ -52,8 +51,8 @@
 chmod -x ChangeLog
 
 %files
-%defattr(-,root,root)
-%doc README AUTHORS COPYING ChangeLog
+%doc README AUTHORS ChangeLog
+%license COPYING
 %{_bindir}/par2
 %{_bindir}/par2create
 %{_bindir}/par2repair

++ par-0.6.14.tar.gz -> par-0.8.0.tar.gz ++
 33726 lines of diff (skipped)




commit python-tooz for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package python-tooz for openSUSE:Factory 
checked in at 2018-02-20 17:55:25

Comparing /work/SRC/openSUSE:Factory/python-tooz (Old)
 and  /work/SRC/openSUSE:Factory/.python-tooz.new (New)


Package is "python-tooz"

Tue Feb 20 17:55:25 2018 rev:5 rq:578062 version:1.60.0

Changes:

--- /work/SRC/openSUSE:Factory/python-tooz/python-tooz.changes  2017-11-29 
10:53:02.227829171 +0100
+++ /work/SRC/openSUSE:Factory/.python-tooz.new/python-tooz.changes 
2018-02-20 17:55:35.853336069 +0100
@@ -1,0 +2,8 @@
+Mon Feb 19 14:41:56 UTC 2018 - cloud-de...@suse.de
+
+- update to version 1.60.0
+  - Update .gitreview for stable/queens
+  - Use native Zuul v3 tox jobs
+  - msgpack-python has been renamed to msgpack
+
+---

Old:

  tooz-1.59.0.tar.gz

New:

  tooz-1.60.0.tar.gz



Other differences:
--
++ python-tooz.spec ++
--- /var/tmp/diff_new_pack.rwcxWs/_old  2018-02-20 17:55:37.109290846 +0100
+++ /var/tmp/diff_new_pack.rwcxWs/_new  2018-02-20 17:55:37.113290702 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-tooz
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,11 @@
 
 
 %global pypi_name tooz
+%if 0%{?rhel} || 0%{?fedora}
+%global rdo 1
+%endif
 Name:   python-tooz
-Version:1.59.0
+Version:1.60.0
 Release:0
 Summary:Coordination library for distributed systems
 License:Apache-2.0
@@ -28,33 +31,33 @@
 BuildRequires:  memcached
 BuildRequires:  openstack-macros
 BuildRequires:  python-devel
-BuildRequires:  python-enum34
-BuildRequires:  python-fasteners >= 0.7
+BuildRequires:  python-enum34 >= 1.0.4
+BuildRequires:  python-fasteners >= 0.7.0
 BuildRequires:  python-fixtures >= 3.0.0
-BuildRequires:  python-futures >= 3.0
-BuildRequires:  python-futurist >= 0.11.0
+BuildRequires:  python-futures >= 3.0.0
+BuildRequires:  python-futurist >= 1.2.0
 BuildRequires:  python-iso8601 >= 0.1.11
-BuildRequires:  python-mock >= 2.0
-BuildRequires:  python-oslo.serialization >= 1.10.0
-BuildRequires:  python-oslo.utils >= 3.20.0
+BuildRequires:  python-mock >= 2.0.0
+BuildRequires:  python-oslo.serialization >= 2.18.0
+BuildRequires:  python-oslo.utils >= 3.33.0
 BuildRequires:  python-pbr >= 2.0.0
 BuildRequires:  python-pifpaf >= 0.10.0
 BuildRequires:  python-pymemcache >= 1.2.9
 BuildRequires:  python-setuptools >= 16.0
 BuildRequires:  python-stevedore >= 1.20.0
 BuildRequires:  python-tenacity >= 3.2.1
-BuildRequires:  python-testtools >= 1.4.0
+BuildRequires:  python-testtools >= 2.2.0
 BuildRequires:  python-voluptuous >= 0.8.9
 Requires:   python-Babel >= 2.3.4
-Requires:   python-enum34
-Requires:   python-fasteners >= 0.7
-Requires:   python-futures >= 3.0
-Requires:   python-futurist >= 0.11.0
+Requires:   python-enum34 >= 1.0.4
+Requires:   python-fasteners >= 0.7.0
+Requires:   python-futures >= 3.0.0
+Requires:   python-futurist >= 1.2.0
 Requires:   python-iso8601 >= 0.1.11
-Requires:   python-msgpack-python >= 0.4.0
-Requires:   python-oslo.serialization >= 1.10.0
-Requires:   python-oslo.utils >= 3.20.0
-Requires:   python-six >= 1.9.0
+Requires:   python-msgpack >= 0.4.0
+Requires:   python-oslo.serialization >= 2.18.0
+Requires:   python-oslo.utils >= 3.33.0
+Requires:   python-six >= 1.10.0
 Requires:   python-stevedore >= 1.20.0
 Requires:   python-tenacity >= 3.2.1
 Requires:   python-voluptuous >= 0.8.9
@@ -68,9 +71,9 @@
 
 %package doc
 Summary:Documentation for %{name}
-Group:  Documentation
+Group:  Documentation/HTML
 BuildRequires:  python-Sphinx
-BuildRequires:  python-openstackdocstheme >= 1.11.0
+BuildRequires:  python-openstackdocstheme >= 1.17.0
 BuildRequires:  python-redis >= 2.10.0
 
 %description doc
@@ -94,9 +97,11 @@
 rm -rf html/.{doctrees,buildinfo}
 
 %check
+%if ! 0%{?rdo}
 export TOOZ_TEST_DRIVERS="memcached"
 export PATH=%{_prefix}/sbin:$PATH
 bash run-tests.sh
+%endif
 
 %install
 %py2_install

++ tooz-1.59.0.tar.gz -> tooz-1.60.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tooz-1.59.0/.zuul.yaml new/tooz-1.60.0/.zuul.yaml
--- old/tooz-1.59.0/.zuul.yaml  1970-01-01 01:00:00.0 +0100
+++ new/tooz-1.60.0/.zuul.yaml  2018-02-15 21:04:44.0 +0100
@@ -0,0 +1,229 @@
+- project:
+check:
+  jobs:
+- tooz-tox-py27-etcd
+

commit pdsh for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package pdsh for openSUSE:Factory checked in 
at 2018-02-20 17:56:05

Comparing /work/SRC/openSUSE:Factory/pdsh (Old)
 and  /work/SRC/openSUSE:Factory/.pdsh.new (New)


Package is "pdsh"

Tue Feb 20 17:56:05 2018 rev:33 rq:578240 version:2.33

Changes:

--- /work/SRC/openSUSE:Factory/pdsh/pdsh.changes2018-02-18 
11:46:06.073551873 +0100
+++ /work/SRC/openSUSE:Factory/.pdsh.new/pdsh.changes   2018-02-20 
17:56:09.900110152 +0100
@@ -1,0 +2,8 @@
+Tue Feb 20 06:16:24 UTC 2018 - e...@suse.com
+
+- Since the different host-list plugins have conflicting
+  options and a 'the first one wins' policy is not well
+  defined, package all of them separately and make ones
+  with identical options conflict (bsc#1081673).
+
+---



Other differences:
--
++ pdsh.spec ++
--- /var/tmp/diff_new_pack.gvQrwX/_old  2018-02-20 17:56:11.172064353 +0100
+++ /var/tmp/diff_new_pack.gvQrwX/_new  2018-02-20 17:56:11.176064209 +0100
@@ -73,11 +73,43 @@
 Summary:Genders plugin for pdsh
 Group:  Productivity/Clustering/Computing
 Requires:   pdsh = %{version}
+Conflicts:  pdsh-netgroup
+Conflicts:  pdsh-dshgroup
+Conflicts:  pdsh-machines
 
 %description genders
 Plugin for pdsh to determine nodes to run on by genders attributes.
 %endif
 
+%package machines
+Summary:Machines plugin for pdsh
+Group:  Productivity/Clustering/Computing
+Requires:   pdsh = %{version}
+Conflicts:  pdsh-genders
+
+%description machines
+Plugin for pdsh to determine nodes to run on from machines file.
+
+%package dshgroup
+Summary:Dsh plugin for pdsh
+Group:  Productivity/Clustering/Computing
+Requires:   pdsh = %{version}
+Conflicts:  pdsh-genders
+Conflicts:  pdsh-netgroup
+
+%description dshgroup
+Plugin for pdsh to determine nodes from dsh-style "group" files
+
+%package netgroup
+Summary:Netgroup plugin for pdsh
+Group:  Productivity/Clustering/Computing
+Requires:   pdsh = %{version}
+Conflicts:  pdsh-genders
+Conflicts:  pdsh-dshgroup
+
+%description netgroup
+Plugin for pdsh to determine nodes to run on from netgroups.
+
 %prep
 %setup -q 
 
@@ -117,6 +149,9 @@
 %_libdir/pdsh
 %{?have_genders:%exclude %_libdir/pdsh/genders.so}
 %{?have_slurm:%exclude %_libdir/pdsh/slurm.so}
+%exclude %_libdir/pdsh/machines.so
+%exclude %_libdir/pdsh/dshgroup.so
+%exclude %_libdir/pdsh/netgroup.so
 
 %if 0%{?have_slurm}
 %files slurm
@@ -130,4 +165,16 @@
 %_libdir/pdsh/genders.so
 %endif
 
+%files machines
+%defattr(-,root,root)
+%_libdir/pdsh/machines.so
+
+%files dshgroup
+%defattr(-,root,root)
+%_libdir/pdsh/dshgroup.so
+
+%files netgroup
+%defattr(-,root,root)
+%_libdir/pdsh/netgroup.so
+
 %changelog




commit platformsh-cli for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package platformsh-cli for openSUSE:Factory 
checked in at 2018-02-20 17:55:41

Comparing /work/SRC/openSUSE:Factory/platformsh-cli (Old)
 and  /work/SRC/openSUSE:Factory/.platformsh-cli.new (New)


Package is "platformsh-cli"

Tue Feb 20 17:55:41 2018 rev:36 rq:578163 version:3.29.1

Changes:

--- /work/SRC/openSUSE:Factory/platformsh-cli/platformsh-cli.changes
2018-02-13 10:32:20.082756333 +0100
+++ /work/SRC/openSUSE:Factory/.platformsh-cli.new/platformsh-cli.changes   
2018-02-20 17:55:46.816941304 +0100
@@ -1,0 +2,15 @@
+Mon Feb 19 17:19:37 UTC 2018 - ji...@boombatower.com
+
+- Update to version 3.29.1:
+  * Release v3.29.1
+  * Add self:release command
+  * Fix array to string conversion in project identifier
+  * [auth:browser-login] Always show help message
+  * [activity:get] [activity:log] Match partial activity IDs
+  * New line tweak [skip changelog]
+  * Add self:stats command
+  * [project:create] Get the list of regions dynamically
+  * [activity:log] Do not require ANSI check for polling/logging
+  * Merge metadata back from master [skip changelog]
+
+---

Old:

  platformsh-cli-3.29.0.tar.xz

New:

  platformsh-cli-3.29.1.tar.xz



Other differences:
--
++ platformsh-cli.spec ++
--- /var/tmp/diff_new_pack.5mtXT3/_old  2018-02-20 17:55:48.168892624 +0100
+++ /var/tmp/diff_new_pack.5mtXT3/_new  2018-02-20 17:55:48.172892480 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   platformsh-cli
-Version:3.29.0
+Version:3.29.1
 Release:0
 Summary:Tool for managing Platform.sh services from the command line
 # See licenses.txt for dependency licenses.

++ _service ++
--- /var/tmp/diff_new_pack.5mtXT3/_old  2018-02-20 17:55:48.208891184 +0100
+++ /var/tmp/diff_new_pack.5mtXT3/_new  2018-02-20 17:55:48.216890896 +0100
@@ -2,7 +2,7 @@
   
 @PARENT_TAG@
 v(.*)
-refs/tags/v3.29.0
+refs/tags/v3.29.1
 git://github.com/platformsh/platformsh-cli.git
 git
 enable

++ _servicedata ++
--- /var/tmp/diff_new_pack.5mtXT3/_old  2018-02-20 17:55:48.240890032 +0100
+++ /var/tmp/diff_new_pack.5mtXT3/_new  2018-02-20 17:55:48.240890032 +0100
@@ -1,6 +1,6 @@
 
   
 git://github.com/platformsh/platformsh-cli.git
-55eff65515f99bd641aff9905c3b664f1119fc79
+eca9da9648826c4932b4b74f5fc6d4d3717dc6e3
   
 

++ licenses.txt ++
--- /var/tmp/diff_new_pack.5mtXT3/_old  2018-02-20 17:55:48.300887871 +0100
+++ /var/tmp/diff_new_pack.5mtXT3/_new  2018-02-20 17:55:48.300887871 +0100
@@ -16,8 +16,8 @@
 padraic/humbug_get_contents 1.0.4BSD-3-Clause  
 padraic/phar-updater1.0.4BSD-3-Clause  
 paragonie/random_compat v2.0.11  MIT   
-platformsh/client   v0.14.1  MIT   
-platformsh/console-form v0.0.15  MIT   
+platformsh/client   v0.15.0  MIT   
+platformsh/console-form v0.0.16  MIT   
 psr/container   1.0.0MIT   
 psr/log 1.0.2MIT   
 react/promise   v2.5.1   MIT   

++ platformsh-cli-3.29.0.tar.xz -> platformsh-cli-3.29.1.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/platformsh-cli-3.29.0/composer.json 
new/platformsh-cli-3.29.1/composer.json
--- old/platformsh-cli-3.29.0/composer.json 2018-02-12 10:10:33.0 
+0100
+++ new/platformsh-cli-3.29.1/composer.json 2018-02-19 13:10:22.0 
+0100
@@ -7,8 +7,8 @@
 "doctrine/cache": "~1.5",
 "guzzlehttp/guzzle": "^5.3",
 "guzzlehttp/ringphp": "^1.1",
-"platformsh/console-form": ">=0.0.14 <2.0",
-"platformsh/client": ">=0.14.0 <2.0",
+"platformsh/console-form": ">=0.0.16 <2.0",
+"platformsh/client": ">=0.15.0 <2.0",
 "symfony/console": "^3.0 !=3.2.5 !=3.2.6",
 "symfony/yaml": "^3.0 || ^2.6",
 "symfony/finder": "^3.0",
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/platformsh-cli-3.29.0/composer.lock 
new/platformsh-cli-3.29.1/composer.lock
--- old/platformsh-cli-3.29.0/composer.lock 2018-02-12 10:10:33.0 
+0100
+++ new/platformsh-cli-3.29.1/composer.lock 2018-02-19 13:10:22.0 
+0100
@@ -4,7 +4,7 @@
 "Read more about it at 
https://getcomposer.org/doc/01-basic-usage.md#composer-lock-the-lock-file;,
 "This file is @generated automatically"
 ],
-"content-hash": "99aec30edb51fe7608bde25ca891ca04",
+"content-hash": 

commit haveged for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package haveged for openSUSE:Factory checked 
in at 2018-02-20 17:53:17

Comparing /work/SRC/openSUSE:Factory/haveged (Old)
 and  /work/SRC/openSUSE:Factory/.haveged.new (New)


Package is "haveged"

Tue Feb 20 17:53:17 2018 rev:48 rq:577945 version:1.9.2

Changes:

--- /work/SRC/openSUSE:Factory/haveged/haveged.changes  2016-06-29 
15:02:33.0 +0200
+++ /work/SRC/openSUSE:Factory/.haveged.new/haveged.changes 2018-02-20 
17:53:24.102080073 +0100
@@ -1,0 +2,11 @@
+Sun Feb 18 20:27:41 UTC 2018 - avin...@opensuse.org
+
+- update to 1.9.2
+  * Cross compile fixes
+  * Limit watermark max to less than pool size to avoid 100% cpu
+condition
+  * Add service.suse init script
+- drop fix-enforced-clock-gettime.patch (fixed upstream)
+- cleanup with spec-cleaner
+
+---

Old:

  fix-enforced-clock-gettime.patch
  haveged-1.9.1.tar.gz

New:

  haveged-1.9.2.tar.gz



Other differences:
--
++ haveged.spec ++
--- /var/tmp/diff_new_pack.AttgBi/_old  2018-02-20 17:53:25.738021166 +0100
+++ /var/tmp/diff_new_pack.AttgBi/_new  2018-02-20 17:53:25.742021022 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package haveged
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,8 +16,9 @@
 #
 
 
+%{!?_udevrulesdir: %global _udevrulesdir %(pkg-config --variable=udevdir 
udev)/rules.d }
 Name:   haveged
-Version:1.9.1
+Version:1.9.2
 Release:0
 Summary:Feed entropy into random pool
 License:GPL-3.0
@@ -30,15 +31,16 @@
 Patch0: ppc64le.patch
 # PATCH-FIX-UPSTREAM: ent tests randomly fail so make them conditional 
tchva...@suse.cz bnc#876674
 Patch1: haveged-conditional-enttest.patch
-# PATCH-FIX-OPENSUSE: ignore clock-gettime enablement on generic architectures
-Patch2: fix-enforced-clock-gettime.patch
 # PATCH-FIX-UPSTREAM: don't write to syslog at startup to avoid deadlocks 
psim...@suse.com bnc#959237
 Patch3: haveged-no-syslog.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  libtool
+BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(systemd)
 BuildRequires:  pkgconfig(udev)
+Requires(post): coreutils
+Requires(postun): coreutils
 Enhances:   apache2
 Enhances:   gpg2
 Enhances:   openssl
@@ -46,11 +48,7 @@
 Enhances:   php5
 Enhances:   smtp_daemon
 Enhances:   systemd
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %{?systemd_requires}
-%{!?_udevrulesdir: %global _udevrulesdir %(pkg-config --variable=udevdir 
udev)/rules.d }
-Requires(post): coreutils
-Requires(postun): coreutils
 
 %description
 The haveged daemon feeds the linux entropy pool with random
@@ -82,7 +80,6 @@
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2
 %patch3 -p1
 
 %build
@@ -102,21 +99,21 @@
 #XXX: nist test is killed by SIGKILL with static int random_pool1[_32MB] on
 # 32bit. Let change it to _08MB to avoid the test beeing killed, even if I
 # am not sure allocate of 128M is prohibited
-%ifarch %ix86
+%ifarch %{ix86}
 sed -i 's/\[_32MB\]/[_08MB]/' nist/nist.c
 %endif
 
 make %{?_smp_mflags} check
 
 %install
-make DESTDIR=%{buildroot} install %{?_smp_mflags}
+%make_install
 install -D -m0644 %{SOURCE2} %{buildroot}%{_unitdir}/%{name}.service
-install -D -m0644 %{SOURCE3} %{buildroot}%{_udevrulesdir}/90-haveged.rules
+install -D -m0644 %{SOURCE3} %{buildroot}%{_udevrulesdir}/90-%{name}.rules
 rm -f %{buildroot}%{_libdir}/libhavege.*a
 ln -s %{_sbindir}/service %{buildroot}%{_sbindir}/rc%{name}
 
-install -d -m0755 %{buildroot}/usr/lib/dracut/modules.d/98haveged
-install -m0755 %{SOURCE4} 
%{buildroot}/usr/lib/dracut/modules.d/98haveged/module-setup.sh
+install -d -m0755 %{buildroot}%{_prefix}/lib/dracut/modules.d/98%{name}
+install -m0755 %{SOURCE4} 
%{buildroot}%{_prefix}/lib/dracut/modules.d/98%{name}/module-setup.sh
 
 %post
 %{?udev_rules_update:%udev_rules_update}
@@ -137,33 +134,29 @@
 %service_del_preun %{name}.service
 
 %post -n libhavege1 -p /sbin/ldconfig
-
 %postun -n libhavege1 -p /sbin/ldconfig
 
 %files
-%defattr(-,root,root)
 %doc COPYING
 %{_sbindir}/rc%{name}
 %{_sbindir}/%{name}
-%doc %{_mandir}/man8/%{name}.8*
+%{_mandir}/man8/%{name}.8%{ext_man}
 %{_unitdir}/%{name}.service
-%{_udevrulesdir}/90-haveged.rules
-%dir /usr/lib/dracut
-%dir /usr/lib/dracut/modules.d
-%dir /usr/lib/dracut/modules.d/98haveged
-/usr/lib/dracut/modules.d/98haveged/module-setup.sh
+%{_udevrulesdir}/90-%{name}.rules

commit wxWidgets-3_0 for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package wxWidgets-3_0 for openSUSE:Factory 
checked in at 2018-02-20 17:53:06

Comparing /work/SRC/openSUSE:Factory/wxWidgets-3_0 (Old)
 and  /work/SRC/openSUSE:Factory/.wxWidgets-3_0.new (New)


Package is "wxWidgets-3_0"

Tue Feb 20 17:53:06 2018 rev:24 rq:577900 version:3.0.3

Changes:

--- /work/SRC/openSUSE:Factory/wxWidgets-3_0/wxWidgets-3_0-nostl.changes
2018-01-26 13:57:06.375964275 +0100
+++ /work/SRC/openSUSE:Factory/.wxWidgets-3_0.new/wxWidgets-3_0-nostl.changes   
2018-02-20 17:53:14.534424582 +0100
@@ -1,0 +2,7 @@
+Sat Feb 17 09:36:15 UTC 2018 - martin.koeg...@chello.at
+
+- Prevent breaking binaries, if C++11 is enabled
+  http://trac.wxwidgets.org/ticket/18034
+  Add 0001-18034-stick-with-compile-settings-detected-at-config.patch
+
+---
wxWidgets-3_0.changes: same change

New:

  0001-18034-stick-with-compile-settings-detected-at-config.patch



Other differences:
--
++ wxWidgets-3_0-nostl.spec ++
--- /var/tmp/diff_new_pack.7WUvg8/_old  2018-02-20 17:53:16.458355305 +0100
+++ /var/tmp/diff_new_pack.7WUvg8/_new  2018-02-20 17:53:16.458355305 +0100
@@ -48,6 +48,7 @@
 Patch17:relax-abi.diff
 Patch18:0001-spinctrl.patch
 Patch19:0002-spinctrl.patch
+Patch20:0001-18034-stick-with-compile-settings-detected-at-config.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 #Link SDL2 for newer distros
@@ -259,6 +260,7 @@
 %patch -P 17 -p1
 %patch -P 18 -p1
 %patch -P 19 -p1
+%patch -P 20 -p1
 cp %{S:2} .
 
 %build

wxWidgets-3_0.spec: same change
++ 0001-18034-stick-with-compile-settings-detected-at-config.patch ++
>From c585363db117ab928256586bcf76231a612bd0ca Mon Sep 17 00:00:00 2001
From: Martin Koegler 
Date: Sat, 30 Dec 2017 09:51:25 +
Subject: [PATCH]  #18034 stick with compile settings detected at configure
 time

---
 include/wx/defs.h | 6 --
 1 file changed, 6 deletions(-)

diff --git a/include/wx/defs.h b/include/wx/defs.h
index 2c5cdeeeb6..6a2a779081 100644
--- a/include/wx/defs.h
+++ b/include/wx/defs.h
@@ -378,12 +378,6 @@
 #ifndef HAVE_TYPE_TRAITS
 #define HAVE_TYPE_TRAITS
 #endif
-#ifndef HAVE_STD_UNORDERED_MAP
-#define HAVE_STD_UNORDERED_MAP
-#endif
-#ifndef HAVE_STD_UNORDERED_SET
-#define HAVE_STD_UNORDERED_SET
-#endif
 #elif defined(__has_include)
 /*
 Notice that we trust our configure tests more than __has_include(),
-- 
2.13.6




commit remmina for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package remmina for openSUSE:Factory checked 
in at 2018-02-20 17:56:50

Comparing /work/SRC/openSUSE:Factory/remmina (Old)
 and  /work/SRC/openSUSE:Factory/.remmina.new (New)


Package is "remmina"

Tue Feb 20 17:56:50 2018 rev:22 rq:578289 version:1.2.0~rcgit.27

Changes:

--- /work/SRC/openSUSE:Factory/remmina/remmina.changes  2018-01-09 
14:53:16.859555241 +0100
+++ /work/SRC/openSUSE:Factory/.remmina.new/remmina.changes 2018-02-20 
17:58:27.799144930 +0100
@@ -1,0 +2,26 @@
+Fri Feb 16 08:17:21 UTC 2018 - jweberho...@weberhofer.at
+
+- Fix compilation on factory: upstream fix 
644cd140a387c7b5d3805b8af9554e241d5d2954.patch
+  for github#FreeRDP/Remmina#1476
+
+---
+Thu Feb 15 07:10:58 UTC 2018 - jweberho...@weberhofer.at
+
+- Updated dependencies
+
+- Upgraded to 1.2.0-rcgit.27
+
+  Implemented enhancements:
+  * Remmina usage statistics collection
+  * Remmina stats: Profiles and protocols counter
+  * Updated freerdp on flatpak definition file
+
+  Fixed bugs:
+  * RDP + DYNRES: Screen is black immediately after connection and becames
+visible only later when DISP_DVC_CHANNEL_NAME is connected
+
+  Other improvements:
+  * Add initial [MS-RDPEGFX] software support
+  * Permit SCALE_MODE_DYNRES before DISP_DVC_CHANNEL_NAME is enabled.
+
+---

Old:

  Remmina-1.2.0-rcgit.26.tar.gz

New:

  644cd140a387c7b5d3805b8af9554e241d5d2954.patch
  Remmina-1.2.0-rcgit.27.tar.gz



Other differences:
--
++ remmina.spec ++
--- /var/tmp/diff_new_pack.sNtqPt/_old  2018-02-20 17:58:29.071099151 +0100
+++ /var/tmp/diff_new_pack.sNtqPt/_new  2018-02-20 17:58:29.075099007 +0100
@@ -16,16 +16,18 @@
 #
 
 
-%define realver 1.2.0-rcgit.26
+%define realver 1.2.0-rcgit.27
 %bcond_with nx
 Name:   remmina
-Version:1.2.0~rcgit.26
+Version:1.2.0~rcgit.27
 Release:0
 Summary:Versatile Remote Desktop Client
 License:GPL-2.0+
 Group:  Productivity/Networking/Other
 URL:http://www.remmina.org/
 Source0:
https://github.com/FreeRDP/Remmina/archive/v%{realver}.tar.gz#/Remmina-%{realver}.tar.gz
+# PATCH-FIX-UPSTREAM 644cd140a387c7b5d3805b8af9554e241d5d2954.patch 
github#FreeRDP/Remmina#1476 jweberho...@weberhofer.at -- Fix compilation on 
factory
+Patch0: 644cd140a387c7b5d3805b8af9554e241d5d2954.patch
 BuildRequires:  cmake
 BuildRequires:  ed
 BuildRequires:  intltool
@@ -41,7 +43,9 @@
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(gnutls)
 BuildRequires:  pkgconfig(gtk+-3.0)
+BuildRequires:  pkgconfig(json-glib-1.0)
 BuildRequires:  pkgconfig(libsecret-1)
+BuildRequires:  pkgconfig(libsoup-2.4)
 BuildRequires:  pkgconfig(libssh)
 BuildRequires:  pkgconfig(libvncserver)
 BuildRequires:  pkgconfig(pango)
@@ -56,6 +60,9 @@
 Recommends: %{name}-plugin-vnc
 Provides:   %{name}-plugins-common = %{version}
 Obsoletes:  %{name}-plugins-common < 1.0.0
+%if 0%{?suse_version} > 1500
+BuildRequires:  pkgconfig(wayland-client)
+%endif
 %if 0%{?is_opensuse}
 BuildRequires:  pkgconfig(appindicator3-0.1)
 %endif
@@ -151,14 +158,15 @@
 
 %prep
 %setup -q -n Remmina-%{realver}
+%patch0 -p1
 
 %build
 #TODO: enable TELEPATHY when issues have been fixed
-%cmake \
-%if ! 0%{?is_opensuse}
-   -DWITH_APPINDICATOR=OFF \
+%if 0%{?is_opensuse}
+%cmake -DWITH_TELEPATHY=OFF
+%else
+%cmake -DWITH_TELEPATHY=OFF -DWITH_APPINDICATOR=OFF
 %endif
-   -DWITH_TELEPATHY=OFF
 
 make %{?_smp_mflags}
 

++ 644cd140a387c7b5d3805b8af9554e241d5d2954.patch ++
>From 644cd140a387c7b5d3805b8af9554e241d5d2954 Mon Sep 17 00:00:00 2001
From: Giovanni Panozzo 
Date: Thu, 15 Feb 2018 23:40:31 +0100
Subject: [PATCH] Search for wayland-client.h include dir

---
 cmake/FindGTK3.cmake | 10 ++
 1 file changed, 10 insertions(+)

diff --git a/cmake/FindGTK3.cmake b/cmake/FindGTK3.cmake
index 6e32c7355..f69a3349c 100644
--- a/cmake/FindGTK3.cmake
+++ b/cmake/FindGTK3.cmake
@@ -1,6 +1,7 @@
 # Remmina - The GTK+ Remote Desktop Client
 #
 # Copyright (C) 2011 Marc-Andre Moreau
+# Copyright (C) 2018 Antenore Gatta, Giovanni Panozzo
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -51,6 +52,12 @@ find_path(GDKPIXBUF_INCLUDE_DIR gdk-pixbuf/gdk-pixbuf.h
 find_library(GDKPIXBUF_LIBRARY NAMES gdk_pixbuf-2.0
HINTS ${PC_GDKPIXBUF_LIBDIR} ${PC_GDKPIXBUF_LIBRARY_DIRS})
 
+# Wayland client, if GTK3's pkg-config suggests it. We only need
+# the include dir
+
+find_path(WAYLAND_INCLUDE_DIR wayland-client.h

commit yast2-auth-server for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package yast2-auth-server for 
openSUSE:Factory checked in at 2018-02-20 17:57:29

Comparing /work/SRC/openSUSE:Factory/yast2-auth-server (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-auth-server.new (New)


Package is "yast2-auth-server"

Tue Feb 20 17:57:29 2018 rev:17 rq:578356 version:3.2.1

Changes:

--- /work/SRC/openSUSE:Factory/yast2-auth-server/yast2-auth-server.changes  
2017-11-10 14:43:37.457960744 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-auth-server.new/yast2-auth-server.changes 
2018-02-20 17:59:27.161008442 +0100
@@ -1,0 +2,7 @@
+Mon Feb 19 13:49:24 UTC 2018 - h...@suse.com
+
+- Upgrade to version 3.2.1 that resolves issues in setting up
+  new directory and kerberos servers and renames program entry
+  points (bsc#1081324 and bsc#1072808).
+
+---

Old:

  yast2-auth-server-3.2.0.tar.bz2

New:

  yast2-auth-server-3.2.1.tar.bz2



Other differences:
--
++ yast2-auth-server.spec ++
--- /var/tmp/diff_new_pack.V0DuLi/_old  2018-02-20 17:59:27.964979506 +0100
+++ /var/tmp/diff_new_pack.V0DuLi/_new  2018-02-20 17:59:27.968979362 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package yast2-auth-server
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,7 +20,7 @@
 Summary:A tool for creating identity management server instances
 License:GPL-2.0+
 Group:  System/YaST
-Version:3.2.0
+Version:3.2.1
 Release:0
 Source0:%{name}-%{version}.tar.bz2
 Url:https://github.com/yast/yast-auth-server

++ yast2-auth-server-3.2.0.tar.bz2 -> yast2-auth-server-3.2.1.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-auth-server-3.2.0/README.md 
new/yast2-auth-server-3.2.1/README.md
--- old/yast2-auth-server-3.2.0/README.md   2017-11-08 10:18:12.478848137 
+0100
+++ new/yast2-auth-server-3.2.1/README.md   2018-02-20 13:52:11.0 
+0100
@@ -15,4 +15,4 @@
 $ sudo zypper install yast2-auth-server
 
 # Run
-Visit Yast control panel and launch "Authentication Server".
\ No newline at end of file
+Visit Yast control panel and launch "Create New Kerberos Server" or "Create 
New Directory Server".
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-auth-server-3.2.0/package/yast2-auth-server.changes 
new/yast2-auth-server-3.2.1/package/yast2-auth-server.changes
--- old/yast2-auth-server-3.2.0/package/yast2-auth-server.changes   
2017-11-08 10:18:12.478848137 +0100
+++ new/yast2-auth-server-3.2.1/package/yast2-auth-server.changes   
2018-02-20 13:52:11.0 +0100
@@ -1,4 +1,11 @@
 ---
+Mon Feb 19 13:49:24 UTC 2018 - h...@suse.com
+
+- Upgrade to version 3.2.1 that resolves issues in setting up
+  new directory and kerberos servers and renames program entry
+  points (bsc#1081324 and bsc#1072808).
+
+---
 Fri Sep 22 08:47:51 UTC 2017 - h...@suse.com
 
 - Upgrade to version 3.2.0 that is a rewrite to work with 389 instead
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-auth-server-3.2.0/package/yast2-auth-server.spec 
new/yast2-auth-server-3.2.1/package/yast2-auth-server.spec
--- old/yast2-auth-server-3.2.0/package/yast2-auth-server.spec  2017-11-08 
10:18:12.478848137 +0100
+++ new/yast2-auth-server-3.2.1/package/yast2-auth-server.spec  2018-02-20 
13:52:11.0 +0100
@@ -18,7 +18,7 @@
 Name:   yast2-auth-server
 Group: System/YaST
 Summary:   A tool for creating identity management server instances
-Version:3.2.0
+Version:3.2.1
 Release:0
 License:GPL-2.0+
 Source0:%{name}-%{version}.tar.bz2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-auth-server-3.2.0/src/clients/krb-server.rb 
new/yast2-auth-server-3.2.1/src/clients/krb-server.rb
--- old/yast2-auth-server-3.2.0/src/clients/krb-server.rb   1970-01-01 
01:00:00.0 +0100
+++ new/yast2-auth-server-3.2.1/src/clients/krb-server.rb   2018-02-20 
13:52:11.0 +0100
@@ -0,0 +1,14 @@
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# This program is free software; you can redistribute it and/or modify it under
+# 

commit openQA for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package openQA for openSUSE:Factory checked 
in at 2018-02-20 17:57:26

Comparing /work/SRC/openSUSE:Factory/openQA (Old)
 and  /work/SRC/openSUSE:Factory/.openQA.new (New)


Package is "openQA"

Tue Feb 20 17:57:26 2018 rev:12 rq:578346 version:4.5.1519128406.810fb68b

Changes:

--- /work/SRC/openSUSE:Factory/openQA/openQA.changes2018-02-14 
10:51:33.773811483 +0100
+++ /work/SRC/openSUSE:Factory/.openQA.new/openQA.changes   2018-02-20 
17:59:16.437394394 +0100
@@ -1,0 +2,54 @@
+Tue Feb 20 12:06:58 UTC 2018 - co...@suse.com
+
+- Update to version 4.5.1519128406.810fb68b:
+  * Show correct port for created job (#1578)
+  * Use rwp also to call rsync (#1585)
+  * Force a restart when the children or grand-children processes die
+  * OpenQA::Parser::Format::JUnit mark testsuite failed if one of testcases 
fails
+  * Replace the exec call with ReadWriteProcess module
+  * Add use Mojo::DOM in JUnit and XUnit Parser (#1580)
+  * Use the generated Mojo::URL as Client base_url
+  * Add get_piece() in OpenQA::File to ease writing of downloader class
+  * Add test for OpenQA::Files's prepare()
+  * Make integration tests of uploader with fixed chunk size
+  * Fire events inside subprocess before and after chunk processing.
+  * Move uri checks inside common function in OpenQA::Client::Handler and 
guard from not configured scheme in host
+  * Add test to check if retrials numbers are matching
+  * Use subprocess for potential loop blocks
+  * Adapt workers to error handling
+  * Add tests for OpenQA::Client::Upload retrials on failures, and events 
propagation
+  * Emit errors on OpenQA::Client::Upload
+  * Swap multi-chunk uploader in worker with OpenQA::Client
+  * Make OpenQA::Handlers EventEmitter(s)
+  * Split OpenQA::Client
+  * Wipe out content of written chunk, try only weak check and back to Storable
+  * Do not always perform total cksum
+  * Drop Mojo force to File asset, display stats of uploaded chunks
+  * Write as we receive in a temp file
+  * Avoid to relay too much on the serializer
+  * Use C backend to read whole file when computing total cksum
+  * Enhance error detection
+  * Allow to chunks to dynamically grow and shrink
+  * Make total checksum verification run faster
+  * Let specify chunk size in config file, and default to 100 bytes
+  * Also add API endpoint to inform of upload status, adapt tests
+  * Do not make split() to load the file
+  * Pass asset option in multichunk upload
+  * Create empty file before writing it if doesn't exist
+  * Try to swap current uploader with multi-chunked one for assets
+  * Add spurt to OpenQA::Files
+  * Add write_verify_chunks() and write_chunks to OpenQA::Files
+  * Add methods to verify against chunks, also add test when joining/verifying 
in-place
+  * Add serialize/deserialize also to single result of parser
+  * Add OpenQA::File, wraps Mojo::File and adds seek capabilities
+  * Add worker version check on the server. (#1552)
+  * Add basic test for OpenQA::WebAPI::Description
+  * Add POD documentation to Controller/API/V1 packages
+  * Test 27-errorpages.t with a predefined API desc
+  * Replace Pod::Tree for Pod::POM in WebAPI::Description
+  * Add POD documentation to Controller/API/V1 packages
+  * Move API description methods to its own package
+  * Add POD documentation to Controller/API/V1 packages
+  * WebAPI: Add API description from Controller's POD
+
+---

Old:

  openQA-4.5.1518003872.3977d2f5.tar.xz

New:

  openQA-4.5.1519128406.810fb68b.tar.xz



Other differences:
--
++ openQA.spec ++
--- /var/tmp/diff_new_pack.HtQKT9/_old  2018-02-20 17:59:17.625351638 +0100
+++ /var/tmp/diff_new_pack.HtQKT9/_new  2018-02-20 17:59:17.629351494 +0100
@@ -34,9 +34,9 @@
 %bcond_with tests
 %endif
 # runtime requirements that also the testsuite needs
-%define t_requires perl(DBD::Pg) perl(DBIx::Class) perl(Config::IniFiles) 
perl(SQL::Translator) perl(Date::Format) perl(File::Copy::Recursive) 
perl(DateTime::Format::Pg) perl(Net::OpenID::Consumer) 
perl(Mojolicious::Plugin::RenderFile) perl(Mojolicious::Plugin::AssetPack) 
perl(aliased) perl(Config::Tiny) perl(DBIx::Class::DynamicDefault) 
perl(DBIx::Class::Schema::Config) perl(DBIx::Class::Storage::Statistics) 
perl(IO::Socket::SSL) perl(Data::Dump) perl(DBIx::Class::OptimisticLocking) 
perl(Text::Markdown) perl(Net::DBus) perl(IPC::Run) perl(Archive::Extract) 
perl(CSS::Minifier::XS) perl(JavaScript::Minifier::XS) perl(Time::ParseDate) 
perl(Sort::Versions) perl(Mojo::RabbitMQ::Client) perl(BSD::Resource) 
perl(Cpanel::JSON::XS)
+%define t_requires perl(DBD::Pg) perl(DBIx::Class) perl(Config::IniFiles) 

commit leptonica for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package leptonica for openSUSE:Factory 
checked in at 2018-02-20 17:56:57

Comparing /work/SRC/openSUSE:Factory/leptonica (Old)
 and  /work/SRC/openSUSE:Factory/.leptonica.new (New)


Package is "leptonica"

Tue Feb 20 17:56:57 2018 rev:14 rq:578295 version:1.75.3

Changes:

--- /work/SRC/openSUSE:Factory/leptonica/leptonica.changes  2018-02-06 
16:48:54.976736203 +0100
+++ /work/SRC/openSUSE:Factory/.leptonica.new/leptonica.changes 2018-02-20 
17:58:35.846855285 +0100
@@ -1,0 +2,12 @@
+Mon Feb 19 16:30:01 UTC 2018 - kbabi...@suse.com
+
+- Update to 1.75.3:
+  * See changes in the version-notes.html file.
+  * Fixed a stack based buffer overflows in gplotRead() and ptaReadStream()
+when parsing crafted files can lead to denial of service
+(CVE-2018-7186 bsc#1081576)
+  * Fixed a buffer overflow in pixHtmlViewer in prog/htmlviewer.c
+(unsanitized input (rootname)), which could potentially lead to
+arbitrary code exeuction. (CVE-2018-7247 bsc#1081631)
+
+---

Old:

  leptonica-1.75.1.tar.gz

New:

  leptonica-1.75.3.tar.gz



Other differences:
--
++ leptonica.spec ++
--- /var/tmp/diff_new_pack.qzQlYq/_old  2018-02-20 17:58:37.878782154 +0100
+++ /var/tmp/diff_new_pack.qzQlYq/_new  2018-02-20 17:58:37.882782010 +0100
@@ -19,7 +19,7 @@
 %define major   5
 
 Name:   leptonica
-Version:1.75.1
+Version:1.75.3
 Release:0
 Summary:Library for image processing and image analysis applications
 License:BSD-2-Clause

++ leptonica-1.75.1.tar.gz -> leptonica-1.75.3.tar.gz ++
/work/SRC/openSUSE:Factory/leptonica/leptonica-1.75.1.tar.gz 
/work/SRC/openSUSE:Factory/.leptonica.new/leptonica-1.75.3.tar.gz differ: char 
5, line 1




commit nodejs6 for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package nodejs6 for openSUSE:Factory checked 
in at 2018-02-20 17:56:47

Comparing /work/SRC/openSUSE:Factory/nodejs6 (Old)
 and  /work/SRC/openSUSE:Factory/.nodejs6.new (New)


Package is "nodejs6"

Tue Feb 20 17:56:47 2018 rev:22 rq:578284 version:6.12.3

Changes:

--- /work/SRC/openSUSE:Factory/nodejs6/nodejs6.changes  2018-02-07 
18:42:21.565524965 +0100
+++ /work/SRC/openSUSE:Factory/.nodejs6.new/nodejs6.changes 2018-02-20 
17:58:25.239237075 +0100
@@ -1,0 +2,7 @@
+Tue Feb 13 08:40:52 UTC 2018 - adam.ma...@suse.de
+
+- Add Recommends and BuildRequire on python2 for npm. node-gyp
+  requires this old version of python for now. This is only needed
+  for binary modules.
+
+---



Other differences:
--
++ nodejs6.spec ++
--- /var/tmp/diff_new_pack.YBnIwI/_old  2018-02-20 17:58:26.695184663 +0100
+++ /var/tmp/diff_new_pack.YBnIwI/_new  2018-02-20 17:58:26.703184375 +0100
@@ -146,9 +146,15 @@
 %define cc_exec  gcc-5
 %define cpp_exec g++-5
 %else
+%if 0%{?sle_version} <= 120200 || (0%{?sle_version} == 120300 && 
!0%{?is_opensuse})
 BuildRequires:  gcc6-c++
 %define cc_exec  gcc-6
 %define cpp_exec g++-6
+%else
+BuildRequires:  gcc7-c++
+%define cc_exec  gcc-7
+%define cpp_exec g++-7
+%endif # SLE 12 <= SP2 and SLE 12 SP3 but not Leap 42.3
 %endif # SLE 12 < SP1
 %endif # node >= 8 and sle == 12
 
@@ -161,6 +167,7 @@
 BuildRequires:  pkg-config
 BuildRequires:  procps
 BuildRequires:  python
+BuildRequires:  python2
 BuildRequires:  xz
 BuildRequires:  zlib-devel
 
@@ -240,6 +247,7 @@
 Obsoletes:  nodejs-npm < 4.0.0
 Provides:   npm = %{version}
 Provides:   npm(npm) = 3.10.10
+Recommends: python2
 
 %description -n npm6
 A package manager for Node.js that allows developers to install and






commit python-pymisp for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package python-pymisp for openSUSE:Factory 
checked in at 2018-02-20 17:57:13

Comparing /work/SRC/openSUSE:Factory/python-pymisp (Old)
 and  /work/SRC/openSUSE:Factory/.python-pymisp.new (New)


Package is "python-pymisp"

Tue Feb 20 17:57:13 2018 rev:7 rq:578328 version:2.4.87.1

Changes:

--- /work/SRC/openSUSE:Factory/python-pymisp/python-pymisp.changes  
2018-02-07 18:40:53.069668690 +0100
+++ /work/SRC/openSUSE:Factory/.python-pymisp.new/python-pymisp.changes 
2018-02-20 17:58:43.654574277 +0100
@@ -1,0 +2,11 @@
+Tue Feb 13 10:59:26 UTC 2018 - sebix+novell@sebix.at
+
+- update to version 2.4.87.1:
+ - APIs to manage sharing groups. (#185)
+ - ReturnMetaAttributes flag for freeTextImport API. (#188)
+ - Encode string in _encode_file_to_upload.
+ - Prevent unpublished events to be included in feed.
+   Change default proposed config
+- remove patch fix-Encode_string_in__encode_file_to_upload.patch, included 
upstream
+
+---

Old:

  fix-Encode_string_in__encode_file_to_upload.patch
  pymisp-2.4.87.tar.gz

New:

  pymisp-2.4.87.1.tar.gz



Other differences:
--
++ python-pymisp.spec ++
--- /var/tmp/diff_new_pack.G4N7WQ/_old  2018-02-20 17:58:44.794533250 +0100
+++ /var/tmp/diff_new_pack.G4N7WQ/_new  2018-02-20 17:58:44.794533250 +0100
@@ -20,15 +20,13 @@
 %{!?license: %global license %doc}
 %bcond_without test
 Name:   python-pymisp
-Version:2.4.87
+Version:2.4.87.1
 Release:0
 Summary:Python API for MISP
 License:BSD-2-Clause
 Group:  Development/Languages/Python
 Url:https://github.com/MISP/PyMISP
 Source: 
https://files.pythonhosted.org/packages/source/p/pymisp/pymisp-%{version}.tar.gz
-# PATCH_FIX_UPSTREAM: Fixes https://github.com/MISP/PyMISP/issues/183
-Patch0: 
https://github.com/MISP/PyMISP/commit/05bbfac658fb9f35ab773982b1c7dc94fbdbc96f.patch#/fix-Encode_string_in__encode_file_to_upload.patch
 BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
@@ -69,7 +67,6 @@
 
 %prep
 %setup -q -n pymisp-%{version}
-%patch0 -p1
 find pymisp examples -name "*.py" -type f -exec sed -i '1s/^#!.*//' '{}' \+
 
 %build

++ pymisp-2.4.87.tar.gz -> pymisp-2.4.87.1.tar.gz ++
 5516 lines of diff (skipped)




commit openSUSE-release-tools for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package openSUSE-release-tools for 
openSUSE:Factory checked in at 2018-02-20 17:57:34

Comparing /work/SRC/openSUSE:Factory/openSUSE-release-tools (Old)
 and  /work/SRC/openSUSE:Factory/.openSUSE-release-tools.new (New)


Package is "openSUSE-release-tools"

Tue Feb 20 17:57:34 2018 rev:58 rq:578369 version:20180220.fc7e60b

Changes:

--- 
/work/SRC/openSUSE:Factory/openSUSE-release-tools/openSUSE-release-tools.changes
2018-02-15 19:31:58.929738756 +0100
+++ 
/work/SRC/openSUSE:Factory/.openSUSE-release-tools.new/openSUSE-release-tools.changes
   2018-02-20 17:59:40.128541729 +0100
@@ -1,0 +2,6 @@
+Tue Feb 20 14:26:33 UTC 2018 - opensuse-releaset...@opensuse.org
+
+- Update to version 20180220.fc7e60b:
+  * pkglistgen: use set_namespaceproviders function
+
+---

Old:

  openSUSE-release-tools-20180215.60cfab2.obscpio

New:

  openSUSE-release-tools-20180220.fc7e60b.obscpio



Other differences:
--
++ openSUSE-release-tools.spec ++
--- /var/tmp/diff_new_pack.ffOojn/_old  2018-02-20 17:59:41.120506027 +0100
+++ /var/tmp/diff_new_pack.ffOojn/_new  2018-02-20 17:59:41.124505883 +0100
@@ -20,7 +20,7 @@
 %define source_dir osc-plugin-factory
 %define announcer_filename factory-package-news
 Name:   openSUSE-release-tools
-Version:20180215.60cfab2
+Version:    20180220.fc7e60b
 Release:0
 Summary:Tools to aid in staging and release work for openSUSE/SUSE
 License:GPL-2.0+ AND MIT

++ _servicedata ++
--- /var/tmp/diff_new_pack.ffOojn/_old  2018-02-20 17:59:41.172504156 +0100
+++ /var/tmp/diff_new_pack.ffOojn/_new  2018-02-20 17:59:41.172504156 +0100
@@ -1,6 +1,6 @@
 
   
 https://github.com/openSUSE/osc-plugin-factory.git
-9f2cf8da1c0c0f23d1c4f3268a9c3dd6ecd3895f
+38f2131ab7d7eda538b73b8e73c94a3984d5aafa
   
 

++ openSUSE-release-tools-20180215.60cfab2.obscpio -> 
openSUSE-release-tools-20180220.fc7e60b.obscpio ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/openSUSE-release-tools-20180215.60cfab2/pkglistgen.py 
new/openSUSE-release-tools-20180220.fc7e60b/pkglistgen.py
--- old/openSUSE-release-tools-20180215.60cfab2/pkglistgen.py   2018-02-15 
13:30:35.0 +0100
+++ new/openSUSE-release-tools-20180220.fc7e60b/pkglistgen.py   2018-02-20 
15:19:43.0 +0100
@@ -553,25 +553,6 @@
 self.lockjobs[arch] = []
 solvables = set()
 
-def cb(name, evr):
-ret = 0
-if name == solv.NAMESPACE_MODALIAS:
-ret = 1
-elif name == solv.NAMESPACE_FILESYSTEM:
-ret = 1
-elif name == solv.NAMESPACE_LANGUAGE:
-if pool.id2str(evr) in self.locales:
-ret = 1
-else:
-logger.warning('unhandled "{} {}"'.format(pool.id2str(name), 
pool.id2str(evr)))
-
-return ret
-
-if hasattr(pool, 'set_namespacecallback'):
-pool.set_namespacecallback(cb)
-else:
-logger.debug('libsolv missing namespace callback')
-
 for prp in self.repos:
 project, reponame = prp.split('/')
 repo = pool.add_repo(project)
@@ -587,6 +568,13 @@
 pool.addfileprovides()
 pool.createwhatprovides()
 
+# https://github.com/openSUSE/libsolv/issues/231
+if hasattr(pool, 'set_namespaceproviders'):
+for l in self.locales:
+pool.set_namespaceproviders(solv.NAMESPACE_LANGUAGE, 
pool.Dep(l), True)
+else:
+logger.warn('libsolv missing set_namespaceproviders()')
+
 return pool
 
 # parse file and merge all groups

++ openSUSE-release-tools.obsinfo ++
--- /var/tmp/diff_new_pack.ffOojn/_old  2018-02-20 17:59:42.376460824 +0100
+++ /var/tmp/diff_new_pack.ffOojn/_new  2018-02-20 17:59:42.376460824 +0100
@@ -1,5 +1,5 @@
 name: openSUSE-release-tools
-version: 20180215.60cfab2
-mtime: 1518697835
-commit: 60cfab2dd68eaa1ebe3d38e281ada193e67c674f
+version: 20180220.fc7e60b
+mtime: 1519136383
+commit: fc7e60bff7a2c0b15fd5ca05ca369b07049f9e91
 




commit timidity for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package timidity for openSUSE:Factory 
checked in at 2018-02-20 17:57:45

Comparing /work/SRC/openSUSE:Factory/timidity (Old)
 and  /work/SRC/openSUSE:Factory/.timidity.new (New)


Package is "timidity"

Tue Feb 20 17:57:45 2018 rev:40 rq:578388 version:2.14.0

Changes:

--- /work/SRC/openSUSE:Factory/timidity/timidity.changes2017-11-24 
10:54:43.995709286 +0100
+++ /work/SRC/openSUSE:Factory/.timidity.new/timidity.changes   2018-02-20 
17:59:47.680269935 +0100
@@ -1,0 +2,11 @@
+Tue Feb 20 14:33:10 CET 2018 - ti...@suse.de
+
+- Fix division-by-zero with malformed MIDI file (CVE-2017-11546,
+  bsc#1081694):
+  timidity-readmidi-zero-division-fix.patch
+- Fix out-of-bound accesses in the resamplers (CVE-2017-11547,
+  bsc#1081694):
+  timidity-resample-frac-overflow-fix.patch
+- Drop tcl/tk dependency; it's already broken with Tcl/Tk 8.6
+
+---

New:

  timidity-readmidi-zero-division-fix.patch
  timidity-resample-frac-overflow-fix.patch



Other differences:
--
++ timidity.spec ++
--- /var/tmp/diff_new_pack.VVXWc3/_old  2018-02-20 17:59:48.884226604 +0100
+++ /var/tmp/diff_new_pack.VVXWc3/_new  2018-02-20 17:59:48.888226460 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package timidity
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -40,7 +40,6 @@
 BuildRequires:  ncurses-devel
 BuildRequires:  slang-devel
 BuildRequires:  speex-devel
-BuildRequires:  tk-devel
 BuildRequires:  update-desktop-files
 BuildRequires:  xaw3d
 BuildRequires:  xorg-x11
@@ -61,6 +60,8 @@
 Patch2: 0002-Fix-alsaseq-polling-at-idle-time.patch
 Patch100:   timidity-no_date.patch
 Patch101:   timidity-add_fluid_cfgs.patch
+Patch200:   timidity-readmidi-zero-division-fix.patch
+Patch201:   timidity-resample-frac-overflow-fix.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -74,6 +75,8 @@
 %patch2 -p1
 %patch100
 %patch101
+%patch200 -p1
+%patch201 -p1
 for f in ./utils/bitset.c ./utils/bitset.h ./utils/nkflib.c; do
iconv -f EUC-JISX0213 -t UTF-8 $f > $f.utf8 && mv $f.utf8 $f
 done
@@ -82,7 +85,7 @@
 echo >> autoconf/arts.m4
 autoreconf --force --install
 %configure \
-   
--enable-dynamic=ncurses,emacs,slang,vt100,xskin,gtk,tcltk,alsaseq,server \
+   --enable-dynamic=ncurses,emacs,slang,vt100,xskin,gtk,alsaseq,server \
--enable-audio=alsa,oss,vorbis,jack,ao,flac,speex \
--with-default-output=alsa \
--enable-network \

++ timidity-readmidi-zero-division-fix.patch ++
From: Takashi Iwai 
Subject: readmidi: Fix division by zero
References: CVE-2017-11546

An adhoc fix for division by zero in insert_note_steps().

Signed-off-by: Takashi Iwai 

---
 timidity/readmidi.c |2 ++
 1 file changed, 2 insertions(+)

--- a/timidity/readmidi.c
+++ b/timidity/readmidi.c
@@ -4585,6 +4585,8 @@ static void insert_note_steps(void)
if (beat != 0)
meas++, beat = 0;
num = timesig[n].a, denom = timesig[n].b, n++;
+   if (!denom)
+   denom = 1;
}
a = (meas + 1) & 0xff;
b = (((meas + 1) >> 8) & 0x0f) + ((beat + 1) << 4);
++ timidity-resample-frac-overflow-fix.patch ++
From: Takashi Iwai 
Subject: resample: Fix out-of-bound access in resamplers
References: CVE-2017-11547

An adhoc fix for out-of-bound accesses in resamples.
The offset might overflow the given data range.

Signed-off-by: Takashi Iwai 

--- a/timidity/resample.c
+++ b/timidity/resample.c
@@ -57,6 +57,8 @@ static resample_t resample_cspline(sample_t *src, splen_t 
ofs, resample_rec_t *r
 {
 int32 ofsi, ofsf, v0, v1, v2, v3, temp;
 
+if (ofs + (1 << FRACTION_BITS) >= rec->data_length)
+  return src[ofs >> FRACTION_BITS];
 ofsi = ofs >> FRACTION_BITS;
 v1 = src[ofsi];
 v2 = src[ofsi + 1];
@@ -96,6 +98,8 @@ static resample_t resample_lagrange(sample_t *src, splen_t 
ofs, resample_rec_t *
 {
 int32 ofsi, ofsf, v0, v1, v2, v3;
 
+if (ofs + (1 << FRACTION_BITS) >= rec->data_length)
+  return src[ofs >> FRACTION_BITS];
 ofsi = ofs >> FRACTION_BITS;
 v1 = (int32)src[ofsi];
 v2 = (int32)src[ofsi + 1];
@@ -154,6 +158,8 @@ static resample_t resample_gauss(sample_t *src, splen_t 
ofs, resample_rec_t *rec
 sample_t *sptr;
   

commit libcontainers-storage for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package libcontainers-storage for 
openSUSE:Factory checked in at 2018-02-20 17:57:52

Comparing /work/SRC/openSUSE:Factory/libcontainers-storage (Old)
 and  /work/SRC/openSUSE:Factory/.libcontainers-storage.new (New)


Package is "libcontainers-storage"

Tue Feb 20 17:57:52 2018 rev:2 rq:578391 version:0+git26204

Changes:

--- 
/work/SRC/openSUSE:Factory/libcontainers-storage/libcontainers-storage.changes  
2018-02-19 13:00:27.363184674 +0100
+++ 
/work/SRC/openSUSE:Factory/.libcontainers-storage.new/libcontainers-storage.changes
 2018-02-20 17:59:50.124181977 +0100
@@ -1,0 +2,6 @@
+Tue Feb 13 13:52:22 UTC 2018 - vrothb...@suse.com
+
+- Require golang >= 1.7.
+- Use golang-packaging macro to strip binaries.
+
+---



Other differences:
--
++ libcontainers-storage.spec ++
--- /var/tmp/diff_new_pack.LEfD7Q/_old  2018-02-20 17:59:50.964151746 +0100
+++ /var/tmp/diff_new_pack.LEfD7Q/_new  2018-02-20 17:59:50.968151602 +0100
@@ -16,7 +16,6 @@
 #
 
 
-%define __arch_install_post export NO_BRP_STRIP_DEBUG=true
 %define projectgithub.com/containers/storage
 %define commit d4bace6a6d19ee11ba1ed30d7d92a58cf3d73b67
 # rev_list = git rev-list commit | wc -l
@@ -32,11 +31,14 @@
 Source1:storage.conf
 BuildRequires:  device-mapper-devel
 BuildRequires:  go-md2man
-BuildRequires:  golang(API) >= 1.5
+BuildRequires:  golang(API) >= 1.7
+BuildRequires:  golang-packaging
 BuildRequires:  libbtrfs-devel
 BuildRequires:  libcontainers-common
 BuildRequires:  make
 Requires:   libcontainers-common
+# disable stripping of binaries
+%{go_nostrip}
 
 %description
 Configuration files, manpages and debugging tools from 
github.com/containers/storage.




commit canna for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package canna for openSUSE:Factory checked 
in at 2018-02-20 17:57:41

Comparing /work/SRC/openSUSE:Factory/canna (Old)
 and  /work/SRC/openSUSE:Factory/.canna.new (New)


Package is "canna"

Tue Feb 20 17:57:41 2018 rev:37 rq:578387 version:3.7p3

Changes:

--- /work/SRC/openSUSE:Factory/canna/canna.changes  2017-03-12 
20:02:46.332181069 +0100
+++ /work/SRC/openSUSE:Factory/.canna.new/canna.changes 2018-02-20 
17:59:45.580345514 +0100
@@ -1,0 +2,5 @@
+Mon Feb 19 20:09:03 UTC 2018 - crrodrig...@opensuse.org
+
+- BuildRequires imake not xorg-x11-devel
+
+---



Other differences:
--
++ canna.spec ++
--- /var/tmp/diff_new_pack.u2Vn51/_old  2018-02-20 17:59:46.960295848 +0100
+++ /var/tmp/diff_new_pack.u2Vn51/_new  2018-02-20 17:59:46.972295416 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package canna
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,10 +19,10 @@
 Name:   canna
 BuildRequires:  automake
 BuildRequires:  gcc
+BuildRequires:  imake
 BuildRequires:  ncurses-devel
 BuildRequires:  pwdutils
 BuildRequires:  termcap
-BuildRequires:  xorg-x11-devel
 Requires(pre):  /usr/sbin/useradd
 Requires(pre):  /usr/sbin/groupadd
 Requires(pre):  /bin/rm




commit os-autoinst for openSUSE:Factory

2018-02-20 Thread root
Hello community,

here is the log from the commit of package os-autoinst for openSUSE:Factory 
checked in at 2018-02-20 17:57:20

Comparing /work/SRC/openSUSE:Factory/os-autoinst (Old)
 and  /work/SRC/openSUSE:Factory/.os-autoinst.new (New)


Package is "os-autoinst"

Tue Feb 20 17:57:20 2018 rev:14 rq:578345 version:4.5.1518780731.3ca7dc34

Changes:

--- /work/SRC/openSUSE:Factory/os-autoinst/os-autoinst.changes  2018-01-31 
19:50:07.658398913 +0100
+++ /work/SRC/openSUSE:Factory/.os-autoinst.new/os-autoinst.changes 
2018-02-20 17:59:14.281471988 +0100
@@ -1,0 +2,19 @@
+Sat Feb 17 01:01:09 UTC 2018 - ok...@suse.com
+
+- Update to version 4.5.1518780731.3ca7dc34:
+  * Do not fail on chattr failures (#924)
+  * qemu: disable CoW for the HDD image directory (#790)
+  * get_ssh_output and get_cmd_output return array in list context (#916)
+  * Avoid letting the kids get loose. (#919)
+  * Don't add floppy for arm/aarch (#923)
+  * wip -- test to prevent double typing echo on virtio-console
+  * Correct VNC stall threshold variable name (#922)
+  * Check runcmd return status (#898)
+  * testapi: Correct spelling mistake
+  * testapi: Ensure script_output only returns the actual ouput of the 
executed script
+  * tinycv: Add test for send_with_fd
+  * testapi: Allow memory dump any time
+  * qemu: Increase memory dump performance
+  * tinycv: Add send_with_fd utility function
+
+---

Old:

  os-autoinst-4.5.1516891126.e9d61c6d.tar.xz

New:

  os-autoinst-4.5.1518780731.3ca7dc34.tar.xz



Other differences:
--
++ os-autoinst.spec ++
--- /var/tmp/diff_new_pack.u1SIH2/_old  2018-02-20 17:59:16.189403320 +0100
+++ /var/tmp/diff_new_pack.u1SIH2/_new  2018-02-20 17:59:16.193403176 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   os-autoinst
-Version:4.5.1516891126.e9d61c6d
+Version:4.5.1518780731.3ca7dc34
 Release:0
 Summary:OS-level test automation
 License:GPL-2.0+
@@ -36,6 +36,8 @@
 BuildRequires:  pkgconfig(libpng)
 BuildRequires:  pkgconfig(sndfile)
 BuildRequires:  pkgconfig(theoraenc)
+# just for the test suite
+BuildRequires:  qemu-tools
 Requires:   /usr/bin/qemu-img
 Requires:   git-core
 Requires:   optipng
@@ -43,7 +45,7 @@
 Requires:   qemu >= 2.0.0
 Requires:   tesseract-ocr
 Requires:   withlock
-%define t_requires perl(Carp::Always) perl(Data::Dump) perl(Crypt::DES) 
perl(JSON) perl(autodie) perl(Class::Accessor::Fast) perl(Exception::Class) 
perl(File::Which) perl(IPC::Run::Debug) perl(Net::DBus) perl(Net::SNMP) 
perl(Net::IP) perl(IPC::System::Simple) perl(Net::SSH2) perl(XML::LibXML) 
perl(Test::Output) perl(Test::Fatal) perl(Test::Warnings) perl(Pod::Coverage) 
perl(Test::Pod) perl(Test::MockModule) perl(Devel::Cover) perl(JSON::XS) 
perl(List::MoreUtils) perl(Test::Mock::Time)
+%define t_requires perl(Carp::Always) perl(Data::Dump) perl(Crypt::DES) 
perl(JSON) perl(autodie) perl(Class::Accessor::Fast) perl(Exception::Class) 
perl(File::Which) perl(IPC::Run::Debug) perl(Net::DBus) perl(Net::SNMP) 
perl(Net::IP) perl(IPC::System::Simple) perl(Net::SSH2) perl(XML::LibXML) 
perl(Test::Output) perl(Test::Fatal) perl(Test::Warnings) perl(Pod::Coverage) 
perl(Test::Pod) perl(Test::MockModule) perl(Devel::Cover) perl(JSON::XS) 
perl(List::MoreUtils) perl(Test::Mock::Time) perl(Socket::MsgHdr)
 BuildRequires:  %t_requires
 Requires:   %t_requires
 BuildRequires:  perl(Mojolicious)
@@ -77,6 +79,7 @@
 
 %prep
 %setup -q
+sed -e 's,/bin/env python,/bin/python,' -i crop.py
 
 %build
 mkdir -p m4
@@ -89,7 +92,7 @@
 # Replace version number from git to what's reported by the package
 sed  -i 's/ my $thisversion = qx{git rev-parse HEAD};/ my $thisversion = 
"%{version}";/' %{buildroot}/usr/bin/isotovideo
 # only internal stuff
-rm %{buildroot}/usr/lib/os-autoinst/tools/tidy
+rm %{buildroot}/usr/lib/os-autoinst/tools/{tidy,check_coverage,absolutize}
 rm -r %{buildroot}/usr/lib/os-autoinst/tools/lib/perlcritic
 #
 ls -lR %buildroot
@@ -154,9 +157,7 @@
 %{_libexecdir}/os-autoinst/OpenQA
 %{_libexecdir}/os-autoinst/consoles
 %dir %{_libexecdir}/os-autoinst/tools
-%{_libexecdir}/os-autoinst/tools/absolutize
 %{_libexecdir}/os-autoinst/tools/preparepool
-%{_libexecdir}/os-autoinst/tools/check_coverage
 %{_libexecdir}/os-autoinst/autotest.pm
 %{_libexecdir}/os-autoinst/crop.py
 

++ os-autoinst-4.5.1516891126.e9d61c6d.tar.xz -> 
os-autoinst-4.5.1518780731.3ca7dc34.tar.xz ++
/work/SRC/openSUSE:Factory/os-autoinst/os-autoinst-4.5.1516891126.e9d61c6d.tar.xz
 
/work/SRC/openSUSE:Factory/.os-autoinst.new/os-autoinst-4.5.1518780731.3ca7dc34.tar.xz
 differ: char 26, line 1