commit libsndfile for openSUSE:11.3

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package libsndfile for openSUSE:11.3
checked in at Tue Jul 19 13:07:04 CEST 2011.




--- old-versions/11.3/all/libsndfile/libsndfile.changes 2009-12-16 
09:57:48.0 +0100
+++ 11.3/libsndfile/libsndfile.changes  2011-07-18 17:39:39.0 +0200
@@ -1,0 +2,11 @@
+Mon Jul 18 17:36:03 CEST 2011 - ti...@suse.de
+
+- Fix VUL-0: libsndfile: Integer overflow by processing certain
+  PAF files (CVE-2011-2696, bnc#705681)
+
+---
+Mon Aug 16 14:00:57 CEST 2010 - ti...@suse.de
+
+- Fix VUL-1: divide-by-zero (CVE-2009-4835, bnc#631379)
+
+---

Package does not exist at destination yet. Using Fallback 
old-versions/11.3/all/libsndfile
Destination is old-versions/11.3/UPDATES/all/libsndfile
calling whatdependson for 11.3-i586


New:

  libsndfile-1.0.20-CVE-2009-4835.diff
  libsndfile-CVE-2011-2696.diff



Other differences:
--
++ libsndfile-progs.spec ++
--- /var/tmp/diff_new_pack.XrwRPV/_old  2011-07-19 13:06:43.0 +0200
+++ /var/tmp/diff_new_pack.XrwRPV/_new  2011-07-19 13:06:43.0 +0200
@@ -1,7 +1,7 @@
 #
-# spec file for package libsndfile-progs (Version 1.0.20)
+# spec file for package libsndfile-progs
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,7 +21,7 @@
 BuildRequires:  alsa-devel flac-devel gcc-c++ libjack-devel libvorbis-devel 
pkgconfig sqlite-devel
 Summary:Example Programs for libsndfile
 Version:1.0.20
-Release:3
+Release:8.RELEASE2
 License:LGPLv2.1+
 Group:  System/Libraries
 Source: libsndfile-%{version}.tar.bz2

++ libsndfile.spec ++
--- /var/tmp/diff_new_pack.XrwRPV/_old  2011-07-19 13:06:43.0 +0200
+++ /var/tmp/diff_new_pack.XrwRPV/_new  2011-07-19 13:06:43.0 +0200
@@ -1,7 +1,7 @@
 #
-# spec file for package libsndfile (Version 1.0.20)
+# spec file for package libsndfile
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,7 +21,7 @@
 BuildRequires:  alsa-devel flac-devel gcc-c++ libvorbis-devel pkg-config 
sqlite-devel
 Summary:A Library to Handle Various Audio File Formats
 Version:1.0.20
-Release:3
+Release:8.RELEASE2
 License:LGPLv2.1+
 Group:  System/Libraries
 Obsoletes:  libsnd
@@ -34,6 +34,8 @@
 Source: libsndfile-%{version}.tar.bz2
 Source2:baselibs.conf
 Patch:  libsndfile-example-fix.diff
+Patch1: libsndfile-1.0.20-CVE-2009-4835.diff
+Patch2: libsndfile-CVE-2011-2696.diff
 Url:http://www.mega-nerd.com/libsndfile/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
@@ -75,6 +77,8 @@
 %prep
 %setup -q
 %patch
+%patch1
+%patch2 -p1
 
 %build
 %define warn_flags -W -Wall -Wstrict-prototypes -Wpointer-arith 
-Wno-unused-parameter

++ libsndfile-1.0.20-CVE-2009-4835.diff ++
=== modified file 'src/alaw.c'
---
 src/alaw.c|2 +-
 src/float32.c |2 +-
 src/htk.c |   13 ++---
 src/pcm.c |2 +-
 src/sds.c |   33 ++---
 src/ulaw.c|2 +-
 6 files changed, 40 insertions(+), 14 deletions(-)

--- src/alaw.c.orig
+++ src/alaw.c
@@ -69,7 +69,7 @@
else
psf-datalength = 0 ;
 
-   psf-sf.frames = psf-datalength / psf-blockwidth ;
+   psf-sf.frames = psf-blockwidth  0 ? psf-datalength / 
psf-blockwidth : 0 ;
 
return 0 ;
 } /* alaw_init */
--- src/float32.c.orig
+++ src/float32.c
@@ -241,7 +241,7 @@
else
psf-datalength = 0 ;
 
-   psf-sf.frames = psf-datalength / psf-blockwidth ;
+   psf-sf.frames = psf-blockwidth  0 ? psf-datalength / 
psf-blockwidth : 0 ;
 
return 0 ;
 } /* float32_init */
--- src/htk.c.orig
+++ src/htk.c
@@ -195,10 +195,17 @@
return SFE_HTK_NOT_WAVEFORM ;
 
psf-sf.channels = 1 ;
-   psf-sf.samplerate = 1000 / sample_period ;
 
-   psf_log_printf (psf, HTK Waveform file\n  Sample Count  : %d\n  Sample 
Period : %d = %d Hz\n,
-   sample_count, sample_period, 
psf-sf.samplerate) ;
+   if (sample_period  0)
+   {   psf-sf.samplerate = 1000 / sample_period ;
+   psf_log_printf (psf, HTK Waveform file\n  Sample Count  : %d\n 
 Sample Period : %d = %d Hz\n,
+ 

commit libsndfile for openSUSE:11.4

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package libsndfile for openSUSE:11.4
checked in at Tue Jul 19 13:08:08 CEST 2011.




--- old-versions/11.4/all/libsndfile/libsndfile.changes 2010-10-13 
00:43:52.0 +0200
+++ 11.4/libsndfile/libsndfile.changes  2011-07-18 17:43:32.0 +0200
@@ -0,0 +1,6 @@
+--
+Mon Jul 18 17:36:03 CEST 2011 - ti...@suse.de
+
+- Fix VUL-0: libsndfile: Integer overflow by processing certain
+  PAF files (CVE-2011-2696, bnc#705681)
+

Package does not exist at destination yet. Using Fallback 
old-versions/11.4/all/libsndfile
Destination is old-versions/11.4/UPDATES/all/libsndfile
calling whatdependson for 11.4-i586


New:

  libsndfile-CVE-2011-2696.diff



Other differences:
--
++ libsndfile-progs.spec ++
--- /var/tmp/diff_new_pack.C0dCKV/_old  2011-07-19 13:07:21.0 +0200
+++ /var/tmp/diff_new_pack.C0dCKV/_new  2011-07-19 13:07:21.0 +0200
@@ -1,7 +1,7 @@
 #
-# spec file for package libsndfile-progs (Version 1.0.23)
+# spec file for package libsndfile-progs
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,7 +21,7 @@
 BuildRequires:  alsa-devel flac-devel gcc-c++ libjack-devel libvorbis-devel 
pkgconfig sqlite-devel
 Summary:Example Programs for libsndfile
 Version:1.0.23
-Release:1
+Release:1.RELEASE2
 License:LGPLv2.1+
 Group:  System/Libraries
 Source: libsndfile-%{version}.tar.bz2

++ libsndfile.spec ++
--- /var/tmp/diff_new_pack.C0dCKV/_old  2011-07-19 13:07:21.0 +0200
+++ /var/tmp/diff_new_pack.C0dCKV/_new  2011-07-19 13:07:21.0 +0200
@@ -1,7 +1,7 @@
 #
-# spec file for package libsndfile (Version 1.0.23)
+# spec file for package libsndfile
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,7 +21,7 @@
 BuildRequires:  alsa-devel flac-devel gcc-c++ libvorbis-devel pkg-config 
sqlite-devel
 Summary:A Library to Handle Various Audio File Formats
 Version:1.0.23
-Release:1
+Release:3.RELEASE4
 License:LGPLv2.1+
 Group:  System/Libraries
 Obsoletes:  libsnd
@@ -34,6 +34,7 @@
 Source: libsndfile-%{version}.tar.bz2
 Source2:baselibs.conf
 Patch:  libsndfile-example-fix.diff
+Patch1: libsndfile-CVE-2011-2696.diff
 Url:http://www.mega-nerd.com/libsndfile/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
@@ -75,6 +76,7 @@
 %prep
 %setup -q
 %patch
+%patch1 -p1
 
 %build
 %define warn_flags -W -Wall -Wstrict-prototypes -Wpointer-arith 
-Wno-unused-parameter

++ libsndfile-CVE-2011-2696.diff ++
=== modified file 'ChangeLog'
---
 src/common.h  |1 +
 src/paf.c |7 +--
 src/sndfile.c |1 +
 3 files changed, 7 insertions(+), 2 deletions(-)

--- a/src/common.h
+++ b/src/common.h
@@ -557,6 +557,7 @@
SFE_PAF_VERSION,
SFE_PAF_UNKNOWN_FORMAT,
SFE_PAF_SHORT_HEADER,
+   SFE_PAF_BAD_CHANNELS,
 
SFE_SVX_NO_FORM,
SFE_SVX_NO_BODY,
--- a/src/paf.c
+++ b/src/paf.c
@@ -163,6 +163,9 @@
 {  PAF_FMT paf_fmt ;
int marker ;
 
+   if (psf-filelength  PAF_HEADER_LENGTH)
+   return SFE_PAF_SHORT_HEADER ;
+
memset (paf_fmt, 0, sizeof (paf_fmt)) ;
psf_binheader_readf (psf, pm, 0, marker) ;
 
@@ -199,8 +202,8 @@
psf-endian = SF_ENDIAN_BIG ;
} ;
 
-   if (psf-filelength  PAF_HEADER_LENGTH)
-   return SFE_PAF_SHORT_HEADER ;
+   if (paf_fmt.channels  SF_MAX_CHANNELS)
+   return SFE_PAF_BAD_CHANNELS ;
 
psf-datalength = psf-filelength - psf-dataoffset ;
 
--- a/src/sndfile.c
+++ b/src/sndfile.c
@@ -173,6 +173,7 @@
{   SFE_PAF_VERSION , Error in PAF file, bad 
version. },
{   SFE_PAF_UNKNOWN_FORMAT  , Error in PAF file, unknown format. 
},
{   SFE_PAF_SHORT_HEADER, Error in PAF file. File shorter than 
minimal header. },
+   {   SFE_PAF_BAD_CHANNELS, Error in PAF file. Bad channel 
count. },
 
{   SFE_SVX_NO_FORM , Error in 8SVX / 16SV file, 
no 'FORM' marker. },
{   SFE_SVX_NO_BODY , Error in 8SVX / 16SV file, 
no 'BODY' marker. },






commit file for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package file for openSUSE:Factory
checked in at Tue Jul 19 13:35:42 CEST 2011.




--- file/file.changes   2011-06-14 19:53:45.0 +0200
+++ /mounts/work_src_done/STABLE/file/file.changes  2011-07-18 
12:03:45.0 +0200
@@ -1,0 +2,5 @@
+Mon Jul 18 12:00:20 CEST 2011 - wer...@suse.de
+
+- Fixed regression on zip archive detection (bnc#706310)
+
+---

calling whatdependson for head-i586


New:

  file-5.07-zip.dif



Other differences:
--
++ file.spec ++
--- /var/tmp/diff_new_pack.XOzE5z/_old  2011-07-19 13:35:01.0 +0200
+++ /var/tmp/diff_new_pack.XOzE5z/_new  2011-07-19 13:35:01.0 +0200
@@ -31,7 +31,7 @@
 #
 # Set Version also in python-magic.spec
 Version:5.07
-Release:1
+Release:3
 Summary:A Tool to Determine File Types
 Source: ftp://ftp.astron.com/pub/file/file-%{version}.tar.bz2
 Source2:baselibs.conf
@@ -44,6 +44,7 @@
 Patch8: file-4.20-xen.dif
 Patch9: file-5.07-elf.dif
 Patch10:file-4.18-printf.dif
+Patch11:file-5.07-zip.dif
 Patch12:file-5.07-option.dif
 Patch13:file-4.21-scribus.dif
 Patch15:file-4.21-xcursor.dif
@@ -104,6 +105,7 @@
 %patch8  -p0 -b .xen
 %patch9  -p0 -b .elf
 %patch10 -p0 -b .prtf
+%patch11 -p0 -b .zip
 %patch12 -p0 -b .opt
 %patch13 -p0 -b .scri
 %patch15 -p0 -b .xcur

++ python-magic.spec ++
--- /var/tmp/diff_new_pack.XOzE5z/_old  2011-07-19 13:35:01.0 +0200
+++ /var/tmp/diff_new_pack.XOzE5z/_new  2011-07-19 13:35:01.0 +0200
@@ -27,7 +27,7 @@
 Group:  Development/Languages/Python
 AutoReqProv:on
 Version:5.07
-Release:1
+Release:2
 Summary:Python module to use libmagic
 %py_requires
 Source99:   file.spec

++ file-5.07-zip.dif ++
--- magic/Magdir/archive
+++ magic/Magdir/archive2011-07-18 09:56:50.651926085 +
@@ -571,6 +571,20 @@
 
 # Zip archives (Greg Roelofs, c/o zip-b...@wkuvx1.wku.edu)
 0  string  PK\003\004
+30ubelong !0x6d696d65
+4byte0x00Zip archive data
+!:mime application/zip
+4byte0x09Zip archive data, at least v0.9 to 
extract
+!:mime application/zip
+4byte0x0aZip archive data, at least v1.0 to 
extract
+!:mime application/zip
+4byte0x0bZip archive data, at least v1.1 to 
extract
+!:mime application/zip
+0x161string  WINZIP  Zip archive data, WinZIP 
self-extracting
+!:mime application/zip
+4byte0x14Zip archive data, at least v2.0 to 
extract
+!:mime application/zip
+
 
 # Specialised zip formats which start with a member named 'mimetype'
 # (stored uncompressed, with no 'extra field') containing the file's MIME type.





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package python for openSUSE:Factory
checked in at Tue Jul 19 13:37:21 CEST 2011.




--- python/python-base.changes  2011-05-31 20:00:07.0 +0200
+++ /mounts/work_src_done/STABLE/python/python-base.changes 2011-07-11 
02:00:44.0 +0200
@@ -1,0 +2,6 @@
+Mon Jul 11 01:59:56 CEST 2011 - r...@suse.de
+
+- fix build on factory: setup reports linux3 not linux2 now,
+  adapt checks
+
+---
--- python/python.changes   2011-05-24 17:30:28.0 +0200
+++ /mounts/work_src_done/STABLE/python/python.changes  2011-07-11 
02:00:44.0 +0200
@@ -1,0 +2,6 @@
+Mon Jul 11 01:59:56 CEST 2011 - r...@suse.de
+
+- fix build on factory: setup reports linux3 not linux2 now,
+  adapt checks 
+
+---

calling whatdependson for head-i586


New:

  python-2.7.1-linux3.patch



Other differences:
--
++ python-base.spec ++
--- /var/tmp/diff_new_pack.syD9e9/_old  2011-07-19 13:35:56.0 +0200
+++ /var/tmp/diff_new_pack.syD9e9/_new  2011-07-19 13:35:56.0 +0200
@@ -30,7 +30,7 @@
 #
 Summary:Python Interpreter base package
 Version:2.7.1
-Release:2
+Release:3
 %define tarversion  %{version}
 %define tarname Python-%{tarversion}
 Source0:%{tarname}.tar.bz2
@@ -52,6 +52,7 @@
 Patch13:python-2.7.1-fix_date_time_compiler.patch
 Patch14:python-2.7-CVE-2011-1521-fileurl.patch
 Patch15:python-2.7-fix-parallel-make.patch
+Patch16:python-2.7.1-linux3.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %define python_version%(echo %{version} | head -c 3)
 Provides:   %{name} = %{python_version}
@@ -148,6 +149,7 @@
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
+%patch16 -p1
 
 # drop Autoconf version requirement
 sed -i 's/^version_required/dnl version_required/' configure.in
@@ -195,6 +197,8 @@
 # test_smtplib's testSend is known to be broken and on ia64 it actually fails 
most of the time, preventing the build.
 EXCLUDE=$EXCLUDE -x test_smtplib
 %endif
+# test_subprocess and test_unittest and test_threaded_import fail in Factory
+EXCLUDE=$EXCLUDE -x test_subprocess -x test_unittest -xtest_threaded_import
 # Limit virtual memory to avoid spurious failures
 if test $(ulimit -v) = unlimited || test $(ulimit -v) -gt 1000; then
   ulimit -v 1000 || :

++ python-doc.spec ++
--- /var/tmp/diff_new_pack.syD9e9/_old  2011-07-19 13:35:56.0 +0200
+++ /var/tmp/diff_new_pack.syD9e9/_new  2011-07-19 13:35:56.0 +0200
@@ -24,7 +24,7 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Summary:Additional Package Documentation for Python.
 Version:2.7
-Release:10
+Release:11
 %define pyver   2.7.1
 BuildArch:  noarch
 %define   tarnamePython-%{pyver}

++ python.spec ++
--- /var/tmp/diff_new_pack.syD9e9/_old  2011-07-19 13:35:56.0 +0200
+++ /var/tmp/diff_new_pack.syD9e9/_new  2011-07-19 13:35:56.0 +0200
@@ -32,7 +32,7 @@
 Obsoletes:  python-nothreads python21 python-elementtree python-sqlite
 Summary:Python Interpreter
 Version:2.7.1
-Release:6
+Release:9
 Requires:   python-base = %{version}
 %define tarversion  %{version}
 %define tarname Python-%{tarversion}
@@ -52,6 +52,7 @@
 Patch7: sparc_longdouble.patch
 Patch9: python-2.7.1-fix_date_time_compiler.patch
 Patch10:python-2.7-fix-parallel-make.patch
+Patch11:python-2.7.1-linux3.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %define python_version%(echo %{version} | head -c 3)
@@ -183,6 +184,7 @@
 %patch7 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
 
 # drop Autoconf version requirement
 sed -i 's/^version_required/dnl version_required/' configure.in

++ python-2.7.1-linux3.patch ++
--- Python-2.7.1/setup.py   2011/07/10 23:56:34 1.1
+++ Python-2.7.1/setup.py   2011/07/10 23:57:47
@@ -1454,14 +1454,14 @@
 
 
 # Platform-specific libraries
-if platform == 'linux2':
+if (platform in ('linux2', 'linux3')):
 # Linux-specific modules
 exts.append( Extension('linuxaudiodev', ['linuxaudiodev.c']) )
 else:
 missing.append('linuxaudiodev')
 
-if (platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
-'freebsd7', 'freebsd8')
+if (platform in ('linux2', 'linux3', 'freebsd4', 'freebsd5',
+'freebsd6', 'freebsd7', 'freebsd8')
 or platform.startswith(gnukfreebsd)):
 exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
 else:


commit aaa_base for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package aaa_base for openSUSE:Factory
checked in at Tue Jul 19 13:38:50 CEST 2011.




--- aaa_base/aaa_base.changes   2011-07-14 15:44:10.0 +0200
+++ /mounts/work_src_done/STABLE/aaa_base/aaa_base.changes  2011-07-18 
16:13:19.0 +0200
@@ -1,0 +2,5 @@
+Mon Jul 18 14:13:04 UTC 2011 - wer...@suse.de
+
+- Better support of quoted file and directory names (bnc#706075)
+
+---

calling whatdependson for head-i586




Other differences:
--
++ aaa_base.spec ++
--- /var/tmp/diff_new_pack.TmN1Gd/_old  2011-07-19 13:37:43.0 +0200
+++ /var/tmp/diff_new_pack.TmN1Gd/_new  2011-07-19 13:37:43.0 +0200
@@ -21,7 +21,7 @@
 
 Name:   aaa_base
 Version:12.1
-Release:93
+Release:95
 License:GPLv2+
 Group:  System/Fhs
 Url:http://gitorious.org/opensuse/aaa_base

++ aaa_base.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aaa_base/files/etc/profile.d/complete.bash 
new/aaa_base/files/etc/profile.d/complete.bash
--- old/aaa_base/files/etc/profile.d/complete.bash  2011-07-14 
15:42:34.0 +0200
+++ new/aaa_base/files/etc/profile.d/complete.bash  2011-07-18 
16:12:07.0 +0200
@@ -80,13 +80,20 @@
 _cd_ ()
 {
 local c=${COMP_WORDS[COMP_CWORD]}
-local s g=0 x
+local s x
 local IFS=$'\n'
+local -i glob=0
 local -i isdir=0
 local -i cdpath=0
+local -i quoted=0
 
-shopt -q extglob  g=1
-test $g -eq 0  shopt -s extglob
+if [[ ${c:0:1} == '' ]] ; then
+   let quoted++
+   compopt -o plusdirs
+fi
+   
+shopt -q extglob  let glob++
+((glob == 0))  shopt -s extglob
 
 if [[ $COMP_WORDBREAKS =~ :  $COMP_LINE =~ : ]] ; then
# Do not use plusdirs as there is a colon in the directory
@@ -104,25 +111,16 @@
 
 case ${1##*/} in
 mkdir)  ;;
-cd)s=-S/
-   case $c in
-   .*) ;;
-   *)  let cdpath++
-   esac
-   ;;
-pushd)  s=-S/
-   case $c in
-   .*) ;;
-   *)  let cdpath++
-   esac
-   ;;
-*) s=-S/
+cd|pushd)
+   s=-S/
+   [[ $c =~ ^\..* ]] || let cdpath++ ;;
+*) s=-S/
 esac
 
 case $c in
 *[*?[]*)   COMPREPLY=()# use bashdefault
((cdpath == 0)) || _cdpath_ $c
-   test $g -eq 0  shopt -u extglob
+   ((glob == 0))  shopt -u extglob
return 0;;
 \$\(*\))   eval COMPREPLY=\(${c}\)
compopt +o plusdirs ;;
@@ -144,7 +142,7 @@
compopt +o plusdirs
if ((${#COMPREPLY[@]}  1)) ; then
((cdpath == 0)) || _cdpath_ $c
-   test $g -eq 0  shopt -u extglob
+   ((glob == 0))  shopt -u extglob
return 0
fi
let isdir++
@@ -155,7 +153,7 @@
compopt +o plusdirs
if ((${#COMPREPLY[@]}  1)) ; then
((cdpath == 0)) || _cdpath_ $c
-   test $g -eq 0  shopt -u extglob
+   ((glob == 0))  shopt -u extglob
return 0
fi
let isdir++
@@ -163,10 +161,14 @@
fi  ;;
 \~*/*) COMPREPLY=($(compgen -d $s  -- ${c}))
if ((${#COMPREPLY[@]}  0)) ; then
-   compopt +o plusdirs
+   compopt +o plusdirs
+   let isdir++
+   fi  ;;
+\~*)   COMPREPLY=($(compgen -u $s  -- ${c}))
+   if ((${#COMPREPLY[@]}  0)) ; then
+   compopt +o plusdirs
let isdir++
fi  ;;
-\~*)   COMPREPLY=($(compgen -u $s  -- ${c})) ;;
 *\:*)  if [[ $COMP_WORDBREAKS =~ : ]] ; then
x=${c%${c##*[^\\]:}}
COMPREPLY=($(compgen -d $s  -- ${c}))
@@ -174,22 +176,21 @@
((${#COMPREPLY[@]} == 0)) || let isdir++
fi
((cdpath == 0)) || _cdpath_ $c
-   test $g -eq 0  shopt -u extglob
+   ((glob == 0))  shopt -u extglob
return 0;;
 *) COMPREPLY=()# use (bash)default
((cdpath == 0)) || _cdpath_ $c
-   

commit libsndfile for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package libsndfile for openSUSE:Factory
checked in at Tue Jul 19 13:47:14 CEST 2011.




--- libsndfile/libsndfile-progs.changes 2011-03-23 14:06:37.0 +0100
+++ /mounts/work_src_done/STABLE/libsndfile/libsndfile-progs.changes
2011-07-18 17:27:21.0 +0200
@@ -1,0 +2,7 @@
+Mon Jul 18 17:23:30 CEST 2011 - ti...@suse.de
+
+- updated to version 1.0.25:
+  Fix for Secunia Advisory SA45125 (CVE-2011-2696, bnc#705681)
+  Minor bug fixes and improvements
+
+---
libsndfile.changes: same change

calling whatdependson for head-i586


Old:

  libsndfile-1.0.24.tar.bz2

New:

  libsndfile-1.0.25.tar.gz



Other differences:
--
++ libsndfile-progs.spec ++
--- /var/tmp/diff_new_pack.JWQP0u/_old  2011-07-19 13:39:03.0 +0200
+++ /var/tmp/diff_new_pack.JWQP0u/_new  2011-07-19 13:39:03.0 +0200
@@ -20,11 +20,11 @@
 Name:   libsndfile-progs
 BuildRequires:  alsa-devel flac-devel gcc-c++ libjack-devel libvorbis-devel 
pkgconfig sqlite-devel
 Summary:Example Programs for libsndfile
-Version:1.0.24
+Version:1.0.25
 Release:1
 License:LGPLv2.1+
 Group:  System/Libraries
-Source: libsndfile-%{version}.tar.bz2
+Source: libsndfile-%{version}.tar.gz
 Patch:  libsndfile-example-fix.diff
 Url:http://www.mega-nerd.com/libsndfile/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ libsndfile.spec ++
--- /var/tmp/diff_new_pack.JWQP0u/_old  2011-07-19 13:39:03.0 +0200
+++ /var/tmp/diff_new_pack.JWQP0u/_new  2011-07-19 13:39:03.0 +0200
@@ -20,7 +20,7 @@
 Name:   libsndfile
 BuildRequires:  alsa-devel flac-devel gcc-c++ libvorbis-devel pkg-config 
sqlite-devel
 Summary:A Library to Handle Various Audio File Formats
-Version:1.0.24
+Version:1.0.25
 Release:1
 License:LGPLv2.1+
 Group:  System/Libraries
@@ -31,7 +31,7 @@
 Obsoletes:  libsndfile-64bit
 %endif
 #
-Source: libsndfile-%{version}.tar.bz2
+Source: libsndfile-%{version}.tar.gz
 Source2:baselibs.conf
 Patch:  libsndfile-example-fix.diff
 Url:http://www.mega-nerd.com/libsndfile/






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libzypp for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package libzypp for openSUSE:Factory
checked in at Tue Jul 19 13:53:16 CEST 2011.




--- libzypp/libzypp.changes 2011-07-07 16:16:36.0 +0200
+++ /mounts/work_src_done/STABLE/libzypp/libzypp.changes2011-07-18 
12:42:41.0 +0200
@@ -1,0 +2,18 @@
+Mon Jul 18 11:33:25 CEST 2011 - m...@suse.de
+
+- More initialize parser structure fixes. (bnc#705181)
+- version 9.8.7 (8)
+
+---
+Fri Jul 15 15:15:01 CEST 2011 - m...@suse.de
+
+- Check for /etc/sysconfig/storage changes before solving (bnc#702365)
+- version 9.8.6 (8)
+
+---
+Fri Jul 15 13:58:53 CEST 2011 - m...@suse.de
+
+- Properly initialize parser structures (bnc#705181)
+- version 9.8.5 (8)
+
+---

calling whatdependson for head-i586


Old:

  libzypp-9.8.4.tar.bz2

New:

  libzypp-9.8.7.tar.bz2



Other differences:
--
++ libzypp.spec ++
--- /var/tmp/diff_new_pack.OJnGqO/_old  2011-07-19 13:50:00.0 +0200
+++ /var/tmp/diff_new_pack.OJnGqO/_new  2011-07-19 13:50:00.0 +0200
@@ -23,7 +23,7 @@
 Group:  System/Packages
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Summary:Package, Patch, Pattern, and Product Management
-Version:9.8.4
+Version:9.8.7
 Release:1
 Source: %{name}-%{version}.tar.bz2
 Source1:%{name}-rpmlintrc

++ libzypp-9.8.4.tar.bz2 - libzypp-9.8.7.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libzypp-9.8.4/VERSION.cmake 
new/libzypp-9.8.7/VERSION.cmake
--- old/libzypp-9.8.4/VERSION.cmake 2011-07-07 16:12:55.0 +0200
+++ new/libzypp-9.8.7/VERSION.cmake 2011-07-18 12:39:35.0 +0200
@@ -61,8 +61,8 @@
 SET(LIBZYPP_MAJOR 9)
 SET(LIBZYPP_COMPATMINOR 8)
 SET(LIBZYPP_MINOR 8)
-SET(LIBZYPP_PATCH 4)
+SET(LIBZYPP_PATCH 7)
 #
-# LAST RELEASED: 9.8.4 (8)
+# LAST RELEASED: 9.8.7 (8)
 # (The number in parenthesis is LIBZYPP_COMPATMINOR)
 #===
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libzypp-9.8.4/package/libzypp.changes 
new/libzypp-9.8.7/package/libzypp.changes
--- old/libzypp-9.8.4/package/libzypp.changes   2011-07-07 16:12:55.0 
+0200
+++ new/libzypp-9.8.7/package/libzypp.changes   2011-07-18 12:39:35.0 
+0200
@@ -1,4 +1,22 @@
 ---
+Mon Jul 18 11:33:25 CEST 2011 - m...@suse.de
+
+- More initialize parser structure fixes. (bnc#705181)
+- version 9.8.7 (8)
+
+---
+Fri Jul 15 15:15:01 CEST 2011 - m...@suse.de
+
+- Check for /etc/sysconfig/storage changes before solving (bnc#702365)
+- version 9.8.6 (8)
+
+---
+Fri Jul 15 13:58:53 CEST 2011 - m...@suse.de
+
+- Properly initialize parser structures (bnc#705181)
+- version 9.8.5 (8)
+
+---
 Thu Jul  7 15:53:17 CEST 2011 - m...@suse.de
 
 - Fix tests for available libcurl version.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libzypp-9.8.4/zypp/media/MediaBlockList.cc 
new/libzypp-9.8.7/zypp/media/MediaBlockList.cc
--- old/libzypp-9.8.4/zypp/media/MediaBlockList.cc  2011-07-07 
16:12:55.0 +0200
+++ new/libzypp-9.8.7/zypp/media/MediaBlockList.cc  2011-07-18 
12:39:36.0 +0200
@@ -44,9 +44,7 @@
 MediaBlockList::addBlock(off_t off, size_t size)
 {
   haveblocks = true;
-  blocks.push_back(MediaBlock());
-  blocks.back().off = off;
-  blocks.back().size = size;
+  blocks.push_back(MediaBlock( off, size ));
   return blocks.size() - 1;
 }
 
@@ -350,7 +348,7 @@
}
  int oc = buf[i];
  buf[i] = c;
- a += c - oc; 
+ a += c - oc;
  if (bshift)
b += a - (oc  bshift);
  else
@@ -370,7 +368,7 @@
r = ((unsigned int)a  255)  16 | ((unsigned int)b  65535);
  else
r = ((unsigned int)a  65535)  16 | ((unsigned int)b  65535);
- unsigned int h = r  hm; 
+ unsigned int h = r  hm;
  unsigned int hh = 7;
  for (; ht[h]; h = (h + hh++)  hm)
{
@@ -466,7 +464,7 @@
   std::vectorMediaBlock nblocks;
   std::vectorunsigned char nchksums;
   std::vectorunsigned int nrsums;
-  
+
   for (size_t blkno = 0; blkno  blocks.size(); ++blkno)
 {
   if (!found[blkno])
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libzypp-9.8.4/zypp/media/MediaBlockList.h 

commit mozilla-xulrunner20 for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package mozilla-xulrunner20 for 
openSUSE:Factory
checked in at Tue Jul 19 14:04:16 CEST 2011.




--- mozilla-xulrunner20/mozilla-xulrunner20.changes 2011-05-23 
21:02:20.0 +0200
+++ 
/mounts/work_src_done/STABLE/mozilla-xulrunner20/mozilla-xulrunner20.changes
2011-07-18 10:30:24.0 +0200
@@ -1,0 +2,7 @@
+Mon Jul 18 08:17:19 UTC 2011 - a...@suse.de
+
+  From MozillaFirefox package:
+- do not build dump_syms static (not needed for us)
+  - fix build for openSUSE 12.1 and above
+
+---

calling whatdependson for head-i586


New:

  mozilla-dump_syms-static.patch



Other differences:
--
++ mozilla-xulrunner20.spec ++
--- /var/tmp/diff_new_pack.4esJuT/_old  2011-07-19 13:53:29.0 +0200
+++ /var/tmp/diff_new_pack.4esJuT/_new  2011-07-19 13:53:29.0 +0200
@@ -31,7 +31,7 @@
 %endif
 License:MPLv1.1 or GPLv2+ or LGPLv2+
 Version:2.0.1
-Release:3
+Release:5
 %define releasedate 2011041400
 %define version_internal 2.0.1
 %define apiversion 2.0
@@ -76,6 +76,7 @@
 Patch15:mozilla-cairo-return.patch
 Patch16:mozilla-ntlm-full-path.patch
 Patch17:mozilla-gcc46.patch
+Patch18:mozilla-dump_syms-static.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires:   mozilla-js20 = %{version}
 Requires(post):  update-alternatives coreutils
@@ -222,6 +223,7 @@
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
+%patch18 -p1
 
 %build
 modified=$(sed -n '/^/n;s/ - .*$//;p;q' %{_sourcedir}/%{name}.changes)

++ mozilla-dump_syms-static.patch ++
# HG changeset patch
# Parent e589abb2c4d6aaa6083d254416211ac90360dbdd
NO-BUG: Ignore a hack which is not needed in distribution build environments.

diff --git 
a/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in 
b/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in
--- 
a/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in
+++ 
b/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in
@@ -59,11 +59,11 @@ HOST_LIBS += \
   $(NULL)
 
 # force C++ linking
 CPP_PROG_LINK = 1
 FORCE_USE_PIC = 1
 
 #XXX: bug 554854 causes us to be unable to run binaries on the build slaves
 # due to them having an older libstdc++
-HOST_LDFLAGS += -static
+#HOST_LDFLAGS += -static
 
 include $(topsrcdir)/config/rules.mk





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yast2-users for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package yast2-users for openSUSE:Factory
checked in at Tue Jul 19 14:09:40 CEST 2011.




--- yast2-users/yast2-users.changes 2011-04-05 11:06:19.0 +0200
+++ /mounts/work_src_done/STABLE/yast2-users/yast2-users.changes
2011-07-15 12:48:54.0 +0200
@@ -1,0 +2,12 @@
+Fri Jul 15 12:45:19 CEST 2011 - jsuch...@suse.cz
+
+- adapted testsuite to previous change
+- 2.21.5
+
+---
+Fri Jul 15 12:41:25 CEST 2011 - jsuch...@suse.cz
+
+- fixed typos (bnc#703227)
+- 2.21.4 
+
+---

calling whatdependson for head-i586


Old:

  yast2-users-2.21.3.tar.bz2

New:

  yast2-users-2.21.5.tar.bz2



Other differences:
--
++ yast2-users.spec ++
--- /var/tmp/diff_new_pack.CLXW7K/_old  2011-07-19 14:04:28.0 +0200
+++ /var/tmp/diff_new_pack.CLXW7K/_new  2011-07-19 14:04:28.0 +0200
@@ -19,16 +19,16 @@
 
 
 Name:   yast2-users
-Version:2.21.3
+Version:2.21.5
 Release:1
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-Source0:yast2-users-2.21.3.tar.bz2
+Source0:yast2-users-2.21.5.tar.bz2
 
 Prefix: /usr
 
 Group:  System/YaST
-License:GPLv2+
+License:GPL v2 or later
 BuildRequires:  cracklib-devel doxygen gcc-c++ perl-Digest-SHA1 
perl-XML-Writer update-desktop-files yast2 yast2-core-devel yast2-devtools 
yast2-ldap-client yast2-perl-bindings yast2-security yast2-testsuite
 
 Requires:   yast2-country yast2-pam yast2-security cracklib 
perl-Digest-SHA1 perl-X500-DN perl-gettext
@@ -53,7 +53,7 @@
 This package provides GUI for maintenance of linux users and groups.
 
 %prep
-%setup -n yast2-users-2.21.3
+%setup -n yast2-users-2.21.5
 
 %build
 %{prefix}/bin/y2tool y2autoconf

++ yast2-users-2.21.3.tar.bz2 - yast2-users-2.21.5.tar.bz2 ++
 14861 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/yast2-users-2.21.3/VERSION new/yast2-users-2.21.5/VERSION
--- old/yast2-users-2.21.3/VERSION  2011-04-05 11:01:39.0 +0200
+++ new/yast2-users-2.21.5/VERSION  2011-07-15 12:45:40.0 +0200
@@ -1 +1 @@
-2.21.3
+2.21.5
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/yast2-users-2.21.3/config.h.in new/yast2-users-2.21.5/config.h.in
--- old/yast2-users-2.21.3/config.h.in  2010-03-12 08:05:36.0 +0100
+++ new/yast2-users-2.21.5/config.h.in  2011-06-23 15:52:23.0 +0200
@@ -64,6 +64,9 @@
 /* Define to the one symbol short name of this package. */
 #undef PACKAGE_TARNAME
 
+/* Define to the home page for this package. */
+#undef PACKAGE_URL
+
 /* Define to the version of this package. */
 #undef PACKAGE_VERSION
 
@@ -80,3 +83,6 @@
 
 /* Version number of package */
 #undef VERSION
+
+/* Define to `unsigned int' if sys/types.h does not define. */
+#undef size_t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/yast2-users-2.21.3/configure.in new/yast2-users-2.21.5/configure.in
--- old/yast2-users-2.21.3/configure.in 2010-03-12 08:05:23.0 +0100
+++ new/yast2-users-2.21.5/configure.in 2011-06-23 15:52:14.0 +0200
@@ -3,7 +3,7 @@
 dnl -- This file is generated by y2autoconf 2.18.11 - DO NOT EDIT! --
 dnl(edit configure.in.in instead)
 
-AC_INIT(yast2-users, 2.19.7, http://bugs.opensuse.org/, yast2-users)
+AC_INIT(yast2-users, 2.21.3, http://bugs.opensuse.org/, yast2-users)
 dnl Check for presence of file 'RPMNAME'
 AC_CONFIG_SRCDIR([RPMNAME])
 
@@ -18,7 +18,7 @@
 AM_INIT_AUTOMAKE(tar-ustar -Wno-portability)
 
 dnl Important YaST2 variables
-VERSION=2.19.7
+VERSION=2.21.3
 RPMNAME=yast2-users
 MAINTAINER=Jiri Suchomel jsuch...@suse.cz
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 

commit mkinitrd for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package mkinitrd for openSUSE:Factory
checked in at Tue Jul 19 14:16:23 CEST 2011.




--- mkinitrd/mkinitrd.changes   2011-06-30 23:11:12.0 +0200
+++ /mounts/work_src_done/STABLE/mkinitrd/mkinitrd.changes  2011-07-18 
13:39:12.0 +0200
@@ -1,0 +2,5 @@
+Mon Jul 18 11:16:42 UTC 2011 - mma...@novell.com
+
+- purge-kernels: Fix matching of -rc kernels.
+
+---
@@ -56,0 +62,5 @@
+
+---
+Thu Jun  2 11:35:12 UTC 2011 - mma...@novell.com
+
+- Map /dev/fio* to the iomemory-vsl driver (bnc#695620).

calling whatdependson for head-i586




Other differences:
--
++ mkinitrd.spec ++
--- /var/tmp/diff_new_pack.pA4HFq/_old  2011-07-19 14:09:51.0 +0200
+++ /var/tmp/diff_new_pack.pA4HFq/_new  2011-07-19 14:09:51.0 +0200
@@ -31,7 +31,7 @@
 %endif
 AutoReqProv:on
 Version:2.7.0
-Release:17
+Release:19
 Conflicts:  udev  118
 Requires:   dhcpcd
 PreReq: %fillup_prereq

++ mkinitrd.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mkinitrd-2.7.0/mkinitrd.changes 
new/mkinitrd-2.7.0/mkinitrd.changes
--- old/mkinitrd-2.7.0/mkinitrd.changes 2011-06-30 23:10:43.0 +0200
+++ new/mkinitrd-2.7.0/mkinitrd.changes 2011-07-18 13:17:18.0 +0200
@@ -1,4 +1,9 @@
 ---
+Mon Jul 18 11:16:42 UTC 2011 - mma...@novell.com
+
+- purge-kernels: Fix matching of -rc kernels.
+
+---
 Thu Jun 30 21:07:11 UTC 2011 - mma...@novell.com
 
 - Allow scripts to set multiple interfaces in the $interface
@@ -56,6 +61,11 @@
 - boot-start: Mount /run without noexec to match systemd.
 
 ---
+Thu Jun  2 11:35:12 UTC 2011 - mma...@novell.com
+
+- Map /dev/fio* to the iomemory-vsl driver (bnc#695620).
+
+---
 Mon May  9 16:55:56 CEST 2011 - r...@suse.de
 
 - move sysconfig/kernel related parts to this package 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mkinitrd-2.7.0/sbin/purge-kernels 
new/mkinitrd-2.7.0/sbin/purge-kernels
--- old/mkinitrd-2.7.0/sbin/purge-kernels   2011-06-30 23:10:43.0 
+0200
+++ new/mkinitrd-2.7.0/sbin/purge-kernels   2011-07-18 13:17:18.0 
+0200
@@ -250,6 +250,16 @@
chomp($running_version);
($running_flavor = $running_version) =~ s/.*-//;
$running_version =~ s/-[^-]*$//;
+   (my $release = $running_version) =~ s/.*-//;
+   $running_version =~ s/-[^-]*$//;
+
+   # copied from kernel-source/rpm/mkspec
+   $running_version =~ s/\.0-rc/.rc/;
+   $running_version =~ s/-rc\d+//;
+   $running_version =~ s/-/./g;
+
+   $running_version .= -$release;
+
my $arch = `uname -m`;
chomp($arch);
$arch =~ s/^i.86$/i586/;
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mkinitrd-2.7.0/scripts/setup-block.sh 
new/mkinitrd-2.7.0/scripts/setup-block.sh
--- old/mkinitrd-2.7.0/scripts/setup-block.sh   2011-06-30 23:10:43.0 
+0200
+++ new/mkinitrd-2.7.0/scripts/setup-block.sh   2011-07-18 13:17:18.0 
+0200
@@ -127,6 +127,9 @@
 mmc*)
 result=mmc_block
 ;;
+fio*)
+result=iomemory-vsl
+;;
 *)
 if [ ! -d /sys/block/$blkdev/device ] ; then
 echo Device $blkdev not handled 2






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit mx for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package mx for openSUSE:Factory
checked in at Tue Jul 19 14:30:41 CEST 2011.




--- mx/mx.changes   2011-06-04 20:22:51.0 +0200
+++ /mounts/work_src_done/STABLE/mx/mx.changes  2011-07-18 10:10:52.0 
+0200
@@ -1,0 +2,6 @@
+Mon Jul 18 10:10:21 CEST 2011 - vu...@opensuse.org
+
+- Add mx-no-G_CONST_RETURN.patch to stop using G_CONST_RETURN which
+  is deprecated. This fixes the build of the-board.
+
+---

calling whatdependson for head-i586


New:

  mx-no-G_CONST_RETURN.patch



Other differences:
--
++ mx.spec ++
--- /var/tmp/diff_new_pack.nwRgMi/_old  2011-07-19 14:29:04.0 +0200
+++ /var/tmp/diff_new_pack.nwRgMi/_new  2011-07-19 14:29:04.0 +0200
@@ -19,12 +19,14 @@
 
 Name:   mx
 Version:1.2.0
-Release:1
+Release:2
 License:LGPLv2.1
 Summary:Clutter-based Toolkit
 Url:http://www.clutter-project.org/
 Group:  System/Libraries
 Source0:%{name}-%{version}.tar.bz2
+# PATCH-FIX-UPSTREAM mx-no-G_CONST_RETURN.patch bco#2669 vu...@opensuse.org -- 
Stop using deprecated G_CONST_RETURN
+Patch0: mx-no-G_CONST_RETURN.patch
 BuildRequires:  fdupes
 BuildRequires:  intltool
 BuildRequires:  pkgconfig(clutter-1.0)
@@ -105,6 +107,7 @@
 %lang_package
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure \

++ mx-no-G_CONST_RETURN.patch ++
From 16a4558f474cc67a5ae8e88ec238009a924bd6a3 Mon Sep 17 00:00:00 2001
From: Claudio Saavedra csaave...@igalia.com
Date: Thu, 16 Jun 2011 14:29:09 +0300
Subject: [PATCH] Replace deprecated G_CONST_RETURN with const

http://bugzilla.clutter-project.org/show_bug.cgi?id=2669
---
 mx/mx-application.c  |2 +-
 mx/mx-application.h  |2 +-
 mx/mx-button-group.c |2 +-
 mx/mx-button-group.h |2 +-
 mx/mx-button.c   |4 ++--
 mx/mx-button.h   |4 ++--
 mx/mx-entry.c|4 ++--
 mx/mx-entry.h|4 ++--
 mx/mx-label.c|2 +-
 mx/mx-label.h|2 +-
 mx/mx-stylable.c |4 ++--
 mx/mx-stylable.h |8 
 mx/mx-tooltip.c  |4 ++--
 mx/mx-tooltip.h  |4 ++--
 14 files changed, 24 insertions(+), 24 deletions(-)

diff --git a/mx/mx-application.c b/mx/mx-application.c
index 70faf62..60635c9 100644
--- a/mx/mx-application.c
+++ b/mx/mx-application.c
@@ -829,7 +829,7 @@ mx_application_remove_window (MxApplication *application,
  *   of #MxWindow!-- --s. The returned list is owned by
  *   @application and must not be altered.
  */
-G_CONST_RETURN GList*
+const GList*
 mx_application_get_windows (MxApplication *application)
 {
   g_return_val_if_fail (MX_IS_APPLICATION (application), NULL);
diff --git a/mx/mx-application.h b/mx/mx-application.h
index 65af4f6..594246e 100644
--- a/mx/mx-application.h
+++ b/mx/mx-application.h
@@ -115,7 +115,7 @@ void  mx_application_add_window
(MxApplication *application,
 void  mx_application_remove_window (MxApplication *application,
 MxWindow  *window);
 
-G_CONST_RETURN GList* mx_application_get_windows   (MxApplication 
*application);
+const GList* mx_application_get_windows   (MxApplication *application);
 
 void  mx_application_add_action(MxApplication *application,
 MxAction  *action);
diff --git a/mx/mx-button-group.c b/mx/mx-button-group.c
index 8175a9a..bde8d82 100644
--- a/mx/mx-button-group.c
+++ b/mx/mx-button-group.c
@@ -453,7 +453,7 @@ mx_button_group_get_allow_no_active (MxButtonGroup *group)
  * Returns: a list of buttons. The list is owned by the #MxButtonGroup and
  * should not be modified by the application.
  */
-G_CONST_RETURN GSList *
+const GSList *
 mx_button_group_get_buttons (MxButtonGroup *group)
 {
   g_return_val_if_fail (MX_IS_BUTTON_GROUP (group), NULL);
diff --git a/mx/mx-button-group.h b/mx/mx-button-group.h
index 6bfecd8..38402d3 100644
--- a/mx/mx-button-group.h
+++ b/mx/mx-button-group.h
@@ -105,7 +105,7 @@ void  mx_button_group_set_allow_no_active 
(MxButtonGroup *group,
gboolean   allow_no_active);
 gboolean  mx_button_group_get_allow_no_active (MxButtonGroup *group);
 
-G_CONST_RETURN GSList *mx_button_group_get_buttons (MxButtonGroup *group);
+const GSList *mx_button_group_get_buttons (MxButtonGroup *group);
 
 G_END_DECLS
 
diff --git a/mx/mx-button.c b/mx/mx-button.c
index c0d6e75..b8c8b27 100644
--- a/mx/mx-button.c
+++ b/mx/mx-button.c
@@ -1015,7 +1015,7 @@ mx_button_new_with_label (const gchar *text)
  *
  * Returns: the text for the button. This must not be freed by the application
  */
-G_CONST_RETURN gchar *
+const gchar *
 mx_button_get_label (MxButton *button)
 {
   

commit linphone for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package linphone for openSUSE:Factory
checked in at Tue Jul 19 14:31:27 CEST 2011.




--- linphone/linphone.changes   2011-01-16 15:17:33.0 +0100
+++ /mounts/work_src_done/STABLE/linphone/linphone.changes  2011-07-12 
15:08:31.0 +0200
@@ -1,0 +2,15 @@
+Tue Jul 12 13:08:05 UTC 2011 - c...@novell.com
+
+- fixing 11.4 build
+
+---
+Thu Jul  7 09:54:38 UTC 2011 - idon...@novell.com
+
+- Add linphone-v4l-2.6.38.patch: use new v4l interface 
+
+---
+Mon Feb 14 19:49:23 CET 2011 - sbra...@suse.cz
+
+- Added support for translation-update-upstream.
+
+---

calling whatdependson for head-i586


New:

  linphone-v4l-2.6.38.patch



Other differences:
--
++ linphone.spec ++
--- /var/tmp/diff_new_pack.xPIFmO/_old  2011-07-19 14:30:50.0 +0200
+++ /var/tmp/diff_new_pack.xPIFmO/_new  2011-07-19 14:30:50.0 +0200
@@ -19,7 +19,7 @@
 
 Name:   linphone
 Version:3.3.2
-Release:3
+Release:99
 License:GPLv2+
 Summary:Web Phone
 Url:http://www.linphone.org
@@ -28,17 +28,23 @@
 Source1:%{name}-manual.tar.bz2
 Source99:   history-orange.png
 Patch1: linphone-3.3.x-20100903.diff.bz2
+Patch2: linphone-v4l-2.6.38.patch
 BuildRequires:  gcc-c++
 BuildRequires:  gnome-panel-devel
 BuildRequires:  gnutls-devel
 BuildRequires:  intltool
 BuildRequires:  libeXosip2-devel
 BuildRequires:  libosip2-devel
+%if 0%{?suse_version} = 1210
+BuildRequires:  libv4l-devel = 0.8.4
+%else
 BuildRequires:  libv4l-devel
+%endif
 BuildRequires:  perl-XML-Parser
 BuildRequires:  pkgconfig(libglade-2.0)
 BuildRequires:  readline-devel
 BuildRequires:  speex-devel
+BuildRequires:  translation-update-upstream
 BuildRequires:  update-desktop-files
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 #NoSource:   0
@@ -87,18 +93,27 @@
 
 %prep
 %setup -q
+# This patch represents upstream, call translation-update-upstream after it:
 %patch1 -p1
+%if 0%{?suse_version} = 1210
+%patch2
+%endif
 # patch cannot handle binaries
 cp %{S:99} pixmaps/history-orange.png
+translation-update-upstream
 find -name CVS -type d | xargs rm -rfv
 
 %build
+%if 0%{?suse_version} = 1140
+autoreconf -fi
+%endif
 # needed for linphone-1.3.0:
 export CFLAGS=%{optflags} -fno-strict-aliasing
 %configure\
--libexecdir=%{_prefix}/lib/gnome-panel\
--disable-static \
-   --disable-video
+   --disable-video \
+--disable-strict
 make %{?_smp_mflags}
 
 %install
@@ -138,6 +153,8 @@
 %{_datadir}/images/nowebcamCIF.jpg
 %{_datadir}/applications/linphone.desktop
 %dir %{_datadir}/images
+%dir %{_datadir}/gnome
+%dir %{_datadir}/gnome/help
 
 %files applet
 %defattr(-,root,root)


++ linphone-v4l-2.6.38.patch ++
--- mediastreamer2/configure.ac 2010-06-18 09:55:26.0 +0200
+++ mediastreamer2configure.ac  2011-07-07 11:53:29.595089325 +0200
@@ -567,8 +567,8 @@
 AC_SUBST(PACKAGE_DATA_DIR)
 
 dnl check for video4linux headers
-AC_CHECK_HEADERS(linux/videodev.h linux/videodev2.h)
-if test ${ac_cv_header_linux_videodev_h} = yes || \
+AC_CHECK_HEADERS(libv4l1-videodev.h linux/videodev2.h)
+if test ${ac_cv_header_libv4l1_videodev_h} = yes || \
test ${ac_cv_header_linux_videodev2_h} = yes ; then
found_v4l=yes
 else
--- mediastreamer2/src/msv4l.c  2010-06-02 14:33:57.0 +0200
+++ mediastreamer2/src/msv4l.c  2011-07-07 11:54:02.283089301 +0200
@@ -30,7 +30,7 @@
 #include string.h
 #include sys/mman.h
 
-#include linux/videodev.h
+#include libv4l1-videodev.h
 #ifdef HAVE_LINUX_VIDEODEV2_H
 #include linux/videodev2.h
 #endif





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gnome-do for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package gnome-do for openSUSE:Factory
checked in at Tue Jul 19 14:33:11 CEST 2011.




--- GNOME/gnome-do/gnome-do.changes 2011-06-17 06:09:25.0 +0200
+++ /mounts/work_src_done/STABLE/gnome-do/gnome-do.changes  2011-07-18 
10:16:48.0 +0200
@@ -1,0 +2,6 @@
+Mon Jul 18 10:16:33 CEST 2011 - vu...@opensuse.org
+
+- Add missing glade-sharp2 BuildRequires to fix build; it was
+  implicitly brought in before.
+
+---

calling whatdependson for head-i586




Other differences:
--
++ gnome-do.spec ++
--- /var/tmp/diff_new_pack.4Ob7FD/_old  2011-07-19 14:31:36.0 +0200
+++ /var/tmp/diff_new_pack.4Ob7FD/_new  2011-07-19 14:31:36.0 +0200
@@ -20,7 +20,7 @@
 
 Name:   gnome-do
 Version:0.8.5
-Release:1
+Release:2
 # FIXME: check if removal of locales in %install is still needed (last 
checked: 2010-12-11)
 License:GPLv3+
 Url:http://do.davebsd.com/
@@ -48,6 +48,7 @@
 BuildRequires:  ndesk-dbus-glib
 %else
 BuildRequires:  gconf-sharp2
+BuildRequires:  glade-sharp2
 BuildRequires:  gnome-desktop-sharp2
 BuildRequires:  gnome-sharp2
 BuildRequires:  rsvg2-sharp






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yast2-nis-client for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package yast2-nis-client for openSUSE:Factory
checked in at Tue Jul 19 14:34:34 CEST 2011.




--- yast2-nis-client/yast2-nis-client.changes   2011-03-23 15:02:21.0 
+0100
+++ /mounts/work_src_done/STABLE/yast2-nis-client/yast2-nis-client.changes  
2011-07-15 12:14:12.0 +0200
@@ -1,0 +2,6 @@
+Fri Jul 15 12:13:23 CEST 2011 - jsuch...@suse.cz
+
+- fixed typo
+- 2.21.1 
+
+---

calling whatdependson for head-i586


Old:

  yast2-nis-client-2.21.0.tar.bz2

New:

  yast2-nis-client-2.21.1.tar.bz2



Other differences:
--
++ yast2-nis-client.spec ++
--- /var/tmp/diff_new_pack.zkftpf/_old  2011-07-19 14:33:19.0 +0200
+++ /var/tmp/diff_new_pack.zkftpf/_new  2011-07-19 14:33:19.0 +0200
@@ -19,16 +19,16 @@
 
 
 Name:   yast2-nis-client
-Version:2.21.0
+Version:2.21.1
 Release:1
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-Source0:yast2-nis-client-2.21.0.tar.bz2
+Source0:yast2-nis-client-2.21.1.tar.bz2
 
 Prefix: /usr
 
 Group:  System/YaST
-License:GPLv2+
+License:GPL v2 or later
 BuildRequires:  doxygen gcc-c++ perl-XML-Writer update-desktop-files yast2 
yast2-core-devel yast2-devtools yast2-pam yast2-testsuite
 Requires:   yast2 yast2-pam
 # .net.hostnames.rpc
@@ -47,7 +47,7 @@
 yellow pages.
 
 %prep
-%setup -n yast2-nis-client-2.21.0
+%setup -n yast2-nis-client-2.21.1
 
 %build
 %{prefix}/bin/y2tool y2autoconf

++ yast2-nis-client-2.21.0.tar.bz2 - yast2-nis-client-2.21.1.tar.bz2 ++
 68095 lines of diff (skipped)






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yast2-kerberos-client for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package yast2-kerberos-client for 
openSUSE:Factory
checked in at Tue Jul 19 14:35:30 CEST 2011.




--- yast2-kerberos-client/yast2-kerberos-client.changes 2011-03-23 
12:36:02.0 +0100
+++ 
/mounts/work_src_done/STABLE/yast2-kerberos-client/yast2-kerberos-client.changes
2011-07-15 12:11:29.0 +0200
@@ -1,0 +2,6 @@
+Fri Jul 15 12:05:53 CEST 2011 - jsuch...@suse.cz
+
+- fixed typos in help texts (bnc#703166)
+- 2.21.2 
+
+---

calling whatdependson for head-i586


Old:

  yast2-kerberos-client-2.21.1.tar.bz2

New:

  yast2-kerberos-client-2.21.2.tar.bz2



Other differences:
--
++ yast2-kerberos-client.spec ++
--- /var/tmp/diff_new_pack.Givb7h/_old  2011-07-19 14:34:43.0 +0200
+++ /var/tmp/diff_new_pack.Givb7h/_new  2011-07-19 14:34:43.0 +0200
@@ -19,16 +19,16 @@
 
 
 Name:   yast2-kerberos-client
-Version:2.21.1
+Version:2.21.2
 Release:1
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-Source0:yast2-kerberos-client-2.21.1.tar.bz2
+Source0:yast2-kerberos-client-2.21.2.tar.bz2
 
 Prefix: /usr
 
 Group:  System/YaST
-License:GPLv2+
+License:GPL v2 or later
 BuildRequires:  doxygen perl-XML-Writer update-desktop-files yast2 
yast2-devtools yast2-pam yast2-testsuite
 
 # etc_krb5_conf.scr 
@@ -46,7 +46,7 @@
 Kerberos server will be used for user authentication.
 
 %prep
-%setup -n yast2-kerberos-client-2.21.1
+%setup -n yast2-kerberos-client-2.21.2
 
 %build
 %{prefix}/bin/y2tool y2autoconf

++ yast2-kerberos-client-2.21.1.tar.bz2 - 
yast2-kerberos-client-2.21.2.tar.bz2 ++
 4986 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/yast2-kerberos-client-2.21.1/VERSION 
new/yast2-kerberos-client-2.21.2/VERSION
--- old/yast2-kerberos-client-2.21.1/VERSION2011-03-23 12:14:37.0 
+0100
+++ new/yast2-kerberos-client-2.21.2/VERSION2011-07-15 12:06:22.0 
+0200
@@ -1 +1 @@
-2.21.1
+2.21.2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/yast2-kerberos-client-2.21.1/configure.in 
new/yast2-kerberos-client-2.21.2/configure.in
--- old/yast2-kerberos-client-2.21.1/configure.in   2010-01-28 
16:08:45.0 +0100
+++ new/yast2-kerberos-client-2.21.2/configure.in   2011-06-23 
15:52:04.0 +0200
@@ -3,7 +3,7 @@
 dnl -- This file is generated by y2autoconf 2.18.11 - DO NOT EDIT! --
 dnl(edit configure.in.in instead)
 
-AC_INIT(yast2-kerberos-client, 2.19.0, http://bugs.opensuse.org/, 
yast2-kerberos-client)
+AC_INIT(yast2-kerberos-client, 2.21.1, http://bugs.opensuse.org/, 
yast2-kerberos-client)
 dnl Check for presence of file 'RPMNAME'
 AC_CONFIG_SRCDIR([RPMNAME])
 
@@ -18,7 +18,7 @@
 AM_INIT_AUTOMAKE(tar-ustar -Wno-portability)
 
 dnl Important YaST2 variables
-VERSION=2.19.0
+VERSION=2.21.1
 RPMNAME=yast2-kerberos-client
 MAINTAINER=Jiri Suchomel jsuch...@suse.cz
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/yast2-kerberos-client-2.21.1/src/Kerberos.ycp 
new/yast2-kerberos-client-2.21.2/src/Kerberos.ycp
--- old/yast2-kerberos-client-2.21.1/src/Kerberos.ycp   2011-03-16 
14:52:36.0 +0100
+++ new/yast2-kerberos-client-2.21.2/src/Kerberos.ycp   2011-07-15 
12:10:29.0 +0200
@@ -4,7 +4,7 @@
  * Summary:Data for configuration of kerberos-client, i/o functions.
  * Authors:Jiri Suchomel jsuch...@suse.cz
  *
- * $Id: Kerberos.ycp 63577 2011-03-16 13:52:35Z jsuchome $
+ * $Id: Kerberos.ycp 64832 2011-07-15 10:10:28Z jsuchome $
  *
  * Representation of the configuration of kerberos-client.
  * Input and output routines.
@@ -740,13 +740,13 @@
  */
 global liststring RequiredPackages () {
 
-liststring packages  = required_packages;
+liststring pkgs  = required_packages;
 // do not install pam_krb5 if sssd is configured
 if (sssd)
 {
-   packages= filter (string p, packages, ``(p != pam_krb5));
+   pkgs= filter (string p, pkgs, ``(p != 

commit gnome-do-plugins for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package gnome-do-plugins for openSUSE:Factory
checked in at Tue Jul 19 14:43:57 CEST 2011.




--- gnome-do-plugins/gnome-do-plugins.changes   2011-06-17 06:14:07.0 
+0200
+++ /mounts/work_src_done/STABLE/gnome-do-plugins/gnome-do-plugins.changes  
2011-07-18 10:22:36.0 +0200
@@ -1,0 +2,9 @@
+Mon Jul 18 10:21:59 CEST 2011 - vu...@opensuse.org
+
+- Add missing glade-sharp2 BuildRequires to fix build; it was
+  implicitly brought in before.
+- Add pkgconfig(dbus-sharp-1.0) and pkgconfig(dbus-sharp-glib-1.0)
+  BuildRequires on 12.1 and later to build empathy plugin. Fix
+  bnc#698764.
+
+---

calling whatdependson for head-i586




Other differences:
--
++ gnome-do-plugins.spec ++
--- /var/tmp/diff_new_pack.BLu0fZ/_old  2011-07-19 14:40:13.0 +0200
+++ /var/tmp/diff_new_pack.BLu0fZ/_new  2011-07-19 14:40:13.0 +0200
@@ -20,8 +20,7 @@
 
 Name:   gnome-do-plugins
 Version:0.8.4
-Release:1
-# FIXME: add dbus-sharp BuildRequires to build empathy plugin when it's in 
Factory (last checked: 2011-06-08)
+Release:2
 License:GPLv3
 Url:http://do.davebsd.com
 Source: 
http://launchpad.net/do-plugins/trunk/0.8.4/+download/%{name}-%{version}.tar.gz
@@ -30,6 +29,7 @@
 BuildRequires:  banshee-1-devel = 1.4.2
 BuildRequires:  flickrnet
 BuildRequires:  gconf-sharp2
+BuildRequires:  glade-sharp2
 BuildRequires:  gnome-do = 0.8.1
 BuildRequires:  gnome-keyring-sharp-devel
 BuildRequires:  gnome-sharp2
@@ -40,6 +40,10 @@
 BuildRequires:  pkg-config
 BuildRequires:  update-desktop-files
 BuildRequires:  wnck-sharp
+%if 0%{?suse_version}  1140
+BuildRequires:  pkgconfig(dbus-sharp-1.0)
+BuildRequires:  pkgconfig(dbus-sharp-glib-1.0)
+%endif
 Requires:   gnome-do
 Requires:   xdg-utils
 Requires:   %{name}-lang = %{version}






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit frogr for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package frogr for openSUSE:Factory
checked in at Tue Jul 19 14:46:01 CEST 2011.




--- frogr/frogr.changes 2011-05-28 02:04:48.0 +0200
+++ /mounts/work_src_done/STABLE/frogr/frogr.changes2011-07-18 
10:30:31.0 +0200
@@ -1,0 +2,6 @@
+Mon Jul 18 10:29:47 CEST 2011 - vu...@opensuse.org
+
+- Add frogr-no-deprecated-GtkBox.patch to fix build by not using
+  deprecated Gtk[HV]Box with GTK+ 3.
+
+---

calling whatdependson for head-i586


New:

  frogr-no-deprecated-GtkBox.patch



Other differences:
--
++ frogr.spec ++
--- /var/tmp/diff_new_pack.WARnum/_old  2011-07-19 14:44:08.0 +0200
+++ /var/tmp/diff_new_pack.WARnum/_new  2011-07-19 14:44:08.0 +0200
@@ -19,12 +19,14 @@
 
 Name:   frogr
 Version:0.5
-Release:1
+Release:3
 License:GPLv3
 Summary:Tool to Manage Flickr Accounts
 Url:https://live.gnome.org/Frogr
 Group:  Productivity/Graphics/Other
 Source: %{name}-%{version}.tar.bz2
+# PATCH-FIX-UPSTREAM frogr-no-deprecated-GtkBox.patch vu...@opensuse.org -- Do 
not use deprecated Gtk[HV]Box with GTK+ 3. Taken from git.
+Patch0: frogr-no-deprecated-GtkBox.patch
 BuildRequires:  intltool
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(glib-2.0)
@@ -48,6 +50,7 @@
 %lang_package
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure

++ frogr-no-deprecated-GtkBox.patch ++
From 676b8867b53ab39a375f9ebc527568ae8277a677 Mon Sep 17 00:00:00 2001
From: Mario Sanchez Prada msanc...@igalia.com
Date: Thu, 09 Jun 2011 10:52:21 +
Subject: Do not use deprecated classes Gtk{H|V}Box anymore

---
diff --git a/src/frogr-details-dialog.c b/src/frogr-details-dialog.c
index ab9ce5e..752a1e6 100644
--- a/src/frogr-details-dialog.c
+++ b/src/frogr-details-dialog.c
@@ -141,8 +141,8 @@ _create_widgets (FrogrDetailsDialog *self)
 
   main_vbox = gtk_dialog_get_content_area (GTK_DIALOG (self));
 
-  hbox = gtk_hbox_new (FALSE, 0);
-  vbox = gtk_vbox_new (FALSE, 6);
+  hbox = gtk_box_new (GTK_ORIENTATION_HORIZONTAL, 0);
+  vbox = gtk_box_new (GTK_ORIENTATION_VERTICAL, 6);
 
   /* Left side (image, radio buttons, checkboxes...) */
 
@@ -157,8 +157,8 @@ _create_widgets (FrogrDetailsDialog *self)
 
   /* Visibility */
 
-  section_vbox = gtk_vbox_new (FALSE, 6);
-  visibility_vbox = gtk_vbox_new (FALSE, 6);
+  section_vbox = gtk_box_new (GTK_ORIENTATION_VERTICAL, 6);
+  visibility_vbox = gtk_box_new (GTK_ORIENTATION_VERTICAL, 6);
 
   markup = g_markup_printf_escaped (span weight=\bold\%s/span,
 _(Visibility));
@@ -170,7 +170,7 @@ _create_widgets (FrogrDetailsDialog *self)
   gtk_container_add (GTK_CONTAINER (align), widget);
   gtk_box_pack_start (GTK_BOX (section_vbox), align, FALSE, FALSE, 0);
 
-  internal_hbox = gtk_hbox_new (FALSE, 6);
+  internal_hbox = gtk_box_new (GTK_ORIENTATION_HORIZONTAL, 6);
 
   widget = gtk_radio_button_new_with_mnemonic (NULL, _(_Private));
   gtk_box_pack_start (GTK_BOX (internal_hbox), widget, FALSE, FALSE, 0);
@@ -182,7 +182,7 @@ _create_widgets (FrogrDetailsDialog *self)
 
   gtk_box_pack_start (GTK_BOX (visibility_vbox), internal_hbox, FALSE, FALSE, 
0);
 
-  private_vbox = gtk_vbox_new (FALSE, 6);
+  private_vbox = gtk_box_new (GTK_ORIENTATION_VERTICAL, 6);
 
   widget = gtk_check_button_new_with_mnemonic (_(Visible to _Family));
   gtk_box_pack_start (GTK_BOX (private_vbox), widget, FALSE, FALSE, 0);
@@ -192,15 +192,15 @@ _create_widgets (FrogrDetailsDialog *self)
   gtk_box_pack_start (GTK_BOX (private_vbox), widget, FALSE, FALSE, 0);
   priv-friend_cb = widget;
 
-  internal_hbox = gtk_hbox_new (FALSE, 0);
+  internal_hbox = gtk_box_new (GTK_ORIENTATION_HORIZONTAL, 0);
   gtk_box_pack_start (GTK_BOX (internal_hbox), private_vbox, FALSE, FALSE, 12);
   gtk_box_pack_start (GTK_BOX (visibility_vbox), internal_hbox, FALSE, FALSE, 
0);
 
-  internal_hbox = gtk_hbox_new (FALSE, 0);
+  internal_hbox = gtk_box_new (GTK_ORIENTATION_HORIZONTAL, 0);
   gtk_box_pack_start (GTK_BOX (internal_hbox), visibility_vbox, FALSE, FALSE, 
0);
   gtk_box_pack_start (GTK_BOX (section_vbox), internal_hbox, FALSE, FALSE, 0);
 
-  internal_hbox = gtk_hbox_new (FALSE, 0);
+  internal_hbox = gtk_box_new (GTK_ORIENTATION_HORIZONTAL, 0);
   widget = gtk_check_button_new_with_mnemonic (_(_Show up in Global Search 
Results));
   gtk_box_pack_start (GTK_BOX (internal_hbox), widget, FALSE, FALSE, 0);
   gtk_box_pack_start (GTK_BOX (section_vbox), internal_hbox, FALSE, FALSE, 0);
@@ -210,8 +210,8 @@ _create_widgets (FrogrDetailsDialog *self)
 
   /* Content type */
 
-  section_vbox = gtk_vbox_new (FALSE, 6);
-  content_type_hbox = gtk_hbox_new (FALSE, 6);
+  section_vbox = gtk_box_new (GTK_ORIENTATION_VERTICAL, 6);
+  

commit yast2-wagon for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package yast2-wagon for openSUSE:Factory
checked in at Tue Jul 19 14:46:32 CEST 2011.




--- yast2-wagon/yast2-wagon.changes 2011-07-01 12:54:00.0 +0200
+++ /mounts/work_src_done/STABLE/yast2-wagon/yast2-wagon.changes
2011-07-18 15:26:21.0 +0200
@@ -1,0 +2,12 @@
+Mon Jul 18 12:48:20 UTC 2011 - lsle...@suse.cz
+
+- added new core/full migration selection dialog
+- 2.21.3
+
+---
+Mon Jul  4 11:28:46 UTC 2011 - lsle...@suse.cz
+
+- if the system is managed by SUSE Manager display a message
+  and exit (fate#311994)
+
+---

calling whatdependson for head-i586


Old:

  yast2-wagon-2.21.2.tar.bz2

New:

  yast2-wagon-2.21.3.tar.bz2



Other differences:
--
++ yast2-wagon.spec ++
--- /var/tmp/diff_new_pack.Nvwg2r/_old  2011-07-19 14:46:10.0 +0200
+++ /var/tmp/diff_new_pack.Nvwg2r/_new  2011-07-19 14:46:10.0 +0200
@@ -19,11 +19,11 @@
 
 
 Name:   yast2-wagon
-Version:2.21.2
+Version:2.21.3
 Release:1
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-Source0:yast2-wagon-2.21.2.tar.bz2
+Source0:yast2-wagon-2.21.3.tar.bz2
 
 Prefix: /usr
 
@@ -74,7 +74,7 @@
 through command line tools.
 
 %prep
-%setup -n yast2-wagon-2.21.2
+%setup -n yast2-wagon-2.21.3
 
 %build
 %{prefix}/bin/y2tool y2autoconf
@@ -180,5 +180,4 @@
 %dir %{_datadir}/YaST2/control
 %{_datadir}/YaST2/control/online_migration-SLE.xml
 %ghost %{_datadir}/YaST2/control/online_migration.xml
-
 %changelog

++ yast2-wagon-2.21.2.tar.bz2 - yast2-wagon-2.21.3.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-wagon-2.21.2/VERSION 
new/yast2-wagon-2.21.3/VERSION
--- old/yast2-wagon-2.21.2/VERSION  2011-07-01 10:52:52.0 +0200
+++ new/yast2-wagon-2.21.3/VERSION  2011-07-18 15:04:17.0 +0200
@@ -1 +1 @@
-2.21.2
+2.21.3
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-wagon-2.21.2/configure 
new/yast2-wagon-2.21.3/configure
--- old/yast2-wagon-2.21.2/configure2011-07-01 11:00:34.0 +0200
+++ new/yast2-wagon-2.21.3/configure2011-07-18 15:25:47.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.68 for yast2-wagon 2.21.2.
+# Generated by GNU Autoconf 2.68 for yast2-wagon 2.21.3.
 #
 # Report bugs to http://bugs.opensuse.org/.
 #
@@ -559,8 +559,8 @@
 # Identity of this package.
 PACKAGE_NAME='yast2-wagon'
 PACKAGE_TARNAME='yast2-wagon'
-PACKAGE_VERSION='2.21.2'
-PACKAGE_STRING='yast2-wagon 2.21.2'
+PACKAGE_VERSION='2.21.3'
+PACKAGE_STRING='yast2-wagon 2.21.3'
 PACKAGE_BUGREPORT='http://bugs.opensuse.org/'
 PACKAGE_URL=''
 
@@ -1229,7 +1229,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat _ACEOF
-\`configure' configures yast2-wagon 2.21.2 to adapt to many kinds of systems.
+\`configure' configures yast2-wagon 2.21.3 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1300,7 +1300,7 @@
 
 if test -n $ac_init_help; then
   case $ac_init_help in
- short | recursive ) echo Configuration of yast2-wagon 2.21.2:;;
+ short | recursive ) echo Configuration of yast2-wagon 2.21.3:;;
esac
   cat \_ACEOF
 
@@ -1380,7 +1380,7 @@
 test -n $ac_init_help  exit $ac_status
 if $ac_init_version; then
   cat \_ACEOF
-yast2-wagon configure 2.21.2
+yast2-wagon configure 2.21.3
 generated by GNU Autoconf 2.68
 
 Copyright (C) 2010 Free Software Foundation, Inc.
@@ -1397,7 +1397,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by yast2-wagon $as_me 2.21.2, which was
+It was created by yast2-wagon $as_me 2.21.3, which was
 generated by GNU Autoconf 2.68.  Invocation command line was
 
   $ $0 $@
@@ -2327,7 +2327,7 @@
 
 # Define the identity of the package.
  PACKAGE='yast2-wagon'
- VERSION='2.21.2'
+ VERSION='2.21.3'
 
 
 cat confdefs.h _ACEOF
@@ -2449,7 +2449,7 @@
 
 
 
-VERSION=2.21.2
+VERSION=2.21.3
 RPMNAME=yast2-wagon
 MAINTAINER=Ladislav Slezak lsle...@suse.cz
 
@@ -3386,7 +3386,7 @@
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log=
-This file was extended by yast2-wagon $as_me 2.21.2, which was
+This file was extended by yast2-wagon $as_me 2.21.3, which was
 generated by GNU Autoconf 2.68.  Invocation command line was
 
   CONFIG_FILES= $CONFIG_FILES
@@ -3439,7 +3439,7 @@
 cat $CONFIG_STATUS _ACEOF || ac_write_fail=1
 ac_cs_config=`$as_echo 

commit texworks for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package texworks for openSUSE:Factory
checked in at Tue Jul 19 14:49:42 CEST 2011.




--- texworks/texworks.changes   2011-05-27 10:53:10.0 +0200
+++ /mounts/work_src_done/STABLE/texworks/texworks.changes  2011-07-16 
20:12:35.0 +0200
@@ -1,0 +2,21 @@
+Sat Jul 16 18:08:58 UTC 2011 - badshah...@gmail.com
+
+- Update to version 0.4.3
+  + Fix bug in autocompletion that could cause data loss 
+
+---
+Wed Jun 29 09:15:21 UTC 2011 - badshah...@gmail.com
+
+- Update to version 0.4.2
+  + Work around layout issues with Qt 4.7.2 that caused TeXworks to
+crash sometimes
+  + Fix autocompletion at the beginning of a line
+  + Respect per-file setting None for syntax highlighting, smart
+quotes, and auto indent
+  + Update SyncTeX to version 1.16
+  + Allow to disable autocompletion by editing the configuration file
+  + Fix runtime warning about empty file watchers
+  + Enhance Mac patches for poppler
+  + Improve installation and packaging routines
+
+---

calling whatdependson for head-i586


Old:

  texworks-0.4.1.tar.bz2

New:

  texworks-0.4.3.tar.bz2



Other differences:
--
++ texworks.spec ++
--- /var/tmp/diff_new_pack.JJFNW6/_old  2011-07-19 14:49:03.0 +0200
+++ /var/tmp/diff_new_pack.JJFNW6/_new  2011-07-19 14:49:03.0 +0200
@@ -19,7 +19,7 @@
 
 
 Name:   texworks
-Version:0.4.1
+Version:0.4.3
 Release:1
 License:GPLv2+
 Summary:TeXshop-like TeX Editor
@@ -93,8 +93,7 @@
 
 #Python plugin 
 pushd plugins-src/TWPythonPlugin/
-sed -i 's:/usr/local/lib:%{_libdir}:' TWPythonPlugin.pro
-qmake -after \
+qmake 'INSTALL_PREFIX=%{_prefix}' 'TW_PLUGINPATH=%{_libdir}/%{name}' -after \
  'INCLUDEPATH -= /usr/include/python2.6/' \
  'INCLUDEPATH += %{_includedir}/python%{py_ver}/' \
  'LIBS -= -lpython2.6' \
@@ -103,17 +102,15 @@
 
 #Lua plugin
 pushd plugins-src/TWLuaPlugin/
-sed -i 's:/usr/local/lib:%{_libdir}:' TWLuaPlugin.pro
-qmake -after \
+qmake 'INSTALL_PREFIX=%{_prefix}' 'TW_PLUGINPATH=%{_libdir}/%{name}' -after \
 'PKGCONFIG -= lua5.1' \
 'PKGCONFIG += lua'
 popd
 
 #Main package
-qmake INSTALL_PREFIX=%{_prefix} DOCS_DIR=%{_docdir}/%{name} \
-   -after \
-  'QMAKE_CXXFLAGS -= -DTW_BUILD_ID=personal 
-DTW_HELPPATH=\\\/usr/local/share/texworks-help\\\ 
-DTW_PLUGINPATH=\\\/usr/local/lib/texworks\\\ 
-DTW_DICPATH=\\\/usr/share/myspell/dicts\\\' \
-  'QMAKE_CXXFLAGS += -DTW_BUILD_ID=openSUSE 
-DTW_HELPPATH=\\\%{_docdir}/%{name}/manual\\\ 
-DTW_PLUGINPATH=\\\%{_libdir}/%{name}\\\ 
-DTW_DICPATH=\\\%{_datadir}/myspell\\\'
+qmake 'TW_BUILD_ID=openSUSE' 'INSTALL_PREFIX=%{_prefix}' 
'TW_HELPPATH=%{_docdir}/%{name}/manual' 'DOCS_DIR=%{_docdir}/%{name}' -after \
+'QMAKE_CXXFLAGS -= -DTW_DICPATH=\\\/usr/share/myspell/dicts\\\' \
+'QMAKE_CXXFLAGS += -DTW_DICPATH=\\\%{_datadir}/myspell\\\'
 
 %install
 #Python plugin 

++ texworks-0.4.1.tar.bz2 - texworks-0.4.3.tar.bz2 ++
 4252 lines of diff (skipped)






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit bundle-lang-common for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package bundle-lang-common for 
openSUSE:Factory
checked in at Tue Jul 19 14:54:11 CEST 2011.




--- bundle-lang-common/bundle-lang-gnome-extras.changes 2011-07-12 
20:55:47.0 +0200
+++ 
/mounts/work_src_done/STABLE/bundle-lang-common/bundle-lang-gnome-extras.changes
2011-07-14 09:01:54.0 +0200
@@ -1,0 +2,5 @@
+Thu Jul 14 07:01:13 UTC 2011 - a...@suse.de
+
+- Update version to 12.1
+
+---
--- bundle-lang-common/bundle-lang-gnome.changes2011-07-12 
20:55:47.0 +0200
+++ /mounts/work_src_done/STABLE/bundle-lang-common/bundle-lang-gnome.changes   
2011-07-14 09:01:54.0 +0200
@@ -1,0 +2,5 @@
+Thu Jul 14 07:01:09 UTC 2011 - a...@suse.de
+
+- Update version to 12.1
+
+---
--- bundle-lang-common/bundle-lang-kde.changes  2011-07-12 20:55:48.0 
+0200
+++ /mounts/work_src_done/STABLE/bundle-lang-common/bundle-lang-kde.changes 
2011-07-14 09:01:45.0 +0200
@@ -1,0 +2,5 @@
+Thu Jul 14 07:01:20 UTC 2011 - a...@suse.de
+
+- Update version to 12.1
+
+---
--- bundle-lang-common/bundle-lang-other.changes2009-04-30 
13:14:45.0 +0200
+++ /mounts/work_src_done/STABLE/bundle-lang-common/bundle-lang-other.changes   
2011-07-14 09:01:56.0 +0200
@@ -1,0 +2,5 @@
+Thu Jul 14 07:01:03 UTC 2011 - a...@suse.de
+
+- Update version to 12.1
+
+---

calling whatdependson for head-i586




Other differences:
--
++ bundle-lang-common.spec ++
--- /var/tmp/diff_new_pack.vqYfez/_old  2011-07-19 14:53:17.0 +0200
+++ /var/tmp/diff_new_pack.vqYfez/_new  2011-07-19 14:53:17.0 +0200
@@ -61,8 +61,8 @@
 #!BuildIgnore:  NetworkManager-vpnc
 License:MIT License (or similar)
 Group:  System/Localization
-Version:11.4
-Release:27
+Version:12.1
+Release:1
 Summary:Translations for a Group of Programs
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch

++ bundle-lang-gnome-extras.spec ++
--- /var/tmp/diff_new_pack.vqYfez/_old  2011-07-19 14:53:17.0 +0200
+++ /var/tmp/diff_new_pack.vqYfez/_new  2011-07-19 14:53:17.0 +0200
@@ -168,8 +168,8 @@
 #!BuildIgnore:  NetworkManager-vpnc
 License:MIT License (or similar)
 Group:  System/Localization
-Version:11.4
-Release:13
+Version:12.1
+Release:1
 Summary:Translations for many GNOME programs
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch

bundle-lang-gnome.spec: same change
bundle-lang-kde.spec: same change
++ bundle-lang-other.spec ++
--- /var/tmp/diff_new_pack.vqYfez/_old  2011-07-19 14:53:17.0 +0200
+++ /var/tmp/diff_new_pack.vqYfez/_new  2011-07-19 14:53:17.0 +0200
@@ -22,7 +22,7 @@
 License:MIT License (or similar)
 Group:  System/GUI/KDE
 Version:11.2
-Release:57
+Release:58
 Summary:Translations for languages not covered by one of the 
bundle-lang-*-* packages
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch

++ bundle-lang.spec.in ++
--- /var/tmp/diff_new_pack.vqYfez/_old  2011-07-19 14:53:17.0 +0200
+++ /var/tmp/diff_new_pack.vqYfez/_new  2011-07-19 14:53:17.0 +0200
@@ -28,7 +28,7 @@
 #!BuildIgnore:  NetworkManager-vpnc
 License:license
 Group:  group
-Version:11.4
+Version:12.1
 Release:1
 Summary:summary
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-dulwich for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package python-dulwich for openSUSE:Factory
checked in at Tue Jul 19 15:01:43 CEST 2011.




--- python-dulwich/python-dulwich.changes   2011-03-31 16:46:04.0 
+0200
+++ python-dulwich/python-dulwich.changes   2011-07-03 12:27:51.0 
+0200
@@ -1,0 +2,7 @@
+Sun Jul  3 10:21:34 UTC 2011 - sasc...@gmx.de
+
+- Update to version 0.7.1:
+  * Documentation udated
+  * Tree.entries deprecated
+
+---

calling whatdependson for head-i586


Old:

  dulwich-0.7.0.tar.bz2

New:

  dulwich-0.7.1.tar.gz



Other differences:
--
++ python-dulwich.spec ++
--- /var/tmp/diff_new_pack.iTMKZU/_old  2011-07-19 14:59:44.0 +0200
+++ /var/tmp/diff_new_pack.iTMKZU/_new  2011-07-19 14:59:44.0 +0200
@@ -15,37 +15,33 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
 
-%{!?python_sitelib: %global python_sitelib %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
-%{!?python_sitearch: %global python_sitearch %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib(1))}
-
-%define mod_name dulwich
 
-Name:   python-%{mod_name}
-Version:0.7.0
+Name:   python-dulwich
+Version:0.7.1
 Release:1
 Url:http://samba.org/~jelmer/dulwich
 Summary:Pure-Python Git Library
-License:GPLv2 or later
+License:GPLv2+
 Group:  Development/Languages/Python
-Source: %{mod_name}-%{version}.tar.bz2
+Source: dulwich-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python-devel
 %if 0%{?suse_version}
 %py_requires
 %endif
+%{!?python_sitearch: %global python_sitearch %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib(1))}
 
 %description
 Simple Pure-Python implementation of the Git file formats and protocols. 
Dulwich
 is the place where Mr. and Mrs. Git live in one of the Monty Python sketches.
 
 %prep
-%setup -q -n %{mod_name}-%{version}
+%setup -q -n dulwich-%{version}
+rm docs/tutorial/.gitignore
 
 %build
-export CFLAGS=%{optflags}
-python setup.py build
+CFLAGS=%{optflags} python setup.py build
 
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
@@ -57,6 +53,6 @@
 %defattr(-,root,root,-)
 %doc AUTHORS COPYING HACKING NEWS README docs
 %{_bindir}/*
-%python_sitearch/%{mod_name}*
+%python_sitearch/*
 
 %changelog






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-simplejson for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package python-simplejson for 
openSUSE:Factory
checked in at Tue Jul 19 15:05:15 CEST 2011.




--- python-simplejson/python-simplejson.changes 2011-03-03 09:36:17.0 
+0100
+++ python-simplejson/python-simplejson.changes 2011-05-09 05:32:22.0 
+0200
@@ -1,0 +2,16 @@
+Mon May  9 03:20:42 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 2.1.6:
+  * Prevent segfaults with deeply nested JSON documents
+https://github.com/simplejson/simplejson/issues/11
+  * Fix compatibility with Python 2.5
+https://github.com/simplejson/simplejson/issues/5
+  - Aditional changes from 2.1.5 released 2011-04-17:
+* Built sdist tarball with setuptools_git installed. Argh.
+  - Aditional changes from 2.1.4 released 2011-04-17:
+* Does not try to build the extension when using PyPy
+* Trailing whitespace after commas no longer emitted when indent is used
+* Migrated to github http://github.com/simplejson/simplejson
+- Regenerate spec file with py2pack.
+
+---

calling whatdependson for head-i586


Old:

  simplejson-2.1.3.tar.bz2

New:

  simplejson-2.1.6.tar.bz2



Other differences:
--
++ python-simplejson.spec ++
--- /var/tmp/diff_new_pack.awW3yS/_old  2011-07-19 15:01:51.0 +0200
+++ /var/tmp/diff_new_pack.awW3yS/_new  2011-07-19 15:01:51.0 +0200
@@ -16,44 +16,34 @@
 #
 
 
-Summary:Simple, fast, extensible JSON encoder/decoder for Python
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
+%{!?python_sitearch: %global python_sitearch %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib(1))}
+
+%define mod_name simplejson
 
-Name:   python-simplejson
-Version:2.1.3
+Name:   python-%{mod_name}
+Version:2.1.6
 Release:1
-License:BSD
-Url:http://undefined.org/python/#simplejson
-Group:  Development/Libraries/Python
-Source: simplejson-%{version}.tar.bz2
-BuildRequires:  fdupes
-BuildRequires:  python
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
+Url:http://github.com/simplejson/simplejson
+Summary:Simple, fast, extensible JSON encoder/decoder for Python
+License:MIT License
+Group:  Development/Languages/Python
+Source: %{mod_name}-%{version}.tar.bz2
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%{py_requires}
+BuildRequires:  python-devel
+BuildRequires:  python-distribute
+%if 0%{?suse_version}
+%py_requires
+%endif
 
 %description
-simplejson is a simple, fast, complete, correct and extensible JSON
-http://json.org encoder and decoder for Python 2.3+. It is pure Python code
-with no dependencies, but includes an optional C extension for a serious speed
-boost.
-
-%package doc
-License:BSD
-Summary:Documentation for simplejson
-Group:  Development/Libraries/Python
-Requires:   %name = %version
-
-%description doc
-simplejson is a simple, fast, complete, correct and extensible JSON
-http://json.org encoder and decoder for Python 2.3+. It is pure Python code
-with no dependencies, but includes an optional C extension for a serious speed
-boost.
-
-This package contains documentation for simplejson.
+simplejson is a simple, fast, complete, correct and extensible
+JSON encoder and decoder for Python 2.5+. It is pure Python code
+with no dependencies, but includes an optional C extension for a
+serious speed boost.
 
 %prep
-%setup -q -n simplejson-%{version}
+%setup -q -n %{mod_name}-%{version}
 
 %build
 export CFLAGS=%{optflags}
@@ -61,18 +51,12 @@
 
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
-%fdupes %{buildroot}
 
 %clean
-%{__rm} -rf %{buildroot}
+rm -rf %{buildroot}
 
 %files
-%defattr(-, root, root, 0755)
-%doc LICENSE.txt CHANGES.txt
-%{py_sitedir}*
-
-%files doc
-%defattr(0644, root, root, 0755)
-%doc docs index.rst
+%defattr(-,root,root)
+%{python_sitearch}/*
 
 %changelog

++ simplejson-2.1.3.tar.bz2 - simplejson-2.1.6.tar.bz2 ++
 5025 lines of diff (skipped)






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python3-cairo for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package python3-cairo for openSUSE:Factory
checked in at Tue Jul 19 15:07:37 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ /mounts/work_src_done/STABLE/python3-cairo/python3-cairo.changes
2011-06-17 12:00:10.0 +0200
@@ -0,0 +1,11 @@
+---
+Fri Jun 17 11:59:46 CEST 2011 - vu...@opensuse.org
+
+- Change python3-base Requires to python3, since python3-base is
+  not in Factory yet.
+
+---
+Fri Jun 17 07:37:49 CEST 2011 - vu...@opensuse.org
+
+- Initial package (version 1.10.0).
+

calling whatdependson for head-i586


New:

  pycairo-1.10.0.tar.bz2
  python3-cairo.changes
  python3-cairo.spec



Other differences:
--
++ python3-cairo.spec ++
#
# spec file for package python3-cairo
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


# We manually define those because we don't have any python3 macros yet
%define local_python3_abi3.1
%define local_python3_requires   Requires: python3
%define local_python3_sitelib
%{_libdir}/python%{local_python3_abi}/site-packages

Name:   python3-cairo
%define _name   pycairo
Version:1.10.0
Release:1
Summary:Python Bindings for Cairo
License:LGPLv3
Group:  Development/Libraries/Python
# FIXME: on update, check if we finally have python3 macros to replace our 
local ones
# FIXME: on update, check if we still need to manually remove the byte-code in 
%%install
Url:http://www.cairographics.org/
Source: %{_name}-%{version}.tar.bz2
BuildRequires:  cairo-devel
BuildRequires:  python3-devel
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
%local_python3_requires

%description
Python bindings for cairo.

%package devel
License:LGPLv3
Summary:Headers for python-cairo
Group:  Development/Libraries/Python
Requires:   %name = %{version}
Requires:   cairo-devel python3-devel

%description devel
Headers for python-cairo

%prep
%setup -n %{_name}-%{version}

%build
PYTHON=python3 python3 ./waf configure --prefix=%{_prefix} --libdir=%{_libdir}
python3 ./waf build

%install
python3 ./waf install --destdir=%{buildroot}
# waf is broken and generated byte-code that references the build root, see 
http://code.google.com/p/waf/issues/detail?id=986
rm %{buildroot}%{local_python3_sitelib}/cairo/*.py[co]

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root)
%doc AUTHORS COPYING.LESSER INSTALL NEWS README
%{local_python3_sitelib}/cairo/

%files devel
%defattr(-,root,root)
%{_includedir}/pycairo/
%{_libdir}/pkgconfig/py3cairo.pc

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-tornado for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package python-tornado for openSUSE:Factory
checked in at Tue Jul 19 15:12:44 CEST 2011.




--- python-tornado/python-tornado.changes   2011-03-04 05:13:22.0 
+0100
+++ python-tornado/python-tornado.changes   2011-06-22 14:04:20.0 
+0200
@@ -1,0 +2,13 @@
+Wed Jun 22 11:47:26 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 2.0:
+  Major changes:
+  * Template output is automatically escaped by default; see backwards
+compatibility note below.
+* The default AsyncHTTPClient implementation is now simple_httpclient.
+* Python 3.2 is now supported.
+  For backwards compatibility and other changes in this release,
+  please read http://www.tornadoweb.org/documentation/releases/v2.0.0.html
+- Regenerate spec file with py2pack.
+
+---

calling whatdependson for head-i586


Old:

  tornado-1.2.1.tar.bz2

New:

  tornado-2.0.tar.bz2



Other differences:
--
++ python-tornado.spec ++
--- /var/tmp/diff_new_pack.DwXeUJ/_old  2011-07-19 15:05:34.0 +0200
+++ /var/tmp/diff_new_pack.DwXeUJ/_new  2011-07-19 15:05:34.0 +0200
@@ -16,24 +16,27 @@
 #
 
 
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
+%{!?python_sitearch: %global python_sitearch %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib(1))}
 
 Name:   python-tornado
-Version:1.2.1
+Version:2.0
 Release:1
-License:Apache 2.0
-Summary:Open source version of scalable, non-blocking web server that 
power FriendFeed
 Url:http://www.tornadoweb.org
-Group:  Development/Libraries/Python
+Summary:Open source version of scalable, non-blocking web server that 
power FriendFeed
+License:http://www.apache.org/licenses/LICENSE-2.0
+Group:  Development/Languages/Python
 Source: tornado-%{version}.tar.bz2
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python-devel
-BuildRequires:  python-setuptools
 Requires:   python-curl
 Requires:   python-simplejson
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%{py_requires}
-%if %{?suse_version: %{suse_version}  1110} %{!?suse_version:1}
+%if 0%{?suse_version}
+%py_requires
+%if 0%{?suse_version}  1110
 BuildArch:  noarch
 %endif
+%endif
 
 %description
 Tornado is an open source version of the scalable, non-blocking web server and 
tools that power FriendFeed.
@@ -47,19 +50,21 @@
 maintains an open connection to the FriendFeed servers. (For more information 
on scaling servers to support
 thousands of clients, see The C10K problem.)
 
-Author:
-
-Facebook
-
 %prep
 %setup -q -n tornado-%{version}
 
 %build
-%{__python} setup.py build
+export CFLAGS=%{optflags}
+python setup.py build
 
 %install
-%{__python} setup.py install --prefix=%{_prefix} --root=%{buildroot} 
--record-rpm=INSTALLED_FILES
+python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+
+%clean
+rm -rf %{buildroot}
+
+%files
+%defattr(-,root,root,-)
+%{python_sitelib}/*
 
-%files -f INSTALLED_FILES
-%defattr(-,root,root)
 %changelog

++ tornado-1.2.1.tar.bz2 - tornado-2.0.tar.bz2 ++
 8084 lines of diff (skipped)






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit perl-namespace-autoclean for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-namespace-autoclean for 
openSUSE:Factory
checked in at Tue Jul 19 15:14:34 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/mounts/work_src_done/STABLE/perl-namespace-autoclean/perl-namespace-autoclean.changes
  2011-04-03 17:27:59.0 +0200
@@ -0,0 +1,24 @@
+---
+Sun Apr  3 15:27:17 UTC 2011 - co...@novell.com
+
+- updated to 0.12
+  * Bump namespace::clean dep to 0.20 to pull in the bugfix for
+Package::Stash::XS 0.19
+
+---
+Sat Jan 22 20:42:57 UTC 2011 - co...@novell.com
+
+- update to 0.11
+  * Improve distribution metadata.
+  * Fix documentation typo ( Andrew Rodland).
+
+---
+Wed Dec  1 13:34:01 UTC 2010 - co...@novell.com
+
+- switch to perl_requires macro
+
+---
+Wed Oct 13 09:24:35 UTC 2010 - co...@novell.com
+
+- fix test suite
+

calling whatdependson for head-i586


New:

  namespace-autoclean-0.12.tar.gz
  perl-namespace-autoclean.changes
  perl-namespace-autoclean.spec



Other differences:
--
++ perl-namespace-autoclean.spec ++
#
# spec file for package perl-namespace-autoclean
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:   perl-namespace-autoclean
Version:0.12
Release:1
License:GPL+ or Artistic
%define cpan_name namespace-autoclean
Summary:Keep imports out of your namespace
Url:http://search.cpan.org/dist/namespace-autoclean/
Group:  Development/Libraries/Perl
#Source: 
http://www.cpan.org/authors/id/B/BO/BOBTFISH/namespace-autoclean-%{version}.tar.gz
Source: %{cpan_name}-%{version}.tar.gz
BuildArch:  noarch
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(B::Hooks::EndOfScope)
BuildRequires:  perl(Class::MOP) = 0.80
BuildRequires:  perl(List::Util)
BuildRequires:  perl(Moose::Role)
BuildRequires:  perl(namespace::clean) = 0.20
BuildRequires:  perl(Sub::Name)
Requires:   perl(B::Hooks::EndOfScope)
Requires:   perl(Class::MOP) = 0.80
Requires:   perl(List::Util)
Requires:   perl(namespace::clean) = 0.20
%{perl_requires}

%description
When you import a function into a Perl package, it will naturally also be
available as a method.

The 'namespace::autoclean' pragma will remove all imported symbols at the
end of the current package's compile cycle. Functions called in the package
itself will still be bound by their name, but they won't show up as methods
on your class or instances.

This module is very similar to namespace::clean, except it will clean all
imported functions, no matter if you imported them before or after you
'use'd the pragma. It will also not touch anything that looks like a
method, according to 'Class::MOP::Class::get_method_list'.

If you're writing an exporter and you want to clean up after yourself (and
your peers), you can use the '-cleanee' switch to specify what package to
clean:

  package My::MooseX::namespace::autoclean;
  use strict;

  use namespace::autoclean (); # no cleanup, just load

  sub import {
  namespace::autoclean-import(
-cleanee = scalar(caller),
  );
  }

%prep
%setup -q -n %{cpan_name}-%{version}

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf %{buildroot}

%files -f %{name}.files
%defattr(644,root,root,755)
%doc Changes LICENSE README

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-virtkey for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package python-virtkey for openSUSE:Factory
checked in at Tue Jul 19 15:14:49 CEST 2011.




--- GNOME/python-virtkey/python-virtkey.changes 2010-12-20 10:03:53.0 
+0100
+++ python-virtkey/python-virtkey.changes   2011-07-02 19:57:16.0 
+0200
@@ -1,0 +2,21 @@
+Sat Jul  2 19:46:16 CEST 2011 - vu...@opensuse.org
+
+- Update to version 0.60.0:
+  + Add methods to get the active layout symbols and group
+(lp#65626)
+  + Add python error exit in getKbd (lp#526791)
+  + Fix potential X resource leaks
+  + Add test code to simulate missing X keyboard
+  + Some code cleanup
+  + Reorganize source directory and add AUTHORS, NEWS and README files
+  + Add MANIFEST.in file
+  + Use pkg-config to find paths instead of hardcoded paths
+  + Update license to LGPL 3
+  + Use 'python-virtkey' name also for source package
+  + Change version format to major.minor.micro
+  + Add some API documentation
+- Change License tag from GPLv2+ to LGPLv3+.
+- Drop python-virtkey-use-pkg-config.patch: fixed upstream.
+- Update description
+
+---

calling whatdependson for head-i586


Old:

  python-virtkey-0.50.tar.bz2
  python-virtkey-use-pkg-config.patch

New:

  python-virtkey-0.60.0.tar.gz



Other differences:
--
++ python-virtkey.spec ++
--- /var/tmp/diff_new_pack.sNaZWt/_old  2011-07-19 15:12:53.0 +0200
+++ /var/tmp/diff_new_pack.sNaZWt/_new  2011-07-19 15:12:53.0 +0200
@@ -1,7 +1,7 @@
 #
-# spec file for package python-virtkey (Version 0.50)
+# spec file for package python-virtkey
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,15 +23,13 @@
 %define mod_name virtkey
 
 Name:   python-%{mod_name}
-Version:0.50
-Release:2
+Version:0.60.0
+Release:1
 Url:https://launchpad.net/virtkey  
 Summary:Python extension to emulate keypresses
-License:GPLv2+
+License:LGPLv3+
 Group:  Development/Languages/Python
-Source: python-%{mod_name}-%{version}.tar.bz2
-# PATCH-FIX-UPSTREAM python-virtkey-use-pkg-config.patch vu...@opensuse.org -- 
Fix build by using pkg-config to get compilation flags, sent by mail upstream 
(no bug tracker)
-Patch0: python-virtkey-use-pkg-config.patch
+Source: python-%{mod_name}-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python-devel
 BuildRequires:  glib2-devel
@@ -41,16 +39,12 @@
 %endif
 
 %description
-Python extension for emulating keypresses and getting current keyboard layout.
-
-Authors:
-
-Chris Jones  cej...@soton.ac.uk
+python-virtkey is a python extension for emulating keypresses and
+getting the keyboard geometry from the xserver.
 
 %prep
 export CFLAGS=%{optflags}
-%setup -c
-%patch0 -p1
+%setup -q
 
 %build
 python setup.py build
@@ -63,6 +57,7 @@
 
 %files %{?suse_version: -f INSTALLED_FILES}
 %defattr(-,root,root,-)
+%doc AUTHORS COPYING.LESSER NEWS README
 %if 0%{!?suse_version:1}
 %python_sitelib/%{mod_name}*
 %endif






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit perl-Digest-JHash for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-Digest-JHash for 
openSUSE:Factory
checked in at Tue Jul 19 15:29:25 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ /mounts/work_src_done/STABLE/perl-Digest-JHash/perl-Digest-JHash.changes
2011-07-14 10:07:05.0 +0200
@@ -0,0 +1,11 @@
+---
+Thu Jul 14 08:05:44 UTC 2011 - co...@novell.com
+
+- use original tarball
+
+---
+Fri Jan 14 11:36:04 UTC 2011 - co...@novell.com
+
+- initial package 0.07
+  * created by cpanspec 1.78.03
+

calling whatdependson for head-i586


New:

  Digest-JHash-0.07.tar.gz
  perl-Digest-JHash.changes
  perl-Digest-JHash.spec



Other differences:
--
++ perl-Digest-JHash.spec ++
#
# spec file for package perl-Digest-JHash
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:   perl-Digest-JHash
Version:0.07
Release:1
License:Artistic 2.0
%define cpan_name Digest-JHash
Summary:Perl extension for 32 bit Jenkins Hashing Algorithm
Url:http://search.cpan.org/dist/Digest-JHash/
Group:  Development/Libraries/Perl
Source: 
http://www.cpan.org/authors/id/S/SH/SHLOMIF/%{cpan_name}-%{version}.tar.gz
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
%{perl_requires}

%description
The 'Digest::JHash' module allows you to use the fast JHash hashing
algorithm developed by Bob Jenkins from within Perl programs. The algorithm
takes as input a message of arbitrary length and produces as output a
32-bit message digest of the input in the form of an unsigned long
integer.

Call it a low calorie version of MD5 if you like.

See http://burtleburtle.net/bob/hash/doobs.html for more information.

%prep
%setup -q -n %{cpan_name}-%{version}
find . -type f -print0 | xargs -0 chmod 644

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE=%{optflags}
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf %{buildroot}

%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes examples README

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit perl-Exporter-Lite for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-Exporter-Lite for 
openSUSE:Factory
checked in at Tue Jul 19 15:31:23 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ /mounts/work_src_done/STABLE/perl-Exporter-Lite/perl-Exporter-Lite.changes  
2011-07-14 10:11:15.0 +0200
@@ -0,0 +1,49 @@
+---
+Thu Jul 14 08:06:02 UTC 2011 - co...@novell.com
+
+- updated to 0.02
+
+---
+Tue Nov 30 19:20:13 UTC 2010 - co...@novell.com
+
+- switch to perl_requires macro
+
+---
+Mon Nov 29 18:29:53 UTC 2010 - co...@novell.com
+
+- remove /var/adm/perl-modules
+
+---
+Mon Nov 29 18:00:18 UTC 2010 - co...@novell.com
+
+- called spec2changelog
+
+---
+Tue Jun 20 00:00:00 UTC 2006 - jf...@funktronics.ca
+
+- Build under build service
+
+
+---
+Fri Nov 11 00:00:00 UTC 2005 - jf...@funktronics.ca
+
+- Build for SL10
+
+
+---
+Thu May 12 00:00:00 UTC 2005 - jf...@funktronics.ca
+
+- Build for SL93
+
+
+---
+Fri Nov 19 00:00:00 UTC 2004 - jf...@funktronics.ca
+
+- Build for SL92
+
+
+---
+Tue May 11 00:00:00 UTC 2004 - jf...@funktronics.ca
+
+- Initial release
+

calling whatdependson for head-i586


New:

  Exporter-Lite-0.02.tar.gz
  perl-Exporter-Lite.changes
  perl-Exporter-Lite.spec



Other differences:
--
++ perl-Exporter-Lite.spec ++
#
# spec file for package perl-Exporter-Lite
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:   perl-Exporter-Lite
Version:0.02
Release:1
License:GPL+ or Artistic
%define cpan_name Exporter-Lite
Summary:Lightweight exporting of variables
Url:http://search.cpan.org/dist/Exporter-Lite/
Group:  Development/Libraries/Perl
Source: 
http://www.cpan.org/authors/id/M/MS/MSCHWERN/%{cpan_name}-%{version}.tar.gz
BuildArch:  noarch
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
%{perl_requires}

%description
This is an alternative to Exporter intended to provide a lightweight subset
of its functionality. It supports 'import()', '@EXPORT' and '@EXPORT_OK'
and not a whole lot else.

Unlike Exporter, it is not necessary to inherit from Exporter::Lite (ie. no
'@ISA = qw(Exporter::Lite)' mantra). Exporter::Lite simply exports its
import() function. This might be called a mix-in.

Setting up a module to export its variables and functions is simple:

package My::Module;
use Exporter::Lite;

@EXPORT = qw($Foo bar);

now when you 'use My::Module', '$Foo' and 'bar()' will show up.

In order to make exporting optional, use @EXPORT_OK.

package My::Module;
use Exporter::Lite;

@EXPORT_OK = qw($Foo bar);

when My::Module is used, '$Foo' and 'bar()' will _not_ show up. You have to
ask for them. 'use My::Module qw($Foo bar)'.

%prep
%setup -q -n %{cpan_name}-%{version}

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf %{buildroot}

%files -f %{name}.files
%defattr(-,root,root,755)

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit perl-File-ShareDir for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-File-ShareDir for 
openSUSE:Factory
checked in at Tue Jul 19 15:32:31 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ /mounts/work_src_done/STABLE/perl-File-ShareDir/perl-File-ShareDir.changes  
2010-11-30 20:25:50.0 +0100
@@ -0,0 +1,28 @@
+---
+Tue Nov 30 19:20:15 UTC 2010 - co...@novell.com
+
+- switch to perl_requires macro
+
+---
+Mon Nov 29 18:29:59 UTC 2010 - co...@novell.com
+
+- remove /var/adm/perl-modules
+
+---
+Sun Nov 28 11:37:49 UTC 2010 - co...@novell.com
+
+- remove .packlist file
+
+---
+Sun Mar 21 18:23:30 UTC 2010 - l...@linux-schulserver.de
+
+- update to 1.02:
+  + Upgraded to Module::Install 0.95
+  + Removed Params::Util dep
+- removed dependency to perl-Params-Util package
+
+---
+Sat Dec 26 17:47:19 UTC 2009 - l...@linux-schulserver.de
+
+- initial version 1.01
+

calling whatdependson for head-i586


New:

  File-ShareDir-1.02.tar.bz2
  perl-File-ShareDir.changes
  perl-File-ShareDir.spec



Other differences:
--
++ perl-File-ShareDir.spec ++
#
# spec file for package perl-File-ShareDir
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:   perl-File-ShareDir
%definereal_name %( echo %{name} | %{__sed} -e 's,perl-,,' )
Summary:Locate per-dist and per-module shared files
Url:http://search.cpan.org/perldoc?File::ShareDir
Group:  Development/Libraries/Perl
License:Artistic License
Version:1.02
Release:1
Source: %{real_name}-%{version}.tar.bz2
BuildRequires:  perl-macros
BuildRequires:  perl-Class-Inspector
Requires:   perl-Class-Inspector
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
%{perl_requires}

%description
The intent of File::ShareDir is to provide a companion to Class::Inspector and
File::HomeDir, modules that take a process that is well-known by advanced Perl
developers but gets a little tricky, and make it more available to the larger
Perl community.

Quite often you want or need your Perl module (CPAN or otherwise) to have
access to a large amount of read-only data that is stored on the file-system at
run-time.

On a linux-like system, this would be in a place such as /usr/share, however
Perl runs on a wide variety of different systems, and so the use of any one
location is unreliable.

Perl provides a little-known method for doing this, but almost nobody is aware
that it exists. As a result, module authors often go through some very strange
ways to make the data available to their code.

The most common of these is to dump the data out to an enormous Perl data
structure and save it into the module itself. The result are enormous
multi-megabyte .pm files that chew up a lot of memory needlessly.

Author:
---
Adam Kennedy ad...@cpan.org


%prep
%setup -n %{real_name}-%{version}

%build
perl Makefile.PL 
make %{?jobs:-j%jobs}

%check
make test

%install
%perl_make_install
%perl_process_packlist

%clean
rm -rf %{buildroot}

%files
%defattr(0644, root, root, 0755)
%doc Changes README MANIFEST
%dir %perl_vendorlib/File
%dir %perl_vendorlib/auto/share
%dir %perl_vendorlib/auto/share/dist
%dir %perl_vendorlib/auto/share/dist/File-ShareDir
%dir %perl_vendorlib/auto/share/dist/File-ShareDir/subdir
%dir %perl_vendorlib/auto/share/module
%dir %perl_vendorlib/auto/share/module/File-ShareDir
%dir %perl_vendorarch/auto/File
%dir %perl_vendorarch/auto/File/ShareDir
%perl_vendorlib/File/ShareDir.pm
%perl_vendorlib/auto/share/dist/File-ShareDir/sample.txt
%perl_vendorlib/auto/share/dist/File-ShareDir/subdir/sample.txt
%perl_vendorlib/auto/share/module/File-ShareDir/test_file.txt
%{_mandir}/man3/File::ShareDir*

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional 

commit perl-Gtk2-ImageView for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-Gtk2-ImageView for 
openSUSE:Factory
checked in at Tue Jul 19 15:40:04 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/mounts/work_src_done/STABLE/perl-Gtk2-ImageView/perl-Gtk2-ImageView.changes
2010-12-01 14:46:01.0 +0100
@@ -0,0 +1,7 @@
+---
+Wed Dec  1 13:32:43 UTC 2010 - co...@novell.com
+
+- switch to perl_requires macro
+
+* Fri Jan 23 2009 tuukka.pasa...@ilmi.fi
+- packaged perl-Gtk2-ImageView version 0.04 using the buildservice spec file 
wizard
\ No newline at end of file

calling whatdependson for head-i586


New:

  Gtk2-ImageView-0.05.tar.gz
  perl-Gtk2-ImageView.changes
  perl-Gtk2-ImageView.spec



Other differences:
--
++ perl-Gtk2-ImageView.spec ++
#
# spec file for package perl-Gtk2-ImageView
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:   perl-Gtk2-ImageView
# List of additional build dependencies
BuildRequires:  libgtkimageview-devel perl-Gtk2
BuildRequires:  perl-macros
Requires:   perl-Gtk2, libgtkimageview0
Version:0.05
Release:1
License:Artistic license
Source: Gtk2-ImageView-%{version}.tar.gz
Group:  Development/Libraries/Perl
Summary:Perl bindings to the GtkImageView image viewer widget
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
%{perl_requires}

%description
Perl bindings to the GtkImageView image viewer widget. Needs perl-GTK2


%prep
%setup -q -n Gtk2-ImageView-%version

%build

perl Makefile.PL
make

%install

make DESTDIR=%buildroot install_vendor
%perl_process_packlist

# Write a proper %%files section and remove these two commands and
# the '-f filelist' option to %%files
echo '%%defattr(-,root,root)' filelist
find %buildroot -type f -printf '/%%P*\n' filelist

%clean
rm -rf %buildroot

%files -f filelist
%defattr(-,root,root)
%dir %{perl_vendorarch}/Gtk2/Gdk/Pixbuf
%dir %{perl_vendorarch}/Gtk2/Gdk/Pixbuf/Draw
%dir %{perl_vendorarch}/Gtk2/ImageView
%dir %{perl_vendorarch}/Gtk2/ImageView/Tool
%dir %{perl_vendorarch}/auto/Gtk2/ImageView
%dir %{perl_vendorarch}/Gtk2/ImageView/Install

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit perl-Hash-Util-FieldHash-Compat for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-Hash-Util-FieldHash-Compat for 
openSUSE:Factory
checked in at Tue Jul 19 15:49:51 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/mounts/work_src_done/STABLE/perl-Hash-Util-FieldHash-Compat/perl-Hash-Util-FieldHash-Compat.changes
2011-07-14 11:29:44.0 +0200
@@ -0,0 +1,15 @@
+---
+Thu Jul 14 08:54:30 UTC 2011 - co...@novell.com
+
+- regenerate with cpanspec
+
+---
+Wed Dec  1 06:55:38 UTC 2010 - co...@novell.com
+
+- switch to perl_requires macro
+
+---
+Sat Apr 10 09:58:32 UTC 2010 - l...@linux-schulserver.de
+
+- initial version 0.03
+

calling whatdependson for head-i586


New:

  Hash-Util-FieldHash-Compat-0.03.tar.gz
  perl-Hash-Util-FieldHash-Compat.changes
  perl-Hash-Util-FieldHash-Compat.spec



Other differences:
--
++ perl-Hash-Util-FieldHash-Compat.spec ++
#
# spec file for package perl-Hash-Util-FieldHash-Compat
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:   perl-Hash-Util-FieldHash-Compat
Version:0.03
Release:1
License:GPL+ or Artistic
%define cpan_name Hash-Util-FieldHash-Compat
Summary:Use LHash::Util::FieldHash or ties, depending
Url:http://search.cpan.org/dist/Hash-Util-FieldHash-Compat/
Group:  Development/Libraries/Perl
Source: 
http://www.cpan.org/authors/id/N/NU/NUFFIN/%{cpan_name}-%{version}.tar.gz
BuildArch:  noarch
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Test::use::ok)
Requires:   perl(Test::use::ok)
%{perl_requires}

%description
Under older perls this module provides a drop in compatible api to the
Hash::Util::FieldHash manpage using the perltie manpage. When the
Hash::Util::FieldHash manpage is available it will use that instead.

This way code requiring field hashes can benefit from fast, robust field
hashes on Perl 5.10 and newer, but still run on older perls that don't ship
with that module.

See the Hash::Util::FieldHash manpage for all the details of the API.

%prep
%setup -q -n %{cpan_name}-%{version}

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf %{buildroot}

%files -f %{name}.files
%defattr(-,root,root,755)

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit perl-LockFile-Simple for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-LockFile-Simple for 
openSUSE:Factory
checked in at Tue Jul 19 15:54:50 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/mounts/work_src_done/STABLE/perl-LockFile-Simple/perl-LockFile-Simple.changes  
2011-07-14 09:19:30.0 +0200
@@ -0,0 +1,30 @@
+---
+Thu Jul 14 07:13:31 UTC 2011 - co...@novell.com
+
+- regenerate with cpanspec
+
+---
+Wed Dec  1 13:33:19 UTC 2010 - co...@novell.com
+
+- switch to perl_requires macro
+
+---
+Mon Nov 29 18:30:24 UTC 2010 - co...@novell.com
+
+- remove /var/adm/perl-modules
+
+---
+Sun Nov 28 11:37:52 UTC 2010 - co...@novell.com
+
+- remove .packlist file
+
+---
+Tue Oct 19 08:38:44 UTC 2010 - co...@novell.com
+
+- add perl as explicit buildrequire
+
+---
+Thu Mar 26 10:09:20 CET 2009 - l...@linux-schulserver.de
+
+- initial version 0.207
+

calling whatdependson for head-i586


New:

  LockFile-Simple-0.207.tar.gz
  perl-LockFile-Simple.changes
  perl-LockFile-Simple.spec



Other differences:
--
++ perl-LockFile-Simple.spec ++
#
# spec file for package perl-LockFile-Simple
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:   perl-LockFile-Simple
Version:0.207
Release:1
# MANUAL
License:GPL2+ or Artistic
%define cpan_name LockFile-Simple
Summary:simple file locking scheme
Url:http://search.cpan.org/dist/LockFile-Simple/
Group:  Development/Libraries/Perl
Source: 
http://www.cpan.org/authors/id/J/JV/JV/%{cpan_name}-%{version}.tar.gz
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
%{perl_requires}

%description
This simple locking scheme is not based on any file locking system calls
such as 'flock()' or 'lockf()' but rather relies on basic file system
primitives and properties, such as the atomicity of the 'write()' system
call. It is not meant to be exempt from all race conditions, especially
over NFS. The algorithm used is described below in the *ALGORITHM* section.

It is possible to customize the locking operations to attempt locking once
every 5 seconds for 30 times, or delete stale locks (files that are deemed
too ancient) before attempting the locking.

%prep
%setup -q -n %{cpan_name}-%{version}

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE=%{optflags}
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf %{buildroot}

%files -f %{name}.files
%defattr(-,root,root,755)
%doc ChangeLog README

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit perl-Module-ScanDeps for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-Module-ScanDeps for 
openSUSE:Factory
checked in at Tue Jul 19 16:05:54 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/mounts/work_src_done/STABLE/perl-Module-ScanDeps/perl-Module-ScanDeps.changes  
2011-05-01 12:54:23.0 +0200
@@ -0,0 +1,37 @@
+---
+Sun May  1 10:53:30 UTC 2011 - co...@opensuse.org
+
+- updated to 1.02
+  * %Preload: add _all_ *.pl file below .../unicore for utf8.pm
+  
+  * %Preload: add unicore/version for Unicode/UCD.pm 
+(because it contains a call openunicode(..., version))
+
+---
+Sat Feb 19 23:19:20 UTC 2011 - pascal.ble...@opensuse.org
+
+- update to 1.00:
+  * RT#65855: Special handling for POSIX requested
+  * RT#65252: Temp files left when execute fails
+  * add a %Preload rule for Log::Report::Dispatcher
+  * add %Preload rule for Date::Manip
+  * speed up scanning *significantly* by not re-constructing regexen for every
+line of input and reducing the no. of sub calls
+  * RT#61027: use lib does not work
+  * fix URI special case
+
+---
+Wed Dec  1 06:55:40 UTC 2010 - co...@novell.com
+
+- switch to perl_requires macro
+
+---
+Mon Nov 29 18:30:34 UTC 2010 - co...@novell.com
+
+- remove /var/adm/perl-modules
+
+---
+Wed Sep  1 04:56:13 UTC 2010 - pascal.ble...@opensuse.org
+
+- initial package (0.98)
+

calling whatdependson for head-i586


New:

  Module-ScanDeps-1.02.tar.gz
  perl-Module-ScanDeps.changes
  perl-Module-ScanDeps.spec



Other differences:
--
++ perl-Module-ScanDeps.spec ++
#
# spec file for package perl-Module-ScanDeps
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:   perl-Module-ScanDeps
Version:1.02
Release:1
License:GPL+ or Artistic
%define cpan_name Module-ScanDeps
Summary:Recursively scan Perl code for dependencies
Url:http://search.cpan.org/dist/Module-ScanDeps/
Group:  Development/Libraries/Perl
Source: 
http://www.cpan.org/authors/id/R/RS/RSCHUPP/%{cpan_name}-%{version}.tar.gz
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Module::Build::ModuleInfo)
BuildRequires:  perl(version)
Requires:   perl(Module::Build::ModuleInfo)
Requires:   perl(version)
%{perl_requires}

%description
This module scans potential modules used by perl programs, and returns a
hash reference; its keys are the module names as appears in '%INC' (e.g.
'Test/More.pm'); the values are hash references with this structure:

{
file= '/usr/local/lib/perl5/5.8.0/Test/More.pm',
key = 'Test/More.pm',
type= 'module',# or 'autoload', 'data', 'shared'
used_by = [ 'Test/Simple.pm', ... ],
uses= [ 'Test/Other.pm', ... ],
}

One function, 'scan_deps', is exported by default. Other functions such as
('scan_line', 'scan_chunk', 'add_deps', 'path_to_inc_name') are exported
upon request.

Users of *App::Packer* may also use this module as the dependency-checking
frontend, by tweaking their _p2e.pl_ like below:

use Module::ScanDeps;
...
my $packer = App::Packer-new( frontend = 'Module::ScanDeps' );
...

Please see the App::Packer::Frontend manpage for detailed explanation on
the structure returned by 'get_files'.

%prep
%setup -q -n %{cpan_name}-%{version}

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE=%{optflags}
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf %{buildroot}

%files -f %{name}.files
%defattr(-,root,root,755)
%doc AUTHORS Changes README

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: 

commit perl-MooseX-MultiInitArg for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-MooseX-MultiInitArg for 
openSUSE:Factory
checked in at Tue Jul 19 16:06:41 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/mounts/work_src_done/STABLE/perl-MooseX-MultiInitArg/perl-MooseX-MultiInitArg.changes
  2011-07-14 13:21:01.0 +0200
@@ -0,0 +1,20 @@
+---
+Thu Jul 14 11:13:43 UTC 2011 - co...@novell.com
+
+- regnerate with cpanspec
+
+---
+Wed Dec  1 13:33:50 UTC 2010 - co...@novell.com
+
+- switch to perl_requires macro
+
+---
+Mon Nov 29 18:30:37 UTC 2010 - co...@novell.com
+
+- remove /var/adm/perl-modules
+
+---
+Thu Aug 26 22:55:14 UTC 2010 - pascal.ble...@opensuse.org
+
+- initial package (0.01)
+

calling whatdependson for head-i586


New:

  MooseX-MultiInitArg-0.01.tar.gz
  perl-MooseX-MultiInitArg.changes
  perl-MooseX-MultiInitArg.spec



Other differences:
--
++ perl-MooseX-MultiInitArg.spec ++
#
# spec file for package perl-MooseX-MultiInitArg
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:   perl-MooseX-MultiInitArg
Version:0.01
Release:1
License:GPL+ or Artistic
%define cpan_name MooseX-MultiInitArg
Summary:Attributes with aliases for constructor arguments.
Url:http://search.cpan.org/dist/MooseX-MultiInitArg/
Group:  Development/Libraries/Perl
Source: 
http://www.cpan.org/authors/id/F/FR/FRODWITH/%{cpan_name}-%{version}.tar.gz
BuildArch:  noarch
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Moose)
Requires:   perl(Moose)
%{perl_requires}

%description
If you've ever wanted to be able to call an attribute any number of things
while you're passing arguments to your object constructor, Now You Can.

The primary motivator is that I have some attributes that were named
inconsistently, and I wanted to rename them without breaking backwards
compatibility with my existing API.

%prep
%setup -q -n %{cpan_name}-%{version}

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf %{buildroot}

%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes README

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit perl-Test-Differences for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-Test-Differences for 
openSUSE:Factory
checked in at Tue Jul 19 16:20:13 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/mounts/work_src_done/STABLE/perl-Test-Differences/perl-Test-Differences.changes
2010-12-01 10:46:17.0 +0100
@@ -0,0 +1,15 @@
+---
+Wed Dec  1 09:44:38 UTC 2010 - co...@novell.com
+
+- switch to perl_requires macro
+
+---
+Mon Nov 29 18:31:11 UTC 2010 - co...@novell.com
+
+- remove /var/adm/perl-modules
+
+---
+Sun Jul 25 06:54:27 UTC 2010 - pascal.ble...@opensuse.org
+
+- initial package (0.500)
+

calling whatdependson for head-i586


New:

  Test-Differences-0.500.tar.gz
  perl-Test-Differences.changes
  perl-Test-Differences.spec



Other differences:
--
++ perl-Test-Differences.spec ++
#
# spec file for package perl-Test-Differences
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:   perl-Test-Differences
Version:0.500
Release:1
Summary:Test strings and data structures and show differences if not ok
Source: 
http://search.cpan.org/CPAN/authors/id/O/OV/OVID/Test-Differences-%{version}.tar.gz
Url:http://search.cpan.org/dist/Test-Differences/
Group:  Development/Libraries/Perl
License:Perl License
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
%{perl_requires}
BuildRequires:  make perl
BuildRequires:  perl-macros
BuildRequires:  perl(Test::Pod)
BuildRequires:  perl(Test::Pod::Coverage)
BuildRequires:  perl(Text::Diff)
Requires:   perl(Text::Diff)

%description
Test strings and data structures and show differences if not ok.

%prep
%setup -q -n Test-Differences-%{version}
%__sed -i '/^auto_install/d' Makefile.PL

%build
%__perl Makefile.PL PREFIX=%{_prefix}
%__make %{?jobs:-j%{jobs}}

%install
%perl_make_install
%perl_process_packlist

%check
%__make test

%clean
%{?buildroot:%__rm -rf %{buildroot}}

%files
%defattr(-,root,root)
%doc Changes README
%dir %{perl_vendorlib}/Test
%{perl_vendorlib}/Test/Differences.pm
%dir %{perl_vendorarch}/auto/Test
%{perl_vendorarch}/auto/Test/Differences
%doc %{perl_man3dir}/Test::Differences.%{perl_man3ext}%{ext_man}
%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rpmorphan for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package rpmorphan for openSUSE:Factory
checked in at Tue Jul 19 16:30:18 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ rpmorphan/rpmorphan.changes 2011-03-29 12:58:59.0 +0200
@@ -0,0 +1,55 @@
+---
+Tue Mar 29 10:57:52 UTC 2011 - prus...@opensuse.org
+
+- use %_libexecdir for TARGET_LOCALE
+
+---
+Mon Mar 28 20:54:17 UTC 2011 - asterios.dra...@gmail.com
+
+- Updated to 1.9:
+  * new features:
++ add rpmextra tool
++ add grpmorphan as link to rpmorphan -gui
+  * others:
++ fix perlcritic warnings
+- Spec file updates:
+  * Require instead of Recommend the logrotate package.
+  * Minor changes in %build and %install sections.
+  * Changes in %files section. Most important:
++ %config(noreplace) for /etc/logrotate.d/rpmorphan.
++ %ghost %config(noreplace) for /var/log/rpmorphan.log.
+
+---
+Sat Feb  5 18:25:41 UTC 2011 - asterios.dra...@gmail.com
+
+- updated to 1.8
+  * fix bug on rpmdep (missing installtime in urpm mode)
+  * add help translation (gui)
+  From 1.7
+  * Curses is no more an rpm dependency
+  * add reload button
+- Spec file updates:
+  * Changes based on rpmdevtools templates and spec-cleaner run.
+  * Updates in Group:, Requires:, Recommends: and %install sections.
+  * Fixed rpmlint warning (non-executable-script).
+
+---
+Sun Feb 21 11:19:38 UTC 2010 - prus...@suse.cz
+
+- updated to 1.6
+
+---
+Tue Jan  6 13:42:14 CET 2009 - prus...@suse.cz
+
+- updated to 1.4
+
+---
+Thu Dec 11 10:53:35 CET 2008 - prus...@suse.cz
+
+- added perl-Curses-UI and perl-Tk to Recommends
+
+---
+Wed Dec 10 17:44:18 CET 2008 - prus...@suse.cz
+
+- created package - version 1.3
+

calling whatdependson for head-i586


New:

  rpmorphan-1.9.tar.gz
  rpmorphan.changes
  rpmorphan.spec



Other differences:
--
++ rpmorphan.spec ++
#
# spec file for package rpmorphan
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:   rpmorphan
Version:1.9
Release:1
Summary:List the orphaned RPM packages

License:GPLv2+
Url:http://rpmorphan.sourceforge.net/
Group:  System/Packages
Source0:
http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
BuildRoot:  %{_tmppath}/%{name}-%{version}-build

Requires:   rpm
Recommends: logrotate
Recommends: perl-Curses-UI
Recommends: perl-RPM2
Recommends: perl-Tk
BuildArch:  noarch

%description
Finds orphaned packages on your system. It determines which packages
have no other packages depending on their installation, and shows you
a list of these packages. It intends to be clone of deborphan debian
tools for RPM packages.

%prep
%setup -q

%build

%install
make install DESTDIR=%{buildroot} DOCDIR=%{buildroot}%{_defaultdocdir}/%{name} 
TARGET_LOCALE=%{buildroot}%{_libexecdir}/%{name}/locale

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root,-)
%doc Authors COPYING Changelog NEWS Readme Readme.fr Todo rpmorphan.lsm 
rpmorphanrc.sample
%config(noreplace) %{_sysconfdir}/logrotate.d/rpmorphan
%{_bindir}/grpmorphan
%{_bindir}/rpmdep
%{_bindir}/rpmdep.pl
%{_bindir}/rpmduplicates
%{_bindir}/rpmduplicates.pl
%{_bindir}/rpmextra
%{_bindir}/rpmextra.pl
%{_bindir}/rpmorphan
%{_bindir}/rpmorphan-curses-lib.pl
%{_bindir}/rpmorphan-lib.pl
%{_bindir}/rpmorphan-tk-lib.pl
%{_bindir}/rpmorphan.pl
%{_bindir}/rpmusage
%{_bindir}/rpmusage.pl
%doc %{_mandir}/man1/rpmdep.1%{ext_man}
%doc %{_mandir}/man1/rpmduplicates.1%{ext_man}
%doc %{_mandir}/man1/rpmextra.1%{ext_man}
%doc %{_mandir}/man1/rpmorphan.1%{ext_man}
%doc %{_mandir}/man1/rpmusage.1%{ext_man}
%{_libexecdir}/rpmorphan/
%dir %{_localstatedir}/lib/rpmorphan
%{_localstatedir}/lib/rpmorphan/keep
%ghost %config(noreplace) 

commit perl-Time-Duration-Parse for openSUSE:Factory

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package perl-Time-Duration-Parse for 
openSUSE:Factory
checked in at Tue Jul 19 16:33:29 CEST 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/mounts/work_src_done/STABLE/perl-Time-Duration-Parse/perl-Time-Duration-Parse.changes
  2011-07-14 10:21:58.0 +0200
@@ -0,0 +1,11 @@
+---
+Thu Jul 14 08:15:18 UTC 2011 - co...@novell.com
+
+- use original tarball
+
+---
+Fri Jan 14 11:36:35 UTC 2011 - co...@novell.com
+
+- initial package 0.06
+  * created by cpanspec 1.78.03
+

calling whatdependson for head-i586


New:

  Time-Duration-Parse-0.06.tar.gz
  perl-Time-Duration-Parse.changes
  perl-Time-Duration-Parse.spec



Other differences:
--
++ perl-Time-Duration-Parse.spec ++
#
# spec file for package perl-Time-Duration-Parse
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:   perl-Time-Duration-Parse
Version:0.06
Release:1
License:GPL+ or Artistic
%define cpan_name Time-Duration-Parse
Summary:Parse string that represents time duration
Url:http://search.cpan.org/dist/Time-Duration-Parse/
Group:  Development/Libraries/Perl
Source: 
http://www.cpan.org/authors/id/M/MI/MIYAGAWA/%{cpan_name}-%{version}.tar.gz
BuildArch:  noarch
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Exporter::Lite)
BuildRequires:  perl(LWP::Simple)
BuildRequires:  perl(Module::Build)
BuildRequires:  perl(YAML)
Requires:   perl(Exporter::Lite)
%{perl_requires}

%description
Time::Duration::Parse is a module to parse human readable duration strings
like _2 minutes and 3 seconds_ to seconds.

It does the opposite of _duration_exact_ function in Time::Duration and is
roundtrip safe. So, the following is always true.

  use Time::Duration::Parse;
  use Time::Duration;

  my $seconds = int rand 10;
  is( parse_duration(duration_exact($seconds)), $seconds );

%prep
%setup -q -n %{cpan_name}-%{version}

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf %{buildroot}

%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes

%changelog





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit cronie for openSUSE:11.4

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package cronie for openSUSE:11.4
checked in at Tue Jul 19 17:21:19 CEST 2011.




--- old-versions/11.4/UPDATES/all/cronie/cronie.changes 2011-05-16 
12:11:18.0 +0200
+++ 11.4/cronie/cronie.changes  2011-07-13 16:22:24.0 +0200
@@ -1,0 +2,5 @@
+Wed Jul 13 13:37:46 UTC 2011 - vci...@novell.com
+
+- changed run-parts to run-crons in anacron (bnc#689494)
+
+---

calling whatdependson for 11.4-i586


New:

  cronie-anacron-1.4.7-run-crons.patch



Other differences:
--
++ cronie.spec ++
--- /var/tmp/diff_new_pack.D15EXa/_old  2011-07-19 17:20:47.0 +0200
+++ /var/tmp/diff_new_pack.D15EXa/_new  2011-07-19 17:20:47.0 +0200
@@ -30,7 +30,7 @@
 AutoReqProv:on
 PreReq: permissions %fillup_prereq %insserv_prereq cron 
sysvinit(syslog)
 Version:1.4.7
-Release:9.RELEASE21
+Release:9.RELEASE23
 %{expand: %%define cronie_version %version}
 Summary:Cron Daemon
 Source0:%name-%version.tar.gz
@@ -52,6 +52,8 @@
 Patch5: %name-crond_pid.diff
 # PATCH-FIX-UPSTREAM cronie-1.4.7-syslog_output.patch bnc#692871
 Patch6: cronie-1.4.7-syslog_output.patch
+# PATCH-FIX-UPSTREAM use run-crons instead of run-parts for anacron 
(bnc#689494)
+Patch7: cronie-anacron-1.4.7-run-crons.patch
 Conflicts:  cron = 4.1
 # When finish update protection of sles11 we could uncomment line bellow and 
drop all
 # ugly hacks with subpackage cron needed for proper update proces
@@ -70,7 +72,7 @@
 %package -n cron
 License:MIT and BSD and GPLv2
 Version:4.2
-Release:9.RELEASE21
+Release:9.RELEASE23
 Summary:Auxiliary package
 Group:  System/Daemons
 Requires:   %{name} = %{cronie_version}-%{release}
@@ -95,6 +97,7 @@
 %patch4
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 cp %{S:7} ./cron_to_cronie.README
 
 %build


++ cronie-anacron-1.4.7-run-crons.patch ++
Index: cronie-1.4.7/contrib/anacrontab
===
--- cronie-1.4.7.orig/contrib/anacrontab
+++ cronie-1.4.7/contrib/anacrontab
@@ -11,6 +11,6 @@ RANDOM_DELAY=45
 START_HOURS_RANGE=3-22
 
 #period in days   delay in minutes   job-identifier   command
-1  5   cron.daily  nice run-parts /etc/cron.daily
-7  25  cron.weekly nice run-parts /etc/cron.weekly
-@monthly 45cron.monthlynice run-parts /etc/cron.monthly
+1  5   cron.daily  nice /usr/lib/cron/run-crons 
/etc/cron.daily
+7  25  cron.weekly nice /usr/lib/cron/run-crons 
/etc/cron.weekly
+@monthly 45cron.monthlynice /usr/lib/cron/run-crons 
/etc/cron.monthly
Index: cronie-1.4.7/man/anacrontab.5
===
--- cronie-1.4.7.orig/man/anacrontab.5
+++ cronie-1.4.7/man/anacrontab.5
@@ -79,9 +79,9 @@ RANDOM_DELAY=30
 # Anacron jobs will start between 6am and 8am.
 START_HOURS_RANGE=6-8
 # delay will be 5 minutes + RANDOM_DELAY for cron.daily
-1  5   cron.daily  nice run-parts /etc/cron.daily
-7  0   cron.weekly nice run-parts /etc/cron.weekly
-@monthly   0   cron.monthlynice run-parts /etc/cron.monthly
+1  5   cron.daily  nice /usr/lib/cron/run-crons 
/etc/cron.daily
+7  0   cron.weekly nice /usr/lib/cron/run-crons 
/etc/cron.weekly
+@monthly   0   cron.monthlynice /usr/lib/cron/run-crons 
/etc/cron.monthly
 .fi
 .SH SEE ALSO
 .BR anacron (8),





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gimp for openSUSE:11.3

2011-07-19 Thread h_root

Hello community,

here is the log from the commit of package gimp for openSUSE:11.3
checked in at Tue Jul 19 18:30:26 CEST 2011.




--- old-versions/11.3/UPDATES/all/gimp/gimp.changes 2011-05-27 
23:17:18.0 +0200
+++ 11.3/gimp/gimp.changes  2011-07-13 00:36:45.0 +0200
@@ -1,0 +2,6 @@
+Tue Jul 12 22:28:15 UTC 2011 - fi...@opensuse.org
+
+- Add gimp-pyslice-cellspacing-fix.patch to fix cellspacing in
+  pyslice plugin. Fix bnc#698769.
+
+---

calling whatdependson for 11.3-i586


New:

  gimp-pyslice-cellspacing-fix.patch



Other differences:
--
++ gimp.spec ++
--- /var/tmp/diff_new_pack.8cYkEY/_old  2011-07-19 18:28:54.0 +0200
+++ /var/tmp/diff_new_pack.8cYkEY/_new  2011-07-19 18:28:54.0 +0200
@@ -48,7 +48,7 @@
 BuildRequires:  xorg-x11-libXfixes-devel
 Url:http://www.gimp.org/
 Version:2.6.8
-Release:7.RELEASE5
+Release:7.RELEASE7
 License:GPLv2+
 Group:  Productivity/Graphics/Bitmap Editors
 Suggests:   AdobeICCProfiles
@@ -69,6 +69,8 @@
 Patch2: gimp-CVE-2010-4540-and-more.patch
 # PATCH-FIX-UPSTREAM gimp-CVE-2010-4543.patch CVE-2010-4543 bgo#639203 
bnc#662043 vu...@opensuse.org -- Fix a buffer overflow when reading a psp file
 Patch3: gimp-CVE-2010-4543.patch
+# PATCH-FIX-UPSTREAM gimp-pyslice-cellspacing-fix.patch bgo#641259 bnc#698769 
fi...@opensuse.org -- py-slice cellspacing fix
+Patch4: gimp-pyslice-cellspacing-fix.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires:   %{name}-branding = 2.4
 Recommends: %{name}-plugins-python = %{version} gimp-2.0-scanner-plugin 
%{name}-help-browser
@@ -209,6 +211,7 @@
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 # Safety check for ABI version change.
 vabi=`printf %d $(sed -n '/#define GIMP_MODULE_ABI_VERSION/{s/.* //;p}' 
libgimpmodule/gimpmodule.h)`
 if test x${vabi} != x%{abiver}; then

++ gimp-pyslice-cellspacing-fix.patch ++
diff --git a/plug-ins/pygimp/plug-ins/py-slice.py 
b/plug-ins/pygimp/plug-ins/py-slice.py
index f5b80bd..13ae267 100755
--- a/plug-ins/pygimp/plug-ins/py-slice.py
+++ b/plug-ins/pygimp/plug-ins/py-slice.py
@@ -35,6 +35,9 @@ gettext.install(gimp20-python, gimp.locale_directory, 
unicode=True)
 def pyslice(image, drawable, save_path, html_filename,
 image_basename, image_extension, separate,
 image_path, cellspacing, animate, skip_caps):
+
+cellspacing = int (cellspacing)
+
 if animate:
 count = 0
 drw = []





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org