commit aaa_base for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package aaa_base for openSUSE:Factory 
checked in at 2012-01-19 09:40:42

Comparing /work/SRC/openSUSE:Factory/aaa_base (Old)
 and  /work/SRC/openSUSE:Factory/.aaa_base.new (New)


Package is aaa_base, Maintainer is r...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/aaa_base/aaa_base.changes2012-01-11 
15:35:52.0 +0100
+++ /work/SRC/openSUSE:Factory/.aaa_base.new/aaa_base.changes   2012-01-19 
09:40:43.0 +0100
@@ -1,0 +2,5 @@
+Mon Jan 16 12:50:34 UTC 2012 - rha...@suse.de
+
+- Added application/json mimetype to /etc/mime.types (bnc#741546)
+
+---



Other differences:
--
++ aaa_base.spec ++
--- /var/tmp/diff_new_pack.yEHGIr/_old  2012-01-19 09:40:45.0 +0100
+++ /var/tmp/diff_new_pack.yEHGIr/_new  2012-01-19 09:40:45.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package aaa_base
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed

++ aaa_base.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aaa_base/files/etc/mime.types 
new/aaa_base/files/etc/mime.types
--- old/aaa_base/files/etc/mime.types   2012-01-09 15:34:51.0 +0100
+++ new/aaa_base/files/etc/mime.types   2012-01-17 14:33:54.0 +0100
@@ -14,6 +14,7 @@
 application/flash-video flv
 application/illustrator ai
 application/javascript js
+application/json json
 application/mac-binhex40
 application/mathematica nb
 application/msword doc

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit audiofile for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package audiofile for openSUSE:Factory 
checked in at 2012-01-19 09:40:48

Comparing /work/SRC/openSUSE:Factory/audiofile (Old)
 and  /work/SRC/openSUSE:Factory/.audiofile.new (New)


Package is audiofile, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/audiofile/audiofile.changes  2011-12-02 
09:25:43.0 +0100
+++ /work/SRC/openSUSE:Factory/.audiofile.new/audiofile.changes 2012-01-19 
09:40:49.0 +0100
@@ -1,0 +2,15 @@
+Tue Jan 17 08:52:59 UTC 2012 - vu...@opensuse.org
+
+- Update to version 0.3.3:
+  + Update library's soname version.
+  + Link against libm.
+- Drop audiofile-add-lm-linker.patch: fixed upstream.
+- Rebase audiofile-remove-unused-variables.patch.
+- Remove call to autoreconf: it was only there for
+  audiofile-add-lm-linker.patch.
+- Move man pages from libaudiofile0 subpackage to audiofile
+  subpackage, where the binaries live.
+- Rename libaudiofile0 subpackage to libaudiofile1, following
+  upstream soversion change.
+
+---

Old:

  audiofile-0.3.2.tar.xz
  audiofile-add-lm-linker.patch

New:

  audiofile-0.3.3.tar.xz



Other differences:
--
++ audiofile.spec ++
--- /var/tmp/diff_new_pack.pphBie/_old  2012-01-19 09:40:51.0 +0100
+++ /var/tmp/diff_new_pack.pphBie/_new  2012-01-19 09:40:51.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package audiofile
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,24 +16,22 @@
 #
 
 
-
 Name:   audiofile
-License:GPL-2.0+ ; LGPL-2.1+
-%define lname  libaudiofile0
+%define lname  libaudiofile1
 Url:http://www.68k.org/~michael/audiofile/
-Group:  System/Libraries
 # bug437293
 %ifarch ppc64
 Obsoletes:  audiofile-64bit
 %endif
-Version:0.3.2
-Release:1
+Version:0.3.3
+Release:0
 #
 Summary:An Audio File Library
+License:GPL-2.0+ ; LGPL-2.1+
+Group:  System/Libraries
 Source: 
http://download.gnome.org/sources/audiofile/0.3/%{name}-%{version}.tar.xz
 Source2:baselibs.conf
 Patch1: %{name}-remove-unused-variables.patch
-Patch2: %{name}-add-lm-linker.patch
 BuildRequires:  alsa-devel
 BuildRequires:  gcc-c++
 BuildRequires:  libtool
@@ -65,7 +63,6 @@
 NeXT/Sun).
 
 %package devel
-License:GPL-2.0+ ; LGPL-2.1+
 Summary:An audio file library
 Group:  Development/Libraries/C and C++
 Requires:   %lname = %{version}
@@ -80,7 +77,6 @@
 NeXT/Sun).
 
 %package doc
-License:GPL-2.0+ ; LGPL-2.1+
 Summary:An audio file library
 Group:  Documentation/Man
 Requires:   %{name} = %{version}
@@ -97,10 +93,8 @@
 %prep
 %setup -q
 %patch1
-%patch2
 
 %build
-autoreconf -fiv
 %{configure} \
 --with-pic \
 --disable-static
@@ -124,19 +118,20 @@
 %files
 %defattr(-, root, root)
 %doc README TODO COPYING* ACKNOWLEDGEMENTS AUTHORS NEWS NOTES
-%{_bindir}/s*
+%{_bindir}/sfconvert
+%{_bindir}/sfinfo
+%{_mandir}/man1/sfconvert.1*
+%{_mandir}/man1/sfinfo.1*
 
 %files -n %lname
 %defattr(-,root,root)
-%{_libdir}/*.so.*
-%{_mandir}/man1/sfconvert.1*
-%{_mandir}/man1/sfinfo.1*
+%{_libdir}/libaudiofile.so.*
 
 %files devel
 %defattr(-, root, root)
 %{_includedir}/*
-%{_libdir}/*.so
-%{_libdir}/pkgconfig/*.pc
+%{_libdir}/libaudiofile.so
+%{_libdir}/pkgconfig/audiofile.pc
 %if 0%{?suse_version} = 1110
 %{_libdir}/*.la
 %endif

++ audiofile-remove-unused-variables.patch ++
--- /var/tmp/diff_new_pack.pphBie/_old  2012-01-19 09:40:51.0 +0100
+++ /var/tmp/diff_new_pack.pphBie/_new  2012-01-19 09:40:51.0 +0100
@@ -47,8 +47,8 @@
bool hasFrameCount = false;
 -  bool hasINST = false;
  
-   instruments = NULL;
-   instrumentCount = 0;
+   Track *track = allocateTrack();
+ 
 @@ -796,28 +792,24 @@
}
else if (chunkid == cue )

++ baselibs.conf ++
--- /var/tmp/diff_new_pack.pphBie/_old  2012-01-19 09:40:51.0 +0100
+++ /var/tmp/diff_new_pack.pphBie/_new  2012-01-19 09:40:51.0 +0100
@@ -1,4 +1,4 @@
-libaudiofile0
+libaudiofile1
 audiofile-devel
requires -audiofile-targettype
-   requires libaudiofile0-targettype = version
+   requires libaudiofile1-targettype = version

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit babl for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package babl for openSUSE:Factory checked in 
at 2012-01-19 09:40:53

Comparing /work/SRC/openSUSE:Factory/babl (Old)
 and  /work/SRC/openSUSE:Factory/.babl.new (New)


Package is babl, Maintainer is sbra...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/babl/babl.changes2011-11-28 
12:53:00.0 +0100
+++ /work/SRC/openSUSE:Factory/.babl.new/babl.changes   2012-01-19 
09:40:54.0 +0100
@@ -1,0 +2,12 @@
+Tue Jan 10 16:46:07 UTC 2012 - dims...@opensuse.org
+
+- Add babl-fix-gir.patch: Fix building of the .gir and .typelib
+  files.
+- Add vala and gobject-introspection BuildRequires to build the
+  introspection and vala support.
+- Create typelib-1_0-Babl-0_1 subpackage for typelib.
+- Add typelib-1_0-Babl-0_1 Requires to -devel package.
+- Add libtool BuildRequires and call to autogen.sh as the patch
+  babl-fix-gir.patch touches the build system.
+
+---

New:

  babl-fix-gir.patch



Other differences:
--
++ babl.spec ++
--- /var/tmp/diff_new_pack.rygS2Q/_old  2012-01-19 09:40:55.0 +0100
+++ /var/tmp/diff_new_pack.rygS2Q/_new  2012-01-19 09:40:55.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package babl
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,18 +15,22 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   babl
 Url:http://gegl.org/babl/
 Version:0.1.6
-Release:1
+Release:0
+Summary:Dynamic Pixel Format Translation Library
 License:LGPL-3.0+
 Group:  System/Libraries
-Summary:Dynamic Pixel Format Translation Library
 Source: http://ftp.gtk.org/pub/babl/0.1/%{name}-%{version}.tar.bz2
+# PATCH-FIX-UPSTREAM babl-fix-gir.patch bgo#47 dims...@opensuse.org -- Fix 
building of .gir and typelib files.
+Patch0: babl-fix-gir.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  gobject-introspection-devel
+# Needed for patch0
+BuildRequires:  libtool
 BuildRequires:  pkg-config
+BuildRequires:  vala
 %define debug_package_requires libbabl-0_1-0 = %{version}-%{release}
 # None of these is needed for standard build:
 #BuildRequires:  inkscape ruby w3m
@@ -45,7 +49,6 @@
 types.
 
 %package -n libbabl-0_1-0
-License:LGPL-3.0+
 Summary:Dynamic Pixel Format Translation Library
 Group:  System/Libraries
 
@@ -60,12 +63,29 @@
 provided as well as the framework to add new color models and data
 types.
 
+%package -n typelib-1_0-Babl-0_1
+Summary:Dynamic Pixel Format Translation Library -- Introspection 
bindings
+Group:  System/Libraries
+
+%description -n typelib-1_0-Babl-0_1
+babl is a dynamic, any to any, pixel format translation library.
+
+It allows converting between different methods of storing pixels known
+as pixel formats that have with different bitdepths and other data
+representations, color models and component permutations.
+
+A vocabulary to formulate new pixel formats from existing primitives is
+provided as well as the framework to add new color models and data
+types.
+
+This package provides the GObject Introspection bindings for babl.
+
 %package devel
-License:LGPL-3.0+
 Summary:Dynamic Pixel Format Translation Library
 Group:  Development/Libraries/C and C++
 Requires:   glibc-devel
 Requires:   libbabl-0_1-0 = %{version}
+Requires:   typelib-1_0-Babl-0_1 = %{version}
 
 %description devel
 babl is a dynamic, any to any, pixel format translation library.
@@ -80,8 +100,11 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
+# Needed for patch0
+./autogen.sh
 %configure\
--disable-static
 make %{?_smp_mflags}
@@ -100,8 +123,16 @@
 %{_libdir}/*.so.*
 %{_libdir}/babl-0.1/
 
+%files -n typelib-1_0-Babl-0_1
+%defattr(-,root,root)
+%{_libdir}/girepository-1.0/Babl-0.1.typelib
+
 %files devel
 %defattr(-,root,root)
+%{_datadir}/gir-1.0/Babl-0.1.gir
+%dir %{_datadir}/vala
+%dir %{_datadir}/vala/vapi
+%{_datadir}/vala/vapi/babl-0.1.vapi
 %{_includedir}/babl-0.1/
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/*.pc

++ babl-fix-gir.patch ++
diff -ur babl-0.1.6/babl/Makefile.am babl-0.1.6.patched/babl/Makefile.am
--- babl-0.1.6/babl/Makefile.am 2011-11-18 18:03:21.0 +0100
+++ babl-0.1.6.patched/babl/Makefile.am 2012-01-10 17:26:29.275911662 +0100
@@ -92,10 +92,10 @@
 INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir)
 

commit banshee for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package banshee for openSUSE:Factory checked 
in at 2012-01-19 09:40:56

Comparing /work/SRC/openSUSE:Factory/banshee (Old)
 and  /work/SRC/openSUSE:Factory/.banshee.new (New)


Package is banshee, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/banshee/banshee.changes  2012-01-05 
19:10:11.0 +0100
+++ /work/SRC/openSUSE:Factory/.banshee.new/banshee.changes 2012-01-19 
09:40:58.0 +0100
@@ -1,0 +2,6 @@
+Tue Jan 17 11:11:22 UTC 2012 - vu...@opensuse.org
+
+- Add banshee Requires to muinshee subpackage as /usr/bin/muinshee
+  is a symlink to /usr/bin/banshee. Fix bnc#736777.
+
+---



Other differences:
--
++ banshee.spec ++
--- /var/tmp/diff_new_pack.S6vroT/_old  2012-01-19 09:40:59.0 +0100
+++ /var/tmp/diff_new_pack.S6vroT/_new  2012-01-19 09:40:59.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package banshee
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,7 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 Name:   banshee
 Version:2.3.3
 Release:0
@@ -272,6 +271,8 @@
 %package -n muinshee
 Summary:Banshee client modeled after the Muine music player interface
 Group:  Productivity/Multimedia/Sound/Players
+# /usr/bin/muinshee is a symlink to /usr/bin/banshee (bnc#736777)
+Requires:   %{name} = %{version}
 Requires:   %{name}-core = %{version}
 Provides:   %{name}-client = %{version}
 Provides:   %{name}-client-muinshee = %{version}


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit bundle-lang-common for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package bundle-lang-common for 
openSUSE:Factory checked in at 2012-01-19 09:41:11

Comparing /work/SRC/openSUSE:Factory/bundle-lang-common (Old)
 and  /work/SRC/openSUSE:Factory/.bundle-lang-common.new (New)


Package is bundle-lang-common, Maintainer is co...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/bundle-lang-common/bundle-lang-common.changes
2011-11-28 12:53:19.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.bundle-lang-common.new/bundle-lang-common.changes   
2012-01-19 09:41:12.0 +0100
@@ -1,0 +2,5 @@
+Tue Jan 10 05:57:22 UTC 2012 - co...@suse.com
+
+- update package list
+
+---
--- 
/work/SRC/openSUSE:Factory/bundle-lang-common/bundle-lang-gnome-extras.changes  
2011-11-07 16:58:40.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.bundle-lang-common.new/bundle-lang-gnome-extras.changes
 2012-01-19 09:41:12.0 +0100
@@ -1,0 +2,10 @@
+Tue Jan 10 05:57:22 UTC 2012 - co...@suse.com
+
+- update package list
+
+---
+Sat Nov 26 19:02:26 UTC 2011 - co...@suse.com
+
+- update package list
+
+---
bundle-lang-gnome.changes: same change
bundle-lang-kde.changes: same change



Other differences:
--
++ bundle-lang-common.spec ++
--- /var/tmp/diff_new_pack.YNUKqH/_old  2012-01-19 09:41:14.0 +0100
+++ /var/tmp/diff_new_pack.YNUKqH/_new  2012-01-19 09:41:14.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package bundle-lang-common
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,56 +15,57 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
 
 #!BuildIgnore: gimp-unstable
 
 Name:   bundle-lang-common
 # @BREQUIRES@
-BuildRequires:  xz-lang
-BuildRequires:  wdiff-lang
-BuildRequires:  vorbis-tools-lang
-BuildRequires:  util-linux-lang
-BuildRequires:  upower-lang
-BuildRequires:  tar-lang
-BuildRequires:  pulseaudio-lang
-BuildRequires:  nano-lang
-BuildRequires:  mc-lang
-BuildRequires:  login-lang
-BuildRequires:  libgphoto2-lang
-BuildRequires:  iso-codes-lang
-BuildRequires:  gtk3-lang
-BuildRequires:  gtk2-lang
-BuildRequires:  gstreamer-0_10-plugins-base-lang
-BuildRequires:  gstreamer-0_10-lang
-BuildRequires:  gsettings-desktop-schemas-lang
-BuildRequires:  gpg2-lang
-BuildRequires:  gnome-vfs2-lang
-BuildRequires:  gnome-keyring-lang
-BuildRequires:  glib2-lang
-BuildRequires:  glib-networking-lang
-BuildRequires:  gimp-lang
-BuildRequires:  gdk-pixbuf-lang
-BuildRequires:  gconf2-lang
-BuildRequires:  cpio-lang
-BuildRequires:  coreutils-lang
-BuildRequires:  bash-lang
-BuildRequires:  avahi-lang
-BuildRequires:  PackageKit-lang
-BuildRequires:  NetworkManager-vpnc-lang
-BuildRequires:  NetworkManager-pptp-lang
-BuildRequires:  NetworkManager-openvpn-lang
 BuildRequires:  NetworkManager-lang
+BuildRequires:  NetworkManager-openvpn-lang
+BuildRequires:  NetworkManager-pptp-lang
+BuildRequires:  NetworkManager-vpnc-lang
+BuildRequires:  PackageKit-lang
+BuildRequires:  avahi-lang
+BuildRequires:  bash-lang
+BuildRequires:  coreutils-lang
+BuildRequires:  cpio-lang
 BuildRequires:  fdupes
+BuildRequires:  gconf2-lang
+BuildRequires:  gcr-lang
+BuildRequires:  gdk-pixbuf-lang
+BuildRequires:  gimp-lang
+BuildRequires:  glib-networking-lang
+BuildRequires:  glib2-lang
+BuildRequires:  gnome-keyring-lang
+BuildRequires:  gnome-vfs2-lang
+BuildRequires:  gpg2-lang
+BuildRequires:  gsettings-desktop-schemas-lang
+BuildRequires:  gstreamer-0_10-lang
+BuildRequires:  gstreamer-0_10-plugins-base-lang
+BuildRequires:  gtk2-lang
+BuildRequires:  gtk3-lang
+BuildRequires:  iso-codes-lang
+BuildRequires:  libgphoto2-lang
+BuildRequires:  login-lang
+BuildRequires:  mc-lang
+BuildRequires:  nano-lang
+BuildRequires:  pulseaudio-lang
+BuildRequires:  tar-lang
+BuildRequires:  upower-lang
+BuildRequires:  util-linux-lang
+BuildRequires:  vorbis-tools-lang
+BuildRequires:  wdiff-lang
+BuildRequires:  xz-lang
 #!BuildIgnore:  xorg-x11-driver-input
 #!BuildIgnore:  NetworkManager-openvpn
 #!BuildIgnore:  NetworkManager-pptp
 #!BuildIgnore:  NetworkManager-vpnc
-License:MIT
-Group:  System/Localization
+#!BuildIgnore:  NetworkManager-openconnect
 Version:12.1
-Release:1
+Release:0
 Summary:Translations for a Group of Programs
+License:MIT

commit cgdb for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package cgdb for openSUSE:Factory checked in 
at 2012-01-19 09:41:15

Comparing /work/SRC/openSUSE:Factory/cgdb (Old)
 and  /work/SRC/openSUSE:Factory/.cgdb.new (New)


Package is cgdb, Maintainer is bwa...@novell.com

Changes:

--- /work/SRC/openSUSE:Factory/cgdb/cgdb.changes2011-09-23 
01:53:19.0 +0200
+++ /work/SRC/openSUSE:Factory/.cgdb.new/cgdb.changes   2012-01-19 
09:41:17.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:30:32 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ cgdb.spec ++
--- /var/tmp/diff_new_pack.Mepa39/_old  2012-01-19 09:41:18.0 +0100
+++ /var/tmp/diff_new_pack.Mepa39/_new  2012-01-19 09:41:18.0 +0100
@@ -1,10 +1,26 @@
+#
+# spec file for package cgdb
+#
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An Open Source License is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
 Name:   cgdb
 Version:0.6.6
-Release:2
-License:GPL
+Release:0
 Summary:Curses debugger
-Url:http://cgdb.sourceforge.net
+License:GPL-2.0+
 Group:  Development/Tools/Debuggers
+Url:http://cgdb.sourceforge.net
 Source0:
http://garr.dl.sourceforge.net/sourceforge/cgdb/%{name}-%{version}.tar.bz2
 BuildRequires:  bison
 BuildRequires:  flex
@@ -13,7 +29,6 @@
 Requires(pre):  %install_info_prereq
 Requires:   gdb
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-Autoreq:on
 
 %description
 CGDB is a curses (terminal-based) interface to the GNU Debugger (GDB). Its goal
@@ -48,3 +63,5 @@
 %{_mandir}/man1/cgdb.1.gz
 %{_infodir}/cgdb.info.gz
 %dir %{_datadir}/cgdb
+
+%changelog

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit cutecom for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package cutecom for openSUSE:Factory checked 
in at 2012-01-19 09:41:22

Comparing /work/SRC/openSUSE:Factory/cutecom (Old)
 and  /work/SRC/openSUSE:Factory/.cutecom.new (New)


Package is cutecom, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/cutecom/cutecom.changes  2011-09-23 
01:54:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.cutecom.new/cutecom.changes 2012-01-19 
09:41:23.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:30:33 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ cutecom.spec ++
--- /var/tmp/diff_new_pack.DwVC0n/_old  2012-01-19 09:41:24.0 +0100
+++ /var/tmp/diff_new_pack.DwVC0n/_new  2012-01-19 09:41:24.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package cutecom
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,17 +15,17 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   cutecom
 Version:0.22.0
-Release:1
+Release:0
 Url:http://cutecom.sourceforge.net/
-License:GPL
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  cmake gcc-c++ libqt4-devel
-Group:  Applications/Communications
+BuildRequires:  cmake
+BuildRequires:  gcc-c++
+BuildRequires:  libqt4-devel
 Summary:Serial terminal
+License:GPL-2.0+
+Group:  Applications/Communications
 Source: %{name}-%{version}.tar.gz
 Source3:%{name}.desktop
 Source4:%{name}.png
@@ -33,7 +33,8 @@
 
 %if 0%{?suse_version}
 # for = 11.1 validity tests
-BuildRequires:  gnome-icon-theme kdelibs3
+BuildRequires:  gnome-icon-theme
+BuildRequires:  kdelibs3
 %endif
 
 %description


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gettext-runtime for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package gettext-runtime for openSUSE:Factory 
checked in at 2012-01-19 09:41:38

Comparing /work/SRC/openSUSE:Factory/gettext-runtime (Old)
 and  /work/SRC/openSUSE:Factory/.gettext-runtime.new (New)


Package is gettext-runtime, Maintainer is p...@suse.com

Changes:

gettext-java.changes: same change
--- /work/SRC/openSUSE:Factory/gettext-runtime/gettext-runtime.changes  
2011-10-03 09:19:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.gettext-runtime.new/gettext-runtime.changes 
2012-01-19 09:41:41.0 +0100
@@ -1,0 +2,11 @@
+Thu Jan 12 15:57:24 UTC 2012 - a...@suse.de
+
+- Disable tests test-readlink and test-areadlink since they 
+  fail randomly.
+
+---
+Thu Jan 12 13:37:28 UTC 2012 - a...@suse.de
+
+- Remove cvs, not used anymore since 0.18.1 in our build.
+
+---



Other differences:
--
++ gettext-csharp.spec ++
--- /var/tmp/diff_new_pack.IiVf0y/_old  2012-01-19 09:41:42.0 +0100
+++ /var/tmp/diff_new_pack.IiVf0y/_new  2012-01-19 09:41:42.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gettext-csharp
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed

gettext-java.spec: same change
++ gettext-runtime.spec ++
--- /var/tmp/diff_new_pack.IiVf0y/_old  2012-01-19 09:41:42.0 +0100
+++ /var/tmp/diff_new_pack.IiVf0y/_new  2012-01-19 09:41:42.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gettext-runtime
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -73,7 +73,7 @@
 License:LGPL-2.1+
 Summary:Tools for Native Language Support (NLS)
 Group:  Development/Tools/Other
-Requires:   %{name} = %{version}, cvs
+Requires:   %{name} = %{version}
 PreReq: info
 # bug437293
 %ifarch ppc64
@@ -119,7 +119,6 @@
   OPTS=--disable-openmp
 %endif
 %configure --enable-shared $OPTS
-
 make %{?_smp_mflags} GMSGFMT=../src/msgfmt
 # use texinfo.tex supplied by the system (texinfo)
 # make -C gettext-tools/doc gettext.pdf
@@ -160,6 +159,11 @@
 # s390s fails this test, 
 # Starting test_recursive_lock ...test-lock: pthread_mutex_lock.c:66: 
__pthread_mutex_lock: Assertion `mutex-__data.__owner == 0' failed.
 
+# These fails randomly, remove them from Makefile
+sed -i -e 's/test-areadlink\$(EXEEXT) //g' \
+ -e 's/test-readlink\$(EXEEXT) //g' \
+ gettext-tools/gnulib-tests/Makefile
+
 make check || {
 %ifarch s390x
echo got this during mbuild testing on s390x (on both times which make 
check ran):

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit go for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package go for openSUSE:Factory checked in 
at 2012-01-19 09:41:42

Comparing /work/SRC/openSUSE:Factory/go (Old)
 and  /work/SRC/openSUSE:Factory/.go.new (New)


Package is go, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/go/go.changes2011-12-09 09:31:45.0 
+0100
+++ /work/SRC/openSUSE:Factory/.go.new/go.changes   2012-01-19 
09:41:45.0 +0100
@@ -1,0 +2,35 @@
+Fri Dec 23 13:02:09 UTC 2011 - gra...@andtech.eu
+
+- Update to weekly.2011.12.22
+- changes to the images/ycbcr and testing packages
+  * gofix required for code using images/ycbr
+  * Testing package B (benchmark) type now has same methods as T 
+- Compiler inlining: Enabled in .spec as export GCFLAGS=-l
+  * Needs to be explicitly enabled at compile time with the above
+flag or using the -l compiler flag
+- Initial implementation of 'go' command utility
+- Many fixes and updates
+  * http://weekly.golang.org/doc/devel/weekly.html#2011-12-22
+
+---
+Fri Dec 16 10:03:38 CET 2011 - dmuel...@suse.de
+
+- fix exclusivearch for %%arm
+- fix filelist for %%arm
+
+---
+Tue Dec 13 14:54:16 UTC 2011 - sasc...@suse.de
+
+- Use $GOBIN as install target directory for binaries (Make.cmd)
+  regardless of $TARGDIR (Second part of bnc#735320)
+
+---
+Tue Dec 13 14:06:38 UTC 2011 - sasc...@suse.de
+
+- Improve macros %go_make, %go_make_test and %go_make_install:
+  * Set TARGDIR and GOBIN all macros (bnc#735320)
+  * Make sure %{buildroot}%{_bindir} exists in any case
+- The above should simplify spec files for Go packages that use, .e.g.,
+  'make tools' to install additional stuff (like binaries)
+
+---

Old:

  go-0.0.r60.3+hg20111205.tar.bz2

New:

  go-0.0.r60.3+hg20111222.tar.bz2
  go-set-make-cmd-install-path-to-gobin.patch



Other differences:
--
++ go.spec ++
--- /var/tmp/diff_new_pack.OaYRYE/_old  2012-01-19 09:41:47.0 +0100
+++ /var/tmp/diff_new_pack.OaYRYE/_new  2012-01-19 09:41:47.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package go
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c) 2011, Sascha Peilicke sasc...@gmx.de
 #
 # All modifications and additions to the file contributed by third parties
@@ -16,14 +16,12 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   go
-Version:0.0.r60.3+hg20111205
+Version:0.0.r60.3+hg20111222
 Release:0
 Summary:A compiled, garbage-collected, concurrent programming language
-Group:  Development/Languages/Other
 License:BSD-3-Clause
+Group:  Development/Languages/Other
 Url:http://golang.org
 Source0:go-%{version}.tar.bz2
 Source1:rpmlintrc
@@ -36,9 +34,11 @@
 Patch1: go-godoc-path-locations.patch
 # PATCH-FIX-OPENSUSE set correct location of gdb pretty printer
 Patch2: gdb-printer.patch
+# PATCH-FIX-OPENSUSE set correct install path (GOBIN) for Make.cmd
+Patch3: go-set-make-cmd-install-path-to-gobin.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  ed
 BuildRequires:  bison
+BuildRequires:  ed
 BuildRequires:  mercurial
 %if 0%{?suse_version}  1020
 BuildRequires:  fdupes
@@ -48,7 +48,7 @@
 Provides:   go-devel-static = %{version}
 Provides:   go-devel = %{version}
 Obsoletes:  go-devel  %{version}
-ExclusiveArch:  %ix86 x86_64 arm
+ExclusiveArch:  %ix86 x86_64 %arm
 
 %description
 Go is an expressive, concurrent, garbage collected systems programming language
@@ -93,6 +93,7 @@
 %setup -q -n %{name}
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 cp %{SOURCE4} .
 
 # setup go_arch (BSD-like scheme)
@@ -121,6 +122,8 @@
 mkdir -p $GOBIN
 cd src
 export GDB_PRINTER=%{gdb_printer}
+# enable compiler inlining
+export GCFLAGS=-l
 HOST_EXTRA_CFLAGS=%{optflags} -Wno-error -D GDB_PRINTER='\$GDB_PRINTER\' 
./make.bash
 
 %install
@@ -135,6 +138,14 @@
 mkdir -p %{buildroot}%{_bindir}
 mkdir -p %{buildroot}%{_sbindir}
 cp -r bin/* %{buildroot}%{_bindir}
+# all C compilers are now built for generated files, remove them for other 
archs
+rm %{buildroot}%{_bindir}/5c
+%ifarch %ix86
+rm %{buildroot}%{_bindir}/6c
+%endif
+%ifarch x86_64
+rm %{buildroot}%{_bindir}/8c
+%endif
 mv %{buildroot}%{_bindir}/goinstall %{buildroot}%{_sbindir}/goinstall
 rm -f %{buildroot}%{_bindir}/{hgpatch,quietgcc}
 mkdir -p $GOROOT/src
@@ -186,10 +197,13 

commit go-go-gtk for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package go-go-gtk for openSUSE:Factory 
checked in at 2012-01-19 09:41:53

Comparing /work/SRC/openSUSE:Factory/go-go-gtk (Old)
 and  /work/SRC/openSUSE:Factory/.go-go-gtk.new (New)


Package is go-go-gtk, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/go-go-gtk/go-go-gtk.changes  2011-10-27 
12:16:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.go-go-gtk.new/go-go-gtk.changes 2012-01-19 
09:41:55.0 +0100
@@ -1,0 +2,6 @@
+Fri Dec 23 22:22:27 UTC 2011 - gra...@andtech.eu
+
+- Update to 23.12.2011 git
+- GtkEntry.SetAlignment()
+
+---

Old:

  go-gtk-0.0.0+git20111019.tar.bz2

New:

  go-gtk-0.0.0+git20111223.tar.bz2



Other differences:
--
++ go-go-gtk.spec ++
--- /var/tmp/diff_new_pack.eaIQr9/_old  2012-01-19 09:41:57.0 +0100
+++ /var/tmp/diff_new_pack.eaIQr9/_new  2012-01-19 09:41:57.0 +0100
@@ -19,7 +19,7 @@
 
 
 Name:   go-go-gtk
-Version:0.0.0+git20111019
+Version:0.0.0+git20111223
 Release:0
 License:BSD ; LGPL-2.0+
 Summary:Go bindings for GTK

++ go-gtk-0.0.0+git20111019.tar.bz2 - go-gtk-0.0.0+git20111223.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/go-gtk/example/twitter/twitter.go 
new/go-gtk/example/twitter/twitter.go
--- old/go-gtk/example/twitter/twitter.go   2011-10-19 18:23:01.0 
+0200
+++ new/go-gtk/example/twitter/twitter.go   2011-12-23 23:06:39.0 
+0100
@@ -1,36 +1,40 @@
 package main
 
 import (
-   github.com/mattn/go-gtk/gtk
+   bytes
+   encoding/json
+   fmt
github.com/mattn/go-gtk/gdk
github.com/mattn/go-gtk/gdkpixbuf
-   http
-   json
-   bytes
+   github.com/mattn/go-gtk/gtk
io
io/ioutil
+   net/http
os
strings
 )
 
-func url2pixbuf(url string) *gdkpixbuf.GdkPixbuf {
+func readURL(url string) ([]byte, *http.Response) {
r, err := http.Get(url)
if err != nil {
-   return nil
+   return nil, nil
}
-   t := r.Header.Get(Content-Type)
-   b := make([]byte, r.ContentLength)
-   if _, err = io.ReadFull(r.Body, b); err != nil {
-   return nil
+   var b []byte
+   if b, err = ioutil.ReadAll(r.Body); err != nil {
+   return nil, nil
}
+   return b, r
+}
+
+func bytes2pixbuf(data []byte, typ string) *gdkpixbuf.GdkPixbuf {
var loader *gdkpixbuf.GdkPixbufLoader
-   if strings.Index(t, jpeg) = 0 {
+   if strings.Index(typ, jpeg) = 0 {
loader, _ = gdkpixbuf.PixbufLoaderWithMimeType(image/jpeg)
} else {
loader, _ = gdkpixbuf.PixbufLoaderWithMimeType(image/png)
}
loader.SetSize(24, 24)
-   loader.Write(b)
+   loader.Write(data)
loader.Close()
return loader.GetPixbuf()
 }
@@ -72,19 +76,26 @@
_, err = io.ReadFull(r.Body, b)
}
if err != nil {
-   println(err.String())
+   fmt.Println(err)
return
}
var j interface{}
-   json.NewDecoder(bytes.NewBuffer(b)).Decode(j)
+   err = 
json.NewDecoder(bytes.NewBuffer(b)).Decode(j)
+   if err != nil {
+   fmt.Println(err)
+   return
+   }
arr := j.([]interface{})
for i := 0; i  len(arr); i++ {
data := arr[i].(map[string]interface{})
icon := 
data[user].(map[string]interface{})[profile_image_url].(string)
var iter gtk.GtkTextIter
+   pixbufbytes, resp := readURL(icon)
gdk.ThreadsEnter()
-   buffer.GetStartIter(iter)
-   buffer.InsertPixbuf(iter, 
url2pixbuf(icon))
+   buffer.GetEndIter(iter)
+   if resp != nil {
+   buffer.InsertPixbuf(iter, 
bytes2pixbuf(pixbufbytes, resp.Header.Get(Content-Type)))
+   }

commit go-goauth2 for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package go-goauth2 for openSUSE:Factory 
checked in at 2012-01-19 09:41:48

Comparing /work/SRC/openSUSE:Factory/go-goauth2 (Old)
 and  /work/SRC/openSUSE:Factory/.go-goauth2.new (New)


Package is go-goauth2, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/go-goauth2/go-goauth2.changes2011-10-07 
00:47:36.0 +0200
+++ /work/SRC/openSUSE:Factory/.go-goauth2.new/go-goauth2.changes   
2012-01-19 09:41:49.0 +0100
@@ -1,0 +2,5 @@
+Tue Dec 13 15:31:07 UTC 2011 - sasc...@suse.de
+
+- Adjust to Go weekly.2011-12-02 release changes
+
+---

Old:

  goauth2-0.0.0+hg20110813.tar.bz2
  rpmlintrc

New:

  goauth2-0.0.0+hg20111205.tar.bz2
  goauth2-weekly-fixes.patch



Other differences:
--
++ go-goauth2.spec ++
--- /var/tmp/diff_new_pack.MT41nq/_old  2012-01-19 09:41:50.0 +0100
+++ /var/tmp/diff_new_pack.MT41nq/_new  2012-01-19 09:41:50.0 +0100
@@ -2,7 +2,7 @@
 # spec file for package go-goauth2
 #
 # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
-# Copyright (c), 2011, Sascha Peilicke sasc...@gmx.de
+# Copyright (c) 2011 Sascha Peilicke sasc...@gmx.de
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,15 +17,15 @@
 #
 
 
-
 Name:   go-goauth2
-Version:0.0.0+hg20110813
-Release:1
+Version:0.0.0+hg20111205
+Release:0
 Summary:OAuth 2.0 for Go clients
-Group:  Development/Languages/Other
 License:MIT
+Group:  Development/Languages/Other
 Url:http://code.google.com/p/goauth2/
 Source0:goauth2-%{version}.tar.bz2
+Patch0: goauth2-weekly-fixes.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  go-devel
 %{go_provides}
@@ -37,18 +37,16 @@
 
 %prep
 %setup -q -n goauth2
+%patch0 -p1
 
 %build
 
 %install
 cd oauth  %{go_make_install}
 
-%clean
-rm -rf %{buildroot}
-
 %files
 %defattr(-,root,root,-)
-%doc oauth/example
+%doc AUTHORS CONTRIBUTORS LICENSE oauth/example
 %{go_sitearch}/*
 
 %changelog

++ goauth2-0.0.0+hg20110813.tar.bz2 - goauth2-0.0.0+hg20111205.tar.bz2 
++
Files old/goauth2/.hg/00changelog.i and new/goauth2/.hg/00changelog.i differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/goauth2/.hg/branch new/goauth2/.hg/branch
--- old/goauth2/.hg/branch  2011-10-06 16:06:24.0 +0200
+++ new/goauth2/.hg/branch  1970-01-01 01:00:00.0 +0100
@@ -1 +0,0 @@
-default
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/goauth2/.hg/cache/branchheads 
new/goauth2/.hg/cache/branchheads
--- old/goauth2/.hg/cache/branchheads   2011-10-06 16:06:24.0 +0200
+++ new/goauth2/.hg/cache/branchheads   1970-01-01 01:00:00.0 +0100
@@ -1,2 +0,0 @@
-1d1bf184962bfb6857eb4360e745adaef1390205 20
-1d1bf184962bfb6857eb4360e745adaef1390205 default
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/goauth2/.hg/cache/tags new/goauth2/.hg/cache/tags
--- old/goauth2/.hg/cache/tags  2011-10-06 16:06:24.0 +0200
+++ new/goauth2/.hg/cache/tags  1970-01-01 01:00:00.0 +0100
@@ -1,5 +0,0 @@
-20 1d1bf184962bfb6857eb4360e745adaef1390205 
dbd998807b7aad9a4682c2e357d90c61582a921f
-
-379476c9e05c5275356e0a82ca079e61869e9192 release
-dfcfcf8893af73b581ed04be83ce405bd1e24f66 weekly.2011-08-17
-dfcfcf8893af73b581ed04be83ce405bd1e24f66 weekly
Files old/goauth2/.hg/dirstate and new/goauth2/.hg/dirstate differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/goauth2/.hg/hgrc new/goauth2/.hg/hgrc
--- old/goauth2/.hg/hgrc2011-10-06 16:06:24.0 +0200
+++ new/goauth2/.hg/hgrc1970-01-01 01:00:00.0 +0100
@@ -1,2 +0,0 @@
-[paths]
-default = https://code.google.com/p/goauth2/
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/goauth2/.hg/requires new/goauth2/.hg/requires
--- old/goauth2/.hg/requires2011-10-06 16:06:23.0 +0200
+++ new/goauth2/.hg/requires1970-01-01 01:00:00.0 +0100
@@ -1,4 +0,0 @@
-revlogv1
-store
-fncache
-dotencode
Files old/goauth2/.hg/store/00changelog.i and 
new/goauth2/.hg/store/00changelog.i differ
Files old/goauth2/.hg/store/00manifest.i and new/goauth2/.hg/store/00manifest.i 
differ
Files old/goauth2/.hg/store/data/_c_o_n_t_r_i_b_u_t_o_r_s.i and 
new/goauth2/.hg/store/data/_c_o_n_t_r_i_b_u_t_o_r_s.i differ
Files 

commit go-GoMySQL for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package go-GoMySQL for openSUSE:Factory 
checked in at 2012-01-19 09:41:57

Comparing /work/SRC/openSUSE:Factory/go-GoMySQL (Old)
 and  /work/SRC/openSUSE:Factory/.go-GoMySQL.new (New)


Package is go-GoMySQL, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/go-GoMySQL/go-GoMySQL.changes2011-10-27 
12:16:21.0 +0200
+++ /work/SRC/openSUSE:Factory/.go-GoMySQL.new/go-GoMySQL.changes   
2012-01-19 09:41:59.0 +0100
@@ -1,0 +2,10 @@
+Sat Dec 24 08:30:49 UTC 2011 - gra...@andtech.eu
+
+- Update to work with weekly.2011.12.22
+- If db isn't setup, show helpful tips and don't crash
+- Remove some unnecessary type assertions
+- Add UseResult method on Statement
+- fixed to handle null values
+- Return an error in UseResult if there's no result set
+
+---

Old:

  GoMySQL-0.0.0+git20110521.tar.bz2

New:

  GoMySQL-0.0.0+git20111224.tar.bz2



Other differences:
--
++ go-GoMySQL.spec ++
--- /var/tmp/diff_new_pack.SRivNj/_old  2012-01-19 09:41:59.0 +0100
+++ /var/tmp/diff_new_pack.SRivNj/_new  2012-01-19 09:41:59.0 +0100
@@ -1,4 +1,7 @@
 #
+# spec file for package go-GoMySQL
+#
+# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c), 2011, Sascha Peilicke sasc...@gmx.de
 #
 # All modifications and additions to the file contributed by third parties
@@ -10,13 +13,18 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
+
+
+
 Name:   go-GoMySQL
-Version:0.0.0+git20110521
+Version:0.0.0+git20111224
 Release:0
 Summary:MySQL client library written completely in Go
 Group:  Development/Languages/Other
 License:BSD-3-Clause
-URL:https://github.com/Philio/GoMySQL
+Url:https://github.com/Philio/GoMySQL
 Source0:GoMySQL-%{version}.tar.bz2
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  go-devel
@@ -35,11 +43,12 @@
 %setup -q -n GoMySQL
 
 %build
+
 %install
 %{go_make_install}
 
-#%check
-#%{go_make_test}
+%check
+%{go_make_test}
 
 %clean
 rm -rf %{buildroot}

++ GoMySQL-0.0.0+git20110521.tar.bz2 - GoMySQL-0.0.0+git20111224.tar.bz2 
++
 2503 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit go-Go-SDL for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package go-Go-SDL for openSUSE:Factory 
checked in at 2012-01-19 09:42:06

Comparing /work/SRC/openSUSE:Factory/go-Go-SDL (Old)
 and  /work/SRC/openSUSE:Factory/.go-Go-SDL.new (New)


Package is go-Go-SDL, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/go-Go-SDL/go-Go-SDL.changes  2011-10-27 
19:16:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.go-Go-SDL.new/go-Go-SDL.changes 2012-01-19 
09:42:08.0 +0100
@@ -1,0 +2,7 @@
+Fri Dec 30 08:12:51 UTC 2011 - gra...@andtech.eu
+
+- Update to 18.12.2011 git version
+- image.Image to *sdl.Surface conversion
+- Misc gofix/updates to follow spec/language changes
+
+---

Old:

  Go-SDL-0.0.0+git20110624.tar.bz2
  Go-SDL-uint-count.patch

New:

  Go-SDL-0.0.0+git20111219.tar.bz2



Other differences:
--
++ go-Go-SDL.spec ++
--- /var/tmp/diff_new_pack.fSFTLj/_old  2012-01-19 09:42:09.0 +0100
+++ /var/tmp/diff_new_pack.fSFTLj/_new  2012-01-19 09:42:09.0 +0100
@@ -1,4 +1,7 @@
 #
+# spec file for package go-Go-SDL
+#
+# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c), 2011, Sascha Peilicke sasc...@gmx.de
 #
 # All modifications and additions to the file contributed by third parties
@@ -10,16 +13,20 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
+
+
+
 Name:   go-Go-SDL
-Version:0.0.0+git20110624
+Version:0.0.0+git20111219
 Release:0
 Summary:Go bindings for SDL
 Group:  Development/Languages/Other
 License:BSD-3-Clause
-URL:https://github.com/banthar/Go-SDL
+Url:https://github.com/banthar/Go-SDL
 Source0:Go-SDL-%{version}.tar.bz2
 Source1:LICENSE
-Patch0: Go-SDL-uint-count.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  go-devel
 %if 0%{?fedora_version} || 0%{?rhel_version} || 0%{?centos_version}
@@ -40,10 +47,10 @@
 
 %prep
 %setup -q -n Go-SDL
-%patch0 -p1
 cp %{SOURCE1} .
 
 %build
+
 %install
 %{go_make_install}
 

++ Go-SDL-0.0.0+git20110624.tar.bz2 - Go-SDL-0.0.0+git20111219.tar.bz2 
++
/work/SRC/openSUSE:Factory/go-Go-SDL/Go-SDL-0.0.0+git20110624.tar.bz2 
/work/SRC/openSUSE:Factory/.go-Go-SDL.new/Go-SDL-0.0.0+git20111219.tar.bz2 
differ: char 11, line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit go-go-readline for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package go-go-readline for openSUSE:Factory 
checked in at 2012-01-19 09:42:02

Comparing /work/SRC/openSUSE:Factory/go-go-readline (Old)
 and  /work/SRC/openSUSE:Factory/.go-go-readline.new (New)


Package is go-go-readline, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/go-go-readline/go-go-readline.changes
2011-10-27 12:16:24.0 +0200
+++ /work/SRC/openSUSE:Factory/.go-go-readline.new/go-go-readline.changes   
2012-01-19 09:42:04.0 +0100
@@ -1,0 +2,6 @@
+Tue Jan 10 08:46:28 UTC 2012 - sasc...@suse.de
+
+- Update to 10/01/2012 mercurial version:
+  * Adjust to recent Go changes
+
+---

Old:

  go-readline-0.0.0+hg20110702.tar.bz2

New:

  go-readline-0.0.0+hg20120110.tar.bz2



Other differences:
--
++ go-go-readline.spec ++
--- /var/tmp/diff_new_pack.eMLGoB/_old  2012-01-19 09:42:05.0 +0100
+++ /var/tmp/diff_new_pack.eMLGoB/_new  2012-01-19 09:42:05.0 +0100
@@ -1,5 +1,8 @@
 #
-# Copyright (c), 2011, Sascha Peilicke sasc...@gmx.de
+# spec file for package go-go-readline
+#
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2011 Sascha Peilicke sasc...@gmx.de
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -10,18 +13,22 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
+
 Name:   go-go-readline
-Version:0.0.0+hg20110702
+Version:0.0.0+hg20120110
 Release:0
 Summary:Readline support for Go
-Group:  Development/Languages/Other
 License:BSD-2-Clause
-URL:https://bitbucket.org/binet/go-readline/
+Group:  Development/Languages/Other
+Url:https://bitbucket.org/binet/go-readline/
 Source0:go-readline-%{version}.tar.bz2
+# PATCH-FIX-OPENSUSE -- Need different import statements for local build
 Patch0: go-readline-fix-local-imports.patch
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  go-devel
 BuildRequires:  readline-devel
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %{go_provides}
 %{go_requires}
 %{go_disable_brp_strip_static_archive}
@@ -40,9 +47,6 @@
 %check
 %{go_make_test}
 
-%clean
-rm -rf %{buildroot}
-
 %files
 %defattr(-,root,root,-)
 %doc README

++ go-readline-0.0.0+hg20110702.tar.bz2 - 
go-readline-0.0.0+hg20120110.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/go-readline/readline.go new/go-readline/readline.go
--- old/go-readline/readline.go 2011-07-02 11:50:35.0 +0200
+++ new/go-readline/readline.go 2012-01-10 09:42:15.0 +0100
@@ -12,32 +12,52 @@
  #include string.h
  #include readline/readline.h
  #include readline/history.h
- */
+
+ char* _go_readline_strarray_at(char **strarray, int idx) 
+ {
+   return strarray[idx];
+ }
+
+ int _go_readline_strarray_len(char **strarray)
+ {
+   int sz = 0;
+   while (strarray[sz] != NULL) {
+ sz += 1;
+   }
+   return sz;
+ }
+*/
 import C
 import unsafe
-import os
+import syscall
 
 func ReadLine(prompt *string) *string {
-   var p *C.char;
+   var p *C.char
 
//readline allows an empty prompt(NULL)
-   if prompt != nil { p = C.CString(*prompt) }
+   if prompt != nil {
+   p = C.CString(*prompt)
+   }
 
-   ret := C.readline(p);
+   ret := C.readline(p)
 
-   if p != nil { C.free(unsafe.Pointer(p)) }
+   if p != nil {
+   C.free(unsafe.Pointer(p))
+   }
 
-   if ret == nil { return nil } //EOF
+   if ret == nil {
+   return nil
+   } //EOF
 
-   s := C.GoString(ret);
-   C.free(unsafe.Pointer(ret));
+   s := C.GoString(ret)
+   C.free(unsafe.Pointer(ret))
return s
 }
 
 func AddHistory(s string) {
-   p := C.CString(s);
+   p := C.CString(s)
defer C.free(unsafe.Pointer(p))
-   C.add_history(p);   
+   C.add_history(p)
 }
 
 // Parse and execute single line of a readline init file.
@@ -49,20 +69,26 @@
 
 // Parse a readline initialization file.
 // The default filename is the last filename used.
-func ReadInitFile(s string) os.Errno {
+func ReadInitFile(s string) error {
p := C.CString(s)
defer C.free(unsafe.Pointer(p))
errno := C.rl_read_init_file(p)
-   return os.Errno(errno)
+   if errno == 0 {
+   return nil
+   }
+   return syscall.Errno(errno)

commit go-httplib.go for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package go-httplib.go for openSUSE:Factory 
checked in at 2012-01-19 09:42:11

Comparing /work/SRC/openSUSE:Factory/go-httplib.go (Old)
 and  /work/SRC/openSUSE:Factory/.go-httplib.go.new (New)


Package is go-httplib.go, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/go-httplib.go/go-httplib.go.changes  
2011-10-06 17:21:45.0 +0200
+++ /work/SRC/openSUSE:Factory/.go-httplib.go.new/go-httplib.go.changes 
2012-01-19 09:42:13.0 +0100
@@ -1,0 +2,5 @@
+Tue Dec 13 14:33:48 UTC 2011 - sasc...@suse.de
+
+- Patch to build against weekly.2011-12-02
+
+---
@@ -10 +15 @@
-- patch to build against weekly 2011.06.23
+- Patch to build against weekly.2011-06-23

Old:

  httplib.go-0.0.0+git20110915.tar.bz2
  rpmlintrc

New:

  httplib.go-0.0.0+git20111213.tar.bz2
  httplib.go-weekly-fixes.patch



Other differences:
--
++ go-httplib.go.spec ++
--- /var/tmp/diff_new_pack.F7Hgwl/_old  2012-01-19 09:42:14.0 +0100
+++ /var/tmp/diff_new_pack.F7Hgwl/_new  2012-01-19 09:42:14.0 +0100
@@ -2,7 +2,7 @@
 # spec file for package go-httplib.go
 #
 # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
-# Copyright (c), 2011, Sascha Peilicke sasc...@gmx.de
+# Copyright (c) 2011 Sascha Peilicke sasc...@gmx.de
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,15 +17,15 @@
 #
 
 
-
 Name:   go-httplib.go
-Version:0.0.0+git20110915
-Release:1
+Version:0.0.0+git20111213
+Release:0
 Summary:A simple, low-level http library for Go
-Group:  Development/Languages/Other
 License:MIT
+Group:  Development/Languages/Other
 Url:https://github.com/hoisie/httplib.go
 Source0:httplib.go-%{version}.tar.bz2
+Patch0: httplib.go-weekly-fixes.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  go-devel
 %{go_provides}
@@ -44,18 +44,15 @@
 
 %prep
 %setup -q -n httplib.go
+%patch0 -p1
 
 %build
-
 %install
 %{go_make_install}
 
 %check
 %{go_make_test}
 
-%clean
-rm -rf %{buildroot}
-
 %files
 %defattr(-,root,root,-)
 %doc Readme.md LICENSE

++ httplib.go-0.0.0+git20110915.tar.bz2 - 
httplib.go-0.0.0+git20111213.tar.bz2 ++

++ httplib.go-weekly-fixes.patch ++
diff -ru a/httplib.go b/httplib.go
--- a/httplib.go2011-12-13 15:24:59.776471311 +0100
+++ b/httplib.go2011-12-13 15:33:00.687482771 +0100
@@ -1,15 +1,16 @@
 package httplib
 
 import (
-bytes
-crypto/tls
-http
-io
-io/ioutil
-net
-os
-strings
-url
+   bytes
+   crypto/tls
+   io
+   io/ioutil
+   net
+   net/http
+   net/http/httputil
+   net/url
+   os
+   strings
 )
 
 var defaultUserAgent = httplib.go
@@ -17,239 +18,239 @@
 var debugprint = false
 
 type Client struct {
-conn*http.ClientConn
-lastURL *url.URL
+   conn*httputil.ClientConn
+   lastURL *url.URL
 }
 
 type nopCloser struct {
-io.Reader
+   io.Reader
 }
 
-func (nopCloser) Close() os.Error { return nil }
+func (nopCloser) Close() error { return nil }
 
 func getNopCloser(buf *bytes.Buffer) nopCloser {
-return nopCloser{buf}
+   return nopCloser{buf}
 }
 
 func hasPort(s string) bool { return strings.LastIndex(s, :)  
strings.LastIndex(s, ]) }
 
-func newConn(url *url.URL) (*http.ClientConn, os.Error) {
-addr := url.Host
-//just set the default scheme to http
-if url.Scheme ==  {
-url.Scheme = http
-}
-if !hasPort(addr) {
-addr += : + url.Scheme
-}
-var conn net.Conn
-var err os.Error
-if url.Scheme == http {
-conn, err = net.Dial(tcp, addr)
-if err != nil {
-return nil, err
-}
-} else { // https
-conn, err = tls.Dial(tcp, addr, nil)
-if err != nil {
-return nil, err
-}
-h := url.Host
-if hasPort(h) {
-h = h[0:strings.LastIndex(h, :)]
-}
-if err := conn.(*tls.Conn).VerifyHostname(h); err != nil {
-return nil, err
-}
-}
-
-return http.NewClientConn(conn, nil), nil
-}
-
-func getResponse(rawUrl string, req *http.Request) (*http.ClientConn, 
*http.Response, os.Error) {
-url, err := url.Parse(rawUrl)
-if url.Scheme ==  {
-rawUrl = http://; + rawUrl
-url, err = url.Parse(rawUrl)
-}
-
-if err != nil {
-return nil, nil, err
-}
-req.URL = url
-if debugprint {
-dump, err := 

commit kernel-installation-tapeipl for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package kernel-installation-tapeipl for 
openSUSE:Factory checked in at 2012-01-19 09:42:28

Comparing /work/SRC/openSUSE:Factory/kernel-installation-tapeipl (Old)
 and  /work/SRC/openSUSE:Factory/.kernel-installation-tapeipl.new (New)


Package is kernel-installation-tapeipl, Maintainer is i...@suse.com

Changes:

--- 
/work/SRC/openSUSE:Factory/kernel-installation-tapeipl/kernel-installation-tapeipl.changes
  2011-12-05 12:44:07.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.kernel-installation-tapeipl.new/kernel-installation-tapeipl.changes
 2012-01-19 09:42:30.0 +0100
@@ -1,0 +2,5 @@
+Tue Jan 10 07:58:35 UTC 2012 - co...@suse.com
+
+- GPL is not a spdx.org license, pick GPL-2.0
+
+---



Other differences:
--
++ kernel-installation-tapeipl.spec ++
--- /var/tmp/diff_new_pack.LfJCaS/_old  2012-01-19 09:42:31.0 +0100
+++ /var/tmp/diff_new_pack.LfJCaS/_new  2012-01-19 09:42:31.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package kernel-installation-tapeipl
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,13 +16,12 @@
 #
 
 
-
 Name:   kernel-installation-tapeipl
 BuildRequires:  kernel-source
 Version:MACRO
-Release:1
+Release:0
 Summary:Installation Kernel for IPL from Tape
-License:GPL
+License:GPL-2.0
 Group:  System/Kernel
 AutoReqProv:off
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -36,13 +35,6 @@
 internally to provide the kernel image with tape IPL record for the
 installation CD.
 
-
-
-Authors:
-
-Susanne Oberhauser
-Bernhard Kaindl
-
 %define current_package_name %{name}
 %define kernel_source`rpm -qf /usr/src/linux --qf '%%{name}'`
 


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libdmtx for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libdmtx for openSUSE:Factory checked 
in at 2012-01-19 09:42:32

Comparing /work/SRC/openSUSE:Factory/libdmtx (Old)
 and  /work/SRC/openSUSE:Factory/.libdmtx.new (New)


Package is libdmtx, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libdmtx/libdmtx.changes  2011-09-23 
02:08:07.0 +0200
+++ /work/SRC/openSUSE:Factory/.libdmtx.new/libdmtx.changes 2012-01-19 
09:42:33.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:30:42 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ libdmtx.spec ++
--- /var/tmp/diff_new_pack.998kM8/_old  2012-01-19 09:42:34.0 +0100
+++ /var/tmp/diff_new_pack.998kM8/_new  2012-01-19 09:42:34.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libdmtx
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,15 +15,13 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   libdmtx
 Version:0.7.4
-Release:1
-License:BSD 2 clause
+Release:0
 Summary:Software for reading and writing Data Matrix barcodes
-Url:http://www.libdmtx.org
+License:BSD-2-Clause
 Group:  Development/Libraries/C and C++
+Url:http://www.libdmtx.org
 #Source: 
http://sourceforge.net/projects/libdmtx/files/%{name}/%{version}/%{name}-%{version}.tar.bz2/download
 Source: %{name}-%{version}.tar.bz2
 Patch0: libdmtx-0.7.4.diff
@@ -36,8 +34,8 @@
 its capabilities without extra restrictions or overhead.
 
 %package -n libdmtx0
-License:GPLv2 or later, LGPLv2.1 or later
 Summary:Software for reading and writing Data Matrix barcodes
+License:GPL-2.0+ and LGPL-2.1+
 Group:  Development/Libraries/C and C++
 
 %description -n libdmtx0
@@ -46,8 +44,8 @@
 its capabilities without extra restrictions or overhead.
 
 %package devel
-License:GPLv2 or later, LGPLv2.1 or later
 Summary:Software for reading and writing Data Matrix barcodes
+License:GPL-2.0+ and LGPL-2.1+
 Group:  Development/Libraries/C and C++
 Requires:   libdmtx0 = %{version}
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit go-web.go for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package go-web.go for openSUSE:Factory 
checked in at 2012-01-19 09:42:24

Comparing /work/SRC/openSUSE:Factory/go-web.go (Old)
 and  /work/SRC/openSUSE:Factory/.go-web.go.new (New)


Package is go-web.go, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/go-web.go/go-web.go.changes  2011-10-06 
17:22:01.0 +0200
+++ /work/SRC/openSUSE:Factory/.go-web.go.new/go-web.go.changes 2012-01-19 
09:42:25.0 +0100
@@ -1,0 +2,5 @@
+Tue Dec 13 13:20:21 UTC 2011 - sasc...@suse.de
+
+- Apply fixes for weekly.2011-12-02 changes
+
+---

Old:

  web.go-0.0.0+git20110915.tar.bz2

New:

  web.go-0.0.0+git20111213.tar.bz2
  web.go-weekly-fixes.patch



Other differences:
--
++ go-web.go.spec ++
--- /var/tmp/diff_new_pack.A4whyG/_old  2012-01-19 09:42:26.0 +0100
+++ /var/tmp/diff_new_pack.A4whyG/_new  2012-01-19 09:42:26.0 +0100
@@ -2,7 +2,7 @@
 # spec file for package go-web.go
 #
 # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
-# Copyright (c), 2011, Sascha Peilicke sasc...@gmx.de
+# Copyright (c) 2011 Sascha Peilicke sasc...@gmx.de
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,13 +19,14 @@
 
 
 Name:   go-web.go
-Version:0.0.0+git20110915
-Release:1
+Version:0.0.0+git20111213
+Release:0
 Summary:A simple framework to write webapps in Go
-Group:  Development/Languages/Other
 License:MIT
+Group:  Development/Languages/Other
 Url:http://github.com/hoisie/web.go
 Source0:web.go-%{version}.tar.bz2
+Patch0: web.go-weekly-fixes.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  go-devel
 %{go_provides}
@@ -38,10 +39,12 @@
 
 %prep
 %setup -q -n web.go
+%patch0 -p1
 
 %build
 
 %install
+gofix *.go
 %{go_make_install}
 
 %check

++ web.go-0.0.0+git20110915.tar.bz2 - web.go-0.0.0+git20111213.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/web.go/request.go new/web.go/request.go
--- old/web.go/request.go   2011-10-06 13:50:51.0 +0200
+++ new/web.go/request.go   2011-12-13 10:51:40.0 +0100
@@ -1,7 +1,6 @@
 package web
 
 import (
-container/vector
 fmt
 http
 io
@@ -68,7 +67,6 @@
 
 req := Request{
 Method: hr.Method,
-RawURL: hr.RawURL,
 URL:hr.URL,
 Proto:  hr.Proto,
 ProtoMajor: hr.ProtoMajor,
@@ -140,7 +138,6 @@
 }
 
 func parseForm(m map[string][]string, query string) (err os.Error) {
-data := make(map[string]*vector.StringVector)
 for _, kv := range strings.Split(query, ) {
 kvPair := strings.SplitN(kv, =, 2)
 
@@ -154,16 +151,11 @@
 err = e
 }
 
-vec, ok := data[key]
+vec, ok := m[key]
 if !ok {
-vec = new(vector.StringVector)
-data[key] = vec
+vec = []string{}
 }
-vec.Push(value)
-}
-
-for k, vec := range data {
-m[k] = vec.Copy()
+m[key] = append(vec, value)
 }
 
 return
@@ -208,17 +200,19 @@
 if !ok {
 return os.NewError(Missing Boundary)
 }
+
 reader := multipart.NewReader(r.Body, boundary)
 r.Files = make(map[string]filedata)
 for {
 part, err := reader.NextPart()
+if part == nil  err == os.EOF {
+break
+}
+
 if err != nil {
 return err
 }
 
-if part == nil {
-break
-}
 //read the data
 data, _ := ioutil.ReadAll(part)
 //check for the 'filename' param
@@ -234,8 +228,8 @@
 if params[filename] !=  {
 r.Files[name] = filedata{params[filename], data}
 } else {
-var params vector.StringVector = r.FullParams[name]
-params.Push(string(data))
+var params []string = r.FullParams[name]
+params = append(params, string(data))
 r.FullParams[name] = params
 }
 
@@ -244,6 +238,7 @@
 return badStringError{unknown Content-Type, ct}
 }
 }
+
 if queryParams !=  {
 err = parseForm(r.FullParams, queryParams)
 if err != nil {
diff -urN '--exclude=CVS' 

commit libgdiplus0 for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libgdiplus0 for openSUSE:Factory 
checked in at 2012-01-19 09:42:41

Comparing /work/SRC/openSUSE:Factory/libgdiplus0 (Old)
 and  /work/SRC/openSUSE:Factory/.libgdiplus0.new (New)


Package is libgdiplus0, Maintainer is mono-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/libgdiplus0/libgdiplus0.changes  2011-09-23 
02:08:19.0 +0200
+++ /work/SRC/openSUSE:Factory/.libgdiplus0.new/libgdiplus0.changes 
2012-01-19 09:42:43.0 +0100
@@ -1,0 +2,11 @@
+Mon Jan 16 14:20:33 UTC 2012 - cdenic...@suse.com
+
+- license update: LGPL-2.1+ or MPL-1.1; MIT
+
+
+---
+Thu Jan 12 11:30:42 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ libgdiplus0.spec ++
--- /var/tmp/diff_new_pack.MM2VGz/_old  2012-01-19 09:42:44.0 +0100
+++ /var/tmp/diff_new_pack.MM2VGz/_new  2012-01-19 09:42:44.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libgdiplus0
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,19 +15,17 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 %define real_name libgdiplus
 # There may be strange bugs when using the system cairo
 %define system_cairo 0
 
 Name:   libgdiplus0
 Version:2.10
-Release:1
-License:LGPLv2.1 ; MPL ; MIT License (or similar)
+Release:0
 Url:http://go-mono.org/
 Source0:%{real_name}-%{version}.tar.bz2
 Summary:Open Source Implementation of the GDI+ API
+License:LGPL-2.1+ or MPL-1.1; MIT
 Group:  Development/Libraries/Other
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Obsoletes:  libgdiplus-devel

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libgluezilla0 for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libgluezilla0 for openSUSE:Factory 
checked in at 2012-01-19 09:42:46

Comparing /work/SRC/openSUSE:Factory/libgluezilla0 (Old)
 and  /work/SRC/openSUSE:Factory/.libgluezilla0.new (New)


Package is libgluezilla0, Maintainer is mono-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/libgluezilla0/libgluezilla0.changes  
2011-09-23 02:08:20.0 +0200
+++ /work/SRC/openSUSE:Factory/.libgluezilla0.new/libgluezilla0.changes 
2012-01-19 09:42:47.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:30:43 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ libgluezilla0.spec ++
--- /var/tmp/diff_new_pack.FVn7Ur/_old  2012-01-19 09:42:48.0 +0100
+++ /var/tmp/diff_new_pack.FVn7Ur/_new  2012-01-19 09:42:48.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package libgluezilla0 (Version 2.6)
+# spec file for package libgluezilla0
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,21 +15,20 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 %define real_name gluezilla
 
 Name:   libgluezilla0
 Version:2.6
-Release:6
-License:LGPLv2.0 ; MPL ..
+Release:0
 Url:http://www.mono-project.com
 Source0:%{real_name}-%{version}.tar.bz2
 Patch0: xulrunner-1.9.2.patch
 Summary:Glue library for Winforms Web Control
+License:LGPL-2.0 ; MPL-1.1
 Group:  Development/Languages/Mono
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  gcc-c++ gtk2-devel
+BuildRequires:  gcc-c++
+BuildRequires:  gtk2-devel
   suse  
 %if 0%{?suse_version}
 %if %suse_version  1130
@@ -42,18 +41,23 @@
 BuildRequires:  mozilla-xulrunner190-devel
 %endif
 %if %suse_version == 1030
-BuildRequires:  mozilla-nspr-devel mozilla-xulrunner181-devel
+BuildRequires:  mozilla-nspr-devel
+BuildRequires:  mozilla-xulrunner181-devel
 %endif
 %if %suse_version == 1020
-BuildRequires:  mozilla-nspr-devel mozilla-xulrunner181-devel
+BuildRequires:  mozilla-nspr-devel
+BuildRequires:  mozilla-xulrunner181-devel
 %endif
 %if %sles_version == 10
-BuildRequires:  gecko-sdk mozilla-nspr-devel mozilla-xulrunner
+BuildRequires:  gecko-sdk
+BuildRequires:  mozilla-nspr-devel
+BuildRequires:  mozilla-xulrunner
 %endif
 %if %sles_version == 9
 # Broken: missing nsEmbedCID.h
 # mozilla-devel-1.7.8-5.13
-BuildRequires:  mozilla-devel pkgconfig
+BuildRequires:  mozilla-devel
+BuildRequires:  pkgconfig
 %endif
 %endif
   fedora  

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libqjson for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libqjson for openSUSE:Factory 
checked in at 2012-01-19 09:42:57

Comparing /work/SRC/openSUSE:Factory/libqjson (Old)
 and  /work/SRC/openSUSE:Factory/.libqjson.new (New)


Package is libqjson, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libqjson/libqjson.changes2011-09-23 
02:09:19.0 +0200
+++ /work/SRC/openSUSE:Factory/.libqjson.new/libqjson.changes   2012-01-19 
09:42:58.0 +0100
@@ -0,0 +1,5 @@
+---
+Thu Jan 12 11:30:44 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+



Other differences:
--
++ libqjson.spec ++
--- /var/tmp/diff_new_pack.nR4zBV/_old  2012-01-19 09:42:59.0 +0100
+++ /var/tmp/diff_new_pack.nR4zBV/_new  2012-01-19 09:42:59.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package libqjson (Version 0.7.1)
+# spec file for package libqjson
 #
-# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,18 +15,15 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   libqjson
 Summary:QJson is a qt-based library that maps JSON data to QVariant 
objects
+License:LGPL-2.1+
+Group:  Development/Libraries/C and C++
 Version:0.7.1
-Release:1
-License:LGPL
+Release:0
 Url:http://qjson.sourceforge.net/
 %define svn_rev 1058132
 Source: qjson-svn-r%{svn_rev}.tar.bz2
-Group:  Development/Libraries/C and C++
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  cmake
 BuildRequires:  libqt4-devel
@@ -47,7 +44,6 @@
 %package -n libqjson0
 Summary:QJson is a qt-based library that maps JSON data to QVariant 
objects
 Group:  Development/Libraries/C and C++
-License:LGPL
 
 %description -n libqjson0
 JSON (JavaScript Object Notation) is a lightweight data-interchange format.
@@ -63,7 +59,6 @@
 %package devel
 Summary:Development files for QJson
 Group:  Development/Libraries/C and C++
-License:LGPL
 Requires:   %{soname} = %{version}
 
 %description devel

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libquvi for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libquvi for openSUSE:Factory checked 
in at 2012-01-19 09:43:01

Comparing /work/SRC/openSUSE:Factory/libquvi (Old)
 and  /work/SRC/openSUSE:Factory/.libquvi.new (New)


Package is libquvi, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libquvi/libquvi.changes  2012-01-17 
16:10:58.0 +0100
+++ /work/SRC/openSUSE:Factory/.libquvi.new/libquvi.changes 2012-01-19 
09:43:02.0 +0100
@@ -1,0 +2,6 @@
+Tue Jan 17 12:37:03 UTC 2012 - vu...@opensuse.org
+
+- Always build against lua-devel: lua 5.2 on 12.2/Factory doesn't
+  seem to be an issue.
+
+---



Other differences:
--
++ libquvi.spec ++
--- /var/tmp/diff_new_pack.CdBpt2/_old  2012-01-19 09:43:03.0 +0100
+++ /var/tmp/diff_new_pack.CdBpt2/_new  2012-01-19 09:43:03.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libquvi
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,17 +15,18 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define soname 7
 
 Name:   libquvi
 Version:0.4.0
-Release:1
+Release:0
 Summary:Library to parse flash media stream URLs
-Group:  System/Libraries
 License:LGPL-2.1+
+Group:  System/Libraries
 Url:http://quvi.sourceforge.net/
 Source: %{name}-%{version}.tar.bz2
-BuildRequires:  lua51-devel
+BuildRequires:  lua-devel = 5.1
 # For pkgconfig() Provides
 BuildRequires:  pkg-config
 BuildRequires:  pkgconfig(libcurl) = 7.18.2

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libquvi-scripts for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libquvi-scripts for openSUSE:Factory 
checked in at 2012-01-19 09:43:05

Comparing /work/SRC/openSUSE:Factory/libquvi-scripts (Old)
 and  /work/SRC/openSUSE:Factory/.libquvi-scripts.new (New)


Package is libquvi-scripts, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libquvi-scripts/libquvi-scripts.changes  
2012-01-11 15:38:36.0 +0100
+++ /work/SRC/openSUSE:Factory/.libquvi-scripts.new/libquvi-scripts.changes 
2012-01-19 09:43:07.0 +0100
@@ -1,0 +2,12 @@
+Tue Jan 17 12:34:24 UTC 2012 - vu...@opensuse.org
+
+- Always build against lua-devel: lua 5.2 on 12.2/Factory doesn't
+  seem to be an issue.
+
+---
+Wed Jan 11 10:22:34 UTC 2012 - pascal.ble...@opensuse.org
+
+- fix build on  factory
+- also package nsfw scripts, but into a separate subpackage
+
+---



Other differences:
--
++ libquvi-scripts.spec ++
--- /var/tmp/diff_new_pack.fVCQgX/_old  2012-01-19 09:43:08.0 +0100
+++ /var/tmp/diff_new_pack.fVCQgX/_new  2012-01-19 09:43:08.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libquvi-scripts
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,15 +15,16 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   libquvi-scripts
 Version:0.4.2
-Release:1
+Release:0
 Summary:Lua scripts used by libquvi
-Group:  Productivity/Multimedia/Other
 License:LGPL-2.1+
+Group:  Productivity/Multimedia/Other
 Url:http://quvi.sourceforge.net/
 Source: %{name}-%{version}.tar.bz2
-BuildRequires:  lua51-devel
+BuildRequires:  lua-devel = 5.1
 # For pkgconfig() Provides
 BuildRequires:  pkg-config
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -43,23 +44,46 @@
 parsing the media details. Some additional utility scripts are also
 included.
 
+%package nsfw
+Summary:Not Safe For Work Lua scripts used by libquvi
+Group:  Productivity/Multimedia/Other
+Requires:   %{name} = %{version}
+
+%description nsfw
+Website fetching scripts used by %{name} that are marked as NSFW
+(Not Safe For Work).
+
 %prep
 %setup -q
 
 %build
-%configure
+%configure \
+--with-nsfw
+
 make %{?_smp_mflags}
 
 %install
 %make_install
 find %{buildroot}%{_libdir} -name '*.la' -type f -delete -print
 
-%files
+EXCL=$PWD/exclude.lst
+NSFW=$PWD/nsfw.lst
+echo -n $EXCL
+echo -n $NSFW
+perl -n -e 'print $1,\n if /^if WITH_NSFW/ .. /endif/ and 
m,\b(lua/website/.+\.lua),' share/Makefile.am | while read f; do
+echo %exclude %{_datadir}/libquvi-scripts/$f $EXCL
+echo %{_datadir}/libquvi-scripts/$f $NSFW
+done
+
+%files -f exclude.lst
 %defattr(-,root,root)
 %doc AUTHORS ChangeLog COPYING NEWS README
 %{_datadir}/libquvi-scripts/
 %{_mandir}/man7/libquvi-scripts.7%{?ext_man}
 
+%files nsfw -f nsfw.lst
+%defattr(-,root,root)
+
 %files devel
 %defattr(-,root,root)
 %{_libdir}/pkgconfig/libquvi-scripts.pc

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit librcps for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package librcps for openSUSE:Factory checked 
in at 2012-01-19 09:43:10

Comparing /work/SRC/openSUSE:Factory/librcps (Old)
 and  /work/SRC/openSUSE:Factory/.librcps.new (New)


Package is librcps, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/librcps/librcps.changes  2011-11-23 
19:35:59.0 +0100
+++ /work/SRC/openSUSE:Factory/.librcps.new/librcps.changes 2012-01-19 
09:43:12.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:30:45 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ librcps.spec ++
--- /var/tmp/diff_new_pack.tfkJ2c/_old  2012-01-19 09:43:13.0 +0100
+++ /var/tmp/diff_new_pack.tfkJ2c/_new  2012-01-19 09:43:13.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package librcps
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,19 +15,17 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   librcps
 Version:0.3
-Release:1
-License:GPL
+Release:0
 Summary:A open source library for resource constrained project 
scheduling
-Url:http://www.librcps.org/
+License:GPL-2.0+
 Group:  Development/Libraries/C and C++
+Url:http://www.librcps.org/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source0:%{name}-%{version}.tar.bz2
-BuildRequires:  libtool texlive-latex
+BuildRequires:  libtool
+BuildRequires:  texlive-latex
 
 %description
 A versatile, powerful and fast open source library for resource constrained 
project scheduling
@@ -39,7 +37,6 @@
 
 
 %package devel
-License:GPL
 Summary:Development and Include Files for libraw1394
 Group:  Development/Libraries/C and C++
 Requires:   librcps0 = %{version}
@@ -53,7 +50,6 @@
 Robert Lemmen rober...@semistable.com
 
 %package -n librcps0
-License:GPL
 Summary:Development and Include Files for libraw1394
 Group:  Development/Libraries/C and C++
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libreadline-java for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libreadline-java for 
openSUSE:Factory checked in at 2012-01-19 09:43:14

Comparing /work/SRC/openSUSE:Factory/libreadline-java (Old)
 and  /work/SRC/openSUSE:Factory/.libreadline-java.new (New)


Package is libreadline-java, Maintainer is 
bnc-team-j...@forge.provo.novell.com

Changes:

--- /work/SRC/openSUSE:Factory/libreadline-java/libreadline-java.changes
2011-09-23 02:09:51.0 +0200
+++ /work/SRC/openSUSE:Factory/.libreadline-java.new/libreadline-java.changes   
2012-01-19 09:43:15.0 +0100
@@ -1,0 +2,6 @@
+Thu Jan 12 19:48:34 UTC 2012 - andreas.stie...@gmx.de
+
+- remove libreadline-java-java14compat.patch
+  ( -C -ftarget=1.4 not supported by current javac )
+
+---

Old:

  libreadline-java-java14compat.patch



Other differences:
--
++ libreadline-java.spec ++
--- /var/tmp/diff_new_pack.Xeujne/_old  2012-01-19 09:43:16.0 +0100
+++ /var/tmp/diff_new_pack.Xeujne/_new  2012-01-19 09:43:16.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package libreadline-java (Version 0.8.0)
+# spec file for package libreadline-java
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -14,34 +14,36 @@
 
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
-
-# norootforbuild
 # icecream 0
 
 
 Name:   libreadline-java
-BuildRequires:  fastjar gjdoc java-1_4_2-gcj-compat-devel readline-devel 
termcap unzip xerces-j2
+BuildRequires:  fastjar
+BuildRequires:  gjdoc
+BuildRequires:  java-1_4_2-gcj-compat-devel
+BuildRequires:  readline-devel
+BuildRequires:  termcap
+BuildRequires:  unzip
+BuildRequires:  xerces-j2
 %define name   libreadline-java
 %define version0.8.0
 %define readline_ver   4.3
 %define release9jpp
 %define sectionfree
 Version:0.8.0
-Release:256
+Release:0
 Summary:Java Wrapper for the GNU Readline Library
 License:LGPL-2.1+
+Group:  Development/Libraries/Java
 Source0:
http://download.sourceforge.net/java-readline/libreadline-java-0.8.0-src.tar.gz
 Source1:baselibs.conf
-Patch0: %{name}-java14compat.patch
-Patch1: %{name}-%{version}-missing-return-type.patch
+Patch1: libreadline-java-0.8.0-missing-return-type.patch
 Url:http://java-readline.sf.net/
 # Requires:readline = %{readline_ver}
 PreReq: /sbin/ldconfig
 Provides:   java_readline
 Provides:   gnu.readline
-Group:  Development/Libraries/Java
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-AutoReqProv:on
 
 %description
 Java-Readline is a port of GNU Readline for Java.  To be more precise,
@@ -50,7 +52,6 @@
 
 
 %package javadoc
-License:LGPL-2.1+
 PreReq: coreutils
 Summary:Javadoc for libreadline-java
 Group:  Development/Libraries/Java
@@ -66,7 +67,6 @@
 
 %prep
 %setup -q -n %{name}-%{version}
-%patch0
 %patch1 -p1
 find . -name *.jar -exec rm -f {} \;
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libspnav for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libspnav for openSUSE:Factory 
checked in at 2012-01-19 09:43:18

Comparing /work/SRC/openSUSE:Factory/libspnav (Old)
 and  /work/SRC/openSUSE:Factory/.libspnav.new (New)


Package is libspnav, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libspnav/libspnav.changes2011-09-23 
02:10:51.0 +0200
+++ /work/SRC/openSUSE:Factory/.libspnav.new/libspnav.changes   2012-01-19 
09:43:20.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:30:45 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ libspnav.spec ++
--- /var/tmp/diff_new_pack.HhkJRl/_old  2012-01-19 09:43:20.0 +0100
+++ /var/tmp/diff_new_pack.HhkJRl/_new  2012-01-19 09:43:20.0 +0100
@@ -1,20 +1,28 @@
 #
 # spec file for package libspnav
 #
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c) 2009,2011 Herbert Graeber
 #
-# This file and all modifications and additions to the pristine
-# package are under the same license as the package itself.
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An Open Source License is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
 
 Name:  libspnav
 Version:   0.2.2
 Release:   0
 Summary:   Library for accessing 3D connexion devices
+License:BSD-3-Clause
 Group: Hardware/Other
-License:   BSD
 Url:   http://sourceforge.net/projects/spacenav/
 Source:%{name}-%{version}.tar.bz2
 BuildRoot: %{_tmppath}/%{name}-%{version}-build

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libvirt for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libvirt for openSUSE:Factory checked 
in at 2012-01-19 09:43:21

Comparing /work/SRC/openSUSE:Factory/libvirt (Old)
 and  /work/SRC/openSUSE:Factory/.libvirt.new (New)


Package is libvirt, Maintainer is jfeh...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/libvirt/libvirt.changes  2012-01-05 
13:51:27.0 +0100
+++ /work/SRC/openSUSE:Factory/.libvirt.new/libvirt.changes 2012-01-19 
09:43:24.0 +0100
@@ -1,0 +2,16 @@
+Wed Jan 11 09:32:28 MST 2012 - jfeh...@suse.com
+
+- During configure, libvirt checks for availability of iptables
+  binary and doesn't actually use anything from iptables-devel
+  package, hence only need 'BuildRequires: iptables'.
+
+---
+Mon Jan  9 15:45:33 MST 2012 - jfeh...@suse.com
+
+- Update to libvirt 0.9.9
+  - Add new API virDomain{S,G}etInterfaceParameters
+  - Add new API virDomain{G,S}etNumaParameters
+  - Add support for ppc64 qemu
+  - Support Xen domctl v8
+
+---

Old:

  10404671-systemd-build-fix.patch
  478a4d07-systemd-build-fix.patch
  ae1232b2-CVE-2011-4600.patch
  libvirt-0.9.8.tar.bz2
  xen-domctl-ver8.patch

New:

  9ae4ac7a-PolicyKit.patch
  libvirt-0.9.9.tar.bz2



Other differences:
--
++ libvirt.spec ++
--- /var/tmp/diff_new_pack.mkcqWl/_old  2012-01-19 09:43:26.0 +0100
+++ /var/tmp/diff_new_pack.mkcqWl/_new  2012-01-19 09:43:26.0 +0100
@@ -263,12 +263,13 @@
 %if %{with_netcf}
 BuildRequires:  netcf-devel = 0.1.4
 %endif
+%define with_netcontrol 1
 %if %{with_netcontrol}
 BuildRequires:  libnetcontrol-devel = 0.2.0
 %endif
 %if %{with_network}
 BuildRequires:  dnsmasq = 2.41
-BuildRequires:  iptables-devel
+BuildRequires:  iptables
 BuildRequires:  radvd
 %endif
 %if %{with_nwfilter}
@@ -323,7 +324,7 @@
 License:LGPL-2.1+
 Group:  Development/Libraries/C and C++
 AutoReqProv:yes
-Version:0.9.8
+Version:0.9.9
 Release:1
 Summary:A C toolkit to interact with the virtualization capabilities 
of Linux
 Conflicts:  kvm  0.14.1
@@ -397,15 +398,12 @@
 Source2:libvirtd-relocation-server.fw
 Source99:   baselibs.conf
 # Upstream patches
-Patch0: ae1232b2-CVE-2011-4600.patch
-Patch1: 478a4d07-systemd-build-fix.patch
-Patch2: 10404671-systemd-build-fix.patch
+Patch0: 9ae4ac7a-PolicyKit.patch
 # Need to go upstream
 Patch100:   xen-name-for-devid.patch
 Patch101:   clone.patch
 Patch102:   xen-pv-cdrom.patch
-Patch103:   xen-domctl-ver8.patch
-Patch104:   AF_PACKET.patch
+Patch103:   AF_PACKET.patch
 # Our patches
 Patch200:   libvirtd-defaults.patch
 Patch201:   use-init-script-redhat.patch
@@ -541,13 +539,10 @@
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
 %patch100 -p1
 %patch101
 %patch102 -p1
 %patch103 -p1
-%patch104 -p1
 %patch200 -p1
 %patch201 -p1
 %patch202 -p1

++ 9ae4ac7a-PolicyKit.patch ++
commit 9ae4ac7ac07d872cd32d0a3a1b1b44730b04bda7
Author: Jim Fehlig jfeh...@suse.com
Date:   Tue Jan 3 11:35:06 2012 -0700

PolicyKit: Check auth before asking client to obtain it

I previously mentioned [1] a PolicyKit issue where libvirt would
proceed with authentication even though polkit-auth failed:

testusr xen134:~ virsh list --all
Attempting to obtain authorization for org.libvirt.unix.manage.
polkit-grant-helper: given auth type (8 - yes) is bogus
Failed to obtain authorization for org.libvirt.unix.manage.
 Id Name State
--
  0 Domain-0 running
  - sles11sp1-pv shut off

AFAICT, libvirt attempts to obtain a privilege it already has,
causing polkit-auth to fail with above message.  Instead of calling
obtain and then checking auth, IMO the workflow should be for the
server to check auth first, and if that fails ask the client to
obtain it and check again.  This workflow also allows for checking
only successful exit of polkit-auth in virConnectAuthGainPolkit().

[1] https://www.redhat.com/archives/libvir-list/2011-December/msg00837.html

Index: libvirt-0.9.9/src/libvirt.c
===
--- libvirt-0.9.9.orig/src/libvirt.c
+++ libvirt-0.9.9/src/libvirt.c
@@ -119,7 +119,7 @@ static int virConnectAuthGainPolkit(cons
 
 cmd = virCommandNewArgList(POLKIT_AUTH, --obtain, privilege, NULL);
 if (virCommandRun(cmd, status)  0 ||
-status  1)
+status  0)
 goto cleanup;
 
 ret = 0;
Index: 

commit openstack-quantum for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package openstack-quantum for 
openSUSE:Factory checked in at 2012-01-19 09:43:32

Comparing /work/SRC/openSUSE:Factory/openstack-quantum (Old)
 and  /work/SRC/openSUSE:Factory/.openstack-quantum.new (New)


Package is openstack-quantum, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/openstack-quantum/openstack-quantum.changes  
2012-01-11 15:38:41.0 +0100
+++ /work/SRC/openSUSE:Factory/.openstack-quantum.new/openstack-quantum.changes 
2012-01-19 09:43:33.0 +0100
@@ -1,0 +2,6 @@
+Tue Jan 10 13:53:17 UTC 2012 - cfarr...@suse.com
+
+- license update: Apache-2.0 and GPL-3.0+
+  Use SPDX syntax and add GPL-3.0+ (aggregation) because of rfc.sh
+
+---



Other differences:
--
++ openstack-quantum.spec ++
--- /var/tmp/diff_new_pack.fjqA7n/_old  2012-01-19 09:43:33.0 +0100
+++ /var/tmp/diff_new_pack.fjqA7n/_new  2012-01-19 09:43:33.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package openstack-quantum
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -11,11 +11,11 @@
 # case the license is the MIT License). An Open Source License is a
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
-#
+
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# options to forcefully build with/without vcs
+
 %bcond_with from_vcs
 %bcond_with no_from_vcs
 
@@ -35,7 +35,7 @@
 Name:   openstack-quantum
 Version:0.1
 Release:0
-License:Apache License 2.0
+License:Apache-2.0 and GPL-3.0+
 Summary:A virtual network manager %{vcs_summary_warn}
 Url:https://github.com/openstack/quantum
 Group:  Development/Languages/Python

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit pam_ssh for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package pam_ssh for openSUSE:Factory checked 
in at 2012-01-19 09:43:46

Comparing /work/SRC/openSUSE:Factory/pam_ssh (Old)
 and  /work/SRC/openSUSE:Factory/.pam_ssh.new (New)


Package is pam_ssh, Maintainer is vci...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/pam_ssh/pam_ssh.changes  2011-11-28 
12:55:33.0 +0100
+++ /work/SRC/openSUSE:Factory/.pam_ssh.new/pam_ssh.changes 2012-01-19 
09:43:48.0 +0100
@@ -1,0 +2,12 @@
+Thu Jan 12 15:57:39 UTC 2012 - vci...@suse.com
+
+- added patch that prevents segfault when empty passphrase is
+  supplied (bnc#741541)
+
+---
+Mon Nov 28 11:47:01 UTC 2011 - jeng...@medozas.de
+
+- Remove redundant/unwanted tags/section (cf. specfile guidelines)
+- Use %_smp_mflags for parallel building
+
+---

New:

  pam_ssh-1.97-empty_passphrase_segfault.patch



Other differences:
--
++ pam_ssh.spec ++
--- /var/tmp/diff_new_pack.phklDF/_old  2012-01-19 09:43:49.0 +0100
+++ /var/tmp/diff_new_pack.phklDF/_new  2012-01-19 09:43:49.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package pam_ssh
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,20 +16,24 @@
 #
 
 
-
 Name:   pam_ssh
-BuildRequires:  libtool openssh openssl-devel pam-devel
-License:BSD3c(or similar)
-Group:  Productivity/Networking/SSH
+BuildRequires:  libtool
+BuildRequires:  openssh
+BuildRequires:  openssl-devel
+BuildRequires:  pam-devel
 Version:1.97
 Release:0
 Summary:PAM Module for SSH Authentication
+License:BSD-3-Clause
+Group:  Productivity/Networking/SSH
 Url:http://sourceforge.net/projects/pam-ssh/
 Source: %{name}-%{version}.tar.bz2
 Source2:baselibs.conf
 Patch0: pam_ssh-double-free.patch
 Patch1: pam_ssh-1.97-setgid.patch
 Patch2: pam_ssh-1.97-sigmask.patch
+# PATCH-FIX-OPENSUSE crashed on EOF passphrase (bnc#741541)
+Patch3: pam_ssh-1.97-empty_passphrase_segfault.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -50,16 +54,15 @@
 %patch0 -p1
 %patch1 -p1
 %patch2 -p0
+%patch3 -p1
 
 %build
 %{suse_update_config -f}
 autoreconf --verbose --force --install
-CFLAGS=$RPM_OPT_FLAGS -fno-strict-aliasing  \
-./configure --libdir=/%{_lib} \
---with-pamdir=/%{_lib}/security \
---prefix=%{_prefix} \
-   --mandir=%{_mandir}
-make
+export CFLAGS=$RPM_OPT_FLAGS -fno-strict-aliasing
+%configure --libdir=/%{_lib} \
+--with-pamdir=/%{_lib}/security
+make %{?_smp_mflags}
 
 %install
 install -d 755 $RPM_BUILD_ROOT/%{_lib}/security
@@ -67,9 +70,6 @@
 install -d 755 $RPM_BUILD_ROOT%{_mandir}/man8
 install -m 644 pam_ssh.8 $RPM_BUILD_ROOT%{_mandir}/man8/
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(444,root,root,755)
 %doc README TODO NEWS

++ pam_ssh-1.97-empty_passphrase_segfault.patch ++
--- pam_ssh-1.92.orig/pam_get_pass.c2004-02-19 19:59:05.0 +0100
+++ pam_ssh-1.92/pam_get_pass.c 2009-04-18 13:51:10.0 +0200
@@ -63,6 +63,8 @@
retval = conv-conv(1, msgs, resp, conv-appdata_ptr);
if (retval != PAM_SUCCESS)
return retval;
+   if (resp[0].resp == NULL)
+   return PAM_AUTHTOK_RECOVERY_ERR;
retval = pam_set_item(pamh, PAM_AUTHTOK, resp[0].resp);
if (retval != PAM_SUCCESS)
return retval;

++ pam_ssh-1.97-sigmask.patch ++
--- /var/tmp/diff_new_pack.phklDF/_old  2012-01-19 09:43:49.0 +0100
+++ /var/tmp/diff_new_pack.phklDF/_new  2012-01-19 09:43:49.0 +0100
@@ -1,7 +1,8 @@
-diff -up pam_ssh.c.orig-sigmask pam_ssh.c
 pam_ssh.c.orig-sigmask 2011-10-30 16:38:41.365415881 +0100
-+++ pam_ssh.c  2011-10-30 16:39:09.396068291 +0100
-@@ -554,6 +554,7 @@ pam_sm_open_session(pam_handle_t *pamh,
+Index: pam_ssh.c
+===
+--- pam_ssh.c.orig 2012-01-12 12:20:00.108458104 +0100
 pam_ssh.c  2012-01-12 16:00:01.650388767 +0100
+@@ -554,6 +554,7 @@
  time_t file_ctime;  /* creation time of per-agent file */
  time_t time_now;/* current time */
  time_t time_up; /* uptime */
@@ -9,7 +10,7 @@
  
  memset(options, 0, sizeof options);
  

commit pciutils-ids for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package pciutils-ids for openSUSE:Factory 
checked in at 2012-01-19 09:43:51

Comparing /work/SRC/openSUSE:Factory/pciutils-ids (Old)
 and  /work/SRC/openSUSE:Factory/.pciutils-ids.new (New)


Package is pciutils-ids, Maintainer is vci...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/pciutils-ids/pciutils-ids.changes
2012-01-11 15:38:43.0 +0100
+++ /work/SRC/openSUSE:Factory/.pciutils-ids.new/pciutils-ids.changes   
2012-01-19 09:43:54.0 +0100
@@ -2 +2 @@
-Sat Jan  7 03:40:08 CET 2012 - autobu...@suse.de
+Sat Jan 14 18:40:05 CET 2012 - autobu...@suse.de
@@ -4 +4 @@
-- automated update on 2012-01-07
+- automated update on 2012-01-14



Other differences:
--
++ pciutils-ids.spec ++
--- /var/tmp/diff_new_pack.Hg9s5m/_old  2012-01-19 09:43:55.0 +0100
+++ /var/tmp/diff_new_pack.Hg9s5m/_new  2012-01-19 09:43:55.0 +0100
@@ -19,7 +19,7 @@
 
 
 Name:   pciutils-ids
-Version:2012.1.6
+Version:2012.1.14
 Release:1
 AutoReqProv:on
 Group:  Hardware/Other

++ pci.ids.bz2 ++
--- /var/tmp/diff_new_pack.Hg9s5m/_old  2012-01-19 09:43:55.0 +0100
+++ /var/tmp/diff_new_pack.Hg9s5m/_new  2012-01-19 09:43:55.0 +0100
@@ -1,11 +1,11 @@
 #
 #  List of PCI ID's
 #
-#  Version: 2012.01.06
-#  Date:2012-01-06 03:15:01
+#  Version: 2012.01.14
+#  Date:2012-01-14 15:34:18
 #
 #  Maintained by Martin Mares m...@ucw.cz and other volunteers from the
-#  PCI ID Project at http://pciids.sf.net/.
+#  PCI ID Project at http://pci-ids.ucw.cz/.
 #
 #  New data are always welcome, especially if they are accurate. If you 
have
 #  anything to contribute, please follow the instructions at the web site.
@@ -1847,7 +1847,7 @@
9806  Wrestler [Radeon HD 6320]
aa00  R600 Audio Device [Radeon HD 2900 Series]
aa08  RV630 audio device [Radeon HD 2600 Series]
-   aa10  RV610 audio device [Radeon HD 2400 PRO]
+   aa10  RV610 HDMI Audio [Radeon HD 2350/2400 Series]
174b aa10  Sapphire HD 2400 PRO audio device
18bc aa10  GeCube Radeon HD 2400 PRO HDCP-capable digital-only 
audio device
aa18  RV670/680 HDMI Audio [Radeon HD 3690/3800 Series]
@@ -1860,14 +1860,19 @@
174b aa38  R700 Audio Device [Radeon HD 4000 Series]
aa50  Cypress HDMI Audio [Radeon HD 5800 Series]
aa58  Juniper HDMI Audio [Radeon HD 5700 Series]
-   aa60  Redwood HDMI Audio [Radeon HD 5600 Series]
+# 5500, 5600 and mobile 5700 series
+   aa60  Redwood HDMI Audio [Radeon HD 5000 Series]
1025 033d  Mobility Radeon HD 5650
1025 0347  Aspire 7740G
-   aa68  Manhattan HDMI Audio [Mobility Radeon HD 5000 Series]
+   aa68  Cedar HDMI Audio [Radeon HD 5400/6300 Series]
1028 aa68  XPS 8300
+   aa80  Cayman/Antilles HDMI Audio [Radeon HD 6900 Series]
aa88  Barts HDMI Audio [Radeon HD 6800 Series]
+# 6500, 6600 and mobile 6700 series
+   aa90  Turks HDMI Audio [Radeon HD 6000 Series]
aa98  Caicos HDMI Audio [Radeon HD 6400 Series]
174b aa98  Sapphire HD 6450 1GB DDR3
+   aaa0  Tahiti XT HDMI Audio [Radeon HD 7970 Series]
ac00  Theater 600 Pro
ac02  TV Wonder HD 600 PCIe
ac12  Theater HD T507 (DVB-T) TV tuner/capture device
@@ -2355,6 +2360,21 @@
1302  Family 11h Processor DRAM Controller
1303  Family 11h Processor Miscellaneous Control
1304  Family 11h Processor Link Control
+   1400  Family 15h (Models 10h-1fh) Processor Function 0
+   1401  Family 15h (Models 10h-1fh) Processor Function 1
+   1402  Family 15h (Models 10h-1fh) Processor Function 2
+   1403  Family 15h (Models 10h-1fh) Processor Function 3
+   1404  Family 15h (Models 10h-1fh) Processor Function 4
+   1405  Family 15h (Models 10h-1fh) Processor Function 5
+   1410  Family 15h (Models 10h-1fh) Processor Root Complex
+   1412  Family 15h (Models 10h-1fh) Processor Root Port
+   1413  Family 15h (Models 10h-1fh) Processor Root Port
+   1414  Family 15h (Models 10h-1fh) Processor Root Port
+   1415  Family 15h (Models 10h-1fh) Processor Root Port
+   1416  Family 15h (Models 10h-1fh) Processor Root Port
+   1417  Family 15h (Models 10h-1fh) Processor Root Port
+   1418  Family 15h (Models 10h-1fh) Processor Root Port
+   1419  Family 15h (Models 10h-1fh) I/O Memory Management Unit
1510  Family 14h Processor Root Complex
1512  Family 14h Processor Root Port
1513  Family 14h Processor Root Port
@@ -3325,6 +3345,12 @@
103c 3249  

commit mobile-broadband-provider-info for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package mobile-broadband-provider-info for 
openSUSE:Factory checked in at 2012-01-19 09:43:28

Comparing /work/SRC/openSUSE:Factory/mobile-broadband-provider-info (Old)
 and  /work/SRC/openSUSE:Factory/.mobile-broadband-provider-info.new (New)


Package is mobile-broadband-provider-info, Maintainer is j...@suse.com

Changes:

--- 
/work/SRC/openSUSE:Factory/mobile-broadband-provider-info/mobile-broadband-provider-info.changes
2011-09-23 02:13:06.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.mobile-broadband-provider-info.new/mobile-broadband-provider-info.changes
   2012-01-19 09:43:29.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:30:47 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ mobile-broadband-provider-info.spec ++
--- /var/tmp/diff_new_pack.WxvOvJ/_old  2012-01-19 09:43:29.0 +0100
+++ /var/tmp/diff_new_pack.WxvOvJ/_new  2012-01-19 09:43:29.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package mobile-broadband-provider-info
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,16 +15,13 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   mobile-broadband-provider-info
 Version:20110511
-Release:1
+Release:0
 Summary:Mobile Service Provider Database
-License:CC Public Domain Dedication
-Url:
http://live.gnome.org/NetworkManager/MobileBroadband/ServiceProviders
+License:SUSE-Public-Domain
 Group:  Productivity/Networking/System
+Url:
http://live.gnome.org/NetworkManager/MobileBroadband/ServiceProviders
 Source0:%{name}-%{version}.tar.bz2
 Source1:rpmlintrc
 BuildRequires:  pkg-config

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit poppler for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package poppler for openSUSE:Factory checked 
in at 2012-01-19 09:44:03

Comparing /work/SRC/openSUSE:Factory/poppler (Old)
 and  /work/SRC/openSUSE:Factory/.poppler.new (New)


Package is poppler, Maintainer is b...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/poppler/poppler-qt.changes   2012-01-11 
15:38:48.0 +0100
+++ /work/SRC/openSUSE:Factory/.poppler.new/poppler-qt.changes  2012-01-19 
09:44:04.0 +0100
@@ -1,0 +2,20 @@
+Mon Jan 16 13:20:26 UTC 2012 - vu...@opensuse.org
+
+- Update to version 0.18.3:
+  + core:
+- Do not fail if we are trying to save a file with Encrypt that
+  has not been modified (kde#288045)
+- Include .otf fonts when finding substitute fonts (fdo#44412)
+- Fix stack overflow in PDFDoc::markObject() (fdo#44660)
+- Include strings.h as we use memcpy (fdo#43558)
+  + utils:
+- pdfunite: Properly initialize globalParams (fdo#44659)
+- pdfseparate: Properly initialize globalParams
+- Fix iniliazialization of GooString arguments
+  + build system:
+- autoconf: Check for cairo-ft and other cairo backends
+  (fdo#43969)
+- Add explicit pkgconfig() BuildRequires, following upstream
+  changes, for: cairo-ft, cairo-pdf, cairo-ps, cairo-svg.
+
+---
poppler.changes: same change

Old:

  poppler-0.18.2.tar.gz

New:

  poppler-0.18.3.tar.gz



Other differences:
--
++ poppler-qt.spec ++
--- /var/tmp/diff_new_pack.vTm1Ak/_old  2012-01-19 09:44:06.0 +0100
+++ /var/tmp/diff_new_pack.vTm1Ak/_new  2012-01-19 09:44:06.0 +0100
@@ -15,11 +15,12 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define build_qt 1
 
 Name:   poppler-qt
 %define _name   poppler
-Version:0.18.2
+Version:0.18.3
 Release:0
 # Actual version of poppler-data:
 %define poppler_data_version 0.2.1
@@ -44,6 +45,10 @@
 BuildRequires:  update-desktop-files
 BuildRequires:  zlib-devel
 BuildRequires:  pkgconfig(cairo) = 1.10.0
+BuildRequires:  pkgconfig(cairo-ft) = 1.10.0
+BuildRequires:  pkgconfig(cairo-pdf)
+BuildRequires:  pkgconfig(cairo-ps)
+BuildRequires:  pkgconfig(cairo-svg)
 BuildRequires:  pkgconfig(fontconfig)
 BuildRequires:  pkgconfig(freetype2)
 BuildRequires:  pkgconfig(gobject-2.0) = 2.18

++ poppler.spec ++
--- /var/tmp/diff_new_pack.vTm1Ak/_old  2012-01-19 09:44:06.0 +0100
+++ /var/tmp/diff_new_pack.vTm1Ak/_new  2012-01-19 09:44:06.0 +0100
@@ -15,11 +15,12 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define build_qt 0
 
 Name:   poppler
 %define _name   poppler
-Version:0.18.2
+Version:0.18.3
 Release:0
 # Actual version of poppler-data:
 %define poppler_data_version 0.2.1
@@ -44,6 +45,10 @@
 BuildRequires:  update-desktop-files
 BuildRequires:  zlib-devel
 BuildRequires:  pkgconfig(cairo) = 1.10.0
+BuildRequires:  pkgconfig(cairo-ft) = 1.10.0
+BuildRequires:  pkgconfig(cairo-pdf)
+BuildRequires:  pkgconfig(cairo-ps)
+BuildRequires:  pkgconfig(cairo-svg)
 BuildRequires:  pkgconfig(fontconfig)
 BuildRequires:  pkgconfig(freetype2)
 BuildRequires:  pkgconfig(gobject-2.0) = 2.18

++ poppler-0.18.2.tar.gz - poppler-0.18.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/poppler-0.18.2/CMakeLists.txt 
new/poppler-0.18.3/CMakeLists.txt
--- old/poppler-0.18.2/CMakeLists.txt   2011-12-04 15:43:57.0 +0100
+++ new/poppler-0.18.3/CMakeLists.txt   2012-01-15 15:20:02.0 +0100
@@ -16,7 +16,7 @@
 
 set(POPPLER_MAJOR_VERSION 0)
 set(POPPLER_MINOR_VERSION 18)
-set(POPPLER_MICRO_VERSION 2)
+set(POPPLER_MICRO_VERSION 3)
 set(POPPLER_VERSION 
${POPPLER_MAJOR_VERSION}.${POPPLER_MINOR_VERSION}.${POPPLER_MICRO_VERSION})
 
 # command line switches
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/poppler-0.18.2/ChangeLog new/poppler-0.18.3/ChangeLog
--- old/poppler-0.18.2/ChangeLog2011-12-04 15:48:02.0 +0100
+++ new/poppler-0.18.3/ChangeLog2012-01-15 15:23:22.0 +0100
@@ -1,3 +1,149 @@
+commit be59afb19e83c5040ea0d993cfb238aefc06abb1
+Author: Albert Astals Cid aa...@kde.org
+Date:   Sun Jan 15 15:21:06 2012 +0100
+
+0.18.3
+
+ CMakeLists.txt   |2 +-
+ NEWS |   15 +++
+ configure.ac |2 +-
+ cpp/Doxyfile |2 +-
+ qt4/src/Doxyfile |2 +-
+ 5 files changed, 19 insertions(+), 4 deletions(-)
+
+commit d4bff411d0d42064a617812d4e1bf2353fd79e1c
+Author: Albert Astals Cid aa...@kde.org
+Date:   Sun Jan 15 15:13:59 2012 +0100
+
+Add copyrights 

commit postfix for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package postfix for openSUSE:Factory checked 
in at 2012-01-19 09:44:09

Comparing /work/SRC/openSUSE:Factory/postfix (Old)
 and  /work/SRC/openSUSE:Factory/.postfix.new (New)


Package is postfix, Maintainer is vark...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/postfix/postfix.changes  2011-12-14 
14:34:28.0 +0100
+++ /work/SRC/openSUSE:Factory/.postfix.new/postfix.changes 2012-01-19 
09:44:12.0 +0100
@@ -1,0 +2,10 @@
+Thu Jan 12 12:18:17 UTC 2012 - vark...@suse.com
+
+- Add postmap rebuild script to systemv init script too 
+
+---
+Wed Jan 11 14:21:21 UTC 2012 - vark...@suse.com
+
+- bnc#738900 - cyrus-imapd not receiving mail from postfix 
+
+---



Other differences:
--
++ postfix.spec ++
--- /var/tmp/diff_new_pack.wxOd7y/_old  2012-01-19 09:44:13.0 +0100
+++ /var/tmp/diff_new_pack.wxOd7y/_new  2012-01-19 09:44:13.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package postfix
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,15 +16,13 @@
 #
 
 
-
 Name:   postfix
 Summary:A fast, secure, and flexible mailer
-Version:2.8.7
-Release:1
-License:IBM Public License ..
+License:IPL-1.0
 Group:  Productivity/Networking/Email/Servers
+Version:2.8.7
+Release:0
 Url:http://www.postfix.org/
-AutoReqProv:on
 Source: %{name}-%{version}.tar.bz2
 Source1:%{name}-SuSE.tar.gz
 Source2:%{name}-mysql.tar.bz2
@@ -42,7 +40,7 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 PreReq: %insserv_prereq %fillup_prereq
 PreReq: /usr/bin/getent
-PreReq: /usr/sbin/useradd /usr/sbin/groupadd
+PreReq: /usr/sbin/useradd /usr/sbin/groupadd /usr/sbin/usermod
 PreReq: /bin/sed /bin/awk /bin/grep
 PreReq: textutils sh-utils fileutils pcre netcfg
 %if 0%{?suse_version}  1130
@@ -51,7 +49,9 @@
 Requires:   iproute2
 BuildRequires:  db-devel
 BuildRequires:  mysql-devel
-BuildRequires:  openldap2-devel pcre-devel postgresql-devel
+BuildRequires:  openldap2-devel
+BuildRequires:  pcre-devel
+BuildRequires:  postgresql-devel
 # require pwdutils to make postinstall script check work
 BuildRequires:  pwdutils
 %if 0%{?suse_version} = 1100
@@ -84,6 +84,7 @@
 %define pf_uid   51
 %define pf_gid   51
 %define maildrop_gid 59
+%define mail_gid12
 %define conf_backup_dir  /var/adm/backup/%{name}
 %define omc_pdir /usr/share/omc/
 %define omc_dir  /usr/share/omc/svcinfo.d/
@@ -100,9 +101,7 @@
 
 %package  devel
 Summary:Development headers for the postfix package
-License:IBM Public License ..
 Group:  Development/Libraries/C and C++
-AutoReqProv:on
 PreReq: %{name} = %{version}
 
 %description devel
@@ -110,7 +109,6 @@
 
 %package  doc
 Summary:Documentations for the postfix package
-License:IBM Public License ..
 Group:  Productivity/Networking/Email/Servers
 %if 0%{?suse_version} = 1120
 BuildArch:  noarch
@@ -122,9 +120,7 @@
 
 %package  mysql
 Summary:Postfix plugin to support MySQL maps
-License:IBM Public License ..
 Group:  Productivity/Networking/Email/Servers
-AutoReqProv:on
 PreReq: %{name} = %{version}
 
 %description mysql
@@ -133,9 +129,7 @@
 
 %package  postgresql
 Summary:Postfix plugin to support PostgreSQL maps
-License:IBM Public License ..
 Group:  Productivity/Networking/Email/Servers
-AutoReqProv:on
 PreReq: %{name} = %{version}
 
 %description postgresql
@@ -181,6 +175,7 @@
 /usr/sbin/groupadd -g %{pf_gid} -o -r %{name} 2 /dev/null || :
 /usr/sbin/groupadd -g %{maildrop_gid} -o -r maildrop 2 /dev/null || :
 /usr/sbin/useradd -r -o -g %{name} -u %{pf_uid} -s /bin/false -c Postfix 
Daemon -d /%{pf_queue_directory} %{name} 2 /dev/null || :
+/usr/sbin/usermod -G %{maildrop_gid},%{mail_gid} {name} 2 /dev/null || :
 mkdir -p $RPM_BUILD_ROOT/%{_libdir}
 install lib/*.1 $RPM_BUILD_ROOT/%{_libdir}
 for i in $RPM_BUILD_ROOT/%{_libdir}/*.1; do
@@ -330,6 +325,7 @@
 /usr/sbin/groupadd -g %{pf_gid} -o -r %{name} 2 /dev/null || :
 /usr/sbin/groupadd -g %{maildrop_gid} -o -r maildrop 2 /dev/null || :
 /usr/sbin/useradd  -r -o -g %{name} -u 

commit pulseaudio for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package pulseaudio for openSUSE:Factory 
checked in at 2012-01-19 09:44:14

Comparing /work/SRC/openSUSE:Factory/pulseaudio (Old)
 and  /work/SRC/openSUSE:Factory/.pulseaudio.new (New)


Package is pulseaudio, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/pulseaudio/pulseaudio.changes2011-12-27 
18:38:18.0 +0100
+++ /work/SRC/openSUSE:Factory/.pulseaudio.new/pulseaudio.changes   
2012-01-19 09:44:17.0 +0100
@@ -1,0 +2,7 @@
+Thu Jan 12 20:30:01 UTC 2012 - reddw...@opensuse.org
+
+- Remove libatomic-ops-devel buildrequires since it has been
+  dropped from Factory (for x86/x86-64 it wasn't being used
+  anyway)
+
+---



Other differences:
--
++ pulseaudio.spec ++
--- /var/tmp/diff_new_pack.qmYWGY/_old  2012-01-19 09:44:18.0 +0100
+++ /var/tmp/diff_new_pack.qmYWGY/_new  2012-01-19 09:44:18.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package pulseaudio
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,8 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
+
 Name:   pulseaudio
 Version:1.1
 Release:0
@@ -38,7 +40,6 @@
 BuildRequires:  gdbm-devel
 BuildRequires:  intltool
 BuildRequires:  jack-devel
-BuildRequires:  libatomic-ops-devel
 BuildRequires:  libavahi-devel
 BuildRequires:  libopenssl-devel
 BuildRequires:  libsamplerate-devel


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit pidgin-birthday-reminder for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package pidgin-birthday-reminder for 
openSUSE:Factory checked in at 2012-01-19 09:43:59

Comparing /work/SRC/openSUSE:Factory/pidgin-birthday-reminder (Old)
 and  /work/SRC/openSUSE:Factory/.pidgin-birthday-reminder.new (New)


Package is pidgin-birthday-reminder, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/pidgin-birthday-reminder/pidgin-birthday-reminder.changes
2012-01-17 16:14:56.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.pidgin-birthday-reminder.new/pidgin-birthday-reminder.changes
   2012-01-19 09:44:00.0 +0100
@@ -1,0 +2,6 @@
+Fri Jan 13 08:31:16 UTC 2012 - cfarr...@suse.com
+
+- license update: GPL-2.0+
+  SDPDX format
+
+---



Other differences:
--
++ pidgin-birthday-reminder.spec ++
--- /var/tmp/diff_new_pack.QjtVZa/_old  2012-01-19 09:44:01.0 +0100
+++ /var/tmp/diff_new_pack.QjtVZa/_new  2012-01-19 09:44:01.0 +0100
@@ -17,7 +17,7 @@
 Name:   pidgin-birthday-reminder
 Version:1.7
 Release:1
-License:GPLv2+
+License:GPL-2.0+
 Summary:Pidgin plugin to remind you of the birthdays of your buddies
 Url:https://launchpad.net/pidgin-birthday-reminder
 Group:  Productivity/Networking/Instant Messenger
@@ -32,7 +32,7 @@
 MSN and XMPP protocols.
 
 %package -n pidgin-plugin-birthday-reminder
-License:GPLv2+
+License:GPL-2.0+
 Summary:Pidgin plugin to remind you of the birthdays of your buddies
 Group:  Productivity/Networking/Instant Messenger
 Requires:   pidgin

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit pidgin-advanced-sound-notification for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package pidgin-advanced-sound-notification 
for openSUSE:Factory checked in at 2012-01-19 09:43:54

Comparing /work/SRC/openSUSE:Factory/pidgin-advanced-sound-notification (Old)
 and  /work/SRC/openSUSE:Factory/.pidgin-advanced-sound-notification.new 
(New)


Package is pidgin-advanced-sound-notification, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/pidgin-advanced-sound-notification/pidgin-advanced-sound-notification.changes
2012-01-17 16:14:52.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.pidgin-advanced-sound-notification.new/pidgin-advanced-sound-notification.changes
   2012-01-19 09:43:55.0 +0100
@@ -1,0 +2,6 @@
+Thu Jan 12 16:41:37 UTC 2012 - cfarr...@suse.com
+
+- license update: GPL-2.0+
+  SPDX
+
+---



Other differences:
--
++ pidgin-advanced-sound-notification.spec ++
--- /var/tmp/diff_new_pack.c2CUq0/_old  2012-01-19 09:43:56.0 +0100
+++ /var/tmp/diff_new_pack.c2CUq0/_new  2012-01-19 09:43:56.0 +0100
@@ -17,7 +17,7 @@
 Name:   pidgin-advanced-sound-notification
 Version:1.2.1
 Release:1
-License:GPLv2+
+License:GPL-2.0+
 Summary:Pidgin plugin adding sound notifications
 Url:https://launchpad.net/pidgin-advanced-sound-notification
 Group:  Productivity/Networking/Instant Messenger
@@ -31,7 +31,7 @@
 Incoming Filetransfer or Authentication requested).
 
 %package -n pidgin-plugin-advanced-sound-notification
-License:GPLv2+
+License:GPL-2.0+
 Summary:Pidgin plugin adding sound notifications
 Group:  Productivity/Networking/Instant Messenger
 Requires:   pidgin

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-sqlalchemy-migrate for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package python-sqlalchemy-migrate for 
openSUSE:Factory checked in at 2012-01-19 09:44:30

Comparing /work/SRC/openSUSE:Factory/python-sqlalchemy-migrate (Old)
 and  /work/SRC/openSUSE:Factory/.python-sqlalchemy-migrate.new (New)


Package is python-sqlalchemy-migrate, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/python-sqlalchemy-migrate/python-sqlalchemy-migrate.changes
  2011-12-07 14:40:00.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-sqlalchemy-migrate.new/python-sqlalchemy-migrate.changes
 2012-01-19 09:44:31.0 +0100
@@ -1,0 +2,46 @@
+Wed Jan 11 14:24:07 UTC 2012 - rha...@suse.de
+
+- update to 0.7.2:
+  * Changes:
+- support for SQLAlchemy 0.5.x has been dropped
+- Python 2.6 is the minimum supported Python version
+  * Features
+- improved :pep:`8` compliance
+- optionally number versions with timestamps instead of
+  sequences (partly pulled from Pete Keen)
+- allow descriptions in SQL change script filenames (by Pete
+  Keen)
+- improved model generation
+  * Fixed Bugs
+- api test downgrade/upgrade does not work with sql scripts
+  (pulled from Yuen Ho Wong)
+- passing a unicode string as the migrate repository fails (add
+  regression test)
+- make_update_script_for_model fails with AttributeError:
+  'SchemaDiff' object has no attribute 'colDiffs' (patch by
+  Jeremy Cantrell)
+- upgrade and downgrade functions are reversed when using the
+  command make_update_script_for_model (patch by Jeremy
+  Cantrell)
+- manage.py should use the if __name__=='__main__' trick
+- column creation in make_update_script_for_model and required
+  API change (by Gabriel de Perthuis)
+- compare_model_to_db gets confused by sqlite_sequence (pulled
+  from Dustin J. Mitchell)
+- drop column does not work on persistent sqlite databases
+  (pulled from Benoît Allard)
+- table rename failure with sqlalchemy 0.7.x (patch by Mark
+  McLoughlin)
+- update documentation and help text (pulled from Yuen Ho Wong)
+
+---
+Wed Nov 30 18:27:26 UTC 2011 - jdmul...@gmail.com
+- Fixed shebang removal code on .spec line 52
+* This line was indiscriminately deleting the 1st line of all .py
+  and .py_tmpl file which caused it to delete things that were not
+  shebangs. This causes errors when it deletes things like 
+  before a doc string. For instance executing
+  from migrate import changeset resulted in an
+  Unexpected Indentation Error
+
+---

Old:

  sqlalchemy-migrate-0.7.1.tar.gz

New:

  sqlalchemy-migrate-0.7.2.tar.gz



Other differences:
--
++ python-sqlalchemy-migrate.spec ++
--- /var/tmp/diff_new_pack.lpkc6j/_old  2012-01-19 09:44:32.0 +0100
+++ /var/tmp/diff_new_pack.lpkc6j/_new  2012-01-19 09:44:32.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-sqlalchemy-migrate
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright 2011 LISA GmbH, Bingen, Germany.
 #
 # All modifications and additions to the file contributed by third parties
@@ -19,13 +19,13 @@
 
 
 Name:   python-sqlalchemy-migrate
-Version:0.7.1
+Version:0.7.2
 Release:0
 License:MIT
 Summary:Database schema migration for SQLAlchemy
 Url:http://pypi.python.org/pypi/sqlalchemy-migrate
 Group:  Development/Libraries/Python
-Source: 
http://pypi.python.org/packages/source/s/sqlalchemy-migrate/sqlalchemy-migrate-0.7.1.tar.gz
+Source: 
http://pypi.python.org/packages/source/s/sqlalchemy-migrate/sqlalchemy-migrate-0.7.2.tar.gz
 BuildRequires:  python-Sphinx = 0.5
 BuildRequires:  python-distribute
 Requires:   python-SQLAlchemy = 0.5
@@ -49,7 +49,7 @@
 
 %prep
 %setup -q -n sqlalchemy-migrate-%{version}
-find . -type f -name *.py -o -name *.py_tmpl | xargs sed -i 1d # Fix 
non-executable scripts
+find . -type f -name *.py -o -name *.py_tmpl | xargs sed -i /#!/d # 
Remove shebang from non-executable scripts
 
 %build
 python setup.py build

++ sqlalchemy-migrate-0.7.1.tar.gz - sqlalchemy-migrate-0.7.2.tar.gz ++
 3871 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rhino for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package rhino for openSUSE:Factory checked 
in at 2012-01-19 09:44:34

Comparing /work/SRC/openSUSE:Factory/rhino (Old)
 and  /work/SRC/openSUSE:Factory/.rhino.new (New)


Package is rhino, Maintainer is bnc-team-j...@forge.provo.novell.com

Changes:

--- /work/SRC/openSUSE:Factory/rhino/rhino.changes  2011-09-23 
12:44:20.0 +0200
+++ /work/SRC/openSUSE:Factory/.rhino.new/rhino.changes 2012-01-19 
09:44:36.0 +0100
@@ -1,0 +2,17 @@
+Tue Jan 17 12:56:04 UTC 2012 - cfarr...@suse.com
+
+- license update: MPL-1.1 or GPL-2.0+
+  the code is dual licensed under a choice of MPL-1.1 or GPL-2.0+
+
+---
+Mon Jan 16 15:47:09 UTC 2012 - mvysko...@suse.cz
+
+- update to rhino 1_7R3 (bugfix release)
+- fix bnc#739502 - rhino-dojo.patch adds Sun proprietary code to rhino 1.7
+
+---
+Thu Dec 15 13:50:34 UTC 2011 - co...@suse.com
+
+- fix license to be in spdx.org format
+
+---

Old:

  rhino-class-loader.patch
  rhino-docs.tar.bz2
  rhino-dojo.patch
  rhino1_7R2.tar.bz2

New:

  rhino-1.7R3-crosslink.patch
  rhino-addOrbitManifest.patch
  rhino1_7R3-suse.tar.gz



Other differences:
--
++ rhino.spec ++
--- /var/tmp/diff_new_pack.JdD2Kr/_old  2012-01-19 09:44:37.0 +0100
+++ /var/tmp/diff_new_pack.JdD2Kr/_new  2012-01-19 09:44:37.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package rhino
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c) 2000-2009, JPackage Project
 # All rights reserved.
 #
@@ -19,19 +19,21 @@
 
 
 %define section free
-%define cvs_version 1_7R2
-%define archive_version 1_7R2
+%define cvs_version 1_7R3
 
 Name:   rhino
-Version:1.7
-Release:20
+Version:1.7R3
+Release:1
 Summary:JavaScript for Java
-License:MPL ..
-# wget ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino%{archive_version}.zip
-# unzip -q rhino%{archive_version}.zip
-# find rhino%{archive_version}/ -name '*jar' | xargs rm -rf
-# tar -cjf rhino%{archive_version}.tar.bz2 rhino%{archive_version}/
-Source0:rhino%{archive_version}.tar.bz2
+License:MPL-1.1 or GPL-2.0+
+Group:  Development/Libraries/Java
+Url:http://www.mozilla.org/rhino/
+
+# wget ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino%{cvs_version}.zip
+# unzip -q rhino%{cvs_version}.zip
+# find rhino%{cvs_version}/ -name '*jar' | xargs rm -rf
+# tar -czf rhino%{cvs_version}-suse.tar.gz rhino%{cvs_version}/
+Source0:rhino%{cvs_version}-suse.tar.gz
 Source2:rhino.script
 Source3:rhino-debugger.script
 Source4:rhino-idswitch.script
@@ -39,36 +41,34 @@
 Source6:rhino-js.pom
 Source7:rhino.pom
 Source8:rhino-component-info.xml
-# export CVSROOT=:pserver:anonym...@cvs-mirror.mozilla.org:/www
-# vs -z3 co mozilla-org/html/rhino
-# cd mozilla-org/html/
-# rm -r rhino/apidocs   # the javadoc is in different directory
-# tar -cjf rhino-docs.tar.bz2 rhino
-Source100:  rhino-docs.tar.bz2
+
 Patch0: rhino-build.patch
-Patch1: rhino-dojo.patch
-Patch2: rhino-class-loader.patch
+# Add OSGi metadata from Eclipse Orbit project
+# Rip out of MANIFEST.MF included in this JAR:
+# 
http://www.eclipse.org/downloads/download.php?r=1file=/tools/orbit/downloads/drops/R20110523182458/repository/plugins/org.mozilla.javascript_1.7.2.v201005080400.jar
+Patch1: %{name}-addOrbitManifest.patch
+Patch2: %{name}-1.7R3-crosslink.patch
 Patch3: rhino-288467.patch
 #PATCH-FIX-OPENSUSE: allow build under gcj
 Patch100:   rhino-1.7-gcj.patch
-Url:http://www.mozilla.org/rhino/
-Group:  Development/Libraries/Java
-Requires:   jline
-Requires:   bea-stax-api
-Requires:   xmlbeans
+
 BuildRequires:  ant
-BuildRequires:  jpackage-utils
-BuildRequires:  jline
 BuildRequires:  bea-stax-api
-BuildRequires:  xmlbeans-mini
-BuildRequires:  unzip
+BuildRequires:  jline
+BuildRequires:  jpackage-utils
 BuildRequires:  xerces-j2-bootstrap
+BuildRequires:  xmlbeans-mini
+BuildRequires:  java-1_5_0-gcj-compat-devel
 #!BuildIgnore:  xerces-j2 xml-commons xml-commons-apis xml-commons-resolver
 #!BuildIgnore:  antlr antlr-java
 #!BuildIgnore:  xml-commons-jaxp-1.3-apis
-BuildArch:  noarch
-BuildRequires:  java-1_5_0-gcj-compat-devel
 #!BuildIgnore:  java-1_6_0-openjdk java-1_6_0-openjdk-devel
+
+Requires:   jline
+Requires:   bea-stax-api
+Requires:   

commit shorewall for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package shorewall for openSUSE:Factory 
checked in at 2012-01-19 09:44:39

Comparing /work/SRC/openSUSE:Factory/shorewall (Old)
 and  /work/SRC/openSUSE:Factory/.shorewall.new (New)


Package is shorewall, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/shorewall/shorewall.changes  2011-12-15 
16:07:48.0 +0100
+++ /work/SRC/openSUSE:Factory/.shorewall.new/shorewall.changes 2012-01-19 
09:44:41.0 +0100
@@ -1,0 +2,82 @@
+Mon Jan 16 14:13:20 UTC 2012 - tog...@opensuse.org
+
+- Update to 4.4.27.2. For more details see changelog.txt and
+  releasenotes.txt
+
+  * A long-standing problem with Shorewall's 'save' facility has
+been discovered. The defect can cause rules to be dropped during
+'save' so that they are not available to be reapplied during
+'restore'. This can occur in 'safe-restart' when the prompt is
+not acknowledged or when it is acknowledged with 'n'.
+
+The problem can occur when:
+
+a) There are IPSEC zones or hosts present; and
+b)  GOTO Target support is available in the kernel and
+iptables.
+
+Example of rule that will be dropped:
+
+  -A eth2_fwd -m policy --dir in --pol ipsec -g AAA_frwd
+
+The defective code has been corrected so that rules are no
+longer dropped.
+ 
+
+---
+Thu Jan 12 19:33:16 UTC 2012 - tog...@opensuse.org
+
+- Update to 4.4.27.1. For more details see changelog.txt and
+  releasenotes.txt 
+
+  * When optimization category 4 is used, unconditional jumps at
+the end of chains are replaced with the rules in the target
+chain. This can result in rulesets that are considerably larger
+than necessary. Beginning with this release, replacement will
+only occur if:
+
+a) The jump is the only reference to the target chain; or
+b) The target chain contains 3 or less rules.
+
+  * The feature introduced in 4.4.25 that allowed provider names in
+the  'enable' and 'disable' commands was only implemented for
+'enable'. It is now implemented for 'disable' as well.
+
+  * When detecting IPv6 global addresses through an interface, 
+Shorewall6-generated scripts were ignoring addresses beginning
+with '3'.
+
+  * A typo in /usr/share/shorewall/prog.header caused an 'awk' script
+to fail when saving a multi-hop default route during 'start'.
+
+  * The value '0' is once again accepted in the IN_BANDWIDTH
+columns of tcinterfaces and tcrules, and causes no ingress
+policing to be configured.
+
+  * MARK_IN_FORWARD_CHAIN=Yes no longer generates an error when 
+$FW:address is entered in the SOURCE column of the tcrules
+file.
+
+  * In most Shorewall 4.4 versions, if an exported params file
+(EXPORTPARAMS=Yes in shorewall.conf) generates any output to
+stdout, then the following messages would appear during
+start/restart:
+
+  Compiling /etc/shorewall/routestopped...
+  Shorewall configuration compiled to 
+  /var/lib/shorewall/.restart
+  printf: 214: Build: expected numeric value
+  printf: 214: ipset: expected numeric value
+  printf: 214: of: expected numeric value
+  Processing /etc/shorewall/params ...
+  Build ipset of blacklisted addresses
+  Usage: /var/lib/shorewall/.restart [ options ] command
+
+ command is one of:
+start
+stop
+...
+
+This has now been corrected.
+
+---
@@ -4 +86 @@
-- Update to 4.4.26.1 For more details see  chnagelog.txt and
+- Update to 4.4.26.1 For more details see changelog.txt and

Old:

  shorewall-4.4.26.1.tar.bz2
  shorewall-docs-html-4.4.26.1.tar.bz2
  shorewall-init-4.4.26.1.tar.bz2
  shorewall-lite-4.4.26.1.tar.bz2
  shorewall6-4.4.26.1.tar.bz2
  shorewall6-lite-4.4.26.1.tar.bz2

New:

  shorewall-4.4.27.2.tar.bz2
  shorewall-docs-html-4.4.27.2.tar.bz2
  shorewall-init-4.4.27.2.tar.bz2
  shorewall-lite-4.4.27.2.tar.bz2
  shorewall6-4.4.27.2.tar.bz2
  shorewall6-lite-4.4.27.2.tar.bz2



Other differences:
--
++ shorewall.spec ++
--- /var/tmp/diff_new_pack.5ft1Yt/_old  2012-01-19 09:44:42.0 +0100
+++ /var/tmp/diff_new_pack.5ft1Yt/_new  2012-01-19 09:44:42.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package shorewall
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   shorewall
-Version:4.4.26.1

commit python-managesieve for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package python-managesieve for 
openSUSE:Factory checked in at 2012-01-19 09:44:20

Comparing /work/SRC/openSUSE:Factory/python-managesieve (Old)
 and  /work/SRC/openSUSE:Factory/.python-managesieve.new (New)


Package is python-managesieve, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-managesieve/python-managesieve.changes
2011-09-23 12:42:57.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-managesieve.new/python-managesieve.changes   
2012-01-19 09:44:21.0 +0100
@@ -1,0 +2,19 @@
+Tue Jan 17 10:37:38 UTC 2012 - sasc...@suse.de
+
+- Update license to GPL-2.0+ and Python-2.0 (bnc#741277)
+
+---
+Thu Jan 12 14:36:45 UTC 2012 - sasc...@suse.de
+
+- Spec file cleanup:
+  * BuildRequire python-distribute instead of setuptools
+  * Removed %clean section (has sane default)
+  * Removed authors from description
+  * Ran spec-cleaner
+
+---
+Thu Jan 12 11:31:10 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ python-managesieve.spec ++
--- /var/tmp/diff_new_pack.T3gf1z/_old  2012-01-19 09:44:22.0 +0100
+++ /var/tmp/diff_new_pack.T3gf1z/_new  2012-01-19 09:44:22.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package python-managesieve (Version 0.4.2)
+# spec file for package python-managesieve
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c) 2009 Guido Berhoerster.
 #
 # All modifications and additions to the file contributed by third parties
@@ -17,21 +17,20 @@
 #
 
 
-
 Name:   python-managesieve
-Summary:Python Module Implementing the ManageSieve Protocol
 Version:0.4.2
-Release:1
-License:GPL, MIT License (or similar)
+Release:0
+Summary:Python Module Implementing the ManageSieve Protocol
+License:GPL-2.0+ and Python-2.0
 Group:  Development/Libraries/Python
-AutoReqProv:on
-Source: 
http://download.origo.ethz.ch/python-managesieve/1573/managesieve-0.4.2.tar.bz2
 Url:http://python-managesieve.origo.ethz.ch/wiki/python_managesieve
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+Source: 
http://download.origo.ethz.ch/python-managesieve/1573/managesieve-0.4.2.tar.bz2
 BuildRequires:  python-devel
-BuildRequires:  python-setuptools = 0.6c9
-%{py_requires}
-%if %{?suse_version: %{suse_version}  1110} %{!?suse_version:1}
+BuildRequires:  python-distribute
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+%if 0%{?suse_version}  0%{?suse_version} = 1110
+%{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
+%else
 BuildArch:  noarch
 %endif
 
@@ -39,26 +38,19 @@
 python-managesieve is a Python module implementing the ManageSieve client
 protocol. It also includes an user application (the interactive sieveshell).
 
-Authors:
-
-Hartmut Goebel h.goe...@crazy-compilers.com
-Ulrich Eck u...@net-labs.de
-
-
 %prep
 %setup -q -n managesieve-%{version}
 
 %build
-%{__python} setup.py build
+python setup.py build
 
 %install
-%{__python} setup.py install --prefix=%{_prefix} --root=%{buildroot} 
--record-rpm=INSTALLED_FILES
-
-%clean
-rm -rf $RPM_BUILD_ROOT
+python setup.py install --prefix=%{_prefix} --root=%{buildroot}
 
-%files -f INSTALLED_FILES
+%files
 %defattr(-,root,root,-)
 %doc draft-martin-managesieve-07.txt HISTORY README TODO
+%{_bindir}/sieveshell
+%{python_sitelib}/*
 
 %changelog

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit storeBackup for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package storeBackup for openSUSE:Factory 
checked in at 2012-01-19 09:44:45

Comparing /work/SRC/openSUSE:Factory/storeBackup (Old)
 and  /work/SRC/openSUSE:Factory/.storeBackup.new (New)


Package is storeBackup, Maintainer is m...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/storeBackup/storeBackup.changes  2012-01-04 
07:31:52.0 +0100
+++ /work/SRC/openSUSE:Factory/.storeBackup.new/storeBackup.changes 
2012-01-19 09:44:46.0 +0100
@@ -1,0 +2,6 @@
+Mon Jan  2 14:26:49 UTC 2012 - cfarr...@suse.com
+
+- license update: GPL-3.0+
+  No indication of a GPL-3.0 only license in the package
+
+---



Other differences:
--
++ storeBackup.spec ++
--- /var/tmp/diff_new_pack.G90Pvc/_old  2012-01-19 09:44:47.0 +0100
+++ /var/tmp/diff_new_pack.G90Pvc/_new  2012-01-19 09:44:47.0 +0100
@@ -20,7 +20,7 @@
 Version:3.2
 Release:0
 Summary:storeBackup is a disk-to-disk backup tool for Linux
-License:GPL-3.0
+License:GPL-3.0+
 Group:  Productivity/Archiving/Backup
 Source0:storeBackup-%{version}.tar.bz2
 Source1:storeBackup-%{version}.config.default

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit xorg-x11-libs for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package xorg-x11-libs for openSUSE:Factory 
checked in at 2012-01-19 09:44:49

Comparing /work/SRC/openSUSE:Factory/xorg-x11-libs (Old)
 and  /work/SRC/openSUSE:Factory/.xorg-x11-libs.new (New)


Package is xorg-x11-libs, Maintainer is sndir...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/xorg-x11-libs/xorg-x11-libs.changes  
2012-01-13 11:00:51.0 +0100
+++ /work/SRC/openSUSE:Factory/.xorg-x11-libs.new/xorg-x11-libs.changes 
2012-01-19 09:44:52.0 +0100
@@ -1,0 +2,6 @@
+Mon Jan 16 11:25:52 CET 2012 - sndir...@suse.de
+
+- provide fake libxcb-atom.so.1 (bnc #741465) for older openSUSE
+  releases since it apparently vanished with xcb-util 0.3.8 :-(
+
+---



Other differences:
--
++ xorg-x11-libs.spec ++
--- /var/tmp/diff_new_pack.DfyfDp/_old  2012-01-19 09:44:54.0 +0100
+++ /var/tmp/diff_new_pack.DfyfDp/_new  2012-01-19 09:44:54.0 +0100
@@ -23,9 +23,11 @@
 %ifarch ppc64 s390x x86_64
 Provides:   libXaw.so.8()(64bit) libXaw.so.7()(64bit) libXaw.so.6()(64bit)
 Provides:   libXaw8.so.8()(64bit) libXaw7.so.7()(64bit) 
libXaw6.so.6()(64bit)
+Provides:   libxcb-atom.so.1()(64bit)
 %else
 Provides:   libXaw.so.8 libXaw.so.7 libXaw.so.6
 Provides:   libXaw8.so.8 libXaw7.so.7 libXaw6.so.6
+Provides:   libxcb-atom.so.1
 %endif
 # bug437293
 %ifarch ppc64
@@ -144,6 +146,14 @@
 # for compatibility reasons
 ln -s libXaw7.so.7 $RPM_BUILD_ROOT/%{_libdir}/libXaw8.so.8
 ln -s libXaw.so.7  $RPM_BUILD_ROOT/%{_libdir}/libXaw.so.8
+# create fake libxcb-atom.so.1 (bnc #741465)
+ xcb-atom.c
+gcc -Wall -ansi -pedantic -c xcb-atom.c -fPIC
+gcc -shared -Wl,-soname,libxcb-atom.so.1 \
+   -o $RPM_BUILD_ROOT%{_libdir}/libxcb-atom.so.1 xcb-atom.o
+%if %suse_version  1110
+%{__rm} -f %{buildroot}%{_libdir}/*.la
+%endif
 %fdupes -s $RPM_BUILD_ROOT/%_mandir
 
 %clean

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yast2 for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package yast2 for openSUSE:Factory checked 
in at 2012-01-19 09:44:54

Comparing /work/SRC/openSUSE:Factory/yast2 (Old)
 and  /work/SRC/openSUSE:Factory/.yast2.new (New)


Package is yast2, Maintainer is jsr...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/yast2/yast2.changes  2012-01-09 
12:55:43.0 +0100
+++ /work/SRC/openSUSE:Factory/.yast2.new/yast2.changes 2012-01-19 
09:44:56.0 +0100
@@ -1,0 +2,7 @@
+Fri Jan 13 14:35:47 CET 2012 - mvid...@suse.cz
+
+- Internet test: fail early if NetworkManager has crashed
+  (bnc#739390).
+- 2.22.3
+
+---

Old:

  yast2-2.22.2.tar.bz2

New:

  yast2-2.22.3.tar.bz2



Other differences:
--
++ yast2.spec ++
--- /var/tmp/diff_new_pack.7z6KSE/_old  2012-01-19 09:44:58.0 +0100
+++ /var/tmp/diff_new_pack.7z6KSE/_new  2012-01-19 09:44:58.0 +0100
@@ -18,7 +18,7 @@
 
 
 Name:   yast2
-Version:2.22.2
+Version:2.22.3
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-2.22.2.tar.bz2 - yast2-2.22.3.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-2.22.2/VERSION new/yast2-2.22.3/VERSION
--- old/yast2-2.22.2/VERSION2012-01-06 16:00:28.0 +0100
+++ new/yast2-2.22.3/VERSION2012-01-13 14:51:31.0 +0100
@@ -1 +1 @@
-2.22.2
+2.22.3
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-2.22.2/configure new/yast2-2.22.3/configure
--- old/yast2-2.22.2/configure  2012-01-06 16:00:32.0 +0100
+++ new/yast2-2.22.3/configure  2012-01-13 14:51:36.0 +0100
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.68 for yast2 2.22.2.
+# Generated by GNU Autoconf 2.68 for yast2 2.22.3.
 #
 # Report bugs to http://bugs.opensuse.org/.
 #
@@ -559,8 +559,8 @@
 # Identity of this package.
 PACKAGE_NAME='yast2'
 PACKAGE_TARNAME='yast2'
-PACKAGE_VERSION='2.22.2'
-PACKAGE_STRING='yast2 2.22.2'
+PACKAGE_VERSION='2.22.3'
+PACKAGE_STRING='yast2 2.22.3'
 PACKAGE_BUGREPORT='http://bugs.opensuse.org/'
 PACKAGE_URL=''
 
@@ -1232,7 +1232,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat _ACEOF
-\`configure' configures yast2 2.22.2 to adapt to many kinds of systems.
+\`configure' configures yast2 2.22.3 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1303,7 +1303,7 @@
 
 if test -n $ac_init_help; then
   case $ac_init_help in
- short | recursive ) echo Configuration of yast2 2.22.2:;;
+ short | recursive ) echo Configuration of yast2 2.22.3:;;
esac
   cat \_ACEOF
 
@@ -1383,7 +1383,7 @@
 test -n $ac_init_help  exit $ac_status
 if $ac_init_version; then
   cat \_ACEOF
-yast2 configure 2.22.2
+yast2 configure 2.22.3
 generated by GNU Autoconf 2.68
 
 Copyright (C) 2010 Free Software Foundation, Inc.
@@ -1400,7 +1400,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by yast2 $as_me 2.22.2, which was
+It was created by yast2 $as_me 2.22.3, which was
 generated by GNU Autoconf 2.68.  Invocation command line was
 
   $ $0 $@
@@ -2330,7 +2330,7 @@
 
 # Define the identity of the package.
  PACKAGE='yast2'
- VERSION='2.22.2'
+ VERSION='2.22.3'
 
 
 cat confdefs.h _ACEOF
@@ -2452,7 +2452,7 @@
 
 
 
-VERSION=2.22.2
+VERSION=2.22.3
 RPMNAME=yast2
 MAINTAINER=Jiri Srain jsr...@suse.cz
 
@@ -3498,7 +3498,7 @@
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log=
-This file was extended by yast2 $as_me 2.22.2, which was
+This file was extended by yast2 $as_me 2.22.3, which was
 generated by GNU Autoconf 2.68.  Invocation command line was
 
   CONFIG_FILES= $CONFIG_FILES
@@ -3551,7 +3551,7 @@
 cat $CONFIG_STATUS _ACEOF || ac_write_fail=1
 ac_cs_config=`$as_echo $ac_configure_args | sed 's/^ //; 
s/[\\\`\$]//g'`
 ac_cs_version=\\
-yast2 config.status 2.22.2
+yast2 config.status 2.22.3
 configured by $0, generated by GNU Autoconf 2.68,
   with options \\\$ac_cs_config\\
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-2.22.2/configure.in 
new/yast2-2.22.3/configure.in
--- old/yast2-2.22.2/configure.in   2012-01-06 16:00:29.0 +0100
+++ new/yast2-2.22.3/configure.in   2012-01-13 14:51:32.0 +0100
@@ -3,7 +3,7 @@
 dnl -- This file is generated by y2autoconf 2.21.7 

commit yast2-country for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package yast2-country for openSUSE:Factory 
checked in at 2012-01-19 09:45:01

Comparing /work/SRC/openSUSE:Factory/yast2-country (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-country.new (New)


Package is yast2-country, Maintainer is jsuch...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/yast2-country/yast2-country.changes  
2012-01-04 08:01:51.0 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-country.new/yast2-country.changes 
2012-01-19 09:45:02.0 +0100
@@ -1,0 +2,15 @@
+Fri Jan 13 11:35:23 CET 2012 - jsuch...@suse.cz
+
+- call GfxMenu::Update from client, so we do not have to require
+  yast2-bootloader package dependency (bnc#730391)
+- expanded texts about UTC/localtime to convice user for using UTC
+  (bnc#732769)
+- 2.22.4
+
+---
+Thu Jan 12 09:35:32 CET 2012 - jsuch...@suse.cz
+
+- Confirmed license 
+- 2.22.3
+
+---

Old:

  yast2-country-2.22.2.tar.bz2

New:

  yast2-country-2.22.4.tar.bz2



Other differences:
--
++ yast2-country.spec ++
--- /var/tmp/diff_new_pack.qGMlhp/_old  2012-01-19 09:45:03.0 +0100
+++ /var/tmp/diff_new_pack.qGMlhp/_new  2012-01-19 09:45:03.0 +0100
@@ -19,14 +19,14 @@
 
 
 Name:   yast2-country
-Version:2.22.2
+Version:2.22.4
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source0:yast2-country-%{version}.tar.bz2
 
 Group:  System/YaST
-License:GPL-2.0+
+License:GPL-2.0
 #policy files for YaPI dbus interface
 Source1:org.opensuse.yast.modules.yapi.time.policy
 Source2:org.opensuse.yast.modules.yapi.language.policy
@@ -116,6 +116,7 @@
 %files
 %defattr(-,root,root)
 %doc %{_prefix}/share/doc/packages/yast2-country
+%doc COPYING
 /usr/share/YaST2/modules/Console.y*
 /usr/share/YaST2/modules/Keyboard.y*
 /usr/share/YaST2/modules/Timezone.y*



++ yast2-country-2.22.2.tar.bz2 - yast2-country-2.22.4.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-country-2.22.2/VERSION 
new/yast2-country-2.22.4/VERSION
--- old/yast2-country-2.22.2/VERSION2012-01-02 12:01:54.0 +0100
+++ new/yast2-country-2.22.4/VERSION2012-01-12 15:22:56.0 +0100
@@ -1 +1 @@
-2.22.2
+2.22.4
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-country-2.22.2/configure 
new/yast2-country-2.22.4/configure
--- old/yast2-country-2.22.2/configure  2011-11-14 14:00:28.0 +0100
+++ new/yast2-country-2.22.4/configure  2012-01-12 09:35:57.0 +0100
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.68 for yast2-country 2.21.6.
+# Generated by GNU Autoconf 2.68 for yast2-country 2.22.3.
 #
 # Report bugs to http://bugs.opensuse.org/.
 #
@@ -559,8 +559,8 @@
 # Identity of this package.
 PACKAGE_NAME='yast2-country'
 PACKAGE_TARNAME='yast2-country'
-PACKAGE_VERSION='2.21.6'
-PACKAGE_STRING='yast2-country 2.21.6'
+PACKAGE_VERSION='2.22.3'
+PACKAGE_STRING='yast2-country 2.22.3'
 PACKAGE_BUGREPORT='http://bugs.opensuse.org/'
 PACKAGE_URL=''
 
@@ -1229,7 +1229,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat _ACEOF
-\`configure' configures yast2-country 2.21.6 to adapt to many kinds of systems.
+\`configure' configures yast2-country 2.22.3 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1300,7 +1300,7 @@
 
 if test -n $ac_init_help; then
   case $ac_init_help in
- short | recursive ) echo Configuration of yast2-country 2.21.6:;;
+ short | recursive ) echo Configuration of yast2-country 2.22.3:;;
esac
   cat \_ACEOF
 
@@ -1380,7 +1380,7 @@
 test -n $ac_init_help  exit $ac_status
 if $ac_init_version; then
   cat \_ACEOF
-yast2-country configure 2.21.6
+yast2-country configure 2.22.3
 generated by GNU Autoconf 2.68
 
 Copyright (C) 2010 Free Software Foundation, Inc.
@@ -1397,7 +1397,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by yast2-country $as_me 2.21.6, which was
+It was created by yast2-country $as_me 2.22.3, which was
 generated by GNU Autoconf 2.68.  Invocation command line was
 
   $ $0 $@
@@ -2327,7 +2327,7 @@
 
 # Define the identity of the package.
  PACKAGE='yast2-country'
- VERSION='2.21.6'
+ VERSION='2.22.3'
 
 
 cat confdefs.h _ACEOF
@@ -2449,7 +2449,7 @@
 
 
 

commit yast2-ncurses for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package yast2-ncurses for openSUSE:Factory 
checked in at 2012-01-19 09:45:07

Comparing /work/SRC/openSUSE:Factory/yast2-ncurses (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-ncurses.new (New)


Package is yast2-ncurses, Maintainer is g...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/yast2-ncurses/yast2-ncurses.changes  
2011-12-15 16:08:49.0 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-ncurses.new/yast2-ncurses.changes 
2012-01-19 09:45:09.0 +0100
@@ -1,0 +2,6 @@
+Wed Dec 21 12:23:41 CET 2011 - g...@suse.de
+
+- Confirmed license
+- V 2.22.0 
+
+---

Old:

  yast2-ncurses-2.21.4.tar.bz2

New:

  yast2-ncurses-2.22.0.tar.bz2



Other differences:
--
++ yast2-ncurses.spec ++
--- /var/tmp/diff_new_pack.eCrUwJ/_old  2012-01-19 09:45:10.0 +0100
+++ /var/tmp/diff_new_pack.eCrUwJ/_new  2012-01-19 09:45:10.0 +0100
@@ -16,40 +16,35 @@
 #
 
 
+
 Name:   yast2-ncurses
-Version:2.21.4
+Version:2.22.0
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source0:yast2-ncurses-%{version}.tar.bz2
 
-BuildRequires:  blocxx-devel
-BuildRequires:  dejagnu
-BuildRequires:  doxygen
-BuildRequires:  gcc-c++
-BuildRequires:  libtool
-BuildRequires:  libxcrypt-devel
-BuildRequires:  ncurses-devel
-BuildRequires:  yast2-devtools
 
-Summary:YaST2 - Character Based User Interface
-License:GPL-2.0+
 Group:  System/YaST
+License: GPL-2.0
+BuildRequires: doxygen dejagnu gcc-c++ yast2-devtools libtool
+BuildRequires: libxcrypt-devel blocxx-devel ncurses-devel
+
+Summary:   YaST2 - Character Based User Interface
 Provides:   yast2_ui
 Requires:   glibc-locale
 BuildRequires:  yast2-libyui-devel = 2.21.1
 Requires:   yast2-libyui   = 2.21.1
 Recommends: yast2-ncurses-pkg
-
 %description
 This package contains the character based (ncurses) user interface
 component for YaST2.
 
 %package devel
 Requires:   yast2-ncurses = %version
+Group: Development/Libraries
 
 Summary:YaST2 - Character Based User Interface
-Group:  Development/Libraries
 Requires:   yast2-ncurses = 2.16.15
 Requires:   ncurses-devel yast2-libyui-devel
 
@@ -68,7 +63,6 @@
 export CFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 export CXXFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 
-%{?suse_update_config:%{suse_update_config -f}}
 ./configure --libdir=%{_libdir} --prefix=%{_prefix} --mandir=%{_mandir}
 # V=1: verbose build in case we used AM_SILENT_RULES(yes)
 # so that RPM_OPT_FLAGS check works
@@ -99,5 +93,6 @@
 %dir %{_prefix}/include/YaST2
 %{_prefix}/include/YaST2/ncurses/
 %doc %{_prefix}/share/doc/packages/yast2-ncurses
+%doc COPYING
 
 %changelog

++ yast2-ncurses-2.21.4.tar.bz2 - yast2-ncurses-2.22.0.tar.bz2 ++
 6889 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yast2-ncurses-pkg for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package yast2-ncurses-pkg for 
openSUSE:Factory checked in at 2012-01-19 09:45:12

Comparing /work/SRC/openSUSE:Factory/yast2-ncurses-pkg (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-ncurses-pkg.new (New)


Package is yast2-ncurses-pkg, Maintainer is g...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/yast2-ncurses-pkg/yast2-ncurses-pkg.changes  
2011-12-15 16:08:55.0 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-ncurses-pkg.new/yast2-ncurses-pkg.changes 
2012-01-19 09:45:16.0 +0100
@@ -1,0 +2,6 @@
+Tue Jan 17 13:55:34 CET 2012 - g...@suse.de
+
+- Confirmed license
+- 2.22.0 
+
+---

Old:

  yast2-ncurses-pkg-2.21.2.tar.bz2

New:

  yast2-ncurses-pkg-2.22.0.tar.bz2



Other differences:
--
++ yast2-ncurses-pkg.spec ++
--- /var/tmp/diff_new_pack.2yz2Vz/_old  2012-01-19 09:45:17.0 +0100
+++ /var/tmp/diff_new_pack.2yz2Vz/_new  2012-01-19 09:45:17.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package yast2-ncurses-pkg
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,27 +16,20 @@
 #
 
 
+
 Name:   yast2-ncurses-pkg
-Version:2.21.2
+Version:2.22.0
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source0:yast2-ncurses-pkg-%{version}.tar.bz2
 
-BuildRequires:  blocxx-devel
-BuildRequires:  dejagnu
-BuildRequires:  doxygen
-BuildRequires:  gcc-c++
-BuildRequires:  libtool
-BuildRequires:  libxcrypt-devel
-BuildRequires:  ncurses-devel
-BuildRequires:  yast2-core-devel
-BuildRequires:  yast2-devtools
-BuildRequires:  yast2-ncurses-devel
+Group:  System/YaST
+License:GPL-2.0
+BuildRequires:  dejagnu doxygen gcc-c++ libtool yast2-core-devel yast2-devtools
+BuildRequires:  blocxx-devel libxcrypt-devel ncurses-devel yast2-ncurses-devel
 
 Summary:YaST2 - Character Based Package Manager Frontend
-License:GPL-2.0+
-Group:  System/YaST
 Provides:   yast2-ncurses:%{_libdir}/YaST2/plugin/libpy2ncurses.so
 Provides:   yast2_ui_pkg
 Requires:   glibc-locale
@@ -63,7 +56,6 @@
 export CFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 export CXXFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 
-%{?suse_update_config:%{suse_update_config -f}}
 ./configure --libdir=%{_libdir} --prefix=%{_prefix} --mandir=%{_mandir}
 # V=1: verbose build in case we used AM_SILENT_RULES(yes)
 # so that RPM_OPT_FLAGS check works

++ yast2-ncurses-pkg-2.21.2.tar.bz2 - yast2-ncurses-pkg-2.22.0.tar.bz2 
++
 17923 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit cyrus-sasl for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package cyrus-sasl for openSUSE:Factory 
checked in at 2012-01-19 10:34:34

Comparing /work/SRC/openSUSE:Factory/cyrus-sasl (Old)
 and  /work/SRC/openSUSE:Factory/.cyrus-sasl.new (New)


Package is cyrus-sasl, Maintainer is rha...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/cyrus-sasl/cyrus-sasl-saslauthd.changes  
2011-11-25 23:04:33.0 +0100
+++ /work/SRC/openSUSE:Factory/.cyrus-sasl.new/cyrus-sasl-saslauthd.changes 
2012-01-19 10:34:35.0 +0100
@@ -1,0 +2,5 @@
+Wed Jan 18 13:06:35 UTC 2012 - a...@suse.de
+
+- Move some doc files from cyrus-sasl to here.
+
+---
--- /work/SRC/openSUSE:Factory/cyrus-sasl/cyrus-sasl.changes2011-11-25 
23:04:33.0 +0100
+++ /work/SRC/openSUSE:Factory/.cyrus-sasl.new/cyrus-sasl.changes   
2012-01-19 10:34:35.0 +0100
@@ -1,0 +2,5 @@
+Wed Jan 18 13:06:00 UTC 2012 - a...@suse.de
+
+- Move some doc files to devel package and to cyrus-sasl-saslauthd.
+
+---



Other differences:
--
++ cyrus-sasl-saslauthd.spec ++
--- /var/tmp/diff_new_pack.T4KGLs/_old  2012-01-19 10:34:37.0 +0100
+++ /var/tmp/diff_new_pack.T4KGLs/_new  2012-01-19 10:34:37.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package cyrus-sasl-saslauthd
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -139,6 +139,7 @@
 /usr/sbin/*
 /usr/bin/*
 %doc %{_mandir}/man8/*.gz
+%doc saslauthd/AUTHORS saslauthd/COPYING saslauthd/ChangeLog 
saslauthd/LDAP_SASLAUTHD saslauthd/NEWS saslauthd/README
 
 %files -n cyrus-sasl-sqlauxprop
 %defattr(-,root,root)

++ cyrus-sasl.spec ++
--- /var/tmp/diff_new_pack.T4KGLs/_old  2012-01-19 10:34:37.0 +0100
+++ /var/tmp/diff_new_pack.T4KGLs/_new  2012-01-19 10:34:37.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package cyrus-sasl
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -210,8 +210,7 @@
 /usr/bin/*
 %doc %{_mandir}/man3/sasl.*.gz
 %doc %{_mandir}/man8/*.gz
-%doc AUTHORS COPYING ChangeLog NEWS README doc
-%doc saslauthd/AUTHORS saslauthd/COPYING saslauthd/ChangeLog 
saslauthd/LDAP_SASLAUTHD saslauthd/NEWS saslauthd/README
+%doc COPYING
 
 %files gssapi
 %defattr(-,root,root)
@@ -247,6 +246,7 @@
 
 %files devel
 %defattr(-,root,root)
+%doc AUTHORS COPYING ChangeLog NEWS README doc
 /usr/include/sasl
 %doc %{_mandir}/man3/sasl_*.gz
 %{_libdir}/libsasl2.so

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit glibc for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package glibc for openSUSE:Factory checked 
in at 2012-01-19 10:34:43

Comparing /work/SRC/openSUSE:Factory/glibc (Old)
 and  /work/SRC/openSUSE:Factory/.glibc.new (New)


Package is glibc, Maintainer is m...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/glibc/glibc.changes  2012-01-11 
15:37:24.0 +0100
+++ /work/SRC/openSUSE:Factory/.glibc.new/glibc.changes 2012-01-19 
10:34:44.0 +0100
@@ -1,0 +2,23 @@
+Wed Jan 18 09:29:24 UTC 2012 - a...@suse.de
+
+- Update license strings in spec file.
+
+---
+Mon Jan 16 13:19:43 UTC 2012 - a...@suse.de
+
+- Split up new subpackage glibc-extra and move makedb with its
+  dependency on libselinux to it. (bnc#741525)
+- Use lua script for verifyscript to not have a dependency on bash
+
+---
+Thu Jan 12 15:42:36 UTC 2012 - a...@suse.de
+
+- Disable netlink caching (bnc#741021).
+
+---
+Thu Jan 12 11:01:41 UTC 2012 - a...@suse.de
+
+- Use _target_cpu instead of _build and _host. This makes the 
+  i686 library really build for i686.
+
+---

New:

  glibc-revert-netlink-cache.patch



Other differences:
--
++ glibc.spec ++
--- /var/tmp/diff_new_pack.udoRAZ/_old  2012-01-19 10:34:46.0 +0100
+++ /var/tmp/diff_new_pack.udoRAZ/_new  2012-01-19 10:34:46.0 +0100
@@ -20,7 +20,7 @@
 
 Name:   glibc
 Summary:Standard Shared Libraries (from the GNU C Library)
-License:GPL-2.0+
+License:LGPL-2.1+ and SUSE-LGPL-2.1+-with-GCC-exception and GPL-2.0+
 Group:  System/Libraries
 BuildRequires:  gcc-c++
 BuildRequires:  libselinux-devel
@@ -96,6 +96,7 @@
 Source51:   
http://www.openwall.com/crypt/crypt_blowfish-%{crypt_bf_version}.tar.gz.sign
 
 Requires(pre):  filesystem
+Recommends: glibc-extra
 Provides:   rtld(GNU_HASH)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if %_target_cpu == i686
@@ -196,6 +197,8 @@
 Patch90:glibc-ppc-getcontext.patch
 # PATCH-FIX-OPENSUSE Revert some math ifuncs (bnc#740109) - a...@suse.de
 Patch91:glibc-2.15-math64crash.patch
+# PATCH-FIX-OPENSUSE Remove netlink optimization (bnc#741021) - a...@suse.de
+Patch92:glibc-revert-netlink-cache.patch
 
 %description
 The GNU C Library provides the most important standard libraries used
@@ -205,7 +208,7 @@
 
 %package info
 Summary:Info Files for the GNU C Library
-License:GPL-2.0+
+License:GFDL-1.1
 Group:  Documentation/Other
 Requires(post): %{install_info_prereq}
 Requires(postun): %{install_info_prereq}
@@ -218,7 +221,7 @@
 
 %package html
 Summary:HTML Documentation for the GNU C Library
-License:GPL-2.0+ ; LGPL-2.1+
+License:GFDL-1.1
 Group:  Documentation/HTML
 BuildArch:  noarch
 
@@ -229,7 +232,7 @@
 
 %package i18ndata
 Summary:Database Sources for 'locale'
-License:LGPL-2.1+
+License:GPL-2.0+ and MIT
 Group:  System/Libraries
 BuildArch:  noarch
 
@@ -241,7 +244,7 @@
 
 %package locale
 Summary:Locale Data for Localized Programs
-License:GPL-2.0+ ; LGPL-2.1+
+License:GPL-2.0+ and MIT and LGPL-2.1+
 Group:  System/Libraries
 Requires(post): /bin/cat
 Requires:   glibc = %{version}
@@ -258,7 +261,7 @@
 
 %package -n nscd
 Summary:Name Service Caching Daemon
-License:LGPL-2.1+
+License:GPL-2.0+
 Group:  System/Daemons
 Provides:   aaa_base:/etc/init.d/nscd
 Provides:   glibc:/usr/sbin/nscd
@@ -273,7 +276,7 @@
 
 %package profile
 Summary:Libc Profiling and Debugging Versions
-License:LGPL-2.1+
+License:LGPL-2.1+ and SUSE-LGPL-2.1+-with-GCC-exception and GPL-2.0+
 Group:  Development/Libraries/C and C++
 Requires:   glibc = %{version}
 # bug437293
@@ -290,7 +293,7 @@
 
 %package devel
 Summary:Include Files and Libraries Mandatory for Development
-License:BSD-3-Clause ; GPL-2.0+ ; LGPL-2.1+
+License:BSD-3-Clause and LGPL-2.1+ and 
SUSE-LGPL-2.1+-with-GCC-exception and GPL-2.0+
 Group:  Development/Libraries/C and C++
 Obsoletes:  epoll = 1.0
 Provides:   epoll  1.0
@@ -310,7 +313,7 @@
 
 %package devel-static
 Summary:C library static libraries for -static linking
-License:GPL-2.0+
+License:BSD-3-Clause and LGPL-2.1+ and 
SUSE-LGPL-2.1+-with-GCC-exception and GPL-2.0+
 Group:  Development/Libraries/C and C++
 Requires:   %{name}-devel = 

commit gnome-online-accounts for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package gnome-online-accounts for 
openSUSE:Factory checked in at 2012-01-19 10:34:50

Comparing /work/SRC/openSUSE:Factory/gnome-online-accounts (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-online-accounts.new (New)


Package is gnome-online-accounts, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-online-accounts/gnome-online-accounts.changes  
2012-01-09 15:16:37.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.gnome-online-accounts.new/gnome-online-accounts.changes
 2012-01-19 10:34:52.0 +0100
@@ -1,0 +2,6 @@
+Fri Jan 13 13:13:04 UTC 2012 - vu...@opensuse.org
+
+- Add baselibs.conf, as we need the 32bit package for
+  evolution-data-server libraries.
+
+---

New:

  baselibs.conf



Other differences:
--
++ gnome-online-accounts.spec ++
--- /var/tmp/diff_new_pack.TSId91/_old  2012-01-19 10:34:54.0 +0100
+++ /var/tmp/diff_new_pack.TSId91/_new  2012-01-19 10:34:54.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gnome-online-accounts
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   gnome-online-accounts
 Version:3.3.0
 Release:0
@@ -23,6 +24,7 @@
 Group:  System/GUI/GNOME
 Url:http://www.gnome.org
 Source: 
http://download.gnome.org/sources/gnome-online-accounts/3.3/%{name}-%{version}.tar.xz
+Source99:   baselibs.conf
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  gobject-introspection-devel
 BuildRequires:  gtk-doc

++ baselibs.conf ++
libgoa-1_0-0
libgoa-backend-1_0-0

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit guile for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package guile for openSUSE:Factory checked 
in at 2012-01-19 10:34:55

Comparing /work/SRC/openSUSE:Factory/guile (Old)
 and  /work/SRC/openSUSE:Factory/.guile.new (New)


Package is guile, Maintainer is pgaj...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/guile/guile.changes  2011-12-20 
14:30:08.0 +0100
+++ /work/SRC/openSUSE:Factory/.guile.new/guile.changes 2012-01-19 
10:35:00.0 +0100
@@ -1,0 +2,5 @@
+Wed Jan 18 16:21:57 UTC 2012 - pgaj...@suse.com
+
+- don't conflict with guile1 [bnc#724917]
+
+---



Other differences:
--
++ guile.spec ++
--- /var/tmp/diff_new_pack.7qBjuF/_old  2012-01-19 10:35:01.0 +0100
+++ /var/tmp/diff_new_pack.7qBjuF/_new  2012-01-19 10:35:01.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package guile
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,7 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 # define the name used for versioning libs and directories.
 %define guilemaj2
 %define guilemin0
@@ -33,11 +32,11 @@
 BuildRequires:  libunistring-devel
 BuildRequires:  pkg-config
 BuildRequires:  readline-devel
-License:GFDL-1.3 and GPL-3.0+ and LGPL-3.0+
-Group:  Development/Languages/Scheme
 Version:%{guilevers}.3
 Release:0
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+License:GFDL-1.3 and GPL-3.0+ and LGPL-3.0+
+Group:  Development/Languages/Scheme
 Url:http://www.gnu.org/software/guile/
 Source0:%{name}-%{version}.tar.bz2
 Patch1: %{name}-64bit.patch
@@ -49,7 +48,6 @@
 PreReq: fileutils sh-utils
 PreReq: %install_info_prereq
 Conflicts:  slib  3a5
-Conflicts:  guile1
 
 %description
 This is Guile, a portable, embeddable Scheme implementation written in
@@ -58,6 +56,8 @@
 
 %package -n libguile-%{gsuff}
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+License:GFDL-1.3 and GPL-3.0+ and LGPL-3.0+
+Group:  Development/Languages/Scheme
 Requires:   %{name}-modules-%{guilemaj}_%{guilemin} = %{version}
 
 %description -n libguile-%{gsuff}
@@ -68,6 +68,8 @@
 
 %package modules-%{guilemaj}_%{guilemin}
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+License:GFDL-1.3 and GPL-3.0+ and LGPL-3.0+
+Group:  Development/Languages/Scheme
 
 %description modules-%{guilemaj}_%{guilemin}
 This is Guile, a portable, embeddable Scheme implementation written in
@@ -77,6 +79,8 @@
 
 %package -n libguilereadline-%{greadsuff}
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+License:GFDL-1.3 and GPL-3.0+ and LGPL-3.0+
+Group:  Development/Languages/Scheme
 
 %description -n libguilereadline-%{greadsuff}
 This is Guile, a portable, embeddable Scheme implementation written in
@@ -85,14 +89,14 @@
 contains the shared libraries.
 
 %package devel
-License:LGPL-2.1+
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+License:LGPL-2.1+
+Group:  Development/Languages/Scheme
 Requires:   gmp-devel readline-devel ncurses-devel gc-devel 
libunistring-devel libffi-devel
 # following Requires needed because /usr/bin/guile-config needs /usr/bin/guile
 Requires:   guile = %{version}
 Requires:   libguilereadline-%{greadsuff} = %{version}
 Requires:   libguile-%{gsuff} = %{version}
-Conflicts:  libguile1-devel
 
 %description devel
 This is Guile, a portable, embeddable Scheme implementation written in

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit ImageMagick for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package ImageMagick for openSUSE:Factory 
checked in at 2012-01-19 10:35:02

Comparing /work/SRC/openSUSE:Factory/ImageMagick (Old)
 and  /work/SRC/openSUSE:Factory/.ImageMagick.new (New)


Package is ImageMagick, Maintainer is pgaj...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/ImageMagick/ImageMagick.changes  2011-11-14 
11:53:51.0 +0100
+++ /work/SRC/openSUSE:Factory/.ImageMagick.new/ImageMagick.changes 
2012-01-19 10:35:03.0 +0100
@@ -1,0 +2,10 @@
+Tue Jan 17 19:42:15 UTC 2012 - crrodrig...@opensuse.org
+
+- Add explicit libbz2-devel BuildRequires
+- Support LZMA
+- Use libcms2 now.
+- Cleanup huge dependency bloat in -devel package, this 
+  will likely cause build fails on dependant packages
+  the solution is to fix your BuildRequires.
+
+---



Other differences:
--
++ ImageMagick.spec ++
--- /var/tmp/diff_new_pack.vPtvLN/_old  2012-01-19 10:35:06.0 +0100
+++ /var/tmp/diff_new_pack.vPtvLN/_new  2012-01-19 10:35:06.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package ImageMagick
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -36,7 +36,8 @@
 
 BuildRequires:  fdupes pkgconfig
 BuildRequires:  libtool
-
+BuildRequires:  libbz2-devel
+BuildRequires:  lzma-devel
 %if %{with DCraw}
 BuildRequires:  dcraw
 %endif
@@ -54,7 +55,7 @@
 %endif
 
 %if %{with LCMS}
-BuildRequires:  liblcms-devel
+BuildRequires:  liblcms2-devel
 %endif
 
 %if %{with TIFF}
@@ -129,30 +130,7 @@
 Requires:   ImageMagick = %{version}
 Summary:Include Files and Libraries Mandatory for Development
 Group:  Development/Libraries/C and C++
-%if %{with FreeType}
-Requires:   freetype2-devel
-%endif
-%if %{with LCMS}
-Requires:   liblcms-devel
-%endif
-%if %{with TIFF}
-Requires:   libtiff-devel
-%endif
-%if %{with WMF}
-Requires:   libwmf-devel
-%endif
-%if %{with EXIF}
-Requires:   libexif-devel
-%endif
-%if %{with JPEG}
-Requires:   libjasper-devel
-%endif
-%if %{with WEBP}
-Requires:   libwebp-devel
-%endif
-%if %{with RSVG}
-Requires:   librsvg-devel
-%endif
+Requires:   glibc-devel
 
 %package extra
 License:PERMISSIVE-OSI-COMPLIANT
@@ -214,7 +192,7 @@
 %{__make} header-test.o   #
 
 %build
-%define CFLAGS ${RPM_OPT_FLAGS} -fstack-protector-all
+%define CFLAGS ${RPM_OPT_FLAGS}
 %define LDFLAGS -L%{_libdir}
 %define system_ltdl 0
 %if %system_ltdl
@@ -238,7 +216,7 @@
 # openmp does not work with perl module
   OPENMP=--disable-openmp
 %endif
-%configure \
+%configure --with-pic \
   --enable-shared \
   --without-frozenpaths \
   --with-magick_plus_plus \
@@ -509,4 +487,11 @@
 
 
 
+
+
+
+
+
+
+
 %changelog

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libdbi-drivers for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libdbi-drivers for openSUSE:Factory 
checked in at 2012-01-19 10:35:09

Comparing /work/SRC/openSUSE:Factory/libdbi-drivers (Old)
 and  /work/SRC/openSUSE:Factory/.libdbi-drivers.new (New)


Package is libdbi-drivers, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libdbi-drivers/libdbi-drivers.changes
2011-09-23 02:08:05.0 +0200
+++ /work/SRC/openSUSE:Factory/.libdbi-drivers.new/libdbi-drivers.changes   
2012-01-19 10:35:10.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:30:42 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ libdbi-drivers.spec ++
--- /var/tmp/diff_new_pack.2vEsl3/_old  2012-01-19 10:35:11.0 +0100
+++ /var/tmp/diff_new_pack.2vEsl3/_new  2012-01-19 10:35:11.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libdbi-drivers
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,21 +15,25 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %define special -1
 
 Summary:Database drivers for libdbi
+License:LGPL-2.1+
+Group:  Development/Libraries
 
 Name:   libdbi-drivers
 Version:0.8.3
-Release:6
-Group:  Development/Libraries
-License:LGPL
+Release:0
 Url:http://libdbi-drivers.sourceforge.net/
 Source: %{name}-%{version}%{special}.tar.bz2
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
-BuildRequires:  gettext libdbi-devel mysql-devel openjade postgresql-devel 
sqlite-devel
+BuildRequires:  gettext
+BuildRequires:  libdbi-devel
+BuildRequires:  mysql-devel
+BuildRequires:  openjade
+BuildRequires:  postgresql-devel
+BuildRequires:  sqlite-devel
 
 %description
 libdbi implements a database-independent abstraction layer in C, similar to the
@@ -41,7 +45,6 @@
 
 
 %package dbd-mysql
-License:LGPL
 Summary:MySQL driver for libdbi
 Group:  Development/Libraries
 Requires:   libdbi0 = %{version}
@@ -52,7 +55,6 @@
 does not require recompilation or rewriting source code.
 
 %package dbd-pgsql
-License:LGPL
 Summary:PostgreSQL driver for libdbi
 Group:  Development/Libraries
 Requires:   libdbi0 = %{version}, postgresql = 7.0.3
@@ -66,7 +68,6 @@
 # SLES 9
 
 %package dbd-sqlite
-License:LGPL
 Summary:SQLite driver for libdbi
 Group:  Development/Libraries
 Requires:   libdbi0 = %{version}, sqlite
@@ -80,7 +81,6 @@
 
 %package dbd-sqlite3
 
-
 Summary:SQLite3 driver for libdbi
 Group:  Development/Libraries
 Requires:   libdbi0 = %{version}, sqlite

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libmtp for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libmtp for openSUSE:Factory checked 
in at 2012-01-19 10:35:14

Comparing /work/SRC/openSUSE:Factory/libmtp (Old)
 and  /work/SRC/openSUSE:Factory/.libmtp.new (New)


Package is libmtp, Maintainer is meiss...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/libmtp/libmtp.changes2011-12-31 
17:19:40.0 +0100
+++ /work/SRC/openSUSE:Factory/.libmtp.new/libmtp.changes   2012-01-19 
10:35:18.0 +0100
@@ -1,0 +2,15 @@
+Fri Jan 13 11:35:55 CET 2012 - meiss...@suse.de
+
+- updated to 1.1.2
+  * device updates
+  * ported to use libusb 1.0
+  * Autodetect sony.net devices
+
+---
+Thu Dec 29 16:30:06 UTC 2011 - jeng...@medozas.de
+
+- Remove redundant tags/sections (authors list, already in package
+  as a file); put %description after %package
+- Parallel build with %_smp_mflags
+
+---

Old:

  add-galaxy-nexus-support.diff
  libmtp-1.1.1.tar.gz

New:

  libmtp-1.1.2.tar.gz



Other differences:
--
++ libmtp.spec ++
--- /var/tmp/diff_new_pack.ecfoWa/_old  2012-01-19 10:35:19.0 +0100
+++ /var/tmp/diff_new_pack.ecfoWa/_new  2012-01-19 10:35:19.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libmtp
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,15 +20,14 @@
 Name:   libmtp
 Url:http://sf.net/projects/libmtp
 BuildRequires:  doxygen
-BuildRequires:  libusb-devel
+BuildRequires:  libusb-1_0-devel
 BuildRequires:  pkg-config
 Summary:Commandline utilities for access to MTP Players
 License:LGPL-2.1+
 Group:  Productivity/Multimedia/Sound/Players
-Version:1.1.1
+Version:1.1.2
 Release:0
 Source0:
http://downloads.sourceforge.net/project/libmtp/libmtp/%{version}/libmtp-%{version}.tar.gz
-Patch0: add-galaxy-nexus-support.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -39,17 +38,6 @@
 Common devices using this technology are Creative Zen, iRiver, Samsung
 and others.
 
-
-
-Authors:
-
-Richard Low rich...@wentnet.com
-Linus Walleij tr...@df.lth.se
-
-based on code by:
-Mariusz Woloszyn e...@ipartners.pl
-Marcus Meissner mar...@jet.franken.de
-
 %package -n libmtp9
 Summary:Library for accessing MTP Players
 Group:  Productivity/Multimedia/Sound/Players
@@ -62,21 +50,15 @@
 Common devices using this technology are Creative Zen, iRiver, Samsung
 and others.
 
-
-
-Authors:
-
-Richard Low rich...@wentnet.com
-Linus Walleij tr...@df.lth.se
-
-based on code by:
-Mariusz Woloszyn e...@ipartners.pl
-Marcus Meissner mar...@jet.franken.de
-
 %package -n mtp-tools
 Summary:Commandline utilities for access to MTP Players
 Group:  Productivity/Multimedia/Sound/Players
 
+%description -n mtp-tools
+This package contains binaries that allow command line access to USB
+based media players based on the MTP (Media Transfer Protocol) authored
+by Microsoft. For graphical user interfaces use Amarok or Banshee.
+
 %package devel
 Summary:Development files for access to MTP Player library
 Group:  Development/Libraries/Other
@@ -88,40 +70,12 @@
 that allows access to USB based media players based on the MTP (Media
 Transfer Protocol) authored by Microsoft.
 
-
-
-Authors:
-
-Richard Low rich...@wentnet.com
-Linus Walleij tr...@df.lth.se
-
-based on code by:
-Mariusz Woloszyn e...@ipartners.pl
-Marcus Meissner mar...@jet.franken.de
-
-%description -n mtp-tools
-This package contains binaries that allow command line access to USB
-based media players based on the MTP (Media Transfer Protocol) authored
-by Microsoft. For graphical user interfaces use Amarok or Banshee.
-
-
-
-Authors:
-
-Richard Low rich...@wentnet.com
-Linus Walleij tr...@df.lth.se
-
-based on code by:
-Mariusz Woloszyn e...@ipartners.pl
-Marcus Meissner mar...@jet.franken.de
-
 %prep
 %setup -q
-%patch0 -p0
 
 %build
 %configure --disable-static --enable-doxygen
-make
+make %{?_smp_mflags}
 
 %install
 make install DESTDIR=$RPM_BUILD_ROOT

++ libmtp-1.1.1.tar.gz - libmtp-1.1.2.tar.gz ++
 8109 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org


commit tboot for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package tboot for openSUSE:Factory checked 
in at 2012-01-19 10:35:21

Comparing /work/SRC/openSUSE:Factory/tboot (Old)
 and  /work/SRC/openSUSE:Factory/.tboot.new (New)


Package is tboot, Maintainer is meiss...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/tboot/tboot.changes  2011-09-23 
12:47:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.tboot.new/tboot.changes 2012-01-19 
10:35:22.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:31:12 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ tboot.spec ++
--- /var/tmp/diff_new_pack.gSAa6V/_old  2012-01-19 10:35:23.0 +0100
+++ /var/tmp/diff_new_pack.gSAa6V/_new  2012-01-19 10:35:23.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package tboot
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,19 +15,18 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   tboot
 Version:20110520
-Release:1
+Release:0
 Summary:Performs a verified launch using Intel(R) TXT
+License:BSD-3-Clause
 Group:  Productivity/Security
-License:BSD
 Url:http://sourceforge.net/projects/tboot/
 Source0:%{name}-%{version}.tar.bz2
 #Patch0: tboot-%{version}-Makefile_typo.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  openssl-devel trousers-devel
+BuildRequires:  openssl-devel
+BuildRequires:  trousers-devel
 
 #ExclusiveArch: %{ix86} x86_64
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit xorg-x11-server for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package xorg-x11-server for openSUSE:Factory 
checked in at 2012-01-19 10:35:26

Comparing /work/SRC/openSUSE:Factory/xorg-x11-server (Old)
 and  /work/SRC/openSUSE:Factory/.xorg-x11-server.new (New)


Package is xorg-x11-server, Maintainer is sndir...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/xorg-x11-server/xorg-x11-server.changes  
2012-01-13 11:00:56.0 +0100
+++ /work/SRC/openSUSE:Factory/.xorg-x11-server.new/xorg-x11-server.changes 
2012-01-19 10:35:27.0 +0100
@@ -1,0 +2,6 @@
+Fri Jan 13 14:40:00 UTC 2012 - sndir...@suse.com
+
+- added /usr/share/fonts/misc/sgi to Xserver core font rendering
+  fontpath (bnc#738961)
+
+---



Other differences:
--
++ xorg-x11-server.spec ++
--- /var/tmp/diff_new_pack.lqvdQc/_old  2012-01-19 10:35:29.0 +0100
+++ /var/tmp/diff_new_pack.lqvdQc/_new  2012-01-19 10:35:29.0 +0100
@@ -256,6 +256,7 @@
 /usr/share/fonts/Type1/,/usr/share/fonts/100dpi:unscaled,\
 /usr/share/fonts/75dpi:unscaled,/usr/share/fonts/URW/,\
 /usr/share/fonts/cyrillic:unscaled,\
+/usr/share/fonts/misc/sgi:unscaled,\
 /usr/share/fonts/truetype/,built-ins
 make %{?jobs:-j %jobs}
 make -C hw/kdrive %{?jobs:-j %jobs}

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit horde4-ingo for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package horde4-ingo for openSUSE:Factory 
checked in at 2012-01-19 11:05:53

Comparing /work/SRC/openSUSE:Factory/horde4-ingo (Old)
 and  /work/SRC/openSUSE:Factory/.horde4-ingo.new (New)


Package is horde4-ingo, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/horde4-ingo/horde4-ingo.changes  2011-12-22 
10:54:09.0 +0100
+++ /work/SRC/openSUSE:Factory/.horde4-ingo.new/horde4-ingo.changes 
2012-01-19 11:05:55.0 +0100
@@ -1,0 +2,13 @@
+Tue Jan 17 16:02:41 UTC 2012 - l...@b1-systems.de
+
+- version 2.0.7
+- [jan] Fix disabling of actions by locking preferences (Bug #10455).
+- [jan] Sort blacklist and whitelist for display instead of for storage.
+- [mms] Fix displaying From address in notification when filtering with IMAP 
driver.
+- [jan] Catch if files donapos;t exist while deleting with VFS transport 
(michael-...@fami-braun.de, Bug #10494).
+- [jan] Update Japanese translation (Hiromi Kimura 
lt;hir...@tac.tsukuba.ac.jpgt;).
+- [jan] Set Return-Path: in Maildrop vacation driver (rsal...@mbpgroup.com, 
Bug #10568).
+- [mms] Additional fixes when creating new mailboxes (Bug #10282).
+- [mms] Fix creating new mailboxes (Bug #10282).
+
+---

Old:

  ingo-2.0.4.tgz

New:

  ingo-2.0.7.tgz



Other differences:
--
++ horde4-ingo.spec ++
--- /var/tmp/diff_new_pack.krmOw7/_old  2012-01-19 11:05:56.0 +0100
+++ /var/tmp/diff_new_pack.krmOw7/_new  2012-01-19 11:05:56.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package horde4-ingo
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,12 +20,12 @@
 %define xmldir  /var/lib/pear
 %define hordedir /usr/share/php5/PEAR/www/horde
 
-Summary:PEAR: An email filter rules manager
+Summary:Ingo email filter rules manager
 License:BSD-3-Clause
 Group:  Productivity/Networking/Web/Utilities
 
 Name:   horde4-ingo
-Version:2.0.4
+Version:2.0.7
 Release:0
 Source0:http://pear.horde.org/get/ingo-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -78,7 +78,6 @@
 
 Requires:   horde4-timeobjects horde4-content
 Requires:   php5-gettext 
-#php5-singolexml
 BuildArch:  noarch
 
 %description

++ ingo-2.0.4.tgz - ingo-2.0.7.tgz ++
 99324 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit horde4-kronolith for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package horde4-kronolith for 
openSUSE:Factory checked in at 2012-01-19 11:05:57

Comparing /work/SRC/openSUSE:Factory/horde4-kronolith (Old)
 and  /work/SRC/openSUSE:Factory/.horde4-kronolith.new (New)


Package is horde4-kronolith, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/horde4-kronolith/horde4-kronolith.changes
2011-09-23 02:02:53.0 +0200
+++ /work/SRC/openSUSE:Factory/.horde4-kronolith.new/horde4-kronolith.changes   
2012-01-19 11:05:59.0 +0100
@@ -1,0 +2,79 @@
+Tue Jan 17 16:06:14 UTC 2012 - l...@b1-systems.de
+
+- version 3.0.14
+- [jan] Fix fatal error while searching if hitting certain recurring events.
+- [jan] Fix exporting events with snoozed alarms (Bug #10438).
+- [jan] Fix opening events from agenda view.
+- [mjr] The current default calendar is always included in the sync_calendars 
pref.
+- [mjr] Ensure exception gets start and end times when created from month view 
(Bug #10496)
+- [jan] Update group permission when changing group down list in basic 
permissions (Bug #10482).
+- [jan] Fix race condition when editing group permission in basic permission 
screen (Bug #10482).
+- [mjr] Fix removeUserData API (Bug #10241).
+- [jan] Fix deleting events with a WebDAV client (Bug #10478).
+- [mjr] Fix alarms for recurring events (Bug #10678).
+- [mjr] Allow filtering listTagInfo results by user.
+- [jan] Fix uncompleting tasks in dynamic view (Carlos Timóteo, Bug #10653).
+- [cjh/jan] Improve design.
+- [mjr] Fix displaying resources when no attendees are present (Bug #10507).
+- [jan] Show status of events in agenda messages (Request #10517).
+- [mjr] Fix selecting custom time from time selection drop down (Bug #10737).
+- [jan] Always use fresh Horde_Http_Client instances for remote calendars (Bug 
#10740).
+- [jan] Add confirmation screen when deleting events in dynamic view (Request 
#10725).
+- [jan] Fix holidays disappearing from month view if deleting another event.
+- [jan] Fix resetting attendee response status when saving events in dynamic 
view (Bug #10620).
+- [jan] Support CalDAV servers that donapos;t use DAV: as the default 
namespace (chris...@buergi.lugs.ch, Bug #10716).
+- [jan] Allow to view and create copies of holiday events (Bug #10650).
+- [jan] Donapos;t show import/export tabs in dynamic view if disabled (Bug 
#10705).
+- [jan] Donapos;t show option to share with everyone in basic permissions if 
disabled (pi...@hrz.uni-marburg.de, Bug #10706).
+- [mjr] Only set ORGANIZER field if the event is a group meeting (Bug #10697).
+- [jan] Hide disabled calendar sections (Bug #9815).
+- [gwr] Fixed recurrence handling with the Kolab backend.
+- [gwr] Fixed naming of the default calendar for the Kolab backend.
+- [gwr] Fixed deleting events with the Kolab backend.
+- [gwr] Fixed migrations for SQLite as database backend.
+- [mjr] Fix keyboard navigation of time entry fields in dynamic view (Bug 
#10799).
+- [mjr] Fix parsing display_cal variables for internal calendar links on 
various blocks and embedded imples (Bug #10767).
+- [mjr] Fix adding events directly to a resourceapos;s calendar (Bug #10827).
+- [mjr] Fix regression introduced in 3.0.12 that broke checking a 
Resourceapos;s availability in certain cases (Bug #10806).
+- [jan] Donapos;t fail on empty CalDAV calendars (chris...@buergi.lugs.ch, 
Bug #10739).
+- [jan] Check permissions when building application drop down 
(sberthe...@emisfr.com, Bug #10811).
+- [gwr] Fix saving Kolab events.
+- [jan] Update Japanese translation (Hiromi Kimura 
lt;hir...@tac.tsukuba.ac.jpgt;).
+- [mjr] Fix bug that could cause incorrect event exceptions to be created when 
drag and dropping events in month view.
+- [jan] Fix page titles not always updating correctly.
+- [jan] Display event time in dynamic view if requested (Request #9866).
+- [jan] Only show end time if different from start time.
+- [jan] Fix day sorting in agenda view.
+- [jan] Sort user and group names in permission screen (Request #10896).
+
+
+---
+Sat Aug 27 20:03:46 UTC 2011 - l...@b1-systems.de
+
+- version 3.0.8
+- [jan] Fix deleting resources (Bug #10427)
+- [jan] Support snoozing alarms with Sundbird/Lightning (Request #7470).
+- [jan] Import VALARM components from iCalendar 2.0 data (Request #6665).
+- [jan] Fix creating events from dynamic view on Windows (Bug #9916).
+- [mjr] Fix displaying of freebusy data in dynamic view 
(adoming...@cne.gob.ve, Bug #10347)
+
+---
+Mon Aug 15 11:28:45 UTC 2011 - l...@b1-systems.de
+
+- version 3.0.7
+- [jan] Display event time in dynamic agenda/search view.
+- [jan] Don't load all shares with requested permissions from the backend if 

commit horde4-timeobjects for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package horde4-timeobjects for 
openSUSE:Factory checked in at 2012-01-19 11:06:01

Comparing /work/SRC/openSUSE:Factory/horde4-timeobjects (Old)
 and  /work/SRC/openSUSE:Factory/.horde4-timeobjects.new (New)


Package is horde4-timeobjects, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/horde4-timeobjects/horde4-timeobjects.changes
2011-12-22 10:54:16.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.horde4-timeobjects.new/horde4-timeobjects.changes   
2012-01-19 11:06:03.0 +0100
@@ -1,0 +2,12 @@
+Tue Jan 17 16:39:34 UTC 2012 - l...@b1-systems.de
+
+- version 1.0.5
+- [mjr] Remove support for the now non-existent weatherdotcom API.
+- [mjr] Add support for Horde_Service_Weather.
+- [jan] Add Latvian translation (Jānis Eisaks lt;ja...@dv.lvgt;).
+- [jan] Add Estonian translation (Alar Sing lt;alar.s...@err.eegt;).
+- [jan] Add Dutch translation (Arjen de Korte 
lt;arjen+ho...@de-korte.orggt;).
+- [jan] Update Japanese translation (Hiromi Kimura 
lt;hir...@tac.tsukuba.ac.jpgt;).
+- [jan] Fix retrieving driver list if Horde_Service_Weather is not installed.
+
+---

Old:

  timeobjects-1.0.2.tgz

New:

  timeobjects-1.0.5.tgz



Other differences:
--
++ horde4-timeobjects.spec ++
--- /var/tmp/diff_new_pack.gj5iQx/_old  2012-01-19 11:06:04.0 +0100
+++ /var/tmp/diff_new_pack.gj5iQx/_new  2012-01-19 11:06:04.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package horde4-timeobjects
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,12 +20,12 @@
 %define xmldir  /var/lib/pear
 %define hordedir /usr/share/php5/PEAR/www/horde
 
-Summary:PEAR: Horde timeobjects application
+Summary:Horde timeobjects application
 License:BSD-3-Clause
 Group:  Productivity/Networking/Web/Utilities
 
 Name:   horde4-timeobjects
-Version:1.0.2
+Version:1.0.5
 Release:0
 Source0:http://pear.horde.org/get/timeobjects-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ timeobjects-1.0.2.tgz - timeobjects-1.0.5.tgz ++
 2942 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Db for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Db for 
openSUSE:Factory checked in at 2012-01-19 11:06:07

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Db (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Db.new (New)


Package is php5-pear-Horde_Db, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/php5-pear-Horde_Db/php5-pear-Horde_Db.changes
2011-12-19 16:09:54.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Db.new/php5-pear-Horde_Db.changes   
2012-01-19 11:06:08.0 +0100
@@ -1,0 +2,23 @@
+Fri Jan 13 11:40:51 UTC 2012 - l...@b1-systems.de
+
+- version 1.2.0
+- add license file
+- [jan] Fix migrations from primary keys that have not been created with 
Horde_Db in PostgreSQL.
+- [jan] Fix autoincrementKey sequences not incrementing after manually 
inserting key values in PostgreSQL.
+- [jan] Fix changeColumn() migration to autoincrementKey if no primary key 
exists yet.
+- [jan] Fix determination of last insert id on PostgreSQL up to 8.1.
+- [jan] Add methods to add and drop primary keys (Request #10469).
+- [gwr] Fix usage of Horde_Exception_Wrapped.
+- [jan] Fix setting unix socket in PostgreSQL DSN (bug-repo...@flipjam.co.uk, 
Bug #10466).
+- [jan] More flexible conversion of charset names to native MySQL names.
+- [jan] Correctly escape binding characters in buildClause() (Bug #10610).
+- [jan] Fix transactions with MySQLi driver (Bug #10578).
+- [jan] Fix DISTINCT clause generation on PostgreSQL (Bug #10543).
+- [mms] Fix escaping binary data on Postgresql 9.1+ servers (Bug #10602).
+- [mms] Greatly reduce memory usage when working with binary data in 
PostgreSQL 9.0+ (Bug #10774).
+- [mms] Cache postgresql version.
+- [jan] Improve API documentation.
+- [gwr] Alternative API to support modified dates with SQLite as well.
+- [mjr] Add support for mediumtext and longtext field types.
+
+---

Old:

  Horde_Db-1.0.3.tgz

New:

  Horde_Db-1.2.0.tgz



Other differences:
--
++ php5-pear-Horde_Db.spec ++
--- /var/tmp/diff_new_pack.5191XG/_old  2012-01-19 11:06:09.0 +0100
+++ /var/tmp/diff_new_pack.5191XG/_new  2012-01-19 11:06:09.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Db
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,7 +24,7 @@
 Group:  Development/Libraries/PHP
 
 Name:   php5-pear-Horde_Db
-Version:1.0.3
+Version:1.2.0
 Release:0
 Source0:http://pear.horde.org/get/Horde_Db-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ Horde_Db-1.0.3.tgz - Horde_Db-1.2.0.tgz ++
 40184 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Http for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Http for 
openSUSE:Factory checked in at 2012-01-19 11:06:11

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Http (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Http.new (New)


Package is php5-pear-Horde_Http, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Http/php5-pear-Horde_Http.changes
2011-12-19 16:09:58.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Http.new/php5-pear-Horde_Http.changes
   2012-01-19 11:06:13.0 +0100
@@ -1,0 +2,10 @@
+Fri Jan 13 12:58:19 UTC 2012 - l...@b1-systems.de
+
+- version 1.1.0
+- license file
+- [gwr] Added SOCKS proxy support where available.
+- [gwr] Support multiple mock responses with the mock request.
+- [gwr] Fixed setting response headers for the mock response.
+
+
+---

Old:

  Horde_Http-1.0.3.tgz

New:

  Horde_Http-1.1.0.tgz



Other differences:
--
++ php5-pear-Horde_Http.spec ++
--- /var/tmp/diff_new_pack.FTmMXi/_old  2012-01-19 11:06:14.0 +0100
+++ /var/tmp/diff_new_pack.FTmMXi/_new  2012-01-19 11:06:14.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Http
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,7 +24,7 @@
 Group:  Development/Libraries/PHP
 
 Name:   php5-pear-Horde_Http
-Version:1.0.3
+Version:1.1.0
 Release:0
 Source0:http://pear.horde.org/get/Horde_Http-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -95,5 +95,6 @@
 
 %{peardir}/*
 %{xmldir}/Horde_Http.xml
+%doc %{_docdir}/%{name}
 
 %changelog

++ Horde_Http-1.0.3.tgz - Horde_Http-1.1.0.tgz ++
 3606 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Ldap for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Ldap for 
openSUSE:Factory checked in at 2012-01-19 11:06:16

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Ldap (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Ldap.new (New)


Package is php5-pear-Horde_Ldap, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Ldap/php5-pear-Horde_Ldap.changes
2011-09-23 12:40:29.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Ldap.new/php5-pear-Horde_Ldap.changes
   2012-01-19 11:06:18.0 +0100
@@ -1,0 +2,8 @@
+Sat Jan 14 12:41:50 UTC 2012 - l...@b1-systems.de
+
+- version 1.1.4
+- use shipped lgpl file, drop external file
+- [jan] Speed up Horde_Ldap_Search#shiftEntry() on large result sets.
+- [jan] Add missing test autoloader.
+
+---

Old:

  Horde_Ldap-1.1.2.tgz
  lgpl-3.0.txt

New:

  Horde_Ldap-1.1.4.tgz



Other differences:
--
++ php5-pear-Horde_Ldap.spec ++
--- /var/tmp/diff_new_pack.fkrXVm/_old  2012-01-19 11:06:19.0 +0100
+++ /var/tmp/diff_new_pack.fkrXVm/_new  2012-01-19 11:06:19.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Ldap
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,14 +20,13 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: Horde LDAP libraries
-
-Name:   php5-pear-Horde_Ldap
-Version:1.1.2
-Release:2
 License:LGPL-3.0
 Group:  Development/Libraries/PHP
+
+Name:   php5-pear-Horde_Ldap
+Version:1.1.4
+Release:0
 Source0:http://pear.horde.org/get/Horde_Ldap-%{version}.tgz
-Source1:http://www.gnu.org/licenses/lgpl-3.0.txt
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Ldap
 BuildRequires:  php5-pear = 1.4.7
@@ -79,7 +78,6 @@
 mkdir -p %{buildroot}%{xmldir}
 tar -xzf %{SOURCE0} package.xml
 %{__install} -D -m0644  package.xml %{buildroot}%{xmldir}/Horde_Ldap.xml
-%{__install} -D -m0644 %{SOURCE1} %{buildroot}/%{_docdir}/%{name}/%{SOURCE1}
 
 %clean
 rm -rf %{buildroot}

++ Horde_Ldap-1.1.2.tgz - Horde_Ldap-1.1.4.tgz ++
 16265 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Mail for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Mail for 
openSUSE:Factory checked in at 2012-01-19 11:06:23

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Mail (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Mail.new (New)


Package is php5-pear-Horde_Mail, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Mail/php5-pear-Horde_Mail.changes
2011-12-19 16:10:07.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Mail.new/php5-pear-Horde_Mail.changes
   2012-01-19 11:06:24.0 +0100
@@ -1,0 +2,10 @@
+Tue Jan 17 12:48:24 UTC 2012 - l...@b1-systems.de
+
+- version 1.0.3
+- add license file
+- [mms] Fix parseAddressList() for empty address strings (Bug #10534).
+- [mms] Fix SMTP error codes/messages (Bug #10498).
+- [mms] Always use canonical line endings in sendmail driver (Bug #10696).
+- [mms] Fix line-endings for transport drivers that send messages using local 
tools/programs.
+
+---

Old:

  Horde_Mail-1.0.0.tgz

New:

  Horde_Mail-1.0.3.tgz



Other differences:
--
++ php5-pear-Horde_Mail.spec ++
--- /var/tmp/diff_new_pack.FmTw8b/_old  2012-01-19 11:06:25.0 +0100
+++ /var/tmp/diff_new_pack.FmTw8b/_new  2012-01-19 11:06:25.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Mail
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,7 +24,7 @@
 Group:  Development/Libraries/PHP
 
 Name:   php5-pear-Horde_Mail
-Version:1.0.0
+Version:1.0.3
 Release:0
 Source0:http://pear.horde.org/get/Horde_Mail-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -102,5 +102,6 @@
 
 %{peardir}/*
 %{xmldir}/Horde_Mail.xml
+%doc %{_docdir}/%{name}/
 
 %changelog

++ Horde_Mail-1.0.0.tgz - Horde_Mail-1.0.3.tgz ++
 6049 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Mime for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Mime for 
openSUSE:Factory checked in at 2012-01-19 11:06:26

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Mime (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Mime.new (New)


Package is php5-pear-Horde_Mime, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Mime/php5-pear-Horde_Mime.changes
2011-09-23 12:40:31.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Mime.new/php5-pear-Horde_Mime.changes
   2012-01-19 11:06:28.0 +0100
@@ -1,0 +2,23 @@
+Tue Jan 17 12:59:59 UTC 2012 - l...@b1-systems.de
+
+- version 1.4.1
+- ships license file
+- spec spdx license format
+- [mms] Fix quoted-printable encoding for message parts contained in a 
multipart that do not share the same EOLs as the parent part (Bug #10324).
+- [mms] Provide method to return approximate size of parts if it contains 
base64 encoded data (Request #9783).
+- [mms] Support Content-Duration MIME header (RFC 3803).
+- [mms] MIME body part can not have disposition of apos;attachmentapos; (Bug 
#10458).
+- [jan] Add Horde_Mime_Mail#clearParts().
+- [mms] Horde_Mime_Part::getRawPartText() was incorrectly returning a trailing 
EOL for body data.
+- [jan] Make unit tests locale independent.
+- [mms] Added apos;canonicalapos; parameter to Horde_Mime_Headers#toArray() 
and Horde_Mime_Headers#toString() (Bug #10696).
+- [mms] Work around broken number_format() in PHP lt; 5.4.0.
+- [mms] Fix for broken 8BITMIME/BINARYMIME SMTP capability detection 
(chris...@buergi.lugs.ch, Bug #10820).
+- [mms] Improved detection of charsets in broken (8-bit) MIME headers.
+- [mms] Allow Horde_Mime_Part::getRawPartText() to accept stream input.
+- [mms] Workaround incoming message data to Horde_Mime_Part::getRawPartText() 
that contains varying EOL characters (Bug #10809).
+- [mms] Fix detection of MIME boundaries at beginning of string (Bug #10809).
+- [mms] Abstract charset detection code out into 
Horde_Mime_Headers::sanityCheck().
+- [jan] Improve compatibility with some broken text MIME parts (Bug #10925).
+
+---

Old:

  Horde_Mime-1.0.5.tgz

New:

  Horde_Mime-1.4.1.tgz



Other differences:
--
++ php5-pear-Horde_Mime.spec ++
--- /var/tmp/diff_new_pack.t37pVq/_old  2012-01-19 11:06:29.0 +0100
+++ /var/tmp/diff_new_pack.t37pVq/_new  2012-01-19 11:06:29.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Mime
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,17 +15,16 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %define peardir %(pear config-get php_dir 2 /dev/null || echo 
%{_datadir}/pear)
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: Horde MIME Library
-
-Name:   php5-pear-Horde_Mime
-Version:1.0.5
-Release:1
 License:LGPL-2.1
 Group:  Development/Libraries/PHP
+
+Name:   php5-pear-Horde_Mime
+Version:1.4.1
+Release:0
 Source0:http://pear.horde.org/get/Horde_Mime-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Mime
@@ -101,5 +100,6 @@
 
 %{peardir}/*
 %{xmldir}/Horde_Mime.xml
+%doc %{_docdir}/%{name}
 
 %changelog

++ Horde_Mime-1.0.5.tgz - Horde_Mime-1.4.1.tgz ++
 23210 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Nls for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Nls for 
openSUSE:Factory checked in at 2012-01-19 11:06:30

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Nls (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Nls.new (New)


Package is php5-pear-Horde_Nls, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/php5-pear-Horde_Nls/php5-pear-Horde_Nls.changes  
2011-09-23 12:40:32.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Nls.new/php5-pear-Horde_Nls.changes 
2012-01-19 11:06:32.0 +0100
@@ -1,0 +2,12 @@
+Tue Jan 17 13:08:56 UTC 2012 - l...@b1-systems.de
+
+- version 1.1.3
+- add license file and markup license in spdx format
+- [mms] Add ISO 639 language code lookup.
+- [jan] Update German translation.
+- [jan] Update Brazilian Portuguese translation.
+- [jan] Update Croatian translation.
+- [jan] Update Estonian translation.
+- [jan] Update Japanese translation (Hiromi Kimura hir...@tac.tsukuba.ac.jp).
+
+---

Old:

  Horde_Nls-1.0.2.tgz

New:

  Horde_Nls-1.1.3.tgz



Other differences:
--
++ php5-pear-Horde_Nls.spec ++
--- /var/tmp/diff_new_pack.f5UKkj/_old  2012-01-19 11:06:36.0 +0100
+++ /var/tmp/diff_new_pack.f5UKkj/_new  2012-01-19 11:06:36.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Nls
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,12 +20,12 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: This package provides Native Language Support (NLS)
-
-Name:   php5-pear-Horde_Nls
-Version:1.0.2
-Release:1
 License:LGPL-2.1
 Group:  Development/Libraries/PHP
+
+Name:   php5-pear-Horde_Nls
+Version:1.1.3
+Release:0
 Source0:http://pear.horde.org/get/Horde_Nls-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Nls
@@ -103,5 +103,6 @@
 
 %{peardir}/*
 %{xmldir}/Horde_Nls.xml
+%doc %{_docdir}/%{name}
 
 %changelog

++ Horde_Nls-1.0.2.tgz - Horde_Nls-1.1.3.tgz ++
 107763 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Prefs for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Prefs for 
openSUSE:Factory checked in at 2012-01-19 11:06:33

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Prefs (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Prefs.new (New)


Package is php5-pear-Horde_Prefs, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Prefs/php5-pear-Horde_Prefs.changes  
2011-09-23 12:40:34.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Prefs.new/php5-pear-Horde_Prefs.changes
 2012-01-19 11:06:36.0 +0100
@@ -1,0 +2,11 @@
+Tue Jan 17 13:21:25 UTC 2012 - l...@b1-systems.de
+
+- version 1.1.7
+- add license file
+- [jan] Catch exceptions from storage writing during shutdown.
+- [jan] Use binary column type for preference values (Bug #10803).
+- [jan] Update Japanese translation (Hiromi Kimura 
lt;hir...@tac.tsukuba.ac.jpgt;).
+- [mms] Fix identities when default_identity is locked (Bug #10098).
+- [jan] Skip Kolab test if Horde_Kolab_Storage is not installed.
+
+---

Old:

  Horde_Prefs-1.1.3.tgz

New:

  Horde_Prefs-1.1.7.tgz



Other differences:
--
++ php5-pear-Horde_Prefs.spec ++
--- /var/tmp/diff_new_pack.HlC1BM/_old  2012-01-19 11:06:37.0 +0100
+++ /var/tmp/diff_new_pack.HlC1BM/_new  2012-01-19 11:06:37.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Prefs
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,12 +20,12 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: Horde Preferences API
-
-Name:   php5-pear-Horde_Prefs
-Version:1.1.3
-Release:1
 License:LGPL-2.1
 Group:  Development/Libraries/PHP
+
+Name:   php5-pear-Horde_Prefs
+Version:1.1.7
+Release:0
 Source0:http://pear.horde.org/get/Horde_Prefs-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Prefs
@@ -96,5 +96,6 @@
 %{peardir}/*
 %{xmldir}/%{pear_name}.xml
 %{_bindir}/horde-prefs
+%doc %{_docdir}/%{name}
 
 %changelog

++ Horde_Prefs-1.1.3.tgz - Horde_Prefs-1.1.7.tgz ++
 13616 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Service_Facebook for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Service_Facebook for 
openSUSE:Factory checked in at 2012-01-19 11:06:37

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Service_Facebook (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Service_Facebook.new (New)


Package is php5-pear-Horde_Service_Facebook, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Service_Facebook/php5-pear-Horde_Service_Facebook.changes
2011-12-19 16:10:10.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Service_Facebook.new/php5-pear-Horde_Service_Facebook.changes
   2012-01-19 11:06:38.0 +0100
@@ -1,0 +2,7 @@
+Tue Jan 17 13:44:43 UTC 2012 - l...@b1-systems.de
+
+- version 1.1.2
+- [jan] Update Japanese translation (Hiromi Kimura 
lt;hir...@tac.tsukuba.ac.jpgt;).
+- [mjr] Use FQL to obtain event list and add rsvp_status
+
+---

Old:

  Horde_Service_Facebook-1.1.0.tgz

New:

  Horde_Service_Facebook-1.1.2.tgz



Other differences:
--
++ php5-pear-Horde_Service_Facebook.spec ++
--- /var/tmp/diff_new_pack.F87Ax5/_old  2012-01-19 11:06:39.0 +0100
+++ /var/tmp/diff_new_pack.F87Ax5/_new  2012-01-19 11:06:39.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Service_Facebook
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,7 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %define peardir %(pear config-get php_dir 2 /dev/null || echo 
%{_datadir}/pear)
 %define xmldir  /var/lib/pear
 
@@ -24,7 +23,7 @@
 Group:  Development/Libraries/PHP
 
 Name:   php5-pear-Horde_Service_Facebook
-Version:1.1.0
+Version:1.1.2
 Release:0
 Source0:http://pear.horde.org/get/Horde_Service_Facebook-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ Horde_Service_Facebook-1.1.0.tgz - Horde_Service_Facebook-1.1.2.tgz 
++
 8620 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Share for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Share for 
openSUSE:Factory checked in at 2012-01-19 11:06:42

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Share (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Share.new (New)


Package is php5-pear-Horde_Share, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Share/php5-pear-Horde_Share.changes  
2011-09-23 12:40:39.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Share.new/php5-pear-Horde_Share.changes
 2012-01-19 11:06:43.0 +0100
@@ -1,0 +2,15 @@
+Tue Jan 17 14:23:15 UTC 2012 - l...@b1-systems.de
+
+- version 1.2.2
+- added license file
+- [jan] Skip Kolab test if Horde_Kolab_Storage is not installed.
+- [gwr] Fix usage of Horde_Exception_Wrapped.
+
+---
+Sat Aug 27 19:47:13 UTC 2011 - l...@b1-systems.de
+
+- version 1.2.0
+- [gwr] Fixed support for share parents in the Kolab driver.
+- [gwr] Fixed support for multiple namespaces of the same type in the Kolab 
driver.
+
+---

Old:

  Horde_Share-1.1.2.tgz

New:

  Horde_Share-1.2.2.tgz



Other differences:
--
++ php5-pear-Horde_Share.spec ++
--- /var/tmp/diff_new_pack.bKeNIy/_old  2012-01-19 11:06:44.0 +0100
+++ /var/tmp/diff_new_pack.bKeNIy/_new  2012-01-19 11:06:44.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Share
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,12 +20,12 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: Horde Shared Permissions System
-
-Name:   php5-pear-Horde_Share
-Version:1.1.2
-Release:1
 License:LGPL-2.1
 Group:  Development/Libraries/PHP
+
+Name:   php5-pear-Horde_Share
+Version:1.2.2
+Release:0
 Source0:http://pear.horde.org/get/Horde_Share-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Share
@@ -94,5 +94,6 @@
 
 %{peardir}/*
 %{xmldir}/%{pear_name}.xml
+%doc %{_docdir}/%{name}
 
 %changelog

++ Horde_Share-1.1.2.tgz - Horde_Share-1.2.2.tgz ++
 21555 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_SyncMl for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_SyncMl for 
openSUSE:Factory checked in at 2012-01-19 11:06:45

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_SyncMl (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_SyncMl.new (New)


Package is php5-pear-Horde_SyncMl, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_SyncMl/php5-pear-Horde_SyncMl.changes
2011-09-23 12:40:40.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_SyncMl.new/php5-pear-Horde_SyncMl.changes
   2012-01-19 11:06:47.0 +0100
@@ -1,0 +2,15 @@
+Tue Jan 17 14:31:39 UTC 2012 - l...@b1-systems.de
+
+- version 1.0.8
+- added license file
+- [jan] Fix encoding of CDATA (ho...@chk.cksf.de, Bug #10692).
+- [jan] Fix undefined method while synchronizing events with Funambol (Bug 
#10908).
+- [jan] Catch exceptions when changing or retrieving objects from the 
applications.
+
+---
+Sat Aug 27 19:49:23 UTC 2011 - l...@b1-systems.de
+
+- version 1.0.5
+- Fix logging errors while retrieving server changes.
+
+---

Old:

  Horde_SyncMl-1.0.4.tgz

New:

  Horde_SyncMl-1.0.8.tgz



Other differences:
--
++ php5-pear-Horde_SyncMl.spec ++
--- /var/tmp/diff_new_pack.EZlYMU/_old  2012-01-19 11:06:49.0 +0100
+++ /var/tmp/diff_new_pack.EZlYMU/_new  2012-01-19 11:06:49.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_SyncMl
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,12 +20,12 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: Horde_SyncMl provides an API for processing SyncML 
requests
+License:LGPL-2.1
+Group:  Development/Libraries/PHP
 
 Name:   php5-pear-Horde_SyncMl
-Version:1.0.4
-Release:1
-License:LGPLv2.1
-Group:  Development/Libraries/PHP
+Version:1.0.8
+Release:0
 Source0:http://pear.horde.org/get/Horde_SyncMl-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_SyncMl

++ Horde_SyncMl-1.0.4.tgz - Horde_SyncMl-1.0.8.tgz ++
 38502 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Util for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Util for 
openSUSE:Factory checked in at 2012-01-19 11:06:49

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Util (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Util.new (New)


Package is php5-pear-Horde_Util, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Util/php5-pear-Horde_Util.changes
2011-09-23 12:40:44.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Util.new/php5-pear-Horde_Util.changes
   2012-01-19 11:06:54.0 +0100
@@ -1,0 +2,9 @@
+Tue Jan 17 14:59:45 UTC 2012 - l...@b1-systems.de
+
+- added license file
+- version 1.2.0
+- [jan] Speed up Horde_String::substr() (Evert Pot, Request #8627).
+- [mms] Add Horde_Variables#filter().
+- [mms] Add Horde_String::validUtf8().
+
+---

Old:

  Horde_Util-1.0.5.tgz

New:

  Horde_Util-1.2.0.tgz



Other differences:
--
++ php5-pear-Horde_Util.spec ++
--- /var/tmp/diff_new_pack.49LQHK/_old  2012-01-19 11:06:55.0 +0100
+++ /var/tmp/diff_new_pack.49LQHK/_new  2012-01-19 11:06:55.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Util
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,12 +20,12 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: Horde Utility Libraries
-
-Name:   php5-pear-Horde_Util
-Version:1.0.5
-Release:1
 License:LGPL-2.1
 Group:  Development/Libraries/PHP
+
+Name:   php5-pear-Horde_Util
+Version:1.2.0
+Release:0
 Source0:http://pear.horde.org/get/Horde_Util-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Util
@@ -92,7 +92,7 @@
 
 %files
 %defattr(-,root,root)
-
+%doc %{_docdir}/%{name}
 %{peardir}/*
 %{xmldir}/Horde_Util.xml
 

++ Horde_Util-1.0.5.tgz - Horde_Util-1.2.0.tgz ++
 9629 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Vfs for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Vfs for 
openSUSE:Factory checked in at 2012-01-19 11:06:52

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Vfs (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Vfs.new (New)


Package is php5-pear-Horde_Vfs, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/php5-pear-Horde_Vfs/php5-pear-Horde_Vfs.changes  
2011-09-23 12:40:44.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Vfs.new/php5-pear-Horde_Vfs.changes 
2012-01-19 11:06:55.0 +0100
@@ -1,0 +2,17 @@
+Tue Jan 17 15:02:30 UTC 2012 - l...@b1-systems.de
+
+- version 1.0.8
+- ship license file
+- [jan] Fix renaming and catching errors while reading sizes in SQL driver.
+- jan] Fix reading file contents from FTP.
+- [jan] Fix setting permissions with File driver (Bug #10630).
+- [mms] Fix using File driver if vfsroot directory already exists (Bug #10584).
+- [mms] Fix internal reference to QUOTA_METRIC_* constants (Bug #10585).
+- [jan] Fix parsing of directory listings on /dev file systems in the SSH 
driver.
+- [jan] Fix reading file sizes from Samba backends.
+- [jan] Catch output from smbclient during error conditions (Bug #10638).
+- [jan] Implement size() method in Samba driver.
+- [gwr] Make unit tests timezone independent.
+
+
+---

Old:

  Horde_Vfs-1.0.4.tgz

New:

  Horde_Vfs-1.0.8.tgz



Other differences:
--
++ php5-pear-Horde_Vfs.spec ++
--- /var/tmp/diff_new_pack.r3qiXN/_old  2012-01-19 11:06:57.0 +0100
+++ /var/tmp/diff_new_pack.r3qiXN/_new  2012-01-19 11:06:57.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Vfs
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,12 +20,12 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: Virtual File System API
-
-Name:   php5-pear-Horde_Vfs
-Version:1.0.4
-Release:1
 License:LGPL-2.1
 Group:  Development/Libraries/PHP
+
+Name:   php5-pear-Horde_Vfs
+Version:1.0.8
+Release:0
 Source0:http://pear.horde.org/get/Horde_Vfs-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Vfs
@@ -110,7 +110,7 @@
 
 %files -f %{pear_name}.lang
 %defattr(-,root,root)
-
+%doc %{_docdir}/%{name}
 %{peardir}/*
 %{xmldir}/Horde_Vfs.xml
 /usr/bin/horde-vfs

++ Horde_Vfs-1.0.4.tgz - Horde_Vfs-1.0.8.tgz ++
 20457 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit claws-mail for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package claws-mail for openSUSE:Factory 
checked in at 2012-01-19 16:54:25

Comparing /work/SRC/openSUSE:Factory/claws-mail (Old)
 and  /work/SRC/openSUSE:Factory/.claws-mail.new (New)


Package is claws-mail, Maintainer is nadvor...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/claws-mail/claws-mail.changes2011-10-02 
09:52:18.0 +0200
+++ /work/SRC/openSUSE:Factory/.claws-mail.new/claws-mail.changes   
2012-01-19 16:54:27.0 +0100
@@ -1,0 +2,50 @@
+Tue Jan 17 16:38:49 UTC 2012 - vu...@opensuse.org
+
+- Work on a GTK+ 3 build:
+  + Use favor_gtk2 to switch between gtk2 and gtk3 builds.
+  + For gtk3 build, use gtk3-devel BuildRequires instead of
+gtk2-devel and pass --enable-gtk3 to configure.
+  + Forcefully disable the gtk3 build with a gtk3_ready macro,
+since the gtk3 support is not ready yet.
+- Stop adding a GenericName to claws-mail.desktop as there's
+  already one.
+
+---
+Mon Jan  2 06:24:16 CET 2012 - malcolmle...@opensuse.org
+
+- Update to version 3.8.0:
+  + GnuTLS 2.2 is now a minimum requirement if encrypted
+connections to servers are required.
+  + The list displays have been updated to use newer GTK+
+functions, this means that the expanders look different and
+the optional dotted lines have been dropped.
+  + A hidden option, 'summary_from_show', which controls the
+display in the From column of the Message List: 0 (default):
+show name, 1: show address, 2: show name + address.
+  + The image viewer now uses the EXIF Orientation.
+  + 'Generate X-Mailer header' has been added as an Account
+option.
+  + /View/Message scroll has been added, allowing keyboard
+shortcuts to be added and used for message scrolling.
+  + Home and End keys now function in the Message View.
+  + /Message/Print has been added to the Compose window.
+  + Several bug fixes, including a fix for focus problem on Gnome
+shell (see NEWS for details).
+  + Updated manuals.
+  + Update man page.
+  + Bug fixes:
+  + Updated translations.
+- Drop claws-mail-new-gnutls.patch: fixed upstream.
+- Drop claws-mail-glib-2.31.patch: fixed upstream.
+- Update spec file License field from GPLv3+ and GPLv2+ to
+  GPL-3.0+ and GPL-2.0+ respectivley, to conform with spdx.org
+  identifier.
+- Add claws-mail-fix-bufferoverflowstrncat.patch: Fix statement
+  might be overflowing a buffer in strncat.
+
+---
+Mon Nov 28 22:18:24 UTC 2011 - dims...@opensuse.org
+
+- Add claws-mail-glib-2.31.patch: Fix build with glib 2.31.
+
+---

Old:

  claws-mail-3.7.10.tar.bz2
  claws-mail-new-gnutls.patch

New:

  claws-mail-3.8.0.tar.bz2
  claws-mail-fix-bufferoverflowstrncat.patch



Other differences:
--
++ claws-mail.spec ++
--- /var/tmp/diff_new_pack.tFBIBe/_old  2012-01-19 16:54:29.0 +0100
+++ /var/tmp/diff_new_pack.tFBIBe/_new  2012-01-19 16:54:29.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package claws-mail
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,18 +16,22 @@
 #
 
 
+%define gtk3_ready 0
+%if !%{gtk3_ready}
+%define favor_gtk2 1
+%endif
 
 Name:   claws-mail
-Version:3.7.10
-Release:1
-License:GPLv3+
-Group:  Productivity/Networking/Email/Clients
+Version:3.8.0
+Release:0
 Url:http://www.claws-mail.org/
 Summary:A lightweight and highly configurable email client
-Source0:
http://downloads.sourceforge.net/project/sylpheed-claws/Claws%20Mail/3.7.10/%{name}-%{version}.tar.bz2
+License:GPL-3.0+
+Group:  Productivity/Networking/Email/Clients
+Source0:
http://downloads.sourceforge.net/project/sylpheed-claws/Claws%20Mail/3.8.0/%{name}-%{version}.tar.bz2
 Patch0: claws-mail-python.diff
-# PATCH-FIX-UPSTREAM claws-mail-new-gnutls.patch vu...@opensuse.org -- Fix 
build with gnutls 3.0.3, based on upstream change: 
http://www.colino.net/claws-mail/getpatchset.php?ver=3.7.10cvs18
-Patch1: claws-mail-new-gnutls.patch
+# PATCH-FIX-UPSTREAM claws-mail-fix-bufferoverflowstrncat.patch 
malcolmle...@opensuse.org -- Fix statement might be overflowing a buffer in 
strncat, http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2574
+Patch1: claws-mail-fix-bufferoverflowstrncat.patch
 

commit claws-mail-extra-plugins for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package claws-mail-extra-plugins for 
openSUSE:Factory checked in at 2012-01-19 16:54:31

Comparing /work/SRC/openSUSE:Factory/claws-mail-extra-plugins (Old)
 and  /work/SRC/openSUSE:Factory/.claws-mail-extra-plugins.new (New)


Package is claws-mail-extra-plugins, Maintainer is nadvor...@suse.com

Changes:

--- 
/work/SRC/openSUSE:Factory/claws-mail-extra-plugins/claws-mail-extra-plugins.changes
2011-10-04 18:08:13.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.claws-mail-extra-plugins.new/claws-mail-extra-plugins.changes
   2012-01-19 16:54:41.0 +0100
@@ -1,0 +2,58 @@
+Mon Jan  2 07:43:03 CET 2012 - malcolmle...@opensuse.org
+
+- Update to version 3.8.0:
+  + acpi Notifier:
+- Added Lenovo's Thinklights.
+  + Address Keeper:
+- Fixed win32 libtool call.
+  + attachwarner:
+- Show mail context which has triggered the alert of a missing
+  attachment. Probably fixes lp#190201.
+  + att_remover:
+- Fixed a crash.
+  + bsfilter:
+- Fixed win32 libtool call.
+  + Fancy:
+- Fixed use of deprecated webkit API.
+  + GData:
+- Add support for libgdata 0.9.
+- Preserve sort order.
+- Query asynchronously on plugin load, re-query periodically.
+- Start a query when prefs page is saved and when switching
+  from offline to online mode.
+- Log actions that require networking to the network log.
+- Save contacts cache for offline use.
+  + GeoLocation:
+- When coordinates could not be infered, at least try to
+  identify the country.
+  + gtkhtml2_viewer:
+- Fix for GTK+ 2.16.
+- Fixed win32 libtool call.
+  + mailmbox:
+- Update Actions on folder renaming.
+  + notification:
+- Fixed build with GLib 2.31.
+- Fixed win32 libtool call.
+  + perl:
+- Use the address completion list for checks if address is in
+  any addressbook.
+  + RSSyl:
+- Fixed win32 libtool call.
+  + TNEF Parser:
+- Fixed win32 libtool call.
+  + vCalendar:
+- Implement a DBus server to impersonate
+  org.gnome.Shell.CalendarServer and make appointments visible
+  in the Gnome calendar.
+- Use new locked mail sending.
+- Fixed a crash and a major memory leak.
+- Fixed win32 libtool call.
+  + Updated translations.
+- Redefine the build_gdata macro, now that it supports more recent
+  versions of libgdata: we build the gdata plugin on = 11.4.
+- Update sed hack for geolocation plugin, as the version of the
+  plugin was increased.
+- Update rm hack for gdata plugin, as the version of the plugin
+  was increased.
+
+---

Old:

  claws-mail-extra-plugins-3.7.10.tar.bz2

New:

  claws-mail-extra-plugins-3.8.0.tar.bz2



Other differences:
--
++ claws-mail-extra-plugins.spec ++
--- /var/tmp/diff_new_pack.yG3QS4/_old  2012-01-19 16:54:42.0 +0100
+++ /var/tmp/diff_new_pack.yG3QS4/_new  2012-01-19 16:54:42.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package claws-mail-extra-plugins
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,33 +15,33 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %if 0%{?suse_version} = 1140
 %define build_geolocation 1
 %else
 %define build_geolocation 0
 %endif
 
-# The right combination of libraries is only in 11.4 for now
-%if 0%{?suse_version} == 1140
+# The right combination of libraries is only in greater than or
+# equal to 11.4 for now
+%if 0%{?suse_version} = 1140
 %define build_gdata 1
 %else
 %define build_gdata 0
 %endif
 
 Name:   claws-mail-extra-plugins
-Version:3.7.10
-Release:1
+Version:3.8.0
+Release:0
 # NOTE: Try to enable gdata and geolocation plugins again. Last checked for 
3.7.10 on 12.1.
 Summary:Plugins for Claws Mail
 License:GPL-2.0+
 Group:  Productivity/Networking/Email/Clients
 Url:http://claws-mail.org
-Source0:
http://downloads.sourceforge.net/project/sylpheed-claws/extra%20plugins/3.7.10/%{name}-%{version}.tar.bz2
+Source0:
http://downloads.sourceforge.net/project/sylpheed-claws/extra%20plugins/3.8.0/%{name}-%{version}.tar.bz2
 Patch0: claws-mail-extra-plugins-libytnef_shlib.patch
 # PATCH-FIX-OPENSUSE claws-mail-extra-plugins-fancy-build.patch -- Fix build 
of fancy plugin on 11.4
 Patch1: claws-mail-extra-plugins-fancy-build.patch
-BuildRequires:  claws-mail-devel = 3.7.2
+BuildRequires: 

commit clisp for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package clisp for openSUSE:Factory checked 
in at 2012-01-19 16:54:35

Comparing /work/SRC/openSUSE:Factory/clisp (Old)
 and  /work/SRC/openSUSE:Factory/.clisp.new (New)


Package is clisp, Maintainer is wer...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/clisp/clisp.changes  2011-12-25 
17:33:34.0 +0100
+++ /work/SRC/openSUSE:Factory/.clisp.new/clisp.changes 2012-01-19 
16:54:43.0 +0100
@@ -1,0 +2,7 @@
+Tue Jan 17 15:01:26 UTC 2012 - sweet_...@gmx.de
+
+- don't use deprecated macro suse_update_config
+- remove berkeley-db.dif
+- strip needs writable files
+
+---

Old:

  clisp-2.49-berkeley-db.dif



Other differences:
--
++ clisp.spec ++
--- /var/tmp/diff_new_pack.OkjldT/_old  2012-01-19 16:54:44.0 +0100
+++ /var/tmp/diff_new_pack.OkjldT/_new  2012-01-19 16:54:44.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package clisp
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,7 +20,6 @@
 %define min_suse_ver 1030
 
 Name:   clisp
-BuildRequires:  automake
 BuildRequires:  db-devel
 BuildRequires:  gdbm-devel
 BuildRequires:  gtk2-devel
@@ -42,7 +41,7 @@
 %define debug  no
 License:GPL-2.0+
 Group:  Development/Languages/Other
-PreReq: vim
+Requires(pre):  vim
 Version:2.49
 Release:0
 Summary:A Common Lisp Interpreter
@@ -61,7 +60,6 @@
 Patch4: clisp-2.44.1-ia64.dif
 Patch7: clisp-2.39-ia64-wooh.dif
 Patch8: clisp-2.39-clx.dif
-Patch9: clisp-2.49-berkeley-db.dif
 Patch10:ffcall-1.10+2.43.dif
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %global vimdir  %{_datadir}/vim/site/after/syntax
@@ -102,7 +100,6 @@
 %patch4  -p0 -b .ia64
 %patch7  -p0 -b .wooh
 %patch8  -p0 -b .clx
-%patch9  -p0 -b .bdb
 %patch10 -p0 -b .ffcall
 %patch0
 
@@ -120,11 +117,6 @@
 # Current system
 #
 SYSTEM=${RPM_ARCH}-suse-linux
-#
-# Update autoconf files
-#
-AUTODIR=$(find -name autoconf -and -type d 2 /dev/null)
-%{?suse_update_config $AUTODIR}
 export PATH=$PATH:.
 #
 # Set gcc command line but do not use CFLAGS
@@ -302,6 +294,7 @@
 pushd modules/clx/
   tar xfz clx-manual.tar.gz -C %{buildroot}${CLXDOC}
 popd
+find %{buildroot} -name *.a | xargs chmod u+w
 chmodu+xrw,a+rx %{buildroot}%{_bindir}/clisp
 chmodu+xrw,a+rx %{buildroot}%{_bindir}/clisp-link
 chmod -R g+r,o+r%{buildroot}${LSPDOC}/


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit dee for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package dee for openSUSE:Factory checked in 
at 2012-01-19 16:54:43

Comparing /work/SRC/openSUSE:Factory/dee (Old)
 and  /work/SRC/openSUSE:Factory/.dee.new (New)


Package is dee, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/dee/dee.changes  2011-10-25 15:49:48.0 
+0200
+++ /work/SRC/openSUSE:Factory/.dee.new/dee.changes 2012-01-19 
16:54:44.0 +0100
@@ -1,0 +2,12 @@
+Fri Jan 13 08:17:39 UTC 2012 - dims...@opensuse.org
+
+- Update to version 1.0.0:
+  + Bugs fixed: lp#905463, lp#894023, lp#900629, lp#904293,
+lp#904299, lp#913128, lp#622446, lp#901098, lp#901100,
+lp#912675, lp#911667.
+- Split typelib file into typelib-1_0-Dee-1_0 subpackage.
+- Add typelib-1_0-Dee-1_0 Requires to the -devel subpackage.
+- Rename libdee-1_0-1 to libdee-1_0-4, following the upstream
+  soname change.
+
+---

Old:

  dee-0.5.22.tar.gz

New:

  dee-1.0.0.tar.gz



Other differences:
--
++ dee.spec ++
--- /var/tmp/diff_new_pack.v5gVUp/_old  2012-01-19 16:54:46.0 +0100
+++ /var/tmp/diff_new_pack.v5gVUp/_new  2012-01-19 16:54:46.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package dee
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,16 +16,16 @@
 #
 
 
-%define soname 1_0-1
+%define soname 1_0-4
 
 Name:   dee
-Version:0.5.22
-Release:1
-License:LGPL-3.0
+Version:1.0.0
+Release:0
 Summary:Library that uses DBus to provide objects
-Url:http://launchpad.net/dee
+License:LGPL-3.0
 Group:  System/Libraries
-Source0:%{name}-%{version}.tar.gz
+Url:http://launchpad.net/dee
+Source0:
http://launchpad.net/dee/1.0/1.0.0/+download/%{name}-%{version}.tar.gz
 BuildRequires:  fdupes
 BuildRequires:  libtool
 BuildRequires:  vala
@@ -42,7 +42,6 @@
 %package -n libdee-%{soname}
 Summary:Library that uses DBus to provide objects
 Group:  System/Libraries
-License:LGPL-3.0
 
 %description -n libdee-%{soname}
 Libdee is a library that uses DBus to provide objects allowing you to create
@@ -50,10 +49,21 @@
 objects which extend DBus allowing for peer-to-peer discoverability of known
 objects without needing a central registrar.
 
+%package -n typelib-1_0-Dee-1_0
+Summary:Library that uses DBus to provide objects - Introspection 
bindings
+Group:  System/Libraries
+
+%description -n typelib-1_0-Dee-1_0
+Libdee is a library that uses DBus to provide objects allowing you to create
+Model-View-Controller type programs across DBus. It also consists of utility
+objects which extend DBus allowing for peer-to-peer discoverability of known
+objects without needing a central registrar.
+
+This package provides the GObject Introspection bindings for libdee.
+
 %package -n python-dee
-Summary:Library that uses DBus to provide objects - python bindings
+Summary:Library that uses DBus to provide objects - Python bindings
 Group:  Development/Libraries/Other
-License:LGPL-3.0
 Requires:   libdee-%{soname} = %{version}
 Requires:   python-gobject
 Supplements:packageand(libdee-%{soname}:python-gobject)
@@ -67,11 +77,12 @@
 %package devel
 Summary:Development files for dee
 Group:  Development/Libraries/Other
-License:LGPL-3.0
 Requires:   libdee-%{soname} = %{version}
+Requires:   typelib-1_0-Dee-1_0 = %{version}
 
 %description devel
 This package provides the development files for dee.
+
 Libdee is a library that uses DBus to provide objects allowing you to create
 Model-View-Controller type programs across DBus. It also consists of utility
 objects which extend DBus allowing for peer-to-peer discoverability of known
@@ -99,20 +110,24 @@
 %defattr(-,root,root)
 %doc ChangeLog README COPYING
 %{_libdir}/libdee-1.0.so.*
-%{_libdir}/girepository-1.0/Dee-0.5.typelib
+
+%files -n typelib-1_0-Dee-1_0
+%defattr(-, root, root)
+%{_libdir}/girepository-1.0/Dee-1.0.typelib
 
 %files -n python-dee
 %defattr(-,root,root)
 %dir %{python_sitearch}/gi/
 %dir %{python_sitearch}/gi/overrides/
-%{python_sitearch}/gi/overrides/
+%{python_sitearch}/gi/overrides/*
 
 %files devel
 %defattr(-,root,root)
+%{_bindir}/dee-tool
 %{_includedir}/dee-1.0/
 %{_libdir}/libdee-1.0.so
 %{_libdir}/pkgconfig/dee-1.0.pc
-%{_datadir}/gir-1.0/Dee-0.5.gir
+%{_datadir}/gir-1.0/Dee-1.0.gir
 

commit epdfview for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package epdfview for openSUSE:Factory 
checked in at 2012-01-19 16:54:48

Comparing /work/SRC/openSUSE:Factory/epdfview (Old)
 and  /work/SRC/openSUSE:Factory/.epdfview.new (New)


Package is epdfview, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/epdfview/epdfview.changes2011-12-30 
08:45:33.0 +0100
+++ /work/SRC/openSUSE:Factory/.epdfview.new/epdfview.changes   2012-01-19 
16:54:49.0 +0100
@@ -1,0 +2,6 @@
+Sun Jan  8 15:55:20 UTC 2012 - g...@opensuse.org
+
+- added epdfview-fix-glib-include.patch so glib/gmacros.h
+  is not included directly (backported from upstream SVN)
+
+---

New:

  epdfview-fix-glib-include.patch



Other differences:
--
++ epdfview.spec ++
--- /var/tmp/diff_new_pack.8tMgRK/_old  2012-01-19 16:54:50.0 +0100
+++ /var/tmp/diff_new_pack.8tMgRK/_new  2012-01-19 16:54:50.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package epdfview
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,7 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 Name:   epdfview
 Version:0.1.8
 Release:0
@@ -31,6 +30,8 @@
 Patch2: epdfview-fix-missing-return-value.patch
 # PATCH-FIX-UPSTREAM epdfview-0.1.8-fix-colors.patch bnc#736465 
g...@opensuse.org -- Fixes the displayed colors with poppler = 0.17.0 by 
swapping the blue and red channels (backported from upstream SVN)
 Patch3: epdfview-0.1.8-fix-colors.patch
+# PATCH-FIX-UPSTREAM epdfview-fix-glib-include.patch g...@opensuse.org -- Do 
not include glib/gmacros.h directly (backported from upstream SVN)
+Patch4: epdfview-fix-glib-include.patch
 BuildRequires:  automake
 BuildRequires:  cups-devel
 BuildRequires:  gcc-c++
@@ -52,6 +53,7 @@
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 touch ChangeLog

++ epdfview-fix-glib-include.patch ++
Index: epdfview-0.1.8/src/gtk/StockIcons.h
===
--- epdfview-0.1.8.orig/src/gtk/StockIcons.h
+++ epdfview-0.1.8/src/gtk/StockIcons.h
@@ -18,7 +18,7 @@
 #if !defined (__STOCK_ICONS_H__)
 #define __STOCK_ICONS_H__
 
-#include glib/gmacros.h
+#include glib.h
 
 G_BEGIN_DECLS
 
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit evolution-data-server for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package evolution-data-server for 
openSUSE:Factory checked in at 2012-01-19 16:54:55

Comparing /work/SRC/openSUSE:Factory/evolution-data-server (Old)
 and  /work/SRC/openSUSE:Factory/.evolution-data-server.new (New)


Package is evolution-data-server, Maintainer is gnome-maintain...@suse.de

Changes:

--- 
/work/SRC/openSUSE:Factory/evolution-data-server/evolution-data-server.changes  
2011-10-18 14:11:56.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.evolution-data-server.new/evolution-data-server.changes
 2012-01-19 16:55:03.0 +0100
@@ -1,0 +2,76 @@
+Wed Dec 21 08:45:04 UTC 2011 - vu...@opensuse.org
+
+- Add evolution-data-server-fix-introspection-build.patch: fix
+  build of introspection support.
+- Set %with_introspection macro to 1 now that we can build
+  introspection support again.
+
+---
+Tue Dec 20 13:26:28 UTC 2011 - vu...@opensuse.org
+
+- Update to version 3.3.3:
+  + Be more responsive to cancellations.
+  + Add --wait-for-client factory processes command line option
+  + Fix leaks.
+  + Various other code changes.
+  + Bugs fixed: bgo#665253, bgo#662068, bgo#666106, bgo#652173,
+bgo#665337, bgo#664819, bgo#664572, bgo#652177.
+  + Updated translations.
+- Add xz BuildRequires because we can't build a package for a
+  xz-compressed tarball without explicitly specifying that... See
+  bnc#697467 for more details.
+- Bump so_camel define to 32 and so_edata_cal to 15, to follow
+  library soversion changes.
+- Update baselibs.conf for library soversion changes.
+- Split typelib files into typelib-1_0-EBook-1_2,
+  typelib-1_0-ECalendar-1_2, typelib-1_0-EDataServer-1_2
+  subpackages.
+- Add typelib-1_0-EBook-1_2, typelib-1_0-ECalendar-1_2,
+  typelib-1_0-EDataServer-1_2 Requires to devel subpackage.
+
+---
+Mon Nov 21 08:05:04 UTC 2011 - dims...@opensuse.org
+
+- Update to version 3.3.2:
+  + Various code changes.
+  + Bugs fixed: bgo#440316, bgo#652171, bgo#652175, bgo#655167,
+bgo#659736, bgo#660182, bgo#660646, bgo#660972, bgo#660974,
+bgo#661033, bgo#662473, bgo#662524, bgo#662643, bgo#662929,
+bgo#663062, bgo#663219
+  + Updated translations.
+
+---
+Thu Oct 27 18:18:27 UTC 2011 - dims...@opensuse.org
+
+- Update to version 3.3.1.1:
+  + Work around libgthread shenanigans in GLib 2.31.
+- Drop evolution-data-server-g_thread.patch: fixed upstream.
+- Update the soname defines following library soversion changes.
+- Change evo_version to 3.4, as this is the development tree
+  leading to evolution-data-server 3.4.
+- Add a with_introspection defines to easily enable/disable
+  building of gobject-introspection and vala bindings. Currently,
+  this is disabled due to bgo#662888. Based on with_introspection,
+  pass either --disable-vala-bindings --disable-introspection (if
+  with_introspection=0) or --enable-vala-bindings
+  --enable-introspection (with_introspection=1) to configure.
+
+---
+Wed Oct 26 19:46:39 UTC 2011 - dims...@opensuse.org
+
+- Update to version 3.3.1:
+  + Fix crashes.
+  + Various other code changes.
+  + Bugs fixed:
+- bgo#601898: SOCKS proxy does not work with mailer
+- bgo#660870: Empty contacts list when pressing To: in composer
+- bgo#527614, bgo#620382, bgo#632619, bgo#642984, bgo#655252,
+  bgo#656473, bgo#656603, bgo#659438, bgo#659553, bgo#659555,
+  bgo#659568, bgo#659914, bgo#660246, bgo#660533, bgo#660615,
+  bgo#660656, bgo#660829, bgo#660884, bgo#661432, bgo#661448,
+  bgo#661549.
+  + Updated translations.
+- Add evolution-data-server-g_thread.patch: do not call
+  g_thread_init; taken from upstream git.
+
+---

Old:

  evolution-data-server-3.2.1.tar.bz2

New:

  evolution-data-server-3.3.3.tar.xz
  evolution-data-server-fix-introspection-build.patch



Other differences:
--
++ evolution-data-server.spec ++
--- /var/tmp/diff_new_pack.fIuitx/_old  2012-01-19 16:55:05.0 +0100
+++ /var/tmp/diff_new_pack.fIuitx/_new  2012-01-19 16:55:05.0 +0100
@@ -17,28 +17,31 @@
 
 
 %define USE_EVOLDAP 0
+%define with_introspection 1
 
 # Shared Library soNUMs, to make it easier for updates
 # When updating the sonums, do not forget to also update baselibs.conf
-%define so_camel 29
-%define so_ebackend 1
-%define so_ebook 12
-%define so_ecal 10
-%define so_edata_book 11
-%define so_edata_cal 13
-%define so_edataserver 15
+%define so_camel 32
+%define so_ebackend 2
+%define 

commit go-gosqlite for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package go-gosqlite for openSUSE:Factory 
checked in at 2012-01-19 16:55:35

Comparing /work/SRC/openSUSE:Factory/go-gosqlite (Old)
 and  /work/SRC/openSUSE:Factory/.go-gosqlite.new (New)


Package is go-gosqlite, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/go-gosqlite/go-gosqlite.changes  2011-10-27 
19:16:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.go-gosqlite.new/go-gosqlite.changes 
2012-01-19 16:55:36.0 +0100
@@ -1,0 +2,5 @@
+Tue Jan 10 09:21:18 UTC 2012 - sasc...@suse.de
+
+- Update to 12/01/2012 mercurial release
+
+---

Old:

  gosqlite-0.0.0+hg20110601.tar.bz2

New:

  Makefile
  gosqlite-0.0.0+hg20120110.tar.bz2
  gosqlite-weekly-fixes.patch



Other differences:
--
++ go-gosqlite.spec ++
--- /var/tmp/diff_new_pack.dh1Bcw/_old  2012-01-19 16:55:37.0 +0100
+++ /var/tmp/diff_new_pack.dh1Bcw/_new  2012-01-19 16:55:37.0 +0100
@@ -1,5 +1,8 @@
 #
-# Copyright (c), 2011, Sascha Peilicke sasc...@gmx.de
+# spec file for package go-gosqlite
+#
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 Sascha Peilicke sasc...@gmx.de
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -10,15 +13,20 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
+
 Name:   go-gosqlite
-Version:0.0.0+hg20110601
+Version:0.0.0+hg20120110
 Release:0
 Summary:Trivial SQLite binding for Go
-Group:  Development/Languages/Other
 License:BSD-3-Clause
-URL:http://code.google.com/p/gosqlite/
+Group:  Development/Languages/Other
+Url:http://code.google.com/p/gosqlite/
 Source0:gosqlite-%{version}.tar.bz2
 Source1:LICENSE
+Source2:Makefile
+Patch0: gosqlite-weekly-fixes.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  go-devel
 %if 0%{?fedora_version} || 0%{?rhel_version} || 0%{?centos_version}
@@ -37,7 +45,9 @@
 
 %prep
 %setup -q -n gosqlite
+%patch0 -p1
 cp %{SOURCE1} .
+cp %{SOURCE2} ./sqlite
 
 %build
 %install

++ Makefile ++
include $(GOROOT)/src/Make.inc

TARG=code.google.com/p/gosqlite

CGOFILES:=sqlite.go

include $(GOROOT)/src/Make.pkg
++ gosqlite-0.0.0+hg20110601.tar.bz2 - gosqlite-0.0.0+hg20120110.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gosqlite/sqlite/Makefile new/gosqlite/sqlite/Makefile
--- old/gosqlite/sqlite/Makefile2011-06-01 14:37:10.0 +0200
+++ new/gosqlite/sqlite/Makefile1970-01-01 01:00:00.0 +0100
@@ -1,18 +0,0 @@
-# Copyright 2010 The Go Authors. All rights reserved.
-# Use of this source code is governed by a BSD-style
-# license that can be found in the LICENSE file.
-
-include $(GOROOT)/src/Make.inc
-
-TARG=gosqlite.googlecode.com/hg/sqlite
-
-CGOFILES=\
-   sqlite.go
-
-ifeq ($(GOOS),darwin)
-CGO_LDFLAGS=/usr/lib/libsqlite3.0.dylib
-else
-CGO_LDFLAGS=-L/usr/local/lib/oeis -lsqlite3
-endif
-
-include $(GOROOT)/src/Make.pkg
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gosqlite/sqlite/sqlite.go 
new/gosqlite/sqlite/sqlite.go
--- old/gosqlite/sqlite/sqlite.go   2011-06-01 14:37:10.0 +0200
+++ new/gosqlite/sqlite/sqlite.go   2012-01-10 09:50:04.0 +0100
@@ -6,6 +6,8 @@
 package sqlite
 
 /*
+#cgo LDFLAGS: -lsqlite3
+
 #include sqlite3.h
 #include stdlib.h
 
@@ -28,6 +30,7 @@
 import C
 
 import (
+   errors
fmt
os
reflect
@@ -38,7 +41,7 @@
 
 type Errno int
 
-func (e Errno) String() string {
+func (e Errno) Error() string {
s := errText[e]
if s ==  {
return fmt.Sprintf(errno %d, int(e))
@@ -47,76 +50,76 @@
 }
 
 var (
-   ErrError os.Error = Errno(1)  ///* SQL error or missing database */
-   ErrInternal os.Error = Errno(2)  ///* Internal logic error in 
SQLite */
-   ErrPerm os.Error = Errno(3)  ///* Access permission denied */
-   ErrAbort os.Error = Errno(4)  ///* Callback routine requested an 
abort */
-   ErrBusy os.Error = Errno(5)  ///* The database file is locked */
-   ErrLocked os.Error = Errno(6)  ///* A table in the database is 
locked */
-   ErrNoMem os.Error = Errno(7)  ///* A malloc() failed */
-   ErrReadOnly os.Error = Errno(8)  ///* Attempt to write a 

commit gnome-bluetooth for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package gnome-bluetooth for openSUSE:Factory 
checked in at 2012-01-19 16:55:31

Comparing /work/SRC/openSUSE:Factory/gnome-bluetooth (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-bluetooth.new (New)


Package is gnome-bluetooth, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gnome-bluetooth/gnome-bluetooth.changes  
2012-01-09 12:40:02.0 +0100
+++ /work/SRC/openSUSE:Factory/.gnome-bluetooth.new/gnome-bluetooth.changes 
2012-01-19 16:55:34.0 +0100
@@ -1,0 +2,6 @@
+Wed Jan 11 08:59:36 UTC 2012 - vu...@opensuse.org
+
+- Change gnome-control-center Requires to Recommends, to avoid a
+  build loop.
+
+---



Other differences:
--
++ gnome-bluetooth.spec ++
--- /var/tmp/diff_new_pack.N77R0g/_old  2012-01-19 16:55:35.0 +0100
+++ /var/tmp/diff_new_pack.N77R0g/_new  2012-01-19 16:55:35.0 +0100
@@ -15,7 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 Name:   gnome-bluetooth
 Version:3.3.3
 Release:0
@@ -48,9 +47,9 @@
 Requires:   bluez = 4.36
 # Require obexd for bluetooth-sendto to work (bnc#622946)
 Requires:   obexd-client
-# Require gnome-control-center for bluetooth setup to work (bnc#732689)
-Requires:   gnome-control-center
 Recommends: %{name}-lang
+# Recommend gnome-control-center for bluetooth setup to work (bnc#732689). 
It's not a Requires to avoid a build loop between NetworkManager-gnome and 
gnome-control-center.
+Recommends: gnome-control-center
 Provides:   bluez-gnome = 1.8
 Obsoletes:  bluez-gnome  1.8
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit grilo-plugins for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package grilo-plugins for openSUSE:Factory 
checked in at 2012-01-19 16:55:41

Comparing /work/SRC/openSUSE:Factory/grilo-plugins (Old)
 and  /work/SRC/openSUSE:Factory/.grilo-plugins.new (New)


Package is grilo-plugins, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/grilo-plugins/grilo-plugins.changes  
2012-01-09 15:17:12.0 +0100
+++ /work/SRC/openSUSE:Factory/.grilo-plugins.new/grilo-plugins.changes 
2012-01-19 16:55:43.0 +0100
@@ -1,0 +2,6 @@
+Wed Jan 11 20:19:25 UTC 2012 - dims...@opensuse.org
+
+- Build against gmime 2.6: replace pkgconfig(gmime-2.4)
+  BuildRequires with pkgconfig(gmime-2.4).
+
+---



Other differences:
--
++ grilo-plugins.spec ++
--- /var/tmp/diff_new_pack.y9QmYq/_old  2012-01-19 16:55:44.0 +0100
+++ /var/tmp/diff_new_pack.y9QmYq/_new  2012-01-19 16:55:44.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package grilo-plugins
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   grilo-plugins
 Version:0.1.18
 Release:0
@@ -29,7 +30,7 @@
 BuildRequires:  xz
 BuildRequires:  pkgconfig(gio-2.0)
 BuildRequires:  pkgconfig(glib-2.0)
-BuildRequires:  pkgconfig(gmime-2.4)
+BuildRequires:  pkgconfig(gmime-2.6)
 BuildRequires:  pkgconfig(gmodule-2.0)
 BuildRequires:  pkgconfig(gobject-2.0)
 BuildRequires:  pkgconfig(grilo-0.1) = 0.1.18


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gtk2-engines for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package gtk2-engines for openSUSE:Factory 
checked in at 2012-01-19 16:55:45

Comparing /work/SRC/openSUSE:Factory/gtk2-engines (Old)
 and  /work/SRC/openSUSE:Factory/.gtk2-engines.new (New)


Package is gtk2-engines, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gtk2-engines/gtk2-engines.changes
2012-01-09 15:17:25.0 +0100
+++ /work/SRC/openSUSE:Factory/.gtk2-engines.new/gtk2-engines.changes   
2012-01-19 16:55:50.0 +0100
@@ -1,0 +2,23 @@
+Fri Jan 13 12:23:41 UTC 2012 - vu...@opensuse.org
+
+- Manually remove translations in %install and drop lang
+  subpackage: the translations are useless at runtime, since they
+  are integrated in the xml files.
+- Add Obsoletes for gtk-engines-lang to main subpackage, for smooth
+  upgrades.
+
+---
+Sat Dec 24 20:39:29 UTC 2011 - gan...@opensuse.org
+
+- Split gtk2-engines package in subpackages for each engine and
+  theme: gtk2-engine-{engine_name} and gtk2-theme-{theme_name}, for
+  clearlooks, crux, glide, hcengine, industrial, mist, redmond95,
+  thinice. Fix bnc#706929.
+- Add Requires for all new subpackages to gtk2-engines: it is now a
+  metapackage used to install all engines and themes.
+- Add README.openSUSE to gtk2-engines to explain that this is a
+  metapackage.
+- Remove fdupes BuildRequires and call to %fdupes since it can't be
+  useful anymore with split packages.
+
+---

New:

  README.openSUSE



Other differences:
--
++ gtk2-engines.spec ++
--- /var/tmp/diff_new_pack.QT0tTg/_old  2012-01-19 16:55:51.0 +0100
+++ /var/tmp/diff_new_pack.QT0tTg/_new  2012-01-19 16:55:51.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gtk2-engines
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,36 +15,56 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   gtk2-engines
 %define _name gtk-engines
-BuildRequires:  fdupes
-BuildRequires:  gtk2-devel
-BuildRequires:  intltool
-BuildRequires:  pkg-config
-# See comment below on why this is disabled
-#BuildRequires:  lua-devel
-Summary:Engines for GTK2 Themes
+Summary:GTK+ 2 Theme Engines
 License:LGPL-2.1+
 Group:  System/GUI/GNOME
 Version:2.20.2
 Release:0
+# FIXME: On new version, change = Obsoletes to  (last checked: 2.20.2)
 # FIXME: On new versions, check if bgo#607127 is solved, and if it is, enable
 # the lua engine: uncomment lua-devel BuildRequires and configure options.
+Url:http://www.gnome.org
 Source: %{_name}-%{version}.tar.bz2
+Source1:README.openSUSE
 Source99:   baselibs.conf
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-# gnome-themes had Industrial before this version (= SuSE Linux 9.2, = NLD9).
-Conflicts:  gnome-themes  2.11.90
+#
+Patch0: gtk-engines-bnc546966-clearlooks-fix-main-menu-icon-size.patch
+# PATCH-FIX-UPSTREAM gtk-engines-glib.patch bgo#664914 dims...@opensuse.org -- 
FIx build with new glib: only glib.h can be included.
+Patch1: gtk-engines-glib.patch
+BuildRequires:  gtk2-devel
+BuildRequires:  intltool
+BuildRequires:  pkg-config
+# See comment below on why this is disabled
+#BuildRequires:  lua-devel
 # We require the exact version of gtk2 we were compiled with since the engines 
are located in a versioned directory
 %define gtk2_ver %(rpm -q --whatprovides --qf '%%{version}' gtk2)
-Requires:   gtk2 == %{gtk2_ver}
-Recommends: %{name}-lang
-Url:http://www.gnome.org
-Enhances:   gtk2
+Requires:   gtk2-engine-clearlooks
+Requires:   gtk2-theme-clearlooks
+Requires:   gtk2-engine-crux
+Requires:   gtk2-theme-crux
+Requires:   gtk2-engine-glide
+Requires:   gtk2-engine-hcengine
+Requires:   gtk2-engine-industrial
+Requires:   gtk2-theme-industrial
+Requires:   gtk2-engine-mist
+Requires:   gtk2-theme-mist
+Requires:   gtk2-engine-redmond95
+Requires:   gtk2-theme-redmond95
+Requires:   gtk2-engine-thinice
+Requires:   gtk2-theme-thinice
 # Prevent missing engine failures on bi-arch systems:
 %ifarch x86_64 s390x
 Recommends: %{name}-32bit = %{version}
 %endif
+Enhances:   gtk2
+# gnome-themes had Industrial before this version (= SuSE Linux 9.2, = NLD9).
+Conflicts:  gnome-themes  2.11.90
+# For 

commit keybinder for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package keybinder for openSUSE:Factory 
checked in at 2012-01-19 16:55:54

Comparing /work/SRC/openSUSE:Factory/keybinder (Old)
 and  /work/SRC/openSUSE:Factory/.keybinder.new (New)


Package is keybinder, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/keybinder/keybinder.changes  2011-09-23 
02:06:45.0 +0200
+++ /work/SRC/openSUSE:Factory/.keybinder.new/keybinder.changes 2012-01-19 
16:55:55.0 +0100
@@ -1,0 +2,6 @@
+Sun Jan  8 16:10:41 UTC 2012 - g...@opensuse.org
+
+- build against lua51 on  12.1
+- remove /usr/bin/env shebang from example scripts
+
+---



Other differences:
--
++ keybinder.spec ++
--- /var/tmp/diff_new_pack.uGgkm0/_old  2012-01-19 16:55:56.0 +0100
+++ /var/tmp/diff_new_pack.uGgkm0/_new  2012-01-19 16:55:56.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package keybinder
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -22,18 +22,23 @@
 
 Name:   keybinder
 Version:0.2.2
-Release:3
-License:GPL-2.0
+Release:0
 Summary:A Library for Registering Global Keyboard Shortcuts
-Url:http://kaizer.se/wiki/keybinder/
+License:GPL-2.0
 Group:  Development/Libraries/Other
+Url:http://kaizer.se/wiki/keybinder/
 Source: %{name}-%{version}.tar.bz2
+BuildRequires:  ed
 BuildRequires:  fdupes
-BuildRequires:  lua-devel
-BuildRequires:  pkgconfig(gtk+-2.0)
 BuildRequires:  python-devel
 BuildRequires:  python-gobject2-devel
 BuildRequires:  python-gtk-devel
+%if 0%{suse_version}  1210
+BuildRequires:  lua51-devel
+%else
+BuildRequires:  lua-devel
+%endif
+BuildRequires:  pkgconfig(gtk+-2.0)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -47,7 +52,6 @@
 - An examples directory with programs in C, Lua, Python and Vala.
 
 %package -n %libname
-License:GPL-2.0
 Summary:Library Package for Keybinder
 Group:  System/Libraries
 
@@ -62,7 +66,6 @@
 - An examples directory with programs in C, Lua, Python and Vala.
 
 %package devel
-License:GPL-2.0
 Summary:Development Files for Keybinder
 Group:  Development/Libraries/Other
 Requires:   %{libname} = %{version}
@@ -73,7 +76,6 @@
 based on keybinder.
 
 %package lua
-License:GPL-2.0
 Summary:Lua Files for Keybinder
 Group:  Development/Libraries/Other
 Requires:   %{libname} = %{version}
@@ -83,7 +85,6 @@
 
 %package -n python-%{name}
 
-
 Summary:Python Bindings for Keybinder
 Group:  Development/Libraries/Python
 Requires:   python-base = %{py_ver}
@@ -96,6 +97,12 @@
 
 %prep
 %setup -q
+find examples/ \( -name '*.py' -o -name '*.lua' \) -print -exec sh -c '
+ed -s $1 2/dev/null \EOF
+,s/^#!\/usr\/bin\/env /#!\/usr\/bin\//
+w
+EOF
+' {} {} \;
 
 %build
 %{configure}\

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gtk2-metatheme-equinox for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package gtk2-metatheme-equinox for 
openSUSE:Factory checked in at 2012-01-19 16:55:49

Comparing /work/SRC/openSUSE:Factory/gtk2-metatheme-equinox (Old)
 and  /work/SRC/openSUSE:Factory/.gtk2-metatheme-equinox.new (New)


Package is gtk2-metatheme-equinox, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/gtk2-metatheme-equinox/gtk2-metatheme-equinox.changes
2012-01-05 19:12:57.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.gtk2-metatheme-equinox.new/gtk2-metatheme-equinox.changes
   2012-01-19 16:55:52.0 +0100
@@ -1,0 +2,6 @@
+Fri Jan 13 13:07:34 UTC 2012 - vu...@opensuse.org
+
+- Add dmz-icon-theme-cursors and faenza-icon-theme Requires to main
+  subpackage, as those are needed by the metathemes.
+
+---



Other differences:
--
++ gtk2-metatheme-equinox.spec ++
--- /var/tmp/diff_new_pack.kYInQb/_old  2012-01-19 16:55:53.0 +0100
+++ /var/tmp/diff_new_pack.kYInQb/_new  2012-01-19 16:55:53.0 +0100
@@ -15,7 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %define _version 1.50
 # Unfortunately, the tarballs are not properly versioned. The real
 # version has to be found on the website...
@@ -33,6 +32,10 @@
 Patch1: gtk2-metatheme-equinox-glib-2.31.patch
 BuildRequires:  fdupes
 BuildRequires:  pkgconfig(gtk+-2.0)
+# Cursor theme specified in .theme files
+Requires:   dmz-icon-theme-cursors
+# Icon theme specified in .theme files
+Requires:   faenza-icon-theme
 Requires:   gtk2-engine-equinox
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libdmapsharing for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libdmapsharing for openSUSE:Factory 
checked in at 2012-01-19 16:55:58

Comparing /work/SRC/openSUSE:Factory/libdmapsharing (Old)
 and  /work/SRC/openSUSE:Factory/.libdmapsharing.new (New)


Package is libdmapsharing, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libdmapsharing/libdmapsharing.changes
2011-11-16 17:19:13.0 +0100
+++ /work/SRC/openSUSE:Factory/.libdmapsharing.new/libdmapsharing.changes   
2012-01-19 16:56:01.0 +0100
@@ -1,0 +2,6 @@
+Wed Jan 18 07:06:28 UTC 2012 - vu...@opensuse.org
+
+- Update to version 2.9.14:
+  + Use single include for glib.
+
+---

Old:

  libdmapsharing-2.9.13.tar.gz

New:

  libdmapsharing-2.9.14.tar.gz



Other differences:
--
++ libdmapsharing.spec ++
--- /var/tmp/diff_new_pack.YQozvT/_old  2012-01-19 16:56:02.0 +0100
+++ /var/tmp/diff_new_pack.YQozvT/_new  2012-01-19 16:56:02.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libdmapsharing
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c) 2010 Dominique Leuenberger, Amsterdam, Netherlands.
 #
 # All modifications and additions to the file contributed by third parties
@@ -17,19 +17,18 @@
 #
 
 
-
 Name:   libdmapsharing
-Version:2.9.13
-Release:1
-License:LGPL-2.1+
+Version:2.9.14
+Release:0
 Summary:Library implementing the DMAP family of protocols
-Url:http://www.flyn.org/projects/libdmapsharing/
+License:LGPL-2.1+
 Group:  System/Libraries
+Url:http://www.flyn.org/projects/libdmapsharing/
 Source: 
http://flyn.org/projects/libdmapsharing/%{name}-%{version}.tar.gz
 BuildRequires:  pkg-config
 BuildRequires:  pkgconfig(avahi-glib)
-BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(gdk-pixbuf-2.0)
+BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
 BuildRequires:  pkgconfig(libsoup-2.4)
 
@@ -43,7 +42,6 @@
 share media such as music and photos.
 
 %package -n libdmapsharing-3_0-2
-License:LGPL-2.1+
 Summary:Library implementing the DMAP family of protocols
 Group:  System/Libraries
 
@@ -57,7 +55,6 @@
 share media such as music and photos.
 
 %package devel
-License:LGPL-2.1+
 Summary:Library implementing the DMAP family of protocols - 
Development Files
 Group:  Development/Languages/C and C++
 Requires:   libdmapsharing-3_0-2 = %{version}

++ libdmapsharing-2.9.13.tar.gz - libdmapsharing-2.9.14.tar.gz ++
 6381 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit nautilus-terminal for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package nautilus-terminal for 
openSUSE:Factory checked in at 2012-01-19 16:56:05

Comparing /work/SRC/openSUSE:Factory/nautilus-terminal (Old)
 and  /work/SRC/openSUSE:Factory/.nautilus-terminal.new (New)


Package is nautilus-terminal, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/nautilus-terminal/nautilus-terminal.changes  
2011-10-02 10:20:20.0 +0200
+++ /work/SRC/openSUSE:Factory/.nautilus-terminal.new/nautilus-terminal.changes 
2012-01-19 16:56:07.0 +0100
@@ -1,0 +2,10 @@
+Wed Jan 18 09:27:52 UTC 2012 - vu...@opensuse.org
+
+- Update to version 1.0:
+  + Implement about dialog.
+  + Add accelerators for copy/paste.
+  + Implement drag and drop.
+  + Bug fixes.
+- Drop nautilus-terminal-gi-gobject.patch: fixed upstream.
+
+---

Old:

  nautilus-terminal-0.99_bzr9.tar.gz
  nautilus-terminal-gi-gobject.patch

New:

  nautilus-terminal_1.0_src.tar.gz



Other differences:
--
++ nautilus-terminal.spec ++
--- /var/tmp/diff_new_pack.Pt5W2B/_old  2012-01-19 16:56:08.0 +0100
+++ /var/tmp/diff_new_pack.Pt5W2B/_new  2012-01-19 16:56:08.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package nautilus-terminal
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,20 +15,16 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %define have_lang 0
 
 Name:   nautilus-terminal
-# This is a checkout of the current version in bzr (revision 9)
-Version:0.99_bzr9
-Release:1
-License:GPL-3.0+
+Version:1.0
+Release:0
 Summary:Integrated Terminal for the Nautilus File Browser
-Url:http://software.flogisoft.com/nautilus-terminal/
+License:GPL-3.0+
 Group:  System/GUI/GNOME
-Source: %{name}-%{version}.tar.gz
-# PATCH-FIX-UPSTREAM nautilus-terminal-gi-gobject.patch lp#841381 
vu...@opensuse.org -- Finish port to pygobject 3.0
-Patch0: nautilus-terminal-gi-gobject.patch
+Url:http://software.flogisoft.com/nautilus-terminal/
+Source: %{name}_%{version}_src.tar.gz
 # For directory ownership:
 BuildRequires:  python-nautilus
 Requires:   nautilus
@@ -49,8 +45,7 @@
 %endif
 
 %prep
-%setup -q -n %{name}
-%patch0 -p1
+%setup -q -n %{name}_%{version}_src
 sed -i '
 s:/usr/share/doc:%{_docdir}/%{name}:
 s:/usr/share:%{_datadir}:
@@ -72,6 +67,7 @@
 %defattr(-,root,root)
 %doc %{_docdir}/%{name}/
 %{_datadir}/nautilus-python/extensions/nautilus_terminal.py
+%{_datadir}/nautilus-terminal/
 
 %if %{have_lang}
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit offlineimap for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package offlineimap for openSUSE:Factory 
checked in at 2012-01-19 16:56:10

Comparing /work/SRC/openSUSE:Factory/offlineimap (Old)
 and  /work/SRC/openSUSE:Factory/.offlineimap.new (New)


Package is offlineimap, Maintainer is gre...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/offlineimap/offlineimap.changes  2012-01-09 
16:01:23.0 +0100
+++ /work/SRC/openSUSE:Factory/.offlineimap.new/offlineimap.changes 
2012-01-19 16:56:12.0 +0100
@@ -1,0 +2,19 @@
+Tue Jan 17 09:26:40 UTC 2012 - g...@opensuse.org
+
+- update to version 6.5.2
+  * user documentation is now integrated in
+http://docs.offlineimap.org
+  * Gmail realdelete option is considered harmful and has the
+potential for data loss (see
+http://article.gmane.org/gmane.mail.imap.offlineimap.general/5265)
+  * rather than write out the nametrans'lated folder names for
+mbnames, we now write out the local untransformed box names,
+this became relevant since we support nametrans rules on the
+local side since only a short time
+  * some sanity checks and improved error messages
+  * revert 6.5.1.1 change to use public imaplib2 function, it was
+reported to not always work
+  * don't fail when ~/netrc is not readable by us
+  * don't emit noisy regular sleeping announcements in Basic UI
+
+---

Old:

  offlineimap-v6.5.1.2.tar.gz

New:

  offlineimap-v6.5.2.tar.gz



Other differences:
--
++ offlineimap.spec ++
--- /var/tmp/diff_new_pack.QzQLxN/_old  2012-01-19 16:56:13.0 +0100
+++ /var/tmp/diff_new_pack.QzQLxN/_new  2012-01-19 16:56:13.0 +0100
@@ -16,7 +16,7 @@
 #
 
 Name:   offlineimap
-Version:6.5.1.2
+Version:6.5.2
 Release:0
 Summary:Powerful IMAP/Maildir Synchronization Tool
 License:GPL-2.0+
@@ -47,7 +47,7 @@
 
 
 %prep
-%setup -q -n spaetz-offlineimap-36080ac
+%setup -q -n spaetz-offlineimap-091272d
 sed -i '/^#!\/usr\/bin\/env/d' offlineimap/imaplib2.py
 
 %build

++ offlineimap-v6.5.1.2.tar.gz - offlineimap-v6.5.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/spaetz-offlineimap-36080ac/Changelog.rst 
new/spaetz-offlineimap-091272d/Changelog.rst
--- old/spaetz-offlineimap-36080ac/Changelog.rst2012-01-07 
23:34:00.0 +0100
+++ new/spaetz-offlineimap-091272d/Changelog.rst2012-01-17 
01:40:41.0 +0100
@@ -11,6 +11,28 @@
   on releases. And because I'm lazy, it will also be used as a draft for the
   releases announces.
 
+OfflineIMAP v6.5.2 (2012-01-17)
+===
+
+* Gmail realdelete option is considered harmful and has the potential
+  for data loss. Analysis at
+  http://article.gmane.org/gmane.mail.imap.offlineimap.general/5265
+  Warnings were added to offlineimap.conf
+
+* Rather than write out the nametrans'lated folder names for mbnames, we
+  now write out the local untransformed box names. This is generally
+  what we want. This became relevant since we support nametrans rules on
+  the local side since only a short time. Reported by Paul Collignan.
+
+* Some sanity checks and improved error messages.
+
+* Revert 6.5.1.1 change to use public imaplib2 function, it was reported to 
+  not always work.
+
+* Don't fail when ~/netrc is not readable by us.
+
+* Don't emit noisy regular sleeping announcements in Basic UI.
+
 OfflineIMAP v6.5.1.2 (2012-01-07) - Baby steps
 
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/spaetz-offlineimap-36080ac/docs/INSTALL.rst 
new/spaetz-offlineimap-091272d/docs/INSTALL.rst
--- old/spaetz-offlineimap-36080ac/docs/INSTALL.rst 2012-01-07 
23:34:00.0 +0100
+++ new/spaetz-offlineimap-091272d/docs/INSTALL.rst 2012-01-17 
01:40:41.0 +0100
@@ -1,81 +1,90 @@
 .. -*- coding: utf-8 -*-
+.. _OfflineIMAP: https://github.com/spaetz/offlineimap
+.. _OLI_git_repo: git://github.com/spaetz/offlineimap.git
 
-.. _OfflineIMAP: https://github.com/nicolas33/offlineimap
+
+Installation
+
 
 .. contents::
-.. sectnum::
+.. .. sectnum::
 
-=
+-
 Prerequisites
-=
+-
 
 In order to use `OfflineIMAP`_, you need to have these conditions satisfied:
 
-1. Your mail server must support IMAP.  Most Internet Service Providers and
-   corporate networks do, and most operating systems have an IMAP 
implementation
-   readily available.  A special Gmail mailbox type is available to interface 
with
-   Gmail's IMAP front-end.
-
-2. You must have Python 

commit php5-pear-Horde_Date_Parser for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Date_Parser for 
openSUSE:Factory checked in at 2012-01-19 16:56:27

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Date_Parser (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Date_Parser.new (New)


Package is php5-pear-Horde_Date_Parser, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Date_Parser/php5-pear-Horde_Date_Parser.changes
  2011-09-23 12:40:18.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Date_Parser.new/php5-pear-Horde_Date_Parser.changes
 2012-01-19 16:56:29.0 +0100
@@ -1,0 +2,14 @@
+Fri Jan 13 11:35:08 UTC 2012 - l...@b1-systems.de
+
+- add license faile
+- version 1.0.2
+- [jan] Fix tests to work with PHPUnit 3.6.
+- [jan] Correctly parse 'nacht' in German (Bug #10511).
+
+
+---
+Sun Aug 14 20:44:00 UTC 2011 - l...@b1-systems.de
+
+- removed the explicit conflict with 2.0 packages
+
+---

Old:

  Horde_Date_Parser-1.0.0.tgz

New:

  Horde_Date_Parser-1.0.2.tgz



Other differences:
--
++ php5-pear-Horde_Date_Parser.spec ++
--- /var/tmp/diff_new_pack.EhMFyW/_old  2012-01-19 16:56:30.0 +0100
+++ /var/tmp/diff_new_pack.EhMFyW/_new  2012-01-19 16:56:30.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Date_Parser
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,18 +20,17 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: Horde Date Parser
+License:LGPL-2.1
+Group:  Development/Libraries/PHP
 
 Name:   php5-pear-Horde_Date_Parser
-Version:1.0.0
-Release:1
-License:LGPL
-Group:  Development/Libraries/PHP
+Version:1.0.2
+Release:0
 Source0:http://pear.horde.org/get/Horde_Date_Parser-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Date_Parser
 BuildRequires:  php5-pear = 1.4.7
 Requires:   php5-pear-Horde_Date  2.0.0, php5-pear-Horde_Support  2.0.0, 
php5-pear = 1.7.0
-Conflicts:  php5-pear-Horde_Date = 2.0.0, php5-pear-Horde_Support = 2.0.0
 BuildRequires:  php5-pear-channel-horde
 Requires:   php5-pear-channel-horde
 BuildArch:  noarch

++ Horde_Date_Parser-1.0.0.tgz - Horde_Date_Parser-1.0.2.tgz ++
 7578 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Itip for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Itip for 
openSUSE:Factory checked in at 2012-01-19 16:56:36

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Itip (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Itip.new (New)


Package is php5-pear-Horde_Itip, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Itip/php5-pear-Horde_Itip.changes
2011-09-23 12:40:24.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Itip.new/php5-pear-Horde_Itip.changes
   2012-01-19 16:56:37.0 +0100
@@ -1,0 +2,9 @@
+Fri Jan 13 14:03:32 UTC 2012 - l...@b1-systems.de
+
+- version 1.0.6
+- added license file
+- [jan] Add Estonian translation.
+- [jan] Update Croatian translation.
+- [jan] Make unit tests locale independent.
+
+---

Old:

  Horde_Itip-1.0.4.tgz

New:

  Horde_Itip-1.0.6.tgz



Other differences:
--
++ php5-pear-Horde_Itip.spec ++
--- /var/tmp/diff_new_pack.J8QIsl/_old  2012-01-19 16:56:38.0 +0100
+++ /var/tmp/diff_new_pack.J8QIsl/_new  2012-01-19 16:56:38.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Itip
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,12 +20,12 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: Horde invitation response handling
-
-Name:   php5-pear-Horde_Itip
-Version:1.0.4
-Release:1
 License:LGPL-2.1
 Group:  Development/Libraries/PHP
+
+Name:   php5-pear-Horde_Itip
+Version:1.0.6
+Release:0
 Source0:http://pear.horde.org/get/Horde_Itip-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Itip

++ Horde_Itip-1.0.4.tgz - Horde_Itip-1.0.6.tgz ++
 12401 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Imap_Client for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Imap_Client for 
openSUSE:Factory checked in at 2012-01-19 16:56:32

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Imap_Client (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Imap_Client.new (New)


Package is php5-pear-Horde_Imap_Client, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Imap_Client/php5-pear-Horde_Imap_Client.changes
  2011-09-23 12:40:23.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Imap_Client.new/php5-pear-Horde_Imap_Client.changes
 2012-01-19 16:56:33.0 +0100
@@ -1,0 +2,37 @@
+Fri Jan 13 13:48:26 UTC 2012 - l...@b1-systems.de
+
+- added license
+- version 1.3.1
+- [mms] Remove dependency on Auth_SASL.
+- [mms] Fix client-side Cc/From/To sorting (Bug #10503).
+- [mms] Improved IMAP debug logging.
+- [mms] Fix search charset determination for servers that support SORT amp; 
ESORT (Bug #10479).
+- [mms] Improved phpdoc documentation.
+- [mms] API CHANGE: Add shortcuts to get MIME decoded envelope information.
+- [mms] Automatically authenticate to server when using a command that 
requires an authenticated/selected state (Bug #10473).
+- [mms] Fixed setting data for several POP3 fetch results.
+- [mms] Parsing/generating sequence strings for POP3 servers has been fixed.
+- [mms] Removed unmaintained Mock driver.
+- [mms] API CHANGE: Added Horde_Imap_Client_Mailbox to provide way to 
accurately switch between UTF7-IMAP and UTF-8 mailbox representations.
+- [mms] API CHANGE: Deprecate Horde_Imap_Client_Base::parseCommandArray() - 
use Horde_Imap_Client_Utils::parseCommandArray() instead.
+- [mms] API CHANGE: Added a required parameter (apos;baseobapos;) to 
Horde_Imap_Client_Cache constructor.
+- [mms] API CHANGE: Added Horde_Imap_Client_Base::writeDebug().
+- [mms] API CHANGE: Added Horde_Imap_Client_Base::getIdsOb().
+- [mms] API CHANGE: Deprecate Horde_Imap_Client_Cache::singleton().
+- [mms] Workaround missing search charset support in the Socket driver (Bug 
#10726).
+- [mms] Only add CHARSET data to SEARCH queries if necessary (Bug #10726).
+- [mms] Work around broken headers in IMAP envelope data.
+- [mms] LIST-STATUS does not depend on LIST-EXTENDED.
+- [mms] Add dependency checking for capabilities.
+- [mms] Remove Cclient drivers.
+- [mms] Fix deletion of cached message entries.
+
+
+---
+Sat Aug 27 19:41:48 UTC 2011 - l...@b1-systems.de
+
+- version 1.0.13
+- [mms] Encrypted data is already base64 encoded (Bug #10285).
+- Fix typo that prevented deletion of messages on POP3 servers (Bug #10424).
+
+---

Old:

  Horde_Imap_Client-1.0.11.tgz

New:

  Horde_Imap_Client-1.3.1.tgz



Other differences:
--
++ php5-pear-Horde_Imap_Client.spec ++
--- /var/tmp/diff_new_pack.vRFqxa/_old  2012-01-19 16:56:34.0 +0100
+++ /var/tmp/diff_new_pack.vRFqxa/_new  2012-01-19 16:56:34.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Imap_Client
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,12 +20,12 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: Horde IMAP abstraction interface
+License:LGPL-2.1
+Group:  Development/Libraries/PHP
 
 Name:   php5-pear-Horde_Imap_Client
-Version:1.0.11
-Release:1
-License:LGPLv2.1
-Group:  Development/Libraries/PHP
+Version:1.3.1
+Release:0
 Source0:http://pear.horde.org/get/Horde_Imap_Client-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Imap_Client
@@ -33,6 +33,9 @@
 Requires:   php5-pear-Horde_Exception  2.0.0
 Requires:   php5-pear-Horde_Mime  2.0.0
 Requires:   php5-pear-Horde_Util  2.0.0
+Requires:   php5-pear-Horde_Secret  2.0.0
+Requires:   php5-pear-Horde_Cache  2.0.0
+Requires:   php5-pear-Horde_Stream_Filter  2.0.0
 Requires:   php5-pear = 1.7.0
 BuildRequires:  php5-pear-channel-horde
 Requires:   php5-pear-channel-horde
@@ -98,5 +101,6 @@
 
 %{peardir}/*
 %{xmldir}/Horde_Imap_Client.xml
+%doc %{_docdir}/%{name}
 
 %changelog

++ Horde_Imap_Client-1.0.11.tgz - Horde_Imap_Client-1.3.1.tgz ++
 36688 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: 

commit php5-pear-Horde_DataTree for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_DataTree for 
openSUSE:Factory checked in at 2012-01-19 16:56:22

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_DataTree (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_DataTree.new (New)


Package is php5-pear-Horde_DataTree, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_DataTree/php5-pear-Horde_DataTree.changes
2011-09-23 12:40:17.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_DataTree.new/php5-pear-Horde_DataTree.changes
   2012-01-19 16:56:25.0 +0100
@@ -1,0 +2,7 @@
+Fri Jan 13 10:33:28 UTC 2012 - l...@b1-systems.de
+
+- version 1.0.1
+- add license faile
+- [jan] Add missing dependency on PEAR DB package.
+
+---

Old:

  Horde_DataTree-1.0.0.tgz

New:

  Horde_DataTree-1.0.1.tgz



Other differences:
--
++ php5-pear-Horde_DataTree.spec ++
--- /var/tmp/diff_new_pack.Ab5wYl/_old  2012-01-19 16:56:26.0 +0100
+++ /var/tmp/diff_new_pack.Ab5wYl/_new  2012-01-19 16:56:26.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_DataTree
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,18 +20,17 @@
 %define xmldir  /var/lib/pear
 
 Summary:PEAR: DataTree API
+License:LGPL-2.1
+Group:  Development/Libraries/PHP
 
 Name:   php5-pear-Horde_DataTree
-Version:1.0.0
-Release:1
-License:LGPL
-Group:  Development/Libraries/PHP
+Version:1.0.1
+Release:0
 Source0:http://pear.horde.org/get/Horde_DataTree-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_DataTree
 BuildRequires:  php5-pear = 1.4.7
-Requires:   php5-pear-Horde_Core  2.0.0, php5-pear-Horde_Exception  
2.0.0, php5-pear-Horde_Serialize  2.0.0, php5-pear-Horde_Util  2.0.0, 
php5-pear = 1.7.0
-Conflicts:  php5-pear-Horde_Core = 2.0.0, php5-pear-Horde_Exception = 
2.0.0, php5-pear-Horde_Serialize = 2.0.0, php5-pear-Horde_Util = 2.0.0
+Requires:   php5-pear-Horde_Core  2.0.0, php5-pear-Horde_Exception  
2.0.0, php5-pear-Horde_Serialize  2.0.0, php5-pear-Horde_Util  2.0.0, 
php5-pear = 1.7.0 php5-pear-DB
 BuildRequires:  php5-pear-channel-horde
 Requires:   php5-pear-channel-horde
 BuildArch:  noarch

++ Horde_DataTree-1.0.0.tgz - Horde_DataTree-1.0.1.tgz ++
 8811 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit pidgin-sipe for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package pidgin-sipe for openSUSE:Factory 
checked in at 2012-01-19 16:56:40

Comparing /work/SRC/openSUSE:Factory/pidgin-sipe (Old)
 and  /work/SRC/openSUSE:Factory/.pidgin-sipe.new (New)


Package is pidgin-sipe, Maintainer is gb...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/pidgin-sipe/pidgin-sipe.changes  2012-01-09 
21:44:12.0 +0100
+++ /work/SRC/openSUSE:Factory/.pidgin-sipe.new/pidgin-sipe.changes 
2012-01-19 16:57:54.0 +0100
@@ -1,0 +2,7 @@
+Thu Jan 12 08:57:16 UTC 2012 - dims...@opensuse.org
+
+- Change gmime-2_4-devel BuildRequires to gmime-devel. This rename
+  happened long ago and was just a virtual provides by now.
+- Drop checks for openSUSE 11.1.
+
+---



Other differences:
--
++ pidgin-sipe.spec ++
--- /var/tmp/diff_new_pack.9kCSIR/_old  2012-01-19 16:57:55.0 +0100
+++ /var/tmp/diff_new_pack.9kCSIR/_new  2012-01-19 16:57:55.0 +0100
@@ -32,9 +32,7 @@
 Patch0: pidgin-sipe-no-deprecated.patch
 BuildRequires:  gettext-devel
 BuildRequires:  glib2-devel = 2.12.0
-%if 0%{?suse_version}  1110
-BuildRequires:  gmime-2_4-devel
-%endif
+BuildRequires:  gmime-devel
 BuildRequires:  intltool
 BuildRequires:  krb5-devel
 BuildRequires:  libpurple-devel = 2.4.0

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit xfce4-panel-plugin-netload for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package xfce4-panel-plugin-netload for 
openSUSE:Factory checked in at 2012-01-19 16:57:11

Comparing /work/SRC/openSUSE:Factory/xfce4-panel-plugin-netload (Old)
 and  /work/SRC/openSUSE:Factory/.xfce4-panel-plugin-netload.new (New)


Package is xfce4-panel-plugin-netload, Maintainer is 
xfce-maintain...@suse.de

Changes:

--- 
/work/SRC/openSUSE:Factory/xfce4-panel-plugin-netload/xfce4-panel-plugin-netload.changes
2011-09-23 12:51:21.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.xfce4-panel-plugin-netload.new/xfce4-panel-plugin-netload.changes
   2012-01-19 16:58:02.0 +0100
@@ -1,0 +2,9 @@
+Fri Jan 13 15:04:50 UTC 2012 - g...@opensuse.org
+
+- update to version 1.1.0
+  - add option to show values in panel in addition to the bars
+  - format units automatically
+  - port to libxfce4ui
+  - fix two calls to snprintf
+
+---

Old:

  xfce4-netload-plugin-1.0.0.tar.bz2

New:

  xfce4-netload-plugin-1.1.0.tar.bz2



Other differences:
--
++ xfce4-panel-plugin-netload.spec ++
--- /var/tmp/diff_new_pack.pFRKPd/_old  2012-01-19 16:58:03.0 +0100
+++ /var/tmp/diff_new_pack.pFRKPd/_new  2012-01-19 16:58:03.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package xfce4-panel-plugin-netload
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,21 +15,21 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %define panel_version 4.8.0
 %define plugin_name xfce4-netload-plugin
 
 Name:   xfce4-panel-plugin-netload
-License:GPL-2.0+
-Version:1.0.0
-Release:5
+Version:1.1.0
+Release:0
 Summary:Network load monitoring plugin for the Xfce panel
-Url:
http://goodies.xfce.org/projects/panel-plugins/xfce4-netload-plugin
-Source0:xfce4-netload-plugin-1.0.0.tar.bz2
+License:GPL-2.0+
 Group:  System/GUI/XFCE
-BuildRequires:  intltool
+Url:
http://goodies.xfce.org/projects/panel-plugins/xfce4-netload-plugin
+Source0:xfce4-netload-plugin-%{version}.tar.bz2
 BuildRequires:  fdupes
+BuildRequires:  intltool
 BuildRequires:  pkgconfig(libxfce4panel-1.0)
+BuildRequires:  pkgconfig(libxfce4ui-1)
 Requires:   xfce4-panel = 4.8.0
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 

++ xfce4-netload-plugin-1.0.0.tar.bz2 - xfce4-netload-plugin-1.1.0.tar.bz2 
++
 6888 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-matplotlib for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package python-matplotlib for 
openSUSE:Factory checked in at 2012-01-19 16:56:53

Comparing /work/SRC/openSUSE:Factory/python-matplotlib (Old)
 and  /work/SRC/openSUSE:Factory/.python-matplotlib.new (New)


Package is python-matplotlib, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-matplotlib/python-matplotlib.changes  
2011-12-26 16:29:13.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-matplotlib.new/python-matplotlib.changes 
2012-01-19 16:57:57.0 +0100
@@ -1,0 +2,5 @@
+Tue Jan 10 11:38:24 CET 2012 - ku...@suse.de
+
+- Fix spec file for SLE11 (Group entries did go lost)
+
+---



Other differences:
--
++ python-matplotlib.spec ++
--- /var/tmp/diff_new_pack.yH7VXp/_old  2012-01-19 16:57:59.0 +0100
+++ /var/tmp/diff_new_pack.yH7VXp/_new  2012-01-19 16:57:59.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-matplotlib
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,8 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   python-matplotlib
 Version:1.1.0
 Release:0
@@ -84,6 +82,7 @@
 
 %package tk
 Summary:Tk backend for python-matplotlib
+Group:  Development/Libraries/Python
 Requires:   %{name} = %{version}
 Requires:   python-tk
 
@@ -92,6 +91,7 @@
 
 %package wx
 Summary:Wx backend for python-matplotlib
+Group:  Development/Libraries/Python
 Requires:   %{name} = %{version}
 Requires:   python-wxGTK
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit xfce4-panel-plugin-xkb for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package xfce4-panel-plugin-xkb for 
openSUSE:Factory checked in at 2012-01-19 16:57:15

Comparing /work/SRC/openSUSE:Factory/xfce4-panel-plugin-xkb (Old)
 and  /work/SRC/openSUSE:Factory/.xfce4-panel-plugin-xkb.new (New)


Package is xfce4-panel-plugin-xkb, Maintainer is xfce-maintain...@suse.de

Changes:

--- 
/work/SRC/openSUSE:Factory/xfce4-panel-plugin-xkb/xfce4-panel-plugin-xkb.changes
2011-12-06 13:54:18.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.xfce4-panel-plugin-xkb.new/xfce4-panel-plugin-xkb.changes
   2012-01-19 16:58:03.0 +0100
@@ -1,0 +2,8 @@
+Sat Jan  7 13:38:49 UTC 2012 - g...@opensuse.org
+
+- update to version 0.5.4.3
+  - fix error with incorrect handling variants
+  - text size on icon is now adjustable
+  - new flag: Cambodia
+
+---

Old:

  xfce4-xkb-plugin-0.5.4.2.tar.bz2

New:

  xfce4-xkb-plugin-0.5.4.3.tar.bz2



Other differences:
--
++ xfce4-panel-plugin-xkb.spec ++
--- /var/tmp/diff_new_pack.McEAeU/_old  2012-01-19 16:58:05.0 +0100
+++ /var/tmp/diff_new_pack.McEAeU/_new  2012-01-19 16:58:05.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package xfce4-panel-plugin-xkb
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,25 +15,24 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %define panel_version 4.8.0
 %define plugin_name xfce4-xkb-plugin
 
 Name:   xfce4-panel-plugin-xkb
-License:GPL-2.0+
-Version:0.5.4.2
-Release:19
+Version:0.5.4.3
+Release:0
 Summary:XKB layout switcher plugin for the Xfce panel
+License:GPL-2.0+
+Group:  System/GUI/XFCE
 Url:http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin
 Source0:xfce4-xkb-plugin-%{version}.tar.bz2
-Group:  System/GUI/XFCE
-BuildRequires:  intltool
 BuildRequires:  fdupes
+BuildRequires:  intltool
+BuildRequires:  pkgconfig(librsvg-2.0)
+BuildRequires:  pkgconfig(libwnck-1.0)
 BuildRequires:  pkgconfig(libxfce4panel-1.0)
 BuildRequires:  pkgconfig(libxfce4ui-1)
 BuildRequires:  pkgconfig(libxklavier)
-BuildRequires:  pkgconfig(librsvg-2.0)
-BuildRequires:  pkgconfig(libwnck-1.0)
 Requires:   xfce4-panel = 4.8.0
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 

++ xfce4-xkb-plugin-0.5.4.2.tar.bz2 - xfce4-xkb-plugin-0.5.4.3.tar.bz2 
++
 6010 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit release-notes-openSUSE for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package release-notes-openSUSE for 
openSUSE:Factory checked in at 2012-01-19 16:56:58

Comparing /work/SRC/openSUSE:Factory/release-notes-openSUSE (Old)
 and  /work/SRC/openSUSE:Factory/.release-notes-openSUSE.new (New)


Package is release-notes-openSUSE, Maintainer is k...@suse.com

Changes:

--- 
/work/SRC/openSUSE:Factory/release-notes-openSUSE/release-notes-openSUSE.changes
2011-11-10 16:04:13.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.release-notes-openSUSE.new/release-notes-openSUSE.changes
   2012-01-19 16:57:59.0 +0100
@@ -1,0 +2,12 @@
+Thu Jan 19 09:33:56 UTC 2012 - k...@suse.de
+
+- 12.2.0:
+* Start resetting for 12.2.
+
+---
+Fri Nov 25 14:40:45 UTC 2011 - k...@suse.de
+
+- 12.1.8:
+* Update translations (bnc#729717).
+
+---

Old:

  release-notes-opensuse-12.1.7.tar.bz2

New:

  release-notes-opensuse-12.2.0.tar.bz2



Other differences:
--
++ release-notes-openSUSE.spec ++
--- /var/tmp/diff_new_pack.zYMfA5/_old  2012-01-19 16:58:00.0 +0100
+++ /var/tmp/diff_new_pack.zYMfA5/_new  2012-01-19 16:58:00.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package release-notes-openSUSE
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,8 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   release-notes-openSUSE
 BuildRequires:  docbook-xsl-stylesheets
@@ -28,13 +26,13 @@
 BuildRequires:  update-desktop-files
 BuildRequires:  xml2po
 BuildRequires:  xmlcharent
-License:GFDLv1.1
-Group:  Documentation/SUSE
 Summary:Most Important Changes for This openSUSE Release
+License:GFDL-1.1
+Group:  Documentation/SUSE
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-Version:12.1.7
-Release:1
+Version:12.2.0
+Release:0
 Provides:   release-notes = %{version}
 Source0:release-notes-opensuse-%{version}.tar.bz2
 Source8:%{name}.desktop.in
@@ -47,7 +45,6 @@
 
 
 %prep
-# %%setup -q -n release-notes-%version
 %setup -q -n release-notes-opensuse-%{version}
 # rfile=RELEASE-NOTES-openSUSE.en.po
 rfile=po/en.po

++ release-notes-opensuse-12.1.7.tar.bz2 - 
release-notes-opensuse-12.2.0.tar.bz2 ++
 14269 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit xfce4-session for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package xfce4-session for openSUSE:Factory 
checked in at 2012-01-19 16:57:20

Comparing /work/SRC/openSUSE:Factory/xfce4-session (Old)
 and  /work/SRC/openSUSE:Factory/.xfce4-session.new (New)


Package is xfce4-session, Maintainer is xfce-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/xfce4-session/xfce4-session.changes  
2011-12-21 10:04:30.0 +0100
+++ /work/SRC/openSUSE:Factory/.xfce4-session.new/xfce4-session.changes 
2012-01-19 16:58:08.0 +0100
@@ -1,0 +2,6 @@
+Fri Jan 13 17:04:56 UTC 2012 - g...@opensuse.org
+
+- added xfce4-session-fix-libgmodule-underlinking.patch in order to
+  explicitly link against libgmodule
+
+---

New:

  xfce4-session-fix-libgmodule-underlinking.patch



Other differences:
--
++ xfce4-session.spec ++
--- /var/tmp/diff_new_pack.bCLLJN/_old  2012-01-19 16:58:09.0 +0100
+++ /var/tmp/diff_new_pack.bCLLJN/_new  2012-01-19 16:58:09.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package xfce4-session
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -30,12 +30,15 @@
 Patch1: xfce4-session-fix-gnome-mode.patch
 # PATCH-FEATURE-UPSTREAM xfce4-session-lock-screen-on-suspend-hibernate.patch 
bxo#6019 g...@opensuse.org -- Try to lock the screen when hibernating/suspending
 Patch2: xfce4-session-lock-screen-on-suspend-hibernate.patch
+# PATCH-FEATURE-UPSTREAM xfce4-session-fix-libgmodule-underlinking.patch 
bxo#8340 g...@opensuse.org -- Link explicitly against libgmodule
+Patch3: xfce4-session-fix-libgmodule-underlinking.patch
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  docbook_4
 BuildRequires:  intltool
 BuildRequires:  libxslt
 BuildRequires:  perl-XML-Parser
 BuildRequires:  update-desktop-files
+BuildRequires:  xfce4-dev-tools
 BuildRequires:  xml2po
 BuildRequires:  xorg-x11
 BuildRequires:  pkgconfig(dbus-glib-1)
@@ -91,8 +94,10 @@
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
+xdt-autogen
 %configure \
 --docdir=%{_datadir}/xfce4/xfce4-session \
 --disable-static \

++ xfce4-session-fix-libgmodule-underlinking.patch ++
Index: xfce4-session-4.8.2/configure.in
===
--- xfce4-session-4.8.2.orig/configure.in
+++ xfce4-session-4.8.2/configure.in
@@ -82,6 +82,7 @@ XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.
 XDT_CHECK_PACKAGE([LIBWNCK], [libwnck-1.0], [2.22])
 XDT_CHECK_PACKAGE([DBUS], [dbus-1], [1.0.0])
 XDT_CHECK_PACKAGE([DBUS_GLIB], [dbus-glib-1], [0.73])
+XDT_CHECK_PACKAGE([GMODULE], [gmodule-2.0], [])
 XDT_CHECK_PACKAGE([XFCONF], [libxfconf-0], [4.8.0])
 
 dnl we provide a panel plugin now
Index: xfce4-session-4.8.2/settings/Makefile.am
===
--- xfce4-session-4.8.2.orig/settings/Makefile.am
+++ xfce4-session-4.8.2/settings/Makefile.am
@@ -25,6 +25,7 @@ xfce4_session_settings_CFLAGS = \
-DMODULESDIR=\$(libdir)/xfce4/session/splash-engines\ \
-DG_LOG_DOMAIN=\xfce4-session-settings\ \
-I$(top_srcdir) \
+   $(GMODULE_CFLAGS) \
$(LIBXFCE4UTIL_CFLAGS) \
$(LIBXFCE4UI_CFLAGS) \
$(XFCONF_CFLAGS) \
@@ -32,7 +33,8 @@ xfce4_session_settings_CFLAGS = \
 
 xfce4_session_settings_LDADD = \
$(top_builddir)/libxfsm/libxfsm-4.6.la \
-   $(LIBXFCE4UTIL_CFLAGS) \
+   $(GMODULE_LIBS) \
+   $(LIBXFCE4UTIL_LIBS) \
$(LIBXFCE4UI_LIBS) \
$(XFCONF_LIBS) \
$(DBUS_GLIB_LIBS)
Index: xfce4-session-4.8.2/xfce4-session/Makefile.am
===
--- xfce4-session-4.8.2.orig/xfce4-session/Makefile.am
+++ xfce4-session-4.8.2/xfce4-session/Makefile.am
@@ -51,6 +51,7 @@ xfce4_session_SOURCES =   
\
xfsm-startup.h
 
 xfce4_session_CFLAGS = \
+   $(GMODULE_CFLAGS)   \
$(GNOME_CFLAGS) \
$(GNOME_KEYRING_CFLAGS) \
$(LIBSM_CFLAGS) \
@@ -69,6 +70,7 @@ xfce4_session_CFLAGS =
\
 
 xfce4_session_LDADD =  \

commit ristretto for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package ristretto for openSUSE:Factory 
checked in at 2012-01-19 16:57:06

Comparing /work/SRC/openSUSE:Factory/ristretto (Old)
 and  /work/SRC/openSUSE:Factory/.ristretto.new (New)


Package is ristretto, Maintainer is xfce-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/ristretto/ristretto.changes  2011-11-14 
13:43:03.0 +0100
+++ /work/SRC/openSUSE:Factory/.ristretto.new/ristretto.changes 2012-01-19 
16:58:01.0 +0100
@@ -1,0 +2,44 @@
+Sat Jan 14 17:47:26 UTC 2012 - g...@opensuse.org
+
+- update to version 0.3.2
+  - apply saturation and brightness settings in the set-wallpaper
+preview widget
+  - disable the sensitivity of the 'back' and 'forward' buttons
+when showing the first or last image in a list
+  - improve preview of the set-wallpaper dialog
+  - save the sorting algoritm
+  - allow a directory to be passed in as a command-line argument
+  - add back documentation
+- removed obsolete ristretto-0.3.0-docs.tar.bz2 and
+  ristretto-use-offline-documentation.patch
+
+---
+Wed Jan 11 09:03:13 UTC 2012 - g...@opensuse.org
+
+- ristretto 0.3.1 requires GTK+ = 2.24
+
+---
+Tue Jan 10 18:01:33 UTC 2012 - g...@opensuse.org
+
+- update to version 0.3.1
+  - do not open the copy of an image when saving
+  - apply saturation and brightness settings in the set-wallpaper
+preview widget
+  - add 'has-next' and 'has-previous' functions to disable the
+sensitivity of the 'back' and 'forward' buttons when showing
+the first or last image in a list
+  - improve preview of the set-wallpaper dialog
+  - make sure file-types unsupported by gdkpixbufloader are not
+accidently included in the image-list
+  - save the sorting algoritm
+  - limit rendering of selection-box to the inside of the image
+  - allow a directory to be passed in as a command-line argument
+  - bugfixes
+  - translation updates
+- added ristretto-0.3.0-docs.tar.bz2 and
+  ristretto-use-offline-documentation.patch which add back the
+  documentation
+- removed obsolete
+  ristretto-0.3.0-fix-no-return-in-nonvoid-function.patch
+
+---

Old:

  ristretto-0.3.0-fix-no-return-in-nonvoid-function.patch
  ristretto-0.3.0.tar.bz2

New:

  ristretto-0.3.2.tar.bz2



Other differences:
--
++ ristretto.spec ++
--- /var/tmp/diff_new_pack.Y8Ze5e/_old  2012-01-19 16:58:02.0 +0100
+++ /var/tmp/diff_new_pack.Y8Ze5e/_new  2012-01-19 16:58:02.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package ristretto
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,27 +15,25 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   ristretto
-Version:0.3.0
-Release:1
-License:GPL-2.0+
+Version:0.3.2
+Release:0
 Summary:Fast and Lightweight Image-viewer for the Xfce desktop 
environment
-Url:http://goodies.xfce.org/projects/applications/ristretto
+License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
-Source: %{name}-%{version}.tar.bz2
+Url:http://goodies.xfce.org/projects/applications/ristretto
+Source0:%{name}-%{version}.tar.bz2
 # PATCH-FEATURE-OPENSUSE ristretto-0.0.91-add-more-mime-types.patch 
g...@opensuse.org -- Adds support for additional image MIME types supported by 
openSUSE
 Patch0: ristretto-0.0.91-add-more-mime-types.patch
-# PATCH-FIX-UPSTREAM ristretto-0.3.0-fix-no-return-in-nonvoid-function.patch 
bxo# g...@opensuse.org -- Fix non-void function with no return statement 
(backported from upstream git)
-Patch1: ristretto-0.3.0-fix-no-return-in-nonvoid-function.patch
+BuildRequires:  fdupes
 BuildRequires:  intltool
 BuildRequires:  pkg-config
-BuildRequires:  pkgconfig(gtk+-2.0)
-BuildRequires:  pkgconfig(libexif)
-BuildRequires:  pkgconfig(libxfce4ui-1)
 BuildRequires:  thunar-devel
 BuildRequires:  update-desktop-files
+BuildRequires:  xfce4-dev-tools
+BuildRequires:  pkgconfig(gtk+-2.0) = 2.24
+BuildRequires:  pkgconfig(libexif)
+BuildRequires:  pkgconfig(libxfce4ui-1)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -44,15 +42,16 @@
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
+xdt-autogen
 %configure --docdir=%{_datadir}/xfce4/ristretto
 make 

commit python-flickrapi for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package python-flickrapi for 
openSUSE:Factory checked in at 2012-01-19 16:56:45

Comparing /work/SRC/openSUSE:Factory/python-flickrapi (Old)
 and  /work/SRC/openSUSE:Factory/.python-flickrapi.new (New)


Package is python-flickrapi, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-flickrapi/python-flickrapi.changes
2011-09-26 10:14:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-flickrapi.new/python-flickrapi.changes   
2012-01-19 16:57:55.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:31:09 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ python-flickrapi.spec ++
--- /var/tmp/diff_new_pack.W9mzwL/_old  2012-01-19 16:57:56.0 +0100
+++ /var/tmp/diff_new_pack.W9mzwL/_new  2012-01-19 16:57:56.0 +0100
@@ -21,7 +21,7 @@
 Release:0
 Url:http://stuvel.eu/projects/flickrapi
 Summary:Python interface to Flickr
-License:Python 2.5 license
+License:Python-2.0
 Group:  Development/Libraries/Python
 Source: flickrapi-%{version}.zip
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-gnupg for openSUSE:Factory

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package python-gnupg for openSUSE:Factory 
checked in at 2012-01-19 16:56:48

Comparing /work/SRC/openSUSE:Factory/python-gnupg (Old)
 and  /work/SRC/openSUSE:Factory/.python-gnupg.new (New)


Package is python-gnupg, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-gnupg/python-gnupg.changes
2011-09-23 12:42:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-gnupg.new/python-gnupg.changes   
2012-01-19 16:57:56.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:31:10 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ python-gnupg.spec ++
--- /var/tmp/diff_new_pack.iSEchb/_old  2012-01-19 16:57:57.0 +0100
+++ /var/tmp/diff_new_pack.iSEchb/_new  2012-01-19 16:57:57.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-gnupg
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,7 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %{!?python_sitelib: %global python_sitelib %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
 %{!?python_sitearch: %global python_sitearch %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib(1))}
 
@@ -26,7 +25,7 @@
 Release:0
 Url:http://code.google.com/p/python-gnupg/
 Summary:A wrapper for the Gnu Privacy Guard (GPG or GnuPG)
-License:BSD
+License:BSD-3-Clause
 Group:  Development/Languages/Python
 Source: python-%{mod_name}-%{version}.tar.bz2
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit daps for openSUSE:12.1:Update:Test

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package daps for openSUSE:12.1:Update:Test 
checked in at 2012-01-19 18:05:01

Comparing /work/SRC/openSUSE:12.1:Update:Test/daps (Old)
 and  /work/SRC/openSUSE:12.1:Update:Test/.daps.new (New)


Package is daps, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ /work/SRC/openSUSE:12.1:Update:Test/.daps.new/daps.changes  2012-01-19 
18:05:02.0 +0100
@@ -0,0 +1,545 @@
+---
+Mon Jan  9 15:30:47 UTC 2012 - t...@suse.de
+
+- Really fixed bnc#739213,
+- Added COPYING-{2.0,3.0} files
+
+---
+Wed Dec 28 11:48:06 UTC 2011 - k...@suse.de
+
+- Remove fetch_source.
+
+---
+Wed Dec 28 08:39:57 UTC 2011 - k...@suse.de
+
+- BuildRequire exiftool that's now available as a subpackage on
+  Factory.
+
+---
+Thu Dec 15 14:07:13 UTC 2011 - fsunderme...@opensuse.org
+
+New version 0.9.2
+
+- BUGFIXES:
+  * fixed misspelled variablename in fo generating target
+  * remarks in HTML and PDF builds were only shown when comments
+were turned on, too. This had been fixed earlier but the fix
+seems to have been reverted by mistake. Re-enabled the fix in
+the inline.xslt stxlesheets for fo and html
+- -r/--remarls now implies draft mode
+- -m/--meta now implies draft mode but does not imply remarks
+  anymore
+
+---
+Thu Dec 15 10:39:31 UTC 2011 - k...@suse.de
+
+- Set license to GPL-2.0+.
+
+---
+Thu Dec 15 06:49:50 UTC 2011 - k...@suse.de
+
+- On 12.1, BuildRequire perl-Image-ExifTool.
+
+---
+Fri Dec  9 11:53:10 UTC 2011 - fsunderme...@opensuse.org
+
+- BUGFIX: Misspelled variable name in fo generation for FOP
+- Styleshhet changes:
+  * added first draft of release notes stylesheets 
+
+---
+Wed Dec  7 13:54:43 UTC 2011 - fsunderme...@opensuse.org
+
+- Stylesheet changes:
+  Fixed bugs:
+  * bnc#573835: pdf-color: title in PDF properties too general
+  * bnc#703483: FOP: No Hyphenation?
+  * bnc#706452: FOP: Too much Whitespace Behind ulink and filename
+  * bnc#711526: Layout: sect3 can not be distinguished from a sect4
+  * bnc#719848: daps stylesheets: Make metadata for PDF draft mode optional  
+
+- Program changes:
+  * New version 0.9.1
+  * NEW FEATURES:
+- daps -h subcommand now shows help for subcommand
+- New config option XSLTPARAM / cmdline switch --xsltparam:
+  can be used to overwrite one or more stylesheet
+  parameters. Using that option/switch it is possible to change
+  the pagesize, pageformat, alignment, margins, etc. etc.
+  without having to rewrite the stylesheets directly
+- subcommand getimages can now be run with a rootid or a filename
+- subcommands getimages and checklink can now be invoked without
+  a filename or a rootid - in this case the rootid provided by
+  the ENV-file is used
+- new general command line switch --version
+- new switch -m/--meta for pdf builds (adds same functionality as
+  for the html builds)
+  * completely rewrote lib/daps_functions:
+- now has a generic option parser
+- functions setup_builddir and format_options have been
+  combined into one function called init_env
+- one single function that invokes make: call_make
+- logging can be turned on/off within each function invoking
+  call_make by setting WRITE_LOG to 1/0 (default: 1 (on))
+- the make command is now set up here rather than in bin/daps
+- getimages now uses make to create the image list (rather than
+  using /usr/bin/xml)
+- new function no_opts for subcommands that have no command line
+  switches
+  * pretty printing has been moved from lib/daps_functions into the
+makefiles
+  * BUGFIXES:
+- We now do an early! check whether a subcommand is correct
+  or not function run_subcmds has therefore been replaced by an
+  associative hash; the hash's key/value pairs can be eval'd to
+  call the function
+- .fo files will always be regenerated by using PHONY targets
+  This also keeps the .fo file, which is desireable for debugging
+  purposes
+  
+---
+Fri Oct  7 12:28:15 UTC 2011 - fsunderme...@opensuse.org
+
+- Bugfixes on .document and .desktop file generation 
+
+---
+Fri Oct  7 

commit libvirt for openSUSE:12.1:Update:Test

2012-01-19 Thread h_root
Hello community,

here is the log from the commit of package libvirt for 
openSUSE:12.1:Update:Test checked in at 2012-01-19 18:05:43

Comparing /work/SRC/openSUSE:12.1:Update:Test/libvirt (Old)
 and  /work/SRC/openSUSE:12.1:Update:Test/.libvirt.new (New)


Package is libvirt, Maintainer is jfeh...@suse.com

Changes:

--- /work/SRC/openSUSE:12.1:Update:Test/libvirt/libvirt.changes 2012-01-19 
18:05:49.0 +0100
+++ /work/SRC/openSUSE:12.1:Update:Test/.libvirt.new/libvirt.changes
2012-01-19 18:05:49.0 +0100
@@ -1,0 +2,69 @@
+Wed Jan  4 10:04:04 MST 2012 - jfeh...@suse.com
+
+- Use %fdupes for duplicate file checking instead of hand-rolled
+  function
+
+---
+Tue Dec 20 15:46:29 MST 2011 - jfeh...@suse.com
+
+- Fix authorization workflow with PolicyKit.
+  polkit.patch
+  bnc#735403
+
+---
+Thu Dec 15 14:00:57 MST 2011 - jfeh...@suse.com
+
+- Fix qemu default migration speed.  It should not be 33554432Mb!
+  61f2b6ba-no-unlimited-mig2file-speed.patch
+  d8916dc8-def-qemu-migspeed.patch
+
+---
+Mon Dec 12 16:50:59 MST 2011 - jfeh...@suse.com
+
+- CVE-2011-4600: unintended firewall port exposure after restarting
+  libvirtd when defining a bridged forward-mode network
+  ae1232b2-CVE-2011-4600.patch
+  bnc#736082
+
+---
+Thu Dec  8 10:30:32 MST 2011 - jfeh...@suse.com
+
+- Fix default console type setting
+  209c2880-multiple-consoles-7.patch
+- Fix 'virsh console' with Xen HVM
+  xen-hvm-virsh-console.patch
+  bnc#731974
+
+---
+Wed Dec  7 11:47:15 MST 2011 - jfeh...@suse.com
+
+- Prevent libvirtd crash on 'virsh qemu-attach' when
+  security_driver is none in /etc/libvirt/qemu.conf
+  28423019-qemu-attach-crash.patch
+  bnc#735023
+
+---
+Wed Nov 30 09:53:25 MST 2011 - jfeh...@suse.com
+
+- Allow qemu driver (and hence libvirtd) to load when qemu
+  user:group does not exist.  The kvm or qemu package, which may
+  not exist on a xen host, creates qemu user:group.
+  relax-qemu-usergroup-check.patch
+  bnc#711096
+
+---
+Mon Nov 28 15:19:42 MST 2011 - jfeh...@suse.com
+- Accommodate Xen domctl version 8
+  xen-domctl-ver8.patch
+- Handle empty strings in s-expression returned by xend
+  a495365d-sexpr-empty-str.patch
+  bnc#731344
+- Allow libvirtd to access libvirt_{io,part}helper when confined
+  by apparmor
+  Update install-apparmor-profiles.patch
+  bnc#730435
+- Fixed to return success when there are no errors while parsing
+  bonding interface miimon xml node parameters.
+  bonding-miimon-xml-parsing.patch
+
+---

New:

  209c2880-multiple-consoles-7.patch
  28423019-qemu-attach-crash.patch
  49d8c8bc-xen-domctl-ver8.patch
  61f2b6ba-no-unlimited-mig2file-speed.patch
  9ae4ac7a-PolicyKit.patch
  a495365d-sexpr-empty-str.patch
  ae1232b2-CVE-2011-4600.patch
  beeea90a-xen-hvm-console.patch
  bonding-miimon-xml-parsing.patch
  d8916dc8-def-qemu-migspeed.patch
  relax-qemu-usergroup-check.patch



Other differences:
--
++ libvirt.spec ++
--- /var/tmp/diff_new_pack.I0nnCU/_old  2012-01-19 18:05:49.0 +0100
+++ /var/tmp/diff_new_pack.I0nnCU/_new  2012-01-19 18:05:49.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libvirt
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -378,15 +378,26 @@
 # the openSUSE kvm package is patched with qemu 'no-shutdown' fix
 Patch0: f84aedad-revert.patch
 Patch1: c1bc3d89-qemu-add-ahci.patch
+Patch2: a495365d-sexpr-empty-str.patch
+Patch3: 28423019-qemu-attach-crash.patch
+Patch4: 209c2880-multiple-consoles-7.patch
+Patch5: ae1232b2-CVE-2011-4600.patch
+Patch6: 61f2b6ba-no-unlimited-mig2file-speed.patch
+Patch7: d8916dc8-def-qemu-migspeed.patch
+Patch8: 49d8c8bc-xen-domctl-ver8.patch
+Patch9: beeea90a-xen-hvm-console.patch
+Patch10:9ae4ac7a-PolicyKit.patch
 # Need to go upstream
 Patch100:   xen-name-for-devid.patch
 Patch101:   clone.patch
 Patch102:   xen-pv-cdrom.patch
 Patch103:   xend-disk-order.patch
+Patch104:   

  1   2   >