commit at-spi2-atk for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package at-spi2-atk for openSUSE:Factory 
checked in at 2012-01-25 10:34:45

Comparing /work/SRC/openSUSE:Factory/at-spi2-atk (Old)
 and  /work/SRC/openSUSE:Factory/.at-spi2-atk.new (New)


Package is at-spi2-atk, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/at-spi2-atk/at-spi2-atk.changes  2012-01-09 
11:14:55.0 +0100
+++ /work/SRC/openSUSE:Factory/.at-spi2-atk.new/at-spi2-atk.changes 
2012-01-25 10:34:50.0 +0100
@@ -1,0 +2,7 @@
+Mon Jan 16 13:24:29 UTC 2012 - vu...@opensuse.org
+
+- Update to version 2.3.4:
+  + bgo#666870: Keystroke listeners do not work unless an event
+listener is also registered [also needs updated at-spi2-core]
+
+---

Old:

  at-spi2-atk-2.3.3.tar.xz

New:

  at-spi2-atk-2.3.4.tar.xz



Other differences:
--
++ at-spi2-atk.spec ++
--- /var/tmp/diff_new_pack.uIeHFS/_old  2012-01-25 10:34:51.0 +0100
+++ /var/tmp/diff_new_pack.uIeHFS/_new  2012-01-25 10:34:51.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package at-spi2-atk
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,8 +15,9 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   at-spi2-atk
-Version:2.3.3
+Version:2.3.4
 Release:0
 Summary:Assistive Technology Service Provider Interface - GTK+ module
 License:GPL-2.0+
@@ -41,6 +42,7 @@
 %package common
 
 Summary:Assistive Technology Service Provider Interface -- Common 
Files for GTK+ Modules
+Group:  System/Libraries
 # The GTK+ module is useful only if the at-spi registry is running. But it's
 # not a strict runtime dependency.
 Recommends: at-spi2-core
@@ -60,6 +62,7 @@
 %package gtk2
 
 Summary:Assistive Technology Service Provider Interface - GTK+ 2 Module
+Group:  System/Libraries
 Requires:   %{name}-common = %{version}
 # We want to have this package installed if the user has gtk2 and the at-spi
 # stack already installed
@@ -74,6 +77,7 @@
 %package gtk3
 
 Summary:Assistive Technology Service Provider Interface - GTK+ 3 Module
+Group:  System/Libraries
 Requires:   %{name}-common = %{version}
 # We want to have this package installed if the user has gtk3 and the at-spi
 # stack already installed

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit at-spi2-core for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package at-spi2-core for openSUSE:Factory 
checked in at 2012-01-25 10:34:50

Comparing /work/SRC/openSUSE:Factory/at-spi2-core (Old)
 and  /work/SRC/openSUSE:Factory/.at-spi2-core.new (New)


Package is at-spi2-core, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/at-spi2-core/at-spi2-core.changes
2012-01-05 19:09:59.0 +0100
+++ /work/SRC/openSUSE:Factory/.at-spi2-core.new/at-spi2-core.changes   
2012-01-25 10:34:51.0 +0100
@@ -1,0 +2,13 @@
+Mon Jan 16 13:24:16 UTC 2012 - vu...@opensuse.org
+
+- Update to version 2.3.4:
+  + Add some dbus message signature checks.
+  + Fix a crash if a device listener incorrectly returns a
+non-bool.
+  + bgo#666870: Keystroke listeners do not work unless an event
+listener is also registered [also needs updated at-spi2-atk]
+  + bgo#667254: Some atspi-selection_* functions were broken.
+  + When a call times out, ping the connection and avoid making
+subsequent calls until the ping is answered.
+
+---

Old:

  at-spi2-core-2.3.3.tar.xz

New:

  at-spi2-core-2.3.4.tar.xz



Other differences:
--
++ at-spi2-core.spec ++
--- /var/tmp/diff_new_pack.2qBt2F/_old  2012-01-25 10:34:53.0 +0100
+++ /var/tmp/diff_new_pack.2qBt2F/_new  2012-01-25 10:34:53.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package at-spi2-core
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,8 +15,9 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   at-spi2-core
-Version:2.3.3
+Version:2.3.4
 Release:0
 Summary:Assistive Technology Service Provider Interface - D-Bus based 
implementation
 License:GPL-2.0+

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit balsa for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package balsa for openSUSE:Factory checked 
in at 2012-01-25 10:34:55

Comparing /work/SRC/openSUSE:Factory/balsa (Old)
 and  /work/SRC/openSUSE:Factory/.balsa.new (New)


Package is balsa, Maintainer is sbra...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/balsa/balsa.changes  2012-01-05 
19:10:06.0 +0100
+++ /work/SRC/openSUSE:Factory/.balsa.new/balsa.changes 2012-01-25 
10:34:56.0 +0100
@@ -1,0 +2,9 @@
+Thu Jan 12 08:49:00 UTC 2012 - dims...@opensuse.org
+
+- Build openSUSE  12.1 against gmime 2.6: Conditionally change
+  pkgconfig(gmime-2.4) BuildRequires to pkgconfig(gmime-2.6).
+- Add balsa-gmime-2_6.patch: Allow building against gmime 2.6.
+- Add libtool BuildRequires and call to bootstrap.sh as the patch
+  above touches the build system.
+
+---

New:

  balsa-gmime-2_6.patch



Other differences:
--
++ balsa.spec ++
--- /var/tmp/diff_new_pack.LtFdPs/_old  2012-01-25 10:34:57.0 +0100
+++ /var/tmp/diff_new_pack.LtFdPs/_new  2012-01-25 10:34:57.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package balsa
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,17 +16,18 @@
 #
 
 
-
 Name:   balsa
 %define TOUCHSCREEN_OPTIMIZATION %(echo %{name} | grep -qv touchscreen ; echo 
$?)
 %define base_name balsa
 Version:2.4.11
-Release:1
-License:GPLv2+
+Release:0
 Summary:The GNOME Mail Program
-Url:http://pawsa.fedorapeople.org/balsa/
+License:GPL-2.0+
 Group:  Productivity/Networking/Email/Clients
+Url:http://pawsa.fedorapeople.org/balsa/
 Source: http://pawsa.fedorapeople.org/balsa/%{name}-%{version}.tar.bz2
+# PATCH-FIX-UPSTREAM balsa-gmime-2_6.patch dims...@opensuse.org -- Fix build 
with gmime 2.6, Upstream commit 393d007.
+Patch0: balsa-gmime-2_6.patch
 BuildRequires:  compface
 BuildRequires:  fdupes
 BuildRequires:  gnome-doc-utils-devel
@@ -34,6 +35,8 @@
 BuildRequires:  intltool
 BuildRequires:  krb5-devel
 BuildRequires:  libesmtp-devel
+# Needed by patch0
+BuildRequires:  libtool
 BuildRequires:  openldap2-devel
 BuildRequires:  openssl-devel
 BuildRequires:  translation-update-upstream
@@ -41,7 +44,11 @@
 BuildRequires:  pkgconfig(enchant)
 BuildRequires:  pkgconfig(gconf-2.0)
 BuildRequires:  pkgconfig(glib-2.0)
+%if 0%{?suse_version}  1210
+BuildRequires:  pkgconfig(gmime-2.6)
+%else
 BuildRequires:  pkgconfig(gmime-2.4)
+%endif
 BuildRequires:  pkgconfig(gnome-icon-theme)
 BuildRequires:  pkgconfig(gnome-keyring-1)
 BuildRequires:  pkgconfig(gtk+-2.0)
@@ -78,9 +85,12 @@
 
 %prep
 %setup -q -n %{base_name}-%{version}
+%patch0 -p1
 translation-update-upstream
 
 %build
+# Needed by patch0
+./bootstrap.sh
 %configure\
 %if %TOUCHSCREEN_OPTIMIZATION
--enable-touch-ui\

++ balsa-gmime-2_6.patch ++
 1373 lines (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit eog for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package eog for openSUSE:Factory checked in 
at 2012-01-25 10:35:03

Comparing /work/SRC/openSUSE:Factory/eog (Old)
 and  /work/SRC/openSUSE:Factory/.eog.new (New)


Package is eog, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/eog/eog.changes  2012-01-09 12:03:22.0 
+0100
+++ /work/SRC/openSUSE:Factory/.eog.new/eog.changes 2012-01-25 
10:35:04.0 +0100
@@ -1,0 +2,9 @@
+Tue Jan 17 07:59:38 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Use scrollwheel to change scale in image preview (bgo#495716)
+  + Support for symlinks when dragging image to folder (bgo#667076)
+  + Build failure upgrading from 3.3.2 to 3.3.3 (bgo#666556)
+  + Updated translations.
+
+---

Old:

  eog-3.3.3.tar.xz

New:

  eog-3.3.4.tar.xz



Other differences:
--
++ eog.spec ++
--- /var/tmp/diff_new_pack.lswm6Q/_old  2012-01-25 10:35:05.0 +0100
+++ /var/tmp/diff_new_pack.lswm6Q/_new  2012-01-25 10:35:05.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package eog
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,7 +16,7 @@
 #
 
 Name:   eog
-Version:3.3.3
+Version:3.3.4
 Release:0
 # FIXME: replace libexempi-devel BuildRequires with pkgconfig(exempi-2.0) once 
fixed exempi is in
 Summary:Image Viewer for GNOME
@@ -58,6 +58,7 @@
 
 %package devel
 Summary:Image Viewer for GNOME
+Group:  Productivity/Graphics/Viewers
 Requires:   %{name} = %{version}
 
 %description devel
@@ -100,7 +101,7 @@
 %dir %{_datadir}/gnome/help/
 %dir %{_datadir}/gnome/help/%{name}/
 %doc %{_datadir}/gnome/help/%{name}/C/
-%{_bindir}/*
+%{_bindir}/eog
 %{_libdir}/eog/
 %{_datadir}/applications/eog.desktop
 %{_datadir}/eog/

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit evolution for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package evolution for openSUSE:Factory 
checked in at 2012-01-25 10:35:10

Comparing /work/SRC/openSUSE:Factory/evolution (Old)
 and  /work/SRC/openSUSE:Factory/.evolution.new (New)


Package is evolution, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/evolution/evolution.changes  2012-01-09 
12:03:38.0 +0100
+++ /work/SRC/openSUSE:Factory/.evolution.new/evolution.changes 2012-01-25 
10:35:12.0 +0100
@@ -1,0 +2,17 @@
+Mon Jan 16 17:52:14 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Various code changes.
+  + User documentation improvements
+  + Bugs fixed:
+- bgo#661087: Add ability to remove localized Re: prefixes in
+  subject
+- bgo#343499, bgo#353743, bgo#357175, bgo#612257, bgo#636214,
+  bgo#638810, bgo#641154, bgo#661885, bgo#664003, bgo#664370,
+  bgo#665036, bgo#666490, bgo#75, bgo#95, bgo#666706,
+  bgo#666832, bgo#667119, bgo#667185, bgo#667281, bgo#667346,
+  bgo#667384, bgo#667398, bgo#667528.
+  + Updated translations.
+- Drop evolution-libpst-0.6.54.patch: fixed upstream.
+
+---

Old:

  evolution-3.3.3.tar.xz
  evolution-libpst-0.6.54.patch

New:

  evolution-3.3.4.tar.xz



Other differences:
--
++ evolution.spec ++
--- /var/tmp/diff_new_pack.bvWIEF/_old  2012-01-25 10:35:14.0 +0100
+++ /var/tmp/diff_new_pack.bvWIEF/_new  2012-01-25 10:35:14.0 +0100
@@ -64,7 +64,7 @@
 BuildRequires:  pkgconfig(libgdata)
 BuildRequires:  pkgconfig(libgtkhtml-4.0)
 BuildRequires:  pkgconfig(libnotify)
-BuildRequires:  pkgconfig(libpst)
+BuildRequires:  pkgconfig(libpst) = 0.6.54
 BuildRequires:  pkgconfig(libsoup-2.4)
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(nspr)
@@ -73,15 +73,13 @@
 BuildRequires:  pkgconfig(shared-mime-info)
 # This should be updated upon major version changes; it should match 
BASE_VERSION as defined in configure.in.
 %define evolution_base_version 3.4
-Version:3.3.3
+Version:3.3.4
 Release:0
 # FIXME: check with upstream/meego if we want to enable clutter for express 
mode
 Summary:The Integrated GNOME Mail, Calendar, and Address Book Suite
 License:LGPL-2.0 ; LGPL-3.0
 Group:  Productivity/Networking/Email/Clients
 Source0:
http://download.gnome.org/sources/evolution/3.3/%{name}-%{version}.tar.xz
-# PATCH-FIX-UPSTREAM evolution-libpst-0.6.54.patch bgo#667346 
vu...@opensuse.org -- Fix build with libpst 0.6.54
-Patch0: evolution-libpst-0.6.54.patch
 # PATCH-FIX-OPENSUSE evolution-custom-openldap-includes.patch m...@novell.com 
-- look for ldap includes in %{_libdir}/evoldap/include
 Patch15:evolution-custom-openldap-includes.patch
 # PATCH-FIX-UPSTREAM bnc-435722-book-uri-long.patch bnc#435722 
abhar...@suse.de -- Book URI: Spills Into Second Column.
@@ -171,7 +169,6 @@
 %prep
 %setup -q
 translation-update-upstream
-%patch0 -p1
 %if %USE_EVOLDAP
 %patch15 -p1
 %endif

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit evolution-data-server for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package evolution-data-server for 
openSUSE:Factory checked in at 2012-01-25 10:35:45

Comparing /work/SRC/openSUSE:Factory/evolution-data-server (Old)
 and  /work/SRC/openSUSE:Factory/.evolution-data-server.new (New)


Package is evolution-data-server, Maintainer is gnome-maintain...@suse.de

Changes:

--- 
/work/SRC/openSUSE:Factory/evolution-data-server/evolution-data-server.changes  
2012-01-19 16:55:03.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.evolution-data-server.new/evolution-data-server.changes
 2012-01-25 10:35:46.0 +0100
@@ -1,0 +2,12 @@
+Mon Jan 16 17:51:52 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Various code changes.
+  + Bugs fixed: bgo#357175, bgo#482171, bgo#592906, bgo#638810,
+bgo#644817, bgo#661743, bgo#662888, bgo#665036, bgo#666327,
+bgo#666327, bgo#666757, bgo#666770, bgo#667388, bgo#667698.
+  + Updated translations.
+- Drop evolution-data-server-fix-introspection-build.patch: fixed
+  upstream.
+
+---

Old:

  evolution-data-server-3.3.3.tar.xz
  evolution-data-server-fix-introspection-build.patch

New:

  evolution-data-server-3.3.4.tar.xz



Other differences:
--
++ evolution-data-server.spec ++
--- /var/tmp/diff_new_pack.SuIGwh/_old  2012-01-25 10:35:47.0 +0100
+++ /var/tmp/diff_new_pack.SuIGwh/_new  2012-01-25 10:35:47.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package evolution-data-server
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -32,7 +32,7 @@
 
 Name:   evolution-data-server
 %define _evo_version 3.4
-Version:3.3.3
+Version:3.3.4
 Release:0
 Summary:Evolution Data Server
 License:LGPL-2.1+
@@ -40,8 +40,6 @@
 Url:http://www.gnome.org
 Source0:
http://download.gnome.org/sources/evolution-data-server/3.3/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
-# PATCH-FIX-UPSTREAM evolution-data-server-fix-introspection-build.patch 
bgo#662888 vu...@opensuse.org -- Fix build of introspection data
-Patch0: evolution-data-server-fix-introspection-build.patch
 BuildRequires:  bison
 BuildRequires:  db-devel
 %if %USE_EVOLDAP
@@ -256,7 +254,6 @@
 %prep
 %setup -q
 translation-update-upstream
-%patch0 -p1
 
 %build
 %{configure} \

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit evolution-ews for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package evolution-ews for openSUSE:Factory 
checked in at 2012-01-25 10:36:07

Comparing /work/SRC/openSUSE:Factory/evolution-ews (Old)
 and  /work/SRC/openSUSE:Factory/.evolution-ews.new (New)


Package is evolution-ews, Maintainer is pchenth...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/evolution-ews/evolution-ews.changes  
2012-01-09 12:03:41.0 +0100
+++ /work/SRC/openSUSE:Factory/.evolution-ews.new/evolution-ews.changes 
2012-01-25 10:36:09.0 +0100
@@ -1,0 +2,10 @@
+Mon Jan 16 18:04:36 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Bugs fixed:
+- bgo#665104: Possible memory leaks
+- bgo#665533: OAB caching not working
+- bgo#667185: Menu items from plugins not translated
+  + Updated translations.
+
+---

Old:

  evolution-ews-3.3.3.tar.xz

New:

  evolution-ews-3.3.4.tar.xz



Other differences:
--
++ evolution-ews.spec ++
--- /var/tmp/diff_new_pack.HJFEFR/_old  2012-01-25 10:36:10.0 +0100
+++ /var/tmp/diff_new_pack.HJFEFR/_new  2012-01-25 10:36:10.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package evolution-ews
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 Name:   evolution-ews
 # This should be updated upon major version changes; it should match 
BASE_VERSION as defined in configure.in.
 %define evolution_base_version 3.4
-Version:3.3.3
+Version:3.3.4
 Release:0
 Summary:Exchange Connector for Evolution, compatible with Exchange 
2007 and later
 License:LGPL-2.1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit evolution-exchange for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package evolution-exchange for 
openSUSE:Factory checked in at 2012-01-25 10:36:14

Comparing /work/SRC/openSUSE:Factory/evolution-exchange (Old)
 and  /work/SRC/openSUSE:Factory/.evolution-exchange.new (New)


Package is evolution-exchange, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/evolution-exchange/evolution-exchange.changes
2012-01-09 12:03:44.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.evolution-exchange.new/evolution-exchange.changes   
2012-01-25 10:36:15.0 +0100
@@ -1,0 +2,9 @@
+Mon Jan 16 18:04:47 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Bugs fixed:
+- bgo#667185: Menu items from plugins not translated
+  + Updated translations.
+- Drop evolution-exchange-fix-build.patch: fixed upstream.
+
+---

Old:

  evolution-exchange-3.3.3.tar.xz
  evolution-exchange-fix-build.patch

New:

  evolution-exchange-3.3.4.tar.xz



Other differences:
--
++ evolution-exchange.spec ++
--- /var/tmp/diff_new_pack.iaxYs7/_old  2012-01-25 10:36:17.0 +0100
+++ /var/tmp/diff_new_pack.iaxYs7/_new  2012-01-25 10:36:17.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package evolution-exchange
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define USE_EVOLDAP 0
 
 Name:   evolution-exchange
@@ -36,14 +37,12 @@
 BuildRequires:  translation-update-upstream
 # Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
 BuildRequires:  xz
-Version:3.3.3
+Version:3.3.4
 Release:0
 Summary:Evolution Connector for Microsoft Exchange Server 2000/2003
 License:GPL-2.0+
 Group:  Productivity/Networking/Email/Utilities
 Source: 
http://download.gnome.org/sources/evolution-exchange/3.3/%{name}-%{version}.tar.xz
-# PATCH-FIX-UPSTREAM evolution-exchange-fix-build.patch vu...@opensuse.org -- 
Fix build, taken from git
-Patch0: evolution-exchange-fix-build.patch
 Url:http://www.novell.com/products/connector
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 DocDir: %{_defaultdocdir}/evolution-exchange
@@ -65,7 +64,6 @@
 %prep
 %setup -q
 translation-update-upstream
-%patch0 -p1
 
 %build
 %{configure} \

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit evolution-groupwise for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package evolution-groupwise for 
openSUSE:Factory checked in at 2012-01-25 10:36:23

Comparing /work/SRC/openSUSE:Factory/evolution-groupwise (Old)
 and  /work/SRC/openSUSE:Factory/.evolution-groupwise.new (New)


Package is evolution-groupwise, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/evolution-groupwise/evolution-groupwise.changes  
2012-01-09 12:03:47.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.evolution-groupwise.new/evolution-groupwise.changes 
2012-01-25 10:36:27.0 +0100
@@ -1,0 +2,9 @@
+Mon Jan 16 18:04:41 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Bugs fixed:
+- bgo#627334: Blank junk setting window
+- bgo#665036: Memory leak with allocated string value
+- bgo#667185: Menu items from plugins not translated
+
+---

Old:

  evolution-groupwise-3.3.3.tar.xz

New:

  evolution-groupwise-3.3.4.tar.xz



Other differences:
--
++ evolution-groupwise.spec ++
--- /var/tmp/diff_new_pack.a3YQvM/_old  2012-01-25 10:36:28.0 +0100
+++ /var/tmp/diff_new_pack.a3YQvM/_new  2012-01-25 10:36:28.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package evolution-groupwise
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,12 +15,13 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define libegroupwise 13
 
 Name:   evolution-groupwise
 # This should be updated upon major version changes; it should match 
BASE_VERSION as defined in configure.in.
 %define evolution_base_version 3.4
-Version:3.3.3
+Version:3.3.4
 Release:0
 Summary:GroupWise Connector for Evolution
 License:LGPL-2.1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gcalctool for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gcalctool for openSUSE:Factory 
checked in at 2012-01-25 10:36:28

Comparing /work/SRC/openSUSE:Factory/gcalctool (Old)
 and  /work/SRC/openSUSE:Factory/.gcalctool.new (New)


Package is gcalctool, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gcalctool/gcalctool.changes  2011-10-02 
10:02:06.0 +0200
+++ /work/SRC/openSUSE:Factory/.gcalctool.new/gcalctool.changes 2012-01-25 
10:36:30.0 +0100
@@ -1,0 +2,12 @@
+Tue Jan 17 08:23:18 UTC 2012 - vu...@opensuse.org
+
+- Update to version 6.3.4:
+  + Fix a crash in gcalctool when ECB rate file can't be parsed
+  + Fix square centimeter conversions
+  + Fix incorrect spelling of Celsius
+  + Remove deprecated API usage
+- Add xz BuildRequires because we can't build a package for a
+  xz-compressed tarball without explicitly specifying that... See
+  bnc#697467 for more details.
+
+---

Old:

  gcalctool-6.2.0.tar.bz2

New:

  gcalctool-6.3.4.tar.xz



Other differences:
--
++ gcalctool.spec ++
--- /var/tmp/diff_new_pack.XV0sik/_old  2012-01-25 10:36:31.0 +0100
+++ /var/tmp/diff_new_pack.XV0sik/_new  2012-01-25 10:36:31.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gcalctool
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,16 +15,14 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   gcalctool
-Version:6.2.0
-Release:1
-License:GPL-2.0+
+Version:6.3.4
+Release:0
 Summary:A GNOME Calculator Application
-Url:http://www.gnome.org
+License:GPL-2.0+
 Group:  Productivity/Scientific/Math
-Source: 
http://download.gnome.org/sources/gcalctool/6.2/%{name}-%{version}.tar.bz2
+Url:http://www.gnome.org
+Source: 
http://download.gnome.org/sources/gcalctool/6.3/%{name}-%{version}.tar.xz
 BuildRequires:  bison
 BuildRequires:  fdupes
 BuildRequires:  flex
@@ -32,8 +30,10 @@
 BuildRequires:  intltool
 BuildRequires:  translation-update-upstream
 BuildRequires:  update-desktop-files
-BuildRequires:  pkgconfig(gio-2.0)
-BuildRequires:  pkgconfig(gtk+-3.0)
+# Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
+BuildRequires:  xz
+BuildRequires:  pkgconfig(gio-2.0) = 2.31
+BuildRequires:  pkgconfig(gtk+-3.0) = 3.0
 BuildRequires:  pkgconfig(libxml-2.0)
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gcr for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gcr for openSUSE:Factory checked in 
at 2012-01-25 10:36:39

Comparing /work/SRC/openSUSE:Factory/gcr (Old)
 and  /work/SRC/openSUSE:Factory/.gcr.new (New)


Package is gcr, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/gcr/gcr.changes  2012-01-09 11:15:08.0 
+0100
+++ /work/SRC/openSUSE:Factory/.gcr.new/gcr.changes 2012-01-25 
10:36:41.0 +0100
@@ -1,0 +2,11 @@
+Mon Jan 16 16:50:36 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Display an appropriate title in gcr-viewer
+  + Include GcrPrompt documentation
+  + Add 'new-prompt' signal to GcrSystemPrompter for use with
+javascript
+  + Fix build for glib 2.31 deprecations
+  + Build fixes
+
+---

Old:

  gcr-3.3.3.1.tar.xz

New:

  gcr-3.3.4.tar.xz



Other differences:
--
++ gcr.spec ++
--- /var/tmp/diff_new_pack.7g6K3e/_old  2012-01-25 10:36:42.0 +0100
+++ /var/tmp/diff_new_pack.7g6K3e/_new  2012-01-25 10:36:42.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gcr
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,9 +15,10 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   gcr
-Version:3.3.3.1
-Release:1
+Version:3.3.4
+Release:0
 # FIXME: Verify if parallel build works again. Last checked in version 3.3.2
 Summary:Library for Crypto UI related task
 License:LGPL-2.1+

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gdl for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gdl for openSUSE:Factory checked in 
at 2012-01-25 10:36:45

Comparing /work/SRC/openSUSE:Factory/gdl (Old)
 and  /work/SRC/openSUSE:Factory/.gdl.new (New)


Package is gdl, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gdl/gdl.changes  2012-01-09 12:04:10.0 
+0100
+++ /work/SRC/openSUSE:Factory/.gdl.new/gdl.changes 2012-01-25 
10:36:47.0 +0100
@@ -1,0 +2,9 @@
+Tue Jan 17 07:33:05 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Include some inkscape patches.
+- Add xz BuildRequires because we can't build a package for a
+  xz-compressed tarball without explicitly specifying that... See
+  bnc#697467 for more details.
+
+---

Old:

  gdl-3.3.1.tar.bz2

New:

  gdl-3.3.4.tar.xz



Other differences:
--
++ gdl.spec ++
--- /var/tmp/diff_new_pack.fEDOTf/_old  2012-01-25 10:36:51.0 +0100
+++ /var/tmp/diff_new_pack.fEDOTf/_new  2012-01-25 10:36:51.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gdl
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,20 +15,23 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   gdl
-Version:3.3.1
+Version:3.3.4
 Release:0
 Summary:Gnome Devtool Libraries
 License:LGPL-2.1+
 Group:  System/Libraries
 Url:http://ftp.gnome.org/pub/GNOME/sources/gdl/0.7/
-Source: 
http://download.gnome.org/sources/gdl/3.3/%{name}-%{version}.tar.bz2
+Source: 
http://download.gnome.org/sources/gdl/3.3/%{name}-%{version}.tar.xz
 BuildRequires:  fdupes
 BuildRequires:  gobject-introspection-devel
 BuildRequires:  gtk3-devel
 BuildRequires:  intltool
 BuildRequires:  libxml2-devel
 BuildRequires:  translation-update-upstream
+# Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
+BuildRequires:  xz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gnome-keyring for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gnome-keyring for openSUSE:Factory 
checked in at 2012-01-25 10:36:50

Comparing /work/SRC/openSUSE:Factory/gnome-keyring (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-keyring.new (New)


Package is gnome-keyring, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gnome-keyring/gnome-keyring.changes  
2012-01-09 15:16:33.0 +0100
+++ /work/SRC/openSUSE:Factory/.gnome-keyring.new/gnome-keyring.changes 
2012-01-25 10:36:51.0 +0100
@@ -1,0 +2,7 @@
+Mon Jan 16 16:52:29 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Build fixes
+  + Updated translations.
+
+---

Old:

  gnome-keyring-3.3.3.1.tar.xz

New:

  gnome-keyring-3.3.4.tar.xz



Other differences:
--
++ gnome-keyring.spec ++
--- /var/tmp/diff_new_pack.ube38q/_old  2012-01-25 10:36:53.0 +0100
+++ /var/tmp/diff_new_pack.ube38q/_new  2012-01-25 10:36:53.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gnome-keyring
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,9 +15,8 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 Name:   gnome-keyring
-Version:3.3.3.1
+Version:3.3.4
 Release:0
 Url:http://www.gnome.org/
 Summary:GNOME Keyring
@@ -42,7 +41,7 @@
 # Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
 BuildRequires:  xz
 BuildRequires:  pkgconfig(dbus-1)
-BuildRequires:  pkgconfig(gck-1) = 3.3.3
+BuildRequires:  pkgconfig(gck-1) = 3.3.4
 BuildRequires:  pkgconfig(gcr-3) = 3.3.3
 BuildRequires:  pkgconfig(glib-2.0) = 2.28.0
 BuildRequires:  pkgconfig(gtk+-3.0)
@@ -74,6 +73,7 @@
 
 %package -n libgck-modules-gnome-keyring
 Summary:Glib wrapper library for PKCS#11 - Modules
+Group:  System/GUI/GNOME
 # libgck-X-Y has a Provides for gck, just to help us with this Requires
 Requires:   gck
 # libgp11 used to be the library providing all this. It turns out the
@@ -92,6 +92,7 @@
 
 %package pam
 Summary:GNOME Keyring - PAM module
+Group:  System/GUI/GNOME
 Requires:   %{name} = %{version}
 PreReq: pam-config = 0.72
 PreReq: sed

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gnome-system-monitor for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gnome-system-monitor for 
openSUSE:Factory checked in at 2012-01-25 10:36:54

Comparing /work/SRC/openSUSE:Factory/gnome-system-monitor (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-system-monitor.new (New)


Package is gnome-system-monitor, Maintainer is gnome-maintain...@suse.de

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-system-monitor/gnome-system-monitor.changes
2012-01-09 12:40:34.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.gnome-system-monitor.new/gnome-system-monitor.changes
   2012-01-25 10:36:57.0 +0100
@@ -1,0 +2,13 @@
+Tue Jan 17 08:13:37 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Added Process Properties dialog (bgo#543347).
+  + CPU usage line colors can be set for more than the first 4 CPUs
+(bgo#632188).
+  + Optional support for systemd (unit, session, seat, owner) in
+process view
+  + Improved sorting (bgo#507108, bgo#557122).
+  + Fix crash (bgo#662463).
+  + Updated translations.
+
+---

Old:

  gnome-system-monitor-3.3.3.tar.xz

New:

  gnome-system-monitor-3.3.4.tar.xz



Other differences:
--
++ gnome-system-monitor.spec ++
--- /var/tmp/diff_new_pack.d3B6EI/_old  2012-01-25 10:36:59.0 +0100
+++ /var/tmp/diff_new_pack.d3B6EI/_new  2012-01-25 10:36:59.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gnome-system-monitor
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -33,7 +33,7 @@
 BuildRequires:  pkgconfig(gmodule-2.0)
 BuildRequires:  pkgconfig(gtkmm-3.0)
 BuildRequires:  pkgconfig(libwnck-3.0)
-Version:3.3.3
+Version:3.3.4
 Release:0
 Source0:
http://download.gnome.org/sources/gnome-system-monitor/3.3/%{name}-%{version}.tar.xz
 Url:http://www.gnome.org

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit goffice for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package goffice for openSUSE:Factory checked 
in at 2012-01-25 10:36:59

Comparing /work/SRC/openSUSE:Factory/goffice (Old)
 and  /work/SRC/openSUSE:Factory/.goffice.new (New)


Package is goffice, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/goffice/goffice.changes  2011-09-23 
02:01:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.goffice.new/goffice.changes 2012-01-25 
10:37:01.0 +0100
@@ -1,0 +2,70 @@
+Mon Jan 23 15:29:33 UTC 2012 - cfarr...@suse.com
+
+- license update: GPL-2.0
+  The canonical license of the spec file should be GPL-2.0
+
+---
+Thu Jan 19 07:38:57 UTC 2012 - vu...@opensuse.org
+
+- Add explicit pkgconfig() BuildRequires: cairo, cairo-pdf,
+  cairo-ps, cairo-svg, gdk-pixbuf-2.0, glib-2.0, pango, pangocairo.
+  Those were all implicitly brought in before.
+- Add pkgconfig(libspectre) BuildRequires to enable EPS support.
+- Remove pcre-devel BuildRequires: it's not needed anymore.
+- Apply shared library packaging policy:
+  + Create a libgoffice-0_10-9 subpackage.
+  + Add a Provides for goffice to make lang subpackage
+installable.
+  + Note that it's fine to ship the data files in this subpackage
+as they all live in a versioned directory.
+  + Change goffice Requires in devel subpackage to
+libgoffice-0_10-9.
+- Manually create %{_libdir}/goffice/0.10/plugins directory in
+  %install, and own it: this is the directory for the external
+  plugins.
+
+---
+Mon Jan  9 14:20:08 UTC 2012 - dims...@opensuse.org
+
+- Update to version 0.9.1:
+  + High-precision accumulator improvements.
+- Changes from version 0.9.0:
+  + Port to gtk+-3.0
+  + Make GSettings the default configuration backend
+  + Remove GConf support
+  + Add support for SVG images
+  + Add some optional support for EPS images
+  + Add resource manager for embedded files
+  + Add a plugin directory for extern plugins, independent from
+micro version
+  + Make sheet widgets scalable
+  + Use pango attributes for formatting
+  + Accept rich text in chart labels
+  + Extend encoding specification from file-openers to plugin
+services
+  + Support SI prefixes and units in scientific format selector
+  + Recognize scientific formats with longer exponents
+  + Fix output of scientific number formats with EE to ODF
+  + Fix widgets position inside an RTL canvas
+  + Fix problem with sticky format colouring
+  + Bugs fixed: bgo#117215, bgo#417631, bgo#425685, bgo#513137,
+bgo#584380, bgo#588516, bgo#605434, bgo#623847, bgo#641901,
+bgo#647147, bgo#651561, bgo#654392, bgo#655573, bgo#656043,
+bgo#656056, bgo#656148, bgo#657187, bgo#657288, bgo#657379,
+bgo#657400, bgo#657670, bgo#657695, bgo#657696, bgo#658472,
+bgo#658527, bgo#660564, bgo#660917, bgo#661264, bgo#662393,
+bgo#662414, bgo#663078, bgo#663355, bgo#663717, bgo#664656.
+- Clean spec-file using spec-cleaner.
+- Replace gtk2-devel BuildRequires with pkgconfig(gtk+-3.0),
+  following upstreams change to GTK 3.
+- Drop gconf2-devel BuildRequires: with the move to GSettings this
+  is no longer needed.
+- Add pkgconfig(librsvg-2.0) BuildRequires: A newly introduced
+  dependency to support SVG images.
+- Remove explicit Requires from the -devel package: they are added
+  automatically the pkgconfig()-way.
+- Add xz BuildRequires because we can't build a package for a
+  xz-compressed tarball without explicitly specifying that... See
+  bnc#697467 for more details.
+
+---

Old:

  goffice-0.8.17.tar.bz2

New:

  goffice-0.9.1.tar.xz



Other differences:
--
++ goffice.spec ++
--- /var/tmp/diff_new_pack.Zb3X4O/_old  2012-01-25 10:37:02.0 +0100
+++ /var/tmp/diff_new_pack.Zb3X4O/_new  2012-01-25 10:37:02.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package goffice
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,24 +15,32 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   goffice
+Version:0.9.1
+Release:0
+Summary:GLib/GTK+ Set of Document-Centric Objects and Utilities
+License:GPL-2.0
+Group:  System/GUI/GNOME
+Url:http://www.gnumeric.org/
+Source: 

commit gtk2-metatheme-gilouche for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gtk2-metatheme-gilouche for 
openSUSE:Factory checked in at 2012-01-25 10:37:07

Comparing /work/SRC/openSUSE:Factory/gtk2-metatheme-gilouche (Old)
 and  /work/SRC/openSUSE:Factory/.gtk2-metatheme-gilouche.new (New)


Package is gtk2-metatheme-gilouche, Maintainer is gnome-maintain...@suse.de

Changes:

--- 
/work/SRC/openSUSE:Factory/gtk2-metatheme-gilouche/gtk2-metatheme-gilouche.changes
  2011-09-23 02:02:15.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.gtk2-metatheme-gilouche.new/gtk2-metatheme-gilouche.changes
 2012-01-25 10:37:08.0 +0100
@@ -1,0 +2,6 @@
+Fri Jan 13 12:33:09 UTC 2012 - vu...@opensuse.org
+
+- Change gtk2-engines Requires to gtk2-engine-clearlooks, now that
+  gtk2-engines has split packages (see bnc#706929).
+
+---



Other differences:
--
++ gtk2-metatheme-gilouche.spec ++
--- /var/tmp/diff_new_pack.ailHgi/_old  2012-01-25 10:37:09.0 +0100
+++ /var/tmp/diff_new_pack.ailHgi/_new  2012-01-25 10:37:09.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package gtk2-metatheme-gilouche (Version 11.1.2)
+# spec file for package gtk2-metatheme-gilouche
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,15 +15,12 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   gtk2-metatheme-gilouche
 Version:11.1.2
-Release:9
-Group:  System/GUI/GNOME
-License:GPL-2.0+
+Release:0
 Summary:openSUSE themes and metathemes for gtk2 and metacity
+License:GPL-2.0+
+Group:  System/GUI/GNOME
 Source: metatheme-gilouche-%{version}.tar.bz2
 Source1:metacity-theme-greygilouche.tar.bz2
 Source2:metatheme-synchronicity.tar.bz2
@@ -36,7 +33,7 @@
 BuildRequires:  intltool
 BuildArch:  noarch
 # Gilouche Synchronicity requires engine clearlooks
-Requires:   gtk2-engines
+Requires:   gtk2-engine-clearlooks
 # Gilouche requires engine pixmap
 Requires:   gtk2
 # Gilouche icon theme inherits from tango-icon-theme

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gtk2-metatheme-industrial for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gtk2-metatheme-industrial for 
openSUSE:Factory checked in at 2012-01-25 10:37:12

Comparing /work/SRC/openSUSE:Factory/gtk2-metatheme-industrial (Old)
 and  /work/SRC/openSUSE:Factory/.gtk2-metatheme-industrial.new (New)


Package is gtk2-metatheme-industrial, Maintainer is 
gnome-maintain...@suse.de

Changes:

--- 
/work/SRC/openSUSE:Factory/gtk2-metatheme-industrial/gtk2-metatheme-industrial.changes
  2012-01-09 15:17:26.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.gtk2-metatheme-industrial.new/gtk2-metatheme-industrial.changes
 2012-01-25 10:37:14.0 +0100
@@ -1,0 +2,10 @@
+Fri Jan 13 13:01:59 UTC 2012 - vu...@opensuse.org
+
+- Change gtk2-engines Requires to gtk2-engine-industrial and
+  gtk2-theme-industrial Requires, now that gtk2-engines has split
+  packages (see bnc#706929).
+- Add Supplements for gtk2-engine-industrial and
+  gtk2-theme-industrial since it makes sense to have the metatheme
+  installed in that case.
+
+---



Other differences:
--
++ gtk2-metatheme-industrial.spec ++
--- /var/tmp/diff_new_pack.Vaj9qw/_old  2012-01-25 10:37:15.0 +0100
+++ /var/tmp/diff_new_pack.Vaj9qw/_new  2012-01-25 10:37:15.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gtk2-metatheme-industrial
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,7 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 Name:   gtk2-metatheme-industrial
 %define _name metatheme-industrial
 BuildRequires:  automake
@@ -31,10 +30,13 @@
 Group:  System/GUI/GNOME
 BuildArch:  noarch
 Enhances:   gtk2 metacity
-# For Industrial engine:
-Requires:   gtk2-engines = 2.6.0
+# For Industrial engine and theme:
+Requires:   gtk2-engine-industrial
+Requires:   gtk2-theme-industrial
 # For Gilouche icon theme:
 Requires:   gtk2-metatheme-gilouche
+Supplements:gtk2-engine-industrial
+Supplements:gtk2-theme-industrial
 # for openSUSE = 10.3 SLE = 10
 Provides:   gnome-themes:%{_datadir}/themes/Industrial/index.theme
 # Industrial metatheme was a part of gnome-themes in openSUSE  11.0

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gtksourceview2 for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gtksourceview2 for openSUSE:Factory 
checked in at 2012-01-25 10:37:16

Comparing /work/SRC/openSUSE:Factory/gtksourceview2 (Old)
 and  /work/SRC/openSUSE:Factory/.gtksourceview2.new (New)


Package is gtksourceview2, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/gtksourceview2/gtksourceview2.changes
2011-09-23 02:02:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.gtksourceview2.new/gtksourceview2.changes   
2012-01-25 10:37:17.0 +0100
@@ -1,0 +2,5 @@
+Sat Jan 21 16:41:10 UTC 2012 - zai...@opensuse.org
+
+- Fixed error in sourceurl. 
+
+---



Other differences:
--
++ gtksourceview2.spec ++
--- /var/tmp/diff_new_pack.aQbq6v/_old  2012-01-25 10:37:18.0 +0100
+++ /var/tmp/diff_new_pack.aQbq6v/_new  2012-01-25 10:37:18.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gtksourceview2
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,17 +15,15 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   gtksourceview2
 %define _name   gtksourceview
 Version:2.10.5
-Release:1
-License:GPL-2.0+
+Release:0
 Summary:GTK+ Source Editing Widget
-Url:http://www.gnome.org/
+License:GPL-2.0+
 Group:  System/GUI/GNOME
-Source: 
ftp://ftp.gnome.org/pub/GNOME/sources/gtksourceview/1.8/%{_name}-%{version}.tar.bz2
+Url:http://www.gnome.org/
+Source: 
ftp://ftp.gnome.org/pub/GNOME/sources/gtksourceview/2.10/%{_name}-%{version}.tar.bz2
 BuildRequires:  fdupes
 BuildRequires:  gtk2-devel
 BuildRequires:  intltool
@@ -42,7 +40,6 @@
 features typical of a source editor.
 
 %package -n libgtksourceview-2_0-0
-License:GPL-2.0+
 Summary:GTK+ Source Editing Widget
 Group:  System/GUI/GNOME
 Recommends: %{name}-lang = %{version}
@@ -57,7 +54,6 @@
 features typical of a source editor.
 
 %package -n glade3-catalog-gtksourceview
-License:GPL-2.0+
 Summary:GTK+ Source Editing Widget -- Catalog for Glade
 Group:  Development/Tools/GUI Builders
 Requires:   libgtksourceview-2_0-0 = %{version}
@@ -75,7 +71,6 @@
 GtkSourceView widget in Glade.
 
 %package devel
-License:GPL-2.0+
 Summary:GTK+ Source Editing Widget
 Group:  System/GUI/GNOME
 Requires:   gtk2-devel

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gvfs for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gvfs for openSUSE:Factory checked in 
at 2012-01-25 10:37:19

Comparing /work/SRC/openSUSE:Factory/gvfs (Old)
 and  /work/SRC/openSUSE:Factory/.gvfs.new (New)


Package is gvfs, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gvfs/gvfs.changes2012-01-17 
16:09:08.0 +0100
+++ /work/SRC/openSUSE:Factory/.gvfs.new/gvfs.changes   2012-01-25 
10:37:24.0 +0100
@@ -1,0 +2,12 @@
+Wed Jan 18 17:43:27 UTC 2012 - vu...@opensuse.org
+
+- Update to version 1.11.2:
+  + daemon: Spawn fuse daemon in foreground for uClibc
+compatibility
+  + ftp: Make ftp.mount no longer conditionally built
+  + fuse: Remove the unused sys/vfs.h include
+  + gvfs-mime: List recommended applications
+  + build: Check for util.h to prevent implicit declaration
+  + Updated translations.
+
+---

Old:

  gvfs-1.11.1.tar.xz

New:

  gvfs-1.11.2.tar.xz



Other differences:
--
++ gvfs.spec ++
--- /var/tmp/diff_new_pack.MeiiEH/_old  2012-01-25 10:37:25.0 +0100
+++ /var/tmp/diff_new_pack.MeiiEH/_new  2012-01-25 10:37:25.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gvfs
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,10 +15,10 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   gvfs
-Version:1.11.1
+Version:1.11.2
 Release:0
-# FIXME: add libbluray BuildRequires once available (fate#312440)
 Summary:VFS functionality for GLib
 License:LGPL-2.0+
 Group:  Development/Libraries/C and C++

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kdebase3 for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package kdebase3 for openSUSE:Factory 
checked in at 2012-01-25 10:37:26

Comparing /work/SRC/openSUSE:Factory/kdebase3 (Old)
 and  /work/SRC/openSUSE:Factory/.kdebase3.new (New)


Package is kdebase3, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/kdebase3/kdebase3.changes2011-12-12 
17:01:59.0 +0100
+++ /work/SRC/openSUSE:Factory/.kdebase3.new/kdebase3.changes   2012-01-25 
10:37:27.0 +0100
@@ -1,0 +2,10 @@
+Mon Jan 23 14:19:07 UTC 2012 - an...@opensuse.org
+
+- build fileshareset with PIE option
+
+---
+Wed Jan 11 18:02:45 UTC 2012 - an...@opensuse.org
+
+- add small patch from Slackware
+
+---

New:

  kdebase-slackware-kicker.diff



Other differences:
--
++ kdebase3.spec ++
--- /var/tmp/diff_new_pack.EOwDs1/_old  2012-01-25 10:37:29.0 +0100
+++ /var/tmp/diff_new_pack.EOwDs1/_new  2012-01-25 10:37:29.0 +0100
@@ -252,6 +252,7 @@
 Patch266:   further-desktop-icons-adjustment.patch
 Patch267:   kdebase-pardus-fix-autosuspend.patch
 Patch268:   systemd-shutdown.patch
+Patch269:   kdebase-slackware-kicker.diff
 
 %description
 This package contains kdebase, one of the basic packages of the K
@@ -262,12 +263,6 @@
 This package is needed if you want to use the KDE Desktop. It is not
 needed if you only want to start some KDE applications.
 
-
-
-Authors:
-
-The KDE Team k...@kde.org
-
 %package -n misc-console-font
 License:GPL-2.0+
 Group:  System/GUI/KDE
@@ -303,11 +298,6 @@
 This package contains the wrkspace components of kdebase3 like
 kdesktop, kicker and kwin.
 
-
-Authors:
-
-The KDE Team k...@kde.org
-
 %package apps
 License:GPL-2.0+
 Summary:Major Applications KDE3 Desktop
@@ -319,11 +309,6 @@
 This package contains the major applications kdebase3 like
 Kate, Konqueror and KWrite.
 
-
-Authors:
-
-The KDE Team k...@kde.org
-
 %package devel
 License:GPL-2.0+
 Requires:   kdelibs3-devel kdebase3 = %version kdebase3-apps = %version 
kdebase3-runtime = %version kdebase3-workspace = %version
@@ -339,12 +324,6 @@
 This package is not needed if you do not want to compile high level KDE
 applications.
 
-
-
-Authors:
-
-The KDE Team k...@kde.org
-
 %package kdm
 License:GPL-2.0+
 # usesubdirs kdm
@@ -360,12 +339,6 @@
 %description kdm
 This package contains kdm, the login and session manager for KDE.
 
-
-
-Authors:
-
-The KDE Team k...@kde.org
-
 %package samba
 License:GPL-2.0+
 # usesubdirs kioslave/smb kcontrol/samba
@@ -376,12 +349,6 @@
 This package provides the smb:// protocol, to connect to and from
 Windows and Samba shares.
 
-
-
-Authors:
-
-The KDE Team k...@kde.org
-
 %package extra
 License:GPL-2.0+
 # usesubdirs kpersonalizer kcontrol/thememgr
@@ -396,12 +363,6 @@
 
 - khotkeys aRts support - for voice triggered shortcuts
 
-
-
-Authors:
-
-The KDE Team k...@kde.org
-
 %package nsplugin
 License:GPL-2.0+
 %ifarch x86_64 ppc64 s390x ia64
@@ -417,12 +378,6 @@
 have to enable JavaScript for this.
 
 
-
-Authors:
-
-The KDE Team k...@kde.org
-
-
 %package ksysguardd
 License:GPL-2.0+
 PreReq: %insserv_prereq %fillup_prereq aaa_base
@@ -436,13 +391,6 @@
 This package can be installed on servers without any other KDE packages
 to guard the system from remote computers.
 
-
-
-Authors:
-
-The KDE Team k...@kde.org
-
-
 %package session
 License:GPL-2.0+
 Summary:The KDE Session
@@ -454,12 +402,6 @@
 This package contains the startup scripts necessary to start a KDE
 session from kdm.
 
-
-
-Authors:
-
-The KDE Team k...@kde.org
-
 %if %suse_version  1140
 
 %package beagle
@@ -475,12 +417,6 @@
 This package contains kdebase plugins which provide additional search
 functionality via Beagle.
 
-
-
-Authors:
-
-The KDE Team k...@kde.org
-
 %endif
 
 %package -n fileshareset
@@ -495,12 +431,6 @@
 add or remove file shares.  It's also possible to list currently shared
 locations. /etc/security/fileshare.conf is the main configuration file.
 
-
-
-Authors:
-
-Uwe Gansert uwe.gansert at SuSE dot de
-
 %define sysconfdir /etc
 
 %prep
@@ -677,6 +607,7 @@
 %patch266 -p1
 %patch267 -p1
 %patch268 -p1
+%patch269 -p4
 
 rm -rf kappfinder
 rm pics/crystalsvg/cr??-*emacs.png
@@ -697,14 +628,10 @@
 %ifnarch s390
 PARANOIA=--with-cdparanoia
 %endif
-  LDAP=--with-ldap
-%if %suse_version  1010
-  MOTIF_INCLUDE=/usr/include
+LDAP=--with-ldap

commit kdelibs3 for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package kdelibs3 for openSUSE:Factory 
checked in at 2012-01-25 10:37:36

Comparing /work/SRC/openSUSE:Factory/kdelibs3 (Old)
 and  /work/SRC/openSUSE:Factory/.kdelibs3.new (New)


Package is kdelibs3, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/kdelibs3/kdelibs3.changes2012-01-11 
15:38:04.0 +0100
+++ /work/SRC/openSUSE:Factory/.kdelibs3.new/kdelibs3.changes   2012-01-25 
10:37:38.0 +0100
@@ -1,0 +2,5 @@
+Tue Jan 17 12:01:57 UTC 2012 - an...@opensuse.org
+
+- patch for webdav from KDE bugzilla
+
+---

New:

  kdelibs-tarent-fix-webdav-utf8.diff



Other differences:
--
++ kdelibs3.spec ++
--- /var/tmp/diff_new_pack.8qVDB3/_old  2012-01-25 10:37:40.0 +0100
+++ /var/tmp/diff_new_pack.8qVDB3/_new  2012-01-25 10:37:40.0 +0100
@@ -185,6 +185,8 @@
 Patch219:   kiconview-text-fix.patch
 Patch220:   kdelibs-fedora-3.5.x-CVE-2011-3365.patch
 
+Patch221:   kdelibs-tarent-fix-webdav-utf8.diff
+
 %description
 This package contains kdelibs, one of the basic packages of the K
 Desktop Environment. It contains the necessary libraries for the KDE
@@ -356,6 +358,7 @@
 %patch218 -p1
 %patch219 -p1
 %patch220 -p1
+%patch221 -p1
 
 tar xfvj %SOURCE12
 #


++ kdelibs-tarent-fix-webdav-utf8.diff ++
Description: fix UTF-8 encoding for WebDAV directories
Bug: http://bugs.kde.org/show_bug.cgi?id=127251
Author: Thorsten “mirabilos” Glaser t.gla...@tarent.de
Origin: KIO slave http.cpp from KDE 4

--- kdelibs-3.5.10/kioslave/http/http.cc~   2008-02-13 10:41:06.0 
+0100
+++ kdelibs-3.5.10/kioslave/http/http.cc2011-12-27 13:27:17.0 
+0100
@@ -45,6 +45,7 @@
 #include qregexp.h
 #include qdatetime.h
 #include qstringlist.h
+#include qurl.h
 
 #include kurl.h
 #include kidna.h
@@ -750,9 +751,14 @@ void HTTPProtocol::davStatList( const KU
   entry.clear();
 
   QString urlStr = href.text();
+#if 0
   int encoding = remoteEncoding()-encodingMib();
   if ((encoding == 106)  
(!KStringHandler::isUtf8(KURL::decode_string(urlStr, 4).latin1(
 encoding = 4; // Use latin1 if the file is not actually utf-8
+#else
+  QUrl::decode(urlStr);
+  int encoding = 106;
+#endif
 
   KURL thisURL ( urlStr, encoding );
 
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kvm for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package kvm for openSUSE:Factory checked in 
at 2012-01-25 10:37:41

Comparing /work/SRC/openSUSE:Factory/kvm (Old)
 and  /work/SRC/openSUSE:Factory/.kvm.new (New)


Package is kvm, Maintainer is brog...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/kvm/kvm.changes  2012-01-17 16:10:13.0 
+0100
+++ /work/SRC/openSUSE:Factory/.kvm.new/kvm.changes 2012-01-25 
10:37:43.0 +0100
@@ -1,0 +2,5 @@
+Mon Jan 23 19:15:54 UTC 2012 - brog...@suse.com
+
+- avoid buffer overflow in e1000 device emulation (bnc#740165)
+
+---

New:

  kvm-qemu-preXX-e1000-check-for-overflow-whenever-issuing-PCI-dma-reads.patch



Other differences:
--
++ kvm.spec ++
--- /var/tmp/diff_new_pack.E7dmRi/_old  2012-01-25 10:37:45.0 +0100
+++ /var/tmp/diff_new_pack.E7dmRi/_new  2012-01-25 10:37:45.0 +0100
@@ -136,6 +136,7 @@
 Patch104:   kvm-qemu-madvise-hugepages.patch
 Patch105:   kvm-qemu-preXX-dictzip3.patch
 Patch106:   
kvm-qemu-preXX-g_thread_init-users-don-t-call-it-if-glib-2.31.patch
+Patch107:   
kvm-qemu-preXX-e1000-check-for-overflow-whenever-issuing-PCI-dma-reads.patch
 
 Patch150:   qemu-kvm-common-code-fixes-for-s390-build.patch
 
@@ -230,6 +231,7 @@
 %patch104 -p1
 %patch105 -p1
 %patch106 -p1
+%patch107 -p1
 
 %patch150 -p1
 

++ 
kvm-qemu-preXX-e1000-check-for-overflow-whenever-issuing-PCI-dma-reads.patch 
++
From 7fff7710abc9893d8dce5dbad1e7093caf521132 Mon Sep 17 00:00:00 2001
From: Anthony Liguori aligu...@us.ibm.com
Date: Wed, 4 Jan 2012 14:50:45 -0600
Subject: e1000: check for overflow whenever issuing PCI dma reads

Reported-by: Nicolae Mogoreanu m...@google.com
Signed-off-by: Anthony Liguori aligu...@us.ibm.com
---
 hw/e1000.c |3 +++
 1 files changed, 3 insertions(+), 0 deletions(-)

Index: qemu-kvm-0.12.5/hw/e1000.c
===
--- qemu-kvm-0.12.5.orig/hw/e1000.c
+++ qemu-kvm-0.12.5/hw/e1000.c
@@ -466,6 +466,8 @@ process_tx_desc(E1000State *s, struct e1000_tx_desc *dp)
 bytes = split_size;
 if (tp-size + bytes  msh)
 bytes = msh - tp-size;
+
+bytes = MIN(sizeof(tp-data) - tp-size, bytes);
 pci_dma_read(s-dev, addr, tp-data + tp-size, bytes);
 if ((sz = tp-size + bytes) = hdr  tp-size  hdr)
 memmove(tp-header, tp-data, hdr);
@@ -481,6 +483,7 @@ process_tx_desc(E1000State *s, struct e1000_tx_desc *dp)
 // context descriptor TSE is not set, while data descriptor TSE is set
 DBGOUT(TXERR, TCP segmentaion Error\n);
 } else {
+split_size = MIN(sizeof(tp-data) - tp-size, split_size);
 pci_dma_read(s-dev, addr, tp-data + tp-size, split_size);
 tp-size += split_size;
 }


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libstatgrab for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package libstatgrab for openSUSE:Factory 
checked in at 2012-01-25 10:37:56

Comparing /work/SRC/openSUSE:Factory/libstatgrab (Old)
 and  /work/SRC/openSUSE:Factory/.libstatgrab.new (New)


Package is libstatgrab, Maintainer is r...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/libstatgrab/libstatgrab.changes  2011-10-18 
14:31:02.0 +0200
+++ /work/SRC/openSUSE:Factory/.libstatgrab.new/libstatgrab.changes 
2012-01-25 10:37:58.0 +0100
@@ -1,0 +2,5 @@
+Thu Jan 12 11:30:46 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ libstatgrab.spec ++
--- /var/tmp/diff_new_pack.VJJDXv/_old  2012-01-25 10:37:59.0 +0100
+++ /var/tmp/diff_new_pack.VJJDXv/_new  2012-01-25 10:37:59.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libstatgrab
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,13 +15,14 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %define soname 6
 
 Name:   libstatgrab
 Version:0.16
-Release:2
+Release:0
 Summary:Interface to System Statistics
+License:LGPL-2.1+
+Group:  Development/Libraries/C and C++
 Url:http://www.i-scream.org/libstatgrab/
 Source: 
ftp://ftp.i-scream.org/pub/i-scream/libstatgrab/libstatgrab-%{version}.tar.gz
 Source1:statgrab.desktop
@@ -30,11 +31,15 @@
 Patch1: libstatgrab-os-linux.diff
 Patch2: libstatgrab-link-ncurses.diff
 Patch3: libstatgrab-fix-include-ncurses.patch
-Group:  Development/Libraries/C and C++
-License:GNU Library General Public License (LGPL)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  gcc glibc-devel make ncurses-devel
-BuildRequires:  autoconf automake libtool update-desktop-files
+BuildRequires:  autoconf
+BuildRequires:  automake
+BuildRequires:  gcc
+BuildRequires:  glibc-devel
+BuildRequires:  libtool
+BuildRequires:  make
+BuildRequires:  ncurses-devel
+BuildRequires:  update-desktop-files
 
 %description
 The libstatgrab library provides an easy-to-use interface for accessing system
@@ -48,26 +53,26 @@
 
 %package -n %{name}%{soname}
 Summary:Library for %{name}
+License:LGPL-2.1+
 Group:  Development/Libraries/C and C++
-License:GNU Library General Public License (LGPL)
 
 %description -n %{name}%{soname}
 Library for package %{name}.
 
 %package devel
 Summary:Development Environment for %{name}
-Requires:   %{name}%{soname} = %{version}-%{release}
+License:LGPL-2.1+
 Group:  Development/Libraries/C and C++
-License:GNU Library General Public License (LGPL)
+Requires:   %{name}%{soname} = %{version}-%{release}
 
 %description devel
 Development environment for %{name} (headers, library links, static library).
 
 %package -n statgrab
 Summary:Portable System Statistics Tools
-Requires:   %{name}%{soname} = %{version}-%{release}
+License:GPL-2.0+
 Group:  System/Monitoring
-License:GNU General Public License (GPL)
+Requires:   %{name}%{soname} = %{version}-%{release}
 
 %description -n statgrab
 This package includes a couple of useful tools that use the %{name} library.
@@ -79,9 +84,9 @@
 
 %package -n saidar
 Summary:Portable System Statistics Tools
-Requires:   %{name}%{soname} = %{version}-%{release}
+License:GPL-2.0+
 Group:  System/Monitoring
-License:GNU General Public License (GPL)
+Requires:   %{name}%{soname} = %{version}-%{release}
 
 %description -n saidar
 This package includes a couple of useful tools that use the %{name} library.

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libwpg for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package libwpg for openSUSE:Factory checked 
in at 2012-01-25 10:38:04

Comparing /work/SRC/openSUSE:Factory/libwpg (Old)
 and  /work/SRC/openSUSE:Factory/.libwpg.new (New)


Package is libwpg, Maintainer is mhruse...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/libwpg/libwpg.changes2011-10-05 
17:46:13.0 +0200
+++ /work/SRC/openSUSE:Factory/.libwpg.new/libwpg.changes   2012-01-25 
10:38:05.0 +0100
@@ -1,0 +2,5 @@
+Mon Jan 23 18:06:20 UTC 2012 - crrodrig...@opensuse.org
+
+- Build with -fvisibility-inlines-hidden 
+
+---



Other differences:
--
++ libwpg.spec ++
--- /var/tmp/diff_new_pack.udIMg6/_old  2012-01-25 10:38:06.0 +0100
+++ /var/tmp/diff_new_pack.udIMg6/_new  2012-01-25 10:38:06.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libwpg
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -129,6 +129,7 @@
 %patch0
 
 %build
+export CXXFLAGS=%optflags -fvisibility-inlines-hidden
 %configure --disable-static --docdir=%_docdir/%name
 make %{?jobs:-j%jobs}
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit mysql-connector-cpp for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package mysql-connector-cpp for 
openSUSE:Factory checked in at 2012-01-25 10:38:13

Comparing /work/SRC/openSUSE:Factory/mysql-connector-cpp (Old)
 and  /work/SRC/openSUSE:Factory/.mysql-connector-cpp.new (New)


Package is mysql-connector-cpp, Maintainer is mhruse...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/mysql-connector-cpp/mysql-connector-cpp.changes  
2011-09-23 02:14:05.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.mysql-connector-cpp.new/mysql-connector-cpp.changes 
2012-01-25 10:38:15.0 +0100
@@ -1,0 +2,11 @@
+Wed Jan 18 13:04:42 UTC 2012 - cdenic...@suse.com
+
+- license update: SUSE-GPL-2.0-with-FLOSS-exception
+  GPL has FLOSS exception.
+
+---
+Thu Jan 12 11:30:48 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---



Other differences:
--
++ mysql-connector-cpp.spec ++
--- /var/tmp/diff_new_pack.VCHwnL/_old  2012-01-25 10:38:16.0 +0100
+++ /var/tmp/diff_new_pack.VCHwnL/_new  2012-01-25 10:38:16.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package mysql-connector-cpp (Version 1.0.5)
+# spec file for package mysql-connector-cpp
 #
-# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,15 +15,12 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   mysql-connector-cpp
 Summary:MySQL Connector/C++: Standardized database driver for C++ 
development
-Version:1.1.0
-Release:1
+License:SUSE-GPL-2.0-with-FLOSS-exception
 Group:  Development/Libraries/C and C++
-License:GPL
+Version:1.1.0
+Release:0
 Url:http://dev.mysql.com/downloads/connector/
 #   
http://dev.mysql.com/get/Downloads/Connector-C%2B%2B/mysql-connector-c%2B%2B-%{version}.tar.gz
 Source: mysql-connector-c++-%{version}.tar.bz2
@@ -33,7 +30,10 @@
 # http://bugs.mysql.com/44931
 Patch1: mysql-connector-cpp-1.1.0-gcc44.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  cmake gcc-c++ libmysqlclient-devel boost-devel
+BuildRequires:  boost-devel
+BuildRequires:  cmake
+BuildRequires:  gcc-c++
+BuildRequires:  libmysqlclient-devel
 
 %description
 MySQL Connector/C++ is a MySQL database connector for C++ development. The
@@ -54,10 +54,9 @@
 * Shorter development times 
 
 %package -n libmysqlcppconn-devel
-License:GPL
 Requires:   libmysqlcppconn5 = %{version}
-Group:  Development/Libraries/C and C++
 Summary:Development files for MySQL Connector/C++
+Group:  Development/Libraries/C and C++
 
 %description -n libmysqlcppconn-devel
 MySQL Connector/C++ is a MySQL database connector for C++ development. The
@@ -78,9 +77,8 @@
 * Shorter development times 
 
 %package -n libmysqlcppconn5
-License:GPL
-Group:  Development/Libraries/C and C++
 Summary:MySQL Connector/C++: Standardized database driver for C++ 
development
+Group:  Development/Libraries/C and C++
 
 %description -n libmysqlcppconn5
 MySQL Connector/C++ is a MySQL database connector for C++ development. The

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit orca for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package orca for openSUSE:Factory checked in 
at 2012-01-25 10:38:20

Comparing /work/SRC/openSUSE:Factory/orca (Old)
 and  /work/SRC/openSUSE:Factory/.orca.new (New)


Package is orca, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/orca/orca.changes2012-01-09 
15:20:29.0 +0100
+++ /work/SRC/openSUSE:Factory/.orca.new/orca.changes   2012-01-25 
10:38:22.0 +0100
@@ -1,0 +2,27 @@
+Tue Jan 17 08:11:09 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Stability and Performance:
+- Explicitly handle dead accessible objects to prevent
+  triggering crashes in GNOME Shell
+- Refactor InputEvent handling so that it is more performant
+  and less convoluted
+- Get rid of the fake window:activate event as it is no longer
+  required and may be triggering window manager warnings
+- Move wayward event management functionality to the Event
+  Manager
+- Fix for the problem of updatePunctuationLevel() causing
+  breakage for Emacspeak users
+- bgo#28: gdk_keymap_translate_keyboard_state() expects
+  Gdk.ModifierType; not int
+- bgo#666594: app-specific preferences cannot be saved for
+  certain configurations
+  + Keyboard and Keybindings:
+- Speak state changes in locking keys independent of key echo
+- Make it possible to use the NumPad as expected in the Desktop
+  Layout
+- Remove the redundant alternative keybinding functionality
+  + Updated translations.
+- Remove checks for old versions of openSUSE (= 11.1).
+
+---

Old:

  orca-3.3.3.tar.xz

New:

  orca-3.3.4.tar.xz



Other differences:
--
++ orca.spec ++
--- /var/tmp/diff_new_pack.h0nBEO/_old  2012-01-25 10:38:24.0 +0100
+++ /var/tmp/diff_new_pack.h0nBEO/_new  2012-01-25 10:38:24.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package orca
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,8 +15,9 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   orca
-Version:3.3.3
+Version:3.3.4
 Release:0
 Summary:Screen reader for GNOME
 License:LGPL-2.1+
@@ -54,9 +55,6 @@
 Recommends: python-speechd
 Recommends: typelib(Wnck)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if %suse_version = 1110
-%define python_sitearch %{py_sitedir}
-%endif
 %py_requires
 
 %description

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit PackageKit for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package PackageKit for openSUSE:Factory 
checked in at 2012-01-25 10:38:50

Comparing /work/SRC/openSUSE:Factory/PackageKit (Old)
 and  /work/SRC/openSUSE:Factory/.PackageKit.new (New)


Package is PackageKit, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/PackageKit/PackageKit.changes2012-01-09 
11:16:12.0 +0100
+++ /work/SRC/openSUSE:Factory/.PackageKit.new/PackageKit.changes   
2012-01-25 10:38:58.0 +0100
@@ -1,0 +2,41 @@
+Wed Jan 18 07:23:39 UTC 2012 - vu...@opensuse.org
+
+- Update to version 0.7.2:
+  + New Features:
+- Add a new repair-system policy and use it by the
+  corresponding RepairSystem method
+- Add a transaction_reset backend hook
+- Add new roles SimulateRepairSystem and RepairSystem
+- Add pk_*_enum_to_localised_text to pk-enum.h and export via
+  GIR
+- Add possibility to connect/disconnect backend signals
+- Add PropertiesChanged signals to the main and transaction
+  interfaces
+- Allow the Plasma version to be specified for
+  PK_PROVIDES_ENUM_PLASMA_SERVICE
+  + Libraries (glib):
+- Convert libpackagekit-glib2 from dbus-glib to GDBus
+- Skip empty catalog entries
+  + Libraries (qt):
+- Automatically rebuild moc files with different moc version
+  + Zypp Backend:
+- Retrieve url for packages instead of returning TODO
+  + Non-zypp backends updates.
+  + Bugfixes:
+- browser-plugin: Make it compile with newest xulrunner
+- Fix a critical warning in the client tools when a simulation
+  is cancelled
+- Fix builddir != srcdir issue
+- Fix item-percentage call in the spawned backend
+- gtk-plugin: Fix name of GTK plugin schema file
+- Make PkProc part of the daemon again
+- Remove deprecated g_thread_init() on GLib  2.31
+- Set the frontend socket as environment variable in the
+  spawned backend
+- Update the website matrix to include the new
+  (Simulate)RepairSystem roles
+- Rebase patches, via git, including removal of
+  0002-Retrieve-url-for-packages-instead-of-returning-TODO.patch
+  (fixed upstream).
+
+---

Old:

  0002-Retrieve-url-for-packages-instead-of-returning-TODO.patch
  0003-Build-against-npapi-sdk-instead-of-xulrunner.patch
  PackageKit-0.7.1.tar.xz

New:

  0002-Build-against-npapi-sdk-instead-of-xulrunner.patch
  PackageKit-0.7.2.tar.xz



Other differences:
--
++ PackageKit.spec ++
--- /var/tmp/diff_new_pack.y989NC/_old  2012-01-25 10:39:00.0 +0100
+++ /var/tmp/diff_new_pack.y989NC/_new  2012-01-25 10:39:00.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package PackageKit
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -32,9 +32,8 @@
 %endif
 
 Name:   PackageKit
-Version:0.7.1
+Version:0.7.2
 Release:0
-# FIXME: on update, check if we can remove the rm hack for .moc files in 
%%prep (see fdo#40662). Last checked: 0.6.18.
 BuildRequires:  NetworkManager-devel
 BuildRequires:  automake
 BuildRequires:  docbook-utils
@@ -53,7 +52,7 @@
 BuildRequires:  libqt4-devel
 BuildRequires:  libtool
 BuildRequires:  libzypp-devel
-BuildRequires:  mozilla-nspr-devel
+BuildRequires:  mozilla-nspr-devel = 4.8
 %if 0%{suse_version}  1140
 BuildRequires:  pkgconfig(npapi-sdk)
 %else
@@ -84,10 +83,8 @@
 #
 # PATCH-FEATURE-OPENSUSE 
0001-Change-the-configuration-of-the-cron-script-to-a-sys.patch 
vu...@opensuse.org -- Change the configuration of the cron script to a 
sysconfig-like config
 Patch0: 0001-Change-the-configuration-of-the-cron-script-to-a-sys.patch
-# PATCH-FIX-UPSTREAM backport fix for packages showing TODO as url
-Patch1: 0002-Retrieve-url-for-packages-instead-of-returning-TODO.patch
 # PATCH-FIX-UPSTREAM PackageKit-npapi.patch fdo#40026 w...@rosenauer.org -- 
Build against npapi-sdk instead of xulrunner
-Patch2: 0003-Build-against-npapi-sdk-instead-of-xulrunner.patch
+Patch1: 0002-Build-against-npapi-sdk-instead-of-xulrunner.patch
 #
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires:   %{name}-branding = %{version}
@@ -289,9 +286,8 @@
 %setup -q
 translation-update-upstream
 %patch0 -p1
-%patch1 -p1
 %if 0%{?suse_version}  1140
-%patch2 -p1
+%patch1 -p1
 %endif
 
 %build
@@ -422,7 +418,7 @@
 %dir %{_libdir}/gnome-settings-daemon-3.0/gtk-modules
 

commit pan for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package pan for openSUSE:Factory checked in 
at 2012-01-25 10:39:08

Comparing /work/SRC/openSUSE:Factory/pan (Old)
 and  /work/SRC/openSUSE:Factory/.pan.new (New)


Package is pan, Maintainer is dr...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/pan/pan.changes  2012-01-05 19:14:35.0 
+0100
+++ /work/SRC/openSUSE:Factory/.pan.new/pan.changes 2012-01-25 
10:39:09.0 +0100
@@ -1,0 +2,6 @@
+Thu Jan 12 08:18:32 UTC 2012 - dims...@opensuse.org
+
+- Build openSUSE  12.1 against gmime 2.6: Conditionally change
+  pkgconfig(gmime-2.4) BuildRequires to pkgconfig(gmime-2.6).
+
+---



Other differences:
--
++ pan.spec ++
--- /var/tmp/diff_new_pack.IIzXCU/_old  2012-01-25 10:39:10.0 +0100
+++ /var/tmp/diff_new_pack.IIzXCU/_new  2012-01-25 10:39:10.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package pan
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,14 +16,13 @@
 #
 
 
-
 Name:   pan
 Version:0.135
-Release:1
-License:GPLv2+
+Release:0
 Summary:A Powerful Newsreader for GNOME
-Url:http://pan.rebelbase.com/
+License:GPL-2.0+
 Group:  Productivity/Networking/News/Clients
+Url:http://pan.rebelbase.com/
 Source: 
http://pan.rebelbase.com/download/releases/0.134/source/%{name}-%{version}.tar.bz2
 # PATCH-FIX-UPSTREAM fix-desktop-file-11.0.diff -- validate desktop file
 Patch0: fix-desktop-file-11.0.diff
@@ -35,7 +34,11 @@
 BuildRequires:  intltool
 BuildRequires:  translation-update-upstream
 BuildRequires:  update-desktop-files
+%if 0%{?suse_version}  1210
+BuildRequires:  pkgconfig(gmime-2.6)
+%else
 BuildRequires:  pkgconfig(gmime-2.4)
+%endif
 %if 0%{?favor_gtk2}
 BuildRequires:  pkgconfig(gtk+-2.0)
 BuildRequires:  pkgconfig(gtkspell-2.0)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit paratype-pt-mono-fonts for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package paratype-pt-mono-fonts for 
openSUSE:Factory checked in at 2012-01-25 10:39:46

Comparing /work/SRC/openSUSE:Factory/paratype-pt-mono-fonts (Old)
 and  /work/SRC/openSUSE:Factory/.paratype-pt-mono-fonts.new (New)


Package is paratype-pt-mono-fonts, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.paratype-pt-mono-fonts.new/paratype-pt-mono-fonts.changes
   2012-01-25 10:39:49.0 +0100
@@ -0,0 +1,5 @@
+---
+Sat Jan  7 16:38:24 UTC 2012 - lazy.k...@opensuse.org
+
+- Initial package created - 1.000OFL
+

New:

  PTMonoOFL.zip
  paratype-pt-mono-fonts.changes
  paratype-pt-mono-fonts.spec



Other differences:
--
++ paratype-pt-mono-fonts.spec ++
#
# spec file for package paratype-pt-mono-fonts
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define _ttf_fontdir%{_datadir}/fonts/truetype

Name:   paratype-pt-mono-fonts
Version:1.000OFL
Release:0
License:OFL-1.1
Summary:Monospaced Fonts for Minority Languages of Russia
Url:http://www.paratype.com/public/
Group:  System/X11/Fonts
Source0:http://www.fontstock.com/public/PTMonoOFL.zip
BuildRequires:  unzip
BuildRequires:  xorg-x11-devel
Provides:   locale(be;ru;uk)
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildArch:  noarch
Requires(pre):  %suseconfig_fonts_prereq

%description
PT Mono was developed for the special needs — for use in forms, tables,
work sheets etc. Equal widths of characters are very helpful in setting
complex documents, with such font you may easily calculate size of entry
fields, column widths in tables and so on. One of the most important
area of use is Web sites of “electronic governments“ where visitors have
to fill different request forms. Currently PT Mono consists of just one
Regular style.
 
The fonts beside standard Western, Central European and Cyrillic code
pages contain characters of all title languages of Russian Federation
that make them unique and very important tool of the modern digital
communications.

%prep
%setup -cqn %{name}-%{version}
sed -i 's/\r$//g' PTSSM_OFL.txt

%build

%install
install -dm 0755 %{buildroot}%{_ttf_fontdir}
install -m 0644 *.ttf %{buildroot}%{_ttf_fontdir}

%post
%run_suseconfig_fonts

%postun
%run_suseconfig_fonts

%files
%defattr(-,root,root,-)
%doc PTSSM_OFL.txt
%dir %{_ttf_fontdir}
%{_ttf_fontdir}/*.ttf

%changelog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit paratype-pt-sans-fonts for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package paratype-pt-sans-fonts for 
openSUSE:Factory checked in at 2012-01-25 10:40:19

Comparing /work/SRC/openSUSE:Factory/paratype-pt-sans-fonts (Old)
 and  /work/SRC/openSUSE:Factory/.paratype-pt-sans-fonts.new (New)


Package is paratype-pt-sans-fonts, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.paratype-pt-sans-fonts.new/paratype-pt-sans-fonts.changes
   2012-01-25 10:40:22.0 +0100
@@ -0,0 +1,27 @@
+---
+Wed Dec 14 12:18:28 UTC 2011 - t...@suse.de
+
+- Renamed PTSans-fonts - paratype-pt-sans-fonts according to
+  openSUSE packaging guidelines and FATE#313035
+  Adjusted Obsoletes and Provides accordingly
+
+---
+Thu Nov 24 17:38:09 UTC 2011 - lazy.k...@opensuse.org
+
+- Spec clean up.
+
+---
+Sat Sep 17 10:02:25 UTC 2011 - jeng...@medozas.de
+
+- Remove redundant tags/sections from specfile
+
+---
+Thu Jul  7 02:06:44 UTC 2011 - lazy.k...@opensuse.org
+
+- Provides locale be, ru, uk
+
+---
+Mon Jun 27 03:25:40 UTC 2011 - lazy.k...@opensuse.org
+
+- Initial package created - 2.003OFL
+

New:

  Info_PT_SS.pdf
  PTSansOFL.zip
  paratype-pt-sans-fonts.changes
  paratype-pt-sans-fonts.spec



Other differences:
--
++ paratype-pt-sans-fonts.spec ++
#
# spec file for package paratype-pt-sans-fonts
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define _ttf_fontdir%{_datadir}/fonts/truetype

Name:   paratype-pt-sans-fonts
Version:2.003OFL
Release:0
Summary:Sans Fonts for Minority Languages of Russia
License:OFL-1.1
Group:  System/X11/Fonts
Url:http://www.paratype.com/public/
Source0:http://www.fontstock.com/public/PTSansOFL.zip
Source1:http://www.paratype.ru/public/Info_PT_SS.pdf
BuildRequires:  unzip
BuildRequires:  xorg-x11-devel
Provides:   locale(be;ru;uk)
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildArch:  noarch
Requires(pre):  %suseconfig_fonts_prereq
# FIXME: This causes a rpmlint warning; change = to  once there's a new 
upstream version
Obsoletes:  PTSans-fonts = 2.003OFL
Provides:   PTSans-fonts = %{version}

%description
PT Sans is based on Russian sans serif types of the second part of
the XX century, but at the same time has a very distinctive features of
modern humanistic design. The family consists of 8 styles: 4 basic
styles; 2 captions styles for small sizes and 2 narrows styles for
economic setting.

The fonts beside standard Western, Central European and Cyrillic code
pages contain characters of all title languages of Russian Federation
that make them unique and very important tool of the modern digital
communications.

%prep
%setup -cqn %{name}-%{version}
cp %{SOURCE1} .
sed -i 's/\r$//g' PTSansPTSerifOFL.txt

%build

%install
install -dm 0755 %{buildroot}%{_ttf_fontdir}
install -m 0644 *.ttf %{buildroot}%{_ttf_fontdir}

%post
%run_suseconfig_fonts

%postun
%run_suseconfig_fonts

%files
%defattr(-,root,root,-)
%doc Info_PT_SS.pdf PTSansPTSerifOFL.txt
%dir %{_ttf_fontdir}
%{_ttf_fontdir}/*.ttf

%changelog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit qpdf for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package qpdf for openSUSE:Factory checked in 
at 2012-01-25 10:40:53

Comparing /work/SRC/openSUSE:Factory/qpdf (Old)
 and  /work/SRC/openSUSE:Factory/.qpdf.new (New)


Package is qpdf, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/qpdf/qpdf.changes2012-01-04 
07:30:48.0 +0100
+++ /work/SRC/openSUSE:Factory/.qpdf.new/qpdf.changes   2012-01-25 
10:40:54.0 +0100
@@ -1,0 +2,8 @@
+Mon Jan 23 19:33:01 UTC 2012 - crrodrig...@opensuse.org
+
+- Fix devel package requires
+- Build with -fvisibility-inlines-hidden, test suite
+  confirms it works and saves a few dozens of entries in the 
+  exported symbol table.
+
+---



Other differences:
--
++ qpdf.spec ++
--- /var/tmp/diff_new_pack.ECaCbF/_old  2012-01-25 10:40:55.0 +0100
+++ /var/tmp/diff_new_pack.ECaCbF/_new  2012-01-25 10:40:55.0 +0100
@@ -16,6 +16,7 @@
 #
 
 
+
 Name:   qpdf
 Version:2.3.1
 Release:0
@@ -48,8 +49,7 @@
 Summary:Development files for qpdf PDF manipulation library
 Group:  Development/Libraries/C and C++
 Requires:   %{name} = %{version}
-Requires:   pcre-devel
-Requires:   zlib-devel
+Requires:   libstdc++-devel
 
 %description devel
 The qpdf-devel package contains header files and libraries necessary
@@ -59,7 +59,8 @@
 %setup -q
 
 %build
-%configure --disable-test-compare-images \
+export CXXFLAGS=%optflags -fvisibility-inlines-hidden
+%configure --disable-static --disable-test-compare-images \
--docdir='${datarootdir}'/doc/packages/%{name}
 make %{?_smp_mflags}
 
@@ -70,8 +71,6 @@
 %install
 %makeinstall
 
-rm %{buildroot}%{_libdir}/libqpdf.a
-
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-atspi for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package python-atspi for openSUSE:Factory 
checked in at 2012-01-25 10:40:49

Comparing /work/SRC/openSUSE:Factory/python-atspi (Old)
 and  /work/SRC/openSUSE:Factory/.python-atspi.new (New)


Package is python-atspi, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-atspi/python-atspi.changes
2011-10-20 14:10:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-atspi.new/python-atspi.changes   
2012-01-25 10:40:50.0 +0100
@@ -1,0 +2,11 @@
+Mon Jan 16 13:25:48 UTC 2012 - vu...@opensuse.org
+
+- Update to version 2.3.4:
+  + bgo#666871: deregisterKeystrokeListener was broken.
+- Add xz BuildRequires because we can't build a package for a
+  xz-compressed tarball without explicitly specifying that... See
+  bnc#697467 for more details.
+- Remove checks for old non-maintained versions of openSUSE (11.1
+  and earlier).
+
+---

Old:

  pyatspi-2.2.1.tar.bz2

New:

  pyatspi-2.3.4.tar.xz



Other differences:
--
++ python-atspi.spec ++
--- /var/tmp/diff_new_pack.3hTYMd/_old  2012-01-25 10:40:51.0 +0100
+++ /var/tmp/diff_new_pack.3hTYMd/_new  2012-01-25 10:40:51.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-atspi
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,19 +16,20 @@
 #
 
 
-
 Name:   python-atspi
 %define _name   pyatspi
-Version:2.2.1
-Release:1
+Version:2.3.4
+Release:0
 Summary:Assistive Technology Service Provider Interface - Python 
bindings
 License:LGPL-2.0
 Group:  Development/Libraries/Python
 Url:http://www.gnome.org/
-Source0:
http://download.gnome.org/sources/pyatspi/2.2/%{_name}-%{version}.tar.bz2
+Source0:
http://download.gnome.org/sources/pyatspi/2.3/%{_name}-%{version}.tar.xz
 BuildRequires:  fdupes
 # Needed to have typelib() Requires.
 BuildRequires:  gobject-introspection
+# Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
+BuildRequires:  xz
 BuildRequires:  pkgconfig(pygobject-3.0) = 2.90.1
 Requires:   dbus-1-python
 Requires:   python-gobject
@@ -41,12 +42,7 @@
 # at-spi stack is used. Only the default at-spi stack should define it.
 Provides:   pyatspi
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if %suse_version  1110
 BuildArch:  noarch
-%endif
-%if %suse_version = 1110
-%define python_sitelib %{py_sitedir}
-%endif
 %py_requires
 
 %description

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5-pear-Horde_Mime_Viewer for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package php5-pear-Horde_Mime_Viewer for 
openSUSE:Factory checked in at 2012-01-25 10:40:43

Comparing /work/SRC/openSUSE:Factory/php5-pear-Horde_Mime_Viewer (Old)
 and  /work/SRC/openSUSE:Factory/.php5-pear-Horde_Mime_Viewer.new (New)


Package is php5-pear-Horde_Mime_Viewer, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/php5-pear-Horde_Mime_Viewer/php5-pear-Horde_Mime_Viewer.changes
  2011-09-23 12:40:31.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.php5-pear-Horde_Mime_Viewer.new/php5-pear-Horde_Mime_Viewer.changes
 2012-01-25 10:40:44.0 +0100
@@ -1,0 +2,19 @@
+Tue Jan 17 13:04:39 UTC 2012 - l...@b1-systems.de
+
+- version 1.0.8
+- spec file license format like spdx
+- ships license file from upstream
+- [jan] Fix configuration of syntaxhighlighter viewer.
+- [mms] Fix iteration through child HTML nodes in the HTML viewer so that 
extended viewers can do things like remove nodes outright.
+- [jan] Add Croatian translation.
+- [jan] Add Estonian translation.
+
+---
+Sun Aug 14 21:48:15 UTC 2011 - l...@b1-systems.de
+
+- version 1.0.5
+- [jan] Update Lithuanian translation.
+- [jan] Update Brazilian Portuguese translation.
+- [gwr] Support restricting the HTML tidy post processing by the message size 
(Request #10266).
+- [jan] Update Latvian translation. 
+---

Old:

  Horde_Mime_Viewer-1.0.3.tgz

New:

  Horde_Mime_Viewer-1.0.8.tgz



Other differences:
--
++ php5-pear-Horde_Mime_Viewer.spec ++
--- /var/tmp/diff_new_pack.QBQgzw/_old  2012-01-25 10:40:45.0 +0100
+++ /var/tmp/diff_new_pack.QBQgzw/_new  2012-01-25 10:40:45.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package php5-pear-Horde_Mime_Viewer
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,12 +21,12 @@
 %define hordedir /usr/share/php5/PEAR/www/horde
 
 Summary:PEAR: Horde MIME Viewer Library
+License:LGPL-2.1
+Group:  Development/Libraries/PHP
 
 Name:   php5-pear-Horde_Mime_Viewer
-Version:1.0.3
-Release:1
-License:LGPL
-Group:  Development/Libraries/PHP
+Version:1.0.8
+Release:0
 Source0:http://pear.horde.org/get/Horde_Mime_Viewer-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/Horde_Mime_Viewer
@@ -40,8 +40,8 @@
 Requires:   php5-pear-Horde_Util  2.0.0
 Requires:   php5-pear-Horde_Translation  2.0.0
 Requires:   php5-pear = 1.7.0
-Conflicts:  php5-pear-Horde_Browser = 2.0.0, php5-pear-Horde_Compress = 
2.0.0, php5-pear-Horde_Exception = 2.0.0, php5-pear-Horde_Mime = 2.0.0, 
php5-pear-Horde_Text_Filter = 2.0.0, php5-pear-Horde_Text_Flowed = 2.0.0, 
php5-pear-Horde_Util = 2.0.0, php5-pear-Horde_Translation = 2.0.0
-BuildRequires:  php5-pear-Horde_Role php5-pear-channel-horde
+BuildRequires:  php5-pear-Horde_Role
+BuildRequires:  php5-pear-channel-horde
 Requires:   php5-pear-channel-horde,  php5-pear-Horde_Role
 BuildArch:  noarch
 %define pear_name  Horde_Mime_Viewer
@@ -106,5 +106,6 @@
 %dir %{hordedir}/js
 %dir %{hordedir}/js/syntaxhighlighter
 %{hordedir}/js/syntaxhighlighter/*
+%doc %{_docdir}/%{name}
 
 %changelog

++ Horde_Mime_Viewer-1.0.3.tgz - Horde_Mime_Viewer-1.0.8.tgz ++
 45141 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit seahorse for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package seahorse for openSUSE:Factory 
checked in at 2012-01-25 10:41:04

Comparing /work/SRC/openSUSE:Factory/seahorse (Old)
 and  /work/SRC/openSUSE:Factory/.seahorse.new (New)


Package is seahorse, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/seahorse/seahorse.changes2012-01-09 
15:21:26.0 +0100
+++ /work/SRC/openSUSE:Factory/.seahorse.new/seahorse.changes   2012-01-25 
10:41:07.0 +0100
@@ -1,0 +2,8 @@
+Mon Jan 16 16:52:35 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Remove limitation of max keyring item description characters
+  + Build fixes
+  + Updated translations.
+
+---

Old:

  seahorse-3.3.3.tar.xz

New:

  seahorse-3.3.4.tar.xz



Other differences:
--
++ seahorse.spec ++
--- /var/tmp/diff_new_pack.Hbcrgb/_old  2012-01-25 10:41:08.0 +0100
+++ /var/tmp/diff_new_pack.Hbcrgb/_new  2012-01-25 10:41:08.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package seahorse
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,7 +16,7 @@
 #
 
 Name:   seahorse
-Version:3.3.3
+Version:3.3.4
 Release:0
 Summary:GNOME interface for gnupg
 License:GPL-2.0+

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit shared-desktop-ontologies for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package shared-desktop-ontologies for 
openSUSE:Factory checked in at 2012-01-25 10:41:09

Comparing /work/SRC/openSUSE:Factory/shared-desktop-ontologies (Old)
 and  /work/SRC/openSUSE:Factory/.shared-desktop-ontologies.new (New)


Package is shared-desktop-ontologies, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/shared-desktop-ontologies/shared-desktop-ontologies.changes
  2011-11-28 12:57:32.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.shared-desktop-ontologies.new/shared-desktop-ontologies.changes
 2012-01-25 10:41:11.0 +0100
@@ -1,0 +2,6 @@
+Wed Jan 18 13:56:36 UTC 2012 - cfarr...@suse.com
+
+- license update: (CC-BY-SA-3.0 or BSD-3-Clause) and CC-BY-3.0 and W3C
+  SPDX format reflecting the license as stated in LICENSE.README
+
+---



Other differences:
--
++ shared-desktop-ontologies.spec ++
--- /var/tmp/diff_new_pack.b89Jhw/_old  2012-01-25 10:41:12.0 +0100
+++ /var/tmp/diff_new_pack.b89Jhw/_new  2012-01-25 10:41:12.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package shared-desktop-ontologies
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,15 +15,13 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   shared-desktop-ontologies
 Version:0.8.1
-Release:1
-License:CCBY
+Release:0
 Summary:Shared Desktop Ontologies
-Url:http://sourceforge.net/projects/oscaf
+License:(CC-BY-SA-3.0 or BSD-3-Clause) and CC-BY-3.0 and W3C
 Group:  System/X11/Utilities
+Url:http://sourceforge.net/projects/oscaf
 Source0:
http://sourceforge.net/projects/oscaf/files/%{name}/0.8.1/%{name}-%{version}.tar.bz2
 BuildRequires:  cmake
 BuildRequires:  gcc-c++
@@ -39,7 +37,6 @@
 desktop and web applications.
 
 %package devel
-License:CCBY
 Summary:Shared Desktop Ontologies
 Group:  Development/Libraries/C and C++
 Requires:   %{name} = %{version}

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit vinagre for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package vinagre for openSUSE:Factory checked 
in at 2012-01-25 10:41:26

Comparing /work/SRC/openSUSE:Factory/vinagre (Old)
 and  /work/SRC/openSUSE:Factory/.vinagre.new (New)


Package is vinagre, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/vinagre/vinagre.changes  2012-01-09 
15:22:37.0 +0100
+++ /work/SRC/openSUSE:Factory/.vinagre.new/vinagre.changes 2012-01-25 
10:41:27.0 +0100
@@ -1,0 +2,8 @@
+Tue Jan 17 08:04:53 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Make host text entry editable in connect dialog
+  + Improved documentation.
+  + Updated translations.
+
+---

Old:

  vinagre-3.3.3.tar.xz

New:

  vinagre-3.3.4.tar.xz



Other differences:
--
++ vinagre.spec ++
--- /var/tmp/diff_new_pack.xBe0Fr/_old  2012-01-25 10:41:28.0 +0100
+++ /var/tmp/diff_new_pack.xBe0Fr/_new  2012-01-25 10:41:28.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package vinagre
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,11 +15,12 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   vinagre
 Summary:VNC client for GNOME
 License:GPL-2.0+
 Group:  Productivity/Networking/Other
-Version:3.3.3
+Version:3.3.4
 Release:0
 # FIXME: the %%{_datadir}/help/$locale/ files be found by %%find_lang
 Url:http://www.gnome.org/projects/vinagre/

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit x11-input-mtrack for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package x11-input-mtrack for 
openSUSE:Factory checked in at 2012-01-25 10:41:36

Comparing /work/SRC/openSUSE:Factory/x11-input-mtrack (Old)
 and  /work/SRC/openSUSE:Factory/.x11-input-mtrack.new (New)


Package is x11-input-mtrack, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ /work/SRC/openSUSE:Factory/.x11-input-mtrack.new/x11-input-mtrack.changes   
2012-01-25 10:41:37.0 +0100
@@ -0,0 +1,25 @@
+---
+Mon Jan 23 10:52:36 UTC 2012 - sndir...@suse.com
+
+- added missing copyright for specfile 
+
+---
+Thu Jan 12 15:00:29 UTC 2012 - cfarr...@suse.com
+
+- license update: GPL-2.0
+  SPDX format
+
+---
+Tue Jan 10 13:39:20 UTC 2012 - sndir...@suse.com
+
+- reworked mtrack.conf
+- give the driver higher priority in /etc/X11/xorg.conf.d than the
+  synaptics one; removed the voodoo of synaptics driver config
+  renaming
+
+---
+Thu Aug 11 16:38:38 CEST 2011 - ti...@suse.de
+
+- initial version: 0.2.0
+- add xorg.conf file
+

New:

  mtrack.conf
  multitouch-missing-include.diff
  x11-input-mtrack.changes
  x11-input-mtrack.spec
  xf86-input-mtrack-0.2.0-1-g71abf32.tar.bz2



Other differences:
--
++ x11-input-mtrack.spec ++
#
# spec file for package x11-input-mtrack
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:   x11-input-mtrack
BuildRequires:  mtdev-devel pkgconfig xorg-x11-proto-devel xorg-x11-server-sdk
BuildRequires:  autoconf automake libtool
Summary:An Xorg driver for multitouch trackpads
Version:0.2.0
Release:1
License:GPL-2.0
Group:  System/X11/Servers/XF86_4
Source: xf86-input-mtrack-0.2.0-1-g71abf32.tar.bz2
Source1:mtrack.conf
Patch:  multitouch-missing-include.diff
ExcludeArch:s390 s390x
Conflicts:  x11-input-multitouch
Url:http://github.com/BlueDragonX/xf86-input-mtrack
BuildRoot:  %{_tmppath}/%{name}-%{version}-build

%description
An Xorg driver for multitouch trackpads. Supports any trackpad whose kernel 
driver uses the slotted multitouch protocol. For more information on the 
protocol see the kernel documentation.

This driver is compatible with Xorg server versions 1.7, 1.8, and 1.10. It 
requires the mtdev library to operate.

%prep
%setup -q -n xf86-input-mtrack
%patch -p1

%build
autoreconf -fi
%configure
%{__make}

%install
%makeinstall
mkdir -p $RPM_BUILD_ROOT/etc/X11/xorg.conf.d
# higher priority than synaptics (50-synaptics.conf), apparently the last
# driver entry wins ...
install -c -m 0644 %{S:1} $RPM_BUILD_ROOT/etc/X11/xorg.conf.d/60-mtrack.conf

%clean
rm -rf $RPM_BUILD_ROOT

%files 
%defattr(-,root,root)
%doc COPYING README.md
%{_libdir}/xorg/modules/input
/etc/X11/xorg.conf.d/*.conf

%changelog
++ mtrack.conf ++
Section InputClass
MatchIsTouchpad on
Identifier  Touchpads
MatchDevicePath /dev/input/event*
Driver  mtrack
# Default for some options
# Option ButtonIntegrated   true
# Option ClickFinger1   3
# Option ClickFinger2   2
# Option ClickFinger3   0
# Option ThumbSize  25
# Option PalmSize   40
# Option ClickTime  50
# Option ScrollDistance 150
EndSection
++ multitouch-missing-include.diff ++
diff --git a/driver/mtrack.c b/driver/mtrack.c
index a835b5e..6052243 100644
--- a/driver/mtrack.c
+++ b/driver/mtrack.c
@@ -27,6 +27,7 @@
 #if GET_ABI_MAJOR(ABI_XINPUT_VERSION) = 7
 #include X11/Xatom.h
 #include xserver-properties.h
+#include xorg/exevents.h
 #endif
 
 #define TAP_HOLD 100
diff --git a/include/common.h b/include/common.h
index 6098c30..e01cebe 100644
--- a/include/common.h
+++ b/include/common.h
@@ -33,6 +33,7 @@
 #include xf86Xinput.h
 #include errno.h
 #include mtdev-mapping.h
+#include mtdev-plumbing.h
 

commit yelp for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package yelp for openSUSE:Factory checked in 
at 2012-01-25 10:41:49

Comparing /work/SRC/openSUSE:Factory/yelp (Old)
 and  /work/SRC/openSUSE:Factory/.yelp.new (New)


Package is yelp, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/yelp/yelp.changes2012-01-09 
15:23:02.0 +0100
+++ /work/SRC/openSUSE:Factory/.yelp.new/yelp.changes   2012-01-25 
10:41:51.0 +0100
@@ -1,0 +2,11 @@
+Tue Jan 17 14:14:52 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.3:
+  + Adjust CSS for yelp-xsl changes
+  + Reverting Share button for 3.4
+  + Don't segfault without dbus (bgo#660579)
+  + Updated translations.
+- Remove pkgconfig(folks) and pkgconfig(gee-1.0) BuildRequires: the
+  Share button is gone for now.
+
+---

Old:

  yelp-3.3.2.tar.xz

New:

  yelp-3.3.3.tar.xz



Other differences:
--
++ yelp.spec ++
--- /var/tmp/diff_new_pack.9frTEA/_old  2012-01-25 10:41:52.0 +0100
+++ /var/tmp/diff_new_pack.9frTEA/_new  2012-01-25 10:41:52.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package yelp
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   yelp
-Version:3.3.2
+Version:3.3.3
 Release:0
 Summary:Help Browser for the GNOME Desktop
 License:GPL-2.0+ ; LGPL-2.1+
@@ -38,8 +38,6 @@
 BuildRequires:  update-desktop-files
 # Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
 BuildRequires:  xz
-BuildRequires:  pkgconfig(folks) = 0.6.3
-BuildRequires:  pkgconfig(gee-1.0)
 BuildRequires:  pkgconfig(gtk+-3.0)
 BuildRequires:  pkgconfig(liblzma)
 BuildRequires:  pkgconfig(libxslt)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit arpwatch-ethercodes for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package arpwatch-ethercodes for 
openSUSE:Factory checked in at 2012-01-25 11:07:24

Comparing /work/SRC/openSUSE:Factory/arpwatch-ethercodes (Old)
 and  /work/SRC/openSUSE:Factory/.arpwatch-ethercodes.new (New)


Package is arpwatch-ethercodes, Maintainer is dr...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/arpwatch-ethercodes/arpwatch-ethercodes.changes  
2012-01-20 20:22:35.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.arpwatch-ethercodes.new/arpwatch-ethercodes.changes 
2012-01-25 11:07:25.0 +0100
@@ -2 +2 @@
-Fri Jan 20 08:40:09 CET 2012 - autobu...@suse.de
+Wed Jan 25 08:40:05 CET 2012 - autobu...@suse.de
@@ -4 +4 @@
-- automated update on 2012-01-20
+- automated update on 2012-01-25



Other differences:
--
++ arpwatch-ethercodes.spec ++
--- /var/tmp/diff_new_pack.PjvZDk/_old  2012-01-25 11:07:33.0 +0100
+++ /var/tmp/diff_new_pack.PjvZDk/_new  2012-01-25 11:07:33.0 +0100
@@ -23,7 +23,7 @@
 License:BSD-3-Clause
 Group:  Productivity/Networking/Diagnostic
 Summary:Ethercodes Data for arpwatch
-Version:2012.1.20
+Version:2012.1.25
 Release:1
 Source0:http://standards.ieee.org/regauth/oui/oui.txt
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ oui.txt ++
--- /var/tmp/diff_new_pack.PjvZDk/_old  2012-01-25 11:07:33.0 +0100
+++ /var/tmp/diff_new_pack.PjvZDk/_new  2012-01-25 11:07:33.0 +0100
@@ -6431,7 +6431,7 @@
 
 00-03-DB   (hex)   Apogee Electronics Corp.
 0003DB (base 16)   Apogee Electronics Corp.
-   3145 Donald Douglas Loop South
+   1715 Berkeley St. 
Santa Monica CA 90405-3210
UNITED STATES
 
@@ -32818,8 +32818,9 @@
 
 00-14-36   (hex)   Qwerty Elektronik AB
 001436 (base 16)   Qwerty Elektronik AB
-   Bälinge Klockargård
-   Tystberga  610 60
+   Gryt 44
+   SE-148 92
+   �smo  610 60
SWEDEN
 
 00-14-37   (hex)   GSTeletech Co.,Ltd.
@@ -57216,11 +57217,10 @@
Stellenbosch Western Cape 7600
SOUTH AFRICA
 
-00-23-41   (hex)   Siemens AG
-002341 (base 16)   Siemens AG
-   Industry Sector, Building Technologies Division
-   I BT DE SP, Siemensallee 84
-   Karlsruhe Deutschland D-76187
+00-23-41   (hex)   Siemens AG, Infrastructure  Cities Sector, 
Building Technologies Division
+002341 (base 16)   Siemens AG, Infrastructure  Cities Sector, 
Building Technologies Division
+   Siemensallee 84
+   Karlsruhe Baden-Wuerttemberg D-76187
GERMANY
 
 00-23-42   (hex)   Coffee Equipment Company
@@ -82641,6 +82641,12 @@
Gasan-Dong, Gumcheon-Gu Seoul 153-803
KOREA, REPUBLIC OF
 
+10-E4-AF   (hex)   APR, LLC
+10E4AF (base 16)   APR, LLC
+   4800 US HWY 280 West
+   Opelika AL 36801
+   UNITED STATES
+
 10-E6-AE   (hex)   Source Technologies, LLC
 10E6AE (base 16)   Source Technologies, LLC
2910 Whitehall Park Drive
@@ -83224,6 +83230,12 @@
Seongnam-si Gyeonggi-do 463-760
KOREA, REPUBLIC OF
 
+18-D6-6A   (hex)   Inmarsat
+18D66A (base 16)   Inmarsat
+   99 City Road
+   London  EC1Y 1AX
+   UNITED KINGDOM
+
 18-E2-88   (hex)   STT Condigi
 18E288 (base 16)   STT Condigi
Agnesfridsvagen 113 A
@@ -84147,6 +84159,13 @@
San Jose CA 95131
UNITED STATES
 
+28-17-CE   (hex)   Omnisense Ltd
+2817CE (base 16)   Omnisense Ltd
+   3rd Floor St Andrew#39;s House
+   59 St Andrews Street
+   Cambridge Cambridgeshire CB2 3BZ
+   UNITED KINGDOM
+
 28-18-FD   (hex)   Aditya Infotech Ltd.
 2818FD (base 16)   

commit colord for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package colord for openSUSE:Factory checked 
in at 2012-01-25 11:07:32

Comparing /work/SRC/openSUSE:Factory/colord (Old)
 and  /work/SRC/openSUSE:Factory/.colord.new (New)


Package is colord, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/colord/colord.changes2012-01-09 
12:03:09.0 +0100
+++ /work/SRC/openSUSE:Factory/.colord.new/colord.changes   2012-01-25 
11:07:33.0 +0100
@@ -1,0 +2,35 @@
+Wed Jan 18 10:47:23 UTC 2012 - vu...@opensuse.org
+
+- Add pkgconfig(gusb) BuildRequires to build with libgusb support,
+  which matters even more now than libusb support is gone.
+
+---
+Tue Jan 17 18:02:05 UTC 2012 - vu...@opensuse.org
+
+- Update to version 0.1.16:
+  + New Features:
+- Add a device-inhibit command to the colormgr client
+- Add org.freedesktop.policykit.owner annotations to .policy
+  file
+- Add profile metadata MAPPING_device_id for automatic profile
+  mapping
+- Add some profile metadata keys
+- Install a systemd service file if systemd is used
+- Support 2nd generation Huey hardware
+- Use GUsb for the Huey sensor
+  + Bugfixes:
+- Fix a Wformat error when printing a gsize
+- If /usr/share/color appears at runtime, don't rescan the
+  parent dir
+- Set the colorimeter sensor group so the dameon can access the
+  sensor
+- Split the spyder hardware into different types
+- Add pkgconfig(systemd) BuildRequires, following upstream change,
+  to know where to install the .service file.
+- Remove pkgconfig(libusb-1.0) BuildRequires: the dependency is
+  gone now.
+- Drop colord-polkit-annotate-owner.patch: fixed upstream.
+- Remove libtool BuildRequires and call to autoreconf and
+  intltoolize, that were only needed for above patch.
+
+---

Old:

  colord-0.1.15.tar.xz
  colord-polkit-annotate-owner.patch

New:

  colord-0.1.16.tar.xz



Other differences:
--
++ colord.spec ++
--- /var/tmp/diff_new_pack.fhfEjK/_old  2012-01-25 11:07:52.0 +0100
+++ /var/tmp/diff_new_pack.fhfEjK/_new  2012-01-25 11:07:52.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package colord
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,8 +15,9 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   colord
-Version:0.1.15
+Version:0.1.16
 Release:0
 Summary:System Daemon for Managing Color Devices
 License:GPL-2.0+
@@ -24,12 +25,8 @@
 Url:http://colord.hughsie.com/
 Source0:
http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
-# PATCH-FIX-UPSTREAM colord-polkit-annotate-owner.patch vu...@opensuse.org -- 
Add org.freedesktop.policykit.owner annotations to policy file; will enter git 
very soon
-Patch1: colord-polkit-annotate-owner.patch
 BuildRequires:  gobject-introspection-devel
 BuildRequires:  intltool
-# needed for patch1
-BuildRequires:  libtool
 BuildRequires:  sane-backends-devel
 BuildRequires:  vala
 # Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
@@ -41,10 +38,11 @@
 BuildRequires:  pkgconfig(gmodule-2.0)
 BuildRequires:  pkgconfig(gobject-2.0)
 BuildRequires:  pkgconfig(gudev-1.0)
+BuildRequires:  pkgconfig(gusb) = 0.1.1
 BuildRequires:  pkgconfig(lcms2)
-BuildRequires:  pkgconfig(libusb-1.0) = 1.0.0
-BuildRequires:  pkgconfig(polkit-gobject-1)
+BuildRequires:  pkgconfig(polkit-gobject-1) = 0.103
 BuildRequires:  pkgconfig(sqlite3)
+BuildRequires:  pkgconfig(systemd)
 Requires(pre):  pwdutils
 Requires:   shared-color-profiles
 Recommends: %{name}-lang
@@ -91,12 +89,8 @@
 %lang_package
 %prep
 %setup -q
-%patch1 -p1
 
 %build
-# needed for patch1
-autoreconf -fi
-intltoolize --force
 %configure \
 --disable-static \
 --enable-polkit \
@@ -131,6 +125,7 @@
 %files
 %defattr(-,root,root)
 %doc AUTHORS ChangeLog COPYING NEWS README
+/lib/systemd/system/colord.service
 /lib/udev/rules.d/*.rules
 %attr(755,colord,colord) %dir %{_localstatedir}/lib/colord
 %config(noreplace) %{_sysconfdir}/%{name}.conf

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit ctdb for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package ctdb for openSUSE:Factory checked in 
at 2012-01-25 11:07:36

Comparing /work/SRC/openSUSE:Factory/ctdb (Old)
 and  /work/SRC/openSUSE:Factory/.ctdb.new (New)


Package is ctdb, Maintainer is samba-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/ctdb/ctdb.changes2011-09-23 
01:54:43.0 +0200
+++ /work/SRC/openSUSE:Factory/.ctdb.new/ctdb.changes   2012-01-25 
11:07:52.0 +0100
@@ -1,0 +2,21 @@
+Mon Jan 23 16:36:00 UTC 2012 - lmue...@suse.de
+
+- Simplify conditional BuildRrequires of pkg-config.
+
+---
+Wed Dec 21 12:59:18 UTC 2011 - co...@suse.com
+
+- Add autoconf as buildrequire to avoid implicit dependency for post-11.4
+  systems.
+
+---
+Tue Dec 20 20:24:22 UTC 2011 - co...@suse.com
+
+- Remove call to suse_update_config macro for post-11.4 systems.
+
+---
+Sun Sep 18 00:07:30 UTC 2011 - jeng...@medozas.de
+
+- Remove redundant tags/sections from specfile
+
+---



Other differences:
--
++ ctdb.spec ++
--- /var/tmp/diff_new_pack.XCbXnD/_old  2012-01-25 11:07:58.0 +0100
+++ /var/tmp/diff_new_pack.XCbXnD/_new  2012-01-25 11:07:58.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package ctdb
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,12 +17,12 @@
 
 
 Summary:Clustered TDB
+License:GPL-3.0
+Group:  System/Daemons
 
 Name:   ctdb
 Version:1.2.29
-Release:3
-License:GPL-3.0
-Group:  System/Daemons
+Release:0
 Url:http://ctdb.samba.org/
 Source: ctdb-%{version}.tar.bz2
 Source1:ctdb-sysconfig-suse.template
@@ -34,27 +34,22 @@
 %endif
 PreReq: fileutils /bin/mktemp /usr/bin/killall sed
 %define initdir %{_sysconfdir}/init.d
-AutoReqProv:on
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+%if 0%{?suse_version} == 0 || 0%{?suse_version}  1140
+BuildRequires:  autoconf
+%endif
 %if 0%{?suse_version}  1020
 BuildRequires:  pkg-config
 %else
-%if 0%{?suse_version}
 BuildRequires:  pkgconfig
 %endif
-%endif
-#%if 0%{?suse_version}
-#BuildRequires:  pkg-config
-#%endif
 
 %description
 ctdb is the clustered database used by Samba
 
 %package devel
-License:GPL-3.0
 Summary:Libraries and Header Files to Develop Programs with ctdb 
support
 Group:  Development/Libraries/C and C++
-AutoReqProv:on
 
 %description devel
 This package contains the static libraries and header files needed to
@@ -65,7 +60,9 @@
 %patch1 -p1
 
 %build
+%if 0%{?suse_version}  0%{?suse_version}  1141
 %{?suse_update_config:%{suse_update_config -f}}
+%endif
 autoreconf --force --install \
-I. \
-Ilib/replace \

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit flac for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package flac for openSUSE:Factory checked in 
at 2012-01-25 11:07:42

Comparing /work/SRC/openSUSE:Factory/flac (Old)
 and  /work/SRC/openSUSE:Factory/.flac.new (New)


Package is flac, Maintainer is ti...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/flac/flac.changes2011-11-21 
15:45:41.0 +0100
+++ /work/SRC/openSUSE:Factory/.flac.new/flac.changes   2012-01-25 
11:07:58.0 +0100
@@ -1,0 +2,8 @@
+Tue Jan 24 16:01:40 UTC 2012 - crrodrig...@opensuse.org
+
+- Support symbol visibility features
+- Disable test suite, nothing wrong with it, it just
+  takes too long to run and uses private/hidden symbols to
+  test flac's internals.
+
+---

New:

  flac-visibility.patch



Other differences:
--
++ flac.spec ++
--- /var/tmp/diff_new_pack.pcwJTX/_old  2012-01-25 11:07:59.0 +0100
+++ /var/tmp/diff_new_pack.pcwJTX/_new  2012-01-25 11:07:59.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package flac
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,8 +18,10 @@
 
 
 Name:   flac
-BuildRequires:  gcc-c++ libogg-devel pkg-config
+BuildRequires:  gcc-c++
+BuildRequires:  libogg-devel
 BuildRequires:  libtool
+BuildRequires:  pkg-config
 %ifarch %{ix86}
 BuildRequires:  nasm
 %endif
@@ -27,29 +29,36 @@
 %ifarch ppc64
 Obsoletes:  flac-64bit
 %endif
-#
-Summary:Free Lossless Audio Codec
 Version:1.2.1
 Release:83
 License:BSD-3-Clause
+#
+Summary:Free Lossless Audio Codec
+Url:http://flac.sourceforge.net/
 Group:  Productivity/Multimedia/Sound/Utilities
 Source: %{name}-%{version}.tar.bz2
 Source2:baselibs.conf
-Patch:  flac-no-xmms.diff
+# PATCH-MISSING-TAG -- See 
http://wiki.opensuse.org/openSUSE:Packaging_Patches_guidelines
+Patch0: flac-no-xmms.diff
+# PATCH-MISSING-TAG -- See 
http://wiki.opensuse.org/openSUSE:Packaging_Patches_guidelines
 Patch1: flac-printf-format-fix.diff
+# PATCH-MISSING-TAG -- See 
http://wiki.opensuse.org/openSUSE:Packaging_Patches_guidelines
 Patch2: flac-gcc43-fixes.diff
+# PATCH-MISSING-TAG -- See 
http://wiki.opensuse.org/openSUSE:Packaging_Patches_guidelines
 Patch3: flac-1.2.1-asm.patch  
+# PATCH-MISSING-TAG -- See 
http://wiki.opensuse.org/openSUSE:Packaging_Patches_guidelines
 Patch4: flac-1.2.1-bitreader.patch
+# PATCH-MISSING-TAG -- See 
http://wiki.opensuse.org/openSUSE:Packaging_Patches_guidelines
 Patch5: flac-ocloexec.patch
-Url:http://flac.sourceforge.net/
+Patch6: flac-visibility.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 FLAC is an open source lossless audio codec developed by Josh Coalson.
 
 %package -n libFLAC8
-Summary:Free Lossless Audio Codec Library
 License:BSD-3-Clause
+Summary:Free Lossless Audio Codec Library
 Group:  System/Libraries
 Obsoletes:  libflac = %{version}
 Provides:   libflac = %{version}
@@ -59,8 +68,8 @@
 developed by Josh Coalson.
 
 %package -n libFLAC++6
-Summary:Free Lossless Audio Codec Library
 License:BSD-3-Clause
+Summary:Free Lossless Audio Codec Library
 Group:  System/Libraries
 
 %description -n libFLAC++6
@@ -68,10 +77,13 @@
 Codec) developed by Josh Coalson.
 
 %package devel
-Summary:FLAC Library Development Package
 License:BSD-3-Clause
+Summary:FLAC Library Development Package
 Group:  Development/Libraries/C and C++
-Requires:   libFLAC8 = %{version} libFLAC++6 = %{version} glibc-devel 
libstdc++-devel
+Requires:   glibc-devel
+Requires:   libFLAC++6 = %{version}
+Requires:   libFLAC8 = %{version}
+Requires:   libstdc++-devel
 
 %description devel
 This package contains the files needed to compile programs that use the
@@ -79,19 +91,20 @@
 
 %prep
 %setup -q
-%patch
+%patch0
 %patch1
 %patch2
 %patch3 -p1
 %patch4
 %patch5
+%patch6
 
 %build
 autoreconf --force --install
 %define warn_flags -W -Wall -Wstrict-prototypes -Wformat-security
-export CFLAGS=$RPM_OPT_FLAGS %{warn_flags}
+export CFLAGS=%{optflags} %{warn_flags}
 export CXXFLAGS=$CFLAGS
-%configure --disable-thorough-tests \
+%configure  --disable-thorough-tests --disable-exhaustive-tests\
 --disable-xmms-plugin \
--disable-static \
--disable-rpath \
@@ -101,14 +114,11 @@
 make 

commit go for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package go for openSUSE:Factory checked in 
at 2012-01-25 11:07:46

Comparing /work/SRC/openSUSE:Factory/go (Old)
 and  /work/SRC/openSUSE:Factory/.go.new (New)


Package is go, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/go/go.changes2012-01-19 09:41:45.0 
+0100
+++ /work/SRC/openSUSE:Factory/.go.new/go.changes   2012-01-25 
11:08:01.0 +0100
@@ -1,0 +2,29 @@
+Tue Jan 24 17:28:14 UTC 2012 - gra...@andtech.eu
+
+- Add %goinstall() macro for new go tool
+- Update godoc path locations patch
+- Update go install patch (fixes building packages with go install)
+
+- Update to weekly.2012-01-20
+- The image package's Tiled type has been renamed to Repeated.
+- The encoding/xml package has been changed to make more idiomatic 
+  use of struct tags, among other things. If you use the xml package
+  please read the change description to see if your code is affected:
+   http://code.google.com/p/go/source/detail?r=70e914beb409
+- exp/sql package to database/sql
+- Package net's SetTimeout methods were changed to SetDeadline.
+- Many functions in package os now take a os.FileMode argument instead
+  of a plain uint32. An os.ModeSticky constant is also now defined.
+- The meaning of the first buffer element for image.YCbCr has changed to
+  match the semantics of the other image types like image.RGBA.
+- The NewMD5, NewSHA1 and NewSHA256 functions in crypto/hmac have been
+  deprecated. Use New instead, explicitly passing the hash function.
+
+---
+Fri Dec 30 06:12:26 UTC 2011 - gra...@andtech.eu
+
+- Patch new go install to allow -s option
+  This prevents rebuild/reinstall of std libs and allows packages
+  to be installed into a users $GOPATH
+
+---

Old:

  go-0.0.r60.3+hg20111222.tar.bz2

New:

  go-0.0.r60.3+hg20120120.tar.bz2
  go-install-dont-rebuild-std-packages.patch



Other differences:
--
++ go.spec ++
--- /var/tmp/diff_new_pack.aZUs6O/_old  2012-01-25 11:08:03.0 +0100
+++ /var/tmp/diff_new_pack.aZUs6O/_new  2012-01-25 11:08:03.0 +0100
@@ -16,8 +16,10 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
+
 Name:   go
-Version:0.0.r60.3+hg20111222
+Version:0.0.r60.3+hg20120120
 Release:0
 Summary:A compiled, garbage-collected, concurrent programming language
 License:BSD-3-Clause
@@ -36,6 +38,8 @@
 Patch2: gdb-printer.patch
 # PATCH-FIX-OPENSUSE set correct install path (GOBIN) for Make.cmd
 Patch3: go-set-make-cmd-install-path-to-gobin.patch
+# PATCH-FIX-OPENSUSE add -s flag to 'go install' (don't rebuild std libs)
+Patch4: go-install-dont-rebuild-std-packages.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  bison
 BuildRequires:  ed
@@ -91,9 +95,11 @@
 
 %prep
 %setup -q -n %{name}
+echo %{url}
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 cp %{SOURCE4} .
 
 # setup go_arch (BSD-like scheme)
@@ -156,6 +162,8 @@
 for ext in *.{go,c,h}; do
   find src -name ${ext} -exec install -Dm644 \{\} 
%{buildroot}%{_datadir}/go/\{\} \;
 done
+ln -s /usr/share/go/src/pkg $GOROOT/src/pkg
+ln -s /usr/share/go/src/cmd $GOROOT/src/cmd
 
 # replace $GOROOT in several scripts
 sed -i 's|GOROOT=.*$|GOROOT=%{_libdir}/go|g' %{buildroot}%{_bindir}/gomake

++ VERSION ++
--- /var/tmp/diff_new_pack.aZUs6O/_old  2012-01-25 11:08:03.0 +0100
+++ /var/tmp/diff_new_pack.aZUs6O/_new  2012-01-25 11:08:03.0 +0100
@@ -1 +1 @@
-weekly.2011-12-22 10879
+weekly.2012-01-15 f690897afe60

++ go-0.0.r60.3+hg20111222.tar.bz2 - go-0.0.r60.3+hg20120120.tar.bz2 ++
/work/SRC/openSUSE:Factory/go/go-0.0.r60.3+hg20111222.tar.bz2 
/work/SRC/openSUSE:Factory/.go.new/go-0.0.r60.3+hg20120120.tar.bz2 differ: char 
11, line 1

++ go-godoc-path-locations.patch ++
--- /var/tmp/diff_new_pack.aZUs6O/_old  2012-01-25 11:08:03.0 +0100
+++ /var/tmp/diff_new_pack.aZUs6O/_new  2012-01-25 11:08:03.0 +0100
@@ -1,10 +1,11 @@
-diff -ru a/src/cmd/godoc/godoc.go b/src/cmd/godoc/godoc.go
 a/src/cmd/godoc/godoc.go   2011-09-22 10:15:24.0 +0200
-+++ b/src/cmd/godoc/godoc.go   2011-09-22 10:25:35.697267470 +0200
-@@ -80,6 +80,11 @@
+diff --git a/src/cmd/godoc/godoc.go b/src/cmd/godoc/godoc.go
+--- a/src/cmd/godoc/godoc.go
 b/src/cmd/godoc/godoc.go
+@@ -88,6 +88,12 @@
pkgHandler httpHandler
  )
  
++// OPENSUSE-PATCHFIX-GODOC-LOCATIONS
 +const (
 +  docroot = /usr/share/doc/packages/go-doc/doc
 +  srcroot = /usr/share/go/
@@ -13,7 +14,7 @@
  func initHandlers() {
 

commit kde3-amarok for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package kde3-amarok for openSUSE:Factory 
checked in at 2012-01-25 11:07:50

Comparing /work/SRC/openSUSE:Factory/kde3-amarok (Old)
 and  /work/SRC/openSUSE:Factory/.kde3-amarok.new (New)


Package is kde3-amarok, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/kde3-amarok/kde3-amarok.changes  2011-10-27 
11:08:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.kde3-amarok.new/kde3-amarok.changes 
2012-01-25 11:08:03.0 +0100
@@ -1,0 +2,5 @@
+Tue Jan 24 06:04:52 UTC 2012 - an...@opensuse.org
+
+- fix build for Factory (12.2)
+
+---

Old:

  undefined-entity.diff



Other differences:
--
++ kde3-amarok.spec ++
--- /var/tmp/diff_new_pack.UHZOsu/_old  2012-01-25 11:08:05.0 +0100
+++ /var/tmp/diff_new_pack.UHZOsu/_new  2012-01-25 11:08:05.0 +0100
@@ -158,6 +158,7 @@
 
 sed -i 1i\ '#include cstddef' 
amarok/src/magnatunebrowser/magnatuneredownloaddialog.h
 sed -i 's|WFlags|Qt::WFlags|g' 
amarok/src/magnatunebrowser/magnatuneredownloaddialog.h
+sed -i 1i\ '#include cstdlib' amarok/src/mediadevice/mtp/mtpmediadevice.cpp
 
 . /etc/opt/kde3/common_options
 update_admin

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kiwi for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package kiwi for openSUSE:Factory checked in 
at 2012-01-25 11:07:56

Comparing /work/SRC/openSUSE:Factory/kiwi (Old)
 and  /work/SRC/openSUSE:Factory/.kiwi.new (New)


Package is kiwi, Maintainer is m...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/kiwi/kiwi.changes2012-01-17 
16:09:53.0 +0100
+++ /work/SRC/openSUSE:Factory/.kiwi.new/kiwi.changes   2012-01-25 
11:08:06.0 +0100
@@ -1,0 +2,191 @@
+Tue Jan 24 17:28:54 CET 2012 - m...@suse.de
+
+- v5.02.5 released
+  
+---
+Tue Jan 24 17:26:34 CET 2012 - m...@suse.de
+  
+- really fixed basePackBootIncludes to pack only files and don't
+  break if packages includes symbolic links (bnc #743159)
+  
+---
+Tue Jan 24 16:25:03 CET 2012 - m...@suse.de
+  
+- added support for oem image type for the arm architecture
+  
+---
+Tue Jan 24 15:54:23 CET 2012 - m...@suse.de
+  
+- fixed call of isohybrid, there is no -o option but -offset
+  
+---
+Tue Jan 24 09:54:19 CET 2012 - m...@suse.de
+  
+- clean ProductData, RepoMetaHandler, and Root modules to perl critic
+  
+---
+Tue Jan 24 09:53:54 CET 2012 - m...@suse.de
+  
+- eliminate previously removed SatSolverLegacy file from
+  check lists in the pre-commit hook
+  
+---
+Mon Jan 23 16:09:13 CET 2012 - m...@suse.de
+  
+- v5.02.4 released
+  
+---
+Mon Jan 23 15:53:52 CET 2012 - m...@suse.de
+  
+- check if fbiterm binary really exists and don't assume it's
+  there just because a framebuffer device exists. Also cleanup
+  the Dialog function to work without a framebuffer
+  
+---
+Mon Jan 23 14:28:43 CET 2012 - rjsch...@suse.de
+  
+- ignore additional files (emacs backup, localization, temporaries)
+  
+---
+Mon Jan 23 11:52:32 CET 2012 - m...@suse.de
+  
+- fixed setup of root partition for LVM images
+  
+---
+Mon Jan 23 10:55:16 CET 2012 - m...@suse.de
+  
+- fixed repo and config setup for RHEL6 JeOS
+  
+---
+Mon Jan 23 06:51:14 CET 2012 - rjsch...@suse.de
+  
+- create hybrid ISOs at offset 64. This fixes (bnc #742836)
+  
+---
+Fri Jan 20 15:10:33 CET 2012 - m...@suse.de
+  
+- migration changes:
+  * add support for local repo (git) checkout detection
+  * search for unpacked symlinks whose origin is packaged
+
+---
+Fri Jan 20 11:00:07 CET 2012 - m...@suse.de
+
+- migration: added support for gem inspection
+  
+---
+Thu Jan 19 17:12:14 CET 2012 - m...@suse.de
+  
+- make media check more user friendly. check if checkmedia
+  returns successfully and print a message. After that wait
+  for keypress and don't reboot (bnc #728384)
+  
+---
+Thu Jan 19 16:49:07 CET 2012 - m...@suse.de
+  
+- migration: fixed creation of unpackaged files information
+  
+---
+Thu Jan 19 11:38:28 CET 2012 - m...@suse.de
+  
+- fixed basePackBootIncludes to pack only files from boot
+  included rpm packages but not entire directories
+  
+---
+Wed Jan 18 21:03:20 CET 2012 - m...@suse.de
+  
+- make sure rhel oemboot descriptions are packaged
+  
+---
+Wed Jan 18 16:16:57 CET 2012 - m...@suse.de
+  
+- fixed RHEL6 JeOS used group names
+  
+---
+Wed Jan 18 11:55:35 CET 2012 - m...@suse.de
+  
+- removed staging/hv drivers from SLE11, they conflict with
+  the kmp package provided on SLE11
+  
+---
+Wed Jan 18 08:56:22 CET 2012 - m...@suse.de
+  
+- fixed error handling in XML info module when sources can't be found
+  
+---
+Tue Jan 17 16:56:54 CET 2012 - m...@suse.de
+  
+- DB: update schema documentation
+  

commit libgnome-keyring for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package libgnome-keyring for 
openSUSE:Factory checked in at 2012-01-25 11:08:00

Comparing /work/SRC/openSUSE:Factory/libgnome-keyring (Old)
 and  /work/SRC/openSUSE:Factory/.libgnome-keyring.new (New)


Package is libgnome-keyring, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libgnome-keyring/libgnome-keyring.changes
2012-01-06 11:45:21.0 +0100
+++ /work/SRC/openSUSE:Factory/.libgnome-keyring.new/libgnome-keyring.changes   
2012-01-25 11:08:10.0 +0100
@@ -1,0 +2,7 @@
+Mon Jan 16 16:50:31 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Fix gnome_keyring_item_info_copy()
+  + Build fixes
+
+---

Old:

  libgnome-keyring-3.3.3.tar.xz

New:

  libgnome-keyring-3.3.4.tar.xz



Other differences:
--
++ libgnome-keyring.spec ++
--- /var/tmp/diff_new_pack.MYaoF6/_old  2012-01-25 11:08:12.0 +0100
+++ /var/tmp/diff_new_pack.MYaoF6/_new  2012-01-25 11:08:12.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libgnome-keyring
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,7 +16,7 @@
 #
 
 Name:   libgnome-keyring
-Version:3.3.3
+Version:3.3.4
 Release:0
 Url:http://www.gnome.org/
 Summary:Library to integrate with the GNOME Keyring
@@ -41,6 +41,7 @@
 
 %package -n libgnome-keyring0
 Summary:Library to integrate with the GNOME Keyring
+Group:  Development/Libraries/GNOME
 Recommends: %{name}-lang
 Recommends: gnome-keyring
 # To make the lang package happy
@@ -53,6 +54,7 @@
 
 %package devel
 Summary:Library to integrate with the GNOME Keyring - Development Files
+Group:  Development/Libraries/GNOME
 Requires:   libgnome-keyring0 = %{version}
 Requires:   glib2-devel
 Provides:   gnome-keyring-devel = %{version}

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libsoup for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package libsoup for openSUSE:Factory checked 
in at 2012-01-25 11:08:05

Comparing /work/SRC/openSUSE:Factory/libsoup (Old)
 and  /work/SRC/openSUSE:Factory/.libsoup.new (New)


Package is libsoup, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/libsoup/libsoup.changes  2012-01-06 
11:46:02.0 +0100
+++ /work/SRC/openSUSE:Factory/.libsoup.new/libsoup.changes 2012-01-25 
11:08:12.0 +0100
@@ -1,0 +2,21 @@
+Tue Jan 17 07:12:34 UTC 2012 - vu...@opensuse.org
+
+- Update to version 2.37.4:
+  + SoupMessage now has a network-event signal that can be
+monitored for information about DNS, proxy lookup, TCP
+connections, and TLS handshakes.
+  + The HTTP header parsing code now avoids hitting
+g_return_if_fails() (and returns an error instead) in a few
+cases of seriously-invalid headers. [bgo#666316]
+  + POSTs and other non-idempotent requests are now always sent
+on newly-created connections. You can also force this
+behavior on other messages by setting the
+SOUP_MESSAGE_NEW_CONNECTION flag. [bgo#578990]
+  + Server-closed idle connections are now detected ahead of time
+on Windows, preventing occasional spurious Connection
+terminated unexpectedly errors. (This had been fixed on UNIX
+since 2.28, but the earlier fix didn't work with WinSock.)
+[bgo#578990]
+  + Plugged a leak in SoupRequestHTTP. [bgo#667099]
+
+---

Old:

  libsoup-2.37.3.tar.xz

New:

  libsoup-2.37.4.tar.xz



Other differences:
--
++ libsoup.spec ++
--- /var/tmp/diff_new_pack.Q6PRBH/_old  2012-01-25 11:08:14.0 +0100
+++ /var/tmp/diff_new_pack.Q6PRBH/_new  2012-01-25 11:08:14.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libsoup
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,13 +20,13 @@
 Summary:HTTP client/server library for GNOME
 License:LGPL-2.1+
 Group:  Development/Libraries/GNOME
-Version:2.37.3
+Version:2.37.4
 Release:0
 Url:http://www.gnome.org
 Source: 
http://download.gnome.org/sources/libsoup/2.37/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 BuildRequires:  glib-networking
-BuildRequires:  glib2-devel = 2.31.0
+BuildRequires:  glib2-devel = 2.31.7
 BuildRequires:  gobject-introspection-devel
 BuildRequires:  gtk-doc
 BuildRequires:  libgnome-keyring-devel

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libtorrent-rasterbar for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package libtorrent-rasterbar for 
openSUSE:Factory checked in at 2012-01-25 11:08:14

Comparing /work/SRC/openSUSE:Factory/libtorrent-rasterbar (Old)
 and  /work/SRC/openSUSE:Factory/.libtorrent-rasterbar.new (New)


Package is libtorrent-rasterbar, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/libtorrent-rasterbar/libtorrent-rasterbar.changes
2011-12-14 14:34:12.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.libtorrent-rasterbar.new/libtorrent-rasterbar.changes
   2012-01-25 11:08:15.0 +0100
@@ -1,0 +2,10 @@
+Thu Jan 19 17:06:13 UTC 2012 - fi...@opensuse.org
+
+- Upstream update to 0.15.9, bugfix release.
+
+---
+Fri Dec  9 13:19:25 UTC 2011 - jeng...@medozas.de
+
+- Remove redundant/unwanted tags/section (cf. specfile guidelines)
+
+---

Old:

  libtorrent-rasterbar-0.15.8-missing-return.patch
  libtorrent-rasterbar-0.15.8.tar.gz

New:

  libtorrent-rasterbar-0.15.9-missing-return.patch
  libtorrent-rasterbar-0.15.9.tar.gz



Other differences:
--
++ libtorrent-rasterbar.spec ++
--- /var/tmp/diff_new_pack.hr6e8n/_old  2012-01-25 11:08:16.0 +0100
+++ /var/tmp/diff_new_pack.hr6e8n/_new  2012-01-25 11:08:16.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libtorrent-rasterbar
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define _soname 6
 # for setting those bcond_with* configs see
 # http://lizards.opensuse.org/2008/09/12/conditional-features-aka-use-flags/
@@ -22,14 +23,14 @@
 %bcond_with examples
 
 Name:   libtorrent-rasterbar
-Version:0.15.8
+Version:0.15.9
 Release:0
 Summary:Libtorrent is a C++ implementation of the BitTorrent protocol
 License:BSD-3-Clause
 Group:  Development/Libraries/C and C++
 Url:http://www.rasterbar.com/products/libtorrent/
 Source: 
http://libtorrent.googlecode.com/files/%{name}-%{version}.tar.gz
-Patch0: libtorrent-rasterbar-0.15.8-missing-return.patch
+Patch0: libtorrent-rasterbar-0.15.9-missing-return.patch
 BuildRequires:  boost-devel = 1.36
 BuildRequires:  gcc-c++
 BuildRequires:  libGeoIP-devel
@@ -135,9 +136,6 @@
 mkdir -p %{buildroot}%{_defaultdocdir}/%{name}
 install -m 644 docs/* %{buildroot}%{_defaultdocdir}/%{name}/
 
-%clean
-%{?buildroot:rm -rf %{buildroot}}
-
 %post  -n %{name}%{_soname} -p /sbin/ldconfig
 
 %postun -n %{name}%{_soname} -p /sbin/ldconfig

++ libtorrent-rasterbar-0.15.8-missing-return.patch - 
libtorrent-rasterbar-0.15.9-missing-return.patch ++

++ libtorrent-rasterbar-0.15.8.tar.gz - libtorrent-rasterbar-0.15.9.tar.gz 
++
 4107 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libvisual for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package libvisual for openSUSE:Factory 
checked in at 2012-01-25 11:08:18

Comparing /work/SRC/openSUSE:Factory/libvisual (Old)
 and  /work/SRC/openSUSE:Factory/.libvisual.new (New)


Package is libvisual, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/libvisual/libvisual.changes  2011-10-25 
16:09:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.libvisual.new/libvisual.changes 2012-01-25 
11:08:20.0 +0100
@@ -1,0 +2,5 @@
+Tue Nov 22 10:20:46 UTC 2011 - co...@suse.com
+
+- add libtool as buildrequire to avoid implicit dependency
+
+---



Other differences:
--
++ libvisual.spec ++
--- /var/tmp/diff_new_pack.rEwVk0/_old  2012-01-25 11:08:21.0 +0100
+++ /var/tmp/diff_new_pack.rEwVk0/_new  2012-01-25 11:08:21.0 +0100
@@ -15,11 +15,10 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
 
 
 Name:   libvisual
-BuildRequires:  freeglut-devel gcc-c++ libdrm-devel pkgconfig
+BuildRequires:  freeglut-devel gcc-c++ libdrm-devel libtool pkgconfig
 License:GPLv2+ ; LGPLv2.1+
 Group:  Productivity/Multimedia/Sound/Visualization
 Version:0.4.0

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit lifelines for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package lifelines for openSUSE:Factory 
checked in at 2012-01-25 11:08:22

Comparing /work/SRC/openSUSE:Factory/lifelines (Old)
 and  /work/SRC/openSUSE:Factory/.lifelines.new (New)


Package is lifelines, Maintainer is wer...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/lifelines/lifelines.changes  2011-09-23 
02:11:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.lifelines.new/lifelines.changes 2012-01-25 
11:08:24.0 +0100
@@ -1,0 +2,10 @@
+Wed Dec 21 10:31:40 UTC 2011 - co...@suse.com
+
+- remove call to suse_update_config (very old work around)
+
+---
+Fri Dec  2 15:54:29 UTC 2011 - co...@suse.com
+
+- add automake as buildrequire to avoid implicit dependency
+
+---



Other differences:
--
++ lifelines.spec ++
--- /var/tmp/diff_new_pack.vHMIqr/_old  2012-01-25 11:08:25.0 +0100
+++ /var/tmp/diff_new_pack.vHMIqr/_new  2012-01-25 11:08:25.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package lifelines (Version 3.0.62)
+# spec file for package lifelines
 #
-# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,19 +15,32 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   lifelines
-BuildRequires:  bison docbook-utils dos2unix libjpeg-devel libpng 
libxslt-devel ncurses-devel perl-XML-DOM perl-XML-Parser perl-XML-SAX 
perl-libwww-perl texlive texlive-jadetex texlive-latex texlive-xmltex tidy
+BuildRequires:  automake
+BuildRequires:  bison
+BuildRequires:  docbook-utils
+BuildRequires:  dos2unix
+BuildRequires:  libjpeg-devel
+BuildRequires:  libpng
+BuildRequires:  libxslt-devel
+BuildRequires:  ncurses-devel
+BuildRequires:  perl-XML-DOM
+BuildRequires:  perl-XML-Parser
+BuildRequires:  perl-XML-SAX
+BuildRequires:  perl-libwww-perl
+BuildRequires:  texlive
+BuildRequires:  texlive-jadetex
+BuildRequires:  texlive-latex
+BuildRequires:  texlive-xmltex
+BuildRequires:  tidy
 Url:http://lifelines.sourceforge.net/
-License:MIT License (or similar)
-Group:  Productivity/Scientific/Other
-AutoReqProv:on
 Version:3.0.62
-Release:111
+Release:0
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Summary:The Lifelines Genealogy Program
+License:MIT
+Group:  Productivity/Scientific/Other
 Source: 
http://download.sourceforge.net/lifelines/lifelines-3.0.62.tar.bz2
 Source1:sh.rellink
 Patch:  lifelines-3.0.62.dif
@@ -64,9 +77,6 @@
 CPPFLAGS=-D_GNU_SOURCE -D_XOPEN_CURSES
 CC=gcc
 export CC CFLAGS CPPFLAGS
-%{?suse_update_config build/autotools/}
-%{?suse_update_config build/gettext/}
-%{?suse_update_config}
 autoreconf -fi
 ./configure --prefix=%{_prefix} -exec-prefix=%{_prefix}\
--libexecdir=%{_libdir} \

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit obs-service-format_spec_file for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package obs-service-format_spec_file for 
openSUSE:Factory checked in at 2012-01-25 11:08:27

Comparing /work/SRC/openSUSE:Factory/obs-service-format_spec_file (Old)
 and  /work/SRC/openSUSE:Factory/.obs-service-format_spec_file.new (New)


Package is obs-service-format_spec_file, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/obs-service-format_spec_file/obs-service-format_spec_file.changes
2012-01-24 12:20:03.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.obs-service-format_spec_file.new/obs-service-format_spec_file.changes
   2012-01-25 11:08:29.0 +0100
@@ -1,0 +2,5 @@
+Wed Jan 25 08:18:28 UTC 2012 - co...@suse.com
+
+- another update from license list
+
+---



Other differences:
--
++ licenses_changes.txt ++
--- /var/tmp/diff_new_pack.7A3H3g/_old  2012-01-25 11:08:30.0 +0100
+++ /var/tmp/diff_new_pack.7A3H3g/_new  2012-01-25 11:08:30.0 +0100
@@ -18,6 +18,7 @@
 Apache-2.0 Apache License, Version 2.0
 Apache-2.0 Apache Software License ..
 Apache-2.0 Apache Software License
+Apache-2.0 Apache Software License, Version 2.0
 Apache-2.0 Apache v2.0
 Apache-1.0 Apache-1.0
 Apache-1.1 Apache-1.1
@@ -202,6 +203,7 @@
 GPL-3.0GPL-3
 GPL-3.0GPL-3.0
 GPL-3.0-with-autoconf-exceptionGPL-3.0-with-autoconf-exception
+SUSE-GPL-3.0+-with-autoconf-exception  GPLv3+ with exceptions
 GPL-3.0-with-GCC-exception GPL-3.0-with-GCC-exception
 GPL-3.0+   GPL-3.0+
 GPL-3.0+   GPL-3+
@@ -313,6 +315,7 @@
 SUSE-Public-Domain Public Domain
 SUSE-Public-Domain Public Domain, Freeware
 SUSE-Public-Domain Public Domain. See http://www.sentex.ca/~mw
+SUSE-Python-1.6CNRI 
(http://www.handle.net/python_licenses/python1.6_9-5-00.html)
 Python-2.0 Python
 Python-2.0 Python ..
 Python-2.0 Python Copyright
@@ -364,4 +367,5 @@
 ZPL-2.1ZPL-2.1
 SUSE-Firmware  Firmware license, redistributable unmodified
 SUSE-PermissiveMust not be copyleft. Must not contain patent clauses 
of any nature. Most not limit ability to copy, modifiy, distribute (through 
multiple tiers of distribution) and distribute modified versions. Must not 
impose obligations such as 'advertising clauses' or anything that could be 
viewed as an 'additional restriction' under GPL-2.0+ or GPL-3.0+. Must not 
impose obligations such as modification by patch only, or reciprocal clauses.
-Artistic-1.0 or GPL-1.0+   Perl License
\ No newline at end of file
+Artistic-1.0 or GPL-1.0+   Perl License
+SUSE-NonFree   NonFree licenses
\ No newline at end of file

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit patchutils for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package patchutils for openSUSE:Factory 
checked in at 2012-01-25 11:08:32

Comparing /work/SRC/openSUSE:Factory/patchutils (Old)
 and  /work/SRC/openSUSE:Factory/.patchutils.new (New)


Package is patchutils, Maintainer is sndir...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/patchutils/patchutils.changes2011-09-23 
12:21:43.0 +0200
+++ /work/SRC/openSUSE:Factory/.patchutils.new/patchutils.changes   
2012-01-25 11:08:34.0 +0100
@@ -1,0 +2,5 @@
+Fri Dec  2 16:30:33 UTC 2011 - co...@suse.com
+
+- add automake as buildrequire to avoid implicit dependency
+
+---



Other differences:
--
++ patchutils.spec ++
--- /var/tmp/diff_new_pack.nXJpFZ/_old  2012-01-25 11:08:35.0 +0100
+++ /var/tmp/diff_new_pack.nXJpFZ/_new  2012-01-25 11:08:35.0 +0100
@@ -15,17 +15,14 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   patchutils
 Url:http://cyberelk.net/tim/patchutils/
-License:GPLv2+
+License:GPL-2.0+
 Group:  Productivity/File utilities
 Requires:   patch diffutils
-AutoReqProv:on
+BuildRequires:  automake
 Version:0.3.2
-Release:3
+Release:0
 Summary:A Collection of Tools for Manipulating Patch Files
 Source: 
http://cyberelk.net/tim/data/patchutils/stable/patchutils-%{version}.tar.bz2
 Patch:  %name-0.2.30-tailsyntax.diff

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit pciutils-ids for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package pciutils-ids for openSUSE:Factory 
checked in at 2012-01-25 11:08:37

Comparing /work/SRC/openSUSE:Factory/pciutils-ids (Old)
 and  /work/SRC/openSUSE:Factory/.pciutils-ids.new (New)


Package is pciutils-ids, Maintainer is vci...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/pciutils-ids/pciutils-ids.changes
2012-01-19 09:43:54.0 +0100
+++ /work/SRC/openSUSE:Factory/.pciutils-ids.new/pciutils-ids.changes   
2012-01-25 11:08:39.0 +0100
@@ -2 +2 @@
-Sat Jan 14 18:40:05 CET 2012 - autobu...@suse.de
+Sat Jan 21 18:40:40 CET 2012 - autobu...@suse.de
@@ -4 +4 @@
-- automated update on 2012-01-14
+- automated update on 2012-01-21



Other differences:
--
++ pciutils-ids.spec ++
--- /var/tmp/diff_new_pack.eMlj2h/_old  2012-01-25 11:08:57.0 +0100
+++ /var/tmp/diff_new_pack.eMlj2h/_new  2012-01-25 11:08:57.0 +0100
@@ -19,7 +19,7 @@
 
 
 Name:   pciutils-ids
-Version:2012.1.14
+Version:2012.1.18
 Release:1
 AutoReqProv:on
 Group:  Hardware/Other

++ pci.ids.bz2 ++
--- /var/tmp/diff_new_pack.eMlj2h/_old  2012-01-25 11:08:58.0 +0100
+++ /var/tmp/diff_new_pack.eMlj2h/_new  2012-01-25 11:08:58.0 +0100
@@ -1,8 +1,8 @@
 #
 #  List of PCI ID's
 #
-#  Version: 2012.01.14
-#  Date:2012-01-14 15:34:18
+#  Version: 2012.01.18
+#  Date:2012-01-18 03:15:02
 #
 #  Maintained by Martin Mares m...@ucw.cz and other volunteers from the
 #  PCI ID Project at http://pci-ids.ucw.cz/.
@@ -4143,7 +4143,7 @@
ba57  eXtremeRAID 4000/5000 support Device
1069 0072  eXtremeRAID 5000 support Device
 106a  Aten Research Inc
-106b  Apple Computer Inc.
+106b  Apple Inc.
0001  Bandit PowerPC host bridge
0002  Grand Central I/O
0003  Control Video
@@ -5453,7 +5453,7 @@
 10dd  Evans  Sutherland
0100  Lightning 1200
10dd 0023  Lightning 1200 15+16M
-10de  nVidia Corporation
+10de  NVIDIA Corporation
0008  NV1 [EDGE 3D]
0009  NV1 [EDGE 3D]
0010  NV2 [Mutara V08]
@@ -6430,6 +6430,7 @@
1849 03f6  939NF6G-VSTA Board
03f7  MCP61 SATA Controller
0400  G84 [GeForce 8600 GTS]
+   1043 8241  EN8600GTS
0401  G84 [GeForce 8600GT]
0402  G84 [GeForce 8600 GT]
1462 0910  NX8600GT-T2D256EZ
@@ -7294,7 +7295,7 @@
1462 7522  X58 Pro-E
1775 11cc  CC11/CL11
1849 8168  Motherboard (one of many)
-   8086 d615  DeskTop Board D510MO
+   8086 d615  Desktop Board D510MO
8169  RTL-8169 Gigabit Ethernet
1025 0079  Aspire 5024WLMi
10bd 3202  EP-320G-TX1 32-bit PCI Gigabit Ethernet Adapter
@@ -7421,6 +7422,7 @@
1102 1009  SB Audigy2 OEM HP
1102 2002  SB Audigy 2 ZS (SB0350)
1102 4001  E-MU 1010
+   1102 4002  E-MU 0404
0005  SB X-Fi
1102 0021  X-Fi Platinum
1102 002c  X-Fi XtremeGamer FATAL1TY PRO
@@ -7495,6 +7497,7 @@
2340  RocketRAID 2340 16 Port SATA-II Controller
2640  RocketRAID 2640 SAS/SATA Controller
2722  RocketRAID 2722
+   3120  RocketRAID 3120
3220  RocketRAID 3220
3320  RocketRAID 3320
 1104  RasterOps Corp.
@@ -9527,8 +9530,7 @@
 11be  International Microcircuits Inc
 11bf  Astrodesign, Inc.
 11c0  Hewlett Packard
-# Nee Lucent Microelectronics
-11c1  Agere Systems
+11c1  nee Agere Systems nee Lucent Microelectronics
0440  56k WinModem
1033 8015  LT WinModem 56k Data+Fax+Voice+Dsvd
1033 8047  LT WinModem 56k Data+Fax+Voice+Dsvd
@@ -14387,15 +14389,21 @@
1924 6204  SFN5122F-R4
1924 6205  SFN5122F-R5
1924 6206  SFN5122F-R6
+   1924 6207  SFN5122F-R7
1924 6210  SFN5322F-R0
1924 6211  SFN5322F-R1
+   1924 6217  SFN5322F-R7
+   1924 6227  SFN6122F-R7
+   1924 6237  SFN6322F-R7
1924 6501  SFN5802K-R1
1924 6511  SFN5814H-R1
1924 6521  SFN5812H-R1
1924 6a05  SFN5112F-R5
1924 6a06  SFN5112F-R6
1924 7206  SFN5162F-R6
+   1924 7207  SFN5162F-R7
1924 7a06  SFN5152F-R6
+   1924 7a07  SFN5152F-R7
0813  SFL9021 [Solarstorm]
1924 6100  SFN5121T-R0
1924 6102  SFN5121T-R2
@@ -16002,8 +16010,8 @@
17aa 2001  ThinkPad T60
17aa 207e  ThinkPad X60s

commit ppl for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package ppl for openSUSE:Factory checked in 
at 2012-01-25 11:08:42

Comparing /work/SRC/openSUSE:Factory/ppl (Old)
 and  /work/SRC/openSUSE:Factory/.ppl.new (New)


Package is ppl, Maintainer is rguent...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/ppl/ppl.changes  2011-09-23 12:41:49.0 
+0200
+++ /work/SRC/openSUSE:Factory/.ppl.new/ppl.changes 2012-01-25 
11:08:58.0 +0100
@@ -1,0 +2,5 @@
+Mon Jan 23 17:22:51 CET 2012 - meiss...@suse.de
+
+- include /usr/share/aclocal directory as we no longer require autoconf
+
+---



Other differences:
--
++ ppl-testsuite.spec ++
--- /var/tmp/diff_new_pack.OQwWmJ/_old  2012-01-25 11:09:25.0 +0100
+++ /var/tmp/diff_new_pack.OQwWmJ/_new  2012-01-25 11:09:25.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package ppl-testsuite
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,18 +15,17 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   ppl-testsuite
 Version:0.11.2
-Release:2
+Release:0
 Summary:The Parma Polyhedra Library
-Group:  Development/Libraries/C and C++
 License:GPL-3.0+
+Group:  Development/Libraries/C and C++
 Url:http://www.cs.unipr.it/ppl/
 Source: ppl-%{version}.tar.bz2
 Source1:baselibs.conf
-BuildRequires:  c++_compiler gmp-devel = 4.1.3
+BuildRequires:  c++_compiler
+BuildRequires:  gmp-devel = 4.1.3
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -45,7 +44,6 @@
 
 
 %package devel
-License:GPL-3.0+
 Summary:Development tools for the Parma Polyhedra Library C and C++ 
interfaces
 Group:  Development/Libraries/C and C++
 Requires:   libppl9 = %{version}-%{release}
@@ -63,7 +61,6 @@
 
 
 %package devel-static
-License:GPL-3.0+
 Summary:Static libraries for the Parma Polyhedra Library C and C++ 
interfaces
 Group:  Development/Libraries/C and C++
 Requires:   ppl-devel = %{version}-%{release}
@@ -77,7 +74,6 @@
 
 
 %package -n libppl9
-License:GPL-3.0+
 Summary:Shared library for the Parma Polyhedra Library
 Group:  Development/Libraries/C and C++
 
@@ -87,7 +83,6 @@
 
 
 %package -n libppl_c4
-License:GPL-3.0+
 Summary:Shared library for the Parma Polyhedra Library C bindings
 Group:  Development/Libraries/C and C++
 
@@ -97,7 +92,6 @@
 
 
 %package doc
-License:GPL-3.0+
 Summary:Documentation for the Parma Polyhedra Library
 Group:  Development/Libraries/C and C++
 %if 0%{?suse_version} = 1120

++ ppl.spec ++
--- /var/tmp/diff_new_pack.OQwWmJ/_old  2012-01-25 11:09:25.0 +0100
+++ /var/tmp/diff_new_pack.OQwWmJ/_new  2012-01-25 11:09:25.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package ppl
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,18 +15,17 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   ppl
 Version:0.11.2
-Release:4
+Release:0
 Summary:The Parma Polyhedra Library
-Group:  Development/Libraries/C and C++
 License:GPL-3.0+
+Group:  Development/Libraries/C and C++
 Url:http://www.cs.unipr.it/ppl/
 Source: ppl-%{version}.tar.bz2
 Source1:baselibs.conf
-BuildRequires:  c++_compiler gmp-devel = 4.1.3
+BuildRequires:  c++_compiler
+BuildRequires:  gmp-devel = 4.1.3
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -45,7 +44,6 @@
 
 
 %package devel
-License:GPL-3.0+
 Summary:Development tools for the Parma Polyhedra Library C and C++ 
interfaces
 Group:  Development/Libraries/C and C++
 Requires:   libppl9 = %{version}-%{release}
@@ -63,7 +61,6 @@
 
 
 %package devel-static
-License:GPL-3.0+
 Summary:Static libraries for the Parma Polyhedra Library C and C++ 
interfaces
 Group:  Development/Libraries/C and C++
 Requires:   ppl-devel = %{version}-%{release}
@@ -77,7 +74,6 @@
 
 
 %package -n libppl9
-License:GPL-3.0+
 Summary:Shared 

commit qt-gstreamer for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package qt-gstreamer for openSUSE:Factory 
checked in at 2012-01-25 11:08:47

Comparing /work/SRC/openSUSE:Factory/qt-gstreamer (Old)
 and  /work/SRC/openSUSE:Factory/.qt-gstreamer.new (New)


Package is qt-gstreamer, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/qt-gstreamer/qt-gstreamer.changes
2012-01-04 07:30:59.0 +0100
+++ /work/SRC/openSUSE:Factory/.qt-gstreamer.new/qt-gstreamer.changes   
2012-01-25 11:09:25.0 +0100
@@ -1,0 +2,7 @@
+Tue Jan 24 20:46:40 UTC 2012 - cgiboude...@gmx.com
+
+- Add fix-build.diff.
+Only glib.h can be included directly.
+
+
+---

New:

  fix-build.diff



Other differences:
--
++ qt-gstreamer.spec ++
--- /var/tmp/diff_new_pack.alpLk0/_old  2012-01-25 11:09:26.0 +0100
+++ /var/tmp/diff_new_pack.alpLk0/_new  2012-01-25 11:09:26.0 +0100
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   qt-gstreamer
 Url:http://gstreamer.freedesktop.org/wiki/QtGStreamer
 BuildRequires:  bison
@@ -33,6 +34,7 @@
 Patch0: fix-install-path.diff
 # PATCH-FIX-UPSTREAM qt-gstreamer-glib2.patch bgo#653266 idoen...@suse.de -- 
Fix compilation with new glib2
 Patch1: qt-gstreamer-glib2.patch
+Patch2: fix-build.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -113,6 +115,7 @@
 %setup -q -n qt-gstreamer-%{version}
 %patch0
 %patch1
+%patch2
 
 %build
   %cmake_kde4 -d build -- -DQTGSTREAMER_STATIC=OFF

++ fix-build.diff ++
--- src/QGlib/error.cpp.orig2012-01-24 21:39:53.015727828 +0100
+++ src/QGlib/error.cpp 2012-01-24 21:40:35.027199674 +0100
@@ -15,7 +15,7 @@
 along with this program.  If not, see http://www.gnu.org/licenses/.
 */
 #include error.h
-#include glib/gerror.h
+#include glib.h
 #include QtCore/QDebug
 
 namespace QGlib {
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit quilt for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package quilt for openSUSE:Factory checked 
in at 2012-01-25 11:08:51

Comparing /work/SRC/openSUSE:Factory/quilt (Old)
 and  /work/SRC/openSUSE:Factory/.quilt.new (New)


Package is quilt, Maintainer is jdelv...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/quilt/quilt.changes  2011-12-21 
14:58:37.0 +0100
+++ /work/SRC/openSUSE:Factory/.quilt.new/quilt.changes 2012-01-25 
11:09:26.0 +0100
@@ -1,0 +2,27 @@
+Tue Jan 17 21:34:30 CET 2012 - jdelv...@suse.de
+
+- inspect-remap-outputs.patch,
+  inspect-check-if-wrapper-executable.patch: inspect: Report if
+  patch/tar wrapper can't be executed (quilt setup).
+
+---
+Fri Dec 16 14:41:39 CET 2011 - jdelv...@suse.de
+
+- Fix two rpmlint warnings.
+
+---
+Fri Dec 16 11:53:53 CET 2011 - jdelv...@suse.de
+
+- Don't call autoconf during build, assume configure script is
+  already up-to-date. This avoids problems when version of autoconf
+  is too old.
+
+---
+Thu Dec 15 15:18:04 CET 2011 - jdelv...@suse.de
+
+- Delete docdir.diff, replaced with
+  substitute-docdir-in-man-page.patch and
+  change-docdir-definition.patch. Upstream solution for the same
+  problem.
+
+---

Old:

  docdir.diff

New:

  change-docdir-definition.patch
  inspect-check-if-wrapper-executable.patch
  inspect-remap-outputs.patch
  patchfns-non-exec.patch
  substitute-docdir-in-man-page.patch



Other differences:
--
++ quilt.spec ++
--- /var/tmp/diff_new_pack.IgyFdk/_old  2012-01-25 11:09:27.0 +0100
+++ /var/tmp/diff_new_pack.IgyFdk/_new  2012-01-25 11:09:27.0 +0100
@@ -36,12 +36,16 @@
 Source: %{name}-%{version}.tar.bz2
 Source1:suse-start-quilt-mode.el
 Patch1: expand.diff
-Patch2: docdir.diff
+Patch2: substitute-docdir-in-man-page.patch
 Patch3: patch-wrapper-rpm.diff
 Patch4: grep-support-spaces.patch
 Patch5: suse-workaround-pseudo-release.patch
 Patch6: mail-fix-delivery-address-checking.patch
 Patch7: fix-inspect.patch
+Patch8: change-docdir-definition.patch
+Patch9: patchfns-non-exec.patch
+Patch10:inspect-remap-outputs.patch
+Patch11:inspect-check-if-wrapper-executable.patch
 Url:http://savannah.nongnu.org/projects/quilt
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
@@ -68,9 +72,12 @@
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
 
 %build
-autoconf
 # --with-rpmbuild=/usr/lib/rpm/rpmb:
 #
 #   SUSE Autobuild uses a version of /usr/bin/rpmbuild that sources
@@ -80,12 +87,13 @@
 CFLAGS=$RPM_OPT_FLAGS \
 ./configure --prefix=/usr \
 --mandir=%{_mandir} \
+--docdir=%{_docdir}/%{name} \
 --with-sendmail=/usr/sbin/sendmail \
 --with-diffstat=/usr/bin/diffstat \
 --with-patch-wrapper \
 --with-patch=/usr/bin/patch \
 --with-rpmbuild=/usr/lib/rpm/rpmb
-make %{?jobs:-j%jobs} BUILD_ROOT=$RPM_BUILD_ROOT RELEASE=%release
+make %{?jobs:-j%jobs} RELEASE=%release
 # Compile quilt.el for faster emacs startup (bnc#617673)
 pushd lib
 emacs -batch -q --no-site -f batch-byte-compile quilt.el
@@ -102,8 +110,6 @@
 install -m 644 lib/quilt.elc \
$RPM_BUILD_ROOT/usr/share/emacs/site-lisp/
 mv $RPM_BUILD_ROOT/etc/bash_completion.d/quilt{,.sh}
-#make rpmlint happy
-chmod 755 $RPM_BUILD_ROOT/%{_datadir}/quilt/scripts/patchfns
 # We only needed the /usr/bin/patch compatibility symlink for the
 # test suite.
 [ $RPM_BUILD_ROOT/usr/share/quilt/compat/patch -ef /usr/bin/patch ] \

++ change-docdir-definition.patch ++
---
 Makefile.in  |   13 +++--
 configure.ac |7 +--
 2 files changed, 8 insertions(+), 12 deletions(-)

--- a/Makefile.in
+++ b/Makefile.in
@@ -1,6 +1,7 @@
 PACKAGE := @PACKAGE_NAME@
 VERSION := @PACKAGE_VERSION@
 RELEASE := @PACKAGE_RELEASE@
+PACKAGE_TARNAME := @PACKAGE_TARNAME@
 PACKAGE_BUGREPORT := @PACKAGE_BUGREPORT@
 
 prefix :=  @prefix@
@@ -213,7 +214,7 @@ doc/quilt.1: doc/quilt.1.in $(QUILT:%=qu
;;  \
  *@DOCSUBDIR@*)\
echo $$line | \
-   $(SED) -e 's:@DOCSUBDIR''@:$(docdir)/$(PACKAGE)-$(VERSION):g' \
+   $(SED) -e 's:@DOCSUBDIR''@:$(docdir):g' \
;;  \
  *) 

commit rpm for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package rpm for openSUSE:Factory checked in 
at 2012-01-25 11:08:59

Comparing /work/SRC/openSUSE:Factory/rpm (Old)
 and  /work/SRC/openSUSE:Factory/.rpm.new (New)


Package is rpm, Maintainer is m...@suse.com

Changes:

New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ /work/SRC/openSUSE:Factory/.rpm.new/python3-rpm.changes 2012-01-25 
11:09:28.0 +0100
@@ -0,0 +1,13 @@
+---
+Tue Jan 17 10:29:20 UTC 2012 - sasc...@suse.de
+
+- Spec file cleanup:
+  * Don't rm -rf %{buildroot}
+  * Removed %clean section
+  * Removed authors from description
+
+---
+Mon Jan  9 17:12:41 CET 2012 - dmuel...@suse.de
+
+- Initial package
+
--- /work/SRC/openSUSE:Factory/rpm/rpm-python.changes   2011-12-12 
17:04:12.0 +0100
+++ /work/SRC/openSUSE:Factory/.rpm.new/rpm-python.changes  2012-01-25 
11:09:28.0 +0100
@@ -1,0 +2,8 @@
+Tue Jan 17 10:28:42 UTC 2012 - sasc...@suse.de
+
+- Spec file cleanup:
+  * Don't rm -rf %{buildroot}
+  * Removed %clean section
+  * Removed authors from description
+
+---
--- /work/SRC/openSUSE:Factory/rpm/rpm.changes  2012-01-11 15:38:54.0 
+0100
+++ /work/SRC/openSUSE:Factory/.rpm.new/rpm.changes 2012-01-25 
11:09:28.0 +0100
@@ -1,0 +2,29 @@
+Tue Jan 17 10:28:00 UTC 2012 - sasc...@suse.de
+
+- Spec file cleanup:
+  * Removed authors from description
+  * Spec-cleaner
+
+---
+Mon Jan 16 16:18:59 UTC 2012 - lnus...@suse.de
+
+- fix automatic kernel supplements (bnc#741543)
+
+---
+Mon Jan 16 14:12:58 UTC 2012 - wer...@suse.de
+
+- Add patch from upstream to reflect changes of perl and python
+  fileattrs to file 5.10 magics
+
+---
+Fri Jan 13 14:16:14 UTC 2012 - co...@suse.com
+
+- split rpmbuild into a package of its own, which then requires basic
+  tools to build rpms
+
+---
+Mon Jan  9 17:12:05 CET 2012 - dmuel...@suse.de
+
+- add a python3-rpm subspecfile
+
+---

New:

  perl-python-attr.patch
  python3-abi-kind.diff
  python3-rpm.changes
  python3-rpm.spec



Other differences:
--
++ python3-rpm.spec ++
#
# spec file for package python3-rpm
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:   python3-rpm
Version:4.9.1.2
Release:0
#!BuildIgnore:  rpmlint-Factory
Summary:Python Bindings for Manipulating RPM Packages
License:GPL-2.0+
Group:  System/Packages
Source99:   rpm.spec
BuildRequires:  file-devel
BuildRequires:  libacl-devel
BuildRequires:  libbz2-devel
BuildRequires:  libcap-devel
BuildRequires:  libelf-devel
BuildRequires:  libselinux-devel
BuildRequires:  libsemanage-devel
BuildRequires:  libtool
BuildRequires:  lua51-devel
BuildRequires:  ncurses-devel
BuildRequires:  popt-devel
BuildRequires:  python3-devel
BuildRequires:  xz-devel
BuildRequires:  zlib-devel
Requires:   rpm = %{version}
%{expand:%(sed -n -e '/^Source:/,/^BuildRoot:/p' %_sourcedir/rpm.spec)}
%global with_python 1

%description
The python3-rpm package contains a module that permits applications
written in the Python programming language to use the interface
supplied by RPM Package Manager libraries.

This package should be installed if you want to develop Python programs
that will manipulate RPM packages and databases.

%prep
%{expand:%(sed -n -e '/^%%prep/,/^%%install/p' %_sourcedir/rpm.spec | sed -e 
'1d' -e '$d')}

%install
mkdir -p %{buildroot}%{_prefix}/lib
# only installing in python/ does not work because rpm links against
# installed libs at install time
%make_install
find %{buildroot} -not -type d -and -not -path 

commit stardict for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package stardict for openSUSE:Factory 
checked in at 2012-01-25 11:09:05

Comparing /work/SRC/openSUSE:Factory/stardict (Old)
 and  /work/SRC/openSUSE:Factory/.stardict.new (New)


Package is stardict, Maintainer is dmzh...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/stardict/stardict.changes2011-12-13 
11:50:03.0 +0100
+++ /work/SRC/openSUSE:Factory/.stardict.new/stardict.changes   2012-01-25 
11:09:36.0 +0100
@@ -1,0 +2,12 @@
+Tue Jan 24 19:43:03 UTC 2012 - kkir...@opensuse.org
+
+- added stardict-3.0.3-fix-glib_h-include.patch to include only
+  glib.h
+
+---
+Tue Dec 27 15:26:16 UTC 2011 - idon...@suse.com
+
+- added stardict-3.0.3-wrong-memset.patch to fix wrong size
+  parameter in memset call 
+
+---

New:

  stardict-3.0.3-fix-glib_h-include.patch
  stardict-3.0.3-wrong-memset.patch



Other differences:
--
++ stardict.spec ++
--- /var/tmp/diff_new_pack.g1Qgte/_old  2012-01-25 11:09:37.0 +0100
+++ /var/tmp/diff_new_pack.g1Qgte/_new  2012-01-25 11:09:37.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package stardict
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,11 +19,11 @@
 
 Name:   stardict
 Version:3.0.3
-Release:1
-License:GPLv3
+Release:0
 Summary:A cross-platform and internationalized dictionary
-Url:http://code.google.com/p/stardict-3/
+License:GPL-3.0
 Group:  Productivity/Office/Dictionary
+Url:http://code.google.com/p/stardict-3/
 Source0:%{name}-%{version}.tar.bz2
 Source1:ru.po
 # PATCH-FIX-OPENSUSE stardict-3.0.3-fix-path-for-sounds.patch -- adjust 
default path for sound files
@@ -34,7 +34,11 @@
 Patch2: stardict-3.0.3-gcc46.patch
 # PATCH-FIX-UPSTREAM stardict-3.0.3-NetDictRequest.patch -- rebased from Arch 
Linux package
 Patch3: stardict-3.0.3-NetDictRequest.patch
+# PATCH-FIX-UPSTREAM stardict-wrong-memset.patch idoen...@suse.de -- Fix wrong 
memset size parameter
+Patch4: stardict-3.0.3-wrong-memset.patch
 %if 0%{?suse_version}
+# PATCH-FIX-UPSTREAM stardict-3.0.3-fix-glib_h-include.patch 
kkir...@opensuse.org -- Fix glib.h include
+Patch5: stardict-3.0.3-fix-glib_h-include.patch
 BuildRequires:  update-desktop-files
 %endif
 BuildRequires:  enchant-devel
@@ -72,6 +76,8 @@
 %patch1
 %patch2
 %patch3
+%patch4
+%patch5
 cp %{SOURCE1} dict/po/
 
 # Remove unneeded sigc++ header files to make it sure

++ stardict-3.0.3-fix-glib_h-include.patch ++
Index: dict/src/tomboykeybinder.h
===
--- dict/src/tomboykeybinder.h.orig
+++ dict/src/tomboykeybinder.h
@@ -21,7 +21,7 @@
 #ifndef __TOMBOY_KEY_BINDER_H__
 #define __TOMBOY_KEY_BINDER_H__
 
-#include glib/gtypes.h
+#include glib.h
 
 G_BEGIN_DECLS
 
++ stardict-3.0.3-wrong-memset.patch ++
Index: dict/src/lib/md5.c
===
--- dict/src/lib/md5.c.orig
+++ dict/src/lib/md5.c
@@ -163,7 +163,7 @@ void MD5Final(unsigned char digest[16],
 MD5Transform(ctx-buf, (uint32 *) ctx-in);
 byteReverse((unsigned char *) ctx-buf, 4);
 memcpy(digest, ctx-buf, 16);
-memset(ctx, 0, sizeof(ctx));   /* In case it's sensitive */
+memset(ctx, 0, sizeof(struct MD5Context)); /* In case it's sensitive */
 }
 
 #ifndef ASM_MD5
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit usbmuxd for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package usbmuxd for openSUSE:Factory checked 
in at 2012-01-25 11:09:10

Comparing /work/SRC/openSUSE:Factory/usbmuxd (Old)
 and  /work/SRC/openSUSE:Factory/.usbmuxd.new (New)


Package is usbmuxd, Maintainer is sts...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/usbmuxd/usbmuxd.changes  2011-09-23 
12:49:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.usbmuxd.new/usbmuxd.changes 2012-01-25 
11:09:37.0 +0100
@@ -1,0 +2,5 @@
+Fri Jan 20 13:06:47 UTC 2012 - co...@suse.com
+
+- remove _service, too fragile
+
+---

Old:

  _service
  _service:download_url:usbmuxd-1.0.7.tar.bz2

New:

  usbmuxd-1.0.7.tar.bz2



Other differences:
--
++ usbmuxd.spec ++
--- /var/tmp/diff_new_pack.vDoVGD/_old  2012-01-25 11:09:38.0 +0100
+++ /var/tmp/diff_new_pack.vDoVGD/_new  2012-01-25 11:09:38.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package usbmuxd
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,16 +16,15 @@
 #
 
 
-
 Name:   usbmuxd
 %define _libname   libusbmuxd
 Version:1.0.7
-Release:4
-License:LGPL v2.1 or GPL v2
+Release:0
 Summary:Socket daemon for the usbmux protocol of iPhone/iPod Touch 
devices
-Url:http://git.marcansoft.com/?p=usbmuxd.git
+License:LGPL-2.1 or GPL-2.0
 Group:  System/Libraries
-Source: %{name}-%{version}.tar.bz2
+Url:http://git.marcansoft.com/?p=usbmuxd.git
+Source: 
http://marcansoft.com/uploads/usbmuxd/%{name}-%{version}.tar.bz2
 BuildRequires:  cmake
 BuildRequires:  gcc-c++
 BuildRequires:  libplist-devel
@@ -44,8 +43,6 @@
 
 %package -n %{_libname}1
 
-
-License:LGPL v2.1 or GPL v2
 Summary:A library to abstract socket/protocol communication to the 
usbmuxd daemon
 Group:  System/Libraries
 Requires:   %{name}
@@ -58,7 +55,6 @@
 
 %package -n %{_libname}-devel
 
-
 Summary:Development files for %{_libname}
 Group:  Development/Libraries/C and C++
 Requires:   %{_libname} = %{version}
@@ -69,7 +65,6 @@
 developing applications that use %{_libname}.
 
 %package -n iproxy
-License:LGPL v2.1 or GPL v2
 Summary:Proxy enabling TCP tunneling to iPhone/iPod Touch via USB cable
 Group:  System/Libraries
 Requires:   %{_libname} = %{version}

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit xine-ui for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package xine-ui for openSUSE:Factory checked 
in at 2012-01-25 11:09:16

Comparing /work/SRC/openSUSE:Factory/xine-ui (Old)
 and  /work/SRC/openSUSE:Factory/.xine-ui.new (New)


Package is xine-ui, Maintainer is mh...@novell.com

Changes:

--- /work/SRC/openSUSE:Factory/xine-ui/xine-ui.changes  2011-10-02 
11:18:17.0 +0200
+++ /work/SRC/openSUSE:Factory/.xine-ui.new/xine-ui.changes 2012-01-25 
11:09:39.0 +0100
@@ -1,0 +2,6 @@
+Mon Jan  9 15:17:30 UTC 2012 - pgaj...@suse.com
+
+- build also against libpng15
+  * libpng15.patch
+
+---

New:

  xine-ui-libpng15.diff



Other differences:
--
++ xine-ui.spec ++
--- /var/tmp/diff_new_pack.chh90s/_old  2012-01-25 11:09:40.0 +0100
+++ /var/tmp/diff_new_pack.chh90s/_new  2012-01-25 11:09:40.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package xine-ui
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,17 +15,20 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   xine-ui
-BuildRequires:  aalib-devel curl-devel libpng-devel lirc-devel readline-devel
-BuildRequires:  update-desktop-files xine-devel xorg-x11-devel
+BuildRequires:  aalib-devel
+BuildRequires:  curl-devel
+BuildRequires:  libpng-devel
+BuildRequires:  lirc-devel
+BuildRequires:  readline-devel
+BuildRequires:  update-desktop-files
+BuildRequires:  xine-devel
+BuildRequires:  xorg-x11-devel
 Summary:Video player with plugins
-Version:0.99.5
-Release:236
 License:GPL-2.0+ ; SUSE-Public-Domain
 Group:  Productivity/Multimedia/Video/Players
+Version:0.99.5
+Release:0
 Url:http://xine.sourceforge.net
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Provides:   xine:/usr/bin/xine
@@ -44,6 +47,9 @@
 Patch21:locale_fix.diff
 Patch22:xine-ui-libs.diff
 Patch23:xine-ui-array-overflow.diff
+# PATCH-FIX-UPSTREAM xine-ui-libpng15.patch -- pgaj...@suse.com; build with 
libpng15; sent today to f1...@users.sourceforge.net
+# build against libpng14 should not be affected, otherwise please let me know
+Patch24:xine-ui-libpng15.diff
 # *** SUSE only changes
 Patch50:xine-ui-crippled-LOCAL.diff
 Patch60:xine-ui-AUTOMAKE.diff
@@ -71,6 +77,7 @@
 %patch21
 %patch22 -p1
 %patch23 -p1
+%patch24 -p1
 %patch50
 %patch60
 %patch61


++ xine-ui-libpng15.diff ++
Index: xine-ui-0.99.5/src/xitk/Imlib-light/load.c
===
--- xine-ui-0.99.5.orig/src/xitk/Imlib-light/load.c
+++ xine-ui-0.99.5/src/xitk/Imlib-light/load.c
@@ -58,7 +58,18 @@ unsigned char *_LoadPNG(ImlibData * id,
   png_destroy_read_struct(png_ptr, NULL, NULL);
   return NULL;
 }
-  if (info_ptr-color_type == PNG_COLOR_TYPE_RGB_ALPHA)
+  /* Not sure why is following check here. As far as I can see,
+ memory, which is info_ptr pointing to, is zeroed in 
+ png_create_info_struct(). In png.h: 
+ #define PNG_COLOR_MASK_COLOR  2
+ #define PNG_COLOR_MASK_ALPHA  4
+ #define PNG_COLOR_TYPE_RGB_ALPHA  (PNG_COLOR_MASK_COLOR | 
PNG_COLOR_MASK_ALPHA)
+ So following condition is never true?
+ Nevertheless:
+*/
+  png_get_IHDR(png_ptr, info_ptr, ww, hh, bit_depth, color_type,
+   NULL, NULL, NULL);
+  if (color_type == PNG_COLOR_TYPE_RGB_ALPHA)
 {
   png_destroy_read_struct(png_ptr, info_ptr, NULL);
   return NULL;

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit xorg-x11-libs for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package xorg-x11-libs for openSUSE:Factory 
checked in at 2012-01-25 11:09:21

Comparing /work/SRC/openSUSE:Factory/xorg-x11-libs (Old)
 and  /work/SRC/openSUSE:Factory/.xorg-x11-libs.new (New)


Package is xorg-x11-libs, Maintainer is sndir...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/xorg-x11-libs/xorg-x11-libs.changes  
2012-01-20 22:08:20.0 +0100
+++ /work/SRC/openSUSE:Factory/.xorg-x11-libs.new/xorg-x11-libs.changes 
2012-01-25 11:09:40.0 +0100
@@ -1,0 +2,7 @@
+Mon Jan 23 10:59:06 UTC 2012 - sndir...@suse.com
+
+- fixed typo in generating fake xcb libs; fake xcb libs don't need
+  to be provided explicitely via spec file, since this Provides is
+  already picked up from the generated xcb libs themselves
+
+---



Other differences:
--
++ xorg-x11-libs.spec ++
--- /var/tmp/diff_new_pack.SIPbJe/_old  2012-01-25 11:09:42.0 +0100
+++ /var/tmp/diff_new_pack.SIPbJe/_new  2012-01-25 11:09:42.0 +0100
@@ -23,11 +23,9 @@
 %ifarch ppc64 s390x x86_64
 Provides:   libXaw.so.8()(64bit) libXaw.so.7()(64bit) libXaw.so.6()(64bit)
 Provides:   libXaw8.so.8()(64bit) libXaw7.so.7()(64bit) 
libXaw6.so.6()(64bit)
-Provides:   libxcb-atom.so.1()(64bit)
 %else
 Provides:   libXaw.so.8 libXaw.so.7 libXaw.so.6
 Provides:   libXaw8.so.8 libXaw7.so.7 libXaw6.so.6
-Provides:   libxcb-atom.so.1
 %endif
 # bug437293
 %ifarch ppc64
@@ -153,7 +151,7 @@
   version=${ext_version#*:}
xcb-${ext}.c
   gcc -Wall -ansi -pedantic -c xcb-${ext}.c -fPIC
-  gcc -shared -Wl,-soname,libxcb-${ext}so.${version} \
+  gcc -shared -Wl,-soname,libxcb-${ext}.so.${version} \
   -o $RPM_BUILD_ROOT%{_libdir}/libxcb-${ext}.so.${version} xcb-${ext}.o
 done
 %if %suse_version  1110

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yelp-xsl for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package yelp-xsl for openSUSE:Factory 
checked in at 2012-01-25 11:09:39

Comparing /work/SRC/openSUSE:Factory/yelp-xsl (Old)
 and  /work/SRC/openSUSE:Factory/.yelp-xsl.new (New)


Package is yelp-xsl, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/yelp-xsl/yelp-xsl.changes2012-01-06 
11:47:08.0 +0100
+++ /work/SRC/openSUSE:Factory/.yelp-xsl.new/yelp-xsl.changes   2012-01-25 
11:09:45.0 +0100
@@ -1,0 +2,13 @@
+Tue Jan 17 14:14:52 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.2:
+  + Customized rendering for mobile devices
+  + Changed how :first-child margin-top is set
+  + Changed div.all to div.page
+  + Copy page/section attributes to cache
+  + Updated translations.
+- Add xz BuildRequires because we can't build a package for a
+  xz-compressed tarball without explicitly specifying that... See
+  bnc#697467 for more details.
+
+---

Old:

  yelp-xsl-3.3.1.tar.bz2

New:

  yelp-xsl-3.3.2.tar.xz



Other differences:
--
++ yelp-xsl.spec ++
--- /var/tmp/diff_new_pack.nVx6tI/_old  2012-01-25 11:09:46.0 +0100
+++ /var/tmp/diff_new_pack.nVx6tI/_new  2012-01-25 11:09:46.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package yelp-xsl
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c) 2010 Dominique Leuenberger, Amsterdam, Netherlands.
 #
 # All modifications and additions to the file contributed by third parties
@@ -17,15 +17,17 @@
 #
 
 Name:   yelp-xsl
-Version:3.3.1
+Version:3.3.2
 Release:0
 Summary:XSL stylesheets for the yelp help browser
 License:GPL-2.0+ and LGPL-2.1+ and MIT
 Group:  System/Libraries
-Source: 
http://download.gnome.org/sources/yelp-xsl/3.3/%{name}-%{version}.tar.bz2
+Source: 
http://download.gnome.org/sources/yelp-xsl/3.3/%{name}-%{version}.tar.xz
 BuildRequires:  intltool
 BuildRequires:  itstool
 BuildRequires:  pkg-config
+# Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
+BuildRequires:  xz
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(libxslt)
 BuildArch:  noarch

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yast2-network for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package yast2-network for openSUSE:Factory 
checked in at 2012-01-25 11:09:30

Comparing /work/SRC/openSUSE:Factory/yast2-network (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-network.new (New)


Package is yast2-network, Maintainer is mvid...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/yast2-network/yast2-network.changes  
2012-01-17 16:17:40.0 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-network.new/yast2-network.changes 
2012-01-25 11:09:44.0 +0100
@@ -1,0 +2,9 @@
+Tue Jan 24 16:28:37 CET 2012 - mvid...@suse.cz
+
+- Fixed broken autoyast in general (bnc#742855)
+  and in case with keep_install_network without dns without routing
+  (bnc#712864).
+- Filter out more Chelsio devices, by PCI id (bnc#711432#c83)
+- 2.22.2
+
+---

Old:

  yast2-network-2.22.1.tar.bz2

New:

  yast2-network-2.22.2.tar.bz2



Other differences:
--
++ yast2-network.spec ++
--- /var/tmp/diff_new_pack.p9WJCG/_old  2012-01-25 11:09:45.0 +0100
+++ /var/tmp/diff_new_pack.p9WJCG/_new  2012-01-25 11:09:45.0 +0100
@@ -16,22 +16,22 @@
 #
 
 
-
 Name:   yast2-network
-Version:2.22.1
+Version:2.22.2
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source0:yast2-network-%{version}.tar.bz2
 
-Group:  System/YaST
-License:GPL-2.0+
 # should be required by devtools
-BuildRequires:  perl-XML-Writer pkgconfig rpm
+BuildRequires:  perl-XML-Writer
+BuildRequires:  pkgconfig
+BuildRequires:  rpm
 BuildRequires:  update-desktop-files
-BuildRequires:  yast2-devtools yast2-testsuite
 BuildRequires:  yast2-country
+BuildRequires:  yast2-devtools
 BuildRequires:  yast2-installation = 2.15.27
+BuildRequires:  yast2-testsuite
 
 # NetworkInterfaces::Write should write ifcfgs only once
 # Wizard::SetDesktopTitleAndIcon
@@ -62,10 +62,12 @@
 Conflicts:  yast2-core  2.10.6
 
 Summary:YaST2 - Network Configuration
+License:GPL-2.0+
+Group:  System/YaST
 
 %package devel-doc
-Group:  System/YaST
 Summary:YaST2 - Developer documentation for yast2-network
+Group:  System/YaST
 
 %description 
 This package contains the YaST2 component for network configuration.

++ yast2-network-2.22.1.tar.bz2 - yast2-network-2.22.2.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-network-2.22.1/VERSION 
new/yast2-network-2.22.2/VERSION
--- old/yast2-network-2.22.1/VERSION2012-01-13 16:12:29.0 +0100
+++ new/yast2-network-2.22.2/VERSION2012-01-24 16:51:48.0 +0100
@@ -1 +1 @@
-2.22.1
+2.22.2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-network-2.22.1/configure 
new/yast2-network-2.22.2/configure
--- old/yast2-network-2.22.1/configure  2012-01-13 16:12:33.0 +0100
+++ new/yast2-network-2.22.2/configure  2012-01-24 16:51:53.0 +0100
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.68 for yast2-network 2.22.1.
+# Generated by GNU Autoconf 2.68 for yast2-network 2.22.2.
 #
 # Report bugs to http://bugs.opensuse.org/.
 #
@@ -559,8 +559,8 @@
 # Identity of this package.
 PACKAGE_NAME='yast2-network'
 PACKAGE_TARNAME='yast2-network'
-PACKAGE_VERSION='2.22.1'
-PACKAGE_STRING='yast2-network 2.22.1'
+PACKAGE_VERSION='2.22.2'
+PACKAGE_STRING='yast2-network 2.22.2'
 PACKAGE_BUGREPORT='http://bugs.opensuse.org/'
 PACKAGE_URL=''
 
@@ -1229,7 +1229,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat _ACEOF
-\`configure' configures yast2-network 2.22.1 to adapt to many kinds of systems.
+\`configure' configures yast2-network 2.22.2 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1300,7 +1300,7 @@
 
 if test -n $ac_init_help; then
   case $ac_init_help in
- short | recursive ) echo Configuration of yast2-network 2.22.1:;;
+ short | recursive ) echo Configuration of yast2-network 2.22.2:;;
esac
   cat \_ACEOF
 
@@ -1380,7 +1380,7 @@
 test -n $ac_init_help  exit $ac_status
 if $ac_init_version; then
   cat \_ACEOF
-yast2-network configure 2.22.1
+yast2-network configure 2.22.2
 generated by GNU Autoconf 2.68
 
 Copyright (C) 2010 Free Software Foundation, Inc.
@@ -1397,7 +1397,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by yast2-network $as_me 2.22.1, which was
+It was created 

commit yast2-fcoe-client for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package yast2-fcoe-client for 
openSUSE:Factory checked in at 2012-01-25 11:09:26

Comparing /work/SRC/openSUSE:Factory/yast2-fcoe-client (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-fcoe-client.new (New)


Package is yast2-fcoe-client, Maintainer is g...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/yast2-fcoe-client/yast2-fcoe-client.changes  
2012-01-09 21:44:30.0 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-fcoe-client.new/yast2-fcoe-client.changes 
2012-01-25 11:09:42.0 +0100
@@ -1,0 +2,11 @@
+Thu Jan 19 09:35:06 CET 2012 - g...@suse.de
+
+- Merge SP2 branch to trunk: use improved 'fipvlan' (bnc #728103),
+  set DCB_REQUIRED to no for Broadcom devices (bnc #728658),
+  enable service start of 'lldpad' before enabling 'fcoe',
+  don't overwrite BOOTPROTO for underlying interface,
+  set default for AUTO_VLAN to yes (bnc #724563),
+  Call 'fipvlan' with option --link-up (bnc #737683)
+- V 2.22.2
+
+---

Old:

  yast2-fcoe-client-2.22.1.tar.bz2

New:

  yast2-fcoe-client-2.22.2.tar.bz2



Other differences:
--
++ yast2-fcoe-client.spec ++
--- /var/tmp/diff_new_pack.fiqXYQ/_old  2012-01-25 11:09:44.0 +0100
+++ /var/tmp/diff_new_pack.fiqXYQ/_new  2012-01-25 11:09:44.0 +0100
@@ -15,25 +15,23 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
+
 Name:   yast2-fcoe-client
-Version:2.22.1
+Version:2.22.2
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source0:yast2-fcoe-client-%{version}.tar.bz2
 
+Group:  System/YaST
+License:GPL-2.0
 Requires:   yast2 = 2.21.22
-BuildRequires:  perl-XML-Writer
-BuildRequires:  update-desktop-files
-BuildRequires:  yast2
-BuildRequires:  yast2-devtools
-BuildRequires:  yast2-testsuite
+BuildRequires:  perl-XML-Writer update-desktop-files yast2 yast2-devtools 
yast2-testsuite
 
 BuildArch:  noarch
 
 Summary:YaST2 - Configuration of Fibre Channel over Ethernet
-License:GPL-2.0
-Group:  System/YaST
 
 %description
 This package contains the YaST2 component for the Fibre Channel over

++ yast2-fcoe-client-2.22.1.tar.bz2 - yast2-fcoe-client-2.22.2.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-fcoe-client-2.22.1/VERSION 
new/yast2-fcoe-client-2.22.2/VERSION
--- old/yast2-fcoe-client-2.22.1/VERSION2011-12-21 14:34:52.0 
+0100
+++ new/yast2-fcoe-client-2.22.2/VERSION2012-01-19 09:49:35.0 
+0100
@@ -1 +1 @@
-2.22.1
+2.22.2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-fcoe-client-2.22.1/configure 
new/yast2-fcoe-client-2.22.2/configure
--- old/yast2-fcoe-client-2.22.1/configure  2011-12-21 14:35:45.0 
+0100
+++ new/yast2-fcoe-client-2.22.2/configure  2012-01-24 11:55:03.0 
+0100
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.68 for yast2-fcoe-client 2.22.1.
+# Generated by GNU Autoconf 2.68 for yast2-fcoe-client 2.22.2.
 #
 # Report bugs to http://bugs.opensuse.org/.
 #
@@ -559,8 +559,8 @@
 # Identity of this package.
 PACKAGE_NAME='yast2-fcoe-client'
 PACKAGE_TARNAME='yast2-fcoe-client'
-PACKAGE_VERSION='2.22.1'
-PACKAGE_STRING='yast2-fcoe-client 2.22.1'
+PACKAGE_VERSION='2.22.2'
+PACKAGE_STRING='yast2-fcoe-client 2.22.2'
 PACKAGE_BUGREPORT='http://bugs.opensuse.org/'
 PACKAGE_URL=''
 
@@ -1229,7 +1229,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat _ACEOF
-\`configure' configures yast2-fcoe-client 2.22.1 to adapt to many kinds of 
systems.
+\`configure' configures yast2-fcoe-client 2.22.2 to adapt to many kinds of 
systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1301,7 +1301,7 @@
 
 if test -n $ac_init_help; then
   case $ac_init_help in
- short | recursive ) echo Configuration of yast2-fcoe-client 2.22.1:;;
+ short | recursive ) echo Configuration of yast2-fcoe-client 2.22.2:;;
esac
   cat \_ACEOF
 
@@ -1381,7 +1381,7 @@
 test -n $ac_init_help  exit $ac_status
 if $ac_init_version; then
   cat \_ACEOF
-yast2-fcoe-client configure 2.22.1
+yast2-fcoe-client configure 2.22.2
 generated by GNU Autoconf 2.68
 
 Copyright (C) 2010 Free Software Foundation, Inc.
@@ -1398,7 +1398,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by yast2-fcoe-client $as_me 2.22.1, 

commit cherrytree for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package cherrytree for openSUSE:Factory 
checked in at 2012-01-25 12:18:02

Comparing /work/SRC/openSUSE:Factory/cherrytree (Old)
 and  /work/SRC/openSUSE:Factory/.cherrytree.new (New)


Package is cherrytree, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/cherrytree/cherrytree.changes2012-01-17 
16:04:35.0 +0100
+++ /work/SRC/openSUSE:Factory/.cherrytree.new/cherrytree.changes   
2012-01-25 12:18:04.0 +0100
@@ -1,0 +2,13 @@
+Tue Jan 24 10:26:20 UTC 2012 - vu...@opensuse.org
+
+- Update to version 0.25.2:
+  + Bug fixes.
+
+---
+Sat Jan 21 09:48:04 UTC 2012 - vu...@opensuse.org
+
+- Update to version 0.25.1:
+  + Middle click on the tree expands/collapses
+  + Bug fixes.
+
+---

Old:

  cherrytree-0.25.tar.gz

New:

  cherrytree-0.25.2.tar.gz



Other differences:
--
++ cherrytree.spec ++
--- /var/tmp/diff_new_pack.1RKdyO/_old  2012-01-25 12:18:05.0 +0100
+++ /var/tmp/diff_new_pack.1RKdyO/_new  2012-01-25 12:18:05.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   cherrytree
-Version:0.25
+Version:0.25.2
 Release:0
 Summary:A hierarchical note taking application
 License:GPL-2.0+

++ cherrytree-0.25.tar.gz - cherrytree-0.25.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cherrytree-0.25/debian/changelog 
new/cherrytree-0.25.2/debian/changelog
--- old/cherrytree-0.25/debian/changelog2012-01-13 22:51:37.0 
+0100
+++ new/cherrytree-0.25.2/debian/changelog  2012-01-22 21:55:42.0 
+0100
@@ -1,4 +1,4 @@
-cherrytree (0.25-2) stable; urgency=low
+cherrytree (0.25.2-1) stable; urgency=low
 
   * Fellow upstream.
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cherrytree-0.25/debian/debhelper.log 
new/cherrytree-0.25.2/debian/debhelper.log
--- old/cherrytree-0.25/debian/debhelper.log2012-01-14 16:39:44.0 
+0100
+++ new/cherrytree-0.25.2/debian/debhelper.log  2012-01-24 01:12:26.0 
+0100
@@ -26,3 +26,45 @@
 dh_gencontrol
 dh_md5sums
 dh_builddeb
+dh_prep
+dh_installdirs
+dh_installchangelogs
+dh_installdocs
+dh_installexamples
+dh_installman
+dh_link
+dh_compress
+dh_fixperms
+dh_pycentral
+dh_installdeb
+dh_gencontrol
+dh_md5sums
+dh_builddeb
+dh_prep
+dh_installdirs
+dh_installchangelogs
+dh_installdocs
+dh_installexamples
+dh_installman
+dh_link
+dh_compress
+dh_fixperms
+dh_pycentral
+dh_installdeb
+dh_gencontrol
+dh_md5sums
+dh_builddeb
+dh_prep
+dh_installdirs
+dh_installchangelogs
+dh_installdocs
+dh_installexamples
+dh_installman
+dh_link
+dh_compress
+dh_fixperms
+dh_pycentral
+dh_installdeb
+dh_gencontrol
+dh_md5sums
+dh_builddeb
Files old/cherrytree-0.25/modules/clipboard.pyc and 
new/cherrytree-0.25.2/modules/clipboard.pyc differ
Files old/cherrytree-0.25/modules/codeboxes.pyc and 
new/cherrytree-0.25.2/modules/codeboxes.pyc differ
Files old/cherrytree-0.25/modules/config.pyc and 
new/cherrytree-0.25.2/modules/config.pyc differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cherrytree-0.25/modules/cons.py 
new/cherrytree-0.25.2/modules/cons.py
--- old/cherrytree-0.25/modules/cons.py 2012-01-13 22:51:37.0 +0100
+++ new/cherrytree-0.25.2/modules/cons.py   2012-01-22 21:55:28.0 
+0100
@@ -22,7 +22,7 @@
 import os, sys
 
 
-VERSION = 0.25
+VERSION = 0.25.2
 APP_NAME = cherrytree
 NEWER_VERSION_URL = http://www.giuspen.com/software/version_cherrytree;
 if sys.platform[0:3] == win:
Files old/cherrytree-0.25/modules/cons.pyc and 
new/cherrytree-0.25.2/modules/cons.pyc differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cherrytree-0.25/modules/core.py 
new/cherrytree-0.25.2/modules/core.py
--- old/cherrytree-0.25/modules/core.py 2012-01-13 22:51:37.0 +0100
+++ new/cherrytree-0.25.2/modules/core.py   2012-01-24 01:08:48.0 
+0100
@@ -1027,6 +1027,7 @@
 support.add_recent_document(self, filepath)
 self.update_window_save_not_needed()
 
self.state_machine.update_state(self.treestore[self.curr_tree_iter][3])
+self.objects_buffer_refresh()
 
 def filepath_extension_fix(self, filepath):
 Check a filepath to have the proper extension
@@ -1055,7 +1056,9 @@
 if not exporting:
 if db in dir(self): self.db_old = self.db
 self.db = self.ctdb_handler.new_db(filepath_tmp)
-

commit cheese for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package cheese for openSUSE:Factory checked 
in at 2012-01-25 12:17:52

Comparing /work/SRC/openSUSE:Factory/cheese (Old)
 and  /work/SRC/openSUSE:Factory/.cheese.new (New)


Package is cheese, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/cheese/cheese.changes2012-01-09 
12:02:52.0 +0100
+++ /work/SRC/openSUSE:Factory/.cheese.new/cheese.changes   2012-01-25 
12:17:54.0 +0100
@@ -1,0 +2,16 @@
+Tue Jan 17 07:46:20 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.4:
+  + Add videos and picture sharing support (bgo#522210).
+  + Set PulseAudio media role to production, to hint PulseAudio
+that a microphone control should be presented to the user
+(bgo#666875).
+  + Fix help links.
+  + Add code coverage reporting, using lcov.
+  + Various other code changes.
+  + Build fixes.
+  + Updated translations.
+- Add nautilus-sendto Requires, for the new videos and picture
+  sharing support.
+
+---

Old:

  cheese-3.3.3.tar.xz

New:

  cheese-3.3.4.tar.xz



Other differences:
--
++ cheese.spec ++
--- /var/tmp/diff_new_pack.zZxXZE/_old  2012-01-25 12:17:55.0 +0100
+++ /var/tmp/diff_new_pack.zZxXZE/_new  2012-01-25 12:17:55.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package cheese
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,12 +15,11 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %define lib_major 3
 %define lib_gtk_major 21
 
 Name:   cheese
-Version:3.3.3
+Version:3.3.4
 Release:0
 # FIXME: the %%{_datadir}/help/$locale/ files be found by %%find_lang
 Summary:Webcam Booth for GNOME
@@ -57,6 +56,8 @@
 BuildRequires:  pkgconfig(mx-1.0)
 BuildRequires:  pkgconfig(x11)
 Requires:   gnome-video-effects
+# For sharing pictures/videos
+Requires:   nautilus-sendto
 Requires:   yelp
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit clutter-gst for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package clutter-gst for openSUSE:Factory 
checked in at 2012-01-25 12:18:06

Comparing /work/SRC/openSUSE:Factory/clutter-gst (Old)
 and  /work/SRC/openSUSE:Factory/.clutter-gst.new (New)


Package is clutter-gst, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/clutter-gst/clutter-gst.changes  2012-01-09 
12:02:58.0 +0100
+++ /work/SRC/openSUSE:Factory/.clutter-gst.new/clutter-gst.changes 
2012-01-25 12:18:07.0 +0100
@@ -1,0 +2,9 @@
+Wed Jan 18 17:37:43 UTC 2012 - vu...@opensuse.org
+
+- Update to version 1.4.6:
+  + Fix reffing/unreffing behaviour of ClutterGstVideoTexture
+- Add xz BuildRequires because we can't build a package for a
+  xz-compressed tarball without explicitly specifying that... See
+  bnc#697467 for more details.
+
+---

Old:

  clutter-gst-1.4.4.tar.bz2

New:

  clutter-gst-1.4.6.tar.xz



Other differences:
--
++ clutter-gst.spec ++
--- /var/tmp/diff_new_pack.bhfAtj/_old  2012-01-25 12:18:08.0 +0100
+++ /var/tmp/diff_new_pack.bhfAtj/_new  2012-01-25 12:18:08.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package clutter-gst
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,20 +15,23 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   clutter-gst
-BuildRequires:  gobject-introspection-devel
-BuildRequires:  gstreamer-0_10-devel = 0.10.26
-BuildRequires:  gstreamer-0_10-plugins-base-devel
-BuildRequires:  pkgconfig(clutter-1.0) = 1.4.0
-BuildRequires:  pkgconfig(cogl-1.0) = 1.8.0
-Version:1.4.4
+Version:1.4.6
 Release:0
-Source0:
http://download.gnome.org/sources/clutter-gst/1.4/%{name}-%{version}.tar.bz2
-Source99:   baselibs.conf
 Url:http://clutter-project.org/
 Summary:GStreamer integration for Clutter
 License:LGPL-2.1+
 Group:  System/Libraries
+Source0:
http://download.gnome.org/sources/clutter-gst/1.4/%{name}-%{version}.tar.xz
+Source99:   baselibs.conf
+BuildRequires:  gobject-introspection-devel
+BuildRequires:  gstreamer-0_10-devel = 0.10.26
+BuildRequires:  gstreamer-0_10-plugins-base-devel
+# Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
+BuildRequires:  xz
+BuildRequires:  pkgconfig(clutter-1.0) = 1.4.0
+BuildRequires:  pkgconfig(cogl-1.0) = 1.8.0
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %define debug_package_requires libclutter-gst-1_0-0 = %{version}-%{release}
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit giver for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package giver for openSUSE:Factory checked 
in at 2012-01-25 12:18:15

Comparing /work/SRC/openSUSE:Factory/giver (Old)
 and  /work/SRC/openSUSE:Factory/.giver.new (New)


Package is giver, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/giver/giver.changes  2011-09-23 
01:59:58.0 +0200
+++ /work/SRC/openSUSE:Factory/.giver.new/giver.changes 2012-01-25 
12:18:16.0 +0100
@@ -1,0 +2,10 @@
+Mon Jan 23 08:30:54 UTC 2012 - vu...@opensuse.org
+
+- Move to pkgconfig() BuildRequires:
+  + Old ones: avahi-mono, gnome-sharp2, gtk-sharp2, notify-sharp.
+  + New ones: avahi-sharp, glib-sharp-2.0, gnome-sharp-2.0,
+gtk-dotnet-2.0, notify-sharp.
+- Remove unneeded gtk2-devel, monodoc, ndesk-dbus, and
+  ndesk-dbus-glib BuildRequires.
+
+---



Other differences:
--
++ giver.spec ++
--- /var/tmp/diff_new_pack.Llvk8y/_old  2012-01-25 12:18:17.0 +0100
+++ /var/tmp/diff_new_pack.Llvk8y/_new  2012-01-25 12:18:17.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package giver
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,25 +15,32 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   giver
-Url:http://idea.opensuse.org/content/ideas/easy-file-sharing
-BuildRequires:  avahi-mono fdupes gnome-sharp2 gtk-sharp2 gtk2-devel 
mono-devel monodoc ndesk-dbus ndesk-dbus-glib notify-sharp perl-XML-Parser 
pkg-config update-desktop-files
-BuildArch:  noarch
 Version:0.1.8
-Release:215
+Release:0
+Summary:A simple file sharing desktop application
 License:MIT
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-Requires:   ndesk-dbus ndesk-dbus-glib notify-sharp avahi-mono
-Recommends: %{name}-lang
+Group:  Productivity/Networking/File-Sharing
 Source: %{name}-%{version}.tar.bz2
+Url:http://idea.opensuse.org/content/ideas/easy-file-sharing
 Patch:  bnc-326064.txt
 # PATCH-FIX-UPSTREAM giver-change-photo.patch bnc#328531 vu...@opensuse.org -- 
Make it possible to change the photo, patch taken from 
http://code.google.com/p/giver/issues/detail?id=4
 Patch1: giver-change-photo.patch
-Group:  Productivity/Networking/File-Sharing
-Summary:A simple file sharing desktop application
+BuildRequires:  fdupes
+BuildRequires:  mono-devel
+BuildRequires:  perl-XML-Parser
+BuildRequires:  pkg-config
+BuildRequires:  update-desktop-files
+BuildRequires:  pkgconfig(avahi-sharp)
+BuildRequires:  pkgconfig(glib-sharp-2.0)
+BuildRequires:  pkgconfig(gnome-sharp-2.0)
+BuildRequires:  pkgconfig(gtk-dotnet-2.0)
+BuildRequires:  pkgconfig(notify-sharp)
+Requires:   ndesk-dbus ndesk-dbus-glib notify-sharp avahi-mono
+Recommends: %{name}-lang
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildArch:  noarch
 
 %description
 Giver is a simple desktop file sharing application based that uses

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gnome-devel-docs for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gnome-devel-docs for 
openSUSE:Factory checked in at 2012-01-25 12:18:19

Comparing /work/SRC/openSUSE:Factory/gnome-devel-docs (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-devel-docs.new (New)


Package is gnome-devel-docs, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/gnome-devel-docs/gnome-devel-docs.changes
2011-10-18 14:13:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-devel-docs.new/gnome-devel-docs.changes   
2012-01-25 12:18:22.0 +0100
@@ -1,0 +2,15 @@
+Mon Jan 23 19:31:44 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.1:
+  + Platform Overview:
+- Fixed link in ATK documentation
+- Added previously omitted files to Makefile.am
+  + Platform Demos:
+- Added previously omitted files to Makefile.am
+- Added Vala version of Image Viewer Demo
+  + Updated translations.
+- Add xz BuildRequires because we can't build a package for a
+  xz-compressed tarball without explicitly specifying that... See
+  bnc#697467 for more details.
+
+---

Old:

  gnome-devel-docs-3.2.1.tar.bz2

New:

  gnome-devel-docs-3.3.1.tar.xz



Other differences:
--
++ gnome-devel-docs.spec ++
--- /var/tmp/diff_new_pack.Z7GKXE/_old  2012-01-25 12:18:23.0 +0100
+++ /var/tmp/diff_new_pack.Z7GKXE/_new  2012-01-25 12:18:23.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gnome-devel-docs
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,19 +15,19 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   gnome-devel-docs
-Version:3.2.1
-Release:1
-License:GFDL-1.1
+Version:3.3.1
+Release:0
 Summary:GNOME Platform Documentation
-Url:http://www.gnome.org
+License:GFDL-1.1
 Group:  Documentation/Other
-Source: 
http://download.gnome.org/sources/gnome-devel-docs/3.2/%{name}-%{version}.tar.bz2
+Url:http://www.gnome.org
+Source: 
http://download.gnome.org/sources/gnome-devel-docs/3.3/%{name}-%{version}.tar.xz
 BuildRequires:  fdupes
 BuildRequires:  gnome-doc-utils-devel
 BuildRequires:  pkg-config
+# Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
+BuildRequires:  xz
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gnome-do for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gnome-do for openSUSE:Factory 
checked in at 2012-01-25 12:18:24

Comparing /work/SRC/openSUSE:Factory/gnome-do (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-do.new (New)


Package is gnome-do, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gnome-do/gnome-do.changes2012-01-05 
19:11:44.0 +0100
+++ /work/SRC/openSUSE:Factory/.gnome-do.new/gnome-do.changes   2012-01-25 
12:18:25.0 +0100
@@ -1,0 +2,16 @@
+Mon Jan 23 08:33:21 UTC 2012 - vu...@opensuse.org
+
+- Move to pkgconfig() BuildRequires:
+  + Old ones: gconf-sharp2, glade-sharp2, gnome-desktop-sharp2,
+gnome-keyring-sharp-devel, gnome-sharp2, gtk2-devel,
+mono-addins, rsvg2-sharp, ndesk-dbus-glib-devel, notify-sharp,
+wnck-sharp.
+  + New ones: gconf-sharp-2.0, gdk-2.0, gdk-x11-2.0,
+glade-sharp-2.0, glib-2.0, glib-sharp-2.0,
+gnome-desktop-sharp-2.0, gnome-keyring-sharp-1.0,
+gnome-sharp-2.0, gnome-vfs-sharp-2.0, gtk+-2.0, gtk-sharp-2.0,
+mono-addins, mono-addins-gui, mono-addins-setup,
+ndesk-dbus-1.0, ndesk-dbus-glib-1.0, notify-sharp,
+rsvg2-sharp-2.0, wnck-sharp-1.0.
+
+---



Other differences:
--
++ gnome-do.spec ++
--- /var/tmp/diff_new_pack.kd5iaK/_old  2012-01-25 12:18:25.0 +0100
+++ /var/tmp/diff_new_pack.kd5iaK/_new  2012-01-25 12:18:25.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gnome-do
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,14 +15,10 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   gnome-do
 Version:0.8.5
-Release:2
+Release:0
 # FIXME: check if removal of locales in %install is still needed (last 
checked: 2010-12-11)
-License:GPLv3+
 Url:http://do.davebsd.com/
 Source: 
http://launchpad.net/do/trunk/0.8.5/+download/%{name}-%{version}.tar.gz
 # PATCH-FIX-UPSTREAM gnome-do-OnlyShowIn.patch lp#413575 
dominique-...@leuenberger.net -- Show gnome-do only in gnome desktop.
@@ -34,30 +30,34 @@
 # PATCH-FIX-UPSREAM gnome-do-glib-2.31.patch lp#897450 dims...@opensuse.org -- 
Fix build with glib 2.31
 Patch8: gnome-do-glib-2.31.patch
 Summary:A powerful, speedy, and sexy remote control for your GNOME 
Desktop
+License:GPL-3.0+
 Group:  Productivity/Other
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  gconf2-devel
-BuildRequires:  gnome-keyring-sharp-devel
-BuildRequires:  gtk2-devel
 BuildRequires:  intltool
 BuildRequires:  libtool
-BuildRequires:  mono-addins
 BuildRequires:  mono-devel
-BuildRequires:  notify-sharp
-BuildRequires:  wnck-sharp
-%if 0%{?fedora_version}
-BuildRequires:  gnome-sharp-devel
-BuildRequires:  gtk-sharp2-devel
-BuildRequires:  ndesk-dbus-glib
-%else
-BuildRequires:  gconf-sharp2
-BuildRequires:  glade-sharp2
-BuildRequires:  gnome-desktop-sharp2
-BuildRequires:  gnome-sharp2
-BuildRequires:  rsvg2-sharp
-BuildRequires:  ndesk-dbus-glib-devel
 BuildRequires:  pkg-config
-%endif
+BuildRequires:  pkgconfig(gconf-sharp-2.0)
+BuildRequires:  pkgconfig(gdk-2.0)
+BuildRequires:  pkgconfig(gdk-x11-2.0)
+BuildRequires:  pkgconfig(glade-sharp-2.0)
+BuildRequires:  pkgconfig(glib-2.0)
+BuildRequires:  pkgconfig(glib-sharp-2.0)
+BuildRequires:  pkgconfig(gnome-desktop-sharp-2.0)
+BuildRequires:  pkgconfig(gnome-keyring-sharp-1.0)
+BuildRequires:  pkgconfig(gnome-sharp-2.0)
+BuildRequires:  pkgconfig(gnome-vfs-sharp-2.0)
+BuildRequires:  pkgconfig(gtk+-2.0)
+BuildRequires:  pkgconfig(gtk-sharp-2.0)
+BuildRequires:  pkgconfig(mono-addins)
+BuildRequires:  pkgconfig(mono-addins-gui)
+BuildRequires:  pkgconfig(mono-addins-setup)
+BuildRequires:  pkgconfig(ndesk-dbus-1.0)
+BuildRequires:  pkgconfig(ndesk-dbus-glib-1.0)
+BuildRequires:  pkgconfig(notify-sharp)
+BuildRequires:  pkgconfig(rsvg2-sharp-2.0)
+BuildRequires:  pkgconfig(wnck-sharp-1.0)
 %if 0%{?suse_version}
 BuildRequires:  update-desktop-files
 %else

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gnome-do-plugins for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gnome-do-plugins for 
openSUSE:Factory checked in at 2012-01-25 12:18:28

Comparing /work/SRC/openSUSE:Factory/gnome-do-plugins (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-do-plugins.new (New)


Package is gnome-do-plugins, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gnome-do-plugins/gnome-do-plugins.changes
2011-09-23 02:00:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-do-plugins.new/gnome-do-plugins.changes   
2012-01-25 12:18:30.0 +0100
@@ -1,0 +2,19 @@
+Mon Jan 23 08:58:24 UTC 2012 - vu...@opensuse.org
+
+- Move to pkgconfig() BuildRequires:
+  + Old ones: banshee-1-devel, flickrnet, gconf-sharp2,
+glade-sharp2, gnome-keyring-sharp-devel, gnome-sharp2,
+ndesk-dbus-glib-devel, wnck-sharp.
+  + New ones: banshee-collection-indexer, flickrnet,
+gconf-sharp-2.0, glade-sharp-2.0, glib-sharp-2.0,
+gnome-desktop-sharp-2.0, gnome-keyring-sharp-1.0,
+gnome-sharp-2.0, gnome-vfs-sharp-2.0, gtk-sharp-2.0,
+ndesk-dbus-1.0, ndesk-dbus-glib-1.0, wnck-sharp-1.0.
+- Add explicit pkgconfig() BuildRequires that were provided by
+  gdata-sharp (implicitly brought in before): gdata-sharp-acl,
+  gdata-sharp-calendar, gdata-sharp-contacts, gdata-sharp-core,
+  gdata-sharp-documents, gdata-sharp-youtube.
+- Add explicit pkgconfig() BuildRequires that were missing before:
+  mono-addins, mono-addins-gui, mono-addins-setup, notify-sharp.
+
+---



Other differences:
--
++ gnome-do-plugins.spec ++
--- /var/tmp/diff_new_pack.2qFre9/_old  2012-01-25 12:18:31.0 +0100
+++ /var/tmp/diff_new_pack.2qFre9/_new  2012-01-25 12:18:31.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gnome-do-plugins
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,26 +20,41 @@
 
 Name:   gnome-do-plugins
 Version:0.8.4
-Release:4
-License:GPL-3.0
+Release:0
 Url:http://do.davebsd.com
 Source: 
http://launchpad.net/do-plugins/trunk/0.8.4/+download/%{name}-%{version}.tar.gz
 Summary:Plugins for GNOME Do
+License:GPL-3.0
 Group:  Productivity/Other
-BuildRequires:  banshee-1-devel = 1.4.2
-BuildRequires:  flickrnet
-BuildRequires:  gconf-sharp2
-BuildRequires:  glade-sharp2
 BuildRequires:  gnome-do = 0.8.1
-BuildRequires:  gnome-keyring-sharp-devel
-BuildRequires:  gnome-sharp2
 BuildRequires:  intltool
 BuildRequires:  mono-data-sqlite
 BuildRequires:  mono-devel
-BuildRequires:  ndesk-dbus-glib-devel
 BuildRequires:  pkg-config
 BuildRequires:  update-desktop-files
-BuildRequires:  wnck-sharp
+BuildRequires:  pkgconfig(banshee-collection-indexer) = 2.1
+BuildRequires:  pkgconfig(flickrnet)
+BuildRequires:  pkgconfig(gconf-sharp-2.0)
+BuildRequires:  pkgconfig(gdata-sharp-acl)
+BuildRequires:  pkgconfig(gdata-sharp-calendar)
+BuildRequires:  pkgconfig(gdata-sharp-contacts)
+BuildRequires:  pkgconfig(gdata-sharp-core)
+BuildRequires:  pkgconfig(gdata-sharp-documents)
+BuildRequires:  pkgconfig(gdata-sharp-youtube)
+BuildRequires:  pkgconfig(glade-sharp-2.0)
+BuildRequires:  pkgconfig(glib-sharp-2.0)
+BuildRequires:  pkgconfig(gnome-desktop-sharp-2.0)
+BuildRequires:  pkgconfig(gnome-keyring-sharp-1.0)
+BuildRequires:  pkgconfig(gnome-sharp-2.0)
+BuildRequires:  pkgconfig(gnome-vfs-sharp-2.0)
+BuildRequires:  pkgconfig(gtk-sharp-2.0)
+BuildRequires:  pkgconfig(mono-addins)
+BuildRequires:  pkgconfig(mono-addins-gui)
+BuildRequires:  pkgconfig(mono-addins-setup)
+BuildRequires:  pkgconfig(ndesk-dbus-1.0)
+BuildRequires:  pkgconfig(ndesk-dbus-glib-1.0)
+BuildRequires:  pkgconfig(notify-sharp)
+BuildRequires:  pkgconfig(wnck-sharp-1.0)
 %if 0%{?suse_version}  1140
 BuildRequires:  pkgconfig(dbus-sharp-1.0)
 BuildRequires:  pkgconfig(dbus-sharp-glib-1.0)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gnuplot for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gnuplot for openSUSE:Factory checked 
in at 2012-01-25 12:18:33

Comparing /work/SRC/openSUSE:Factory/gnuplot (Old)
 and  /work/SRC/openSUSE:Factory/.gnuplot.new (New)


Package is gnuplot, Maintainer is wer...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/gnuplot/gnuplot.changes  2011-09-23 
02:01:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnuplot.new/gnuplot.changes 2012-01-25 
12:18:35.0 +0100
@@ -1,0 +2,41 @@
+Tue Dec 13 08:33:16 UTC 2011 - cfarr...@suse.com
+
+- license update: SUSE-Gnuplot and GPL-2.0+
+  SPDX format (including SUSE prefix for licenses not yet accepted by SPDX
+  upstream). This is not BSD-3-Clause. The Gnuplot license insists that
+  modifications to source code be done by patch only. There are GPL-2.0+
+  components included as aggegation
+
+---
+Thu Dec  1 16:46:07 UTC 2011 - co...@suse.com
+
+- add automake as buildrequire to avoid implicit dependency
+
+---
+Tue Nov 29 22:48:07 UTC 2011 - bur...@net-b.de
+
+- Update to gnuplot 4.4.4
+  * NEW boxxyerrors plot style now allows variable color
+  * NEW splot with pm3d now allows variable rgb color
+  * NEW nonuniform matrix indicates ascii data with explicit x, y
+  * CHANGE columnhead(N) is a string-valued function, not a keyword
+  * CHANGE Demarcate plots in svg output using g id=Plot_#title...
+  * CHANGE xticlabels() works for binary data files as well as ascii
+  * CHANGE set key maxrows now applies to 3D plots as well as 2D
+  * CHANGE rewrite installation path rules for TeX files
+  * FIX wxt terminal should now work on at least some flavors of OSX
+  * FIX incorrect space allowed for outside left key box
+  * FIX buffer overflow from enhanced text timefmt tic labels
+  * FIX correction for offset in epochs when reading in time format %s
+  * FIX discontinuity in defined palette limited by maxcolors
+  * FIX initialization of svg pattern-fill definitions
+  * FIX positioning of histogram bars when some data entries are missing
+  * FIX emf terminal can handle UTF-8 encoding
+  * FIX User-specified axis tick labels override auto labels in 3D
+just as in 2D
+  * FIX `plot with labels` failed to skip labels with UNDEFINED coords
+  * FIX NaN (not a number) implementation for Windows build
+  * FIX work-around for poor scaling in pdfcairo pattern fill
+  * FIX segfault if mismatch between palette sizes of successive terminals
+
+---

Old:

  gnuplot-4.4.0-wxt.dif
  gnuplot-4.4.3.tar.bz2

New:

  gnuplot-4.4.4.tar.bz2



Other differences:
--
++ gnuplot.spec ++
--- /var/tmp/diff_new_pack.aiIbm2/_old  2012-01-25 12:18:36.0 +0100
+++ /var/tmp/diff_new_pack.aiIbm2/_new  2012-01-25 12:18:36.0 +0100
@@ -15,18 +15,30 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   gnuplot
-BuildRequires:  cairo-devel emacs-nox freetype2-devel gcc-c++ gd-devel 
gtk2-devel latex2html libjpeg-devel netpbm pango-devel readline-devel 
texlive-latex xorg-x11 xorg-x11-devel
+BuildRequires:  automake
+BuildRequires:  cairo-devel
+BuildRequires:  emacs-nox
+BuildRequires:  freetype2-devel
+BuildRequires:  gcc-c++
+BuildRequires:  gd-devel
+BuildRequires:  gtk2-devel
+BuildRequires:  latex2html
+BuildRequires:  libjpeg-devel
+BuildRequires:  netpbm
+BuildRequires:  pango-devel
+BuildRequires:  readline-devel
+BuildRequires:  texlive-latex
+BuildRequires:  xorg-x11
+BuildRequires:  xorg-x11-devel
 %if %suse_version  1130
 BuildRequires:  wxWidgets-devel
 %else
 BuildRequires:  wxGTK-devel
 %endif
 %if 0%{?suse_version}  1120
-BuildRequires:  libpng14-devel lua-devel
+BuildRequires:  libpng14-devel
+BuildRequires:  lua-devel
 %else
 BuildRequires:  libpng-devel
 %endif
@@ -36,11 +48,10 @@
 BuildRequires:  plotutils
 %endif
 Url:http://www.gnuplot.info/
-License:BSD3c(or similar)
+License:SUSE-Gnuplot and GPL-2.0+
 Group:  Productivity/Graphics/Visualization/Graph
-AutoReqProv:on
-Version:4.4.3
-Release:1
+Version:4.4.4
+Release:0
 Summary:GNUplot a Function Plotting Utility
 Source0:gnuplot-%{version}.tar.bz2
 Source2:gnuplot-fr.doc.bz2
@@ -48,7 +59,6 @@
 Patch0: gnuplot-4.4.1.dif
 Patch1: gnuplot-4.4.0-x11ovf.dif
 Patch2: gnuplot-4.4.0-fonts.dif
-Patch3: gnuplot-4.4.0-wxt.dif
 Patch4: gnuplot-4.4.0-demo.dif
 Patch6: gnuplot-4.2.5-fix-format-errors.dif
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ 

commit installation-images for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package installation-images for 
openSUSE:Factory checked in at 2012-01-25 12:18:48

Comparing /work/SRC/openSUSE:Factory/installation-images (Old)
 and  /work/SRC/openSUSE:Factory/.installation-images.new (New)


Package is installation-images, Maintainer is snw...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/installation-images/installation-images.changes  
2012-01-20 20:23:57.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.installation-images.new/installation-images.changes 
2012-01-25 12:18:50.0 +0100
@@ -1,0 +2,5 @@
+Wed Jan 25 09:16:21 CET 2012 - snw...@suse.de
+
+- adjusted lib deps
+
+---

Old:

  installation-images-13.22.tar.bz2

New:

  installation-images-13.23.tar.bz2



Other differences:
--
++ installation-images.spec ++
--- /var/tmp/diff_new_pack.tR6QLR/_old  2012-01-25 12:18:52.0 +0100
+++ /var/tmp/diff_new_pack.tR6QLR/_new  2012-01-25 12:18:52.0 +0100
@@ -31,8 +31,7 @@
 BuildRequires:  bzip2 cracklib cracklib-dict-full curl gpart iproute2 
libexpat1 libfuse2 libreiserfs libreiserfs-devel module-init-tools nfs-client 
ntfs-3g parted procinfo procps psmisc reiserfs squashfs strace vim xntp xz 
yast2-devtools
 BuildRequires:  alsa alsa-utils bind-libs bind-utils chkrootkit espeak lsscsi 
openldap2-client portmap python rpcbind sdparm smp_utils uuid-runtime 
xorg-x11-xauth yast2-multipath
 BuildRequires:  btrfsprogs cairo graphviz graphviz-gnome kernel-default 
kernel-firmware libiw30 pango sax2-tools unscd valgrind wireless-tools 
wpa_supplicant yast2-qt-graph
-BuildRequires:  hdparm
-BuildRequires:  sysvinit sysvinit-init
+BuildRequires:  hdparm sysvinit sysvinit-init
 %if %has_vnc
 BuildRequires:  xorg-x11-Xvnc
 %endif
@@ -109,9 +108,9 @@
 Obsoletes:  y2image
 AutoReqProv:off
 Summary:Installation Image Files
-Version:13.22
+Version:13.23
 Release:4
-Source: installation-images-13.22.tar.bz2
+Source: installation-images-13.23.tar.bz2
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %define _binary_payload w.ufdio
 

++ installation-images-13.22.tar.bz2 - installation-images-13.23.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/installation-images-13.22/VERSION 
new/installation-images-13.23/VERSION
--- old/installation-images-13.22/VERSION   2012-01-19 12:19:01.0 
+0100
+++ new/installation-images-13.23/VERSION   2012-01-25 09:16:16.0 
+0100
@@ -1 +1 @@
-13.22
+13.23
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/installation-images-13.22/changelog 
new/installation-images-13.23/changelog
--- old/installation-images-13.22/changelog 2012-01-19 12:19:05.0 
+0100
+++ new/installation-images-13.23/changelog 2012-01-25 09:16:20.0 
+0100
@@ -1,4 +1,7 @@
-2012-01-19:HEAD
+2012-01-25:HEAD
+   - adjusted lib deps
+
+2012-01-19:13.22
- use liblua5_1
 
 2012-01-18:13.21
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/installation-images-13.22/data/base/base.file_list 
new/installation-images-13.23/data/base/base.file_list
--- old/installation-images-13.22/data/base/base.file_list  2012-01-18 
11:16:44.0 +0100
+++ new/installation-images-13.23/data/base/base.file_list  2012-01-25 
08:31:59.0 +0100
@@ -328,6 +328,9 @@
 libcap*:
   /
 
+liblzo*-*:
+  /
+
 squashfs:
   /usr/bin/mksquashfs
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/installation-images-13.22/data/initrd/initrd.file_list 
new/installation-images-13.23/data/initrd/initrd.file_list
--- old/installation-images-13.22/data/initrd/initrd.file_list  2012-01-19 
12:17:34.0 +0100
+++ new/installation-images-13.23/data/initrd/initrd.file_list  2012-01-25 
08:34:41.0 +0100
@@ -398,6 +398,9 @@
 liblua5_1:
   /
 
+liblzo*-*:
+  /
+
 squashfs:
   /usr/bin/mksquashfs
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/installation-images-13.22/data/rescue/rescue.file_list 
new/installation-images-13.23/data/rescue/rescue.file_list
--- old/installation-images-13.22/data/rescue/rescue.file_list  2012-01-19 
12:17:47.0 +0100
+++ new/installation-images-13.23/data/rescue/rescue.file_list  2012-01-25 
08:34:24.0 +0100
@@ -527,9 +527,6 @@
 libgobject-*-*:
   /
 
-libgthread-*-*:
-  /
-
 libudev*:
   /
 
@@ -728,6 +725,12 @@
 libmount*:
   /
 
+liblzo*-*:
+  /
+
+squashfs:
+  /
+
 
 ###
 # to keep postin scripts 

commit libalkimia for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package libalkimia for openSUSE:Factory 
checked in at 2012-01-25 12:18:54

Comparing /work/SRC/openSUSE:Factory/libalkimia (Old)
 and  /work/SRC/openSUSE:Factory/.libalkimia.new (New)


Package is libalkimia, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libalkimia/libalkimia.changes2011-09-23 
02:07:48.0 +0200
+++ /work/SRC/openSUSE:Factory/.libalkimia.new/libalkimia.changes   
2012-01-25 12:18:55.0 +0100
@@ -1,0 +2,6 @@
+Fri Jan 20 21:38:35 UTC 2012 - asterios.dra...@gmail.com
+
+- Update to version 4.3.2:
+  * Bugfix release.
+
+---

Old:

  137323-libalkimia-4.3.1.tar.bz2

New:

  137323-libalkimia-4.3.2.tar.bz2



Other differences:
--
++ libalkimia.spec ++
--- /var/tmp/diff_new_pack.cDZeWH/_old  2012-01-25 12:18:56.0 +0100
+++ /var/tmp/diff_new_pack.cDZeWH/_new  2012-01-25 12:18:56.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libalkimia
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,28 +15,25 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   libalkimia
-Version:4.3.1
-Release:1
-License:LGPL-2.1+
+Version:4.3.2
+Release:0
 Summary:Library with common classes and functionality used by finance 
applications
-Url:http://kde-apps.org/content/show.php/libalkimia?content=137323
+License:LGPL-2.1+
 Group:  System/Libraries
+Url:http://kde-apps.org/content/show.php/libalkimia?content=137323
 Source0:
http://kde-apps.org/CONTENT/content-files/137323-%{name}-%{version}.tar.bz2
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  doxygen
 BuildRequires:  gmp-devel
 BuildRequires:  libkde4-devel
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 libalkimia is a library with common classes and functionality used by finance
 applications for the KDE SC.
 
 %package devel
-License:LGPL-2.1+
 Summary:Development Files for libalkimia
 Group:  Development/Languages/C and C++
 Requires:   libalkimia4 = %{version}
@@ -45,7 +42,6 @@
 The development files for libalkimia.
 
 %package -n libalkimia4
-License:LGPL-2.1+
 Summary:Library with common classes and functionality used by finance 
applications
 Group:  System/Libraries
 
@@ -69,12 +65,9 @@
 
 %postun -n libalkimia4 -p /sbin/ldconfig
 
-%clean
-rm -rf %{buildroot}
-
 %files devel
 %defattr(-,root,root,-)
-%doc ChangeLog ReleaseLog
+%doc libalkimia/{ChangeLog,ReleaseLog}
 %{_kde4_appsdir}/cmake/modules/FindLibAlkimia.cmake
 %{_kde4_includedir}/alkimia/
 %{_kde4_libdir}/libalkimia.so

++ 137323-libalkimia-4.3.1.tar.bz2 - 137323-libalkimia-4.3.2.tar.bz2 ++
 9050 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gthumb for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gthumb for openSUSE:Factory checked 
in at 2012-01-25 12:18:38

Comparing /work/SRC/openSUSE:Factory/gthumb (Old)
 and  /work/SRC/openSUSE:Factory/.gthumb.new (New)


Package is gthumb, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gthumb/gthumb.changes2012-01-05 
19:12:52.0 +0100
+++ /work/SRC/openSUSE:Factory/.gthumb.new/gthumb.changes   2012-01-25 
12:18:40.0 +0100
@@ -1,0 +2,10 @@
+Mon Jan 23 21:17:51 UTC 2012 - zai...@opensuse.org
+
+- Update to version 2.14.2:
+  + Fixed memory leak in 'Adjust Colors'. (bgo#667931)
+  + Fixed renaming of folders and catalogs.
+  + Fixed names of the gconf keys for the 'change date' tool.
+  + Fixed possible crash on startup.
+  + Updated translations.
+
+---

Old:

  gthumb-2.14.1.tar.xz

New:

  gthumb-2.14.2.tar.xz



Other differences:
--
++ gthumb.spec ++
--- /var/tmp/diff_new_pack.2sK7xo/_old  2012-01-25 12:18:41.0 +0100
+++ /var/tmp/diff_new_pack.2sK7xo/_new  2012-01-25 12:18:41.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gthumb
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,21 +15,18 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   gthumb
-Version:2.14.1
-Release:1
+Version:2.14.2
+Release:0
 # FIXME: Add libchamplain BuildRequires once the map feature is considered 
stable.
-License:GPLv2+
 Summary:An Image Viewer and Browser for GNOME
-Url:http://live.gnome.org/gthumb
+License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
+Url:http://live.gnome.org/gthumb
 Source: 
http://download.gnome.org/sources/gthumb/2.14/%{name}-%{version}.tar.xz
 # Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
-BuildRequires:  xz
 BuildRequires:  fdupes
+BuildRequires:  xz
 # For web albums
 BuildRequires:  bison
 BuildRequires:  brasero-devel
@@ -64,9 +61,8 @@
 slide shows, set your desktop background, and more.
 
 %package devel
-License:GPLv2+
-Group:  Productivity/Graphics/Viewers
 Summary:An Image Viewer and Browser for GNOME - Development Files
+Group:  Productivity/Graphics/Viewers
 Requires:   %{name} = %{version}
 
 %description devel

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit perl-Log-Contextual for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package perl-Log-Contextual for 
openSUSE:Factory checked in at 2012-01-25 12:19:11

Comparing /work/SRC/openSUSE:Factory/perl-Log-Contextual (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Log-Contextual.new (New)


Package is perl-Log-Contextual, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Log-Contextual.new/perl-Log-Contextual.changes 
2012-01-25 12:19:12.0 +0100
@@ -0,0 +1,15 @@
+---
+Mon Jan  9 08:47:06 UTC 2012 - co...@suse.com
+
+- update to 0.004001 
+  - Fix version of Exporter::Declare that we dep on
+  - Support Log::Contextual subclasses for default import options
+  - Allow custom log levels
+  - Fix regression that caused D* subs to dumper even if the log level was off
+
+---
+Tue Apr 12 04:36:16 UTC 2011 - co...@opensuse.org
+
+- initial package 0.00304
+* created by cpanspec 1.78.04
+

New:

  Log-Contextual-0.004001.tar.gz
  perl-Log-Contextual.changes
  perl-Log-Contextual.spec



Other differences:
--
++ perl-Log-Contextual.spec ++
#
# spec file for package perl-Log-Contextual
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:   perl-Log-Contextual
Version:0.004001
Release:0
%define cpan_name Log-Contextual
Summary:Simple logging interface with a contextual log
License:Artistic-1.0 or GPL-1.0+
Group:  Development/Libraries/Perl
Url:http://search.cpan.org/dist/Log-Contextual/
Source: 
http://www.cpan.org/authors/id/F/FR/FREW/%{cpan_name}-%{version}.tar.gz
BuildArch:  noarch
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Data::Dumper::Concise)
BuildRequires:  perl(Exporter::Declare) = 0.105
#BuildRequires: perl(BaseLogger)
#BuildRequires: perl(Exporter::Declare::Export::Generator)
#BuildRequires: perl(inc::Module::Install) = 0.91
#BuildRequires: perl(JSON)
#BuildRequires: perl(Log::Contextual)
#BuildRequires: perl(Log::Contextual::SimpleLogger)
#BuildRequires: perl(Log::Contextual::WarnLogger)
#BuildRequires: perl(Log::Log4perl)
#BuildRequires: perl(LWP::Simple)
#BuildRequires: perl(Module::Build)
#BuildRequires: perl(Module::Install::Base)
#BuildRequires: perl(Parse::CPAN::Meta)
#BuildRequires: perl(YAML::Tiny)
Requires:   perl(Data::Dumper::Concise)
Requires:   perl(Exporter::Declare) = 0.105
%{perl_requires}

%description
This module is a simple interface to extensible logging. It is bundled with
a really basic logger, the Log::Contextual::SimpleLogger manpage, but in
general you should use a real logger instead of that. For something more
serious but not overly complicated, try the Log::Dispatchouli manpage (see
the /SYNOPSIS manpage for example.)

The reason for this module is to abstract your logging interface so that
logging is as painless as possible, while still allowing you to switch from
one logger to another.

%prep
%setup -q -n %{cpan_name}-%{version}

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes

%changelog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rednotebook for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package rednotebook for openSUSE:Factory 
checked in at 2012-01-25 12:19:16

Comparing /work/SRC/openSUSE:Factory/rednotebook (Old)
 and  /work/SRC/openSUSE:Factory/.rednotebook.new (New)


Package is rednotebook, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/rednotebook/rednotebook.changes  2011-10-07 
15:22:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.rednotebook.new/rednotebook.changes 
2012-01-25 12:19:18.0 +0100
@@ -1,0 +2,34 @@
+Wed Jan 25 07:17:12 UTC 2012 - vu...@opensuse.org
+
+- Update to version 1.3.0:
+  + Let tags be categories without entries. This greatly simplifies
+and in fact unifies tags and categories.
+  + Unify clouds and search - Show the search bar above the clouds
+When a search is made, substitute the word cloud with the
+search results.
+  + Apply styling for thick horizontal lines
+- Thin line:  
+- Thick line: 
+  + Apply formatting only once if a format button is clicked
+multiple times
+  + Allow Close to tray only on Windows as most modern Linux
+distros don't have a tray anymore (lp#902228). If you still
+want the tray icon, set closeToTray=1 in the configuration
+file.
+  + Make journal saving more than twice as fast by using libyaml.
+  + Change Ctrl-PageUp(Down) directions to be more intuitive
+  + Update and revise help text
+  + Fix: utf-8 special chars not displayed correctly in html export
+for firefox (lp#910094)
+  + Fix: Do not abort if a wrong regex is entered
+  + Fix: Correctly highlight all picture formats in edit mode
+  + Fix: When the format button is clicked and a tag is selected,
+format it instead of the editor pane
+  + Write month only if changes are actually made (lp#871730)
+  + Call categories tags in more places
+  + Print PDF export path after export
+  + Do not warn if second instance is suspected (too many
+false-positives)
+  + Updated translations.
+
+---

Old:

  rednotebook-1.2.0.tar.gz

New:

  rednotebook-1.3.0.tar.gz



Other differences:
--
++ rednotebook.spec ++
--- /var/tmp/diff_new_pack.litVcX/_old  2012-01-25 12:19:19.0 +0100
+++ /var/tmp/diff_new_pack.litVcX/_new  2012-01-25 12:19:19.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package rednotebook
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,17 +15,15 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   rednotebook
-Version:1.2.0
-Release:1
+Version:1.3.0
+Release:0
 # Note: there's no lang package as of 1.1.4 because the translations are not 
installed in the usual place. See lp#687349.
 # See note at the end of README: code is using some LGPL-3.0+ module, so the 
resulting work is GPL-3.0+.
-License:GPL-3.0+
 Summary:Graphical diary and journal
-Url:http://rednotebook.sourceforge.net/
+License:GPL-3.0+
 Group:  Productivity/Office/Other
+Url:http://rednotebook.sourceforge.net/
 Source: 
http://downloads.sourceforge.net/project/rednotebook/%{name}-%{version}.tar.gz
 BuildRequires:  fdupes
 BuildRequires:  python-devel

++ rednotebook-1.2.0.tar.gz - rednotebook-1.3.0.tar.gz ++
 104939 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit sparkleshare for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package sparkleshare for openSUSE:Factory 
checked in at 2012-01-25 12:19:21

Comparing /work/SRC/openSUSE:Factory/sparkleshare (Old)
 and  /work/SRC/openSUSE:Factory/.sparkleshare.new (New)


Package is sparkleshare, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/sparkleshare/sparkleshare.changes
2012-01-05 19:15:57.0 +0100
+++ /work/SRC/openSUSE:Factory/.sparkleshare.new/sparkleshare.changes   
2012-01-25 12:19:22.0 +0100
@@ -1,0 +2,24 @@
+Mon Jan 23 07:40:00 UTC 2012 - vu...@opensuse.org
+
+- Update to version 0.8.0:
+  + Show syncing progress in the status icon
+  + Hide dock icon on Mac until you open a window
+  + Update dates in the event log after midnight
+  + Don't let git compress already compressed files (.jpg .ogg
+.zip, etc.)
+  + Limit git's memory usage
+  + Ignore history of any added git/hg/bzr repositories, just add
+the files
+  + Spin status icon on syncing changes made before startup
+- Move to pkgconfig() BuildRequires:
+  + Old ones: gtk-sharp2, notify-sharp, webkit-sharp.
+  + New ones: glib-sharp-2.0, gtk-sharp-2.0, notify-sharp,
+webkit-sharp-1.0.
+- Remove unneeded ndesk-dbus and ndesk-dbus-glib-devel
+  BuildRequires, and ndesk-dbus Requires: they're not used anymore.
+- Remove gtk-sharp2, notify-sharp, webkit-sharp Requires: they are
+  automatically added the mono() way.
+- Add help-C.tar.bz2 source containing help files, as those files
+  are missing from the tarball again.
+
+---

Old:

  sparkleshare-0.6.0.tar.gz

New:

  help-C.tar.bz2
  sparkleshare-0.8.0.tar.gz



Other differences:
--
++ sparkleshare.spec ++
--- /var/tmp/diff_new_pack.IgfLym/_old  2012-01-25 12:19:24.0 +0100
+++ /var/tmp/diff_new_pack.IgfLym/_new  2012-01-25 12:19:24.0 +0100
@@ -15,37 +15,33 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %define pynautilusextdir %(pkg-config --variable=pythondir 
nautilus-python)
 
 Name:   sparkleshare
-Version:0.6.0
+Version:0.8.0
 Release:0
 Summary:A file sharing and collaboration tool
 License:GPL-3.0
 Group:  Productivity/Archiving/Backup
 Url:http://sparkleshare.org
 Source: 
https://github.com/downloads/hbons/SparkleShare/%{name}-%{version}.tar.gz
+# Help files missing from tarball, again
+Source1:help-C.tar.bz2
 BuildRequires:  fdupes
 BuildRequires:  gnome-doc-utils-devel
-BuildRequires:  gtk-sharp2
 BuildRequires:  intltool
 BuildRequires:  mono-devel
 BuildRequires:  nant
-BuildRequires:  ndesk-dbus
-BuildRequires:  ndesk-dbus-glib-devel
-BuildRequires:  notify-sharp
 BuildRequires:  python-nautilus-devel
 BuildRequires:  update-desktop-files
-BuildRequires:  webkit-sharp
+BuildRequires:  pkgconfig(glib-sharp-2.0) = 2.12.2
+BuildRequires:  pkgconfig(gtk-sharp-2.0) = 2.12.2
+BuildRequires:  pkgconfig(notify-sharp)
+BuildRequires:  pkgconfig(webkit-sharp-1.0)
 Requires:   git-core = 1.7.1
-Requires:   gtk-sharp2
 Requires:   gvfs
 Requires:   mono-core
-Requires:   ndesk-dbus
-Requires:   notify-sharp
 Requires:   openssh
-Requires:   webkit-sharp
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
@@ -86,7 +82,7 @@
 
 %lang_package
 %prep
-%setup -q
+%setup -q -a1
 if [ -x AUTHORS ]; then
   chmod a-x AUTHORS LICENSE NEWS
 else

++ sparkleshare-0.6.0.tar.gz - sparkleshare-0.8.0.tar.gz ++
 16391 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit tmux for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package tmux for openSUSE:Factory checked in 
at 2012-01-25 12:19:26

Comparing /work/SRC/openSUSE:Factory/tmux (Old)
 and  /work/SRC/openSUSE:Factory/.tmux.new (New)


Package is tmux, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/tmux/tmux.changes2011-09-23 
12:48:20.0 +0200
+++ /work/SRC/openSUSE:Factory/.tmux.new/tmux.changes   2012-01-25 
12:19:28.0 +0100
@@ -1,0 +2,58 @@
+Tue Jan 24 09:16:45 UTC 2012 - g...@opensuse.org
+
+- update to version 1.6
+  - extend the mode-mouse option to add a third choice which means
+the mouse does not enter copy mode
+  - add a -r flag to switch-client to toggle the client read-only
+flag
+  - add pane-base-index option
+  - support \ for line continuation in the configuration file
+  - framework for more powerful formatting of command output and
+use it for list-{panes,windows,sessions}; this allows more
+descriptive replacements (such as #{session_name}) and
+conditionals
+  - mark dead panes with some text saying they are dead
+  - reject $SHELL if it is not a full path
+  - add -S option to refresh-client to redraw status line
+  - add an else clause for if-shell
+  - try to resolve relative paths for loadb and saveb (first, using
+client working directory, if any, then default-path or session
+working directory)
+  - support for \e[3J to clear the history and send the
+corresponding terminfo code (E3) before locking
+  - when in copy mode, make repeat count indicate buffer to
+replace, if used
+  - add screen*:XT to terminal-overrides for tmux-in-tmux
+  - status-line message attributes added
+  - move word-separators to be a session rather than window option
+  - change the way the working directory for new processes is
+discovered; if default-path isn't empty, it is used; otherwise,
+if a new window is created from the command-line, the working
+directory of the client is used; if not, platform specific code
+is used to retrieve the current working directory of the
+process in the active pane; if that fails, the directory where
+the session was created is used, instead
+  - do not change the current pane if both
+mouse-select-{pane,window} are enabled
+  - add \033[s and \033[u to save and restore cursor position
+  - allow $HOME to be used as default-path
+  - add CNL and CPL escape sequences
+  - calculate last position correctly for UTF-8 wide characters
+  - add an option allow-rename to disable the window rename escape
+sequence
+  - attributes for each type of status-line alert (ie bell, content
+and activity) added; therefore, remove the superfluous options
+window-status-alert-{attr,bg,fg}
+  - add a -R flag to send-keys to reset the terminal
+  - add strings to allow the aixterm bright colours to be used when
+configuring colours
+  - drop the ability to have a list of keys in the prefix in favour
+of two separate options, prefix and prefix2
+  - flag -2 added to send-prefix to send the secondary prefix key
+  - show pane size in top right of display panes mode
+  - some memory leaks plugged
+  - more command-prompt editing improvements
+  - various manpage improvements
+  - more Vi mode improvements
+
+---

Old:

  tmux-1.5.tar.gz

New:

  tmux-1.6.tar.gz



Other differences:
--
++ tmux.spec ++
--- /var/tmp/diff_new_pack.kW7KcE/_old  2012-01-25 12:19:29.0 +0100
+++ /var/tmp/diff_new_pack.kW7KcE/_new  2012-01-25 12:19:29.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package tmux
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c) 2010 Guido Berhoerster.
 #
 # All modifications and additions to the file contributed by third parties
@@ -16,18 +16,15 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   tmux
-Version:1.5
-Release:1
+Version:1.6
+Release:0
 Summary:Terminal multiplexer
-Group:  System/Console
 License:ISC ; BSD-3-Clause ; BSD-2-Clause
+Group:  System/Console
 Url:http://tmux.sourceforge.net/
-AutoReqProv:on
-BuildRequires:  ncurses-devel
 BuildRequires:  libevent-devel
+BuildRequires:  ncurses-devel
 Source: %{name}-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 

++ tmux-1.5.tar.gz - tmux-1.6.tar.gz ++
 8080 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yelp-tools for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package yelp-tools for openSUSE:Factory 
checked in at 2012-01-25 12:19:43

Comparing /work/SRC/openSUSE:Factory/yelp-tools (Old)
 and  /work/SRC/openSUSE:Factory/.yelp-tools.new (New)


Package is yelp-tools, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/yelp-tools/yelp-tools.changes2012-01-06 
11:47:05.0 +0100
+++ /work/SRC/openSUSE:Factory/.yelp-tools.new/yelp-tools.changes   
2012-01-25 12:19:49.0 +0100
@@ -1,0 +2,10 @@
+Mon Jan 23 19:24:46 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.3.2:
+  + yelp.m4: Custom distdir target to work around Argument list
+too long
+- Add xz BuildRequires because we can't build a package for a
+  xz-compressed tarball without explicitly specifying that... See
+  bnc#697467 for more details.
+
+---

Old:

  yelp-tools-3.3.1.tar.bz2

New:

  yelp-tools-3.3.2.tar.xz



Other differences:
--
++ yelp-tools.spec ++
--- /var/tmp/diff_new_pack.7hMdqa/_old  2012-01-25 12:19:51.0 +0100
+++ /var/tmp/diff_new_pack.7hMdqa/_new  2012-01-25 12:19:51.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package yelp-tools
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,18 +15,21 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   yelp-tools
-Version:3.3.1
+Version:3.3.2
 Release:0
 Summary:Collection of utilities to help create documentation
 License:GPL-2.0+
 Group:  Development/Tools/Other
 Url:http://projects.gnome.org/yelp/
-Source: 
http://download.gnome.org/sources/yelp-tools/3.3/%{name}-%{version}.tar.bz2
+Source: 
http://download.gnome.org/sources/yelp-tools/3.3/%{name}-%{version}.tar.xz
 BuildRequires:  itstool
 BuildRequires:  libxml2
 BuildRequires:  libxslt
 BuildRequires:  pkg-config
+# Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
+BuildRequires:  xz
 BuildRequires:  pkgconfig(yelp-xsl)
 Requires:   itstool
 Requires:   libxml2

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit xsel for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package xsel for openSUSE:Factory checked in 
at 2012-01-25 12:19:32

Comparing /work/SRC/openSUSE:Factory/xsel (Old)
 and  /work/SRC/openSUSE:Factory/.xsel.new (New)


Package is xsel, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/xsel/xsel.changes2011-09-23 
12:52:45.0 +0200
+++ /work/SRC/openSUSE:Factory/.xsel.new/xsel.changes   2012-01-25 
12:19:33.0 +0100
@@ -1,0 +2,5 @@
+Thu Nov  3 09:06:49 UTC 2011 - pascal.ble...@opensuse.org
+
+- build fixes for SLE_10 and SLE_11
+
+---



Other differences:
--
++ xsel.spec ++
--- /var/tmp/diff_new_pack.izVTUa/_old  2012-01-25 12:19:34.0 +0100
+++ /var/tmp/diff_new_pack.izVTUa/_new  2012-01-25 12:19:34.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package xsel (Version 1.2.0)
+# spec file for package xsel
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c) 2010 Guido Berhoerster.
 #
 # All modifications and additions to the file contributed by third parties
@@ -24,35 +24,39 @@
 Release:1
 License:MIT
 Group:  System/X11/Utilities
-AutoReqProv:on
 Source: 
http://www.kfish.org/software/xsel/download/xsel-%{version}.tar.gz
 Url:http://www.kfish.org/software/xsel/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+%if 0%{?suse_version}  0  0%{?suse_version}  1000
+BuildRequires:  XFree86-devel
+%else
 BuildRequires:  xorg-x11-devel
-Requires:   xorg-x11
+%endif
 
 %description
 XSel is a command-line program for getting and setting the contents of the X
 selection. Normally this is only accessible by manually highlighting
 information and pasting it with the middle mouse button.
 
-
-Authors:
-
-Conrad Parker con...@vergenet.net
-
 %prep
 %setup -q
 
 %build
-%configure
+%if 0%{?suse_version}  0  0%{?suse_version}  1100
+export CFLAGS=%{optflags} -L%{_usr}/X11R6/%{_lib} -lX11
+%endif
+%configure \
+%if 0%{?suse_version}  0  0%{?suse_version}  1100
+--x-includes=%{_usr}/X11R6/include
+%endif
+
 make %{?_smp_mflags}
 
 %install
-%make_install
+make DESTDIR=%{buildroot} install
 
 %clean
-rm -rf $RPM_BUILD_ROOT
+%{?buildroot:%__rm -rf %{buildroot}}
 
 %files
 %defattr(-,root,root,-)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit aaa_base for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package aaa_base for openSUSE:Factory 
checked in at 2012-01-25 15:00:53

Comparing /work/SRC/openSUSE:Factory/aaa_base (Old)
 and  /work/SRC/openSUSE:Factory/.aaa_base.new (New)


Package is aaa_base, Maintainer is r...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/aaa_base/aaa_base.changes2012-01-19 
09:40:43.0 +0100
+++ /work/SRC/openSUSE:Factory/.aaa_base.new/aaa_base.changes   2012-01-25 
15:00:54.0 +0100
@@ -1,0 +2,5 @@
+Fri Jan 20 10:19:45 UTC 2012 - lnus...@suse.de
+
+- Make alljava.(c)sh friendly to third-party JVMs (bnc#722252)
+
+---



Other differences:
--
++ aaa_base.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aaa_base/files/etc/profile.d/alljava.csh 
new/aaa_base/files/etc/profile.d/alljava.csh
--- old/aaa_base/files/etc/profile.d/alljava.csh2012-01-17 
14:33:54.0 +0100
+++ new/aaa_base/files/etc/profile.d/alljava.csh2012-01-20 
11:18:10.0 +0100
@@ -1,46 +1,41 @@
 #
 #/etc/profile.d/alljava.csh
 #
-# send feedback to http://www.suse.de/feedback
+# send feedback to http://bugs.opensuse.org
 
 #
 # This script sets some environment variables for default java.
-# Affected variables: PATH, JAVA_BINDIR, JAVA_HOME, JRE_HOME, 
+# Affected variables: JAVA_BINDIR, JAVA_HOME, JRE_HOME, 
 # JDK_HOME, SDK_HOME
 #
 
-set __libdir=lib
-if ( -l /usr/lib64/jvm/java || -l /usr/lib64/jvm/jre ) then
-  set __libdir=lib64
-endif
-
-if ( -x /usr/$__libdir/jvm/java/bin/java || -x /usr/$__libdir/jvm/java/bin/jre 
) then
-  setenv JAVA_BINDIR /usr/$__libdir/jvm/java/bin
-  setenv JAVA_ROOT /usr/$__libdir/jvm/java
-  setenv JAVA_HOME /usr/$__libdir/jvm/java
-  setenv JRE_HOME /usr/$__libdir/jvm/jre
-  unsetenv JDK_HOME
-  unsetenv SDK_HOME
-  if ( -x /usr/$__libdir/jvm/java/bin/javac ) then
-# it is development kit 
-if ( -x /usr/$__libdir/jvm/java/bin/jre ) then
-  setenv JDK_HOME /usr/$__libdir/jvm/java
-else
-  setenv JDK_HOME /usr/$__libdir/jvm/java
-  setenv SDK_HOME /usr/$__libdir/jvm/java
-endif
-  endif
-else
-  if ( -x /usr/$__libdir/jvm/jre/bin/java ) then
-# it is IBMJava2-JRE or SunJava2-JRE
-setenv PATH ${PATH}:/usr/$__libdir/jvm/jre/bin
-setenv JAVA_BINDIR /usr/$__libdir/jvm/jre/bin
-setenv JAVA_ROOT /usr/$__libdir/jvm/jre
-setenv JAVA_HOME /usr/$__libdir/jvm/jre
-setenv JRE_HOME /usr/$__libdir/jvm/jre
-unsetenv JDK_HOME
-unsetenv SDK_HOME
-  endif
-endif
+foreach JDIR ( /usr/lib64/jvm /usr/lib/jvm /usr/java/latest /usr/java )
 
-unset __libdir
+if ( ! -d $JDIR ) continue
+
+foreach JPATH ( $JDIR $JDIR/java `ls -I 'java' -I 'jre' -d $JDIR/*` 
$JDIR/jre )
+
+if ( ! -x $JPATH/bin/java ) continue
+
+setenv JAVA_BINDIR $JPATH/bin
+setenv JAVA_ROOT $JPATH
+setenv JAVA_HOME $JPATH
+unset JDK_HOME
+unset SDK_HOME
+
+switch ( $JPATH )
+case *jre*:
+setenv JRE_HOME $JPATH
+breaksw
+default:
+setenv JRE_HOME $JPATH/jre
+# it is development kit=20
+if ( -x $JPATH/bin/javac ) then
+setenv JDK_HOME $JPATH
+setenv SDK_HOME $JPATH
+endif
+endsw
+end
+unset JPATH
+end
+unset JDIR
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aaa_base/files/etc/profile.d/alljava.sh 
new/aaa_base/files/etc/profile.d/alljava.sh
--- old/aaa_base/files/etc/profile.d/alljava.sh 2012-01-17 14:33:54.0 
+0100
+++ new/aaa_base/files/etc/profile.d/alljava.sh 2012-01-20 11:18:10.0 
+0100
@@ -1,46 +1,49 @@
 #  
 
 #/etc/profile.d/alljava.sh 
   
 #  
 
-# send feedback to http://www.suse.de/feedback
+# send feedback to http://bugs.opensuse.org
 
 #
 # This script sets some environment variables for default java.
-# Affected variables: PATH, JAVA_BINDIR, JAVA_HOME, JRE_HOME, 
+# Affected variables: JAVA_BINDIR, JAVA_HOME, JRE_HOME, 
 # JDK_HOME, SDK_HOME
 #
 
-__libdir=lib
-if [ -x /usr/lib64/jvm/java ] || [ -x /usr/lib64/jvm/jre ] ; then
-  __libdir=lib64
-fi
-
-if [ -x /usr/$__libdir/jvm/java/bin/java ] || [ -x 
/usr/$__libdir/jvm/java/bin/jre ] ; then
-  export JAVA_BINDIR=/usr/$__libdir/jvm/java/bin
-  export JAVA_ROOT=/usr/$__libdir/jvm/java
-  export JAVA_HOME=/usr/$__libdir/jvm/java
-  export 

commit ant for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package ant for openSUSE:Factory checked in 
at 2012-01-25 15:01:03

Comparing /work/SRC/openSUSE:Factory/ant (Old)
 and  /work/SRC/openSUSE:Factory/.ant.new (New)


Package is ant, Maintainer is bnc-team-j...@forge.provo.novell.com

Changes:

--- /work/SRC/openSUSE:Factory/ant/ant.changes  2012-01-06 11:42:56.0 
+0100
+++ /work/SRC/openSUSE:Factory/.ant.new/ant.changes 2012-01-25 
15:01:05.0 +0100
@@ -1,0 +2,6 @@
+Wed Jan 25 09:54:17 UTC 2012 - mvysko...@suse.cz
+
+- use new _mavendepmapfragdir macro instead of hardocded path
+- change java-devel Requires to Recommends
+
+---



Other differences:
--
++ ant.spec ++
--- /var/tmp/diff_new_pack.0oOBjs/_old  2012-01-25 15:01:06.0 +0100
+++ /var/tmp/diff_new_pack.0oOBjs/_new  2012-01-25 15:01:06.0 +0100
@@ -80,7 +80,8 @@
 Requires:   xml-commons-apis
 Requires:   xml-commons-resolver
 Requires:   jpackage-utils = 1.7.5
-Requires:   java-devel = 1.5.0
+# allow usage third-party java in future
+Recommends: java-devel = 1.5.0
 Obsoletes:  apache-ant  %{version}
 Provides:   apache-ant = %{version}
 Obsoletes:  ant-nodeps  %{version}
@@ -688,7 +689,6 @@
 %{_datadir}/maven2/poms/JPP-ant-parent.pom
 %{_datadir}/maven2/poms/JPP-ant.pom
 %config(noreplace) %{_mavendepmapfragdir}/*
-%config(noreplace) %dir %{_sysconfdir}/maven/fragments
 %dir %{_datadir}/maven2
 %dir %{_datadir}/maven2/poms
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit cronie for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package cronie for openSUSE:Factory checked 
in at 2012-01-25 15:01:08

Comparing /work/SRC/openSUSE:Factory/cronie (Old)
 and  /work/SRC/openSUSE:Factory/.cronie.new (New)


Package is cronie, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/cronie/cronie.changes2011-12-06 
17:58:42.0 +0100
+++ /work/SRC/openSUSE:Factory/.cronie.new/cronie.changes   2012-01-25 
15:01:09.0 +0100
@@ -1,0 +2,17 @@
+Wed Jan 18 15:15:14 UTC 2012 - tabra...@novell.com
+
+- removed cronie-1.4.7-syslog_output.patch deprecated by this update
+
+- Update to 1.4.8
+  + Cron writes job output to syslog incorrectly. When cron is
+invoked in a way to print job output to syslog, it does print
+only the first character of the output
+  + Check orphanded crontabs for adoption
+  + Unify logging in case SyslogOutput with the rest of crond
+  + The charset of anacron's mail is always ANSI_X3.4-1968. There
+are no setlocale in anacron's source
+  + Cronie disables inotify when the /etc/crontab file does not
+exist at startup. Existance of crontab and directories wasn't
+controlled before creating inotify watches.
+
+---

Old:

  cronie-1.4.7-syslog_output.patch
  cronie-1.4.7.tar.gz

New:

  cronie-1.4.8.tar.gz



Other differences:
--
++ cronie.spec ++
--- /var/tmp/diff_new_pack.nXCTHO/_old  2012-01-25 15:01:09.0 +0100
+++ /var/tmp/diff_new_pack.nXCTHO/_new  2012-01-25 15:01:09.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package cronie
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -14,6 +14,8 @@
 
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
+
+
 # 3 : we don't need to do something with /etc/sysconfig/cron for now
 %define cron_configs 
\{/etc/init.d/cron,/etc/pam.d/crond,/etc/crontab,/etc/cron.deny,/etc/omc/srvinfo.d/cron.xml\}
 
@@ -30,7 +32,7 @@
 Recommends: postfix
 PreReq: permissions %fillup_prereq %insserv_prereq cron 
sysvinit(syslog)
 %{?systemd_requires}
-Version:1.4.7
+Version:1.4.8
 Release:0
 %{expand: %%define cronie_version %version}
 Summary:Cron Daemon
@@ -51,8 +53,6 @@
 Patch4: %name-nheader_lines.diff
 # we use cron.pid instead of crond.pid 
 Patch5: %name-crond_pid.diff
-# PATCH-FIX-UPSTREAM cronie-1.4.7-syslog_output.patch bnc#692871
-Patch6: cronie-1.4.7-syslog_output.patch
 # PATCH-FIX-UPSTREAM mention logging disabling for a command in man
 Patch7: cronie-1.4.7-disable_logging.patch
 # PATCH-FIX-UPSTREAM use run-crons instead of run-parts for anacron 
(bnc#689494)
@@ -96,7 +96,6 @@
 %patch3 -p1
 %patch4
 %patch5 -p1
-%patch6 -p1
 %patch7 -p1
 %patch8 -p1
 cp %{S:7} ./cron_to_cronie.README


++ cronie-1.4.7.tar.gz - cronie-1.4.8.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cronie-1.4.7/ChangeLog new/cronie-1.4.8/ChangeLog
--- old/cronie-1.4.7/ChangeLog  2011-03-15 13:13:17.0 +0100
+++ new/cronie-1.4.8/ChangeLog  2011-06-27 16:02:25.0 +0200
@@ -1,3 +1,44 @@
+2011-06-24  Marcela Mašláňová mmasl...@redhat.com
+
+   * src/do_command.c: Cron writes job output to syslog incorrectly.
+   When cron is invoked in a way to print job output to syslog, it does
+   print only the first character of the output. Author: Vitezslav
+   Cizek Signed-off-by: Marcela Mašláňová mmasl...@redhat.com
+
+2011-06-21  Tomas Mraz tm...@fedoraproject.org
+
+   * src/cron.c, src/database.c, src/funcs.h, src/structs.h: Check
+   orphaned crontabs for adoption.
+
+2011-06-21  Tomas Mraz tm...@fedoraproject.org
+
+   * src/do_command.c: Unify logging in case of SyslogOutput with the
+   rest of crond.
+
+2011-05-26  Marcela Mašláňová mmasl...@redhat.com
+
+   * man/cron.8, man/crontab.1: Change of email adress of cluster
+   support author.
+
+2011-05-16  Kiyoshi OHGISHI ohgi...@gaia.eonet.ne.jp
+
+   * anacron/main.c: The charset of anacron's mail is always
+   ANSI_X3.4-1968. There are no setlocale is anacron's source.  
Signed-off-by: Marcela Mašláňová mmasl...@redhat.com
+
+2011-04-28  Marcela Mašláňová mmasl...@redhat.com
+
+   * src/cron.c: Cronie disables inotify support when the /etc/crontab
+   file does not exist at startup.  Existence of crontab and directories 
wasn't controlled before
+   creating inotify watches.
+

commit eject for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package eject for openSUSE:Factory checked 
in at 2012-01-25 15:01:12

Comparing /work/SRC/openSUSE:Factory/eject (Old)
 and  /work/SRC/openSUSE:Factory/.eject.new (New)


Package is eject, Maintainer is vci...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/eject/eject.changes  2011-12-12 
16:59:18.0 +0100
+++ /work/SRC/openSUSE:Factory/.eject.new/eject.changes 2012-01-25 
15:01:15.0 +0100
@@ -1,0 +2,11 @@
+Tue Jan 24 16:31:59 UTC 2012 - lnus...@suse.de
+
+- use %set_permissions instead of the obsolete %run_permissions
+- don't install INSTALL
+
+---
+Mon Jan 23 14:06:56 UTC 2012 - crrodrig...@opensuse.org
+
+- Build with -pie and full RELRO 
+
+---



Other differences:
--
++ eject.spec ++
--- /var/tmp/diff_new_pack.0aVSHk/_old  2012-01-25 15:01:16.0 +0100
+++ /var/tmp/diff_new_pack.0aVSHk/_new  2012-01-25 15:01:16.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package eject
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,8 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
+
 Name:   eject
 BuildRequires:  automake
 BuildRequires:  recode
@@ -57,6 +59,8 @@
 %patch9 -p1
 
 %build
+export CFLAGS=%optflags -fpie
+export LDFLAGS=-pie  -Wl,-z,relro,-z,now
 aclocal
 automake -a
 autoconf
@@ -70,13 +74,14 @@
 %find_lang %{name}
 
 %post
-%run_permissions
+%set_permissions /bin/eject
+
 %verifyscript
 %verify_permissions -e /bin/eject
 
 %files -f %{name}.lang
 %defattr(-,root,root)
-%doc README COPYING ChangeLog TODO PORTING INSTALL
+%doc README COPYING ChangeLog TODO PORTING
 %doc %{_mandir}/man?/*
 %verify(not mode) %attr(4750,root,audio) /bin/eject
 %{_bindir}/*

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit findutils for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package findutils for openSUSE:Factory 
checked in at 2012-01-25 15:01:17

Comparing /work/SRC/openSUSE:Factory/findutils (Old)
 and  /work/SRC/openSUSE:Factory/.findutils.new (New)


Package is findutils, Maintainer is p...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/findutils/findutils.changes  2011-12-06 
17:59:01.0 +0100
+++ /work/SRC/openSUSE:Factory/.findutils.new/findutils.changes 2012-01-25 
15:01:19.0 +0100
@@ -1,0 +2,181 @@
+Tue Jan 17 02:40:55 UTC 2012 - tabra...@novell.com
+
+- removed patches deprecated by this release
+  - findutils-4.4.2-selinux.patch
+  - findutils-4.4.2-selinux-gnulib.patch
+  - findutils-4.4.2-fts-remount.patch
+- refreshed other patches as required
+
+- Update to 4.5.10
+  + doc: The manual now includes a small number of references to 
+   further reading on security.
+  + fixed bug #30608: Automagic dependency on selinux. The configure 
+script now provides a --without-selinux option.
+  + fixed bug #29949: find -execdir does not change working directory
+  + fixed bug #31359: test-strstr unit test fails on alpha.
+  + fixed bug #30777: find -exec echo TURNIP{} \+ is accepted but 
+TURNIP is eaten
+  + fixed bug #30180: error message from incorrect -size option is off
+  + fixed bug #29828: test suite deadlock on FreeBSD
+  + updated translations - Finnish, Italian, Danish, Slovenian,
+German, Estonian, French, Japanese and Danish
+
+- Update to 4.5.9
+  + fixed bug #29593: Make import-gnulib.sh work under a POSIX shell.
+  + fixed bug #29511: fails to build on kfreebsd-*
+  + fixed bug #27563: -L breaks -execdir
+  + fixed bug #19593: -execdir  {} + has suboptimal performance 
+(see below)
+  + updated translation - Chinese (simplified)
+  + The find program will once again build argument lists longer 
+than 1 with -execdir ...+.  The upper limit of 1 argument for 
+execdir was introduced as a workaround in findutils-4.3.4. The 
+limit is now removed, but find still does not issue the maximum 
+possible number of arguments, since an exec will occur each time 
+find encounters a subdirectory (if at least one argument is 
+pending).
+  + You can now increase the parallelism of xargs in mid-run by 
+sending it SIGUSR1, and decrease the parallelism with SIGUSR2.
+
+- Update to 4.5.8
+  + fixed bug #29460: -printf %Y fails in $CWD-dependent way
+  + fixed bug #27974: Use gnulib's xreadlinkat support
+  + fixed bug #29435: fd_is_cloexec does not work on Fedora buildhosts
+  + fixed bug #27221: symlink_loop check broken by FTS_CWDFD
+  + fixed bug #27213: avoid failed assertions for non-executable 
+directories.
+  + updated translations - Vietnamese, Czech, Dutch, Polish, Russian
+
+- Update to 4.5.7
+  + If you use the -fstype FOO predicate and specify a filsystem 
+type FOO which is not known (e.g. present in /etc/mtab) at the 
+time find starts, that predicate is now equivalent to -false. 
+This substitution currently occurs at optimisation level 2 and 
+above.
+
+- Update to 4.5.6
+  + patch #4848 - support for SELinux
+  + fixed bug #29089 - SELinux --context and %Z options
+  + fixed bug #28872: Mistake in #safer example in Problems with 
+-exec and filenames section of the Texinfo manual.
+  + fixed bug #28824: Corrected error message for -ctime x.
+Likewise for -gid, -inum, -links, -mmin, -cmin, -amin,
+-uid, -used, -atime, -mtime, -ctime.
+  + fixed bug #27975: Infinite loop for -exec [..] {} +.
+  + fixed bug #27846: Assertion failure in xargs.c on AIX.
+  + fixed bug #27375: Open file descriptors leak into child processes.
+  + fixed bug #27017: find -D opt / -fstype ext3 -print , -quit coredumps
+  + fixed bug #27328: segfault if the initial exec for find -exec fails.
+  + fixed bug #26868: compilation error in pred.c on Solaris x86_64
+  + fixed bug #24873: Duplicate fprint option corrupts output
+  + fixed bug #23920: warn about un-matchable -path arguments ending in /.
+  + fixed bug #19120: Patch to fix single quotes in man page find(1)
+  + fixed bug #26327: xargs man page is vague about the number of times 
+command is executed.
+
+- Update to 4.5.5
+  + xargs now handles the case where the system's actual exec limits
+are smaller than the value of ARG_MAX at compile time. Very few
+platforms normally have this property, but it is possible to
+configure sume Unix systems this way.
+  + fixed bug #25359 - files/testsuite/find.gnu/posix-h.exp test fail
+  + fixed bug #26587 - fix a typo in -execdir documentation (it says
+-exec by mistake in the text)
+  + fixed bug #26537 - find -prune now makes sure it has valid stat()
+information
+  + fixed bug #22708 - exit status 126 and 127 from the utility invoked
+from xargs now 

commit gnumeric for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package gnumeric for openSUSE:Factory 
checked in at 2012-01-25 15:01:21

Comparing /work/SRC/openSUSE:Factory/gnumeric (Old)
 and  /work/SRC/openSUSE:Factory/.gnumeric.new (New)


Package is gnumeric, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gnumeric/gnumeric.changes2011-10-26 
15:36:12.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnumeric.new/gnumeric.changes   2012-01-25 
15:01:24.0 +0100
@@ -1,0 +2,58 @@
+Thu Jan 19 07:56:17 UTC 2012 - vu...@opensuse.org
+
+- Add explicit pkgconfig() BuildRequires: glib-2.0, pango,
+  pangocairo. Those were all implicitly brought in before.
+- Change goffice-devel BuildRequires to pkgconfig(libgoffice-0.10),
+  to avoid any confusion between goffice-0_8 and goffice.
+- Stop changing Name of gnumeric.desktop: it's already fine
+  upstream.
+
+---
+Mon Jan  9 16:37:21 UTC 2012 - dims...@opensuse.org
+
+- Update to version 1.11.1:
+  + Show range selection cursors even while selecting new regions
+and on other sheets
+  + Fixed expression range cursor behavior [bgo#664852]
+  + Build fixes relating to embedded ui files [bgo#664828]
+- Changes from version 1.11.0:
+  + Highlights:
+- Gnumeric uses GTK+ 3, not GTK+ 2.
+- Gnumeric uses GTK+'s ui manager files, not libglade.
+- Gnumeric uses GSettings, not GConf.
+- Lots of small bug fixes.
+  + Various fixes for xls, xlsx and ODF compatibility.
+  + Add support for SVG images.
+  + Clarify the distinction beween open/save and import/export.
+  + Add HPFILTER function calculating the Hodrick Prescott Filter.
+  + Enable markup selection in scientific format selector.
+  + Fix IRR and other functions acting on paired data set when
+called with fixed arrays.
+  + Remove obsolete Hildon port and obsolete code.
+  + Bugs fixed: bgo#304007, bgo#356711, bgo#425685, bgo#455712,
+bgo#535473, bgo#584380, bgo#603533, bgo#627509, bgo#628472,
+bgo#634803, bgo#645673, bgo#645842, bgo#651561, bgo#655877,
+bgo#656418, bgo#656799, bgo#657036, bgo#657506, bgo#658140,
+bgo#658194, bgo#658223, bgo#658639, bgo#658916, bgo#658981,
+bgo#658982, bgo#659246, bgo#660241, bgo#660242, bgo#660248,
+bgo#660605, bgo#660657, bgo#661213, bgo#661405, bgo#661720,
+bgo#661855, bgo#661958, bgo#662056, bgo#662056, bgo#662149,
+bgo#662310, bgo#662331, bgo#662361, bgo#662412, bgo#662413,
+bgo#662472, bgo#662474, bgo#662551, bgo#663078, bgo#663117,
+bgo#663135, bgo#663216, bgo#663663, bgo#663671, bgo#663712,
+bgo#663802, bgo#664243, bgo#664351, bgo#664447, bgo#664692,
+bgo#664754, deb#642135, lp#262777.
+  + Updated translations.
+- Add xz BuildRequires because we can't build a package for a
+  xz-compressed tarball without explicitly specifying that... See
+  bnc#697467 for more details.
+- Replace gtk2-devel BuildRequires with pkgconfig(gtk+-3.0),
+  following upstreams change to GTK 3.
+- Drop gconf2-devel BuildRequires: with the move to GSettings this
+  is no longer needed.
+- Remove gconf schema handling macros: gconf is no longer used.
+- Clean spec-file using spec-cleaner.
+- Remove explicit Requires from the -devel package: they are added
+  automatically the pkgconfig()-way.
+
+---

Old:

  gnumeric-1.10.17.tar.bz2

New:

  gnumeric-1.11.1.tar.xz



Other differences:
--
++ gnumeric.spec ++
--- /var/tmp/diff_new_pack.JcVi00/_old  2012-01-25 15:01:28.0 +0100
+++ /var/tmp/diff_new_pack.JcVi00/_new  2012-01-25 15:01:28.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gnumeric
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,21 +15,16 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   gnumeric
-Version:1.10.17
-Release:1
+Version:1.11.1
+Release:0
 Summary:Spreadsheet Application
 License:GPL-2.0+
-Url:http://www.gnumeric.org/
 Group:  Productivity/Office/Spreadsheets
-Source0:
http://download.gnome.org/sources/gnumeric/1.10/%{name}-%{version}.tar.bz2
+Url:http://www.gnumeric.org/
+Source0:
http://download.gnome.org/sources/gnumeric/1.11/%{name}-%{version}.tar.xz
 BuildRequires:  fdupes
-BuildRequires:  gconf2-devel
-BuildRequires:  goffice-devel
-BuildRequires:  gtk2-devel
 

commit guile1 for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package guile1 for openSUSE:Factory checked 
in at 2012-01-25 15:01:44

Comparing /work/SRC/openSUSE:Factory/guile1 (Old)
 and  /work/SRC/openSUSE:Factory/.guile1.new (New)


Package is guile1, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/guile1/guile1.changes2012-01-20 
20:23:45.0 +0100
+++ /work/SRC/openSUSE:Factory/.guile1.new/guile1.changes   2012-01-25 
15:01:45.0 +0100
@@ -1,0 +2,6 @@
+Wed Jan 25 09:00:05 UTC 2012 - pgaj...@suse.com
+
+- package /usr/share/aclocal/guile1.m4 (gnucash uses autoreconf)
+  (GUILE_* macros renamed to GUILE1_*) [bnc#724917]
+
+---



Other differences:
--
++ guile1.spec ++
--- /var/tmp/diff_new_pack.mVz8nU/_old  2012-01-25 15:01:46.0 +0100
+++ /var/tmp/diff_new_pack.mVz8nU/_new  2012-01-25 15:01:46.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package guile
+# spec file for package guile1
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,19 +18,24 @@
 
 %define binpref guile1
 Name:   guile1
-BuildRequires:  gc-devel gmp-devel readline-devel pkg-config automake libtool
-License:LGPL-2.1+
-Group:  Development/Languages/Scheme
+BuildRequires:  automake
+BuildRequires:  gc-devel
+BuildRequires:  gmp-devel
+BuildRequires:  libtool
+BuildRequires:  pkg-config
+BuildRequires:  readline-devel
 Version:1.8.8
 Release:0
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+License:LGPL-2.1+
+Group:  Development/Languages/Scheme
 Url:http://www.gnu.org/software/guile/
 Source0:guile-%{version}.tar.bz2
 Patch1: guile-64bit.patch
 Patch2: guile-1.6.10-mktemp.patch
 Patch3: guile-popen-test.patch
 Patch5: guile-gcc.patch
-BuildRoot:  %{_tmppath}/guile-%{version}-build
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 PreReq: fileutils sh-utils
 PreReq: %install_info_prereq
 Conflicts:  slib  3a5
@@ -41,8 +46,8 @@
 linked in as a library when building extensible programs.
 
 %package -n libguile17
-Group:  Development/Languages/Scheme
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+Group:  Development/Languages/Scheme
 
 %description -n libguile17
 This is Guile, a portable, embeddable Scheme implementation written in
@@ -51,8 +56,8 @@
 contains the shared libraries.
 
 %package -n libguile-srfi-srfi-1-v-3-3
-Group:  Development/Languages/Scheme
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+Group:  Development/Languages/Scheme
 
 %description -n libguile-srfi-srfi-1-v-3-3
 This is Guile, a portable, embeddable Scheme implementation written in
@@ -61,8 +66,8 @@
 contains the shared libraries.
 
 %package -n libguile-srfi-srfi-4-v-3-3
-Group:  Development/Languages/Scheme
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+Group:  Development/Languages/Scheme
 
 %description -n libguile-srfi-srfi-4-v-3-3
 This is Guile, a portable, embeddable Scheme implementation written in
@@ -71,8 +76,8 @@
 contains the shared libraries.
 
 %package -n libguile-srfi-srfi-13-14-v-3-3
-Group:  Development/Languages/Scheme
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+Group:  Development/Languages/Scheme
 
 %description -n libguile-srfi-srfi-13-14-v-3-3
 This is Guile, a portable, embeddable Scheme implementation written in
@@ -81,8 +86,8 @@
 contains the shared libraries.
 
 %package -n libguile-srfi-srfi-60-v-2-2
-Group:  Development/Languages/Scheme
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+Group:  Development/Languages/Scheme
 
 %description -n libguile-srfi-srfi-60-v-2-2
 This is Guile, a portable, embeddable Scheme implementation written in
@@ -91,8 +96,8 @@
 contains the shared libraries.
 
 %package -n libguilereadline-v-17-17
-Group:  Development/Languages/Scheme
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+Group:  Development/Languages/Scheme
 
 %description -n libguilereadline-v-17-17
 This is Guile, a portable, embeddable Scheme implementation written in
@@ -102,8 +107,8 @@
 
 
 %package -n libguile1-devel
-Group:  Development/Languages/Scheme
 Summary:GNU's Ubiquitous Intelligent Language for Extension
+Group:  

commit horde4-content for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package horde4-content for openSUSE:Factory 
checked in at 2012-01-25 15:01:52

Comparing /work/SRC/openSUSE:Factory/horde4-content (Old)
 and  /work/SRC/openSUSE:Factory/.horde4-content.new (New)


Package is horde4-content, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/horde4-content/horde4-content.changes
2011-09-23 02:02:52.0 +0200
+++ /work/SRC/openSUSE:Factory/.horde4-content.new/horde4-content.changes   
2012-01-25 15:01:54.0 +0100
@@ -1,0 +2,14 @@
+Tue Jan 17 15:15:54 UTC 2012 - l...@b1-systems.de
+
+- version 1.0.3
+- [mjr] Honor the limit and radius parameters.
+- [mjr] Fix getObjects method when passing object_id (Bug# 10439).
+- [mjr] Fix including all non-aggregate fields in GROUP BY clause (Bug# 10419).
+- [jan] Fix commandline scripts (Bug #10656).
+
+---
+Thu Jan 12 11:30:38 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---

Old:

  content-1.0.2.tgz

New:

  content-1.0.3.tgz



Other differences:
--
++ horde4-content.spec ++
--- /var/tmp/diff_new_pack.C1ngPM/_old  2012-01-25 15:01:55.0 +0100
+++ /var/tmp/diff_new_pack.C1ngPM/_new  2012-01-25 15:01:55.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package horde4-content
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,18 +21,20 @@
 %define hordedir /usr/share/php5/PEAR/www/horde
 
 Summary:PEAR: Horde tagging application
+License:BSD-3-Clause
+Group:  Productivity/Networking/Web/Utilities
 
 Name:   horde4-content
-Version:1.0.2
-Release:1
-License:BSD
-Group:  Productivity/Networking/Web/Utilities
+Version:1.0.3
+Release:0
 Source0:http://pear.horde.org/get/content-%{version}.tgz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://pear.horde.org/package/content
 BuildRequires:  php5-pear = 1.7.0
 Requires:   horde4  5.0.0, php5-pear = 1.7.0
-BuildRequires:  horde4 php5-pear-Horde_Role php5-pear-channel-horde
+BuildRequires:  horde4
+BuildRequires:  php5-pear-Horde_Role
+BuildRequires:  php5-pear-channel-horde
 Requires:   php5-pear-channel-horde, php5-pear-Horde_Role, 
php5-pear-Horde_Core = 2.0.0, php5-pear-Horde_Date, php5-pear-Horde_Exception
 Requires:   php5-pear-Horde_Util,  php5-pear-Horde_Db,  
php5-pear-Horde_Injector, php5-pear-Horde_Rdo, php5-pear-Horde_Argv, 
php5-pear-Horde_Controller
 Requires:   php5-gettext, php5-json

++ content-1.0.2.tgz - content-1.0.3.tgz ++
 5956 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit lockdev for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package lockdev for openSUSE:Factory checked 
in at 2012-01-25 15:02:13

Comparing /work/SRC/openSUSE:Factory/lockdev (Old)
 and  /work/SRC/openSUSE:Factory/.lockdev.new (New)


Package is lockdev, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/lockdev/lockdev.changes  2011-11-22 
17:48:42.0 +0100
+++ /work/SRC/openSUSE:Factory/.lockdev.new/lockdev.changes 2012-01-25 
15:02:14.0 +0100
@@ -1,0 +2,5 @@
+Mon Jan 23 13:30:35 UTC 2012 - lnus...@suse.de
+
+- compile lockdev with -fPIE/-pie
+
+---

New:

  lockdev-pie.diff



Other differences:
--
++ lockdev.spec ++
--- /var/tmp/diff_new_pack.n16Tpr/_old  2012-01-25 15:02:15.0 +0100
+++ /var/tmp/diff_new_pack.n16Tpr/_new  2012-01-25 15:02:15.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package lockdev
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -30,6 +30,7 @@
 Patch0: lockdev-drop-baudboy.h.diff
 Patch1: lockdev-fix-implicit-declarations.diff
 Patch2: lockdev-reserve-some-space-to-avoid-buffer-overflow.diff
+Patch3: lockdev-pie.diff
 #
 Requires(pre):  pwdutils permissions
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -71,6 +72,7 @@
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 cat  VERSION EOF

++ lockdev-pie.diff ++
Index: lockdev-1.0.3_git201003141408/src/Makefile.am
===
--- lockdev-1.0.3_git201003141408.orig/src/Makefile.am
+++ lockdev-1.0.3_git201003141408/src/Makefile.am
@@ -7,6 +7,8 @@ AM_CPPFLAGS = -include $(top_builddir)/c
 
 lockdev_SOURCES = sample.c
 lockdev_LDADD = liblockdev.la
+lockdev_CFLAGS = -fPIE
+lockdev_LDFLAGS = -pie
 
 baudboy_SOURCES = baudboy_test.c
 baudboy_LDADD = liblockdev.la
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit mgetty for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package mgetty for openSUSE:Factory checked 
in at 2012-01-25 15:02:17

Comparing /work/SRC/openSUSE:Factory/mgetty (Old)
 and  /work/SRC/openSUSE:Factory/.mgetty.new (New)


Package is mgetty, Maintainer is g...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/mgetty/mgetty.changes2011-12-26 
16:28:57.0 +0100
+++ /work/SRC/openSUSE:Factory/.mgetty.new/mgetty.changes   2012-01-25 
15:02:20.0 +0100
@@ -1,0 +2,5 @@
+Tue Jan 24 16:58:02 UTC 2012 - prus...@opensuse.org
+
+- build with PIE [bnc#743151]
+
+---



Other differences:
--
++ mgetty.spec ++
--- /var/tmp/diff_new_pack.EhIMMu/_old  2012-01-25 15:02:26.0 +0100
+++ /var/tmp/diff_new_pack.EhIMMu/_new  2012-01-25 15:02:26.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package mgetty
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,6 +16,7 @@
 #
 
 
+
 Name:   mgetty
 BuildRequires:  netpbm
 BuildRequires:  texlive
@@ -91,8 +92,8 @@
 
 %build
 ln -s policy.h-dist policy.h
-make OPTFLAGS=$RPM_OPT_FLAGS CC=%__cc
-make -C voice CFLAGS=$RPM_OPT_FLAGS -DAUTO_PPP CC=%__cc
+make CFLAGS=$RPM_OPT_FLAGS -fPIE LDFLAGS=-pie CC=%__cc
+make -C voice CFLAGS=$RPM_OPT_FLAGS -fPIE -DAUTO_PPP LDFLAGS=-pie 
CC=%__cc
 
 %install
 %{_sbindir}/useradd -r -o -g uucp -u 33 -s /bin/bash -c Facsimile agent -d 
%{_localstatedir}/spool/fax fax 2 /dev/null || :

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit mkinitrd for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package mkinitrd for openSUSE:Factory 
checked in at 2012-01-25 15:02:21

Comparing /work/SRC/openSUSE:Factory/mkinitrd (Old)
 and  /work/SRC/openSUSE:Factory/.mkinitrd.new (New)


Package is mkinitrd, Maintainer is mma...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/mkinitrd/mkinitrd.changes2012-01-09 
16:21:45.0 +0100
+++ /work/SRC/openSUSE:Factory/.mkinitrd.new/mkinitrd.changes   2012-01-25 
15:02:26.0 +0100
@@ -1,0 +2,5 @@
+Fri Jan 20 16:18:20 UTC 2012 - mma...@suse.cz
+
+- Load all scsi_dh_* modules early during boot (bnc#727428).
+
+---



Other differences:
--
++ mkinitrd.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mkinitrd-2.7.0/mkinitrd.changes 
new/mkinitrd-2.7.0/mkinitrd.changes
--- old/mkinitrd-2.7.0/mkinitrd.changes 2012-01-06 13:54:20.0 +0100
+++ new/mkinitrd-2.7.0/mkinitrd.changes 2012-01-23 13:57:12.0 +0100
@@ -1,4 +1,9 @@
 ---
+Fri Jan 20 16:18:20 UTC 2012 - mma...@suse.cz
+
+- Load all scsi_dh_* modules early during boot (bnc#727428).
+
+---
 Fri Jan  6 12:53:47 UTC 2012 - mma...@suse.cz
 
 - setup-network: Properly install awk.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mkinitrd-2.7.0/scripts/boot-scsi_dh.sh 
new/mkinitrd-2.7.0/scripts/boot-scsi_dh.sh
--- old/mkinitrd-2.7.0/scripts/boot-scsi_dh.sh  1970-01-01 01:00:00.0 
+0100
+++ new/mkinitrd-2.7.0/scripts/boot-scsi_dh.sh  2012-01-23 13:57:12.0 
+0100
@@ -0,0 +1,6 @@
+#!/bin/bash
+#%stage: boot
+#%depends: start
+#%modules: $scsi_dh_modules
+#%dontshow
+#%if: -n $scsi_dh_modules
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mkinitrd-2.7.0/scripts/setup-scsi_dh.sh 
new/mkinitrd-2.7.0/scripts/setup-scsi_dh.sh
--- old/mkinitrd-2.7.0/scripts/setup-scsi_dh.sh 1970-01-01 01:00:00.0 
+0100
+++ new/mkinitrd-2.7.0/scripts/setup-scsi_dh.sh 2012-01-23 13:57:12.0 
+0100
@@ -0,0 +1,13 @@
+#!/bin/bash
+#
+#%stage: device
+#
+# Include all scsi_dh_* modules and load them on boot (bnc#727428 et al)
+
+scsi_dh_modules=
+for i in $(find 
$root_dir/lib/modules/$kernel_version/kernel/drivers/scsi/device_handler -name 
scsi[-_]dh[_-]*.ko); do
+   i=${i%.ko}
+   scsi_dh_modules=$scsi_dh_modules ${i##*/}
+done
+
+save_var scsi_dh_modules

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit polkit-default-privs for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package polkit-default-privs for 
openSUSE:Factory checked in at 2012-01-25 15:02:38

Comparing /work/SRC/openSUSE:Factory/polkit-default-privs (Old)
 and  /work/SRC/openSUSE:Factory/.polkit-default-privs.new (New)


Package is polkit-default-privs, Maintainer is lnus...@suse.com

Changes:

--- 
/work/SRC/openSUSE:Factory/polkit-default-privs/polkit-default-privs.changes
2011-12-01 17:38:34.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.polkit-default-privs.new/polkit-default-privs.changes
   2012-01-25 15:02:40.0 +0100
@@ -1,0 +2,7 @@
+Wed Jan 18 09:08:17 UTC 2012 - lnus...@suse.de
+
+- add org.freedesktop.packagekit.repair-system (bnc#742024)
+- fix FSF address
+- remove old obsoletes
+
+---



Other differences:
--
++ polkit-default-privs.spec ++
--- /var/tmp/diff_new_pack.zYF8I5/_old  2012-01-25 15:02:41.0 +0100
+++ /var/tmp/diff_new_pack.zYF8I5/_new  2012-01-25 15:02:41.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package polkit-default-privs
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -32,15 +32,6 @@
 BuildArch:  noarch
 Url:http://git.opensuse.org/?p=projects/polkit-default-privs.git
 PreReq: %fillup_prereq
-%if %suse_version  1100
-Obsoletes:  hal-resmgr  0.2
-Obsoletes:  resmgr  1.1.1
-# bug437293
-%ifarch ppc64
-Obsoletes:  resmgr-64bit
-%endif
-#
-%endif
 
 %description
 Different default privilege settings depending on local configuration

++ polkit-default-privs-12.2.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/polkit-default-privs-12.2/chkstat-polkit 
new/polkit-default-privs-12.2/chkstat-polkit
--- old/polkit-default-privs-12.2/chkstat-polkit2011-12-01 
13:39:18.0 +0100
+++ new/polkit-default-privs-12.2/chkstat-polkit2012-01-18 
10:14:11.0 +0100
@@ -14,7 +14,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
 #
 # Author: Ludwig Nussel  lnus...@suse.de 2008
 #
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/polkit-default-privs-12.2/polkit-default-privs.restrictive 
new/polkit-default-privs-12.2/polkit-default-privs.restrictive
--- old/polkit-default-privs-12.2/polkit-default-privs.restrictive  
2011-12-01 13:39:18.0 +0100
+++ new/polkit-default-privs-12.2/polkit-default-privs.restrictive  
2012-01-18 10:14:11.0 +0100
@@ -64,6 +64,7 @@
 org.freedesktop.packagekit.device-rebindauth_admin_keep
 org.freedesktop.packagekit.system-change-install-root   auth_admin
 org.freedesktop.packagekit.upgrade-system   auth_admin
+org.freedesktop.packagekit.repair-systemauth_admin
 #
 org.pulseaudio.acquire-real-time
auth_admin_keep_always
 org.pulseaudio.acquire-high-priority
auth_admin_keep_always
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/polkit-default-privs-12.2/polkit-default-privs.standard 
new/polkit-default-privs-12.2/polkit-default-privs.standard
--- old/polkit-default-privs-12.2/polkit-default-privs.standard 2011-12-01 
13:39:18.0 +0100
+++ new/polkit-default-privs-12.2/polkit-default-privs.standard 2012-01-18 
10:14:11.0 +0100
@@ -65,6 +65,7 @@
 org.freedesktop.packagekit.device-rebindauth_admin_keep
 org.freedesktop.packagekit.system-change-install-root   auth_admin
 org.freedesktop.packagekit.upgrade-system   auth_admin
+org.freedesktop.packagekit.repair-systemauth_admin
 #
 org.pulseaudio.acquire-real-time
auth_admin_keep_always
 org.pulseaudio.acquire-high-priority
auth_admin_keep_always
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/polkit-default-privs-12.2/set_polkit_default_privs 
new/polkit-default-privs-12.2/set_polkit_default_privs
--- old/polkit-default-privs-12.2/set_polkit_default_privs  2011-12-01 
13:39:18.0 

commit su-wrapper for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package su-wrapper for openSUSE:Factory 
checked in at 2012-01-25 15:02:43

Comparing /work/SRC/openSUSE:Factory/su-wrapper (Old)
 and  /work/SRC/openSUSE:Factory/.su-wrapper.new (New)


Package is su-wrapper, Maintainer is wer...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/su-wrapper/su-wrapper.changes2011-09-23 
12:47:01.0 +0200
+++ /work/SRC/openSUSE:Factory/.su-wrapper.new/su-wrapper.changes   
2012-01-25 15:02:44.0 +0100
@@ -1,0 +2,5 @@
+Mon Jan 23 14:23:24 UTC 2012 - crrodrig...@opensuse.org
+
+- Build with -fpie and full RELRO 
+
+---



Other differences:
--
++ su-wrapper.spec ++
--- /var/tmp/diff_new_pack.Fm80N9/_old  2012-01-25 15:02:45.0 +0100
+++ /var/tmp/diff_new_pack.Fm80N9/_new  2012-01-25 15:02:45.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package su-wrapper (Version 1.2.0)
+# spec file for package su-wrapper
 #
-# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed

++ su-wrapper-1.2.0.dif ++
--- /var/tmp/diff_new_pack.Fm80N9/_old  2012-01-25 15:02:45.0 +0100
+++ /var/tmp/diff_new_pack.Fm80N9/_new  2012-01-25 15:02:45.0 +0100
@@ -1,5 +1,5 @@
 su-wrapper.conf.dist
-+++ su-wrapper.conf.dist   2001-12-19 16:40:50.0 +0100
+--- su-wrapper.conf.dist.orig
 su-wrapper.conf.dist
 @@ -30,13 +30,13 @@
  #is significant. so if you wann deny some special things,
  #  you have to put them under those lines which would allow them.
@@ -21,14 +21,17 @@
  
  # deny nobody everything, each call from nobody ends up in an empty command
  nobody-   *   *   -   -   -
 src/Makefile
-+++ src/Makefile   2001-12-19 16:48:24.0 +0100
-@@ -1,5 +1,5 @@
+--- src/Makefile.orig
 src/Makefile
+@@ -1,7 +1,7 @@
  CC= gcc
 -CFLAGS= -D_GNU_SOURCE -O2 -pipe -Wall
-+CFLAGS= -D_GNU_SOURCE $(RPM_OPT_FLAGS) -pipe -Wall
++CFLAGS= -fpie -fPIE -D_GNU_SOURCE $(RPM_OPT_FLAGS) -pipe -Wall
  #CFLAGS = -D_GNU_SOURCE -O -g -DDEBUG -Wall
- LDFLAGS   = -Wl,-warn-common
+-LDFLAGS   = -Wl,-warn-common
++LDFLAGS   = -pie -Wl,-warn-common  -Wl,-z,relro,-z,now
+ 
+ all:  su-wrapper
  
 @@ -9,11 +9,11 @@ su-wrapper:  su-wrapper.o
$(CC) $(LDFLAGS) su-wrapper.o -o su-wrapper
@@ -45,8 +48,8 @@
 -  mv /etc/su-wrapper.conf /etc/su-wrapper.conf.---
 +  rm -f $(DESTDIR)/usr/sbin/su-wrapper
 +  mv $(DESTDIR)/etc/su-wrapper.conf $(DESTDIR)/etc/su-wrapper.conf.---
 src/su-wrapper.c
-+++ src/su-wrapper.c   2008-10-08 12:25:12.178827251 +0200
+--- src/su-wrapper.c.orig
 src/su-wrapper.c
 @@ -134,7 +134,7 @@ static int cmdline_match (char * const m
while ((oslot = strsep(l, ,:))) {
if (!*oslot)/* empty slot means no slot */

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit udev for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package udev for openSUSE:Factory checked in 
at 2012-01-25 15:02:48

Comparing /work/SRC/openSUSE:Factory/udev (Old)
 and  /work/SRC/openSUSE:Factory/.udev.new (New)


Package is udev, Maintainer is gre...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/udev/udev.changes2011-11-08 
20:12:01.0 +0100
+++ /work/SRC/openSUSE:Factory/.udev.new/udev.changes   2012-01-25 
15:02:50.0 +0100
@@ -1,0 +2,7 @@
+Mon Jan  9 09:52:11 UTC 2012 - vu...@opensuse.org
+
+- Split typelib file into typelib-1_0-GUdev-1_0 subpackage.
+- Add typelib-1_0-GUdev-1_0 Requires to libgudev-1_0-devel
+  subpackage.
+
+---



Other differences:
--
++ udev.spec ++
--- /var/tmp/diff_new_pack.c5VHrM/_old  2012-01-25 15:02:51.0 +0100
+++ /var/tmp/diff_new_pack.c5VHrM/_new  2012-01-25 15:02:51.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package udev
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,16 +15,13 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   udev
 Url:http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
 Version:173
-Release:1
+Release:0
+Summary:A rule-based device node and kernel event manager
 License:GPL-2.0+
 Group:  System/Kernel
-Summary:A rule-based device node and kernel event manager
 PreReq: /bin/pidof /bin/rm /usr/bin/stat %insserv_prereq 
%fillup_prereq /usr/sbin/groupadd
 Conflicts:  systemd  28
 Conflicts:  aaa_base  11.5
@@ -33,10 +30,16 @@
 Conflicts:  util-linux  2.16
 Conflicts:  ConsoleKit  0.4.1
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  libselinux-devel libsepol-devel
-BuildRequires:  libusb-devel pciutils-ids usbutils
-BuildRequires:  gperf libacl-devel pkg-config
-BuildRequires:  glib2-devel gobject-introspection-devel
+BuildRequires:  glib2-devel
+BuildRequires:  gobject-introspection-devel
+BuildRequires:  gperf
+BuildRequires:  libacl-devel
+BuildRequires:  libselinux-devel
+BuildRequires:  libsepol-devel
+BuildRequires:  libusb-devel
+BuildRequires:  pciutils-ids
+BuildRequires:  pkg-config
+BuildRequires:  usbutils
 Source0:
ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.bz2
 Source1:udev-rpmlintrc
 Source2:baselibs.conf
@@ -59,8 +62,8 @@
 call tools to initialize a device, or load needed kernel modules.
 
 %package -n libudev0
-License:LGPL-2.1+
 Summary:Dynamic library to access udev device information
+License:LGPL-2.1+
 Group:  System/Libraries
 Requires:   udev = %{version}-%{release}
 
@@ -69,8 +72,8 @@
 access to udev device information
 
 %package -n libudev-devel
-License:LGPL-2.1+
 Summary:Development files for libudev
+License:LGPL-2.1+
 Group:  Development/Libraries/Other
 Requires:   libudev0 = %{version}-%{release}
 
@@ -79,21 +82,31 @@
 dynamic library, which provides access to udev device information.
 
 %package -n libgudev-1_0-0
-License:LGPL-2.1+
 Summary:GObject library, to access udev device information
-Requires:   libudev0 = %{version}-%{release}
+License:LGPL-2.1+
 Group:  System/Libraries
+Requires:   libudev0 = %{version}-%{release}
 
 %description -n libgudev-1_0-0
 This package contains the GObject library libgudev, which provides
 access to udev device information.
 
-%package -n libgudev-1_0-devel
+%package -n typelib-1_0-GUdev-1_0
+Summary:GObject library, to access udev device information -- 
Introspection bindings
 License:LGPL-2.1+
+Group:  System/Libraries
+
+%description -n typelib-1_0-GUdev-1_0
+This package provides the GObject Introspection bindings for libgudev, which
+provides access to udev device information.
+
+%package -n libgudev-1_0-devel
 Summary:Devel package for libgudev
+License:LGPL-2.1+
 Group:  Development/Libraries/Other
 Requires:   libgudev-1_0-0 = %{version}-%{release}
 Requires:   libudev-devel = %{version}-%{release}
+Requires:   typelib-1_0-GUdev-1_0 = %{version}-%{release}
 Requires:   glib2-devel
 
 %description -n libgudev-1_0-devel
@@ -229,6 +242,9 @@
 %files -n libgudev-1_0-0
 %defattr(-,root,root)
 /%{_lib}/libgudev-1.0.so.*
+
+%files -n typelib-1_0-GUdev-1_0

commit virtuoso for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package virtuoso for openSUSE:Factory 
checked in at 2012-01-25 15:02:53

Comparing /work/SRC/openSUSE:Factory/virtuoso (Old)
 and  /work/SRC/openSUSE:Factory/.virtuoso.new (New)


Package is virtuoso, Maintainer is dmuel...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/virtuoso/virtuoso.changes2011-12-27 
18:39:41.0 +0100
+++ /work/SRC/openSUSE:Factory/.virtuoso.new/virtuoso.changes   2012-01-25 
15:02:54.0 +0100
@@ -1,0 +2,17 @@
+Wed Jan 25 10:54:11 UTC 2012 - cgiboude...@gmx.com
+
+- Update suse-gawk-4.diff. It can now be applied regardless of the
+  Opensuse version.
+
+---
+Wed Jan 25 10:45:11 UTC 2012 - idon...@suse.com
+
+- Back to internal PCRE, system one will result in runtime problems. 
+
+---
+Sat Jan 21 22:54:25 UTC 2012 - crrodrig...@opensuse.org
+
+- Use system PCRE.
+- Do not include build dates in binaries.
+
+---

New:

  virtuoso-no-build-dates.patch



Other differences:
--
++ virtuoso.spec ++
--- /var/tmp/diff_new_pack.Lsvr19/_old  2012-01-25 15:02:57.0 +0100
+++ /var/tmp/diff_new_pack.Lsvr19/_new  2012-01-25 15:02:57.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package virtuoso
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,7 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 Name:   virtuoso
 Version:6.1.4
 Release:0
@@ -36,6 +35,8 @@
 Patch4: suse-gawk-4.diff
 # PATCH-FIX-UPSTREAM patches/virtuoso-wrong-memset.patch idoen...@suse.de -- 
Fix wrong size parameter in memset call
 Patch5: virtuoso-wrong-memset.patch
+# PATCH-FIX-OPENSUSE Do not include build date and hostname in binaries
+Patch6: virtuoso-no-build-dates.patch
 BuildRequires:  bison
 BuildRequires:  flex
 BuildRequires:  gperf
@@ -51,7 +52,8 @@
 BuildRequires:  libwbxml2-devel
 BuildRequires:  libtool
 BuildRequires:  openldap2-devel
-BuildRequires:  pcre-devel
+# We can't use system pcre because internal pcre is modified for virtuoso's 
own use
+#BuildRequires:  pcre-devel
 BuildRequires:  zlib-devel
 BuildRequires:  pkgconfig(ImageMagick)
 BuildRequires:  pkgconfig(libxml-2.0)
@@ -97,10 +99,9 @@
 %patch1
 %patch2 -p1
 %patch3
-%if 0%{?suse_version} = 1210
 %patch4 -p1
-%endif
 %patch5 -p1
+%patch6
 
 %build
 # autogen.sh because of patching Makefile.am

++ suse-gawk-4.diff ++
--- /var/tmp/diff_new_pack.Lsvr19/_old  2012-01-25 15:02:57.0 +0100
+++ /var/tmp/diff_new_pack.Lsvr19/_new  2012-01-25 15:02:57.0 +0100
@@ -1,38 +1,77 @@
 diff --git a/binsrc/cached_resources/res_to_c.awk 
b/binsrc/cached_resources/res_to_c.awk
-index 31b4c5c..c608ea6 100644
+index 31b4c5c..9de6789 100644
 --- a/binsrc/cached_resources/res_to_c.awk
 +++ b/binsrc/cached_resources/res_to_c.awk
-@@ -32,10 +32,11 @@ BEGIN   {
+@@ -30,13 +30,7 @@ BEGIN   {
+   }
+   {
  fun = $0
- # was: gsub ( /\\/, , fun)
- q = 
+-# was: gsub ( /\\/, , fun)
+-q = 
 -if (PROCINFO[version] ~ /^4/)
 -  gsub ( q, q q, fun)
 -else
 -  gsub ( q, q, fun)
-+##  SUSE uses gawk4 with gsub functionality from gawk 3
-+##if (PROCINFO[version] ~ /^4/)
-+##gsub ( q, q q, fun)
-+##else
-+gsub ( q, q, fun)
- 
+-
++  gsub ( , , fun)
  gsub ( //, \\\, fun)
  gsub ( /\$/, \\044, fun)
+ gsub ( /.*/, \\\n\,, fun)
+diff --git a/binsrc/hosting/perl/pl_to_c.awk b/binsrc/hosting/perl/pl_to_c.awk
+index 369610f..7307d41 100644
+--- a/binsrc/hosting/perl/pl_to_c.awk
 b/binsrc/hosting/perl/pl_to_c.awk
+@@ -42,7 +42,7 @@ END {
+ }
+ 
+   x = $0
+-  gsub (/\\/, , x)
++  gsub ( , , x)
+   gsub (/\/, \\\, x)
+   print \ x \\n\
+ }
+diff --git a/binsrc/hosting/python/py_to_c.awk 
b/binsrc/hosting/python/py_to_c.awk
+index f7d6935..8de1851 100644
+--- a/binsrc/hosting/python/py_to_c.awk
 b/binsrc/hosting/python/py_to_c.awk
+@@ -48,7 +48,7 @@ END {
+ }
+ 
+   x = $0
+-  gsub (/\\/, , x)
++  gsub ( , , x)
+   gsub (/\/, \\\, x)
+   print \ x \\n\
+ }
+diff --git a/binsrc/ws/wsrm/xsd2sql.awk b/binsrc/ws/wsrm/xsd2sql.awk
+index 074a30d..2705207 100644
+--- a/binsrc/ws/wsrm/xsd2sql.awk
 

commit xine-lib for openSUSE:Factory

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package xine-lib for openSUSE:Factory 
checked in at 2012-01-25 15:02:58

Comparing /work/SRC/openSUSE:Factory/xine-lib (Old)
 and  /work/SRC/openSUSE:Factory/.xine-lib.new (New)


Package is xine-lib, Maintainer is mh...@novell.com

Changes:

--- /work/SRC/openSUSE:Factory/xine-lib/xine-lib.changes2011-10-29 
00:18:58.0 +0200
+++ /work/SRC/openSUSE:Factory/.xine-lib.new/xine-lib.changes   2012-01-25 
15:03:00.0 +0100
@@ -1,0 +2,39 @@
+Mon Dec 02 22:51:00 UTC 2011 - manfred.trem...@iiv.de
+
+- update to 1.1.20.1
+  * Various bug fixes.
+  * Use the current ImageMagick API (if using ImageMagick).
+  * Fix PVR plugin input building (needs V4L2).
+  * Fixes related to unknown audio  subtitle languages.
+  * Memory leak fixes.
+
+---
+Sat Nov 19 15:41:25 UTC 2011 - co...@suse.com
+
+- add libtool as buildrequire to avoid implicit dependency
+
+---
+Sun Nov 13 16:58:00 UTC 2011 - manfred.trem...@iiv.de
+
+- update to 1.1.20
+  * Imagine that there's a large poppy here.
+  * Ensure that file and socket descriptors are marked as CLOEXEC.
+  * Enable FFmpeg's support for AAC LATM audio.
+  * Fix build-time check for dvdnav.
+  * Allow use of GraphicsMagick instead of ImageMagick.
+  * Fix build on Debian GNU/kFreeBSD (broken in 1.1.19).
+  * Add a Japanese translation from Takeshi Hamasaki.
+  * Czech translation update.
+  * New MinGW-w64 port, various portability fixes.
+  * MinGW port updates.
+  * Possibility to disable HW acceleration in directx video output.
+  * Header stripping support in Matroska demuxer.
+  * Update nosefart to 2.7-mls (stability with corrupted NSF files).
+  * Add .ass extension to be recognized as subtitle file. [Bug #123]
+---
+Sun Nov  6 03:48:03 UTC 2011 - reddw...@opensuse.org
+
+- Fix Packman build: since /usr/share/xine/mad is no longer needed
+  don't create it
+
+---

Old:

  xine-lib-1.1.19-assert.patch
  xine-lib-1.1.19-crippled.tar.bz2
  xine-lib-1.1.19-demuxcheckfor_mad_ffmpeg.patch
  xine-lib-1.1.19-ffmpeg_abi_change.diff
  xine-lib-1.1.19-glitch-free-pulseaudio.patch
  xine-lib-1.1.19-ia64-is-not-alpha.diff
  xine-lib-1.1.19-install-plugins-helper.diff
  xine-lib-1.1.19-mjpegplugin.diff
  xine-lib-1.1.19-xvmc.patch
  xine-lib-1.1.19.tar.bz2

New:

  xine-lib-1.1.20.1-assert.patch
  xine-lib-1.1.20.1-crippled.tar.bz2
  xine-lib-1.1.20.1-demuxcheckfor_mad_ffmpeg.patch
  xine-lib-1.1.20.1-glitch-free-pulseaudio.patch
  xine-lib-1.1.20.1-ia64-is-not-alpha.diff
  xine-lib-1.1.20.1-install-plugins-helper.diff
  xine-lib-1.1.20.1-mjpegplugin.diff
  xine-lib-1.1.20.1.tar.bz2



Other differences:
--
++ xine-lib.spec ++
--- /var/tmp/diff_new_pack.aPlQ80/_old  2012-01-25 15:03:02.0 +0100
+++ /var/tmp/diff_new_pack.aPlQ80/_new  2012-01-25 15:03:02.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package xine-lib
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -54,6 +54,7 @@
 BuildRequires:  Mesa-devel libsmbclient-devel libtheora-devel libvorbis-devel
 BuildRequires:  readline-devel update-desktop-files vcdimager-devel
 BuildRequires:  speex-devel
+BuildRequires:  libtool
 %if 0%{suse_version} = 1210
 BuildRequires:  libv4l-devel = 0.8.4
 %else
@@ -104,13 +105,13 @@
 %if %{with modplug}
 BuildRequires:  libmodplug-devel
 %endif
-Version:1.1.19
-Release:7
+Version:1.1.20.1
+Release:0
 # bug437293
 %ifarch ppc64
 Obsoletes:  xine-lib-64bit
 %endif
-%define abiversion 1.29
+%define abiversion 1.30
 Summary:Video Player with Plug-Ins
 Group:  Productivity/Multimedia/Video/Players
 License:GPLv2+
@@ -128,7 +129,6 @@
 Patch26:xine-lib-doc-fix-X11R6.diff
 Patch28:xine-lib-%{version}-ia64-is-not-alpha.diff
 Patch31:xine-lib-%{version}-glitch-free-pulseaudio.patch
-Patch32:
http://repos.archlinux.org/wsvn/packages/xine-lib/trunk/xine-lib-1.1.19-xvmc.patch
 # *** Addons
 Patch50:vdr-xine-0.9.3.diff.bz2
 Patch51:vdr-xine-SUSE.diff
@@ -143,7 +143,6 @@
 Patch75:xine-lib-v4l-2.6.38.patch
 # *** Only working for noncrippled source
 Patch80:xine-lib-various-noncrippled.diff
-Patch81:xine-lib-%{version}-ffmpeg_abi_change.diff
 
 

commit quilt for openSUSE:12.1:Update:Test

2012-01-25 Thread h_root
Hello community,

here is the log from the commit of package quilt for openSUSE:12.1:Update:Test 
checked in at 2012-01-25 15:06:36

Comparing /work/SRC/openSUSE:12.1:Update:Test/quilt (Old)
 and  /work/SRC/openSUSE:12.1:Update:Test/.quilt.new (New)


Package is quilt, Maintainer is jdelv...@suse.com

Changes:

--- /work/SRC/openSUSE:12.1:Update:Test/quilt/quilt.changes 2012-01-25 
15:06:39.0 +0100
+++ /work/SRC/openSUSE:12.1:Update:Test/.quilt.new/quilt.changes
2012-01-25 15:06:39.0 +0100
@@ -0,0 +1,8 @@
+--
+Mon Jan 23 17:11:14 CET 2012 - jdelv...@suse.de
+
+- suse-workaround-pseudo-release.patch: Filter invalid characters
+  in release field (bnc#628258).
+- inspect-fix-xz-detection.patch: Fix detection of xz-compressed
+  archives and patches (bnc#739083).
+

New:

  inspect-fix-xz-detection.patch
  suse-workaround-pseudo-release.patch



Other differences:
--
++ quilt.spec ++
--- /var/tmp/diff_new_pack.1jKsoW/_old  2012-01-25 15:06:39.0 +0100
+++ /var/tmp/diff_new_pack.1jKsoW/_new  2012-01-25 15:06:39.0 +0100
@@ -47,6 +47,8 @@
 Patch13:setup-support-reverse-patch.patch
 Patch14:completion-revert.patch
 Patch15:   inspect-shell-syntax-errors.patch
+Patch16:inspect-fix-xz-detection.patch
+Patch17:suse-workaround-pseudo-release.patch
 Url:http://savannah.nongnu.org/projects/quilt
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
@@ -67,6 +69,7 @@
 %prep
 %setup -q
 %patch -p1 -P 1 -P 2 -P 3 -P 4 -P 5 -P 6 -P 7 -P 8 -P 9 -P 10 -P 11 -P 12 -P 
13 -P 14 -P 15
+%patch -p1 -P 16 -P 17
 
 %build
 autoconf

++ inspect-fix-xz-detection.patch ++
From: Philipp Thomas p...@suse.de
Date: Thu, 10 Nov 2011 20:14:45 +
Subject: inspect: Newer file changed the output for xz compressed data so adapt 
to it.
Patch-mainline: 0.50
Git-commit: 0b1f605c5d5db8b77a4e0d1c528c8d7bc696d471

- quilt/inspect.in: Newer file changed the output for xz compressed
  data so adapt to it.

---
 quilt/scripts/inspect.in |2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--- quilt-0.48.orig/quilt/scripts/inspect.in
+++ quilt-0.48/quilt/scripts/inspect.in
@@ -120,7 +120,7 @@ do
set -- $(lzma -cd $file | md5sum)
echo $1 $basename
;;
-   xz*)
+   xz*|XZ*)
echo -n x 4
echo xz -cd $file | md5sum 2
set -- $(xz -cd $file | md5sum)
++ suse-workaround-pseudo-release.patch ++
Upstream: Never

Old Suse spec files have a pseudo release string which uses characters
newer versions of rpmbuild don't like. Filter them out to make rpmbuild
happy again. Packages in openSUSE 11.4 and later no longer need this.

--- quilt-0.48.orig/quilt/scripts/inspect.in
+++ quilt-0.48/quilt/scripts/inspect.in
@@ -67,6 +67,14 @@ trap rm -rf $tmpdir EXIT
 mkdir -p $tmpdir/build
 mkdir -p $tmpdir/bin
 
+# Older versions of Suse packages have a symbolic release number, and rpmbuild
+# won't like that, so change it to something compliant.
+if grep -q '^Release:.*[]' $specdir/$specfile
+then
+   sed -e '/^Release:/s/[]//g'  $specdir/$specfile  
$tmpdir/$specfile
+   specdir=$tmpdir
+fi
+
 # Redirect file descriptors
 if [ -n $verbose ]
 then
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org