commit util-linux for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package util-linux for openSUSE:Factory 
checked in at 2012-03-20 10:35:30

Comparing /work/SRC/openSUSE:Factory/util-linux (Old)
 and  /work/SRC/openSUSE:Factory/.util-linux.new (New)


Package is util-linux, Maintainer is pu...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/util-linux/util-linux.changes2012-02-28 
14:16:25.0 +0100
+++ /work/SRC/openSUSE:Factory/.util-linux.new/util-linux.changes   
2012-03-20 10:35:32.0 +0100
@@ -1,0 +2,17 @@
+Fri Mar 16 09:56:21 UTC 2012 - fcro...@suse.com
+
+- Fix Obsoletes / Provides for login.
+
+---
+Tue Mar 13 16:38:34 CET 2012 - ku...@suse.de
+
+- Enable /bin/login and obsolete old fork now merged back
+  (not moved to /usr/bin until all problems are solved to
+   avoid that root is not able to login).
+
+---
+Tue Mar  6 21:18:56 UTC 2012 - rschweik...@suse.com
+
+- keep binaries in /usr tree (UsrMerge project)
+
+---

New:

  login.pamd
  remote.pamd



Other differences:
--
++ util-linux.spec ++
--- /var/tmp/diff_new_pack.GvWYpD/_old  2012-03-20 10:35:36.0 +0100
+++ /var/tmp/diff_new_pack.GvWYpD/_new  2012-03-20 10:35:36.0 +0100
@@ -52,15 +52,17 @@
 Group:  System/Base
 Source: 
ftp://ftp.kernel.org/pub/linux/utils/util-linux/v2.21/%{name}-%{version}.tar.bz2
 Source1:util-linux-rpmlintrc
-# XXX: make nologin part of login package
+# XXX: make nologin part of util-linux upstream
 Source2:nologin.c
 Source3:nologin.8
 Source4:raw.init
 Source5:etc.raw
 Source6:etc_filesystems
 Source7:baselibs.conf
+Source8:login.pamd
+Source9:remote.pamd
 # TODO: split to separate package
-Source9:
http://ftp.debian.org/debian/pool/main/a/adjtimex/adjtimex_%{adjtimex_ver}.orig.tar.gz
+Source10:   
http://ftp.debian.org/debian/pool/main/a/adjtimex/adjtimex_%{adjtimex_ver}.orig.tar.gz
 Source11:   klogconsole.tar.bz2
 # TODO: split to separate package
 Source12:   which-%{which_ver}.tar.bz2
@@ -106,8 +108,18 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 PreReq: %insserv_prereq %fillup_prereq /bin/sed
 #
-Provides:   util = %{version}-%{release} rawio = %{version}-%{release} raw 
= %{version}-%{release} base = %{version}-%{release} uuid-runtime = 
%{version}-%{release}
-Obsoletes:  util  %{version}-%{release} rawio  %{version}-%{release} raw 
 %{version}-%{release} base  %{version}-%{release} uuid-runtime  
%{version}-%{release}
+Provides:   base = %{version}-%{release}
+Provides:   login = 4.0-33.7
+Provides:   raw = %{version}-%{release}
+Provides:   rawio = %{version}-%{release}
+Provides:   util = %{version}-%{release}
+Provides:   uuid-runtime = %{version}-%{release}
+Obsoletes:  base  %{version}-%{release}
+Obsoletes:  login  4.0-33.7
+Obsoletes:  raw  %{version}-%{release}
+Obsoletes:  rawio  %{version}-%{release}
+Obsoletes:  util  %{version}-%{release}
+Obsoletes:  uuid-runtime  %{version}-%{release}
 
 %description
 This package contains a large variety of low-level system utilities
@@ -165,7 +177,7 @@
 
 %description -n libmount1
 Library designed to be used in low-level utils like
-mount(8) and /sbin/mount.type helpers.
+mount(8) and /usr/sbin/mount.type helpers.
 
 %package -n libmount-devel
 Summary:Development files for libmount1
@@ -177,7 +189,7 @@
 
 %lang_package
 %prep
-%setup -q -n %{name}-%{version} -a 9 -b 11 -b 12 -b 13
+%setup -q -n %{name}-%{version} -a 10 -b 11 -b 12 -b 13
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -235,8 +247,6 @@
 export SUID_CFLAGS=-fpie
 export SUID_LDFLAGS=-pie
 %configure \
-  --bindir=/bin \
-  --sbindir=/sbin \
   --with-audit \
   --with-selinux \
   --enable-mesg \
@@ -246,6 +256,7 @@
   --enable-line \
   --enable-libmount-mount \
   --enable-ddate \
+  --enable-login-utils \
   --disable-mountpoint \
   --disable-use-tty-group \
   --disable-static \
@@ -259,13 +270,15 @@
 %{__cc} -fwhole-program %{optflags} -o chrp-addnote %{SOURCE31}
 
 %install
-mkdir -p 
%{buildroot}{/etc/init.d,%{_mandir}/man{1,8},/bin,/sbin,/usr/bin,/usr/sbin,%{_infodir}}
+mkdir -p 
%{buildroot}{/etc/init.d,/etc/pam.d,%{_mandir}/man{1,8},/bin,/sbin,/usr/bin,/usr/sbin,%{_infodir}}
 mkdir -p %{buildroot}%{_localstatedir}/lib/libuuid/
 mkdir -p %{buildroot}%{_localstatedir}/run/uuidd/
 install -m 744 %{SOURCE50} %{buildroot}%{_initddir}/uuidd
 install -m 644 %{SOURCE51} %{buildroot}%{_sysconfdir}/blkid.conf
+install -m 644 %{SOURCE8} 

commit acpid for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package acpid for openSUSE:Factory checked 
in at 2012-03-20 11:24:40

Comparing /work/SRC/openSUSE:Factory/acpid (Old)
 and  /work/SRC/openSUSE:Factory/.acpid.new (New)


Package is acpid, Maintainer is hma...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/acpid/acpid.changes  2012-01-25 
15:01:01.0 +0100
+++ /work/SRC/openSUSE:Factory/.acpid.new/acpid.changes 2012-03-20 
11:24:43.0 +0100
@@ -1,0 +2,50 @@
+Fri Mar 16 12:49:12 UTC 2012 - tabra...@novell.com
+
+- Update to acpid 2.0.15
+  + Improve man page (Debian bug #656676)
+(acpid.8 acpi_listen.8)  (Ted Felix)
+  + Change makefile to get rid of double slashes on install paths.
+Note: This change was lost due to introduction of autoconf which
+wiped out the old Makefile.  (Makefile)  (Gilles Espinasse)
+  + Switch from Makefile to autoconf build system.  Fix some related
+warnings.
+(Makefile Makefile.am README TODO acpi_ids.c acpi_ids.h acpid.h 
+configure.ac connection_list.h event.c kacpimon/Makefile.am 
+kacpimon/makefile proc.h sock.h)
+(Cristian Rodriguez)
+  + Fix build warnings uncovered by new gcc settings from autoconf.
+(inotify_handler.c input_layer.c kacpimon/acpi_ids.c kacpimon/acpi_ids.h 
+kacpimon/connection_list.c kacpimon/connection_list.h 
+kacpimon/input_layer.c kacpimon/kacpimon.c kacpimon/netlink.c netlink.c
+proc.c sock.c)
+(Ted Felix)
+  + Remove fcntl() calls to set FD_CLOEXEC and replace with
+CLOEXEC flags within the various open(), recvmsg() and other calls.
+Requires kernel version 2.6.23 and above.
+(acpi_listen.c inotify_handler.c input_layer.c libnetlink.c netlink.c
+proc.c ud_socket.c)
+(Cristian Rodriguez)
+  + Add SOCK_NONBLOCK to ud_create_socket().
+(ud_socket.c) (Cristian Rodriguez)
+  + Use isfdtype() instead of getsockopt() in is_socket().  Use fchmod(), 
+fstat(), and fchown() instead of the non-f versions in open_sock().
+(sock.c) (Cristian Rodriguez)
+  + Use __attribute__ for argument checking in acpid_log().
+(input_layer.c log.h netlink.c ud_socket.c) (Cristian Rodriguez)
+  + Close only the open fds in close_fds().
+(acpid.c) (Cristian Rodriguez)
+  + Use accept4() with SOCK_CLOEXEC and SOCK_NONBLOCK in ud_accept().
+Remove unnecessary calls to fcntl() in process_sock().  
+(sock.c ud_socket.c) (Cristian Rodriguez)
+  + Use asprintf() instead of snprintf() in process_sock().
+(sock.c) (Cristian Rodriguez)
+  + Use TEMP_FAILURE_RETRY macro instead of bogus checks for EINTR.
+(acpi_listen.c acpid.c event.c input_layer.c libnetlink.c netlink.c 
+proc.c ud_socket.c) (Cristian Rodriguez)
+  + Use safer, faster, and more modern functions asprintf(), fstatat(), 
+openat(), and fdopen() in the configuration file processing.
+(event.c) (Cristian Rodriguez)
+
+- refreshed patches - acpid-makefile.patch acpid-wrong-memset.patch
+
+---

Old:

  acpid-2.0.14.tar.gz

New:

  acpid-2.0.15.tar.gz



Other differences:
--
++ acpid.spec ++
--- /var/tmp/diff_new_pack.yLA275/_old  2012-03-20 11:24:44.0 +0100
+++ /var/tmp/diff_new_pack.yLA275/_new  2012-03-20 11:24:44.0 +0100
@@ -18,7 +18,7 @@
 
 
 Name:   acpid
-Version:2.0.14
+Version:2.0.15
 Release:0
 License:GPL-2.0+
 Summary:Executes Actions at ACPI Events
@@ -55,12 +55,13 @@
 %prep
 %setup -q
 %patch1
-%patch2 -p1
+%patch2 
 
 cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} 
%{SOURCE9} .
 
 %build
 export LDFLAGS=-Wl,-z,relro,-z,now
+%configure 
 make OPT=%{optflags} %{?_smp_mflags}
 
 %install
@@ -111,10 +112,12 @@
 %_unitdir/%{name}.service
 %{_sbindir}/rcacpid
 %{_sbindir}/acpid
+%{_sbindir}/kacpimon
 %{_bindir}/acpi_listen
 %doc README.SuSE README Changelog examples
 %{_mandir}/man8/acpid.8.gz
 %{_mandir}/man8/acpi_listen.8.gz
+%{_mandir}/man8/kacpimon.8.gz
 %ghost %config(noreplace,missingok) %{_localstatedir}/log/acpid
 
 %changelog

++ acpid-2.0.14.tar.gz - acpid-2.0.15.tar.gz ++
 16540 lines of diff (skipped)

++ acpid-makefile.patch ++
--- /var/tmp/diff_new_pack.yLA275/_old  2012-03-20 11:24:45.0 +0100
+++ /var/tmp/diff_new_pack.yLA275/_new  2012-03-20 11:24:45.0 +0100
@@ -1,13 +1,11 @@
-Index: Makefile
-===
 Makefile.orig
-+++ Makefile
-@@ -49,7 +49,7 @@ install_docs:
-   for a in $(DOCS); do install -m 0644 $$a $(DESTDIR)/$(DOCDIR) ; done
-   cp -a samples $(DESTDIR)/$(DOCDIR)
+--- Makefile.in.orig   2012-03-16 09:34:42.474574907 -0400
 Makefile.in

commit arabic-fonts for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package arabic-fonts for openSUSE:Factory 
checked in at 2012-03-20 11:24:58

Comparing /work/SRC/openSUSE:Factory/arabic-fonts (Old)
 and  /work/SRC/openSUSE:Factory/.arabic-fonts.new (New)


Package is arabic-fonts, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.arabic-fonts.new/arabic-fonts.changes   
2012-03-20 11:25:12.0 +0100
@@ -0,0 +1,96 @@
+---
+Thu Mar 15 10:42:16 UTC 2012 - cfarr...@suse.com
+
+- license update: GPL-2.0+
+  See the license file. This is _not_ public domain. Also, use SPDX
+  (http://www.spdx.org) format
+
+---
+Wed Feb  1 12:44:15 UTC 2012 - pgaj...@suse.com
+
+- renamed to arabic-fonts
+
+---
+Sun Sep 18 17:17:12 UTC 2011 - jeng...@medozas.de
+
+- Apply packaging guidelines (remove redundant/obsolete
+  tags/sections from specfile, etc.)
+
+---
+Thu Apr  8 18:27:31 CEST 2010 - ti...@suse.de
+
+- remove unnecessary buildrequires for too old distros
+
+---
+Wed Jan 14 13:03:28 CET 2009 - mfab...@suse.de
+
+- bnc#465330: update also ae_fonts (ttf) to 2.0.
+
+---
+Mon Jan 12 14:54:46 CET 2009 - mfab...@suse.de
+
+- bnc#465330: update kacst fonts to 2.0.
+
+---
+Fri Aug 04 17:24:29 CEST 2006 - mfab...@suse.de
+
+- move fonts to /usr/share/fonts/ in STABLE (paths changed
+  because of the move to Xorg X11R7).
+
+---
+Wed Mar 01 13:27:56 CET 2006 - mfab...@suse.de
+
+- add Provides: locale(ar).
+
+---
+Wed Jan 25 21:46:21 CET 2006 - m...@suse.de
+
+- converted neededforbuild to BuildRequires
+
+---
+Thu Jan 13 15:09:35 CET 2005 - mfab...@suse.de
+
+- update Kacst fonts to 1.6.2.
+- add ae_fonts1_ttf_1.1
+
+---
+Fri Dec 03 18:50:15 CET 2004 - mfab...@suse.de
+
+- use new macro %run_suseconfig_fonts
+
+---
+Mon Sep 13 16:44:40 CEST 2004 - mfab...@suse.de
+
+- Bugzilla #45156: add Provides: scalable-font-ar.
+
+---
+Tue Aug 17 18:39:38 CEST 2004 - mfab...@suse.de
+
+- Bugzilla #39451: run SuSEconfig.fonts only if it exists
+
+---
+Tue Aug 17 18:18:19 CEST 2004 - mfab...@suse.de
+
+- add freetype2, freetype2-devel to neededforbuild
+  (bdftopcf needs libfreetype).
+
+---
+Thu Mar 18 18:43:31 CET 2004 - mfab...@suse.de
+
+- use %suseconfig_fonts_prereq
+
+---
+Tue Feb 17 12:29:24 CET 2004 - r...@suse.de
+
+- fix typo in specfile
+
+---
+Sat Feb 14 04:13:53 CET 2004 - mfab...@suse.de
+
+- don't build as root
+- run SuSEconfig.fonts and SuSEconfig.pango in %post and %postun
+
+---
+Thu May 29 00:27:08 CEST 2003 - mfab...@suse.de
+
+- new package: fonts-arabic version 0.20030528

New:

  ae_fonts_2.0.tar.bz2
  ae_fonts_mono.tar.bz2
  arabic-fonts.changes
  arabic-fonts.spec
  haydar_fonts.tar.bz2
  kacst_fonts_2.01.tar.bz2
  lateef.shaikh_fonts.tar.bz2
  sharif.univ_ttf.bz2



Other differences:
--
++ arabic-fonts.spec ++
#
# spec file for package fonts-arabic (Version 0.20091208)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:  

commit aria2 for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package aria2 for openSUSE:Factory checked 
in at 2012-03-20 11:25:08

Comparing /work/SRC/openSUSE:Factory/aria2 (Old)
 and  /work/SRC/openSUSE:Factory/.aria2.new (New)


Package is aria2, Maintainer is po...@novell.com

Changes:

--- /work/SRC/openSUSE:Factory/aria2/aria2.changes  2011-10-16 
12:43:15.0 +0200
+++ /work/SRC/openSUSE:Factory/.aria2.new/aria2.changes 2012-03-20 
11:25:17.0 +0100
@@ -1,0 +2,100 @@
+Tue Mar 13 08:32:18 UTC 2012 - cfarr...@suse.com
+
+- license update: SUSE-GPL-2.0+-with-openssl-exception
+  Package expressly allows linking against openSSL
+
+---
+Wed Feb 29 18:56:56 UTC 2012 - pascal.ble...@opensuse.org
+
+- update to 1.14.2:
+  * only accepts 32 bit integer values from int and i4 elements in XML-RPC;
+fixed overflow bug in aria2.tellWaiting and aria2.tellStopped RPC methods
+  * updated Spanish, Italian, Russian and Chinese (Simplified) translations
+  * fixed the bug that aria2 does not listen on address given in --interface
+  * check scheme part in redirected URI more strictly: the previous
+implementation mistakenly sees '/abspath?uri=http://foo' as an absolute URI
+because it contains '://', but actually it is not; this change checks
+scheme part is constructed in the allowed character set described in RFC
+3986 Section 3.1
+  * allow missing params in XML-RPC request
+  * fixed Max payload length exceeded or invalid error when the number of
+pieces is very large
+  * added --deferred-input option; if true is given to --deferred-input option,
+aria2 does not read all URIs and options from file specified by -i option
+at startup, but it reads one by one when it needs later; this may reduce
+memory usage if input file contains a lot of URIs to download; if false is
+given, aria2 reads all URIs and options at startup;tThis option defaults to
+false
+
+---
+Sat Feb 18 11:04:36 UTC 2012 - zai...@opensuse.org
+
+- Update to version 1.14.1:
+  + This version fixes the bug that prevents the --checksum option
+from working correctly.
+  + It also fixes the bug where a log file was not created if a
+warn level log was created before the log file was opened.
+  + Now aria2 doesn't assume the download has completed just 
+because file size matched. The old behavior is problematic,
+because aria2 just assumes the download is completed, but in
+reality it is not. 
+
+---
+Thu Jan 12 11:30:29 UTC 2012 - co...@suse.com
+
+- change license to be in spdx.org format
+
+---
+Mon Dec 26 11:06:49 UTC 2011 - pascal.ble...@opensuse.org
+
+- update to 1.14.0:
+ * updated Chinese (Simplified), Spanish, French and Russian translations
+ * ignore peer which possibly sent bad data in next few minutes. In aria2, one
+   piece is downloaded from several peers, so when hash check failed for that
+   piece, it cannot determine which peer(s) sent bad data. So, we ignore peer
+   who sent last block of data in random minutes. We use randomized timeout
+   because all peers get waken up at the almost same time.
+ * Added suggestion for unknown/ambiguous options. The help messages shown when
+   argument error were redesigned and less verbose now. When unknown or
+   ambiguous option is given, show suggestions like Did you mean Some
+   constant values related to levenstein distance are borrowed from git help.c.
+ * Added --stop-with-process=PID option. This feature stops application when
+   process PID is not running. This is useful if aria2 process is forked from a
+   parent process. The parent process can fork aria2 with its own pid and when
+   parent process exits for some reason, aria2 can detect it and shutdown
+   itself.
+ * Support IPv6 address for FTP via HTTP tunneling.
+ * The previous implementation could not handle the situation when user,
+   password and proxy URI is given various order. Now we just set rules:
+   username set in --*-proxy-user overrides username in --*-proxy option, no
+   matter in any order username, password and proxy URI are parsed. Likewise,
+   password set in --*--proxy-passwd overrides password in --*-proxy option.
+ * Changed format of ETA. Now no leading 0 is used. If hour part and/or min
+   part is non-zero, and sec part is 0, sec part is omitted, like this 1h3m.
+ * Rewritten Metalink XML parser. Now we don't strip white spaces while parsing
+   Metalink V3 document.
+ * Now xml attribute and characters in RPC request is not stripped at all.
+ * Fixed bug that some information such as port number is lost if 

commit armagetron for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package armagetron for openSUSE:Factory 
checked in at 2012-03-20 11:25:18

Comparing /work/SRC/openSUSE:Factory/armagetron (Old)
 and  /work/SRC/openSUSE:Factory/.armagetron.new (New)


Package is armagetron, Maintainer is p...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/armagetron/armagetron.changes2011-09-26 
10:29:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.armagetron.new/armagetron.changes   
2012-03-20 11:25:22.0 +0100
@@ -1,0 +2,13 @@
+Thu Mar 15 22:53:39 UTC 2012 - dims...@opensuse.org
+
+- Update to version 0.2.8.3.2:
+  + Various security and bug fixes
+  + For a full list of changes see NEWS file.
+- Drop patches that have been fixed upstream:
+  + armagetronad-0.2.8.2.1-no_type_punning.patch
+  + armagetronad-0.2.8.2.1-string_const.patch
+  + armagetronad-missing_headers.patch
+  + gcc46_add_default_ctors.patch
+- Add armagetron-configure.patch: Change detection of libpng.
+
+---

Old:

  armagetronad-0.2.8.2.1-no_type_punning.patch
  armagetronad-0.2.8.2.1-string_const.patch
  armagetronad-0.2.8.2.1.tar.bz2
  armagetronad-missing_headers.patch
  gcc46_add_default_ctors.patch

New:

  armagetron-configure.patch
  armagetronad-0.2.8.3.2.src.tar.bz2



Other differences:
--
++ armagetron.spec ++
--- /var/tmp/diff_new_pack.PgqLzl/_old  2012-03-20 11:25:24.0 +0100
+++ /var/tmp/diff_new_pack.PgqLzl/_new  2012-03-20 11:25:24.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package armagetron
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,23 +16,20 @@
 #
 
 
-
 Name:   armagetron
-BuildRequires:  SDL_image-devel SDL_mixer-devel kdelibs3-devel
+BuildRequires:  SDL_image-devel
+BuildRequires:  SDL_mixer-devel
+BuildRequires:  kdelibs3-devel
 PreReq: sh-utils fileutils
 Summary:OpenGL Game Similar to the Film Tron
-Version:0.2.8.2.1
-Release:12
 License:GPL-2.0+
 Group:  Amusements/Games
+Version:0.2.8.3.2
+Release:0
 Url:http://armagetronad.sourceforge.net
-Source: %{name}ad-%{version}.tar.bz2
+Source: %{name}ad-%{version}.src.tar.bz2
 Source1:armagetron_add.tar.gz
-Patch1: armagetronad-missing_headers.patch
-Patch4: gcc46_add_default_ctors.patch
-#backports from 0.2.8.3
-Patch2: armagetronad-0.2.8.2.1-no_type_punning.patch
-Patch3: armagetronad-0.2.8.2.1-string_const.patch
+Patch0: armagetron-configure.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -47,12 +44,14 @@
 
 %prep
 %setup -q -a 1 -n armagetronad-%version
-%patch1
-%patch2
-%patch3
-%patch4
+%patch0 -p1
+#patch1
+#patch2
+#patch3
+#patch4
 
 %build
+autoreconf -fi
 export CFLAGS=%{optflags} CXXFLAGS=%{optflags}
 %configure \
--enable-music \

++ armagetron-configure.patch ++
Index: armagetronad-0.2.8.3.2/configure.ac
===
--- armagetronad-0.2.8.3.2.orig/configure.ac
+++ armagetronad-0.2.8.3.2/configure.ac
@@ -731,7 +731,7 @@ fi
 CPPFLAGS=$CPPFLAGS `libpng-config --cflags`
 LIBS=$LIBS $PNGLIBS
 
-AC_CHECK_FUNC(png_check_sig,
+AC_CHECK_FUNC(png_sig_cmp,
 ,
 AC_MSG_ERROR([You need libpng to compile Armagetron.]))
 
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit arpwatch-ethercodes for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package arpwatch-ethercodes for 
openSUSE:Factory checked in at 2012-03-20 11:25:26

Comparing /work/SRC/openSUSE:Factory/arpwatch-ethercodes (Old)
 and  /work/SRC/openSUSE:Factory/.arpwatch-ethercodes.new (New)


Package is arpwatch-ethercodes, Maintainer is dr...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/arpwatch-ethercodes/arpwatch-ethercodes.changes  
2012-03-16 13:09:14.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.arpwatch-ethercodes.new/arpwatch-ethercodes.changes 
2012-03-20 11:25:34.0 +0100
@@ -2 +2 @@
-Thu Mar 15 06:40:19 CET 2012 - autobu...@suse.de
+Sat Mar 17 05:40:07 CET 2012 - autobu...@suse.de
@@ -4 +4 @@
-- automated update on 2012-03-15
+- automated update on 2012-03-17



Other differences:
--
++ arpwatch-ethercodes.spec ++
--- /var/tmp/diff_new_pack.gUnmkM/_old  2012-03-20 11:25:36.0 +0100
+++ /var/tmp/diff_new_pack.gUnmkM/_new  2012-03-20 11:25:36.0 +0100
@@ -23,7 +23,7 @@
 License:BSD-3-Clause
 Group:  Productivity/Networking/Diagnostic
 Summary:Ethercodes Data for arpwatch
-Version:2012.3.15
+Version:2012.3.17
 Release:1
 Source0:http://standards.ieee.org/regauth/oui/oui.txt
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ oui.txt ++
--- /var/tmp/diff_new_pack.gUnmkM/_old  2012-03-20 11:25:36.0 +0100
+++ /var/tmp/diff_new_pack.gUnmkM/_new  2012-03-20 11:25:36.0 +0100
@@ -80756,6 +80756,12 @@
MANASSAS VA 20110
UNITED STATES
 
+04-98-F3   (hex)   ALPS Electric Co,. Ltd.
+0498F3 (base 16)   ALPS Electric Co,. Ltd.
+   6-1 NISHIDA
+   KAKUDA MIYAGI PREF 9876-8501
+   JAPAN
+
 04-9F-81   (hex)   Simena, LLC
 049F81 (base 16)   Simena, LLC
46030 Manekin Plaza
@@ -83916,6 +83922,13 @@
Hsinchu  300
TAIWAN, REPUBLIC OF CHINA
 
+20-9B-A5   (hex)   JIAXING GLEAD Electronics Co.,Ltd
+209BA5 (base 16)   JIAXING GLEAD Electronics Co.,Ltd
+   No.66 Zhengyuan Road in Tanghu Industrial 
Garden 
+   Jiaxing Economic Development Zone
+   Jiaxing Zhejiang 314003
+   CHINA
+
 20-A2-E7   (hex)   Lee-Dickens Ltd
 20A2E7 (base 16)   Lee-Dickens Ltd
Rushton Rd
@@ -86404,6 +86417,12 @@
Cupertino CA 95014
UNITED STATES
 
+40-70-4A   (hex)   Power Idea Technology Limited
+40704A (base 16)   Power Idea Technology Limited
+   1401A, Mintai Building, WenXin 5 Road, 
ShenZhen, PRC
+   Guang Dong Shen Zhen 518054
+   CHINA
+
 40-7B-1B   (hex)   Mettle Networks Inc.
 407B1B (base 16)   Mettle Networks Inc.
111 N. Market St STE 300
@@ -87737,6 +87756,12 @@
Shenzhen Guangdong 518103
CHINA
 
+50-8C-77   (hex)   DIRMEIER Systems
+508C77 (base 16)   DIRMEIER Systems
+   Siemensstra�e 2
+   Nabburg Bayern 92507
+   GERMANY
+
 50-93-4F   (hex)   Gradual Tecnologia Ltda.
 50934F (base 16)   Gradual Tecnologia Ltda.
Rod. Alkindar M. Junqueira, Km 34,2
@@ -88851,6 +88876,12 @@
Essen NRW 45149
GERMANY
 
+60-84-3B   (hex)   Soladigm, Inc.
+60843B (base 16)   Soladigm, Inc.
+   195. S Milpitas Blvd
+   Milpitas CA 95035
+   UNITED STATES
+
 60-86-45   (hex)   Avery Weigh-Tronix, LLC
 608645 (base 16)   Avery Weigh-Tronix, LLC
1000 Armstrong Drive
@@ -88924,6 +88955,12 @@
Encino CA 91436
UNITED STATES
 
+60-B9-82   (hex)   RO.VE.R. Laboratories S.p.A.
+60B982 (base 16)   RO.VE.R. Laboratories S.p.A.
+   Via Parini, 2
+   Sirmione Brescia 25019
+   ITALY
+
 60-C5-47   (hex)   

commit audacity for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package audacity for openSUSE:Factory 
checked in at 2012-03-20 11:25:40

Comparing /work/SRC/openSUSE:Factory/audacity (Old)
 and  /work/SRC/openSUSE:Factory/.audacity.new (New)


Package is audacity, Maintainer is mse...@novell.com

Changes:

--- /work/SRC/openSUSE:Factory/audacity/audacity.changes2012-01-04 
07:23:28.0 +0100
+++ /work/SRC/openSUSE:Factory/.audacity.new/audacity.changes   2012-03-20 
11:25:43.0 +0100
@@ -1,0 +2,43 @@
+Wed Mar 14 15:06:03 UTC 2012 - reddw...@opensuse.org
+
+- Update to version 2.0.0
+
+  * Bug fixes for:
+
+   - Interface:
+ - Fixed playback speed and synchronization problems when dragging
+   clips or tracks between tracks having different sample rates.
+
+ - Imports and Exports:
+   - Fixed crashes when changing the sample format of read-directly WAV
+ or AIFF files using the Track Drop-Down Menu.
+   - Fixed a crash importing MP3 files that had duplicate metadata tags
+ (this is a bug in current libsndfile which has been patched in
+ Audacity; MP3 files mislabeled as WAV which have duplicate tags
+ will still crash Audacity on Linux if Audacity has been compiled
+ against an affected version of system libsndfile).
+ - Fixed an issue where excessively high or corrupted sample values in
+   the audio could corrupt exports from the start of the problem for
+   the rest of the file, and could corrupt the rest of the project.
+- Fixed Audacity could not be compiled against FFmpeg
+  0.7.x and 0.8.x.
+
+   - Effects and Analysis:
+ - Fixed crash on launch when using Ambisonic Decoders (PC) VST
+   plug-ins and other plug-ins that enable additional floating point
+   exceptions.
+ - Fixed Plot Spectrum background could be transparent on some machines.
+ - Bug fixes for Click Track, High Pass, Low Pass and Vocal Remover.
+ - Chirp, Tone and Silence generators now remember their settings.
+
+   - Other miscellaneous bug fixes.
+
+  * Changes and Improvements:
+
+   - New Interface preference to show the track name in the display (this
+ is off by default).
+   - Longer default Playback preference for effects preview and preview
+ before cut.
+   - Restored use of Page Up and Page Down to scroll horizontally.
+
+---

Old:

  audacity-1.3.13-ffmpeg.patch
  audacity-minsrc-1.3.14-beta.tar.bz2

New:

  audacity-minsrc-2.0.0.tar.bz2



Other differences:
--
++ audacity.spec ++
--- /var/tmp/diff_new_pack.ID29U2/_old  2012-03-20 11:25:45.0 +0100
+++ /var/tmp/diff_new_pack.ID29U2/_new  2012-03-20 11:25:45.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package audacity
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -22,8 +22,6 @@
 
 Name:   audacity
 BuildRequires:  alsa-devel
-# we use internal PortAudio(so it is not included here in BuildRequires), 
because audacity team grab sources
-# from Portaudio's svn more frequently than we (e.g. see support for non-mmap 
devices like pulseaudio)
 BuildRequires:  flac-devel
 BuildRequires:  gcc-c++
 BuildRequires:  jack-devel
@@ -32,18 +30,19 @@
 BuildRequires:  libsamplerate-devel
 BuildRequires:  libsndfile-devel
 BuildRequires:  libvorbis-devel
+# This would require to patch our portaudio package with PortMixer... an 
extra API that never got integrated in PortAudio.
+#BuildRequires:  portaudio-devel
 BuildRequires:  soundtouch-devel
 BuildRequires:  taglib-devel
 BuildRequires:  update-desktop-files
 %if %suse_version  1130
 BuildRequires:  wxWidgets-wxcontainer-devel
+%define _use_internal_dependency_generator 0
+%define __find_requires %wx_requires
 %else
 BuildRequires:  wxGTK-devel
 %endif
-#vamp-plugin-sdk-devel is available since openSUSE 11.2
-%if %suse_version  1110
 BuildRequires:  vamp-plugin-sdk-devel
-%endif
 %if %{with ffmpeg}
 BuildRequires:  libffmpeg-devel
 %endif
@@ -53,25 +52,19 @@
 %if %{with twolame}
 BuildRequires:  libtwolame-devel
 %endif
-Version:1.3.14
-Release:1
-License:GPL-2.0+
+Version:2.0.0
+Release:0
 Summary:A Free, Cross-Platform Digital Audio Editor
-Url:http://audacity.sourceforge.net/
+License:GPL-2.0+
 Group:  Productivity/Multimedia/Sound/Editors and Convertors
-Source0:
http://%{name}.googlecode.com/files/%{name}-minsrc-%{version}-beta.tar.bz2
+Url:

commit bleachbit for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package bleachbit for openSUSE:Factory 
checked in at 2012-03-20 11:25:50

Comparing /work/SRC/openSUSE:Factory/bleachbit (Old)
 and  /work/SRC/openSUSE:Factory/.bleachbit.new (New)


Package is bleachbit, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/bleachbit/bleachbit.changes  2011-11-16 
17:17:14.0 +0100
+++ /work/SRC/openSUSE:Factory/.bleachbit.new/bleachbit.changes 2012-03-20 
11:25:52.0 +0100
@@ -1,0 +2,11 @@
+Sat Mar 17 19:02:59 UTC 2012 - sascha.ma...@open-slx.de
+
+- updated to version 0.9.2
+- These are the changes since version 0.9.1
+These are the changes since version 0.9.1:
+   * Clean Firefox crash reports.
+   * Clean more Google Chrome and Chromium history: omnibox shortcuts,
+ Network Action Predictor, and keywords_backup.
+   * Clean LibreOffice. 
+
+---

Old:

  bleachbit-0.9.1.tar.bz2
  bleachbit-bnc712471.patch

New:

  bleachbit-0.9.2.tar.bz2



Other differences:
--
++ bleachbit.spec ++
--- /var/tmp/diff_new_pack.gOgwvP/_old  2012-03-20 11:25:54.0 +0100
+++ /var/tmp/diff_new_pack.gOgwvP/_new  2012-03-20 11:25:54.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package bleachbit
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 # Copyright (c) 8/2011 by open-slx GmbH sascha.ma...@open-slx.de
 # Copyright (c) 2010 - 7/2011 by Sascha Manns saigk...@opensuse.org
 #
@@ -20,16 +20,14 @@
 
 
 Name:   bleachbit
-Version:0.9.1
+Version:0.9.2
 Release:1
 License:GPL-3.0
 Summary:Remove unnecessary files, free space, and maintain privacy
 BuildRequires:  fdupes
 BuildRequires:  make
 BuildRequires:  python-devel
-%if 0%{?suse_version} = 1110
 BuildRequires:  update-desktop-files
-%endif
 %if 0%{?fedora} == 11
 BuildRequires:  python
 BuildRequires:  python-devel
@@ -46,10 +44,8 @@
 Obsoletes:  %{name}  %{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
-%if 0%{?suse_version} = 1110
 %py_requires
 %lang_package
-%endif
 
 %description
 BleachBit deletes unnecessary files to free valuable disk space and

++ bleachbit-0.9.1.tar.bz2 - bleachbit-0.9.2.tar.bz2 ++
 9068 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit brp-extract-appdata for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package brp-extract-appdata for 
openSUSE:Factory checked in at 2012-03-20 11:26:02

Comparing /work/SRC/openSUSE:Factory/brp-extract-appdata (Old)
 and  /work/SRC/openSUSE:Factory/.brp-extract-appdata.new (New)


Package is brp-extract-appdata, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/brp-extract-appdata/brp-extract-appdata.changes  
2012-03-16 13:10:09.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.brp-extract-appdata.new/brp-extract-appdata.changes 
2012-03-20 11:26:07.0 +0100
@@ -1,0 +2,5 @@
+Mon Mar 19 08:31:40 UTC 2012 - co...@suse.com
+
+- remove the icon tag if there is no icon
+
+---



Other differences:
--
++ extract-icons.pl ++
--- /var/tmp/diff_new_pack.2G5DhB/_old  2012-03-20 11:26:08.0 +0100
+++ /var/tmp/diff_new_pack.2G5DhB/_new  2012-03-20 11:26:08.0 +0100
@@ -103,7 +103,11 @@
   next if defined $ids{$id-{content}};
   $ids{$id-{content}} = 1;
   my $icon = extract_icon(@{$app-{icon}}[0], $tmpdir);
-  $app-{icon} = [ { type = local, content = $icon } ];
+  if ($icon) {
+$app-{icon} = [ { type = local, content = $icon } ];
+  } else {
+delete $app-{icon};
+  }
   push(@napps, $app);
 }
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit canna for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package canna for openSUSE:Factory checked 
in at 2012-03-20 11:26:18

Comparing /work/SRC/openSUSE:Factory/canna (Old)
 and  /work/SRC/openSUSE:Factory/.canna.new (New)


Package is canna, Maintainer is lzw...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/canna/canna.changes  2011-12-25 
17:33:25.0 +0100
+++ /work/SRC/openSUSE:Factory/.canna.new/canna.changes 2012-03-20 
11:26:21.0 +0100
@@ -1,0 +2,6 @@
+Thu Mar 15 13:59:25 UTC 2012 - dval...@suse.com
+
+- copy config.guess, as the stock one is too old and not able to
+  guess ppc64
+
+---



Other differences:
--
++ canna.spec ++
--- /var/tmp/diff_new_pack.FyHglp/_old  2012-03-20 11:26:23.0 +0100
+++ /var/tmp/diff_new_pack.FyHglp/_new  2012-03-20 11:26:23.0 +0100
@@ -20,6 +20,7 @@
 BuildRequires:  pwdutils
 BuildRequires:  termcap
 BuildRequires:  xorg-x11-devel
+BuildRequires:  automake
 PreReq: /usr/sbin/useradd /bin/rm %insserv_prereq %fillup_prereq
 PreReq: sysvinit(network)
 #BuildPrereq:  termcap
@@ -162,6 +163,7 @@
 make Makefile
 make CDEBUGFLAGS=$RPM_OPT_FLAGS -fPIC -fno-strict-aliasing 
CXXDEBUGFLAGS=$RPM_OPT_FLAGS -fPIC -fno-strict-aliasing canna 
 pushd canuum
+cp /usr/share/automake-1.11/config.* .
 export CDEBUGFLAGS=$RPM_OPT_FLAGS -fno-strict-aliasing
 export CXXDEBUGFLAGS=$RPM_OPT_FLAGS -fno-strict-aliasing
 xmkmf -a

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit dcmtk for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package dcmtk for openSUSE:Factory checked 
in at 2012-03-20 11:26:30

Comparing /work/SRC/openSUSE:Factory/dcmtk (Old)
 and  /work/SRC/openSUSE:Factory/.dcmtk.new (New)


Package is dcmtk, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/dcmtk/dcmtk.changes  2011-12-19 
16:09:12.0 +0100
+++ /work/SRC/openSUSE:Factory/.dcmtk.new/dcmtk.changes 2012-03-20 
11:26:32.0 +0100
@@ -1,0 +2,7 @@
+Sun Mar 18 14:42:01 UTC 2012 - asterios.dra...@gmail.com
+
+- Added a patch (gcc-4.7_fix.patch) to fix compilation with gcc-4.7.
+- Remove zero-length file /usr/share/dcmtk/wlistdb/OFFIS/lockfile (fix rpmlint
+  warning).
+
+---

New:

  gcc-4.7_fix.patch



Other differences:
--
++ dcmtk.spec ++
--- /var/tmp/diff_new_pack.alij4u/_old  2012-03-20 11:26:33.0 +0100
+++ /var/tmp/diff_new_pack.alij4u/_new  2012-03-20 11:26:33.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package dcmtk
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,10 +16,11 @@
 #
 
 
+%define libname libdcmtk3_6
+
 Name:   dcmtk
 Version:3.6.0
 Release:0
-%define libname libdcmtk3_6
 Summary:DICOM Toolkit
 License:BSD-3-Clause and Apache-2.0
 Group:  Productivity/Scientific/Other
@@ -41,6 +42,8 @@
 Patch6: 
dcmtk-3.6.0-0007-Add-soname-generation-for-modules-which-are-not-in-D.patch
 # PATCH-FIX-OPENSUSE dcmtk-3.6.0.diff asterios.dra...@gmail.com -- Fix 
libraries linking
 Patch7: dcmtk-3.6.0.diff
+# PATCH-FIX-UPSTREAM gcc-4.7_fix.patch asterios.dra...@gmail.com -- Fix 
compilation with gcc-4.7
+Patch8: gcc-4.7_fix.patch
 BuildRequires:  CharLS-devel
 BuildRequires:  cmake
 BuildRequires:  doxygen
@@ -72,7 +75,7 @@
 Summary:DICOM Toolkit
 Group:  System/Libraries
 
-%description -n libdcmtk3_6
+%description -n %{libname}
 DCMTK is a collection of libraries and applications implementing large
 parts the DICOM standard.
 
@@ -86,6 +89,7 @@
 %patch5 -p1
 %patch6 -p1
 %patch7
+%patch8 -p1
 
 # Make sure the internal library copy is not used
 rm -rf dcmjpls/libcharls/
@@ -117,6 +121,9 @@
 %make_install
 cd ..
 
+# Remove zero-length file (fix rpmlint warning)
+rm -f %{buildroot}%{_datadir}/dcmtk/wlistdb/OFFIS/lockfile
+
 # Fix binary name
 mv -f %{buildroot}%{_bindir}/dcmsign-3.6.0 %{buildroot}%{_bindir}/dcmsign
 
@@ -142,7 +149,7 @@
 %config(noreplace) %{_sysconfdir}/dcmtk/*.cfg
 %{_bindir}/*
 %{_datadir}/dcmtk/
-%{_docdir}/dcmtk/
+%doc %{_docdir}/dcmtk/
 
 %files devel
 %defattr(-,root,root,-)

++ gcc-4.7_fix.patch ++
 945 lines (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit dhcp for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package dhcp for openSUSE:Factory checked in 
at 2012-03-20 11:26:37

Comparing /work/SRC/openSUSE:Factory/dhcp (Old)
 and  /work/SRC/openSUSE:Factory/.dhcp.new (New)


Package is dhcp, Maintainer is m...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/dhcp/dhcp.changes2012-01-17 
16:05:01.0 +0100
+++ /work/SRC/openSUSE:Factory/.dhcp.new/dhcp.changes   2012-03-20 
11:26:40.0 +0100
@@ -1,0 +2,7 @@
+Mon Mar 19 09:37:52 UTC 2012 - m...@suse.com
+
+- dhcp-server: fixed to escape all values used in constructed
+  ldap filters as a DN may contain e.g. asterisks (bnc#721829,
+  [ISC-Bugs #28545]).
+
+---

New:

  dhcp-4.2.3-P2-ldap-filter-value-escape.patch



Other differences:
--
++ dhcp.spec ++
--- /var/tmp/diff_new_pack.6u3lPE/_old  2012-03-20 11:26:42.0 +0100
+++ /var/tmp/diff_new_pack.6u3lPE/_new  2012-03-20 11:26:42.0 +0100
@@ -83,6 +83,7 @@
 Patch21:dhcp-4.2.2-dhclient-send-hostname-rml.diff
 ## patch repo lives here: http://www.suse.de/~mt/git/dhcp-ldap.git/
 Patch30:dhcp-4.2.3-P1-ldap-patch-mt01.diff.bz2
+Patch31:dhcp-4.2.3-P2-ldap-filter-value-escape.patch
 Patch40:dhcp-4.1.1-P1-lpf-bind-msg-fix.diff
 Patch44:dhcp-4.2.2-xen-checksum.diff
 Patch45:dhcp-4.2.2-dhclient-option-checks.bnc675052.diff
@@ -213,6 +214,7 @@
 %patch21 -p1
 %if %{with_ldap}
 %patch30 -p1
+%patch31 -p1
 %endif
 %patch40 -p1
 %patch44 -p1

++ dhcp-4.2.3-P2-ldap-filter-value-escape.patch ++
From e8ad30e0ed9dcb77cb1a87e5e676f4dc56a36afa Mon Sep 17 00:00:00 2001
From: Marius Tomaschewski m...@suse.de
Date: Tue, 31 Jan 2012 17:38:25 +0100
Subject: [PATCH] Fixed to escape values used in ldap filters

Use ldap_bv2escaped_filter_value to escape all values used in
constructed ldap filters, e.g. o=*Test in DN (bnc#721829).

Signed-off-by: Marius Tomaschewski m...@suse.de
---
 server/ldap.c |  116 +++-
 1 files changed, 97 insertions(+), 19 deletions(-)

diff --git a/server/ldap.c b/server/ldap.c
index 68acbbb..274e934 100644
--- a/server/ldap.c
+++ b/server/ldap.c
@@ -1024,6 +1024,17 @@ _do_ldap_retry(int ret, const char *server, int port)
   return 0;
 }
 
+static struct berval *
+_do_ldap_str2esc_filter_bv(const char *str, ber_len_t len, struct berval *bv_o)
+{
+  struct berval bv_i;
+
+  if (!str || !bv_o || (ber_str2bv(str, len, 0, bv_i) == NULL) ||
+ (ldap_bv2escaped_filter_value(bv_i, bv_o) != 0))
+return NULL;
+  return bv_o;
+}
+
 static void
 ldap_start (void)
 {
@@ -1801,6 +1812,7 @@ ldap_read_config (void)
   size_t length;
   int ret, cnt;
   struct berval **tempbv = NULL;
+  struct berval bv_o[2];
 
   if (local_family != AF_INET)
 return (ISC_R_SUCCESS);
@@ -1825,24 +1837,49 @@ ldap_read_config (void)
   uname (unme);
   if (ldap_dhcp_server_cn != NULL)
 {
+  if (_do_ldap_str2esc_filter_bv(ldap_dhcp_server_cn, 0, bv_o[0]) == NULL)
+{
+  log_error (Cannot escape ldap filter value %s: %m, 
ldap_dhcp_server_cn);
+  return (ISC_R_FAILURE);
+}
+
  snprintf (hfilter, sizeof (hfilter),
-((objectClass=dhcpServer)(cn=%s)), ldap_dhcp_server_cn);
-}
-  else
-  {
-  if(0 == get_host_entry(fqdn, sizeof(fqdn), NULL, 0))
-{
-  snprintf (hfilter, sizeof (hfilter),
-((objectClass=dhcpServer)(|(cn=%s)(cn=%s))), 
-unme.nodename, fqdn);
+((objectClass=dhcpServer)(cn=%s)), bv_o[0].bv_val);
+
+ ber_memfree(bv_o[0].bv_val);
 }
   else
 {
-  snprintf (hfilter, sizeof (hfilter),
-((objectClass=dhcpServer)(cn=%s)), unme.nodename);
-}
+  if (_do_ldap_str2esc_filter_bv(unme.nodename, 0, bv_o[0]) == NULL)
+{
+  log_error (Cannot escape ldap filter value %s: %m, unme.nodename);
+  return (ISC_R_FAILURE);
+}
+
+  if(0 == get_host_entry(fqdn, sizeof(fqdn), NULL, 0))
+{
+  if (_do_ldap_str2esc_filter_bv(fqdn, 0, bv_o[1]) == NULL)
+{
+  log_error (Cannot escape ldap filter value %s: %m, fqdn);
+  ber_memfree(bv_o[0].bv_val);
+  return (ISC_R_FAILURE);
+}
 
-  }
+  snprintf (hfilter, sizeof (hfilter),
+((objectClass=dhcpServer)(|(cn=%s)(cn=%s))), 
+bv_o[0].bv_val, bv_o[1].bv_val);
+
+  ber_memfree(bv_o[1].bv_val);
+}
+  else
+{
+  snprintf (hfilter, sizeof (hfilter),
+((objectClass=dhcpServer)(cn=%s)),
+bv_o[0].bv_val);
+}
+
+  

commit exim for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package exim for openSUSE:Factory checked in 
at 2012-03-20 11:26:45

Comparing /work/SRC/openSUSE:Factory/exim (Old)
 and  /work/SRC/openSUSE:Factory/.exim.new (New)


Package is exim, Maintainer is po...@novell.com

Changes:

--- /work/SRC/openSUSE:Factory/exim/exim.changes2011-09-23 
01:57:06.0 +0200
+++ /work/SRC/openSUSE:Factory/.exim.new/exim.changes   2012-03-20 
11:26:48.0 +0100
@@ -1,0 +2,94 @@
+Sat Mar 17 19:42:30 UTC 2012 - l...@samba.org
+
+- Disable format-security and missing-format-attribute warnings via CFLAGS on
+  pre-11.2 systems.
+
+---
+Wed Mar  7 16:13:51 UTC 2012 - l...@samba.org
+
+- Remove obsoleted Authors lines from spec file.
+
+---
+Wed Mar  7 15:33:12 UTC 2012 - l...@samba.org
+
+- update to 4.77
+  - DKIM Verification: Fix relaxed canon for empty headers w/o
+whitespace trailer
+  - Fix a couple more cases where we did not log the error message
+when unlink() failed. See also change 4.74-TF/03.
+  - Make the exiwhat support code safe for signals. Previously Exim might
+lock up or crash if it happened to be inside a call to libc when it
+got a SIGUSR1 from exiwhat.
+  - The SIGUSR1 handler appends the current process status to the process
+log which is later printed by exiwhat. It used to use the general
+purpose logging code to do this, but several functions it calls are
+not safe for signals.
+  - The new output code in the SIGUSR1 handler is specific to the process
+log, and simple enough that it's easy to inspect for signal safety.
+Removing some special cases also simplifies the general logging code.
+Removing the spurious timestamps from the process log simplifies
+exiwhat.
+  - Improved ratelimit ACL condition.
+  - Removed obsolete $Cambridge$ CVS revision strings.
+  - Removed a few PCRE remnants.
+  - Automatically extract Exim's version number from tags in the git
+repository when doing development or release builds.
+  - Raise smtp_cmd_buffer_size to 16kB.
+Bugzilla 879.  Patch from Paul Fisher.
+  - Implement SSL-on-connect outbound with protocol=smtps on smtp transport.
+Heavily based on revision 40f9a89a from Simon Arlott's tree.
+Bugzilla 97.
+  - Use .dylib instead of .so for dynamic library loading on MacOS.
+  - Variable $av_failed, true if the AV scanner deferred.
+Bugzilla 1078.  Patch from John Horne.
+  - Stop make process more reliably on build failure.
+Bugzilla 1087.  Patch from Heiko Schlittermann.
+  - Make maildir_use_size_file an _expandable_ boolean.
+Bugzilla 1089.  Patch from Heiko Schlittermann.
+  - Handle ${run} returning more data than OS pipe buffer size.
+Bugzilla 1131.  Patch from Holger Weiß.
+  - Handle IPv6 addresses with SPF.
+Bugzilla 860.  Patch from Wolfgang Breyha.
+  - GnuTLS: support TLS 1.2  1.1.
+Bugzilla 1156.
+Use gnutls_certificate_verify_peers2() [patch from Andreas Metzler].
+Bugzilla 1095.
+  - match_* no longer expand right-hand-side by default.
+New compile-time build option, EXPAND_LISTMATCH_RHS.
+New expansion conditions, inlist, inlisti.
+  - fix uninitialised greeting string from PP/03 (smtps client support).
+  - shell and compiler warnings fixes for RC1-RC4 changes.
+  - fix log_write() format string regression from TF/03.
+Bugzilla 1152.  Patch from Dmitry Isaikin.
+
+- update to 4.77
+  - The new ldap_require_cert option would segfault if used.  Fixed.
+  - Harmonised TLS library version reporting; only show if debugging.
+Layout now matches that introduced for other libraries in 4.74 PP/03.
+  - New openssl_options items: no_sslv2 no_sslv3 no_ticket no_tlsv1
+  - New dns_use_edns0 global option.
+  - Don't segfault on misconfiguration of ref:name exim-user as uid.
+Bugzilla 1098.
+  - Extra paranoia around buffer usage at the STARTTLS transition.
+nb: Exim is not vulnerable to http://www.kb.cert.org/vuls/id/555316
+  - Updated PolarSSL code to 0.14.2.
+Bugzilla 1097. Patch from Andreas Metzler.
+  - Catch divide-by-zero in ${eval:...}.
+Fixes bugzilla 1102.
+  - Condition negation of bool{}/bool_lax{} did not negate.  Fixed.
+Bugzilla 1104.
+  - Bugzilla 1106: CVE-2011-1764 - DKIM log line was subject to a
+format-string attack -- SECURITY: remote arbitrary code execution.
+  - SECURITY - DKIM signature header parsing was double-expanded, second
+time unintentionally subject to list matching rules, letting the header
+cause arbitrary Exim lookups (of items which can occur in lists, *not*
+arbitrary string expansion). This allowed for information disclosure.
+  - Fix another SIGFPE (x86) in ${eval:...} expansion, 

commit firmwarekit for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package firmwarekit for openSUSE:Factory 
checked in at 2012-03-20 11:26:54

Comparing /work/SRC/openSUSE:Factory/firmwarekit (Old)
 and  /work/SRC/openSUSE:Factory/.firmwarekit.new (New)


Package is firmwarekit, Maintainer is tr...@novell.com

Changes:

--- /work/SRC/openSUSE:Factory/firmwarekit/firmwarekit.changes  2011-09-23 
01:57:52.0 +0200
+++ /work/SRC/openSUSE:Factory/.firmwarekit.new/firmwarekit.changes 
2012-03-20 11:26:57.0 +0100
@@ -1,0 +2,6 @@
+Fri Mar 16 09:14:03 UTC 2012 - a...@suse.de
+
+- It's nostdlib and not nostdlibs as command line option.
+- Remove obsolete version checks.
+
+---

New:

  firmwarekit-gcc.patch



Other differences:
--
++ firmwarekit.spec ++
--- /var/tmp/diff_new_pack.jOAIsi/_old  2012-03-20 11:26:59.0 +0100
+++ /var/tmp/diff_new_pack.jOAIsi/_new  2012-03-20 11:26:59.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package firmwarekit (Version 3)
+# spec file for package firmwarekit
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -22,11 +22,7 @@
 BuildRequires:  bash coreutils dhcp-client findutils gawk gdb glib2-devel
 BuildRequires:  grep iproute2 module-init-tools ncurses-devel newt newt-devel
 BuildRequires:  perl pkgconfig sed sharutils slang-devel sysvinit
-%if %suse_version  1110
 BuildRequires:  acpica dmidecode
-%else
-BuildRequires:  pmtools
-%endif
 BuildRequires:  termcap util-linux wget xorg-x11-util-devel
 Url:http://www.linuxfirmwarekit.org
 Summary:BIOS checker that validates ACPI and other parts for x86 and 
x86_64 machines
@@ -36,11 +32,7 @@
 Group:  System/Boot
 AutoReqProv:on
 PreReq: gzip
-%if %suse_version  1110
 Requires:   acpica dmidecode
-%else
-Requires:   pmtools
-%endif
 Requires:   hwinfo util-linux powertop
 Summary:BIOS checker that validates ACPI and other parts for x86 and 
x86_64 machines
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -61,6 +53,7 @@
 Patch12:%{name}-fix-rpmlint.patch
 Patch13:%{name}-outputdir
 Patch14:%{name}-dmidecode-detail
+Patch15:%{name}-gcc.patch
 
 %description
 This tool, developed by Intel, is meant for vendors to validate and
@@ -91,6 +84,7 @@
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch15 -p1
 # This is arch specific stuff, put all in /usr/lib/firmwarekit
 %define location /usr/lib/%{name}
 

++ firmwarekit-gcc.patch ++
Index: linuxfirmwarekit/Makefile
===
--- linuxfirmwarekit.orig/Makefile
+++ linuxfirmwarekit/Makefile
@@ -1,7 +1,7 @@
 CFLAGS =  -Wall -W -Os -D_FORTIFY_SOURCE=2 -g
 override CFLAGS +=  `pkg-config --cflags glib-2.0` -I/usr/include/slang -fPIC 
-I.
 #LDFLAGS = -nodefaultlibs -Linitramfs/data/lib -Linitramfs/data/usr/lib  
-export-dynamic  -lc -ldl `pkg-config --libs glib-2.0`   -lnewt -lslang  
-LDFLAGS = -nostdlibs -Linitramfs/data/lib -Linitramfs/data/usr/lib  
-export-dynamic  -lc -ldl `pkg-config --libs glib-2.0`   -lnewt -lslang 
+LDFLAGS = -nostdlib -Linitramfs/data/lib -Linitramfs/data/usr/lib  
-export-dynamic  -lc -ldl `pkg-config --libs glib-2.0`   -lnewt -lslang 
 
 
 # Rip out lmbench, our package is in no good shape...
++ firmwarekit-outputdir ++
--- /var/tmp/diff_new_pack.jOAIsi/_old  2012-03-20 11:26:59.0 +0100
+++ /var/tmp/diff_new_pack.jOAIsi/_new  2012-03-20 11:26:59.0 +0100
@@ -15,8 +15,10 @@
  ssh.c |   10 ++
  6 files changed, 67 insertions(+), 9 deletions(-)
 
 a/acpitable.c
-+++ b/acpitable.c
+Index: linuxfirmwarekit/acpitable.c
+===
+--- linuxfirmwarekit.orig/acpitable.c
 linuxfirmwarekit/acpitable.c
 @@ -180,6 +180,7 @@ void extract_acpi_tables(void)
   * are located (should exist after compiling acpicompile plugin).
   * Since we're standalone, we could be called from a few different
@@ -43,8 +45,10 @@
  }
  
  void load_acpi_tables(void) {
 a/biostest.h
-+++ b/biostest.h
+Index: linuxfirmwarekit/biostest.h
+===
+--- linuxfirmwarekit.orig/biostest.h
 linuxfirmwarekit/biostest.h
 @@ -139,6 +139,7 @@ extern int locate_acpi_table(char *name,
  extern int e820_is_reserved(uint64_t memory);
  extern char *copy_acpi_table(void *address, char *name);
@@ -53,8 

commit fwbuilder for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package fwbuilder for openSUSE:Factory 
checked in at 2012-03-20 11:27:03

Comparing /work/SRC/openSUSE:Factory/fwbuilder (Old)
 and  /work/SRC/openSUSE:Factory/.fwbuilder.new (New)


Package is fwbuilder, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/fwbuilder/fwbuilder.changes  2012-02-10 
17:13:54.0 +0100
+++ /work/SRC/openSUSE:Factory/.fwbuilder.new/fwbuilder.changes 2012-03-20 
11:27:05.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar 17 21:39:27 UTC 2012 - dims...@opensuse.org
+
+- Add fwbuilder-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  fwbuilder-gcc47.patch



Other differences:
--
++ fwbuilder.spec ++
--- /var/tmp/diff_new_pack.2gZTWB/_old  2012-03-20 11:27:06.0 +0100
+++ /var/tmp/diff_new_pack.2gZTWB/_new  2012-03-20 11:27:06.0 +0100
@@ -27,6 +27,7 @@
 Release:0.0
 Url:http://www.fwbuilder.org/
 Source: %{name}-%{version}.tar.bz2
+Patch0: fwbuilder-gcc47.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  autoconf
 BuildRequires:  automake
@@ -64,6 +65,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 ./autogen.sh

++ fwbuilder-gcc47.patch ++
Only in fwbuilder-5.0.1.3592: patches
Only in fwbuilder-5.0.1.3592: .pc
diff -upr fwbuilder-5.0.1.3592/src/libfwbuilder/src/fwbuilder/ThreadTools.h 
/var/tmp/build-root/home/abuild/rpmbuild/BUILD/fwbuilder-5.0.1.3592/src/libfwbuilder/src/fwbuilder/ThreadTools.h
--- fwbuilder-5.0.1.3592/src/libfwbuilder/src/fwbuilder/ThreadTools.h   
2011-12-08 02:02:07.0 +0100
+++ 
/var/tmp/build-root/home/abuild/rpmbuild/BUILD/fwbuilder-5.0.1.3592/src/libfwbuilder/src/fwbuilder/ThreadTools.h
2012-03-17 22:29:16.317275376 +0100
@@ -31,6 +31,7 @@
 
 #include time.h //for time_t definition
 #include pthread.h
+#include unistd.h
 
 #include string
 #include queue
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit groff for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package groff for openSUSE:Factory checked 
in at 2012-03-20 11:27:20

Comparing /work/SRC/openSUSE:Factory/groff (Old)
 and  /work/SRC/openSUSE:Factory/.groff.new (New)


Package is groff, Maintainer is mvysko...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/groff/groff.changes  2011-10-02 
10:10:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.groff.new/groff.changes 2012-03-20 
11:27:21.0 +0100
@@ -1,0 +2,6 @@
+Sun Mar 18 00:14:49 UTC 2012 - jeng...@medozas.de
+
+- Remove redundant tags/sections from specfile
+- Enable parallel build with %_smp_mflags
+
+---
gxditview.changes: same change



Other differences:
--
++ groff.spec ++
--- /var/tmp/diff_new_pack.mSlIRf/_old  2012-03-20 11:27:23.0 +0100
+++ /var/tmp/diff_new_pack.mSlIRf/_new  2012-03-20 11:27:23.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package groff
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -14,16 +14,12 @@
 
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
-
-# norootforbuild
-
-
 Name:   groff
-License:BSD-3-Clause ; GPL-2.0+
-Group:  Productivity/Publishing/Troff
 Version:1.21
-Release:1
+Release:0
 Summary:GNU troff Document Formatting System
+License:BSD-3-Clause ; GPL-2.0+
+Group:  Productivity/Publishing/Troff
 Url:http://www.gnu.org/software/groff/groff.html
 Source0:ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
 Source3:zzz-groff.sh
@@ -51,15 +47,14 @@
 Patch10:groff-force-locale-usage.patch
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  gcc-c++
 BuildRequires:  bison
 BuildRequires:  fdupes
+BuildRequires:  gcc-c++
 Provides:   normal-groff = %{version}-%{release}
 Provides:   jgroff = %{version}-%{release}
 Obsoletes:  jgroff  %{version}
 Requires(pre):  %fillup_prereq
 Requires(pre):  %install_info_prereq
-AutoReqProv:on
 # for pre-grohtml and pdfroff
 Recommends: netpbm
 Recommends: ghostscript-library
@@ -76,9 +71,8 @@
 /usr/X11R6/man/.
 
 %package doc
-License:BSD-3-Clause ; GPL-2.0+
-Group:  Productivity/Publishing/Troff
 Summary:HTML documentation and examples for groff
+Group:  Productivity/Publishing/Troff
 
 %description doc
 The groff package provides compatible versions of troff, nroff, eqn,
@@ -91,7 +85,7 @@
 /usr/X11R6/man/.
 
 %prep
-%setup -q -n groff-%{version} 
+%setup -q
 %patch0 -p1 -b .debian
 %patch1
 %patch2 -p1 -b .bnc540600
@@ -118,9 +112,9 @@
 export CXXFLAGS=$RPM_OPT_FLAGS -fno-strict-aliasing
 %{configure}
 ulimit -c unlimited
-%{__make}
+make %{?_smp_mflags}
 pushd doc
-%{__make}
+make %{?_smp_mflags}
 makeinfo groff.texinfo
 popd
 
@@ -143,9 +137,6 @@
 
 %fdupes -s %{buildroot}
 
-%clean
-rm -rf %{buildroot}
-
 %post
 %install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz
 

++ gxditview.spec ++
--- /var/tmp/diff_new_pack.mSlIRf/_old  2012-03-20 11:27:23.0 +0100
+++ /var/tmp/diff_new_pack.mSlIRf/_new  2012-03-20 11:27:23.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gxditview
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -14,16 +14,12 @@
 
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
-
-
-
 Name:   gxditview
-License:MIT
-Group:  Productivity/Publishing/Troff
-AutoReqProv:on
 Version:1.21
-Release:1
+Release:0
 Summary:Ditroff Output Displayer for Groff
+License:MIT
+Group:  Productivity/Publishing/Troff
 Url:http://www.gnu.org/software/groff/groff.html
 Source0:ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
 # for file in `cat series | grep -v '^#' | grep  '^[a-z]' `; do
@@ -52,9 +48,9 @@
 the -X option.
 
 %package -n groff-devx
+Summary:X output devices for groff
 License:BSD-3-Clause ; GPL-2.0+
 Group:  Productivity/Publishing/Troff
-Summary:X output devices for groff
 Requires:   groff
 Supplements:groff
 
@@ -81,7 +77,7 @@
 #
 export CFLAGS=$RPM_OPT_FLAGS -fno-strict-aliasing 

commit hugin for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package hugin for openSUSE:Factory checked 
in at 2012-03-20 11:27:30

Comparing /work/SRC/openSUSE:Factory/hugin (Old)
 and  /work/SRC/openSUSE:Factory/.hugin.new (New)


Package is hugin, Maintainer is sbra...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/hugin/hugin.changes  2012-01-11 
15:37:53.0 +0100
+++ /work/SRC/openSUSE:Factory/.hugin.new/hugin.changes 2012-03-20 
11:27:32.0 +0100
@@ -1,0 +2,6 @@
+Mon Mar 19 17:30:17 UTC 2012 - alinm.el...@gmail.com
+
+- added patch to fix gcc 4.7 failure (gcc47.diff)
+- added fdupes 
+
+---

New:

  gcc47.diff



Other differences:
--
++ hugin.spec ++
--- /var/tmp/diff_new_pack.MzFgyC/_old  2012-03-20 11:27:33.0 +0100
+++ /var/tmp/diff_new_pack.MzFgyC/_new  2012-03-20 11:27:33.0 +0100
@@ -16,7 +16,6 @@
 #
 
 
-
 Name:   hugin
 BuildRequires:  Mesa-devel
 BuildRequires:  OpenEXR-devel
@@ -24,21 +23,22 @@
 BuildRequires:  boost-devel
 BuildRequires:  cmake
 BuildRequires:  fdupes
+BuildRequires:  fdupes
 BuildRequires:  fftw3-devel
 BuildRequires:  freeglut-devel
 BuildRequires:  gcc-c++
 BuildRequires:  glew-devel
 BuildRequires:  lapack
 BuildRequires:  libexiv2-devel
+BuildRequires:  libjpeg-devel
 BuildRequires:  liblapack3
 BuildRequires:  libpano-devel = 2.9.18
+BuildRequires:  libtiff-devel
 BuildRequires:  libxml2
 BuildRequires:  tclap
 BuildRequires:  update-desktop-files
 BuildRequires:  vigra
 BuildRequires:  zip
-BuildRequires:  libtiff-devel
-BuildRequires:  libjpeg-devel
 %if 0%{?suse_version}  1130
 BuildRequires:  python-wxWidgets = 2.7.0
 BuildRequires:  wxWidgets-devel
@@ -58,6 +58,7 @@
 # svn co https://hugin.svn.sourceforge.net/svnroot/hugin/hugin/trunk hugin
 #Source: %%{name}-svn2008.tar.bz2
 Source1:%{name}-svn-dummy
+Patch0: gcc47.diff
 Requires:   enblend-enfuse = 3.2
 Recommends: autopano-sift
 Recommends: exiftool
@@ -96,6 +97,7 @@
 #mkdir bin
 #cp %%{SOURCE1} bin/svn
 #chmod +x bin/svn
+%patch0 -p1
 
 %build
 export PATH=$PWD/bin:$PATH
@@ -119,6 +121,7 @@
 mkdir -p %{buildroot}%{_docdir}/%{name}
 cp -a AUTHORS authors.txt COPYING ChangeLog LICENCE_VIGRA README README_JP 
TODO %{buildroot}%{_docdir}/%{name}/
 chmod -x %{buildroot}%{_docdir}/%{name}/*
+%fdupes %{buildroot}
 
 %post
 %if 0%{?suse_version}  1130

++ gcc47.diff ++
diff -r 658ded2153f2 src/celeste/Utilities.h
--- a/src/celeste/Utilities.h Sun Jan 01 13:23:39 2012 +0100
+++ b/src/celeste/Utilities.h SunSat Jan 07 19:38:25 2012 +
@@ -33,6 +33,8 @@
 #include stdio.h
 #ifdef _WINDOWS
 #include direct.h
+#else
+#include unistd.h
 #endif
 
 using namespace std; 
diff -r 658ded2153f2 src/foreign/zthread/include/zthread/Guard.h
--- a/src/foreign/zthread/include/zthread/Guard.h SunSatSun Jan 01 13:23:39 
2012 +0100
+++ b/src/foreign/zthread/include/zthread/Guard.h SunSatSunSat Jan 07 19:38:25 
2012 +
@@ -428,7 +428,7 @@
   template class U, class V
   Guard(GuardU, V g) : LockHolderLockType(g) {
 
-LockingPolicy::shareScope(*this, extract(g));
+LockingPolicy::shareScope(*this, this-extract(g));
 
   }
 
@@ -458,7 +458,7 @@
   template class U, class V
   Guard(GuardU, V g, LockType lock) : LockHolderLockType(lock) {
 
-LockingPolicy::transferScope(*this, extract(g));
+LockingPolicy::transferScope(*this, this-extract(g));
 
   }
 
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit hxtools for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package hxtools for openSUSE:Factory checked 
in at 2012-03-20 11:27:37

Comparing /work/SRC/openSUSE:Factory/hxtools (Old)
 and  /work/SRC/openSUSE:Factory/.hxtools.new (New)


Package is hxtools, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/hxtools/hxtools.changes  2012-01-09 
16:21:39.0 +0100
+++ /work/SRC/openSUSE:Factory/.hxtools.new/hxtools.changes 2012-03-20 
11:27:38.0 +0100
@@ -1,0 +2,13 @@
+Mon Mar 12 11:27:33 UTC 2012 - cfarr...@suse.com
+
+- license update: GPL-2.0+
+  spec file license should be in SPDX (compatible) format. GPL-2.0+ seems
+  to be the most appropriate license choice for the resulting binary (no
+  GPL-3.0 except for as choice in dual license situation)
+
+---
+Sat Feb 25 10:00:17 UTC 2012 - jeng...@medozas.de
+
+- Avoid fdupes-induced hardlink across partitions
+
+---

New:

  7a4b085-capabilities.diff



Other differences:
--
++ hxtools.spec ++
--- /var/tmp/diff_new_pack.uCB4uO/_old  2012-03-20 11:27:39.0 +0100
+++ /var/tmp/diff_new_pack.uCB4uO/_new  2012-03-20 11:27:39.0 +0100
@@ -15,23 +15,41 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   hxtools
 Version:20120107
 Release:0
-Group:  System/Base
 Url:http://jengelh.medozas.de/projects/hxtools/
 Summary:Collection of day-to-day tools (binaries)
+License:GPL-2.0+
+Group:  System/Base
 
 Source: %name-%version.tar.xz
 Source2:%name-%version.tar.xz.asc
-License:GPL,PD
+Patch1: 7a4b085-capabilities.diff
+BuildRequires:  fdupes
+BuildRequires:  libcap-devel = 2
 # xorg-x11 for bdftopcf
-BuildRequires:  libcap-devel xorg-x11 xz
-BuildRequires:  pkgconfig = 0.23 pkgconfig(libHX) = 3.12
+%if 0%{?suse_version}
+BuildRequires:  xorg-x11
+%endif
+%if 0%{?rhel_version} || 0%{?fedora_version}
+BuildRequires:  bdftopcf
+%endif
+BuildRequires:  pkgconfig = 0.21
+BuildRequires:  xz
+%if 0%{?suse_version} = 1130
+BuildRequires:  pkgconfig(libHX) = 3.12
+%else
+BuildRequires:  libHX-devel = 3.12
+%endif
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-Recommends: %name-scripts = %version, %name-man = %version
+
+Requires:   %name-scripts = %version
+%if 0%{?suse_version} = 1100
+Recommends: %name-man = %version
+%else
+Requires:   %name-man = %version
+%endif
 
 %define build_profile 1
 
@@ -47,10 +65,17 @@
 * vfontas(1) — VGA font file assembler
 
 %package scripts
-Group:  System/Base
 Summary:Collection of day-to-day tools (scripts)
+Group:  System/Base
+%if 0%{?suse_version} = 1120
 BuildArch:  noarch
-Recommends: %name, %name-man
+%endif
+Requires:   %name
+%if 0%{?suse_version} = 1100
+Recommends: %name-man
+%else
+Requires:   %name-man
+%endif
 Requires:   perl(Data::Dumper), perl(File::Find)
 Requires:   perl(File::Find::Rule)
 Requires:   perl(Getopt::Long), perl(IPC::Open2), perl(Text::CSV_XS)
@@ -81,18 +106,22 @@
 * wktimer(1) — work timer
 
 %package man
-Group:  Documentation/Man
 Summary:Manual pages for the hxtools suite
+Group:  Documentation/Man
+%if 0%{?suse_version} = 1120
 BuildArch:  noarch
+%endif
 
 %description man
 This package contains the manual pages for the binaries and scripts
 from hxtools.
 
 %package data
-Group:  System/Base
 Summary:Collection of day-to-day tools (data)
+Group:  System/Base
+%if 0%{?suse_version} = 1120
 BuildArch:  noarch
+%endif
 
 %description data
 Architecture-independent data from hxtools.
@@ -102,11 +131,13 @@
 * additional syntax highlighting definitions for mcedit
 
 %package profile
-Group:  System/Base
 Summary:The hxtools shell environment
+Group:  System/Base
 Requires:   %name = %version, %name-scripts = %version
 Requires:   %name-data = %version
+%if 0%{?suse_version} = 1120
 BuildArch:  noarch
+%endif
 
 %description profile
 Bash environment settings from hxtools. Particularly, this provides
@@ -114,7 +145,13 @@
 only important parts of a path.
 
 %prep
+%if 0%{?__xz:1}
 %setup -q
+%else
+tar -xf %{S:0} --use=xz;
+%setup -DTq
+%endif
+%patch -P 1 -p1
 
 %build
 %configure \
@@ -132,7 +169,8 @@
 install -dm0755 $b/%_datadir/mc/syntax;
 install -pm0644 cooledit/*.syntax $b/%_datadir/mc/syntax/;
 install -dm0755 $b/%_sysconfdir/openldap/schema;
-install -pm0644 data/rfc2307bis-utf8.schema $b/%_sysconfdir/openldap/schema/;
+ln -s %_datadir/hxtools/rfc2307bis-utf8.schema \
+   

commit hydrogen for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package hydrogen for openSUSE:Factory 
checked in at 2012-03-20 11:27:45

Comparing /work/SRC/openSUSE:Factory/hydrogen (Old)
 and  /work/SRC/openSUSE:Factory/.hydrogen.new (New)


Package is hydrogen, Maintainer is ti...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/hydrogen/hydrogen.changes2011-10-26 
20:21:41.0 +0200
+++ /work/SRC/openSUSE:Factory/.hydrogen.new/hydrogen.changes   2012-03-20 
11:27:50.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar 17 20:38:28 UTC 2012 - bo...@steki.net
+
+- Add hydrogen-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  hydrogen-gcc47.patch



Other differences:
--
++ hydrogen.spec ++
--- /var/tmp/diff_new_pack.8tr0KC/_old  2012-03-20 11:27:52.0 +0100
+++ /var/tmp/diff_new_pack.8tr0KC/_new  2012-03-20 11:27:52.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package hydrogen
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -25,9 +25,30 @@
 %define librubberband 0
 
 Name:   hydrogen
-BuildRequires:  alsa-devel doxygen flac-devel libjack-devel liblrdf-devel 
libqt4-devel libsndfile-devel util-linux
-BuildRequires:  ladspa ladspa-devel lash-devel libarchive-devel 
libraptor-devel portaudio-devel zlib-devel
-BuildRequires:  cmake fdupes gcc-c++ help2man hicolor-icon-theme pkg-config 
rsync subversion update-desktop-files
+BuildRequires:  alsa-devel
+BuildRequires:  cmake
+BuildRequires:  doxygen
+BuildRequires:  fdupes
+BuildRequires:  flac-devel
+BuildRequires:  gcc-c++
+BuildRequires:  help2man
+BuildRequires:  hicolor-icon-theme
+BuildRequires:  ladspa
+BuildRequires:  ladspa-devel
+BuildRequires:  lash-devel
+BuildRequires:  libarchive-devel
+BuildRequires:  libjack-devel
+BuildRequires:  liblrdf-devel
+BuildRequires:  libqt4-devel
+BuildRequires:  libraptor-devel
+BuildRequires:  libsndfile-devel
+BuildRequires:  pkg-config
+BuildRequires:  portaudio-devel
+BuildRequires:  rsync
+BuildRequires:  subversion
+BuildRequires:  update-desktop-files
+BuildRequires:  util-linux
+BuildRequires:  zlib-devel
 BuildRequires:  pkgconfig(Qt3Support)
 BuildRequires:  pkgconfig(QtCLucene)
 BuildRequires:  pkgconfig(QtCore)
@@ -60,11 +81,11 @@
 BuildRequires:  rubberband-cli
 %endif
 Summary:A Real-Time Drum Machine and Sequencer
+License:GPL-2.0+
+Group:  Productivity/Multimedia/Sound/Midi
 # NOTE: Don't forget to update the libsuffix macro.
 Version:0.9.6
 Release:0
-License:GPL-2.0+
-Group:  Productivity/Multimedia/Sound/Midi
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://www.hydrogen-music.org/
 Source0:%{name}-%{version}.tar.bz2
@@ -77,6 +98,8 @@
 Patch1: hydrogen-no-current-time.patch
 # libhydrogencore has no soname and installs in _libexecdir
 Patch2: hydrogen-0.9.6-lib64.patch
+# PATCH-FIX-UPSTREAM hydrogen-gcc47.patch bo...@steki.net -- Fix build with 
gcc 4.7.
+Patch3: hydrogen-gcc47.patch
 
 %description
 Hydrogen is an advanced drum machine for GNU/Linux.
@@ -103,15 +126,15 @@
 Export song to midi file.
 
 %package -n libhydrogen-core%{soversion}
-Group:  System/Libraries
 Summary:Library essential for hydrogen
+Group:  System/Libraries
 
 %description -n libhydrogen-core%{soversion}
 This is the core of hydrogen's operation.
 
 %package -n libhydrogen-core-devel
-Group:  Development/Libraries/C and C++
 Summary:Development files and headers for libhydrogen-core
+Group:  Development/Libraries/C and C++
 Requires:   libhydrogen-core%{soversion} = %{version}-%{release}
 
 %description -n libhydrogen-core-devel
@@ -123,6 +146,8 @@
 %patch0
 %patch1
 %patch2
+%patch3
+
 # copy licence with correct fsf address
 install -m 0644 %{S:3} ./
 

++ hydrogen-gcc47.patch ++
Index: src/gui/src/SongEditor/SongEditor.cpp
===
--- src/gui/src/SongEditor/SongEditor.cpp.orig  2011-07-13 07:20:49.0 
+0200
+++ src/gui/src/SongEditor/SongEditor.cpp   2012-03-17 21:26:39.717208076 
+0100
@@ -21,6 +21,7 @@
  */
 
 #include assert.h
+#include unistd.h
 #include algorithm
 #include memory
 
Index: src/tests/xml.cpp
===
--- src/tests/xml.cpp.orig  2011-07-22 09:34:28.0 +0200
+++ src/tests/xml.cpp   2012-03-17 21:25:11.436012069 

commit installation-images for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package installation-images for 
openSUSE:Factory checked in at 2012-03-20 11:27:54

Comparing /work/SRC/openSUSE:Factory/installation-images (Old)
 and  /work/SRC/openSUSE:Factory/.installation-images.new (New)


Package is installation-images, Maintainer is snw...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/installation-images/installation-images.changes  
2012-03-15 15:58:40.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.installation-images.new/installation-images.changes 
2012-03-20 11:27:56.0 +0100
@@ -1,0 +2,10 @@
+Fri Mar 16 13:49:12 CET 2012 - snw...@suse.de
+
+- remove libelf0
+
+---
+Fri Mar 16 11:32:42 CET 2012 - snw...@suse.de
+
+- adjust xorg lib deps
+
+---

Old:

  installation-images-13.34.tar.bz2
  new.patch

New:

  installation-images-13.36.tar.bz2



Other differences:
--
++ installation-images.spec ++
--- /var/tmp/diff_new_pack.uhvl27/_old  2012-03-20 11:27:58.0 +0100
+++ /var/tmp/diff_new_pack.uhvl27/_new  2012-03-20 11:27:58.0 +0100
@@ -91,7 +91,6 @@
 BuildRequires:  krb5-devel
 BuildRequires:  libXi6
 BuildRequires:  libcares2
-BuildRequires:  libelf0
 BuildRequires:  libexpat1
 BuildRequires:  libfuse2
 BuildRequires:  libidn
@@ -335,10 +334,9 @@
 Summary:Installation Image Files
 License:GPL-2.0+
 Group:  Metapackages
-Version:13.34
+Version:13.36
 Release:0
-Source: installation-images-13.34.tar.bz2
-Patch0: new.patch
+Source: installation-images-13.36.tar.bz2
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %define _binary_payload w.ufdio
 
@@ -401,7 +399,6 @@
 
 %prep
 %setup
-%patch0 -p1
 rm -f /usr/lib/build/checks/04-check-filelist
 
 %build

++ installation-images-13.34.tar.bz2 - installation-images-13.36.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/installation-images-13.34/VERSION 
new/installation-images-13.36/VERSION
--- old/installation-images-13.34/VERSION   2012-03-15 13:53:59.0 
+0100
+++ new/installation-images-13.36/VERSION   2012-03-16 13:49:06.0 
+0100
@@ -1 +1 @@
-13.34
+13.36
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/installation-images-13.34/bin/mk_image 
new/installation-images-13.36/bin/mk_image
--- old/installation-images-13.34/bin/mk_image  2012-03-14 13:56:59.0 
+0100
+++ new/installation-images-13.36/bin/mk_image  2012-03-16 13:32:02.0 
+0100
@@ -179,6 +179,7 @@
 if($x =~ /^\//) {
   next if $x =~ m#^/lbin/#;
   next if $x =~ m#^/proc/#;
+  next if $x =~ m#^/dev/#;
 
   next if -e $dir$x;
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/installation-images-13.34/changelog 
new/installation-images-13.36/changelog
--- old/installation-images-13.34/changelog 2012-03-15 13:54:03.0 
+0100
+++ new/installation-images-13.36/changelog 2012-03-16 13:49:10.0 
+0100
@@ -1,4 +1,10 @@
-2012-03-15:HEAD
+2012-03-16:HEAD
+   - use all of systemd
+
+2012-03-16:13.35
+   - adjust xorg lib deps
+
+2012-03-15:13.34
- make vbox package optional
- add yast.ssh link (bnc #745340)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/installation-images-13.34/data/root/root.file_list 
new/installation-images-13.36/data/root/root.file_list
--- old/installation-images-13.34/data/root/root.file_list  2012-03-15 
13:53:04.0 +0100
+++ new/installation-images-13.36/data/root/root.file_list  2012-03-16 
13:38:02.0 +0100
@@ -41,12 +41,11 @@
 #
 # - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
 
-# FIXME: for ltrace
-libelf0:
+libkmod*:
   /
 
 systemd:
-  /usr/lib
+  /
 
 libdb-*:
   /
@@ -1316,11 +1315,11 @@
 libgmodule-2_0-*:
   /
 
-libxcb-render*:
-  /
+#libxcb-render*:
+#  /
 
-libxcb-shape*:
-  /
+#libxcb-shape*:
+#  /
 
 libltdl*:
   /

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kde4-l10n for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package kde4-l10n for openSUSE:Factory 
checked in at 2012-03-20 11:28:07

Comparing /work/SRC/openSUSE:Factory/kde4-l10n (Old)
 and  /work/SRC/openSUSE:Factory/.kde4-l10n.new (New)


Package is kde4-l10n, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/kde4-l10n/kde4-l10n.changes  2012-01-27 
15:19:00.0 +0100
+++ /work/SRC/openSUSE:Factory/.kde4-l10n.new/kde4-l10n.changes 2012-03-20 
11:28:45.0 +0100
@@ -1,0 +2,6 @@
+Wed Mar  7 10:18:48 UTC 2012 - idon...@suse.com
+
+- update to 4.8.1
+  * see http://kde.org/announcements/changelogs/changelog4_8_0to4_8_1.php for 
details 
+
+---

Old:

  kde-l10n-ar-4.8.0.tar.bz2
  kde-l10n-bg-4.8.0.tar.bz2
  kde-l10n-bs-4.8.0.tar.bz2
  kde-l10n-ca-4.8.0.tar.bz2
  kde-l10n...@valencia-4.8.0.tar.bz2
  kde-l10n-cs-4.8.0.tar.bz2
  kde-l10n-da-4.8.0.tar.bz2
  kde-l10n-de-4.8.0.tar.bz2
  kde-l10n-el-4.8.0.tar.bz2
  kde-l10n-en_GB-4.8.0.tar.bz2
  kde-l10n-es-4.8.0.tar.bz2
  kde-l10n-et-4.8.0.tar.bz2
  kde-l10n-eu-4.8.0.tar.bz2
  kde-l10n-fa-4.8.0.tar.bz2
  kde-l10n-fi-4.8.0.tar.bz2
  kde-l10n-fr-4.8.0.tar.bz2
  kde-l10n-ga-4.8.0.tar.bz2
  kde-l10n-gl-4.8.0.tar.bz2
  kde-l10n-hr-4.8.0.tar.bz2
  kde-l10n-hu-4.8.0.tar.bz2
  kde-l10n-ia-4.8.0.tar.bz2
  kde-l10n-is-4.8.0.tar.bz2
  kde-l10n-it-4.8.0.tar.bz2
  kde-l10n-ja-4.8.0.tar.bz2
  kde-l10n-kk-4.8.0.tar.bz2
  kde-l10n-km-4.8.0.tar.bz2
  kde-l10n-ko-4.8.0.tar.bz2
  kde-l10n-lt-4.8.0.tar.bz2
  kde-l10n-lv-4.8.0.tar.bz2
  kde-l10n-nb-4.8.0.tar.bz2
  kde-l10n-nds-4.8.0.tar.bz2
  kde-l10n-nl-4.8.0.tar.bz2
  kde-l10n-nn-4.8.0.tar.bz2
  kde-l10n-pa-4.8.0.tar.bz2
  kde-l10n-pl-4.8.0.tar.bz2
  kde-l10n-pt-4.8.0.tar.bz2
  kde-l10n-pt_BR-4.8.0.tar.bz2
  kde-l10n-ro-4.8.0.tar.bz2
  kde-l10n-ru-4.8.0.tar.bz2
  kde-l10n-si-4.8.0.tar.bz2
  kde-l10n-sk-4.8.0.tar.bz2
  kde-l10n-sl-4.8.0.tar.bz2
  kde-l10n-sr-4.8.0.tar.bz2
  kde-l10n-sv-4.8.0.tar.bz2
  kde-l10n-tg-4.8.0.tar.bz2
  kde-l10n-th-4.8.0.tar.bz2
  kde-l10n-tr-4.8.0.tar.bz2
  kde-l10n-uk-4.8.0.tar.bz2
  kde-l10n-vi-4.8.0.tar.bz2
  kde-l10n-wa-4.8.0.tar.bz2
  kde-l10n-zh_CN-4.8.0.tar.bz2
  kde-l10n-zh_TW-4.8.0.tar.bz2

New:

  kde-l10n-ar-4.8.1.tar.bz2
  kde-l10n-bg-4.8.1.tar.bz2
  kde-l10n-bs-4.8.1.tar.bz2
  kde-l10n-ca-4.8.1.tar.bz2
  kde-l10n...@valencia-4.8.1.tar.bz2
  kde-l10n-cs-4.8.1.tar.bz2
  kde-l10n-da-4.8.1.tar.bz2
  kde-l10n-de-4.8.1.tar.bz2
  kde-l10n-el-4.8.1.tar.bz2
  kde-l10n-en_GB-4.8.1.tar.bz2
  kde-l10n-es-4.8.1.tar.bz2
  kde-l10n-et-4.8.1.tar.bz2
  kde-l10n-eu-4.8.1.tar.bz2
  kde-l10n-fa-4.8.1.tar.bz2
  kde-l10n-fi-4.8.1.tar.bz2
  kde-l10n-fr-4.8.1.tar.bz2
  kde-l10n-ga-4.8.1.tar.bz2
  kde-l10n-gl-4.8.1.tar.bz2
  kde-l10n-he-4.8.1.tar.bz2
  kde-l10n-hr-4.8.1.tar.bz2
  kde-l10n-hu-4.8.1.tar.bz2
  kde-l10n-ia-4.8.1.tar.bz2
  kde-l10n-id-4.8.1.tar.bz2
  kde-l10n-is-4.8.1.tar.bz2
  kde-l10n-it-4.8.1.tar.bz2
  kde-l10n-ja-4.8.1.tar.bz2
  kde-l10n-kk-4.8.1.tar.bz2
  kde-l10n-km-4.8.1.tar.bz2
  kde-l10n-ko-4.8.1.tar.bz2
  kde-l10n-lt-4.8.1.tar.bz2
  kde-l10n-lv-4.8.1.tar.bz2
  kde-l10n-nb-4.8.1.tar.bz2
  kde-l10n-nds-4.8.1.tar.bz2
  kde-l10n-nl-4.8.1.tar.bz2
  kde-l10n-nn-4.8.1.tar.bz2
  kde-l10n-pa-4.8.1.tar.bz2
  kde-l10n-pl-4.8.1.tar.bz2
  kde-l10n-pt-4.8.1.tar.bz2
  kde-l10n-pt_BR-4.8.1.tar.bz2
  kde-l10n-ro-4.8.1.tar.bz2
  kde-l10n-ru-4.8.1.tar.bz2
  kde-l10n-si-4.8.1.tar.bz2
  kde-l10n-sk-4.8.1.tar.bz2
  kde-l10n-sl-4.8.1.tar.bz2
  kde-l10n-sr-4.8.1.tar.bz2
  kde-l10n-sv-4.8.1.tar.bz2
  kde-l10n-tg-4.8.1.tar.bz2
  kde-l10n-th-4.8.1.tar.bz2
  kde-l10n-tr-4.8.1.tar.bz2
  kde-l10n-ug-4.8.1.tar.bz2
  kde-l10n-uk-4.8.1.tar.bz2
  kde-l10n-vi-4.8.1.tar.bz2
  kde-l10n-wa-4.8.1.tar.bz2
  kde-l10n-zh_CN-4.8.1.tar.bz2
  kde-l10n-zh_TW-4.8.1.tar.bz2



Other differences:
--
++ kde4-l10n.spec ++
 678 lines (skipped)
 between /work/SRC/openSUSE:Factory/kde4-l10n/kde4-l10n.spec
 and /work/SRC/openSUSE:Factory/.kde4-l10n.new/kde4-l10n.spec

++ kde-l10n-ar-4.8.0.tar.bz2 - kde-l10n-ar-4.8.1.tar.bz2 ++
 175505 lines of diff (skipped)

++ kde-l10n-bg-4.8.0.tar.bz2 - kde-l10n-bg-4.8.1.tar.bz2 ++
 147749 lines of diff (skipped)

++ kde-l10n-bs-4.8.0.tar.bz2 - kde-l10n-bs-4.8.1.tar.bz2 ++
 156812 lines of diff (skipped)

++ kde-l10n-ca-4.8.0.tar.bz2 - kde-l10n-ca-4.8.1.tar.bz2 ++
/work/SRC/openSUSE:Factory/kde4-l10n/kde-l10n-ca-4.8.0.tar.bz2 
/work/SRC/openSUSE:Factory/.kde4-l10n.new/kde-l10n-ca-4.8.1.tar.bz2 differ: 
char 11, line 1

++ kde-l10n...@valencia-4.8.0.tar.bz2 - kde-l10n...@valencia-4.8.1.tar.bz2 
++
 149766 lines of diff (skipped)

++ kde-l10n-cs-4.8.0.tar.bz2 - kde-l10n-cs-4.8.1.tar.bz2 

commit libcryptopp for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package libcryptopp for openSUSE:Factory 
checked in at 2012-03-20 11:28:35

Comparing /work/SRC/openSUSE:Factory/libcryptopp (Old)
 and  /work/SRC/openSUSE:Factory/.libcryptopp.new (New)


Package is libcryptopp, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libcryptopp/libcryptopp.changes  2012-02-07 
14:46:05.0 +0100
+++ /work/SRC/openSUSE:Factory/.libcryptopp.new/libcryptopp.changes 
2012-03-20 11:30:08.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar 17 14:25:26 UTC 2012 - dims...@opensuse.org
+
+- Add libcryptopp-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  libcryptopp-gcc47.patch



Other differences:
--
++ libcryptopp.spec ++
--- /var/tmp/diff_new_pack.pwWSFX/_old  2012-03-20 11:30:10.0 +0100
+++ /var/tmp/diff_new_pack.pwWSFX/_new  2012-03-20 11:30:10.0 +0100
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   libcryptopp
 Version:5.6.1
 Release:0
@@ -30,6 +31,7 @@
 Source: cryptopp%{pkg_version}.tar.bz2
 Source2:cryptopp.pc
 Patch1: libcryptopp-shared.patch
+Patch2: libcryptopp-gcc47.patch
 BuildRequires:  gcc-c++
 BuildRequires:  libstdc++-devel
 BuildRequires:  pkg-config
@@ -56,6 +58,7 @@
 %prep
 %setup -q -c %{name}-%{version}
 %patch1
+%patch2 -p1
 
 %build
 make %{?_smp_mflags} \

++ libcryptopp-gcc47.patch ++
Index: libcryptopp-5.6.1/eccrypto.h
===
--- libcryptopp-5.6.1.orig/eccrypto.h
+++ libcryptopp-5.6.1/eccrypto.h
@@ -43,7 +43,7 @@ public:
void Initialize(const EllipticCurve ec, const Point G, const Integer 
n, const Integer k = Integer::Zero())
{
this-m_groupPrecomputation.SetCurve(ec);
-   SetSubgroupGenerator(G);
+   this-SetSubgroupGenerator(G);
m_n = n;
m_k = k;
}
@@ -145,9 +145,9 @@ public:
typedef typename EC::Point Element;
 
void Initialize(const DL_GroupParameters_ECEC params, const Element 
Q)
-   {this-AccessGroupParameters() = params; SetPublicElement(Q);}
+   {this-AccessGroupParameters() = params; 
this-SetPublicElement(Q);}
void Initialize(const EC ec, const Element G, const Integer n, const 
Element Q)
-   {this-AccessGroupParameters().Initialize(ec, G, n); 
SetPublicElement(Q);}
+   {this-AccessGroupParameters().Initialize(ec, G, n); 
this-SetPublicElement(Q);}
 
// X509PublicKey
void BERDecodePublicKey(BufferedTransformation bt, bool 
parametersPresent, size_t size);
@@ -166,9 +166,9 @@ public:
void Initialize(const EC ec, const Element G, const Integer n, const 
Integer x)
{this-AccessGroupParameters().Initialize(ec, G, n); 
this-SetPrivateExponent(x);}
void Initialize(RandomNumberGenerator rng, const 
DL_GroupParameters_ECEC params)
-   {GenerateRandom(rng, params);}
+   {this-GenerateRandom(rng, params);}
void Initialize(RandomNumberGenerator rng, const EC ec, const Element 
G, const Integer n)
-   {GenerateRandom(rng, DL_GroupParameters_ECEC(ec, G, n));}
+   {this-GenerateRandom(rng, DL_GroupParameters_ECEC(ec, G, 
n));}
 
// PKCS8PrivateKey
void BERDecodePrivateKey(BufferedTransformation bt, bool 
parametersPresent, size_t size);
Index: libcryptopp-5.6.1/secblock.h
===
--- libcryptopp-5.6.1.orig/secblock.h
+++ libcryptopp-5.6.1/secblock.h
@@ -88,7 +88,7 @@ public:
 
pointer allocate(size_type n, const void * = NULL)
{
-   CheckSize(n);
+   this-CheckSize(n);
if (n == 0)
return NULL;
 
Index: libcryptopp-5.6.1/eccrypto.cpp
===
--- libcryptopp-5.6.1.orig/eccrypto.cpp
+++ libcryptopp-5.6.1/eccrypto.cpp
@@ -435,7 +435,7 @@ template class EC void DL_GroupParamet
StringSource ssG(param.g, true, new HexDecoder);
Element G;
bool result = GetCurve().DecodePoint(G, ssG, 
(size_t)ssG.MaxRetrievable());
-   SetSubgroupGenerator(G);
+   this-SetSubgroupGenerator(G);
assert(result);
 
StringSource ssN(param.n, true, new HexDecoder);
@@ -591,7 +591,7 @@ bool DL_GroupParameters_ECEC::Validate
if (level = 2  pass)
{
const Integer q = GetSubgroupOrder();
-   Element gq = gpc ? 
gpc-Exponentiate(this-GetGroupPrecomputation(), 

commit kiwi for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package kiwi for openSUSE:Factory checked in 
at 2012-03-20 11:28:29

Comparing /work/SRC/openSUSE:Factory/kiwi (Old)
 and  /work/SRC/openSUSE:Factory/.kiwi.new (New)


Package is kiwi, Maintainer is m...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/kiwi/kiwi.changes2012-03-09 
21:22:21.0 +0100
+++ /work/SRC/openSUSE:Factory/.kiwi.new/kiwi.changes   2012-03-20 
11:30:01.0 +0100
@@ -1,0 +2,66 @@
+Fri Mar 16 14:27:06 CET 2012 - m...@suse.de
+
+- v5.02.19 released
+  
+---
+Fri Mar 16 13:59:52 CET 2012 - m...@suse.de
+  
+- fixed order of files in an ova tar archive per spec
+  in http://www.vmware.com/pdf/ovf_spec_draft.pdf (bnc #752581)
+  
+---
+Fri Mar 16 13:55:01 CET 2012 - m...@suse.de
+  
+- fixed malformed ovf file. the Envelope properties
+  xmlns:rasd and xmlns:vssd are split in two lines with
+  an extra quote () (bnc #752580)
+  
+---
+Thu Mar 15 15:23:15 CET 2012 - m...@suse.de
+  
+- make split building more robust. the read-only partition size
+  will be a bit bigger than the actual read-only filesystem image
+  to be sure it fits into the partition. Due to the alignment this
+  was required and costs a few bytes
+  
+---
+Thu Mar 15 11:02:28 CET 2012 - m...@suse.de
+  
+- make sure kernelCheck() initializes list of kernels if empty (bnc #752259)
+  
+---
+Wed Mar 14 11:17:59 CET 2012 - m...@suse.de
+  
+- don't remove libbz2 from isoboot boot images for SLE11
+  
+---
+Wed Mar 14 10:30:27 CET 2012 - m...@suse.de
+  
+- fixed removePackages() function
+  * make sure rpmLibs() is called prior to rpm. if all packages
+are installed by bootstrap only this is required
+  * make sure to check for empty $final variable
+
+---
+Wed Mar 14 09:54:57 CET 2012 - m...@suse.de
+
+- added ovf format example to examples/suse-12.1/suse-vm-guest
+  
+---
+Wed Mar 14 09:40:39 CET 2012 - m...@suse.de
+  
+- better warning message about required machine section data
+  
+---
+Tue Mar 13 09:02:57 CET 2012 - rjsch...@suse.de
+  
+- run the unit tests in verbose mode during package build
+  
+---
+Mon Mar 12 15:41:40 CET 2012 - rjsch...@suse.de
+  
+- fix Validator test
+  Revert f551128061 and d76e57194c, comparison in question checks for
+  equality of objects, thus numerical comparison is appropriate
+  
+---



Other differences:
--
++ kiwi.spec ++
--- /var/tmp/diff_new_pack.ViDHyI/_old  2012-03-20 11:30:06.0 +0100
+++ /var/tmp/diff_new_pack.ViDHyI/_new  2012-03-20 11:30:06.0 +0100
@@ -22,7 +22,7 @@
 Summary:OpenSuSE - KIWI Image System
 License:GPL-2.0
 Group:  System/Management
-Version:5.02.18
+Version:5.02.19
 Release:0
 # requirements to build packages
 BuildRequires:  gcc-c++
@@ -363,11 +363,11 @@
 %build
 # empty because of rpmlint warning rpm-buildroot-usage
 
-#%if %{suse_version}  1140
-#
-#%check
-#make test
-#%endif
+%if %{suse_version}  1140
+
+%check
+make KIWIVERBTEST=1 test
+%endif
 
 %install
 # build

++ kiwi-docu.tar.bz2 ++
/work/SRC/openSUSE:Factory/kiwi/kiwi-docu.tar.bz2 
/work/SRC/openSUSE:Factory/.kiwi.new/kiwi-docu.tar.bz2 differ: char 11, line 1

++ kiwi-repo.tar.bz2 ++

++ kiwi.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kiwi/.revision new/kiwi/.revision
--- old/kiwi/.revision  2012-03-09 14:57:02.0 +0100
+++ new/kiwi/.revision  2012-03-16 14:27:44.0 +0100
@@ -1 +1 @@
-0ed9c17c2b116ea83c6e790467e755f06f2a100c
+c96be4b3076b74e1d47b902aced3d44aec271672
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kiwi/Makefile new/kiwi/Makefile
--- old/kiwi/Makefile   2012-03-09 14:57:02.0 +0100
+++ new/kiwi/Makefile   2012-03-16 14:27:43.0 +0100
@@ -43,6 +43,10 @@
 PACKDOCVZ   = ${doc_prefix}/kiwi
 MANVZ   = ${man_prefix}/man1
 
+ifdef KIWIVERBTEST
+TESTVERBOSE = --verbose
+endif
+
 all: modules/KIWISchema.rng

commit libmsn for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package libmsn for openSUSE:Factory checked 
in at 2012-03-20 11:28:41

Comparing /work/SRC/openSUSE:Factory/libmsn (Old)
 and  /work/SRC/openSUSE:Factory/.libmsn.new (New)


Package is libmsn, Maintainer is dmuel...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/libmsn/libmsn.changes2012-02-10 
17:16:51.0 +0100
+++ /work/SRC/openSUSE:Factory/.libmsn.new/libmsn.changes   2012-03-20 
11:30:11.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar 17 12:14:36 UTC 2012 - dims...@opensuse.org
+
+- Add libmsn-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  libmsn-gcc47.patch



Other differences:
--
++ libmsn.spec ++
--- /var/tmp/diff_new_pack.1AOImv/_old  2012-03-20 11:30:13.0 +0100
+++ /var/tmp/diff_new_pack.1AOImv/_new  2012-03-20 11:30:13.0 +0100
@@ -33,6 +33,7 @@
 Patch1: gcc-warnings.diff
 Patch2: literal-string-compare.diff
 Patch3: install-xmlparser.patch
+Patch4: libmsn-gcc47.patch
 Source99:   COPYING.LGPL
 %define debug_package_requires libmsn0_1 = %{version}-%{release}
 
@@ -69,6 +70,7 @@
 %patch1
 %patch2
 %patch3 -p1
+%patch4 -p1
 cp %{S:99} .
 
 %build

++ libmsn-gcc47.patch ++
Index: libmsn-4.2/msn/util.cpp
===
--- libmsn-4.2.orig/msn/util.cpp
+++ libmsn-4.2/msn/util.cpp
@@ -32,6 +32,7 @@
 #include sys/timeb.h
 #include md5.h
 #include libsiren/siren7.h
+#include unistd.h //for unlink()
 
 #ifdef _WIN32
 #define random rand
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libofx for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package libofx for openSUSE:Factory checked 
in at 2012-03-20 11:28:46

Comparing /work/SRC/openSUSE:Factory/libofx (Old)
 and  /work/SRC/openSUSE:Factory/.libofx.new (New)


Package is libofx, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/libofx/libofx.changes2012-01-12 
15:30:55.0 +0100
+++ /work/SRC/openSUSE:Factory/.libofx.new/libofx.changes   2012-03-20 
11:30:13.0 +0100
@@ -1,0 +2,5 @@
+Wed Mar 14 20:51:33 UTC 2012 - dims...@opensuse.org
+
+- Add libofx-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  libofx-gcc47.patch



Other differences:
--
++ libofx.spec ++
--- /var/tmp/diff_new_pack.aonR7b/_old  2012-03-20 11:30:15.0 +0100
+++ /var/tmp/diff_new_pack.aonR7b/_new  2012-03-20 11:30:15.0 +0100
@@ -24,6 +24,7 @@
 Group:  Development/Libraries/Other
 Url:http://libofx.sourceforge.net/
 Source: 
http://downloads.sourceforge.net/project/libofx/libofx/0.9.5/%{name}-%{version}.tar.gz
+Patch0: libofx-gcc47.patch
 BuildRequires:  curl-devel
 BuildRequires:  doxygen
 BuildRequires:  fdupes
@@ -77,6 +78,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 chmod -x doc/ofx_sample_files/ofx_spec160_stmtrs_example.sgml
 
 %build

++ libofx-gcc47.patch ++
Index: libofx-0.9.5/ofxconnect/ofxpartner.cpp
===
--- libofx-0.9.5.orig/ofxconnect/ofxpartner.cpp
+++ libofx-0.9.5/ofxconnect/ofxpartner.cpp
@@ -37,6 +37,7 @@
 #include vector
 #include algorithm
 #include string.h
+#include unistd.h
 
 using std::string;
 using std::vector;
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libqtweetlib for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package libqtweetlib for openSUSE:Factory 
checked in at 2012-03-20 11:28:52

Comparing /work/SRC/openSUSE:Factory/libqtweetlib (Old)
 and  /work/SRC/openSUSE:Factory/.libqtweetlib.new (New)


Package is libqtweetlib, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libqtweetlib/libqtweetlib.changes
2012-02-24 06:53:06.0 +0100
+++ /work/SRC/openSUSE:Factory/.libqtweetlib.new/libqtweetlib.changes   
2012-03-20 11:30:15.0 +0100
@@ -1,0 +2,6 @@
+Sat Mar 17 17:37:01 UTC 2012 - d...@dominik-schmidt.de
+
+- Version bump to 0.5
+  * Fix leading zeros in OAuth pins being cut off
+
+---

Old:

  QTweetLib-0.4.tar.gz

New:

  QTweetLib-0.5.tar.gz



Other differences:
--
++ libqtweetlib.spec ++
--- /var/tmp/diff_new_pack.ROjITD/_old  2012-03-20 11:30:16.0 +0100
+++ /var/tmp/diff_new_pack.ROjITD/_new  2012-03-20 11:30:16.0 +0100
@@ -17,10 +17,10 @@
 
 
 %define _libname libQTweetLib
-%define soname 0
+%define soname 1_0
 
 Name:   libqtweetlib
-Version:0.4
+Version:0.5
 Release:0
 Source0:QTweetLib-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ QTweetLib-0.4.tar.gz - QTweetLib-0.5.tar.gz ++
 45264 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libunicap for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package libunicap for openSUSE:Factory 
checked in at 2012-03-20 11:28:57

Comparing /work/SRC/openSUSE:Factory/libunicap (Old)
 and  /work/SRC/openSUSE:Factory/.libunicap.new (New)


Package is libunicap, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libunicap/libunicap.changes  2011-10-18 
14:31:13.0 +0200
+++ /work/SRC/openSUSE:Factory/.libunicap.new/libunicap.changes 2012-03-20 
11:30:16.0 +0100
@@ -1,0 +2,5 @@
+Fri Mar 16 20:30:33 CET 2012 - sbra...@suse.cz
+
+- Port rules to the new udev (bnc#726471).
+
+---

New:

  libunicap-udev.patch



Other differences:
--
++ libunicap.spec ++
--- /var/tmp/diff_new_pack.y8SBDf/_old  2012-03-20 11:30:18.0 +0100
+++ /var/tmp/diff_new_pack.y8SBDf/_new  2012-03-20 11:30:18.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libunicap
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define _use_internal_dependency_generator 0
 %{expand:%%define prev__find_provides %{__find_provides}}
 %define __find_provides sh %{SOURCE1} %{prev__find_provides}
@@ -35,6 +36,8 @@
 Patch1: libunicap-0.9.12-find_videodev.patch
 # PATCH-FIX-UPSTREAM uses the reserved keyword private 
https://bugs.launchpad.net/unicap/+bug/656229
 Patch2: libunicap_0912_fixPrivate.patch
+# PATCH-FIX-UPSTREAM libunicap-udev.patch bnc726471 
https://bugs.launchpad.net/unicap/+bug/959626 sbra...@suse.cz -- port rules to 
the new udev
+Patch3: libunicap-udev.patch
 BuildRequires:  alsa-lib-devel
 BuildRequires:  gettext
 BuildRequires:  gtk-doc = 1.4
@@ -96,6 +99,7 @@
 %patch1
 %endif
 %patch2 -p 1
+%patch3 -p 1
 
 %build
 %configure --disable-rpath --enable-gtk-doc --enable-libv4l
@@ -109,6 +113,7 @@
 %find_lang unicap
 
 %post   -n libunicap2 -p /sbin/ldconfig
+
 %postun -n libunicap2 -p /sbin/ldconfig
 
 %files -n libunicap2 -f unicap.lang

++ libunicap-udev.patch ++
Index: libunicap-0.9.12/data/50-euvccam.rules
===
--- libunicap-0.9.12.orig/data/50-euvccam.rules
+++ libunicap-0.9.12/data/50-euvccam.rules
@@ -1,8 +1,13 @@
-SYSFS{idVendor}==199e, SYSFS{idProduct}==8201, GROUP=video, MODE=0660
-SYSFS{idVendor}==199e, SYSFS{idProduct}==8202, GROUP=video, MODE=0660
-SYSFS{idVendor}==199e, SYSFS{idProduct}==8203, GROUP=video, MODE=0660
-SYSFS{idVendor}==199e, SYSFS{idProduct}==8204, GROUP=video, MODE=0660
-SYSFS{idVendor}==199e, SYSFS{idProduct}==8205, GROUP=video, MODE=0660
-SYSFS{idVendor}==199e, SYSFS{idProduct}==8206, GROUP=video, MODE=0660
-SYSFS{idVendor}==199e, SYSFS{idProduct}==8207, GROUP=video, MODE=0660
+ACTION!=add, GOTO=euvccam_rules_end
+SUBSYSTEM!=usb, GOTO=euvccam_rules_end
+ENV{DEVTYPE}!=usb_device, GOTO=euvccam_rules_end
 
+ATTRS{idVendor}==199e, ATTRS{idProduct}==8201, GROUP=video, MODE=0660
+ATTRS{idVendor}==199e, ATTRS{idProduct}==8202, GROUP=video, MODE=0660
+ATTRS{idVendor}==199e, ATTRS{idProduct}==8203, GROUP=video, MODE=0660
+ATTRS{idVendor}==199e, ATTRS{idProduct}==8204, GROUP=video, MODE=0660
+ATTRS{idVendor}==199e, ATTRS{idProduct}==8205, GROUP=video, MODE=0660
+ATTRS{idVendor}==199e, ATTRS{idProduct}==8206, GROUP=video, MODE=0660
+ATTRS{idVendor}==199e, ATTRS{idProduct}==8207, GROUP=video, MODE=0660
+
+LABEL=euvccam_rules_end
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit lsyncd for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package lsyncd for openSUSE:Factory checked 
in at 2012-03-20 11:29:12

Comparing /work/SRC/openSUSE:Factory/lsyncd (Old)
 and  /work/SRC/openSUSE:Factory/.lsyncd.new (New)


Package is lsyncd, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/lsyncd/lsyncd.changes2011-09-23 
02:12:11.0 +0200
+++ /work/SRC/openSUSE:Factory/.lsyncd.new/lsyncd.changes   2012-03-20 
11:30:26.0 +0100
@@ -1,0 +2,34 @@
+Sun Feb 26 16:02:41 CET 2012 - dmuel...@suse.de
+
+- fix build in factory (build against lua 5.1) 
+
+---
+Mon Nov 28 09:58:02 UTC 2011 - eugene.isto...@edss.ee
+- update to 2.0.5
+  * fix: Lsyncd will now terminate if it inotify watching exceeds 
+its preset limit.
+  * fix: rsync error exit code 12 now results in retries.
+  * fix: Lsyncd 2.0.5 should now compile better on a bit elder 
+GNU/Linux versions.
+  * fix: examples are now installed in the configured document directory.
+  * fix: partial transfers during startup are considered ok. Lsyncd 
+will rework the specified files anyway.
+  * change: Layer 1 interface init() now receives an Init event 
+instead of an inlet.
+  * change: builtin Lua code is now loaded via a c-array.Now more 
+portable and correct memory flags are set.
+  * change: Lsyncd will now bail on unknown error codes.
+  * enhancement: settings.maxProcesses can now be set as a global limit of 
childprocesses
+  * enhancement: Lsyncd will refuse to start when any startup rsync 
+does not work cleanly and returns again unless settings.insist or
+--insist is specified, then Lsyncd will keep retrying until it works.
+  * enhancement: option rsyncBinary determines which rsync Lsyncd calls.
+Default is /usr/bin/rsync
+  * enhancement: fsevents (inotify for OSX) fixed for Snowleopard.
+and is available to configure by default.
+  * enhancement: settings.inotifyMode: the actualy Modification event
+Lsyncd reacts to can now be configured. Default is to react on
+file closing in write mode.
+  * enhancement: readdir(path) is available to userscripts, reads the contents
+of a directory.
+---

Old:

  lsyncd-2.0.4.tar.bz2

New:

  lsyncd-2.0.5.tar.gz
  lsyncd-init.d
  lsyncd.conf
  rsync_sudo.sh



Other differences:
--
++ lsyncd.spec ++
--- /var/tmp/diff_new_pack.d0tY44/_old  2012-03-20 11:30:28.0 +0100
+++ /var/tmp/diff_new_pack.d0tY44/_new  2012-03-20 11:30:28.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package lsyncd
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,26 +15,29 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   lsyncd
-Version:2.0.4
-Release:1
-License:GPL-2.0
-Group:  Productivity/Networking/Other
+Version:2.0.5
+Release:0
 Url:http://code.google.com/p/lsyncd/
-Source0:%{name}-%{version}.tar.bz2
+Source0:%{name}-%{version}.tar.gz
+Source1:%{name}-init.d
+Source2:%{name}.conf
+Source3:rsync_sudo.sh
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if 0%{?suse_version}
 BuildRequires:  pkg-config
 %else
 BuildRequires:  pkgconfig
 %endif
-#BuildRequires:  pkgconfig(lua) = 5.1
+%if 0%{?suse_version}  1210
+BuildRequires:  lua51-devel
+%else
 BuildRequires:  lua-devel = 5.1
+%endif
 Requires:   rsync
 Summary:Live Syncing (Mirror) Daemon
+License:GPL-2.0
+Group:  Productivity/Networking/Other
 
 %description
 Lsyncd (Live Syncing (Mirror) Daemon) uses rsync to synchronize local 
directories with a remote machine running rsyncd. It watches multiple directory 
trees through inotify. The first step after adding the watches is to rsync all 
directories with the remote host, and then the software synchronizes single 
files by collecting the inotify events. lsyncd is a lightweight live mirror 
solution that should be easy to install and use while blending well with your 
system.
@@ -51,8 +54,11 @@
 %install
 %makeinstall
 %{__mkdir_p} %{buildroot}%{_docdir}/%{name}
-mv %{buildroot}%{_datadir}/doc/%{name}/* %{buildroot}%{_docdir}/%{name}
-rm -rf %{buildroot}%{_datadir}/doc/%{name}
+%{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
+%{__mkdir_p} %{buildroot}%{_localstatedir}/log/lsyncd
+%__install -Dm 755 %{S:1} 

commit lyx for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package lyx for openSUSE:Factory checked in 
at 2012-03-20 11:29:26

Comparing /work/SRC/openSUSE:Factory/lyx (Old)
 and  /work/SRC/openSUSE:Factory/.lyx.new (New)


Package is lyx, Maintainer is b...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/lyx/lyx.changes  2012-02-29 14:08:42.0 
+0100
+++ /work/SRC/openSUSE:Factory/.lyx.new/lyx.changes 2012-03-20 
11:30:28.0 +0100
@@ -1,0 +2,6 @@
+Mon Mar 12 14:50:22 UTC 2012 - corne...@solcon.nl
+
+- Correct the license: lyx is GPL-2.0 and later, not LGPL-2.1 and later
+- Fix some rpmlint warnings
+
+---



Other differences:
--
++ lyx.spec ++
--- /var/tmp/diff_new_pack.0bNVoc/_old  2012-03-20 11:30:31.0 +0100
+++ /var/tmp/diff_new_pack.0bNVoc/_new  2012-03-20 11:30:31.0 +0100
@@ -28,7 +28,7 @@
 Version:2.0.3
 Release:0
 Summary:WYSIWYM (What You See Is What You Mean) document processor
-License:LGPL-2.1+
+License:GPL-2.0+
 Group:  Productivity/Publishing/TeX/Frontends
 Url:http://www.lyx.org/
 Source: ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/lyx-%{version}.tar.gz
@@ -42,7 +42,8 @@
 
 Requires:   ImageMagick
 Requires:   texlive-latex
-Recommends: texlive-xetex xindy
+Recommends: texlive-xetex
+Recommends: xindy
 
 %description
 LyX is a document processor that encourages an approach to writing
@@ -79,6 +80,11 @@
 # some defaults
 install -p -m644 -D %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/lyx/lyxrc.dist
 
+# Add executable to files with shebang as advised by rpmlint
+chmod +x $RPM_BUILD_ROOT%{_datadir}/lyx/scripts/*.py
+chmod +x $RPM_BUILD_ROOT%{_datadir}/lyx/scripts/listerrors
+chmod +x $RPM_BUILD_ROOT%{_datadir}/lyx/lyx2lyx/profiling.py
+
 mkdir -p $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}
 pushd $RPM_BUILD_ROOT%{_datadir}/lyx/doc/
 for i in *


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit memtest86+ for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package memtest86+ for openSUSE:Factory 
checked in at 2012-03-20 11:29:43

Comparing /work/SRC/openSUSE:Factory/memtest86+ (Old)
 and  /work/SRC/openSUSE:Factory/.memtest86+.new (New)


Package is memtest86+, Maintainer is d...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/memtest86+/memtest86+.changes2011-09-23 
02:12:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.memtest86+.new/memtest86+.changes   
2012-03-20 11:30:32.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar 17 14:19:45 UTC 2012 - l...@samba.org
+
+- PreReq perl to avoid update-bootloader to abort while install; (bnc#730022).
+
+---



Other differences:
--
++ memtest86+.spec ++
--- /var/tmp/diff_new_pack.3dTKOX/_old  2012-03-20 11:30:34.0 +0100
+++ /var/tmp/diff_new_pack.3dTKOX/_new  2012-03-20 11:30:34.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package memtest86+
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,19 +16,17 @@
 #
 
 
-
 Name:   memtest86+
 Version:4.20
-Release:1
+Release:0
 #
-License:BSD-3-Clause
-Group:  System/Boot
 #
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  cdrkit-cdrtools-compat
 %ifarch x86_64
 BuildRequires:  glibc-devel-32bit
 %endif
+PreReq: perl
 ExclusiveArch:  %ix86 x86_64
 Provides:   lilo:/boot/memtest.bin
 Obsoletes:  memtest86 = 3.2
@@ -38,6 +36,8 @@
 Source: 
http://www.memtest.org/download/%{version}/%{name}-%{version}.tar.bz2
 Patch0: fix-destdir
 Summary:Memory Testing Image for x86 Architecture
+License:BSD-3-Clause
+Group:  System/Boot
 
 %description
 Memtest86 is an image that can be booted instead of a real OS. Once

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit mkinitrd for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package mkinitrd for openSUSE:Factory 
checked in at 2012-03-20 11:30:12

Comparing /work/SRC/openSUSE:Factory/mkinitrd (Old)
 and  /work/SRC/openSUSE:Factory/.mkinitrd.new (New)


Package is mkinitrd, Maintainer is mma...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/mkinitrd/mkinitrd.changes2012-02-24 
06:53:10.0 +0100
+++ /work/SRC/openSUSE:Factory/.mkinitrd.new/mkinitrd.changes   2012-03-20 
11:30:37.0 +0100
@@ -1,0 +2,5 @@
+Wed Mar 14 13:32:58 UTC 2012 - ru...@raaftech.nl
+
+- Copy ifcfg settings regardless of nettype value (bnc#724775).
+
+---



Other differences:
--
++ mkinitrd.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mkinitrd-2.7.0/mkinitrd.changes 
new/mkinitrd-2.7.0/mkinitrd.changes
--- old/mkinitrd-2.7.0/mkinitrd.changes 2012-02-23 16:32:27.0 +0100
+++ new/mkinitrd-2.7.0/mkinitrd.changes 2012-03-14 14:50:06.0 +0100
@@ -1,4 +1,9 @@
 ---
+Wed Mar 14 13:32:58 UTC 2012 - ru...@raaftech.nl
+
+- Copy ifcfg settings regardless of nettype value (bnc#724775).
+
+---
 Thu Feb 23 15:31:57 UTC 2012 - rjsch...@suse.com
 
 - support binaries in /usr tree.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mkinitrd-2.7.0/scripts/setup-network.sh 
new/mkinitrd-2.7.0/scripts/setup-network.sh
--- old/mkinitrd-2.7.0/scripts/setup-network.sh 2012-02-23 16:32:27.0 
+0100
+++ new/mkinitrd-2.7.0/scripts/setup-network.sh 2012-03-14 14:50:06.0 
+0100
@@ -266,9 +266,9 @@
 done
 
 # Copy ifcfg settings
+mkdir -p $tmp_mnt/etc/sysconfig
+cp -rp /etc/sysconfig/network $tmp_mnt/etc/sysconfig
 if [ $nettype = ifup ] ; then
-mkdir -p $tmp_mnt/etc/sysconfig
-cp -rp /etc/sysconfig/network $tmp_mnt/etc/sysconfig
 for i in /etc/sysconfig/network/ifcfg-*; do
interface=${i##*/ifcfg-}
if [ -d /sys/class/net/$interface/device ] ; then

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit mgdiff for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package mgdiff for openSUSE:Factory checked 
in at 2012-03-20 11:29:59

Comparing /work/SRC/openSUSE:Factory/mgdiff (Old)
 and  /work/SRC/openSUSE:Factory/.mgdiff.new (New)


Package is mgdiff, Maintainer is wer...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/mgdiff/mgdiff.changes2011-09-23 
02:13:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.mgdiff.new/mgdiff.changes   2012-03-20 
11:30:36.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar 17 10:26:06 UTC 2012 - tog...@opensuse.org
+
+- add %dir /usr/share/X11/app-defaults to fix factory build.
+
+---



Other differences:
--
++ mgdiff.spec ++
--- /var/tmp/diff_new_pack.tfrDcw/_old  2012-03-20 11:30:37.0 +0100
+++ /var/tmp/diff_new_pack.tfrDcw/_new  2012-03-20 11:30:37.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package mgdiff (Version 1.0.1)
+# spec file for package mgdiff
 #
-# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,17 +15,16 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   mgdiff
-BuildRequires:  openmotif openmotif-devel update-desktop-files
-License:MIT
-Group:  Productivity/Text/Utilities
-AutoReqProv:on
+BuildRequires:  openmotif
+BuildRequires:  openmotif-devel
+BuildRequires:  update-desktop-files
 Version:1.0.1
-Release:195
+Release:0
 Summary:Compare Files Side by Side
+License:MIT
+Group:  Productivity/Text/Utilities
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source: mgdiff-1.0.tar.bz2
 Source1:mgdiff.desktop
@@ -86,6 +85,7 @@
 /usr/share/applications/*.desktop
 %{_bindir}/*diff
 %dir %{_x11data}/mgdiff
+%dir %{_x11data}/app-defaults
 %{_x11data}/mgdiff/rmgdiff*
 %config %{_appdefdir}/Mgdiff
 %doc %{_mandir}/man1/*.1x.gz

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit obs-service-tar_scm for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package obs-service-tar_scm for 
openSUSE:Factory checked in at 2012-03-20 11:30:42

Comparing /work/SRC/openSUSE:Factory/obs-service-tar_scm (Old)
 and  /work/SRC/openSUSE:Factory/.obs-service-tar_scm.new (New)


Package is obs-service-tar_scm, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/obs-service-tar_scm/obs-service-tar_scm.changes  
2012-03-01 17:21:40.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.obs-service-tar_scm.new/obs-service-tar_scm.changes 
2012-03-20 11:30:43.0 +0100
@@ -1,0 +2,5 @@
+Mon Mar 19 13:39:28 GMT 2012 - aspi...@suse.com
+
+- Check that git pull succeeds
+
+---



Other differences:
--
++ tar_scm ++
--- /var/tmp/diff_new_pack.NB2dWO/_old  2012-03-20 11:30:45.0 +0100
+++ /var/tmp/diff_new_pack.NB2dWO/_new  2012-03-20 11:30:45.0 +0100
@@ -327,7 +327,7 @@
   if git branch | grep -q '^\* (no branch)$'; then
 echo $MYREVISION does not refer to a branch, not attempting git pull
   else
-git pull
+safe_run git pull
   fi
   ;;
 svn|bzr)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit MozillaFirefox-branding-openSUSE for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package MozillaFirefox-branding-openSUSE for 
openSUSE:Factory checked in at 2012-03-20 11:30:24

Comparing /work/SRC/openSUSE:Factory/MozillaFirefox-branding-openSUSE (Old)
 and  /work/SRC/openSUSE:Factory/.MozillaFirefox-branding-openSUSE.new (New)


Package is MozillaFirefox-branding-openSUSE, Maintainer is m...@novell.com

Changes:

--- 
/work/SRC/openSUSE:Factory/MozillaFirefox-branding-openSUSE/MozillaFirefox-branding-openSUSE.changes
2011-12-25 17:37:03.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.MozillaFirefox-branding-openSUSE.new/MozillaFirefox-branding-openSUSE.changes
   2012-03-20 11:30:39.0 +0100
@@ -1,0 +2,9 @@
+Thu Mar 15 08:18:11 UTC 2012 - w...@rosenauer.org
+
+- bumped version to 6.0
+- support firefox-esr RPM packages
+- removed MozillaFirefox build dependency and PreReq
+  * everything controlled by Supplements and Requirements from
+base package
+
+---



Other differences:
--
++ MozillaFirefox-branding-openSUSE.spec ++
--- /var/tmp/diff_new_pack.euFjY4/_old  2012-03-20 11:30:40.0 +0100
+++ /var/tmp/diff_new_pack.euFjY4/_new  2012-03-20 11:30:40.0 +0100
@@ -1,8 +1,8 @@
 #
 # spec file for package MozillaFirefox-branding-openSUSE
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
-# Copyright (c) 2008-2011 Wolfgang Rosenauer
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2008-2012 Wolfgang Rosenauer
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,11 +18,15 @@
 
 
 Name:   MozillaFirefox-branding-openSUSE
-Version:5.0
+BuildRequires:  bc
+BuildRequires:  unzip
+BuildRequires:  zip
+Version:6.0
 Release:0
 Summary:openSUSE branding of MozillaFirefox
-License:BSD-3-Clause ; GPL-v2.0+
+License:BSD-3-Clause ; GPL-2.0+
 Group:  Productivity/Networking/Web/Browsers
+Url:http://www.opensuse.org/
 Source: susefox-2008.tar.bz2
 Source1:opensuse-software.xml.in
 Source2:bookmarks.html.suse
@@ -31,23 +35,20 @@
 Source5:distribution.ini.in
 Source6:%{name}-COPYING
 Source7:all-openSUSE.js
-BuildRequires:  bc
-BuildRequires:  unzip
-BuildRequires:  zip
-PreReq: MozillaFirefox = 4.99
 Supplements:packageand(MozillaFirefox:branding-openSUSE)
+Supplements:packageand(firefox-esr:branding-openSUSE)
 Provides:   MozillaFirefox-branding = %{version}
+Provides:   firefox-esr-branding = %{version}
 Conflicts:  otherproviders(MozillaFirefox-branding)
+Conflicts:  otherproviders(firefox-esr-branding)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %define progdir %{_libdir}/firefox
 %define libgssapi libgssapi_krb5.so.2
 %define suseversion %(echo -e scale=1\\n%{suse_version}/100 | bc 2/dev/null)
 # HINT: default homepage is a property now included in susefox
-#%define gconf_confdir %{_sysconfdir}/gconf
-#%gconf_schemas_prereq
 
 %description
-This package provides openSUSE Look and Feel for MozillaFirefox.
+This package provides openSUSE Look and Feel for Firefox.
 
 %prep
 cp -a %{SOURCE6} COPYING
@@ -78,11 +79,6 @@
 install -d $RPM_BUILD_ROOT%{progdir}/searchplugins
 sed -e 's,%VERSION%,%{suseversion},g' \
   %{SOURCE1}  $RPM_BUILD_ROOT%{progdir}/searchplugins/opensuse-software.xml
-# SCHEMA file
-#mkdir -p $RPM_BUILD_ROOT%{gconf_confdir}/schemas
-#install -m 644 %{SOURCE4} \
-#   $RPM_BUILD_ROOT%{gconf_confdir}/schemas/
-#%%find_gconf_schemas
 # install the system extension
 mkdir susefox\@opensuse.org
 (cd susefox\@opensuse.org; unzip ../susefox.xpi)
@@ -93,24 +89,18 @@
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-#%pre -f %{name}.schemas_pre
-
-#%preun -f %{name}.schemas_preun
-
-#%posttrans -f %{name}.schemas_posttrans
-
-#%files -f %{name}.schemas_list
-
 %files
 %defattr(-,root,root)
 %doc COPYING.susefox
 %doc ../COPYING
+%dir %{progdir}
+%dir %{progdir}/defaults/
 %dir %{progdir}/defaults/pref
 %{progdir}/defaults/pref/all-openSUSE.js
 %{progdir}/defaults/pref/firefox-openSUSE.js
 %dir %{progdir}/defaults/profile/
 %{progdir}/defaults/profile/bookmarks.html
-%{progdir}/searchplugins/*
+%{progdir}/searchplugins/
 %{progdir}/distribution
 %{_datadir}/mozilla
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit nxtvepg for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package nxtvepg for openSUSE:Factory checked 
in at 2012-03-20 11:30:34

Comparing /work/SRC/openSUSE:Factory/nxtvepg (Old)
 and  /work/SRC/openSUSE:Factory/.nxtvepg.new (New)


Package is nxtvepg, Maintainer is mma...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/nxtvepg/nxtvepg.changes  2011-09-23 
02:14:56.0 +0200
+++ /work/SRC/openSUSE:Factory/.nxtvepg.new/nxtvepg.changes 2012-03-20 
11:30:40.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar 17 10:42:15 UTC 2012 - tog...@opensuse.org
+
+- add %dir /usr/share/X11/app-defaults to fix factory build 
+
+---



Other differences:
--
++ nxtvepg.spec ++
--- /var/tmp/diff_new_pack.y9NjRo/_old  2012-03-20 11:30:41.0 +0100
+++ /var/tmp/diff_new_pack.y9NjRo/_new  2012-03-20 11:30:41.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package nxtvepg (Version 2.8.1)
+# spec file for package nxtvepg
 #
-# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,18 +15,16 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   nxtvepg
-BuildRequires:  tk-devel xorg-x11-devel
+BuildRequires:  tk-devel
+BuildRequires:  xorg-x11-devel
 Url:http://nxtvepg.sourceforge.net/
-License:GPL-2.0+
-Group:  Hardware/TV
-AutoReqProv:on
 Version:2.8.1
-Release:1
+Release:0
 Summary:Nextview EPG Decoder and Browser
+License:GPL-2.0+
+Group:  Hardware/TV
 Source0:%{name}-%{version}.tar.bz2
 Source1:rc.nxtvepg
 Patch1: nxtvepg-Makefile.patch
@@ -88,6 +86,7 @@
 /usr/bin/nxtvepg
 /usr/share/nxtvepg
 /usr/share/man/man1/nxtvepg.1*
+%dir /usr/share/X11/app-defaults
 %{_datadir}/X11/app-defaults/Nxtvepg
 %doc CHANGES COPYRIGHT TODO README manual.html
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit OpenLP for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package OpenLP for openSUSE:Factory checked 
in at 2012-03-20 11:30:56

Comparing /work/SRC/openSUSE:Factory/OpenLP (Old)
 and  /work/SRC/openSUSE:Factory/.OpenLP.new (New)


Package is OpenLP, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/OpenLP/OpenLP.changes2012-03-12 
20:15:54.0 +0100
+++ /work/SRC/openSUSE:Factory/.OpenLP.new/OpenLP.changes   2012-03-20 
11:30:58.0 +0100
@@ -1,0 +2,6 @@
+Mon Mar 19 03:44:31 UTC 2012 - jdmul...@gmail.com
+
+- Added python-xdg as a dependency so that data files are always
+  stored in ~/.local/share/openlp
+
+---



Other differences:
--
++ OpenLP.spec ++
--- /var/tmp/diff_new_pack.e1hwT8/_old  2012-03-20 11:31:00.0 +0100
+++ /var/tmp/diff_new_pack.e1hwT8/_new  2012-03-20 11:31:00.0 +0100
@@ -47,6 +47,7 @@
 Requires:   python-pyenchant
 Requires:   python-qt4
 Requires:   python-sqlalchemy-migrate
+Requires:   python-xdg
 Recommends: libreoffice-pyuno
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires(post): shared-mime-info

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit openttd-openmsx for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package openttd-openmsx for openSUSE:Factory 
checked in at 2012-03-20 11:31:11

Comparing /work/SRC/openSUSE:Factory/openttd-openmsx (Old)
 and  /work/SRC/openSUSE:Factory/.openttd-openmsx.new (New)


Package is openttd-openmsx, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.openttd-openmsx.new/openttd-openmsx.changes 
2012-03-20 11:31:14.0 +0100
@@ -0,0 +1,51 @@
+---
+Mon Mar 19 22:01:55 UTC 2012 - s...@ammler.ch
+
+- change timidity from requires to recommends (bnc#752669) 
+
+---
+Fri Mar 16 12:12:48 UTC 2012 - s...@ammler.ch
+
+- new install location for basesets
+
+---
+Thu Mar 15 10:27:36 UTC 2012 - cfarr...@suse.com
+
+- license update: GPL-2.0
+  SPDX format
+
+---
+Sun Oct 31 17:36:59 UTC 2010 - amm...@openttdcoop.org
+
+- rename to openttd-openmsx to make it compliment to other distros
+
+---
+Tue Aug 10 15:33:56 UTC 2010 - amm...@openttdcoop.org
+
+- upstream update 0.3.1
+
+---
+Thu Jul 15 20:27:58 UTC 2010 - amm...@openttdcoop.org
+
+- upstream update 0.3.0
+  first complete set
+
+---
+Thu Apr  1 10:15:28 UTC 2010 - Marcel Gmür amm...@openttdcoop.org
+
+- upstream update 0.2.1
+
+---
+Sun Mar 14 14:25:10 UTC 2010 - Marcel Gmür amm...@openttdcoop.org
+
+- Upstream update 0.2.0
+
+---
+Sat Feb 27 13:22:16 UTC 2010 - amm...@openttdcoop.org
+
+- requires timidity  
+
+---
+Sat Feb 27 01:47:28 UTC 2010 - amm...@openttdcoop.org
+
+- initial release 0.1.0

New:

  openmsx-0.3.1-source.tar.gz
  openttd-openmsx.changes
  openttd-openmsx.spec



Other differences:
--
++ openttd-openmsx.spec ++
#
# spec file for package openttd-openmsx
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:   openttd-openmsx
Version:0.3.1
Release:1%{?dist}
Summary:An OpenTTD Music set
License:GPL-2.0
Group:  Amusements/Games/Strategy/Other

Url:http://dev.openttdcoop.org/projects/openmsx
Source0:
http://bundles.openttdcoop.org/openmsx/releases/%{version}/openmsx-%{version}-source.tar.gz
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildArch:  noarch

BuildRequires:  python
Requires:   openttd-data = 1.2
%if 0%{?suse_version} || 0%{?mdkversion}
Recommends: timidity
%endif

%description
OpenMSX is an open source replacement for the original Transport Tycoon Deluxe 
(TTD) 
music. All contributions are licensed under the GPL v2.

%prep
%setup -qn openmsx-%{version}-source

%build
make %{?_smp_mflags} _V=

%install
%define omsxdir %{_datadir}/openttd/baseset
make install INSTALL_DIR=%{buildroot}%{omsxdir} _V=
#openmsx adds a versioned dir to the install dir
%define omsxdir %{_datadir}/openttd/baseset/openmsx-%{version}

%files
%defattr(-,root,root,-)
%dir %{_datadir}/openttd
%dir %{_datadir}/openttd/baseset
%dir %{omsxdir}
%doc %{omsxdir}/changelog.txt
%doc %{omsxdir}/license.txt
%doc %{omsxdir}/readme.txt
%{omsxdir}/openmsx.obm
%{omsxdir}/*.mid

%changelog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit package-translations for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package package-translations for 
openSUSE:Factory checked in at 2012-03-20 11:31:19

Comparing /work/SRC/openSUSE:Factory/package-translations (Old)
 and  /work/SRC/openSUSE:Factory/.package-translations.new (New)


Package is package-translations, Maintainer is co...@suse.com

Changes:

--- 
/work/SRC/openSUSE:Factory/package-translations/package-translations.changes
2012-03-16 13:20:30.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.package-translations.new/package-translations.changes
   2012-03-20 11:31:20.0 +0100
@@ -2 +2 @@
-Wed Mar 14 16:13:31 CET 2012 - co...@suse.com
+Fri Mar 16 16:13:30 CET 2012 - co...@suse.com
@@ -4 +4 @@
-- automated update on 2012-03-14
+- automated update on 2012-03-16



Other differences:
--
++ package-translations.tar.bz2 ++
Files old/mo/package-translations-ru.mo and new/mo/package-translations-ru.mo 
differ

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit perl-Bootloader for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package perl-Bootloader for openSUSE:Factory 
checked in at 2012-03-20 11:31:27

Comparing /work/SRC/openSUSE:Factory/perl-Bootloader (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Bootloader.new (New)


Package is perl-Bootloader, Maintainer is snw...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/perl-Bootloader/perl-Bootloader.changes  
2012-03-06 13:40:26.0 +0100
+++ /work/SRC/openSUSE:Factory/.perl-Bootloader.new/perl-Bootloader.changes 
2012-03-20 11:31:29.0 +0100
@@ -1,0 +2,5 @@
+Fri Mar  9 08:40:15 UTC 2012 - mch...@suse.com
+
+- grub2-skip-fs-probe-for-extended-partition.patch (bnc#750897) 
+
+---

New:

  grub2-skip-fs-probe-for-extended-partition.patch



Other differences:
--
++ perl-Bootloader.spec ++
--- /var/tmp/diff_new_pack.RCtyEc/_old  2012-03-20 11:31:31.0 +0100
+++ /var/tmp/diff_new_pack.RCtyEc/_new  2012-03-20 11:31:31.0 +0100
@@ -29,6 +29,7 @@
 Source1:update-bootloader
 Source2:bootloader_entry
 Source3:boot.readme
+Patch:  grub2-skip-fs-probe-for-extended-partition.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl
 Conflicts:  multipath-tools  0.4.8-40.25.1
@@ -48,6 +49,7 @@
 
 %prep
 %setup -q
+%patch -p1
 rm -rf perl-Bootloader-testsuite
 mkdir -p lib
 mv src lib/Bootloader

++ grub2-skip-fs-probe-for-extended-partition.patch ++
Index: perl-Bootloader-0.6.0/src/Core/GRUB2.pm
===
--- perl-Bootloader-0.6.0.orig/src/Core/GRUB2.pm
+++ perl-Bootloader-0.6.0/src/Core/GRUB2.pm
@@ -655,6 +655,7 @@ Returns undef on fail, defined nonzero v
 # boolean InitializeBootloader ()
 sub InitializeBootloader {
 my $self = shift;
+my %glob = %{$self-{global}};
 my $file = Bootloader::Path::Grub2_installdevice();
 my $files_ref = $self-ReadFiles ([$file,]);
 
@@ -663,6 +664,13 @@ sub InitializeBootloader {
 return undef;
 }
 
+my $install_opts = --force;
+my $skip_fs_probe = delete $glob{boot_extended};
+
+if (defined $skip_fs_probe and $skip_fs_probe eq true) {
+$install_opts .=  --skip-fs-probe ;
+}
+
 my @devices = @{$files_ref-{$file} || []};
 
 # Hmm .. grub2-install must has been run before
@@ -679,7 +687,7 @@ sub InitializeBootloader {
 # the tradeoff is we can't capture errors
 # only patch grub2 package is possible way
 # to get around this problem
-/usr/sbin/grub2-install --force $dev,
+/usr/sbin/grub2-install $install_opts $dev,
 /var/log/YaST2/y2log_bootloader
 );
 
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit podofo for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package podofo for openSUSE:Factory checked 
in at 2012-03-20 11:31:41

Comparing /work/SRC/openSUSE:Factory/podofo (Old)
 and  /work/SRC/openSUSE:Factory/.podofo.new (New)


Package is podofo, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/podofo/podofo.changes2011-11-29 
16:24:44.0 +0100
+++ /work/SRC/openSUSE:Factory/.podofo.new/podofo.changes   2012-03-20 
11:31:42.0 +0100
@@ -1,0 +2,6 @@
+Sat Mar 17 14:11:54 UTC 2012 - dims...@opensuse.org
+
+- Change lua-devel BuildRequires to lua51-devel on openSUSE  12.1:
+  the code is not ready to work with lua 5.2.
+
+---



Other differences:
--
++ podofo.spec ++
--- /var/tmp/diff_new_pack.VOU4NA/_old  2012-03-20 11:31:43.0 +0100
+++ /var/tmp/diff_new_pack.VOU4NA/_new  2012-03-20 11:31:43.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package podofo
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,11 +20,11 @@
 
 Name:   podofo
 Version:0.9.1
-Release:1
-License:GPL-2.0+
+Release:0
 Summary:Tools to work with PDF files
-Url:http://podofo.sourceforge.net/
+License:GPL-2.0+
 Group:  Productivity/Publishing/PDF
+Url:http://podofo.sourceforge.net/
 # http://downloads.sourceforge.net/podofo/podofo-0.9.1.tar.gz
 Source0:%{name}-%{version}.tar.bz2
 # PATCH-FIX-OPENSUSE podofobox.1_fix.patch asterios.dra...@gmail.com -- Fix 
manual-page-warning rpmlint warning
@@ -36,7 +36,11 @@
 BuildRequires:  libjpeg-devel
 BuildRequires:  libpng-devel
 BuildRequires:  libtiff-devel
+%if 0%{?suse_version}  1210
+BuildRequires:  lua51-devel
+%else
 BuildRequires:  lua-devel
+%endif
 BuildRequires:  openssl-devel
 BuildRequires:  zlib-devel
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -46,16 +50,16 @@
 
 %package -n libpodofo%{libver}
 
-License:LGPL-2.1+
 Summary:PDF parsing and creation library
+License:LGPL-2.1+
 Group:  System/Libraries
 
 %description -n libpodofo%{libver}
 A cross platform PDF parsing and creation library.
 
 %package -n libpodofo-devel
-License:LGPL-2.1+
 Summary:Development files for podofo
+License:LGPL-2.1+
 Group:  Development/Libraries/Other
 Requires:   libpodofo%{libver} = %{version}
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-blinker for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-blinker for openSUSE:Factory 
checked in at 2012-03-20 11:31:52

Comparing /work/SRC/openSUSE:Factory/python-blinker (Old)
 and  /work/SRC/openSUSE:Factory/.python-blinker.new (New)


Package is python-blinker, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.python-blinker.new/python-blinker.changes   
2012-03-20 11:31:53.0 +0100
@@ -0,0 +1,5 @@
+---
+Fri Sep 23 12:39:41 UTC 2011 - sasc...@suse.de
+
+- Initial version
+

New:

  blinker-1.1.zip
  python-blinker.changes
  python-blinker.spec



Other differences:
--
++ python-blinker.spec ++
#
# spec file for package python-blinker
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:   python-blinker
Version:1.1
Release:0
Url:http://discorporate.us/projects/Blinker/
Summary:Fast, simple object-to-object and broadcast signaling
License:MIT
Group:  Development/Languages/Python
Source: 
http://pypi.python.org/packages/source/b/blinker/blinker-%{version}.zip
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  python-devel
BuildRequires:  python-nose
BuildRequires:  unzip
%if 0%{?suse_version}
%py_requires
%if 0%{?suse_version}  1110
BuildArch:  noarch
%endif
%endif
%{!?python_sitelib: %global python_sitelib %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}

%description
Blinker provides a fast dispatching system that allows any number of
interested parties to subscribe to events, or signals.

Signal receivers can subscribe to specific senders or receive signals
sent by any sender.

%prep
%setup -q -n blinker-%{version}

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}

%check
nosetests

%files
%defattr(-,root,root,-)
%doc AUTHORS CHANGES LICENSE README docs/html
%{python_sitelib}/*

%changelog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-django-static for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-django-static for 
openSUSE:Factory checked in at 2012-03-20 11:32:32

Comparing /work/SRC/openSUSE:Factory/python-django-static (Old)
 and  /work/SRC/openSUSE:Factory/.python-django-static.new (New)


Package is python-django-static, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-django-static.new/python-django-static.changes
   2012-03-20 11:32:33.0 +0100
@@ -0,0 +1,106 @@
+---
+Wed Mar 14 10:36:28 UTC 2012 - sasc...@suse.de
+
+- Simplified macro usage
+- Removed outdated %clean section
+- Package README.rst
+- Pick BSD-3-Clause as license (instead of just 'BSD')
+
+---
+Thu Oct 27 22:34:23 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 1.5.5:
+  - Sorry, no changelog atm.
+
+---
+Tue Mar 22 16:15:01 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 1.5.4.
+
+---
+Sun Mar 20 20:41:47 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 1.5.3.
+
+---
+Fri Mar 11 19:27:34 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 1.5.2;
+- Regenerated spec file with py2pack.
+
+---
+Sun Jan 16 20:38:05 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 1.5.1.
+
+---
+Tue Jan 11 01:57:57 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 1.5.0.
+
+---
+Mon Jan 10 18:40:24 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 1.4.1.
+
+---
+Wed Sep 15 02:06:53 UTC 2010 - alexan...@exatati.com.br
+
+- Update to 1.4.0;
+- Bzip2 source file.
+
+---
+Thu Aug  5 03:54:37 UTC 2010 - alexan...@exatati.com.br
+
+- Update to 1.3.9.
+
+---
+Sat Jun 12 18:34:35 UTC 2010 - alexan...@exatati.com.br
+
+- Update to 1.3.8.
+
+---
+Mon May 31 19:07:39 UTC 2010 - alexan...@exatati.com.br
+
+- Update to 1.3.7.
+
+---
+Mon May 31 11:23:10 UTC 2010 - alexan...@exatati.com.br
+
+- Update to 1.3.6.
+
+---
+Sat May  8 12:15:57 UTC 2010 - alexan...@exatati.com.br
+
+- Update to 1.3.5.
+
+---
+Fri May  7 12:18:38 UTC 2010 - alexan...@exatati.com.br
+
+- Update to 1.3.4.
+
+---
+Wed Apr 28 11:49:39 UTC 2010 - alexan...@exatati.com.br
+
+- Updatet to 1.3.3.
+
+---
+Wed Mar 31 22:17:06 UTC 2010 - alexan...@exatati.com.br
+
+- Update to 1.3.2;
+- Spec file cleaned with spec-cleaner.
+
+---
+Mon Feb  8 10:27:06 UTC 2010 - alexan...@exatati.com.br
+
+- Update to 1.3.1.
+
+---
+Mon Jan 25 16:51:23 UTC 2010 - alexan...@exatati.com.br
+
+- Update to 1.3.
+
+---
+Thu Dec 17 10:47:58 UTC 2009 - alexan...@exatati.com.br
+
+- Initial package (1.2.2) for openSUSE.

New:

  django-static-1.5.5.tar.bz2
  python-django-static.changes
  python-django-static.spec



Other differences:
--
++ python-django-static.spec ++
#
# spec file for package python-django-static
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:   python-django-static
Version: 

commit python-espeak for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-espeak for openSUSE:Factory 
checked in at 2012-03-20 11:32:44

Comparing /work/SRC/openSUSE:Factory/python-espeak (Old)
 and  /work/SRC/openSUSE:Factory/.python-espeak.new (New)


Package is python-espeak, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-espeak/python-espeak.changes  
2012-03-07 13:44:53.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-espeak.new/python-espeak.changes 
2012-03-20 11:32:46.0 +0100
@@ -1,0 +2,6 @@
+Tue Mar  6 11:52:11 UTC 2012 - cfarr...@suse.com
+
+- license update: GPL-3.0+
+  No indication of GPL-3.0 (only) files.
+
+---



Other differences:
--
++ python-espeak.spec ++
--- /var/tmp/diff_new_pack.TAwuSf/_old  2012-03-20 11:32:47.0 +0100
+++ /var/tmp/diff_new_pack.TAwuSf/_new  2012-03-20 11:32:47.0 +0100
@@ -19,7 +19,7 @@
 Name:   python-espeak
 Version:0.4
 Release:0
-License:GPL-3.0
+License:GPL-3.0+
 Summary:Python bindings for espeak
 Url:https://launchpad.net/python-espeak
 Group:  Development/Languages/Python

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-FormEncode for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-FormEncode for 
openSUSE:Factory checked in at 2012-03-20 11:32:54

Comparing /work/SRC/openSUSE:Factory/python-FormEncode (Old)
 and  /work/SRC/openSUSE:Factory/.python-FormEncode.new (New)


Package is python-FormEncode, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.python-FormEncode.new/python-FormEncode.changes 
2012-03-20 11:32:55.0 +0100
@@ -0,0 +1,209 @@
+---
+Wed Mar 14 13:44:30 UTC 2012 - sasc...@suse.de
+
+- Set license to SDPX style (Python-2.0)
+- Removed outdated %clean section
+- Simplified macro usage
+- Only package HTML documentation (not the doc sources)
+
+---
+Thu Sep  1 08:46:05 UTC 2011 - sasc...@suse.de
+
+- Add provides/obsoletes for python-formencode
+
+---
+Thu Sep  1 08:38:45 UTC 2011 - sasc...@suse.de
+
+- Renamed to python-FormEncode to match upstream name
+- Properly package documentation
+
+---
+Sun Jun  7 00:01:01 CEST 2009 - l...@linux-schulserver.de
+
+- disable runtime dependency to python-setuptools
+
+---
+Mon Apr 27 17:51:38 CEST 2009 - l...@linux-schulserver.de
+
+- update to 1.2.2
+- remove FormEncode-1.2-svn-fixes.patch
+- added rpmlintrc
+
+---
+Sun Dec 14 00:00:00 CET 2008 - jf...@funktronics.ca
+
+- Apply some fixes from SVN
+
+---
+Wed Dec 03 00:00:00 CET 2008 - jf...@funktronics.ca
+
+- Update to 1.2
+  * Added :class:`formencode.validators.IPAddress`, validating IP
+  addresses, from Leandro Lucarella.
+  * Added :meth:`formencode.api.Invalid.__unicode__`
+  * In :mod:`formencode.htmlfill` use a default encoding of utf8 when
+  handling mixed ``str``/``unicode`` content.  Also do not modify
+  ``input type=image`` tags (previously ``src`` would be
+  overwritten, for no good reason).
+  * In :class:`formencode.validators.Email` allow single-character
+  domain names (like x.com).
+  * Make :class:`formencode.validators.FieldsMatch` give a normal
+  ``Invalid`` exception if you pass it a non-dictionary.  Also treat
+  all missing keys as the empty string (previously the first key was
+  required and would raise KeyError).
+  * :class:`formencode.validators.Number` works with ``inf`` float
+  values (before it would raise a OverflowError).
+  * The ``tw`` locale has been renamed to the more standard ``zh_TW``.
+  * Added Japanese and Turkish translations.
+  * Fixed some outdated translations and errors in Spanish and Greek
+  translations. Translations now managed with `Babel
+  http://babel.edgewall.org/`_.
+- 1.1
+  * Fixed the ``is_empty()`` method in
+  :class:`formencode.validators.FieldStorageUploadConverter`;
+  previously it returned the opposite of the intended result.
+  * Added a parameter to ``htmlfill.render()``: ``prefix_error``.  If
+  this parameter is true (the default) then errors automatically go
+  before the input field; if false then they go after the input field.
+  * Remove deprecated modules: ``fields``, ``formgen``, ``htmlform``,
+  ``sqlformgen``, and ``sqlschema``.
+  * Added ``formencode.htmlrename``, which renames HTML inputs.
+  * In ``formencode.htmlfill``, non-string values are compared usefully
+  (e.g., a select box with integer values).
+  * The validators ``Int`` and ``Number`` both take min/max arguments
+  (from Shannon Behrens).
+  * Validators based on ``formencode.validators.FormValidator`` will not
+  treat ``{}`` as an empty (unvalidated) value.
+  * Some adjustments to the URL validator.
+  * :class:`formencode.compound.All` does not handle empty values,
+  instead relying on sub-validators to check for emptiness.
+  * Fixed the ``if_missing`` attribute in
+  :class:`formencode.foreach.ForEach`; previously it would be the same
+  list instance, so if you modified it then it would effect future
+  ``if_missing`` values (reported by Felix Schwarz).
+  * Added formatter to :mod:`formencode.htmlfill`, so you can use
+  ``form:error name=field_name formatter=ignore /`` -- this will
+  cause the error to be swallowed, not shown to the user.
+  * Added :class:`formencode.validators.XRI` for validation i-names,
+  i-numbers, URLs, etc (as used in OpenID).
+  * Look in ``/usr/share/locale`` for locale files, in addition to the
+  normal locations.
+  * Quiet Python 2.6 deprecation warnings.
+  * Fix :class:`formencode.validators.URL`, which was accepting illegal
+  characters 

commit python-geopy for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-geopy for openSUSE:Factory 
checked in at 2012-03-20 11:33:04

Comparing /work/SRC/openSUSE:Factory/python-geopy (Old)
 and  /work/SRC/openSUSE:Factory/.python-geopy.new (New)


Package is python-geopy, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-geopy/python-geopy.changes
2011-09-26 10:15:24.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-geopy.new/python-geopy.changes   
2012-03-20 11:33:05.0 +0100
@@ -1,0 +2,9 @@
+Tue Mar 13 01:32:09 UTC 2012 - alexan...@exatati.com.br
+
+- Update to 0.94.2:
+  ADDED:   MANIFEST.in so that LICENSE file gets included in dist
+   packages (per req by Debian Python Module Team)
+  UPDATED: Yahoo geocoder uses new PlaceFinder API instead of
+   outdated MapsService V1 API.
+
+---

Old:

  geopy-0.94.1.tar.bz2

New:

  geopy-0.94.2.tar.bz2



Other differences:
--
++ python-geopy.spec ++
--- /var/tmp/diff_new_pack.xhttrw/_old  2012-03-20 11:33:08.0 +0100
+++ /var/tmp/diff_new_pack.xhttrw/_new  2012-03-20 11:33:08.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-geopy
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,11 +15,13 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
+%{!?python_sitearch: %global python_sitearch %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib(1))}
 
 Name:   python-geopy
-Version:0.94.1
+Version:0.94.2
 Release:0
-Url:http://www.geopy.org/
+Url:http://code.google.com/p/geopy/
 Summary:Python Geocoding Toolbox
 License:MIT
 Group:  Development/Languages/Python
@@ -36,14 +38,13 @@
 BuildArch:  noarch
 %endif
 %endif
-%{!?python_sitelib: %global python_sitelib %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
 
 %description
-geopy makes it easy for developers to locate the coordinates of addresses, 
cities,
+Geopy makes it easy for developers to locate the coordinates of addresses, 
cities,
 countries, and landmarks across the globe using third-party geocoders and 
other data
 sources, such as wikis.
 
-geopy currently includes support for six geocoders: Google Maps, Yahoo! Maps, 
Windows
+Geopy currently includes support for six geocoders: Google Maps, Yahoo! Maps, 
Windows
 Local Live (Virtual Earth), geocoder.us, GeoNames, MediaWiki pages (with the 
GIS
 extension), and Semantic MediaWiki pages.
 
@@ -56,12 +57,8 @@
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
 
-# TODO: Disable only tests that need network access
-#%%check
-#python setup.py test
-
 %files
 %defattr(-,root,root,-)
-%python_sitelib/*
+%{python_sitelib}/*
 
 %changelog

++ geopy-0.94.1.tar.bz2 - geopy-0.94.2.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/geopy-0.94.1/LICENSE new/geopy-0.94.2/LICENSE
--- old/geopy-0.94.1/LICENSE1970-01-01 01:00:00.0 +0100
+++ new/geopy-0.94.2/LICENSE2012-03-12 20:27:30.0 +0100
@@ -0,0 +1,21 @@
+Copyright (c) 2006-2010 Brian Beck
+Copyright (c) 2010-2012 GeoPy Project and individual contributors.
+All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy 
of 
+this software and associated documentation files (the Software), to deal in 
+the Software without restriction, including without limitation the rights to 
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies 
+of the Software, and to permit persons to whom the Software is furnished to do 
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all 
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED AS IS, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR 
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, 
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE 
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER 
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, 
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR 

commit python-imaging for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-imaging for openSUSE:Factory 
checked in at 2012-03-20 11:33:10

Comparing /work/SRC/openSUSE:Factory/python-imaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-imaging.new (New)


Package is python-imaging, Maintainer is jmate...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/python-imaging/python-imaging.changes
2011-09-23 12:42:54.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-imaging.new/python-imaging.changes   
2012-03-20 11:33:11.0 +0100
@@ -1,0 +2,5 @@
+Wed Mar 14 14:06:38 UTC 2012 - dh...@wustl.edu
+
+- fixed jpeg support so factory passes tests
+
+---



Other differences:
--
++ python-imaging.spec ++
--- /var/tmp/diff_new_pack.IupTdi/_old  2012-03-20 11:33:12.0 +0100
+++ /var/tmp/diff_new_pack.IupTdi/_new  2012-03-20 11:33:12.0 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package python-imaging (Version 1.1.7)
+# spec file for package python-imaging
 #
-# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,6 +20,9 @@
 
 Name:   python-imaging
 BuildRequires:  freetype2-devel giflib-devel libgphoto2-devel libpng-devel 
libtiff-devel netpbm python-devel python-tk tix tk-devel xorg-x11-devel
+%if 0%{?suse_version}  1210
+BuildRequires:  libjpeg8-devel
+%endif
 %if 0%{?suse_version}  1130
 BuildRequires:  sane-backends-devel
 %else

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-interlude for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-interlude for 
openSUSE:Factory checked in at 2012-03-20 11:33:22

Comparing /work/SRC/openSUSE:Factory/python-interlude (Old)
 and  /work/SRC/openSUSE:Factory/.python-interlude.new (New)


Package is python-interlude, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.python-interlude.new/python-interlude.changes   
2012-03-20 11:33:31.0 +0100
@@ -0,0 +1,10 @@
+---
+Wed Mar 14 10:34:49 UTC 2012 - sasc...@suse.de
+
+- Use license mentioned in README.rst
+
+---
+Mon Mar 12 08:51:33 UTC 2012 - sasc...@suse.de
+
+- Initial version
+

New:

  interlude-1.1.1.tar.gz
  python-interlude.changes
  python-interlude.spec



Other differences:
--
++ python-interlude.spec ++
#
# spec file for package python-interlude
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:   python-interlude
Version:1.1.1
Release:0
Url:http://github.com/collective/interlude
Summary:Interlude for Doctests provides an Interactive Console
License:LGPL-3.0+
Group:  Development/Languages/Python
Source: 
http://pypi.python.org/packages/source/i/interlude/interlude-%{version}.tar.gz
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  python-devel
BuildRequires:  python-distribute
Recommends: IPython
%if 0%{?suse_version}  0%{?suse_version} = 1110
%{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
%else
BuildArch:  noarch
%endif

%description
Provides an interactive shell aka console inside your doctest case.

The console looks exact like in a doctest-case and you can copy and paste
code from the shell into your doctest. It feels as you are in the test case 
itself. Its not pdb, it's a python shell. 

In your doctest you can invoke the shell at any point by calling::

 interact( locals() )

To make your testrunner interlude aware following is needed:

%prep
%setup -q -n interlude-%{version}

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}

%files
%defattr(-,root,root,-)
%doc CHANGELOG.rst README.rst
%{python_sitelib}/*

%changelog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-kombu for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-kombu for openSUSE:Factory 
checked in at 2012-03-20 11:33:30

Comparing /work/SRC/openSUSE:Factory/python-kombu (Old)
 and  /work/SRC/openSUSE:Factory/.python-kombu.new (New)


Package is python-kombu, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-kombu/python-kombu.changes
2012-02-17 12:08:52.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-kombu.new/python-kombu.changes   
2012-03-20 11:33:32.0 +0100
@@ -1,0 +2,17 @@
+Sat Mar 10 17:49:39 UTC 2012 - sasc...@gmx.de
+
+- Require rabbitmq-server, suggest mongodb or couchdb
+
+---
+Sat Mar 10 17:00:40 UTC 2012 - sasc...@gmx.de
+
+- Update to version 2.1.1:
+  * Connection URLs now supports encoded characters.
+  * Fixed a case where connection pool could not recover from connection loss.
+  * We now patch amqplib's ``__del__`` method to skip trying to close the 
socket
+if it is not connected, as this resulted in an annoying warning.
+  * Compression can now be used with binary message payloads.
+- Don't install INSTALL
+- Run testsuite
+
+---
@@ -12 +28,0 @@
-

Old:

  kombu-2.1.0.tar.bz2

New:

  kombu-2.1.1.tar.gz



Other differences:
--
++ python-kombu.spec ++
--- /var/tmp/diff_new_pack.ka1ygC/_old  2012-03-20 11:33:33.0 +0100
+++ /var/tmp/diff_new_pack.ka1ygC/_new  2012-03-20 11:33:33.0 +0100
@@ -15,28 +15,32 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-%{!?python_sitelib: %global python_sitelib %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
-%{!?python_sitearch: %global python_sitearch %(%{__python} -c from 
distutils.sysconfig import get_python_lib; print get_python_lib(1))}
 
 Name:   python-kombu
-Version:2.1.0
+Version:2.1.1
 Release:0
 License:BSD-2-Clause
 Summary:AMQP Messaging Framework for Python
 Url:http://github.com/ask/kombu/
 Group:  Development/Languages/Python
-Source: kombu-%{version}.tar.bz2
+Source: kombu-%{version}.tar.gz
+BuildRequires:  python-amqplib
+BuildRequires:  python-anyjson
 BuildRequires:  python-devel
 BuildRequires:  python-distribute
+BuildRequires:  python-mock
+BuildRequires:  python-nose-cover3
 Requires:   python-amqplib
 Requires:   python-anyjson
+Requires:   rabbitmq-server
+Suggests:   couchdb
+Suggests:   mongodb
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version}
-%py_requires
-%if %{?suse_version: %{suse_version}  1110}
+%if 0%{?suse_version}  0%{?suse_version} = 1110
+%{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
+%else
 BuildArch:  noarch
 %endif
-%endif
 
 %description
 An AMQP messaging framework for Python.
@@ -59,9 +63,12 @@
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
 
+%check
+python setup.py test
+
 %files
 %defattr(-,root,root,-)
-%doc AUTHORS Changelog FAQ INSTALL README THANKS TODO
+%doc AUTHORS Changelog FAQ README THANKS TODO
 %{python_sitelib}/*
 
 %changelog

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-ldap for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-ldap for openSUSE:Factory 
checked in at 2012-03-20 11:33:34

Comparing /work/SRC/openSUSE:Factory/python-ldap (Old)
 and  /work/SRC/openSUSE:Factory/.python-ldap.new (New)


Package is python-ldap, Maintainer is jmate...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/python-ldap/python-ldap.changes  2011-10-11 
17:59:12.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-ldap.new/python-ldap.changes 
2012-03-20 11:33:36.0 +0100
@@ -1,0 +2,8 @@
+Fri Mar 16 14:34:59 UTC 2012 - sasc...@suse.de
+
+- Remove service
+- Spec file cleanup:
+  * Remove outdated sections
+  * Proper macro usage
+
+---

Old:

  python-ldap-2.4.3.tar.gz

New:

  python-ldap-2.4.9.tar.gz



Other differences:
--
++ python-ldap.spec ++
--- /var/tmp/diff_new_pack.eSYzog/_old  2012-03-20 11:33:37.0 +0100
+++ /var/tmp/diff_new_pack.eSYzog/_new  2012-03-20 11:33:37.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-ldap
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,22 +15,25 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   python-ldap
-BuildRequires:  fdupes krb5-devel openldap2-devel = 2.4.11 python-devel
-Requires:   openldap2-client = 2.4.11
+Version:2.4.9
+Release:0
+Summary:Python LDAP interface
 License:SUSE-Public-Domain
 Group:  Development/Libraries/Python
-AutoReqProv:on
-Version:2.4.3
-Release:1
-Summary:Python LDAP interface
 Url:http://www.python-ldap.org/
 Source: 
http://pypi.python.org/packages/source/p/python-ldap/python-ldap-%{version}.tar.gz
+BuildRequires:  cyrus-sasl-devel
+BuildRequires:  fdupes
+BuildRequires:  krb5-devel
+BuildRequires:  openldap2-devel = 2.4.11
+BuildRequires:  python-devel
+Requires:   libldap-2_4-2 = 2.4.11
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%{py_requires}
+%if 0%{?suse_version}  0%{?suse_version} = 1110
+%{!?python_sitearch: %global python_sitearch %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib(1))}
+%endif
 
 %description
 python-ldap provides an LDAP client API for Python in the spirit of
@@ -39,23 +42,20 @@
 python-ldap pages on http://python-ldap.sourceforge.net/
 
 %prep
-%setup
+%setup -q
 cp Build/setup.cfg.suse-linux setup.cfg
 find -name .CVS -o -name .cvsignore -exec rm -rf {} ;
 
 %build
-#export CFLAGS=$RPM_OPT_FLAGS -DLDAP_DEPRECATED
-python setup.py build
+CFLAGS=%{optflags} -DLDAP_DEPRECATED python setup.py build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT 
--record-rpm=INSTALLED_FILES
-%fdupes $RPM_BUILD_ROOT/%{_libdir}
-
-%clean
-rm -rf $RPM_BUILD_ROOT
+python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%fdupes %{buildroot}/%{_libdir}
 
-%files -f INSTALLED_FILES
+%files
 %defattr(-,root,root)
 %doc README Demo CHANGES TODO LICENCE
+%{python_sitearch}/*
 
 %changelog

++ python-ldap-2.4.3.tar.gz - python-ldap-2.4.9.tar.gz ++
 2728 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-matplotlib for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-matplotlib for 
openSUSE:Factory checked in at 2012-03-20 11:33:39

Comparing /work/SRC/openSUSE:Factory/python-matplotlib (Old)
 and  /work/SRC/openSUSE:Factory/.python-matplotlib.new (New)


Package is python-matplotlib, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-matplotlib/python-matplotlib.changes  
2012-01-19 16:57:57.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-matplotlib.new/python-matplotlib.changes 
2012-03-20 11:33:40.0 +0100
@@ -1,0 +2,7 @@
+Fri Mar 16 15:13:32 UTC 2012 - toddrme2...@gmail.com
+
+- Cleaned up spec file formatting
+- Removed tests for obsolete openSUSE versions
+- Added Qt Designer plugin from Python(x,y) project
+
+---

New:

  matplotlibplugin.py
  matplotlibwidget.py



Other differences:
--
++ python-matplotlib.spec ++
--- /var/tmp/diff_new_pack.4KM2jz/_old  2012-03-20 11:33:42.0 +0100
+++ /var/tmp/diff_new_pack.4KM2jz/_new  2012-03-20 11:33:42.0 +0100
@@ -15,16 +15,19 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-Name:   python-matplotlib
+%define modname matplotlib
+Name:   python-%{modname}
 Version:1.1.0
 Release:0
 
 Summary:Plotting Library for Python
 License:BSD-2-Clause
 Group:  Development/Libraries/Python
-Url:http://sourceforge.net/projects/matplotlib
-Source: matplotlib-%{version}.tar.bz2
-Source1:matplotlib-setup.cfg
+Url:http://sourceforge.net/projects/%{modname}
+Source: %{modname}-%{version}.tar.bz2
+Source1:%{modname}-setup.cfg
+Source2:%{modname}plugin.py
+Source3:%{modname}widget.py
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 BuildRequires:  fltk-devel
@@ -33,6 +36,7 @@
 BuildRequires:  gtk2-devel
 BuildRequires:  libpng-devel
 BuildRequires:  python-gtk
+BuildRequires:  python-gtk-devel
 BuildRequires:  python-numpy-devel = 1.2.1
 BuildRequires:  python-tk
 BuildRequires:  tcl
@@ -44,25 +48,16 @@
 Requires:   python-numpy = 1.2.1
 Requires:   python-tz
 %py_requires
-%if %suse_version  1130
-BuildRequires:  python-wxWidgets
-BuildRequires:  wxWidgets-devel
-%else
+%if 0%{?sles_version} == 11
+BuildRequires:  gnome-libs-devel
+BuildRequires:  python-qt
 BuildRequires:  python-wxGTK
 BuildRequires:  wxGTK-devel
-%endif
-BuildRequires:  python-gtk-devel
-%if 0%{?suse_version} = 1120
-BuildRequires:  python-qt4
 %else
-BuildRequires:  python-qt
-%endif
-%if 0%{?suse_version} = 1130
 BuildRequires:  libgnome-devel
-%else
-BuildRequires:  gnome-libs-devel
-%endif
-%if %suse_version  1130
+BuildRequires:  python-qt4
+BuildRequires:  python-wxWidgets
+BuildRequires:  wxWidgets-devel
 %define _use_internal_dependency_generator 0
 %define __find_requires %wx_requires
 %endif
@@ -81,26 +76,40 @@
 application servers, and six graphical user interface toolkits.
 
 %package tk
-Summary:Tk backend for python-matplotlib
+Summary:Tk backend for %{name}
 Group:  Development/Libraries/Python
 Requires:   %{name} = %{version}
 Requires:   python-tk
 
 %description tk
-Tk backend for python-matplotlib plotting package
+Tk backend for %{name} plotting package
 
 %package wx
-Summary:Wx backend for python-matplotlib
+Summary:Wx backend for %{name}
 Group:  Development/Libraries/Python
 Requires:   %{name} = %{version}
 Requires:   python-wxGTK
 
 %description wx
-wxWidgets backend for python-matplotlib plotting package
+wxWidgets backend for %{name} plotting package
+
+%package designer
+Summary:%{name} widget for Qt Designer
+Group:  Development/Libraries/Python
+License:MIT
+Requires:   %{name} = %{version}
+Requires:   python-qt4
+Requires:   qt-creator
+
+%description designer
+This is a plugin and widget to let you use %{name} 
+plots as widget in PyQt4 GUIs using Qt Designer
+
+This plugin comes from Python(x,y)
 
 %prep
 %setup -n matplotlib-%{version}
-chmod -x lib/matplotlib/mpl-data/images/*.svg
+chmod -x lib/%{modname}/mpl-data/images/*.svg
 
 %build
 cp %{SOURCE1} ./setup.cfg
@@ -109,36 +118,45 @@
 %install
 python setup.py install --root=%{buildroot} \
--record-rpm=INSTALLED_FILES --prefix=%{_prefix}
+mkdir -p %{buildroot}%{_libdir}/qt4/PyQt4/plugins/
+cp -v %{SOURCE2} %{buildroot}%{_libdir}/qt4/PyQt4/plugins/
+cp -v %{SOURCE3} %{buildroot}%{py_sitedir}/%{modname}/
 
 %clean
 rm -rf %{buildroot}
 
 %files
 %defattr(-,root,root,-)
-%doc README.txt CHANGELOG INSTALL
+%doc README.txt CHANGELOG
 %doc PKG-INFO TODO CXX examples 
-%{py_sitedir}/*

commit python-passlib for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-passlib for openSUSE:Factory 
checked in at 2012-03-20 11:33:46

Comparing /work/SRC/openSUSE:Factory/python-passlib (Old)
 and  /work/SRC/openSUSE:Factory/.python-passlib.new (New)


Package is python-passlib, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-passlib/python-passlib.changes
2012-02-17 12:08:55.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-passlib.new/python-passlib.changes   
2012-03-20 11:33:47.0 +0100
@@ -1,0 +2,5 @@
+Thu Mar  8 11:34:03 UTC 2012 - sasc...@suse.de
+
+- Don't run testsuite on SLE, fixes build
+
+---



Other differences:
--
++ python-passlib.spec ++
--- /var/tmp/diff_new_pack.qgD4MR/_old  2012-03-20 11:33:50.0 +0100
+++ /var/tmp/diff_new_pack.qgD4MR/_new  2012-03-20 11:33:50.0 +0100
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   python-passlib
 Version:1.5.3
 Release:0
@@ -50,8 +51,10 @@
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
 
+%if 0%{?suse_version}  0%{?suse_version}  1130
 %check
 nosetests
+%endif
 
 %files
 %defattr(-,root,root,-)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-Shed_Skin for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-Shed_Skin for 
openSUSE:Factory checked in at 2012-03-20 11:33:53

Comparing /work/SRC/openSUSE:Factory/python-Shed_Skin (Old)
 and  /work/SRC/openSUSE:Factory/.python-Shed_Skin.new (New)


Package is python-Shed_Skin, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/python-Shed_Skin/python-Shed_Skin.changes
2011-09-23 12:42:27.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-Shed_Skin.new/python-Shed_Skin.changes   
2012-03-20 11:33:55.0 +0100
@@ -1,0 +2,66 @@
+Wed Mar 14 13:55:16 UTC 2012 - sasc...@suse.de
+
+- Update to version 0.9.1:
+  - new -L option to add library directories (Artem Egorkine)
+  - support /etc/shedskin/FLAGS, /usr/share/shedskin/lib (triggered by Paul 
Boddie)
+  - support enumerate 'start' argument
+  - itertools.product optimization (triggered by lesshaste)
+  - str.join and str non-equality optimization (triggered by lesshaste)
+  - new example: hq2x image scaling
+  - fix for itertools.izip (Jérémie Roquet)
+  - several fixes for MSVC (Liu Zhenhai)
+  - fix os.listdir crash (Pierre-Marie de Rodat)
+  - annotation fix (William Edwards)
+  - fix for 'not a  b  c' (François Boutines)
+  - os.popen2 improvement (triggered by Danny Milosavljevic)
+  - improved extmod warnings (triggered by Paul Boddie)
+  - sys.exit improvements (reported by rodseth)
+  - added missing class qualifier/include statement
+  - fix for ConfigParser model (reported by Danny Milosavljevic) 
+- Changes from version 0.9.0:
+  - major type inference scalability improvements (c64 emulator 10 times 
faster!)
+  - support for 'mmap' module (francois boutines)
+  - support for 'binascii' module (fahrzin hemmati)
+  - support for 'colorsys' module (tony veijalainen)
+  - greatly improved file I/O performance (francois)
+  - massive optimization for complex numbers (copy-by-value)
+  - optimized 'for .., .. in somedict.iteritems()'
+  - 6 new example programs (now 63 in total!):
+  - natural language parser (andreas van cranenburgh) 
+  - sokoban (uses array, collections.deque) 
+  - connect-4 
+  - interactive mandelbrot (tony veijalainen) 
+  - dancing links sudoku solver 
+  - K-means++ clustering 
+  - c64 emulator example now without glitches for international karate
+  - fixes for 'universal mode' (francois)
+  - only print tracebacks for uncaught exceptions (shedskin -x; joris van 
zwieten)
+  - some further exception handling cleanups
+  - add set.isdisjoint, sys.maxsize (brent pedersen)
+  - several set methods now take multiple arguments (brent)
+  - string equality optimization (francois)
+  - fix for string/array equality and \0 (francois)
+  - improved support for overloading comparison operators
+  - several inheritance fixes (thanks to test case by jason ye)
+  - improvements for working with 'incompatible' types (e.g., [[]] == [[1]])
+  - implementation of builtins split up into separate files (triggered by 
francois)
+  - cleaned up GCC warnings for builtins (triggered by francois)
+  - support 'id' builtin for non-scalars
+  - some optimizations for array('c')
+  - some improvements for 'copy' module
+  - use 'long' type for hash values everywhere
+  - support for 'isinstance' was dropped
+  - avoid 'jump' to 100% in progress bar
+  - removed -d command-line option, replaced it with hidden debug-level option
+  - add --silent mode, showing only warnings
+  - add timer (jason ye)
+  - os.utime implementation for windows
+  - documented how to profile extension modules
+  - documentation moved to wiki 
+- Use examples from external tarball
+- Remove outdated %clean section
+- Simplified macro usage
+- Added some requirements you typically want to have when translating
+  Python modules to C++ with Shed Skin
+
+---

Old:

  shedskin-0.8.tgz

New:

  shedskin-0.9.1.tgz
  shedskin-examples-0.9.1.tgz



Other differences:
--
++ python-Shed_Skin.spec ++
--- /var/tmp/diff_new_pack.QDZ3BI/_old  2012-03-20 11:33:57.0 +0100
+++ /var/tmp/diff_new_pack.QDZ3BI/_new  2012-03-20 11:33:57.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-Shed_Skin
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,26 +16,28 @@
 #
 
 
-
 Name:   python-Shed_Skin
-Version:0.8
-Release:3
+Version:0.9.1
+Release:0
 Url:http://shedskin.googlecode.com
 Summary:An 

commit python-slimit for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-slimit for openSUSE:Factory 
checked in at 2012-03-20 11:34:00

Comparing /work/SRC/openSUSE:Factory/python-slimit (Old)
 and  /work/SRC/openSUSE:Factory/.python-slimit.new (New)


Package is python-slimit, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.python-slimit.new/python-slimit.changes 
2012-03-20 11:34:01.0 +0100
@@ -0,0 +1,5 @@
+---
+Mon Mar 12 08:43:00 UTC 2012 - sasc...@suse.de
+
+- Initial version
+

New:

  python-slimit.changes
  python-slimit.spec
  slimit-0.6.zip



Other differences:
--
++ python-slimit.spec ++
#
# spec file for package python-slimit
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:   python-slimit
Version:0.6
Release:0
Url:http://slimit.org
Summary:JavaScript minifier written in Python
License:MIT
Group:  Development/Languages/Python
Source: 
http://pypi.python.org/packages/source/s/slimit/slimit-%{version}.zip
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  python-devel
BuildRequires:  python-distribute
BuildRequires:  python-odict
BuildRequires:  python-ply
BuildRequires:  unzip
%if 0%{?suse_version}  0%{?suse_version} = 1110
%{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
%else
BuildArch:  noarch
%endif

%description
SlimIt is a JavaScript minifier written in Python. It compiles JavaScript into
more compact code so that it downloads
and runs faster.

SlimIt also provides a library that includes a JavaScript parser,
lexer, pretty printer and a tree visitor.

%prep
%setup -q -n slimit-%{version}

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}

%check
python setup.py test

%files
%defattr(-,root,root,-)
%doc CHANGES README.rst
%{_bindir}/slimit
%{python_sitelib}/*

%changelog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-socketpool for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-socketpool for 
openSUSE:Factory checked in at 2012-03-20 11:34:14

Comparing /work/SRC/openSUSE:Factory/python-socketpool (Old)
 and  /work/SRC/openSUSE:Factory/.python-socketpool.new (New)


Package is python-socketpool, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.python-socketpool.new/python-socketpool.changes 
2012-03-20 11:34:15.0 +0100
@@ -0,0 +1,10 @@
+---
+Wed Mar 14 10:33:50 UTC 2012 - sasc...@suse.de
+
+- Ran spec-cleaner
+
+---
+Thu Feb  2 10:03:09 UTC 2012 - sasc...@suse.de
+
+- Initial version
+

New:

  python-socketpool.changes
  python-socketpool.spec
  socketpool-0.3.0.tar.gz



Other differences:
--
++ python-socketpool.spec ++
#
# spec file for package python-socketpool
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:   python-socketpool
Version:0.3.0
Release:0
License:MIT
Summary:Python socket pool
Url:http://github.com/benoitc/socketpool
Group:  Development/Languages/Python
Source: 
http://pypi.python.org/packages/source/s/socketpool/socketpool-%{version}.tar.gz
BuildRequires:  python-devel
BuildRequires:  python-nose
Recommends: python-eventlet
Recommends: python-gevent
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version}  0%{?suse_version} = 1110
%{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
%else
BuildArch:  noarch
%endif

%description
Socket pool is a simple socket pool that suports multiple factories and
backends. It can easily be used by gevent, eventlet or any other library.

%prep
%setup -q -n socketpool-%{version}

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
rm -r %{buildroot}%{_prefix}/socketpool # Remove wrongly installed docs

%check
nosetests

%files
%defattr(-,root,root,-)
%doc README.rst *LICENSE examples
%{python_sitelib}/*

%changelog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-stomper for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-stomper for openSUSE:Factory 
checked in at 2012-03-20 11:34:28

Comparing /work/SRC/openSUSE:Factory/python-stomper (Old)
 and  /work/SRC/openSUSE:Factory/.python-stomper.new (New)


Package is python-stomper, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.python-stomper.new/python-stomper.changes   
2012-03-20 11:34:29.0 +0100
@@ -0,0 +1,58 @@
+---
+Wed Mar 14 10:32:57 UTC 2012 - sasc...@suse.de
+
+- Simplified macro usage, ran spec-cleaner
+
+---
+Thu Sep 22 12:17:04 UTC 2011 - sasc...@suse.de
+
+- Require python-uuid for SLE_10 and below.
+- Use python-nose for unittests to fix SLE build
+
+---
+Thu Sep 22 08:56:39 UTC 2011 - sasc...@suse.de
+
+- Fixed license to Apache-2.0
+
+---
+Thu Sep 22 08:51:57 UTC 2011 - sasc...@suse.de
+
+- Update to version 0.2.4:
+  *Fixing the problem whereby uuid would be installed on python2.5+.
+- Changes from version 0.2.3:
+  * Fixed issue #9 with the example code. All messages are sent and received 
correctly.
+- Spec file cleanup:
+  * Added proper changes file and spec file license header
+  * Run testsuite
+
+---
+Thu Apr  9 00:00:00 UTC 2009 - si...@sewell.ch
+
+- Remove Python version dependency
+
+---
+Sun Mar 29 00:00:00 UTC 2009 - si...@sewell.ch
+
+- Fix dependencies
+
+---
+Thu Mar 26 00:00:00 UTC 2009 - si...@sewell.ch
+
+- Update package name to conform to Fedora naming standards
+- Change define to global
+
+---
+Fri Mar 20 00:00:00 UTC 2009 - si...@sewell.ch
+
+- Update upstream package to remove hidden files
+
+---
+Thu Mar  5 00:00:00 UTC 2009 - si...@sewell.ch
+
+- Manually remove hidden files
+
+---
+Wed Dec 17 00:00:00 UTC 2008 - si...@sewell.ch
+
+- Initial package
+

New:

  python-stomper.changes
  python-stomper.spec
  stomper-0.2.4.tar.gz



Other differences:
--
++ python-stomper.spec ++
#
# spec file for package python-stomper
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:   python-stomper
Version:0.2.4
Release:0
License:Apache-2.0
Summary:This is a transport neutral client implementation of the STOMP 
protocol
Url:http://code.google.com/p/stomper
Group:  Development/Languages/Python
Source: 
http://pypi.python.org/packages/source/s/stomper/stomper-%{version}.tar.gz
BuildRequires:  python-devel
BuildRequires:  python-distribute
BuildRequires:  python-nose
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version}  0%{?suse_version} = 1110
%{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
%else
BuildArch:  noarch
%endif

%description
This is a python client implementation of the STOMP protocol.

The client is attempting to be transport layer neutral. This module provides
functions to create and parse STOMP messages in a programatic fashion. The
messages can be easily generated and parsed, however its up to the user to do
the sending and receiving.

%prep
%setup -q -n stomper-%{version}

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}

%check
nosetests

%files
%defattr(-,root,root,-)
%doc README lib/stomper/examples
%{python_sitelib}/*

%changelog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: 

commit qtcurve-kde4 for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package qtcurve-kde4 for openSUSE:Factory 
checked in at 2012-03-20 11:34:41

Comparing /work/SRC/openSUSE:Factory/qtcurve-kde4 (Old)
 and  /work/SRC/openSUSE:Factory/.qtcurve-kde4.new (New)


Package is qtcurve-kde4, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/qtcurve-kde4/qtcurve-kde4.changes
2011-09-23 12:43:59.0 +0200
+++ /work/SRC/openSUSE:Factory/.qtcurve-kde4.new/qtcurve-kde4.changes   
2012-03-20 11:34:42.0 +0100
@@ -1,0 +2,17 @@
+Thu Mar 15 07:33:12 UTC 2012 - m...@suse.com
+
+- Update to version 1.8.11
+  * Fix flashing of clementine's position slider tooltip.
+
+- Changes in 1.8.10
+  * Fix some toolbutton icon clipping.
+  * Korean translation - thanks to YoungUk Kim.
+  * Fix kwin button corruption when compositing is disabled under KDE SC4.8
+  * Minimum 1ms delay for sub menus.
+   
+- Changes in 1.8.9
+  * Dont force alternate listview colours for KAboutApplicationDialog
+  * Fix issues with konqueror style menu toolbar buttons and the joined 
toolbar button style.
+  * Implement shadows for KDE SC4.7 
+
+---

Old:

  QtCurve-KDE4-1.8.8.tar.bz2

New:

  QtCurve-KDE4-1.8.11.tar.bz2



Other differences:
--
++ qtcurve-kde4.spec ++
--- /var/tmp/diff_new_pack.NhFqvO/_old  2012-03-20 11:34:44.0 +0100
+++ /var/tmp/diff_new_pack.NhFqvO/_new  2012-03-20 11:34:44.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package qtcurve-kde4
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,14 +16,13 @@
 #
 
 
-
 Name:   qtcurve-kde4
-Version:1.8.8
-Release:1
-License:GPL-2.0+
+Version:1.8.11
+Release:0
 Summary:QtCurve style for KDE 4
-Url:http://www.kde-look.org/content/show.php?content=40492
+License:GPL-2.0+
 Group:  System/GUI/KDE
+Url:http://www.kde-look.org/content/show.php?content=40492
 Source0:QtCurve-KDE4-%{version}.tar.bz2
 BuildRequires:  kdebase4-workspace-devel
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ QtCurve-KDE4-1.8.8.tar.bz2 - QtCurve-KDE4-1.8.11.tar.bz2 ++
 7378 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rfc for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package rfc for openSUSE:Factory checked in 
at 2012-03-20 11:34:47

Comparing /work/SRC/openSUSE:Factory/rfc (Old)
 and  /work/SRC/openSUSE:Factory/.rfc.new (New)


Package is rfc, Maintainer is vci...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/rfc/rfc.changes  2012-03-11 20:05:22.0 
+0100
+++ /work/SRC/openSUSE:Factory/.rfc.new/rfc.changes 2012-03-20 
11:35:01.0 +0100
@@ -2 +2 @@
-Sat Mar 10 09:43:17 CET 2012 - autobu...@suse.de
+Sun Mar 18 08:42:55 CET 2012 - autobu...@suse.de
@@ -4 +4 @@
-- automated update on 2012-03-10
+- automated update on 2012-03-18



Other differences:
--

++ rfc.tgz ++
/work/SRC/openSUSE:Factory/rfc/rfc.tgz 
/work/SRC/openSUSE:Factory/.rfc.new/rfc.tgz differ: char 5, line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rpmlint for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package rpmlint for openSUSE:Factory checked 
in at 2012-03-20 11:34:58

Comparing /work/SRC/openSUSE:Factory/rpmlint (Old)
 and  /work/SRC/openSUSE:Factory/.rpmlint.new (New)


Package is rpmlint, Maintainer is dmuel...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/rpmlint/rpmlint.changes  2012-03-16 
13:24:27.0 +0100
+++ /work/SRC/openSUSE:Factory/.rpmlint.new/rpmlint.changes 2012-03-20 
11:35:20.0 +0100
@@ -1,0 +2,11 @@
+Tue Mar 20 08:32:33 UTC 2012 - lnus...@suse.de
+
+- better deal with spaces in logrotate config
+- add colord-sane dbus service to whitelist (bnc#752518)
+
+---
+Fri Mar 16 14:26:34 CET 2012 - dmuel...@suse.de
+
+- fix parsing of update-alternatives and clarify info message 
+
+---



Other differences:
--
++ CheckAlternativesGhostFiles.py ++
--- /var/tmp/diff_new_pack.Hm0zxA/_old  2012-03-20 11:35:22.0 +0100
+++ /var/tmp/diff_new_pack.Hm0zxA/_new  2012-03-20 11:35:22.0 +0100
@@ -32,8 +32,12 @@
 if cls.INSTALL in c):
 
 #parse install
-xs = command.split(None, 4)
-ghost_files.append(xs[1])
+command_args = []
+for arg in command.split(None):
+if not arg.startswith(--):
+command_args.append(arg)
+ 
+ghost_files.append(command_args[0])
 
 if cls.SLAVE in command:
 for sc in ( \
@@ -70,12 +74,12 @@
 addDetails(
 
 'generic-name-not-marked-as-ghost',
-'''The generic name is not marked as a ghost, which may cause a problems during
-update. Mark it as a %ghost in %files section.''',
+'''The update-alternatives generic name is not marked as a ghost in the %files 
section.
+This causes problems during update. Mark it as a %ghost in %files section.''',
 
 'generic-name-not-in-filelist',
-'''The generic name is not in a filelist of package, add it to list marked as
-%ghost. Note: this error will be raised, if you use a hash ($) in file name,
-use rpm macros in spec file instead.''',
+'''The update-alternatives generic name is not in a filelist of package.
+Add it to list marked as %ghost. Note: this error will be raised, 
+if you use a hash ($) in file name, use rpm macros in spec file instead.''',
 
 )

++ CheckLogrotate.py ++
--- /var/tmp/diff_new_pack.Hm0zxA/_old  2012-03-20 11:35:22.0 +0100
+++ /var/tmp/diff_new_pack.Hm0zxA/_new  2012-03-20 11:35:22.0 +0100
@@ -63,7 +63,8 @@
 if line.endswith('{'):
 insection = True
 for logfile in line.split(' '):
-if logfile == '{':
+logfile = logfile.strip()
+if len(logfile) == 0 or logfile == '{':
 continue
 dn = os.path.dirname(logfile)
 if not dn in dirs:

++ config ++
--- /var/tmp/diff_new_pack.Hm0zxA/_old  2012-03-20 11:35:22.0 +0100
+++ /var/tmp/diff_new_pack.Hm0zxA/_new  2012-03-20 11:35:22.0 +0100
@@ -1,5 +1,5 @@
 # -*- python -*-
-# vim: syntax=python
+# vim: syntax=python sw=4 et
 # Configuration for the rpmlint utility.
 # Loaded before ~/.rpmlintrc
 # $Id: config,v 1.39 2003/12/22 11:20:55 flepied Exp $
@@ -481,6 +481,9 @@
 # colord (bnc#698250)
 org.freedesktop.ColorManager.service,
 org.freedesktop.ColorManager.conf,
+# colord-sane (bnc#752518)
+org.freedesktop.colord-sane.service,
+org.freedesktop.colord-sane.conf,
 # lightdm (bnc#708205)
 org.freedesktop.DisplayManager.conf,
 # kdepim4/kalarm (bnc#707723)


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit sanlock for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package sanlock for openSUSE:Factory checked 
in at 2012-03-20 11:35:26

Comparing /work/SRC/openSUSE:Factory/sanlock (Old)
 and  /work/SRC/openSUSE:Factory/.sanlock.new (New)


Package is sanlock, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/sanlock/sanlock.changes  2012-01-27 
15:24:18.0 +0100
+++ /work/SRC/openSUSE:Factory/.sanlock.new/sanlock.changes 2012-03-20 
11:35:28.0 +0100
@@ -1,0 +2,11 @@
+Tue Mar 13 12:04:11 MDT 2012 - jfeh...@suse.com
+
+- Update to sanlock 2.1
+  - python: release leases for other processes
+  - python: add shared resource parameter to acquire
+  - add a logrotate file
+  - status for all shared tokens
+  - retry transient sh failures
+  - fix inquire state string
+
+---

Old:

  sanlock-1.9.tar.gz

New:

  sanlock-2.1.tar.bz2



Other differences:
--
++ sanlock.spec ++
--- /var/tmp/diff_new_pack.FaUUmq/_old  2012-03-20 11:35:32.0 +0100
+++ /var/tmp/diff_new_pack.FaUUmq/_new  2012-03-20 11:35:32.0 +0100
@@ -15,22 +15,25 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define with_systemd   0
 %if 0%{?suse_version}  1140
 %define with_systemd   1
 %endif
 
-
 Name:   sanlock
-Version:1.9
+Version:2.1
 Release:1%{?dist}
 Summary:A shared disk lock manager
-
-Group:  System/Base
 License:GPL-2.0 ; GPL-2.0+ ; LGPL-2.1+
-URL:https://fedorahosted.org/sanlock/
+Group:  System/Base
+
+Url:https://fedorahosted.org/sanlock/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  libblkid-devel libaio-devel python python-devel
+BuildRequires:  libaio-devel
+BuildRequires:  libblkid-devel
+BuildRequires:  python
+BuildRequires:  python-devel
 %if %{with_systemd}
 BuildRequires:  systemd
 %{?systemd_requires}
@@ -39,7 +42,7 @@
 Requires:   %{name}-lib = %{version}-%{release}
 # Latest version available at
 # https://fedorahosted.org/releases/s/a/sanlock/
-Source0:%{name}-%{version}.tar.gz
+Source0:%{name}-%{version}.tar.bz2
 Source1:sanlock.init
 Source2:wdmd.init
 Source3:sysconfig.sanlock

++ sanlock-1.9.tar.gz - sanlock-2.1.tar.bz2 ++
 3484 lines of diff (skipped)

++ sanlock-SCHED_RESET_ON_FORK-undefined.patch ++
--- /var/tmp/diff_new_pack.FaUUmq/_old  2012-03-20 11:35:32.0 +0100
+++ /var/tmp/diff_new_pack.FaUUmq/_new  2012-03-20 11:35:32.0 +0100
@@ -2,9 +2,9 @@
 ===
 --- src/main.c.orig
 +++ src/main.c
-@@ -50,6 +50,10 @@
- #include client_cmd.h
- #include cmd.h
+@@ -52,6 +52,10 @@
+ 
+ #define RELEASE_VERSION 2.1
  
 +#ifndef SCHED_RESET_ON_FORK
 +#define SCHED_RESET_ON_FORK 0
@@ -19,7 +19,7 @@
 +++ wdmd/main.c
 @@ -43,6 +43,10 @@
  
- #define RELEASE_VERSION 1.9
+ #define RELEASE_VERSION 2.1
  
 +#ifndef SCHED_RESET_ON_FORK
 +#define SCHED_RESET_ON_FORK 0

++ suse-no-date-time.patch ++
--- /var/tmp/diff_new_pack.FaUUmq/_old  2012-03-20 11:35:32.0 +0100
+++ /var/tmp/diff_new_pack.FaUUmq/_new  2012-03-20 11:35:32.0 +0100
@@ -1,8 +1,8 @@
-Index: sanlock-1.9/src/main.c
+Index: sanlock-2.1/src/main.c
 ===
 sanlock-1.9.orig/src/main.c
-+++ sanlock-1.9/src/main.c
-@@ -1430,8 +1430,7 @@ static int read_command_line(int argc, c
+--- sanlock-2.1.orig/src/main.c
 sanlock-2.1/src/main.c
+@@ -1439,8 +1439,7 @@ static int read_command_line(int argc, c
  
if (!strcmp(arg1, version) || !strcmp(arg1, --version) ||
!strcmp(arg1, -V)) {

++ suse-systemd.patch ++
--- /var/tmp/diff_new_pack.FaUUmq/_old  2012-03-20 11:35:32.0 +0100
+++ /var/tmp/diff_new_pack.FaUUmq/_new  2012-03-20 11:35:32.0 +0100
@@ -1,7 +1,7 @@
-Index: sanlock-1.9/init.d/sanlock.service
+Index: sanlock-2.1/init.d/sanlock.service
 ===
 sanlock-1.9.orig/init.d/sanlock.service
-+++ sanlock-1.9/init.d/sanlock.service
+--- sanlock-2.1.orig/init.d/sanlock.service
 sanlock-2.1/init.d/sanlock.service
 @@ -3,8 +3,9 @@ After=syslog.target wdmd.service
  
  [Service]
@@ -14,10 +14,10 @@
  
  [Install]
  WantedBy=multi-user.target
-Index: sanlock-1.9/init.d/wdmd.service
+Index: sanlock-2.1/init.d/wdmd.service
 ===
 sanlock-1.9.orig/init.d/wdmd.service
-+++ sanlock-1.9/init.d/wdmd.service
+--- sanlock-2.1.orig/init.d/wdmd.service
 sanlock-2.1/init.d/wdmd.service
 @@ 

commit sblim-cmpi-ssh_service_profile for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package sblim-cmpi-ssh_service_profile for 
openSUSE:Factory checked in at 2012-03-20 11:35:34

Comparing /work/SRC/openSUSE:Factory/sblim-cmpi-ssh_service_profile (Old)
 and  /work/SRC/openSUSE:Factory/.sblim-cmpi-ssh_service_profile.new (New)


Package is sblim-cmpi-ssh_service_profile, Maintainer is npax...@novell.com

Changes:

--- 
/work/SRC/openSUSE:Factory/sblim-cmpi-ssh_service_profile/sblim-cmpi-ssh_service_profile.changes
2011-11-28 18:28:04.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.sblim-cmpi-ssh_service_profile.new/sblim-cmpi-ssh_service_profile.changes
   2012-03-20 11:35:36.0 +0100
@@ -1,0 +2,11 @@
+Mon Mar  5 08:28:36 UTC 2012 - cfarr...@suse.com
+
+- license update: EPL-1.0
+
+
+---
+Tue Jan 24 08:45:54 UTC 2012 - kkae...@suse.com
+
+- add missing pclose (bnc#530329)
+
+---

New:

  bnc530329-pclose.patch



Other differences:
--
++ sblim-cmpi-ssh_service_profile.spec ++
--- /var/tmp/diff_new_pack.20JNRO/_old  2012-03-20 11:35:38.0 +0100
+++ /var/tmp/diff_new_pack.20JNRO/_new  2012-03-20 11:35:38.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package sblim-cmpi-ssh_service_profile
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -25,7 +25,7 @@
 Release:0
 Group:  System/Management
 Summary:Instrumentation for DMTF SSH Service Profile.
-License:Other uncritical OpenSource License; Eclipse Public License 1.0
+License:EPL-1.0
 # This is necessary to build the RPM as a non-root user.
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 # yes is the default, but we put it here explicitly to avoid someone
@@ -34,6 +34,7 @@
 Requires:   sblim-sfcb sblim-cmpi-base
 Requires:   cim-schema = 2.17
 Source0:sblim-cmpi-ssh_service_profile-%{version}.tar.gz
+Patch1: bnc530329-pclose.patch
 
 %description
 Linux providers for instrumentation of DMTF SSH Service Profile (DSP
@@ -50,6 +51,7 @@
 %prep
 # Untar the sources.
 %setup -n sblim-cmpi-ssh_service_profile-%{version}
+%patch1 -p1
 
 %build
 # If the LD_RUN_PATH environment variable is set at link time,

++ bnc530329-pclose.patch ++
diff -wruN -x '*~' ../orig-sblim-cmpi-ssh_service_profile-1.0.0/src/Resource.c 
./src/Resource.c
--- ../orig-sblim-cmpi-ssh_service_profile-1.0.0/src/Resource.c 2008-08-07 
18:31:58.0 +0200
+++ ./src/Resource.c2012-01-24 09:40:14.0 +0100
@@ -252,7 +252,7 @@
 if (!ptr)
 {
 free(data);
-fclose(is);
+pclose(is);
 return -1;
 }
 
@@ -260,6 +260,7 @@
 memcpy(data[size++], sess, sizeof(sess));
 }
 
+pclose(is);
 *sessions = data;
 *num_sessions = size;
 return 0;
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit siproxd for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package siproxd for openSUSE:Factory checked 
in at 2012-03-20 11:35:46

Comparing /work/SRC/openSUSE:Factory/siproxd (Old)
 and  /work/SRC/openSUSE:Factory/.siproxd.new (New)


Package is siproxd, Maintainer is r...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/siproxd/siproxd.changes  2011-09-23 
12:46:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.siproxd.new/siproxd.changes 2012-03-20 
11:35:48.0 +0100
@@ -1,0 +2,5 @@
+Mon Mar 19 16:12:48 CET 2012 - r...@suse.de
+
+- switch from user nobody to own user siproxd (bnc#710608) 
+
+---



Other differences:
--
++ siproxd.spec ++
--- /var/tmp/diff_new_pack.6g5HQL/_old  2012-03-20 11:35:49.0 +0100
+++ /var/tmp/diff_new_pack.6g5HQL/_new  2012-03-20 11:35:49.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package siproxd
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,15 +19,16 @@
 #
 %define piddir  /var/run/siproxd/
 %define regdir  /var/lib/siproxd/
-%define siproxduser nobody
+%define siproxduser siproxd
+%define siproxdgroupsiproxd
 
 Name:   siproxd
 Version:0.8.1
-Release:1
-License:GPL-2.0+
+Release:0
 Summary:A SIP masquerading proxy with RTP support
-Url:http://siproxd.sourceforge.net/
+License:GPL-2.0+
 Group:  Productivity/Networking/Other
+Url:http://siproxd.sourceforge.net/
 Source0:%{name}-%{version}.tar.bz2
 Source1:susefirewall2.%{name}
 Source2:%name.init.in
@@ -44,8 +45,13 @@
 #PATCH-FIX-FROM-DEBIAN use logger not user
 Patch1: siproxd-log.c.patch
 Patch9: siproxd.plugin_fix_bogus_via.c.patch
-BuildRequires:  docbook-utils libltdl libosip2 libosip2-devel libtool
+BuildRequires:  docbook-utils
+BuildRequires:  libltdl
+BuildRequires:  libosip2
+BuildRequires:  libosip2-devel
+BuildRequires:  libtool
 Requires:   logrotate
+PreReq: %_sbindir/groupadd %_sbindir/useradd
 Suggests:   SuSEfirewall2
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -59,7 +65,6 @@
 
 %package doc
 Summary:Documentation for %{name}
-License:GPL-2.0+
 Group:  Documentation/Other 
 
 %description doc
@@ -106,6 +111,10 @@
 
 %{__mkdir} -p %buildroot%_mandir/man8
 %__install -m 0644 %{S:4} %{buildroot}%{_mandir}/man8/%name.8.gz
+#
+sed -i -e s@nobody@%{siproxduser}@ 
%{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
+sed -i -e s@nobody@%{siproxduser}@ %buildroot/%{_sysconfdir}/init.d/%{name}
+#
 # Directory needs to exist for packaging
 %if %suse_version  1120
 %{__mkdir} -p %buildroot%{_localstatedir}/run/%{name}
@@ -121,6 +130,10 @@
 
 %post -p  /sbin/ldconfig
 
+%pre
+%_sbindir/groupadd -r %{sipproxdgroup} 2 /dev/null || :
+%_sbindir/useradd -r -o -g %{sipproxdgroup} -s /bin/false -c Siproxd user -d 
%{_localstatedir}/run/%{name} %{siproxduser} 2 /dev/null || :
+
 %postun
 /sbin/ldconfig
 %restart_on_update %{name}
@@ -148,7 +161,7 @@
 
 %if %suse_version  1120
  #make rpm know about a directory but do not package it
-   %attr(0750,nobody,root) %ghost %{_localstatedir}/run/%{name}
+   %attr(0750,%{siproxduser},root) %ghost %{_localstatedir}/run/%{name}
 %endif
 
 %files doc


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit sssd for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package sssd for openSUSE:Factory checked in 
at 2012-03-20 11:35:54

Comparing /work/SRC/openSUSE:Factory/sssd (Old)
 and  /work/SRC/openSUSE:Factory/.sssd.new (New)


Package is sssd, Maintainer is rha...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/sssd/sssd.changes2011-10-21 
16:41:10.0 +0200
+++ /work/SRC/openSUSE:Factory/.sssd.new/sssd.changes   2012-03-20 
11:35:56.0 +0100
@@ -1,0 +2,13 @@
+Sun Mar 11 18:36:44 UTC 2012 - jeng...@medozas.de
+
+- Update to new upstream release 1.8.0
+* Support for the service map in NSS
+* Support for setting default SELinux user context from FreeIPA
+* Support for retrieving SSH user and host keys from LDAP
+* Support for caching autofs LDAP requests
+* Support for caching SUDO rules
+* Include the IPA AutoFS provider
+* Fixed several memory-corruption bugs
+* Fixed a regression in the proxy provider
+
+---

Old:

  0001-sss_client-avoid-leaking-file-descriptors.patch
  0002-Request-password-control-unconditionally-during-bind.patch
  sssd-1.5.11.tar.bz2

New:

  0004-avoid-hard-crypto-dep.diff
  0005-implicit-decl.diff
  sssd-1.8.0.tar.bz2



Other differences:
--
++ sssd.spec ++
--- /var/tmp/diff_new_pack.LE14Kx/_old  2012-03-20 11:35:58.0 +0100
+++ /var/tmp/diff_new_pack.LE14Kx/_new  2012-03-20 11:35:58.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package sssd
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -14,23 +14,20 @@
 
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
-
-
-
 Name:   sssd
-Version:1.5.11
-Release:2
-Group:  System/Daemons
+Version:1.8.0
+Release:0
 Summary:System Security Services Daemon
 License:GPL-3.0+ and LGPL-3.0+
+Group:  System/Daemons
 Url:https://fedorahosted.org/sssd/
 Source0:%{name}-%{version}.tar.bz2
 Source1:baselibs.conf
-Patch1: 0001-sss_client-avoid-leaking-file-descriptors.patch
-Patch2: 0002-Request-password-control-unconditionally-during-bind.patch
 Patch3: 0003-Allow-LDAP-to-decide-when-an-expiration-warning-is-w.patch
+Patch4: 0004-avoid-hard-crypto-dep.diff
+Patch5: 0005-implicit-decl.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if %suse_version  1140
+%if %suse_version = 1210
 %{?systemd_requires}
 %endif
 
@@ -47,38 +44,53 @@
 %endif
 
 ### Build Dependencies ###
+%if 0%{?suse_version} = 1210
+BuildRequires:  pkgconfig(collection) = 0.5.1
+BuildRequires:  pkgconfig(dbus-1)
+BuildRequires:  pkgconfig(dhash) = 0.4.2
+BuildRequires:  pkgconfig(ini_config) = 0.6.1
+BuildRequires:  pkgconfig(ldb) = 0.9.2
+BuildRequires:  pkgconfig(libcares)
+BuildRequires:  pkgconfig(libcrypto)
+BuildRequires:  pkgconfig(libnl-1) = 1.1
+BuildRequires:  pkgconfig(libpcre) = 7
+BuildRequires:  pkgconfig(popt)
+BuildRequires:  pkgconfig(python)
+BuildRequires:  pkgconfig(talloc)
+BuildRequires:  pkgconfig(tdb) = 1.1.3
+BuildRequires:  pkgconfig(tevent)
+%else
+BuildRequires:  dbus-1-devel
+BuildRequires:  libcares-devel
+BuildRequires:  libcollection-devel = 0.5.1
+BuildRequires:  libdhash-devel = 0.4.2
+BuildRequires:  libini_config-devel = 0.6.1
+BuildRequires:  libldb-devel = 0.9.2
+BuildRequires:  libnl-devel = 1.1
+BuildRequires:  libopenssl-devel
+BuildRequires:  libtalloc-devel
+BuildRequires:  libtdb-devel = 1.1.3
+BuildRequires:  libtevent-devel
+BuildRequires:  pcre-devel = 7
+BuildRequires:  popt-devel
+BuildRequires:  python-devel
+%endif
 BuildRequires:  autoconf
 BuildRequires:  automake
+BuildRequires:  bind-utils
+BuildRequires:  docbook-xsl-stylesheets
+BuildRequires:  krb5-devel
 BuildRequires:  libtool
-BuildRequires:  m4
-BuildRequires:  popt-devel
-BuildRequires:  libtalloc-devel
-BuildRequires:  libtevent-devel
-BuildRequires:  libtdb-devel
-BuildRequires:  libldb-devel
-BuildRequires:  libxslt
+BuildRequires:  libunistring-devel
+# wants: xmllint, xsltproc
 BuildRequires:  libxml2
-BuildRequires:  libcares-devel
-BuildRequires:  dbus-1-devel
+BuildRequires:  libxslt
+BuildRequires:  nscd
 BuildRequires:  openldap2-devel
 BuildRequires:  pam-devel
 BuildRequires:  pkg-config
-BuildRequires:  pcre-devel
-BuildRequires:  docbook-xsl-stylesheets
-BuildRequires:  krb5-devel
-BuildRequires:  python-devel
-BuildRequires:  bind-utils
-BuildRequires:  nscd
-BuildRequires:  libpath_utils-devel

commit Terminal for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package Terminal for openSUSE:Factory 
checked in at 2012-03-20 11:36:21

Comparing /work/SRC/openSUSE:Factory/Terminal (Old)
 and  /work/SRC/openSUSE:Factory/.Terminal.new (New)


Package is Terminal, Maintainer is xfce-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/Terminal/Terminal.changes2011-10-25 
17:13:15.0 +0200
+++ /work/SRC/openSUSE:Factory/.Terminal.new/Terminal.changes   2012-03-20 
11:36:23.0 +0100
@@ -1,0 +2,6 @@
+Wed Mar 14 17:25:21 UTC 2012 - lazy.k...@opensuse.org
+
+- Moved localized man pages to language package.
+- Clean up spec.
+
+---



Other differences:
--
++ Terminal.spec ++
--- /var/tmp/diff_new_pack.tlvLgA/_old  2012-03-20 11:36:24.0 +0100
+++ /var/tmp/diff_new_pack.tlvLgA/_new  2012-03-20 11:36:24.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package Terminal
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,29 +16,27 @@
 #
 
 
-
 Name:   Terminal
 Version:0.4.8
-Release:1
+Release:0
+Summary:Terminal Emulator for the Xfce Desktop Environment
 License:GPL-2.0+
-Summary:Terminal emulator for the Xfce desktop environment
-Url:http://goodies.xfce.org/projects/applications/terminal
 Group:  System/X11/Terminals
+Url:http://goodies.xfce.org/projects/applications/terminal
 Source0:%{name}-%{version}.tar.bz2
 Source1:%name-rpmlintrc
 # PATCH-FIX-UPSTREAM Terminal-0.4.8-fix-help.patch g...@opensuse.org -- Fix 
help by making sure there is no trailing '#' in URLs which make exo-helper-1 
choke
 Patch0: Terminal-0.4.8-fix-help.patch
+BuildRequires:  fdupes
 BuildRequires:  intltool
-BuildRequires:  libpng-devel
+BuildRequires:  startup-notification
+BuildRequires:  update-desktop-files
+BuildRequires:  xfce4-dev-tools
 BuildRequires:  pkgconfig(dbus-1)
-BuildRequires:  exo-devel
+BuildRequires:  pkgconfig(dbus-glib-1)
+BuildRequires:  pkgconfig(exo-1)
 BuildRequires:  pkgconfig(gtk+-2.0)
 BuildRequires:  pkgconfig(vte)
-BuildRequires:  pkgconfig(dbus-glib-1)
-BuildRequires:  xfce4-dev-tools
-BuildRequires:  startup-notification
-BuildRequires:  update-desktop-files
-BuildRequires:  fdupes
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Recommends: %{name}-lang = %{version}
 Recommends: %{name}-doc = %{version}
@@ -52,9 +50,8 @@
 helps to save space on the desktop.
 
 %package doc
-License:GPL-2.0+
-Group:  Documentation/HTML
 Summary:Documentation for Terminal
+Group:  Documentation/HTML
 BuildArch:  noarch
 Requires:   %{name} = %{version}
 
@@ -74,7 +71,7 @@
 
 %install
 %makeinstall
-%fdupes %{buildroot}/%{_mandir}
+%fdupes %{buildroot}/%{_datadir}
 %suse_update_desktop_file -i Terminal System TerminalEmulator Utility
 rm %{buildroot}%{_datadir}/pixmaps/terminal.xpm
 # create terminal - Terminal symlinks
@@ -84,22 +81,15 @@
 ln -sf ${manpage##*/} \
 $(printf %s\n ${manpage##*/} | tr [:upper:] [:lower:]) )
 done
-rm -rf %{buildroot}%{_datadir}/locale/{ast,kk,tl_PH,ur_PK}
-%find_lang %{name}
-
-%clean
-rm -rf %{buildroot}
-
-%if 0%{?suse_version} = 1140
+%find_lang %{name} --with-man
 
 %post
-%desktop_database_post
 %icon_theme_cache_post
+%desktop_database_post
 
 %postun
-%desktop_database_postun
 %icon_theme_cache_postun
-%endif
+%desktop_database_postun
 
 %files
 %defattr(-,root,root)
@@ -110,22 +100,11 @@
 %{_datadir}/Terminal/*ui
 %{_datadir}/Terminal/Terminal.glade
 %{_datadir}/applications/Terminal.desktop
-%dir %{_datadir}/icons/hicolor/*
-%{_datadir}/icons/hicolor/*/*/
+%{_datadir}/icons/hicolor/*/*/*
 %dir %{_datadir}/gnome-control-center
 %dir %{_datadir}/gnome-control-center/default-apps
 %{_datadir}/gnome-control-center/default-apps/Terminal-default-apps.xml
-%dir %{_mandir}/ca
-%dir %{_mandir}/da
-%dir %{_mandir}/el
-%dir %{_mandir}/gl
-%dir %{_mandir}/id
-%dir %{_mandir}/pt
-%dir %{_mandir}/ru
-%dir %{_mandir}/ug
-%dir %{_mandir}/sv
-%dir %{_mandir}/zh_CN
-%doc %{_mandir}/*/*
+%doc %{_mandir}/man?/*
 
 %files doc
 %defattr(-,root,root)
@@ -134,5 +113,11 @@
 %doc %{_datadir}/xfce4/Terminal/html/
 
 %files lang -f %{name}.lang
+%defattr(-,root,root)
+%dir %{_mandir}/??
+%dir %{_mandir}/??_??
+%doc %dir %{_mandir}/??/man1
+%doc %dir %{_mandir}/??_??/man1
+%doc %{_mandir}/*/man1/terminal.*
 
 %changelog

-- 
To unsubscribe, e-mail: 

commit sysvinit for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package sysvinit for openSUSE:Factory 
checked in at 2012-03-20 11:36:15

Comparing /work/SRC/openSUSE:Factory/sysvinit (Old)
 and  /work/SRC/openSUSE:Factory/.sysvinit.new (New)


Package is sysvinit, Maintainer is wer...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/sysvinit/sysvinit.changes2012-03-02 
13:50:12.0 +0100
+++ /work/SRC/openSUSE:Factory/.sysvinit.new/sysvinit.changes   2012-03-20 
11:36:17.0 +0100
@@ -1,0 +2,10 @@
+Fri Mar 16 16:51:33 UTC 2012 - wer...@suse.de
+
+- Add two patch from upstream
+  + Handle deleted binaries in pidof (was upstream bug #34992)
+  + Allow init to delte extra environment variables (was upstream
+bug #35858)
+  + Avoid that init double environment variables for its childs
+(was upstream bug #35855)
+
+---

New:

  sysvinit-2.88+dsf-dostat.patch
  sysvinit-2.88+dsf-env.patch



Other differences:
--
++ sysvinit.spec ++
--- /var/tmp/diff_new_pack.EAbMiK/_old  2012-03-20 11:36:19.0 +0100
+++ /var/tmp/diff_new_pack.EAbMiK/_new  2012-03-20 11:36:19.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package sysvinit
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,8 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   sysvinit
 %define PDVER  2.0.2
@@ -24,13 +22,16 @@
 %define SCVER  1.16
 %define SIVER  2.88+
 %define START  0.58
-License:GPL-2.0+
-Group:  System/Base
 Version:%{SIVER}
-Release:58
+Release:0
 Summary:SysV-Style init
+License:GPL-2.0+
+Group:  System/Base
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  audit-devel libselinux-devel libsepol-devel pam-devel
+BuildRequires:  audit-devel
+BuildRequires:  libselinux-devel
+BuildRequires:  libsepol-devel
+BuildRequires:  pam-devel
 Url:http://savannah.nongnu.org/projects/sysvinit/
 Source: sysvinit-%{SIVER}dsf.tar.bz2
 Source2:killproc-%{KPVER}.tar.bz2
@@ -52,6 +53,8 @@
 Patch7: %{name}-%{version}dsf-crypt.patch
 Patch8: %{name}-%{version}dsf-blowfish.dif
 Patch9: %{name}-2.88dsf-no-kill.patch
+Patch10:%{name}-%{version}dsf-env.patch
+Patch11:%{name}-%{version}dsf-dostat.patch
 Patch20:powerd-%{PDVER}.dif
 Patch21:powerd-%{PDVER}-getaddrinfo.patch
 Patch30:killproc-%{KPVER}.dif
@@ -71,6 +74,7 @@
 
 %package tools
 Summary:Tools for basic booting
+Group:  System/Base
 %if 0%{suse_version}  1120
 Requires(preun):  coreutils %insserv_prereq
 Requires(postun): coreutils %insserv_prereq
@@ -85,6 +89,7 @@
 
 %package init
 Summary:Provides /sbin/init for sysvinit
+Group:  System/Base
 Provides:   sbin_init
 Conflicts:  otherproviders(sbin_init)
 Requires:   %{name}
@@ -103,6 +108,8 @@
 %patch7  -p0 -b .crypt
 %patch8  -p0 -b .blowfish
 %patch9  -p0 -b .no-kill
+%patch10 -p0 -b .env
+%patch11 -p0 -b .dostat
 %patch
 pushd doc
   mkdir killproc powerd showconsole

++ sysvinit-2.88+dsf-dostat.patch ++
Index: src/killall5.c
===
--- src/killall5.c  (revision 114)
+++ src/killall5.c  (working copy)
@@ -638,8 +638,32 @@ int readproc(int do_stat)
if ((p-nfs = check4nfs(path, buf)))
goto link;
case DO_STAT:
-   if (stat(path, st) != 0)
+   if (stat(path, st) != 0) {
+   char * ptr;
+
+   len = readlink(path, buf, PATH_MAX);
+   if (len = 0)
+   break;
+   buf[len] = '\0';
+
+   ptr = strstr(buf,  (deleted));
+   if (!ptr)
+   break;
+   *ptr = '\0';
+   len -= strlen( (deleted));
+
+   if (stat(buf, st) != 0)
+   break;
+   p-dev = st.st_dev;
+   p-ino = st.st_ino;
+   p-pathname = (char *)xmalloc(len + 1);
+   memcpy(p-pathname, 

commit wpa_supplicant for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package wpa_supplicant for openSUSE:Factory 
checked in at 2012-03-20 11:36:28

Comparing /work/SRC/openSUSE:Factory/wpa_supplicant (Old)
 and  /work/SRC/openSUSE:Factory/.wpa_supplicant.new (New)


Package is wpa_supplicant, Maintainer is g...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/wpa_supplicant/wpa_supplicant.changes
2012-01-10 14:51:40.0 +0100
+++ /work/SRC/openSUSE:Factory/.wpa_supplicant.new/wpa_supplicant.changes   
2012-03-20 11:36:30.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar 17 22:30:51 UTC 2012 - dims...@opensuse.org
+
+- Add wpa_supplicant-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  wpa_supplicant-gcc47.patch



Other differences:
--
++ wpa_supplicant.spec ++
--- /var/tmp/diff_new_pack.F1XdSW/_old  2012-03-20 11:36:34.0 +0100
+++ /var/tmp/diff_new_pack.F1XdSW/_new  2012-03-20 11:36:34.0 +0100
@@ -15,11 +15,14 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
 
 Name:   wpa_supplicant
-BuildRequires:  dbus-1-devel libqt4 libqt4-devel openssl-devel pkg-config 
readline-devel
+BuildRequires:  dbus-1-devel
+BuildRequires:  libqt4
+BuildRequires:  libqt4-devel
+BuildRequires:  openssl-devel
+BuildRequires:  pkg-config
+BuildRequires:  readline-devel
 %if 0%{?suse_version}  1140
 BuildRequires:  libnl-1_1-devel
 %else
@@ -27,10 +30,10 @@
 %endif
 Url:http://hostap.epitest.fi/wpa_supplicant/
 Version:0.7.3
-Release:6
+Release:0
+Summary:WPA supplicant implementation
 License:BSD-3-Clause ; GPL-2.0+
 Group:  Productivity/Networking/Other
-Summary:WPA supplicant implementation
 Source: 
http://hostap.epitest.fi/releases/wpa_supplicant-%{version}.tar.bz2
 Source1:config
 Source2:%{name}.conf
@@ -49,6 +52,8 @@
 Patch5: wpa_supplicant-dbus-events.patch
 # PATCH-FIX-UPSTREAM wpa_supplicant-probed-cert-dbus-signal.patch bnc#574266 
g...@suse.com -- emit a D-Bus signal when the AP returned the certificate of 
the RADIUS server
 Patch6: wpa_supplicant-probed-cert-dbus-signal.patch
+# PATCH-FIX-UPSTREAM wpa_supplicant-gcc47.patch dims...@opensuse.org -- Fix 
build with gcc 4.7.
+Patch7: wpa_supplicant-gcc47.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires:   logrotate
 
@@ -64,10 +69,9 @@
 Jouni Malinen jkmal...@cc.hut.fi
 
 %package gui
-License:BSD-3-Clause ; GPL-2.0+
 Summary:WPA supplicant graphical front-end
-Requires:   wpa_supplicant
 Group:  System/Monitoring
+Requires:   wpa_supplicant
 
 %description gui
 This package contains a graphical front-end to wpa_supplicant, an
@@ -88,6 +92,7 @@
 %patch4 -p0
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 %build
 cd wpa_supplicant

++ wpa_supplicant-gcc47.patch ++
Only in wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4/.obj: 
moc_networkconfig.o
Only in wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4/.obj: moc_peers.o
Only in wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4/.obj: moc_scanresults.o
Only in wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4/.obj: 
moc_userdatarequest.o
Only in wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4/.obj: moc_wpagui.o
Only in wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4/.obj: wpagui.o
Only in wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4: wpa_gui
diff -ur -p wpa_supplicant-0.7.3.orig/wpa_supplicant/wpa_gui-qt4/wpagui.cpp 
wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4/wpagui.cpp
--- wpa_supplicant-0.7.3.orig/wpa_supplicant/wpa_gui-qt4/wpagui.cpp 
2010-09-07 15:43:39.0 +
+++ wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4/wpagui.cpp  2012-03-17 
22:27:50.791658139 +
@@ -12,10 +12,8 @@
  * See README and COPYING for more details.
  */
 
-#ifdef __MINGW32__
 /* Need to get getopt() */
 #include unistd.h
-#endif
 
 #ifdef CONFIG_NATIVE_WINDOWS
 #include windows.h
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit wvstreams for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package wvstreams for openSUSE:Factory 
checked in at 2012-03-20 11:36:41

Comparing /work/SRC/openSUSE:Factory/wvstreams (Old)
 and  /work/SRC/openSUSE:Factory/.wvstreams.new (New)


Package is wvstreams, Maintainer is klw...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/wvstreams/wvstreams.changes  2012-02-14 
19:09:35.0 +0100
+++ /work/SRC/openSUSE:Factory/.wvstreams.new/wvstreams.changes 2012-03-20 
11:36:43.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar 17 13:48:53 UTC 2012 - dims...@opensuse.org
+
+- Add wvstreams-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  wvstreams-gcc47.patch



Other differences:
--
++ wvstreams.spec ++
--- /var/tmp/diff_new_pack.p3UDbq/_old  2012-03-20 11:36:45.0 +0100
+++ /var/tmp/diff_new_pack.p3UDbq/_new  2012-03-20 11:36:45.0 +0100
@@ -16,14 +16,19 @@
 #
 
 
-
 Name:   wvstreams
 Url:http://alumnit.ca/wiki/?WvStreams
-BuildRequires:  db-devel gcc-c++ openssl-devel pam-devel pkgconfig zlib-devel
-License:LGPL-2.1+
+BuildRequires:  db-devel
+BuildRequires:  gcc-c++
+BuildRequires:  openssl-devel
+BuildRequires:  pam-devel
+BuildRequires:  pkgconfig
+BuildRequires:  zlib-devel
 Version:4.4.1
-Release:74
+Release:0
 Summary:Network Programming Library in C++
+License:LGPL-2.1+
+Group:  Development/Libraries/Other
 Source0:http://open.nit.ca/download/%{name}-%{version}.tar.bz2
 Patch0: set-empty.diff
 Patch1: sentinel.diff
@@ -33,7 +38,7 @@
 Patch8: wvstreams-gcc43.patch
 Patch9: wvstreams-openssl.patch
 Patch10:wvstreams-headers.patch
-Group:  Development/Libraries/Other
+Patch11:wvstreams-gcc47.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -73,6 +78,7 @@
 %patch8
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
 
 %build
 # This package failed when testing with -Wl,-as-needed being default.

++ wvstreams-gcc47.patch ++
Index: wvstreams-4.4.1/include/uniconftree.h
===
--- wvstreams-4.4.1.orig/include/uniconftree.h
+++ wvstreams-4.4.1/include/uniconftree.h
@@ -108,7 +108,7 @@ public:
 void visit(const Visitor visitor, void *userdata,
 bool preorder = true, bool postorder = false) const
 {
-_recursive_unsorted_visit(this, reinterpret_cast
+this-_recursive_unsorted_visit(this, reinterpret_cast
 const typename Base::BaseVisitor(visitor), userdata,
 preorder, postorder);
 }
@@ -124,7 +124,7 @@ public:
 bool compare(const Sub *other, const Comparator comparator,
 void *userdata)
 {
-return _recursivecompare(this, other, reinterpret_cast
+return this-_recursivecompare(this, other, reinterpret_cast
 const typename Base::BaseComparator(comparator), userdata);
 }
 
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit xemacs-packages for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package xemacs-packages for openSUSE:Factory 
checked in at 2012-03-20 11:36:47

Comparing /work/SRC/openSUSE:Factory/xemacs-packages (Old)
 and  /work/SRC/openSUSE:Factory/.xemacs-packages.new (New)


Package is xemacs-packages, Maintainer is wer...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/xemacs-packages/xemacs-packages.changes  
2011-09-23 12:51:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.xemacs-packages.new/xemacs-packages.changes 
2012-03-20 11:36:49.0 +0100
@@ -1,0 +2,7 @@
+Fri Mar  2 12:25:51 UTC 2012 - wer...@suse.de
+
+- Update to sumo-2012-02-14
+  * as there are a lot of changes you may read
+https://bitbucket.org/xemacs/xemacs-packages/changesets
+
+---

Old:

  apel-upstream-cvs.diff
  bugzilla-130200-generate-autoloads-with-xemacs-21.5.patch
  disable-apel.patch
  disable-hyperbole.patch
  disable-lookup.patch
  disable-tm.patch
  fix-mule-make-coding-system.patch
  format-info.patch
  latin-unity.patch
  locale-start.patch
  packages-cvs-sumo-2003-02-05-Local.ruless.template.patch
  packages-cvs-sumo-2009-02-17.tar.bz2
  packages-cvs-xemacs-sumo-2002-05-22-mule-ucs.patch
  update-vc.patch

New:

  xemacs-packages-rpmlintrc
  xemacs-sumo-2012-02-14.tar.bz2



Other differences:
--
++ xemacs-packages.spec ++
 1889 lines (skipped)
 between /work/SRC/openSUSE:Factory/xemacs-packages/xemacs-packages.spec
 and /work/SRC/openSUSE:Factory/.xemacs-packages.new/xemacs-packages.spec

++ app-defaults.patch ++
--- /var/tmp/diff_new_pack.04mT3c/_old  2012-03-20 11:36:53.0 +0100
+++ /var/tmp/diff_new_pack.04mT3c/_new  2012-03-20 11:36:53.0 +0100
@@ -1,30 +1,49 @@
-Index: packages/mule-packages/locale/app-defaults/fr/Emacs
-===
 packages/mule-packages/locale/app-defaults/fr/Emacs.orig
-+++ packages/mule-packages/locale/app-defaults/fr/Emacs
+--- packages/mule-packages/locale/app-defaults/de/Emacs
 packages/mule-packages/locale/app-defaults/de/Emacs2012-02-28 
14:10:14.754434028 +
+@@ -3,6 +3,20 @@
+ ! German localization resources for XEmacs.
+ ! updated Fri Aug 10 16:17:07 2007  by Mike FABIAN  mfab...@suse.de
+ 
++!!
++!! FontSet for menus when you use --with-xfs or --with-xim=xlib.
++XEmacs*fontSet:   
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso10646-1,\
++  
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*,\
++  -*-*-*-*-*-*-*-120-*-iso10646-1
++XEmacs*menubar*fontSet:   
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso10646-1,\
++  
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*,\
++  -*-*-*-*-*-*-*-120-*-iso10646-1
++XEmacs*popup*fontSet: 
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso10646-1,\
++  
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*,\
++  -*-*-*-*-*-*-*-120-*-iso10646-1
++XEmacs*menubar*Font:  -*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*
++XEmacs*popup*Font:-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*
++
+ ! Pulldown menu internationalization.  The first line of the file
+ ! *XlwMenu.resourceLabels: True has to be there to make sure
+ ! all the labelString will be read and displayed by X.
+--- packages/mule-packages/locale/app-defaults/fr/Emacs
 packages/mule-packages/locale/app-defaults/fr/Emacs2012-02-28 
14:10:32.129993870 +
 @@ -1,3 +1,18 @@
 +! -*- coding: iso-8859-1 -*-
 +!!
 +!! FontSet for menus when you use --with-xfs or --with-xim=xlib.
-+XEmacs*fontSet: 
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso10646-1,\
-+
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*,\
-+  -*-*-*-*-*-*-*-120-*-iso10646-1
-+XEmacs*menubar*fontSet: 
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso10646-1,\
-+
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*,\
-+  -*-*-*-*-*-*-*-120-*-iso10646-1
-+XEmacs*popup*fontSet:   
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso10646-1,\
-+
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*,\
-+  -*-*-*-*-*-*-*-120-*-iso10646-1
++XEmacs*fontSet:   
-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso10646-1,\
++  

commit yast2-storage for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package yast2-storage for openSUSE:Factory 
checked in at 2012-03-20 12:04:25

Comparing /work/SRC/openSUSE:Factory/yast2-storage (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-storage.new (New)


Package is yast2-storage, Maintainer is aschn...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/yast2-storage/yast2-storage.changes  
2011-12-07 14:40:39.0 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-storage.new/yast2-storage.changes 
2012-03-20 12:04:31.0 +0100
@@ -1,0 +2,63 @@
+Tue Mar 13 15:15:28 CET 2012 - f...@suse.de
+
+- warn about slowness when resizing mounted fs by more than 50Gig 
+  (bnc#749946)
+- 2.22.1
+
+---
+Mon Mar 05 11:30:46 CET 2012 - aschn...@suse.de
+
+- allow equal-sign = in passwords (bnc#750306)
+
+---
+Wed Jan 25 12:20:53 CET 2012 - f...@suse.de
+
+- allow resize and move of simple btrfs volumes if they are
+  formatted anyway (bnc#742491)
+- fix bug handling used devices of simple btrfs volumes in resize
+
+---
+Tue Jan 24 14:15:29 CET 2012 - aschn...@suse.de
+
+- do not query user to autostart multipath in AutoYaST (bnc#742913)
+
+---
+Tue Jan 24 13:52:45 CET 2012 - f...@suse.de
+
+- ensure default mountby uuid for btrfs in all cases 
+- prevent display of outdated data with simple btrfs volumes
+
+---
+Thu Jan 19 10:52:02 GMT 2012 - aschn...@suse.de
+
+- improved layout for small screens (bnc#740006)
+
+---
+Tue Jan 10 18:59:52 CET 2012 - f...@suse.de
+
+- fix parsing problem with old style size values (e.g. 10G instead
+  of 10GB) (bnc#740560)
+
+---
+Mon Jan  9 16:39:46 CET 2012 - f...@suse.de
+
+- fix missing /boot partition in proposal (bnc#739091)
+- do not enforce subvolumes to start with @/ on openSuSE 
+  (bnc#738542)
+
+---
+Tue Jan 03 11:59:51 CET 2012 - aschn...@suse.de
+
+- removed generating fstab entries for ZIP drives
+
+---
+Wed Dec 21 12:04:31 CET 2011 - aschn...@suse.de
+
+- handle FBA DASD with parted instead of fdasd (bnc#584703)
+
+---
+Tue Dec 20 14:08:55 CET 2011 - f...@suse.de
+
+- fix proposal to reuse also larger root filesystems (bnc#727362)
+
+---

Old:

  yast2-storage-2.22.0.tar.bz2

New:

  yast2-storage-2.22.1.tar.bz2



Other differences:
--
++ yast2-storage.spec ++
--- /var/tmp/diff_new_pack.bFfUFB/_old  2012-03-20 12:04:33.0 +0100
+++ /var/tmp/diff_new_pack.bFfUFB/_new  2012-03-20 12:04:33.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package yast2-storage
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 
 Name:   yast2-storage
-Version:2.22.0
+Version:2.22.1
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -26,7 +26,7 @@
 
 Group:  System/YaST
 License:GPL-2.0+
-BuildRequires:  blocxx-devel boost-devel gcc-c++ libtool libxcrypt-devel 
openssl-devel sablot swig
+BuildRequires:  blocxx-devel boost-devel gcc-c++ libtool openssl-devel sablot 
swig
 BuildRequires:  docbook-xsl-stylesheets doxygen libxslt perl-XML-Writer 
sgml-skel update-desktop-files
 BuildRequires:  libstorage-devel = 2.21.11 yast2 = 2.19.4 yast2-core-devel 
= 2.18.1 yast2-devtools
 BuildRequires:  yast2-perl-bindings yast2-testsuite = 2.19.0

++ yast2-storage-2.22.0.tar.bz2 - yast2-storage-2.22.1.tar.bz2 ++
 5893 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/yast2-storage-2.22.0/VERSION new/yast2-storage-2.22.1/VERSION
--- old/yast2-storage-2.22.0/VERSION2011-11-15 15:03:04.0 

commit yast2-installation for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package yast2-installation for 
openSUSE:Factory checked in at 2012-03-20 12:04:34

Comparing /work/SRC/openSUSE:Factory/yast2-installation (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-installation.new (New)


Package is yast2-installation, Maintainer is jsuch...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/yast2-installation/yast2-installation.changes
2012-02-16 16:25:05.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.yast2-installation.new/yast2-installation.changes   
2012-03-20 12:04:36.0 +0100
@@ -1,0 +2,6 @@
+Wed Mar 14 15:42:19 CET 2012 - aschn...@suse.de
+
+- create link yast.ssh for 2nd stage ssh installation (bnc#745340)
+- 2.22.5
+
+---

Old:

  yast2-installation-2.22.4.tar.bz2

New:

  yast2-installation-2.22.5.tar.bz2



Other differences:
--
++ yast2-installation.spec ++
--- /var/tmp/diff_new_pack.LEWiN3/_old  2012-03-20 12:04:38.0 +0100
+++ /var/tmp/diff_new_pack.LEWiN3/_new  2012-03-20 12:04:38.0 +0100
@@ -18,7 +18,7 @@
 
 
 Name:   yast2-installation
-Version:2.22.4
+Version:2.22.5
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -153,6 +153,7 @@
 export CFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 export CXXFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 
+%{?suse_update_config:%{suse_update_config -f}}
 ./configure --libdir=%{_libdir} --prefix=%{_prefix} --mandir=%{_mandir}
 # V=1: verbose build in case we used AM_SILENT_RULES(yes)
 # so that RPM_OPT_FLAGS check works

++ yast2-installation-2.22.4.tar.bz2 - yast2-installation-2.22.5.tar.bz2 
++
 2661 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/yast2-installation-2.22.4/VERSION new/yast2-installation-2.22.5/VERSION
--- old/yast2-installation-2.22.4/VERSION   2012-02-14 15:28:13.0 
+0100
+++ new/yast2-installation-2.22.5/VERSION   2012-03-16 18:01:09.0 
+0100
@@ -1 +1 @@
-2.22.4
+2.22.5
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/yast2-installation-2.22.4/configure.in 
new/yast2-installation-2.22.5/configure.in
--- old/yast2-installation-2.22.4/configure.in  2012-02-14 15:44:28.0 
+0100
+++ new/yast2-installation-2.22.5/configure.in  2012-03-16 18:01:43.0 
+0100
@@ -1,9 +1,9 @@
 dnl configure.in for yast2-installation
 dnl
-dnl -- This file is generated by y2autoconf 2.21.8 - DO NOT EDIT! --
+dnl -- This file is generated by y2autoconf 2.21.6 - DO NOT EDIT! --
 dnl(edit configure.in.in instead)
 
-AC_INIT(yast2-installation, 2.22.4, http://bugs.opensuse.org/, 
yast2-installation)
+AC_INIT(yast2-installation, 2.22.5, http://bugs.opensuse.org/, 
yast2-installation)
 dnl Check for presence of file 'RPMNAME'
 AC_CONFIG_SRCDIR([RPMNAME])
 
@@ -18,7 +18,7 @@
 AM_INIT_AUTOMAKE(tar-ustar -Wno-portability)
 
 dnl Important YaST2 variables
-VERSION=2.22.4
+VERSION=2.22.5
 RPMNAME=yast2-installation
 MAINTAINER=Jiří Suchomel jsuch...@suse.cz
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/yast2-installation-2.22.4/startup/Second-Stage/S08-start 
new/yast2-installation-2.22.5/startup/Second-Stage/S08-start
--- old/yast2-installation-2.22.4/startup/Second-Stage/S08-start
2012-02-14 15:28:13.0 +0100
+++ new/yast2-installation-2.22.5/startup/Second-Stage/S08-start
2012-03-15 10:26:44.0 +0100
@@ -31,10 +31,12 @@
#==
# We are going to start a SSH based remote session
#--
+   ln -sf /usr/lib/YaST2/startup/YaST2.ssh /sbin/yast.ssh
ssh_message
while [ -f /var/lib/YaST2/runme_at_boot ]; do
sleep 3
done
+   rm /sbin/yast.ssh
 fi
 
 #=
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 

commit rpm for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package rpm for openSUSE:Factory checked in 
at 2012-03-20 12:04:39

Comparing /work/SRC/openSUSE:Factory/rpm (Old)
 and  /work/SRC/openSUSE:Factory/.rpm.new (New)


Package is rpm, Maintainer is m...@suse.com

Changes:

rpm-python.changes: same change
--- /work/SRC/openSUSE:Factory/rpm/rpm.changes  2012-02-03 10:26:42.0 
+0100
+++ /work/SRC/openSUSE:Factory/.rpm.new/rpm.changes 2012-03-20 
12:04:41.0 +0100
@@ -1,0 +2,19 @@
+Tue Mar 13 21:53:12 UTC 2012 - dims...@opensuse.org
+
+- Add rpm-gcc47.patch: Fix build with gcc 4.7 by correcting a
+  strncat call and including missing headers.
+
+---
+Tue Mar 13 14:40:47 UTC 2012 - vu...@opensuse.org
+
+- Add findlang-new-help.diff: patch based on git commit 6047ddf6 to
+  make find-lang know about the new gnome help layout.
+- Add findlang-new-help-fix.diff: additional fix to above patch, so
+  that locales with a territory work too (for instance, fr_FR).
+- Rebase langnoc.diff on top of findlang-new-help.diff, so that we
+  won't need to rebase it with a future release containing
+  findlang-new-help.diff.
+- Update remove-translations.diff to also remove help translations
+  for languages that are not supported by the filesystem package.
+
+---

New:

  findlang-new-help-fix.diff
  findlang-new-help.diff
  rpm-gcc47.patch



Other differences:
--
++ python3-rpm.spec ++
--- /var/tmp/diff_new_pack.VdGEti/_old  2012-03-20 12:04:51.0 +0100
+++ /var/tmp/diff_new_pack.VdGEti/_new  2012-03-20 12:04:51.0 +0100
@@ -16,7 +16,6 @@
 #
 
 
-
 Name:   python3-rpm
 Version:4.9.1.2
 Release:0

rpm-python.spec: same change
++ rpm.spec ++
--- /var/tmp/diff_new_pack.VdGEti/_old  2012-03-20 12:04:51.0 +0100
+++ /var/tmp/diff_new_pack.VdGEti/_new  2012-03-20 12:04:51.0 +0100
@@ -16,7 +16,6 @@
 #
 
 
-
 Name:   rpm
 BuildRequires:  binutils
 BuildRequires:  bzip2
@@ -118,7 +117,7 @@
 Patch62:pythondeps.diff
 Patch63:fontprovides.diff
 Patch64:rpm-gst-provides.patch
-Patch65:langnoc.diff
+Patch65:findlang-new-help.diff
 Patch66:initscriptsprov.diff
 Patch67:remove-translations.diff
 Patch68:no_rep_autop.diff
@@ -136,6 +135,9 @@
 Patch80:rpm-deptracking.patch
 Patch81:python3-abi-kind.diff
 Patch82:perl-python-attr.patch
+Patch83:findlang-new-help-fix.diff
+Patch84:langnoc.diff
+Patch85:rpm-gcc47.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 #
 # avoid bootstrapping problem
@@ -169,19 +171,20 @@
 Summary:Tools and Scripts to create rpm packages
 Group:  System/Packages
 Requires:   rpm = %{version}
-Provides:   rpmbuild rpm:%_bindir/rpmbuild
+Provides:   rpm:%_bindir/rpmbuild
+Provides:   rpmbuild
 # SUSE's build essentials
-Requires:   bzip2
-Requires:   xz
-Requires:   gzip
 Requires:   binutils
-Requires:   make
+Requires:   bzip2
+Requires:   findutils
 Requires:   gcc
 Requires:   gettext-tools
-Requires:   findutils
-Requires:   patch
 Requires:   glibc-devel
+Requires:   gzip
+Requires:   make
+Requires:   patch
 Requires:   perl-base
+Requires:   xz
 
 %description build
 If you want to build a rpm, you need this package. It provides rpmbuild
@@ -208,7 +211,7 @@
 %patch -P 50 -P 51 -P 52 -P 53 -P 54 -P 55 -P 56 -P 57 -P 58 -P 59
 %patch -P 60 -P 61 -P 62 -P 63 -P 64 -P 65 -P 66 -P 67 -P 68 -P 69
 %patch -P 70 -P 71 -P 72 -P 73 -P 74 -P 75 -P 76 -P 77 -P 78 -P 79 
-%patch -P 80 -P 81 -P 82
+%patch -P 80 -P 81 -P 82 -P 83 -P 84 -P 85
 #chmod 755 scripts/find-supplements{,.ksyms}
 #chmod 755 scripts/find-provides.ksyms scripts/find-requires.ksyms
 #chmod 755 scripts/firmware.prov

++ findlang-new-help-fix.diff ++
Index: scripts/find-lang.sh
===
--- scripts/find-lang.sh.orig
+++ scripts/find-lang.sh
@@ -139,8 +139,8 @@ s:%lang(C) ::
 
 find $TOP_DIR -type d|sed '
 s:'$TOP_DIR'::
-'$NO_ALL_NAME$GNOME's:\(.*/share/help/\)\([^/_]\+\)\(/'$NAME'\)$:%lang(\2) 
%doc \1\2\3/:
-'$ALL_NAME$GNOME's:\(.*/share/help/\)\([^/_]\+\)\(/[a-zA-Z0-9.\_\-]\+\)$:%lang(\2)
 %doc \1\2\3/:
+'$NO_ALL_NAME$GNOME's:\(.*/share/help/\)\([^/_]\+\)\([^/]*\)\(/'$NAME'\)$:%lang(\2)
 %doc \1\2\3\4/:
+'$ALL_NAME$GNOME's:\(.*/share/help/\)\([^/_]\+\)\([^/]*\)\(/[a-zA-Z0-9.\_\-]\+\)$:%lang(\2)
 %doc \1\2\3\4/:
 s:^\([^%].*\)::
 s:%lang(C) ::
 /^$/d'  $MO_NAME_NEW
++ findlang-new-help.diff ++
From 

commit systemd for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package systemd for openSUSE:Factory checked 
in at 2012-03-20 12:04:45

Comparing /work/SRC/openSUSE:Factory/systemd (Old)
 and  /work/SRC/openSUSE:Factory/.systemd.new (New)


Package is systemd, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/systemd/systemd-gtk.changes  2012-03-13 
00:46:06.0 +0100
+++ /work/SRC/openSUSE:Factory/.systemd.new/systemd-gtk.changes 2012-03-20 
12:04:51.0 +0100
@@ -1,0 +2,27 @@
+Mon Mar 19 10:11:23 UTC 2012 - fcro...@suse.com
+
+- Add 0001-util-never-follow-symlinks-in-rm_rf_children.patch: fix
+  CVE-2012-1174 (bnc#752281).
+
+---
+Fri Mar 16 09:21:54 UTC 2012 - fcro...@suse.com
+
+- Update to version 43:
+  + Support optional initialization of the machine ID from the KVM
+or container configured UUID.
+  + Support immediate reboots with systemctl reboot -ff
+  + Show /etc/os-release data in systemd-analyze output
+  + Many bugfixes for the journal, including endianess fixes and
+ensuring that disk space enforcement works
+  + non-UTF8 strings are refused if used in configuration and unit
+files.
+  + Register Mimo USB Screens as suitable for automatic seat
+configuration
+  + Reorder configuration file lookup order. /etc now always
+overrides /run.
+  + manpages for journal utilities.
+- Drop fix-c++-compat.patch, no-tmpfs-fsck.patch,
+  systemd-journald-fix-endianess-bug.patch.
+- Requires util-linux = 2.21 (needed to fix fsck on tmpfs).
+
+---
systemd.changes: same change

Old:

  fix-c++-compat.patch
  no-tmpfs-fsck.patch
  systemd-43.tar.xz
  systemd-journald-fix-endianess-bug.patch

New:

  0001-util-never-follow-symlinks-in-rm_rf_children.patch
  systemd-44.tar.xz



Other differences:
--
++ systemd-gtk.spec ++
--- /var/tmp/diff_new_pack.JGceoI/_old  2012-03-20 12:04:55.0 +0100
+++ /var/tmp/diff_new_pack.JGceoI/_new  2012-03-20 12:04:55.0 +0100
@@ -18,7 +18,7 @@
 
 Name:   systemd-gtk
 Url:http://www.freedesktop.org/wiki/Software/systemd
-Version:43
+Version:44
 Release:0
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  audit-devel

++ systemd.spec ++
--- /var/tmp/diff_new_pack.JGceoI/_old  2012-03-20 12:04:55.0 +0100
+++ /var/tmp/diff_new_pack.JGceoI/_new  2012-03-20 12:04:55.0 +0100
@@ -20,7 +20,7 @@
 
 Name:   systemd
 Url:http://www.freedesktop.org/wiki/Software/systemd
-Version:43
+Version:44
 Release:0
 Summary:A System and Session Manager
 License:GPL-2.0+
@@ -52,7 +52,7 @@
 Requires:   pam-config = 0.79-5
 Requires:   systemd-presets-branding
 Requires:   udev = 172
-Requires:   util-linux = 2.19
+Requires:   util-linux = 2.21
 Recommends: dbus-1-python
 Conflicts:  filesystem  11.5
 Conflicts:  mkinitrd  2.7.0
@@ -86,9 +86,7 @@
 # Never add any patches to this package without the upstream commit id
 # in the patch. Any patches added here without a very good reason to make
 # an exception will be silently removed with the next version update.
-Patch21:no-tmpfs-fsck.patch
-Patch40:systemd-journald-fix-endianess-bug.patch
-Patch41:fix-c++-compat.patch
+Patch40:0001-util-never-follow-symlinks-in-rm_rf_children.patch
 
 %description
 Systemd is a system and service manager, compatible with SysV and LSB
@@ -139,7 +137,6 @@
 %patch15 -p1
 %patch16 -p1
 %patch19 -p1
-%patch21 -p1
 %patch22 -p1
 %patch23 -p1
 %patch24 -p1
@@ -149,7 +146,6 @@
 %patch38 -p1
 %patch39 -p1
 %patch40 -p1
-%patch41 -p1
 
 %build
 autoreconf -fiv

++ 0001-util-never-follow-symlinks-in-rm_rf_children.patch ++
From 5ebff5337594d690b322078c512eb222d34aaa82 Mon Sep 17 00:00:00 2001
From: Michal Schmidt mschm...@redhat.com
Date: Fri, 2 Mar 2012 10:39:10 +0100
Subject: [PATCH] util: never follow symlinks in rm_rf_children()

The function checks if the entry is a directory before recursing, but
there is a window between the check and the open, during which the
directory could be replaced with a symlink.

CVE-2012-1174
https://bugzilla.redhat.com/show_bug.cgi?id=803358
---
 src/util.c |3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

diff --git a/src/util.c b/src/util.c
index 20cbc2b..dfc1dc6 100644
--- a/src/util.c
+++ b/src/util.c
@@ -3593,7 +3593,8 @@ static int rm_rf_children(int fd, bool only_dirs, bool 
honour_sticky) {
 if (is_dir) {
 int subdir_fd;
 
-if ((subdir_fd = openat(fd, de-d_name, 

commit linux-glibc-devel for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package linux-glibc-devel for 
openSUSE:Factory checked in at 2012-03-20 12:04:51

Comparing /work/SRC/openSUSE:Factory/linux-glibc-devel (Old)
 and  /work/SRC/openSUSE:Factory/.linux-glibc-devel.new (New)


Package is linux-glibc-devel, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/linux-glibc-devel/linux-glibc-devel.changes  
2012-01-09 11:15:53.0 +0100
+++ /work/SRC/openSUSE:Factory/.linux-glibc-devel.new/linux-glibc-devel.changes 
2012-03-20 12:04:58.0 +0100
@@ -1,0 +2,10 @@
+Mon Mar 19 12:24:26 UTC 2012 - a...@suse.de
+
+- Update to Linux 3.3 headers.
+
+---
+Fri Mar 16 08:28:51 UTC 2012 - a...@suse.de
+
+- Update version.h text (bnc#751668).
+
+---

Old:

  linux-glibc-devel-3.2.tar.bz2

New:

  linux-glibc-devel-3.3.tar.bz2



Other differences:
--
++ linux-glibc-devel.spec ++
--- /var/tmp/diff_new_pack.ijx83b/_old  2012-03-20 12:04:59.0 +0100
+++ /var/tmp/diff_new_pack.ijx83b/_new  2012-03-20 12:04:59.0 +0100
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 BuildRequires:  fdupes
 
 Name:   linux-glibc-devel
@@ -24,10 +25,10 @@
 BuildArch:  noarch
 # this confusing version number has no meaning, it's the version
 # of the Linux kernel where these headers come from
-Version:3.2.0
+Version:3.3.0
 Release:0
 # A - is not allowed in version
-%define upstream_version 3.2
+%define upstream_version 3.3
 Url:http://www.kernel.org/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Provides:   kernel-headers 
@@ -66,25 +67,26 @@
 #error programs should not directly include linux/*.h or
 #error asm/*.h as well.
 #error 
-#error To build kernel modules please do the following:
-#error 
-#error  o Have the kernel sources installed
-#error 
-#error  o Make sure that the symbolic link
-#error/lib/modules/\`uname -r\`/build exists and points to
-#errorthe matching kernel source directory
-#error 
-#error  o When compiling, make sure to use the following
-#errorcompiler option to use the correct include files:
+#error Since Linux 2.6, the kernel module build process has been
+#error updated such that users building modules should not typically
+#error need to specify additional include directories at all.
+#error 
+#error To build kernel modules, ensure you have the build environment 
+#error available either via the kernel-devel and kernel-flavor-devel 
+#error packages or a properly configured kernel source tree.
+#error 
+#error Then, modules can be built using:
+#error make -C path M=$PWD
+#error 
+#error For the currently running kernel there will be a symbolic 
+#error link pointing to the build environment located at 
+#error /lib/modules/$(uname -r)/build for use as path.
 #error 
-#error-I/lib/modules/\`uname -r\`/build/include
+#error If you are seeing this message, your environment is 
+#error not configured properly. 
 #error 
-#errorinstead of
-#error 
-#error-I/usr/include/linux
-#error 
-#errorPlease adjust the Makefile accordingly.
-#error ===
+#error Please adjust the Makefile accordingly.
+#error ===
 #else
 BOGUS
 # Get LINUX_VERSION_CODE and KERNEL_VERSION directly from kernel

++ linux-glibc-devel-3.2.tar.bz2 - linux-glibc-devel-3.3.tar.bz2 ++
 5241 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit cogl for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package cogl for openSUSE:Factory checked in 
at 2012-03-20 12:04:54

Comparing /work/SRC/openSUSE:Factory/cogl (Old)
 and  /work/SRC/openSUSE:Factory/.cogl.new (New)


Package is cogl, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/cogl/cogl.changes2012-03-01 
09:50:27.0 +0100
+++ /work/SRC/openSUSE:Factory/.cogl.new/cogl.changes   2012-03-20 
12:05:00.0 +0100
@@ -1,0 +2,36 @@
+Tue Mar  6 08:18:28 UTC 2012 - vu...@opensuse.org
+
+- Update to version 1.9.8:
+  + Various Visual Studio build fixes
+  + Correctly check for GL_EXT_packed_depth_stencil and support
+using GL_OES_packed_depth_stencil on GLES2
+  + Correctly handle pre-multiplied alpha conversions when reading
+back texture data.
+  + Added cogl_renderer_{get,set}_driver functions so the
+underlying driver can be chosen programmatically.
+  + Revamped the conformance testing framework so that it
+automatically runs every test against GLES2 as well as GL and
+also against all of the pipeline backends and with npot
+textures disabled.
+  + Add a conformance test for reading back an RGBA texture as
+alpha-only
+  + Added support for converting between all of Cogl's supported
+pixel formats including pre-multiplied alpha conversions.
+  + Added conformance tests for converting to and from all of the
+supported formats.
+  + Added a public cogl_framebuffer_read_pixels_into_bitmap()
+function which will effective read into a CoglPixelBuffer.
+  + CoglPixelBuffer was changed to no longer have associated width,
+height and format information and instead we will rely on
+CoglBitmap to track that informations.
+  + Added public cogl_bitmap_get_{width,height,format,rowstride}
+API
+  + Added a public accessor for the underlying pixel buffer of a
+CoglBitmap.
+  + Added various missing cast macros for some buffer objects.
+  + Ported the Clutter based test-pixel-buffer test to be
+standalone.
+  + Bugs fixed: bgo#666184, bgo#670793, bgo#671016.
+- Rename libcogl8 to libcogl9, following upstream soversion change.
+
+---

Old:

  cogl-1.9.6.tar.xz

New:

  cogl-1.9.8.tar.xz



Other differences:
--
++ cogl.spec ++
--- /var/tmp/diff_new_pack.6cINxe/_old  2012-03-20 12:05:02.0 +0100
+++ /var/tmp/diff_new_pack.6cINxe/_new  2012-03-20 12:05:02.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   cogl
-Version:1.9.6
+Version:1.9.8
 Release:0
 Summary:An object oriented GL/GLES Abstraction/Utility Layer
 License:LGPL-2.1+
@@ -45,7 +45,7 @@
 Cogl is a small open source library for using 3D graphics hardware to draw
 pretty pictures.
 
-%package -n libcogl8
+%package -n libcogl9
 Summary:An object oriented GL/GLES Abstraction/Utility Layer
 Group:  System/Libraries
 Requires:   Mesa
@@ -53,7 +53,7 @@
 # To make the lang package installable
 Provides:   %{name} = %{version}
 
-%description  -n libcogl8
+%description  -n libcogl9
 Cogl is a small open source library for using 3D graphics hardware to draw
 pretty pictures.
 
@@ -91,8 +91,8 @@
 Group:  Development/Libraries/GNOME
 # cogl-defines.h includes GL/gl.h
 Requires:   Mesa-devel
-Requires:   libcogl8 = %{version}
 Requires:   libcogl-pango0 = %{version}
+Requires:   libcogl9 = %{version}
 Requires:   typelib-1_0-Cogl-1_0 = %{version}
 Requires:   typelib-1_0-CoglPango-1_0 = %{version}
 
@@ -117,15 +117,15 @@
 %find_lang cogl
 %fdupes %{buildroot}%{_libdir}/pkgconfig/
 
-%post -n libcogl8 -p /sbin/ldconfig
+%post -n libcogl9 -p /sbin/ldconfig
 
-%postun -n libcogl8 -p /sbin/ldconfig
+%postun -n libcogl9 -p /sbin/ldconfig
 
 %post -n libcogl-pango0 -p /sbin/ldconfig
 
 %postun -n libcogl-pango0 -p /sbin/ldconfig
 
-%files -n libcogl8
+%files -n libcogl9
 %defattr(-,root,root)
 %doc COPYING NEWS README ChangeLog
 %{_libdir}/libcogl.so.*

++ baselibs.conf ++
--- /var/tmp/diff_new_pack.6cINxe/_old  2012-03-20 12:05:02.0 +0100
+++ /var/tmp/diff_new_pack.6cINxe/_new  2012-03-20 12:05:02.0 +0100
@@ -1,3 +1,3 @@
-libcogl8
+libcogl9
   requires Mesa-targettype
 libcogl-pango0

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit php5 for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package php5 for openSUSE:Factory checked in 
at 2012-03-20 12:04:57

Comparing /work/SRC/openSUSE:Factory/php5 (Old)
 and  /work/SRC/openSUSE:Factory/.php5.new (New)


Package is php5, Maintainer is pgaj...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/php5/php5.changes2012-01-06 
11:46:27.0 +0100
+++ /work/SRC/openSUSE:Factory/.php5.new/php5.changes   2012-03-20 
12:05:10.0 +0100
@@ -1,0 +2,44 @@
+Thu Mar  8 19:40:22 UTC 2012 - co...@suse.com
+
+- fix license to spdx.org format
+
+---
+Tue Feb 28 09:08:30 UTC 2012 - pgaj...@suse.com
+
+- fixed build with new pcre (php bug 60986) 
+
+---
+Sat Feb  4 16:35:07 UTC 2012 - crrodrig...@opensuse.org
+
+- Build with -fpie 
+
+---
+Thu Feb  2 21:31:00 UTC 2012 - crrodrig...@opensuse.org
+
+- PHP 5.3.10, fixes CVE-2012-0830.
+
+---
+Sat Jan 28 18:52:35 UTC 2012 - crrodrig...@opensuse.org
+
+- remove unapplied patches 
+
+---
+Wed Jan 18 15:17:02 UTC 2012 - pgaj...@suse.com
+
+- buildrequire libjpeg-devel
+
+---
+Tue Jan 17 08:35:44 UTC 2012 - pgaj...@suse.com
+
+- remove apache module conflict with apache2-worker [bnc#728671]
+- amended README.SUSE instead
+
+---
+Wed Jan 11 01:46:14 UTC 2012 - crrodrig...@opensuse.org
+
+- Update to version 5.3.9
+  * Drop already applied patches
+  * This update only contain minor bug fixes, it is a stop over
+php 5.4.0 that should be out very soon.
+
+---

Old:

  php-5.3.8-CVE-2011-1466.patch
  php-5.3.8-CVE-2011-3379.patch
  php-5.3.8-CVE-2011-4566.patch
  php-5.3.8-CVE-2011-4885.patch
  php-5.3.8.tar.bz2
  php-wrong-page_size.patch
  php5-2g-crash.patch
  suhosin-0.9.32.1.tar.gz

New:

  php-5.3.10-pcre_fullinfo.patch
  php-5.3.10.tar.bz2
  suhosin-0.9.33.tgz



Other differences:
--
++ php5.spec ++
 784 lines (skipped)
 between /work/SRC/openSUSE:Factory/php5/php5.spec
 and /work/SRC/openSUSE:Factory/.php5.new/php5.spec


++ php-5.3.10-pcre_fullinfo.patch ++
http://svn.php.net/viewvc/?view=revisionamp;revision=323096
http://svn.php.net/viewvc/?view=revisionamp;revision=323097
Index: ext/pcre/php_pcre.c
===
--- ext/pcre/php_pcre.c.orig
+++ ext/pcre/php_pcre.c
@@ -241,6 +241,7 @@ PHPAPI pcre_cache_entry* pcre_get_compil
char*pattern;
int  do_study = 0;
int  poptions = 0;
+   int count = 0;
unsigned const char *tables = NULL;
 #if HAVE_SETLOCALE
char*locale = setlocale(LC_CTYPE, NULL);
@@ -252,10 +253,10 @@ PHPAPI pcre_cache_entry* pcre_get_compil
   back the compiled pattern, otherwise go on and compile it. */
if (zend_hash_find(PCRE_G(pcre_cache), regex, regex_len+1, (void 
**)pce) == SUCCESS) {
/*
-* We use a quick pcre_info() check to see whether cache is 
corrupted, and if it
+* We use a quick pcre_fullinfo() check to see whether cache is 
corrupted, and if it
 * is, we flush it and compile the pattern from scratch.
 */
-   if (pcre_info(pce-re, NULL, NULL) == PCRE_ERROR_BADMAGIC) {
+   if (pcre_fullinfo(pce-re, NULL, PCRE_INFO_CAPTURECOUNT, 
count) == PCRE_ERROR_BADMAGIC) {
zend_hash_clean(PCRE_G(pcre_cache));
} else {
 #if HAVE_SETLOCALE
Index: ext/pcre/php_pcre.def
===
--- ext/pcre/php_pcre.def.orig
+++ ext/pcre/php_pcre.def
@@ -4,7 +4,6 @@ php_pcre_copy_substring
 php_pcre_exec
 php_pcre_get_substring
 php_pcre_get_substring_list
-php_pcre_info
 php_pcre_maketables
 php_pcre_study
 php_pcre_version
Index: main/php_compat.h
===
--- main/php_compat.h.orig
+++ main/php_compat.h
@@ -34,7 +34,6 @@
 #define pcre_exec  php_pcre_exec
 #define pcre_get_substring php_pcre_get_substring
 #define pcre_get_substring_listphp_pcre_get_substring_list
-#define pcre_info

commit NetworkManager for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package NetworkManager for openSUSE:Factory 
checked in at 2012-03-20 12:05:16

Comparing /work/SRC/openSUSE:Factory/NetworkManager (Old)
 and  /work/SRC/openSUSE:Factory/.NetworkManager.new (New)


Package is NetworkManager, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/NetworkManager/NetworkManager.changes
2012-03-01 07:25:03.0 +0100
+++ /work/SRC/openSUSE:Factory/.NetworkManager.new/NetworkManager.changes   
2012-03-20 12:05:22.0 +0100
@@ -1,0 +2,30 @@
+Tue Mar 13 16:11:33 UTC 2012 - vu...@opensuse.org
+
+- Add NetworkManager Supplements to
+  NetworkManager-device-plugin-wimax so that it gets automatically
+  installed by default.
+
+---
+Fri Mar  2 19:23:53 UTC 2012 - dims...@opensuse.org
+
+- Update to version 0.9.3.995:
+  + Linux Wireless Extensions (WEXT) support can be disabled at
+configure time with --with-wext=no
+  + IPv6 Privacy Extensions are now enabled by default for new
+connections
+  + Support for checking Internet connectivity has been added
+  + The ifnet system config plugin rewrites config files less often
+- Add pkgconfig(libsoup-2.4) BuildRequires and pass
+  --enable-concheck to configure to enable internet connectivity
+  check.
+
+---
+Wed Feb 29 17:59:27 UTC 2012 - dims...@opensuse.org
+
+- Add with_wimax define, which prepares NM for wimax. If with_wimax
+  is defined to 1:
+  + Add pkgconfig(libiWmxSdk-0) BuildRequires
+  + Change --disable-wimax to --enable-wimax in configure
+  + Create NetworkManager-device-plugin-wimax subpackage
+
+---

Old:

  NetworkManager-0.9.3.990.tar.xz

New:

  NetworkManager-0.9.3.995.tar.xz



Other differences:
--
++ NetworkManager.spec ++
--- /var/tmp/diff_new_pack.pGHneV/_old  2012-03-20 12:05:25.0 +0100
+++ /var/tmp/diff_new_pack.pGHneV/_new  2012-03-20 12:05:25.0 +0100
@@ -19,10 +19,11 @@
 # We cannot enable systemd support right now, as it is exclusive and means we
 # lose ConsoleKit support (bad for sysvinit)
 %define with_systemd 0
+%define with_wimax 0
 
 Name:   NetworkManager
 Url:http://www.gnome.org/projects/NetworkManager/
-Version:0.9.3.990
+Version:0.9.3.995
 Release:0
 Summary:Network Link Manager and User Applications
 License:GPL-2.0+
@@ -53,12 +54,13 @@
 BuildRequires:  pkgconfig(dbus-glib-1)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(gudev-1.0)
-# We should get lib Intel Wimax in here! Remove --disable-wimax
-# from configure when we have it.
-#BuildRequires:  pkgconfig(libiWmxSdk-0)
+%if %{with_wimax}
+BuildRequires:  pkgconfig(libiWmxSdk-0) = 1.5.1
+%endif
 BuildRequires:  pkgconfig(libnl-3.0)
 BuildRequires:  pkgconfig(libnl-genl-3.0)
 BuildRequires:  pkgconfig(libnl-route-3.0)
+BuildRequires:  pkgconfig(libsoup-2.4) = 2.26
 %if %{with_systemd}
 BuildRequires:  pkgconfig(libsystemd-login)
 %endif
@@ -91,6 +93,21 @@
 obtain IP addresses from a DHCP server, and change name servers
 whenever it sees fit.
 
+%if %{with_wimax}
+%package device-plugin-wimax
+Summary:WiMAX support for NetworkManager
+Group:  Productivity/Networking/System
+Supplements:%{name}
+
+%description device-plugin-wimax
+NetworkManager attempts to keep an active network connection available
+at all times.  The point of NetworkManager is to make networking
+configuration and setup as painless and automatic as possible. If
+using DHCP, NetworkManager is intended to replace default routes,
+obtain IP addresses from a DHCP server, and change name servers
+whenever it sees fit.
+%endif
+
 %package devel
 Summary:Libraries and headers for adding NetworkManager support to 
applications
 Group:  Development/Libraries/Other
@@ -176,10 +193,15 @@
 --enable-more-warnings=no \
 --with-pppd-plugin-dir=$pppddir \
 --with-dhclient=/sbin/dhclient \
+--enable-concheck \
 %if %{with_systemd}
 --with-session-tracking=systemd \
 %endif
+%if %{with_wimax}
+--enable-wimax
+%else
 --disable-wimax
+%endif
 %__make %{?_smp_mflags}
 
 %install
@@ -241,7 +263,8 @@
 %doc %{_mandir}/man5/NetworkManager.conf.5*
 %doc %{_mandir}/man5/nm-system-settings.conf.5*
 %doc %{_mandir}/man8/NetworkManager.*
-%{_libdir}/NetworkManager/
+%dir %{_libdir}/NetworkManager/
+%{_libdir}/NetworkManager/libnm-settings-plugin-ifcfg-suse.so
 %dir %{_libdir}/pppd/2.4.5
 %{_libdir}/pppd/2.4.5/nm-pppd-plugin.*
 %{_libexecdir}/nm-avahi-autoipd.action
@@ -265,6 +288,12 @@
 

commit gstreamer-0_10-plugins-bad for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package gstreamer-0_10-plugins-bad for 
openSUSE:Factory checked in at 2012-03-20 12:11:06

Comparing /work/SRC/openSUSE:Factory/gstreamer-0_10-plugins-bad (Old)
 and  /work/SRC/openSUSE:Factory/.gstreamer-0_10-plugins-bad.new (New)


Package is gstreamer-0_10-plugins-bad, Maintainer is 
gnome-maintain...@suse.de

Changes:

--- 
/work/SRC/openSUSE:Factory/gstreamer-0_10-plugins-bad/gstreamer-0_10-plugins-bad.changes
2012-02-16 16:14:42.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.gstreamer-0_10-plugins-bad.new/gstreamer-0_10-plugins-bad.changes
   2012-03-20 12:11:08.0 +0100
@@ -1,0 +2,299 @@
+Fri Mar  2 08:37:20 UTC 2012 - vu...@opensuse.org
+
+- Add a comment about GPL-3.0+ in the tarball, that were
+  mis-licensed by mistake. This is already fixed upstream.
+
+---
+Thu Mar  1 00:39:49 UTC 2012 - reddw...@opensuse.org
+
+- Add support for vo-amrwbenc and vo-aacenc
+
+---
+Thu Feb 23 18:22:31 UTC 2012 - vu...@opensuse.org
+
+- Comment out opencv-devel BuildRequires to avoid building the
+  opencv plugin until bnc#748666 is fixed: opencv currently has
+  dependencies on libqt4-x11 and libxine, and that's not a good
+  thing for a gstreamer plugin.
+
+---
+Tue Feb 21 15:19:29 UTC 2012 - vu...@opensuse.org
+
+- Update to version 0.10.23:
+  + aiffparse: extract ID3 tags embedded in ID3 chunks
+  + amrwbenc: switch to the free vo-amrwbenc library
+  + apexsink: add support for generation 2 AirTunes hardware
+  + applemedia: bump the rank of qtkitvideosrc to PRIMARY
+  + autoconvert: remove the initial-identity property from
+autoconvert, update for basetransform changes in core
+  + avcsrc: add AVC Video Services plugin for OS/X (captures DV or
+HDV video from Firewire port)
+  + basevideo:
+- cater for format conversion
+- fix locking, especially if both pads have different streaming
+  threads
+  + basevideodecoder:
+- add API to drop a frame and post a QoS message on the bus
+- reverse playback support; limited legacy seeking support
+- better caps handling; event handling fixes esp. discont and
+  flush
+  + basevideoencoder:
+- add support for new force-key-unit event API
+- implement preset interface; enable clipping by default
+- proxy the width/height/framerate/PAR constraints of
+  downstream caps to upstream
+  + bayer2rgb: rewrite signal processing and convert to orc for
+better speed
+  + camerabin2:
+- no longer experimental; add flags to disable conversion
+  elements
+- add audio-filter property; countless fixes
+  + camerabin:
+- add image-formatter property
+- prevent audio source from providing clock; reset audiosrc
+  timestamping
+- prevent captures from being lost when switching resolutions
+  + colorspace:
+- add JPEG YCbCr matrix
+- fix odd width and height handling in some fastpath cases
+- fix r210 writing only half a scanline
+  + d3dvideosink: new d3dvideosink element
+  + dc1394src: implement LATENCY query
+  + debugutils: new elements: compare (with memcmp and ssim method)
+and debugspy
+  + decklink:
+- add more modes, connection type, audio-input and
+  subdevice properties
+- add support for Windows; properly set up analog input
+  + decklinksink: add audio support
+  + dfbvideosink: also consider non-accelerated DirectFB surfaces
+  + diracparse: make diracparse work correctly
+  + directdrawsink: handle pixel-aspect-ratio, lower rank to
+secondary
+  + dshowdecwrapper: fix COM initialization
+  + dtmf: post messages when starting to send/receive DTMF
+  + dtmfsrc:
+- align DTMF sound buffers with last-stop from event
+- reject start/stop requests that come out of order
+  + dvbsrc: add timeout property and use (interruptible) GstPoll
+  + element-templates: improve the audiofilter template
+  + faac:
+- add properties for VBR encoding
+- add profile and level to the caps; negotiate output format
+  from downstream caps
+  + facedetect: detect face features (mouth, nose, eyes) and drop
+faces that don't have them
+  + faceoverlay: add element that displays an SVG image over a
+detected face
+  + freeverb: new freeverb element (reverb effect)
+  + h263parse: also extract width and height into caps; propagate
+downstream caps
+  + h264parse:
+- many negotiation and caps-related fixes; propagate downstream
+  caps where appropriate
+- countless parsing and timestamping fixes
+  + hlsdemux:
+- allow bandwidth switching during caching of fragments
+- make more error resilient
+- cache number of 

commit libdbus-c++ for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package libdbus-c++ for openSUSE:Factory 
checked in at 2012-03-20 12:11:21

Comparing /work/SRC/openSUSE:Factory/libdbus-c++ (Old)
 and  /work/SRC/openSUSE:Factory/.libdbus-c++.new (New)


Package is libdbus-c++, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.libdbus-c++.new/libdbus-c++.changes 
2012-03-20 12:11:22.0 +0100
@@ -0,0 +1,18 @@
+---
+Mon Mar 12 08:42:55 UTC 2012 - davejpla...@gmail.com
+
+- Added baselibs.conf for 32 bit compat libs.
+
+---
+Sun Mar 11 11:53:09 UTC 2012 - davejpla...@gmail.com
+
+- Added libdbus-c++-noreturn.patch to fix rpmlint error, will be
+  reported upstream as the comment in the source file suggests that
+  the developer hasn't decided what to do about it yet.
+
+---
+Sat Feb 25 08:20:55 UTC 2012 - davejpla...@gmail.com
+
+- Created package dbus-c++ for ffado svn build.
+- See bnc#747391  bnc#736115
+

New:

  baselibs.conf
  libdbus-c++-0.9.0.tar.bz2
  libdbus-c++-gcc47.patch
  libdbus-c++-nodocdatetime.patch
  libdbus-c++-noreturn.patch
  libdbus-c++-pthread.patch
  libdbus-c++.changes
  libdbus-c++.spec



Other differences:
--
++ libdbus-c++.spec ++
#
# spec file for package libdbus-c++
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:   libdbus-c++
Version:0.9.0
Release:0
Summary:C++ Interface for DBus
License:LGPL-2.1+
Group:  System/Libraries
Url:http://dbus-cplusplus.sourceforge.net/index.html
Source0:%{name}-%{version}.tar.bz2
Source1:baselibs.conf
# Fix no return from function
Patch0: libdbus-c++-noreturn.patch
# Get ffado to build with libdbus-c++
Patch1: libdbus-c++-pthread.patch
# No current date / time allowed in docs?
Patch2: libdbus-c++-nodocdatetime.patch
# Fix gcc47 build errors
Patch3: libdbus-c++-gcc47.patch
BuildRequires:  autoconf
BuildRequires:  automake
BuildRequires:  dos2unix
BuildRequires:  doxygen
BuildRequires:  fdupes
BuildRequires:  gcc-c++
BuildRequires:  graphviz
BuildRequires:  gtkmm2-devel
BuildRequires:  libexpat-devel
BuildRequires:  libtool
BuildRequires:  pkgconfig
BuildRequires:  pkgconfig(dbus-1)
BuildRequires:  pkgconfig(dbus-glib-1)
# ecore
%if 0%{?suse_version} = 1030
BuildRequires:  libexpat-devel
%else
BuildRequires:  expat
%endif
BuildRoot:  %{_tmppath}/%{name}-%{version}-build

%description
DBus-c++ attempts to provide a C++ API for D-BUS. The library has
a glib and an ecore mainloop integration. It also offers an
optional own main loop.

%package -n libdbus-c++-1-0
Summary:The libdbus-c++ library
Group:  System/Libraries

%description -n libdbus-c++-1-0
DBus-c++ attempts to provide a C++ API for D-BUS. The library has
a glib and an ecore mainloop integration. It also offers an
optional own main loop. The libdbus-c++ library.

%package -n libdbus-c++-glib-1-0
Summary:Glib for libdbus-c++
Group:  System/Libraries

%description -n libdbus-c++-glib-1-0
DBus-c++ attempts to provide a C++ API for D-BUS. The library has
a glib and an ecore mainloop integration. It also offers an
optional own main loop. The glib libdbus-c++ library.

%package devel
Summary:Development files for libdbus-c++
Group:  Development/Libraries/C and C++
Requires:   libdbus-c++-1-0 = %{version}
Requires:   libdbus-c++-glib-1-0 = %{version}

%description devel
DBus-c++ attempts to provide a C++ API for D-BUS. The library has
a glib and an ecore mainloop integration. It also offers an
optional own main loop. Files for building against libdbus-c++

%prep

%setup -q
%patch0
%patch1
%patch2
%patch3

%build
#./autogen.sh
# FIXME: for some strange reason the 32 bit build needs -lpthread.
%ifarch x86_64
export LDFLAGS=$LDFLAGS -lexpat
%else
export LDFLAGS=$LDFLAGS -lexpat 

commit mjpegtools for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package mjpegtools for openSUSE:Factory 
checked in at 2012-03-20 12:11:34

Comparing /work/SRC/openSUSE:Factory/mjpegtools (Old)
 and  /work/SRC/openSUSE:Factory/.mjpegtools.new (New)


Package is mjpegtools, Maintainer is vdziewie...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/mjpegtools/mjpegtools.changes2011-12-08 
11:53:27.0 +0100
+++ /work/SRC/openSUSE:Factory/.mjpegtools.new/mjpegtools.changes   
2012-03-20 12:11:36.0 +0100
@@ -1,0 +2,5 @@
+Thu Mar 15 19:38:49 UTC 2012 - dims...@opensuse.org
+
+- Add mjpegtools-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  mjpegtools-gcc47.patch



Other differences:
--
++ mjpegtools.spec ++
--- /var/tmp/diff_new_pack.rg4mMd/_old  2012-03-20 12:11:37.0 +0100
+++ /var/tmp/diff_new_pack.rg4mMd/_new  2012-03-20 12:11:37.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package mjpegtools
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,12 +15,14 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   mjpegtools
 Version:2.0.0
 Release:0
 Summary:MJPEG Video Capture and Processing Tools
-Url:http://mjpeg.sourceforge.net/
+License:BSD-3-Clause ; GPL-2.0+
 Group:  Productivity/Multimedia/Video/Editors and Convertors
+Url:http://mjpeg.sourceforge.net/
 %if 0%{?BUILD_ORIG}
 Source0:
http://sourceforge.net/projects/mjpeg/files/mjpegtools/%{version}/mjpegtools-%{version}.tar.gz
 %else
@@ -28,7 +30,6 @@
 #%(sh %{_sourcedir}/mjpegtools-codecpatch.sh %{_sourcedir} 
mjpegtools-%{version}.tar.gz mjpegtools-%{version}-patched.tar.gz )
 Source0:%{name}-%{version}-patched.tar.gz
 %endif
-License:BSD-3-Clause ; GPL-2.0+
 Source1:mjpegtools-codecpatch.sh
 Patch0: mjpegtools-cpuinfo.patch
 Patch1: mjpegtools-vector_alignment.patch
@@ -37,6 +38,7 @@
 Patch4: mjpegtools-no_arch_tuning.patch
 Patch5: mjpegtools-config_h.patch
 Patch6: mjpegtools-v4l-2.6.38.patch
+Patch7: mjpegtools-gcc47.patch
 Patch100:   mjpegtools-codecpatch.patch
 BuildRequires:  gcc-c++
 BuildRequires:  libjpeg-devel
@@ -51,8 +53,8 @@
 %if 0%{?suse_version} = 1210
 BuildRequires:  pkgconfig(libv4l1)
 %endif
-BuildRequires:  pkgconfig(sdl)
 BuildRequires:  pkgconfig(SDL_gfx)
+BuildRequires:  pkgconfig(sdl)
 Requires(post):  info
 Requires(preun): info
 
@@ -100,6 +102,7 @@
 %if 0%{?suse_version} = 1210
 %patch6
 %endif
+%patch7 -p1
 %if ! 0%{?BUILD_ORIG}
 # remove references to files removed by %%{name}-codecpatch.sh
 %patch100

++ mjpegtools-2.0.0-patched.tar.gz ++

++ mjpegtools-gcc47.patch ++
Index: mjpegtools-2.0.0/y4mdenoise/MotionSearcher.hh
===
--- mjpegtools-2.0.0.orig/y4mdenoise/MotionSearcher.hh
+++ mjpegtools-2.0.0/y4mdenoise/MotionSearcher.hh
@@ -2196,7 +2196,7 @@ MotionSearcherPIXEL_NUM,DIM,PIXEL_TOL,P
{
// This region is too small to be bothered with.
// Just get rid of it.
-   DeleteRegion (a_pRegion);
+   this-DeleteRegion (a_pRegion);
}
else
{
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-celery for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package python-celery for openSUSE:Factory 
checked in at 2012-03-20 12:11:44

Comparing /work/SRC/openSUSE:Factory/python-celery (Old)
 and  /work/SRC/openSUSE:Factory/.python-celery.new (New)


Package is python-celery, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.python-celery.new/python-celery.changes 
2012-03-20 12:11:45.0 +0100
@@ -0,0 +1,476 @@
+---
+Mon Mar 19 10:32:04 UTC 2012 - cfarr...@suse.com
+
+- license update: BSD-3-Clause
+  See LICENSE file
+
+---
+Wed Mar 14 10:29:11 UTC 2012 - sasc...@suse.de
+
+- Don't buildrequire pymongo, it's not yet in Factory and only needed to let
+  some additional tests pass. It's however still suggested.
+
+---
+Sat Mar 10 17:44:01 UTC 2012 - sasc...@gmx.de
+
+- Suggest python-eventlet, python-gevent, python-pymongo, python-pytyrant
+- Recommend python-curses, python-pyOpenSSL
+- Run testsuite
+- Changes file cleanup
+
+---
+Thu Mar  1 17:47:07 UTC 2012 - alexan...@exatati.com.br
+
+- Update to 2.5.1:
+  * Eventlet/Gevent: A small typo caused celeryd to hang when eventlet/gevent
+was used, this was because the environment was not monkey patched
+early enough.
+  * Eventlet/Gevent: Another small typo caused the mediator to be started
+with eventlet/gevent, which would make celeryd sometimes hang at shutdown.
+  * Mulitprocessing: Fixed an error occurring if the pool was stopped
+before it was properly started.
+  * Proxy objects now redirects __doc__ and __name__ so help(obj)
+works.
+  * Internal timer (timer2) now logs exceptions instead of swallowing them
+  * celeryctl shell: can now be started with --eventlet or
+--gevent options to apply their monkey patches.
+
+---
+Fri Feb 24 22:26:12 UTC 2012 - alexan...@exatati.com.br
+
+- Update to 2.5.0:
+  - Considerable size of changelog, please read
+http://docs.celeryproject.org/en/latest/whatsnew-2.5.html or
+the Changelog file inside the package.
+
+---
+Wed Dec 28 17:52:49 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 2.4.6:
+  - The group id was not changed if both --uid and --gid specified.
+
+---
+Fri Dec  2 23:43:13 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 2.4.5:
+  - Periodic task interval schedules were accidentally rounded down,
+resulting in some periodic tasks being executed early.
+  - Logging of humanized times in the celerybeat log is now more detailed.
+  - New brokers section in the Getting Started part of the Documentation
+This replaces the old tut-otherqueues tutorial, and adds
+documentation for MongoDB, Beanstalk and CouchDB.
+
+---
+Fri Nov 25 21:56:24 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 2.4.4:
+  - [Security: CELERYSA-0001] Daemons would set effective id’s
+rather than real id’s when the --uid/--gid arguments to
+celeryd-multi, celeryd_detach, celerybeat and celeryev were used.
+  - Processes pool: Fixed rare deadlock at shutdown
+  - Webhook tasks issued the wrong HTTP POST headers
+The Content-Type header has been changed from
+application/json ⇒ application/x-www-form-urlencoded, and adds
+a proper Content-Length header.
+  - Daemonization cookbook: Adds a configuration example using
+Django and virtualenv together
+  - Generic init scripts now automatically creates log and pid
+file directories
+
+---
+Tue Nov 22 22:25:20 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 2.4.3:
+  * Fixes module import typo in celeryctl
+
+---
+Mon Nov 14 12:35:54 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 2.4.2:
+  - Program module no longer uses relative imports so that it is
+possible to do python -m celery.bin.name.
+
+---
+Mon Nov  7 23:26:56 UTC 2011 - alexan...@exatati.com.br
+
+- Update to 2.4.1:
+  * celeryctl inspect commands was missing output.
+  * processes pool: Decrease polling interval for less idle CPU usage.
+  * processes pool: MaybeEncodingError was not wrapped in ExceptionInfo
+  * celeryd: would silence errors occuring after task consumer started.
+  * logging: Fixed a bug where 

commit sword for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package sword for openSUSE:Factory checked 
in at 2012-03-20 12:11:55

Comparing /work/SRC/openSUSE:Factory/sword (Old)
 and  /work/SRC/openSUSE:Factory/.sword.new (New)


Package is sword, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/sword/sword.changes  2011-09-23 
12:47:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.sword.new/sword.changes 2012-03-20 
12:11:57.0 +0100
@@ -1,0 +2,5 @@
+Fri Mar 16 17:43:53 UTC 2012 - dims...@opensuse.org
+
+- Add sword-gcc47.patch: Fix build with gcc 4.7.
+
+---

Old:

  sword-1.6.2-fix_build_with_new_curl.patch
  sword-1.6.2.tar.bz2

New:

  sword-1.6.2+svn2679.tar.bz2
  sword-gcc47.patch



Other differences:
--
++ sword.spec ++
--- /var/tmp/diff_new_pack.w1KkEG/_old  2012-03-20 12:11:58.0 +0100
+++ /var/tmp/diff_new_pack.w1KkEG/_new  2012-03-20 12:11:58.0 +0100
@@ -1,24 +1,35 @@
 #
 # spec file for package sword
 #
-# This file and all modifications and additions to the pristine
-# package are under the same license as the package itself.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An Open Source License is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
 
 %define libver 1_6_2
+%definelibinstver 1.6.2
 
 Name:   sword
-Version:1.6.2
-Release:1
-License:GPL-2.0
+Version:1.6.2+svn2679
+Release:0
 Summary:Framework for manipulating Bible texts
-Url:http://www.crosswire.org/sword
+License:GPL-2.0
 Group:  Development/Libraries/C and C++
+Url:http://www.crosswire.org/sword
 Source0:%{name}-%{version}.tar.bz2
 Patch1: sword-1.6.1-fix_compiler_warnings.patch
 Patch2: sword-1.6.1-curl.patch
-Patch3: sword-1.6.2-fix_build_with_new_curl.patch
+Patch3: sword-gcc47.patch
 Requires:   libsword-%{libver} = %version
 BuildRequires:  curl-devel
 BuildRequires:  gcc-c++
@@ -45,8 +56,18 @@
 # Mandriva
 #
 %if 0%{?mandriva_version}
+%ifarch x86_64
+BuildRequires:  lib64clucene-devel
+%else
 BuildRequires:  libclucene-devel
 %endif
+%endif
+#
+# CentOS
+#
+%if ( %{defined centos_version}  0%{?centos_version}  600 )
+BuildRequires:  sqlite
+%endif
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -69,7 +90,11 @@
 %package devel
 Summary:Include files and static libraries for developing sword 
applications
 Group:  Development/Libraries/Other
+%if 0%{?centos_version}  600
+Requires:   curl-devel
+%else
 Requires:   libcurl-devel
+%endif
 Requires:   sword = %{version}
 
 %description devel
@@ -80,9 +105,14 @@
 %setup -q
 %patch1
 %patch2
-%patch3
+%patch3 -p1
 
 %build
+
+%if 0%{?mandriva_version}
+autoreconf
+%endif
+
 %configure --disable-static \
--with-icu \
--enable-tests \
@@ -148,7 +178,7 @@
 %files -n libsword-%{libver}
 %defattr(-,root,root)
 %doc LICENSE
-%{_libdir}/libsword-%{version}.so
+%{_libdir}/libsword-%{libinstver}.so
 
 %files devel
 %defattr(-,root,root)
@@ -156,6 +186,6 @@
 %{_includedir}/*
 %{_libdir}/pkgconfig/sword.pc
 %{_libdir}/*.so
-%exclude %{_libdir}/libsword-%{version}.so
+%exclude %{_libdir}/libsword-%{libinstver}.so
 
 %changelog

++ sword-gcc47.patch ++
Index: sword-1.6.2+svn2679/include/multimapwdef.h
===
--- sword-1.6.2+svn2679.orig/include/multimapwdef.h
+++ sword-1.6.2+svn2679/include/multimapwdef.h
@@ -19,14 +19,14 @@ public:
}
 
T operator[](const Key k) {
-   if (find(k) == this-end()) {
-   insert(value_type(k, T()));
+   if (this-find(k) == this-end()) {
+   this-insert(value_type(k, T()));
}
-   return (*(find(k))).second;
+   return (*(this-find(k))).second;
}
bool has(const Key k, const T val) const {
-   typename std::multimapKey, T, Compare::const_iterator start = 
lower_bound(k);
-   

drop libxcrypt from openSUSE:Factory

2012-03-20 Thread h_root

Hello community,

FYI: Package libxcrypt was dropped from openSUSE:Factory at Tue Mar 20 12:16:16 
CET 2012.

You can find the latest sources of the package in the
   openSUSE:Dropped
repository:

https://build.opensuse.org/package/show?project=openSUSE:Droppedpackage=libxcrypt

Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit nginx-1.0 for openSUSE:12.1:Update:Test

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package nginx-1.0 for 
openSUSE:12.1:Update:Test checked in at 2012-03-20 13:22:19

Comparing /work/SRC/openSUSE:12.1:Update:Test/nginx-1.0 (Old)
 and  /work/SRC/openSUSE:12.1:Update:Test/.nginx-1.0.new (New)


Package is nginx-1.0, Maintainer is sch...@suse.com

Changes:

--- /work/SRC/openSUSE:12.1:Update:Test/nginx-1.0/nginx-1.0.changes 
2011-12-02 17:28:50.0 +0100
+++ /work/SRC/openSUSE:12.1:Update:Test/.nginx-1.0.new/nginx-1.0.changes
2012-03-20 13:22:21.0 +0100
@@ -1,0 +2,6 @@
+Mon Mar 19 11:26:04 UTC 2012 - sch...@suse.com
+
+- Fixed VUL-0: CVE-2012-1180 nginx: information leak 
+  (bnc #752482)
+
+---

New:

  nginx-CVE-2012-1180.patch



Other differences:
--
++ nginx-1.0.spec ++
--- /var/tmp/diff_new_pack.hdckS9/_old  2012-03-20 13:22:21.0 +0100
+++ /var/tmp/diff_new_pack.hdckS9/_new  2012-03-20 13:22:21.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package nginx-1.0
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,8 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
+
 Name:   nginx-1.0
 Version:1.0.10
 Release:0
@@ -90,7 +92,10 @@
 Patch3: nginx-0.4.0-perl_vendor_install.patch
 # PATCH-FIX-UPSTREAM nginx-1.0.4_default_config.patch
 Patch4: nginx-1.0.4_default_config.patch
+# PATCH CVE-2012-1180
+Patch5: nginx-CVE-2012-1180.patch
 Summary:A HTTP server and IMAP/POP3 proxy server
+
 %description
 nginx [engine x] is a HTTP server and IMAP/POP3 proxy server written by Igor 
Sysoev.
 It has been running on many heavily loaded Russian sites for more than two 
years.
@@ -105,6 +110,7 @@
 %patch2
 %patch3
 %patch4
+%patch5
 
 perl -pi -e 's|\r\n|\n|g' contrib/geo2nginx.pl
 

++ nginx-CVE-2012-1180.patch ++
--- src/http/modules/ngx_http_fastcgi_module.c
+++ src/http/modules/ngx_http_fastcgi_module.c
@@ -1442,10 +1442,10 @@
 h-lowcase_key = h-key.data + h-key.len + 1
  + h-value.len + 1;
 
-ngx_cpystrn(h-key.data, r-header_name_start,
-h-key.len + 1);
-ngx_cpystrn(h-value.data, r-header_start,
-h-value.len + 1);
+ngx_memcpy(h-key.data, r-header_name_start, h-key.len);
+h-key.data[h-key.len] = '\0';
+ngx_memcpy(h-value.data, r-header_start, h-value.len);
+h-value.data[h-value.len] = '\0';
 }
 
 h-hash = r-header_hash;
--- src/http/modules/ngx_http_proxy_module.c
+++ src/http/modules/ngx_http_proxy_module.c
@@ -1277,8 +1277,10 @@
 h-value.data = h-key.data + h-key.len + 1;
 h-lowcase_key = h-key.data + h-key.len + 1 + h-value.len + 1;
 
-ngx_cpystrn(h-key.data, r-header_name_start, h-key.len + 1);
-ngx_cpystrn(h-value.data, r-header_start, h-value.len + 1);
+ngx_memcpy(h-key.data, r-header_name_start, h-key.len);
+h-key.data[h-key.len] = '\0';
+ngx_memcpy(h-value.data, r-header_start, h-value.len);
+h-value.data[h-value.len] = '\0';
 
 if (h-key.len == r-lowcase_index) {
 ngx_memcpy(h-lowcase_key, r-lowcase_header, h-key.len);
--- src/http/modules/ngx_http_scgi_module.c
+++ src/http/modules/ngx_http_scgi_module.c
@@ -894,8 +894,10 @@
 h-value.data = h-key.data + h-key.len + 1;
 h-lowcase_key = h-key.data + h-key.len + 1 + h-value.len + 1;
 
-ngx_cpystrn(h-key.data, r-header_name_start, h-key.len + 1);
-ngx_cpystrn(h-value.data, r-header_start, h-value.len + 1);
+ngx_memcpy(h-key.data, r-header_name_start, h-key.len);
+h-key.data[h-key.len] = '\0';
+ngx_memcpy(h-value.data, r-header_start, h-value.len);
+h-value.data[h-value.len] = '\0';
 
 if (h-key.len == r-lowcase_index) {
 ngx_memcpy(h-lowcase_key, r-lowcase_header, h-key.len);
--- src/http/modules/ngx_http_uwsgi_module.c
+++ src/http/modules/ngx_http_uwsgi_module.c
@@ -944,8 +944,10 @@
 h-value.data = h-key.data + h-key.len + 1;
 h-lowcase_key = h-key.data + h-key.len + 1 + h-value.len + 1;
 
-ngx_cpystrn(h-key.data, r-header_name_start, h-key.len + 1);
-

drop fonts-arabic from openSUSE:Factory

2012-03-20 Thread h_root

Hello community,

FYI: Package fonts-arabic was dropped from openSUSE:Factory at Tue Mar 20 
13:23:36 CET 2012.

You can find the latest sources of the package in the
   openSUSE:Dropped
repository:

https://build.opensuse.org/package/show?project=openSUSE:Droppedpackage=fonts-arabic

Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit clamav for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package clamav for openSUSE:Factory checked 
in at 2012-03-20 13:28:55

Comparing /work/SRC/openSUSE:Factory/clamav (Old)
 and  /work/SRC/openSUSE:Factory/.clamav.new (New)


Package is clamav, Maintainer is m...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/clamav/clamav.changes2012-03-20 
01:58:54.0 +0100
+++ /work/SRC/openSUSE:Factory/.clamav.new/clamav.changes   2012-03-20 
13:28:56.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar 17 19:36:17 UTC 2012 - dims...@opensuse.org
+
+- Add clamav-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  clamav-gcc47.patch



Other differences:
--
++ clamav.spec ++
--- /var/tmp/diff_new_pack.GBd5Vk/_old  2012-03-20 13:28:59.0 +0100
+++ /var/tmp/diff_new_pack.GBd5Vk/_new  2012-03-20 13:28:59.0 +0100
@@ -61,6 +61,7 @@
 Source5:clamav-rcmilter
 Patch1: clamav-conf.patch
 Patch2: clamav-sles9.patch
+Patch3: clamav-gcc47.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -129,6 +130,7 @@
 # SLES9's libmilter doesn't have smfi_insheader()
 %patch2
 %endif
+%patch3 -p1
 
 %build
 %if 0%{?suse_version} = 1010

++ clamav-gcc47.patch ++
Index: clamav-0.97.3/libclamav/c++/llvm/lib/ExecutionEngine/JIT/Intercept.cpp
===
--- clamav-0.97.3.orig/libclamav/c++/llvm/lib/ExecutionEngine/JIT/Intercept.cpp
+++ clamav-0.97.3/libclamav/c++/llvm/lib/ExecutionEngine/JIT/Intercept.cpp
@@ -15,6 +15,7 @@
 //
 
//===--===//
 
+#include unistd.h
 #include JIT.h
 #include llvm/Support/ErrorHandling.h
 #include llvm/System/DynamicLibrary.h
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit ding-libs for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package ding-libs for openSUSE:Factory 
checked in at 2012-03-20 13:29:02

Comparing /work/SRC/openSUSE:Factory/ding-libs (Old)
 and  /work/SRC/openSUSE:Factory/.ding-libs.new (New)


Package is ding-libs, Maintainer is rha...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/ding-libs/ding-libs.changes  2011-09-23 
01:55:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.ding-libs.new/ding-libs.changes 2012-03-20 
13:29:17.0 +0100
@@ -1,0 +2,7 @@
+Sun Mar 11 19:24:54 UTC 2012 - jeng...@medozas.de
+
+- Update to new upstream release 0.1.3
+* Fixes a serious bug in libdhash with very large (1024 slots)
+  initial size
+
+---

Old:

  Fix-license-text-for-several-files-that-should-be-LGPLv3+.patch
  ding-libs-0.1.2.tar.bz2

New:

  ding-libs-0.1.3.tar.bz2
  pkgconfig-deps.diff



Other differences:
--
++ ding-libs.spec ++
--- /var/tmp/diff_new_pack.p5ntEO/_old  2012-03-20 13:29:18.0 +0100
+++ /var/tmp/diff_new_pack.p5ntEO/_new  2012-03-20 13:29:18.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package ding-libs
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -14,33 +14,34 @@
 
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
-
-
-%global path_utils_version 0.2.1
-%global dhash_version 0.4.2
 %global collection_version 0.6.0
-%global ref_array_version 0.1.1
+%global dhash_version 0.4.3
 %global ini_config_version 0.6.1
+%global path_utils_version 0.2.1
+%global ref_array_version 0.1.1
 
 Name:   ding-libs
-Version:0.1.2
-Release:1
+Version:0.1.3
+Release:0
 Summary:Ding is not GLib assorted utility libraries
-Group:  Development/Libraries/C and C++
 License:LGPL-3.0+
+Group:  Development/Libraries/C and C++
 Url:http://fedorahosted.org/sssd/
+
+#DL-URL:   https://fedorahosted.org/sssd/wiki/Releases
+#Git-Clone:git://git.fedorahosted.org/ding-libs
 Source0:%{name}-%{version}.tar.bz2
 Source2:baselibs.conf
 Patch0: doxygen-notimestamp.dif
-Patch1: Fix-license-text-for-several-files-that-should-be-LGPLv3+.patch
+Patch1: pkgconfig-deps.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 ### Build Dependencies ###
 BuildRequires:  autoconf
 BuildRequires:  automake
+BuildRequires:  doxygen
 BuildRequires:  libtool
 BuildRequires:  m4
-BuildRequires:  doxygen
 BuildRequires:  pkg-config
 
 %description
@@ -53,10 +54,9 @@
 
 %package -n libpath_utils1
 Summary:Filesystem Path Utilities
-Group:  Development/Libraries/C and C++
-License:LGPL-3.0+
+Group:  System/Libraries
 Version:%{path_utils_version}
-Release:1
+Release:0
 
 %description -n libpath_utils1
 Utility functions to manipulate filesystem pathnames
@@ -65,9 +65,8 @@
 Summary:Development files for libpath_utils
 Group:  Development/Libraries/C and C++
 Requires:   libpath_utils1 = %{path_utils_version}
-License:LGPL-3.0+
 Version:%{path_utils_version}
-Release:1
+Release:0
 
 %description -n libpath_utils-devel
 Utility functions to manipulate filesystem pathnames
@@ -95,11 +94,10 @@
 ##
 
 %package -n libdhash1
-Group:  Development/Libraries/C and C++
 Summary:Dynamic hash table
-License:LGPL-3.0+
+Group:  System/Libraries
 Version:%{dhash_version}
-Release:1
+Release:0
 
 %description -n libdhash1
 A hash table which will dynamically resize to achieve optimal storage  access
@@ -109,9 +107,8 @@
 Summary:Development files for libdhash
 Group:  Development/Libraries/C and C++
 Requires:   libdhash1 = %{dhash_version}
-License:LGPL-3.0+
 Version:%{dhash_version}
-Release:1
+Release:0
 
 %description -n libdhash-devel
 A hash table which will dynamically resize to achieve optimal storage  access
@@ -123,8 +120,7 @@
 
 %files -n libdhash1
 %defattr(-,root,root,-)
-%{_libdir}/libdhash.so.1
-%{_libdir}/libdhash.so.1.0.0
+%{_libdir}/libdhash.so.1*
 
 %files -n libdhash-devel
 %defattr(-,root,root,-)
@@ -141,10 +137,9 @@
 
 %package -n libcollection2
 Summary:Collection data-type for C
-Group:  Development/Libraries/C and C++
-License:LGPL-3.0+
+Group:

commit pwlib for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package pwlib for openSUSE:Factory checked 
in at 2012-03-20 13:29:25

Comparing /work/SRC/openSUSE:Factory/pwlib (Old)
 and  /work/SRC/openSUSE:Factory/.pwlib.new (New)


Package is pwlib, Maintainer is dli...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/pwlib/pwlib.changes  2012-02-14 
11:26:28.0 +0100
+++ /work/SRC/openSUSE:Factory/.pwlib.new/pwlib.changes 2012-03-20 
13:29:27.0 +0100
@@ -1,0 +2,10 @@
+Tue Mar 20 10:25:04 UTC 2012 - idon...@suse.com
+
+- Use versioned Provides/Obsoletes 
+
+---
+Thu Mar 15 21:13:44 UTC 2012 - dims...@opensuse.org
+
+- Add pwlib-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  pwlib-gcc47.patch



Other differences:
--
++ pwlib.spec ++
--- /var/tmp/diff_new_pack.EYDzrM/_old  2012-03-20 13:29:28.0 +0100
+++ /var/tmp/diff_new_pack.EYDzrM/_new  2012-03-20 13:29:28.0 +0100
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   pwlib
 Summary:Portable Windows Library from Equivalence Pty. Ltd
 License:MPL-1.0
@@ -32,6 +33,7 @@
 Patch3: %{name}-v1_11_0-ldap.patch
 Patch4: %{name}-v1_11_0-openssl.patch
 Patch5: %{name}-v4l-2.6.38.patch
+Patch6: pwlib-gcc47.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  SDL-devel
 BuildRequires:  automake
@@ -45,8 +47,12 @@
 %if 0%{?suse_version} = 1210
 BuildRequires:  libv4l-devel = 0.8.4
 %endif
-Provides:   %{name}-plugins-alsa %{name}-plugins-oss %{name}-plugins-v4l
-Obsoletes:  %{name}-plugins-alsa %{name}-plugins-oss %{name}-plugins-v4l
+Provides:   %{name}-plugins-alsa = %{version}-%{release}
+Provides:   %{name}-plugins-oss = %{version}-%{release}
+Provides:   %{name}-plugins-v4l = %{version}-%{release}
+Obsoletes:  %{name}-plugins-alsa  %{version}-%{release}
+Obsoletes:  %{name}-plugins-oss  %{version}-%{release}
+Obsoletes:  %{name}-plugins-v4l  %{version}-%{release}
 
 %define debug_package_requires libpt1_11 = %{version}-%{release}
 
@@ -69,8 +75,11 @@
 %package devel
 Summary:The pwlib package for developers (includes headers and scripts)
 Group:  Development/Libraries/C and C++
+Requires:   SDL-devel
+Requires:   libexpat-devel
 Requires:   libpt1_11 = %{version}
-Requires:   SDL-devel libexpat-devel openldap2-devel openssl-devel
+Requires:   openldap2-devel
+Requires:   openssl-devel
 
 %description devel
 This package includes header files and scripts needed for developers
@@ -102,6 +111,7 @@
 %if 0%{?suse_version} = 1210
 %patch5 -p1
 %endif
+%patch6 -p1
 
 %build
 #autoreconf --force --install

++ pwlib-gcc47.patch ++
Index: pwlib_v1_11_0/include/ptlib/array.h
===
--- pwlib_v1_11_0.orig/include/ptlib/array.h
+++ pwlib_v1_11_0/include/ptlib/array.h
@@ -632,7 +632,7 @@ template class T class PScalarArray :
   T t;
   stream  t;
   if (!stream.fail())
-SetAt(index, t);
+this-SetAt(index, t);
 }
 };
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rubygem-highline for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package rubygem-highline for 
openSUSE:Factory checked in at 2012-03-20 13:29:42

Comparing /work/SRC/openSUSE:Factory/rubygem-highline (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-highline.new (New)


Package is rubygem-highline, Maintainer is mrueck...@suse.com

Changes:

New Changes file:

--- /dev/null   2012-03-17 10:42:43.883537212 +0100
+++ /work/SRC/openSUSE:Factory/.rubygem-highline.new/rubygem-highline.changes   
2012-03-20 13:29:43.0 +0100
@@ -0,0 +1,86 @@
+---
+Fri Mar  9 09:03:55 UTC 2012 - sasc...@suse.de
+
+- Fix wrong shebang lines
+
+---
+Thu Mar  8 08:53:45 UTC 2012 - sasc...@suse.de
+
+- Update to version 1.6.11:
+  * Fixed a bad test.  (Fix by Diego Elio Pettenò.)
+- Changes from version 1.6.10:
+  * Fixed a regression that prevented asking for String arguments (by Jeffery
+  Sman.)
+  * Fixed a testing incompatibility (by Hans de Graaff.)
+- Changes from version 1.6.9:
+  * The new list modes now properly ignore escapes when sizing.
+  * Added a project gemspec file.
+  * Fixed a bug that prevented the use of termios (by tomdz).
+  * Switch to JLine to provide better echo support on JRuby (by tomdz).
+- Changes from version 1.6.8:
+  * Fix missing ttERASE_CHAR/tt reference (by Aaron Gifford).
+- See CHANGELOG for previous versions...
+
+
+---
+Thu Aug 18 12:46:23 UTC 2011 - mrueck...@suse.de
+
+- update to version 1.6.2
+  - Correctly handle STDIN being closed before we receive any data
+(fix by mleinart).
+  - Try if msvcrt, if we can't load crtdll on Windows
+(fix by pepijnve).
+  - A fix for nil_on_handled not running the action
+(reported by Andrew Davey).
+
+---
+Wed Dec 15 11:16:08 UTC 2010 - pu...@novell.com
+
+- update to version 1.6.1
+  * Fixed raw_no_echo_mode so that it uses stty -icanon rather than
+cbreak as cbreak does not appear to be the posixly correct
+argument.  It fails on Solaris if cbreak is used.
+  * Fixed an issue that kept Menu from showing the correct choices
+for disambiguation.
+  * Removed a circular require that kept Ruby 1.9.2 from loading
+HighLine.
+  * Fixed a bug that caused infinite looping when wrapping text
+without spaces.
+  * Fixed it so that :auto paging accounts for the two lines it
+adds.
+  * On JRuby, improved error message about ffi-ncurses.  Before
+1.5.3, HighLine was silently swallowing error messages when
+ffi-ncurses gem was installed without ncurses present on the
+system.
+  * Reverted Aaron Simmons's patch to allow redirecting STDIN on
+Windows.  This is the only way we could find to restore
+HighLine's character reading to working order.
+
+---
+Fri Jun 11 17:06:38 UTC 2010 - mrueck...@suse.de
+
+- update to version 1.5.2
+  * Added support for using the ffi-ncurses gem which is supported
+in JRuby.
+  * Added gem build instructions.
+
+---
+Fri Jun 11 10:00:01 UTC 2010 - mrueck...@suse.de
+
+- use rubygems_requires macro
+
+---
+Fri Dec 25 02:22:37 UTC 2009 - prus...@suse.cz
+
+- update to 1.5.1
+
+---
+Wed Nov 12 15:55:58 CET 2008 - mrueck...@suse.de
+
+- update to 1.5.0
+
+---
+Sun Aug  5 19:33:16 CEST 2007 - mrueck...@suse.de
+
+- initial package of version 1.2.9
+

New:

  highline-1.6.11.gem
  rubygem-highline.changes
  rubygem-highline.spec



Other differences:
--
++ rubygem-highline.spec ++
#
# spec file for package rubygem-highline
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:   rubygem-highline
Version:1.6.11
Release:   

commit yast2-sound for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package yast2-sound for openSUSE:Factory 
checked in at 2012-03-20 13:30:00

Comparing /work/SRC/openSUSE:Factory/yast2-sound (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-sound.new (New)


Package is yast2-sound, Maintainer is lsle...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/yast2-sound/yast2-sound.changes  2011-12-21 
10:04:53.0 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-sound.new/yast2-sound.changes 
2012-03-20 13:30:02.0 +0100
@@ -1,0 +2,6 @@
+Tue Mar 20 10:50:14 CET 2012 - aschn...@suse.de
+
+- fixed for gcc 4.7
+- 2.22.0
+
+---

Old:

  yast2-sound-2.21.3.tar.bz2

New:

  yast2-sound-2.22.0.tar.bz2



Other differences:
--
++ yast2-sound.spec ++
--- /var/tmp/diff_new_pack.VUg7eQ/_old  2012-03-20 13:30:04.0 +0100
+++ /var/tmp/diff_new_pack.VUg7eQ/_new  2012-03-20 13:30:04.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package yast2-sound
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,25 +16,17 @@
 #
 
 
+
 Name:   yast2-sound
-Version:2.21.3
+Version:2.22.0
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source0:yast2-sound-%{version}.tar.bz2
 
-BuildRequires:  alsa-devel
-BuildRequires:  doxygen
-BuildRequires:  gcc-c++
-BuildRequires:  kernel-default
-BuildRequires:  libtool
-BuildRequires:  perl-XML-Writer
-BuildRequires:  ruby
-BuildRequires:  update-desktop-files
-BuildRequires:  yast2
-BuildRequires:  yast2-core-devel
-BuildRequires:  yast2-devtools
-BuildRequires:  yast2-testsuite
+Group:  System/YaST
+License:GPL-2.0+
+BuildRequires:  alsa-devel doxygen gcc-c++ kernel-default libtool 
perl-XML-Writer ruby update-desktop-files yast2 yast2-core-devel yast2-devtools 
yast2-testsuite
 
 # GetInstArgs::automatic_configuration
 # Wizard::SetDesktopTitleAndIcon
@@ -49,8 +41,6 @@
 Obsoletes:  y2c_sparc y2c_sprc yast2-db-sound y2d_snd
 
 Summary:YaST2 - Sound Configuration
-License:GPL-2.0+
-Group:  System/YaST
 
 %description
 This package contains the YaST2 component for sound card configuration.
@@ -66,7 +56,6 @@
 export CFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 export CXXFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 
-%{?suse_update_config:%{suse_update_config -f}}
 ./configure --libdir=%{_libdir} --prefix=%{_prefix} --mandir=%{_mandir}
 # V=1: verbose build in case we used AM_SILENT_RULES(yes)
 # so that RPM_OPT_FLAGS check works

++ yast2-sound-2.21.3.tar.bz2 - yast2-sound-2.22.0.tar.bz2 ++
 16622 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libpqxx for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package libpqxx for openSUSE:Factory checked 
in at 2012-03-20 16:31:08

Comparing /work/SRC/openSUSE:Factory/libpqxx (Old)
 and  /work/SRC/openSUSE:Factory/.libpqxx.new (New)


Package is libpqxx, Maintainer is m...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/libpqxx/libpqxx.changes  2011-12-12 
17:02:50.0 +0100
+++ /work/SRC/openSUSE:Factory/.libpqxx.new/libpqxx.changes 2012-03-20 
16:31:10.0 +0100
@@ -1,0 +2,5 @@
+Mon Mar 19 11:59:02 UTC 2012 - dims...@opensuse.org
+
+- Add libpqxx-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  libpqxx-gcc47.patch



Other differences:
--
++ libpqxx.spec ++
--- /var/tmp/diff_new_pack.KniZ5B/_old  2012-03-20 16:31:16.0 +0100
+++ /var/tmp/diff_new_pack.KniZ5B/_new  2012-03-20 16:31:16.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libpqxx
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -36,6 +36,8 @@
 # PATCH-FIX-UPSTREAM libpqxx-gcc46.patch idoen...@suse.de
 # -- Fix compilation with gcc 4.6, upstream r1722
 Patch1: libpqxx-gcc46.patch 
+# PATCH-FIX-UPSTREAM libpqxx-gcc47.patch dims...@opensuse.org -- Fix build 
with gcc 4.7
+Patch2: libpqxx-gcc47.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -55,6 +57,7 @@
 %prep
 %setup -q
 %patch1
+%patch2 -p1
 chmod 0644 AUTHORS COPYING ChangeLog NEWS README README-UPGRADE
 
 %build

++ libpqxx-gcc47.patch ++
Index: libpqxx-3.1/include/pqxx/util.hxx
===
--- libpqxx-3.1.orig/include/pqxx/util.hxx
+++ libpqxx-3.1/include/pqxx/util.hxx
@@ -19,6 +19,7 @@
 #define PQXX_H_UTIL
 
 #include pqxx/compiler-public.hxx
+#include pqxx/strconv.hxx
 
 #include cstdio
 #include cctype
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gcc46 for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package gcc46 for openSUSE:Factory checked 
in at 2012-03-20 16:33:10

Comparing /work/SRC/openSUSE:Factory/gcc46 (Old)
 and  /work/SRC/openSUSE:Factory/.gcc46.new (New)


Package is gcc46, Maintainer is rguent...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/gcc46/cross-armv5el-gcc-icecream-backend.changes 
2012-03-16 13:10:32.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.gcc46.new/cross-armv5el-gcc-icecream-backend.changes
2012-03-20 16:33:12.0 +0100
@@ -1,0 +2,16 @@
+Mon Mar 19 12:12:51 UTC 2012 - rguent...@suse.com
+
+- Change armv5 to use soft floating point.
+
+---
+Thu Mar 15 09:29:59 UTC 2012 - rguent...@suse.com
+
+- Backport patch to not search for lto-plugin when only preprocessing.
+  [bnc#747918]
+
+---
+Wed Mar  7 11:14:02 UTC 2012 - rguent...@suse.com
+
+- Package the gdb python scripts.  [bnc#750960]
+
+---
cross-armv7l-gcc-icecream-backend.changes: same change
cross-hppa-gcc-icecream-backend.changes: same change
cross-i386-gcc-icecream-backend.changes: same change
cross-ia64-gcc-icecream-backend.changes: same change
cross-ppc-gcc-icecream-backend.changes: same change
cross-ppc64-gcc-icecream-backend.changes: same change
cross-s390-gcc-icecream-backend.changes: same change
cross-s390x-gcc-icecream-backend.changes: same change
cross-x86_64-gcc-icecream-backend.changes: same change
gcc46-testresults.changes: same change
gcc46.changes: same change
libffi46.changes: same change
libgcj46.changes: same change

New:

  gcc46-bnc747918.diff



Other differences:
--
++ cross-armv5el-gcc-icecream-backend.spec ++
--- /var/tmp/diff_new_pack.XjTpiL/_old  2012-03-20 16:33:29.0 +0100
+++ /var/tmp/diff_new_pack.XjTpiL/_new  2012-03-20 16:33:29.0 +0100
@@ -94,6 +94,8 @@
 Patch28:pr33763.diff
 Patch29:pr50193.diff
 Patch30:gcc43-no-unwind-tables.diff
+# Do not search for the lto-plugin when preprocessing only
+Patch31:gcc46-bnc747918.diff
 # A set of patches from the RH srpm
 Patch51:gcc41-ia64-stack-protector.patch
 Patch55:gcc41-java-slow_pthread_self.patch
@@ -195,6 +197,7 @@
 %patch28
 %patch29 -p1
 %patch30
+%patch31
 %patch51
 %patch55
 %patch57
@@ -384,7 +387,7 @@
 %endif
 %if %{TARGET_ARCH} == armv5tel
--with-arch=armv5te \
-   --with-float=softfp \
+   --with-float=soft \
--with-mode=arm \
--with-abi=aapcs-linux \
--disable-sjlj-exceptions \

cross-armv7l-gcc-icecream-backend.spec: same change
cross-hppa-gcc-icecream-backend.spec: same change
cross-i386-gcc-icecream-backend.spec: same change
cross-ia64-gcc-icecream-backend.spec: same change
cross-ppc-gcc-icecream-backend.spec: same change
cross-ppc64-gcc-icecream-backend.spec: same change
cross-s390-gcc-icecream-backend.spec: same change
cross-s390x-gcc-icecream-backend.spec: same change
cross-x86_64-gcc-icecream-backend.spec: same change
gcc46-testresults.spec: same change
++ gcc46.spec ++
--- /var/tmp/diff_new_pack.XjTpiL/_old  2012-03-20 16:33:29.0 +0100
+++ /var/tmp/diff_new_pack.XjTpiL/_new  2012-03-20 16:33:29.0 +0100
@@ -201,6 +201,8 @@
 Patch28:pr33763.diff
 Patch29:pr50193.diff
 Patch30:gcc43-no-unwind-tables.diff
+# Do not search for the lto-plugin when preprocessing only
+Patch31:gcc46-bnc747918.diff
 # A set of patches from the RH srpm
 Patch51:gcc41-ia64-stack-protector.patch
 Patch55:gcc41-java-slow_pthread_self.patch
@@ -1504,6 +1506,7 @@
 %patch28
 %patch29 -p1
 %patch30
+%patch31
 %patch51
 %patch55
 %patch57
@@ -1693,7 +1696,7 @@
 %endif
 %if %{TARGET_ARCH} == armv5tel
--with-arch=armv5te \
-   --with-float=softfp \
+   --with-float=soft \
--with-mode=arm \
--with-abi=aapcs-linux \
--disable-sjlj-exceptions \
@@ -1889,8 +1892,6 @@
 if ! test -z $dir_ml; then
   ln -s . 
$RPM_BUILD_ROOT%{_prefix}/include/c++/%{gcc_dir_version}/%{GCCDIST}/$dir_ml
 fi
-# For now we do not want to have the python gdb scripts
-rm -Rf $RPM_BUILD_ROOT%{_datadir}/gcc%{binsuffix}
 %endif
 # LIBJAVA-DELETE-END
 
@@ -2438,6 +2439,7 @@
 %dir %{_datadir}/gdb/auto-load%{_prefix}
 %dir %{_datadir}/gdb/auto-load/%{mainlibdir}
 %{_datadir}/gdb/auto-load/%{mainlibdir}/libstdc++.so.*-gdb.py
+%{_datadir}/gcc%{binsuffix}
 
 %if %{separate_biarch}
 %files -n libstdc++46-devel%{separate_biarch_suffix}

++ libffi46.spec ++
--- /var/tmp/diff_new_pack.XjTpiL/_old  2012-03-20 16:33:29.0 +0100
+++ /var/tmp/diff_new_pack.XjTpiL/_new  

commit mysql-community-server for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package mysql-community-server for 
openSUSE:Factory checked in at 2012-03-20 17:47:26

Comparing /work/SRC/openSUSE:Factory/mysql-community-server (Old)
 and  /work/SRC/openSUSE:Factory/.mysql-community-server.new (New)


Package is mysql-community-server, Maintainer is 

Changes:

--- 
/work/SRC/openSUSE:Factory/mysql-community-server/mysql-community-server.changes
2012-03-01 17:21:11.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.mysql-community-server.new/mysql-community-server.changes
   2012-03-20 17:47:28.0 +0100
@@ -1,0 +2,10 @@
+Fri Mar 16 15:01:14 UTC 2012 - dval...@suse.com
+
+- fix libdir for ppc64 
+
+---
+Wed Mar 14 15:57:38 UTC 2012 - mhruse...@suse.cz
+
+- better va_list handling (fixes build on arm)
+
+---



Other differences:
--
++ mysql-community-server.spec ++
--- /var/tmp/diff_new_pack.l9PHOv/_old  2012-03-20 17:47:31.0 +0100
+++ /var/tmp/diff_new_pack.l9PHOv/_new  2012-03-20 17:47:31.0 +0100
@@ -22,6 +22,8 @@
 %define use_cmake  1
 %define cluster0
 %define builtin_plugins partition,csv,heap,myisam,innobase
+%define use_extra_provides 1
+%define extra_provides mysql-community-server_55
 
 %if %{?rel:0}%{!?rel:1}
 %define rel 1
@@ -76,6 +78,10 @@
 Requires:   %{name}-client perl-base
 Provides:   mysql-Max = %{srv_vers}
 Provides:   mysql = %{srv_vers}
+%if 0%{?use_extra_provides}  0
+Provides:   %{extra_provides} = %{version}
+Obsoletes:  %{extra_provides}  %{version}
+%endif
 %if 0%{?prefered}  0
 Obsoletes:  mysql  %{srv_vers}
 Obsoletes:  mysql-Max  %{srv_vers}
@@ -171,6 +177,10 @@
 Summary:Client for MySQL Community Server
 Group:  Productivity/Databases/Clients
 Provides:   mysql-client = %{srv_vers}
+%if 0%{?use_extra_provides}  0
+Provides:   %{extra_provides}-client = %{version}
+Obsoletes:  %{extra_provides}-client  %{version}
+%endif
 %if 0%{?prefered}  0
 Obsoletes:  mysql-client  %{srv_vers}
 %endif
@@ -185,6 +195,10 @@
 Summary:Benchmarks for MySQL Community Server
 Group:  Productivity/Databases/Tools
 Provides:   mysql-bench = %{srv_vers}
+%if 0%{?use_extra_provides}  0
+Provides:   %{extra_provides}-bench = %{version}
+Obsoletes:  %{extra_provides}-bench  %{version}
+%endif
 %if 0%{?prefered}  0
 Obsoletes:  mysql-bench  %{srv_vers}
 %endif
@@ -204,6 +218,10 @@
 Requires:   %{name} = %{version}
 Provides:   mysql-debug = %{srv_vers}
 Provides:   %{name}-debug = %{srv_vers}
+%if 0%{?use_extra_provides}  0
+Provides:   %{extra_provides}-debug-verion = %{version}
+Obsoletes:  %{extra_provides}-debug-version  %{version}
+%endif
 %if 0%{?prefered}  0
 Obsoletes:  mysql-debug  %{srv_vers}
 %endif
@@ -226,6 +244,10 @@
 Requires:   %{name}-tools = %{version}
 Requires:   %{name}-bench = %{version}
 Provides:   mysql-test = %{srv_vers}
+%if 0%{?use_extra_provides}  0
+Provides:   %{extra_provides}-test = %{version}
+Obsoletes:  %{extra_provides}-test  %{version}
+%endif
 %if 0%{?prefered}  0
 Obsoletes:  mysql-test  %{srv_vers}
 %endif
@@ -244,6 +266,10 @@
 # make sure this package is installed when updating from 10.2 and older
 Provides:   mysql:/usr/bin/mysqlhotcopy mysql-client:/usr/bin/perror
 Provides:   mysql-tools = %{srv_vers}
+%if 0%{?use_extra_provides}  0
+Provides:   %{extra_provides}-tools = %{version}
+Obsoletes:  %{extra_provides}-tools  %{version}
+%endif
 %if 0%{?prefered}  0
 Obsoletes:  mysql-tools  %{srv_vers}
 %endif

++ configuration-tweaks.tar.bz2 ++

++ mysql-patches.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/mysql-patches/mysql-patches/mysql-community-server-5.5.21-ppc64-libdir.patch
 
new/mysql-patches/mysql-patches/mysql-community-server-5.5.21-ppc64-libdir.patch
--- 
old/mysql-patches/mysql-patches/mysql-community-server-5.5.21-ppc64-libdir.patch
1970-01-01 01:00:00.0 +0100
+++ 
new/mysql-patches/mysql-patches/mysql-community-server-5.5.21-ppc64-libdir.patch
2012-03-16 13:27:30.0 +0100
@@ -0,0 +1,19 @@
+PATCH-P1-FIX-SUSE: set libdir for ppc64 correctly
+
+The patch sets correct libdir for ppc64
+
+Maintainer: Michal Hrusecky michal.hruse...@opensuse.org
+
+Index: mysql-5.5.21/cmake/install_layout.cmake
+===
+--- mysql-5.5.21.orig/cmake/install_layout.cmake
 mysql-5.5.21/cmake/install_layout.cmake
+@@ -138,7 +138,7 @@ SET(INSTALL_BINDIR_RPM
+ 

commit pam for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package pam for openSUSE:Factory checked in 
at 2012-03-20 17:47:35

Comparing /work/SRC/openSUSE:Factory/pam (Old)
 and  /work/SRC/openSUSE:Factory/.pam.new (New)


Package is pam, Maintainer is m...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/pam/pam.changes  2011-10-25 16:47:31.0 
+0200
+++ /work/SRC/openSUSE:Factory/.pam.new/pam.changes 2012-03-20 
17:47:42.0 +0100
@@ -1,0 +2,10 @@
+Sat Mar  3 15:16:42 UTC 2012 - jeng...@medozas.de
+
+- Update to new upstream release 1.1.5
+* pam_env: Fix CVE-2011-3148: correctly count leading whitespace
+  when parsing environment file in pam_env
+* Fix CVE-2011-3149: when overflowing, exit with PAM_BUF_ERR in
+  pam_env
+* pam_access: Add hostname resolution cache
+
+---

Old:

  Linux-PAM-1.1.4-docs.tar.bz2
  Linux-PAM-1.1.4.tar.bz2
  bug-724480_pam_env-fix-dos.patch
  bug-724480_pam_env-fix-overflow.patch
  pam_tally2-man.dif

New:

  Linux-PAM-1.1.5-docs.tar.bz2
  Linux-PAM-1.1.5.tar.bz2



Other differences:
--
++ pam.spec ++
--- /var/tmp/diff_new_pack.j8Fn62/_old  2012-03-20 17:47:44.0 +0100
+++ /var/tmp/diff_new_pack.j8Fn62/_new  2012-03-20 17:47:44.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package pam
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,32 +15,36 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
 
 %define enable_selinux 1
 
 Name:   pam
 Url:http://www.kernel.org/pub/linux/libs/pam/
-BuildRequires:  bison cracklib-devel db-devel flex
 BuildRequires:  audit-devel
-BuildRequires:  libtirpc-devel
+BuildRequires:  bison
+BuildRequires:  cracklib-devel
+BuildRequires:  db-devel
+BuildRequires:  flex
+BuildRequires:  pkgconfig(libtirpc)
 %if %{enable_selinux}
 BuildRequires:  libselinux-devel
 %endif
 %define libpam_so_version 0.83.1
 %define libpam_misc_so_version 0.82.0
 %define libpamc_so_version 0.82.1
-License:GPL-2.0+ or BSD-3-Clause
-Group:  System/Libraries
-AutoReqProv:on
 # bug437293
 %ifarch ppc64
 Obsoletes:  pam-64bit
 %endif
 #
-Version:1.1.4
-Release:1
+Version:1.1.5
+Release:0
 Summary:A Security Tool that Provides Authentication for Applications
+License:GPL-2.0+ or BSD-3-Clause
+Group:  System/Libraries
+
+###DL-URL: http://www.kernel.org/pub/linux/libs/pam/library/
+#DL-URL:   https://fedorahosted.org/releases/l/i/linux-pam/
 Source: Linux-PAM-%{version}.tar.bz2
 Source1:Linux-PAM-%{version}-docs.tar.bz2
 Source2:securetty
@@ -52,9 +56,6 @@
 Source8:etc.environment
 Source9:baselibs.conf
 Patch0: pam_tally-deprecated.diff
-Patch1: bug-724480_pam_env-fix-overflow.patch
-Patch2: bug-724480_pam_env-fix-dos.patch
-Patch3: pam_tally2-man.dif
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -65,10 +66,11 @@
 
 
 %package doc
-License:GPL-2.0+ or BSD-3-Clause
 Summary:Documentation for Pluggable Authentication Modules
 Group:  Documentation/HTML
-###BuildArch:  noarch
+%if 0%{?suse_version} = 1140
+BuildArch:  noarch
+%endif
 
 %description doc
 PAM (Pluggable Authentication Modules) is a system security tool that
@@ -80,11 +82,9 @@
 
 
 %package devel
-License:GPL-2.0+ or BSD-3-Clause
 Summary:Include Files and Libraries for PAM-Development
 Group:  Development/Libraries/C and C++
 Requires:   pam = %{version} glibc-devel
-AutoReqProv:on
 # bug437293
 %ifarch ppc64
 Obsoletes:  pam-devel-64bit
@@ -104,15 +104,12 @@
 %prep
 %setup -q -n Linux-PAM-%{version} -b 1
 %patch0 -p0
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
 
 %build
-CFLAGS=$RPM_OPT_FLAGS -DNDEBUG \
-./configure \
---infodir=%{_infodir} \
---mandir=%{_mandir} \
+export CFLAGS=%optflags -DNDEBUG
+%configure \
+   --sbindir=/sbin \
+   --includedir=%_includedir/security \
--docdir=%{_docdir}/pam \
--htmldir=%{_docdir}/pam/html \
--pdfdir=%{_docdir}/pam/pdf \
@@ -179,15 +176,12 @@
 # Create filelist with translatins
 %{find_lang} Linux-PAM
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+%verifyscript
+%verify_permissions -e /sbin/unix_chkpwd
 
 %post -p /sbin/ldconfig
 
-%postun
-/sbin/ldconfig
-%verifyscript
-%verify_permissions -e /sbin/unix_chkpwd
+%postun -p /sbin/ldconfig
 
 

commit clucene-core for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package clucene-core for openSUSE:Factory 
checked in at 2012-03-20 17:47:39

Comparing /work/SRC/openSUSE:Factory/clucene-core (Old)
 and  /work/SRC/openSUSE:Factory/.clucene-core.new (New)


Package is clucene-core, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/clucene-core/clucene-core.changes
2011-12-02 09:25:54.0 +0100
+++ /work/SRC/openSUSE:Factory/.clucene-core.new/clucene-core.changes   
2012-03-20 17:47:45.0 +0100
@@ -1,0 +2,5 @@
+Thu Mar 15 15:02:01 UTC 2012 - dval...@suse.com
+
+- fix ppc64 build 
+
+---



Other differences:
--
++ clucene-core.spec ++
--- /var/tmp/diff_new_pack.i7YyNK/_old  2012-03-20 17:47:49.0 +0100
+++ /var/tmp/diff_new_pack.i7YyNK/_new  2012-03-20 17:47:49.0 +0100
@@ -82,7 +82,7 @@
 -DCMAKE_C_FLAGS=%{optflags} \
 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
 -DLUCENE_SYS_INCLUDES:PATH=%{_libdir} \
-%ifarch x86_64
+%ifarch x86_64 ppc64
 -DLIB_SUFFIX=64 \
 %endif
 -DCMAKE_BUILD_TYPE=RelWithDebInfo

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libpng14 for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package libpng14 for openSUSE:Factory 
checked in at 2012-03-20 17:47:43

Comparing /work/SRC/openSUSE:Factory/libpng14 (Old)
 and  /work/SRC/openSUSE:Factory/.libpng14.new (New)


Package is libpng14, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/libpng14/libpng14.changes2012-02-21 
07:32:23.0 +0100
+++ /work/SRC/openSUSE:Factory/.libpng14.new/libpng14.changes   2012-03-20 
17:47:50.0 +0100
@@ -1,0 +2,6 @@
+Thu Mar 15 11:49:13 UTC 2012 - pgaj...@suse.com
+
+- updated to 1.4.10:
+  * fixed CVE-2011-3045 [bnc#752008]
+
+---

Old:

  libpng-1.4.9.tar.bz2

New:

  libpng-1.4.10.tar.bz2



Other differences:
--
++ libpng14.spec ++
--- /var/tmp/diff_new_pack.d4oKpY/_old  2012-03-20 17:47:53.0 +0100
+++ /var/tmp/diff_new_pack.d4oKpY/_new  2012-03-20 17:47:53.0 +0100
@@ -19,7 +19,7 @@
 
 %define major   1
 %define minor   4
-%define micro   9
+%define micro   10
 %define branch  %{major}%{minor}
 %define libname libpng%{branch}-%{branch}
 

++ libpng-1.4.9.tar.bz2 - libpng-1.4.10.tar.bz2 ++
 8292 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit subversion for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package subversion for openSUSE:Factory 
checked in at 2012-03-20 17:47:50

Comparing /work/SRC/openSUSE:Factory/subversion (Old)
 and  /work/SRC/openSUSE:Factory/.subversion.new (New)


Package is subversion, Maintainer is dmuel...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/subversion/subversion.changes2012-03-01 
17:28:05.0 +0100
+++ /work/SRC/openSUSE:Factory/.subversion.new/subversion.changes   
2012-03-20 17:47:54.0 +0100
@@ -1,0 +2,25 @@
+Thu Mar  8 00:00:00 UTC 2012 - andreas.stie...@gmx.de
+
+- update to upstream 1.7.4
+
+  User-visible changes:
+* fix 'svn log --diff' for moved paths
+* fix ra_serf problem with reading directory entries via HTTPv2
+* prepend sqlite: to error messages from SQLite
+* fix randomly missing Merged via notifications in 'svn log -g'
+* fix spurious conflict when merging deleted symbolic link (issue #4052)
+* fix URL-to-WC copy of externals on Windows (issue #4123)
+* improve an FSFS sanity-check error message
+* fix regressions with symlinks pointing at externals (issue #4102)
+* fix 'svn log --diff' output ordering issue on Windows
+
+  Developer-visible changes:
+* don't build mod_dontdothat if not building with httpd
+* fix the testsuite to avoid FAILs on APR hash order
+
+---
+Sat Mar  3 13:20:33 UTC 2012 - andreas.stie...@gmx.de
+
+- add bash completion subpackage
+
+---

Old:

  subversion-1.7.3.tar.bz2

New:

  subversion-1.7.4.tar.bz2



Other differences:
--
++ subversion.spec ++
--- /var/tmp/diff_new_pack.jMgFWW/_old  2012-03-20 17:47:57.0 +0100
+++ /var/tmp/diff_new_pack.jMgFWW/_new  2012-03-20 17:47:57.0 +0100
@@ -40,8 +40,14 @@
 
 %bcond_without regression_tests
 
+%if 0%{?sles_version}  10  0%{?sles_version}  12
+%define with_bashcomp 0
+%else
+%define with_bashcomp 1
+%endif
+
 Name:   subversion
-Version:1.7.3
+Version:1.7.4
 Release:0
 # in-tree SWIG version to use for the build:
 %define swig_version   1.3.36
@@ -58,6 +64,9 @@
 BuildRequires:  python-xml
 BuildRequires:  update-alternatives
 BuildRequires:  zlib-devel
+%if %with_bashcomp
+BuildRequires:  bash-completion
+%endif #with_bashcomp
 %if %with_python_ctypes
 BuildRequires:  ctypesgen
 %endif
@@ -284,6 +293,23 @@
 
 %endif # with_gnome_keyring
 
+%if %with_bashcomp
+
+%package bash-completion
+Summary:Bash Completion for %{name}
+Group:  Development/Tools/Version Control
+Requires:   %{name} = %{version}
+Requires:   bash-completion
+%if %{?suse_version} = 1130
+BuildArch:  noarch
+%endif
+
+%description bash-completion
+Bash command line completion support for %{name} - completion of subcommands,
+parameters and keywords for the svn command and other tools.
+
+%endif # with_bashcomp
+
 %prep
 %if %with_intree_swig
 %setup -q -n subversion-%{version} -a 4 -b 90
@@ -550,6 +576,10 @@
 fi
 rm -f %{buildroot}/var/adm/perl-modules/subversion
 
+%if %with_bashcomp
+%__install -D -m0644 tools/client-side/bash_completion 
%{buildroot}/etc/bash_completion.d/%{name}
+%endif #with_bashcomp
+
 %check
 
 %if %{with regression_tests}
@@ -754,4 +784,11 @@
 %{_libdir}/libsvn_auth_kwallet-1.so.0.*
 %endif # with_kde4_kwallet
 
+%if %with_bashcomp
+
+%files bash-completion
+%defattr(-,root,root)
+%config %{_sysconfdir}/bash_completion.d/%{name}
+%endif #with_bashcomp
+
 %changelog

++ subversion-1.7.3.tar.bz2 - subversion-1.7.4.tar.bz2 ++
 8424 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yast2-fingerprint-reader for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package yast2-fingerprint-reader for 
openSUSE:Factory checked in at 2012-03-20 17:48:38

Comparing /work/SRC/openSUSE:Factory/yast2-fingerprint-reader (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-fingerprint-reader.new (New)


Package is yast2-fingerprint-reader, Maintainer is jsuch...@suse.com

Changes:

--- 
/work/SRC/openSUSE:Factory/yast2-fingerprint-reader/yast2-fingerprint-reader.changes
2012-01-17 16:17:31.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.yast2-fingerprint-reader.new/yast2-fingerprint-reader.changes
   2012-03-20 17:48:42.0 +0100
@@ -1,0 +2,6 @@
+Tue Mar 20 12:32:03 CET 2012 - aschn...@suse.de
+
+- fixed for gcc 4.7
+- 2.22.1
+
+---

Old:

  yast2-fingerprint-reader-2.22.0.tar.bz2

New:

  yast2-fingerprint-reader-2.22.1.tar.bz2



Other differences:
--
++ yast2-fingerprint-reader.spec ++
--- /var/tmp/diff_new_pack.ybccTF/_old  2012-03-20 17:48:43.0 +0100
+++ /var/tmp/diff_new_pack.ybccTF/_new  2012-03-20 17:48:43.0 +0100
@@ -18,7 +18,7 @@
 
 
 Name:   yast2-fingerprint-reader
-Version:2.22.0
+Version:2.22.1
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-fingerprint-reader-2.22.0.tar.bz2 - 
yast2-fingerprint-reader-2.22.1.tar.bz2 ++
 16849 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yast2-dbus-server for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package yast2-dbus-server for 
openSUSE:Factory checked in at 2012-03-20 17:48:41

Comparing /work/SRC/openSUSE:Factory/yast2-dbus-server (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-dbus-server.new (New)


Package is yast2-dbus-server, Maintainer is mvid...@suse.com

Changes:

--- /work/SRC/openSUSE:Factory/yast2-dbus-server/yast2-dbus-server.changes  
2011-12-21 10:04:46.0 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-dbus-server.new/yast2-dbus-server.changes 
2012-03-20 17:48:44.0 +0100
@@ -1,0 +2,6 @@
+Tue Mar 20 12:45:43 CET 2012 - aschn...@suse.de
+
+- fixed for gcc 4.7
+- 2.22.1
+
+---

Old:

  yast2-dbus-server-2.22.0.tar.bz2

New:

  yast2-dbus-server-2.22.1.tar.bz2



Other differences:
--
++ yast2-dbus-server.spec ++
--- /var/tmp/diff_new_pack.kGJzTG/_old  2012-03-20 17:48:45.0 +0100
+++ /var/tmp/diff_new_pack.kGJzTG/_new  2012-03-20 17:48:45.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package yast2-dbus-server
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,11 +15,10 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
 
 
 Name:   yast2-dbus-server
-Version:2.22.0
+Version:2.22.1
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -42,7 +41,7 @@
 BuildRequires:  sgml-skel
 
 # for SCR DBus service
-BuildRequires:  dbus-1-devel dbus-1-x11 libxcrypt-devel polkit-devel
+BuildRequires:  dbus-1-devel dbus-1-x11 polkit-devel
 # its tests
 BuildRequires:  dbus-1-python python-devel
 # its tests
@@ -66,7 +65,6 @@
 export CFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 export CXXFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 
-%{?suse_update_config:%{suse_update_config -f}}
 ./configure --libdir=%{_libdir} --prefix=%{_prefix} --mandir=%{_mandir}
 # V=1: verbose build in case we used AM_SILENT_RULES(yes)
 # so that RPM_OPT_FLAGS check works

++ yast2-dbus-server-2.22.0.tar.bz2 - yast2-dbus-server-2.22.1.tar.bz2 
++
 16444 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yast2-phone-services for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package yast2-phone-services for 
openSUSE:Factory checked in at 2012-03-20 17:48:45

Comparing /work/SRC/openSUSE:Factory/yast2-phone-services (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-phone-services.new (New)


Package is yast2-phone-services, Maintainer is mvid...@suse.com

Changes:

--- 
/work/SRC/openSUSE:Factory/yast2-phone-services/yast2-phone-services.changes
2011-10-03 09:26:51.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.yast2-phone-services.new/yast2-phone-services.changes
   2012-03-20 17:48:51.0 +0100
@@ -1,0 +2,6 @@
+Mon Mar 19 12:46:25 UTC 2012 - mfi...@suse.com
+
+- Fixed definition of Fax user edit dialog - bnc#739731 
+- 2.21.1
+
+---

Old:

  yast2-phone-services-2.21.0.tar.bz2

New:

  yast2-phone-services-2.21.1.tar.bz2



Other differences:
--
++ yast2-phone-services.spec ++
--- /var/tmp/diff_new_pack.lSpaTP/_old  2012-03-20 17:48:52.0 +0100
+++ /var/tmp/diff_new_pack.lSpaTP/_new  2012-03-20 17:48:52.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package yast2-phone-services
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,18 +15,15 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
 
 
 Name:   yast2-phone-services
-Version:2.21.0
+Version:2.21.1
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source0:yast2-phone-services-%{version}.tar.bz2
 
-Prefix: /usr
-
 Group:  System/YaST
 License:GPL-2.0+
 BuildRequires:  doxygen perl-XML-Writer pkg-config update-desktop-files yast2 
yast2-devtools yast2-users
@@ -45,23 +42,22 @@
 %setup -n yast2-phone-services-%{version}
 
 %build
-%{prefix}/bin/y2tool y2autoconf
-%{prefix}/bin/y2tool y2automake
+%{_prefix}/bin/y2tool y2autoconf
+%{_prefix}/bin/y2tool y2automake
 autoreconf --force --install
 
 export CFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 export CXXFLAGS=$RPM_OPT_FLAGS -DNDEBUG
 
-%{?suse_update_config:%{suse_update_config -f}}
-./configure --libdir=%{_libdir} --prefix=%{prefix} --mandir=%{_mandir}
+./configure --libdir=%{_libdir} --prefix=%{_prefix} --mandir=%{_mandir}
 # V=1: verbose build in case we used AM_SILENT_RULES(yes)
 # so that RPM_OPT_FLAGS check works
 make %{?jobs:-j%jobs} V=1
 
 %install
 make install DESTDIR=$RPM_BUILD_ROOT
-[ -e %{prefix}/share/YaST2/data/devtools/NO_MAKE_CHECK ] || 
Y2DIR=$RPM_BUILD_ROOT/usr/share/YaST2 make check DESTDIR=$RPM_BUILD_ROOT
-for f in `find $RPM_BUILD_ROOT/%{prefix}/share/applications/YaST2/ -name 
*.desktop` ; do
+[ -e %{_prefix}/share/YaST2/data/devtools/NO_MAKE_CHECK ] || 
Y2DIR=$RPM_BUILD_ROOT/usr/share/YaST2 make check DESTDIR=$RPM_BUILD_ROOT
+for f in `find $RPM_BUILD_ROOT/%{_prefix}/share/applications/YaST2/ -name 
*.desktop` ; do
 d=${f##*/}
 %suse_update_desktop_file -d ycc_${d%.desktop} ${d%.desktop}
 done
@@ -75,8 +71,8 @@
 /usr/share/YaST2/include/phone-services/*
 /usr/share/YaST2/clients/*.ycp
 /usr/share/YaST2/modules/*.y*
-%{prefix}/share/applications/YaST2/*.desktop
+%{_prefix}/share/applications/YaST2/*.desktop
 /usr/share/YaST2/scrconf/*.scr
-%doc %{prefix}/share/doc/packages/yast2-phone-services
+%doc %{_prefix}/share/doc/packages/yast2-phone-services
 
 %changelog

++ yast2-phone-services-2.21.0.tar.bz2 - 
yast2-phone-services-2.21.1.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-phone-services-2.21.0/Makefile.am 
new/yast2-phone-services-2.21.1/Makefile.am
--- old/yast2-phone-services-2.21.0/Makefile.am 2011-09-27 10:25:50.0 
+0200
+++ new/yast2-phone-services-2.21.1/Makefile.am 2012-03-20 12:32:41.0 
+0100
@@ -20,7 +20,6 @@
 IS_DEVTOOLS= $(findstring yast2-devtools,$(RPMNAME))
 
 DEVTOOLS_DIR   = $(if 
$(IS_DEVTOOLS),$(srcdir)/devtools,$(Y2DEVTOOLS_PREFIX)/share/YaST2/data/devtools)
-ALL_PACKAGES   = $(DEVTOOLS_DIR)/admin/all-packages
 LEGALESE_DIR   = $(if 
$(HAS_YAST_LICENSE),$(DEVTOOLS_DIR)/admin/copyright/yast,$(DEVTOOLS_DIR)/admin/copyright/gpl)
 
 COPYRIGHT_files_gpl= README COPYING
@@ -35,7 +34,7 @@
 # where devtools install m4 snippets
 # argh, executed literally
 #ACLOCAL_AMFLAGS = -I $(Y2DEVTOOLS_PREFIX)/share/aclocal
-ACLOCAL_AMFLAGS = -I . -I `if test -d ./devtools/admin; then echo 
./devtools/admin; else pkg-config --print-errors --variable=datadir 

commit kdebase4-runtime for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package kdebase4-runtime for 
openSUSE:Factory checked in at 2012-03-20 17:48:55

Comparing /work/SRC/openSUSE:Factory/kdebase4-runtime (Old)
 and  /work/SRC/openSUSE:Factory/.kdebase4-runtime.new (New)


Package is kdebase4-runtime, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/kdebase4-runtime/kdebase4-runtime.changes
2012-03-12 20:14:43.0 +0100
+++ /work/SRC/openSUSE:Factory/.kdebase4-runtime.new/kdebase4-runtime.changes   
2012-03-20 17:48:56.0 +0100
@@ -1,0 +2,7 @@
+Thu Mar 15 11:19:22 UTC 2012 - wstephen...@suse.com
+
+- Add patches from 4.8 branch to improve mail indexing
+  * Improve performance of storing semantic metadata
+  * Fix failure to store semantic metadata on merge with existing
+
+---

New:

  50ef3393-nepomuk-data-merging-fix.diff
  754275ed-nepomuk-res-ident-perf.diff



Other differences:
--
++ kdebase4-runtime.spec ++
--- /var/tmp/diff_new_pack.zxT85k/_old  2012-03-20 17:48:58.0 +0100
+++ /var/tmp/diff_new_pack.zxT85k/_new  2012-03-20 17:48:58.0 +0100
@@ -16,6 +16,7 @@
 #
 
 
+
 Name:   kdebase4-runtime
 Version:4.8.1
 Release:0
@@ -41,6 +42,8 @@
 Patch15:kdesu-symbol-lookup-workaround.diff
 Patch16:phonon-always-forget.diff
 Patch17:desktop-files.diff
+Patch18:754275ed-nepomuk-res-ident-perf.diff
+Patch19:50ef3393-nepomuk-data-merging-fix.diff
 BuildRequires:  NetworkManager-devel
 BuildRequires:  QtZeitgeist-devel
 BuildRequires:  bluez-devel
@@ -168,6 +171,8 @@
 %patch15
 %patch16
 %patch17
+%patch18 -p1
+%patch19 -p1
 
 %build
   %cmake_kde4 -d build -- -DKDE4_ENABLE_FPIE=1

++ 50ef3393-nepomuk-data-merging-fix.diff ++
commit 50ef33937d04c6e4b72e1d492c6cc1ef9f699151
Author: Vishesh Handa handa.v...@gmail.com
Date:   Tue Mar 13 18:23:06 2012 +0530

Merge duplicate statements in the ResourceMerger

This happens in cases where two resources identifiy to the same resource and
their statements are resolved in the ResourceMerger. During the cardinality
checks, there exist identical duplicates (because of the merge) of certain
properties which result in cardinality errors.

Also added a unit test.

This should fix the problem with PIM Email Indexing

CCMAIL: wstephen...@kde.org

diff --git a/nepomuk/services/storage/resourcemerger.cpp 
b/nepomuk/services/storage/resourcemerger.cpp
index 0aa4ae7..93d39be 100644
--- a/nepomuk/services/storage/resourcemerger.cpp
+++ b/nepomuk/services/storage/resourcemerger.cpp
@@ -509,20 +509,26 @@ Soprano::Node 
Nepomuk::ResourceMerger::resolveUnmappedNode(const Soprano::Node
 return newUri;
 }
 
-void 
Nepomuk::ResourceMerger::resolveBlankNodesInList(QListSoprano::Statement 
*stList)
+void Nepomuk::ResourceMerger::resolveBlankNodesInSet(QSetSoprano::Statement 
*stList)
 {
-QMutableListIteratorSoprano::Statement iter( *stList );
+QSetSoprano::Statement newSet;
+
+QSetIteratorSoprano::Statement iter( *stList );
 while( iter.hasNext() ) {
-Soprano::Statement st = iter.next();
+Soprano::Statement st = iter.next();
 
 st.setSubject( resolveUnmappedNode(st.subject()) );
 st.setObject( resolveUnmappedNode(st.object()) );
+
+newSet.insert( st );
 }
+
+*stList = newSet;
 }
 
-void Nepomuk::ResourceMerger::removeDuplicatesInList(QListSoprano::Statement 
*stList)
+void Nepomuk::ResourceMerger::removeDuplicatesInList(QSetSoprano::Statement 
*stList)
 {
-QMutableListIteratorSoprano::Statement it( *stList );
+QMutableSetIteratorSoprano::Statement it( *stList );
 while( it.hasNext() ) {
 const Soprano::Statement st = it.next();
 if( st.subject().isBlank() || st.object().isBlank() )
@@ -649,9 +655,9 @@ bool Nepomuk::ResourceMerger::merge( const Soprano::Graph 
stGraph )
 // First separate all the statements predicate rdf:type.
 // and collect info required to check the types and cardinality
 //
-QListSoprano::Statement remainingStatements;
-QListSoprano::Statement typeStatements;
-QListSoprano::Statement metadataStatements;
+QSetSoprano::Statement remainingStatements;
+QSetSoprano::Statement typeStatements;
+QSetSoprano::Statement metadataStatements;
 
 foreach( const Soprano::Statement  st, statements ) {
 const QUrl subUri = getBlankOrResourceUri( st.subject() );
@@ -676,7 +682,9 @@ bool Nepomuk::ResourceMerger::merge( const Soprano::Graph 
stGraph )
 // Get the cardinality
 if( tree-maxCardinality( prop )  0 ) {
 QPairQUrl,QUrl 

commit kdevplatform for openSUSE:Factory

2012-03-20 Thread h_root
Hello community,

here is the log from the commit of package kdevplatform for openSUSE:Factory 
checked in at 2012-03-20 17:48:58

Comparing /work/SRC/openSUSE:Factory/kdevplatform (Old)
 and  /work/SRC/openSUSE:Factory/.kdevplatform.new (New)


Package is kdevplatform, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/kdevplatform/kdevplatform.changes
2011-09-23 02:06:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdevplatform.new/kdevplatform.changes   
2012-03-20 17:48:59.0 +0100
@@ -1,0 +2,30 @@
+Tue Mar 13 10:01:37 UTC 2012 - wstephen...@suse.com
+
+- update to 1.3.0:
+  * more fixes to gcc 4.7 and cvstest in regard to macro handling
+  * Only store katepart session information for the last 20 files
+  * cleanup includes
+  * Give a warning and return false on isTextDocument if the
+text-document is not properly initialized.
+  * Translate session picker
+  * Save and reload settings exposed by katepart per file
+  * skip files that are larger than 5MiB during parsing
+  * Activate the new active view through the main-window after
+switching working-set, to get the correct focus.
+  * Don't disable updates while changing working-sets. There seems
+to be a bug in Qt which can cause the updates to stay disabled
+forever, ignoring setUpdatesEnabled(true).
+  * Fix a regression caused by the introduced quickopen-timer which
+led to the previous quickopen-filter being used instead of a blank one.
+  * fix serious memory leak of kate documents
+  * Calling toString() is very slow, use the native way of filtering
+empty identifiers.
+  * optimize: .contains  .value can be reduced to a single call to
+.value()
+  * fallback to document-controller when looking for a mimetype of
+files without a file extension
+  * optimize: apply quickopen filter after 150ms timeout
+  * delay calls to QuickOpenModel::restart
+  * hide quickopen project items with empty identifier
+
+---

Old:

  kdevplatform-1.2.3.tar.bz2

New:

  kdevplatform-1.3.0.tar.bz2



Other differences:
--
++ kdevplatform.spec ++
--- /var/tmp/diff_new_pack.KsO3Us/_old  2012-03-20 17:49:01.0 +0100
+++ /var/tmp/diff_new_pack.KsO3Us/_new  2012-03-20 17:49:01.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package kdevplatform
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,15 +15,13 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   kdevplatform
-Version:1.2.3
-Release:7
-License:GPL-2.0+
+Version:1.3.0
+Release:0
 Summary:Base Package for Integrated Development Environments
-Url:http://www.kdevelop.org
+License:GPL-2.0+
 Group:  Development/Tools/IDE
+Url:http://www.kdevelop.org
 Source0:%{name}-%{version}.tar.bz2
 BuildRequires:  boost-devel
 BuildRequires:  commoncpp2-devel
@@ -68,6 +66,7 @@
   %find_lang kdevdocumentswitcher %{name}.lang
   %find_lang kdevdocumentview %{name}.lang
   %find_lang kdevexecute %{name}.lang
+  %find_lang kdevexecutescript %{name}.lang
   %find_lang kdevfilemanager %{name}.lang
   %find_lang kdevgenericprojectmanager %{name}.lang
   %find_lang kdevgrepview %{name}.lang
@@ -75,8 +74,10 @@
   %find_lang kdevpatchreview %{name}.lang
   %find_lang kdevplatform %{name}.lang
   %find_lang kdevproblemreporter %{name}.lang
+  %find_lang kdevprojectdashboard %{name}.lang
   %find_lang kdevprojectmanagerview %{name}.lang
   %find_lang kdevquickopen %{name}.lang
+  %find_lang kdevreviewboard %{name}.lang
   %find_lang kdevsnippet %{name}.lang
   %find_lang kdevstandardoutputview %{name}.lang
   %find_lang kdevsubversion %{name}.lang
@@ -85,7 +86,7 @@
   %find_lang kdevcodeutils %{name}.lang
   %find_lang kdevopenwith %{name}.lang
   %find_lang kdevpastebin %{name}.lang
-  %find_lang kdevreviewboard %{name}.lang
+  %find_lang kdevvcsprojectintegration %{name}.lang
 
 %post -p /sbin/ldconfig
 
@@ -97,7 +98,6 @@
 %files lang -f %{name}.lang
 
 %package -n libkdevplatform-devel
-License:GPL-2.0+
 Summary:Base Package for Integrated Development Environments: Build 
Environment
 Group:  Development/Tools/IDE
 Requires:   kdevplatform = %{version}
@@ -124,7 +124,6 @@
 %{_kde4_libdir}/cmake
 
 %package -n libkdevplatform0
-License:GPL-2.0+
 Summary:Libraries for Integrated Development Environments
 

  1   2   >