commit icinga for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package icinga for openSUSE:Factory checked 
in at 2014-09-12 10:03:32

Comparing /work/SRC/openSUSE:Factory/icinga (Old)
 and  /work/SRC/openSUSE:Factory/.icinga.new (New)


Package is icinga

Changes:

--- /work/SRC/openSUSE:Factory/icinga/icinga.changes2014-09-03 
20:00:18.0 +0200
+++ /work/SRC/openSUSE:Factory/.icinga.new/icinga.changes   2014-09-12 
10:03:58.0 +0200
@@ -1,0 +2,8 @@
+Wed Sep  3 12:47:59 UTC 2014 - thard...@suse.com
+
+- update to upstream version 1.11.7
+  * Use versioned dependencies in the RPM spec file #7071 - GB
+  * Import 1.11.7 schema changes from Icinga 2 #6939 - MF
+  * New programstatus column 'endpoint_name' requires schema update to 1.11.7! 
#6939
+
+---

Old:

  icinga-1.11.6.tar.gz

New:

  icinga-1.11.7.tar.gz



Other differences:
--
++ icinga.spec ++
--- /var/tmp/diff_new_pack.5xIb71/_old  2014-09-12 10:04:00.0 +0200
+++ /var/tmp/diff_new_pack.5xIb71/_new  2014-09-12 10:04:00.0 +0200
@@ -23,7 +23,7 @@
 %endif
 
 Name:   icinga
-Version:1.11.6
+Version:1.11.7
 Release:0
 
 Summary:Host/service/network monitoring program
@@ -133,7 +133,7 @@
 Group:  System/Monitoring
 Provides:   %{name}-classicui
 Provides:   monitoring_webfrontend
-Requires:   %{name}-classicui-config
+Requires:   %{name}-classicui-config = %{version}
 Requires:   %{name}-doc = %{version}
 Requires(pre):  apache2
 

++ icinga-1.11.6.tar.gz - icinga-1.11.7.tar.gz ++
/work/SRC/openSUSE:Factory/icinga/icinga-1.11.6.tar.gz 
/work/SRC/openSUSE:Factory/.icinga.new/icinga-1.11.7.tar.gz differ: char 5, 
line 1


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-requests for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package python-requests for openSUSE:Factory 
checked in at 2014-09-12 10:03:33

Comparing /work/SRC/openSUSE:Factory/python-requests (Old)
 and  /work/SRC/openSUSE:Factory/.python-requests.new (New)


Package is python-requests

Changes:

--- /work/SRC/openSUSE:Factory/python-requests/python-requests.changes  
2014-06-16 21:32:36.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-requests.new/python-requests.changes 
2014-09-12 10:04:00.0 +0200
@@ -1,0 +2,23 @@
+Thu Sep 11 12:34:42 UTC 2014 - toddrme2...@gmail.com
+
+- Update to 2.4.1 (2014-09-09)
+  - Now has a security package extras set, 
+``$ pip install requests[security]``
+  - Requests will now use Certifi if it is available.
+  - Capture and re-raise urllib3 ProtocolError
+  - Bugfix for responses that attempt to redirect to themselves 
+forever (wtf?).
+- Update to 2.4.0 (2014-08-29)
+  * Behavioral Changes
+- ``Connection: keep-alive`` header is now sent automatically.
+  * Improvements
+- Support for connect timeouts! Timeout now accepts a tuple 
+  (connect, read) which is used to set individual connect and 
+  read timeouts.
+- Allow copying of PreparedRequests without headers/cookies.
+- Updated bundled urllib3 version.
+- Refactored settings loading from environment
+  new `Session.merge_environment_settings`.
+- Handle socket errors in iter_content.
+
+---

Old:

  requests-2.3.0.tar.gz

New:

  requests-2.4.1.tar.gz



Other differences:
--
++ python-requests.spec ++
--- /var/tmp/diff_new_pack.AVrefy/_old  2014-09-12 10:04:02.0 +0200
+++ /var/tmp/diff_new_pack.AVrefy/_new  2014-09-12 10:04:02.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python-requests
-Version:2.3.0
+Version:2.4.1
 Release:0
 Url:http://python-requests.org
 Summary:Awesome Python HTTP Library That's Actually Usable
@@ -32,7 +32,9 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python
 BuildRequires:  python-devel
+BuildRequires:  python-py
 BuildRequires:  python-setuptools
+Requires:   python-py
 Requires:   python
 %if 0%{?suse_version}  0%{?suse_version} = 1110
 %{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}

++ no-default-cacert-sles.patch ++
--- /var/tmp/diff_new_pack.AVrefy/_old  2014-09-12 10:04:02.0 +0200
+++ /var/tmp/diff_new_pack.AVrefy/_new  2014-09-12 10:04:02.0 +0200
@@ -23,12 +23,12 @@
 ===
 --- requests-1.1.0.orig/requests/certs.py
 +++ requests-1.1.0/requests/certs.py
-@@ -18,7 +18,7 @@ def where():
- def where():
- Return the preferred certificate bundle.
- # vendored bundle inside Requests
--return os.path.join(os.path.dirname(__file__), 'cacert.pem')
-+return None
+@@ -19,7 +19,7 @@
+ def where():
+ Return the preferred certificate bundle.
+ # vendored bundle inside Requests
+-return os.path.join(os.path.dirname(__file__), 'cacert.pem')
++return None
  
  if __name__ == '__main__':
  print(where())

++ no-default-cacert.patch ++
--- /var/tmp/diff_new_pack.AVrefy/_old  2014-09-12 10:04:02.0 +0200
+++ /var/tmp/diff_new_pack.AVrefy/_new  2014-09-12 10:04:02.0 +0200
@@ -12,12 +12,12 @@
  else:
 --- a/requests/certs.py
 +++ b/requests/certs.py
-@@ -18,7 +18,7 @@
- def where():
- Return the preferred certificate bundle.
- # vendored bundle inside Requests
--return os.path.join(os.path.dirname(__file__), 'cacert.pem')
-+return '/etc/ssl/certs/'
+@@ -19,7 +19,7 @@
+ def where():
+ Return the preferred certificate bundle.
+ # vendored bundle inside Requests
+-return os.path.join(os.path.dirname(__file__), 'cacert.pem')
++return '/etc/ssl/certs/'
  
  if __name__ == '__main__':
  print(where())
@@ -26,3 +26,4 @@
 @@ -1 +1 @@
 -include README.rst LICENSE NOTICE HISTORY.rst test_requests.py 
requirements.txt requests/cacert.pem
 +include README.rst LICENSE NOTICE HISTORY.rst test_requests.py 
requirements.txt
+ 

++ requests-2.3.0.tar.gz - requests-2.4.1.tar.gz ++
 3858 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit lmdb for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package lmdb for openSUSE:Factory checked in 
at 2014-09-12 10:03:27

Comparing /work/SRC/openSUSE:Factory/lmdb (Old)
 and  /work/SRC/openSUSE:Factory/.lmdb.new (New)


Package is lmdb

Changes:

--- /work/SRC/openSUSE:Factory/lmdb/lmdb.changes2014-08-05 
21:11:23.0 +0200
+++ /work/SRC/openSUSE:Factory/.lmdb.new/lmdb.changes   2014-09-12 
10:03:43.0 +0200
@@ -1,0 +2,13 @@
+Wed Sep 10 20:34:09 UTC 2014 - crrodrig...@opensuse.org
+
+- automake.diff changes: 
+* for autoconf tests to have effect, (like those in 
+  0001-Patch-for-LMDB-to-use-robust-mutexes.patch) config.h must be 
+  included as first file in all C code.
+* in 32 bit systems, ensure we support large databases.
+* Switch the compiler to the current C standard, currently -std=gnu99
+  in upcoming autoconf versions it is C11 though.
+- liblmdb-implicit-decl.patch atol() requires stdlib.h
+- Enable verbose build, rpmlint depends on that to work.
+
+---

New:

  liblmdb-implicit-decl.patch



Other differences:
--
++ lmdb.spec ++
--- /var/tmp/diff_new_pack.rcb16F/_old  2014-09-12 10:03:44.0 +0200
+++ /var/tmp/diff_new_pack.rcb16F/_new  2014-09-12 10:03:44.0 +0200
@@ -30,6 +30,7 @@
 Patch1: automake.diff
 Patch2: 0001-Patch-for-LMDB-to-use-robust-mutexes.patch
 Patch3: 0002-Add-extra-tools-and-CFEngine-modifications-for-LMDB.patch
+Patch4: liblmdb-implicit-decl.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  autoconf
 BuildRequires:  automake = 1.10
@@ -84,12 +85,14 @@
 %patch2 -p1
 # PATCH-FIX-OPENSUSE - debugging tools (https://github.com/kacfengine/lmdb)
 %patch3 -p1
+# PATCH-FIX-OPENSUSE - Implicit declaration of atol()
+%patch4 -p1
 
 %build
 mkdir -p m4
 autoreconf -fi
 %configure --disable-static
-make %{?_smp_mflags}
+make %{?_smp_mflags} V=1
 
 %install
 make install DESTDIR=%buildroot

++ 0002-Add-extra-tools-and-CFEngine-modifications-for-LMDB.patch ++
--- /var/tmp/diff_new_pack.rcb16F/_old  2014-09-12 10:03:44.0 +0200
+++ /var/tmp/diff_new_pack.rcb16F/_new  2014-09-12 10:03:44.0 +0200
@@ -1,6 +1,5 @@
-diff -wruN -x '*~' -x '*.o' -x '*.a' -x '*.so' -x '*.so.[0-9]' -x 
autom4te.cache -x .deps -x .libs ../orig-liblmdb/lmdump.c ./lmdump.c
 ../orig-liblmdb/lmdump.c   1970-01-01 01:00:00.0 +0100
-+++ ./lmdump.c 2014-07-28 17:50:23.263838569 +0200
+--- /dev/null
 liblmdb/lmdump.c
 @@ -0,0 +1,128 @@
 +/* lmdump.c - Lmdb database dumper
 +   Has three modes :
@@ -130,9 +129,8 @@
 +
 +return 0;
 +}
-diff -wruN -x '*~' -x '*.o' -x '*.a' -x '*.so' -x '*.so.[0-9]' -x 
autom4te.cache -x .deps -x .libs ../orig-liblmdb/lmmgr.c ./lmmgr.c
 ../orig-liblmdb/lmmgr.c1970-01-01 01:00:00.0 +0100
-+++ ./lmmgr.c  2014-07-28 17:50:23.263838569 +0200
+--- /dev/null
 liblmdb/lmmgr.c
 @@ -0,0 +1,201 @@
 +/*
 +lmmgr.c : Add, remove or manage the maxreaders value of a given database file
@@ -335,11 +333,10 @@
 +
 +return 1;
 +}
-diff -wruN -x '*~' -x '*.o' -x '*.a' -x '*.so' -x '*.so.[0-9]' -x 
autom4te.cache -x .deps -x .libs ../orig-liblmdb/Makefile.am ./Makefile.am
 ../orig-liblmdb/Makefile.am2014-07-28 17:44:34.137071474 +0200
-+++ ./Makefile.am  2014-07-28 17:58:11.979702178 +0200
-@@ -4,7 +4,7 @@
- AM_CFLAGS = -W -Wall -Wno-unused-parameter -Wbad-function-cast -pthread
+--- liblmdb.orig/Makefile.am
 liblmdb/Makefile.am
+@@ -5,7 +5,7 @@ AM_CFLAGS = -W -Wall -Wno-unused-paramet
+ AM_CPPFLAGS = -include config.h
  LDADD = liblmdb.la
  
 -bin_PROGRAMS = mdb_copy mdb_stat

++ automake.diff ++
--- /var/tmp/diff_new_pack.rcb16F/_old  2014-09-12 10:03:44.0 +0200
+++ /var/tmp/diff_new_pack.rcb16F/_new  2014-09-12 10:03:44.0 +0200
@@ -27,15 +27,14 @@
  configure.ac |   13 +
  2 files changed, 29 insertions(+)
 
-Index: liblmdb/Makefile.am
-===
 --- /dev/null
 +++ liblmdb/Makefile.am
-@@ -0,0 +1,16 @@
+@@ -0,0 +1,17 @@
 +# -*- Makefile -*-
 +
 +ACLOCAL_AMFLAGS = -I m4
 +AM_CFLAGS = -W -Wall -Wno-unused-parameter -Wbad-function-cast -pthread
++AM_CPPFLAGS = -include config.h
 +LDADD = liblmdb.la
 +
 +bin_PROGRAMS = mdb_copy mdb_stat
@@ -48,17 +47,17 @@
 +
 +clean-local:
 +  rm -Rf testdb
-Index: liblmdb/configure.ac
-===
 --- /dev/null
 +++ liblmdb/configure.ac
-@@ -0,0 +1,13 @@
+@@ -0,0 +1,15 @@
 +AC_INIT([liblmdb], [0.9.11], [http://symas.com/mdb/])
 +AC_CONFIG_AUX_DIR([build-aux])
 +AC_CONFIG_HEADERS([config.h])
 +AC_CONFIG_MACRO_DIR([m4])
 

commit vtk for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package vtk for openSUSE:Factory checked in 
at 2014-09-12 10:03:29

Comparing /work/SRC/openSUSE:Factory/vtk (Old)
 and  /work/SRC/openSUSE:Factory/.vtk.new (New)


Package is vtk

Changes:

--- /work/SRC/openSUSE:Factory/vtk/vtk.changes  2014-03-04 14:00:01.0 
+0100
+++ /work/SRC/openSUSE:Factory/.vtk.new/vtk.changes 2014-09-12 
10:03:52.0 +0200
@@ -1,0 +2,7 @@
+Thu Sep 11 01:52:56 UTC 2014 - badshah...@gmail.com
+
+- Add vtk-Mesa10.3-build-failures.patch to workaround build
+  failures when compiling against Mesa = 10.3; patch taken from
+  upstream git and rebased; applied only for openSUSE = 13.2.
+
+---

New:

  vtk-Mesa10.3-build-failures.patch



Other differences:
--
++ vtk.spec ++
--- /var/tmp/diff_new_pack.vK9qmh/_old  2014-09-12 10:03:53.0 +0200
+++ /var/tmp/diff_new_pack.vK9qmh/_new  2014-09-12 10:03:53.0 +0200
@@ -34,6 +34,8 @@
 Patch1: vtk-fix-file-contains-date-time.patch
 # PATCH-FIX-UPSTREAM vtk-install-missing-modules.patch badshah...@gmail.com -- 
Install some cmake modules missed in upstream packaging (will be required if in 
future we can get paraview to use system installed vtk)
 Patch2: vtk-install-missing-modules.patch
+# PATCH-FIX-UPSTREAM vtk-Mesa10.3-build-failures.patch badshah...@gmail.com -- 
 Actually define GLX_GLXEXT_LEGACY to prevent the system glext.h include; fixes 
buld failures with Mesa = 10.3; fix taken from upstream git and rebased
+Patch3: vtk-Mesa10.3-build-failures.patch
 BuildRequires:  Mesa-libGL-devel
 BuildRequires:  R-base-devel
 BuildRequires:  boost-devel
@@ -224,6 +226,9 @@
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%if 0%{?suse_version}  1310
+%patch3 -p1
+%endif
 
 # Replace relative path ../../../VTKData with 
%%{_datadir}/%%{name}data-%%{version}
 # otherwise it will break on symlinks.

++ vtk-Mesa10.3-build-failures.patch ++
Index: VTK-6.1.0/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
===
--- VTK-6.1.0.orig/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
+++ VTK-6.1.0/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
@@ -27,7 +27,7 @@
 
 // define GLX_GLXEXT_LEGACY to prevent glx.h to include glxext.h provided by
 // the system
-//#define GLX_GLXEXT_LEGACY
+#define GLX_GLXEXT_LEGACY
 #include GL/glx.h
 
 #include vtkgl.h
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit docker for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package docker for openSUSE:Factory checked 
in at 2014-09-12 10:03:38

Comparing /work/SRC/openSUSE:Factory/docker (Old)
 and  /work/SRC/openSUSE:Factory/.docker.new (New)


Package is docker

Changes:

--- /work/SRC/openSUSE:Factory/docker/docker.changes2014-09-01 
16:59:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.docker.new/docker.changes   2014-09-12 
10:04:04.0 +0200
@@ -1,0 +2,5 @@
+Thu Sep  4 15:41:39 UTC 2014 - fcaste...@suse.com
+
+- Updates to SUSE's readme file.
+
+---



Other differences:
--
++ README_SUSE.md ++
--- /var/tmp/diff_new_pack.AGLZft/_old  2014-09-12 10:04:06.0 +0200
+++ /var/tmp/diff_new_pack.AGLZft/_new  2014-09-12 10:04:06.0 +0200
@@ -106,19 +106,40 @@
 
 ## Storage drivers
 
-Docker images are made by series of stacked layers. The recommended driver is
-DeviceMapper one, which is also the default choice.
+Docker supports different storage drivers:
 
-The Docker packages ships also an experimental BTRFS driver. To use this driver
-Docker daemon must run on a BTRFS partition already prepared by the host 
system.
-
-To use the experimental BTRFS driver the Docker daemon must be started with 
this
-command:
+  * `vfs`: this driver is automatically used when the Docker host filesystem
+does not support copy-on-write. This is a simple driver which does not 
offer
+some of the advantages of Docker (like sharing layers, more on that in the
+next sections). It is highly reliable but also slow.
+  * `devicemapper`: this driver relies on the device-mapper thin provisioning
+module. It supports copy-on-write, hence it offers all the advantages of
+Docker.
+  * `btrfs`: this driver relies on Btrfs to provide all the features required
+by Docker. To use this driver the `/var/lib/docker` directory must be on a
+btrfs filesystem.
+  * `AUFS`: this driver relies on AUFS union filesystem. Neither the upstream
+kernel nor the SUSE one supports this filesystem. Hence the AUFS driver is
+not built into the SUSE Docker package.
+
+It is possible to specify which driver to use by changing the value of the
+`DOCKER_OPTS` variable defined inside of the `/etc/sysconfig/docker` file.
+This can be done either manually or using yast; by browsing to:
+  * System
+  * /etc/sysconfig Editor
+  * System
+  * Management
+  * DOCKER_OPTS
+menu and entering the `-s storage_driver` string.
 
+For example, to force the usage of the `devicemapper` driver
+enter the following text:
 ```
-docker -d -s btrfs
+DOCKER_OPTS=-s devicemapper
 ```
 
+It is recommended to have `/var/lib/docker` mounted on a different filesystem
+to not affect the Docker host OS in case of a filesystem corruption.
 
 # Setting up a Docker host
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit cmocka for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package cmocka for openSUSE:Factory checked 
in at 2014-09-12 10:03:36

Comparing /work/SRC/openSUSE:Factory/cmocka (Old)
 and  /work/SRC/openSUSE:Factory/.cmocka.new (New)


Package is cmocka

Changes:

--- /work/SRC/openSUSE:Factory/cmocka/cmocka.changes2014-09-03 
19:37:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.cmocka.new/cmocka.changes   2014-09-12 
10:04:03.0 +0200
@@ -1,0 +2,9 @@
+Thu Sep 11 15:03:12 UTC 2014 - a...@cryptomilk.org
+
+- Update to version 0.4.1
+  * Added CMOCKA_TEST_ABORT env variable to leave threading apps.
+  * Fixed count parameter of expect_check() macro.
+  * Fixed reporting the number of tests.
+  * Fixed cmake config files.
+
+---
@@ -4,0 +14,5 @@
+
+---
+Tue Aug 26 13:23:43 UTC 2014 - a...@cryptomilk.org
+
+- Add BuildRequire for pkg-config.

Old:

  cmocka-0.4.0.tar.xz

New:

  cmocka-0.4.1.tar.xz



Other differences:
--
++ cmocka.spec ++
--- /var/tmp/diff_new_pack.mG1bE0/_old  2014-09-12 10:04:04.0 +0200
+++ /var/tmp/diff_new_pack.mG1bE0/_new  2014-09-12 10:04:04.0 +0200
@@ -21,7 +21,7 @@
 BuildRequires:  pkg-config
 
 Name:   cmocka
-Version:0.4.0
+Version:0.4.1
 Release:0
 #
 Summary:Lightweight library to simplify and generalize unit tests for C
@@ -143,8 +143,9 @@
 %{_includedir}/cmocka.h
 %{_libdir}/libcmocka.so
 %{_libdir}/pkgconfig/cmocka.pc
-%{_libdir}/cmake/cmocka-config-version.cmake
-%{_libdir}/cmake/cmocka-config.cmake
+%dir %{_libdir}/cmake/cmocka
+%{_libdir}/cmake/cmocka/cmocka-config-version.cmake
+%{_libdir}/cmake/cmocka/cmocka-config.cmake
 
 %files -n libcmocka-devel-static
 %defattr(-,root,root)

++ cmocka-0.4.0.tar.xz - cmocka-0.4.1.tar.xz ++
Files old/cmocka-0.4.0/.ycm_extra_conf.pyc and 
new/cmocka-0.4.1/.ycm_extra_conf.pyc differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cmocka-0.4.0/CMakeLists.txt 
new/cmocka-0.4.1/CMakeLists.txt
--- old/cmocka-0.4.0/CMakeLists.txt 2014-04-11 15:43:46.0 +0200
+++ new/cmocka-0.4.1/CMakeLists.txt 2014-05-22 14:40:29.0 +0200
@@ -8,7 +8,7 @@
 
 set(APPLICATION_VERSION_MAJOR 0)
 set(APPLICATION_VERSION_MINOR 4)
-set(APPLICATION_VERSION_PATCH 0)
+set(APPLICATION_VERSION_PATCH 1)
 
 set(APPLICATION_VERSION 
${APPLICATION_VERSION_MAJOR}.${APPLICATION_VERSION_MINOR}.${APPLICATION_VERSION_PATCH})
 
@@ -19,7 +19,7 @@
 # Increment AGE. Set REVISION to 0
 #   If the source code was changed, but there were no interface changes:
 # Increment REVISION.
-set(LIBRARY_VERSION 0.2.0)
+set(LIBRARY_VERSION 0.2.1)
 set(LIBRARY_SOVERSION 0)
 
 # where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is 
checked
@@ -67,14 +67,16 @@
 )
 
 # cmake config files
-configure_file(cmocka-config.cmake.in 
${CMAKE_CURRENT_BINARY_DIR}/cmocka-config.cmake @ONLY)
-configure_file(cmocka-config-version.cmake.in 
${CMAKE_CURRENT_BINARY_DIR}/cmocka-config-version.cmake @ONLY)
+set(CMOCKA_LIBRARY_NAME 
@CMAKE_SHARED_LIBRARY_PREFIX@${PROJECT_NAME}@CMAKE_SHARED_LIBRARY_SUFFIX@)
+
+configure_file(${PROJECT_NAME}-config.cmake.in 
${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}-config.cmake @ONLY)
+configure_file(${PROJECT_NAME}-config-version.cmake.in 
${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}-config-version.cmake @ONLY)
 install(
 FILES
-${CMAKE_CURRENT_BINARY_DIR}/cmocka-config.cmake
-${CMAKE_CURRENT_BINARY_DIR}/cmocka-config-version.cmake
+${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}-config.cmake
+${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}-config-version.cmake
 DESTINATION
-${CMAKE_INSTALL_DIR}
+${CMAKE_INSTALL_DIR}/${PROJECT_NAME}
 COMPONENT
 devel
 )
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cmocka-0.4.0/CPackConfig.cmake 
new/cmocka-0.4.1/CPackConfig.cmake
--- old/cmocka-0.4.0/CPackConfig.cmake  2013-11-06 08:12:58.0 +0100
+++ new/cmocka-0.4.1/CPackConfig.cmake  2014-04-14 09:23:21.0 +0200
@@ -19,7 +19,7 @@
 
 ### source generator
 set(CPACK_SOURCE_GENERATOR TGZ)
-set(CPACK_SOURCE_IGNORE_FILES 
~$;[.]swp$;/[.]svn/;/[.]git/;.gitignore;/build/;/obj/;tags;cscope.*)
+set(CPACK_SOURCE_IGNORE_FILES 
~$;[.]swp$;/[.]svn/;/[.]git/;.gitignore;/build/;/obj/;tags;cscope.*;.ycm_extra_conf.pyc)
 set(CPACK_SOURCE_PACKAGE_FILE_NAME 
${CPACK_PACKAGE_NAME}-${CPACK_PACKAGE_VERSION})
 
 if (WIN32)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cmocka-0.4.0/ChangeLog 

commit python3-requests for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package python3-requests for 
openSUSE:Factory checked in at 2014-09-12 10:03:35

Comparing /work/SRC/openSUSE:Factory/python3-requests (Old)
 and  /work/SRC/openSUSE:Factory/.python3-requests.new (New)


Package is python3-requests

Changes:

--- /work/SRC/openSUSE:Factory/python3-requests/python3-requests.changes
2014-07-17 06:58:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-requests.new/python3-requests.changes   
2014-09-12 10:04:02.0 +0200
@@ -1,0 +2,23 @@
+Thu Sep 11 12:34:42 UTC 2014 - toddrme2...@gmail.com
+
+- Update to 2.4.1 (2014-09-09)
+  - Now has a security package extras set, 
+``$ pip install requests[security]``
+  - Requests will now use Certifi if it is available.
+  - Capture and re-raise urllib3 ProtocolError
+  - Bugfix for responses that attempt to redirect to themselves 
+forever (wtf?).
+- Update to 2.4.0 (2014-08-29)
+  * Behavioral Changes
+- ``Connection: keep-alive`` header is now sent automatically.
+  * Improvements
+- Support for connect timeouts! Timeout now accepts a tuple 
+  (connect, read) which is used to set individual connect and 
+  read timeouts.
+- Allow copying of PreparedRequests without headers/cookies.
+- Updated bundled urllib3 version.
+- Refactored settings loading from environment
+  new `Session.merge_environment_settings`.
+- Handle socket errors in iter_content.
+
+---

Old:

  requests-2.3.0.tar.gz

New:

  requests-2.4.1.tar.gz



Other differences:
--
++ python3-requests.spec ++
--- /var/tmp/diff_new_pack.mj7Q2O/_old  2014-09-12 10:04:03.0 +0200
+++ /var/tmp/diff_new_pack.mj7Q2O/_new  2014-09-12 10:04:03.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python3-requests
-Version:2.3.0
+Version:2.4.1
 Release:0
 Url:http://python-requests.org
 Summary:Awesome Python HTTP Library That's Actually Usable
@@ -31,7 +31,9 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python3
 BuildRequires:  python3-devel
+BuildRequires:  python3-py
 BuildRequires:  python3-setuptools
+Requires:   python3-py
 BuildArch:  noarch
 
 %description

++ no-default-cacert-sles.patch ++
--- /var/tmp/diff_new_pack.mj7Q2O/_old  2014-09-12 10:04:03.0 +0200
+++ /var/tmp/diff_new_pack.mj7Q2O/_new  2014-09-12 10:04:03.0 +0200
@@ -23,12 +23,12 @@
 ===
 --- requests-1.1.0.orig/requests/certs.py
 +++ requests-1.1.0/requests/certs.py
-@@ -18,7 +18,7 @@ def where():
- def where():
- Return the preferred certificate bundle.
- # vendored bundle inside Requests
--return os.path.join(os.path.dirname(__file__), 'cacert.pem')
-+return None
+@@ -19,7 +19,7 @@
+ def where():
+ Return the preferred certificate bundle.
+ # vendored bundle inside Requests
+-return os.path.join(os.path.dirname(__file__), 'cacert.pem')
++return None
  
  if __name__ == '__main__':
  print(where())

++ no-default-cacert.patch ++
--- /var/tmp/diff_new_pack.mj7Q2O/_old  2014-09-12 10:04:03.0 +0200
+++ /var/tmp/diff_new_pack.mj7Q2O/_new  2014-09-12 10:04:03.0 +0200
@@ -12,12 +12,12 @@
  else:
 --- a/requests/certs.py
 +++ b/requests/certs.py
-@@ -18,7 +18,7 @@
- def where():
- Return the preferred certificate bundle.
- # vendored bundle inside Requests
--return os.path.join(os.path.dirname(__file__), 'cacert.pem')
-+return '/etc/ssl/certs/'
+@@ -19,7 +19,7 @@
+ def where():
+ Return the preferred certificate bundle.
+ # vendored bundle inside Requests
+-return os.path.join(os.path.dirname(__file__), 'cacert.pem')
++return '/etc/ssl/certs/'
  
  if __name__ == '__main__':
  print(where())
@@ -26,3 +26,4 @@
 @@ -1 +1 @@
 -include README.rst LICENSE NOTICE HISTORY.rst test_requests.py 
requirements.txt requests/cacert.pem
 +include README.rst LICENSE NOTICE HISTORY.rst test_requests.py 
requirements.txt
+ 

++ requests-2.3.0.tar.gz - requests-2.4.1.tar.gz ++
 3858 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-urllib3 for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package python-urllib3 for openSUSE:Factory 
checked in at 2014-09-12 10:03:42

Comparing /work/SRC/openSUSE:Factory/python-urllib3 (Old)
 and  /work/SRC/openSUSE:Factory/.python-urllib3.new (New)


Package is python-urllib3

Changes:

--- /work/SRC/openSUSE:Factory/python-urllib3/python-urllib3.changes
2014-03-21 13:34:29.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-urllib3.new/python-urllib3.changes   
2014-09-12 10:04:08.0 +0200
@@ -1,0 +2,54 @@
+Thu Sep 11 12:38:13 UTC 2014 - toddrme2...@gmail.com
+
+- Remove upstreamed 0001-Don-t-install-dummyserver-into-site-packages.patch
+- Rebase 0001-Don-t-pin-dependency-to-exact-version.patch and
+  urllib3-test-no-coverage.patch
+- Update to version 1.9 (2014-07-04)
+  * Shuffled around development-related files. 
+If you're maintaining a distro package of urllib3, you may need 
+to tweak things. (Issue #415)
+  * Unverified HTTPS requests will trigger a warning on the first 
+request. See our new security documentation for details.
+(Issue #426)
+  * New retry logic and urllib3.util.retry.Retry configuration 
+object. (Issue #326)
+  * All raised exceptions should now wrapped in a 
+urllib3.exceptions.HTTPException-extending exception. 
+(Issue #326)
+  * All errors during a retry-enabled request should be wrapped in
+urllib3.exceptions.MaxRetryError, including timeout-related 
+exceptions which were previously exempt. Underlying error is 
+accessible from the .reason propery. (Issue #326)
+  * urllib3.exceptions.ConnectionError renamed to 
+urllib3.exceptions.ProtocolError. (Issue #326)
+  * Errors during response read (such as IncompleteRead) are now
+wrapped in urllib3.exceptions.ProtocolError. (Issue #418)
+  * Requesting an empty host will raise 
+urllib3.exceptions.LocationValueError. (Issue #417)
+  * Catch read timeouts over SSL connections as 
+urllib3.exceptions.ReadTimeoutError. (Issue #419)
+  * Apply socket arguments before connecting. (Issue #427)
+- Update to version 1.8.3 (2014-06-23)
+  * Fix TLS verification when using a proxy in Python 3.4.1. 
+(Issue #385)
+  * Add disable_cache option to urllib3.util.make_headers. 
+(Issue #393)
+  * Wrap socket.timeout exception with 
+urllib3.exceptions.ReadTimeoutError. (Issue #399)
+  * Fixed proxy-related bug where connections were being reused 
+incorrectly. (Issues #366, #369)
+  * Added socket_options keyword parameter which allows to define 
+setsockopt configuration of new sockets. (Issue #397)
+  * Removed HTTPConnection.tcp_nodelay in favor of 
+HTTPConnection.default_socket_options. (Issue #397)
+  * Fixed TypeError bug in Python 2.6.4. (Issue #411)
+- Update to version 1.8.2 (2014-04-17)
+  * Fix urllib3.util not being included in the package.
+- Update to version 1.8.1 (2014-04-17)
+  * Fix AppEngine bug of HTTPS requests going out as HTTP.
+(Issue #356)
+  * Don't install dummyserver into site-packages as it's only 
+needed for the test suite. (Issue #362)
+  * Added support for specifying source_address. (Issue #352)
+
+---

Old:

  0001-Don-t-install-dummyserver-into-site-packages.patch
  urllib3-1.8.tar.gz

New:

  urllib3-1.9.tar.gz



Other differences:
--
++ python-urllib3.spec ++
--- /var/tmp/diff_new_pack.JgFWCd/_old  2014-09-12 10:04:09.0 +0200
+++ /var/tmp/diff_new_pack.JgFWCd/_new  2014-09-12 10:04:09.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python-urllib3
-Version:1.8
+Version:1.9
 Release:0
 Summary:HTTP library with thread-safe connection pooling, file post, 
and more
 License:MIT
@@ -26,10 +26,8 @@
 Source: 
https://pypi.python.org/packages/source/u/urllib3/urllib3-%{version}.tar.gz
 # PATCH-FIX-UPSTREAM speili...@suse.com -- 
https://github.com/shazow/urllib3/pull/361
 Patch0: 0001-Don-t-pin-dependency-to-exact-version.patch
-# PATCH-FIX-UPSTREAM speili...@suse.com -- 
https://github.com/shazow/urllib3/pull/362
-Patch1: 0001-Don-t-install-dummyserver-into-site-packages.patch
 # PATCH-FIX-OPENSUSE speili...@suse.com -- We need no coverage report
-Patch2: urllib3-test-no-coverage.patch
+Patch1: urllib3-test-no-coverage.patch
 BuildRequires:  python-devel
 # Test requirements:
 BuildRequires:  python-mock = 1.0.1
@@ -62,7 +60,6 @@
 %setup -q -n urllib3-%{version}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 python setup.py build
@@ -71,7 +68,8 @@
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
 
 %check
-nosetests
+rm -rf build
+PYTHONPATH=%{buildroot}%{python_sitelib} 

commit python-configobj for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package python-configobj for 
openSUSE:Factory checked in at 2014-09-12 10:03:31

Comparing /work/SRC/openSUSE:Factory/python-configobj (Old)
 and  /work/SRC/openSUSE:Factory/.python-configobj.new (New)


Package is python-configobj

Changes:

--- /work/SRC/openSUSE:Factory/python-configobj/python-configobj.changes
2014-07-27 18:47:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-configobj.new/python-configobj.changes   
2014-09-12 10:03:56.0 +0200
@@ -1,0 +2,6 @@
+Thu Sep 11 10:37:46 UTC 2014 - toddrme2...@gmail.com
+
+- Update to version 5.0.6
+  * Improves error messages in certain edge cases
+
+---

Old:

  configobj-5.0.5.tar.gz

New:

  configobj-5.0.6.tar.gz



Other differences:
--
++ python-configobj.spec ++
--- /var/tmp/diff_new_pack.DdyE9Y/_old  2014-09-12 10:03:58.0 +0200
+++ /var/tmp/diff_new_pack.DdyE9Y/_new  2014-09-12 10:03:58.0 +0200
@@ -16,26 +16,25 @@
 #
 
 
-%define modname configobj
-Name:   python-%{modname}
-Version:5.0.5
+Name:   python-configobj
+Version:5.0.6
 Release:0
 Url:https://github.com/DiffSK/configobj
 Summary:Config file reading, writing and validation
 License:BSD-3-Clause
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/c/%{modname}/%{modname}-%{version}.tar.gz
+Source: 
http://pypi.python.org/packages/source/c/configobj/configobj-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python-devel
+BuildRequires:  python-six
 Requires:   python-six
 # There are no real docs!
-Provides:   python-%{modname}-docs = %{version}
-Obsoletes:  python-%{modname}-docs  %{version}
+Provides:   python-configobj-docs = %{version}
+Obsoletes:  python-configobj-docs  %{version}
 %if 0%{?suse_version} = 1110
 %{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print(get_python_lib()))}
 %else
 BuildArch:  noarch
-%py_requires
 %endif
 
 %description
@@ -58,7 +57,7 @@
  * Powerful ``unrepr`` mode for storing/retrieving Python data-types
 
 %prep
-%setup -q -n %{modname}-%{version}
+%setup -q -n configobj-%{version}
 
 %build
 python setup.py build
@@ -68,9 +67,9 @@
 
 %files
 %defattr(-,root,root,-)
-%{python_sitelib}/%{modname}.py*
+%{python_sitelib}/configobj.py*
 %{python_sitelib}/validate.py*
 %{python_sitelib}/_version.py*
-%{python_sitelib}/%{modname}-%{version}-py%{py_ver}.egg-info
+%{python_sitelib}/configobj-%{version}-py*.egg-info
 
 %changelog

++ configobj-5.0.5.tar.gz - configobj-5.0.6.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/configobj-5.0.5/PKG-INFO new/configobj-5.0.6/PKG-INFO
--- old/configobj-5.0.5/PKG-INFO2014-04-28 13:18:13.0 +0200
+++ new/configobj-5.0.6/PKG-INFO2014-08-26 03:16:28.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: configobj
-Version: 5.0.5
+Version: 5.0.6
 Summary: Config file reading, writing and validation.
 Home-page: https://github.com/DiffSK/configobj
 Author: Rob Dennis, Eli Courtwright (Michael Foord  Nicola Larosa original 
maintainers)
@@ -26,6 +26,7 @@
 * The order of keys/sections is preserved
 * Powerful ``unrepr`` mode for storing/retrieving Python data-types
 
+| Release 5.0.6 improves error messages in certain edge cases
 | Release 5.0.5 corrects a unicode-bug that still existed in writing 
files
 | Release 5.0.4 corrects a unicode-bug that still existed in reading 
files after
 | fixing lists of string in 5.0.3
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/configobj-5.0.5/_version.py 
new/configobj-5.0.6/_version.py
--- old/configobj-5.0.5/_version.py 2014-04-26 19:06:01.0 +0200
+++ new/configobj-5.0.6/_version.py 2014-08-26 03:13:35.0 +0200
@@ -1 +1 @@
-__version__ = '5.0.5'
\ No newline at end of file
+__version__ = '5.0.6'
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/configobj-5.0.5/configobj.py 
new/configobj-5.0.6/configobj.py
--- old/configobj-5.0.5/configobj.py2014-04-26 19:06:01.0 +0200
+++ new/configobj-5.0.6/configobj.py2014-08-26 03:13:35.0 +0200
@@ -1581,7 +1581,7 @@
 self.indent_type = indent
 cur_depth = sect_open.count('[')
 if cur_depth != sect_close.count(']'):
-

commit python3-rdflib for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package python3-rdflib for openSUSE:Factory 
checked in at 2014-09-12 10:03:41

Comparing /work/SRC/openSUSE:Factory/python3-rdflib (Old)
 and  /work/SRC/openSUSE:Factory/.python3-rdflib.new (New)


Package is python3-rdflib

Changes:

--- /work/SRC/openSUSE:Factory/python3-rdflib/python3-rdflib.changes
2014-09-03 21:01:02.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-rdflib.new/python3-rdflib.changes   
2014-09-12 10:04:06.0 +0200
@@ -1,0 +2,69 @@
+Thu Sep 11 12:31:20 UTC 2014 - toddrme2...@gmail.com
+
+- Update to 4.1.2
+  * This is a bug-fix release.
+* Fixed unicode/str bug in py3 for rdfpipe
+  [#375](https://github.com/RDFLib/rdflib/issues/375)
+- Update to 4.1.1
+  * This is a bug-fix release.
+  * This will be the last RDFLib release to support python 2.5.
+* The RDF/XML Parser was made stricter, now raises exceptions for
+  illegal repeated node-elements.
+  [#363](https://github.com/RDFLib/rdflib/issues/363)
+* The SPARQLUpdateStore now supports non-ascii unicode in update
+  statements
+  [#356](https://github.com/RDFLib/rdflib/issues/356)
+* Fixed a bug in the NTriple/NQuad parser wrt. to unicode escape sequences
+  [#352](https://github.com/RDFLib/rdflib/issues/352)
+* HTML5Lib is no longer pinned to 0.95
+  [#355](https://github.com/RDFLib/rdflib/issues/360)
+* RDF/XML Serializer now uses parseType=Literal for well-formed XML 
literals
+* A bug in the manchester OWL syntax was fixed
+  [#355](https://github.com/RDFLib/rdflib/issues/355)
+- Update to 4.1
+  * This is a new minor version RDFLib, which includes a handful of new 
features:
+* A TriG parser was added (we already had a serializer) - it is
+  up-to-date wrt. to the newest spec from: http://www.w3.org/TR/trig/
+* The Turtle parser was made up to date wrt. to the latest Turtle spec.
+* Many more tests have been added - RDFLib now has over 2000
+  (passing!) tests. This is mainly thanks to the NT, Turtle, TriG,
+  NQuads and SPARQL test-suites from W3C. This also included many
+  fixes to the nt and nquad parsers.
+* ```ConjunctiveGraph``` and ```Dataset``` now support directly 
adding/removing
+  quads with ```add/addN/remove``` methods.
+* ```rdfpipe``` command now supports datasets, and reading/writing context
+  sensitive formats.
+* Optional graph-tracking was added to the Store interface, allowing
+  empty graphs to be tracked for Datasets. The DataSet class also saw
+  a general clean-up, see: 
[#309](https://github.com/RDFLib/rdflib/pull/309)
+* After long deprecation, ```BackwardCompatibleGraph``` was removed.
+  * Minor enhancements/bugs fixed:
+* Many code samples in the documentation were fixed thanks to @PuckCh
+* The new ```IOMemory``` store was optimised a bit
+* ```SPARQL(Update)Store``` has been made more generic.
+* MD5 sums were never reinitialized in ```rdflib.compare```
+* Correct default value for empty prefix in N3
+  [#312](https://github.com/RDFLib/rdflib/issues/312)
+* Fixed tests when running in a non UTF-8 locale
+  [#344](https://github.com/RDFLib/rdflib/issues/344)
+* Prefix in the original turtle have an impact on SPARQL query
+  resolution
+  [#313](https://github.com/RDFLib/rdflib/issues/313)
+* Duplicate BNode IDs from N3 Parser
+  [#305](https://github.com/RDFLib/rdflib/issues/305)
+* Use QNames for TriG graph names
+  [#330](https://github.com/RDFLib/rdflib/issues/330)
+* \u escapes in Turtle/N3 were fixed
+  [#335](https://github.com/RDFLib/rdflib/issues/335)
+* A way to limit the number of triples retrieved from the
+  ```SPARQLStore``` was added
+  [#346](https://github.com/RDFLib/rdflib/pull/346)
+* Dots in localnames in Turtle
+  [#345](https://github.com/RDFLib/rdflib/issues/345)
+  [#336](https://github.com/RDFLib/rdflib/issues/336)
+* ```BNode``` as Graph's public ID
+  [#300](https://github.com/RDFLib/rdflib/issues/300)
+* Introduced ordering of ```QuotedGraphs```
+  [#291](https://github.com/RDFLib/rdflib/issues/291)
+
+---

Old:

  rdflib-4.0.1.tar.gz

New:

  rdflib-4.1.2.tar.gz



Other differences:
--
++ python3-rdflib.spec ++
--- /var/tmp/diff_new_pack.uefNl3/_old  2014-09-12 10:04:07.0 +0200
+++ /var/tmp/diff_new_pack.uefNl3/_new  2014-09-12 10:04:07.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-rdflib
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, 

commit gnuradio for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package gnuradio for openSUSE:Factory 
checked in at 2014-09-12 10:03:30

Comparing /work/SRC/openSUSE:Factory/gnuradio (Old)
 and  /work/SRC/openSUSE:Factory/.gnuradio.new (New)


Package is gnuradio

Changes:

--- /work/SRC/openSUSE:Factory/gnuradio/gnuradio.changes2014-09-03 
19:52:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnuradio.new/gnuradio.changes   2014-09-12 
10:03:55.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep  9 08:06:26 UTC 2014 - co...@suse.com
+
+- disable parallal build - it's too unreliable (due to memory pressure
+  on OBS workers)
+
+---



Other differences:
--
++ gnuradio.spec ++
--- /var/tmp/diff_new_pack.rjbT0Y/_old  2014-09-12 10:03:56.0 +0200
+++ /var/tmp/diff_new_pack.rjbT0Y/_new  2014-09-12 10:03:56.0 +0200
@@ -143,7 +143,7 @@
 %build
 %cmake \
   -DCMAKE_SHARED_LINKER_FLAGS=
-make %{?_smp_mflags}
+make -j1
 
 %install
 %cmake_install

++ _constraints ++
--- /var/tmp/diff_new_pack.rjbT0Y/_old  2014-09-12 10:03:56.0 +0200
+++ /var/tmp/diff_new_pack.rjbT0Y/_new  2014-09-12 10:03:56.0 +0200
@@ -1,7 +1,7 @@
 constraints
  hardware
   memory
-   size unit=G4/size
+   size unit=G5/size
   /memory
  /hardware
-/constraints
\ No newline at end of file
+/constraints

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit irqbalance for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package irqbalance for openSUSE:Factory 
checked in at 2014-09-12 11:19:05

Comparing /work/SRC/openSUSE:Factory/irqbalance (Old)
 and  /work/SRC/openSUSE:Factory/.irqbalance.new (New)


Package is irqbalance

Changes:

--- /work/SRC/openSUSE:Factory/irqbalance/irqbalance.changes2014-06-19 
13:08:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.irqbalance.new/irqbalance.changes   
2014-09-12 11:19:06.0 +0200
@@ -1,0 +2,8 @@
+Thu Sep 11 13:12:26 UTC 2014 - tr...@suse.de
+
+- Only warn once for affinity hint subset empty irqs
+* Add bug-893478_warn-once.patch
+- Rename rcirq_balancer like the package name and the already renamed
+  systemd service: rcirqbalance
+
+---

New:

  bug-893478_warn-once.patch



Other differences:
--
++ irqbalance.spec ++
--- /var/tmp/diff_new_pack.ytoiEq/_old  2014-09-12 11:19:07.0 +0200
+++ /var/tmp/diff_new_pack.ytoiEq/_new  2014-09-12 11:19:07.0 +0200
@@ -25,6 +25,7 @@
 Url:http://code.google.com/p/irqbalance
 Source: 
http://irqbalance.googlecode.com/files/%{name}-%{version}.tar.bz2
 Source3:sysconfig.irqbalance
+Patch0: bug-893478_warn-once.patch
 BuildRequires:  libnuma-devel
 BuildRequires:  libtool
 BuildRequires:  pkgconfig(glib-2.0)
@@ -43,6 +44,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 ./autogen.sh
@@ -62,7 +64,7 @@
 # Remove syslog.target in systemd service file; not provided by systemd anymore
 sed -ie s|After=syslog.target||g misc/irqbalance.service
 install -D -m 0644 misc/irqbalance.service 
%{buildroot}%{_unitdir}/irqbalance.service
-ln -s /usr/sbin/service %{buildroot}%{_sbindir}/rcirq_balancer
+ln -s /usr/sbin/service %{buildroot}%{_sbindir}/rcirqbalance
 
 %pre
 %service_add_pre irqbalance.service
@@ -80,7 +82,7 @@
 %files
 %defattr(-,root,root,-)
 %{_sbindir}/irqbalance
-%{_sbindir}/rcirq_balancer
+%{_sbindir}/rcirqbalance
 %{_unitdir}/irqbalance.service
 %{_mandir}/man1/irqbalance.1.gz
 %{_localstatedir}/adm/fillup-templates/sysconfig.irqbalance

++ bug-893478_warn-once.patch ++
From: Takashi Iwai ti...@suse.com
Only warn once for affinity hint subset empty irqs

bnc#893478

Signed-off-by: Thomas Renninger tr...@suse.de
---
 activate.c |   13 -
 types.h|1 +
 2 files changed, 9 insertions(+), 5 deletions(-)

--- a/activate.c
+++ b/activate.c
@@ -84,11 +84,14 @@ static void activate_mapping(struct irq_
if ((hint_policy == HINT_POLICY_SUBSET) 
(!cpus_empty(info-affinity_hint))) {
cpus_and(applied_mask, applied_mask, 
info-affinity_hint);
-   if (!cpus_intersects(applied_mask, unbanned_cpus))
-   log(TO_ALL, LOG_WARNING,
-   irq %d affinity_hint subset empty\n,
-  info-irq);
-   else
+   if (!cpus_intersects(applied_mask, unbanned_cpus)) {
+   if (!info-warned) {
+   info-warned = 1;
+   log(TO_ALL, LOG_WARNING,
+   irq %d affinity_hint subset 
empty\n,
+   info-irq);
+   }
+   } else
valid_mask = 1;
} else {
valid_mask = 1;
--- a/types.h
+++ b/types.h
@@ -69,6 +69,7 @@ struct irq_info {
uint64_t load;
int moved;
 struct topo_obj *assigned_obj;
+   unsigned int warned;
 };
 
 #endif
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-rdflib for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package python-rdflib for openSUSE:Factory 
checked in at 2014-09-12 11:19:02

Comparing /work/SRC/openSUSE:Factory/python-rdflib (Old)
 and  /work/SRC/openSUSE:Factory/.python-rdflib.new (New)


Package is python-rdflib

Changes:

--- /work/SRC/openSUSE:Factory/python-rdflib/python-rdflib.changes  
2013-03-08 13:29:14.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-rdflib.new/python-rdflib.changes 
2014-09-12 11:19:03.0 +0200
@@ -1,0 +2,93 @@
+Thu Sep 11 12:31:20 UTC 2014 - toddrme2...@gmail.com
+
+- Update to 4.1.2
+  * This is a bug-fix release.
+* Fixed unicode/str bug in py3 for rdfpipe
+  [#375](https://github.com/RDFLib/rdflib/issues/375)
+- Update to 4.1.1
+  * This is a bug-fix release.
+  * This will be the last RDFLib release to support python 2.5.
+* The RDF/XML Parser was made stricter, now raises exceptions for
+  illegal repeated node-elements.
+  [#363](https://github.com/RDFLib/rdflib/issues/363)
+* The SPARQLUpdateStore now supports non-ascii unicode in update
+  statements
+  [#356](https://github.com/RDFLib/rdflib/issues/356)
+* Fixed a bug in the NTriple/NQuad parser wrt. to unicode escape sequences
+  [#352](https://github.com/RDFLib/rdflib/issues/352)
+* HTML5Lib is no longer pinned to 0.95
+  [#355](https://github.com/RDFLib/rdflib/issues/360)
+* RDF/XML Serializer now uses parseType=Literal for well-formed XML 
literals
+* A bug in the manchester OWL syntax was fixed
+  [#355](https://github.com/RDFLib/rdflib/issues/355)
+- Update to 4.1
+  * This is a new minor version RDFLib, which includes a handful of new 
features:
+* A TriG parser was added (we already had a serializer) - it is
+  up-to-date wrt. to the newest spec from: http://www.w3.org/TR/trig/
+* The Turtle parser was made up to date wrt. to the latest Turtle spec.
+* Many more tests have been added - RDFLib now has over 2000
+  (passing!) tests. This is mainly thanks to the NT, Turtle, TriG,
+  NQuads and SPARQL test-suites from W3C. This also included many
+  fixes to the nt and nquad parsers.
+* ```ConjunctiveGraph``` and ```Dataset``` now support directly 
adding/removing
+  quads with ```add/addN/remove``` methods.
+* ```rdfpipe``` command now supports datasets, and reading/writing context
+  sensitive formats.
+* Optional graph-tracking was added to the Store interface, allowing
+  empty graphs to be tracked for Datasets. The DataSet class also saw
+  a general clean-up, see: 
[#309](https://github.com/RDFLib/rdflib/pull/309)
+* After long deprecation, ```BackwardCompatibleGraph``` was removed.
+  * Minor enhancements/bugs fixed:
+* Many code samples in the documentation were fixed thanks to @PuckCh
+* The new ```IOMemory``` store was optimised a bit
+* ```SPARQL(Update)Store``` has been made more generic.
+* MD5 sums were never reinitialized in ```rdflib.compare```
+* Correct default value for empty prefix in N3
+  [#312](https://github.com/RDFLib/rdflib/issues/312)
+* Fixed tests when running in a non UTF-8 locale
+  [#344](https://github.com/RDFLib/rdflib/issues/344)
+* Prefix in the original turtle have an impact on SPARQL query
+  resolution
+  [#313](https://github.com/RDFLib/rdflib/issues/313)
+* Duplicate BNode IDs from N3 Parser
+  [#305](https://github.com/RDFLib/rdflib/issues/305)
+* Use QNames for TriG graph names
+  [#330](https://github.com/RDFLib/rdflib/issues/330)
+* \u escapes in Turtle/N3 were fixed
+  [#335](https://github.com/RDFLib/rdflib/issues/335)
+* A way to limit the number of triples retrieved from the
+  ```SPARQLStore``` was added
+  [#346](https://github.com/RDFLib/rdflib/pull/346)
+* Dots in localnames in Turtle
+  [#345](https://github.com/RDFLib/rdflib/issues/345)
+  [#336](https://github.com/RDFLib/rdflib/issues/336)
+* ```BNode``` as Graph's public ID
+  [#300](https://github.com/RDFLib/rdflib/issues/300)
+* Introduced ordering of ```QuotedGraphs```
+  [#291](https://github.com/RDFLib/rdflib/issues/291)
+
+---
+Fri Dec  6 13:57:34 UTC 2013 - toddrme2...@gmail.com
+
+- Update to 4.0.1
+  * Bugfixes
+- Update to 4.0
+  * The new SPARQL 1.1 engine (rdflib-sparql) has been included in the core 
distribution. SPARQL 1.1 queries and updates should work out of the box.
+  * Several RDF 1.1 features are available:
+* A new DataSet class
+* XMLLiteral and HTMLLiterals
+* BNode (de)skolemization is supported through BNode.skolemize, 
URIRef.de_skolemize, Graph.skolemize and Graph.de_skolemize
+  * Handled of Literal equality was split into lexical comparison (for 

commit dracut for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package dracut for openSUSE:Factory checked 
in at 2014-09-12 11:19:06

Comparing /work/SRC/openSUSE:Factory/dracut (Old)
 and  /work/SRC/openSUSE:Factory/.dracut.new (New)


Package is dracut

Changes:

--- /work/SRC/openSUSE:Factory/dracut/dracut.changes2014-09-06 
12:17:36.0 +0200
+++ /work/SRC/openSUSE:Factory/.dracut.new/dracut.changes   2014-09-12 
11:19:09.0 +0200
@@ -1,0 +2,9 @@
+Thu Sep 11 13:36:03 UTC 2014 - tr...@suse.de
+
+- dracut.usage.asc: Remove distro specific help from manpage (bnc#895363)
+*Add 0156-dracut.usage.asc-Remove-distro-specific-help-from-ma.patch
+- Add /boot/zipl to host devs if it is a mount point (bnc#892187)
+*Add 0157-Add-boot-zipl-to-host-devs-if-it-is-a-mount-point.patch
+- Add SUSE kernel module dependencies (in /etc/modprobe.d/*) (bnc#895331)
+*Add 0158-Add-SUSE-kernel-module-dependencies-in-etc-modprobe..patch
+---

New:

  0156-dracut.usage.asc-Remove-distro-specific-help-from-ma.patch
  0157-Add-boot-zipl-to-host-devs-if-it-is-a-mount-point.patch
  0158-Add-SUSE-kernel-module-dependencies-in-etc-modprobe..patch



Other differences:
--
++ dracut.spec ++
--- /var/tmp/diff_new_pack.zZABsB/_old  2014-09-12 11:19:11.0 +0200
+++ /var/tmp/diff_new_pack.zZABsB/_new  2014-09-12 11:19:11.0 +0200
@@ -176,6 +176,9 @@
 Patch153:   0153-Only-add-network-module-on-request-and-on-dependenci.patch
 Patch154:   0154-resume-Also-allow-this-module-on-S390-again-s2disk-c.patch
 Patch155:   0155-iscsi-iscsi.initiator-and-others-can-and-must-only-s.patch
+Patch156:   0156-dracut.usage.asc-Remove-distro-specific-help-from-ma.patch
+Patch157:   0157-Add-boot-zipl-to-host-devs-if-it-is-a-mount-point.patch
+Patch158:   0158-Add-SUSE-kernel-module-dependencies-in-etc-modprobe..patch
 
 BuildRequires:  asciidoc
 BuildRequires:  bash
@@ -374,6 +377,9 @@
 %patch153 -p1
 %patch154 -p1
 %patch155 -p1
+%patch156 -p1
+%patch157 -p1
+%patch158 -p1
 
 %build
 %configure\

++ 0156-dracut.usage.asc-Remove-distro-specific-help-from-ma.patch ++
From 8c53ac66b29e91fa5a6140e7e414ca884032fd11 Mon Sep 17 00:00:00 2001
From: Thomas Renninger tr...@suse.de
Date: Mon, 8 Sep 2014 16:43:20 +0200
Subject: dracut.usage.asc: Remove distro specific help from manpage

Signed-off-by: Thomas Renninger tr...@suse.de
---
 dracut.usage.asc |   17 +
 1 files changed, 1 insertions(+), 16 deletions(-)

diff --git a/dracut.usage.asc b/dracut.usage.asc
index 0787ead..6f3c513 100644
--- a/dracut.usage.asc
+++ b/dracut.usage.asc
@@ -246,21 +246,6 @@ specified multiple times.
 If your root partition is on a network drive, you have to have the network
 dracut modules installed to create a network aware initramfs image.
 
-On a Red Hat Enterprise Linux or Fedora system, this means, you have to install
-the _dracut-network_ rpm package:
-
-
-
-# yum install dracut-network
-
-
-The resulting initramfs image can be served by a boot manager residing on your
-local hard drive or it can be served by a PXE/TFTP server.
-
-How to setup your PXE/TFTP server can be found in the
-http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Storage_Administration_Guide/[Red
-Hat Enterprise Linux Storage Administration Guide].
-
 If you specify ip=auto on the kernel command line, then dracut asks a dhcp
 server about the ip adress for the machine. The dhcp server can also serve an
 additional root-path, which will set the root device for dracut. With this
@@ -300,7 +285,7 @@ This will reduce the size of the initramfs image 
significantly.
 If the boot process does not succeed, you have several options to debug the
 situation. Some of the basic operations are covered here. For more information
 you should also visit:
-http://fedoraproject.org/wiki/How_to_debug_Dracut_problems
+https://www.kernel.org/pub/linux/utils/boot/dracut/dracut.html
 
 
 [[identifying-your-problem-area]]
-- 
1.7.6.1

++ 0157-Add-boot-zipl-to-host-devs-if-it-is-a-mount-point.patch ++
From 7067073ca16b10749edd6a508e3c4b1c38c3c7c2 Mon Sep 17 00:00:00 2001
From: Thomas Renninger tr...@suse.de
Date: Thu, 11 Sep 2014 15:17:10 +0200
Subject: Add /boot/zipl to host devs if it is a mount point

bnc#892187

Signed-off-by: Thomas Renninger tr...@suse.de
---
 dracut.sh |1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

diff --git a/dracut.sh b/dracut.sh
index 3a0c64b..411a972 100755
--- a/dracut.sh
+++ b/dracut.sh
@@ -1077,6 +1077,7 @@ if [[ $hostonly ]]; then
 /usr/lib64 \
 /boot \
 /boot/efi \
+/boot/zipl \
 ;
 do
 mp=$(readlink -f $mp)
-- 
1.7.6.1


commit kdepimlibs4 for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kdepimlibs4 for openSUSE:Factory 
checked in at 2014-09-12 11:19:11

Comparing /work/SRC/openSUSE:Factory/kdepimlibs4 (Old)
 and  /work/SRC/openSUSE:Factory/.kdepimlibs4.new (New)


Package is kdepimlibs4

Changes:

--- /work/SRC/openSUSE:Factory/kdepimlibs4/kdepimlibs4.changes  2014-08-25 
10:58:15.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdepimlibs4.new/kdepimlibs4.changes 
2014-09-12 11:19:16.0 +0200
@@ -1,0 +2,5 @@
+Thu Sep 11 14:40:56 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Add baselibs.conf, needed for kdebase4-workspace-libs-32bit
+
+---
@@ -6 +11 @@
-   * See http://www.kde.org/announcements/4.13/
+   * See http://www.kde.org/announcements/4.14/

New:

  baselibs.conf



Other differences:
--
++ kdepimlibs4.spec ++
--- /var/tmp/diff_new_pack.qd1i9P/_old  2014-09-12 11:19:16.0 +0200
+++ /var/tmp/diff_new_pack.qd1i9P/_new  2014-09-12 11:19:16.0 +0200
@@ -23,7 +23,8 @@
 License:LGPL-2.1+
 Group:  System/GUI/KDE
 Url:http://www.kde.org
-Source0:kdepimlibs-%{version}.tar.xz
+Source: kdepimlibs-%{version}.tar.xz
+Source1:baselibs.conf
 Patch1: disable-pth-build.diff
 BuildRequires:  boost-devel
 BuildRequires:  cyrus-sasl-devel

++ baselibs.conf ++
libakonadi4
libkdepimlibs4--
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit cronie for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package cronie for openSUSE:Factory checked 
in at 2014-09-12 11:19:08

Comparing /work/SRC/openSUSE:Factory/cronie (Old)
 and  /work/SRC/openSUSE:Factory/.cronie.new (New)


Package is cronie

Changes:

--- /work/SRC/openSUSE:Factory/cronie/cronie.changes2014-06-19 
13:08:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.cronie.new/cronie.changes   2014-09-12 
11:19:12.0 +0200
@@ -1,0 +2,15 @@
+Thu Sep 11 13:59:08 UTC 2014 - kstreit...@suse.com
+
+- clean up with spec-cleaner 
+
+---
+Thu Sep 11 13:51:44 UTC 2014 - kstreit...@suse.com
+
+- fix dangling symlink on sbin/service 
+
+---
+Fri Aug  1 14:32:37 UTC 2014 - vci...@suse.com
+
+- add sysconfig.cron that used to be provided by aaa_base (bnc#860058)
+
+---

New:

  sysconfig.cron



Other differences:
--
++ cronie.spec ++
--- /var/tmp/diff_new_pack.iKt8xB/_old  2014-09-12 11:19:13.0 +0200
+++ /var/tmp/diff_new_pack.iKt8xB/_new  2014-09-12 11:19:13.0 +0200
@@ -17,25 +17,15 @@
 
 
 # 3 : we don't need to do something with /etc/sysconfig/cron for now
-%define cron_configs 
\{/etc/pam.d/crond,/etc/crontab,/etc/cron.deny,/etc/omc/srvinfo.d/cron.xml\}
-
+%define cron_configs 
\{%{_sysconfdir}/pam.d/crond,%{_sysconfdir}/crontab,%{_sysconfdir}/cron.deny,%{_sysconfdir}/omc/srvinfo.d/cron.xml\}
 Name:   cronie
-BuildRequires:  audit-devel
-BuildRequires:  libselinux-devel
-BuildRequires:  pam-devel
-BuildRequires:  pkgconfig(systemd)
-Url:https://fedorahosted.org/cronie/
-Recommends: smtp_daemon
-Suggests:   postfix
-PreReq: permissions cron
-%{?systemd_requires}
 Version:1.4.11
 Release:0
-%{expand: %%define cronie_version %version}
 Summary:Cron Daemon
 License:BSD-3-Clause and GPL-2.0 and MIT
 Group:  System/Daemons
-Source0:
https://fedorahosted.org/releases/c/r/%name/%name-%version.tar.gz
+Url:https://fedorahosted.org/cronie/
+Source0:
https://fedorahosted.org/releases/c/r/%{name}/%{name}-%{version}.tar.gz
 Source2:run-crons
 Source3:sample.root
 Source4:deny.sample
@@ -43,25 +33,37 @@
 Source6:cronie-rpmlintrc
 Source7:cron_to_cronie.README
 Source8:cron.service
+Source9:sysconfig.cron
 # PATCH-FEATURE-OPENSUSE cronie-pam_config.diff added pam config file from old 
cron
-Patch3: %name-pam_config.diff
+Patch3: %{name}-pam_config.diff
 # openSUSE set NHEADER_LINES to 3 - old openSUSE cron put three lines of 
comments 
 # in top of crontab file, so we want to hide this junk comments if user edit 
 # crontab file with crontab -e command, patch grabbed from old openSUSE cron
-Patch4: %name-nheader_lines.diff
+Patch4: %{name}-nheader_lines.diff
 # we use cron.pid instead of crond.pid 
-Patch5: %name-crond_pid.diff
+Patch5: %{name}-crond_pid.diff
 # PATCH-FIX-UPSTREAM mention logging disabling for a command in man
 Patch7: cronie-1.4.7-disable_logging.patch
 # PATCH-FIX-UPSTREAM use run-crons instead of run-parts for anacron 
(bnc#689494)
 Patch8: cronie-anacron-1.4.7-run-crons.patch
 Patch10:cronie-nofork-nopid.patch
 Patch12:cronie-piddir.patch
-Conflicts:  cron = 4.1
+BuildRequires:  audit-devel
+BuildRequires:  libselinux-devel
+BuildRequires:  pam-devel
+BuildRequires:  pkgconfig(systemd)
+Requires(pre):  cron
+Requires(post): permissions
+Requires(post): %fillup_prereq
+Recommends: smtp_daemon
+Suggests:   postfix
 # When finish update protection of sles11 we could uncomment line bellow and 
drop all
 # ugly hacks with subpackage cron needed for proper update proces
 # Obsoletes: cron =4.x
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+%{?systemd_requires}
+%{expand: %%define cronie_version %{version}}
+Conflicts:  cron = 4.1
 
 %description
 cron automatically starts programs at specific times. Add new entries
@@ -99,71 +101,82 @@
 %patch5 -p1
 %patch7 -p1
 %patch8 -p1
-cp %{S:7} ./cron_to_cronie.README
+cp %{SOURCE7} ./cron_to_cronie.README
 %patch10
 %patch12 -p1
+
 %build
 # fill macro CRON_VERSION it is used in top three lines of crontab file,should 
be reworked
-export CFLAGS=$RPM_OPT_FLAGS -DCRON_VERSION=\\\%{version}\\\
+export CFLAGS=%{optflags} -DCRON_VERSION=\\\%{version}\\\
 export LDFLAGS=-Wl,-z,relro,-z,now,-z,defs
-%configure --with-audit --enable-anacron --with-pam --with-selinux 
--with-inotify --enable-pie SPOOL_DIR=/var/spool/cron/tabs
-%{__make} 

commit akonadi-runtime for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package akonadi-runtime for openSUSE:Factory 
checked in at 2014-09-12 11:19:10

Comparing /work/SRC/openSUSE:Factory/akonadi-runtime (Old)
 and  /work/SRC/openSUSE:Factory/.akonadi-runtime.new (New)


Package is akonadi-runtime

Changes:

--- /work/SRC/openSUSE:Factory/akonadi-runtime/akonadi-runtime.changes  
2014-08-25 10:58:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.akonadi-runtime.new/akonadi-runtime.changes 
2014-09-12 11:19:13.0 +0200
@@ -1,0 +2,5 @@
+Thu Sep 11 14:40:56 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Add baselibs.conf, needed for kdebase4-workspace-libs-32bit
+
+---

New:

  baselibs.conf



Other differences:
--
++ akonadi-runtime.spec ++
--- /var/tmp/diff_new_pack.9QSZt2/_old  2014-09-12 11:19:15.0 +0200
+++ /var/tmp/diff_new_pack.9QSZt2/_new  2014-09-12 11:19:15.0 +0200
@@ -25,6 +25,7 @@
 Group:  System/GUI/KDE
 Url:http://akonadi-project.org
 Source: 
http://download.kde.org/stable/%{rname}/src/%{rname}-%{version}.tar.bz2
+Source1:baselibs.conf
 Source99:   akonadi-runtime-rpmlintrc
 BuildRequires:  boost-devel
 BuildRequires:  cmake = 2.8.8

++ baselibs.conf ++
libakonadiprotocolinternals1--
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit qrencode for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package qrencode for openSUSE:Factory 
checked in at 2014-09-12 11:19:16

Comparing /work/SRC/openSUSE:Factory/qrencode (Old)
 and  /work/SRC/openSUSE:Factory/.qrencode.new (New)


Package is qrencode

Changes:

--- /work/SRC/openSUSE:Factory/qrencode/qrencode.changes2013-12-23 
22:19:45.0 +0100
+++ /work/SRC/openSUSE:Factory/.qrencode.new/qrencode.changes   2014-09-12 
11:19:19.0 +0200
@@ -1,0 +2,5 @@
+Thu Sep 11 14:40:56 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Add baselibs.conf, needed for kdebase4-workspace-libs-32bit
+
+---

New:

  baselibs.conf



Other differences:
--
++ qrencode.spec ++
--- /var/tmp/diff_new_pack.k0sH78/_old  2014-09-12 11:19:20.0 +0200
+++ /var/tmp/diff_new_pack.k0sH78/_new  2014-09-12 11:19:20.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package qrencode
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -25,7 +25,8 @@
 License:LGPL-2.1+
 Group:  Productivity/Graphics/Other
 Url:http://fukuchi.org/works/qrencode/index.en.html
-Source0:http://fukuchi.org/works/qrencode/%{name}-%{version}.tar.bz2
+Source: http://fukuchi.org/works/qrencode/%{name}-%{version}.tar.bz2
+Source1:baselibs.conf
 BuildRequires:  pkg-config
 %if !0%{?sles_version}
 BuildRequires:  pkgconfig(libpng)

++ baselibs.conf ++
libqrencode3--
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit mxml for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package mxml for openSUSE:Factory checked in 
at 2014-09-12 11:19:22

Comparing /work/SRC/openSUSE:Factory/mxml (Old)
 and  /work/SRC/openSUSE:Factory/.mxml.new (New)


Package is mxml

Changes:

--- /work/SRC/openSUSE:Factory/mxml/mxml.changes2012-02-16 
10:06:25.0 +0100
+++ /work/SRC/openSUSE:Factory/.mxml.new/mxml.changes   2014-09-12 
11:19:24.0 +0200
@@ -1,0 +2,5 @@
+Thu Sep 11 19:02:58 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Add baselibs.conf
+
+---

New:

  baselibs.conf



Other differences:
--
++ mxml.spec ++
--- /var/tmp/diff_new_pack.XR46TH/_old  2014-09-12 11:19:25.0 +0200
+++ /var/tmp/diff_new_pack.XR46TH/_new  2014-09-12 11:19:25.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package mxml
 #
-# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,15 +16,15 @@
 #
 
 
-
 Name:   mxml
 Url:http://www.easysw.com/~mike/mxml
-License:LGPL-2.1+
-Group:  Development/Libraries/Other
 Version:2.6
-Release:25
+Release:0
 Summary:Small XML Parsing Library
+License:LGPL-2.1+
+Group:  Development/Libraries/Other
 Source: %{name}-%{version}.tar.bz2
+Source1:baselibs.conf
 Patch:  mxml-2.3-nobinstrip.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  pkgconfig
@@ -45,9 +45,10 @@
 %define library_name libmxml1
 
 %package -n %library_name
-Group:  Development/Libraries/Other
 #
 Summary:Shared library for mxml
+License:LGPL-2.1+
+Group:  Development/Libraries/Other
 
 %description -n %library_name
 Mini-XML is a small XML parsing library that you can use to read XML
@@ -63,11 +64,11 @@
 Michael Sweet
 
 %package devel
-License:GPL-2.0+
-Group:  Development/Libraries/Other
 Requires:   %{library_name} = %{version}
 #
 Summary:Development files for mxml
+License:GPL-2.0+
+Group:  Development/Libraries/Other
 
 %description devel
 Mini-XML is a small XML parsing library that you can use to read XML

++ baselibs.conf ++
libmxml1--
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kactivities4 for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kactivities4 for openSUSE:Factory 
checked in at 2014-09-12 11:19:13

Comparing /work/SRC/openSUSE:Factory/kactivities4 (Old)
 and  /work/SRC/openSUSE:Factory/.kactivities4.new (New)


Package is kactivities4

Changes:

--- /work/SRC/openSUSE:Factory/kactivities4/kactivities4.changes
2014-08-16 15:37:34.0 +0200
+++ /work/SRC/openSUSE:Factory/.kactivities4.new/kactivities4.changes   
2014-09-12 11:19:17.0 +0200
@@ -1,0 +2,5 @@
+Thu Sep 11 14:40:56 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Add baselibs.conf, needed for kdebase4-workspace-libs-32bit
+
+---

New:

  baselibs.conf



Other differences:
--
++ kactivities4.spec ++
--- /var/tmp/diff_new_pack.EnqIey/_old  2014-09-12 11:19:18.0 +0200
+++ /var/tmp/diff_new_pack.EnqIey/_new  2014-09-12 11:19:18.0 +0200
@@ -24,7 +24,8 @@
 License:GPL-2.0+ and LGPL-2.1+
 Group:  System/GUI/KDE
 Url:http://www.kde.org
-Source0:kactivities-%{version}.tar.xz
+Source: kactivities-%{version}.tar.xz
+Source1:baselibs.conf
 BuildRequires:  libkde4-devel = %version
 BuildRequires:  update-desktop-files
 BuildRequires:  xz

++ baselibs.conf ++
libkactivities6--
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libprison for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package libprison for openSUSE:Factory 
checked in at 2014-09-12 11:19:15

Comparing /work/SRC/openSUSE:Factory/libprison (Old)
 and  /work/SRC/openSUSE:Factory/.libprison.new (New)


Package is libprison

Changes:

--- /work/SRC/openSUSE:Factory/libprison/libprison.changes  2014-06-25 
06:57:34.0 +0200
+++ /work/SRC/openSUSE:Factory/.libprison.new/libprison.changes 2014-09-12 
11:19:18.0 +0200
@@ -1,0 +2,5 @@
+Thu Sep 11 14:40:56 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Add baselibs.conf, needed for kdebase4-workspace-libs-32bit
+
+---

New:

  baselibs.conf



Other differences:
--
++ libprison.spec ++
--- /var/tmp/diff_new_pack.0Ur9wa/_old  2014-09-12 11:19:19.0 +0200
+++ /var/tmp/diff_new_pack.0Ur9wa/_new  2014-09-12 11:19:19.0 +0200
@@ -25,6 +25,7 @@
 Group:  Development/Libraries/C and C++
 Url:https://projects.kde.org/projects/prison
 Source: 
http://download.kde.org/stable/prison/%{version}/src/%{rname}-%{version}.tar.xz
+Source1:baselibs.conf
 BuildRequires:  cmake
 BuildRequires:  kde4-filesystem
 BuildRequires:  libdmtx-devel

++ baselibs.conf ++
libprison0--
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libdmtx for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package libdmtx for openSUSE:Factory checked 
in at 2014-09-12 11:19:17

Comparing /work/SRC/openSUSE:Factory/libdmtx (Old)
 and  /work/SRC/openSUSE:Factory/.libdmtx.new (New)


Package is libdmtx

Changes:

--- /work/SRC/openSUSE:Factory/libdmtx/libdmtx.changes  2012-11-21 
17:02:09.0 +0100
+++ /work/SRC/openSUSE:Factory/.libdmtx.new/libdmtx.changes 2014-09-12 
11:19:21.0 +0200
@@ -1,0 +2,5 @@
+Thu Sep 11 14:40:56 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Add baselibs.conf, needed for kdebase4-workspace-libs-32bit
+
+---

New:

  baselibs.conf



Other differences:
--
++ libdmtx.spec ++
--- /var/tmp/diff_new_pack.ML6EL1/_old  2014-09-12 11:19:22.0 +0200
+++ /var/tmp/diff_new_pack.ML6EL1/_new  2014-09-12 11:19:22.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libdmtx
 #
-# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -25,6 +25,7 @@
 Url:http://www.libdmtx.org
 #Source:http://sourceforge.net/projects/libdmtx/files/
 Source: %{name}-%{version}.tar.bz2
+Source1:baselibs.conf
 Patch0: libdmtx-0.7.4.diff
 BuildRequires:  ImageMagick-devel
 BuildRequires:  pkg-config

++ baselibs.conf ++
libdmtx0--
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit libguestfs for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package libguestfs for openSUSE:Factory 
checked in at 2014-09-12 11:19:24

Comparing /work/SRC/openSUSE:Factory/libguestfs (Old)
 and  /work/SRC/openSUSE:Factory/.libguestfs.new (New)


Package is libguestfs

Changes:

--- /work/SRC/openSUSE:Factory/libguestfs/libguestfs.changes2014-09-03 
20:15:21.0 +0200
+++ /work/SRC/openSUSE:Factory/.libguestfs.new/libguestfs.changes   
2014-09-12 11:19:26.0 +0200
@@ -2 +2,10 @@
-Tue Aug 26 07:20:34 UTC 2014 - oher...@suse.com
+Fri Sep  5 09:53:22 CEST 2014 - oher...@suse.de
+
+- Update to version 1.26.9
+  * customize: fix locking accounts with passwords
+  * daemon: lvm-filter: use augeas for setting the filter
+  * daemon: move AUGEAS_ERROR to the common header
+  * daemon: add add_sprintf
+
+---
+Tue Aug 26 07:20:34 UTC 2014 - oher...@suse.de

Old:

  libguestfs-1.26.8.tar.xz

New:

  libguestfs-1.26.9.tar.xz



Other differences:
--
++ libguestfs.spec ++
--- /var/tmp/diff_new_pack.STD2NN/_old  2014-09-12 11:19:27.0 +0200
+++ /var/tmp/diff_new_pack.STD2NN/_new  2014-09-12 11:19:27.0 +0200
@@ -17,7 +17,7 @@
 #
 
 
-Version:1.26.8
+Version:1.26.9
 Release:0
 
 %define opt %(test -x %{_bindir}/ocamlopt  echo 1 || echo 0)

++ libguestfs-1.26.8.tar.xz - libguestfs-1.26.9.tar.xz ++
 6041 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit osc for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package osc for openSUSE:Factory checked in 
at 2014-09-12 11:19:22

Comparing /work/SRC/openSUSE:Factory/osc (Old)
 and  /work/SRC/openSUSE:Factory/.osc.new (New)


Package is osc

Changes:

--- /work/SRC/openSUSE:Factory/osc/osc.changes  2014-08-27 07:46:59.0 
+0200
+++ /work/SRC/openSUSE:Factory/.osc.new/osc.changes 2014-09-12 
11:19:22.0 +0200
@@ -1,0 +2,16 @@
+Fri Sep 12 07:03:37 UTC 2014 - adr...@suse.de
+
+- 0.148.1
+  - fixes crash regression
+
+---
+Thu Sep 11 10:35:57 UTC 2014 - adr...@suse.de
+
+- 0.148.0
+  - support new history including review history of OBS 2.6
+  - display request priorities, if important or critical
+  - add osc rq priorize command to re-priorize existing requests
+  - allow also osc rq ls shortcut
+  - fish shell completion support
+
+---
@@ -4 +20 @@
-- 0.147
+- 0.147.0

Old:

  osc-0.147.0.tar.gz

New:

  osc-0.148.1.tar.gz



Other differences:
--
++ osc.spec ++
--- /var/tmp/diff_new_pack.EIAhaS/_old  2014-09-12 11:19:23.0 +0200
+++ /var/tmp/diff_new_pack.EIAhaS/_new  2014-09-12 11:19:23.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   osc
-Version:0.147.0
+Version:0.148.1
 Release:0
 Summary:openSUSE Build Service Commander
 License:GPL-2.0+

++ PKGBUILD ++
--- /var/tmp/diff_new_pack.EIAhaS/_old  2014-09-12 11:19:23.0 +0200
+++ /var/tmp/diff_new_pack.EIAhaS/_new  2014-09-12 11:19:23.0 +0200
@@ -1,5 +1,5 @@
 pkgname=osc
-pkgver=0.147.0
+pkgver=0.148.1
 pkgrel=0
 pkgdesc=Open Build Service client
 arch=('i686' 'x86_64')
@@ -8,7 +8,7 @@
 groups=('base-devel')
 depends=('python2' 'python2-m2crypto' 'urlgrabber')
 source=(osc-${pkgver}.tar.gz)
-md5sums=('a0a5d3abb52b62ea616c8a209a336096')
+md5sums=('afe87fa0c93848a0492da4505d56725b')
 
 package() {
   msg Installing osc ...

++ _service ++
--- /var/tmp/diff_new_pack.EIAhaS/_old  2014-09-12 11:19:23.0 +0200
+++ /var/tmp/diff_new_pack.EIAhaS/_new  2014-09-12 11:19:23.0 +0200
@@ -1,7 +1,7 @@
 services
   service name=tar_scm mode=disabled
-param name=version0.147.0/param
-param name=revision0.147.0/param
+param name=version0.148.1/param
+param name=revision0.148/param
 param name=urlgit://github.com/openSUSE/osc.git/param
 param name=scmgit/param
   /service

++ osc-0.147.0.tar.gz - osc-0.148.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/osc-0.147.0/NEWS new/osc-0.148.1/NEWS
--- old/osc-0.147.0/NEWS2014-08-26 09:51:39.0 +0200
+++ new/osc-0.148.1/NEWS2014-09-12 09:13:58.0 +0200
@@ -1,3 +1,10 @@
+0.148
+  - support new history including review history of OBS 2.6
+  - display request priorities, if important or critical
+  - add osc rq priorize command to re-priorize existing requests
+  - allow also osc rq ls shortcut
+  - fish shell completion support
+
 0.147
   - support groups in maintainership requests
   - fixing listing of review requests
@@ -8,6 +15,7 @@
   - handle ppc64le for debian as well
   - fix buildlog --strip-time
   - some more minor bugfixes
+  - speedup update of a project working copy (in some cases)
 
 0.146
   - support maintenance release request with acceptinfo data (OBS 2.6)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/osc-0.147.0/osc/build.py new/osc-0.148.1/osc/build.py
--- old/osc-0.147.0/osc/build.py2014-08-26 09:51:39.0 +0200
+++ new/osc-0.148.1/osc/build.py2014-09-12 09:13:58.0 +0200
@@ -268,6 +268,7 @@
 b_built = subprocess.Popen(['find', os.path.join(pacdir, 'KIWI'),
 '-type', 'f'],

stdout=subprocess.PIPE).stdout.read().strip()
+s_built = ''
 elif buildtype == 'dsc':
 b_built = subprocess.Popen(['find', os.path.join(pacdir, 'DEBS'),
 '-name', '*.deb'],
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/osc-0.147.0/osc/commandline.py 
new/osc-0.148.1/osc/commandline.py
--- old/osc-0.147.0/osc/commandline.py  2014-08-26 09:51:39.0 +0200
+++ new/osc-0.148.1/osc/commandline.py  2014-09-12 09:13:58.0 +0200
@@ -1958,6 +1958,9 @@
 
 checkout will checkout the request's source package (submit 
requests only).
 
+priorize change the prioritity of a request to either critical, 
important, moderate or low
+
+
 The 'review' command has 

commit rubygem-nokogiri for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package rubygem-nokogiri for 
openSUSE:Factory checked in at 2014-09-12 11:28:22

Comparing /work/SRC/openSUSE:Factory/rubygem-nokogiri (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-nokogiri.new (New)


Package is rubygem-nokogiri

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-nokogiri/rubygem-nokogiri.changes
2014-06-01 18:54:48.0 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-nokogiri.new/rubygem-nokogiri.changes   
2014-09-12 11:28:23.0 +0200
@@ -1,0 +2,5 @@
+Wed Sep 10 09:59:44 UTC 2014 - mrueck...@suse.de
+
+- remove unneded rm call, this is handled in gem_cleanup.sh now.
+
+---



Other differences:
--
++ rubygem-nokogiri.spec ++
--- /var/tmp/diff_new_pack.7vRIBj/_old  2014-09-12 11:28:24.0 +0200
+++ /var/tmp/diff_new_pack.7vRIBj/_new  2014-09-12 11:28:24.0 +0200
@@ -37,6 +37,7 @@
 # MANUAL END
 Url:http://nokogiri.org
 Source: http://rubygems.org/gems/%{mod_full_name}.gem
+Source1:rubygem-nokogiri-rpmlintrc
 Summary:Nokogiri (鋸) is an HTML, XML, SAX, and Reader parser
 License:MIT
 Group:  Development/Languages/Ruby
@@ -79,7 +80,6 @@
 %gem_cleanup
 # MANUAL
 rm -rf %{buildroot}%{gem_base}/gems/%{mod_full_name}/ports
-rm %{buildroot}%{gem_base}/doc/extensions/*/*/%{mod_full_name}/page-mkmf_log.ri
 
 mkdir -p %{buildroot}%{_sysconfdir}/alternatives
 mv %{buildroot}%{_bindir}/nokogiri{,%{mod_branch}}

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rubygem-gem2rpm for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package rubygem-gem2rpm for openSUSE:Factory 
checked in at 2014-09-12 11:28:21

Comparing /work/SRC/openSUSE:Factory/rubygem-gem2rpm (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-gem2rpm.new (New)


Package is rubygem-gem2rpm

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-gem2rpm/rubygem-gem2rpm.changes  
2014-07-27 18:47:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-gem2rpm.new/rubygem-gem2rpm.changes 
2014-09-12 11:28:22.0 +0200
@@ -1,0 +2,25 @@
+Mon Sep  8 11:02:50 UTC 2014 - mrueck...@suse.de
+
+- changed rubinius macro
+
+---
+Fri Sep  5 09:46:22 UTC 2014 - mrueck...@suse.de
+
+- for easier bootstrapping dont use gem2rpm here for now.
+
+---
+Thu Sep  4 13:34:30 UTC 2014 - mrueck...@suse.de
+
+- make it easier to enable rbx and ruby 2.2 support
+
+---
+Wed Sep  3 12:44:54 UTC 2014 - mrueck...@suse.de
+
+- added support for building for rbx
+
+---
+Mon Jul 28 11:11:27 UTC 2014 - mrueck...@suse.de
+
+- really install the templates as docs
+
+---
@@ -49,0 +75,3 @@
+- added gem2rpm_bootstrap conditional:
+  If this is set to true, the hardcoded subpackage/files sections
+  are used. Otherwise it will use the normal gem2rpm based solution
@@ -58,0 +87 @@
+- only build for 2.1 for now
@@ -127,0 +157,35 @@
+- added quilt series file to the sources list
+- dropped empty doc package
+
+---
+Thu Jun 26 09:58:34 UTC 2014 - mrueck...@suse.de
+
+- update rpm macros requires to 5
+
+---
+Wed Jun 25 17:07:59 UTC 2014 - mrueck...@suse.de
+
+- fix filelist for multi ruby packaging
+
+---
+Wed Jun 25 16:28:46 UTC 2014 - mrueck...@suse.de
+
+- add ruby 2.2 support
+
+---
+Tue Jun 24 15:19:28 UTC 2014 - mrueck...@suse.de
+
+- added BuildIgnore for rubygem(gem2rpm), otherwise we can not
+  bootstrap a new ruby version. this package will need the
+  subpackages for a new ruby version to be created manually.
+
+---
+Wed Jun 18 20:10:04 UTC 2014 - mrueck...@suse.de
+
+- fixed paths in the u-a scriptlets
+
+---
+Wed Jun 18 18:47:31 UTC 2014 - mrueck...@suse.de
+
+- no longer provide gem2rpm-opensuse
+- use new style packaging but the hardcoded version
@@ -140,0 +205 @@
+

New:

  series



Other differences:
--
++ rubygem-gem2rpm.spec ++
--- /var/tmp/diff_new_pack.tpng0C/_old  2014-09-12 11:28:23.0 +0200
+++ /var/tmp/diff_new_pack.tpng0C/_new  2014-09-12 11:28:23.0 +0200
@@ -14,7 +14,9 @@
 
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
-
+%bcond_without  gem2rpm_bootstrap
+%bcond_with ruby22
+%bcond_with rubinius22
 
 Name:   rubygem-gem2rpm
 Version:0.10.1
@@ -23,16 +25,21 @@
 %define mod_full_name %{mod_name}-%{version}
 %define mod_branch -%{version}
 %define mod_weight 1001
-#
+#define rb_build_versions %{rb_default_ruby}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  ruby-macros = 1
-%rubygems_requires
+BuildRequires:  ruby-macros = 5
+BuildRequires:  %{ruby}
+%if %{with gem2rpm_bootstrap}
+#!BuildIgnore:  rubygem(gem2rpm) rubygem(ruby:2.1.0:gem2rpm) 
rubygem(ruby:2.2.0:gem2rpm) rubygem(rbx:2.2:gem2rpm)
+%else
+BuildRequires:  %{rubygem gem2rpm}
+%endif
+BuildRequires:  update-alternatives
 Url:https://github.com/lutter/gem2rpm/
 Source: http://rubygems.org/gems/%{mod_full_name}.gem
 Source1:gem2rpm.yml.documentation
 Source2:gem2rpm-opensuse
-
-
+Source3:series
 Patch0: 0001-use-the-ID-from-os-release-to-use-the-proper-templat.patch
 Patch1: 0002-added-basic-config-file-support-to-gem2rpm-in-yaml-f.patch
 Patch2: 0003-sle-12-templates.-they-require-the-config-file-suppo.patch
@@ -49,15 +56,6 @@
 Generate source rpms and rpm spec files from a Ruby Gem.
 The spec file tries to follow the gem as closely as possible
 
-%package doc
-Summary:RDoc documentation for %{mod_name}
-Group:  Development/Languages/Ruby
-Requires:   %{name} = %{version}
-
-%description doc
-Documentation generated at gem installation time.
-Usually in 

commit libjansson for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package libjansson for openSUSE:Factory 
checked in at 2014-09-12 11:28:41

Comparing /work/SRC/openSUSE:Factory/libjansson (Old)
 and  /work/SRC/openSUSE:Factory/.libjansson.new (New)


Package is libjansson

Changes:

--- /work/SRC/openSUSE:Factory/libjansson/libjansson.changes2014-07-21 
22:34:36.0 +0200
+++ /work/SRC/openSUSE:Factory/.libjansson.new/libjansson.changes   
2014-09-12 12:22:58.0 +0200
@@ -1,0 +2,5 @@
+Thu Sep 11 18:59:04 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Add baselibs.conf
+
+---

New:

  baselibs.conf



Other differences:
--
++ libjansson.spec ++
--- /var/tmp/diff_new_pack.XGQLlw/_old  2014-09-12 12:22:59.0 +0200
+++ /var/tmp/diff_new_pack.XGQLlw/_new  2014-09-12 12:22:59.0 +0200
@@ -27,6 +27,7 @@
 
 #Git-Clone:git://github.com/akheron/jansson
 Source: http://www.digip.org/jansson/releases/jansson-%version.tar.bz2
+Source1:baselibs.conf
 Source2:
http://www.digip.org/jansson/releases/jansson-%version.tar.bz2.asc
 Source3:%name.keyring
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ baselibs.conf ++
libjansson4
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rubygem-flog for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package rubygem-flog for openSUSE:Factory 
checked in at 2014-09-12 11:28:28

Comparing /work/SRC/openSUSE:Factory/rubygem-flog (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-flog.new (New)


Package is rubygem-flog

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-flog/rubygem-flog.changes
2013-10-31 15:55:05.0 +0100
+++ /work/SRC/openSUSE:Factory/.rubygem-flog.new/rubygem-flog.changes   
2014-09-12 12:22:49.0 +0200
@@ -1,0 +2,14 @@
+Wed Sep 10 13:59:44 UTC 2014 - mrueck...@suse.de
+
+- added gem2rpm.yml as source
+
+---
+Wed Sep 10 09:32:05 UTC 2014 - mrueck...@suse.de
+
+- added a small scriptlet to fix the shebang line of the wrapper
+  script in the gem dir. the installed copy has it overwritten
+  but our she bang line checks the not installed copy too.
+- also added a gem2rpm.yml for later, but did not regenerate the
+  specfile just yet.
+
+---

New:

  gem2rpm.yml



Other differences:
--
++ rubygem-flog.spec ++
--- /var/tmp/diff_new_pack.xpOuNf/_old  2014-09-12 12:22:50.0 +0200
+++ /var/tmp/diff_new_pack.xpOuNf/_new  2014-09-12 12:22:50.0 +0200
@@ -30,6 +30,7 @@
 BuildRequires:  rubygem(rdoc)  3.10
 Url:http://ruby.sadi.st/
 Source: http://rubygems.org/gems/%{mod_full_name}.gem
+Source1:gem2rpm.yml
 Summary:Flog reports the most tortured code in an easy to read pain 
report
 License:MIT
 Group:  Development/Languages/Ruby
@@ -73,6 +74,9 @@
 mkdir -p %{buildroot}%{_docdir}/%{name}
 ln -s %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/History.txt 
%buildroot/%{_docdir}/%{name}/History.txt
 ln -s %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/README.txt 
%buildroot/%{_docdir}/%{name}/README.txt
+# MANUAL
+perl -p -i -e 's|#!\S+|#!/usr/bin/ruby|g' 
%{buildroot}%{_libdir}/*/gems/*/gems/%{mod_full_name}/bin/flog
+# /MANUAL
 
 %post
 /usr/sbin/update-alternatives --install \

++ gem2rpm.yml ++
# ---
# ## used by gem2rpm
# :summary: this is a custom summary
# ## used by gem2rpm
# :description: |-
#   this is a custom description
#
#   it can be multiline
# ## used by gem2rpm
# :license: MIT or Ruby
# ## used by gem2rpm and gem_packages
# :version_suffix: -x_y
# ## used by gem2rpm and gem_packages
# :disable_docs: true
# ## used by gem2rpm
# :disable_automatic_rdoc_dep: true
# ## used by gem2rpm
# :preamble: |-
#   BuildRequires: foobar
#   Requires: foobar
# ## used by gem2rpm
# :patches:
#   foo.patch: -p1
#   bar.patch: 
# ## used by gem2rpm
# :sources:
# - foo.desktop
# - bar.desktop
# :gem_install_args: ''
# ## used by gem2rpm
# :pre_install: |-
#   %if 0%{?use_system_libev}
#   export USE_VENDORED_LIBEV=no
#   %endif
# ## used by gem2rpm
# :post_install: |-
#   # delete custom files here or do other fancy stuff
#   install -D -m 0644 %{S:1} %{buildroot}%{_bindir}/gem2rpm-opensuse
# ## used by gem2rpm
# :testsuite_command: |-
#   (pushd %{buildroot}%{gem_base}/gems/%{mod_full_name}  rake test)
# ## used by gem2rpm
# :filelist: |-
#   /usr/bin/gem2rpm-opensuse
# ## used by gem2rpm
# :scripts:
#   :post: |-
# /bin/echo foo
# ## used by gem_packages
# :main:
#   :preamble: |-
# Requires: util-linux
# Recommends: pwgen
#   :filelist: |-
# /usr/bin/gem2rpm-opensuse
# ## used by gem_packages
# :custom:
#   apache:
# :preamble: |-
#   Requires: .
# :filelist: |-
#   /etc/apache2/conf.d/passenger.conf
# :summary: Custom summary is optional
# :description: |-
#   Custom description is optional
#
#   bar
# :post: |-
#   /bin/echo foo
#
---
:post_install: |-
  perl -p -i -e 's|#!\S+|#!/usr/bin/ruby|g' 
%{buildroot}%{_libdir}/*/gems/*/gems/%{mod_full_name}/bin/flog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rubygem-ruby_parser for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package rubygem-ruby_parser for 
openSUSE:Factory checked in at 2014-09-12 11:28:29

Comparing /work/SRC/openSUSE:Factory/rubygem-ruby_parser (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-ruby_parser.new (New)


Package is rubygem-ruby_parser

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-ruby_parser/rubygem-ruby_parser.changes  
2014-05-22 06:57:45.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.rubygem-ruby_parser.new/rubygem-ruby_parser.changes 
2014-09-12 12:22:51.0 +0200
@@ -1,0 +2,13 @@
+Wed Sep 10 13:57:52 UTC 2014 - mrueck...@suse.de
+
+- added gem2rpm.yml as source
+
+---
+Wed Sep 10 09:39:32 UTC 2014 - mrueck...@suse.de
+
+- added a small scriptlet to fix the shebang line of the test
+  scripts
+- also added a gem2rpm.yml for later, but did not regenerate the
+  specfile just yet.
+
+---

New:

  gem2rpm.yml



Other differences:
--
++ rubygem-ruby_parser.spec ++
--- /var/tmp/diff_new_pack.x6jxYM/_old  2014-09-12 12:22:52.0 +0200
+++ /var/tmp/diff_new_pack.x6jxYM/_new  2014-09-12 12:22:52.0 +0200
@@ -30,6 +30,7 @@
 BuildRequires:  rubygem(rdoc)  3.10
 Url:https://github.com/seattlerb/ruby_parser
 Source: http://rubygems.org/gems/%{mod_full_name}.gem
+Source1:gem2rpm.yml
 Summary:ruby_parser (RP) is a ruby parser written in pure ruby 
(utilizing
 License:MIT
 Group:  Development/Languages/Ruby
@@ -96,6 +97,10 @@
 ln -s %{gem_base}/gems/%{mod_full_name}/History.txt 
%buildroot/%{_docdir}/%{name}/History.txt
 ln -s %{gem_base}/gems/%{mod_full_name}/README.txt 
%buildroot/%{_docdir}/%{name}/README.txt
 
+# MANUAL
+perl -p -i -e 's|#!\S+|#!/usr/bin/ruby|g' 
%{buildroot}%{_libdir}/*/gems/*/gems/%{mod_full_name}/test/*
+# /MANUAL
+
 %post
 /usr/sbin/update-alternatives --install \
 %{_bindir}/ruby_parse ruby_parse %{_bindir}/ruby_parse%{mod_branch} 
%{mod_weight}

++ gem2rpm.yml ++
# ---
# ## used by gem2rpm
# :summary: this is a custom summary
# ## used by gem2rpm
# :description: |-
#   this is a custom description
#
#   it can be multiline
# ## used by gem2rpm
# :license: MIT or Ruby
# ## used by gem2rpm and gem_packages
# :version_suffix: -x_y
# ## used by gem2rpm and gem_packages
# :disable_docs: true
# ## used by gem2rpm
# :disable_automatic_rdoc_dep: true
# ## used by gem2rpm
# :preamble: |-
#   BuildRequires: foobar
#   Requires: foobar
# ## used by gem2rpm
# :patches:
#   foo.patch: -p1
#   bar.patch: 
# ## used by gem2rpm
# :sources:
# - foo.desktop
# - bar.desktop
# :gem_install_args: ''
# ## used by gem2rpm
# :pre_install: |-
#   %if 0%{?use_system_libev}
#   export USE_VENDORED_LIBEV=no
#   %endif
# ## used by gem2rpm
# :post_install: |-
#   # delete custom files here or do other fancy stuff
#   install -D -m 0644 %{S:1} %{buildroot}%{_bindir}/gem2rpm-opensuse
# ## used by gem2rpm
# :testsuite_command: |-
#   (pushd %{buildroot}%{gem_base}/gems/%{mod_full_name}  rake test)
# ## used by gem2rpm
# :filelist: |-
#   /usr/bin/gem2rpm-opensuse
# ## used by gem2rpm
# :scripts:
#   :post: |-
# /bin/echo foo
# ## used by gem_packages
# :main:
#   :preamble: |-
# Requires: util-linux
# Recommends: pwgen
#   :filelist: |-
# /usr/bin/gem2rpm-opensuse
# ## used by gem_packages
# :custom:
#   apache:
# :preamble: |-
#   Requires: .
# :filelist: |-
#   /etc/apache2/conf.d/passenger.conf
# :summary: Custom summary is optional
# :description: |-
#   Custom description is optional
#
#   bar
# :post: |-
#   /bin/echo foo
#
---
:post_install: |-
  perl -p -i -e 's|#!\S+|#!/usr/bin/ruby|g' 
%{buildroot}%{_libdir}/*/gems/*/gems/%{mod_full_name}/test/*
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rubygem-sexp_processor-3_2 for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package rubygem-sexp_processor-3_2 for 
openSUSE:Factory checked in at 2014-09-12 11:28:31

Comparing /work/SRC/openSUSE:Factory/rubygem-sexp_processor-3_2 (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-sexp_processor-3_2.new (New)


Package is rubygem-sexp_processor-3_2

Changes:

--- 
/work/SRC/openSUSE:Factory/rubygem-sexp_processor-3_2/rubygem-sexp_processor-3_2.changes
2012-08-05 00:06:44.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.rubygem-sexp_processor-3_2.new/rubygem-sexp_processor-3_2.changes
   2014-09-12 12:22:53.0 +0200
@@ -1,0 +2,13 @@
+Wed Sep 10 13:59:10 UTC 2014 - mrueck...@suse.de
+
+- added gem2rpm.yml as source
+
+---
+Wed Sep 10 09:50:27 UTC 2014 - mrueck...@suse.de
+
+- added a small scriptlet to fix the shebang line of the test
+  scripts.
+- also added a gem2rpm.yml for later, but did not regenerate the
+  specfile just yet.
+
+---

New:

  gem2rpm.yml



Other differences:
--
++ rubygem-sexp_processor-3_2.spec ++
--- /var/tmp/diff_new_pack.NWb2zc/_old  2014-09-12 12:22:54.0 +0200
+++ /var/tmp/diff_new_pack.NWb2zc/_new  2014-09-12 12:22:54.0 +0200
@@ -26,6 +26,7 @@
 BuildRequires:  ruby-macros = 1
 Url:https://github.com/seattlerb/sexp_processor
 Source: %{mod_full_name}.gem
+Source1:gem2rpm.yml
 Summary:sexp_processor branches from ParseTree bringing all the 
generic sexp processing tools with it
 License:MIT
 Group:  Development/Languages/Ruby
@@ -61,6 +62,10 @@
 
 %install
 %gem_install -f
+# MANUAL
+perl -p -i -e 's|#!\S+|#!/usr/bin/ruby|g' 
%{buildroot}%{_libdir}/*/gems/*/gems/%{mod_full_name}/test/*
+# /MANUAL
+
 
 %files
 %defattr(-,root,root,-)

++ gem2rpm.yml ++
# ---
# ## used by gem2rpm
# :summary: this is a custom summary
# ## used by gem2rpm
# :description: |-
#   this is a custom description
#
#   it can be multiline
# ## used by gem2rpm
# :license: MIT or Ruby
# ## used by gem2rpm and gem_packages
# :version_suffix: -x_y
# ## used by gem2rpm and gem_packages
# :disable_docs: true
# ## used by gem2rpm
# :disable_automatic_rdoc_dep: true
# ## used by gem2rpm
# :preamble: |-
#   BuildRequires: foobar
#   Requires: foobar
# ## used by gem2rpm
# :patches:
#   foo.patch: -p1
#   bar.patch: 
# ## used by gem2rpm
# :sources:
# - foo.desktop
# - bar.desktop
# :gem_install_args: ''
# ## used by gem2rpm
# :pre_install: |-
#   %if 0%{?use_system_libev}
#   export USE_VENDORED_LIBEV=no
#   %endif
# ## used by gem2rpm
# :post_install: |-
#   # delete custom files here or do other fancy stuff
#   install -D -m 0644 %{S:1} %{buildroot}%{_bindir}/gem2rpm-opensuse
# ## used by gem2rpm
# :testsuite_command: |-
#   (pushd %{buildroot}%{gem_base}/gems/%{mod_full_name}  rake test)
# ## used by gem2rpm
# :filelist: |-
#   /usr/bin/gem2rpm-opensuse
# ## used by gem2rpm
# :scripts:
#   :post: |-
# /bin/echo foo
# ## used by gem_packages
# :main:
#   :preamble: |-
# Requires: util-linux
# Recommends: pwgen
#   :filelist: |-
# /usr/bin/gem2rpm-opensuse
# ## used by gem_packages
# :custom:
#   apache:
# :preamble: |-
#   Requires: .
# :filelist: |-
#   /etc/apache2/conf.d/passenger.conf
# :summary: Custom summary is optional
# :description: |-
#   Custom description is optional
#
#   bar
# :post: |-
#   /bin/echo foo
#
---
:post_install: |-
  perl -p -i -e 's|#!\S+|#!/usr/bin/ruby|g' 
%{buildroot}%{_libdir}/*/gems/*/gems/%{mod_full_name}/test/*
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rubygem-sexp_processor for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package rubygem-sexp_processor for 
openSUSE:Factory checked in at 2014-09-12 11:28:30

Comparing /work/SRC/openSUSE:Factory/rubygem-sexp_processor (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-sexp_processor.new (New)


Package is rubygem-sexp_processor

Changes:

--- 
/work/SRC/openSUSE:Factory/rubygem-sexp_processor/rubygem-sexp_processor.changes
2014-04-08 12:50:43.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.rubygem-sexp_processor.new/rubygem-sexp_processor.changes
   2014-09-12 12:22:52.0 +0200
@@ -1,0 +2,13 @@
+Wed Sep 10 13:58:31 UTC 2014 - mrueck...@suse.de
+
+- added gem2rpm.yml as source
+
+---
+Wed Sep 10 09:48:40 UTC 2014 - mrueck...@suse.de
+
+- added a small scriptlet to fix the shebang line of the test
+  scripts.
+- also added a gem2rpm.yml for later, but did not regenerate the
+  specfile just yet.
+
+---

New:

  gem2rpm.yml



Other differences:
--
++ rubygem-sexp_processor.spec ++
--- /var/tmp/diff_new_pack.Rk5rIW/_old  2014-09-12 12:22:53.0 +0200
+++ /var/tmp/diff_new_pack.Rk5rIW/_new  2014-09-12 12:22:53.0 +0200
@@ -27,6 +27,7 @@
 BuildRequires:  rubygem(rdoc)  3.10
 Url:https://github.com/seattlerb/sexp_processor
 Source: http://rubygems.org/gems/%{mod_full_name}.gem
+Source1:gem2rpm.yml
 Summary:sexp_processor branches from ParseTree bringing all the 
generic sexp
 License:MIT
 Group:  Development/Languages/Ruby
@@ -65,6 +66,9 @@
 mkdir -p %{buildroot}%{_docdir}/%{name}
 ln -s %{gem_base}/gems/%{mod_full_name}/History.txt 
%buildroot/%{_docdir}/%{name}/History.txt
 ln -s %{gem_base}/gems/%{mod_full_name}/README.txt 
%buildroot/%{_docdir}/%{name}/README.txt
+# MANUAL
+perl -p -i -e 's|#!\S+|#!/usr/bin/ruby|g' 
%{buildroot}%{_libdir}/*/gems/*/gems/%{mod_full_name}/test/*
+# /MANUAL
 
 %files
 %defattr(-,root,root,-)

++ gem2rpm.yml ++
# ---
# ## used by gem2rpm
# :summary: this is a custom summary
# ## used by gem2rpm
# :description: |-
#   this is a custom description
#
#   it can be multiline
# ## used by gem2rpm
# :license: MIT or Ruby
# ## used by gem2rpm and gem_packages
# :version_suffix: -x_y
# ## used by gem2rpm and gem_packages
# :disable_docs: true
# ## used by gem2rpm
# :disable_automatic_rdoc_dep: true
# ## used by gem2rpm
# :preamble: |-
#   BuildRequires: foobar
#   Requires: foobar
# ## used by gem2rpm
# :patches:
#   foo.patch: -p1
#   bar.patch: 
# ## used by gem2rpm
# :sources:
# - foo.desktop
# - bar.desktop
# :gem_install_args: ''
# ## used by gem2rpm
# :pre_install: |-
#   %if 0%{?use_system_libev}
#   export USE_VENDORED_LIBEV=no
#   %endif
# ## used by gem2rpm
# :post_install: |-
#   # delete custom files here or do other fancy stuff
#   install -D -m 0644 %{S:1} %{buildroot}%{_bindir}/gem2rpm-opensuse
# ## used by gem2rpm
# :testsuite_command: |-
#   (pushd %{buildroot}%{gem_base}/gems/%{mod_full_name}  rake test)
# ## used by gem2rpm
# :filelist: |-
#   /usr/bin/gem2rpm-opensuse
# ## used by gem2rpm
# :scripts:
#   :post: |-
# /bin/echo foo
# ## used by gem_packages
# :main:
#   :preamble: |-
# Requires: util-linux
# Recommends: pwgen
#   :filelist: |-
# /usr/bin/gem2rpm-opensuse
# ## used by gem_packages
# :custom:
#   apache:
# :preamble: |-
#   Requires: .
# :filelist: |-
#   /etc/apache2/conf.d/passenger.conf
# :summary: Custom summary is optional
# :description: |-
#   Custom description is optional
#
#   bar
# :post: |-
#   /bin/echo foo
#
---
:post_install: |-
  perl -p -i -e 's|#!\S+|#!/usr/bin/ruby|g' 
%{buildroot}%{_libdir}/*/gems/*/gems/%{mod_full_name}/test/*
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit rubygem-mini_portile for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package rubygem-mini_portile for 
openSUSE:Factory checked in at 2014-09-12 11:28:36

Comparing /work/SRC/openSUSE:Factory/rubygem-mini_portile (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-mini_portile.new (New)


Package is rubygem-mini_portile

Changes:

--- 
/work/SRC/openSUSE:Factory/rubygem-mini_portile/rubygem-mini_portile.changes
2014-05-22 09:04:47.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.rubygem-mini_portile.new/rubygem-mini_portile.changes
   2014-09-12 12:22:56.0 +0200
@@ -1,0 +2,13 @@
+Thu Sep 11 11:03:18 UTC 2014 - co...@suse.com
+
+- back to 0.6.0 - nokogiri (even HEAD) requires it
+
+---
+Thu Sep 11 10:57:10 UTC 2014 - co...@suse.com
+
+- update to 0.6.1
+ * Enhancements:
+   * Expand path to logfile to easier debugging on failures.
+ Pull #33 [marvin2k]
+
+---



Other differences:
--
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit cobbler for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package cobbler for openSUSE:Factory checked 
in at 2014-09-12 11:28:40

Comparing /work/SRC/openSUSE:Factory/cobbler (Old)
 and  /work/SRC/openSUSE:Factory/.cobbler.new (New)


Package is cobbler

Changes:

--- /work/SRC/openSUSE:Factory/cobbler/cobbler.changes  2014-08-03 
15:37:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.cobbler.new/cobbler.changes 2014-09-12 
12:22:57.0 +0200
@@ -1,0 +2,13 @@
+Thu Sep  4 09:43:01 UTC 2014 - fcaste...@suse.com
+
+- Added do_not_use_grubby_compat_when_grub2_is_in_use.diff: prevents
+  usage of grubby-compat when grub2 is active. Use grub2 features
+  do modify the boot loader.
+
+---
+Tue Sep  2 15:08:40 UTC 2014 - fcaste...@suse.com
+
+- Moved grubby-compat inside of the koan sub-package. The scrit was 
accidentally
+  moved into the cobbler package.
+
+---

New:

  do_not_use_grubby_compat_when_grub2_is_in_use.diff



Other differences:
--
++ cobbler.spec ++
--- /var/tmp/diff_new_pack.9wzB3p/_old  2014-09-12 12:22:58.0 +0200
+++ /var/tmp/diff_new_pack.9wzB3p/_new  2014-09-12 12:22:58.0 +0200
@@ -58,6 +58,7 @@
 Patch11:fix-powermanagement-status.dif
 Patch12:bnc_877009.patch
 Patch13:fix_sle_detection.patch
+Patch14:do_not_use_grubby_compat_when_grub2_is_in_use.diff
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
@@ -67,10 +68,10 @@
 BuildRequires:  git
 BuildRequires:  python-cheetah
 %if 0%{?suse_version}
-BuildRequires:  python-PyYAML
-BuildRequires:  distribution-release
-BuildRequires:  atftp
 BuildRequires:  apache2
+BuildRequires:  atftp
+BuildRequires:  distribution-release
+BuildRequires:  python-PyYAML
 Requires:   apache2-mod_wsgi
 Requires:   ipmitool
 %else
@@ -163,6 +164,7 @@
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
+%patch14 -p1
 
 mv vendor-files/cobbler.1.gz docs
 
@@ -404,7 +406,6 @@
 %config /etc/apache2/vhosts.d/cobbler_web.conf
 %config /etc/sysconfig/SuSEfirewall2.d/cobbler
 /usr/sbin/fence_ipmitool
-/usr/sbin/grubby-compat
 /usr/sbin/rccobblerd
 %endif
 
@@ -434,6 +435,9 @@
 %{_bindir}/ovz-install
 %{_bindir}/cobbler-register
 %{python_sitelib}/koan
+%if 0%{?suse_version}
+%attr(0755,root,root) /usr/sbin/grubby-compat
+%endif
 
 %if 0%{?fedora} = 9 || 0%{?rhel} = 5 || 0%{?suse_version}
 %exclude %{python_sitelib}/koan/sub_process.py*

++ do_not_use_grubby_compat_when_grub2_is_in_use.diff ++
diff --git a/koan/app.py b/koan/app.py
index a732309..4a125f8 100644
--- a/koan/app.py
+++ b/koan/app.py
@@ -1042,9 +1042,12 @@ class Koan:
 raise InfoException, grub2 is not installed
 use_grub2 = True
 elif (make == suse):
-if not os.path.exists(/usr/sbin/grubby-compat):
-raise InfoException, grub2 is not installed
-use_grubby_compat = True
+if os.path.exists(/usr/sbin/grub2-install):
+   use_grub2 = True
+else:
+if not os.path.exists(/usr/sbin/grubby-compat):
+   raise InfoException, grubby-compat is not installed
+use_grubby_compat = True
 else:
 if not os.path.exists(/sbin/grubby):
 raise InfoException, grubby is not installed
@@ -1175,10 +1178,13 @@ class Koan:
 
 # Set paths for Ubuntu/Debian
 # TODO: Add support for other distros when they ship grub2
-if make in ['ubuntu', 'debian']:
+if make in ['ubuntu', 'debian', 'suse']:
 grub_file = /etc/grub.d/42_koan
 grub_default_file = /etc/default/grub
-cmd = [update-grub]
+if make in ['suse']:
+cmd = ['/sbin/update-bootloader', '--refresh']
+else:
+cmd = [update-grub]
 default_cmd = ['sed', '-i', 
's/^GRUB_DEFAULT\=.*$/GRUB_DEFAULT=%s/g' % name, grub_default_file]
 
 # Create grub2 menuentry
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit ruby for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package ruby for openSUSE:Factory checked in 
at 2014-09-12 11:28:34

Comparing /work/SRC/openSUSE:Factory/ruby (Old)
 and  /work/SRC/openSUSE:Factory/.ruby.new (New)


Package is ruby

Changes:

--- /work/SRC/openSUSE:Factory/ruby/ruby.changes2014-05-18 
06:50:21.0 +0200
+++ /work/SRC/openSUSE:Factory/.ruby.new/ruby.changes   2014-09-12 
12:22:54.0 +0200
@@ -1,0 +2,31 @@
+Wed Sep 10 15:25:10 UTC 2014 - mrueck...@suse.de
+
+- to make it easier to migrate from the old scheme to the new
+  scheme BuildIgnore: ruby aswell
+
+---
+Tue Sep  9 17:44:06 UTC 2014 - mrueck...@suse.de
+
+- cleaned up buildrequires/requires and added buildignore for rubygem-gem2rpm
+
+---
+Mon Jun 23 10:02:27 UTC 2014 - mrueck...@suse.de
+
+- remove obsolete expand line
+
+---
+Fri Jun 20 13:35:53 UTC 2014 - mrueck...@suse.de
+
+- remove the provides to avoid have choice
+
+---
+Sat Jun 14 14:55:22 UTC 2014 - mrueck...@suse.de
+
+- migrated to just plain wrapper packages
+- patches moved to ruby2.1 package:
+   rubygems-1.5.0_buildroot.patch
+   ruby-1.9.2p290_tcl_no_stupid_rpaths.patch
+   drop_content_size_check_in_xmlrpc.patch
+   ruby19-export_init_prelude.patch
+
+---

Old:

  drop_content_size_check_in_xmlrpc.patch
  gem_build_cleanup
  gem_install.sh
  generate_buildrequires.sh
  generate_rubygemprovides.awk
  ruby-1.9.2p290_tcl_no_stupid_rpaths.patch
  ruby-2.1.2.tar.bz2
  ruby-rpmlintrc
  ruby.macros
  ruby.rpm-macros
  ruby19-export_init_prelude.patch
  rubygems-1.5.0_buildroot.patch
  rubygems.attr
  rubygemsdeps.rb

New:

  README



Other differences:
--
++ ruby.spec ++
--- /var/tmp/diff_new_pack.cO0EW2/_old  2014-09-12 12:22:56.0 +0200
+++ /var/tmp/diff_new_pack.cO0EW2/_new  2014-09-12 12:22:56.0 +0200
@@ -17,104 +17,19 @@
 
 
 Name:   ruby
-
-
-#!!!
-#!!! when updating, check versions of embedded rubygems in package stdlib below
-#!!!
-
-
-%define patch_level p0
-Version:2.1.2
+Version:2.1
 Release:0
-# make the exported API version explicit
-%define api_version 2.1.0
-
-# ruby-macros and ruby-common version
-%define rpm_macros_version 3
-
-#
-%define pkg_version %{version}
-%define libname lib%{name}2_1
-# keep in sync with macro file!
-%define rb_ver  %{api_version}
-%define rb_arch %(echo %{_target_cpu}-linux-gnu | sed -e s/ppc/powerpc/)
-%define rb_libdir %{_libdir}/ruby/%{rb_ver}/
-%define rb_archdir%{_libdir}/ruby/%{rb_ver}/%{rb_arch}
-# keep in sync with macro file!
-#
-# from valgrind.spec
-%ifarch %ix86 x86_64 ppc ppc64
-%define use_valgrind 1
-%endif
-# see https://bugs.ruby-lang.org/issues/8000 - might come back
-%if %suse_version  1230
-%define tk_version_supported 1
-%endif
-# the tests are unfortunately rather fishy
-%define run_tests 0
-
-#
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  awk
-BuildRequires:  gdbm-devel
-BuildRequires:  libffi-devel
-BuildRequires:  libyaml-devel
-BuildRequires:  ncurses-devel
-BuildRequires:  openssl-devel
-BuildRequires:  pkg-config
-BuildRequires:  readline-devel
-BuildRequires:  tk-devel
-BuildRequires:  zlib-devel
-# this requires is needed as distros older than 11.3 have a buildignore on 
freetype2, without this the detection of the tk extension fails
-BuildRequires:  freetype2-devel
-%if 0%{?suse_version}  1010
-BuildRequires:  xorg-x11-libX11-devel
-%else
-BuildRequires:  xorg-x11-devel
-%endif
-%if 0%{?use_valgrind}
-%if 0%{?suse_version}  1021
-BuildRequires:  valgrind-devel
-%else
-BuildRequires:  valgrind
-%endif
-%endif
-Provides:   rubygem-rake = 10.1.0
-Provides:   ruby(abi) = %{rb_ver}
-
-Provides:   ruby-common = %{rpm_macros_version}
-Obsoletes:  ruby-common  %{rpm_macros_version}
-Provides:   ruby21
-Conflicts:  ruby18
-Conflicts:  ruby19
-Conflicts:  ruby20
-Requires:   ruby-stdlib
-PreReq: update-alternatives
-BuildRequires:  update-alternatives
-
-Provides:   ruby-macros = %{rpm_macros_version}
-
-#
+Source: README
 Url:http://www.ruby-lang.org/
-Source: 
http://cache.ruby-lang.org/pub/ruby/2.1/ruby-%{pkg_version}.tar.bz2
-# sources from former ruby-common
-Source1:gem_build_cleanup
-Source2:ruby.macros
-Source3:ruby.rpm-macros
-Source4:rubygems.attr
-Source5:

commit xf86-video-intel for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package xf86-video-intel for 
openSUSE:Factory checked in at 2014-09-12 15:24:59

Comparing /work/SRC/openSUSE:Factory/xf86-video-intel (Old)
 and  /work/SRC/openSUSE:Factory/.xf86-video-intel.new (New)


Package is xf86-video-intel

Changes:

--- /work/SRC/openSUSE:Factory/xf86-video-intel/xf86-video-intel.changes
2014-09-01 16:59:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.xf86-video-intel.new/xf86-video-intel.changes   
2014-09-12 15:25:12.0 +0200
@@ -1,0 +2,41 @@
+Tue Sep  9 13:43:07 UTC 2014 - tobias.johannes.klausm...@mni.thm.de
+
+- Update to 3.0 prerelease 2.99.916:
+  A Quick update for MST in UXA - we need to hook up the RandR outputs
+  for dynamicaly added connectors.
+
+---
+Tue Sep  9 13:40:55 UTC 2014 - tobias.johannes.klausm...@mni.thm.de
+
+- Update to 3.0 prerelease 2.99.915:
+  A significant change to UXA to enable MST and to keep it working on
+  recent kernels needs some soaking before a major release, and the
+  usual plethora of bugfixes. One other feature is the support for
+  hardware rotations on very recent kernels.
+  + Handle rotated scanouts that are all clear correctly. The region to
+update was not being computed correctly, overdrawing the wrong CRTC.
+https://bugs.freedesktop.org/show_bug.cgi?id=81820
+ +  Reset cursor images after rotation and size changes
+https://bugs.freedesktop.org/show_bug.cgi?id=81886
+https://bugs.freedesktop.org/show_bug.cgi?id=82273
+https://bugs.freedesktop.org/show_bug.cgi?id=82337
+  + Handle stale DRI2 buffers and Client errors more gracefully
+  + Fallback if we fail to render a glyph onto a too-large surface, e.g.
+direct rendering of glyphs onto extended desktops with gen2/gen3.
+https://bugs.archlinux.org/task/40949
+  + Further work to enable tiled rendering onto large surfaces in
+severely aperture and memory constrained devices (e.g. gen2/gen3)
+  + Honour the Primary option from xorg.conf and mark that as the RandR
+primary.
+https://bugs.freedesktop.org/show_bug.cgi?id=82193
+https://bugs.freedesktop.org/show_bug.cgi?id=82205
+  + Fix another Client-Window DRI2 close race
+https://bugs.freedesktop.org/show_bug.cgi?id=82979
+  + Fix incorrect discarding of GPU damage when copying over the TearFree
+scanout - which caused a flicker in rapidly updated elements (like
+simple video panes).
+https://bugs.freedesktop.org/show_bug.cgi?id=81973
+- Remove upstreamed patch:
+  Patch1: U_Erase-cursor-image-when-changing-rotation.patch
+
+---

Old:

  U_Erase-cursor-image-when-changing-rotation.patch
  xf86-video-intel-2.99.914.tar.bz2

New:

  xf86-video-intel-2.99.916.tar.bz2



Other differences:
--
++ xf86-video-intel.spec ++
--- /var/tmp/diff_new_pack.okD0Cb/_old  2014-09-12 15:25:13.0 +0200
+++ /var/tmp/diff_new_pack.okD0Cb/_new  2014-09-12 15:25:13.0 +0200
@@ -20,7 +20,7 @@
 %define backlighthelper 0
 
 Name:   xf86-video-intel
-Version:2.99.914
+Version:2.99.916
 Release:0
 Summary:Intel video driver for the Xorg X server
 License:MIT
@@ -88,7 +88,6 @@
 ExclusiveArch:  %ix86 x86_64
 
 Patch0: U_sna_dri3_mesa_relies_upon_implicit_fences.patch
-Patch1: U_Erase-cursor-image-when-changing-rotation.patch
 
 %x11_abi_videodrv_req
 
@@ -107,7 +106,6 @@
 %setup -q
 
 %patch0 -p1
-%patch1 -p1
 
 %build
 autoreconf -fi

++ xf86-video-intel-2.99.914.tar.bz2 - xf86-video-intel-2.99.916.tar.bz2 
++
 6566 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit poppler for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package poppler for openSUSE:Factory checked 
in at 2014-09-12 15:24:53

Comparing /work/SRC/openSUSE:Factory/poppler (Old)
 and  /work/SRC/openSUSE:Factory/.poppler.new (New)


Package is poppler

Changes:

--- /work/SRC/openSUSE:Factory/poppler/poppler-qt.changes   2014-08-06 
15:31:43.0 +0200
+++ /work/SRC/openSUSE:Factory/.poppler.new/poppler-qt.changes  2014-09-12 
15:24:55.0 +0200
@@ -1,0 +2,16 @@
+Tue Sep  9 16:41:22 UTC 2014 - zai...@opensuse.org
+
+- Update to version 0.26.4:
+  + core:
+- CairoOutputDev: Make sure we always push a transparency group
+  in setSoftMaskFromImageMask() (fdo#81624).
+- Fix a crash when adding Annotation without contents.
+- Improve non-latin characters in inline notes (fdo#65956).
+- Don't check for inlineImg twice (fdo#82059).
+- printf() - error().
+  + glib:
+- Return NULL in poppler_annot_get_contents also for empty
+  strings.
+- Fix a memory leak when getting text layout and attributes.
+
+---
poppler-qt5.changes: same change
poppler.changes: same change

Old:

  poppler-0.26.3.tar.xz

New:

  poppler-0.26.4.tar.xz



Other differences:
--
++ poppler-qt.spec ++
--- /var/tmp/diff_new_pack.NMKLq5/_old  2014-09-12 15:24:57.0 +0200
+++ /var/tmp/diff_new_pack.NMKLq5/_new  2014-09-12 15:24:57.0 +0200
@@ -21,7 +21,7 @@
 
 Name:   poppler-qt
 %define _name   poppler
-Version:0.26.3
+Version:0.26.4
 Release:0
 # Actual version of poppler-data:
 %define poppler_data_version 0.4.6

poppler-qt5.spec: same change
++ poppler.spec ++
--- /var/tmp/diff_new_pack.NMKLq5/_old  2014-09-12 15:24:57.0 +0200
+++ /var/tmp/diff_new_pack.NMKLq5/_new  2014-09-12 15:24:57.0 +0200
@@ -21,7 +21,7 @@
 
 Name:   poppler
 %define _name   poppler
-Version:0.26.3
+Version:0.26.4
 Release:0
 # Actual version of poppler-data:
 %define poppler_data_version 0.4.6

++ poppler-0.26.3.tar.xz - poppler-0.26.4.tar.xz ++
 2302 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit yast2-theme for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package yast2-theme for openSUSE:Factory 
checked in at 2014-09-12 15:25:05

Comparing /work/SRC/openSUSE:Factory/yast2-theme (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-theme.new (New)


Package is yast2-theme

Changes:

--- /work/SRC/openSUSE:Factory/yast2-theme/yast2-theme.changes  2014-09-03 
12:50:36.0 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-theme.new/yast2-theme.changes 
2014-09-12 15:25:20.0 +0200
@@ -1,0 +2,6 @@
+Wed Sep 10 11:52:33 UTC 2014 - co...@suse.com
+
+- workaround for rpm's inability to update from symlink to directory
+- 3.1.31
+
+---

Old:

  yast2-theme-3.1.30.tar.bz2

New:

  yast2-theme-3.1.31.tar.bz2



Other differences:
--
++ yast2-theme-SLE.spec ++
--- /var/tmp/diff_new_pack.TrbOSP/_old  2014-09-12 15:25:21.0 +0200
+++ /var/tmp/diff_new_pack.TrbOSP/_new  2014-09-12 15:25:21.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-theme-SLE
-Version:3.1.30
+Version:3.1.31
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-theme.spec ++
--- /var/tmp/diff_new_pack.TrbOSP/_old  2014-09-12 15:25:21.0 +0200
+++ /var/tmp/diff_new_pack.TrbOSP/_new  2014-09-12 15:25:21.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-theme
-Version:3.1.30
+Version:3.1.31
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -82,6 +82,12 @@
 %fdupes $RPM_BUILD_ROOT%{yast_themedir}
 %fdupes $RPM_BUILD_ROOT/usr/share/icons
 
+%pre -n yast2-branding-openSUSE
+# used to be a symlink, we need to remove it so rpm can update to the directory
+if test -L %{yast_themedir}/current ; then
+  rm %{yast_themedir}/current
+fi
+
 %files -n yast2-branding-openSUSE
 %defattr(-,root,root)
 %dir %{yast_themedir}

++ yast2-theme-3.1.30.tar.bz2 - yast2-theme-3.1.31.tar.bz2 ++
/work/SRC/openSUSE:Factory/yast2-theme/yast2-theme-3.1.30.tar.bz2 
/work/SRC/openSUSE:Factory/.yast2-theme.new/yast2-theme-3.1.31.tar.bz2 differ: 
char 11, line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit wicked for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package wicked for openSUSE:Factory checked 
in at 2014-09-12 15:25:01

Comparing /work/SRC/openSUSE:Factory/wicked (Old)
 and  /work/SRC/openSUSE:Factory/.wicked.new (New)


Package is wicked

Changes:

--- /work/SRC/openSUSE:Factory/wicked/wicked.changes2014-09-06 
12:17:57.0 +0200
+++ /work/SRC/openSUSE:Factory/.wicked.new/wicked.changes   2014-09-12 
15:25:15.0 +0200
@@ -1,0 +2,18 @@
+Wed Sep 10 09:34:53 UTC 2014 - pwieczorkiew...@suse.com
+
+- version 0.6.7
+- config: fixed optional include attribute parsing bug introduced 
+  in version 0.6.6 and causing wicked to fail while config parsing. 
+- util: install signal handlers only once
+
+---
+Tue Sep  9 15:20:02 UTC 2014 - pwieczorkiew...@suse.com
+
+- version 0.6.6
+- Add wake-on-lan support (bnc#869114)
+- ifconfig: delete address first if address differs (bnc#890406)
+- config: support a local.xml file, clean-up of config file syntax
+- man page wicked-config.5 update
+- Clean-up and removing unused functions
+
+---

Old:

  wicked-0.6.5.tar.bz2

New:

  wicked-0.6.7.tar.bz2



Other differences:
--
++ wicked.spec ++
--- /var/tmp/diff_new_pack.WAcWMQ/_old  2014-09-12 15:25:16.0 +0200
+++ /var/tmp/diff_new_pack.WAcWMQ/_new  2014-09-12 15:25:16.0 +0200
@@ -18,7 +18,7 @@
 
 %definerelease_prefix  %{?snapshot:%{snapshot}}%{!?snapshot:0}
 Name:   wicked
-Version:0.6.5
+Version:0.6.7
 Release:%{release_prefix}.0.0
 Summary:Network configuration infrastructure
 License:GPL-2.0

++ wicked-0.6.5.tar.bz2 - wicked-0.6.7.tar.bz2 ++
 1956 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit mxml for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package mxml for openSUSE:Factory checked in 
at 2014-09-12 15:25:21

Comparing /work/SRC/openSUSE:Factory/mxml (Old)
 and  /work/SRC/openSUSE:Factory/.mxml.new (New)


Package is mxml

Changes:

--- /work/SRC/openSUSE:Factory/mxml/mxml.changes2014-09-12 
11:19:24.0 +0200
+++ /work/SRC/openSUSE:Factory/.mxml.new/mxml.changes   2014-09-12 
15:25:35.0 +0200
@@ -1,0 +2,5 @@
+Fri Sep 12 08:29:09 UTC 2014 - jeng...@inai.de
+
+- Improve on RPM group classification
+
+---



Other differences:
--
++ mxml.spec ++
--- /var/tmp/diff_new_pack.9OLen4/_old  2014-09-12 15:25:37.0 +0200
+++ /var/tmp/diff_new_pack.9OLen4/_new  2014-09-12 15:25:37.0 +0200
@@ -22,7 +22,8 @@
 Release:0
 Summary:Small XML Parsing Library
 License:LGPL-2.1+
-Group:  Development/Libraries/Other
+Group:  Development/Libraries/C and C++
+
 Source: %{name}-%{version}.tar.bz2
 Source1:baselibs.conf
 Patch:  mxml-2.3-nobinstrip.patch
@@ -48,7 +49,7 @@
 #
 Summary:Shared library for mxml
 License:LGPL-2.1+
-Group:  Development/Libraries/Other
+Group:  System/Libraries
 
 %description -n %library_name
 Mini-XML is a small XML parsing library that you can use to read XML
@@ -68,7 +69,7 @@
 #
 Summary:Development files for mxml
 License:GPL-2.0+
-Group:  Development/Libraries/Other
+Group:  Development/Libraries/C and C++
 
 %description devel
 Mini-XML is a small XML parsing library that you can use to read XML

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit curl for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package curl for openSUSE:Factory checked in 
at 2014-09-12 15:25:04

Comparing /work/SRC/openSUSE:Factory/curl (Old)
 and  /work/SRC/openSUSE:Factory/.curl.new (New)


Package is curl

Changes:

--- /work/SRC/openSUSE:Factory/curl/curl.changes2014-09-01 
16:59:07.0 +0200
+++ /work/SRC/openSUSE:Factory/.curl.new/curl.changes   2014-09-12 
15:25:18.0 +0200
@@ -1,0 +2,25 @@
+Wed Sep 10 09:07:59 UTC 2014 - vci...@suse.com
+
+- update to 7.38.0
+  * fixes CVE-2014-3613 (bnc#894575) and CVE-2014-3620 (bnc#895991)
+  * cookie leaks with IP address as domain and TLDs respectively
+  Changes:
+supports HTTP/2 draft-14
+CURLE_HTTP2 is a new error code
+CURLAUTH_NEGOTIATE is a new auth define
+CURL_VERSION_GSSAPI is a new capability bit
+no longer use fbopenssl for anything
+schannel: use CryptGenRandom for random numbers
+axtls: define curlssl_random using axTLS's PRNG
+cyassl: use RNG_GenerateBlock to generate a good random number
+findprotocol: show unsupported protocol within quotes
+version: detect and show LibreSSL
+version: detect and show BoringSSL
+imap/pop3/smtp: Kerberos (SASL GSSAPI) authentication via Windows SSPI
+http2: requires nghttp2 0.6.0 or later
+  Bugfixes:
+SECURITY ADVISORY: cookie leak with IP address as domain
+SECURITY ADVISORY: cookie leak for TLDs
+And many other fixes
+
+---

Old:

  curl-7.37.1.tar.lzma
  curl-7.37.1.tar.lzma.asc

New:

  curl-7.38.0.tar.lzma
  curl-7.38.0.tar.lzma.asc



Other differences:
--
++ curl.spec ++
--- /var/tmp/diff_new_pack.fieuSN/_old  2014-09-12 15:25:19.0 +0200
+++ /var/tmp/diff_new_pack.fieuSN/_new  2014-09-12 15:25:19.0 +0200
@@ -21,7 +21,7 @@
 %bcond_without testsuite
 
 Name:   curl
-Version:7.37.1
+Version:7.38.0
 Release:0
 Summary:A Tool for Transferring Data from URLs
 License:BSD-3-Clause and MIT

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit librest for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package librest for openSUSE:Factory checked 
in at 2014-09-12 15:24:55

Comparing /work/SRC/openSUSE:Factory/librest (Old)
 and  /work/SRC/openSUSE:Factory/.librest.new (New)


Package is librest

Changes:

--- /work/SRC/openSUSE:Factory/librest/librest.changes  2014-04-04 
16:36:51.0 +0200
+++ /work/SRC/openSUSE:Factory/.librest.new/librest.changes 2014-09-12 
15:24:58.0 +0200
@@ -1,0 +2,9 @@
+Mon Sep  8 08:50:54 UTC 2014 - dims...@opensuse.org
+
+- Update to version 0.7.92:
+  + Bugs fixed: bgo#665716, bgo#708358, bgo#708359, bgo#728340,
+bgo#728952, bgo#728953, bgo#735919, bgo#735920, bgo#735921,
+bgo#735922.
+- Add librest-missing-include.patch: Add missing includes.
+
+---

Old:

  rest-0.7.91.tar.xz

New:

  librest-missing-include.patch
  rest-0.7.92.tar.xz



Other differences:
--
++ librest.spec ++
--- /var/tmp/diff_new_pack.KQAdCJ/_old  2014-09-12 15:24:59.0 +0200
+++ /var/tmp/diff_new_pack.KQAdCJ/_new  2014-09-12 15:24:59.0 +0200
@@ -21,7 +21,7 @@
 %define soname  0
 %define abi 0.7
 %define abi_pkg 0_7
-Version:0.7.91
+Version:0.7.92
 Release:0
 Summary:Library to access RESTful web services
 License:LGPL-2.1
@@ -29,6 +29,8 @@
 Url:http://git.gnome.org/browse/librest/
 Source0:
http://download.gnome.org/sources/rest/0.7/%{_name}-%{version}.tar.xz
 Source99:   baselibs.conf
+# PATCH-FIX-UPSTREAM librest-missing-include.patch dims...@opensuse.org -- Add 
missing includes
+Patch0: librest-missing-include.patch
 BuildRequires:  pkgconfig(glib-2.0) = 2.24
 BuildRequires:  pkgconfig(gobject-introspection-1.0)
 BuildRequires:  pkgconfig(libsoup-2.4)
@@ -91,6 +93,7 @@
 
 %prep
 %setup -q -n %{_name}-%{version}
+%patch0 -p1
 
 %build
 %configure \

++ librest-missing-include.patch ++
commit b50ace7738ea03817acdad87fb2b338a86018329
Author: Christophe Fergeau cferg...@redhat.com
Date:   Wed Sep 3 11:31:49 2014 +0200

oauth: Add missing include

This fixes a compilation warning about a missing prototype.

diff --git a/rest/oauth-proxy-call.c b/rest/oauth-proxy-call.c
index dce2c66..ab77b1a 100644
--- a/rest/oauth-proxy-call.c
+++ b/rest/oauth-proxy-call.c
@@ -25,6 +25,7 @@
 #include rest/rest-proxy-call.h
 #include oauth-proxy-call.h
 #include oauth-proxy-private.h
+#include rest-proxy-call-private.h
 #include sha1.h
 
 G_DEFINE_TYPE (OAuthProxyCall, oauth_proxy_call, REST_TYPE_PROXY_CALL)
++ rest-0.7.91.tar.xz - rest-0.7.92.tar.xz ++
 24447 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kernel-source for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kernel-source for openSUSE:Factory 
checked in at 2014-09-12 15:24:57

Comparing /work/SRC/openSUSE:Factory/kernel-source (Old)
 and  /work/SRC/openSUSE:Factory/.kernel-source.new (New)


Package is kernel-source

Changes:

--- /work/SRC/openSUSE:Factory/kernel-source/kernel-debug.changes   
2014-09-07 11:08:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.kernel-source.new/kernel-debug.changes  
2014-09-12 15:25:05.0 +0200
@@ -1,0 +2,24 @@
+Sun Sep  7 06:40:17 CEST 2014 - jsl...@suse.cz
+
+- Linux 3.16.2 (bko#8 bnc#887046 bnc#889790).
+- Update config files.
+- Refresh patches.xen/xen-x86-EFI.
+- Refresh patches.xen/xen-x86-bzImage.
+- Refresh patches.xen/xen3-auto-common.diff.
+- Refresh patches.xen/xen3-patch-2.6.37.
+- Delete
+  patches.fixes/Btrfs-Fix-memory-corruption-by-ulist_add_merge-on-32.
+- Delete patches.fixes/drm-omapdrm-fix-compiler-errors.
+- Delete
+  patches.fixes/nfs-nfs3_list_one_acl-check-get_acl-result-with-is_err_or_null.
+- Delete
+  patches.suse/btrfs-0003-read-lock-extent-buffer-while-walking-backrefs.patch.
+- Delete
+  patches.suse/btrfs-0006-fix-compressed-write-corruption-on-enospc.patch.
+- Delete
+  patches.suse/btrfs-0008-fix-csum-tree-corruption-duplicate-and-outdate.patch.
+- Delete
+  patches.suse/btrfs-0033-fix-task-hang-under-heavy-compressed-write.patch.
+- commit dcee397
+
+---
kernel-default.changes: same change
kernel-desktop.changes: same change
kernel-docs.changes: same change
kernel-ec2.changes: same change
kernel-lpae.changes: same change
kernel-obs-build.changes: same change
kernel-obs-qa-xen.changes: same change
kernel-obs-qa.changes: same change
kernel-pae.changes: same change
kernel-source.changes: same change
kernel-syms.changes: same change
kernel-vanilla.changes: same change
kernel-xen.changes: same change



Other differences:
--
++ kernel-debug.spec ++
--- /var/tmp/diff_new_pack.moXrcX/_old  2014-09-12 15:25:10.0 +0200
+++ /var/tmp/diff_new_pack.moXrcX/_new  2014-09-12 15:25:10.0 +0200
@@ -20,7 +20,7 @@
 # needssslcertforbuild
 
 %define srcversion 3.16
-%define patchversion 3.16.1
+%define patchversion 3.16.2
 %define variant %{nil}
 %define vanilla_only 0
 
@@ -59,11 +59,11 @@
 Summary:A Debug Version of the Kernel
 License:GPL-2.0
 Group:  System/Kernel
-Version:3.16.1
+Version:3.16.2
 %if 0%{?is_kotd}
-Release:RELEASE.g2ab6585
+Release:RELEASE.gdcee397
 %else
-Release:RELEASE.g2ab6585
+Release:RELEASE.gdcee397
 %endif
 Url:http://www.kernel.org/
 BuildRequires:  bc

kernel-default.spec: same change
kernel-desktop.spec: same change
++ kernel-docs.spec ++
--- /var/tmp/diff_new_pack.moXrcX/_old  2014-09-12 15:25:10.0 +0200
+++ /var/tmp/diff_new_pack.moXrcX/_new  2014-09-12 15:25:10.0 +0200
@@ -16,7 +16,7 @@
 #
 
 
-%define patchversion 3.16.1
+%define patchversion 3.16.2
 %define variant %{nil}
 
 %include %_sourcedir/kernel-spec-macros
@@ -25,11 +25,11 @@
 Summary:Kernel Documentation
 License:GPL-2.0
 Group:  Documentation/Man
-Version:3.16.1
+Version:3.16.2
 %if 0%{?is_kotd}
-Release:RELEASE.g2ab6585
+Release:RELEASE.gdcee397
 %else
-Release:RELEASE.g2ab6585
+Release:RELEASE.gdcee397
 %endif
 BuildRequires:  docbook-toys
 BuildRequires:  docbook-utils

++ kernel-ec2.spec ++
--- /var/tmp/diff_new_pack.moXrcX/_old  2014-09-12 15:25:10.0 +0200
+++ /var/tmp/diff_new_pack.moXrcX/_new  2014-09-12 15:25:10.0 +0200
@@ -20,7 +20,7 @@
 # needssslcertforbuild
 
 %define srcversion 3.16
-%define patchversion 3.16.1
+%define patchversion 3.16.2
 %define variant %{nil}
 %define vanilla_only 0
 
@@ -59,11 +59,11 @@
 Summary:The Amazon EC2 Xen Kernel
 License:GPL-2.0
 Group:  System/Kernel
-Version:3.16.1
+Version:3.16.2
 %if 0%{?is_kotd}
-Release:RELEASE.g2ab6585
+Release:RELEASE.gdcee397
 %else
-Release:RELEASE.g2ab6585
+Release:RELEASE.gdcee397
 %endif
 Url:http://www.kernel.org/
 BuildRequires:  bc

kernel-lpae.spec: same change
++ kernel-obs-build.spec ++
--- /var/tmp/diff_new_pack.moXrcX/_old  2014-09-12 15:25:10.0 +0200
+++ /var/tmp/diff_new_pack.moXrcX/_new  2014-09-12 15:25:10.0 +0200
@@ -19,7 +19,7 @@
 
 #!BuildIgnore: post-build-checks
 
-%define patchversion 3.16.1
+%define patchversion 3.16.2
 %define variant %{nil}
 
 %include %_sourcedir/kernel-spec-macros
@@ -45,11 +45,11 @@
 Summary:package kernel and initrd for OBS VM builds
 

commit telepathy-qt4 for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package telepathy-qt4 for openSUSE:Factory 
checked in at 2014-09-12 15:24:56

Comparing /work/SRC/openSUSE:Factory/telepathy-qt4 (Old)
 and  /work/SRC/openSUSE:Factory/.telepathy-qt4.new (New)


Package is telepathy-qt4

Changes:

--- /work/SRC/openSUSE:Factory/telepathy-qt4/telepathy-qt4.changes  
2014-08-27 22:18:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.telepathy-qt4.new/telepathy-qt4.changes 
2014-09-12 15:25:00.0 +0200
@@ -1,0 +2,16 @@
+Tue Sep  9 22:31:08 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 0.9.5:
+ * Added more service side bindings
+ * Service bindings now enabled by default
+ * Bump Farstream version
+ * Allow subclass of Tp::ReceivedMessage
+ * Workaround invalid channelRequests when delegating, fdo#77986
+- Rebase, reorder and apply search-for-farstream0.2.diff,
+  search-for-gstreamer1.0.diff and
+  search-for-telepathy-farstream-0.4.diff only for
+  openSUSE 13.1 and older
+- Provide telepathy-qt4-service-devel-static, due to newly enabled
+  service library
+
+---

Old:

  telepathy-qt-0.9.4.tar.gz

New:

  telepathy-qt-0.9.5.tar.gz



Other differences:
--
++ telepathy-qt4.spec ++
--- /var/tmp/diff_new_pack.LCxn1E/_old  2014-09-12 15:25:01.0 +0200
+++ /var/tmp/diff_new_pack.LCxn1E/_new  2014-09-12 15:25:01.0 +0200
@@ -26,17 +26,17 @@
 %endif
 
 Name:   telepathy-qt4
-Version:0.9.4
+Version:0.9.5
 Release:0
 Summary:Qt4 bindings for the Telepathy Library
 License:LGPL-2.1+
 Group:  Development/Tools/Other
 Url:http://telepathy.freedesktop.org/
 Source: 
http://telepathy.freedesktop.org/releases/telepathy-qt/telepathy-qt-%{version}.tar.gz
-# PATCH-FIX-UPSTREAM search-for-farstream0.2.diff -- searches for 
farstream0.2, instead of deprecated 0.1
-Patch0: search-for-farstream0.2.diff
 # PATCH-FIX-UPSTREAM search-for-gstreamer1.0.diff -- searches for 
gstreamer1.0, which is only required for includes
-Patch1: search-for-gstreamer1.0.diff
+Patch0: search-for-gstreamer1.0.diff
+# PATCH-FIX-UPSTREAM search-for-farstream0.2.diff -- searches for 
farstream0.2, instead of deprecated 0.1
+Patch1: search-for-farstream0.2.diff
 # PATCH-FIX-UPSTREAM search-for-telepathy-farstream-0.4.diff -- searches for 
telepathy-farstream-0.4
 Patch2: search-for-telepathy-farstream-0.4.diff
 BuildRequires:  cmake
@@ -47,8 +47,8 @@
 BuildRequires:  libxml2-devel
 BuildRequires:  python-xml
 BuildRequires:  pkgconfig(telepathy-glib)
-%if %farstream
-%if %gstreamer1
+%if 0%{?farstream}
+%if 0%{?gstreamer1}
 BuildRequires:  pkgconfig(farstream-0.2)
 BuildRequires:  pkgconfig(gstreamer-1.0)
 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
@@ -78,7 +78,7 @@
 %description -n %{libname}-%{major}
 Telepathy-Qt4 is a high-level binding for Telepathy, similar to telepathy-glib 
but for Qt 4.
 
-%if %farstream
+%if 0%{?farstream}
 %package -n %{libname}-farstream%{major}
 Summary:Library for performing syntax highlighting in Qt documents
 Group:  Development/Tools/Other
@@ -92,9 +92,10 @@
 Summary:Header files, libraries and development documentation for 
%{name}
 Group:  Development/Libraries/C and C++
 Requires:   %{libname}-%{major} = %{version}
-%if %farstream
+Provides:   %{name}-service-devel-static = %{version}
+%if 0%{?farstream}
 Requires:   %{libname}-farstream%{major} = %{version}
-%if %gstreamer1
+%if 0%{?gstreamer1}
 Requires:   pkgconfig(gstreamer-1.0)
 Requires:   pkgconfig(gstreamer-plugins-base-1.0)
 %else
@@ -108,16 +109,11 @@
 
 %prep
 %setup -q -n telepathy-qt-%{version}
-%if 0%{?suse_version} = 1230
-%if %farstream
-%if %gstreamer1
-%patch0 -p1
+%if 0%{?suse_version} = 1310
+%patch0 -Rp1
 %patch1 -p1
-%else
 %patch2 -p1
 %endif
-%endif
-%endif
 
 %build
 export CXXFLAGS=%{optflags}
@@ -141,7 +137,7 @@
 
 %postun -n %{libname}-%{major} -p /sbin/ldconfig
 
-%if %farstream
+%if 0%{?farstream}
 %post -n %{libname}-farstream%{major} -p /sbin/ldconfig
 
 %postun -n %{libname}-farstream%{major} -p /sbin/ldconfig
@@ -151,7 +147,7 @@
 %defattr(-,root,root)
 %{_libdir}/libtelepathy-qt4.so.*
 
-%if %farstream
+%if 0%{?farstream}
 %files -n %{libname}-farstream%{major}
 %defattr(-,root,root)
 %{_libdir}/libtelepathy-qt4-farstream.so.*
@@ -162,9 +158,12 @@
 %doc AUTHORS ChangeLog README COPYING HACKING NEWS
 %{_includedir}/telepathy-qt4/
 %{_libdir}/libtelepathy-qt4.so
+%{_libdir}/libtelepathy-qt4-service.a
 %{_libdir}/pkgconfig/TelepathyQt4.pc
 %{_libdir}/cmake/TelepathyQt4/
-%if %farstream
+%{_libdir}/cmake/TelepathyQt4Service/

commit libaal for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package libaal for openSUSE:Factory checked 
in at 2014-09-12 15:25:15

Comparing /work/SRC/openSUSE:Factory/libaal (Old)
 and  /work/SRC/openSUSE:Factory/.libaal.new (New)


Package is libaal

Changes:

--- /work/SRC/openSUSE:Factory/libaal/libaal.changes2013-04-14 
10:18:27.0 +0200
+++ /work/SRC/openSUSE:Factory/.libaal.new/libaal.changes   2014-09-12 
15:25:32.0 +0200
@@ -1,0 +2,7 @@
+Sun Jun 29 02:50:28 UTC 2014 - jeng...@inai.de
+
+- Update to new upstream release 1.0.6
+* Implement device discard functionality in libaal to be used by
+  mkfs and friends.
+
+---

Old:

  libaal-1.0.5.tar.xz

New:

  libaal-1.0.6.tar.gz



Other differences:
--
++ libaal.spec ++
--- /var/tmp/diff_new_pack.JnPhRQ/_old  2014-09-12 15:25:33.0 +0200
+++ /var/tmp/diff_new_pack.JnPhRQ/_new  2014-09-12 15:25:33.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libaal
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,25 +20,26 @@
 Summary:A library providing application abstraction mechanisms used by 
reiser4progs
 License:GPL-2.0
 Group:  System/Filesystems
-Version:1.0.5
-Release:95
+Version:1.0.6
+Release:0
 Url:http://sf.net/projects/reiser4/
 
-Source: libaal-%version.tar.xz
-Patch1: libaal-%version-rpmoptflags.patch
+Source: http://downloads.sf.net/reiser4/libaal-%version.tar.gz
+Patch1: libaal-1.0.5-rpmoptflags.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  autoconf
+BuildRequires:  automake
 BuildRequires:  libtool
-BuildRequires:  xz
 
 %description
 libaal includes device abstraction, libc independence code, and more.
 
-%package -n libaal-1_0-5
+%package -n libaal-1_0-6
 Summary:A library providing application abstraction mechanisms used by 
reiser4progs
 License:GPL-2.0
 Group:  System/Libraries
 
-%description -n libaal-1_0-5
+%description -n libaal-1_0-6
 libaal includes device abstraction, libc independence code, and more.
 
 %package -n libaal-minimal0
@@ -53,7 +54,7 @@
 Summary:A library providing application abstraction mechanisms used by 
reiser4progs
 License:GPL-2.0+
 Group:  Development/Libraries/C and C++
-Requires:   libaal-1_0-5 = %version
+Requires:   libaal-1_0-6 = %version
 Requires:   libaal-minimal0 = %version
 
 %description devel
@@ -84,15 +85,15 @@
 make %{?_smp_mflags} install DESTDIR=%buildroot
 rm -f %buildroot/%_libdir/*.la
 
-%post   -n libaal-1_0-5 -p /sbin/ldconfig
-%postun -n libaal-1_0-5 -p /sbin/ldconfig
+%post   -n libaal-1_0-6 -p /sbin/ldconfig
+%postun -n libaal-1_0-6 -p /sbin/ldconfig
 %post   -n libaal-minimal0 -p /sbin/ldconfig
 %postun -n libaal-minimal0 -p /sbin/ldconfig
 
-%files -n libaal-1_0-5
+%files -n libaal-1_0-6
 %defattr(-,root,root)
-%doc AUTHORS BUGS COPYING CREDITS ChangeLog README THANKS TODO
-%_libdir/libaal-1.0.so.5*
+%doc COPYING
+%_libdir/libaal-1.0.so.6*
 
 %files -n libaal-minimal0
 %defattr(-,root,root)
@@ -100,6 +101,7 @@
 
 %files devel
 %defattr(-,root,root)
+%doc AUTHORS BUGS CREDITS ChangeLog README THANKS TODO
 %_libdir/libaal*.so
 %_includedir/aal
 %_datadir/aclocal

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit mariadb for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package mariadb for openSUSE:Factory checked 
in at 2014-09-12 15:25:06

Comparing /work/SRC/openSUSE:Factory/mariadb (Old)
 and  /work/SRC/openSUSE:Factory/.mariadb.new (New)


Package is mariadb

Changes:

--- /work/SRC/openSUSE:Factory/mariadb/mariadb.changes  2014-08-28 
21:05:43.0 +0200
+++ /work/SRC/openSUSE:Factory/.mariadb.new/mariadb.changes 2014-09-12 
15:25:22.0 +0200
@@ -1,0 +2,7 @@
+Wed Sep  3 12:26:08 UTC 2014 - kstreit...@novell.com
+
+- bnc#894479: fix URL (changed from http://www.mariab.org; to 
+ https://www.mariadb.org;) 
+- README.SuSE renamed to README.SUSE
+
+---

Old:

  README.SuSE

New:

  README.SUSE



Other differences:
--
++ mariadb.spec ++
--- /var/tmp/diff_new_pack.7XWx4c/_old  2014-09-12 15:25:23.0 +0200
+++ /var/tmp/diff_new_pack.7XWx4c/_new  2014-09-12 15:25:23.0 +0200
@@ -43,14 +43,14 @@
 Version:10.0.13
 Release:0
 %define srv_vers 5.6.17
-Url:http://www.mariab.org
+Url:https://www.mariadb.org
 Source: mariadb-%{version}.tar.bz2
 Source2:baselibs.conf
 Source3:README.debug
 Source4:suse-test-run
 Source5:mysql.SuSEfirewall2
 Source7:README.install
-Source8:README.SuSE
+Source8:README.SUSE
 Source9:mysql-patches.tar.bz2
 Source10:   build.inc
 Source11:   install.inc
@@ -388,7 +388,7 @@
 
 %prep
 %setup -q -n mariadb-%{version} -D -a 9
-cp %_sourcedir/README.SuSE .
+cp %_sourcedir/README.SUSE .
 cp %_sourcedir/suse-test-run .
 # apply patches from series
 mysql-patches/tools/quilt-setup.sh  %{S:12}

++ README.SUSE ++
Notes about MySQL 5.1 package:
==

With MySQL 5.1 package we introduced some changes you may like to know. Most of
them will affect you only if you are upgrading from previous version and you
did some changes to your configuration.

1) Plugins:
===

One of the new features in MySQL 5.1 is support for plugins. So some of the
storage engines are now shipped like that. You can use following plugins:

 - archive
 - blackhole
 - federated
 - example

InnoDB is still compiled as internal part of MySQL. If you are upgrading from
version 5.0 or if this is your first installation of MySQL 5.1, all plugins
will be enabled by default and you can disable them manually later (see
http://dev.mysql.com/doc/refman/5.1/en/uninstall-plugin.html).

With this change you need to remove skip-federated option from your my.cnf file
if you have changed it manually. This option was there by default in previous
versions of MySQL.

2) File locations:
==

There were some changes in files locations. Most of them were made in the
default configuration file so if you are experiencing problems and you have
made some manual adjustments to your /etc/my.cnf, try to merge this file with
/etc/my.cnf.rpmnew.

File locations changes:
 - MySQL socket file and pid file were moved from /var/lib/mysql to more
   reasonable location ( /var/run/mysql ) by default.
 - MySQL log files are in /var/log/mysql.

3) BerkeleyDB:
==

MySQL no longer contains BerkeleyDB as storage engine. There is no fix for that
and if you used it before, you have to migrate your data to different storage
engine BEFORE updating. This can be done for example using following command:

ALTER TABLE foo ENGINE = INNODB;

4) MySQL Upgrade Log


If you missed messages displayed during automatic MySQL database upgrade, you
can find them from now on in

/var/log/mysql/mysqld-upgrade.log

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit virtualbox for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package virtualbox for openSUSE:Factory 
checked in at 2014-09-12 15:25:09

Comparing /work/SRC/openSUSE:Factory/virtualbox (Old)
 and  /work/SRC/openSUSE:Factory/.virtualbox.new (New)


Package is virtualbox

Changes:

--- /work/SRC/openSUSE:Factory/virtualbox/virtualbox.changes2014-08-11 
10:07:54.0 +0200
+++ /work/SRC/openSUSE:Factory/.virtualbox.new/virtualbox.changes   
2014-09-12 15:25:24.0 +0200
@@ -1,0 +2,6 @@
+Mon Sep  8 10:16:53 UTC 2014 - mse...@gmail.com
+
+- modify hint message in virtualbox-60-vboxdrv.rules, so udev rules
+  will stay enabled also after package update
+
+---



Other differences:
--

++ virtualbox-60-vboxdrv.rules ++
--- /var/tmp/diff_new_pack.zHK8Zq/_old  2014-09-12 15:25:26.0 +0200
+++ /var/tmp/diff_new_pack.zHK8Zq/_new  2014-09-12 15:25:26.0 +0200
@@ -1,6 +1,8 @@
 KERNEL==vboxdrv, NAME=vboxdrv, OWNER=root, GROUP=root, MODE=0600
+#
 #these lines below give access permission to vboxusers to properly work with 
usb nodes, but enabling them could be security risk (bnc#664520) !!
-#SUBSYSTEM==usb_device, ACTION==add, RUN+=VBoxCreateUSBNode.sh $major 
$minor $attr{bDeviceClass} vboxusers
-#SUBSYSTEM==usb, ACTION==add, ENV{DEVTYPE}==usb_device, 
RUN+=VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers
-#SUBSYSTEM==usb_device, ACTION==remove, RUN+=VBoxCreateUSBNode.sh 
--remove $major $minor
-#SUBSYSTEM==usb, ACTION==remove, ENV{DEVTYPE}==usb_device, 
RUN+=VBoxCreateUSBNode.sh --remove $major $minor
+#if you can live with this security problem put these lines below in to the 
new file /etc/udev/rules.d/60-vboxdrv.rules so they will stay enabled also 
after package update
+#SUBSYSTEM==usb_device, ACTION==add, 
RUN+=/usr/lib/udev/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} 
vboxusers
+#SUBSYSTEM==usb, ACTION==add, ENV{DEVTYPE}==usb_device, 
RUN+=/usr/lib/udev/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} 
vboxusers
+#SUBSYSTEM==usb_device, ACTION==remove, 
RUN+=/usr/lib/udev/VBoxCreateUSBNode.sh --remove $major $minor
+#SUBSYSTEM==usb, ACTION==remove, ENV{DEVTYPE}==usb_device, 
RUN+=/usr/lib/udev/VBoxCreateUSBNode.sh --remove $major $minor


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit coccinelle for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package coccinelle for openSUSE:Factory 
checked in at 2014-09-12 15:25:16

Comparing /work/SRC/openSUSE:Factory/coccinelle (Old)
 and  /work/SRC/openSUSE:Factory/.coccinelle.new (New)


Package is coccinelle

Changes:

--- /work/SRC/openSUSE:Factory/coccinelle/coccinelle.changes2013-05-13 
14:43:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.coccinelle.new/coccinelle.changes   
2014-09-12 15:25:33.0 +0200
@@ -1,0 +2,22 @@
+Thu Sep  9 14:25:25 UTC 2013 - mcg...@suse.com
+
+- Update to new upstream release 1.0.0~rc21
+* Support decimal type with the --ibm option
+* Support some matching on pragmas
+* Initialize and finalize rules contain a metavariable declaration
+  region.
+* Allow some parameters of a function not to have names.
+* Eliminate the reliance on grep in most cases for worth trying,
+  to improve performance.
+* Allow multidecls when removing variable names or when modifying
+  type.
+* Take fresh declarations into account when computing
+  get_constants to create dependencies
+* Leave ifdefs-like directives in unparsed code, if they don't have
+  beginning or ending counterparts.
+* Improve type inference performance when many files included by
+  using maps.
+- Add fix-no_prepare_ocamlcocci-arguments.patch: fix incorrect
+  call to two functions
+
+---

Old:

  coccinelle-1.0.0-rc17.tar.xz

New:

  coccinelle-1.0.0-rc21.tgz
  fix-no_prepare_ocamlcocci-arguments.patch



Other differences:
--
++ coccinelle.spec ++
--- /var/tmp/diff_new_pack.ukZuvI/_old  2014-09-12 15:25:34.0 +0200
+++ /var/tmp/diff_new_pack.ukZuvI/_new  2014-09-12 15:25:34.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package coccinelle
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,23 +17,24 @@
 
 
 Name:   coccinelle
-Version:1.0.0~rc17
+Version:1.0.0~rc21
 Release:0
 Summary:Semantic patch utility
 License:GPL-2.0
 Group:  Productivity/Text/Utilities
 Url:http://coccinelle.lip6.fr/
-%define rversion   1.0.0-rc17
+%define rversion   1.0.0-rc21
 
 #Git-Clone:git://github.com/coccinelle/coccinelle
-Source: %name-%rversion.tar.xz
+Source: http://coccinelle.lip6.fr/distrib/%name-%rversion.tgz
+Patch1: fix-no_prepare_ocamlcocci-arguments.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  ncurses-devel
 BuildRequires:  ocaml = 3.11
 BuildRequires:  ocaml-camlp4-devel = 3.11
+BuildRequires:  ocaml-findlib
 BuildRequires:  ocaml-ocamldoc = 3.11
 BuildRequires:  pkg-config
-BuildRequires:  xz
 # Fails to link with PCRE
 #BuildRequires:  pkgconfig(libpcre)
 BuildRequires:  pkgconfig(python)
@@ -53,6 +54,7 @@
 
 %prep
 %setup -qn %name-%rversion
+%patch -P 1 -p1
 
 %build
 %configure

++ fix-no_prepare_ocamlcocci-arguments.patch ++
From: Luis R. Rodriguez mcg...@do-not-panic.com
Date: Tue, 9 Sep 2014 15:10:42 -0700
X-Upstream: should appear in 1.0.0~rc22

The functions do take five arguments, but these two call sites erroneously
just passed four.

--- a/ocaml/no_prepare_ocamlcocci.ml
+++ b/ocaml/no_prepare_ocamlcocci.ml
@@ -9,9 +9,9 @@
function
Ast_cocci.ScriptRule (name,ocaml,deps,mv,script_vars,code) -
  code :: prev
- | Ast_cocci.InitialScriptRule (name,ocaml,deps,code) -
+ | Ast_cocci.InitialScriptRule (name,ocaml,deps,mvs,code) -
  code :: prev
- | Ast_cocci.FinalScriptRule (name,ocaml,deps,code) -
+ | Ast_cocci.FinalScriptRule (name,ocaml,deps,mvs,code) -
  code :: prev
  | _ - prev)
   [] code in
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit java-1_7_0-openjdk for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package java-1_7_0-openjdk for 
openSUSE:Factory checked in at 2014-09-12 15:25:12

Comparing /work/SRC/openSUSE:Factory/java-1_7_0-openjdk (Old)
 and  /work/SRC/openSUSE:Factory/.java-1_7_0-openjdk.new (New)


Package is java-1_7_0-openjdk

Changes:

New Changes file:

--- /dev/null   2014-07-24 01:57:42.080040256 +0200
+++ 
/work/SRC/openSUSE:Factory/.java-1_7_0-openjdk.new/java-1_7_0-openjdk-bootstrap.changes
 2014-09-12 15:25:28.0 +0200
@@ -0,0 +1,2042 @@
+---
+Wed Sep 10 05:48:11 UTC 2014 - co...@suse.com
+
+- add an explicit 2nd spec file - I liked the beauty of the topadd
+  _link but our tools just don't expect beauty ;(
+
+---
+Tue Sep  9 06:31:47 UTC 2014 - co...@suse.com
+
+- conflict bootstrap with non-bootstrap versions to avoid file
+  conflicts
+
+---
+Mon Sep  8 07:45:46 UTC 2014 - fst...@suse.com
+
+- Add provides jre-64 on x86_64. bnc#895191
+
+---
+Fri Sep  5 09:15:34 UTC 2014 - co...@suse.com
+
+- ignore ecj's java require - we already have java-bootstrap
+
+---
+Thu Aug 28 08:09:49 UTC 2014 - co...@suse.com
+
+- build a bootstrap version when bootstrap conditional set and buildrequire
+  this in the version when bootstrap conditional is not set
+
+To make this work, we need in every prj with jdk a _link in jdk-bootstrap with
+this content:
+
+link  package=java-1_7_0-openjdk cicount=copy
+patches
+  topadd%global _with_bootstrap 1/topadd
+/patches
+/link
+
+This makes sure the build dependencies of jdk are clear and you don't need 
tricks
+(other than the _link)
+
+---
+Thu Aug 21 08:39:32 UTC 2014 - fst...@suse.com
+
+- Removed patches unused patches:
+  * java-1.7.0-openjdk-debugdocs.patch
+  * java-1.7.0-openjdk-debuginfo.patch
+
+---
+Mon Jul 28 07:26:31 UTC 2014 - tchva...@suse.com
+
+- Use SUSE in names, not SuSE. bnc#889006
+
+---
+Thu Jul 24 11:49:20 UTC 2014 - fst...@suse.com
+
+- Don't try to run multiprocess on aarch64 where we are normally
+  using qemu. Qemu cannot guarantee that in user emulation mode
+  signals will be delivered to the correct thread
+
+---
+Wed Jul 23 17:05:15 UTC 2014 - fst...@suse.com
+
+- Added patch: file-contains-date-and-time.patch
+  * fix rpmlint warning and diminish number of rebuilds
+- Make sample/rmi/java-rmi.cgi
+  * fix rpmlint warning about no-executable file with shebang
+- Run osc service localrun clean_spec_file on the package
+  * fix manually some shortcomings
+
+---
+Wed Jul 23 08:23:09 UTC 2014 - fst...@suse.com
+
+- Use released icedtea-sound-1.0.1 tarball
+  * rename libpulse-java.so - libicedtea-sound.so
+  * rename pulse-java.jar - icedtea-sound.jar
+- Remove dependencies on autoconf and automake
+  * no need to re-autogenerate any more
+
+---
+Tue Jul 22 23:22:26 UTC 2014 - fst...@suse.com
+
+- Make zero build usable also on aarch64 (--with zero option)
+- Run osc service localrun clean_spec_file on the package
+
+---
+Tue Jul 22 15:18:16 UTC 2014 - fst...@suse.com
+
+- Modified patch:
+  * java-1_7_0-openjdk-suse-desktop-files.patch
+- change categories for policytool.desktop
+
+---
+Fri Jul 18 07:29:10 UTC 2014 - fst...@suse.com
+
+- Modify pulseaudio conditional, since the required dependencies
+  can be satisfied in SLE11 SP3
+- Modify accessibility post script to actually create the
+  corresponding symlinks
+
+---
+Wed Jul 16 11:00:00 UTC 2014 - fst...@suse.com
+
+- update to 2.5.1 - OpenJDK 7u65
+  * Security fixes
+- S8029755, CVE-2014-4209: Enhance subject class
+- S8030763: Validate global memory allocation
+- S8031340, CVE-2014-4264: Better TLS/EC management
+- S8031346, CVE-2014-4244: Enhance RSA key handling
+- S8031540: Introduce document horizon
+- S8032536: JVM resolves wrong method in some unusual cases
+- S8033055: Issues in 2d
+- S8033301, CVE-2014-4266: Build more informative InfoBuilder
+- S8034267: Probabilistic native crash
+- S8034272: Do not cram data into CRAM 

commit kcodecs for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kcodecs for openSUSE:Factory checked 
in at 2014-09-12 17:02:36

Comparing /work/SRC/openSUSE:Factory/kcodecs (Old)
 and  /work/SRC/openSUSE:Factory/.kcodecs.new (New)


Package is kcodecs

Changes:

--- /work/SRC/openSUSE:Factory/kcodecs/kcodecs.changes  2014-08-16 
15:41:35.0 +0200
+++ /work/SRC/openSUSE:Factory/.kcodecs.new/kcodecs.changes 2014-09-12 
17:03:13.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:11 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kcodecs-5.1.0.tar.xz

New:

  kcodecs-5.2.0.tar.xz



Other differences:
--
++ kcodecs.spec ++
--- /var/tmp/diff_new_pack.WUTPfC/_old  2014-09-12 17:03:14.0 +0200
+++ /var/tmp/diff_new_pack.WUTPfC/_new  2014-09-12 17:03:14.0 +0200
@@ -18,10 +18,10 @@
 
 %define lname   libKF5Codecs5
 Name:   kcodecs
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  libqt5-linguist-devel = 5.2.0

++ kcodecs-5.1.0.tar.xz - kcodecs-5.2.0.tar.xz ++
 922850 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kf5-filesystem for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kf5-filesystem for openSUSE:Factory 
checked in at 2014-09-12 17:02:30

Comparing /work/SRC/openSUSE:Factory/kf5-filesystem (Old)
 and  /work/SRC/openSUSE:Factory/.kf5-filesystem.new (New)


Package is kf5-filesystem

Changes:

--- /work/SRC/openSUSE:Factory/kf5-filesystem/kf5-filesystem.changes
2014-08-16 15:41:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.kf5-filesystem.new/kf5-filesystem.changes   
2014-09-12 17:03:06.0 +0200
@@ -1,0 +2,5 @@
+Mon Sep  8 01:04:14 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Bump to 5.2.0
+
+---



Other differences:
--
++ kf5-filesystem.spec ++
--- /var/tmp/diff_new_pack.p5V0vR/_old  2014-09-12 17:03:08.0 +0200
+++ /var/tmp/diff_new_pack.p5V0vR/_new  2014-09-12 17:03:08.0 +0200
@@ -18,7 +18,7 @@
 
 Name:   kf5-filesystem
 Url:http://www.kde.org
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Summary:KF5 Directory Layout

++ macros.kf5 ++
--- /var/tmp/diff_new_pack.p5V0vR/_old  2014-09-12 17:03:08.0 +0200
+++ /var/tmp/diff_new_pack.p5V0vR/_new  2014-09-12 17:03:08.0 +0200
@@ -26,7 +26,7 @@
 %_kf5_servicetypesdir %{_kf5_sharedir}/kservicetypes5
 %_kf5_htmldir %{_kf5_sharedir}/doc/HTML
 
-%_kf5_version 5.1.0
+%_kf5_version 5.2.0
 %_plasma5_branding_version 5.0.0
 %_kf5_build_type None
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit attica-qt5 for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package attica-qt5 for openSUSE:Factory 
checked in at 2014-09-12 17:02:32

Comparing /work/SRC/openSUSE:Factory/attica-qt5 (Old)
 and  /work/SRC/openSUSE:Factory/.attica-qt5.new (New)


Package is attica-qt5

Changes:

--- /work/SRC/openSUSE:Factory/attica-qt5/attica-qt5.changes2014-08-16 
15:41:34.0 +0200
+++ /work/SRC/openSUSE:Factory/.attica-qt5.new/attica-qt5.changes   
2014-09-12 17:03:11.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:11 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  attica-5.1.0.tar.xz

New:

  attica-5.2.0.tar.xz



Other differences:
--
++ attica-qt5.spec ++
--- /var/tmp/diff_new_pack.eUrAvG/_old  2014-09-12 17:03:13.0 +0200
+++ /var/tmp/diff_new_pack.eUrAvG/_new  2014-09-12 17:03:13.0 +0200
@@ -21,7 +21,7 @@
 %define _libname KF5Attica
 
 Name:   attica-qt5
-Version:5.1.0
+Version:5.2.0
 Release:0
 Summary:Open Collaboration Service client library
 License:LGPL-2.1+
@@ -30,7 +30,7 @@
 Source: %{rname}-%{version}.tar.xz
 Source99:   baselibs.conf
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  pkgconfig(Qt5Core) = 5.2.0

++ attica-5.1.0.tar.xz - attica-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/attica-5.1.0/CMakeLists.txt 
new/attica-5.2.0/CMakeLists.txt
--- old/attica-5.1.0/CMakeLists.txt 2014-08-02 10:11:03.0 +0200
+++ new/attica-5.2.0/CMakeLists.txt 2014-09-08 01:23:00.0 +0200
@@ -3,7 +3,7 @@
 project(Attica)
 
 # ECM setup
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
 include(FeatureSummary)
@@ -15,7 +15,7 @@
 include(KDEFrameworkCompilerSettings)
 include(KDECMakeSettings)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
 
 ecm_setup_version(${KF5_VERSION}
 VARIABLE_PREFIX ATTICA
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/attica-5.1.0/Mainpage.dox 
new/attica-5.2.0/Mainpage.dox
--- old/attica-5.1.0/Mainpage.dox   2014-08-02 10:11:03.0 +0200
+++ new/attica-5.2.0/Mainpage.dox   1970-01-01 01:00:00.0 +0100
@@ -1,11 +0,0 @@
-/** @mainpage The LibAttica API Reference
-
-Attica is a Qt library that implements the Open Collaboration Services API 
version 1.6. 
-The REST API is defined here:
-http://freedesktop.org/wiki/Specifications/open-collaboration-services-draft/
-
-*/
-// DOXYGEN_VERSION=4.0
-// DOXYGEN_NAME=attica
-// DOXYGEN_ENABLE=YES
-// DOXYGEN_SET_RECURSIVE = YES
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/attica-5.1.0/README.md new/attica-5.2.0/README.md
--- old/attica-5.1.0/README.md  2014-08-02 10:11:03.0 +0200
+++ new/attica-5.2.0/README.md  2014-09-08 01:23:00.0 +0200
@@ -10,8 +10,3 @@
 The library is used in KNewStuff3 as content provider.
 In order to integrate with KDE's Plasma Desktop, a platform plugin exists in 
kdebase.
 
-## Links
-
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/attica/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/attica-5.1.0/metainfo.yaml 
new/attica-5.2.0/metainfo.yaml
--- old/attica-5.1.0/metainfo.yaml  2014-08-02 10:11:03.0 +0200
+++ new/attica-5.2.0/metainfo.yaml  2014-09-08 01:23:00.0 +0200
@@ -1,5 +1,5 @@
 maintainer:
-description: Attica is a Qt library that implements the Open Collaboration 
Services API version 1.6.
+description: Open Collaboration Services API
 tier: 1
 type: functional
 platforms:
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: Attica
+   cmake: KF5::Attica
+cmakename: KF5Attica

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kjs for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kjs for openSUSE:Factory checked in 
at 2014-09-12 17:02:49

Comparing /work/SRC/openSUSE:Factory/kjs (Old)
 and  /work/SRC/openSUSE:Factory/.kjs.new (New)


Package is kjs

Changes:

--- /work/SRC/openSUSE:Factory/kjs/kjs.changes  2014-08-16 15:41:50.0 
+0200
+++ /work/SRC/openSUSE:Factory/.kjs.new/kjs.changes 2014-09-12 
17:03:34.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:16 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kjs-5.1.0.tar.xz

New:

  kjs-5.2.0.tar.xz



Other differences:
--
++ kjs.spec ++
--- /var/tmp/diff_new_pack.AIV5pc/_old  2014-09-12 17:03:36.0 +0200
+++ /var/tmp/diff_new_pack.AIV5pc/_new  2014-09-12 17:03:36.0 +0200
@@ -18,10 +18,10 @@
 
 %define sonum   5
 Name:   kjs
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  pcre-devel

++ kjs-5.1.0.tar.xz - kjs-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kjs-5.1.0/CMakeLists.txt new/kjs-5.2.0/CMakeLists.txt
--- old/kjs-5.1.0/CMakeLists.txt2014-08-02 10:19:56.0 +0200
+++ new/kjs-5.2.0/CMakeLists.txt2014-09-08 01:26:17.0 +0200
@@ -3,7 +3,7 @@
 project(KJS)
 
 # ECM setup
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} 
${CMAKE_CURRENT_SOURCE_DIR}/cmake)
 
 include(FeatureSummary)
@@ -12,7 +12,7 @@
 include(ECMSetupVersion)
 include(ECMMarkNonGuiExecutable)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
 
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KJS
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kjs_version.h
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kjs-5.1.0/README.md new/kjs-5.2.0/README.md
--- old/kjs-5.1.0/README.md 2014-08-02 10:19:56.0 +0200
+++ new/kjs-5.2.0/README.md 2014-09-08 01:26:17.0 +0200
@@ -8,9 +8,3 @@
 is based on well known scripting languages such as Netscape's JavaScript and
 Microsoft's JScript.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kjs
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: https://projects.kde.org/projects/frameworks/kjs/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kjs-5.1.0/metainfo.yaml new/kjs-5.2.0/metainfo.yaml
--- old/kjs-5.1.0/metainfo.yaml 2014-08-02 10:19:56.0 +0200
+++ new/kjs-5.2.0/metainfo.yaml 2014-09-08 01:26:17.0 +0200
@@ -7,3 +7,9 @@
 portingAid: true
 deprecated: true
 release: true
+libraries:
+ - qmake: KJSApi
+   cmake: KF5::JSApi
+ - qmake: KJS
+   cmake: KF5::JS
+cmakename: KF5JS

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit krunner for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package krunner for openSUSE:Factory checked 
in at 2014-09-12 17:02:44

Comparing /work/SRC/openSUSE:Factory/krunner (Old)
 and  /work/SRC/openSUSE:Factory/.krunner.new (New)


Package is krunner

Changes:

--- /work/SRC/openSUSE:Factory/krunner/krunner.changes  2014-08-16 
15:41:43.0 +0200
+++ /work/SRC/openSUSE:Factory/.krunner.new/krunner.changes 2014-09-12 
17:03:25.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:14 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  krunner-5.1.0.tar.xz

New:

  krunner-5.2.0.tar.xz



Other differences:
--
++ krunner.spec ++
--- /var/tmp/diff_new_pack.CAg4Ii/_old  2014-09-12 17:03:26.0 +0200
+++ /var/tmp/diff_new_pack.CAg4Ii/_new  2014-09-12 17:03:26.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Runner5
 Name:   krunner
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kconfig-devel = %{kf5_version}
 BuildRequires:  kcoreaddons-devel = %{kf5_version}

++ krunner-5.1.0.tar.xz - krunner-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/krunner-5.1.0/CMakeLists.txt 
new/krunner-5.2.0/CMakeLists.txt
--- old/krunner-5.1.0/CMakeLists.txt2014-08-02 10:20:58.0 +0200
+++ new/krunner-5.2.0/CMakeLists.txt2014-09-08 01:27:08.0 +0200
@@ -3,7 +3,7 @@
 project(KRunner)
 
 # ECM setup
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
 include(FeatureSummary)
@@ -15,8 +15,8 @@
 include(KDECompilerSettings)
 include(KDECMakeSettings)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 
 ecm_setup_version(${KF5_VERSION}
 VARIABLE_PREFIX KRUNNER
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/krunner-5.1.0/README.md new/krunner-5.2.0/README.md
--- old/krunner-5.1.0/README.md 2014-08-02 10:20:58.0 +0200
+++ new/krunner-5.2.0/README.md 2014-09-08 01:27:08.0 +0200
@@ -12,12 +12,6 @@
 
 This functionality is provided via plugins loaded at runtime called Runners.
 These plugins can be used by any application using the Plasma library. The
-KRunner framework is used to write these plugins.
+KRunner framework is used to write these plugins, as explained in
+[this 
tutorial](http://techbase.kde.org/Development/Tutorials/Plasma/AbstractRunner)
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/krunner
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/krunner/repository
-- Tutorial: 
http://techbase.kde.org/Development/Tutorials/Plasma/AbstractRunner
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/krunner-5.1.0/examples/runner/plasma-runner-example-homefiles.desktop 
new/krunner-5.2.0/examples/runner/plasma-runner-example-homefiles.desktop
--- old/krunner-5.1.0/examples/runner/plasma-runner-example-homefiles.desktop   
2014-08-02 10:20:58.0 +0200
+++ new/krunner-5.2.0/examples/runner/plasma-runner-example-homefiles.desktop   
2014-09-08 01:27:08.0 +0200
@@ -22,6 +22,7 @@
 Name[pl]=Pliki domowe
 Name[pt]=Ficheiros Pessoais
 Name[pt_BR]=Arquivos pessoais
+Name[ro]=Fișiere de acasă
 Name[ru]=Файлы в домашней папке
 Name[sk]=Domáce súbory
 Name[sl]=Domače datoteke
@@ -56,6 +57,7 @@
 Comment[pl]=Część samouczka wyjaśniająca sposób tworzenia wtyczek Runnera
 Comment[pt]=Parte de um tutorial que demonstra como criar 'plugins' do Runner
 Comment[pt_BR]=Parte de um tutorial que demonstra como criar plugins do Runner
+Comment[ro]=Parte dintr-un îndrumar care demonstrează cum să creați extensii 
pentru Lansator
 Comment[ru]=Часть руководства по созданию расширений для KRunner
 Comment[sk]=Časť kurzu demonštrujúceho ako vytvoriť pluginy Runnera
 Comment[sl]=Del vodnika za ustvarjanje vstavkov za Zaganjalnik
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/krunner-5.1.0/metainfo.yaml 

commit kguiaddons for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kguiaddons for openSUSE:Factory 
checked in at 2014-09-12 17:02:41

Comparing /work/SRC/openSUSE:Factory/kguiaddons (Old)
 and  /work/SRC/openSUSE:Factory/.kguiaddons.new (New)


Package is kguiaddons

Changes:

--- /work/SRC/openSUSE:Factory/kguiaddons/kguiaddons.changes2014-08-16 
15:41:39.0 +0200
+++ /work/SRC/openSUSE:Factory/.kguiaddons.new/kguiaddons.changes   
2014-09-12 17:03:20.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:13 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kguiaddons-5.1.0.tar.xz

New:

  kguiaddons-5.2.0.tar.xz



Other differences:
--
++ kguiaddons.spec ++
--- /var/tmp/diff_new_pack.Te4A3p/_old  2014-09-12 17:03:21.0 +0200
+++ /var/tmp/diff_new_pack.Te4A3p/_new  2014-09-12 17:03:21.0 +0200
@@ -18,10 +18,10 @@
 
 %define lname   libKF5GuiAddons5
 Name:   kguiaddons
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  pkgconfig(Qt5Gui) = 5.2.0

++ kguiaddons-5.1.0.tar.xz - kguiaddons-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kguiaddons-5.1.0/CMakeLists.txt 
new/kguiaddons-5.2.0/CMakeLists.txt
--- old/kguiaddons-5.1.0/CMakeLists.txt 2014-08-02 10:18:45.0 +0200
+++ new/kguiaddons-5.2.0/CMakeLists.txt 2014-09-08 01:25:16.0 +0200
@@ -2,7 +2,7 @@
 
 project(KGuiAddons)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
@@ -21,7 +21,7 @@
 include(GenerateExportHeader)
 include(ECMSetupVersion)
 include(ECMGenerateHeaders)
-set(KF5_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
 
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KGUIADDONS
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kguiaddons_version.h
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kguiaddons-5.1.0/README.md 
new/kguiaddons-5.2.0/README.md
--- old/kguiaddons-5.1.0/README.md  2014-08-02 10:18:45.0 +0200
+++ new/kguiaddons-5.2.0/README.md  2014-09-08 01:25:16.0 +0200
@@ -7,9 +7,3 @@
 The KDE GUI addons provide utilities for graphical user interfaces in the areas
 of colors, fonts, text, images, keyboard input.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kguiaddons
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kguiaddons/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kguiaddons-5.1.0/metainfo.yaml 
new/kguiaddons-5.2.0/metainfo.yaml
--- old/kguiaddons-5.1.0/metainfo.yaml  2014-08-02 10:18:45.0 +0200
+++ new/kguiaddons-5.2.0/metainfo.yaml  2014-09-08 01:25:16.0 +0200
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KGuiAddons
+   cmake: KF5::GuiAddons
+cmakename: KF5GuiAddons

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit crmsh for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package crmsh for openSUSE:Factory checked 
in at 2014-09-12 15:25:24

Comparing /work/SRC/openSUSE:Factory/crmsh (Old)
 and  /work/SRC/openSUSE:Factory/.crmsh.new (New)


Package is crmsh

Changes:

--- /work/SRC/openSUSE:Factory/crmsh/crmsh.changes  2014-09-04 
07:56:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.crmsh.new/crmsh.changes 2014-09-12 
17:03:02.0 +0200
@@ -1,0 +2,6 @@
+Thu Sep 11 08:27:16 UTC 2014 - kgronl...@suse.com
+
+- Drop patch since pacemaker now has correct version
+  - Removed patch: crmsh-cibadmin_can_patch.patch
+
+---

Old:

  crmsh-cibadmin_can_patch.patch



Other differences:
--
++ crmsh.spec ++
--- /var/tmp/diff_new_pack.tsUYt4/_old  2014-09-12 17:03:04.0 +0200
+++ /var/tmp/diff_new_pack.tsUYt4/_new  2014-09-12 17:03:04.0 +0200
@@ -45,10 +45,6 @@
 Release:%{?crmsh_release}%{?dist}
 Url:http://crmsh.github.io
 Source0:crmsh.tar.bz2
-# PATCH-FEATURE-OPENSUSE crmsh-cibadmin_can_patch.patch
-# de...@suse.de -- enable atomic CIB updates here, because our
-# pacemaker version has been fixed in the meantime
-Patch11:crmsh-cibadmin_can_patch.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires(pre):  pacemaker
 Requires:   pssh
@@ -122,7 +118,6 @@
 
 %prep
 %setup -q -n %{upstream_prefix}
-%patch11 -p1
 
 # Force the local time
 #

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kcompletion for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kcompletion for openSUSE:Factory 
checked in at 2014-09-12 17:02:45

Comparing /work/SRC/openSUSE:Factory/kcompletion (Old)
 and  /work/SRC/openSUSE:Factory/.kcompletion.new (New)


Package is kcompletion

Changes:

--- /work/SRC/openSUSE:Factory/kcompletion/kcompletion.changes  2014-08-16 
15:41:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.kcompletion.new/kcompletion.changes 
2014-09-12 17:03:27.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:14 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kcompletion-5.1.0.tar.xz

New:

  kcompletion-5.2.0.tar.xz



Other differences:
--
++ kcompletion.spec ++
--- /var/tmp/diff_new_pack.fnJTKE/_old  2014-09-12 17:03:28.0 +0200
+++ /var/tmp/diff_new_pack.fnJTKE/_new  2014-09-12 17:03:28.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Completion5
 Name:   kcompletion
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kconfig-devel = %{kf5_version}
 BuildRequires:  kf5-filesystem

++ kcompletion-5.1.0.tar.xz - kcompletion-5.2.0.tar.xz ++
 901617 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit postfixadmin for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package postfixadmin for openSUSE:Factory 
checked in at 2014-09-12 15:25:25

Comparing /work/SRC/openSUSE:Factory/postfixadmin (Old)
 and  /work/SRC/openSUSE:Factory/.postfixadmin.new (New)


Package is postfixadmin

Changes:

--- /work/SRC/openSUSE:Factory/postfixadmin/postfixadmin.changes
2014-02-22 18:14:25.0 +0100
+++ /work/SRC/openSUSE:Factory/.postfixadmin.new/postfixadmin.changes   
2014-09-12 17:03:05.0 +0200
@@ -1,0 +2,25 @@
+Fri Sep 12 11:16:16 UTC 2014 - opens...@cboltz.de
+
+- add postfixadmin-svn.diff with changes from upstream SVN (r1689):
+  - AliasHandler: don't clean goto field when making alias inactive (bug#316)
+  - list-virtual: display quota even if $CONF[used_quotas] == NO (bug#307)
+  - vacation.pl: fix postgresql queries in vacation.pl (bug#315)
+  - fix query in AliasHandler getList which caused an empty list on some 
+systems (bug#313)
+  - fetchmail.pl: fix ssl extra options (cert check, cert path, fingerprint)
+  - fix logging (run setup.php to fix old log entries) (bug#317)
+  - fetchmail.php: change error_reporting() to exclude E_NOTICE (bug#322)
+  - fr.lang translation update (patch#123)
+- make postfixadmin-cli executable
+
+---
+Tue May  6 21:47:01 UTC 2014 - opens...@cboltz.de
+
+- update to PostfixAdmin 2.91 aka 3.0 beta1
+  - new commandline client postfixadmin-cli
+  - vacation start and end date
+  - (nearly) complete rewrite to *Handler classes
+  - smarty templates
+  - and much more, see upstream CHANGELOG.TXT
+
+---
@@ -6 +31 @@
-  - SECURITY: fix SQL injection in show_gen_status()
+  - SECURITY: fix SQL injection in show_gen_status() (CVE-2014-2655, 
bnc#870434)

Old:

  postfixadmin-2.3.7.tar.gz

New:

  postfixadmin-2.91.tar.gz
  postfixadmin-svn.diff



Other differences:
--
++ postfixadmin.spec ++
--- /var/tmp/diff_new_pack.5zGcIu/_old  2014-09-12 17:03:06.0 +0200
+++ /var/tmp/diff_new_pack.5zGcIu/_new  2014-09-12 17:03:06.0 +0200
@@ -17,14 +17,14 @@
 
 
 Name:   postfixadmin
-Version:2.3.7
+Version:2.91
 Release:0
 Url:http://postfixadmin.sourceforge.net/
 Source0:%{name}-%{version}.tar.gz
 
-# changes from SVN 2.3 branch since the 2.3.7 release
+# changes from SVN since the release
 # (currently none)
-# Patch0: postfixadmin-2.3-branch.diff
+Patch0: postfixadmin-svn.diff
 
 BuildArch:  noarch
 
@@ -107,7 +107,7 @@
 
 %prep
 %setup -q
-#patch0
+%patch0 -p1
 
 %build
 echo *** serverroot: %{serverroot} ***
@@ -124,21 +124,24 @@
 #ln -s ../../../..%{_sysconfdir}/%{name}/config.inc.php \
 #%{buildroot}%{_datadir}/%{name}/config.inc.php
 
-install -m 0644 *.php motd*.txt %{buildroot}%{serverroot}/%{name}/
+install -m 0644 *.php *.js %{buildroot}%{serverroot}/%{name}/
 
 mv VIRTUAL_VACATION/vacation.pl %{buildroot}%{_prefix}/lib/%{name}/
 # compatibility symlink to match documentation
 ( cd %{buildroot}%{_localstatedir}/spool/vacation/  ln -s 
../../../usr/lib/%{name}/vacation.pl )
 
 # copy over the rest
-for d in admin images languages model templates users css; do
+for d in configs css images languages model scripts smarty templates users ; do
 cp -rp $d %{buildroot}%{serverroot}/%{name}/
 done
+chmod 755 %{buildroot}%{serverroot}/%{name}/scripts/postfixadmin-cli
+
+install -d %{buildroot}%{serverroot}/%{name}/templates_c 
 
 # remove files related to debian packaging (to avoid it's copied as %doc)
 rm -r ADDITIONS/squirrelmail-plugin/debian/
 cp -rp ADDITIONS %{buildroot}%{_prefix}/lib//%{name}/
-chmod 755 %{buildroot}%{_prefix}/lib/%{name}/ADDITIONS/*.{pl,sh,py}
+chmod 755 %{buildroot}%{_prefix}/lib/%{name}/ADDITIONS/*.{pl,sh,py} 
%{buildroot}%{_prefix}/lib/%{name}/ADDITIONS/squirrelmail-plugin/locale/build.sh
 
 # install the config file
 #mkdir -p %{buildroot}%{_sysconfdir}/apache2/conf.d
@@ -171,6 +174,7 @@
 #%config(noreplace) %{_sysconfdir}/apache2/conf.d/*.conf
 %doc DOCUMENTS/* *.TXT VIRTUAL_VACATION
 %{serverroot}/%{name}/
+%attr(770,root,www) %dir %{serverroot}/%{name}/templates_c/
 %dir %{_prefix}/lib/%{name}/
 %{_prefix}/lib/%{name}/ADDITIONS/
 %attr( 750,root,vacation)   %{_prefix}/lib/%{name}/vacation.pl

++ postfixadmin-2.3.7.tar.gz - postfixadmin-2.91.tar.gz ++
 176362 lines of diff (skipped)

++ postfixadmin-svn.diff ++
 1085 lines (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kjobwidgets for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kjobwidgets for openSUSE:Factory 
checked in at 2014-09-12 17:02:43

Comparing /work/SRC/openSUSE:Factory/kjobwidgets (Old)
 and  /work/SRC/openSUSE:Factory/.kjobwidgets.new (New)


Package is kjobwidgets

Changes:

--- /work/SRC/openSUSE:Factory/kjobwidgets/kjobwidgets.changes  2014-08-16 
15:41:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.kjobwidgets.new/kjobwidgets.changes 
2014-09-12 17:03:21.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:13 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kjobwidgets-5.1.0.tar.xz

New:

  kjobwidgets-5.2.0.tar.xz



Other differences:
--
++ kjobwidgets.spec ++
--- /var/tmp/diff_new_pack.jbiT81/_old  2014-09-12 17:03:23.0 +0200
+++ /var/tmp/diff_new_pack.jbiT81/_new  2014-09-12 17:03:23.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5JobWidgets5
 Name:   kjobwidgets
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kcoreaddons-devel = %{kf5_version}
 BuildRequires:  kf5-filesystem

++ kjobwidgets-5.1.0.tar.xz - kjobwidgets-5.2.0.tar.xz ++
 916540 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kdewebkit for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kdewebkit for openSUSE:Factory 
checked in at 2014-09-12 17:02:53

Comparing /work/SRC/openSUSE:Factory/kdewebkit (Old)
 and  /work/SRC/openSUSE:Factory/.kdewebkit.new (New)


Package is kdewebkit

Changes:

--- /work/SRC/openSUSE:Factory/kdewebkit/kdewebkit.changes  2014-08-16 
15:41:54.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdewebkit.new/kdewebkit.changes 2014-09-12 
17:03:39.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:18 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kdewebkit-5.1.0.tar.xz

New:

  kdewebkit-5.2.0.tar.xz



Other differences:
--
++ kdewebkit.spec ++
--- /var/tmp/diff_new_pack.s6n99P/_old  2014-09-12 17:03:41.0 +0200
+++ /var/tmp/diff_new_pack.s6n99P/_new  2014-09-12 17:03:41.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5WebKit5
 Name:   kdewebkit
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kbookmarks-devel =  %{kf5_version}
 BuildRequires:  kcompletion-devel =  %{kf5_version}

++ kdewebkit-5.1.0.tar.xz - kdewebkit-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdewebkit-5.1.0/CMakeLists.txt 
new/kdewebkit-5.2.0/CMakeLists.txt
--- old/kdewebkit-5.1.0/CMakeLists.txt  2014-08-02 10:18:15.0 +0200
+++ new/kdewebkit-5.2.0/CMakeLists.txt  2014-09-08 01:24:49.0 +0200
@@ -2,7 +2,7 @@
 
 project(KDEWebKit)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
@@ -18,8 +18,8 @@
 include(ECMSetupVersion)
 include(ECMGenerateHeaders)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KDEWEBKIT
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kdewebkit_version.h
 PACKAGE_VERSION_FILE 
${CMAKE_CURRENT_BINARY_DIR}/KF5WebKitConfigVersion.cmake
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdewebkit-5.1.0/README.md 
new/kdewebkit-5.2.0/README.md
--- old/kdewebkit-5.1.0/README.md   2014-08-02 10:18:15.0 +0200
+++ new/kdewebkit-5.2.0/README.md   2014-09-08 01:24:49.0 +0200
@@ -12,9 +12,3 @@
 in place of QGraphicsWebView and KWebPage in place of QWebPage.  See the
 documentation for those classes for more information.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kdewebkit
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kdewebkit/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdewebkit-5.1.0/metainfo.yaml 
new/kdewebkit-5.2.0/metainfo.yaml
--- old/kdewebkit-5.1.0/metainfo.yaml   2014-08-02 10:18:15.0 +0200
+++ new/kdewebkit-5.2.0/metainfo.yaml   2014-09-08 01:24:49.0 +0200
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KDEWebKit
+   cmake: KF5::WebKit
+cmakename: KF5WebKit

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit extra-cmake-modules for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package extra-cmake-modules for 
openSUSE:Factory checked in at 2014-09-12 17:02:31

Comparing /work/SRC/openSUSE:Factory/extra-cmake-modules (Old)
 and  /work/SRC/openSUSE:Factory/.extra-cmake-modules.new (New)


Package is extra-cmake-modules

Changes:

--- /work/SRC/openSUSE:Factory/extra-cmake-modules/extra-cmake-modules.changes  
2014-08-16 15:41:32.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.extra-cmake-modules.new/extra-cmake-modules.changes 
2014-09-12 17:03:09.0 +0200
@@ -1,0 +2,9 @@
+Tue Sep  9 09:49:34 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 1.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+- Drop 0001-Remove-Qt5-debugfull-hack-from-ECMConfig.cmake.patch,
+  merged upstream
+
+---

Old:

  0001-Remove-Qt5-debugfull-hack-from-ECMConfig.cmake.patch
  extra-cmake-modules-1.1.0.tar.xz

New:

  extra-cmake-modules-1.2.0.tar.xz



Other differences:
--
++ extra-cmake-modules.spec ++
--- /var/tmp/diff_new_pack.Xc3n99/_old  2014-09-12 17:03:10.0 +0200
+++ /var/tmp/diff_new_pack.Xc3n99/_new  2014-09-12 17:03:10.0 +0200
@@ -21,11 +21,9 @@
 License:BSD-3-Clause
 Group:  Development/Tools/Other
 Url:
https://projects.kde.org/projects/kdesupport/extra-cmake-modules
-Version:1.1.0
+Version:1.2.0
 Release:0
-Source: 
http://download.kde.org/stable/frameworks/5.1.0/%{name}-%{version}.tar.xz
-# PATCH-FIX-UPSTREAM 0001-Remove-Qt5-debugfull-hack-from-ECMConfig.cmake.patch
-Patch0: 0001-Remove-Qt5-debugfull-hack-from-ECMConfig.cmake.patch
+Source: 
http://download.kde.org/stable/frameworks/5.2.0/%{name}-%{version}.tar.xz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  cmake = 2.8.12
 BuildRequires:  gcc-c++
@@ -57,7 +55,6 @@
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
   %cmake_kf5 -d build

++ extra-cmake-modules-1.1.0.tar.xz - extra-cmake-modules-1.2.0.tar.xz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/extra-cmake-modules-1.1.0/CMakeLists.txt 
new/extra-cmake-modules-1.2.0/CMakeLists.txt
--- old/extra-cmake-modules-1.1.0/CMakeLists.txt2014-08-01 
19:07:16.0 +0200
+++ new/extra-cmake-modules-1.2.0/CMakeLists.txt2014-09-06 
00:20:45.0 +0200
@@ -3,7 +3,7 @@
 project(extra-cmake-modules NONE)
 
 set(ECM_MAJOR_VERSION 1)
-set(ECM_MINOR_VERSION 1)
+set(ECM_MINOR_VERSION 2)
 set(ECM_PATCH_VERSION 0)
 
 set(ECM_VERSION ${ECM_MAJOR_VERSION}.${ECM_MINOR_VERSION}.${ECM_PATCH_VERSION})
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/extra-cmake-modules-1.1.0/ECMConfig.cmake.in 
new/extra-cmake-modules-1.2.0/ECMConfig.cmake.in
--- old/extra-cmake-modules-1.1.0/ECMConfig.cmake.in2014-08-01 
19:07:16.0 +0200
+++ new/extra-cmake-modules-1.2.0/ECMConfig.cmake.in2014-09-06 
00:20:45.0 +0200
@@ -16,10 +16,3 @@
 set(ECM_MODULE_PATH ${ECM_MODULE_DIR} ${ECM_FIND_MODULE_DIR} 
${ECM_KDE_MODULE_DIR})
 
 include(${ECM_MODULE_DIR}/ECMUseFindModules.cmake)
-
-if(CMAKE_MINIMUM_REQUIRED_VERSION VERSION_LESS 2.8.13)
-  find_package(Qt5Core 5.2.0 REQUIRED)
-  set_property(TARGET Qt5::Core PROPERTY INTERFACE_COMPILE_DEFINITIONS 
QT_CORE_LIB $$NOT:$OR:$CONFIG:Debug,$CONFIG:DebugFull:QT_NO_DEBUG)
-else()
-  message(FATAL_ERROR \Remove this hack. Set 
CMAKE_MAP_IMPORTED_TARGET_DEBUGFULL to DEBUG instead.\)
-endif()
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/extra-cmake-modules-1.1.0/kde-modules/KDECompilerSettings.cmake 
new/extra-cmake-modules-1.2.0/kde-modules/KDECompilerSettings.cmake
--- old/extra-cmake-modules-1.1.0/kde-modules/KDECompilerSettings.cmake 
2014-08-01 19:07:16.0 +0200
+++ new/extra-cmake-modules-1.2.0/kde-modules/KDECompilerSettings.cmake 
2014-09-06 00:20:45.0 +0200
@@ -102,13 +102,9 @@
 set(CMAKE_REQUIRED_DEFINITIONS ${CMAKE_REQUIRED_DEFINITIONS} ${ARGV})
 endmacro()
 
-if (UNIX)
-# Enable basically everything portable across modern UNIX systems.
-# See http://www.delorie.com/gnu/docs/glibc/libc_13.html, although
-# this define is for the benefit of other libc implementations
-# (since _GNU_SOURCE is defined below).
-_kde_add_platform_definitions(-D_XOPEN_SOURCE=500)
-
+include(CheckSymbolExists)
+check_symbol_exists(__GLIBC__ stdlib.h LIBC_IS_GLIBC)
+if (LIBC_IS_GLIBC)
 # Enable everything in GNU libc.  Any code using non-portable features
 # needs to perform feature tests, but this ensures that any such 

commit kdesu for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kdesu for openSUSE:Factory checked 
in at 2014-09-12 17:02:46

Comparing /work/SRC/openSUSE:Factory/kdesu (Old)
 and  /work/SRC/openSUSE:Factory/.kdesu.new (New)


Package is kdesu

Changes:

--- /work/SRC/openSUSE:Factory/kdesu/kdesu.changes  2014-08-16 
15:41:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdesu.new/kdesu.changes 2014-09-12 
17:03:29.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:15 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kdesu-5.1.0.tar.xz

New:

  kdesu-5.2.0.tar.xz



Other differences:
--
++ kdesu.spec ++
--- /var/tmp/diff_new_pack.BvxemP/_old  2014-09-12 17:03:31.0 +0200
+++ /var/tmp/diff_new_pack.BvxemP/_new  2014-09-12 17:03:31.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Su5
 Name:   kdesu
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kcoreaddons-devel = %{kf5_version}
 BuildRequires:  kf5-filesystem

++ kdesu-5.1.0.tar.xz - kdesu-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdesu-5.1.0/CMakeLists.txt 
new/kdesu-5.2.0/CMakeLists.txt
--- old/kdesu-5.1.0/CMakeLists.txt  2014-08-02 10:18:09.0 +0200
+++ new/kdesu-5.2.0/CMakeLists.txt  2014-09-08 01:24:44.0 +0200
@@ -2,7 +2,7 @@
 
 project(KDESu)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
@@ -12,8 +12,8 @@
 include(KDEFrameworkCompilerSettings)
 include(KDECMakeSettings)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 find_package(KF5CoreAddons ${KF5_DEP_VERSION} REQUIRED)
 find_package(KF5Service ${KF5_DEP_VERSION} REQUIRED)
 find_package(KF5Pty ${KF5_DEP_VERSION} REQUIRED)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdesu-5.1.0/README.md new/kdesu-5.2.0/README.md
--- old/kdesu-5.1.0/README.md   2014-08-02 10:18:09.0 +0200
+++ new/kdesu-5.2.0/README.md   2014-09-08 01:24:44.0 +0200
@@ -8,9 +8,3 @@
 (password asking) console mode programs. For example, kdesu and
 kdessh use it to interface with su and ssh respectively.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kdesu
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kdesu/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdesu-5.1.0/metainfo.yaml 
new/kdesu-5.2.0/metainfo.yaml
--- old/kdesu-5.1.0/metainfo.yaml   2014-08-02 10:18:09.0 +0200
+++ new/kdesu-5.2.0/metainfo.yaml   2014-09-08 01:24:44.0 +0200
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KDESu
+   cmake: KF5::Su
+cmakename: KF5Su

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit ktexteditor for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package ktexteditor for openSUSE:Factory 
checked in at 2014-09-12 17:02:57

Comparing /work/SRC/openSUSE:Factory/ktexteditor (Old)
 and  /work/SRC/openSUSE:Factory/.ktexteditor.new (New)


Package is ktexteditor

Changes:

--- /work/SRC/openSUSE:Factory/ktexteditor/ktexteditor.changes  2014-08-16 
15:42:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.ktexteditor.new/ktexteditor.changes 
2014-09-12 17:03:46.0 +0200
@@ -1,0 +2,8 @@
+Tue Sep  9 09:49:19 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+- Added pkgconfig(Qt5Xml) and pkgconfig(Qt5XmlPatterns) BuildRequires
+
+---

Old:

  ktexteditor-5.1.0.tar.xz

New:

  ktexteditor-5.2.0.tar.xz



Other differences:
--
++ ktexteditor.spec ++
--- /var/tmp/diff_new_pack.Op5vN9/_old  2014-09-12 17:03:48.0 +0200
+++ /var/tmp/diff_new_pack.Op5vN9/_new  2014-09-12 17:03:48.0 +0200
@@ -17,11 +17,11 @@
 
 
 Name:   ktexteditor
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  karchive-devel = %{kf5_version}
 BuildRequires:  kconfig-devel = %{kf5_version}
@@ -36,6 +36,8 @@
 BuildRequires:  pkgconfig(Qt5Script) = 5.2.0
 BuildRequires:  pkgconfig(Qt5Test) = 5.2.0
 BuildRequires:  pkgconfig(Qt5Widgets) = 5.2.0
+BuildRequires:  pkgconfig(Qt5Xml) = 5.2.0
+BuildRequires:  pkgconfig(Qt5XmlPatterns) = 5.2.0
 Recommends: %{name}-lang = %{version}
 Obsoletes:  libKF5TextEditor4
 Obsoletes:  libKF5TextEditor5

++ ktexteditor-5.1.0.tar.xz - ktexteditor-5.2.0.tar.xz ++
 333172 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kdesignerplugin for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kdesignerplugin for openSUSE:Factory 
checked in at 2014-09-12 17:02:41

Comparing /work/SRC/openSUSE:Factory/kdesignerplugin (Old)
 and  /work/SRC/openSUSE:Factory/.kdesignerplugin.new (New)


Package is kdesignerplugin

Changes:

--- /work/SRC/openSUSE:Factory/kdesignerplugin/kdesignerplugin.changes  
2014-08-16 15:41:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdesignerplugin.new/kdesignerplugin.changes 
2014-09-12 17:03:16.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:12 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kdesignerplugin-5.1.0.tar.xz

New:

  kdesignerplugin-5.2.0.tar.xz



Other differences:
--
++ kdesignerplugin.spec ++
--- /var/tmp/diff_new_pack.U1qjAB/_old  2014-09-12 17:03:18.0 +0200
+++ /var/tmp/diff_new_pack.U1qjAB/_new  2014-09-12 17:03:18.0 +0200
@@ -17,11 +17,11 @@
 
 
 Name:   kdesignerplugin
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  kbookmarks-devel = %{kf5_version}
 BuildRequires:  kcompletion-devel = %{kf5_version}
 BuildRequires:  kconfigwidgets-devel = %{kf5_version}

++ kdesignerplugin-5.1.0.tar.xz - kdesignerplugin-5.2.0.tar.xz ++
 901450 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kdoctools for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kdoctools for openSUSE:Factory 
checked in at 2014-09-12 17:03:13

Comparing /work/SRC/openSUSE:Factory/kdoctools (Old)
 and  /work/SRC/openSUSE:Factory/.kdoctools.new (New)


Package is kdoctools

Changes:

--- /work/SRC/openSUSE:Factory/kdoctools/kdoctools.changes  2014-08-16 
15:42:18.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdoctools.new/kdoctools.changes 2014-09-12 
17:04:06.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:25 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kdoctools-5.1.0.tar.xz

New:

  kdoctools-5.2.0.tar.xz



Other differences:
--
++ kdoctools.spec ++
--- /var/tmp/diff_new_pack.oZtX97/_old  2014-09-12 17:04:07.0 +0200
+++ /var/tmp/diff_new_pack.oZtX97/_new  2014-09-12 17:04:07.0 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   kdoctools
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  docbook_4
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  karchive-devel = %{kf5_version}
 BuildRequires:  kf5-filesystem

++ kdoctools-5.1.0.tar.xz - kdoctools-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdoctools-5.1.0/CMakeLists.txt 
new/kdoctools-5.2.0/CMakeLists.txt
--- old/kdoctools-5.1.0/CMakeLists.txt  2014-08-02 10:18:25.0 +0200
+++ new/kdoctools-5.2.0/CMakeLists.txt  2014-09-08 01:24:58.0 +0200
@@ -3,7 +3,7 @@
 project(KDocTools)
 
 # ECM setup
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake ${ECM_MODULE_PATH} 
${ECM_KDE_MODULE_DIR})
 
 include(FeatureSummary)
@@ -11,8 +11,8 @@
 include(ECMMarkNonGuiExecutable)
 include(ECMPackageConfigHelpers)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KDOCTOOLS
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kdoctools_version.h
 PACKAGE_VERSION_FILE 
${CMAKE_CURRENT_BINARY_DIR}/KF5DocToolsConfigVersion.cmake
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdoctools-5.1.0/README.md 
new/kdoctools-5.2.0/README.md
--- old/kdoctools-5.1.0/README.md   2014-08-02 10:18:25.0 +0200
+++ new/kdoctools-5.2.0/README.md   2014-09-08 01:24:58.0 +0200
@@ -16,9 +16,3 @@
 plus a number of people that made suggestions, improved scripts, sent
 bug reports, etc, etc.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kdoctools
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-docbook
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kdoctools/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdoctools-5.1.0/metainfo.yaml 
new/kdoctools-5.2.0/metainfo.yaml
--- old/kdoctools-5.1.0/metainfo.yaml   2014-08-02 10:18:25.0 +0200
+++ new/kdoctools-5.2.0/metainfo.yaml   2014-09-08 01:24:58.0 +0200
@@ -7,3 +7,4 @@
 portingAid: false
 deprecated: false
 release: true
+cmakename: KF5DocTools

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit khtml for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package khtml for openSUSE:Factory checked 
in at 2014-09-12 17:02:47

Comparing /work/SRC/openSUSE:Factory/khtml (Old)
 and  /work/SRC/openSUSE:Factory/.khtml.new (New)


Package is khtml

Changes:

--- /work/SRC/openSUSE:Factory/khtml/khtml.changes  2014-08-16 
15:41:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.khtml.new/khtml.changes 2014-09-12 
17:03:32.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:16 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  khtml-5.1.0.tar.xz

New:

  khtml-5.2.0.tar.xz



Other differences:
--
++ khtml.spec ++
--- /var/tmp/diff_new_pack.eW8G8O/_old  2014-09-12 17:03:33.0 +0200
+++ /var/tmp/diff_new_pack.eW8G8O/_new  2014-09-12 17:03:33.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5KHtml5
 Name:   khtml
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  giflib-devel
 BuildRequires:  karchive-devel = %{kf5_version}

++ khtml-5.1.0.tar.xz - khtml-5.2.0.tar.xz ++
 4077 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kjsembed for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kjsembed for openSUSE:Factory 
checked in at 2014-09-12 17:02:55

Comparing /work/SRC/openSUSE:Factory/kjsembed (Old)
 and  /work/SRC/openSUSE:Factory/.kjsembed.new (New)


Package is kjsembed

Changes:

--- /work/SRC/openSUSE:Factory/kjsembed/kjsembed.changes2014-08-16 
15:41:58.0 +0200
+++ /work/SRC/openSUSE:Factory/.kjsembed.new/kjsembed.changes   2014-09-12 
17:03:44.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:19 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kjsembed-5.1.0.tar.xz

New:

  kjsembed-5.2.0.tar.xz



Other differences:
--
++ kjsembed.spec ++
--- /var/tmp/diff_new_pack.9h3qnT/_old  2014-09-12 17:03:45.0 +0200
+++ /var/tmp/diff_new_pack.9h3qnT/_new  2014-09-12 17:03:45.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5JsEmbed5
 Name:   kjsembed
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kdoctools-devel = %{kf5_version}
 BuildRequires:  kf5-filesystem

++ kjsembed-5.1.0.tar.xz - kjsembed-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kjsembed-5.1.0/CMakeLists.txt 
new/kjsembed-5.2.0/CMakeLists.txt
--- old/kjsembed-5.1.0/CMakeLists.txt   2014-08-02 11:07:30.0 +0200
+++ new/kjsembed-5.2.0/CMakeLists.txt   2014-09-09 02:27:42.0 +0200
@@ -2,7 +2,7 @@
 
 project(KJsEmbed)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
 set(REQUIRED_QT_VERSION 5.2)
@@ -17,8 +17,8 @@
 include(ECMSetupVersion)
 include(ECMGenerateHeaders)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KJSEMBED
#VERSION_HEADER ${CMAKE_CURRENT_BINARY_DIR}/kjsembed_version.h
 PACKAGE_VERSION_FILE 
${CMAKE_CURRENT_BINARY_DIR}/KF5JsEmbedConfigVersion.cmake
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kjsembed-5.1.0/README.md new/kjsembed-5.2.0/README.md
--- old/kjsembed-5.1.0/README.md2014-08-02 11:07:30.0 +0200
+++ new/kjsembed-5.2.0/README.md2014-09-09 02:27:42.0 +0200
@@ -32,9 +32,3 @@
 }
 
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kjsembed
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kjsembed/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kjsembed-5.1.0/metainfo.yaml 
new/kjsembed-5.2.0/metainfo.yaml
--- old/kjsembed-5.1.0/metainfo.yaml2014-08-02 11:07:30.0 +0200
+++ new/kjsembed-5.2.0/metainfo.yaml2014-09-09 02:27:42.0 +0200
@@ -9,3 +9,7 @@
 release: true
 framework-dependencies:
   - KDocTools
+libraries:
+ - qmake: KJsEmbed
+   cmake: KF5::JsEmbed
+cmakename: KF5JsEmbed
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kjsembed-5.1.0/po/ca/kjsembed5.po 
new/kjsembed-5.2.0/po/ca/kjsembed5.po
--- old/kjsembed-5.1.0/po/ca/kjsembed5.po   2014-08-02 11:07:30.0 
+0200
+++ new/kjsembed-5.2.0/po/ca/kjsembed5.po   2014-09-09 02:27:42.0 
+0200
@@ -4,7 +4,7 @@
 # version 3 or later versions approved by the membership of KDE e.V.
 #
 # Sebastià Pla i Sanz s...@sastia.com, 1998, 1999, 2000, 2001, 2002, 2003, 
2004, 2005, 2006, 2007.
-# Antoni Bella Pérez antonibel...@orange.es, 2003, 2006, 2011, 2012, 2013.
+# Antoni Bella Pérez antonibel...@orange.es, 2003, 2006, 2011, 2012, 2013, 
2014.
 # Albert Astals Cid aa...@kde.org, 2004, 2005, 2007.
 # Josep Ma. Ferrer txe...@gmail.com, 2007, 2008, 2009, 2010, 2011, 2012, 
2013, 2014.
 # Robert Millan r...@aybabtu.com, 2009.
@@ -14,14 +14,14 @@
 Project-Id-Version: kjsembed5\n
 Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 POT-Creation-Date: 2014-04-27 20:58+\n
-PO-Revision-Date: 2014-03-09 02:55+0100\n
-Last-Translator: Josep Ma. Ferrer txe...@gmail.com\n
+PO-Revision-Date: 2014-08-08 15:08+0200\n

commit kimageformats for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kimageformats for openSUSE:Factory 
checked in at 2014-09-12 17:03:22

Comparing /work/SRC/openSUSE:Factory/kimageformats (Old)
 and  /work/SRC/openSUSE:Factory/.kimageformats.new (New)


Package is kimageformats

Changes:

--- /work/SRC/openSUSE:Factory/kimageformats/kimageformats.changes  
2014-08-16 15:42:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.kimageformats.new/kimageformats.changes 
2014-09-12 17:04:23.0 +0200
@@ -1,0 +2,9 @@
+Tue Sep  9 09:49:29 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * KImageFormats: disable the DDS and JPEG-2000 plugins when
+Qt version is 5.3 or later
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kimageformats-5.1.0.tar.xz

New:

  kimageformats-5.2.0.tar.xz



Other differences:
--
++ kimageformats.spec ++
--- /var/tmp/diff_new_pack.DYLiom/_old  2014-09-12 17:04:25.0 +0200
+++ /var/tmp/diff_new_pack.DYLiom/_new  2014-09-12 17:04:25.0 +0200
@@ -17,10 +17,10 @@
 
 
 Name:   kimageformats
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  openexr

++ kimageformats-5.1.0.tar.xz - kimageformats-5.2.0.tar.xz ++
 2420 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kactivities5 for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kactivities5 for openSUSE:Factory 
checked in at 2014-09-12 17:03:18

Comparing /work/SRC/openSUSE:Factory/kactivities5 (Old)
 and  /work/SRC/openSUSE:Factory/.kactivities5.new (New)


Package is kactivities5

Changes:

--- /work/SRC/openSUSE:Factory/kactivities5/kactivities5.changes
2014-08-16 15:42:24.0 +0200
+++ /work/SRC/openSUSE:Factory/.kactivities5.new/kactivities5.changes   
2014-09-12 17:04:16.0 +0200
@@ -1,0 +2,12 @@
+Tue Sep  9 09:49:28 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * KActivities: reimplementation of the file item plugin for
+linking files to activities
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+- Added kcmutils-devel, kdeclarative-devel, kglobalaccel-devel and
+  kxmlgui-devel BuildRequires
+- Rebase kamd-rename.patch
+
+---

Old:

  kactivities-5.1.0.tar.xz

New:

  kactivities-5.2.0.tar.xz



Other differences:
--
++ kactivities5.spec ++
--- /var/tmp/diff_new_pack.TJEi49/_old  2014-09-12 17:04:18.0 +0200
+++ /var/tmp/diff_new_pack.TJEi49/_new  2014-09-12 17:04:18.0 +0200
@@ -18,7 +18,7 @@
 
 %define lname   libKF5Activities5
 Name:   kactivities5
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 Summary:KDE Plasma Activities support
@@ -31,16 +31,20 @@
 Patch0: kamd-rename.patch
 BuildRequires:  boost-devel = 1.49.0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
+BuildRequires:  kcmutils-devel = %{kf5_version}
 BuildRequires:  kconfig-devel = %{kf5_version}
 BuildRequires:  kcoreaddons-devel = %{kf5_version}
 BuildRequires:  kdbusaddons-devel = %{kf5_version}
+BuildRequires:  kdeclarative-devel = %{kf5_version}
 BuildRequires:  kf5-filesystem
+BuildRequires:  kglobalaccel-devel = %{kf5_version}
 BuildRequires:  ki18n-devel = %{kf5_version}
 BuildRequires:  kio-devel = %{kf5_version}
 BuildRequires:  kservice-devel = %{kf5_version}
 BuildRequires:  kwindowsystem-devel = %{kf5_version}
+BuildRequires:  kxmlgui-devel = %{kf5_version}
 BuildRequires:  xz
 BuildRequires:  pkgconfig(Qt5Core) = 5.2.0
 BuildRequires:  pkgconfig(Qt5DBus) = 5.2.0
@@ -78,7 +82,7 @@
 Summary:KDE Plasma Activities support
 Group:  Development/Libraries/KDE
 Requires:   %lname = %{version}
-Requires:   extra-cmake-modules = 1.1.0
+Requires:   extra-cmake-modules = 1.2.0
 Requires:   pkgconfig(Qt5Core) = 5.2.0
 
 %description devel
@@ -116,6 +120,7 @@
 %{_kf5_plugindir}/
 %{_kf5_servicesdir}/
 %{_kf5_servicetypesdir}/
+%{_kf5_datadir}/
 
 %files imports
 %defattr(-,root,root)

++ kactivities-5.1.0.tar.xz - kactivities-5.2.0.tar.xz ++
 17206 lines of diff (skipped)

++ kamd-rename.patch ++
--- /var/tmp/diff_new_pack.TJEi49/_old  2014-09-12 17:04:18.0 +0200
+++ /var/tmp/diff_new_pack.TJEi49/_new  2014-09-12 17:04:18.0 +0200
@@ -12,7 +12,7 @@
  
  
 diff --git a/src/lib/core/manager_p.cpp b/src/lib/core/manager_p.cpp
-index 2a81ff8..fc653a4 100644
+index 077c634..7be66dd 100644
 --- a/src/lib/core/manager_p.cpp
 +++ b/src/lib/core/manager_p.cpp
 @@ -94,11 +94,11 @@ Manager *Manager::self()
@@ -30,23 +30,32 @@
  }
  
 diff --git a/src/service/Application.cpp b/src/service/Application.cpp
-index 09332f8..572fe48 100644
+index 6b0e3e1..3894540 100644
 --- a/src/service/Application.cpp
 +++ b/src/service/Application.cpp
-@@ -351,7 +351,7 @@ int main(int argc, char **argv)
+@@ -280,7 +280,7 @@ int main(int argc, char **argv)
+ application.setApplicationName(QStringLiteral(ActivityManager));
+ application.setOrganizationDomain(QStringLiteral(kde.org));
+ 
+-// KAboutData about(kactivitymanagerd, Q_NULLPTR, ki18n(KDE Activity 
Manager), 3.0,
++// KAboutData about(kactivitymanagerd5, Q_NULLPTR, ki18n(KDE Activity 
Manager), 3.0,
+ // ki18n(KDE Activity Management Service),
+ // KAboutData::License_GPL,
+ // ki18n((c) 2010, 2011, 2012 Ivan Cukic), KLocalizedString(),
+@@ -333,7 +333,7 @@ int main(int argc, char **argv)
  // Starting the dameon
  
  QProcess::startDetached(
 -KAMD_INSTALL_PREFIX /bin/kactivitymanagerd,
 +KAMD_INSTALL_PREFIX /bin/kactivitymanagerd5,
- {start-daemon}
+ QStringList{start-daemon}
  );
  
 diff --git a/src/service/CMakeLists.txt b/src/service/CMakeLists.txt
-index 38e6e2b..fb762e5 100644
+index 4b4978b..2220f34 100644
 --- 

commit ki18n for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package ki18n for openSUSE:Factory checked 
in at 2014-09-12 17:02:54

Comparing /work/SRC/openSUSE:Factory/ki18n (Old)
 and  /work/SRC/openSUSE:Factory/.ki18n.new (New)


Package is ki18n

Changes:

--- /work/SRC/openSUSE:Factory/ki18n/ki18n.changes  2014-08-16 
15:41:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.ki18n.new/ki18n.changes 2014-09-12 
17:03:41.0 +0200
@@ -1,0 +2,8 @@
+Tue Sep  9 09:49:18 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+- Added gettext-runtime and python (Build)Requires
+
+---

Old:

  ki18n-5.1.0.tar.xz

New:

  ki18n-5.2.0.tar.xz



Other differences:
--
++ ki18n.spec ++
--- /var/tmp/diff_new_pack.L68YDu/_old  2014-09-12 17:03:43.0 +0200
+++ /var/tmp/diff_new_pack.L68YDu/_new  2014-09-12 17:03:43.0 +0200
@@ -18,12 +18,14 @@
 
 %define lname   libKF5I18n5
 Name:   ki18n
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
+BuildRequires:  gettext-runtime
 BuildRequires:  kf5-filesystem
+BuildRequires:  python
 BuildRequires:  pkgconfig(Qt5Concurrent) = 5.2.0
 BuildRequires:  pkgconfig(Qt5Core) = 5.2.0
 BuildRequires:  pkgconfig(Qt5Script) = 5.2.0
@@ -61,6 +63,8 @@
 Group:  Development/Libraries/KDE
 Requires:   %lname = %{version}
 Requires:   extra-cmake-modules
+Requires:   gettext-runtime
+Requires:   python
 
 %description devel
 KI18n provides functionality for internationalizing user interface text
@@ -88,6 +92,9 @@
 %postun -n %lname -p /sbin/ldconfig
 
 %files -n %lname-lang -f %{name}5.lang
+%defattr(-,root,root)
+%dir %{_kf5_sharedir}/locale/*/LC_SCRIPTS
+%{_kf5_sharedir}/locale/*/LC_SCRIPTS/ki18n5/
 
 %files -n %lname
 %defattr(-,root,root)

++ ki18n-5.1.0.tar.xz - ki18n-5.2.0.tar.xz ++
 285549 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kconfigwidgets for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kconfigwidgets for openSUSE:Factory 
checked in at 2014-09-12 17:03:00

Comparing /work/SRC/openSUSE:Factory/kconfigwidgets (Old)
 and  /work/SRC/openSUSE:Factory/.kconfigwidgets.new (New)


Package is kconfigwidgets

Changes:

--- /work/SRC/openSUSE:Factory/kconfigwidgets/kconfigwidgets.changes
2014-08-16 15:42:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.kconfigwidgets.new/kconfigwidgets.changes   
2014-09-12 17:03:51.0 +0200
@@ -1,0 +2,10 @@
+Tue Sep  9 09:49:20 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * KConfigWidgets: fix missing default shortcuts for standard
+actions, leading to many runtime warnings
+  * KConfigWidgets: better support for QGroupBox in KConfigDialogManager
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kconfigwidgets-5.1.0.tar.xz

New:

  kconfigwidgets-5.2.0.tar.xz



Other differences:
--
++ kconfigwidgets.spec ++
--- /var/tmp/diff_new_pack.F1NOIi/_old  2014-09-12 17:03:52.0 +0200
+++ /var/tmp/diff_new_pack.F1NOIi/_new  2014-09-12 17:03:52.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5ConfigWidgets5
 Name:   kconfigwidgets
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kauth-devel = %{kf5_version}
 BuildRequires:  kcodecs-devel = %{kf5_version}
@@ -62,7 +62,7 @@
 Summary:Widgets for configuration dialogs: Build Environment
 Group:  Development/Libraries/KDE
 Requires:   %lname = %{version}
-Requires:   extra-cmake-modules = 1.1.0
+Requires:   extra-cmake-modules = 1.2.0
 Requires:   kauth-devel = %{kf5_version}
 Requires:   kcodecs-devel = %{kf5_version}
 Requires:   kconfig-devel = %{kf5_version}

++ kconfigwidgets-5.1.0.tar.xz - kconfigwidgets-5.2.0.tar.xz ++
 6237 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit knewstuff for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package knewstuff for openSUSE:Factory 
checked in at 2014-09-12 17:03:15

Comparing /work/SRC/openSUSE:Factory/knewstuff (Old)
 and  /work/SRC/openSUSE:Factory/.knewstuff.new (New)


Package is knewstuff

Changes:

--- /work/SRC/openSUSE:Factory/knewstuff/knewstuff.changes  2014-08-16 
15:42:20.0 +0200
+++ /work/SRC/openSUSE:Factory/.knewstuff.new/knewstuff.changes 2014-09-12 
17:04:10.0 +0200
@@ -1,0 +2,8 @@
+Tue Sep  9 09:49:26 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * KNewStuff: installing stuff works again (porting bug)
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  knewstuff-5.1.0.tar.xz

New:

  knewstuff-5.2.0.tar.xz



Other differences:
--
++ knewstuff.spec ++
--- /var/tmp/diff_new_pack.zD1yHe/_old  2014-09-12 17:04:13.0 +0200
+++ /var/tmp/diff_new_pack.zD1yHe/_new  2014-09-12 17:04:13.0 +0200
@@ -18,12 +18,12 @@
 
 %define lname   libKF5NewStuff5
 Name:   knewstuff
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  attica-qt5-devel = %{kf5_version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  karchive-devel = %{kf5_version}
 BuildRequires:  kcompletion-devel = %{kf5_version}

++ knewstuff-5.1.0.tar.xz - knewstuff-5.2.0.tar.xz ++
 2960 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kservice for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kservice for openSUSE:Factory 
checked in at 2014-09-12 17:02:51

Comparing /work/SRC/openSUSE:Factory/kservice (Old)
 and  /work/SRC/openSUSE:Factory/.kservice.new (New)


Package is kservice

Changes:

--- /work/SRC/openSUSE:Factory/kservice/kservice.changes2014-08-16 
15:41:51.0 +0200
+++ /work/SRC/openSUSE:Factory/.kservice.new/kservice.changes   2014-09-12 
17:03:36.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:17 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kservice-5.1.0.tar.xz

New:

  kservice-5.2.0.tar.xz



Other differences:
--
++ kservice.spec ++
--- /var/tmp/diff_new_pack.rq3IDj/_old  2014-09-12 17:03:38.0 +0200
+++ /var/tmp/diff_new_pack.rq3IDj/_new  2014-09-12 17:03:38.0 +0200
@@ -17,11 +17,11 @@
 
 
 Name:   kservice
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kconfig-devel = %{kf5_version}
 BuildRequires:  kcoreaddons-devel = %{kf5_version}
@@ -100,7 +100,6 @@
 
 %files devel
 %defattr(-,root,root)
-%{_kf5_bindir}/desktoptojson
 %{_kf5_libdir}/libKF5Service.so
 %{_kf5_libdir}/cmake/KF5Service/
 %dir %{_kf5_includedir}/*/

++ kservice-5.1.0.tar.xz - kservice-5.2.0.tar.xz ++
 3348 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kunitconversion for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kunitconversion for openSUSE:Factory 
checked in at 2014-09-12 17:03:17

Comparing /work/SRC/openSUSE:Factory/kunitconversion (Old)
 and  /work/SRC/openSUSE:Factory/.kunitconversion.new (New)


Package is kunitconversion

Changes:

--- /work/SRC/openSUSE:Factory/kunitconversion/kunitconversion.changes  
2014-08-16 15:42:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.kunitconversion.new/kunitconversion.changes 
2014-09-12 17:04:14.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:27 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kunitconversion-5.1.0.tar.xz

New:

  kunitconversion-5.2.0.tar.xz



Other differences:
--
++ kunitconversion.spec ++
--- /var/tmp/diff_new_pack.esiJxV/_old  2014-09-12 17:04:16.0 +0200
+++ /var/tmp/diff_new_pack.esiJxV/_new  2014-09-12 17:04:16.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5UnitConversion5
 Name:   kunitconversion
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kconfig-devel = %{_kf5_version}
 BuildRequires:  kf5-filesystem

++ kunitconversion-5.1.0.tar.xz - kunitconversion-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kunitconversion-5.1.0/CMakeLists.txt 
new/kunitconversion-5.2.0/CMakeLists.txt
--- old/kunitconversion-5.1.0/CMakeLists.txt2014-08-02 11:11:30.0 
+0200
+++ new/kunitconversion-5.2.0/CMakeLists.txt2014-09-09 02:38:24.0 
+0200
@@ -2,7 +2,7 @@
 
 project(KUnitConversion)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
@@ -18,8 +18,8 @@
 include(ECMSetupVersion)
 include(ECMGenerateHeaders)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KUNITCONVERSION
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kunitconversion_version.h
 PACKAGE_VERSION_FILE 
${CMAKE_CURRENT_BINARY_DIR}/KF5UnitConversionConfigVersion.cmake
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kunitconversion-5.1.0/README.md 
new/kunitconversion-5.2.0/README.md
--- old/kunitconversion-5.1.0/README.md 2014-08-02 11:11:30.0 +0200
+++ new/kunitconversion-5.2.0/README.md 2014-09-09 02:38:24.0 +0200
@@ -27,9 +27,3 @@
 * Velocity
 * Volume
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kunitconversion
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kunitconversion/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kunitconversion-5.1.0/metainfo.yaml 
new/kunitconversion-5.2.0/metainfo.yaml
--- old/kunitconversion-5.1.0/metainfo.yaml 2014-08-02 11:11:30.0 
+0200
+++ new/kunitconversion-5.2.0/metainfo.yaml 2014-09-09 02:38:24.0 
+0200
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KUnitConversion
+   cmake: KF5::UnitConversion
+cmakename: KF5UnitConversion

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit ktextwidgets for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package ktextwidgets for openSUSE:Factory 
checked in at 2014-09-12 17:03:09

Comparing /work/SRC/openSUSE:Factory/ktextwidgets (Old)
 and  /work/SRC/openSUSE:Factory/.ktextwidgets.new (New)


Package is ktextwidgets

Changes:

--- /work/SRC/openSUSE:Factory/ktextwidgets/ktextwidgets.changes
2014-08-16 15:42:12.0 +0200
+++ /work/SRC/openSUSE:Factory/.ktextwidgets.new/ktextwidgets.changes   
2014-09-12 17:03:57.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:23 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  ktextwidgets-5.1.0.tar.xz

New:

  ktextwidgets-5.2.0.tar.xz



Other differences:
--
++ ktextwidgets.spec ++
--- /var/tmp/diff_new_pack.CS4QGw/_old  2014-09-12 17:03:59.0 +0200
+++ /var/tmp/diff_new_pack.CS4QGw/_new  2014-09-12 17:03:59.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5TextWidgets5
 Name:   ktextwidgets
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kcompletion-devel = %{kf5_version}
 BuildRequires:  kconfig-devel = %{kf5_version}

++ ktextwidgets-5.1.0.tar.xz - ktextwidgets-5.2.0.tar.xz ++
 2504 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kconfig for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kconfig for openSUSE:Factory checked 
in at 2014-09-12 17:02:51

Comparing /work/SRC/openSUSE:Factory/kconfig (Old)
 and  /work/SRC/openSUSE:Factory/.kconfig.new (New)


Package is kconfig

Changes:

--- /work/SRC/openSUSE:Factory/kconfig/kconfig.changes  2014-08-16 
15:41:53.0 +0200
+++ /work/SRC/openSUSE:Factory/.kconfig.new/kconfig.changes 2014-09-12 
17:03:38.0 +0200
@@ -1,0 +2,10 @@
+Tue Sep  9 09:49:17 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+- Added 0001-ensure-platform-window-resize-processing.patch for
+  resolving https://bugreports.qt-project.org/browse/QTBUG-40584
+  within KConfig Framework
+  
+---

Old:

  kconfig-5.1.0.tar.xz

New:

  0001-ensure-platform-window-resize-processing.patch
  kconfig-5.2.0.tar.xz



Other differences:
--
++ kconfig.spec ++
--- /var/tmp/diff_new_pack.kusU0N/_old  2014-09-12 17:03:39.0 +0200
+++ /var/tmp/diff_new_pack.kusU0N/_new  2014-09-12 17:03:39.0 +0200
@@ -18,10 +18,10 @@
 
 %define sonum   5
 Name:   kconfig
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  libqt5-linguist-devel = 5.2.0
@@ -34,6 +34,8 @@
 Url:http://www.kde.org
 Source: 
http://download.kde.org/stable/frameworks/%{version}/%{name}-%{version}.tar.xz
 Source1:baselibs.conf
+# PATCH-FIX-UPSTREAM 0001-ensure-platform-window-resize-processing.patch -- 
https://git.reviewboard.kde.org/r/119593/
+Patch0: 0001-ensure-platform-window-resize-processing.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -115,6 +117,7 @@
 %lang_package -n libKF5ConfigCore%sonum
 %prep
 %setup -q
+%patch0 -p1
 
 %build
   %cmake_kf5 -d build -- -Dlconvert_executable=%{_kf5_libdir}/qt5/bin/lconvert

++ 0001-ensure-platform-window-resize-processing.patch ++
From 06632ddebeefa97594c19fc4ede5b89ed263b917 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Thomas=20L=C3=BCbking?= thomas.luebk...@gmail.com
Date: Sat, 2 Aug 2014 12:25:00 +0200
Subject: [PATCH] ensure platform window resize processing

---
 src/gui/kwindowconfig.cpp | 5 +
 1 file changed, 5 insertions(+)

diff --git a/src/gui/kwindowconfig.cpp b/src/gui/kwindowconfig.cpp
index c3cefb7..a906cd5 100644
--- a/src/gui/kwindowconfig.cpp
+++ b/src/gui/kwindowconfig.cpp
@@ -21,6 +21,7 @@
 
 #include kwindowconfig.h
 
+#include QCoreApplication
 #include QScreen
 #include QWindow
 
@@ -63,6 +64,7 @@ void KWindowConfig::restoreWindowSize(QWindow *window, const 
KConfigGroup confi
 if (!window) {
 return;
 }
+window-create(); // ensure the platform window is created before 
attempting the resize
 
 const QRect desk = window-screen()-geometry();
 
@@ -80,6 +82,9 @@ void KWindowConfig::restoreWindowSize(QWindow *window, const 
KConfigGroup confi
 
 // If window is maximized set maximized state and in all case set the size
 window-resize(width, height);
+// restoring the size will often happen before event processing
+// - force processing now to have the platform window pick the new size
+QCoreApplication::processEvents();
 if (isMaximized) {
 window-setWindowState(Qt::WindowMaximized);
 }
-- 
2.0.3

++ kconfig-5.1.0.tar.xz - kconfig-5.2.0.tar.xz ++
 91930 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kcrash for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kcrash for openSUSE:Factory checked 
in at 2014-09-12 17:03:19

Comparing /work/SRC/openSUSE:Factory/kcrash (Old)
 and  /work/SRC/openSUSE:Factory/.kcrash.new (New)


Package is kcrash

Changes:

--- /work/SRC/openSUSE:Factory/kcrash/kcrash.changes2014-08-16 
15:42:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.kcrash.new/kcrash.changes   2014-09-12 
17:04:18.0 +0200
@@ -1,0 +2,12 @@
+Tue Sep  9 09:49:28 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---
+Fri Aug 22 18:55:13 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Let libKF5Crash5 Recommends drkonqi5
+
+---

Old:

  kcrash-5.1.0.tar.xz

New:

  kcrash-5.2.0.tar.xz



Other differences:
--
++ kcrash.spec ++
--- /var/tmp/diff_new_pack.t1Xi6r/_old  2014-09-12 17:04:21.0 +0200
+++ /var/tmp/diff_new_pack.t1Xi6r/_new  2014-09-12 17:04:21.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Crash5
 Name:   kcrash
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kcoreaddons-devel = %{kf5_version}
 BuildRequires:  kf5-filesystem
@@ -45,6 +45,7 @@
 %package -n %lname
 Summary:Gracefull handling of application crashes
 Group:  System/GUI/KDE
+Recommends: drkonqi5
 
 %description -n %lname
 KCrash provides support for intercepting and handling application crashes.

++ kcrash-5.1.0.tar.xz - kcrash-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kcrash-5.1.0/CMakeLists.txt 
new/kcrash-5.2.0/CMakeLists.txt
--- old/kcrash-5.1.0/CMakeLists.txt 2014-08-02 10:17:32.0 +0200
+++ new/kcrash-5.2.0/CMakeLists.txt 2014-09-08 01:24:07.0 +0200
@@ -2,7 +2,7 @@
 
 project(KCrash)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
 set(REQUIRED_QT_VERSION 5.2.0)
@@ -22,8 +22,8 @@
 include(ECMSetupVersion)
 include(ECMGenerateHeaders)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KCrash
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kcrash_version.h
 PACKAGE_VERSION_FILE 
${CMAKE_CURRENT_BINARY_DIR}/KF5CrashConfigVersion.cmake
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kcrash-5.1.0/README.md new/kcrash-5.2.0/README.md
--- old/kcrash-5.1.0/README.md  2014-08-02 10:17:32.0 +0200
+++ new/kcrash-5.2.0/README.md  2014-09-08 01:24:07.0 +0200
@@ -1,14 +1,6 @@
 # KCrash
 
-Graceful handling of application crashes
-
 ## Introduction
 
 KCrash provides support for intercepting and handling application crashes.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kcrash
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kcrash/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kcrash-5.1.0/metainfo.yaml 
new/kcrash-5.2.0/metainfo.yaml
--- old/kcrash-5.1.0/metainfo.yaml  2014-08-02 10:17:32.0 +0200
+++ new/kcrash-5.2.0/metainfo.yaml  2014-09-08 01:24:07.0 +0200
@@ -8,3 +8,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KCrash
+   cmake: KF5::Crash
+cmakename: KF5Crash
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kcrash-5.1.0/src/config-kcrash.h.cmake 
new/kcrash-5.2.0/src/config-kcrash.h.cmake
--- old/kcrash-5.1.0/src/config-kcrash.h.cmake  2014-08-02 10:17:32.0 
+0200
+++ new/kcrash-5.2.0/src/config-kcrash.h.cmake  2014-09-08 01:24:07.0 
+0200
@@ -1,5 +1,4 @@
 #cmakedefine01 HAVE_X11
 
 #define kde_socklen_t socklen_t
-#define CMAKE_INSTALL_PREFIX ${CMAKE_INSTALL_PREFIX}
-#define LIBEXEC_INSTALL_DIR ${LIBEXEC_INSTALL_DIR}
+#define CMAKE_INSTALL_FULL_LIBEXECDIR ${CMAKE_INSTALL_FULL_LIBEXECDIR}
diff -urN '--exclude=CVS' 

commit kcoreaddons for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kcoreaddons for openSUSE:Factory 
checked in at 2014-09-12 17:03:12

Comparing /work/SRC/openSUSE:Factory/kcoreaddons (Old)
 and  /work/SRC/openSUSE:Factory/.kcoreaddons.new (New)


Package is kcoreaddons

Changes:

--- /work/SRC/openSUSE:Factory/kcoreaddons/kcoreaddons.changes  2014-09-01 
16:59:41.0 +0200
+++ /work/SRC/openSUSE:Factory/.kcoreaddons.new/kcoreaddons.changes 
2014-09-12 17:04:02.0 +0200
@@ -1,0 +2,11 @@
+Tue Sep  9 09:49:24 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * KCoreAddons: Mark KAboutData::setProgramIconName() as deprecated,
+it did not do anything.
+Use QApplication::setWindowIcon(QIcon::fromTheme(...)) instead.
+  * KCoreAddons: new classes Kdelibs4ConfigMigrator and KPluginMetaData
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kcoreaddons-5.1.0.tar.xz

New:

  kcoreaddons-5.2.0.tar.xz



Other differences:
--
++ kcoreaddons.spec ++
--- /var/tmp/diff_new_pack.nEn3nc/_old  2014-09-12 17:04:04.0 +0200
+++ /var/tmp/diff_new_pack.nEn3nc/_new  2014-09-12 17:04:04.0 +0200
@@ -18,10 +18,10 @@
 
 %define lname   libKF5CoreAddons5
 Name:   kcoreaddons
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  libqt5-linguist-devel = 5.2.0
@@ -111,6 +111,7 @@
 
 %files devel
 %defattr(-,root,root)
+%{_kf5_bindir}/desktoptojson
 %{_kf5_libdir}/libKF5CoreAddons.so
 %{_kf5_libdir}/cmake/KF5CoreAddons/
 %{_kf5_includedir}/

++ kcoreaddons-5.1.0.tar.xz - kcoreaddons-5.2.0.tar.xz ++
 939222 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit frameworkintegration for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package frameworkintegration for 
openSUSE:Factory checked in at 2014-09-12 17:03:11

Comparing /work/SRC/openSUSE:Factory/frameworkintegration (Old)
 and  /work/SRC/openSUSE:Factory/.frameworkintegration.new (New)


Package is frameworkintegration

Changes:

--- 
/work/SRC/openSUSE:Factory/frameworkintegration/frameworkintegration.changes
2014-08-16 15:42:15.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.frameworkintegration.new/frameworkintegration.changes
   2014-09-12 17:03:59.0 +0200
@@ -1,0 +2,9 @@
+Tue Sep  9 09:49:23 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * Frameworkintegration: the file dialog now remembers its size
+correctly, and works better with remote URLs.
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  frameworkintegration-5.1.0.tar.xz

New:

  frameworkintegration-5.2.0.tar.xz



Other differences:
--
++ frameworkintegration.spec ++
--- /var/tmp/diff_new_pack.4SWoMZ/_old  2014-09-12 17:04:01.0 +0200
+++ /var/tmp/diff_new_pack.4SWoMZ/_new  2014-09-12 17:04:01.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Style5
 Name:   frameworkintegration
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kconfig-devel = %{kf5_version}
 BuildRequires:  kconfigwidgets-devel = %{kf5_version}
@@ -108,6 +108,7 @@
 %{_kf5_libdir}/libKF5Style.so.*
 %{_kf5_datadir}/infopage/
 %{_kf5_plugindir}/
+%{_kf5_notifydir}/
 
 %files devel
 %defattr(-,root,root)

++ frameworkintegration-5.1.0.tar.xz - frameworkintegration-5.2.0.tar.xz 
++
 2001 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kdbusaddons for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kdbusaddons for openSUSE:Factory 
checked in at 2014-09-12 17:03:27

Comparing /work/SRC/openSUSE:Factory/kdbusaddons (Old)
 and  /work/SRC/openSUSE:Factory/.kdbusaddons.new (New)


Package is kdbusaddons

Changes:

--- /work/SRC/openSUSE:Factory/kdbusaddons/kdbusaddons.changes  2014-08-16 
15:44:05.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdbusaddons.new/kdbusaddons.changes 
2014-09-12 17:04:32.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:31 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kdbusaddons-5.1.0.tar.xz

New:

  kdbusaddons-5.2.0.tar.xz



Other differences:
--
++ kdbusaddons.spec ++
--- /var/tmp/diff_new_pack.E23dLL/_old  2014-09-12 17:04:33.0 +0200
+++ /var/tmp/diff_new_pack.E23dLL/_new  2014-09-12 17:04:33.0 +0200
@@ -18,10 +18,10 @@
 
 %define lname   libKF5DBusAddons5
 Name:   kdbusaddons
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  libqt5-linguist-devel = 5.2.0

++ kdbusaddons-5.1.0.tar.xz - kdbusaddons-5.2.0.tar.xz ++
 2107 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit knotifyconfig for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package knotifyconfig for openSUSE:Factory 
checked in at 2014-09-12 17:03:32

Comparing /work/SRC/openSUSE:Factory/knotifyconfig (Old)
 and  /work/SRC/openSUSE:Factory/.knotifyconfig.new (New)


Package is knotifyconfig

Changes:

--- /work/SRC/openSUSE:Factory/knotifyconfig/knotifyconfig.changes  
2014-08-16 15:42:36.0 +0200
+++ /work/SRC/openSUSE:Factory/.knotifyconfig.new/knotifyconfig.changes 
2014-09-12 17:04:35.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:32 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  knotifyconfig-5.1.0.tar.xz

New:

  knotifyconfig-5.2.0.tar.xz



Other differences:
--
++ knotifyconfig.spec ++
--- /var/tmp/diff_new_pack.P2Q2Tn/_old  2014-09-12 17:04:36.0 +0200
+++ /var/tmp/diff_new_pack.P2Q2Tn/_new  2014-09-12 17:04:36.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5NotifyConfig5
 Name:   knotifyconfig
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kbookmarks-devel = %{kf5_version}
 BuildRequires:  kcompletion-devel = %{kf5_version}

++ knotifyconfig-5.1.0.tar.xz - knotifyconfig-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/knotifyconfig-5.1.0/CMakeLists.txt 
new/knotifyconfig-5.2.0/CMakeLists.txt
--- old/knotifyconfig-5.1.0/CMakeLists.txt  2014-08-02 11:08:39.0 
+0200
+++ new/knotifyconfig-5.2.0/CMakeLists.txt  2014-09-09 02:32:25.0 
+0200
@@ -3,12 +3,12 @@
 project(KNotifyConfig)
 
 # Dependencies
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
 set(REQUIRED_QT_VERSION 5.2.0)
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 
 # Required Qt5 components to build this framework
 find_package(Qt5 ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Widgets DBus)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/knotifyconfig-5.1.0/README.md 
new/knotifyconfig-5.2.0/README.md
--- old/knotifyconfig-5.1.0/README.md   2014-08-02 11:08:39.0 +0200
+++ new/knotifyconfig-5.2.0/README.md   2014-09-09 02:32:25.0 +0200
@@ -7,9 +7,3 @@
 KNotifyConfig provides a configuration dialog for desktop notifications which
 can be embedded in your application.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/knotifyconfig
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/knotifyconfig/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/knotifyconfig-5.1.0/metainfo.yaml 
new/knotifyconfig-5.2.0/metainfo.yaml
--- old/knotifyconfig-5.1.0/metainfo.yaml   2014-08-02 11:08:39.0 
+0200
+++ new/knotifyconfig-5.2.0/metainfo.yaml   2014-09-09 02:32:25.0 
+0200
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KNotifyConfig
+   cmake: KF5::NotifyConfig
+cmakename: KF5NotifyConfig
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/knotifyconfig-5.1.0/po/af/knotifyconfig5.po 
new/knotifyconfig-5.2.0/po/af/knotifyconfig5.po
--- old/knotifyconfig-5.1.0/po/af/knotifyconfig5.po 2014-08-02 
11:08:39.0 +0200
+++ new/knotifyconfig-5.2.0/po/af/knotifyconfig5.po 2014-09-09 
02:32:25.0 +0200
@@ -3,7 +3,7 @@
 msgstr 
 Project-Id-Version: kdelibs4 stable\n
 Report-Msgid-Bugs-To: http://bugs.kde.org\n;
-POT-Creation-Date: 2014-04-27 20:56+\n
+POT-Creation-Date: 2014-08-08 08:32+\n
 PO-Revision-Date: 2006-01-12 16:33+0200\n
 Last-Translator: JUANITA FRANZ juanita.fr...@vr-web.de\n
 Language-Team: AFRIKAANS translate-discuss...@lists.sourceforge.net\n
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/knotifyconfig-5.1.0/po/ar/knotifyconfig5.po 
new/knotifyconfig-5.2.0/po/ar/knotifyconfig5.po
--- old/knotifyconfig-5.1.0/po/ar/knotifyconfig5.po 2014-08-02 
11:08:39.0 +0200
+++ 

commit kparts for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kparts for openSUSE:Factory checked 
in at 2014-09-12 17:03:38

Comparing /work/SRC/openSUSE:Factory/kparts (Old)
 and  /work/SRC/openSUSE:Factory/.kparts.new (New)


Package is kparts

Changes:

--- /work/SRC/openSUSE:Factory/kparts/kparts.changes2014-08-16 
15:42:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.kparts.new/kparts.changes   2014-09-12 
17:04:49.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:35 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kparts-5.1.0.tar.xz

New:

  kparts-5.2.0.tar.xz



Other differences:
--
++ kparts.spec ++
--- /var/tmp/diff_new_pack.xToG86/_old  2014-09-12 17:04:53.0 +0200
+++ /var/tmp/diff_new_pack.xToG86/_new  2014-09-12 17:04:53.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Parts5
 Name:   kparts
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kbookmarks-devel = %{kf5_version}
 BuildRequires:  kcompletion-devel = %{kf5_version}

++ kparts-5.1.0.tar.xz - kparts-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kparts-5.1.0/CMakeLists.txt 
new/kparts-5.2.0/CMakeLists.txt
--- old/kparts-5.1.0/CMakeLists.txt 2014-08-02 11:09:00.0 +0200
+++ new/kparts-5.2.0/CMakeLists.txt 2014-09-09 02:33:36.0 +0200
@@ -2,7 +2,7 @@
 
 project(KParts)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
@@ -17,8 +17,8 @@
 
 include(ECMSetupVersion)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KPARTS
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kparts_version.h
 PACKAGE_VERSION_FILE 
${CMAKE_CURRENT_BINARY_DIR}/KF5PartsConfigVersion.cmake
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kparts-5.1.0/README.md new/kparts-5.2.0/README.md
--- old/kparts-5.1.0/README.md  2014-08-02 11:09:00.0 +0200
+++ new/kparts-5.2.0/README.md  2014-09-09 02:33:36.0 +0200
@@ -39,9 +39,3 @@
 KParts::ComponentFactory::createPartInstanceFromQuery.
 
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kparts
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kparts/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kparts-5.1.0/metainfo.yaml 
new/kparts-5.2.0/metainfo.yaml
--- old/kparts-5.1.0/metainfo.yaml  2014-08-02 11:09:00.0 +0200
+++ new/kparts-5.2.0/metainfo.yaml  2014-09-09 02:33:36.0 +0200
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KParts
+   cmake: KF5::Parts
+cmakename: KF5Parts
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kparts-5.1.0/po/cs/kparts5.po 
new/kparts-5.2.0/po/cs/kparts5.po
--- old/kparts-5.1.0/po/cs/kparts5.po   2014-08-02 11:09:00.0 +0200
+++ new/kparts-5.2.0/po/cs/kparts5.po   2014-09-09 02:33:36.0 +0200
@@ -18,6 +18,8 @@
 Content-Transfer-Encoding: 8bit\n
 Plural-Forms: nplurals=3; plural=(n==1) ? 0 : (n=2  n=4) ? 1 : 2;\n
 X-Generator: Lokalize 1.5\n
+X-Language: cs_CZ\n
+X-Source-Language: en_US\n
 
 msgctxt NAME OF TRANSLATORS
 msgid Your names
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kparts-5.1.0/po/fi/kparts5.po 
new/kparts-5.2.0/po/fi/kparts5.po
--- old/kparts-5.1.0/po/fi/kparts5.po   2014-08-02 11:09:00.0 +0200
+++ new/kparts-5.2.0/po/fi/kparts5.po   2014-09-09 02:33:36.0 +0200
@@ -29,7 +29,7 @@
 POT-Creation-Date: 2014-04-27 20:57+\n
 PO-Revision-Date: 2014-03-24 21:09+0200\n
 Last-Translator: Lasse Liehu lasse.li...@gmail.com\n
-Language-Team: Finnish lokalisoi...@lists.coss.fi\n
+Language-Team: Finnish kde-i18n-...@kde.org\n
 Language: fi\n
 MIME-Version: 1.0\n
 Content-Type: text/plain; 

commit kmediaplayer for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kmediaplayer for openSUSE:Factory 
checked in at 2014-09-12 17:03:07

Comparing /work/SRC/openSUSE:Factory/kmediaplayer (Old)
 and  /work/SRC/openSUSE:Factory/.kmediaplayer.new (New)


Package is kmediaplayer

Changes:

--- /work/SRC/openSUSE:Factory/kmediaplayer/kmediaplayer.changes
2014-08-16 15:42:11.0 +0200
+++ /work/SRC/openSUSE:Factory/.kmediaplayer.new/kmediaplayer.changes   
2014-09-12 17:03:56.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:22 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kmediaplayer-5.1.0.tar.xz

New:

  kmediaplayer-5.2.0.tar.xz



Other differences:
--
++ kmediaplayer.spec ++
--- /var/tmp/diff_new_pack.eaRgPR/_old  2014-09-12 17:03:57.0 +0200
+++ /var/tmp/diff_new_pack.eaRgPR/_new  2014-09-12 17:03:57.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5MediaPlayer5
 Name:   kmediaplayer
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kbookmarks-devel = %{kf5_version}
 BuildRequires:  kcompletion-devel = %{kf5_version}

++ kmediaplayer-5.1.0.tar.xz - kmediaplayer-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kmediaplayer-5.1.0/CMakeLists.txt 
new/kmediaplayer-5.2.0/CMakeLists.txt
--- old/kmediaplayer-5.1.0/CMakeLists.txt   2014-08-02 10:20:08.0 
+0200
+++ new/kmediaplayer-5.2.0/CMakeLists.txt   2014-09-08 01:26:27.0 
+0200
@@ -6,7 +6,7 @@
 #
 # CMake stuff from ECM
 #
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
 include(KDEInstallDirs)
@@ -19,8 +19,8 @@
 include(ECMGenerateHeaders)
 include(ECMPackageConfigHelpers)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 
 #
 # Version info
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kmediaplayer-5.1.0/README.md 
new/kmediaplayer-5.2.0/README.md
--- old/kmediaplayer-5.1.0/README.md2014-08-02 10:20:08.0 +0200
+++ new/kmediaplayer-5.2.0/README.md2014-09-08 01:26:27.0 +0200
@@ -47,9 +47,3 @@
 }
 
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kmediaplayer
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: \#kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kmediaplayer/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kmediaplayer-5.1.0/metainfo.yaml 
new/kmediaplayer-5.2.0/metainfo.yaml
--- old/kmediaplayer-5.1.0/metainfo.yaml2014-08-02 10:20:08.0 
+0200
+++ new/kmediaplayer-5.2.0/metainfo.yaml2014-09-08 01:26:27.0 
+0200
@@ -7,3 +7,4 @@
 portingAid: true
 deprecated: true
 release: true
+cmakename: KF5MediaPlayer

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kidletime for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kidletime for openSUSE:Factory 
checked in at 2014-09-12 17:03:14

Comparing /work/SRC/openSUSE:Factory/kidletime (Old)
 and  /work/SRC/openSUSE:Factory/.kidletime.new (New)


Package is kidletime

Changes:

--- /work/SRC/openSUSE:Factory/kidletime/kidletime.changes  2014-08-16 
15:42:19.0 +0200
+++ /work/SRC/openSUSE:Factory/.kidletime.new/kidletime.changes 2014-09-12 
17:04:07.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:26 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kidletime-5.1.0.tar.xz

New:

  kidletime-5.2.0.tar.xz



Other differences:
--
++ kidletime.spec ++
--- /var/tmp/diff_new_pack.aAXUfE/_old  2014-09-12 17:04:09.0 +0200
+++ /var/tmp/diff_new_pack.aAXUfE/_new  2014-09-12 17:04:09.0 +0200
@@ -18,10 +18,10 @@
 
 %define lname   libKF5IdleTime5
 Name:   kidletime
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  pkgconfig(Qt5Core) = 5.2.0

++ kidletime-5.1.0.tar.xz - kidletime-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kidletime-5.1.0/CMakeLists.txt 
new/kidletime-5.2.0/CMakeLists.txt
--- old/kidletime-5.1.0/CMakeLists.txt  2014-08-02 10:19:11.0 +0200
+++ new/kidletime-5.2.0/CMakeLists.txt  2014-09-08 01:25:39.0 +0200
@@ -3,7 +3,7 @@
 project(KIdleTime)
 
 # ECM setup
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
 include(FeatureSummary)
@@ -13,7 +13,7 @@
 include(ECMSetupVersion)
 include(ECMGenerateHeaders)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
 
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KIDLETIME
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kidletime_version.h
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kidletime-5.1.0/README.md 
new/kidletime-5.2.0/README.md
--- old/kidletime-5.1.0/README.md   2014-08-02 10:19:11.0 +0200
+++ new/kidletime-5.2.0/README.md   2014-09-08 01:25:39.0 +0200
@@ -8,9 +8,3 @@
 only for finding out about the current idle time of the PC, but also for 
getting
 notified upon idle time events, such as custom timeouts, or user activity.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kidletime
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kidletime/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kidletime-5.1.0/metainfo.yaml 
new/kidletime-5.2.0/metainfo.yaml
--- old/kidletime-5.1.0/metainfo.yaml   2014-08-02 10:19:11.0 +0200
+++ new/kidletime-5.2.0/metainfo.yaml   2014-09-08 01:25:39.0 +0200
@@ -9,3 +9,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KIdleTime
+   cmake: KF5::IdleTime
+cmakename: KF5IdleTime

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kiconthemes for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kiconthemes for openSUSE:Factory 
checked in at 2014-09-12 17:03:06

Comparing /work/SRC/openSUSE:Factory/kiconthemes (Old)
 and  /work/SRC/openSUSE:Factory/.kiconthemes.new (New)


Package is kiconthemes

Changes:

--- /work/SRC/openSUSE:Factory/kiconthemes/kiconthemes.changes  2014-08-16 
15:42:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.kiconthemes.new/kiconthemes.changes 
2014-09-12 17:03:55.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:21 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kiconthemes-5.1.0.tar.xz

New:

  kiconthemes-5.2.0.tar.xz



Other differences:
--
++ kiconthemes.spec ++
--- /var/tmp/diff_new_pack.8tv2mu/_old  2014-09-12 17:03:56.0 +0200
+++ /var/tmp/diff_new_pack.8tv2mu/_new  2014-09-12 17:03:56.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5IconThemes5
 Name:   kiconthemes
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kconfigwidgets-devel = %{kf5_version}
 BuildRequires:  kf5-filesystem

++ kiconthemes-5.1.0.tar.xz - kiconthemes-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kiconthemes-5.1.0/CMakeLists.txt 
new/kiconthemes-5.2.0/CMakeLists.txt
--- old/kiconthemes-5.1.0/CMakeLists.txt2014-08-02 11:05:17.0 
+0200
+++ new/kiconthemes-5.2.0/CMakeLists.txt2014-09-09 02:23:23.0 
+0200
@@ -3,7 +3,7 @@
 project(KIconThemes)
 
 # ECM setup
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
 include(KDEInstallDirs)
@@ -15,8 +15,8 @@
 include(ECMGenerateHeaders)
 include(ECMMarkNonGuiExecutable)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 
 ecm_setup_version(${KF5_VERSION}
   VARIABLE_PREFIX KICONTHEMES
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kiconthemes-5.1.0/README.md 
new/kiconthemes-5.2.0/README.md
--- old/kiconthemes-5.1.0/README.md 2014-08-02 11:05:17.0 +0200
+++ new/kiconthemes-5.2.0/README.md 2014-09-09 02:23:23.0 +0200
@@ -17,9 +17,3 @@
 Other classes in this repository are used internally by the icon
 theme configuration dialogs, and should not be used by applications.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kiconthemes
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kiconthemes/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kiconthemes-5.1.0/metainfo.yaml 
new/kiconthemes-5.2.0/metainfo.yaml
--- old/kiconthemes-5.1.0/metainfo.yaml 2014-08-02 11:05:17.0 +0200
+++ new/kiconthemes-5.2.0/metainfo.yaml 2014-09-09 02:23:23.0 +0200
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KIconThemes
+   cmake: KF5::IconThemes
+cmakename: KF5IconThemes
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kiconthemes-5.1.0/po/nds/kiconthemes5.po 
new/kiconthemes-5.2.0/po/nds/kiconthemes5.po
--- old/kiconthemes-5.1.0/po/nds/kiconthemes5.po2014-08-02 
11:05:17.0 +0200
+++ new/kiconthemes-5.2.0/po/nds/kiconthemes5.po2014-09-09 
02:23:23.0 +0200
@@ -17,7 +17,7 @@
 MIME-Version: 1.0\n
 Content-Type: text/plain; charset=UTF-8\n
 Content-Transfer-Encoding: 8bit\n
-X-Generator: Lokalize 1.5\n
+X-Generator: Lokalize 1.4\n
 Plural-Forms: nplurals=2; plural=n != 1;\n
 
 #: kicondialog.cpp:240 kicondialog.cpp:250 kicondialog.cpp:589
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kiconthemes-5.1.0/po/sr/kiconthemes5.po 
new/kiconthemes-5.2.0/po/sr/kiconthemes5.po
--- old/kiconthemes-5.1.0/po/sr/kiconthemes5.po 2014-08-02 11:05:17.0 
+0200
+++ new/kiconthemes-5.2.0/po/sr/kiconthemes5.po 2014-09-09 02:23:23.0 
+0200
@@ -19,8 +19,8 @@
 %10=2  n%10=4  (n%10010 || n%100=20) ? 1 : 2;\n
 

commit kemoticons for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kemoticons for openSUSE:Factory 
checked in at 2014-09-12 17:03:21

Comparing /work/SRC/openSUSE:Factory/kemoticons (Old)
 and  /work/SRC/openSUSE:Factory/.kemoticons.new (New)


Package is kemoticons

Changes:

--- /work/SRC/openSUSE:Factory/kemoticons/kemoticons.changes2014-08-16 
15:42:27.0 +0200
+++ /work/SRC/openSUSE:Factory/.kemoticons.new/kemoticons.changes   
2014-09-12 17:04:21.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:29 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kemoticons-5.1.0.tar.xz

New:

  kemoticons-5.2.0.tar.xz



Other differences:
--
++ kemoticons.spec ++
--- /var/tmp/diff_new_pack.e08hlg/_old  2014-09-12 17:04:23.0 +0200
+++ /var/tmp/diff_new_pack.e08hlg/_new  2014-09-12 17:04:23.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Emoticons5
 Name:   kemoticons
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  karchive-devel = %{kf5_version}
 BuildRequires:  kconfig-devel = %{kf5_version}

++ kemoticons-5.1.0.tar.xz - kemoticons-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kemoticons-5.1.0/CMakeLists.txt 
new/kemoticons-5.2.0/CMakeLists.txt
--- old/kemoticons-5.1.0/CMakeLists.txt 2014-08-02 10:18:32.0 +0200
+++ new/kemoticons-5.2.0/CMakeLists.txt 2014-09-08 01:25:05.0 +0200
@@ -2,7 +2,7 @@
 
 project(KEmoticons)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} 
${CMAKE_CURRENT_SOURCE_DIR}/cmake)
 
@@ -19,8 +19,8 @@
 include(ECMGenerateHeaders)
 include(ECMPackageConfigHelpers)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KEMOTICONS
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kemoticons_version.h
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kemoticons-5.1.0/README.md 
new/kemoticons-5.2.0/README.md
--- old/kemoticons-5.1.0/README.md  2014-08-02 10:18:32.0 +0200
+++ new/kemoticons-5.2.0/README.md  2014-09-08 01:25:05.0 +0200
@@ -8,9 +8,3 @@
 images in HTML. It supports setting different themes for emoticons coming
 from different providers.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kemoticons
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kemoticons/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kemoticons-5.1.0/metainfo.yaml 
new/kemoticons-5.2.0/metainfo.yaml
--- old/kemoticons-5.1.0/metainfo.yaml  2014-08-02 10:18:32.0 +0200
+++ new/kemoticons-5.2.0/metainfo.yaml  2014-09-08 01:25:05.0 +0200
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KEmoticons
+   cmake: KF5::Emoticons
+cmakename: KF5Emoticons

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit knotifications for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package knotifications for openSUSE:Factory 
checked in at 2014-09-12 17:03:23

Comparing /work/SRC/openSUSE:Factory/knotifications (Old)
 and  /work/SRC/openSUSE:Factory/.knotifications.new (New)


Package is knotifications

Changes:

--- /work/SRC/openSUSE:Factory/knotifications/knotifications.changes
2014-08-16 15:42:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.knotifications.new/knotifications.changes   
2014-09-12 17:04:26.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:30 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  knotifications-5.1.0.tar.xz

New:

  knotifications-5.2.0.tar.xz



Other differences:
--
++ knotifications.spec ++
--- /var/tmp/diff_new_pack.9qp5hh/_old  2014-09-12 17:04:27.0 +0200
+++ /var/tmp/diff_new_pack.9qp5hh/_new  2014-09-12 17:04:27.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Notifications5
 Name:   knotifications
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kcodecs-devel = %{kf5_version}
 BuildRequires:  kconfig-devel = %{kf5_version}

++ knotifications-5.1.0.tar.xz - knotifications-5.2.0.tar.xz ++
 899883 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kio for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kio for openSUSE:Factory checked in 
at 2014-09-12 17:03:37

Comparing /work/SRC/openSUSE:Factory/kio (Old)
 and  /work/SRC/openSUSE:Factory/.kio.new (New)


Package is kio

Changes:

--- /work/SRC/openSUSE:Factory/kio/kio.changes  2014-08-16 15:42:45.0 
+0200
+++ /work/SRC/openSUSE:Factory/.kio.new/kio.changes 2014-09-12 
17:04:45.0 +0200
@@ -1,0 +2,16 @@
+Tue Sep  9 09:49:34 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * KIO/KService: now follows the mime-apps spec, for better
+interoperability with gio when it comes to the user's
+preferred and default apps.
+  * KIO: new classes EmptyTrashJob and RestoreJob
+  * KIO: new functions isClipboardDataCut and setClipboardDataCut.
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+- Added 0001-Fix-thumbnails-for-mimetype-groups.patch, fixes thumbnail
+  generation for mimetypes with wildcard usage
+- 0002-Fix-relative-paths-being-turned-into-http-urls-by-fr.patch,
+  fixes filedialog appening 'http://' on directory change
+
+---

Old:

  kio-5.1.0.tar.xz

New:

  0001-Fix-thumbnails-for-mimetype-groups.patch
  0002-Fix-relative-paths-being-turned-into-http-urls-by-fr.patch
  kio-5.2.0.tar.xz



Other differences:
--
++ kio.spec ++
--- /var/tmp/diff_new_pack.uhlZ0W/_old  2014-09-12 17:04:47.0 +0200
+++ /var/tmp/diff_new_pack.uhlZ0W/_new  2014-09-12 17:04:47.0 +0200
@@ -17,11 +17,11 @@
 
 
 Name:   kio
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  karchive-devel = %{kf5_version}
 BuildRequires:  kbookmarks-devel = %{kf5_version}
@@ -66,6 +66,10 @@
 Url:http://www.kde.org
 Source: 
http://download.kde.org/stable/frameworks/%{version}/%{name}-%{version}.tar.xz
 Source1:baselibs.conf
+# PATCH-FIX-UPSTREAM  0001-Fix-thumbnails-for-mimetype-groups.patch -- 
https://git.reviewboard.kde.org/r/119958/
+Patch0: 0001-Fix-thumbnails-for-mimetype-groups.patch
+# PATCH-FIX-UPSTREAM  
0002-Fix-relative-paths-being-turned-into-http-urls-by-fr.patch
+Patch1: 0002-Fix-relative-paths-being-turned-into-http-urls-by-fr.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -95,6 +99,8 @@
 %lang_package
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 
 %build
   %cmake_kf5 -d build

++ 0001-Fix-thumbnails-for-mimetype-groups.patch ++
From ae87a7d6999fc6ad90ab300dd8ea0c9c68c02bd4 Mon Sep 17 00:00:00 2001
From: Maarten De Meyer de.meyer.maar...@gmail.com
Date: Mon, 8 Sep 2014 23:58:55 +0200
Subject: [PATCH 1/2] Fix thumbnails for mimetype groups.

KService::mimeTypes cannot handle mimetype groups. ex: text/*
Go back to KService::serviceTypes and remove 'ThumbCreator' entries.

REVIEW: 119958
---
 src/widgets/previewjob.cpp | 17 +++--
 1 file changed, 11 insertions(+), 6 deletions(-)

diff --git a/src/widgets/previewjob.cpp b/src/widgets/previewjob.cpp
index 55a3fb7..ca47934 100644
--- a/src/widgets/previewjob.cpp
+++ b/src/widgets/previewjob.cpp
@@ -268,20 +268,25 @@ void PreviewJobPrivate::startPreview()
 protocols.append(p);
 }
 foreach (const QString protocol, protocols) {
-const QStringList mtypes = (*it)-mimeTypes();
+// We cannot use mimeTypes() here, it doesn't support groups such 
as: text/*
+const QStringList mtypes = (*it)-serviceTypes();
 // Add supported mimetype for this protocol
 QStringList _ms = m_remoteProtocolPlugins[protocol];
 foreach (const QString _m, mtypes) {
-protocolMap[protocol].insert(_m, *it);
-if (!_ms.contains(_m)) {
-_ms.append(_m);
+if (_m != QLatin1String(ThumbCreator)) {
+protocolMap[protocol].insert(_m, *it);
+if (!_ms.contains(_m)) {
+_ms.append(_m);
+}
 }
 }
 }
 if (enabledPlugins.contains((*it)-desktopEntryName())) {
-const QStringList mimeTypes = (*it)-mimeTypes();
+const QStringList mimeTypes = (*it)-serviceTypes();
 for (QStringList::ConstIterator mt = mimeTypes.constBegin(); mt != 
mimeTypes.constEnd(); ++mt) {
-mimeMap.insert(*mt, *it);
+if (*mt != QLatin1String(ThumbCreator)) {
+

commit kinit for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kinit for openSUSE:Factory checked 
in at 2014-09-12 17:03:30

Comparing /work/SRC/openSUSE:Factory/kinit (Old)
 and  /work/SRC/openSUSE:Factory/.kinit.new (New)


Package is kinit

Changes:

--- /work/SRC/openSUSE:Factory/kinit/kinit.changes  2014-08-16 
15:42:34.0 +0200
+++ /work/SRC/openSUSE:Factory/.kinit.new/kinit.changes 2014-09-12 
17:04:33.0 +0200
@@ -1,0 +2,8 @@
+Tue Sep  9 09:49:32 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+- Rebase fpie.patch
+
+---

Old:

  kinit-5.1.0.tar.xz

New:

  kinit-5.2.0.tar.xz



Other differences:
--
++ kinit.spec ++
--- /var/tmp/diff_new_pack.JuOJdw/_old  2014-09-12 17:04:35.0 +0200
+++ /var/tmp/diff_new_pack.JuOJdw/_new  2014-09-12 17:04:35.0 +0200
@@ -17,11 +17,11 @@
 
 
 Name:   kinit
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kcrash-devel = %{kf5_version}
 BuildRequires:  kdoctools-devel = %{kf5_version}

++ fpie.patch ++
--- /var/tmp/diff_new_pack.JuOJdw/_old  2014-09-12 17:04:35.0 +0200
+++ /var/tmp/diff_new_pack.JuOJdw/_new  2014-09-12 17:04:35.0 +0200
@@ -1,5 +1,5 @@
 diff --git a/src/start_kdeinit/CMakeLists.txt 
b/src/start_kdeinit/CMakeLists.txt
-index 56a91e3..1af14de 100644
+index 46d6cb3..31434df 100644
 --- a/src/start_kdeinit/CMakeLists.txt
 +++ b/src/start_kdeinit/CMakeLists.txt
 @@ -2,6 +2,11 @@ add_executable(start_kdeinit start_kdeinit.c)
@@ -13,4 +13,4 @@
 +
  add_executable(start_kdeinit_wrapper start_kdeinit_wrapper.c)
  
- install(TARGETS start_kdeinit DESTINATION ${KF5_LIBEXEC_INSTALL_DIR})
+ install(TARGETS start_kdeinit DESTINATION 
${CMAKE_INSTALL_FULL_LIBEXECDIR_KF5})

++ kinit-5.1.0.tar.xz - kinit-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kinit-5.1.0/CMakeLists.txt 
new/kinit-5.2.0/CMakeLists.txt
--- old/kinit-5.1.0/CMakeLists.txt  2014-08-02 11:05:47.0 +0200
+++ new/kinit-5.2.0/CMakeLists.txt  2014-09-09 02:24:19.0 +0200
@@ -2,7 +2,7 @@
 
 project(KInit)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} 
${CMAKE_CURRENT_SOURCE_DIR}/cmake)
 
 set(REQUIRED_QT_VERSION 5.2)
@@ -15,8 +15,8 @@
 include(ECMPackageConfigHelpers)
 include(ECMSetupVersion)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KINIT
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kinit_version.h
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kinit-5.1.0/README.md new/kinit-5.2.0/README.md
--- old/kinit-5.1.0/README.md   2014-08-02 11:05:47.0 +0200
+++ new/kinit-5.2.0/README.md   2014-09-09 02:24:19.0 +0200
@@ -83,9 +83,3 @@
 
 [kde-dev-scripts]: 
https://projects.kde.org/projects/kde/kdesdk/kde-dev-scripts/
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kinit
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kinit/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kinit-5.1.0/metainfo.yaml 
new/kinit-5.2.0/metainfo.yaml
--- old/kinit-5.1.0/metainfo.yaml   2014-08-02 11:05:47.0 +0200
+++ new/kinit-5.2.0/metainfo.yaml   2014-09-09 02:24:19.0 +0200
@@ -9,3 +9,4 @@
 portingAid: false
 deprecated: false
 release: true
+cmakename: KF5Init
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kinit-5.1.0/po/cs/kinit5.po 
new/kinit-5.2.0/po/cs/kinit5.po
--- old/kinit-5.1.0/po/cs/kinit5.po 2014-08-02 11:05:47.0 +0200
+++ new/kinit-5.2.0/po/cs/kinit5.po 2014-09-09 02:24:19.0 +0200
@@ -18,6 +18,8 @@
 Content-Transfer-Encoding: 8bit\n
 Plural-Forms: nplurals=3; plural=(n==1) ? 0 : (n=2  n=4) ? 1 : 2;\n
 X-Generator: Lokalize 1.5\n
+X-Language: cs_CZ\n
+X-Source-Language: en_US\n
 
 #: kdeinit/kinit.cpp:526
 msgid 
diff -urN 

commit solid for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package solid for openSUSE:Factory checked 
in at 2014-09-12 17:03:40

Comparing /work/SRC/openSUSE:Factory/solid (Old)
 and  /work/SRC/openSUSE:Factory/.solid.new (New)


Package is solid

Changes:

--- /work/SRC/openSUSE:Factory/solid/solid.changes  2014-08-16 
15:42:49.0 +0200
+++ /work/SRC/openSUSE:Factory/.solid.new/solid.changes 2014-09-12 
17:04:53.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:35 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  solid-5.1.0.tar.xz

New:

  solid-5.2.0.tar.xz



Other differences:
--
++ solid.spec ++
--- /var/tmp/diff_new_pack.RJoPp4/_old  2014-09-12 17:04:58.0 +0200
+++ /var/tmp/diff_new_pack.RJoPp4/_new  2014-09-12 17:04:58.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Solid5
 Name:   solid
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  bison
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  flex
 BuildRequires:  kf5-filesystem

++ solid-5.1.0.tar.xz - solid-5.2.0.tar.xz ++
 116917 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kapidox for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kapidox for openSUSE:Factory checked 
in at 2014-09-12 17:03:26

Comparing /work/SRC/openSUSE:Factory/kapidox (Old)
 and  /work/SRC/openSUSE:Factory/.kapidox.new (New)


Package is kapidox

Changes:

--- /work/SRC/openSUSE:Factory/kapidox/kapidox.changes  2014-08-16 
15:42:33.0 +0200
+++ /work/SRC/openSUSE:Factory/.kapidox.new/kapidox.changes 2014-09-12 
17:04:31.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:31 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kapidox-5.1.0.tar.xz

New:

  kapidox-5.2.0.tar.xz



Other differences:
--
++ kapidox.spec ++
--- /var/tmp/diff_new_pack.eHY04R/_old  2014-09-12 17:04:32.0 +0200
+++ /var/tmp/diff_new_pack.eHY04R/_new  2014-09-12 17:04:32.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   kapidox
-Version:5.1.0
+Version:5.2.0
 Release:0
 Requires:   doxygen
 BuildRequires:  fdupes

++ kapidox-5.1.0.tar.xz - kapidox-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kapidox-5.1.0/.reviewboardrc 
new/kapidox-5.2.0/.reviewboardrc
--- old/kapidox-5.1.0/.reviewboardrc2014-07-15 21:20:31.0 +0200
+++ new/kapidox-5.2.0/.reviewboardrc2014-09-02 21:01:58.0 +0200
@@ -2,4 +2,4 @@
 REPOSITORY = 'git://anongit.kde.org/kapidox'
 BRANCH = 'master'
 TARGET_GROUPS = 'kdeframeworks'
-TARGET_PEOPLE = 'gateau'
+TARGET_PEOPLE = 'alexmerry'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kapidox-5.1.0/metainfo.yaml 
new/kapidox-5.2.0/metainfo.yaml
--- old/kapidox-5.1.0/metainfo.yaml 2014-07-15 21:20:31.0 +0200
+++ new/kapidox-5.2.0/metainfo.yaml 2014-09-02 21:01:58.0 +0200
@@ -1,4 +1,4 @@
-maintainer: gateau
+maintainer: alexmerry
 description: Scripts and data for building API documentation (dox) in a 
standard format and style
 tier: 1
 type: functional
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kapidox-5.1.0/setup.py new/kapidox-5.2.0/setup.py
--- old/kapidox-5.1.0/setup.py  2014-07-15 21:20:31.0 +0200
+++ new/kapidox-5.2.0/setup.py  2014-09-02 21:01:58.0 +0200
@@ -5,7 +5,7 @@
 
 setup(
 name='kapidox',
-version='5.0.0',
+version='5.2.0',
 description='KDE API documentation generation tools',
 maintainer = 'Aurélien Gâteau',
 maintainer_email = 'agat...@kde.org',
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kapidox-5.1.0/src/kapidox/data/frameworks.yaml 
new/kapidox-5.2.0/src/kapidox/data/frameworks.yaml
--- old/kapidox-5.1.0/src/kapidox/data/frameworks.yaml  2014-07-15 
21:20:31.0 +0200
+++ new/kapidox-5.2.0/src/kapidox/data/frameworks.yaml  2014-09-02 
21:01:58.0 +0200
@@ -6,7 +6,14 @@
   desktop applications (such as KNewStuff, for fetching downloadable add-on
   content in an application, or the powerful KIO multi-protocol file access
   framework).
-- The frameworks are divided into four tiers.
+- The KDE Frameworks can be used in CMake-based and QMake-based projects,
+  and most of them are portable to at least Windows, Mac and Linux. The
+  documentation of each framework has code snippets that show how to 
include
+  the framework in a QMake or CMake project.
+- The frameworks are divided into four tiers, based on the kind of
+  dependencies that they have. For instance, Tier 1 frameworks depend on Qt
+  and possibly some third-party libraries, but not on other frameworks. 
This
+  makes them easy to integrate into existing applications.
 
 tiers:
 1: Tier 1 frameworks depend only on Qt (and possibly a small number of 
other
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kapidox-5.1.0/src/kapidox/data/htmlresource/kde.css 
new/kapidox-5.2.0/src/kapidox/data/htmlresource/kde.css
--- old/kapidox-5.1.0/src/kapidox/data/htmlresource/kde.css 2014-07-15 
21:20:31.0 +0200
+++ new/kapidox-5.2.0/src/kapidox/data/htmlresource/kde.css 2014-09-02 
21:01:58.0 +0200
@@ -46,8 +46,19 @@
 border: 1px solid;
 }
 
+dt a {
+font-weight: bold;
+}
+
+dt {
+margin-top: 0.8em;
+}
+dt:first-child {
+margin-top: 0;
+}
 dd {
 margin-left: 1em;
+color: #323232;
 }
 
 form {
@@ -168,6 +179,17 @@
 display: none;
 }
 
+/* The Doxygen-provided page title, that is already displayed 

commit karchive for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package karchive for openSUSE:Factory 
checked in at 2014-09-12 17:03:35

Comparing /work/SRC/openSUSE:Factory/karchive (Old)
 and  /work/SRC/openSUSE:Factory/.karchive.new (New)


Package is karchive

Changes:

--- /work/SRC/openSUSE:Factory/karchive/karchive.changes2014-08-16 
15:42:41.0 +0200
+++ /work/SRC/openSUSE:Factory/.karchive.new/karchive.changes   2014-09-12 
17:04:40.0 +0200
@@ -1,0 +2,8 @@
+Tue Sep  9 09:49:33 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * KArchive: fix handling of uncompressed files
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  karchive-5.1.0.tar.xz

New:

  karchive-5.2.0.tar.xz



Other differences:
--
++ karchive.spec ++
--- /var/tmp/diff_new_pack.JIZTyN/_old  2014-09-12 17:04:42.0 +0200
+++ /var/tmp/diff_new_pack.JIZTyN/_new  2014-09-12 17:04:42.0 +0200
@@ -18,10 +18,10 @@
 
 %define lname   libKF5Archive5
 Name:   karchive
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  pkgconfig(Qt5Core) = 5.2.0

++ karchive-5.1.0.tar.xz - karchive-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/karchive-5.1.0/CMakeLists.txt 
new/karchive-5.2.0/CMakeLists.txt
--- old/karchive-5.1.0/CMakeLists.txt   2014-08-02 10:15:53.0 +0200
+++ new/karchive-5.2.0/CMakeLists.txt   2014-09-08 01:23:20.0 +0200
@@ -2,7 +2,7 @@
 
 project(KArchive)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
@@ -45,7 +45,7 @@
 include(ECMSetupVersion)
 include(ECMGenerateHeaders)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
 
 ecm_setup_version(${KF5_VERSION}
 VARIABLE_PREFIX KARCHIVE
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/karchive-5.1.0/README.md new/karchive-5.2.0/README.md
--- old/karchive-5.1.0/README.md2014-08-02 10:15:53.0 +0200
+++ new/karchive-5.2.0/README.md2014-09-08 01:23:20.0 +0200
@@ -1,24 +1,15 @@
 # KArchive
 
-Reading, creating, and manipulating file archives
-
 ## Introduction
 
 KArchive provides classes for easy reading, creation and manipulation of
 archive formats like ZIP and TAR.
 
-If also provides transparent compression and decompression of data, like the
+It also provides transparent compression and decompression of data, like the
 GZip format, via a subclass of QIODevice.
 
 ## Usage
 
-If you are using CMake, you need to have
-
-find_package(KF5Archive NO_MODULE)
-
-(or similar) in your CMakeLists.txt file, and you need to link any target that
-uses KArchive against KF5::Archive.
-
 If you want to read and write compressed data, just create an instance of
 KCompressionDevice and write to or read from that.
 
@@ -27,9 +18,3 @@
 combine this with usage of KCompressionDevice (see the API documentation for 
the
 relevant KArchive subclass for details).
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/karchive
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/karchive/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/karchive-5.1.0/autotests/kfiltertest.cpp 
new/karchive-5.2.0/autotests/kfiltertest.cpp
--- old/karchive-5.1.0/autotests/kfiltertest.cpp2014-08-02 
10:15:53.0 +0200
+++ new/karchive-5.2.0/autotests/kfiltertest.cpp2014-09-08 
01:23:20.0 +0200
@@ -409,7 +409,13 @@
 QVERIFY(QFile::exists(outFile));
 KCompressionDevice reader(outFile, compressionType);
 QVERIFY(reader.open(QIODevice::ReadOnly));
+QString expectedFullData;
 for( int i = 0 ; i  numLines ; ++i ) {
 QCOMPARE(QString::fromUtf8(reader.readLine()), 
QString(lineTemplate.arg(i) + '\n'));
+expectedFullData += QString(lineTemplate.arg(i) + '\n');
 }
+KFilterDev otherReader(outFile);
+QVERIFY(otherReader.open(QIODevice::ReadOnly));
+QCOMPARE(QString::fromLatin1(otherReader.readAll()), expectedFullData);
+QVERIFY(otherReader.atEnd());
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' 

commit kdnssd-framework for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kdnssd-framework for 
openSUSE:Factory checked in at 2014-09-12 17:03:02

Comparing /work/SRC/openSUSE:Factory/kdnssd-framework (Old)
 and  /work/SRC/openSUSE:Factory/.kdnssd-framework.new (New)


Package is kdnssd-framework

Changes:

--- /work/SRC/openSUSE:Factory/kdnssd-framework/kdnssd-framework.changes
2014-08-16 15:42:07.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdnssd-framework.new/kdnssd-framework.changes   
2014-09-12 17:03:52.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:20 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kdnssd-5.1.0.tar.xz

New:

  kdnssd-5.2.0.tar.xz



Other differences:
--
++ kdnssd-framework.spec ++
--- /var/tmp/diff_new_pack.Q80TKd/_old  2014-09-12 17:03:53.0 +0200
+++ /var/tmp/diff_new_pack.Q80TKd/_new  2014-09-12 17:03:53.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5DNSSD5
 Name:   kdnssd-framework
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  avahi-compat-mDNSResponder-devel
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  libqt5-linguist-devel = 5.2.0

++ kdnssd-5.1.0.tar.xz - kdnssd-5.2.0.tar.xz ++
 898618 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kwidgetsaddons for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kwidgetsaddons for openSUSE:Factory 
checked in at 2014-09-12 17:03:33

Comparing /work/SRC/openSUSE:Factory/kwidgetsaddons (Old)
 and  /work/SRC/openSUSE:Factory/.kwidgetsaddons.new (New)


Package is kwidgetsaddons

Changes:

--- /work/SRC/openSUSE:Factory/kwidgetsaddons/kwidgetsaddons.changes
2014-08-16 15:42:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.kwidgetsaddons.new/kwidgetsaddons.changes   
2014-09-12 17:04:37.0 +0200
@@ -1,0 +2,10 @@
+Tue Sep  9 09:49:33 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * KWidgetsAddons: new class KColumnResizer (makes it easy to
+vertically align widgets across groups)
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+- Added pkgconfig(Qt5UiTools) BuildRequires
+
+---

Old:

  kwidgetsaddons-5.1.0.tar.xz

New:

  kwidgetsaddons-5.2.0.tar.xz



Other differences:
--
++ kwidgetsaddons.spec ++
--- /var/tmp/diff_new_pack.tDKHrM/_old  2014-09-12 17:04:38.0 +0200
+++ /var/tmp/diff_new_pack.tDKHrM/_new  2014-09-12 17:04:38.0 +0200
@@ -18,14 +18,15 @@
 
 %define lname   libKF5WidgetsAddons5
 Name:   kwidgetsaddons
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  libqt5-linguist-devel = 5.2.0
 BuildRequires:  pkgconfig(Qt5Test) = 5.2.0
+BuildRequires:  pkgconfig(Qt5UiTools) = 5.2.0
 BuildRequires:  pkgconfig(Qt5Widgets) = 5.2.0
 Summary:Large set of desktop widgets
 License:LGPL-2.1+

++ kwidgetsaddons-5.1.0.tar.xz - kwidgetsaddons-5.2.0.tar.xz ++
 1060748 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kdeclarative for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kdeclarative for openSUSE:Factory 
checked in at 2014-09-12 17:03:36

Comparing /work/SRC/openSUSE:Factory/kdeclarative (Old)
 and  /work/SRC/openSUSE:Factory/.kdeclarative.new (New)


Package is kdeclarative

Changes:

--- /work/SRC/openSUSE:Factory/kdeclarative/kdeclarative.changes
2014-08-16 15:42:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdeclarative.new/kdeclarative.changes   
2014-09-12 17:04:42.0 +0200
@@ -1,0 +2,8 @@
+Tue Sep  9 09:49:34 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * KDeclarative: added org.kde.kio component.
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kdeclarative-5.1.0.tar.xz

New:

  kdeclarative-5.2.0.tar.xz



Other differences:
--
++ kdeclarative.spec ++
--- /var/tmp/diff_new_pack.4ekTFc/_old  2014-09-12 17:04:45.0 +0200
+++ /var/tmp/diff_new_pack.4ekTFc/_new  2014-09-12 17:04:45.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Declarative5
 Name:   kdeclarative
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kconfig-devel = %{kf5_version}
 BuildRequires:  kcoreaddons-devel = %{kf5_version}

++ kdeclarative-5.1.0.tar.xz - kdeclarative-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdeclarative-5.1.0/CMakeLists.txt 
new/kdeclarative-5.2.0/CMakeLists.txt
--- old/kdeclarative-5.1.0/CMakeLists.txt   2014-08-02 11:02:41.0 
+0200
+++ new/kdeclarative-5.2.0/CMakeLists.txt   2014-09-09 01:45:17.0 
+0200
@@ -3,12 +3,12 @@
 project(KDeclarative)
 
 # Dependencies
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
 set(REQUIRED_QT_VERSION 5.2.0)
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 
 find_package(Qt5 ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Qml Quick Gui)
 include(KDEInstallDirs)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdeclarative-5.1.0/KF5DeclarativeConfig.cmake.in 
new/kdeclarative-5.2.0/KF5DeclarativeConfig.cmake.in
--- old/kdeclarative-5.1.0/KF5DeclarativeConfig.cmake.in2014-08-02 
11:02:41.0 +0200
+++ new/kdeclarative-5.2.0/KF5DeclarativeConfig.cmake.in2014-09-09 
01:45:17.0 +0200
@@ -1,9 +1,6 @@
 @PACKAGE_INIT@
 
-# Required components to use this framework
-# For example:
-# find_dependency(Qt5Widgets @REQUIRED_QT_VERSION@)
-
+find_dependency(Qt5Qml @REQUIRED_QT_VERSION@)
 find_dependency(KF5KIO @KF5_DEP_VERSION@)
 
 include(${CMAKE_CURRENT_LIST_DIR}/KF5DeclarativeTargets.cmake)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdeclarative-5.1.0/README.md 
new/kdeclarative-5.2.0/README.md
--- old/kdeclarative-5.1.0/README.md2014-08-02 11:02:41.0 +0200
+++ new/kdeclarative-5.2.0/README.md2014-09-09 01:45:17.0 +0200
@@ -6,9 +6,3 @@
 
 KDeclarative provides integration of QML and KDE work spaces.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kdeclarative
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kdeclarative/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdeclarative-5.1.0/metainfo.yaml 
new/kdeclarative-5.2.0/metainfo.yaml
--- old/kdeclarative-5.1.0/metainfo.yaml2014-08-02 11:02:41.0 
+0200
+++ new/kdeclarative-5.2.0/metainfo.yaml2014-09-09 01:45:17.0 
+0200
@@ -8,3 +8,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KDeclarative
+   cmake: KF5::Declarative
+cmakename: KF5Declarative
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdeclarative-5.1.0/po/cs/kdeclarative5.po 
new/kdeclarative-5.2.0/po/cs/kdeclarative5.po
--- old/kdeclarative-5.1.0/po/cs/kdeclarative5.po   2014-08-02 
11:02:41.0 +0200
+++ new/kdeclarative-5.2.0/po/cs/kdeclarative5.po   2014-09-09 
01:45:17.0 +0200
@@ -18,6 

commit kwallet for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kwallet for openSUSE:Factory checked 
in at 2014-09-12 17:03:25

Comparing /work/SRC/openSUSE:Factory/kwallet (Old)
 and  /work/SRC/openSUSE:Factory/.kwallet.new (New)


Package is kwallet

Changes:

--- /work/SRC/openSUSE:Factory/kwallet/kwallet.changes  2014-08-16 
15:42:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.kwallet.new/kwallet.changes 2014-09-12 
17:04:29.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:30 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kwallet-5.1.0.tar.xz

New:

  kwallet-5.2.0.tar.xz



Other differences:
--
++ kwallet.spec ++
--- /var/tmp/diff_new_pack.NKwTcD/_old  2014-09-12 17:04:30.0 +0200
+++ /var/tmp/diff_new_pack.NKwTcD/_new  2014-09-12 17:04:30.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Wallet5
 Name:   kwallet
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kconfig-devel = %{kf5_version}
 BuildRequires:  kcoreaddons-devel = %{kf5_version}

++ kwallet-5.1.0.tar.xz - kwallet-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kwallet-5.1.0/CMakeLists.txt 
new/kwallet-5.2.0/CMakeLists.txt
--- old/kwallet-5.1.0/CMakeLists.txt2014-08-02 10:21:34.0 +0200
+++ new/kwallet-5.2.0/CMakeLists.txt2014-09-08 01:27:36.0 +0200
@@ -2,15 +2,15 @@
 
 project(KWallet)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} 
${CMAKE_CURRENT_SOURCE_DIR}/cmake)
 
 set(REQUIRED_QT_VERSION 5.2.0)
 find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Widgets DBus)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 include(KDEInstallDirs)
 include(KDEFrameworkCompilerSettings)
 include(KDECMakeSettings)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kwallet-5.1.0/README.md new/kwallet-5.2.0/README.md
--- old/kwallet-5.1.0/README.md 2014-08-02 10:21:34.0 +0200
+++ new/kwallet-5.2.0/README.md 2014-09-08 01:27:36.0 +0200
@@ -13,9 +13,3 @@
 `BUILD_KWALLETD` option to `OFF`.
 
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kwallet-framework
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kwallet-framework/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kwallet-5.1.0/metainfo.yaml 
new/kwallet-5.2.0/metainfo.yaml
--- old/kwallet-5.1.0/metainfo.yaml 2014-08-02 10:21:34.0 +0200
+++ new/kwallet-5.2.0/metainfo.yaml 2014-09-08 01:27:36.0 +0200
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KWallet
+   cmake: KF5::Wallet
+cmakename: KF5Wallet

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kplotting for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kplotting for openSUSE:Factory 
checked in at 2014-09-12 17:03:42

Comparing /work/SRC/openSUSE:Factory/kplotting (Old)
 and  /work/SRC/openSUSE:Factory/.kplotting.new (New)


Package is kplotting

Changes:

--- /work/SRC/openSUSE:Factory/kplotting/kplotting.changes  2014-08-16 
15:42:53.0 +0200
+++ /work/SRC/openSUSE:Factory/.kplotting.new/kplotting.changes 2014-09-12 
17:05:03.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:36 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kplotting-5.1.0.tar.xz

New:

  kplotting-5.2.0.tar.xz



Other differences:
--
++ kplotting.spec ++
--- /var/tmp/diff_new_pack.raHoi4/_old  2014-09-12 17:05:05.0 +0200
+++ /var/tmp/diff_new_pack.raHoi4/_new  2014-09-12 17:05:05.0 +0200
@@ -18,10 +18,10 @@
 
 %define lname   libKF5Plotting5
 Name:   kplotting
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  pkgconfig(Qt5Test) = 5.2.0

++ kplotting-5.1.0.tar.xz - kplotting-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kplotting-5.1.0/CMakeLists.txt 
new/kplotting-5.2.0/CMakeLists.txt
--- old/kplotting-5.1.0/CMakeLists.txt  2014-08-02 10:20:40.0 +0200
+++ new/kplotting-5.2.0/CMakeLists.txt  2014-09-08 01:26:53.0 +0200
@@ -2,7 +2,7 @@
 
 project(KPlotting)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
@@ -19,7 +19,7 @@
 include(ECMSetupVersion)
 include(ECMGenerateHeaders)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
 
 ecm_setup_version(${KF5_VERSION} VARIABLE_PREFIX KPLOTTING
 VERSION_HEADER 
${CMAKE_CURRENT_BINARY_DIR}/kplotting_version.h
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kplotting-5.1.0/README.md 
new/kplotting-5.2.0/README.md
--- old/kplotting-5.1.0/README.md   2014-08-02 10:20:40.0 +0200
+++ new/kplotting-5.2.0/README.md   2014-09-08 01:26:53.0 +0200
@@ -20,9 +20,3 @@
 of a data point.  KPlotObject also specifies the type of data to be
 plotted (POINTS or CURVE or POLYGON or LABEL).
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kplotting
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kplotting/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kplotting-5.1.0/metainfo.yaml 
new/kplotting-5.2.0/metainfo.yaml
--- old/kplotting-5.1.0/metainfo.yaml   2014-08-02 10:20:40.0 +0200
+++ new/kplotting-5.2.0/metainfo.yaml   2014-09-08 01:26:53.0 +0200
@@ -7,3 +7,7 @@
 portingAid: false
 deprecated: false
 release: true
+libraries:
+ - qmake: KPlotting
+   cmake: KF5::Plotting
+cmakename: KF5Plotting

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kauth for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kauth for openSUSE:Factory checked 
in at 2014-09-12 17:03:41

Comparing /work/SRC/openSUSE:Factory/kauth (Old)
 and  /work/SRC/openSUSE:Factory/.kauth.new (New)


Package is kauth

Changes:

--- /work/SRC/openSUSE:Factory/kauth/kauth.changes  2014-08-16 
15:42:51.0 +0200
+++ /work/SRC/openSUSE:Factory/.kauth.new/kauth.changes 2014-09-12 
17:04:59.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:36 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kauth-5.1.0.tar.xz

New:

  kauth-5.2.0.tar.xz



Other differences:
--
++ kauth.spec ++
--- /var/tmp/diff_new_pack.dNjGIA/_old  2014-09-12 17:05:02.0 +0200
+++ /var/tmp/diff_new_pack.dNjGIA/_new  2014-09-12 17:05:02.0 +0200
@@ -18,11 +18,11 @@
 
 %define lname   libKF5Auth5
 Name:   kauth
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kcoreaddons-devel = %{kf5_version}
 BuildRequires:  kf5-filesystem

++ kauth-5.1.0.tar.xz - kauth-5.2.0.tar.xz ++
 901330 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kwindowsystem for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kwindowsystem for openSUSE:Factory 
checked in at 2014-09-12 17:03:43

Comparing /work/SRC/openSUSE:Factory/kwindowsystem (Old)
 and  /work/SRC/openSUSE:Factory/.kwindowsystem.new (New)


Package is kwindowsystem

Changes:

--- /work/SRC/openSUSE:Factory/kwindowsystem/kwindowsystem.changes  
2014-08-16 15:42:54.0 +0200
+++ /work/SRC/openSUSE:Factory/.kwindowsystem.new/kwindowsystem.changes 
2014-09-12 17:05:05.0 +0200
@@ -1,0 +2,8 @@
+Tue Sep  9 09:49:37 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * KWindowSystem: New method KWindowSystem::setOnActivities
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kwindowsystem-5.1.0.tar.xz

New:

  kwindowsystem-5.2.0.tar.xz



Other differences:
--
++ kwindowsystem.spec ++
--- /var/tmp/diff_new_pack.U0pPsD/_old  2014-09-12 17:05:07.0 +0200
+++ /var/tmp/diff_new_pack.U0pPsD/_new  2014-09-12 17:05:07.0 +0200
@@ -18,10 +18,10 @@
 
 %define lname   libKF5WindowSystem5
 Name:   kwindowsystem
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  libqt5-linguist-devel = 5.2.0

++ kwindowsystem-5.1.0.tar.xz - kwindowsystem-5.2.0.tar.xz ++
 902609 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit sonnet for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package sonnet for openSUSE:Factory checked 
in at 2014-09-12 17:03:44

Comparing /work/SRC/openSUSE:Factory/sonnet (Old)
 and  /work/SRC/openSUSE:Factory/.sonnet.new (New)


Package is sonnet

Changes:

--- /work/SRC/openSUSE:Factory/sonnet/sonnet.changes2014-08-16 
15:42:57.0 +0200
+++ /work/SRC/openSUSE:Factory/.sonnet.new/sonnet.changes   2014-09-12 
17:05:08.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:38 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  sonnet-5.1.0.tar.xz

New:

  sonnet-5.2.0.tar.xz



Other differences:
--
++ sonnet.spec ++
--- /var/tmp/diff_new_pack.l8IUUS/_old  2014-09-12 17:05:10.0 +0200
+++ /var/tmp/diff_new_pack.l8IUUS/_new  2014-09-12 17:05:10.0 +0200
@@ -18,13 +18,13 @@
 
 %define sonum   5
 Name:   sonnet
-Version:5.1.0
+Version:5.2.0
 Release:0
 BuildRequires:  aspell-devel
 BuildRequires:  cmake = 2.8.12
 # Enchant plugin is currently disabled upstream
 #BuildRequires:  enchant-devel
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
 BuildRequires:  libqt5-linguist-devel = 5.2.0

++ sonnet-5.1.0.tar.xz - sonnet-5.2.0.tar.xz ++
 931307 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit kded for openSUSE:Factory

2014-09-12 Thread h_root
Hello community,

here is the log from the commit of package kded for openSUSE:Factory checked in 
at 2014-09-12 17:03:47

Comparing /work/SRC/openSUSE:Factory/kded (Old)
 and  /work/SRC/openSUSE:Factory/.kded.new (New)


Package is kded

Changes:

--- /work/SRC/openSUSE:Factory/kded/kded.changes2014-08-16 
15:43:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.kded.new/kded.changes   2014-09-12 
17:05:14.0 +0200
@@ -1,0 +2,7 @@
+Tue Sep  9 09:49:39 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 5.2.0
+  * For more details please see:
+http://kde.org/announcements/kde-frameworks-5.2.php
+
+---

Old:

  kded-5.1.0.tar.xz

New:

  kded-5.2.0.tar.xz



Other differences:
--
++ kded.spec ++
--- /var/tmp/diff_new_pack.Lrltcl/_old  2014-09-12 17:05:15.0 +0200
+++ /var/tmp/diff_new_pack.Lrltcl/_new  2014-09-12 17:05:15.0 +0200
@@ -17,11 +17,11 @@
 
 
 Name:   kded
-Version:5.1.0
+Version:5.2.0
 Release:0
 %define kf5_version %{version}
 BuildRequires:  cmake = 2.8.12
-BuildRequires:  extra-cmake-modules = 1.1.0
+BuildRequires:  extra-cmake-modules = 1.2.0
 BuildRequires:  fdupes
 BuildRequires:  kcoreaddons-devel = %{kf5_version}
 BuildRequires:  kcrash-devel = %{kf5_version}

++ kded-5.1.0.tar.xz - kded-5.2.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kded-5.1.0/CMakeLists.txt 
new/kded-5.2.0/CMakeLists.txt
--- old/kded-5.1.0/CMakeLists.txt   2014-08-02 10:17:50.0 +0200
+++ new/kded-5.2.0/CMakeLists.txt   2014-09-08 01:24:26.0 +0200
@@ -2,7 +2,7 @@
 
 project(KDED)
 
-find_package(ECM 1.1.0 REQUIRED NO_MODULE)
+find_package(ECM 1.2.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
 
 set(REQUIRED_QT_VERSION 5.2)
@@ -12,8 +12,8 @@
 include(KDEFrameworkCompilerSettings)
 include(KDECMakeSettings)
 
-set(KF5_VERSION 5.1.0) # handled by release scripts
-set(KF5_DEP_VERSION 5.1.0) # handled by release scripts
+set(KF5_VERSION 5.2.0) # handled by release scripts
+set(KF5_DEP_VERSION 5.2.0) # handled by release scripts
 find_package(KF5Config ${KF5_DEP_VERSION} REQUIRED)
 find_package(KF5CoreAddons ${KF5_DEP_VERSION} REQUIRED)
 find_package(KF5Crash ${KF5_DEP_VERSION} REQUIRED)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kded-5.1.0/README.md new/kded-5.2.0/README.md
--- old/kded-5.1.0/README.md2014-08-02 10:17:50.0 +0200
+++ new/kded-5.2.0/README.md2014-09-08 01:24:26.0 +0200
@@ -96,9 +96,3 @@
 
 See docs/HOWTO.
 
-## Links
-
-- Home page: https://projects.kde.org/projects/frameworks/kded
-- Mailing list: https://mail.kde.org/mailman/listinfo/kde-frameworks-devel
-- IRC channel: #kde-devel on Freenode
-- Git repository: 
https://projects.kde.org/projects/frameworks/kded/repository
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kded-5.1.0/metainfo.yaml new/kded-5.2.0/metainfo.yaml
--- old/kded-5.1.0/metainfo.yaml2014-08-02 10:17:50.0 +0200
+++ new/kded-5.2.0/metainfo.yaml2014-09-08 01:24:26.0 +0200
@@ -9,3 +9,4 @@
 framework-dependencies:
 # kded depends on CMake macros provided by kinit
 - KInit
+cmakename: KDED

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



  1   2   >