commit python3-Cython for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python3-Cython for openSUSE:Factory 
checked in at 2015-08-07 00:21:46

Comparing /work/SRC/openSUSE:Factory/python3-Cython (Old)
 and  /work/SRC/openSUSE:Factory/.python3-Cython.new (New)


Package is python3-Cython

Changes:

--- /work/SRC/openSUSE:Factory/python3-Cython/python3-Cython.changes
2015-01-10 23:07:06.0 +0100
+++ /work/SRC/openSUSE:Factory/.python3-Cython.new/python3-Cython.changes   
2015-08-07 00:21:48.0 +0200
@@ -1,0 +2,102 @@
+Wed Jul 29 16:09:38 UTC 2015 - toddrme2...@gmail.com
+
+- Enable tests except on SLES 12 and openSUSE 13.2.
+
+---
+Wed Jul 29 11:47:46 UTC 2015 - toddrme2...@gmail.com
+
+- Remove unneeded numpy dependency to avoid dependency loop.
+
+---
+Tue Jul 21 07:47:31 UTC 2015 - co...@suse.com
+
+- create dummy alternative to avoid 13.1's post-build-check bug
+
+---
+Tue Jul 21 04:04:43 UTC 2015 - a...@gmx.de
+
+- specfile:
+  * fixing update_alternatives
+
+---
+Sun Jul 19 15:35:48 UTC 2015 - a...@gmx.de
+
+- specfile:  (adapted from 2.7 version)
+  * updated use of update_alternatives
+  * added dependencies needed for test gcc-c++, numpy, numpy-devel
+  * added dependency xml
+  * (tried running tests, but for some distributions one test still
+failed, so didn't enable the tests)
+
+---
+Sun Jun 21 02:42:59 UTC 2015 - a...@gmx.de
+
+- update to version 0.22.1:
+  * Crash when returning values on generator termination.
+  * In some cases, exceptions raised during internal isinstance()
+checks were not propagated.
+  * Runtime reported file paths of source files (e.g for profiling and
+tracing) are now relative to the build root directory instead of
+the main source file.
+  * Tracing exception handling code could enter the trace function
+with an active exception set.
+  * The internal generator function type was not shared across
+modules.
+  * Comparisons of (inferred) ctuples failed to compile.
+  * Closures inside of cdef functions returning void failed to
+compile.
+  * Using const C++ references in intermediate parts of longer
+expressions could fail to compile.
+  * C++ exception declarations with mapping functions could fail to
+compile when pre-declared in .pxd files.
+  * C++ compilation could fail with an ambiguity error in recent
+MacOS-X Xcode versions.
+  * C compilation could fail in pypy3.
+  * Fixed a memory leak in the compiler when compiling multiple
+modules.
+  * When compiling multiple modules, external library dependencies
+could leak into later compiler runs. Fix by Jeroen Demeyer. This
+fixes ticket 845.
+
+---
+Sat Feb 14 16:33:14 UTC 2015 - a...@gmx.de
+
+- specfile:
+  * Cython-cython in tar ball name on pypi
+  * fix update alternatives
+
+- update to version 0.22:
+  * C functions can coerce to Python functions, which allows passing
+them around as callable objects.
+  * C arrays can be assigned by value and auto-coerce from Python
+iterables and to Python lists (and tuples).
+  * Extern C functions can now be declared as cpdef to export them to
+the module's Python namespace. Extern C functions in pxd files
+export their values to their own module, iff it exists.
+  * Anonymous C tuple types can be declared as (ctype1, ctype2, ...).
+  * PEP 479: turn accidental StopIteration exceptions that exit
+generators into a RuntimeError, activated with future import
+generator_stop. See http://legacy.python.org/dev/peps/pep-0479/
+  * Looping over reversed(range()) is optimised in the same way as
+range(). Patch by Favian Contreras.
+  * Mismatching 'except' declarations on signatures in .pxd and .pyx
+files failed to produce a compile error.
+  * Failure to find any files for the path pattern(s) passed into
+cythonize() is now an error to more easily detect accidental
+typos.
+  * The logaddexp family of functions in numpy.math now has correct
+declarations.
+  * In Py2.6/7 and Py3.2, simple Cython memory views could
+accidentally be interpreted as non-contiguous by CPython, which
+could trigger a CPython bug when copying data from them, thus
+leading to data corruption. See CPython issues 12834 and 23349.
+  * Preliminary support for defining the Cython language with a formal
+grammar. To try parsing your files against this grammar, use the
+--formal_grammar directive. Experimental.
+  * _ is no longer considered a 

commit python-lxml for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-lxml for openSUSE:Factory 
checked in at 2015-08-07 00:22:38

Comparing /work/SRC/openSUSE:Factory/python-lxml (Old)
 and  /work/SRC/openSUSE:Factory/.python-lxml.new (New)


Package is python-lxml

Changes:

--- /work/SRC/openSUSE:Factory/python-lxml/python-lxml.changes  2015-04-25 
16:46:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-lxml.new/python-lxml.changes 
2015-08-07 00:22:39.0 +0200
@@ -1,0 +2,9 @@
+Mon Jul 27 19:15:25 UTC 2015 - aloi...@gmx.com
+
+- Update to version 3.4.4
+  Bugs fixed:
+  * An ElementTree compatibility test added in lxml 3.4.3 that failed in
+Python 3.4+ was removed again.
+- Aligned dependency versions with PyPI ones
+
+---

Old:

  lxml-3.4.3.tar.gz
  lxmldoc-3.4.3.pdf

New:

  lxml-3.4.4.tar.gz
  lxmldoc-3.4.4.pdf



Other differences:
--
++ python-lxml.spec ++
--- /var/tmp/diff_new_pack.snCeaL/_old  2015-08-07 00:22:40.0 +0200
+++ /var/tmp/diff_new_pack.snCeaL/_new  2015-08-07 00:22:40.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python-lxml
-Version:3.4.3
+Version:3.4.4
 Release:0
 Summary:Powerful and Pythonic XML processing library
 License:BSD-3-Clause and GPL-2.0+
@@ -27,12 +27,12 @@
 Source1:http://lxml.de/lxmldoc-%{version}.pdf
 BuildRequires:  libxml2-devel = 2.7.0
 BuildRequires:  libxslt-devel = 1.1.23
-BuildRequires:  python-Cython = 0.20
+BuildRequires:  python-Cython = 0.22.1
 BuildRequires:  python-devel
-BuildRequires:  python-setuptools
+BuildRequires:  python-setuptools = 18.0.1
 # Needed for test cases:
-BuildRequires:  python-cssselect
-Requires:   python-cssselect
+BuildRequires:  python-cssselect = 0.9.1
+Requires:   python-cssselect = 0.9.1
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if 0%{?suse_version}  0%{?suse_version} = 1110
 %{!?python_sitearch: %global python_sitearch %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib(1))}

++ lxml-3.4.3.tar.gz - lxml-3.4.4.tar.gz ++
 12695 lines of diff (skipped)

++ lxmldoc-3.4.3.pdf - lxmldoc-3.4.4.pdf ++
(binary differes)




commit python-dateutil for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-dateutil for openSUSE:Factory 
checked in at 2015-08-07 00:22:21

Comparing /work/SRC/openSUSE:Factory/python-dateutil (Old)
 and  /work/SRC/openSUSE:Factory/.python-dateutil.new (New)


Package is python-dateutil

Changes:

--- /work/SRC/openSUSE:Factory/python-dateutil/python-dateutil.changes  
2013-10-25 11:13:02.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-dateutil.new/python-dateutil.changes 
2015-08-07 00:22:23.0 +0200
@@ -1,0 +2,9 @@
+Mon Jul 27 19:01:48 UTC 2015 - aloi...@gmx.com
+
+- Update to version 2.2:
+  * Updated zoneinfo to 2013h
+  * fuzzy_with_tokens parse addon from Christopher Corley
+  * Bug with LANG=C fixed by Mike Gilbert 
+- Aligned requirement version with PyPI
+
+---

Old:

  python-dateutil-2.1.tar.gz

New:

  python-dateutil-2.2.tar.gz



Other differences:
--
++ python-dateutil.spec ++
--- /var/tmp/diff_new_pack.mFirsP/_old  2015-08-07 00:22:24.0 +0200
+++ /var/tmp/diff_new_pack.mFirsP/_new  2015-08-07 00:22:24.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-dateutil
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,15 +21,15 @@
 Summary:A Python Datetime Library
 License:BSD-3-Clause
 Group:  Development/Libraries/Python
-Version:2.1
+Version:2.2
 Release:0
 Source0:
http://pypi.python.org/packages/source/p/%{name}/%{name}-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://labix.org/python-dateutil
 BuildRequires:  python-devel
-BuildRequires:  python-setuptools
-BuildRequires:  python-six
-Requires:   python-six
+BuildRequires:  python-setuptools = 18.0.1
+BuildRequires:  python-six = 1.9.0
+Requires:   python-six = 1.9.0
 %if 0%{?suse_version} = 1110
 %{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print(get_python_lib()))}
 %else

++ python-dateutil-2.1.tar.gz - python-dateutil-2.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-dateutil-2.1/NEWS new/python-dateutil-2.2/NEWS
--- old/python-dateutil-2.1/NEWS2012-03-28 17:57:55.0 +0200
+++ new/python-dateutil-2.2/NEWS2013-10-31 15:00:03.0 +0100
@@ -1,3 +1,12 @@
+Version 2.2
+---
+
+- Updated zoneinfo to 2013h
+
+- fuzzy_with_tokens parse addon from Christopher Corley
+
+- Bug with LANG=C fixed by Mike Gilbert
+
 Version 2.1
 ---
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-dateutil-2.1/PKG-INFO 
new/python-dateutil-2.2/PKG-INFO
--- old/python-dateutil-2.1/PKG-INFO2012-03-28 18:03:08.0 +0200
+++ new/python-dateutil-2.2/PKG-INFO2013-11-01 09:33:53.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: python-dateutil
-Version: 2.1
+Version: 2.2
 Summary: Extensions to the standard Python datetime module
 Home-page: http://labix.org/python-dateutil
 Author: Tomi Pievilaeinen
@@ -10,4 +10,15 @@
 datetime module available in the Python standard library.
 
 Platform: UNKNOWN
+Classifier: Development Status :: 5 - Production/Stable
+Classifier: Intended Audience :: Developers
+Classifier: License :: OSI Approved :: BSD License
+Classifier: Programming Language :: Python
+Classifier: Programming Language :: Python :: 2
+Classifier: Programming Language :: Python :: 2.6
+Classifier: Programming Language :: Python :: 2.7
+Classifier: Programming Language :: Python :: 3
+Classifier: Programming Language :: Python :: 3.2
+Classifier: Programming Language :: Python :: 3.3
+Classifier: Topic :: Software Development :: Libraries
 Requires: six
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-dateutil-2.1/README 
new/python-dateutil-2.2/README
--- old/python-dateutil-2.1/README  2012-03-28 16:25:43.0 +0200
+++ new/python-dateutil-2.2/README  2013-11-01 09:31:13.0 +0100
@@ -80,7 +80,9 @@
   * attachment:python-dateutil-1.0-1.noarch.rpm
 
 == Author ==
-The dateutil module was written by GustavoNiemeyer gust...@niemeyer.net.
+The dateutil module was written by Gustavo Niemeyer gust...@niemeyer.net and
+is currently maintained by Tomi Pieviläinen tomi.pievilai...@iki.fi. The 
latest
+code is available in 

commit python-Sphinx for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-Sphinx for openSUSE:Factory 
checked in at 2015-08-07 00:21:27

Comparing /work/SRC/openSUSE:Factory/python-Sphinx (Old)
 and  /work/SRC/openSUSE:Factory/.python-Sphinx.new (New)


Package is python-Sphinx

Changes:

--- /work/SRC/openSUSE:Factory/python-Sphinx/python-Sphinx.changes  
2015-07-18 14:39:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-Sphinx.new/python-Sphinx.changes 
2015-08-07 00:21:28.0 +0200
@@ -1,0 +2,11 @@
+Wed Jul 29 13:18:28 UTC 2015 - h...@urpla.net
+
+- Be explicit about six version requirements 
+
+---
+Mon Jul 27 09:03:41 UTC 2015 - seife+...@b1-systems.com
+
+- fix build on CentOS/RHEL by conditionalizing Recommends: tag
+- add #!BuildIgnore: texinfo to work around CentOS-7 project config
+
+---



Other differences:
--
++ python-Sphinx.spec ++
--- /var/tmp/diff_new_pack.4xoVzN/_old  2015-08-07 00:21:29.0 +0200
+++ /var/tmp/diff_new_pack.4xoVzN/_new  2015-08-07 00:21:29.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-Sphinx
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -33,7 +33,7 @@
 BuildRequires:  python-alabaster
 BuildRequires:  python-docutils = 0.7
 BuildRequires:  python-mock
-BuildRequires:  python-six
+BuildRequires:  python-six = 1.4
 BuildRequires:  python-snowballstemmer
 BuildRequires:  python-sphinx_rtd_theme
 # Testsuite requirements:
@@ -46,10 +46,15 @@
 Requires:   python-Pygments = 2.0
 Requires:   python-alabaster
 Requires:   python-docutils = 0.11
-Requires:   python-six
+Requires:   python-six = 1.4
 Requires:   python-snowballstemmer
 Requires:   python-sphinx_rtd_theme
+%if 0%{?suse_version}
 Recommends: python-rst2pdf
+%endif
+# workaround for suboptimal CentOS-7 project config
+#!BuildIgnore: texinfo
+
 Provides:   python-sphinx = %{version}
 Obsoletes:  python-sphinx  %{version}
 %if 0%{?suse_version}  0%{?suse_version} = 1110




commit python-html5lib for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-html5lib for openSUSE:Factory 
checked in at 2015-08-07 00:23:33

Comparing /work/SRC/openSUSE:Factory/python-html5lib (Old)
 and  /work/SRC/openSUSE:Factory/.python-html5lib.new (New)


Package is python-html5lib

Changes:

--- /work/SRC/openSUSE:Factory/python-html5lib/python-html5lib.changes  
2015-07-28 11:41:43.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-html5lib.new/python-html5lib.changes 
2015-08-07 00:23:34.0 +0200
@@ -1,0 +2,14 @@
+Mon Aug  3 16:30:05 UTC 2015 - tbecht...@suse.com
+
+- Relax python-lxml BuildRequires and Requires. html5lib should
+  also work with older python-lxml modules.
+
+---
+Mon Jul 27 19:04:15 UTC 2015 - aloi...@gmx.com
+
+- Update to version 0.99
+  * Fix #189: fix the sanitizer to allow relative URLs again
+   (as it did prior to 0./1.0b5).
+- Aligned version requirements with PyPI
+
+---

Old:

  html5lib-0.9.tar.gz

New:

  html5lib-0.99.tar.gz



Other differences:
--
++ python-html5lib.spec ++
--- /var/tmp/diff_new_pack.OqlNpF/_old  2015-08-07 00:23:35.0 +0200
+++ /var/tmp/diff_new_pack.OqlNpF/_new  2015-08-07 00:23:35.0 +0200
@@ -17,22 +17,22 @@
 
 
 Name:   python-html5lib
-Version:0.9
+Version:0.99
 Release:0
 Summary:HTML parser based on the WHAT-WG Web Applications 1
 License:MIT
 Group:  Development/Languages/Python
 Url:https://github.com/html5lib/html5lib-python
 Source: 
http://pypi.python.org/packages/source/h/html5lib/html5lib-%{version}.tar.gz
-BuildRequires:  python-Genshi
+BuildRequires:  python-Genshi = 0.7
 BuildRequires:  python-devel
 BuildRequires:  python-lxml
-BuildRequires:  python-nose
-BuildRequires:  python-setuptools
-BuildRequires:  python-six
-Requires:   python-six
+BuildRequires:  python-nose = 1.3.7
+BuildRequires:  python-setuptools = 18.0.1
+BuildRequires:  python-six = 1.9.0
+Requires:   python-six = 1.9.0
 %if 0%{?suse_version}
-Recommends: python-Genshi
+Recommends: python-Genshi = 0.7
 Recommends: python-lxml
 %endif
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ html5lib-0.9.tar.gz - html5lib-0.99.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/html5lib-0.9/CHANGES.rst 
new/html5lib-0.99/CHANGES.rst
--- old/html5lib-0.9/CHANGES.rst2015-04-30 21:55:49.0 +0200
+++ new/html5lib-0.99/CHANGES.rst   2015-07-07 03:59:29.0 +0200
@@ -1,6 +1,15 @@
 Change Log
 --
 
+0.99/1.0b7
+~~
+
+Released on July 7, 2015
+
+* Fix #189: fix the sanitizer to allow relative URLs again (as it did
+  prior to 0./1.0b5).
+
+
 0.9/1.0b6
 ~
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/html5lib-0.9/PKG-INFO 
new/html5lib-0.99/PKG-INFO
--- old/html5lib-0.9/PKG-INFO   2015-04-30 22:00:05.0 +0200
+++ new/html5lib-0.99/PKG-INFO  2015-07-07 03:59:36.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: html5lib
-Version: 0.9
+Version: 0.99
 Summary: HTML parser based on the WHATWG HTML specification
 Home-page: https://github.com/html5lib/html5lib-python
 Author: James Graham
@@ -167,6 +167,15 @@
 Change Log
 --
 
+0.99/1.0b7
+~~
+
+Released on July 7, 2015
+
+* Fix #189: fix the sanitizer to allow relative URLs again (as it did
+  prior to 0./1.0b5).
+
+
 0.9/1.0b6
 ~
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/html5lib-0.9/html5lib/__init__.py 
new/html5lib-0.99/html5lib/__init__.py
--- old/html5lib-0.9/html5lib/__init__.py   2015-04-30 22:00:02.0 
+0200
+++ new/html5lib-0.99/html5lib/__init__.py  2015-07-07 03:59:29.0 
+0200
@@ -20,4 +20,6 @@
 
 __all__ = [HTMLParser, parse, parseFragment, getTreeBuilder,
getTreeWalker, serialize]
-__version__ = 0.9
+
+# this has to be at the top level, see how setup.py parses this
+__version__ = 0.99
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/html5lib-0.9/html5lib/sanitizer.py 
new/html5lib-0.99/html5lib/sanitizer.py
--- old/html5lib-0.9/html5lib/sanitizer.py  2015-04-30 17:17:38.0 
+0200
+++ 

commit python-nose for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-nose for openSUSE:Factory 
checked in at 2015-08-07 00:22:55

Comparing /work/SRC/openSUSE:Factory/python-nose (Old)
 and  /work/SRC/openSUSE:Factory/.python-nose.new (New)


Package is python-nose

Changes:

--- /work/SRC/openSUSE:Factory/python-nose/python-nose-doc.changes  
2015-04-22 01:14:49.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-nose.new/python-nose-doc.changes 
2015-08-07 00:22:57.0 +0200
@@ -1,0 +2,8 @@
+Mon Jul 27 19:34:27 UTC 2015 - aloi...@gmx.com
+
+- Update to version 1.3.7:
+  * Fix loading packages from capitalised package on Windows
+Patch by Thomas Kluyver
+- Aligned dependency requirements with PyPI
+
+---
--- /work/SRC/openSUSE:Factory/python-nose/python-nose.changes  2015-04-22 
01:14:49.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-nose.new/python-nose.changes 
2015-08-07 00:22:57.0 +0200
@@ -1,0 +2,10 @@
+Mon Jul 27 19:33:56 UTC 2015 - aloi...@gmx.com
+
+- Update to version 1.3.7:
+  * Fix loading packages from capitalised package on Windows
+Patch by Thomas Kluyver
+- Aligned dependency requirements with PyPI
+- Dropped nose-drop-timing-dependent-tests.patch because
+  the test is already excluded upstream
+
+---

Old:

  nose-1.3.6.tar.gz
  nose-drop-timing-dependent-tests.patch

New:

  nose-1.3.7.tar.gz



Other differences:
--
++ python-nose-doc.spec ++
--- /var/tmp/diff_new_pack.md5uwo/_old  2015-08-07 00:22:58.0 +0200
+++ /var/tmp/diff_new_pack.md5uwo/_new  2015-08-07 00:22:58.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python-nose-doc
-Version:1.3.6
+Version:1.3.7
 Release:0
 Url:http://readthedocs.org/docs/nose/
 Summary:Nose extends unittest to make testing easier
@@ -25,7 +25,7 @@
 Group:  Development/Languages/Python
 Source: 
http://pypi.python.org/packages/source/n/nose/nose-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  python-Sphinx
+BuildRequires:  python-Sphinx = 1.3.1
 BuildRequires:  python-devel
 Requires:   python-nose = %{version}
 BuildArch:  noarch

++ python-nose.spec ++
--- /var/tmp/diff_new_pack.md5uwo/_old  2015-08-07 00:22:58.0 +0200
+++ /var/tmp/diff_new_pack.md5uwo/_new  2015-08-07 00:22:58.0 +0200
@@ -17,26 +17,24 @@
 
 
 Name:   python-nose
-Version:1.3.6
+Version:1.3.7
 Release:0
 Url:http://readthedocs.org/docs/nose/
 Summary:Nose extends unittest to make testing easier
 License:LGPL-2.0+
 Group:  Development/Languages/Python
 Source: 
http://pypi.python.org/packages/source/n/nose/nose-%{version}.tar.gz
-# PATCH-FIX-OPENSUSE speili...@suse.com -- Drop time-dependent tests:
-Patch0: nose-drop-timing-dependent-tests.patch
 # PATCH-FIX-OPENSUSE mj...@suse.com -- Fix skip test plugin
 # Since we are using python 2.6 we have to revert upstream commit 
 # 
https://github.com/nose-devs/nose/commit/395a1bff9919f083eba9eb45800692e8ab55728c
 Patch1: nose-fix-skip-test-plugin.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python-devel
-BuildRequires:  python-setuptools
+BuildRequires:  python-setuptools = 18.0.1
 BuildRequires:  python-xml
 #Testsuite build requirements:
-BuildRequires:  python-coverage
-Requires:   python-setuptools
+BuildRequires:  python-coverage = 3.7.1
+Requires:   python-setuptools = 18.0.1
 Requires:   python-xml
 Requires(post): update-alternatives
 Requires(postun): update-alternatives
@@ -63,7 +61,6 @@
 
 %prep
 %setup -q -n nose-%{version}
-%patch0 -p1
 %patch1 -p2
 sed -i s|man/man1|share/man/man1| setup.py # Fix man-page install path
 

++ nose-1.3.6.tar.gz - nose-1.3.7.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/nose-1.3.6/CHANGELOG new/nose-1.3.7/CHANGELOG
--- old/nose-1.3.6/CHANGELOG2015-04-04 13:45:24.0 +0200
+++ new/nose-1.3.7/CHANGELOG2015-06-02 10:39:35.0 +0200
@@ -1,3 +1,8 @@
+1.3.7
+
+- Fix loading packages from capitalised package on Windows
+  Patch by Thomas Kluyver
+
 1.3.6
 
 - Re-release of 1.3.5 with wheels fixed.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/nose-1.3.6/PKG-INFO new/nose-1.3.7/PKG-INFO
--- old/nose-1.3.6/PKG-INFO 2015-04-04 13:45:28.0 +0200
+++ new/nose-1.3.7/PKG-INFO 2015-06-02 11:07:39.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: nose

commit libreoffice-voikko for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package libreoffice-voikko for 
openSUSE:Factory checked in at 2015-08-07 00:23:52

Comparing /work/SRC/openSUSE:Factory/libreoffice-voikko (Old)
 and  /work/SRC/openSUSE:Factory/.libreoffice-voikko.new (New)


Package is libreoffice-voikko

Changes:

--- /work/SRC/openSUSE:Factory/libreoffice-voikko/libreoffice-voikko.changes
2015-01-22 21:50:24.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.libreoffice-voikko.new/libreoffice-voikko.changes   
2015-08-07 00:23:53.0 +0200
@@ -1,0 +2,6 @@
+Wed Aug  5 08:49:14 UTC 2015 - mplus...@suse.com
+
+- Add gpg signature
+- Tiny cleanup with spec-cleaner
+
+---

New:

  libreoffice-voikko-4.1.tar.gz.asc
  libreoffice-voikko.keyring



Other differences:
--
++ libreoffice-voikko.spec ++
--- /var/tmp/diff_new_pack.dHaQtM/_old  2015-08-07 00:23:54.0 +0200
+++ /var/tmp/diff_new_pack.dHaQtM/_new  2015-08-07 00:23:54.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libreoffice-voikko
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,9 @@
 License:MPL-2.0 or GPL-3.0+
 Group:  Productivity/Text/Spell
 Url:http://voikko.puimula.org/
-Source: 
http://www.puimula.org/voikko-sources/%{name}/%{name}-%{version}.tar.gz
+Source0:
http://www.puimula.org/voikko-sources/%{name}/%{name}-%{version}.tar.gz
+Source1:
http://www.puimula.org/voikko-sources/%{name}/%{name}-%{version}.tar.gz.asc
+Source2:%{name}.keyring
 BuildRequires:  gcc-c++
 BuildRequires:  java-devel
 BuildRequires:  libreoffice = 4.1




commit ha-cluster-bootstrap for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package ha-cluster-bootstrap for 
openSUSE:Factory checked in at 2015-08-07 00:23:50

Comparing /work/SRC/openSUSE:Factory/ha-cluster-bootstrap (Old)
 and  /work/SRC/openSUSE:Factory/.ha-cluster-bootstrap.new (New)


Package is ha-cluster-bootstrap

Changes:

--- 
/work/SRC/openSUSE:Factory/ha-cluster-bootstrap/ha-cluster-bootstrap.changes
2015-05-22 09:53:29.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.ha-cluster-bootstrap.new/ha-cluster-bootstrap.changes
   2015-08-07 00:23:51.0 +0200
@@ -1,0 +2,6 @@
+Mon Aug  3 13:10:19 UTC 2015 - kgronl...@suse.com
+
+- Remove admin IP suggestion as it is confusing (bsc#939351)
+- Add 0004-Remove-admin-IP-suggestion-as-it-is-confusing-bsc-93.patch 
+
+---

New:

  0004-Remove-admin-IP-suggestion-as-it-is-confusing-bsc-93.patch



Other differences:
--
++ ha-cluster-bootstrap.spec ++
--- /var/tmp/diff_new_pack.il6fbm/_old  2015-08-07 00:23:52.0 +0200
+++ /var/tmp/diff_new_pack.il6fbm/_new  2015-08-07 00:23:52.0 +0200
@@ -31,6 +31,8 @@
 Patch2: 0002-Add-administration-Virtual-IP-fate-318549.patch
 # PATCH-FIX-UPSTREAM: Only check watchdog if potentially using SBD
 Patch3: 0003-Only-check-watchdog-if-potentially-using-SBD.patch
+# PATCH-FIX-UPSTREAM: Remove admin IP suggestion as it is confusing 
(bsc#939351)
+Patch4: 0004-Remove-admin-IP-suggestion-as-it-is-confusing-bsc-93.patch
 
 Requires:   csync2
 Requires:   hawk
@@ -52,6 +54,7 @@
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 %build
 
 %install

++ 0004-Remove-admin-IP-suggestion-as-it-is-confusing-bsc-93.patch ++
From 09f54d9c58273f551f1d90eef0ca36174ed62b59 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Kristoffer=20Gr=C3=B6nlund?= k...@koru.se
Date: Mon, 3 Aug 2015 15:06:51 +0200
Subject: [PATCH] Remove admin IP suggestion as it is confusing (bsc#939351)

---
 scripts/ha-cluster-init | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/scripts/ha-cluster-init b/scripts/ha-cluster-init
index e1cd774..c983658 100755
--- a/scripts/ha-cluster-init
+++ b/scripts/ha-cluster-init
@@ -619,7 +619,7 @@ Configure Administration IP Address:
fi
 
adminaddr=$(prompt_for_string \
-   'Administration Virtual IP 
(e.g.: 192.168.1.200)' \
+   'Administration Virtual IP' \
'([0-9]+\.){3}[0-9]+' )
[ -z $adminaddr ]  error 'No value for admin address'
else
-- 
2.1.4




commit python-six for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-six for openSUSE:Factory 
checked in at 2015-08-07 00:23:42

Comparing /work/SRC/openSUSE:Factory/python-six (Old)
 and  /work/SRC/openSUSE:Factory/.python-six.new (New)


Package is python-six

Changes:

--- /work/SRC/openSUSE:Factory/python-six/python-six.changes2015-04-22 
01:14:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-six.new/python-six.changes   
2015-08-07 00:23:44.0 +0200
@@ -1,0 +2,12 @@
+Tue Aug  4 07:50:17 UTC 2015 - dims...@opensuse.org
+
+- Delete the system egg-info during pre phase: older versions of
+  the package installed it as a directory, the latest update
+  creates a file, and rpm has known issues with replacing this.
+
+---
+Wed Jul 29 13:01:56 UTC 2015 - toddrme2...@gmail.com
+
+- Make tests conditional to avoid dependency loop.
+
+---



Other differences:
--
++ python-six.spec ++
--- /var/tmp/diff_new_pack.j7LIDL/_old  2015-08-07 00:23:45.0 +0200
+++ /var/tmp/diff_new_pack.j7LIDL/_new  2015-08-07 00:23:45.0 +0200
@@ -16,6 +16,10 @@
 #
 
 
+# NOTE(saschpe): git invocation and pythonpath issues with testrepository
+# enable testing with a build conditional (off by default):
+%bcond_with test
+
 Name:   python-six
 Version:1.9.0
 Release:0
@@ -26,9 +30,11 @@
 Source: 
http://pypi.python.org/packages/source/s/six/six-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python-devel
+%if %{with test}
 # Test requirements:
 BuildRequires:  python-py
 BuildRequires:  python-pytest
+%endif
 %if 0%{?suse_version} = 1110
 BuildRequires:  python-argparse
 Requires:   python-argparse
@@ -56,8 +62,17 @@
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
 
+%if %{with test}
 %check
 python test_six.py
+%endif
+
+%pre
+# previous versions of the package installed .egg-info as a directory,
+# the new update now installs it as a file. Clean out the directory, should it 
exist.
+if [ -d %{python_sitelib}/six-%{version}-py%{py_ver}.egg-info ]; then
+  rm -rf %{python_sitelib}/six-%{version}-py%{py_ver}.egg-info
+fi
 
 %files
 %defattr(-,root,root)




commit python-pbr for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-pbr for openSUSE:Factory 
checked in at 2015-08-07 00:23:14

Comparing /work/SRC/openSUSE:Factory/python-pbr (Old)
 and  /work/SRC/openSUSE:Factory/.python-pbr.new (New)


Package is python-pbr

Changes:

New Changes file:

--- /dev/null   2015-07-22 21:25:44.928025004 +0200
+++ /work/SRC/openSUSE:Factory/.python-pbr.new/python-pbr-doc.changes   
2015-08-07 00:23:15.0 +0200
@@ -0,0 +1,4 @@
+---
+Mon Aug  3 09:46:34 UTC 2015 - toddrme2...@gmail.com
+
+- Split documentation into own package to avoid dependency loop
--- /work/SRC/openSUSE:Factory/python-pbr/python-pbr.changes2015-07-21 
13:25:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-pbr.new/python-pbr.changes   
2015-08-07 00:23:15.0 +0200
@@ -1,0 +2,15 @@
+Mon Aug  3 10:04:09 UTC 2015 - toddrme2...@gmail.com
+
+- Actually remove documentation requirements
+
+---
+Mon Aug  3 09:46:34 UTC 2015 - toddrme2...@gmail.com
+
+- Split documentation into own package to avoid dependency loop
+
+---
+Mon Jul 27 15:37:32 UTC 2015 - toddrme2...@gmail.com
+
+- Fix update-alternatives usage.
+
+---

New:

  python-pbr-doc.changes
  python-pbr-doc.spec



Other differences:
--
++ python-pbr-doc.spec ++
#
# spec file for package python-pbr-doc
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:   python-pbr-doc
Version:1.3.0
Release:0
Summary:Documentation for python-pbr
License:Apache-2.0
Group:  Development/Languages/Python
Url:http://pypi.python.org/pypi/pbr
Source: 
https://pypi.python.org/packages/source/p/pbr/pbr-%{version}.tar.gz
Source1:python-pbr-rpmlintrc
# NOTE(toabctl): this is currently in review: 
https://review.openstack.org/#/c/193462/
# needed to be abe to use pbr with newer Sphinx versions
Patch0: 0001-Remove-sphinx_config.init_values-manual-call.patch
BuildRequires:  fdupes
BuildRequires:  python-devel
# Documentation requirements:
BuildRequires:  python-Sphinx = 1.1.2
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version}  0%{?suse_version} = 1110
%{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
%else
BuildArch:  noarch
%endif

%description
This package contains documentation files for python-pbr

%prep
%setup -q -n pbr-%{version}
%patch0 -p1
# Get rid of ugly build-time deps that require network:
sed -i s/, 'sphinx\.ext\.intersphinx'// doc/source/conf.py

%build
python setup.py build_sphinx  rm doc/build/html/.buildinfo

%install
mkdir -p %{buildroot}%{_docdir}/python-pbr
cp -r doc/build/html %{buildroot}%{_docdir}/python-pbr/

%files
%defattr(-,root,root,-)
%doc LICENSE
%{_docdir}/python-pbr/

%changelog
++ python-pbr.spec ++
--- /var/tmp/diff_new_pack.qjZcaO/_old  2015-08-07 00:23:16.0 +0200
+++ /var/tmp/diff_new_pack.qjZcaO/_new  2015-08-07 00:23:16.0 +0200
@@ -35,8 +35,6 @@
 BuildRequires:  fdupes
 BuildRequires:  python-devel
 BuildRequires:  python-pip = 1.4
-# Documentation requirements:
-BuildRequires:  python-Sphinx = 1.1.2
 # Test requirements:
 %if %{with test}
 #BuildRequires:  python-coverage = 3.6
@@ -69,14 +67,6 @@
 files and generate AUTHORS and ChangeLog file all from git
 information.
 
-%package doc
-Summary:Python Build Reasonableness documentation
-Group:  Development/Languages/Python
-Requires:   %{name} = %{version}
-
-%description doc
-This package contains documentation files for %{name}.
-
 %prep
 %setup -q -n pbr-%{version}
 %patch0 -p1
@@ -85,14 +75,14 @@
 
 %build
 python setup.py build
-python setup.py build_sphinx  rm doc/build/html/.buildinfo
 
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
 mkdir -p 

commit python-pbr-doc for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-pbr-doc for openSUSE:Factory 
checked in at 2015-08-07 00:23:20

Comparing /work/SRC/openSUSE:Factory/python-pbr-doc (Old)
 and  /work/SRC/openSUSE:Factory/.python-pbr-doc.new (New)


Package is python-pbr-doc

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _link



Other differences:
--
++ _link ++
link package=python-pbr cicount=copy /


commit python-mock for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-mock for openSUSE:Factory 
checked in at 2015-08-07 00:20:08

Comparing /work/SRC/openSUSE:Factory/python-mock (Old)
 and  /work/SRC/openSUSE:Factory/.python-mock.new (New)


Package is python-mock

Changes:

--- /work/SRC/openSUSE:Factory/python-mock/python-mock.changes  2014-02-26 
06:55:13.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-mock.new/python-mock.changes 
2015-08-07 00:20:09.0 +0200
@@ -1,0 +2,88 @@
+Mon Jul 27 11:30:53 UTC 2015 - seife+...@b1-systems.com
+
+- python-mock now requires python-pbr
+
+---
+Mon Jul 27 07:02:44 UTC 2015 - dmuel...@suse.com
+
+- update to 1.3.0:
+  * Update sync point
+  * Issue #21750: Further fixup to be styled like other mock APIs
+  * Typo fix in mock.patch
+  * Revert Issue #21750: mock_open.read_data can now be read from each 
instance, as it
+  * Add 2.6 back to classifiers
+  * Record sync point
+  * Issue #21750: mock_open.read_data can now be read from each instance, as 
it could in Python 3.3
+  * Issue #18622: unittest.mock.mock_open().reset_mock would recurse infinitely
+  * Folk should test 2.6 locally too
+  * Closes #279: setuptools.version is too new
+  * Support python 2.6
+  * Update sync point and sync docs
+  * Issue #23661: unittest.mock side_effects can now be exceptions again
+  * Abort installation if the installer is using setuptools17.1
+  * Closes #269: setup_requires pbr 1.3
+  * Closes #257: version the dependency on six
+  * Rename README.txt to README.rst
+  * Make reproducing travis behaviour somewhat easier
+  * Cleanup version number handling
+  * Overhaul docs
+  * Update docs
+  * Remove stale MANIFEST.in, ignore pbr outputs
+  * Convert to a package, use pbr, update metadata
+  * Bump versions
+  * Officially drop 2.6 support
+  * Issue #23310: Fix MagicMock's initializer to work with __methods__. 
Behavior equivalent to m.configure_mock(). Patch by Kasia Jachim
+  * Issue #23568: Add rdivmod support to MagicMock() objects
+  * Issue #23581: Add matmul support to MagicMock
+  * Issue #23326: Removed __ne__ implementations. Since fixing default __ne__ 
implementation in issue #21408 they are redundant
+  * Issue #22823: Use set literals instead of creating a set from a list. 
Fixed an output of sets in examples
+  * Closes #21270 : We now override tuple methods in mock.call objects
+  * Suppress a couple more DeprecationWarnings in the test suite
+  * Closes #21256: Printout of keyword args in deterministic order in mock 
calls
+  * Removes unused varargs and varkwargs from assert_not_called()
+  * Closes Issue 21262: New method assert_not_called for Mock
+  * Closes Issue 21238: New keyword argument `unsafe` to Mock
+  * Closes issue 21239. unittest.mock.patch.stopall() did not work 
deterministically when the same name was patched multiple times
+  * Closes Issue 21222
+  * Closes issue 17660. You no longer need to explicitly pass create=True when 
patching builtin names
+  * Issue 17826. Setting an iterable side_effect on a mock created by 
create_autospec now works
+  * Issue 20968. unittest.mock.MagicMock now supports division
+  * Issue #20189: Four additional builtin types (PyTypeObject, 
PyMethodDescr_Type, _PyMethodWrapper_Type, and PyWrapperDescr_Type) have been 
modified to provide introspection information for builtins. Also: many 
additional Lib, test suite, and Argument Clinic fixes
+  * Issue #19594: Use specific asserts in unittest tests
+  * Remove shadowed test
+  * Adjust comment
+  * Issue #19013: add a __main__ to unittest.test.testmock to ease CLI 
invocation
+  * Issue #19013: add unittest.main() epilogs to unittest.mock's own test 
modules
+  * Process DEFAULT values in mock side_effect that returns iterator
+  * Closes issue 17467. Add readline and readlines support to 
unittest.mock.mock_open
+  * Issue #17047: remove doubled words added in 3.3 as reported by Serhiy 
Storchaka and Matthew Barnett
+  * Issue #17015: When it has a spec, a Mock object now inspects its signature 
when matching calls, so that arguments can be matched positionally or by name
+  * Closes issue 15323. Improve failure message of Mock.assert_called_once_with
+  * Close #14857: fix regression in references to PEP 3135 implicit __class__ 
closure variable. Reopens issue #12370, but also updates unittest.mock to 
workaround that issue
+  * Remove incorrect comment
+  * Closes issue 14634. unittest.mock.create_autospec now supports keyword 
only arguments
+  * unittest.mock: removed another bit of Python 2 only code
+  * Adding unittest.mock documentation
+  * unittest.mock: remove another piece of Python 2 specific code
+  * Remove more Python 2 code from unittest.mock (obsolete function attributes)
+  * Support subclassing 

commit python3-pbr for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python3-pbr for openSUSE:Factory 
checked in at 2015-08-07 00:20:24

Comparing /work/SRC/openSUSE:Factory/python3-pbr (Old)
 and  /work/SRC/openSUSE:Factory/.python3-pbr.new (New)


Package is python3-pbr

Changes:

New Changes file:

--- /dev/null   2015-07-22 21:25:44.928025004 +0200
+++ /work/SRC/openSUSE:Factory/.python3-pbr.new/python3-pbr-doc.changes 
2015-08-07 00:20:25.0 +0200
@@ -0,0 +1,6 @@
+---
+Tue Jul 28 09:18:18 UTC 2015 - toddrme2...@gmail.com
+
+- Split documentation into separate package to avoid dependency
+  loop
+
--- /work/SRC/openSUSE:Factory/python3-pbr/python3-pbr.changes  2015-06-15 
17:50:08.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-pbr.new/python3-pbr.changes 
2015-08-07 00:20:26.0 +0200
@@ -1,0 +2,43 @@
+Tue Jul 28 10:18:51 UTC 2015 - toddrme2...@gmail.com
+
+- Don't depend on pip for python = 3.4, since it is built-in.
+
+---
+Tue Jul 28 09:18:18 UTC 2015 - toddrme2...@gmail.com
+
+- Split documentation into separate package to avoid dependency
+  loop
+
+---
+Mon Jul 27 15:35:50 UTC 2015 - toddrme2...@gmail.com
+
+- update to 1.3.0:
+  * Wrap env markers in parens
+  * Updated from global requirements
+  * Add more documentation around building docs
+  * Updated from global requirements
+  * Use string for 'OS_TEST_TIMEOUT' default
+  * Updated from global requirements
+  * This documents the use of comments that work between 2.6, 2.7 and 3.4
+- Add 0001-Remove-sphinx_config.init_values-manual-call.patch . Needed
+  for newer Sphinx versions.
+- update to 1.2.0:
+  * Strip markers from test requirements
+  * Revert Remove sphinx_config.init_values(
+- Implement update-alternatives
+  
+  ---
+Mon Jul 27 15:25:59 UTC 2015 - toddrme2...@gmail.com
+
+- update to 1.3.0
+  * Wrap env markers in parens
+  * Updated from global requirements
+  * Add more documentation around building docs
+  * Updated from global requirements
+  * Use string for 'OS_TEST_TIMEOUT' default
+  * Updated from global requirements
+  * This documents the use of comments that work between 2.6, 2.7 and 3.4
+- update to 1.2.0
+  * Strip markers from test requirements
+
+---

Old:

  pbr-1.1.1.tar.gz

New:

  0001-Remove-sphinx_config.init_values-manual-call.patch
  pbr-1.3.0.tar.gz
  python3-pbr-doc.changes
  python3-pbr-doc.spec
  python3-pbr-rpmlintrc



Other differences:
--
++ python3-pbr-doc.spec ++
#
# spec file for package python3-pbr-doc
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:   python3-pbr-doc
Version:1.3.0
Release:0
Summary:Documentation for python3-pbr
License:Apache-2.0
Group:  Development/Languages/Python
Url:http://pypi.python.org/pypi/pbr
Source: 
http://pypi.python.org/packages/source/p/pbr/pbr-%{version}.tar.gz
Source1:python3-pbr-rpmlintrc
# NOTE(toabctl): this is currently in review: 
https://review.openstack.org/#/c/193462/
# needed to be abe to use pbr with newer Sphinx versions
Patch0: 0001-Remove-sphinx_config.init_values-manual-call.patch
BuildRequires:  fdupes
BuildRequires:  python3-devel
# Documentation requirements:
BuildRequires:  python3-Sphinx = 1.1.2
BuildArch:  noarch

%description
PBR is a library to automatically do a bunch of standard
things you want in your setup.py without you having to repeat
them every time. It will set versions, process requirements
files and generate AUTHORS and ChangeLog file all from git
information.

%prep
%setup -q -n pbr-%{version}
%patch0 -p1
# Get rid of ugly build-time deps that require network:
sed -i s/, 'sphinx\.ext\.intersphinx'// doc/source/conf.py

%build
python3 setup.py build_sphinx

%install
mkdir -p %{buildroot}%{_docdir}/python3-pbr
cp -r 

commit yelp for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package yelp for openSUSE:Factory checked in 
at 2015-08-07 00:19:11

Comparing /work/SRC/openSUSE:Factory/yelp (Old)
 and  /work/SRC/openSUSE:Factory/.yelp.new (New)


Package is yelp

Changes:

--- /work/SRC/openSUSE:Factory/yelp/yelp.changes2015-05-18 
21:43:54.0 +0200
+++ /work/SRC/openSUSE:Factory/.yelp.new/yelp.changes   2015-08-07 
00:19:12.0 +0200
@@ -1,0 +2,6 @@
+Tue Aug  4 14:15:30 UTC 2015 - zai...@opensuse.org
+
+- Add yelp-not-use-active-bg-color.patch: yelp-settings: don't use
+  ACTIVE background color (bgo#749947). Patch from upstream git.
+
+---

New:

  yelp-not-use-active-bg-color.patch



Other differences:
--
++ yelp.spec ++
--- /var/tmp/diff_new_pack.lZRFPl/_old  2015-08-07 00:19:13.0 +0200
+++ /var/tmp/diff_new_pack.lZRFPl/_new  2015-08-07 00:19:13.0 +0200
@@ -28,6 +28,8 @@
 Patch0: yelp-2.13.5-use-susehelp.patch
 # PATCH-FEATURE-OPENSUSE yelp-lang-bundle.patch bnc#689979 vu...@opensuse.org 
-- Support help documents shipped in bundles
 Patch1: yelp-lang-bundle.patch
+# PATCH-FIX-UPSTREAM yelp-not-use-active-bg-color.patch bgo#749947 
zai...@opensuse.org -- yelp-settings: don't use ACTIVE background color.
+Patch2: yelp-not-use-active-bg-color.patch
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  gnome-common
@@ -88,6 +90,7 @@
 # For now we prefer to be launched in yelp, even in a KDE session.
 #patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 # needed by patch0

++ yelp-not-use-active-bg-color.patch ++
From 5e522a1e03ceb69517d4d2e6499f993e43453822 Mon Sep 17 00:00:00 2001
From: Lars Uebernickel lars.uebernic...@canonical.com
Date: Wed, 27 May 2015 11:03:15 +0200
Subject: yelp-settings: don't use ACTIVE background color

GTK_STATE_FLAG_ACTIVE is meant for depressed buttons or the currently
selected row in a list box.

It did use NORMAL prior to b6ac534.

https://bugzilla.gnome.org/show_bug.cgi?id=749947

diff --git a/libyelp/yelp-settings.c b/libyelp/yelp-settings.c
index 866cb1d..c29e7b9 100644
--- a/libyelp/yelp-settings.c
+++ b/libyelp/yelp-settings.c
@@ -897,7 +897,7 @@ gtk_theme_changed (GtkSettings  *gtk_settings,
 linkcontext = gtk_widget_get_style_context (tmplink);
 
 gtk_style_context_get_color (context, GTK_STATE_FLAG_NORMAL, text);
-gtk_style_context_get_background_color (context, GTK_STATE_FLAG_ACTIVE, 
base);
+gtk_style_context_get_background_color (context, GTK_STATE_FLAG_NORMAL, 
base);
 
 rgb_to_hsv (text, text_h, text_s, text_v);
 rgb_to_hsv (base, base_h, base_s, base_v);
-- 
cgit v0.10.2




commit libinput for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package libinput for openSUSE:Factory 
checked in at 2015-08-07 00:19:42

Comparing /work/SRC/openSUSE:Factory/libinput (Old)
 and  /work/SRC/openSUSE:Factory/.libinput.new (New)


Package is libinput

Changes:

--- /work/SRC/openSUSE:Factory/libinput/libinput.changes2015-07-19 
11:45:33.0 +0200
+++ /work/SRC/openSUSE:Factory/.libinput.new/libinput.changes   2015-08-07 
00:19:44.0 +0200
@@ -1,0 +2,34 @@
+Tue Aug  4 16:35:20 UTC 2015 - zai...@opensuse.org
+
+- Update to version 0.21.0:
+  * A new addition to the API is the configuration option to toggle
+disable-while-typing. It's still enabled by default, but can
+now be disabled for the use-cases where it is problematic
+(games, for example). The API is the usual quartett of
+configuration options:
+- libinput_device_config_dwt_is_available
+- libinput_device_config_dwt_set_enabled
+- libinput_device_config_dwt_get_enabled
+- libinput_device_config_dwt_get_default_enabled
+  * The second addition to the API is the ability to get the time
+in microseconds from an event:
+- libinput_event_gesture_get_time_usec
+- libinput_event_keyboard_get_time_usec
+- libinput_event_pointer_get_time_usec
+- libinput_event_touch_get_time_usec
+  * libinput switched internally to use µs for all timestamps which
+will help those devices that have a sampling frequency of more
+than 1000Hz.
+  * Thumb detection, added for 0.20, has seen fine-tuning to reduce
+the number of misdetection. Likewise, the gesture code has seen
+a bunch of changes to tune the reliability of gesture
+detection, especially on semi-mt touchpads.
+  * Scrolling is now more reactive too, with reduced thresholds
+before scrolling kicks in.
+  * Merged a bunch of device-specific device handling to
+work around quirks and deficiencies in some touchpad hardware.
+- Add
+  libinput-touchpad-serial-synaptics-needto-fake-new-touches.patch
+  following upstreams advice for kernel 4.1.
+
+---

Old:

  libinput-0.20.0.tar.xz
  libinput-0.20.0.tar.xz.sig

New:

  libinput-0.21.0.tar.xz
  libinput-0.21.0.tar.xz.sig
  libinput-touchpad-serial-synaptics-needto-fake-new-touches.patch



Other differences:
--
++ libinput.spec ++
--- /var/tmp/diff_new_pack.t5zH2l/_old  2015-08-07 00:19:45.0 +0200
+++ /var/tmp/diff_new_pack.t5zH2l/_new  2015-08-07 00:19:45.0 +0200
@@ -18,8 +18,8 @@
 
 Name:   libinput
 %define lname  libinput10
-%define rversion 0.20.0
-Version:0.20
+%define rversion 0.21.0
+Version:0.21
 Release:0
 Summary:Input device and event processing library
 License:MIT
@@ -33,6 +33,7 @@
 Source2:
http://freedesktop.org/software/libinput/%name-%rversion.tar.xz.sig
 Source3:baselibs.conf
 Source4:%name.keyring
+Patch1: 
libinput-touchpad-serial-synaptics-needto-fake-new-touches.patch
 #git#BuildRequires:  autoconf = 2.64
 #git#BuildRequires:  automake = 1.11
 #git#BuildRequires:  libtool = 2.2
@@ -99,6 +100,7 @@
 
 %prep
 %setup -qn %name-%rversion
+%patch -P 1 -p1
 
 %build
 if [ ! -e configure ]; then

++ libinput-0.20.0.tar.xz - libinput-0.21.0.tar.xz ++
 12947 lines of diff (skipped)

++ libinput-touchpad-serial-synaptics-needto-fake-new-touches.patch ++
From: Peter Hutterer peter.hutte...@who-t.net
References: 
http://lists.freedesktop.org/archives/wayland-devel/2015-August/023782.html

On the 4.1 kernels synaptics pretends to have 3 slots (the serial fw only does
2). This was added to avoid cursor jumps but has since been reverted for 4.2
(kernel commit dbf3c37086, 4.1.3 is still buggy). In some cases a TRIPLETAP
may be triggered without slot 2 ever activating.

While there are still those kernels out there, work around this bug by opening
a new touch point where none exists if the fake finger count exceeds the slot
count.

Reported-by: Jan Alexander Steffens jan.steffens at gmail.com
Signed-off-by: Peter Hutterer peter.hutterer at who-t.net
Tested-by: Jan Alexander Steffens jan.steffens at gmail.com
Reviewed-by: Hans de Goede hdegoede at redhat.com
---
Changes to v2:
- split out the handling instead of having a tmp state variable, see Hans'
  comments from v2

Mainly sending this to the list again so I have a link to point people to.
If you're on 4.1.x add this patch to your distribution package.

 src/evdev-mt-touchpad.c | 22 --
 1 file changed, 16 insertions(+), 6 deletions(-)

diff --git a/src/evdev-mt-touchpad.c b/src/evdev-mt-touchpad.c
index a683d9a..5ef03d5 100644
--- a/src/evdev-mt-touchpad.c

commit glusterfs for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package glusterfs for openSUSE:Factory 
checked in at 2015-08-07 00:19:50

Comparing /work/SRC/openSUSE:Factory/glusterfs (Old)
 and  /work/SRC/openSUSE:Factory/.glusterfs.new (New)


Package is glusterfs

Changes:

--- /work/SRC/openSUSE:Factory/glusterfs/glusterfs.changes  2015-04-10 
10:20:48.0 +0200
+++ /work/SRC/openSUSE:Factory/.glusterfs.new/glusterfs.changes 2015-08-07 
00:19:51.0 +0200
@@ -1,0 +2,7 @@
+Tue Aug  4 19:07:46 UTC 2015 - sco...@free.fr
+
+- Update to version 3.6.4 
+  * No ChangeLog available
+- Fix Url
+
+---

Old:

  glusterfs-3.6.2.tar.gz

New:

  glusterfs-3.6.4.tar.gz



Other differences:
--
++ glusterfs.spec ++
--- /var/tmp/diff_new_pack.dtilFL/_old  2015-08-07 00:19:52.0 +0200
+++ /var/tmp/diff_new_pack.dtilFL/_new  2015-08-07 00:19:52.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package glusterfs
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,12 +17,12 @@
 
 
 Name:   glusterfs
-Version:3.6.2
+Version:3.6.4
 Release:0
 Summary:Aggregating distributed file system
 License:GPL-2.0 or LGPL-3.0+
 Group:  System/Filesystems
-Url:http://gluster.org/
+Url:http://www.gluster.org/
 
 #Git-Clone:git://github.com/gluster/glusterfs
 #Git-Clone:git://github.com/fvzwieten/lsgvt

++ glusterfs-3.6.2.tar.gz - glusterfs-3.6.4.tar.gz ++
 21650 lines of diff (skipped)




commit tiff for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package tiff for openSUSE:Factory checked in 
at 2015-08-07 00:18:50

Comparing /work/SRC/openSUSE:Factory/tiff (Old)
 and  /work/SRC/openSUSE:Factory/.tiff.new (New)


Package is tiff

Changes:

--- /work/SRC/openSUSE:Factory/tiff/tiff.changes2015-07-05 
17:55:36.0 +0200
+++ /work/SRC/openSUSE:Factory/.tiff.new/tiff.changes   2015-08-07 
00:18:52.0 +0200
@@ -1,0 +2,5 @@
+Tue Aug  4 08:17:35 UTC 2015 - kstreit...@suse.com
+
+- use spec-cleaner
+
+---



Other differences:
--
++ tiff.spec ++
--- /var/tmp/diff_new_pack.MBPR3V/_old  2015-08-07 00:18:53.0 +0200
+++ /var/tmp/diff_new_pack.MBPR3V/_new  2015-08-07 00:18:53.0 +0200
@@ -17,9 +17,26 @@
 
 
 Name:   tiff
+Version:4.0.4
+Release:0
+Summary:Tools for Converting from and to the Tiff Format
+License:HPND
+Group:  Productivity/Graphics/Convertors
+Url:http://www.remotesensing.org/libtiff
+Source: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
+Source2:README.SUSE
+Source3:baselibs.conf
+Patch0: tiff-4.0.3-seek.patch
+# http://bugzilla.maptools.org/show_bug.cgi?id=2442
+Patch1: tiff-4.0.3-compress-warning.patch
 BuildRequires:  gcc-c++
 BuildRequires:  libjpeg-devel
 BuildRequires:  libtool
+BuildRequires:  zlib-devel
+# FYI: this issue is solved another way
+# http://bugzilla.maptools.org/show_bug.cgi?id=1985#c1
+# Patch9: tiff-%{version}-lzw-CVE-2009-2285.patch
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if 0%{?suse_version}  1030
 BuildRequires:  lzma-devel
 %endif
@@ -29,7 +46,6 @@
 %if 0%{?suse_version}  1000
 BuildRequires:  pkg-config
 %endif
-BuildRequires:  zlib-devel
 # bug437293
 %ifarch ppc64
 Obsoletes:  tiff-64bit
@@ -37,23 +53,6 @@
 %if 0%{?suse_version}  1210
 BuildRequires:  libjbig-devel
 %endif
-Version:4.0.4
-Release:0
-Summary:Tools for Converting from and to the Tiff Format
-License:HPND
-Group:  Productivity/Graphics/Convertors
-Url:http://www.remotesensing.org/libtiff
-Source: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
-Source2:README.SUSE
-Source3:baselibs.conf
-Patch0: tiff-4.0.3-seek.patch
-# http://bugzilla.maptools.org/show_bug.cgi?id=2442
-Patch1: tiff-4.0.3-compress-warning.patch
-
-# FYI: this issue is solved another way
-# http://bugzilla.maptools.org/show_bug.cgi?id=1985#c1
-# Patch9: tiff-%{version}-lzw-CVE-2009-2285.patch
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 This package contains the library and support programs for the TIFF
@@ -97,13 +96,13 @@
 %patch1 -p1
 
 %build
-CFLAGS=$RPM_OPT_FLAGS -fPIE
+CFLAGS=%{optflags} -fPIE
 %configure --disable-static --with-pic
 make %{?_smp_mflags} LDFLAGS=-pie
 
 %install
 mkdir -p %{buildroot}/{%{_mandir}/{man1,man3},usr/{bin,lib,include}}
-%makeinstall
+make DESTDIR=%{buildroot} install %{?_smp_mflags}
 for f in `find %{buildroot}/%{_mandir} -type f -print ` ; do
   if [ `wc -l $f` -eq 1 ]  grep -q ^\.so  $f ; then
 linkto=`sed -e s|^\.so || $f`
@@ -113,7 +112,7 @@
 
 cp %{SOURCE2} .
 rm -rf %{buildroot}%{_datadir}/doc/tiff*
-rm -f %{buildroot}/%{_libdir}/*.la
+find %{buildroot} -type f -name *.la -delete -print
 find html -name Makefile* | xargs rm
 
 %check
@@ -129,7 +128,7 @@
 %{_bindir}/*
 %doc html
 %doc README COPYRIGHT VERSION ChangeLog TODO RELEASE-DATE
-%doc %{_mandir}/man1/*
+%{_mandir}/man1/*
 
 %files -n libtiff5
 %defattr(-,root,root)
@@ -141,6 +140,6 @@
 %{_includedir}/*
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/*.pc
-%doc %{_mandir}/man3/*
+%{_mandir}/man3/*
 
 %changelog




commit yast2-devtools for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package yast2-devtools for openSUSE:Factory 
checked in at 2015-08-07 00:19:55

Comparing /work/SRC/openSUSE:Factory/yast2-devtools (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-devtools.new (New)


Package is yast2-devtools

Changes:

--- /work/SRC/openSUSE:Factory/yast2-devtools/yast2-devtools.changes
2015-05-23 12:45:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-devtools.new/yast2-devtools.changes   
2015-08-07 00:19:57.0 +0200
@@ -1,0 +2,14 @@
+Wed Aug  5 16:57:29 CEST 2015 - shundham...@suse.de
+
+- reasonable defaults for method and class lengths in rubocop.yml
+  (bnc#940671)
+- 3.1.38
+
+---
+Wed Aug  5 06:22:46 UTC 2015 - lsle...@suse.cz
+
+- integrate the common rubocop.yml file for the SUSE Ruby style
+  (bsc#940571)
+- 3.1.37
+
+---
@@ -5 +19 @@
-  (they cause for example rubocop check to fail)
+  (they cause for example rubocop check to fail) (bnc#940203)

Old:

  yast2-devtools-3.1.36.tar.bz2

New:

  yast2-devtools-3.1.38.tar.bz2



Other differences:
--
++ yast2-devtools.spec ++
--- /var/tmp/diff_new_pack.B8iBxK/_old  2015-08-07 00:19:58.0 +0200
+++ /var/tmp/diff_new_pack.B8iBxK/_new  2015-08-07 00:19:58.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-devtools
-Version:3.1.36
+Version:3.1.38
 Release:0
 Url:http://github.com/yast/yast-devtools
 

++ yast2-devtools-3.1.36.tar.bz2 - yast2-devtools-3.1.38.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-devtools-3.1.36/README.md 
new/yast2-devtools-3.1.38/README.md
--- old/yast2-devtools-3.1.36/README.md 2015-05-14 13:12:44.0 +0200
+++ new/yast2-devtools-3.1.38/README.md 2015-08-05 17:28:08.0 +0200
@@ -33,3 +33,8 @@
 documentation tool.
 They make sense only for a developer who is interested in generating
 new documentation.
+
+### [obs-tools](obs-tools)
+
+Tools used to manipulate with YaST repositories at [open build 
service](http://build.opensuse.org/).
+They make sense only for a developer with permissions to target repositories.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-devtools-3.1.36/obs-tools/README.md 
new/yast2-devtools-3.1.38/obs-tools/README.md
--- old/yast2-devtools-3.1.36/obs-tools/README.md   1970-01-01 
01:00:00.0 +0100
+++ new/yast2-devtools-3.1.38/obs-tools/README.md   2015-08-05 
17:28:08.0 +0200
@@ -0,0 +1,12 @@
+## OBS tools
+
+Jenkins tools are intended to help with operations
+on http://build.opensuse.org/ ( or internal instance ).
+
+They are not intended to be distributed in a RPM.
+Usage requires obs permissions for yast projects.
+If you can do your task quicker than reading the script
+then it is not the right tool for you.
+
+### opensuse42_submit.sh
+Helps with submitting from factory to openSUSE:42.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-devtools-3.1.36/obs-tools/opensuse42_submit.sh 
new/yast2-devtools-3.1.38/obs-tools/opensuse42_submit.sh
--- old/yast2-devtools-3.1.36/obs-tools/opensuse42_submit.sh1970-01-01 
01:00:00.0 +0100
+++ new/yast2-devtools-3.1.38/obs-tools/opensuse42_submit.sh2015-08-05 
17:28:08.0 +0200
@@ -0,0 +1,14 @@
+#! /bin/bash
+
+LIST=`osc list openSUSE:Factory | grep -i -e yast2 -e skelcd -e ^libstorage$ 
-e perl-bootloader -e linuxrc`
+
+for i in $LIST; do
+  # compare if something is new by comparing binaries ( as version is part of 
rpm output )
+  OS42=$(osc cat openSUSE:42 $i $i.spec 2/dev/null | grep ^Version | sed 
's/Version:[[:space:]]*//;s/#.*$//')
+  FACTORY=$(osc cat openSUSE:Factory $i $i.spec 2/dev/null | grep ^Version 
| sed 's/Version:[[:space:]]*//;s/#.*$//')
+  if [ $OS42 == $FACTORY ]; then
+ continue
+  fi
+  echo submitting $i...
+  osc sr openSUSE:Factory $i openSUSE:42 -m opensuse42_submit.sh: update of 
yast2 related package to the SLE12SP1 version
+done
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-devtools-3.1.36/package/yast2-devtools.changes 
new/yast2-devtools-3.1.38/package/yast2-devtools.changes
--- old/yast2-devtools-3.1.36/package/yast2-devtools.changes2015-05-22 
09:08:08.0 +0200
+++ new/yast2-devtools-3.1.38/package/yast2-devtools.changes2015-08-05 
17:28:08.0 +0200
@@ -1,8 +1,22 @@
 ---
+Wed Aug  5 16:57:29 CEST 2015 - shundham...@suse.de
+
+- 

commit python-setuptools for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-setuptools for 
openSUSE:Factory checked in at 2015-08-07 00:20:17

Comparing /work/SRC/openSUSE:Factory/python-setuptools (Old)
 and  /work/SRC/openSUSE:Factory/.python-setuptools.new (New)


Package is python-setuptools

Changes:

--- /work/SRC/openSUSE:Factory/python-setuptools/python-setuptools.changes  
2015-07-02 22:45:08.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-setuptools.new/python-setuptools.changes 
2015-08-07 00:20:18.0 +0200
@@ -1,0 +2,12 @@
+Mon Jul 20 19:39:31 UTC 2015 - dmuel...@suse.com
+
+- update to 18.0.1:
+  * Issue #401: Fix failure in test suite.
+  * Dropped support for builds with Pyrex. Only Cython is supported.
+  * Issue #288: Detect Cython later in the build process, after
+``setup_requires`` dependencies are resolved.
+  * Issue #396: Fixed test failure on OS X.
+  * Pull Request #136: Remove excessive quoting from shebang headers
+for Jython.
+
+---

Old:

  setuptools-17.1.1.tar.gz

New:

  setuptools-18.0.1.tar.gz



Other differences:
--
++ python-setuptools.spec ++
--- /var/tmp/diff_new_pack.QJvkR5/_old  2015-08-07 00:20:19.0 +0200
+++ /var/tmp/diff_new_pack.QJvkR5/_new  2015-08-07 00:20:19.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python-setuptools
-Version:17.1.1
+Version:18.0.1
 Release:0
 Url:http://pypi.python.org/pypi/setuptools
 Summary:Easily download, build, install, upgrade, and uninstall Python 
packages
@@ -65,6 +65,7 @@
 find . -type f -name *.orig -delete
 
 %build
+chmod -x *txt
 python setup.py build
 
 %install

++ setuptools-17.1.1.tar.gz - setuptools-18.0.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools-17.1.1/CHANGES.txt 
new/setuptools-18.0.1/CHANGES.txt
--- old/setuptools-17.1.1/CHANGES.txt   2015-06-08 19:28:47.0 +0200
+++ new/setuptools-18.0.1/CHANGES.txt   2015-06-24 22:58:42.0 +0200
@@ -3,6 +3,38 @@
 ===
 
 --
+18.0.1
+--
+
+* Issue #401: Fix failure in test suite.
+
+
+18.0
+
+
+* Dropped support for builds with Pyrex. Only Cython is supported.
+* Issue #288: Detect Cython later in the build process, after
+  ``setup_requires`` dependencies are resolved.
+  Projects backed by Cython can now be readily built
+  with a ``setup_requires`` dependency. For example::
+
+ext = setuptools.Extension('mylib', ['src/CythonStuff.pyx', 
'src/CStuff.c'])
+setuptools.setup(
+...
+ext_modules=[ext],
+setup_requires=['cython'],
+)
+
+  For compatibility with older versions of setuptools, packagers should
+  still include ``src/CythonMod.c`` in the source distributions or
+  require that Cython be present before building source distributions.
+  However, for systems with this build of setuptools, Cython will be
+  downloaded on demand.
+* Issue #396: Fixed test failure on OS X.
+* Pull Request #136: Remove excessive quoting from shebang headers
+  for Jython.
+
+--
 17.1.1
 --
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools-17.1.1/PKG-INFO 
new/setuptools-18.0.1/PKG-INFO
--- old/setuptools-17.1.1/PKG-INFO  2015-06-08 19:36:29.0 +0200
+++ new/setuptools-18.0.1/PKG-INFO  2015-06-24 22:59:54.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: setuptools
-Version: 17.1.1
+Version: 18.0.1
 Summary: Easily download, build, install, upgrade, and uninstall Python 
packages
 Home-page: https://bitbucket.org/pypa/setuptools
 Author: Python Packaging Authority
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools-17.1.1/ez_setup.py 
new/setuptools-18.0.1/ez_setup.py
--- old/setuptools-17.1.1/ez_setup.py   2015-06-08 19:36:24.0 +0200
+++ new/setuptools-18.0.1/ez_setup.py   2015-06-24 22:59:47.0 +0200
@@ -30,7 +30,7 @@
 except ImportError:
 USER_SITE = None
 
-DEFAULT_VERSION = 17.1.1
+DEFAULT_VERSION = 18.0.1
 DEFAULT_URL = https://pypi.python.org/packages/source/s/setuptools/;
 DEFAULT_SAVE_DIR = os.curdir
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools-17.1.1/setuptools/command/build_ext.py 
new/setuptools-18.0.1/setuptools/command/build_ext.py
--- old/setuptools-17.1.1/setuptools/command/build_ext.py   2015-05-10 
00:36:35.0 +0200
+++ new/setuptools-18.0.1/setuptools/command/build_ext.py   2015-06-18 
14:36:06.0 +0200
@@ -11,8 +11,8 @@
 from setuptools.extension import Library
 
 try:
-# Attempt to 

commit libqt5-qtbase for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package libqt5-qtbase for openSUSE:Factory 
checked in at 2015-08-07 00:19:29

Comparing /work/SRC/openSUSE:Factory/libqt5-qtbase (Old)
 and  /work/SRC/openSUSE:Factory/.libqt5-qtbase.new (New)


Package is libqt5-qtbase

Changes:

--- /work/SRC/openSUSE:Factory/libqt5-qtbase/libqt5-qtbase.changes  
2015-08-02 22:45:49.0 +0200
+++ /work/SRC/openSUSE:Factory/.libqt5-qtbase.new/libqt5-qtbase.changes 
2015-08-07 00:19:30.0 +0200
@@ -1,0 +2,5 @@
+Tue Aug  4 19:05:31 UTC 2015 - hrvoje.sen...@gmail.com
+
+- Update QMimeDatabase-use-QElapsedTimer.patch to latest version
+
+---



Other differences:
--
++ QMimeDatabase-use-QElapsedTimer.patch ++
--- /var/tmp/diff_new_pack.VKNKZu/_old  2015-08-07 00:19:33.0 +0200
+++ /var/tmp/diff_new_pack.VKNKZu/_new  2015-08-07 00:19:33.0 +0200
@@ -23,7 +23,7 @@
  {
 -const QDateTime now = QDateTime::currentDateTime();
 -if (m_lastCheck.isValid()  m_lastCheck.secsTo(now)  
qmime_secondsBetweenChecks)
-+if (m_lastCheck.isValid()  m_lastCheck.elapsed()  
qmime_secondsBetweenChecks)
++if (m_lastCheck.isValid()  m_lastCheck.elapsed()  
qmime_secondsBetweenChecks * 1000)
  return false;
 -m_lastCheck = now;
 +m_lastCheck.start();





commit diffstat for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package diffstat for openSUSE:Factory 
checked in at 2015-08-07 00:16:19

Comparing /work/SRC/openSUSE:Factory/diffstat (Old)
 and  /work/SRC/openSUSE:Factory/.diffstat.new (New)


Package is diffstat

Changes:

--- /work/SRC/openSUSE:Factory/diffstat/diffstat.changes2015-04-22 
01:15:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.diffstat.new/diffstat.changes   2015-08-07 
00:16:26.0 +0200
@@ -1,0 +2,8 @@
+Wed Aug  5 14:34:45 UTC 2015 - mplus...@suse.com
+
+- Update to 1.60
+  * add configure option --with-man2html
+  * update configure macros
+  * update config.guess, config.sub
+
+---

Old:

  diffstat-1.59.tgz
  diffstat-1.59.tgz.asc

New:

  diffstat-1.60.tgz
  diffstat-1.60.tgz.asc



Other differences:
--
++ diffstat.spec ++
--- /var/tmp/diff_new_pack.10qnmR/_old  2015-08-07 00:16:27.0 +0200
+++ /var/tmp/diff_new_pack.10qnmR/_new  2015-08-07 00:16:27.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   diffstat
-Version:1.59
+Version:1.60
 Release:0
 Summary:Utility That Provides Statistics Based on the Output of diff
 License:MIT

++ diffstat-1.59.tgz - diffstat-1.60.tgz ++
 7031 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/diffstat-1.59/CHANGES new/diffstat-1.60/CHANGES
--- old/diffstat-1.59/CHANGES   2014-06-05 23:09:32.0 +0200
+++ new/diffstat-1.60/CHANGES   2015-07-07 01:21:00.0 +0200
@@ -1,4 +1,11 @@
--- $Id: CHANGES,v 1.90 2014/06/05 21:09:32 tom Exp $
+-- $Id: CHANGES,v 1.91 2015/07/06 23:21:00 tom Exp $
+
+2015/07/07 (diffstat 1.60)
+   + add configure option --with-man2html
+
+   + update configure macros
+
+   + update config.guess, config.sub
 
 2014/06/05 (diffstat 1.59)
+ add -E option to filter escape-sequences, e.g., from colordiff
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/diffstat-1.59/COPYING new/diffstat-1.60/COPYING
--- old/diffstat-1.59/COPYING   2014-01-11 13:57:08.0 +0100
+++ new/diffstat-1.60/COPYING   2015-07-07 01:29:04.0 +0200
@@ -1,4 +1,4 @@
-Copyright 1994-2013,2014 by Thomas E. Dickey
+Copyright 1994-2014,2015 by Thomas E. Dickey
 All Rights Reserved.
 
 Permission to use, copy, modify, and distribute this software and its
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/diffstat-1.59/COPYING.asc new/diffstat-1.60/COPYING.asc
--- old/diffstat-1.59/COPYING.asc   2014-01-11 13:57:26.0 +0100
+++ new/diffstat-1.60/COPYING.asc   2015-07-07 01:29:25.0 +0200
@@ -2,7 +2,7 @@
 Version: GnuPG v1.4.10 (GNU/Linux)
 Comment: See http://invisible-island.net/public/public.html for info
 
-iEYEABECAAYFAlLRP7IACgkQcCNT4PfkjtvdygCfQgDoICYF7VocKEb+FJ++Glou
-R3gAoLmOq0LmlGyKr1y2oSKnyWErNqgP
-=tcQA
+iEYEABECAAYFAlWbD1EACgkQcCNT4Pfkjtta2gCeL9RsKaNoyJUWQPmHwLNHlQaX
+x0AAoLCG482y5wuQuKSbchhkaCz/YlBu
+=mgEw
 -END PGP SIGNATURE-
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/diffstat-1.59/configure.in new/diffstat-1.60/configure.in
--- old/diffstat-1.59/configure.in  2014-01-11 13:57:53.0 +0100
+++ new/diffstat-1.60/configure.in  2015-07-07 01:22:57.0 +0200
@@ -1,7 +1,7 @@
 dnl Process this file with 'autoconf' to produce a 'configure' script
-dnl $Id: configure.in,v 1.27 2014/01/11 12:57:53 tom Exp $
+dnl $Id: configure.in,v 1.28 2015/07/06 23:22:57 tom Exp $
 AC_PREREQ(2.52.20011201)
-AC_REVISION($Revision: 1.27 $)
+AC_REVISION($Revision: 1.28 $)
 AC_INIT(diffstat.c)
 AC_CONFIG_HEADER(config.h:config_h.in)
 
@@ -48,6 +48,7 @@
 
 

commit libvoikko for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package libvoikko for openSUSE:Factory 
checked in at 2015-08-07 00:16:08

Comparing /work/SRC/openSUSE:Factory/libvoikko (Old)
 and  /work/SRC/openSUSE:Factory/.libvoikko.new (New)


Package is libvoikko

Changes:

--- /work/SRC/openSUSE:Factory/libvoikko/libvoikko.changes  2014-11-24 
11:11:08.0 +0100
+++ /work/SRC/openSUSE:Factory/.libvoikko.new/libvoikko.changes 2015-08-07 
00:16:25.0 +0200
@@ -1,0 +2,5 @@
+Wed Aug  5 08:45:10 UTC 2015 - mplus...@suse.com
+
+- Add gpg signature
+
+---

New:

  libvoikko-3.7.1.tar.gz.asc
  libvoikko.keyring



Other differences:
--
++ libvoikko.spec ++
--- /var/tmp/diff_new_pack.IodP8l/_old  2015-08-07 00:16:26.0 +0200
+++ /var/tmp/diff_new_pack.IodP8l/_new  2015-08-07 00:16:26.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libvoikko
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,12 +23,14 @@
 License:GPL-2.0+
 Group:  Productivity/Text/Spell
 Url:http://voikko.puimula.org
-Source: 
http://www.puimula.org/voikko-sources/%{name}/%{name}-%{version}.tar.gz
+Source0:
http://www.puimula.org/voikko-sources/%{name}/%{name}-%{version}.tar.gz
+Source1:
http://www.puimula.org/voikko-sources/%{name}/%{name}-%{version}.tar.gz.asc
+Source2:%{name}.keyring
 Source99:   baselibs.conf
 BuildRequires:  gcc-c++
 BuildRequires:  glib2-devel
 BuildRequires:  libmalaga-devel
-BuildRequires:  pkgconfig
+BuildRequires:  pkg-config
 BuildRequires:  python
 BuildRequires:  python-xml
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -94,7 +96,7 @@
 %files -n voikkospell
 %defattr(-,root,root)
 %{_bindir}/*
-%doc %{_mandir}/man?/*.*
+%{_mandir}/man?/*.*
 
 %files devel
 %defattr(-,root,root)




commit pcsc-lite for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package pcsc-lite for openSUSE:Factory 
checked in at 2015-08-07 00:15:59

Comparing /work/SRC/openSUSE:Factory/pcsc-lite (Old)
 and  /work/SRC/openSUSE:Factory/.pcsc-lite.new (New)


Package is pcsc-lite

Changes:

--- /work/SRC/openSUSE:Factory/pcsc-lite/pcsc-lite.changes  2015-03-19 
20:43:42.0 +0100
+++ /work/SRC/openSUSE:Factory/.pcsc-lite.new/pcsc-lite.changes 2015-08-07 
00:16:23.0 +0200
@@ -1,0 +2,11 @@
+Wed Aug  5 14:00:49 UTC 2015 - w...@rosenauer.org
+
+- Updated to version 1.8.14
+  * Threading: lock the PC/SC context in a safe way
+  * Threading: lock the card context in a safe way
+  * SCardGetStatusChange(): fix card movement rare bug
+  * Use asprintf(3) instead of strlcat(3) and strlcpy(3)
+  * Allow to use pcscd in a remote session (polkit issue)
+  * Some other minor improvements and bug corrections
+
+---

Old:

  pcsc-lite-1.8.13.tar.bz2
  pcsc-lite-1.8.13.tar.bz2.asc

New:

  pcsc-lite-1.8.14.tar.bz2
  pcsc-lite-1.8.14.tar.bz2.asc



Other differences:
--
++ pcsc-lite.spec ++
--- /var/tmp/diff_new_pack.DMcNaE/_old  2015-08-07 00:16:24.0 +0200
+++ /var/tmp/diff_new_pack.DMcNaE/_new  2015-08-07 00:16:24.0 +0200
@@ -21,7 +21,7 @@
 %define USER   scard
 %define GROUP  scard
 Name:   pcsc-lite
-Version:1.8.13
+Version:1.8.14
 Release:0
 Summary:PCSC Smart Cards Library
 License:BSD-3-Clause
@@ -157,7 +157,7 @@
 mkdir -p %{buildroot}%{_localstatedir}/adm/fillup-templates
 cp %{name}.sysconfig 
%{buildroot}%{_localstatedir}/adm/fillup-templates/sysconfig.pcscd
 mkdir -p %{buildroot}%{_docdir}/%{name}
-cp -a AUTHORS ChangeLog ChangeLog.svn COPYING DRIVERS HELP NEWS README 
README.SUSE SECURITY TODO %{buildroot}%{_docdir}/%{name}
+cp -a AUTHORS ChangeLog COPYING DRIVERS HELP NEWS README README.SUSE SECURITY 
TODO %{buildroot}%{_docdir}/%{name}
 # Use socket activated pcscd by default.
 %if 0%{?suse_version}  1140
 mkdir -p %{buildroot}%{_libexecdir}/systemd/system-preset

++ pcsc-lite-1.8.13.tar.bz2 - pcsc-lite-1.8.14.tar.bz2 ++
 59668 lines of diff (skipped)




commit libreoffice for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package libreoffice for openSUSE:Factory 
checked in at 2015-08-07 00:15:38

Comparing /work/SRC/openSUSE:Factory/libreoffice (Old)
 and  /work/SRC/openSUSE:Factory/.libreoffice.new (New)


Package is libreoffice

Changes:

--- /work/SRC/openSUSE:Factory/libreoffice/libreoffice.changes  2015-08-03 
17:21:05.0 +0200
+++ /work/SRC/openSUSE:Factory/.libreoffice.new/libreoffice.changes 
2015-08-07 00:15:50.0 +0200
@@ -1,0 +2,13 @@
+Tue Aug  4 10:57:23 UTC 2015 - tchva...@suse.com
+
+- Kill branding-openSUSE, stick to TDF branding.
+
+---
+Tue Aug  4 09:19:53 UTC 2015 - tchva...@suse.com
+
+- Version bump to 5.0 rc5:
+  * Bunch of final touchups here and there
+- Remove some upstreamed patches:
+  * old-cairo.patch
+
+---

Old:

  libreoffice-5.0.0.3.tar.xz
  libreoffice-help-5.0.0.3.tar.xz
  libreoffice-translations-5.0.0.3.tar.xz
  old-cairo.patch

New:

  libreoffice-5.0.0.5.tar.xz
  libreoffice-help-5.0.0.5.tar.xz
  libreoffice-translations-5.0.0.5.tar.xz



Other differences:
--
++ libreoffice.spec ++
--- /var/tmp/diff_new_pack.hBdc1l/_old  2015-08-07 00:16:19.0 +0200
+++ /var/tmp/diff_new_pack.hBdc1l/_new  2015-08-07 00:16:19.0 +0200
@@ -65,7 +65,7 @@
 %endif
 # This is used due to the need for beta releases
 Name:   libreoffice
-Version:5.0.0.3
+Version:5.0.0.5
 Release:0
 Summary:A Free Office Suite (Framework)
 License:Apache-2.0 and Artistic-1.0 and BSD-3-Clause and BSD-4-Clause 
and GPL-2.0+ and LPPL-1.3c and LGPL-2.1+ and LGPL-3.0 and MPL-1.1 and MIT and 
SUSE-Public-Domain and W3C
@@ -168,8 +168,6 @@
 Patch5: mediawiki-no-broken-help.diff
 # PATCH-FIX-SUSE: do not declare java6 available for without system libs build
 Patch7: 0001-Make-HAVE_JAVA6-be-always-false.patch
-# PATCH-FIX-UPSTREAM: build with old sle11 cairo
-Patch8: old-cairo.patch
 # try to save space by using hardlinks
 Patch990:   install-with-hardlinks.diff
 BuildRequires:  %{name}-share-linker
@@ -374,6 +372,8 @@
 Supplements:packageand(libreoffice:branding-upstream)
 Conflicts:  otherproviders(libreoffice-branding)
 Provides:   libreoffice-branding = %{version}
+Provides:   libreoffice-branding-openSUSE = 4.0.1
+Obsoletes:  libreoffice-branding-openSUSE  4.0.1
 %if %{with noarch_subpkgs}
 BuildArch:  noarch
 %endif
@@ -973,7 +973,6 @@
 %if !%{with systemlibs}
 %patch7 -p1
 %endif
-%patch8 -p1
 %patch990 -p1
 # 256x256 icons
 tar -xjf %{SOURCE20}





















++ libreoffice-5.0.0.3.tar.xz - libreoffice-5.0.0.5.tar.xz ++
/work/SRC/openSUSE:Factory/libreoffice/libreoffice-5.0.0.3.tar.xz 
/work/SRC/openSUSE:Factory/.libreoffice.new/libreoffice-5.0.0.5.tar.xz differ: 
char 26, line 1

++ libreoffice-help-5.0.0.3.tar.xz - libreoffice-help-5.0.0.5.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libreoffice-5.0.0.3/ChangeLog-helpcontent2 
new/libreoffice-5.0.0.5/ChangeLog-helpcontent2
--- old/libreoffice-5.0.0.3/ChangeLog-helpcontent2  2015-07-10 
00:58:35.0 +0200
+++ new/libreoffice-5.0.0.5/ChangeLog-helpcontent2  2015-07-31 
02:48:25.0 +0200
@@ -1,8 +1,8 @@
-2015-07-10  Christian Lohmaier  lohmaier+libreoff...@googlemail.com  
[13e0f47b5d7b748c2f8e88083c68338c310720cf]
+2015-07-31  Christian Lohmaier  lohmaier+libreoff...@googlemail.com  
[d573f6806b0b73f142d87458bd3fd7a1dd552d95]
 
-Version 5.0.0.3, tag libreoffice-5.0.0.3
+Version 5.0.0.5, tag libreoffice-5.0.0.5
 
-Change-Id: I079d41e9ad6ad5dccadb12de32abe9a948d74162
+Change-Id: Icdb37502617876f355589a0cea1b2bde047d4e4e
 
 2015-07-10  Christian Lohmaier  lohmaier+libreoff...@googlemail.com  
[c8227a67c388586c27388d416914cdbbd52620fd]
 

++ libreoffice-translations-5.0.0.3.tar.xz - 
libreoffice-translations-5.0.0.5.tar.xz ++
/work/SRC/openSUSE:Factory/libreoffice/libreoffice-translations-5.0.0.3.tar.xz 
/work/SRC/openSUSE:Factory/.libreoffice.new/libreoffice-translations-5.0.0.5.tar.xz
 differ: char 26, line 1




commit patterns-openSUSE for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package patterns-openSUSE for 
openSUSE:Factory checked in at 2015-08-07 00:15:48

Comparing /work/SRC/openSUSE:Factory/patterns-openSUSE (Old)
 and  /work/SRC/openSUSE:Factory/.patterns-openSUSE.new (New)


Package is patterns-openSUSE

Changes:

--- /work/SRC/openSUSE:Factory/patterns-openSUSE/patterns-openSUSE.changes  
2015-07-25 07:43:15.0 +0200
+++ /work/SRC/openSUSE:Factory/.patterns-openSUSE.new/patterns-openSUSE.changes 
2015-08-07 00:16:21.0 +0200
@@ -1,0 +2,5 @@
+Tue Aug  4 19:53:35 UTC 2015 - mimi...@gmail.com
+
+- add haskell_platform pattern 
+
+---



Other differences:
--
++ patterns-openSUSE.spec ++
--- /var/tmp/diff_new_pack.EZn6Dh/_old  2015-08-07 00:16:23.0 +0200
+++ /var/tmp/diff_new_pack.EZn6Dh/_new  2015-08-07 00:16:23.0 +0200
@@ -2646,6 +2646,88 @@
 %dir /usr/share/doc/packages/patterns-openSUSE
 /usr/share/doc/packages/patterns-openSUSE/gnome_yast.txt
 
+%package haskell_platform
+%pattern_development
+Summary:Haskell Platform
+Group:  Metapackages
+Provides:   pattern() = haskell_platform
+Provides:   pattern-icon() = pattern-generic
+Provides:   pattern-order() = 3400
+Requires:   alex
+Requires:   cabal-install
+Requires:   ghc
+Requires:   ghc-Cabal-devel
+Requires:   ghc-GLURaw-devel
+Requires:   ghc-GLUT-devel
+Requires:   ghc-HTTP-devel
+Requires:   ghc-HUnit-devel
+Requires:   ghc-ObjectName-devel
+Requires:   ghc-OpenGL-devel
+Requires:   ghc-OpenGLRaw-devel
+Requires:   ghc-QuickCheck-devel
+Requires:   ghc-StateVar-devel
+Requires:   ghc-array-devel
+Requires:   ghc-async-devel
+Requires:   ghc-attoparsec-devel
+Requires:   ghc-base-devel
+Requires:   ghc-case-insensitive-devel
+# Required by plattform, but now unsupported in LTS
+# Requires:   ghc-cgi-devel
+Requires:   ghc-containers-devel
+Requires:   ghc-deepseq-devel
+Requires:   ghc-directory-devel
+Requires:   ghc-exceptions-devel
+Requires:   ghc-fgl-devel
+Requires:   ghc-filepath-devel
+Requires:   ghc-hashable-devel
+Requires:   ghc-haskell-src-devel
+Requires:   ghc-hpc-devel
+Requires:   ghc-html-devel
+Requires:   ghc-mtl-devel
+Requires:   ghc-multipart-devel
+Requires:   ghc-network-devel
+Requires:   ghc-network-uri-devel
+Requires:   ghc-old-locale-devel
+Requires:   ghc-old-time-devel
+Requires:   ghc-parallel-devel
+Requires:   ghc-parsec-devel
+Requires:   ghc-pretty-devel
+Requires:   ghc-primitive-devel
+Requires:   ghc-process-devel
+Requires:   ghc-random-devel
+Requires:   ghc-regex-base-devel
+Requires:   ghc-regex-compat-devel
+Requires:   ghc-regex-posix-devel
+Requires:   ghc-scientific-devel
+Requires:   ghc-split-devel
+Requires:   ghc-stm-devel
+Requires:   ghc-syb-devel
+Requires:   ghc-template-haskell-devel
+Requires:   ghc-text-devel
+Requires:   ghc-tf-random-devel
+Requires:   ghc-time-devel
+Requires:   ghc-transformers-compat-devel
+Requires:   ghc-transformers-devel
+Requires:   ghc-unix-devel
+Requires:   ghc-unordered-containers-devel
+Requires:   ghc-vector-devel
+Requires:   ghc-xhtml-devel
+Requires:   ghc-zlib-devel
+Requires:   happy
+Requires:   hscolour
+Recommends: ghc-mod
+Suggests:   pointfree
+Suggests:   pointful
+
+%description haskell_platform
+The Haskell Platform is the easiest way to get started with programming 
Haskell.
+It comes with all you need to get up and running. 
+Think of it as Haskell: batteries included.
+
+%files haskell_platform
+%dir /usr/share/doc/packages/patterns-openSUSE
+/usr/share/doc/packages/patterns-openSUSE/haskell_platform.txt
+
 %package imaging
 %pattern_desktopfunctions
 Summary:Graphics
@@ -7273,6 +7355,7 @@
 echo 'This file marks the pattern gnome_office_opt to be installed.'  
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_office_opt.txt
 echo 'This file marks the pattern gnome_utilities to be installed.'  
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_utilities.txt
 echo 'This file marks the pattern gnome_yast to be installed.'  
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_yast.txt
+echo 'This file marks the pattern haskell_platform to be installed.'  
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/haskell_platform.txt
 echo 'This file marks the pattern imaging to be installed.'  
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/imaging.txt
 echo 'This file marks the pattern 

commit tlp for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package tlp for openSUSE:Factory checked in 
at 2015-08-07 00:25:16

Comparing /work/SRC/openSUSE:Factory/tlp (Old)
 and  /work/SRC/openSUSE:Factory/.tlp.new (New)


Package is tlp

Changes:

--- /work/SRC/openSUSE:Factory/tlp/tlp.changes  2015-02-01 12:30:44.0 
+0100
+++ /work/SRC/openSUSE:Factory/.tlp.new/tlp.changes 2015-08-07 
00:25:18.0 +0200
@@ -1,0 +2,38 @@
+Thu Aug  6 18:03:12 UTC 2015 - sor.ale...@meowr.ru
+
+- Update to 0.8:
+  * General:
+  - TLP_DEFAULT_MODE: change default operation mode to AC when
+no power supply can be detected (concerns some desktop and
+embedded hardware only).
+  * Radio Devices:
+  - Resume: restore bluetooth state.
+  * Radio Device Wizard (tlp-rdw):
+  - Support ThinkPad OneLink Dock Basic/Pro for dock/undock
+events.
+  - Detect systemd predictable network interface names for
+WWAN.
+  * ThinkPad Battery:
+  - tpacpi-bat: new upstream version 2.2: get ASL path from
+/sys/class/power_supply/*/device/path; avoids unnecessary
+AE_NOT_FOUND kernel messages.
+  - tlp-stat:
+- Show No batteries detected.
+- Explain battery status Unknown as threshold effective.
+- Show battery cell group voltages (verbose mode, tp-smapi
+  only).
+- Show acpi-call suggestion for ThinkPad *40, *50, X1
+  models.
+  * USB:
+  - Remove USB_DRIVER_BLACKLIST.
+  * tlp-stat:
+  - Show warnings for ata errors by default.
+  * Bugfixes:
+- tlp-stat: detect kernel config with PM_RUNTIME=N.
+- tlp recalibrate: fix exitcode check.
+- USB autosuspend: write power/control if actually changing
+  only.
+- Ignore missing files in /proc/sys/fs/xfs.
+- Fix udev event processing for AC/BAT sw.
+
+---

Old:

  tlp-0.7.tar.gz

New:

  tlp-0.8.tar.gz



Other differences:
--
++ tlp.spec ++
--- /var/tmp/diff_new_pack.elNbfa/_old  2015-08-07 00:25:19.0 +0200
+++ /var/tmp/diff_new_pack.elNbfa/_new  2015-08-07 00:25:19.0 +0200
@@ -18,7 +18,7 @@
 
 %define _name   TLP
 Name:   tlp
-Version:0.7
+Version:0.8
 Release:0
 Summary:Save battery power on laptops
 License:GPL-2.0+ and GPL-3.0+
@@ -60,7 +60,6 @@
 
 %prep
 %setup -q -n %{_name}-%{version}
-gzip man/*
 
 %build
 make %{?_smp_mflags}
@@ -74,7 +73,7 @@
 
 for num in 1 8; do
 mkdir -p %{buildroot}%{_mandir}/man$num/
-install -Dm 0644 man/*.$num.gz %{buildroot}%{_mandir}/man$num/
+install -Dm 0644 man/*.$num %{buildroot}%{_mandir}/man$num/
 done
 for rc in rc%{name} rc%{name}-sleep; do
 ln -sf %{_sbindir}/service %{buildroot}%{_sbindir}/$rc
@@ -98,7 +97,6 @@
 %dir %{_sysconfdir}/acpi/
 %dir %{_sysconfdir}/acpi/events/
 %config %{_sysconfdir}/acpi/events/thinkpad-radiosw
-%config %{_sysconfdir}/bash_completion.d/%{name}
 %config(noreplace) %{_sysconfdir}/default/%{name}
 %{_sysconfdir}/acpi/thinkpad-radiosw.sh
 %{_bindir}/bluetooth
@@ -108,13 +106,16 @@
 %{_bindir}/wwan
 %{_sbindir}/*%{name}*
 %{_unitdir}/%{name}*.service
+%dir %{_datadir}/bash-completion/
+%dir %{_datadir}/bash-completion/completions/
+%{_datadir}/bash-completion/completions/%{name}
 %{_libexecdir}/%{name}-pm/
 %{_libexecdir}/pm-utils/
 %dir %{_libexecdir}/udev/
 %dir %{_libexecdir}/udev/rules.d/
 %{_libexecdir}/udev/%{name}-usb-udev
 %{_libexecdir}/udev/rules.d/85-%{name}.rules
-%{_mandir}/man*/*
+%{_mandir}/man?/*
 
 %files rdw
 %defattr(-,root,root)

++ tlp-0.7.tar.gz - tlp-0.8.tar.gz ++
 1762 lines of diff (skipped)




commit nspluginwrapper for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package nspluginwrapper for openSUSE:Factory 
checked in at 2015-08-07 00:25:08

Comparing /work/SRC/openSUSE:Factory/nspluginwrapper (Old)
 and  /work/SRC/openSUSE:Factory/.nspluginwrapper.new (New)


Package is nspluginwrapper

Changes:

--- /work/SRC/openSUSE:Factory/nspluginwrapper/nspluginwrapper.changes  
2015-08-05 19:14:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.nspluginwrapper.new/nspluginwrapper.changes 
2015-08-07 00:25:09.0 +0200
@@ -1,0 +2,5 @@
+Wed Aug  5 13:48:10 UTC 2015 - dval...@suse.com
+
+- Exclude Power architectures 
+
+---



Other differences:
--
++ nspluginwrapper.spec ++
--- /var/tmp/diff_new_pack.YZeVF1/_old  2015-08-07 00:25:10.0 +0200
+++ /var/tmp/diff_new_pack.YZeVF1/_new  2015-08-07 00:25:10.0 +0200
@@ -45,7 +45,7 @@
 # Name of platform split package, used in openSUSE BS before 11.0:
 Provides:   %{name}-i386 = %{version}
 Obsoletes:  %{name}-i386  %{version}
-ExcludeArch:s390 s390x %ix86
+ExcludeArch:s390 s390x %ix86 ppc ppc64 ppc64le
 
 %description
 nspluginwrapper is an Open Source compatibility plugin for Netscape 4




commit subversion for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package subversion for openSUSE:Factory 
checked in at 2015-08-07 00:25:00

Comparing /work/SRC/openSUSE:Factory/subversion (Old)
 and  /work/SRC/openSUSE:Factory/.subversion.new (New)


Package is subversion

Changes:

--- /work/SRC/openSUSE:Factory/subversion/subversion.changes2015-05-18 
22:23:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.subversion.new/subversion.changes   
2015-08-07 00:25:03.0 +0200
@@ -1,0 +2,39 @@
+Thu Aug  6 11:28:23 UTC 2015 - s...@elego.de
+
+- Pass --enable-broken-httpd-auth to configure. Assumes all apache2
+  packages contain security patches regardless of their version number.
+  Should fix the build on SLES12 and perhaps elsewhere.
+
+---
+Thu Aug  6 11:10:50 UTC 2015 - s...@elego.de
+
+- fix mod_authz_svn build with -Wunused-variable
+  * subversion-1.8.14-unused-var-authnrequired.patch
+
+---
+Thu Aug  6 10:48:33 UTC 2015 - s...@elego.de
+
+- Apache Subversion 1.8.14
+  This release fixes two vulnerabilities:
+  * mod_authz_svn: do not leak information in mixed anonymous/authenticated
+httpd (dav) configurations (CVE-2015-3184) bnc#939514
+  * do not leak paths that were hidden by path-based authz (CVE-2015-3187)
+bnc#939517
+  Non-security fixes:
+  * document svn:autoprops
+  * fix 'svn cp ^/A/D/H@1 ^/A' to properly create A
+  * improve conflict prompts for binary files
+  * improve performance of 'ls -v'
+  * improved Sqlite 3.8.9 query performance
+  * fixed issue #4580: 'svn -v st' on file externals reports ? for user/rev
+  * mod_dav_svn: do not ignore skel parsing errors
+  * detect invalid svndiff data earlier
+  * prevent possible repository corruption on power/disk failures
+  * fixed issue #4577: Read error with some repository nodes
+  * fixed issue #4531: server-side copy (over dav) is slow
+  * swig-pl: fix some stack memory problems
+- Refreshed patch subversion-no-build-date.patch
+- Remove obsoleted patch subversion-1.8.13-fix-sqlite-3.8.9-tests.patch
+- Add patch subversion-1.8.14-httpd-version-number-detection.patch
+
+---

Old:

  subversion-1.8.13-fix-sqlite-3.8.9-tests.patch
  subversion-1.8.13.tar.bz2
  subversion-1.8.13.tar.bz2.asc

New:

  subversion-1.8.14-httpd-version-number-detection.patch
  subversion-1.8.14-unused-var-authnrequired.patch
  subversion-1.8.14.tar.bz2
  subversion-1.8.14.tar.bz2.asc



Other differences:
--
++ subversion.spec ++
--- /var/tmp/diff_new_pack.b1HkKi/_old  2015-08-07 00:25:06.0 +0200
+++ /var/tmp/diff_new_pack.b1HkKi/_new  2015-08-07 00:25:06.0 +0200
@@ -36,7 +36,7 @@
 %bcond_without python_ctypes
 %bcond_withall_regression_tests
 Name:   subversion
-Version:1.8.13
+Version:1.8.14
 Release:0
 Summary:Subversion version control system
 License:Apache-2.0
@@ -71,7 +71,8 @@
 Patch43:subversion-1.8.11-swig-py-comment-2.patch
 Patch44:subversion-1.8.11-swig-py-comment-3.patch
 Patch45:subversion-1.8.11-autocheck-time.patch
-Patch46:subversion-1.8.13-fix-sqlite-3.8.9-tests.patch
+Patch46:subversion-1.8.14-httpd-version-number-detection.patch
+Patch47:subversion-1.8.14-unused-var-authnrequired.patch
 BuildRequires:  apache2-devel
 BuildRequires:  apache2-prefork
 BuildRequires:  cyrus-sasl-devel
@@ -252,6 +253,7 @@
 %patch44 -p1
 %patch45 -p1
 %patch46 -p1
+%patch47
 
 %build
 # Re-boot strap, needed for patch37
@@ -312,7 +314,8 @@
 %endif
--disable-mod-activation \
--with-libmagic \
-   --disable-static
+   --disable-static \
+   --enable-broken-httpd-auth
 make %{?_smp_mflags}
 make doc-api %{?_smp_mflags}
 


++ subversion-1.8.14-httpd-version-number-detection.patch ++
diff -ur subversion-1.8.14.orig/build/ac-macros/apache.m4 
subversion-1.8.14/build/ac-macros/apache.m4
--- subversion-1.8.14.orig/build/ac-macros/apache.m4Mon Jul 27 02:23:40 2015
+++ subversion-1.8.14/build/ac-macros/apache.m4 Tue Jul 28 11:08:30 2015
@@ -164,7 +164,7 @@
 if ! test -e $HTTPD ; then
   HTTPD=`$APXS -q bindir`/`$APXS -q PROGNAME`
 fi
-HTTPD_VERSION=[`$HTTPD -v | $SED -e 's@^.*/\([0-9.]*\)\(.*$\)@\1@ ; 1q'`]
+HTTPD_VERSION=[`$HTTPD -v | $SED -e 's/^.*Apache\/\([0-9.]*\).*$/\1/' -e 
1q`]
 AC_ARG_ENABLE(broken-httpd-auth,
   AS_HELP_STRING([--enable-broken-httpd-auth],
  [Allow building against httpd 2.4 with broken auth]),
++ subversion-1.8.14-unused-var-authnrequired.patch ++
--- 

commit ghc-auto-update for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package ghc-auto-update for openSUSE:Factory 
checked in at 2015-08-07 00:25:17

Comparing /work/SRC/openSUSE:Factory/ghc-auto-update (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-auto-update.new (New)


Package is ghc-auto-update

Changes:

--- /work/SRC/openSUSE:Factory/ghc-auto-update/ghc-auto-update.changes  
2015-05-21 08:34:17.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-auto-update.new/ghc-auto-update.changes 
2015-08-07 00:25:19.0 +0200
@@ -1,0 +2,6 @@
+Thu Aug  6 18:53:11 UTC 2015 - mimi...@gmail.com
+
+- update to 0.1.2.2
+* Added Control.Debounce
+
+---

Old:

  auto-update-0.1.2.1.tar.gz

New:

  auto-update-0.1.2.2.tar.gz



Other differences:
--
++ ghc-auto-update.spec ++
--- /var/tmp/diff_new_pack.qBfKIi/_old  2015-08-07 00:25:20.0 +0200
+++ /var/tmp/diff_new_pack.qBfKIi/_new  2015-08-07 00:25:20.0 +0200
@@ -15,15 +15,16 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %global pkg_name auto-update
 
-Name:   ghc-%{pkg_name}
-Version:0.1.2.1
+Name:   ghc-auto-update
+Version:0.1.2.2
 Release:0
 Summary:Efficiently run periodic, on-demand actions
+License:MIT
 Group:  System/Libraries
 
-License:MIT
 Url:https://hackage.haskell.org/package/%{pkg_name}
 Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -51,31 +52,24 @@
 %prep
 %setup -q -n %{pkg_name}-%{version}
 
-
 %build
 %ghc_lib_build
 
-
 %install
 %ghc_lib_install
 
-
 %post devel
 %ghc_pkg_recache
 
-
 %postun devel
 %ghc_pkg_recache
 
-
 %files -f %{name}.files
 %defattr(-,root,root,-)
 %doc LICENSE
 
-
 %files devel -f %{name}-devel.files
 %defattr(-,root,root,-)
 %doc README.md
 
-
 %changelog

++ auto-update-0.1.2.1.tar.gz - auto-update-0.1.2.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/auto-update-0.1.2.1/README.md 
new/auto-update-0.1.2.2/README.md
--- old/auto-update-0.1.2.1/README.md   2014-12-21 10:46:55.0 +0100
+++ new/auto-update-0.1.2.2/README.md   2015-07-05 07:04:58.0 +0200
@@ -2,8 +2,8 @@
 
 A common problem is the desire to have an action run at a scheduled interval,
 but only if it is needed. For example, instead of having every web request
-result in a new 1getCurrentTime1 call, we'd like to have a single worker thread
-run every second, updating an 1IORef1. However, if the request frequency is
+result in a new `getCurrentTime` call, we'd like to have a single worker thread
+run every second, updating an `IORef`. However, if the request frequency is
 less than once per second, this is a pessimization, and worse, kills idle GC.
 
 This library allows you to define actions which will either be performed by a
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/auto-update-0.1.2.1/auto-update.cabal 
new/auto-update-0.1.2.2/auto-update.cabal
--- old/auto-update-0.1.2.1/auto-update.cabal   2014-12-21 10:46:55.0 
+0100
+++ new/auto-update-0.1.2.2/auto-update.cabal   2015-07-05 07:04:58.0 
+0200
@@ -1,5 +1,5 @@
 name:auto-update
-version: 0.1.2.1
+version: 0.1.2.2
 synopsis:Efficiently run periodic, on-demand actions
 description: API docs and the README are available at 
http://www.stackage.org/package/auto-update.
 homepage:https://github.com/yesodweb/wai




commit kye for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package kye for openSUSE:Factory checked in 
at 2015-08-07 00:25:14

Comparing /work/SRC/openSUSE:Factory/kye (Old)
 and  /work/SRC/openSUSE:Factory/.kye.new (New)


Package is kye

Changes:

--- /work/SRC/openSUSE:Factory/kye/kye.changes  2015-08-03 17:22:00.0 
+0200
+++ /work/SRC/openSUSE:Factory/.kye.new/kye.changes 2015-08-07 
00:25:16.0 +0200
@@ -1,0 +2,6 @@
+Thu Aug  6 15:25:26 UTC 2015 - jeng...@inai.de
+
+- kye-data is not required
+- Ship license file
+
+---



Other differences:
--
++ kye.spec ++
--- /var/tmp/diff_new_pack.yEKygp/_old  2015-08-07 00:25:17.0 +0200
+++ /var/tmp/diff_new_pack.yEKygp/_new  2015-08-07 00:25:17.0 +0200
@@ -33,7 +33,6 @@
 BuildRequires:  fdupes
 BuildRequires:  update-desktop-files
 %endif
-Requires:   %name-data
 Requires:   gdk-pixbuf-loader-rsvg
 Requires:   python-gtk
 %if 0%{?suse_version}  0%{?suse_version} = 1110
@@ -95,5 +94,6 @@
 %_datadir/pixmaps/kye*
 %python_sitelib/%name
 %python_sitelib/%name-%version-py%py_ver.egg-info
+%doc COPYING
 
 %changelog




commit apache2-mod_wsgi for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package apache2-mod_wsgi for 
openSUSE:Factory checked in at 2015-08-07 00:24:54

Comparing /work/SRC/openSUSE:Factory/apache2-mod_wsgi (Old)
 and  /work/SRC/openSUSE:Factory/.apache2-mod_wsgi.new (New)


Package is apache2-mod_wsgi

Changes:

--- /work/SRC/openSUSE:Factory/apache2-mod_wsgi/apache2-mod_wsgi.changes
2015-07-20 11:20:59.0 +0200
+++ /work/SRC/openSUSE:Factory/.apache2-mod_wsgi.new/apache2-mod_wsgi.changes   
2015-08-07 00:24:55.0 +0200
@@ -1,0 +2,5 @@
+Thu Aug  6 13:07:16 UTC 2015 - m...@suse.com
+
+- Build subpackage with mod_wsgi_python3 (bsc#939717)
+
+---



Other differences:
--
++ apache2-mod_wsgi.spec ++
--- /var/tmp/diff_new_pack.3cNnxk/_old  2015-08-07 00:24:56.0 +0200
+++ /var/tmp/diff_new_pack.3cNnxk/_new  2015-08-07 00:24:56.0 +0200
@@ -16,6 +16,7 @@
 #
 
 
+%define py3dir  %_builddir/py3
 %define modnamemod_wsgi
 Name:   apache2-mod_wsgi
 Version:4.4.6
@@ -52,10 +53,33 @@
 The aim of mod_wsgi is to implement a simple to use Apache module which can
 host any Python application which supports the Python WSGI interface.
 
+%package python3
+Summary:A WSGI interface for Python3 web applications in Apache
+Group:  System Environment/Libraries
+BuildRequires:  python3-devel
+%if 0%{?suse_version}
+Requires:   %{apache_mmn}
+Requires:   %{apache_suse_maintenance_mmn}
+Requires:   apache2
+%else
+Requires:   httpd
+%endif
+
+%description python3
+The mod_wsgi adapter is an Apacheache module that provides a WSGI compliant
+interface for hosting Python based web applications within Apache. The
+adapter is writtentten completely in C code against the Apache C runtime and
+for hosting WSGI applications within Apache has a lower overhead than using
+existing WSGI adapters for mod_python or CGI.
+
+
 %prep
 %setup -q -n %{modname}-%{version}
 %patch0 -p1
 
+mkdir -p %{py3dir}
+cp -a . %{py3dir}
+
 %build
 export CFLAGS=%{optflags} -fno-strict-aliasing
 %configure \
@@ -67,7 +91,23 @@
 --with-python=python
 make %{?_smp_mflags}
 
+pushd %{py3dir}
+%configure \
+%if 0%{?suse_version}
+--with-apxs=%{apache_apxs}-prefork \
+%else
+--with-apxs=%{apache_apxs} \
+%endif
+--with-python=python3
+make %{?_smp_mflags}
+popd
+
 %install
+pushd %{py3dir}
+make install DESTDIR=$RPM_BUILD_ROOT LIBEXECDIR=%{apache_libexecdir}
+mv  $RPM_BUILD_ROOT%{apache_libexecdir}/mod_wsgi{,_python3}.so
+popd
+
 make install DESTDIR=%{buildroot} LIBEXECDIR=%{apache_libexecdir}
 
 %post
@@ -86,10 +126,32 @@
 fi
 %endif
 
+%post python3
+%if 0%{?suse_version}
+if ! %{_sbindir}/a2enmod -q wsgi_python3; then
+  %{_sbindir}/a2enmod wsgi_python3
+fi
+%endif
+
+%postun python3
+%if 0%{?suse_version}
+if [ $1 = 0 ]; then
+  if a2enmod -q wsgi_python3; then
+%{_sbindir}/a2enmod -d wsgi_python3
+  fi
+fi
+%endif
+
 %files
 %defattr(-,root,root)
 %doc LICENSE README.rst docs/release-notes
 %dir %{apache_libexecdir}
 %{apache_libexecdir}/%{modname}.so
 
+%files python3
+%defattr(-,root,root)
+%doc LICENSE README.rst docs/release-notes
+%dir %{apache_libexecdir}
+%{apache_libexecdir}/%{modname}_python3.so
+
 %changelog




commit fcoe-utils for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package fcoe-utils for openSUSE:Factory 
checked in at 2015-08-07 00:19:02

Comparing /work/SRC/openSUSE:Factory/fcoe-utils (Old)
 and  /work/SRC/openSUSE:Factory/.fcoe-utils.new (New)


Package is fcoe-utils

Changes:

--- /work/SRC/openSUSE:Factory/fcoe-utils/fcoe-utils.changes2014-08-06 
11:42:11.0 +0200
+++ /work/SRC/openSUSE:Factory/.fcoe-utils.new/fcoe-utils.changes   
2015-08-07 00:19:03.0 +0200
@@ -1,0 +2,53 @@
+Mon Aug  3 12:35:16 CEST 2015 - h...@suse.de
+
+- Update to version 1.0.30 (FATE#318849)
+  * Remove merged patches:
++ 0001-man-Fix-small-typo-regarding-fcf-option.patch
++ 0002-Don-t-call-AM_INIT_AUTOMAKE-twice.patch
++ 0003-fipvlan-fails-on-powerpc.patch
++ 0004-fipvlan-Only-shutdown-interfaces-if-no-vlans-are-cre.patch
++ 0005-fipvlan-start-VLAN-interface-from-netlink-handler.patch
++ 0006-fipvlan-Extract-create_missing_vlan-function-from-lo.patch
++ 0007-fipvlan-create-VLANs-from-netlink-handler.patch
++ 0008-fipvlan-Start-FCoE-from-netlink-handler.patch
++ 0009-fipvlan-Update-wait-loop-to-wait-for-VLANs.patch
++ 0010-fipvlan-Re-send-VLAN-discovery.patch
++ 0011-fipvlan-update-manpage.patch
++ 0012-fipvlan-Leave-link-up-if-requested.patch
++ 0013-fipvlan-Update-manpage-to-reflect-correct-timeout.patch
++ 0014-fipvlan-Do-not-shut-down-FCoE-connections-on-physica.patch
++ 0015-fipvlan-break-out-of-receive-loop-on-error.patch
++ 0016-fipvlan-handle-errors-from-fip-socket-creation.patch
++ 0017-fipvlan-filter-interfaces-from-rtnl_getlink.patch
++ 0018-Add-missing-DESTDIR-when-installing-bash-completion.patch
++ 0019-Fix-build-with-Wl-as-needed.patch
++ 0020-Fix-integer-formatting.patch
++ 0021-fcnsq-Fixup-help-text.patch
++ 0022-fcnsq-Fixup-64bit-integer-handling.patch
++ 0023-fcoemon-add-systemd-service-file.patch
++ 0024-fcoemon-systemd-socket-activation.patch
++ 0025-doc-Update-QUICKSTART-INSTALL-docs-for-systemd-init-.patch
++ 0026-FIPVLAN-Really-break-out-of-the-recv_loop-upon-fip_r.patch
++ 0027-man-Fix-typo-in-fcoemon-documentation.patch
++ 0032-fipvlan-Fix-crash-in-create_and_start_vlan.patch
++ 0033-fipvlan-suppress-warning-interface-already-exists.patch
++ 0034-fipvlan-do-not-crash-on-empty-MAC-address-in-lookup_.patch
+  * Add new patches from upstream:
++ 0001-fcoemon-Rework-daemonizing-and-error-handling.patch
+  * Rename patches:
++ Rename 0031-fcoemon-Fix-IEEE-state-machine.patch to
+  0002-fcoemon-fix-IEEE-state-machine.patch
++ Rename 0028-systemctl-cannot-start-fcoemon.socket.patch to
+  0003-systemctl-cannot-start-fcoemon.socket.patch
++ Rename 0029-fcoemon-Correctly-handle-options-in-the-service-file.patch to
+  0004-fcoemon-Correctly-handle-options-in-the-service-file.patch
++ Rename 0030-fcoe.service-Add-foreground-to-prevent-fcoemon-to-be.patch to
+  0005-fcoe.service-Add-foreground-to-prevent-fcoemon-to-be.patch
++ Rename 0035-fipvlan-fixup-return-value-on-error.patch to
+  0006-fipvlan-fixup-return-value-on-error.patch
++ Rename 0036-fipvlan-clean-up-state-machine-for-pfd_add.patch to
+  0007-fipvlan-clean-up-state-machine-for-pfd_add.patch
++ Rename 0037-Use-correct-socket-for-fcoemon.socket.patch to
+  0008-Use-correct-socket-for-fcoemon.socket.patch
+
+---

Old:

  0001-man-Fix-small-typo-regarding-fcf-option.patch
  0002-Don-t-call-AM_INIT_AUTOMAKE-twice.patch
  0003-fipvlan-fails-on-powerpc.patch
  0004-fipvlan-Only-shutdown-interfaces-if-no-vlans-are-cre.patch
  0005-fipvlan-start-VLAN-interface-from-netlink-handler.patch
  0006-fipvlan-Extract-create_missing_vlan-function-from-lo.patch
  0007-fipvlan-create-VLANs-from-netlink-handler.patch
  0008-fipvlan-Start-FCoE-from-netlink-handler.patch
  0009-fipvlan-Update-wait-loop-to-wait-for-VLANs.patch
  0010-fipvlan-Re-send-VLAN-discovery.patch
  0011-fipvlan-update-manpage.patch
  0012-fipvlan-Leave-link-up-if-requested.patch
  0013-fipvlan-Update-manpage-to-reflect-correct-timeout.patch
  0014-fipvlan-Do-not-shut-down-FCoE-connections-on-physica.patch
  0015-fipvlan-break-out-of-receive-loop-on-error.patch
  0016-fipvlan-handle-errors-from-fip-socket-creation.patch
  0017-fipvlan-filter-interfaces-from-rtnl_getlink.patch
  0018-Add-missing-DESTDIR-when-installing-bash-completion.patch
  0019-Fix-build-with-Wl-as-needed.patch
  0020-Fix-integer-formatting.patch
  0021-fcnsq-Fixup-help-text.patch
  0022-fcnsq-Fixup-64bit-integer-handling.patch
  0023-fcoemon-add-systemd-service-file.patch
  0024-fcoemon-systemd-socket-activation.patch
  0025-doc-Update-QUICKSTART-INSTALL-docs-for-systemd-init-.patch
  

commit libHBAAPI2 for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package libHBAAPI2 for openSUSE:Factory 
checked in at 2015-08-07 00:18:02

Comparing /work/SRC/openSUSE:Factory/libHBAAPI2 (Old)
 and  /work/SRC/openSUSE:Factory/.libHBAAPI2.new (New)


Package is libHBAAPI2

Changes:

--- /work/SRC/openSUSE:Factory/libHBAAPI2/libHBAAPI2.changes2013-12-06 
14:41:16.0 +0100
+++ /work/SRC/openSUSE:Factory/.libHBAAPI2.new/libHBAAPI2.changes   
2015-08-07 00:18:03.0 +0200
@@ -1,0 +2,8 @@
+Mon Aug  3 13:03:22 CEST 2015 - h...@suse.de
+
+- Update to v2.2.10 (FATE#318847)
+  * Merge patch with upstream:
++ Remove libHBAAPI-Add-ldl-during-link.patch
+  * Add new HBA_PORTSPEED definitions
+
+---

Old:

  libHBAAPI-Add-ldl-during-link.patch
  libHBAAPI-v2.2.9.tar.bz2

New:

  libHBAAPI-v2.2.10.tar.xz



Other differences:
--
++ libHBAAPI2.spec ++
--- /var/tmp/diff_new_pack.OlK2ly/_old  2015-08-07 00:18:04.0 +0200
+++ /var/tmp/diff_new_pack.OlK2ly/_new  2015-08-07 00:18:04.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libHBAAPI2
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,15 +17,14 @@
 
 
 Name:   libHBAAPI2
-Version:2.2.9
+Version:2.2.10
 Release:0
 Summary:SNIA HBAAPI library
 License:SUSE-SNIA-1.1
 Group:  System/Libraries
 Url:http://open-fcoe.org/libHBAAPI
-Source0:libHBAAPI-v%{version}.tar.bz2
+Source0:libHBAAPI-v%{version}.tar.xz
 Source1:SNIAv1.1.txt
-Patch0: libHBAAPI-Add-ldl-during-link.patch
 BuildRequires:  automake
 BuildRequires:  libtool
 BuildRequires:  pkg-config
@@ -45,7 +44,6 @@
 
 %prep
 %setup -n libHBAAPI-v%{version}
-%patch0 -p1
 cp %{S:1} COPYING
 
 %build




commit lensfun for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package lensfun for openSUSE:Factory checked 
in at 2015-08-07 00:18:39

Comparing /work/SRC/openSUSE:Factory/lensfun (Old)
 and  /work/SRC/openSUSE:Factory/.lensfun.new (New)


Package is lensfun

Changes:

--- /work/SRC/openSUSE:Factory/lensfun/lensfun.changes  2015-07-20 
11:19:48.0 +0200
+++ /work/SRC/openSUSE:Factory/.lensfun.new/lensfun.changes 2015-08-07 
00:18:40.0 +0200
@@ -1,0 +2,143 @@
+Mon Aug  3 19:10:08 UTC 2015 - mrueck...@suse.de
+
+- update to version 0.3.1
+  * Improved performance when used with 32-bit float image buffers.
+  * Introduced automated testing.
+  * lensfun-update-data now also works without root privileges
+  * Fixed autoscaling for panoramic and equirectangular projections
+
+
+  New interchangeable lenses:
+
+  * Canon EF 16-35mm f/4L IS USM
+  * Canon EF-S 18-55mm f/3.5-5.6 IS STM
+  * Canon Lens FL 50mm F1.4
+  * Canon FDn 50mm 1:1.4 (APS-C)
+  * Nikkor AF-S 60mm f/2.8G ED Micro
+  * Canon EF 70-210mm f/3.5-4.5 USM
+  * Canon Lens FL 135mm F3.5
+  * Canon EF 300mm f/2.8L IS II USM (also with 1.4x and 2.0x converters)
+  * Canon EF 400mm f/5.6L USM (also with 1.4x converter)
+  * Canon EF 500mm f/4L IS II USM (also with 1.4x and 2.0x converters)
+  * Cosina 19-35mm f/3.5-4.5 MC
+  * Fotasy M3517 35mm f/1.7
+  * Fujifilm TCL-X100 teleconverter (for X100/X100s cameras)
+  * Fujifilm XF 23mm f/1.4 R
+  * Fujifilm XF 60mm f/2.4 R Macro
+  * KMZ MC HELIOS-44M-4 58mm 1:2
+  * Leica DG Summilux 15mm f/1.7
+  * Lumix G Vario 12-32 f/3.5-5.6
+  * Lumix G 14mm f/2.5 II
+  * Minolta MD 35mm 1/2.8
+  * Minolta AF 35-105mm f/3.5-4.5
+  * Nikkor AF 10.5mm f/2.8G DX ED Fisheye
+  * Nikkor AF-S 18-55mm f/3.5-5.6G DX VR II
+  * Nikkor AF-S 18-300mm f/3.5-6.3G DX ED VR
+  * Nikkor AI 20mm f/3.5
+  * Nikkor AF 20-35mm f/2.8D IF
+  * Nikkor AI-S 24mm f/2.8
+  * Nikkor AF-S 24-120mm f/4G ED VR
+  * Nikkor AF 28mm f/1.4D
+  * Nikkor AF-S 28mm f/1.8G
+  * Nikkor AI-S 28mm f/2.8
+  * Nikkor AF 28-80mm f/3.3-5.6G
+  * Nikkor AF 28-200mm f/3.5-5.6G IF-ED
+  * Nikkor AI-S 35mm f/2.0
+  * Nikkor AF 60mm f/2.8D Micro
+  * Nikkor AF-S 70-300mm f/4.5-5.6G VR IF-ED
+  * Olympus M.Zuiko Digital 60mm f/2.8 Macro
+  * HD Pentax-DA 20-40mm f/2.8-4 ED Limited DC WR
+  * smc Pentax-A 28mm 1:2.8
+  * smc Pentax-DA 18-55mm f/3.5-5.6 AL II
+  * smc Pentax-DA 50mm f/1.8
+  * smc Pentax-M Macro 1:4 50mm
+  * Ricoh 50mm 1:2.0
+  * Schneider-Kreuznach Retina-Curtagon 1:4/28mm
+  * Sigma 8mm f/3.5 EX DG Circular (APS-C)
+  * Sony FE 28-70mm f/3.5-5.6 OSS
+  * Tamron SP AF 60mm f/2 Di II LD (IF) Macro
+  * Tamron SP 150-600mm f/5-6.3 Di VC USD
+  * Tokina AF 100mm f/2.8 AT-X Pro D Macro
+  * Voigtländer Skoparex 1:3,4/35
+  * Voigtländer Color-Skopar X 1:2,8/50
+  * Zenitar MC 16mm f/2.8
+  * Carl Zeiss Jena 1Q Biotar 1:2 f=58mm T
+
+  New interchangable lens cameras:
+
+  * Canon EOS 7D Mark II
+  * Canon EOS 750D
+  * Canon EOS 760D
+  * Canon EOS M2
+  * Canon EOS M3
+  * Fuji X-A2
+  * Nikon D5500
+  * Nikon D7200
+  * Nikon 1 S2
+  * Nikon 1 V3
+  * Nikon 1 J5
+  * Olympus E-5 Mark II
+  * Panasonic DMC-GH4
+  * Panasonic DMC-GF7
+  * Samsung NX1
+  * Samsung NX300M
+  * Samsung NX500
+  * Sony A5100
+
+  New compact cameras:
+
+  * Canon IXUS 220 HS (CHDK's DNGs)
+  * Canon PowerShot A4000 IS (CHDK's DNGs)
+  * Canon PowerShot G1 X Mark II
+  * Canon PowerShot S95
+  * DIJ Phantom Vision FC200
+  * Fujifilm FinePix A370
+  * Fujifilm X100T
+  * Fujifilm X30
+  * Fujifilm XQ1
+  * Olympus E-PL7
+  * Olympus Stylus 1s
+  * Panasonic FZ1000
+  * Panasonic DMC-GM5
+  * Panasonic DMC-LX100
+  * Ricoh GR
+  * Sony RX100 III
+
+  Additional/updated data for:
+
+  * Canon EF-S 10-22mm f/3.5-4.5 USM
+  * Canon TS-E 24mm f/3.5L
+  * Canon EF 24-85mm f/3.5-4.5 USM
+  * Canon EF 50mm f/1.8
+  * Canon EF 70-200mm f/4L IS USM
+  * Fujifilm XC 16-50mm f/3.5-5.6 OIS
+  * Fujifilm XC 50-230mm f/4.5-6.7 OIS
+  * Nikkor AF 24-85mm f/2.8-4D IF
+  * Nikkor AF 50mm f/1.4D
+  * Nikkor AF 50mm f/1.8D
+  * Nikkor AF-S 55-300mm f/4.5-5.6G DX ED VR
+  * Nikkor AF-S 70-200mm f/2.8G VR IF-ED
+  * Nikkor AF 70-210mm f/4-5.6
+  * Nikkor AF 80-200mm f/2.8 ED
+  * Nikkor AF 85mm f/1.8
+  * Olympus M.Zuiko Digital 25mm f/1.8
+  * Olympus M.Zuiko Digital 60mm f/2.8 Macro
+  * Olympus M.Zuiko Digital ED 75-300mm f/4.8-6.7 II
+  * smc Pentax-DA 18-55mm f/3.5-5.6 AL WR
+  * smc Pentax-M 28mm 1:3.5
+  * smc Pentax-DA 35mm f/2.4 AL
+  * smc Pentax-A 50mm f/1.7
+  * Samyang 14mm f/2.8 ED AS IF UMC
+  * Sigma 19mm f/2.8 EX DN
+  * Sigma 50-150mm f/2.8 APO EX DC OS HSM
+  * Sigma 70-200mm f/2.8 EX DG OS HSM
+  * Sigma 105mm f/2.8 EX DG OS HSM Macro
+  * Sony 50mm f/1.4
+  * Sony E 16-50mm f/3.5-5.6 OSS PZ
+
+  * Canon PowerShot A640
+  * Canon PowerShot A720
+  * Canon PowerShot SX150
+  * Canon PowerShot SX220
+

commit libhbalinux2 for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package libhbalinux2 for openSUSE:Factory 
checked in at 2015-08-07 00:18:10

Comparing /work/SRC/openSUSE:Factory/libhbalinux2 (Old)
 and  /work/SRC/openSUSE:Factory/.libhbalinux2.new (New)


Package is libhbalinux2

Changes:

--- /work/SRC/openSUSE:Factory/libhbalinux2/libhbalinux2.changes
2013-09-13 14:45:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.libhbalinux2.new/libhbalinux2.changes   
2015-08-07 00:18:11.0 +0200
@@ -1,0 +2,12 @@
+Mon Aug  3 12:55:31 CEST 2015 - h...@suse.de
+
+- Update to upstream version v1.0.17 (FATE#318847)
+  * Fixup Automake
+  * Support port speeds up to 40 Gbit
+
+---
+Wed Mar 12 11:13:17 CET 2014 - h...@suse.de
+
+- Add 'sed' to PreReq (bnc#865842)
+
+---

Old:

  libhbalinux-v1.0.16.tar.bz2

New:

  libhbalinux-1.0.17.tar.xz



Other differences:
--
++ libhbalinux2.spec ++
--- /var/tmp/diff_new_pack.hxR36S/_old  2015-08-07 00:18:12.0 +0200
+++ /var/tmp/diff_new_pack.hxR36S/_new  2015-08-07 00:18:12.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libhbalinux2
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,18 +17,19 @@
 
 
 Name:   libhbalinux2
-Version:1.0.16
+Version:1.0.17
 Release:0
 Summary:FC-HBAAPI implementation using scsi_transport_fc interfaces
 License:LGPL-2.0+
 Group:  System/Libraries
 Url:http://www.open-fcoe.org
-Source0:libhbalinux-v%{version}.tar.bz2
+Source0:libhbalinux-%{version}.tar.xz
 Patch0: libhbalinux-remove-install-data-hook
 Patch2: hbalinux-automake.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+PreReq: sed
 BuildRequires:  autoconf
-BuildRequires:  libHBAAPI2-devel
+BuildRequires:  libHBAAPI2-devel = 2.2.10
 BuildRequires:  libpciaccess0-devel
 BuildRequires:  libtool
 #Requires:   libHBAAPI2
@@ -53,7 +54,7 @@
 Development header files for FC-HBAAPI implementation
 
 %prep
-%setup -q -n libhbalinux-v%{version}
+%setup -q -n libhbalinux-%{version}
 %patch0 -p1
 %patch2 -p1
 




commit apache2 for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package apache2 for openSUSE:Factory checked 
in at 2015-08-07 00:18:22

Comparing /work/SRC/openSUSE:Factory/apache2 (Old)
 and  /work/SRC/openSUSE:Factory/.apache2.new (New)


Package is apache2

Changes:

--- /work/SRC/openSUSE:Factory/apache2/apache2.changes  2015-07-23 
15:21:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.apache2.new/apache2.changes 2015-08-07 
00:18:23.0 +0200
@@ -1,0 +2,5 @@
+Wed Jul 29 06:22:59 UTC 2015 - pgaj...@suse.com
+
+- add reference upstream bug#58188 along httpd-2.4.12-lua-5.2.patch
+
+---



Other differences:
--
++ apache2.spec ++
--- /var/tmp/diff_new_pack.mQh7mN/_old  2015-08-07 00:18:25.0 +0200
+++ /var/tmp/diff_new_pack.mQh7mN/_new  2015-08-07 00:18:25.0 +0200
@@ -120,7 +120,7 @@
 # PATCH-FEATURE-UPSTREAM httpd-2.4.3-mod_systemd.patch 
crrodrig...@opensuse.org simple module provides systemd integration.
 Patch109:   httpd-2.4.3-mod_systemd.patch
 Patch111:   httpd-visibility.patch
-# PATCH-FIX-UPSTREAM marguer...@opensuse.org -- compability for lua 5.2+
+# PATCH-FIX-UPSTREAM marguer...@opensuse.org -- compability for lua 5.2+ 
https://bz.apache.org/bugzilla/show_bug.cgi?id=58188
 Patch114:  httpd-2.4.12-lua-5.2.patch
 BuildRequires:  automake
 BuildRequires:  db-devel







commit apache-rpm-macros for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package apache-rpm-macros for 
openSUSE:Factory checked in at 2015-08-07 00:18:15

Comparing /work/SRC/openSUSE:Factory/apache-rpm-macros (Old)
 and  /work/SRC/openSUSE:Factory/.apache-rpm-macros.new (New)


Package is apache-rpm-macros

Changes:

--- /work/SRC/openSUSE:Factory/apache-rpm-macros/apache-rpm-macros.changes  
2015-07-16 17:17:12.0 +0200
+++ /work/SRC/openSUSE:Factory/.apache-rpm-macros.new/apache-rpm-macros.changes 
2015-08-07 00:18:16.0 +0200
@@ -1,0 +2,16 @@
+Tue Jul 28 12:01:08 UTC 2015 - pgaj...@suse.com
+
+- this is arch package
+
+---
+Mon Jul 27 16:03:19 UTC 2015 - pgaj...@suse.com
+
+- bump version to 20150717
+
+---
+Fri Jul 17 06:36:39 UTC 2015 - pgaj...@suse.com
+
+- %{apache_suse_maintenance_mmn} expands to just 'apache2' when
+  apache2 does not provide suse_maintenance_mmn_# symbol
+
+---



Other differences:
--
++ apache-rpm-macros.spec ++
--- /var/tmp/diff_new_pack.juMabu/_old  2015-08-07 00:18:17.0 +0200
+++ /var/tmp/diff_new_pack.juMabu/_new  2015-08-07 00:18:17.0 +0200
@@ -29,7 +29,7 @@
 %define ap_libexecdir %(%{ap_apxs} -q LIBEXECDIR)
 %define ap_localstatedir  %(%{ap_apxs} -q LOCALSTATEDIR)
 %define ap_mmn%(MMN=$(%{ap_apxs} -q LIBEXECDIR)_MMN; test -x $MMN 
 $MMN)
-%define ap_maint_mmn  %(rpm -q --provides apache2 | grep 
suse_maintenance_mmn)
+%define ap_maint_mmn  %(MMN=$(rpm -q --provides apache2 | grep 
suse_maintenance_mmn); test -z $MMN  MMN=apache2; echo $MMN)
 %define ap_serverroot %(%{ap_apxs} -q PREFIX)
 %define ap_sysconfdir %(%{ap_apxs} -q SYSCONFDIR)
 %define ap_datadir%(%{ap_apxs} -q DATADIR)
@@ -43,7 +43,7 @@
 %endif
 %define macros_file   macros.apache
 Name:   apache-rpm-macros
-Version:2014
+Version:20150717
 Release:0
 Summary:Apache RPM Macros
 License:Apache-2.0
@@ -51,7 +51,6 @@
 Url:http://httpd.apache.org/
 BuildRequires:  apache%{ap_major}-devel
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildArch:  noarch
 
 %description
 RPM Macros intended for Apache modules spec files.




commit swig for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package swig for openSUSE:Factory checked in 
at 2015-08-07 00:18:31

Comparing /work/SRC/openSUSE:Factory/swig (Old)
 and  /work/SRC/openSUSE:Factory/.swig.new (New)


Package is swig

Changes:

--- /work/SRC/openSUSE:Factory/swig/swig.changes2015-07-16 
17:14:05.0 +0200
+++ /work/SRC/openSUSE:Factory/.swig.new/swig.changes   2015-08-07 
00:18:32.0 +0200
@@ -1,0 +2,10 @@
+Tue Aug  4 07:43:49 UTC 2015 - kkae...@suse.com
+
+- Update to 3.0.7
+  - Add support for Octave-4.0.0.
+  - Remove potential Android security exploit in generated Java classes.
+  - Minor new features and bug fixes.
+
+- drop swig-octave4.patch and swig-3.0.6.patch, upstream now
+
+---

Old:

  swig-3.0.6.patch
  swig-3.0.6.tar.gz
  swig-octave4.patch

New:

  swig-3.0.7.tar.gz



Other differences:
--
++ swig.spec ++
--- /var/tmp/diff_new_pack.4pCxwx/_old  2015-08-07 00:18:35.0 +0200
+++ /var/tmp/diff_new_pack.4pCxwx/_new  2015-08-07 00:18:35.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   swig
-Version:3.0.6
+Version:3.0.7
 Release:0
 Summary:Simplified Wrapper and Interface Generator
 License:GPL-3.0+ and BSD-3-Clause
@@ -25,10 +25,6 @@
 Url:http://www.swig.org/
 Source: 
http://sourceforge.net/projects/swig/files/swig/%{name}-%{version}/%{name}-%{version}.tar.gz
 Source1:%{name}.rpmlintrc
-# Ocaml detection is wrong
-Patch0: %{name}-%{version}.patch
-# PATCH-FIX-UPSTREAM swig-octave4.patch badshah...@gmail.com -- Fix swig 
bindings for octave = 4.0
-Patch1: swig-octave4.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  boost-devel
@@ -122,8 +118,6 @@
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
 
 %build
 ./autogen.sh

++ swig-3.0.6.tar.gz - swig-3.0.7.tar.gz ++
 12212 lines of diff (skipped)




commit python-pytest for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-pytest for openSUSE:Factory 
checked in at 2015-08-07 00:20:39

Comparing /work/SRC/openSUSE:Factory/python-pytest (Old)
 and  /work/SRC/openSUSE:Factory/.python-pytest.new (New)


Package is python-pytest

Changes:

--- /work/SRC/openSUSE:Factory/python-pytest/python-pytest.changes  
2015-07-16 17:13:56.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-pytest.new/python-pytest.changes 
2015-08-07 00:20:40.0 +0200
@@ -1,0 +2,16 @@
+Wed Jul 29 13:01:56 UTC 2015 - toddrme2...@gmail.com
+
+- Make tests conditional to avoid dependency loop.
+
+---
+Mon Jul 27 09:29:06 UTC 2015 - seife+...@b1-systems.com
+
+- revert update-alternatives change, causes OBS trouble
+
+---
+Fri Jul 24 06:37:21 UTC 2015 - seife+...@b1-systems.com
+
+- Change update-alternatives requirement to absolute path to fix
+  non-SUSE distributions (RHEL7)
+
+---



Other differences:
--
++ python-pytest.spec ++
--- /var/tmp/diff_new_pack.K0U2Qr/_old  2015-08-07 00:20:41.0 +0200
+++ /var/tmp/diff_new_pack.K0U2Qr/_new  2015-08-07 00:20:41.0 +0200
@@ -15,6 +15,9 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+# NOTE(saschpe): git invocation and pythonpath issues with testrepository
+# enable testing with a build conditional (off by default):
+%bcond_with test
 
 Name:   python-pytest
 Version:2.7.1
@@ -31,8 +34,10 @@
 BuildRequires:  unzip
 # Test requirements:
 BuildRequires:  lsof
+%if %{with test}
 BuildRequires:  python-mock
 BuildRequires:  python-pexpect
+%endif
 BuildRequires:  python-xml
 Requires:   python-py = 1.4.25
 Requires(post): update-alternatives
@@ -72,11 +77,8 @@
 rm %{buildroot}%{_bindir}/py.test 
 ln -s %{_bindir}/py.test-%{py_ver} %{buildroot}%{_bindir}/py.test
 
-%if 0%{?suse_version}  1110
+%if %{with test}  0%{?suse_version}  1110
 %check
-#FIXME (mvyskocil): test fail on doc/en/example/nonpython/test_simple.yml
-#maybe too old python-PyYAML package? Factory has 3.12, where latest upstream 
is 13.12.0
-
 python setup.py test
 %endif
 




commit python-Cython for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-Cython for openSUSE:Factory 
checked in at 2015-08-07 00:20:33

Comparing /work/SRC/openSUSE:Factory/python-Cython (Old)
 and  /work/SRC/openSUSE:Factory/.python-Cython.new (New)


Package is python-Cython

Changes:

--- /work/SRC/openSUSE:Factory/python-Cython/python-Cython.changes  
2015-01-10 23:07:09.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-Cython.new/python-Cython.changes 
2015-08-07 00:20:34.0 +0200
@@ -1,0 +2,94 @@
+Wed Jul 29 11:52:24 UTC 2015 - toddrme2...@gmail.com
+
+- Remove unneeded numpy dependency to avoid dependency loop.
+- create dummy alternative to avoid 13.1's post-build-check bug
+- specfile:
+  * fixing update_alternatives
+
+---
+Fri Jul 10 21:59:38 UTC 2015 - ter...@gmail.com
+
+- Update to 0.22.1:
+  Bugs fixed
+  * Crash when returning values on generator termination.
+  * In some cases, exceptions raised during internal isinstance()
+checks were not propagated.
+  * Runtime reported file paths of source files (e.g for profiling
+and tracing) are now relative to the build root directory instead
+of the main source file. 
+  * Tracing exception handling code could enter the trace function with an
+active exception set.
+  * The internal generator function type was not shared across modules.
+  * Comparisons of (inferred) ctuples failed to compile.
+  * Closures inside of cdef functions returning ``void`` failed to compile.
+  * Using ``const`` C++ references in intermediate parts of longer
+expressions could fail to compile.
+  * C++ exception declarations with mapping functions could fail to compile
+when pre-declared in .pxd files.
+  * C++ compilation could fail with an ambiguity error in recent MacOS-X
+Xcode versions.
+  * C compilation could fail in pypy3.
+  * Fixed a memory leak in the compiler when compiling multiple modules.
+  * When compiling multiple modules, external library dependencies could
+leak into later compiler runs.  Fix by Jeroen Demeyer.  This fixes
+ticket 845.
+- removed patch fix-32bit.patch as applied upstream
+
+---
+Wed Apr 22 14:05:18 UTC 2015 - mci...@suse.cz
+
+- Use Source URL from cython.org
+
+---
+Wed Apr 22 11:52:03 UTC 2015 - mci...@suse.cz
+
+- Add python-numpy as BuildRequires to have more complete test coverage
+
+---
+Wed Apr 22 11:01:47 UTC 2015 - mci...@suse.cz
+
+- Fix doctests in 32-bit environment (fix-32bit.patch)
+
+---
+Wed Apr 22 09:10:30 UTC 2015 - mci...@suse.cz
+
+- Update to 0.22:
+  Features added
+  * C functions can coerce to Python functions, which allows passing them
+around as callable objects.
+  * C arrays can be assigned by value and auto-coerce from Python iterables
+and to Python lists (and tuples).
+  * Extern C functions can now be declared as cpdef to export them to
+the module's Python namespace.  Extern C functions in pxd files export
+their values to their own module, iff it exists.
+  * Anonymous C tuple types can be declared as (ctype1, ctype2, ...).
+  * PEP 479: turn accidental StopIteration exceptions that exit generators
+into a RuntimeError, activated with future import generator_stop.
+See http://legacy.python.org/dev/peps/pep-0479/
+  * Looping over ``reversed(range())`` is optimised in the same way as
+``range()``.  Patch by Favian Contreras.
+  Bugs fixed
+  * Mismatching 'except' declarations on signatures in .pxd and .pyx files 
failed
+to produce a compile error.
+  * Failure to find any files for the path pattern(s) passed into 
``cythonize()``
+is now an error to more easily detect accidental typos.
+  * The ``logaddexp`` family of functions in ``numpy.math`` now has correct
+declarations.
+  * In Py2.6/7 and Py3.2, simple Cython memory views could accidentally be
+interpreted as non-contiguous by CPython, which could trigger a CPython
+bug when copying data from them, thus leading to data corruption.
+See CPython issues 12834 and 23349.
+  Other changes
+  * Preliminary support for defining the Cython language with a formal grammar.
+To try parsing your files against this grammar, use the --formal_grammar 
directive.
+Experimental.
+  * ``_`` is no longer considered a cacheable builtin as it could interfere 
with
+gettext.
+  * Cythonize-computed metadata now cached in the generated C files.
+
+---
+Thu Feb  5 11:35:45 UTC 2015 - h...@urpla.net
+
+- fix 

commit python-virtualenv-doc for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-virtualenv-doc for 
openSUSE:Factory checked in at 2015-08-07 00:21:10

Comparing /work/SRC/openSUSE:Factory/python-virtualenv-doc (Old)
 and  /work/SRC/openSUSE:Factory/.python-virtualenv-doc.new (New)


Package is python-virtualenv-doc

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _link



Other differences:
--
++ _link ++
link package=python-virtualenv cicount=copy /


commit python-virtualenv for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-virtualenv for 
openSUSE:Factory checked in at 2015-08-07 00:21:01

Comparing /work/SRC/openSUSE:Factory/python-virtualenv (Old)
 and  /work/SRC/openSUSE:Factory/.python-virtualenv.new (New)


Package is python-virtualenv

Changes:

New Changes file:

--- /dev/null   2015-07-22 21:25:44.928025004 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-virtualenv.new/python-virtualenv-doc.changes 
2015-08-07 00:21:02.0 +0200
@@ -0,0 +1,6 @@
+---
+Wed Jul 29 12:41:42 UTC 2015 - toddrme2...@gmail.com
+
+- Split documentation into subpackage to avoid
+  dependency loop
+
--- /work/SRC/openSUSE:Factory/python-virtualenv/python-virtualenv.changes  
2015-04-05 02:04:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-virtualenv.new/python-virtualenv.changes 
2015-08-07 00:21:02.0 +0200
@@ -1,0 +2,6 @@
+Wed Jul 29 12:41:42 UTC 2015 - toddrme2...@gmail.com
+
+- Split documentation into subpackage to avoid
+  dependency loop
+
+---

New:

  python-virtualenv-doc.changes
  python-virtualenv-doc.spec



Other differences:
--
++ python-virtualenv-doc.spec ++
#
# spec file for package python-virtualenv-doc
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:   python-virtualenv-doc
Version:12.0.7
Release:0
Url:http://www.virtualenv.org/
Summary:Documentation for python-virtualenv
License:MIT
Group:  Development/Languages/Python
Source: 
https://pypi.python.org/packages/source/v/virtualenv/virtualenv-%{version}.tar.gz
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  python-devel
# Documentation requirements
BuildRequires:  python-Sphinx
Requires:   python-setuptools
%if 0%{?suse_version}  0%{?suse_version} = 1110
%{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
%else
BuildArch:  noarch
%endif

%description
virtualenv is a tool to create isolated Python environments.
The basic problem being addressed is one of dependencies and versions, and
indirectly permissions. Imagine you have an application that needs version 1
of LibFoo, but another application requires version 2. How can you use both
these applications? If you install everything into
/usr/lib/python2.4/site-packages (or whatever your platforms standard location
is), its easy to end up in a situation where you unintentionally upgrade an
application that shouldnt be upgraded.

Or more generally, what if you want to install an application and leave it be?
If an application works, any change in its libraries or the versions of those
libraries can break the application.

Also, what if you cant install packages into the global site-packages
directory? For instance, on a shared host.

In all these cases, virtualenv can help you. It creates an environment that
has its own installation directories, that doesnt share libraries with other
virtualenv environments (and optionally doesnt use the globally installed
libraries either).

This package provides the documentation and help files for python-virtualenv.

%prep
%setup -q -n virtualenv-%{version}

%build
python setup.py build_sphinx  rm build/sphinx/html/.buildinfo

%install
mkdir -p %{buildroot}%{_docdir}/python-virtualenv
cp -r build/sphinx/html %{buildroot}%{_docdir}/python-virtualenv/

%files
%defattr(-,root,root,-)
%doc LICENSE.txt
%{_docdir}/python-virtualenv/

%changelog
++ python-virtualenv.spec ++
--- /var/tmp/diff_new_pack.Xrx6nD/_old  2015-08-07 00:21:03.0 +0200
+++ /var/tmp/diff_new_pack.Xrx6nD/_new  2015-08-07 00:21:03.0 +0200
@@ -26,9 +26,6 @@
 Source: 
https://pypi.python.org/packages/source/v/virtualenv/virtualenv-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python-devel
-# Documentation requirements
-BuildRequires:  python-Sphinx
-#Requires:   python-pip
 Requires:   

commit python-pip for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-pip for openSUSE:Factory 
checked in at 2015-08-07 00:20:46

Comparing /work/SRC/openSUSE:Factory/python-pip (Old)
 and  /work/SRC/openSUSE:Factory/.python-pip.new (New)


Package is python-pip

Changes:

--- /work/SRC/openSUSE:Factory/python-pip/python-pip.changes2015-03-23 
12:18:57.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-pip.new/python-pip.changes   
2015-08-07 00:20:47.0 +0200
@@ -1,0 +2,5 @@
+Wed Jul 29 13:01:56 UTC 2015 - toddrme2...@gmail.com
+
+- Make tests conditional to avoid dependency loop.
+
+---



Other differences:
--
++ python-pip.spec ++
--- /var/tmp/diff_new_pack.Hykjga/_old  2015-08-07 00:20:48.0 +0200
+++ /var/tmp/diff_new_pack.Hykjga/_new  2015-08-07 00:20:48.0 +0200
@@ -15,6 +15,9 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+# NOTE(saschpe): git invocation and pythonpath issues with testrepository
+# enable testing with a build conditional (off by default):
+%bcond_with test
 
 Name:   python-pip
 Version:6.0.8
@@ -27,11 +30,13 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python-devel
 BuildRequires:  python-setuptools
+%if %{with test}
 # Test requirements:
 BuildRequires:  python-mock
 BuildRequires:  python-pytest
 BuildRequires:  python-scripttest = 1.3
 BuildRequires:  python-virtualenv = 1.10
+%endif
 Requires:   python-setuptools
 Requires:   python-xml
 Requires(post): update-alternatives
@@ -61,8 +66,10 @@
 rm %{buildroot}%{_bindir}/pip
 ln -s %{_bindir}/pip%{py_ver} %{buildroot}%{_bindir}/pip
 
+%if %{with test}
 %check
 python setup.py test
+%endif
 
 %pre
 # Since /usr/bin/pip became ghosted to be used with update-alternatives, we 
have to get rid




commit spice-protocol for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package spice-protocol for openSUSE:Factory 
checked in at 2015-08-07 00:17:23

Comparing /work/SRC/openSUSE:Factory/spice-protocol (Old)
 and  /work/SRC/openSUSE:Factory/.spice-protocol.new (New)


Package is spice-protocol

Changes:

--- /work/SRC/openSUSE:Factory/spice-protocol/spice-protocol.changes
2015-07-28 11:42:05.0 +0200
+++ /work/SRC/openSUSE:Factory/.spice-protocol.new/spice-protocol.changes   
2015-08-07 00:17:25.0 +0200
@@ -1,0 +2,13 @@
+Sun Aug  2 22:16:09 UTC 2015 - mplus...@suse.com
+
+- Update to 0.12.9
+  + Rename newly introduced SpiceImageCompress enum to 
+SpiceImageCompression as otherwise it was clashing with the 
+definition used by older spice-server releases, breaking QEMU 
+build.
+- Drop no longer needed patch revert-da3cf336.patch.
+- Tiny spec file cleanup:
+  + drop empty documentation files.
+  + do not use obsoleyr makeinstall macro.
+
+---

Old:

  revert-da3cf336.patch
  spice-protocol-0.12.8.tar.bz2

New:

  spice-protocol-0.12.9.tar.bz2



Other differences:
--
++ spice-protocol.spec ++
--- /var/tmp/diff_new_pack.t9Hsd3/_old  2015-08-07 00:17:26.0 +0200
+++ /var/tmp/diff_new_pack.t9Hsd3/_new  2015-08-07 00:17:26.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package spice-protocol
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   spice-protocol
-Version:0.12.8
+Version:0.12.9
 Release:0
 Url:http://www.spice-space.org/
 Summary:SPICE-protocol definitions
@@ -27,8 +27,6 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  pkgconfig
 Source: 
http://spice-space.org/download/releases/%{name}-%{version}.tar.bz2
-# Revert patch introducing compatibility problems with stable spice
-Patch0: revert-da3cf336.patch
 
 %description
 Headers defining the SPICE-protocol
@@ -42,18 +40,17 @@
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 %configure
 %__make %{?_smp_mflags}
 
 %install
-%makeinstall
+%make_install
 
 %files devel
 %defattr(-,root,root)
-%doc AUTHORS COPYING NEWS README
+%doc COPYING NEWS
 %{_datadir}/pkgconfig/spice-protocol.pc
 %{_includedir}/spice-1/
 

++ spice-protocol-0.12.8.tar.bz2 - spice-protocol-0.12.9.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/spice-protocol-0.12.8/NEWS 
new/spice-protocol-0.12.9/NEWS
--- old/spice-protocol-0.12.8/NEWS  2015-06-30 16:31:23.0 +0200
+++ new/spice-protocol-0.12.9/NEWS  2015-07-29 17:42:05.0 +0200
@@ -1,3 +1,9 @@
+Major changes in 0.12.9
+===
+* rename newly introduced SpiceImageCompress enum to SpiceImageCompression
+  as otherwise it was clashing with the definition used by older spice-server
+  releases, breaking QEMU build
+
 Major changes in 0.12.8
 ===
 * add LZ4 support
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/spice-protocol-0.12.8/configure 
new/spice-protocol-0.12.9/configure
--- old/spice-protocol-0.12.8/configure 2015-06-30 16:57:14.0 +0200
+++ new/spice-protocol-0.12.9/configure 2015-07-29 18:01:40.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for spice-protocol 0.12.8.
+# Generated by GNU Autoconf 2.69 for spice-protocol 0.12.9.
 #
 #
 # Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
@@ -576,8 +576,8 @@
 # Identity of this package.
 PACKAGE_NAME='spice-protocol'
 PACKAGE_TARNAME='spice-protocol'
-PACKAGE_VERSION='0.12.8'
-PACKAGE_STRING='spice-protocol 0.12.8'
+PACKAGE_VERSION='0.12.9'
+PACKAGE_STRING='spice-protocol 0.12.9'
 PACKAGE_BUGREPORT=''
 PACKAGE_URL=''
 
@@ -1200,7 +1200,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat _ACEOF
-\`configure' configures spice-protocol 0.12.8 to adapt to many kinds of 
systems.
+\`configure' configures spice-protocol 0.12.9 to adapt to many kinds of 
systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1266,7 +1266,7 @@
 
 if test -n $ac_init_help; then
   case $ac_init_help in
- short | recursive ) echo Configuration of spice-protocol 0.12.8:;;
+ short | recursive ) echo Configuration of 

commit apparmor for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package apparmor for openSUSE:Factory 
checked in at 2015-08-07 00:16:52

Comparing /work/SRC/openSUSE:Factory/apparmor (Old)
 and  /work/SRC/openSUSE:Factory/.apparmor.new (New)


Package is apparmor

Changes:

--- /work/SRC/openSUSE:Factory/apparmor/apparmor.changes2015-08-02 
22:44:12.0 +0200
+++ /work/SRC/openSUSE:Factory/.apparmor.new/apparmor.changes   2015-08-07 
00:16:54.0 +0200
@@ -1,0 +2,6 @@
+Thu Jul 30 20:08:20 UTC 2015 - opens...@cboltz.de
+
+- add apparmor-winbindd-r3213.diff - add missing k permissions for
+  /etc/samba/smbd.tmp/msg/* in winbindd profile (boo#921098 #c15..19)
+
+---

New:

  apparmor-winbindd-r3213.diff



Other differences:
--
++ apparmor.spec ++
--- /var/tmp/diff_new_pack.wYMptG/_old  2015-08-07 00:16:56.0 +0200
+++ /var/tmp/diff_new_pack.wYMptG/_new  2015-08-07 00:16:56.0 +0200
@@ -95,6 +95,9 @@
 # boo#862170 - fix ugly initscript output (commited upstream trunk r3208)
 Patch8: fix-initscript-aa_log_end_msg.diff
 
+# additional winbindd permissions (commited upstream trunk r3213, 2.9 r2946) - 
(boo#921098 #c15..19)
+Patch9: apparmor-winbindd-r3213.diff
+
 Url:https://launchpad.net/apparmor
 PreReq: sed
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -440,6 +443,7 @@
 %patch6
 %patch7 -p1
 %patch8
+%patch9
 
 # search for left-over multiline rules
 test -z $(grep -r '^\s*\(unix\|dbus\)[^,]\(([^)]*)\)*[^,]*$' 
profiles/apparmor.d/)


++ apparmor-winbindd-r3213.diff ++

revno: 3213
committer: Christian Boltz appar...@cboltz.de
branch nick: apparmor
timestamp: Thu 2015-07-30 22:03:02 +0200
message:
  winbindd profile: allow k for /etc/samba/smbd.tmp/msg/*
  
  References: https://bugzilla.opensuse.org/show_bug.cgi?id=921098 starting at 
comment 15
  
  
  Acked-by: Steve Beattie st...@nxnw.org for trunk and 2.9


=== modified file 'profiles/apparmor.d/usr.sbin.winbindd'
--- profiles/apparmor.d/usr.sbin.winbindd   2015-05-18 23:25:26 +
+++ profiles/apparmor.d/usr.sbin.winbindd   2015-07-30 20:03:02 +
@@ -15,7 +15,7 @@
   /etc/samba/secrets.tdb rwk,
   /etc/samba/smbd.tmp/ rw,
   /etc/samba/smbd.tmp/msg/ rw,
-  /etc/samba/smbd.tmp/msg/* rw,
+  /etc/samba/smbd.tmp/msg/* rwk,
   @{PROC}/sys/kernel/core_pattern r,
   /tmp/.winbindd/ w,
   /tmp/krb5cc_* rwk,


vim:ft=diff




commit prctl for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package prctl for openSUSE:Factory checked 
in at 2015-08-07 00:16:43

Comparing /work/SRC/openSUSE:Factory/prctl (Old)
 and  /work/SRC/openSUSE:Factory/.prctl.new (New)


Package is prctl

Changes:

--- /work/SRC/openSUSE:Factory/prctl/prctl.changes  2014-05-02 
14:01:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.prctl.new/prctl.changes 2015-08-07 
00:16:45.0 +0200
@@ -1,0 +2,6 @@
+Sun Aug  2 17:24:37 UTC 2015 - mplus...@suse.com
+
+- Cleanup spec file with spec-cleaner
+- Remove old source (prctl-1.5.tar.gz)
+
+---

Old:

  prctl-1.5.tar.gz



Other differences:
--
++ prctl.spec ++
--- /var/tmp/diff_new_pack.JQC83q/_old  2015-08-07 00:16:47.0 +0200
+++ /var/tmp/diff_new_pack.JQC83q/_new  2015-08-07 00:16:47.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package prctl
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -37,18 +37,19 @@
 %setup -q
 cp %{SOURCE1} .
 %patch0 -p1 -b .makefile
-%patch1 -p0 -b .warnings
+%patch1  -b .warnings
 
 %build
-%{configure}
+%configure
+make
 
 %install
-%{makeinstall}
+make DESTDIR=%{buildroot} install
 
 %files
 %defattr(-, root, root)
 %doc COPYING ChangeLog
 %{_bindir}/%{name}
-%doc %{_mandir}/man1/%{name}.1.*
+%{_mandir}/man1/%{name}.1.*
 
 %changelog




commit perl-Archive-Zip for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package perl-Archive-Zip for 
openSUSE:Factory checked in at 2015-08-07 00:16:35

Comparing /work/SRC/openSUSE:Factory/perl-Archive-Zip (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Archive-Zip.new (New)


Package is perl-Archive-Zip

Changes:

--- /work/SRC/openSUSE:Factory/perl-Archive-Zip/perl-Archive-Zip.changes
2015-07-02 22:44:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Archive-Zip.new/perl-Archive-Zip.changes   
2015-08-07 00:16:39.0 +0200
@@ -1,0 +2,10 @@
+Sat Aug  1 08:21:41 UTC 2015 - co...@suse.com
+
+- updated to 1.49
+   see /usr/share/doc/packages/perl-Archive-Zip/Changes
+
+  1.49 Fri 31 Jul 2015
+  - Fails on unseekable file handle after desiredCompressionLevel(), RT 
#54827
+  - Upgrade build tools to avoid tar warnings, RT #105547
+
+---

Old:

  Archive-Zip-1.48.tar.gz

New:

  Archive-Zip-1.49.tar.gz



Other differences:
--
++ perl-Archive-Zip.spec ++
--- /var/tmp/diff_new_pack.wQUpCP/_old  2015-08-07 00:16:40.0 +0200
+++ /var/tmp/diff_new_pack.wQUpCP/_new  2015-08-07 00:16:40.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Archive-Zip
-Version:1.48
+Version:1.49
 Release:0
 %define cpan_name Archive-Zip
 Summary:Provide an interface to ZIP archive files

++ Archive-Zip-1.48.tar.gz - Archive-Zip-1.49.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Archive-Zip-1.48/Changes new/Archive-Zip-1.49/Changes
--- old/Archive-Zip-1.48/Changes2015-06-18 23:12:33.0 +0200
+++ new/Archive-Zip-1.49/Changes2015-07-31 20:54:56.0 +0200
@@ -1,5 +1,9 @@
 Revision history for Perl extension Archive-Zip
 
+1.49 Fri 31 Jul 2015
+- Fails on unseekable file handle after desiredCompressionLevel(), RT 
#54827
+- Upgrade build tools to avoid tar warnings, RT #105547
+
 1.48 Thu 18 Jun 2015
 - Wrap skip in a SKIP: block [github/plicease]
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Archive-Zip-1.48/META.json 
new/Archive-Zip-1.49/META.json
--- old/Archive-Zip-1.48/META.json  2015-06-18 23:12:53.0 +0200
+++ new/Archive-Zip-1.49/META.json  2015-07-31 20:59:09.0 +0200
@@ -4,7 +4,7 @@
   Ned Konz p...@bike-nomad.com
],
dynamic_config : 1,
-   generated_by : ExtUtils::MakeMaker version 6.98, CPAN::Meta::Converter 
version 2.142690,
+   generated_by : ExtUtils::MakeMaker version 7.04, CPAN::Meta::Converter 
version 2.142690,
license : [
   perl_5
],
@@ -53,5 +53,5 @@
  url : https://github.com/redhotpenguin/perl-Archive-Zip-svn;
   }
},
-   version : 1.48
+   version : 1.49
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Archive-Zip-1.48/META.yml 
new/Archive-Zip-1.49/META.yml
--- old/Archive-Zip-1.48/META.yml   2015-06-18 23:12:53.0 +0200
+++ new/Archive-Zip-1.49/META.yml   2015-07-31 20:59:08.0 +0200
@@ -7,7 +7,7 @@
 configure_requires:
   ExtUtils::MakeMaker: '0'
 dynamic_config: 1
-generated_by: 'ExtUtils::MakeMaker version 6.98, CPAN::Meta::Converter version 
2.142690'
+generated_by: 'ExtUtils::MakeMaker version 7.04, CPAN::Meta::Converter version 
2.142690'
 license: perl
 meta-spec:
   url: http://module-build.sourceforge.net/META-spec-v1.4.html
@@ -32,4 +32,4 @@
   perl: '5.006'
 resources:
   repository: https://github.com/redhotpenguin/perl-Archive-Zip-svn
-version: '1.48'
+version: '1.49'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Archive-Zip-1.48/lib/Archive/Zip/Archive.pm 
new/Archive-Zip-1.49/lib/Archive/Zip/Archive.pm
--- old/Archive-Zip-1.48/lib/Archive/Zip/Archive.pm 2015-06-18 
23:12:25.0 +0200
+++ new/Archive-Zip-1.49/lib/Archive/Zip/Archive.pm 2015-07-31 
20:58:45.0 +0200
@@ -13,7 +13,7 @@
 use vars qw( $VERSION @ISA );
 
 BEGIN {
-$VERSION = '1.48';
+$VERSION = '1.49';
 @ISA = qw( Archive::Zip );
 
 if ($^O eq 'MSWin32') {
@@ -663,9 +663,9 @@
$self-{'numberOfCentralDirectories'} == 0x ||
$self-{'centralDirectorySize'} == 0x ||
$self-{'centralDirectoryOffsetWRTStartingDiskNumber'} == 
0x) {
-return _formatError(zip64 not supported);
+return _formatError(zip64 not supported . Dumper($self));
 }
-
+use Data::Dumper;
 if ($zipfileCommentLength) {
 my $zipfileComment = '';
 $bytesRead = $fh-read($zipfileComment, $zipfileCommentLength);
diff -urN '--exclude=CVS' 

commit kiwi for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package kiwi for openSUSE:Factory checked in 
at 2015-08-07 00:17:33

Comparing /work/SRC/openSUSE:Factory/kiwi (Old)
 and  /work/SRC/openSUSE:Factory/.kiwi.new (New)


Package is kiwi

Changes:

--- /work/SRC/openSUSE:Factory/kiwi/kiwi.changes2015-08-02 
22:43:58.0 +0200
+++ /work/SRC/openSUSE:Factory/.kiwi.new/kiwi.changes   2015-08-07 
00:17:37.0 +0200
@@ -1,0 +2,116 @@
+Mon Aug  3 10:56:37 CEST 2015 - m...@suse.de
+
+- v7.03.13 released
+  
+---
+Thu Jul 30 17:34:24 CEST 2015 - m...@suse.de
+  
+- Fixed XML writer for array of objects
+  
+  Elements which can appear multiple times like the vagrantconfig
+  element are stored as array of objects. The XML writer has to
+  iterate over the array and ask for the XML setup of each of
+  the objects inside of the array
+  
+---
+Wed Jul 29 14:24:35 CEST 2015 - m...@suse.de
+  
+- v7.03.12 released
+  
+---
+Wed Jul 29 14:19:29 CEST 2015 - m...@suse.de
+  
+- Fixed RHEL recovery
+  
+  delete recovery of zypp database backup, this does not exist
+  on rhel systems
+  
+---
+Tue Jul 28 16:39:21 CEST 2015 - m...@suse.de
+  
+- v7.03.11 released
+  
+---
+Tue Jul 28 16:31:24 CEST 2015 - m...@suse.de
+  
+- Update RHEL6 JeOS
+  
+  use group id names instead of the description
+  
+---
+Tue Jul 28 16:24:49 CEST 2015 - m...@suse.de
+  
+- Deleted yum grouplist check
+  
+  Prior to installing yum groups, kiwi performed a grouplist
+  to check if the group exists. That's because yum groupinstall
+  does only print a warning message if a non existing group
+  should be installed. The problem here is that the group names
+  displayed by yum grouplist are the description names like
+  Console internet tools but the group id name in this case
+  console-internet is not displayed. This makes it impossible
+  for kiwi to use the yum group id names which we should prefer
+  over the description texts, because the texts could contain
+  special characters which makes it hard to validate the content
+  in a stable way. In addition yum groupinstall works more
+  reliable if the group id names are used
+  
+---
+Tue Jul 28 12:59:59 CEST 2015 - m...@suse.de
+  
+- v7.03.10 released
+  
+---
+Tue Jul 28 12:55:20 CEST 2015 - m...@suse.de
+  
+- Fixed installation of recovery grub for RHEL
+  
+---
+Tue Jul 28 10:35:36 CEST 2015 - m...@suse.de
+  
+- Update spec file to package updated RHEL JeOS
+  
+---
+Tue Jul 28 10:34:54 CEST 2015 - m...@suse.de
+  
+- Update RHEL6 JeOS template
+  
+  Update to rhel server v6.6
+  
+---
+Mon Jul 27 15:58:36 CEST 2015 - m...@suse.de
+  
+- Fixed disk size adaption for in place recovery
+  
+  The size of the disk is increased by the require space to
+  create the recovery tar archive at boot time. However the
+  value was not in the xml instance because KIWIBoot creates
+  their own instance of KIWIXML. This is fixed now by passing
+  along the origin XML instance when available
+  
+---
+Mon Jul 27 12:02:07 CEST 2015 - m...@suse.de
+  
+- Fixed in place recovery
+  
+  The information about the size of the recovery partition was
+  missing inside of the initrd. The information is now available
+  as variable in the profile environment
+  
+---
+Fri Jul 24 16:51:56 CEST 2015 - m...@suse.de
+  
+- v7.03.9 released
+  
+---
+Fri Jul 24 16:46:18 CEST 2015 - m...@suse.de
+  
+- Added custom hybridpersistent_filesystem attribute
+  
+  By default kiwi creates a btrfs partition as write space for hybrid
+  live systems. With the new attribute one can specify also the 'fat'
+  filesystem as write space. This would allow to create hybrid live
+  images which are compatible with the Windows OS in a similar way
+  like kiwi's livestick tool does it. This Fixes #475
+  
+---



Other differences:

commit gnome-documents for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package gnome-documents for openSUSE:Factory 
checked in at 2015-08-07 00:17:42

Comparing /work/SRC/openSUSE:Factory/gnome-documents (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-documents.new (New)


Package is gnome-documents

Changes:

--- /work/SRC/openSUSE:Factory/gnome-documents/gnome-documents.changes  
2015-05-18 21:39:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-documents.new/gnome-documents.changes 
2015-08-07 00:17:47.0 +0200
@@ -1,0 +2,10 @@
+Mon Aug  3 10:10:43 UTC 2015 - zai...@opensuse.org
+
+- Update to version 3.16.3:
+  + Collections are not displayed in the collections dialog.
+  + Fix the sharing dialog to work with the latest Google Drive
+changes.
+  + Unbreak activating documents from the search provider.
+  + Updated translations.
+
+---

Old:

  gnome-documents-3.16.2.tar.xz

New:

  gnome-documents-3.16.3.tar.xz



Other differences:
--
++ gnome-documents.spec ++
--- /var/tmp/diff_new_pack.VAFpRY/_old  2015-08-07 00:17:49.0 +0200
+++ /var/tmp/diff_new_pack.VAFpRY/_new  2015-08-07 00:17:49.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-documents
-Version:3.16.2
+Version:3.16.3
 Release:0
 Summary:Document Manager for GNOME
 License:GPL-2.0+

++ gnome-documents-3.16.2.tar.xz - gnome-documents-3.16.3.tar.xz ++
 7376 lines of diff (skipped)




commit tracker for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package tracker for openSUSE:Factory checked 
in at 2015-08-07 00:17:50

Comparing /work/SRC/openSUSE:Factory/tracker (Old)
 and  /work/SRC/openSUSE:Factory/.tracker.new (New)


Package is tracker

Changes:

--- /work/SRC/openSUSE:Factory/tracker/tracker-extras.changes   2015-03-30 
19:28:59.0 +0200
+++ /work/SRC/openSUSE:Factory/.tracker.new/tracker-extras.changes  
2015-08-07 00:17:52.0 +0200
@@ -1,0 +2,21 @@
+Fri Jul 31 23:04:54 UTC 2015 - zai...@opensuse.org
+
+- Update to version 1.4.1:
+  + build: Move bash-completion to new location.
+  + libtracker-miner: Set inotify limits for 'GInotifyFileBackend'
+too (changes in GLib).
+  + tracker-extract: Remove ModulePath from comic/ebook rules.
+  + tracker-extract-gstreamer:
+- Rely better on the GstDiscoverer than mimetype sniffing.
+- Fallback to preview image for album art.
+  + tracker-miner-fs: Reset retry counter when we need to prepend
+parents.
+  + tracker-preferences: Use the new command line tool.
+  + tracker: Improve bash completion script (complete on real
+files for some arguments).
+  + tracker: Mark missing strings for translation.
+  + Bugs fixed: bgo#735610, bgo#732236, bgo#750394, bgo#751723,
+bgo#751724, bgo#751992, bgo#748677, bgo#746401.
+  + Updated translations.
+
+---
tracker.changes: same change

Old:

  tracker-1.4.0.tar.xz

New:

  tracker-1.4.1.tar.xz



Other differences:
--
++ tracker-extras.spec ++
--- /var/tmp/diff_new_pack.mNGdUm/_old  2015-08-07 00:17:54.0 +0200
+++ /var/tmp/diff_new_pack.mNGdUm/_new  2015-08-07 00:17:54.0 +0200
@@ -45,7 +45,7 @@
 # Do not edit this auto generated file! Edit tracker.spec.
 Name:   tracker-extras
 %define _name   tracker
-Version:1.4.0
+Version:1.4.1
 Release:0
 %define TrackerAPI1.0
 %define RPMTrackerAPI 1_0
@@ -632,7 +632,7 @@
 %files
 %defattr(-,root,root)
 %doc AUTHORS ChangeLog COPYING README NEWS
-%{_sysconfdir}/bash_completion.d/tracker-prompt.sh
+%{_sysconfdir}/xdg/autostart/tracker-extract.desktop
 %{_sysconfdir}/xdg/autostart/tracker-store.desktop
 %{_bindir}/tracker
 %{_bindir}/tracker-control
@@ -657,6 +657,7 @@
 %{_datadir}/glib-2.0/schemas/org.freedesktop.Tracker.Store.gschema.xml
 %{_datadir}/glib-2.0/schemas/org.freedesktop.Tracker.Writeback.gschema.xml
 %{_datadir}/glib-2.0/schemas/org.freedesktop.Tracker.gschema.xml
+%{_datadir}/bash-completion/completions/tracker
 %{_mandir}/man1/tracker-daemon.1%{ext_man}
 %{_mandir}/man1/tracker-extract.1%{ext_man}
 %{_mandir}/man1/tracker-index.1%{ext_man}
@@ -675,7 +676,6 @@
 %{_mandir}/man5/tracker-miner-fs.cfg.5%{ext_man}
 %{_mandir}/man5/tracker-store.cfg.5%{ext_man}
 %{_mandir}/man5/tracker-writeback.cfg.5%{ext_man}
-%{_sysconfdir}/xdg/autostart/tracker-extract.desktop
 # Exclude files which live in other packages
 %if %{build_evo}
 %exclude %{_datadir}/tracker/miners/tracker-miner-evolution.desktop

++ tracker.spec ++
--- /var/tmp/diff_new_pack.mNGdUm/_old  2015-08-07 00:17:54.0 +0200
+++ /var/tmp/diff_new_pack.mNGdUm/_new  2015-08-07 00:17:54.0 +0200
@@ -44,7 +44,7 @@
 
 Name:   tracker
 %define _name   tracker
-Version:1.4.0
+Version:1.4.1
 Release:0
 %define TrackerAPI1.0
 %define RPMTrackerAPI 1_0
@@ -631,7 +631,7 @@
 %files
 %defattr(-,root,root)
 %doc AUTHORS ChangeLog COPYING README NEWS
-%{_sysconfdir}/bash_completion.d/tracker-prompt.sh
+%{_sysconfdir}/xdg/autostart/tracker-extract.desktop
 %{_sysconfdir}/xdg/autostart/tracker-store.desktop
 %{_bindir}/tracker
 %{_bindir}/tracker-control
@@ -656,6 +656,7 @@
 %{_datadir}/glib-2.0/schemas/org.freedesktop.Tracker.Store.gschema.xml
 %{_datadir}/glib-2.0/schemas/org.freedesktop.Tracker.Writeback.gschema.xml
 %{_datadir}/glib-2.0/schemas/org.freedesktop.Tracker.gschema.xml
+%{_datadir}/bash-completion/completions/tracker
 %{_mandir}/man1/tracker-daemon.1%{ext_man}
 %{_mandir}/man1/tracker-extract.1%{ext_man}
 %{_mandir}/man1/tracker-index.1%{ext_man}
@@ -674,7 +675,6 @@
 %{_mandir}/man5/tracker-miner-fs.cfg.5%{ext_man}
 %{_mandir}/man5/tracker-store.cfg.5%{ext_man}
 %{_mandir}/man5/tracker-writeback.cfg.5%{ext_man}
-%{_sysconfdir}/xdg/autostart/tracker-extract.desktop
 # Exclude files which live in other packages
 %if %{build_evo}
 %exclude %{_datadir}/tracker/miners/tracker-miner-evolution.desktop

++ tracker-1.4.0.tar.xz - tracker-1.4.1.tar.xz ++
 204350 lines of diff (skipped)




commit os-prober for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package os-prober for openSUSE:Factory 
checked in at 2015-08-07 00:17:00

Comparing /work/SRC/openSUSE:Factory/os-prober (Old)
 and  /work/SRC/openSUSE:Factory/.os-prober.new (New)


Package is os-prober

Changes:

--- /work/SRC/openSUSE:Factory/os-prober/os-prober.changes  2015-07-05 
17:51:11.0 +0200
+++ /work/SRC/openSUSE:Factory/.os-prober.new/os-prober.changes 2015-08-07 
00:17:01.0 +0200
@@ -1,0 +2,7 @@
+Sun Aug  2 15:14:55 UTC 2015 - arvidj...@gmail.com
+
+- add os-prober-40grub-check-grub2.patch
+  * also skip legacy grub if /boot/grub2/grub.cfg is present, not only
+/boot/grub/grub.cfg
+
+---

New:

  os-prober-40grub-check-grub2.patch



Other differences:
--
++ os-prober.spec ++
--- /var/tmp/diff_new_pack.NaDFv9/_old  2015-08-07 00:17:02.0 +0200
+++ /var/tmp/diff_new_pack.NaDFv9/_new  2015-08-07 00:17:02.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package os-prober
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -60,6 +60,8 @@
 Patch17:Improve-btrfs-handling-on-os-probing-for-grub2.patch
 # PATCH-FIX-SLE: fix os-prober mount error, no such file or directory 
(bsc#931955)
 Patch18:os-prober-btrfs-absolute-subvol.patch
+# PATCH-FIX-OPENSUSE: also skip legacy grub if /boot/grub2/grub.cfg is present
+Patch19:os-prober-40grub-check-grub2.patch
 Requires:   /bin/grep
 Requires:   /bin/sed
 Requires:   /sbin/modprobe
@@ -99,6 +101,7 @@
 %patch16 -p1
 %patch17 -p1
 %patch18 -p1
+%patch19 -p1
 find . -name \*.orig -delete
 
 %build

++ os-prober-40grub-check-grub2.patch ++
From: Andrei Borzenkov arvidj...@gmail.com
Subject: Also skip legacy grub if grub2 is found

Check for grub.cfg also in /boot/grub2, not only in /boot/grub.
Index: os-prober/linux-boot-probes/mounted/x86/40grub
===
--- os-prober.orig/linux-boot-probes/mounted/x86/40grub
+++ os-prober/linux-boot-probes/mounted/x86/40grub
@@ -95,7 +95,9 @@ fi
 
 if [ $grubconf ]  \
([ ! -e $mpoint/boot/grub/grub.cfg ] || \
-[ $mpoint/boot/grub/$grubconf -nt $mpoint/boot/grub/grub.cfg ]); then
+[ $mpoint/boot/grub/$grubconf -nt $mpoint/boot/grub/grub.cfg ])  \
+   ([ ! -e $mpoint/boot/grub2/grub.cfg ] || \
+[ $mpoint/boot/grub/$grubconf -nt $mpoint/boot/grub2/grub.cfg ]); then
debug parsing $grubconf
parse_grub_menu $mpoint $partition $bootpart  
$mpoint/boot/grub/$grubconf
 fi



commit man-pages for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package man-pages for openSUSE:Factory 
checked in at 2015-08-07 00:17:09

Comparing /work/SRC/openSUSE:Factory/man-pages (Old)
 and  /work/SRC/openSUSE:Factory/.man-pages.new (New)


Package is man-pages

Changes:

--- /work/SRC/openSUSE:Factory/man-pages/man-pages.changes  2015-05-15 
09:54:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.man-pages.new/man-pages.changes 2015-08-07 
00:17:13.0 +0200
@@ -1,0 +2,12 @@
+Mon Jul 27 06:40:42 UTC 2015 - pgaj...@suse.com
+
+- update to 4.01:
+  - new and rewritten pages
+* bpf.2
+* __ppc_get_timebase.3
+* queue.3
+  - newly documented interfaces in existing pages
+* rename.2
+ Document RENAME_WHITEOUT
+
+---

Old:

  man-pages-4.00.tar.xz

New:

  man-pages-4.01.tar.xz



Other differences:
--
++ man-pages.spec ++
--- /var/tmp/diff_new_pack.oredIx/_old  2015-08-07 00:17:14.0 +0200
+++ /var/tmp/diff_new_pack.oredIx/_new  2015-08-07 00:17:14.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   man-pages
-Version:4.00
+Version:4.01
 Release:0
 Summary:Linux  Manual Pages
 License:BSD-3-Clause and GPL-2.0+ and MIT

++ man-pages-4.00.tar.xz - man-pages-4.01.tar.xz ++
 24708 lines of diff (skipped)




commit libuv for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package libuv for openSUSE:Factory checked 
in at 2015-08-07 00:24:09

Comparing /work/SRC/openSUSE:Factory/libuv (Old)
 and  /work/SRC/openSUSE:Factory/.libuv.new (New)


Package is libuv

Changes:

--- /work/SRC/openSUSE:Factory/libuv/libuv.changes  2015-03-03 
11:16:06.0 +0100
+++ /work/SRC/openSUSE:Factory/.libuv.new/libuv.changes 2015-08-07 
00:24:11.0 +0200
@@ -1,0 +2,86 @@
+Wed Aug  5 08:53:20 UTC 2015 - mplus...@suse.com
+
+- Update to 1.6.1
+  * unix: handle invalid _SC_GETPW_R_SIZE_MAX values (cjihrig)
+- Changes for 1.6.0
+  * aix: fix setsockopt for multicast options (Michael)
+  * unix: don't block for io if any io handle is primed (Saúl 
+Ibarra Corretgé)
+  * windows: MSVC 2015 has snprintf() (Rui Abreu Ferreira)
+  * windows: Add VS2015 support to vcbuild.bat (Jason Williams)
+  * doc: fix typo in tcp.rst (Igor Soarez)
+  * linux: work around epoll bug in kernels  2.6.37 (Ben 
+Noordhuis)
+  * unix,win: add uv_os_homedir() (cjihrig)
+  * stream: fix `select()` race condition (Fedor Indutny)
+  * unix: prevent infinite loop in uv__run_pending (Saúl Ibarra 
+Corretgé)
+  * unix: make sure UDP send callbacks are asynchronous (Saúl 
+Ibarra Corretgé)
+  * test: fix `platform_output` netmask printing. (Andrew Paprocki)
+  * aix: add ahafs autoconf detection and README notes (Andrew 
+Paprocki)
+  * core: add ability to customize memory allocator (Saúl Ibarra 
+Corretgé)
+- Changes for 1.5.0
+  * doc: clarify that the thread pool primites are not thread safe 
+(Andrius Bentkus)
+  * aix: always deregister closing fds from epoll (Michael)
+  * unix: fix glibc-2.20+ macro incompatibility (Massimiliano 
+Torromeo)
+  * doc: add Sphinx plugin for generating links to man pages 
+(Saúl Ibarra Corretgé)
+  * doc: link system and library calls to man pages (Saúl 
+Ibarra Corretgé)
+  * doc: document uv_getnameinfo_t.{host|service} (Saúl Ibarra 
+Corretgé)
+  * build: update the location of gyp (Stephen von Takach)
+  * win: name all anonymous structs and unions (TomCrypto)
+  * linux: work around epoll bug in kernels 3.10-3.19 (Ben 
+Noordhuis)
+  * darwin: fix size calculation in select() fallback (Ole 
+André Vadla Ravnås)
+  * solaris: fix setsockopt for multicast options (Julien 
+Gilli)
+  * test: fix race condition in multithreaded test (Ben Noordhuis)
+  * doc: fix long lines in tty.rst (Ben Noordhuis)
+  * test: use UV_TTY_MODE_* values in tty test (Ben Noordhuis)
+  * unix: don't clobber errno in uv_tty_reset_mode() (Ben 
+Noordhuis)
+  * unix: reject non-tty fds in uv_tty_init() (Ben Noordhuis)
+  * win: fix pipe blocking writes (Alexis Campailla)
+  * build: fix cross-compiling for iOS (Steven Kabbes)
+  * win: remove unnecessary malloc.h
+  * include: use `extern c++` for defining C++ code (Kazuho Oku)
+  * unix: reap child on execvp() failure (Ryan Phillips)
+  * windows: fix handle leak on EMFILE (Brian Green)
+  * test: fix tty_file, close handle if initialized (Saúl Ibarra 
+Corretgé)
+  * doc: clarify what uv_*_open accepts (Saúl Ibarra Corretgé)
+  * doc: clarify that we don't maintain external doc resources 
+(Saúl Ibarra Corretgé)
+  * build: add documentation for ninja support (Devchandra 
+Meetei Leishangthem)
+  * doc: document uv_buf_t members (Corey Farrell)
+  * linux: fix epoll_pwait() fallback on arm64 (Ben Noordhuis)
+  * android: fix compilation warning (Saúl Ibarra Corretgé)
+  * unix: don't close the fds we just setup (Sam Roberts)
+  * test: spawn child replacing std{out,err} to stderr 
+  * unix: fix swapping fds order in uv_spawn 
+  * unix: fix potential bug if dup2 fails in uv_spawn 
+  * test: remove LOG and LOGF variadic macros
+  * win: fix uv_fs_access on directories 
+  * win: fix of double free in uv_uptime
+  * unix: open /dev/null instead of / for emfile_fd 
+  * docs: add some missing words 
+  * unix: clean up uv_fs_open() O_CLOEXEC logic 
+  * build: set SONAME for shared library in uv.gyp 
+  * windows: define snprintf replacement as inline instead of static
+  * win: fix unlink of readonly files 
+  * doc: fix uv_run(UV_RUN_DEFAULT) description 
+  * linux: intercept syscall when running under memory sanitizer
+  * aix: fix uv_interface_addresses return value
+  * windows: defer reporting TCP write failure until next tick
+  * test: add test for deferred TCP write failure 
+
+---

Old:

  v1.4.2.tar.gz

New:

  v1.6.1.tar.gz



Other differences:
--
++ libuv.spec ++
--- /var/tmp/diff_new_pack.i5ui70/_old  2015-08-07 00:24:13.0 +0200
+++ /var/tmp/diff_new_pack.i5ui70/_new  2015-08-07 

commit colordiff for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package colordiff for openSUSE:Factory 
checked in at 2015-08-07 00:24:13

Comparing /work/SRC/openSUSE:Factory/colordiff (Old)
 and  /work/SRC/openSUSE:Factory/.colordiff.new (New)


Package is colordiff

Changes:

--- /work/SRC/openSUSE:Factory/colordiff/colordiff.changes  2015-03-30 
19:34:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.colordiff.new/colordiff.changes 2015-08-07 
00:24:14.0 +0200
@@ -1,0 +2,6 @@
+Wed Aug  5 14:25:05 UTC 2015 - mplus...@suse.com
+
+- Update to 1.0.15
+  * see attached CHANGES for details
+
+---

Old:

  colordiff-1.0.13.tar.gz

New:

  colordiff-1.0.15.tar.gz



Other differences:
--
++ colordiff.spec ++
--- /var/tmp/diff_new_pack.zZQ1fz/_old  2015-08-07 00:24:15.0 +0200
+++ /var/tmp/diff_new_pack.zZQ1fz/_new  2015-08-07 00:24:15.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   colordiff
-Version:1.0.13
+Version:1.0.15
 Release:0
 Summary:Colour-highlighted 'diff' output
 License:GPL-2.0+

++ colordiff-1.0.13.tar.gz - colordiff-1.0.15.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/colordiff-1.0.13/CHANGES new/colordiff-1.0.15/CHANGES
--- old/colordiff-1.0.13/CHANGES2012-11-14 10:36:31.0 +0100
+++ new/colordiff-1.0.15/CHANGES2015-06-23 22:36:28.0 +0200
@@ -117,5 +117,15 @@
 Avoid accidentally identifying some diffs as side-by-side, handling colordiff
 arguments better.  Plus code refactoring, corrections to docs.
 
+Changes between version 1.0.13 and 1.0.14
+
+Big improvements to side-by-side diff detection, thanks Peter Wu.  Additional
+colordiffrc example colour scheme file to match 'git diff'.  Misc fixes thanks
+to John Szakmeister, Matthew Wang.
+
+Changes between 1.0.14 and 1.0.15
+
+Missed gitdiff file from tarball, bumping version number for clarity.
+
 # vim: tw=72
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/colordiff-1.0.13/Makefile 
new/colordiff-1.0.15/Makefile
--- old/colordiff-1.0.13/Makefile   2012-10-17 22:14:35.0 +0200
+++ new/colordiff-1.0.15/Makefile   2015-06-23 22:35:04.0 +0200
@@ -4,11 +4,11 @@
 VERSION=$(shell egrep '^my .version' colordiff.pl |cut -f 2 -d ')
 DIST_FILES=COPYING INSTALL Makefile README \
colordiff.pl colordiffrc colordiffrc-lightbg cdiff.sh BUGS CHANGES 
colordiff.1 \
-   colordiff.xml cdiff.xml cdiff.1
+   colordiff.xml cdiff.xml cdiff.1 colordiffrc-gitdiff
 TMPDIR=colordiff-${VERSION}
 TARBALL=${TMPDIR}.tar.gz
 
-
+.PHONY: doc
 doc: colordiff.xml cdiff.xml
xmlto -vv man colordiff.xml
xmlto -vv man cdiff.xml
@@ -19,6 +19,7 @@
perl -p -i -e 's#/body#/div/body#' colordiff.html
perl -p -i -e 's#div class=\refentry\#div id=\content\div 
class=\refentry\#' colordiff.html
 
+.PHONY: install
 install:
install -d ${DESTDIR}${INSTALL_DIR}
sed -e s%/etc%${ETC_DIR}%g colordiff.pl  \
@@ -39,6 +40,7 @@
-chown root.root ${DESTDIR}${ETC_DIR}/colordiffrc
chmod 644 ${DESTDIR}${ETC_DIR}/colordiffrc
 
+.PHONY: uninstall
 uninstall:
rm -f ${DESTDIR}${INSTALL_DIR}/colordiff
rm -f ${DESTDIR}${ETC_DIR}/colordiffrc
@@ -46,14 +48,17 @@
rm -f ${DESTDIR}${MAN_DIR}/colordiff.1
rm -f ${DESTDIR}${MAN_DIR}/cdiff.1
 
+.PHONY: dist
 dist:
mkdir ${TMPDIR}
cp -p ${DIST_FILES} ${TMPDIR}
tar -zcvf ${TARBALL} ${TMPDIR}
rm -fR ${TMPDIR}
 
+.PHONY: gitclean
 gitclean:
rm -f colordiff.1 colordiff.html cdiff.1
 
+.PHONY: clean
 clean:
rm -f README colordiff.1 colordiff.html cdiff.1
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/colordiff-1.0.13/README new/colordiff-1.0.15/README
--- old/colordiff-1.0.13/README 2012-11-14 10:50:32.0 +0100
+++ new/colordiff-1.0.15/README 2015-05-21 11:19:12.0 +0200
@@ -39,6 +39,11 @@
 
 $ diff -u file1 file2 | colordiff | less -R
 
+If you want to force disable colour escape sequences (for example pipe the
+output to patch), you can use option '--color=no' to do so:
+
+$ diff -u file1 file2 | colordiff --color=no | patch -p0 -d another-working-dir
+
 If you have wdiff installed, colordiff will correctly colourise the added and
 removed text, provided that the '-n' option is given to wdiff:
 
@@ -70,6 +75,12 @@
 
 Note that the function name, cvsdiff, can be customized.
 
+By default colordiff returns the exit code of the underlying diff invocation
+(if there is one), but there are some circumstances where it is 

commit squid for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package squid for openSUSE:Factory checked 
in at 2015-08-07 00:24:30

Comparing /work/SRC/openSUSE:Factory/squid (Old)
 and  /work/SRC/openSUSE:Factory/.squid.new (New)


Package is squid

Changes:

--- /work/SRC/openSUSE:Factory/squid/squid.changes  2015-07-22 
09:19:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.squid.new/squid.changes 2015-08-07 
00:24:31.0 +0200
@@ -1,0 +2,22 @@
+Wed Aug  5 21:20:28 UTC 2015 - ch...@computersalat.de
+
+- Changes to squid-3.5.7 (01 Aug 2015):
+  * Bug 4293: wrong SNI sent to server after URL-rewrite
+  * Bug 4251: incorrect instance name for memory segments in /dev/shm
+  * Bug 4227: invalid key in AuthUserHashPointer causing assertation failure
+  * Bug 3345: support %un (any available user name) format code for external 
ACLs.
+  * basic_smb_auth: Fix several old issues identified by Debian users
+  * Support ssl-bump splicing to origin cache_peer
+  * Fix SSL errors relayed using invalid certificates
+  * Fix crash in TcpAccepter with profiler enabled
+  * Fix some cases of ssl_crtd SSL certificate DB corruption
+  * Fix performance regression in SBuf::chop operations
+  * Improve handling of client connections on shutdown
+  * Handle exceptions during squid.conf parse
+  * Make pod2man an optional dependency
+  * ... and polishing for several cache.log notification messages
+  * Do not blindly forward cache peer CONNECT responses (CVE-2015-5400)
+- rebase patch 
+  * squid-config.patch
+
+---

Old:

  squid-3.5.6.tar.xz
  squid-3.5.6.tar.xz.asc

New:

  squid-3.5.7.tar.xz
  squid-3.5.7.tar.xz.asc



Other differences:
--
++ squid.spec ++
--- /var/tmp/diff_new_pack.QoOPls/_old  2015-08-07 00:24:33.0 +0200
+++ /var/tmp/diff_new_pack.QoOPls/_new  2015-08-07 00:24:33.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package squid
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,7 +20,7 @@
 %define squidconfdir %{_sysconfdir}/squid
 
 Name:   squid
-Version:3.5.6
+Version:3.5.7
 Release:0
 Summary:A fully featured HTTP/1.0 proxy
 License:GPL-2.0+

++ squid-3.5.6.tar.xz - squid-3.5.7.tar.xz ++
 12264 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/squid-3.5.6/ChangeLog new/squid-3.5.7/ChangeLog
--- old/squid-3.5.6/ChangeLog   2015-07-03 11:12:52.0 +0200
+++ new/squid-3.5.7/ChangeLog   2015-08-01 08:08:17.0 +0200
@@ -1,3 +1,21 @@
+Changes to squid-3.5.7 (01 Aug 2015):
+
+   - Bug 4293: wrong SNI sent to server after URL-rewrite
+   - Bug 4251: incorrect instance name for memory segments in /dev/shm
+   - Bug 4227: invalid key in AuthUserHashPointer causing assertation 
failure
+   - Bug 3345: support %un (any available user name) format code for 
external ACLs.
+   - basic_smb_auth: Fix several old issues identified by Debian users
+   - Support ssl-bump splicing to origin cache_peer
+   - Fix SSL errors relayed using invalid certificates
+   - Fix crash in TcpAccepter with profiler enabled
+   - Fix some cases of ssl_crtd SSL certificate DB corruption
+   - Fix performance regression in SBuf::chop operations
+   - Improve handling of client connections on shutdown
+   - Handle exceptions during squid.conf parse
+   - Make pod2man an optional dependency
+   - ... and polishing for several cache.log notification messages
+   - ... and all fixes from squid 3.4.14
+
 Changes to squid-3.5.6 (03 Jul 2015):
 
- Bug 4274: ssl_crtd.8 not being installed
@@ -182,6 +200,10 @@
- ... and many error page translation updates
- ... and much code cleanup and polishing
 
+Changes to squid-3.4.14 (01 Aug 2015):
+
+   - Do not blindly forward cache peer CONNECT responses (CVE-2015-5400)
+
 Changes to squid-3.4.13 (01 May 2015):
 
- Bug 4212: ssl_crtd crashes with corrupt database
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude 

commit c_count for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package c_count for openSUSE:Factory checked 
in at 2015-08-07 00:24:15

Comparing /work/SRC/openSUSE:Factory/c_count (Old)
 and  /work/SRC/openSUSE:Factory/.c_count.new (New)


Package is c_count

Changes:

--- /work/SRC/openSUSE:Factory/c_count/c_count.changes  2014-12-25 
23:20:26.0 +0100
+++ /work/SRC/openSUSE:Factory/.c_count.new/c_count.changes 2015-08-07 
00:24:16.0 +0200
@@ -1,0 +2,11 @@
+Wed Aug  5 14:43:33 UTC 2015 - mplus...@suse.com
+
+- Update to 7.16
+  * add configure option --with-man2html
+  * updated configure macros
+  * update config.guess and config.sub
+- Add gpg signature
+- Cleanup spec file with spec-cleaner
+- Update dependencies
+
+---

Old:

  c_count-7.15.tgz

New:

  c_count-7.16.tgz
  c_count-7.16.tgz.asc
  c_count.keyring



Other differences:
--
++ c_count.spec ++
--- /var/tmp/diff_new_pack.SJU0vK/_old  2015-08-07 00:24:17.0 +0200
+++ /var/tmp/diff_new_pack.SJU0vK/_new  2015-08-07 00:24:17.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package c_count
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2012 Pascal Bleser pascal.ble...@opensuse.org
 #
 # All modifications and additions to the file contributed by third parties
@@ -18,19 +18,17 @@
 
 
 Name:   c_count
-Version:7.15
+Version:7.16
 Release:0
 Summary:Source Code Measure Counter for C/C++/Java
 License:MIT
 Group:  Development/Tools/Other
 Url:http://invisible-island.net/c_count/
-Source: ftp://invisible-island.net/c_count/%{name}-%{version}.tgz
+Source0:ftp://invisible-island.net/c_count/%{name}-%{version}.tgz
+Source1:ftp://invisible-island.net/c_count/%{name}-%{version}.tgz.asc
+Source2:%{name}.keyring
 BuildRequires:  autoconf
 BuildRequires:  automake
-BuildRequires:  gcc
-BuildRequires:  glibc-devel
-BuildRequires:  libtool
-BuildRequires:  make
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -42,6 +40,7 @@
 %setup -q
 
 %build
+autoreconf -fiv
 %configure \
 --enable-warnings
 
@@ -59,6 +58,6 @@
 %defattr(-,root,root)
 %doc COPYING CHANGES README
 %{_bindir}/c_count
-%doc %{_mandir}/man1/c_count.1%{ext_man}
+%{_mandir}/man1/c_count.1%{ext_man}
 
 %changelog

++ c_count-7.15.tgz - c_count-7.16.tgz ++
 4316 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/c_count-7.15/CHANGES new/c_count-7.16/CHANGES
--- old/c_count-7.15/CHANGES2014-09-22 21:59:25.0 +0200
+++ new/c_count-7.16/CHANGES2015-07-06 01:51:08.0 +0200
@@ -1,4 +1,11 @@
--- $Id: CHANGES,v 7.29 2014/09/22 19:59:25 tom Exp $
+-- $Id: CHANGES,v 7.30 2015/07/05 23:51:08 tom Exp $
+
+2015/07/05 (c_count 7.16)
+   + add configure option --with-man2html
+
+   + updated configure macros
+
+   + update config.guess and config.sub
 
 2014/09/22 (c_count 7.15)
+ ensure that parse-state returns to code after a comment is
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/c_count-7.15/COPYING new/c_count-7.16/COPYING
--- old/c_count-7.15/COPYING2014-09-22 22:03:24.0 +0200
+++ new/c_count-7.16/COPYING2015-07-06 01:55:16.0 +0200
@@ -1,10 +1,10 @@
-$Id: COPYING,v 7.10 2014/09/22 20:03:24 tom Exp $
+$Id: COPYING,v 7.11 2015/07/05 23:55:16 tom Exp $
 
 C_COUNT
 
 

 
-Copyright 1985-2013,2014 by Thomas E. Dickey
+Copyright 1985-2014,2015 by Thomas E. Dickey
 All Rights Reserved.
 
 Permission to use, copy, modify, and distribute this software and its
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/c_count-7.15/MANIFEST new/c_count-7.16/MANIFEST
--- 

commit afl for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package afl for openSUSE:Factory checked in 
at 2015-08-07 00:24:04

Comparing /work/SRC/openSUSE:Factory/afl (Old)
 and  /work/SRC/openSUSE:Factory/.afl.new (New)


Package is afl

Changes:

--- /work/SRC/openSUSE:Factory/afl/afl.changes  2015-06-16 14:05:18.0 
+0200
+++ /work/SRC/openSUSE:Factory/.afl.new/afl.changes 2015-08-07 
00:24:05.0 +0200
@@ -1,0 +2,16 @@
+Wed Aug  5 13:46:26 UTC 2015 - mplus...@suse.com
+
+- Update to 1.85b
+  * Fixed a garbled sentence in notes on parallel fuzzing.
+  * Fixed a minor glitch in afl-cmin.
+- Changes for 1.84b
+  * Made SIMPLE_FILES behave as expected when naming backup 
+directories for crashes and hangs.
+  * Added the total number of favored paths to fuzzer_stats.
+  * Made afl-tmin, afl-fuzz, and afl-cmin reject negative values 
+passed to -t and -m, since they generally won't work as 
+expected.
+  * Made a fix for no lahf / sahf support on older versions of 
+FreeBSD.
+
+---

Old:

  afl-1.83b.tgz

New:

  afl-1.85b.tgz



Other differences:
--
++ afl.spec ++
--- /var/tmp/diff_new_pack.H94HV9/_old  2015-08-07 00:24:06.0 +0200
+++ /var/tmp/diff_new_pack.H94HV9/_new  2015-08-07 00:24:06.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   afl
-Version:1.83b
+Version:1.85b
 Release:0
 Summary:American fuzzy lop is a security-oriented fuzzer
 License:Apache-2.0

++ afl-1.58b-fix-paths.patch ++
--- /var/tmp/diff_new_pack.H94HV9/_old  2015-08-07 00:24:06.0 +0200
+++ /var/tmp/diff_new_pack.H94HV9/_new  2015-08-07 00:24:06.0 +0200
@@ -2,11 +2,11 @@
  Makefile |4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)
 
-Index: afl-1.58b/Makefile
+Index: afl-1.85b/Makefile
 ===
 afl-1.58b.orig/Makefile2015-03-27 07:47:58.0 +0100
-+++ afl-1.58b/Makefile 2015-03-27 21:14:10.0 +0100
-@@ -18,8 +18,8 @@ VERSION = 1.58b
+--- afl-1.85b.orig/Makefile
 afl-1.85b/Makefile
+@@ -18,8 +18,8 @@ VERSION = 1.85b
  
  PREFIX ?= /usr/local
  BIN_PATH= $(PREFIX)/bin

++ afl-1.83b.tgz - afl-1.85b.tgz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/afl-1.83b/Makefile new/afl-1.85b/Makefile
--- old/afl-1.83b/Makefile  2015-06-14 16:34:26.0 +0200
+++ new/afl-1.85b/Makefile  2015-08-01 04:44:56.0 +0200
@@ -14,7 +14,7 @@
 #
 
 PROGNAME= afl
-VERSION = 1.83b
+VERSION = 1.85b
 
 PREFIX ?= /usr/local
 BIN_PATH= $(PREFIX)/bin
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/afl-1.83b/afl-as.h new/afl-1.85b/afl-as.h
--- old/afl-1.83b/afl-as.h  2015-06-11 08:33:07.0 +0200
+++ new/afl-1.85b/afl-as.h  2015-07-17 19:53:09.0 +0200
@@ -388,11 +388,11 @@
   \n
   __afl_maybe_log:\n
   \n
-#ifdef  __OpenBSD__
+#if defined(__OpenBSD__)  || (defined(__FreeBSD__)  (__FreeBSD__  9))
 .byte 0x9f /* lahf */\n
 #else
 lahf\n
-#endif /* ^__OpenBSD__ */
+#endif /* ^__OpenBSD__, etc */
 seto  %al\n
   \n
 /* Check if SHM region is already mapped. */\n
@@ -420,11 +420,11 @@
   __afl_return:\n
   \n
 addb $127, %al\n
-#ifdef  __OpenBSD__
+#if defined(__OpenBSD__)  || (defined(__FreeBSD__)  (__FreeBSD__  9))
 .byte 0x9e /* sahf */\n
 #else
 sahf\n
-#endif /* ^__OpenBSD__ */
+#endif /* ^__OpenBSD__, etc */
 ret\n
   \n
   .align 8\n
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/afl-1.83b/afl-cmin new/afl-1.85b/afl-cmin
--- old/afl-1.83b/afl-cmin  2015-06-14 16:33:53.0 +0200
+++ new/afl-1.85b/afl-cmin  2015-08-01 04:43:30.0 +0200
@@ -260,7 +260,7 @@
 
 if [ $STDIN_FILE =  ]; then
 
-  AFL_CMIN_ALLOW_ANY=1 $SHOWMAP -m $MEM_LIMIT -t $TIMEOUT -o 
$TRACE_DIR/.run_test -Z $EXTRA_PAR -- $@ $IN_DIR/$fn
+  AFL_CMIN_ALLOW_ANY=1 $SHOWMAP -m $MEM_LIMIT -t $TIMEOUT -o 
$TRACE_DIR/.run_test -Z $EXTRA_PAR -- $@ $IN_DIR/$FIRST_FILE
 
 else
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/afl-1.83b/afl-fuzz.c new/afl-1.85b/afl-fuzz.c
--- old/afl-1.83b/afl-fuzz.c2015-06-12 09:50:07.0 +0200
+++ new/afl-1.85b/afl-fuzz.c2015-07-04 21:36:50.0 +0200
@@ -3168,6 +3168,7 @@
  execs_done : %llu\n
  execs_per_sec  : %0.02f\n
  paths_total: %u\n
+ paths_favored  : %u\n
  paths_found: %u\n
  paths_imported : %u\n
  max_depth 

commit python-requests for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package python-requests for openSUSE:Factory 
checked in at 2015-08-07 00:24:44

Comparing /work/SRC/openSUSE:Factory/python-requests (Old)
 and  /work/SRC/openSUSE:Factory/.python-requests.new (New)


Package is python-requests

Changes:

--- /work/SRC/openSUSE:Factory/python-requests/python-requests.changes  
2015-08-01 11:37:15.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-requests.new/python-requests.changes 
2015-08-07 00:24:48.0 +0200
@@ -25 +25 @@
-- Update to 2.6.0:
+- Update to 2.6.0 (bsc#922448, CVE-2015-2296):
@@ -48 +48 @@
-- update to 2.5.2:
+- update to 2.5.2 (bsc#929736):



Other differences:
--



commit vegastrike for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package vegastrike for openSUSE:Factory 
checked in at 2015-08-07 00:24:26

Comparing /work/SRC/openSUSE:Factory/vegastrike (Old)
 and  /work/SRC/openSUSE:Factory/.vegastrike.new (New)


Package is vegastrike

Changes:

--- /work/SRC/openSUSE:Factory/vegastrike/vegastrike.changes2015-03-25 
10:00:58.0 +0100
+++ /work/SRC/openSUSE:Factory/.vegastrike.new/vegastrike.changes   
2015-08-07 00:24:27.0 +0200
@@ -1,0 +2,5 @@
+Mon May 11 22:00:04 UTC 2015 - dmuel...@suse.com
+
+- add vegastrike-aarch64.patch: Fix build for aarch64
+
+---

New:

  vegastrike-aarch64.patch



Other differences:
--
++ vegastrike.spec ++
--- /var/tmp/diff_new_pack.n5Vk2p/_old  2015-08-07 00:24:28.0 +0200
+++ /var/tmp/diff_new_pack.n5Vk2p/_new  2015-08-07 00:24:28.0 +0200
@@ -41,6 +41,7 @@
 Patch5: vegastrike-src-0.5.1.r1-libpng16.patch
 # PATCH-FIX-UPSTREAM vegastrike-src-0.5.1.r1-boost150_compat.patch -- fix 
build with latest boost (seemingly unrelated change but boost makes it blow 
without)
 Patch6: vegastrike-src-0.5.1.r1-boost150_compat.patch
+Patch7: vegastrike-aarch64.patch
 BuildRequires:  SDL_mixer-devel
 BuildRequires:  boost-devel
 BuildRequires:  freealut-devel
@@ -100,6 +101,7 @@
 %patch4 -p0
 %patch5 -p0
 %patch6 -p1
+%patch7 -p1
 iconv -f ISO-8859-1 -t UTF-8 README  README.tmp
 touch -r README README.tmp
 mv README.tmp README

++ _constraints ++
--- /var/tmp/diff_new_pack.n5Vk2p/_old  2015-08-07 00:24:28.0 +0200
+++ /var/tmp/diff_new_pack.n5Vk2p/_new  2015-08-07 00:24:28.0 +0200
@@ -1,7 +1,7 @@
 constraints
   hardware
 memory
-  size unit=M4096/size
+  size unit=M4000/size
 /memory
   /hardware
 /constraints

++ vegastrike-aarch64.patch ++
--- a/src/posh.h
+++ b/src/posh.h
@@ -572,6 +572,18 @@
 #  endif
 #endif
 
+/* --
+** AArch64
+** --
+*/
+#if defined __aarch64__ || defined __arm64__ || defined FORCE_DOXYGEN
+#  define POSH_CPU_AARCH64 /**if defined, target CPU is AArch64 */
+#  if !defined FORCE_DOXYGEN
+# define POSH_CPU_STRING AArch64
+#  endif
+#endif
+
+
 /** @} */
 
 #if !defined POSH_CPU_STRING



commit perl-Devel-NYTProf for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package perl-Devel-NYTProf for 
openSUSE:Factory checked in at 2015-08-07 00:24:34

Comparing /work/SRC/openSUSE:Factory/perl-Devel-NYTProf (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Devel-NYTProf.new (New)


Package is perl-Devel-NYTProf

Changes:

--- /work/SRC/openSUSE:Factory/perl-Devel-NYTProf/perl-Devel-NYTProf.changes
2015-04-18 10:40:31.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Devel-NYTProf.new/perl-Devel-NYTProf.changes   
2015-08-07 00:24:36.0 +0200
@@ -1,0 +2,13 @@
+Wed Aug  5 08:40:53 UTC 2015 - co...@suse.com
+
+- updated to 6.02
+   see /usr/share/doc/packages/perl-Devel-NYTProf/Changes
+
+  =head2 Changes in Devel::NYTProf 6.02 - 2nd August 2015
+  
+FlameGraphs upgraded the latest version, which supports searching.
+Use JSON::MaybeXS instead of JSON::Any (deprecated), thanks to Ether #73
+Updated metacpan urls, thanks to Ether #74
+Internal context optimizations, thanks to jandubois #75
+
+---

Old:

  Devel-NYTProf-6.01.tar.gz

New:

  Devel-NYTProf-6.02.tar.gz



Other differences:
--
++ perl-Devel-NYTProf.spec ++
--- /var/tmp/diff_new_pack.DmArix/_old  2015-08-07 00:24:37.0 +0200
+++ /var/tmp/diff_new_pack.DmArix/_new  2015-08-07 00:24:37.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Devel-NYTProf
-Version:6.01
+Version:6.02
 Release:0
 %define cpan_name Devel-NYTProf
 Summary:Powerful fast feature-rich Perl source code profiler
@@ -30,11 +30,11 @@
 BuildRequires:  perl
 BuildRequires:  perl-macros
 BuildRequires:  perl(File::Which) = 1.09
-BuildRequires:  perl(JSON::Any)
+BuildRequires:  perl(JSON::MaybeXS)
 BuildRequires:  perl(Test::Differences) = 0.60
 BuildRequires:  perl(Test::More) = 0.84
 Requires:   perl(File::Which) = 1.09
-Requires:   perl(JSON::Any)
+Requires:   perl(JSON::MaybeXS)
 Requires:   perl(Test::Differences) = 0.60
 Requires:   perl(Test::More) = 0.84
 %{perl_requires}

++ Devel-NYTProf-6.01.tar.gz - Devel-NYTProf-6.02.tar.gz ++
 1843 lines of diff (skipped)




commit rubygem-js-routes for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package rubygem-js-routes for 
openSUSE:Factory checked in at 2015-08-07 00:24:32

Comparing /work/SRC/openSUSE:Factory/rubygem-js-routes (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-js-routes.new (New)


Package is rubygem-js-routes

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-js-routes/rubygem-js-routes.changes  
2015-04-25 11:25:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-js-routes.new/rubygem-js-routes.changes 
2015-08-07 00:24:35.0 +0200
@@ -1,0 +2,19 @@
+Thu Aug  6 04:30:03 UTC 2015 - co...@suse.com
+
+- updated to version 1.1.0
+ see installed CHANGELOG.md
+
+  ## v1.1.0
+  
+  * Ensure routes are loaded, prior to generating them 
[#148](https://github.com/railsware/js-routes/pull/148)
+  * Use `flat_map` rather than `map{...}.flatten` 
[#149](https://github.com/railsware/js-routes/pull/149)
+  * URL escape routes.rb url to fix bad URI(is not URI?) error 
[#150](https://github.com/railsware/js-routes/pull/150)
+  * Fix for rails 5 - test rails-edge on travis allowing failure 
[#151](https://github.com/railsware/js-routes/pull/151)
+  * Adds `serializer` option 
[#155](https://github.com/railsware/js-routes/pull/155/files)
+  
+  ## v1.0.1
+  
+  * Support sprockets-3
+  * Performance optimization of include/exclude options
+
+---

Old:

  js-routes-1.0.1.gem

New:

  js-routes-1.1.0.gem



Other differences:
--
++ rubygem-js-routes.spec ++
--- /var/tmp/diff_new_pack.o0ZHPF/_old  2015-08-07 00:24:36.0 +0200
+++ /var/tmp/diff_new_pack.o0ZHPF/_new  2015-08-07 00:24:36.0 +0200
@@ -24,7 +24,7 @@
 #
 
 Name:   rubygem-js-routes
-Version:1.0.1
+Version:1.1.0
 Release:0
 %define mod_name js-routes
 %define mod_full_name %{mod_name}-%{version}

++ js-routes-1.0.1.gem - js-routes-1.1.0.gem ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/.travis.yml new/.travis.yml
--- old/.travis.yml 2015-04-17 11:13:09.0 +0200
+++ new/.travis.yml 2015-08-05 10:59:04.0 +0200
@@ -13,10 +13,10 @@
 gemfile:
   - gemfiles/rails32.gemfile
   - gemfiles/rails40.gemfile
-  - gemfiles/rails41.gemfile
-  - gemfiles/rails42.gemfile
   - gemfiles/rails40_sprockets3.gemfile
+  - gemfiles/rails41.gemfile
   - gemfiles/rails41_sprockets3.gemfile
+  - gemfiles/rails42.gemfile
   - gemfiles/rails42_sprockets3.gemfile
 
 sudo: false
@@ -30,7 +30,12 @@
 - master
 
 matrix:
+  include:
+- gemfile: gemfiles/rails_edge.gemfile
+  rvm: 2.2
   allow_failures:
 - rvm: jruby-19mode
 - rvm: ruby-head
 - rvm: jruby-head
+- gemfile: gemfiles/rails_edge.gemfile
+  rvm: 2.2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Appraisals new/Appraisals
--- old/Appraisals  2015-04-17 11:13:09.0 +0200
+++ new/Appraisals  2015-08-05 10:59:04.0 +0200
@@ -3,7 +3,7 @@
   gem 'tzinfo'
 end
 
-{rails40: '4.0.5', rails41: '4.1.1', rails42: '4.2.0'}.each do |rails, version|
+{rails40: '4.0.5', rails41: '4.1.1', rails42: '4.2.1'}.each do |rails, version|
   appraise #{rails} do
 gem railties, ~ #{version}
 gem sprockets,  3
@@ -14,3 +14,8 @@
 gem sprockets, ~ 3.0
   end
 end
+
+appraise rails-edge do
+  gem railties, github: 'rails/rails'
+  gem sprockets, ~ 3.0
+end
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CHANGELOG.md new/CHANGELOG.md
--- old/CHANGELOG.md2015-04-17 11:13:09.0 +0200
+++ new/CHANGELOG.md2015-08-05 10:59:04.0 +0200
@@ -1,5 +1,18 @@
 ## master
 
+## v1.1.0
+
+* Ensure routes are loaded, prior to generating them 
[#148](https://github.com/railsware/js-routes/pull/148)
+* Use `flat_map` rather than `map{...}.flatten` 
[#149](https://github.com/railsware/js-routes/pull/149)
+* URL escape routes.rb url to fix bad URI(is not URI?) error 
[#150](https://github.com/railsware/js-routes/pull/150)
+* Fix for rails 5 - test rails-edge on travis allowing failure 
[#151](https://github.com/railsware/js-routes/pull/151)
+* Adds `serializer` option 
[#155](https://github.com/railsware/js-routes/pull/155/files)
+
+## v1.0.1
+
+* Support sprockets-3
+* Performance optimization of include/exclude options
+
 ## v1.0.0
 
  * Add the compact mode [#125](https://github.com/railsware/js-routes/pull/125)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Readme.md new/Readme.md
--- old/Readme.md   2015-04-17 11:13:09.0 +0200
+++ new/Readme.md   2015-08-05 10:59:04.0 

commit byacc for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package byacc for openSUSE:Factory checked 
in at 2015-08-07 00:24:23

Comparing /work/SRC/openSUSE:Factory/byacc (Old)
 and  /work/SRC/openSUSE:Factory/.byacc.new (New)


Package is byacc

Changes:

--- /work/SRC/openSUSE:Factory/byacc/byacc.changes  2015-03-01 
14:46:51.0 +0100
+++ /work/SRC/openSUSE:Factory/.byacc.new/byacc.changes 2015-08-07 
00:24:25.0 +0200
@@ -1,0 +2,6 @@
+Wed Aug  5 14:39:02 UTC 2015 - mplus...@suse.com
+
+- Update to 20150711
+  * See attached CHANGES for complete list of changes
+
+---

Old:

  byacc-20141128.tgz
  byacc-20141128.tgz.asc

New:

  byacc-20150711.tgz
  byacc-20150711.tgz.asc



Other differences:
--
++ byacc.spec ++
--- /var/tmp/diff_new_pack.xnDDsh/_old  2015-08-07 00:24:26.0 +0200
+++ /var/tmp/diff_new_pack.xnDDsh/_new  2015-08-07 00:24:26.0 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   byacc
-Version:20141128
+Version:20150711
 Release:0
 Summary:LALR(1) parser generator
 License:SUSE-Public-Domain

++ byacc-20141128.tgz - byacc-20150711.tgz ++
 5204 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/byacc-20141128/CHANGES new/byacc-20150711/CHANGES
--- old/byacc-20141128/CHANGES  2014-11-28 16:46:42.0 +0100
+++ new/byacc-20150711/CHANGES  2015-07-11 02:53:38.0 +0200
@@ -1,3 +1,38 @@
+2015-07-10  Thomas E. Dickey  t...@invisible-island.net
+
+   * lr0.c: fix a duplicate-free in the leak-checking
+
+   * VERSION, package/byacc.spec, package/debian/changelog, 
package/mingw-byacc.spec, package/pkgsrc/Makefile:
+   bump
+
+   * reader.c:
+   make cache-size clearer (prompted by discussion with Pedro Giffuni,
+   Oliver Pinter)
+
+   * main.c:
+   make relationship with format/size clearer (prompted by discussion
+   with Pedro Giffuni, Oliver Pinter)
+
+2015-07-05  Thomas E. Dickey  t...@invisible-island.net
+
+   * configure: regen
+
+   * package/pkgsrc/Makefile, package/mingw-byacc.spec, 
package/debian/copyright, package/debian/changelog, package/byacc.spec, VERSION:
+   bump
+
+   * aclocal.m4: resync with my-autoconf
+   add configure option --with-man2html
+
+   * makefile.in: add configure options --with-man2html
+
+   * configure.in: add configure option --with-man2html
+
+2015-05-02  Thomas E. Dickey  t...@invisible-island.net
+
+   * config.guess: 2015-03-04
+
+   * config.sub: 2015-03-08
+
 2014-11-28  Thomas E. Dickey  t...@invisible-island.net
 
* lr0.c: coverity #39181: memory leak
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/byacc-20141128/MANIFEST new/byacc-20150711/MANIFEST
--- old/byacc-20141128/MANIFEST 2014-11-28 16:42:17.0 +0100
+++ new/byacc-20150711/MANIFEST 2015-07-11 02:53:15.0 +0200
@@ -1,4 +1,4 @@
-MANIFEST for byacc-20141128, version t20141128
+MANIFEST for byacc-20150711, version t20150711
 

 MANIFESTthis file
 ACKNOWLEDGEMENTSoriginal version of byacc - 1993
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/byacc-20141128/VERSION new/byacc-20150711/VERSION
--- old/byacc-20141128/VERSION  2014-11-28 16:42:17.0 +0100
+++ new/byacc-20150711/VERSION  2015-07-11 02:53:15.0 +0200
@@ -1 +1 @@
-20141128
+20150711
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/byacc-20141128/configure.in new/byacc-20150711/configure.in
--- old/byacc-20141128/configure.in 2014-10-07 

commit lua52 for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package lua52 for openSUSE:Factory checked 
in at 2015-08-07 00:24:28

Comparing /work/SRC/openSUSE:Factory/lua52 (Old)
 and  /work/SRC/openSUSE:Factory/.lua52.new (New)


Package is lua52

Changes:

--- /work/SRC/openSUSE:Factory/lua52/lua52.changes  2015-07-19 
11:45:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.lua52.new/lua52.changes 2015-08-07 
00:24:28.0 +0200
@@ -1,0 +2,5 @@
+Fri Jul 31 18:12:35 UTC 2015 - jeng...@inai.de
+
+- Update RPM group classification
+
+---



Other differences:
--
++ lua52.spec ++
--- /var/tmp/diff_new_pack.7R3qJV/_old  2015-08-07 00:24:29.0 +0200
+++ /var/tmp/diff_new_pack.7R3qJV/_new  2015-08-07 00:24:29.0 +0200
@@ -23,7 +23,7 @@
 Release:0
 Summary:Small Embeddable Language with Simple Procedural Syntax
 License:MIT
-Group:  System/Libraries
+Group:  Development/Languages/Other
 Url:http://www.lua.org
 Source: http://www.lua.org/ftp/lua-%{version}.tar.gz
 Source1:macros.lua
@@ -71,7 +71,7 @@
 application.
 
 %package -n liblua%{libsuf}
-Summary:Small Embeddable Language with Simple Procedural Syntax
+Summary:The Lua integration library
 Group:  System/Libraries
 Provides:   %{name}-libs = %{version}
 Obsoletes:  %{name}-libs  %{version}
@@ -90,8 +90,8 @@
 simplicity, efficiency, portability, and low embedding cost.
 
 %package doc
-Summary:Small Embeddable Language with Simple Procedural Syntax
-Group:  System/Libraries
+Summary:Documentation for lua, a small embeddable language
+Group:  Documentation/HTML
 %if 0%{?suse_version} = 1120
 BuildArch:  noarch
 %endif




commit bmake for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package bmake for openSUSE:Factory checked 
in at 2015-08-07 00:24:19

Comparing /work/SRC/openSUSE:Factory/bmake (Old)
 and  /work/SRC/openSUSE:Factory/.bmake.new (New)


Package is bmake

Changes:

--- /work/SRC/openSUSE:Factory/bmake/bmake.changes  2015-05-18 
22:27:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.bmake.new/bmake.changes 2015-08-07 
00:24:21.0 +0200
@@ -1,0 +2,7 @@
+Wed Aug  5 14:12:57 UTC 2015 - mplus...@suse.com
+
+- Update to 20150606
+  * Merge with NetBSD make, pick up
++ o make.1: document .OBJDIR target
+
+---

Old:

  bmake-20150505.tar.gz

New:

  bmake-20150606.tar.gz



Other differences:
--
++ bmake.spec ++
--- /var/tmp/diff_new_pack.TAW0mm/_old  2015-08-07 00:24:22.0 +0200
+++ /var/tmp/diff_new_pack.TAW0mm/_new  2015-08-07 00:24:22.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   bmake
-Version:20150505
+Version:20150606
 Release:0
 Summary:The NetBSD make(1) tool
 License:BSD-2-Clause and BSD-3-Clause and BSD-4-Clause

++ bmake-20150505.tar.gz - bmake-20150606.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/ChangeLog new/bmake/ChangeLog
--- old/bmake/ChangeLog 2015-05-05 23:58:16.0 +0200
+++ new/bmake/ChangeLog 2015-06-07 18:07:34.0 +0200
@@ -1,3 +1,9 @@
+2015-06-06  Simon J. Gerraty  s...@bad.crufty.net
+
+   * Makefile (MAKE_VERSION): 20150606
+ Merge with NetBSD make, pick up
+ o make.1: document .OBJDIR target
+
 2015-05-05  Simon J. Gerraty  s...@bad.crufty.net
 
* Makefile (MAKE_VERSION): 20150505
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/Makefile new/bmake/Makefile
--- old/bmake/Makefile  2015-05-05 23:58:16.0 +0200
+++ new/bmake/Makefile  2015-06-07 18:07:34.0 +0200
@@ -1,7 +1,7 @@
-#  $Id: Makefile,v 1.38 2015/05/05 21:58:05 sjg Exp $
+#  $Id: Makefile,v 1.39 2015/06/07 15:54:37 sjg Exp $
 
 # Base version on src date
-MAKE_VERSION= 20150505
+MAKE_VERSION= 20150606
 
 PROG=  bmake
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/bmake.1 new/bmake/bmake.1
--- old/bmake/bmake.1   2015-04-10 19:50:10.0 +0200
+++ new/bmake/bmake.1   2015-06-07 19:14:20.0 +0200
@@ -1,4 +1,4 @@
-.\$NetBSD: make.1,v 1.247 2015/04/10 08:43:32 wiz Exp $
+.\$NetBSD: make.1,v 1.249 2015/06/05 07:33:40 wiz Exp $
 .\
 .\ Copyright (c) 1990, 1993
 .\The Regents of the University of California.  All rights reserved.
@@ -29,7 +29,7 @@
 .\
 .\from: @(#)make.18.4 (Berkeley) 3/19/94
 .\
-.Dd April 9, 2015
+.Dd June 4, 2015
 .Dt MAKE 1
 .Os
 .Sh NAME
@@ -993,14 +993,15 @@
 .Ql Ev MAKEOBJDIR .
 .Pp
 .Ql Va .OBJDIR
-may be modified in the makefile as a global variable.
+may be modified in the makefile via the special target
+.Ql Ic .OBJDIR .
 In all cases,
 .Nm
 will
 .Xr chdir 2
-to
+to the specified directory if it exists, and set
 .Ql Va .OBJDIR
-and set
+and
 .Ql Ev PWD
 to that directory before executing any targets.
 .
@@ -2001,6 +2002,15 @@
 Synonym for
 .Ic .NOTPARALLEL ,
 for compatibility with other pmake variants.
+.It Ic .OBJDIR
+The source is a new value for
+.Ql Va .OBJDIR .
+If it exists,
+.Nm
+will
+.Xr chdir 2
+to it and update the value of
+.Ql Va .OBJDIR .
 .It Ic .ORDER
 The named targets are made in sequence.
 This ordering does not add targets to the list of targets to be made.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/bmake.cat1 new/bmake/bmake.cat1
--- old/bmake/bmake.cat12015-04-10 19:50:10.0 +0200
+++ new/bmake/bmake.cat12015-06-07 19:14:20.0 +0200
@@ -647,10 +647,10 @@
  may be used.  This is especially useful with
  `MAKEOBJDIR'.
 
- `_._O_B_J_D_I_R' may be modified in the makefile 
as a global
- variable.  In all cases, bbmmaakkee will chdir(2) to 
`_._O_B_J_D_I_R'
- and set `PWD' to that directory before executing any tar-
- gets.
+ `_._O_B_J_D_I_R' may be modified in the makefile 
via the special
+ target `..OOBBJJDDIIRR'.  In all cases, 
bbmmaakkee will chdir(2) to
+ the specified directory if it exists, and set 
`_._O_B_J_D_I_R'
+ and `PWD' to that directory before executing any targets.
 
  

commit dvbtune for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package dvbtune for openSUSE:Factory checked 
in at 2015-08-07 00:24:38

Comparing /work/SRC/openSUSE:Factory/dvbtune (Old)
 and  /work/SRC/openSUSE:Factory/.dvbtune.new (New)


Package is dvbtune

Changes:

--- /work/SRC/openSUSE:Factory/dvbtune/dvbtune.changes  2014-10-18 
09:09:12.0 +0200
+++ /work/SRC/openSUSE:Factory/.dvbtune.new/dvbtune.changes 2015-08-07 
00:24:39.0 +0200
@@ -1,0 +2,8 @@
+Thu Aug  6 06:27:03 UTC 2015 - mplus...@suse.com
+
+- Use url for source
+- Do not use cvs snapshot but released version
+- Cleanup spec file with spec-cleaner
+- Refresh dvbtune-use-rpmopts
+
+---

Old:

  dvbtune-cvs.tar.bz2

New:

  dvbtune-0.5.tar.gz



Other differences:
--
++ dvbtune.spec ++
--- /var/tmp/diff_new_pack.IakyR0/_old  2015-08-07 00:24:40.0 +0200
+++ /var/tmp/diff_new_pack.IakyR0/_new  2015-08-07 00:24:40.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package dvbtune
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,11 +23,11 @@
 License:GPL-2.0+
 Group:  Hardware/TV
 Url:http://www.linuxstb.org/dvbtune/index.shtml
-Source: %name-cvs.tar.bz2
-Patch:  %name-use-rpmopts
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+Source0:
http://sourceforge.net/projects/dvbtools/files/dvbtune/dvbtune-%{version}/dvbtune-%{version}.tar.gz
+Patch0: dvbtune-use-rpmopts
 BuildRequires:  dvb
 BuildRequires:  libxml2-devel
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 DVBtune is a tuning application for DVB cards supported by the Linux
@@ -45,33 +45,26 @@
 xml2vdr can convert this XML file into a channels.conf file suitable
 for use with the VDR application.
 
-
-
-Authors:
-
-David Chapman d...@dchapman.com
-
 %prep
-%setup -n dvbtune-cvs
-rm -rf scripts/CVS
-%patch -p1
+%setup -q
+%patch0 -p1
 
 %build
 # This package failed when testing with -Wl,-as-needed being default.
 # So we disable it here, if you want to retest, just delete this comment and 
the line below.
 export SUSE_ASNEEDED=0
 make %{?_smp_mflags}
-make xml2vdr
+make %{?_smp_mflags} xml2vdr
 
 %install
 bins=dvbtune xml2vdr
-mkdir -p $RPM_BUILD_ROOT/usr/bin
-install -m 755 $bins $RPM_BUILD_ROOT/usr/bin
+mkdir -p %{buildroot}%{_prefix}/bin
+install -m 755 $bins %{buildroot}%{_prefix}/bin
 
 %files
 %defattr(-,root,root)
 %doc README scripts
-/usr/bin/dvbtune
-/usr/bin/xml2vdr
+%{_bindir}/dvbtune
+%{_bindir}/xml2vdr
 
 %changelog

++ dvbtune-use-rpmopts ++
--- /var/tmp/diff_new_pack.IakyR0/_old  2015-08-07 00:24:40.0 +0200
+++ /var/tmp/diff_new_pack.IakyR0/_new  2015-08-07 00:24:40.0 +0200
@@ -1,9 +1,11 @@
 dvbtune-cvs/Makefile.orig  2005-11-14 15:41:25.0 +0100
-+++ dvbtune-cvs/Makefile   2005-11-14 16:06:59.0 +0100
+Index: dvbtune-0.5/Makefile
+===
+--- dvbtune-0.5.orig/Makefile
 dvbtune-0.5/Makefile
 @@ -1,5 +1,5 @@
  INCS=-I /usr/include/libxml2
 -CFLAGS= -Wall $(INCS)
 +CFLAGS= -Wall $(RPM_OPT_FLAGS) $(INCS)
- LDFLAGS=-lxml2
  CC=gcc
  all: dvbtune
+ 




commit global for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package global for openSUSE:Factory checked 
in at 2015-08-07 00:24:17

Comparing /work/SRC/openSUSE:Factory/global (Old)
 and  /work/SRC/openSUSE:Factory/.global.new (New)


Package is global

Changes:

--- /work/SRC/openSUSE:Factory/global/global.changes2015-05-24 
19:32:08.0 +0200
+++ /work/SRC/openSUSE:Factory/.global.new/global.changes   2015-08-07 
00:24:19.0 +0200
@@ -1,0 +2,6 @@
+Wed Aug  5 14:59:27 UTC 2015 - mplus...@suse.com
+
+- Update to 6.5
+  * See attached NEWS for detailed list of changes
+
+---

Old:

  global-6.4.tar.gz
  global-6.4.tar.gz.sig

New:

  global-6.5.tar.gz
  global-6.5.tar.gz.sig



Other differences:
--
++ global.spec ++
--- /var/tmp/diff_new_pack.xQaUQe/_old  2015-08-07 00:24:20.0 +0200
+++ /var/tmp/diff_new_pack.xQaUQe/_new  2015-08-07 00:24:20.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   global
-Version:6.4
+Version:6.5
 Release:0
 Summary:Common source code tag system
 License:GPL-3.0
@@ -52,9 +52,9 @@
 %patch0 -p1
 %patch1 -p1
 %patch3 -p1
-autoreconf -fi
 
 %build
+autoreconf -fiv
 %configure \
--disable-static \
--with-sqlite3 \

++ global-5.7-gcc.diff ++
--- /var/tmp/diff_new_pack.xQaUQe/_old  2015-08-07 00:24:20.0 +0200
+++ /var/tmp/diff_new_pack.xQaUQe/_new  2015-08-07 00:24:20.0 +0200
@@ -2,10 +2,10 @@
  htags/lexcommon.h |2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-Index: global-6.3.2/htags/lexcommon.h
+Index: global-6.5/htags/lexcommon.h
 ===
 global-6.3.2.orig/htags/lexcommon.h
-+++ global-6.3.2/htags/lexcommon.h
+--- global-6.5.orig/htags/lexcommon.h
 global-6.5/htags/lexcommon.h
 @@ -55,7 +55,7 @@ to generate language specific symbols.
   * It assumed that @VAR{CPP_COMMENT} and @VAR{SHELL_COMMENT} is one line 
comment.
   */

++ global-5.7.diff ++
--- /var/tmp/diff_new_pack.xQaUQe/_old  2015-08-07 00:24:20.0 +0200
+++ /var/tmp/diff_new_pack.xQaUQe/_new  2015-08-07 00:24:20.0 +0200
@@ -2,10 +2,10 @@
  Makefile.am |2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-Index: global-6.4/Makefile.am
+Index: global-6.5/Makefile.am
 ===
 global-6.4.orig/Makefile.am
-+++ global-6.4/Makefile.am
+--- global-6.5.orig/Makefile.am
 global-6.5/Makefile.am
 @@ -20,7 +20,7 @@ if USE_GTAGSCSCOPE
  SUBDIRS += gtags-cscope
  endif

++ global-5.9.5-fix-gcc-warnings.patch ++
--- /var/tmp/diff_new_pack.xQaUQe/_old  2015-08-07 00:24:20.0 +0200
+++ /var/tmp/diff_new_pack.xQaUQe/_new  2015-08-07 00:24:20.0 +0200
@@ -2,10 +2,10 @@
  gtags-cscope/exec.c |1 +
  1 file changed, 1 insertion(+)
 
-Index: global-6.3.2/gtags-cscope/exec.c
+Index: global-6.5/gtags-cscope/exec.c
 ===
 global-6.3.2.orig/gtags-cscope/exec.c
-+++ global-6.3.2/gtags-cscope/exec.c
+--- global-6.5.orig/gtags-cscope/exec.c
 global-6.5/gtags-cscope/exec.c
 @@ -135,6 +135,7 @@ myexecvp(char *a, char **args)
  askforreturn();   /* wait until the user sees the message */
  myexit(1);/* exit the child */

++ global-6.4.tar.gz - global-6.5.tar.gz ++
 29345 lines of diff (skipped)





commit gst-rtsp-server for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package gst-rtsp-server for openSUSE:Factory 
checked in at 2015-08-07 00:24:01

Comparing /work/SRC/openSUSE:Factory/gst-rtsp-server (Old)
 and  /work/SRC/openSUSE:Factory/.gst-rtsp-server.new (New)


Package is gst-rtsp-server

Changes:

--- /work/SRC/openSUSE:Factory/gst-rtsp-server/gst-rtsp-server.changes  
2015-01-03 22:01:00.0 +0100
+++ /work/SRC/openSUSE:Factory/.gst-rtsp-server.new/gst-rtsp-server.changes 
2015-08-07 00:24:03.0 +0200
@@ -1,0 +2,7 @@
+Wed Aug  5 13:59:12 UTC 2015 - zai...@opensuse.org
+
+- Add grs-rtsp-fix-double-unlock-in_get_buffer_size.patch: Fixes an
+  abort when calling gst_rtsp_media_get_buffer_size() because of
+  double g_mutex_unlock () usage (bgo#745434).
+
+---

New:

  grs-rtsp-fix-double-unlock-in_get_buffer_size.patch



Other differences:
--
++ gst-rtsp-server.spec ++
--- /var/tmp/diff_new_pack.6Ui1GM/_old  2015-08-07 00:24:05.0 +0200
+++ /var/tmp/diff_new_pack.6Ui1GM/_new  2015-08-07 00:24:05.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gst-rtsp-server
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,6 +24,8 @@
 Group:  Productivity/Multimedia/Other
 Url:http://gstreamer.freedesktop.org/
 Source: 
http://gstreamer.freedesktop.org/src/gst-rtsp-server/%{name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM grs-rtsp-fix-double-unlock-in_get_buffer_size.patch 
bgo#745434 zai...@opensuse.org -- rtsp-media: fix double unlock in 
_get_buffer_size(). Patch from upstream git.
+Patch0: grs-rtsp-fix-double-unlock-in_get_buffer_size.patch
 BuildRequires:  gstreamer-plugins-good = 1.4.0
 BuildRequires:  pkgconfig(gobject-introspection-1.0) = 1.31.1
 BuildRequires:  pkgconfig(gstreamer-1.0) = 1.4.0
@@ -60,6 +62,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure

++ grs-rtsp-fix-double-unlock-in_get_buffer_size.patch ++
From 380be80184103a80435c5462c6a21d36e8683585 Mon Sep 17 00:00:00 2001
From: Gregor Boirie gregor.boi...@parrot.com
Date: Fri, 27 Feb 2015 17:45:42 +0100
Subject: rtsp-media: fix double unlock in _get_buffer_size()

Fixes an abort when calling gst_rtsp_media_get_buffer_size()
because of double g_mutex_unlock () usage.

https://bugzilla.gnome.org/show_bug.cgi?id=745434

diff --git a/gst/rtsp-server/rtsp-media.c b/gst/rtsp-server/rtsp-media.c
index 6b81e25..a464642 100644
--- a/gst/rtsp-server/rtsp-media.c
+++ b/gst/rtsp-server/rtsp-media.c
@@ -1083,7 +1083,7 @@ gst_rtsp_media_get_buffer_size (GstRTSPMedia * media)
 
   priv = media-priv;
 
-  g_mutex_unlock (priv-lock);
+  g_mutex_lock (priv-lock);
   res = priv-buffer_size;
   g_mutex_unlock (priv-lock);
 
-- 
cgit v0.10.2




commit htop for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package htop for openSUSE:Factory checked in 
at 2015-08-07 00:24:07

Comparing /work/SRC/openSUSE:Factory/htop (Old)
 and  /work/SRC/openSUSE:Factory/.htop.new (New)


Package is htop

Changes:

--- /work/SRC/openSUSE:Factory/htop/htop.changes2015-02-22 
17:26:32.0 +0100
+++ /work/SRC/openSUSE:Factory/.htop.new/htop.changes   2015-08-07 
00:24:08.0 +0200
@@ -1,0 +2,5 @@
+Sun Aug  2 16:21:35 UTC 2015 - mplus...@suse.com
+
+- Add scriplets for desktop file handling
+
+---



Other differences:
--
++ htop.spec ++
--- /var/tmp/diff_new_pack.QxDU9G/_old  2015-08-07 00:24:09.0 +0200
+++ /var/tmp/diff_new_pack.QxDU9G/_new  2015-08-07 00:24:09.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package htop
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,10 +26,13 @@
 Source0:
http://hisham.hm/htop/releases/%{version}/%{name}-%{version}.tar.gz
 Patch0: htop-desktop-file-fix-thoenig-01.patch
 Patch1: htop-stdgnu.patch
+BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  ncurses-devel
 BuildRequires:  python
 BuildRequires:  update-desktop-files
+Requires(post):   update-desktop-files
+Requires(postun): update-desktop-files
 Recommends: lsof
 Recommends: strace
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -46,7 +49,7 @@
 %patch1 -p1
 
 %build
-autoreconf -fi
+autoreconf -fiv
 %configure \
--enable-taskstats \
--enable-unicode \
@@ -59,6 +62,12 @@
 make DESTDIR=%{buildroot} install %{?_smp_mflags}
 %suse_update_desktop_file -i %{name} System Monitor
 
+%post
+%desktop_database_post
+
+%postun
+%desktop_database_postun
+
 %files
 %defattr(-,root,root)
 %doc COPYING




commit hawk2 for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package hawk2 for openSUSE:Factory checked 
in at 2015-08-07 00:24:41

Comparing /work/SRC/openSUSE:Factory/hawk2 (Old)
 and  /work/SRC/openSUSE:Factory/.hawk2.new (New)


Package is hawk2

Changes:

--- /work/SRC/openSUSE:Factory/hawk2/hawk2.changes  2015-08-05 
19:17:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.hawk2.new/hawk2.changes 2015-08-07 
00:24:46.0 +0200
@@ -1,0 +2,6 @@
+Thu Aug 06 06:51:54 UTC 2015 - kgronl...@suse.com
+
+- Update to version 1.0.0~alpha1+git.1438843863.671db31:
+  + Relax requirement for js-routes
+
+---

Old:

  hawk2-1.0.0~alpha1+git.1438696250.7574201.tar.bz2

New:

  hawk2-1.0.0~alpha1+git.1438843863.671db31.tar.bz2



Other differences:
--
++ hawk2.spec ++
--- /var/tmp/diff_new_pack.2XZuek/_old  2015-08-07 00:24:47.0 +0200
+++ /var/tmp/diff_new_pack.2XZuek/_new  2015-08-07 00:24:47.0 +0200
@@ -39,7 +39,7 @@
 Summary:HA Web Konsole
 License:GPL-2.0
 Group:  %{pkg_group}
-Version:1.0.0~alpha1+git.1438696250.7574201
+Version:1.0.0~alpha1+git.1438843863.671db31
 Release:0
 Url:http://www.clusterlabs.org/wiki/Hawk
 Source: %{name}-%{version}.tar.bz2
@@ -80,7 +80,7 @@
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:gettext_i18n_rails_js)
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:haml-rails) = 0.8.2
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:hashie) = 3.4
-BuildRequires:  rubygem(%{rb_default_ruby_abi}:js-routes)
+BuildRequires:  rubygem(%{rb_default_ruby_abi}:js-routes:1)
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:mail) = 2.6
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:mime-types) = 2.5
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:minitest) = 5.6
@@ -114,7 +114,7 @@
 Requires:   rubygem(%{rb_default_ruby_abi}:gettext_i18n_rails_js)
 Requires:   rubygem(%{rb_default_ruby_abi}:haml-rails) = 0.8.2
 Requires:   rubygem(%{rb_default_ruby_abi}:hashie) = 3.4
-Requires:   rubygem(%{rb_default_ruby_abi}:js-routes:1.0)
+Requires:   rubygem(%{rb_default_ruby_abi}:js-routes:1)
 Requires:   rubygem(%{rb_default_ruby_abi}:puma:2) = 2.11
 Requires:   rubygem(%{rb_default_ruby_abi}:rails:4.2)
 Requires:   rubygem(%{rb_default_ruby_abi}:sass-rails:5.0) = 5.0.1

++ _servicedata ++
--- /var/tmp/diff_new_pack.2XZuek/_old  2015-08-07 00:24:47.0 +0200
+++ /var/tmp/diff_new_pack.2XZuek/_new  2015-08-07 00:24:47.0 +0200
@@ -1,4 +1,4 @@
 servicedata
 service name=tar_scm
 param name=urlgit://github.com/ClusterLabs/hawk.git/param
-  param 
name=changesrevision7574201a02196ed5e00d96ed9e89c273bbedab5c/param/service/servicedata
\ No newline at end of file
+  param 
name=changesrevision671db31f634bc51092ee4eb9d6fef121f7aec5f6/param/service/servicedata
\ No newline at end of file

++ hawk2-1.0.0~alpha1+git.1438696250.7574201.tar.bz2 - 
hawk2-1.0.0~alpha1+git.1438843863.671db31.tar.bz2 ++
/work/SRC/openSUSE:Factory/hawk2/hawk2-1.0.0~alpha1+git.1438696250.7574201.tar.bz2
 
/work/SRC/openSUSE:Factory/.hawk2.new/hawk2-1.0.0~alpha1+git.1438843863.671db31.tar.bz2
 differ: char 11, line 1




commit gparted for openSUSE:Factory

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package gparted for openSUSE:Factory checked 
in at 2015-08-07 00:24:49

Comparing /work/SRC/openSUSE:Factory/gparted (Old)
 and  /work/SRC/openSUSE:Factory/.gparted.new (New)


Package is gparted

Changes:

--- /work/SRC/openSUSE:Factory/gparted/gparted.changes  2015-03-25 
10:01:53.0 +0100
+++ /work/SRC/openSUSE:Factory/.gparted.new/gparted.changes 2015-08-07 
00:24:50.0 +0200
@@ -1,0 +2,37 @@
+Wed Aug 05 09:04:33 UTC 2015 - joerg.loren...@ki.tng.de
+
+- Update to version 0.23.0:
+  + Add partition name to create dialog and enable online naming
+(relevant for GPT partitioned disk).
+  + Show serial number in device information.
+  + Add support for btrfs set new file system UUID.
+  + Prevent UI hang when resizing FAT16/32, HFS and HFS+ file
+systems.
+  + Bugs fixed:
+- Only set LVM partition flag on tables which support it
+  (bgo#746204).
+- Add partition name to create dialog and enable online naming
+  (bgo#746214).
+- Fix some operations fail after paste into existing partition
+  (bgo#746559).
+- Fix FileSystem object memory leaks in init_filesystems
+  (bgo#749036).
+- Fix arcane cylinder size adjustment when copying and resizing
+  (bgo#749867).
+- Reduce the amount of copying of partition objects
+  (bgo#750168).
+- Refactor LVM2_PV_Info module interface and cache
+  representation (bgo#750582).
+  - Adjust pointers to prevent crash resizing a logical
+partition (bgo#752587).
+- Show serial number in device information (bgo#751251).
+- Add support for btrfs set new file system UUID(bgo#751337).
+- Prevent UI hang when resizing FAT16/32, HFS and HFS+ file
+  systems (bgo#737022).
+- Add translation comments for code section setting partition
+  flag (bgo#752901).
+  + Updated translations.
+- Add hdparm requires: hdparm command is required for optional
+  display serial number device information.
+
+---

Old:

  gparted-0.22.0.tar.bz2
  gparted-0.22.0.tar.bz2.sig

New:

  gparted-0.23.0.tar.bz2
  gparted-0.23.0.tar.bz2.sig



Other differences:
--
++ gparted.spec ++
--- /var/tmp/diff_new_pack.mboebu/_old  2015-08-07 00:24:51.0 +0200
+++ /var/tmp/diff_new_pack.mboebu/_new  2015-08-07 00:24:51.0 +0200
@@ -17,15 +17,15 @@
 
 
 Name:   gparted
-Version:0.22.0
+Version:0.23.0
 Release:0
 Summary:Gnome Partition Editor
 License:GPL-2.0
 Group:  System/Filesystems
 Url:http://gparted.sourceforge.net/
-Source0:
http://downloads.sourceforge.net/project/gparted/gparted/gparted-0.22.0/%{name}-%{version}.tar.bz2
+Source0:
http://downloads.sourceforge.net/project/gparted/gparted/gparted-0.23.0/%{name}-%{version}.tar.bz2
 Source1:gparted.policy
-Source98:   
http://downloads.sourceforge.net/project/gparted/gparted/gparted-0.22.0/%{name}-%{version}.tar.bz2.sig
+Source98:   
http://downloads.sourceforge.net/project/gparted/gparted/gparted-0.23.0/%{name}-%{version}.tar.bz2.sig
 Source99:   %{name}.keyring
 BuildRequires:  e2fsprogs-devel
 BuildRequires:  fdupes
@@ -40,8 +40,9 @@
 BuildRequires:  translation-update-upstream
 BuildRequires:  update-desktop-files
 BuildRequires:  xfsprogs-devel
-Requires:   btrfsprogs
+Requires:   btrfsprogs = 4.1
 Requires:   e2fsprogs
+Requires:   hdparm
 Requires:   hfsutils
 Requires:   jfsutils
 Requires:   mtools

++ gparted-0.22.0.tar.bz2 - gparted-0.23.0.tar.bz2 ++
 55402 lines of diff (skipped)






commit php5 for openSUSE:13.2:Update

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package php5 for openSUSE:13.2:Update 
checked in at 2015-08-06 09:42:16

Comparing /work/SRC/openSUSE:13.2:Update/php5 (Old)
 and  /work/SRC/openSUSE:13.2:Update/.php5.new (New)


Package is php5

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.TYuqFi/_old  2015-08-06 09:42:21.0 +0200
+++ /var/tmp/diff_new_pack.TYuqFi/_new  2015-08-06 09:42:21.0 +0200
@@ -1 +1 @@
-link package='php5.3869' cicount='copy' /
+link package='php5.3945' cicount='copy' /




commit php5 for openSUSE:13.1:Update

2015-08-06 Thread h_root
Hello community,

here is the log from the commit of package php5 for openSUSE:13.1:Update 
checked in at 2015-08-06 09:42:11

Comparing /work/SRC/openSUSE:13.1:Update/php5 (Old)
 and  /work/SRC/openSUSE:13.1:Update/.php5.new (New)


Package is php5

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.ouknWf/_old  2015-08-06 09:42:13.0 +0200
+++ /var/tmp/diff_new_pack.ouknWf/_new  2015-08-06 09:42:13.0 +0200
@@ -1 +1 @@
-link package='php5.3869' cicount='copy' /
+link package='php5.3945' cicount='copy' /