commit tigervnc for openSUSE:13.2:Update

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package tigervnc for openSUSE:13.2:Update 
checked in at 2016-05-17 17:26:46

Comparing /work/SRC/openSUSE:13.2:Update/tigervnc (Old)
 and  /work/SRC/openSUSE:13.2:Update/.tigervnc.new (New)


Package is "tigervnc"

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.wvdiM0/_old  2016-05-17 17:26:48.0 +0200
+++ /var/tmp/diff_new_pack.wvdiM0/_new  2016-05-17 17:26:48.0 +0200
@@ -1 +1 @@
-
+




commit patchinfo.5030 for openSUSE:13.2:Update

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package patchinfo.5030 for 
openSUSE:13.2:Update checked in at 2016-05-17 17:26:50

Comparing /work/SRC/openSUSE:13.2:Update/patchinfo.5030 (Old)
 and  /work/SRC/openSUSE:13.2:Update/.patchinfo.5030.new (New)


Package is "patchinfo.5030"

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _patchinfo



Other differences:
--
++ _patchinfo ++

  xorg-x11-Xvnc misses dependency on xauth and 
xkbcomp
  recommended
  moderate
  michalsrb
  
This update for tigervnc fixes the following issues:

- Added missing dependency on xauth and xorg-x11-fonts-core. (boo#977019)

  Recommended update for tigervnc




commit poppler for openSUSE:13.2:Update

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package poppler for openSUSE:13.2:Update 
checked in at 2016-05-17 17:26:07

Comparing /work/SRC/openSUSE:13.2:Update/poppler (Old)
 and  /work/SRC/openSUSE:13.2:Update/.poppler.new (New)


Package is "poppler"

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.HILU0i/_old  2016-05-17 17:26:09.0 +0200
+++ /var/tmp/diff_new_pack.HILU0i/_new  2016-05-17 17:26:09.0 +0200
@@ -1 +1 @@
-
+




commit poppler-qt for openSUSE:13.2:Update

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package poppler-qt for openSUSE:13.2:Update 
checked in at 2016-05-17 17:25:56

Comparing /work/SRC/openSUSE:13.2:Update/poppler-qt (Old)
 and  /work/SRC/openSUSE:13.2:Update/.poppler-qt.new (New)


Package is "poppler-qt"

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.ZSRJsC/_old  2016-05-17 17:25:57.0 +0200
+++ /var/tmp/diff_new_pack.ZSRJsC/_new  2016-05-17 17:25:57.0 +0200
@@ -1 +1 @@
-
+




commit poppler-qt.5045 for openSUSE:13.2:Update

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package poppler-qt.5045 for 
openSUSE:13.2:Update checked in at 2016-05-17 17:25:52

Comparing /work/SRC/openSUSE:13.2:Update/poppler-qt.5045 (Old)
 and  /work/SRC/openSUSE:13.2:Update/.poppler-qt.5045.new (New)


Package is "poppler-qt.5045"

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _link



Other differences:
--
++ _link ++



commit poppler-qt5 for openSUSE:13.2:Update

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package poppler-qt5 for openSUSE:13.2:Update 
checked in at 2016-05-17 17:26:00

Comparing /work/SRC/openSUSE:13.2:Update/poppler-qt5 (Old)
 and  /work/SRC/openSUSE:13.2:Update/.poppler-qt5.new (New)


Package is "poppler-qt5"

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.0v1yIJ/_old  2016-05-17 17:26:02.0 +0200
+++ /var/tmp/diff_new_pack.0v1yIJ/_new  2016-05-17 17:26:02.0 +0200
@@ -1 +1 @@
-
+




commit curl for openSUSE:13.2:Update

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package curl for openSUSE:13.2:Update 
checked in at 2016-05-17 17:25:35

Comparing /work/SRC/openSUSE:13.2:Update/curl (Old)
 and  /work/SRC/openSUSE:13.2:Update/.curl.new (New)


Package is "curl"

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.oX892C/_old  2016-05-17 17:25:36.0 +0200
+++ /var/tmp/diff_new_pack.oX892C/_new  2016-05-17 17:25:36.0 +0200
@@ -1 +1 @@
-
+




commit courier-unicode for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package courier-unicode for openSUSE:Factory 
checked in at 2016-05-17 17:16:21

Comparing /work/SRC/openSUSE:Factory/courier-unicode (Old)
 and  /work/SRC/openSUSE:Factory/.courier-unicode.new (New)


Package is "courier-unicode"

Changes:

--- /work/SRC/openSUSE:Factory/courier-unicode/courier-unicode.changes  
2015-08-05 19:14:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.courier-unicode.new/courier-unicode.changes 
2016-05-17 17:16:22.0 +0200
@@ -1,0 +2,6 @@
+Mon May 16 01:31:03 UTC 2016 - ch...@computersalat.de
+
+- update to 1.4
+  * no info about changes available
+
+---

Old:

  courier-unicode-1.3.tar.bz2
  courier-unicode-1.3.tar.bz2.sig

New:

  courier-unicode-1.4.tar.bz2
  courier-unicode-1.4.tar.bz2.sig



Other differences:
--
++ courier-unicode.spec ++
--- /var/tmp/diff_new_pack.Zt7PMm/_old  2016-05-17 17:16:23.0 +0200
+++ /var/tmp/diff_new_pack.Zt7PMm/_new  2016-05-17 17:16:23.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package courier-unicode
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,19 +18,19 @@
 
 Name:   courier-unicode
 %define libname   lib%{name}
-%define libsoname %{libname}1
+%define libsoname %{libname}3
 
 Summary:Courier Unicode Library
 License:GPL-3.0+
 Group:  Productivity/Networking/Email/Servers
-Version:1.3
+Version:1.4
 Release:0
 Url:http://www.courier-mta.org/
 Source0:%{name}-%{version}.tar.bz2
 Source1:%{name}-%{version}.tar.bz2.sig
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  gcc-c++
 BuildRequires:  fdupes
+BuildRequires:  gcc-c++
 
 %description
 The Courier Unicode Library based on the Unicode 6.3.0 standard.
@@ -103,7 +103,7 @@
 %defattr(-,root,root)
 %doc AUTHORS
 %{_libdir}/%{libname}.so
-%{_includedir}/%{name}.h
+%{_includedir}/%{name}*.h
 
 %files doc
 %defattr(-,root,root)

++ courier-unicode-1.3.tar.bz2 -> courier-unicode-1.4.tar.bz2 ++
 13357 lines of diff (skipped)




commit python3-smbc for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-smbc for openSUSE:Factory 
checked in at 2016-05-17 17:12:45

Comparing /work/SRC/openSUSE:Factory/python3-smbc (Old)
 and  /work/SRC/openSUSE:Factory/.python3-smbc.new (New)


Package is "python3-smbc"

Changes:

--- /work/SRC/openSUSE:Factory/python3-smbc/python3-smbc.changes
2015-10-06 13:27:36.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-smbc.new/python3-smbc.changes   
2016-05-17 17:12:46.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:06:25 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-smbc.spec ++
--- /var/tmp/diff_new_pack.CQQdOP/_old  2016-05-17 17:12:47.0 +0200
+++ /var/tmp/diff_new_pack.CQQdOP/_new  2016-05-17 17:12:47.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-smbc
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,7 +24,7 @@
 Release:0
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://cyberelk.net/tim/software/pysmbc/
-Source: 
https://pypi.python.org/packages/source/p/pysmbc/pysmbc-%{version}.tar.bz2
+Source: 
https://files.pythonhosted.org/packages/source/p/pysmbc/pysmbc-%{version}.tar.bz2
 Summary:Python bindings for samba clients (libsmbclient)
 License:GPL-2.0+
 Group:  Development/Libraries/Python




commit python3-lxml for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-lxml for openSUSE:Factory 
checked in at 2016-05-17 17:10:36

Comparing /work/SRC/openSUSE:Factory/python3-lxml (Old)
 and  /work/SRC/openSUSE:Factory/.python3-lxml.new (New)


Package is "python3-lxml"

Changes:

--- /work/SRC/openSUSE:Factory/python3-lxml/python3-lxml.changes
2016-03-26 15:11:24.0 +0100
+++ /work/SRC/openSUSE:Factory/.python3-lxml.new/python3-lxml.changes   
2016-05-17 17:10:37.0 +0200
@@ -1,0 +2,8 @@
+Sun May  8 07:02:46 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * changed to https for source url
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-lxml.spec ++
--- /var/tmp/diff_new_pack.IDrHOe/_old  2016-05-17 17:10:38.0 +0200
+++ /var/tmp/diff_new_pack.IDrHOe/_new  2016-05-17 17:10:38.0 +0200
@@ -23,7 +23,7 @@
 License:BSD-3-Clause and GPL-2.0+
 Group:  Development/Languages/Python
 Url:http://lxml.de/
-Source: 
http://pypi.python.org/packages/source/l/lxml/lxml-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/l/lxml/lxml-%{version}.tar.gz
 Source1:http://lxml.de/lxmldoc-%{version}.pdf
 BuildRequires:  libxslt-devel
 BuildRequires:  python3-Cython




commit python3-simplejson for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-simplejson for 
openSUSE:Factory checked in at 2016-05-17 17:12:33

Comparing /work/SRC/openSUSE:Factory/python3-simplejson (Old)
 and  /work/SRC/openSUSE:Factory/.python3-simplejson.new (New)


Package is "python3-simplejson"

Changes:

--- /work/SRC/openSUSE:Factory/python3-simplejson/python3-simplejson.changes
2016-02-22 08:56:40.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python3-simplejson.new/python3-simplejson.changes   
2016-05-17 17:12:34.0 +0200
@@ -1,0 +2,8 @@
+Sun May  8 07:06:18 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * changed to https for source url
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-simplejson.spec ++
--- /var/tmp/diff_new_pack.BkhqQr/_old  2016-05-17 17:12:35.0 +0200
+++ /var/tmp/diff_new_pack.BkhqQr/_new  2016-05-17 17:12:35.0 +0200
@@ -23,7 +23,7 @@
 Summary:Simple, fast, extensible JSON encoder/decoder for Python
 License:MIT or AFL-2.1
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/s/simplejson/simplejson-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/s/simplejson/simplejson-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python3 >= 3.3
 BuildRequires:  python3-devel




commit libtorrent-rasterbar for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package libtorrent-rasterbar for 
openSUSE:Factory checked in at 2016-05-17 17:16:33

Comparing /work/SRC/openSUSE:Factory/libtorrent-rasterbar (Old)
 and  /work/SRC/openSUSE:Factory/.libtorrent-rasterbar.new (New)


Package is "libtorrent-rasterbar"

Changes:

--- 
/work/SRC/openSUSE:Factory/libtorrent-rasterbar/libtorrent-rasterbar.changes
2016-04-28 17:00:03.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.libtorrent-rasterbar.new/libtorrent-rasterbar.changes
   2016-05-17 17:16:38.0 +0200
@@ -1,0 +2,9 @@
+Mon May 16 13:26:12 UTC 2016 - sor.ale...@meowr.ru
+
+- Build Python3 bindings for openSUSE Leap 42.2 and newer.
+- Remove GeoIP support remnants, was removed in 1.1.0.
+- Replace fix-sse-only-on-x86.patch with
+  libtorrent-rasterbar-1.1.0-remove-x86-only-flag.patch
+  (commit 680eddf) and apply unconditionally.
+
+---

Old:

  fix-sse-only-on-x86.patch

New:

  libtorrent-rasterbar-1.1.0-remove-x86-only-flag.patch



Other differences:
--
++ libtorrent-rasterbar.spec ++
--- /var/tmp/diff_new_pack.aTF9Lo/_old  2016-05-17 17:16:39.0 +0200
+++ /var/tmp/diff_new_pack.aTF9Lo/_new  2016-05-17 17:16:39.0 +0200
@@ -26,22 +26,20 @@
 Summary:Libtorrent is a C++ implementation of the BitTorrent protocol
 License:BSD-3-Clause
 Group:  Development/Libraries/C and C++
-Url:http://rasterbar.com/products/libtorrent
+Url:http://libtorrent.org/
 Source: 
https://github.com/arvidn/%{_name}/releases/download/%{_name}-%{_version}/%{name}-%{version}.tar.gz
-%ifnarch x86_64 amd64 %{ix86}
-Patch0: fix-sse-only-on-x86.patch
-BuildRequires:  autoconf
-BuildRequires:  automake
-BuildRequires:  libtool
-%endif
-BuildRequires:  boost-devel >= 1.36
+# PATCH-FIX-UPSTREAM libtorrent-rasterbar-1.1.0-remove-x86-only-flag.patch -- 
Remove -msse4.2 flag (commit 680eddf).
+Patch0: %{name}-1.1.0-remove-x86-only-flag.patch
+BuildRequires:  boost-devel >= 1.47
 BuildRequires:  gcc-c++
 BuildRequires:  pkg-config
 BuildRequires:  python-devel
-BuildRequires:  pkgconfig(geoip)
 BuildRequires:  pkgconfig(openssl)
-# For quadmath.h we need gcc-fortran on openSUSE < Factory (<= 42.1)
-%if 0%{?suse_version} <=1320
+%if 0%{?suse_version} > 1320 || (0%{?sle_version} >= 120200 && 
0%{?is_opensuse})
+BuildRequires:  python3-devel
+%endif
+%if 0%{?suse_version} <= 1320
+# For quadmath.h we need gcc-fortran on openSUSE Leap 42.x and older.
 BuildRequires:  gcc-fortran
 %endif
 
@@ -81,6 +79,15 @@
 %description -n python-%{name}
 Python Bindings for the libtorrent-rasterbar package.
 
+%if 0%{?suse_version} > 1320 || (0%{?sle_version} >= 120200 && 
0%{?is_opensuse})
+%package -n python3-%{name}
+Summary:Python Bindings for libtorrent-rasterbar
+Group:  Development/Libraries/Python
+
+%description -n python3-%{name}
+Python Bindings for the libtorrent-rasterbar package.
+%endif
+
 %if %{with examples}
 %package tools
 Summary:Example tools from libtorrent-rasterbar
@@ -96,7 +103,7 @@
 Requires:   %{name}%{sover} = %{version}
 Requires:   boost-devel >= 1.36
 Requires:   gcc-c++
-Requires:   pkgconfig(geoip)
+Requires:   pkg-config
 Requires:   pkgconfig(openssl)
 
 %description devel
@@ -121,40 +128,50 @@
 
 %prep
 %setup -q
-
-%ifnarch x86_64 amd64 %{ix86}
 %patch0 -p1
-autoreconf -vi
-%endif
 
 %build
 export CFLAGS="%{optflags} -fno-strict-aliasing"
 export CXXFLAGS="$CFLAGS"
 export LDFLAGS="%{optflags} -lrt"
 
-%configure \
+%global _configure ../configure
+%if 0%{?suse_version} > 1320 || (0%{?sle_version} >= 120200 && 
0%{?is_opensuse})
+for py in python python3; do
+%else
+for py in python; do
+%endif
+mkdir -p "build-$py"
+pushd "build-$py"
+export PYTHON="$py"
+%configure \
   --disable-static   \
   --disable-silent-rules \
-  --with-libgeoip\
-  --with-boost-libdir=%{_libdir} \
 %if %{with examples}
   --enable-examples  \
 %endif
-  --enable-python-binding\
-  --enable-encryption
-make %{?_smp_mflags}
+  --with-boost-python="libboost_$py" \
+  --enable-python-binding
+make %{?_smp_mflags}
+popd
+done
 
 %install
-%make_install
+%make_install -C build-python
+%if 0%{?suse_version} > 1320 || (0%{?sle_version} >= 120200 && 
0%{?is_opensuse})
+%make_install -C build-python3
+%endif
+
 find %{buildroot} -type f -name "*.la" -delete -print
 # Move doc to a separate package.
 mkdir -p %{buildroot}%{_docdir}/%{name}/
 cp -r docs/* %{buildroot}%{_docdir}/%{name}/
 
 %if %{with examples}
-# Drop tests binaries from -tools subpackage.
-rm -v 

commit gdouros-aegean-fonts for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package gdouros-aegean-fonts for 
openSUSE:Factory checked in at 2016-05-17 17:16:24

Comparing /work/SRC/openSUSE:Factory/gdouros-aegean-fonts (Old)
 and  /work/SRC/openSUSE:Factory/.gdouros-aegean-fonts.new (New)


Package is "gdouros-aegean-fonts"

Changes:

--- 
/work/SRC/openSUSE:Factory/gdouros-aegean-fonts/gdouros-aegean-fonts.changes
2016-01-22 01:07:47.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.gdouros-aegean-fonts.new/gdouros-aegean-fonts.changes
   2016-05-17 17:16:27.0 +0200
@@ -1,0 +2,13 @@
+Fri May  6 17:03:03 UTC 2016 - aloi...@gmx.com
+
+- Update to version 8.91 
+- Replaced tarball with original archives and pdf docs
+  renamed to include the version or last modified date
+  (AegeanFonts-8.91.zip Aegean-20160402.pdf
+   Alphabetics-20160401.pdf CretanHieroglyphs-20160401.pdf
+   CyproMinoanInscriptions-20160401.pdf
+   CyproMinoanSigns-20160401.pdf LinearABsigns-20160401.pdf
+   LinearAwords-20160401.pdf Phaistos-20160305.pdf)
+- Re-added README-SUSE as separate license file
+
+---

Old:

  aegean-fonts-8.01.tar.bz2

New:

  Aegean-20160402.pdf
  AegeanFonts-8.91.zip
  Alphabetics-20160401.pdf
  CretanHieroglyphs-20160401.pdf
  CyproMinoanInscriptions-20160401.pdf
  CyproMinoanSigns-20160401.pdf
  LinearABsigns-20160401.pdf
  LinearAwords-20160401.pdf
  Phaistos-20160305.pdf
  README-SUSE



Other differences:
--
++ gdouros-aegean-fonts.spec ++
--- /var/tmp/diff_new_pack.0q77Zo/_old  2016-05-17 17:16:28.0 +0200
+++ /var/tmp/diff_new_pack.0q77Zo/_new  2016-05-17 17:16:28.0 +0200
@@ -19,14 +19,24 @@
 %define fontname aegean-fonts
 
 Name:   gdouros-aegean-fonts
-Version:8.01
+Version:8.91
 Release:0
 Summary:Font with Support for Ancient Aegean and Eastern Mediterranean 
Scripts
 License:SUSE-Permissive
 Group:  System/X11/Fonts
 Url:http://users.teilar.gr/~g1951d/
-Source: %{fontname}-%{version}.tar.bz2
+Source0:
http://users.teilar.gr/~g1951d/AegeanFonts.zip#/AegeanFonts-%{version}.zip
+Source1:http://users.teilar.gr/~g1951d/Aegean.pdf#/Aegean-20160402.pdf
+Source2:
http://users.teilar.gr/~g1951d/Alphabetics.pdf#/Alphabetics-20160401.pdf
+Source3:
http://users.teilar.gr/~g1951d/CretanHieroglyphs.pdf#/CretanHieroglyphs-20160401.pdf
+Source4:
http://users.teilar.gr/~g1951d/CyproMinoanInscriptions.pdf#/CyproMinoanInscriptions-20160401.pdf
+Source5:
http://users.teilar.gr/~g1951d/CyproMinoanSigns.pdf#/CyproMinoanSigns-20160401.pdf
+Source6:
http://users.teilar.gr/~g1951d/LinearABsigns.pdf#/LinearABsigns-20160401.pdf
+Source7:
http://users.teilar.gr/~g1951d/LinearAwords.pdf#/LinearAwords-20160401.pdf
+Source8:
http://users.teilar.gr/~g1951d/Phaistos.pdf#/Phaistos-20160305.pdf
+Source9:README-SUSE
 BuildRequires:  fontpackages-devel
+BuildRequires:  unzip
 %reconfigure_fonts_prereq
 %define _ttfontsdir /usr/share/fonts/truetype
 Obsoletes:  %{fontname} < 7.12
@@ -38,13 +48,20 @@
 Aegean covers the following scripts and symbols supported by Unicode: Basic 
Latin, Greek and Coptic, Greek Extended, some Punctuation and other Symbols, 
Linear B Syllabary, Linear B Ideograms, Aegean Numbers, Ancient Greek Numbers, 
Ancient Symbols, Phaistos Disc, Lycian, Carian, Old Italic, Ugaritic, Old 
Persian, Cypriot Syllabary, Phoenician, Lydian, and Archaic Greek Musical 
Notation. Aegean allocates in Plane 15 of the UCS the following scripts and 
symbols, as yet unsupported by Unicode: Cretan Hieroglyphs, Cypro-Minoan, 
Linear A, the Arkalochori Axe, signs on Troy vessels and the Dispilio tablet. 
In this version Linear A and B have been expanded with variant glyphs. The 
Tsepis stele variant of the Cypriot Syllabary has been added as its Open Type 
Stylistic Set VI.
 
 %prep
-%setup -q -n %{fontname}-%{version}
+%setup -q -cT -a0
 
 %build
 
 %install
 mkdir -p %{buildroot}%{_ttfontsdir}
 install -m 0644 *.ttf %{buildroot}%{_ttfontsdir}/
+# install docs
+cp %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
+   %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
+   %{SOURCE9} -t .
+for i in *.pdf; do
+IFS=-. read -r a b c <<< "$i"; mv "$i" "$a.$c"
+done
 
 %reconfigure_fonts_scriptlets
 

++ README-SUSE ++
Cited from http://users.teilar.gr/~g1951d/ as of 20160117

In lieu of a licence

Fonts and documents in this site are free for any use.

George Douros



commit retext for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package retext for openSUSE:Factory checked 
in at 2016-05-17 17:16:30

Comparing /work/SRC/openSUSE:Factory/retext (Old)
 and  /work/SRC/openSUSE:Factory/.retext.new (New)


Package is "retext"

Changes:

--- /work/SRC/openSUSE:Factory/retext/retext.changes2015-12-24 
12:17:29.0 +0100
+++ /work/SRC/openSUSE:Factory/.retext.new/retext.changes   2016-05-17 
17:16:35.0 +0200
@@ -1,0 +2,23 @@
+Sat May 14 14:12:40 UTC 2016 - mplus...@suse.com
+
+- Update to version 6.0.0
+  * The live preview now automatically scrolls to match its 
+sition with the editor (only for Markdown).
+  * Markup conversion is now performed in a background process, 
+proving responsiveness of the editor.
+  * Images can now be copied and pasted into ReText (contributed by 
+Bart Clephas).
+  * Added a button to quickly close the search bar.
+  * Added basic CSS styling for tables.
+  * Replaced the tags box with the new “Formatting” box for 
+Markdown (contributed by Donato Marrazzo).
+  * Hitting return twice now ends the Markdown list.
+  * ReText now depends on version 2.0 or higher of pymarkups.
+  * The QtWebKit dependency is now optional (though still 
+recommended).
+- Spec file cleanups
+  * Update dependencies
+  * Use pretty name for source archive
+  * Disable testsuite as it requires connection to Xserver
+
+---

Old:

  5.3.0.tar.gz

New:

  retext-6.0.0.tar.gz



Other differences:
--
++ retext.spec ++
--- /var/tmp/diff_new_pack.isZKNf/_old  2016-05-17 17:16:36.0 +0200
+++ /var/tmp/diff_new_pack.isZKNf/_new  2016-05-17 17:16:36.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package retext
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,30 +17,34 @@
 
 
 Name:   retext
-Version:5.3.0
+Version:6.0.0
 Release:0
 Summary:Simple editor for Markdown and reStructuredText
 License:GPL-3.0+
-Group:  Productivity/Editors/Other
+Group:  Productivity/Text/Editors
 Url:https://github.com/retext-project/retext
-Source: 
https://github.com/retext-project/retext/archive/%{version}.tar.gz
+Source: 
https://github.com/retext-project/retext/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
 BuildRequires:  dos2unix
 BuildRequires:  fdupes
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  python3
 BuildRequires:  python3-Markdown
-BuildRequires:  python3-Markups
+BuildRequires:  python3-Markups >= 2.0
 BuildRequires:  python3-devel
 BuildRequires:  python3-docutils
 BuildRequires:  python3-qt5
 BuildRequires:  rsvg-view
 BuildRequires:  update-desktop-files
 Requires:   python3-Markdown
-Requires:   python3-Markups
+Requires:   python3-Markups >= 2.0
 Requires:   python3-docutils
 Requires:   python3-pyenchant
 Requires:   python3-qt5
 Recommends: python3-Pygments
+Requires(post): hicolor-icon-theme
+Requires(post): update-desktop-files
+Requires(postun): hicolor-icon-theme
+Requires(postun): update-desktop-files
 Provides:   ReText = %{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
@@ -50,23 +54,20 @@
 markup languages. It is written in Python using PyQt libraries.
 
 %prep
-%setup
+%setup -q
 dos2unix LICENSE_GPL
 
 %build
 python3 setup.py build
 
-%check
-python3 setup.py test
-
 %install
 python3 setup.py install --root=%{buildroot} --prefix=%{_prefix}
 
-%{__mkdir} -pv %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/
-%{__mkdir} -pv %{buildroot}%{_datadir}/%{name}/
-%{__mkdir} -pv %{buildroot}%{_datadir}/applications/
+mkdir -pv %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/
+mkdir -pv %{buildroot}%{_datadir}/%{name}/
+mkdir -pv %{buildroot}%{_datadir}/applications/
 
-%{__cp} -r icons/*.svg %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/
+cp -r icons/*.svg %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/
 ICONSIZE="16 22 32 48 64 128 256"
 pushd %{buildroot}%{_datadir}/icons/hicolor/
 for i in $ICONSIZE; do




commit postgrey for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package postgrey for openSUSE:Factory 
checked in at 2016-05-17 17:16:29

Comparing /work/SRC/openSUSE:Factory/postgrey (Old)
 and  /work/SRC/openSUSE:Factory/.postgrey.new (New)


Package is "postgrey"

Changes:

--- /work/SRC/openSUSE:Factory/postgrey/postgrey.changes2016-04-30 
23:31:03.0 +0200
+++ /work/SRC/openSUSE:Factory/.postgrey.new/postgrey.changes   2016-05-17 
17:16:34.0 +0200
@@ -1,0 +2,5 @@
+Mon May 16 15:29:18 UTC 2016 - ch...@computersalat.de
+
+- add condition for suggesting cron to fix build for CentOS
+
+---



Other differences:
--
++ postgrey.spec ++
--- /var/tmp/diff_new_pack.P28JGz/_old  2016-05-17 17:16:35.0 +0200
+++ /var/tmp/diff_new_pack.P28JGz/_new  2016-05-17 17:16:35.0 +0200
@@ -48,11 +48,13 @@
 Requires:   perl-NetAddr-IP
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
+%if 0%{?suse_version}
 Suggests:   cron
 %if 0%{?suse_version} >= 1210
 BuildRequires:  systemd
 %systemd_requires
 %endif
+%endif
 Requires(post): %fillup_prereq
 
 %description




commit deluge for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package deluge for openSUSE:Factory checked 
in at 2016-05-17 17:16:36

Comparing /work/SRC/openSUSE:Factory/deluge (Old)
 and  /work/SRC/openSUSE:Factory/.deluge.new (New)


Package is "deluge"

Changes:

--- /work/SRC/openSUSE:Factory/deluge/deluge.changes2015-09-17 
09:20:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.deluge.new/deluge.changes   2016-05-17 
17:16:46.0 +0200
@@ -1,0 +2,7 @@
+Mon May 16 13:26:12 UTC 2016 - sor.ale...@meowr.ru
+
+- Add deluge-fix-blocklist-crash.patch: workaround a bug in
+  libtorrent-rasterbar 1.1.0 which results in a crash when
+  blocklist is used (boo#978600).
+
+---

New:

  deluge-fix-blocklist-crash.patch



Other differences:
--
++ deluge.spec ++
--- /var/tmp/diff_new_pack.ctvgcy/_old  2016-05-17 17:16:47.0 +0200
+++ /var/tmp/diff_new_pack.ctvgcy/_new  2016-05-17 17:16:47.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package deluge
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,6 +26,8 @@
 Source: 
http://download.deluge-torrent.org/source/%{name}-%{version}.tar.gz
 # PATCH-FIX-UPSTREAM deluge-update_7z_binary.patch
 Patch0: %{name}-update_7z_binary.patch
+# PATCH-FIX-OPENSUSE deluge-fix-blocklist-crash.patch -- Workaround a bug in 
libtorrent-rb 1.1.0 which results in a crash when blocklist is used.
+Patch1: %{name}-fix-blocklist-crash.patch
 BuildRequires:  fdupes
 BuildRequires:  gettext
 BuildRequires:  hicolor-icon-theme
@@ -60,12 +62,14 @@
 %prep
 %setup -q
 %patch0
+%patch1 -p1
 
 %build
 python2 setup.py build
 
 %install
-python2 setup.py install --root=%{buildroot} --prefix=%{_prefix} --optimize=1
+python2 setup.py install \
+  --root=%{buildroot} --prefix=%{_prefix}
 
 mv -f %{buildroot}%{python_sitelib}/%{name}/i18n/ 
%{buildroot}%{_datadir}/locale/
 ln -s %{_datadir}/locale %{buildroot}%{python_sitelib}/%{name}/i18n
@@ -77,7 +81,7 @@
 fi
 done
 
-%fdupes %{buildroot}%{python_sitelib}
+%fdupes %{buildroot}%{python_sitelib}/
 %find_lang %{name}
 
 %post

++ deluge-fix-blocklist-crash.patch ++
--- a/deluge/core/core.py
+++ b/deluge/core/core.py
@@ -92,6 +92,9 @@ class Core(component.Component):
 # Setting session flags to 1 enables all libtorrent default plugins
 self.session = lt.session(lt.fingerprint("DE", *version), flags=1)
 
+# Load an empty ip_filter
+self.session.set_ip_filter(lt.ip_filter())
+
 # Load the session state if available
 self.__load_session_state()
 



commit courier-authlib for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package courier-authlib for openSUSE:Factory 
checked in at 2016-05-17 17:16:22

Comparing /work/SRC/openSUSE:Factory/courier-authlib (Old)
 and  /work/SRC/openSUSE:Factory/.courier-authlib.new (New)


Package is "courier-authlib"

Changes:

--- /work/SRC/openSUSE:Factory/courier-authlib/courier-authlib.changes  
2015-08-05 19:14:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.courier-authlib.new/courier-authlib.changes 
2016-05-17 17:16:23.0 +0200
@@ -1,0 +2,6 @@
+Mon May 16 12:46:18 UTC 2016 - ch...@computersalat.de
+
+- udpate to 0.66.4
+  * authgetconfig.c (authgetconfig): avoid invalid memory read.
+
+---

Old:

  courier-authlib-0.66.3.tar.bz2
  courier-authlib-0.66.3.tar.bz2.sig

New:

  courier-authlib-0.66.4.tar.bz2
  courier-authlib-0.66.4.tar.bz2.sig



Other differences:
--
++ courier-authlib.spec ++
--- /var/tmp/diff_new_pack.5SjsUC/_old  2016-05-17 17:16:24.0 +0200
+++ /var/tmp/diff_new_pack.5SjsUC/_new  2016-05-17 17:16:24.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package courier-authlib
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,7 +20,7 @@
 Summary:Courier authentication library
 License:SUSE-GPL-3.0-with-openssl-exception
 Group:  Productivity/Networking/Email/Servers
-Version:0.66.3
+Version:0.66.4
 Release:0
 Url:http://www.courier-mta.org/imap/
 Source0:%{name}-%{version}.tar.bz2

++ courier-authlib-0.66.3.tar.bz2 -> courier-authlib-0.66.4.tar.bz2 ++
 148232 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/courier-authlib-0.66.3/ChangeLog new/courier-authlib-0.66.4/ChangeLog
--- old/courier-authlib-0.66.3/ChangeLog2015-06-29 04:09:59.0 
+0200
+++ new/courier-authlib-0.66.4/ChangeLog2015-11-14 22:48:55.0 
+0100
@@ -1,3 +1,9 @@
+0.66.4
+
+2015-11-14 "Hanno Böck" 
+
+   * authgetconfig.c (authgetconfig): avoid invalid memory read.
+
 0.66.3
 
 2015-06-09  Sam Varshavchik  
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/courier-authlib-0.66.3/auth_mkhomedir.3 
new/courier-authlib-0.66.4/auth_mkhomedir.3
--- old/courier-authlib-0.66.3/auth_mkhomedir.3 2015-06-20 14:58:37.0 
+0200
+++ new/courier-authlib-0.66.4/auth_mkhomedir.3 2015-11-04 16:15:08.0 
+0100
@@ -4,12 +4,12 @@
 .\" Title: auth_mkhomedir
 .\"Author: [FIXME: author] [see http://docbook.sf.net/el/author]
 .\" Generator: DocBook XSL Stylesheets v1.78.1 
-.\"  Date: 06/20/2015
+.\"  Date: 11/04/2015
 .\"Manual: Double Precision, Inc.
 .\"Source: Double Precision, Inc.
 .\"  Language: English
 .\"
-.TH "AUTH_MKHOMEDIR" "3" "06/20/2015" "Double Precision, Inc." "Double 
Precision, Inc."
+.TH "AUTH_MKHOMEDIR" "3" "11/04/2015" "Double Precision, Inc." "Double 
Precision, Inc."
 .\" -
 .\" * Define some portability stuff
 .\" -
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/courier-authlib-0.66.3/auth_mkhomedir.html 
new/courier-authlib-0.66.4/auth_mkhomedir.html
--- old/courier-authlib-0.66.3/auth_mkhomedir.html  2015-06-20 
14:58:32.0 +0200
+++ new/courier-authlib-0.66.4/auth_mkhomedir.html  2015-11-04 
16:10:58.0 +0100
@@ -6,7 +6,7 @@
 
 --> 
Nameauth_mkhomedir — Autocreate a new account's 
home directorySynopsis
 #include courierauth.h
-int 
rc=auth_mkhomedir(struct authinfo *auth);  

commit aria2 for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package aria2 for openSUSE:Factory checked 
in at 2016-05-17 17:16:35

Comparing /work/SRC/openSUSE:Factory/aria2 (Old)
 and  /work/SRC/openSUSE:Factory/.aria2.new (New)


Package is "aria2"

Changes:

--- /work/SRC/openSUSE:Factory/aria2/aria2.changes  2016-05-03 
10:16:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.aria2.new/aria2.changes 2016-05-17 
17:16:39.0 +0200
@@ -1,0 +2,23 @@
+Tue May 17 08:16:35 UTC 2016 - mplus...@suse.com
+
+- Update to version 1.23.0:
+  * Simplify cache write
+  * Allow subsecond value in ns cookie.txt file's expiry time field
+  * Adjust chromium cookie time
+  * import-po: iterate on glob, not ls output
+  * Add --stderr option to redirect all stdout log output to stderr
+  * Add "hide" to --download-result option
+  * Fix downloaded metaurl torrent filename
+  * Add a little bit of color to have a better visual of important 
+informations
+  * Update README URLs based on HTTP redirects
+  * Relocate from github.com/tatsuhiro-t/aria2 to 
+github.com/aria2/aria2
+  * mingw: Defer the falloc warning until falloc is specified by 
+option
+  * Add bittorrent key to aria2.tellStopped status
+  * Addsystem.listNotifications RPC method
+  * Report CheckIntegrity info in tellStatus
+- Update download url
+
+---

Old:

  aria2-1.22.0.tar.xz

New:

  aria2-1.23.0.tar.xz



Other differences:
--
++ aria2.spec ++
--- /var/tmp/diff_new_pack.IWrJ2C/_old  2016-05-17 17:16:40.0 +0200
+++ /var/tmp/diff_new_pack.IWrJ2C/_new  2016-05-17 17:16:40.0 +0200
@@ -18,13 +18,13 @@
 
 %define somajor 0
 Name:   aria2
-Version:1.22.0
+Version:1.23.0
 Release:0
 Summary:Parallelizing Multi-Protocol Utility for Downloading Files
 License:SUSE-GPL-2.0-with-openssl-exception
 Group:  Productivity/Networking/Other
 Url:https://aria2.github.io
-Source0:
https://github.com/tatsuhiro-t/aria2/releases/download/release-%{version}/aria2-%{version}.tar.xz
+Source0:
https://github.com/aria2/aria2/releases/download/release-%{version}/aria2-%{version}.tar.xz
 Source1:%{name}.changes
 BuildRequires:  bison
 BuildRequires:  gcc-c++

++ aria2-1.22.0.tar.xz -> aria2-1.23.0.tar.xz ++
 60866 lines of diff (skipped)




commit librecad for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package librecad for openSUSE:Factory 
checked in at 2016-05-17 17:16:32

Comparing /work/SRC/openSUSE:Factory/librecad (Old)
 and  /work/SRC/openSUSE:Factory/.librecad.new (New)


Package is "librecad"

Changes:

--- /work/SRC/openSUSE:Factory/librecad/librecad.changes2016-01-28 
17:22:33.0 +0100
+++ /work/SRC/openSUSE:Factory/.librecad.new/librecad.changes   2016-05-17 
17:16:37.0 +0200
@@ -1,0 +2,15 @@
+Mon May 16 13:04:14 UTC 2016 - jsl...@suse.com
+
+- Update to new upstream release 2.0.10:
+  * the Arch paper sizes were not properly supported
+  * the pen toolbar was wider than necessary on super HD displays
+  * various memory leaks
+  * build error when using boost version greater than 1.53
+  * auto-save could not really be turned off
+  * file dialog always opened with DXF, instead of the last chosen file type
+  * the statusbar and statusbar font were not allowed to autosize
+  * the fixed extension line length option was not working for dimensions
+  * the program would crash after: modify action -> undo -> repeat modify
+action
+
+---

Old:

  2.0.9.tar.gz

New:

  2.0.10.tar.gz



Other differences:
--
++ librecad.spec ++
--- /var/tmp/diff_new_pack.zywfvK/_old  2016-05-17 17:16:38.0 +0200
+++ /var/tmp/diff_new_pack.zywfvK/_new  2016-05-17 17:16:38.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package librecad
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   librecad
-Version:2.0.9
+Version:2.0.10
 Release:0
 Summary:Computer-aided design (CAD) software package for 2D design and 
drafting
 License:GPL-2.0 and (Apache-2.0 or SUSE-GPL-3.0+-with-font-exception)

++ 2.0.9.tar.gz -> 2.0.10.tar.gz ++
/work/SRC/openSUSE:Factory/librecad/2.0.9.tar.gz 
/work/SRC/openSUSE:Factory/.librecad.new/2.0.10.tar.gz differ: char 12, line 1







commit vm-install for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package vm-install for openSUSE:Factory 
checked in at 2016-05-17 17:16:27

Comparing /work/SRC/openSUSE:Factory/vm-install (Old)
 and  /work/SRC/openSUSE:Factory/.vm-install.new (New)


Package is "vm-install"

Changes:

--- /work/SRC/openSUSE:Factory/vm-install/vm-install.changes2016-04-30 
23:32:01.0 +0200
+++ /work/SRC/openSUSE:Factory/.vm-install.new/vm-install.changes   
2016-05-17 17:16:32.0 +0200
@@ -1,0 +2,7 @@
+Wed May  4 11:11:26 MDT 2016 - carn...@suse.com
+
+- bsc#978526 - text mode installation doesn't allow specifying
+  install source
+- Version 0.8.52
+
+---

Old:

  vm-install-0.8.51.tar.bz2

New:

  vm-install-0.8.52.tar.bz2



Other differences:
--
++ vm-install.spec ++
--- /var/tmp/diff_new_pack.Nc2uxw/_old  2016-05-17 17:16:33.0 +0200
+++ /var/tmp/diff_new_pack.Nc2uxw/_new  2016-05-17 17:16:33.0 +0200
@@ -27,12 +27,12 @@
 %endif
 # For directory ownership:
 BuildRequires:  yast2
-Version:0.8.51
+Version:0.8.52
 Release:0
 Summary:Tool to Define a Virtual Machine and Install Its Operating 
System
 License:GPL-2.0
 Group:  System/Emulators/PC
-Source0:%{name}-0.8.51.tar.bz2
+Source0:%{name}-0.8.52.tar.bz2
 Source1:vm-install.conf
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires:   dbus-1-python

++ vm-install-0.8.51.tar.bz2 -> vm-install-0.8.52.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vm-install-0.8.51/Makefile 
new/vm-install-0.8.52/Makefile
--- old/vm-install-0.8.51/Makefile  2016-04-21 00:03:51.0 +0200
+++ new/vm-install-0.8.52/Makefile  2016-05-09 16:04:08.0 +0200
@@ -1,5 +1,5 @@
 PACKAGE = vm-install
-VER = 0.8.51
+VER = 0.8.52
 
 default:
@echo "Run 'make install DESTDIR=$destdir' to install."
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vm-install-0.8.51/setup.py 
new/vm-install-0.8.52/setup.py
--- old/vm-install-0.8.51/setup.py  2016-04-21 00:03:44.0 +0200
+++ new/vm-install-0.8.52/setup.py  2016-05-09 16:04:14.0 +0200
@@ -1,7 +1,7 @@
 from distutils.core import setup
 
 setup(name='vminstall',
-  version='0.8.51',
+  version='0.8.52',
   description='Define a virtual machine and install its operating system',
   author='Charles Coffing',
   author_email='ccoff...@novell.com',
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vm-install-0.8.51/src/vminstall/text/interface.py 
new/vm-install-0.8.52/src/vminstall/text/interface.py
--- old/vm-install-0.8.51/src/vminstall/text/interface.py   2015-06-08 
22:41:24.0 +0200
+++ new/vm-install-0.8.52/src/vminstall/text/interface.py   2016-05-09 
16:04:40.0 +0200
@@ -434,8 +434,6 @@
 if options.pxe_boot == True:
 options.os_type = 'pxe'
 return
-if options.source:
-return
 
 vmdefaults = VMDefaults[options.os_type]
 install_selections = {}
@@ -452,9 +450,13 @@
 default = url
 else:
 network_protocols.append(p)
+if options.source:
+default = 'host'
+install_selections[default] = '%s (%s)' % 
(vminstall.msg.installation_source_prompt, options.source)
 if network_protocols:
-default = 'network'
-install_selections[default] = '%s (%s)' % (vminstall.msg.network_url, 
', '.join(network_protocols),)
+install_selections['network'] = '%s (%s)' % 
(vminstall.msg.network_url, ', '.join(network_protocols),)
+if default is None:
+default = 'network'
 if default is None:
 # Validation step will catch this error, and allow user to retry.
 return
@@ -463,6 +465,8 @@
 url = prompt_selection_by_number(vminstall.msg.install_media_help, 
install_selections, default)
 
 try:
+if options.source and url == 'host':
+break
 if not url.startswith('dev:/'):
 url = prompt_string("Type the install URL:")
 options.source = url




commit ghc-persistent-template for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-persistent-template for 
openSUSE:Factory checked in at 2016-05-17 17:15:58

Comparing /work/SRC/openSUSE:Factory/ghc-persistent-template (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-persistent-template.new (New)


Package is "ghc-persistent-template"

Changes:

--- 
/work/SRC/openSUSE:Factory/ghc-persistent-template/ghc-persistent-template.changes
  2016-04-28 17:02:12.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.ghc-persistent-template.new/ghc-persistent-template.changes
 2016-05-17 17:15:59.0 +0200
@@ -1,0 +2,6 @@
+Sat May 14 20:21:10 UTC 2016 - mimi...@gmail.com
+
+- update to 2.1.8.1
+* fix a bad Eq instance /= definition for Key when mpsGenetric=True
+
+---

Old:

  persistent-template-2.1.8.tar.gz

New:

  persistent-template-2.1.8.1.tar.gz



Other differences:
--
++ ghc-persistent-template.spec ++
--- /var/tmp/diff_new_pack.xj7I5n/_old  2016-05-17 17:16:00.0 +0200
+++ /var/tmp/diff_new_pack.xj7I5n/_new  2016-05-17 17:16:00.0 +0200
@@ -20,7 +20,7 @@
 %bcond_with tests
 
 Name:   ghc-persistent-template
-Version:2.1.8
+Version:2.1.8.1
 Release:0
 Summary:Type-safe, non-relational, multi-backend persistence
 Group:  System/Libraries

++ persistent-template-2.1.8.tar.gz -> persistent-template-2.1.8.1.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/persistent-template-2.1.8/ChangeLog.md 
new/persistent-template-2.1.8.1/ChangeLog.md
--- old/persistent-template-2.1.8/ChangeLog.md  2016-04-23 09:41:14.0 
+0200
+++ new/persistent-template-2.1.8.1/ChangeLog.md2016-05-14 
06:08:26.0 +0200
@@ -1,3 +1,7 @@
+## 2.1.8.1
+
+* fix a bad Eq instance /= definition for Key when mpsGenetric=True
+
 ## 2.1.7
 
 * Support for GHC 8 [#556](https://github.com/yesodweb/persistent/issues/556)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/persistent-template-2.1.8/Database/Persist/TH.hs 
new/persistent-template-2.1.8.1/Database/Persist/TH.hs
--- old/persistent-template-2.1.8/Database/Persist/TH.hs2016-04-23 
09:42:28.0 +0200
+++ new/persistent-template-2.1.8.1/Database/Persist/TH.hs  2016-05-14 
06:09:06.0 +0200
@@ -766,9 +766,6 @@
 x == y =
 ($(return unKeyE) x) ==
 ($(return unKeyE) y)
-x /= y =
-($(return unKeyE) x) ==
-($(return unKeyE) y)
  instance Ord (BackendKey $(pure backendT)) => Ord (Key $(pure 
recordType)) where
 compare x y = compare
 ($(return unKeyE) x)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/persistent-template-2.1.8/persistent-template.cabal 
new/persistent-template-2.1.8.1/persistent-template.cabal
--- old/persistent-template-2.1.8/persistent-template.cabal 2016-04-23 
09:42:38.0 +0200
+++ new/persistent-template-2.1.8.1/persistent-template.cabal   2016-05-14 
06:08:17.0 +0200
@@ -1,5 +1,5 @@
 name:persistent-template
-version: 2.1.8
+version: 2.1.8.1
 license: MIT
 license-file:LICENSE
 author:  Michael Snoyman 




commit ghc-parsec for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-parsec for openSUSE:Factory 
checked in at 2016-05-17 17:15:56

Comparing /work/SRC/openSUSE:Factory/ghc-parsec (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-parsec.new (New)


Package is "ghc-parsec"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-parsec/ghc-parsec.changes2015-05-21 
08:11:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-parsec.new/ghc-parsec.changes   
2016-05-17 17:15:57.0 +0200
@@ -1,0 +2,12 @@
+Sat May 14 20:16:02 UTC 2016 - mimi...@gmail.com
+
+- update to 3.1.11
+- remove useless _service
+* Most types now have a `Typeable` instance. Some instances are dropped from
+   older versions of GHC (sorry about that!).
+* The token-parser now rejects Unicode numeric escape sequences for characters
+outside the Unicode range.
+* The token-parser now loses less precision when parsing literal doubles.
+* Documentation fixes and corrections.
+
+---

Old:

  _service
  parsec-3.1.9.tar.gz

New:

  parsec-3.1.11.tar.gz



Other differences:
--
++ ghc-parsec.spec ++
--- /var/tmp/diff_new_pack.05tLIn/_old  2016-05-17 17:15:58.0 +0200
+++ /var/tmp/diff_new_pack.05tLIn/_new  2016-05-17 17:15:58.0 +0200
@@ -19,7 +19,7 @@
 %global pkg_name parsec
 
 Name:   ghc-parsec
-Version:3.1.9
+Version:3.1.11
 Release:0
 Summary:Monadic parser combinators
 License:BSD-3-Clause

++ parsec-3.1.9.tar.gz -> parsec-3.1.11.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/parsec-3.1.9/CHANGES new/parsec-3.1.11/CHANGES
--- old/parsec-3.1.9/CHANGES2015-03-22 02:13:17.0 +0100
+++ new/parsec-3.1.11/CHANGES   2016-05-13 05:05:07.0 +0200
@@ -1,3 +1,17 @@
+3.1.11
+
+- Include `README.md` in package.
+
+3.1.10
+
+- Most types now have a `Typeable` instance. Some instances are dropped from
+  older versions of GHC (sorry about that!).
+- The token-parser now rejects Unicode numeric escape sequences for characters
+  outside the Unicode range.
+- The token-parser now loses less precision when parsing literal doubles.
+- Documentation fixes and corrections.
+- We no longer test parsec builds on GHC 7.4.
+
 3.1.9
 
 - Many and various updates to documentation and package description (inlcuding
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/parsec-3.1.9/README.md new/parsec-3.1.11/README.md
--- old/parsec-3.1.9/README.md  1970-01-01 01:00:00.0 +0100
+++ new/parsec-3.1.11/README.md 2016-05-13 05:05:07.0 +0200
@@ -0,0 +1,95 @@
+Parsec [![Build 
Status](https://travis-ci.org/aslatter/parsec.svg?branch=master)](https://travis-ci.org/aslatter/parsec)
+==
+
+A monadic parser combinator library, written by Daan Leijen. Parsec is designed
+from scratch as an industrial-strength parser library. It is simple, safe, well
+documented, has extensive libraries, good error messages, and is fast.
+
+Some links:
+
+* [Parsec on Hackage](https://hackage.haskell.org/package/parsec),
+  contains the generated documentation.
+* The 2001 paper written by Daan Leijen, some what outdated
+  
([PDF](https://web.archive.org/web/20140528151730/http://legacy.cs.uu.nl/daan/download/parsec/parsec.pdf),
+  
[HTML](https://web.archive.org/web/20140528151730/http://legacy.cs.uu.nl/daan/download/parsec/parsec.html),
+  thanks to [archive.org](http://web.archive.org);
+  and 
[PDF](https://research.microsoft.com/en-us/um/people/daan/download/parsec/parsec.pdf),
+  thanks to Microsoft Research).
+* [Using Parsec](http://book.realworldhaskell.org/read/using-parsec.html),
+  chapter 16 of [Real World Haskell](http://book.realworldhaskell.org/).
+* [An introduction to the Parsec 
library](http://kunigami.wordpress.com/2014/01/21/an-introduction-to-the-parsec-library)
+  on Kunigami's blog.
+* [An introduction to parsing text in Haskell with 
Parsec](http://unbui.lt/#!/post/haskell-parsec-basics) on Wilson's blog.
+* Differences between Parsec and
+  [Attoparsec](http://hackage.haskell.org/package/attoparsec)
+  (Haskell's other prominent parser library) as explained in
+  [an answer on StackExchange](http://stackoverflow.com/a/19213247).
+* Differences between Parsec and [Happy](http://www.haskell.org/happy)
+  (Haskell's parser generator) as explained in two
+  answers on separate StackExchange questions
+  ([1](http://stackoverflow.com/a/7270904),
+  [2](http://stackoverflow.com/a/14775331)).
+
+By analyzing [Parsec's reverse dependencies on 
Hackage](http://packdeps.haskellers.com/reverse/parsec)
+we can find open source project that make use of Parsec.  

commit meson for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package meson for openSUSE:Factory checked 
in at 2016-05-17 17:16:19

Comparing /work/SRC/openSUSE:Factory/meson (Old)
 and  /work/SRC/openSUSE:Factory/.meson.new (New)


Package is "meson"

Changes:

--- /work/SRC/openSUSE:Factory/meson/meson.changes  2016-05-16 
12:04:33.0 +0200
+++ /work/SRC/openSUSE:Factory/.meson.new/meson.changes 2016-05-17 
17:16:20.0 +0200
@@ -1,0 +2,5 @@
+Mon May  9 16:47:26 UTC 2016 - jeng...@inai.de
+
+- Avoid unnecessary bashism in %install script (run with /bin/sh)
+
+---



Other differences:
--
++ meson.spec ++
--- /var/tmp/diff_new_pack.QJccpb/_old  2016-05-17 17:16:21.0 +0200
+++ /var/tmp/diff_new_pack.QJccpb/_new  2016-05-17 17:16:21.0 +0200
@@ -88,7 +88,7 @@
   --root=%{buildroot} --prefix=%{_prefix}
 
 for file in %{buildroot}%{_bindir}/*.py; do
-mv -f "$file" "${file/.py}"
+mv -fv "$file" "${file%.py}"
 done
 install -Dm 0644 data/macros.%{name} 
%{buildroot}%{_rpmconfigdir}/macros.d/macros.%{name}
 





commit ghc-GLUT for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-GLUT for openSUSE:Factory 
checked in at 2016-05-17 17:15:50

Comparing /work/SRC/openSUSE:Factory/ghc-GLUT (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-GLUT.new (New)


Package is "ghc-GLUT"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-GLUT/ghc-GLUT.changes2016-04-22 
16:25:21.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-GLUT.new/ghc-GLUT.changes   2016-05-17 
17:15:52.0 +0200
@@ -1,0 +2,11 @@
+Fri May 13 12:49:19 UTC 2016 - mimi...@gmail.com
+
+- update to 2.7.0.10 
+
+---
+Thu May 12 18:42:12 UTC 2016 - mimi...@gmail.com
+
+- update to 2.7.0.8
+* Relaxed upper version bound for OpenGLRaw.
+
+---

Old:

  GLUT-2.7.0.7.tar.gz

New:

  GLUT-2.7.0.10.tar.gz



Other differences:
--
++ ghc-GLUT.spec ++
--- /var/tmp/diff_new_pack.w79qQg/_old  2016-05-17 17:15:53.0 +0200
+++ /var/tmp/diff_new_pack.w79qQg/_new  2016-05-17 17:15:53.0 +0200
@@ -18,7 +18,7 @@
 
 %global pkg_name GLUT
 Name:   ghc-GLUT
-Version:2.7.0.7
+Version:2.7.0.10
 Release:0
 Summary:A binding for the OpenGL Utility Toolkit
 License:BSD-3-Clause

++ GLUT-2.7.0.7.tar.gz -> GLUT-2.7.0.10.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/GLUT-2.7.0.7/CHANGELOG.md 
new/GLUT-2.7.0.10/CHANGELOG.md
--- old/GLUT-2.7.0.7/CHANGELOG.md   2016-04-11 09:26:25.0 +0200
+++ new/GLUT-2.7.0.10/CHANGELOG.md  2016-05-12 18:47:38.0 +0200
@@ -1,3 +1,16 @@
+2.7.0.10
+
+* Mac OS X: Search public frameworks first, then system frameworks.
+
+2.7.0.9
+
+* The GLUT package compiles without any additional library/framework now.
+* Windows: We search for a native freeglut DLL, a MinGW freeglut DLL and a 
classic GLUT DLL, in that order.
+
+2.7.0.8
+
+* Relaxed upper version bound for `OpenGLRaw`.
+
 2.7.0.7
 ---
 * Removed redundant constraints.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/GLUT-2.7.0.7/GLUT.cabal new/GLUT-2.7.0.10/GLUT.cabal
--- old/GLUT-2.7.0.7/GLUT.cabal 2016-04-11 09:26:30.0 +0200
+++ new/GLUT-2.7.0.10/GLUT.cabal2016-05-12 18:47:38.0 +0200
@@ -1,5 +1,5 @@
 name: GLUT
-version: 2.7.0.7
+version: 2.7.0.10
 synopsis: A binding for the OpenGL Utility Toolkit
 description:
   A Haskell binding for the OpenGL Utility Toolkit, a window system independent
@@ -46,7 +46,7 @@
 flag UseNativeWindowsLibraries
   description:
 When compiling under Windows, use the native libraries instead of e.g. the
-ones coming with Cygwin.
+ones coming with Cygwin or MSYS.
 
 flag BuildExamples
   description: Build various OpenGL/GLUT examples.
@@ -100,14 +100,9 @@
 else
   cpp-options: "-DCALLCONV=ccall"
 cc-options: "-DUSE_GETPROCADDRESS"
-extra-libraries: glut32
   else
 cpp-options: "-DCALLCONV=ccall"
 cc-options: "-DUSE_DLSYM"
-if os(darwin)
-  frameworks: GLUT
-else
-  extra-libraries: glut
 
 executable BOGLGP01-OnYourOwn1
   if !flag(BuildExamples)
@@ -240,7 +235,7 @@
   if !flag(BuildExamples)
 buildable: False
   main-is: SmoothOpenGL3.hs
-  build-depends: base >= 3 && < 5, bytestring >= 0.9 && < 0.11, OpenGLRaw >= 
1.0 && < 3.2, GLUT
+  build-depends: base >= 3 && < 5, bytestring >= 0.9 && < 0.11, OpenGLRaw >= 
1.0 && < 3.3, GLUT
   hs-source-dirs: examples/Misc
   default-language: Haskell2010
   ghc-options: -Wall
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/GLUT-2.7.0.7/cbits/HsGLUT.c 
new/GLUT-2.7.0.10/cbits/HsGLUT.c
--- old/GLUT-2.7.0.7/cbits/HsGLUT.c 2015-10-06 10:20:16.0 +0200
+++ new/GLUT-2.7.0.10/cbits/HsGLUT.c2016-05-12 18:47:38.0 +0200
@@ -1,7 +1,7 @@
 /* 
-
  *
  * Module  :  C support for Graphics.UI.GLUT.Raw
- * Copyright   :  (c) Sven Panne 2002-2013
+ * Copyright   :  (c) Sven Panne 2002-2016
  * License :  BSD3
  *
  * Maintainer  :  Sven Panne 
@@ -10,68 +10,6 @@
  *
  * -- 
*/
 
-#if defined(_MSC_VER) || defined(__CYGWIN__) || defined(__MINGW32__) || 
defined(__WATCOMC__)
-
-#define GLUT_STROKE_ROMAN  ((void *)0x)
-#define GLUT_STROKE_MONO_ROMAN ((void *)0x0001)
-#define GLUT_BITMAP_9_BY_15((void *)0x0002)
-#define GLUT_BITMAP_8_BY_13((void *)0x0003)
-#define GLUT_BITMAP_TIMES_ROMAN_10 ((void *)0x0004)

commit libnl-doc for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package libnl-doc for openSUSE:Factory 
checked in at 2016-05-17 17:16:06

Comparing /work/SRC/openSUSE:Factory/libnl-doc (Old)
 and  /work/SRC/openSUSE:Factory/.libnl-doc.new (New)


Package is "libnl-doc"

Changes:

--- /work/SRC/openSUSE:Factory/libnl-doc/libnl-doc.changes  2013-06-13 
16:52:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.libnl-doc.new/libnl-doc.changes 2016-05-17 
17:16:08.0 +0200
@@ -1,0 +2,6 @@
+Sun May  8 17:40:11 UTC 2016 - jeng...@inai.de
+
+- Update to new upstream release 3.2.27
+* Documentation updated for libnl-3.2.27 API
+
+---

Old:

  libnl-doc-3.2.22.tar.xz

New:

  libnl-doc-3.2.27.tar.gz
  libnl-doc-3.2.27.tar.gz.sig



Other differences:
--
++ libnl-doc.spec ++
--- /var/tmp/diff_new_pack.Uw3PM5/_old  2016-05-17 17:16:10.0 +0200
+++ /var/tmp/diff_new_pack.Uw3PM5/_new  2016-05-17 17:16:10.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libnl-doc
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   libnl-doc
-Version:3.2.22
+Version:3.2.27
 Release:0
 Summary:Documentation for libnl, a library for working with Netlink 
sockets
 License:GPL-3.0
@@ -25,12 +25,12 @@
 Url:http://www.carisma.slowglass.com/~tgr/libnl/
 
 #Git-Clone:git://git.infradead.org/users/tgr/libnl
-#Git-Clone:git://github.com/tgraf/libnl
-#DL-URL:   http://www.carisma.slowglass.com/~tgr/libnl/files/
-Source: libnl-doc-%version.tar.xz
+#Git-Clone:git://github.com/thom311/libnl/
+#Mailing-List: http://lists.infradead.org/mailman/listinfo/libnl
+Source: 
https://github.com/thom311/libnl/releases/download/libnl3_2_27/%name-%version.tar.gz
+Source2:
https://github.com/thom311/libnl/releases/download/libnl3_2_27/%name-%version.tar.gz.sig
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch: noarch
-BuildRequires:  xz
 %if 0%{?suse_version}
 BuildRequires:  fdupes
 %endif
@@ -40,17 +40,12 @@
 Netlink protocol based Linux kernel interfaces.
 
 %prep
-%if 0%{?__xz:1}
 %setup -qn libnl-doc-%version
-%else
-tar -xf "%{S:0}" --use=xz;
-%setup -DTqn libnl-doc-%version
-%endif
 
 %build
 
 %install
-b="%buildroot";
+b="%buildroot"
 rm -Rf build-aux configure.ac
 find . -name .gitignore -delete
 mkdir -p "$b/%_docdir"




commit csync2 for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package csync2 for openSUSE:Factory checked 
in at 2016-05-17 17:16:16

Comparing /work/SRC/openSUSE:Factory/csync2 (Old)
 and  /work/SRC/openSUSE:Factory/.csync2.new (New)


Package is "csync2"

Changes:

--- /work/SRC/openSUSE:Factory/csync2/csync2.changes2015-03-28 
18:38:41.0 +0100
+++ /work/SRC/openSUSE:Factory/.csync2.new/csync2.changes   2016-05-17 
17:16:17.0 +0200
@@ -1,0 +2,20 @@
+Fri May  6 21:13:01 UTC 2016 - jeng...@inai.de
+
+- Avoid runtime dependency on systemd, the macros can all deal with
+  its absence.
+- Ensure csync@.service template instances are disabled on package
+  removal.
+
+---
+Wed Apr 27 09:49:11 UTC 2016 - kgronl...@suse.com
+
+- Update to csync2-2.0-6-g10636a4:
+  - Document the -N flag to bind csync2 to a specific ip address.
+  - fix diff mode truncation to first 512 byte
+  - fix diff mode prefix substitution
+
+- Drop merged patches:
+  - Remove csync2-librsync-1.0.0.patch
+  - Remove fix-csync2_ssl_cert-filename.patch
+
+---

Old:

  csync2-2.0+git.1368794815.cf835a7.tar.bz2
  csync2-librsync-1.0.0.patch
  fix-csync2_ssl_cert-filename.patch

New:

  csync2-2.0+git.1461714863.10636a4.tar.bz2



Other differences:
--
++ csync2.spec ++
--- /var/tmp/diff_new_pack.4zXGgb/_old  2016-05-17 17:16:18.0 +0200
+++ /var/tmp/diff_new_pack.4zXGgb/_new  2016-05-17 17:16:18.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package csync2
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,7 +21,7 @@
 Group:  Productivity/Clustering/HA
 
 Name:   csync2
-Version:2.0+git.1368794815.cf835a7
+Version:2.0+git.1461714863.10636a4
 Release:0
 Url:http://oss.linbit.com/csync2/
 #Source0:   http://oss.linbit.com/csync2/%{name}-%{version}.tar.gz
@@ -34,14 +34,10 @@
 Patch0: csync2-fix-xinetd.patch
 # PATCH-FIX-UPSTREAM -- add-ac_prog_cpp.patch tser...@suse.com -- fix ugly 
./configure warnings about missing headers
 Patch10:add-ac_prog_cpp.patch
-# PATCH-FIX-UPSTREAM -- fix-csync2_ssl_cert-filename.patch tser...@suse.com -- 
correct csync2 ssl cert filename
-Patch11:fix-csync2_ssl_cert-filename.patch
 # PATCH-FIX-UPSTREAM -- fix-sonames.patch tser...@suse.com -- use properly 
versioned sonames in dlopen()
 Patch12:fix-sonames.patch
 # PATCH-FIX-UPSTREAM -- add-COPYING.patch tser...@suse.com -- ensure COPYING 
is present in docfiles and thus %doc
 Patch13:add-COPYING.patch
-# PATCH-FIX-UPSTREAM csync2-librsync-1.0.0.patch dims...@opensuse.org -- Fix 
build with librsync 1.0.0
-Patch14:csync2-librsync-1.0.0.patch
 
 BuildRequires:  autoconf
 BuildRequires:  automake
@@ -55,7 +51,6 @@
 BuildRequires:  sqlite3-devel
 Requires:   openssl
 Requires:   sqlite3
-%{?systemd_requires}
 %if 0%{?suse_version} >= 1210
 BuildRequires:  systemd
 %endif
@@ -64,7 +59,6 @@
 %if 0%{?suse_version} > 1220
 BuildRequires:  texlive-nopageno
 %endif
-
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -79,10 +73,8 @@
 
 %patch0 -p1
 %patch10 -p1
-%patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%patch14 -p1
 
 %build
 export CFLAGS="%{optflags}"
@@ -131,7 +123,7 @@
 fi
 
 %preun
-%service_del_preun csync2.socket
+%service_del_preun csync2.socket csync2@.service
 # Cleanup all databases upon last removal
 if [ $1 -eq 0 ]; then
   rm -f %{_localstatedir}/lib/csync2/*

++ csync2-2.0+git.1368794815.cf835a7.tar.bz2 -> 
csync2-2.0+git.1461714863.10636a4.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/csync2-2.0+git.1368794815.cf835a7/Makefile.am 
new/csync2-2.0+git.1461714863.10636a4/Makefile.am
--- old/csync2-2.0+git.1368794815.cf835a7/Makefile.am   2013-08-21 
06:48:24.0 +0200
+++ new/csync2-2.0+git.1461714863.10636a4/Makefile.am   2016-04-27 
11:48:11.0 +0200
@@ -1,5 +1,5 @@
 # csync2 - cluster synchronization tool, 2nd generation
-# Copyright (C) 2004 - 2013 LINBIT Information Technologies GmbH
+# Copyright (C) 2004 - 2015 LINBIT Information Technologies GmbH
 # http://www.linbit.com; see also AUTHORS
 #
 # This program is free software; you can redistribute it and/or modify
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/csync2-2.0+git.1368794815.cf835a7/README 

commit ghc-xml-conduit for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-xml-conduit for openSUSE:Factory 
checked in at 2016-05-17 17:16:05

Comparing /work/SRC/openSUSE:Factory/ghc-xml-conduit (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-xml-conduit.new (New)


Package is "ghc-xml-conduit"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-xml-conduit/ghc-xml-conduit.changes  
2016-04-28 17:02:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-xml-conduit.new/ghc-xml-conduit.changes 
2016-05-17 17:16:06.0 +0200
@@ -1,0 +2,6 @@
+Thu May 12 13:39:32 UTC 2016 - mimi...@gmail.com
+
+- update to 1.3.5
+* Improvements for using xml-conduit for streaming XML protocols
+
+---

Old:

  xml-conduit-1.3.4.2.tar.gz

New:

  xml-conduit-1.3.5.tar.gz



Other differences:
--
++ ghc-xml-conduit.spec ++
--- /var/tmp/diff_new_pack.CBEq97/_old  2016-05-17 17:16:07.0 +0200
+++ /var/tmp/diff_new_pack.CBEq97/_new  2016-05-17 17:16:07.0 +0200
@@ -21,7 +21,7 @@
 %bcond_with tests
 
 Name:   ghc-xml-conduit
-Version:1.3.4.2
+Version:1.3.5
 Release:0
 Summary:Pure-Haskell utilities for dealing with XML with the conduit 
package
 License:BSD-2-Clause

++ xml-conduit-1.3.4.2.tar.gz -> xml-conduit-1.3.5.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/xml-conduit-1.3.4.2/ChangeLog.md 
new/xml-conduit-1.3.5/ChangeLog.md
--- old/xml-conduit-1.3.4.2/ChangeLog.md2016-04-18 08:57:08.0 
+0200
+++ new/xml-conduit-1.3.5/ChangeLog.md  2016-05-11 13:03:26.0 +0200
@@ -1,3 +1,7 @@
+## 1.3.5
+
+* Improvements for using xml-conduit for streaming XML protocols 
[#85](https://github.com/snoyberg/xml/pull/85)
+
 ## 1.3.4.2
 
 * transformers dep bump
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/xml-conduit-1.3.4.2/Text/XML/Stream/Render.hs 
new/xml-conduit-1.3.5/Text/XML/Stream/Render.hs
--- old/xml-conduit-1.3.4.2/Text/XML/Stream/Render.hs   2016-04-18 
08:57:08.0 +0200
+++ new/xml-conduit-1.3.5/Text/XML/Stream/Render.hs 2016-05-11 
13:03:26.0 +0200
@@ -1,11 +1,13 @@
 {-# LANGUAGE FlexibleContexts  #-}
 {-# LANGUAGE OverloadedStrings #-}
+{-# LANGUAGE RankNTypes#-}
 -- | 'Enumeratee's to render XML 'Event's. Unlike libxml-enumerator and
 -- expat-enumerator, this module does not provide IO and ST variants, since the
 -- underlying rendering operations are pure functions.
 module Text.XML.Stream.Render
 ( -- * Rendering XML files
   renderBuilder
+, renderBuilderFlush
 , renderBytes
 , renderText
 , prettify
@@ -115,31 +117,49 @@
 -- the blaze-builder package, and allow the create of optimally sized
 -- 'ByteString's with minimal buffer copying.
 renderBuilder :: Monad m => RenderSettings -> Conduit Event m Builder
-renderBuilder RenderSettings { rsPretty = True, rsNamespaces = n, rsUseCDATA = 
useCDATA } = prettify =$= renderBuilder' n True useCDATA
-renderBuilder RenderSettings { rsPretty = False, rsNamespaces = n, rsUseCDATA 
= useCDATA } = renderBuilder' n False useCDATA
+renderBuilder settings = CL.map Chunk =$= renderBuilder' yield' settings
+  where
+yield' Flush = return ()
+yield' (Chunk bs) = yield bs
+
+-- | Same as 'renderBuilder' but allows you to flush XML stream to ensure that 
all
+-- events at needed point are rendered.
+--
+-- @since 1.3.5
+renderBuilderFlush :: Monad m => RenderSettings -> Conduit (Flush Event) m 
(Flush Builder)
+renderBuilderFlush = renderBuilder' yield
+
+renderBuilder' :: Monad m => (Flush Builder -> Producer m o) -> RenderSettings 
-> Conduit (Flush Event) m o
+renderBuilder' yield' settings =
+if rsPretty settings
+then prettify =$= renderEvent'
+else renderEvent'
+  where
+renderEvent' = renderEvent yield' settings
 
-renderBuilder' :: Monad m => [(Text, Text)] -> Bool -> (Content -> Bool) -> 
Conduit Event m Builder
-renderBuilder' namespaces0 isPretty useCDATA = do
+renderEvent :: Monad m => (Flush Builder -> Producer m o) -> RenderSettings -> 
Conduit (Flush Event) m o
+renderEvent yield' RenderSettings { rsPretty = isPretty, rsNamespaces = 
namespaces0, rsUseCDATA = useCDATA } = do
 loop []
   where
 loop nslevels = await >>= maybe (return ()) (go nslevels)
 
-go nslevels e =
+go nslevels Flush = yield' Flush >> loop nslevels
+go nslevels (Chunk e) =
 case e of
 EventBeginElement n1 as -> do
 mnext <- CL.peek
 isClosed <-
 case mnext of
-Just (EventEndElement n2) | n1 == n2 -> do
+  

commit vala-panel-plugin-sntray for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package vala-panel-plugin-sntray for 
openSUSE:Factory checked in at 2016-05-17 17:15:45

Comparing /work/SRC/openSUSE:Factory/vala-panel-plugin-sntray (Old)
 and  /work/SRC/openSUSE:Factory/.vala-panel-plugin-sntray.new (New)


Package is "vala-panel-plugin-sntray"

Changes:

--- 
/work/SRC/openSUSE:Factory/vala-panel-plugin-sntray/vala-panel-plugin-sntray.changes
2015-08-19 09:29:54.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.vala-panel-plugin-sntray.new/vala-panel-plugin-sntray.changes
   2016-05-17 17:15:46.0 +0200
@@ -1,0 +2,8 @@
+Sat May  7 07:12:54 UTC 2016 - sor.ale...@meowr.ru
+
+- Make vala-panel-plugin-sntray-lang recommend neither
+  vala-panel-plugin-sntray, nor xfce4-panel-plugin-sntray, to
+  avoid recommending one when other is being installed.
+- Fix build by using upstream glib-2.0.vapi.
+
+---



Other differences:
--
++ vala-panel-plugin-sntray.spec ++
--- /var/tmp/diff_new_pack.W2pwCo/_old  2016-05-17 17:15:47.0 +0200
+++ /var/tmp/diff_new_pack.W2pwCo/_new  2016-05-17 17:15:47.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package vala-panel-plugin-sntray
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -27,12 +27,13 @@
 Source: 
https://github.com/rilian-la-te/%{_name}/releases/download/%{version}/%{_name}-%{version}.tar.gz
 BuildRequires:  cmake >= 2.8
 BuildRequires:  gettext
+BuildRequires:  pkg-config
 BuildRequires:  vala >= 0.24
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.12
 BuildRequires:  pkgconfig(libpeas-1.0) >= 1.2
 BuildRequires:  pkgconfig(vala-panel)
 Recommends: %{name}-lang
-%if 0%{?suse_version} >= 1315
+%if 0%{?suse_version} >= 1315 && 0%{?suse_version} != 1320
 BuildRequires:  pkgconfig(libxfce4panel-2.0)
 BuildRequires:  pkgconfig(libxfconf-0)
 %endif
@@ -40,12 +41,12 @@
 %description
 StatusNotifierItem is the new D-Bus standard for system tray.
 
-%if 0%{?suse_version} >= 1315
+%if 0%{?suse_version} >= 1315 && 0%{?suse_version} != 1320
 %package lang
 Summary:Languages for package vala-panel-plugin-sntray
 Group:  System/Localization
-Recommends: %{name} = %{version}
-Recommends: xfce4-panel-plugin-sntray = %{version}
+Suggests:   %{name} = %{version}
+Suggests:   xfce4-panel-plugin-sntray = %{version}
 Supplements:packageand(bundle-lang-other:%{name})
 Supplements:packageand(bundle-lang-other:xfce4-panel-plugin-sntray)
 Provides:   %{name}-lang-all = %{version}
@@ -60,7 +61,7 @@
 %lang_package
 %endif
 
-%if 0%{?suse_version} >= 1315
+%if 0%{?suse_version} >= 1315 && 0%{?suse_version} != 1320
 %package -n xfce4-panel-plugin-sntray
 Summary:StatusNotifierItem (appindicator) plugin for xfce4-panel
 Group:  System/GUI/XFCE
@@ -73,6 +74,10 @@
 
 %prep
 %setup -q -n %{_name}-%{version}
+%if 0%{?suse_version} != 1320
+# Use upstream glib-2.0.vapi.
+rm src/vapi/glib-2.0.vapi
+%endif
 
 %build
 %cmake \
@@ -101,7 +106,7 @@
 %files lang -f %{_name}.lang
 %defattr(-,root,root)
 
-%if 0%{?suse_version} >= 1315
+%if 0%{?suse_version} >= 1315 && 0%{?suse_version} != 1320
 %files -n xfce4-panel-plugin-sntray
 %defattr(-,root,root)
 %doc LICENSE README.md




commit ghc-stm-containers for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-stm-containers for 
openSUSE:Factory checked in at 2016-05-17 17:16:00

Comparing /work/SRC/openSUSE:Factory/ghc-stm-containers (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-stm-containers.new (New)


Package is "ghc-stm-containers"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-stm-containers/ghc-stm-containers.changes
2016-02-17 12:12:00.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.ghc-stm-containers.new/ghc-stm-containers.changes   
2016-05-17 17:16:01.0 +0200
@@ -1,0 +2,5 @@
+Sat May 14 20:26:17 UTC 2016 - mimi...@gmail.com
+
+- update to 0.2.11 
+
+---

Old:

  stm-containers-0.2.10.tar.gz

New:

  stm-containers-0.2.11.tar.gz



Other differences:
--
++ ghc-stm-containers.spec ++
--- /var/tmp/diff_new_pack.zw9q7N/_old  2016-05-17 17:16:02.0 +0200
+++ /var/tmp/diff_new_pack.zw9q7N/_new  2016-05-17 17:16:02.0 +0200
@@ -20,7 +20,7 @@
 %bcond_with tests
 
 Name:   ghc-stm-containers
-Version:0.2.10
+Version:0.2.11
 Release:0
 Summary:Containers for STM
 Group:  System/Libraries
@@ -37,8 +37,6 @@
 BuildRequires:  ghc-focus-devel
 BuildRequires:  ghc-hashable-devel
 BuildRequires:  ghc-list-t-devel
-BuildRequires:  ghc-loch-th-devel
-BuildRequires:  ghc-placeholders-devel
 BuildRequires:  ghc-primitive-devel
 BuildRequires:  ghc-transformers-devel
 %if %{with tests}

++ stm-containers-0.2.10.tar.gz -> stm-containers-0.2.11.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/stm-containers-0.2.10/executables/APITests/MapTests.hs 
new/stm-containers-0.2.11/executables/APITests/MapTests.hs
--- old/stm-containers-0.2.10/executables/APITests/MapTests.hs  2016-02-12 
13:36:47.0 +0100
+++ new/stm-containers-0.2.11/executables/APITests/MapTests.hs  2016-05-14 
09:21:20.0 +0200
@@ -72,6 +72,20 @@
 -- * Tests
 -
 
+prop_sizeAndList =
+  forAll gen prop
+  where
+gen = do
+  keys <- nub <$> listOf (arbitrary :: Gen Char)
+  mapM (liftA2 (flip (,)) (arbitrary :: Gen Int) . pure) keys
+prop list =
+  length list == stmMapLength
+  where
+stmMapLength =
+  unsafePerformIO $ atomically $ do
+x <- stmMapFromList list
+STMMap.size x
+
 prop_fromListToListIsomorphism =
   forAll gen prop
   where
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/stm-containers-0.2.10/executables/ConcurrentInsertionBench.hs 
new/stm-containers-0.2.11/executables/ConcurrentInsertionBench.hs
--- old/stm-containers-0.2.10/executables/ConcurrentInsertionBench.hs   
2016-02-12 13:36:47.0 +0100
+++ new/stm-containers-0.2.11/executables/ConcurrentInsertionBench.hs   
2016-05-14 09:21:20.0 +0200
@@ -119,12 +119,12 @@
   [
 bgroup "STM Containers"
   [
-bench "Focus-based" $ 
+bench "Focus-based" $ nfIO $
   scSessionRunner focusSCInterpreter threadTransactions,
-bench "Specialized" $ 
+bench "Specialized" $ nfIO $
   scSessionRunner specializedSCInterpreter threadTransactions
   ],
-bench "Unordered Containers" $
+bench "Unordered Containers" $ nfIO $
   ucSessionRunner threadTransactions
   ]
   where
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/stm-containers-0.2.10/executables/ConcurrentTransactionsBench.hs 
new/stm-containers-0.2.11/executables/ConcurrentTransactionsBench.hs
--- old/stm-containers-0.2.10/executables/ConcurrentTransactionsBench.hs
2016-02-12 13:36:47.0 +0100
+++ new/stm-containers-0.2.11/executables/ConcurrentTransactionsBench.hs
2016-05-14 09:21:20.0 +0200
@@ -202,7 +202,7 @@
 map concat $! 
 slices (length transactionsGroups `div` threadsNum) transactionsGroups
   in
-bench (shows threadsNum . showString "/" . shows (transactionsNum 
`div` threadsNum) $ "") $
+bench (shows threadsNum . showString "/" . shows (transactionsNum 
`div` threadsNum) $ "") $ nfIO $
   scSessionRunner specializedSCInterpreter session
   where
 threadsNums = [1, 2, 4, 6, 8, 12, 16, 32, 40, 52, 64, 80, 128]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/stm-containers-0.2.10/executables/InsertionBench.hs 
new/stm-containers-0.2.11/executables/InsertionBench.hs
--- 

commit courier-imap for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package courier-imap for openSUSE:Factory 
checked in at 2016-05-17 17:16:26

Comparing /work/SRC/openSUSE:Factory/courier-imap (Old)
 and  /work/SRC/openSUSE:Factory/.courier-imap.new (New)


Package is "courier-imap"

Changes:

--- /work/SRC/openSUSE:Factory/courier-imap/courier-imap.changes
2015-08-05 19:14:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.courier-imap.new/courier-imap.changes   
2016-05-17 17:16:29.0 +0200
@@ -1,0 +2,12 @@
+Mon May 16 12:59:14 UTC 2016 - ch...@computersalat.de
+
+- update to 4.17.1
+  * Fix TLS SNI code.
+- update to 4.17.0
+  * Stop using SSL2 and SSL3 openssl configuration methods.
+  * libs/tcpd/libcouriertls.c: Add support for TLS SNI.
+  * imaplogin.c (starttls): flush stdin after negotiating STARTTLS.
+  * Fix Courier-IMAP rpm build on pre-systemd systems.
+- rebase courier-imap-Makefile.patch
+
+---

Old:

  courier-imap-4.16.2.tar.bz2
  courier-imap-4.16.2.tar.bz2.sig

New:

  courier-imap-4.17.1.tar.bz2
  courier-imap-4.17.1.tar.bz2.sig



Other differences:
--
++ courier-imap.spec ++
--- /var/tmp/diff_new_pack.cNBQHO/_old  2016-05-17 17:16:30.0 +0200
+++ /var/tmp/diff_new_pack.cNBQHO/_new  2016-05-17 17:16:30.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package courier-imap
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,7 +20,7 @@
 Summary:An IMAP and POP3 Server for Maildir MTAs
 License:GPL-3.0+
 Group:  Productivity/Networking/Email/Servers
-Version:4.16.2
+Version:4.17.1
 Release:0
 Url:http://www.courier-mta.org/imap/
 Source0:%{name}-%{version}.tar.bz2

++ courier-imap-4.16.2.tar.bz2 -> courier-imap-4.17.1.tar.bz2 ++
 184344 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/courier-imap-4.16.2/config.h.in new/courier-imap-4.17.1/config.h.in
--- old/courier-imap-4.16.2/config.h.in 2015-06-27 19:52:40.0 +0200
+++ new/courier-imap-4.17.1/config.h.in 2016-04-30 17:31:59.0 +0200
@@ -30,8 +30,7 @@
 /* Define to 1 if you have the  header file. */
 #undef HAVE_UNISTD_H
 
-/* Define to the sub-directory in which libtool stores uninstalled libraries.
-   */
+/* Define to the sub-directory where libtool stores uninstalled libraries. */
 #undef LT_OBJDIR
 
 /* Name of package */
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/courier-imap-4.16.2/configure.ac new/courier-imap-4.17.1/configure.ac
--- old/courier-imap-4.16.2/configure.ac2015-06-27 19:30:47.0 
+0200
+++ new/courier-imap-4.17.1/configure.ac2016-04-30 17:30:39.0 
+0200
@@ -1,10 +1,10 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl
-dnl Copyright 1998 - 2015 Double Precision, Inc.  See COPYING for
+dnl Copyright 1998 - 2016 Double Precision, Inc.  See COPYING for
 dnl distribution information.
 
 AC_PREREQ(2.59)
-AC_INIT(courier-imap, 4.16.2, [courier-i...@lists.sourceforge.net])
+AC_INIT(courier-imap, 4.17.1, [courier-i...@lists.sourceforge.net])
 AC_CONFIG_SRCDIR(libs/imap/imapd.c)
 AC_CONFIG_HEADERS(config.h)
 AM_INIT_AUTOMAKE
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/courier-imap-4.16.2/courier-imap.spec 
new/courier-imap-4.17.1/courier-imap.spec
--- old/courier-imap-4.16.2/courier-imap.spec   2015-06-29 04:36:56.0 
+0200
+++ new/courier-imap-4.17.1/courier-imap.spec   2016-05-08 15:08:57.0 
+0200
@@ -26,13 +26,13 @@
 %define _missing_doc_files_terminate_build 1
 %define _unpackaged_files_terminate_build 1
 
-Summary: Courier-IMAP 4.16.2 IMAP server

commit ghc-tls for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-tls for openSUSE:Factory checked 
in at 2016-05-17 17:16:01

Comparing /work/SRC/openSUSE:Factory/ghc-tls (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-tls.new (New)


Package is "ghc-tls"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-tls/ghc-tls.changes  2016-05-12 
09:34:10.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-tls.new/ghc-tls.changes 2016-05-17 
17:16:03.0 +0200
@@ -1,0 +2,5 @@
+Fri May 13 12:53:41 UTC 2016 - mimi...@gmail.com
+
+- update to 1.3.8 
+
+---

Old:

  tls-1.3.7.tar.gz

New:

  tls-1.3.8.tar.gz



Other differences:
--
++ ghc-tls.spec ++
--- /var/tmp/diff_new_pack.mamkNS/_old  2016-05-17 17:16:04.0 +0200
+++ /var/tmp/diff_new_pack.mamkNS/_new  2016-05-17 17:16:04.0 +0200
@@ -21,7 +21,7 @@
 %bcond_with tests
 
 Name:   ghc-tls
-Version:1.3.7
+Version:1.3.8
 Release:0
 Summary:TLS/SSL protocol native implementation (Server and Client)
 License:BSD-3-Clause

++ tls-1.3.7.tar.gz -> tls-1.3.8.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tls-1.3.7/Network/TLS/Handshake/Common.hs 
new/tls-1.3.8/Network/TLS/Handshake/Common.hs
--- old/tls-1.3.7/Network/TLS/Handshake/Common.hs   2016-05-08 
07:10:23.0 +0200
+++ new/tls-1.3.8/Network/TLS/Handshake/Common.hs   2016-05-12 
08:01:28.0 +0200
@@ -135,5 +135,6 @@
 , sessionSecret  = ms
 }
 
+extensionLookup :: ExtensionID -> [ExtensionRaw] -> Maybe Bytes
 extensionLookup toFind = fmap (\(ExtensionRaw _ content) -> content)
-   . find (\(ExtensionRaw eid content) -> eid == toFind)
+   . find (\(ExtensionRaw eid _) -> eid == toFind)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tls-1.3.7/Network/TLS/Handshake/Signature.hs 
new/tls-1.3.8/Network/TLS/Handshake/Signature.hs
--- old/tls-1.3.7/Network/TLS/Handshake/Signature.hs2016-05-08 
07:10:23.0 +0200
+++ new/tls-1.3.8/Network/TLS/Handshake/Signature.hs2016-05-12 
08:01:28.0 +0200
@@ -83,7 +83,7 @@
 Just HashSHA256 -> SHA256
 Just HashSHA1   -> SHA1
 Nothing -> SHA1_MD5
-Just hash   -> error ("unimplemented RSA signature hash type: " ++ 
show hash)
+Just hsh-> error ("unimplemented RSA signature hash type: " ++ 
show hsh)
 signatureHashData SignatureDSS mhash =
 case mhash of
 Nothing   -> SHA1
@@ -96,7 +96,7 @@
 Just HashSHA256 -> SHA256
 Just HashSHA1   -> SHA1
 Nothing -> SHA1_MD5
-Just hash   -> error ("unimplemented ECDSA signature hash type: " 
++ show hash)
+Just hsh-> error ("unimplemented ECDSA signature hash type: " 
++ show hsh)
 signatureHashData sig _ = error ("unimplemented signature type: " ++ show sig)
 
 --signatureCreate :: Context -> Maybe HashAndSignatureAlgorithm -> HashDescr 
-> Bytes -> IO DigitallySigned
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tls-1.3.7/Network/TLS/Parameters.hs 
new/tls-1.3.8/Network/TLS/Parameters.hs
--- old/tls-1.3.7/Network/TLS/Parameters.hs 2016-05-08 07:10:23.0 
+0200
+++ new/tls-1.3.8/Network/TLS/Parameters.hs 2016-05-12 08:01:28.0 
+0200
@@ -1,3 +1,5 @@
+ {-# LANGUAGE CPP #-}
+
 -- |
 -- Module  : Network.TLS.Parameters
 -- License : BSD-style
@@ -36,6 +38,9 @@
 import Network.TLS.RNG (Seed)
 import Data.Default.Class
 import qualified Data.ByteString as B
+#if __GLASGOW_HASKELL__ < 710
+import Data.Monoid (mempty)
+#endif
 
 type HostName = String
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tls-1.3.7/tls.cabal new/tls-1.3.8/tls.cabal
--- old/tls-1.3.7/tls.cabal 2016-05-08 07:10:23.0 +0200
+++ new/tls-1.3.8/tls.cabal 2016-05-12 08:01:28.0 +0200
@@ -1,5 +1,5 @@
 Name:tls
-Version: 1.3.7
+Version: 1.3.8
 Description:
Native Haskell TLS and SSL protocol implementation for server and client.
.
@@ -23,6 +23,7 @@
 Category:Network
 stability:   experimental
 Cabal-Version:   >=1.8
+Tested-With: GHC == 7.0.4, GHC == 7.4.2, GHC == 7.6.3, GHC == 7.8.4, 
GHC == 7.10.3, GHC == 8.0.1
 Homepage:http://github.com/vincenthz/hs-tls
 extra-source-files:  Tests/*.hs
  CHANGELOG.md
@@ -40,7 +41,7 @@
   Default:   False
 
 Library
-  Build-Depends: base 

commit vala-panel for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package vala-panel for openSUSE:Factory 
checked in at 2016-05-17 17:15:38

Comparing /work/SRC/openSUSE:Factory/vala-panel (Old)
 and  /work/SRC/openSUSE:Factory/.vala-panel.new (New)


Package is "vala-panel"

Changes:

--- /work/SRC/openSUSE:Factory/vala-panel/vala-panel.changes2015-06-30 
10:15:48.0 +0200
+++ /work/SRC/openSUSE:Factory/.vala-panel.new/vala-panel.changes   
2016-05-17 17:15:43.0 +0200
@@ -1,0 +2,5 @@
+Sat May  7 07:12:54 UTC 2016 - sor.ale...@meowr.ru
+
+- Fix build by using upstream glib-2.0.vapi.
+
+---



Other differences:
--
++ vala-panel.spec ++
--- /var/tmp/diff_new_pack.Jt6VjO/_old  2016-05-17 17:15:45.0 +0200
+++ /var/tmp/diff_new_pack.Jt6VjO/_new  2016-05-17 17:15:45.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package vala-panel
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -27,6 +27,7 @@
 BuildRequires:  cmake >= 2.8
 BuildRequires:  fdupes
 BuildRequires:  gettext
+BuildRequires:  pkg-config
 BuildRequires:  vala >= 0.24
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.12.0
 BuildRequires:  pkgconfig(libpeas-1.0) >= 1.2.0
@@ -53,6 +54,7 @@
 Summary:Development files for vala-panel
 Group:  Development/Libraries/Other
 Requires:   %{name} = %{version}
+Requires:   pkg-config
 Requires:   pkgconfig(gtk+-3.0) >= 3.12.0
 Requires:   pkgconfig(libpeas-1.0) >= 1.2.0
 Requires:   pkgconfig(libwnck-3.0) >= 3.4.0
@@ -80,6 +82,10 @@
 
 %prep
 %setup -q
+%if 0%{?suse_version} != 1320
+# Use upstream glib-2.0.vapi.
+rm vapi/glib-2.0.vapi
+%endif
 
 %build
 %cmake \




commit when-command for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package when-command for openSUSE:Factory 
checked in at 2016-05-17 17:16:15

Comparing /work/SRC/openSUSE:Factory/when-command (Old)
 and  /work/SRC/openSUSE:Factory/.when-command.new (New)


Package is "when-command"

Changes:

--- /work/SRC/openSUSE:Factory/when-command/when-command.changes
2016-03-05 13:07:29.0 +0100
+++ /work/SRC/openSUSE:Factory/.when-command.new/when-command.changes   
2016-05-17 17:16:16.0 +0200
@@ -1,0 +2,20 @@
+Mon May 16 06:32:55 UTC 2016 - jeng...@inai.de
+
+- Add rpmlintrc control file
+
+---
+Sat May  7 07:12:54 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 0.9.11~beta1 (changes since 0.9.10~beta2):
+  * Fix a bug that would run activities scheduled for time
+specifications containing zeros immediately after their creation.
+  * Fix a bug that prevented the disabled state of a condition to
+be retained when set through the Remote API.
+  * Support the new interface to external devices featured in
+gvfs 1.26, lack of it prevented When to correctly register
+events related to connection of external storage devices.
+- Alter official when-command.desktop instead of supplying an other
+  one.
+- Add a basic when-command.appdata.xml file.
+
+---

Old:

  when-command-0.9.10-beta.2.tar.gz
  when-command.desktop

New:

  when-command-0.9.11-beta.1.tar.gz
  when-command-rpmlintrc
  when-command.appdata.xml



Other differences:
--
++ when-command.spec ++
--- /var/tmp/diff_new_pack.dKMUTF/_old  2016-05-17 17:16:17.0 +0200
+++ /var/tmp/diff_new_pack.dKMUTF/_new  2016-05-17 17:16:17.0 +0200
@@ -16,20 +16,24 @@
 #
 
 
-%define _version 0.9.10-beta.2
+%define _version 0.9.11-beta.1
 Name:   when-command
-Version:0.9.10~beta2
+Version:0.9.11~beta1
 Release:0
 Summary:Configurable user task scheduler
 License:BSD-3-Clause
 Group:  Productivity/Other
 Url:http://almostearthling.github.io/when-command
 Source: 
https://github.com/almostearthling/%{name}/archive/v%{_version}.tar.gz#/%{name}-%{_version}.tar.gz
-Source1:%{name}.desktop
+Source1:%{name}.appdata.xml
+Source2:%{name}-rpmlintrc
 BuildRequires:  fdupes
 BuildRequires:  gobject-introspection-devel
 BuildRequires:  hicolor-icon-theme
+BuildRequires:  libXss1
 BuildRequires:  python3-devel
+BuildRequires:  python3-gobject
+BuildRequires:  python3-pyinotify
 BuildRequires:  python3-setuptools
 BuildRequires:  update-desktop-files
 Requires:   libXss1
@@ -49,7 +53,8 @@
 
 %prep
 %setup -q -n %{name}-%{_version}
-cp -f %{SOURCE1} %{name}.desktop
+cp -f %{SOURCE1} %{name}.appdata.xml
+sed -i 's/^\(Exec=\).*$/\1%{name}/' share/applications/%{name}.desktop
 
 %build
 python3 setup.py build
@@ -58,15 +63,17 @@
 python3 setup.py install \
   --root=%{buildroot} --prefix=%{_prefix}
 
-install -Dm 0644 %{name}.desktop 
%{buildroot}%{_datadir}/applications/%{name}.desktop
+install -Dm 0644 %{name}.appdata.xml \
+  %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
 
 mkdir -p %{buildroot}%{_docdir}/
 mv -f %{buildroot}%{_datadir}/doc/%{name}/ \
   %{buildroot}%{_docdir}/%{name}/
 
-%suse_update_desktop_file %{name}
-%find_lang %{name}
+%suse_update_desktop_file -r -G "When scheduler" %{name} Utility TimeUtility
+
 %fdupes %{buildroot}%{_prefix}/
+%find_lang %{name}
 
 %post
 %desktop_database_post
@@ -82,8 +89,10 @@
 %{_bindir}/%{name}
 %{_datadir}/%{name}/
 %{_datadir}/applications/%{name}.desktop
+%dir %{_datadir}/appdata/
+%{_datadir}/appdata/%{name}.appdata.xml
 %{_datadir}/icons/hicolor/*/apps/%{name}.*
-%{_mandir}/man?/when-command.?%{?ext_man}
+%{_mandir}/man?/%{name}.?%{?ext_man}
 %{python3_sitelib}/when_command-*
 
 %files lang -f %{name}.lang

++ when-command-0.9.10-beta.2.tar.gz -> when-command-0.9.11-beta.1.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/when-command-0.9.10-beta.2/README.md 
new/when-command-0.9.11-beta.1/README.md
--- old/when-command-0.9.10-beta.2/README.md2016-03-02 00:45:02.0 
+0100
+++ new/when-command-0.9.11-beta.1/README.md2016-05-03 19:52:11.0 
+0200
@@ -7,9 +7,20 @@
 
 It is not generally intended as a replacement to 
[_cron_](https://en.wikipedia.org/wiki/Cron) and the [Gnome Task 
Scheduler](http://gnome-schedule.sourceforge.net/), although to some extent 
these utilities might overlap. **When** is intended to be more flexible, 
although less precise, and to provide an alternative to more complicated 
solutions -- such as 

commit ubuntu-fonts for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ubuntu-fonts for openSUSE:Factory 
checked in at 2016-05-17 17:16:10

Comparing /work/SRC/openSUSE:Factory/ubuntu-fonts (Old)
 and  /work/SRC/openSUSE:Factory/.ubuntu-fonts.new (New)


Package is "ubuntu-fonts"

Changes:

--- /work/SRC/openSUSE:Factory/ubuntu-fonts/ubuntu-fonts.changes
2014-04-11 17:59:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.ubuntu-fonts.new/ubuntu-fonts.changes   
2016-05-17 17:16:15.0 +0200
@@ -1,0 +2,5 @@
+Sun May 15 12:16:08 UTC 2016 - devel...@develop7.info
+
+- update to v0.83
+
+---

Old:

  ubuntu-font-family-0.80.zip

New:

  ubuntu-font-family-0.83.zip



Other differences:
--
++ ubuntu-fonts.spec ++
--- /var/tmp/diff_new_pack.dV3fdV/_old  2016-05-17 17:16:16.0 +0200
+++ /var/tmp/diff_new_pack.dV3fdV/_new  2016-05-17 17:16:16.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package ubuntu-fonts
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %define fontname ubuntu-font-family
 Name:   ubuntu-fonts
-Version:0.80
+Version:0.83
 Release:0
 Summary:A unique, custom designed font that has a very distinctive 
look and feel
 License:SUSE-Ubuntu-Font-License-1.0




commit xtables-geoip for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package xtables-geoip for openSUSE:Factory 
checked in at 2016-05-17 17:16:09

Comparing /work/SRC/openSUSE:Factory/xtables-geoip (Old)
 and  /work/SRC/openSUSE:Factory/.xtables-geoip.new (New)


Package is "xtables-geoip"

Changes:

--- /work/SRC/openSUSE:Factory/xtables-geoip/xtables-geoip.changes  
2015-11-13 23:36:03.0 +0100
+++ /work/SRC/openSUSE:Factory/.xtables-geoip.new/xtables-geoip.changes 
2016-05-17 17:16:10.0 +0200
@@ -1,0 +2,5 @@
+Sun May  8 17:49:06 UTC 2016 - jeng...@inai.de
+
+- Update database files to 2016.05.03
+
+---



Other differences:
--
++ xtables-geoip.spec ++
--- /var/tmp/diff_new_pack.4s81zZ/_old  2016-05-17 17:16:11.0 +0200
+++ /var/tmp/diff_new_pack.4s81zZ/_new  2016-05-17 17:16:11.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package xtables-geoip
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   xtables-geoip
-Version:2015.11
+Version:2016.05
 Release:0
 Summary:Geolocation database files for xt_geoip
 License:CC-BY-SA-3.0

++ GeoIPCountryWhois.csv.xz ++
 35096 lines (skipped)
 between GeoIPCountryWhois.csv.xz
 and /work/SRC/openSUSE:Factory/.xtables-geoip.new/GeoIPCountryWhois.csv.xz

++ GeoIPv6.csv.xz ++
 6801 lines (skipped)
 between GeoIPv6.csv.xz
 and /work/SRC/openSUSE:Factory/.xtables-geoip.new/GeoIPv6.csv.xz




commit mmc-utils for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package mmc-utils for openSUSE:Factory 
checked in at 2016-05-17 17:15:21

Comparing /work/SRC/openSUSE:Factory/mmc-utils (Old)
 and  /work/SRC/openSUSE:Factory/.mmc-utils.new (New)


Package is "mmc-utils"

Changes:

--- /work/SRC/openSUSE:Factory/mmc-utils/mmc-utils.changes  2016-03-16 
10:34:35.0 +0100
+++ /work/SRC/openSUSE:Factory/.mmc-utils.new/mmc-utils.changes 2016-05-17 
17:15:22.0 +0200
@@ -1,0 +2,6 @@
+Thu May 12 20:45:28 UTC 2016 - mplus...@suse.com
+
+- Update to version 0.1+git.20160511:
+  * mmc-utils: Add disable partition boot to 'mmc bootpart enable'
+
+---

Old:

  mmc-utils-0.1~git.20160308.tar.xz

New:

  mmc-utils-0.1+git.20160511.tar.xz



Other differences:
--
++ mmc-utils.spec ++
--- /var/tmp/diff_new_pack.070otw/_old  2016-05-17 17:15:23.0 +0200
+++ /var/tmp/diff_new_pack.070otw/_new  2016-05-17 17:15:23.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   mmc-utils
-Version:0.1~git.20160308
+Version:0.1+git.20160511
 Release:0
 Summary:Tools for MMC/SD devices
 License:GPL-2.0

++ _service ++
--- /var/tmp/diff_new_pack.070otw/_old  2016-05-17 17:15:23.0 +0200
+++ /var/tmp/diff_new_pack.070otw/_new  2016-05-17 17:15:23.0 +0200
@@ -4,7 +4,7 @@
 git
 mmc-utils
 enable
-0.1~git.%ad
+0.1+git.%cd
   
   
 *.tar




commit libbullet for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package libbullet for openSUSE:Factory 
checked in at 2016-05-17 17:15:28

Comparing /work/SRC/openSUSE:Factory/libbullet (Old)
 and  /work/SRC/openSUSE:Factory/.libbullet.new (New)


Package is "libbullet"

Changes:

--- /work/SRC/openSUSE:Factory/libbullet/libbullet.changes  2016-05-08 
10:46:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.libbullet.new/libbullet.changes 2016-05-17 
17:15:30.0 +0200
@@ -1,0 +2,7 @@
+Fri May 13 02:56:25 UTC 2016 - sfl...@suse.de
+
+- Fix CFlags in bullet.pc to not be /usr/usr upstream ticket #626
+  This patch has been submitted upstream by myself.
+  * Adds fix-pkgconfig-cflags.patch
+
+---

New:

  fix-pkgconfig-cflags.patch



Other differences:
--
++ libbullet.spec ++
--- /var/tmp/diff_new_pack.4qHFan/_old  2016-05-17 17:15:31.0 +0200
+++ /var/tmp/diff_new_pack.4qHFan/_new  2016-05-17 17:15:31.0 +0200
@@ -26,6 +26,7 @@
 Url:http://bulletphysics.org/
 Source: 
https://github.com/bulletphysics/bullet3/archive/%{version}/bullet3-%{version}.tar.gz
 Patch0: fix-gtest.patch
+Patch1: fix-pkgconfig-cflags.patch
 BuildRequires:  cmake
 BuildRequires:  fdupes
 BuildRequires:  freeglut-devel
@@ -64,6 +65,7 @@
 %prep
 %setup -q -n bullet3-%{version}
 %patch0 -p1
+%patch1 -p1
 sed -i 's/\r//' README.md
 
 %build

++ fix-pkgconfig-cflags.patch ++
Index: bullet3-2.83.7/bullet.pc.cmake
===
--- bullet3-2.83.7.orig/bullet.pc.cmake
+++ bullet3-2.83.7/bullet.pc.cmake
@@ -3,4 +3,4 @@ Description: Bullet Continuous Collision
 Requires:
 Version: @BULLET_VERSION@
 Libs: -L@CMAKE_INSTALL_PREFIX@/@LIB_DESTINATION@ -lBulletSoftBody 
-lBulletDynamics -lBulletCollision -lLinearMath
-Cflags: @BULLET_DOUBLE_DEF@ -I@CMAKE_INSTALL_PREFIX@/@INCLUDE_INSTALL_DIR@ 
-I@CMAKE_INSTALL_PREFIX@/include
+Cflags: @BULLET_DOUBLE_DEF@ -I@INCLUDE_INSTALL_DIR@ 
-I@CMAKE_INSTALL_PREFIX@/include



commit hdevtools for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package hdevtools for openSUSE:Factory 
checked in at 2016-05-17 17:15:52

Comparing /work/SRC/openSUSE:Factory/hdevtools (Old)
 and  /work/SRC/openSUSE:Factory/.hdevtools.new (New)


Package is "hdevtools"

Changes:

--- /work/SRC/openSUSE:Factory/hdevtools/hdevtools.changes  2016-03-16 
10:33:37.0 +0100
+++ /work/SRC/openSUSE:Factory/.hdevtools.new/hdevtools.changes 2016-05-17 
17:15:53.0 +0200
@@ -1,0 +2,7 @@
+Sat May 14 20:04:55 UTC 2016 - mimi...@gmail.com
+
+- update to 0.1.3.1
+* Added support for new Cabal versions
+* Do not generate code, fixing inline-c modules typechecking
+
+---

Old:

  hdevtools-0.1.3.0.tar.gz

New:

  hdevtools-0.1.3.1.tar.gz



Other differences:
--
++ hdevtools.spec ++
--- /var/tmp/diff_new_pack.mxzSnF/_old  2016-05-17 17:15:54.0 +0200
+++ /var/tmp/diff_new_pack.mxzSnF/_new  2016-05-17 17:15:54.0 +0200
@@ -18,7 +18,7 @@
 
 %global debug_package %{nil}
 Name:   hdevtools
-Version:0.1.3.0
+Version:0.1.3.1
 Release:0
 Summary:Persistent GHC powered background server for FAST haskell 
development tools
 License:MIT

++ hdevtools-0.1.3.0.tar.gz -> hdevtools-0.1.3.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hdevtools-0.1.3.0/CHANGELOG.md 
new/hdevtools-0.1.3.1/CHANGELOG.md
--- old/hdevtools-0.1.3.0/CHANGELOG.md  2016-02-29 09:34:28.0 +0100
+++ new/hdevtools-0.1.3.1/CHANGELOG.md  2016-05-13 14:29:31.0 +0200
@@ -1,5 +1,10 @@
 # Changelog
 
+## 0.1.3.1 - 2016-05-13
+
+ * Added support for new Cabal versions
+ * Do not generate code, fixing inline-c modules typechecking
+
 ## 0.1.3.0 - 2016-02-29
 
  * Improved performance in stack projects: The stack configuration is
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hdevtools-0.1.3.0/hdevtools.cabal 
new/hdevtools-0.1.3.1/hdevtools.cabal
--- old/hdevtools-0.1.3.0/hdevtools.cabal   2016-02-29 09:48:29.0 
+0100
+++ new/hdevtools-0.1.3.1/hdevtools.cabal   2016-05-13 14:22:19.0 
+0200
@@ -1,10 +1,10 @@
 name:hdevtools
-version: 0.1.3.0
+version: 0.1.3.1
 synopsis:Persistent GHC powered background server for FAST haskell 
development tools
 license: MIT
 license-file:LICENSE
 author:  Bit Connor
-maintainer:  Sebastian Nagel , 
+maintainer:  Sebastian Nagel ,
  Ranjit Jhala 
 copyright:   See AUTHORS file
 category:Development
@@ -38,7 +38,7 @@
 for getting info about identifiers, and getting type information for 
snippets
 of code.
 
-extra-source-files:  
+extra-source-files:
   CHANGELOG.md
   README.md
 
@@ -49,7 +49,6 @@
 executable hdevtools
   hs-source-dirs:  src
   ghc-options: -Wall
-  cpp-options: -DCABAL
   main-is: Main.hs
   other-modules:   Cabal,
Client,
@@ -79,15 +78,11 @@
unix
 
   if impl(ghc == 7.6.*)
-build-depends: Cabal == 1.16.*
-cpp-options:   -DENABLE_CABAL
+build-depends: Cabal >= 1.16
 
   if impl(ghc >= 7.7)
 build-depends: Cabal >= 1.18
-cpp-options:   -DENABLE_CABAL
 
   if impl(ghc >= 7.9)
 build-depends: Cabal >= 1.22,
bin-package-db
-
-cpp-options:   -DENABLE_CABAL
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hdevtools-0.1.3.0/src/Cabal.hs 
new/hdevtools-0.1.3.1/src/Cabal.hs
--- old/hdevtools-0.1.3.0/src/Cabal.hs  2016-02-29 09:29:22.0 +0100
+++ new/hdevtools-0.1.3.1/src/Cabal.hs  2016-03-22 20:54:41.0 +0100
@@ -4,7 +4,6 @@
   , findCabalFile
   ) where
 
-#ifdef ENABLE_CABAL
 import Stack
 import Control.Exception (IOException, catch)
 import Control.Monad (when)
@@ -22,7 +21,7 @@
 import Distribution.Simple.Configure (configure)
 import Distribution.Simple.LocalBuildInfo (LocalBuildInfo(..), 
ComponentLocalBuildInfo(..),
 Component(..), ComponentName(..),
-#if __GLASGOW_HASKELL__ < 707
+#if !MIN_VERSION_Cabal(1,18,0)
 allComponentsBy,
 #endif
 componentBuildInfo, foldComponent)
@@ -34,10 +33,10 @@
 import Distribution.Simple.Program.Types (ConfiguredProgram(programVersion), 
simpleProgram)
 import Distribution.Simple.Program.GHC (GhcOptions(..), renderGhcOptions)
 import Distribution.Simple.Setup (ConfigFlags(..), defaultConfigFlags, 

commit mate-menu for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package mate-menu for openSUSE:Factory 
checked in at 2016-05-17 17:15:08

Comparing /work/SRC/openSUSE:Factory/mate-menu (Old)
 and  /work/SRC/openSUSE:Factory/.mate-menu.new (New)


Package is "mate-menu"

Changes:

--- /work/SRC/openSUSE:Factory/mate-menu/mate-menu.changes  2016-04-30 
23:31:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.mate-menu.new/mate-menu.changes 2016-05-17 
17:15:11.0 +0200
@@ -1,0 +2,7 @@
+Wed May  4 16:34:01 UTC 2016 - sor.ale...@meowr.ru
+
+- Add a missing python-gobject-Gdk dependency.
+- Remove useless libmate-desktop-2-17, libmate-panel-applet-4-1
+  dependencies.
+
+---



Other differences:
--
++ mate-menu.spec ++
--- /var/tmp/diff_new_pack.8Vj5po/_old  2016-05-17 17:15:12.0 +0200
+++ /var/tmp/diff_new_pack.8Vj5po/_new  2016-05-17 17:15:12.0 +0200
@@ -38,8 +38,6 @@
 BuildRequires:  update-desktop-files
 Requires:   glib2-tools
 Requires:   gvfs
-Requires:   libmate-desktop-2-17
-Requires:   libmate-panel-applet-4-1
 Requires:   mate-menus
 Requires:   mozo
 Requires:   python-configobj
@@ -52,6 +50,9 @@
 Recommends: lsb-release
 BuildArch:  noarch
 %glib2_gsettings_schema_requires
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python-gobject-Gdk
+%endif
 
 %description
 An advanced menu for MATE. Supports filtering, favourites,
@@ -76,6 +77,7 @@
 python2 setup.py install \
   --root=%{buildroot}\
   --prefix=%{_prefix}
+
 %py_compile %{buildroot}%{_libexecdir}/%{name}/
 %py_compile %{buildroot}%{_datadir}/%{name}/plugins/
 %find_lang %{name}




commit ghc-GLURaw for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-GLURaw for openSUSE:Factory 
checked in at 2016-05-17 17:15:49

Comparing /work/SRC/openSUSE:Factory/ghc-GLURaw (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-GLURaw.new (New)


Package is "ghc-GLURaw"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-GLURaw/ghc-GLURaw.changes2016-01-22 
01:08:41.0 +0100
+++ /work/SRC/openSUSE:Factory/.ghc-GLURaw.new/ghc-GLURaw.changes   
2016-05-17 17:15:50.0 +0200
@@ -1,0 +2,7 @@
+Thu May 12 18:39:24 UTC 2016 - mimi...@gmail.com
+
+- update to 2.0.0.2
+* Relaxed upper version bound for OpenGLRaw.
+* Silence warnings about pattern synonyms with no type signatures.
+
+---

Old:

  GLURaw-2.0.0.1.tar.gz

New:

  GLURaw-2.0.0.2.tar.gz



Other differences:
--
++ ghc-GLURaw.spec ++
--- /var/tmp/diff_new_pack.jMm264/_old  2016-05-17 17:15:51.0 +0200
+++ /var/tmp/diff_new_pack.jMm264/_new  2016-05-17 17:15:51.0 +0200
@@ -18,7 +18,7 @@
 
 %global pkg_name GLURaw
 Name:   ghc-GLURaw
-Version:2.0.0.1
+Version:2.0.0.2
 Release:0
 Summary:A raw binding for the OpenGL graphics system
 License:BSD-3-Clause

++ GLURaw-2.0.0.1.tar.gz -> GLURaw-2.0.0.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/GLURaw-2.0.0.1/CHANGELOG.md 
new/GLURaw-2.0.0.2/CHANGELOG.md
--- old/GLURaw-2.0.0.1/CHANGELOG.md 2016-01-10 16:25:43.0 +0100
+++ new/GLURaw-2.0.0.2/CHANGELOG.md 2016-05-11 14:37:48.0 +0200
@@ -1,3 +1,8 @@
+2.0.0.2
+---
+* Relaxed upper version bound for `OpenGLRaw`.
+* Silence warnings about pattern synonyms with no type signatures.
+
 2.0.0.1
 ---
 * Relaxed upper version bound for `OpenGLRaw`.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/GLURaw-2.0.0.1/GLURaw.cabal 
new/GLURaw-2.0.0.2/GLURaw.cabal
--- old/GLURaw-2.0.0.1/GLURaw.cabal 2016-01-10 16:25:43.0 +0100
+++ new/GLURaw-2.0.0.2/GLURaw.cabal 2016-05-11 14:22:16.0 +0200
@@ -1,5 +1,5 @@
 name: GLURaw
-version: 2.0.0.1
+version: 2.0.0.2
 synopsis: A raw binding for the OpenGL graphics system
 description:
   GLURaw is a raw Haskell binding for the GLU 1.3 OpenGL utility library. It is
@@ -21,6 +21,11 @@
 maintainer: Sven Panne , Jason Dagit 
 category: Graphics
 build-type: Simple
+tested-with:
+  GHC == 7.8.4
+  GHC == 7.10.3
+  GHC == 8.0.1
+  GHC == 8.1
 cabal-version:  >= 1.10
 extra-source-files:
   CHANGELOG.md
@@ -46,9 +51,11 @@
   build-depends:
 base >= 4   && < 5,
 transformers >= 0.2 && < 0.6,
-OpenGLRaw>= 3.0 && < 3.2
+OpenGLRaw>= 3.0 && < 3.3
   default-language: Haskell2010
   ghc-options: -Wall
+  if impl(ghc > 8)
+ghc-options: -Wcompat
   other-extensions:
 CPP
 PatternSynonyms
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/GLURaw-2.0.0.1/src/Graphics/GLU/Tokens.hs 
new/GLURaw-2.0.0.2/src/Graphics/GLU/Tokens.hs
--- old/GLURaw-2.0.0.1/src/Graphics/GLU/Tokens.hs   2016-01-10 
16:25:43.0 +0100
+++ new/GLURaw-2.0.0.2/src/Graphics/GLU/Tokens.hs   2016-02-26 
09:03:57.0 +0100
@@ -1,4 +1,7 @@
-{-# LANGUAGE PatternSynonyms, ScopedTypeVariables #-}
+{-# LANGUAGE CPP, PatternSynonyms, ScopedTypeVariables #-}
+#if __GLASGOW_HASKELL__ >= 800
+{-# OPTIONS_GHC -Wno-missing-pattern-synonym-signatures #-}
+#endif
 

 -- |
 -- Module  :  Graphics.GLU.Tokens




commit vala-panel-extras for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package vala-panel-extras for 
openSUSE:Factory checked in at 2016-05-17 17:15:42

Comparing /work/SRC/openSUSE:Factory/vala-panel-extras (Old)
 and  /work/SRC/openSUSE:Factory/.vala-panel-extras.new (New)


Package is "vala-panel-extras"

Changes:

--- /work/SRC/openSUSE:Factory/vala-panel-extras/vala-panel-extras.changes  
2015-08-23 17:53:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.vala-panel-extras.new/vala-panel-extras.changes 
2016-05-17 17:15:45.0 +0200
@@ -1,0 +2,7 @@
+Sat May  7 07:12:54 UTC 2016 - sor.ale...@meowr.ru
+
+- Add vala-panel-extras-fix-gquarks.patch: fix build by using int
+  instead of GQuark.
+- Fix build by using upstream glib-2.0.vapi.
+
+---

New:

  vala-panel-extras-fix-gquarks.patch



Other differences:
--
++ vala-panel-extras.spec ++
--- /var/tmp/diff_new_pack.U5qXsY/_old  2016-05-17 17:15:46.0 +0200
+++ /var/tmp/diff_new_pack.U5qXsY/_new  2016-05-17 17:15:46.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package vala-panel-extras
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,8 +26,11 @@
 Source: 
https://github.com/rilian-la-te/%{name}/releases/download/%{version}/%{name}-%{version}.tar.gz
 # PATCH-FIX-OPENSUSE vala-panel-extras-fix-xkb-build.patch sor.ale...@meowr.ru 
-- Fix XKB module build in some conditions.
 Patch0: %{name}-fix-xkb-build.patch
+# PATCH-FIX-OPENSUSE vala-panel-extras-fix-gquarks.patch sor.ale...@meowr.ru 
-- Fix build by using int instead of GQuark.
+Patch1: %{name}-fix-gquarks.patch
 BuildRequires:  cmake >= 2.8
 BuildRequires:  gettext
+BuildRequires:  pkg-config
 BuildRequires:  vala >= 0.24
 BuildRequires:  pkgconfig(alsa)
 BuildRequires:  pkgconfig(gdk-x11-3.0)
@@ -119,6 +122,11 @@
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%if 0%{?suse_version} != 1320
+# Use upstream glib-2.0.vapi.
+rm vapi/glib-2.0.vapi
+%endif
 
 %build
 %cmake \

++ vala-panel-extras-fix-gquarks.patch ++
--- a/lib/notifications.vala
+++ b/lib/notifications.vala
@@ -18,17 +18,17 @@ namespace Notifier
 public abstract string[] get_capabilites() throws Error;
 public abstract void get_server_information(out string name, out 
string vendor,
 out string version, out 
string specv) throws Error;
-public abstract Quark notify(string app_name,
-Quark id,
-string app_icon,
-string title,
-string body,
-string[] actions,
-HashTable hints,
-int expire_timeout) throws Error;
-public abstract Quark close_notification(Quark id) throws Error;
-public abstract signal void action_invoked(Quark id, string 
action_name);
-public abstract signal void notification_closed(Quark id, CloseReason 
reason);
+public abstract uint32 notify(string app_name,
+  uint32 id,
+  string app_icon,
+  string title,
+  string body,
+  string[] actions,
+  HashTable hints,
+  int expire_timeout) throws Error;
+public abstract uint32 close_notification(uint32 id) throws Error;
+public abstract signal void action_invoked(uint32 id, string 
action_name);
+public abstract signal void notification_closed(uint32 id, CloseReason 
reason);
 }
 public Daemon? get_daemon()
 {



commit eiciel for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package eiciel for openSUSE:Factory checked 
in at 2016-05-17 17:15:14

Comparing /work/SRC/openSUSE:Factory/eiciel (Old)
 and  /work/SRC/openSUSE:Factory/.eiciel.new (New)


Package is "eiciel"

Changes:

--- /work/SRC/openSUSE:Factory/eiciel/eiciel.changes2015-10-12 
10:02:57.0 +0200
+++ /work/SRC/openSUSE:Factory/.eiciel.new/eiciel.changes   2016-05-17 
17:15:15.0 +0200
@@ -1,0 +2,8 @@
+Thu May 12 14:09:28 UTC 2016 - dims...@opensuse.org
+
+- Do not delete the .desktop file. It is needed for AppStream
+  processes to have a valid reference.
+- Add update-desktop-files BuildRequires.
+- Change Categories of eiciel.desktop to System;Filesystem.
+
+---



Other differences:
--
++ eiciel.spec ++
--- /var/tmp/diff_new_pack.tfQiLZ/_old  2016-05-17 17:15:17.0 +0200
+++ /var/tmp/diff_new_pack.tfQiLZ/_new  2016-05-17 17:15:17.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package eiciel
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -32,6 +32,7 @@
 BuildRequires:  libattr-devel
 BuildRequires:  libgnomeui-devel
 BuildRequires:  translation-update-upstream
+BuildRequires:  update-desktop-files
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if 0%{?favor_gtk2}
@@ -76,7 +77,7 @@
 make DESTDIR=%{buildroot} install %{?_smp_mflags}
 %find_lang %{name} %{?no_lang_C}
 find %{buildroot} -type f -name "*.la" -delete -print
-rm %{buildroot}%{_datadir}/applications/*.desktop
+%suse_update_desktop_file -r eiciel System Filesystem
 %fdupes -s %{buildroot}
 
 %files
@@ -90,6 +91,7 @@
 %doc %{_mandir}/man1/eiciel.1.gz
 %dir %{_datadir}/appdata
 %{_datadir}/appdata/eiciel.appdata.xml
+%{_datadir}/applications/eiciel.desktop
 %{_datadir}/eiciel/
 %{_datadir}/icons/hicolor/*/apps/eiciel.*
 




commit nemo-extensions for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package nemo-extensions for openSUSE:Factory 
checked in at 2016-05-17 17:15:10

Comparing /work/SRC/openSUSE:Factory/nemo-extensions (Old)
 and  /work/SRC/openSUSE:Factory/.nemo-extensions.new (New)


Package is "nemo-extensions"

Changes:

--- /work/SRC/openSUSE:Factory/nemo-extensions/nemo-extensions.changes  
2016-04-30 23:29:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.nemo-extensions.new/nemo-extensions.changes 
2016-05-17 17:15:12.0 +0200
@@ -1,0 +2,6 @@
+Wed May  4 16:34:01 UTC 2016 - sor.ale...@meowr.ru
+
+- nemo-extension-{emblems,pastebin,terminal}: add a missing
+  python-gobject-Gdk dependency.
+
+---



Other differences:
--
++ nemo-extensions.spec ++
--- /var/tmp/diff_new_pack.A1t7P1/_old  2016-05-17 17:15:13.0 +0200
+++ /var/tmp/diff_new_pack.A1t7P1/_new  2016-05-17 17:15:13.0 +0200
@@ -148,6 +148,9 @@
 Provides:   nemo-emblems = %{version}
 Obsoletes:  nemo-emblems < %{version}
 BuildArch:  noarch
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python-gobject-Gdk
+%endif
 
 %description -n nemo-extension-emblems
 Change a directory or a file emblem in Nemo, the Cinnamon desktop
@@ -211,6 +214,9 @@
 Obsoletes:  nemo-pastebin < %{version}
 BuildArch:  noarch
 %glib2_gsettings_schema_requires
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python-gobject-Gdk
+%endif
 
 %description -n nemo-extension-pastebin
 nemo-pastebin is an extension for the Nemo file manager, which
@@ -306,6 +312,9 @@
 Provides:   nemo-terminal = %{version}
 Obsoletes:  nemo-terminal < %{version}
 BuildArch:  noarch
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python-gobject-Gdk
+%endif
 
 %description -n nemo-extension-terminal
 Nemo Terminal is an embedded terminal for Nemo, the Cinnamon file




commit blueberry for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package blueberry for openSUSE:Factory 
checked in at 2016-05-17 17:15:31

Comparing /work/SRC/openSUSE:Factory/blueberry (Old)
 and  /work/SRC/openSUSE:Factory/.blueberry.new (New)


Package is "blueberry"

Changes:

--- /work/SRC/openSUSE:Factory/blueberry/blueberry.changes  2016-04-28 
17:03:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.blueberry.new/blueberry.changes 2016-05-17 
17:15:33.0 +0200
@@ -1,0 +2,5 @@
+Wed May  4 16:34:01 UTC 2016 - sor.ale...@meowr.ru
+
+- Add a missing python-gobject-Gdk dependency.
+
+---



Other differences:
--
++ blueberry.spec ++
--- /var/tmp/diff_new_pack.WTKCBw/_old  2016-05-17 17:15:34.0 +0200
+++ /var/tmp/diff_new_pack.WTKCBw/_new  2016-05-17 17:15:34.0 +0200
@@ -36,6 +36,9 @@
 Recommends: %{name}-lang
 BuildArch:  noarch
 %glib2_gsettings_schema_requires
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python-gobject-Gdk
+%endif
 
 %description
 Utility for Bluetooth devices graphical configuration.




commit ghc for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc for openSUSE:Factory checked in 
at 2016-05-17 17:15:36

Comparing /work/SRC/openSUSE:Factory/ghc (Old)
 and  /work/SRC/openSUSE:Factory/.ghc.new (New)


Package is "ghc"

Changes:

--- /work/SRC/openSUSE:Factory/ghc/ghc.changes  2016-04-30 23:30:22.0 
+0200
+++ /work/SRC/openSUSE:Factory/.ghc.new/ghc.changes 2016-05-17 
17:15:38.0 +0200
@@ -1,0 +2,11 @@
+Sat May 14 09:13:07 UTC 2016 - peter.tromm...@ohm-hochschule.de
+
+- add D2214.patch
+* backport of upstream patch slated for ghc 8.0.2
+* fix issue in code PowerPC code generator (32 bit and 64 bit)
+- add 0001-Fix-misspelled-WORDS_BIGENDIAN-macro.patch
+* backport of upstream fix slated for ghc 8.0.2
+* fix bytestring library on big-endian archs
+* fix wrong results in ghc-pureMD5 and others on big-endian 
+
+---

New:

  0001-Fix-misspelled-WORDS_BIGENDIAN-macro.patch
  D2214.patch



Other differences:
--
++ ghc.spec ++
--- /var/tmp/diff_new_pack.YtjYiq/_old  2016-05-17 17:15:39.0 +0200
+++ /var/tmp/diff_new_pack.YtjYiq/_new  2016-05-17 17:15:39.0 +0200
@@ -82,6 +82,11 @@
 Patch22:u_Cabal_update.patch
 # PATCH-FIX-UPSTREAM u_haskeline_update.patch mimi...@gmail.com -- update 
haskeline to 0.7.2.3
 Patch23:u_haskeline_update.patch
+# PATCH-FIX-UPSTREAM 0001-Fix-misspelled-WORDS_BIGENDIAN-macro.patch 
peter.tromm...@ohm-hochschule.de -- Fix ghc-pureMD5 and other Haskell packages 
on big-endian architectures.
+Patch24:0001-Fix-misspelled-WORDS_BIGENDIAN-macro.patch
+# PATCH-FIX-UPSTREAM D2214.patch peter.tromm...@ohm-hochschule.de -- Fix 
PowerPC code generator. See Haskell Trac #12054 and 
https://phabricator.haskell.org/D2214 for details.
+Patch25:D2214.patch
+
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -178,6 +183,8 @@
 %patch21 -p2
 %patch22 -p2
 %patch23 -p2
+%patch24 -p1
+%patch25 -p1
 
 %build
 # Patch 19 modifies build system

++ 0001-Fix-misspelled-WORDS_BIGENDIAN-macro.patch ++
>From 4f52849a99753fab63d634769dd35a31f4d5a1b2 Mon Sep 17 00:00:00 2001
From: Herbert Valerio Riedel 
Date: Thu, 12 May 2016 20:36:34 +0200
Subject: [PATCH] Fix misspelled WORDS_BIGENDIAN macro

This was causing word{16,32,64}{le,be} primitives to break
on big endian archs (such as `powerpc`/`powerpc64`) with
serious consequences such as
https://github.com/TomMD/pureMD5/issues/5
---
 Data/ByteString/Builder/Prim/Binary.hs | 12 ++--
 1 file changed, 6 insertions(+), 6 deletions(-)

Index: ghc-8.0.1/libraries/bytestring/Data/ByteString/Builder/Prim/Binary.hs
===
--- ghc-8.0.1.orig/libraries/bytestring/Data/ByteString/Builder/Prim/Binary.hs
+++ ghc-8.0.1/libraries/bytestring/Data/ByteString/Builder/Prim/Binary.hs
@@ -83,7 +83,7 @@ word8 = storableToF
 -- | Encoding 'Word16's in big endian format.
 {-# INLINE word16BE #-}
 word16BE :: FixedPrim Word16
-#ifdef WORD_BIGENDIAN
+#ifdef WORDS_BIGENDIAN
 word16BE = word16Host
 #else
 word16BE = fixedPrim 2 $ \w p -> do
@@ -94,7 +94,7 @@ word16BE = fixedPrim 2 $ \w p -> do
 -- | Encoding 'Word16's in little endian format.
 {-# INLINE word16LE #-}
 word16LE :: FixedPrim Word16
-#ifdef WORD_BIGENDIAN
+#ifdef WORDS_BIGENDIAN
 word16LE = fixedPrim 2 $ \w p -> do
 poke p   (fromIntegral (w)  :: Word8)
 poke (p `plusPtr` 1) (fromIntegral (shiftr_w16 w 8) :: Word8)
@@ -105,7 +105,7 @@ word16LE = word16Host
 -- | Encoding 'Word32's in big endian format.
 {-# INLINE word32BE #-}
 word32BE :: FixedPrim Word32
-#ifdef WORD_BIGENDIAN
+#ifdef WORDS_BIGENDIAN
 word32BE = word32Host
 #else
 word32BE = fixedPrim 4 $ \w p -> do
@@ -118,7 +118,7 @@ word32BE = fixedPrim 4 $ \w p -> do
 -- | Encoding 'Word32's in little endian format.
 {-# INLINE word32LE #-}
 word32LE :: FixedPrim Word32
-#ifdef WORD_BIGENDIAN
+#ifdef WORDS_BIGENDIAN
 word32LE = fixedPrim 4 $ \w p -> do
 poke p   (fromIntegral (w)   :: Word8)
 poke (p `plusPtr` 1) (fromIntegral (shiftr_w32 w  8) :: Word8)
@@ -134,7 +134,7 @@ word32LE = word32Host
 -- | Encoding 'Word64's in big endian format.
 {-# INLINE word64BE #-}
 word64BE :: FixedPrim Word64
-#ifdef WORD_BIGENDIAN
+#ifdef WORDS_BIGENDIAN
 word64BE = word64Host
 #else
 #if WORD_SIZE_IN_BITS < 64
@@ -170,7 +170,7 @@ word64BE = fixedPrim 8 $ \w p -> do
 -- | Encoding 'Word64's in little endian format.
 {-# INLINE word64LE #-}
 word64LE :: FixedPrim Word64
-#ifdef WORD_BIGENDIAN
+#ifdef WORDS_BIGENDIAN
 #if WORD_SIZE_IN_BITS < 64
 word64LE =
 fixedPrim 8 $ \w p -> do
++ D2214.patch ++
Index: 

commit ghc-extra for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-extra for openSUSE:Factory 
checked in at 2016-05-17 17:15:47

Comparing /work/SRC/openSUSE:Factory/ghc-extra (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-extra.new (New)


Package is "ghc-extra"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-extra/ghc-extra.changes  2016-05-03 
10:16:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-extra.new/ghc-extra.changes 2016-05-17 
17:15:48.0 +0200
@@ -1,0 +2,6 @@
+Thu May 12 13:35:41 UTC 2016 - mimi...@gmail.com
+
+- update to 1.4.6
+* add maybeM and eitherM
+
+---

Old:

  extra-1.4.5.tar.gz

New:

  extra-1.4.6.tar.gz



Other differences:
--
++ ghc-extra.spec ++
--- /var/tmp/diff_new_pack.R7uanh/_old  2016-05-17 17:15:49.0 +0200
+++ /var/tmp/diff_new_pack.R7uanh/_new  2016-05-17 17:15:49.0 +0200
@@ -21,7 +21,7 @@
 %global debug_package %{nil}
 %bcond_with tests
 Name:   ghc-extra
-Version:1.4.5
+Version:1.4.6
 Release:0
 Summary:Extra functions I use
 License:BSD-3-Clause

++ extra-1.4.5.tar.gz -> extra-1.4.6.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/extra-1.4.5/CHANGES.txt new/extra-1.4.6/CHANGES.txt
--- old/extra-1.4.5/CHANGES.txt 2016-04-29 21:36:57.0 +0200
+++ new/extra-1.4.6/CHANGES.txt 2016-05-11 13:08:20.0 +0200
@@ -1,5 +1,7 @@
 Changelog for Extra
 
+1.4.6
+#11, add maybeM and eitherM
 1.4.5
 #17, change fileEq on files that do not exist to be an error
 1.4.4
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/extra-1.4.5/extra.cabal new/extra-1.4.6/extra.cabal
--- old/extra-1.4.5/extra.cabal 2016-04-29 21:36:57.0 +0200
+++ new/extra-1.4.6/extra.cabal 2016-05-11 13:08:20.0 +0200
@@ -1,7 +1,7 @@
 cabal-version:  >= 1.10
 build-type: Simple
 name:   extra
-version:1.4.5
+version:1.4.6
 license:BSD3
 license-file:   LICENSE
 category:   Development
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/extra-1.4.5/src/Control/Monad/Extra.hs 
new/extra-1.4.6/src/Control/Monad/Extra.hs
--- old/extra-1.4.5/src/Control/Monad/Extra.hs  2016-04-29 21:36:57.0 
+0200
+++ new/extra-1.4.6/src/Control/Monad/Extra.hs  2016-05-11 13:08:20.0 
+0200
@@ -8,6 +8,7 @@
 module Control.Monad,
 whenJust, whenJustM,
 unit,
+maybeM, eitherM,
 -- * Loops
 loopM, whileM,
 -- * Lists
@@ -42,6 +43,16 @@
 unit :: m () -> m ()
 unit = id
 
+
+-- | Monadic generalisation of 'maybe'.
+maybeM :: Monad m => m b -> (a -> m b) -> m (Maybe a) -> m b
+maybeM n j x = maybe n j =<< x
+
+
+-- | Monadic generalisation of 'either'.
+eitherM :: Monad m => (a -> m c) -> (b -> m c) -> m (Either a b) -> m c
+eitherM l r x = either l r =<< x
+
 -- Data.List for Monad
 
 -- | A version of 'partition' that works with a monadic predicate.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/extra-1.4.5/src/Extra.hs new/extra-1.4.6/src/Extra.hs
--- old/extra-1.4.5/src/Extra.hs2016-04-29 21:36:57.0 +0200
+++ new/extra-1.4.6/src/Extra.hs2016-05-11 13:08:20.0 +0200
@@ -14,7 +14,7 @@
 retry, retryBool, showException, stringException, errorIO, ignore, catch_, 
handle_, try_, catchJust_, handleJust_, tryJust_, catchBool, handleBool, 
tryBool,
 -- * Control.Monad.Extra
 -- | Extra functions available in @"Control.Monad.Extra"@.
-whenJust, whenJustM, unit, loopM, whileM, partitionM, concatMapM, 
mconcatMapM, mapMaybeM, findM, firstJustM, whenM, unlessM, ifM, notM, (||^), 
(&&^), orM, andM, anyM, allM,
+whenJust, whenJustM, unit, maybeM, eitherM, loopM, whileM, partitionM, 
concatMapM, mconcatMapM, mapMaybeM, findM, firstJustM, whenM, unlessM, ifM, 
notM, (||^), (&&^), orM, andM, anyM, allM,
 -- * Data.Either.Extra
 -- | Extra functions available in @"Data.Either.Extra"@.
 isLeft, isRight, fromLeft, fromRight, fromEither,




commit ghc-OpenGL for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-OpenGL for openSUSE:Factory 
checked in at 2016-05-17 17:15:54

Comparing /work/SRC/openSUSE:Factory/ghc-OpenGL (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-OpenGL.new (New)


Package is "ghc-OpenGL"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-OpenGL/ghc-OpenGL.changes2016-04-22 
16:25:27.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-OpenGL.new/ghc-OpenGL.changes   
2016-05-17 17:15:54.0 +0200
@@ -1,0 +2,9 @@
+Thu May 12 19:12:48 UTC 2016 - mimi...@gmail.com
+
+- update to 3.0.1.0
+* Added Uniform instances for GLmatrix, Vertex1, Vector1, Vector2, Vector3,
+and Vector4.
+* Unbreak Uniform instances for GLint, GLuint and Gldouble.
+* Relaxed upper version bound for OpenGLRaw.
+
+---

Old:

  OpenGL-3.0.0.2.tar.gz

New:

  OpenGL-3.0.1.0.tar.gz



Other differences:
--
++ ghc-OpenGL.spec ++
--- /var/tmp/diff_new_pack.QcBTH8/_old  2016-05-17 17:15:55.0 +0200
+++ /var/tmp/diff_new_pack.QcBTH8/_new  2016-05-17 17:15:55.0 +0200
@@ -19,7 +19,7 @@
 %global pkg_name OpenGL
 
 Name:   ghc-OpenGL
-Version:3.0.0.2
+Version:3.0.1.0
 Release:0
 Summary:A binding for the OpenGL graphics system
 License:BSD-3-Clause

++ OpenGL-3.0.0.2.tar.gz -> OpenGL-3.0.1.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/OpenGL-3.0.0.2/CHANGELOG.md 
new/OpenGL-3.0.1.0/CHANGELOG.md
--- old/OpenGL-3.0.0.2/CHANGELOG.md 2016-04-11 08:30:08.0 +0200
+++ new/OpenGL-3.0.1.0/CHANGELOG.md 2016-05-11 14:20:57.0 +0200
@@ -1,3 +1,9 @@
+3.0.1.0
+---
+* Added `Uniform` instances for `GLmatrix`, `Vertex1`, `Vector1`, `Vector2`, 
`Vector3`, and `Vector4`.
+* Unbreak `Uniform` instances for `GLint`, `GLuint` and `Gldouble`.
+* Relaxed upper version bound for `OpenGLRaw`.
+
 3.0.0.2
 ---
 * Removed redundant constraints.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/OpenGL-3.0.0.2/OpenGL.cabal 
new/OpenGL-3.0.1.0/OpenGL.cabal
--- old/OpenGL-3.0.0.2/OpenGL.cabal 2016-04-11 08:30:36.0 +0200
+++ new/OpenGL-3.0.1.0/OpenGL.cabal 2016-05-11 14:20:57.0 +0200
@@ -1,5 +1,5 @@
 name: OpenGL
-version: 3.0.0.2
+version: 3.0.1.0
 synopsis: A binding for the OpenGL graphics system
 description:
   A Haskell binding for the OpenGL graphics system (GL, version 4.5) and its
@@ -126,6 +126,7 @@
 Graphics.Rendering.OpenGL.GL.FramebufferObjects.RenderbufferTarget
 Graphics.Rendering.OpenGL.GL.GLboolean
 Graphics.Rendering.OpenGL.GL.IOState
+Graphics.Rendering.OpenGL.GL.MatrixComponent
 Graphics.Rendering.OpenGL.GL.PeekPoke
 Graphics.Rendering.OpenGL.GL.PixelData
 Graphics.Rendering.OpenGL.GL.PixelFormat
@@ -162,7 +163,7 @@
 transformers >= 0.2 && < 0.6,
 ObjectName   >= 1.1 && < 1.2,
 StateVar >= 1.1 && < 1.2,
-OpenGLRaw>= 3.0 && < 3.2,
+OpenGLRaw>= 3.0 && < 3.3,
 GLURaw   >= 2.0 && < 2.1
   default-language: Haskell2010
   other-extensions:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/OpenGL-3.0.0.2/src/Graphics/Rendering/OpenGL/GL/CoordTrans.hs 
new/OpenGL-3.0.1.0/src/Graphics/Rendering/OpenGL/GL/CoordTrans.hs
--- old/OpenGL-3.0.0.2/src/Graphics/Rendering/OpenGL/GL/CoordTrans.hs   
2016-01-04 08:30:21.0 +0100
+++ new/OpenGL-3.0.1.0/src/Graphics/Rendering/OpenGL/GL/CoordTrans.hs   
2016-05-11 10:58:44.0 +0200
@@ -13,8 +13,6 @@
 --
 

 
-{-# LANGUAGE TypeSynonymInstances #-}
-
 module Graphics.Rendering.OpenGL.GL.CoordTrans (
-- * Controlling the Viewport
depthRange,
@@ -43,9 +41,9 @@
 import Foreign.Marshal.Utils
 import Foreign.Ptr
 import Foreign.Storable
-import Graphics.Rendering.OpenGL.GL.Tensor
 import Graphics.Rendering.OpenGL.GL.Capability
 import Graphics.Rendering.OpenGL.GL.Exception
+import Graphics.Rendering.OpenGL.GL.MatrixComponent
 import Graphics.Rendering.OpenGL.GL.PeekPoke
 import Graphics.Rendering.OpenGL.GL.QueryUtils
 import Graphics.Rendering.OpenGL.GL.Texturing.TextureUnit
@@ -180,38 +178,6 @@
 
 

 
-class Storable c => MatrixComponent c where
-   getMatrix :: GetPNameMatrix p => p -> Ptr c -> IO ()
-   loadMatrix :: Ptr c -> IO ()
-   loadTransposeMatrix :: Ptr c -> IO ()
-   multMatrix_ :: Ptr c -> IO ()
-   multTransposeMatrix :: Ptr c -> IO ()
-   rotate :: c -> Vector3 c -> IO ()
-   translate :: Vector3 c -> IO 

commit ptpd for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ptpd for openSUSE:Factory checked in 
at 2016-05-17 17:15:16

Comparing /work/SRC/openSUSE:Factory/ptpd (Old)
 and  /work/SRC/openSUSE:Factory/.ptpd.new (New)


Package is "ptpd"

Changes:

--- /work/SRC/openSUSE:Factory/ptpd/ptpd.changes2015-06-09 
08:50:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.ptpd.new/ptpd.changes   2016-05-17 
17:15:20.0 +0200
@@ -1,0 +2,8 @@
+Thu May 12 19:33:35 UTC 2016 - mplus...@suse.com
+
+- Update to 2.3.1
+  * see attached Changelog for full list of changes
+- Update project and download url
+- Small spec file cleanups
+
+---

Old:

  ptpd-2.3.0.tar.gz

New:

  ptpd-2.3.1.tar.gz



Other differences:
--
++ ptpd.spec ++
--- /var/tmp/diff_new_pack.7Xdyhf/_old  2016-05-17 17:15:22.0 +0200
+++ /var/tmp/diff_new_pack.7Xdyhf/_new  2016-05-17 17:15:22.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package ptpd
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,13 +17,13 @@
 
 
 Name:   ptpd
-Version:2.3.0
+Version:2.3.1
 Release:0
 Summary:Implements the Precision Time protocol as defined by IEEE 1588 
standard
 License:BSD-3-Clause
 Group:  System/Daemons
-Url:http://ptpd.sourceforge.net/
-Source0:
http://downloads.sourceforge.net/project/%{name}/%{name}/%{version}/%{name}-%{version}.tar.gz
+Url:https://github.com/ptpd/ptpd
+Source0:https://github.com/ptpd/ptpd/archive/ptpd-%{version}.tar.gz
 Source1:ptpd2.service
 Source2:ptpd2.conf
 Source3:conf.sysconfig.ptpd
@@ -58,17 +58,15 @@
 PTPd is free. Everyone is invited to use and contribute to PTPd.
 
 %prep
-%setup -q
-autoreconf -fiv
+%setup -q -n %{name}-%{name}-%{version}
 
 %build
+autoreconf -fiv
 %configure \
---enable-statistics \
---enable-ntpdc \
---enable-sigusr2=counters
+  --enable-statistics
 
 %install
-make DESTDIR=%{buildroot} install %{?_smp_mflags}
+make %{?_smp_mflags} DESTDIR=%{buildroot} install
 install -D -m 644 %{SOURCE1} %{buildroot}/%{_unitdir}/%{name}2.service
 ln -sv %{_sbindir}/service %{buildroot}%{_sbindir}/rc%{name}2
 install -D -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/%{name}2.conf
@@ -77,17 +75,6 @@
 install -d %{buildroot}%{_localstatedir}/log
 touch %{buildroot}%{_localstatedir}/log/ptpd2_kernelclock.drift
 
-%files
-%defattr(-, root, root)
-%doc COPYRIGHT ChangeLog README
-%config %{_sysconfdir}/%{name}2.conf
-%{_sbindir}/*
-%{_mandir}/man8/*
-%{_mandir}/man5/*
-%{_libexecdir}/systemd/system/ptpd2.service
-%{_localstatedir}/adm/fillup-templates/*
-%config %ghost %{_localstatedir}/log/ptpd2_kernelclock.drift
-
 %pre
 %service_add_pre %{name}2.service
 
@@ -101,4 +88,16 @@
 %postun
 %service_del_postun %{name}2.service
 
+%files
+%defattr(-, root, root)
+%doc COPYRIGHT ChangeLog README
+%config %{_sysconfdir}/%{name}2.conf
+%{_sbindir}/*
+%{_mandir}/man8/*
+%{_mandir}/man5/*
+%{_datadir}/ptpd
+%{_libexecdir}/systemd/system/ptpd2.service
+%{_localstatedir}/adm/fillup-templates/*
+%config %ghost %{_localstatedir}/log/ptpd2_kernelclock.drift
+
 %changelog

++ ptpd-2.3.0.tar.gz -> ptpd-2.3.1.tar.gz ++
 30164 lines of diff (skipped)




commit ghc-conduit for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-conduit for openSUSE:Factory 
checked in at 2016-05-17 17:14:31

Comparing /work/SRC/openSUSE:Factory/ghc-conduit (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-conduit.new (New)


Package is "ghc-conduit"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-conduit/ghc-conduit.changes  2016-03-16 
10:36:10.0 +0100
+++ /work/SRC/openSUSE:Factory/.ghc-conduit.new/ghc-conduit.changes 
2016-05-17 17:14:32.0 +0200
@@ -1,0 +2,7 @@
+Sat May  7 06:19:42 UTC 2016 - mimi...@gmail.com
+
+- update to 1.2.6.6
+* Fix test suite compilation on older GHCs
+* In zipConduitApp, left bias not respected mixing monadic and non-monadic 
conduits
+
+---

Old:

  conduit-1.2.6.4.tar.gz

New:

  conduit-1.2.6.6.tar.gz



Other differences:
--
++ ghc-conduit.spec ++
--- /var/tmp/diff_new_pack.ai8y93/_old  2016-05-17 17:14:33.0 +0200
+++ /var/tmp/diff_new_pack.ai8y93/_new  2016-05-17 17:14:33.0 +0200
@@ -19,7 +19,7 @@
 %global pkg_name conduit
 
 Name:   ghc-conduit
-Version:1.2.6.4
+Version:1.2.6.6
 Release:0
 Summary:Streaming data processing library
 License:MIT

++ conduit-1.2.6.4.tar.gz -> conduit-1.2.6.6.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/conduit-1.2.6.4/ChangeLog.md 
new/conduit-1.2.6.6/ChangeLog.md
--- old/conduit-1.2.6.4/ChangeLog.md2016-03-10 09:33:45.0 +0100
+++ new/conduit-1.2.6.6/ChangeLog.md2016-05-05 14:29:07.0 +0200
@@ -1,3 +1,11 @@
+## 1.2.6.6
+
+* Fix test suite compilation on older GHCs
+
+## 1.2.6.5
+
+* In zipConduitApp, left bias not respected mixing monadic and non-monadic 
conduits [#263](https://github.com/snoyberg/conduit/pull/263)
+
 ## 1.2.6.4
 
 * Fix benchmark by adding a type signature
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/conduit-1.2.6.4/Data/Conduit/Internal/Conduit.hs 
new/conduit-1.2.6.6/Data/Conduit/Internal/Conduit.hs
--- old/conduit-1.2.6.4/Data/Conduit/Internal/Conduit.hs2016-03-10 
09:33:45.0 +0100
+++ new/conduit-1.2.6.6/Data/Conduit/Internal/Conduit.hs2016-05-05 
14:29:07.0 +0200
@@ -540,6 +540,8 @@
 -> ConduitM i o m y
 zipConduitApp (ConduitM left0) (ConduitM right0) = ConduitM $ \rest -> let
 go _ _ (Done f) (Done x) = rest (f x)
+go finalX finalY (PipeM mx) y = PipeM (flip (go finalX finalY) y `liftM` 
mx)
+go finalX finalY x (PipeM my) = PipeM (go finalX finalY x `liftM` my)
 go _ finalY (HaveOutput x finalX o) y = HaveOutput
 (go finalX finalY x y)
 (finalX >> finalY)
@@ -550,8 +552,6 @@
 o
 go _ _ (Leftover _ i) _ = absurd i
 go _ _ _ (Leftover _ i) = absurd i
-go finalX finalY (PipeM mx) y = PipeM (flip (go finalX finalY) y `liftM` 
mx)
-go finalX finalY x (PipeM my) = PipeM (go finalX finalY x `liftM` my)
 go finalX finalY (NeedInput px cx) (NeedInput py cy) = NeedInput
 (\i -> go finalX finalY (px i) (py i))
 (\u -> go finalX finalY (cx u) (cy u))
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/conduit-1.2.6.4/conduit.cabal 
new/conduit-1.2.6.6/conduit.cabal
--- old/conduit-1.2.6.4/conduit.cabal   2016-03-10 09:33:45.0 +0100
+++ new/conduit-1.2.6.6/conduit.cabal   2016-05-05 14:29:07.0 +0200
@@ -1,5 +1,5 @@
 Name:conduit
-Version: 1.2.6.4
+Version: 1.2.6.6
 Synopsis:Streaming data processing library.
 description:
 Hackage documentation generation is not reliable. For up to date 
documentation, please see: .
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/conduit-1.2.6.4/test/Data/Conduit/Extra/ZipConduitSpec.hs 
new/conduit-1.2.6.6/test/Data/Conduit/Extra/ZipConduitSpec.hs
--- old/conduit-1.2.6.4/test/Data/Conduit/Extra/ZipConduitSpec.hs   
2016-03-10 09:33:45.0 +0100
+++ new/conduit-1.2.6.6/test/Data/Conduit/Extra/ZipConduitSpec.hs   
2016-05-05 14:29:07.0 +0200
@@ -2,7 +2,7 @@
 import Test.Hspec
 import Data.Conduit
 import qualified Data.Conduit.List as CL
-import Control.Applicative ((<*))
+import Control.Applicative ((<*), pure)
 
 spec :: Spec
 spec = describe "Data.Conduit.Extra.ZipConduit" $ do
@@ -24,3 +24,11 @@
 sink = CL.consume
 res <- src $$ conduit =$ sink
 res `shouldBe` [2, 1, 1, 3, 2, 2, 4, 3, 3, 12]
+it "ZipConduitMonad" $ do
+let src = mapM_ yield [1..3 :: Int]
+

commit ipsec-tools for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ipsec-tools for openSUSE:Factory 
checked in at 2016-05-17 17:15:23

Comparing /work/SRC/openSUSE:Factory/ipsec-tools (Old)
 and  /work/SRC/openSUSE:Factory/.ipsec-tools.new (New)


Package is "ipsec-tools"

Changes:

--- /work/SRC/openSUSE:Factory/ipsec-tools/ipsec-tools.changes  2015-06-23 
11:56:49.0 +0200
+++ /work/SRC/openSUSE:Factory/.ipsec-tools.new/ipsec-tools.changes 
2016-05-17 17:15:24.0 +0200
@@ -1,0 +2,6 @@
+Wed Aug  5 10:58:13 UTC 2015 - meiss...@suse.com
+
+- do not run %fdupes over the whole tree, to avoid symlinking
+  /etc/ config files and /usr/ sample configs.
+
+---



Other differences:
--
++ ipsec-tools.spec ++
--- /var/tmp/diff_new_pack.UYufvz/_old  2016-05-17 17:15:25.0 +0200
+++ /var/tmp/diff_new_pack.UYufvz/_new  2016-05-17 17:15:25.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package ipsec-tools
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -126,7 +126,8 @@
 ln -s service %{buildroot}%{_sbindir}/rcracoon
 ln -s service %{buildroot}%{_sbindir}/rcracoon-setkey
 
-%fdupes -s %{buildroot}
+# do not fdupe the whole tree, otherwise it might symlink /etc config files 
into /usr
+%fdupes -s %{buildroot}/usr
 
 %pre
 %service_add_pre racoon.service racoon-setkey.service




commit fetchmail for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package fetchmail for openSUSE:Factory 
checked in at 2016-05-17 17:15:30

Comparing /work/SRC/openSUSE:Factory/fetchmail (Old)
 and  /work/SRC/openSUSE:Factory/.fetchmail.new (New)


Package is "fetchmail"

Changes:

--- /work/SRC/openSUSE:Factory/fetchmail/fetchmail.changes  2016-04-11 
10:26:51.0 +0200
+++ /work/SRC/openSUSE:Factory/.fetchmail.new/fetchmail.changes 2016-05-17 
17:15:31.0 +0200
@@ -1,0 +2,7 @@
+Fri May 13 12:06:54 UTC 2016 - pjano...@suse.de
+
+- Made the helper script introduced in last change return exit status
+  5 on configuration errors instead of 1, which should make it a bit
+  less confusing (bsc#979534)
+
+---



Other differences:
--

++ fetchmail.exec ++
--- /var/tmp/diff_new_pack.wTUtqP/_old  2016-05-17 17:15:32.0 +0200
+++ /var/tmp/diff_new_pack.wTUtqP/_new  2016-05-17 17:15:32.0 +0200
@@ -3,13 +3,13 @@
 
 die() {
echo "$@" 1>&2
-   exit 1
+   exit 5 # closest thing among fetchmail's exit codes
 }
 
 echo "$FETCHMAIL_POLLING_INTERVAL" | grep -Eq '^[0-9]+$' \
|| die 'invalid $FETCHMAIL_POLLING_INTERVAL setting'
 [ -r "$FETCHMAIL_RC_PATH" ] \
-   || die '$FETCHMAIL_RC_PATH does not exist'
+   || die '$FETCHMAIL_RC_PATH does not exist or cannot be read'
 
 OPTS="-d $FETCHMAIL_POLLING_INTERVAL"
 [ "$FETCHMAIL_FETCHALL" = "yes" ] && OPTS="$OPTS -a"




commit go-for-it for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package go-for-it for openSUSE:Factory 
checked in at 2016-05-17 17:15:33

Comparing /work/SRC/openSUSE:Factory/go-for-it (Old)
 and  /work/SRC/openSUSE:Factory/.go-for-it.new (New)


Package is "go-for-it"

Changes:

--- /work/SRC/openSUSE:Factory/go-for-it/go-for-it.changes  2016-02-08 
09:48:32.0 +0100
+++ /work/SRC/openSUSE:Factory/.go-for-it.new/go-for-it.changes 2016-05-17 
17:15:35.0 +0200
@@ -1,0 +2,5 @@
+Sat May  7 07:12:54 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 1.4.6.
+
+---

Old:

  go-for-it-1.4.5.tar.gz

New:

  go-for-it-1.4.6.tar.gz



Other differences:
--
++ go-for-it.spec ++
--- /var/tmp/diff_new_pack.coGs0K/_old  2016-05-17 17:15:36.0 +0200
+++ /var/tmp/diff_new_pack.coGs0K/_new  2016-05-17 17:15:36.0 +0200
@@ -18,13 +18,13 @@
 
 %define _name   Go-For-It
 Name:   go-for-it
-Version:1.4.5
+Version:1.4.6
 Release:0
 Summary:A stylish to-do list with built-in productivity timer
 License:GPL-3.0
 Group:  Productivity/Office/Organizers
 Url:https://github.com/mank319/Go-For-It
-Source: 
https://github.com/mank319/%{_name}/archive/release_v%{version}.tar.gz#/%{name}-%{version}.tar.gz
+Source: 
https://github.com/mank319/%{_name}/archive/release_%{version}.tar.gz#/%{name}-%{version}.tar.gz
 BuildRequires:  cmake >= 2.8
 BuildRequires:  gcc-c++
 BuildRequires:  hicolor-icon-theme
@@ -42,7 +42,7 @@
 on a regular base.
 
 %prep
-%setup -q -n %{_name}-release_v%{version}
+%setup -q -n %{_name}-release_%{version}
 
 %build
 %cmake

++ go-for-it-1.4.5.tar.gz -> go-for-it-1.4.6.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Go-For-It-release_v1.4.5/CMakeLists.txt 
new/Go-For-It-release_1.4.6/CMakeLists.txt
--- old/Go-For-It-release_v1.4.5/CMakeLists.txt 2016-01-17 11:31:25.0 
+0100
+++ new/Go-For-It-release_1.4.6/CMakeLists.txt  2016-03-26 18:52:51.0 
+0100
@@ -9,7 +9,7 @@
 set (PKGDATADIR "${DATADIR}/go-for-it")
 set (EXEC_NAME "go-for-it")
 set (RELEASE_NAME "A stylish to-do list with built-in productivity timer.")
-set (VERSION "1.4.5")
+set (VERSION "1.4.6")
 set (VERSION_INFO "initial release")
 
 # find pkgconfig to make sure dependencies are installed
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Go-For-It-release_v1.4.5/src/TaskManager.vala 
new/Go-For-It-release_1.4.6/src/TaskManager.vala
--- old/Go-For-It-release_v1.4.5/src/TaskManager.vala   2016-01-17 
11:31:25.0 +0100
+++ new/Go-For-It-release_1.4.6/src/TaskManager.vala2016-03-26 
18:52:51.0 +0100
@@ -30,6 +30,7 @@
 public TaskStore todo_store;
 public TaskStore done_store;
 private bool read_only;
+private bool need_to_add_tasks;
 private FileMonitor monitor;
 
 string[] default_todos = {
@@ -42,6 +43,8 @@
 public TaskManager (SettingsManager settings) {
 this.settings = settings;
 
+need_to_add_tasks = settings.first_start;
+
 // Initialize TaskStores
 todo_store = new TaskStore (false);
 done_store = new TaskStore (true);
@@ -51,7 +54,6 @@
 /* Signal processing */
 settings.todo_txt_location_changed.connect (load_task_stores);
 
-
 // Move done tasks off the todo list on startup
 auto_transfer_tasks();
 }
@@ -135,7 +137,15 @@
 
 load_tasks ();
 
-monitor = todo_txt_dir.monitor_directory (FileMonitorFlags.NONE, null);
+watch_file ();
+}
+
+private void watch_file () {
+try {
+monitor = todo_txt_dir.monitor_directory (FileMonitorFlags.NONE, 
null);
+} catch (IOError e) {
+stderr.printf ("watch_file: %s\n", e.message);
+}
 
 monitor.changed.connect ((src, dest, event) => {
 refresh();
@@ -155,11 +165,11 @@
 read_only = true;
 todo_store.clear ();
 done_store.clear ();
-read_only = false;
 read_task_file (this.todo_store, this.todo_txt);
 read_task_file (this.done_store, this.done_txt);
+read_only = false;
 
-if (settings.first_start) {
+if (need_to_add_tasks) {
 // Iterate in reverse order because todos are added to position 0
 for (int i = default_todos.length - 1;
  i >= 0;
@@ -167,13 +177,18 @@
 {
 todo_store.add_task(default_todos[i], 0);
 }
+

commit ghc-auto-update for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-auto-update for openSUSE:Factory 
checked in at 2016-05-17 17:14:26

Comparing /work/SRC/openSUSE:Factory/ghc-auto-update (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-auto-update.new (New)


Package is "ghc-auto-update"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-auto-update/ghc-auto-update.changes  
2016-04-30 23:30:12.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-auto-update.new/ghc-auto-update.changes 
2016-05-17 17:14:27.0 +0200
@@ -1,0 +2,6 @@
+Wed May 11 15:05:19 UTC 2016 - mimi...@gmail.com
+
+- update to 0.1.4
+* Provide updateActionModify API in AutoUpdate
+
+---

Old:

  auto-update-0.1.3.1.tar.gz

New:

  auto-update-0.1.4.tar.gz



Other differences:
--
++ ghc-auto-update.spec ++
--- /var/tmp/diff_new_pack.drAdqL/_old  2016-05-17 17:14:28.0 +0200
+++ /var/tmp/diff_new_pack.drAdqL/_new  2016-05-17 17:14:28.0 +0200
@@ -19,7 +19,7 @@
 %global pkg_name auto-update
 
 Name:   ghc-auto-update
-Version:0.1.3.1
+Version:0.1.4
 Release:0
 Summary:Efficiently run periodic, on-demand actions
 License:MIT

++ auto-update-0.1.3.1.tar.gz -> auto-update-0.1.4.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/auto-update-0.1.3.1/ChangeLog.md 
new/auto-update-0.1.4/ChangeLog.md
--- old/auto-update-0.1.3.1/ChangeLog.md2016-04-25 15:26:28.0 
+0200
+++ new/auto-update-0.1.4/ChangeLog.md  2016-05-09 07:43:44.0 +0200
@@ -1,3 +1,7 @@
+## 0.1.4
+
+* Provide updateActionModify API in AutoUpdate 
[#547](https://github.com/yesodweb/wai/pull/547)
+
 ## 0.1.3.1
 
 * Doc improvements
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/auto-update-0.1.3.1/Control/AutoUpdate.hs 
new/auto-update-0.1.4/Control/AutoUpdate.hs
--- old/auto-update-0.1.3.1/Control/AutoUpdate.hs   2016-04-24 
15:33:08.0 +0200
+++ new/auto-update-0.1.4/Control/AutoUpdate.hs 2016-05-09 07:43:44.0 
+0200
@@ -1,3 +1,4 @@
+{-# LANGUAGE CPP #-}
 -- | In a multithreaded environment, running actions on a regularly scheduled
 -- background thread can dramatically improve performance.
 -- For example, web servers need to return the current time with each HTTP 
response.
@@ -37,12 +38,17 @@
 , updateSpawnThreshold
   -- * Creation
 , mkAutoUpdate
+, mkAutoUpdateWithModify
 ) where
 
+#if __GLASGOW_HASKELL__ < 709
+import   Control.Applicative ((<*>))
+#endif
 import   Control.Concurrent  (forkIO, threadDelay)
 import   Control.Concurrent.MVar (newEmptyMVar, putMVar, readMVar,
   takeMVar, tryPutMVar)
-import   Control.Exception   (SomeException, catch, throw, mask_, 
try)
+import   Control.Exception   (SomeException, catch, mask_, throw,
+  try)
 import   Control.Monad   (void)
 import   Data.IORef  (newIORef, readIORef, writeIORef)
 
@@ -97,7 +103,18 @@
 --
 -- @since 0.1.0
 mkAutoUpdate :: UpdateSettings a -> IO (IO a)
-mkAutoUpdate us = do
+mkAutoUpdate us = mkAutoUpdateHelper us Nothing
+
+-- | Generate an action which will either read from an automatically
+-- updated value, or run the update action in the current thread if
+-- the first time or the provided modify action after that.
+--
+-- @since 0.1.4
+mkAutoUpdateWithModify :: UpdateSettings a -> (a -> IO a) -> IO (IO a)
+mkAutoUpdateWithModify us f = mkAutoUpdateHelper us (Just f)
+
+mkAutoUpdateHelper :: UpdateSettings a -> Maybe (a -> IO a) -> IO (IO a)
+mkAutoUpdateHelper us updateActionModify = do
 -- A baton to tell the worker thread to generate a new value.
 needsRunning <- newEmptyMVar
 
@@ -140,12 +157,12 @@
 -- This infinite loop makes up out worker thread. It takes an a
 -- responseVar value where the next value should be putMVar'ed to for
 -- the benefit of any requesters currently blocked on it.
-let loop responseVar = do
+let loop responseVar maybea = do
 -- block until a value is actually needed
 takeMVar needsRunning
 
 -- new value requested, so run the updateAction
-a <- catchSome $ updateAction us
+a <- catchSome $ maybe (updateAction us) id 
(updateActionModify <*> maybea)
 
 -- we got a new value, update currRef and lastValue
 writeIORef currRef $ Right a
@@ -160,10 +177,10 @@
 -- variable.
 

commit python3-cov-core for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-cov-core for 
openSUSE:Factory checked in at 2016-05-17 17:09:47

Comparing /work/SRC/openSUSE:Factory/python3-cov-core (Old)
 and  /work/SRC/openSUSE:Factory/.python3-cov-core.new (New)


Package is "python3-cov-core"

Changes:

--- /work/SRC/openSUSE:Factory/python3-cov-core/python3-cov-core.changes
2015-01-10 23:05:20.0 +0100
+++ /work/SRC/openSUSE:Factory/.python3-cov-core.new/python3-cov-core.changes   
2016-05-17 17:09:48.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 06:59:22 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-cov-core.spec ++
--- /var/tmp/diff_new_pack.84PpVY/_old  2016-05-17 17:09:49.0 +0200
+++ /var/tmp/diff_new_pack.84PpVY/_new  2016-05-17 17:09:49.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-cov-core
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,7 @@
 License:MIT
 Group:  Development/Languages/Python
 Url:http://bitbucket.org/memedough/cov-core/overview
-Source: 
https://pypi.python.org/packages/source/c/cov-core/cov-core-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/c/cov-core/cov-core-%{version}.tar.gz
 BuildRequires:  python3-coverage
 BuildRequires:  python3-devel
 BuildRequires:  python3-setuptools




commit mutt for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package mutt for openSUSE:Factory checked in 
at 2016-05-17 17:15:24

Comparing /work/SRC/openSUSE:Factory/mutt (Old)
 and  /work/SRC/openSUSE:Factory/.mutt.new (New)


Package is "mutt"

Changes:

--- /work/SRC/openSUSE:Factory/mutt/mutt.changes2016-04-14 
13:07:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.mutt.new/mutt.changes   2016-05-17 
17:15:26.0 +0200
@@ -1,0 +2,28 @@
+Thu May 12 13:50:14 UTC 2016 - wer...@suse.de
+
+- Update to mutt version 1.6.1 (2016-05-01):
+  ! Bug fix release.  No features were modified or added.
+- Add and use neomutt-patches-20160502.tar.gz from
+  http://www.neomutt.org/
+- Modify the patches
+   aw.listreply.diff
+   bsc907453-CVE-2014-9116-jessie.patch
+   bug-676388-largefile.patch
+   mutt-1.5.15-wrapcolumn.diff
+   mutt-1.5.20-sendgroupreplyto.diff
+   mutt-1.5.21-mailcap.diff
+   mutt-1.5.21-tinfo.dif
+   mutt-1.5.23-cariage-return.path
+   mutt-1.5.9i-pgpewrap.diff
+   patch-1.5.24.vk.pgp_verbose_mime
+   widechar.sidebar.dif
+- Modify and rename the patches
+   mutt-1.6.0-opennfs.dif becomes mutt-1.6.1-opennfs.dif
+   mutt-1.6.0.dif becomes mutt-1.6.1.dif
+   patch-1.6.0.rr.compressed.bz2 becomes patch-1.6.1.rr.compressed.bz2
+- Remove the patches
+   patch-1.6.0.sidebar.20160411.patch
+   nion.sidebar-color.diff
+  now upstream or part of neomutt patch collection
+
+---

Old:

  mutt-1.6.0-opennfs.dif
  mutt-1.6.0-patches.tar.bz2
  mutt-1.6.0.dif
  mutt-1.6.0.tar.gz
  nion.sidebar-color.diff
  patch-1.6.0.rr.compressed.bz2
  patch-1.6.0.sidebar.20160411.patch

New:

  mutt-1.6.1-opennfs.dif
  mutt-1.6.1-patches.tar.bz2
  mutt-1.6.1.dif
  mutt-1.6.1.tar.gz
  neomutt-patches-20160502.tar.gz
  patch-1.6.1.rr.compressed.bz2



Other differences:
--
++ mutt.spec ++
--- /var/tmp/diff_new_pack.z1tdOb/_old  2016-05-17 17:15:28.0 +0200
+++ /var/tmp/diff_new_pack.z1tdOb/_new  2016-05-17 17:15:28.0 +0200
@@ -68,7 +68,8 @@
 # NOTE: We don't want this dependency and desktop-data-SuSE is in all
 # desktop selections.
 #Requires:desktop-data-SuSE
-Version:1.6.0
+%globalneo 20160502
+Version:1.6.1
 Release:0
 Summary:Mail Program
 License:GPL-2.0+
@@ -84,21 +85,20 @@
 Source7:mutt-1.5.21.de.po
 Source8:%name-%version-patches.tar.bz2
 Source9:mutt.mailcap
+# http://www.neomutt.org/
+Source10:   neomutt-patches-%{neo}.tar.gz
 Patch:  %name-%version.dif
 # http://www.spinnaker.de/mutt/compressed/
-Patch1: patch-%version.rr.compressed.bz2
+Patch1: patch-1.6.1.rr.compressed.bz2
 Patch2: %name-1.5.9i-pgpewrap.diff
 Patch3: %name-1.5.20-sendgroupreplyto.diff
 Patch4: %name-1.5.15-wrapcolumn.diff
-# http://www.lunar-linux.org/mutt-sidebar/
-Patch6: patch-1.6.0.sidebar.20160411.patch
-Patch7: mutt-1.6.0-opennfs.dif
+Patch7: mutt-1.6.1-opennfs.dif
 Patch9: bug-676388-largefile.patch
 Patch10:mutt-1.5.21-tinfo.dif
 # http://www.wolfermann.org/mutt.html
 Patch11:aw.listreply.diff
 Patch12:patch-1.5.24.vk.pgp_verbose_mime
-Patch14:nion.sidebar-color.diff
 # PATCH-FIX-OPENSUSE: bnc#813498 - mutt crashes in fgetwc in 
text_enriched_handler
 Patch15:widechar.sidebar.dif
 # PATCH-FIX-OPENSUSE: Be able to read signed/encrypted messsages even with CRLF
@@ -116,28 +116,29 @@
 however.
 
 %prep
-%setup -q -n mutt-%version -b 8
+%setup -q -n mutt-%version -b 8 -b 10
 for p in ../%name-%version-patches/*; do
 test -e $p || break
 echo Patch $p
 patch -s -p1 < $p
 done
+patch -s -p1 < ../neomutt-patches-%{neo}/neomutt-%{neo}.patch
 %patch
 %patch1 -p0 -b .compressed
 %patch2 -p0 -b .pgpewrap
-%patch3 -p1 -b .sendgroupreplyto
+%patch3 -p0 -b .sendgroupreplyto
 %patch4 -p0 -b .wrapcolumn
-%patch6 -p1 -b .sidebar
 %patch7 -p0 -b .opennfs
-%patch9 -p1 -b .largefile
+%patch9 -p0 -b .largefile
 %patch10 -p0 -b .tinfo
-%patch11 -p1 -b .listreply
+%patch11 -p0 -b .listreply
 %patch12 -p0 -b .pgp_verbose_mtime
-%patch14 -p1 -b .sidebar.color
-%patch15 -p1 -b .widechar.sidebar
+%patch15 -p0 -b .widechar.sidebar
 %patch16 -p0 -b .crlf
-%patch18 -p1 -b .mailcap
-%patch19 -p1 -b .cvw2014.9116
+%patch18 -p0 -b .mailcap
+%patch19 -p0 -b .cvw2014.9116
+rm -vf README*.orig
+rm -vf PATCHES*.orig
 
 cp doc/Muttrc Muttrc.SuSE
 cp %{S:2} .

++ aw.listreply.diff ++
--- /var/tmp/diff_new_pack.z1tdOb/_old  2016-05-17 17:15:28.0 +0200
+++ /var/tmp/diff_new_pack.z1tdOb/_new  2016-05-17 17:15:28.0 +0200
@@ -7,15 +7,16 @@
  send.c  |   18 ++
  4 files changed, 27 

commit sblim-wbemcli for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package sblim-wbemcli for openSUSE:Factory 
checked in at 2016-05-17 17:15:12

Comparing /work/SRC/openSUSE:Factory/sblim-wbemcli (Old)
 and  /work/SRC/openSUSE:Factory/.sblim-wbemcli.new (New)


Package is "sblim-wbemcli"

Changes:

--- /work/SRC/openSUSE:Factory/sblim-wbemcli/sblim-wbemcli.changes  
2014-10-15 18:11:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.sblim-wbemcli.new/sblim-wbemcli.changes 
2016-05-17 17:15:13.0 +0200
@@ -1,0 +2,7 @@
+Thu May 12 15:07:14 UTC 2016 - mvet...@suse.com
+
+- Requested by fate#319145
+- Adding: sblim-wbemcli-allow-tls.patch:
+  * Enable configurable SSL/TLS support
+
+---

New:

  sblim-wbemcli-allow-tls.patch



Other differences:
--
++ sblim-wbemcli.spec ++
--- /var/tmp/diff_new_pack.ECoPbl/_old  2016-05-17 17:15:15.0 +0200
+++ /var/tmp/diff_new_pack.ECoPbl/_new  2016-05-17 17:15:15.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package sblim-wbemcli
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -30,6 +30,7 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Url:http://sblim.wiki.sourceforge.net/
 Source: 
http://prdownloads.sourceforge.net/sblim/%{name}-%{version}.tar.bz2
+Patch0: sblim-wbemcli-allow-tls.patch
 Summary:SBLIM WBEM Command Line Interface
 License:EPL-1.0
 Group:  System/Management
@@ -47,6 +48,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 sed -i 's|wbemcli/samples|wbemcli/examples|' man/wbemcli.1.pre.in
 sed -i 's|wbemcli/samples|wbemcli/examples|' man/wbemcli.1

++ sblim-wbemcli-allow-tls.patch ++
diff -urEbwB sblim-wbemcli-1.6.2/CimCurl.cpp sblim-wbemcli-1.6.2.new/CimCurl.cpp
--- sblim-wbemcli-1.6.2/CimCurl.cpp 2009-03-04 20:10:54.0 +0100
+++ sblim-wbemcli-1.6.2.new/CimCurl.cpp 2016-05-10 14:53:59.423867376 +0200
@@ -165,8 +165,36 @@
 rv = curl_easy_setopt(mHandle, CURLOPT_SSL_VERIFYHOST, 0);
 //rv = curl_easy_setopt(mHandle, CURLOPT_SSL_VERIFYPEER, 0);
 
-/* Force using SSL V3 */
-rv = curl_easy_setopt(mHandle, CURLOPT_SSLVERSION, 3);
+/* Force use of a specific SSL/TLS version */
+char * curlSslVer = getenv("WBEMCLI_CURL_SSLVERSION");
+if (curlSslVer) {
+  if (!strcasecmp(curlSslVer,"SSLv2"))
+rv = curl_easy_setopt(mHandle, CURLOPT_SSLVERSION, 
CURL_SSLVERSION_SSLv2);
+  else if (!strcasecmp(curlSslVer,"SSLv3"))
+rv = curl_easy_setopt(mHandle, CURLOPT_SSLVERSION, 
CURL_SSLVERSION_SSLv3);
+  else if (!strcasecmp(curlSslVer,"TLSv1"))
+rv = curl_easy_setopt(mHandle, CURLOPT_SSLVERSION, 
CURL_SSLVERSION_TLSv1);
+  else if (!strcasecmp(curlSslVer,"TLSv1.0") || 
!strcasecmp(curlSslVer,"TLSv1_0"))
+#if LIBCURL_VERSION_NUM >= 0x072200
+rv = curl_easy_setopt(mHandle, CURLOPT_SSLVERSION, 
CURL_SSLVERSION_TLSv1_0);
+#else
+throw URLException("WBEMCLI_CURL_SSLVERSION=TLSv1.0 requires libcurl 
7.34 or greater");
+#endif
+  else if (!strcasecmp(curlSslVer,"TLSv1.1") || 
!strcasecmp(curlSslVer,"TLSv1_1"))
+#if LIBCURL_VERSION_NUM >= 0x072200
+rv = curl_easy_setopt(mHandle, CURLOPT_SSLVERSION, 
CURL_SSLVERSION_TLSv1_1);
+#else
+throw URLException("WBEMCLI_CURL_SSLVERSION=TLSv1.1 requires libcurl 
7.34 or greater");
+#endif
+  else if (!strcasecmp(curlSslVer,"TLSv1.2") || 
!strcasecmp(curlSslVer,"TLSv1_2"))
+#if LIBCURL_VERSION_NUM >= 0x072200
+rv = curl_easy_setopt(mHandle, CURLOPT_SSLVERSION, 
CURL_SSLVERSION_TLSv1_2);
+#else
+throw URLException("WBEMCLI_CURL_SSLVERSION=TLSv1.2 requires libcurl 
7.34 or greater");
+#endif
+  else
+throw URLException("unknown WBEMCLI_CURL_SSLVERSION");
+}
 
 /* Set username and password */
 if (url.user.length() > 0 && url.password.length() > 0) {
diff -urEbwB sblim-wbemcli-1.6.2/man/wbemcli.1.pre.in 
sblim-wbemcli-1.6.2.new/man/wbemcli.1.pre.in
--- sblim-wbemcli-1.6.2/man/wbemcli.1.pre.in2009-06-20 01:10:57.0 
+0200
+++ sblim-wbemcli-1.6.2.new/man/wbemcli.1.pre.in2016-05-10 
14:56:57.495339650 +0200
@@ -554,6 +554,15 @@
wbemcli gi 'myCimom/root/cimv2:rpm_package.name="glibc"'
 .PP
 
+.SH ENVIRONMENT
+.TP
+.B WBEMCLI_CURL_SSLVERSION
+Specifies the SSL protocol that will be used.
+Valid values are SSLv2, SSLv3, TLSv1, TLSv1.0 (TLSv1_0), TLSv1.1 (TLSv1_1)
+or TLSv1.2 (TLSv1_2).
+If this variable is not set, wbemcli will attempt to figure out 

commit crmsh for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package crmsh for openSUSE:Factory checked 
in at 2016-05-17 17:15:00

Comparing /work/SRC/openSUSE:Factory/crmsh (Old)
 and  /work/SRC/openSUSE:Factory/.crmsh.new (New)


Package is "crmsh"

Changes:

--- /work/SRC/openSUSE:Factory/crmsh/crmsh.changes  2016-05-05 
12:12:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.crmsh.new/crmsh.changes 2016-05-17 
17:15:03.0 +0200
@@ -1,0 +2,10 @@
+Thu May 12 08:40:54 UTC 2016 - kgronl...@suse.com
+
+- Update to version 2.2.0+git.1462967444.169c554:
+  + high: parse: Support for event-driven alerts (fate#320855) (#136)
+  + high: utils: Avoid deadlock if DC changes during idle wait (bsc#978480)
+  + medium: ui_resource: Add force argument to resource cleanup (bsc#979420)
+  + medium: ui_resource: Show utilization in output from crm resource scores
+  + high: ui_resource: Improved resource move/clear/locate commands
+
+---

Old:

  crmsh-2.2.0+git.1462285059.d79cd0d.tar.bz2

New:

  crmsh-2.2.0+git.1462967444.169c554.tar.bz2



Other differences:
--
++ crmsh.spec ++
--- /var/tmp/diff_new_pack.qvK0Pp/_old  2016-05-17 17:15:04.0 +0200
+++ /var/tmp/diff_new_pack.qvK0Pp/_new  2016-05-17 17:15:04.0 +0200
@@ -32,13 +32,13 @@
 
 %{!?python_sitelib: %define python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
 
-%define version_unconverted 2.2.0+git.1462285059.d79cd0d
+%define version_unconverted 2.2.0+git.1462967444.169c554
 
 Name:   crmsh
 Summary:High Availability cluster command-line interface
 License:GPL-2.0+
 Group:  %{pkg_group}
-Version:2.2.0+git.1462285059.d79cd0d
+Version:2.2.0+git.1462967444.169c554
 Release:0
 Url:http://crmsh.github.io
 Source0:%{name}-%{version}.tar.bz2

++ _servicedata ++
--- /var/tmp/diff_new_pack.qvK0Pp/_old  2016-05-17 17:15:04.0 +0200
+++ /var/tmp/diff_new_pack.qvK0Pp/_new  2016-05-17 17:15:04.0 +0200
@@ -1,4 +1,4 @@
 
 
 git://github.com/ClusterLabs/crmsh.git
-  d79cd0db97b99ccb6d4dbbe9797917c18a4982aa
\ No newline at end of file
+  169c5549accf42af8b89f6cc4d574c6c219768b1
\ No newline at end of file

++ crmsh-2.2.0+git.1462285059.d79cd0d.tar.bz2 -> 
crmsh-2.2.0+git.1462967444.169c554.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/crmsh-2.2.0+git.1462285059.d79cd0d/.gitignore 
new/crmsh-2.2.0+git.1462967444.169c554/.gitignore
--- old/crmsh-2.2.0+git.1462285059.d79cd0d/.gitignore   2016-05-03 
16:17:39.0 +0200
+++ new/crmsh-2.2.0+git.1462967444.169c554/.gitignore   1970-01-01 
01:00:00.0 +0100
@@ -1,19 +0,0 @@
-*.pyc
-*~
-#*.*#
-.#*
-doc/website-v1/gen
-Makefile.in
-autom4te.cache
-patches/*
-
-# Tool specific files
-.README.md.html
-.*.*~
-.project
-.settings
-.pydevproject
-
-contrib/build/
-contrib/dist/
-contrib/pygments_crmsh_lexers.egg-info/
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/crmsh-2.2.0+git.1462285059.d79cd0d/.hgignore 
new/crmsh-2.2.0+git.1462967444.169c554/.hgignore
--- old/crmsh-2.2.0+git.1462285059.d79cd0d/.hgignore2016-05-03 
16:17:39.0 +0200
+++ new/crmsh-2.2.0+git.1462967444.169c554/.hgignore1970-01-01 
01:00:00.0 +0100
@@ -1,7 +0,0 @@
-syntax: glob
-
-*.pyc
-*~
-#*.*#
-doc/gen
-
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/crmsh-2.2.0+git.1462285059.d79cd0d/Makefile.am 
new/crmsh-2.2.0+git.1462967444.169c554/Makefile.am
--- old/crmsh-2.2.0+git.1462285059.d79cd0d/Makefile.am  2016-05-03 
16:17:39.0 +0200
+++ new/crmsh-2.2.0+git.1462967444.169c554/Makefile.am  2016-05-12 
10:40:53.0 +0200
@@ -73,11 +73,11 @@
 install-exec-local:
-mkdir -p $(DESTDIR)$(pkgpythondir)
$(PYTHON) $(srcdir)/setup.py install \
-   --root $(DESTDIR) \
+   --root $(DESTDIR)/// \
$(python_prefix) \
--record $(DESTDIR)$(pkgpythondir)/install_files.txt \
--verbose
-   $(INSTALL) -d -m 770 $(DESTDIR)/$(CRM_CACHE_DIR)
+   $(INSTALL) -d -m 770 $(DESTDIR)$(CRM_CACHE_DIR)
 
 uninstall-local:
cat $(DESTDIR)$(pkgpythondir)/install_files.txt | xargs rm -rf
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/crmsh-2.2.0+git.1462285059.d79cd0d/crmsh/cibconfig.py 
new/crmsh-2.2.0+git.1462967444.169c554/crmsh/cibconfig.py
--- old/crmsh-2.2.0+git.1462285059.d79cd0d/crmsh/cibconfig.py   2016-05-03 
16:17:39.0 +0200

commit cinnamon for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package cinnamon for openSUSE:Factory 
checked in at 2016-05-17 17:15:07

Comparing /work/SRC/openSUSE:Factory/cinnamon (Old)
 and  /work/SRC/openSUSE:Factory/.cinnamon.new (New)


Package is "cinnamon"

Changes:

--- /work/SRC/openSUSE:Factory/cinnamon/cinnamon.changes2016-05-04 
08:20:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.cinnamon.new/cinnamon.changes   2016-05-17 
17:15:10.0 +0200
@@ -1,0 +2,37 @@
+Thu May 12 09:54:43 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 3.0.2:
+  * Cache generated thumbnails.
+  * Fix desktop effects on dialogs and menus.
+This prevents desktop effects on dialogs and menus from being
+used if desktop-effects is turned off. It's like already like
+this in the effects settings dialog.
+  * Power applet: Fixed declaration of alias variable.
+  * Window list: Fix call on null object.
+  * Fix handling of device icon where GIcon is null.
+  * cinnamon-settings: Don't set the stack switcher to use the main
+settings stack on creation.
+This is causing visual glitches in a lot of Gtk themes when
+changing from the main icon view to a page that displays the
+stack switcher.
+  * Fix highlighting not working correctly for multiple instances
+of an applet.
+  * ExtensionCore.py: Don't break when an xlet provides a bad icon
+file.
+  * Add null conditional to return empty array when get_devices
+returns null.
+  * Correct a potential infinite loop.
+  * accessibility settings: Don't use PackageKit for now when
+looking for assistance applications that are installed.
+Just look for their binaries, and notify if not installed.
+Watch the bin folders in case the user installs the dependency
+and doesn't restart cinnamon settings.
+  * cs_sound.py: Add a close button to the speaker test dialog.
+  * Fix image close crash.
+
+---
+Wed May  4 16:34:01 UTC 2016 - sor.ale...@meowr.ru
+
+- Add a missing python-gobject-Gdk dependency (boo#978298).
+
+---

Old:

  cinnamon-3.0.1.tar.gz

New:

  cinnamon-3.0.2.tar.gz



Other differences:
--
++ cinnamon.spec ++
--- /var/tmp/diff_new_pack.oAasFC/_old  2016-05-17 17:15:11.0 +0200
+++ /var/tmp/diff_new_pack.oAasFC/_new  2016-05-17 17:15:11.0 +0200
@@ -21,7 +21,7 @@
 %define _name   Cinnamon
 %define _version 3.0.0
 Name:   cinnamon
-Version:3.0.1
+Version:3.0.2
 Release:0
 Summary:GNU/Linux Desktop featuring a traditional layout
 License:GPL-2.0+ and LGPL-2.1
@@ -115,6 +115,9 @@
 # typelib-1_0-Cinnamon-0_1 was last used in openSUSE Leap 42.1.
 Provides:   typelib-1_0-Cinnamon-0_1 = %{version}
 Obsoletes:  typelib-1_0-Cinnamon-0_1 <= %{version}
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python-gobject-Gdk
+%endif
 
 %description
 Cinnamon is a modern Linux desktop which provides advanced innovative

++ cinnamon-3.0.1.tar.gz -> cinnamon-3.0.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Cinnamon-3.0.1/configure.ac 
new/Cinnamon-3.0.2/configure.ac
--- old/Cinnamon-3.0.1/configure.ac 2016-04-25 11:11:29.0 +0200
+++ new/Cinnamon-3.0.2/configure.ac 2016-05-10 17:39:03.0 +0200
@@ -1,5 +1,5 @@
 AC_PREREQ(2.63)
-AC_INIT([cinnamon],[3.0.1],[https://github.com/linuxmint/Cinnamon/issues],[cinnamon])
+AC_INIT([cinnamon],[3.0.2],[https://github.com/linuxmint/Cinnamon/issues],[cinnamon])
 
 AC_CONFIG_HEADERS([config.h])
 AC_CONFIG_SRCDIR([src/cinnamon-global.c])
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Cinnamon-3.0.1/debian/changelog 
new/Cinnamon-3.0.2/debian/changelog
--- old/Cinnamon-3.0.1/debian/changelog 2016-04-25 11:11:29.0 +0200
+++ new/Cinnamon-3.0.2/debian/changelog 2016-05-10 17:39:03.0 +0200
@@ -1,3 +1,42 @@
+cinnamon (3.0.2) sarah; urgency=medium
+
+  [ ion201 ]
+  * Cache generated thumbnails
+
+  [ Lars Mueller ]
+  * Fix desktop effects on dialogs and menus This prevents desktop effects on 
dialogs and menus from being used if desktop-effects is turned off. It's like 
already like this in the effects settings dialog.
+
+  [ Clement Lefebvre ]
+  * Power applet: Fixed declaration of alias variable
+  * Window list: Fixed call on null object
+
+  [ Stephen Collins ]
+  * Fix handling of device icon where gicon is None (partially fixes #5248)
+
+  [ JosephMcc ]
+  * cinnamon-settings: Don't set the stack switcher to use the main settings 
stack on creation This is 

commit sparse for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package sparse for openSUSE:Factory checked 
in at 2016-05-17 17:15:02

Comparing /work/SRC/openSUSE:Factory/sparse (Old)
 and  /work/SRC/openSUSE:Factory/.sparse.new (New)


Package is "sparse"

Changes:

--- /work/SRC/openSUSE:Factory/sparse/sparse.changes2015-11-11 
10:30:05.0 +0100
+++ /work/SRC/openSUSE:Factory/.sparse.new/sparse.changes   2016-05-17 
17:15:05.0 +0200
@@ -1,0 +2,9 @@
+Sun May  8 11:08:42 UTC 2016 - mplus...@suse.com
+
+- Change versioning to include latest release - 0.5+git.20150208
+- Enable sparse-llvm
+- Update dependencies
+- Small spec file cleanup with spec-cleaner
+- Make building more verbose
+
+---

Old:

  sparse-20150124.tar.xz

New:

  sparse-0.5+git.20150208.tar.xz



Other differences:
--
++ sparse.spec ++
--- /var/tmp/diff_new_pack.pfVc5G/_old  2016-05-17 17:15:06.0 +0200
+++ /var/tmp/diff_new_pack.pfVc5G/_new  2016-05-17 17:15:06.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package sparse
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,21 +17,27 @@
 
 
 Name:   sparse
+Version:0.5+git.20150208
+Release:0
 Summary:A semantic parser of source files
 License:MIT
 Group:  Development/Tools/Building
-Version:20150124
-Release:0
 Url:https://sparse.wiki.kernel.org/index.php/Main_Page
 Source: sparse-%{version}.tar.xz
-
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  gcc
-BuildRequires:  gtk2-devel
-BuildRequires:  libxml2-devel
+BuildRequires:  gcc-c++
 BuildRequires:  make
-BuildRequires:  pkg-config
+BuildRequires:  ncurses-devel
+BuildRequires:  pkgconfig
 BuildRequires:  xz
+BuildRequires:  pkgconfig(gtk+-2.0)
+BuildRequires:  pkgconfig(libxml-2.0)
+Provides:   %{name} = 20150204
+Obsoletes:  %{name} = 20150204
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+%if 0%{?suse_version} > 1320
+BuildRequires:  llvm-devel
+%endif
 
 %description
 Sparse is a semantic parser of source files: it's neither a compiler
@@ -50,46 +56,71 @@
 Sparse is primarily used in the development and debugging of the Linux
 kernel.
 
-%package -n sparse-devel
+%package devel
 Summary:Devel files for sparse
 Group:  Development/Libraries/C and C++
 
-%description -n sparse-devel
+%description devel
 Development headers and libraries for sparse.
 
-%package -n sparse-inspect
+%package inspect
 Summary:Inspect binary from sparse
 Group:  Development/Libraries/C and C++
 
-%description -n sparse-inspect
+%description inspect
 test-inspect is a gtk frontend for sparse.
 
+%package llvm
+Summary:LLVM backed sparse
+Group:  Development/Libraries/C and C++
+
+%description llvm
+LLVM backend for sparse, including sparsec
+
 %prep
 %setup -q
 
 %build
-make %{?_smp_mflags} PREFIX=%{_prefix} LIBDIR=%{_libdir} MANDIR=%{_mandir} \
-   PKGCONFIGDIR=%{_datadir}/pkgconfig CFLAGS="%{optflags}"
+make \
+  %{?_smp_mflags} \
+  PREFIX=%{_prefix} \
+  LIBDIR=%{_libdir} \
+  MANDIR=%{_mandir} \
+  PKGCONFIGDIR=%{_datadir}/pkgconfig \
+  CFLAGS="%{optflags}" \
+  V=1
 
 %install
-%{makeinstall} \
-   PREFIX=%{_prefix} LIBDIR=%{_libdir} MANDIR=%{_mandir} \
-   PKGCONFIGDIR=%{_datadir}/pkgconfig
+make \
+  %{?_smp_mflags} \
+  DESTDIR=%{buildroot} \
+  PREFIX=%{_prefix} \
+  LIBDIR=%{_libdir} \
+  MANDIR=%{_mandir} \
+  PKGCONFIGDIR=%{_datadir}/pkgconfig \
+  install
 
 %files
 %defattr(-,root,root)
 %doc LICENSE README FAQ
-%{_mandir}/man?/cgcc.1.gz
-%{_mandir}/man?/sparse.1.gz
-%{_bindir}/c2xml
 %{_bindir}/cgcc
+%{_bindir}/c2xml
 %{_bindir}/sparse
+%{_mandir}/man1/cgcc.1%{ext_man}
+%{_mandir}/man1/sparse.1%{ext_man}
+
+%if 0%{?suse_version} > 1320
+%files llvm
+%defattr(-,root,root)
+%{_bindir}/sparsec
+%{_bindir}/sparse-llvm
+%endif
 
-%files -n sparse-inspect
+%files inspect
 %defattr(-,root,root)
 %{_bindir}/test-inspect
 
-%files -n sparse-devel
+%files devel
 %defattr(-,root,root)
 %{_includedir}/sparse
 %{_libdir}/libsparse.a

++ _service ++
--- /var/tmp/diff_new_pack.pfVc5G/_old  2016-05-17 17:15:06.0 +0200
+++ /var/tmp/diff_new_pack.pfVc5G/_new  2016-05-17 17:15:06.0 +0200
@@ -2,8 +2,9 @@
   
 git://git.kernel.org/pub/scm/devel/sparse/sparse.git
 git
+enable
 sparse
-%ad
+0.5+git.%cd
   
   
 *.tar




commit ubuntu-mate-artwork for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ubuntu-mate-artwork for 
openSUSE:Factory checked in at 2016-05-17 17:14:58

Comparing /work/SRC/openSUSE:Factory/ubuntu-mate-artwork (Old)
 and  /work/SRC/openSUSE:Factory/.ubuntu-mate-artwork.new (New)


Package is "ubuntu-mate-artwork"

Changes:

--- /work/SRC/openSUSE:Factory/ubuntu-mate-artwork/ubuntu-mate-artwork.changes  
2016-04-22 16:25:46.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.ubuntu-mate-artwork.new/ubuntu-mate-artwork.changes 
2016-05-17 17:14:59.0 +0200
@@ -1,0 +2,8 @@
+Wed May  4 16:34:01 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 16.04.6.1:
+  * Add 1px padding to calendar widget elements; looks better.
+  * Add these fixes for Calendar: lp#1551744, lp#1558659.
+  * Merge fixes from ubuntu-themes.
+
+---

Old:

  ubuntu-mate-artwork_16.04.6.tar.xz

New:

  ubuntu-mate-artwork_16.04.6.1.tar.xz



Other differences:
--
++ ubuntu-mate-artwork.spec ++
--- /var/tmp/diff_new_pack.uB5I5x/_old  2016-05-17 17:15:03.0 +0200
+++ /var/tmp/diff_new_pack.uB5I5x/_new  2016-05-17 17:15:03.0 +0200
@@ -17,9 +17,9 @@
 
 
 %define _name   ubuntu-mate
-%define _version 16.04.5
+%define _version xenial
 Name:   ubuntu-mate-artwork
-Version:16.04.6
+Version:16.04.6.1
 Release:0
 Summary:Ubuntu MATE themes and artwork
 License:GPL-3.0+ and CC-BY-SA-4.0 and CC-BY-SA-3.0

++ ubuntu-mate-artwork_16.04.6.tar.xz -> 
ubuntu-mate-artwork_16.04.6.1.tar.xz ++
/work/SRC/openSUSE:Factory/ubuntu-mate-artwork/ubuntu-mate-artwork_16.04.6.tar.xz
 
/work/SRC/openSUSE:Factory/.ubuntu-mate-artwork.new/ubuntu-mate-artwork_16.04.6.1.tar.xz
 differ: char 25, line 1




commit libmemcached for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package libmemcached for openSUSE:Factory 
checked in at 2016-05-17 17:15:04

Comparing /work/SRC/openSUSE:Factory/libmemcached (Old)
 and  /work/SRC/openSUSE:Factory/.libmemcached.new (New)


Package is "libmemcached"

Changes:

--- /work/SRC/openSUSE:Factory/libmemcached/libmemcached.changes
2015-02-24 13:07:16.0 +0100
+++ /work/SRC/openSUSE:Factory/.libmemcached.new/libmemcached.changes   
2016-05-17 17:15:06.0 +0200
@@ -1,0 +2,7 @@
+Wed May 11 14:53:53 UTC 2016 - kstreit...@suse.com
+
+- use spec-cleaner to clean specfile
+- remove unnecessary conditionals
+- update description and summary
+
+---



Other differences:
--
++ libmemcached.spec ++
--- /var/tmp/diff_new_pack.x1Jp3U/_old  2016-05-17 17:15:07.0 +0200
+++ /var/tmp/diff_new_pack.x1Jp3U/_new  2016-05-17 17:15:07.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libmemcached
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,13 +16,13 @@
 #
 
 
-Name:   libmemcached
 %define libsoname %{name}11
-Summary:A C and C++ client library to the memcached server
-License:BSD-3-Clause
-Group:  Development/Libraries/C and C++
+Name:   libmemcached
 Version:1.0.18
 Release:0
+Summary:A C/C++ client library and tools for the memcached server
+License:BSD-3-Clause
+Group:  Development/Libraries/C and C++
 Url:http://libmemcached.org
 Source0:
https://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
 
 Source1:
https://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz.asc
@@ -32,51 +32,48 @@
 Patch1: libmemcached-automake1_14.diff
 # PATCH-FIX-UPSTREAM libmemcached-no-docs-available.patch dims...@opensuse.org 
-- Do not build docs if not VCS checkout
 Patch2: libmemcached-no-docs-available.patch
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 # List of additional build dependencies
 BuildRequires:  automake >= 1.13
 BuildRequires:  bison
 BuildRequires:  cyrus-sasl-devel
+# needed for man pages
+BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  libevent-devel
 BuildRequires:  libtool
 BuildRequires:  memcached
 BuildRequires:  pkgconfig
-# needed for man pages
-BuildRequires:  fdupes
 BuildRequires:  python-Sphinx
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-Libmemcached is a C and C++ client library to the memcached server
-(http://danga.com/memcached). It has been designed to be light on
-memory usage, thread safe, and provide full access to server side
-methods.
+Libmemcached is a C/C++ client library and tools for the memcached server
+(http://memcached.org/). It has been designed to be light on memory
+usage, thread safe, and provide full access to server side methods.
 
 %package -n %{libsoname}
-Summary:Libmemcached is a C and C++ client library to the memcached 
server
+Summary:Libmemcached is a C/C++ client library and tools for the 
memcached server
 Group:  System/Libraries
 
 %description -n %{libsoname}
-Libmemcached is a C and C++ client library to the memcached server
-(http://danga.com/memcached). It has been designed to be light on
-memory usage, thread safe, and provide full access to server side
-methods.
+Libmemcached is a C/C++ client library and tools for the memcached server
+(http://memcached.org/). It has been designed to be light on memory
+usage, thread safe, and provide full access to server side methods.
 
 %package -n libmemcachedutil2
-Summary:Libmemcached is a C and C++ client library to the memcached 
server
+Summary:Libmemcached is a C/C++ client library and tools for the 
memcached server
 Group:  System/Libraries
 
 %description -n libmemcachedutil2
-Libmemcached is a C and C++ client library to the memcached server
-(http://danga.com/memcached). It has been designed to be light on
-memory usage, thread safe, and provide full access to server side
-methods.
+Libmemcached is a C/C++ client library and tools for the memcached server
+(http://memcached.org/). It has been designed to be light on memory
+usage, thread safe, and provide full access to server side methods.
 
 The libmemcachedutil library contains utility functions used by
 libmemcached.
 
 %package devel
-Summary:Libmemcached is a C and 

commit cinnamon-desktop for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package cinnamon-desktop for 
openSUSE:Factory checked in at 2016-05-17 17:15:06

Comparing /work/SRC/openSUSE:Factory/cinnamon-desktop (Old)
 and  /work/SRC/openSUSE:Factory/.cinnamon-desktop.new (New)


Package is "cinnamon-desktop"

Changes:

--- /work/SRC/openSUSE:Factory/cinnamon-desktop/cinnamon-desktop.changes
2016-04-28 17:01:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.cinnamon-desktop.new/cinnamon-desktop.changes   
2016-05-17 17:15:07.0 +0200
@@ -1,0 +2,15 @@
+Thu May 12 09:54:43 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 3.0.1:
+  * Fix possible null pointer dereference.
+  * Fix usage of uninitialised values.
+  * Disable event-sounds by default.
+  * Disable audible-bell by default.
+  * Remove dependency on gnome-software (boo#978264).
+
+---
+Wed May  4 16:34:01 UTC 2016 - sor.ale...@meowr.ru
+
+- Add a missing python-gobject-Gdk dependency (boo#978298).
+
+---

Old:

  cinnamon-desktop-3.0.0.tar.gz

New:

  cinnamon-desktop-3.0.1.tar.gz



Other differences:
--
++ cinnamon-desktop.spec ++
--- /var/tmp/diff_new_pack.1jxRba/_old  2016-05-17 17:15:08.0 +0200
+++ /var/tmp/diff_new_pack.1jxRba/_new  2016-05-17 17:15:08.0 +0200
@@ -23,7 +23,7 @@
 %define typelib typelib-1_0-CinnamonDesktop-3_0
 %define typelib_cvc typelib-1_0-Cvc-1_0
 Name:   cinnamon-desktop
-Version:3.0.0
+Version:3.0.1
 Release:0
 Summary:Libcinnamon-desktop API
 License:GPL-2.0+ and MIT
@@ -63,7 +63,6 @@
 Summary:Libcinnamon-desktop API
 Group:  System/Libraries
 Requires:   %{soname}-data >= %{version}
-Requires:   gnome-software
 Provides:   %{name} = %{version}
 Provides:   %{soname} = %{version}
 Obsoletes:  %{name} < %{version}
@@ -83,13 +82,15 @@
 %package -n %{soname}-data
 Summary:Libcinnamon-desktop API -- Common Files
 Group:  System/GUI/Other
-Requires:   python
 Requires:   python-gobject
 Recommends: %{soname}-lang
 Provides:   %{name}-data = %{version}
 Provides:   %{name}-lang = %{version}
 Obsoletes:  %{name}-lang < %{version}
 %glib2_gsettings_schema_requires
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python-gobject-Gdk
+%endif
 
 %description -n %{soname}-data
 cinnamon-desktop contains the libcinnamon-desktop library, the

++ cinnamon-desktop-3.0.0.tar.gz -> cinnamon-desktop-3.0.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cinnamon-desktop-3.0.0/configure.ac 
new/cinnamon-desktop-3.0.1/configure.ac
--- old/cinnamon-desktop-3.0.0/configure.ac 2016-04-23 16:58:56.0 
+0200
+++ new/cinnamon-desktop-3.0.1/configure.ac 2016-05-10 17:34:47.0 
+0200
@@ -1,5 +1,5 @@
 
-AC_INIT(cinnamon-desktop, 3.0.0)
+AC_INIT(cinnamon-desktop, 3.0.1)
 AC_CONFIG_SRCDIR(libcinnamon-desktop)
 
 AM_INIT_AUTOMAKE([1.11 foreign no-dist-gzip dist-xz tar-ustar])
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cinnamon-desktop-3.0.0/debian/changelog 
new/cinnamon-desktop-3.0.1/debian/changelog
--- old/cinnamon-desktop-3.0.0/debian/changelog 2016-04-23 16:58:56.0 
+0200
+++ new/cinnamon-desktop-3.0.1/debian/changelog 2016-05-10 17:34:47.0 
+0200
@@ -1,3 +1,18 @@
+cinnamon-desktop (3.0.1) sarah; urgency=medium
+
+  [ Igor ]
+  * Fix possible NULL pointer dereference
+  * Fix usage of uninitialized values
+
+  [ Clement Lefebvre ]
+  * Disable event-sounds by default
+  * Disable audible-bell by default
+
+  [ Michael Webster ]
+  * debian/control: remove dependency on gnome-packagekit-session.
+
+ -- Clement Lefebvre   Tue, 10 May 2016 16:34:06 +0100
+
 cinnamon-desktop (3.0.0) sarah; urgency=medium
 
   [ Michael Webster ]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cinnamon-desktop-3.0.0/debian/control 
new/cinnamon-desktop-3.0.1/debian/control
--- old/cinnamon-desktop-3.0.0/debian/control   2016-04-23 16:58:56.0 
+0200
+++ new/cinnamon-desktop-3.0.1/debian/control   2016-05-10 17:34:47.0 
+0200
@@ -41,7 +41,6 @@
 Multi-Arch: same
 Pre-Depends: ${misc:Pre-Depends}
 Depends: cinnamon-desktop-data (>= ${source:Version}),
- gnome-packagekit-session,
  ${misc:Depends},
  ${shlibs:Depends}
 Recommends: hwdata (>= 0.227-1)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit gdal for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package gdal for openSUSE:Factory checked in 
at 2016-05-17 17:14:23

Comparing /work/SRC/openSUSE:Factory/gdal (Old)
 and  /work/SRC/openSUSE:Factory/.gdal.new (New)


Package is "gdal"

Changes:

--- /work/SRC/openSUSE:Factory/gdal/gdal.changes2016-02-08 
09:47:48.0 +0100
+++ /work/SRC/openSUSE:Factory/.gdal.new/gdal.changes   2016-05-17 
17:14:25.0 +0200
@@ -1,0 +2,29 @@
+Tue May 10 03:11:00 UTC 2016 - Angelos Tzotsos 
+
+- New upstream release 2.1.0
+  - https://trac.osgeo.org/gdal/wiki/Release/2.1.0-News
+- packaging changes
+  - Removed gdal-python_install.patch
+  - Removed gdal-2.0.2-sqlite-crash.patch
+  - Removed gdal-configure.patch
+  - Added ogr_wrap.patch to solve no-return-in-non-void-function error
+  - Submitted ogr_wrap.patch upstream: https://trac.osgeo.org/gdal/ticket/6506
+  - Redone patch GDALmake.opt.in.patch
+
+---
+Tue Feb 23 14:42:10 UTC 2016 - br...@ioda-net.ch
+
+- Upgrade to 2x series version : 2.0.2 bugfix release
+  - https://trac.osgeo.org/gdal/wiki/Release/2.0.2-News 
+  - https://trac.osgeo.org/gdal/wiki/Release/2.0.1-News
+  - https://trac.osgeo.org/gdal/wiki/Release/2.0.0-News
+
+- packaging
+  - Redone patch GDALmake.opt.in.patch and gdal-libproj.patch
+  - Delete upstream merged gdal-python-swig3-issue6045.path
+  - Delete upstream merged gdal_swig-perl-issue3084.patch
+  - Add gdal-2.0.2-sqlite-crash.patch Fix upstream issue 6360
+  - spec-cleaner minimal (pkgconfig make unresolvable all except
+Leap and Tumbleweed)
+
+---

Old:

  gdal-1.11.4.tar.gz
  gdal-configure.patch
  gdal-python_install.patch

New:

  gdal-2.1.0.tar.xz
  ogr_wrap.patch



Other differences:
--
++ gdal.spec ++
--- /var/tmp/diff_new_pack.eDCy9Z/_old  2016-05-17 17:14:26.0 +0200
+++ /var/tmp/diff_new_pack.eDCy9Z/_new  2016-05-17 17:14:26.0 +0200
@@ -17,21 +17,26 @@
 
 
 %bcond_with ecw_support
+# Soname should be bumped on API/ABI break
+# http://trac.osgeo.org/gdal/ticket/4543
+%define soversion 20
+%define sourcename gdal
+
 Name:   gdal
-Version:1.11.4
+Version:2.1.0
 Release:0
 Summary:GDAL/OGR - a translator library for raster and vector 
geospatial data formats
 License:MIT and BSD-3-Clause and SUSE-Public-Domain
 Group:  Development/Libraries/C and C++
 Url:http://www.gdal.org/
-Source0:
http://download.osgeo.org/%{name}/%{version}/%{name}-%{version}.tar.gz
-Patch0: gdal-python_install.patch
-Patch1: gdal-configure.patch
-Patch2: gdal-perl.patch
-# Fix occasional paralle build failure
-Patch3: GDALmake.opt.in.patch
+Source0:
http://download.osgeo.org/%{name}/%{version}/%{sourcename}-%{version}.tar.xz
+Patch0: gdal-perl.patch
+# Fix occasional parallel build failure
+Patch1: GDALmake.opt.in.patch
 # Fix hard coded name of libproj library
-Patch4: gdal-libproj.patch
+# But libproj.so is valid if libproj-devel is installed ?
+Patch2: gdal-libproj.patch
+Patch3: ogr_wrap.patch
 BuildRequires:  blas-devel
 BuildRequires:  chrpath
 BuildRequires:  curl-devel
@@ -46,7 +51,6 @@
 BuildRequires:  libgeotiff-devel >= 1.2.1
 BuildRequires:  libjasper-devel
 BuildRequires:  libjpeg-devel
-BuildRequires:  libmysqld-devel
 BuildRequires:  libpng-devel
 BuildRequires:  libproj-devel
 BuildRequires:  libspatialite-devel
@@ -54,17 +58,22 @@
 BuildRequires:  libtool
 BuildRequires:  libxerces-c-devel
 BuildRequires:  libxml2-devel
+BuildRequires:  mysql-devel
 BuildRequires:  netcdf-devel
+BuildRequires:  opencl-headers
 BuildRequires:  openjpeg2-devel
+BuildRequires:  perl-macros
+BuildRequires:  php5-devel
 BuildRequires:  poppler-devel
 BuildRequires:  postgresql-devel
 BuildRequires:  python-numpy-devel
 BuildRequires:  python-setuptools
-BuildRequires:  python3-devel
 BuildRequires:  python3-numpy-devel
+BuildRequires:  python3-setuptools
 BuildRequires:  sqlite-devel >= 3
 BuildRequires:  swig
 BuildRequires:  unixODBC-devel
+BuildRequires:  xz-devel
 BuildRequires:  zlib-devel >= 1.1.4
 %if %{with ecw_support}
 BuildRequires:  libecwj2-devel
@@ -97,22 +106,23 @@
 %package devel
 Summary:GDAL library header files
 Group:  Development/Languages/C and C++
-Requires:   lib%{name}1 = %{version}
+Requires:   lib%{name}%{soversion} = %{version}
+Provides:   lib%{name}%{soversion}-devel
 Provides:   lib%{name}-devel
 
 %description devel
 Development Libraries for the GDAL file format library
 
-%package -n lib%{name}1

commit mozo for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package mozo for openSUSE:Factory checked in 
at 2016-05-17 17:14:56

Comparing /work/SRC/openSUSE:Factory/mozo (Old)
 and  /work/SRC/openSUSE:Factory/.mozo.new (New)


Package is "mozo"

Changes:

--- /work/SRC/openSUSE:Factory/mozo/mozo.changes2016-04-15 
19:11:34.0 +0200
+++ /work/SRC/openSUSE:Factory/.mozo.new/mozo.changes   2016-05-17 
17:14:58.0 +0200
@@ -1,0 +2,5 @@
+Wed May  4 16:34:01 UTC 2016 - sor.ale...@meowr.ru
+
+- Add a missing python-gobject-Gdk dependency.
+
+---



Other differences:
--
++ mozo.spec ++
--- /var/tmp/diff_new_pack.Hcb0u7/_old  2016-05-17 17:14:59.0 +0200
+++ /var/tmp/diff_new_pack.Hcb0u7/_new  2016-05-17 17:14:59.0 +0200
@@ -31,6 +31,7 @@
 BuildRequires:  gobject-introspection-devel
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  mate-common >= %{_version}
+BuildRequires:  pkg-config
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(libmate-menu) >= %{_version}
 BuildRequires:  pkgconfig(pygobject-3.0)
@@ -43,6 +44,9 @@
 Obsoletes:  mate-menu-editor < %{version}
 Obsoletes:  mate-menu-editor-lang < %{version}
 BuildArch:  noarch
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python-gobject-Gdk
+%endif
 
 %description
 This package provides Mozo, a menu editor for the MATE Desktop,
@@ -61,6 +65,7 @@
 
 %install
 %make_install
+
 %find_lang %{name} %{?no_lang_C}
 %fdupes %{buildroot}%{python_sitelib}/
 %suse_update_desktop_file %{name}




commit mate-themes for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package mate-themes for openSUSE:Factory 
checked in at 2016-05-17 17:14:52

Comparing /work/SRC/openSUSE:Factory/mate-themes (Old)
 and  /work/SRC/openSUSE:Factory/.mate-themes.new (New)


Package is "mate-themes"

Changes:

--- /work/SRC/openSUSE:Factory/mate-themes/mate-themes.changes  2016-04-15 
19:11:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.mate-themes.new/mate-themes.changes 
2016-05-17 17:14:53.0 +0200
@@ -1,0 +2,57 @@
+Wed May  4 16:34:01 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 3.20.6:
+  * GTK+-3.20 BlackMATE: Adjust tooltips.
+  * GTK+-3.20 TOK themes: Adjust tooltips.
+  * GTK+-3.20 ContrastHighInverse: Adjust tooltips.
+  * GTK+-3.20 GreenLaguna: Re-work tooltips.
+  * GTK+-3.20 Submarine themes: Re-work tooltip settings, fix
+Firefox tooltips.
+  * GTK+-3.20 TOK themes: Adjustments for headerbars, placesidebar
+and placesview.
+  * GTK+-3.20 Submarine themes: Adjust headerbars.
+  * GTK+-3.20 Menta themes: Adjust headerbar settings for gedit.
+  * GTK+-3.20 BlackMATE: Fix gedit headerbar buttons.
+  * GTK+-3.20 BlackMATE: Fix incorrect headerbar selector.
+  * GTK+-3.20 BlackMATE: More Firefox fixes.
+  * GTK+-3.20 BlackMATE: Fix check and radio buttons in Firefox
+Gtk3 website content.
+  * GTK+-3.20 TOK themes: Fix check and radio buttons for Firefox.
+  * GTK+-3.20 GreenLaguna: Fix check and radio boxes for Firefox.
+  * GTK+-3.20 BlackMATE: Fix check and radio boxes in Firefox.
+  * GTK+-3.20 Menta themes: Fix for check and radio boxes in
+Firefox.
+  * GTK+-3.20 BlackMATE: Use origin border-radius for trough and
+progress.
+  * GTK+-3.20 BlackMATE: Don't set insensitive colours as a general
+setting.
+  * GTK+-3.20 BlackMATE: Little adjustement for scrollbars.
+  * GTK+-3.20 BlackMATE: Re-work menus.
+  * GTK+-3.20 BlackMATE: Fix some general parameters.
+  * GTK+-3.20 BlackMATE: Use a padding for menubar menuitem from
+mate-panel.
+  * GTK+-3.20 BlackMATE: Fix fg colour of text selection in Firefox.
+  * GTK+-3.20 Submarine themes: More adjustments.
+  * GTK+-3.20 Menta themes: More adjustments.
+  * GTK+-3.20 TOK themes: Re-work menus and fix issue with arrows
+in Firefox menus.
+  * GTK+-3.20 GreenLaguna: Use the LSD effect on popover arrows.
+  * GTK+-3.20 GreenLaguna: Some button size correction.
+  * Enable build of GreenLaguna again.
+  * Menta themes: Improve metacity-3.xml version.
+  * GTK+-3.20 GreenLaguna: Port to gtk+-3.20.
+  * GTK+-3.20 TOK themes: Style nemo-preferences dialog.
+  * GTK+-3.20 TOK themes: Add stack-switcher support.
+  * GTK+-3.20 TOK themes: Some corrections for scrolledwindow and
+primary-toolbar button.
+  * GTK+-3.20 BlackMATE: Correct bg of active treeview cells.
+  * GTK+-3.20 BlackMATE: Match stacksidebar to placessidebar.
+  * GTK+-3.20 TOK themes: Some improvements for filechooser dialog
+window.
+  * GTK+-3.18 TOK themes: Fix button jummping in spinbuttons of
+colour selection.
+  * GTK+-3.20 TOK themes: Remove the scrollbar colour from
+scrolledwindow.
+  * GTK+-3.20 All themes: Fix text selection in firefox.
+
+---

Old:

  mate-themes-3.20.5.tar.xz

New:

  mate-themes-3.20.6.tar.xz



Other differences:
--
++ mate-themes.spec ++
--- /var/tmp/diff_new_pack.ruME7g/_old  2016-05-17 17:14:54.0 +0200
+++ /var/tmp/diff_new_pack.ruME7g/_new  2016-05-17 17:14:54.0 +0200
@@ -21,7 +21,7 @@
 # Let's use the Gtk 3.20 version for openSUSE Tumbleweed.
 %define _version 3.20
 Name:   mate-themes
-Version:3.20.5
+Version:3.20.6
 Release:0
 Summary:Themes for the MATE desktop
 License:LGPL-2.1+
@@ -31,6 +31,7 @@
 BuildRequires:  fdupes
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  mate-common
+BuildRequires:  pkg-config
 BuildRequires:  pkgconfig(gdk-pixbuf-2.0)
 BuildRequires:  pkgconfig(gtk+-2.0)
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.20
@@ -79,6 +80,7 @@
 %{_datadir}/themes/HighContrast/
 %{_datadir}/themes/ContrastHighInverse/
 %{_datadir}/themes/Green-Submarine/
+%{_datadir}/themes/GreenLaguna/
 %{_datadir}/themes/Menta/
 %{_datadir}/themes/Shiny/
 %{_datadir}/themes/TraditionalOk/

++ mate-themes-3.20.5.tar.xz -> mate-themes-3.20.6.tar.xz ++
 23528 lines of diff (skipped)




commit lightdm for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package lightdm for openSUSE:Factory checked 
in at 2016-05-17 17:14:21

Comparing /work/SRC/openSUSE:Factory/lightdm (Old)
 and  /work/SRC/openSUSE:Factory/.lightdm.new (New)


Package is "lightdm"

Changes:

--- /work/SRC/openSUSE:Factory/lightdm/lightdm.changes  2016-04-22 
16:24:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.lightdm.new/lightdm.changes 2016-05-17 
17:14:22.0 +0200
@@ -1,0 +2,18 @@
+Sat May  7 07:12:54 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 1.19.0:
+  * Use /dev/tty0 instead of /dev/console for VT operations.
+  * Don't quit on SIGUSR1, SIGUSR2 or SIGHUP.
+  * Improve XDMCP IPv6 address selection.
+  * Set XDMCP hostname field in to system hostname or configured
+value.
+  * Allow fcitx and mozc to run in guest session.
+  * Fix lxsession running in guest session.
+  * Drop support for legacy XMir.
+  * Fix g_spawn compiler warning.
+- Don't configure twice.
+- Enable Vala bindings.
+- Drop support for openSUSE older than 13.2.
+- Some spec cleanup.
+
+---

Old:

  lightdm-1.18.1.tar.xz

New:

  lightdm-1.19.0.tar.xz



Other differences:
--
++ lightdm.spec ++
--- /var/tmp/diff_new_pack.AWbXMm/_old  2016-05-17 17:14:23.0 +0200
+++ /var/tmp/diff_new_pack.AWbXMm/_new  2016-05-17 17:14:23.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package lightdm
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2011 Guido Berhoerster.
 #
 # All modifications and additions to the file contributed by third parties
@@ -16,22 +16,23 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-%define ver_master  1.18
+
+%define ver_master  1.19
 %define gobject_libname lightdm-gobject-1
 %define gobject_lib lib%{gobject_libname}-0
-%define qt_libname  lightdm-qt-3
-%define qt_lib  lib%{qt_libname}-0
+%define qt4_libname lightdm-qt-3
+%define qt4_lib lib%{qt4_libname}-0
 %define qt5_libname lightdm-qt5-3
 %define qt5_lib lib%{qt5_libname}-0
 %define typelibname typelib-1_0-LightDM-1
 %define rundir  /run
 Name:   lightdm
-Version:1.18.1
+Version:1.19.0
 Release:0
 Summary:Lightweight, Cross-desktop Display Manager
 License:GPL-3.0+
 Group:  System/X11/Displaymanagers
-Url:http://www.freedesktop.org/wiki/Software/LightDM
+Url:https://freedesktop.org/wiki/Software/LightDM
 Source0:
https://launchpad.net/lightdm/%{ver_master}/%{version}/+download/%{name}-%{version}.tar.xz
 Source1:%{name}-greeter.pamd
 Source2:X11-displaymanagers-%{name}
@@ -46,15 +47,23 @@
 # PATCH-FEATURE-OPENSUSE lightdm-set-gdmflexiserver-envvar.patch 
g...@opensuse.org -- Sets the GDMFLEXISERVER environment variable for the 
gdmflexiserver wrapper
 Patch2: lightdm-set-gdmflexiserver-envvar.patch
 # PATCH-FIX-OPENSUSE lightdm-disable-utmp-handling.patch g...@opensuse.org -- 
Disable utmp handling since this is handled in the Xstartup/Xreset scripts
-Patch5: lightdm-disable-utmp-handling.patch
+Patch3: lightdm-disable-utmp-handling.patch
 # PATCH-FIX-OPENSUSE lightdm-use-run-dir.patch g...@opensuse.org -- Use /run 
instead of /var/run
-Patch6: lightdm-use-run-dir.patch
+Patch4: lightdm-use-run-dir.patch
 BuildRequires:  gcc-c++
 BuildRequires:  gnome-common
 BuildRequires:  intltool
 BuildRequires:  libgcrypt-devel
 BuildRequires:  pam-devel
+BuildRequires:  pkg-config
+BuildRequires:  vala
 BuildRequires:  xdm
+BuildRequires:  pkgconfig(Qt5Core)
+BuildRequires:  pkgconfig(Qt5DBus)
+BuildRequires:  pkgconfig(Qt5Gui)
+BuildRequires:  pkgconfig(QtCore)
+BuildRequires:  pkgconfig(QtDBus)
+BuildRequires:  pkgconfig(QtGui)
 BuildRequires:  pkgconfig(gio-2.0) >= 2.26
 BuildRequires:  pkgconfig(gio-unix-2.0)
 BuildRequires:  pkgconfig(glib-2.0) >= 2.30
@@ -62,14 +71,6 @@
 BuildRequires:  pkgconfig(gobject-introspection-1.0)
 BuildRequires:  pkgconfig(gtk-doc)
 BuildRequires:  pkgconfig(libxklavier)
-BuildRequires:  pkgconfig(QtCore)
-BuildRequires:  pkgconfig(QtDBus)
-BuildRequires:  pkgconfig(QtGui)
-%if 0%{?suse_version} >= 1310
-BuildRequires:  pkgconfig(Qt5Core)
-BuildRequires:  pkgconfig(Qt5DBus)
-BuildRequires:  pkgconfig(Qt5Gui)
-%endif
 BuildRequires:  pkgconfig(x11)
 BuildRequires:  pkgconfig(xcb)
 BuildRequires:  pkgconfig(xdmcp)
@@ -81,14 +82,14 @@
 Requires:   xdm
 Requires(pre):  pwdutils
 Recommends: %{name}-lang
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-LightDM is a 

commit ghc-pipes for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-pipes for openSUSE:Factory 
checked in at 2016-05-17 17:14:37

Comparing /work/SRC/openSUSE:Factory/ghc-pipes (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-pipes.new (New)


Package is "ghc-pipes"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-pipes/ghc-pipes.changes  2016-01-28 
17:24:59.0 +0100
+++ /work/SRC/openSUSE:Factory/.ghc-pipes.new/ghc-pipes.changes 2016-05-17 
17:14:38.0 +0200
@@ -1,0 +2,5 @@
+Sun May  8 11:17:01 UTC 2016 - mimi...@gmail.com
+
+- update to 4.1.9 
+
+---

Old:

  pipes-4.1.8.tar.gz

New:

  pipes-4.1.9.tar.gz



Other differences:
--
++ ghc-pipes.spec ++
--- /var/tmp/diff_new_pack.Yr7s45/_old  2016-05-17 17:14:40.0 +0200
+++ /var/tmp/diff_new_pack.Yr7s45/_new  2016-05-17 17:14:40.0 +0200
@@ -21,7 +21,7 @@
 %bcond_with tests
 
 Name:   ghc-pipes
-Version:4.1.8
+Version:4.1.9
 Release:0
 Summary:Compositional pipelines
 License:BSD-3-Clause

++ pipes-4.1.8.tar.gz -> pipes-4.1.9.tar.gz ++
 10556 lines of diff (skipped)




commit ghc-socks for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-socks for openSUSE:Factory 
checked in at 2016-05-17 17:14:43

Comparing /work/SRC/openSUSE:Factory/ghc-socks (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-socks.new (New)


Package is "ghc-socks"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-socks/ghc-socks.changes  2015-05-27 
12:46:05.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-socks.new/ghc-socks.changes 2016-05-17 
17:14:44.0 +0200
@@ -1,0 +2,6 @@
+Sat May  7 06:33:56 UTC 2016 - mimi...@gmail.com
+
+- update to 0.5.5 
+- remove uselees _service
+
+---

Old:

  _service
  socks-0.5.4.tar.gz

New:

  socks-0.5.5.tar.gz



Other differences:
--
++ ghc-socks.spec ++
--- /var/tmp/diff_new_pack.rIgGbh/_old  2016-05-17 17:14:45.0 +0200
+++ /var/tmp/diff_new_pack.rIgGbh/_new  2016-05-17 17:14:45.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package ghc-socks
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,60 +15,71 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
 %global pkg_name socks
-Name:   ghc-socks
-Version:0.5.4
+
+Name:   ghc-%{pkg_name}
+Version:0.5.5
 Release:0
 Summary:Socks proxy (version 5) implementation
-License:BSD-3-Clause
 Group:  System/Libraries
-Url:http://hackage.haskell.org/package/%{pkg_name}
-Source0:
http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz
+
+License:BSD-3-Clause
+Url:https://hackage.haskell.org/package/%{pkg_name}
+Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+
 BuildRequires:  ghc-Cabal-devel
+BuildRequires:  ghc-rpm-macros
 # Begin cabal-rpm deps:
 BuildRequires:  ghc-bytestring-devel
 BuildRequires:  ghc-cereal-devel
 BuildRequires:  ghc-network-devel
-BuildRequires:  ghc-rpm-macros
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 # End cabal-rpm deps
 
 %description
-Socks proxy (version 5) implementation for Haskell.
+Socks proxy (version 5) implementation.
+
 
 %package devel
 Summary:Haskell %{pkg_name} library development files
 Group:  Development/Libraries/Other
-Requires:   %{name} = %{version}-%{release}
 Requires:   ghc-compiler = %{ghc_version}
-Provides:   %{name}-static = %{version}-%{release}
+Requires(post): ghc-compiler = %{ghc_version}
+Requires(postun): ghc-compiler = %{ghc_version}
+Requires:   %{name} = %{version}-%{release}
 
 %description devel
 This package provides the Haskell %{pkg_name} library development files.
 
+
 %prep
 %setup -q -n %{pkg_name}-%{version}
 
+
 %build
-%{ghc_lib_build}
+%ghc_lib_build
+
 
 %install
-%{ghc_lib_install}
+%ghc_lib_install
+
 
 %post devel
-%{ghc_pkg_recache}
+%ghc_pkg_recache
+
 
 %postun devel
-%{ghc_pkg_recache}
+%ghc_pkg_recache
+
 
 %files -f %{name}.files
 %defattr(-,root,root,-)
 %doc LICENSE
-%{_datadir}/%{pkg_name}-%{version}
+
 
 %files devel -f %{name}-devel.files
 %defattr(-,root,root,-)
 %doc Example.hs README.md
 
+
 %changelog

++ socks-0.5.4.tar.gz -> socks-0.5.5.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/socks-0.5.4/Network/Socks5/Parse.hs 
new/socks-0.5.5/Network/Socks5/Parse.hs
--- old/socks-0.5.4/Network/Socks5/Parse.hs 1970-01-01 01:00:00.0 
+0100
+++ new/socks-0.5.5/Network/Socks5/Parse.hs 2016-05-05 07:30:40.0 
+0200
@@ -0,0 +1,217 @@
+{-# LANGUAGE Rank2Types #-}
+{-# LANGUAGE BangPatterns #-}
+{-# LANGUAGE OverloadedStrings #-}
+-- |
+-- Module  : Network.Socks5.Parse
+-- License : BSD-style
+-- Maintainer  : Vincent Hanquez 
+-- Stability   : experimental
+-- Portability : portable
+--
+-- A very simple bytestring parser related to Parsec and Attoparsec
+--
+-- Simple example:
+--
+-- > > parse ((,) <$> take 2 <*> byte 0x20 <*> (bytes "abc" *> anyByte)) "xx 
abctest"
+-- > ParseOK "est" ("xx", 116)
+--
+module Network.Socks5.Parse
+( Parser
+, Result(..)
+-- * run the Parser
+, parse
+, parseFeed
+-- * Parser methods
+, byte
+, anyByte
+, bytes
+, take
+, takeWhile
+, takeAll
+, skip
+, skipWhile
+, skipAll
+, takeStorable
+) where
+
+import Control.Applicative
+import Control.Monad

commit ghc-tagsoup for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-tagsoup for openSUSE:Factory 
checked in at 2016-05-17 17:14:47

Comparing /work/SRC/openSUSE:Factory/ghc-tagsoup (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-tagsoup.new (New)


Package is "ghc-tagsoup"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-tagsoup/ghc-tagsoup.changes  2016-03-26 
15:26:19.0 +0100
+++ /work/SRC/openSUSE:Factory/.ghc-tagsoup.new/ghc-tagsoup.changes 
2016-05-17 17:14:48.0 +0200
@@ -1,0 +2,7 @@
+Sat May  7 06:30:29 UTC 2016 - mimi...@gmail.com
+
+- update to 0.13.10
+* improve the Haddock documentation
+* fix some > 16bit HTML entities
+
+---

Old:

  tagsoup-0.13.9.tar.gz

New:

  tagsoup-0.13.10.tar.gz



Other differences:
--
++ ghc-tagsoup.spec ++
--- /var/tmp/diff_new_pack.CC1ka4/_old  2016-05-17 17:14:49.0 +0200
+++ /var/tmp/diff_new_pack.CC1ka4/_new  2016-05-17 17:14:49.0 +0200
@@ -19,7 +19,7 @@
 %global pkg_name tagsoup
 
 Name:   ghc-tagsoup
-Version:0.13.9
+Version:0.13.10
 Release:0
 Summary:Parsing and extracting information from (possibly malformed) 
HTML/XML documents
 License:BSD-3-Clause

++ tagsoup-0.13.9.tar.gz -> tagsoup-0.13.10.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tagsoup-0.13.9/CHANGES.txt 
new/tagsoup-0.13.10/CHANGES.txt
--- old/tagsoup-0.13.9/CHANGES.txt  2016-03-15 13:07:28.0 +0100
+++ new/tagsoup-0.13.10/CHANGES.txt 2016-05-06 16:01:11.0 +0200
@@ -1,5 +1,8 @@
 Changelog for TagSoup
 
+0.13.10
+#51, improve the Haddock documentation
+#52, fix some > 16bit HTML entities
 0.13.9
 #50, fix a space leak
 #36, fix the demo examples
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tagsoup-0.13.9/Text/HTML/TagSoup/Entity.hs 
new/tagsoup-0.13.10/Text/HTML/TagSoup/Entity.hs
--- old/tagsoup-0.13.9/Text/HTML/TagSoup/Entity.hs  2016-03-15 
13:07:28.0 +0100
+++ new/tagsoup-0.13.10/Text/HTML/TagSoup/Entity.hs 2016-05-06 
16:01:11.0 +0200
@@ -108,8 +108,8 @@
 ,"AElig;" * "\x00C6"
 ,"aelig;" * "\x00E6"
 ,"af;" * "\x2061"
-,"Afr;" * "\xD835\xDD04"
-,"afr;" * "\xD835\xDD1E"
+,"Afr;" * "\x1D504"
+,"afr;" * "\x1D51E"
 ,"Agrave" * "\x00C0"
 ,"agrave" * "\x00E0"
 ,"Agrave;" * "\x00C0"
@@ -151,8 +151,8 @@
 ,"angzarr;" * "\x237C"
 ,"Aogon;" * "\x0104"
 ,"aogon;" * "\x0105"
-,"Aopf;" * "\xD835\xDD38"
-,"aopf;" * "\xD835\xDD52"
+,"Aopf;" * "\x1D538"
+,"aopf;" * "\x1D552"
 ,"ap;" * "\x2248"
 ,"apacir;" * "\x2A6F"
 ,"ape;" * "\x224A"
@@ -166,8 +166,8 @@
 ,"aring" * "\x00E5"
 ,"Aring;" * "\x00C5"
 ,"aring;" * "\x00E5"
-,"Ascr;" * "\xD835\xDC9C"
-,"ascr;" * "\xD835\xDCB6"
+,"Ascr;" * "\x1D49C"
+,"ascr;" * "\x1D4B6"
 ,"Assign;" * "\x2254"
 ,"ast;" * "\x002A"
 ,"asymp;" * "\x2248"
@@ -210,8 +210,8 @@
 ,"beta;" * "\x03B2"
 ,"beth;" * "\x2136"
 ,"between;" * "\x226C"
-,"Bfr;" * "\xD835\xDD05"
-,"bfr;" * "\xD835\xDD1F"
+,"Bfr;" * "\x1D505"
+,"bfr;" * "\x1D51F"
 ,"bigcap;" * "\x22C2"
 ,"bigcirc;" * "\x25EF"
 ,"bigcup;" * "\x22C3"
@@ -241,8 +241,8 @@
 ,"bnequiv;" * "\x2261\x20E5"
 ,"bnot;" * "\x2310"
 ,"bNot;" * "\x2AED"
-,"Bopf;" * "\xD835\xDD39"
-,"bopf;" * "\xD835\xDD53"
+,"Bopf;" * "\x1D539"
+,"bopf;" * "\x1D553"
 ,"bot;" * "\x22A5"
 ,"bottom;" * "\x22A5"
 ,"bowtie;" * "\x22C8"
@@ -296,7 +296,7 @@
 ,"brvbar" * "\x00A6"
 ,"brvbar;" * "\x00A6"
 ,"Bscr;" * "\x212C"
-,"bscr;" * "\xD835\xDCB7"
+,"bscr;" * "\x1D4B7"
 ,"bsemi;" * "\x204F"
 ,"bsim;" * "\x223D"
 ,"bsime;" * "\x22CD"
@@ -347,7 +347,7 @@
 ,"CenterDot;" * "\x00B7"
 ,"centerdot;" * "\x00B7"
 ,"Cfr;" * "\x212D"
-,"cfr;" * "\xD835\xDD20"
+,"cfr;" * "\x1D520"
 ,"CHcy;" * "\x0427"
 ,"chcy;" * "\x0447"
 ,"check;" * "\x2713"
@@ -396,7 +396,7 @@
 ,"Conint;" * "\x222F"
 ,"ContourIntegral;" * "\x222E"
 ,"Copf;" * "\x2102"
-,"copf;" * "\xD835\xDD54"
+,"copf;" * "\x1D554"
 ,"coprod;" * "\x2210"
 ,"Coproduct;" * "\x2210"
 ,"COPY" * "\x00A9"
@@ -408,8 +408,8 @@
 ,"crarr;" * "\x21B5"
 ,"cross;" * "\x2717"
 ,"Cross;" * "\x2A2F"
-,"Cscr;" * "\xD835\xDC9E"
-,"cscr;" * "\xD835\xDCB8"
+,"Cscr;" * "\x1D49E"
+,"cscr;" * "\x1D4B8"
 ,"csub;" * "\x2ACF"
 ,"csube;" * "\x2AD1"
 ,"csup;" * "\x2AD0"
@@ -473,8 +473,8 @@
 ,"delta;" * "\x03B4"
 ,"demptyv;" * "\x29B1"
 ,"dfisht;" * 

commit ghc-aeson-compat for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-aeson-compat for 
openSUSE:Factory checked in at 2016-05-17 17:14:24

Comparing /work/SRC/openSUSE:Factory/ghc-aeson-compat (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-aeson-compat.new (New)


Package is "ghc-aeson-compat"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-aeson-compat/ghc-aeson-compat.changes
2016-03-31 13:02:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-aeson-compat.new/ghc-aeson-compat.changes   
2016-05-17 17:14:26.0 +0200
@@ -1,0 +2,6 @@
+Wed May 11 14:54:56 UTC 2016 - mimi...@gmail.com
+
+- updte to 0.3.3.0
+* Enable PolyKinds to generalize Proxy, Tagged, and Const instances.
+
+---

Old:

  aeson-compat-0.3.2.0.tar.gz

New:

  aeson-compat-0.3.3.0.tar.gz



Other differences:
--
++ ghc-aeson-compat.spec ++
--- /var/tmp/diff_new_pack.WHQ7DN/_old  2016-05-17 17:14:27.0 +0200
+++ /var/tmp/diff_new_pack.WHQ7DN/_new  2016-05-17 17:14:27.0 +0200
@@ -20,7 +20,7 @@
 %bcond_with tests
 
 Name:   ghc-aeson-compat
-Version:0.3.2.0
+Version:0.3.3.0
 Release:0
 Summary:Compatibility layer for aeson
 Group:  System/Libraries

++ aeson-compat-0.3.2.0.tar.gz -> aeson-compat-0.3.3.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aeson-compat-0.3.2.0/CHANGELOG.md 
new/aeson-compat-0.3.3.0/CHANGELOG.md
--- old/aeson-compat-0.3.2.0/CHANGELOG.md   2016-03-27 17:28:25.0 
+0200
+++ new/aeson-compat-0.3.3.0/CHANGELOG.md   2016-05-02 07:08:44.0 
+0200
@@ -1,3 +1,7 @@
+# 0.3.3.0
+
+- Enable `PolyKinds` to generalize `Proxy`, `Tagged`, and `Const` instances.
+
 # 0.3.2.0
 
 - Introduce instances from `aeson-0.11.1.0`: `Const`, `Tagged`, `Proxy` and 
`NonEmpty`
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aeson-compat-0.3.2.0/aeson-compat.cabal 
new/aeson-compat-0.3.3.0/aeson-compat.cabal
--- old/aeson-compat-0.3.2.0/aeson-compat.cabal 2016-03-27 17:28:25.0 
+0200
+++ new/aeson-compat-0.3.3.0/aeson-compat.cabal 2016-05-02 07:08:44.0 
+0200
@@ -1,9 +1,9 @@
--- This file has been generated from package.yaml by hpack version 0.11.2.
+-- This file has been generated from package.yaml by hpack version 0.13.0.
 --
 -- see: https://github.com/sol/hpack
 
 name:   aeson-compat
-version:0.3.2.0
+version:0.3.3.0
 synopsis:   Compatibility layer for aeson
 description:Compatibility layer for @aeson@
 category:   Web
@@ -32,7 +32,7 @@
   build-depends:
   base >=4.6  && <4.10
 , base-compat  >=0.6.0 && <0.10
-, aeson>=0.7.0.6 && <0.11.2
+, aeson>=0.7.0.6 && <0.11.3
 , attoparsec   >=0.12 && <0.14
 , bytestring   >=0.10 && <0.11
 , containers   >=0.5  && <0.6
@@ -62,7 +62,7 @@
   build-depends:
   base >=4.6  && <4.10
 , base-compat  >=0.6.0 && <0.10
-, aeson>=0.7.0.6 && <0.11.2
+, aeson>=0.7.0.6 && <0.11.3
 , attoparsec   >=0.12 && <0.14
 , bytestring   >=0.10 && <0.11
 , containers   >=0.5  && <0.6
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aeson-compat-0.3.2.0/src/Data/Aeson/Compat.hs 
new/aeson-compat-0.3.3.0/src/Data/Aeson/Compat.hs
--- old/aeson-compat-0.3.2.0/src/Data/Aeson/Compat.hs   2016-03-27 
17:28:25.0 +0200
+++ new/aeson-compat-0.3.3.0/src/Data/Aeson/Compat.hs   2016-05-02 
07:08:44.0 +0200
@@ -1,6 +1,7 @@
 {-# LANGUAGE CPP #-}
 {-# LANGUAGE DeriveDataTypeable #-}
 {-# LANGUAGE OverloadedStrings #-}
+{-# LANGUAGE PolyKinds #-}
 {-# OPTIONS_GHC -fno-warn-orphans #-}
 -
 -- |




commit ghc-tar for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-tar for openSUSE:Factory checked 
in at 2016-05-17 17:14:48

Comparing /work/SRC/openSUSE:Factory/ghc-tar (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-tar.new (New)


Package is "ghc-tar"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-tar/ghc-tar.changes  2016-05-03 
10:16:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-tar.new/ghc-tar.changes 2016-05-17 
17:14:50.0 +0200
@@ -1,0 +2,6 @@
+Wed May  4 07:33:10 UTC 2016 - mimi...@gmail.com
+
+- update to 0.5.0.3
+* Fix tarbomb logic to ignore special PAX entries. Was breaking many valid 
tarballs.
+
+---

Old:

  tar-0.5.0.2.tar.gz

New:

  tar-0.5.0.3.tar.gz



Other differences:
--
++ ghc-tar.spec ++
--- /var/tmp/diff_new_pack.lDhEmW/_old  2016-05-17 17:14:51.0 +0200
+++ /var/tmp/diff_new_pack.lDhEmW/_new  2016-05-17 17:14:51.0 +0200
@@ -20,7 +20,7 @@
 %bcond_with tests
 
 Name:   ghc-tar
-Version:0.5.0.2
+Version:0.5.0.3
 Release:0
 Summary:Reading, writing and manipulating ".tar" archive files
 Group:  System/Libraries

++ tar-0.5.0.2.tar.gz -> tar-0.5.0.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tar-0.5.0.2/Codec/Archive/Tar/Check.hs 
new/tar-0.5.0.3/Codec/Archive/Tar/Check.hs
--- old/tar-0.5.0.2/Codec/Archive/Tar/Check.hs  2016-05-01 02:10:33.0 
+0200
+++ new/tar-0.5.0.3/Codec/Archive/Tar/Check.hs  2016-05-03 14:23:27.0 
+0200
@@ -120,6 +120,15 @@
 checkTarbomb expectedTopDir = checkEntries (checkEntryTarbomb expectedTopDir)
 
 checkEntryTarbomb :: FilePath -> Entry -> Maybe TarBombError
+checkEntryTarbomb _ entry | nonFilesystemEntry = Nothing
+  where
+-- Ignore some special entries we will not unpack anyway
+nonFilesystemEntry =
+  case entryContent entry of
+OtherEntryType 'g' _ _ -> True --PAX global header
+OtherEntryType 'x' _ _ -> True --PAX individual header
+_  -> False
+
 checkEntryTarbomb expectedTopDir entry =
   case FilePath.Native.splitDirectories (entryPath entry) of
 (topDir:_) | topDir == expectedTopDir -> Nothing
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tar-0.5.0.2/changelog.md new/tar-0.5.0.3/changelog.md
--- old/tar-0.5.0.2/changelog.md2016-05-01 02:10:33.0 +0200
+++ new/tar-0.5.0.3/changelog.md2016-05-03 14:23:27.0 +0200
@@ -1,3 +1,8 @@
+0.5.0.3 Duncan Coutts  May 2016
+
+  * Fix tarbomb logic to ignore special PAX entries. Was breaking many
+valid tarballs. https://github.com/haskell/cabal/issues/3390
+
 0.5.0.2 Duncan Coutts  April 2016
 
   * Fix compatability when using ghc-7.4.x and directory >= 1.2.3
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tar-0.5.0.2/tar.cabal new/tar-0.5.0.3/tar.cabal
--- old/tar-0.5.0.2/tar.cabal   2016-05-01 02:10:33.0 +0200
+++ new/tar-0.5.0.3/tar.cabal   2016-05-03 14:23:27.0 +0200
@@ -1,5 +1,5 @@
 name:tar
-version: 0.5.0.2
+version: 0.5.0.3
 license: BSD3
 license-file:LICENSE
 author:  Duncan Coutts 




commit cabal-rpm for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package cabal-rpm for openSUSE:Factory 
checked in at 2016-05-17 17:14:28

Comparing /work/SRC/openSUSE:Factory/cabal-rpm (Old)
 and  /work/SRC/openSUSE:Factory/.cabal-rpm.new (New)


Package is "cabal-rpm"

Changes:

--- /work/SRC/openSUSE:Factory/cabal-rpm/cabal-rpm.changes  2016-03-31 
13:02:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.cabal-rpm.new/cabal-rpm.changes 2016-05-17 
17:14:28.0 +0200
@@ -1,0 +2,6 @@
+Sat May  7 06:18:12 UTC 2016 - mimi...@gmail.com
+
+- update to 0.9.11
+* build with Cabal-1.24
+
+---

Old:

  cabal-rpm-0.9.10.tar.gz

New:

  cabal-rpm-0.9.11.tar.gz



Other differences:
--
++ cabal-rpm.spec ++
--- /var/tmp/diff_new_pack.ngGH2H/_old  2016-05-17 17:14:29.0 +0200
+++ /var/tmp/diff_new_pack.ngGH2H/_new  2016-05-17 17:14:29.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   cabal-rpm
-Version:0.9.10
+Version:0.9.11
 Release:0
 Summary:RPM packaging tool for Haskell Cabal-based packages
 License:GPL-3.0+

++ cabal-rpm-0.9.10.tar.gz -> cabal-rpm-0.9.11.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cabal-rpm-0.9.10/ChangeLog 
new/cabal-rpm-0.9.11/ChangeLog
--- old/cabal-rpm-0.9.10/ChangeLog  2016-03-24 08:29:55.0 +0100
+++ new/cabal-rpm-0.9.11/ChangeLog  2016-05-06 13:31:16.0 +0200
@@ -1,3 +1,6 @@
+* 0.9.11 (2016-05-06)
+- build with Cabal-1.24
+
 * 0.9.10 (2016-03-24)
 - bugfixes
   - update no longer tries to grep non-existent .git
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cabal-rpm-0.9.10/cabal-rpm.cabal 
new/cabal-rpm-0.9.11/cabal-rpm.cabal
--- old/cabal-rpm-0.9.10/cabal-rpm.cabal2016-03-24 08:29:55.0 
+0100
+++ new/cabal-rpm-0.9.11/cabal-rpm.cabal2016-05-06 13:31:16.0 
+0200
@@ -1,5 +1,5 @@
 Name:cabal-rpm
-Version: 0.9.10
+Version: 0.9.11
 Synopsis:RPM packaging tool for Haskell Cabal-based packages
 Description:
 This package provides a RPM packaging tool for Haskell Cabal-based 
packages.
@@ -34,7 +34,7 @@
 Executable cblrpm
 Main-is:Main.hs
 Build-depends: base < 5,
-   Cabal > 1.10 && < 1.24,
+   Cabal > 1.10 && < 1.25,
directory,
filepath,
process,
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cabal-rpm-0.9.10/src/Commands/Spec.hs 
new/cabal-rpm-0.9.11/src/Commands/Spec.hs
--- old/cabal-rpm-0.9.10/src/Commands/Spec.hs   2016-03-24 08:29:55.0 
+0100
+++ new/cabal-rpm-0.9.11/src/Commands/Spec.hs   2016-05-06 13:31:16.0 
+0200
@@ -66,7 +66,7 @@
 then do
 now <- getCurrentTime
 return $ formatTime defaultTimeLocale "0.%Y%m%d" now
-else return $ if (distro == SUSE) then "0" else "1"
+else return $ if distro == SUSE then "0" else "1"
 
 rstrip :: (Char -> Bool) -> String -> String
 rstrip p = reverse . dropWhile p . reverse
@@ -100,7 +100,7 @@
   if specAlreadyExists
 then notice verbose $ specFile +-+ "exists:" +-+ if rpmForce flags then 
"forcing overwrite" else "creating" +-+ specFile'
 else do
-let realdir dir = ("cblrpm." `isPrefixOf` takeBaseName dir)
+let realdir dir = "cblrpm." `isPrefixOf` takeBaseName dir
 when (maybe True realdir mdest) $
   putStrLn pkgname
 
@@ -274,7 +274,7 @@
   let execs = sort $ map exeName $ filter isBuildable $ executables pkgDesc
   when selfdep $ do
 putNewline
-put $ "%ghc_fix_dynamic_rpath" +-+ intercalate " " (map (\ p -> if p == 
name then "%{pkg_name}" else p) execs)
+put $ "%ghc_fix_dynamic_rpath" +-+ unwords (map (\ p -> if p == name then 
"%{pkg_name}" else p) execs)
 
   let licensefiles =
 #if defined(MIN_VERSION_Cabal) && MIN_VERSION_Cabal(1,20,0)
@@ -312,7 +312,7 @@
 
   docs <- findDocs cabalPath licensefiles
 
-  let license_macro = if (distro == Fedora) then "%license" else "%doc"
+  let license_macro = if distro == Fedora then "%license" else "%doc"
 
   when hasExecPkg $ do
 put "%files"
@@ -345,7 +345,7 @@
 when (distro /= Fedora) $ put "%defattr(-,root,root,-)"
 unless (null docs) $
   put $ "%doc" +-+ unwords docs
-when (not binlib) $
+unless binlib $
   mapM_ (\ p -> put $ "%{_bindir}/" ++ (if p == name then "%{pkg_name}" 
else p)) execs
 putNewline
 putNewline
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cabal-rpm-0.9.10/src/Dependencies.hs 

commit ghc-retry for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-retry for openSUSE:Factory 
checked in at 2016-05-17 17:14:41

Comparing /work/SRC/openSUSE:Factory/ghc-retry (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-retry.new (New)


Package is "ghc-retry"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-retry/ghc-retry.changes  2016-01-22 
01:08:27.0 +0100
+++ /work/SRC/openSUSE:Factory/.ghc-retry.new/ghc-retry.changes 2016-05-17 
17:14:43.0 +0200
@@ -1,0 +2,6 @@
+Wed May  4 07:11:22 UTC 2016 - mimi...@gmail.com
+
+- update to 0.7.2
+* Fix premature integer overflow  
+
+---

Old:

  retry-0.7.1.tar.gz

New:

  retry-0.7.2.tar.gz



Other differences:
--
++ ghc-retry.spec ++
--- /var/tmp/diff_new_pack.c3fvQx/_old  2016-05-17 17:14:44.0 +0200
+++ /var/tmp/diff_new_pack.c3fvQx/_new  2016-05-17 17:14:44.0 +0200
@@ -20,7 +20,7 @@
 %bcond_with tests
 
 Name:   ghc-retry
-Version:0.7.1
+Version:0.7.2
 Release:0
 Summary:Retry combinators for monadic actions that may fail
 Group:  System/Libraries

++ retry-0.7.1.tar.gz -> retry-0.7.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/retry-0.7.1/changelog.md new/retry-0.7.2/changelog.md
--- old/retry-0.7.1/changelog.md2016-01-13 18:40:22.0 +0100
+++ new/retry-0.7.2/changelog.md2016-05-03 17:49:56.0 +0200
@@ -1,3 +1,6 @@
+0.7.2
+* Fix premature integer overflow error thanks to Mitsutoshi Aoe
+
 0.7.1
 * Various documentation updates.
 * Add stepping combinator for manual retries.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/retry-0.7.1/retry.cabal new/retry-0.7.2/retry.cabal
--- old/retry-0.7.1/retry.cabal 2016-01-13 18:40:22.0 +0100
+++ new/retry-0.7.2/retry.cabal 2016-05-03 17:49:56.0 +0200
@@ -14,7 +14,7 @@
 case we should hang back for a bit and retry the query instead
 of simply raising an exception.
 
-version: 0.7.1
+version: 0.7.2
 synopsis:Retry combinators for monadic actions that may fail
 license: BSD3
 license-file:LICENSE
@@ -35,8 +35,9 @@
   base >= 4.6 && < 5
 , data-default-class
 , exceptions   >= 0.5 && < 0.9
+, ghc-prim < 0.5
 , random   >= 1 && < 1.2
-, transformers < 0.5
+, transformers < 0.6
   hs-source-dirs:  src
   default-language:Haskell2010
 
@@ -54,7 +55,9 @@
   , random
   , time
   , QuickCheck >= 2.7 && < 2.9
-  , HUnit  >= 1.2.5.2 && < 1.3
+  , HUnit  >= 1.2.5.2 && < 1.4
   , hspec  >= 1.9
   , stm
+  , ghc-prim
+  , mtl
 default-language: Haskell2010
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/retry-0.7.1/src/Control/Retry.hs 
new/retry-0.7.2/src/Control/Retry.hs
--- old/retry-0.7.1/src/Control/Retry.hs2016-01-13 18:40:22.0 
+0100
+++ new/retry-0.7.2/src/Control/Retry.hs2016-05-03 17:49:56.0 
+0200
@@ -1,8 +1,11 @@
 {-# LANGUAGE BangPatterns  #-}
 {-# LANGUAGE CPP   #-}
 {-# LANGUAGE DeriveGeneric #-}
+{-# LANGUAGE MagicHash #-}
 {-# LANGUAGE RankNTypes#-}
+{-# LANGUAGE RecordWildCards   #-}
 {-# LANGUAGE ScopedTypeVariables   #-}
+{-# LANGUAGE UnboxedTuples #-}
 {-# LANGUAGE ViewPatterns  #-}
 
 -
@@ -49,6 +52,7 @@
 , stepping
 , recoverAll
 , logRetries
+, defaultLogMsg
 
 -- * Retry Policies
 , constantDelay
@@ -82,9 +86,12 @@
 import   Control.Monad.Trans.Maybe
 import   Control.Monad.Trans.State
 import   Data.Default.Class
+import   Data.List (foldl')
 import   Data.Functor.Identity
 import   Data.Maybe
 import   GHC.Generics
+import   GHC.Prim
+import   GHC.Types (Int(I#))
 import   System.Random
 import   Data.Monoid
 import   Preludehiding (catch)
@@ -204,7 +211,7 @@
 case res of
   Just delay -> return $! Just $! RetryStatus 
   { rsIterNumber = rsIterNumber s + 1
-  , rsCumulativeDelay = rsCumulativeDelay s + delay
+  , rsCumulativeDelay = rsCumulativeDelay s `boundedPlus` delay
   , rsPreviousDelay = Just delay }
   Nothing -> return Nothing
 
@@ -276,8 +283,8 @@
 :: Int
 -- ^ First delay in 

commit mate-tweak for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package mate-tweak for openSUSE:Factory 
checked in at 2016-05-17 17:14:54

Comparing /work/SRC/openSUSE:Factory/mate-tweak (Old)
 and  /work/SRC/openSUSE:Factory/.mate-tweak.new (New)


Package is "mate-tweak"

Changes:

--- /work/SRC/openSUSE:Factory/mate-tweak/mate-tweak.changes2016-04-30 
23:31:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.mate-tweak.new/mate-tweak.changes   
2016-05-17 17:14:56.0 +0200
@@ -1,0 +2,5 @@
+Wed May  4 16:34:01 UTC 2016 - sor.ale...@meowr.ru
+
+- Add a missing python3-gobject-Gdk dependency.
+
+---



Other differences:
--
++ mate-tweak.spec ++
--- /var/tmp/diff_new_pack.L5ssPy/_old  2016-05-17 17:14:57.0 +0200
+++ /var/tmp/diff_new_pack.L5ssPy/_new  2016-05-17 17:14:57.0 +0200
@@ -50,6 +50,9 @@
 Requires:   xdg-utils
 Recommends: %{name}-lang
 BuildArch:  noarch
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python3-gobject-Gdk
+%endif
 
 %description
 Configures some aspects of the MATE desktop not exposed via the




commit ghc-either for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-either for openSUSE:Factory 
checked in at 2016-05-17 17:14:35

Comparing /work/SRC/openSUSE:Factory/ghc-either (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-either.new (New)


Package is "ghc-either"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-either/ghc-either.changes2015-08-27 
08:55:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-either.new/ghc-either.changes   
2016-05-17 17:14:36.0 +0200
@@ -1,0 +2,7 @@
+Wed May 11 15:13:10 UTC 2016 - mimi...@gmail.com
+
+- update to 4.4.1.1
+* Fixed building on newer GHCs. (type synonyms require explicit foralls for 
unused
+variables these days)
+
+---

Old:

  either-4.4.1.tar.gz

New:

  either-4.4.1.1.tar.gz



Other differences:
--
++ ghc-either.spec ++
--- /var/tmp/diff_new_pack.WnbfFv/_old  2016-05-17 17:14:37.0 +0200
+++ /var/tmp/diff_new_pack.WnbfFv/_new  2016-05-17 17:14:37.0 +0200
@@ -19,7 +19,7 @@
 %global pkg_name either
 
 Name:   ghc-either
-Version:4.4.1
+Version:4.4.1.1
 Release:0
 Summary:An either monad transformer
 License:BSD-3-Clause

++ either-4.4.1.tar.gz -> either-4.4.1.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/either-4.4.1/CHANGELOG.markdown 
new/either-4.4.1.1/CHANGELOG.markdown
--- old/either-4.4.1/CHANGELOG.markdown 2015-05-29 16:10:31.0 +0200
+++ new/either-4.4.1.1/CHANGELOG.markdown   2016-05-10 01:31:19.0 
+0200
@@ -1,3 +1,12 @@
+4.4.1.1
+---
+* Fixed building on newer GHCs. (type synonyms require explicit foralls for 
unused variables these days)
+
+4.4.1
+-
+* `transformers` 0.5 support
+* Documentation fixes
+
 4.4
 ---
 * Support `mmorph`
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/either-4.4.1/README.markdown 
new/either-4.4.1.1/README.markdown
--- old/either-4.4.1/README.markdown2015-05-29 16:10:31.0 +0200
+++ new/either-4.4.1.1/README.markdown  2016-05-10 01:31:19.0 +0200
@@ -1,7 +1,7 @@
 either
 ==
 
-[![Build 
Status](https://secure.travis-ci.org/ekmett/either.png?branch=master)](http://travis-ci.org/ekmett/either)
+[![Hackage](https://img.shields.io/hackage/v/either.svg)](https://hackage.haskell.org/package/either)
 [![Build 
Status](https://secure.travis-ci.org/ekmett/either.png?branch=master)](http://travis-ci.org/ekmett/either)
 
 This provides an `Either` monad transformer that unlike `ErrorT` is 
unencumbered by a constraint on its `Left` hand argument. This is needed for a 
number of applications of this monad transformer, notably in 
[recursion-schemes](https://github.com/ekmett/recursion-schemes).
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/either-4.4.1/either.cabal 
new/either-4.4.1.1/either.cabal
--- old/either-4.4.1/either.cabal   2015-05-29 16:10:31.0 +0200
+++ new/either-4.4.1.1/either.cabal 2016-05-10 01:31:19.0 +0200
@@ -1,6 +1,6 @@
 name:  either
 category:  Control, Monads
-version:   4.4.1
+version:   4.4.1.1
 license:   BSD3
 cabal-version: >= 1.6
 license-file:  LICENSE
@@ -38,7 +38,7 @@
 profunctors   >= 4   && < 6,
 semigroups>= 0.8.3.1 && < 1,
 semigroupoids >= 4   && < 6,
-transformers  >= 0.2 && < 0.5,
+transformers  >= 0.2 && < 0.6,
 transformers-base >= 0.4 && < 0.5
 
   extensions: CPP
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/either-4.4.1/src/Data/Either/Combinators.hs 
new/either-4.4.1.1/src/Data/Either/Combinators.hs
--- old/either-4.4.1/src/Data/Either/Combinators.hs 2015-05-29 
16:10:31.0 +0200
+++ new/either-4.4.1.1/src/Data/Either/Combinators.hs   2016-05-10 
01:31:19.0 +0200
@@ -237,7 +237,7 @@
 -- | Extract the left value or a default.
 --
 -- @
--- 'fromLeft' ≡ 'either' 'id'
+-- 'fromLeft' b ≡ 'either' 'id' ('const' b)
 -- @
 --
 -- >>> fromLeft "hello" (Right 42)
@@ -252,7 +252,7 @@
 -- | Extract the right value or a default.
 --
 -- @
--- 'fromRight' b ≡ 'either' b 'id'
+-- 'fromRight' b ≡ 'either' ('const' b) 'id'
 -- @
 --
 -- >>> fromRight "hello" (Right "world")
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/either-4.4.1/src/Data/Either/Validation.hs 
new/either-4.4.1.1/src/Data/Either/Validation.hs
--- old/either-4.4.1/src/Data/Either/Validation.hs  2015-05-29 
16:10:31.0 +0200
+++ new/either-4.4.1.1/src/Data/Either/Validation.hs2016-05-10 

commit ghc-pureMD5 for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-pureMD5 for openSUSE:Factory 
checked in at 2016-05-17 17:14:39

Comparing /work/SRC/openSUSE:Factory/ghc-pureMD5 (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-pureMD5.new (New)


Package is "ghc-pureMD5"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-pureMD5/ghc-pureMD5.changes  2016-03-26 
17:26:51.0 +0100
+++ /work/SRC/openSUSE:Factory/.ghc-pureMD5.new/ghc-pureMD5.changes 
2016-05-17 17:14:40.0 +0200
@@ -1,0 +2,6 @@
+Wed May 11 15:25:25 UTC 2016 - mimi...@gmail.com
+
+- update to 2.1.3
+- remove no-inline-get-nth-word.patch -- upstreamed
+
+---

Old:

  no-inline-get-nth-word.patch
  pureMD5-2.1.2.1.tar.gz

New:

  pureMD5-2.1.3.tar.gz



Other differences:
--
++ ghc-pureMD5.spec ++
--- /var/tmp/diff_new_pack.W0shfi/_old  2016-05-17 17:14:41.0 +0200
+++ /var/tmp/diff_new_pack.W0shfi/_new  2016-05-17 17:14:41.0 +0200
@@ -19,7 +19,7 @@
 %global pkg_name pureMD5
 
 Name:   ghc-pureMD5
-Version:2.1.2.1
+Version:2.1.3
 Release:0
 Summary:A Haskell-only implementation of the MD5 digest (hash) 
algorithm
 License:BSD-3-Clause
@@ -27,8 +27,6 @@
 
 Url:https://hackage.haskell.org/package/%{pkg_name}
 Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
-# PATCH-FIX-UPSTREAM no-inline-get-nth-word.patch 
peter.tromm...@ohm-hochschule.de -- Do not inline long form of getNthWord. See 
pull request https://github.com/TomMD/pureMD5/pull/3 for details
-Patch:  no-inline-get-nth-word.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 BuildRequires:  ghc-Cabal-devel
@@ -60,7 +58,6 @@
 
 %prep
 %setup -q -n %{pkg_name}-%{version}
-%patch -p1
 
 %build
 %ghc_lib_build

++ pureMD5-2.1.2.1.tar.gz -> pureMD5-2.1.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pureMD5-2.1.2.1/Data/Digest/Pure/MD5.hs 
new/pureMD5-2.1.3/Data/Digest/Pure/MD5.hs
--- old/pureMD5-2.1.2.1/Data/Digest/Pure/MD5.hs 2012-09-06 18:05:05.0 
+0200
+++ new/pureMD5-2.1.3/Data/Digest/Pure/MD5.hs   2016-05-09 19:45:01.0 
+0200
@@ -1,25 +1,27 @@
-{-# LANGUAGE BangPatterns, ForeignFunctionInterface, MultiParamTypeClasses, 
CPP #-}
+{-# LANGUAGE BangPatterns #-}
+{-# LANGUAGE CPP #-}
+{-# LANGUAGE MultiParamTypeClasses #-}
 -
 --
 -- Module  : Data.Digest.Pure.MD5
 -- License : BSD3
 -- Maintainer  : thomas.dubuis...@gmail.com
 -- Stability   : experimental
--- Portability : portable, requires bang patterns and ByteString
--- Tested with : GHC-6.8.1
+-- Portability : portable
+-- Tested with : GHC-7.6.3
 --
 -- | It is suggested you use the 'crypto-api' class-based interface to access 
the MD5 algorithm.
 -- Either rely on type inference or provide an explicit type:
 --
 -- @
---   hashFileStrict = liftM hash' B.readFile
---   hashFileLazyBS = liftM hash B.readFile
+--   hashFileStrict = liftM hash' . B.readFile
+--   hashFileLazyBS = liftM hash . B.readFile
 -- @
 --
 -
 
 module Data.Digest.Pure.MD5
-   (
+(
 -- * Types
   MD5Context
 , MD5Digest
@@ -29,23 +31,23 @@
 , md5
 , md5Update
 , md5Finalize
-   -- * Crypto-API interface
-   , Hash(..)
+, md5DigestBytes
+-- * Crypto-API interface
+, Hash(..)
 ) where
 
-import Data.ByteString.Unsafe (unsafeUseAsCString)
 import qualified Data.ByteString as B
 import qualified Data.ByteString.Lazy as L
-import Data.ByteString.Unsafe (unsafeDrop)
+import Data.ByteString.Unsafe (unsafeDrop,unsafeUseAsCString)
 import Data.ByteString.Internal
+#if MIN_VERSION_binary(0,8,3)
+import Data.ByteString.Builder.Extra as B
+#endif
 import Data.Bits
 import Data.List
-import Data.Int (Int64)
 import Data.Word
 import Foreign.Storable
-import Foreign.Ptr
-import Foreign.ForeignPtr
-import System.IO
+import Foreign.Ptr (castPtr)
 import Data.Binary
 import Data.Binary.Get
 import Data.Binary.Put
@@ -53,16 +55,19 @@
 import qualified Data.Serialize.Put as P
 import qualified Data.Serialize as S
 import Crypto.Classes (Hash(..), hash)
+import Control.Monad (replicateM_)
 import Data.Tagged
 import Numeric
+#ifdef FastWordExtract
+import System.IO.Unsafe (unsafePerformIO)
+#endif
 
 -- | Block size in bits
 md5BlockSize :: Int
 md5BlockSize = 512
 
+blockSizeBytes :: Int
 blockSizeBytes = md5BlockSize `div` 8
-blockSizeBytesI64 = (fromIntegral 

commit mate-applet-dock for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package mate-applet-dock for 
openSUSE:Factory checked in at 2016-05-17 17:14:50

Comparing /work/SRC/openSUSE:Factory/mate-applet-dock (Old)
 and  /work/SRC/openSUSE:Factory/.mate-applet-dock.new (New)


Package is "mate-applet-dock"

Changes:

--- /work/SRC/openSUSE:Factory/mate-applet-dock/mate-applet-dock.changes
2016-04-15 19:11:20.0 +0200
+++ /work/SRC/openSUSE:Factory/.mate-applet-dock.new/mate-applet-dock.changes   
2016-05-17 17:14:51.0 +0200
@@ -1,0 +2,21 @@
+Wed May  4 16:34:01 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 0.71:
+  * More improvements to matching applications with their .desktop
+files.
+  * Application icons can now be sourced from the 'hicolor'
+directory.
+  * The window list now displays the title of the active window in
+bold and italicised text.
+  * Remove the options to display pinned applications from all or
+only the current workspace as these were based on a
+misunderstanding of a feature request. They have been replaced
+with a new option to only show indicators and window list
+items for windows which are on the current workspace and this
+provides the requested functionality.
+  * Add a 'Hints and Tips' window accessible from the About dialog
+as a place to list useful keyboard shortcuts etc.
+- Add missing python3-gobject-cairo, python3-gobject-Gdk
+  dependencies.
+
+---

Old:

  dock-applet-0.70.tar.gz

New:

  dock-applet-0.71.tar.gz



Other differences:
--
++ mate-applet-dock.spec ++
--- /var/tmp/diff_new_pack.tSvjtx/_old  2016-05-17 17:14:52.0 +0200
+++ /var/tmp/diff_new_pack.tSvjtx/_new  2016-05-17 17:14:52.0 +0200
@@ -18,7 +18,7 @@
 
 %define _name   dock-applet
 Name:   mate-applet-dock
-Version:0.70
+Version:0.71
 Release:0
 Summary:Dock applet for the MATE panel
 License:GPL-2.0+
@@ -33,9 +33,13 @@
 Requires:   python3-Pillow
 Requires:   python3-cairo
 Requires:   python3-gobject
+Requires:   python3-gobject-cairo
 Requires:   python3-scipy
 Requires:   python3-xdg
 %glib2_gsettings_schema_requires
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python3-gobject-Gdk
+%endif
 
 %description
 An application dock applet for the MATE panel.
@@ -71,7 +75,7 @@
 
 %install
 %make_install
-%fdupes %{buildroot}%{_libdir}
+%fdupes %{buildroot}%{_libdir}/
 
 find %{buildroot}%{_libdir} -type f -name '*.py' | while read py; do
 if [[ "$(head -c2 "$py"; echo)" == "#!" ]]; then

++ dock-applet-0.70.tar.gz -> dock-applet-0.71.tar.gz ++
 1910 lines of diff (skipped)




commit ghc-split for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-split for openSUSE:Factory 
checked in at 2016-05-17 17:14:45

Comparing /work/SRC/openSUSE:Factory/ghc-split (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-split.new (New)


Package is "ghc-split"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-split/ghc-split.changes  2016-01-22 
01:08:24.0 +0100
+++ /work/SRC/openSUSE:Factory/.ghc-split.new/ghc-split.changes 2016-05-17 
17:14:47.0 +0200
@@ -1,0 +2,7 @@
+Wed May  4 07:29:07 UTC 2016 - mimi...@gmail.com
+
+- update to 0.2.3.1
+* Fix a test case which was causing occasional spurious test suite
+failures due to too many discarded tests.
+
+---

Old:

  split-0.2.3.tar.gz

New:

  split-0.2.3.1.tar.gz



Other differences:
--
++ ghc-split.spec ++
--- /var/tmp/diff_new_pack.nu3jYQ/_old  2016-05-17 17:14:48.0 +0200
+++ /var/tmp/diff_new_pack.nu3jYQ/_new  2016-05-17 17:14:48.0 +0200
@@ -21,7 +21,7 @@
 %bcond_with tests
 
 Name:   ghc-split
-Version:0.2.3
+Version:0.2.3.1
 Release:0
 Summary:Combinator library for splitting lists
 License:BSD-3-Clause

++ split-0.2.3.tar.gz -> split-0.2.3.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/split-0.2.3/CHANGES new/split-0.2.3.1/CHANGES
--- old/split-0.2.3/CHANGES 2016-01-12 16:34:45.0 +0100
+++ new/split-0.2.3.1/CHANGES   2016-05-03 04:13:41.0 +0200
@@ -1,3 +1,9 @@
+* 0.2.3.1 (2 May 2016)
+
+  - Fix a test case which was causing occasional spurious test suite
+failures due to too many discarded tests.  Thanks to Doug
+Beardsley and Peter Simons for reporting the issue.
+
 * 0.2.3 (12 January 2016)
 
   - New function 'divvy' (with associated tests) from Tim Washington.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/split-0.2.3/split.cabal new/split-0.2.3.1/split.cabal
--- old/split-0.2.3/split.cabal 2016-01-12 16:34:45.0 +0100
+++ new/split-0.2.3.1/split.cabal   2016-05-03 04:13:41.0 +0200
@@ -1,5 +1,5 @@
 Name:split
-Version: 0.2.3
+Version: 0.2.3.1
 Stability:   stable
 
 Description: A collection of various methods for splitting
@@ -35,7 +35,7 @@
 Category:List
 Build-type:  Simple
 Cabal-Version:   >= 1.10
-Tested-with: GHC ==7.0.4, GHC ==7.2.1, GHC ==7.4.*, GHC ==7.6.1, GHC 
==7.8.3, GHC==7.10.3
+Tested-with: GHC ==7.0.4, GHC ==7.2.1, GHC ==7.4.*, GHC ==7.6.1, GHC 
==7.8.3, GHC==7.10.3, GHC==8.0.1
 Bug-reports: http://hub.darcs.net/byorgey/split/issues
 
 Test-suite split-tests
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/split-0.2.3/test/Properties.hs 
new/split-0.2.3.1/test/Properties.hs
--- old/split-0.2.3/test/Properties.hs  2016-01-12 16:34:45.0 +0100
+++ new/split-0.2.3.1/test/Properties.hs2016-05-03 04:13:41.0 
+0200
@@ -363,8 +363,14 @@
 prop_chop_words s = words s' == (filter (not . null) . chop (span (not . 
isSpace) . dropWhile isSpace) $ s')
   where s' = map unEltWS s
 
-prop_divvy_evenly :: [Elt] -> Positive Int -> Property
-prop_divvy_evenly elems (Positive n) = (length elems `mod` n == 0) ==> concat 
(divvy n n elems) == elems
+prop_divvy_evenly :: [Elt] -> Positive Int -> Bool
+prop_divvy_evenly elems (Positive n) = concat (divvy n n elems') == elems'
+  where
+-- Chop off the smallest possible tail of elems to make the length
+-- evenly divisible by n.  This property used to have a
+-- precondition (length elemens `mod` n == 0), but that led to too
+-- many discarded test cases and occasional test suite failures.
+elems' = take ((length elems `div` n) * n) elems
 
 prop_divvy_discard_remainder :: [Elt] -> Positive Int -> Bool
 prop_divvy_discard_remainder elems (Positive n) =




commit ghc-concurrent-output for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package ghc-concurrent-output for 
openSUSE:Factory checked in at 2016-05-17 17:14:29

Comparing /work/SRC/openSUSE:Factory/ghc-concurrent-output (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-concurrent-output.new (New)


Package is "ghc-concurrent-output"

Changes:

--- 
/work/SRC/openSUSE:Factory/ghc-concurrent-output/ghc-concurrent-output.changes  
2016-05-03 09:36:24.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.ghc-concurrent-output.new/ghc-concurrent-output.changes
 2016-05-17 17:14:30.0 +0200
@@ -1,0 +2,12 @@
+Wed May 11 15:09:45 UTC 2016 - mimi...@gmail.com
+
+- update to 1.7.6
+* Update transformers dep to allow 0.5.
+
+---
+Mon May  2 10:02:55 UTC 2016 - mimi...@gmail.com
+
+- update to 1.7.5
+* createProcessConcurrent and System.Process.Concurrent are now available on 
Windows
+
+---

Old:

  concurrent-output-1.7.4.tar.gz

New:

  concurrent-output-1.7.6.tar.gz



Other differences:
--
++ ghc-concurrent-output.spec ++
--- /var/tmp/diff_new_pack.Zc1ti2/_old  2016-05-17 17:14:31.0 +0200
+++ /var/tmp/diff_new_pack.Zc1ti2/_new  2016-05-17 17:14:31.0 +0200
@@ -18,7 +18,7 @@
 
 %global pkg_name concurrent-output
 Name:   ghc-%{pkg_name}
-Version:1.7.4
+Version:1.7.6
 Release:0
 Summary:Ungarble output from several threads or commands
 License:BSD-2-Clause

++ concurrent-output-1.7.4.tar.gz -> concurrent-output-1.7.6.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/concurrent-output-1.7.4/CHANGELOG 
new/concurrent-output-1.7.6/CHANGELOG
--- old/concurrent-output-1.7.4/CHANGELOG   2016-03-12 18:18:30.0 
+0100
+++ new/concurrent-output-1.7.6/CHANGELOG   2016-05-02 14:01:38.0 
+0200
@@ -1,3 +1,16 @@
+concurrent-output (1.7.6) unstable; urgency=medium
+
+  * Update transformers dep to allow 0.5.
+
+ -- Joey Hess   Mon, 02 May 2016 08:01:20 -0400
+
+concurrent-output (1.7.5) unstable; urgency=medium
+
+  * createProcessConcurrent and System.Process.Concurrent are
+now available on Windows.
+
+ -- Joey Hess   Sun, 01 May 2016 19:40:38 -0400
+
 concurrent-output (1.7.4) unstable; urgency=medium
 
   * Update process dep to allow 1.4.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/concurrent-output-1.7.4/System/Console/Concurrent/Internal.hs 
new/concurrent-output-1.7.6/System/Console/Concurrent/Internal.hs
--- old/concurrent-output-1.7.4/System/Console/Concurrent/Internal.hs   
2016-03-12 18:18:30.0 +0100
+++ new/concurrent-output-1.7.6/System/Console/Concurrent/Internal.hs   
2016-05-02 14:01:38.0 +0200
@@ -1,5 +1,7 @@
 {-# LANGUAGE BangPatterns, TypeSynonymInstances, FlexibleInstances, 
TupleSections #-}
-{-# LANGUAGE CPP #-}
+{-# OPTIONS_GHC -O2 #-}
+{- Building this module with -O0 causes streams not to fuse and too much
+ - memory to be used. -}
 
 -- | 
 -- Copyright: 2015 Joey Hess 
@@ -12,9 +14,6 @@
 module System.Console.Concurrent.Internal where
 
 import System.IO
-#ifndef mingw32_HOST_OS
-import System.Posix.IO
-#endif
 import System.Directory
 import System.Exit
 import Control.Monad
@@ -258,7 +257,6 @@
 -- as the output lock becomes free.
 --
 -- Currently only available on Unix systems, not Windows.
-#ifndef mingw32_HOST_OS
 createProcessConcurrent :: P.CreateProcess -> IO (Maybe Handle, Maybe Handle, 
Maybe Handle, ConcurrentProcessHandle) 
 createProcessConcurrent p
| willOutput (P.std_out p) || willOutput (P.std_err p) =
@@ -271,7 +269,6 @@
asyncProcessWaiter $
void $ tryIO $ P.waitForProcess h
return (toConcurrentProcessHandle r)
-#endif
 
 -- | Wrapper around `System.Process.createProcess` that makes sure a process
 -- is run in the foreground, with direct access to stdout and stderr.
@@ -293,31 +290,33 @@
dropOutputLock
return (toConcurrentProcessHandle r)
 
-#ifndef mingw32_HOST_OS
 bgProcess :: P.CreateProcess -> IO (Maybe Handle, Maybe Handle, Maybe Handle, 
ConcurrentProcessHandle)
 bgProcess p = do
-   (toouth, fromouth) <- pipe
-   (toerrh, fromerrh) <- pipe
let p' = p
-   { P.std_out = rediroutput (P.std_out p) toouth
-   , P.std_err = rediroutput (P.std_err p) toerrh
+   { P.std_out = rediroutput (P.std_out p)
+   , P.std_err = rediroutput (P.std_err p)
}
registerOutputThread
-   r@(_, _, _, 

commit xorg-x11-server for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package xorg-x11-server for openSUSE:Factory 
checked in at 2016-05-17 17:14:09

Comparing /work/SRC/openSUSE:Factory/xorg-x11-server (Old)
 and  /work/SRC/openSUSE:Factory/.xorg-x11-server.new (New)


Package is "xorg-x11-server"

Changes:

--- /work/SRC/openSUSE:Factory/xorg-x11-server/xorg-x11-server.changes  
2016-05-13 09:22:45.0 +0200
+++ /work/SRC/openSUSE:Factory/.xorg-x11-server.new/xorg-x11-server.changes 
2016-05-17 17:14:10.0 +0200
@@ -1,0 +2,11 @@
+Mon May 16 19:53:50 UTC 2016 - e...@suse.com
+
+- Replace
+  N_Force-swcursor-for-KMS-drivers-without-hw-cursor-sup.patch
+  by
+  N_Disable-HW-Cursor-for-cirrus-and-mgag200-kernel-modules.patch
+  Only disable HW cursor for cirrus and mgag200. This should fix
+  a regression introduced by using modesetting for Intel gen9+ 
+  (boo#980124).
+
+---

Old:

  N_Force-swcursor-for-KMS-drivers-without-hw-cursor-sup.patch

New:

  N_Disable-HW-Cursor-for-cirrus-and-mgag200-kernel-modules.patch



Other differences:
--
++ xorg-x11-server.spec ++
--- /var/tmp/diff_new_pack.uYGlss/_old  2016-05-17 17:14:11.0 +0200
+++ /var/tmp/diff_new_pack.uYGlss/_new  2016-05-17 17:14:11.0 +0200
@@ -190,7 +190,7 @@
 Patch104:   u_xorg-server-xdmcp.patch
 Patch112:   
u_render-Cast-color-masks-to-unsigned-long-before-shifting-them.patch
 
-Patch115:   N_Force-swcursor-for-KMS-drivers-without-hw-cursor-sup.patch
+Patch115:   N_Disable-HW-Cursor-for-cirrus-and-mgag200-kernel-modules.patch
 
 Patch117:   xorg-x11-server-byte-order.patch
 

++ N_Disable-HW-Cursor-for-cirrus-and-mgag200-kernel-modules.patch ++
From: Egbert Eich 
Date: Mon May 16 21:22:31 2016 +0200
Subject: [PATCH]Disable HW Cursor for cirrus and mgag200 kernel modules.
Patch-mainline: N/A
Git-commit: 265e92915c8182369a50c89f9ca0d36b9baab8b6
References: boo#980124
Signed-off-by: Egbert Eich 

Signed-off-by: Egbert Eich 
---
 hw/xfree86/drivers/modesetting/driver.c | 11 +++
 1 file changed, 11 insertions(+)

diff --git a/hw/xfree86/drivers/modesetting/driver.c 
b/hw/xfree86/drivers/modesetting/driver.c
index 8f60eae..a81efaf 100644
--- a/hw/xfree86/drivers/modesetting/driver.c
+++ b/hw/xfree86/drivers/modesetting/driver.c
@@ -858,6 +858,17 @@ PreInit(ScrnInfoPtr pScrn, int flags)
 
 if (xf86ReturnOptValBool(ms->drmmode.Options, OPTION_SW_CURSOR, FALSE)) {
 ms->drmmode.sw_cursor = TRUE;
+} else {
+/* hw cursor still considered broken on cirrus */
+drmVersionPtr drm_version = drmGetVersion(ms->fd);
+if (drm_version) {
+if (strncmp("cirrus", drm_version->name,
+min(7,drm_version->name_len)) == 0 ||
+strncmp("mgag200", drm_version->name,
+min(8,drm_version->name_len)) == 0)
+ms->drmmode.sw_cursor = TRUE;
+drmFreeVersion(drm_version);
+}
 }
 
 ms->cursor_width = 64;



commit python3-backports_abc for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-backports_abc for 
openSUSE:Factory checked in at 2016-05-17 17:14:03

Comparing /work/SRC/openSUSE:Factory/python3-backports_abc (Old)
 and  /work/SRC/openSUSE:Factory/.python3-backports_abc.new (New)


Package is "python3-backports_abc"

Changes:

--- 
/work/SRC/openSUSE:Factory/python3-backports_abc/python3-backports_abc.changes  
2015-11-24 22:33:40.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python3-backports_abc.new/python3-backports_abc.changes
 2016-05-17 17:14:04.0 +0200
@@ -1,0 +2,12 @@
+Mon May 16 17:52:29 UTC 2016 - jeng...@inai.de
+
+- Drop trailing dot from summary, and redundant defattr parameter.
+
+---
+Sun May  8 07:14:45 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-backports_abc.spec ++
--- /var/tmp/diff_new_pack.fxuwEv/_old  2016-05-17 17:14:05.0 +0200
+++ /var/tmp/diff_new_pack.fxuwEv/_new  2016-05-17 17:14:05.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-backports_abc
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,11 +19,11 @@
 Name:   python3-backports_abc
 Version:0.4
 Release:0
-Summary:A backport of recent additions to the 'collections.abc' module.
+Summary:A backport of recent additions to the 'collections.abc' module
 License:Python-2.0
 Group:  Development/Languages/Python
 Url:https://pypi.python.org/pypi/backports_abc
-Source: 
https://pypi.python.org/packages/source/b/backports_abc/backports_abc-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/b/backports_abc/backports_abc-%{version}.tar.gz
 BuildRequires:  python3-devel
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
@@ -56,7 +56,7 @@
 python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
 
 %files
-%defattr(-,root,root,-)
+%defattr(-,root,root)
 %{python3_sitelib}/*
 %doc README.rst CHANGES.rst
 




commit raspberrypi-firmware for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package raspberrypi-firmware for 
openSUSE:Factory checked in at 2016-05-17 17:14:16

Comparing /work/SRC/openSUSE:Factory/raspberrypi-firmware (Old)
 and  /work/SRC/openSUSE:Factory/.raspberrypi-firmware.new (New)


Package is "raspberrypi-firmware"

Changes:

--- 
/work/SRC/openSUSE:Factory/raspberrypi-firmware/raspberrypi-firmware.changes
2016-05-04 08:19:53.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.raspberrypi-firmware.new/raspberrypi-firmware.changes
   2016-05-17 17:14:18.0 +0200
@@ -1,0 +2,5 @@
+Wed May  4 19:37:54 UTC 2016 - afaer...@suse.de
+
+- Enable aarch64 builds for Raspberry Pi 3
+
+---



Other differences:
--
++ raspberrypi-firmware.spec ++
--- /var/tmp/diff_new_pack.hbgt0A/_old  2016-05-17 17:14:19.0 +0200
+++ /var/tmp/diff_new_pack.hbgt0A/_new  2016-05-17 17:14:19.0 +0200
@@ -23,7 +23,7 @@
 License:SUSE-Firmware
 Group:  System/Boot
 Url:https://github.com/raspberrypi/firmware/
-ExclusiveArch:  %arm
+ExclusiveArch:  %arm aarch64
 Source0:raspberrypi-firmware-%{version}.tar.bz2
 Source1:get-from-git.sh
 Source2:Config.txt




commit xf86-video-intel for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package xf86-video-intel for 
openSUSE:Factory checked in at 2016-05-17 17:13:56

Comparing /work/SRC/openSUSE:Factory/xf86-video-intel (Old)
 and  /work/SRC/openSUSE:Factory/.xf86-video-intel.new (New)


Package is "xf86-video-intel"

Changes:

--- /work/SRC/openSUSE:Factory/xf86-video-intel/xf86-video-intel.changes
2016-05-11 16:37:08.0 +0200
+++ /work/SRC/openSUSE:Factory/.xf86-video-intel.new/xf86-video-intel.changes   
2016-05-17 17:13:58.0 +0200
@@ -1,0 +2,15 @@
+Mon May 16 14:37:18 UTC 2016 - e...@suse.com
+
+- Updated to 2.99.917.651_g34f63f2:
+  sna: Do not force ping-pong migration for TearFree + NoAccel
+  sna: Add a special case for fast DRI2CopyRegion and NoAccel
+  sna/dri2: Force consideration of the DRI2CopyRegion source as unclean
+  sna/dri2: Enforce swap-limits on stale buffers
+  sna/gen6+: Don't force a switch to BLT if the target bo cannot be blitted
+  sna/dri2: Force blocking wait if vblank queue fails
+  sna/dri2: Refactor open-coded __kgem_bo_is_busy
+  sna: Do not cache the current crtc bo after performing the setcrtc
+  sna: Ensure we only cache the local CRTC scanout buffer
+  (boo#980124).
+
+---
@@ -12,0 +28 @@
+

Old:

  xf86-video-intel-2.99.917.641_ge4ef6e9.tar.bz2

New:

  xf86-video-intel-2.99.917.651_g34f63f2.tar.bz2



Other differences:
--
++ xf86-video-intel.spec ++
--- /var/tmp/diff_new_pack.Q4I8IP/_old  2016-05-17 17:13:59.0 +0200
+++ /var/tmp/diff_new_pack.Q4I8IP/_new  2016-05-17 17:13:59.0 +0200
@@ -20,7 +20,7 @@
 %define backlighthelper 0
 
 Name:   xf86-video-intel
-Version:2.99.917.641_ge4ef6e9
+Version:2.99.917.651_g34f63f2
 Release:0
 Summary:Intel video driver for the Xorg X server
 License:MIT

++ xf86-video-intel-2.99.917.641_ge4ef6e9.tar.bz2 -> 
xf86-video-intel-2.99.917.651_g34f63f2.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/xf86-video-intel-2.99.917.641_ge4ef6e9/configure.ac 
new/xf86-video-intel-2.99.917.651_g34f63f2/configure.ac
--- old/xf86-video-intel-2.99.917.641_ge4ef6e9/configure.ac 2016-04-30 
15:10:57.0 +0200
+++ new/xf86-video-intel-2.99.917.651_g34f63f2/configure.ac 2016-05-16 
11:14:04.0 +0200
@@ -280,6 +280,9 @@
 AM_CONDITIONAL(X11_DRI3, test "x$x11_dri3" = "xyes" -a "x$shm" = "xyes")
 AM_CONDITIONAL(X11_SHM, test "x$shm" = "xyes")
 
+PKG_CHECK_MODULES(X11_VM, [xxf86vm], [x11_vm="yes"], [x11_vm="no"])
+AM_CONDITIONAL(X11_VM, test "x$x11_vm" = "xyes")
+
 AC_ARG_ENABLE(tools,
   AS_HELP_STRING([--disable-tools],
 [Enable building and installing the miscellaneous 
tools [default=auto]]),
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/xf86-video-intel-2.99.917.641_ge4ef6e9/src/sna/blt.c 
new/xf86-video-intel-2.99.917.651_g34f63f2/src/sna/blt.c
--- old/xf86-video-intel-2.99.917.641_ge4ef6e9/src/sna/blt.c2016-04-30 
15:10:57.0 +0200
+++ new/xf86-video-intel-2.99.917.651_g34f63f2/src/sna/blt.c2016-05-16 
11:14:04.0 +0200
@@ -349,6 +349,71 @@
}
 }
 
+static fast_memcpy void
+memcpy_between_tiled_x__swizzle_0(const void *src, void *dst, int bpp,
+ int32_t src_stride, int32_t dst_stride,
+ int16_t src_x, int16_t src_y,
+ int16_t dst_x, int16_t dst_y,
+ uint16_t width, uint16_t height)
+{
+   const unsigned tile_width = 512;
+   const unsigned tile_height = 8;
+   const unsigned tile_size = 4096;
+
+   const unsigned cpp = bpp / 8;
+   const unsigned tile_pixels = tile_width / cpp;
+   const unsigned tile_shift = ffs(tile_pixels) - 1;
+   const unsigned tile_mask = tile_pixels - 1;
+
+   DBG(("%s(bpp=%d): src=(%d, %d), dst=(%d, %d), size=%dx%d, 
pitch=%d/%d\n",
+__FUNCTION__, bpp, src_x, src_y, dst_x, dst_y, width, height, 
src_stride, dst_stride));
+   assert(src != dst);
+   assert((dst_x & tile_mask) == (src_x & tile_mask));
+
+   while (height--) {
+   unsigned w = width * cpp;
+   uint8_t *dst_row = dst;
+   const uint8_t *src_row = src;
+
+   dst_row += dst_y / tile_height * dst_stride * tile_height;
+   dst_row += (dst_y & (tile_height-1)) * tile_width;
+   if (dst_x)
+   dst_row += (dst_x >> tile_shift) * tile_size;
+   dst_y++;
+
+   src_row += src_y / tile_height * src_stride * 

commit python3-tox for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-tox for openSUSE:Factory 
checked in at 2016-05-17 17:13:09

Comparing /work/SRC/openSUSE:Factory/python3-tox (Old)
 and  /work/SRC/openSUSE:Factory/.python3-tox.new (New)


Package is "python3-tox"

Changes:

--- /work/SRC/openSUSE:Factory/python3-tox/python3-tox.changes  2015-12-23 
09:57:13.0 +0100
+++ /work/SRC/openSUSE:Factory/.python3-tox.new/python3-tox.changes 
2016-05-17 17:13:10.0 +0200
@@ -1,0 +2,8 @@
+Sun May  8 07:06:58 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * changed to https for source url
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-tox.spec ++
--- /var/tmp/diff_new_pack.2CgJ3b/_old  2016-05-17 17:13:11.0 +0200
+++ /var/tmp/diff_new_pack.2CgJ3b/_new  2016-05-17 17:13:11.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-tox
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,7 @@
 License:MIT
 Group:  Development/Languages/Python
 Url:https://bitbucket.org/hpk42/tox
-Source: 
http://pypi.python.org/packages/source/t/tox/tox-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/t/tox/tox-%{version}.tar.gz
 # PATCH-FIX-OPENSUSE speili...@suse.com -- Due to update-alternative usage, 
some bianries aren't available at build-time
 Patch0: tox-disable-env-tests.patch
 BuildRequires:  python3-devel




commit python3-urllib3 for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-urllib3 for openSUSE:Factory 
checked in at 2016-05-17 17:13:32

Comparing /work/SRC/openSUSE:Factory/python3-urllib3 (Old)
 and  /work/SRC/openSUSE:Factory/.python3-urllib3.new (New)


Package is "python3-urllib3"

Changes:

--- /work/SRC/openSUSE:Factory/python3-urllib3/python3-urllib3.changes  
2016-04-14 13:02:08.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-urllib3.new/python3-urllib3.changes 
2016-05-17 17:13:33.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:13:57 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-urllib3.spec ++
--- /var/tmp/diff_new_pack.3i5Dko/_old  2016-05-17 17:13:34.0 +0200
+++ /var/tmp/diff_new_pack.3i5Dko/_new  2016-05-17 17:13:34.0 +0200
@@ -23,7 +23,7 @@
 License:MIT
 Group:  Development/Languages/Python
 Url:http://urllib3.readthedocs.org/
-Source: 
https://pypi.python.org/packages/source/u/urllib3/urllib3-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/u/urllib3/urllib3-%{version}.tar.gz
 # PATCH-FIX-OPENSUSE speili...@suse.com -- We need no coverage report
 Patch1: urllib3-test-no-coverage.patch
 # PATCH-FEATURE-UPSTREAM -- use set_default_verify_paths() if no certificate 
path is supplied




commit python3-wheel for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-wheel for openSUSE:Factory 
checked in at 2016-05-17 17:13:44

Comparing /work/SRC/openSUSE:Factory/python3-wheel (Old)
 and  /work/SRC/openSUSE:Factory/.python3-wheel.new (New)


Package is "python3-wheel"

Changes:

--- /work/SRC/openSUSE:Factory/python3-wheel/python3-wheel.changes  
2016-02-18 12:35:18.0 +0100
+++ /work/SRC/openSUSE:Factory/.python3-wheel.new/python3-wheel.changes 
2016-05-17 17:13:45.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:07:31 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-wheel.spec ++
--- /var/tmp/diff_new_pack.UV0G9m/_old  2016-05-17 17:13:46.0 +0200
+++ /var/tmp/diff_new_pack.UV0G9m/_new  2016-05-17 17:13:46.0 +0200
@@ -23,7 +23,7 @@
 License:MIT
 Group:  Development/Languages/Python
 Url:https://bitbucket.org/pypa/wheel
-Source: 
https://pypi.python.org/packages/source/w/wheel/wheel-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/w/wheel/wheel-%{version}.tar.gz
 BuildRequires:  python3-devel
 BuildRequires:  python3-setuptools
 # Test requirements:




commit python3-zope.interface for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-zope.interface for 
openSUSE:Factory checked in at 2016-05-17 17:13:50

Comparing /work/SRC/openSUSE:Factory/python3-zope.interface (Old)
 and  /work/SRC/openSUSE:Factory/.python3-zope.interface.new (New)


Package is "python3-zope.interface"

Changes:

--- 
/work/SRC/openSUSE:Factory/python3-zope.interface/python3-zope.interface.changes
2015-10-14 16:44:13.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python3-zope.interface.new/python3-zope.interface.changes
   2016-05-17 17:13:52.0 +0200
@@ -1,0 +2,8 @@
+Sun May  8 07:08:00 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * changed to https for source url
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-zope.interface.spec ++
--- /var/tmp/diff_new_pack.rzx1A9/_old  2016-05-17 17:13:52.0 +0200
+++ /var/tmp/diff_new_pack.rzx1A9/_new  2016-05-17 17:13:52.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-zope.interface
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,7 @@
 Summary:Interfaces for Python
 License:ZPL-2.1
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/z/zope.interface/zope.interface-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/z/zope.interface/zope.interface-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  fdupes
 BuildRequires:  python3




commit python3-unittest2 for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-unittest2 for 
openSUSE:Factory checked in at 2016-05-17 17:13:26

Comparing /work/SRC/openSUSE:Factory/python3-unittest2 (Old)
 and  /work/SRC/openSUSE:Factory/.python3-unittest2.new (New)


Package is "python3-unittest2"

Changes:

--- /work/SRC/openSUSE:Factory/python3-unittest2/python3-unittest2.changes  
2015-10-24 10:22:43.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-unittest2.new/python3-unittest2.changes 
2016-05-17 17:13:28.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:07:17 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-unittest2.spec ++
--- /var/tmp/diff_new_pack.1Ry4IC/_old  2016-05-17 17:13:29.0 +0200
+++ /var/tmp/diff_new_pack.1Ry4IC/_new  2016-05-17 17:13:29.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-unittest2
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,7 @@
 Summary:The new features in unittest for Python 2.7 backported to 
Python 2.3+
 License:BSD-3-Clause
 Group:  Development/Languages/Python
-Source: 
https://pypi.python.org/packages/source/u/unittest2/unittest2-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/u/unittest2/unittest2-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python3-devel
 BuildRequires:  python3-linecache2




commit python3-vcversioner for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-vcversioner for 
openSUSE:Factory checked in at 2016-05-17 17:13:38

Comparing /work/SRC/openSUSE:Factory/python3-vcversioner (Old)
 and  /work/SRC/openSUSE:Factory/.python3-vcversioner.new (New)


Package is "python3-vcversioner"

Changes:

--- /work/SRC/openSUSE:Factory/python3-vcversioner/python3-vcversioner.changes  
2015-06-30 10:15:33.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python3-vcversioner.new/python3-vcversioner.changes 
2016-05-17 17:13:39.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:11:34 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-vcversioner.spec ++
--- /var/tmp/diff_new_pack.GRSry9/_old  2016-05-17 17:13:40.0 +0200
+++ /var/tmp/diff_new_pack.GRSry9/_new  2016-05-17 17:13:40.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-vcversioner
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,7 @@
 License:ISC
 Group:  Development/Languages/Python
 Url:https://github.com/habnabit/vcversioner
-Source: 
https://pypi.python.org/packages/source/v/vcversioner/vcversioner-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/v/vcversioner/vcversioner-%{version}.tar.gz
 BuildRequires:  python3-devel
 BuildRequires:  python3-setuptools
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build




commit python3-tornado for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-tornado for openSUSE:Factory 
checked in at 2016-05-17 17:13:03

Comparing /work/SRC/openSUSE:Factory/python3-tornado (Old)
 and  /work/SRC/openSUSE:Factory/.python3-tornado.new (New)


Package is "python3-tornado"

Changes:

--- /work/SRC/openSUSE:Factory/python3-tornado/python3-tornado.changes  
2015-12-01 09:17:16.0 +0100
+++ /work/SRC/openSUSE:Factory/.python3-tornado.new/python3-tornado.changes 
2016-05-17 17:13:04.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:06:56 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-tornado.spec ++
--- /var/tmp/diff_new_pack.YOUqIm/_old  2016-05-17 17:13:05.0 +0200
+++ /var/tmp/diff_new_pack.YOUqIm/_new  2016-05-17 17:13:05.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-tornado
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,7 @@
 Summary:Open source version of scalable, non-blocking web server that 
power FriendFeed
 License:Apache-2.0
 Group:  Development/Languages/Python
-Source: 
https://pypi.python.org/packages/source/t/tornado/tornado-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/t/tornado/tornado-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python3-backports_abc >= 0.4
 BuildRequires:  python3-certifi




commit python3-traceback2 for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-traceback2 for 
openSUSE:Factory checked in at 2016-05-17 17:13:15

Comparing /work/SRC/openSUSE:Factory/python3-traceback2 (Old)
 and  /work/SRC/openSUSE:Factory/.python3-traceback2.new (New)


Package is "python3-traceback2"

Changes:

--- /work/SRC/openSUSE:Factory/python3-traceback2/python3-traceback2.changes
2015-03-18 13:06:09.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python3-traceback2.new/python3-traceback2.changes   
2016-05-17 17:13:16.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:09:58 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-traceback2.spec ++
--- /var/tmp/diff_new_pack.hU9K5i/_old  2016-05-17 17:13:17.0 +0200
+++ /var/tmp/diff_new_pack.hU9K5i/_new  2016-05-17 17:13:17.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-traceback2
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,10 +23,10 @@
 License:MIT
 Group:  Development/Languages/Python
 Url:https://github.com/bitprophet/traceback2
-Source: 
https://pypi.python.org/packages/source/t/traceback2/traceback2-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/t/traceback2/traceback2-%{version}.tar.gz
 BuildRequires:  python3-devel
-BuildRequires:  python3-setuptools
 BuildRequires:  python3-pbr
+BuildRequires:  python3-setuptools
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
 




commit python3-Twisted for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-Twisted for openSUSE:Factory 
checked in at 2016-05-17 17:13:20

Comparing /work/SRC/openSUSE:Factory/python3-Twisted (Old)
 and  /work/SRC/openSUSE:Factory/.python3-Twisted.new (New)


Package is "python3-Twisted"

Changes:

--- /work/SRC/openSUSE:Factory/python3-Twisted/python3-Twisted.changes  
2016-04-28 16:50:57.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-Twisted.new/python3-Twisted.changes 
2016-05-17 17:13:21.0 +0200
@@ -1,0 +2,8 @@
+Sun May  8 07:14:16 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * changed to https for source url
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-Twisted.spec ++
--- /var/tmp/diff_new_pack.aQip24/_old  2016-05-17 17:13:22.0 +0200
+++ /var/tmp/diff_new_pack.aQip24/_new  2016-05-17 17:13:22.0 +0200
@@ -23,7 +23,7 @@
 Summary:An asynchronous networking framework written in Python
 License:MIT
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/T/Twisted/Twisted-%{version}.tar.bz2
+Source: 
https://files.pythonhosted.org/packages/source/T/Twisted/Twisted-%{version}.tar.bz2
 # PATCH-FIX-UPSTREAM -- https://twistedmatrix.com/trac/ticket/6280
 Patch0: lp1102685.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build




commit python3-snowballstemmer for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-snowballstemmer for 
openSUSE:Factory checked in at 2016-05-17 17:12:51

Comparing /work/SRC/openSUSE:Factory/python3-snowballstemmer (Old)
 and  /work/SRC/openSUSE:Factory/.python3-snowballstemmer.new (New)


Package is "python3-snowballstemmer"

Changes:

--- 
/work/SRC/openSUSE:Factory/python3-snowballstemmer/python3-snowballstemmer.changes
  2016-01-04 09:21:23.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python3-snowballstemmer.new/python3-snowballstemmer.changes
 2016-05-17 17:12:52.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:10:00 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-snowballstemmer.spec ++
--- /var/tmp/diff_new_pack.dQkers/_old  2016-05-17 17:12:53.0 +0200
+++ /var/tmp/diff_new_pack.dQkers/_new  2016-05-17 17:12:53.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-snowballstemmer
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,7 @@
 License:BSD-2-Clause
 Group:  Development/Languages/Python
 Url:https://github.com/shibukawa/snowball_py
-Source: 
https://pypi.python.org/packages/source/s/snowballstemmer/snowballstemmer-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/s/snowballstemmer/snowballstemmer-%{version}.tar.gz
 BuildRequires:  python3-devel
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch




commit python3-sphinx_rtd_theme for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-sphinx_rtd_theme for 
openSUSE:Factory checked in at 2016-05-17 17:12:56

Comparing /work/SRC/openSUSE:Factory/python3-sphinx_rtd_theme (Old)
 and  /work/SRC/openSUSE:Factory/.python3-sphinx_rtd_theme.new (New)


Package is "python3-sphinx_rtd_theme"

Changes:

--- 
/work/SRC/openSUSE:Factory/python3-sphinx_rtd_theme/python3-sphinx_rtd_theme.changes
2015-10-06 13:27:35.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python3-sphinx_rtd_theme.new/python3-sphinx_rtd_theme.changes
   2016-05-17 17:12:57.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:09:56 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-sphinx_rtd_theme.spec ++
--- /var/tmp/diff_new_pack.6fwhq3/_old  2016-05-17 17:12:57.0 +0200
+++ /var/tmp/diff_new_pack.6fwhq3/_new  2016-05-17 17:12:57.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python3-sphinx_rtd_theme
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,7 @@
 License:MIT and Apache-2.0 and OFL-1.1
 Group:  Development/Languages/Python
 Url:https://github.com/snide/sphinx_rtd_theme
-Source: 
https://pypi.python.org/packages/source/s/sphinx_rtd_theme/sphinx_rtd_theme-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/s/sphinx_rtd_theme/sphinx_rtd_theme-%{version}.tar.gz
 BuildRequires:  python3-devel
 BuildRequires:  python3-setuptools
 Recommends: python3-Sphinx




commit python3-six for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-six for openSUSE:Factory 
checked in at 2016-05-17 17:12:38

Comparing /work/SRC/openSUSE:Factory/python3-six (Old)
 and  /work/SRC/openSUSE:Factory/.python3-six.new (New)


Package is "python3-six"

Changes:

--- /work/SRC/openSUSE:Factory/python3-six/python3-six-doc.changes  
2016-01-23 01:04:05.0 +0100
+++ /work/SRC/openSUSE:Factory/.python3-six.new/python3-six-doc.changes 
2016-05-17 17:12:40.0 +0200
@@ -1,0 +2,8 @@
+Sun May  8 07:06:21 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * changed to https for source url
+  * updated source url to files.pythonhosted.org
+
+
+---
--- /work/SRC/openSUSE:Factory/python3-six/python3-six.changes  2016-01-30 
11:31:31.0 +0100
+++ /work/SRC/openSUSE:Factory/.python3-six.new/python3-six.changes 
2016-05-17 17:12:40.0 +0200
@@ -1,0 +2,8 @@
+Sun May  8 07:06:19 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * changed to https for source url
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-six.spec ++
--- /var/tmp/diff_new_pack.2PXoqo/_old  2016-05-17 17:12:41.0 +0200
+++ /var/tmp/diff_new_pack.2PXoqo/_new  2016-05-17 17:12:41.0 +0200
@@ -23,7 +23,7 @@
 Summary:Python 2 and 3 compatibility utilities
 License:MIT
 Group:  Development/Libraries/Python
-Source: 
http://pypi.python.org/packages/source/s/six/six-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/s/six/six-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python3-devel
 BuildArch:  noarch




commit python3-requests for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-requests for 
openSUSE:Factory checked in at 2016-05-17 17:12:27

Comparing /work/SRC/openSUSE:Factory/python3-requests (Old)
 and  /work/SRC/openSUSE:Factory/.python3-requests.new (New)


Package is "python3-requests"

Changes:

--- /work/SRC/openSUSE:Factory/python3-requests/python3-requests.changes
2016-03-26 15:08:26.0 +0100
+++ /work/SRC/openSUSE:Factory/.python3-requests.new/python3-requests.changes   
2016-05-17 17:12:28.0 +0200
@@ -1,0 +2,8 @@
+Sun May  8 07:05:52 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * changed to https for source url
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-requests.spec ++
--- /var/tmp/diff_new_pack.tBysJe/_old  2016-05-17 17:12:29.0 +0200
+++ /var/tmp/diff_new_pack.tBysJe/_new  2016-05-17 17:12:29.0 +0200
@@ -25,7 +25,7 @@
 License:Apache-2.0
 Group:  Development/Languages/Python
 Url:http://python-requests.org/
-Source: 
http://pypi.python.org/packages/source/r/requests/requests-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/r/requests/requests-%{version}.tar.gz
 Source100:  PACKAGING_NOTES
 Source101:  set_urllib3_version.sh
 # PATCH-FIX-OPENSUSE no-default-cacert.patch -- Completely ignore the internal 
CA bundle.




commit python3-pytz for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-pytz for openSUSE:Factory 
checked in at 2016-05-17 17:12:21

Comparing /work/SRC/openSUSE:Factory/python3-pytz (Old)
 and  /work/SRC/openSUSE:Factory/.python3-pytz.new (New)


Package is "python3-pytz"

Changes:

--- /work/SRC/openSUSE:Factory/python3-pytz/python3-pytz.changes
2016-03-29 09:51:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-pytz.new/python3-pytz.changes   
2016-05-17 17:12:22.0 +0200
@@ -1,0 +2,18 @@
+Sun May  8 07:05:37 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * changed to https for source url
+  * updated source url to files.pythonhosted.org
+
+
+---
+Sun Apr 24 14:13:52 UTC 2016 - a...@gmx.de
+
+- update to version 2016.4:
+  * Fix old example insisting normalize() is necessary after
+astimezone() conversion
+  * Update Makefile for xenial container
+  * Import 2016d
+  * development container setup cheat sheet
+
+---

Old:

  pytz-2016.3.tar.bz2

New:

  pytz-2016.4.tar.bz2



Other differences:
--
++ python3-pytz.spec ++
--- /var/tmp/diff_new_pack.EZpzD1/_old  2016-05-17 17:12:23.0 +0200
+++ /var/tmp/diff_new_pack.EZpzD1/_new  2016-05-17 17:12:23.0 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   python3-pytz
-Version:2016.3
+Version:2016.4
 Release:0
 Url:http://pytz.sourceforge.net
 Summary:World timezone definitions, modern and historical
 License:MIT
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/p/pytz/pytz-%{version}.tar.bz2
+Source: 
https://files.pythonhosted.org/packages/source/p/pytz/pytz-%{version}.tar.bz2
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  fdupes
 BuildRequires:  python3

++ pytz-2016.3.tar.bz2 -> pytz-2016.4.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pytz-2016.3/PKG-INFO new/pytz-2016.4/PKG-INFO
--- old/pytz-2016.3/PKG-INFO2016-03-24 07:07:11.0 +0100
+++ new/pytz-2016.4/PKG-INFO2016-04-22 15:11:10.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: pytz
-Version: 2016.3
+Version: 2016.4
 Summary: World timezone definitions, modern and historical
 Home-page: http://pythonhosted.org/pytz
 Author: Stuart Bishop
@@ -143,19 +143,21 @@
 >>> dt2.strftime(fmt)
 '2002-10-27 01:30:00 EST-0500'
 
-Converting between timezones also needs special attention. We also need
-to use the ``normalize()`` method to ensure the conversion is correct.
+Converting between timezones is more easily done, using the
+standard astimezone method.
 
 >>> utc_dt = utc.localize(datetime.utcfromtimestamp(1143408899))
 >>> utc_dt.strftime(fmt)
 '2006-03-26 21:34:59 UTC+'
 >>> au_tz = timezone('Australia/Sydney')
->>> au_dt = au_tz.normalize(utc_dt.astimezone(au_tz))
+>>> au_dt = utc_dt.astimezone(au_tz)
 >>> au_dt.strftime(fmt)
 '2006-03-27 08:34:59 AEDT+1100'
->>> utc_dt2 = utc.normalize(au_dt.astimezone(utc))
+>>> utc_dt2 = au_dt.astimezone(utc)
 >>> utc_dt2.strftime(fmt)
 '2006-03-26 21:34:59 UTC+'
+>>> utc_dt == utc_dt2
+True
 
 You can take shortcuts when dealing with the UTC side of timezone
 conversions. ``normalize()`` and ``localize()`` are not really
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pytz-2016.3/README.txt new/pytz-2016.4/README.txt
--- old/pytz-2016.3/README.txt  2016-03-24 07:06:58.0 +0100
+++ new/pytz-2016.4/README.txt  2016-04-22 14:58:11.0 +0200
@@ -134,19 +134,21 @@
 >>> dt2.strftime(fmt)
 '2002-10-27 01:30:00 EST-0500'
 
-Converting between timezones also needs special attention. We also need
-to use the ``normalize()`` method to ensure the conversion is correct.
+Converting between timezones is more easily done, using the
+standard astimezone method.
 
 >>> utc_dt = utc.localize(datetime.utcfromtimestamp(1143408899))
 >>> utc_dt.strftime(fmt)
 '2006-03-26 21:34:59 UTC+'
 >>> au_tz = timezone('Australia/Sydney')
->>> au_dt = au_tz.normalize(utc_dt.astimezone(au_tz))
+>>> au_dt = utc_dt.astimezone(au_tz)
 >>> au_dt.strftime(fmt)
 '2006-03-27 08:34:59 AEDT+1100'
->>> utc_dt2 = utc.normalize(au_dt.astimezone(utc))
+>>> utc_dt2 = au_dt.astimezone(utc)
 >>> utc_dt2.strftime(fmt)
 '2006-03-26 21:34:59 UTC+'
+>>> utc_dt == utc_dt2
+True
 
 You can take shortcuts when 

commit python3-pycurl for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-pycurl for openSUSE:Factory 
checked in at 2016-05-17 17:11:54

Comparing /work/SRC/openSUSE:Factory/python3-pycurl (Old)
 and  /work/SRC/openSUSE:Factory/.python3-pycurl.new (New)


Package is "python3-pycurl"

Changes:

--- /work/SRC/openSUSE:Factory/python3-pycurl/python3-pycurl.changes
2016-05-03 09:33:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-pycurl.new/python3-pycurl.changes   
2016-05-17 17:11:56.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:04:44 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-pycurl.spec ++
--- /var/tmp/diff_new_pack.34zoMW/_old  2016-05-17 17:11:57.0 +0200
+++ /var/tmp/diff_new_pack.34zoMW/_new  2016-05-17 17:11:57.0 +0200
@@ -23,7 +23,7 @@
 License:LGPL-2.1+ and MIT
 Group:  Development/Languages/Python
 Url:http://pycurl.sourceforge.net/
-Source: 
https://pypi.python.org/packages/source/p/pycurl/pycurl-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/p/pycurl/pycurl-%{version}.tar.gz
 # PATCH-FIX-UPSTREAM remove __DATE__ and __TIME__
 Patch0: pycurl-7.19.5-no-runtime-curlvercheck.patch
 BuildRequires:  libcurl-devel >= 7.19.0




commit python3-pytest-cov for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-pytest-cov for 
openSUSE:Factory checked in at 2016-05-17 17:12:15

Comparing /work/SRC/openSUSE:Factory/python3-pytest-cov (Old)
 and  /work/SRC/openSUSE:Factory/.python3-pytest-cov.new (New)


Package is "python3-pytest-cov"

Changes:

--- /work/SRC/openSUSE:Factory/python3-pytest-cov/python3-pytest-cov.changes
2016-02-05 00:30:49.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python3-pytest-cov.new/python3-pytest-cov.changes   
2016-05-17 17:12:16.0 +0200
@@ -1,0 +2,7 @@
+Sun May  8 07:05:23 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-pytest-cov.spec ++
--- /var/tmp/diff_new_pack.2fX1Ll/_old  2016-05-17 17:12:16.0 +0200
+++ /var/tmp/diff_new_pack.2fX1Ll/_new  2016-05-17 17:12:16.0 +0200
@@ -23,7 +23,7 @@
 License:MIT
 Group:  Development/Languages/Python
 Url:https://github.com/schlamar/pytest-cov
-Source: 
https://pypi.python.org/packages/source/p/pytest-cov/pytest-cov-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/p/pytest-cov/pytest-cov-%{version}.tar.gz
 BuildRequires:  python3-cov-core >= 1.14
 BuildRequires:  python3-devel
 BuildRequires:  python3-pytest >= 2.2.3




commit python3-pyserial for openSUSE:Factory

2016-05-17 Thread h_root
Hello community,

here is the log from the commit of package python3-pyserial for 
openSUSE:Factory checked in at 2016-05-17 17:12:01

Comparing /work/SRC/openSUSE:Factory/python3-pyserial (Old)
 and  /work/SRC/openSUSE:Factory/.python3-pyserial.new (New)


Package is "python3-pyserial"

Changes:

--- /work/SRC/openSUSE:Factory/python3-pyserial/python3-pyserial.changes
2016-01-13 22:43:07.0 +0100
+++ /work/SRC/openSUSE:Factory/.python3-pyserial.new/python3-pyserial.changes   
2016-05-17 17:12:02.0 +0200
@@ -1,0 +2,8 @@
+Sun May  8 07:05:15 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * changed to https for source url
+  * updated source url to files.pythonhosted.org
+
+
+---



Other differences:
--
++ python3-pyserial.spec ++
--- /var/tmp/diff_new_pack.NRZ3tl/_old  2016-05-17 17:12:03.0 +0200
+++ /var/tmp/diff_new_pack.NRZ3tl/_new  2016-05-17 17:12:03.0 +0200
@@ -23,7 +23,7 @@
 Summary:Python Serial Port Extension
 License:Python-2.0
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/p/pyserial/pyserial-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/p/pyserial/pyserial-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  python3
 BuildRequires:  python3-2to3




  1   2   >