commit go for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package go for openSUSE:Factory checked in 
at 2016-06-19 13:54:11

Comparing /work/SRC/openSUSE:Factory/go (Old)
 and  /work/SRC/openSUSE:Factory/.go.new (New)


Package is "go"

Changes:

--- /work/SRC/openSUSE:Factory/go/go.changes2016-06-12 18:55:29.0 
+0200
+++ /work/SRC/openSUSE:Factory/.go.new/go.changes   2016-06-19 
13:54:13.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 01:52:50 UTC 2016 - i...@marguerite.su
+
+- install shared libraries.
+
+---



Other differences:
--
++ go.spec ++
--- /var/tmp/diff_new_pack.SAspSt/_old  2016-06-19 13:54:14.0 +0200
+++ /var/tmp/diff_new_pack.SAspSt/_new  2016-06-19 13:54:14.0 +0200
@@ -27,6 +27,23 @@
 %endif
 
 %define go_api 1.6
+
+# shared library support
+%define shared_supported %(echo "%{go_api} >= 1.5" | bc -l)
+%if %{shared_supported}
+%if %{with_gccgo}
+%define with_shared 1
+%else
+%ifarch %ix86 %arm x86_64 aarch64
+%define with_shared 1
+%else
+%define with_shared 0
+%endif
+%endif
+%else
+%define with_shared 0
+%endif
+
 Name:   go
 Version:1.6.2
 Release:0
@@ -77,6 +94,7 @@
 BuildRequires:  rpm >= 4.11.1
 %endif
 %endif
+BuildRequires:  bc
 # for go.gdbinit, directory ownership
 BuildRequires:  gdb
 Requires(post):update-alternatives
@@ -161,7 +179,10 @@
 %ifarch x86_64
 # Install race detection version of std libraries (amd64 only)
 bin/go install -race std
-bin/go install -buildmode=shared std
+%endif
+ 
+%if %{with_shared}
+bin/go install -buildmode=shared -linkshared std
 %endif
 
 %install




commit fcitx-unikey for openSUSE:Factory

2016-06-19 Thread h_root


binR1jROljAOh.bin
Description: Binary data


commit zeromq for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package zeromq for openSUSE:Factory checked 
in at 2016-06-19 13:54:17

Comparing /work/SRC/openSUSE:Factory/zeromq (Old)
 and  /work/SRC/openSUSE:Factory/.zeromq.new (New)


Package is "zeromq"

Changes:

--- /work/SRC/openSUSE:Factory/zeromq/zeromq.changes2016-06-02 
09:38:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.zeromq.new/zeromq.changes   2016-06-19 
13:54:19.0 +0200
@@ -1,0 +2,12 @@
+Fri Jun 17 12:41:46 UTC 2016 - adam.ma...@suse.de
+
+- New upstream version 4.1.5
+  * Fixed #1806 - uninitialised read in curve getsockopt.
+  * Fixed #1807 - build broken with GCC 6.
+  * Fixed #1831 - potential assertion failure with latest libsodium.
+  * Fixed #1850 - detection issues with tweetnacl/libsodium.
+  * Fixed #1877 - Avoid terminating connections prematurely
+  * fixes some IPv6 related issues
+- Removed 3ad076.patch, upstreamed
+
+---

Old:

  3ad076.patch
  zeromq-4.1.4.tar.gz

New:

  zeromq-4.1.5.tar.gz



Other differences:
--
++ zeromq.spec ++
--- /var/tmp/diff_new_pack.xHLKJZ/_old  2016-06-19 13:54:20.0 +0200
+++ /var/tmp/diff_new_pack.xHLKJZ/_new  2016-06-19 13:54:20.0 +0200
@@ -21,14 +21,13 @@
 %define with_pgm 1
 %endif
 Name:   zeromq
-Version:4.1.4
+Version:4.1.5
 Release:0
 Summary:Lightweight messaging kernel
 License:LGPL-3.0+
 Group:  Productivity/Networking/Web/Servers
 Url:http://www.zeromq.org/
-Source: http://download.zeromq.org/%{name}-%{version}.tar.gz
-Patch:  3ad076.patch
+Source: 
https://github.com/zeromq/zeromq4-1/releases/download/v%{version}/zeromq-%{version}.tar.gz
 BuildRequires:  asciidoc
 BuildRequires:  gcc-c++
 BuildRequires:  pkgconfig
@@ -110,7 +109,6 @@
 
 %prep
 %setup -q
-%patch -p1
 
 %build
 %configure \

++ zeromq-4.1.4.tar.gz -> zeromq-4.1.5.tar.gz ++
 129014 lines of diff (skipped)




commit gnucap for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package gnucap for openSUSE:Factory checked 
in at 2016-06-19 13:54:13

Comparing /work/SRC/openSUSE:Factory/gnucap (Old)
 and  /work/SRC/openSUSE:Factory/.gnucap.new (New)


Package is "gnucap"

Changes:

--- /work/SRC/openSUSE:Factory/gnucap/gnucap.changes2012-07-02 
10:52:08.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnucap.new/gnucap.changes   2016-06-19 
13:54:14.0 +0200
@@ -1,0 +2,6 @@
+Fri Jun 17 06:46:39 UTC 2016 - dmitr...@opensuse.org
+
+- Fix build with GCC 6 [boo#985099]
+  * gnucap-0.35-gcc6.patch
+
+---

New:

  gnucap-0.35-gcc6.patch



Other differences:
--
++ gnucap.spec ++
--- /var/tmp/diff_new_pack.9sIn99/_old  2016-06-19 13:54:15.0 +0200
+++ /var/tmp/diff_new_pack.9sIn99/_new  2016-06-19 13:54:15.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gnucap
 #
-# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,13 +15,14 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   gnucap
 Version:0.35
-Release:10
-License:GPL-2.0+
+Release:0
 Summary:Gnu Circuit Analysis Package
-Url:http://www.gnu.org/software/gnucap/
+License:GPL-2.0+
 Group:  Productivity/Scientific/Electronics
+Url:http://www.gnu.org/software/gnucap/
 Source: %{name}-%{version}.tar.bz2
 Source1:gnucap-modelgen.1
 # PATCH-FIX-UPSTREAM -- fix build with GCC 4.3
@@ -32,6 +33,8 @@
 Patch3: gnucap-docpath.patch
 # PATCH-FIX-OPENSUSE -- from Debian: add shebang, and explicitly call gnucap
 Patch4: gnucap-fix_runall.patch
+# PATCH-FIX-UPSTREAM -- Fix build with GCC 6
+Patch5: gnucap-0.35-gcc6.patch
 BuildRequires:  gcc-c++
 BuildRequires:  libpng-devel
 BuildRequires:  ncurses-devel
@@ -72,6 +75,7 @@
 %patch2 -p1
 %patch3 -p0
 %patch4 -p0
+%patch5 -p1
 rm INSTALL
 
 %build

++ gnucap-0.35-gcc6.patch ++
diff -up gnucap-0.35/src/plot.cc~ gnucap-0.35/src/plot.cc
--- gnucap-0.35/src/plot.cc~2016-04-26 09:16:25.0 +0200
+++ gnucap-0.35/src/plot.cc 2016-04-26 09:18:43.392162278 +0200
@@ -231,9 +231,9 @@ static void plotarg(
double yhi,
double zhi)
 {
-  auto char adata[MAXWIDTH+1]; /* actual data. copy emptydata, insert */
+  char adata[MAXWIDTH+1]; /* actual data. copy emptydata, insert */
   char *xxs;/* string representation of xx */
-  memcpy(adata, emptydata, MAXWIDTH); /* copy prototype */
+  memcpy(adata, emptydata, MAXWIDTH + 1); /* copy prototype */
   xxs = ftos( xx, 11, 5, IO::formaat );
   if (zz != NOT_VALID) {
 adata[point(zz,zlo,zhi,CONSSCALE,0,1)] = '+';/* zap data into string */



commit numix-gtk-theme for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package numix-gtk-theme for openSUSE:Factory 
checked in at 2016-06-19 13:54:20

Comparing /work/SRC/openSUSE:Factory/numix-gtk-theme (Old)
 and  /work/SRC/openSUSE:Factory/.numix-gtk-theme.new (New)


Package is "numix-gtk-theme"

Changes:

--- /work/SRC/openSUSE:Factory/numix-gtk-theme/numix-gtk-theme.changes  
2016-06-14 23:07:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.numix-gtk-theme.new/numix-gtk-theme.changes 
2016-06-19 13:54:21.0 +0200
@@ -1,0 +2,6 @@
+Fri Jun 17 15:43:19 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 2.6.0:
+  * No changelog available.
+
+---

Old:

  numix-gtk-theme-2.5.1+git20160610.tar.gz

New:

  numix-gtk-theme-2.6.0.tar.gz



Other differences:
--
++ numix-gtk-theme.spec ++
--- /var/tmp/diff_new_pack.iSsYkp/_old  2016-06-19 13:54:22.0 +0200
+++ /var/tmp/diff_new_pack.iSsYkp/_new  2016-06-19 13:54:22.0 +0200
@@ -19,13 +19,13 @@
 %define _theme  Numix
 %define _name   numix
 Name:   numix-gtk-theme
-Version:2.5.1+git20160610
+Version:2.6.0
 Release:0
 Summary:Numix GTK+ theme for MATE, GNOME, and Xfce
 License:GPL-3.0+
 Group:  System/GUI/Other
 Url:https://numixproject.org/
-Source: %{name}-%{version}.tar.gz
+Source: 
https://github.com/numixproject/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
 # PATCH-FIX-OPENSUSE numix-gtk-theme-light-menubars.patch sor.ale...@meowr.ru 
-- Make light menus (Gtk2), dark menus are buggy in Qt4 QGtkStyle.
 Patch0: %{name}-light-menubars.patch
 BuildRequires:  fdupes

++ numix-gtk-theme-2.5.1+git20160610.tar.gz -> numix-gtk-theme-2.6.0.tar.gz 
++




commit scantailor for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package scantailor for openSUSE:Factory 
checked in at 2016-06-19 13:54:09

Comparing /work/SRC/openSUSE:Factory/scantailor (Old)
 and  /work/SRC/openSUSE:Factory/.scantailor.new (New)


Package is "scantailor"

Changes:

--- /work/SRC/openSUSE:Factory/scantailor/scantailor.changes2016-02-26 
00:44:55.0 +0100
+++ /work/SRC/openSUSE:Factory/.scantailor.new/scantailor.changes   
2016-06-19 13:54:11.0 +0200
@@ -1,0 +2,7 @@
+Fri Jun 17 06:10:12 UTC 2016 - dmitr...@opensuse.org
+
+- Update to version 0.9.12.2 [boo#985096]
+  * Bugfix release
+  * Drop obsolete scantailor-boost-1.60.patch
+
+---

Old:

  scantailor-0.9.11.1.tar.gz
  scantailor-boost-1.60.patch

New:

  scantailor-0.9.12.2.tar.gz



Other differences:
--
++ scantailor.spec ++
--- /var/tmp/diff_new_pack.isE0aE/_old  2016-06-19 13:54:12.0 +0200
+++ /var/tmp/diff_new_pack.isE0aE/_new  2016-06-19 13:54:12.0 +0200
@@ -17,16 +17,15 @@
 
 
 Name:   scantailor
-Version:0.9.11.1
+Version:0.9.12.2
 Release:0
+%define src_ver 0_9_12_2
 Summary:Interactive post-processing tool for scanned pages
 License:GPL-3.0+
 Group:  Productivity/Graphics/Other
 Url:http://scantailor.sourceforge.net/
-Source0:
http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
+Source0:
https://github.com/%{name}/%{name}/archive/RELEASE_%{src_ver}.tar.gz#/%{name}-%{version}.tar.gz
 Source1:%{name}-icons.tar.bz2
-# PATCH-FIX-UPSTREAM scantailor-boost-1.60.patch -- Fix build with new boost
-Patch1: scantailor-boost-1.60.patch
 BuildRequires:  boost-devel >= 1.42
 BuildRequires:  cmake
 BuildRequires:  hicolor-icon-theme
@@ -53,8 +52,7 @@
 This package provides command line version of scantailor.
 
 %prep
-%setup -q -a 1
-%patch1 -p1
+%setup -q -a 1 -n %{name}-RELEASE_%{src_ver}
 cp -p resources/icons/{COPYING,COPYING.icons}
 
 %build

++ scantailor-0.9.11.1.tar.gz -> scantailor-0.9.12.2.tar.gz ++
 17582 lines of diff (skipped)




commit chromium for openSUSE:13.2:Update

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package chromium for openSUSE:13.2:Update 
checked in at 2016-06-19 13:07:07

Comparing /work/SRC/openSUSE:13.2:Update/chromium (Old)
 and  /work/SRC/openSUSE:13.2:Update/.chromium.new (New)


Package is "chromium"

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.hu8XfH/_old  2016-06-19 13:07:15.0 +0200
+++ /var/tmp/diff_new_pack.hu8XfH/_new  2016-06-19 13:07:15.0 +0200
@@ -1 +1 @@
-
+




commit chromium for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package chromium for openSUSE:Factory 
checked in at 2016-06-19 12:53:16

Comparing /work/SRC/openSUSE:Factory/chromium (Old)
 and  /work/SRC/openSUSE:Factory/.chromium.new (New)


Package is "chromium"

Changes:

--- /work/SRC/openSUSE:Factory/chromium/chromium.changes2016-06-03 
16:39:01.0 +0200
+++ /work/SRC/openSUSE:Factory/.chromium.new/chromium.changes   2016-06-19 
12:53:33.0 +0200
@@ -1,0 +2,14 @@
+Fri Jun 17 11:11:46 UTC 2016 - astie...@suse.com
+
+- Update to Chromium 51.0.2704.103
+  * Security fixes:
+  - CVE-2016-1704: Various fixes from internal audits, fuzzing and
+   other initiatives (boo#985397)
+
+---
+Tue Jun  7 12:15:02 UTC 2016 - tittiatc...@gmail.com
+
+- Update to Chromium 51.0.2704.84
+  * No further changelog
+
+---

Old:

  chromium-51.0.2704.79.tar.xz

New:

  chromium-51.0.2704.103.tar.xz



Other differences:
--
++ chromium.spec ++
--- /var/tmp/diff_new_pack.gouQ6R/_old  2016-06-19 12:53:47.0 +0200
+++ /var/tmp/diff_new_pack.gouQ6R/_new  2016-06-19 12:53:47.0 +0200
@@ -18,7 +18,7 @@
 
 %define chromium_no_dlopen 1
 Name:   chromium
-Version:51.0.2704.79
+Version:51.0.2704.103
 Release:0
 Summary:Google's opens source browser project
 License:BSD-3-Clause and LGPL-2.1+

++ _constraints ++
--- /var/tmp/diff_new_pack.gouQ6R/_old  2016-06-19 12:53:47.0 +0200
+++ /var/tmp/diff_new_pack.gouQ6R/_new  2016-06-19 12:53:47.0 +0200
@@ -3,7 +3,7 @@
   
 
 
-   23000
+   15000
 
 
   6000

++ chromium-51.0.2704.79.tar.xz -> chromium-51.0.2704.103.tar.xz ++
/work/SRC/openSUSE:Factory/chromium/chromium-51.0.2704.79.tar.xz 
/work/SRC/openSUSE:Factory/.chromium.new/chromium-51.0.2704.103.tar.xz differ: 
char 26, line 1





commit nmon for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package nmon for openSUSE:Factory checked in 
at 2016-06-19 12:53:20

Comparing /work/SRC/openSUSE:Factory/nmon (Old)
 and  /work/SRC/openSUSE:Factory/.nmon.new (New)


Package is "nmon"

Changes:

--- /work/SRC/openSUSE:Factory/nmon/nmon.changes2016-04-12 
19:36:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.nmon.new/nmon.changes   2016-06-19 
12:53:49.0 +0200
@@ -1,0 +2,6 @@
+Sat Jun 18 18:42:06 UTC 2016 - mplus...@suse.com
+
+- Update to version 16f (boo#985538):
+  * Minor changed to the on-screen view only.
+
+---

Old:

  lmon16e.c

New:

  lmon16f.c



Other differences:
--
++ nmon.spec ++
--- /var/tmp/diff_new_pack.WncP8M/_old  2016-06-19 12:53:50.0 +0200
+++ /var/tmp/diff_new_pack.WncP8M/_new  2016-06-19 12:53:50.0 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   nmon
-Version:16e
+Version:16f
 Release:0
 Summary:Performance Monitor
 License:GPL-3.0
@@ -81,6 +81,8 @@
 install -d %{buildroot}%{_mandir}/man1
 help2man \
   --help-option=-h \
+  --no-info \
+  --no-discard-stderr \
   --name="Performance Monitor" \
   --version-string=%{version} \
   ./nmon > %{buildroot}%{_mandir}/man1/nmon.1

++ lmon16f.c ++
 8726 lines (skipped)




commit bonnie++ for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package bonnie++ for openSUSE:Factory 
checked in at 2016-06-19 12:53:23

Comparing /work/SRC/openSUSE:Factory/bonnie++ (Old)
 and  /work/SRC/openSUSE:Factory/.bonnie++.new (New)


Package is "bonnie++"

Changes:

--- /work/SRC/openSUSE:Factory/bonnie++/bonnie++.changes2014-10-18 
09:10:23.0 +0200
+++ /work/SRC/openSUSE:Factory/.bonnie++.new/bonnie++.changes   2016-06-19 
12:53:52.0 +0200
@@ -1,0 +2,9 @@
+Sun Jun 19 08:09:29 UTC 2016 - mplus...@suse.com
+
+- Cleanup spec file with spec-cleaner
+- Use configure and make install
+- Add patches (both from Fedora):
+  * bonnie++-1.96-minmax.patch (building with gcc6 - boo#985139)
+  * bonnie++-1.96-makefile.patch (fixes installation using make)
+
+---

New:

  bonnie++-1.96-makefile.patch
  bonnie++-1.96-minmax.patch



Other differences:
--
++ bonnie++.spec ++
--- /var/tmp/diff_new_pack.PD62t8/_old  2016-06-19 12:53:53.0 +0200
+++ /var/tmp/diff_new_pack.PD62t8/_new  2016-06-19 12:53:53.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package bonnie++
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,6 +24,10 @@
 Group:  System/Benchmark
 Url:http://www.coker.com.au/bonnie++/
 Source: 
http://www.coker.com.au/bonnie++/experimental/%{name}-%{version}.tgz
+# PATCH-FIX-UPSTREAM bonnie++-1.96-makefile.patch -- fixes make install
+Patch0: bonnie++-1.96-makefile.patch
+# PATCH-FIX-UPSTREAM bonnie++-1.96-minmax.patch -- fixes building with gcc6 
(boo#985139)
+Patch1: bonnie++-1.96-minmax.patch
 BuildRequires:  gcc-c++
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
@@ -34,29 +38,33 @@
 %prep
 # match the upstream tarball, there's no diff against 1.97
 %setup -q -n bonnie++-1.97.1
+%patch0
+%patch1
 
 %build
+%configure \
+  --disable-stripping
 make clean %{?_smp_mflags}
-make MORECFLAGS="%{optflags}" %{?_smp_mflags}
+make MORECFLAGS="%{optflags}" LINK="g++ -Wl,--as-needed -Wl,--no-undefined 
-Wl,-z,now" %{?_smp_mflags}
 
 %install
-mkdir -p %{buildroot}%{_prefix}/bin
-%{_bindir}/install -c bonnie++ zcav %{buildroot}%{_prefix}/bin
-%{_bindir}/install -c bon_csv2html bon_csv2txt %{buildroot}%{_prefix}/bin
-mkdir -p %{buildroot}%{_mandir}/man{1,8}
-%{_bindir}/install -c -m 644 bon_csv2html.1 bon_csv2txt.1 
%{buildroot}%{_mandir}/man1
-%{_bindir}/install -c -m 644 bonnie++.8 zcav.8 %{buildroot}%{_mandir}/man8
+%make_install
 
 %files
 %defattr(-,root,root)
-%doc readme.html
-%{_bindir}/bonnie++
-%{_bindir}/zcav
+%doc README-2.00 README.txt
 %{_bindir}/bon_csv2html
 %{_bindir}/bon_csv2txt
-%{_mandir}/man8/bonnie++.8.gz
-%{_mandir}/man8/zcav.8.gz
-%{_mandir}/man1/bon_csv2html.1.gz
-%{_mandir}/man1/bon_csv2txt.1.gz
+%{_bindir}/generate_randfile
+%{_sbindir}/bonnie++
+%{_sbindir}/getc_putc
+%{_sbindir}/getc_putc_helper
+%{_sbindir}/zcav
+%{_mandir}/man1/bon_csv2html.1%{ext_man}
+%{_mandir}/man1/bon_csv2txt.1%{ext_man}
+%{_mandir}/man1/generate_randfile.1%{ext_man}
+%{_mandir}/man8/bonnie++.8%{ext_man}
+%{_mandir}/man8/getc_putc.8%{ext_man}
+%{_mandir}/man8/zcav.8%{ext_man}
 
 %changelog

++ bonnie++-1.96-makefile.patch ++
Index: Makefile.in
===
--- Makefile.in.orig2008-12-30 22:04:25.0 +0100
+++ Makefile.in 2016-06-19 10:00:30.009151497 +0200
@@ -17,6 +17,8 @@ THREAD_LFLAGS=@thread_ldflags@
 INSTALL=@INSTALL@
 INSTALL_PROGRAM=@INSTALL_PROGRAM@
 
+DESTDIR=
+
 BONSRC=bonnie++.cpp bon_io.cpp bon_file.cpp bon_time.cpp semaphore.cpp \
  sync.cpp thread.cpp bon_suid.cpp duration.cpp rand.o util.o
 BONOBJS=$(BONSRC:.cpp=.o)
@@ -52,15 +54,15 @@ generate_randfile: generate_randfile.o
$(LINK) generate_randfile.o -o generate_randfile
 
 install-bin: $(EXE) $(EXES)
-   mkdir -p $(eprefix)/bin $(eprefix)/sbin
-   @INSTALL_PROGRAM@ @stripping@ $(EXES) $(eprefix)/sbin
-   @INSTALL_PROGRAM@ @stripping@ $(EXE) $(eprefix)/bin
-   @INSTALL_SCRIPT@ $(SCRIPTS) $(eprefix)/bin
+   mkdir -p $(DESTDIR)$(eprefix)/bin $(DESTDIR)$(eprefix)/sbin
+   @INSTALL_PROGRAM@ @stripping@ $(EXES) $(DESTDIR)$(eprefix)/sbin
+   @INSTALL_PROGRAM@ @stripping@ $(EXE) $(DESTDIR)$(eprefix)/bin
+   @INSTALL_SCRIPT@ $(SCRIPTS) $(DESTDIR)$(eprefix)/bin
 
 install: install-bin
-   mkdir -p @mandir@/man1 @mandir@/man8
-   @INSTALL_DATA@ $(MAN1) @mandir@/man1
-   @INSTALL_DATA@ $(MAN8) @mandir@/man8
+

commit OpenImageIO for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package OpenImageIO for openSUSE:Factory 
checked in at 2016-06-19 12:53:07

Comparing /work/SRC/openSUSE:Factory/OpenImageIO (Old)
 and  /work/SRC/openSUSE:Factory/.OpenImageIO.new (New)


Package is "OpenImageIO"

Changes:

--- /work/SRC/openSUSE:Factory/OpenImageIO/OpenImageIO.changes  2016-03-29 
09:56:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.OpenImageIO.new/OpenImageIO.changes 
2016-06-19 12:53:08.0 +0200
@@ -1,0 +2,14 @@
+Fri Jun 17 15:11:15 UTC 2016 - norm...@linux.vnet.ibm.com
+
+- Added oiio_gcc6_missleading_indentation.patch tracked upstream
+  https://github.com/OpenImageIO/oiio/pull/1436
+  and remove just added flag. See boo#985370
+- Removed previous work around for the bug.
+
+---
+Fri Jun 17 14:57:11 UTC 2016 - davejpla...@gmail.com
+
+- Fix gcc6 build with -Wno-error=misleading-indentation flag, see
+  boo#985370
+
+---

New:

  oiio_gcc6_missleading_indentation.patch



Other differences:
--
++ OpenImageIO.spec ++
--- /var/tmp/diff_new_pack.Lck3a3/_old  2016-06-19 12:53:09.0 +0200
+++ /var/tmp/diff_new_pack.Lck3a3/_new  2016-06-19 12:53:09.0 +0200
@@ -28,6 +28,7 @@
 Source0:oiio-Release-%{version}.tar.bz2
 Patch0: oiio-clusterfit-boundscheck.patch
 Patch1: oiio-detectplatform-others.patch
+Patch2: oiio_gcc6_missleading_indentation.patch
 # NOTE: Please don't uncomment a build requirement unless you have submitted 
the package to factory and it exists
 #BuildRequires:  Field3D-devel
 BuildRequires:  OpenColorIO-devel
@@ -122,6 +123,7 @@
 %setup -q -n oiio-Release-%{version}
 %patch0
 %patch1
+%patch2 -p1
 
 # Make sure that bundled libraries are not used
 rm -f src/include/pugiconfig.hpp \

++ oiio_gcc6_missleading_indentation.patch ++
---
 src/dpx.imageio/libdpx/Writer.cpp |   16 
 1 file changed, 8 insertions(+), 8 deletions(-)

Index: oiio-Release-1.7.0dev/src/dpx.imageio/libdpx/Writer.cpp
===
--- oiio-Release-1.7.0dev.orig/src/dpx.imageio/libdpx/Writer.cpp
+++ oiio-Release-1.7.0dev/src/dpx.imageio/libdpx/Writer.cpp
@@ -208,12 +208,12 @@ bool dpx::Writer::WriteElement(const int
 if (! this->WritePadData(0x2000))
 return false;
 
-   // update file ptr
-   this->header.SetDataOffset(element, this->fileLoc);
-   this->fileLoc += count;
-   
-   // write
-   return (this->fd->Write(data, count) > 0);
+// update file ptr
+this->header.SetDataOffset(element, this->fileLoc);
+this->fileLoc += count;
+
+// write
+return (this->fd->Write(data, count) > 0);
 }
 
 
@@ -244,9 +244,9 @@ bool dpx::Writer::WriteElement(const int
return false;
 
 // The DPX spec recommends that the image data starts on a 8K boundry.
-if (! this->WritePadData(0x2000))
+if (! this->WritePadData(0x2000)) {
 return false;
-
+}
// mark location in headers
if (element == 0)
this->header.SetImageOffset(this->fileLoc);



commit aiccu for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package aiccu for openSUSE:Factory checked 
in at 2016-06-19 12:53:18

Comparing /work/SRC/openSUSE:Factory/aiccu (Old)
 and  /work/SRC/openSUSE:Factory/.aiccu.new (New)


Package is "aiccu"

Changes:

--- /work/SRC/openSUSE:Factory/aiccu/aiccu.changes  2015-04-22 
01:19:49.0 +0200
+++ /work/SRC/openSUSE:Factory/.aiccu.new/aiccu.changes 2016-06-19 
12:53:48.0 +0200
@@ -1,0 +2,5 @@
+Sat Jun 18 18:13:04 UTC 2016 - mplus...@suse.com
+
+- Small spec file cleanup
+
+---



Other differences:
--
++ aiccu.spec ++
--- /var/tmp/diff_new_pack.Vn2cTC/_old  2016-06-19 12:53:49.0 +0200
+++ /var/tmp/diff_new_pack.Vn2cTC/_new  2016-06-19 12:53:49.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package aiccu
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -40,7 +40,7 @@
 Requires:   net-tools
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if 0%{?suse_version} >= 1210
-BuildRequires:  pkg-config
+BuildRequires:  pkgconfig
 BuildRequires:  systemd-devel
 BuildRequires:  pkgconfig(systemd)
 %systemd_requires
@@ -70,8 +70,8 @@
 %patch5 -p1
 
 %build
-RPM_OPT_FLAGS="%{optflags} -fPIE -pie"
-export RPM_OPT_FLAGS
+export RPM_OPT_FLAGS="%{optflags} -fPIE -fPIC"
+export LDFLAGS="-Wl,--as-needed -Wl,--no-undefined -Wl,-z,now -pie"
 %if 0%{?suse_version} > 1210
 make HAVE_SYSTEMD=1 %{?_smp_mflags}
 %else




commit 0ad-data for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package 0ad-data for openSUSE:Factory 
checked in at 2016-06-19 12:53:12

Comparing /work/SRC/openSUSE:Factory/0ad-data (Old)
 and  /work/SRC/openSUSE:Factory/.0ad-data.new (New)


Package is "0ad-data"

Changes:

--- /work/SRC/openSUSE:Factory/0ad-data/0ad-data.changes2016-05-25 
21:22:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.0ad-data.new/0ad-data.changes   2016-06-19 
12:53:13.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 13:32:08 UTC 2016 - norm...@linux.vnet.ibm.com
+
+- add _constraints file for ppc64 builder
+
+---

New:

  _constraints



Other differences:
--
++ _constraints ++

  

  ppc64
  ppc64le


  
4700
  

  




commit vacuum-im for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package vacuum-im for openSUSE:Factory 
checked in at 2016-06-19 12:53:21

Comparing /work/SRC/openSUSE:Factory/vacuum-im (Old)
 and  /work/SRC/openSUSE:Factory/.vacuum-im.new (New)


Package is "vacuum-im"

Changes:

--- /work/SRC/openSUSE:Factory/vacuum-im/vacuum-im.changes  2015-06-12 
20:31:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.vacuum-im.new/vacuum-im.changes 2016-06-19 
12:53:50.0 +0200
@@ -1,0 +2,5 @@
+Sat Jun 18 18:51:55 UTC 2016 - egdf...@opensuse.org
+
+- add vacuum-im-gcc6.patch to resolve bnc#985094
+
+---

Old:

  vacuum-im-1.2.5+rc9ea75a.tar.xz

New:

  vacuum-im-1.2.5+rab1f3e3.tar.xz
  vacuum-im-gcc6.patch



Other differences:
--
++ vacuum-im.spec ++
--- /var/tmp/diff_new_pack.zTcyxt/_old  2016-06-19 12:53:51.0 +0200
+++ /var/tmp/diff_new_pack.zTcyxt/_new  2016-06-19 12:53:51.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package vacuum-im
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,8 @@
 
 
 %define sname vacuum
-%define rtime 1433926841
-%define rhash c9ea75a
+%define rtime 1433788363
+%define rhash ab1f3e3
 Name:   %{sname}-im
 Summary:Crossplatform Jabber client written on Qt
 License:GPL-3.0
@@ -32,6 +32,8 @@
 Patch1: paranoia.patch
 # PATCH-FIX-OPENSUSE fix_default_smiles.patch
 Patch2: fix_default_smiles.patch
+# PATCH-FEATURE-UPSTREAM to resolve build time issue via gcc6 (bnc#985094).
+Patch3: vacuum-im-gcc6.patch
 Url:http://www.vacuum-im.org/
 BuildRequires:  cmake >= 2.8
 BuildRequires:  fdupes
@@ -73,6 +75,9 @@
 %patch0 -p1
 %patch1 -p0
 %patch2 -p0
+%patch3 -p0
+# fix shlib-policy-name-error
+sed -i -e '/set(VERSION_UTILS_ABI/ s/[[:digit:]]*\.\([[:digit:]]*\)/\1/' 
config.cmake
 
 %build
 %{__mkdir} build

++ vacuum-im-1.2.5+rc9ea75a.tar.xz -> vacuum-im-1.2.5+rab1f3e3.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vacuum-im/CMakeLists.txt new/vacuum-im/CMakeLists.txt
--- old/vacuum-im/CMakeLists.txt2015-06-11 20:53:31.0 +0200
+++ new/vacuum-im/CMakeLists.txt2016-03-26 19:09:02.0 +0100
@@ -2,10 +2,6 @@
 
 project(vacuum-im)
 
-if(POLICY CMP0022)
-   cmake_policy(SET CMP0022 NEW)
-endif()
-
 find_package(Qt4 REQUIRED)
 
 add_custom_target(updatets)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vacuum-im/config.cmake new/vacuum-im/config.cmake
--- old/vacuum-im/config.cmake  2015-06-11 20:49:21.0 +0200
+++ new/vacuum-im/config.cmake  2016-03-26 19:09:02.0 +0100
@@ -3,7 +3,7 @@
 
 if (UNIX)
set(VERSION_UTILS 1.17.0)
-   set(VERSION_UTILS_ABI 17)
+   set(VERSION_UTILS_ABI 1.17)
 endif (UNIX)
 
 if (APPLE)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vacuum-im/src/loader/CMakeLists.txt 
new/vacuum-im/src/loader/CMakeLists.txt
--- old/vacuum-im/src/loader/CMakeLists.txt 2015-06-11 20:44:08.0 
+0200
+++ new/vacuum-im/src/loader/CMakeLists.txt 2016-03-26 19:09:02.0 
+0100
@@ -12,25 +12,20 @@
 set(QT_USE_QTMAIN YES)
 include(${QT_USE_FILE})
 
-set(GIT_HASH "" CACHE STRING "GIT HASH: git log -n 1 --format=%H")
-set(GIT_DATE "" CACHE STRING "GIT DATE: git log -n 1 --format=%ct")
+set(VER_STRING "" CACHE STRING "This string will be appended to program 
version (defaults to SVN revision number)")
 
-if (GIT_HASH STREQUAL "")
-   execute_process(COMMAND git log -n 1 --format=%H WORKING_DIRECTORY 
${CMAKE_SOURCE_DIR}
-   OUTPUT_VARIABLE GIT_HASH 
OUTPUT_STRIP_TRAILING_WHITESPACE)
-endif (GIT_HASH STREQUAL "")
+if (VER_STRING STREQUAL "")
+execute_process(COMMAND svnversion -n -c "${CMAKE_SOURCE_DIR}"
+   OUTPUT_VARIABLE SVN_REVISION)
+else (VER_STRING STREQUAL "")
+   set(SVN_REVISION "0:${VER_STRING}") # see PluginManager::revision()
+endif (VER_STRING STREQUAL "")
 
-if (GIT_DATE STREQUAL "")
-   execute_process(COMMAND git log -n 1 --format=%ct WORKING_DIRECTORY 
${CMAKE_SOURCE_DIR}
-   OUTPUT_VARIABLE GIT_DATE 
OUTPUT_STRIP_TRAILING_WHITESPACE)
-endif (GIT_DATE STREQUAL "")
-
-if (NOT (GIT_DATE STREQUAL ""))
-   file(REMOVE "${CMAKE_BINARY_DIR}/src/loader/gitinfo.h")
-   file(APPEND "${CMAKE_BINARY_DIR}/src/loader/gitinfo.h" "#define 
GIT_HASH \"${GIT_HASH}\"\n")
-   

commit libucl1 for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package libucl1 for openSUSE:Factory checked 
in at 2016-06-19 12:53:14

Comparing /work/SRC/openSUSE:Factory/libucl1 (Old)
 and  /work/SRC/openSUSE:Factory/.libucl1.new (New)


Package is "libucl1"

Changes:

--- /work/SRC/openSUSE:Factory/libucl1/libucl1.changes  2015-03-11 
09:57:18.0 +0100
+++ /work/SRC/openSUSE:Factory/.libucl1.new/libucl1.changes 2016-06-19 
12:53:25.0 +0200
@@ -1,0 +2,5 @@
+Sat Jun 18 17:26:37 UTC 2016 - mplus...@suse.com
+
+- Fix building with gcc6 (boo#985136)
+
+---



Other differences:
--
++ libucl1.spec ++
--- /var/tmp/diff_new_pack.WwHSFo/_old  2016-06-19 12:53:26.0 +0200
+++ /var/tmp/diff_new_pack.WwHSFo/_new  2016-06-19 12:53:26.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libucl1
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -54,6 +54,9 @@
 xargs sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g"
 
 %build
+export CFLAGS="%{optflags} -std=c90 -fPIC"
+export CXXFLAGS="%{optflags} -std=c90 -fPIC"
+export LDFLAGS="-Wl,--as-needed -Wl,--no-undefined -Wl,-z,now"
 %configure \
--disable-static \
--enable-shared \
@@ -61,14 +64,13 @@
 make %{?_smp_mflags}
 
 %install
-make DESTDIR=%{buildroot} install %{?_smp_mflags}
+make %{?_smp_mflags} DESTDIR=%{buildroot} install
 find %{buildroot} -type f -name "*.la" -delete -print
 
 %check
 make %{?_smp_mflags} check
 
 %post -p /sbin/ldconfig
-
 %postun -p /sbin/ldconfig
 
 %files




commit clamav for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package clamav for openSUSE:Factory checked 
in at 2016-06-19 12:52:58

Comparing /work/SRC/openSUSE:Factory/clamav (Old)
 and  /work/SRC/openSUSE:Factory/.clamav.new (New)


Package is "clamav"

Changes:

--- /work/SRC/openSUSE:Factory/clamav/clamav.changes2016-03-08 
10:18:35.0 +0100
+++ /work/SRC/openSUSE:Factory/.clamav.new/clamav.changes   2016-06-19 
12:52:59.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 10:07:51 UTC 2016 - martin.li...@suse.com
+
+- Change default C++ std to -std=gnu++98.
+
+---



Other differences:
--
++ clamav.spec ++
--- /var/tmp/diff_new_pack.g7XKRt/_old  2016-06-19 12:53:00.0 +0200
+++ /var/tmp/diff_new_pack.g7XKRt/_new  2016-06-19 12:53:00.0 +0200
@@ -79,7 +79,7 @@
 CFLAGS="-fstack-protector"
 CXXFLAGS="-fstack-protector"
 export CFLAGS="%optflags $CFLAGS -fPIE -fno-strict-aliasing"
-export CXXFLAGS="%optflags $CXXFLAGS -fPIE -fno-strict-aliasing"
+export CXXFLAGS="%optflags $CXXFLAGS -fPIE -fno-strict-aliasing -std=gnu++98"
 export LDFLAGS="-pie"
 %if "%_lib" == "lib64"
 # tomsfastmath needs this for correct operation on 64-bit platforms





commit kaffeine for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package kaffeine for openSUSE:Factory 
checked in at 2016-06-19 12:53:04

Comparing /work/SRC/openSUSE:Factory/kaffeine (Old)
 and  /work/SRC/openSUSE:Factory/.kaffeine.new (New)


Package is "kaffeine"

Changes:

--- /work/SRC/openSUSE:Factory/kaffeine/kaffeine.changes2016-02-24 
18:43:05.0 +0100
+++ /work/SRC/openSUSE:Factory/.kaffeine.new/kaffeine.changes   2016-06-19 
12:53:04.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 18:57:21 UTC 2016 - wba...@tmo.at
+
+- Add kaffeine-gcc6.patch to fix build with gcc6 (boo#985371)
+
+---

New:

  kaffeine-gcc6.patch



Other differences:
--
++ kaffeine.spec ++
--- /var/tmp/diff_new_pack.wKMh8U/_old  2016-06-19 12:53:06.0 +0200
+++ /var/tmp/diff_new_pack.wKMh8U/_new  2016-06-19 12:53:06.0 +0200
@@ -45,6 +45,8 @@
 Patch8: support_for_sundtek_tv_tuners.patch
 #PATCH-FIX-UPSTREAM kaffeine-cmake34.patch -- Include files containing the 
functions used by the build system
 Patch9: kaffeine-cmake34.patch
+# PATCH-FIX-UPSTREAM kaffeine-gcc6.patch boo#985371 wba...@tmo.at -- fix build 
with gcc6
+Patch10:kaffeine-gcc6.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 BuildRequires:  libkde4-devel
@@ -82,6 +84,7 @@
 %patch7
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
 
 %build
 %cmake_kde4 -d build

++ kaffeine-gcc6.patch ++
--- a/src/dvb/dvbdevice.cpp
+++ b/src/dvb/dvbdevice.cpp
@@ -353,8 +353,8 @@
 
switch (config->configuration) {
case DvbConfigBase::DiseqcSwitch: {
-   char cmd[] = { 0xe0, 0x10, 0x38, 0x00 };
-   cmd[3] = 0xf0 | (config->lnbNumber << 2) | (horPolar ? 2 : 0) | 
(highBand ? 1 : 0);
+   char cmd[] = { char(0xe0), 0x10, 0x38, 0x00 };
+   cmd[3] = 0xf0 | char(config->lnbNumber << 2) | (horPolar ? 2 : 
0) | (highBand ? 1 : 0);
backend->sendMessage(cmd, sizeof(cmd));
usleep(15000);
 
@@ -399,7 +399,7 @@
value |= 0xd000;
}
 
-   char cmd[] = { 0xe0, 0x31, 0x6e, (value / 256), (value % 256) };
+   char cmd[] = { char(0xe0), 0x31, 0x6e, char(value / 256), 
char(value % 256) };
backend->sendMessage(cmd, sizeof(cmd));
usleep(15000);
moveRotor = true;
@@ -407,7 +407,7 @@
}
 
case DvbConfigBase::PositionsRotor: {
-   char cmd[] = { 0xe0, 0x31, 0x6b, config->lnbNumber };
+   char cmd[] = { char(0xe0), 0x31, 0x6b, char(config->lnbNumber) 
};
backend->sendMessage(cmd, sizeof(cmd));
usleep(15000);
moveRotor = true;




commit xosview for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package xosview for openSUSE:Factory checked 
in at 2016-06-19 12:52:52

Comparing /work/SRC/openSUSE:Factory/xosview (Old)
 and  /work/SRC/openSUSE:Factory/.xosview.new (New)


Package is "xosview"

Changes:

--- /work/SRC/openSUSE:Factory/xosview/xosview.changes  2015-11-22 
11:02:42.0 +0100
+++ /work/SRC/openSUSE:Factory/.xosview.new/xosview.changes 2016-06-19 
12:52:53.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 08:22:27 UTC 2016 - wer...@suse.de
+
+- Choose a working compiler 
+
+---



Other differences:
--
++ xosview.spec ++
--- /var/tmp/diff_new_pack.bMpLqo/_old  2016-06-19 12:52:54.0 +0200
+++ /var/tmp/diff_new_pack.bMpLqo/_new  2016-06-19 12:52:54.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package xosview
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 Name:   xosview
 BuildRequires:  autoconf
-BuildRequires:  gcc-c++
+BuildRequires:  gcc5-c++
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(x11)
 BuildRequires:  pkgconfig(xpm)
@@ -67,7 +67,8 @@
 
 %build
   OPTFLAGS="$RPM_OPT_FLAGS"
- CXX=g++
+ CXX=g++-5
+export OPTFLAGS CXX
 case "$RPM_OPT_FLAGS" in
 *-fno-const-strings*) ;;
 *)





commit diff-pdf for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package diff-pdf for openSUSE:Factory 
checked in at 2016-06-19 12:53:10

Comparing /work/SRC/openSUSE:Factory/diff-pdf (Old)
 and  /work/SRC/openSUSE:Factory/.diff-pdf.new (New)


Package is "diff-pdf"

Changes:

--- /work/SRC/openSUSE:Factory/diff-pdf/diff-pdf.changes2016-06-03 
16:38:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.diff-pdf.new/diff-pdf.changes   2016-06-19 
12:53:11.0 +0200
@@ -1,0 +2,6 @@
+Sat Jun 18 10:27:21 UTC 2016 - mplus...@suse.com
+
+- Fix building with gcc6 (boo#985353)
+- Use safer ldflags
+
+---



Other differences:
--
++ diff-pdf.spec ++
--- /var/tmp/diff_new_pack.lkj3Uz/_old  2016-06-19 12:53:12.0 +0200
+++ /var/tmp/diff_new_pack.lkj3Uz/_new  2016-06-19 12:53:12.0 +0200
@@ -43,6 +43,8 @@
 %setup -q
 
 %build
+export CXXFLAGS="%{optflags} -fpermissive"
+export LDFLAGS='-Wl,--as-needed -Wl,--no-undefined -Wl,-z,now'
 ./bootstrap
 %configure
 make %{?_smp_mflags} V=1




commit libqxt for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package libqxt for openSUSE:Factory checked 
in at 2016-06-19 12:53:08

Comparing /work/SRC/openSUSE:Factory/libqxt (Old)
 and  /work/SRC/openSUSE:Factory/.libqxt.new (New)


Package is "libqxt"

Changes:

--- /work/SRC/openSUSE:Factory/libqxt/libqxt.changes2014-01-03 
19:44:33.0 +0100
+++ /work/SRC/openSUSE:Factory/.libqxt.new/libqxt.changes   2016-06-19 
12:53:09.0 +0200
@@ -1,0 +2,9 @@
+Fri Jun 17 15:24:41 UTC 2016 - dap.darkn...@gmail.com
+
+-`spec-cleaner`.
+- Updated Url & BuildRequires tags.
+- Added libqxt-gcc6.patch to resolve bnc#985109.
+- Enabled verbose make output.
+- Required xrandr & zeroconf to resolve configure time warnings.
+
+---

New:

  libqxt-gcc6.patch



Other differences:
--
++ libqxt.spec ++
--- /var/tmp/diff_new_pack.OTVgOz/_old  2016-06-19 12:53:10.0 +0200
+++ /var/tmp/diff_new_pack.OTVgOz/_new  2016-06-19 12:53:10.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libqxt
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,8 +23,9 @@
 Summary:Library extending Qt
 License:CPL-1.0 and LGPL-2.1
 Group:  Development/Libraries/C and C++
-Url:http://libqxt.org/
+Url:https://bitbucket.org/libqxt/libqxt/wiki/Home
 
+# SourceUrl seems to be unavailable.
 Source0:v%{version}.tar.bz2
 # PATCH-FIX-OPENSUSE to support multimedia keys on keyboards.
 # http://dev.libqxt.org/libqxt-old-hg/issue/75
@@ -32,12 +33,16 @@
 # PATCH-FIX-OPENSUSE to respect X11 event filters already set.
 # http://dev.libqxt.org/libqxt/pull-request/41
 Patch1: libqxt-event-filters.patch
+# PATCH-FIX-OPENSUSE to resolve build time issue via gcc6 (bnc#985109).
+Patch2: libqxt-gcc6.patch
 
 BuildRequires:  chrpath
+BuildRequires:  db-devel
 BuildRequires:  fdupes
-BuildRequires:  libdb-4_8-devel
-BuildRequires:  libqt4-devel
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  pkgconfig
+BuildRequires:  pkgconfig(QtCore)
+BuildRequires:  pkgconfig(avahi-core)
+BuildRequires:  pkgconfig(xrandr)
 
 %description
 LibQxt is an extension library for Qt providing a suite of cross-platform 
utility classes to add functionality not readily available in the Qt toolkit by 
Trolltech, a Nokia company.
@@ -66,15 +71,19 @@
 %setup -q -n libqxt-libqxt-%{versionhash}
 %patch0 -p1
 %patch1
+%if 0%{?suse_version} > 1320
+%patch2 -p1
+%endif
 
 %build
-./configure -prefix /usr -libdir %{_libdir}
-make %{?_smp_mflags}
+# Does not use GNU configure
+./configure -prefix %{_prefix} -libdir %{_libdir}
+make V=1 %{?_smp_mflags}
 
 %install
-make INSTALL_ROOT=%{buildroot} install
+make V=1 INSTALL_ROOT=%{buildroot} install
 chrpath --delete %{buildroot}%{_libdir}/*.so 
%{buildroot}%{_libdir}/qt4/plugins/designer/*.so
-find %{buildroot} -name '*.la' -exec rm -f {} ';'
+find %{buildroot} -type f -name "*.la" -delete -print
 %fdupes -s %{buildroot}%{_includedir}/
 
 %post -n %{name}1 -p /sbin/ldconfig

++ libqxt-gcc6.patch ++
--- a/src/core/qxtslotjob.cpp   2011-11-24 16:10:32.0 -0600
+++ b/src/core/qxtslotjob.cpp   2016-03-07 16:20:32.758268253 -0600
@@ -174,7 +174,7 @@ This uses QxtSignalWaiter so it will _no
 
 QVariant QxtFuture::delayedResult(int msec)
 {
-if (!waiter->wait(msec, false))
+if (!waiter->wait(msec, NULL))
 return QVariant();
 return job->result();
 }



commit kvpnc for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package kvpnc for openSUSE:Factory checked 
in at 2016-06-19 12:52:56

Comparing /work/SRC/openSUSE:Factory/kvpnc (Old)
 and  /work/SRC/openSUSE:Factory/.kvpnc.new (New)


Package is "kvpnc"

Changes:

--- /work/SRC/openSUSE:Factory/kvpnc/kvpnc.changes  2016-03-17 
16:47:30.0 +0100
+++ /work/SRC/openSUSE:Factory/.kvpnc.new/kvpnc.changes 2016-06-19 
12:52:58.0 +0200
@@ -1,0 +2,7 @@
+Fri Jun 17 12:04:25 UTC 2016 - tittiatc...@gmail.com
+
+- Cherry pick important commits from upstream (also fixes GCC6 build)
+   * upstream-fixes.patch
+   * kvpnc-gcc6.patch (boo#985190)
+
+---

New:

  kvpnc-gcc6.patch
  upstream-fixes.patch



Other differences:
--
++ kvpnc.spec ++
--- /var/tmp/diff_new_pack.0piMJk/_old  2016-06-19 12:52:59.0 +0200
+++ /var/tmp/diff_new_pack.0piMJk/_new  2016-06-19 12:52:59.0 +0200
@@ -26,6 +26,8 @@
 Source0:http://download.gna.org/kvpnc/%{name}-%{version}-kde4.tar.bz2
 Source1:http://download.gna.org/kvpnc/%{name}-0.9.6-kde4-locale.tar.bz2
 Patch0: kvpnc-gcc47.patch
+Patch1: upstream-fixes.patch
+Patch2: kvpnc-gcc6.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 # only needed to patch broken images in the upstream tarball
 BuildRequires:  ImageMagick
@@ -49,6 +51,8 @@
 %prep
 %setup -q -n %{name}-%{version}-kde4 -a1
 %patch0 -p1
+%patch1 -p0
+%patch2 -p1
 echo "find_package(Msgfmt REQUIRED)" >> CMakeLists.txt
 echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt
 echo "add_subdirectory( po )" >> CMakeLists.txt

++ kvpnc-gcc6.patch ++
diff -urNB new/src/utils.cpp new1/src/utils.cpp
--- new/src/utils.cpp   2016-06-17 14:36:23.534039790 +0200
+++ new1/src/utils.cpp  2016-06-17 14:43:20.292353264 +0200
@@ -914,7 +914,7 @@
 NameAndPidOfProgramListenProcess->start(proc, args);
 if (!NameAndPidOfProgramListenProcess->waitForStarted()) {
 kError() << "netstat fails!" << endl;
-return false;
+return "";
 } else {
 NameAndPidOfProgramListenProcess->waitForFinished();
 
@@ -946,7 +946,7 @@
 GetEmailAddressOfCertProcess->start(proc, args);
 if (!GetEmailAddressOfCertProcess->waitForStarted()) {
 kError() << "GetEmailAddressOfCertProcess" << endl;
-return false;
+return "";
 } else {
 GetEmailAddressOfCertProcess->waitForFinished();
 disconnect(GetEmailAddressOfCertProcess, 
SIGNAL(readyReadStandardOutput()), this, SLOT(readOutGetEmailAddressOfCert()));
++ upstream-fixes.patch ++
--- loginfo 2005-10-08 14:26:34.0 +0200
+++ loginfo 2016-06-17 14:31:39.532482472 +0200
@@ -1 +0,0 @@
-ALL /usr/bin/perl /home/crissi/ciabot_cvs_1.12.pl %p %{s} %n $USER project 
from_email dest_email ignore_regexp
--- src/CMakeLists.txt  2010-05-19 10:47:21.0 +0200
+++ src/CMakeLists.txt  2016-06-17 14:31:39.532482472 +0200
@@ -180,7 +180,8 @@
 
 target_link_libraries(kvpnc_bin ${KDE4_KFILE_LIBS} ${KDE4_KDE3SUPPORT_LIBS} 
${KDE4_KIO_LIBS} ${QT_QTXML_LIBRARY} ${KDE4_KNOTIFYCONFIG_LIBS} 
${LIBGCRYPT_LIBRARIES} ${KDE4_KPTY_LIBS})
 
-install(FILES kvpnc.notifyrc ping_check.sh DESTINATION 
${DATA_INSTALL_DIR}/kvpnc)
+install(FILES kvpnc.notifyrc DESTINATION ${DATA_INSTALL_DIR}/kvpnc)
+install(PROGRAMS ping_check.sh DESTINATION ${DATA_INSTALL_DIR}/kvpnc)
 install(TARGETS kvpnc_bin ${INSTALL_TARGETS_DEFAULT_ARGS})
 install(FILES kvpncui.rc DESTINATION ${DATA_INSTALL_DIR}/kvpnc)
 install(FILES kvpnc.desktop DESTINATION ${XDG_APPS_INSTALL_DIR})
--- src/kvpncconfig.cpp 2010-03-08 11:26:33.0 +0100
+++ src/kvpncconfig.cpp 2016-06-17 14:31:42.208497071 +0200
@@ -4295,7 +4295,7 @@
 appPointer->processEvents();
 
 if (useKwallet && KWallet::Wallet::isEnabled())
-configgroup.deleteEntry("First use of Kwallet", false);
+configgroup.deleteEntry("First use of Kwallet");
 
 
 /* = user data = */
--- src/utils.cpp   2010-02-28 12:22:35.0 +0100
+++ src/utils.cpp   2016-06-17 14:36:23.534039790 +0200
@@ -1146,27 +1146,6 @@
 return needsPassphrase;
 }
 
-QString Utils::getHostname()
-{
-Hostname = "linux.local";
-
-GetHostnameProcess = new QProcess(this);
-QString proc = "hostname";
-QStringList args;
-connect(GetHostnameProcess, SIGNAL(readyReadStandardOutput()), this, 
SLOT(readStdOutGetHostname()));
-connect(GetHostnameProcess, SIGNAL(readyReadStandardError()), this, 
SLOT(readStdErrGetHostname()));
-GetHostnameProcess->setEnvironment(*env);
-GetHostnameProcess->start(proc, args);
-if (!GetHostnameProcess->waitForStarted()) {
-kError() << "Unable to start 

commit qbittorrent for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package qbittorrent for openSUSE:Factory 
checked in at 2016-06-19 12:53:02

Comparing /work/SRC/openSUSE:Factory/qbittorrent (Old)
 and  /work/SRC/openSUSE:Factory/.qbittorrent.new (New)


Package is "qbittorrent"

Changes:

--- /work/SRC/openSUSE:Factory/qbittorrent/qbittorrent.changes  2016-04-01 
13:02:58.0 +0200
+++ /work/SRC/openSUSE:Factory/.qbittorrent.new/qbittorrent.changes 
2016-06-19 12:53:03.0 +0200
@@ -1,0 +2,6 @@
+Fri Jun 17 17:03:09 UTC 2016 - sor.ale...@meowr.ru
+
+- Add qbittorrent-gcc6.patch from commit e2bf462: fix GCC 6 errors
+  with qmake (boo#985244).
+
+---

New:

  qbittorrent-gcc6.patch



Other differences:
--
++ qbittorrent.spec ++
--- /var/tmp/diff_new_pack.23qut2/_old  2016-06-19 12:53:04.0 +0200
+++ /var/tmp/diff_new_pack.23qut2/_new  2016-06-19 12:53:04.0 +0200
@@ -28,20 +28,24 @@
 Source: http://downloads.sf.net/%{name}/%{name}-%{version}.tar.xz
 Source1:http://downloads.sf.net/%{name}/%{name}-%{version}.tar.xz.asc
 Source2:%{name}.keyring
-Patch1: bittorrent_missing_ppc64le_in_ax_boost_base.m4.patch
+# PATCH-FIX-OPENSUSE bittorrent_missing_ppc64le_in_ax_boost_base.m4.patch 
norm...@linux.vnet.ibm.com -- Add ppc64le support.
+Patch0: bittorrent_missing_ppc64le_in_ax_boost_base.m4.patch
+# PATCH-FIX-UPSTREAM qbittorrent-gcc6.patch boo#985244 
sledgehammer...@qbittorrent.org -- Fix GCC 6 compilation with qmake.
+Patch1: %{name}-gcc6.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  boost-devel >= 1.35
 BuildRequires:  fdupes
 BuildRequires:  hicolor-icon-theme
+BuildRequires:  pkg-config
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(libtorrent-rasterbar) >= 1.0.6
-# For geolocalization.
+# For geolocalisation.
 Requires:   GeoIP
 # For search engines.
 Requires:   python3
 Recommends: python
-%if 0%{?suse_version} >= 1320 || (0%{?suse_version} == 1315 && 
0%{?is_opensuse})
+%if 0%{?suse_version} >= 1320 || (0%{?sle_version} >= 120100 && 
0%{?is_opensuse})
 BuildRequires:  libqt5-linguist >= 5.2.0
 BuildRequires:  pkgconfig(Qt5Concurrent) >= 5.2.0
 BuildRequires:  pkgconfig(Qt5Core) >= 5.2.0
@@ -65,7 +69,7 @@
 
 It aims to be a good alternative to all other bittorrent clients
 out there. qBittorrent is fast, stable and provides unicode support
-as well as many features.
+as well as lots of features.
 
 %package nox
 Summary:A BitTorrent client in Qt, CLI version
@@ -77,10 +81,11 @@
 
 It aims to be a good alternative to all other bittorrent clients
 out there. qBittorrent is fast, stable and provides unicode support
-as well as many features.
+as well as lots of features.
 
 %prep
 %setup -q
+%patch0 -p1
 %patch1 -p1
 
 %build
@@ -93,7 +98,7 @@
 pushd $ui
 %configure \
   $ui_opt   \
-%if 0%{?suse_version} < 1320 && !(0%{?suse_version} == 1315 && 
0%{?is_opensuse})
+%if 0%{?suse_version} < 1320 && !(0%{?sle_version} >= 120100 && 
0%{?is_opensuse})
   --with-qt4\
 %endif
   --enable-systemd


++ qbittorrent-gcc6.patch ++
--- a/conf.pri.in
+++ b/conf.pri.in
@@ -6,8 +6,14 @@ DATADIR = @EXPAND_DATADIR@
 MANPREFIX = @EXPAND_MANDIR@
 
 QMAKE_CXXFLAGS += @QBT_CONF_EXTRA_CFLAGS@
-INCLUDEPATH += @QBT_CONF_INCLUDES@
-LIBS += @LDFLAGS@ @LIBS@
+
+EXTERNAL_INCLUDES = @QBT_CONF_INCLUDES@
+EXTERNAL_INCLUDES -= $$QMAKE_DEFAULT_INCDIRS
+INCLUDEPATH += $$EXTERNAL_INCLUDES
+
+EXTERNAL_LIBS = @LDFLAGS@ @LIBS@
+EXTERNAL_LIBS -= $$QMAKE_DEFAULT_LIBDIRS
+LIBS += $$EXTERNAL_LIBS
 
 CONFIG += @QBT_ADD_CONFIG@
 CONFIG -= @QBT_REMOVE_CONFIG@



commit krename for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package krename for openSUSE:Factory checked 
in at 2016-06-19 12:53:01

Comparing /work/SRC/openSUSE:Factory/krename (Old)
 and  /work/SRC/openSUSE:Factory/.krename.new (New)


Package is "krename"

Changes:

--- /work/SRC/openSUSE:Factory/krename/krename.changes  2014-09-03 
20:09:27.0 +0200
+++ /work/SRC/openSUSE:Factory/.krename.new/krename.changes 2016-06-19 
12:53:02.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 16:50:33 UTC 2016 - wba...@tmo.at
+
+- Add gcc6-fix.patch to fix build with gcc6 (boo#985366)
+
+---

New:

  gcc6-fix.patch



Other differences:
--
++ krename.spec ++
--- /var/tmp/diff_new_pack.XT53wQ/_old  2016-06-19 12:53:03.0 +0200
+++ /var/tmp/diff_new_pack.XT53wQ/_new  2016-06-19 12:53:03.0 +0200
@@ -34,6 +34,8 @@
 Patch3: remove-gplv2-code.diff
 # PATCH-FIX-openSUSE tittiatcokeægmail.com -- make sure that the freetype 
includes are found
 Patch4: fix-freetype2-includes.patch
+# PATCH-FIX-OPENSUSE gcc6-fix.patch boo#985366 -- fix build with gcc6
+Patch5: gcc6-fix.patch
 BuildRequires:  freetype2-devel
 BuildRequires:  libexiv2-devel
 BuildRequires:  libkde4-devel
@@ -66,6 +68,7 @@
 %if 0%{?suse_version} > 1310
 %patch4 -p1
 %endif
+%patch5 -p1
 
 # Remove build time references so build-compare can do its work (fix rpmlint 
warning "file-contains-date-and-time")
 FAKE_BUILDTIME=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%H:%%M')

++ gcc6-fix.patch ++
From: Martin T. H. Sandsmark 
Date: Sat, 07 May 2016 21:59:34 +
Subject: fix build
X-Git-Url: 
http://quickgit.kde.org/?p=scratch%2Fsandsmark%2Fkrename.git=commitdiff=62f65e049d6640dc346ea5bd18c6bd81aee0936f
---
fix build
---


--- a/src/batchrenamer.cpp
+++ b/src/batchrenamer.cpp
@@ -402,7 +402,7 @@
 break;
 case eRenameMode_Link:
 // In case of link delete created file
-job = KIO::file_delete( dstUrl, false );
+job = KIO::file_delete( dstUrl, KIO::HideProgressInfo );
 break;
 case eRenameMode_Copy: // no undo possible
 // TODO: Maybe we should delete the created files




commit kdebindings-smokekde for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package kdebindings-smokekde for 
openSUSE:Factory checked in at 2016-06-19 12:52:50

Comparing /work/SRC/openSUSE:Factory/kdebindings-smokekde (Old)
 and  /work/SRC/openSUSE:Factory/.kdebindings-smokekde.new (New)


Package is "kdebindings-smokekde"

Changes:

--- 
/work/SRC/openSUSE:Factory/kdebindings-smokekde/kdebindings-smokekde.changes
2015-08-31 22:59:12.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.kdebindings-smokekde.new/kdebindings-smokekde.changes
   2016-06-19 12:52:51.0 +0200
@@ -1,0 +2,12 @@
+Thu Jun 16 20:12:22 UTC 2016 - wba...@tmo.at
+
+- Use CMAKE_CXX_STANDARD=98 to fix build with gcc6 (boo#985250)
+
+---
+Wed Feb 3 19:53:24 UTC 2016 - tittiatc...@gmail.com
+
+- Drop the buildrequires on kdepimlibs4. This make no sense anymore
+  as that we switched to KDEPIM5 and we are going to drop most of 
+  the bindings anyway.
+
+---



Other differences:
--
++ kdebindings-smokekde.spec ++
--- /var/tmp/diff_new_pack.MpC9cG/_old  2016-06-19 12:52:52.0 +0200
+++ /var/tmp/diff_new_pack.MpC9cG/_new  2016-06-19 12:52:52.0 +0200
@@ -30,7 +30,6 @@
 Patch1: remove_kfile.diff
 BuildRequires:  libjasper-devel
 BuildRequires:  libkde4-devel
-BuildRequires:  libkdepimlibs4-devel
 BuildRequires:  libsmokegen-devel
 BuildRequires:  libsmokeqt-devel
 BuildRequires:  okular-devel
@@ -72,7 +71,7 @@
 %patch1 -p1
 
 %build
-  %cmake_kde4 -d build
+  %cmake_kde4 -d build -- -DCMAKE_CXX_STANDARD=98
   %make_jobs
 
 %install




commit perl-qt4 for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package perl-qt4 for openSUSE:Factory 
checked in at 2016-06-19 12:52:46

Comparing /work/SRC/openSUSE:Factory/perl-qt4 (Old)
 and  /work/SRC/openSUSE:Factory/.perl-qt4.new (New)


Package is "perl-qt4"

Changes:

--- /work/SRC/openSUSE:Factory/perl-qt4/perl-qt4.changes2014-11-19 
20:27:59.0 +0100
+++ /work/SRC/openSUSE:Factory/.perl-qt4.new/perl-qt4.changes   2016-06-19 
12:52:48.0 +0200
@@ -1,0 +2,5 @@
+Thu Jun 16 14:28:44 UTC 2016 - wba...@tmo.at
+
+- Added gcc6-fix.patch to fix build with gcc6 (boo#985188, kde#360844)
+
+---

New:

  gcc6-fix.patch



Other differences:
--
++ perl-qt4.spec ++
--- /var/tmp/diff_new_pack.uOh6fS/_old  2016-06-19 12:52:49.0 +0200
+++ /var/tmp/diff_new_pack.uOh6fS/_new  2016-06-19 12:52:49.0 +0200
@@ -24,6 +24,8 @@
 Group:  Development/Languages/Perl
 Url:https://projects.kde.org/projects/kde/kdebindings/perl/perlqt
 Source0:perlqt-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM gcc6-fix.patch boo#985188, kde#360844 -- fix build with 
gcc6
+Patch:  gcc6-fix.patch
 BuildRequires:  cmake
 BuildRequires:  kde4-filesystem
 BuildRequires:  kdebindings-smokegen
@@ -53,6 +55,7 @@
 
 %prep
 %setup -q -n perlqt-%{version}
+%patch -p1
 
 %build
   EXTRA_FLAGS="-DCUSTOM_PERL_SITE_ARCH_DIR=`perl -MConfig -e 'print 
$Config{vendorarch}'`"

++ gcc6-fix.patch ++
>From 70100c1865985e0cabbba5716cb9a6df8099b377 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= 
Date: Tue, 22 Mar 2016 11:27:24 +0100
Subject: [PATCH] Initialize smokeperl_object properly
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This patch fixes this build failure with GCC 6:

/builddir/build/BUILD/Qt-0.96.0/qtcore/src/util.cpp:2248:59: error: cannot 
convert 'bool' to 'void*' in initialization
 static smokeperl_object nothis = { 0, 0, 0, false };
   ^
CPAN RT#111630

Signed-off-by: Petr Písař 
---
 qtcore/src/util.cpp | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/qtcore/src/util.cpp b/qtcore/src/util.cpp
index b913af3..4c94e2c 100644
--- a/qtcore/src/util.cpp
+++ b/qtcore/src/util.cpp
@@ -2251,7 +2251,7 @@ XS(XS_AUTOLOAD) {
 methcache.insert(mcid, new Smoke::ModuleIndex(mi));
 }
 
-static smokeperl_object nothis = { 0, 0, 0, false };
+static smokeperl_object nothis = { 0, 0, 0, NULL };
 smokeperl_object* call_this = 0;
 if ( SvOK(sv_this) ) {
 call_this = sv_obj_info( sv_this );
-- 
2.5.5




commit printer-driver-brlaser for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package printer-driver-brlaser for 
openSUSE:Factory checked in at 2016-06-19 12:52:53

Comparing /work/SRC/openSUSE:Factory/printer-driver-brlaser (Old)
 and  /work/SRC/openSUSE:Factory/.printer-driver-brlaser.new (New)


Package is "printer-driver-brlaser"

Changes:

--- 
/work/SRC/openSUSE:Factory/printer-driver-brlaser/printer-driver-brlaser.changes
2016-02-11 12:37:43.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.printer-driver-brlaser.new/printer-driver-brlaser.changes
   2016-06-19 12:52:54.0 +0200
@@ -1,0 +2,18 @@
+Fri Jun 17 06:36:23 UTC 2016 - lnus...@suse.de
+
+- Update to version 3+git20160302.03bb366:
+  * Kill a harmless dead store
+  * Fix lest.hpp dependency for the tests.
+  * Add Brother DCP-7055
+  * Misc cleanups, mostly in the test code
+  * Reject unexpected raster formats
+  * Use cups-config --ldflags
+  * Refuse to build without a C++11 compiler
+- fetch patches from pull requests:
+  0001-mark-DCP-7055W-as-supported.diff (was brlaser-br7055w.diff)
+  0002-Add-Brother-DCP1510.diff
+  0003-Add-missing-include-string.diff (fixes boo#985119)
+- remove SLE11 and SLE10 noise from spec file again, doesn't build there
+  anyways.
+
+---

Old:

  brlaser-3+git20141125.4f1a00d.tar.gz
  brlaser-br7055w.diff

New:

  0001-mark-DCP-7055W-as-supported.diff
  0002-Add-Brother-DCP1510.diff
  0003-Add-missing-include-string.diff
  brlaser-3+git20160302.03bb366.tar.gz



Other differences:
--
++ printer-driver-brlaser.spec ++
--- /var/tmp/diff_new_pack.7OKE4K/_old  2016-06-19 12:52:55.0 +0200
+++ /var/tmp/diff_new_pack.7OKE4K/_new  2016-06-19 12:52:55.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   printer-driver-brlaser
-Version:3+git20141125.4f1a00d
+Version:3+git20160302.03bb366
 Release:0
 Summary:Driver for (some) Brother laster printers
 License:GPL-2.0+
@@ -25,22 +25,17 @@
 Url:https://github.com/pdewacht/brlaser
 Source: brlaser-%{version}.tar.gz
 # PATCH-FIX-UPSTREAM -- https://github.com/pdewacht/brlaser/pull/5
-Patch0: brlaser-br7055w.diff
+Patch0: 0001-mark-DCP-7055W-as-supported.diff
+# PATCH-FIX-UPSTREAM -- https://github.com/pdewacht/brlaser/pull/7
+Patch1: 0002-Add-Brother-DCP1510.diff
+# PATCH-FIX-UPSTREAM -- https://github.com/pdewacht/brlaser/pull/9
+Patch2: 0003-Add-missing-include-string.diff
 BuildRequires:  autoconf
 BuildRequires:  automake
-# SLE10 and SLE11 and SLE12 need special BuildRequires.
-# For suse_version values see 
https://en.opensuse.org/openSUSE:Build_Service_cross_distribution_howto
-%if 0%{?suse_version} != 1010 && 0%{?suse_version} != 1110 && 
0%{?suse_version} != 1315
-# Anything what is not SLE10 or SLE11 or SLE12 (i.e. all openSUSE versions) 
have "normal" BuildRequires.
+%if 0%{?is_opensuse} || 0%{?suse_version} != 1315
 BuildRequires:  cups-ddk
 BuildRequires:  cups-devel
-%endif
-%if 0%{?suse_version} == 1110 || 0%{?suse_version} == 1010
-# On SLE11 and SLE10 there is the separated package cupsddk.
-BuildRequires:  cups-devel
-BuildRequires:  cupsddk
-%endif
-%if 0%{?suse_version} == 1315
+%else
 # For SLE12 by default CUPS 1.7.5 is provided and alternatively CUPS 1.5.4 is 
provided in the "legacy" module.
 # For SLE12 build it with traditional CUPS 1.5.4 to ensure it works on SLE12 
both with CUPS 1.7.5 and CUPS 1.5.4.
 # Only in the Printing project for SLE12 use cups154-ddk (a sub package of the 
cups154-SLE12 source package):
@@ -48,15 +43,7 @@
 BuildRequires:  cups154-devel
 %endif
 BuildRequires:  gcc-c++
-%if 0%{?suse_version} != 1010
-# On SLE10 there is no python-cups. Simply omit it because that BuildRequires 
is only there to
-# add python-cups BuildRequires to have postscriptdriver() Provides for the 
drivers in gutenprint.
 BuildRequires:  python-cups
-%endif
-%if 0%{?suse_version} == 1110
-# For SLE11 redefine _libexecdir because on SLE11 _libexecdir is "/usr/lib64":
-%global _libexecdir /usr/lib
-%endif
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -67,14 +54,14 @@
 
 It is known to support these printers:
 
+Brother DCP-1510 series
 Brother DCP-7030
 Brother DCP-7055
 Brother DCP-7055W
 Brother DCP-7065DN
 
 %prep
-%setup -q -n brlaser-%{version}
-%patch0 -p1
+%autosetup -p1 -n brlaser-%{version}
 
 %build
 autoreconf -fi

++ 0001-mark-DCP-7055W-as-supported.diff ++
>From 1c5d3177eb74c5e150aec44ef1750f9a55f4d769 Mon Sep 17 00:00:00 2001
From: Ludwig Nussel 
Date: Thu, 28 Jan 2016 10:57:04 +0100
Subject: [PATCH 1/3] mark DCP-7055W as supported

---
 README.md  | 

commit blender for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package blender for openSUSE:Factory checked 
in at 2016-06-19 12:52:59

Comparing /work/SRC/openSUSE:Factory/blender (Old)
 and  /work/SRC/openSUSE:Factory/.blender.new (New)


Package is "blender"

Changes:

--- /work/SRC/openSUSE:Factory/blender/blender.changes  2016-06-07 
23:50:03.0 +0200
+++ /work/SRC/openSUSE:Factory/.blender.new/blender.changes 2016-06-19 
12:53:00.0 +0200
@@ -1,0 +2,7 @@
+Fri Jun 17 06:18:04 UTC 2016 - adr...@suse.de
+
+- use sse compiler options only on supported architectures
+- fix build on ppc by skipping colormanagement
+- drop SUPPORT_SSE2_BUILD since it is not used by cmake anymore
+
+---



Other differences:
--
++ blender.spec ++
--- /var/tmp/diff_new_pack.KCT33A/_old  2016-06-19 12:53:02.0 +0200
+++ /var/tmp/diff_new_pack.KCT33A/_new  2016-06-19 12:53:02.0 +0200
@@ -216,8 +216,8 @@
 echo %{_version}
 
 %build
-# sse options not supported by PowerPC
-%ifnarch ppc ppc64 ppc64le
+# sse options only on supported archs
+%ifarch %{ix86} x86_64
 sseflags='-msse -msse2'
 %endif
 # Find python3 version and abiflags
@@ -279,7 +279,6 @@
   -DWITH_SDL:BOOL=ON \
   -DWITH_SDL_DYNLOAD:BOOL=on \
 %ifnarch x86_64
-  -DSUPPORT_SSE2_BUILD=false \
   -DWITH_RAYOPTIMIZATION:BOOL=OFF \
   -DWITH_MOD_OCEANSIM:BOOL=OFF \
 %else
@@ -414,7 +413,9 @@
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/%{_version}
 %dir %{_datadir}/%{name}/%{_version}/datafiles
+%ifnarch ppc %power64
 %{_datadir}/%{name}/%{_version}/datafiles/colormanagement/
+%endif
 %{_datadir}/%{name}/%{_version}/scripts/
 %{_datadir}/applications/blender.desktop
 %{_datadir}/applications/x-blend.desktop





commit geis for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package geis for openSUSE:Factory checked in 
at 2016-06-19 12:52:55

Comparing /work/SRC/openSUSE:Factory/geis (Old)
 and  /work/SRC/openSUSE:Factory/.geis.new (New)


Package is "geis"

Changes:

--- /work/SRC/openSUSE:Factory/geis/geis.changes2015-11-17 
14:22:45.0 +0100
+++ /work/SRC/openSUSE:Factory/.geis.new/geis.changes   2016-06-19 
12:52:56.0 +0200
@@ -1,0 +2,12 @@
+Fri Jun 17 12:13:46 UTC 2016 - jeng...@inai.de
+
+- Remove pointless pkg-config require; it already exist through
+  by /usr/lib/rpm/pkgconfigdeps.sh.
+
+---
+Thu Jun 16 21:22:44 UTC 2016 - sor.ale...@meowr.ru
+
+- Use tarball signing.
+- Add geis-disable-werror.patch: disable -Werror (boo#985131).
+
+---

New:

  geis-2.2.17.tar.xz.asc
  geis-disable-werror.patch
  geis.keyring



Other differences:
--
++ geis.spec ++
--- /var/tmp/diff_new_pack.7ARaxO/_old  2016-06-19 12:52:57.0 +0200
+++ /var/tmp/diff_new_pack.7ARaxO/_new  2016-06-19 12:52:57.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package geis
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,7 +26,11 @@
 Group:  System/GUI/Other
 Url:https://launchpad.net/geis
 Source: 
https://launchpad.net/%{name}/trunk/%{version}/+download/%{name}-%{version}.tar.xz
-Source1:baselibs.conf
+Source1:
https://launchpad.net/%{name}/trunk/%{version}/+download/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
+Source3:baselibs.conf
+# PATCH-FIX-OPENSUSE geis-disable-werror.patch boo#985131 sor.ale...@meowr.ru 
-- Disable -Werror.
+Patch0: %{name}-disable-werror.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  fdupes
@@ -86,6 +90,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 autoreconf -fi

++ geis-disable-werror.patch ++
--- a/configure.ac
+++ b/configure.ac
@@ -65,7 +65,7 @@ fi
 AC_DEFINE([GEIS_UNUSED],[__attribute__((unused))],[symbol is unused])
 
 AC_SUBST(AM_CFLAGS,
- "-Wall -Wextra -Werror -pedantic -std=iso9899:1999 -D_GNU_SOURCE=1")
+ "-Wall -Wextra -pedantic -std=iso9899:1999 -D_GNU_SOURCE=1")
 
 # Check for TDD tools
 PKG_CHECK_MODULES([CHECK], [check >= 0.9.8],
++ geis.keyring ++
 3308 lines (skipped)




commit kdebindings-smokeqt for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package kdebindings-smokeqt for 
openSUSE:Factory checked in at 2016-06-19 12:52:48

Comparing /work/SRC/openSUSE:Factory/kdebindings-smokeqt (Old)
 and  /work/SRC/openSUSE:Factory/.kdebindings-smokeqt.new (New)


Package is "kdebindings-smokeqt"

Changes:

--- /work/SRC/openSUSE:Factory/kdebindings-smokeqt/kdebindings-smokeqt.changes  
2014-11-19 20:27:52.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.kdebindings-smokeqt.new/kdebindings-smokeqt.changes 
2016-06-19 12:52:49.0 +0200
@@ -1,0 +2,5 @@
+Thu Jun 16 15:43:46 UTC 2016 - wba...@tmo.at
+
+- Use CMAKE_CXX_STANDARD=98 to fix build with gcc6 (boo#985059)
+
+---



Other differences:
--
++ kdebindings-smokeqt.spec ++
--- /var/tmp/diff_new_pack.Pq7gTH/_old  2016-06-19 12:52:50.0 +0200
+++ /var/tmp/diff_new_pack.Pq7gTH/_new  2016-06-19 12:52:50.0 +0200
@@ -60,7 +60,7 @@
 %setup -q -n smokeqt-%{version}
 
 %build
-  %cmake_kde4 -d build
+  %cmake_kde4 -d build -- -DCMAKE_CXX_STANDARD=98
   %make_jobs
 
 %install




commit python3-numexpr for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package python3-numexpr for openSUSE:Factory 
checked in at 2016-06-19 11:08:41

Comparing /work/SRC/openSUSE:Factory/python3-numexpr (Old)
 and  /work/SRC/openSUSE:Factory/.python3-numexpr.new (New)


Package is "python3-numexpr"

Changes:

--- /work/SRC/openSUSE:Factory/python3-numexpr/python3-numexpr.changes  
2016-05-25 21:24:59.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-numexpr.new/python3-numexpr.changes 
2016-06-19 11:08:58.0 +0200
@@ -1,0 +2,17 @@
+Sat Jun 18 18:05:31 UTC 2016 - a...@gmx.de
+
+- update to version 2.6.0:
+  * Introduced a new re_evaluate() function for re-evaluating the
+previous executed array expression without any check. This is
+meant for accelerating loops that are re-evaluating the same
+expression repeatedly without changing anything else than the
+operands. If unsure, use evaluate() which is safer.
+  * The BLOCK_SIZE1 and BLOCK_SIZE2 constants have been re-checked in
+order to find a value maximizing most of the benchmarks in bench/
+directory. The new values (8192 and 16 respectively) give somewhat
+better results (~5%) overall. The CPU used for fine tuning is a
+relatively new Haswell processor (E3-1240 v3).
+  * The '--name' flag for setup.py returning the name of the package
+is honored now (issue #215).
+
+---
@@ -7 +23,0 @@
-

Old:

  numexpr-2.5.2.tar.gz

New:

  numexpr-2.6.0.tar.gz



Other differences:
--
++ python3-numexpr.spec ++
--- /var/tmp/diff_new_pack.1hSqpj/_old  2016-06-19 11:08:59.0 +0200
+++ /var/tmp/diff_new_pack.1hSqpj/_new  2016-06-19 11:08:59.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python3-numexpr
-Version:2.5.2
+Version:2.6.0
 Release:0
 Url:https://github.com/pydata/numexpr
 Summary:Fast numerical expression evaluator for NumPy

++ numexpr-2.5.2.tar.gz -> numexpr-2.6.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/numexpr-2.5.2/ANNOUNCE.rst 
new/numexpr-2.6.0/ANNOUNCE.rst
--- old/numexpr-2.5.2/ANNOUNCE.rst  2016-04-07 11:35:39.0 +0200
+++ new/numexpr-2.6.0/ANNOUNCE.rst  2016-06-01 13:53:04.0 +0200
@@ -1,5 +1,5 @@
 =
- Announcing Numexpr 2.5.2
+ Announcing Numexpr 2.6.0
 =
 
 Numexpr is a fast numerical expression evaluator for NumPy.  With it,
@@ -21,11 +21,20 @@
 What's new
 ==
 
-This is a maintenance release shaking some remaining problems with VML
-(it is nice to see how Anaconda VML's support helps raising hidden
-issues).  Now conj() and abs() are actually added as VML-powered
-functions, preventing the same problems than log10() before (PR #212);
-thanks to Tom Kooij.  Upgrading to this release is highly recommended.
+This is a minor version bump because it introduces a new function.
+Also some minor fine tuning for recent CPUs has been done:
+
+- Introduced a new re_evaluate() function for re-evaluating the
+  previous executed array expression without any check.  This is meant
+  for accelerating loops that are re-evaluating the same expression
+  repeatedly without changing anything else than the operands.  If
+  unsure, use evaluate() which is safer.
+
+- The BLOCK_SIZE1 and BLOCK_SIZE2 constants have been re-checked in
+  order to find a value maximizing most of the benchmarks in bench/
+  directory.  The new values (8192 and 16 respectively) give somewhat
+  better results (~5%) overall.  The CPU used for fine tuning is a
+  relatively new Haswell processor (E3-1240 v3).
 
 In case you want to know more in detail what has changed in this
 version, see:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/numexpr-2.5.2/PKG-INFO new/numexpr-2.6.0/PKG-INFO
--- old/numexpr-2.5.2/PKG-INFO  2016-04-07 11:41:55.0 +0200
+++ new/numexpr-2.6.0/PKG-INFO  2016-06-01 13:58:34.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.0
 Name: numexpr
-Version: 2.5.2
+Version: 2.6.0
 Summary: Fast numerical expression evaluator for NumPy
 Home-page: https://github.com/pydata/numexpr
 Author: David M. Cooke, Francesc Alted and others
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/numexpr-2.5.2/README.rst new/numexpr-2.6.0/README.rst
--- old/numexpr-2.5.2/README.rst2016-04-07 11:40:55.0 +0200
+++ new/numexpr-2.6.0/README.rst2016-05-30 17:29:04.0 +0200
@@ -35,30 +35,31 @@
 This allows further acceleration of transcendent expressions.
 
 
-How Numexpr achieves high performance 

commit tomboy for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package tomboy for openSUSE:Factory checked 
in at 2016-06-19 11:08:31

Comparing /work/SRC/openSUSE:Factory/tomboy (Old)
 and  /work/SRC/openSUSE:Factory/.tomboy.new (New)


Package is "tomboy"

Changes:

--- /work/SRC/openSUSE:Factory/tomboy/tomboy.changes2016-03-11 
09:38:35.0 +0100
+++ /work/SRC/openSUSE:Factory/.tomboy.new/tomboy.changes   2016-06-19 
11:08:54.0 +0200
@@ -1,0 +2,8 @@
+Sat Jun 18 11:48:34 UTC 2016 - dims...@opensuse.org
+
+- Add tomboy-buildfix.patch: Fix build with make 4.2 (boo#985253,
+  bgo#767813).
+- Add libtool BuildRequires and call autoreconf, as above patch
+  touches the build system.
+
+---

New:

  tomboy-buildfix.patch



Other differences:
--
++ tomboy.spec ++
--- /var/tmp/diff_new_pack.HBfOFF/_old  2016-06-19 11:08:55.0 +0200
+++ /var/tmp/diff_new_pack.HBfOFF/_new  2016-06-19 11:08:55.0 +0200
@@ -26,6 +26,8 @@
 Group:  Productivity/Office/Other
 Url:http://projects.gnome.org/tomboy/
 Source: 
http://download.gnome.org/sources/tomboy/1.15/%{name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM tomboy-buildfix.patch boo#985253 bgo#767813 
dims...@opensuse.org -- Fix build with make 4.2
+Patch0: tomboy-buildfix.patch
 BuildRequires:  dbus-1-x11
 BuildRequires:  dbus-sharp-devel
 BuildRequires:  dbus-sharp-glib-devel
@@ -42,6 +44,7 @@
 BuildRequires:  gtk-sharp2
 BuildRequires:  gtkspell-devel
 BuildRequires:  intltool
+BuildRequires:  libtool
 BuildRequires:  libxslt-devel
 BuildRequires:  mono-basic
 BuildRequires:  mono-data-sqlite
@@ -71,10 +74,11 @@
 %lang_package
 %prep
 %setup -q
+%patch0 -p1
 translation-update-upstream
 
 %build
-#autoreconf -f -i
+autoreconf -f -i
 %configure\
 --disable-schemas-install\
 --disable-scrollkeeper\

++ tomboy-buildfix.patch ++
>From 90ae893f8503ba0a62df0a09af2e3ec9ae766eda Mon Sep 17 00:00:00 2001
From: Dominique Leuenberger 
Date: Sat, 18 Jun 2016 13:43:28 +0200
Subject: [PATCH] Build: fix building with recent make

---
 Tomboy/Makefile.am | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Tomboy/Makefile.am b/Tomboy/Makefile.am
index b1458ce..e2cb014 100644
--- a/Tomboy/Makefile.am
+++ b/Tomboy/Makefile.am
@@ -208,7 +208,7 @@ $(PANEL_WRAPPER): $(srcdir)/$(PANEL_WRAPPER).in Makefile
< $< > $@
chmod +x $(PANEL_WRAPPER)
 
-$(TARGET).config: $(srcdir)/$(TARGET_NAME$).config.in Makefile
+$(TARGET).config: $(srcdir)/$(TARGET_NAME).config.in Makefile
sed -e "s|\@pkglibdir\@|$(pkglibdir)|" \
< $< > $@
 
-- 
2.8.3




commit python3-setuptools_scm for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package python3-setuptools_scm for 
openSUSE:Factory checked in at 2016-06-19 11:08:37

Comparing /work/SRC/openSUSE:Factory/python3-setuptools_scm (Old)
 and  /work/SRC/openSUSE:Factory/.python3-setuptools_scm.new (New)


Package is "python3-setuptools_scm"

Changes:

--- 
/work/SRC/openSUSE:Factory/python3-setuptools_scm/python3-setuptools_scm.changes
2016-05-25 21:26:19.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python3-setuptools_scm.new/python3-setuptools_scm.changes
   2016-06-19 11:08:57.0 +0200
@@ -1,0 +2,8 @@
+Sat Jun 18 15:10:44 UTC 2016 - a...@gmx.de
+
+- update to version 1.11.1:
+  * fix issue #88 - better docs for sphinx usage (thanks Jason)
+  * fix issue #89 - use normpath to deal with windows (thanks Te-jé
+Rodgers for reporting and fixing)
+
+---
@@ -6 +13,0 @@
-

Old:

  setuptools_scm-1.11.0.tar.gz

New:

  setuptools_scm-1.11.1.tar.gz



Other differences:
--
++ python3-setuptools_scm.spec ++
--- /var/tmp/diff_new_pack.IV05on/_old  2016-06-19 11:08:58.0 +0200
+++ /var/tmp/diff_new_pack.IV05on/_new  2016-06-19 11:08:58.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python3-setuptools_scm
-Version:1.11.0
+Version:1.11.1
 Release:0
 Summary:The blessed package to manage your versions by scm tags
 License:MIT

++ setuptools_scm-1.11.0.tar.gz -> setuptools_scm-1.11.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools_scm-1.11.0/CHANGELOG.rst 
new/setuptools_scm-1.11.1/CHANGELOG.rst
--- old/setuptools_scm-1.11.0/CHANGELOG.rst 2016-04-06 10:37:26.0 
+0200
+++ new/setuptools_scm-1.11.1/CHANGELOG.rst 2016-06-12 23:09:53.0 
+0200
@@ -1,3 +1,10 @@
+v1.11.1
+
+
+* fix issue #88 - better docs for sphinx usage (thanks Jason)
+* fix issue #89 - use normpath to deal with windows
+  (thanks Te-jé Rodgers for reporting and fixing) 
+
 v1.11.0
 ===
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools_scm-1.11.0/PKG-INFO 
new/setuptools_scm-1.11.1/PKG-INFO
--- old/setuptools_scm-1.11.0/PKG-INFO  2016-04-06 10:37:48.0 +0200
+++ new/setuptools_scm-1.11.1/PKG-INFO  2016-06-12 23:10:13.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: setuptools_scm
-Version: 1.11.0
+Version: 1.11.1
 Summary: the blessed package to manage your versions by scm tags
 Home-page: https://github.com/pypa/setuptools_scm/
 Author: Ronny Pfannschmidt
@@ -43,12 +43,13 @@
 Programmatic usage
 --
 
-In oder to use setuptools_scm for sphinx config
+In order to use setuptools_scm for sphinx config, assuming the sphinx 
conf
+is one directory deeper than the project's root, use::
 
 .. code:: python
 
 from setuptools_scm import get_version
-version = get_version()
+version = get_version(root='..', relative_to=__file__)
 
 
 Notable Plugins
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools_scm-1.11.0/README.rst 
new/setuptools_scm-1.11.1/README.rst
--- old/setuptools_scm-1.11.0/README.rst2016-04-06 10:37:26.0 
+0200
+++ new/setuptools_scm-1.11.1/README.rst2016-06-12 23:09:53.0 
+0200
@@ -35,12 +35,13 @@
 Programmatic usage
 --
 
-In oder to use setuptools_scm for sphinx config
+In order to use setuptools_scm for sphinx config, assuming the sphinx conf
+is one directory deeper than the project's root, use::
 
 .. code:: python
 
 from setuptools_scm import get_version
-version = get_version()
+version = get_version(root='..', relative_to=__file__)
 
 
 Notable Plugins
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools_scm-1.11.0/setup.py 
new/setuptools_scm-1.11.1/setup.py
--- old/setuptools_scm-1.11.0/setup.py  2016-04-06 10:37:48.0 +0200
+++ new/setuptools_scm-1.11.1/setup.py  2016-06-12 23:10:13.0 +0200
@@ -63,7 +63,7 @@
 url='https://github.com/pypa/setuptools_scm/',
 zip_safe=True,
 # pass here since entrypints are not yet registred
-version="1.11.0",
+version="1.11.1",
 author='Ronny Pfannschmidt',
 author_email='opensou...@ronnypfannschmidt.de',
 description=('the blessed package to manage your versions by scm tags'),
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit VirtualGL for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package VirtualGL for openSUSE:Factory 
checked in at 2016-06-19 11:08:24

Comparing /work/SRC/openSUSE:Factory/VirtualGL (Old)
 and  /work/SRC/openSUSE:Factory/.VirtualGL.new (New)


Package is "VirtualGL"

Changes:

--- /work/SRC/openSUSE:Factory/VirtualGL/VirtualGL.changes  2015-09-17 
09:18:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.VirtualGL.new/VirtualGL.changes 2016-06-19 
11:08:49.0 +0200
@@ -1,0 +2,13 @@
+Thu Jun 16 15:30:58 UTC 2016 - tchva...@suse.com
+
+- Version update to 2.5 release
+  * See upstream changelog for details
+  * Mostly removal of compat for pre-VirtualGL namespace
+- Refresh patch VirtualGL-link-libs.patch
+
+---
+Thu Jun 16 15:21:54 UTC 2016 - norm...@linux.vnet.ibm.com
+
+- new gcc6_literal_suffixes.patch
+
+---

Old:

  VirtualGL-2.4.1.tar.gz

New:

  VirtualGL-2.5.tar.gz
  gcc6_literal_suffixes.patch



Other differences:
--
++ VirtualGL.spec ++
--- /var/tmp/diff_new_pack.fl4yMo/_old  2016-06-19 11:08:50.0 +0200
+++ /var/tmp/diff_new_pack.fl4yMo/_new  2016-06-19 11:08:50.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package VirtualGL
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   VirtualGL
-Version:2.4.1
+Version:2.5
 Release:0
 Summary:A toolkit for displaying OpenGL applications to thin clients
 License:LGPL-2.1 and SUSE-wxWidgets-3.1
@@ -26,20 +26,23 @@
 Source0:
http://downloads.sourceforge.net/virtualgl/%{name}-%{version}.tar.gz
 Source1:baselibs.conf
 Patch1: VirtualGL-link-libs.patch
+Patch2: gcc6_literal_suffixes.patch
 BuildRequires:  Mesa-devel
 BuildRequires:  Mesa-libGLU-devel
 BuildRequires:  cmake
 BuildRequires:  fltk-devel
 BuildRequires:  gcc-c++
 BuildRequires:  glibc-devel
-BuildRequires:  glu-devel
 BuildRequires:  libjpeg-devel
-BuildRequires:  libopenssl-devel
-# Fixme: Remove after 13.1 is out of scope, there is broken devel package on 
older
-BuildRequires:  libturbojpeg0
-BuildRequires:  xorg-x11-libX11-devel
-BuildRequires:  xorg-x11-libXext-devel
-BuildRequires:  xorg-x11-libXv-devel
+BuildRequires:  pkgconfig
+BuildRequires:  pkgconfig(glu)
+BuildRequires:  pkgconfig(libcrypto)
+BuildRequires:  pkgconfig(libssl)
+BuildRequires:  pkgconfig(openssl)
+BuildRequires:  pkgconfig(x11)
+BuildRequires:  pkgconfig(x11-xcb)
+BuildRequires:  pkgconfig(xext)
+BuildRequires:  pkgconfig(xv)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -90,6 +93,7 @@
 %prep
 %setup -q
 %patch1 -p1
+%patch2 -p1
 
 # Use /var/lib
 sed -e "s#%{_sysconfdir}/opt#%{_localstatedir}/lib#g" \
@@ -120,14 +124,13 @@
 # Fix fakelib placement
 rm -rf %{buildroot}%{_prefix}/fakelib
 mkdir -p %{buildroot}%{_libdir}/fakelib
-ln -sf ../librrfaker.so %{buildroot}%{_libdir}/fakelib/libGL.so
+ln -sf ../libvglfaker.so %{buildroot}%{_libdir}/fakelib/libGL.so
 # Docs had wrong names
 chmod 644 doc/LGPL.txt doc/LICENSE.txt doc/index.html doc/*.png doc/*.gif 
doc/*.css
 rm -rf %{buildroot}%{_prefix}/doc
 mv -f %{buildroot}%{_bindir}/glxinfo %{buildroot}%{_bindir}/glxinfo2
 
 %post -p /sbin/ldconfig
-
 %postun -p /sbin/ldconfig
 
 %files
@@ -155,8 +158,9 @@
 %{_bindir}/vglrun
 %{_bindir}/glreadtest
 %{_libdir}/fakelib/libGL.so
-%{_libdir}/librrfaker.so
+%{_libdir}/libvglfaker.so
 %{_libdir}/libdlfaker.so
+%{_libdir}/libvglfaker-nodl.so
 %{_libdir}/libgefaker.so
 
 %files devel

++ VirtualGL-2.4.1.tar.gz -> VirtualGL-2.5.tar.gz ++
 42687 lines of diff (skipped)

++ VirtualGL-link-libs.patch ++
--- /var/tmp/diff_new_pack.fl4yMo/_old  2016-06-19 11:08:51.0 +0200
+++ /var/tmp/diff_new_pack.fl4yMo/_new  2016-06-19 11:08:51.0 +0200
@@ -1,28 +1,28 @@
-Index: VirtualGL-2.4.1/server/CMakeLists.txt
+Index: VirtualGL-2.5/server/CMakeLists.txt
 ===
 VirtualGL-2.4.1.orig/server/CMakeLists.txt
-+++ VirtualGL-2.4.1/server/CMakeLists.txt
-@@ -95,12 +95,12 @@ install(CODE "execute_process(COMMAND ${
-   \$ENV{DESTDIR}${VGL_FAKELIBDIR}/libGL.so)")
+--- VirtualGL-2.5.orig/server/CMakeLists.txt
 VirtualGL-2.5/server/CMakeLists.txt
+@@ -102,12 +102,12 @@ foreach(fakerlib ${VGL_FAKER_NAME} ${VGL
+ endforeach()
  
  add_library(${VGL_DLFAKER_NAME} SHARED dlfaker.c)
 

commit openttd for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package openttd for openSUSE:Factory checked 
in at 2016-06-19 11:08:27

Comparing /work/SRC/openSUSE:Factory/openttd (Old)
 and  /work/SRC/openSUSE:Factory/.openttd.new (New)


Package is "openttd"

Changes:

--- /work/SRC/openSUSE:Factory/openttd/openttd.changes  2016-04-12 
19:37:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.openttd.new/openttd.changes 2016-06-19 
11:08:51.0 +0200
@@ -1,0 +2,5 @@
+Thu Jun 16 18:18:17 UTC 2016 - dims...@opensuse.org
+
+- Update openttd-gcc5.patch: Have gcc6 use the same flags as gcc5.
+
+---



Other differences:
--
++ openttd-gcc5.patch ++
--- /var/tmp/diff_new_pack.nrevof/_old  2016-06-19 11:08:52.0 +0200
+++ /var/tmp/diff_new_pack.nrevof/_new  2016-06-19 11:08:52.0 +0200
@@ -1,17 +1,30 @@
-Index: openttd-1.5.1/config.lib
+Index: openttd-1.5.3/config.lib
 ===
 openttd-1.5.1.orig/config.lib
-+++ openttd-1.5.1/config.lib
+--- openttd-1.5.3.orig/config.lib
 openttd-1.5.3/config.lib
 @@ -1317,7 +1317,11 @@ make_compiler_cflags() {
ldflags="$ldflags -rdynamic"
else
# Enable some things only for certain GCC versions
 -  cc_version=`$1 -dumpversion | cut -c 1,3`
 +cc_version=`$1 -dumpversion | cut -c 1,3`
-+if [ $cc_version -eq 5 ]; then
++if [ $cc_version -ge 5 ]; then
 +# Special case: GCC 5.0 reports only '5'
 +cc_version=50
 +fi
  
if [ $cc_version -lt 33 ]; then
log 1 "configure: error: gcc older than 3.3 can't 
compile OpenTTD because of its poor template support"
+Index: openttd-1.5.3/src/safeguards.h
+===
+--- openttd-1.5.3.orig/src/safeguards.h
 openttd-1.5.3/src/safeguards.h
+@@ -21,6 +21,8 @@
+ #ifndef SAFEGUARDS_H
+ #define SAFEGUARDS_H
+ 
++#include 
++
+ /* Use MallocT instead. */
+ #define mallocSAFEGUARD_DO_NOT_USE_THIS_METHOD
+ 




commit 7kaa for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package 7kaa for openSUSE:Factory checked in 
at 2016-06-19 11:08:28

Comparing /work/SRC/openSUSE:Factory/7kaa (Old)
 and  /work/SRC/openSUSE:Factory/.7kaa.new (New)


Package is "7kaa"

Changes:

--- /work/SRC/openSUSE:Factory/7kaa/7kaa.changes2015-10-06 
13:24:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.7kaa.new/7kaa.changes   2016-06-19 
11:08:52.0 +0200
@@ -1,0 +2,6 @@
+Thu Jun 16 14:03:33 UTC 2016 - norm...@linux.vnet.ibm.com
+
+- new gcc6_char_cast.patch proposal for upstream issue
+  https://github.com/the3dfxdude/7kaa/issues/63
+
+---

New:

  gcc6_char_cast.patch



Other differences:
--
++ 7kaa.spec ++
--- /var/tmp/diff_new_pack.Agse9B/_old  2016-06-19 11:08:53.0 +0200
+++ /var/tmp/diff_new_pack.Agse9B/_new  2016-06-19 11:08:53.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package 7kaa
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -30,6 +30,7 @@
 Patch0: %{name}-2.14.5.patch
 # PATCH-FIX-UPSTREAM - patch buffer overflow due to wrong size assumptions
 Patch1: %{name}-2.14.5_overflow.patch
+Patch2: gcc6_char_cast.patch
 Source1:%{name}.png
 Source2:%{name}.desktop
 %if 0%{?suse_version}
@@ -64,6 +65,7 @@
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 export CXXFLAGS="%{optflags} -fno-strict-aliasing"


++ gcc6_char_cast.patch ++
 646 lines (skipped)




commit python3-pyparsing for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package python3-pyparsing for 
openSUSE:Factory checked in at 2016-06-19 11:08:35

Comparing /work/SRC/openSUSE:Factory/python3-pyparsing (Old)
 and  /work/SRC/openSUSE:Factory/.python3-pyparsing.new (New)


Package is "python3-pyparsing"

Changes:

--- /work/SRC/openSUSE:Factory/python3-pyparsing/python3-pyparsing.changes  
2016-05-25 21:25:41.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-pyparsing.new/python3-pyparsing.changes 
2016-06-19 11:08:56.0 +0200
@@ -1,0 +2,69 @@
+Sat Jun 18 15:19:06 UTC 2016 - a...@gmx.de
+
+- update to version 2.1.5:
+  * Added ParserElement.split() generator method, similar to
+re.split().  Includes optional arguments maxsplit (to limit the
+number of splits), and includeSeparators (to include the
+separating matched text in the returned output, default=False).
+  * Added a new parse action construction helper tokenMap, which will
+apply a function and optional arguments to each element in a
+ParseResults.
+  * Added more expressions to pyparsing_common:
++ IPv4 and IPv6 addresses (including long, short, and mixed
+  forms of IPv6)
++ MAC address
++ ISO8601 date and date time strings (with named fields for
+  year, month, etc.)
++ UUID (----)
++ hex integer (returned as int)
++ fraction (integer '/' integer, returned as float)
++ mixed integer (integer '-' fraction, or just fraction,
+  returned as float)
++ stripHTMLTags (parse action to remove tags from HTML source)
++ parse action helpers convertToDate and convertToDatetime to do
+  custom parse time conversions of parsed ISO8601 strings
+  * runTests now returns a two-tuple: success if all tests succeed,
+and an output list of each test and its output lines.
+  * Added failureTests argument (default=False) to runTests, so that
+tests can be run that are expected failures, and runTests' success
+value will return True only if all tests *fail* as expected. Also,
+parseAll now defaults to True.
+  * New example numerics.py, shows samples of parsing integer and real
+numbers using locale-dependent formats
+
+- changes from version 2.1.4:
+  * Split out the '==' behavior in ParserElement, now implemented as
+the ParserElement.matches() method. Using '==' for string test
+purposes will be removed in a future release.
+  * Expanded capabilities of runTests(). Will now accept embedded
+comments (default is Python style, leading '#' character, but
+customizable). Comments will be emitted along with the tests and
+test output. Useful during test development, to create a test
+string consisting only of test case description comments separated
+by blank lines, and then fill in the test cases. Will also
+highlight ParseFatalExceptions with "(FATAL)".
+  * Added a 'pyparsing_common' class containing common/helpful little
+expressions such as integer, float, identifier, etc. I used this
+class as a sort of embedded namespace, to contain these helpers
+without further adding to pyparsing's namespace bloat.
+  * Minor enhancement to traceParseAction decorator, to retain the
+parse action's name for the trace output.
+  * Added optional 'fatal' keyword arg to addCondition, to indicate
+that a condition failure should halt parsing immediately.
+
+- changes from version 2.1.3:
+  * _trim_arity fix in 2.1.2 was very version-dependent on Py 3.5.0.
+Now works for Python 2.x, 3.3, 3.4, 3.5.0, and 3.5.1 (and
+hopefully beyond).
+
+- changes from version 2.1.2:
+  * Fixed bug in _trim_arity when pyparsing code is included in a
+PyInstaller, reported by maluwa.
+  * Fixed catastrophic regex backtracking in implementation of the
+quoted string expressions (dblQuotedString, sglQuotedString, and
+quotedString). Reported on the pyparsing wiki by webpentest, good
+catch! (Also tuned up some other expressions susceptible to the
+same backtracking problem, such as cStyleComment, cppStyleComment,
+etc.)
+
+---
@@ -7 +75,0 @@
-

Old:

  pyparsing-2.1.1.tar.gz

New:

  pyparsing-2.1.5.tar.gz



Other differences:
--
++ python3-pyparsing.spec ++
--- /var/tmp/diff_new_pack.qRN9Nb/_old  2016-06-19 11:08:57.0 +0200
+++ /var/tmp/diff_new_pack.qRN9Nb/_new  2016-06-19 11:08:57.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python3-pyparsing
-Version:2.1.1
+Version:2.1.5
 Release:0
 Url:http://pyparsing.wikispaces.com/
 Summary:Grammar Parser Library for Python

++ pyparsing-2.1.1.tar.gz -> 

commit supertuxkart for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package supertuxkart for openSUSE:Factory 
checked in at 2016-06-19 11:08:22

Comparing /work/SRC/openSUSE:Factory/supertuxkart (Old)
 and  /work/SRC/openSUSE:Factory/.supertuxkart.new (New)


Package is "supertuxkart"

Changes:

--- /work/SRC/openSUSE:Factory/supertuxkart/supertuxkart.changes
2015-10-24 10:29:56.0 +0200
+++ /work/SRC/openSUSE:Factory/.supertuxkart.new/supertuxkart.changes   
2016-06-19 11:08:35.0 +0200
@@ -1,0 +2,18 @@
+Thu Jun 16 13:42:10 UTC 2016 - dims...@opensuse.org
+
+- Update to version 0.9.2-rc2:
+  + Ghost replay races.
+  + Battle mode AI.
+  + Soccer mode AI.
+  + New icy soccer field.
+  + New subsea track.
+  + New volcano track.
+  + TTF font rendering.
+  + Kart properties refactor.
+  + Scripting work under the hood.
+  + Work on the track editor.
+  + Tweak to challenges.
+  + New farm track song.
+  + Bugfixes.
+
+---

Old:

  supertuxkart-0.9.1-src.tar.xz

New:

  supertuxkart-0.9.2-rc1-src.tar.xz



Other differences:
--
++ supertuxkart.spec ++
--- /var/tmp/diff_new_pack.XUvhOK/_old  2016-06-19 11:08:49.0 +0200
+++ /var/tmp/diff_new_pack.XUvhOK/_new  2016-06-19 11:08:49.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package supertuxkart
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,13 +17,13 @@
 
 
 Name:   supertuxkart
-Version:0.9.1
+Version:0.9.2~rc1
 Release:0
 Summary:A 3D kart racing game
 License:GPL-2.0+ and GPL-3.0+ and CC-BY-SA-3.0
 Group:  Amusements/Games/3D/Race
 Url:http://supertuxkart.sourceforge.net/
-Source: 
http://sourceforge.net/projects/supertuxkart/files/SuperTuxKart/%{version}/%{name}-%{version}-src.tar.xz
+Source: 
http://sourceforge.net/projects/supertuxkart/files/SuperTuxKart/0.9.2/%{name}-0.9.2-rc1-src.tar.xz
 # Geeko kart add-on (CC-BY 3.0)
 Source1:http://stkaddons.net/dl/14e6ba25b17f0d.zip
 BuildRequires:  bluez-devel
@@ -45,6 +45,7 @@
 BuildRequires:  openal-soft-devel
 BuildRequires:  unzip
 BuildRequires:  update-desktop-files
+BuildRequires:  pkgconfig(freetype2)
 BuildRequires:  pkgconfig(gl)
 Requires:   %{name}-data = %{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -73,7 +74,7 @@
 Data files for SuperTuxKart a Free 3d kart racing game.
 
 %prep
-%setup -q
+%setup -q -n %{name}-0.9.2-rc1
 find -name '*~' -delete -print
 
 %build





commit dasher for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package dasher for openSUSE:Factory checked 
in at 2016-06-19 11:08:33

Comparing /work/SRC/openSUSE:Factory/dasher (Old)
 and  /work/SRC/openSUSE:Factory/.dasher.new (New)


Package is "dasher"

Changes:

--- /work/SRC/openSUSE:Factory/dasher/dasher.changes2014-02-12 
11:09:16.0 +0100
+++ /work/SRC/openSUSE:Factory/.dasher.new/dasher.changes   2016-06-19 
11:08:55.0 +0200
@@ -1,0 +2,6 @@
+Sat Jun 18 12:08:57 UTC 2016 - dims...@opensuse.org
+
+- Add dasher-gcc6.patch: Fix build with gcc 6 (bool can't be used
+  as return value for functions returning string) (boo#985108).
+
+---

New:

  dasher-gcc6.patch



Other differences:
--
++ dasher.spec ++
--- /var/tmp/diff_new_pack.Qmyu1X/_old  2016-06-19 11:08:56.0 +0200
+++ /var/tmp/diff_new_pack.Qmyu1X/_new  2016-06-19 11:08:56.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package dasher
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -28,6 +28,8 @@
 Source2:locale-map.txt
 # PATCH-FIX-UPSTREAM dasher-linkX11.patch bgo#657306 dims...@opensuse.org -- 
Remove unneded code requiring to link against libX11.
 Patch0: dasher-linkX11.patch
+# PATCH-FIX-UPSTREAM dasher-gcc6.patch boo#985108 dims...@opensuse.org -- Fix 
build with gcc 6 (bool can't be used as return value for functions returning 
string)
+Patch1: dasher-gcc6.patch
 BuildRequires:  cairo-devel
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
@@ -85,6 +87,7 @@
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 translation-update-upstream
 cp %{SOURCE2} .
 

++ dasher-gcc6.patch ++
Index: dasher-4.11/Src/DasherCore/SettingsStore.cpp
===
--- dasher-4.11.orig/Src/DasherCore/SettingsStore.cpp
+++ dasher-4.11/Src/DasherCore/SettingsStore.cpp
@@ -295,7 +295,7 @@ std::string CSettingsStore::GetStringOpt
 
   // This means the key passed in a string was not found in the new table
   DASHER_ASSERT(0);
-  return false;
+  return NULL;
 }
 
 void CSettingsStore::SetBoolOption(const std::string , bool Value) {
Index: dasher-4.11/Src/Gtk2/DasherAppSettings.cpp
===
--- dasher-4.11.orig/Src/Gtk2/DasherAppSettings.cpp
+++ dasher-4.11/Src/Gtk2/DasherAppSettings.cpp
@@ -389,7 +389,7 @@ const gchar *dasher_app_settings_get_str
 if(pPrivate->bWidgetSet) 
   return 
gtk_dasher_control_get_parameter_string(GTK_DASHER_CONTROL(pDasherWidget), 
iParameter);
 else
-  return false;
+  return NULL;
   }
   else
 return app_stringparamtable[ iParameter - FIRST_APP_SP ].value;



commit notmuch for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package notmuch for openSUSE:Factory checked 
in at 2016-06-19 10:50:46

Comparing /work/SRC/openSUSE:Factory/notmuch (Old)
 and  /work/SRC/openSUSE:Factory/.notmuch.new (New)


Package is "notmuch"

Changes:

--- /work/SRC/openSUSE:Factory/notmuch/notmuch.changes  2015-08-01 
11:35:12.0 +0200
+++ /work/SRC/openSUSE:Factory/.notmuch.new/notmuch.changes 2016-06-19 
10:50:51.0 +0200
@@ -1,0 +2,24 @@
+Sat Jun 18 10:04:44 UTC 2016 - l...@suse.com
+
+- version 0.22
+  - Xapian 1.3 support
+  - Limited support for S/MIME messages
+  - Fix for threading bug involving deleting and re-adding messages. 
+  - Fix for case-sensitive content disposition headers.
+  - Fix handling of 1 character directory names at top level.
+  - Emacs: Notmuch replies now include all parts shown in the show view
+  - Emacs: Filtering or Limiting messages is now bound to `l` in the
+search view
+  - Emacs: `F` forwards all open messages in a thread
+  - Emacs: Preferred content type can be determined from the message
+content
+- version 0.21
+  - Notmuch now requires gmime >= 2.6.7. The gmime 2.4 series is no
+longer supported.
+  - Database revision tracking: `lastmod:` queries
+  - Date queries now support `date:..!` shorthand for
+`date:..`
+  - Notmuch database upgrade to support `lastmod:` queries
+  - The `notmuch address` command supports new deduplication schemes
+  
+---

Old:

  notmuch-0.20.2.tar.gz
  notmuch-0.20.2.tar.gz.sha1
  notmuch-0.20.2.tar.gz.sha1.asc

New:

  notmuch-0.22.tar.gz
  notmuch-0.22.tar.gz.sha1
  notmuch-0.22.tar.gz.sha1.asc



Other differences:
--
++ notmuch.spec ++
--- /var/tmp/diff_new_pack.3bdx0S/_old  2016-06-19 10:50:52.0 +0200
+++ /var/tmp/diff_new_pack.3bdx0S/_new  2016-06-19 10:50:52.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package notmuch
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   notmuch
-Version:0.20.2
+Version:0.22
 Release:0
 Summary:The mail indexer
 License:GPL-3.0+

++ notmuch-0.20.2.tar.gz -> notmuch-0.22.tar.gz ++
 12154 lines of diff (skipped)

++ notmuch-0.20.2.tar.gz.sha1 -> notmuch-0.22.tar.gz.sha1 ++
--- /work/SRC/openSUSE:Factory/notmuch/notmuch-0.20.2.tar.gz.sha1   
2015-08-01 11:35:12.0 +0200
+++ /work/SRC/openSUSE:Factory/.notmuch.new/notmuch-0.22.tar.gz.sha1
2016-06-19 10:50:51.0 +0200
@@ -1 +1 @@
-1aba10c86af29cc5b372b81f1780290bebff7f26  notmuch-0.20.2.tar.gz
+c3c3c805cd821aca0966e46dffd56d37d42f2616  notmuch-0.22.tar.gz




commit libpfm for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package libpfm for openSUSE:Factory checked 
in at 2016-06-19 10:50:19

Comparing /work/SRC/openSUSE:Factory/libpfm (Old)
 and  /work/SRC/openSUSE:Factory/.libpfm.new (New)


Package is "libpfm"

Changes:

--- /work/SRC/openSUSE:Factory/libpfm/libpfm.changes2016-01-22 
01:10:13.0 +0100
+++ /work/SRC/openSUSE:Factory/.libpfm.new/libpfm.changes   2016-06-19 
10:50:22.0 +0200
@@ -1,0 +2,11 @@
+Fri Jun 17 08:00:28 UTC 2016 - tchva...@suse.com
+
+- Version bump to 4.7.0:
+  * Intel Skylake core PMU
+  * Intel Haswell-EP uncore PMUs
+  * Intel Broadwell-DE
+  * Major update on Intel event tables
+  * bug fixes and many other improvements
+- Respect cflags, disable werror bnc#985166
+
+---

Old:

  libpfm-4.6.0.tar.gz

New:

  libpfm-4.7.0.tar.gz



Other differences:
--
++ libpfm.spec ++
--- /var/tmp/diff_new_pack.gXxgZe/_old  2016-06-19 10:50:23.0 +0200
+++ /var/tmp/diff_new_pack.gXxgZe/_new  2016-06-19 10:50:23.0 +0200
@@ -18,7 +18,7 @@
 
 %define vname   libpfm4
 Name:   libpfm
-Version:4.6.0
+Version:4.7.0
 Release:0
 Summary:Library to encode performance events
 License:MIT
@@ -75,8 +75,13 @@
 
 %prep
 %setup -q
+# disable werror
+sed -i \
+-e 's:-Werror::g' \
+config.mk
 
 %build
+export CFLAGS="%{optflags}"
 %global python_config CONFIG_PFMLIB_NOPYTHON=n
 make %{?_smp_mflags} %{python_config}
 

++ libpfm-4.6.0.tar.gz -> libpfm-4.7.0.tar.gz ++
 21030 lines of diff (skipped)




commit openxcom for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package openxcom for openSUSE:Factory 
checked in at 2016-06-19 10:50:21

Comparing /work/SRC/openSUSE:Factory/openxcom (Old)
 and  /work/SRC/openSUSE:Factory/.openxcom.new (New)


Package is "openxcom"

Changes:

--- /work/SRC/openSUSE:Factory/openxcom/openxcom.changes2016-03-29 
10:40:05.0 +0200
+++ /work/SRC/openSUSE:Factory/.openxcom.new/openxcom.changes   2016-06-19 
10:50:23.0 +0200
@@ -1,0 +2,6 @@
+Fri Jun 17 08:17:08 UTC 2016 - tchva...@suse.com
+
+- Add patch fixing gcc6 build bnc#985174:
+  * openxcom-abs.patch
+
+---

New:

  openxcom-abs.patch



Other differences:
--
++ openxcom.spec ++
--- /var/tmp/diff_new_pack.IbP5ID/_old  2016-06-19 10:50:24.0 +0200
+++ /var/tmp/diff_new_pack.IbP5ID/_new  2016-06-19 10:50:24.0 +0200
@@ -25,6 +25,8 @@
 Url:http://openxcom.org/
 # Interesting approach to count downloads http://openxcom.org/file/1726/
 Source: %{name}-%{version}.tar.gz
+# PATCH-FIX-UPSTREAM: gcc6 compat, taken from git
+Patch0: openxcom-abs.patch
 BuildRequires:  Mesa-devel
 BuildRequires:  SDL-devel
 BuildRequires:  SDL_gfx-devel >= 2.0.22
@@ -61,6 +63,8 @@
 
 %prep
 %setup -q
+%patch0 -p1
+
 chmod -x LICENSE.txt
 sed -i \
-e 's:HTML_TIMESTAMP = YES:HTML_TIMESTAMP = NO:g' \

++ openxcom-abs.patch ++
>From 49bec0851fc6e5365cac0f71b2c40a80ddf95e77 Mon Sep 17 00:00:00 2001
From: Louis Delacroix 
Date: Sun, 16 Nov 2014 20:47:41 +
Subject: [PATCH] Fix use of abs() for floating point arguments

---
 src/Battlescape/ProjectileFlyBState.cpp | 2 +-
 src/Geoscape/Globe.cpp  | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/Battlescape/ProjectileFlyBState.cpp 
b/src/Battlescape/ProjectileFlyBState.cpp
index c890d12..2ea67ae 100644
--- a/src/Battlescape/ProjectileFlyBState.cpp
+++ b/src/Battlescape/ProjectileFlyBState.cpp
@@ -651,7 +651,7 @@ int ProjectileFlyBState::getMaxThrowDistance(int weight, 
int strength, int level
 if (curZ < 0 && dz < 0) //roll back
 {
 dz = std::max(dz, -1.0);
-if (abs(dz)>1e-10) //rollback horizontal
+if (std::abs(dz)>1e-10) //rollback horizontal
 dist -= curZ / dz;
 break;
 }
diff --git a/src/Geoscape/Globe.cpp b/src/Geoscape/Globe.cpp
index e5249ce..1a360dd 100755
--- a/src/Geoscape/Globe.cpp
+++ b/src/Geoscape/Globe.cpp
@@ -1217,12 +1217,12 @@ void Globe::drawVHLine(Surface *surface, double lon1, 
double lat1, double lon2,
 
if (fabs(sx)<0.01)
{
-   seg = abs( sy/(2*M_PI)*48 );
+   seg = std::abs(sy/(2*M_PI)*48);
if (seg == 0) ++seg;
}
else
{
-   seg = abs( sx/(2*M_PI)*96 );
+   seg = std::abs(sx/(2*M_PI)*96);
if (seg == 0) ++seg;
}
 



commit simplescreenrecorder for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package simplescreenrecorder for 
openSUSE:Factory checked in at 2016-06-19 10:50:37

Comparing /work/SRC/openSUSE:Factory/simplescreenrecorder (Old)
 and  /work/SRC/openSUSE:Factory/.simplescreenrecorder.new (New)


Package is "simplescreenrecorder"

Changes:

--- 
/work/SRC/openSUSE:Factory/simplescreenrecorder/simplescreenrecorder.changes
2015-11-04 15:34:31.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.simplescreenrecorder.new/simplescreenrecorder.changes
   2016-06-19 10:50:40.0 +0200
@@ -1,0 +2,9 @@
+Fri Jun 17 16:22:18 UTC 2016 - dap.darkn...@gmail.com
+
+- `spec-cleaner`
+- Added simplescreenrecorder-0.3.6-missing-include.diff
+  to resolve bnc#985369.
+- Tips from Packman's package.
+- Enabled verbose make build.
+
+---

New:

  simplescreenrecorder-0.3.6-missing-include.diff



Other differences:
--
++ simplescreenrecorder.spec ++
--- /var/tmp/diff_new_pack.HtDKz1/_old  2016-06-19 10:50:41.0 +0200
+++ /var/tmp/diff_new_pack.HtDKz1/_new  2016-06-19 10:50:41.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package simplescreenrecorder
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -25,11 +25,15 @@
 Url:http://www.maartenbaert.be/simplescreenrecorder
 Source: https://github.com/MaartenBaert/ssr/archive/%{version}.tar.gz
 Source9:baselibs.conf
+# PATCH-FIX-UPSTREAM vs. "error: 'mt19937' is not a member of 'std'".
+# See more at https://github.com/MaartenBaert/ssr/issues/455 & bnc#985369.
+Patch0: simplescreenrecorder-0.3.6-missing-include.diff
 
 BuildRequires:  cmake
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  libjpeg8-devel
 BuildRequires:  libqt5-linguist
+BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(Qt5Gui)   >= 5.1
 BuildRequires:  pkgconfig(Qt5Widgets)   >= 5.1
@@ -38,14 +42,16 @@
 BuildRequires:  pkgconfig(gl)
 BuildRequires:  pkgconfig(glu)
 BuildRequires:  pkgconfig(jack)
-BuildRequires:  pkgconfig(libavformat)
+BuildRequires:  pkgconfig(libavcodec) >= 53
+BuildRequires:  pkgconfig(libavformat) >= 53
+BuildRequires:  pkgconfig(libavutil) >= 51
 BuildRequires:  pkgconfig(libpulse)
-BuildRequires:  pkgconfig(libswscale)
+BuildRequires:  pkgconfig(libswscale) >= 2
 BuildRequires:  pkgconfig(x11)
 BuildRequires:  pkgconfig(xext)
 BuildRequires:  pkgconfig(xfixes)
 BuildRequires:  pkgconfig(xi)
-%ifarch %ix86 x86_64
+%ifarch %{ix86} x86_64
 # openGL apps:
 Recommends: libssr-glinject
 %if %{_lib} == "lib64"
@@ -88,7 +94,7 @@
out what something does.
 
 
-%ifarch %ix86 x86_64
+%ifarch %{ix86} x86_64
 %package -n libssr-glinject
 Summary:Simple Screen Recorder openGL plugin
 License:MIT
@@ -103,16 +109,17 @@
 
 %prep
 %setup -q -n ssr-%{version}
+%patch0 -p1
 
 %build
-%ifarch %ix86 x86_64
+%ifarch %{ix86} x86_64
 # /usr/include/qt5/QtCore/qglobal.h:1067:4: error: error "You must build
 # your code with position independent code if Qt was built with
 # -reduce-relocations. " "Compile your code with -fPIC (-fPIE is not
 # enough)." error "You must build your code with position independent code
 # if Qt was built with -reduce-relocations."
-export CFLAGS="%optflags -fPIC"
-export CXXFLAGS="%optflags -fPIC"
+export CFLAGS="%{optflags} -fPIC"
+export CXXFLAGS="%{optflags} -fPIC"
 %configure --with-qt5
 %else
 %configure \
@@ -120,11 +127,11 @@
--disable-x86-asm \
--disable-glinjectlib
 %endif
-make %{?_smp_mflags}
+make V=1 %{?_smp_mflags}
 
 %install
-%make_install
-find %{buildroot} -name *.la -delete
+%make_install V=1
+find %{buildroot} -type f -name "*.la" -delete -print
 %suse_update_desktop_file %{name}
 
 %post
@@ -146,7 +153,7 @@
 %{_mandir}/*/%{name}*
 %{_mandir}/*/ssr-glinject*
 
-%ifarch %ix86 x86_64
+%ifarch %{ix86} x86_64
 %files -n libssr-glinject
 %defattr(-,root,root)
 %{_libdir}/libssr-glinject.so

++ simplescreenrecorder-0.3.6-missing-include.diff ++
diff --git a/aclocal.m4 b/aclocal.m4
index 8b5415e..555b53d 100644
--- a/aclocal.m4
+++ b/aclocal.m4
@@ -21,7 +21,7 @@ If you have problems, you may need to regenerate the build 
system entirely.
 To do so, use the procedure documented by the package, typically 
'autoreconf'.])])
 
 dnl pkg.m4 - Macros to locate and utilise pkg-config.   -*- Autoconf -*-
-dnl serial 11 (pkg-config-0.29)
+dnl serial 11 (pkg-config-0.29.1)
 dnl
 dnl Copyright © 2004 Scott James Remnant 

commit php5-phalcon for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package php5-phalcon for openSUSE:Factory 
checked in at 2016-06-19 10:49:56

Comparing /work/SRC/openSUSE:Factory/php5-phalcon (Old)
 and  /work/SRC/openSUSE:Factory/.php5-phalcon.new (New)


Package is "php5-phalcon"

Changes:

--- /work/SRC/openSUSE:Factory/php5-phalcon/php5-phalcon.changes
2016-06-09 16:06:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.php5-phalcon.new/php5-phalcon.changes   
2016-06-19 10:49:58.0 +0200
@@ -1,0 +2,11 @@
+Mon Jun  6 08:51:31 UTC 2016 - m...@poczta.onet.pl
+
+- Phalcon 2.0.13
+ * Restored Phalcon\Text::camelize behavior #11767
+ * Used Zephir v0.9.2 to maintain backwards compatibility
+
+- Phalcon 2.0.12
+ * Fixed regression changes for Phalcon\Mvc\View\Engine\Volt::callMacro #11745
+ * Fixed the argument type of Phalcon\Flash::success #11764
+
+---

Old:

  phalcon-v2.0.11.tar.gz

New:

  phalcon-v2.0.13.tar.gz



Other differences:
--
++ php5-phalcon.spec ++
--- /var/tmp/diff_new_pack.hbQpnG/_old  2016-06-19 10:49:59.0 +0200
+++ /var/tmp/diff_new_pack.hbQpnG/_new  2016-06-19 10:49:59.0 +0200
@@ -21,7 +21,7 @@
 %define _name   phalcon
 
 Name:   %{_php}-%{_name}
-Version:2.0.11
+Version:2.0.13
 Release:0
 Summary:PHP5 Extension Module
 License:BSD-3-Clause

++ phalcon-v2.0.11.tar.gz -> phalcon-v2.0.13.tar.gz ++
 10478 lines of diff (skipped)

++ zephir-master.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zephir-master/.gitattributes 
new/zephir-master/.gitattributes
--- old/zephir-master/.gitattributes1970-01-01 01:00:00.0 +0100
+++ new/zephir-master/.gitattributes2016-05-27 18:50:25.0 +0200
@@ -0,0 +1 @@
+*.html ident
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zephir-master/.travis.yml 
new/zephir-master/.travis.yml
--- old/zephir-master/.travis.yml   2016-05-09 13:14:56.0 +0200
+++ new/zephir-master/.travis.yml   2016-05-27 18:50:25.0 +0200
@@ -11,8 +11,17 @@
   - 5.6
   - 7.0
 
+git:
+  depth: 1
+
 cache:
-- apt
+  apt: true
+  ccache: true
+  timeout: 691200
+  directories:
+- vendor
+- $HOME/.ccache
+- $HOME/.composer/cache
 
 before_install:
  - if [[ "$TRAVIS_PULL_REQUEST" == "false" ]]; then openssl aes-256-cbc -k 
"$encryption_key" -in id_rsa.enc -out ~/.ssh/id_rsa -d; chmod 600 
~/.ssh/id_rsa; fi
@@ -23,6 +32,7 @@
  - if [[ "$TRAVIS_PULL_REQUEST" == "false" ]]; then git remote set-url origin 
g...@github.com:phalcon/zephir.git; fi
 
 install:
+ - export CC="ccache gcc"
  - export LD_LIBRARY_PATH="$TRAVIS_BUILD_DIR/build/lib":$LD_LIBRARY_PATH
  - export LIBRARY_PATH="$TRAVIS_BUILD_DIR/build/lib":$LIBRARY_PATH
  - export C_INCLUDE_PATH="$TRAVIS_BUILD_DIR/build/include"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zephir-master/Library/ClassDefinition.php 
new/zephir-master/Library/ClassDefinition.php
--- old/zephir-master/Library/ClassDefinition.php   2016-05-09 
13:14:56.0 +0200
+++ new/zephir-master/Library/ClassDefinition.php   2016-05-27 
18:50:25.0 +0200
@@ -857,13 +857,13 @@
 {
 foreach ($interfaceDefinition->getMethods() as $method) {
 if (!$classDefinition->hasMethod($method->getName())) {
-throw new CompilerException("Class " . 
$classDefinition->getCompleteName() . " must implement method: " . 
$method->getName() . " defined on interface: " . 
$interfaceDefinition->getCompleteName());
+throw new CompilerException("Class " . 
$classDefinition->getCompleteName() . " must implement a method called: \"" . 
$method->getName() . "\" as requirement of interface: \"" . 
$interfaceDefinition->getCompleteName() . "\"");
 }
 
 if ($method->hasParameters()) {
 $implementedMethod = 
$classDefinition->getMethod($method->getName());
 if ($implementedMethod->getNumberOfRequiredParameters() > 
$method->getNumberOfRequiredParameters() || 
$implementedMethod->getNumberOfParameters() < $method->getNumberOfParameters()) 
{
-throw new CompilerException("Class " . 
$classDefinition->getCompleteName() . "::" . $method->getName() . "() does not 
have the same number of required parameters in interface: " . 
$interfaceDefinition->getCompleteName());
+throw new CompilerException("Class " . 
$classDefinition->getCompleteName() . "::" . $method->getName() . "() does not 
have the same number of required parameters in 

commit nomacs for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package nomacs for openSUSE:Factory checked 
in at 2016-06-19 10:50:27

Comparing /work/SRC/openSUSE:Factory/nomacs (Old)
 and  /work/SRC/openSUSE:Factory/.nomacs.new (New)


Package is "nomacs"

Changes:

--- /work/SRC/openSUSE:Factory/nomacs/nomacs.changes2016-05-10 
09:27:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.nomacs.new/nomacs.changes   2016-06-19 
10:50:30.0 +0200
@@ -1,0 +2,7 @@
+Fri Jun 17 10:36:49 UTC 2016 - sor.ale...@meowr.ru
+
+- Add nomacs-3.2.0-gcc6.patch from
+  https://github.com/nomacs/nomacs/issues/62: fix GCC6 errors
+  (boo#985374).
+
+---

New:

  nomacs-3.2.0-gcc6.patch



Other differences:
--
++ nomacs.spec ++
--- /var/tmp/diff_new_pack.MKlxJm/_old  2016-06-19 10:50:31.0 +0200
+++ /var/tmp/diff_new_pack.MKlxJm/_new  2016-06-19 10:50:31.0 +0200
@@ -24,6 +24,8 @@
 Group:  Productivity/Graphics/Viewers
 Url:http://nomacs.org/
 Source: 
https://github.com/%{name}/%{name}/releases/download/%{version}/%{name}-%{version}-source.tar.bz2
+# PATCH-FIX-UPSTREAM nomacs-3.2.0-gcc6.patch boo#985374 ser...@serjux.com -- 
Fix GCC6 errors.
+Patch0: %{name}-3.2.0-gcc6.patch
 BuildRequires:  cmake >= 2.6
 BuildRequires:  dos2unix
 BuildRequires:  gcc-c++
@@ -52,6 +54,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 dos2unix Readme/*
 find src -type f -name '*.cpp' | while read f; do
 # Fix encoding issues in nomacs with Qt5.

++ nomacs-3.2.0-gcc6.patch ++
--- a/src/DkGui/DkPong.cpp
+++ b/src/DkGui/DkPong.cpp
@@ -655,7 +655,7 @@ void DkBall::fixAngle() {
double angle = mDirection.angle();
double range = CV_PI / 5.0;
double sign = angle > 0 ? 1.0 : -1.0;
-   angle = abs(angle);
+   angle = fabs(angle);
double newAngle = 0.0;
 
if (angle < CV_PI*0.5 && angle > CV_PI*0.5 - range) {
--- a/src/DkGui/DkViewPort.cpp
+++ b/src/DkGui/DkViewPort.cpp
@@ -1251,7 +1251,7 @@ void DkViewPort::animateFade() {
mAnimationValue = 
1.0f-(float)(mAnimationTime.elapsed()/1000.0)/Settings::param().display().animationDuration;

// slow in - slow out
-   double speed = mAnimationValue > 0.5 ? abs(1.0 - mAnimationValue) : 
abs(mAnimationValue);
+   double speed = mAnimationValue > 0.5 ? fabs(1.0 - mAnimationValue) : 
fabs(mAnimationValue);
speed *= .05;
 
mAnimationValue += (float)speed;



commit fio for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package fio for openSUSE:Factory checked in 
at 2016-06-19 10:49:58

Comparing /work/SRC/openSUSE:Factory/fio (Old)
 and  /work/SRC/openSUSE:Factory/.fio.new (New)


Package is "fio"

Changes:

--- /work/SRC/openSUSE:Factory/fio/fio.changes  2016-05-29 03:14:33.0 
+0200
+++ /work/SRC/openSUSE:Factory/.fio.new/fio.changes 2016-06-19 
10:50:03.0 +0200
@@ -1,0 +2,6 @@
+Thu Jun 16 13:53:38 UTC 2016 - mplus...@suse.com
+
+- Update to version 2.12:
+  * No changelog available
+
+---

Old:

  fio-2.11.tar.bz2

New:

  fio-2.12.tar.bz2



Other differences:
--
++ fio.spec ++
--- /var/tmp/diff_new_pack.9nivLb/_old  2016-06-19 10:50:04.0 +0200
+++ /var/tmp/diff_new_pack.9nivLb/_new  2016-06-19 10:50:04.0 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   fio
-Version:2.11
+Version:2.12
 Release:0
 Summary:Flexible I/O Tester/benchmarker
 License:GPL-2.0
@@ -98,6 +98,7 @@
 %{_bindir}/fio-dedupe
 %{_bindir}/fio-genzipf
 %{_bindir}/fio-verify-state
+%{_bindir}/fio_latency2csv.py
 %{_datadir}/fio
 %{_mandir}/man1/fio.1%{ext_man}
 %{_mandir}/man1/fio_generate_plots.1%{ext_man}

++ fio-2.11.tar.bz2 -> fio-2.12.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fio-2.11/FIO-VERSION-GEN new/fio-2.12/FIO-VERSION-GEN
--- old/fio-2.11/FIO-VERSION-GEN2016-05-25 02:42:04.0 +0200
+++ new/fio-2.12/FIO-VERSION-GEN2016-06-13 23:42:44.0 +0200
@@ -1,7 +1,7 @@
 #!/bin/sh
 
 GVF=FIO-VERSION-FILE
-DEF_VER=fio-2.11
+DEF_VER=fio-2.12
 
 LF='
 '
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fio-2.11/HOWTO new/fio-2.12/HOWTO
--- old/fio-2.11/HOWTO  2016-05-25 02:42:04.0 +0200
+++ new/fio-2.12/HOWTO  2016-06-13 23:42:44.0 +0200
@@ -53,8 +53,8 @@
 
IO engine   How do we issue io? We could be memory mapping the
file, we could be using regular read/write, we
-   could be using splice, async io, syslet, or even
-   SG (SCSI generic sg).
+   could be using splice, async io, or even SG
+   (SCSI generic sg).
 
IO depthIf the io engine is async, how large a queuing
depth do we want to maintain?
@@ -706,7 +706,9 @@
 
vsync   Basic readv(2) or writev(2) IO.
 
-   psyncv  Basic preadv(2) or pwritev(2) IO.
+   pvsync  Basic preadv(2) or pwritev(2) IO.
+
+   pvsync2 Basic preadv2(2) or pwritev2(2) IO.
 
libaio  Linux native asynchronous io. Note that Linux
may only support queued behaviour with
@@ -726,9 +728,6 @@
vmsplice(2) to transfer data from user
space to the kernel.
 
-   syslet-rw Use the syslet system calls to make
-   regular read/write async.
-
sg  SCSI generic sg v3 io. May either be
synchronous using the SG_IO ioctl, or if
the target is an sg character device
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fio-2.11/Makefile new/fio-2.12/Makefile
--- old/fio-2.11/Makefile   2016-05-25 02:42:04.0 +0200
+++ new/fio-2.12/Makefile   2016-06-13 23:42:44.0 +0200
@@ -26,7 +26,7 @@
 CFLAGS = -std=gnu99 -Wwrite-strings -Wall -Wdeclaration-after-statement 
$(OPTFLAGS) $(EXTFLAGS) $(BUILD_CFLAGS) -I. -I$(SRCDIR)
 LIBS   += -lm $(EXTLIBS)
 PROGS  = fio
-SCRIPTS = $(addprefix $(SRCDIR)/,tools/fio_generate_plots 
tools/plot/fio2gnuplot tools/genfio tools/fiologparser.py)
+SCRIPTS = $(addprefix $(SRCDIR)/,tools/fio_generate_plots 
tools/plot/fio2gnuplot tools/genfio tools/fiologparser.py 
tools/fio_latency2csv.py)
 
 ifndef CONFIG_FIO_NO_OPT
   CFLAGS += -O3
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fio-2.11/arch/arch-arm.h new/fio-2.12/arch/arch-arm.h
--- old/fio-2.11/arch/arch-arm.h2016-05-25 02:42:04.0 +0200
+++ new/fio-2.12/arch/arch-arm.h2016-06-13 23:42:44.0 +0200
@@ -18,6 +18,13 @@
 #define __NR_sys_vmsplice  343
 #endif
 
+#ifndef __NR_preadv2
+#define __NR_preadv2   392
+#endif
+#ifndef __NR_pwritev2
+#define __NR_pwritev2  393
+#endif
+
 #if defined (__ARM_ARCH_4__) || defined 

commit syncthing for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package syncthing for openSUSE:Factory 
checked in at 2016-06-19 10:50:25

Comparing /work/SRC/openSUSE:Factory/syncthing (Old)
 and  /work/SRC/openSUSE:Factory/.syncthing.new (New)


Package is "syncthing"

Changes:

--- /work/SRC/openSUSE:Factory/syncthing/syncthing.changes  2016-06-07 
23:47:57.0 +0200
+++ /work/SRC/openSUSE:Factory/.syncthing.new/syncthing.changes 2016-06-19 
10:50:27.0 +0200
@@ -1,0 +2,12 @@
+Fri Jun 17 01:22:25 UTC 2016 - jacobwin...@gmail.com
+
+- Update to version 0.13.7:
+  * Fixes the issue with the GUI being grey on startup.
+- Update to version 0.13.6:
+  * v0.13.5 -no-upgrade build now requires gcc.
+  * Favicon should not be animated.
+  * Toggling HTTP/HTTPS breaks GUI/API.
+  * Understand older/newer Hello messages.
+  * Warnings on relay connectivity issues are reduced.
+
+---

Old:

  syncthing-source-v0.13.5.tar.gz
  syncthing-source-v0.13.5.tar.gz.asc

New:

  syncthing-source-v0.13.7.tar.gz
  syncthing-source-v0.13.7.tar.gz.asc



Other differences:
--
++ syncthing.spec ++
--- /var/tmp/diff_new_pack.LlmMsS/_old  2016-06-19 10:50:29.0 +0200
+++ /var/tmp/diff_new_pack.LlmMsS/_new  2016-06-19 10:50:29.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   syncthing
-Version:0.13.5
+Version:0.13.7
 Release:0
 Summary:FOSS Continuous File Synchronisation
 License:MPL-2.0

++ syncthing-source-v0.13.5.tar.gz -> syncthing-source-v0.13.7.tar.gz ++
 4833 lines of diff (skipped)




commit libvmime_zarafa7 for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package libvmime_zarafa7 for 
openSUSE:Factory checked in at 2016-06-19 10:50:13

Comparing /work/SRC/openSUSE:Factory/libvmime_zarafa7 (Old)
 and  /work/SRC/openSUSE:Factory/.libvmime_zarafa7.new (New)


Package is "libvmime_zarafa7"

Changes:

--- /work/SRC/openSUSE:Factory/libvmime_zarafa7/libvmime_zarafa7.changes
2015-10-02 09:23:43.0 +0200
+++ /work/SRC/openSUSE:Factory/.libvmime_zarafa7.new/libvmime_zarafa7.changes   
2016-06-19 10:50:16.0 +0200
@@ -2 +2 @@
-Mon Sep 28 13:42:17 UTC 2015 - jeng...@inai.de
+Fri Jun 17 06:26:14 UTC 2016 - jeng...@inai.de
@@ -4,7 +4,3 @@
-- Add 09-vmime-phf-stop-on-whitespace.diff,
-  10-vmime-backport-mailboxList-parser-29954e5.diff,
-  11-vmime-disable-rfc2231.diff,
-  12-vmime-ignore-multiple-colons-in-headers.diff,
-  13-vmime-ignore-newlines.diff, 14-vmime-remove-setlocale.diff,
-  15-vmime-wrongly-padded-B64-words.diff, 16-vmime-x-uuencode.diff,
-  17-vmime-avoid-unneeded-conversion.diff, vmime-all4debian.diff
+- Add 18-vmime-gcc6.diff to work with gcc6 changed parser behavior.
+  Rename libvmime-sotag.diff to libvmime-sotag.xdiff since it is
+  only used as a reference.

Old:

  libvmime-sotag.diff

New:

  18-vmime-gcc6.diff



Other differences:
--
++ libvmime_zarafa7.spec ++
--- /var/tmp/diff_new_pack.WZwFOz/_old  2016-06-19 10:50:18.0 +0200
+++ /var/tmp/diff_new_pack.WZwFOz/_new  2016-06-19 10:50:18.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libvmime_zarafa7
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -28,13 +28,12 @@
 #Svn-Clone:https://vmime.svn.sourceforge.net/svnroot/vmime/trunk
 Source: libvmime-%{version}sotag.tar.bz2
 Source2:spice_source.sh
-Source3:libvmime-%{version}.tar.bz2
-Source4:readme.txt
-Source5:build.collax
+Source3:build.collax
+Source4:manual-sotag.xdiff
+Source5:vmime-all4debian.diff
 Source6:debian.docs
-Source7:libvmime-sotag.diff
-Source8:manual-sotag.xdiff
-Source9:vmime-all4debian.diff
+Source7:readme.txt
+Source8:libvmime-0.9.1+svn603.tar.bz2
 Patch1: libvmime-nodatetime.diff
 Patch3: vmime-0.8.1-charset-catch.diff
 Patch4: vmime-0.9.2-header-value-on-next-line.diff
@@ -50,6 +49,7 @@
 Patch15:15-vmime-wrongly-padded-B64-words.diff
 Patch16:16-vmime-x-uuencode.diff
 Patch17:17-vmime-avoid-unneeded-conversion.diff
+Patch18:18-vmime-gcc6.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  autoconf
 BuildRequires:  automake
@@ -115,25 +115,25 @@
 %prep
 %setup -qn vmime
 %patch -P 1 -P 3 -P 4 -P 5 -P 6 -P 7 -p1
-%patch -P 9 -P 10 -P 11 -P 12 -P 13 -P 14 -P 15 -P 16 -P 17 -p1
+%patch -P 9 -P 10 -P 11 -P 12 -P 13 -P 14 -P 15 -P 16 -P 17 -P 18 -p1
 
 %build
-export CFLAGS="%optflags -DVMIME_ALWAYS_GENERATE_7BIT_PARAMETER=1";
-export CXXFLAGS="$CFLAGS";
+export CFLAGS="%optflags -DVMIME_ALWAYS_GENERATE_7BIT_PARAMETER=1"
+export CXXFLAGS="$CFLAGS"
 # sendmail's awesome location.
-export PATH="$PATH:/usr/sbin";
+export PATH="$PATH:/usr/sbin"
 %configure --disable-static --disable-sasl --disable-tls
-make %{?_smp_mflags};
+make %{?_smp_mflags} CFLAGS="$CFLAGS" CXXFLAGS="$CXXFLAGS"
 
 %install
 b="%buildroot";
-make install DESTDIR="$b" docdir="%_docdir/%name";
-find "$b" -type f -name "*.la" -delete;
+make install DESTDIR="$b" docdir="%_docdir/%name"
+find "$b" -type f -name "*.la" -delete
 ln -sfv libvmime_zarafa7.so "$b/%_libdir/libvmime.so"
 mv -v "$b/%_libdir/pkgconfig"/{vmime_zarafa7.pc,vmime.pc}
 
 %check
-make check;
+make check
 
 %post -n %lname -p /sbin/ldconfig
 

++ 09-vmime-phf-stop-on-whitespace.diff ++
--- /var/tmp/diff_new_pack.WZwFOz/_old  2016-06-19 10:50:18.0 +0200
+++ /var/tmp/diff_new_pack.WZwFOz/_new  2016-06-19 10:50:18.0 +0200
@@ -1,4 +1,5 @@
-For certain broken input mail which forgets to use the semicolon in e.g.
+Attempt to handle broken input mail which forgets to use the semicolon
+in e.g.
   Content-Type: text/plain charset=utf-8
 
 ---

++ 10-vmime-backport-mailboxList-parser-29954e5.diff ++
--- /var/tmp/diff_new_pack.WZwFOz/_old  2016-06-19 10:50:18.0 +0200
+++ /var/tmp/diff_new_pack.WZwFOz/_new  2016-06-19 10:50:18.0 +0200
@@ -1,3 +1,5 @@
+[no description, what's it for?]
+
 ---
  src/mailboxList.cpp |   30 +-
  vmime/address.hpp   |1 -

++ 

commit abiword for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package abiword for openSUSE:Factory checked 
in at 2016-06-19 10:50:30

Comparing /work/SRC/openSUSE:Factory/abiword (Old)
 and  /work/SRC/openSUSE:Factory/.abiword.new (New)


Package is "abiword"

Changes:

--- /work/SRC/openSUSE:Factory/abiword/abiword.changes  2016-05-16 
12:03:45.0 +0200
+++ /work/SRC/openSUSE:Factory/.abiword.new/abiword.changes 2016-06-19 
10:50:34.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 13:08:40 UTC 2016 - norm...@linux.vnet.ibm.com
+
+- Add abiword-3.0.1-gcc6.patch: Fix build with gcc6 (boo#985070).
+
+---

New:

  abiword-3.0.1-gcc6.patch



Other differences:
--
++ abiword.spec ++
--- /var/tmp/diff_new_pack.s2rLVk/_old  2016-06-19 10:50:35.0 +0200
+++ /var/tmp/diff_new_pack.s2rLVk/_new  2016-06-19 10:50:35.0 +0200
@@ -33,6 +33,8 @@
 Patch5: abiword-librevenge.patch
 # PATCH-FIX-UPSTREAM abiword-libwps-0.4.patch dims...@opensuse.org -- Port to 
libwps-0.4; patch taken from Fedora.
 Patch6: abiword-libwps-0.4.patch
+# PATCH-FIX-UPSTREAM abiword-3.0.1-gcc6.patch boo#985070 
abiword-3.0.1-gcc6.patch -- Fix build with gcc6, patch borrowed from fedora
+Patch7: abiword-3.0.1-gcc6.patch
 BuildRequires:  asio-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -109,6 +111,7 @@
 %patch4
 %patch5
 %patch6
+%patch7
 
 %build
 # We modified plugin configuration and thus we need to regenerate the whole 
build system

++ abiword-3.0.1-gcc6.patch ++
---
 configure.ac |2 
 plugins/collab/backends/service/xp/RealmProtocol.cpp |4 
 plugins/collab/backends/service/xp/soa_soup.cpp  |2 
 plugins/latex/xp/ie_exp_LaTeX.cpp|2 
 plugins/xslfo/xp/ie_exp_XSL-FO.cpp   |2 
 src/af/xap/cocoa/xap_CocoaApp.cpp|2 
 src/af/xap/cocoa/xap_CocoaApp.h  |2 
 src/af/xap/gtk/xap_UnixApp.cpp   |  106 ---
 src/af/xap/gtk/xap_UnixApp.h |2 
 src/af/xap/win/xap_Win32App.cpp  |2 
 src/af/xap/win/xap_Win32App.h|2 
 src/af/xap/xp/xap_App.h  |2 
 12 files changed, 60 insertions(+), 70 deletions(-)

Index: src/af/xap/cocoa/xap_CocoaApp.h
===
--- src/af/xap/cocoa/xap_CocoaApp.h.orig
+++ src/af/xap/cocoa/xap_CocoaApp.h
@@ -65,7 +65,7 @@ public:
virtual void
copyToClipboard(PD_DocumentRange * pDocRange, bool bUseClipboard = true) = 0;
virtual void
pasteFromClipboard(PD_DocumentRange * pDocRange, bool bUseClipboard, bool 
bHonorFormatting = true) = 0;
virtual bool
canPasteFromClipboard() = 0;
-   virtual const char *
getUserPrivateDirectory();
+   virtual const char *
getUserPrivateDirectory() const;
virtual bool
findAbiSuiteBundleFile(std::string & path, const char * filename, const char * 
subdir = 0); // checks only bundle
virtual bool
findAbiSuiteLibFile(std::string & path, const char * filename, const char * 
subdir = 0);
virtual bool
findAbiSuiteAppFile(std::string & path, const char * filename, const char * 
subdir = 0); // doesn't check user-dir
Index: src/af/xap/cocoa/xap_CocoaApp.cpp
===
--- src/af/xap/cocoa/xap_CocoaApp.cpp.orig
+++ src/af/xap/cocoa/xap_CocoaApp.cpp
@@ -196,7 +196,7 @@ void XAP_CocoaApp::getGeometry(int * x,
*flags = m_geometry.flags;
 }
 
-const char * XAP_CocoaApp::getUserPrivateDirectory()
+const char * XAP_CocoaApp::getUserPrivateDirectory() const
 {
static const char * szAbiDir = "Library/Application Support/AbiSuite";

Index: src/af/xap/gtk/xap_UnixApp.h
===
--- src/af/xap/gtk/xap_UnixApp.h.orig
+++ src/af/xap/gtk/xap_UnixApp.h
@@ -73,7 +73,7 @@ public:
virtual void
pasteFromClipboard(PD_DocumentRange * pDocRange, bool bUseClipboard, bool 
bHonorFormatting = true) = 0;
virtual bool
canPasteFromClipboard() = 0;

commit i3 for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package i3 for openSUSE:Factory checked in 
at 2016-06-19 10:50:31

Comparing /work/SRC/openSUSE:Factory/i3 (Old)
 and  /work/SRC/openSUSE:Factory/.i3.new (New)


Package is "i3"

Changes:

--- /work/SRC/openSUSE:Factory/i3/i3.changes2016-03-26 15:25:08.0 
+0100
+++ /work/SRC/openSUSE:Factory/.i3.new/i3.changes   2016-06-19 
10:50:35.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 14:56:32 UTC 2016 - asa...@suse.de
+
+* Correct recommends to fix boo#985443
+
+---



Other differences:
--
++ i3.spec ++
--- /var/tmp/diff_new_pack.6VlHRe/_old  2016-06-19 10:50:36.0 +0200
+++ /var/tmp/diff_new_pack.6VlHRe/_new  2016-06-19 10:50:36.0 +0200
@@ -48,8 +48,11 @@
 BuildRequires:  pkgconfig(xcb-icccm)
 BuildRequires:  pkgconfig(xcb-keysyms)
 
-# introduced to fix bnc#971897
-Recommends: i3-status
+# introduced to fix bnc#971897 and boo#985443
+Recommends: i3status
+
+# So that M-enter works in the default config. boo#985443
+Recommends: dmenu
 
 # Upstream First - Policy:
 # Never add any patches to this package without the upstream commit id





commit nodejs-packaging for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package nodejs-packaging for 
openSUSE:Factory checked in at 2016-06-19 10:50:00

Comparing /work/SRC/openSUSE:Factory/nodejs-packaging (Old)
 and  /work/SRC/openSUSE:Factory/.nodejs-packaging.new (New)


Package is "nodejs-packaging"

Changes:

--- /work/SRC/openSUSE:Factory/nodejs-packaging/nodejs-packaging.changes
2016-03-31 13:03:13.0 +0200
+++ /work/SRC/openSUSE:Factory/.nodejs-packaging.new/nodejs-packaging.changes   
2016-06-19 10:50:05.0 +0200
@@ -1,0 +2,7 @@
+Thu Jun 16 14:59:07 UTC 2016 - i...@marguerite.su
+
+- update version v10.beta11
+  * bower.rb: github tags can be in more than one page. so 
+the check for avaiable versions should be recursive.
+
+---

Old:

  nodejs-packaging-10.beta10.tar.gz

New:

  nodejs-packaging-10.beta11.tar.gz



Other differences:
--
++ nodejs-packaging.spec ++
--- /var/tmp/diff_new_pack.guECPp/_old  2016-06-19 10:50:07.0 +0200
+++ /var/tmp/diff_new_pack.guECPp/_new  2016-06-19 10:50:07.0 +0200
@@ -18,7 +18,7 @@
 
 %define _rpmconfigdir %{_prefix}/lib/rpm
 Name:   nodejs-packaging
-Version:10.beta10
+Version:10.beta11
 Release:0
 Summary:Node.js Dependency generators for openSUSE
 License:MIT

++ nodejs-packaging-10.beta10.tar.gz -> nodejs-packaging-10.beta11.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/nodejs-packaging-10.beta10/tool/plugins/bower.rb 
new/nodejs-packaging-10.beta11/tool/plugins/bower.rb
--- old/nodejs-packaging-10.beta10/tool/plugins/bower.rb2016-03-28 
11:45:24.0 +0200
+++ new/nodejs-packaging-10.beta11/tool/plugins/bower.rb2016-06-16 
16:50:06.0 +0200
@@ -29,6 +29,33 @@
 
end
 
+   def get_version(url="",versions=[])
+
+   html = Nokogiri::HTML(open(url))
+   html.xpath('//span[@class="tag-name"]').each {|f| versions << 
f.text}
+
+   if html.xpath('//div[@class="pagination"]/a')
+   newurls = []
+   html.xpath('//div[@class="pagination"]/a/@href').each 
do |l|
+newurls << l.value
+   end
+   if newurls.size > 1
+   newurl = newurls[1]
+   get_version(newurl,versions)
+   else
+   if 
html.xpath('//div[@class="pagination"]/a').text == "Next"
+   newurl = newurls[0]
+   get_version(newurl,versions)
+   else
+   return versions
+   end
+   end
+   else
+   return versions
+   end
+
+   end
+
def lookup(name="")
 
json = dependency(name)
@@ -42,10 +69,12 @@
open(file) {|f| j = JSON.parse(f.read)}
FileUtils.rm_f file
url = 
j["url"].gsub("git://","https://;).gsub(".git","")
-   html = Nokogiri::HTML(open(url + "/tags"))
versions_pre,versions,matches = [],[],[]
-   html.xpath('//span[@class="tag-name"]').each 
{|f| versions_pre << f.text
-}
+
+   # in case there're more than one page of tags
+   puts "Processing " + k
+   versions_pre = get_version(url + "/tags")
+
# remove the prefix "v" in eg v3.0.0
versions_pre.each do |v1|
if v1.index(/^v/)




commit grilo-plugins for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package grilo-plugins for openSUSE:Factory 
checked in at 2016-06-19 10:50:02

Comparing /work/SRC/openSUSE:Factory/grilo-plugins (Old)
 and  /work/SRC/openSUSE:Factory/.grilo-plugins.new (New)


Package is "grilo-plugins"

Changes:

--- /work/SRC/openSUSE:Factory/grilo-plugins/grilo-plugins.changes  
2016-03-29 14:48:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.grilo-plugins.new/grilo-plugins.changes 
2016-06-19 10:50:08.0 +0200
@@ -1,0 +2,6 @@
+Thu Jun 16 09:11:20 UTC 2016 - zai...@opensuse.org
+
+- Add grilo-plugins-Fix-gcc6-build.patch: Fix build with GCC 6,
+  patch from upstream.
+
+---

New:

  grilo-plugins-Fix-gcc6-build.patch



Other differences:
--
++ grilo-plugins.spec ++
--- /var/tmp/diff_new_pack.kkyzw5/_old  2016-06-19 10:50:08.0 +0200
+++ /var/tmp/diff_new_pack.kkyzw5/_new  2016-06-19 10:50:08.0 +0200
@@ -26,6 +26,8 @@
 Group:  Productivity/Multimedia/Other
 Url:https://live.gnome.org/Grilo
 Source: 
http://download.gnome.org/sources/grilo-plugins/0.3/%{name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM grilo-plugins-Fix-gcc6-build.patch zai...@opensuse.org -- 
Fix build with GCC 6
+Patch0: grilo-plugins-Fix-gcc6-build.patch
 BuildRequires:  docbook_4
 BuildRequires:  intltool >= 0.40.0
 BuildRequires:  itstool
@@ -107,6 +109,7 @@
 %lang_package
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure \

++ grilo-plugins-Fix-gcc6-build.patch ++
>From 1546e677f4f0484402a2287f51f821b54fb345c3 Mon Sep 17 00:00:00 2001
From: Bastien Nocera 
Date: Tue, 22 Mar 2016 16:22:31 +0100
Subject: [PATCH 1/2] jamendo: Fix "format not a string literal" error

---
 src/jamendo/grl-jamendo.c | 86 +++
 1 file changed, 65 insertions(+), 21 deletions(-)

diff --git a/src/jamendo/grl-jamendo.c b/src/jamendo/grl-jamendo.c
index a58be4b..a0188ae 100644
--- a/src/jamendo/grl-jamendo.c
+++ b/src/jamendo/grl-jamendo.c
@@ -139,10 +139,12 @@ typedef struct {
   gboolean cancelled;
 } XmlParseEntries;
 
+/* Note: you'll also need to update
+ * grl_jamendo_source_browse() */
 struct Feeds {
   gchar *name;
   JamendoCategory cat;
-  gchar *url;
+  const gchar *url;
 } feeds[] = {
   { N_("Albums of the week"), JAMENDO_ALBUM_CAT,
 JAMENDO_GET_ALBUMS "=ratingweek_desc", },
@@ -1174,10 +1176,46 @@ grl_jamendo_source_browse (GrlSource *source,
 
 feed_id = atoi (container_split[1]);
 jamendo_keys = get_jamendo_keys (feeds[feed_id].cat);
-url = g_strdup_printf (feeds[feed_id].url,
-   jamendo_keys,
-   page_size,
-   page_number);
+switch (feed_id) {
+case 0:
+  url = g_strdup_printf (JAMENDO_GET_ALBUMS "=ratingweek_desc",
+ jamendo_keys,
+ page_size,
+ page_number);
+  break;
+case 1:
+  url = g_strdup_printf (JAMENDO_GET_TRACKS "=ratingweek_desc",
+ jamendo_keys,
+ page_size,
+ page_number);
+  break;
+case 2:
+  url = g_strdup_printf (JAMENDO_GET_TRACKS "=releasedate_desc",
+ jamendo_keys,
+ page_size,
+ page_number);
+  break;
+case 3:
+  url = g_strdup_printf (JAMENDO_GET_ARTISTS "=rating_desc",
+ jamendo_keys,
+ page_size,
+ page_number);
+  break;
+case 4:
+  url = g_strdup_printf (JAMENDO_GET_ALBUMS "=rating_desc",
+ jamendo_keys,
+ page_size,
+ page_number);
+  break;
+case 5:
+  url = g_strdup_printf (JAMENDO_GET_TRACKS "=rating_desc",
+ jamendo_keys,
+ page_size,
+ page_number);
+  break;
+default:
+  g_assert_not_reached ();
+}
 g_free (jamendo_keys);
   } else {
 send_feeds (bs);
@@ -1234,7 +1272,6 @@ grl_jamendo_source_query (GrlSource *source,
   gchar *term = NULL;
   gchar *url;
   gchar *jamendo_keys = NULL;
-  gchar *query = NULL;
   XmlParseEntries *xpe = NULL;
   guint page_size;
   guint page_number;
@@ -1252,33 +1289,40 @@ 

commit qpid-cpp for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package qpid-cpp for openSUSE:Factory 
checked in at 2016-06-19 10:50:33

Comparing /work/SRC/openSUSE:Factory/qpid-cpp (Old)
 and  /work/SRC/openSUSE:Factory/.qpid-cpp.new (New)


Package is "qpid-cpp"

Changes:

--- /work/SRC/openSUSE:Factory/qpid-cpp/qpid-cpp.changes2015-09-08 
18:05:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.qpid-cpp.new/qpid-cpp.changes   2016-06-19 
10:50:36.0 +0200
@@ -1,0 +2,8 @@
+Fri Jun 17 15:47:48 UTC 2016 - fst...@suse.com
+
+- Added patch:
+  * qpid-cpp-0.34-gcc6.patch
+- Disable -Werror in order to be able to build with the new
+  GCC6 warnings.
+
+---

New:

  qpid-cpp-0.34-gcc6.patch



Other differences:
--
++ perl-qpid.spec ++
--- /var/tmp/diff_new_pack.ZQdaJM/_old  2016-06-19 10:50:38.0 +0200
+++ /var/tmp/diff_new_pack.ZQdaJM/_new  2016-06-19 10:50:38.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-qpid
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed

++ qpid-cpp.spec ++
--- /var/tmp/diff_new_pack.ZQdaJM/_old  2016-06-19 10:50:38.0 +0200
+++ /var/tmp/diff_new_pack.ZQdaJM/_new  2016-06-19 10:50:38.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package qpid-cpp
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,12 +26,13 @@
 Source0:
http://www.apache.org/dist/qpid/cpp/%{version}/%{name}-%{version}.tar.gz
 Source1000: %{name}-rpmlintrc
 Patch0: 0001-NO-JIRA-qpidd.service-file-for-use-on-Fedora.patch
-Patch3: qpid-0.24-date.patch
-Patch4: qpid-cpp-tests.patch
-Patch5: qpid-cpp-initdir.patch
-Patch8: %{name}-0.30-cmake.patch
-Patch9: %{name}-aarch64.patch
-Patch10:qpid-boost-test-message.patch
+Patch1: qpid-0.24-date.patch
+Patch2: qpid-cpp-tests.patch
+Patch3: qpid-cpp-initdir.patch
+Patch4: %{name}-0.30-cmake.patch
+Patch5: %{name}-aarch64.patch
+Patch6: qpid-boost-test-message.patch
+Patch7: qpid-cpp-0.34-gcc6.patch
 BuildRequires:  boost-devel
 BuildRequires:  cmake
 BuildRequires:  cyrus-sasl
@@ -346,12 +347,13 @@
 %prep
 %setup -q
 %patch0 -p3
-%patch3 -p2 -b .date
-%patch4 -p1 -b .tests
-%patch5 -p1 -b .initdir
-%patch8 -p1
-%patch9 -p2
-%patch10 -p1
+%patch1 -p2 -b .date
+%patch2 -p1 -b .tests
+%patch3 -p1 -b .initdir
+%patch4 -p1
+%patch5 -p2
+%patch6 -p1
+%patch7 -p1
 
 %global perftests "qpid-perftest qpid-topic-listener qpid-topic-publisher 
qpid-latency-test qpid-client-test qpid-txtest"
 

++ qpid-cpp-0.34-gcc6.patch ++
--- qpid-cpp-0.34/CMakeLists.txt2015-02-27 00:06:31.0 +0100
+++ qpid-cpp-0.34/CMakeLists.txt2016-06-17 17:38:34.756625133 +0200
@@ -144,7 +144,7 @@
# -Wunreachable-code -Wpadded -Winline
# -Wshadow - warns about boost headers.
set (WARNING_FLAGS
-"-Werror -pedantic -Wall -Wextra -Wno-shadow -Wpointer-arith 
-Wcast-qual -Wcast-align -Wno-long-long -Wvolatile-register-var -Winvalid-pch 
-Wno-system-headers -Woverloaded-virtual")
+"-pedantic -Wall -Wextra -Wno-shadow -Wpointer-arith -Wcast-qual 
-Wcast-align -Wno-long-long -Wvolatile-register-var -Winvalid-pch 
-Wno-system-headers -Woverloaded-virtual")
 
set (CATCH_UNDEFINED "-Wl,--no-undefined")
# gcc on SunOS uses native linker whose "-z defs" is too fussy



commit gfan for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package gfan for openSUSE:Factory checked in 
at 2016-06-19 10:50:07

Comparing /work/SRC/openSUSE:Factory/gfan (Old)
 and  /work/SRC/openSUSE:Factory/.gfan.new (New)


Package is "gfan"

Changes:

--- /work/SRC/openSUSE:Factory/gfan/gfan.changes2014-10-14 
07:11:03.0 +0200
+++ /work/SRC/openSUSE:Factory/.gfan.new/gfan.changes   2016-06-19 
10:50:10.0 +0200
@@ -1,0 +2,7 @@
+Thu Jun 16 21:38:19 UTC 2016 - jeng...@inai.de
+
+- Add missing post and postun sections for ldconfig
+- Build with std=gnu++98 because the code has not been written
+  with C++11's std::rank in mind.
+
+---



Other differences:
--
++ gfan.spec ++
--- /var/tmp/diff_new_pack.CO0s3R/_old  2016-06-19 10:50:11.0 +0200
+++ /var/tmp/diff_new_pack.CO0s3R/_new  2016-06-19 10:50:11.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gfan
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -77,26 +77,28 @@
 %patch -P 1 -P 2 -P 3 -P 4 -p1
 
 %build
-autoreconf -fi;
-%if 0%{?suse_version} <= 1110
-# -Wno-unused-result is not a recognized option of gcc 4.3
-export CXXFLAGS="%optflags -Wno-sign-compare -Wno-reorder -Wno-unused";
-%else
-export CXXFLAGS="%optflags -Wno-sign-compare -Wno-reorder -Wno-unused 
-Wno-unused-result";
+autoreconf -fi
+export CXXFLAGS="%optflags -Wno-sign-compare -Wno-reorder -Wno-unused 
-std=gnu++98"
+%if 0%{?suse_version} > 1110
+# -Wno-unused-result not known in old SUSE
+export CXXFLAGS="$CXXFLAGS -Wno-unused-result"
 %endif
 %configure --disable-static --enable-silent-rules
-make %{?_smp_mflags};
+make %{?_smp_mflags}
 %if 0%{?with_pdf}
-make -C doc %{?_smp_mflags};
+make -C doc %{?_smp_mflags}
 %endif
 
 %install
-b="%buildroot";
-make install DESTDIR="$b";
+b="%buildroot"
+make install DESTDIR="$b"
 for i in $(./gfan _list | grep ^gfan_); do
-   ln -s gfan "$b/%_bindir/$i";
+   ln -s gfan "$b/%_bindir/$i"
 done;
-rm -f "$b/%_libdir"/*.la;
+rm -fv "$b/%_libdir"/*.la
+
+%post   -n %lname -p /sbin/ldconfig
+%postun -n %lname -p /sbin/ldconfig
 
 %files
 %defattr(-,root,root)




commit openucx for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package openucx for openSUSE:Factory checked 
in at 2016-06-19 10:50:43

Comparing /work/SRC/openSUSE:Factory/openucx (Old)
 and  /work/SRC/openSUSE:Factory/.openucx.new (New)


Package is "openucx"

Changes:

--- /work/SRC/openSUSE:Factory/openucx/openucx.changes  2015-10-08 
08:24:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.openucx.new/openucx.changes 2016-06-19 
10:50:45.0 +0200
@@ -1,0 +2,7 @@
+Sat Jun 18 07:36:59 UTC 2016 - jeng...@inai.de
+
+- Update to snapshot 0~git1727
+* New: libucm. libucm is a standalone non-unloadable library which
+  installs hooks for virtual memory changes in the current process.
+
+---

Old:

  ucx-0~git862.tar.xz

New:

  _service
  ucx-0~git1727.tar.xz



Other differences:
--
++ openucx.spec ++
--- /var/tmp/diff_new_pack.9TurQc/_old  2016-06-19 10:50:46.0 +0200
+++ /var/tmp/diff_new_pack.9TurQc/_new  2016-06-19 10:50:46.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package openucx
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,17 +16,18 @@
 #
 
 
+%define version_unconverted 0~git1727
+
 Name:   openucx
 Summary:Unifieid Communication X
 License:BSD-3-Clause
 Group:  Development/Libraries/C and C++
-Version:0~git862
+Version:0~git1727
 Release:0
 Url:http://openucx.org/
 
 #Git-Clone:git://github.com/openucx/ucx
 #Git-Web:  https://github.com/openucx/ucx
-#Snapshot: c3a0e0a96e0168796132b9408039ea3792f30c76
 Source: ucx-%version.tar.xz
 BuildRequires:  autoconf >= 2.63
 BuildRequires:  automake >= 1.10
@@ -50,6 +51,28 @@
 %description tools
 Miscallaneous utilities for Unified Communication X.
 
+%package -n libucm0
+Summary:Memory (un)happing hooks for Unified Communication X
+Group:  System/Libraries
+
+%description -n libucm0
+libucm is a standalone non-unloadable library which installs hooks
+for virtual memory changes in the current process. Then, it calls
+user-defined callbacks, which may potentially override the default
+behavior, or just passively listen and update their own data. libucm
+does not use libuct, to avoid making it non-unloadable as well, and
+impelements a basic logging service which is safe to use from malloc
+hooks.
+
+%package -n libucm-devel
+Summary:Development files for Unified Communication X Memory Hooks
+Group:  Development/Libraries/C and C++
+Requires:   libucm0 = %version
+
+%description -n libucm-devel
+libucm is a standalone non-unloadable library which installs hooks
+for virtual memory changes in the current process.
+
 %package -n libucp2
 Summary:Infiniband Unified Communication Protocols
 Group:  System/Libraries
@@ -101,14 +124,8 @@
 Low-level API that expose basic network operations supported by
 underlying hardware.
 
-%package -n libucxmalloc0
-Summary:Allocation library for Unified Communication X
-Group:  System/Libraries
-
-%description -n libucxmalloc0
-
 %prep
-%setup -qn ucx
+%setup -qn ucx-%version
 
 %build
 autoreconf -fi
@@ -121,14 +138,12 @@
 %postun -n libucs2 -p /sbin/ldconfig
 %post   -n libuct2 -p /sbin/ldconfig
 %postun -n libuct2 -p /sbin/ldconfig
-%post   -n libucxmalloc0 -p /sbin/ldconfig
-%postun -n libucxmalloc0 -p /sbin/ldconfig
+%post   -n libucm0 -p /sbin/ldconfig
+%postun -n libucm0 -p /sbin/ldconfig
 
 %install
 %make_install
 rm -fv "%buildroot/%_libdir"/*.la
-# no headers for this lib
-rm -f "%buildroot/%_libdir/libucxmalloc.so"
 
 %files tools
 %defattr(-,root,root)
@@ -136,6 +151,15 @@
 %_datadir/ucx/
 %doc LICENSE
 
+%files -n libucm0
+%defattr(-,root,root)
+%_libdir/libucm.so.*
+
+%files -n libucm-devel
+%defattr(-,root,root)
+%_includedir/ucm/
+%_libdir/libucm.so
+
 %files -n libucp2
 %defattr(-,root,root)
 %_libdir/libucp.so.*
@@ -163,8 +187,4 @@
 %_includedir/uct/
 %_libdir/libuct.so
 
-%files -n libucxmalloc0
-%defattr(-,root,root)
-%_libdir/libucxmalloc.so.*
-
 %changelog

++ _service ++


git
git://github.com/openucx/ucx
6cb0d7189bd53534575a992a2bdb27dd1cb66e22
20bf38e8c57df29815c512aa19fb194cf0527f3d
0~git@TAG_OFFSET@


*.tar
xz



++ ucx-0~git862.tar.xz -> ucx-0~git1727.tar.xz ++
 109174 lines of diff (skipped)




commit wxWidgets-3_0 for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package wxWidgets-3_0 for openSUSE:Factory 
checked in at 2016-06-19 10:50:16

Comparing /work/SRC/openSUSE:Factory/wxWidgets-3_0 (Old)
 and  /work/SRC/openSUSE:Factory/.wxWidgets-3_0.new (New)


Package is "wxWidgets-3_0"

Changes:

--- /work/SRC/openSUSE:Factory/wxWidgets-3_0/wxWidgets-3_0.changes  
2016-03-07 13:24:06.0 +0100
+++ /work/SRC/openSUSE:Factory/.wxWidgets-3_0.new/wxWidgets-3_0.changes 
2016-06-19 10:50:20.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 07:19:49 UTC 2016 - jeng...@inai.de
+
+- Add abs.diff to reenable successful gcc6 build
+
+---

New:

  abs.diff



Other differences:
--
++ wxGTK3-3_0.spec ++
--- /var/tmp/diff_new_pack.vBxZ11/_old  2016-06-19 10:50:22.0 +0200
+++ /var/tmp/diff_new_pack.vBxZ11/_new  2016-06-19 10:50:22.0 +0200
@@ -54,6 +54,7 @@
 Patch12:0003-Don-t-use-frame-extents-when-not-using-X11-in-wxGTK.patch
 Patch13:0004-Don-t-crash-when-switching-to-full-screen-in-non-X11.patch
 Patch14:0005-Don-t-use-X11-only-functions-when-not-using-X11-in-w.patch
+Patch15:abs.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  SDL-devel
 BuildRequires:  autoconf
@@ -225,7 +226,7 @@
 echo "=== RPM build flags: WX_DEBUG=0%{?WX_DEBUG}"
 %setup -q -n %tarball_name-%version
 %patch -P 1 -P 2 -P 3 -P 4 -P 5 -P 6 -P 7 -P 8 -P 9 -p1
-%patch -P 10 -P 11 -P 12 -P 13 -P 14 -p1
+%patch -P 10 -P 11 -P 12 -P 13 -P 14 -P 15 -p1
 cp %{S:2} .
 
 %build

wxWidgets-3_0.spec: same change
++ abs.diff ++
From: Jan Engelhardt 
Date: 2016-06-17 08:08:34.610326109 +0200

Pick one of the abses and move on.

./src/stc/scintilla/src/Editor.cxx:5844:23: error: call of overloaded 
'abs(XYPOSITION)' is ambiguous
  if (abs(pt1.x - pt2.x) > 3)
./src/stc/scintilla/src/Editor.cxx:5846:23: error: call of overloaded 
'abs(XYPOSITION)' is ambiguous
  if (abs(pt1.y - pt2.y) > 3)

---
 src/stc/scintilla/src/Editor.cxx |6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Index: wxWidgets-3.0.2/src/stc/scintilla/src/Editor.cxx
===
--- wxWidgets-3.0.2.orig/src/stc/scintilla/src/Editor.cxx
+++ wxWidgets-3.0.2/src/stc/scintilla/src/Editor.cxx
@@ -981,7 +981,7 @@ void Editor::ScrollTo(int line, bool mov
// Try to optimise small scrolls
 #ifndef UNDER_CE
int linesToMove = topLine - topLineNew;
-   bool performBlit = (abs(linesToMove) <= 10) && (paintState == 
notPainting);
+   bool performBlit = (abs(static_cast(linesToMove)) <= 10) 
&& (paintState == notPainting);
willRedrawAll = !performBlit;
 #endif
SetTopLine(topLineNew);
@@ -5841,9 +5841,9 @@ void Editor::GoToLine(int lineNo) {
 }
 
 static bool Close(Point pt1, Point pt2) {
-   if (abs(pt1.x - pt2.x) > 3)
+   if (abs(static_cast(pt1.x - pt2.x)) > 3)
return false;
-   if (abs(pt1.y - pt2.y) > 3)
+   if (abs(static_cast(pt1.y - pt2.y)) > 3)
return false;
return true;
 }



commit openbabel for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package openbabel for openSUSE:Factory 
checked in at 2016-06-19 10:50:23

Comparing /work/SRC/openSUSE:Factory/openbabel (Old)
 and  /work/SRC/openSUSE:Factory/.openbabel.new (New)


Package is "openbabel"

Changes:

--- /work/SRC/openSUSE:Factory/openbabel/openbabel.changes  2015-06-23 
11:58:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.openbabel.new/openbabel.changes 2016-06-19 
10:50:25.0 +0200
@@ -1,0 +2,19 @@
+Fri Jun 17 09:02:52 UTC 2016 - martin.li...@suse.com
+
+- Fix errors seen by 02-check-gcc-output script.
+
+---
+Thu Jun 16 14:39:01 UTC 2016 - tchva...@suse.com
+
+- Version update to 2.3.2 and cripple the tarball
+  * various small bugfixes, the git is far away from this but
+upstream seems not to do releases
+  * Add patch to properly install bindings to right location:
++ python-installdir.patch
+
+---
+Thu Jun 16 13:00:32 UTC 2016 - mli...@suse.cz
+
+- Add patch to build with gcc6 openbabel-gcc6.patch
+
+---

Old:

  openbabel-2.3.1-crippled.tar.bz2

New:

  openbabel-2.3.2-crippled.tar.bz2
  openbabel-gcc6.patch
  python-installdir.patch



Other differences:
--
++ openbabel.spec ++
--- /var/tmp/diff_new_pack.oFqA1I/_old  2016-06-19 10:50:27.0 +0200
+++ /var/tmp/diff_new_pack.oFqA1I/_new  2016-06-19 10:50:27.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package openbabel
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   openbabel
-Version:2.3.1
+Version:2.3.2
 Release:0
 Summary:Open Babel - The Open Source Chemistry Toolbox
 License:GPL-2.0
@@ -30,10 +30,14 @@
 Patch0: openbabel-2.3.1-no-build-date.patch
 # PATCH-FIX-UPSTREAM openbabel-gcc5.patch dims...@opensuse.org -- Fix build 
with GCC5, taken from git
 Patch1: openbabel-gcc5.patch
+# PATCH-FIX-UPSTREAM openbabel-gcc6.patch mli...@suse.cz -- Fix build with GCC6
+Patch2: openbabel-gcc6.patch
+# PATCH-MERGED-UPSTREAM python-installdir.patch tchva...@suse.com -- Fix 
bindings install dir
+Patch3: python-installdir.patch
 BuildRequires:  cmake
 BuildRequires:  gcc-c++
 BuildRequires:  libeigen2-devel
-BuildRequires:  pkg-config
+BuildRequires:  pkgconfig
 BuildRequires:  python-devel
 BuildRequires:  swig
 BuildRequires:  zlib-devel
@@ -84,25 +88,23 @@
 %setup -q
 %patch0
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
-%define libsuffix ""
-%if "%{_lib}" == "lib64"
-%define libsuffix 64
-%endif
-cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_SUFFIX=%libsuffix 
-DPYTHON_BINDINGS=ON -DCMAKE_SKIP_INSTALL_RPATH=ON
+export CXXFLAGS="%{optflags} -std=gnu++98 -fno-strict-aliasing"
+%cmake \
+-DPYTHON_BINDINGS=ON \
+-DRUN_SWIG=ON \
+-DOPTIMIZE_NATIVE=OFF
 make %{?_smp_mflags}
 
 %install
-make DESTDIR=%{buildroot} install
+%cmake_install
 
 %post -n libopenbabel4 -p /sbin/ldconfig
-
 %postun -n libopenbabel4 -p /sbin/ldconfig
 
-%clean
-rm -rf %{buildroot}
-
 %files
 %defattr(-,root,root,-)
 %{_libdir}/openbabel

++ openbabel-2.3.1-crippled.tar.bz2 -> openbabel-2.3.2-crippled.tar.bz2 
++
/work/SRC/openSUSE:Factory/openbabel/openbabel-2.3.1-crippled.tar.bz2 
/work/SRC/openSUSE:Factory/.openbabel.new/openbabel-2.3.2-crippled.tar.bz2 
differ: char 11, line 1

++ openbabel-gcc6.patch ++
Index: openbabel-2.3.2/src/bitvec.cpp
===
--- openbabel-2.3.2.orig/src/bitvec.cpp
+++ openbabel-2.3.2/src/bitvec.cpp
@@ -57,11 +57,11 @@ namespace OpenBabel
 
   static unsigned int bitsoff[SETWORD] =
 {
-  
0x,0xFFFE,0xFFFC,0xFFF8,0xFFF0,0xFFE0,0xFFC0,
-  
0xFF80,0xFF00,0xFE00,0xFC00,0xF800,0xF000,0xE000,
-  
0xC000,0x8000,0x,0xFFFE,0xFFFC,0xFFF8,0xFFF0,
-  
0xFFE0,0xFFC0,0xFF80,0xFF00,0xFE00,0xFC00,0xF800,
-  0xF000,0xE000,0xC000,0x8000
+  
(int)0x,(int)0xFFFE,(int)0xFFFC,(int)0xFFF8,(int)0xFFF0,(int)0xFFE0,(int)0xFFC0,
+  
(int)0xFF80,(int)0xFF00,(int)0xFE00,(int)0xFC00,(int)0xF800,(int)0xF000,(int)0xE000,
+  

commit gnome-boxes for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package gnome-boxes for openSUSE:Factory 
checked in at 2016-06-19 10:50:04

Comparing /work/SRC/openSUSE:Factory/gnome-boxes (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-boxes.new (New)


Package is "gnome-boxes"

Changes:

--- /work/SRC/openSUSE:Factory/gnome-boxes/gnome-boxes.changes  2016-05-12 
09:33:59.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-boxes.new/gnome-boxes.changes 
2016-06-19 10:50:09.0 +0200
@@ -1,0 +2,5 @@
+Sun May 22 15:47:38 UTC 2016 - zai...@opensuse.org
+
+- Pass --enable-vala to configure. Build from vala sources.
+
+---



Other differences:
--
++ gnome-boxes.spec ++
--- /var/tmp/diff_new_pack.VzuH7K/_old  2016-06-19 10:50:10.0 +0200
+++ /var/tmp/diff_new_pack.VzuH7K/_new  2016-06-19 10:50:10.0 +0200
@@ -88,8 +88,9 @@
 
 %build
 %configure \
---enable-usbredir \
---enable-smartcard
+--enable-smartcard \
+--enable-vala \
+--enable-usbredir
 make %{?_smp_mflags}
 
 %install
@@ -116,7 +117,12 @@
 %{_datadir}/appdata/org.gnome.Boxes.appdata.xml
 %{_datadir}/applications/org.gnome.Boxes.desktop
 %{_datadir}/glib-2.0/schemas/org.gnome.boxes.gschema.xml
-%{_datadir}/gnome-boxes/
+%dir %{_datadir}/gnome-boxes
+%dir %{_datadir}/gnome-boxes/sources
+%dir %{_datadir}/gnome-boxes/unattended
+%{_datadir}/gnome-boxes/gnome-boxes-logos-db.xml
+%{_datadir}/gnome-boxes/sources/QEMU_Session
+%{_datadir}/gnome-boxes/unattended/disk.img
 %{_datadir}/icons/hicolor/*/apps/gnome-boxes*
 
 %files -n gnome-shell-search-provider-boxes




commit ubuntu-themes for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package ubuntu-themes for openSUSE:Factory 
checked in at 2016-06-19 10:50:35

Comparing /work/SRC/openSUSE:Factory/ubuntu-themes (Old)
 and  /work/SRC/openSUSE:Factory/.ubuntu-themes.new (New)


Package is "ubuntu-themes"

Changes:

--- /work/SRC/openSUSE:Factory/ubuntu-themes/ubuntu-themes.changes  
2016-05-29 03:14:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.ubuntu-themes.new/ubuntu-themes.changes 
2016-06-19 10:50:38.0 +0200
@@ -1,0 +2,7 @@
+Fri Jun 17 16:43:36 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 14.04~bzr20160613:
+  * [Suru icons] Add location indicator icons for inactive, idle
+and active states (lp#1407921).
+
+---

Old:

  ubuntu-themes_14.04+16.04.20160426.orig.tar.gz

New:

  ubuntu-themes_14.04+16.10.20160613.orig.tar.gz



Other differences:
--
++ ubuntu-themes.spec ++
--- /var/tmp/diff_new_pack.Q0HXIp/_old  2016-06-19 10:50:40.0 +0200
+++ /var/tmp/diff_new_pack.Q0HXIp/_new  2016-06-19 10:50:40.0 +0200
@@ -16,9 +16,9 @@
 #
 
 
-%define _version 14.04+16.04.20160426
+%define _version 14.04+16.10.20160613
 Name:   ubuntu-themes
-Version:14.04~bzr20160426
+Version:14.04~bzr20160613
 Release:0
 Summary:Eyecandy from Ubuntu
 License:GPL-3.0+

++ ubuntu-themes_14.04+16.04.20160426.orig.tar.gz -> 
ubuntu-themes_14.04+16.10.20160613.orig.tar.gz ++
/work/SRC/openSUSE:Factory/ubuntu-themes/ubuntu-themes_14.04+16.04.20160426.orig.tar.gz
 
/work/SRC/openSUSE:Factory/.ubuntu-themes.new/ubuntu-themes_14.04+16.10.20160613.orig.tar.gz
 differ: char 5, line 1




commit vdr-plugin-epgsearch for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package vdr-plugin-epgsearch for 
openSUSE:Factory checked in at 2016-06-19 10:50:40

Comparing /work/SRC/openSUSE:Factory/vdr-plugin-epgsearch (Old)
 and  /work/SRC/openSUSE:Factory/.vdr-plugin-epgsearch.new (New)


Package is "vdr-plugin-epgsearch"

Changes:

--- 
/work/SRC/openSUSE:Factory/vdr-plugin-epgsearch/vdr-plugin-epgsearch.changes
2015-03-11 09:56:52.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.vdr-plugin-epgsearch.new/vdr-plugin-epgsearch.changes
   2016-06-19 10:50:43.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 19:53:21 UTC 2016 - seife+...@b1-systems.com
+
+- add patch epgsearch-gcc6.patch to fix build with gcc 6
+
+---

New:

  epgsearch-gcc6.patch



Other differences:
--
++ vdr-plugin-epgsearch.spec ++
--- /var/tmp/diff_new_pack.CdjObn/_old  2016-06-19 10:50:44.0 +0200
+++ /var/tmp/diff_new_pack.CdjObn/_new  2016-06-19 10:50:44.0 +0200
@@ -1,8 +1,8 @@
 #
 # spec file for package vdr-plugin-epgsearch
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
-# Copyright (c) 2014 B1 Systems GmbH, Vohburg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 B1 Systems GmbH, Vohburg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -32,6 +32,7 @@
 Source: %plugintarball
 Patch0: %pluginname-1.0.1.beta5-fix-bashisms.patch
 Patch1: epgsearch-vdr-2.2.patch
+Patch2: epgsearch-gcc6.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Summary:VDR %pluginname plugin
 License:GPL-2.0+
@@ -54,6 +55,7 @@
 %setup -q -n %plugindir
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 chmod 644 scripts/*
 rm -f scripts/*~
 

++ epgsearch-gcc6.patch ++
Index: b/switchtimer.c
===
--- a/switchtimer.c
+++ b/switchtimer.c
@@ -157,7 +157,7 @@ bool cSwitchTimer::Save(FILE *f)
 
 cSwitchTimer* cSwitchTimers::InSwitchList(const cEvent* event)
 {
-if (!event) return false;
+if (!event) return NULL;
 cMutexLock SwitchTimersLock(this);
 cSwitchTimer* switchTimer = SwitchTimers.First();
 while (switchTimer)



commit perl-Image-ExifTool for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package perl-Image-ExifTool for 
openSUSE:Factory checked in at 2016-06-19 10:50:09

Comparing /work/SRC/openSUSE:Factory/perl-Image-ExifTool (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Image-ExifTool.new (New)


Package is "perl-Image-ExifTool"

Changes:

--- /work/SRC/openSUSE:Factory/perl-Image-ExifTool/perl-Image-ExifTool.changes  
2016-05-02 10:44:55.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Image-ExifTool.new/perl-Image-ExifTool.changes 
2016-06-19 10:50:11.0 +0200
@@ -1,0 +2,59 @@
+Tue Jun 14 17:43:24 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 10.20 (changes since 10.15):
+  * Add %D, %F and %E filename format codes.
+  * Add a new Minolta lens.
+  * Decode Photoshop Compression mode.
+  * Decode Nikon MultiExposure information for the D5.
+  * Update decoding of Sony tags for ILCA-68.
+  * Fix bug adding back XMP tags after deleting all XMP from
+MOV/MP4 files.
+  * Fix problem using -o option when reading from stdin (ie. FILE
+is "-").
+  * Fix problem where user-defined Composite tags may not always
+override pre-defined Composite tags with the same name, and
+added feature to allow the user to specify whether they should
+override existing tags or not.
+  * Add support for Leica X-U (Typ 113) maker notes.
+  * Add a new Pentax LensType.
+  * Add a number of new Sony lenses.
+  * Add a new Canon LensType.
+  * Extract TIFF-format thumbnails and previews.
+  * Patch to ignore XML entities inside comments.
+  * Fix inconsistent conversion of PreviewColorSpace values.
+  * Fix writing of TargetPrinter tag.
+  * Fix bug introduced in 10.16 which which could cause a runtime
+warning when using the -o option and not writing any "real"
+tags.
+  * Add a number of new Sigma LensTypes.
+  * Add a few new Sony/Minolta lenses.
+  * Add ability to write FilePermissions.
+  * Decode NikonCustom settings for the D500.
+  * Decode PLUS MediaSummaryCode values.
+  * Use hexadecimal for Sigma LensType values.
+  * Change -fileOrder option to sort numbers in strings numerically.
+  * Fix typo in Samsung lens name.
+  * Add a few new Sony and Sigma LensType values.
+  * Decode more Nikon tags.
+  * Fix an incorrect Sigma LensType.
+  * Fix decoding of D500 custom settings for NEF images.
+  * Add a few new Sigma LensTypes.
+  * Add a new Sony LensType.
+  * Add two new Canon LensTypes.
+  * Add a couple of new PentaxModelID's.
+  * Add a new Pentax LensType.
+  * Add a few new Olympus PictureMode values.
+  * Add a few more XMP tags.
+  * Decode a new Nikon video tag.
+  * Patch to allow protected binary data tags to be extracted when
+-b is combined with -php or -X if the tag is specifically
+requested.
+  * Fix bug introduced in version 9.96 where extended XMP is
+ignored if the MWG module is used
+  * Fix problem where the MWG module wasn't loaded automatically
+if there were MWG tags in the argument to the -p option.
+  * Fix column alignment of alternate-language output (requires
+Unicode::GCString to be installed).
+  * Fix problem writing Sigma:LensFocalRange.
+
+---

Old:

  Image-ExifTool-10.15.tar.gz

New:

  Image-ExifTool-10.20.tar.gz



Other differences:
--
++ perl-Image-ExifTool.spec ++
--- /var/tmp/diff_new_pack.2a4sZ7/_old  2016-06-19 10:50:12.0 +0200
+++ /var/tmp/diff_new_pack.2a4sZ7/_new  2016-06-19 10:50:12.0 +0200
@@ -18,7 +18,7 @@
 
 %define cpan_name Image-ExifTool
 Name:   perl-Image-ExifTool
-Version:10.15
+Version:10.20
 Release:0
 Summary:Perl module to read and write meta information
 License:GPL-1.0+ or Artistic-1.0
@@ -30,7 +30,7 @@
 Requires:   perl(File::RandomAccess)
 Conflicts:  exiftool < %{version}
 BuildArch:  noarch
-%perl_requires
+%{?perl_requires}
 
 %description
 ExifTool is a customisable set of Perl modules plus a full-featured

++ Image-ExifTool-10.15.tar.gz -> Image-ExifTool-10.20.tar.gz ++
 26844 lines of diff (skipped)




commit librecad for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package librecad for openSUSE:Factory 
checked in at 2016-06-19 10:50:28

Comparing /work/SRC/openSUSE:Factory/librecad (Old)
 and  /work/SRC/openSUSE:Factory/.librecad.new (New)


Package is "librecad"

Changes:

--- /work/SRC/openSUSE:Factory/librecad/librecad.changes2016-06-02 
09:38:53.0 +0200
+++ /work/SRC/openSUSE:Factory/.librecad.new/librecad.changes   2016-06-19 
10:50:32.0 +0200
@@ -1,0 +2,15 @@
+Fri Jun 17 10:21:20 UTC 2016 - jsl...@suse.com
+
+- add librecad-gcc6.patch
+
+---
+Tue Jun  7 07:51:47 UTC 2016 - jsl...@suse.com
+
+- Update to new upstream release 2.1.0
+  * new features
+  * lot of bug fixes
+  * other changes
+  * see full changelog at:
+
https://github.com/LibreCAD/ChangeLogs/blob/master/developers/r-a-v-a-s/2-1/2-1-0/2-1-0.md
+
+---

Old:

  2.0.11.tar.gz

New:

  2.1.0.tar.gz
  librecad-gcc6.patch



Other differences:
--
++ librecad.spec ++
--- /var/tmp/diff_new_pack.3rT0lo/_old  2016-06-19 10:50:34.0 +0200
+++ /var/tmp/diff_new_pack.3rT0lo/_new  2016-06-19 10:50:34.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   librecad
-Version:2.0.11
+Version:2.1.0
 Release:0
 Summary:Computer-aided design (CAD) software package for 2D design and 
drafting
 License:GPL-2.0 and (Apache-2.0 or SUSE-GPL-3.0+-with-font-exception)
@@ -34,6 +34,7 @@
 Source4:http://wiki.librecad.org/images/9/9d/Electrical1-LCAD.zip
 Source10:   ttf2lff.1
 Source20:   %name-rpmlintrc
+Patch0: librecad-gcc6.patch
 Patch1: librecad-no-date.diff
 Patch2: librecad-use-system-libdxfrw.patch
 Patch3: librecad-install.diff
@@ -87,9 +88,13 @@
 
 %prep
 %setup -qn LibreCAD-%version -a 2 -a 3 -a 4
-%patch -P 1 -P 2 -P 3 -P 4 -p1
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
 %if 0%{?suse_version} >= 1321
-%patch -P 5 -p1
+%patch5 -p1
 %endif
 
 dxfrw_includedir=$(pkg-config --cflags-only-I libdxfrw0 | sed 's|-I||g')
@@ -97,6 +102,9 @@
 # Fix paths
 sed -i 's|##LIBDIR##|%_libdir|g' librecad/src/lib/engine/rs_system.cpp
 sed -i 's|$${DXFRW_INCLUDEDIR}|'"$dxfrw_includedir"'|g' librecad/src/src.pro
+%if 0%{?suse_version} >= 1321
+sed -i 's@LRELEASE="lrelease"@LRELEASE="lrelease-qt5"@' 
scripts/postprocess-unix.sh
+%endif
 
 # Make sure bundled libraries are not used
 rm -rf libraries/libdxfrw
@@ -108,6 +116,7 @@
 sed -i 's/\r$//' LICENSE-MIT.txt LICENSE_KST32B_v2.txt 
license-lc_opengost-fonts.txt
 
 %build
+echo 'DISABLE_POSTSCRIPT = true' > librecad/src/custom.pri
 %if 0%{?suse_version} >= 1321
 qmake-qt5 \
 %else

++ 2.0.11.tar.gz -> 2.1.0.tar.gz ++
/work/SRC/openSUSE:Factory/librecad/2.0.11.tar.gz 
/work/SRC/openSUSE:Factory/.librecad.new/2.1.0.tar.gz differ: char 16, line 1




++ librecad-gcc6.patch ++
Subject: Fix gcc6 build failure

Taken from fedora.

---
diff -up 
LibreCAD-dbf1cc7c9597740d34a068f6f09c36841054e903/librecad/src/boost.pri.gcc6 
LibreCAD-dbf1cc7c9597740d34a068f6f09c36841054e903/librecad/src/boost.pri
--- 
LibreCAD-dbf1cc7c9597740d34a068f6f09c36841054e903/librecad/src/boost.pri.gcc6   
2016-06-06 11:47:24.087659733 -0400
+++ LibreCAD-dbf1cc7c9597740d34a068f6f09c36841054e903/librecad/src/boost.pri
2016-06-06 11:47:27.439636022 -0400
@@ -113,7 +113,7 @@ unix {
 }
 
 
-INCLUDEPATH += $${BOOST_INCDIR}
+# INCLUDEPATH += $${BOOST_INCDIR}
 HEADERS += $${BOOST_INCDIR}
 
 !isEmpty( BOOST_LIBS ) {
diff -up 
LibreCAD-dbf1cc7c9597740d34a068f6f09c36841054e903/librecad/src/muparser.pri.gcc6
 LibreCAD-dbf1cc7c9597740d34a068f6f09c36841054e903/librecad/src/muparser.pri
--- 
LibreCAD-dbf1cc7c9597740d34a068f6f09c36841054e903/librecad/src/muparser.pri.gcc6
2016-06-05 02:27:45.0 -0400
+++ LibreCAD-dbf1cc7c9597740d34a068f6f09c36841054e903/librecad/src/muparser.pri 
2016-06-06 11:46:11.508173138 -0400
@@ -2,9 +2,7 @@
 macx|win32|equals(build_muparser, "true")|!packagesExist(muparser){
 message("Using bundled muparser")
MUPARSER_DIR = ../../libraries/muparser
-   DEPENDPATH += $$MUPARSER_DIR/include \
-   $$MUPARSER_DIR/src
-   INCLUDEPATH += $$MUPARSER_DIR/include
+   DEPENDPATH += $$MUPARSER_DIR/src
GEN_LIB_DIR = ../../generated/lib
LIBS += -L$$GEN_LIB_DIR -lmuparser
PRE_TARGETDEPS += $$GEN_LIB_DIR/libmuparser.a
++ librecad-install.diff ++
--- /var/tmp/diff_new_pack.3rT0lo/_old  2016-06-19 10:50:34.0 +0200
+++ /var/tmp/diff_new_pack.3rT0lo/_new  2016-06-19 10:50:34.0 +0200
@@ -1,24 +1,13 @@

commit doomsday for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package doomsday for openSUSE:Factory 
checked in at 2016-06-19 10:50:11

Comparing /work/SRC/openSUSE:Factory/doomsday (Old)
 and  /work/SRC/openSUSE:Factory/.doomsday.new (New)


Package is "doomsday"

Changes:

--- /work/SRC/openSUSE:Factory/doomsday/doomsday.changes2015-04-07 
09:29:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.doomsday.new/doomsday.changes   2016-06-19 
10:50:13.0 +0200
@@ -1,0 +2,5 @@
+Thu Jun 16 22:13:12 UTC 2016 - jeng...@inai.de
+
+- Add -Wno-narrowing to let gcc6 build pass
+
+---



Other differences:
--
++ doomsday.spec ++
--- /var/tmp/diff_new_pack.gLSc5Q/_old  2016-06-19 10:50:16.0 +0200
+++ /var/tmp/diff_new_pack.gLSc5Q/_new  2016-06-19 10:50:16.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package doomsday
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -90,23 +90,27 @@
 %patch -P 1 -p1
 
 %build
-pushd doomsday;
-find . -type f -name "*.h" -exec perl -i -pe 's{__DATE__}{""}gs' "{}" "+";
+pushd doomsday
+find . -type f -name "*.h" -exec perl -i -pe 's{__DATE__}{""}gs' "{}" "+"
 %if 0%{?fedora_version}
-alias qmake="qmake-qt4";
+alias qmake="qmake-qt4"
 %endif
-qmake QMAKE_CFLAGS+="%optflags" QMAKE_CXXFLAGS+="%optflags" \
-   QMAKE_STRIP="true" DENG_LIB_DIR="%_libdir";
-make %{?_smp_mflags};
-popd;
+cf="%optflags"
+%if 0%{?suse_version} > 1320
+cf="$cf -Wno-narrowing"
+%endif
+qmake QMAKE_CFLAGS+="%optflags" QMAKE_CXXFLAGS+="$cf" \
+   QMAKE_STRIP="true" DENG_LIB_DIR="%_libdir"
+make %{?_smp_mflags}
+popd
 
 %install
-b="%buildroot";
-pushd doomsday/;
-make install INSTALL_ROOT="$b";
-mkdir -p "$b/%_libexecdir/%name";
-mv "$b/%_bindir"/{md2tool,savegametool,texc} "$b/%_libexecdir/%name/";
-popd;
+b="%buildroot"
+pushd doomsday/
+make install INSTALL_ROOT="$b"
+mkdir -p "$b/%_libexecdir/%name"
+mv "$b/%_bindir"/{md2tool,savegametool,texc} "$b/%_libexecdir/%name/"
+popd
 
 # Prepare for the icons
 mkdir -p "$b/%_datadir/pixmaps"




commit vdr-plugin-satip for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package vdr-plugin-satip for 
openSUSE:Factory checked in at 2016-06-19 10:50:38

Comparing /work/SRC/openSUSE:Factory/vdr-plugin-satip (Old)
 and  /work/SRC/openSUSE:Factory/.vdr-plugin-satip.new (New)


Package is "vdr-plugin-satip"

Changes:

--- /work/SRC/openSUSE:Factory/vdr-plugin-satip/vdr-plugin-satip.changes
2015-11-02 12:55:06.0 +0100
+++ /work/SRC/openSUSE:Factory/.vdr-plugin-satip.new/vdr-plugin-satip.changes   
2016-06-19 10:50:42.0 +0200
@@ -1,0 +2,5 @@
+Fri Jun 17 20:03:28 UTC 2016 - seife+...@b1-systems.com
+
+- add vdr-satip-gcc6.patch to fix build with GCC 6
+
+---

New:

  vdr-satip-gcc6.patch



Other differences:
--
++ vdr-plugin-satip.spec ++
--- /var/tmp/diff_new_pack.G4Q4YN/_old  2016-06-19 10:50:43.0 +0200
+++ /var/tmp/diff_new_pack.G4Q4YN/_new  2016-06-19 10:50:43.0 +0200
@@ -1,8 +1,8 @@
 #
 # spec file for package vdr-plugin-satip
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
-# Copyright (c) 2014,2015 B1 Systems GmbH, Vohburg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2014,2015,2016 B1 Systems GmbH, Vohburg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -25,6 +25,7 @@
 Group:  Productivity/Multimedia/Other
 Url:http://www.saunalahti.fi/~rahrenbe/vdr/satip/
 Source0:
http://www.saunalahti.fi/~rahrenbe/vdr/satip/files/vdr-satip-%{version}.tgz
+Patch0: vdr-satip-gcc6.patch
 BuildRequires:  gcc-c++
 BuildRequires:  pkg-config
 BuildRequires:  tinyxml-devel
@@ -44,6 +45,7 @@
 
 %prep
 %setup -q -n satip-%{version}
+%patch0 -p1
 
 %build
 # use msgmerge wrapper

++ vdr-satip-gcc6.patch ++
diff --git a/common.h b/common.h
index ac9ea20..a17a1fd 100644
--- a/common.h
+++ b/common.h
@@ -52,7 +52,7 @@
   do {   \
  if (exp) {  \
 char tmp[64];\
-esyslog("[%s,%d]: "errstr": %s", __FILE__, __LINE__, \
+esyslog("[%s,%d]: " errstr ": %s", __FILE__, __LINE__, \
 strerror_r(errno, tmp, sizeof(tmp)));\
 func;\
 ret; \



commit aria2 for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package aria2 for openSUSE:Factory checked 
in at 2016-06-19 10:50:44

Comparing /work/SRC/openSUSE:Factory/aria2 (Old)
 and  /work/SRC/openSUSE:Factory/.aria2.new (New)


Package is "aria2"

Changes:

--- /work/SRC/openSUSE:Factory/aria2/aria2.changes  2016-05-17 
17:16:39.0 +0200
+++ /work/SRC/openSUSE:Factory/.aria2.new/aria2.changes 2016-06-19 
10:50:47.0 +0200
@@ -1,0 +2,16 @@
+Sat Jun 18 10:02:37 UTC 2016 - mplus...@suse.com
+
+- Update to version 1.24.0:
+  * BitTorrent: Allow 32KiB request
+  * Don't unchoke peer which is not interested in us
+  * Fix bug that evaluation of Peer::amChoking is negated
+  * Faster seed/download on fast connection
+  * Increase DHT task concurrency to 15
+  * Fixed mmap failure check with MAP_FAILED flag
+  * Added file size overflow check for mmap on 32bit os
+  * Use standard percent-encode for tracker request query
+  * mingw32: Gain privilege before opening files
+  * Restart active download to apply previously not applicable
+options
+
+---

Old:

  aria2-1.23.0.tar.xz

New:

  aria2-1.24.0.tar.xz



Other differences:
--
++ aria2.spec ++
--- /var/tmp/diff_new_pack.A39SAq/_old  2016-06-19 10:50:49.0 +0200
+++ /var/tmp/diff_new_pack.A39SAq/_new  2016-06-19 10:50:49.0 +0200
@@ -18,7 +18,7 @@
 
 %define somajor 0
 Name:   aria2
-Version:1.23.0
+Version:1.24.0
 Release:0
 Summary:Parallelizing Multi-Protocol Utility for Downloading Files
 License:SUSE-GPL-2.0-with-openssl-exception
@@ -75,7 +75,7 @@
 %package devel
 Summary:Devel files for %{name}
 Group:  Development/Libraries/C and C++
-Requires:   lib%{name}-%{somajor} = %{version}-%{release}
+Requires:   lib%{name}-%{somajor} = %{version}
 
 %description devel
 aria2 is a utility for downloading files. It has completely new design

++ aria2-1.23.0.tar.xz -> aria2-1.24.0.tar.xz ++
 40448 lines of diff (skipped)




commit python3-lesscpy for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package python3-lesscpy for openSUSE:Factory 
checked in at 2016-06-19 10:48:56

Comparing /work/SRC/openSUSE:Factory/python3-lesscpy (Old)
 and  /work/SRC/openSUSE:Factory/.python3-lesscpy.new (New)


Package is "python3-lesscpy"

Changes:

--- /work/SRC/openSUSE:Factory/python3-lesscpy/python3-lesscpy.changes  
2016-05-25 21:24:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-lesscpy.new/python3-lesscpy.changes 
2016-06-19 10:49:04.0 +0200
@@ -1,0 +2,5 @@
+Mon Jun 13 16:57:21 UTC 2016 - toddrme2...@gmail.com
+
+- Remove unneeded test dependencies.
+
+---



Other differences:
--
++ python3-lesscpy.spec ++
--- /var/tmp/diff_new_pack.PDuxFj/_old  2016-06-19 10:49:05.0 +0200
+++ /var/tmp/diff_new_pack.PDuxFj/_new  2016-06-19 10:49:05.0 +0200
@@ -30,8 +30,6 @@
 BuildRequires:  python3-setuptools
 BuildRequires:  python3-six
 # Test requirements:
-BuildRequires:  python3-coverage
-BuildRequires:  python3-flake8
 BuildRequires:  python3-nose
 BuildConflicts: python3-buildservice-tweak
 Requires:   python3-ply




commit rofi for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package rofi for openSUSE:Factory checked in 
at 2016-06-19 10:49:51

Comparing /work/SRC/openSUSE:Factory/rofi (Old)
 and  /work/SRC/openSUSE:Factory/.rofi.new (New)


Package is "rofi"

Changes:

--- /work/SRC/openSUSE:Factory/rofi/rofi.changes2016-05-13 
09:24:18.0 +0200
+++ /work/SRC/openSUSE:Factory/.rofi.new/rofi.changes   2016-06-19 
10:49:53.0 +0200
@@ -1,0 +2,25 @@
+Thu Jun 16 12:18:30 UTC 2016 - mvet...@suse.com
+
+- Fix typo in xdg-terminal.patch
+
+---
+Thu Jun 16 11:57:08 UTC 2016 - mvet...@suse.com
+
+- Update to version 1.1.0:
+  New Features
+* Keys mode, showing keybindings.
+   * Stop cycling option (#407) (Thx to Yaroslav)
+* Kill window on delete entry (#316)
+  Improvements
+* Add Control+Backspace as remove word back keybinding.
+* Allow user to use X11 background for fake transparency (#390)
+* Allow user to specify background image.
+* Improved keybinding handling, allowing on-release and modifier only 
(#384).
+* Use display name for prompt (#409)
+* Parse subdirectories in drun parser (#416)
+* Switch to stop cycling (#407)
+  Bug fixes
+   * Grab mouse pointer with keyboard
+- Update xdg-terminal.patch to match
+
+---

Old:

  rofi-1.0.1.tar.gz

New:

  rofi-1.1.0.tar.gz



Other differences:
--
++ rofi.spec ++
--- /var/tmp/diff_new_pack.meu5cq/_old  2016-06-19 10:49:53.0 +0200
+++ /var/tmp/diff_new_pack.meu5cq/_new  2016-06-19 10:49:53.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   rofi
-Version:1.0.1
+Version:1.1.0
 Release:0
 Summary:A window switcher, run dialog and dmenu replacement
 License:MIT

++ rofi-1.0.1.tar.gz -> rofi-1.1.0.tar.gz ++
 3756 lines of diff (skipped)

++ xdg-terminal.patch ++
--- /var/tmp/diff_new_pack.meu5cq/_old  2016-06-19 10:49:54.0 +0200
+++ /var/tmp/diff_new_pack.meu5cq/_new  2016-06-19 10:49:54.0 +0200
@@ -1,6 +1,6 @@
-diff -urEbwB rofi-1.0.0/config/config.c rofi-1.0.0.new/config/config.c
 rofi-1.0.0/config/config.c 2016-04-03 13:34:33.0 +0200
-+++ rofi-1.0.0.new/config/config.c 2016-04-19 11:47:04.843817905 +0200
+diff -urEbwB rofi-1.1.0/config/config.c rofi-1.1.0.new/config/config.c
+--- rofi-1.1.0/config/config.c 2016-05-30 20:48:11.0 +0200
 rofi-1.1.0.new/config/config.c 2016-06-16 14:08:10.208852900 +0200
 @@ -56,16 +56,16 @@
  .color_window = "#fdf6e3,#002b36",
  
@@ -10,14 +10,14 @@
  .ssh_client= "ssh",
  /** Command when executing ssh. */
 -.ssh_command   = "{terminal} -e {ssh-client} {host}",
-+.ssh_command   = "{terminal} {ssh-client} {host}",
++.ssh_command   = "{terminal} '{ssh-client} {host}'",
  /** Command when running */
  .run_command   = "{cmd}",
  /** Command used to list executable commands. empty -> internal */
  .run_list_command  = "",
  /** Command executed when running application in terminal */
 -.run_shell_command = "{terminal} -e {cmd}",
-+.run_shell_command = "{terminal} {cmd}",
++.run_shell_command = "{terminal} '{cmd}'",
+ /** Command executed on accep-entry-custom for window modus */
+ .window_command= "xkill -id {window}",
  /**
-  * Location of the window.
-  * Enumeration indicating location or gravity of window.




commit python-gst for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package python-gst for openSUSE:Factory 
checked in at 2016-06-19 10:49:40

Comparing /work/SRC/openSUSE:Factory/python-gst (Old)
 and  /work/SRC/openSUSE:Factory/.python-gst.new (New)


Package is "python-gst"

Changes:

--- /work/SRC/openSUSE:Factory/python-gst/python-gst.changes2016-05-03 
10:16:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-gst.new/python-gst.changes   
2016-06-19 10:49:42.0 +0200
@@ -1,0 +2,6 @@
+Wed Jun 15 14:30:35 UTC 2016 - zai...@opensuse.org
+
+- Update to version 1.8.2:
+  + No changes, version bump only.
+
+---
python3-gst.changes: same change

Old:

  gst-python-1.8.1.tar.xz

New:

  gst-python-1.8.2.tar.xz



Other differences:
--
++ python-gst.spec ++
--- /var/tmp/diff_new_pack.SJ7YLn/_old  2016-06-19 10:49:43.0 +0200
+++ /var/tmp/diff_new_pack.SJ7YLn/_new  2016-06-19 10:49:43.0 +0200
@@ -34,7 +34,7 @@
 
 Name:   python-gst
 %define _name gst-python
-Version:1.8.1
+Version:1.8.2
 Release:0
 Summary:Python Bindings for GStreamer
 License:LGPL-2.1+

++ python3-gst.spec ++
--- /var/tmp/diff_new_pack.SJ7YLn/_old  2016-06-19 10:49:43.0 +0200
+++ /var/tmp/diff_new_pack.SJ7YLn/_new  2016-06-19 10:49:43.0 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package python-gst
+# spec file for package python3-gst
 #
 # Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
@@ -34,7 +34,7 @@
 
 Name:   python3-gst
 %define _name gst-python
-Version:1.8.1
+Version:1.8.2
 Release:0
 Summary:Python Bindings for GStreamer
 License:LGPL-2.1+

++ gst-python-1.8.1.tar.xz -> gst-python-1.8.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gst-python-1.8.1/ChangeLog 
new/gst-python-1.8.2/ChangeLog
--- old/gst-python-1.8.1/ChangeLog  2016-04-20 17:21:03.0 +0200
+++ new/gst-python-1.8.2/ChangeLog  2016-06-09 10:30:58.0 +0200
@@ -1,9 +1,20 @@
+=== release 1.8.2 ===
+
+2016-06-09  Sebastian Dröge 
+
+   * configure.ac:
+ releasing 1.8.2
+
 === release 1.8.1 ===
 
-2016-04-20  Sebastian Dröge 
+2016-04-20 18:35:29 +0300  Sebastian Dröge 
 
+   * ChangeLog:
+   * NEWS:
+   * RELEASE:
* configure.ac:
- releasing 1.8.1
+   * gst-python.doap:
+ Release 1.8.1
 
 === release 1.8.0 ===
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gst-python-1.8.1/Makefile.in 
new/gst-python-1.8.2/Makefile.in
--- old/gst-python-1.8.1/Makefile.in2016-04-20 14:17:57.0 +0200
+++ new/gst-python-1.8.2/Makefile.in2016-06-09 10:30:56.0 +0200
@@ -179,7 +179,7 @@
$(top_srcdir)/common/cruft.mak \
$(top_srcdir)/common/release.mak AUTHORS COPYING ChangeLog \
INSTALL NEWS README TODO compile config.guess config.sub \
-   install-sh ltmain.sh missing py-compile
+   depcomp install-sh ltmain.sh missing py-compile
 DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
 distdir = $(PACKAGE)-$(VERSION)
 top_distdir = $(distdir)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gst-python-1.8.1/NEWS new/gst-python-1.8.2/NEWS
--- old/gst-python-1.8.1/NEWS   2016-04-20 17:21:49.0 +0200
+++ new/gst-python-1.8.2/NEWS   2016-06-09 10:32:53.0 +0200
@@ -1,24 +1,26 @@
-### 1.8.1
+### 1.8.2
 
-The first 1.8 bug-fix release (1.8.1) was released on 20 April 2016.
+The first 1.8 bug-fix release (1.8.2) was released on 9 June 2016.
 This release only contains bugfixes and it should be safe to update from 1.8.0.
 
- Major bugfixes in 1.8.1
+ Major bugfixes in 1.8.2
 
- - Fix app compilation with Android NDK r11 and newer
- - Fix compilation of nvenc plugin against latest NVIDIA SDK 6.0
- - Fix regression in avdeinterlace
- - Fix memory corruption in scaletempo element with S16 input
- - Fix regression in qtdemux with MSE streams
- - Fix glitches at the start with all audio sinks except for pulsesink
- - Fix regression with encrypted HLS streams
- - Fix automatic multithreaded decoding of VP8/9 video
- - Fix deadlock in HTTP adaptive streams when scrub-seeking
- - Fix regression in RTSP source with SRTP
- - Add support for SRTP rollover counters in the RTSP source
- - Add support for HiDPI ("Retina") screens in caopengllayersink
- - ... and many more!
+ - Fix vp8enc and flacenc segmentation faults on Windows
+ - Fix Android build failure due to 

commit gstreamer-plugins-vaapi for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package gstreamer-plugins-vaapi for 
openSUSE:Factory checked in at 2016-06-19 10:49:12

Comparing /work/SRC/openSUSE:Factory/gstreamer-plugins-vaapi (Old)
 and  /work/SRC/openSUSE:Factory/.gstreamer-plugins-vaapi.new (New)


Package is "gstreamer-plugins-vaapi"

Changes:

--- 
/work/SRC/openSUSE:Factory/gstreamer-plugins-vaapi/gstreamer-plugins-vaapi.changes
  2016-06-14 23:09:05.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.gstreamer-plugins-vaapi.new/gstreamer-plugins-vaapi.changes
 2016-06-19 10:49:13.0 +0200
@@ -1,0 +2,6 @@
+Tue Jun 14 20:05:03 UTC 2016 - zai...@opensuse.org
+
+- Update to version 1.8.2:
+  + bgo#765702: build: errors when compiling without X11.
+
+---

Old:

  gstreamer-vaapi-1.8.1.tar.xz

New:

  gstreamer-vaapi-1.8.2.tar.xz



Other differences:
--
++ gstreamer-plugins-vaapi.spec ++
--- /var/tmp/diff_new_pack.61Egto/_old  2016-06-19 10:49:14.0 +0200
+++ /var/tmp/diff_new_pack.61Egto/_new  2016-06-19 10:49:14.0 +0200
@@ -19,7 +19,7 @@
 %define gst_branch 1.0
 
 Name:   gstreamer-plugins-vaapi
-Version:1.8.1
+Version:1.8.2
 Release:0
 Summary:Gstreamer VA-API plugins
 License:LGPL-2.1+

++ gstreamer-vaapi-1.8.1.tar.xz -> gstreamer-vaapi-1.8.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gstreamer-vaapi-1.8.1/ChangeLog 
new/gstreamer-vaapi-1.8.2/ChangeLog
--- old/gstreamer-vaapi-1.8.1/ChangeLog 2016-04-20 17:28:01.0 +0200
+++ new/gstreamer-vaapi-1.8.2/ChangeLog 2016-06-09 10:36:15.0 +0200
@@ -1,9 +1,33 @@
+=== release 1.8.2 ===
+
+2016-06-09  Sebastian Dröge 
+
+   * configure.ac:
+ releasing 1.8.2
+
+2016-04-29 13:11:48 +0200  Víctor Manuel Jáquez Leal 
+
+   * gst/vaapi/gstvaapipluginbase.h:
+ plugin: fix macro processor check
+ Instead of #ifdef it should be used #if becasuse USE_GST_GL_HELPERS 
is always
+ defined in config.h, but it would be 0 or 1 depending on the 
configure output.
+ https://bugzilla.gnome.org/show_bug.cgi?id=765702
+
+2016-04-29 12:53:06 +0200  Víctor Manuel Jáquez Leal 
+
+   * tests/test-display.c:
+ tests: display: guard possible unused variables
+ https://bugzilla.gnome.org/show_bug.cgi?id=765702
+
 === release 1.8.1 ===
 
-2016-04-20  Sebastian Dröge 
+2016-04-20 18:39:46 +0300  Sebastian Dröge 
 
+   * ChangeLog:
+   * NEWS:
* configure.ac:
- releasing 1.8.1
+   * gstreamer-vaapi.doap:
+ Release 1.8.1
 
 2016-04-13 20:33:32 +0200  Víctor Manuel Jáquez Leal 
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gstreamer-vaapi-1.8.1/Makefile.in 
new/gstreamer-vaapi-1.8.2/Makefile.in
--- old/gstreamer-vaapi-1.8.1/Makefile.in   2016-04-20 17:27:54.0 
+0200
+++ new/gstreamer-vaapi-1.8.2/Makefile.in   2016-06-09 09:27:12.0 
+0200
@@ -186,8 +186,8 @@
$(top_srcdir)/build-aux/ltmain.sh \
$(top_srcdir)/build-aux/missing AUTHORS COPYING.LIB ChangeLog \
INSTALL NEWS README build-aux/compile build-aux/config.guess \
-   build-aux/config.sub build-aux/depcomp build-aux/install-sh \
-   build-aux/ltmain.sh build-aux/missing
+   build-aux/config.sub build-aux/install-sh build-aux/ltmain.sh \
+   build-aux/missing
 DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
 distdir = $(PACKAGE)-$(VERSION)
 top_distdir = $(distdir)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gstreamer-vaapi-1.8.1/NEWS 
new/gstreamer-vaapi-1.8.2/NEWS
--- old/gstreamer-vaapi-1.8.1/NEWS  2016-04-20 17:29:01.0 +0200
+++ new/gstreamer-vaapi-1.8.2/NEWS  2016-06-09 10:37:00.0 +0200
@@ -1,25 +1,26 @@
-### 1.8.1
+### 1.8.2
 
-The first 1.8 bug-fix release (1.8.1) was released on 20 April 2016.
+The first 1.8 bug-fix release (1.8.2) was released on 9 June 2016.
 This release only contains bugfixes and it should be safe to update from 1.8.0.
 
- Major bugfixes in 1.8.1
+ Major bugfixes in 1.8.2
 
- - Fix app compilation with Android NDK r11 and newer
- - Fix compilation of nvenc plugin against latest NVIDIA SDK 6.0
- - Fix regression in avdeinterlace
- - Fix memory corruption in scaletempo element with S16 input
- - Fix regression in qtdemux with MSE streams
- - Fix glitches at the start with all audio sinks except for pulsesink
- - 

commit docker for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package docker for openSUSE:Factory checked 
in at 2016-06-19 10:49:28

Comparing /work/SRC/openSUSE:Factory/docker (Old)
 and  /work/SRC/openSUSE:Factory/.docker.new (New)


Package is "docker"

Changes:

--- /work/SRC/openSUSE:Factory/docker/docker.changes2016-05-23 
16:39:12.0 +0200
+++ /work/SRC/openSUSE:Factory/.docker.new/docker.changes   2016-06-19 
10:49:31.0 +0200
@@ -1,0 +2,28 @@
+Wed Jun  8 14:42:08 UTC 2016 - asa...@suse.de
+
+* Removed patches:
+  - cve-2016-3697-numeric-uid.patch (merged upstream in 
gh@docker/docker#22998).
+* Update Docker to 1.11.2. Changelog from upstream:
+
+* Networking
+  * Fix a stale endpoint issue on overlay networks during ungraceful restart
+(#23015)
+  * Fix an issue where the wrong port could be reported by docker
+inspect/ps/port (#22997)
+
+* Runtime
+  * Fix a potential panic when running docker build (#23032)
+  * Fix interpretation of --user parameter (#22998)
+  * Fix a bug preventing container statistics to be correctly reported (#22955)
+  * Fix an issue preventing container to be restarted after daemon restart
+(#22947)
+  * Fix issues when running 32 bit binaries on Ubuntu 16.04 (#22922)
+  * Fix a possible deadlock on image deletion and container attach (#22918)
+  * Fix an issue where containers fail to start after a daemon restart if they
+depend on a containerized cluster store (#22561)
+  * Fix an issue causing docker ps to hang on CentOS when using devicemapper
+(#22168, #23067)
+  * Fix a bug preventing to docker exec into a container when using
+devicemapper (#22168, #23067)
+
+---

Old:

  cve-2016-3697-numeric-uid.patch
  docker-1.11.1.tar.xz

New:

  docker-1.11.2.tar.xz



Other differences:
--
++ docker.spec ++
--- /var/tmp/diff_new_pack.YV7PcC/_old  2016-06-19 10:49:33.0 +0200
+++ /var/tmp/diff_new_pack.YV7PcC/_new  2016-06-19 10:49:33.0 +0200
@@ -22,10 +22,10 @@
 
 %define git_version 9e83765
 %define go_arches %ix86 x86_64 aarch64
-%define version_unconverted 1.11.1
+%define version_unconverted 1.11.2
 
 Name:   docker
-Version:1.11.1
+Version:1.11.2
 Release:0
 Summary:The Linux container runtime
 License:Apache-2.0
@@ -54,9 +54,6 @@
 Patch101:   gcc-go-patches.patch
 Patch102:   netlink_gcc_go.patch
 Patch103:   netlink_netns_powerpc.patch
-# This fixes bsc#976777. While the fix is upstream, it isn't in Docker 1.10.3 
or
-# Docker 1.11.0. This patch was squashed and cherry-picked from runc#708.
-Patch301:   cve-2016-3697-numeric-uid.patch
 # This fixes bnc#964673. This fix is in boltdb upstream, but has yet to be
 # merged into Docker (in a vendor commit). This patch was cherry-picked from
 # bolt#555.
@@ -177,8 +174,6 @@
 %patch102 -p1
 %patch103 -p1
 %endif
-# bsc#976777
-%patch301 -p1
 # bnc#964673
 %patch302 -p1
 cp %{SOURCE7} .

++ _service ++
--- /var/tmp/diff_new_pack.YV7PcC/_old  2016-06-19 10:49:33.0 +0200
+++ /var/tmp/diff_new_pack.YV7PcC/_new  2016-06-19 10:49:33.0 +0200
@@ -3,8 +3,8 @@
 https://github.com/docker/docker.git
 git
 .git
-1.11.1
-v1.11.1
+1.11.2
+v1.11.2
   
   
 docker-*.tar

++ docker-1.11.1.tar.xz -> docker-1.11.2.tar.xz ++
/work/SRC/openSUSE:Factory/docker/docker-1.11.1.tar.xz 
/work/SRC/openSUSE:Factory/.docker.new/docker-1.11.2.tar.xz differ: char 25, 
line 1




commit psi+ for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package psi+ for openSUSE:Factory checked in 
at 2016-06-19 10:49:21

Comparing /work/SRC/openSUSE:Factory/psi+ (Old)
 and  /work/SRC/openSUSE:Factory/.psi+.new (New)


Package is "psi+"

Changes:

--- /work/SRC/openSUSE:Factory/psi+/psi+.changes2016-05-05 
08:12:58.0 +0200
+++ /work/SRC/openSUSE:Factory/.psi+.new/psi+.changes   2016-06-19 
10:49:23.0 +0200
@@ -1,0 +2,8 @@
+Wed Jun  8 08:31:21 UTC 2016 - jsl...@suse.com
+
+- update to 20160607
+  * updated translations
+  * some bugfixes
+- add plugins-devel for building external plugins
+
+---

Old:

  psi+-20160501.tar.xz

New:

  psi+-20160607.tar.xz



Other differences:
--
++ psi+.spec ++
--- /var/tmp/diff_new_pack.t099Uj/_old  2016-06-19 10:49:24.0 +0200
+++ /var/tmp/diff_new_pack.t099Uj/_new  2016-06-19 10:49:24.0 +0200
@@ -20,11 +20,11 @@
 %define with_qt5 1
 %endif
 
-%define version_unconverted 20160501
+%define version_unconverted 20160607
 
 Name:   psi+
 Url:https://github.com/psi-plus
-Version:20160501
+Version:20160607
 Release:0
 Summary:Jabber client using Qt
 License:GPL-2.0+
@@ -118,6 +118,14 @@
 %description themes
 Themes for Psi.
 
+%package plugins-devel
+Summary:Headers for Psi plugins
+Group:  Development/Libraries/C and C++
+Requires:   %{name} = %{version}
+
+%description plugins-devel
+Headers and qmake project include files for developing Psi+ plugins.
+
 %package plugins-juickplugin
 Summary:Plugin for Psi
 Group:  Productivity/Networking/Talk/Clients
@@ -398,7 +406,7 @@
 %patch0 -p1
 
 %if 0%{?with_qt5}
-sed -i 's@\@&-qt5@' ../psi-plus-l10n-1/update-repo.sh
+sed -i 's@\@&-qt5@' ../psi-plus-l10n-1/update-translations.sh
 %endif
 
 # generic/antievil does not build (yet)
@@ -466,7 +474,7 @@
 make -C src/plugins %{?_smp_mflags}
 
 cd %{_builddir}/psi-plus-l10n-1/
-./update-repo.sh make
+./update-translations.sh make
 
 %install
 make INSTALL_ROOT=%{buildroot} install
@@ -675,4 +683,10 @@
 %defattr(-,root,root)
 %{_datadir}/psi-plus/themes
 
+%files plugins-devel
+%defattr(-,root,root)
+%dir %{_datadir}/psi-plus/plugins/
+%{_datadir}/psi-plus/plugins/include/
+%{_datadir}/psi-plus/plugins/*.pri
+
 %changelog

++ psi+-20160501.tar.xz -> psi+-20160607.tar.xz ++
/work/SRC/openSUSE:Factory/psi+/psi+-20160501.tar.xz 
/work/SRC/openSUSE:Factory/.psi+.new/psi+-20160607.tar.xz differ: char 26, line 
1

++ psi-plus-l10n-1.tar.xz ++
 55271 lines of diff (skipped)




commit firewalld for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package firewalld for openSUSE:Factory 
checked in at 2016-06-19 10:49:54

Comparing /work/SRC/openSUSE:Factory/firewalld (Old)
 and  /work/SRC/openSUSE:Factory/.firewalld.new (New)


Package is "firewalld"

Changes:

--- /work/SRC/openSUSE:Factory/firewalld/firewalld.changes  2016-06-02 
12:39:19.0 +0200
+++ /work/SRC/openSUSE:Factory/.firewalld.new/firewalld.changes 2016-06-19 
10:49:56.0 +0200
@@ -1,0 +2,7 @@
+Wed Jun  8 08:10:11 UTC 2016 - mchand...@suse.de
+
+- Add upstream patch to prevent unconditional dependencies to the
+  NetworkManager typelib (gh#t-woerner/firewalld#119)
+  * 0003-firewall.core.fw_nm-Hide-NM-typelib-import-new-nm_ge.patch
+
+---

New:

  0003-firewall.core.fw_nm-Hide-NM-typelib-import-new-nm_ge.patch



Other differences:
--
++ firewalld.spec ++
--- /var/tmp/diff_new_pack.ytzP1V/_old  2016-06-19 10:49:57.0 +0200
+++ /var/tmp/diff_new_pack.ytzP1V/_new  2016-06-19 10:49:57.0 +0200
@@ -30,6 +30,9 @@
 # PATCH-FIX-UPSTREAM: 
0002-firewall-core-fw_ifcfg-Quickly-return-if-ifcfg-direc.patch
 # Do not access the ifcfg directory if it does not exist
 Patch1: 0002-firewall-core-fw_ifcfg-Quickly-return-if-ifcfg-direc.patch
+# PATCH-FIX-UPSTREAM: 
0003-firewall.core.fw_nm-Hide-NM-typelib-import-new-nm_ge.patch
+# Hide unneeded NM dependencies
+Patch2: 0003-firewall.core.fw_nm-Hide-NM-typelib-import-new-nm_ge.patch
 BuildRequires:  desktop-file-utils
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  gettext
@@ -92,6 +95,7 @@
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %configure --enable-sysconfig --enable-rpmmacros

++ 0003-firewall.core.fw_nm-Hide-NM-typelib-import-new-nm_ge.patch ++
>From dbc30dd2dfee1b4b662aa997cee6a6cb59aa559f Mon Sep 17 00:00:00 2001
From: Thomas Woerner 
Date: Tue, 7 Jun 2016 16:19:20 +0200
Subject: [PATCH] firewall.core.fw_nm: Hide NM typelib import, new
 nm_get_dbus_interface function

The typelib import of NM should not be added to __all__. The new function
nm_get_dbus_interface has been added to be able to add a signal receiver for
NetworkManager firewall-config and firewall-applet.

Fixes: #119
---
 src/firewall-applet| 2 +-
 src/firewall-config| 2 +-
 src/firewall/core/fw_nm.py | 9 +++--
 3 files changed, 9 insertions(+), 4 deletions(-)

diff --git a/src/firewall-applet b/src/firewall-applet
index a078df8..1cf4633 100755
--- a/src/firewall-applet
+++ b/src/firewall-applet
@@ -550,7 +550,7 @@ class TrayApplet(QtGui.QSystemTrayIcon):
 if nm_is_imported():
 self.bus.add_signal_receiver(
 self.nm_signal_receiver,
-dbus_interface=NM.DBUS_INTERFACE,
+dbus_interface=nm_get_dbus_interface(),
 signal_name='PropertiesChanged',
 member_keyword='member')
 self.nm_signal_receiver()
diff --git a/src/firewall-config b/src/firewall-config
index b69c69f..e25b058 100755
--- a/src/firewall-config
+++ b/src/firewall-config
@@ -1250,7 +1250,7 @@ class FirewallConfig(object):
 if nm_is_imported():
 self.fw.bus.add_signal_receiver(
 self.nm_signal_receiver,
-dbus_interface=NM.DBUS_INTERFACE,
+dbus_interface=nm_get_dbus_interface(),
 signal_name='PropertiesChanged',
 member_keyword='member')
 else:
diff --git a/src/firewall/core/fw_nm.py b/src/firewall/core/fw_nm.py
index 3df94c4..8a8043b 100644
--- a/src/firewall/core/fw_nm.py
+++ b/src/firewall/core/fw_nm.py
@@ -21,10 +21,10 @@
 
 """Functions for NetworkManager interaction"""
 
-__all__ = [ "NM", "check_nm_imported", "nm_is_imported",
+__all__ = [ "check_nm_imported", "nm_is_imported",
 "nm_get_zone_of_connection", "nm_set_zone_of_connection",
 "nm_get_connections", "nm_get_connection_of_interface",
-"nm_get_bus_name" ]
+"nm_get_bus_name", "nm_get_dbus_interface" ]
 
 import gi
 try:
@@ -164,3 +164,8 @@ def nm_get_bus_name():
 except Exception as msg:
 log.debug2("Failed to get bus name of NetworkManager")
 return None
+
+def nm_get_dbus_interface():
+if not _nm_imported:
+return ""
+return NM.DBUS_INTERFACE
-- 
2.8.3




commit apache-pdfbox for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package apache-pdfbox for openSUSE:Factory 
checked in at 2016-06-19 10:49:49

Comparing /work/SRC/openSUSE:Factory/apache-pdfbox (Old)
 and  /work/SRC/openSUSE:Factory/.apache-pdfbox.new (New)


Package is "apache-pdfbox"

Changes:

--- /work/SRC/openSUSE:Factory/apache-pdfbox/apache-pdfbox.changes  
2016-03-26 15:22:40.0 +0100
+++ /work/SRC/openSUSE:Factory/.apache-pdfbox.new/apache-pdfbox.changes 
2016-06-19 10:49:50.0 +0200
@@ -1,0 +2,6 @@
+Thu Jun 16 08:43:53 UTC 2016 - fv...@suse.com
+
+- Update to version 1.8.12
+  - CVE-2016-2175 (pdfbox only, which isn't build by this spec)
+
+---

Old:

  fontbox-1.8.11.pom
  jempbox-1.8.11.pom
  pdfbox-1.8.11-src.zip
  pdfbox-1.8.11.pom

New:

  fontbox-1.8.12.pom
  jempbox-1.8.12.pom
  pdfbox-1.8.12-src.zip
  pdfbox-1.8.12.pom



Other differences:
--
++ apache-pdfbox.spec ++
--- /var/tmp/diff_new_pack.DoXPxJ/_old  2016-06-19 10:49:51.0 +0200
+++ /var/tmp/diff_new_pack.DoXPxJ/_new  2016-06-19 10:49:51.0 +0200
@@ -19,7 +19,7 @@
 # Only fontbox and jempbox are built as pdfbox itself depends on Adobe's pcif.
 
 Name:   apache-pdfbox
-Version:1.8.11
+Version:1.8.12
 Release:0
 Summary:Java PDF Library
 License:Apache-2.0




commit python3-kombu for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package python3-kombu for openSUSE:Factory 
checked in at 2016-06-19 10:48:55

Comparing /work/SRC/openSUSE:Factory/python3-kombu (Old)
 and  /work/SRC/openSUSE:Factory/.python3-kombu.new (New)


Package is "python3-kombu"

Changes:

--- /work/SRC/openSUSE:Factory/python3-kombu/python3-kombu.changes  
2016-05-25 21:24:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-kombu.new/python3-kombu.changes 
2016-06-19 10:49:02.0 +0200
@@ -1,0 +2,5 @@
+Mon Jun 13 17:04:15 UTC 2016 - toddrme2...@gmail.com
+
+- Comment out unused test requirements.
+
+---



Other differences:
--
++ python3-kombu.spec ++
--- /var/tmp/diff_new_pack.O4HN4B/_old  2016-06-19 10:49:03.0 +0200
+++ /var/tmp/diff_new_pack.O4HN4B/_new  2016-06-19 10:49:03.0 +0200
@@ -26,14 +26,14 @@
 Source: 
https://files.pythonhosted.org/packages/source/k/kombu/kombu-%{version}.tar.gz
 BuildRequires:  python3-devel
 BuildRequires:  python3-setuptools
-# Test requirements:
-BuildRequires:  python3-PyYAML
 BuildRequires:  python3-amqp >= 1.0.13
 BuildRequires:  python3-amqplib
-BuildRequires:  python3-anyjson >= 0.3.3
-BuildRequires:  python3-mock
-BuildRequires:  python3-nose-cover3
-BuildRequires:  python3-unittest2 >= 0.5.0
+# Test requirements:
+# BuildRequires:  python3-PyYAML
+# BuildRequires:  python3-anyjson >= 0.3.3
+# BuildRequires:  python3-mock
+# BuildRequires:  python3-nose-cover3
+# BuildRequires:  python3-unittest2 >= 0.5.0
 Requires:   python3-amqp >= 1.0.13
 Requires:   python3-anyjson >= 0.3.3
 Recommends: couchdb
@@ -68,8 +68,9 @@
 %install
 python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
 
-%check
-#python3 setup.py test
+# Tests are currently incompatible with latest amqp.  Check in next release.
+# %check
+# python3 setup.py test
 
 %files
 %defattr(-,root,root,-)




commit afl for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package afl for openSUSE:Factory checked in 
at 2016-06-19 10:49:33

Comparing /work/SRC/openSUSE:Factory/afl (Old)
 and  /work/SRC/openSUSE:Factory/.afl.new (New)


Package is "afl"

Changes:

--- /work/SRC/openSUSE:Factory/afl/afl.changes  2016-06-02 09:38:51.0 
+0200
+++ /work/SRC/openSUSE:Factory/.afl.new/afl.changes 2016-06-19 
10:49:35.0 +0200
@@ -1,0 +2,8 @@
+Wed Jun 15 18:26:54 UTC 2016 - astie...@suse.com
+
+- afl 2.14b:
+  - Added FUZZING_BUILD_MODE_UNSAFE_FOR_PRODUCTION as a macro
+defined when compiling with afl-gcc and friends
+  - Refreshed some of the non-x86 docs.
+
+---

Old:

  afl-2.13b.tgz

New:

  afl-2.14b.tgz



Other differences:
--
++ afl.spec ++
--- /var/tmp/diff_new_pack.3zHLfB/_old  2016-06-19 10:49:36.0 +0200
+++ /var/tmp/diff_new_pack.3zHLfB/_new  2016-06-19 10:49:36.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   afl
-Version:2.13b
+Version:2.14b
 Release:0
 Summary:American fuzzy lop is a security-oriented fuzzer
 License:Apache-2.0

++ afl-2.13b.tgz -> afl-2.14b.tgz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/afl-2.13b/Makefile new/afl-2.14b/Makefile
--- old/afl-2.13b/Makefile  2016-05-14 19:43:15.0 +0200
+++ new/afl-2.14b/Makefile  2016-06-07 08:45:45.0 +0200
@@ -14,7 +14,7 @@
 #
 
 PROGNAME= afl
-VERSION = 2.13b
+VERSION = 2.14b
 
 PREFIX ?= /usr/local
 BIN_PATH= $(PREFIX)/bin
@@ -50,7 +50,7 @@
 
 test_x86:
@echo "[*] Checking for the ability to compile x86 code..."
-   @echo 'main() { __asm__("xorb %al, %al"); }' | $(CC) -w -x c - -o .test 
|| ( echo; echo "Oops, looks like your compiler can't generate x86 code."; 
echo; echo "You can still try using the LLVM or QEMU mode, but see docs/INSTALL 
first."; echo "To ignore this error, set AFL_NO_X86=1."; echo; exit 1 )
+   @echo 'main() { __asm__("xorb %al, %al"); }' | $(CC) -w -x c - -o .test 
|| ( echo; echo "Oops, looks like your compiler can't generate x86 code."; 
echo; echo "Don't panic! You can use the LLVM or QEMU mode, but see 
docs/INSTALL first."; echo "(To ignore this error, set AFL_NO_X86=1 and try 
again.)"; echo; exit 1 )
@rm -f .test
@echo "[+] Everything seems to be working, ready to compile."
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/afl-2.13b/afl-gcc.c new/afl-2.14b/afl-gcc.c
--- old/afl-2.13b/afl-gcc.c 2016-03-05 01:08:50.0 +0100
+++ new/afl-2.14b/afl-gcc.c 2016-06-07 20:07:28.0 +0200
@@ -262,7 +262,12 @@
 
 cc_params[cc_par_cnt++] = "-O3";
 cc_params[cc_par_cnt++] = "-funroll-loops";
+
+/* Two indicators that you're building for fuzzing; one of them is
+   AFL-specific, the other is shared with libfuzzer. */
+
 cc_params[cc_par_cnt++] = "-D__AFL_COMPILER=1";
+cc_params[cc_par_cnt++] = "-DFUZZING_BUILD_MODE_UNSAFE_FOR_PRODUCTION=1";
 
   }
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/afl-2.13b/afl-tmin.c new/afl-2.14b/afl-tmin.c
--- old/afl-2.13b/afl-tmin.c2016-05-02 21:54:46.0 +0200
+++ new/afl-2.14b/afl-tmin.c2016-05-29 23:42:29.0 +0200
@@ -15,7 +15,7 @@
A simple test case minimizer that takes an input file and tries to remove
as much data as possible while keeping the binary in a crashing state
*or* producing consistent instrumentation output (the mode is auto-selected
-   based on initially observed behavior).
+   based on the initially observed behavior).
 
  */
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/afl-2.13b/docs/ChangeLog new/afl-2.14b/docs/ChangeLog
--- old/afl-2.13b/docs/ChangeLog2016-05-15 17:31:07.0 +0200
+++ new/afl-2.14b/docs/ChangeLog2016-06-07 20:06:05.0 +0200
@@ -17,6 +17,15 @@
 to get on with the times.
 
 --
+Version 2.14b:
+--
+
+  - Added FUZZING_BUILD_MODE_UNSAFE_FOR_PRODUCTION as a macro defined when
+compiling with afl-gcc and friends. Suggested by Kostya Serebryany.
+
+  - Refreshed some of the non-x86 docs.
+
+--
 Version 2.13b:
 --
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/afl-2.13b/docs/INSTALL new/afl-2.14b/docs/INSTALL
--- old/afl-2.13b/docs/INSTALL  2016-02-20 21:10:50.0 +0100
+++ new/afl-2.14b/docs/INSTALL  2016-06-07 20:17:00.0 +0200
@@ -105,12 +105,19 @@
 leverage two other options:
 
   - The 

commit php5-ice for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package php5-ice for openSUSE:Factory 
checked in at 2016-06-19 10:49:24

Comparing /work/SRC/openSUSE:Factory/php5-ice (Old)
 and  /work/SRC/openSUSE:Factory/.php5-ice.new (New)


Package is "php5-ice"

Changes:

--- /work/SRC/openSUSE:Factory/php5-ice/php5-ice.changes2016-06-03 
16:39:21.0 +0200
+++ /work/SRC/openSUSE:Factory/.php5-ice.new/php5-ice.changes   2016-06-19 
10:49:28.0 +0200
@@ -1,0 +2,13 @@
+Wed Jun 15 13:24:17 UTC 2016 - m...@poczta.onet.pl
+
+- Ice 1.1.5
+ * Router, fastRoute code improvements
+ * Di, fix url auto-resolving
+ * Response, move messages to function, remove di property
+ * Router, add default routes, remove di property
+ * Dump, add skip di property
+ * FastRoute, fix #120 and update to nikic/FastRoute@30470b6
+ * Copyright, update year
+ * Sleet, allow for multi-line tags, fix #118
+
+---

Old:

  php5-ice-1.1.4.tar.gz

New:

  php5-ice-1.1.5.tar.gz



Other differences:
--
++ php5-ice.spec ++
--- /var/tmp/diff_new_pack.rriDmw/_old  2016-06-19 10:49:29.0 +0200
+++ /var/tmp/diff_new_pack.rriDmw/_new  2016-06-19 10:49:29.0 +0200
@@ -22,7 +22,7 @@
 %define _name   ice
 
 Name:   %{_php}-%{_name}
-Version:1.1.4
+Version:1.1.5
 Release:0
 Summary:Simple and fast PHP framework delivered as C-extension
 License:BSD-3-Clause

++ php5-ice-1.1.4.tar.gz -> php5-ice-1.1.5.tar.gz ++
 11192 lines of diff (skipped)




commit kile for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package kile for openSUSE:Factory checked in 
at 2016-06-19 10:49:47

Comparing /work/SRC/openSUSE:Factory/kile (Old)
 and  /work/SRC/openSUSE:Factory/.kile.new (New)


Package is "kile"

Changes:

--- /work/SRC/openSUSE:Factory/kile/kile.changes2016-03-17 
16:47:29.0 +0100
+++ /work/SRC/openSUSE:Factory/.kile.new/kile.changes   2016-06-19 
10:49:48.0 +0200
@@ -1,0 +2,11 @@
+Thu Jun 16 09:26:50 UTC 2016 - wba...@tmo.at
+
+- Require konsole4-part on Leap as well, konsole is KF5 based and
+  doesn't work in the KDE4 based kile (boo#984980)
+
+---
+Tue Jun 14 21:57:26 UTC 2016 - wba...@tmo.at
+
+- Use shared-mime-info macros (boo#979301)
+
+---



Other differences:
--
++ kile.spec ++
--- /var/tmp/diff_new_pack.JuEWfR/_old  2016-06-19 10:49:50.0 +0200
+++ /var/tmp/diff_new_pack.JuEWfR/_new  2016-06-19 10:49:50.0 +0200
@@ -31,7 +31,7 @@
 %if 0%{?suse_version}
 BuildRequires:  update-desktop-files
 %endif
-%if 0%{?suse_version} > 1320
+%if 0%{?suse_version} > 1320 || 0%{?is_opensuse}
 Requires:   kate4-parts
 Requires:   konsole4-part
 %else
@@ -125,10 +125,10 @@
 %kde_post_install
 
 %post
-/usr/bin/update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
+%mime_database_post
 
 %postun
-/usr/bin/update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
+%mime_database_postun
 
 %files
 %defattr(-,root,root,-)




commit gstreamer-validate for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package gstreamer-validate for 
openSUSE:Factory checked in at 2016-06-19 10:49:38

Comparing /work/SRC/openSUSE:Factory/gstreamer-validate (Old)
 and  /work/SRC/openSUSE:Factory/.gstreamer-validate.new (New)


Package is "gstreamer-validate"

Changes:

--- /work/SRC/openSUSE:Factory/gstreamer-validate/gstreamer-validate.changes
2016-05-03 10:16:48.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.gstreamer-validate.new/gstreamer-validate.changes   
2016-06-19 10:49:40.0 +0200
@@ -1,0 +2,13 @@
+Wed Jun 15 14:11:06 UTC 2016 - zai...@opensuse.org
+
+- Update to version 1.8.2:
+  + configure: Properly set the current validate testsuite to 1.8.
+  + validate: Stop using deprecated method.
+
+---
+Mon Jun 13 21:42:11 UTC 2016 - nov...@mirell.de
+
+- Add gstreamer-validate-correctplugindir.patch from upstream
+  to fix Pitivi startup on some systems.
+
+---

Old:

  gst-validate-1.8.1.tar.xz

New:

  gst-validate-1.8.2.tar.xz
  gstreamer-validate-correctplugindir.patch



Other differences:
--
++ gstreamer-validate.spec ++
--- /var/tmp/diff_new_pack.y9Tv6n/_old  2016-06-19 10:49:41.0 +0200
+++ /var/tmp/diff_new_pack.y9Tv6n/_new  2016-06-19 10:49:41.0 +0200
@@ -18,13 +18,15 @@
 
 %define _name   gst-validate
 Name:   gstreamer-validate
-Version:1.8.1
+Version:1.8.2
 Release:0
 Summary:Validate GStreamer Pipelines
 License:LGPL-2.1+
 Group:  Productivity/Multimedia/Other
 Url:http://gstreamer.freedesktop.org
 Source: 
http://gstreamer.freedesktop.org/src/%{_name}/%{_name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM gstreamer-validate-correctplugindir.patch 
nov...@mirell.de -- Fix use of correct plugin directory
+Patch1: gstreamer-validate-correctplugindir.patch
 BuildRequires:  pkgconfig(cairo)
 BuildRequires:  pkgconfig(gdk-3.0)
 BuildRequires:  pkgconfig(gee-1.0)
@@ -90,6 +92,7 @@
 
 %prep
 %setup -q -n %{_name}-%{version}
+%patch1 -p2
 
 %build
 %configure

++ gst-validate-1.8.1.tar.xz -> gst-validate-1.8.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gst-validate-1.8.1/ChangeLog 
new/gst-validate-1.8.2/ChangeLog
--- old/gst-validate-1.8.1/ChangeLog2016-04-20 17:23:37.0 +0200
+++ new/gst-validate-1.8.2/ChangeLog2016-06-09 10:33:30.0 +0200
@@ -1,9 +1,31 @@
-=== release 1.8.1 ===
+=== release 1.8.2 ===
 
-2016-04-20  Sebastian Dröge 
+2016-06-09  Sebastian Dröge 
 
* configure.ac:
- releasing 1.8.1
+ releasing 1.8.2
+
+2016-04-13 21:18:28 +0200  Alexandru Băluț 
+
+   * validate/plugins/gtk/gstvalidategtk.c:
+ validate: Stop using deprecated method
+ https://bugzilla.gnome.org/show_bug.cgi?id=764964
+
+2016-05-06 08:36:55 -0300  Thibault Saunier 
+
+   * validate/configure.ac:
+ configure: Properly set the current validate testsuite to 1.8
+ So that the validate testsuites know with what version they are 
working
+
+=== release 1.8.1 ===
+
+2016-04-20 18:39:32 +0300  Sebastian Dröge 
+
+   * validate/ChangeLog:
+   * validate/NEWS:
+   * validate/configure.ac:
+   * validate/gst-validate.doap:
+ Release 1.8.1
 
 2016-04-07 14:11:45 +0200  Edward Hervey 
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gst-validate-1.8.1/NEWS new/gst-validate-1.8.2/NEWS
--- old/gst-validate-1.8.1/NEWS 2016-04-20 17:24:38.0 +0200
+++ new/gst-validate-1.8.2/NEWS 2016-06-09 10:34:25.0 +0200
@@ -1,24 +1,26 @@
-### 1.8.1
+### 1.8.2
 
-The first 1.8 bug-fix release (1.8.1) was released on 20 April 2016.
+The first 1.8 bug-fix release (1.8.2) was released on 9 June 2016.
 This release only contains bugfixes and it should be safe to update from 1.8.0.
 
- Major bugfixes in 1.8.1
+ Major bugfixes in 1.8.2
 
- - Fix app compilation with Android NDK r11 and newer
- - Fix compilation of nvenc plugin against latest NVIDIA SDK 6.0
- - Fix regression in avdeinterlace
- - Fix memory corruption in scaletempo element with S16 input
- - Fix regression in qtdemux with MSE streams
- - Fix glitches at the start with all audio sinks except for pulsesink
- - Fix regression with encrypted HLS streams
- - Fix automatic multithreaded decoding of VP8/9 video
- - Fix deadlock in HTTP adaptive streams when scrub-seeking
- - Fix regression 

commit bmake for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package bmake for openSUSE:Factory checked 
in at 2016-06-19 10:49:10

Comparing /work/SRC/openSUSE:Factory/bmake (Old)
 and  /work/SRC/openSUSE:Factory/.bmake.new (New)


Package is "bmake"

Changes:

--- /work/SRC/openSUSE:Factory/bmake/bmake.changes  2016-05-30 
09:57:19.0 +0200
+++ /work/SRC/openSUSE:Factory/.bmake.new/bmake.changes 2016-06-19 
10:49:12.0 +0200
@@ -1,0 +2,7 @@
+Tue Jun 14 17:58:29 UTC 2016 - dap.darkn...@gmail.com
+
+- 20160528
+  * boot-strap, make-bootstrap.sh.in: Makefile uses _MAKE_VERSION
+- Removed bmake-MAKE_VERSION.diff so.
+
+---

Old:

  bmake-20160512.tar.gz
  bmake-MAKE_VERSION.diff

New:

  bmake-20160528.tar.gz



Other differences:
--
++ bmake.spec ++
--- /var/tmp/diff_new_pack.jmToix/_old  2016-06-19 10:49:13.0 +0200
+++ /var/tmp/diff_new_pack.jmToix/_new  2016-06-19 10:49:13.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   bmake
-Version:20160512
+Version:20160528
 Release:0
 Summary:The NetBSD make(1) tool
 License:BSD-2-Clause and BSD-3-Clause and BSD-4-Clause
@@ -25,8 +25,6 @@
 Url:ftp://ftp.NetBSD.org/pub/NetBSD/misc/sjg/
 Source0:
ftp://ftp.NetBSD.org/pub/NetBSD/misc/sjg/bmake-%{version}.tar.gz
 Source1:Linux.sys.mk
-# PATCH-FIX-OPENSUSE to fix MAKE_VERSION variable & mk-configure package.
-Patch0: bmake-MAKE_VERSION.diff
 
 %description
 bmake, the NetBSD make(1) tool, is a program designed to simplify the
@@ -40,7 +38,6 @@
 
 %prep
 %setup -q -n %{name}
-%patch0
 
 %build
 unset MAKEFLAGS

++ bmake-20160512.tar.gz -> bmake-20160528.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/ChangeLog new/bmake/ChangeLog
--- old/bmake/ChangeLog 2016-05-12 22:34:55.0 +0200
+++ new/bmake/ChangeLog 2016-05-29 02:10:35.0 +0200
@@ -1,3 +1,9 @@
+2016-05-28  Simon J. Gerraty  
+
+   * Makefile (_MAKE_VERSION): 20160528
+
+   * boot-strap, make-bootstrap.sh.in: Makefile now uses _MAKE_VERSION 
+
 2016-05-12  Simon J. Gerraty  
 
* Makefile (_MAKE_VERSION): 20160512
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/Makefile new/bmake/Makefile
--- old/bmake/Makefile  2016-05-12 22:34:55.0 +0200
+++ new/bmake/Makefile  2016-05-29 02:10:59.0 +0200
@@ -1,7 +1,7 @@
-#  $Id: Makefile,v 1.63 2016/05/12 20:34:46 sjg Exp $
+#  $Id: Makefile,v 1.64 2016/05/29 00:10:59 sjg Exp $
 
 # Base version on src date
-_MAKE_VERSION= 20160512
+_MAKE_VERSION= 20160528
 
 PROG=  bmake
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/boot-strap new/bmake/boot-strap
--- old/bmake/boot-strap2015-10-25 06:20:48.0 +0100
+++ new/bmake/boot-strap2016-05-29 02:09:14.0 +0200
@@ -111,7 +111,7 @@
 #  Simon J. Gerraty 
 
 # RCSid:
-#  $Id: boot-strap,v 1.48 2015/10/25 05:20:48 sjg Exp $
+#  $Id: boot-strap,v 1.49 2016/05/29 00:09:14 sjg Exp $
 #
 #  @(#) Copyright (c) 2001 Simon J. Gerraty
 #
@@ -451,7 +451,7 @@
op_install
else
op_test
-   MAKE_VERSION=`sed -n '/^MAKE_VERSION/ { s,.*=  *,,;p; }' 
$srcdir/Makefile`
+   MAKE_VERSION=`sed -n '/^_MAKE_VERSION/ { s,.*=  *,,;p; }' 
$srcdir/Makefile`
echo You can install by running:
echo
echo $0 $cmd_args op=install
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/make-bootstrap.sh.in 
new/bmake/make-bootstrap.sh.in
--- old/bmake/make-bootstrap.sh.in  2015-09-10 20:07:05.0 +0200
+++ new/bmake/make-bootstrap.sh.in  2016-05-29 02:05:05.0 +0200
@@ -13,7 +13,7 @@
 CC="@CC@"
 CFLAGS="@CFLAGS@ -I. -I${srcdir} @DEFS@ @CPPFLAGS@ -DMAKE_NATIVE ${XDEFS} 
-DBMAKE_PATH_MAX=@bmake_path_max@"
 
-MAKE_VERSION=`sed -n '/^MAKE_VERSION=/s,.*=[^0-9]*,,p' $srcdir/Makefile`
+MAKE_VERSION=`sed -n '/^_MAKE_VERSION=/s,.*=[^0-9]*,,p' $srcdir/Makefile`
 
 MDEFS="-DMAKE_VERSION=\"$MAKE_VERSION\" \
 -D@force_machine@MACHINE=\"@machine@\" -DMACHINE_ARCH=\"@machine_arch@\" \
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/mk/meta.stage.mk new/bmake/mk/meta.stage.mk
--- old/bmake/mk/meta.stage.mk  2016-03-16 19:21:31.0 +0100
+++ new/bmake/mk/meta.stage.mk  2016-05-29 02:09:09.0 +0200
@@ -1,4 +1,4 @@
-# $Id: meta.stage.mk,v 1.44 2016/03/16 18:21:23 

commit gpaste for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package gpaste for openSUSE:Factory checked 
in at 2016-06-19 10:49:16

Comparing /work/SRC/openSUSE:Factory/gpaste (Old)
 and  /work/SRC/openSUSE:Factory/.gpaste.new (New)


Package is "gpaste"

Changes:

--- /work/SRC/openSUSE:Factory/gpaste/gpaste.changes2016-04-12 
19:32:05.0 +0200
+++ /work/SRC/openSUSE:Factory/.gpaste.new/gpaste.changes   2016-06-19 
10:49:18.0 +0200
@@ -1,0 +2,15 @@
+Tue Jun 14 17:43:24 UTC 2016 - gan...@opensuse.org
+
+- Update to version 3.20.3
+  + Fix soname versioning.
+- Changes from version 3.20.2:
+  + Add missing icon.
+- Changes from version 3.20.1:
+  + Fix crash when a search goes wrong.
+  + Fix hanging issue due to gtk+ race (?) in gtk_clipboard_store.
+  + Fix the gnome-shell menu sometimes displaying twice.
+  + Add debug logs to the core library.
+  + Fix some build issues with some toolchains.
+  + Updated translations.
+
+---

Old:

  gpaste-3.20.tar.xz

New:

  gpaste-3.20.3.tar.xz



Other differences:
--
++ gpaste.spec ++
--- /var/tmp/diff_new_pack.foL07w/_old  2016-06-19 10:49:19.0 +0200
+++ /var/tmp/diff_new_pack.foL07w/_new  2016-06-19 10:49:19.0 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   gpaste
-Version:3.20
+Version:3.20.3
 Release:0
 Summary:Clipboard management system for GNOME
 License:BSD-2-Clause

++ gpaste-3.20.tar.xz -> gpaste-3.20.3.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gpaste-3.20/ChangeLog new/gpaste-3.20.3/ChangeLog
--- old/gpaste-3.20/ChangeLog   2016-03-23 20:48:19.0 +0100
+++ new/gpaste-3.20.3/ChangeLog 2016-06-14 08:56:38.0 +0200
@@ -1,6 +1,189 @@
 # Generated by Makefile. Do not edit.
 
 
+commit d917e87176329fcae6649e7243ada272c7260104
+Author: Marc-Antoine Perennou 
+Date:   Tue May 24 09:08:32 2016 +0200
+
+Release GPaste 3.20.2
+
+Signed-off-by: Marc-Antoine Perennou 
+
+commit 323f08d2a30eb361255f3c6f6400e06d3c469985
+Author: Marc-Antoine Perennou 
+Date:   Mon May 23 20:28:37 2016 +0200
+
+specify the window icon
+
+Signed-off-by: Marc-Antoine Perennou 
+
+commit d9ccd33462ba719eb34acaab668915dd544c07ce
+Author: Marc-Antoine Perennou 
+Date:   Mon May 23 13:58:18 2016 +0200
+
+Release GPaste 3.20.1
+
+Signed-off-by: Marc-Antoine Perennou 
+
+commit ad2ed8235b3d95ca2d7e30858ded4c4478bad6e8
+Merge: 371c8bc 09b9da5
+Author: Marc-Antoine Perennou 
+Date:   Sun May 22 23:03:48 2016 +0200
+
+Merge branch 'gpaste-3.18' into gpaste-3.20
+
+* gpaste-3.18:
+  Release GPaste 3.18.4
+  clipboard: fix missing return
+
+commit 09b9da5a5d7cec4477cdb5c39fc1bb59d683add0
+Author: Marc-Antoine Perennou 
+Date:   Sun May 22 23:00:26 2016 +0200
+
+Release GPaste 3.18.4
+
+Signed-off-by: Marc-Antoine Perennou 
+
+commit 909f1d5e21433fb42e716ac131f4dec9b8e04fbf
+Author: Marc-Antoine Perennou 
+Date:   Sun May 22 22:58:07 2016 +0200
+
+clipboard: fix missing return
+
+Signed-off-by: Marc-Antoine Perennou 
+
+commit 371c8bc500febe6dbaa58fa50306ef125f18a5b2
+Merge: 6f91890 d430bf6
+Author: Marc-Antoine Perennou 
+Date:   Sun May 22 22:39:21 2016 +0200
+
+Merge branch 'gpaste-3.18' into gpaste-3.20
+
+* gpaste-3.18:
+  Release GPaste 3.18.4
+  core: add debug logs
+
+commit d430bf680032759323d9ecd21df35ad762825e06
+Author: Marc-Antoine Perennou 
+Date:   Sun May 22 22:31:24 2016 +0200
+
+Release GPaste 3.18.4
+
+Signed-off-by: Marc-Antoine Perennou 
+
+commit 889111ccde45ca188f0872c1e15e95c448fdf5d0
+Author: Marc-Antoine Perennou 
+Date:   Sun May 22 22:22:00 2016 +0200
+
+core: add debug logs
+
+Signed-off-by: Marc-Antoine Perennou 
+
+commit 6f91890a9b300be9b514dd4105972168768c3e50
+Merge: 42b5fc8 cdcb2e9
+Author: Marc-Antoine Perennou 
+Date:   Wed May 18 22:46:40 2016 +0200
+
+Merge branch 'gpaste-3.18' into gpaste-3.20
+
+* gpaste-3.18:
+  clipboard: avoid calling gtk_clipboard_store too often
+
+commit cdcb2e94195c0dfeb47376b33ac6446b4fd9d0b3
+Author: Marc-Antoine Perennou 
+Date:   Wed May 18 22:45:03 

commit tellico for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package tellico for openSUSE:Factory checked 
in at 2016-06-19 10:49:42

Comparing /work/SRC/openSUSE:Factory/tellico (Old)
 and  /work/SRC/openSUSE:Factory/.tellico.new (New)


Package is "tellico"

Changes:

--- /work/SRC/openSUSE:Factory/tellico/tellico.changes  2016-01-09 
23:14:03.0 +0100
+++ /work/SRC/openSUSE:Factory/.tellico.new/tellico.changes 2016-06-19 
10:49:46.0 +0200
@@ -1,0 +2,5 @@
+Wed Jun 15 21:54:26 UTC 2016 - wba...@tmo.at
+
+- Use shared-mime-database macros (boo#979301)
+
+---



Other differences:
--
++ tellico.spec ++
--- /var/tmp/diff_new_pack.J3GH3I/_old  2016-06-19 10:49:48.0 +0200
+++ /var/tmp/diff_new_pack.J3GH3I/_new  2016-06-19 10:49:48.0 +0200
@@ -84,10 +84,10 @@
 %fdupes -s %{buildroot}
 
 %post
-/usr/bin/update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
+%mime_database_post
 
 %postun
-/usr/bin/update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
+%mime_database_postun
 
 %files
 %defattr(-,root,root,-)




commit dateutils for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package dateutils for openSUSE:Factory 
checked in at 2016-06-19 10:49:18

Comparing /work/SRC/openSUSE:Factory/dateutils (Old)
 and  /work/SRC/openSUSE:Factory/.dateutils.new (New)


Package is "dateutils"

Changes:

--- /work/SRC/openSUSE:Factory/dateutils/dateutils.changes  2016-02-26 
00:28:49.0 +0100
+++ /work/SRC/openSUSE:Factory/.dateutils.new/dateutils.changes 2016-06-19 
10:49:19.0 +0200
@@ -1,0 +2,29 @@
+Wed Jun 15 10:06:41 UTC 2016 - sweet_...@gmx.de
+
+- fix .mex file extension for octave plugin,
+  0001-Revert-chore-be-more-portable-in-sxe-matlab.m4.patch
+- explicit octave plugin file list
+- remove *.la files
+
+---
+Thu Jun  2 14:07:21 UTC 2016 - sweet_...@gmx.de
+
+- bump version 0.4.0, this is a feature release.
+  * Bugfixes:
+- document %g/%G format specifiers
+- bug/42, accept NUL characters in input
+- bug/45, correctly display Gregorian and ISO week dates in one
+  line
+- bug/46, adhere to ISO group's official formatting of week
+  dates
+- bug/47, allow rounding of Epoch based timestamps
+- bug/48, avoid crash for void input to strptime(3)
+  * Features:
+- datetest supports --isvalid to conditionalise on date/time
+  parsing
+- all tools support --from-locale to parse localised input
+- tools with output formatting support --locale to format
+  output according to locale
+  * See info page examples and/or README. 
+
+---

Old:

  dateutils-0.3.5.tar.xz

New:

  0001-Revert-chore-be-more-portable-in-sxe-matlab.m4.patch
  dateutils-0.4.0.tar.xz



Other differences:
--
++ dateutils.spec ++
--- /var/tmp/diff_new_pack.xeHyu4/_old  2016-06-19 10:49:20.0 +0200
+++ /var/tmp/diff_new_pack.xeHyu4/_new  2016-06-19 10:49:20.0 +0200
@@ -16,7 +16,7 @@
 #
 
 
-%define xversion 0.3.5
+%define xversion 0.4.0
 
 %define have_octave 0
 
@@ -39,13 +39,15 @@
 %endif
 
 Name:   dateutils
-Version:0.3.5
+Version:0.4.0
 Release:0
 Summary:Nifty command line date and time utilities
 License:BSD-3-Clause
 Group:  Productivity/Text/Utilities
 Url:https://github.com/hroptatyr/dateutils/
 Source: 
https://bitbucket.org/hroptatyr/dateutils/downloads/%{name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM
+Patch1: 0001-Revert-chore-be-more-portable-in-sxe-matlab.m4.patch
 BuildRequires:  pkgconfig
 BuildRequires:  xz
 %if 0%{?suse_version}
@@ -78,6 +80,7 @@
 
 %prep
 %setup -q -n %{name}-%{xversion}
+%patch1 -p1
 
 %build
 %configure \
@@ -91,6 +94,7 @@
 %install
 %{?make_install} %{!?make_install:make install DESTDIR=%{buildroot}}
 rm -f %{buildroot}%{_infodir}/dir
+rm -f %{buildroot}%{_libdir}/octave/site/oct/*/dateutils/tzconv.la
 
 %check
 if ! make check; then
@@ -134,6 +138,7 @@
 %{_bindir}/datezone
 %{_bindir}/strptime
 %dir %{_datadir}/dateutils/
+%{_datadir}/dateutils/locale
 %{_datadir}/dateutils/*.tzmcc
 %doc %{_infodir}/%{name}.info*
 %doc %{_mandir}/man1/%{name}.1*
@@ -161,7 +166,8 @@
 %files octave
 %defattr(-,root,root)
 %dir %{_libdir}/octave/site/oct/*/dateutils/
-%{_libdir}/octave/site/oct/*/dateutils/*
+%{_libdir}/octave/site/oct/*/dateutils/tzconv.m
+%{_libdir}/octave/site/oct/*/dateutils/tzconv.mex
 %endif
 
 %changelog

++ 0001-Revert-chore-be-more-portable-in-sxe-matlab.m4.patch ++
>From 98a8df78e1668f05df86b250c4ad12efb7490b24 Mon Sep 17 00:00:00 2001
From: Sebastian Freundt 
Date: Wed, 15 Jun 2016 09:26:02 +
Subject: [PATCH] Revert "chore, be more portable in sxe-matlab.m4"

This reverts commit 471c813a4fb6d26f828cd7c191cfd1ec478a2bd8.

This makes the matlab detection fail on systems with older shells.

Signed-off-by: Ruediger Meier 
---
 m4/sxe-matlab.m4 | 10 +-
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/m4/sxe-matlab.m4 b/m4/sxe-matlab.m4
index 77fc708..5f1099e 100644
--- a/m4/sxe-matlab.m4
+++ b/m4/sxe-matlab.m4
@@ -3,10 +3,10 @@ AC_DEFUN([SXE_CHECK_MATLAB], [dnl
foo=`mktemp /tmp/sxe_check_matlab.XX`
 
AC_ARG_VAR([MATLAB], [full path to matlab binary])
-   sxe_cv_matlab="${MATLAB-matlab}"
+   sxe_cv_matlab="${MATLAB:-matlab}"
 
AC_ARG_VAR([MATLABPATH], [path to matlab toolboxes])
-   sxe_cv_matlabpath="${MATLABPATH-no}"
+   sxe_cv_matlabpath="${MATLABPATH:-no}"
 
AC_MSG_CHECKING([for matlab root])
## assume no matlab
@@ -35,9 +35,9 @@ AC_DEFUN([SXE_CHECK_MATLAB], [dnl
 
AC_MSG_CHECKING([for matlab mex file extension])

commit lib3ds for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package lib3ds for openSUSE:Factory checked 
in at 2016-06-19 10:49:14

Comparing /work/SRC/openSUSE:Factory/lib3ds (Old)
 and  /work/SRC/openSUSE:Factory/.lib3ds.new (New)


Package is "lib3ds"

Changes:

--- /work/SRC/openSUSE:Factory/lib3ds/lib3ds.changes2014-09-17 
17:27:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.lib3ds.new/lib3ds.changes   2016-06-19 
10:49:16.0 +0200
@@ -1,0 +2,5 @@
+Fri May 20 05:17:38 UTC 2016 - christ...@stop.pe
+
+- Fixed packaging of -devel package to include lib3ds.pc file 
(/usr/bin/lib3ds-config will not work without it).
+
+---



Other differences:
--
++ lib3ds.spec ++
--- /var/tmp/diff_new_pack.SZrY70/_old  2016-06-19 10:49:17.0 +0200
+++ /var/tmp/diff_new_pack.SZrY70/_new  2016-06-19 10:49:17.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package lib3ds
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -28,6 +28,7 @@
 Patch0: lib3ds-pkgconfig.patch
 Patch1: lib3ds-mesh.c.patch
 BuildRequires:  libtool
+BuildRequires:  pkg-config
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -73,6 +74,8 @@
 %install
 rm -rf examples/.deps
 make DESTDIR=%{buildroot} install %{?_smp_mflags}
+mkdir -p %{buildroot}%{_datadir}/pkgconfig/
+install -m644 lib3ds.pc %{buildroot}%{_datadir}/pkgconfig/
 find %{buildroot} -type f -name "*.la" -delete -print
 
 %check
@@ -92,6 +95,7 @@
 %{_mandir}/man1/*gz
 %{_libdir}/lib3ds.so
 %{_datadir}/aclocal/lib3ds.m4
+%{_datadir}/pkgconfig/lib3ds.pc
 
 %post -n %{libname}  -p /sbin/ldconfig
 

++ lib3ds-pkgconfig.patch ++
--- /var/tmp/diff_new_pack.SZrY70/_old  2016-06-19 10:49:17.0 +0200
+++ /var/tmp/diff_new_pack.SZrY70/_new  2016-06-19 10:49:17.0 +0200
@@ -1,6 +1,7 @@
-diff -uNr lib3ds-1.2.0.orig/lib3ds-config.in lib3ds-1.2.0/lib3ds-config.in
 lib3ds-1.2.0.orig/lib3ds-config.in 2000-05-23 14:13:08.0 +0200
-+++ lib3ds-1.2.0/lib3ds-config.in  2007-10-21 06:37:48.0 +0200
+Index: lib3ds-1.3.0/lib3ds-config.in
+===
+--- lib3ds-1.3.0.orig/lib3ds-config.in
 lib3ds-1.3.0/lib3ds-config.in
 @@ -1,9 +1,5 @@
  #!/bin/sh
  
@@ -11,7 +12,7 @@
  usage()
  {
  cat <&2
  fi
  
@@ -20,7 +21,7 @@
  while test $# -gt 0; do
case "$1" in
-*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
-@@ -30,23 +28,23 @@
+@@ -30,23 +28,23 @@ while test $# -gt 0; do
  
case $1 in
  --prefix=*)
@@ -48,7 +49,7 @@
;;
  --cflags)
echo_cflags=yes
-@@ -62,23 +60,18 @@
+@@ -62,23 +60,18 @@ while test $# -gt 0; do
  done
  
  if test "$echo_prefix" = "yes"; then
@@ -77,9 +78,10 @@
 +  pkg-config $PKG_CONFIG_ARGS --libs lib3ds
 +fi
  
-diff -uNr lib3ds-1.2.0.orig/lib3ds.pc.in lib3ds-1.2.0/lib3ds.pc.in
 lib3ds-1.2.0.orig/lib3ds.pc.in 1970-01-01 01:00:00.0 +0100
-+++ lib3ds-1.2.0/lib3ds.pc.in  2007-10-21 06:23:53.0 +0200
+Index: lib3ds-1.3.0/lib3ds.pc.in
+===
+--- /dev/null
 lib3ds-1.3.0/lib3ds.pc.in
 @@ -0,0 +1,11 @@
 +prefix=@prefix@
 +exec_prefix=@exec_prefix@
@@ -92,3 +94,28 @@
 +Requires:
 +Libs: -L${libdir} -l3ds -lm
 +Cflags: -I${includedir}
+Index: lib3ds-1.3.0/Makefile.am
+===
+--- lib3ds-1.3.0.orig/Makefile.am
 lib3ds-1.3.0/Makefile.am
+@@ -35,6 +35,7 @@ man_MANS = \
+ EXTRA_DIST = \
+   lib3ds.m4 \
+   lib3ds-config.1 \
++  lib3ds.pc \
+   AUTHORS \
+   COPYING \
+   ChangeLog \
+Index: lib3ds-1.3.0/configure.in
+===
+--- lib3ds-1.3.0.orig/configure.in
 lib3ds-1.3.0/configure.in
+@@ -16,6 +16,8 @@ AM_INIT_AUTOMAKE(lib3ds, $LIB3DS_VERSION
+ AC_PROG_CC
+ AC_PROG_LIBTOOL
+ 
++AC_CONFIG_FILES([lib3ds.pc])
++
+ AC_MSG_CHECKING([for debugging mode])
+ AC_ARG_ENABLE(debug-mode,   
+   [  --enable-debug-mode enable debugging mode],




commit leechcraft for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package leechcraft for openSUSE:Factory 
checked in at 2016-06-19 10:49:08

Comparing /work/SRC/openSUSE:Factory/leechcraft (Old)
 and  /work/SRC/openSUSE:Factory/.leechcraft.new (New)


Package is "leechcraft"

Changes:

--- /work/SRC/openSUSE:Factory/leechcraft/leechcraft.changes2016-06-11 
00:00:59.0 +0200
+++ /work/SRC/openSUSE:Factory/.leechcraft.new/leechcraft.changes   
2016-06-19 10:49:11.0 +0200
@@ -1,0 +2,9 @@
+Sat Jun 11 14:48:26 UTC 2016 - dap.darkn...@gmail.com
+
+- Dropped openSUSE 13.1 & SLE because of no valid compiler.
+- Enabled more packages for openSUSE Leap 42.
+- Recommended extra engines for lmp.
+- Added rpmlintrc to silence useless warnings.
+- Added simple man pages.
+
+---

New:

  lc_plugin_wrapper.1
  leechcraft-rpmlintrc
  leechcraft-session.1



Other differences:
--
++ leechcraft.spec ++
--- /var/tmp/diff_new_pack.yA57zD/_old  2016-06-19 10:49:12.0 +0200
+++ /var/tmp/diff_new_pack.yA57zD/_new  2016-06-19 10:49:12.0 +0200
@@ -39,12 +39,6 @@
 %define xpc_postfix %{so_ver}_2
 %define xsd_postfix %{so_ver}
 
-%if 0%{?suse_version} > 1310
-%define lmp_gstreamer_1_0 1
-%else
-%define lmp_gstreamer_1_0 0
-%endif
-
 %if 0%{?suse_version} > 1320
 %define use_cpp14 1
 %else
@@ -60,6 +54,9 @@
 Url:http://leechcraft.org
 
 Source0:leechcraft-%{LEECHCRAFT_VERSION}.tar.xz
+Source4:%{name}-rpmlintrc
+Source8:leechcraft-session.1
+Source9:lc_plugin_wrapper.1
 # NOTE: delete p0 at version bump!
 # PATCH-FIX-UPSTREAM for newest torrent rasterbar.
 Patch0: leechcraft-%{LEECHCRAFT_VERSION}-torrent110.diff
@@ -81,72 +78,41 @@
 BuildRequires:  gcc-c++
 %endif
 BuildRequires:  hicolor-icon-theme
-%if 0%{?suse_version} == 1310
-%ifarch %ix86 x86_64 %arm
-BuildRequires:  jbig2dec-devel
-%endif
-%endif
 BuildRequires:  libjpeg-devel
-%if 0%{?suse_version} != 1315
 BuildRequires:  liblastfm-devel
-%endif
 BuildRequires:  libotr-devel
 BuildRequires:  libqscintilla-devel
 BuildRequires:  libqt4-sql
-%if 0%{?suse_version} >= 1320
 BuildRequires:  libqxt-devel
-%endif
 BuildRequires:  libsensors4-devel
-%if 0%{?suse_version} != 1315
 BuildRequires:  libtidy-devel
-%endif
-%ifarch %ix86 %arm x86_64 ppc64 ppc64le
 %if 0%{suse_version} <= 1320
 BuildRequires:  llvm-clang >= 3.4
 %endif
-%endif
-%if 0%{?suse_version} == 1310
-%ifarch %ix86 x86_64 %arm
-BuildRequires:  mupdf-devel-static
-%endif
-%endif
-%if 0%{?suse_version} != 1315
 BuildRequires:  qwt6-devel
-%endif
-%if 0%{?suse_version} > 1315
 BuildRequires:  wt-devel >= 3.3
-%endif
-%if 0%{?suse_version} > 1315
-BuildRequires:  pkgconfig(TelepathyQt4)
-%endif
 BuildRequires:  pkgconfig(QJson) >= 0.8.1
 BuildRequires:  pkgconfig(QtCore) >= 4.8
 BuildRequires:  pkgconfig(QtWebKit)
+BuildRequires:  pkgconfig(TelepathyQt4)
 BuildRequires:  pkgconfig(bzip2)
 BuildRequires:  pkgconfig(ddjvuapi)
 BuildRequires:  pkgconfig(geoip)
+BuildRequires:  pkgconfig(gstreamer-app-1.0)
 BuildRequires:  pkgconfig(libidn)
 BuildRequires:  pkgconfig(libmtp)
 BuildRequires:  pkgconfig(libnl-3.0)
 BuildRequires:  pkgconfig(libpcre)
-%if 0%{?suse_version} != 1315
 BuildRequires:  pkgconfig(libprojectM)
-%endif
 BuildRequires:  pkgconfig(phonon)
 BuildRequires:  pkgconfig(purple)
 BuildRequires:  pkgconfig(speex)
 BuildRequires:  pkgconfig(taglib)
-%if 0%{?lmp_gstreamer_1_0}
-BuildRequires:  pkgconfig(gstreamer-app-1.0)
 BuildConflicts: gstreamer-0_10-devel
 BuildConflicts: gstreamer-0_10-plugins-base-devel
 BuildConflicts: libgstapp-0_10
 BuildConflicts: libgstinterfaces-0_10
 BuildConflicts: libgstreamer-0_10
-%else
-BuildRequires:  pkgconfig(gstreamer-interfaces-0.10)
-BuildConflicts: libgstreamer-1_0-0
-%endif
 BuildRequires:  pkgconfig(hunspell)
 BuildRequires:  pkgconfig(kqoauth)
 %if 0%{?suse_version} > 1320
@@ -156,20 +122,13 @@
 %endif
 BuildRequires:  pkgconfig(libcurl)
 BuildRequires:  pkgconfig(libguess)
-%if 0%{?suse_version} == 1310
-%ifarch %ix86 x86_64 %arm
-BuildRequires:  pkgconfig(libopenjpeg)
-%endif
-%endif
 BuildRequires:  pkgconfig(libqrencode)
 %if 0%{?suse_version} > 1320
 BuildRequires:  pkgconfig(libswresample)
 %endif
 BuildRequires:  pkgconfig(libtorrent-rasterbar) >= 1.0
 BuildRequires:  pkgconfig(libudev)
-%if 0%{?suse_version} != 1315
 BuildRequires:  pkgconfig(libvlc)
-%endif
 BuildRequires:  pkgconfig(poppler-cpp)
 BuildRequires:  pkgconfig(poppler-qt4)
 BuildRequires:  pkgconfig(qca2)
@@ -289,7 +248,6 @@
 guide to writing recipes if you are interested in writing your own ones.
 
 
-%if 0%{?suse_version} > 1315
 %package aggregator-webaccess
 Summary:LeechCraft Aggregator - Web 

commit gstreamer-editing-services for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package gstreamer-editing-services for 
openSUSE:Factory checked in at 2016-06-19 10:49:53

Comparing /work/SRC/openSUSE:Factory/gstreamer-editing-services (Old)
 and  /work/SRC/openSUSE:Factory/.gstreamer-editing-services.new (New)


Package is "gstreamer-editing-services"

Changes:

--- 
/work/SRC/openSUSE:Factory/gstreamer-editing-services/gstreamer-editing-services.changes
2016-05-03 10:16:51.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.gstreamer-editing-services.new/gstreamer-editing-services.changes
   2016-06-19 10:49:54.0 +0200
@@ -1,0 +2,19 @@
+Wed Jun 15 14:33:23 UTC 2016 - zai...@opensuse.org
+
+- Update to version 1.8.2:
+  + bgo765853: timeline: rename "track-element" to 
+"track_element" in select-tracks-for-object documentation.
+  + bgo#765856: g-i: use only " ges/ges.h " as c-include for
+introspection.
+  + bgo#766455: nlecomposition: ensure elements pending to be added
+are not leaked.
+  + bgo#766459: ges: ges_asset_set_proxy documentation fix and add
+some g-i annotations.
+  + bgo#766524: audio-source: unref private capsfilter reference on
+finalize.
+  + bgo#767053: nlecomposition: Fix race condition in seek handling
+causing deadlocks.
+  + bgo#767293: ges-uri-asset: GstDiscoverer can return a valid
+info but a non-OK result, consider this an error.
+
+---

Old:

  gstreamer-editing-services-1.8.1.tar.xz

New:

  gstreamer-editing-services-1.8.2.tar.xz



Other differences:
--
++ gstreamer-editing-services.spec ++
--- /var/tmp/diff_new_pack.XETvXO/_old  2016-06-19 10:49:55.0 +0200
+++ /var/tmp/diff_new_pack.XETvXO/_new  2016-06-19 10:49:55.0 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   gstreamer-editing-services
-Version:1.8.1
+Version:1.8.2
 Release:0
 Summary:GStreamer Editing Services
 License:GPL-3.0+ and LGPL-2.1+

++ gstreamer-editing-services-1.8.1.tar.xz -> 
gstreamer-editing-services-1.8.2.tar.xz ++
 5304 lines of diff (skipped)




commit ghex for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package ghex for openSUSE:Factory checked in 
at 2016-06-19 10:49:19

Comparing /work/SRC/openSUSE:Factory/ghex (Old)
 and  /work/SRC/openSUSE:Factory/.ghex.new (New)


Package is "ghex"

Changes:

--- /work/SRC/openSUSE:Factory/ghex/ghex.changes2016-06-02 
09:39:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghex.new/ghex.changes   2016-06-19 
10:49:21.0 +0200
@@ -1,0 +2,7 @@
+Tue Jun 14 18:03:58 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.18.2:
+  + Fix build with GCC 6.
+  + Updated translations.
+
+---

Old:

  ghex-3.18.1.tar.xz

New:

  ghex-3.18.2.tar.xz



Other differences:
--
++ ghex.spec ++
--- /var/tmp/diff_new_pack.xhLy3v/_old  2016-06-19 10:49:22.0 +0200
+++ /var/tmp/diff_new_pack.xhLy3v/_new  2016-06-19 10:49:22.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   ghex
-Version:3.18.1
+Version:3.18.2
 Release:0
 Summary:GNOME Binary Editor
 License:GPL-2.0+

++ ghex-3.18.1.tar.xz -> ghex-3.18.2.tar.xz ++
 3743 lines of diff (skipped)




commit GeoIP for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package GeoIP for openSUSE:Factory checked 
in at 2016-06-19 10:49:36

Comparing /work/SRC/openSUSE:Factory/GeoIP (Old)
 and  /work/SRC/openSUSE:Factory/.GeoIP.new (New)


Package is "GeoIP"

Changes:

--- /work/SRC/openSUSE:Factory/GeoIP/GeoIP.changes  2016-02-08 
09:47:49.0 +0100
+++ /work/SRC/openSUSE:Factory/.GeoIP.new/GeoIP.changes 2016-06-19 
10:49:38.0 +0200
@@ -1,0 +2,5 @@
+Thu Jun 16 09:06:14 UTC 2016 - martin.li...@suse.com
+
+- Fix compilation errors seen by GCC6.
+
+---



Other differences:
--
++ geoip-asn-csv-to-dat.cpp ++
--- /var/tmp/diff_new_pack.ol1xB2/_old  2016-06-19 10:49:39.0 +0200
+++ /var/tmp/diff_new_pack.ol1xB2/_new  2016-06-19 10:49:39.0 +0200
@@ -700,12 +700,14 @@
 
switch (address_family) {
case AF_INET: {
-   const char structure_info[4] = { 0xFF, 0xFF, 0xFF, 9 };
+   const char structure_info[4] = { (char)0xFF, (char)0xFF,
+(char)0xFF, 9 };
dat_stream.write(structure_info, 4);
break;
}
case AF_INET6: {
-   const char structure_info[4] = { 0xFF, 0xFF, 0xFF, 21 };
+   const char structure_info[4] = { (char)0xFF, (char)0xFF,
+(char)0xFF, 21 };
dat_stream.write(structure_info, 4);
break;
}

++ geoip-csv-to-dat.cpp ++
--- /var/tmp/diff_new_pack.ol1xB2/_old  2016-06-19 10:49:39.0 +0200
+++ /var/tmp/diff_new_pack.ol1xB2/_new  2016-06-19 10:49:39.0 +0200
@@ -655,12 +655,12 @@
uint8_t bytes[6];
char chars[6];
} binary = {{
-   (it->edges[0]  ) & 0xFF,
-   (it->edges[0] >>  8) & 0xFF,
-   (it->edges[0] >> 16) & 0xFF,
-   (it->edges[1]  ) & 0xFF,
-   (it->edges[1] >>  8) & 0xFF,
-   (it->edges[1] >> 16) & 0xFF
+   (uint8_t) ((it->edges[0]  ) & 0xFF),
+   (uint8_t) ((it->edges[0] >>  8) & 0xFF),
+   (uint8_t) ((it->edges[0] >> 16) & 0xFF),
+   (uint8_t) ((it->edges[1]  ) & 0xFF),
+   (uint8_t) ((it->edges[1] >>  8) & 0xFF),
+   (uint8_t) ((it->edges[1] >> 16) & 0xFF)
}};
dat_stream->write(binary.chars, 6);
if (dat_stream->bad())
@@ -680,7 +680,8 @@
 
 void dat_writer::write_structure_info()
 {
-   const char structure_info[4] = { 0xFF, 0xFF, 0xFF, database_type };
+   const char structure_info[4] = { (char)0xFF, (char)0xFF, (char)0xFF,
+(char)database_type };
dat_stream->write(structure_info, 4);
 }
 
@@ -804,13 +805,13 @@
 {
int trie_size = std::distance(trie.nodes_begin(), trie.nodes_end());
 
-   const char structure_info[7] = { 0xFF,
-0xFF,
-0xFF,
-database_type,
-(trie_size  ) & 0xFF,
-(trie_size >> 8 ) & 0xFF,
-(trie_size >> 16) & 0xFF};
+   const char structure_info[7] = { (char)0xFF,
+(char)0xFF,
+(char)0xFF,
+(char)database_type,
+(char)((trie_size  ) & 0xFF),
+(char)((trie_size >> 8 ) & 0xFF),
+(char)((trie_size >> 16) & 0xFF)};
dat_stream->write(structure_info, 7);
 }
 




commit fwnn for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package fwnn for openSUSE:Factory checked in 
at 2016-06-19 10:49:01

Comparing /work/SRC/openSUSE:Factory/fwnn (Old)
 and  /work/SRC/openSUSE:Factory/.fwnn.new (New)


Package is "fwnn"

Changes:

--- /work/SRC/openSUSE:Factory/fwnn/fwnn.changes2015-12-29 
12:59:29.0 +0100
+++ /work/SRC/openSUSE:Factory/.fwnn.new/fwnn.changes   2016-06-19 
10:49:06.0 +0200
@@ -1,0 +2,13 @@
+Mon Jun 13 22:33:24 UTC 2016 - jeng...@inai.de
+
+- Implement shared library guideline
+- Condense description to present the main idea
+- Rename development subpackages to *-devel
+
+---
+Tue Jun  7 13:58:26 UTC 2016 - mp...@suse.com
+
+- Removed %{?_smp_mflags} from the make command to fix a build
+  failure on the s390x architecture.
+
+---



Other differences:
--
++ fwnn.spec ++
--- /var/tmp/diff_new_pack.YNHCQE/_old  2016-06-19 10:49:08.0 +0200
+++ /var/tmp/diff_new_pack.YNHCQE/_new  2016-06-19 10:49:08.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package fwnn
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -49,19 +49,8 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-FreeWnn is a Kana-Kanji translation system, originally developed by a
-joint project made up of Kyoto University, OMRON Corporation [formerly
-known as Tateishi Electronics Co.], and ASTEC Inc. Further development
-and maintenance is now done by the "FreeWnn Project"
-(http://www.freewnn.org).
-
-The name "Wnn", is an acronym for the Japanese sentence "Watashino
-Namaeha Nakanodesu" (literally, it means "my name is Nakano."), and is
-derived from a goal of the project: to develop a system powerful enough
-to translate a whole sentence like that at once.  The source code has
-been written in C and is freely distributed. Consequently, Wnn spread
-widely among workstation platforms, and became a de facto standard as a
-Kana-Kanji translation system for UNIX operating systems.
+FreeWnn is a Kana-Kanji translation system intended as a system
+powerful enough to translate entire sentences at once.
 
 Wnn works in a client/server manner. The server portion of Wnn, or
 jserver, is used as a Kana-Kanji translation engine for clients like
@@ -71,11 +60,27 @@
 
 This package contains only the Japanese server.
 
+%package -n libjd0
+Summary:FreeWnn Japanese Input System library
+Group:  System/Libraries
+
+%description -n libjd0
+This subpackage contains a core library of the Wnn input system.
+
+%package -n libwnn0
+Summary:FreeWnn Input System library
+Group:  System/Libraries
+
+%description -n libwnn0
+This subpackage contains a core library of the Wnn input system.
+
 %package -n fwnn-devel
 Summary:Development Library and Header Files for FreeWnn
 Group:  Development/Libraries/C and C++
-Requires:   fcwnndev = %{version}
+Requires:   fcwnn-devel = %{version}
 Requires:   fwnn = %{version}
+Requires:   libjd0 = %{version}
+Requires:   libwnn0 = %{version}
 Provides:   fwnndev = %{version}
 Obsoletes:  fwnndev < %{version}
 
@@ -117,12 +122,22 @@
 Chinese Input Systems. Free cWnn is for mainland Chinese and free tWnn
 is for Taiwan-Chinese.
 
-%package -n fcwnndev
+%package -n libcwnn0
+Summary:FreeWnn Chinese Input System library
+Group:  System/Libraries
+
+%description -n libcwnn0
+This subpackage contains a core library of the Wnn input system.
+
+%package -n fcwnn-devel
 Summary:Development Libraries and Header Files for Free cWnn
 Group:  Development/Libraries/C and C++
 Requires:   fcwnn = %{version}
+Requires:   libcwnn0 = %{version}
+Obsoletes:  fcwnndev < %{version}-%{release}
+Provides:   fcwnndev = %{version}-%{release}
 
-%description -n fcwnndev
+%description -n fcwnn-devel
 This package contains the header files and libraries for building
 client programs that use the Chinese Input System, Free cWnn.
 
@@ -148,13 +163,22 @@
 %description -n fkwnn
 Free kWnn Korean input system.
 
-%package -n fkwnndev
+%package -n libkwnn0
+Summary:FreeWnn Korean Input System library
+Group:  System/Libraries
+
+%description -n libkwnn0
+This subpackage contains a core library of the Wnn input system.
+
+%package -n fkwnn-devel
 Summary:Development Libraries and Header Files for Free kWnn
 Group:  

commit elinks for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package elinks for openSUSE:Factory checked 
in at 2016-06-19 10:49:13

Comparing /work/SRC/openSUSE:Factory/elinks (Old)
 and  /work/SRC/openSUSE:Factory/.elinks.new (New)


Package is "elinks"

Changes:

--- /work/SRC/openSUSE:Factory/elinks/elinks.changes2016-05-04 
08:19:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.elinks.new/elinks.changes   2016-06-19 
10:49:15.0 +0200
@@ -1,0 +2,8 @@
+Tue Jun 14 14:46:59 UTC 2016 - adam.ma...@suse.de
+
+- Add %perl_requires to be certain that package rebuilds when
+  perl is updated. This is causing elinks not to be rebuilt with
+  factory and it can't find current libperl.so. See bnc#984661
+  for details.
+
+---



Other differences:
--
++ elinks.spec ++
--- /var/tmp/diff_new_pack.SIPU88/_old  2016-06-19 10:49:16.0 +0200
+++ /var/tmp/diff_new_pack.SIPU88/_new  2016-06-19 10:49:16.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package elinks
 #
-# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define pkg_version 0.12pre6
 
 %bcond_with js
@@ -22,10 +23,10 @@
 Name:   elinks
 Version:0.11.996
 Release:0
-License:GPL-2.0
 Summary:An advanced and well-established feature-rich text mode web 
browser
-Url:http://elinks.or.cz/
+License:GPL-2.0
 Group:  Productivity/Networking/Web/Browsers
+Url:http://elinks.or.cz/
 Source0:http://elinks.or.cz/download/%{name}-%{pkg_version}.tar.bz2
 # PATCH-FIX-UPSTREAM elinks-0.12_pre5-compilation-fix.patch 
asterios.dra...@gmail.com -- Fix compilation with gc (patch taken from Gentoo)
 Patch0: elinks-0.12_pre5-compilation-fix.patch
@@ -38,8 +39,8 @@
 %endif
 BuildRequires:  gpm-devel
 %if %{with js}
-BuildRequires:  mozjs24-devel
 BuildRequires:  gcc-c++
+BuildRequires:  mozjs24-devel
 %endif
 BuildRequires:  krb5-devel
 BuildRequires:  libbz2-devel
@@ -50,14 +51,17 @@
 %else
 BuildRequires:  lua-devel
 %endif
+BuildRequires:  autoconf
+BuildRequires:  automake
+BuildRequires:  libtool
 BuildRequires:  openssl-devel
 BuildRequires:  pkg-config
 BuildRequires:  ruby-devel
 BuildRequires:  tre-devel
 BuildRequires:  zlib-devel
-BuildRequires:  automake autoconf libtool
 Provides:   web_browser
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+%perl_requires
 
 %description
 ELinks is an advanced and well-established feature-rich text mode web




commit criu for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package criu for openSUSE:Factory checked in 
at 2016-06-19 10:49:34

Comparing /work/SRC/openSUSE:Factory/criu (Old)
 and  /work/SRC/openSUSE:Factory/.criu.new (New)


Package is "criu"

Changes:

--- /work/SRC/openSUSE:Factory/criu/criu.changes2016-05-19 
12:15:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.criu.new/criu.changes   2016-06-19 
10:49:36.0 +0200
@@ -1,0 +2,28 @@
+Wed Jun 15 08:19:40 CEST 2016 - ti...@suse.de
+
+- Update to criu 2.3:
+  New features
+  * Ability not to show payload for some objects in CRIT
+  * Pidfile is written at the end of restore
+  * Ability to join existing namespaces on restore
+  * C/R of Data sitting in TTYs, Partially write-protected SysVIPC
+segments, Debugfs and tracefs mounts, Overmounted tmpfs, IPv6
+devconf sysctls, External block devices, Unix sockets with
+mismatched shutdown state
+  Optimizations/improvements:
+  * Relaxed calculation of AIO ring size
+  * Tree-based search of tasks by real pid
+  * Less mem-to-mem copies on restore
+  * Saner devconf image format
+  * More verbose explanation of why task cannot be seized
+  * PID is printed in PIE logs
+  Fixes:
+  * Too many mmap-ed files blocked the dump
+  * Potential memory corruption when working with IPv6 sockets
+  * Overmounted bind mounts could cause restore to fail
+  * Overmounted bind mounts could result in badly restored mount tree
+  * Incomplete restoration of RO bind mounts options
+  Deprecated/removed:
+  * Greedy mode of pagemap (non-root) caused dump to fail (disabled)
+
+---

Old:

  criu-2.2.tar.bz2

New:

  criu-2.3.tar.bz2



Other differences:
--
++ criu.spec ++
--- /var/tmp/diff_new_pack.jnmMJh/_old  2016-06-19 10:49:37.0 +0200
+++ /var/tmp/diff_new_pack.jnmMJh/_new  2016-06-19 10:49:37.0 +0200
@@ -16,15 +16,14 @@
 #
 
 
-%define package_version 2.2
 Name:   criu
-Version:2.2
+Version:2.3
 Release:0
 Summary:Checkpoint/Restore In Userspace Tools
 License:GPL-2.0
 Group:  System/Console
 Url:http://criu.org/
-Source0:http://download.openvz.org/criu/criu-%{package_version}.tar.bz2
+Source0:http://download.openvz.org/criu/criu-%{version}.tar.bz2
 BuildRequires:  asciidoc
 %if 0%{suse_version} > 1320
 BuildRequires:  libbsd-devel
@@ -68,7 +67,7 @@
 to develop applications with CRIU library.
 
 %prep
-%setup -q -n %{name}-%{package_version}
+%setup -q
 
 %build
 export CFLAGS="%{optflags}"

++ criu-2.2.tar.bz2 -> criu-2.3.tar.bz2 ++
 10105 lines of diff (skipped)




commit python3-pyzmq for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package python3-pyzmq for openSUSE:Factory 
checked in at 2016-06-19 10:48:59

Comparing /work/SRC/openSUSE:Factory/python3-pyzmq (Old)
 and  /work/SRC/openSUSE:Factory/.python3-pyzmq.new (New)


Package is "python3-pyzmq"

Changes:

--- /work/SRC/openSUSE:Factory/python3-pyzmq/python3-pyzmq.changes  
2016-05-25 21:26:02.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-pyzmq.new/python3-pyzmq.changes 
2016-06-19 10:49:05.0 +0200
@@ -1,0 +2,6 @@
+Mon Jun 13 19:10:29 UTC 2016 - toddrme2...@gmail.com
+
+- Enable gevent.  It is now available for python 3.
+- Disable unused test dependencies.
+
+---



Other differences:
--
++ python3-pyzmq.spec ++
--- /var/tmp/diff_new_pack.8spGbH/_old  2016-06-19 10:49:06.0 +0200
+++ /var/tmp/diff_new_pack.8spGbH/_new  2016-06-19 10:49:06.0 +0200
@@ -37,10 +37,9 @@
 BuildRequires:  python3-simplejson
 BuildRequires:  python3-tornado
 BuildRequires:  zeromq-devel
-# Not available yet in Python 3.x
-# BuildRequires:  python3-gevent
+BuildRequires:  python3-gevent
 # Test requirements
-BuildRequires:  python3-nose
+# BuildRequires:  python3-nose
 Requires:   python3
 Recommends: python3-cffi
 Recommends: python3-numpy
@@ -49,8 +48,7 @@
 Recommends: python3-simplejson
 Recommends: python3-tornado
 Recommends: python3-paramiko
-# Not available yet in Python 3.x
-# Recommends: python3-gevent
+Recommends: python3-gevent
 Recommends: zeromq
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 




commit profanity for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package profanity for openSUSE:Factory 
checked in at 2016-06-19 10:49:06

Comparing /work/SRC/openSUSE:Factory/profanity (Old)
 and  /work/SRC/openSUSE:Factory/.profanity.new (New)


Package is "profanity"

Changes:

--- /work/SRC/openSUSE:Factory/profanity/profanity.changes  2015-10-03 
20:30:20.0 +0200
+++ /work/SRC/openSUSE:Factory/.profanity.new/profanity.changes 2016-06-19 
10:49:10.0 +0200
@@ -1,0 +2,7 @@
+Tue Jun 14 11:24:48 UTC 2016 - mvet...@suse.com
+
+- Split profanity in two packages:
+  standard - the default with all features enabled
+  mini - disabling notifications thus not needing X
+
+---



Other differences:
--
++ profanity.spec ++
--- /var/tmp/diff_new_pack.OluM5g/_old  2016-06-19 10:49:10.0 +0200
+++ /var/tmp/diff_new_pack.OluM5g/_new  2016-06-19 10:49:10.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package profanity
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -39,9 +39,38 @@
 BuildRequires:  readline-devel
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
+Requires:   profanity-binary = %{version}
+
 %description
 Profanity is a console based XMPP client written in C using ncurses and 
libstrophe, inspired by Irssi.
 
+%package mini
+Provides:   profanity-binary = %{version}-%{release}
+Requires:   profanity = %{version}
+Requires(post): update-alternatives
+Requires(preun): update-alternatives
+#
+Summary:Console based XMPP client
+Group:  Productivity/Networking/Instant Messenger
+
+%description mini
+Profanity is a console based XMPP client written in C using ncurses and 
libstrophe, inspired by Irssi.
+This package holds the version without desktop notifications support. It is 
well suited for headless servers.
+
+%package standard
+Provides:   profanity-binary = %{version}-%{release}
+Requires:   profanity = %{version}
+Requires(post): update-alternatives
+Requires(preun): update-alternatives
+#
+Summary:Console based XMPP client
+Group:  Productivity/Networking/Instant Messenger
+
+%description standard
+Profanity is a console based XMPP client written in C using ncurses and 
libstrophe, inspired by Irssi.
+
+This package holds the standard version with desktop notifications support.
+
 %prep
 %setup -q
 
@@ -57,12 +86,60 @@
 %install
 make DESTDIR=%{buildroot} install %{?_smp_mflags}
 
+mv %{buildroot}%{_bindir}/profanity{,-standard}
+
+make clean
+
+%configure \
+   --disable-notifications \
+   --enable-otr \
+   --with-themes \
+   --enable-pgp
+make %{?_smp_mflags}
+make DESTDIR=%{buildroot} install %{?_smp_mflags}
+
+mv %{buildroot}%{_bindir}/profanity{,-mini}
+
+# u-a handling
+mkdir -p %{buildroot}/etc/alternatives/
+ln -s profanity %{buildroot}/etc/alternatives/profanity
+ln -s profanity %{buildroot}%{_bindir}/profanity
+
 %files
 %defattr(-,root,root)
-%{_bindir}/profanity
 %{_mandir}/man1/profanity.1.*
 %dir %{_datadir}/profanity/themes/
 %dir %{_datadir}/profanity/
 %{_datadir}/profanity/themes/*
 
+%files mini
+%defattr(-,root,root)
+%ghost /etc/alternatives/profanity
+%ghost %{_bindir}/profanity
+%{_bindir}/profanity-mini
+
+%files standard
+%defattr(-,root,root)
+%ghost /etc/alternatives/profanity
+%ghost %{_bindir}/profanity
+%{_bindir}/profanity-standard
+
+%post mini
+/usr/sbin/update-alternatives --install \
+%{_bindir}/profanity profanity %{_bindir}/profanity-mini 10
+
+%preun mini
+if [ "$1" = 0 ] ; then
+  /usr/sbin/update-alternatives --remove profanity %{_bindir}/profanity-mini
+fi
+
+%post standard
+/usr/sbin/update-alternatives --install \
+%{_bindir}/profanity profanity %{_bindir}/profanity-standard 20
+
+%preun standard
+if [ "$1" = 0 ] ; then
+  /usr/sbin/update-alternatives --remove profanity 
%{_bindir}/profanity-standard
+fi
+
 %changelog




commit python-pygraphviz for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package python-pygraphviz for 
openSUSE:Factory checked in at 2016-06-19 10:49:31

Comparing /work/SRC/openSUSE:Factory/python-pygraphviz (Old)
 and  /work/SRC/openSUSE:Factory/.python-pygraphviz.new (New)


Package is "python-pygraphviz"

Changes:

--- /work/SRC/openSUSE:Factory/python-pygraphviz/python-pygraphviz.changes  
2014-03-30 12:26:01.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-pygraphviz.new/python-pygraphviz.changes 
2016-06-19 10:49:34.0 +0200
@@ -1,0 +2,10 @@
+Wed Jun 15 17:11:49 UTC 2016 - toddrme2...@gmail.com
+
+- Update to 1.3.1
+  - Update manifest to include missing files
+- Update to 1.3
+  - Python 3 support
+  - Encoding bugfixes
+- Rebase docdir.patch
+
+---

Old:

  pygraphviz-1.2.tar.gz

New:

  pygraphviz-1.3.1.tar.gz



Other differences:
--
++ python-pygraphviz.spec ++
--- /var/tmp/diff_new_pack.3kjd4Z/_old  2016-06-19 10:49:35.0 +0200
+++ /var/tmp/diff_new_pack.3kjd4Z/_new  2016-06-19 10:49:35.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pygraphviz
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   python-pygraphviz
-Version:1.2
+Version:1.3.1
 Release:0
 Url:http://networkx.lanl.gov/pygraphviz
 Summary:Python interface to Graphviz
@@ -27,14 +27,14 @@
 # PATCH-FIX-UPSTREAM docdir.patch
 Patch:  docdir.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  graphviz-devel
+BuildRequires:  graphviz-devel >= 2.16
 BuildRequires:  pkg-config
+BuildRequires:  python-nose
 BuildRequires:  python-devel
-Requires:   graphviz-python
+BuildRequires:  python-setuptools
+Requires:   graphviz >= 2.16
 %if 0%{?suse_version} <= 1110
-%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from 
distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
-%else
-%py_requires
+%{!?python_sitearch: %global python_sitearch %(python -c "from 
distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
 %endif
 
 %description
@@ -46,19 +46,20 @@
 %patch
 
 %build
-export CFLAGS="%{optflags}"
-python setup.py build
+CFLAGS="%{optflags}" python setup.py build
 
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
 chmod +x %{buildroot}%{python_sitearch}/pygraphviz/tests/test.py
 
-%clean
-rm -rf %{buildroot}
+%check
+pushd examples
+PYTHONPATH=%{buildroot}%{python_sitearch} python -c "import 
pygraphviz;pygraphviz.test()"
+popd
 
 %files
 %defattr(-,root,root,-)
-%doc doc
+%doc LICENSE README.rst
 %{_docdir}/pygraphviz-%{version}
 %{python_sitearch}/pygraphviz/
 %{python_sitearch}/pygraphviz-%{version}-py*.egg-info

++ docdir.patch ++
--- /var/tmp/diff_new_pack.3kjd4Z/_old  2016-06-19 10:49:35.0 +0200
+++ /var/tmp/diff_new_pack.3kjd4Z/_new  2016-06-19 10:49:35.0 +0200
@@ -2,12 +2,12 @@
 ===
 --- setup.py.orig
 +++ setup.py
-@@ -109,7 +109,7 @@ else:
+@@ -36,7 +36,7 @@
  sys.path.pop(0)
  
- packages = ["pygraphviz","pygraphviz.tests"]
--docdirbase  = 'share/doc/pygraphviz-%s' % release.version
-+docdirbase  = 'share/doc/packages/pygraphviz-%s' % release.version
- data = [(docdirbase, glob("*.txt")),
- (os.path.join(docdirbase, 'examples'),glob("examples/*.py")),
- (os.path.join(docdirbase, 'examples'),glob("examples/*.dat")),
+ packages = ["pygraphviz", "pygraphviz.tests"]
+-docdirbase = 'share/doc/pygraphviz-%s' % release.version
++docdirbase = 'share/doc/packages/pygraphviz-%s' % release.version
+ data = [
+ (docdirbase, glob("*.txt")),
+ (os.path.join(docdirbase, 'examples'), glob("examples/*.py")),

++ pygraphviz-1.2.tar.gz -> pygraphviz-1.3.1.tar.gz ++
 17753 lines of diff (skipped)




commit gnome-mines for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package gnome-mines for openSUSE:Factory 
checked in at 2016-06-19 10:49:22

Comparing /work/SRC/openSUSE:Factory/gnome-mines (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-mines.new (New)


Package is "gnome-mines"

Changes:

--- /work/SRC/openSUSE:Factory/gnome-mines/gnome-mines.changes  2016-03-29 
14:41:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-mines.new/gnome-mines.changes 
2016-06-19 10:49:26.0 +0200
@@ -1,0 +2,7 @@
+Wed Jun 15 10:18:53 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.20.1:
+  + Can not enter custom size (bgo#766145).
+  + Updated translations.
+
+---

Old:

  gnome-mines-3.20.0.tar.xz

New:

  gnome-mines-3.20.1.tar.xz



Other differences:
--
++ gnome-mines.spec ++
--- /var/tmp/diff_new_pack.Txra2H/_old  2016-06-19 10:49:27.0 +0200
+++ /var/tmp/diff_new_pack.Txra2H/_new  2016-06-19 10:49:27.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-mines
-Version:3.20.0
+Version:3.20.1
 Release:0
 Summary:Minesweeper Game for GNOME
 License:GPL-2.0+

++ gnome-mines-3.20.0.tar.xz -> gnome-mines-3.20.1.tar.xz ++
 10624 lines of diff (skipped)




commit libcpuset for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package libcpuset for openSUSE:Factory 
checked in at 2016-06-19 10:49:30

Comparing /work/SRC/openSUSE:Factory/libcpuset (Old)
 and  /work/SRC/openSUSE:Factory/.libcpuset.new (New)


Package is "libcpuset"

Changes:

--- /work/SRC/openSUSE:Factory/libcpuset/libcpuset.changes  2016-05-23 
16:39:17.0 +0200
+++ /work/SRC/openSUSE:Factory/.libcpuset.new/libcpuset.changes 2016-06-19 
10:49:33.0 +0200
@@ -1,0 +2,8 @@
+Wed Jun 15 16:53:24 UTC 2016 - mgalbra...@suse.com
+
+- Add missing patch.  (SUSE bnc#546310, bnc#984832)
+
+- Patches added by this commit:
+  libcpuset-init-buf-2.patch
+
+---

New:

  libcpuset-init-buf-2.patch



Other differences:
--
++ libcpuset.spec ++
--- /var/tmp/diff_new_pack.bsXt6e/_old  2016-06-19 10:49:34.0 +0200
+++ /var/tmp/diff_new_pack.bsXt6e/_new  2016-06-19 10:49:34.0 +0200
@@ -31,6 +31,7 @@
 Patch3: libcpuset-agnostic-mountpoint.diff
 Patch4: libcpuset-handle-cgroup-mount.diff
 Patch5: 
libcpuset-robustify-cpuset_pin-cpuset_size-cpuset_where-error-handling.diff
+Patch6: libcpuset-init-buf-2.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  libbitmask-devel
@@ -73,6 +74,7 @@
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 %build
 sed -i -e 's@-Werror@@g' configure.in

++ libcpuset-init-buf-2.patch ++
Subject: Fix buf initialization (bnc#546310, bnc#984832)
From: Derek Fults 
Date: 2009-11-11 18:22 UTC

Signed-off-by: Derek Fults 
Signed-off-by: Mike Galbraith 
---

 libcpuset.c |2 ++
 1 file changed, 2 insertions(+)

--- a/libcpuset.c
+++ b/libcpuset.c
@@ -3355,6 +3355,8 @@ int cpuset_latestcpu(pid_t pid)
 
if ((fd = open(buf, O_RDONLY)) < 0)
goto err;
+
+memset(buf, '\0', sizeof(buf));
if (read(fd, buf, sizeof(buf)) < 1)
goto err;
close(fd);



commit gst-rtsp-server for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package gst-rtsp-server for openSUSE:Factory 
checked in at 2016-06-19 10:49:39

Comparing /work/SRC/openSUSE:Factory/gst-rtsp-server (Old)
 and  /work/SRC/openSUSE:Factory/.gst-rtsp-server.new (New)


Package is "gst-rtsp-server"

Changes:

--- /work/SRC/openSUSE:Factory/gst-rtsp-server/gst-rtsp-server.changes  
2016-05-03 10:16:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.gst-rtsp-server.new/gst-rtsp-server.changes 
2016-06-19 10:49:41.0 +0200
@@ -1,0 +2,9 @@
+Wed Jun 15 14:27:03 UTC 2016 - zai...@opensuse.org
+
+- Update to version 1.8.1:
+  + bgo#764744: Crashes when multiple udpsrc are created for each
+client on a shared media, misses tracking and cleanup.
+  + bgo#766619: Space between ; and timeout= in session header is
+not RFC2326 compliant.
+
+---

Old:

  gst-rtsp-server-1.8.1.tar.xz

New:

  gst-rtsp-server-1.8.2.tar.xz



Other differences:
--
++ gst-rtsp-server.spec ++
--- /var/tmp/diff_new_pack.7oaZYQ/_old  2016-06-19 10:49:42.0 +0200
+++ /var/tmp/diff_new_pack.7oaZYQ/_new  2016-06-19 10:49:42.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gst-rtsp-server
-Version:1.8.1
+Version:1.8.2
 Release:0
 Summary:GStreamer based RTSP server library
 License:LGPL-2.0+

++ gst-rtsp-server-1.8.1.tar.xz -> gst-rtsp-server-1.8.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gst-rtsp-server-1.8.1/ChangeLog 
new/gst-rtsp-server-1.8.2/ChangeLog
--- old/gst-rtsp-server-1.8.1/ChangeLog 2016-04-20 17:16:52.0 +0200
+++ new/gst-rtsp-server-1.8.2/ChangeLog 2016-06-09 10:27:42.0 +0200
@@ -1,9 +1,46 @@
+=== release 1.8.2 ===
+
+2016-06-09  Sebastian Dröge 
+
+   * configure.ac:
+ releasing 1.8.2
+
+2016-05-18 16:48:44 +0100  Ian 
+
+   * gst/rtsp-server/rtsp-session.c:
+ rtsp-session: RFC2326 does not allow a space between ; and timeout in 
the Session header
+ This works with rtspsrc and live555, but fails with e.g. ffmpeg.
+ https://bugzilla.gnome.org/show_bug.cgi?id=766619
+
+2016-04-25 08:55:25 -0400  Jake Foytik 
+
+   * gst/rtsp-server/rtsp-stream.c:
+   * tests/check/gst/rtspserver.c:
+   * tests/check/gst/stream.c:
+ rtsp-stream: Fix crash on cleanup with shared media and multiple 
udpsrc
+ - Unicast udpsrcs are now managed in a hash table. This allows for 
proper cleanup in with shared streams and fixes a memory leak.
+ - Unicast udpsrcs are now properly cleaned up when shared connections 
exit. See the update_transport() function.
+ - Create unit test for shared media.
+ https://bugzilla.gnome.org/show_bug.cgi?id=764744
+
+2016-04-11 10:55:23 +0300  Sebastian Dröge 
+
+   * gst/rtsp-server/rtsp-stream.c:
+ rtsp-stream: Always bind to ANY when address is a multicast address 
and not only on Windows
+ For IPv6 addresses, binding to a multicast group does not work on 
Linux
+ either. Always bind to ANY and then later join the multicast group.
+ https://bugzilla.gnome.org/show_bug.cgi?id=764679
+
 === release 1.8.1 ===
 
-2016-04-20  Sebastian Dröge 
+2016-04-20 18:33:39 +0300  Sebastian Dröge 
 
+   * ChangeLog:
+   * NEWS:
+   * RELEASE:
* configure.ac:
- releasing 1.8.1
+   * gst-rtsp-server.doap:
+ Release 1.8.1
 
 === release 1.8.0 ===
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gst-rtsp-server-1.8.1/NEWS 
new/gst-rtsp-server-1.8.2/NEWS
--- old/gst-rtsp-server-1.8.1/NEWS  2016-04-20 17:17:47.0 +0200
+++ new/gst-rtsp-server-1.8.2/NEWS  2016-06-09 10:28:27.0 +0200
@@ -1,25 +1,27 @@
-### 1.8.1
+### 1.8.2
 
-The first 1.8 bug-fix release (1.8.1) was released on 20 April 2016.
+The first 1.8 bug-fix release (1.8.2) was released on 9 June 2016.
 This release only contains bugfixes and it should be safe to update from 1.8.0.
 
- Major bugfixes in 1.8.1
+ Major bugfixes in 1.8.2
 
- - Fix app compilation with Android NDK r11 and newer
- - Fix compilation of nvenc plugin against latest NVIDIA SDK 6.0
- - Fix regression in avdeinterlace
- - Fix memory corruption in scaletempo element with S16 input
- - Fix regression in qtdemux with MSE streams
- - Fix glitches at the start with all audio sinks except for pulsesink
- - Fix regression with encrypted HLS streams
- - Fix automatic multithreaded 

commit bundle-lang-common for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package bundle-lang-common for 
openSUSE:Factory checked in at 2016-06-19 10:48:38

Comparing /work/SRC/openSUSE:Factory/bundle-lang-common (Old)
 and  /work/SRC/openSUSE:Factory/.bundle-lang-common.new (New)


Package is "bundle-lang-common"

Changes:

--- /work/SRC/openSUSE:Factory/bundle-lang-common/bundle-lang-common.changes
2016-05-19 23:28:33.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.bundle-lang-common.new/bundle-lang-common.changes   
2016-06-19 10:48:39.0 +0200
@@ -1,0 +2,5 @@
+Mon Jun 13 11:50:07 UTC 2016 - dims...@opensuse.org
+
+- Update package list.
+
+---
bundle-lang-gnome.changes: same change
bundle-lang-kde.changes: same change



Other differences:
--
++ bundle-lang-common.spec ++
 708 lines (skipped)
 between 
/work/SRC/openSUSE:Factory/bundle-lang-common/bundle-lang-common.spec
 and 
/work/SRC/openSUSE:Factory/.bundle-lang-common.new/bundle-lang-common.spec

bundle-lang-gnome.spec: same change
bundle-lang-other.spec: same change
++ packages.txt ++
--- /var/tmp/diff_new_pack.14InqG/_old  2016-06-19 10:48:41.0 +0200
+++ /var/tmp/diff_new_pack.14InqG/_new  2016-06-19 10:48:41.0 +0200
@@ -217,7 +217,7 @@
 gsettings-desktop-schemas-lang common
 gspell-lang gnome
 gstreamer-lang common
-gstreamer-plugins-bad-lang gnome
+gstreamer-plugins-bad-lang common
 gstreamer-plugins-base-lang common
 gstreamer-plugins-good-lang common
 gstreamer-plugins-ugly-lang gnome
@@ -338,7 +338,7 @@
 libksysguard5-lang kde
 libosinfo-lang gnome
 libpeas-lang gnome
-libpurple-lang gnome
+libpurple-lang common
 libpurple-plugin-bot-sentry-lang gnome-extras
 libpurple-plugin-mrim-lang gnome-extras
 libpurple-plugin-openfetion-lang gnome-extras




commit perl-Devel-PPPort for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package perl-Devel-PPPort for 
openSUSE:Factory checked in at 2016-06-19 10:47:57

Comparing /work/SRC/openSUSE:Factory/perl-Devel-PPPort (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Devel-PPPort.new (New)


Package is "perl-Devel-PPPort"

Changes:

--- /work/SRC/openSUSE:Factory/perl-Devel-PPPort/perl-Devel-PPPort.changes  
2015-10-14 16:44:07.0 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Devel-PPPort.new/perl-Devel-PPPort.changes 
2016-06-19 10:47:58.0 +0200
@@ -1,0 +2,23 @@
+Sun Jun 12 12:53:58 UTC 2016 - co...@suse.com
+
+- updated to 3.33
+   see /usr/share/doc/packages/perl-Devel-PPPort/Changes
+
+  3.33 - 2016-06-03
+  
+  * Add PERL_OP_PARENT related macros, and cBOOL
+  * Add SvRXOK/SvRX/PERL_MAGIC_qr
+(Thanks to arc)
+  * sort files from all_files_in_dir (GH #28, 
https://bugs.debian.org/801523
+(Thanks to ntyni)
+  * Fix coverity finding in test (GH #25)
+(Thanks to jhi)
+  * Add PERL_UNUSED_RESULT and a test (GH #20)
+  * Don't redefine MUTABLE_PTR if it's already there (GH #23)
+  * Add C_ARRAY_LENGTH and C_ARRAY_END (GH #16)
+  * Fix gv_fetchpvn_flags and add init_gv_pvn (#GH 32)
+(Thanks to leont)
+  * Fix compiler warnings
+(Thanks to Dave M.)
+
+---

Old:

  Devel-PPPort-3.32.tar.gz

New:

  Devel-PPPort-3.33.tar.gz



Other differences:
--
++ perl-Devel-PPPort.spec ++
--- /var/tmp/diff_new_pack.nCn1tZ/_old  2016-06-19 10:47:59.0 +0200
+++ /var/tmp/diff_new_pack.nCn1tZ/_new  2016-06-19 10:47:59.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Devel-PPPort
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Devel-PPPort
-Version:3.32
+Version:3.33
 Release:0
 %define cpan_name Devel-PPPort
 Summary:Perl/Pollution/Portability
@@ -52,7 +52,7 @@
 
 %prep
 %setup -q -n %{cpan_name}-%{version}
-find . -type f -print0 | xargs -0 chmod 644
+find . -type f ! -name \*.pl -print0 | xargs -0 chmod 644
 
 %build
 %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"

++ Devel-PPPort-3.32.tar.gz -> Devel-PPPort-3.33.tar.gz ++
 3399 lines of diff (skipped)




commit perl-Math-BigInt for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package perl-Math-BigInt for 
openSUSE:Factory checked in at 2016-06-19 10:48:03

Comparing /work/SRC/openSUSE:Factory/perl-Math-BigInt (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Math-BigInt.new (New)


Package is "perl-Math-BigInt"

Changes:

--- /work/SRC/openSUSE:Factory/perl-Math-BigInt/perl-Math-BigInt.changes
2016-05-25 21:22:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Math-BigInt.new/perl-Math-BigInt.changes   
2016-06-19 10:48:03.0 +0200
@@ -1,0 +2,17 @@
+Sun Jun 12 13:17:55 UTC 2016 - co...@suse.com
+
+- updated to 1.999723
+   see /usr/share/doc/packages/perl-Math-BigInt/CHANGES
+
+  2016-06-09 v1.999723 pjacklam
+  
+   * Add Math::BigInt and Math::BigFloat methods bnstr(), bestr(), and bdstr(),
+ as well as corresponding methods nparts(), eparts(), and dparts(). Also 
add
+ test files bdstr-mbf.t, bdstr-mbi.t, bestr-mbf.t, bestr-mbi.t, 
bnstr-mbf.t,
+ bnstr-mbi.t, bsstr-mbf.t, bsstr-mbi.t, dparts-mbf.t, dparts-mbi.t,
+ eparts-mbf.t, eparts-mbi.t, nparts-mbf.t, nparts-mbi.t, sparts-mbf.t, and
+ sparts-mbi.t.
+  
+   * Fix documentation errors.
+
+---

Old:

  Math-BigInt-1.999722.tar.gz

New:

  Math-BigInt-1.999723.tar.gz



Other differences:
--
++ perl-Math-BigInt.spec ++
--- /var/tmp/diff_new_pack.9ZEf9f/_old  2016-06-19 10:48:04.0 +0200
+++ /var/tmp/diff_new_pack.9ZEf9f/_new  2016-06-19 10:48:04.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Math-BigInt
-Version:1.999722
+Version:1.999723
 Release:0
 %define cpan_name Math-BigInt
 Summary:Arbitrary size integer/float math package

++ Math-BigInt-1.999722.tar.gz -> Math-BigInt-1.999723.tar.gz ++
 4686 lines of diff (skipped)




commit perl-Scope-Upper for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package perl-Scope-Upper for 
openSUSE:Factory checked in at 2016-06-19 10:48:15

Comparing /work/SRC/openSUSE:Factory/perl-Scope-Upper (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Scope-Upper.new (New)


Package is "perl-Scope-Upper"

Changes:

--- /work/SRC/openSUSE:Factory/perl-Scope-Upper/perl-Scope-Upper.changes
2015-08-27 08:56:18.0 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Scope-Upper.new/perl-Scope-Upper.changes   
2016-06-19 10:48:16.0 +0200
@@ -1,0 +2,15 @@
+Sun Jun 12 13:45:25 UTC 2016 - co...@suse.com
+
+- updated to 0.29
+   see /usr/share/doc/packages/perl-Scope-Upper/Changes
+
+  0.292016-06-06 12:00 UTC
+  + Chg : A large chunk of boilerplate XS code, which is also used in
+  other XS modules, has been factored out of the main .xs file
+  to a collection of .h files in the xsh subdirectory.
+  + Fix : [RT #112246] : Blead breaks Scope::Upper
+  Dave Mitchell provided a new implementation of reap(),
+  localize_*() and uplevel() to match the new context stack
+  handling in perl 5.24. Many thanks to him.
+
+---

Old:

  Scope-Upper-0.28.tar.gz

New:

  Scope-Upper-0.29.tar.gz



Other differences:
--
++ perl-Scope-Upper.spec ++
--- /var/tmp/diff_new_pack.qb5Imt/_old  2016-06-19 10:48:17.0 +0200
+++ /var/tmp/diff_new_pack.qb5Imt/_new  2016-06-19 10:48:17.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Scope-Upper
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Scope-Upper
-Version:0.28
+Version:0.29
 Release:0
 %define cpan_name Scope-Upper
 Summary:Act on upper scopes
@@ -35,35 +35,19 @@
 This module lets you defer actions _at run-time_ that will take place when
 the control flow returns into an upper scope. Currently, you can:
 
-* *
+  * hook an upper scope end with reap ;
 
-  hook an upper scope end with the /reap manpage ;
+  * localize variables, array/hash values or deletions of elements in higher
+contexts with respectively localize, localize_elem and localize_delete ;
 
-* *
+  * return values immediately to an upper level with unwind, yield and leave ;
 
-  localize variables, array/hash values or deletions of elements in higher
-  contexts with respectively the /localize manpage, the /localize_elem
-  manpage and the /localize_delete manpage ;
+  * gather information about an upper context with want_at and context_info ;
 
-* *
+  * execute a subroutine in the setting of an upper subroutine stack frame with
+uplevel ;
 
-  return values immediately to an upper level with the /unwind manpage, the
-  /yield manpage and the /leave manpage ;
-
-* *
-
-  gather information about an upper context with the /want_at manpage and
-  the /context_info manpage ;
-
-* *
-
-  execute a subroutine in the setting of an upper subroutine stack frame
-  with the /uplevel manpage ;
-
-* *
-
-  uniquely identify contexts with the /uid manpage and the /validate_uid
-  manpage.
+  * uniquely identify contexts with uid and validate_uid.
 
 %prep
 %setup -q -n %{cpan_name}-%{version}

++ Scope-Upper-0.28.tar.gz -> Scope-Upper-0.29.tar.gz ++
 3031 lines of diff (skipped)




commit apcupsd for openSUSE:Factory

2016-06-19 Thread h_root
Hello community,

here is the log from the commit of package apcupsd for openSUSE:Factory checked 
in at 2016-06-19 10:48:36

Comparing /work/SRC/openSUSE:Factory/apcupsd (Old)
 and  /work/SRC/openSUSE:Factory/.apcupsd.new (New)


Package is "apcupsd"

Changes:

--- /work/SRC/openSUSE:Factory/apcupsd/apcupsd.changes  2015-07-14 
17:46:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.apcupsd.new/apcupsd.changes 2016-06-19 
10:48:37.0 +0200
@@ -1,0 +2,31 @@
+Tue May 31 23:09:00 CEST 2016 - manfre...@gmx.ch
+
+- Update to apcupsd version 3.14.14
+  * win32: Fix missing DLLs when installing only apctray
+  * Fixes for socket error handling. Resolves apcaccess crash when connection 
+fails as well as several other theoretical issues.
+  * MODBUS/USB error handling (COMMLOST) improvements for faulty USB links
+  * Fix hiddev binding when usbfs is mounted on /dev/bus/usb instead of 
+/proc/bus/usb. This is necessary for switching between MODBUS/USB and
+USB/HID on Linux.
+  * Update GPLv2 text and FSF address to match current versions from FSF.
+  * Various fixes for potential issues suggested by Coverity Scan
+  * MacOS X port support for El Capitan System Integrity Protection (SIP)
+aka "rootless"
+  * Fix shutdown failure on Windows when UPSNAME includes spaces
+  * Fix building bsd-usb driver
+(This was broken when modbus-usb support was added.)
+  * Add status display for output current as well as apparent power
+- fix firewall rule installation in spec file
+- drop BuildRequires: net-snmp-devel, net-snmp was dropped in favour of 
snmplite
+- drop installation of own automake files for ppc64, not needed any more
+- Removed patches, fixed in upstream:
+  * apcupsd-3.14.6-undef-MIB-for-new-net-snmp.diff
+  * fix-fsf-adress.patch
+  * apcupsd-3.14.1-cloexec.patch
+  * apcupsd-gpp.patch
+- Removed patch, not needed as it builds on all supported arches,
+  and not linking against libstdc++ is done on purpose:
+  * apcupsd-3.14.8-cxxld.patch
+
+---
@@ -14 +45 @@
-- Version bumpt o 3.13.13:
+- Version bump to 3.14.13:

Old:

  apcupsd-3.14.1-cloexec.patch
  apcupsd-3.14.13.tar.gz
  apcupsd-3.14.13.tar.gz.sig
  apcupsd-3.14.6-undef-MIB-for-new-net-snmp.diff
  apcupsd-3.14.8-cxxld.patch
  apcupsd-gpp.patch
  fix-fsf-adress.patch

New:

  apcupsd-3.14.14.tar.gz
  apcupsd-3.14.14.tar.gz.sig



Other differences:
--
++ apcupsd.spec ++
--- /var/tmp/diff_new_pack.1NlWV4/_old  2016-06-19 10:48:38.0 +0200
+++ /var/tmp/diff_new_pack.1NlWV4/_new  2016-06-19 10:48:38.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package apcupsd
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,44 +18,33 @@
 
 %define apache_serverroot %(%{_sbindir}/apxs2 -q datadir 2>/dev/null || 
%{_sbindir}/apxs -q PREFIX)
 Name:   apcupsd
-Version:3.14.13
+Version:3.14.14
 Release:0
 Summary:APC UPS Daemon (Powerful Daemon for APC UPSs)
 License:GPL-2.0
 Group:  Hardware/UPS
 Url:http://www.apcupsd.com/
-Source: 
http://downloads.sourceforge.net/project/apcupsd/apcupsd%%20-%%20Stable/%{version}/apcupsd-%{version}.tar.gz
+Source: 
https://sourceforge.net/projects/apcupsd/files/apcupsd%20-%20Stable/%{version}/apcupsd-%{version}.tar.gz
 Source1:apcupsd.init
 Source2:README.SUSE
 Source4:%{name}.hibernate
 Source5:%{name}.sysconfig
 Source6:%{name}.logrotate
 Source7:apcupsd-httpd.conf
-Source8:
http://downloads.sourceforge.net/project/apcupsd/apcupsd%%20-%%20Stable/%{version}/apcupsd-%{version}.tar.gz.sig
+Source8:
https://sourceforge.net/projects/apcupsd/files/apcupsd%20-%20Stable/%{version}/apcupsd-%{version}.tar.gz.sig
 Source9:%{name}.keyring
 Source10:   %{name}.firewall
 # PATCH-FIX-OPENSUSE apcupsd-suse.patch sbra...@suse.cz -- Do not perform halt 
script alternation on install.
 Patch0: apcupsd-suse.patch
-# PATCH-FIX-OPENSUSE apcupsd-gpp.patch sbra...@suse.cz -- Build against C++ 
unfriendly system tcpd.h. See below.
-Patch1: apcupsd-gpp.patch
 # PATCH-FEATURE-OPENSUSE apcupsd-hibernate.patch sbra...@suse.cz -- Support 
for hibernation on powerfail.
 Patch2: apcupsd-hibernate.patch
-# PATCH-FIX-OPENSUSE apcupsd-3.14.6-undef-MIB-for-new-net-snmp.diff 
se...@opensuse.org -- Fix build with newer net-snmp by undefining MIB.
-Patch9: 

  1   2   >