commit plasma5-workspace for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package plasma5-workspace for 
openSUSE:Factory checked in at 2016-10-06 22:22:12

Comparing /work/SRC/openSUSE:Factory/plasma5-workspace (Old)
 and  /work/SRC/openSUSE:Factory/.plasma5-workspace.new (New)


Package is "plasma5-workspace"

Changes:

--- /work/SRC/openSUSE:Factory/plasma5-workspace/plasma5-workspace.changes  
2016-10-04 15:57:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.plasma5-workspace.new/plasma5-workspace.changes 
2016-10-06 22:22:13.0 +0200
@@ -1,0 +2,12 @@
+Thu Oct  6 17:18:45 UTC 2016 - fab...@ritter-vogt.de
+
+- Add 0001-save-the-containment-only-aftyer-switch.patch:
+  * Without this it would always change back to the folderview
+after login (boo#1003399)
+
+---
+Wed Oct  5 07:58:52 UTC 2016 - fab...@ritter-vogt.de
+
+- Add Source: URL back
+
+---

New:

  0001-save-the-containment-only-aftyer-switch.patch



Other differences:
--
++ plasma5-workspace.spec ++
--- /var/tmp/diff_new_pack.TXRBfj/_old  2016-10-06 22:22:15.0 +0200
+++ /var/tmp/diff_new_pack.TXRBfj/_new  2016-10-06 22:22:15.0 +0200
@@ -27,7 +27,7 @@
 License:GPL-2.0+
 Group:  System/GUI/KDE
 Url:http://www.kde.org/
-Source: plasma-workspace-%{version}.tar.xz
+Source: 
http://download.kde.org/stable/plasma/%{version}/plasma-workspace-%{version}.tar.xz
 Source1:baselibs.conf
 # PATCH-FIX-OPENSUSE 0001-Rename-qdbus-in-startkde.patch cgiboude...@gmx.com 
-- Rename the qdbus executable in startkde
 Patch0: 0001-Rename-qdbus-in-startkde.patch
@@ -38,6 +38,8 @@
 # PATCH-FIX-OPENSUSE add-tray-icon-cache.patch kde#356479 
fab...@ritter-vogt.de -- Workaround for high load due to animated tray icons
 Patch3: add-tray-icon-cache.patch
 # PATCHES 100-200 and above are from upstream 5.8 branch
+# PATCH-FIX-UPSTREAM 0001-save-the-containment-only-aftyer-switch.patch -- Do 
not overwrite containment on startup
+Patch100:   0001-save-the-containment-only-aftyer-switch.patch
 # PATCHES 201-300 and above are from upstream master/5.9 branch
 BuildRequires:  breeze5-icons
 BuildRequires:  fdupes
@@ -208,6 +210,7 @@
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch100 -p1
 
 %build
   %cmake_kf5 -d build -- -DKDE4_COMMON_PAM_SERVICE=xdm 
-DKDE_DEFAULT_HOME=.kde4 -DCMAKE_INSTALL_LOCALEDIR=%{_kf5_localedir}

++ 0001-save-the-containment-only-aftyer-switch.patch ++
>From 53b2a407af9d1d60cfbb1a42af8546ab0a156d38 Mon Sep 17 00:00:00 2001
From: Marco Martin 
Date: Thu, 6 Oct 2016 15:50:05 +0200
Subject: [PATCH] save the containment only aftyer switch

Summary:
during a type switch
if the new containment gets saved before getting a view,
it will get lastScreen=-1 so the next boot
it will create a new containment

Test Plan:
switched repeatedly between desktop and folderview
the config file always got with the correct lastScreen=0 entry

Reviewers: #plasma

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D2966
---
 shell/shellcorona.cpp | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/shell/shellcorona.cpp b/shell/shellcorona.cpp
index 1d08cd1..74f6ded 100644
--- a/shell/shellcorona.cpp
+++ b/shell/shellcorona.cpp
@@ -1562,8 +1562,6 @@ Plasma::Containment 
*ShellCorona::setContainmentTypeForScreen(int screen, const
 newCg.writeEntry("activityId", oldContainment->activity());
 newContainment->restore(newCg);
 
newContainment->updateConstraints(Plasma::Types::StartupCompletedConstraint);
-newContainment->save(newCg);
-requestConfigSync();
 newContainment->flushPendingConstraintsEvents();
 emit containmentAdded(newContainment);
 
@@ -1588,6 +1586,9 @@ Plasma::Containment 
*ShellCorona::setContainmentTypeForScreen(int screen, const
 view->rootObject()->setFocus(true, Qt::MouseFocusReason);
 QTimer::singleShot(2500, oldContainment, ::Applet::destroy);
 
+//Save now as we now have a screen, so lastScreen will not be -1
+newContainment->save(newCg);
+requestConfigSync();
 emit availableScreenRectChanged();
 
 return newContainment;
-- 
2.10.0




commit libqt5-qtwebengine for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package libqt5-qtwebengine for 
openSUSE:Factory checked in at 2016-10-06 16:46:29

Comparing /work/SRC/openSUSE:Factory/libqt5-qtwebengine (Old)
 and  /work/SRC/openSUSE:Factory/.libqt5-qtwebengine.new (New)


Package is "libqt5-qtwebengine"

Changes:

--- /work/SRC/openSUSE:Factory/libqt5-qtwebengine/libqt5-qtwebengine.changes
2016-10-06 12:28:28.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.libqt5-qtwebengine.new/libqt5-qtwebengine.changes   
2016-10-06 16:46:30.0 +0200
@@ -1,0 +2,6 @@
+Thu Oct  6 09:26:52 UTC 2016 - hrvoje.sen...@gmail.com
+
+- Pass the -fno-delete-null-pointer-checks flag to avoid further
+  gcc6 issues
+
+---



Other differences:
--
++ libqt5-qtwebengine.spec ++
--- /var/tmp/diff_new_pack.5n3Iqw/_old  2016-10-06 16:46:36.0 +0200
+++ /var/tmp/diff_new_pack.5n3Iqw/_new  2016-10-06 16:46:36.0 +0200
@@ -233,8 +233,8 @@
 build/linux/unbundle/replace_gyp_files.py $myconf
 popd
 
+RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fno-delete-null-pointer-checks"
 %ifnarch x86_64
-RPM_OPT_FLAGS="$RPM_OPT_FLAGS "
 export RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-g / }
 %endif
 %qmake5 QMAKE_CFLAGS="$RPM_OPT_FLAGS" \




commit plasma5-openSUSE for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package plasma5-openSUSE for 
openSUSE:Factory checked in at 2016-10-06 16:36:49

Comparing /work/SRC/openSUSE:Factory/plasma5-openSUSE (Old)
 and  /work/SRC/openSUSE:Factory/.plasma5-openSUSE.new (New)


Package is "plasma5-openSUSE"

Changes:

--- /work/SRC/openSUSE:Factory/plasma5-openSUSE/plasma5-openSUSE.changes
2016-10-04 15:56:54.0 +0200
+++ /work/SRC/openSUSE:Factory/.plasma5-openSUSE.new/plasma5-openSUSE.changes   
2016-10-06 16:36:49.0 +0200
@@ -1,0 +2,5 @@
+Thu Oct  6 07:15:27 UTC 2016 - fab...@ritter-vogt.de
+
+- Use a constant Version: 42.1.1 everywhere to allow upgrades
+
+---



Other differences:
--
++ plasma5-openSUSE.spec ++
--- /var/tmp/diff_new_pack.aJwiqI/_old  2016-10-06 16:36:50.0 +0200
+++ /var/tmp/diff_new_pack.aJwiqI/_new  2016-10-06 16:36:50.0 +0200
@@ -16,13 +16,9 @@
 #
 
 %define plasma_version 5.8.0
-%if 0%{?suse_version} == 1315 && 0%{?is_opensuse}
-%define suse_branding_version 42.1
-%else
-%define suse_branding_version 13.3
-%endif
+
 Name:   plasma5-openSUSE
-Version:%{suse_branding_version}.1
+Version:42.1.1
 Release:0
 Summary:openSUSE KDE Extension
 License:GPL-2.0+





commit timezone for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package timezone for openSUSE:Factory 
checked in at 2016-10-06 14:32:28

Comparing /work/SRC/openSUSE:Factory/timezone (Old)
 and  /work/SRC/openSUSE:Factory/.timezone.new (New)


Package is "timezone"

Changes:

--- /work/SRC/openSUSE:Factory/timezone/timezone-java.changes   2016-09-21 
18:24:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.timezone.new/timezone-java.changes  
2016-10-06 14:32:28.0 +0200
@@ -2,33 +1,0 @@
-Fri Sep 16 12:08:42 UTC 2016 - astie...@suse.com
-
-- timezone update 2016g:
-  * Turkey will remain on UTC+03 after 2016-10-30 bsc#997830
-  * New leap second 2016-12-31 23:59:60 UTC 
-Remove 0001-Positive-leap-second-on-2016-12-31.patch
-  * Corrections for past DST transitions
-  * Antarcica and nautical time zones now use numeric time zone
-abbreviations instead of obsolete alphanumeric ones
-  * Renamed Asia/Rangoon to Asia/Yangon
-  * The following change was previously patched in the package
-and is now upstream:
-+ If the installed localtime and/or posixrules files are
-  symbolic links, zic now keeps them symbolic links when
-  updating them, for compatibility with platforms like
-  OpenSUSE where other programs configure these files as
-  symlinks.
-+ zic now avoids hard linking to symbolic links, avoids
-  some unnecessary mkdir and stat system calls, and uses
-  shorter file names internally.
-+ Drop the patches:
-  tzcode-fromname.patch
-  tzcode-link.diff
-  tzcode-revert-01-8c9cb9580.patch
-  tzcode-revert-02-301f794f3.patch
-  tzcode-revert-03-39fd078a6.patch
-  tzcode-symlink.patch
-  tzcode-zic.diff
-  * zdump has a new -i option to generate transitions in a
-more-compact but still human-readable format. (experimental)
-- Drop upstream signatures and keyring, tarball generated from git
-

timezone.changes: same change

Old:

  tzcode2016g.tar.gz
  tzdata2016g.tar.gz

New:

  0001-Positive-leap-second-on-2016-12-31.patch
  timezone.keyring
  tzcode-fromname.patch
  tzcode-link.diff
  tzcode-revert-01-8c9cb9580.patch
  tzcode-revert-02-301f794f3.patch
  tzcode-revert-03-39fd078a6.patch
  tzcode-symlink.patch
  tzcode-zic.diff
  tzcode2016f.tar.gz
  tzcode2016f.tar.gz.asc
  tzdata2016f.tar.gz
  tzdata2016f.tar.gz.asc



Other differences:
--
++ timezone-java.spec ++
--- /var/tmp/diff_new_pack.3LFw5D/_old  2016-10-06 14:32:29.0 +0200
+++ /var/tmp/diff_new_pack.3LFw5D/_new  2016-10-06 14:32:29.0 +0200
@@ -25,12 +25,26 @@
 Group:  System/Base
 # COMMON-BEGIN
 # COMMON-BEGIN
-Version:2016g
+Version:2016f
 Release:0
-Source: tzdata%{version}.tar.gz
-Source1:tzcode%{version}.tar.gz
+Source: ftp://ftp.iana.org/tz/releases/tzdata%{version}.tar.gz
+Source1:ftp://ftp.iana.org/tz/releases/tzcode%{version}.tar.gz
+Source2:ftp://ftp.iana.org/tz/releases/tzdata%{version}.tar.gz.asc
+Source3:ftp://ftp.iana.org/tz/releases/tzcode%{version}.tar.gz.asc
+# http://sks.mrball.net/pks/lookup?op=get=0xED97E90E62AA7E34
+Source4:timezone.keyring
+Patch100:   tzcode-revert-01-8c9cb9580.patch
+Patch101:   tzcode-revert-02-301f794f3.patch
+Patch102:   tzcode-revert-03-39fd078a6.patch
 Patch0: tzdata-china.diff
+Patch1: tzcode-zic.diff
+# PATCH-FIX-OPENSUSE bnc#845530
+Patch2: tzcode-fromname.patch
 Patch3: iso3166-uk.diff
+Patch4: tzcode-link.diff
+Patch5: tzcode-symlink.patch
+# PATCH-FIX-UPSTREAM 0001-Positive-leap-second-on-2016-12-31.patch bsc#988184
+Patch6: 0001-Positive-leap-second-on-2016-12-31.patch
 # COMMON-END
 # COMMON-END
 Url:http://www.gnu.org/software/libc/libc.html
@@ -50,8 +64,19 @@
 %setup -c  -a 1
 # COMMON-PREP-BEGIN
 # COMMON-PREP-BEGIN
+%patch100 -p1 -R
+%patch101 -p1 -R
+%patch102 -p1 -R
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 %patch3 -p1
+%if 0%{?suse_version} < 1220
+%patch4 -p1
+%else
+%patch5 -p1
+%endif
+%patch6 -p1
 sed -ri 's@/usr/local/etc/zoneinfo@%{_datadir}/zoneinfo@g' *.[1358]
 # COMMON-PREP-END
 # COMMON-PREP-END

++ timezone.spec ++
--- /var/tmp/diff_new_pack.3LFw5D/_old  2016-10-06 14:32:29.0 +0200
+++ /var/tmp/diff_new_pack.3LFw5D/_new  2016-10-06 14:32:29.0 +0200
@@ -23,12 +23,26 @@
 Url:http://www.iana.org/time-zones
 PreReq: filesystem, coreutils
 # COMMON-BEGIN
-Version:2016g
+Version:2016f
 Release:0
-Source: tzdata%{version}.tar.gz
-Source1:tzcode%{version}.tar.gz
+Source: 

commit kdevplatform4 for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package kdevplatform4 for openSUSE:Factory 
checked in at 2016-10-06 12:48:14

Comparing /work/SRC/openSUSE:Factory/kdevplatform4 (Old)
 and  /work/SRC/openSUSE:Factory/.kdevplatform4.new (New)


Package is "kdevplatform4"

Changes:

--- /work/SRC/openSUSE:Factory/kdevplatform4/kdevplatform4.changes  
2016-09-30 15:28:10.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdevplatform4.new/kdevplatform4.changes 
2016-10-06 12:48:18.0 +0200
@@ -1,0 +2,6 @@
+Sat Aug 27 10:19:25 UTC 2016 - wba...@tmo.at
+
+- Obsolete kdevplatform and kdevplatform-lang (KDE4 based) after
+  the rename to ease updates
+
+---



Other differences:
--
++ kdevplatform4.spec ++
--- /var/tmp/diff_new_pack.DgvoZx/_old  2016-10-06 12:48:19.0 +0200
+++ /var/tmp/diff_new_pack.DgvoZx/_new  2016-10-06 12:48:19.0 +0200
@@ -40,6 +40,8 @@
 #BuildRequires:  kompare - currently disabled upstream, see toplevel 
CMakeLists.txt
 Requires:   %{name}-lang = %{version}
 Requires:   libkdevplatform%{libkdev_major} = %{version}
+Obsoletes:  kdevplatform <= %{version}
+Obsoletes:  kdevplatform-lang <= %{version}
 BuildRoot:  %{_tmppath}/%{rname}-%{version}-build
 %kde4_runtime_requires
 




commit tryton for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package tryton for openSUSE:Factory checked 
in at 2016-10-06 12:48:06

Comparing /work/SRC/openSUSE:Factory/tryton (Old)
 and  /work/SRC/openSUSE:Factory/.tryton.new (New)


Package is "tryton"

Changes:

--- /work/SRC/openSUSE:Factory/tryton/tryton.changes2016-09-23 
11:32:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.tryton.new/tryton.changes   2016-10-06 
12:48:06.0 +0200
@@ -1,0 +2,5 @@
+Mon Oct  3 08:49:08 UTC 2016 - axel.br...@gmx.de
+
+- version 3.8.10
+
+---

Old:

  tryton-3.8.9.tar.gz

New:

  tryton-3.8.10.tar.gz



Other differences:
--
++ tryton.spec ++
--- /var/tmp/diff_new_pack.rYp2Gz/_old  2016-10-06 12:48:08.0 +0200
+++ /var/tmp/diff_new_pack.rYp2Gz/_new  2016-10-06 12:48:08.0 +0200
@@ -19,7 +19,7 @@
 
 %define majorver 3.8
 Name:   tryton
-Version:%{majorver}.9
+Version:%{majorver}.10
 Release:0
 Summary:The client of the Tryton application platform
 License:GPL-3.0

++ tryton-3.8.9.tar.gz -> tryton-3.8.10.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tryton-3.8.9/CHANGELOG new/tryton-3.8.10/CHANGELOG
--- old/tryton-3.8.9/CHANGELOG  2016-09-03 11:57:46.0 +0200
+++ new/tryton-3.8.10/CHANGELOG 2016-10-02 21:09:35.0 +0200
@@ -1,3 +1,6 @@
+Version 3.8.10 - 2016-10-02
+* Bug fixes (see mercurial logs for details)
+
 Version 3.8.9 - 2016-09-03
 * Bug fixes (see mercurial logs for details)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tryton-3.8.9/PKG-INFO new/tryton-3.8.10/PKG-INFO
--- old/tryton-3.8.9/PKG-INFO   2016-09-03 11:57:56.0 +0200
+++ new/tryton-3.8.10/PKG-INFO  2016-10-02 21:09:45.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: tryton
-Version: 3.8.9
+Version: 3.8.10
 Summary: Tryton client
 Home-page: http://www.tryton.org/
 Author: Tryton
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tryton-3.8.9/tryton/__init__.py 
new/tryton-3.8.10/tryton/__init__.py
--- old/tryton-3.8.9/tryton/__init__.py 2016-08-02 21:59:43.0 +0200
+++ new/tryton-3.8.10/tryton/__init__.py2016-09-03 11:58:23.0 
+0200
@@ -1,3 +1,3 @@
 # This file is part of Tryton.  The COPYRIGHT file at the top level of
 # this repository contains the full copyright notices and license terms.
-__version__ = "3.8.9"
+__version__ = "3.8.10"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tryton-3.8.9/tryton/common/common.py 
new/tryton-3.8.10/tryton/common/common.py
--- old/tryton-3.8.9/tryton/common/common.py2016-05-10 23:45:48.0 
+0200
+++ new/tryton-3.8.10/tryton/common/common.py   2016-10-02 21:09:00.0 
+0200
@@ -466,13 +466,19 @@
 win.set_preview_widget(img_preview)
 win.connect('update-preview', update_preview_cb, img_preview)
 
+if os.name == 'nt':
+encoding = 'utf-8'
+else:
+encoding = sys.getfilesystemencoding()
 button = win.run()
 if button != gtk.RESPONSE_OK:
-result = False
+result = None
 elif not multi:
 result = win.get_filename()
+if result:
+result = unicode(result, encoding)
 else:
-result = win.get_filenames()
+result = [unicode(path, encoding) for path in win.get_filenames()]
 parent.present()
 win.destroy()
 return result
Files old/tryton-3.8.9/tryton/data/locale/bg_BG/LC_MESSAGES/tryton.mo and 
new/tryton-3.8.10/tryton/data/locale/bg_BG/LC_MESSAGES/tryton.mo differ
Files old/tryton-3.8.9/tryton/data/locale/ca_ES/LC_MESSAGES/tryton.mo and 
new/tryton-3.8.10/tryton/data/locale/ca_ES/LC_MESSAGES/tryton.mo differ
Files old/tryton-3.8.9/tryton/data/locale/cs_CZ/LC_MESSAGES/tryton.mo and 
new/tryton-3.8.10/tryton/data/locale/cs_CZ/LC_MESSAGES/tryton.mo differ
Files old/tryton-3.8.9/tryton/data/locale/de_DE/LC_MESSAGES/tryton.mo and 
new/tryton-3.8.10/tryton/data/locale/de_DE/LC_MESSAGES/tryton.mo differ
Files old/tryton-3.8.9/tryton/data/locale/es_AR/LC_MESSAGES/tryton.mo and 
new/tryton-3.8.10/tryton/data/locale/es_AR/LC_MESSAGES/tryton.mo differ
Files old/tryton-3.8.9/tryton/data/locale/es_CO/LC_MESSAGES/tryton.mo and 
new/tryton-3.8.10/tryton/data/locale/es_CO/LC_MESSAGES/tryton.mo differ
Files old/tryton-3.8.9/tryton/data/locale/es_EC/LC_MESSAGES/tryton.mo and 
new/tryton-3.8.10/tryton/data/locale/es_EC/LC_MESSAGES/tryton.mo differ
Files old/tryton-3.8.9/tryton/data/locale/es_ES/LC_MESSAGES/tryton.mo and 

commit trytond_account for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package trytond_account for openSUSE:Factory 
checked in at 2016-10-06 12:48:11

Comparing /work/SRC/openSUSE:Factory/trytond_account (Old)
 and  /work/SRC/openSUSE:Factory/.trytond_account.new (New)


Package is "trytond_account"

Changes:

--- /work/SRC/openSUSE:Factory/trytond_account/trytond_account.changes  
2016-09-23 11:31:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.trytond_account.new/trytond_account.changes 
2016-10-06 12:48:12.0 +0200
@@ -1,0 +2,5 @@
+Tue Oct  4 19:15:14 UTC 2016 - axel.br...@gmx.de
+
+- version 3.8.4
+
+---

Old:

  trytond_account-3.8.3.tar.gz

New:

  trytond_account-3.8.4.tar.gz



Other differences:
--
++ trytond_account.spec ++
--- /var/tmp/diff_new_pack.oekEWQ/_old  2016-10-06 12:48:13.0 +0200
+++ /var/tmp/diff_new_pack.oekEWQ/_new  2016-10-06 12:48:13.0 +0200
@@ -19,16 +19,16 @@
 
 %define majorver 3.8
 Name:   trytond_account
-Version:%{majorver}.3
+Version:%{majorver}.4
 Release:0
 Summary:The "account" module for the Tryton ERP system
 License:GPL-3.0+
 Group:  Productivity/Office/Management
 Url:http://www.tryton.org/
 Source: 
http://downloads.tryton.org/%{majorver}/%{name}-%{version}.tar.gz
+BuildRequires:  fdupes
 BuildRequires:  python-devel
 BuildRequires:  python-setuptools
-BuildRequires:  fdupes
 Requires:   trytond
 Requires:   trytond_company
 Requires:   trytond_currency

++ trytond_account-3.8.3.tar.gz -> trytond_account-3.8.4.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trytond_account-3.8.3/CHANGELOG 
new/trytond_account-3.8.4/CHANGELOG
--- old/trytond_account-3.8.3/CHANGELOG 2016-09-03 12:58:42.0 +0200
+++ new/trytond_account-3.8.4/CHANGELOG 2016-10-02 21:34:18.0 +0200
@@ -1,3 +1,6 @@
+Version 3.8.4 - 2016-10-02
+* Bug fixes (see mercurial logs for details)
+
 Version 3.8.3 - 2016-09-03
 * Bug fixes (see mercurial logs for details)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trytond_account-3.8.3/PKG-INFO 
new/trytond_account-3.8.4/PKG-INFO
--- old/trytond_account-3.8.3/PKG-INFO  2016-09-03 12:58:54.0 +0200
+++ new/trytond_account-3.8.4/PKG-INFO  2016-10-02 21:34:29.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: trytond_account
-Version: 3.8.3
+Version: 3.8.4
 Summary: Tryton module for accounting
 Home-page: http://www.tryton.org/
 Author: Tryton
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trytond_account-3.8.3/party.py 
new/trytond_account-3.8.4/party.py
--- old/trytond_account-3.8.3/party.py  2016-09-03 12:58:24.0 +0200
+++ new/trytond_account-3.8.4/party.py  2016-10-02 21:34:01.0 +0200
@@ -2,7 +2,7 @@
 # this repository contains the full copyright notices and license terms.
 from decimal import Decimal
 
-from sql import Literal, Null
+from sql import Literal, Null, Cast
 from sql.aggregate import Sum
 from sql.conditionals import Coalesce
 
@@ -146,9 +146,14 @@
 today_query = ((line.maturity_date <= Date.today())
 | (line.maturity_date == Null))
 
-line_query, _ = MoveLine.query_get(line)
 Operator = fields.SQL_OPERATORS[clause[1]]
 
+# Need to cast numeric for sqlite
+type_ = MoveLine.debit.sql_type().base
+amount = Cast(
+Sum(Coalesce(line.debit, 0) - Coalesce(line.credit, 0)),
+type_)
+value = Cast(Literal(Decimal(clause[2] or 0)), type_)
 query = line.join(account, condition=account.id == line.account
 ).select(line.party,
 where=account.active
@@ -156,9 +161,7 @@
 & (line.party != Null)
 & (line.reconciliation == Null)
 & (account.company == company_id)
-& line_query & today_query,
+& today_query,
 group_by=line.party,
-having=Operator(Sum(Coalesce(line.debit, 0)
-- Coalesce(line.credit, 0)),
-Decimal(clause[2] or 0)))
+having=Operator(amount, value))
 return [('id', 'in', query)]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trytond_account-3.8.3/tryton.cfg 
new/trytond_account-3.8.4/tryton.cfg
--- old/trytond_account-3.8.3/tryton.cfg2016-07-05 23:14:02.0 
+0200
+++ new/trytond_account-3.8.4/tryton.cfg

commit aqbanking for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package aqbanking for openSUSE:Factory 
checked in at 2016-10-06 12:47:56

Comparing /work/SRC/openSUSE:Factory/aqbanking (Old)
 and  /work/SRC/openSUSE:Factory/.aqbanking.new (New)


Package is "aqbanking"

Changes:

--- /work/SRC/openSUSE:Factory/aqbanking/aqbanking.changes  2016-09-12 
13:27:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.aqbanking.new/aqbanking.changes 2016-10-06 
12:47:56.0 +0200
@@ -1,0 +2,6 @@
+Tue Oct  4 09:19:21 UTC 2016 - jcnen...@gmail.com
+
+- Update to 5.7.2beta
+  + Fix crash receiving account list
+
+---

Old:

  aqbanking-5.7.1beta.tar.gz

New:

  aqbanking-5.7.2beta.tar.gz



Other differences:
--
++ aqbanking.spec ++
--- /var/tmp/diff_new_pack.3l3wL9/_old  2016-10-06 12:47:57.0 +0200
+++ /var/tmp/diff_new_pack.3l3wL9/_new  2016-10-06 12:47:57.0 +0200
@@ -26,7 +26,7 @@
 %define  q4b_cfgmoddir  %{fronts_libdir}/q4banking/cfgmodules
 
 Name:   aqbanking
-Version:5.7.1beta
+Version:5.7.2beta
 Release:0
 Summary:Library for Online Banking Functions and Financial Data Import 
and Export
 License:GPL-2.0 or GPL-3.0

++ aqbanking-5.7.1beta.tar.gz -> aqbanking-5.7.2beta.tar.gz ++
 8704 lines of diff (skipped)




commit psi+ for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package psi+ for openSUSE:Factory checked in 
at 2016-10-06 12:46:23

Comparing /work/SRC/openSUSE:Factory/psi+ (Old)
 and  /work/SRC/openSUSE:Factory/.psi+.new (New)


Package is "psi+"

Changes:

--- /work/SRC/openSUSE:Factory/psi+/psi+.changes2016-08-03 
11:44:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.psi+.new/psi+.changes   2016-10-06 
12:46:24.0 +0200
@@ -1,0 +2,7 @@
+Tue Oct  4 15:06:01 UTC 2016 - jsl...@suse.com
+
+- update to 20161003
+  * updated translations
+  * some bugfixes
+
+---

Old:

  psi+-20160727.tar.xz

New:

  psi+-20161003.tar.xz



Other differences:
--
++ psi+.spec ++
--- /var/tmp/diff_new_pack.NwnTIs/_old  2016-10-06 12:46:26.0 +0200
+++ /var/tmp/diff_new_pack.NwnTIs/_new  2016-10-06 12:46:26.0 +0200
@@ -20,11 +20,11 @@
 %define with_qt5 1
 %endif
 
-%define version_unconverted 20160727
+%define version_unconverted 20161003
 
 Name:   psi+
 Url:https://github.com/psi-plus
-Version:20160727
+Version:20161003
 Release:0
 Summary:Jabber client using Qt
 License:GPL-2.0+

++ psi+-20160727.tar.xz -> psi+-20161003.tar.xz ++
/work/SRC/openSUSE:Factory/psi+/psi+-20160727.tar.xz 
/work/SRC/openSUSE:Factory/.psi+.new/psi+-20161003.tar.xz differ: char 26, line 
1

++ psi-plus-l10n-1.tar.xz ++
 13112 lines of diff (skipped)




commit perl-Future for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package perl-Future for openSUSE:Factory 
checked in at 2016-10-06 12:46:28

Comparing /work/SRC/openSUSE:Factory/perl-Future (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Future.new (New)


Package is "perl-Future"

Changes:

--- /work/SRC/openSUSE:Factory/perl-Future/perl-Future.changes  2015-08-02 
22:46:24.0 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Future.new/perl-Future.changes 
2016-10-06 12:46:28.0 +0200
@@ -1,0 +2,15 @@
+Mon Oct  3 05:27:35 UTC 2016 - co...@suse.com
+
+- updated to 0.34
+   see /usr/share/doc/packages/perl-Future/Changes
+
+  0.342016/10/02 18:40:06
+  [CHANGES]
+   * Added Future::Mutex
+   * Minor documentation wording fixes (thanks ilmari)
+  
+  [BUGFIXES]
+   * Fallback to 'configure_requires' for older versions of
+ Module::Build that don't support 'test_requires' (RT110721)
+
+---

Old:

  Future-0.33.tar.gz

New:

  Future-0.34.tar.gz



Other differences:
--
++ perl-Future.spec ++
--- /var/tmp/diff_new_pack.Arkho3/_old  2016-10-06 12:46:30.0 +0200
+++ /var/tmp/diff_new_pack.Arkho3/_new  2016-10-06 12:46:30.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Future
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Future
-Version:0.33
+Version:0.34
 Release:0
 %define cpan_name Future
 Summary:Represent an Operation Awaiting Completion
@@ -31,7 +31,7 @@
 BuildRequires:  perl
 BuildRequires:  perl-macros
 BuildRequires:  perl(Carp) >= 1.25
-BuildRequires:  perl(Module::Build) >= 0.400400
+BuildRequires:  perl(Module::Build)
 BuildRequires:  perl(Test::Fatal)
 BuildRequires:  perl(Test::Identity)
 BuildRequires:  perl(Test::More) >= 0.88
@@ -68,8 +68,8 @@
 forward-reading manner, and simplifies many common patterns that are often
 involved in such situations.
 
-See also the Future::Utils manpage which contains useful loop-constructing
-functions, to run a future-returning function repeatedly in a loop.
+See also Future::Utils which contains useful loop-constructing functions,
+to run a future-returning function repeatedly in a loop.
 
 Unless otherwise noted, the following methods require at least version
 _0.08_.

++ Future-0.33.tar.gz -> Future-0.34.tar.gz ++
 2026 lines of diff (skipped)




commit gnome-calendar for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package gnome-calendar for openSUSE:Factory 
checked in at 2016-10-06 12:46:15

Comparing /work/SRC/openSUSE:Factory/gnome-calendar (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-calendar.new (New)


Package is "gnome-calendar"

Changes:

--- /work/SRC/openSUSE:Factory/gnome-calendar/gnome-calendar.changes
2016-09-23 11:37:03.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-calendar.new/gnome-calendar.changes   
2016-10-06 12:46:16.0 +0200
@@ -1,0 +2,10 @@
+Sun Oct  2 07:34:33 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.22.1:
+  + Ablility to change months/years through mouse and touchpad
+scroll.
+  + A huge number of bugfixes.
+  + Many memory leaks were fixed.
+  + Updated translations.
+
+---

Old:

  gnome-calendar-3.22.0.tar.xz

New:

  gnome-calendar-3.22.1.tar.xz



Other differences:
--
++ gnome-calendar.spec ++
--- /var/tmp/diff_new_pack.lsr1NL/_old  2016-10-06 12:46:17.0 +0200
+++ /var/tmp/diff_new_pack.lsr1NL/_new  2016-10-06 12:46:17.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-calendar
-Version:3.22.0
+Version:3.22.1
 Release:0
 Summary:A calendar application for GNOME
 License:GPL-3.0+

++ gnome-calendar-3.22.0.tar.xz -> gnome-calendar-3.22.1.tar.xz ++
 5512 lines of diff (skipped)




commit DisplayCAL for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package DisplayCAL for openSUSE:Factory 
checked in at 2016-10-06 12:45:52

Comparing /work/SRC/openSUSE:Factory/DisplayCAL (Old)
 and  /work/SRC/openSUSE:Factory/.DisplayCAL.new (New)


Package is "DisplayCAL"

Changes:

--- /work/SRC/openSUSE:Factory/DisplayCAL/DisplayCAL.changes2016-08-29 
15:44:39.0 +0200
+++ /work/SRC/openSUSE:Factory/.DisplayCAL.new/DisplayCAL.changes   
2016-10-06 12:45:53.0 +0200
@@ -1,0 +2,5 @@
+Tue Oct 04 20:50:59 UTC 2016 - flor...@displaycal.net
+
+- update to 3.1.7.0: see README.html#changelog-3.1.7
+
+---

Old:

  DisplayCAL-3.1.6.0.tar.gz

New:

  DisplayCAL-3.1.7.0.tar.gz



Other differences:
--
++ DisplayCAL.spec ++
--- /var/tmp/diff_new_pack.xUhzOa/_old  2016-10-06 12:45:55.0 +0200
+++ /var/tmp/diff_new_pack.xUhzOa/_new  2016-10-06 12:45:55.0 +0200
@@ -40,10 +40,10 @@
 License:GPL-3.0+
 Group:  %{correct_group}
 Name:   DisplayCAL
-Version:3.1.6.0
+Version:3.1.7.0
 Release:0
 Source0:http://displaycal.net/download/%{name}-%version.tar.gz
-Url:http://displaycal.net/
+Url:https://displaycal.net/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires:   p7zip
 Obsoletes:  DisplayCAL-0install

++ DisplayCAL-3.1.6.0.tar.gz -> DisplayCAL-3.1.7.0.tar.gz ++
/work/SRC/openSUSE:Factory/DisplayCAL/DisplayCAL-3.1.6.0.tar.gz 
/work/SRC/openSUSE:Factory/.DisplayCAL.new/DisplayCAL-3.1.7.0.tar.gz differ: 
char 5, line 1

++ debian.changelog ++
--- /var/tmp/diff_new_pack.xUhzOa/_old  2016-10-06 12:45:55.0 +0200
+++ /var/tmp/diff_new_pack.xUhzOa/_new  2016-10-06 12:45:55.0 +0200
@@ -1,5 +1,5 @@
-displaycal (3.1.6.0-1) stable; urgency=low
+displaycal (3.1.7.0-1) stable; urgency=low
 
-  * Version 3.1.6.0
+  * Version 3.1.7.0
 
- -- Florian Höch   Wed, 24 Aug 2016 21:06:27 +0100
+ -- Florian Höch   Tue, 04 Oct 2016 20:50:59 +

++ debian.copyright ++
--- /var/tmp/diff_new_pack.xUhzOa/_old  2016-10-06 12:45:55.0 +0200
+++ /var/tmp/diff_new_pack.xUhzOa/_new  2016-10-06 12:45:55.0 +0200
@@ -1,7 +1,7 @@
 Format-Specification: 
http://svn.debian.org/wsvn/dep/web/deps/dep5.mdwn?op=file=135
 Name: DisplayCAL
 Maintainer: Florian Höch 
-Source: http://displaycal.net/
+Source: https://displaycal.net/
 
 Copyright: 2008-2016, Florian Höch 
 License: GPL-3+




commit kdevelop5-plugin-python3 for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package kdevelop5-plugin-python3 for 
openSUSE:Factory checked in at 2016-10-06 12:46:05

Comparing /work/SRC/openSUSE:Factory/kdevelop5-plugin-python3 (Old)
 and  /work/SRC/openSUSE:Factory/.kdevelop5-plugin-python3.new (New)


Package is "kdevelop5-plugin-python3"

Changes:

--- 
/work/SRC/openSUSE:Factory/kdevelop5-plugin-python3/kdevelop5-plugin-python3.changes
2016-10-02 00:07:29.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.kdevelop5-plugin-python3.new/kdevelop5-plugin-python3.changes
   2016-10-06 12:46:06.0 +0200
@@ -1,0 +2,12 @@
+Tue Oct  4 12:55:32 UTC 2016 - lbeltr...@kde.org
+
+- Add QtConcurrent to BuildRequires
+
+---
+Mon Oct  3 22:25:48 UTC 2016 - lbeltr...@kde.org
+
+- New upstream release 5.0.1
+  * Fix imports sometimes not being found in kdev-python without
+pressing F5 by hand  
+
+---

Old:

  kdev-python-5.0.tar.xz

New:

  kdev-python-5.0.1.tar.xz



Other differences:
--
++ kdevelop5-plugin-python3.spec ++
--- /var/tmp/diff_new_pack.16w3Ss/_old  2016-10-06 12:46:08.0 +0200
+++ /var/tmp/diff_new_pack.16w3Ss/_new  2016-10-06 12:46:08.0 +0200
@@ -19,27 +19,36 @@
 %define rname kdev-python
 %define rversion 5.0
 Name:   kdevelop5-plugin-python3
-Version:5.0.0
+Version:5.0.1
 Release:0
 Summary:Python support for KDevelop
 License:GPL-2.0+
 Group:  Development/Tools/IDE
 Url:http://www.kdevelop.org
-Source0:
http://download.kde.org/stable/kdevelop/%{version}/src/%{rname}-%{rversion}.tar.xz
+Source0:%{rname}-%{version}.tar.xz
 BuildRequires:  extra-cmake-modules
 BuildRequires:  fdupes
+BuildRequires:  grantlee5-devel
+BuildRequires:  karchive-devel
 BuildRequires:  kcmutils-devel
 BuildRequires:  kdevelop5 >= 5.0.0
 BuildRequires:  kdevplatform-devel >= 5.0.0
 BuildRequires:  kf5-filesystem
+BuildRequires:  kguiaddons-devel
 BuildRequires:  ki18n-devel
+BuildRequires:  kiconthemes-devel
 BuildRequires:  kitemmodels-devel
 BuildRequires:  knewstuff-devel
+BuildRequires:  knotifications-devel
+BuildRequires:  knotifyconfig-devel
 BuildRequires:  ktexteditor-devel
+BuildRequires:  kwindowsystem-devel
 BuildRequires:  pkgconfig
 BuildRequires:  python3 >= 3.5.0
 BuildRequires:  python3-devel >= 3.5.0
 BuildRequires:  threadweaver-devel
+BuildRequires:  pkgconfig(Qt5Concurrent) >= 5.2.0
+BuildRequires:  pkgconfig(Qt5Quick) >= 5.2.0
 BuildRequires:  pkgconfig(Qt5Test) >= 5.2.0
 BuildRequires:  pkgconfig(Qt5Widgets) >= 5.2.0
 Requires:   kdevelop5
@@ -69,7 +78,7 @@
 Provides translations to the package %{name}
 
 %prep
-%setup -q -n %{rname}-%{rversion}
+%setup -q -n %{rname}-%{version}
 
 %build
   %cmake_kf5 -d build

++ kdev-python-5.0.tar.xz -> kdev-python-5.0.1.tar.xz ++
 2651 lines of diff (skipped)




commit qmmp for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package qmmp for openSUSE:Factory checked in 
at 2016-10-06 12:45:58

Comparing /work/SRC/openSUSE:Factory/qmmp (Old)
 and  /work/SRC/openSUSE:Factory/.qmmp.new (New)


Package is "qmmp"

Changes:

--- /work/SRC/openSUSE:Factory/qmmp/qmmp.changes2016-08-28 
12:18:13.0 +0200
+++ /work/SRC/openSUSE:Factory/.qmmp.new/qmmp.changes   2016-10-06 
12:45:59.0 +0200
@@ -1,0 +2,8 @@
+Wed Oct  5 21:51:07 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 1.1.4:
+  * Fix support of skins UTF-16 with encoded pledit.txt.
+  * Fix 'index out of range' warning.
+  * Fix typo in the qsui plugin.
+
+---

Old:

  qmmp-1.1.3.tar.bz2

New:

  qmmp-1.1.4.tar.bz2



Other differences:
--
++ qmmp.spec ++
--- /var/tmp/diff_new_pack.spTdf9/_old  2016-10-06 12:46:00.0 +0200
+++ /var/tmp/diff_new_pack.spTdf9/_new  2016-10-06 12:46:00.0 +0200
@@ -21,7 +21,7 @@
 %bcond_with mad
 %bcond_with restricted
 Name:   qmmp
-Version:1.1.3
+Version:1.1.4
 Release:0
 Summary:Qt-based Multimedia Player
 License:GPL-2.0+

++ qmmp-1.1.3.tar.bz2 -> qmmp-1.1.4.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/qmmp-1.1.3/ChangeLog new/qmmp-1.1.4/ChangeLog
--- old/qmmp-1.1.3/ChangeLog2016-08-26 13:36:55.0 +0200
+++ new/qmmp-1.1.4/ChangeLog2016-10-04 11:49:54.0 +0200
@@ -1211,3 +1211,8 @@
 * fixed librcc database path in the portable mode
 * updated Brazilian Portuguese translation (Vitor Pereira)
 * updated German translation (Ettore Atalan)
+
+Version 1.1.4
+* fixed support of skins UTF-16 with encoded pledit.txt
+* fixed 'index out of range' warning
+* fixed typo in the qsui plugin
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/qmmp-1.1.3/ChangeLog.rus new/qmmp-1.1.4/ChangeLog.rus
--- old/qmmp-1.1.3/ChangeLog.rus2016-08-26 13:36:55.0 +0200
+++ new/qmmp-1.1.4/ChangeLog.rus2016-10-04 11:49:54.0 +0200
@@ -1213,3 +1213,8 @@
 * исправлен путь к кэшу librcc для переносимого режима
 * обновлён бразильский португальский перевод (Vitor Pereira)
 * обновлён немецкий перевод (Ettore Atalan)
+
+Версия 1.1.4
+* исправлена поддержка обложек с файлом pledit.txt в кодировке UTF-16
+* исправлено предупреждение 'index out of range'
+* исправлена опечатка в интерфейсе qsui
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/qmmp-1.1.3/ChangeLog.svn new/qmmp-1.1.4/ChangeLog.svn
--- old/qmmp-1.1.3/ChangeLog.svn2016-08-26 13:36:55.0 +0200
+++ new/qmmp-1.1.4/ChangeLog.svn2016-10-04 11:49:54.0 +0200
@@ -1,4 +1,36 @@
 
+r6750 | trialuser02 | 2016-10-04 12:45:16 +0300 (Вт., 04 окт. 2016) | 1 line
+
+fixed changelog
+
+r6748 | trialuser02 | 2016-10-03 14:34:28 +0300 (Пн., 03 окт. 2016) | 1 line
+
+updated changelogs
+
+r6738 | trialuser02 | 2016-09-19 20:53:33 +0300 (Пн., 19 сент. 2016) | 1 line
+
+updated .ts files
+
+r6735 | trialuser02 | 2016-09-19 20:46:16 +0300 (Пн., 19 сент. 2016) | 1 line
+
+fixed typo
+
+r6726 | trialuser02 | 2016-09-15 17:59:48 +0300 (Чт., 15 сент. 2016) | 1 line
+
+fixed regression
+
+r6713 | trialuser02 | 2016-09-05 09:17:26 +0300 (Пн., 05 сент. 2016) | 1 line
+
+fixed 'index out of range' warning (backported from trunk)
+
+r6706 | trialuser02 | 2016-09-03 20:07:05 +0300 (Сб., 03 сент. 2016) | 1 line
+
+skinned: fixed issue with UTF-16 encoded pledit.txt (#880)
+
+r6700 | trialuser02 | 2016-08-26 14:54:02 +0300 (Пт., 26 авг. 2016) | 1 line
+
+version bump
+
 r6694 | trialuser02 | 2016-08-26 13:55:17 +0300 (Пт., 26 авг. 2016) | 1 line
 
 updated changelog
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/qmmp-1.1.3/qmmp.pri new/qmmp-1.1.4/qmmp.pri
--- old/qmmp-1.1.3/qmmp.pri 2016-08-26 13:36:55.0 +0200
+++ new/qmmp-1.1.4/qmmp.pri 2016-10-04 11:49:54.0 

commit kdevelop5 for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package kdevelop5 for openSUSE:Factory 
checked in at 2016-10-06 12:45:32

Comparing /work/SRC/openSUSE:Factory/kdevelop5 (Old)
 and  /work/SRC/openSUSE:Factory/.kdevelop5.new (New)


Package is "kdevelop5"

Changes:

--- /work/SRC/openSUSE:Factory/kdevelop5/kdevelop5.changes  2016-09-30 
15:31:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdevelop5.new/kdevelop5.changes 2016-10-06 
12:45:33.0 +0200
@@ -1,0 +2,27 @@
+Tue Oct  4 18:20:55 UTC 2016 - lbeltr...@kde.org
+
+- Add missing find_lang macros for additional translations
+
+---
+Tue Oct  4 12:49:32 UTC 2016 - lbeltr...@kde.org
+
+- Add KArchive to BuildRequires and bump Frameworks versions
+  (they were lower than in kdevplatform, and that did not make
+   any sense)
+
+---
+Mon Oct  3 22:22:10 UTC 2016 - lbeltr...@kde.org
+
+- New upstream release 5.0.1
+  * Do not display the "project is already open in a different
+session" dialog on starting up a session under some 
+circumstances. 
+  * Mouseover highlight now uses the "Search highlight" color from
+the configuration dialog, instead of a hard-coded bright 
+yellow.
+  * Fix working directory of Custom Makefile plugin
+  * Fix a possible crash on triggering an assistant popup action
+  * Fix a freeze under some circumstances when the welcome page is
+displayed. 
+
+---

Old:

  kdevelop-5.0.tar.xz

New:

  kdevelop-5.0.1.tar.xz



Other differences:
--
++ kdevelop5.spec ++
--- /var/tmp/diff_new_pack.B7dLR7/_old  2016-10-06 12:45:35.0 +0200
+++ /var/tmp/diff_new_pack.B7dLR7/_new  2016-10-06 12:45:35.0 +0200
@@ -19,45 +19,51 @@
 %define rname   kdevelop
 %define rversion 5.0
 Name:   kdevelop5
-Version:5.0.0
+Version:5.0.1
 Release:0
 Summary:C++ IDE using KDE technologies based on KDevelop Platform
 License:GPL-2.0+
 Group:  Development/Tools/IDE
 Url:http://www.kdevelop.org
-Source0:
http://download.kde.org/stable/%{rname}/%{version}/src/%{rname}-%{rversion}.tar.xz
-BuildRequires:  kcmutils-devel >= 5.15.0
-BuildRequires:  kconfig-devel >= 5.15.0
-BuildRequires:  kcrash-devel >= 5.15.0
-BuildRequires:  kdeclarative-devel >= 5.15.0
+Source0:%{rname}-%{version}.tar.xz
+BuildRequires:  grantlee5-devel
+BuildRequires:  karchive-devel >= 5.16.0
+BuildRequires:  kcmutils-devel >= 5.16.0
+BuildRequires:  kconfig-devel >= 5.16.0
+BuildRequires:  kcrash-devel >= 5.16.0
+BuildRequires:  kdeclarative-devel >= 5.16.0
 BuildRequires:  kdevelop5-pg-qt >= 2.0.0
+BuildRequires:  kdevplatform-devel
 BuildRequires:  kdevplatform-devel >= 5.0.0
-BuildRequires:  kdoctools-devel >= 5.15.0
-BuildRequires:  kf5-filesystem >= 5.15.0
-BuildRequires:  ki18n-devel >= 5.15.0
-BuildRequires:  kiconthemes-devel >= 5.15.0
-BuildRequires:  kio-devel >= 5.15.0
-BuildRequires:  kitemmodels-devel >= 5.15.0
-BuildRequires:  kitemviews-devel >= 5.15.0
-BuildRequires:  kjobwidgets-devel >= 5.15.0
-BuildRequires:  knewstuff-devel >= 5.15.0
-BuildRequires:  knotifyconfig-devel >= 5.15.0
-BuildRequires:  kparts-devel >= 5.15.0
+BuildRequires:  kdoctools-devel >= 5.16.0
+BuildRequires:  kf5-filesystem >= 5.16.0
+BuildRequires:  kguiaddons-devel >= 5.16.0
+BuildRequires:  ki18n-devel >= 5.16.0
+BuildRequires:  kiconthemes-devel >= 5.16.0
+BuildRequires:  kio-devel >= 5.16.0
+BuildRequires:  kitemmodels-devel >= 5.16.0
+BuildRequires:  kitemviews-devel >= 5.16.0
+BuildRequires:  kjobwidgets-devel >= 5.16.0
+BuildRequires:  knewstuff-devel >= 5.16.0
+BuildRequires:  knotifications-devel >= 5.16.0
+BuildRequires:  knotifyconfig-devel >= 5.16.0
+BuildRequires:  kparts-devel >= 5.16.0
 BuildRequires:  krunner-devel
-BuildRequires:  kservice-devel >= 5.15.0
-BuildRequires:  ktexteditor-devel >= 5.15.0
-BuildRequires:  kwindowsystem-devel >= 5.15.0
-BuildRequires:  kxmlgui-devel >= 5.15.0
+BuildRequires:  kservice-devel >= 5.16.0
+BuildRequires:  ktexteditor-devel >= 5.16.0
+BuildRequires:  kwindowsystem-devel >= 5.16.0
+BuildRequires:  kxmlgui-devel >= 5.16.0
 BuildRequires:  libksysguard5-devel
 BuildRequires:  llvm-clang-devel
 BuildRequires:  pkgconfig
 BuildRequires:  plasma-framework-devel
 BuildRequires:  shared-mime-info
-BuildRequires:  threadweaver-devel >= 5.15.0
+BuildRequires:  threadweaver-devel >= 5.16.0
 BuildRequires:  pkgconfig(Qt5Concurrent) >= 5.4.0
 BuildRequires:  pkgconfig(Qt5Core) >= 5.4.0
 BuildRequires:  pkgconfig(Qt5DBus) >= 5.4.0
 BuildRequires:  pkgconfig(Qt5Help) >= 5.4.0

commit lollypop for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lollypop for openSUSE:Factory 
checked in at 2016-10-06 12:45:18

Comparing /work/SRC/openSUSE:Factory/lollypop (Old)
 and  /work/SRC/openSUSE:Factory/.lollypop.new (New)


Package is "lollypop"

Changes:

--- /work/SRC/openSUSE:Factory/lollypop/lollypop.changes2016-09-26 
12:36:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.lollypop.new/lollypop.changes   2016-10-06 
12:45:19.0 +0200
@@ -1,0 +2,8 @@
+Thu Sep 29 03:11:14 UTC 2016 - badshah...@gmail.com
+
+- Update to version 0.9.206:
+  + Fix an issue with GTK 3.22.
+  + Do not search in youtube based on audio length.
+  + Add lollypop-cli command line helper.
+
+---

Old:

  lollypop-0.9.205.tar.xz

New:

  lollypop-0.9.206.tar.xz



Other differences:
--
++ lollypop.spec ++
--- /var/tmp/diff_new_pack.Czodh2/_old  2016-10-06 12:45:21.0 +0200
+++ /var/tmp/diff_new_pack.Czodh2/_new  2016-10-06 12:45:21.0 +0200
@@ -22,7 +22,7 @@
 Name:   lollypop
 Summary:GNOME music playing application
 License:GPL-3.0+
-Version:0.9.205
+Version:0.9.206
 Release:0
 Url:http://gnumdk.github.io/lollypop-web/
 Source0:
https://github.com/gnumdk/lollypop/releases/download/%{version}/%{name}-%{version}.tar.xz
@@ -117,6 +117,8 @@
 %files -f %{name}.lang
 %doc AUTHORS COPYING
 %{_bindir}/%{name}
+%{_bindir}/%{name}-cli
+%{_bindir}/rhythmbox2lollypop
 %{_datadir}/%{name}
 %{_datadir}/help/*/%{name}
 %if 0%{?suse_version} == 1315

++ lollypop-0.9.205.tar.xz -> lollypop-0.9.206.tar.xz ++
 24453 lines of diff (skipped)




commit wine for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package wine for openSUSE:Factory checked in 
at 2016-10-06 12:45:02

Comparing /work/SRC/openSUSE:Factory/wine (Old)
 and  /work/SRC/openSUSE:Factory/.wine.new (New)


Package is "wine"

Changes:

--- /work/SRC/openSUSE:Factory/wine/wine.changes2016-09-17 
14:40:58.0 +0200
+++ /work/SRC/openSUSE:Factory/.wine.new/wine.changes   2016-10-06 
12:45:04.0 +0200
@@ -1,0 +2,10 @@
+Mon Oct  3 16:57:24 UTC 2016 - meiss...@suse.com
+
+- Updated to 1.9.20 development snapshot
+  - Reimplementation of the clipboard API.
+  - Message handling in WebServices.
+  - Many more API Set libraries.
+  - Various bug fixes.
+- updated winetricks
+
+---

Old:

  wine-1.9.19.tar.bz2
  wine-1.9.19.tar.bz2.sign

New:

  wine-1.9.20.tar.bz2
  wine-1.9.20.tar.bz2.sign



Other differences:
--
++ wine.spec ++
--- /var/tmp/diff_new_pack.L08Dlv/_old  2016-10-06 12:45:09.0 +0200
+++ /var/tmp/diff_new_pack.L08Dlv/_new  2016-10-06 12:45:09.0 +0200
@@ -53,8 +53,8 @@
 BuildRequires:  update-desktop-files
 BuildRequires:  valgrind-devel
 BuildRequires:  xorg-x11-devel
-%define realver 1.9.19
-Version:1.9.19
+%define realver 1.9.20
+Version:1.9.20
 Release:0
 Summary:An MS Windows Emulator
 License:LGPL-2.1+

++ wine-1.9.19.tar.bz2 -> wine-1.9.20.tar.bz2 ++
/work/SRC/openSUSE:Factory/wine/wine-1.9.19.tar.bz2 
/work/SRC/openSUSE:Factory/.wine.new/wine-1.9.20.tar.bz2 differ: char 11, line 1


++ winetricks ++
--- /var/tmp/diff_new_pack.L08Dlv/_old  2016-10-06 12:45:09.0 +0200
+++ /var/tmp/diff_new_pack.L08Dlv/_new  2016-10-06 12:45:09.0 +0200
@@ -124,6 +124,7 @@
 #
 # Private things internal to this script, not for use by verbs:
 # - Local variables have lowercase names starting with uppercase _W_
+#   (and should not use the local declaration, as it is not POSIX)
 # - Global variables have uppercase names starting with WINETRICKS_
 # - Functions have lowercase names starting with winetricks_
 # FIXME: A few verbs still use winetricks-private functions or variables.
@@ -519,15 +520,15 @@
 # get sha1sum string and set $_W_gotsum to it
 w_get_sha1sum()
 {
-local _W_file="$1"
+_W_sha1_file="$1"
 
 # See https://github.com/Winetricks/winetricks/issues/645
 # User is running winetricks from /dev/stdin
-if [ -f "$_W_file" ] || [ -h "$_W_file" ]
+if [ -f "$_W_sha1_file" ] || [ -h "$_W_sha1_file" ]
 then
-_W_gotsum=$($WINETRICKS_SHA1SUM < "$_W_file" | sed 's/(stdin)= //;s/ 
.*//')
+_W_gotsum=$($WINETRICKS_SHA1SUM < "$_W_sha1_file" | sed 's/(stdin)= 
//;s/ .*//')
 else
-w_warn "$_W_file is not a regular file, not checking sha1sum"
+w_warn "$_W_sha1_file is not a regular file, not checking sha1sum"
 return
 fi
 }
@@ -609,6 +610,7 @@
 dotnet40) version="4 Client" ;;
 dotnet45) version="4.5" ;;
 dotnet452) version="4.5.2" ;;
+dotnet46) version="4.6" ;;
 *) echo error ; exit 1 ;;
 esac
 w_call dotnet_verifier
@@ -2388,7 +2390,7 @@
 fi
 
 # If the user specified --verify, also run GUI tests:
-if test "$WINETRICKS_VERIFY" = 1 && type verify_$cmd 2> /dev/null
+if test "$WINETRICKS_VERIFY" = 1 && command -v verify_$cmd > /dev/null 
2>&1
 then
 w_try verify_$cmd
 fi
@@ -5916,12 +5918,14 @@
 w_call remove_mono
 
 w_call dotnet20
+$WINESERVER -w
 
 # FIXME: verify on pristine Windows XP:
 if w_workaround_wine_bug 34803
 then
 "$WINE" reg delete 
'HKLM\Software\Microsoft\.NETFramework\v2.0.50727\SBSDisabled' /f
 fi
+$WINESERVER -w
 
 cd "$W_CACHE/$W_PACKAGE"
 w_ahk_do "
@@ -6349,6 +6353,58 @@
 w_dotnet_verify dotnet452
 }
 
+#
+
+w_metadata dotnet46 dlls \
+title="MS .NET 4.6" \
+publisher="Microsoft" \
+year="2015" \
+media="download" \
+file1="NDP46-KB3045557-x86-x64-AllOS-ENU.exe" \
+conflicts="dotnet20 dotnet20sdk dotnet20sp1 dotnet20sp2 dotnet35sp1 
dotnet40 vjrun20" \
+
installed_file1="c:/windows/Microsoft.NET/Framework/v4.0.30319/SetupCache/v4.6.00081/1041/SetupResources.dll"
+
+load_dotnet46()
+{
+if [ $W_ARCH = win64 ]
+then
+w_warn "This package may not work on a 64-bit installation"
+fi
+
+# https://support.microsoft.com/en-us/kb/3045560
+w_download 
https://download.microsoft.com/download/C/3/A/C3A5200B-D33C-47E9-9D70-2F7C65DAAD94/NDP46-KB3045557-x86-x64-AllOS-ENU.exe
 3049a85843eaf65e89e2336d5fe6e85e416797be
+
+   

commit python-oauth2client for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package python-oauth2client for 
openSUSE:Factory checked in at 2016-10-06 12:45:24

Comparing /work/SRC/openSUSE:Factory/python-oauth2client (Old)
 and  /work/SRC/openSUSE:Factory/.python-oauth2client.new (New)


Package is "python-oauth2client"

Changes:

--- /work/SRC/openSUSE:Factory/python-oauth2client/python-oauth2client.changes  
2016-01-12 16:12:47.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-oauth2client.new/python-oauth2client.changes 
2016-10-06 12:45:25.0 +0200
@@ -1,0 +2,48 @@
+Fri Mar 11 10:46:08 UTC 2016 - tbecht...@suse.com
+
+- update to 2.0.1:
+  * Making scopes optional on Google Compute Engine `AppAssertionCredentials`
+and adding a warning that GCE won't honor scopes (#419)
+  * Adding common `sign_blob()` to service account types and a
+`service_account_email` property. (#421)
+  * Improving error message in P12 factory
+`ServiceAccountCredentials.from_p12_keyfile` when pyOpenSSL is
+ missing. (#424)
+  * Allowing default flags in `oauth2client.tools.run_flow()`
+rather than forcing users to create a dummy argparser (#426)
+  * Removing `oauth2client.util.dict_to_tuple_key()` from public
+interface (#429)
+  * Adding `oauth2client.contrib._appengine_ndb` helper module
+for `oauth2client.contrib.appengine` and moving most code that
+uses the `ndb` library into the helper (#434)
+  * Fix error in `django_util` sample code (#438)
+  * Fix Google Compute Engine breakage (#411, breakage introduced in #387) that
+made it impossible to obtain access tokens
+  * Implement `ServiceAccountCredentials.from_p12_keyfile_buffer()`
+to allow passing a file-like object in addition to the factory
+constructor that uses a filename directly (#413)
+  * Implement `ServiceAccountCredentials.create_delegated()`
+to allow upgrading a credential to one that acts on behalf
+of a given subject (#420)
+  * Add django_util (#332)
+  * Avoid OAuth2Credentials `id_token` going out of sync after a token
+refresh (#337)
+  * Move to a `contrib` sub-package code not considered a core part of
+the library (#346, #353, #370, #375, #376, #382)
+  * Add `token_expiry` to `devshell` credentials (#372)
+  * Move `Storage` locking into a base class (#379)
+  * Added dictionary storage (#380)
+  * Added `to_json` and `from_json` methods to all `Credentials`
+classes (#385)
+  * Fall back to read-only credentials on EACCES errors (#389)
+  * Coalesced the two `ServiceAccountCredentials`
+classes (#395, #396, #397, #398, #400)
+  * Add access token refresh error class that includes HTTP status (#310)
+  * Python3 compatibility fixes for Django (#316, #318)
+  * Fix incremental auth in flask_util (#322)
+  * Fall back to credential refresh on EDEADLK in multistore_file (#336)
+- Remove test package. tests are no longer shipped by upstream.
+- Remove hidePythonDeps.patch
+- Some imports moved from oauth2client to oauth2client.contrib
+
+---

Old:

  hidePythonDeps.patch
  oauth2client-1.5.1.tar.gz

New:

  oauth2client-2.0.1.tar.gz



Other differences:
--
++ python-oauth2client.spec ++
--- /var/tmp/diff_new_pack.lGBB48/_old  2016-10-06 12:45:26.0 +0200
+++ /var/tmp/diff_new_pack.lGBB48/_new  2016-10-06 12:45:26.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-oauth2client
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,13 @@
 
 
 Name:   python-oauth2client
-Version:1.5.1
+Version:2.0.1
 Release:0
 Summary:Pythob OAuth2 CLient
 License:Apache-2.0
 Group:  Development/Languages/Python
 Url:https://github.com/google/oauth2client
 Source0:oauth2client-%{version}.tar.gz
-Patch1: hidePythonDeps.patch
 Requires:   python
 Requires:   python-httplib2>= 0.9.1
 Requires:   python-keyring
@@ -40,7 +39,6 @@
 BuildRequires:  python-httplib2>= 0.9.1
 BuildRequires:  python-keyring
 BuildRequires:  python-mock
-BuildRequires:  python-nose
 BuildRequires:  python-pyOpenSSL
 BuildRequires:  python-pyasn1-modules  >= 0.0.5
 BuildRequires:  python-pycrypto
@@ -96,84 +94,45 @@
 Utilities for making it easier to use OAuth 2.0 on Google Compute Engine.
 
 
-%package test
-Summary:Tests for python-oauth2client
-Group:  Development/Libraries/Python
-PreReq: python-oauth2client = %version
-%if 

commit wlc for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package wlc for openSUSE:Factory checked in 
at 2016-10-06 12:45:45

Comparing /work/SRC/openSUSE:Factory/wlc (Old)
 and  /work/SRC/openSUSE:Factory/.wlc.new (New)


Package is "wlc"

Changes:

--- /work/SRC/openSUSE:Factory/wlc/wlc.changes  2016-08-20 12:27:16.0 
+0200
+++ /work/SRC/openSUSE:Factory/.wlc.new/wlc.changes 2016-10-06 
12:45:46.0 +0200
@@ -1,0 +2,16 @@
+Tue Sep 27 19:47:20 UTC 2016 - sleep_wal...@opensuse.org
+
+- bump to 0.0.6
+   submodule: Update wayland-protocols
+   flip vertical coordinates in read_pixels()
+   Fix: Inform X11 windows about border size.
+   output: Set backend surface only after creation
+   cmake: Constant for LINUX doesn't exist
+   keymap: Invalidate fd on release
+   keymap: Zero out structure on release
+   Changes to enable building on FreeBSD. Need to confirm still builds
+ and works as expected on Linux!
+   Include way-cooler in README
+   
+
+---

Old:

  wlc-0.0.5.tar.bz2
  wlc-0.0.5.tar.bz2.asc

New:

  wlc-0.0.6.tar.bz2
  wlc-0.0.6.tar.bz2.asc



Other differences:
--
++ wlc.spec ++
--- /var/tmp/diff_new_pack.aSjDk7/_old  2016-10-06 12:45:48.0 +0200
+++ /var/tmp/diff_new_pack.aSjDk7/_new  2016-10-06 12:45:48.0 +0200
@@ -16,10 +16,10 @@
 #
 
 
-%define wayland_minimal 1.7.0
+%define wayland_minimal 1.7
 
 Name:   wlc
-Version:0.0.5
+Version:0.0.6
 Release:0
 Summary:A Wayland Compositor Library
 License:MIT
@@ -44,6 +44,7 @@
 BuildRequires:  pkgconfig(wayland-client) >= %{wayland_minimal}
 BuildRequires:  pkgconfig(wayland-cursor) >= %{wayland_minimal}
 BuildRequires:  pkgconfig(wayland-egl) >= %{wayland_minimal}
+BuildRequires:  pkgconfig(wayland-protocols) >= %{wayland_minimal}
 BuildRequires:  pkgconfig(wayland-scanner) >= %{wayland_minimal}
 BuildRequires:  pkgconfig(wayland-server) >= %{wayland_minimal}
 BuildRequires:  pkgconfig(x11)

++ wlc-0.0.5.tar.bz2 -> wlc-0.0.6.tar.bz2 ++
 5151 lines of diff (skipped)





commit python-oslo.db for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package python-oslo.db for openSUSE:Factory 
checked in at 2016-10-06 12:45:11

Comparing /work/SRC/openSUSE:Factory/python-oslo.db (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.db.new (New)


Package is "python-oslo.db"

Changes:

--- /work/SRC/openSUSE:Factory/python-oslo.db/python-oslo.db.changes
2016-05-19 12:14:34.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-oslo.db.new/python-oslo.db.changes   
2016-10-06 12:45:13.0 +0200
@@ -1,0 +2,79 @@
+Fri Sep 30 13:37:35 UTC 2016 - dmuel...@suse.com
+
+- update to 4.13.3
+
+---
+Tue Aug 30 16:20:11 UTC 2016 - tbecht...@suse.com
+
+- update to version 4.13.0
+  * Link enginefacade to test database provisioning
+  * Display full reason for backend not available
+  * Fix parameters of assertEqual are misplaced
+  * Add logging_name to enginefacade config
+  * release notes: mention changes in wrap_db_retry()
+  * Deprecate argument sqlite_db in method set_defaults
+  * Updated from global requirements
+  * Add test helpers to enginefacade
+
+---
+Fri Aug 26 20:44:57 UTC 2016 - tbecht...@suse.com
+
+- update to version 4.11.0
+  * Memoize sys.exc_info() before attempting a savepoint rollback
+  * Add a hook to process newly created engines
+  * Set a min and max on the connection_debug option
+  * Consolidate pifpaf commands into variables
+  * Add dispose_pool() method to enginefacade context, factory
+  * Fixed unit tests running on Windows
+  * Capture DatabaseError for deadlock check
+  * tox: add py35 envs for convenience
+  * Set max pool size default to 5
+  * Updated from global requirements
+  * Remove discover from setup.cfg
+
+---
+Wed Aug 10 14:39:02 UTC 2016 - tbecht...@suse.com
+
+- update to version 4.8.0
+  * Add tests for float interval values in wrap_db_retry()
+  * Imported Translations from Zanata
+  * Add debtcollector to requirements
+  * Fix typo: 'olso' to 'oslo'
+  * api: do not log a traceback if error is not expected
+  * Replace tempest-lib dependency with os-testr
+  * Add new filter for DBDataError exception
+  * api: always enable retry_on_request
+  * exc_filters: catch and translate non existent constraint on drop
+  * Deprecate config option sqlite_db for removal
+  * api: use sane default in wrap_db_retry()
+  * Fix spelling mistake
+  * Update reno for stable/mitaka
+  * tests: fix order of assertEqual in exc_filter
+  * exception: make message mandatory in DbMigrationError and deprecates it
+  * Make it possible to use enginefacade decorators with class methods
+  * Fix unit tests failures, when psycopg2 is not installed
+  * Fix server_default comparison for BigInteger
+  * Remove unused sqlite_fk in _init_connection_args call
+  * Fix typos in comments and docstring
+  * Catch empty value DBDuplicate errors
+  * Remove  sqlalchemy < 1.0.0 compatible layer
+  * Let enginefacade._TransactionContextManager look for context
+  * Remove direct dependency on babel
+  * Correct docstring
+  * Repair boolean CHECK constraint detection
+  * Add support for LONGTEXT, MEDIUMTEXT to JsonEncodedType
+  * Raise DbMigrationError for invalid version
+  * exc_filters: catch and translate non existent table on drop
+  * Remove oslo-incubator related stuff
+  * Fix imports in doc
+  * Allow testing of MySQL and PostgreSQL scenario locally
+  * Add support for custom JSON serializer
+  * Updated from global requirements
+
+---
+Mon Jul  4 15:47:30 UTC 2016 - tbecht...@suse.com
+
+- Switch to upstream .spec file
+- Use renderspec source service to update .spec.j2 template
+
+---

Old:

  oslo.db-4.7.0.tar.gz
  rpmlintrc

New:

  oslo.db-4.13.3.tar.gz



Other differences:
--
++ python-oslo.db.spec ++
--- /var/tmp/diff_new_pack.B9a7y1/_old  2016-10-06 12:45:15.0 +0200
+++ /var/tmp/diff_new_pack.B9a7y1/_new  2016-10-06 12:45:15.0 +0200
@@ -16,107 +16,93 @@
 #
 
 
-%define component oslo_db
-
-%define version_unconverted 4.7.0
-
+%global sname oslo.db
 Name:   python-oslo.db
-Version:4.7.0
+Version:4.13.3
 Release:0
-Url:https://launchpad.net/oslo/
-Summary:OpenStack DB API
+Summary:OpenStack oslo.db library
 License:Apache-2.0
 Group:  Development/Languages/Python
-Source: 
https://pypi.python.org/packages/source/o/oslo.db/oslo.db-%{version}.tar.gz
-Source99:   rpmlintrc
-BuildRoot:  

commit kdevelop5-plugin-php for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package kdevelop5-plugin-php for 
openSUSE:Factory checked in at 2016-10-06 12:45:37

Comparing /work/SRC/openSUSE:Factory/kdevelop5-plugin-php (Old)
 and  /work/SRC/openSUSE:Factory/.kdevelop5-plugin-php.new (New)


Package is "kdevelop5-plugin-php"

Changes:

--- 
/work/SRC/openSUSE:Factory/kdevelop5-plugin-php/kdevelop5-plugin-php.changes
2016-09-30 15:32:26.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.kdevelop5-plugin-php.new/kdevelop5-plugin-php.changes
   2016-10-06 12:45:38.0 +0200
@@ -1,0 +2,17 @@
+Tue Oct  4 20:58:29 UTC 2016 - lbeltr...@kde.org
+
+- Remove translations that are no longer there 
+
+---
+Tue Oct  4 13:01:08 UTC 2016 - lbeltr...@kde.org
+
+- Add BuildRequires to QtConcurrent to fix build
+
+---
+Mon Oct  3 22:27:52 UTC 2016 - lbeltr...@kde.org
+
+- New upstream release 5.0.1
+  * Fix a crash in the PHP plugin when editing text in the line 
+after a "TODO".  
+
+---

Old:

  kdev-php-5.0.tar.xz

New:

  kdev-php-5.0.1.tar.xz



Other differences:
--
++ kdevelop5-plugin-php.spec ++
--- /var/tmp/diff_new_pack.MugArM/_old  2016-10-06 12:45:39.0 +0200
+++ /var/tmp/diff_new_pack.MugArM/_new  2016-10-06 12:45:39.0 +0200
@@ -19,25 +19,34 @@
 %define rname   kdev-php
 %define rversion 5.0
 Name:   kdevelop5-plugin-php
-Version:5.0.0
+Version:5.0.1
 Release:0
 Summary:PHP plugin for Kdevelop5 Integrated Development Environment
 License:GPL-2.0+
 Group:  Development/Tools/IDE
 Url:http://www.kdevelop.org
-Source0:
http://download.kde.org/stable/kdevelop/%{version}/src/%{rname}-%{rversion}.tar.xz
+Source0:%{rname}-%{version}.tar.xz
 BuildRequires:  extra-cmake-modules
+BuildRequires:  grantlee5-devel
 BuildRequires:  karchive-devel
 BuildRequires:  kcmutils-devel
 BuildRequires:  kdevelop5-pg-qt >= 2.0.0
 BuildRequires:  kdevplatform-devel >= 5.0.0
 BuildRequires:  kf5-filesystem
+BuildRequires:  kguiaddons-devel
 BuildRequires:  ki18n-devel
+BuildRequires:  kiconthemes-devel
 BuildRequires:  kitemmodels-devel
+BuildRequires:  knewstuff-devel
+BuildRequires:  knotifications-devel
+BuildRequires:  knotifyconfig-devel
 BuildRequires:  ktexteditor-devel
+BuildRequires:  kwindowsystem-devel
 BuildRequires:  pkgconfig
 BuildRequires:  threadweaver-devel
+BuildRequires:  pkgconfig(Qt5Concurrent) >= 5.2.0
 BuildRequires:  pkgconfig(Qt5Core) >= 5.2.0
+BuildRequires:  pkgconfig(Qt5Quick) >= 5.2.0
 BuildRequires:  pkgconfig(Qt5Test) >= 5.2.0
 BuildRequires:  pkgconfig(Qt5WebKitWidgets) >= 5.2.0
 BuildRequires:  pkgconfig(Qt5Widgets) >= 5.2.0
@@ -74,7 +83,7 @@
 Provides translations to the package %{name}
 
 %prep
-%setup -q -n %{rname}-%{rversion}
+%setup -q -n %{rname}-%{version}
 
 %build
   %cmake_kf5 -d build
@@ -83,7 +92,6 @@
 %install
   %kf5_makeinstall -C build
   %find_lang kdevphp %{name}.lang
-  %find_lang kdevphpdocs %{name}.lang
 
 %post -p /sbin/ldconfig
 %postun -p /sbin/ldconfig

++ kdev-php-5.0.tar.xz -> kdev-php-5.0.1.tar.xz ++
 6437 lines of diff (skipped)




commit kdevplatform for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package kdevplatform for openSUSE:Factory 
checked in at 2016-10-06 12:44:58

Comparing /work/SRC/openSUSE:Factory/kdevplatform (Old)
 and  /work/SRC/openSUSE:Factory/.kdevplatform.new (New)


Package is "kdevplatform"

Changes:

--- /work/SRC/openSUSE:Factory/kdevplatform/kdevplatform.changes
2016-09-30 15:32:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.kdevplatform.new/kdevplatform.changes   
2016-10-06 12:44:59.0 +0200
@@ -1,0 +2,12 @@
+Mon Oct  3 22:18:10 UTC 2016 - lbeltr...@kde.org
+
+- New upstream release 5.0.1
+  * Fix a deadlock in the background parser, which especially 
+occured on projects containing both C++ and Python/JS/QML code
+ and caused either parsing or the whole application to freeze
+  randomly.
+  * Fix a crash which sometimes happened when switching git
+branches on command line.
+  * Fix some translation issues.
+
+---

Old:

  kdevplatform-5.0.tar.xz

New:

  kdevplatform-5.0.1.tar.xz



Other differences:
--
++ kdevplatform.spec ++
--- /var/tmp/diff_new_pack.UiXqPj/_old  2016-10-06 12:45:00.0 +0200
+++ /var/tmp/diff_new_pack.UiXqPj/_new  2016-10-06 12:45:00.0 +0200
@@ -19,13 +19,13 @@
 %define rversion 5.0
 %define libkdev_major 10
 Name:   kdevplatform
-Version:5.0.0
+Version:5.0.1
 Release:0
 Summary:Base Package for Integrated Development Environments
 License:GPL-2.0+
 Group:  Development/Tools/IDE
 Url:http://www.kdevelop.org
-Source: 
http://download.kde.org/stable/kdevelop/%{version}/src/%{name}-%{rversion}.tar.xz
+Source: 
http://download.kde.org/stable/kdevelop/%{version}/src/%{name}-%{version}.tar.xz
 BuildRequires:  boost-devel
 BuildRequires:  extra-cmake-modules >= 0.0.9
 BuildRequires:  grantlee5-devel
@@ -85,7 +85,7 @@
 
 
 %prep
-%setup -q -n kdevplatform-%{rversion}
+%setup -q -n kdevplatform-%{version}
 
 %build
   %cmake_kf5 -d build

++ kdevplatform-5.0.tar.xz -> kdevplatform-5.0.1.tar.xz ++
 51453 lines of diff (skipped)




commit lxqt-runner for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-runner for openSUSE:Factory 
checked in at 2016-10-06 12:44:21

Comparing /work/SRC/openSUSE:Factory/lxqt-runner (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-runner.new (New)


Package is "lxqt-runner"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-runner/lxqt-runner.changes  2015-11-13 
23:35:49.0 +0100
+++ /work/SRC/openSUSE:Factory/.lxqt-runner.new/lxqt-runner.changes 
2016-10-06 12:44:22.0 +0200
@@ -1,0 +2,24 @@
+Sat Sep 24 21:49:52 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * Add README.md
+  * Math: Enhance evaluation logic
+  * Math: Use libmuparser for math evaluation
+  * runner: Follow virtual desktop switching
+  * Properly hide the runner when it loses focus
+  * runner: Sort history items by relevance
+  * build: Use external translations (#41)
+  * ts-files removal (#40)
+  * Use QString() instead of ""
+  * Fix layout and focus to get history items right
+  * Bump year
+  * main: Add activation by running second instance
+  * Italian translation update
+  * dialog: Default icons
+  * dialog: Fill background
+  * upd: lxqt-runner_hu.ts
+  * Update lxqt-runner_it.ts
+- Add keyring
+- Remove Qt5Script in favour of libmuparser as BuildRequire
+
+---

Old:

  lxqt-runner-0.10.0.tar.xz

New:

  lxqt-runner-0.11.0.tar.xz
  lxqt-runner-0.11.0.tar.xz.asc
  lxqt-runner.keyring



Other differences:
--
++ lxqt-runner.spec ++
--- /var/tmp/diff_new_pack.fu9s7I/_old  2016-10-06 12:44:23.0 +0200
+++ /var/tmp/diff_new_pack.fu9s7I/_new  2016-10-06 12:44:23.0 +0200
@@ -17,48 +17,45 @@
 
 
 Name:   lxqt-runner
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:LXQt application launcher
 License:LGPL-2.1+
-Group:  System/GUI/LXDE-Qt
-Url:http://www.lxde.org
-Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Group:  System/GUI/LXQt
+Url:http://www.lxqt.org
+Source0:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
-BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  kwindowsystem-devel
-BuildRequires:  pkgconfig(Qt5Script)
+BuildRequires:  cmake(KF5WindowSystem)
+BuildRequires:  pkgconfig(muparser)
 BuildRequires:  pkgconfig(Qt5UiTools)
 BuildRequires:  pkgconfig(Qt5Xdg)
 BuildRequires:  pkgconfig(libmenu-cache)
 BuildRequires:  pkgconfig(lxqt) >= %{version}
 BuildRequires:  pkgconfig(lxqt-globalkeys) >= %{version}
+Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 Tool to launch programs quickly, by typing their names
 
-%lang_package
-
 %prep
 %setup -q
 
 %build
-%cmake
+%cmake -DPULL_TRANSLATIONS=No
 make %{?_smp_mflags}
 
 %install
 %cmake_install
-%fdupes %{buildroot}/%{_datadir}
+install -Dm 0644 man/%{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1   
 
 
 %files
 %defattr(-,root,root)
 %doc AUTHORS LICENSE
 %{_bindir}/lxqt-runner
-
-%files lang
-%defattr(-,root,root)
-%{_datadir}/lxqt/translations
+%{_mandir}/man?/%{name}.?%{ext_man}
 
 
 %changelog

++ lxqt-runner-0.10.0.tar.xz -> lxqt-runner-0.11.0.tar.xz ++
 5528 lines of diff (skipped)




commit hiawatha for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package hiawatha for openSUSE:Factory 
checked in at 2016-10-06 12:44:54

Comparing /work/SRC/openSUSE:Factory/hiawatha (Old)
 and  /work/SRC/openSUSE:Factory/.hiawatha.new (New)


Package is "hiawatha"

Changes:

--- /work/SRC/openSUSE:Factory/hiawatha/hiawatha.changes2015-06-23 
11:59:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.hiawatha.new/hiawatha.changes   2016-10-06 
12:44:54.0 +0200
@@ -1,0 +2,56 @@
+Sun Oct  2 19:30:49 UTC 2016 - fi...@opensuse.org
+
+- Build fails with mbedtls < 2.
+
+---
+Sat Aug 27 11:43:20 UTC 2016 - mplus...@suse.com
+
+- Update to version 10.3:
+  * PreventCSRF, PreventSQLi and PreventXSS improved.
+  * Prevention of MySQL data mining via SQL injection.
+  * Added revoke option to Let's Encrypt script.
+  * Hiawatha ignores RequireTLS for Let's Encrypt authentication
+requests.
+  * Small bugfixes and improvements.
+  * Bugfix: possible HTTP request pipelining error after CSRF
+prevented.
+- Changes for version 10.2:
+  * Added Let's Encrypt script (see extra/letsencrypt).
+  * Added support for requesting Let's Encrypt certificates (see
+AccessList and PasswordFile settings in manual page).
+  * Small improvements.
+  * Bugfix: HideProxy not working for Forwarded header.
+- Changes for 10.1:
+  * Added Extensions setting.
+  * Added support for X-Sendfile header.
+  * mbed TLS updated to 2.2.1.
+  * Improved SQL injection detection.
+  * Small bugfixes and improvements.
+- Changes for 10.0:
+  * Usage of Directory sections changed.
+  * Added support for RFC 5785.
+  * Added support for GZip compression. Removed the UseGZfile
+option.
+  * Added ECDSA support for TLS 1.0 and TLS 1.1.
+  * Replaced UrlToolkit Expire option with ExpirePeriod in
+Directory section.
+  * Replaced IgnoreDotHiawatha option with UseLocalConfig.
+  * Removed the VolatileObject option.
+  * Improved SQL injection detection.
+  * mbed TLS updated to 2.2.0.
+  * Small improvements.
+- Changes for 9.15:
+  * Support for WebSockets via reverse proxy.
+  * UNIX socket support for connections to WebSockets.
+  * Responsive design for directory index and error message.
+  * mbed TLS updated to 2.1.2.
+  * Fixed mbed TLS linking in CMake configuration.
+  * ListenBacklog option added.
+  * Small bugfixes.
+- Changes for 9.14:
+  * mbed TLS updated to 2.0.0.
+  * Small bugfixes.
+  * Bugfix: crash when sending very large request to FastCGI
+server.
+
+---

Old:

  hiawatha-9.13.tar.gz

New:

  hiawatha-10.3.tar.gz



Other differences:
--
++ hiawatha.spec ++
--- /var/tmp/diff_new_pack.FpynwN/_old  2016-10-06 12:44:55.0 +0200
+++ /var/tmp/diff_new_pack.FpynwN/_new  2016-10-06 12:44:55.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package hiawatha
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2013-2015 Mariusz Fik .
 #
 # All modifications and additions to the file contributed by third parties
@@ -20,7 +20,7 @@
 %define webroot /srv/www
 
 Name:   hiawatha
-Version:9.13
+Version:10.3
 Release:0
 Summary:A secure and advanced webserver
 License:GPL-2.0
@@ -33,7 +33,7 @@
 Source101:  %{name}-ssl.firewall
 BuildRequires:  cmake >= 2.8.4
 BuildRequires:  libxslt-devel
-BuildRequires:  mbedtls-devel >= 1.3.10
+BuildRequires:  mbedtls-devel >= 2.3
 BuildRequires:  pkg-config
 BuildRequires:  systemd
 Requires:   logrotate

++ hiawatha-9.13.tar.gz -> hiawatha-10.3.tar.gz ++
 127216 lines of diff (skipped)




commit lxqt-sudo for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-sudo for openSUSE:Factory 
checked in at 2016-10-06 12:44:34

Comparing /work/SRC/openSUSE:Factory/lxqt-sudo (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-sudo.new (New)


Package is "lxqt-sudo"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-sudo/lxqt-sudo.changes  2015-11-13 
23:35:50.0 +0100
+++ /work/SRC/openSUSE:Factory/.lxqt-sudo.new/lxqt-sudo.changes 2016-10-06 
12:44:35.0 +0200
@@ -1,0 +2,14 @@
+Sat Sep 24 22:03:54 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * Add README.md
+  * build: Forward translations parameters
+  * ts-files removal (#21)
+  * Remove translations (will be pulled in build time)
+  * Bump year
+  * Italian translation update
+  * Updated Russian translation Fix language and typos
+  * Add Russian translation
+- Add keyring
+
+---

Old:

  lxqt-sudo-0.10.0.tar.xz

New:

  lxqt-sudo-0.11.0.tar.xz
  lxqt-sudo-0.11.0.tar.xz.asc
  lxqt-sudo.keyring



Other differences:
--
++ lxqt-sudo.spec ++
--- /var/tmp/diff_new_pack.wz7mm0/_old  2016-10-06 12:44:36.0 +0200
+++ /var/tmp/diff_new_pack.wz7mm0/_new  2016-10-06 12:44:36.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package lxqt-sudo
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,35 +17,36 @@
 
 
 Name:   lxqt-sudo
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:GUI frontend for sudo
 License:LGPL-2.1
 Group:  System/X11/Utilities
-Url:https://github.com/lxde/lxqt-sudo
-Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Url:http://lxqt.org
+Source0:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  gcc-c++
-BuildRequires:  kwindowsystem-devel
+BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  pkgconfig(Qt5Widgets)
 BuildRequires:  pkgconfig(lxqt) >= %{version}
+Recommends: %{name}-lang
 Requires:   sudo
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-A graphical QT frontend for plain sudo (for requesting optional password in GUI
+A graphical frontend for plain sudo (for requesting optional password in GUI
 fashion).
 When invoked it simply spawns child sudo process with requested command (and
 arguments). If sudo requests user's password, the GUI password dialog is shown
 and (after submit) the password is provided to sudo.
 
-%lang_package
-
 %prep
 %setup -q
 
 %build
-%cmake
+%cmake -DPULL_TRANSLATIONS=No
 make %{?_smp_mflags}
 
 %install
@@ -59,10 +60,4 @@
 %{_mandir}/man?/%{name}.*
 %{_mandir}/man?/lxsu*.*
 
-%files lang
-%defattr(-,root,root)
-%dir %{_datadir}/lxqt
-%dir %{_datadir}/lxqt/translations
-%dir %{_datadir}/lxqt/translations/%{name}
-%{_datadir}/lxqt/translations/%{name}
-
+%changelog

++ lxqt-sudo-0.10.0.tar.xz -> lxqt-sudo-0.11.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-sudo-0.10.0/.gitignore 
new/lxqt-sudo-0.11.0/.gitignore
--- old/lxqt-sudo-0.10.0/.gitignore 2015-11-02 06:06:33.0 +0100
+++ new/lxqt-sudo-0.11.0/.gitignore 2016-09-24 00:47:03.0 +0200
@@ -1 +1,2 @@
 build
+translations/lxqt-sudo
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-sudo-0.10.0/AUTHORS new/lxqt-sudo-0.11.0/AUTHORS
--- old/lxqt-sudo-0.10.0/AUTHORS2015-11-02 06:06:33.0 +0100
+++ new/lxqt-sudo-0.11.0/AUTHORS2016-09-24 00:47:03.0 +0200
@@ -2,7 +2,7 @@
 LXQt team: http://lxqt.org
 
 Copyright:
-Copyright (c) 2015 LXQt team
+Copyright (c) 2015-2016 LXQt team
 
 License: LGPL-2.1+
 The full text of the licenses can be found in the 'LICENSE' file.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-sudo-0.10.0/CHANGELOG 
new/lxqt-sudo-0.11.0/CHANGELOG
--- old/lxqt-sudo-0.10.0/CHANGELOG  1970-01-01 01:00:00.0 +0100
+++ new/lxqt-sudo-0.11.0/CHANGELOG  2016-09-24 00:47:03.0 +0200
@@ -0,0 +1,64 @@
+
+lxqt-sudo-0.11.0 / 2016-09-24
+=
+
+  * Add README.md
+  * build: Forward translations parameters
+  * ts-files removal (#21)
+  * Remove translations (will be 

commit qterminal for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package qterminal for openSUSE:Factory 
checked in at 2016-10-06 12:44:48

Comparing /work/SRC/openSUSE:Factory/qterminal (Old)
 and  /work/SRC/openSUSE:Factory/.qterminal.new (New)


Package is "qterminal"

Changes:

--- /work/SRC/openSUSE:Factory/qterminal/qterminal.changes  2016-08-17 
12:05:13.0 +0200
+++ /work/SRC/openSUSE:Factory/.qterminal.new/qterminal.changes 2016-10-06 
12:44:52.0 +0200
@@ -1,0 +2,103 @@
+Sun Sep 25 13:30:19 UTC 2016 - mvet...@suse.com
+
+- Update to 0.7.0:
+  * Bump version to 0.7.0 (#262)
+  * Update README.md
+  * Collapse splitter hierarchies containing a single terminal (#254)
+  * Make qterminal.appdata.xml valid (#257)
+  * Add config option for changing window's title/icon
+  * Add support for automatic title & icon modification
+  * Delete Properties instance on exit (#239)
+  * Fix compilation warning related to QXmlStreamReader (#247)
+  * Set the desktopFileName property
+  * Fix typo in the conditional expression
+  * Add location for custom color schemes (#234)
+  * CMake Support changes (#237)
+  * Add keyboard cursor shape setting (#228)
+  * made the .pro file work on openSUSE; #229 (#232)
+  * Fix renaming a tab from the menu
+  * Make the rename current session shortcut work and configurable
+  * build: Use external translations
+  * ts-files removal (#222)
+  * Add pt_BR (Brazilian Portuguese) translation (#215)
+  * Merge pull request #214 from f2404/212_collapse_segfault_fix
+  * Remove noisy qDebug()
+  * Fix jumbled prompt
+  * Add Greek (el) translation
+  * Missing equal symbol for xml template
+  * Delete MainWindow on exit
+  * Link to the current github projects and trackers
+  * Apply context menu to the tab that it was opened over
+  * Close tabs in reverse order
+  * Eliminate memory leaks by closing tabs on exit
+  * Russian translation update
+  * Fix menubar transparency
+  * Fix default settings width
+  * Fix bookmarks widget transparency
+  * Use the same icon for dropdown and regular terminal
+  * Fix license file
+  * Improve README and use markdown
+  * Fixed button focus in close confirmation (resolves #179).
+  * Updated german translation.
+  * Fix Simplified Chinese(zh_CN)
+  * Update japanese translation
+  * Add Japanese translation to *.desktop
+  * fixed #174 XDG_CONFIG_DIRS support - read system wide QSettings
+  *  Fix license issues within qterminal
+  * Add chinese translation
+  * Require Qt 5.2 or higher
+  * fix private header dependency for X11 global shortcuts
+  * fix searching for Qt5 private headers
+  * make only terminal widget transparent, not the parent window
+  * Fix japanese translation
+  * Russian translation update
+  * Add Japanese translation
+  * fixed #160 FTBFS as of commit 4967123
+  * Fixes for Portuguese language
+  * Fixes missing App Window icon
+  * Hungarian translation added
+  * Update qterminal_tr.ts
+  * Create qterminal_tr.ts
+  * do not overwrite settings in migrateSettings
+  * remove fullscreen patch
+  * migrateSettings add size and pos and rm geometry
+  * split geometry into size and position
+  * define saveGeomOnExit in properties.h
+  * add save geometry on exit
+  * Add Alt- shortcuts to all menu items.
+  * Make sure no settings are overwritten in migrateSettings().
+  * Update index property of tabs when tabs are moved by drag-and-drop.
+  * Update german translation.
+  * Corrected terminology in settings (transparency vs. opacity). Now 
transparency instead of opacity is used in the whole application consistently.
+  * Migrate AlwaysShowTabs-setting.
+  * Move migrateSettings()-method to Properties-class and call it *before* 
loadSettings().
+  * Update version number in settings.
+  * Renamed always show tabs setting.
+  * Portuguese update
+  * Add instructions to disable system qxt when building with Qt5.
+  * Changed position of font button in settings.
+  * Changed layout of font-setting to better fit to the other settings in the 
widget.
+  * Appdata file for QTerminal (resolves #60).
+  * Add view-menu actions to mainwindow, to make them available when menu bar 
is hidden.
+  * Add fullscreen mode.
+  * Ignore user-specific project files of QtCreator.
+  * Resolves #115: Store Actions of 'View'-menu in properties too and enable 
shorctus for them.
+  * Set shortcuts for 'Preferences...' and 'Quit' from settings on startup.
+  * Fixed #83: Add menu actions to main window.
+  * Fixed #93: Add 'Toggle Menu' and 'Preferences...' to context menu.
+  * Use GNUInstallDirs in CMakeLists.txt to stop hardcoding paths
+  * Make the left column expandable to get more space for translated text.
+  * Updated german translation
+  * Remove empty file
+  * Remove unnecessarily noisy qDebug calls
+  * Portuguese update
+  * Add Portuguese translation
+  * Update 

commit lxqt-qtplugin for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-qtplugin for openSUSE:Factory 
checked in at 2016-10-06 12:44:15

Comparing /work/SRC/openSUSE:Factory/lxqt-qtplugin (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-qtplugin.new (New)


Package is "lxqt-qtplugin"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-qtplugin/lxqt-qtplugin.changes  
2015-11-13 23:35:44.0 +0100
+++ /work/SRC/openSUSE:Factory/.lxqt-qtplugin.new/lxqt-qtplugin.changes 
2016-10-06 12:44:16.0 +0200
@@ -1,0 +2,18 @@
+Sat Sep 24 21:43:18 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * Add Qt5XdgIconLoader as dependency (#13)
+  * Update README.md
+  * statusnotifieritem: Correctly handle menu
+  * Cleaned up licenses
+  * Use XdgIconLoader library (#10)
+  * xdgIconThemePaths: Use QString::SkipEmptyParts
+  * xdgIconThemePaths: Remove duplicated paths
+  * Adds $XDG_DATA_HOME to the XdgIconThemePaths
+  * Bump year in AUTHORS
+- Add keyring
+- Require pkgconfig(Qt5XdgIconLoader) instead of pkgconfig(Qt5Xdg)
+  because IconLoader has its own package now and got split out
+  of libqt5xdg.
+
+---

Old:

  lxqt-qtplugin-0.10.0.tar.xz

New:

  lxqt-qtplugin-0.11.0.tar.xz
  lxqt-qtplugin-0.11.0.tar.xz.asc
  lxqt-qtplugin.keyring



Other differences:
--
++ lxqt-qtplugin.spec ++
--- /var/tmp/diff_new_pack.0XuavF/_old  2016-10-06 12:44:17.0 +0200
+++ /var/tmp/diff_new_pack.0XuavF/_new  2016-10-06 12:44:17.0 +0200
@@ -17,21 +17,24 @@
 
 
 Name:   lxqt-qtplugin
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:LXQt platform integration plugin for Qt 5
 License:LGPL-2.1+
 Group:  System/GUI/LXQt
-Url:http://www.lxde.org
-Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Url:http://www.lxqt.org
+Source0:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  gcc-c++
-BuildRequires:  kwindowsystem-devel
+BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  libQt5Gui-private-headers-devel
 BuildRequires:  pkgconfig(Qt5Gui)
 BuildRequires:  pkgconfig(Qt5UiTools)
 BuildRequires:  pkgconfig(lxqt) >= %{version}
 BuildRequires:  pkgconfig(dbusmenu-qt5)
+BuildRequires:  pkgconfig(Qt5XdgIconLoader)
 %if 0%{?fedora_version}
 %requires_eqqt5-qtbase-gui
 %else
@@ -44,13 +47,13 @@
 With this plugin, all Qt-based programs can adopt settings of
 LXQt, such as the icon theme.
 
-To use the plugin in Qt 5, we have to export the environment
+To use the plugin in Qt5, we have to export the environment
 variable QT_QPA_PLATFORMTHEME=lxqt. Then every Qt5 program
 can load the theme plugin.
 If, for some unknown reasons, the plugin is not loaded, we can
 debug the plugin by exporting QT_DEBUG_PLUGINS=1.
 Then, Qt5 will print detailed information and error messages
-about all plugins in the console when running any Qt5 programs.)
+about all plugins in the console when running any Qt5 programs.
 
 %prep
 %setup -q

++ lxqt-qtplugin-0.10.0.tar.xz -> lxqt-qtplugin-0.11.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-qtplugin-0.10.0/AUTHORS 
new/lxqt-qtplugin-0.11.0/AUTHORS
--- old/lxqt-qtplugin-0.10.0/AUTHORS2015-11-02 05:35:40.0 +0100
+++ new/lxqt-qtplugin-0.11.0/AUTHORS2016-09-24 00:46:26.0 +0200
@@ -3,8 +3,7 @@
 Hong Jen Yee (PCMan) 
 
 Copyright:
-Copyright (c) 2013-2014 LXQt team
+Copyright (c) 2013-2016 LXQt team
 
 License: LGPL-2.1+
 The full text of the licenses can be found in the 'COPYING' file.
-src/qiconloader_p.h is under LGPL-2.1 or 3 with Digia Qt LGPL Exception 
version 1.1
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-qtplugin-0.10.0/CHANGELOG 
new/lxqt-qtplugin-0.11.0/CHANGELOG
--- old/lxqt-qtplugin-0.10.0/CHANGELOG  1970-01-01 01:00:00.0 +0100
+++ new/lxqt-qtplugin-0.11.0/CHANGELOG  2016-09-24 00:46:26.0 +0200
@@ -0,0 +1,72 @@
+
+lxqt-qtplugin-0.11.0 / 2016-09-24
+=
+
+  * Add Qt5XdgIconLoader as dependency (#13)
+  * Update README.md
+  * statusnotifieritem: Correctly handle menu
+  * Cleaned up licenses
+  * Use XdgIconLoader library (#10)
+  * xdgIconThemePaths: Use QString::SkipEmptyParts
+  * xdgIconThemePaths: Remove duplicated paths
+  * Adds $XDG_DATA_HOME to the XdgIconThemePaths
+  * Bump year in AUTHORS
+
+0.10.0 / 2015-11-02

commit lxqt-session for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-session for openSUSE:Factory 
checked in at 2016-10-06 12:44:27

Comparing /work/SRC/openSUSE:Factory/lxqt-session (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-session.new (New)


Package is "lxqt-session"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-session/lxqt-session.changes
2015-11-13 23:35:46.0 +0100
+++ /work/SRC/openSUSE:Factory/.lxqt-session.new/lxqt-session.changes   
2016-10-06 12:44:28.0 +0200
@@ -1,0 +2,57 @@
+Sat Sep 24 21:55:23 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * lockscreenmanager: always listen to the session provider's lock signal 
(#79)
+  * Update Polish translation
+  * Add README.md
+  * lxqt-config-session: Warn about restart required when removing env variable
+  * Add Catalan translations
+  * lockscreenmanager: use categorized logger
+  * Make screen locking before power actions optional
+  * Add and Update Arabic Translations for Desktop Files
+  * lxqt-session: Replace qCInfo() by qCWarning()
+  * Adds an WITH_LIBUDEV CMake option (#74)
+  * lockscreenmanager: add more log messages
+  * Add logic to lock screen before system sleeps
+  * lxqt-session: Use QLoggingCategory for logging/debug
+  * lxqt-session: Use the base name to compare Wm's names
+  * build: Use external translations
+  * ts-files removal (#72)
+  * Use const references with the foreach iterator
+  * leave: ask or not for confirmation from main dialog
+  * Adjust config dialog's size on startup
+  * Make it compile using QT_USE_QSTRINGBUILDER
+  * Fix lxqt-leave tab order
+  * lxqt-session doesn't copy openbox defaults at session start. startlxqt 
from lxqt-common will copy it.
+  * fixup...centering & spacing
+  * leave: do not set maximum size as minimum size
+  * Use XdgDir to find default path.
+  * Openbox default settings removed.
+  * Load LXQt default settings for Openbox.
+  * UserLocations: An user entered empty string represents the default value
+  * lxqt-config-session: Adds tooltips to the User Directories edits
+  * lxqt-config-session: Replaces Locations by User Directories
+  * Bump year Fix used licenses. lxqt-session is LGPL only
+  * Re-arrange the buttons
+  * lxqt-leave: Reworks window flags
+  * lxqt-leave: Make all buttons of equal width
+  * lxqt-leave: Center the dialog relative to the screen
+  * lxqt-leave: Removes window border and makes it stay on top
+  * lxqt-leave: Make the icons bigger and improves button alignement
+  * Updated german translation.
+  * Fix realloc() usage Check malloc() call result against NULL
+  * Add HR translations
+  * lxqt-session: Update man pages and make session the overview
+  * Update italian translation
+  * Updated Russian translations Removed ru_RU files
+  * Makes the dependency on xdg-user-dirs-update explicit
+  * Fix ending session and stopping modules
+  * upd: lxqt-config-session_hu.ts del: lxt-config-session_hu_HU.ts
+  * Fix desktop file
+  * Make desktop files valid
+  * CMakeLists.txt: Add cmake minimum required version
+- Add keyring
+- Remove 0001-Make-desktop-files-valid.patch: upstreamed
+- Remove 0002-Fix-desktop-file.patch: upstreamed
+
+---

Old:

  0001-Make-desktop-files-valid.patch
  0002-Fix-desktop-file.patch
  lxqt-session-0.10.0.tar.xz

New:

  lxqt-session-0.11.0.tar.xz
  lxqt-session-0.11.0.tar.xz.asc
  lxqt-session.keyring



Other differences:
--
++ lxqt-session.spec ++
--- /var/tmp/diff_new_pack.lJZkKi/_old  2016-10-06 12:44:29.0 +0200
+++ /var/tmp/diff_new_pack.lJZkKi/_new  2016-10-06 12:44:29.0 +0200
@@ -17,47 +17,44 @@
 
 
 Name:   lxqt-session
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:LXQt Session Manager
 License:LGPL-2.1+
 Group:  System/GUI/LXQt
-Url:http://www.lxde.org
-Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
-# Both desktop file patches are upstreamed
-Patch0: 0001-Make-desktop-files-valid.patch
-Patch1: 0002-Fix-desktop-file.patch
+Url:http://www.lxqt.org
+Source0:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  kwindowsystem-devel
+BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  pkgconfig(Qt5UiTools)
 BuildRequires:  pkgconfig(Qt5Xdg)
 BuildRequires:  pkgconfig(lxqt) >= %{version} 
 BuildRequires:  pkgconfig(libudev)
 BuildRequires:  pkgconfig(x11)
 BuildRequires:  

commit pcmanfm-qt for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package pcmanfm-qt for openSUSE:Factory 
checked in at 2016-10-06 12:44:41

Comparing /work/SRC/openSUSE:Factory/pcmanfm-qt (Old)
 and  /work/SRC/openSUSE:Factory/.pcmanfm-qt.new (New)


Package is "pcmanfm-qt"

Changes:

--- /work/SRC/openSUSE:Factory/pcmanfm-qt/pcmanfm-qt.changes2015-11-13 
23:35:47.0 +0100
+++ /work/SRC/openSUSE:Factory/.pcmanfm-qt.new/pcmanfm-qt.changes   
2016-10-06 12:44:42.0 +0200
@@ -1,0 +2,31 @@
+Sat Sep 24 22:10:15 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.1:
+  * Bump version to 0.11.1 (#399)
+  * Extend README.md
+  * Ensure the existence of libfm dir.
+  * Fix the bug that breaks sort folder first option.
+  * Preserve per-folder view settings. * Code refactor and cleanup. * Use 
Fm::FolderConfig internally for storing the per-folder settings.
+  * Per-folder saving of sorting and view mode
+  * Use libfm-qt C++ wrappers instead of the original libfm C API whenever 
possible.
+  * Replace tilde with home path (#371)
+  * Fix -Wswitch warning
+  * Use LXQtCompilerSettings cmake module
+  * Replaces deprecated QStyleOptionViewItemV4
+  * Fixes two typos (#381)
+  * Add Arabic Translations for Desktop Files
+  * I18N: Fix plural string (#374)
+  * Fix some icons for RTL (#366)
+  * Use a wide spread icon theme as fallback for the time beeing (#359)
+  * build: Use external translations
+  * ts-files removal (#352)
+  * Fix memory leak in main window tool bar (#350)
+  * Change "compact icon view" in "icon view" (#349)
+  * Merge pull request #341 from lxde/desktop_sort_settings
+  * Add some tooltips to Pref dialog
+  * Add setting for Desktop con size
+  * Fix a few compiler warnings
+- Split libfm-qt in own package
+- Add keyring
+
+---

Old:

  pcmanfm-qt-0.10.0.tar.xz

New:

  pcmanfm-qt-0.11.1.tar.xz
  pcmanfm-qt-0.11.1.tar.xz.asc
  pcmanfm-qt.keyring



Other differences:
--
++ pcmanfm-qt.spec ++
--- /var/tmp/diff_new_pack.7n903U/_old  2016-10-06 12:44:43.0 +0200
+++ /var/tmp/diff_new_pack.7n903U/_new  2016-10-06 12:44:43.0 +0200
@@ -17,28 +17,29 @@
 
 
 Name:   pcmanfm-qt
-Version:0.10.0
+Version:0.11.1
 Release:0
 Summary:File manager and desktop icon manager
 License:GPL-2.0+
-Group:  System/GUI/LXDE
+Group:  System/GUI/LXQt
 Url:http://www.lxqt.org
-Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source0:
http://downloads.lxqt.org/%{name}/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/%{name}/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  pkg-config
+BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(Qt5Core)
 BuildRequires:  pkgconfig(Qt5DBus)
 BuildRequires:  pkgconfig(Qt5UiTools)
-BuildRequires:  pkgconfig(Qt5Widgets)
 BuildRequires:  pkgconfig(Qt5X11Extras)
-BuildRequires:  pkgconfig(gio-2.0)
-BuildRequires:  pkgconfig(gio-unix-2.0)
-BuildRequires:  pkgconfig(glib-2.0)
-BuildRequires:  pkgconfig(libfm) >= 1.2.0
+BuildRequires:  pkgconfig(Qt5Widgets)
+BuildRequires:  pkgconfig(libfm-qt) >= 0.11.1
+BuildRequires:  pkgconfig(lxqt) >= 0.11.0
+BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  pkgconfig(libmenu-cache) >= 0.4.0
-BuildRequires:  pkgconfig(x11)
+Recommends: %{name}-lang
 Requires(pre): desktop-file-utils
 Requires(post):desktop-file-utils
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -46,29 +47,11 @@
 %description
 PCManFM-Qt is the Qt port of the LXDE file manager PCManFM
 
-%package -n libfm-qt5-2
-Summary:Libfm-Qt libraries
-Group:  System/Libraries
-
-%description -n libfm-qt5-2
-Libfm-Qt is a companion library providing components to build desktop file 
managers
-
-%package -n libfm-qt5-devel
-Summary:Development files for libfm-qt
-Group:  Development/Libraries/C and C++
-Requires:   libfm-qt5-2 >= %{version}
-Requires:   pkg-config
-
-%description -n libfm-qt5-devel
-Libfm-Qt libraries for development
-
-%lang_package
-
 %prep
 %setup -q
 
 %build
-%cmake
+%cmake -DPULL_TRANSLATIONS=No
 make %{?_smp_mflags}
 
 %install
@@ -81,33 +64,11 @@
 %postun
 %desktop_database_postun
 
-%post -n libfm-qt5-2 -p /sbin/ldconfig
-
-%postun -n libfm-qt5-2 -p /sbin/ldconfig
-
 %files
 %defattr(-,root,root)
-%doc AUTHORS COPYING
-%dir %{_datadir}/pcmanfm-qt
+%doc AUTHORS
 %{_bindir}/%{name}
 %{_datadir}/applications/*.desktop
 %{_mandir}/man?/%{name}.*
 
-%files -n libfm-qt5-2
-%defattr(-,root,root)

commit lxqt-powermanagement for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-powermanagement for 
openSUSE:Factory checked in at 2016-10-06 12:44:11

Comparing /work/SRC/openSUSE:Factory/lxqt-powermanagement (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-powermanagement.new (New)


Package is "lxqt-powermanagement"

Changes:

--- 
/work/SRC/openSUSE:Factory/lxqt-powermanagement/lxqt-powermanagement.changes
2015-11-13 23:35:40.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.lxqt-powermanagement.new/lxqt-powermanagement.changes
   2016-10-06 12:44:11.0 +0200
@@ -1,0 +2,24 @@
+Sat Sep 24 21:37:37 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * README.md: Replace dependency XCB with KIdleTime
+  * Idleness Watcher: rely on KIdleTime instead of XCB (#33)
+  * fix indents
+  * Update and extend README.md
+  * Add Catalan translation
+  * Add Arabic Translation for Desktop File
+  * I18N: Fix Plural Strings (#38)
+  * Removes the QEventLoop from the Watcher class
+  * build: Use external translations
+  * ts-files removal (#34)
+  * Bump year Fix licenses, lxqt-powermanagement is LGPL only
+  * Fix source language in Italian translation file
+  * Italian translation update
+  * Update Russian translation Remove ru_RU files
+  * Fix typo in Greek translation
+  * update: lxqt-powermanagement_hu.ts
+  * Add German translation
+- Add keyring
+- Remove BuildRequirs pkgconfig(xcb), got replaced by KF5IdleTime
+
+---

Old:

  lxqt-powermanagement-0.10.0.tar.xz

New:

  lxqt-powermanagement-0.11.0.tar.xz
  lxqt-powermanagement-0.11.0.tar.xz.asc
  lxqt-powermanagement.keyring



Other differences:
--
++ lxqt-powermanagement.spec ++
--- /var/tmp/diff_new_pack.3EqkYo/_old  2016-10-06 12:44:12.0 +0200
+++ /var/tmp/diff_new_pack.3EqkYo/_new  2016-10-06 12:44:12.0 +0200
@@ -17,34 +17,35 @@
 
 
 Name:   lxqt-powermanagement
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:Power Management and Auto-suspend
 License:LGPL-2.1+
-Group:  System/GUI/LXDE-Qt
-Url:http://www.lxde.org
+Group:  System/GUI/LXQt
+Url:http://www.lxqt.org
 Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  kwindowsystem-devel
+BuildRequires:  cmake(KF5WindowSystem)
+BuildRequires:  cmake(KF5IdleTime)
 BuildRequires:  libQt5Gui-private-headers-devel
-BuildRequires:  solid-devel
+BuildRequires:  cmake(KF5Solid)
 BuildRequires:  pkgconfig(Qt5Gui)
 BuildRequires:  pkgconfig(Qt5Svg)
 BuildRequires:  pkgconfig(Qt5UiTools)
 BuildRequires:  pkgconfig(Qt5Xdg)
 BuildRequires:  pkgconfig(lxqt) >= %{version}
-BuildRequires:  pkgconfig(xcb)
+Recommends: %{name}-lang
 Requires(pre): desktop-file-utils
 Requires(post):desktop-file-utils
 %requires_eqlibQt5Gui5
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-LXQt daemon for power management and Auto-suspend
-
-%lang_package
+LXQt daemon for power management and auto-suspend
 
 %prep
 %setup -q
@@ -52,7 +53,7 @@
 #find -name '*desktop.in*' -exec sed -ri 's/(LXQt;)/X-\1/' {} +
 
 %build
-%cmake
+%cmake  -DPULL_TRANSLATIONS=No
 make %{?_smp_mflags}
 
 %install
@@ -75,8 +76,4 @@
 %dir %{_datadir}/icons/hicolor/scalable/devices
 %{_datadir}/icons/hicolor/scalable/devices/*.svg
 
-%files lang
-%defattr(-,root,root)
-%{_datadir}/lxqt/translations
-
 %changelog

++ lxqt-powermanagement-0.10.0.tar.xz -> lxqt-powermanagement-0.11.0.tar.xz 
++
 6417 lines of diff (skipped)




commit lxqt-policykit for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-policykit for openSUSE:Factory 
checked in at 2016-10-06 12:44:02

Comparing /work/SRC/openSUSE:Factory/lxqt-policykit (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-policykit.new (New)


Package is "lxqt-policykit"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-policykit/lxqt-policykit.changes
2015-11-13 23:35:38.0 +0100
+++ /work/SRC/openSUSE:Factory/.lxqt-policykit.new/lxqt-policykit.changes   
2016-10-06 12:44:03.0 +0200
@@ -1,0 +2,19 @@
+Sat Sep 24 21:31:50 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * agentGui: Use default icon
+  * agentGui: Choose current user in identities combo
+  * agentGui: Handle setting the prompt correctly
+  * agent: Handle multiple identities correctly
+  * Update README.md
+  * Fixed typo prefered -> preferred
+  * Add README.md
+  * build: Use external translations
+  * ts-files removal (#21)
+  * Bump year in AUTHORS
+  * Italian translation update
+  * Updated Russian translation Removed ru_RU file
+  * update: lxqt-policykit-agent_hu.ts
+- Add keyring
+
+---

Old:

  lxqt-policykit-0.10.0.tar.xz

New:

  lxqt-policykit-0.11.0.tar.xz
  lxqt-policykit-0.11.0.tar.xz.asc
  lxqt-policykit.keyring



Other differences:
--
++ lxqt-policykit.spec ++
--- /var/tmp/diff_new_pack.0Wdqhd/_old  2016-10-06 12:44:04.0 +0200
+++ /var/tmp/diff_new_pack.0Wdqhd/_new  2016-10-06 12:44:04.0 +0200
@@ -17,48 +17,46 @@
 
 
 Name:   lxqt-policykit
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:PolicyKit authentication agent
 License:LGPL-2.1+
-Group:  System/GUI/LXDE-Qt
-Url:http://www.lxde.org
+Group:  System/GUI/LXQt
+Url:http://www.lxqt.org
 Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
-BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  kwindowsystem-devel
+BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  pkgconfig(Qt5UiTools)
 BuildRequires:  pkgconfig(Qt5Xdg)
 BuildRequires:  pkgconfig(lxqt) >= %{version}
-BuildRequires:  pkgconfig(lxqt-globalkeys) = %{version}
+BuildRequires:  pkgconfig(lxqt-globalkeys) >= %{version}
 BuildRequires:  pkgconfig(polkit-agent-1)
 BuildRequires:  pkgconfig(polkit-qt5-core-1)
+Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 PolicyKit authentication agent for LXQt
 
-%lang_package
-
 %prep
 %setup -q
 
 %build
-%cmake
+%cmake -DPULL_TRANSLATIONS=No
+
 make %{?_smp_mflags}
 
 %install
 %cmake_install
-%fdupes -s %{buildroot}%{_datadir}
+install -Dm 0644 man/%{name}-agent.1 
%{buildroot}%{_mandir}/man1/%{name}-agent.1
 
 %files
 %defattr(-,root,root)
 %doc AUTHORS LICENSE
 %{_bindir}/lxqt-policykit-agent
-
-%files lang
-%defattr(-,root,root)
-%{_datadir}/lxqt/translations
+%{_mandir}/man?/%{name}-agent.?%{ext_man}  
 
 
 %changelog

++ lxqt-policykit-0.10.0.tar.xz -> lxqt-policykit-0.11.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-policykit-0.10.0/.gitignore 
new/lxqt-policykit-0.11.0/.gitignore
--- old/lxqt-policykit-0.10.0/.gitignore2015-10-31 01:25:38.0 
+0100
+++ new/lxqt-policykit-0.11.0/.gitignore2016-09-24 00:46:00.0 
+0200
@@ -1 +1,2 @@
 build
+translations/lxqt-policykit
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-policykit-0.10.0/AUTHORS 
new/lxqt-policykit-0.11.0/AUTHORS
--- old/lxqt-policykit-0.10.0/AUTHORS   2015-10-31 01:25:38.0 +0100
+++ new/lxqt-policykit-0.11.0/AUTHORS   2016-09-24 00:46:00.0 +0200
@@ -4,7 +4,7 @@
 
 Copyright:
 Copyright (c) 2010-2012 Razor team
-Copyright (c) 2012-2014 LXQt team
+Copyright (c) 2012-2016 LXQt team
 
 License: LGPL-2.1+
 The full text of the licenses can be found in the 'COPYING' file.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-policykit-0.10.0/CHANGELOG 
new/lxqt-policykit-0.11.0/CHANGELOG
--- old/lxqt-policykit-0.10.0/CHANGELOG 1970-01-01 01:00:00.0 +0100
+++ new/lxqt-policykit-0.11.0/CHANGELOG 2016-09-24 00:46:00.0 +0200
@@ -0,0 +1,80 @@
+
+lxqt-policykit-0.11.0 / 2016-09-24
+==
+
+  * agentGui: Use default icon
+  * agentGui: Choose current user in identities combo
+  * agentGui: Handle setting the 

commit lxqt-notificationd for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-notificationd for 
openSUSE:Factory checked in at 2016-10-06 12:43:40

Comparing /work/SRC/openSUSE:Factory/lxqt-notificationd (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-notificationd.new (New)


Package is "lxqt-notificationd"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-notificationd/lxqt-notificationd.changes
2016-08-05 18:16:25.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.lxqt-notificationd.new/lxqt-notificationd.changes   
2016-10-06 12:43:39.0 +0200
@@ -1,0 +2,18 @@
+Sat Sep 24 21:10:14 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * Update and extend README.md
+  * Add Catalan translation
+  * build: Use external translations
+  * ts-files removal (#50)
+  * Clean up qDebugs/comments in notification.cpp
+  * config: Use our specific icon for demo
+  * Fix used licenses in AUTHORS, lxqt-notificationd is pure LGPL Bump year in 
AUTHORS
+  * Italian translation update
+  * Updated Russian translation Removed ru_RU files
+  * notification: Default icon
+  * notification: Fill background
+  * update lxqt-config-notificationd_hu.ts
+  * Update lxqt-config-notificationd_it.ts
+
+---

Old:

  lxqt-notificationd-0.10.0.tar.xz

New:

  lxqt-notificationd-0.11.0.tar.xz
  lxqt-notificationd-0.11.0.tar.xz.asc
  lxqt-notificationd.keyring



Other differences:
--
++ lxqt-notificationd.spec ++
--- /var/tmp/diff_new_pack.IWVTkJ/_old  2016-10-06 12:43:41.0 +0200
+++ /var/tmp/diff_new_pack.IWVTkJ/_new  2016-10-06 12:43:41.0 +0200
@@ -17,20 +17,23 @@
 
 
 Name:   lxqt-notificationd
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:LXQt Notification daemon
 License:LGPL-2.1+
-Group:  System/GUI/LXDE-Qt
-Url:http://www.lxde.org
+Group:  System/GUI/LXQt
+Url:http://www.lxqt.org
 Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  kwindowsystem-devel
+BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  pkgconfig(Qt5UiTools)
 BuildRequires:  pkgconfig(Qt5Xdg)
 BuildRequires:  pkgconfig(lxqt) >= %{version} 
+Recommends: %{name}-lang
 Requires(pre): desktop-file-utils
 Requires(post):desktop-file-utils
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -38,15 +41,13 @@
 %description
 The LXQt Notification daemon
 
-%lang_package
-
 %prep
 %setup -q
 # Changing LXQt into X-LXQt in desktop files to be freedesktop compliant and 
shut rpmlint warnings
 #find -name '*desktop.in*' -exec sed -ri 's/(LXQt;)/X-\1/' {} +
 
 %build
-%cmake
+%cmake -DPULL_TRANSLATIONS=No
 make %{?_smp_mflags}
 
 %install
@@ -66,8 +67,4 @@
 %{_bindir}/lxqt-config-notificationd
 %{_datadir}/applications/lxqt-config-notificationd.desktop
 
-%files lang
-%defattr(-,root,root)
-%{_datadir}/lxqt/translations
-
 %changelog

++ lxqt-notificationd-0.10.0.tar.xz -> lxqt-notificationd-0.11.0.tar.xz 
++
 1750 lines of diff (skipped)




commit lxqt-openssh-askpass for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-openssh-askpass for 
openSUSE:Factory checked in at 2016-10-06 12:43:52

Comparing /work/SRC/openSUSE:Factory/lxqt-openssh-askpass (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-openssh-askpass.new (New)


Package is "lxqt-openssh-askpass"

Changes:

--- 
/work/SRC/openSUSE:Factory/lxqt-openssh-askpass/lxqt-openssh-askpass.changes
2015-11-13 23:35:36.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.lxqt-openssh-askpass.new/lxqt-openssh-askpass.changes
   2016-10-06 12:43:53.0 +0200
@@ -1,0 +2,15 @@
+Sat Sep 24 21:13:57 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * Rework README.md
+  * build: Use external translations
+  * ts-files removal (#19)
+  * Fix typo in German translation (#18)
+  * Bump year Fix licenses, lxqt-openssh-askpass is LGPL only
+  * Italian translation update
+  * Fix target language in translation file template
+  * Remove ru_RU translation file
+  * new: lxqt-openssh-askpass_hu.ts
+- Add keyring
+
+---

Old:

  lxqt-openssh-askpass-0.10.0.tar.xz

New:

  lxqt-openssh-askpass-0.11.0.tar.xz
  lxqt-openssh-askpass-0.11.0.tar.xz.asc
  lxqt-openssh-askpass.keyring



Other differences:
--
++ lxqt-openssh-askpass.spec ++
--- /var/tmp/diff_new_pack.9MtvkN/_old  2016-10-06 12:43:54.0 +0200
+++ /var/tmp/diff_new_pack.9MtvkN/_new  2016-10-06 12:43:54.0 +0200
@@ -17,43 +17,40 @@
 
 
 Name:   lxqt-openssh-askpass
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:Openssh password tool
 License:GPL-2.0+ and LGPL-2.1+
-Group:  System/GUI/LXDE-Qt
-Url:http://www.lxde.org
+Group:  System/GUI/LXQt
+Url:http://www.lxqt.org
 Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
-BuildRequires:  fdupes
-BuildRequires:  kwindowsystem-devel
+BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  pkgconfig(Qt5UiTools)
 BuildRequires:  pkgconfig(lxqt) >= %{version}
+Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 Tool that will prompt user for password when using openssh in lxqt
 
-%lang_package
-
 %prep
 %setup -q
 
 %build
-%cmake
+%cmake -DPULL_TRANSLATIONS=No
 make %{?_smp_mflags}
 
 %install
 %cmake_install
-%fdupes -s %{buildroot}%{_datadir}
+install -Dm 0644 man/%{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1   
 
 
 %files
 %defattr(-,root,root)
 %doc AUTHORS LICENSE README.md
 %{_bindir}/%{name}
-
-%files lang
-%defattr(-,root,root)
-%{_datadir}/lxqt/translations
+%{_mandir}/man?/%{name}.?%{ext_man}
 
 
 %changelog

++ lxqt-openssh-askpass-0.10.0.tar.xz -> lxqt-openssh-askpass-0.11.0.tar.xz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-openssh-askpass-0.10.0/.gitignore 
new/lxqt-openssh-askpass-0.11.0/.gitignore
--- old/lxqt-openssh-askpass-0.10.0/.gitignore  1970-01-01 01:00:00.0 
+0100
+++ new/lxqt-openssh-askpass-0.11.0/.gitignore  2016-09-24 00:45:34.0 
+0200
@@ -0,0 +1,2 @@
+build
+translations/lxqt-openssh-askpass
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-openssh-askpass-0.10.0/AUTHORS 
new/lxqt-openssh-askpass-0.11.0/AUTHORS
--- old/lxqt-openssh-askpass-0.10.0/AUTHORS 2015-10-31 01:24:28.0 
+0100
+++ new/lxqt-openssh-askpass-0.11.0/AUTHORS 2016-09-24 00:45:34.0 
+0200
@@ -4,7 +4,7 @@
 
 Copyright:
 Copyright (c) 2010-2012 Razor team
-Copyright (c) 2012-2014 LXQt team
+Copyright (c) 2012-2016 LXQt team
 
-License: GPL-2 and LGPL-2.1+
+License: LGPL-2.1+
 The full text of the licenses can be found in the 'COPYING' file.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lxqt-openssh-askpass-0.10.0/CHANGELOG 
new/lxqt-openssh-askpass-0.11.0/CHANGELOG
--- old/lxqt-openssh-askpass-0.10.0/CHANGELOG   1970-01-01 01:00:00.0 
+0100
+++ new/lxqt-openssh-askpass-0.11.0/CHANGELOG   2016-09-24 00:45:34.0 
+0200
@@ -0,0 +1,74 @@
+
+lxqt-openssh-askpass-0.11.0 / 2016-09-24
+
+
+  * Rework README.md
+  * build: Use external translations
+  * ts-files removal (#19)
+  * Fix typo in German translation (#18)
+  * Bump year Fix licenses, lxqt-openssh-askpass is LGPL only
+  * Italian translation update
+  * Fix target language in translation file 

commit lxqt-panel for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-panel for openSUSE:Factory 
checked in at 2016-10-06 12:43:58

Comparing /work/SRC/openSUSE:Factory/lxqt-panel (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-panel.new (New)


Package is "lxqt-panel"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-panel/lxqt-panel.changes2016-06-02 
09:40:06.0 +0200
+++ /work/SRC/openSUSE:Factory/.lxqt-panel.new/lxqt-panel.changes   
2016-10-06 12:43:58.0 +0200
@@ -1,0 +2,154 @@
+Sat Sep 24 21:26:27 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * Update README.md: Reflect changes introduced in 1c22479
+  * CMakeLists: Fail for unmet dependencies
+  * mainmenu: Remove setting base style in StyleChange
+  * mainmenu: Workaround transparent search
+  * mainmenu: Dispose old menu first when building new
+  * Add README.md
+  * sensors: Add default bar scale
+  * sensors: Check for existence of the max value
+  * sensors: Add minor code optimization
+  * mainmenu: Handle QAction disposal correctly
+  * panel: Don't use autoFillBackground
+  * Plugin: Fix FTBFS for older Qt versions
+  * mainmenu: Fix show/hide actions after menu rebuild
+  * Statusnotifier: Remove setParent on StatusNotifierMenu.
+  * Add XKB_COMMON_X11_INCLUDE_DIRS
+  * panel: Remove/deprecate plugin-screensaver (#363)
+  * Add and Update Arabic Translations for Desktop Files
+  * Fix updating panel geometry on screen size change
+  * panel: Fix screen number config change saving
+  * Separate a String for I18N Enhancement
+  * plugin: Force config dialog activation/raise
+  * plugin: Fix crossreferencing of config dialogs
+  * panel: Dispose unneeded menu
+  * panel: Destroy panel's config dialog
+  * showPopupMenu: Remove extraneous setParent() call (#359)
+  * statusnotifier: fix popup position on right click
+  * desktopswitch: Take layoutDirection into account
+  * taskbar: Remove orientation specific logic for DnD
+  * LXQtPanelLayout: Take layoutDirection into account
+  * taskbar: Remove forgotten debug
+  * taskbar: Consider layoutDirection for DnD
+  * panel: Optimize search a bit
+  * plugin-volume: Avoid an buffer overflow
+  * Respect the OnlyShowIn property for menu entries when using menu-cache 
(#351)
+  * kbindicator-plugin: fix linking with libxcb-1.12
+  * plugin-volume: Handle errors when trying to determine the next card
+  * Clean up CMakeLists.txt
+  * plugin/directorymenu: Removes no use code (#350)
+  * build: Forward translations parameters
+  * ts-files removal (#346)
+  * Fix memory leaks
+  * Use const references with the foreach iterator
+  * Small fix
+  * statusnotifier: Fix showing icons in menu
+  * kbindicator: (Re)Add .desktop translations
+  * Update desktopswitchconfiguration.ui
+  * panel: (Re)Add translations dir
+  * Revert unintended *.desktop files removal
+  * Remove translations (can be pulled in build time)
+  * Use external translations
+  * Update lxqt-panel_it.ts
+  * Add documentation/comments for PanelPluginsModel.
+  * Fix segfault on plugin initialization (#338)
+  * translations: updated german translation (#323)
+  * plugin-mainmenu: update mainmenu_it.ts (#337)
+  * Russian translation update
+  * mainmenu: Use style sheet to override icon
+  * plugins: Change "repolish" logic
+  * mainmenu: Reduce delay of popup when using shortcut
+  * volume: Remove debug
+  * plugins: Don't unload -> avoid dangling resources
+  * Added new translated strings.
+  * Added missing context for lupdate.
+  * Updated german translation.
+  * Ask for confirmation when removing a panel
+  * panel: Add "Lock Panel" functionality
+  * fix updating panel geometry on screen changes
+  * Try find a free position when adding a new panel
+  * LXQtPanelApplication: Use D-Pointers
+  * Animate auto-hiding panels.
+  * Add QT_USE_QSTRINGBUILDER to the compile definitions
+  * tray: Fix SEGFAULT on stop
+  * mainmenu: Fix visual search problems
+  * mainmenu: Remove duplicates from search
+  * mainmenu: Add new configuration options for search
+  * mainmenu: Workadound QLineEdit's wakups(QTBUG-52021)
+  * mainmenu: Add configurable way of search
+  * taskbar: separate adding from changing windows
+  * plugins: Make buttons flat for cleaner look
+  * mainmenu: Fix search interacion
+  * mainmenu: Add search/hide possibility
+  * taskbar: Add show icon by WindowClass to config
+  * taskbar: Use icon from theme (based on windowClass)
+  * panellayout: Do not allow oversized plugins
+  * panellayout: Avoid plugin margins
+  * PluginSettings: Make settings object/class public
+  * Bump year Fix licenses: lxqt-panel is pure LGPL
+  * worldclock: Fix possible SEGFAULT
+  * Add comments for ILXQtPanel and LXQtPanel.
+  * plugin-taskbar: fix German translation of configuration dialogue
+  * panel: Correct PanelPluginsModel logic
+  * volume: Avoid 

commit lxqt-config for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-config for openSUSE:Factory 
checked in at 2016-10-06 12:43:27

Comparing /work/SRC/openSUSE:Factory/lxqt-config (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-config.new (New)


Package is "lxqt-config"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-config/lxqt-config.changes  2016-03-16 
10:35:51.0 +0100
+++ /work/SRC/openSUSE:Factory/.lxqt-config.new/lxqt-config.changes 
2016-10-06 12:43:29.0 +0200
@@ -1,0 +2,78 @@
+Sat Sep 24 20:48:55 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * appearance: Avoid blocking when setting wallpaper
+  * appearance: Do (not) change wallpaper with theme
+  * all: Remove XdgIcon & XdgIconLoader usage
+  * brightness: Add change confirmation dialog
+  * brightness: Correct indentation
+  * Update README.md
+  * Replaces deprecated QStyleOptionViewItemVx
+  * Add Catalan translations
+  * Add and Update Arabic Translations for Desktop Files
+  * lxqt-config-monitor: Correct loadsettings.cpp
+  * lxqt-config-monitor: Use QGuiApplication
+  * I18n: Fix Plural String (#94)
+  * fixed crash when selecting "extended view" while second monitor is off 
(#91)
+  * build: Add optional build for subcomponents
+  * lxqt-config-appearance: Fix a null pointer dereference (#93)
+  * Add README.md
+  * lxqt-config-brightness: Remove compiler warning
+  * lxqt-config-brightness: Add libxcb dependency
+  * lxqt-config-brightness: Use *_LDFLAGS in target_link_libraries
+  * lxqt-config-appearance: Use fewer XdgIcon* stuff (#92)
+  * lxqt-config-appearance: Use the new XdgIconLoader library (#90)
+  * build: Use external translations (#89)
+  * ts-files removal (#88)
+  * Use const references with the foreach iterator
+  * translations: russian translation update (#85)
+  * font config: make it possible to write custom fontconfig files (#83)
+  * view: Use icon/decoration size based on styling
+  * Set grid size according to font and icon sizes.
+  * lxqt-config-brightness: Use arrow keys to change settings.
+  * Desktop file translation to Spanish added.
+  * lxqt-config-brigness: Set brightness value by command line.
+  * Removed not needed LICENSE
+  * lxqt-config-brightness: Increase or decrease brightness using command line.
+  * Create lxqt-config-locale_it.desktop
+  * Rename from lxqt-config-brightness-settings to  lxqt-config-brightness.
+  * lxqt-config-brightness-settings: Some files changes their licenses from 
GPL to LGPL.
+  * lxqt-config-brightness-settings lxqt translations module added.
+  * lxqt-config-brightness-settings added.
+  * fix typo skiping -> skipping
+  * build: Fix FTBFS by reverting the @a7220cb
+  * Bum year in AUTHORS
+  * lxqt-config-brightness-settings has been added. It can change brightness 
and gamma. It's a X11 tool because libKScreen can not change brightness or 
gamma yet.
+  * lxqt-config: Load/store window size on begin/end
+  * categorizedview: Use correct signature
+  * lxqt-config: Remove homemade "activation logic"
+  * Settings are saved in QSettings format instead JSON format.
+  * Set position widget used bad scale. The real widget size is not set until 
the widget is shown.
+  * Remove blue square in GUI position
+  * Fast options added.
+  * GUI only lets one primary output.
+  * Icons aren't installed.
+  * Check KScreen reply is OK. Changes in interface.
+  * liblxqt is used to write autostart entry.
+  * Don't track IDE settings
+  * KScreen is slow loading screen modes at starting. Wait for modes ready.
+  * KScreen sometimes changes id of modes. If mode exists and it is OK,
 settings will be applied.
+  * Save settings dialog added.
+  * Initial support for different paths of xkb base.lst in different OSes.
+  * A couple of bug fixes Check if the memory was allocated after malloc() and 
realloc() calls Fix typo
+  * Update german translation
+  * Fix warning on translation
+  * Replace slang with a more traditional wording
+  * build: Use CMAKE_INSTALL_FULL_LIBDIR for RPATH
+  * Fixes an FTBFS on lxqt-config-locale_ru.desktop
+  * Update Russian translations
+  * apearance: Support "System" theme preview
+  * Italian translation update
+  * lxqt-config: Add CTRL+Q shortcut for closing
+  *_hu.ts files updated, *hu_HU.ts files deleted
+  * Mkdir $XDG_CONFIG_HOME/autostart or ~/.config/autostart, if not exists.
+  * lxqt-config-appearance: Choose the icon with the matching size
+- Remove lxqt-config-monitor_save-config-in-proper-place.patch: upstreamed
+- Add keyring
+
+---

Old:

  lxqt-config-0.10.0.tar.xz
  lxqt-config-monitor_save-config-in-proper-place.patch

New:

  lxqt-config-0.11.0.tar.xz
  lxqt-config-0.11.0.tar.xz.asc
  lxqt-config.keyring


commit lxqt-common for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-common for openSUSE:Factory 
checked in at 2016-10-06 12:43:21

Comparing /work/SRC/openSUSE:Factory/lxqt-common (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-common.new (New)


Package is "lxqt-common"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-common/lxqt-common.changes  2016-06-03 
16:38:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.lxqt-common.new/lxqt-common.changes 
2016-10-06 12:43:22.0 +0200
@@ -1,0 +2,50 @@
+Sat Sep 24 20:19:10 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * Update and extend README.md
+  * themes-system: Add "background" property to panel
+  * startlxqt: Consider LXQT_DEFAULT_OPENBOX_CONFIG
+  * startlxqt: Honor the pre-defined SAL_USE_VLCPLUGIN
+  * themes: Remove Screensaver styles
+  * Replace lxqt-rc.xml with latest openbox version
+  * Move Italian desktop entry to correct path
+  * startlxqt: Consider pre-exising LXDE OB config also
+  * Create lxqt-powermanagement_it.desktop
+  * build: Revert @6d6d2bef54
+  * build: Add xmessage as "dependency"
+  * Openbox: Fix informational message about adoption of rc.xml
+  * themes: Take layoutDirection into account
+  * lxqt-rc.xml: Change default config install path
+  * startlxqt: Copy existing openbox config preferably
+  * Fix the search textfield style for all themes (#52)
+  * PCManFM-Qt: Update default wallpaper (#49)
+  * Added style for the ColorPicker plugin.
+  * Improves changed Openbox default path startup message (#51)
+  * Disable gtk+ 3 overlay scrollbars by default.
+  * Fix bg-fg color swapping in Frost (#50)
+  * Don't add XDG_DATA_HOME to XDG_DATA_DIRS (#47)
+  * Merge pull request #45 from lxde/menu-comment
+  * Message about Openbox default path changed.
+  * Warning message about openbox settings path changed.
+  * startlxqt: Force XDG_CONFIG_DIRS to contain @LXQT_ETC_XDG_DIR@
+  * theme system: Force no icon for main menu
+  * Merge pull request #48 from lxde/pcmanfm-qt-sort-order
+  * Copy openbox defaults at session start.
+  * First experiment in theming the new search menu feature.
+  * Rename openbox/rc.xml to openbox/lxqt-openbox-rc.xml
+  * Openbox aero snap using mouse wheel over title bar.
+  * Settings Openbox updated.
+  * Screenshot (Shift+Print), file manager (ctl+Alt+e) and web browser 
(Ctl+atl+i) key shortcuts added.
+  * Default key shortcuts added to lxqt-globalkeysd.
+  * icons: Add icon "lxqt"
+  * Wallpaper updated. Lighter and with the hummingbird for some identity.
+  * Use the system palette to change the main colors, this will make the theme 
more integrated with the whole environment. Fixed ugly buttons in the volume 
applet.
+  * Use lxqt-sudo in pcmanfm-qt config file by default.
+  * Themes: adjust main menu icon in Light
+  * themes: Add system theme (no theme)
+  * CMakeLists: Use LXQT_GRAPHICS_DIR for graphics
+  * lxqt-applications.menu: remove accidentally added topics from "System 
Tools"
+  * Add startlxqt man page
+- Remove lxqt-common-0.9.1-pcmanfm-qt-use-gnomesu-not-gksu.patch: we have 
lxqt-sudo now
+
+---

Old:

  lxqt-common-0.10.0.tar.xz
  lxqt-common-0.9.1-pcmanfm-qt-use-gnomesu-not-gksu.patch

New:

  lxqt-common-0.11.0.tar.xz
  lxqt-common-0.11.0.tar.xz.asc
  lxqt-common.keyring



Other differences:
--
++ lxqt-common.spec ++
--- /var/tmp/diff_new_pack.Nvx6S7/_old  2016-10-06 12:43:24.0 +0200
+++ /var/tmp/diff_new_pack.Nvx6S7/_new  2016-10-06 12:43:24.0 +0200
@@ -17,22 +17,22 @@
 
 
 Name:   lxqt-common
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:Common Data File
 License:GPL-2.0+ and LGPL-2.1+
-Group:  System/GUI/LXDE-Qt
+Group:  System/GUI/LXQt
 Url:http://www.lxde.org
 Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
-# t...@gmx.com -- Use gnomesu for pcmanfm-qt SuCommand [System] setting, gksu 
is not available in openSUSE
-Patch1: lxqt-common-0.9.1-pcmanfm-qt-use-gnomesu-not-gksu.patch
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  kwindowsystem-devel
+BuildRequires:  cmake(KF5WindowSystem)
+BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(Qt5UiTools)
 BuildRequires:  pkgconfig(lxqt) >= %{version}
-Requires:   libgnomesu
 Requires:   oxygen-icon-theme
 Requires(post): desktop-file-utils
 Requires(pre):  desktop-file-utils
@@ -41,11 +41,10 @@
 BuildArch:  noarch
 
 %description
-Common data file required for running an 

commit lximage-qt for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lximage-qt for openSUSE:Factory 
checked in at 2016-10-06 12:43:45

Comparing /work/SRC/openSUSE:Factory/lximage-qt (Old)
 and  /work/SRC/openSUSE:Factory/.lximage-qt.new (New)


Package is "lximage-qt"

Changes:

--- /work/SRC/openSUSE:Factory/lximage-qt/lximage-qt.changes2014-11-05 
15:55:05.0 +0100
+++ /work/SRC/openSUSE:Factory/.lximage-qt.new/lximage-qt.changes   
2016-10-06 12:43:45.0 +0200
@@ -1,0 +2,54 @@
+Sat Sep 24 19:58:30 UTC 2016 - mvet...@suse.com
+
+- Update to 0.5.0:
+  * Bump version to 0.5.0 (#67)
+  * Remove Core and Qt from Categories in desktop file (#64)
+  * Extend README.md
+  * Fix broken compatibility introduced by libfm-qt API changes. This closes 
lxde/lximage-qt#63.
+  * Add Catalan translations
+  * Quieten compiler warning
+  * Code cleanup
+  * Use LXQtCompilerSettings cmake module
+  * Treat SVG files separately as SVG images
+  * build: Update translations based on *.ui
+  * Fix typo in Portuguese translation for desktop file
+  * Fix typo in German translation for desktop file (#55)
+  * build: Use external translations (#54)
+  * ts-files removal (#53)
+  * Hide cursor smartly in fullscreen mode
+  * build: Use liblxqt's TranslateDesktop module
+  * Adds support for GIF animation.
+  * Implement an EOG-like behavior on starting By clicking on an image for the 
first time, the user wants to see it clearly with lximage-qt. So, the following 
behavior is implemented here:
+  * Add --version command line option
+  * Fix missing Russian translation in desktop file
+  * Fix memory leak if taking screenshot with cursor
+  * Polish translation updated
+  * Another update
+  * Improved Russian translation - thanks to uazure
+  * Fix typo
+  * Add Russian translation
+  * Italian translation update
+  * CMake: Adapt to libfm-qt Targets
+  * Turn on C++11 support. This closes bug lxde/lximage-qt #36.
+  * Exec should have an argument
+  * all GPL files are (or any later)
+  * Add release script
+  * Update translations
+  * Set the color table properly for scaled images
+  * Add Greek (el) translation Remove needless country variant from language 
code
+  * Corrected language code (de_DE -> de) of german translation, marked 
translations as done.
+  * replace tabs with spaces
+  * remove trailing spaces
+  * replace glib with Qt for command-line parsing
+  * Don't save file in private mode
+  * Prevents the slideshow timeout to be set to 0 in the UI
+  * Correctly include CMake modules in intree/superbuild mode
+  * Remove lximage-qt from the Utilities category
+  * Update README
+  * Update .gitignore
+  * Hungarian translations added
+  * save and restore window size and maximized state
+- Add keyring
+- Remove lximage-qt-0.2.0-fix_desktop_file.patch: got upstreamed
+
+---

Old:

  lximage-qt-0.2.0-fix_desktop_file.patch
  lximage-qt-0.3.0.tar.xz

New:

  lximage-qt-0.5.0.tar.xz
  lximage-qt-0.5.0.tar.xz.asc
  lximage-qt.keyring



Other differences:
--
++ lximage-qt.spec ++
--- /var/tmp/diff_new_pack.Sz5A8L/_old  2016-10-06 12:43:47.0 +0200
+++ /var/tmp/diff_new_pack.Sz5A8L/_new  2016-10-06 12:43:47.0 +0200
@@ -17,30 +17,34 @@
 
 
 Name:   lximage-qt
-Version:0.3.0
+Version:0.5.0
 Release:0
-Summary:LXQT Image Viewer
+Summary:LXQt Image Viewer
 License:GPL-2.0+
-Group:  System/GUI/LXDE-Qt
-Url:http://www.lxde.org
-Source: %{name}-%{version}.tar.xz
-Patch0: %{name}-0.2.0-fix_desktop_file.patch
-BuildRequires:  cmake
+Group:  System/GUI/LXQt
+Url:http://www.lxqt.org
+Source: 
https://downloads.lxqt.org/%{name}/%{version}/%{name}-%{version}.tar.xz
+Source1:
https://downloads.lxqt.org/%{name}/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
+BuildRequires:  cmake >= 3.0.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  pkg-config
-BuildRequires:  pkgconfig(Qt5Core)
-BuildRequires:  pkgconfig(Qt5Widgets)
+BuildRequires:  pkgconfig
+BuildRequires:  update-desktop-files
+BuildRequires:  cmake(KF5WindowSystem)
+BuildRequires:  cmake(Qt5LinguistTools)
+BuildRequires:  pkgconfig(Qt5DBus)
 BuildRequires:  pkgconfig(Qt5PrintSupport)
+BuildRequires:  pkgconfig(Qt5Widgets)
 BuildRequires: pkgconfig(Qt5X11Extras)
-BuildRequires:  libqt5-linguist-devel
-BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(libexif)
-BuildRequires:  pkgconfig(libfm) >= 1.2.0
-BuildRequires:  pkgconfig(libfm-qt5)
+BuildRequires:  pkgconfig(libfm-qt)
+BuildRequires:  pkgconfig(libmenu-cache)
+BuildRequires:  

commit lxqt-about for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-about for openSUSE:Factory 
checked in at 2016-10-06 12:43:17

Comparing /work/SRC/openSUSE:Factory/lxqt-about (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-about.new (New)


Package is "lxqt-about"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-about/lxqt-about.changes2015-11-13 
23:35:32.0 +0100
+++ /work/SRC/openSUSE:Factory/.lxqt-about.new/lxqt-about.changes   
2016-10-06 12:43:17.0 +0200
@@ -1,0 +2,23 @@
+Sat Sep 24 20:32:58 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0: 
+  * Extend README.md
+  * translation: Fix language in _nl.desktop
+  * Create lxqt-about_nl.desktop
+  * Add translators_ca.info
+  * Add Catalan translation
+  * Add Arabic Translation for Desktop File and SafaAlFulaij As a Translator 
(#30)
+  * .gitignore: Cleanup
+  * build: Use external translations
+  * ts-files removal (#28)
+  * Bump AUTHORS year Fix license, lxqt-about is LGPL only
+  * Italian translation update
+  * Russian translation update
+  * Updated german translation.
+  * French translation:
+  * Minor update of README.md
+  * Delete country specific files
+  * Add copyright symbol © to ‘About’ tab
+  * Add simple README.md file
+
+---

Old:

  lxqt-about-0.10.0.tar.xz

New:

  lxqt-about-0.11.0.tar.xz
  lxqt-about-0.11.0.tar.xz.asc
  lxqt-about.keyring



Other differences:
--
++ lxqt-about.spec ++
--- /var/tmp/diff_new_pack.QOrnSo/_old  2016-10-06 12:43:19.0 +0200
+++ /var/tmp/diff_new_pack.QOrnSo/_new  2016-10-06 12:43:19.0 +0200
@@ -17,26 +17,27 @@
 
 
 Name:   lxqt-about
-Version:0.10.0
+Version:0.11.0
 Release:0
-Summary:About Dialog
+Summary:LXQt About Dialog
 License:GPL-2.0+ and LGPL-2.1+
 Group:  System/GUI/LXQt
 Url:http://www.lxde.org
 Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
-BuildRequires:  kwindowsystem-devel
+BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  pkgconfig(Qt5UiTools)
 BuildRequires:  pkgconfig(lxqt) >= %{version}
 BuildRequires:  pkgconfig(Qt5Xdg) >= 1.3.0
+Recommends: %{name}-lang
 Requires(post): desktop-file-utils
 Requires(pre):  desktop-file-utils
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-About dialog for lxqt
-
-%lang_package
+About dialog for LXQt
 
 %prep
 %setup -q
@@ -44,7 +45,7 @@
 #find -name '*desktop.in*' -exec sed -ri 's/(LXQt;)/X-\1/' {} +
 
 %build
-%cmake
+%cmake -DPULL_TRANSLATIONS=No
 make %{?_smp_mflags}
 
 %install
@@ -62,10 +63,4 @@
 %{_bindir}/%{name}
 %{_datadir}/applications/*.desktop
 
-%files lang
-%defattr(-,root,root)
-%dir %{_datadir}/lxqt
-%dir %{_datadir}/lxqt/translations
-%{_datadir}/lxqt/translations/%{name}
-
 %changelog

++ lxqt-about-0.10.0.tar.xz -> lxqt-about-0.11.0.tar.xz ++
 5722 lines of diff (skipped)




commit lxqt-globalkeys for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-globalkeys for openSUSE:Factory 
checked in at 2016-10-06 12:43:33

Comparing /work/SRC/openSUSE:Factory/lxqt-globalkeys (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-globalkeys.new (New)


Package is "lxqt-globalkeys"

Changes:

--- /work/SRC/openSUSE:Factory/lxqt-globalkeys/lxqt-globalkeys.changes  
2015-11-13 23:35:34.0 +0100
+++ /work/SRC/openSUSE:Factory/.lxqt-globalkeys.new/lxqt-globalkeys.changes 
2016-10-06 12:43:33.0 +0200
@@ -1,0 +2,27 @@
+Sat Sep 24 21:00:58 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * Add README.md
+  * Add Catalan translation
+  * daemon: Use QDBusServiceWatcher
+  * Fix typo in German translation for desktop file (#38)
+  * build: Use external translations
+  * ts-files removal (#35)
+  * Improve foreach iterator use
+  * daemon/core: Optimize Core startup string stuff
+  * Client: Fix memory leak (static data)
+  * Fix untranslated string in French translation
+  * fix reseting the state of the edit dialog
+  * Default configs from /etc/xdg/lxqt must be loaded.
+  * static_cast, fixes FTBFS for the Hurd
+  * lxqt-globalkeys is LGPL only, there are no GPL files in it
+  * Update italian translation, remove country-specific variant
+  * Italian translation update
+  * Update Russian translation Remove ru_RU files
+  * Update French translation
+  * client: Fix typo in pkg-config dependencies
+  * upd: lxqt-config-globalkeyshortcuts_hu.ts
+  * Fix warning
+- Add keyring
+
+---

Old:

  lxqt-globalkeys-0.10.0.tar.xz

New:

  lxqt-globalkeys-0.11.0.tar.xz
  lxqt-globalkeys-0.11.0.tar.xz.asc
  lxqt-globalkeys.keyring



Other differences:
--
++ lxqt-globalkeys.spec ++
--- /var/tmp/diff_new_pack.xRgBNt/_old  2016-10-06 12:43:35.0 +0200
+++ /var/tmp/diff_new_pack.xRgBNt/_new  2016-10-06 12:43:35.0 +0200
@@ -17,17 +17,19 @@
 
 
 Name:   lxqt-globalkeys
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:Global keyboard shortcuts registration
 License:LGPL-2.1+
-Group:  System/GUI/LXDE-Qt
-Url:http://www.lxde.org
+Group:  System/GUI/LXQt
+Url:http://www.lxqt.org
 Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  kwindowsystem-devel
+BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  pkgconfig(Qt5UiTools)
 BuildRequires:  pkgconfig(lxqt) >= %{version}
 Requires(pre): desktop-file-utils
@@ -45,7 +47,7 @@
 Requires:   %{name} = %{version}
 Requires:   liblxqt-globalkeys-ui0 = %{version}
 Requires:   liblxqt-globalkeys0 = %{version}
-Requires:   pkg-config
+Requires:   pkgconfig
 
 %description devel
 Development files for lxqt-globalkeys including headers and libraries
@@ -60,19 +62,18 @@
 %package -n liblxqt-globalkeys-ui0
 Summary:UI lxqt-globalkeys libraries
 Group:  System/Libraries
+Recommends: %{name}-lang
 
 %description -n liblxqt-globalkeys-ui0
 UI system libraries for lxqt-globalkeys
 
-%lang_package
-
 %prep
 %setup -q
 # Changing LXQt into X-LXQt in desktop files to be freedesktop compliant and 
shut rpmlint warnings
 #find -name '*desktop.in*' -exec sed -ri 's/(LXQt;)/X-\1/' {} +
 
 %build
-%cmake
+%cmake -DPULL_TRANSLATIONS=No
 make %{?_smp_mflags}
 
 %install
@@ -120,8 +121,4 @@
 %defattr(-,root,root)
 %{_libdir}/liblxqt-globalkeys-ui.so.*
 
-%files lang
-%defattr(-,root,root)
-%{_datadir}/lxqt/translations
-
 %changelog

++ lxqt-globalkeys-0.10.0.tar.xz -> lxqt-globalkeys-0.11.0.tar.xz ++
 7519 lines of diff (skipped)




commit liblxqt for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package liblxqt for openSUSE:Factory checked 
in at 2016-10-06 12:43:03

Comparing /work/SRC/openSUSE:Factory/liblxqt (Old)
 and  /work/SRC/openSUSE:Factory/.liblxqt.new (New)


Package is "liblxqt"

Changes:

--- /work/SRC/openSUSE:Factory/liblxqt/liblxqt.changes  2015-11-13 
23:35:48.0 +0100
+++ /work/SRC/openSUSE:Factory/.liblxqt.new/liblxqt.changes 2016-10-06 
12:43:08.0 +0200
@@ -1,0 +2,67 @@
+Fri Sep 30 08:04:57 UTC 2016 - jeng...@inai.de
+
+- Update descriptions. Drop seemingly unneeded Provides: liblxqt.
+  Own all directories.
+
+---
+Sat Sep 24 18:15:21 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0:
+  * Bump version ot 0.11.0 (#105)
+  * Settings: Make use of reverse_iterator conditional
+  * Application: Add  include
+  * Settings: Add "homemade" XDG_CONFIG_DIRS support
+  * Settings: unify duplicated code
+  * Add README.md
+  * translations: Change default translations repository
+  * Update DBus Notify method annotation name
+  * Fix lupdate warning missing Q_OBJECT macro
+  * Replaces deprecated QStyleOptionViewItemV4
+  * Don't lock the screen when it's already locked.
+  * lxqtscreensaver: Makes it a opaque pointer class
+  * GridLayout: Store current animation flag
+  * lxqtgridlayout: Move private class definition
+  * HtmlDelegate: Take layoutDirection into account
+  * GridLayout: Take layoutDirection into account
+  * application: Correct signal handling & clean-up (#72)
+  * lxqtpower: Removes unused stuff
+  * SingleApplication: Only create an DBus adaptor when needed
+  * NotificationPrivate: Fixes programming typo
+  * Don't set icon theme name
+  * configdialog: Update icons in ThemeChanged event
+  * lxqtpower: Add suspend and hibernate to ConsoleKit2 provider
+  * LXQtTranslateTs.cmake: Enable PULL_TRANSLATIONS by default
+  * LXQtTranslateTs.cmake: Use/update template in remote repo
+  * .gitignore: Cleanup
+  * build: Use external translations
+  * ts-files removal (#90)
+  * GridLayout: Fix memory leak
+  * translations: Fix external translations logic
+  * translations: Add external translations support
+  * configdialog: Fix icon bar sizing
+  * configdialog: fix size of PageSelectWidget (#83)
+  * Use const references with the foreach iterator
+  * SettingsCache: Improve performance
+  * Print warning messages when using the fallback Icon Theme
+  * Use LXQT_DATA_DIR for fallback icon theme search path
+  * Sets Oxygen as the only fallback icon theme
+  * Adds CMAKE_INSTALL_PREFIX to the LXQt Theme search paths
+  * LXQtCompilerSettings: Add QT_USE_QSTRINGBUILDER to the compile definitions
+  * SingleApplication: Use QCoreApplication::exit() instead of ::exit()
+  * bump year
+  * TranslateDesktopTs: Adds UPDATE_OPTIONS options
+  * TranslateDesktop: Remove lupdate absolute option
+  * TranslateDesktop: Use -a switch in grep commands
+  * LXQtTheme: Remove (outdated) "singleclick" qss assembly
+  * settings: Upgrade emitting of "changed" signals
+  * SingleApplication: Call also QWidget::show on activate
+  * Updated Russian translation Removed ru_RU file
+  * Use QString() instead of ""
+  * Use CMAKE_INSTALL_FULL_DATAROOTDIR
+  * Add LXQT_GRAPHICS_DIR directory definition
+  * lxqt-config: Correct escaping while setting variables
+  * CMake: Removes artifact
+  * Adds FindXdgUserDirs CMake find_package module
+  * Italian translation update
+
+---

Old:

  liblxqt-0.10.0.tar.xz

New:

  liblxqt-0.11.0.tar.xz
  liblxqt-0.11.0.tar.xz.asc
  liblxqt.keyring



Other differences:
--
++ liblxqt.spec ++
--- /var/tmp/diff_new_pack.2FVdCn/_old  2016-10-06 12:43:10.0 +0200
+++ /var/tmp/diff_new_pack.2FVdCn/_new  2016-10-06 12:43:10.0 +0200
@@ -17,61 +17,66 @@
 
 
 Name:   liblxqt
-Version:0.10.0
+Version:0.11.0
 Release:0
-Summary:Core utility library for lxqt
+Summary:Core utility library for LXQt
 License:LGPL-2.1+
 Group:  Development/Libraries/C and C++
 Url:http://www.lxqt.org
-Source: 
http://downloads.lxqt.org/lxqt/%{version}/liblxqt-%{version}.tar.xz
+Source: 
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  kwindowsystem-devel
-BuildRequires:  pkg-config
+BuildRequires:  cmake(KF5WindowSystem)
+BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(Qt5DBus)
 BuildRequires:  

commit libsysstat-qt5 for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package libsysstat-qt5 for openSUSE:Factory 
checked in at 2016-10-06 12:43:10

Comparing /work/SRC/openSUSE:Factory/libsysstat-qt5 (Old)
 and  /work/SRC/openSUSE:Factory/.libsysstat-qt5.new (New)


Package is "libsysstat-qt5"

Changes:

--- /work/SRC/openSUSE:Factory/libsysstat-qt5/libsysstat-qt5.changes
2015-11-13 23:35:31.0 +0100
+++ /work/SRC/openSUSE:Factory/.libsysstat-qt5.new/libsysstat-qt5.changes   
2016-10-06 12:43:10.0 +0200
@@ -1,0 +2,7 @@
+Sat Sep 24 19:52:58 UTC 2016 - mvet...@suse.com
+
+- Update to 0.3.2:
+* rare file descriptor leak fixed
+* documentation improvements
+
+---

Old:

  libsysstat-0.3.1.tar.xz

New:

  libsysstat-0.3.2.tar.xz
  libsysstat-0.3.2.tar.xz.asc
  libsysstat-qt5.keyring



Other differences:
--
++ libsysstat-qt5.spec ++
--- /var/tmp/diff_new_pack.lIrAoJ/_old  2016-10-06 12:43:12.0 +0200
+++ /var/tmp/diff_new_pack.lIrAoJ/_new  2016-10-06 12:43:12.0 +0200
@@ -16,17 +16,20 @@
 #
 
 
+%define _name libsysstat
 Name:   libsysstat-qt5
-Version:0.3.1
+Version:0.3.2
 Release:0
 Summary:Query system info and statistics
 License:LGPL-2.1+
 Group:  Development/Libraries/C and C++
 Url:http://www.lxde.org
 Source: 
http://downloads.lxqt.org/libsysstat/%{version}/libsysstat-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/libsysstat/%{version}/libsysstat-%{version}.tar.xz.asc
+Source2:libsysstat-qt5.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  gcc-c++
-BuildRequires:  libqt5-linguist-devel
+BuildRequires:  cmake(Qt5LinguistTools)
 BuildRequires:  pkgconfig(Qt5Core)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
@@ -45,13 +48,13 @@
 Summary:Devel files for libsysstat
 Group:  Development/Libraries/C and C++
 Requires:   libsysstat-qt5-0 = %{version}
-Requires:   pkg-config
+Requires:   pkgconfig
 
 %description devel
 sysstat libraries for development
 
 %prep
-%setup -q -n libsysstat-%{version}
+%setup -q -n %{_name}-%{version}
 
 %build
 %cmake -DUSE_QT5=ON

++ libsysstat-0.3.1.tar.xz -> libsysstat-0.3.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libsysstat-0.3.1/AUTHORS new/libsysstat-0.3.2/AUTHORS
--- old/libsysstat-0.3.1/AUTHORS2015-10-30 23:38:55.0 +0100
+++ new/libsysstat-0.3.2/AUTHORS2016-09-17 14:03:10.0 +0200
@@ -5,7 +5,7 @@
 
 Copyright:
 Copyright (c) 2012 Razor team
-Copyright (c) 2012-2014 LXQt team
+Copyright (c) 2012-2016 LXQt team
 
-License: GPL-2 and LGPL-2.1+
+License: LGPL-2.1+
 The full text of the licenses can be found in the 'COPYING' file.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libsysstat-0.3.1/CHANGELOG 
new/libsysstat-0.3.2/CHANGELOG
--- old/libsysstat-0.3.1/CHANGELOG  1970-01-01 01:00:00.0 +0100
+++ new/libsysstat-0.3.2/CHANGELOG  2016-09-17 14:03:10.0 +0200
@@ -0,0 +1,74 @@
+
+libsysstat-0.3.2 / 2016-09-17
+=
+
+  * Bump version to 0.3.2
+  * Add README.md
+  * fixes lxde/libsysstat/issues/11
+  * Bump year and change listed licenses
+  * Fix rare file descriptor leak in readAllFile()
+
+0.3.1 / 2015-10-31
+==
+
+  * Release 0.3.1
+  * Remove duplicate LICENSE file
+  * Remove leftover translation comments
+  * Fix license file
+  * Add release script
+  * Handles CMake policy CMP0063
+  * Uses a local copy of LXQCompilerSettings
+  * CMake: Adds Runtime and Devel install COMPONENTs
+  * Use target_compile_definitions()
+  * Use CMAKE_INCLUDE_CURRENT_DIR
+  * Use GNUInstallDirs
+  * Coding style cleanups
+  * Disables translations support
+  * Use CMAKE_AUTOMOC, drops qt5_wrap_cpp()
+  * Adapts the buildsystem to use CMake Targets
+  * Fix warnings about using uninitialized variables
+  * - Bump missing versioning
+
+0.3.0 / 2014-10-21
+==
+
+  * Adds the Requires field to the .pc confile file
+  * Generate .pc file with the proper version value
+  * Clean up CMakeLists.txt, drop Qt4 support
+
+0.2.0 / 2014-10-19
+==
+
+  * Release 0.2.0
+  * simplify QT switching, use ENV
+  * Use QString::fromLatin1() instead of QString::fromAscii()
+  * Adapt the build system to handle Qt4 and Qt5
+  * Improve FreeBSD support
+
+0.1.0 / 2014-04-29
+==
+
+  * Update AUTHORS and COPYING
+  * Add CPack rules for creating tarball
+  * Don't append library suffix to library install path, but use it by default
+  * Allow 

commit python-openqa_review for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package python-openqa_review for 
openSUSE:Factory checked in at 2016-10-06 12:42:46

Comparing /work/SRC/openSUSE:Factory/python-openqa_review (Old)
 and  /work/SRC/openSUSE:Factory/.python-openqa_review.new (New)


Package is "python-openqa_review"

Changes:

--- 
/work/SRC/openSUSE:Factory/python-openqa_review/python-openqa_review.changes
2016-09-28 11:30:52.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-openqa_review.new/python-openqa_review.changes
   2016-10-06 12:42:46.0 +0200
@@ -1,0 +2,42 @@
+Thu Sep 29 19:59:24 UTC 2016 - opensuse-packag...@opensuse.org
+
+- Update to version 1.3.0:
+  * report_links: Make 'latest' a link in markdown format
+  * wip -- add bug report links, also for progress, for later
+  * TODO: correct indendation of some entries
+  * TODO: Remove implemented bug reporting links
+  * browser: Support saving pages with unicode content in python2
+  * issue_report_link: Support non-digit builds
+  * issue_report_link: Handle non-existing product mapping option gracefully
+  * Allow filtering for closed / unassigned bugs
+  * TODO: Add some ideas
+  * Add dashboard generation script
+  * Store dashboard file at common "bin" location
+  * Delete unnecessary bootstrap.js and font files
+  * Add LICENSE.GPL-2 for files under dashboard_files/
+  * dashboard: Use robust 'sh -e' shebang
+  * Add bin/openqa_review_osd_daily_email script
+  * dashboard: Make all variables options with defaults
+  * dashboard: Replace three-step sed replace by proper template replace
+  * dashboard: Customize logo with a big 'R' on top for 'review'
+  * Merge 'dashboard' and 'openqa_review_osd_daily_email'
+  * issue_report_link: Fix unsupported failures without failed modules
+  * TODO: Mark 'use test verbosity for existing' as fixed
+  * Do not fail when there are no closed/unass bugs (#28)
+  * Fix #21: Put hr to own line and use md syntax (#29)
+  * Make hr between products on dashboard page thicker (#31)
+  * Fix ") in issue subject breaking markdown (#30)
+  * Support new-style progress bars of openQA
+
+---
+Wed Sep 21 20:05:02 UTC 2016 - opensuse-packag...@opensuse.org
+
+- Update to version 1.2.0:
+  * Display ticket priority (#25)
+  * Show __doc__ as port of help
+  * Add links to verbose reports to directly report bugs
+  * Use host specific issue tracker product mapping
+  * Ensure multiple missing archs are sorted
+  * Add more information to bug report links
+
+---

Old:

  python-openqa_review-1.1.0.tar.gz

New:

  python-openqa_review-1.3.0.tar.gz



Other differences:
--
++ python-openqa_review.spec ++
--- /var/tmp/diff_new_pack.DzahUW/_old  2016-10-06 12:42:47.0 +0200
+++ /var/tmp/diff_new_pack.DzahUW/_new  2016-10-06 12:42:47.0 +0200
@@ -18,7 +18,7 @@
 
 %define short_name openqa_review
 Name:   python-%{short_name}
-Version:1.1.0
+Version:1.3.0
 Release:0
 Summary:A review helper script for openQA
 License:MIT

++ python-openqa_review-1.1.0.tar.gz -> python-openqa_review-1.3.0.tar.gz 
++
 23138 lines of diff (skipped)




commit lxqt-l10n for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package lxqt-l10n for openSUSE:Factory 
checked in at 2016-10-06 12:42:30

Comparing /work/SRC/openSUSE:Factory/lxqt-l10n (Old)
 and  /work/SRC/openSUSE:Factory/.lxqt-l10n.new (New)


Package is "lxqt-l10n"

Changes:

New Changes file:

--- /dev/null   2016-09-15 12:42:18.240042505 +0200
+++ /work/SRC/openSUSE:Factory/.lxqt-l10n.new/lxqt-l10n.changes 2016-10-06 
12:42:31.0 +0200
@@ -0,0 +1,6 @@
+---
+Sat Sep 24 23:15:23 UTC 2016 - mvet...@suse.com
+
+- Update to 0.11.0
+- Package created by and.novem...@opensuse.org to X11:LXQt:git
+

New:

  lxqt-l10n-0.11.0.tar.xz
  lxqt-l10n-0.11.0.tar.xz.asc
  lxqt-l10n.changes
  lxqt-l10n.keyring
  lxqt-l10n.spec



Other differences:
--
++ lxqt-l10n.spec ++
#
# spec file for package lxqt-l10n
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:   lxqt-l10n
Version:0.11.0
Release:0
Summary:Translations for LXQt Desktop Environment
License:LGPL-2.1+
Group:  System/Localization
Url:https://github.com/lxde/translations
Source0:
https://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz
Source1:
https://downloads.lxqt.org/lxqt/%{version}/%{name}-%{version}.tar.xz.asc
Source2:%{name}.keyring
BuildRequires:  cmake >= 3.0.2
BuildRequires:  cmake(KF5WindowSystem)
BuildRequires:  cmake(Qt5LinguistTools)
BuildRequires:  fdupes
BuildRequires:  pkgconfig
BuildRequires:  pkgconfig(lxqt)
Requires:   compton-conf-lang = %{version}-%{release}
Requires:   libfm-qt-lang = %{version}-%{release}
Requires:   liblxqt-lang = %{version}-%{release}
Requires:   lximage-qt-lang = %{version}-%{release}
Requires:   lxqt-about-lang = %{version}-%{release}
Requires:   lxqt-admin-lang = %{version}-%{release}
Requires:   lxqt-config-lang = %{version}-%{release}
Requires:   lxqt-globalkeys-lang = %{version}-%{release}
Requires:   lxqt-notificationd-lang = %{version}-%{release}
Requires:   lxqt-openssh-askpass-lang = %{version}-%{release}
Requires:   lxqt-panel-lang = %{version}-%{release}
Requires:   lxqt-policykit-lang = %{version}-%{release}
Requires:   lxqt-powermanagement-lang = %{version}-%{release}
Requires:   lxqt-runner-lang = %{version}-%{release}
Requires:   lxqt-session-lang = %{version}-%{release}
Requires:   lxqt-sudo-lang = %{version}-%{release}
Requires:   obconf-qt-lang = %{version}-%{release}
Requires:   pcmanfm-qt-lang = %{version}-%{release}
Requires:   qterminal-lang = %{version}-%{release}
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildArch:  noarch

%description
This is repository with translations of all LXQt components (like lxqt-panel,
lxqt-runner etc.).

%package -n compton-conf-lang
Group:  System/Localization
Summary:Languages for package compton-conf

%package -n libfm-qt-lang
Group:  System/Localization
Summary:Languages for package libfm-qt

%package -n liblxqt-lang
Group:  System/Localization
Summary:Languages for package liblxqt

%package -n lximage-qt-lang
Group:  System/Localization
Summary:Languages for package lximage-qt

%package -n lxqt-about-lang
Group:  System/Localization
Summary:Languages for package lxqt-about

%package -n lxqt-admin-lang
Group:  System/Localization
Summary:Languages for package lxqt-admin

%package -n lxqt-config-lang
Group:  System/Localization
Summary:Languages for package lxqt-config

%package -n lxqt-globalkeys-lang
Group:  System/Localization
Summary:Languages for package lxqt-globalkeys

%package -n lxqt-notificationd-lang
Group:  System/Localization
Summary:Languages for package lxqt-notificationd

%package -n lxqt-openssh-askpass-lang
Group:  System/Localization
Summary:Languages for package lxqt-openssh-askpass

%package -n lxqt-panel-lang
Group:  System/Localization
Summary:

commit libqt5xdg for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package libqt5xdg for openSUSE:Factory 
checked in at 2016-10-06 12:42:06

Comparing /work/SRC/openSUSE:Factory/libqt5xdg (Old)
 and  /work/SRC/openSUSE:Factory/.libqt5xdg.new (New)


Package is "libqt5xdg"

Changes:

--- /work/SRC/openSUSE:Factory/libqt5xdg/libqt5xdg.changes  2015-11-13 
23:35:58.0 +0100
+++ /work/SRC/openSUSE:Factory/.libqt5xdg.new/libqt5xdg.changes 2016-10-06 
12:42:07.0 +0200
@@ -1,0 +2,11 @@
+Sat Sep 24 18:02:50 UTC 2016 - mvet...@suse.com
+
+- Update to to 2.0.0:
+  * BACKWARDS-INCOMPATIBLE: New XdgIconLoader library
+  * New explicit dependency Qt SVG
+  * The IconLoader can use GTK+ icon cache
+  * Improved overall performance
+  * Better XDG handling
+  * Overall polishing
+
+---

Old:

  libqtxdg-1.3.0.tar.xz

New:

  libqt5xdg.keyring
  libqtxdg-2.0.0.tar.xz
  libqtxdg-2.0.0.tar.xz.asc



Other differences:
--
++ libqt5xdg.spec ++
--- /var/tmp/diff_new_pack.P4O3hd/_old  2016-10-06 12:42:08.0 +0200
+++ /var/tmp/diff_new_pack.P4O3hd/_new  2016-10-06 12:42:08.0 +0200
@@ -15,49 +15,69 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
+%define _name libqtxdg
 Name:   libqt5xdg
-Version:1.3.0
+Version:2.0.0
 Release:0
 Summary:Qt implementation of xdg specs for lxqt
 License:GPL-3.0
 Group:  Development/Libraries/C and C++
 Url:https://lxqt.org
-Source: 
http://downloads.lxqt.org/libqtxdg/%{version}/libqtxdg-%{version}.tar.xz
+Source: 
http://downloads.lxqt.org/%{_name}/%{version}/%{_name}-%{version}.tar.xz
+Source1:
http://downloads.lxqt.org/%{_name}/%{version}/%{_name}-%{version}.tar.xz.asc
+Source2:%{name}.keyring
 BuildRequires:  cmake >= 3.0.2
 BuildRequires:  fdupes
-BuildRequires:  file-devel
 BuildRequires:  gcc-c++
 BuildRequires:  libQt5Gui-private-headers-devel
+BuildRequires:  pkgconfig
+BuildRequires:  pkgconfig(Qt5Core)
 BuildRequires:  pkgconfig(Qt5DBus)
-BuildRequires:  pkgconfig(Qt5UiTools)
+BuildRequires:  pkgconfig(Qt5Svg)
+BuildRequires:  pkgconfig(Qt5Test)
 BuildRequires:  pkgconfig(Qt5Widgets)
 BuildRequires:  pkgconfig(Qt5Xml)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-Qt implementation of freedesktop.org xdg specs for lxqt
+Qt implementation of freedesktop.org XDG specs for LXQt
 
-%package -n libQt5Xdg1
+%package -n libQt5Xdg2
 Summary:Libraries for qtxdg
 Group:  System/Libraries
 Provides:   libqtxdg
 
-%description -n libQt5Xdg1
-qtxdg libraries for development
+%description -n libQt5Xdg2
+QtXDG libraries for development
 
 %package devel
 Summary:Devel files for libqtxdg
 Group:  Development/Libraries/C and C++
-Requires:   libQt5Xdg1 = %{version}
-Requires:   pkg-config
+Requires:   libQt5Xdg2 = %{version}
+Requires:   pkgconfig
 Requires:   pkgconfig(Qt5UiTools)
 
 %description devel
-qtxdg libraries for development
+QtXDG libraries for development
+
+%package -n libQt5XdgIconLoader2
+Summary:IconLoader library for QtXDG
+Group:  System/Libraries
+Provides:   libqtxdgiconloader
+
+%description -n libQt5XdgIconLoader2
+QtXDG icon loader libraries used in LXQt
+
+%package -n libQt5XdgIconLoader-devel
+Summary:Devel files for libQt5XdgIconLoader
+Group:  Development/Libraries/C and C++
+Requires:   libQt5XdgIconLoader2 = %{version}
+
+%description -n libQt5XdgIconLoader-devel
+Development files for QtXDG icon loader libraries used in LXQt
 
 %prep
-%setup -q -n libqtxdg-%{version}
+%setup -q -n %{_name}-%{version}
 
 %build
 %cmake
@@ -67,11 +87,12 @@
 %cmake_install
 %fdupes -s %{buildroot}/%{_datadir}/locale
 
-%post -n libQt5Xdg1 -p /sbin/ldconfig
-
-%postun -n libQt5Xdg1 -p /sbin/ldconfig
+%post -n libQt5Xdg2 -p /sbin/ldconfig
+%postun -n libQt5Xdg2 -p /sbin/ldconfig
+%post -n libQt5XdgIconLoader2 -p /sbin/ldconfig
+%postun -n libQt5XdgIconLoader2 -p /sbin/ldconfig
 
-%files -n libQt5Xdg1
+%files -n libQt5Xdg2
 %defattr(-,root,root)
 %doc AUTHORS COPYING
 %{_libdir}/libQt5Xdg.so.*
@@ -83,4 +104,25 @@
 %{_libdir}/pkgconfig/Qt5Xdg.pc
 %{_libdir}/libQt5Xdg.so
 
+%files -n libQt5XdgIconLoader2
+%defattr(-,root,root)
+%{_libdir}/libQt5XdgIconLoader.so.2
+%{_libdir}/libQt5XdgIconLoader.so.2.0.0
+
+%files -n libQt5XdgIconLoader-devel
+%defattr(-,root,root)
+%dir %{_includedir}/qt5xdgiconloader
+%dir %{_includedir}/qt5xdgiconloader/2.0.0
+%dir %{_includedir}/qt5xdgiconloader/2.0.0/private
+%dir %{_includedir}/qt5xdgiconloader/2.0.0/private/xdgiconloader
+%dir %{_datadir}/cmake/qt5xdgiconloader

commit qtermwidget-qt4 for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package qtermwidget-qt4 for openSUSE:Factory 
checked in at 2016-10-06 12:41:54

Comparing /work/SRC/openSUSE:Factory/qtermwidget-qt4 (Old)
 and  /work/SRC/openSUSE:Factory/.qtermwidget-qt4.new (New)


Package is "qtermwidget-qt4"

Changes:

--- /work/SRC/openSUSE:Factory/qtermwidget-qt4/qtermwidget-qt5.changes  
2016-05-31 12:24:03.0 +0200
+++ /work/SRC/openSUSE:Factory/.qtermwidget-qt4.new/qtermwidget-qt5.changes 
2016-10-06 12:41:55.0 +0200
@@ -1,0 +2,9 @@
+Sun Sep 25 07:52:27 UTC 2016 - dap.darkn...@gmail.com
+
+- Updated to 0.7.0:
+  * Remove support for Qt <= 5.4;
+  * Remove Designer plugin;
+  * Check CHANGELOG for additional information.
+- %%cmake macro.
+
+---

New:

  qtermwidget-0.7.0.tar.xz



Other differences:
--
++ qtermwidget-qt5.spec ++
--- /var/tmp/diff_new_pack.5PX7wu/_old  2016-10-06 12:41:56.0 +0200
+++ /var/tmp/diff_new_pack.5PX7wu/_new  2016-10-06 12:41:56.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package qtermwidget
 #
-# Copyright (c) 2016 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -30,7 +30,7 @@
 removed.
 
 Name:   qtermwidget-qt5
-Version:0.6.0
+Version:0.7.0
 Release:0
 Summary:%{pack_summ}
 License:GPL-2.0+
@@ -38,8 +38,8 @@
 Url:https://github.com/qterminal/qtermwidget
 Source: 
https://github.com/lxde/qtermwidget/releases/download/%{version}/qtermwidget-%{version}.tar.xz
 
-BuildRequires:  cmake
-BuildRequires:  pkgconfig(Qt5Widgets)
+BuildRequires:  cmake >= 3.0
+BuildRequires:  pkgconfig(Qt5Widgets) >= 5.4
 
 %description
 %{pack_desc}
@@ -73,24 +73,12 @@
 %setup -q -n qtermwidget-%{version}
 
 %build
-mkdir build && cd build
-
-# Building Qt designer plugin is not supported for Qt5 yet.
-cmake .. \
--DUSE_QT5=ON \
--DBUILD_DESIGNER_PLUGIN=0 \
-%if "%{_lib}" == "lib64"
--DLIB_SUFFIX=64 \
-%endif
--DCMAKE_CXX_FLAGS="%{optflags}" \
--DCMAKE_INSTALL_PREFIX=%{_prefix} \
--DCMAKE_BUILD_TYPE=RelWithDebInfo
+%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo
 
 make V=1 %{?_smp_mflags}
 
 %install
-cd build
-make V=1 install DESTDIR=%{buildroot}
+%cmake_install
 
 %post -n libqtermwidget%{qt_ver}-0 -p /sbin/ldconfig
 
@@ -98,7 +86,7 @@
 
 %files -n libqtermwidget%{qt_ver}-0
 %defattr(-,root,root)
-%doc AUTHORS COPYING Changelog README
+%doc AUTHORS CHANGELOG LICENSE README.md
 %{_libdir}/libqtermwidget*.so.*
 
 %files data
@@ -109,7 +97,6 @@
 %defattr(-,root,root)
 %{_includedir}/qtermwidget%{qt_ver}
 %{_libdir}/libqtermwidget*.so
-# %%{_libdir}/qt%%{qt_ver}/plugins/designer/libqtermwidget*plugin.so
 %{_libdir}/pkgconfig/qtermwidget%{qt_ver}.pc
 %{_datadir}/cmake/qtermwidget%{qt_ver}
 




commit ghc-pred-set for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package ghc-pred-set for openSUSE:Factory 
checked in at 2016-10-06 12:41:43

Comparing /work/SRC/openSUSE:Factory/ghc-pred-set (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-pred-set.new (New)


Package is "ghc-pred-set"

Changes:

New Changes file:

--- /dev/null   2016-09-15 12:42:18.240042505 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-pred-set.new/ghc-pred-set.changes   
2016-10-06 12:41:43.0 +0200
@@ -0,0 +1,5 @@
+---
+Sun Jul 10 17:03:34 UTC 2016 - psim...@suse.com
+
+- Update to version 0.0.1 revision 0 with cabal2obs.
+

New:

  ghc-pred-set.changes
  ghc-pred-set.spec
  pred-set-0.0.1.tar.gz



Other differences:
--
++ ghc-pred-set.spec ++
#
# spec file for package ghc-pred-set
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%global pkg_name pred-set
Name:   ghc-%{pkg_name}
Version:0.0.1
Release:0
Summary:Simple cached predicates
License:BSD-3-Clause
Group:  System/Libraries
Url:https://hackage.haskell.org/package/%{pkg_name}
Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
BuildRequires:  ghc-Cabal-devel
# Begin cabal-rpm deps:
BuildRequires:  ghc-HSet-devel
BuildRequires:  ghc-hashable-devel
BuildRequires:  ghc-hashtables-devel
BuildRequires:  ghc-rpm-macros
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
# End cabal-rpm deps

%description
Simple cached predicates.

%package devel
Summary:Haskell %{pkg_name} library development files
Group:  Development/Libraries/Other
Requires:   %{name} = %{version}-%{release}
Requires:   ghc-compiler = %{ghc_version}
Requires(post): ghc-compiler = %{ghc_version}
Requires(postun): ghc-compiler = %{ghc_version}

%description devel
This package provides the Haskell %{pkg_name} library development files.

%prep
%setup -q -n %{pkg_name}-%{version}


%build
%ghc_lib_build


%install
%ghc_lib_install


%post devel
%ghc_pkg_recache

%postun devel
%ghc_pkg_recache

%files -f %{name}.files
%defattr(-,root,root,-)
%doc LICENSE

%files devel -f %{name}-devel.files
%defattr(-,root,root,-)

%changelog



commit ghc-pipes-csv for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package ghc-pipes-csv for openSUSE:Factory 
checked in at 2016-10-06 12:41:36

Comparing /work/SRC/openSUSE:Factory/ghc-pipes-csv (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-pipes-csv.new (New)


Package is "ghc-pipes-csv"

Changes:

New Changes file:

--- /dev/null   2016-09-15 12:42:18.240042505 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-pipes-csv.new/ghc-pipes-csv.changes 
2016-10-06 12:41:36.0 +0200
@@ -0,0 +1,5 @@
+---
+Sun Jul 10 17:01:57 UTC 2016 - psim...@suse.com
+
+- Update to version 1.4.3 revision 0 with cabal2obs.
+

New:

  ghc-pipes-csv.changes
  ghc-pipes-csv.spec
  pipes-csv-1.4.3.tar.gz



Other differences:
--
++ ghc-pipes-csv.spec ++
#
# spec file for package ghc-pipes-csv
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%global pkg_name pipes-csv
%bcond_with tests
Name:   ghc-%{pkg_name}
Version:1.4.3
Release:0
Summary:Fast, streaming csv parser
License:MIT
Group:  System/Libraries
Url:https://hackage.haskell.org/package/%{pkg_name}
Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
BuildRequires:  ghc-Cabal-devel
# Begin cabal-rpm deps:
BuildRequires:  ghc-blaze-builder-devel
BuildRequires:  ghc-bytestring-devel
BuildRequires:  ghc-cassava-devel
BuildRequires:  ghc-pipes-devel
BuildRequires:  ghc-rpm-macros
BuildRequires:  ghc-unordered-containers-devel
BuildRequires:  ghc-vector-devel
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
%if %{with tests}
BuildRequires:  ghc-HUnit-devel
BuildRequires:  ghc-MissingH-devel
BuildRequires:  ghc-pipes-bytestring-devel
BuildRequires:  ghc-test-framework-devel
BuildRequires:  ghc-test-framework-hunit-devel
%endif
# End cabal-rpm deps

%description
`pipes-csv` is a streaming csv parser built on top of `cassava` and `pipes`.

%package devel
Summary:Haskell %{pkg_name} library development files
Group:  Development/Libraries/Other
Requires:   %{name} = %{version}-%{release}
Requires:   ghc-compiler = %{ghc_version}
Requires(post): ghc-compiler = %{ghc_version}
Requires(postun): ghc-compiler = %{ghc_version}

%description devel
This package provides the Haskell %{pkg_name} library development files.

%prep
%setup -q -n %{pkg_name}-%{version}


%build
%ghc_lib_build


%install
%ghc_lib_install


%check
%if %{with tests}
%{cabal} test
%endif


%post devel
%ghc_pkg_recache

%postun devel
%ghc_pkg_recache

%files -f %{name}.files
%defattr(-,root,root,-)
%doc LICENSE

%files devel -f %{name}-devel.files
%defattr(-,root,root,-)

%changelog



commit postgresql93 for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package postgresql93 for openSUSE:Factory 
checked in at 2016-10-06 12:40:57

Comparing /work/SRC/openSUSE:Factory/postgresql93 (Old)
 and  /work/SRC/openSUSE:Factory/.postgresql93.new (New)


Package is "postgresql93"

Changes:

--- /work/SRC/openSUSE:Factory/postgresql93/postgresql93-libs.changes   
2016-05-24 09:34:56.0 +0200
+++ /work/SRC/openSUSE:Factory/.postgresql93.new/postgresql93-libs.changes  
2016-10-06 12:40:58.0 +0200
@@ -1,0 +2,21 @@
+Fri Aug 12 07:49:30 UTC 2016 - fwe...@suse.com
+
+- Update to version 9.3.14:
+  * Fix possible mis-evaluation of nested CASE-WHEN expressions
+(CVE-2016-5423)
+  * Fix client programs' handling of special characters in database
+and role names (CVE-2016-5424)
+  * Fix corner-case misbehaviors for IS NULL/IS NOT NULL applied
+to nested composite values
+  * Make the inet and cidr data types properly reject IPv6
+addresses with too many colon-separated fields
+  * Prevent crash in close_ps() (the point ## lseg operator) for
+NaN input coordinates
+  * Fix several one-byte buffer over-reads in to_number()
+  * Avoid unsafe intermediate state during expensive paths through
+heap_update()
+
+  * For the other bug fixes, see the release notes:
+https://www.postgresql.org/docs/9.3/static/release-9-3-14.html
+
+---
postgresql93.changes: same change

Old:

  postgresql-9.3.13.tar.bz2

New:

  postgresql-9.3.14.tar.bz2



Other differences:
--
++ postgresql93-libs.spec ++
--- /var/tmp/diff_new_pack.x0hLgf/_old  2016-10-06 12:41:00.0 +0200
+++ /var/tmp/diff_new_pack.x0hLgf/_new  2016-10-06 12:41:00.0 +0200
@@ -63,7 +63,7 @@
 Summary:Basic Clients and Utilities for PostgreSQL
 License:PostgreSQL
 Group:  Productivity/Databases/Tools
-Version:9.3.13
+Version:9.3.14
 Release:0
 %define pg_minor_version %(echo %version | sed -r 
's/^([0-9]+\\.[0-9]+).*/\\1/')
 Source0:
https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2

postgresql93.spec: same change
++ postgresql-9.3.13.tar.bz2 -> postgresql-9.3.14.tar.bz2 ++
/work/SRC/openSUSE:Factory/postgresql93/postgresql-9.3.13.tar.bz2 
/work/SRC/openSUSE:Factory/.postgresql93.new/postgresql-9.3.14.tar.bz2 differ: 
char 11, line 1




commit ghc-pipes-cacophony for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package ghc-pipes-cacophony for 
openSUSE:Factory checked in at 2016-10-06 12:41:24

Comparing /work/SRC/openSUSE:Factory/ghc-pipes-cacophony (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-pipes-cacophony.new (New)


Package is "ghc-pipes-cacophony"

Changes:

New Changes file:

--- /dev/null   2016-09-15 12:42:18.240042505 +0200
+++ 
/work/SRC/openSUSE:Factory/.ghc-pipes-cacophony.new/ghc-pipes-cacophony.changes 
2016-10-06 12:41:24.0 +0200
@@ -0,0 +1,5 @@
+---
+Sun Jul 10 17:29:45 UTC 2016 - psim...@suse.com
+
+- Update to version 0.2.1 revision 0 with cabal2obs.
+

New:

  ghc-pipes-cacophony.changes
  ghc-pipes-cacophony.spec
  pipes-cacophony-0.2.1.tar.gz



Other differences:
--
++ ghc-pipes-cacophony.spec ++
#
# spec file for package ghc-pipes-cacophony
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%global pkg_name pipes-cacophony
%bcond_with tests
Name:   ghc-%{pkg_name}
Version:0.2.1
Release:0
Summary:Pipes for Noise-secured network connections
License:SUSE-Public-Domain
Group:  System/Libraries
Url:https://hackage.haskell.org/package/%{pkg_name}
Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
BuildRequires:  ghc-Cabal-devel
# Begin cabal-rpm deps:
BuildRequires:  ghc-bytestring-devel
BuildRequires:  ghc-cacophony-devel
BuildRequires:  ghc-pipes-devel
BuildRequires:  ghc-rpm-macros
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
%if %{with tests}
BuildRequires:  ghc-hlint-devel
%endif
# End cabal-rpm deps

%description
A set of pipes to secure network connections with the
 protocol.

%package devel
Summary:Haskell %{pkg_name} library development files
Group:  Development/Libraries/Other
Requires:   %{name} = %{version}-%{release}
Requires:   ghc-compiler = %{ghc_version}
Requires(post): ghc-compiler = %{ghc_version}
Requires(postun): ghc-compiler = %{ghc_version}

%description devel
This package provides the Haskell %{pkg_name} library development
files.

%prep
%setup -q -n %{pkg_name}-%{version}


%build
%ghc_lib_build


%install
%ghc_lib_install


%check
%if %{with tests}
%{cabal} test
%endif


%post devel
%ghc_pkg_recache

%postun devel
%ghc_pkg_recache

%files -f %{name}.files
%defattr(-,root,root,-)
%doc LICENSE

%files devel -f %{name}-devel.files
%defattr(-,root,root,-)
%doc README.md changelog.md

%changelog



commit texlive-specs-z for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-z for openSUSE:Factory 
checked in at 2016-10-06 12:40:21

Comparing /work/SRC/openSUSE:Factory/texlive-specs-z (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-z.new (New)


Package is "texlive-specs-z"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-z/texlive-specs-z.changes  
2016-08-22 10:03:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-z.new/texlive-specs-z.changes 
2016-10-06 12:40:21.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-z.spec ++
--- /var/tmp/diff_new_pack.diV2v2/_old  2016-10-06 12:40:24.0 +0200
+++ /var/tmp/diff_new_pack.diV2v2/_new  2016-10-06 12:40:24.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-y for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-y for openSUSE:Factory 
checked in at 2016-10-06 12:40:00

Comparing /work/SRC/openSUSE:Factory/texlive-specs-y (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-y.new (New)


Package is "texlive-specs-y"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-y/texlive-specs-y.changes  
2016-08-22 10:03:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-y.new/texlive-specs-y.changes 
2016-10-06 12:40:00.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-y.spec ++
--- /var/tmp/diff_new_pack.xQklfs/_old  2016-10-06 12:40:19.0 +0200
+++ /var/tmp/diff_new_pack.xQklfs/_new  2016-10-06 12:40:19.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-v for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-v for openSUSE:Factory 
checked in at 2016-10-06 12:39:01

Comparing /work/SRC/openSUSE:Factory/texlive-specs-v (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-v.new (New)


Package is "texlive-specs-v"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-v/texlive-specs-v.changes  
2016-08-22 10:03:15.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-v.new/texlive-specs-v.changes 
2016-10-06 12:39:02.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-v.spec ++
--- /var/tmp/diff_new_pack.lAF8Qd/_old  2016-10-06 12:39:10.0 +0200
+++ /var/tmp/diff_new_pack.lAF8Qd/_new  2016-10-06 12:39:10.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-w for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-w for openSUSE:Factory 
checked in at 2016-10-06 12:39:22

Comparing /work/SRC/openSUSE:Factory/texlive-specs-w (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-w.new (New)


Package is "texlive-specs-w"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-w/texlive-specs-w.changes  
2016-08-22 10:03:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-w.new/texlive-specs-w.changes 
2016-10-06 12:39:22.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-w.spec ++
--- /var/tmp/diff_new_pack.i9w7YZ/_old  2016-10-06 12:39:33.0 +0200
+++ /var/tmp/diff_new_pack.i9w7YZ/_new  2016-10-06 12:39:33.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-x for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-x for openSUSE:Factory 
checked in at 2016-10-06 12:39:44

Comparing /work/SRC/openSUSE:Factory/texlive-specs-x (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-x.new (New)


Package is "texlive-specs-x"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-x/texlive-specs-x.changes  
2016-08-22 10:03:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-x.new/texlive-specs-x.changes 
2016-10-06 12:39:45.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-x.spec ++
--- /var/tmp/diff_new_pack.dVn5mw/_old  2016-10-06 12:39:55.0 +0200
+++ /var/tmp/diff_new_pack.dVn5mw/_new  2016-10-06 12:39:55.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-u for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-u for openSUSE:Factory 
checked in at 2016-10-06 12:38:37

Comparing /work/SRC/openSUSE:Factory/texlive-specs-u (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-u.new (New)


Package is "texlive-specs-u"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-u/texlive-specs-u.changes  
2016-08-22 10:03:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-u.new/texlive-specs-u.changes 
2016-10-06 12:38:38.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-u.spec ++
--- /var/tmp/diff_new_pack.KuVspF/_old  2016-10-06 12:38:46.0 +0200
+++ /var/tmp/diff_new_pack.KuVspF/_new  2016-10-06 12:38:46.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-s for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-s for openSUSE:Factory 
checked in at 2016-10-06 12:37:57

Comparing /work/SRC/openSUSE:Factory/texlive-specs-s (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-s.new (New)


Package is "texlive-specs-s"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-s/texlive-specs-s.changes  
2016-08-22 10:02:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-s.new/texlive-specs-s.changes 
2016-10-06 12:37:59.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-s.spec ++
--- /var/tmp/diff_new_pack.datq5J/_old  2016-10-06 12:38:09.0 +0200
+++ /var/tmp/diff_new_pack.datq5J/_new  2016-10-06 12:38:09.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-t for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-t for openSUSE:Factory 
checked in at 2016-10-06 12:38:17

Comparing /work/SRC/openSUSE:Factory/texlive-specs-t (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-t.new (New)


Package is "texlive-specs-t"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-t/texlive-specs-t.changes  
2016-08-22 10:02:56.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-t.new/texlive-specs-t.changes 
2016-10-06 12:38:18.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-t.spec ++
--- /var/tmp/diff_new_pack.YdgJ3Z/_old  2016-10-06 12:38:26.0 +0200
+++ /var/tmp/diff_new_pack.YdgJ3Z/_new  2016-10-06 12:38:26.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-q for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-q for openSUSE:Factory 
checked in at 2016-10-06 12:37:11

Comparing /work/SRC/openSUSE:Factory/texlive-specs-q (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-q.new (New)


Package is "texlive-specs-q"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-q/texlive-specs-q.changes  
2016-08-22 10:04:03.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-q.new/texlive-specs-q.changes 
2016-10-06 12:37:12.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-q.spec ++
--- /var/tmp/diff_new_pack.Xeo94h/_old  2016-10-06 12:37:20.0 +0200
+++ /var/tmp/diff_new_pack.Xeo94h/_new  2016-10-06 12:37:20.0 +0200
@@ -16533,8 +16533,8 @@

%{buildroot}/var/adm/update-scripts/texlive-pas-cours-%{texlive_version}.%{texlive_noarch}.1.09dsvn35842-%{release}-zypper
 tar --use-compress-program=xz -xf %{S:181} -C 
%{buildroot}%{_datadir}/texlive/texmf-dist
 tar --use-compress-program=xz -xf %{S:182} -C 
%{buildroot}%{_datadir}/texlive/texmf-dist
-mv -vf %{buildroot}%{_texmfdistdir}/doc/latex/pas-cours/macro-styles.tex 
%{buildroot}%{_texmfdistdir}/tex/latex/pas-cours/macro-styles.tex
 mv -vf %{buildroot}%{_texmfdistdir}/doc/latex/pas-cours/macro-patrons.tex 
%{buildroot}%{_texmfdistdir}/tex/latex/pas-cours/macro-patrons.tex
+mv -vf %{buildroot}%{_texmfdistdir}/doc/latex/pas-cours/macro-styles.tex 
%{buildroot}%{_texmfdistdir}/tex/latex/pas-cours/macro-styles.tex
 mv -vf %{buildroot}%{_texmfdistdir}/doc/latex/pas-cours/macro-solides.tex 
%{buildroot}%{_texmfdistdir}/tex/latex/pas-cours/macro-solides.tex
 ln -sf %{_texmfdistdir}/texconfig/zypper.py \

%{buildroot}/var/adm/update-scripts/texlive-pas-crosswords-%{texlive_version}.%{texlive_noarch}.1.03svn32313-%{release}-zypper




commit texlive-specs-r for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-r for openSUSE:Factory 
checked in at 2016-10-06 12:37:33

Comparing /work/SRC/openSUSE:Factory/texlive-specs-r (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-r.new (New)


Package is "texlive-specs-r"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-r/texlive-specs-r.changes  
2016-08-22 10:02:39.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-r.new/texlive-specs-r.changes 
2016-10-06 12:37:35.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-r.spec ++
--- /var/tmp/diff_new_pack.wGSA9X/_old  2016-10-06 12:37:44.0 +0200
+++ /var/tmp/diff_new_pack.wGSA9X/_new  2016-10-06 12:37:44.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-p for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-p for openSUSE:Factory 
checked in at 2016-10-06 12:36:45

Comparing /work/SRC/openSUSE:Factory/texlive-specs-p (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-p.new (New)


Package is "texlive-specs-p"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-p/texlive-specs-p.changes  
2016-08-22 10:02:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-p.new/texlive-specs-p.changes 
2016-10-06 12:36:46.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-p.spec ++
--- /var/tmp/diff_new_pack.KnmgQj/_old  2016-10-06 12:36:59.0 +0200
+++ /var/tmp/diff_new_pack.KnmgQj/_new  2016-10-06 12:36:59.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-m for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-m for openSUSE:Factory 
checked in at 2016-10-06 12:36:00

Comparing /work/SRC/openSUSE:Factory/texlive-specs-m (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-m.new (New)


Package is "texlive-specs-m"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-m/texlive-specs-m.changes  
2016-08-22 10:02:07.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-m.new/texlive-specs-m.changes 
2016-10-06 12:36:01.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---

New:

  latexpand_perl.dif



Other differences:
--
++ texlive-specs-m.spec ++
--- /var/tmp/diff_new_pack.gGbvkp/_old  2016-10-06 12:36:12.0 +0200
+++ /var/tmp/diff_new_pack.gGbvkp/_new  2016-10-06 12:36:12.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 
@@ -17480,6 +17480,7 @@
 # from 20160523
 Source185:  latexpand.tar.xz
 Source186:  latexpand.doc.tar.xz
+Source187:  latexpand_perl.dif
 
 %description -n texlive-latexpand
 Latexpand is a Perl script that simply replaces \input and
@@ -17698,8 +17699,8 @@
 Requires:   tex(slantsc.sty)
 # Download at ftp://ftp.ctan.org/pub/tex/systems/texlive/tlnet/archive/
 # from 20160523
-Source187:  lato.tar.xz
-Source188:  lato.doc.tar.xz
+Source188:  lato.tar.xz
+Source189:  lato.doc.tar.xz
 
 %description -n texlive-lato
 Lato is a sanserif typeface family designed in the Summer 2010
@@ -18037,8 +18038,8 @@
 Requires:   tex(keyval.sty)
 # Download at ftp://ftp.ctan.org/pub/tex/systems/texlive/tlnet/archive/
 # from 20160523
-Source189:  layaureo.tar.xz
-Source190:  layaureo.doc.tar.xz
+Source190:  layaureo.tar.xz
+Source191:  layaureo.doc.tar.xz
 
 %description -n texlive-layaureo
 This package produces a wide page layout for documents that use
@@ -18109,8 +18110,8 @@
 Provides:   tex(layouts.sty)
 # Download at ftp://ftp.ctan.org/pub/tex/systems/texlive/tlnet/archive/
 # from 20160523
-Source191:  layouts.tar.xz
-Source192:  layouts.doc.tar.xz
+Source192:  layouts.tar.xz
+Source193:  layouts.doc.tar.xz
 
 %description -n texlive-layouts
 Display information about a document, including: text
@@ -18181,8 +18182,8 @@
 Provides:   tex(lazylist.sty)
 # Download at ftp://ftp.ctan.org/pub/tex/systems/texlive/tlnet/archive/
 # from 20160523
-Source193:  lazylist.tar.xz
-Source194:  lazylist.doc.tar.xz
+Source194:  lazylist.tar.xz
+Source195:  lazylist.doc.tar.xz
 
 %description -n texlive-lazylist
 The package was developed to provide flexible lists, whose
@@ -18254,8 +18255,8 @@
 Provides:   tex(lcd.sty)
 # Download at ftp://ftp.ctan.org/pub/tex/systems/texlive/tlnet/archive/
 # from 20160523
-Source195:  lcd.tar.xz
-Source196:  lcd.doc.tar.xz
+Source196:  lcd.tar.xz
+Source197:  lcd.doc.tar.xz
 
 %description -n texlive-lcd
 A LaTeX package that will display text as on an (early) LCD
@@ -18332,7 +18333,7 @@
 Requires(posttrans): texlive >= %{texlive_version}
 # Download at ftp://ftp.ctan.org/pub/tex/systems/texlive/tlnet/archive/
 # from 20160523
-Source197:  lcdftypetools.doc.tar.xz
+Source198:  lcdftypetools.doc.tar.xz
 
 %description -n texlive-lcdftypetools
 This bundle of tools comprises: Cfftot1, which translates a
@@ -18411,8 +18412,8 @@
 Requires:   tex(keyval.sty)
 # Download at ftp://ftp.ctan.org/pub/tex/systems/texlive/tlnet/archive/
 # from 20160523
-Source198:  lcg.tar.xz
-Source199:  lcg.doc.tar.xz
+Source199:  lcg.tar.xz
+Source200:  lcg.doc.tar.xz
 
 %description -n texlive-lcg
 The lcg package generates random numbers (integers) via a
@@ -18487,8 +18488,8 @@
 Requires:   tex(ifpdf.sty)
 # Download at ftp://ftp.ctan.org/pub/tex/systems/texlive/tlnet/archive/
 # from 20160523
-Source200:  lcyw.tar.xz
-Source201:  lcyw.doc.tar.xz
+Source201:  lcyw.tar.xz
+Source202:  lcyw.doc.tar.xz
 
 %description -n texlive-lcyw
 The package makes the classic CM Cyrillic fonts accessible for
@@ -18564,8 +18565,8 @@
 Requires:   tex(calc.sty)
 # Download at ftp://ftp.ctan.org/pub/tex/systems/texlive/tlnet/archive/
 # from 20160523
-Source202:  leading.tar.xz
-Source203:  leading.doc.tar.xz
+Source203:  leading.tar.xz
+Source204:  leading.doc.tar.xz
 
 %description -n texlive-leading
 The package defines 

commit texlive-specs-n for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-n for openSUSE:Factory 
checked in at 2016-10-06 12:36:12

Comparing /work/SRC/openSUSE:Factory/texlive-specs-n (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-n.new (New)


Package is "texlive-specs-n"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-n/texlive-specs-n.changes  
2016-08-22 10:02:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-n.new/texlive-specs-n.changes 
2016-10-06 12:36:13.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-n.spec ++
--- /var/tmp/diff_new_pack.lMd4Eo/_old  2016-10-06 12:36:22.0 +0200
+++ /var/tmp/diff_new_pack.lMd4Eo/_new  2016-10-06 12:36:23.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-o for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-o for openSUSE:Factory 
checked in at 2016-10-06 12:36:28

Comparing /work/SRC/openSUSE:Factory/texlive-specs-o (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-o.new (New)


Package is "texlive-specs-o"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-o/texlive-specs-o.changes  
2016-08-22 10:02:24.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-o.new/texlive-specs-o.changes 
2016-10-06 12:36:29.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-o.spec ++
--- /var/tmp/diff_new_pack.6sXXDJ/_old  2016-10-06 12:36:39.0 +0200
+++ /var/tmp/diff_new_pack.6sXXDJ/_new  2016-10-06 12:36:39.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-l for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-l for openSUSE:Factory 
checked in at 2016-10-06 12:35:43

Comparing /work/SRC/openSUSE:Factory/texlive-specs-l (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-l.new (New)


Package is "texlive-specs-l"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-l/texlive-specs-l.changes  
2016-08-22 10:01:59.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-l.new/texlive-specs-l.changes 
2016-10-06 12:35:45.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-l.spec ++
--- /var/tmp/diff_new_pack.QKBMiZ/_old  2016-10-06 12:35:53.0 +0200
+++ /var/tmp/diff_new_pack.QKBMiZ/_new  2016-10-06 12:35:53.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-j for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-j for openSUSE:Factory 
checked in at 2016-10-06 12:35:12

Comparing /work/SRC/openSUSE:Factory/texlive-specs-j (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-j.new (New)


Package is "texlive-specs-j"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-j/texlive-specs-j.changes  
2016-08-22 10:01:39.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-j.new/texlive-specs-j.changes 
2016-10-06 12:35:12.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-j.spec ++
--- /var/tmp/diff_new_pack.BJbfq0/_old  2016-10-06 12:35:23.0 +0200
+++ /var/tmp/diff_new_pack.BJbfq0/_new  2016-10-06 12:35:23.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-k for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-k for openSUSE:Factory 
checked in at 2016-10-06 12:35:26

Comparing /work/SRC/openSUSE:Factory/texlive-specs-k (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-k.new (New)


Package is "texlive-specs-k"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-k/texlive-specs-k.changes  
2016-08-22 10:01:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-k.new/texlive-specs-k.changes 
2016-10-06 12:35:27.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-k.spec ++
--- /var/tmp/diff_new_pack.V32u8I/_old  2016-10-06 12:35:38.0 +0200
+++ /var/tmp/diff_new_pack.V32u8I/_new  2016-10-06 12:35:38.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-h for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-h for openSUSE:Factory 
checked in at 2016-10-06 12:34:42

Comparing /work/SRC/openSUSE:Factory/texlive-specs-h (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-h.new (New)


Package is "texlive-specs-h"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-h/texlive-specs-h.changes  
2016-08-22 10:01:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-h.new/texlive-specs-h.changes 
2016-10-06 12:34:43.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-h.spec ++
--- /var/tmp/diff_new_pack.F7qmPl/_old  2016-10-06 12:34:50.0 +0200
+++ /var/tmp/diff_new_pack.F7qmPl/_new  2016-10-06 12:34:50.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-i for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-i for openSUSE:Factory 
checked in at 2016-10-06 12:34:57

Comparing /work/SRC/openSUSE:Factory/texlive-specs-i (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-i.new (New)


Package is "texlive-specs-i"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-i/texlive-specs-i.changes  
2016-08-22 10:01:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-i.new/texlive-specs-i.changes 
2016-10-06 12:34:58.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-i.spec ++
--- /var/tmp/diff_new_pack.FjAdwC/_old  2016-10-06 12:35:10.0 +0200
+++ /var/tmp/diff_new_pack.FjAdwC/_new  2016-10-06 12:35:10.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-g for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-g for openSUSE:Factory 
checked in at 2016-10-06 12:34:22

Comparing /work/SRC/openSUSE:Factory/texlive-specs-g (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-g.new (New)


Package is "texlive-specs-g"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-g/texlive-specs-g.changes  
2016-08-22 10:01:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-g.new/texlive-specs-g.changes 
2016-10-06 12:34:23.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-g.spec ++
--- /var/tmp/diff_new_pack.57lJzV/_old  2016-10-06 12:34:31.0 +0200
+++ /var/tmp/diff_new_pack.57lJzV/_new  2016-10-06 12:34:31.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-f for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-f for openSUSE:Factory 
checked in at 2016-10-06 12:33:58

Comparing /work/SRC/openSUSE:Factory/texlive-specs-f (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-f.new (New)


Package is "texlive-specs-f"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-f/texlive-specs-f.changes  
2016-08-22 10:01:05.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-f.new/texlive-specs-f.changes 
2016-10-06 12:33:59.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-f.spec ++
--- /var/tmp/diff_new_pack.n2JR4P/_old  2016-10-06 12:34:06.0 +0200
+++ /var/tmp/diff_new_pack.n2JR4P/_new  2016-10-06 12:34:06.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-d for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-d for openSUSE:Factory 
checked in at 2016-10-06 12:33:15

Comparing /work/SRC/openSUSE:Factory/texlive-specs-d (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-d.new (New)


Package is "texlive-specs-d"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-d/texlive-specs-d.changes  
2016-08-22 10:00:57.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-d.new/texlive-specs-d.changes 
2016-10-06 12:33:15.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-d.spec ++
--- /var/tmp/diff_new_pack.Sveslj/_old  2016-10-06 12:33:24.0 +0200
+++ /var/tmp/diff_new_pack.Sveslj/_new  2016-10-06 12:33:24.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-e for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-e for openSUSE:Factory 
checked in at 2016-10-06 12:33:35

Comparing /work/SRC/openSUSE:Factory/texlive-specs-e (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-e.new (New)


Package is "texlive-specs-e"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-e/texlive-specs-e.changes  
2016-08-22 10:03:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-e.new/texlive-specs-e.changes 
2016-10-06 12:33:37.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--



commit texlive-specs-c for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-c for openSUSE:Factory 
checked in at 2016-10-06 12:32:57

Comparing /work/SRC/openSUSE:Factory/texlive-specs-c (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-c.new (New)


Package is "texlive-specs-c"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-c/texlive-specs-c.changes  
2016-08-22 10:00:48.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-c.new/texlive-specs-c.changes 
2016-10-06 12:32:58.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-c.spec ++
--- /var/tmp/diff_new_pack.FSb8hs/_old  2016-10-06 12:33:05.0 +0200
+++ /var/tmp/diff_new_pack.FSb8hs/_new  2016-10-06 12:33:05.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-b for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-b for openSUSE:Factory 
checked in at 2016-10-06 12:32:40

Comparing /work/SRC/openSUSE:Factory/texlive-specs-b (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-b.new (New)


Package is "texlive-specs-b"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-b/texlive-specs-b.changes  
2016-08-22 10:00:39.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-b.new/texlive-specs-b.changes 
2016-10-06 12:32:41.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-b.spec ++
--- /var/tmp/diff_new_pack.P53mMv/_old  2016-10-06 12:32:49.0 +0200
+++ /var/tmp/diff_new_pack.P53mMv/_new  2016-10-06 12:32:49.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit texlive-specs-a for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package texlive-specs-a for openSUSE:Factory 
checked in at 2016-10-06 12:32:24

Comparing /work/SRC/openSUSE:Factory/texlive-specs-a (Old)
 and  /work/SRC/openSUSE:Factory/.texlive-specs-a.new (New)


Package is "texlive-specs-a"

Changes:

--- /work/SRC/openSUSE:Factory/texlive-specs-a/texlive-specs-a.changes  
2016-08-22 10:00:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.texlive-specs-a.new/texlive-specs-a.changes 
2016-10-06 12:32:26.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 27 12:42:09 UTC 2016 - wer...@suse.de
+
+- Add patch latexpand_perl.dif to fix boo#983823 --
+  latexpand does not work anymore after Tumbleweed update 
+
+---



Other differences:
--
++ texlive-specs-a.spec ++
--- /var/tmp/diff_new_pack.CFHTu3/_old  2016-10-06 12:32:37.0 +0200
+++ /var/tmp/diff_new_pack.CFHTu3/_new  2016-10-06 12:32:37.0 +0200
@@ -19,7 +19,7 @@
 %define texlive_version  2016
 %define texlive_previous 2015
 %define texlive_release  20160523
-%define texlive_noarch   110
+%define texlive_noarch   111
 
 #!BuildIgnore:  texlive
 




commit xkeyboard-config for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package xkeyboard-config for 
openSUSE:Factory checked in at 2016-10-06 12:31:41

Comparing /work/SRC/openSUSE:Factory/xkeyboard-config (Old)
 and  /work/SRC/openSUSE:Factory/.xkeyboard-config.new (New)


Package is "xkeyboard-config"

Changes:

--- /work/SRC/openSUSE:Factory/xkeyboard-config/xkeyboard-config.changes
2016-06-12 18:54:06.0 +0200
+++ /work/SRC/openSUSE:Factory/.xkeyboard-config.new/xkeyboard-config.changes   
2016-10-06 12:31:42.0 +0200
@@ -1,0 +2,6 @@
+Tue Oct  4 12:21:23 UTC 2016 - sndir...@suse.com
+
+- Update to version 2.19
+  * Bug fixes and performance improvements  
+
+---

Old:

  xkeyboard-config-2.18.tar.bz2

New:

  xkeyboard-config-2.19.tar.bz2



Other differences:
--
++ xkeyboard-config.spec ++
--- /var/tmp/diff_new_pack.7qR7U0/_old  2016-10-06 12:31:43.0 +0200
+++ /var/tmp/diff_new_pack.7qR7U0/_new  2016-10-06 12:31:43.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   xkeyboard-config
-Version:2.18
+Version:2.19
 Release:0
 Summary:The X Keyboard Extension
 License:GPL-2.0+ and LGPL-2.1+ and MIT and CDDL-1.0

++ xkeyboard-config-2.18.tar.bz2 -> xkeyboard-config-2.19.tar.bz2 ++
 68800 lines of diff (skipped)




commit git for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package git for openSUSE:Factory checked in 
at 2016-10-06 12:31:02

Comparing /work/SRC/openSUSE:Factory/git (Old)
 and  /work/SRC/openSUSE:Factory/.git.new (New)


Package is "git"

Changes:

--- /work/SRC/openSUSE:Factory/git/git.changes  2016-09-17 14:38:38.0 
+0200
+++ /work/SRC/openSUSE:Factory/.git.new/git.changes 2016-10-06 
12:31:03.0 +0200
@@ -1,0 +2,16 @@
+Tue Oct  4 11:21:51 UTC 2016 - astie...@suse.com
+
+- git 2.10.1:
+  * documentation and command output updates
+  * Prevents loops on submodules with broken metadata
+  * Forbid removal of the symbolic reference HEAD
+  * Update Japanese translation for "git-gui".
+  * Fix "git commit-tree" reading commit.gpgsign configuration
+  * Ignore merges when matching with "git log --cherry-pick"
+  * Fix "git format-patch --base=..." usage of signature separator
+ * "git add --chmod=+x " added recently only toggled the
+   executable bit for paths that are either new or modified. This has
+   been corrected to flip the executable bit for all paths that match
+   the given pathspec.
+
+---

Old:

  git-2.10.0.tar.sign
  git-2.10.0.tar.xz

New:

  git-2.10.1.tar.sign
  git-2.10.1.tar.xz



Other differences:
--
++ git.spec ++
--- /var/tmp/diff_new_pack.iAyh1Z/_old  2016-10-06 12:31:04.0 +0200
+++ /var/tmp/diff_new_pack.iAyh1Z/_new  2016-10-06 12:31:04.0 +0200
@@ -26,7 +26,7 @@
 %endif
 
 Name:   git
-Version:2.10.0
+Version:2.10.1
 Release:0
 Summary:Fast, scalable, distributed revision control system
 License:GPL-2.0

++ git-2.10.0.tar.xz -> git-2.10.1.tar.xz ++
 9206 lines of diff (skipped)





commit sgml-skel for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package sgml-skel for openSUSE:Factory 
checked in at 2016-10-06 12:31:23

Comparing /work/SRC/openSUSE:Factory/sgml-skel (Old)
 and  /work/SRC/openSUSE:Factory/.sgml-skel.new (New)


Package is "sgml-skel"

Changes:

--- /work/SRC/openSUSE:Factory/sgml-skel/sgml-skel.changes  2016-07-01 
09:54:48.0 +0200
+++ /work/SRC/openSUSE:Factory/.sgml-skel.new/sgml-skel.changes 2016-10-06 
12:31:23.0 +0200
@@ -1,0 +2,7 @@
+Tue Oct  4 11:37:09 UTC 2016 - t...@opensuse.org
+
+- Fix for bsc#1002759: change order in /etc/xml/catalog
+  Needed to make precedence of catalog-d.xml over older method
+  (suse-catalog.xml)
+
+---



Other differences:
--
++ sgml-skel.spec ++
--- /var/tmp/diff_new_pack.Hq5WvL/_old  2016-10-06 12:31:24.0 +0200
+++ /var/tmp/diff_new_pack.Hq5WvL/_new  2016-10-06 12:31:24.0 +0200
@@ -62,8 +62,9 @@
 touch %{buildroot}%{_sysconfdir}/sgml/catalog
 xmlcatalog --noout --create %{buildroot}%{_sysconfdir}/xml/suse-catalog.xml
 xmlcatalog --noout --create %{buildroot}%{_sysconfdir}/xml/catalog
-xmlcatalog --noout --add  "nextCatalog" "suse-catalog.xml" "suse-catalog.xml" 
%{buildroot}%{_sysconfdir}/xml/catalog
+# Use correct order: first new method, second old method
 xmlcatalog --noout --add  "nextCatalog" "catalog-d.xml" "catalog-d.xml" 
%{buildroot}%{_sysconfdir}/xml/catalog
+xmlcatalog --noout --add  "nextCatalog" "suse-catalog.xml" "suse-catalog.xml" 
%{buildroot}%{_sysconfdir}/xml/catalog
 install -d -m755 %{buildroot}%{_sysconfdir}/xml/catalog.d
 
 %post




commit os-prober for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package os-prober for openSUSE:Factory 
checked in at 2016-10-06 12:30:45

Comparing /work/SRC/openSUSE:Factory/os-prober (Old)
 and  /work/SRC/openSUSE:Factory/.os-prober.new (New)


Package is "os-prober"

Changes:

--- /work/SRC/openSUSE:Factory/os-prober/os-prober.changes  2016-09-27 
13:41:48.0 +0200
+++ /work/SRC/openSUSE:Factory/.os-prober.new/os-prober.changes 2016-10-06 
12:30:46.0 +0200
@@ -1,0 +2,6 @@
+Tue Oct  4 08:28:26 UTC 2016 - mch...@suse.com
+
+- Handle /etc/os-release symlink (bsc#997465)
+  * refresh os-prober-linux-distro-parse-os-release.patch
+
+---



Other differences:
--
++ os-prober-linux-distro-parse-os-release.patch ++
--- /var/tmp/diff_new_pack.RhVjK2/_old  2016-10-06 12:30:47.0 +0200
+++ /var/tmp/diff_new_pack.RhVjK2/_new  2016-10-06 12:30:47.0 +0200
@@ -2,10 +2,21 @@
 ===
 --- os-prober-1.70.orig/os-probes/mounted/common/90linux-distro
 +++ os-prober-1.70/os-probes/mounted/common/90linux-distro
-@@ -117,6 +117,9 @@ elif [ -e "$dir/etc/lfs-release" ]; then
+@@ -117,6 +117,20 @@ elif [ -e "$dir/etc/lfs-release" ]; then
  elif [ -e "$dir/etc/meego-release" ]; then
short="MeeGo"
long="$(head -1 "$dir/etc/meego-release")"
++elif [ -L "$dir/etc/os-release" ]; then
++  RELPATH=$(readlink -f "$dir/etc/os-release")
++  if readlink "$dir/etc/os-release" | grep -q '^/'; then
++  RELPATH="$dir$RELPATH"
++  fi
++  if [ -f "$RELPATH" ]; then
++  short=$(sed -n "/^NAME=/{s@\"\(.*\)\"@\1@;t 1;s@'\(.*\)'@\1@;: 
1;s@^[^=]\+=@@;p;b}" "$RELPATH")
++  long="$short $(sed -n "/^VERSION=/{s@\"\(.*\)\"@\1@;t 
1;s@'\(.*\)'@\1@;: 1;s@^[^=]\+=@@;p;b}" "$RELPATH")"
++  else
++  exit 1
++  fi
 +elif [ -e "$dir/etc/os-release" ]; then
 +  short=$(sed -n "/^NAME=/{s@\"\(.*\)\"@\1@;t 1;s@'\(.*\)'@\1@;: 
1;s@^[^=]\+=@@;p;b}" $dir/etc/os-release)
 +  long="$short $(sed -n "/^VERSION=/{s@\"\(.*\)\"@\1@;t 
1;s@'\(.*\)'@\1@;: 1;s@^[^=]\+=@@;p;b}" $dir/etc/os-release)"




commit yast2-users for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package yast2-users for openSUSE:Factory 
checked in at 2016-10-06 12:30:21

Comparing /work/SRC/openSUSE:Factory/yast2-users (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-users.new (New)


Package is "yast2-users"

Changes:

--- /work/SRC/openSUSE:Factory/yast2-users/yast2-users.changes  2016-09-27 
13:43:10.0 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-users.new/yast2-users.changes 
2016-10-06 12:30:22.0 +0200
@@ -1,0 +2,7 @@
+Tue Oct  4 13:12:40 CEST 2016 - sch...@suse.de
+
+- Checking all possible /home mount points (/mnt/home and /home).
+  (bnc#995299)
+- 3.1.61
+
+---

Old:

  yast2-users-3.1.60.tar.bz2

New:

  yast2-users-3.1.61.tar.bz2



Other differences:
--
++ yast2-users.spec ++
--- /var/tmp/diff_new_pack.2h87mC/_old  2016-10-06 12:30:24.0 +0200
+++ /var/tmp/diff_new_pack.2h87mC/_new  2016-10-06 12:30:24.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-users
-Version:3.1.60
+Version:3.1.61
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-users-3.1.60.tar.bz2 -> yast2-users-3.1.61.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-users-3.1.60/package/yast2-users.changes 
new/yast2-users-3.1.61/package/yast2-users.changes
--- old/yast2-users-3.1.60/package/yast2-users.changes  2016-09-21 
16:21:01.0 +0200
+++ new/yast2-users-3.1.61/package/yast2-users.changes  2016-10-04 
13:33:29.0 +0200
@@ -1,4 +1,11 @@
 ---
+Tue Oct  4 13:12:40 CEST 2016 - sch...@suse.de
+
+- Checking all possible /home mount points (/mnt/home and /home).
+  (bnc#995299)
+- 3.1.61
+
+---
 Wed Sep 21 13:25:22 UTC 2016 - mvid...@suse.com
 
 - Do not require yast2-ldap for build time tests (bsc#999203).
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-users-3.1.60/package/yast2-users.spec 
new/yast2-users-3.1.61/package/yast2-users.spec
--- old/yast2-users-3.1.60/package/yast2-users.spec 2016-09-21 
16:21:01.0 +0200
+++ new/yast2-users-3.1.61/package/yast2-users.spec 2016-10-04 
13:33:29.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-users
-Version:3.1.60
+Version:3.1.61
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-users-3.1.60/src/modules/Users.pm 
new/yast2-users-3.1.61/src/modules/Users.pm
--- old/yast2-users-3.1.60/src/modules/Users.pm 2016-09-21 16:21:01.0 
+0200
+++ new/yast2-users-3.1.61/src/modules/Users.pm 2016-10-04 13:33:30.0 
+0200
@@ -700,17 +700,19 @@
 }
 
 if ($mountpoint_in ne "") {
-my $home_mountpoint = $home;
-if (Stage->initial()) {
-$home_mountpoint = Installation->destdir() . $home_mountpoint;
-}
-y2milestone("homes mount point is", $home_mountpoint);
+my $dest_home_mountpoint = Installation->destdir() . $home;
+
+y2milestone("home mount points are:", $dest_home_mountpoint, ",", 
$home);
 my $mounted= 0;
 my $mtab   = SCR->Read (".etc.mtab");
if (defined $mtab && ref ($mtab) eq "ARRAY") {
foreach my $line (@{$mtab}) {
my %line= %{$line};
-   if ($line{"file"} eq $home_mountpoint) {
+# While installing package "systemd" the /etc/mtab entries 
will be
+# changed from e.g. /home to /mnt/home. This will be done in 
SLES12
+# only and not for e.g. LEAP. So we have to check both.
+# (bnc#995299, bnc#980878)
+   if ($line{"file"} eq $dest_home_mountpoint || $line{"file"} eq 
$home ) {
$mounted = 1;
}
}




commit python-Twisted for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package python-Twisted for openSUSE:Factory 
checked in at 2016-10-06 12:29:50

Comparing /work/SRC/openSUSE:Factory/python-Twisted (Old)
 and  /work/SRC/openSUSE:Factory/.python-Twisted.new (New)


Package is "python-Twisted"

Changes:

--- /work/SRC/openSUSE:Factory/python-Twisted/python-Twisted.changes
2016-09-11 00:51:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-Twisted.new/python-Twisted.changes   
2016-10-06 12:29:51.0 +0200
@@ -1,0 +2,7 @@
+Wed Sep 28 04:10:24 UTC 2016 - a...@gmx.de
+
+- specfile:
+  * make twistd the update-alternative master, same as in the python3
+version (bnc #1001523)
+
+---



Other differences:
--
++ python-Twisted.spec ++
--- /var/tmp/diff_new_pack.uRBEca/_old  2016-10-06 12:29:52.0 +0200
+++ /var/tmp/diff_new_pack.uRBEca/_new  2016-10-06 12:29:52.0 +0200
@@ -120,7 +120,8 @@
 
 %post
 %_sbindir/update-alternatives \
-   --install %{_bindir}/trial trial %{_bindir}/trial-%{py_ver} 30 \
+   --install %{_bindir}/twistd twistd %{_bindir}/twistd-%{py_ver} 30 \
+   --slave %{_bindir}/trial trial %{_bindir}/trial-%{py_ver} \
--slave %{_bindir}/cftp cftp %{_bindir}/cftp-%{py_ver} \
--slave %{_bindir}/ckeygen ckeygen %{_bindir}/ckeygen-%{py_ver} \
--slave %{_bindir}/conch conch %{_bindir}/conch-%{py_ver} \
@@ -128,7 +129,6 @@
--slave %{_bindir}/pyhtmlizer pyhtmlizer %{_bindir}/pyhtmlizer-%{py_ver} \
--slave %{_bindir}/tkconch tkconch %{_bindir}/tkconch-%{py_ver} \
--slave %{_bindir}/twist twist %{_bindir}/twist-%{py_ver} \
-   --slave %{_bindir}/twistd twistd %{_bindir}/twistd-%{py_ver} \
--slave %{_mandir}/man1/trial.1.gz trial.1.gz 
%{_mandir}/man1/trial-%{py_ver}.1.gz \
--slave %{_mandir}/man1/cftp.1.gz cftp.1.gz 
%{_mandir}/man1/cftp-%{py_ver}.1.gz \
--slave %{_mandir}/man1/ckeygen.1.gz ckeygen.1.gz 
%{_mandir}/man1/ckeygen-%{py_ver}.1.gz \
@@ -140,7 +140,7 @@
 
 %postun
 if [ $1 -eq 0 ] ; then
-%_sbindir/update-alternatives --remove trial %{_bindir}/trial-%{py_ver}
+%_sbindir/update-alternatives --remove twistd %{_bindir}/twistd-%{py_ver}
 fi
 
 %files doc




commit xf86-input-evdev for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package xf86-input-evdev for 
openSUSE:Factory checked in at 2016-10-06 12:29:30

Comparing /work/SRC/openSUSE:Factory/xf86-input-evdev (Old)
 and  /work/SRC/openSUSE:Factory/.xf86-input-evdev.new (New)


Package is "xf86-input-evdev"

Changes:

--- /work/SRC/openSUSE:Factory/xf86-input-evdev/xf86-input-evdev.changes
2016-06-05 14:19:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.xf86-input-evdev.new/xf86-input-evdev.changes   
2016-10-06 12:29:31.0 +0200
@@ -1,0 +2,6 @@
+Sat Oct  1 19:35:04 UTC 2016 - mimi...@gmail.com
+
+- update to version 2.10.4
+  * Support XINPUT ABI version 23 and 24
+
+---

Old:

  xf86-input-evdev-2.10.3.tar.bz2
  xf86-input-evdev-2.10.3.tar.bz2.sig

New:

  xf86-input-evdev-2.10.4.tar.bz2
  xf86-input-evdev-2.10.4.tar.bz2.sig



Other differences:
--
++ xf86-input-evdev.spec ++
--- /var/tmp/diff_new_pack.JwcVSA/_old  2016-10-06 12:29:32.0 +0200
+++ /var/tmp/diff_new_pack.JwcVSA/_new  2016-10-06 12:29:32.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   xf86-input-evdev
-Version:2.10.3
+Version:2.10.4
 Release:0
 Summary:Generic Linux input driver for the Xorg X server
 License:MIT
@@ -74,7 +74,7 @@
 
 %build
 # Once u_01-Add-a-kiosk-mode-for-touch-screens.patch is removed this is no 
longer needed
-/usr/bin/autoreconf -v --install --force
+%{_bindir}/autoreconf -v --install --force
 %configure
 make %{?_smp_mflags} V=1
 
@@ -103,7 +103,7 @@
 %{_datadir}/X11/xorg.conf.d/10-*.conf
 %dir %{_libdir}/xorg/modules/input
 %{_libdir}/xorg/modules/input/evdev_drv.so
-%{_datadir}/man/man4/evdev.4%{?ext_man}
+%{_mandir}/man4/evdev.4%{?ext_man}
 
 %files devel
 %defattr(-,root,root)

++ xf86-input-evdev-2.10.3.tar.bz2 -> xf86-input-evdev-2.10.4.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/xf86-input-evdev-2.10.3/ChangeLog 
new/xf86-input-evdev-2.10.4/ChangeLog
--- old/xf86-input-evdev-2.10.3/ChangeLog   2016-06-01 03:41:52.0 
+0200
+++ new/xf86-input-evdev-2.10.4/ChangeLog   2016-10-01 09:54:15.0 
+0200
@@ -1,3 +1,45 @@
+commit 551db5b86e2a19e027e57571b8e5405dacb8bd67
+Author: Peter Hutterer 
+Date:   Sat Oct 1 17:48:30 2016 +1000
+
+evdev 2.10.4
+
+Signed-off-by: Peter Hutterer 
+
+commit bb8bde7456def4186f9a4a0a9f98d53c949e1450
+Author: Keith Packard 
+Date:   Tue May 31 17:52:43 2016 -0700
+
+Support XINPUT ABI 24 (remove select mask from block/wakeup handlers)
+
+The evdev driver wasn't using the select mask arguments, so this
+change just involves adjusting the argument lists.
+
+Signed-off-by: Keith Packard 
+Signed-off-by: Peter Hutterer 
+
+commit 7b1267f7f18c478d3dc34a7668eaefa402815891
+Author: Keith Packard 
+Date:   Tue May 31 17:52:42 2016 -0700
+
+Support XINPUT ABI version 23 (threaded input)
+
+Use input_lock/input_unlock calls instead of SIGIO functions
+
+Signed-off-by: Keith Packard 
+Signed-off-by: Peter Hutterer 
+
+commit e08b0332761b0cff6d6a3f5d7e88c22f786bd530
+Author: Keith Packard 
+Date:   Tue May 31 17:52:41 2016 -0700
+
+Report errors when attempting to write keyboard controls
+
+This is mostly to eliminate a compiler warning.
+
+Signed-off-by: Keith Packard 
+Signed-off-by: Peter Hutterer 
+
 commit 7c1971d9e7b73b861874633a33f97487abf1d45d
 Author: Peter Hutterer 
 Date:   Wed Jun 1 11:41:03 2016 +1000
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/xf86-input-evdev-2.10.3/configure 
new/xf86-input-evdev-2.10.4/configure
--- old/xf86-input-evdev-2.10.3/configure   2016-06-01 03:41:11.0 
+0200
+++ new/xf86-input-evdev-2.10.4/configure   2016-10-01 09:49:20.0 
+0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for xf86-input-evdev 2.10.3.
+# Generated by GNU Autoconf 2.69 for xf86-input-evdev 2.10.4.
 #
 # Report bugs to .
 #
@@ -591,8 +591,8 @@
 # Identity of this package.
 PACKAGE_NAME='xf86-input-evdev'
 PACKAGE_TARNAME='xf86-input-evdev'
-PACKAGE_VERSION='2.10.3'
-PACKAGE_STRING='xf86-input-evdev 2.10.3'
+PACKAGE_VERSION='2.10.4'
+PACKAGE_STRING='xf86-input-evdev 

commit libdrm for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package libdrm for openSUSE:Factory checked 
in at 2016-10-06 12:29:18

Comparing /work/SRC/openSUSE:Factory/libdrm (Old)
 and  /work/SRC/openSUSE:Factory/.libdrm.new (New)


Package is "libdrm"

Changes:

--- /work/SRC/openSUSE:Factory/libdrm/libdrm.changes2016-08-03 
11:38:33.0 +0200
+++ /work/SRC/openSUSE:Factory/.libdrm.new/libdrm.changes   2016-10-06 
12:29:19.0 +0200
@@ -1,0 +2,16 @@
+Tue Oct  4 08:21:19 UTC 2016 - mimi...@gmail.com
+
+- update to 2.4.71
+*  amdgpu: expose the AMDGPU_GEM_CREATE_VRAM_CLEARED flag
+*  Add drmModeAddFB2WithModifiers() which takes format modifiers
+*  tests/amdgpu: update vce encRefPic addr mode to tiled
+*  radeon: sync radeon_drm.h with the kernel
+*  amdgpu: sync amdgpu_drm.h with the kernel
+*  amdgpu: fix valgrind warnings caused by amdgpu_query_firmware_version
+*  intel: Add new symbols to intel-symbol-check
+*  amdgpu: add SI support
+*  modetest: Also print the pixel clock
+*  intel: Export pooled EU and min no. of eus in a pool
+*  modetest: Adding amdgpu to module list
+
+---

Old:

  libdrm-2.4.70.tar.bz2

New:

  libdrm-2.4.71.tar.bz2



Other differences:
--
++ libdrm.spec ++
--- /var/tmp/diff_new_pack.U4j8iz/_old  2016-10-06 12:29:20.0 +0200
+++ /var/tmp/diff_new_pack.U4j8iz/_new  2016-10-06 12:29:20.0 +0200
@@ -17,29 +17,17 @@
 
 
 Name:   libdrm
-Url:http://dri.freedesktop.org/
-Version:2.4.70
+Version:2.4.71
 Release:0
-Provides:   libdrm23 = %{version}
-Obsoletes:  libdrm23 < %{version}
-# bug437293
-%ifarch ppc64
-Obsoletes:  libdrm-64bit < %{version}
-Provides:   libdrm-64bit = %{version}
-%endif
-#
 Summary:Userspace Interface for Kernel DRM Services
 License:MIT
 Group:  System/Libraries
-
+Url:http://dri.freedesktop.org/
 #Git-Clone:git://anongit.freedesktop.org/git/mesa/drm
 #Git-Web:  http://cgit.freedesktop.org/mesa/drm/
 # Source URL:   http://dri.freedesktop.org/libdrm/
 Source: http://dri.freedesktop.org/libdrm/%{name}-%{version}.tar.bz2
 Source2:baselibs.conf
-# PATCH-FIX-UPSTREAM libdrm-implicit-defs.diff fdo#48599 -- Fix compiler 
warnings in tests/radeon/radeon_ttm.c
-
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  autoconf >= 2.63
 BuildRequires:  automake >= 1.10
 BuildRequires:  libtool >= 2.2
@@ -47,8 +35,16 @@
 BuildRequires:  util-macros-devel
 BuildRequires:  pkgconfig(pciaccess) >= 0.10
 BuildRequires:  pkgconfig(pthread-stubs)
+Provides:   libdrm23 = %{version}
+Obsoletes:  libdrm23 < %{version}
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+# bug437293
+%ifarch ppc64
+Obsoletes:  libdrm-64bit < %{version}
+Provides:   libdrm-64bit = %{version}
+%endif
 %if 0%{?with_valgrind_support:1}
-%ifarch %ix86 x86_64 ppc ppc64 ppc64le s390x %arm
+%ifarch %{ix86} x86_64 ppc ppc64 ppc64le s390x %{arm}
 BuildRequires:  pkgconfig(valgrind)
 %endif
 %endif
@@ -60,9 +56,8 @@
 %package tools
 Summary:Diagnostic utilities for DRI and DRM
 Group:  System/Base
-# O/P added in 12.2
-Obsoletes:  libdrm < %version-%release
-Provides:   libdrm = %version-%release
+Obsoletes:  libdrm < %{version}-%{release}
+Provides:   libdrm = %{version}-%{release}
 
 %description tools
 (Upstream has not provided a description)
@@ -70,19 +65,19 @@
 %package devel
 Summary:Libraries, includes and more to develop libdrm applications
 Group:  Development/Libraries/X11
-Requires:   libdrm2 = %version
-Requires:   libdrm_amdgpu1 = %version
-Requires:   libdrm_nouveau2 = %version
-Requires:   libdrm_radeon1 = %version
-%ifarch %arm aarch64
-Requires:   libdrm_freedreno1 = %version
-%endif
-%ifarch %arm
-Requires:   libdrm_omap1 = %version
-Requires:   libdrm_tegra0 = %version
+Requires:   libdrm2 = %{version}
+Requires:   libdrm_amdgpu1 = %{version}
+Requires:   libdrm_nouveau2 = %{version}
+Requires:   libdrm_radeon1 = %{version}
+%ifarch %{arm} aarch64
+Requires:   libdrm_freedreno1 = %{version}
+%endif
+%ifarch %{arm}
+Requires:   libdrm_omap1 = %{version}
+Requires:   libdrm_tegra0 = %{version}
 %endif
-%ifarch %ix86 x86_64
-Requires:   libdrm_intel1 = %version
+%ifarch %{ix86} x86_64
+Requires:   libdrm_intel1 = %{version}
 %endif
 # bug437293
 %ifarch ppc64
@@ -144,7 +139,7 @@
 %package -n libkms-devel
 Summary:Development files for the KMS MM abstraction library
 Group:  Development/Libraries/C and C++
-Requires:   libkms1 = %version
+Requires:   libkms1 = 

commit kdump for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package kdump for openSUSE:Factory checked 
in at 2016-10-06 12:28:48

Comparing /work/SRC/openSUSE:Factory/kdump (Old)
 and  /work/SRC/openSUSE:Factory/.kdump.new (New)


Package is "kdump"

Changes:

--- /work/SRC/openSUSE:Factory/kdump/kdump.changes  2016-02-23 
16:53:29.0 +0100
+++ /work/SRC/openSUSE:Factory/.kdump.new/kdump.changes 2016-10-06 
12:28:50.0 +0200
@@ -1,0 +2,35 @@
+Wed Oct  5 13:12:53 UTC 2016 - ptesa...@suse.com
+
+- Remove kdump-helpers from Provides. This was needed to allow
+  upgrading in SLE10, but this distribution is discontinued now.
+
+---
+Wed Oct  5 10:55:39 UTC 2016 - ptesa...@suse.com
+
+- kdump-cmake-compat.patch: Build fix for pre-3.0.2 cmake.
+
+---
+Wed Oct  5 07:53:00 UTC 2016 - ptesa...@suse.com
+
+- Update to 0.8.16
+- Drop patches now in mainline:
+  o 0001-multipath-Write-proper-regex-into-multipath-conf.patch
+  o kdump-add-IPv6-KDUMP_NETCONFIG-modes.patch
+  o kdump-bootloader-grub2.patch
+  o kdump-calibrate-systemd-initramfs.patch
+  o kdump-calibrate-systemd-runtime.patch
+  o kdump-count-const-slabs.patch
+  o kdump-count-framebuffer.patch
+  o kdump-enable-fadump-ppc64le.patch
+  o kdump-fadump-bootloader-always.patch
+  o kdump-fadump-keep-sysroot.patch
+  o kdump-get-multipath-wwid-from-sysfs.patch
+  o kdump-move-network-setup-to-module-setup.patch
+  o kdump-remove-root-and-resume.patch
+  o kdump-split-kdump_default_netdev.patch
+  o kdump-systemd-support.patch
+  o kdump-use-fstab-device.patch
+- Drop obsolete patches:
+  o kdump-0.8.15-fix-shebang.patch
+
+---

Old:

  0001-multipath-Write-proper-regex-into-multipath-conf.patch
  kdump-0.8.15-fix-shebang.patch
  kdump-0.8.15.tar.bz2
  kdump-add-IPv6-KDUMP_NETCONFIG-modes.patch
  kdump-bootloader-grub2.patch
  kdump-calibrate-systemd-initramfs.patch
  kdump-calibrate-systemd-runtime.patch
  kdump-count-const-slabs.patch
  kdump-count-framebuffer.patch
  kdump-enable-fadump-ppc64le.patch
  kdump-fadump-bootloader-always.patch
  kdump-fadump-keep-sysroot.patch
  kdump-get-multipath-wwid-from-sysfs.patch
  kdump-move-network-setup-to-module-setup.patch
  kdump-remove-root-and-resume.patch
  kdump-split-kdump_default_netdev.patch
  kdump-systemd-support.patch
  kdump-use-fstab-device.patch
  kdump.service

New:

  kdump-0.8.16.tar.bz2
  kdump-cmake-compat.patch



Other differences:
--
++ kdump.spec ++
--- /var/tmp/diff_new_pack.gEwUM5/_old  2016-10-06 12:28:52.0 +0200
+++ /var/tmp/diff_new_pack.gEwUM5/_new  2016-10-06 12:28:52.0 +0200
@@ -16,6 +16,10 @@
 #
 
 
+# on systemd distros, rpm-build requires systemd-rpm-macros,
+# which in turn defines %systemd_requires
+%define systemd_present %{defined systemd_requires}
+
 %define dracutlibdir %{_prefix}/lib/dracut
 
 %{!?_udevdir: %global _udevdir %(pkg-config --variable=udevdir udev)}
@@ -28,76 +32,57 @@
 %endif
 %define _udevrulesdir %{_udevdir}/rules.d
 
-Url:https://github.com/ptesarik/kdump
-
 Name:   kdump
-Version:0.8.15
+Version:0.8.16
 Release:0
-Requires:   curl
-Requires:   makedumpfile
-Requires:   openssh
 Summary:Script for kdump
 License:GPL-2.0+
 Group:  System/Kernel
+Url:https://github.com/ptesarik/kdump
+Source: %{name}-%{version}.tar.bz2
+Source2:%{name}-rpmlintrc
+Patch1: %{name}-cmake-compat.patch
 BuildRequires:  asciidoc
 BuildRequires:  cmake
 BuildRequires:  gcc-c++
+BuildRequires:  libblkid-devel
 BuildRequires:  libcurl-devel
 BuildRequires:  libelf-devel
 BuildRequires:  libesmtp-devel
 BuildRequires:  libopenssl-devel
-BuildRequires:  libssh2-devel
 BuildRequires:  libxslt
-BuildRequires:  pkg-config
+BuildRequires:  pkgconfig
 BuildRequires:  udev
 BuildRequires:  zlib-devel
+Requires:   curl
+Requires:   kexec-tools
+Requires:   makedumpfile
+Requires:   openssh
+PreReq: %insserv_prereq %fillup_prereq
+PreReq: coreutils
+PreReq: sed
+Recommends: cifs-utils
+Recommends: nfs-client
 #!BuildIgnore:  fop
-%if 0%{?suse_version} > 1220
+# update should detect the split-off from kexec-tools
+Provides:   kexec-tools:%{_initddir}/kdump
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+ExcludeArch:s390 ppc
+%if %{systemd_present}
 BuildRequires:  systemd
 %endif
-PreReq: %insserv_prereq %fillup_prereq
 %if 0%{?suse_version} > 1310
 PreReq: dracut
 %else
 PreReq: mkinitrd
 %endif
-Source: 

commit strace for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package strace for openSUSE:Factory checked 
in at 2016-10-06 12:28:35

Comparing /work/SRC/openSUSE:Factory/strace (Old)
 and  /work/SRC/openSUSE:Factory/.strace.new (New)


Package is "strace"

Changes:

--- /work/SRC/openSUSE:Factory/strace/strace.changes2016-08-06 
20:37:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.strace.new/strace.changes   2016-10-06 
12:28:36.0 +0200
@@ -1,0 +2,36 @@
+Wed Oct  5 08:46:49 UTC 2016 - sch...@suse.de
+
+- Update to strace 4.14
+  * Changes in behavior
+* When using -p option without a command and no processes has been 
attached,
+  strace exits with exit status 1.
+  * Improvements
+* Added printing of the mode argument of open and openat syscalls
+  when O_TMPFILE flag is set.  (Addresses Fedora bug #1377846).
+* Enhanced -e abbrev=set, -e raw=set, and -e verbose=set.
+* Enhanced decoding of futex, keyctl, quotactl, timerfd_settime,
+  and aio family syscalls.
+* Implemented fetching of the 7th subcall argument on mips o32.
+* Updated lists of BPF_*, ETH_P_*, KEXEC_ARCH_*, SCTP_*, TCP_*, and *_MAGIC
+  constants.
+* Updated lists of ioctl commands from Linux 4.8.
+* Added decoding of new syscalls on sh and sh64.
+* Added RISC-V architecture support.
+  * Bug fixes
+* Marked io_setup and io_destroy as memory mapping related syscalls.
+* Fixed leakage of placeholder descriptors to tracees.
+* Fixed printing of mode_t, umode_t, and umask types.
+* Fixed decoding of iovec arrays without a limit on total data size.
+* Fixed decoding of fadvise64, fallocate, futex, keyctl, quotactl, 
readahead,
+  and ipc family syscalls.
+* Fixed decoding of invalid syscalls mapped to indirect subcalls.
+* Fixed decoding of struct btrfs_ioctl_vol_args_v2 on non-native
+  personalities.
+* Fixed decoding of PTRACE_DETACH on sparc and sparc64.
+* Fixed decoding of struct stat64 on sparc64.
+* Fixed decoding of uid and gid-related syscalls on sparc64.
+* Fixed decoding of the forth argument of semctl syscall on sparc64.
+* Fixed values of tty ioctl constants on sparc64.
+* Fixed sparc personality support on sparc64.
+
+---

Old:

  strace-4.13.tar.xz
  strace-4.13.tar.xz.asc

New:

  strace-4.14.tar.xz
  strace-4.14.tar.xz.asc



Other differences:
--
++ strace.spec ++
--- /var/tmp/diff_new_pack.nlfxn6/_old  2016-10-06 12:28:37.0 +0200
+++ /var/tmp/diff_new_pack.nlfxn6/_new  2016-10-06 12:28:37.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   strace
-Version:4.13
+Version:4.14
 Release:0
 Summary:A utility to trace the system calls of a program
 License:BSD-3-Clause

++ strace-4.13.tar.xz -> strace-4.14.tar.xz ++
 49680 lines of diff (skipped)




commit MozillaThunderbird for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package MozillaThunderbird for 
openSUSE:Factory checked in at 2016-10-06 12:28:08

Comparing /work/SRC/openSUSE:Factory/MozillaThunderbird (Old)
 and  /work/SRC/openSUSE:Factory/.MozillaThunderbird.new (New)


Package is "MozillaThunderbird"

Changes:

--- /work/SRC/openSUSE:Factory/MozillaThunderbird/MozillaThunderbird.changes
2016-09-01 14:01:49.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.MozillaThunderbird.new/MozillaThunderbird.changes   
2016-10-06 12:28:09.0 +0200
@@ -1,0 +2,13 @@
+Sat Oct  1 07:12:08 UTC 2016 - w...@rosenauer.org
+
+- update to Thunderbird 45.4.0 (boo#999701)
+  * Display name was truncated if no separating space before email
+address.
+  * Recipient addresses were shown in wrong color in some circumstances.
+  * Additional spaces were inserted when drafts were edited.
+  * Mail saved as template copied In-Reply-To and References from
+original email.
+  * Threading broken when editing message draft, due to loss of Message-ID
+  * "Apply columns to..." did not honor special folders
+
+---

Old:

  l10n-45.3.0.tar.xz
  thunderbird-45.3.0-source.tar.xz

New:

  l10n-45.4.0.tar.xz
  thunderbird-45.4.0-source.tar.xz



Other differences:
--
++ MozillaThunderbird.spec ++
--- /var/tmp/diff_new_pack.R8iQZq/_old  2016-10-06 12:28:26.0 +0200
+++ /var/tmp/diff_new_pack.R8iQZq/_new  2016-10-06 12:28:26.0 +0200
@@ -17,9 +17,9 @@
 #
 
 
-%define mainversion 45.3.0
+%define mainversion 45.4.0
 %define update_channel release
-%define releasedate 2016082900
+%define releasedate 2016093000
 
 %if %suse_version > 1310
 %define gstreamer_ver 1.0


++ compare-locales.tar.xz ++

++ create-tar.sh ++
--- /var/tmp/diff_new_pack.R8iQZq/_old  2016-10-06 12:28:27.0 +0200
+++ /var/tmp/diff_new_pack.R8iQZq/_new  2016-10-06 12:28:27.0 +0200
@@ -2,8 +2,8 @@
 
 CHANNEL="esr45"
 BRANCH="releases/comm-$CHANNEL"
-RELEASE_TAG="THUNDERBIRD_45_3_0_RELEASE"
-VERSION="45.3.0"
+RELEASE_TAG="THUNDERBIRD_45_4_0_RELEASE"
+VERSION="45.4.0"
 
 echo "cloning $BRANCH..."
 hg clone http://hg.mozilla.org/$BRANCH thunderbird

++ l10n-45.3.0.tar.xz -> l10n-45.4.0.tar.xz ++
/work/SRC/openSUSE:Factory/MozillaThunderbird/l10n-45.3.0.tar.xz 
/work/SRC/openSUSE:Factory/.MozillaThunderbird.new/l10n-45.4.0.tar.xz differ: 
char 26, line 1

++ thunderbird-45.3.0-source.tar.xz -> thunderbird-45.4.0-source.tar.xz 
++
/work/SRC/openSUSE:Factory/MozillaThunderbird/thunderbird-45.3.0-source.tar.xz 
/work/SRC/openSUSE:Factory/.MozillaThunderbird.new/thunderbird-45.4.0-source.tar.xz
 differ: char 26, line 1





commit libqt5-qtwebengine for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package libqt5-qtwebengine for 
openSUSE:Factory checked in at 2016-10-06 12:28:24

Comparing /work/SRC/openSUSE:Factory/libqt5-qtwebengine (Old)
 and  /work/SRC/openSUSE:Factory/.libqt5-qtwebengine.new (New)


Package is "libqt5-qtwebengine"

Changes:

--- /work/SRC/openSUSE:Factory/libqt5-qtwebengine/libqt5-qtwebengine.changes
2016-10-01 23:50:34.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.libqt5-qtwebengine.new/libqt5-qtwebengine.changes   
2016-10-06 12:28:28.0 +0200
@@ -1,0 +2,5 @@
+Wed Oct  5 09:54:47 UTC 2016 - hrvoje.sen...@gmail.com
+
+- Added Do-not-depend-on-Linux-4.5.patch (boo#1002873)
+
+---

New:

  Do-not-depend-on-Linux-4.5.patch



Other differences:
--
++ libqt5-qtwebengine.spec ++
--- /var/tmp/diff_new_pack.E7CgdA/_old  2016-10-06 12:28:33.0 +0200
+++ /var/tmp/diff_new_pack.E7CgdA/_new  2016-10-06 12:28:33.0 +0200
@@ -39,6 +39,8 @@
 Patch2: armv6-ffmpeg-no-thumb.patch
 # PATCH-FIX-UPSTREAM webrtc-build-with-neon.patch - Properly configure webrtc 
for neon support
 Patch3: webrtc-build-with-neon.patch
+# PATCH-FIX-UPSTREAM Do-not-depend-on-Linux-4.5.patch
+Patch4: Do-not-depend-on-Linux-4.5.patch
 # http://www.chromium.org/blink not ported to PowerPC
 ExcludeArch:ppc ppc64 ppc64le s390 s390x
 # Try to fix i586 MemoryErrors with rpmlint
@@ -149,6 +151,7 @@
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %package devel
 Summary:Qt Development Kit

++ Do-not-depend-on-Linux-4.5.patch ++
>From b12ffcd411d4776f7120ccecb3be34344d930d2b Mon Sep 17 00:00:00 2001
From: Allan Sandfeld Jensen 
Date: Tue, 9 Aug 2016 16:21:29 +0200
Subject: Do not depend on Linux 4.5

Avoid using MADV_FREE that was only recently added to Linux. It will fail when
run on older Linux kernels.

Change-Id: I9b0369fb31402f088b2327c12f70dd39f5e4c8c0
Reviewed-by: Peter Varga 
---
 src/3rdparty/chromium/third_party/WebKit/Source/wtf/PageAllocator.cpp | 5 +
 1 file changed, 5 insertions(+)

diff --git 
a/src/3rdparty/chromium/third_party/WebKit/Source/wtf/PageAllocator.cpp 
b/src/3rdparty/chromium/third_party/WebKit/Source/wtf/PageAllocator.cpp
index 121b687..be7c3b9 100644
--- a/src/3rdparty/chromium/third_party/WebKit/Source/wtf/PageAllocator.cpp
+++ b/src/3rdparty/chromium/third_party/WebKit/Source/wtf/PageAllocator.cpp
@@ -39,6 +39,11 @@
 
 #include 
 
+#if OS(LINUX) && defined(MADV_FREE)
+// Added in Linux 4.5, but we don't want to depend on 4.5 at runtime
+#undef MADV_FREE
+#endif
+
 #ifndef MADV_FREE
 #define MADV_FREE MADV_DONTNEED
 #endif
-- 
cgit v1.0-4-g1e03



commit libass for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package libass for openSUSE:Factory checked 
in at 2016-10-06 12:27:57

Comparing /work/SRC/openSUSE:Factory/libass (Old)
 and  /work/SRC/openSUSE:Factory/.libass.new (New)


Package is "libass"

Changes:

--- /work/SRC/openSUSE:Factory/libass/libass.changes2016-02-29 
09:12:28.0 +0100
+++ /work/SRC/openSUSE:Factory/.libass.new/libass.changes   2016-10-06 
12:27:57.0 +0200
@@ -1,0 +2,11 @@
+Wed Oct  5 08:22:48 UTC 2016 - tchva...@suse.com
+
+- Update 0.13.4:
+  * Fuzzing fixes bnc#1002982 CVE-2016-7969 CVE-2016-7972
+  * Improve compatibility/portablility of build system, should fix e.g. 
compilation on Solaris.
+  * Fix memory leak in DirectWrite font provider.
+  * Fix the rasterizer when rendering some large outlines.
+  * Remove hack that forced RTL base direction depending on font encoding.
+  * Greatly improve the internal caches with refcounting and gradual clearing.
+
+---

Old:

  libass-0.13.2.tar.xz

New:

  libass-0.13.4.tar.xz



Other differences:
--
++ libass.spec ++
--- /var/tmp/diff_new_pack.4RQds5/_old  2016-10-06 12:27:59.0 +0200
+++ /var/tmp/diff_new_pack.4RQds5/_new  2016-10-06 12:27:59.0 +0200
@@ -18,7 +18,7 @@
 
 %define soname 5
 Name:   libass
-Version:0.13.2
+Version:0.13.4
 Release:0
 Summary:Library for SSA/ASS-formatted subtitle rendering
 License:ISC
@@ -53,10 +53,10 @@
 Group:  Development/Libraries/C and C++
 Requires:   glibc-devel
 Requires:   libass%{soname} = %{version}
-Requires:   pkgconfig(enca)
 Requires:   pkgconfig(fontconfig)
 Requires:   pkgconfig(freetype2) >= 9.10.3
 Requires:   pkgconfig(fribidi) >= 0.19.0
+Requires:   pkgconfig(harfbuzz)
 
 %description devel
 This package is needed if you want to develop / compile against libASS.

++ libass-0.13.2.tar.xz -> libass-0.13.4.tar.xz ++
 3542 lines of diff (skipped)




commit gmime for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package gmime for openSUSE:Factory checked 
in at 2016-10-06 12:27:45

Comparing /work/SRC/openSUSE:Factory/gmime (Old)
 and  /work/SRC/openSUSE:Factory/.gmime.new (New)


Package is "gmime"

Changes:

--- /work/SRC/openSUSE:Factory/gmime/gmime.changes  2016-08-05 
18:12:18.0 +0200
+++ /work/SRC/openSUSE:Factory/.gmime.new/gmime.changes 2016-10-06 
12:27:46.0 +0200
@@ -1,0 +2,7 @@
+Mon Oct  3 13:03:29 UTC 2016 - dims...@opensuse.org
+
+- Add baselibs.conf:
+  + produce libgmime-2_6-0-32bit package, needed by
+libxplayer-plparser18-32bit.
+
+---

New:

  baselibs.conf



Other differences:
--
++ gmime.spec ++
--- /var/tmp/diff_new_pack.ldOan5/_old  2016-10-06 12:27:47.0 +0200
+++ /var/tmp/diff_new_pack.ldOan5/_new  2016-10-06 12:27:47.0 +0200
@@ -26,6 +26,7 @@
 License:LGPL-2.1+
 Group:  Productivity/Networking/Email/Utilities
 Source: 
http://download.gnome.org/sources/gmime/2.6/%{name}-%{version}.tar.xz
+Source99:   baselibs.conf
 BuildRequires:  gobject-introspection-devel >= 1.30.0
 BuildRequires:  gpgme-devel
 BuildRequires:  gtk-doc

++ baselibs.conf ++
libgmime-2_6-0



commit package-translations for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package package-translations for 
openSUSE:Factory checked in at 2016-10-06 12:27:35

Comparing /work/SRC/openSUSE:Factory/package-translations (Old)
 and  /work/SRC/openSUSE:Factory/.package-translations.new (New)


Package is "package-translations"

Changes:

--- 
/work/SRC/openSUSE:Factory/package-translations/package-translations.changes
2016-09-09 10:18:54.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.package-translations.new/package-translations.changes
   2016-10-06 12:27:36.0 +0200
@@ -1,0 +2,5 @@
+Sun Oct  2 12:21:02 UTC 2016 - alex...@gmail.com
+
+- automated update on 2016-10-02
+
+---



Other differences:
--
++ PREPARE_PACKAGE ++
--- /var/tmp/diff_new_pack.LSWhkM/_old  2016-10-06 12:27:38.0 +0200
+++ /var/tmp/diff_new_pack.LSWhkM/_new  2016-10-06 12:27:38.0 +0200
@@ -1,21 +1,21 @@
 #!/bin/bash
 
 test -f package-translations.spec || { "cwd must contain 
package-translations.spec"; exit 1; }
-
-if test -d "$MY_LCN_PACK_CHECKOUT"; then
-  echo "Updating $MY_LCN_PACK_CHECKOUT"
-  svn up $MY_LCN_PACK_CHECKOUT
+PWD=$(pwd)
+if test -d "$MY_PKG_I18N_CHECKOUT"; then
+  echo "Updating $MY_PKG_I18N_CHECKOUT"
+  cd $MY_PKG_I18N_CHECKOUT && git pull && cd $PWD
 else
-  echo "No \$MY_LCN_PACK_CHECKOUT set, will checkout temporarly"
-  svn export https://svn.opensuse.org/svn/opensuse-i18n/trunk/packages
-  export MY_LCN_PACK_CHECKOUT=$PWD/packages
+  echo "No \$MY_PKG_I18N_CHECKOUT set, will checkout temporarly"
+  git clone https://github.com/opensuse/packages-i18n.git
+  export MY_PKG_I18N_CHECKOUT=$PWD/packages-i18n
 fi
 
 rm -rf mo
 tar xf package-translations.tar.bz2
 mv mo mo.old
 mkdir mo
-for file in $MY_LCN_PACK_CHECKOUT/*/po; do
+for file in $MY_PKG_I18N_CHECKOUT/*/po; do
   lang=`echo $file | sed -e "s,/po,,; s,.*/,,"`
   echo $file $lang
   msgcat --use-first $file/*.po | msgfmt -o mo/package-translations-$lang.mo -
@@ -41,11 +41,7 @@
 echo
 echo "- automated update on $timestamp2"
 echo
-if head -n 6 $NAME.changes | grep -q "automated update" ; then
-tail -n +6 $NAME.changes
-else
-cat $NAME.changes
-fi
+cat $NAME.changes
 } > $NAME.changes.new
 mv $NAME.changes.new $NAME.changes
 

++ package-translations.tar.bz2 ++
Files old/mo/package-translations-ru.mo and new/mo/package-translations-ru.mo 
differ




commit ark for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package ark for openSUSE:Factory checked in 
at 2016-10-06 12:27:15

Comparing /work/SRC/openSUSE:Factory/ark (Old)
 and  /work/SRC/openSUSE:Factory/.ark.new (New)


Package is "ark"

Changes:

--- /work/SRC/openSUSE:Factory/ark/ark.changes  2016-09-25 14:27:41.0 
+0200
+++ /work/SRC/openSUSE:Factory/.ark.new/ark.changes 2016-10-06 
12:27:16.0 +0200
@@ -1,0 +2,20 @@
+Sat Oct  1 18:44:04 UTC 2016 - fab...@ritter-vogt.de
+
+- Replace mimeinfo17.patch by patches until git master:
+  * 0001-SVN_SILENT-made-messages-after-extraction.patch
+  * 0002-Add-support-for-application-vnd.rar-fixes-opening-RA.patch
+  * 0003-Stop-crashing-when-dropping-on-empty-ArchiveView.patch
+  * 0004-Show-extraction-dialog-only-after-archive-has-been-l.patch
+  * 0005-SVN_SILENT-made-messages-after-extraction.patch
+  * 0006-Accept-drop-events-when-creating-a-new-archive.patch
+  * 0007-SVN_SILENT-made-messages-after-extraction.patch
+  * 0008-Fix-potential-crash-when-aborting-a-ListJob.patch
+  * 0009-Improve-focus-handling-of-internal-previewer.patch
+  * 0010-SVN_SILENT-made-messages-.desktop-file-always-resolv.patch
+  * 0011-Fix-drag-and-drop-with-RPM-archives.patch
+  * 0012-Add-test-cases-for-RPM-and-AppImage.patch
+  * 0013-Fix-drag-and-drop-extraction-of-entries-from-certain.patch
+  * 0014-Fix-drag-and-drop-extraction-of-parentless-files.patch
+- kde#369535, kde#369390, kde#369401, kde#369283, kde#368807, kde#368786, 
kde#367549
+
+---

Old:

  mimeinfo17.patch

New:

  0001-SVN_SILENT-made-messages-after-extraction.patch
  0002-Add-support-for-application-vnd.rar-fixes-opening-RA.patch
  0003-Stop-crashing-when-dropping-on-empty-ArchiveView.patch
  0004-Show-extraction-dialog-only-after-archive-has-been-l.patch
  0005-SVN_SILENT-made-messages-after-extraction.patch
  0006-Accept-drop-events-when-creating-a-new-archive.patch
  0007-SVN_SILENT-made-messages-after-extraction.patch
  0008-Fix-potential-crash-when-aborting-a-ListJob.patch
  0009-Improve-focus-handling-of-internal-previewer.patch
  0010-SVN_SILENT-made-messages-.desktop-file-always-resolv.patch
  0011-Fix-drag-and-drop-with-RPM-archives.patch
  0012-Add-test-cases-for-RPM-and-AppImage.patch
  0013-Fix-drag-and-drop-extraction-of-entries-from-certain.patch
  0014-Fix-drag-and-drop-extraction-of-parentless-files.patch



Other differences:
--
++ ark.spec ++
--- /var/tmp/diff_new_pack.MsHLd4/_old  2016-10-06 12:27:18.0 +0200
+++ /var/tmp/diff_new_pack.MsHLd4/_new  2016-10-06 12:27:18.0 +0200
@@ -24,8 +24,22 @@
 Group:  Productivity/Other
 Url:http://www.kde.org
 Source0:ark-%{version}.tar.xz
-# PATCH-FIX-UPSTREAM mimeinfo17.patch Add support for application/vnd.rar, 
fixes opening RAR with shared-mime-info 1.7 kde#368786
-Patch1: mimeinfo17.patch
+# PATCH-FIX-UPSTREAM Apply all patches until 593568d (binary diffs stripped)
+# (kde#369535, kde#369390, kde#369401, kde#369283, kde#368807, kde#368786)
+Patch1: 0001-SVN_SILENT-made-messages-after-extraction.patch
+Patch2: 0002-Add-support-for-application-vnd.rar-fixes-opening-RA.patch
+Patch3: 0003-Stop-crashing-when-dropping-on-empty-ArchiveView.patch
+Patch4: 0004-Show-extraction-dialog-only-after-archive-has-been-l.patch
+Patch5: 0005-SVN_SILENT-made-messages-after-extraction.patch
+Patch6: 0006-Accept-drop-events-when-creating-a-new-archive.patch
+Patch7: 0007-SVN_SILENT-made-messages-after-extraction.patch
+Patch8: 0008-Fix-potential-crash-when-aborting-a-ListJob.patch
+Patch9: 0009-Improve-focus-handling-of-internal-previewer.patch
+Patch10:0010-SVN_SILENT-made-messages-.desktop-file-always-resolv.patch
+Patch11:0011-Fix-drag-and-drop-with-RPM-archives.patch
+Patch12:0012-Add-test-cases-for-RPM-and-AppImage.patch
+Patch13:0013-Fix-drag-and-drop-extraction-of-entries-from-certain.patch
+Patch14:0014-Fix-drag-and-drop-extraction-of-parentless-files.patch
 BuildRequires:  extra-cmake-modules >= 1.7.0
 BuildRequires:  karchive-devel >= 5.2.0
 BuildRequires:  kconfig-devel >= 5.2.0
@@ -63,6 +77,19 @@
 %prep
 %setup -q
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
+%patch13 -p1
+%patch14 -p1
 
 %build
   %cmake_kf5 -d build

++ 0001-SVN_SILENT-made-messages-after-extraction.patch ++
>From 7dbd6e9dd07cf6e1984c6bca29f9107a71933009 Mon Sep 17 00:00:00 2001
From: l10n daemon script 
Date: Tue, 13 Sep 2016 11:40:38 +
Subject: [PATCH 

commit zypper for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package zypper for openSUSE:Factory checked 
in at 2016-10-06 12:26:55

Comparing /work/SRC/openSUSE:Factory/zypper (Old)
 and  /work/SRC/openSUSE:Factory/.zypper.new (New)


Package is "zypper"

Changes:

--- /work/SRC/openSUSE:Factory/zypper/zypper.changes2016-09-12 
13:22:27.0 +0200
+++ /work/SRC/openSUSE:Factory/.zypper.new/zypper.changes   2016-10-06 
12:26:55.0 +0200
@@ -1,0 +2,6 @@
+Tue Sep 20 11:40:48 CEST 2016 - m...@suse.de
+
+- aptitude: handle --version (fixes #99)
+- version 1.13.11
+
+---

Old:

  zypper-1.13.10.tar.bz2

New:

  zypper-1.13.11.tar.bz2



Other differences:
--
++ zypper.spec ++
--- /var/tmp/diff_new_pack.niBmwc/_old  2016-10-06 12:26:56.0 +0200
+++ /var/tmp/diff_new_pack.niBmwc/_new  2016-10-06 12:26:56.0 +0200
@@ -34,7 +34,7 @@
 Summary:Command line software manager using libzypp
 License:GPL-2.0+
 Group:  System/Packages
-Version:1.13.10
+Version:1.13.11
 Release:0
 Source: %{name}-%{version}.tar.bz2
 Source1:%{name}-rpmlintrc

++ zypper-1.13.10.tar.bz2 -> zypper-1.13.11.tar.bz2 ++
/work/SRC/openSUSE:Factory/zypper/zypper-1.13.10.tar.bz2 
/work/SRC/openSUSE:Factory/.zypper.new/zypper-1.13.11.tar.bz2 differ: char 11, 
line 1




commit speech-dispatcher for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package speech-dispatcher for 
openSUSE:Factory checked in at 2016-10-06 12:26:29

Comparing /work/SRC/openSUSE:Factory/speech-dispatcher (Old)
 and  /work/SRC/openSUSE:Factory/.speech-dispatcher.new (New)


Package is "speech-dispatcher"

Changes:

--- /work/SRC/openSUSE:Factory/speech-dispatcher/speech-dispatcher.changes  
2016-05-24 09:33:59.0 +0200
+++ /work/SRC/openSUSE:Factory/.speech-dispatcher.new/speech-dispatcher.changes 
2016-10-06 12:26:29.0 +0200
@@ -1,0 +2,7 @@
+Tue Oct  4 14:05:39 CEST 2016 - r...@suse.de
+
+- speech-dispatcher.logrotate: move options to local scope
+  to not affect logrotate configuration for other services
+  (bsc#1001618) 
+
+---



Other differences:
--
++ speech-dispatcher.logrotate ++
--- /var/tmp/diff_new_pack.ePe2kh/_old  2016-10-06 12:26:30.0 +0200
+++ /var/tmp/diff_new_pack.ePe2kh/_new  2016-10-06 12:26:30.0 +0200
@@ -1,9 +1,8 @@
-daily
-compress
-missingok
-sharedscripts
-
 /var/log/speech-dispatcher/speech-dispatcher.log 
/var/log/speech-dispatcher/speech-dispatcher-protocol.log {
+  daily
+  compress
+  missingok
+  sharedscripts
   rotate 7
   postrotate
 /etc/init.d/speech-dispatcher reload >/dev/null
@@ -11,6 +10,10 @@
 }
 
 /var/log/speech-dispatcher/debug-epos-generic 
/var/log/speech-dispatcher/debug-festival 
/var/log/speech-dispatcher/debug-flite {
+  daily
+  compress
+  missingok
+  sharedscripts
   rotate 2
   postrotate
 /etc/init.d/speech-dispatcher reload >/dev/null




commit libqt5-qtdeclarative for openSUSE:Factory

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package libqt5-qtdeclarative for 
openSUSE:Factory checked in at 2016-10-06 12:26:03

Comparing /work/SRC/openSUSE:Factory/libqt5-qtdeclarative (Old)
 and  /work/SRC/openSUSE:Factory/.libqt5-qtdeclarative.new (New)


Package is "libqt5-qtdeclarative"

Changes:

--- 
/work/SRC/openSUSE:Factory/libqt5-qtdeclarative/libqt5-qtdeclarative.changes
2016-10-01 23:49:12.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.libqt5-qtdeclarative.new/libqt5-qtdeclarative.changes
   2016-10-06 12:26:04.0 +0200
@@ -1,0 +2,16 @@
+Wed Sep 28 17:06:29 UTC 2016 - fab...@ritter-vogt.de
+
+- Add new version of V4-Free-up-2-address-bits-in-64bit-mode.patch
+  * Fix testcase failure (boo#989341, QTBUG#54822)
+- Only apply patch on AArch64 to avoid regressions where patch not
+  needed (it's experimental)
+
+---
+Mon Sep 26 07:15:48 UTC 2016 - fv...@suse.com
+
+- Add upstream patches for aarch64 with VA_BITS=48 (boo#989341, QTBUG#54822)
+  * V4-Always-set-the-tag-when-boxing-a-pointer.patch
+  * Add-a-facility-to-version-type-information.patch
+  * V4-Free-up-2-address-bits-in-64bit-mode.patchv4-set-tag.patch
+
+---

New:

  Add-a-facility-to-version-type-information.patch
  V4-Always-set-the-tag-when-boxing-a-pointer.patch
  V4-Free-up-2-address-bits-in-64bit-mode.patch



Other differences:
--
++ libqt5-qtdeclarative.spec ++
--- /var/tmp/diff_new_pack.3BXWAs/_old  2016-10-06 12:26:05.0 +0200
+++ /var/tmp/diff_new_pack.3BXWAs/_new  2016-10-06 12:26:05.0 +0200
@@ -37,6 +37,12 @@
 Patch0: overflow.patch
 # PATCH-FIX-OPENSUSE: 
qtdeclarative-opensource-src-5.6.0-qml_no-lifetime-dse.patch - fix crashes with 
i586 and Plasma (boo #985768)
 Patch2: qtdeclarative-opensource-src-5.6.0-qml_no-lifetime-dse.patch
+# PATCH-FIX-UPSTREAM V4-Always-set-the-tag-when-boxing-a-pointer.patch
+Patch3: V4-Always-set-the-tag-when-boxing-a-pointer.patch
+# PATCH-FIX-UPSTREAM Add-a-facility-to-version-type-information.patch
+Patch4: Add-a-facility-to-version-type-information.patch
+# PATCH-FIX-UPSTREAM V4-Free-up-2-address-bits-in-64bit-mode.patch
+Patch5: V4-Free-up-2-address-bits-in-64bit-mode.patch
 BuildRequires:  fdupes
 BuildRequires:  libQt5Core-private-headers-devel >= %{version}
 BuildRequires:  libQt5Gui-private-headers-devel >= %{version}
@@ -75,6 +81,11 @@
 %setup -q -n qtdeclarative-opensource-src-%{real_version}
 %patch0 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%ifarch aarch64
+%patch5 -p1
+%endif
 
 %package -n %libname
 Summary:Qt 5 Declarative Library

++ Add-a-facility-to-version-type-information.patch ++
>From ad48b299b7fe0bbed2749adc66725e4f12661f79 Mon Sep 17 00:00:00 2001
From: hjk 
Date: Fri, 16 Sep 2016 14:30:14 +0200
Subject: [PATCH] Add a facility to version type information for debugging

This serves the same purpose as qtbase/corelib/global/qhooks.cpp,
but is meant to be in sync with changes in Qt Declarative internals.

Change-Id: I5a4a7d9ca5c340367581749e05d09380590c46fb
Reviewed-by: Ulf Hermann 
---
 src/qml/debugger/qqmldebug.cpp | 18 ++
 1 file changed, 18 insertions(+)

diff --git a/src/qml/debugger/qqmldebug.cpp b/src/qml/debugger/qqmldebug.cpp
index 35dc110..ea98bb1 100644
--- a/src/qml/debugger/qqmldebug.cpp
+++ b/src/qml/debugger/qqmldebug.cpp
@@ -119,4 +119,22 @@ bool QQmlDebuggingEnabler::connectToLocalDebugger(const 
QString ,
 return false;
 }
 
+enum { HookCount = 3 };
+
+// Only add to the end, and bump version if you do.
+quintptr Q_QML_EXPORT qtDeclarativeHookData[] = {
+// Version of this Array. Bump if you add to end.
+1,
+
+// Number of entries in this array.
+HookCount,
+
+// TypeInformationVersion, an integral value, bumped whenever private
+// object sizes or member offsets that are used in Qt Creator's
+// data structure "pretty printing" change.
+1
+};
+
+Q_STATIC_ASSERT(HookCount == sizeof(qtDeclarativeHookData) / 
sizeof(qtDeclarativeHookData[0]));
+
 QT_END_NAMESPACE
++ V4-Always-set-the-tag-when-boxing-a-pointer.patch ++
>From aa7c3b35ef9b737c574f436ea35452019a2ff29c Mon Sep 17 00:00:00 2001
From: Erik Verbruggen 
Date: Thu, 16 Jun 2016 13:39:57 +0200
Subject: [PATCH 1/1] V4: Always set the tag when boxing a pointer in
 QV4::Value.

All setters now store tags, so no-one can play loosy-goosy with the
boxed values (and accidentally forget to "tag" a value, resulting in
random garbage).

Change-Id: Ia0b78aa038d3ff46d5292b14bd593de310da16a0
Reviewed-by: Simon Hausmann 

commit python-Jinja2.5670 for openSUSE:13.2:Update

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package python-Jinja2.5670 for 
openSUSE:13.2:Update checked in at 2016-10-06 11:48:44

Comparing /work/SRC/openSUSE:13.2:Update/python-Jinja2.5670 (Old)
 and  /work/SRC/openSUSE:13.2:Update/.python-Jinja2.5670.new (New)


Package is "python-Jinja2.5670"

Changes:

New Changes file:

--- /dev/null   2016-09-15 12:42:18.240042505 +0200
+++ 
/work/SRC/openSUSE:13.2:Update/.python-Jinja2.5670.new/python-Jinja2.changes
2016-10-06 11:48:45.0 +0200
@@ -0,0 +1,241 @@
+---
+Thu Nov 19 13:18:12 UTC 2015 - apla...@suse.com
+
+- Update to 2.8
+  - Added `target` parameter to urlize function.
+  - Added support for `followsymlinks` to the file system loader.
+  - The truncate filter now counts the length.
+  - Added equalto filter that helps with select filters.
+  - Changed cache keys to use absolute file names if available
+instead of load names.
+  - Fixed loop length calculation for some iterators.
+  - Changed how Jinja2 enforces strings to be native strings in
+Python 2 to work when people break their default encoding.
+  - Added :func:`make_logging_undefined` which returns an undefined
+object that logs failures into a logger.
+  - If unmarshalling of cached data fails the template will be
+reloaded now.
+  - Implemented a block ``set`` tag.
+  - Default cache size was incrased to 400 from a low 50.
+  - Fixed ``is number`` test to accept long integers in all Python versions.
+  - Changed ``is number`` to accept Decimal as a number.
+  - Added a check for default arguments followed by non-default arguments. This
+change makes ``{% macro m(x, y=1, z) %}...{% endmacro %}`` a syntax error. 
The
+previous behavior for this code was broken anyway (resulting in the default
+value being applied to `y`).
+  - Add ability to use custom subclasses of ``jinja2.compiler.CodeGenerator`` 
and
+``jinja2.runtime.Context`` by adding two new attributes to the environment
+(`code_generator_class` and `context_class`) (pull request ``#404``).
+  - added support for context/environment/evalctx decorator functions on
+the finalize callback of the environment.
+  - escape query strings for urlencode properly.  Previously slashes were not
+escaped in that place.
+  - Add 'base' parameter to 'int' filter.
+- Tests are removed from the package (not distributed in the tar.gz)
+
+---
+Wed Jul 22 14:20:45 UTC 2015 - jeng...@inai.de
+
+- Use %python_version over %py_ver: better portability to RHEL
+
+---
+Fri Aug 15 12:30:58 UTC 2014 - mci...@suse.cz
+
+- run testsuite during build
+
+---
+Fri Aug 15 12:29:35 UTC 2014 - mci...@suse.cz
+
+- adjust dependency to use up to date package name for python-MarkupSafe
+
+---
+Tue Jul 15 10:41:00 UTC 2014 - toddrme2...@gmail.com
+
+- Update to 2.7.3 (bnc#858239, CVE-2014-0012)
+  - Security issue: Corrected the security fix for the cache folder.  
+This fix was provided by RedHat.
+
+---
+Thu May  8 21:21:45 UTC 2014 - h...@urpla.net
+
+- fix package build (file selection missing)
+
+---
+Sat Apr 26 19:38:39 UTC 2014 - dmuel...@suse.com
+
+- avoid rebuildcycle with vim 
+
+---
+Mon Jan 13 13:18:53 UTC 2014 - dmuel...@suse.com
+
+- update to 2.7.2:
+  - Prefix loader was not forwarding the locals properly to
+inner loaders.  This is now fixed.
+  - Security issue: Changed the default folder for the filesystem cache to be
+user specific and read and write protected on UNIX systems.  See `Debian 
bug
+734747`_ for more information.
+
+---
+Thu Oct 24 11:07:20 UTC 2013 - speili...@suse.com
+
+- Require python-setuptools instead of distribute (upstreams merged)
+
+---
+Mon Sep  2 15:03:25 UTC 2013 - speili...@suse.com
+
+- Avoid "Recommends:" on old rpm distros
+
+---
+Tue Aug 13 09:56:18 UTC 2013 - dmuel...@suse.com
+
+- update to 2.7.1:
+ - Fixed a bug with ``call_filter`` not working properly on environment
+   and context filters.
+ - Fixed lack of Python 3 support for bytecode caches.
+ - Reverted support for defining blocks in included templates as this
+   broke existing templates for users.
+ - Fixed some warnings with hashing 

commit patchinfo.5670 for openSUSE:13.2:Update

2016-10-06 Thread h_root
Hello community,

here is the log from the commit of package patchinfo.5670 for 
openSUSE:13.2:Update checked in at 2016-10-06 11:48:54

Comparing /work/SRC/openSUSE:13.2:Update/patchinfo.5670 (Old)
 and  /work/SRC/openSUSE:13.2:Update/.patchinfo.5670.new (New)


Package is "patchinfo.5670"

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _patchinfo



Other differences:
--
++ _patchinfo ++

  VUL-0: CVE-2014-1402: python-Jinja2: 
arbitrary code execution vulnerability
  
  security
  important
  scarabeus_iv
  
This update for python-Jinja2 fixes the following issues:

Update to version 2.8:
- Added `target` parameter to urlize function.
- Added support for `followsymlinks` to the file system loader.
- The truncate filter now counts the length.
- Added equalto filter that helps with select filters.
- Changed cache keys to use absolute file names if available
  instead of load names.
- Fixed loop length calculation for some iterators.
- Changed how Jinja2 enforces strings to be native strings in
Python 2 to work when people break their default encoding.
- Added :func:`make_logging_undefined` which returns an undefined
object that logs failures into a logger.
- If unmarshalling of cached data fails the template will be
reloaded now.
- Implemented a block ``set`` tag.
- Default cache size was incrased to 400 from a low 50.
- Fixed ``is number`` test to accept long integers in all Python versions.
- Changed ``is number`` to accept Decimal as a number.
- Added a check for default arguments followed by non-default arguments. This
change makes ``{% macro m(x, y=1, z) %}...{% endmacro %}`` a syntax error. 
The
previous behavior for this code was broken anyway (resulting in the default
value being applied to `y`).
- Add ability to use custom subclasses of ``jinja2.compiler.CodeGenerator`` and
``jinja2.runtime.Context`` by adding two new attributes to the environment
(`code_generator_class` and `context_class`) (pull request ``#404``).
- added support for context/environment/evalctx decorator functions on
the finalize callback of the environment.
- escape query strings for urlencode properly.  Previously slashes were not
escaped in that place.
- Add 'base' parameter to 'int' filter.

- Update to 2.7.3 (boo#858239, CVE-2014-0012)

  Security update for python-Jinja2