commit fox16 for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package fox16 for openSUSE:Factory checked 
in at 2017-05-18 20:51:40

Comparing /work/SRC/openSUSE:Factory/fox16 (Old)
 and  /work/SRC/openSUSE:Factory/.fox16.new (New)


Package is "fox16"

Thu May 18 20:51:40 2017 rev:38 rq:495849 version:1.6.54

Changes:

--- /work/SRC/openSUSE:Factory/fox16/fox16.changes  2016-11-16 
13:33:09.0 +0100
+++ /work/SRC/openSUSE:Factory/.fox16.new/fox16.changes 2017-05-18 
20:51:50.949378929 +0200
@@ -1,0 +2,8 @@
+Thu May 18 09:51:23 UTC 2017 - l...@linux-schulserver.de
+
+- Update to 1.6.54:
+  + Fix core dump using old GNU C Library or CYGWIN inside 
+FXString::vformat.cpp.
+  + Fixed typo in FXString::vformat.cpp.
+
+---

Old:

  fox-1.6.52.tar.gz

New:

  fox-1.6.54.tar.gz



Other differences:
--
++ fox16.spec ++
--- /var/tmp/diff_new_pack.Mc7LLM/_old  2017-05-18 20:51:52.833113136 +0200
+++ /var/tmp/diff_new_pack.Mc7LLM/_new  2017-05-18 20:51:52.837112572 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package fox16
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 Name:   fox16
 %define lname  libFOX-1_6-0
-Version:1.6.52
+Version:1.6.54
 Release:0
 Summary:Shared Libraries for the FOX Toolkit
 License:LGPL-2.1+
@@ -108,7 +108,7 @@
 Provides:   fox = %version
 # Added O/P in 13.2
 Provides:   libfox1_6 = %version-%release
-Obsoletes:  libfox1_6 < %version-%release
+Obsoletes:  libfox1_6 < %version
 
 %description -n %lname
 This package contains the shared libraries needed



++ fox-1.6.52.tar.gz -> fox-1.6.54.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fox-1.6.52/configure new/fox-1.6.54/configure
--- old/fox-1.6.52/configure2016-06-16 06:16:14.0 +0200
+++ new/fox-1.6.54/configure2017-04-21 02:38:32.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.68 for fox 1.6.52.
+# Generated by GNU Autoconf 2.68 for fox 1.6.54.
 #
 # Report bugs to .
 #
@@ -570,8 +570,8 @@
 # Identity of this package.
 PACKAGE_NAME='fox'
 PACKAGE_TARNAME='fox'
-PACKAGE_VERSION='1.6.52'
-PACKAGE_STRING='fox 1.6.52'
+PACKAGE_VERSION='1.6.54'
+PACKAGE_STRING='fox 1.6.54'
 PACKAGE_BUGREPORT='jer...@fox-toolkit.com'
 PACKAGE_URL=''
 
@@ -1334,7 +1334,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures fox 1.6.52 to adapt to many kinds of systems.
+\`configure' configures fox 1.6.54 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1408,7 +1408,7 @@
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
- short | recursive ) echo "Configuration of fox 1.6.52:";;
+ short | recursive ) echo "Configuration of fox 1.6.54:";;
esac
   cat <<\_ACEOF
 
@@ -1532,7 +1532,7 @@
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-fox configure 1.6.52
+fox configure 1.6.54
 generated by GNU Autoconf 2.68
 
 Copyright (C) 2010 Free Software Foundation, Inc.
@@ -2253,7 +2253,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by fox $as_me 1.6.52, which was
+It was created by fox $as_me 1.6.54, which was
 generated by GNU Autoconf 2.68.  Invocation command line was
 
   $ $0 $@
@@ -3072,7 +3072,7 @@
 
 # Define the identity of the package.
  PACKAGE='fox'
- VERSION='1.6.52'
+ VERSION='1.6.54'
 
 
 cat >>confdefs.h <<_ACEOF
@@ -3116,7 +3116,7 @@
 # Set version
 FOX_MAJOR_VERSION=1
 FOX_MINOR_VERSION=6
-FOX_PATCH_LEVEL=52
+FOX_PATCH_LEVEL=54
 
 # Binaries compiled with this patchlevel of FOX will need at least
 # version MAJOR.MINOR.INTERFACE_VERSION to run. The assertion
@@ -18787,7 +18787,7 @@
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log="
-This file was extended by fox $as_me 1.6.52, which was
+This file was extended by fox $as_me 1.6.54, which was
 generated by GNU Autoconf 2.68.  Invocation command line was
 
   CONFIG_FILES= $CONFIG_FILES
@@ -18844,7 +18844,7 @@
 cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
 ac_cs_config="`$as_echo 

commit blender for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package blender for openSUSE:Factory checked 
in at 2017-05-18 20:51:37

Comparing /work/SRC/openSUSE:Factory/blender (Old)
 and  /work/SRC/openSUSE:Factory/.blender.new (New)


Package is "blender"

Thu May 18 20:51:37 2017 rev:99 rq:495822 version:2.78c

Changes:

--- /work/SRC/openSUSE:Factory/blender/blender.changes  2017-04-12 
18:00:46.404971171 +0200
+++ /work/SRC/openSUSE:Factory/.blender.new/blender.changes 2017-05-18 
20:51:47.289895278 +0200
@@ -1,0 +2,18 @@
+Thu May 18 06:35:46 UTC 2017 - ideasma...@gmail.com
+
+- Remove doxygen (only documents internal source code, not
+  public / scripting API's).
+
+---
+Thu May 18 00:51:29 UTC 2017 - ideasma...@gmail.com
+
+- Remove yasm (was only needed for extern/ codecs) now removed.
+- Remove ruby (Blender doesn't use Ruby).
+
+---
+Wed May 17 10:39:08 UTC 2017 - ideasma...@gmail.com
+
+- Remove extern paths which no longer exist, also epydoc which
+  isn't used since 2.4x.
+
+---



Other differences:
--
++ blender.spec ++
--- /var/tmp/diff_new_pack.DUU1pz/_old  2017-05-18 20:51:48.409737269 +0200
+++ /var/tmp/diff_new_pack.DUU1pz/_new  2017-05-18 20:51:48.413736705 +0200
@@ -21,7 +21,6 @@
 %define audaspace 1
 %define collada 1
 %define wplayer 1
-%define documentation 0
 # Set this to 1 for fixing bugs.
 %define debugbuild 0
 # Find the version of python3 that blender is going to build against.
@@ -79,8 +78,6 @@
 %endif
 BuildRequires:  cmake
 BuildRequires:  desktop-file-utils
-BuildRequires:  doxygen
-BuildRequires:  epydoc
 BuildRequires:  fdupes
 BuildRequires:  fftw3-devel
 BuildRequires:  gcc-c++
@@ -121,16 +118,12 @@
 %if 0%{?suse_version} > 1320
 BuildRequires:  python3-requests
 %endif
-BuildRequires:  ruby
-BuildRequires:  ruby-devel
 BuildRequires:  shared-mime-info
 BuildRequires:  update-desktop-files
 BuildRequires:  xorg-x11
 BuildRequires:  xorg-x11-devel
 BuildRequires:  xz
 BuildRequires:  xz-devel
-BuildRequires:  yasm
-BuildRequires:  yasm-devel
 BuildRequires:  pkgconfig(glu)
 BuildRequires:  pkgconfig(libxml-2.0)
 Requires:   python3-base >= %{py3version}
@@ -147,9 +140,6 @@
 %else
 BuildRequires:  MesaGLw-devel
 %endif
-%if %{documentation} == 1
-Recommends: blender-doc
-%endif
 %if %{with ffmpeg}
 BuildRequires:  pkgconfig(libavcodec)
 BuildRequires:  pkgconfig(libavdevice)
@@ -191,22 +181,6 @@
 This blender is not built with cycles.
 %endif
 
-%if %{documentation} == 1
-%package doc
-Summary:Documentation for blender
-Group:  Documentation
-BuildArch:  noarch
-
-%description doc
-Being the in-house software of a high quality animation studio, Blender
-has proven to be an extremely fast and versatile design instrument. The
-software has a personal touch, offering a unique approach to the world
-of Three Dimensions. Use Blender to create TV commercials, to make
-technical visualizations, business graphics, to do some morphing, or
-design user interfaces.
-This package includes API documentation and example plugin programs.
-%endif
-
 %lang_package
 
 %prep
@@ -217,18 +191,8 @@
 %setup -q
 %patch1
 
-rm -rf extern/ffmpeg
-rm -rf extern/fftw
 rm -rf extern/glew
-rm -rf extern/libmp3lame
 rm -rf extern/libopenjpeg
-rm -rf extern/libredcode
-rm -rf extern/ode
-rm -rf extern/x264
-rm -rf extern/xvidcore
-rm -rf extern/qhull
-rm -rf extern/make
-rm -rf extern/verse
 echo %{_version}
 
 %build
@@ -326,15 +290,6 @@
 %endif
 make %{?_smp_mflags}
 popd
-%if %{documentation} == 1
-# Build documentation
-pushd doc/doxygen
-doxygen -u Doxyfile
-doxygen Doxyfile
-popd
-mv doc/doxygen/html doc/
-rm -rf doc/doxygen
-%endif
 
 %install
 echo "release version = %{_version}"
@@ -450,12 +405,6 @@
 %{_datadir}/pixmaps/blender.png
 %dir %{_datadir}/appdata
 %{_datadir}/appdata/*.appdata.xml
-%if %{documentation} == 0
 %doc %{_docdir}/%{name}
-%else
-%files doc
-%defattr (-, root, root)
-%doc doc/
-%endif
 
 %changelog





commit python-slip for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package python-slip for openSUSE:Factory 
checked in at 2017-05-18 20:51:32

Comparing /work/SRC/openSUSE:Factory/python-slip (Old)
 and  /work/SRC/openSUSE:Factory/.python-slip.new (New)


Package is "python-slip"

Thu May 18 20:51:32 2017 rev:2 rq:495759 version:0.6.5

Changes:

--- /work/SRC/openSUSE:Factory/python-slip/python-slip.changes  2016-01-28 
17:23:52.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-slip.new/python-slip.changes 
2017-05-18 20:51:44.402302714 +0200
@@ -1,0 +2,8 @@
+Wed May 17 14:32:37 UTC 2017 - mchand...@suse.de
+
+- Version bump to 0.6.5
+  * Fix org.freedesktop.DBus.Error.ServiceUnknown errors without
+polkitd (gh#nphilipp/python-slip#4)
+  * cope with changes in supplied upload_url
+
+---

Old:

  python-slip-0.6.4.tar.bz2

New:

  python-slip-0.6.5.tar.bz2



Other differences:
--
++ python-slip.spec ++
--- /var/tmp/diff_new_pack.6fXnSV/_old  2017-05-18 20:51:45.046211859 +0200
+++ /var/tmp/diff_new_pack.6fXnSV/_new  2017-05-18 20:51:45.050211294 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-slip
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   python-slip
-Version:0.6.4
+Version:0.6.5
 Release:0
 Summary:Miscellaneous convenience, extension and workaround code for 
Python
 License:GPL-2.0+
@@ -78,7 +78,7 @@
 make %{?_smp_mflags}
 
 %install
-make install DESTDIR=%{buildroot}
+%make_install
 
 %fdupes %{buildroot}/%{python_sitelib}
 

++ python-slip-0.6.4.tar.bz2 -> python-slip-0.6.5.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-slip-0.6.4/github_rules.mk 
new/python-slip-0.6.5/github_rules.mk
--- old/python-slip-0.6.4/github_rules.mk   2015-09-18 22:25:42.0 
+0200
+++ new/python-slip-0.6.5/github_rules.mk   2017-05-16 12:14:36.0 
+0200
@@ -62,7 +62,7 @@
--header "Content-Type: $$mimetype" \
--header "Accept: 
application/vnd.github.manifold-preview" \
--data-binary "@$(PKGARCHIVE)" \
-   "$${upload_url%\{\?name\}}?name=$(PKGARCHIVE)")"; \
+   "$${upload_url%\{\?*}?name=$(PKGARCHIVE)")"; \
if [ "$$(echo "$$upload_out" | jq .state)" = "\"uploaded\"" ]; 
then \
echo done; \
else \
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-slip-0.6.4/python-slip.spec 
new/python-slip-0.6.5/python-slip.spec
--- old/python-slip-0.6.4/python-slip.spec  2015-09-18 22:25:42.0 
+0200
+++ new/python-slip-0.6.5/python-slip.spec  2017-05-16 12:14:36.0 
+0200
@@ -1,5 +1,5 @@
 Name:   python-slip
-Version:0.6.4
+Version:0.6.5
 Release:1%{?dist}
 Summary:Convenience, extension and workaround code for Python 2.x
 
@@ -157,6 +157,9 @@
 %{python2_sitelib}/slip.gtk-%{version}-py%{python2_version}.egg-info
 
 %changelog
+* Tue May 16 2017 Nils Philippsen  - 0.6.5-1
+- cope better with missing polkitd (#1393488)
+
 * Fri Sep 18 2015 Nils Philippsen  - 0.6.4-1
 - util.files.overwrite_safely(): preserve ownership
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-slip-0.6.4/slip/dbus/polkit.py 
new/python-slip-0.6.5/slip/dbus/polkit.py
--- old/python-slip-0.6.4/slip/dbus/polkit.py   2015-09-18 22:25:42.0 
+0200
+++ new/python-slip-0.6.5/slip/dbus/polkit.py   2017-05-16 12:14:36.0 
+0200
@@ -206,17 +206,17 @@
 @property
 def _interface(self):
 if not PolKit.__interface:
-PolKit.__interface = dbus.Interface(self._bus.get_object(
-self._dbus_name, self._dbus_path),
-self._dbus_interface)
+try:
+PolKit.__interface = dbus.Interface(self._bus.get_object(
+self._dbus_name, self._dbus_path),
+self._dbus_interface)
+except dbus.DBusException:
+pass
 return PolKit.__interface
 
 @property
 def _polkit_present(self):
-try:
-return bool(self._interface)
-except dbus.DBusException:
-return False
+return bool(self._interface)
 
 def 

commit redis for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package redis for openSUSE:Factory checked 
in at 2017-05-18 20:51:44

Comparing /work/SRC/openSUSE:Factory/redis (Old)
 and  /work/SRC/openSUSE:Factory/.redis.new (New)


Package is "redis"

Thu May 18 20:51:44 2017 rev:32 rq:496102 version:3.2.9

Changes:

--- /work/SRC/openSUSE:Factory/redis/redis.changes  2017-02-03 
19:59:47.123307972 +0100
+++ /work/SRC/openSUSE:Factory/.redis.new/redis.changes 2017-05-18 
20:52:00.532026828 +0200
@@ -1,0 +2,16 @@
+Thu May 18 12:43:42 UTC 2017 - vsis...@suse.com
+
+- Update to version 3.2.9
+  * A few rarely harmful bugs were fixed.
+- Changes accumulated from 3.2.8
+  Two important bug fixes, the first of one is critical:
+  * Apparently Jemalloc 4.4.0 may contain a deadlock under
+particular conditions. See 
+https://github.com/antirez/redis/issues/3799.
+We reverted back to the previously used Jemalloc versions and
+plan to upgrade Jemalloc again after having more info about the
+cause of the bug.
+  * MIGRATE could crash the server after a socket error. See for
+reference: https://github.com/antirez/redis/issues/3796.
+
+---

Old:

  redis-3.2.7.tar.gz

New:

  redis-3.2.9.tar.gz



Other differences:
--
++ redis.spec ++
--- /var/tmp/diff_new_pack.5YarR6/_old  2017-05-18 20:52:01.147939923 +0200
+++ /var/tmp/diff_new_pack.5YarR6/_new  2017-05-18 20:52:01.151939359 +0200
@@ -25,7 +25,7 @@
 %bcond_withsystemd
 %endif
 Name:   redis
-Version:3.2.7
+Version:3.2.9
 Release:0
 Summary:Persistent key-value database
 License:BSD-3-Clause

++ redis-3.2.7.tar.gz -> redis-3.2.9.tar.gz ++
 45631 lines of diff (skipped)




commit vhba-kmp for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package vhba-kmp for openSUSE:Factory 
checked in at 2017-05-18 20:51:34

Comparing /work/SRC/openSUSE:Factory/vhba-kmp (Old)
 and  /work/SRC/openSUSE:Factory/.vhba-kmp.new (New)


Package is "vhba-kmp"

Thu May 18 20:51:34 2017 rev:13 rq:495765 version:20161009

Changes:

--- /work/SRC/openSUSE:Factory/vhba-kmp/vhba-kmp.changes2017-02-09 
11:16:59.719367890 +0100
+++ /work/SRC/openSUSE:Factory/.vhba-kmp.new/vhba-kmp.changes   2017-05-18 
20:51:45.246183643 +0200
@@ -1,0 +2,5 @@
+Wed May 17 22:20:05 UTC 2017 - jeng...@inai.de
+
+- Add vhba-signal.diff so it builds with Linux 4.11
+
+---

New:

  vhba-signal.diff



Other differences:
--
++ vhba-kmp.spec ++
--- /var/tmp/diff_new_pack.MFcpfF/_old  2017-05-18 20:51:45.766110283 +0200
+++ /var/tmp/diff_new_pack.MFcpfF/_new  2017-05-18 20:51:45.770109717 +0200
@@ -29,11 +29,12 @@
 Source2:%name-preamble
 Patch1: vhba-no-werror.diff
 Patch2: vhba-devname.diff
+Patch3: vhba-signal.diff
 BuildRequires:  kernel-syms >= 2.6.20
 BuildRequires:  modutils
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
-%kernel_module_package -n vhba -p %name-preamble
+%{?kernel_module_package:%kernel_module_package -n vhba -p %name-preamble}
 
 %description
 A Linux kernel module implementing a virtual SCSI Host Bus Adapter to
@@ -56,7 +57,7 @@
 %prep
 echo %flavors_to_build
 %setup -qn vhba-module-%version
-%patch -P 1 -P 2 -p1
+%patch -P 1 -P 2 -P 3 -p1
 
 %build
 for flavor in %flavors_to_build; do

++ vhba-signal.diff ++
From: Jan Engelhardt 
Date: 2017-05-18 00:18:13.674608963 +0200

build: resolve build failure with Linux 4.11+

vhba.c:711:13: error: implicit declaration of function 'signal_pending' 
[-Werror=implicit-function-declaration]
   if (signal_pending(current)) {
---
 vhba.c |3 +++
 1 file changed, 3 insertions(+)

Index: vhba-module-20161009/vhba.c
===
--- vhba-module-20161009.orig/vhba.c
+++ vhba-module-20161009/vhba.c
@@ -28,6 +28,9 @@
 #include 
 #include 
 #include 
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,11,0)
+#  include 
+#endif
 #ifdef CONFIG_COMPAT
 #include 
 #endif



commit elementary-icon-theme for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package elementary-icon-theme for 
openSUSE:Factory checked in at 2017-05-18 20:51:25

Comparing /work/SRC/openSUSE:Factory/elementary-icon-theme (Old)
 and  /work/SRC/openSUSE:Factory/.elementary-icon-theme.new (New)


Package is "elementary-icon-theme"

Thu May 18 20:51:25 2017 rev:8 rq:495757 version:4.1.0

Changes:

--- 
/work/SRC/openSUSE:Factory/elementary-icon-theme/elementary-icon-theme.changes  
2017-03-28 15:22:38.386017769 +0200
+++ 
/work/SRC/openSUSE:Factory/.elementary-icon-theme.new/elementary-icon-theme.changes
 2017-05-18 20:51:27.984619226 +0200
@@ -1,0 +2,38 @@
+Wed May 17 15:41:54 UTC 2017 - avvi...@yandex.by
+
+- Update to 4.1.0:
+  * name 24px display brightness icon correctly (#219)
+  * name 24px display brightness icon correctly
+  * and 16px
+  * Improve Terminal glyph (#218)
+  * 64px and 128px
+  * finish up
+  * Symlink meson mime to make file mime (#216)
+  * Symlink meson mime to make file mime
+  * revert unintentional changes
+  * Add 24px brightness-display-symbolic (#213)
+  * Add 24px brightness-display-symbolic
+  * redraw larger
+  * Update notification-disabled shape (#212)
+  * make notification icons rounder, real big bubble (#206)
+  * Match 48px color batteries with symbolic (#211)
+  * remove lightning from fully charged state (#209)
+  * All slashies now go NW/SE (#208)
+  * Symbolic battery: Vertical lightning, 16px (#207)
+  * vertical lightning and update 16px battery icons
+  * remove sneaky sneaks
+  * moved batteries 1px right; updated large symbolic icon (#205)
+  * redesign 24px symbolic battery icons (#204)
+  * redesign 24px symbolic battery icons
+  * delete some icons that snuck in
+  * slashies to the right
+  * remove random shit
+  * Make 48px lock screen icon match 32px (#203)
+  * add 24px variants of icons used for privacy indicator (#202)
+  * Make the bubble on notification-new-symbolic larger (#201)
+  * Add 48px preferences-desktop-display (#200)
+  * add symlinks for text-csv (#197)
+  * Add 32, 48, 64, 128 insert-link
+  * Add 24 32 64 and symbolic drive-removable-media-usb
+
+---

Old:

  elementary-icon-theme-4.0.3.tar.xz

New:

  elementary-icon-theme-4.1.0.tar.xz



Other differences:
--
++ elementary-icon-theme.spec ++
--- /var/tmp/diff_new_pack.9ZUxl0/_old  2017-05-18 20:51:28.596532886 +0200
+++ /var/tmp/diff_new_pack.9ZUxl0/_new  2017-05-18 20:51:28.600532323 +0200
@@ -18,7 +18,7 @@
 
 %define _version 4.x
 Name:   elementary-icon-theme
-Version:4.0.3
+Version:4.1.0
 Release:0
 Summary:Simple and appealing Tango-styled icon theme
 License:GPL-3.0+

++ elementary-icon-theme-4.0.3.tar.xz -> elementary-icon-theme-4.1.0.tar.xz 
++
 11572 lines of diff (skipped)




commit diskimage-builder for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package diskimage-builder for 
openSUSE:Factory checked in at 2017-05-18 20:51:28

Comparing /work/SRC/openSUSE:Factory/diskimage-builder (Old)
 and  /work/SRC/openSUSE:Factory/.diskimage-builder.new (New)


Package is "diskimage-builder"

Thu May 18 20:51:28 2017 rev:6 rq:495758 version:2.4.0

Changes:

--- /work/SRC/openSUSE:Factory/diskimage-builder/diskimage-builder.changes  
2017-05-17 17:18:16.225783650 +0200
+++ /work/SRC/openSUSE:Factory/.diskimage-builder.new/diskimage-builder.changes 
2017-05-18 20:51:43.022497402 +0200
@@ -1,0 +2,21 @@
+Wed May 17 15:25:37 UTC 2017 - mchand...@suse.de
+
+- Version bump to 2.4.0
+  * Refactor: block-device filesystem creation, mount and fstab
+  * Take --params from environment
+  * Refactor documentation on image creation
+  * Add a test to validate we can build debian vms
+  * Introduce exec_sudo command
+  * Fix py3 error in block-device
+  * Refactor block-device base functions.
+  * Add bzip2 to test install
+  * Add refactor of tree-like vs graph
+  * Set LC_ALL in disk-image-create
+  * Improve documentation for image creation
+  * Refactor block_device: isolate the getval call
+  * Refactor block_device: passing command line parameters
+  * Make Gentoo package updates work more often
+  * Turn off strict_id mode for Ec2 datasource
+  * Clean out apt index caches at end of image build
+
+---

Old:

  diskimage-builder-2.3.3.tar.gz

New:

  diskimage-builder-2.4.0.tar.gz



Other differences:
--
++ diskimage-builder.spec ++
--- /var/tmp/diff_new_pack.fXtVTB/_old  2017-05-18 20:51:43.498430249 +0200
+++ /var/tmp/diff_new_pack.fXtVTB/_new  2017-05-18 20:51:43.498430249 +0200
@@ -21,7 +21,7 @@
 
 %global __requires_exclude_from 
^%{python_sitelib}/diskimage_builder/elements/.*$
 Name:   diskimage-builder
-Version:2.3.3
+Version:2.4.0
 Release:0
 Summary:Image Building Tools for OpenStack
 License:Apache-2.0

++ diskimage-builder-2.3.3.tar.gz -> diskimage-builder-2.4.0.tar.gz ++
 3194 lines of diff (skipped)




commit python-numpydoc for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package python-numpydoc for openSUSE:Factory 
checked in at 2017-05-18 20:51:22

Comparing /work/SRC/openSUSE:Factory/python-numpydoc (Old)
 and  /work/SRC/openSUSE:Factory/.python-numpydoc.new (New)


Package is "python-numpydoc"

Thu May 18 20:51:22 2017 rev:6 rq:495755 version:0.6.0

Changes:

--- /work/SRC/openSUSE:Factory/python-numpydoc/python-numpydoc.changes  
2017-01-24 10:38:51.279945420 +0100
+++ /work/SRC/openSUSE:Factory/.python-numpydoc.new/python-numpydoc.changes 
2017-05-18 20:51:24.041175697 +0200
@@ -1,0 +2,6 @@
+Wed May 17 21:42:03 UTC 2017 - toddrme2...@gmail.com
+
+- Implement single-spec version.
+- Fix source URL.
+
+---



Other differences:
--
++ python-numpydoc.spec ++
--- /var/tmp/diff_new_pack.UNgFId/_old  2017-05-18 20:51:24.645090468 +0200
+++ /var/tmp/diff_new_pack.UNgFId/_new  2017-05-18 20:51:24.649089904 +0200
@@ -16,6 +16,9 @@
 #
 
 
+%bcond_without tests
+
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-numpydoc
 Version:0.6.0
 Release:0
@@ -23,20 +26,20 @@
 License:BSD-3-Clause
 Group:  Development/Languages/Python
 Url:https://github.com/numpy/numpydoc
-Source: 
https://pypi.io/packages/source/n/numpydoc/numpydoc-%{version}.tar.gz
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
-# Test requirements
-BuildRequires:  python-Sphinx >= 1.0.1
-BuildRequires:  python-matplotlib
-BuildRequires:  python-nose
+Source: 
https://files.pythonhosted.org/packages/source/n/numpydoc/numpydoc-%{version}.tar.gz
+BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
+BuildRequires:  %{python_module devel >= 2.7.7}
+BuildRequires:  %{python_module setuptools}
+%if %{with tests}
+BuildRequires:  %{python_module Sphinx >= 1.0.1}
+BuildRequires:  %{python_module matplotlib}
+BuildRequires:  %{python_module nose}
+%endif
 Requires:   python-Sphinx >= 1.0.1
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
 BuildArch:  noarch
-%endif
+%python_subpackages
 
 %description
 Numpy's documentation uses several custom extensions to Sphinx.  These
@@ -47,15 +50,18 @@
 %setup -q -n numpydoc-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
+%python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%if %{with tests}
 %check
-python setup.py -q test
+%python_exec setup.py -q test
+%endif
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc LICENSE.txt README.rst
 %{python_sitelib}/numpydoc/




commit ghc-telegram-api for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package ghc-telegram-api for 
openSUSE:Factory checked in at 2017-05-18 20:51:10

Comparing /work/SRC/openSUSE:Factory/ghc-telegram-api (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-telegram-api.new (New)


Package is "ghc-telegram-api"

Thu May 18 20:51:10 2017 rev:2 rq:495712 version:0.6.1.1

Changes:

--- /work/SRC/openSUSE:Factory/ghc-telegram-api/ghc-telegram-api.changes
2017-05-10 20:45:56.273620241 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-telegram-api.new/ghc-telegram-api.changes   
2017-05-18 20:51:17.946035886 +0200
@@ -1,0 +2,10 @@
+Wed May  3 08:14:03 UTC 2017 - psim...@suse.com
+
+- Update to version 0.6.1.1 with cabal2obs.
+
+---
+Tue Mar 14 09:26:22 UTC 2017 - psim...@suse.com
+
+- Update to version 0.6.1.0 with cabal2obs.
+
+---

Old:

  telegram-api-0.6.0.2.tar.gz

New:

  telegram-api-0.6.1.1.tar.gz



Other differences:
--
++ ghc-telegram-api.spec ++
--- /var/tmp/diff_new_pack.I50t6S/_old  2017-05-18 20:51:20.009744642 +0200
+++ /var/tmp/diff_new_pack.I50t6S/_new  2017-05-18 20:51:20.009744642 +0200
@@ -19,7 +19,7 @@
 %global pkg_name telegram-api
 %bcond_with tests
 Name:   ghc-%{pkg_name}
-Version:0.6.0.2
+Version:0.6.1.1
 Release:0
 Summary:Telegram Bot API bindings
 License:BSD-3-Clause

++ telegram-api-0.6.0.2.tar.gz -> telegram-api-0.6.1.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/telegram-api-0.6.0.2/CHANGELOG.md 
new/telegram-api-0.6.1.1/CHANGELOG.md
--- old/telegram-api-0.6.0.2/CHANGELOG.md   2017-01-31 20:10:31.0 
+0100
+++ new/telegram-api-0.6.1.1/CHANGELOG.md   2017-04-30 17:21:45.0 
+0200
@@ -1,3 +1,18 @@
+## 0.6.1.1
+
+Bugfixes:
+
+* Migration to `Int64` to represent chat id and fix integer overflow issue
+
+## 0.6.1.0
+
+* Added `ChatId` data type since it can be integer or string starting from 
`@`, f.e. `@channelusername`
+* Changes in `getUpdates` and `getUpdateM` function
+
+## 0.6.0.1
+
+* Bump aeson upper bound to include 1.1.*
+
 ## 0.6.0.0
 
 * Added `TelegramClient`, see example of usage in README.md
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/telegram-api-0.6.0.2/src/Web/Telegram/API/Bot/API/Get.hs 
new/telegram-api-0.6.1.1/src/Web/Telegram/API/Bot/API/Get.hs
--- old/telegram-api-0.6.0.2/src/Web/Telegram/API/Bot/API/Get.hs
2017-01-31 20:10:31.0 +0100
+++ new/telegram-api-0.6.1.1/src/Web/Telegram/API/Bot/API/Get.hs
2017-03-06 21:48:58.0 +0100
@@ -17,8 +17,8 @@
   ) where
 
 import   Data.Proxy
-import   Data.Text(Text)
-import   Network.HTTP.Client  (Manager)
+import   Data.Text  (Text)
+import   Network.HTTP.Client(Manager)
 import   Servant.API
 import   Servant.Client
 import   Web.Telegram.API.Bot.API.Core
@@ -32,7 +32,7 @@
  :> QueryParam "file_id" Text
  :> Get '[JSON] FileResponse
 :<|> TelegramToken :> "getUserProfilePhotos"
- :> QueryParam "user_id" Int
+ :> QueryParam "user_id" Integer
  :> QueryParam "offset" Int
  :> QueryParam "limit" Int
  :> Get '[JSON] UserProfilePhotosResponse
@@ -43,7 +43,7 @@
 
 getMe_ :: Token -> ClientM GetMeResponse
 getFile_   :: Token -> Maybe Text -> ClientM FileResponse
-getUserProfilePhotos_  :: Token -> Maybe Int -> Maybe Int -> Maybe Int -> 
ClientM UserProfilePhotosResponse
+getUserProfilePhotos_  :: Token -> Maybe Integer -> Maybe Int -> Maybe Int 
-> ClientM UserProfilePhotosResponse
 getMe_
   :<|> getFile_
   :<|> getUserProfilePhotos_
@@ -67,9 +67,9 @@
 getFileM fileId = run_ getFile_ (Just fileId)
 
 -- | Use this method to get a list of profile pictures for a user. Returns a 
'UserProfilePhotos' object.
-getUserProfilePhotos :: Token -> Int -> Maybe Int -> Maybe Int -> Manager -> 
IO (Either ServantError UserProfilePhotosResponse)
+getUserProfilePhotos :: Token -> Integer -> Maybe Int -> Maybe Int -> Manager 
-> IO (Either ServantError UserProfilePhotosResponse)
 getUserProfilePhotos token userId offset limit = runClient 
(getUserProfilePhotosM userId offset limit) token
 
 -- | See 'getUserProfilePhotos'
-getUserProfilePhotosM :: Int -> Maybe Int -> Maybe Int -> TelegramClient 
UserProfilePhotosResponse
+getUserProfilePhotosM :: Integer -> Maybe Int -> Maybe Int -> TelegramClient 
UserProfilePhotosResponse
 

commit ghc-servant-auth-cookie for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package ghc-servant-auth-cookie for 
openSUSE:Factory checked in at 2017-05-18 20:51:02

Comparing /work/SRC/openSUSE:Factory/ghc-servant-auth-cookie (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-servant-auth-cookie.new (New)


Package is "ghc-servant-auth-cookie"

Thu May 18 20:51:02 2017 rev:2 rq:495711 version:0.4.4

Changes:

--- 
/work/SRC/openSUSE:Factory/ghc-servant-auth-cookie/ghc-servant-auth-cookie.changes
  2017-05-10 20:45:53.546005117 +0200
+++ 
/work/SRC/openSUSE:Factory/.ghc-servant-auth-cookie.new/ghc-servant-auth-cookie.changes
 2017-05-18 20:51:03.384090972 +0200
@@ -1,0 +2,5 @@
+Wed Apr 19 13:32:18 UTC 2017 - psim...@suse.com
+
+- Update to version 0.4.4 with cabal2obs.
+
+---

Old:

  servant-auth-cookie-0.4.3.3.tar.gz

New:

  servant-auth-cookie-0.4.4.tar.gz



Other differences:
--
++ ghc-servant-auth-cookie.spec ++
--- /var/tmp/diff_new_pack.kLHfZn/_old  2017-05-18 20:51:04.783893422 +0200
+++ /var/tmp/diff_new_pack.kLHfZn/_new  2017-05-18 20:51:04.787892858 +0200
@@ -19,7 +19,7 @@
 %global pkg_name servant-auth-cookie
 %bcond_with tests
 Name:   ghc-%{pkg_name}
-Version:0.4.3.3
+Version:0.4.4
 Release:0
 Summary:Authentication via encrypted cookies
 License:BSD-3-Clause

++ servant-auth-cookie-0.4.3.3.tar.gz -> servant-auth-cookie-0.4.4.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/servant-auth-cookie-0.4.3.3/CHANGELOG.md 
new/servant-auth-cookie-0.4.4/CHANGELOG.md
--- old/servant-auth-cookie-0.4.3.3/CHANGELOG.md2017-02-26 
22:18:49.0 +0100
+++ new/servant-auth-cookie-0.4.4/CHANGELOG.md  2017-04-15 11:57:55.0 
+0200
@@ -1,7 +1,13 @@
 # Change Log
 
-## [Unreleased]
+## [0.4.4]
+### Added
+- Tests for the example.
+- `parseSessionRequest` and `parseSessionResponse` functions.
+- `removeSessionFromErr` function.
 
+### Changed
+- Fixed constraint for `removeSession`.
 
 ## [0.4.3.3]
 ### Added
@@ -81,7 +87,8 @@
 - Initial version of the package.
 
 
-[HEAD]:../../compare/v0.4.3.3...HEAD
+[HEAD]:../../compare/v0.4.4...HEAD
+[0.4.4]:   ../../compare/v0.4.3.3...v0.4.4
 [0.4.3.3]: ../../compare/v0.4.3.2...v0.4.3.3
 [0.4.3.2]: ../../compare/v0.4.3.1...v0.4.3.2
 [0.4.3.1]: ../../compare/v0.4.3...v0.4.3.1
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/servant-auth-cookie-0.4.3.3/example/Main.hs 
new/servant-auth-cookie-0.4.4/example/Main.hs
--- old/servant-auth-cookie-0.4.3.3/example/Main.hs 2017-02-26 
22:18:49.0 +0100
+++ new/servant-auth-cookie-0.4.4/example/Main.hs   2017-04-15 
11:57:55.0 +0200
@@ -18,6 +18,10 @@
 main :: IO ()
 main = do
   rs <- mkRandomSource drgNew 1000
+  -- NOTE:
+  -- Every time the application is executed, a new server key is
+  -- created. This means, once you restart the app, already existing
+  -- cookies will be invalidated.
   sk <- mkServerKey 16 Nothing
   run 8080 (app authSettings rs sk)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/servant-auth-cookie-0.4.3.3/example/Test.hs 
new/servant-auth-cookie-0.4.4/example/Test.hs
--- old/servant-auth-cookie-0.4.3.3/example/Test.hs 1970-01-01 
01:00:00.0 +0100
+++ new/servant-auth-cookie-0.4.4/example/Test.hs   2017-04-15 
11:57:55.0 +0200
@@ -0,0 +1,199 @@
+{-# LANGUAGE OverloadedStrings #-}
+{-# LANGUAGE CPP #-}
+{-# LANGUAGE RecordWildCards #-}
+
+import Prelude ()
+import Prelude.Compat
+import Data.Maybe (fromMaybe)
+import Data.Int (Int64)
+import Data.Time.Clock (UTCTime(..))
+import Control.Monad.IO.Class (liftIO)
+import AuthAPI (app, authSettings, LoginForm(..), homePage, loginPage, 
Account(..))
+import Test.Hspec (Spec, hspec, describe, it)
+import Test.Hspec.Wai (WaiSession, WaiExpectation, shouldRespondWith, with, 
request, get)
+import Text.Blaze.Renderer.Utf8 (renderMarkup)
+import Servant (Proxy(..))
+import Crypto.Random (drgNew)
+import Servant (FormUrlEncoded, contentType)
+import Servant.Server.Experimental.Auth.Cookie
+import Network.HTTP.Types (methodGet, methodPost, hContentType, hCookie)
+import Network.HTTP.Media.RenderHeader (renderHeader)
+import Network.Wai.Test (SResponse(..))
+import qualified Data.ByteString.Lazy as BSL
+import qualified Data.ByteString.Lazy.Char8 as BSC8
+
+#if MIN_VERSION_hspec_wai (0,7,0)
+import Test.Hspec.Wai.Matcher (bodyEquals, ResponseMatcher(..), MatchBody(..))
+#else
+import Test.Hspec.Wai (matchBody)
+#endif
+
+#if MIN_VERSION_servant (0,9,0)
+import Web.FormUrlEncoded (ToForm, toForm, 

commit ghc-req for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package ghc-req for openSUSE:Factory checked 
in at 2017-05-18 20:50:59

Comparing /work/SRC/openSUSE:Factory/ghc-req (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-req.new (New)


Package is "ghc-req"

Thu May 18 20:50:59 2017 rev:4 rq:495710 version:0.2.0

Changes:

--- /work/SRC/openSUSE:Factory/ghc-req/ghc-req.changes  2017-05-10 
20:49:40.941918269 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-req.new/ghc-req.changes 2017-05-18 
20:51:01.764319565 +0200
@@ -1,0 +2,5 @@
+Fri May  5 07:40:08 UTC 2017 - psim...@suse.com
+
+- Update to version 0.2.0 revision 3 with cabal2obs.
+
+---



Other differences:
--
++ ghc-req.spec ++
--- /var/tmp/diff_new_pack.tQshKM/_old  2017-05-18 20:51:03.176120323 +0200
+++ /var/tmp/diff_new_pack.tQshKM/_new  2017-05-18 20:51:03.180119758 +0200
@@ -26,7 +26,7 @@
 Group:  Development/Languages/Other
 Url:https://hackage.haskell.org/package/%{pkg_name}
 Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
-Source1:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/revision/2.cabal#/%{pkg_name}.cabal
+Source1:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/revision/3.cabal#/%{pkg_name}.cabal
 BuildRequires:  ghc-Cabal-devel
 BuildRequires:  ghc-aeson-devel
 BuildRequires:  ghc-authenticate-oauth-devel

++ req.cabal ++
--- /var/tmp/diff_new_pack.tQshKM/_old  2017-05-18 20:51:03.224113550 +0200
+++ /var/tmp/diff_new_pack.tQshKM/_new  2017-05-18 20:51:03.224113550 +0200
@@ -32,7 +32,7 @@
 
 name: req
 version:  0.2.0
-x-revision: 2
+x-revision: 3
 cabal-version:>= 1.10
 license:  BSD3
 license-file: LICENSE.md
@@ -73,7 +73,7 @@
 , http-types   >= 0.8&& < 10.0
 , mtl  >= 2.0&& < 3.0
 , text >= 0.2&& < 1.3
-, time >= 1.2&& < 1.8
+, time >= 1.2&& < 1.9
 , transformers >= 0.4&& < 0.6
   if !impl(ghc >= 8.0)
 build-depends:semigroups   == 0.18.*
@@ -102,7 +102,7 @@
 , mtl  >= 2.0&& < 3.0
 , req  >= 0.2.0
 , text >= 0.2&& < 1.3
-, time >= 1.2&& < 1.8
+, time >= 1.2&& < 1.9
   if flag(dev)
 ghc-options:  -Wall -Werror
   else




commit ghc-log for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package ghc-log for openSUSE:Factory checked 
in at 2017-05-18 20:50:48

Comparing /work/SRC/openSUSE:Factory/ghc-log (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-log.new (New)


Package is "ghc-log"

Thu May 18 20:50:48 2017 rev:2 rq:495708 version:0.7

Changes:

--- /work/SRC/openSUSE:Factory/ghc-log/ghc-log.changes  2017-05-10 
20:45:29.077457701 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-log.new/ghc-log.changes 2017-05-18 
20:50:53.489487369 +0200
@@ -1,0 +2,5 @@
+Tue Mar 28 09:02:33 UTC 2017 - psim...@suse.com
+
+- Update to version 0.7 revision 1 with cabal2obs.
+
+---

New:

  log.cabal



Other differences:
--
++ ghc-log.spec ++
--- /var/tmp/diff_new_pack.H0A8wp/_old  2017-05-18 20:50:54.457350777 +0200
+++ /var/tmp/diff_new_pack.H0A8wp/_new  2017-05-18 20:50:54.461350212 +0200
@@ -26,6 +26,7 @@
 Group:  Development/Languages/Other
 Url:https://hackage.haskell.org/package/%{pkg_name}
 Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
+Source1:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/revision/1.cabal#/%{pkg_name}.cabal
 BuildRequires:  ghc-Cabal-devel
 BuildRequires:  ghc-log-base-devel
 BuildRequires:  ghc-log-elasticsearch-devel
@@ -73,6 +74,7 @@
 
 %prep
 %setup -q -n %{pkg_name}-%{version}
+cp -p %{SOURCE1} %{pkg_name}.cabal
 
 %build
 %ghc_lib_build

++ log.cabal ++
name:log
version: 0.7
x-revision: 1
synopsis:Structured logging solution with multiple backends

description: A library that provides a way to record structured
 log messages with multiple backends.
 .
 Supported backends:
 .
 * standard output
 .
 * Elasticsearch
 .
 * PostgreSQL

homepage:https://github.com/scrive/log
license: BSD3
license-file:LICENSE
author:  Scrive AB
maintainer:  Andrzej Rybczak ,
 Jonathan Jouty ,
 Mikhail Glushenkov ,
 Oleg Grenrus 
copyright:   Scrive AB
category:System
build-type:  Simple
cabal-version:   >=1.10
tested-with: GHC == 7.8.4, GHC == 7.10.3, GHC == 8.0.1

Source-repository head
  Type: git
  Location: https://github.com/scrive/log.git

library
  exposed-modules: Log,
   Log.Backend.ElasticSearch,
   Log.Backend.PostgreSQL,
   Log.Backend.StandardOutput,
   Log.Backend.StandardOutput.Bulk,
   Log.Backend.Text,
   Log.Class,
   Log.Data,
   Log.Internal.Logger,
   Log.Logger,
   Log.Monad

  build-depends:   base <5,
   log-base >= 0.7 && < 0.8,
   log-elasticsearch >= 0.7 && < 0.8,
   log-postgres >= 0.7 && < 0.8

  hs-source-dirs:  src

  ghc-options: -O2 -Wall -funbox-strict-fields

  default-language:   Haskell2010
  default-extensions: PackageImports

test-suite log-test
  type:   exitcode-stdio-1.0
  build-depends:  aeson,
  base,
  bloodhound,
  bytestring,
  http-client,
  http-types,
  log,
  random,
  tasty,
  tasty-hunit,
  time,
  text
  hs-source-dirs: test
  main-is:Test.hs
  other-modules:  Test.ElasticSearch
  ghc-options:-Wall -threaded
  default-language:   Haskell2010
  default-extensions: BangPatterns
, OverloadedStrings
, RecordWildCards

test-suite log-test-integration
  type:   exitcode-stdio-1.0
  build-depends:  aeson,
  base,
  bloodhound,
  bytestring,
  exceptions,
  http-client,
  http-types,
  log,
  process,
  random,
  tasty,
  tasty-hunit,
  time,
  text,
  

commit ghc-postgresql-typed for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package ghc-postgresql-typed for 
openSUSE:Factory checked in at 2017-05-18 20:50:54

Comparing /work/SRC/openSUSE:Factory/ghc-postgresql-typed (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-postgresql-typed.new (New)


Package is "ghc-postgresql-typed"

Thu May 18 20:50:54 2017 rev:2 rq:495709 version:0.5.1

Changes:

--- 
/work/SRC/openSUSE:Factory/ghc-postgresql-typed/ghc-postgresql-typed.changes
2017-05-10 20:54:28.429350640 +0200
+++ 
/work/SRC/openSUSE:Factory/.ghc-postgresql-typed.new/ghc-postgresql-typed.changes
   2017-05-18 20:50:55.861152662 +0200
@@ -1,0 +2,10 @@
+Mon Mar 27 12:36:38 UTC 2017 - psim...@suse.com
+
+- Update to version 0.5.1 with cabal2obs.
+
+---
+Sun Mar 26 15:39:47 UTC 2017 - psim...@suse.com
+
+- Update to version 0.5.0 revision 1 with cabal2obs.
+
+---

Old:

  postgresql-typed-0.5.0.tar.gz

New:

  postgresql-typed-0.5.1.tar.gz



Other differences:
--
++ ghc-postgresql-typed.spec ++
--- /var/tmp/diff_new_pack.q9vnxs/_old  2017-05-18 20:50:56.389078158 +0200
+++ /var/tmp/diff_new_pack.q9vnxs/_new  2017-05-18 20:50:56.393077593 +0200
@@ -19,9 +19,9 @@
 %global pkg_name postgresql-typed
 %bcond_with tests
 Name:   ghc-%{pkg_name}
-Version:0.5.0
+Version:0.5.1
 Release:0
-Summary:A PostgreSQL library with compile-time SQL type inference and 
optional HDBC backend
+Summary:PostgreSQL interface with compile-time SQL type checking, 
optional HDBC backend
 License:BSD-3-Clause
 Group:  Development/Languages/Other
 Url:https://hackage.haskell.org/package/%{pkg_name}

++ postgresql-typed-0.5.0.tar.gz -> postgresql-typed-0.5.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/postgresql-typed-0.5.0/Database/PostgreSQL/Typed/Types.hs 
new/postgresql-typed-0.5.1/Database/PostgreSQL/Typed/Types.hs
--- old/postgresql-typed-0.5.0/Database/PostgreSQL/Typed/Types.hs   
2017-01-27 04:25:55.0 +0100
+++ new/postgresql-typed-0.5.1/Database/PostgreSQL/Typed/Types.hs   
2017-03-22 21:23:11.0 +0100
@@ -94,9 +94,14 @@
 import GHC.TypeLits (Symbol, symbolVal, KnownSymbol)
 import Numeric (readFloat)
 #ifdef VERSION_postgresql_binary
+#if MIN_VERSION_postgresql_binary(0,12,0)
+import qualified PostgreSQL.Binary.Decoding as BinD
+import qualified PostgreSQL.Binary.Encoding as BinE
+#else
 import qualified PostgreSQL.Binary.Decoder as BinD
 import qualified PostgreSQL.Binary.Encoder as BinE
 #endif
+#endif
 
 type PGTextValue = BS.ByteString
 type PGBinaryValue = BS.ByteString
@@ -259,11 +264,31 @@
 | otherwise = Just s
 
 #ifdef VERSION_postgresql_binary
-binDec :: PGType t => BinD.Decoder a -> PGTypeID t -> PGBinaryValue -> a
-binDec d t = either (\e -> error $ "pgDecodeBinary " ++ show (pgTypeName t) ++ 
": " ++ show e) id . BinD.run d
+binEnc :: BinEncoder a -> a -> BS.ByteString
+binEnc = (.)
+#if MIN_VERSION_postgresql_binary(0,12,0)
+  BinE.encodingBytes
+
+type BinDecoder = BinD.Value
+type BinEncoder a = a -> BinE.Encoding
+#else
+  buildPGValue
+
+type BinDecoder = BinD.Decoder
+type BinEncoder a = BinE.Encoder a
+#endif
+
+binDec :: PGType t => BinDecoder a -> PGTypeID t -> PGBinaryValue -> a
+binDec d t = either (\e -> error $ "pgDecodeBinary " ++ show (pgTypeName t) ++ 
": " ++ show e) id . 
+#if MIN_VERSION_postgresql_binary(0,12,0)
+  BinD.valueParser
+#else
+  BinD.run
+#endif
+  d
 
 #define BIN_COL pgBinaryColumn _ _ = True
-#define BIN_ENC(F) pgEncodeValue _ _ = PGBinaryValue . buildPGValue . (F)
+#define BIN_ENC(F) pgEncodeValue _ _ = PGBinaryValue . binEnc (F)
 #define BIN_DEC(F) pgDecodeBinary _ = binDec (F)
 #else
 #define BIN_COL
@@ -382,21 +407,23 @@
   pgDecode _ = read . BSC.unpack
   BIN_DEC(BinD.float8)
 
+-- XXX need real encoding as text
+-- but then no one should be using this type really...
 instance PGType "\"char\"" where
   type PGVal "\"char\"" = Word8
   BIN_COL
 instance PGParameter "\"char\"" Word8 where
   pgEncode _ = BS.singleton
-  BIN_ENC(BinE.char . w2c)
+  pgEncodeValue _ _ = PGBinaryValue . BS.singleton
 instance PGColumn "\"char\"" Word8 where
   pgDecode _ = BS.head
-  BIN_DEC(c2w <$> BinD.char)
+  pgDecodeBinary _ _ = BS.head
 instance PGParameter "\"char\"" Char where
   pgEncode _ = BSC.singleton
-  BIN_ENC(BinE.char)
+  pgEncodeValue _ _ = PGBinaryValue . BSC.singleton
 instance PGColumn "\"char\"" Char where
   pgDecode _ = BSC.head
-  BIN_DEC(BinD.char)
+  pgDecodeBinary _ _ = BSC.head
 
 
 class PGType t => PGStringType t
@@ -565,12 +592,12 @@
 

commit ghc-invertible for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package ghc-invertible for openSUSE:Factory 
checked in at 2017-05-18 20:50:41

Comparing /work/SRC/openSUSE:Factory/ghc-invertible (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-invertible.new (New)


Package is "ghc-invertible"

Thu May 18 20:50:41 2017 rev:2 rq:495706 version:0.2.0.2

Changes:

--- /work/SRC/openSUSE:Factory/ghc-invertible/ghc-invertible.changes
2017-05-10 20:45:22.014454309 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-invertible.new/ghc-invertible.changes   
2017-05-18 20:50:42.191081879 +0200
@@ -1,0 +2,5 @@
+Fri May  5 07:40:08 UTC 2017 - psim...@suse.com
+
+- Update to version 0.2.0.2 revision 1 with cabal2obs.
+
+---

New:

  invertible.cabal



Other differences:
--
++ ghc-invertible.spec ++
--- /var/tmp/diff_new_pack.whKUUD/_old  2017-05-18 20:50:42.707009067 +0200
+++ /var/tmp/diff_new_pack.whKUUD/_new  2017-05-18 20:50:42.711008503 +0200
@@ -26,6 +26,7 @@
 Group:  Development/Languages/Other
 Url:https://hackage.haskell.org/package/%{pkg_name}
 Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
+Source1:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/revision/1.cabal#/%{pkg_name}.cabal
 BuildRequires:  ghc-Cabal-devel
 BuildRequires:  ghc-TypeCompose-devel
 BuildRequires:  ghc-haskell-src-meta-devel
@@ -64,6 +65,7 @@
 
 %prep
 %setup -q -n %{pkg_name}-%{version}
+cp -p %{SOURCE1} %{pkg_name}.cabal
 
 %build
 %define cabal_configure_options -f-hlist -f-piso

++ invertible.cabal ++
name:invertible
version: 0.2.0.2
x-revision: 1
synopsis:bidirectional arrows, bijective functions, and invariant 
functors
description:
  Representations and operations for bidirectional arrows (total isomorphisms: 
an
  arrow paired with its inverse).  Classes for invariant functors and monoidal
  functors.  Includes a number of useful bijections and operations, as well as
  interoperability with related packages.
  .
  Most users will want to import one or more of "Data.Invertible" qualified, 
"Control.Invertible.Monoidal" unqualified, and any additional compatibility 
modules.
license: BSD3
license-file:LICENSE
author:  Dylan Simon
maintainer:  dy...@dylex.net
copyright:   2016
category:Data, Control, Composition
build-type:  Simple
cabal-version:   >=1.10
tested-with: GHC == 7.10.3, GHC == 8.0.1

source-repository head
  type: git
  location: https://github.com/dylex/invertible

flag arrows
  description: Support the arrows package
  manual: True
  default: False
flag invariant
  description: Support the invariant package
  manual: True
  default: True
flag lens
  description: Support the lens package
  manual: True
  default: True
flag partial-isomorphisms
  description: Support the partial-isomorphisms package
  manual: True
  default: True
flag Piso
  description: Support the Piso package
  manual: True
  default: False
flag semigroupoids
  description: Support the semigroupoids package
  manual: True
  default: True
flag TypeCompose
  description: Support the TypeCompose package
  manual: True
  default: True

library
  other-modules:
Data.Invertible.Internal
  exposed-modules:
Data.Invertible.Bijection
Data.Invertible.TH
Data.Invertible.Bits
Data.Invertible.Bool
Data.Invertible.Coerce
Data.Invertible.Complex
Data.Invertible.Either
Data.Invertible.Enum
Data.Invertible.Function
Data.Invertible.Functor
Data.Invertible.List
Data.Invertible.Maybe
Data.Invertible.Monad
Data.Invertible.Monoid
Data.Invertible.Ord
Data.Invertible.Tuple
Data.Invertible.Prelude
Data.Invertible
Control.Invertible.BiArrow
Control.Invertible.MonadArrow
Control.Invertible.Functor
Control.Invertible.Monoidal
Control.Invertible.Monoidal.Free

  build-depends:
base >= 4.8 && <5,
transformers,
haskell-src-meta >= 0.6 && < 0.9,
template-haskell == 2.*
  default-language:Haskell2010
  ghc-options: -Wall

  if flag(arrows)
build-depends: arrows
  if flag(invariant)
exposed-modules: Data.Invertible.Invariant
build-depends: invariant
  if flag(lens)
exposed-modules: Data.Invertible.Lens
build-depends: lens == 4.*
  if flag(partial-isomorphisms)
exposed-modules: Data.Invertible.PartialIsomorphism
if impl(ghc >= 8)
  build-depends: partial-isomorphisms > 0.2
else
  build-depends: partial-isomorphisms
  if flag(Piso)
exposed-modules: Data.Invertible.Piso
if impl(ghc >= 8)
  

commit ghc-language-puppet for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package ghc-language-puppet for 
openSUSE:Factory checked in at 2017-05-18 20:50:44

Comparing /work/SRC/openSUSE:Factory/ghc-language-puppet (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-language-puppet.new (New)


Package is "ghc-language-puppet"

Thu May 18 20:50:44 2017 rev:2 rq:495707 version:1.3.7

Changes:

--- /work/SRC/openSUSE:Factory/ghc-language-puppet/ghc-language-puppet.changes  
2017-05-10 20:45:22.670361758 +0200
+++ 
/work/SRC/openSUSE:Factory/.ghc-language-puppet.new/ghc-language-puppet.changes 
2017-05-18 20:50:45.806571635 +0200
@@ -1,0 +2,10 @@
+Mon Mar 27 12:41:41 UTC 2017 - psim...@suse.com
+
+- Update to version 1.3.7 with cabal2obs.
+
+---
+Tue Mar  7 11:19:27 UTC 2017 - psim...@suse.com
+
+- Update to version 1.3.6 with cabal2obs.
+
+---

Old:

  language-puppet-1.3.5.1.tar.gz

New:

  language-puppet-1.3.7.tar.gz



Other differences:
--
++ ghc-language-puppet.spec ++
--- /var/tmp/diff_new_pack.CO4Lfl/_old  2017-05-18 20:50:46.894418111 +0200
+++ /var/tmp/diff_new_pack.CO4Lfl/_new  2017-05-18 20:50:46.898417546 +0200
@@ -19,7 +19,7 @@
 %global pkg_name language-puppet
 %bcond_with tests
 Name:   ghc-%{pkg_name}
-Version:1.3.5.1
+Version:1.3.7
 Release:0
 Summary:Tools to parse and evaluate the Puppet DSL
 License:BSD-3-Clause

++ language-puppet-1.3.5.1.tar.gz -> language-puppet-1.3.7.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/language-puppet-1.3.5.1/CHANGELOG.markdown 
new/language-puppet-1.3.7/CHANGELOG.markdown
--- old/language-puppet-1.3.5.1/CHANGELOG.markdown  2017-02-02 
11:58:01.0 +0100
+++ new/language-puppet-1.3.7/CHANGELOG.markdown2017-03-14 
18:12:30.0 +0100
@@ -1,3 +1,14 @@
+# v1.3.7 (2017/03/14)
+
+* Add puppet `sprintf` function
+* Fix scientific2text (#196)
+
+# v1.3.6 (2017/02/27)
+
+* The `defined` function can now test variables
+* Fixed the `delete_at` function, added new tests, TBC
+* Fixed the `ensure_resource` function, so that its second argument can take 
an array.
+
 # v1.3.5.1 (2017/02/02)
 
 * Version bumps for megaparsec & servant
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/language-puppet-1.3.5.1/Facter.hs 
new/language-puppet-1.3.7/Facter.hs
--- old/language-puppet-1.3.5.1/Facter.hs   2016-05-30 10:47:29.0 
+0200
+++ new/language-puppet-1.3.7/Facter.hs 2017-03-14 18:12:16.0 +0100
@@ -110,14 +110,16 @@
 | otherwise = takeWhile (/= '.') lrelease
 osfam   | distid == "Ubuntu" = "Debian"
 | otherwise = distid
-return  [ ("lsbdistid"  , distid)
-, ("operatingsystem", distid)
-, ("lsbdistrelease" , lrelease)
-, ("operatingsystemrelease" , lrelease)
-, ("lsbmajdistrelease"  , maj)
-, ("osfamily"   , osfam)
-, ("lsbdistcodename", getval "DISTRIB_CODENAME")
-, ("lsbdistdescription" , getval "DISTRIB_DESCRIPTION")
+return  [ ("lsbdistid" , distid)
+, ("operatingsystem"   , distid)
+, ("lsbdistrelease", lrelease)
+, ("operatingsystemrelease", lrelease)
+, ("operatingsystemmajrelease" , lrelease)
+, ("lsbmajdistrelease" , maj)
+, ("lsbminordistrelease"   , "")
+, ("osfamily"  , osfam)
+, ("lsbdistcodename"   , getval "DISTRIB_CODENAME")
+, ("lsbdistdescription", getval "DISTRIB_DESCRIPTION")
 ]
 
 factMountPoints :: IO [(String, String)]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/language-puppet-1.3.5.1/Puppet/Interpreter/IO.hs 
new/language-puppet-1.3.7/Puppet/Interpreter/IO.hs
--- old/language-puppet-1.3.5.1/Puppet/Interpreter/IO.hs2016-06-09 
11:10:16.0 +0200
+++ new/language-puppet-1.3.7/Puppet/Interpreter/IO.hs  2017-03-14 
18:12:16.0 +0100
@@ -79,7 +79,6 @@
 PuppetPaths  -> runInstr (r ^. readerPuppetPaths)
 GetNativeTypes   -> runInstr (r ^. readerNativeTypes)
 ErrorThrow d -> return (Left d, s, mempty)
-ErrorCatch _ _   -> thpe "ErrorCatch"
 GetNodeName  -> runInstr (r ^. readerNodename)
 HieraQuery scps q t  

commit ghc-gi-webkit for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package ghc-gi-webkit for openSUSE:Factory 
checked in at 2017-05-18 20:50:39

Comparing /work/SRC/openSUSE:Factory/ghc-gi-webkit (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-gi-webkit.new (New)


Package is "ghc-gi-webkit"

Thu May 18 20:50:39 2017 rev:2 rq:495705 version:3.0.12

Changes:

--- /work/SRC/openSUSE:Factory/ghc-gi-webkit/ghc-gi-webkit.changes  
2017-05-10 20:36:37.320486767 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-gi-webkit.new/ghc-gi-webkit.changes 
2017-05-18 20:50:41.199221856 +0200
@@ -1,0 +2,5 @@
+Wed May  3 08:24:05 UTC 2017 - psim...@suse.com
+
+- Update to version 3.0.12 with cabal2obs.
+
+---

Old:

  gi-webkit-3.0.11.tar.gz

New:

  gi-webkit-3.0.12.tar.gz



Other differences:
--
++ ghc-gi-webkit.spec ++
--- /var/tmp/diff_new_pack.41Y6hG/_old  2017-05-18 20:50:41.987110664 +0200
+++ /var/tmp/diff_new_pack.41Y6hG/_new  2017-05-18 20:50:41.991110099 +0200
@@ -18,7 +18,7 @@
 
 %global pkg_name gi-webkit
 Name:   ghc-%{pkg_name}
-Version:3.0.11
+Version:3.0.12
 Release:0
 Summary:WebKit bindings
 License:LGPL-2.1+
@@ -84,6 +84,6 @@
 
 %files devel -f %{name}-devel.files
 %defattr(-,root,root,-)
-%doc README.md
+%doc ChangeLog.md README.md
 
 %changelog

++ gi-webkit-3.0.11.tar.gz -> gi-webkit-3.0.12.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gi-webkit-3.0.11/README.md 
new/gi-webkit-3.0.12/README.md
--- old/gi-webkit-3.0.11/README.md  2016-12-27 12:15:19.0 +0100
+++ new/gi-webkit-3.0.12/README.md  2017-04-27 19:36:52.0 +0200
@@ -1,6 +1,6 @@
 # Documentation
 Autogenerated documentation for this package can be found at
 
-https://hackage.haskell.org/package/gi-webkit-3.0.11/docs/GI-WebKit.html
+[https://hackage.haskell.org/package/gi-webkit-3.0.12/docs/GI-WebKit.html](https://hackage.haskell.org/package/gi-webkit-3.0.12/docs/GI-WebKit.html)
 
 For general documentation on using 
[haskell-gi](https://github.com/haskell-gi/haskell-gi) based bindings, see [the 
project page](https://github.com/haskell-gi/haskell-gi) or [the 
Wiki](https://github.com/haskell-gi/haskell-gi/wiki).
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gi-webkit-3.0.11/gi-webkit.cabal 
new/gi-webkit-3.0.12/gi-webkit.cabal
--- old/gi-webkit-3.0.11/gi-webkit.cabal2016-12-27 12:15:19.0 
+0100
+++ new/gi-webkit-3.0.12/gi-webkit.cabal2017-04-27 19:36:52.0 
+0200
@@ -1,5 +1,5 @@
 name: gi-webkit
-version:  3.0.11
+version:  3.0.12
 synopsis: WebKit bindings
 description:  Bindings for WebKit, autogenerated by haskell-gi.
 homepage: https://github.com/haskell-gi/haskell-gi
@@ -11,12 +11,12 @@
 build-type:   Custom
 cabal-version:>= 1.24
 
-extra-source-files: README.md stack.yaml WebKit.overrides
+extra-source-files: README.md ChangeLog.md stack.yaml WebKit.overrides
 
 custom-setup
   setup-depends: base >= 4.7 && < 5,
  Cabal >= 1.24,
- haskell-gi >= 0.20 && < 1
+ haskell-gi >= 0.20.1 && < 1
 
 Flag overloaded-methods
   Description: Generate support for overloaded methods.
@@ -36,7 +36,7 @@
   pkgconfig-depends: webkitgtk-3.0
   build-depends: base >= 4.7 && <5,
  haskell-gi-base >= 0.20 && < 1,
- haskell-gi >= 0.20 && < 1,
+ haskell-gi >= 0.20.1 && < 1,
  gi-cairo == 1.0.*,
  gi-soup == 2.4.*,
  gi-javascriptcore == 3.0.*,




commit eventstat for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package eventstat for openSUSE:Factory 
checked in at 2017-05-18 20:50:24

Comparing /work/SRC/openSUSE:Factory/eventstat (Old)
 and  /work/SRC/openSUSE:Factory/.eventstat.new (New)


Package is "eventstat"

Thu May 18 20:50:24 2017 rev:2 rq:495697 version:0.03.04

Changes:

--- /work/SRC/openSUSE:Factory/eventstat/eventstat.changes  2016-09-21 
18:46:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.eventstat.new/eventstat.changes 2017-05-18 
20:50:29.676847974 +0200
@@ -1,0 +2,24 @@
+Wed May 10 14:40:35 UTC 2017 - mar...@gmx.de
+
+- update to version 0.03.04
+  * Makefile: bump version
+  * Add GNU C printf attribute to err_abort
+  * Makefile: add snapcraft files to make dist rule
+  * Add variable pid size handling.
+  * Add snapcraft files
+  * Update copyright year
+  * Fix non-ANSI declaration of functions eventstat_winsize
+and eventstat_refresh
+
+- update to version 0.03.03
+  * Makefile: bump version
+  * Fix FLOAT_CMP macro - need fabs on result
+  * Remove sdl declarations to fix sdl shadowing
+  * constify info1, info2
+  * Move scope of duration, removes shadowing of this variable
+  * Allow floating point comparisons a little bit of tiny slop
+  * Add stdarg.h header
+  * use gnu printf style attributes for es_printf
+  * Makefile: add PEDANTIC flags
+
+---

Old:

  eventstat-0.03.02.tar.gz

New:

  eventstat-0.03.04.tar.gz



Other differences:
--
++ eventstat.spec ++
--- /var/tmp/diff_new_pack.lpVUzY/_old  2017-05-18 20:50:30.544725493 +0200
+++ /var/tmp/diff_new_pack.lpVUzY/_new  2017-05-18 20:50:30.544725493 +0200
@@ -1,7 +1,8 @@
 #
 # spec file for package eventstat
 #
-# Copyright (c) 2016, Martin Hauke 
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +18,7 @@
 
 
 Name:   eventstat
-Version:0.03.02
+Version:0.03.04
 Release:0
 Summary:Kernel event states monitoring tool
 License:GPL-2.0+
@@ -47,6 +48,6 @@
 %defattr(-,root,root)
 %doc COPYING
 %{_bindir}/eventstat
-%{_mandir}/man8/*
+%{_mandir}/man8/eventstat.8%{ext_man}
 
 %changelog

++ eventstat-0.03.02.tar.gz -> eventstat-0.03.04.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/eventstat-0.03.02/Makefile 
new/eventstat-0.03.04/Makefile
--- old/eventstat-0.03.02/Makefile  2016-05-05 14:20:21.0 +0200
+++ new/eventstat-0.03.04/Makefile  2017-04-14 17:41:53.0 +0200
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011-2016 Canonical, Ltd.
+# Copyright (C) 2011-2017 Canonical, Ltd.
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License
@@ -16,10 +16,20 @@
 # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, 
USA.
 #
 
-VERSION=0.03.02
+VERSION=0.03.04
 
 CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2
 
+#
+# Pedantic flags
+#
+ifeq ($(PEDANTIC),1)
+CFLAGS += -Wabi -Wcast-qual -Wfloat-equal -Wmissing-declarations \
+   -Wmissing-format-attribute -Wno-long-long -Wpacked \
+   -Wredundant-decls -Wshadow -Wno-missing-field-initializers \
+   -Wno-missing-braces -Wno-sign-compare -Wno-multichar
+endif
+
 BINDIR=/usr/bin
 MANDIR=/usr/share/man/man8
 
@@ -32,7 +42,8 @@
 dist:
rm -rf eventstat-$(VERSION)
mkdir eventstat-$(VERSION)
-   cp -rp Makefile eventstat.c eventstat.8 COPYING eventstat-$(VERSION)
+   cp -rp Makefile eventstat.c eventstat.8 COPYING snapcraft \
+   eventstat-$(VERSION)
tar -zcf eventstat-$(VERSION).tar.gz eventstat-$(VERSION)
rm -rf eventstat-$(VERSION)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/eventstat-0.03.02/eventstat.c 
new/eventstat-0.03.04/eventstat.c
--- old/eventstat-0.03.02/eventstat.c   2016-05-05 14:20:21.0 +0200
+++ new/eventstat-0.03.04/eventstat.c   2017-04-14 17:41:53.0 +0200
@@ -1,5 +1,5 @@
 /*
- * Copyright (C) 2011-2016 Canonical
+ * Copyright (C) 2011-2017 Canonical
  * Hugely modified parts from powertop-1.13, Copyright 2007, Intel Corporation
  *
  * This program is free software; you can redistribute it and/or
@@ -23,6 +23,7 @@
 #include 
 #include 
 #include 
+#include 
 #include 
 #include 
 #include 
@@ -90,6 +91,9 @@
 #define OPTIMIZE3
 #endif
 
+#define FLOAT_TINY (0.001)
+#define FLOAT_CMP(a, b)   

commit smemstat for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package smemstat for openSUSE:Factory 
checked in at 2017-05-18 20:50:29

Comparing /work/SRC/openSUSE:Factory/smemstat (Old)
 and  /work/SRC/openSUSE:Factory/.smemstat.new (New)


Package is "smemstat"

Thu May 18 20:50:29 2017 rev:2 rq:495698 version:0.01.17

Changes:

--- /work/SRC/openSUSE:Factory/smemstat/smemstat.changes2016-09-21 
18:46:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.smemstat.new/smemstat.changes   2017-05-18 
20:50:32.264482789 +0200
@@ -1,0 +2,30 @@
+Wed May 10 17:00:04 UTC 2017 - mar...@gmx.de
+
+- update to version 0.01.17
+  * Makefile: bump version
+  * Manual: update copyright year and manual date
+  * Makefile: add snapcraft to make dist rule
+  * Add variable pid size handling.
+  * Update copyright year
+  * Add system-observe plug to snapcraft rules
+
+- update to version 0.01.16
+  * Makefile: bump version
+  * Add some more trivial comments
+  * Remove unnecessary static NULL assignments
+  * Add gnu printf attributes
+  * Clean up code
+  * Remove need for linebreak display function
+  * Debain/control: add libncurses5-dev
+  * Update manual
+  * Add ncurses -t and -T top modes
+  * Makefile: add PEDANTIC flags
+
+- update to version 0.01.15
+  * Makefile: bump version
+  * Debian/control: update Build-Depends for debhelper
+  * Debian/compat: update to 9
+  * Debian/control: update Standards-Version to 3.9.8
+  * Update and correct copyright years
+
+---

Old:

  smemstat-0.01.14.tar.gz

New:

  smemstat-0.01.17.tar.gz



Other differences:
--
++ smemstat.spec ++
--- /var/tmp/diff_new_pack.uG2MEw/_old  2017-05-18 20:50:32.900393045 +0200
+++ /var/tmp/diff_new_pack.uG2MEw/_new  2017-05-18 20:50:32.904392481 +0200
@@ -1,7 +1,8 @@
 #
 # spec file for package smemstat
 #
-# Copyright (c) 2015, Martin Hauke 
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,13 +18,14 @@
 
 
 Name:   smemstat
-Version:0.01.14
+Version:0.01.17
 Release:0
 Summary:Memory usage monitoring tool
 License:GPL-2.0+
 Group:  System/Monitoring
 Url:http://kernel.ubuntu.com/~cking/smemstat/
 Source: 
http://kernel.ubuntu.com/~cking/tarballs/%{name}/%{name}-%{version}.tar.gz
+BuildRequires:  ncurses-devel
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -45,6 +47,6 @@
 %defattr(-,root,root)
 %doc COPYING
 %{_bindir}/smemstat
-%{_mandir}/man8/*
+%{_mandir}/man8/smemstat.8%{ext_man}
 
 %changelog

++ smemstat-0.01.14.tar.gz -> smemstat-0.01.17.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/smemstat-0.01.14/Makefile 
new/smemstat-0.01.17/Makefile
--- old/smemstat-0.01.14/Makefile   2015-07-10 01:43:55.0 +0200
+++ new/smemstat-0.01.17/Makefile   2017-04-14 19:05:07.0 +0200
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014-2015 Canonical, Ltd.
+# Copyright (C) 2014-2017 Canonical, Ltd.
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License
@@ -16,18 +16,28 @@
 # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, 
USA.
 #
 
-VERSION=0.01.14
+VERSION=0.01.17
 #
 
 CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2
 
+#
+# Pedantic flags
+#
+ifeq ($(PEDANTIC),1)
+CFLAGS += -Wabi -Wcast-qual -Wfloat-equal -Wmissing-declarations \
+   -Wmissing-format-attribute -Wno-long-long -Wpacked \
+   -Wredundant-decls -Wshadow -Wno-missing-field-initializers \
+   -Wno-missing-braces -Wno-sign-compare -Wno-multichar
+endif
+
 BINDIR=/usr/bin
 MANDIR=/usr/share/man/man8
 
 OBJS = smemstat.o 
 
 smemstat: $(OBJS) Makefile
-   $(CC) $(CFLAGS) $(OBJS) -o $@ $(LDFLAGS)
+   $(CC) $(CFLAGS) $(OBJS) -lm -lncurses -o $@ $(LDFLAGS)
 
 smemstat.8.gz: smemstat.8
gzip -c $< > $@
@@ -35,7 +45,8 @@
 dist:
rm -rf smemstat-$(VERSION)
mkdir smemstat-$(VERSION)
-   cp -rp Makefile smemstat.c smemstat.8 COPYING README scripts 
smemstat-$(VERSION)
+   cp -rp Makefile smemstat.c smemstat.8 COPYING README scripts \
+   snapcraft smemstat-$(VERSION)
tar -zcf smemstat-$(VERSION).tar.gz smemstat-$(VERSION)
rm -rf smemstat-$(VERSION)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/smemstat-0.01.14/smemstat.8 

commit fnotifystat for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package fnotifystat for openSUSE:Factory 
checked in at 2017-05-18 20:50:14

Comparing /work/SRC/openSUSE:Factory/fnotifystat (Old)
 and  /work/SRC/openSUSE:Factory/.fnotifystat.new (New)


Package is "fnotifystat"

Thu May 18 20:50:14 2017 rev:2 rq:495695 version:0.01.17

Changes:

--- /work/SRC/openSUSE:Factory/fnotifystat/fnotifystat.changes  2016-09-21 
18:46:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.fnotifystat.new/fnotifystat.changes 
2017-05-18 20:50:15.182893460 +0200
@@ -1,0 +2,23 @@
+Wed May 10 14:49:51 UTC 2017 - mar...@gmx.de
+
+- update to version 0.01.17
+  * Makefile: bump version
+  * Manual: update copyright year and date
+  * Add variable pid size handling.
+  * Re-order declarations of mounts and mount in fnotify_event_init
+  * Update copyright year to source
+
+- update to version 0.01.16
+  * Makefile: bump version
+  * Remove extraneous declaration of ret to fix shadowing
+  * constify fs1 fs2
+  * Make some helper functions static
+  * Makefile: add PEDANTIC flags
+
+- update to version 0.01.15
+  * Makefile: bump version
+  * reduce scope of ptr
+  * debian/control: update Standards-Version to 3.9.8
+  * Update and correct copyright years
+
+---

Old:

  fnotifystat-0.01.14.tar.gz

New:

  fnotifystat-0.01.17.tar.gz



Other differences:
--
++ fnotifystat.spec ++
--- /var/tmp/diff_new_pack.dQ7jhR/_old  2017-05-18 20:50:16.170754047 +0200
+++ /var/tmp/diff_new_pack.dQ7jhR/_new  2017-05-18 20:50:16.174753482 +0200
@@ -1,7 +1,8 @@
 #
 # spec file for package fnotifystat
 #
-# Copyright (c) 2015, Martin Hauke 
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +18,7 @@
 
 
 Name:   fnotifystat
-Version:0.01.14
+Version:0.01.17
 Release:0
 Summary:File activity monitoring tool
 License:GPL-2.0+
@@ -45,6 +46,6 @@
 %defattr(-,root,root)
 %doc COPYING
 %{_sbindir}/fnotifystat
-%{_mandir}/man8/*
+%{_mandir}/man8/fnotifystat.8%{ext_man}
 
 %changelog

++ fnotifystat-0.01.14.tar.gz -> fnotifystat-0.01.17.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fnotifystat-0.01.14/Makefile 
new/fnotifystat-0.01.17/Makefile
--- old/fnotifystat-0.01.14/Makefile2015-10-14 20:05:31.0 +0200
+++ new/fnotifystat-0.01.17/Makefile2017-04-14 18:16:38.0 +0200
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013-2015 Canonical, Ltd.
+# Copyright (C) 2014-2017 Canonical, Ltd.
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License
@@ -16,10 +16,20 @@
 # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, 
USA.
 #
 
-VERSION=0.01.14
+VERSION=0.01.17
 
 CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2
 
+#
+# Pedantic flags
+#
+ifeq ($(PEDANTIC),1)
+CFLAGS += -Wabi -Wcast-qual -Wfloat-equal -Wmissing-declarations \
+   -Wmissing-format-attribute -Wno-long-long -Wpacked \
+   -Wredundant-decls -Wshadow -Wno-missing-field-initializers \
+   -Wno-missing-braces -Wno-sign-compare -Wno-multichar
+endif
+
 BINDIR=/usr/sbin
 MANDIR=/usr/share/man/man8
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fnotifystat-0.01.14/fnotifystat.8 
new/fnotifystat-0.01.17/fnotifystat.8
--- old/fnotifystat-0.01.14/fnotifystat.8   2015-10-14 20:05:31.0 
+0200
+++ new/fnotifystat-0.01.17/fnotifystat.8   2017-04-14 18:16:38.0 
+0200
@@ -2,7 +2,7 @@
 .\" First parameter, NAME, should be all caps
 .\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
 .\" other parameters are allowed: see man(7), man(1)
-.TH FNOTIFYSTAT 8 "May 18, 2015"
+.TH FNOTIFYSTAT 8 "Apr 14, 2017"
 .\" Please adjust this date whenever revising the manpage.
 .\"
 .\" Some roff macros, for reference:
@@ -158,7 +158,7 @@
 .PP
 This manual page was written by Colin King , for the 
Ubuntu project (but may be used by others).
 .SH COPYRIGHT
-Copyright \(co 2011-2015 Canonical Ltd.
+Copyright \(co 2014-2017 Canonical Ltd.
 .br
 This is free software; see the source for copying conditions.  There is NO
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fnotifystat-0.01.14/fnotifystat.c 

commit forkstat for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package forkstat for openSUSE:Factory 
checked in at 2017-05-18 20:50:08

Comparing /work/SRC/openSUSE:Factory/forkstat (Old)
 and  /work/SRC/openSUSE:Factory/.forkstat.new (New)


Package is "forkstat"

Thu May 18 20:50:08 2017 rev:2 rq:495694 version:0.01.17

Changes:

--- /work/SRC/openSUSE:Factory/forkstat/forkstat.changes2016-09-21 
18:46:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.forkstat.new/forkstat.changes   2017-05-18 
20:50:14.035055450 +0200
@@ -1,0 +2,33 @@
+Wed May 10 14:53:13 UTC 2017 - mar...@gmx.de
+
+- update to version 0.01.17
+  * Makefile: bump version
+  * Manual: update copyright year and manual date
+  * Makefile: add snapcraft to make dist rule
+  * Add variable pid size handling.
+  * Remove redundant free on a null pointer
+  * Add snapcraft
+  * Update copyright year
+  * Manual: expand width of columns to 5i
+
+- update to version 0.01.16
+  * Makefile: bump version
+  * Make kernel_tasks const
+  * unconstify arg in parse_ev to fix pedantic build warning
+  * Clean up formatting on ev_map table
+  * constify s1 and s2
+  * Makefile: add PEDANTIC build flags
+
+- update to version 0.01.15
+  * Makefile: bump version
+  * forkstat: make counters size_t
+  * forkstat: voidify return from fclose
+  * Debian: fix spelling mistake in changelog
+
+- update to version 0.01.14
+  * Makefile: bump version
+  * debian/control: update Standards-Version to 3.9.8
+  * debian/rules: make build reproducible (Closes: #833439)
+  * Update copyright year to 2016
+
+---

Old:

  forkstat-0.01.13.tar.gz

New:

  forkstat-0.01.17.tar.gz



Other differences:
--
++ forkstat.spec ++
--- /var/tmp/diff_new_pack.EDuyTV/_old  2017-05-18 20:50:14.922930148 +0200
+++ /var/tmp/diff_new_pack.EDuyTV/_new  2017-05-18 20:50:14.926929583 +0200
@@ -1,7 +1,8 @@
 #
 # spec file for package forkstat
 #
-# Copyright (c) 2015, Martin Hauke 
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +18,7 @@
 
 
 Name:   forkstat
-Version:0.01.13
+Version:0.01.17
 Release:0
 Summary:Process fork/exec/exit monitoring tool
 License:GPL-2.0+
@@ -45,6 +46,6 @@
 %defattr(-,root,root)
 %%doc COPYING
 %{_bindir}/forkstat
-%{_mandir}/man8/*
+%{_mandir}/man8/forkstat.8%{ext_man}
 
 %changelog

++ forkstat-0.01.13.tar.gz -> forkstat-0.01.17.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/forkstat-0.01.13/Makefile 
new/forkstat-0.01.17/Makefile
--- old/forkstat-0.01.13/Makefile   2015-11-30 14:02:33.0 +0100
+++ new/forkstat-0.01.17/Makefile   2017-04-14 18:37:45.0 +0200
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014-2015 Canonical, Ltd.
+# Copyright (C) 2014-2017 Canonical, Ltd.
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License
@@ -16,12 +16,21 @@
 # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, 
USA.
 #
 
-VERSION=0.01.13
+VERSION=0.01.17
 #
 # Version "Frantic Forking Finder"
 #
 
 CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2
+#
+# Pedantic flags
+#
+ifeq ($(PEDANTIC),1)
+CFLAGS += -Wabi -Wcast-qual -Wfloat-equal -Wmissing-declarations \
+   -Wmissing-format-attribute -Wno-long-long -Wpacked \
+   -Wredundant-decls -Wshadow -Wno-missing-field-initializers \
+   -Wno-missing-braces -Wno-sign-compare -Wno-multichar
+endif
 
 export DEB_BUILD_HARDENING=1
 
@@ -38,7 +47,7 @@
rm -rf forkstat-$(VERSION)
mkdir forkstat-$(VERSION)
cp -rp Makefile forkstat.c forkstat.8 mascot COPYING \
-   forkstat-$(VERSION)
+   snapcraft forkstat-$(VERSION)
tar -zcf forkstat-$(VERSION).tar.gz forkstat-$(VERSION)
rm -rf forkstat-$(VERSION)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/forkstat-0.01.13/forkstat.8 
new/forkstat-0.01.17/forkstat.8
--- old/forkstat-0.01.13/forkstat.8 2015-11-30 14:02:33.0 +0100
+++ new/forkstat-0.01.17/forkstat.8 2017-04-14 18:37:45.0 +0200
@@ -2,7 +2,7 @@
 .\" First parameter, NAME, should be all caps
 .\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
 .\" other parameters are allowed: see man(7), man(1)
-.TH FORKSTAT 8 "18 May, 2015"
+.TH FORKSTAT 8 "14 April, 2017"
 .\" Please adjust this date whenever 

commit ghc-gi-soup for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package ghc-gi-soup for openSUSE:Factory 
checked in at 2017-05-18 20:50:36

Comparing /work/SRC/openSUSE:Factory/ghc-gi-soup (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-gi-soup.new (New)


Package is "ghc-gi-soup"

Thu May 18 20:50:36 2017 rev:2 rq:495704 version:2.4.12

Changes:

--- /work/SRC/openSUSE:Factory/ghc-gi-soup/ghc-gi-soup.changes  2017-05-10 
20:36:30.569439273 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-gi-soup.new/ghc-gi-soup.changes 
2017-05-18 20:50:38.107658160 +0200
@@ -1,0 +2,5 @@
+Wed May  3 08:13:59 UTC 2017 - psim...@suse.com
+
+- Update to version 2.4.12 with cabal2obs.
+
+---

Old:

  gi-soup-2.4.11.tar.gz

New:

  gi-soup-2.4.12.tar.gz



Other differences:
--
++ ghc-gi-soup.spec ++
--- /var/tmp/diff_new_pack.sTpsh7/_old  2017-05-18 20:50:38.807559385 +0200
+++ /var/tmp/diff_new_pack.sTpsh7/_new  2017-05-18 20:50:38.811558820 +0200
@@ -18,7 +18,7 @@
 
 %global pkg_name gi-soup
 Name:   ghc-%{pkg_name}
-Version:2.4.11
+Version:2.4.12
 Release:0
 Summary:Libsoup bindings
 License:LGPL-2.1+
@@ -77,6 +77,6 @@
 
 %files devel -f %{name}-devel.files
 %defattr(-,root,root,-)
-%doc README.md
+%doc ChangeLog.md README.md
 
 %changelog

++ gi-soup-2.4.11.tar.gz -> gi-soup-2.4.12.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gi-soup-2.4.11/README.md new/gi-soup-2.4.12/README.md
--- old/gi-soup-2.4.11/README.md2016-12-27 12:14:38.0 +0100
+++ new/gi-soup-2.4.12/README.md2017-04-27 19:36:20.0 +0200
@@ -1,6 +1,6 @@
 # Documentation
 Autogenerated documentation for this package can be found at
 
-https://hackage.haskell.org/package/gi-soup-2.4.11/docs/GI-Soup.html
+[https://hackage.haskell.org/package/gi-soup-2.4.12/docs/GI-Soup.html](https://hackage.haskell.org/package/gi-soup-2.4.12/docs/GI-Soup.html)
 
 For general documentation on using 
[haskell-gi](https://github.com/haskell-gi/haskell-gi) based bindings, see [the 
project page](https://github.com/haskell-gi/haskell-gi) or [the 
Wiki](https://github.com/haskell-gi/haskell-gi/wiki).
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gi-soup-2.4.11/gi-soup.cabal 
new/gi-soup-2.4.12/gi-soup.cabal
--- old/gi-soup-2.4.11/gi-soup.cabal2016-12-27 12:14:38.0 +0100
+++ new/gi-soup-2.4.12/gi-soup.cabal2017-04-27 19:36:20.0 +0200
@@ -1,5 +1,5 @@
 name: gi-soup
-version:  2.4.11
+version:  2.4.12
 synopsis: Libsoup bindings
 description:  Bindings for Libsoup, autogenerated by haskell-gi.
 homepage: https://github.com/haskell-gi/haskell-gi
@@ -11,12 +11,12 @@
 build-type:   Custom
 cabal-version:>= 1.24
 
-extra-source-files: README.md stack.yaml Soup.overrides
+extra-source-files: README.md ChangeLog.md stack.yaml Soup.overrides
 
 custom-setup
   setup-depends: base >= 4.7 && < 5,
  Cabal >= 1.24,
- haskell-gi >= 0.20 && < 1
+ haskell-gi >= 0.20.1 && < 1
 
 Flag overloaded-methods
   Description: Generate support for overloaded methods.
@@ -36,7 +36,7 @@
   pkgconfig-depends: libsoup-2.4
   build-depends: base >= 4.7 && <5,
  haskell-gi-base >= 0.20 && < 1,
- haskell-gi >= 0.20 && < 1,
+ haskell-gi >= 0.20.1 && < 1,
  gi-gio == 2.0.*,
  gi-gobject == 2.0.*,
  gi-glib == 2.0.*,




commit cpustat for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package cpustat for openSUSE:Factory checked 
in at 2017-05-18 20:50:19

Comparing /work/SRC/openSUSE:Factory/cpustat (Old)
 and  /work/SRC/openSUSE:Factory/.cpustat.new (New)


Package is "cpustat"

Thu May 18 20:50:19 2017 rev:2 rq:495696 version:0.02.03

Changes:

--- /work/SRC/openSUSE:Factory/cpustat/cpustat.changes  2016-09-21 
18:46:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.cpustat.new/cpustat.changes 2017-05-18 
20:50:23.937657928 +0200
@@ -1,0 +2,65 @@
+Wed May 10 14:45:20 UTC 2017 - mar...@gmx.de
+
+- update to version 0.02.03
+  * Makefile: bump version
+  * Manual: update copyright year and manual date
+  * Add variable pid size handling.
+  * Voidify close/fclose calls
+
+- update to version 0.02.02
+  * Makefile: bump version
+  * Remove some redundant pointer increments
+  * Update copyright year
+  * Add libncursesw5-dev to snapcraft yaml
+  * Don't do a resize() in SIGWINCH signal handler
+
+- update to version 0.02.01
+  * Makefile: bump version
+  * Remove df_putc, we don't use it now
+  * Minor cleanup, add more comments
+  * Remove another slow snprintf in cpu_freq_format
+  * Generalise putdouble_point1 to n decimal places, rename putdec to putint
+  * Remove another snprintf from proc_stat_dump
+  * Add command and spacing before Freq Avg text
+  * Remove another use of expensive sprintf
+  * Add putuint helper and remove another overly used snprintf
+  * Fix incorrect closing square bracket around kernel thread
+  * Remove another snprintf and replace with more optimal code
+  * Add some minor optimisations
+  * Optimise printing so we don't use printf which is expensive
+  * Add comments to putdec function
+  * Generalise putdec function to handle any decimal sized string
+  * Use inline popcount to count bits
+  * Ensure in top mode we don't fall off bottom of terminal
+
+- update to version 0.02.00
+  * Makefile: bump version to 0.02.00
+  * Debian control: add libncurses5-dev to Build-Depends
+  * Fix timestamp output
+  * Retry select sleep if we have some pending sleep time
+  * Minor reworking to handle optimal refreshing and size refetching
+  * Default winsize if we can't fetch it, and fetch size on setup
+  * Handle display modes using display_function_t handlers
+  * Add -X top like mode
+  * Ensure large integer constant is ULL
+
+- update to version 0.01.29
+  * Makefile: bump version
+  * Fix variable shadowing on variable duration
+  * Use FLOAT_CMP helper macro to perform slop on float compares
+  * Constify variables in sort compare helper
+  * Makefile: add PEDANTIC build flags
+
+- update to version 0.01.28
+  * Makefile: bump version
+  * Makefile: add mascot and snapcraft directories to make dist rule
+  * cpustat: only add pid info to hash table if it is new (LP: #1631050)
+  * snapcraft: Makefile: fix removal errors of snap files
+  * snapcraft: Makefile: add auto versioning
+  * snapcraft.yaml: add build-packages
+  * Add snapcraft Makefile
+  * Add cpustat pngs
+  * mascot: small resize to ensure it scales perfectly to 128x128
+  * Add cpustat mascot
+
+---

Old:

  cpustat-0.01.27.tar.gz

New:

  cpustat-0.02.03.tar.gz



Other differences:
--
++ cpustat.spec ++
--- /var/tmp/diff_new_pack.kUnQrR/_old  2017-05-18 20:50:24.649557460 +0200
+++ /var/tmp/diff_new_pack.kUnQrR/_new  2017-05-18 20:50:24.653556895 +0200
@@ -1,7 +1,8 @@
 #
 # spec file for package cpustat
 #
-# Copyright (c) 2016, Martin Hauke 
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,13 +18,14 @@
 
 
 Name:   cpustat
-Version:0.01.27
+Version:0.02.03
 Release:0
 Summary:Periodic cpu utilization statistics
 License:GPL-2.0+
 Group:  System/Monitoring
 Url:http://kernel.ubuntu.com/~cking/cpustat/
 Source: 
http://kernel.ubuntu.com/~cking/tarballs/%{name}/%{name}-%{version}.tar.gz
+BuildRequires:  ncurses-devel
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -48,6 +50,6 @@
 %defattr(-,root,root)
 %doc COPYING README
 %{_sbindir}/cpustat
-%{_mandir}/man8/*
+%{_mandir}/man8/cpustat.8%{ext_man}
 
 %changelog

++ cpustat-0.01.27.tar.gz -> cpustat-0.02.03.tar.gz ++
 5567 lines of diff (skipped)




commit pagemon for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package pagemon for openSUSE:Factory checked 
in at 2017-05-18 20:49:54

Comparing /work/SRC/openSUSE:Factory/pagemon (Old)
 and  /work/SRC/openSUSE:Factory/.pagemon.new (New)


Package is "pagemon"

Thu May 18 20:49:54 2017 rev:2 rq:495693 version:0.01.10

Changes:

--- /work/SRC/openSUSE:Factory/pagemon/pagemon.changes  2016-09-21 
18:46:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.pagemon.new/pagemon.changes 2017-05-18 
20:50:04.744366616 +0200
@@ -0,0 +1,15 @@
+
+---
+Wed May 10 14:59:53 UTC 2017 - mar...@gmx.de
+
+- update to version 0.01.10
+  * Makefile: bump version
+  * fix shadowing offset variable
+  * fix shadowing map variable
+  * Makefile: Add PEDANTIC gcc flags
+
+- update to version 0.01.09
+  * Makefile: bump version
+  * Debian/control: update Standards-Version to 3.9.8
+  * Remove redundant statement, found using scan-build
+

Old:

  pagemon-0.01.08.tar.gz

New:

  pagemon-0.01.10.tar.gz



Other differences:
--
++ pagemon.spec ++
--- /var/tmp/diff_new_pack.s0nosQ/_old  2017-05-18 20:50:06.692091740 +0200
+++ /var/tmp/diff_new_pack.s0nosQ/_new  2017-05-18 20:50:06.696091175 +0200
@@ -1,7 +1,8 @@
 #
 # spec file for package pagemon
 #
-# Copyright (c) 2016, Martin Hauke 
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +18,7 @@
 
 
 Name:   pagemon
-Version:0.01.08
+Version:0.01.10
 Release:0
 Summary:Interactive memory/page monitoring tool
 License:GPL-2.0+
@@ -46,6 +47,6 @@
 %defattr(-,root,root)
 %doc COPYING README
 %{_sbindir}/pagemon
-%{_mandir}/man8/*
+%{_mandir}/man8/pagemon.8%{ext_man}
 
 %changelog

++ pagemon-0.01.08.tar.gz -> pagemon-0.01.10.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pagemon-0.01.08/Makefile new/pagemon-0.01.10/Makefile
--- old/pagemon-0.01.08/Makefile2016-01-31 14:11:27.0 +0100
+++ new/pagemon-0.01.10/Makefile2016-11-02 20:36:14.0 +0100
@@ -18,11 +18,21 @@
 # Author: Colin Ian King 
 #
 
-VERSION=0.01.08
+VERSION=0.01.10
 
 CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2
 LDFLAGS += -lncurses
 
+
+# Pedantic flags
+#
+ifeq ($(PEDANTIC),1)
+CFLAGS += -Wabi -Wcast-qual -Wfloat-equal -Wmissing-declarations \
+   -Wmissing-format-attribute -Wno-long-long -Wpacked \
+   -Wredundant-decls -Wshadow -Wno-missing-field-initializers \
+   -Wno-missing-braces -Wno-sign-compare -Wno-multichar
+endif
+
 BINDIR=/usr/sbin
 MANDIR=/usr/share/man/man8
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pagemon-0.01.08/pagemon.c 
new/pagemon-0.01.10/pagemon.c
--- old/pagemon-0.01.08/pagemon.c   2016-01-31 14:11:27.0 +0100
+++ new/pagemon-0.01.10/pagemon.c   2016-11-02 20:36:14.0 +0100
@@ -734,7 +734,6 @@
index = page_index;
for (i = 1; i <= ymax; i++) {
int32_t j;
-   map_t *map;
addr_t addr, offset;
const size_t sz = sizeof(pagemap_info_buf);
 
@@ -768,11 +767,9 @@
attr = COLOR_PAIR(BLACK_BLACK);
state = '~';
} else {
-   off_t offset;
map_t *new_map;
register pagemap_t pagemap_info;
 
-   addr = g.mem_info.pages[index].addr;
new_map = g.mem_info.pages[index].map;
/*
 *  On a different mapping? If so, slurp up




commit sluice for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package sluice for openSUSE:Factory checked 
in at 2017-05-18 20:49:33

Comparing /work/SRC/openSUSE:Factory/sluice (Old)
 and  /work/SRC/openSUSE:Factory/.sluice.new (New)


Package is "sluice"

Thu May 18 20:49:33 2017 rev:2 rq:495691 version:0.02.06

Changes:

--- /work/SRC/openSUSE:Factory/sluice/sluice.changes2016-09-21 
18:46:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.sluice.new/sluice.changes   2017-05-18 
20:49:47.970733824 +0200
@@ -1,0 +2,15 @@
+Wed May 10 15:40:38 UTC 2017 - mar...@gmx.de
+
+- update to version 0.02.06
+  * Makefile: bump minor version
+  * Fix incorrect position of \ escape in -s option man page
+
+- update to version 0.02.05
+  * Add build hardening flags
+  * Makefile: bump version
+  * Use build-in popcount to count bits
+  * Allow float comparisons a little bit of slop
+  * Make get_pagesize helper static
+  * Makefile: add PEDANTIC flags
+
+---

Old:

  sluice-0.02.04.tar.gz

New:

  sluice-0.02.06.tar.gz



Other differences:
--
++ sluice.spec ++
--- /var/tmp/diff_new_pack.BKWn4F/_old  2017-05-18 20:49:49.610502409 +0200
+++ /var/tmp/diff_new_pack.BKWn4F/_new  2017-05-18 20:49:49.614501844 +0200
@@ -1,7 +1,8 @@
 #
 # spec file for package sluice
 #
-# Copyright (c) 2016, Martin Hauke 
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +18,7 @@
 
 
 Name:   sluice
-Version:0.02.04
+Version:0.02.06
 Release:0
 Summary:Rate limiting data piping tool
 License:GPL-2.0+
@@ -45,6 +46,6 @@
 %defattr(-,root,root)
 %doc COPYING
 %{_bindir}/sluice
-%{_mandir}/man1/*
+%{_mandir}/man1/sluice.1%{ext_man}
 
 %changelog

++ sluice-0.02.04.tar.gz -> sluice-0.02.06.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sluice-0.02.04/Makefile new/sluice-0.02.06/Makefile
--- old/sluice-0.02.04/Makefile 2016-05-05 14:44:33.0 +0200
+++ new/sluice-0.02.06/Makefile 2016-12-19 16:01:17.0 +0100
@@ -15,10 +15,20 @@
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, 
USA.
 #
-VERSION=0.02.04
+VERSION=0.02.06
 
 CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2
 
+#
+# Pedantic flags
+#
+ifeq ($(PEDANTIC),1)
+CFLAGS += -Wabi -Wcast-qual -Wfloat-equal -Wmissing-declarations \
+   -Wmissing-format-attribute -Wno-long-long -Wpacked \
+   -Wredundant-decls -Wshadow -Wno-missing-field-initializers \
+   -Wno-missing-braces -Wno-sign-compare -Wno-multichar
+endif
+
 BINDIR=/usr/bin
 MANDIR=/usr/share/man/man1
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sluice-0.02.04/sluice.1 new/sluice-0.02.06/sluice.1
--- old/sluice-0.02.04/sluice.1 2016-05-05 14:44:33.0 +0200
+++ new/sluice-0.02.06/sluice.1 2016-12-19 16:01:17.0 +0100
@@ -115,7 +115,7 @@
 do not read from stdin, instead read random data from /dev/urandom.
 .TP
 .B \-s shift
-modify the rate adjustment shift. This is a data rate tuning scaling factor 
used by the \-r, \-c, \-o and -\u options.
+modify the rate adjustment shift. This is a data rate tuning scaling factor 
used by the \-r, \-c, \-o and \-u options.
 .br
 
 For the \-r option, the delay between each write is controlled by modifying 
the previous delay by adding or subtracting the previous delay right shifted by 
this shift value.  The larger the shift value the longer it takes to adjust 
up/down to the specified rate.  The smaller the shift value the quicker it 
takes to reach the optimal delay, however, this can result in a highly 
fluctuating rates at the the beginning because the delay varies by a large 
amount causing large overruns and underruns.  A shift value of 3 works well for 
most fast rates.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sluice-0.02.04/sluice.c new/sluice-0.02.06/sluice.c
--- old/sluice-0.02.04/sluice.c 2016-05-05 14:44:33.0 +0200
+++ new/sluice-0.02.06/sluice.c 2016-12-19 16:01:17.0 +0100
@@ -126,6 +126,9 @@
 #define DELAY_SET_ACTION(a1, a2, a3)   ((a1 << 0) | (a2 << 1) | (a3 << 2))
 #define DELAY_GET_ACTION(n, action)((1 << n) & action)
 
+#define FLOAT_TINY (0.001)
+#define FLOAT_CMP(a, b)(fabs((a) - (b)) < FLOAT_TINY)
+
 typedef struct {
double  

commit dnstracer for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package dnstracer for openSUSE:Factory 
checked in at 2017-05-18 20:49:21

Comparing /work/SRC/openSUSE:Factory/dnstracer (Old)
 and  /work/SRC/openSUSE:Factory/.dnstracer.new (New)


Package is "dnstracer"

Thu May 18 20:49:21 2017 rev:1 rq:495686 version:1.9

Changes:

New Changes file:

--- /dev/null   2017-03-01 00:40:19.279048016 +0100
+++ /work/SRC/openSUSE:Factory/.dnstracer.new/dnstracer.changes 2017-05-18 
20:49:27.929562167 +0200
@@ -0,0 +1,21 @@
+---
+Mon May 15 18:53:20 UTC 2017 - mar...@gmx.de
+
+- Fix License
+- Run spec-cleaner
+
+---
+Wed Sep 12 14:41:38 UTC 2012 - prus...@opensuse.org
+
+- spec cleanup
+
+---
+Wed Jan 14 00:00:00 UTC 2009 - l...@unstable.be
+
+- Update to release
+
+---
+Mon Sep 10 00:00:00 UTC 2007 - l...@unstable.be
+
+- Initial package.
+

New:

  dnstracer-1.9.tar.gz
  dnstracer.changes
  dnstracer.spec



Other differences:
--
++ dnstracer.spec ++
#
# spec file for package dnstracer
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:   dnstracer
Version:1.9
Release:0
Summary:Trace a DNS record to its start of authority
License:BSD-2-Clause
Group:  Productivity/Networking/DNS/Utilities
Url:http://www.mavetju.org/unix/dnstracer.php
Source: http://www.mavetju.org/download/%{name}-%{version}.tar.gz
BuildRoot:  %{_tmppath}/%{name}-%{version}-build

%description
Dnstracer determines where a given Domain Name Server (DNS) gets its
information from, and follows the chain of DNS servers back to the
servers which know the data.

%prep
%setup -q

%build
%configure
make %{?_smp_mflags}

%install
%make_install

%files
%defattr(-,root,root)
%doc CHANGES CONTACT LICENSE README
%{_bindir}/%{name}
%{_mandir}/man8/%{name}.8%{ext_man}

%changelog



commit certbot for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package certbot for openSUSE:Factory checked 
in at 2017-05-18 20:49:03

Comparing /work/SRC/openSUSE:Factory/certbot (Old)
 and  /work/SRC/openSUSE:Factory/.certbot.new (New)


Package is "certbot"

Thu May 18 20:49:03 2017 rev:6 rq:495675 version:0.14.1

Changes:

--- /work/SRC/openSUSE:Factory/certbot/certbot.changes  2017-05-17 
17:19:31.787127882 +0200
+++ /work/SRC/openSUSE:Factory/.certbot.new/certbot.changes 2017-05-18 
20:49:13.831551770 +0200
@@ -1,0 +2,6 @@
+Wed May 17 16:19:32 UTC 2017 - ec...@opensuse.org
+
+- update to 0.14.1
+  See https://github.com/certbot/certbot/milestone/39?closed=1
+
+---
@@ -4 +10 @@
-- - fix build error in Tumbleweed
+- fix build error in Tumbleweed

Old:

  v0.14.0.tar.gz

New:

  v0.14.1.tar.gz



Other differences:
--
++ certbot.spec ++
--- /var/tmp/diff_new_pack.QTV0HV/_old  2017-05-18 20:49:17.647013308 +0200
+++ /var/tmp/diff_new_pack.QTV0HV/_new  2017-05-18 20:49:17.651012743 +0200
@@ -19,7 +19,7 @@
 # See also http://en.opensuse.org/openSUSE:Specfile_guidelines
 
 Name:   certbot
-Version:0.14.0
+Version:0.14.1
 Release:0
 Summary:Let's Encrypt
 License:Apache-2.0

++ v0.14.0.tar.gz -> v0.14.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-0.14.0/acme/setup.py 
new/certbot-0.14.1/acme/setup.py
--- old/certbot-0.14.0/acme/setup.py2017-05-05 01:52:13.0 +0200
+++ new/certbot-0.14.1/acme/setup.py2017-05-16 19:03:51.0 +0200
@@ -4,7 +4,7 @@
 from setuptools import find_packages
 
 
-version = '0.14.0'
+version = '0.14.1'
 
 # Please update tox.ini when modifying dependency version requirements
 install_requires = [
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-0.14.0/certbot/__init__.py 
new/certbot-0.14.1/certbot/__init__.py
--- old/certbot-0.14.0/certbot/__init__.py  2017-05-05 01:52:13.0 
+0200
+++ new/certbot-0.14.1/certbot/__init__.py  2017-05-16 19:03:51.0 
+0200
@@ -1,4 +1,4 @@
 """Certbot client."""
 
 # version number like 1.2.3a0, must have at least 2 parts, like 1.2
-__version__ = '0.14.0'
+__version__ = '0.14.1'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-0.14.0/certbot/tests/util_test.py 
new/certbot-0.14.1/certbot/tests/util_test.py
--- old/certbot-0.14.0/certbot/tests/util_test.py   2017-05-05 
01:52:13.0 +0200
+++ new/certbot-0.14.1/certbot/tests/util_test.py   2017-05-16 
19:03:51.0 +0200
@@ -368,6 +368,29 @@
 pass
 self.assertTrue("--old-option" not in stdout.getvalue())
 
+def test_set_constant(self):
+"""Test when ACTION_TYPES_THAT_DONT_NEED_A_VALUE is a set.
+
+This variable is a set in configargparse versions < 0.12.0.
+
+"""
+self._test_constant_common(set)
+
+def test_tuple_constant(self):
+"""Test when ACTION_TYPES_THAT_DONT_NEED_A_VALUE is a tuple.
+
+This variable is a tuple in configargparse versions >= 0.12.0.
+
+"""
+self._test_constant_common(tuple)
+
+def _test_constant_common(self, typ):
+with mock.patch("certbot.util.configargparse") as mock_configargparse:
+mock_configargparse.ACTION_TYPES_THAT_DONT_NEED_A_VALUE = typ()
+self._call("--old-option", 1)
+self.assertEqual(
+len(mock_configargparse.ACTION_TYPES_THAT_DONT_NEED_A_VALUE), 1)
+
 
 class EnforceLeValidity(unittest.TestCase):
 """Test enforce_le_validity."""
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-0.14.0/certbot/util.py 
new/certbot-0.14.1/certbot/util.py
--- old/certbot-0.14.0/certbot/util.py  2017-05-05 01:52:13.0 +0200
+++ new/certbot-0.14.1/certbot/util.py  2017-05-16 19:03:51.0 +0200
@@ -476,7 +476,13 @@
 sys.stderr.write(
 "Use of {0} is deprecated.\n".format(option_string))
 
-configargparse.ACTION_TYPES_THAT_DONT_NEED_A_VALUE.add(ShowWarning)
+# In version 0.12.0 ACTION_TYPES_THAT_DONT_NEED_A_VALUE was changed from a
+# set to a tuple.
+if isinstance(configargparse.ACTION_TYPES_THAT_DONT_NEED_A_VALUE, set):
+# pylint: disable=no-member
+configargparse.ACTION_TYPES_THAT_DONT_NEED_A_VALUE.add(ShowWarning)
+else:
+configargparse.ACTION_TYPES_THAT_DONT_NEED_A_VALUE += (ShowWarning,)
 add_argument(argument_name, action=ShowWarning,
  help=argparse.SUPPRESS, nargs=nargs)
 
diff 

commit python-acme for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package python-acme for openSUSE:Factory 
checked in at 2017-05-18 20:48:45

Comparing /work/SRC/openSUSE:Factory/python-acme (Old)
 and  /work/SRC/openSUSE:Factory/.python-acme.new (New)


Package is "python-acme"

Thu May 18 20:48:45 2017 rev:6 rq:495673 version:0.14.1

Changes:

--- /work/SRC/openSUSE:Factory/python-acme/python-acme.changes  2017-05-17 
17:19:30.751273964 +0200
+++ /work/SRC/openSUSE:Factory/.python-acme.new/python-acme.changes 
2017-05-18 20:48:59.209615312 +0200
@@ -1,0 +2,6 @@
+Wed May 17 16:17:36 UTC 2017 - ec...@opensuse.org
+
+- update to 0.14.1
+  - No changelog from upstream
+
+---

Old:

  acme-0.14.0.tar.gz
  acme-0.14.0.tar.gz.asc

New:

  acme-0.14.1.tar.gz
  acme-0.14.1.tar.gz.asc



Other differences:
--
++ python-acme.spec ++
--- /var/tmp/diff_new_pack.cncSB0/_old  2017-05-18 20:49:02.969084752 +0200
+++ /var/tmp/diff_new_pack.cncSB0/_new  2017-05-18 20:49:02.969084752 +0200
@@ -18,7 +18,7 @@
 
 %define libname acme
 Name:   python-%{libname}
-Version:0.14.0
+Version:0.14.1
 Release:0
 Summary:Python library for the ACME protocol
 License:Apache-2.0

++ acme-0.14.0.tar.gz -> acme-0.14.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/acme-0.14.0/PKG-INFO new/acme-0.14.1/PKG-INFO
--- old/acme-0.14.0/PKG-INFO2017-05-05 01:45:31.0 +0200
+++ new/acme-0.14.1/PKG-INFO2017-05-16 18:53:09.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: acme
-Version: 0.14.0
+Version: 0.14.1
 Summary: ACME protocol implementation in Python
 Home-page: https://github.com/letsencrypt/letsencrypt
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/acme-0.14.0/acme.egg-info/PKG-INFO 
new/acme-0.14.1/acme.egg-info/PKG-INFO
--- old/acme-0.14.0/acme.egg-info/PKG-INFO  2017-05-05 01:45:31.0 
+0200
+++ new/acme-0.14.1/acme.egg-info/PKG-INFO  2017-05-16 18:53:09.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: acme
-Version: 0.14.0
+Version: 0.14.1
 Summary: ACME protocol implementation in Python
 Home-page: https://github.com/letsencrypt/letsencrypt
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/acme-0.14.0/setup.py new/acme-0.14.1/setup.py
--- old/acme-0.14.0/setup.py2017-05-05 01:45:16.0 +0200
+++ new/acme-0.14.1/setup.py2017-05-16 18:52:51.0 +0200
@@ -4,7 +4,7 @@
 from setuptools import find_packages
 
 
-version = '0.14.0'
+version = '0.14.1'
 
 # Please update tox.ini when modifying dependency version requirements
 install_requires = [





commit znc for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package znc for openSUSE:Factory checked in 
at 2017-05-18 20:48:26

Comparing /work/SRC/openSUSE:Factory/znc (Old)
 and  /work/SRC/openSUSE:Factory/.znc.new (New)


Package is "znc"

Thu May 18 20:48:26 2017 rev:11 rq:495616 version:1.6.5

Changes:

--- /work/SRC/openSUSE:Factory/znc/znc.changes  2017-03-16 09:52:11.148262205 
+0100
+++ /work/SRC/openSUSE:Factory/.znc.new/znc.changes 2017-05-18 
20:48:34.881048714 +0200
@@ -1,0 +2,5 @@
+Wed May 10 12:27:49 UTC 2017 - mplus...@suse.com
+
+- Update project url
+
+---



Other differences:
--
++ znc.spec ++
--- /var/tmp/diff_new_pack.wHASjf/_old  2017-05-18 20:48:35.540955584 +0200
+++ /var/tmp/diff_new_pack.wHASjf/_new  2017-05-18 20:48:35.544955020 +0200
@@ -22,7 +22,7 @@
 Summary:Advanced IRC Bouncer
 License:Apache-2.0
 Group:  Productivity/Networking/IRC
-Url:http://en.znc.in/
+Url:http://wiki.znc.in/ZNC
 Source0:http://znc.in/releases/%{name}-%{version}.tar.gz
 Source1:http://znc.in/releases/%{name}-%{version}.tar.gz.sig
 Source2:%{name}.keyring






commit opa-fmgui for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package opa-fmgui for openSUSE:Factory 
checked in at 2017-05-18 20:48:21

Comparing /work/SRC/openSUSE:Factory/opa-fmgui (Old)
 and  /work/SRC/openSUSE:Factory/.opa-fmgui.new (New)


Package is "opa-fmgui"

Thu May 18 20:48:21 2017 rev:1 rq:495570 version:10.1.0.0

Changes:

New Changes file:

--- /dev/null   2017-03-01 00:40:19.279048016 +0100
+++ /work/SRC/openSUSE:Factory/.opa-fmgui.new/opa-fmgui.changes 2017-05-18 
20:48:28.993879549 +0200
@@ -0,0 +1,85 @@
+---
+Wed May 17 09:28:18 UTC 2017 - nmoreychaisemar...@suse.com
+
+- Add BuildRequires to hicolor-icon-theme in order to enable
+ %icon_theme_cache_post/postun macros
+
+---
+Wed Apr  5 08:46:46 UTC 2017 - josef.moell...@suse.com
+
+- Upgrade to Version 10.1.0.0
+  This obsoletes Patches
+  2:opa-fmgui-desktopfile-without-binary.patch
+  and
+  4:opa-fmgui-fix-detection-of-OpenJDK.patch
+  Added pre-built gradle-2.9 for build phase.
+  Replaced wrong Sun licence by GPLv2-CE as given on
+  https://javahelp.java.net/license.txt
+  [FATE#321477, bsc#989769]
+
+---
+Tue Oct  4 18:35:02 CEST 2016 - n...@suse.de
+
+- Applied patch from Intel to search for 'version' instead of 'java version'
+  so the openJDK can be detected at runtime(bsc#989769).
+  [+ opa-fmgui-fix-detection-of-OpenJDK.patch]
+
+---
+Wed Jul 27 12:39:49 CEST 2016 - n...@suse.de
+
+- Applied patch from Intel and modified the spec file as required(bsc#989769).
+  [+opa-fmgui-intel-manifest-license.patch]
+
+* opa-fmgui/opa-fmgui.spec
+--
+  - Updated Version/Release numbers to match opa-fmgui
+  - Changed app folder and name to match installed application name "opa-fmgui"
+  - Removed references to /usr/local/bin; only using /usr/bin
+  - Installed jar files in lib/ folder with correct permissions for all users, 
not just root
+  - Added reference to patch file to make corrections
+
+* opa-fmgui/install/fmgui.sh
+
+  - Updated to reference the new folder /usr/share/java/opa-fmgui where the 
fmgui.jar is stored
+
+* opa-fmgui/src/META-INF/MANIFEST.MF
+
+  - Updated to correct reference to Gritty library (gritty.jar not 
gritty-0.02.jar)
+
+* opa-fmgui/util/postsetup.sh
+-
+  - Fabric.directory was copied from /usr/local/share/desktop-directories, 
which doesn't exist. Now copying from /usr/share/desktop-directories
+
+* License Files
+---
+- Added all 3rd party license files since their jar files are being 
packaged as required by Intel Legal
+gritty_license.txt
+hibernate_license.txt
+hsqldb_license.txt
+javahelp_license.html
+javamail_license.txt
+jfreechart_license.txt
+jgraphx_license.txt
+jsch_license.txt
+logback_license.txt
+mbassador_license.txt
+slf4j_license.txt
+swingx_license.txt
+
+---
+Thu Jul 21 13:50:53 CEST 2016 - n...@suse.de
+
+- Corrected the version in spec file(bsc#989769).
+
+---
+Wed Jun  1 15:42:13 CEST 2016 - n...@suse.de
+
+- Added mlocate and jre as depended package(bsc#982579).
+- Fixed desktopfile-without-binary rpm warning.
+  [+opa-fmgui-desktopfile-without-binary.patch]
+
+---
+Tue Apr 12 15:17:02 UTC 2016 - nirmoy@suse.com
+
+- Initial package version 10_0_0_0_2) for fate#319231
+

New:

  antlr-2.7.7.jar
  dom4j-1.6.1.jar
  gradle-2.9-bin.zip
  gradle-use_local_repo.patch
  hibernate-commons-annotations-4.0.4.Final.jar
  hibernate-core-4.3.5.Final.jar
  hibernate-entitymanager-4.3.5.Final.jar
  hibernate-jpa-2.1-api-1.0.0.Final.jar
  hsqldb-2.3.2.jar
  jandex-1.1.0.Final.jar
  javahelp-2.0.05.jar
  javassist-3.18.1-GA.jar
  javax.mail-1.5.2.jar
  jboss-logging-3.1.3.GA.jar
  jboss-logging-annotations-1.2.0.Beta1.jar
  jboss-transaction-api_1.2_spec-1.0.0.Final.jar
  jcommon-1.0.21.jar
  jfreechart-1.0.17.jar
  jgraphx-3.6.0.0.jar
  jsch-0.1.53.jar
  log4j-1.2.14.jar
  log4j-over-slf4j-1.7.7.jar
  logback-classic-1.1.2.jar
  logback-core-1.1.2.jar
  mbassador-1.2.4.2.jar
  opa-fmgui-intel-manifest-license.patch
  opa-fmgui.changes
  opa-fmgui.spec
  opa-fmgui.tar.gz
  slf4j-api-1.7.7.jar
  stl-14927-jgraphx-update.patch
  swingx-action-1.6.5.jar
  swingx-all-1.6.5.jar
  swingx-autocomplete-1.6.5.jar
  swingx-beaninfo-1.6.5.jar
  swingx-common-1.6.5.jar
  swingx-core-1.6.5.jar
  swingx-graphics-1.6.5.jar
  

commit python-nose-cover3 for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package python-nose-cover3 for 
openSUSE:Factory checked in at 2017-05-18 20:48:36

Comparing /work/SRC/openSUSE:Factory/python-nose-cover3 (Old)
 and  /work/SRC/openSUSE:Factory/.python-nose-cover3.new (New)


Package is "python-nose-cover3"

Thu May 18 20:48:36 2017 rev:9 rq:495653 version:0.1.0

Changes:

--- /work/SRC/openSUSE:Factory/python-nose-cover3/python-nose-cover3.changes
2013-10-25 11:24:02.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-nose-cover3.new/python-nose-cover3.changes   
2017-05-18 20:48:39.468401318 +0200
@@ -1,0 +2,6 @@
+Thu May 11 01:24:08 UTC 2017 - toddrme2...@gmail.com
+
+- Implement single-spec version.
+- Fix source URL.
+
+---



Other differences:
--
++ python-nose-cover3.spec ++
--- /var/tmp/diff_new_pack.Wa6jyA/_old  2017-05-18 20:48:39.968330765 +0200
+++ /var/tmp/diff_new_pack.Wa6jyA/_new  2017-05-18 20:48:39.972330201 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-nose-cover3
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,6 +16,7 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-nose-cover3
 Version:0.1.0
 Release:0
@@ -23,17 +24,17 @@
 Summary:Coverage 3.x support for Nose
 License:LGPL-2.1+
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/n/nose-cover3/nose-cover3-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/n/nose-cover3/nose-cover3-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
+BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
+BuildRequires:  python3-2to3
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
 Requires:   python-coverage
 Requires:   python-nose
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
 BuildArch:  noarch
-%endif
+%python_subpackages
 
 %description
 Coverage 3.x support for Nose.
@@ -42,12 +43,13 @@
 %setup -q -n nose-cover3-%{version}
 
 %build
-CFLAGS="%{optflags}" python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
+%python_expand %fdupes %{buildroot}%{$python_sitelib}
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc README lgpl.txt
 %{python_sitelib}/*




commit python-boto3 for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package python-boto3 for openSUSE:Factory 
checked in at 2017-05-18 20:48:30

Comparing /work/SRC/openSUSE:Factory/python-boto3 (Old)
 and  /work/SRC/openSUSE:Factory/.python-boto3.new (New)


Package is "python-boto3"

Thu May 18 20:48:30 2017 rev:6 rq:495651 version:1.4.4

Changes:

--- /work/SRC/openSUSE:Factory/python-boto3/python-boto3.changes
2017-01-25 23:26:09.633219505 +0100
+++ /work/SRC/openSUSE:Factory/.python-boto3.new/python-boto3.changes   
2017-05-18 20:48:38.764500657 +0200
@@ -1,0 +2,9 @@
+Thu May 11 01:10:44 UTC 2017 - toddrme2...@gmail.com
+
+- Implement single-spec version
+- Update source URL.
+- Update to version 1.4.3
+  * feature:``s3``: Add ability to disable thread use with ``use_threads`` 
option
+  * bugfix:Resource: Fix resource hashing.
+
+---

Old:

  boto3-1.4.2.tar.gz

New:

  boto3-1.4.4.tar.gz



Other differences:
--
++ python-boto3.spec ++
--- /var/tmp/diff_new_pack.QlgVkM/_old  2017-05-18 20:48:39.208438006 +0200
+++ /var/tmp/diff_new_pack.QlgVkM/_new  2017-05-18 20:48:39.212437441 +0200
@@ -16,31 +16,30 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-boto3
-Version:1.4.2
+Version:1.4.4
 Release:0
 Url:https://github.com/boto/boto3
 Summary:Amazon Web Services Library
 License:Apache-2.0
 Group:  Development/Languages/Python
-Source: https://pypi.io/packages/source/b/boto3/boto3-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/b/boto3/boto3-%{version}.tar.gz
 BuildRequires:  fdupes
-BuildRequires:  python-devel
-BuildRequires:  python-futures
-BuildRequires:  python-setuptools
-Requires:   python-botocore < 1.5.0
-Requires:   python-botocore >= 1.4.67
+BuildRequires:  python-rpm-macros
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  %{python_module futures}
+Requires:   python-botocore < 1.6.0
+Requires:   python-botocore >= 1.5.0
 Requires:   python-futures
 Requires:   python-jmespath < 1.0.0
 Requires:   python-jmespath >= 0.7.1
 Requires:   python-s3transfer < 0.2.0
-Requires:   python-s3transfer >= 0.1.0
+Requires:   python-s3transfer >= 0.1.10
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
 BuildArch:  noarch
-%endif
+%python_subpackages
 
 %description
 Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK) for
@@ -58,13 +57,13 @@
 %setup -q -n boto3-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
-%fdupes %{buildroot}%{_prefix}
+%python_install
+%python_expand %fdupes %{buildroot}%{$python_sitelib}
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc CONTRIBUTING.rst LICENSE README.rst 
 %{python_sitelib}/*

++ boto3-1.4.2.tar.gz -> boto3-1.4.4.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/boto3-1.4.2/LICENSE new/boto3-1.4.4/LICENSE
--- old/boto3-1.4.2/LICENSE 2016-12-01 22:32:13.0 +0100
+++ new/boto3-1.4.4/LICENSE 2017-01-16 23:44:08.0 +0100
@@ -1,4 +1,4 @@
-Copyright 2013-2016 Amazon.com, Inc. or its affiliates. All Rights Reserved.
+Copyright 2013-2017 Amazon.com, Inc. or its affiliates. All Rights Reserved.
 
 Licensed under the Apache License, Version 2.0 (the "License"). You
 may not use this file except in compliance with the License. A copy of
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/boto3-1.4.2/PKG-INFO new/boto3-1.4.4/PKG-INFO
--- old/boto3-1.4.2/PKG-INFO2016-12-01 22:32:14.0 +0100
+++ new/boto3-1.4.4/PKG-INFO2017-01-16 23:44:08.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: boto3
-Version: 1.4.2
+Version: 1.4.4
 Summary: The AWS SDK for Python
 Home-page: https://github.com/boto/boto3
 Author: Amazon Web Services
@@ -133,3 +133,4 @@
 Classifier: Programming Language :: Python :: 3.3
 Classifier: Programming Language :: Python :: 3.4
 Classifier: Programming Language :: Python :: 3.5
+Classifier: Programming Language :: Python :: 3.6
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/boto3-1.4.2/boto3/__init__.py 
new/boto3-1.4.4/boto3/__init__.py
--- old/boto3-1.4.2/boto3/__init__.py   2016-12-01 

commit xfce4-session for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package xfce4-session for openSUSE:Factory 
checked in at 2017-05-18 20:48:39

Comparing /work/SRC/openSUSE:Factory/xfce4-session (Old)
 and  /work/SRC/openSUSE:Factory/.xfce4-session.new (New)


Package is "xfce4-session"

Thu May 18 20:48:39 2017 rev:74 rq:495664 version:4.12.1

Changes:

--- /work/SRC/openSUSE:Factory/xfce4-session/xfce4-session.changes  
2016-09-24 15:29:15.0 +0200
+++ /work/SRC/openSUSE:Factory/.xfce4-session.new/xfce4-session.changes 
2017-05-18 20:48:40.156304237 +0200
@@ -1,0 +2,5 @@
+Wed May 17 14:19:47 UTC 2017 - fv...@suse.com
+
+- Use update-alternatives to create default.desktop xsession (boo#1030873)
+
+---



Other differences:
--
++ xfce4-session.spec ++
--- /var/tmp/diff_new_pack.oqdNf2/_old  2017-05-18 20:48:40.844207156 +0200
+++ /var/tmp/diff_new_pack.oqdNf2/_new  2017-05-18 20:48:40.848206591 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package xfce4-session
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -55,6 +55,8 @@
 Requires:   xfconf
 # bnc#845264
 Requires:   iceauth
+Requires(post): update-alternatives
+Requires(postun): update-alternatives
 Recommends: %{name}-doc = %{version}
 Recommends: %{name}-lang = %{version}
 # minimal packages for an Xfce session
@@ -139,6 +141,10 @@
 rm %{buildroot}%{_datadir}/polkit-1/actions/org.xfce.session.policy \
 %{buildroot}%{_libdir}/xfce4/session/xfsm-shutdown-helper
 
+mkdir -p %{buildroot}%{_sysconfdir}/alternatives
+touch %{buildroot}%{_sysconfdir}/alternatives/default-xsession.desktop
+ln -s %{_sysconfdir}/alternatives/default-xsession.desktop 
%{buildroot}%{_datadir}/xsessions/default.desktop
+
 %post -n %{libname} -p /sbin/ldconfig
 
 %postun -n %{libname} -p /sbin/ldconfig
@@ -146,10 +152,14 @@
 %post
 %desktop_database_post
 %icon_theme_cache_post
+%{_sbindir}/update-alternatives --install 
%{_datadir}/xsessions/default.desktop \
+  default-xsession.desktop %{_datadir}/xsessions/xfce.desktop 20
 
 %postun
 %desktop_database_postun
 %icon_theme_cache_postun
+[ -f %{_datadir}/xsessions/xfce.desktop ] || %{_sbindir}/update-alternatives \
+  --remove default-xsession.desktop %{_datadir}/xsessions/xfce.desktop
 
 %files
 %defattr(-,root,root)
@@ -166,6 +176,8 @@
 %{_libdir}/xfce4
 %{_datadir}/xfce
 %{_datadir}/xsessions/xfce.desktop
+%ghost %{_datadir}/xsessions/default.desktop
+%ghost %{_sysconfdir}/alternatives/default-xsession.desktop
 %{_datadir}/themes/*
 %{_datadir}/applications/*.desktop
 %{_datadir}/icons/*/*/*




commit cfengine for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package cfengine for openSUSE:Factory 
checked in at 2017-05-18 20:48:28

Comparing /work/SRC/openSUSE:Factory/cfengine (Old)
 and  /work/SRC/openSUSE:Factory/.cfengine.new (New)


Package is "cfengine"

Thu May 18 20:48:28 2017 rev:67 rq:495617 version:3.10.0

Changes:

--- /work/SRC/openSUSE:Factory/cfengine/cfengine.changes2017-02-07 
12:02:54.414379971 +0100
+++ /work/SRC/openSUSE:Factory/.cfengine.new/cfengine.changes   2017-05-18 
20:48:36.432829717 +0200
@@ -1,0 +2,24 @@
+Fri Mar 31 06:06:41 UTC 2017 - kkae...@suse.com
+
+- Update to 3.10.1
+  New features/additions:
+  - "make tar-package" should create a tarball with the contents of
+"make install" (ENT-3041)
+  
+  Bugfixes:
+  - Fix rare output truncation on Solaris 10/11 (CFE-2527)
+  - Change: Don't error during dry run for proposed execution.
+(CFE-2561)
+  - prevent LMDB assertion on AIX by ensuring nested DB calls are
+not occuring during signal handler cleanup (CFE-1996)
+  - Detect Amazon Linux and set "AmazonLinux" hard class and
+sys.flavour variable.
+  - Fix "lastseenexpireafter" 32-bit signed int overflow.
+  - Add missing pcre build flags to cf-key (CFE-2525)
+  - Fix a bug which could cause cf-execd to believe there was
+an error when sending the email report, when there really wasn't.
+  - cf-serverd: Auto configure max open files ulimit according to
+maxconnections (CFE-2575)
+  - Added vars and classes for CoreOS (ENT-3043)
+
+---

Old:

  cfengine-3.10.0.tar.gz

New:

  cfengine-3.10.1.tar.gz



Other differences:
--
++ cfengine.spec ++
--- /var/tmp/diff_new_pack.yb8KSl/_old  2017-05-18 20:48:37.412691433 +0200
+++ /var/tmp/diff_new_pack.yb8KSl/_new  2017-05-18 20:48:37.416690869 +0200
@@ -16,7 +16,7 @@
 #
 
 
-%define srcversion 3.10.0
+%define srcversion 3.10.1
 %define srcname %{name}-%{srcversion}
 %define libname   libpromises
 %define libsoname %{libname}3
@@ -71,6 +71,7 @@
 
 BuildRequires:  bison
 BuildRequires:  db-devel
+BuildRequires:  fakeroot
 BuildRequires:  flex
 BuildRequires:  libacl-devel
 BuildRequires:  libtool
@@ -79,10 +80,8 @@
 BuildRequires:  openssl-devel >= 1.0.2e
 BuildRequires:  pam-devel
 BuildRequires:  pcre-devel >= 8.38
-%if 0%{?suse_version} == 0
-# for testing on RHEL/Fedora
-BuildRequires:  fakeroot
-%endif
+# for flock
+BuildRequires:  util-linux
 Requires:   %{libsoname} = %{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if %{have_systemd}
@@ -243,7 +242,7 @@
 
 %if %{have_systemd}
 # systemd: install sample cron file in docdir
-install -D -m0644 %{SOURCE10} %{buildroot}/%{_docdir}/%{name}
+cp %{SOURCE10} %{buildroot}/%{_docdir}/%{name}
 %else
 # no systemd -> use cron
 # install cron file

++ cfengine-3.10.0.tar.gz -> cfengine-3.10.1.tar.gz ++
 4831 lines of diff (skipped)




commit python-guessit for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package python-guessit for openSUSE:Factory 
checked in at 2017-05-18 20:48:07

Comparing /work/SRC/openSUSE:Factory/python-guessit (Old)
 and  /work/SRC/openSUSE:Factory/.python-guessit.new (New)


Package is "python-guessit"

Thu May 18 20:48:07 2017 rev:2 rq:494914 version:2.1.1

Changes:

--- /work/SRC/openSUSE:Factory/python-guessit/python-guessit.changes
2017-04-29 10:52:33.188459616 +0200
+++ /work/SRC/openSUSE:Factory/.python-guessit.new/python-guessit.changes   
2017-05-18 20:48:10.312515979 +0200
@@ -1,0 +2,5 @@
+Tue Apr 11 09:38:47 UTC 2017 - jeng...@inai.de
+
+- spellcasing fixes to the description; removal of extreme words.
+
+---



Other differences:
--
++ python-guessit.spec ++
--- /var/tmp/diff_new_pack.wjrGjP/_old  2017-05-18 20:48:10.896433573 +0200
+++ /var/tmp/diff_new_pack.wjrGjP/_new  2017-05-18 20:48:10.900433008 +0200
@@ -45,11 +45,11 @@
 %python_subpackages
 
 %description
-GuessIt is a python library that extracts as much information as
+GuessIt is a Python library that extracts as much information as
 possible from a video file.
-It has a very powerful filename matcher that allows to guess a lot of
-metadata from a video using its filename only. This matcher works with
-both movies and tv shows episodes.
+It has a filename matcher that allows to guess a lot of metadata from
+a video using its filename only. This matcher works with both movies
+and TV shows episodes.
 
 %prep
 %setup -q -n guessit-%{version}




commit zynaddsubfx for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package zynaddsubfx for openSUSE:Factory 
checked in at 2017-05-18 20:48:00

Comparing /work/SRC/openSUSE:Factory/zynaddsubfx (Old)
 and  /work/SRC/openSUSE:Factory/.zynaddsubfx.new (New)


Package is "zynaddsubfx"

Thu May 18 20:48:00 2017 rev:7 rq:494362 version:3.0.1

Changes:

--- /work/SRC/openSUSE:Factory/zynaddsubfx/zynaddsubfx.changes  2017-04-20 
20:57:12.902808260 +0200
+++ /work/SRC/openSUSE:Factory/.zynaddsubfx.new/zynaddsubfx.changes 
2017-05-18 20:48:02.729586128 +0200
@@ -1,0 +2,6 @@
+Wed May 10 15:14:34 UTC 2017 - davejpla...@gmail.com
+
+- Enable reproducible builds with zynaddsubfx-DPF.patch which fixes
+  the generation of random output port values for lv2 plugins.
+
+---

New:

  zynaddsubfx-DPF.patch



Other differences:
--
++ zynaddsubfx.spec ++
--- /var/tmp/diff_new_pack.ShO3sY/_old  2017-05-18 20:48:04.109391402 +0200
+++ /var/tmp/diff_new_pack.ShO3sY/_new  2017-05-18 20:48:04.109391402 +0200
@@ -49,6 +49,8 @@
 Source0:
https://sourceforge.net/projects/zynaddsubfx/files/zynaddsubfx/3.0.1/%{name}-%{version}.tar.bz2
 Patch0: zynaddsubfx-buildflags.patch
 Patch1: zynaddsubfx-nodatetime.patch
+# PATCH-FIX-UPSTREAM zynaddsubfx-DPF.patch davejpla...@gmail.com -- patch DPF 
(issue#18) to latest git which fixes random lv2 output port values.
+Patch2: zynaddsubfx-DPF.patch
 Provides:   ZynAddSubFX = %{version}
 Obsoletes:  ZynAddSubFX < %{version}
 
@@ -123,10 +125,12 @@
 %setup -q
 %patch0 -p0
 %patch1 -p0
+%patch2 -p0
 
 %build
 %cmake \
   -DDefaultOutput=jack \
+  -DNoNeonPlease:BOOL=ON \
   -DCMAKE_CXX_FLAGS=-std=c++11\
 %ifarch %{ix86} x86_64
   -DX86Build=ON \

++ zynaddsubfx-DPF.patch ++
Index: DPF/distrho/src/DistrhoPluginInternal.hpp
===
--- DPF/distrho/src/DistrhoPluginInternal.hpp.orig  2016-08-01 
00:51:33.0 +0200
+++ DPF/distrho/src/DistrhoPluginInternal.hpp   2017-05-10 17:05:02.037419388 
+0200
@@ -43,6 +43,7 @@ struct Plugin::PrivateData {
 #endif
 
 uint32_t   parameterCount;
+uint32_t   parameterOffset;
 Parameter* parameters;
 
 #if DISTRHO_PLUGIN_WANT_PROGRAMS
@@ -73,6 +74,7 @@ struct Plugin::PrivateData {
   audioPorts(nullptr),
 #endif
   parameterCount(0),
+  parameterOffset(0),
   parameters(nullptr),
 #if DISTRHO_PLUGIN_WANT_PROGRAMS
   programCount(0),
@@ -91,6 +93,22 @@ struct Plugin::PrivateData {
 {
 DISTRHO_SAFE_ASSERT(bufferSize != 0);
 DISTRHO_SAFE_ASSERT(d_isNotZero(sampleRate));
+
+#if defined(DISTRHO_PLUGIN_TARGET_DSSI) || defined(DISTRHO_PLUGIN_TARGET_LV2)
+parameterOffset += DISTRHO_PLUGIN_NUM_INPUTS + 
DISTRHO_PLUGIN_NUM_OUTPUTS;
+# if DISTRHO_PLUGIN_WANT_LATENCY
+parameterOffset += 1;
+# endif
+#endif
+
+#ifdef DISTRHO_PLUGIN_TARGET_LV2
+# if (DISTRHO_PLUGIN_IS_SYNTH || DISTRHO_PLUGIN_WANT_TIMEPOS || 
DISTRHO_PLUGIN_WANT_STATE)
+parameterOffset += 1;
+#  if DISTRHO_PLUGIN_WANT_STATE
+parameterOffset += 1;
+#  endif
+# endif
+#endif
 }
 
 ~PrivateData() noexcept
@@ -283,6 +301,13 @@ public:
 return fData->parameterCount;
 }
 
+uint32_t getParameterOffset() const noexcept
+{
+DISTRHO_SAFE_ASSERT_RETURN(fData != nullptr, 0);
+
+return fData->parameterOffset;
+}
+
 uint32_t getParameterHints(const uint32_t index) const noexcept
 {
 DISTRHO_SAFE_ASSERT_RETURN(fData != nullptr && index < 
fData->parameterCount, 0x0);
Index: DPF/distrho/src/DistrhoPluginLADSPA+DSSI.cpp
===
--- DPF/distrho/src/DistrhoPluginLADSPA+DSSI.cpp.orig   2016-08-01 
00:51:33.0 +0200
+++ DPF/distrho/src/DistrhoPluginLADSPA+DSSI.cpp2017-05-10 
17:05:02.117414864 +0200
@@ -331,7 +331,12 @@ public:
 
 int dssi_get_midi_controller_for_port(const ulong port) noexcept
 {
-const uint8_t midiCC = fPlugin.getParameterMidiCC(port);
+const uint32_t parameterOffset = fPlugin.getParameterOffset();
+
+if (port > parameterOffset)
+return DSSI_NONE;
+
+const uint8_t midiCC = 
fPlugin.getParameterMidiCC(port-parameterOffset);
 
 if (midiCC == 0 || midiCC == 32 || midiCC >= 0x78)
 return DSSI_NONE;
Index: DPF/distrho/src/DistrhoPluginLV2export.cpp
===
--- DPF/distrho/src/DistrhoPluginLV2export.cpp.orig 2016-11-20 
18:28:11.0 +0200
+++ DPF/distrho/src/DistrhoPluginLV2export.cpp  2017-05-10 17:05:02.117414864 

commit pymol for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package pymol for openSUSE:Factory checked 
in at 2017-05-18 20:48:03

Comparing /work/SRC/openSUSE:Factory/pymol (Old)
 and  /work/SRC/openSUSE:Factory/.pymol.new (New)


Package is "pymol"

Thu May 18 20:48:03 2017 rev:49 rq:494905 version:1.8.6.1.svn4172

Changes:

--- /work/SRC/openSUSE:Factory/pymol/pymol.changes  2017-03-21 
22:51:23.859102789 +0100
+++ /work/SRC/openSUSE:Factory/.pymol.new/pymol.changes 2017-05-18 
20:48:07.088970905 +0200
@@ -1,0 +2,11 @@
+Fri May  5 17:03:12 UTC 2017 - dh...@wustl.edu
+
+- 1.8.6.1 fixes
+  * Python 3.6 fixes
+  * Python 3: fix builder bond order buttons (Red Hat Bug 1442127)
+  * fix MAE export PDB residue/atom names
+  * restored "scene_animation" setting (1.7.6 regression)
+  * restored "import cmd" prevention (1.8.6.0 regression)
+
+
+---

Old:

  pymol-1.8.6.0.svn4170.tar.xz

New:

  pymol-1.8.6.1.svn4172.tar.xz



Other differences:
--
++ pymol.spec ++
--- /var/tmp/diff_new_pack.c5ewPB/_old  2017-05-18 20:48:07.872860278 +0200
+++ /var/tmp/diff_new_pack.c5ewPB/_new  2017-05-18 20:48:07.872860278 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   pymol
-Version:1.8.6.0.svn4170
+Version:1.8.6.1.svn4172
 Release:0
 Url:http://pymol.org
 Summary:A Molecular Viewer

++ pymol-1.8.6.0.svn4170.tar.xz -> pymol-1.8.6.1.svn4172.tar.xz ++
/work/SRC/openSUSE:Factory/pymol/pymol-1.8.6.0.svn4170.tar.xz 
/work/SRC/openSUSE:Factory/.pymol.new/pymol-1.8.6.1.svn4172.tar.xz differ: char 
25, line 1




commit python-WebTest for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package python-WebTest for openSUSE:Factory 
checked in at 2017-05-18 20:48:10

Comparing /work/SRC/openSUSE:Factory/python-WebTest (Old)
 and  /work/SRC/openSUSE:Factory/.python-WebTest.new (New)


Package is "python-WebTest"

Thu May 18 20:48:10 2017 rev:21 rq:494917 version:2.0.27

Changes:

--- /work/SRC/openSUSE:Factory/python-WebTest/python-WebTest.changes
2016-09-28 11:30:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-WebTest.new/python-WebTest.changes   
2017-05-18 20:48:11.052411560 +0200
@@ -1,0 +2,20 @@
+Wed May  3 16:31:46 UTC 2017 - toddrme2...@gmail.com
+
+- Update to 2.0.27
+  * Bugfix: Allow to use set_cookie when HTTP_HOST is set
+  * Fix #177: resp.json now always decode body as utf8
+- Update to 2.0.26
+  * Added JWT auth support
+  * Always show response body when response status is invalid
+- Update to 2.0.25
+  * Fix #173: Do not omit file uploads without a file from post.
+- Update to 2.0.24
+  * Drop python 2.6 support. Newer versions may still work if you
+use waitress < 1.0
+  * Remove bs4 warnings
+  * Docs improvments
+  * Tets are WebOb 1.7.x compatible
+- Implement singlespec version
+- Fix source URL.
+
+---

Old:

  WebTest-2.0.23.tar.gz

New:

  WebTest-2.0.27.tar.gz



Other differences:
--
++ python-WebTest.spec ++
--- /var/tmp/diff_new_pack.jPMgbG/_old  2017-05-18 20:48:11.676323510 +0200
+++ /var/tmp/diff_new_pack.jPMgbG/_new  2017-05-18 20:48:11.680322946 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-WebTest
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,46 +16,48 @@
 #
 
 
+%bcond_without tests
+
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%define oldpython python
 Name:   python-WebTest
-Version:2.0.23
+Version:2.0.27
 Release:0
 Url:http://webtest.pythonpaste.org/
 Summary:Helper to test WSGI applications
 License:MIT
 Group:  Development/Languages/Python
-Source: 
https://pypi.io/packages/source/W/WebTest/WebTest-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/W/WebTest/WebTest-%{version}.tar.gz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  python-PasteDeploy
-BuildRequires:  python-WSGIProxy2
-BuildRequires:  python-base
-BuildRequires:  python-beautifulsoup4
-BuildRequires:  python-cssselect
-BuildRequires:  python-mock
-BuildRequires:  python-pyquery
-BuildRequires:  python-setuptools
-BuildRequires:  python-six
-BuildRequires:  python-unittest2
-BuildRequires:  python-waitress
-# Documentation build requirements:
-BuildRequires:  python-Sphinx
-# Test build requirements:
-BuildRequires:  python-WebOb
-BuildRequires:  python-coverage
-BuildRequires:  python-nose
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
+BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  %{python_module PasteDeploy}
+BuildRequires:  %{python_module WebOb >= 1.2}
+BuildRequires:  %{python_module WSGIProxy2}
+BuildRequires:  %{python_module beautifulsoup4}
+BuildRequires:  %{python_module cssselect}
+BuildRequires:  %{python_module pyquery}
+BuildRequires:  %{python_module waitress >= 0.8.5}
+%if %{with tests}
+BuildRequires:  %{python_module coverage}
+BuildRequires:  %{python_module mock}
+BuildRequires:  %{python_module nose}
 BuildRequires:  python-unittest2
 %endif
+# Documentation build requirements:
+BuildRequires:  python3-Sphinx
 Requires:   python-WebOb >= 1.2
 Requires:   python-beautifulsoup4
 Requires:   python-six
 Requires:   python-waitress >= 0.8.5
-Provides:   python-webtest = %{version}
-Obsoletes:  python-webtest < %{version}
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
-BuildArch:  noarch
+%ifpython2
+Obsoletes:  %{oldpython}-webtest < %{version}
+Provides:   %{oldpython}-webtest = %{version}
 %endif
+BuildArch:  noarch
+%python_subpackages
 
 %description
 This wraps any WSGI application and makes it easy to send test
@@ -64,12 +66,12 @@
 This provides convenient full-stack testing of applications written
 with any WSGI-compatible framework.
 
-%package doc
+%package -n %{name}-doc
 

commit pantheon-photos for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package pantheon-photos for openSUSE:Factory 
checked in at 2017-05-18 20:47:41

Comparing /work/SRC/openSUSE:Factory/pantheon-photos (Old)
 and  /work/SRC/openSUSE:Factory/.pantheon-photos.new (New)


Package is "pantheon-photos"

Thu May 18 20:47:41 2017 rev:5 rq:493306 version:0.2.3

Changes:

--- /work/SRC/openSUSE:Factory/pantheon-photos/pantheon-photos.changes  
2017-03-31 15:10:10.362571978 +0200
+++ /work/SRC/openSUSE:Factory/.pantheon-photos.new/pantheon-photos.changes 
2017-05-18 20:47:43.608284642 +0200
@@ -1,0 +2,10 @@
+Wed May  3 02:42:03 UTC 2017 - avvi...@yandex.by
+
+- Update to 0.2.3:
+  * Update URLs (#145)
+  * correct undo button position in header bar (#140)
+  * Add Travis CI (#144)
+  * Update README.md; remove old files (#139)
+  * Switch to new comparators
+
+---

Old:

  pantheon-photos-0.2.2.tar.xz

New:

  pantheon-photos-0.2.3.tar.xz



Other differences:
--
++ pantheon-photos.spec ++
--- /var/tmp/diff_new_pack.LI28A3/_old  2017-05-18 20:47:44.168205623 +0200
+++ /var/tmp/diff_new_pack.LI28A3/_new  2017-05-18 20:47:44.168205623 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   pantheon-photos
-Version:0.2.2
+Version:0.2.3
 Release:0
 Summary:Photo manager for Elementary OS
 License:GPL-2.0 and LGPL-2.1
@@ -114,7 +114,7 @@
 
 %files
 %defattr(-,root,root)
-%doc AUTHORS COPYING MAINTAINERS NEWS README THANKS
+%doc AUTHORS COPYING
 %{_bindir}/%{name}
 %{_libdir}/%{name}/
 %{_libexecdir}/%{name}/

++ pantheon-photos-0.2.2.tar.xz -> pantheon-photos-0.2.3.tar.xz ++
 3034 lines of diff (skipped)




commit ansible for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package ansible for openSUSE:Factory checked 
in at 2017-05-18 20:47:32

Comparing /work/SRC/openSUSE:Factory/ansible (Old)
 and  /work/SRC/openSUSE:Factory/.ansible.new (New)


Package is "ansible"

Thu May 18 20:47:32 2017 rev:26 rq:487782 version:2.3.0.0

Changes:

--- /work/SRC/openSUSE:Factory/ansible/ansible.changes  2017-03-28 
15:24:38.708977412 +0200
+++ /work/SRC/openSUSE:Factory/.ansible.new/ansible.changes 2017-05-18 
20:47:34.449577174 +0200
@@ -1,0 +2,7 @@
+Tue Mar 28 08:30:35 UTC 2017 - mich...@stroeder.com
+
+- update to 2.3.0.0
+  for full list of changes see
+  /usr/share/doc/packages/ansible/CHANGELOG.md
+
+---

Old:

  ansible-2.2.2.0.tar.gz

New:

  ansible-2.3.0.0.tar.gz



Other differences:
--
++ ansible.spec ++
--- /var/tmp/diff_new_pack.BoMnmw/_old  2017-05-18 20:47:35.561420264 +0200
+++ /var/tmp/diff_new_pack.BoMnmw/_new  2017-05-18 20:47:35.565419700 +0200
@@ -19,7 +19,7 @@
 
 
 Name:   ansible
-Version:2.2.2.0
+Version:2.3.0.0
 Release:0
 Summary:Radically simple IT automation
 License:GPL-3.0
@@ -99,6 +99,7 @@
 %defattr(-,root,root,-)
 %doc COPYING README.md CHANGELOG.md
 %{_bindir}/ansible
+%{_bindir}/ansible-connection
 %{_bindir}/ansible-console
 %{_bindir}/ansible-playbook
 %{_bindir}/ansible-pull
@@ -107,6 +108,7 @@
 %{_bindir}/ansible-vault
 %{python_sitelib}/*
 %{_mandir}/man1/ansible.1*
+%{_mandir}/man1/ansible-console.1*
 %{_mandir}/man1/ansible-doc.1*
 %{_mandir}/man1/ansible-galaxy.1*
 %{_mandir}/man1/ansible-playbook.1*

++ ansible-2.2.2.0.tar.gz -> ansible-2.3.0.0.tar.gz ++
 852247 lines of diff (skipped)




commit cfengine-masterfiles for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package cfengine-masterfiles for 
openSUSE:Factory checked in at 2017-05-18 20:47:30

Comparing /work/SRC/openSUSE:Factory/cfengine-masterfiles (Old)
 and  /work/SRC/openSUSE:Factory/.cfengine-masterfiles.new (New)


Package is "cfengine-masterfiles"

Thu May 18 20:47:30 2017 rev:17 rq:486313 version:3.10.1

Changes:

--- 
/work/SRC/openSUSE:Factory/cfengine-masterfiles/cfengine-masterfiles.changes
2016-11-24 21:24:48.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.cfengine-masterfiles.new/cfengine-masterfiles.changes
   2017-05-18 20:47:31.685967191 +0200
@@ -1,0 +2,7 @@
+Fri Mar 31 07:43:32 UTC 2017 - kkae...@suse.com
+
+- Update to 3.10.1
+  See https://github.com/cfengine/core/blob/3.10.1/ChangeLog
+  for full ChangeLog
+
+---
@@ -4 +11 @@
-- Update to 3.10.1 (beta1) - LTS until Dec 2019
+- Update to 3.10.0 (beta1) - LTS until Dec 2019

Old:

  cfengine-masterfiles-3.10.0b1.tar.gz

New:

  masterfiles-3.10.1.tar.gz



Other differences:
--
++ cfengine-masterfiles.spec ++
--- /var/tmp/diff_new_pack.oUKMYX/_old  2017-05-18 20:47:32.537846969 +0200
+++ /var/tmp/diff_new_pack.oUKMYX/_new  2017-05-18 20:47:32.541846404 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package cfengine-masterfiles
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,12 +26,11 @@
 Summary:CFEngine promises master files
 License:MIT and LGPL-3.0+
 Group:  Productivity/Networking/System
-Version:3.10.0~b1
+Version:3.10.1
 Release:0
-%define srcversion 3.10.0b1
+%define srcname masterfiles
 Url:http://www.cfengine.org/
-Source: 
https://cfengine-package-repos.s3.amazonaws.com/tarballs/%{name}-%{srcversion}.tar.gz
-#https://github.com/cfengine/masterfiles/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
+Source: 
https://github.com/cfengine/masterfiles/archive/%{version}.tar.gz#/%{srcname}-%{version}.tar.gz
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
@@ -57,7 +56,7 @@
 /var/cfengine/inputs by CFEngine.
 
 %prep
-%setup -q -n %{name}-%{srcversion}
+%setup -q -n %{srcname}-%{version}
 
 %build
 # EXPLICIT_VERSION must be set in the environment else creation of




commit libinput for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libinput for openSUSE:Factory 
checked in at 2017-05-18 20:46:58

Comparing /work/SRC/openSUSE:Factory/libinput (Old)
 and  /work/SRC/openSUSE:Factory/.libinput.new (New)


Package is "libinput"

Thu May 18 20:46:58 2017 rev:44 rq:494461 version:1.7.2

Changes:

--- /work/SRC/openSUSE:Factory/libinput/libinput.changes2017-04-24 
09:47:02.570731220 +0200
+++ /work/SRC/openSUSE:Factory/.libinput.new/libinput.changes   2017-05-18 
20:47:01.718196419 +0200
@@ -1,0 +2,18 @@
+Wed May 10 18:50:20 UTC 2017 - zai...@opensuse.org
+
+- Update to version 1.7.2:
+  * The main change here are patches that change the pressure
+ranges for Elantech touchpads down to something more lenient.
+Previously, the range was set too high, causing the touchpad to
+behave erratically unless the finger pressure was quite high.
+- Drop libinput-elantech-pressure-levels.patch: Fixed upstream.
+
+---
+Tue Apr 25 09:11:04 UTC 2017 - jeng...@inai.de
+
+- Update to new upstream release 1.7.1
+  * One patch fixes a test case failure for recent systemd
+versions, the other patch fixes a minor issue with the
+touchpad code that was likely never triggered anyway.
+
+---

Old:

  libinput-1.7.0.tar.xz
  libinput-1.7.0.tar.xz.sig
  libinput-elantech-pressure-levels.patch

New:

  libinput-1.7.2.tar.xz
  libinput-1.7.2.tar.xz.sig



Other differences:
--
++ libinput.spec ++
--- /var/tmp/diff_new_pack.gQaeXb/_old  2017-05-18 20:47:02.454092565 +0200
+++ /var/tmp/diff_new_pack.gQaeXb/_new  2017-05-18 20:47:02.458092001 +0200
@@ -18,7 +18,7 @@
 
 Name:   libinput
 %define lname  libinput10
-Version:1.7.0
+Version:1.7.2
 Release:0
 Summary:Input device and event processing library
 License:MIT
@@ -32,7 +32,6 @@
 Source2:
http://freedesktop.org/software/libinput/%name-%version.tar.xz.sig
 Source3:baselibs.conf
 Source4:%name.keyring
-Patch1: libinput-elantech-pressure-levels.patch
 #git#BuildRequires:  autoconf >= 2.64
 #git#BuildRequires:  automake >= 1.11
 #git#BuildRequires:  libtool >= 2.2
@@ -99,7 +98,6 @@
 
 %prep
 %setup -qn %name-%version
-%patch -P 1 -p1
 
 %build
 if [ ! -e configure ]; then

++ libinput-1.7.0.tar.xz -> libinput-1.7.2.tar.xz ++
 3530 lines of diff (skipped)




commit picard for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package picard for openSUSE:Factory checked 
in at 2017-05-18 20:47:28

Comparing /work/SRC/openSUSE:Factory/picard (Old)
 and  /work/SRC/openSUSE:Factory/.picard.new (New)


Package is "picard"

Thu May 18 20:47:28 2017 rev:28 rq:494342 version:1.4.2

Changes:

--- /work/SRC/openSUSE:Factory/picard/picard.changes2017-04-11 
09:48:54.705308918 +0200
+++ /work/SRC/openSUSE:Factory/.picard.new/picard.changes   2017-05-18 
20:47:30.086192961 +0200
@@ -1,0 +2,16 @@
+Wed May 10 13:08:08 UTC 2017 - alarr...@suse.com
+
+- Update to version 1.4.2:
+ * Bugfix: Picard does not stop analyzer while moving (PICARD-1053)
+ * Bugfix: Picard hangs with: RuntimeError: maximum recursion depth exceeded 
in cmp (PICARD-1055)
+ * Bugfix: The "Convert Unicode punctuation characters to ASCII" function only 
works in certain tags (PICARD-1070)
+ * Bugfix: ID3v2.4 text encoding settings are not saved correctly (PICARD-1077)
+ * Improvement: Search dialog webservices get queued behind matched album 
requests (PICARD-969)
+ * Improvement: Picard not seeing TOPE and TOAL (PICARD-1034)
+
+---
+Sun May  7 10:08:16 UTC 2017 - o...@aepfle.de
+
+- setup.py requires sip
+
+---

Old:

  picard-1.4.1.tar.gz

New:

  picard-1.4.2.tar.gz



Other differences:
--
++ picard.spec ++
--- /var/tmp/diff_new_pack.iOrrny/_old  2017-05-18 20:47:30.918075560 +0200
+++ /var/tmp/diff_new_pack.iOrrny/_new  2017-05-18 20:47:30.918075560 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   picard
-Version:1.4.1
+Version:1.4.2
 Release:0
 Summary:The Next Generation MusicBrainz Tagger
 License:GPL-2.0+
 Group:  Productivity/Multimedia/Sound/Utilities
 Url:http://musicbrainz.org/doc/PicardTagger
-Source0:
ftp://ftp.musicbrainz.org/pub/musicbrainz/picard/%{name}-1.4.1.tar.gz
+Source0:
ftp://ftp.musicbrainz.org/pub/musicbrainz/picard/%{name}-%{version}.tar.gz
 # http://wiki.musicbrainz.org/Picard_Plugins
 # All of the Search*.py files come from 
https://github.com/brianfreud/Picard-plugins
 # The full URL can not be part of this specfile because download corrupts line 
endings
@@ -46,6 +46,7 @@
 Requires:   python-mutagen
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  python-qt4
+BuildRequires:  python-sip
 BuildRequires:  update-desktop-files
 Recommends: python-discid
 Requires:   python-qt4
@@ -59,7 +60,7 @@
 %lang_package
 
 %prep
-%setup -q -n %{name}-release-1.4.1
+%setup -q -n %{name}-release-%{version}
 
 %build
 python setup.py config

++ picard-1.4.1.tar.gz -> picard-1.4.2.tar.gz ++
 13706 lines of diff (skipped)




commit libreoffice for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libreoffice for openSUSE:Factory 
checked in at 2017-05-18 20:47:04

Comparing /work/SRC/openSUSE:Factory/libreoffice (Old)
 and  /work/SRC/openSUSE:Factory/.libreoffice.new (New)


Package is "libreoffice"

Thu May 18 20:47:04 2017 rev:131 rq:494638 version:5.3.3.2

Changes:

--- /work/SRC/openSUSE:Factory/libreoffice/libreoffice.changes  2017-04-28 
09:12:02.940694947 +0200
+++ /work/SRC/openSUSE:Factory/.libreoffice.new/libreoffice.changes 
2017-05-18 20:47:14.204434289 +0200
@@ -1,0 +2,14 @@
+Thu May 11 11:52:17 UTC 2017 - tchva...@suse.com
+
+- Version update to 5.3.3.2 fate#323270:
+  * Update to 5.3.3 release containing bunch of additional fixes
+- Add direct dep on harfbuzz-icu
+
+---
+Tue May  2 11:32:46 UTC 2017 - tchva...@suse.com
+
+- Version update to 5.3.3.1:
+  * Also contians fix for bsc#1036975 CVE-2017-8358
+  * Various fixes in 5.3 branch for rc1 of 5.3.3
+
+---
@@ -31,0 +46,6 @@
+Mon Mar 13 17:12:52 UTC 2017 - mgo...@suse.com
+
+- Fix syntax error in 0001-allow-none-gi-support.patch
+  (bsc#1028817).
+
+---
@@ -76,0 +97,6 @@
+Sun Jan 22 10:52:54 UTC 2017 - andras.ti...@collabora.com
+
+-  Remove upstreamed patch
+   * bnc1010961.diff
+
+---
@@ -82,0 +109,12 @@
+Fri Jan 20 10:53:49 UTC 2017 - andras.ti...@collabora.com
+
+- Version update to 5.2.5.1
+  * various bugfixes
+- Remove upstreamed patches
+  * bnc945446-vertical-text-clone-formatting.patch
+  * bnc955548-crash-fix.patch
+  * bnc980734.diff
+- Fix L3 bnc#1014896 LO-L3: Libreoffice calc (writer in fact!) freezing when 
running a hyphenate all
+  * bnc1014896.diff
+
+---
@@ -99,0 +138,6 @@
+Mon Jan  9 16:41:37 UTC 2017 - andras.ti...@collabora.com
+
+- Fix L3 bnc#1010961 LO-L3: Change tracking: everything is a change, and 
accepting changes
+  * bnc1010961.diff
+
+---
@@ -112,0 +157,6 @@
+Tue Dec 20 12:54:20 UTC 2016 - andras.ti...@collabora.com
+
+- Fix L3 bnc#980734 LO-L3: LibreOffice missing contents in PPTX deck
+  * bnc980734.diff
+
+---
@@ -116,0 +167,8 @@
+
+---
+Tue Dec 13 11:50:28 UTC 2016 - andras.ti...@collabora.com
+
+- Fix L3 bnc#945446 LO-L3: Clone Formatting ignores vertical text alignment
+  * bnc945446-vertical-text-clone-formatting.patch
+- Fix L3 bnc#955548 LO-L3: CTRL+Z not working to undo changes performed 
through Navigator crash fix
+  * bnc955548-crash-fix.patch

Old:

  libreoffice-5.3.2.2.tar.xz
  libreoffice-help-5.3.2.2.tar.xz
  libreoffice-translations-5.3.2.2.tar.xz

New:

  libreoffice-5.3.3.2.tar.xz
  libreoffice-help-5.3.3.2.tar.xz
  libreoffice-translations-5.3.3.2.tar.xz



Other differences:
--
++ libreoffice.spec ++
--- /var/tmp/diff_new_pack.n2SjLM/_old  2017-05-18 20:47:22.619246741 +0200
+++ /var/tmp/diff_new_pack.n2SjLM/_new  2017-05-18 20:47:22.623246176 +0200
@@ -22,7 +22,7 @@
 %define numbertext_version 0.9.5
 # Urls
 %define external_url   http://dev-www.libreoffice.org/src/
-%define tarball_url
http://download.documentfoundation.org/libreoffice/src/5.3.2
+%define tarball_url
http://download.documentfoundation.org/libreoffice/src/5.3.3
 # Wether to enable the kde integration
 %if 0%{?is_opensuse}
 %bcond_without kdeintegration
@@ -35,7 +35,7 @@
 %bcond_with firebird
 %endif
 Name:   libreoffice
-Version:5.3.2.2
+Version:5.3.3.2
 Release:0
 Summary:A Free Office Suite (Framework)
 License:Apache-2.0 and Artistic-1.0 and BSD-3-Clause and BSD-4-Clause 
and GPL-2.0+ and LPPL-1.3c and LGPL-2.1+ and LGPL-3.0 and MPL-1.1 and MIT and 
SUSE-Public-Domain and W3C
@@ -176,7 +176,8 @@
 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
 BuildRequires:  pkgconfig(gtk+-2.0) >= 2.18.0
 BuildRequires:  pkgconfig(gtk+-3.0)
-BuildRequires:  pkgconfig(harfbuzz)
+BuildRequires:  pkgconfig(harfbuzz) >= 0.9.42
+BuildRequires:  pkgconfig(harfbuzz-icu) >= 0.9.42
 BuildRequires:  pkgconfig(hunspell)
 BuildRequires:  pkgconfig(icu-i18n)
 BuildRequires:  pkgconfig(krb5)








++ libreoffice-5.3.2.2.tar.xz -> libreoffice-5.3.3.2.tar.xz ++
/work/SRC/openSUSE:Factory/libreoffice/libreoffice-5.3.2.2.tar.xz 
/work/SRC/openSUSE:Factory/.libreoffice.new/libreoffice-5.3.3.2.tar.xz 

commit openssl-1_1_0 for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package openssl-1_1_0 for openSUSE:Factory 
checked in at 2017-05-18 20:46:44

Comparing /work/SRC/openSUSE:Factory/openssl-1_1_0 (Old)
 and  /work/SRC/openSUSE:Factory/.openssl-1_1_0.new (New)


Package is "openssl-1_1_0"

Thu May 18 20:46:44 2017 rev:1 rq:494106 version:1.1.0e

Changes:

New Changes file:

--- /dev/null   2017-03-01 00:40:19.279048016 +0100
+++ /work/SRC/openSUSE:Factory/.openssl-1_1_0.new/openssl-1_1_0.changes 
2017-05-18 20:46:47.780163434 +0200
@@ -0,0 +1,2497 @@
+---
+Wed May 10 11:11:33 UTC 2017 - tchva...@suse.com
+
+- Add conflict for any libopenssl-devel that is not in our version
+
+---
+Wed May 10 10:40:53 UTC 2017 - tchva...@suse.com
+
+- Avoid the requires conflict between 1.1 and 1.0 openssl
+
+---
+Fri May  5 07:42:41 UTC 2017 - tchva...@suse.com
+
+- Add conflict on docu packages
+
+---
+Wed May  3 12:48:11 UTC 2017 - vci...@suse.com
+
+- drop unnecessary README.SUSE
+
+---
+Wed May  3 11:46:58 UTC 2017 - vci...@suse.com
+
+- add openssl-1.1-fix-ppc64.patch from Marcus Meissner to fix build
+  on ppc64
+
+---
+Wed May  3 09:06:06 UTC 2017 - tchva...@suse.com
+
+- Fix build on aarch64
+
+---
+Wed May  3 08:50:07 UTC 2017 - tchva...@suse.com
+
+- Remove libpadlock conditional, no longer present
+
+---
+Tue May  2 10:28:38 UTC 2017 - tchva...@suse.com
+
+- Update baselibs.conf to contain all the renamed packages
+
+---
+Wed Apr 26 12:43:47 UTC 2017 - vci...@suse.com
+
+- re-enable tests on SLE-12 and below despite current failure, so
+  they are automatically run once the issue is resolved
+
+---
+Wed Apr 26 12:37:14 UTC 2017 - tchva...@suse.com
+
+- Filter out the pkgconfig provides to force usage of the main
+  openssl package provides
+
+---
+Fri Apr 21 13:04:42 UTC 2017 - vci...@suse.com
+
+- disable tests on SLE-12 and its derivates
+  * they fail because of glibc bug bsc#1035445
+- remove README-FIPS.txt (outdated)
+
+---
+Thu Apr 20 15:08:43 UTC 2017 - vci...@suse.com
+
+- drop openssl-fipslocking.patch
+  The locking in 1.1.0 has been rewritten and converted to the new
+  threading API. The fips deadlock (at least bsc#991193) can't be
+  reproduced anymore.
+- don't ship useless INSTALL* files
+
+---
+Thu Apr 20 10:16:43 UTC 2017 - vci...@suse.com
+
+- simplify openssl-fips-dont-fall-back-to-default-digest.patch
+  The -non-fips-allow option was dropped in OpenSSL 1.1.0
+- drop openssl-no-egd.patch as OpenSSL 1.1.0 disables EGD at compile
+  time by default
+- renumber the patches so the numbers are consequent
+
+---
+Tue Apr 18 19:51:39 UTC 2017 - tchva...@suse.com
+
+- Update showciphers.c to work with new openssl
+
+---
+Tue Apr 18 19:17:42 UTC 2017 - tchva...@suse.com
+
+- Add patch openssl-static-deps.patch to allow dependencies on
+  statically build libraries
+- Refresh openssl-1-1.0-fips.patch to take in use the above approach
+- Silence the install manpage rename phase
+
+---
+Thu Apr 13 12:17:53 UTC 2017 - tchva...@suse.com
+
+- Start update to 1.1.0e basing of the 1.0.0 split release
+- Drop patch merge_from_0.9.8k.patch the ppc64 should work out of the
+  box
+- Drop patch openssl-engines-path.patch converted to configure option
+- Drop patch openssl-1.0.2a-padlock64.patch code behind was redone
+  does not apply at all
+- Drop patch openssl-fix-pod-syntax.diff mostly merged upstream or
+  not applicable
+- Drop patch compression_methods_switch.patch as we do not need
+  to keep the compat on this release anymore
+- Drop patch openssl-1.0.2a-ipv6-apps.patch which was upstreamed
+- Drop upstreamed patch openssl-1.0.2a-default-paths.patch
+- Drop obsolete patch openssl-1.0.0-c_rehash-compat.diff
+- Drop obsolete patch openssl-missing_FIPS_ec_group_new_by_curve_name.patch
+- Drop obsolete patch openssl-print_notice-NULL_crash.patch
+- Drop obsolete 

commit openssl for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package openssl for openSUSE:Factory checked 
in at 2017-05-18 20:46:33

Comparing /work/SRC/openSUSE:Factory/openssl (Old)
 and  /work/SRC/openSUSE:Factory/.openssl.new (New)


Package is "openssl"

Thu May 18 20:46:33 2017 rev:138 rq:492985 version:1.0.2k

Changes:

--- /work/SRC/openSUSE:Factory/openssl/openssl.changes  2017-04-11 
09:29:35.117110729 +0200
+++ /work/SRC/openSUSE:Factory/.openssl.new/openssl.changes 2017-05-18 
20:46:41.389065383 +0200
@@ -1,0 +2,75 @@
+Fri May  5 09:21:04 UTC 2017 - tchva...@suse.com
+
+- Provide pkgconfig(openssl)
+
+---
+Tue May  2 10:34:51 UTC 2017 - tchva...@suse.com
+
+- Provide basic baselibs.conf for 32bit subpackages
+- Specify this package as noarch (as we just provide README files)
+
+---
+Wed Apr 26 12:51:45 UTC 2017 - tchva...@suse.com
+
+- Fix typo in openssl requires
+- Add dependency on the branched devel package
+- Provide all pkgconfig symbols to hide them in versioned subpkgs
+- This allows us to propagate only the preffered version of openssl
+  while allowing us to add extra openssl only as additional dependency
+
+---
+Wed Apr 12 12:25:26 UTC 2017 - tchva...@suse.com
+
+- Remove the ssl provides as it is applicable for only those that
+  really provide it
+
+---
+Wed Apr 12 11:51:36 UTC 2017 - tchva...@suse.com
+
+- Prepare to split to various subpackages converting main one to
+  dummy package
+- Reduce to only provide main pkg and devel and depend on proper
+  soversioned package
+- Version in this package needs to be synced with the one provided
+  by the split package
+- Remove all the patches, now in the proper versioned namespace:
+  * merge_from_0.9.8k.patch
+  * openssl-1.0.0-c_rehash-compat.diff
+  * bug610223.patch
+  * openssl-ocloexec.patch
+  * openssl-1.0.2a-padlock64.patch
+  * openssl-fix-pod-syntax.diff
+  * openssl-truststore.patch
+  * compression_methods_switch.patch
+  * 0005-libssl-Hide-library-private-symbols.patch
+  * openssl-1.0.2a-default-paths.patch
+  * openssl-pkgconfig.patch
+  * openssl-1.0.2a-ipv6-apps.patch
+  * 0001-libcrypto-Hide-library-private-symbols.patch
+  * openssl-1.0.2i-fips.patch
+  * openssl-1.0.2a-fips-ec.patch
+  * openssl-1.0.2a-fips-ctor.patch
+  * openssl-1.0.2i-new-fips-reqs.patch
+  * openssl-gcc-attributes.patch
+  * 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
+  * openssl-no-egd.patch
+  * openssl-fips-hidden.patch
+  * openssl-1.0.1e-add-suse-default-cipher.patch
+  * openssl-1.0.1e-add-test-suse-default-cipher-suite.patch
+  * openssl-missing_FIPS_ec_group_new_by_curve_name.patch
+  * openssl-fips-dont_run_FIPS_module_installed.patch
+  * openssl-fips_disallow_x931_rand_method.patch
+  * openssl-fips_disallow_ENGINE_loading.patch
+  * openssl-rsakeygen-minimum-distance.patch
+  * openssl-urandom-reseeding.patch
+  * openssl-fips-rsagen-d-bits.patch
+  * openssl-fips-selftests_in_nonfips_mode.patch
+  * openssl-fips-fix-odd-rsakeybits.patch
+  * openssl-fips-clearerror.patch
+  * openssl-fips-dont-fall-back-to-default-digest.patch
+  * openssl-fipslocking.patch
+  * openssl-print_notice-NULL_crash.patch
+  * openssl-randfile_fread_interrupt.patch
+
+
+---

Old:

  0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
  0001-libcrypto-Hide-library-private-symbols.patch
  0005-libssl-Hide-library-private-symbols.patch
  README-FIPS.txt
  bug610223.patch
  compression_methods_switch.patch
  merge_from_0.9.8k.patch
  openssl-1.0.0-c_rehash-compat.diff
  openssl-1.0.1e-add-suse-default-cipher.patch
  openssl-1.0.1e-add-test-suse-default-cipher-suite.patch
  openssl-1.0.2a-default-paths.patch
  openssl-1.0.2a-fips-ctor.patch
  openssl-1.0.2a-fips-ec.patch
  openssl-1.0.2a-ipv6-apps.patch
  openssl-1.0.2a-padlock64.patch
  openssl-1.0.2i-fips.patch
  openssl-1.0.2i-new-fips-reqs.patch
  openssl-1.0.2k.tar.gz
  openssl-1.0.2k.tar.gz.asc
  openssl-fips-clearerror.patch
  openssl-fips-dont-fall-back-to-default-digest.patch
  openssl-fips-dont_run_FIPS_module_installed.patch
  openssl-fips-fix-odd-rsakeybits.patch
  openssl-fips-hidden.patch
  openssl-fips-rsagen-d-bits.patch
  openssl-fips-selftests_in_nonfips_mode.patch
  openssl-fips_disallow_ENGINE_loading.patch
  openssl-fips_disallow_x931_rand_method.patch
  openssl-fipslocking.patch
  openssl-fix-pod-syntax.diff
  openssl-gcc-attributes.patch
  openssl-missing_FIPS_ec_group_new_by_curve_name.patch
  openssl-no-egd.patch
  openssl-ocloexec.patch
  openssl-pkgconfig.patch
  

commit vlc for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package vlc for openSUSE:Factory checked in 
at 2017-05-18 20:46:28

Comparing /work/SRC/openSUSE:Factory/vlc (Old)
 and  /work/SRC/openSUSE:Factory/.vlc.new (New)


Package is "vlc"

Thu May 18 20:46:28 2017 rev:67 rq:492648 version:2.2.4

Changes:

--- /work/SRC/openSUSE:Factory/vlc/vlc.changes  2016-12-05 16:32:51.0 
+0100
+++ /work/SRC/openSUSE:Factory/.vlc.new/vlc.changes 2017-05-18 
20:46:29.722711805 +0200
@@ -1,0 +2,7 @@
+Wed May  3 06:57:57 UTC 2017 - dims...@opensuse.org
+
+- Replace libmodplug-devel BuildRequires with
+  pkgconfig(libmodplug): this helps with the migration from
+  libmodplug to openmpt.
+
+---



Other differences:
--
++ vlc.spec ++
--- /var/tmp/diff_new_pack.Eb3Rts/_old  2017-05-18 20:46:30.562593276 +0200
+++ /var/tmp/diff_new_pack.Eb3Rts/_new  2017-05-18 20:46:30.566592711 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package vlc
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2012 Dominique Leuenberger, Amsterdam, The Netherlands
 #
 # All modifications and additions to the file contributed by third parties
@@ -84,10 +84,10 @@
 BuildRequires:  libidn-devel
 BuildRequires:  libjack-devel >= 1.9.7
 BuildRequires:  libkate-devel >= 0.3.0
-BuildRequires:  libmodplug-devel >= 0.8.4
 BuildRequires:  libnotify-devel
 BuildRequires:  libogg-devel >= 1.0
 BuildRequires:  libopus-devel >= 1.0.3
+BuildRequires:  pkgconfig(libmodplug) >= 0.8.4
 %if 0%{?suse_version} >= 1310
 BuildRequires:  pkgconfig(Qt5Core)
 BuildRequires:  pkgconfig(Qt5Gui)




commit libvoikko for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libvoikko for openSUSE:Factory 
checked in at 2017-05-18 20:46:11

Comparing /work/SRC/openSUSE:Factory/libvoikko (Old)
 and  /work/SRC/openSUSE:Factory/.libvoikko.new (New)


Package is "libvoikko"

Thu May 18 20:46:11 2017 rev:29 rq:492491 version:4.1.1

Changes:

--- /work/SRC/openSUSE:Factory/libvoikko/libvoikko.changes  2015-12-01 
09:16:25.0 +0100
+++ /work/SRC/openSUSE:Factory/.libvoikko.new/libvoikko.changes 2017-05-18 
20:46:15.204760658 +0200
@@ -1,0 +2,8 @@
+Tue Apr 25 13:17:13 UTC 2017 - tchva...@suse.com
+
+- Version update to 4.1.1:
+  * Various upstream fixes. See ChangeLog
+  * Should fix boo#1031331
+  * Switch to python3
+
+---

Old:

  libvoikko-3.8.tar.gz
  libvoikko-3.8.tar.gz.asc

New:

  libvoikko-4.1.1.tar.gz
  libvoikko-4.1.1.tar.gz.asc



Other differences:
--
++ libvoikko.spec ++
--- /var/tmp/diff_new_pack.1fRucN/_old  2017-05-18 20:46:15.860668093 +0200
+++ /var/tmp/diff_new_pack.1fRucN/_new  2017-05-18 20:46:15.860668093 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libvoikko
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   libvoikko
-Version:3.8
+Version:4.1.1
 Release:0
 Summary:Spellchecker and Hyphenator for Finnish Language
 License:GPL-2.0+
@@ -29,10 +29,10 @@
 Source99:   baselibs.conf
 BuildRequires:  gcc-c++
 BuildRequires:  glib2-devel
-BuildRequires:  libmalaga-devel
-BuildRequires:  pkg-config
-BuildRequires:  python
-BuildRequires:  python-xml
+BuildRequires:  pkgconfig
+BuildRequires:  python3
+BuildRequires:  python3-xml
+BuildRequires:  pkgconfig(hfstospell)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -72,20 +72,20 @@
 
 %build
 %configure \
+   --disable-silent_rules \
--with-pic \
--disable-static \
-   --with-dictionary-path=%{_datadir}/malaga
+   --with-dictionary-path=%{_libexecdir}/voikko:%{_datadir}/voikko
 make %{?_smp_mflags}
 
 %check
-make %{?_smp_mflags} check
+make %{?_smp_mflags} check || :
 
 %install
-make DESTDIR=%{buildroot} install %{?_smp_mflags}
+%make_install
 find %{buildroot} -type f -name "*.la" -delete -print
 
 %post -n libvoikko1 -p /sbin/ldconfig
-
 %postun -n libvoikko1 -p /sbin/ldconfig
 
 %files -n libvoikko1
@@ -96,7 +96,7 @@
 %files -n voikkospell
 %defattr(-,root,root)
 %{_bindir}/*
-%{_mandir}/man?/*.*
+%{_mandir}/man?/*%{ext_man}
 
 %files devel
 %defattr(-,root,root)

++ libvoikko-3.8.tar.gz -> libvoikko-4.1.1.tar.gz ++
 31568 lines of diff (skipped)





commit malaga-suomi for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package malaga-suomi for openSUSE:Factory 
checked in at 2017-05-18 20:46:04

Comparing /work/SRC/openSUSE:Factory/malaga-suomi (Old)
 and  /work/SRC/openSUSE:Factory/.malaga-suomi.new (New)


Package is "malaga-suomi"

Thu May 18 20:46:04 2017 rev:21 rq:492490 version:2.1

Changes:

--- /work/SRC/openSUSE:Factory/malaga-suomi/malaga-suomi.changes
2015-12-01 09:16:30.0 +0100
+++ /work/SRC/openSUSE:Factory/.malaga-suomi.new/malaga-suomi.changes   
2017-05-18 20:46:05.718099468 +0200
@@ -1,0 +2,6 @@
+Tue Apr 25 16:25:17 UTC 2017 - tchva...@suse.com
+
+- Version update to 2.1
+  * Switches from malaga to libvoikko completely
+
+---

Old:

  suomi-malaga-1.19.tar.gz

New:

  voikko-fi-2.1.tar.gz



Other differences:
--
++ malaga-suomi.spec ++
--- /var/tmp/diff_new_pack.DTj537/_old  2017-05-18 20:46:06.645968523 +0200
+++ /var/tmp/diff_new_pack.DTj537/_new  2017-05-18 20:46:06.649967958 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package malaga-suomi
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,22 +16,30 @@
 #
 
 
-%define _name suomi-malaga
+%define _name voikko-fi
+%define _altname suomi-malaga
 Name:   malaga-suomi
-Version:1.19
+Version:2.1
 Release:0
 Summary:Description of Finnish Morphology Written in Malaga
 License:GPL-2.0+
 Group:  Productivity/Text/Spell
 Url:http://voikko.puimula.org/
 Source: 
http://www.puimula.org/voikko-sources/%{_name}/%{_name}-%{version}.tar.gz
-BuildRequires:  malaga
-BuildRequires:  python-xml
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  foma
+BuildRequires:  python3
+BuildRequires:  voikkospell >= 4.0
+Provides:   %{_name} = %{version}
+Obsoletes:  %{_name} < %{version}
+Provides:   %{_altname} = %{version}
+Obsoletes:  %{_altname} < %{version}
 BuildArch:  noarch
 
 %description
-Suomi-Malaga is a description of Finnish morphology written in Malaga.
+This package contains a compiled version of Voikko-fi using the new
+unweighted VFST dictionary format. It is suitable for use in spell checking,
+grammar checking and hyphenation system Voikko, provided by the libvoikko
+library.
 
 %prep
 %setup -q -n %{_name}-%{version}
@@ -39,17 +47,15 @@
 %build
 CFLAGS="%{optflags}" \
 CXXFLAGS="%{optflags}" \
-make voikko %{?_smp_mflags}
+make %{?_smp_mflags} vvfst 
EXTRA_LEX=vocabulary/erikoisalat/linux-distributions.lex
 
 %install
-make voikko-install DESTDIR=%{buildroot}%{_datadir}/malaga/1/mor-standard
-# compat symlinks
-cd %{buildroot}%{_datadir}/malaga
-ln -s -t. 1/mor-standard/*
+make vvfst-install DESTDIR=%{buildroot}%{_datadir}/voikko
 
 %files
 %defattr(-,root,root)
 %doc CONTRIBUTORS COPYING ChangeLog README README.fi
-%{_datadir}/malaga/*
+%dir %{_datadir}/voikko/
+%{_datadir}/voikko/*
 
 %changelog




commit libsamplerate for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libsamplerate for openSUSE:Factory 
checked in at 2017-05-18 20:45:39

Comparing /work/SRC/openSUSE:Factory/libsamplerate (Old)
 and  /work/SRC/openSUSE:Factory/.libsamplerate.new (New)


Package is "libsamplerate"

Thu May 18 20:45:39 2017 rev:35 rq:492488 version:0.1.9

Changes:

--- /work/SRC/openSUSE:Factory/libsamplerate/libsamplerate.changes  
2016-11-07 10:07:00.0 +0100
+++ /work/SRC/openSUSE:Factory/.libsamplerate.new/libsamplerate.changes 
2017-05-18 20:45:40.913600014 +0200
@@ -1,0 +2,5 @@
+Mon Apr 24 10:35:03 CEST 2017 - ti...@suse.de
+
+- Add missing provides/obsoletes for the old libsamplerate package
+
+---



Other differences:
--
++ libsamplerate.spec ++
--- /var/tmp/diff_new_pack.YW9W6x/_old  2017-05-18 20:45:41.641497289 +0200
+++ /var/tmp/diff_new_pack.YW9W6x/_new  2017-05-18 20:45:41.645496725 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libsamplerate
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -44,6 +44,8 @@
 %package -n libsamplerate0
 Summary:A Sample Rate Converter Library
 Group:  System/Libraries
+Provides:   %{name} = %{version}
+Obsoletes:  %{name} < %{version}
 
 %description -n libsamplerate0
 Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for




commit libsndfile for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libsndfile for openSUSE:Factory 
checked in at 2017-05-18 20:45:45

Comparing /work/SRC/openSUSE:Factory/libsndfile (Old)
 and  /work/SRC/openSUSE:Factory/.libsndfile.new (New)


Package is "libsndfile"

Thu May 18 20:45:45 2017 rev:50 rq:492489 version:1.0.28

Changes:

--- /work/SRC/openSUSE:Factory/libsndfile/libsndfile.changes2017-04-17 
10:24:07.616774697 +0200
+++ /work/SRC/openSUSE:Factory/.libsndfile.new/libsndfile.changes   
2017-05-18 20:45:52.755928761 +0200
@@ -1,0 +2,9 @@
+Tue May  2 14:06:40 CEST 2017 - ti...@suse.de
+
+- Fix FLAC buffer overflows (CVE-2017-8361 CVE-2017-8363
+  CVE-2017-8365 CVE-2017-8362 bsc#1036944 bsc#1036945 bsc#1036946
+  bsc#1036943):
+  0001-FLAC-Fix-a-buffer-read-overrun.patch
+  0002-src-flac.c-Fix-a-buffer-read-overflow.patch
+
+---

New:

  0001-FLAC-Fix-a-buffer-read-overrun.patch
  0002-src-flac.c-Fix-a-buffer-read-overflow.patch



Other differences:
--
++ libsndfile.spec ++
--- /var/tmp/diff_new_pack.tUsjbF/_old  2017-05-18 20:45:55.019609298 +0200
+++ /var/tmp/diff_new_pack.tUsjbF/_new  2017-05-18 20:45:55.023608733 +0200
@@ -28,7 +28,11 @@
 Source1:
http://www.mega-nerd.com/%{name}/files/%{name}-%{version}.tar.gz.asc
 Source2:%{name}.keyring
 Source3:baselibs.conf
-Patch2: sndfile-ocloexec.patch
+# PATCH-FIX-UPSTREAM
+Patch1: 0001-FLAC-Fix-a-buffer-read-overrun.patch
+Patch2: 0002-src-flac.c-Fix-a-buffer-read-overflow.patch
+# PATCH-FIX-OPENSUSE
+Patch100:   sndfile-ocloexec.patch
 BuildRequires:  alsa-devel
 BuildRequires:  flac-devel
 BuildRequires:  gcc-c++
@@ -74,7 +78,9 @@
 
 %prep
 %setup -q
+%patch1 -p1
 %patch2 -p1
+%patch100 -p1
 
 %build
 %define warn_flags -W -Wall -Wstrict-prototypes -Wpointer-arith 
-Wno-unused-parameter

++ 0001-FLAC-Fix-a-buffer-read-overrun.patch ++
>From fd0484aba8e51d16af1e3a880f9b8b857b385eb3 Mon Sep 17 00:00:00 2001
From: Erik de Castro Lopo 
Date: Wed, 12 Apr 2017 19:45:30 +1000
Subject: [PATCH] FLAC: Fix a buffer read overrun
References: CVE-2017-8361 CVE-2017-8363 CVE-2017-8365 bsc#1036944 bsc#1036945 
bsc#1036946

Buffer read overrun occurs when reading a FLAC file that switches
from 2 channels to one channel mid-stream. Only option is to
abort the read.

Closes: https://github.com/erikd/libsndfile/issues/230

---
 src/common.h  |1 +
 src/flac.c|   13 +
 src/sndfile.c |1 +
 3 files changed, 15 insertions(+)

--- a/src/common.h
+++ b/src/common.h
@@ -725,6 +725,7 @@ enum
SFE_FLAC_INIT_DECODER,
SFE_FLAC_LOST_SYNC,
SFE_FLAC_BAD_SAMPLE_RATE,
+   SFE_FLAC_CHANNEL_COUNT_CHANGED,
SFE_FLAC_UNKOWN_ERROR,
 
SFE_WVE_NOT_WVE,
--- a/src/flac.c
+++ b/src/flac.c
@@ -435,6 +435,19 @@ sf_flac_meta_callback (const FLAC__Strea
 
switch (metadata->type)
{   case FLAC__METADATA_TYPE_STREAMINFO :
+   if (psf->sf.channels > 0 && psf->sf.channels != (int) 
metadata->data.stream_info.channels)
+   {   psf_log_printf (psf, "Error: FLAC stream 
changed from %d to %d channels\n"
+   
"Nothing to be but to error out.\n" ,
+   
psf->sf.channels, metadata->data.stream_info.channels) ;
+   psf->error = SFE_FLAC_CHANNEL_COUNT_CHANGED ;
+   return ;
+   } ;
+
+   if (psf->sf.channels > 0 && psf->sf.samplerate != (int) 
metadata->data.stream_info.sample_rate)
+   {   psf_log_printf (psf, "Warning: FLAC stream 
changed sample rates from %d to %d.\n"
+   
"Carrying on as if nothing happened.",
+   
psf->sf.samplerate, metadata->data.stream_info.sample_rate) ;
+   } ;
psf->sf.channels = metadata->data.stream_info.channels ;
psf->sf.samplerate = 
metadata->data.stream_info.sample_rate ;
psf->sf.frames = 
metadata->data.stream_info.total_samples ;
--- a/src/sndfile.c
+++ b/src/sndfile.c
@@ -245,6 +245,7 @@ ErrorStruct SndfileErrors [] =
{   SFE_FLAC_INIT_DECODER   , "Error : problem with initialization 
of the flac decoder." },
{   SFE_FLAC_LOST_SYNC  , "Error : flac decoder lost 
sync." },
{   SFE_FLAC_BAD_SAMPLE_RATE, "Error : 

commit libreoffice-voikko for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libreoffice-voikko for 
openSUSE:Factory checked in at 2017-05-18 20:45:22

Comparing /work/SRC/openSUSE:Factory/libreoffice-voikko (Old)
 and  /work/SRC/openSUSE:Factory/.libreoffice-voikko.new (New)


Package is "libreoffice-voikko"

Thu May 18 20:45:22 2017 rev:15 rq:491013 version:5.0

Changes:

--- /work/SRC/openSUSE:Factory/libreoffice-voikko/libreoffice-voikko.changes
2016-05-23 16:38:47.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.libreoffice-voikko.new/libreoffice-voikko.changes   
2017-05-18 20:45:23.792016302 +0200
@@ -1,0 +2,6 @@
+Tue Apr 25 13:17:59 UTC 2017 - tchva...@suse.com
+
+- Version update to 5.0:
+  * Few parts redone in python instead of C++
+
+---

Old:

  libreoffice-voikko-4.1.tar.gz
  libreoffice-voikko-4.1.tar.gz.asc

New:

  libreoffice-voikko-5.0.tar.gz
  libreoffice-voikko-5.0.tar.gz.asc



Other differences:
--
++ libreoffice-voikko.spec ++
--- /var/tmp/diff_new_pack.6KwOT3/_old  2017-05-18 20:45:24.415928253 +0200
+++ /var/tmp/diff_new_pack.6KwOT3/_new  2017-05-18 20:45:24.419927688 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libreoffice-voikko
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   libreoffice-voikko
-Version:4.1
+Version:5.0
 Release:0
 Summary:LibreOffice spellchecker/hyphenator for finnish language
 License:MPL-2.0 or GPL-3.0+

++ libreoffice-voikko-4.1.tar.gz -> libreoffice-voikko-5.0.tar.gz ++
 6339 lines of diff (skipped)





commit infiniband-diags for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package infiniband-diags for 
openSUSE:Factory checked in at 2017-05-18 20:44:52

Comparing /work/SRC/openSUSE:Factory/infiniband-diags (Old)
 and  /work/SRC/openSUSE:Factory/.infiniband-diags.new (New)


Package is "infiniband-diags"

Thu May 18 20:44:52 2017 rev:5 rq:495521 version:1.6.7

Changes:

--- /work/SRC/openSUSE:Factory/infiniband-diags/infiniband-diags.changes
2015-11-08 14:36:17.0 +0100
+++ /work/SRC/openSUSE:Factory/.infiniband-diags.new/infiniband-diags.changes   
2017-05-18 20:44:55.927948623 +0200
@@ -1,0 +2,23 @@
+Mon May 15 16:23:48 UTC 2017 - nmoreychaisemar...@suse.com
+
+- Remove rdma-ndd now provided by the rdma-core package (bsc#1039146).
+
+---
+Wed May 10 08:55:35 UTC 2017 - nmoreychaisemar...@suse.com
+
+- Update to version 1.6.7 (fate#321867)
+  * No short changelog available; please read the ChangeLog file
+- Use packaged rdma-ndd service file
+- Unify spec and patches with SLE12
+
+---
+Mon Mar  7 13:49:29 CET 2016 - p...@suse.de
+
+- Update to latest git version (fate#320027).
+  For changes see the included ChangeLog.
+- Include Changelog.
+- Remove infiniband-diags-automake_foreign.patch and
+  infiniband-diags-configure.patch as they aren't needed anymore.
+- New sub package rdma-ndd, needed for the above fate.
+
+---

Old:

  infiniband-diags-1.6.6.tar.gz
  infiniband-diags-automake_foreign.patch
  infiniband-diags-configure.patch
  rdma-ndd.service

New:

  infiniband-diags-1.6.7.tar.gz



Other differences:
--
++ infiniband-diags.spec ++
--- /var/tmp/diff_new_pack.Nm7Gl5/_old  2017-05-18 20:44:57.175772524 +0200
+++ /var/tmp/diff_new_pack.Nm7Gl5/_new  2017-05-18 20:44:57.179771959 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package infiniband-diags
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,31 +17,26 @@
 
 
 Name:   infiniband-diags
-Summary:OpenIB InfiniBand Diagnostic Tools
+Summary:OpenFabrics Alliance InfiniBand Diagnostic Tools
 License:GPL-2.0 or BSD-2-Clause
 Group:  Productivity/Networking/Diagnostic
-Version:1.6.6
+Version:1.6.7
 Release:0
 Source0:
https://www.openfabrics.org/downloads/management/%{name}-%{version}.tar.gz
-Source1:rdma-ndd.service
 Source99:   %{name}-rpmlintrc
-Patch0: infiniband-diags-configure.patch
-Patch1: infiniband-diags-automake_foreign.patch
 Patch2: infiniband-diags-help_for_ibnodes.patch
 Url:http://www.openfabrics.org
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  glib2-devel
 BuildRequires:  libibmad-devel
-BuildRequires:  libibumad-devel
-BuildRequires:  libibverbs-devel
 BuildRequires:  libtool
 BuildRequires:  opensm-devel
 BuildRequires:  pkg-config
-BuildRequires:  pkgconfig(libudev)
+BuildRequires:  rdma-core-devel
 BuildRequires:  systemd-rpm-macros
+BuildRequires:  pkgconfig(libudev)
 Requires:   perl = %{perl_version}
-%{?systemd_requires}
 
 %define so_major 5
 
@@ -60,9 +55,8 @@
 
 %package devel
 BuildRequires:  libibmad-devel
-BuildRequires:  libibumad-devel
-BuildRequires:  libibverbs-devel
 BuildRequires:  opensm-devel
+BuildRequires:  rdma-core-devel
 Requires:   %name = %version
 Summary:OpenIB InfiniBand Diagnostic Tools SDK
 Group:  Development/Libraries/C and C++
@@ -75,9 +69,8 @@
 %prep
 %setup -q
 # rename to silence automake
-%patch0
-%patch1
 %patch2
+
 # Avoid unnecessary rebuilds of the package
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
 FAKE_BUILDTIME=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes 
'+%%H:%%M:%%S')
@@ -85,43 +78,31 @@
 
 %build
 autoreconf -fi
+export CFLAGS="%{optflags}"
 %configure --with-perl-installdir=%{perl_vendorarch} --disable-static
 make %{?_smp_mflags} V=1
 
 %install
 make DESTDIR=%buildroot install
 rm -f %{buildroot}%{_libdir}/*.la
-# Remove the init script and install a systemd init file
-rm -rf %{buildroot}/%{_sysconfdir}/init.d
-install -Dm 644 %{SOURCE1} %{buildroot}%{_unitdir}/rdma-ndd.service
-
-%pre
-%service_add_pre rdma-ndd.service
-
-%post
-%service_add_post rdma-ndd.service
-
-%preun
-%service_del_preun rdma-ndd.service
-
-%postun
-%service_del_postun rdma-ndd.service
+#Remove rdma-ndd stuff which is 

commit webkitgtk for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package webkitgtk for openSUSE:Factory 
checked in at 2017-05-18 20:44:26

Comparing /work/SRC/openSUSE:Factory/webkitgtk (Old)
 and  /work/SRC/openSUSE:Factory/.webkitgtk.new (New)


Package is "webkitgtk"

Thu May 18 20:44:26 2017 rev:44 rq:495120 version:2.4.11

Changes:

--- /work/SRC/openSUSE:Factory/webkitgtk/webkitgtk.changes  2016-08-16 
13:01:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.webkitgtk.new/webkitgtk.changes 2017-05-18 
20:44:32.571244839 +0200
@@ -1,0 +2,6 @@
+Fri May 12 08:46:17 UTC 2017 - dims...@opensuse.org
+
+- Add webkitgtk-icu59.patch: Fix build against icu 5.9. Patch
+  ported from Arch.
+
+---
webkitgtk3.changes: same change

New:

  webkitgtk-icu59.patch



Other differences:
--
++ webkitgtk.spec ++
--- /var/tmp/diff_new_pack.kBbZ9o/_old  2017-05-18 20:44:35.678806284 +0200
+++ /var/tmp/diff_new_pack.kBbZ9o/_new  2017-05-18 20:44:35.682805720 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package webkitgtk
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -69,6 +69,8 @@
 Patch10:webkitgtk-ppc32.patch
 # PATCH-FIX-UPSTREAM webkitgtk-abs_to_fabs.patch dims...@opensuse.org -- Use 
fabs() instead of abs() on floating point values
 Patch11:webkitgtk-abs_to_fabs.patch
+# PATCH-FIx-UPSTREAM webkitgtk-icu59.patch dims...@opensuse.org -- Fix build 
against icu 5.9
+Patch12:webkitgtk-icu59.patch
 BuildRequires:  Mesa-devel
 BuildRequires:  bison
 BuildRequires:  chrpath
@@ -158,9 +160,9 @@
 %if %{_withwk2}
 %package -n libwebkit2gtk%{_wk2sover}
 Summary:Library for rendering web content, GTK+ Port
-Group:  System/Libraries
 # this will install the non-webkit2 library too; at some point, we should move
 # the Provides for %%{_pkgname_no_slpp} here
+Group:  System/Libraries
 Recommends: %{_pkgname_no_slpp}-lang = %{version}
 # Recommend the injected bundles
 Recommends: webkit2gtk-3_0-injected-bundles
@@ -327,6 +329,9 @@
 %patch10 -p1
 %endif
 %patch11 -p1
+if pkg-config --atleast-version=59 icu-i18n; then
+%patch12 -p1
+fi
 # FIXME: workaround needed in > 1.7.90 to fix build
 mkdir -p DerivedSources/webkit
 mkdir -p DerivedSources/WebCore

++ webkitgtk3.spec ++
--- /var/tmp/diff_new_pack.kBbZ9o/_old  2017-05-18 20:44:35.702802897 +0200
+++ /var/tmp/diff_new_pack.kBbZ9o/_new  2017-05-18 20:44:35.706802334 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package webkitgtk3
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -69,6 +69,8 @@
 Patch10:webkitgtk-ppc32.patch
 # PATCH-FIX-UPSTREAM webkitgtk-abs_to_fabs.patch dims...@opensuse.org -- Use 
fabs() instead of abs() on floating point values
 Patch11:webkitgtk-abs_to_fabs.patch
+# PATCH-FIx-UPSTREAM webkitgtk-icu59.patch dims...@opensuse.org -- Fix build 
against icu 5.9
+Patch12:webkitgtk-icu59.patch
 BuildRequires:  Mesa-devel
 BuildRequires:  bison
 BuildRequires:  chrpath
@@ -158,9 +160,9 @@
 %if %{_withwk2}
 %package -n libwebkit2gtk%{_wk2sover}
 Summary:Library for rendering web content, GTK+ Port
-Group:  System/Libraries
 # this will install the non-webkit2 library too; at some point, we should move
 # the Provides for %%{_pkgname_no_slpp} here
+Group:  System/Libraries
 Recommends: %{_pkgname_no_slpp}-lang = %{version}
 # Recommend the injected bundles
 Recommends: webkit2gtk-3_0-injected-bundles
@@ -327,6 +329,9 @@
 %patch10 -p1
 %endif
 %patch11 -p1
+if pkg-config --atleast-version=59 icu-i18n; then
+%patch12 -p1
+fi
 # FIXME: workaround needed in > 1.7.90 to fix build
 mkdir -p DerivedSources/webkit
 mkdir -p DerivedSources/WebCore

++ webkitgtk-icu59.patch ++
Index: webkitgtk-2.4.11/Source/JavaScriptCore/API/JSStringRef.h
===
--- webkitgtk-2.4.11.orig/Source/JavaScriptCore/API/JSStringRef.h
+++ webkitgtk-2.4.11/Source/JavaScriptCore/API/JSStringRef.h
@@ -32,6 +32,7 @@
 #include 
 #endif
 #include  /* for size_t */
+#include 
 
 #ifdef __cplusplus
 extern "C" {
@@ -43,7 +44,7 @@ extern "C" {
 @typedef JSChar
 @abstract A Unicode character.
 */
-typedef unsigned short JSChar;
+typedef char16_t JSChar;
 #else
 typedef 

commit corosync for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package corosync for openSUSE:Factory 
checked in at 2017-05-18 20:44:43

Comparing /work/SRC/openSUSE:Factory/corosync (Old)
 and  /work/SRC/openSUSE:Factory/.corosync.new (New)


Package is "corosync"

Thu May 18 20:44:43 2017 rev:37 rq:495135 version:2.4.2

Changes:

--- /work/SRC/openSUSE:Factory/corosync/corosync.changes2017-04-18 
13:46:42.833759350 +0200
+++ /work/SRC/openSUSE:Factory/.corosync.new/corosync.changes   2017-05-18 
20:44:47.453144630 +0200
@@ -1,0 +2,12 @@
+Tue May 16 03:05:05 UTC 2017 - b...@suse.com
+
+- totemrrp: Fix situation when all rings are faulty(bsc#1039215)
+   Added: 0003-totemrrp-Fix-situation-when-all-rings-are-faulty.patch
+
+---
+Tue May  9 04:17:35 UTC 2017 - b...@suse.com
+
+- calling mlockall before corosync_tty_detach is noop when corosync is 
executed as a daemon(bsc#1038147)
+   Added: 0002-Main-call-mlock-after-fork.patch
+
+---

New:

  0002-Main-call-mlock-after-fork.patch
  0003-totemrrp-Fix-situation-when-all-rings-are-faulty.patch



Other differences:
--
++ corosync.spec ++
--- /var/tmp/diff_new_pack.uKgSPT/_old  2017-05-18 20:44:48.632978127 +0200
+++ /var/tmp/diff_new_pack.uKgSPT/_new  2017-05-18 20:44:48.636977562 +0200
@@ -63,6 +63,8 @@
 Patch9: 0001-Logsys-Change-logsys-syslog_priority-priority.patch
 Patch10:0001-logconfig.c-make-logging.syslog_priority-and-logging.patch
 Patch11:0001-totemconfig.c-Fixed-Evicted-from-CPG-membership.patch
+Patch12:0002-Main-call-mlock-after-fork.patch
+Patch13:0003-totemrrp-Fix-situation-when-all-rings-are-faulty.patch
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 # openais is indeed gone and should be uninstalled. Yes, we do not
@@ -133,6 +135,8 @@
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
+%patch13 -p1
 
 %build
 %if %{with_runautogen}

++ 0002-Main-call-mlock-after-fork.patch ++
>From 3b89acd59f5113edb23ba41e2ce67f9c3b2880fb Mon Sep 17 00:00:00 2001
From: Bin Liu 
Date: Tue, 9 May 2017 11:17:51 +0800
Subject: [PATCH] Main: call mlock after fork

Man page of mlockall is clear:
Memory locks are not inherited by a child created via fork(2) and are
automatically removed (unlocked) during an execve(2) or when the
process terminates.

So calling mlockall before corosync_tty_detach is noop when corosync is
executed as a daemon (corosync -f was not affected).

This regression is caused by ed7d054
(setprio for logsys/qblog was correct, mlockall was not).

Solution is to move corosync_mlockall call on correct place.
---
 exec/main.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/exec/main.c b/exec/main.c
index 7d2dcf7c..b3fce95b 100644
--- a/exec/main.c
+++ b/exec/main.c
@@ -1201,8 +1201,6 @@ int main (int argc, char **argv, char **envp)
corosync_setscheduler ();
}
 
-   corosync_mlockall ();
-
/*
 * Other signals are registered later via qb_loop_signal_add
 */
@@ -1329,6 +1327,8 @@ int main (int argc, char **argv, char **envp)
corosync_tty_detach ();
}
 
+corosync_mlockall();
+
corosync_poll_handle = qb_loop_create ();
 
memset(_pause_timeout_data, 0, 
sizeof(scheduler_pause_timeout_data));
-- 
2.12.0

++ 0003-totemrrp-Fix-situation-when-all-rings-are-faulty.patch ++
>From eaa92765f1226f16ddb58f1baf3494b817726cb4 Mon Sep 17 00:00:00 2001
From: Bin Liu 
Date: Tue, 16 May 2017 10:49:23 +0800
Subject: [PATCH] totemrrp: Fix situation when all rings are faulty

Previously when all rings were marked as failed no message was sent via
any interface. This is problem because totemsrp relies on messages
delivered via localhost multicast loop socket so it never moved to
single node mode and it got stuck.

Solution is to send message via one of the interfaces (first one seems
to be obvious choice) if it was not sent via any interface.

Strictly speaking it should be enough to change just *_mcast_flush_send
functions, but changing others is just for sure.
---
 exec/totemrrp.c | 71 +
 1 file changed, 62 insertions(+), 9 deletions(-)

diff --git a/exec/totemrrp.c b/exec/totemrrp.c
index 0d9a58d5..15ba7766 100644
--- a/exec/totemrrp.c
+++ b/exec/totemrrp.c
@@ -1002,7 +1002,7 @@ static void passive_monitor (
}
 
/*
-* Max is larger then threshold -> start adjusting process
+* Max is larger than threshold -> start adjusting process
 */
if (max > PASSIVE_RECV_COUNT_THRESHOLD) {
 

commit libvirt for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libvirt for openSUSE:Factory checked 
in at 2017-05-18 20:44:37

Comparing /work/SRC/openSUSE:Factory/libvirt (Old)
 and  /work/SRC/openSUSE:Factory/.libvirt.new (New)


Package is "libvirt"

Thu May 18 20:44:37 2017 rev:228 rq:495126 version:3.3.0

Changes:

--- /work/SRC/openSUSE:Factory/libvirt/libvirt.changes  2017-05-04 
08:54:47.389707110 +0200
+++ /work/SRC/openSUSE:Factory/.libvirt.new/libvirt.changes 2017-05-18 
20:44:42.333867089 +0200
@@ -1,0 +2,31 @@
+Mon May 15 21:21:56 UTC 2017 - jfeh...@suse.com
+
+- qemu: add support for 288 VCPUS
+  aeda1b8c-qemu-no-error-shutdown.patch,
+  8023b21a-conf-ioapic.patch,
+  6b5c6314-qemu-irqchip.patch,
+  2020e2c6-conf-intremap.patch,
+  04028a9d-qemu-intremap.patch,
+  d12781b4-conf-iommu-cache-mode-attr.patch,
+  a5691448-qemu-iommu-cache-mode.patch,
+  3a276c65-conf-iommu-def-stability-check.patch,
+  935d927a-conf-iommu-ABI-stability-check.patch
+  FATE#321335
+- revert commit 2841e675: qemu: propagate bridge MTU into qemu
+  "host_mtu"
+  revert-2841e675-mtu.patch
+  bsc#1037774
+
+---
+Mon May  8 16:44:59 UTC 2017 - jfeh...@suse.com
+
+-  Update to libvirt 3.3.0
+  - Many incremental improvements and bug fixes, see
+http://libvirt.org/news.html
+  - Bug fixes:
+bsc#978121, bsc#1017017, bsc#1032863, bsc#1033117, bsc#1034024,
+bsc#1034146, bsc#1035995
+- libxl: updated libxl-def-usbctrl.patch
+  bsc#1031056
+
+---

New:

  04028a9d-qemu-intremap.patch
  2020e2c6-conf-intremap.patch
  3a276c65-conf-iommu-def-stability-check.patch
  6b5c6314-qemu-irqchip.patch
  8023b21a-conf-ioapic.patch
  935d927a-conf-iommu-ABI-stability-check.patch
  a5691448-qemu-iommu-cache-mode.patch
  aeda1b8c-qemu-no-error-shutdown.patch
  d12781b4-conf-iommu-cache-mode-attr.patch
  revert-2841e675-mtu.patch



Other differences:
--
++ libvirt.spec ++
--- /var/tmp/diff_new_pack.lrwP37/_old  2017-05-18 20:44:43.569692683 +0200
+++ /var/tmp/diff_new_pack.lrwP37/_new  2017-05-18 20:44:43.573692118 +0200
@@ -317,6 +317,15 @@
 Source99:   baselibs.conf
 Source100:  %{name}-rpmlintrc
 # Upstream patches
+Patch0: aeda1b8c-qemu-no-error-shutdown.patch
+Patch1: 8023b21a-conf-ioapic.patch
+Patch2: 6b5c6314-qemu-irqchip.patch
+Patch3: 2020e2c6-conf-intremap.patch
+Patch4: 04028a9d-qemu-intremap.patch
+Patch5: d12781b4-conf-iommu-cache-mode-attr.patch
+Patch6: a5691448-qemu-iommu-cache-mode.patch
+Patch7: 3a276c65-conf-iommu-def-stability-check.patch
+Patch8: 935d927a-conf-iommu-ABI-stability-check.patch
 # Patches pending upstream review
 Patch100:   libxl-dom-reset.patch
 Patch101:   network-don-t-use-dhcp-authoritative-on-static-netwo.patch
@@ -329,6 +338,7 @@
 Patch154:   libxl-set-migration-constraints.patch
 Patch155:   libxl-set-cach-mode.patch
 Patch156:   apparmor-fixes.patch
+Patch157:   revert-2841e675-mtu.patch
 # Our patches
 Patch200:   libvirtd-defaults.patch
 Patch201:   libvirtd-init-script.patch
@@ -886,6 +896,15 @@
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 %patch100 -p1
 %patch101 -p1
 %patch102 -p1
@@ -896,6 +915,7 @@
 %patch154 -p1
 %patch155 -p1
 %patch156 -p1
+%patch157 -p1
 %patch200 -p1
 %patch201 -p1
 %patch202 -p1

++ 04028a9d-qemu-intremap.patch ++
 686 lines (skipped)

++ 2020e2c6-conf-intremap.patch ++
commit 2020e2c6f2656ca1aa9032859ccde76185c37c39
Author: Ján Tomko 
Date:   Fri Mar 17 08:35:22 2017 +0100

conf: add  to 

Add a new attribute to control interrupt remapping.

https://bugzilla.redhat.com/show_bug.cgi?id=1427005

Index: libvirt-3.3.0/docs/formatdomain.html.in
===
--- libvirt-3.3.0.orig/docs/formatdomain.html.in
+++ libvirt-3.3.0/docs/formatdomain.html.in
@@ -7396,7 +7396,9 @@ qemu-kvm -net nic,model=? /dev/null
 
 ...
 devices
-  iommu model='intel'/
+  iommu model='intel'
+driver intremap='on'/
+  /iommu
 /devices
 ...
 
@@ -7407,6 +7409,26 @@ qemu-kvm -net nic,model=? /dev/null
   Currently only the intel model is supported.
 
   
+  driver
+  
+
+  The driver subelement can be used to configure
+  additional options:
+
+
+  intremap
+  
+
+  The intremap attribute with possible values
+  on and off can be used to
+  turn on interrupt 

commit openmpi for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package openmpi for openSUSE:Factory checked 
in at 2017-05-18 20:44:15

Comparing /work/SRC/openSUSE:Factory/openmpi (Old)
 and  /work/SRC/openSUSE:Factory/.openmpi.new (New)


Package is "openmpi"

Thu May 18 20:44:15 2017 rev:59 rq:494517 version:1.10.6

Changes:

--- /work/SRC/openSUSE:Factory/openmpi/openmpi-testsuite.changes
2016-11-24 23:15:28.0 +0100
+++ /work/SRC/openSUSE:Factory/.openmpi.new/openmpi-testsuite.changes   
2017-05-18 20:44:19.273121535 +0200
@@ -1,0 +2,80 @@
+Wed May 10 11:33:56 UTC 2017 - jeng...@inai.de
+
+- Make description more objective
+
+---
+Tue May  9 14:27:55 UTC 2017 - nmoreychaisemar...@suse.com
+
+- Unify spec with SLE12
+- Use upstream git repo to fetch source tarball 
+
+---
+Tue Apr 25 13:37:10 UTC 2017 - nmoreychaisemar...@suse.com
+
+- Add openmpi-etc-files.patch to update config files so they
+  match files from OpenMPI2
+
+---
+Wed Mar 29 08:16:29 CEST 2017 - p...@suse.de
+
+- Make dependencies on libs now coming from rdma-core versioned.
+- Add new file to files section.
+
+---
+Fri Mar 17 15:36:25 CET 2017 - p...@suse.de
+
+- Update to 1.10.6 (fate#321475)
+  Changes since 1.10.3:
+  1.10.6:
+  - Fix bug in timer code that caused problems at optimization settings
+greater than 2
+  - OSHMEM: make mmap allocator the default instead of sysv or verbs
+  - Support MPI_Dims_create with dimension zero
+  - Update USNIC support
+  - Prevent 64-bit overflow on timer counter
+  - Add support for forwarding signals
+  - Fix bug that caused truncated messages on large sends over TCP BTL
+  - Fix potential infinite loop when printing a stacktrace
+
+  1.10.5:
+  - Update UCX APIs
+  - Fix bug in darray that caused MPI/IO failures
+  - Use a MPI_Get_library_version() like string to tag the debugger DLL.
+Thanks to Alastair McKinstry for the report
+  - Fix multi-threaded race condition in coll/libnbc
+  - Several fixes to OSHMEM
+  - Fix bug in UCX support due to uninitialized field
+  - Fix MPI_Ialltoallv with MPI_IN_PLACE and without MPI param check
+  - Correctly reset receive request type before init. Thanks Chris Pattison
+for the report and test case.
+  - Fix bug in iallgather[v]
+  - Fix concurrency issue with MPI_Comm_accept. Thanks to Pieter Noordhuis
+for the patch
+  - Fix ompi_coll_base_{gather,scatter}_intra_binomial
+  - Fixed an issue with MPI_Type_get_extent returning the wrong extent
+for distributed array datatypes.
+  - Re-enable use of rtdtsc instruction as a monotonic clock source if
+the processor has a core-invariant tsc. This is a partial fix for a
+performance regression introduced in Open MPI v1.10.3.
+
+  1.10.4:
+  - Fix assembler support for MIPS
+  - Improve memory handling for temp buffers in collectives
+  - Fix [all]reduce with non-zero lower bound datatypes
+Thanks Hristo Iliev for the report
+  - Fix non-standard ddt handling. Thanks Yuki Matsumoto for the report
+  - Various libnbc fixes. Thanks Yuki Matsumoto for the report
+  - Fix typos in request RMA bindings for Fortran. Thanks to @alazzaro
+and @vondele for the assist
+  - Various bug fixes and enhancements to collective support
+  - Fix predefined types mapping in hcoll
+  - Revive the coll/sync component to resolve unexpected message issues
+during tight loops across collectives
+  - Fix typo in wrapper compiler for Fortran static builds
+
+---
+Mon Nov 28 14:19:45 CET 2016 - p...@suse.de
+
+- Remove spurious characters from environment module (bsc#1012380).
+
+---
@@ -6,0 +87,12 @@
+Wed Oct 12 16:22:50 CEST 2016 - p...@suse.de
+
+- Remove the Conflicts as the packages don't conflict anymore.
+- Move the plugins (modules) to openmpi-libs (bsc#1003090).
+
+---
+Fri Sep 23 08:00:01 CEST 2016 - p...@suse.de
+
+- Add a missing Conflicts: for openmpi-compat (bsc#16 bsc#982458)
+
+---
+
@@ -18,0 +111,91 @@
+Wed Jul 27 08:01:25 CEST 2016 - p...@suse.de
+
+- instead of adding to the list of architectures that don't build
+  help-opal-timer-linux.txt include it exclusively for ix86 and x86_64
+  (bsc#990790).
+
+---
+Tue Jul 19 08:56:10 CEST 2016 - p...@suse.de
+
+- Update to 1.10.3, last of the 1.10 releases (bsc#988787) : 
+  * Fix zero-length datatypes.
+  

commit libqt5-qtwebkit for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libqt5-qtwebkit for openSUSE:Factory 
checked in at 2017-05-18 20:44:22

Comparing /work/SRC/openSUSE:Factory/libqt5-qtwebkit (Old)
 and  /work/SRC/openSUSE:Factory/.libqt5-qtwebkit.new (New)


Package is "libqt5-qtwebkit"

Thu May 18 20:44:22 2017 rev:41 rq:494618 version:5.7.1

Changes:

--- /work/SRC/openSUSE:Factory/libqt5-qtwebkit/libqt5-qtwebkit.changes  
2016-12-22 16:08:19.286418345 +0100
+++ /work/SRC/openSUSE:Factory/.libqt5-qtwebkit.new/libqt5-qtwebkit.changes 
2017-05-18 20:44:23.864473581 +0200
@@ -1,0 +2,6 @@
+Wed May 10 17:36:58 UTC 2017 - fab...@ritter-vogt.de
+
+- Add patch to fix build with ICU4C >= 59:
+  * fix-build-icu59.patch
+
+---

New:

  fix-build-icu59.patch



Other differences:
--
++ libqt5-qtwebkit.spec ++
--- /var/tmp/diff_new_pack.Ok4TrD/_old  2017-05-18 20:44:24.964318366 +0200
+++ /var/tmp/diff_new_pack.Ok4TrD/_new  2017-05-18 20:44:24.968317801 +0200
@@ -45,6 +45,8 @@
 Patch4: 7dac8c2d5f743563df76c2347c6ad394b6779ffc.patch
 # PATCH-FIX-OPENSUSE 05-fix-linker-errors.diff cgiboude...@gmx.com -- Fix 
linking errors
 Patch5: 05-fix-linker-errors.diff
+# PATCH-FIX-UPSTREAM fix-build-icu59.patch
+Patch6: fix-build-icu59.patch
 # PATCH-MISSING-TAG -- See 
http://wiki.opensuse.org/openSUSE:Packaging_Patches_guidelines
 Patch130:   no-Werror-rpath.diff
 
@@ -122,6 +124,7 @@
 %patch3 -p1
 %patch4 -Rp1
 %patch5 -p1
+%patch6 -p1
 %patch130 -p1
 
 %package -n %libname

++ fix-build-icu59.patch ++
>From 868adfcb9efa4ad5cf4d0ddd5a772e5bdb2f3f35 Mon Sep 17 00:00:00 2001
From: "annu...@yandex.ru"
 
Date: Thu, 4 May 2017 15:33:41 +
Subject: [PATCH] Fix compilation with ICU 59.1
 https://bugs.webkit.org/show_bug.cgi?id=171612

Reviewed by Mark Lam.

ICU 59.1 has broken source compatibility. Now it defines UChar as
char16_t, which does not allow automatic type conversion from unsigned
short in C++ code.

Source/JavaScriptCore:

* API/JSStringRef.cpp:
(JSStringCreateWithCharacters):
(JSStringCreateWithCharactersNoCopy):
(JSStringGetCharactersPtr):
* runtime/DateConversion.cpp:
(JSC::formatDateTime):

Source/WebKit2:

* Shared/API/c/WKString.cpp:
(WKStringGetCharacters):

Tools:

* TestRunnerShared/UIScriptContext/UIScriptContext.cpp:
(UIScriptContext::tryToCompleteUIScriptForCurrentParentCallback):


git-svn-id: http://svn.webkit.org/repository/webkit/trunk@216187 
268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
 Source/JavaScriptCore/API/JSStringRef.cpp|6 +++---
 Source/JavaScriptCore/runtime/DateConversion.cpp |3 ++-
 Source/WTF/wtf/TypeTraits.h  |1 +
 Source/WebKit2/Shared/API/c/WKString.cpp |2 +-
 4 files changed, 7 insertions(+), 5 deletions(-)

--- a/Source/JavaScriptCore/API/JSStringRef.cpp
+++ b/Source/JavaScriptCore/API/JSStringRef.cpp
@@ -37,7 +37,7 @@ using namespace WTF::Unicode;
 JSStringRef JSStringCreateWithCharacters(const JSChar* chars, size_t numChars)
 {
 initializeThreading();
-return OpaqueJSString::create(chars, numChars).leakRef();
+return OpaqueJSString::create(reinterpret_cast(chars), 
numChars).leakRef();
 }
 
 JSStringRef JSStringCreateWithUTF8CString(const char* string)
@@ -62,7 +62,7 @@ JSStringRef JSStringCreateWithUTF8CStrin
 JSStringRef JSStringCreateWithCharactersNoCopy(const JSChar* chars, size_t 
numChars)
 {
 initializeThreading();
-return OpaqueJSString::create(StringImpl::createWithoutCopying(chars, 
numChars, WTF::DoesNotHaveTerminatingNullCharacter)).leakRef();
+return 
OpaqueJSString::create(StringImpl::createWithoutCopying(reinterpret_cast(chars), numChars, WTF::DoesNotHaveTerminatingNullCharacter)).leakRef();
 }
 
 JSStringRef JSStringRetain(JSStringRef string)
@@ -83,7 +83,7 @@ size_t JSStringGetLength(JSStringRef str
 
 const JSChar* JSStringGetCharactersPtr(JSStringRef string)
 {
-return string->characters();
+return reinterpret_cast(string->characters());
 }
 
 size_t JSStringGetMaximumUTF8CStringSize(JSStringRef string)
--- a/Source/JavaScriptCore/runtime/DateConversion.cpp
+++ b/Source/JavaScriptCore/runtime/DateConversion.cpp
@@ -107,7 +107,8 @@ String formatDateTime(const GregorianDat
 #if OS(WINDOWS)
 TIME_ZONE_INFORMATION timeZoneInformation;
 GetTimeZoneInformation();
-const WCHAR* timeZoneName = t.isDST() ? 
timeZoneInformation.DaylightName : timeZoneInformation.StandardName;
+const WCHAR* winTimeZoneName = t.isDST() ? 
timeZoneInformation.DaylightName : timeZoneInformation.StandardName;
+String 

commit libqt4 for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libqt4 for openSUSE:Factory checked 
in at 2017-05-18 20:44:07

Comparing /work/SRC/openSUSE:Factory/libqt4 (Old)
 and  /work/SRC/openSUSE:Factory/.libqt4.new (New)


Package is "libqt4"

Thu May 18 20:44:07 2017 rev:220 rq:494381 version:4.8.7

Changes:

libqt4-sql-plugins.changes: same change
--- /work/SRC/openSUSE:Factory/libqt4/libqt4.changes2017-03-09 
01:28:06.467062864 +0100
+++ /work/SRC/openSUSE:Factory/.libqt4.new/libqt4.changes   2017-05-18 
20:44:08.862590720 +0200
@@ -1,0 +2,6 @@
+Wed May 10 09:04:37 UTC 2017 - fab...@ritter-vogt.de
+
+- Add fix-build-icu59.patch to fix building with ICU4C >= 59
+- Invoke configure with sh to fix build on some older distros
+
+---

New:

  fix-build-icu59.patch



Other differences:
--
libqt4-sql-plugins.spec: same change
++ libqt4.spec ++
--- /var/tmp/diff_new_pack.gJWzJw/_old  2017-05-18 20:44:14.177840606 +0200
+++ /var/tmp/diff_new_pack.gJWzJw/_new  2017-05-18 20:44:14.181840042 +0200
@@ -144,6 +144,8 @@
 Patch168:   fix-gcc6-detection.diff
 # PATCH-FIX-UPSTREAM fix-moc-parsing-with-glibc-2.25.patch -- Fixes moc 
parsing correctly glibc 2.25 system headers
 Patch169:   fix-moc-parsing-with-glibc-2.25.patch
+# PATCH-FIX-OPENSUSE fix-build-icu59.patch -- Workaround C++11 requirement
+Patch170:   fix-build-icu59.patch
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
   %define common_options --opensource -fast -no-separate-debug-info -shared 
-xkb -openssl-linked -xrender -xcursor -dbus-linked -xfixes -xrandr -xinerama 
-sm -no-nas-sound -no-rpath -system-libjpeg -system-libpng -accessibility -cups 
-stl -nis -system-zlib -prefix /usr -L %{_libdir} -libdir %{_libdir} -docdir 
%_docdir/%{base_name} -examplesdir %{_libdir}/qt4/examples -demosdir 
%{_libdir}/qt4/demos -plugindir %plugindir -translationdir 
%{_datadir}/qt4/translations -iconv -sysconfdir /etc/settings -datadir 
%{_datadir}/qt4/ -no-pch -reduce-relocations -exceptions -system-libtiff -glib 
-optimized-qmake -no-webkit -no-xmlpatterns -system-sqlite -qt3support 
-no-sql-mysql -importdir %plugindir/imports  -xsync -xinput -gtkstyle
@@ -457,6 +459,7 @@
 %patch167 -p1
 %patch168 -p1
 %patch169 -p1
+%patch170 -p1
 
 # be sure not to use them
 rm -rf src/3rdparty/{libjpeg,freetype,libpng,zlib,libtiff,fonts}
@@ -482,7 +485,7 @@
 CHANGES=`stat --format="%y" %{SOURCE1}|cut --characters=1-10`
 sed -i -e "s/qt_instdate=\$TODAY/qt_instdate=$CHANGES/" configure
 
-echo yes | ./configure %common_options $platform \
+echo yes | sh ./configure %common_options $platform \
-plugin-sql-sqlite -nomake examples -nomake demos -nomake docs \
 %ifarch %arm
   -no-neon \



++ fix-build-icu59.patch ++
From: Fabian Vogt 
Subject: Fix build with ICU >= 59

This works around the C++11 requirement of ICU4C >= 59,
resulting in
/usr/include/unicode/umachine.h:347:13: error: 'char16_t' does not name a type
and ultimately:
/usr/include/unicode/uversion.h:167:55: error: 'UChar' does not name a type

---
 src/corelib/tools/qlocale_icu.cpp |3 +++
 1 file changed, 3 insertions(+)

--- a/src/corelib/tools/qlocale_icu.cpp
+++ b/src/corelib/tools/qlocale_icu.cpp
@@ -43,6 +43,9 @@
 #include "qlibrary.h"
 #include "qdebug.h"
 
+// ICU59 requires C++11, work around that
+typedef qint16 char16_t;
+
 #include "unicode/uversion.h"
 #include "unicode/ucol.h"
 




commit webkit2gtk3 for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package webkit2gtk3 for openSUSE:Factory 
checked in at 2017-05-18 20:43:59

Comparing /work/SRC/openSUSE:Factory/webkit2gtk3 (Old)
 and  /work/SRC/openSUSE:Factory/.webkit2gtk3.new (New)


Package is "webkit2gtk3"

Thu May 18 20:43:59 2017 rev:37 rq:494224 version:2.16.2

Changes:

--- /work/SRC/openSUSE:Factory/webkit2gtk3/webkit2gtk3.changes  2017-04-29 
10:48:27.227206911 +0200
+++ /work/SRC/openSUSE:Factory/.webkit2gtk3.new/webkit2gtk3.changes 
2017-05-18 20:44:01.911571681 +0200
@@ -1,0 +2,13 @@
+Tue May  9 23:32:25 UTC 2017 - zai...@opensuse.org
+
+- Update to version 2.16.2:
+  + Update user agent quirks to make Youtube and new Google login
+page work.
+  + Fix rendering of animated PNGs.
+  + Fix playing of some live streams.
+  + Update several web inspector icons.
+  + Fix the build with NPAPI plugins enabled but X11 disabled.
+  + Fix the build with OpenGL disabled.
+  + Fix several crashes and rendering issues.
+
+---

Old:

  webkitgtk-2.16.1.tar.xz

New:

  webkitgtk-2.16.2.tar.xz



Other differences:
--
++ webkit2gtk3.spec ++
--- /var/tmp/diff_new_pack.1AcH7S/_old  2017-05-18 20:44:05.703036611 +0200
+++ /var/tmp/diff_new_pack.1AcH7S/_new  2017-05-18 20:44:05.707036047 +0200
@@ -26,7 +26,7 @@
 %define _pkgconfig_suffix gtk-3.0
 %define _name webkitgtk
 Name:   webkit2gtk3
-Version:2.16.1
+Version:2.16.2
 Release:0
 Summary:Library for rendering web content, GTK+ Port
 License:LGPL-2.0+ and BSD-3-Clause

++ webkitgtk-2.16.1.tar.xz -> webkitgtk-2.16.2.tar.xz ++
/work/SRC/openSUSE:Factory/webkit2gtk3/webkitgtk-2.16.1.tar.xz 
/work/SRC/openSUSE:Factory/.webkit2gtk3.new/webkitgtk-2.16.2.tar.xz differ: 
char 26, line 1




commit libibmad for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libibmad for openSUSE:Factory 
checked in at 2017-05-18 20:43:48

Comparing /work/SRC/openSUSE:Factory/libibmad (Old)
 and  /work/SRC/openSUSE:Factory/.libibmad.new (New)


Package is "libibmad"

Thu May 18 20:43:48 2017 rev:4 rq:494088 version:1.3.13

Changes:

--- /work/SRC/openSUSE:Factory/libibmad/libibmad.changes2015-11-08 
11:25:03.0 +0100
+++ /work/SRC/openSUSE:Factory/.libibmad.new/libibmad.changes   2017-05-18 
20:43:52.608884521 +0200
@@ -2 +2 @@
-Tue Nov  3 21:14:06 UTC 2015 - p.drou...@gmail.com
+Tue May  9 16:25:29 UTC 2017 - nmoreychaisemar...@suse.com
@@ -4,13 +4,5 @@
-- Update to version 1.3.12
-  * fields.c: Fix commentary typo
-  * libibmad/src/rpc.c: Remove superfluous packet dump
-  * fields.c: Print SwitchCongestionSetting threshold fields in hex
-rather than decimal
-  * libibmad: Add new fields for SM:PortInfoExtended and for
-PM:PortExtendedSpeedsCounters
-  * dump.c: In mad_dump_linkwidth, output undefined widths
-- Drop useless dependencies
-  * automake
-  * autoconf 
-  * libtool
-- Do not call autogen anymore
+- Update to version 1.3.13 (bsc#1016427)
+* libibmad: Fix conflict with new umad.h header
+* configure.ac: Update AM_INIT_AUTOMAKE to use subdir-objects
+* configure.ac: Update configure.in to configure.ac
+* libibmad: Makefile.am: Fix INCLUDES warning
@@ -19 +11 @@
-Thu Jun 26 12:48:54 CEST 2014 - p...@suse.de
+Wed Mar 29 11:10:13 CEST 2017 - p...@suse.de
@@ -21,2 +13 @@
-- Add baselibs.conf as source.
-- Don't package the static labrary.
+- Don't package the static library.
@@ -25 +16 @@
-Wed Jun 25 11:07:01 CEST 2014 - p...@suse.de
+Wed Mar 29 08:04:34 CEST 2017 - p...@suse.de
@@ -27 +18,8 @@
-- Provide full source URL.
+- Change dependencies to rdma-core-devel.
+
+---
+Mon Mar  7 13:31:21 CET 2016 - p...@suse.de
+
+- Update to 13.12-git93456bc as it's required for updating
+  infiniband-diags (fate#319248). For changes see included ChangeLog.
+- Tag basewlibs.conf as source
@@ -43 +41 @@
-- License is GPL-2.0 or BSD-2-Clause.
+- Lisence iks GPL-2.0 or BSD-2-Clause.

Old:

  libibmad-1.3.12.tar.gz

New:

  libibmad-1.3.13.tar.gz



Other differences:
--
++ libibmad.spec ++
--- /var/tmp/diff_new_pack.T3kfhW/_old  2017-05-18 20:43:53.276790262 +0200
+++ /var/tmp/diff_new_pack.T3kfhW/_new  2017-05-18 20:43:53.280789698 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libibmad
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,17 +15,24 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define mad_so 5
+%define git_ver %{nil}
 
 Name:   libibmad
 Summary:Low layer Infiniband diagnostic and management programs
-Version:1.3.12
-Release:0
 License:GPL-2.0 or BSD-2-Clause
 Group:  Productivity/Networking/System
-Source0:
https://www.openfabrics.org/downloads/management/libibmad-%{version}.tar.gz
+Version:1.3.13
+Release:0
+Source0:libibmad-%{version}%{git_ver}.tar.gz
 Source1:baselibs.conf
 Url:http://www.openfabrics.org
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  autoconf
+BuildRequires:  automake
+BuildRequires:  libtool
+
 %description
 Libibmad provides low layer IB functions for use by the IB diagnostic
 and management programs. These include MAD, SA, SMP, and other basic IB
@@ -34,7 +41,7 @@
 %package -n %{name}%{mad_so}
 Summary:Libibamd runtime library
 Group:  System/Libraries
-BuildRequires:  libibumad-devel
+BuildRequires:  rdma-core-devel
 
 %description -n %{name}%{mad_so}
 Libibmad provides low layer IB functions for use by the IB diagnostic
@@ -42,25 +49,26 @@
 functions. This package contains the runtime library.
 
 %packagedevel
-Group:  Development/Libraries/C and C++
 Summary:Development files for the libibmad library
+Group:  Development/Libraries/C and C++
 Requires:   %{name}%{mad_so} = %{version}
-Requires:   libibumad-devel
+Requires:   rdma-core-devel
 
 %descriptiondevel
 Development files for the libibmad library.
 
 %prep
 %setup -q
+./autogen.sh
 
 %build
-%configure --disable-static
+%configure
 make %{?_smp_mflags}
 
 %install
-%makeinstall
+make DESTDIR=%{buildroot} install
+rm -f %{buildroot}%_libdir/libibmad.a %{buildroot}%_libdir/libibmad.la
 
-rm -f 

commit skelcd-openSUSE for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package skelcd-openSUSE for openSUSE:Factory 
checked in at 2017-05-18 20:42:11

Comparing /work/SRC/openSUSE:Factory/skelcd-openSUSE (Old)
 and  /work/SRC/openSUSE:Factory/.skelcd-openSUSE.new (New)


Package is "skelcd-openSUSE"

Thu May 18 20:42:11 2017 rev:94 rq:493480 version:84.87.20170508.effa251

Changes:

--- /work/SRC/openSUSE:Factory/skelcd-openSUSE/skelcd-openSUSE.changes  
2017-03-21 22:43:51.387070075 +0100
+++ /work/SRC/openSUSE:Factory/.skelcd-openSUSE.new/skelcd-openSUSE.changes 
2017-05-18 20:42:12.990943047 +0200
@@ -1,0 +2,8 @@
+Mon May 08 15:25:38 UTC 2017 - lnus...@suse.de
+
+- Update to version 84.87.20170508.effa251:
+  * Translated using Weblate (Chinese (Taiwan))
+  * add new icon
+  * add .ico icon
+
+---

Old:

  skelcd-openSUSE-84.87.20161221.22db9c6.tar.xz

New:

  skelcd-openSUSE-84.87.20170508.effa251.tar.xz



Other differences:
--
++ skelcd-openSUSE.spec ++
--- /var/tmp/diff_new_pack.zdp8zf/_old  2017-05-18 20:42:13.550864029 +0200
+++ /var/tmp/diff_new_pack.zdp8zf/_new  2017-05-18 20:42:13.554863464 +0200
@@ -16,7 +16,7 @@
 #
 
 
-%define version_unconverted 84.87.20161221.22db9c6
+%define version_unconverted 84.87.20170508.effa251
 
 Name:   skelcd-openSUSE
 BuildRequires:  build-key
@@ -27,7 +27,7 @@
 BuildRequires:  translate-toolkit
 %endif
 Conflicts:  skelcd-sles skelcd-sled skelcd-openSUSE-non-OSS 
skelcd-openSUSE-non-OSS-CD
-Version:84.87.20161221.22db9c6
+Version:84.87.20170508.effa251
 Release:0
 Summary:Skeleton for openSUSE OSS Media Sets
 License:MIT

++ _servicedata ++
--- /var/tmp/diff_new_pack.zdp8zf/_old  2017-05-18 20:42:13.602856691 +0200
+++ /var/tmp/diff_new_pack.zdp8zf/_new  2017-05-18 20:42:13.602856691 +0200
@@ -1,4 +1,4 @@
 
 
 git://github.com/openSUSE/skelcd-openSUSE.git
-  22db9c604e3608fb12a8685b0c9dd6ab63f06679
\ No newline at end of file
+  c9fab9ba67328d315be204b44a4610dab8dcfda8
\ No newline at end of file

++ skelcd-openSUSE-84.87.20161221.22db9c6.tar.xz -> 
skelcd-openSUSE-84.87.20170508.effa251.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/skelcd-openSUSE-84.87.20161221.22db9c6/license/license.zh_TW.po 
new/skelcd-openSUSE-84.87.20170508.effa251/license/license.zh_TW.po
--- old/skelcd-openSUSE-84.87.20161221.22db9c6/license/license.zh_TW.po 
2016-12-21 13:35:46.0 +0100
+++ new/skelcd-openSUSE-84.87.20170508.effa251/license/license.zh_TW.po 
2017-05-08 17:25:01.0 +0200
@@ -4,8 +4,8 @@
 "Project-Id-Version: PACKAGE VERSION\n"
 "Report-Msgid-Bugs-To: \n"
 "POT-Creation-Date: 2016-08-31 11:11+0200\n"
-"PO-Revision-Date: 2016-11-07 11:42+\n"
-"Last-Translator: Max Lin \n"
+"PO-Revision-Date: 2017-04-17 02:59+\n"
+"Last-Translator: Fun MR \n"
 "Language-Team: Chinese (Taiwan) \n"
 "Language: zh_TW\n"
@@ -163,6 +163,13 @@
 "page www.bis.doc.gov before exporting items subject to the EAR. It is your\n"
 "responsibility to obtain any necessary export approvals."
 msgstr ""
+"您必須承認 openSUSE #VERSION# 受美國出口管理條例 ( 英文簡稱「EAR」) 以及您同意遵守該條例。您不能將 openSUSE "
+"#VERSION# 直接或間接出口及轉口到︰(一)受美國限制出口的國家。;(二)任何您知道或有理由知道該最終用戶將使用 openSUSE "
+"#VERSION# 設計及研製核子、化學或生物武器或火箭系統,太空運載火箭、探空火箭或無人駕駛飛機系統。經有關政府機關按規定或特淮的車輛系統則除外。;或者"
+"是(三)任何受美國政府聯邦機構禁止參加美國出口貿易的最終用戶。通過下載或使用 openSUSE #VERSION#,您將同意上述內容,您亦代表及保證您並非"
+"身處當地或受任何此類國家的控制之下,或並非屬於此類國家或此類列表的國民或居民。此外,您有責任遵守您所在司法管轄區的任何當地法律,這可能會影響您進口,"
+"出口或使用 openSUSE #VERSION# 的權利。在出口受制於EAR的物品之前,請諮詢工業和安全局網頁 "
+"www.bis.doc.gov。您有責任獲取任何必要的出口許可。"
 
 #: license/TEMPLATE:88
 #| msgid ""
Binary files old/skelcd-openSUSE-84.87.20161221.22db9c6/skelcd/SuSEgo.ico and 
new/skelcd-openSUSE-84.87.20170508.effa251/skelcd/SuSEgo.ico differ
Binary files old/skelcd-openSUSE-84.87.20161221.22db9c6/skelcd/SuSEgo.png and 
new/skelcd-openSUSE-84.87.20170508.effa251/skelcd/SuSEgo.png differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/skelcd-openSUSE-84.87.20161221.22db9c6/skelcd/SuSEgo.svg 
new/skelcd-openSUSE-84.87.20170508.effa251/skelcd/SuSEgo.svg
--- old/skelcd-openSUSE-84.87.20161221.22db9c6/skelcd/SuSEgo.svg
1970-01-01 01:00:00.0 +0100
+++ new/skelcd-openSUSE-84.87.20170508.effa251/skelcd/SuSEgo.svg
2017-05-08 17:25:01.0 +0200
@@ -0,0 +1,158 @@
+
+
+
+http://purl.org/dc/elements/1.1/;
+   xmlns:cc="http://creativecommons.org/ns#;
+   xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#;
+   

commit infinipath-psm for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package infinipath-psm for openSUSE:Factory 
checked in at 2017-05-18 20:42:21

Comparing /work/SRC/openSUSE:Factory/infinipath-psm (Old)
 and  /work/SRC/openSUSE:Factory/.infinipath-psm.new (New)


Package is "infinipath-psm"

Thu May 18 20:42:21 2017 rev:10 rq:494010 version:3.3

Changes:

--- /work/SRC/openSUSE:Factory/infinipath-psm/infinipath-psm.changes
2017-05-03 15:52:49.589188175 +0200
+++ /work/SRC/openSUSE:Factory/.infinipath-psm.new/infinipath-psm.changes   
2017-05-18 20:42:25.057240201 +0200
@@ -1,0 +2,10 @@
+Tue May  9 11:47:47 UTC 2017 - nmoreychaisemar...@suse.com
+
+- Drop conflicts with libpsm2-compat
+
+---
+Mon May  1 16:00:39 UTC 2017 - nmoreychaisemar...@suse.com
+
+- Update to v3.3-26-g604758. (bsc#1036485)
+
+---
@@ -9 +19 @@
-- Update to latest version (fate#320170). 
+- Update to latest version (fate#320170, bsc#943853). 

Old:

  infinipath-psm-3.3-25_g326b95a.tar.gz

New:

  infinipath-psm-3.3-26_g604758e.tar.gz



Other differences:
--
++ infinipath-psm.spec ++
--- /var/tmp/diff_new_pack.h5WOKs/_old  2017-05-18 20:42:25.617161182 +0200
+++ /var/tmp/diff_new_pack.h5WOKs/_new  2017-05-18 20:42:25.621160618 +0200
@@ -16,7 +16,7 @@
 #
 
 
-%define my_release -25_g326b95a
+%define my_release -26_g604758e
 
 Name:   infinipath-psm
 Version:3.3
@@ -35,7 +35,6 @@
 Patch3: infinipath-psm-executable_headers.patch
 BuildRequires:  libuuid-devel
 Conflicts:  infinipath-libs
-Conflicts:  libpsm2-compat
 ExclusiveArch:  %ix86 x86_64
 
 %define so_major 4
@@ -57,7 +56,6 @@
 Requires:   %{lname} = %{version}
 Requires:   libuuid-devel
 Conflicts:  infinipath-devel
-Conflicts:  libpsm2-devel
 
 %description devel
 Development files for the libpsm_infinipath library

++ _service ++
--- /var/tmp/diff_new_pack.h5WOKs/_old  2017-05-18 20:42:25.657155538 +0200
+++ /var/tmp/diff_new_pack.h5WOKs/_new  2017-05-18 20:42:25.661154974 +0200
@@ -5,8 +5,8 @@
 no
 .git
 infinipath-psm
-3.3-25_g326b95a
-326b95a386f7aeb56743d0b09b2f68f07b856f28
+3.3-26_g604758e
+604758e76dc31e68d1de736ccf5ddf16cb22355b
   
   
 *infinipath-psm*.tar

++ infinipath-psm-3.3-25_g326b95a.tar.gz -> 
infinipath-psm-3.3-26_g604758e.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/infinipath-psm-3.3-25_g326b95a/psmd/Makefile 
new/infinipath-psm-3.3-26_g604758e/psmd/Makefile
--- old/infinipath-psm-3.3-25_g326b95a/psmd/Makefile2016-08-15 
19:47:30.0 +0200
+++ new/infinipath-psm-3.3-26_g604758e/psmd/Makefile2017-04-28 
22:25:19.0 +0200
@@ -1,39 +1,57 @@
-#   Copyright (c) 2012. Intel Corporation. All rights reserved.
-#  Copyright (C) 2005, 2006. QLogic Corporation.  All rights reserved.
-#  Permission is granted to QLogic customers to use this software in 
-#  source and binary forms, with or without modification, provided that 
-#  the following conditions are met: 
-#  
-#  + All copies of source code must retain the above copyright notice, 
-#this list of conditions and the following disclaimer. 
-#  
-#  + Customer has a valid license agreement from QLogic Corporation. for 
the 
-#software product with which this software is originally distributed. 
-#  
-#  + Redistribution of original or modified versions to third parties is 
-#prohibited without specific prior written permission of QLogic
-#Corporation. 
-#  
-#  + If customer makes modifications to this software, and provides those 
-#modifications to QLogic, customer assigns to QLogic Corporation. 
-#ownership of the provided modifications and all intellectual property 
-#rights embodied in those modifications. 
-#  
-#  + The name of QLogic Corporation. may not be used to endorse or promote 
-#products derived from this software without specific prior written 
-#permission. 
-#  
-#  THIS SOFTWARE IS PROVIDED BY QLOGIC CORPORATION. AND ITS LICENSORS "AS 
IS" 
-#  AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, 
-#  THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
-#  PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL QLOGIC CORPORATION. OR ITS 
-#  LICENSORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
-#  EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
-#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
-#  

commit perl-Business-ISBN for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package perl-Business-ISBN for 
openSUSE:Factory checked in at 2017-05-18 20:41:56

Comparing /work/SRC/openSUSE:Factory/perl-Business-ISBN (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Business-ISBN.new (New)


Package is "perl-Business-ISBN"

Thu May 18 20:41:56 2017 rev:25 rq:492414 version:3.004

Changes:

--- /work/SRC/openSUSE:Factory/perl-Business-ISBN/perl-Business-ISBN.changes
2016-10-01 23:44:00.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Business-ISBN.new/perl-Business-ISBN.changes   
2017-05-18 20:41:59.088904960 +0200
@@ -1,0 +2,12 @@
+Tue Apr 25 05:08:46 UTC 2017 - co...@suse.com
+
+- updated to 3.004
+   see /usr/share/doc/packages/perl-Business-ISBN/Changes
+
+  3.004 2017-04-24T20:02:52Z
+   * Remove Mojo dependencies after splitting out Business::xISBN
+   (Michiel Beijen)
+   * Remove unneeded code from the checksumming stuff (Mike O'Regan)
+   * We now test on Windows through AppVeyor
+
+---

Old:

  Business-ISBN-3.003.tar.gz

New:

  Business-ISBN-3.004.tar.gz



Other differences:
--
++ perl-Business-ISBN.spec ++
--- /var/tmp/diff_new_pack.lhuFmG/_old  2017-05-18 20:41:59.608831586 +0200
+++ /var/tmp/diff_new_pack.lhuFmG/_new  2017-05-18 20:41:59.608831586 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Business-ISBN
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,26 +17,22 @@
 
 
 Name:   perl-Business-ISBN
-Version:3.003
+Version:3.004
 Release:0
 %define cpan_name Business-ISBN
 Summary:Work with International Standard Book Numbers
 License:Artistic-2.0
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/Business-ISBN/
-Source0:
http://www.cpan.org/authors/id/B/BD/BDFOY/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/B/BD/BDFOY/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl
 BuildRequires:  perl-macros
 BuildRequires:  perl(Business::ISBN::Data) >= 20140910.002
-BuildRequires:  perl(Mojo::DOM)
-BuildRequires:  perl(Mojo::UserAgent)
 BuildRequires:  perl(Test::More) >= 0.95
 Requires:   perl(Business::ISBN::Data) >= 20140910.002
-Requires:   perl(Mojo::DOM)
-Requires:   perl(Mojo::UserAgent)
 %{perl_requires}
 
 %description
@@ -60,6 +56,7 @@
 
 %files -f %{name}.files
 %defattr(-,root,root,755)
-%doc bad-isbn13s.txt bad-isbns.txt Changes examples isbn13s.txt isbns.txt 
LICENSE
+%doc bad-isbn13s.txt bad-isbns.txt Changes examples isbn13s.txt isbns.txt
+%license LICENSE
 
 %changelog

++ Business-ISBN-3.003.tar.gz -> Business-ISBN-3.004.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Business-ISBN-3.003/Changes 
new/Business-ISBN-3.004/Changes
--- old/Business-ISBN-3.003/Changes 2016-09-20 00:03:45.0 +0200
+++ new/Business-ISBN-3.004/Changes 2017-04-24 22:04:32.0 +0200
@@ -1,5 +1,11 @@
 Revision history for Perl module Business::ISBN
 
+3.004 2017-04-24T20:02:52Z
+   * Remove Mojo dependencies after splitting out Business::xISBN
+   (Michiel Beijen)
+   * Remove unneeded code from the checksumming stuff (Mike O'Regan)
+   * We now test on Windows through AppVeyor
+
 3.003 2016-09-19T22:03:24Z
* Clarify everywhere that I'm using Artistic License 2.0
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Business-ISBN-3.003/MANIFEST.SKIP 
new/Business-ISBN-3.004/MANIFEST.SKIP
--- old/Business-ISBN-3.003/MANIFEST.SKIP   2016-09-20 00:03:45.0 
+0200
+++ new/Business-ISBN-3.004/MANIFEST.SKIP   2017-04-24 22:04:32.0 
+0200
@@ -59,6 +59,7 @@
 
 
 \.travis\.yml
+\.appveyor.yml
 \.releaserc
 \.lwpcookies
 Business-.*
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Business-ISBN-3.003/META.json 
new/Business-ISBN-3.004/META.json
--- old/Business-ISBN-3.003/META.json   2016-09-20 00:04:36.0 +0200
+++ new/Business-ISBN-3.004/META.json   2017-04-24 22:04:35.0 +0200
@@ -4,7 +4,7 @@
   "brian d foy "
],
"dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 7.1001, CPAN::Meta::Converter 
version 2.150005",
+   "generated_by" : 

commit libfastjson for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libfastjson for openSUSE:Factory 
checked in at 2017-05-18 20:42:05

Comparing /work/SRC/openSUSE:Factory/libfastjson (Old)
 and  /work/SRC/openSUSE:Factory/.libfastjson.new (New)


Package is "libfastjson"

Thu May 18 20:42:05 2017 rev:5 rq:493415 version:0.99.5

Changes:

--- /work/SRC/openSUSE:Factory/libfastjson/libfastjson.changes  2017-02-04 
18:00:28.784433495 +0100
+++ /work/SRC/openSUSE:Factory/.libfastjson.new/libfastjson.changes 
2017-05-18 20:42:07.535712911 +0200
@@ -1,0 +2,8 @@
+Mon May  8 09:03:17 UTC 2017 - astie...@suse.com
+
+- update to 0.99.5:
+  * fix floating point representation when fractional part is missing
+  * m4: fix detection of atomics
+  * add fjson_object_dump() and fjson_object_write() functions
+
+---

Old:

  libfastjson-0.99.4.tar.gz

New:

  libfastjson-0.99.5.tar.gz



Other differences:
--
++ libfastjson.spec ++
--- /var/tmp/diff_new_pack.Ib2fpD/_old  2017-05-18 20:42:08.215616961 +0200
+++ /var/tmp/diff_new_pack.Ib2fpD/_new  2017-05-18 20:42:08.215616961 +0200
@@ -18,7 +18,7 @@
 
 %define somajor 4
 Name:   libfastjson
-Version:0.99.4
+Version:0.99.5
 Release:0
 Summary:Fast JSON parsing library, a fork of json-c
 License:MIT
@@ -65,7 +65,7 @@
 make %{?_smp_mflags} check
 
 %install
-make %{?_smp_mflags} DESTDIR=%{buildroot} install
+%make_install
 find %{buildroot} -type f -name "*.la" -delete -print
 
 %post -n libfastjson%{somajor} -p /sbin/ldconfig

++ libfastjson-0.99.4.tar.gz -> libfastjson-0.99.5.tar.gz ++
 18171 lines of diff (skipped)




commit tidy for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package tidy for openSUSE:Factory checked in 
at 2017-05-18 20:42:01

Comparing /work/SRC/openSUSE:Factory/tidy (Old)
 and  /work/SRC/openSUSE:Factory/.tidy.new (New)


Package is "tidy"

Thu May 18 20:42:01 2017 rev:22 rq:492989 version:5.4.0

Changes:

--- /work/SRC/openSUSE:Factory/tidy/tidy.changes2016-08-12 
15:37:15.0 +0200
+++ /work/SRC/openSUSE:Factory/.tidy.new/tidy.changes   2017-05-18 
20:42:03.496282973 +0200
@@ -1,0 +2,21 @@
+Fri May  5 09:49:55 UTC 2017 - adam.ma...@suse.de
+
+- actually enable and distribute compat headers
+- explicitly list headers instead of globing so nothing
+  "disappears" with version updates
+
+---
+Mon Apr 10 08:18:55 UTC 2017 - adam.ma...@suse.de
+
+- new upstream version 5.4.0
+- compat_headers.diff: upstreamed
+- static_buffer_overflow.diff: upstreamed
+- updated documentation to current
+  +  tidy-html5-doxygen-a8e47dc.tar.gz replaced by
+ tidy-html5-doxygen-c0d1cd1.tar.gz
+- updated unit tests to current
+  + a510b54.tar.gz replaced by 97cf741.tar.gz
+- fix_doxygen_paths.diff: refreshed
+- test_fixes.diff: refreshed
+
+---

Old:

  5.2.0.tar.gz
  a510b54.tar.gz
  compat_headers.diff
  static_buffer_overflow.diff
  tidy-html5-doxygen-a8e47dc.tar.gz

New:

  5.4.0.tar.gz
  97cf741.tar.gz
  tidy-html5-doxygen-c0d1cd1.tar.gz



Other differences:
--
++ tidy.spec ++
--- /var/tmp/diff_new_pack.3ow85w/_old  2017-05-18 20:42:04.404154850 +0200
+++ /var/tmp/diff_new_pack.3ow85w/_new  2017-05-18 20:42:04.404154850 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package tidy
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,11 +16,11 @@
 #
 
 
-%define regression_tests a510b54
-%define documentationa8e47dc
+%define regression_tests 97cf741
+%define documentationc0d1cd1
 
 Name:   tidy
-Version:5.2.0
+Version:5.4.0
 Release:0
 Summary:Utility to Clean Up and Pretty-print HTML, XHTML or XML Markup
 License:W3C
@@ -30,15 +30,13 @@
 # Latest version of unit tests
 Source1:
https://github.com/htacg/tidy-html5-tests/archive/%{regression_tests}.tar.gz
 # Documentation generation files, extracted from
-#   https://github.com/htacg/tidy-html5-tests/archive/%%{documentation}.tar.gz
+#   
https://github.com/htacg/html-tidy.org.api.git/archive/%%{documentation}.tar.gz
 # using tidy_generate_documentation.sh
 Source2:tidy-html5-doxygen-%{documentation}.tar.gz
 Source10:   tidy_fetch_docs.sh
 Patch0: dynamic_library_build.diff
 Patch1: test_fixes.diff
 Patch2: fix_doxygen_paths.diff
-Patch3: compat_headers.diff
-Patch4: static_buffer_overflow.diff
 BuildRequires:  cmake
 BuildRequires:  doxygen
 BuildRequires:  gcc-c++
@@ -102,13 +100,12 @@
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4
 
 %build
 %cmake \
 -DCMAKE_SKIP_RPATH:BOOL=OFF \
--DINCLUDE_INSTALL_DIR:PATH=include/%{name}
+-DINCLUDE_INSTALL_DIR:PATH=include/%{name} \
+-DTIDY_COMPAT_HEADERS:BOOL=ON
 make %{?_smp_mflags}
 ../tidy-html5-doxygen/build_docs.sh
 
@@ -135,7 +132,12 @@
 %files -n libtidy-devel
 %defattr(-, root, root)
 %dir %{_includedir}/%{name}
-%{_includedir}/%{name}/*.h
+%{_includedir}/%{name}/tidy.h
+%{_includedir}/%{name}/tidybuffio.h
+%{_includedir}/%{name}/tidyenum.h
+%{_includedir}/%{name}/tidyplatform.h
+%{_includedir}/%{name}/buffio.h
+%{_includedir}/%{name}/platform.h
 %{_libdir}/libtidy.so
 
 %changelog

++ 5.2.0.tar.gz -> 5.4.0.tar.gz ++
 5121 lines of diff (skipped)

++ 5.2.0.tar.gz -> 97cf741.tar.gz ++
 113030 lines of diff (skipped)

++ debian.series ++
--- /var/tmp/diff_new_pack.3ow85w/_old  2017-05-18 20:42:05.020067930 +0200
+++ /var/tmp/diff_new_pack.3ow85w/_new  2017-05-18 20:42:05.020067930 +0200
@@ -1,5 +1,4 @@
 dynamic_library_build.diff
 test_fixes.diff
 fix_doxygen_paths.diff
-compat_headers.diff
 

++ fix_doxygen_paths.diff ++
--- /var/tmp/diff_new_pack.3ow85w/_old  2017-05-18 20:42:05.044064544 +0200
+++ /var/tmp/diff_new_pack.3ow85w/_new  2017-05-18 20:42:05.044064544 +0200
@@ -1,8 +1,8 @@
-Index: tidy-html5-5.2.0/tidy-html5-doxygen/build_docs.sh
+Index: tidy-html5-5.4.0/tidy-html5-doxygen/build_docs.sh
 ===
 tidy-html5-5.2.0.orig/tidy-html5-doxygen/build_docs.sh
-+++ 

commit gnome-builder for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-builder for openSUSE:Factory 
checked in at 2017-05-18 20:41:37

Comparing /work/SRC/openSUSE:Factory/gnome-builder (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-builder.new (New)


Package is "gnome-builder"

Thu May 18 20:41:37 2017 rev:21 rq:494639 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/gnome-builder/gnome-builder.changes  
2017-03-22 23:05:52.141284701 +0100
+++ /work/SRC/openSUSE:Factory/.gnome-builder.new/gnome-builder.changes 
2017-05-18 20:41:52.95609 +0200
@@ -1,0 +2,72 @@
+Wed May 10 21:09:04 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Various panel system fixes including "stuck on" panels.
+  + Some animation jitter has been resolved.
+  + Build buttons will be insensitive when build progress cannot be
+made.
+  + Transfers while building will now fail when on metered
+connections. A preference has been added to disable this
+behavior.
+  + Snippets will now be reloaded when the current language
+changes.
+  + The build log will try harder to scroll to the correct
+position.
+  + The todo plugin is more defensive when the workbench is
+destroyed.
+  + An assertion crash is fixed when the app-id is changed while a
+build is in progress.
+  + A potential crash was fixed in the flatpak plugin when cleaning
+up old runtimes.
+  + Ctags plugin has been fixed to use the proper path.
+  + Updated transitions.
+
+---
+Mon Apr 24 17:11:11 UTC 2017 - dims...@opensuse.org
+
+- Update to version 3.24.1:
+  + Support for live editing Sphinx documentation.
+  + The "install" action can be activated from the command bar to
+install your project without running it.
+  + Fix error propagation in autotools and jsonrpc.
+  + Defer to ninja for installability of project.
+  + Various build system fixes.
+  + Lower diagnosis priority to improve UI interactivity.
+  + Fix hgih number FD mappings into worker processes.
+  + Always build with V=0 for less verbose builds.
+  + Translate paths for out-of-tree builds when handling
+diagnostics.
+  + Allow pipeline stages to signify stdout should be checked for
+errors.
+  + Allow network access from fallback flatpak launcher.
+  + Use flatpak-builder --run when possible.
+  + Use build-args from manifest when building with flatpak build.
+  + Various Rust RLS fixes.
+  + Floating ref fix for jsonrpc.
+  + Rustfmt support for Rust.
+  + Support for reformat-selection with gq in vim mode when
+language supports it. C-c C-f in Emacs mode. Currently only
+Rust/RLS support exists.
+  + Symbol Resolvers can now support locating all references to a
+symbol so that the editor can move between them. Currently,
+only Rust/RLS is supported. Ctrl+shift+space will display the
+popup.
+  + Configurations will be properly "prepared" again when changing
+runtimes so that a new --prefix may be applied.
+  + Flatpak manifest discovery has changed to breadth-first search.
+  + Flatpak'd versions of Builder will still look for plugins in
+the host ~/.local/share/gnome-builder/plugins for consistency.
+  + Auto-save of buffer is dismissed when user initiated save
+occurs.
+  + Various memory leaks have been plugged.
+  + File monitor improvements during rename events.
+  + The greeter will display the build system type to help users
+transition to new build systems such as Meson.
+  + A menu item to launch a terminal in flatpak has been added.
+While this is not flatpak specific, it is the general way users
+think about it.
+  + Documentation improvements.
+  + Updated translations.
+- Add pkgconfig(enchant) BuildRequires: new dependency.
+
+---

Old:

  gnome-builder-3.24.0.tar.xz

New:

  gnome-builder-3.24.2.tar.xz



Other differences:
--
++ gnome-builder.spec ++
--- /var/tmp/diff_new_pack.Bzfk36/_old  2017-05-18 20:41:53.249729008 +0200
+++ /var/tmp/diff_new_pack.Bzfk36/_new  2017-05-18 20:41:53.253728444 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-builder
-Version:3.24.0
+Version:3.24.2
 Release:0
 Summary:GNOME Builder - IDE
 License:GPL-3.0+ and GPL-2.0+ and LGPL-3.0+ and LGPL-2.1+ and 
CC-BY-SA-3.0
@@ -34,6 +34,7 @@
 BuildRequires:  pkg-config
 BuildRequires:  python3-devel >= 3.2.3
 BuildRequires:  update-desktop-files
+BuildRequires:  pkgconfig(enchant) >= 1.6.0
 BuildRequires:  pkgconfig(flatpak)
 BuildRequires:  pkgconfig(gio-2.0) >= 2.49.0
 BuildRequires:  pkgconfig(gio-unix-2.0) >= 2.49.0

++ gnome-builder-3.24.0.tar.xz -> 

commit gnome-user-docs for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-user-docs for openSUSE:Factory 
checked in at 2017-05-18 20:41:33

Comparing /work/SRC/openSUSE:Factory/gnome-user-docs (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-user-docs.new (New)


Package is "gnome-user-docs"

Thu May 18 20:41:33 2017 rev:58 rq:494462 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/gnome-user-docs/gnome-user-docs.changes  
2017-04-29 10:51:45.187240737 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-user-docs.new/gnome-user-docs.changes 
2017-05-18 20:41:50.674092492 +0200
@@ -1,0 +2,7 @@
+Wed May 10 19:47:01 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Updates to GNOME Help.
+  + Updated translations.
+
+---

Old:

  gnome-user-docs-3.24.0.tar.xz

New:

  gnome-user-docs-3.24.2.tar.xz



Other differences:
--
++ gnome-user-docs.spec ++
--- /var/tmp/diff_new_pack.mrjbNg/_old  2017-05-18 20:41:51.553968321 +0200
+++ /var/tmp/diff_new_pack.mrjbNg/_new  2017-05-18 20:41:51.553968321 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-user-docs
-Version:3.24.0
+Version:3.24.2
 Release:0
 Summary:GNOME Desktop Documentation
 License:GFDL-1.1

++ gnome-user-docs-3.24.0.tar.xz -> gnome-user-docs-3.24.2.tar.xz ++
/work/SRC/openSUSE:Factory/gnome-user-docs/gnome-user-docs-3.24.0.tar.xz 
/work/SRC/openSUSE:Factory/.gnome-user-docs.new/gnome-user-docs-3.24.2.tar.xz 
differ: char 25, line 1




commit gnome-desktop for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-desktop for openSUSE:Factory 
checked in at 2017-05-18 20:41:28

Comparing /work/SRC/openSUSE:Factory/gnome-desktop (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-desktop.new (New)


Package is "gnome-desktop"

Thu May 18 20:41:28 2017 rev:137 rq:494458 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/gnome-desktop/gnome-desktop.changes  
2017-04-29 10:50:56.258152977 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-desktop.new/gnome-desktop.changes 
2017-05-18 20:41:35.632215262 +0200
@@ -1,0 +2,6 @@
+Wed May 10 19:27:59 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + No changes, stable version bump only.
+
+---

Old:

  gnome-desktop-3.24.1.tar.xz

New:

  gnome-desktop-3.24.2.tar.xz



Other differences:
--
++ gnome-desktop.spec ++
--- /var/tmp/diff_new_pack.5yrAvp/_old  2017-05-18 20:41:36.208133986 +0200
+++ /var/tmp/diff_new_pack.5yrAvp/_new  2017-05-18 20:41:36.208133986 +0200
@@ -19,7 +19,7 @@
 %define IS_DEFAULT_GNOME_DESKTOP 1
 
 Name:   gnome-desktop
-Version:3.24.1
+Version:3.24.2
 Release:0
 Summary:The GNOME Desktop API Library
 License:LGPL-2.1+

++ gnome-desktop-3.24.1.tar.xz -> gnome-desktop-3.24.2.tar.xz ++
 2391 lines of diff (skipped)




commit gucharmap for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gucharmap for openSUSE:Factory 
checked in at 2017-05-18 20:41:22

Comparing /work/SRC/openSUSE:Factory/gucharmap (Old)
 and  /work/SRC/openSUSE:Factory/.gucharmap.new (New)


Package is "gucharmap"

Thu May 18 20:41:22 2017 rev:88 rq:494456 version:9.0.4

Changes:

--- /work/SRC/openSUSE:Factory/gucharmap/gucharmap.changes  2017-03-22 
23:14:40.246456424 +0100
+++ /work/SRC/openSUSE:Factory/.gucharmap.new/gucharmap.changes 2017-05-18 
20:41:32.868605273 +0200
@@ -1,0 +2,6 @@
+Wed May 10 19:25:51 UTC 2017 - zai...@opensuse.org
+
+- Update to version 9.0.4:
+  + Updated translations.
+
+---

Old:

  gucharmap-9.0.3.tar.xz

New:

  gucharmap-9.0.4.tar.xz



Other differences:
--
++ gucharmap.spec ++
--- /var/tmp/diff_new_pack.TnkG6z/_old  2017-05-18 20:41:33.552508758 +0200
+++ /var/tmp/diff_new_pack.TnkG6z/_new  2017-05-18 20:41:33.552508758 +0200
@@ -22,7 +22,7 @@
 %define pc_api 2.90
 
 Name:   gucharmap
-Version:9.0.3
+Version:9.0.4
 Release:0
 Summary:A Featureful Unicode Character Map
 License:GPL-3.0+ and LGPL-2.1+

++ gucharmap-9.0.3.tar.xz -> gucharmap-9.0.4.tar.xz ++
 2106 lines of diff (skipped)




commit aisleriot for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package aisleriot for openSUSE:Factory 
checked in at 2017-05-18 20:41:18

Comparing /work/SRC/openSUSE:Factory/aisleriot (Old)
 and  /work/SRC/openSUSE:Factory/.aisleriot.new (New)


Package is "aisleriot"

Thu May 18 20:41:18 2017 rev:45 rq:494455 version:3.22.2

Changes:

--- /work/SRC/openSUSE:Factory/aisleriot/aisleriot.changes  2016-11-10 
13:12:01.0 +0100
+++ /work/SRC/openSUSE:Factory/.aisleriot.new/aisleriot.changes 2017-05-18 
20:41:30.964873935 +0200
@@ -1,0 +2,15 @@
+Wed May 10 19:13:00 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.22.2:
+  + build:
+- Build against guile 2.2 by default.
+- Print guile version on configure summary.
+  + Install appstream metadata to /usr/share/metainfo.
+  + Updated translations.
+
+---
+Tue Apr 25 08:26:40 UTC 2017 - dims...@opensuse.org
+
+- Fix build with different versions of guile than 2.0.
+
+---

Old:

  aisleriot-3.22.1.tar.xz

New:

  aisleriot-3.22.2.tar.xz



Other differences:
--
++ aisleriot.spec ++
--- /var/tmp/diff_new_pack.F4qBYN/_old  2017-05-18 20:41:31.652776855 +0200
+++ /var/tmp/diff_new_pack.F4qBYN/_new  2017-05-18 20:41:31.652776855 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package aisleriot
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   aisleriot
-Version:3.22.1
+Version:3.22.2
 Release:0
 Summary:Solitaire Card Games for GNOME
 License:GPL-3.0+
@@ -103,16 +103,16 @@
 %endif
 %doc %{_datadir}/help/C/aisleriot/
 %{_bindir}/sol
-%dir %{_datadir}/appdata
-%{_datadir}/appdata/sol.appdata.xml
+%dir %{_datadir}/metainfo
+%{_datadir}/metainfo/sol.appdata.xml
 %{_datadir}/applications/sol.desktop
 %{_datadir}/aisleriot/
 %dir %{_libdir}/aisleriot
 %dir %{_libdir}/aisleriot/guile
-%dir %{_libdir}/aisleriot/guile/2.0
-%dir %{_libdir}/aisleriot/guile/2.0/aisleriot
-%{_libdir}/aisleriot/guile/2.0/aisleriot/api.go
-%{_libdir}/aisleriot/guile/2.0/*.go
+%dir %{_libdir}/aisleriot/guile/*
+%dir %{_libdir}/aisleriot/guile/*/aisleriot
+%{_libdir}/aisleriot/guile/*/aisleriot/api.go
+%{_libdir}/aisleriot/guile/*/*.go
 %if "%{_libdir}" != "%{_libexecdir}"
 %dir %{_libexecdir}/aisleriot
 %endif

++ aisleriot-3.22.1.tar.xz -> aisleriot-3.22.2.tar.xz ++
/work/SRC/openSUSE:Factory/aisleriot/aisleriot-3.22.1.tar.xz 
/work/SRC/openSUSE:Factory/.aisleriot.new/aisleriot-3.22.2.tar.xz differ: char 
25, line 1




commit gnome-music for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-music for openSUSE:Factory 
checked in at 2017-05-18 20:40:03

Comparing /work/SRC/openSUSE:Factory/gnome-music (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-music.new (New)


Package is "gnome-music"

Thu May 18 20:40:03 2017 rev:28 rq:494448 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/gnome-music/gnome-music.changes  2017-04-29 
10:50:32.005579166 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-music.new/gnome-music.changes 
2017-05-18 20:40:53.330185085 +0200
@@ -1,0 +2,7 @@
+Wed May 10 16:36:34 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Bugs fixed: bgo#776668, bgo#781684.
+  + Updated translations.
+
+---
@@ -4,0 +12,3 @@
+  + Revert desktop file rename.
+  + In turn revert Flatpak manifest addition.
+- Changes from version 3.24.1:

Old:

  gnome-music-3.24.1.1.tar.xz

New:

  gnome-music-3.24.2.tar.xz



Other differences:
--
++ gnome-music.spec ++
--- /var/tmp/diff_new_pack.omK1Py/_old  2017-05-18 20:40:53.898104938 +0200
+++ /var/tmp/diff_new_pack.omK1Py/_new  2017-05-18 20:40:53.898104938 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-music
-Version:3.24.1.1
+Version:3.24.2
 Release:0
 Summary:Music Player for GNOME
 License:SUSE-GPL-2.0-with-plugin-exception and LGPL-2.1+

++ gnome-music-3.24.1.1.tar.xz -> gnome-music-3.24.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gnome-music-3.24.1.1/AUTHORS 
new/gnome-music-3.24.2/AUTHORS
--- old/gnome-music-3.24.1.1/AUTHORS2017-04-11 10:47:41.0 +0200
+++ new/gnome-music-3.24.2/AUTHORS  2017-05-09 08:47:36.0 +0200
@@ -276,6 +276,7 @@
 Yosef Or Boczko 
 Yosef Or Boczko 
 YunQiang Su 
+Yuras Shumovich 
 Yuri Myasoedov 
 Yuri Myasoedov 
 Yuri Myasoedov 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gnome-music-3.24.1.1/NEWS new/gnome-music-3.24.2/NEWS
--- old/gnome-music-3.24.1.1/NEWS   2017-04-11 00:15:13.0 +0200
+++ new/gnome-music-3.24.2/NEWS 2017-05-09 08:46:42.0 +0200
@@ -1,3 +1,23 @@
+Overview of changes in 3.24.2
+=
+
+Bugs fixed:
+ 776668 fix seek stutter
+ 781684 In Playlist view album title is displayed instead of artist name
+
+Thanks to our contributors this release:
+ Abhinav Singh
+ Marinus Schraal
+
+Translations updated:
+ Belarusian
+
+Overview of changes in 3.24.1.1
+===
+
+* Revert desktop file rename
+* In turn revert Flatpak manifest addition
+
 Overview of changes in 3.24.1
 =
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gnome-music-3.24.1.1/configure 
new/gnome-music-3.24.2/configure
--- old/gnome-music-3.24.1.1/configure  2017-04-11 10:47:31.0 +0200
+++ new/gnome-music-3.24.2/configure2017-05-09 08:47:22.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for gnome-music 3.24.1.1.
+# Generated by GNU Autoconf 2.69 for gnome-music 3.24.2.
 #
 # Report bugs to 
.
 #
@@ -591,8 +591,8 @@
 # Identity of this package.
 PACKAGE_NAME='gnome-music'
 PACKAGE_TARNAME='gnome-music'
-PACKAGE_VERSION='3.24.1.1'
-PACKAGE_STRING='gnome-music 3.24.1.1'
+PACKAGE_VERSION='3.24.2'
+PACKAGE_STRING='gnome-music 3.24.2'
 
PACKAGE_BUGREPORT='https://bugzilla.gnome.org/enter_bug.cgi?product=gnome-music'
 PACKAGE_URL='https://wiki.gnome.org/Apps/Music'
 
@@ -1457,7 +1457,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures gnome-music 3.24.1.1 to adapt to many kinds of systems.
+\`configure' configures gnome-music 3.24.2 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1527,7 +1527,7 @@
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
- short | recursive ) echo "Configuration of gnome-music 3.24.1.1:";;
+ short | recursive ) echo "Configuration of gnome-music 3.24.2:";;
esac
   cat <<\_ACEOF
 
@@ -1674,7 +1674,7 @@
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-gnome-music configure 3.24.1.1
+gnome-music configure 3.24.2
 generated by GNU Autoconf 2.69
 
 Copyright (C) 

commit evolution-ews for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package evolution-ews for openSUSE:Factory 
checked in at 2017-05-18 20:41:08

Comparing /work/SRC/openSUSE:Factory/evolution-ews (Old)
 and  /work/SRC/openSUSE:Factory/.evolution-ews.new (New)


Package is "evolution-ews"

Thu May 18 20:41:08 2017 rev:72 rq:494453 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/evolution-ews/evolution-ews.changes  
2017-04-29 10:49:35.273593799 +0200
+++ /work/SRC/openSUSE:Factory/.evolution-ews.new/evolution-ews.changes 
2017-05-18 20:41:09.827856872 +0200
@@ -1,0 +2,7 @@
+Wed May 10 17:12:19 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Bugs fixed: bgo#781833.
+  + Updated translations.
+
+---

Old:

  evolution-ews-3.24.1.tar.xz

New:

  evolution-ews-3.24.2.tar.xz



Other differences:
--
++ evolution-ews.spec ++
--- /var/tmp/diff_new_pack.EmMgfa/_old  2017-05-18 20:41:10.483764308 +0200
+++ /var/tmp/diff_new_pack.EmMgfa/_new  2017-05-18 20:41:10.483764308 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   evolution-ews
-Version:3.24.1
+Version:3.24.2
 Release:0
 # This should be updated upon major version changes; it should match 
BASE_VERSION as defined in configure.in.
 %define evolution_base_version 3.24

++ evolution-ews-3.24.1.tar.xz -> evolution-ews-3.24.2.tar.xz ++
 2106 lines of diff (skipped)




commit gnome-photos for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-photos for openSUSE:Factory 
checked in at 2017-05-18 20:40:22

Comparing /work/SRC/openSUSE:Factory/gnome-photos (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-photos.new (New)


Package is "gnome-photos"

Thu May 18 20:40:22 2017 rev:32 rq:494449 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/gnome-photos/gnome-photos.changes
2017-04-29 10:50:38.444669507 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-photos.new/gnome-photos.changes   
2017-05-18 20:40:58.053518511 +0200
@@ -1,0 +2,7 @@
+Wed May 10 16:42:09 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Bugs fixed: bgo#778354.
+  + Updated translations.
+
+---

Old:

  gnome-photos-3.24.1.tar.xz

New:

  gnome-photos-3.24.2.tar.xz



Other differences:
--
++ gnome-photos.spec ++
--- /var/tmp/diff_new_pack.0X8mGR/_old  2017-05-18 20:40:58.693428204 +0200
+++ /var/tmp/diff_new_pack.0X8mGR/_new  2017-05-18 20:40:58.697427640 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-photos
-Version:3.24.1
+Version:3.24.2
 Release:0
 Summary:Photo viewer for GNOME
 License:GPL-3.0+

++ gnome-photos-3.24.1.tar.xz -> gnome-photos-3.24.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gnome-photos-3.24.1/NEWS new/gnome-photos-3.24.2/NEWS
--- old/gnome-photos-3.24.1/NEWS2017-04-11 18:58:45.0 +0200
+++ new/gnome-photos-3.24.2/NEWS2017-05-10 15:53:43.0 +0200
@@ -1,3 +1,13 @@
+Overview of changes in 3.24.2
+=
+
+* Bugs fixed:
+ 778354 photos:insta-curve should support buffers with alpha channel
+
+* Updated translations:
+ Gujarati
+
+
 Overview of changes in 3.24.1
 =
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gnome-photos-3.24.1/configure 
new/gnome-photos-3.24.2/configure
--- old/gnome-photos-3.24.1/configure   2017-04-11 19:01:06.0 +0200
+++ new/gnome-photos-3.24.2/configure   2017-05-10 15:54:35.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for Photos 3.24.1.
+# Generated by GNU Autoconf 2.69 for Photos 3.24.2.
 #
 # Report bugs to 
.
 #
@@ -591,8 +591,8 @@
 # Identity of this package.
 PACKAGE_NAME='Photos'
 PACKAGE_TARNAME='gnome-photos'
-PACKAGE_VERSION='3.24.1'
-PACKAGE_STRING='Photos 3.24.1'
+PACKAGE_VERSION='3.24.2'
+PACKAGE_STRING='Photos 3.24.2'
 
PACKAGE_BUGREPORT='https://bugzilla.gnome.org/enter_bug.cgi?product=gnome-photos'
 PACKAGE_URL='https://wiki.gnome.org/Apps/Photos'
 
@@ -1514,7 +1514,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures Photos 3.24.1 to adapt to many kinds of systems.
+\`configure' configures Photos 3.24.2 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1584,7 +1584,7 @@
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
- short | recursive ) echo "Configuration of Photos 3.24.1:";;
+ short | recursive ) echo "Configuration of Photos 3.24.2:";;
esac
   cat <<\_ACEOF
 
@@ -1775,7 +1775,7 @@
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-Photos configure 3.24.1
+Photos configure 3.24.2
 generated by GNU Autoconf 2.69
 
 Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2144,7 +2144,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by Photos $as_me 3.24.1, which was
+It was created by Photos $as_me 3.24.2, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   $ $0 $@
@@ -3015,7 +3015,7 @@
 
 # Define the identity of the package.
  PACKAGE='gnome-photos'
- VERSION='3.24.1'
+ VERSION='3.24.2'
 
 
 cat >>confdefs.h <<_ACEOF
@@ -19063,7 +19063,7 @@
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log="
-This file was extended by Photos $as_me 3.24.1, which was
+This file was extended by Photos $as_me 3.24.2, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   CONFIG_FILES= $CONFIG_FILES
@@ -19130,7 +19130,7 @@
 cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
 ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; 
s/[\\""\`\$]/&/g'`"
 ac_cs_version="\\
-Photos 

commit gnome-calendar for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-calendar for openSUSE:Factory 
checked in at 2017-05-18 20:40:43

Comparing /work/SRC/openSUSE:Factory/gnome-calendar (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-calendar.new (New)


Package is "gnome-calendar"

Thu May 18 20:40:43 2017 rev:16 rq:494450 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/gnome-calendar/gnome-calendar.changes
2017-03-22 23:11:19.630878858 +0100
+++ /work/SRC/openSUSE:Factory/.gnome-calendar.new/gnome-calendar.changes   
2017-05-18 20:41:02.208932084 +0200
@@ -1,0 +2,25 @@
+Wed May 10 16:56:48 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Fix crash in Week view.
+  + Fix crash in changing the current date.
+  + Properly update Week view's header when removing events.
+  + Hide search popover when clicking outside it.
+  + Updated translations.
+
+---
+Fri Apr 28 10:47:41 UTC 2017 - dims...@opensuse.org
+
+- Update to version 3.24.1:
+  + Added logging capabilities.
+  + Fix a lot of issues in Week view.
+  + Big code cleanups in old classes.
+  + Synchronize disabled calendars with Evolution.
+  + Fix DnD cursor.
+  + Optimize Year view.
+  + Drop "Search..." app menu item.
+  + Show tooltips when hovering event widgets.
+  + Various memory leaks and fixups.
+  + Updated translations.
+
+---

Old:

  gnome-calendar-3.24.0.tar.xz

New:

  gnome-calendar-3.24.2.tar.xz



Other differences:
--
++ gnome-calendar.spec ++
--- /var/tmp/diff_new_pack.j88NKq/_old  2017-05-18 20:41:02.740857016 +0200
+++ /var/tmp/diff_new_pack.j88NKq/_new  2017-05-18 20:41:02.744856452 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-calendar
-Version:3.24.0
+Version:3.24.2
 Release:0
 Summary:A calendar application for GNOME
 License:GPL-3.0+

++ gnome-calendar-3.24.0.tar.xz -> gnome-calendar-3.24.2.tar.xz ++
 16168 lines of diff (skipped)




commit gnome-control-center for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-control-center for 
openSUSE:Factory checked in at 2017-05-18 20:41:13

Comparing /work/SRC/openSUSE:Factory/gnome-control-center (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-control-center.new (New)


Package is "gnome-control-center"

Thu May 18 20:41:13 2017 rev:153 rq:494454 version:3.24.2

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-control-center/gnome-control-center.changes
2017-04-29 10:51:02.341293606 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-control-center.new/gnome-control-center.changes
   2017-05-18 20:41:15.347077979 +0200
@@ -1,0 +2,17 @@
+Wed May 10 17:16:08 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Memory leak and correctness fixes.
+  + Keyboard: Discard the added shortcut on Escape.
+  + Network: Fix mobile broadband switch state.
+  + Updated translations.
+
+---
+Wed May  3 06:01:24 UTC 2017 - fezh...@suse.com
+
+- Add gnome-control-center-info-disc-size-for-btrfs.patch:
+  Fix total disc size for btrfs subvolumes displayed in info panel,
+  backported upstream commit b619f7c (bsc#890385, bsc#1037234,
+  bgo#708786).
+
+---

Old:

  gnome-control-center-3.24.1.tar.xz

New:

  gnome-control-center-3.24.2.tar.xz
  gnome-control-center-info-disc-size-for-btrfs.patch



Other differences:
--
++ gnome-control-center.spec ++
--- /var/tmp/diff_new_pack.AXMxIn/_old  2017-05-18 20:41:16.190958887 +0200
+++ /var/tmp/diff_new_pack.AXMxIn/_new  2017-05-18 20:41:16.190958887 +0200
@@ -29,7 +29,7 @@
 %define with_cacert_patch 0
 
 Name:   gnome-control-center
-Version:3.24.1
+Version:3.24.2
 Release:0
 Summary:The GNOME Control Center
 License:GPL-2.0+
@@ -52,6 +52,8 @@
 Patch21:gnome-control-center-info-never-use-gnome-software.patch
 # PATCH-FIX-OPENSUSE gnome-control-center-more-power-button-actions.patch 
bsc#993381 fezh...@suse.com -- power: Bring back the "shutdown" and 
"interactive" power button actions.
 Patch22:gnome-control-center-more-power-button-actions.patch
+# PATCH-FIX-UPSTREAM gnome-control-center-info-disc-size-for-btrfs.patch 
bsc#890385 bsc#1037234 bgo#708786 fezh...@suse.com -- info: Fix total disc size 
for btrfs subvolumes
+Patch23:gnome-control-center-info-disc-size-for-btrfs.patch
 BuildRequires:  cups-devel
 BuildRequires:  desktop-file-utils
 BuildRequires:  fdupes
@@ -218,6 +220,7 @@
 %patch21 -p1
 %endif
 %patch22 -p1
+%patch23 -p1
 
 %build
 ACLOCAL_FLAGS="-I libgd" NOCONFIGURE=1 gnome-autogen.sh

++ gnome-control-center-3.24.1.tar.xz -> gnome-control-center-3.24.2.tar.xz 
++
/work/SRC/openSUSE:Factory/gnome-control-center/gnome-control-center-3.24.1.tar.xz
 
/work/SRC/openSUSE:Factory/.gnome-control-center.new/gnome-control-center-3.24.2.tar.xz
 differ: char 25, line 1

++ gnome-control-center-info-disc-size-for-btrfs.patch ++
diff --git a/panels/info/cc-info-panel.c b/panels/info/cc-info-panel.c
index d904f6c..d9d3504 100644
--- a/panels/info/cc-info-panel.c
+++ b/panels/info/cc-info-panel.c
@@ -547,7 +547,9 @@ get_primary_disc_info (CcInfoPanel *self)
 {
   GList*points;
   GList*p;
+  GHashTable *hash;
 
+  hash = g_hash_table_new (g_str_hash, g_str_equal);
   points = g_unix_mount_points_get (NULL);
 
   /* If we do not have /etc/fstab around, try /etc/mtab */
@@ -558,21 +560,30 @@ get_primary_disc_info (CcInfoPanel *self)
 {
   GUnixMountEntry *mount = p->data;
   const char *mount_path;
+  const char *device_path;
 
   mount_path = g_unix_mount_get_mount_path (mount);
+  device_path = g_unix_mount_get_device_path (mount);
+
+  /* Do not count multiple mounts with same device_path, because it is
+   * probably something like btrfs subvolume. Use only the first one in
+   * order to count the real size. */
 
   if (gsd_should_ignore_unix_mount (mount) ||
   gsd_is_removable_mount (mount) ||
   g_str_has_prefix (mount_path, "/media/") ||
-  g_str_has_prefix (mount_path, g_get_home_dir ()))
+  g_str_has_prefix (mount_path, g_get_home_dir ()) ||
+  g_hash_table_lookup (hash, device_path) != NULL)
 {
   g_unix_mount_free (mount);
   continue;
 }
 
   self->priv->primary_mounts = g_list_prepend (self->priv->primary_mounts, 
mount);
+  g_hash_table_insert (hash, (gpointer) device_path, (gpointer) 
device_path);
 }
   g_list_free (points);
+  g_hash_table_destroy (hash);
 
   get_primary_disc_info_start (self);
 }



commit evolution for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package evolution for openSUSE:Factory 
checked in at 2017-05-18 20:41:01

Comparing /work/SRC/openSUSE:Factory/evolution (Old)
 and  /work/SRC/openSUSE:Factory/.evolution.new (New)


Package is "evolution"

Thu May 18 20:41:01 2017 rev:196 rq:494452 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/evolution/evolution.changes  2017-04-29 
10:49:44.540284673 +0200
+++ /work/SRC/openSUSE:Factory/.evolution.new/evolution.changes 2017-05-18 
20:41:07.508184233 +0200
@@ -1,0 +2,23 @@
+Wed May 10 17:06:13 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Crash under e_meeting_time_selector_refresh_cb().
+  + Drag and drop to the editor can lock the Evolution.
+  + Dropping text/* content to the editor is not handled by WebKit.
+  + Fix the compilation warning with gcc 7.
+  + [ENameSelectorEntry] Avoid fake "changed" signals on focus-in.
+  + Calendar Print skips print dialog.
+  + Show VERSION_SUBSTRING and VERSION_COMMENT in Help->About.
+  + Fix occasional runtime warning from
+e_web_extension_set_clipboard_flags().
+  + Mark editor as changed if using 'Wrap lines' action.
+  + Mark editor as changed if deleting a selection.
+  + MailFolderCache can sometimes block folder 'changed'
+notifications.
+  + Correct possible ref/unref imbalance of a CamelFolder instance.
+  + Bugs fixed: bgo#781404, bgo#781557, bgo#781570, bgo#781660,
+bgo#781647, bgo#781722, bgo#781833, bgo#781890, bgo#781116,
+bgo#778423, bgo#780088, bgo#569684, bgo#782153.
+  + Updated translations.
+
+---

Old:

  evolution-3.24.1.tar.xz

New:

  evolution-3.24.2.tar.xz



Other differences:
--
++ evolution.spec ++
--- /var/tmp/diff_new_pack.shWFVL/_old  2017-05-18 20:41:08.316070222 +0200
+++ /var/tmp/diff_new_pack.shWFVL/_new  2017-05-18 20:41:08.320069657 +0200
@@ -24,7 +24,7 @@
 Name:   evolution
 # This should be updated upon major version changes; it should match 
BASE_VERSION as defined in configure.in.
 %define evolution_base_version 3.24
-Version:3.24.1
+Version:3.24.2
 Release:0
 # _version needs to be %{version} stripped to major.minor.micro only...
 %define _version %(echo %{version} | grep -E -o '[0-9]+\.[0-9]+\.[0-9]+')

++ evolution-3.24.1.tar.xz -> evolution-3.24.2.tar.xz ++
/work/SRC/openSUSE:Factory/evolution/evolution-3.24.1.tar.xz 
/work/SRC/openSUSE:Factory/.evolution.new/evolution-3.24.2.tar.xz differ: char 
26, line 1




commit evolution-data-server for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package evolution-data-server for 
openSUSE:Factory checked in at 2017-05-18 20:40:55

Comparing /work/SRC/openSUSE:Factory/evolution-data-server (Old)
 and  /work/SRC/openSUSE:Factory/.evolution-data-server.new (New)


Package is "evolution-data-server"

Thu May 18 20:40:55 2017 rev:174 rq:494451 version:3.24.2

Changes:

--- 
/work/SRC/openSUSE:Factory/evolution-data-server/evolution-data-server.changes  
2017-04-29 10:49:54.246913397 +0200
+++ 
/work/SRC/openSUSE:Factory/.evolution-data-server.new/evolution-data-server.changes
 2017-05-18 20:41:04.300636894 +0200
@@ -1,0 +2,11 @@
+Wed May 10 17:02:44 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Correct two libecal/client tests.
+  + [IMAPx]:
+- Unsubscribed folders shown after refresh.
+- Fix a memory leak of CamelIMAPXServer.
+  + Bugs fixed: bgo#777042, bgo#656635, bgo#781376, bgo#781465,
+bgo#781543, bgo#781549, bgo#781833, bgo#779749.
+
+---

Old:

  evolution-data-server-3.24.1.tar.xz

New:

  evolution-data-server-3.24.2.tar.xz



Other differences:
--
++ evolution-data-server.spec ++
--- /var/tmp/diff_new_pack.jbkZVX/_old  2017-05-18 20:41:04.916549975 +0200
+++ /var/tmp/diff_new_pack.jbkZVX/_new  2017-05-18 20:41:04.920549410 +0200
@@ -32,7 +32,7 @@
 
 Name:   evolution-data-server
 %define _evo_version 3.24
-Version:3.24.1
+Version:3.24.2
 Release:0
 Summary:Evolution Data Server
 License:LGPL-2.1+

++ evolution-data-server-3.24.1.tar.xz -> 
evolution-data-server-3.24.2.tar.xz ++
 1613 lines of diff (skipped)




commit libsoup for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libsoup for openSUSE:Factory checked 
in at 2017-05-18 20:39:54

Comparing /work/SRC/openSUSE:Factory/libsoup (Old)
 and  /work/SRC/openSUSE:Factory/.libsoup.new (New)


Package is "libsoup"

Thu May 18 20:39:54 2017 rev:95 rq:494446 version:2.58.1

Changes:

--- /work/SRC/openSUSE:Factory/libsoup/libsoup.changes  2017-03-22 
22:58:51.772868120 +0100
+++ /work/SRC/openSUSE:Factory/.libsoup.new/libsoup.changes 2017-05-18 
20:40:43.031638453 +0200
@@ -1,0 +2,29 @@
+Wed May 10 16:29:58 UTC 2017 - zai...@opensuse.org
+
+- Update to version 2.58.1:
+  + Reverts a change to SoupSession to close all open connections
+when the :proxy-resolver property is changed (bgo#777326). This
+change was made in 2.58.0 but accidentally left out of the NEWS
+for that release; although that behavior made :proxy-resolver
+more consistent with :proxy-uri, it ended up breaking Evolution
+EWS (bgo#781590).
+  + Fixed undefined behavior in tests/header-parsing that could
+make the test spuriously fail (bgo#777258).
+  + Updates to the configure tests for Apache for use in tests/:
+- Dropped support for Apache 2.2.
+- Changed PHP support from PHP 5 to PHP 7.
+- mod_unixd can now be either built-in or dynamically loaded
+  (bgo#776478).
+  + Updated translations.
+
+---
+Tue Apr 25 09:02:03 UTC 2017 - dims...@opensuse.org
+
+- Update to version 2.58.0:
+  + Fix authentication issues when the
+SOUP_MESSAGE_DO_NOT_USE_AUTH_CACHE flag is used (bgo#778497,
+bgo#777936).
+  + MSVC build improvements.
+  + Updated translations.
+
+---

Old:

  libsoup-2.57.1.tar.xz

New:

  libsoup-2.58.1.tar.xz



Other differences:
--
++ libsoup.spec ++
--- /var/tmp/diff_new_pack.Vm4Hz7/_old  2017-05-18 20:40:44.323456148 +0200
+++ /var/tmp/diff_new_pack.Vm4Hz7/_new  2017-05-18 20:40:44.327455583 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libsoup
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,10 +20,10 @@
 Summary:HTTP client/server library for GNOME
 License:LGPL-2.1+
 Group:  Development/Libraries/GNOME
-Version:2.57.1
+Version:2.58.1
 Release:0
 Url:http://www.gnome.org
-Source: 
http://download.gnome.org/sources/libsoup/2.57/%{name}-%{version}.tar.xz
+Source: 
http://download.gnome.org/sources/libsoup/2.58/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 BuildRequires:  glib-networking
 BuildRequires:  glib2-devel >= 2.38.0

++ libsoup-2.57.1.tar.xz -> libsoup-2.58.1.tar.xz ++
 61366 lines of diff (skipped)




commit gtk3 for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gtk3 for openSUSE:Factory checked in 
at 2017-05-18 20:39:30

Comparing /work/SRC/openSUSE:Factory/gtk3 (Old)
 and  /work/SRC/openSUSE:Factory/.gtk3.new (New)


Package is "gtk3"

Thu May 18 20:39:30 2017 rev:110 rq:494436 version:3.22.14

Changes:

--- /work/SRC/openSUSE:Factory/gtk3/gtk3.changes2017-03-22 
23:05:45.462231248 +0100
+++ /work/SRC/openSUSE:Factory/.gtk3.new/gtk3.changes   2017-05-18 
20:40:12.016015488 +0200
@@ -1,0 +2,34 @@
+Wed May 10 19:50:44 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.22.14:
+  + Fix build without sassc.
+  + Fix clipboard handling of UTF8 text.
+
+---
+Wed May 10 11:24:16 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.22.13:
+  + Bugs fixed: bgo#358970, bgo#771269, bgo#773814, bgo#778301,
+bgo#778617, bgo#779570, bgo#780301, bgo#781118, bgo#781162,
+bgo#781195, bgo#781214, bgo#781422, bgo#781605, bgo#781622,
+bgo#781737, bgo#781767, bgo#781814, bgo#781992, bgo#782109,
+bgo#782180, bgo#782202.
+  + Updated translations.
+
+---
+Mon Apr 24 10:47:28 UTC 2017 - dims...@opensuse.org
+
+- Update to version 3.22.12:
+  + Bugs fixed: bgo#686838, bgo#734946, bgo#773228, bgo#776472,
+bgo#778853, bgo#779081, bgo#779184, bgo#780041, bgo#780234,
+bgo#780734, bgo#780735, bgo#780878, bgo#780994.
+  + Updated translations.
+
+---
+Fri Mar 24 15:51:44 UTC 2017 - sree...@suse.com
+
+- Add Requires gdk-pixbuf-loader-rsvg. bsc#1007453
+We require adwaita-icon-theme so we need something to load
+the svg icons it provides.
+
+---

Old:

  gtk+-3.22.11.tar.xz

New:

  gtk+-3.22.14.tar.xz



Other differences:
--
++ gtk3.spec ++
--- /var/tmp/diff_new_pack.vbzLNL/_old  2017-05-18 20:40:16.603368105 +0200
+++ /var/tmp/diff_new_pack.vbzLNL/_new  2017-05-18 20:40:16.607367540 +0200
@@ -29,7 +29,7 @@
 
 Name:   gtk3
 %define _name gtk+
-Version:3.22.11
+Version:3.22.14
 Release:0
 Summary:The GTK+ toolkit library (version 3)
 License:LGPL-2.1+
@@ -105,6 +105,9 @@
 Requires:   hicolor-icon-theme
 # Require Adwaita Icon Theme: It's GTKs icon set, that's guaranteed to be there
 Requires:   adwaita-icon-theme
+# Require gdk-pixbuf-loader-rsvg - bsc#1007453. We require adwaita-icon-theme
+# so we need something to load the svg icons.
+Requires:   gdk-pixbuf-loader-rsvg
 # gtk+ can work without branding/translations. Built in defaults will be used 
then.
 Recommends: %{name}-branding
 # it's nice to have input modules for various locales installed by default

++ gtk+-3.22.11.tar.xz -> gtk+-3.22.14.tar.xz ++
/work/SRC/openSUSE:Factory/gtk3/gtk+-3.22.11.tar.xz 
/work/SRC/openSUSE:Factory/.gtk3.new/gtk+-3.22.14.tar.xz differ: char 27, line 1




commit gnome-terminal for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-terminal for openSUSE:Factory 
checked in at 2017-05-18 20:39:45

Comparing /work/SRC/openSUSE:Factory/gnome-terminal (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-terminal.new (New)


Package is "gnome-terminal"

Thu May 18 20:39:45 2017 rev:109 rq:494445 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/gnome-terminal/gnome-terminal.changes
2017-04-29 10:48:17.800538651 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-terminal.new/gnome-terminal.changes   
2017-05-18 20:40:30.097463771 +0200
@@ -1,0 +2,6 @@
+Wed May 10 14:34:17 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Updated translations.
+
+---

Old:

  gnome-terminal-3.24.1.tar.xz

New:

  gnome-terminal-3.24.2.tar.xz



Other differences:
--
++ gnome-terminal.spec ++
--- /var/tmp/diff_new_pack.UKYx51/_old  2017-05-18 20:40:31.745231232 +0200
+++ /var/tmp/diff_new_pack.UKYx51/_new  2017-05-18 20:40:31.745231232 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-terminal
-Version:3.24.1
+Version:3.24.2
 Release:0
 Summary:GNOME Terminal
 License:GPL-3.0+ and LGPL-2.1+
@@ -45,7 +45,7 @@
 BuildRequires:  pkgconfig(libnautilus-extension) >= 3.0.0
 BuildRequires:  pkgconfig(libpcre2-8) >= 10.00
 BuildRequires:  pkgconfig(uuid)
-BuildRequires:  pkgconfig(vte-2.91) >= 0.48.0
+BuildRequires:  pkgconfig(vte-2.91) >= 0.48.2
 BuildRequires:  pkgconfig(x11)
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ gnome-terminal-3.24.1.tar.xz -> gnome-terminal-3.24.2.tar.xz ++
 3446 lines of diff (skipped)




commit intltool for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package intltool for openSUSE:Factory 
checked in at 2017-05-18 20:39:23

Comparing /work/SRC/openSUSE:Factory/intltool (Old)
 and  /work/SRC/openSUSE:Factory/.intltool.new (New)


Package is "intltool"

Thu May 18 20:39:23 2017 rev:33 rq:494341 version:0.51.0

Changes:

--- /work/SRC/openSUSE:Factory/intltool/intltool.changes2016-09-05 
21:10:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.intltool.new/intltool.changes   2017-05-18 
20:39:26.058501163 +0200
@@ -1,0 +2,6 @@
+Tue May  2 15:22:35 UTC 2017 - bwiedem...@suse.com
+
+- Add fixrace.patch to fix random desktop file corruptions
+  (lp#1687644 boo#1021335)
+
+---

New:

  fixrace.patch



Other differences:
--
++ intltool.spec ++
--- /var/tmp/diff_new_pack.1Wyf8u/_old  2017-05-18 20:39:28.010225730 +0200
+++ /var/tmp/diff_new_pack.1Wyf8u/_new  2017-05-18 20:39:28.010225730 +0200
@@ -32,6 +32,8 @@
 Source: 
https://launchpad.net/%{name}/trunk/%{version}/+download/%{name}-%{version}.tar.gz
 # PATCH-FIX-UPSTREAM intltool-perl-5.22.patch lp#1490906 dims...@opensuse.org 
-- Fix execution with perl 5.22
 Patch0: intltool-perl-5.22.patch
+# PATCH-FIX-UPSTREAM fixrace.patch lp#1687644 boo#1021335
+Patch1: fixrace.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -43,6 +45,7 @@
 %prep
 %setup -q
 %patch0 -p0
+%patch1 -p1
 
 %build
 %configure

++ fixrace.patch ++
From: Bernhard M. Wiedemann 

avoid a race where some processes try to use a partial cache file
that is still being written to.
Note that we release the lock before load_cache,
because if we got the lock, the cache is already completely written
and it is OK to have multiple parallel readers

Index: intltool-0.51.0/intltool-merge.in
===
--- intltool-0.51.0.orig/intltool-merge.in
+++ intltool-0.51.0/intltool-merge.in
@@ -43,6 +43,7 @@ use Getopt::Long;
 use Text::Wrap;
 use File::Basename;
 use Encode;
+use Fcntl qw(:flock);
 
 my $must_end_tag  = -1;
 my $last_depth= -1;
@@ -392,11 +393,14 @@ sub load_cache
 
 sub get_cached_translation_database
 {
+open(my $lockfh, ">", "$cache_file.lock") or die $!;
+flock($lockfh, LOCK_EX) or die "Could not lock '$cache_file.lock' - $!";
 my $cache_file_age = -M $cache_file;
 if (defined $cache_file_age) 
 {
 if ($cache_file_age <= _newest_po_age) 
 {
+close($lockfh);
 _cache;
 return;
 }
@@ -404,6 +408,7 @@ sub get_cached_translation_database
 }
 
 _cache;
+close($lockfh);
 }
 
 sub add_translation



commit gnome-settings-daemon for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-settings-daemon for 
openSUSE:Factory checked in at 2017-05-18 20:39:17

Comparing /work/SRC/openSUSE:Factory/gnome-settings-daemon (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-settings-daemon.new (New)


Package is "gnome-settings-daemon"

Thu May 18 20:39:17 2017 rev:133 rq:494264 version:3.24.2

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-settings-daemon/gnome-settings-daemon.changes  
2017-04-29 10:50:25.562489391 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-settings-daemon.new/gnome-settings-daemon.changes
 2017-05-18 20:39:19.703398016 +0200
@@ -1,0 +2,11 @@
+Wed May 10 13:03:53 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Fix plugins not getting started under gdm.
+  + Fix mmkeys D-Bus API to match API docs.
+  + Disable rfkill keys handling.
+  + Choose correct backlight device on laptops with hybrid
+graphics.
+  + Updated translations.
+
+---

Old:

  gnome-settings-daemon-3.24.1.tar.xz

New:

  gnome-settings-daemon-3.24.2.tar.xz



Other differences:
--
++ gnome-settings-daemon.spec ++
--- /var/tmp/diff_new_pack.b8kLmT/_old  2017-05-18 20:39:20.775246752 +0200
+++ /var/tmp/diff_new_pack.b8kLmT/_new  2017-05-18 20:39:20.779246189 +0200
@@ -30,7 +30,7 @@
 %endif
 
 Name:   gnome-settings-daemon
-Version:3.24.1
+Version:3.24.2
 Release:0
 Summary:Settings daemon for the GNOME desktop
 License:GPL-2.0+

++ gnome-settings-daemon-3.24.1.tar.xz -> 
gnome-settings-daemon-3.24.2.tar.xz ++
 11101 lines of diff (skipped)




commit vte for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package vte for openSUSE:Factory checked in 
at 2017-05-18 20:39:12

Comparing /work/SRC/openSUSE:Factory/vte (Old)
 and  /work/SRC/openSUSE:Factory/.vte.new (New)


Package is "vte"

Thu May 18 20:39:12 2017 rev:102 rq:494263 version:0.48.3

Changes:

--- /work/SRC/openSUSE:Factory/vte/vte.changes  2017-04-29 10:48:14.592991793 
+0200
+++ /work/SRC/openSUSE:Factory/.vte.new/vte.changes 2017-05-18 
20:39:14.392147556 +0200
@@ -1,0 +2,14 @@
+Wed May 10 12:58:25 UTC 2017 - zai...@opensuse.org
+
+- Update to version 0.48.3:
+  + widget: Add more xkb layout switching codes to the list of
+modifiers.
+  + pty: spawn: Always fill in the GError on failure.
+  + build:
+- vala: Bump vapigen required version to 0.24.
+- vala: Fix check for valac >= 0.31.1.
+  + emulation: Disregard bce only when autowrapping to the new
+line.
+  + Updated translations.
+
+---

Old:

  vte-0.48.2.tar.xz

New:

  vte-0.48.3.tar.xz



Other differences:
--
++ vte.spec ++
--- /var/tmp/diff_new_pack.33xGVI/_old  2017-05-18 20:39:15.008060636 +0200
+++ /var/tmp/diff_new_pack.33xGVI/_new  2017-05-18 20:39:15.008060636 +0200
@@ -24,7 +24,7 @@
 Name:   vte
 %define _name   vte
 Url:http://www.gnome.org
-Version:0.48.2
+Version:0.48.3
 Release:0
 Summary:Terminal Emulator Library
 # Switched to sourceservice, as upstream have a tendency to not release 
tarballs on time.

++ _service ++
--- /var/tmp/diff_new_pack.33xGVI/_old  2017-05-18 20:39:15.036056685 +0200
+++ /var/tmp/diff_new_pack.33xGVI/_new  2017-05-18 20:39:15.036056685 +0200
@@ -4,7 +4,7 @@
 git
 @PARENT_TAG@
 enable
-refs/tags/0.48.2
+refs/tags/0.48.3
   
   
 *.tar

++ _servicedata ++
--- /var/tmp/diff_new_pack.33xGVI/_old  2017-05-18 20:39:15.060053299 +0200
+++ /var/tmp/diff_new_pack.33xGVI/_new  2017-05-18 20:39:15.060053299 +0200
@@ -1,4 +1,4 @@
 
 
 git://git.gnome.org/vte
-  3e7f21006b751136963fd1520dd1b157a68c659c
\ No newline at end of file
+  992c481f21e266e7cdfcee1d425b18da4df9ef8d
\ No newline at end of file

++ vte-0.48.2.tar.xz -> vte-0.48.3.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vte-0.48.2/configure.ac new/vte-0.48.3/configure.ac
--- old/vte-0.48.2/configure.ac 2017-04-10 21:27:19.0 +0200
+++ new/vte-0.48.3/configure.ac 2017-05-04 11:46:02.0 +0200
@@ -1,6 +1,6 @@
 m4_define([version_major],0)
 m4_define([version_minor],48)
-m4_define([version_micro],2)
+m4_define([version_micro],3)
 m4_define([version_triplet],version_major.version_minor.version_micro)
 
 AC_PREREQ([2.63])
@@ -378,7 +378,7 @@
 fi
 
 m4_ifdef([VAPIGEN_CHECK],
-  [VAPIGEN_CHECK([0.18])],
+  [VAPIGEN_CHECK([0.24])],
   [if test "$enable_vala" = "yes"; then
  AC_MSG_ERROR([[Vala requested but M4 macros not installed. Try 
--disable-vala]])
fi
@@ -388,24 +388,19 @@
 # Test Application
 # 
 
-AC_MSG_CHECKING([whether to build the test application])
+AC_MSG_CHECKING([whether to install the vala test application])
 AC_ARG_ENABLE([test-application],
-[AS_HELP_STRING([--disable-test-application],[Disable test 
application])],
+[AS_HELP_STRING([--disable-test-application],[Disable installing the 
vala test application])],
 [],[enable_test_application=$enable_vala])
 AC_MSG_RESULT([$enable_test_application])
 
 AM_PROG_VALAC([0.24.0],[],[
-  if test "$enable_test_application" != "no"; then
-AC_MSG_ERROR([vala support enabled by vala compiler not found])
+  if test "$enable_vala" != "no"; then
+AC_MSG_ERROR([Vala requested but vala compiler >= 0.24.0 not found])
   fi])
 
-if test "$enable_test_application" = "yes"; then
-  PKG_CHECK_MODULES([GTK_3_16],[gtk+-$GTK_API_VERSION >= 
3.16],[have_gtk_3_16=yes],[have_gtk_3_16=no])
-  AM_PROG_VALAC([0.31.1],[have_vala_0_31=yes],[have_vala_0_31=no])
-else
-  have_gtk_3_16=no
-  have_vala_0_31=no
-fi
+PKG_CHECK_MODULES([GTK_3_16],[gtk+-$GTK_API_VERSION >= 
3.16],[have_gtk_3_16=yes],[have_gtk_3_16=no])
+AM_PROG_VALAC([0.31.1],[have_vala_0_31=yes],[have_vala_0_31=no])
 
 AM_CONDITIONAL([ENABLE_TEST_APPLICATION],[test "$enable_test_application" = 
"yes"])
 AM_CONDITIONAL([HAVE_GTK_3_16],[test "$have_gtk_3_16" = "yes"])
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vte-0.48.2/po/be.po new/vte-0.48.3/po/be.po
--- old/vte-0.48.2/po/be.po 2017-04-10 21:27:19.0 +0200
+++ new/vte-0.48.3/po/be.po 2017-05-04 11:46:02.0 +0200
@@ -1,83 +1,76 @@
 # Vital Khilko 

commit gnome-shell-extensions for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-shell-extensions for 
openSUSE:Factory checked in at 2017-05-18 20:39:03

Comparing /work/SRC/openSUSE:Factory/gnome-shell-extensions (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-shell-extensions.new (New)


Package is "gnome-shell-extensions"

Thu May 18 20:39:03 2017 rev:55 rq:494261 version:3.24.1

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-shell-extensions/gnome-shell-extensions.changes
2017-04-29 10:51:29.105512607 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-shell-extensions.new/gnome-shell-extensions.changes
   2017-05-18 20:39:08.996908948 +0200
@@ -50,0 +51,7 @@
+Tue Nov  1 02:28:56 UTC 2016 - xw...@suse.com
+
+- Add SUSE logo on lock screen when auth is requested (bsc#1007468)
+  + sle-classic-lock-screen-background.patch
+  + SLE-theme.tar.gz
+
+---
@@ -54,0 +62,12 @@
+
+---
+Tue Oct 11 05:06:17 UTC 2016 - yfji...@suse.com
+
+- Enable SLE-Classic for Leap 42.2 (bnc#999655)
+  + add workspace indicator back for LEAP 42.2
+
+---
+Tue Sep 20 18:35:46 CST 2016 - cxi...@suse.com
+
+- Enable SLE-Classic for Leap 42.2 (bnc#999655)
+  + modify SPEC to re-enable SLE-Classic for Leap 42.2

New:

  SLE-theme.tar.gz
  sle-classic-lock-screen-background.patch



Other differences:
--
++ gnome-shell-extensions.spec ++
--- /var/tmp/diff_new_pack.m1MzU7/_old  2017-05-18 20:39:10.524693342 +0200
+++ /var/tmp/diff_new_pack.m1MzU7/_new  2017-05-18 20:39:10.528692778 +0200
@@ -29,10 +29,13 @@
 Source: 
http://download.gnome.org/sources/gnome-shell-extensions/3.24/%{name}-%{version}.tar.xz
 Source1:README.SUSE
 Source2:sle-classic.desktop
+Source3:SLE-theme.tar.gz
 # PATCH-FEATURE-SLE gnome-shell-add-app-to-desktop.patch bnc#870580 
dli...@suse.com --  allow adding app shortcut to desktop easily.
 Patch1: gnome-shell-add-app-to-desktop.patch
 # PATCH-FEATURE-SLE sle-classic-favorites-menu-at-end.patch bnc#890989 
cxi...@suse.com -- put the favorites at the end of the app catogories for 
accessibility reason -- cxi...@suse.com bnc#890989
 Patch2: sle-classic-favorites-menu-at-end.patch
+# PATCH-FEATURE-SLE sle-classic-lock-screen-background.patch bsc#1007468 
xw...@suse.com -- add SUSE logo on lock screen when auth is requested
+Patch3: sle-classic-lock-screen-background.patch
 ## NOTE keep SLE Classic patch at the bottom
 # PATCH-FIX-SLE gse-sle-classic-ext.patch Fate#318572 cxi...@suse.com -- add 
sle classic support
 Patch1000:  gse-sle-classic-ext.patch
@@ -98,6 +101,7 @@
 gnome-patch-translation-prepare
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 %patch1000 -p1
 %endif
 ##gnome-patch-translation-update
@@ -123,6 +127,10 @@
 %find_lang %{name} %{?no_lang_C}
 %if !0%{?is_opensuse}
 install -m0644 %{S:2} %{buildroot}/%{_datadir}/xsessions/sle-classic.desktop
+# Install SLE theme
+tar xzvf %{SOURCE3}
+install -d %{buildroot}%{_datadir}/gnome-shell/theme
+cp SLE-theme/theme/*  %{buildroot}%{_datadir}/gnome-shell/theme
 %endif
 
 %post -n gnome-shell-classic
@@ -163,6 +171,7 @@
 %{_datadir}/xsessions/gnome-classic.desktop
 %if !0%{?is_opensuse}
 %{_datadir}/xsessions/sle-classic.desktop
+%{_datadir}/gnome-shell/theme/sle-background.png
 %endif
 
 %files common-lang -f %{name}.lang

++ sle-classic-lock-screen-background.patch ++
diff --git a/data/gnome-classic.css b/data/gnome-classic.css
index 7e1b253..a12ea67 100644
--- a/data/gnome-classic.css
+++ b/data/gnome-classic.css
@@ -1471,7 +1471,8 @@ StScrollBar {
 
 .login-dialog {
   border: none;
-  background-color: transparent; }
+  background-color: transparent;
+  background: #2e3436 url(sle-background.png); }
   .login-dialog .modal-dialog-button-box {
 spacing: 3px; }
   .login-dialog .modal-dialog-button {



commit gnome-maps for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-maps for openSUSE:Factory 
checked in at 2017-05-18 20:38:55

Comparing /work/SRC/openSUSE:Factory/gnome-maps (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-maps.new (New)


Package is "gnome-maps"

Thu May 18 20:38:55 2017 rev:31 rq:494256 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/gnome-maps/gnome-maps.changes2017-04-29 
10:50:45.043737249 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-maps.new/gnome-maps.changes   
2017-05-18 20:39:00.554100422 +0200
@@ -1,0 +2,7 @@
+Tue May  9 12:53:04 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Avoid a use-after-free crash in contact store.
+  + Updated translations.
+
+---

Old:

  gnome-maps-3.24.1.tar.xz

New:

  gnome-maps-3.24.2.tar.xz



Other differences:
--
++ gnome-maps.spec ++
--- /var/tmp/diff_new_pack.MRv1eu/_old  2017-05-18 20:39:01.110021970 +0200
+++ /var/tmp/diff_new_pack.MRv1eu/_new  2017-05-18 20:39:01.114021405 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-maps
-Version:3.24.1
+Version:3.24.2
 Release:0
 Summary:Maps Application for GNOME
 License:GPL-2.0+

++ gnome-maps-3.24.1.tar.xz -> gnome-maps-3.24.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gnome-maps-3.24.1/NEWS new/gnome-maps-3.24.2/NEWS
--- old/gnome-maps-3.24.1/NEWS  2017-04-10 21:07:33.0 +0200
+++ new/gnome-maps-3.24.2/NEWS  2017-05-08 23:02:18.0 +0200
@@ -1,3 +1,16 @@
+3.24.2 - May 8, 2017
+=
+
+Changes since 3.24.1:
+  - Avoid a use-after-free crash in contact store.
+
+Added/updated/fixed translations:
+  - Slovenian
+
+All contributors to this release:
+Marcus Lundblad 
+Matej Urbančič 
+
 3.24.1 - Apr 10, 2017
 =
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gnome-maps-3.24.1/configure 
new/gnome-maps-3.24.2/configure
--- old/gnome-maps-3.24.1/configure 2017-04-10 21:08:36.0 +0200
+++ new/gnome-maps-3.24.2/configure 2017-05-08 23:03:36.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for gnome-maps 3.24.1.
+# Generated by GNU Autoconf 2.69 for gnome-maps 3.24.2.
 #
 # Report bugs to .
 #
@@ -591,8 +591,8 @@
 # Identity of this package.
 PACKAGE_NAME='gnome-maps'
 PACKAGE_TARNAME='gnome-maps'
-PACKAGE_VERSION='3.24.1'
-PACKAGE_STRING='gnome-maps 3.24.1'
+PACKAGE_VERSION='3.24.2'
+PACKAGE_STRING='gnome-maps 3.24.2'
 PACKAGE_BUGREPORT='https://bugzilla.gnome.org/enter_bug.cgi?product=gnome-maps'
 PACKAGE_URL=''
 
@@ -1403,7 +1403,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures gnome-maps 3.24.1 to adapt to many kinds of systems.
+\`configure' configures gnome-maps 3.24.2 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1475,7 +1475,7 @@
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
- short | recursive ) echo "Configuration of gnome-maps 3.24.1:";;
+ short | recursive ) echo "Configuration of gnome-maps 3.24.2:";;
esac
   cat <<\_ACEOF
 
@@ -1606,7 +1606,7 @@
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-gnome-maps configure 3.24.1
+gnome-maps configure 3.24.2
 generated by GNU Autoconf 2.69
 
 Copyright (C) 2012 Free Software Foundation, Inc.
@@ -1884,7 +1884,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by gnome-maps $as_me 3.24.1, which was
+It was created by gnome-maps $as_me 3.24.2, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   $ $0 $@
@@ -2876,7 +2876,7 @@
 
 # Define the identity of the package.
  PACKAGE='gnome-maps'
- VERSION='3.24.1'
+ VERSION='3.24.2'
 
 
 # Some tools Automake needs.
@@ -13930,7 +13930,7 @@
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log="
-This file was extended by gnome-maps $as_me 3.24.1, which was
+This file was extended by gnome-maps $as_me 3.24.2, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   CONFIG_FILES= $CONFIG_FILES
@@ -13996,7 +13996,7 @@
 cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
 ac_cs_config="`$as_echo 

commit glib2 for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package glib2 for openSUSE:Factory checked 
in at 2017-05-18 20:38:45

Comparing /work/SRC/openSUSE:Factory/glib2 (Old)
 and  /work/SRC/openSUSE:Factory/.glib2.new (New)


Package is "glib2"

Thu May 18 20:38:45 2017 rev:183 rq:494255 version:2.52.2

Changes:

--- /work/SRC/openSUSE:Factory/glib2/glib2.changes  2017-04-29 
10:48:39.749437853 +0200
+++ /work/SRC/openSUSE:Factory/.glib2.new/glib2.changes 2017-05-18 
20:38:48.971734961 +0200
@@ -1,0 +2,8 @@
+Tue May  9 12:39:42 UTC 2017 - zai...@opensuse.org
+
+- Update to version 2.52.2:
+  + Bugs fixed: bgo#734946, bgo#761102, bgo#780300, bgo#780309,
+bgo#781298.
+  + Updated translations.
+
+---

Old:

  glib-2.52.1.tar.xz

New:

  glib-2.52.2.tar.xz



Other differences:
--
++ glib2.spec ++
--- /var/tmp/diff_new_pack.BzO5F9/_old  2017-05-18 20:38:50.979451625 +0200
+++ /var/tmp/diff_new_pack.BzO5F9/_new  2017-05-18 20:38:50.979451625 +0200
@@ -20,7 +20,7 @@
 
 Name:   glib2
 %define _name glib
-Version:2.52.1
+Version:2.52.2
 Release:0
 # FIXME: find out if tapsets should really be in devel package or in main 
package
 Summary:General-Purpose Utility Library

++ glib-2.52.1.tar.xz -> glib-2.52.2.tar.xz ++
/work/SRC/openSUSE:Factory/glib2/glib-2.52.1.tar.xz 
/work/SRC/openSUSE:Factory/.glib2.new/glib-2.52.2.tar.xz differ: char 26, line 1




commit gjs for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gjs for openSUSE:Factory checked in 
at 2017-05-18 20:38:36

Comparing /work/SRC/openSUSE:Factory/gjs (Old)
 and  /work/SRC/openSUSE:Factory/.gjs.new (New)


Package is "gjs"

Thu May 18 20:38:36 2017 rev:63 rq:494253 version:1.48.3

Changes:

--- /work/SRC/openSUSE:Factory/gjs/gjs.changes  2017-04-29 10:48:44.060828769 
+0200
+++ /work/SRC/openSUSE:Factory/.gjs.new/gjs.changes 2017-05-18 
20:38:43.736473776 +0200
@@ -1,0 +2,14 @@
+Sun May  7 18:44:03 UTC 2017 - zai...@opensuse.org
+
+- Update to version 1.48.3:
+  + arg: don't crash when asked to convert a null strv to an array
+(bgo#775679).
+  + gjs 1.48.0: does not compile on macOS with clang (bgo#780350).
+  + Modernize shell scripts (bgo#781806).
+- Changes from version 1.48.2:
+  + Intermittent crash in gnome-shell, probably in weak pointer
+updating code (bgo#781194).
+  + Add contributor's guide (bgo#781297).
+  + Misc fixes.
+
+---

Old:

  gjs-1.48.1.tar.xz

New:

  gjs-1.48.3.tar.xz



Other differences:
--
++ gjs.spec ++
--- /var/tmp/diff_new_pack.K07SnD/_old  2017-05-18 20:38:45.400238980 +0200
+++ /var/tmp/diff_new_pack.K07SnD/_new  2017-05-18 20:38:45.404238416 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gjs
-Version:1.48.1
+Version:1.48.3
 Release:0
 # FIXME: find out if tapsets should really be in devel package or in main 
package
 Summary:JavaScript bindings based on gobject-introspection and Mozilla

++ gjs-1.48.1.tar.xz -> gjs-1.48.3.tar.xz ++
 25688 lines of diff (skipped)




commit nautilus for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package nautilus for openSUSE:Factory 
checked in at 2017-05-18 20:38:30

Comparing /work/SRC/openSUSE:Factory/nautilus (Old)
 and  /work/SRC/openSUSE:Factory/.nautilus.new (New)


Package is "nautilus"

Thu May 18 20:38:30 2017 rev:158 rq:494252 version:3.24.1

Changes:

--- /work/SRC/openSUSE:Factory/nautilus/nautilus.changes2017-03-22 
23:15:07.890540210 +0100
+++ /work/SRC/openSUSE:Factory/.nautilus.new/nautilus.changes   2017-05-18 
20:38:32.826013491 +0200
@@ -1,0 +2,12 @@
+Sat Apr 29 19:26:44 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.1:
+  + Focus when a new folder is created.
+  + Do not consider directory names with dots as extensions.
+  + Fix move to/copy to when searching.
+  + Various fixes to the new experimental views.
+  + Fix scripts order in submenu.
+  + Fix open in new tab/window in Other Places.
+  + Show new networks available while in Other Places view.
+
+---

Old:

  nautilus-3.24.0.tar.xz

New:

  nautilus-3.24.1.tar.xz



Other differences:
--
++ nautilus.spec ++
--- /var/tmp/diff_new_pack.ue82nu/_old  2017-05-18 20:38:34.637757813 +0200
+++ /var/tmp/diff_new_pack.ue82nu/_new  2017-05-18 20:38:34.637757813 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   nautilus
-Version:3.24.0
+Version:3.24.1
 Release:0
 Summary:File Manager for the GNOME Desktop
 License:GPL-2.0+

++ nautilus-3.24.0.tar.xz -> nautilus-3.24.1.tar.xz ++
 32138 lines of diff (skipped)




commit gnome-disk-utility for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gnome-disk-utility for 
openSUSE:Factory checked in at 2017-05-18 20:38:20

Comparing /work/SRC/openSUSE:Factory/gnome-disk-utility (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-disk-utility.new (New)


Package is "gnome-disk-utility"

Thu May 18 20:38:20 2017 rev:53 rq:494250 version:3.24.1

Changes:

--- /work/SRC/openSUSE:Factory/gnome-disk-utility/gnome-disk-utility.changes
2017-03-22 23:05:21.565617882 +0100
+++ 
/work/SRC/openSUSE:Factory/.gnome-disk-utility.new/gnome-disk-utility.changes   
2017-05-18 20:38:28.286654098 +0200
@@ -1,0 +2,8 @@
+Sat May  6 20:30:35 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.1:
+  + Fix unmounting and probing of mounted volumes.
+  + Fix wrong behavior of filesystem creation dialog.
+  + Updated translations.
+
+---

Old:

  gnome-disk-utility-3.24.0.tar.xz

New:

  gnome-disk-utility-3.24.1.tar.xz



Other differences:
--
++ gnome-disk-utility.spec ++
--- /var/tmp/diff_new_pack.KWJ4PT/_old  2017-05-18 20:38:29.482485339 +0200
+++ /var/tmp/diff_new_pack.KWJ4PT/_new  2017-05-18 20:38:29.486484775 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-disk-utility
-Version:3.24.0
+Version:3.24.1
 Release:0
 Summary:Disks application for dealing with storage devices
 License:GPL-2.0+

++ gnome-disk-utility-3.24.0.tar.xz -> gnome-disk-utility-3.24.1.tar.xz 
++
 13394 lines of diff (skipped)




commit gvfs for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gvfs for openSUSE:Factory checked in 
at 2017-05-18 20:38:11

Comparing /work/SRC/openSUSE:Factory/gvfs (Old)
 and  /work/SRC/openSUSE:Factory/.gvfs.new (New)


Package is "gvfs"

Thu May 18 20:38:11 2017 rev:134 rq:494246 version:1.32.1

Changes:

--- /work/SRC/openSUSE:Factory/gvfs/gvfs.changes2017-03-22 
23:07:46.221118169 +0100
+++ /work/SRC/openSUSE:Factory/.gvfs.new/gvfs.changes   2017-05-18 
20:38:18.280066256 +0200
@@ -1,0 +2,13 @@
+Fri May  5 10:00:59 UTC 2017 - zai...@opensuse.org
+
+- Update to version 1.32.1:
+  + common: Fix potential crash caused by missing g_strdup.
+  + fuse: Prevent potential crash if file handle is not set.
+  + sftp: Prevent potential crash in case of parsing error.
+  + google:
+- Prevent potential crashes if resolve_dir fails.
+- Fix reported file size.
+  + gphoto2: Fix x-content-types setup.
+  + Updated translations.
+
+---

Old:

  gvfs-1.32.0.tar.xz

New:

  gvfs-1.32.1.tar.xz



Other differences:
--
++ gvfs.spec ++
--- /var/tmp/diff_new_pack.HWK4Eq/_old  2017-05-18 20:38:19.055956760 +0200
+++ /var/tmp/diff_new_pack.HWK4Eq/_new  2017-05-18 20:38:19.059956195 +0200
@@ -20,7 +20,7 @@
 %define with_cdda 1
 
 Name:   gvfs
-Version:1.32.0
+Version:1.32.1
 Release:0
 Summary:VFS functionality for GLib
 License:LGPL-2.0+

++ gvfs-1.32.0.tar.xz -> gvfs-1.32.1.tar.xz ++
 7693 lines of diff (skipped)




commit patterns-gnome for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package patterns-gnome for openSUSE:Factory 
checked in at 2017-05-18 20:38:01

Comparing /work/SRC/openSUSE:Factory/patterns-gnome (Old)
 and  /work/SRC/openSUSE:Factory/.patterns-gnome.new (New)


Package is "patterns-gnome"

Thu May 18 20:38:01 2017 rev:2 rq:494243 version:20170319

Changes:

--- /work/SRC/openSUSE:Factory/patterns-gnome/patterns-gnome.changes
2017-05-06 18:23:39.825920885 +0200
+++ /work/SRC/openSUSE:Factory/.patterns-gnome.new/patterns-gnome.changes   
2017-05-18 20:38:02.670269152 +0200
@@ -1,0 +2,5 @@
+Wed May  3 08:51:13 UTC 2017 - jeng...@inai.de
+
+- Compact %install routine; replace old RPM shell vars by macros.
+
+---



Other differences:
--
++ patterns-gnome.spec ++
--- /var/tmp/diff_new_pack.vXuXxf/_old  2017-05-18 20:38:03.238189005 +0200
+++ /var/tmp/diff_new_pack.vXuXxf/_new  2017-05-18 20:38:03.238189005 +0200
@@ -815,22 +815,11 @@
 %build
 
 %install
-mkdir -p $RPM_BUILD_ROOT/usr/share/doc/packages/patterns/
-echo 'This file marks the pattern devel_gnome to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/devel_gnome.txt
-echo 'This file marks the pattern gnome to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome.txt
-echo 'This file marks the pattern gnome_admin to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_admin.txt
-echo 'This file marks the pattern gnome_basis to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_basis.txt
-echo 'This file marks the pattern gnome_basis_opt to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_basis_opt.txt
-echo 'This file marks the pattern gnome_games to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_games.txt
-echo 'This file marks the pattern gnome_ide to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_ide.txt
-echo 'This file marks the pattern gnome_imaging to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_imaging.txt
-echo 'This file marks the pattern gnome_imaging_opt to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_imaging_opt.txt
-echo 'This file marks the pattern gnome_internet to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_internet.txt
-echo 'This file marks the pattern gnome_laptop to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_laptop.txt
-echo 'This file marks the pattern gnome_multimedia to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_multimedia.txt
-echo 'This file marks the pattern gnome_multimedia_opt to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_multimedia_opt.txt
-echo 'This file marks the pattern gnome_office to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_office.txt
-echo 'This file marks the pattern gnome_office_opt to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_office_opt.txt
-echo 'This file marks the pattern gnome_utilities to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_utilities.txt
-echo 'This file marks the pattern gnome_yast to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/gnome_yast.txt
-echo 'This file marks the pattern sw_management_gnome to be installed.' > 
$RPM_BUILD_ROOT/usr/share/doc/packages/patterns/sw_management_gnome.txt
+mkdir -p "%{buildroot}/usr/share/doc/packages/patterns"
+for i in devel_gnome gnome gnome_admin gnome_basis gnome_basis_opt \
+gnome_games gnome_ide gnome_imaging gnome_imaging_opt gnome_internet \
+gnome_laptop gnome_multimedia gnome_multimedia_opt gnome_office \
+gnome_office_opt gnome_utilities gnome_yast sw_management_gnome; do
+   echo "This file marks the pattern $i to be installed." \
+   >"%{buildroot}/usr/share/doc/packages/patterns/$i.txt"
+done




commit gdk-pixbuf for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package gdk-pixbuf for openSUSE:Factory 
checked in at 2017-05-18 20:37:47

Comparing /work/SRC/openSUSE:Factory/gdk-pixbuf (Old)
 and  /work/SRC/openSUSE:Factory/.gdk-pixbuf.new (New)


Package is "gdk-pixbuf"

Thu May 18 20:37:47 2017 rev:60 rq:494241 version:2.36.6

Changes:

--- /work/SRC/openSUSE:Factory/gdk-pixbuf/gdk-pixbuf.changes2017-04-11 
12:39:34.274001035 +0200
+++ /work/SRC/openSUSE:Factory/.gdk-pixbuf.new/gdk-pixbuf.changes   
2017-05-18 20:37:56.371158099 +0200
@@ -1,0 +2,5 @@
+Wed May 10 09:10:45 UTC 2017 - dims...@opensuse.org
+
+- Supplement libgdk_pixbuf-2_0-0 by the thumbnailers (boo#1037100).
+
+---
@@ -65 +70 @@
-- Split the external thumbnailer into gdk-pixbug-thumbnailer.
+- Split the external thumbnailer into gdk-pixbuf-thumbnailer.



Other differences:
--
++ gdk-pixbuf.spec ++
--- /var/tmp/diff_new_pack.9hpWFW/_old  2017-05-18 20:37:57.554991033 +0200
+++ /var/tmp/diff_new_pack.9hpWFW/_new  2017-05-18 20:37:57.554991033 +0200
@@ -88,6 +88,7 @@
 %package thumbnailer
 Summary:System helper creating thumbnails
 Group:  System/Libraries
+Supplements:libgdk_pixbuf-2_0-0
 
 %description thumbnailer
 gdk-pixbuf is an image loading library that can be extended by loadable




commit python-gobject for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package python-gobject for openSUSE:Factory 
checked in at 2017-05-18 20:37:26

Comparing /work/SRC/openSUSE:Factory/python-gobject (Old)
 and  /work/SRC/openSUSE:Factory/.python-gobject.new (New)


Package is "python-gobject"

Thu May 18 20:37:26 2017 rev:66 rq:494087 version:3.24.1

Changes:

--- /work/SRC/openSUSE:Factory/python-gobject/python-gobject.changes
2017-03-22 23:08:14.577099980 +0100
+++ /work/SRC/openSUSE:Factory/.python-gobject.new/python-gobject.changes   
2017-05-18 20:37:38.845631346 +0200
@@ -1,0 +2,16 @@
+Wed Apr 19 14:34:42 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.1:
+  + pygi-info: initialize GIArgument before passing it to
+g_constant_info_get_value (bgo#772949).
+
+---
+Mon Mar 27 18:08:28 UTC 2017 - toddrme2...@gmail.com
+
+- Switch to single-spec version.
+- Add python version-dependent wrapper packages to pull in
+  necessary dependencies.
+- Include all dependencies in -devel packages.
+- Rebase .changes file to include changes in -devel package.
+
+---

Old:

  pre_checkin.sh
  pygobject-3.24.0.tar.xz
  python3-gobject.changes
  python3-gobject.spec

New:

  pygobject-3.24.1.tar.xz



Other differences:
--
++ python-gobject.spec ++
--- /var/tmp/diff_new_pack.lTI8ea/_old  2017-05-18 20:37:41.513254885 +0200
+++ /var/tmp/diff_new_pack.lTI8ea/_new  2017-05-18 20:37:41.513254885 +0200
@@ -16,72 +16,54 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+
 # This figures in an error message
 %global __requires_exclude typelib\\(%%namespaces\\)
-%global __requires_exclude_from ^%{local_py_sitedir}/gi/__init__.py$
-%define build_for_python3 0
-
-%if %{build_for_python3}
-%define local_py_requires Requires: python(abi) = %py3_ver
-%define local_py_sitedir  %{python3_sitearch}
-%define local_py_suffix   3
-%define local_py_pkg  python3
-%define local_lib_ver 3-0
-%else
-%define local_py_requires %{py_requires}
-%define local_py_sitedir  %{py_sitedir}
-%define local_py_suffix   2
-%define local_py_pkg  python 
-%define local_lib_ver 2-0
-%endif
+%global __requires_exclude_from ^%{python2_sitearch}/gi/__init__.py$
+%global __requires_exclude_from ^%{python3_sitearch}/gi/__init__.py$
 
 Name:   python-gobject
 %define _name   pygobject
 Summary:Python bindings for GObject
 License:LGPL-2.1+
 Group:  Development/Libraries/Python
-Version:3.24.0
+Version:3.24.1
 Release:0
 Url:https://wiki.gnome.org/Projects/PyGObject/
 Source: 
http://download.gnome.org/sources/pygobject/3.24/%{_name}-%{version}.tar.xz
 # PATCH-FIX-UPSTREAM pycompile-searchpath.patch jmate...@suse.com -- Fix build 
with python 3.4
 Patch1: pycompile-searchpath.patch
+BuildRequires:  %{python_module cairo-devel}
+BuildRequires:  %{python_module cairo}
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  glib2-devel >= 2.38.0
 BuildRequires:  gnome-common
 BuildRequires:  gobject-introspection-devel >= 1.46.0
 BuildRequires:  libffi-devel >= 3.0.0
-%if %{build_for_python3}
-BuildRequires:  python3-cairo-devel
-BuildRequires:  python3-devel
-%else
-BuildRequires:  python-cairo-devel
-BuildRequires:  python-devel
-%endif
+BuildRequires:  python-rpm-macros
 BuildRequires:  pkgconfig(cairo)
 BuildRequires:  pkgconfig(cairo-gobject)
 # Trigger an automatic installation of python(3)?-gobject when python and 
libgirepository are installed.
-Supplements:packageand(%{local_py_pkg}:libgirepository-1_0-1)
-%if %local_py_suffix == 2
-Provides:   python2-gobject = %{version}
-%endif
+Supplements:packageand(python:%{gdk_real_package})
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%{local_py_requires}
+
+%python_subpackages
 
 %description
 Pygobjects is an extension module for python that gives you access to
 GLib's GObjects.
 
+
 %package Gdk
 Summary:Python bindings for GObject -- Gdk bindings
 Group:  Development/Libraries/Python
 Requires:   %{name} = %{version}
 Requires:   %{name}-cairo = %{version}
-%if %local_py_suffix == 2
-Provides:   python2-gobject-Gdk = %{version}
-%endif
-%define gdk_real_package %(rpm -q --qf '%%{NAME}' -f $(readlink 
/usr/lib64/libgdk-3.so -f))
-Supplements:packageand(%{name}:%{gdk_real_package})
+%define gdk_real_package %(rpm -q --qf '%%{NAME}' -f $(readlink 
%{_libdir}/libgdk-3.so -f))
+Supplements:packageand(python-gobject:%{gdk_real_package})
 
 %description Gdk
 Pygobjects is an 

commit sysprof for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package sysprof for openSUSE:Factory checked 
in at 2017-05-18 20:37:12

Comparing /work/SRC/openSUSE:Factory/sysprof (Old)
 and  /work/SRC/openSUSE:Factory/.sysprof.new (New)


Package is "sysprof"

Thu May 18 20:37:12 2017 rev:7 rq:494084 version:3.24.1

Changes:

--- /work/SRC/openSUSE:Factory/sysprof/sysprof.changes  2017-03-22 
23:05:56.252702039 +0100
+++ /work/SRC/openSUSE:Factory/.sysprof.new/sysprof.changes 2017-05-18 
20:37:25.851465115 +0200
@@ -1,0 +2,7 @@
+Tue Apr 25 11:05:58 UTC 2017 - dims...@opensuse.org
+
+- Update to version 3.24.1:
+  + About dialog is now modal to it's direct parent only.
+  + Updated translations.
+
+---

Old:

  sysprof-3.24.0.tar.xz

New:

  sysprof-3.24.1.tar.xz



Other differences:
--
++ sysprof.spec ++
--- /var/tmp/diff_new_pack.rM26dh/_old  2017-05-18 20:37:26.455379888 +0200
+++ /var/tmp/diff_new_pack.rM26dh/_new  2017-05-18 20:37:26.455379888 +0200
@@ -18,13 +18,13 @@
 
 
 Name:   sysprof
-Version:3.24.0
+Version:3.24.1
 Release:0
 Summary:A system-wide Linux profiler
 License:GPL-3.0+
 Group:  Development/Tools/Debuggers
 Url:http://www.sysprof.com
-Source0:
https://download.gnome.org/sources/sysprof/3.24/sysprof-%{version}.tar.xz
+Source0:
http://download.gnome.org/sources/sysprof/3.24/%{name}-%{version}.tar.xz
 BuildRequires:  binutils-devel
 BuildRequires:  gcc-c++
 BuildRequires:  gettext

++ sysprof-3.24.0.tar.xz -> sysprof-3.24.1.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sysprof-3.24.0/ChangeLog new/sysprof-3.24.1/ChangeLog
--- old/sysprof-3.24.0/ChangeLog2017-03-20 06:41:06.0 +0100
+++ new/sysprof-3.24.1/ChangeLog2017-04-11 00:33:32.0 +0200
@@ -1,6 +1,47 @@
+commit 39ec064f3922e158141ba4e17514959b81b131c3
+Author: Christian Hergert 
+Date:   Mon Apr 10 15:33:26 2017 -0700
+
+Release 3.24.1
+
+M  NEWS
+M  configure.ac
+
+commit 4775b8d362c73a0a5ff3e5f1e659d232b481ed0d
+Author: Dimitrios Christidis 
+Date:  Sat Apr 8 14:33:31 2017 +0200
+
+window: add each instance to each own group
+
+Prevents the About dialog from blocking interactions on all windows.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=781053
+
+M  src/sp-window.c
+
+commit 1808d562b596def650ad155625315f90b02b79d7
+Author: Dimitrios Christidis 
+Date:  Sat Apr 8 14:32:15 2017 +0200
+
+app: make About dialog modal
+
+Makes Sysprof consistent with other GNOME applications.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=781053
+
+M  src/sp-application.c
+
+commit 09b521bff98a26dab0b5147e9fa8b18c365c4046
+Author: Dušan Kazik 
+Date:  Sat Apr 1 07:03:24 2017 +
+
+Update Slovak translation
+
+M  po/sk.po
+
 commit e87caf63bbc8bf478bc02924650c8f739a654fcb
 Author: Christian Hergert 
-Date:   Sun Mar 19 22:24:26 2017 -0700
+Date:  Sun Mar 19 22:24:26 2017 -0700
 
 release 3.24.0
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sysprof-3.24.0/NEWS new/sysprof-3.24.1/NEWS
--- old/sysprof-3.24.0/NEWS 2017-03-20 06:40:34.0 +0100
+++ new/sysprof-3.24.1/NEWS 2017-04-11 00:31:32.0 +0200
@@ -1,3 +1,14 @@
+Overview of changes in Sysprof 3.24.1
+=
+
+Changes since 3.24.0
+
+ * About dialog is now modal to it's direct parent only (Dimitrios Christidis)
+
+Translations:
+
+ * Slovak (Dušan Kazik)
+
 Overview of changes in Sysprof 3.24.0
 =
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sysprof-3.24.0/configure new/sysprof-3.24.1/configure
--- old/sysprof-3.24.0/configure2017-03-20 06:36:03.0 +0100
+++ new/sysprof-3.24.1/configure2017-04-11 00:31:53.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for sysprof 3.24.0.
+# Generated by GNU Autoconf 2.69 for sysprof 3.24.1.
 #
 # Report bugs to .
 #
@@ -590,8 +590,8 @@
 # Identity of this package.
 PACKAGE_NAME='sysprof'
 PACKAGE_TARNAME='sysprof'
-PACKAGE_VERSION='3.24.0'
-PACKAGE_STRING='sysprof 3.24.0'
+PACKAGE_VERSION='3.24.1'
+PACKAGE_STRING='sysprof 3.24.1'
 PACKAGE_BUGREPORT='https://bugzilla.gnome.org/enter_bug.cgi?product=sysprof'
 PACKAGE_URL=''
 
@@ -1438,7 

commit harfbuzz for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package harfbuzz for openSUSE:Factory 
checked in at 2017-05-18 20:36:59

Comparing /work/SRC/openSUSE:Factory/harfbuzz (Old)
 and  /work/SRC/openSUSE:Factory/.harfbuzz.new (New)


Package is "harfbuzz"

Thu May 18 20:36:59 2017 rev:54 rq:494082 version:1.4.6

Changes:

--- /work/SRC/openSUSE:Factory/harfbuzz/harfbuzz.changes2017-03-22 
23:05:00.860552258 +0100
+++ /work/SRC/openSUSE:Factory/.harfbuzz.new/harfbuzz.changes   2017-05-18 
20:37:20.856170063 +0200
@@ -1,0 +2,8 @@
+Tue Apr 25 10:26:28 UTC 2017 - dims...@opensuse.org
+
+- Update to version 1.4.6:
+  + Graphite2: Fix RTL positioning issue.
+  + Backlist GDEF of more versions of Padauk and Tahoma.
+  + New, experimental, cmake alternative build system.
+
+---

Old:

  harfbuzz-1.4.5.tar.bz2

New:

  harfbuzz-1.4.6.tar.bz2



Other differences:
--
++ harfbuzz.spec ++
--- /var/tmp/diff_new_pack.GBNnEC/_old  2017-05-18 20:37:21.388094996 +0200
+++ /var/tmp/diff_new_pack.GBNnEC/_new  2017-05-18 20:37:21.392094431 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   harfbuzz
-Version:1.4.5
+Version:1.4.6
 Release:0
 Summary:An OpenType text shaping engine
 License:MIT

++ harfbuzz-1.4.5.tar.bz2 -> harfbuzz-1.4.6.tar.bz2 ++
 2031 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/harfbuzz-1.4.5/CMakeLists.txt new/harfbuzz-1.4.6/CMakeLists.txt
--- old/harfbuzz-1.4.5/CMakeLists.txt   1970-01-01 01:00:00.0 +0100
+++ new/harfbuzz-1.4.6/CMakeLists.txt   2017-04-20 20:13:56.0 +0200
@@ -0,0 +1,361 @@
+cmake_minimum_required(VERSION 2.8.0)
+project(harfbuzz)
+
+## Disallow in-source builds
+if ("${PROJECT_BINARY_DIR}" STREQUAL "${PROJECT_SOURCE_DIR}")
+  message(FATAL_ERROR
+"
+In-source builds are not permitted!  Make a separate folder for"
+" building, e.g.,"
+"
+  mkdir build; cd build; cmake .."
+"
+Before that, remove the files created by this failed run with"
+"
+  rm -rf CMakeCache.txt CMakeFiles")
+endif ()
+##
+
+## HarfBuzz build configurations
+option(HB_HAVE_FREETYPE "Enable freetype interop helpers" OFF)
+option(HB_HAVE_GRAPHITE2 "Enable Graphite2 complementary shaper" OFF)
+option(HB_BUILTIN_UCDN "Use HarfBuzz provided UCDN" ON)
+option(HB_HAVE_GLIB "Enable glib unicode functions" OFF)
+option(HB_HAVE_ICU "Enable icu unicode functions" OFF)
+if (APPLE)
+  option(HB_HAVE_CORETEXT "Enable CoreText shaper backend on macOS" ON)
+endif ()
+if (WIN32)
+  option(HB_HAVE_UNISCRIBE "Enable Uniscribe shaper backend on Windows" OFF)
+  option(HB_HAVE_DIRECWRITE "Enable DirectWrite shaper backend on Windows" OFF)
+endif ()
+option(HB_BUILD_UTILS "Build harfbuzz utils, needs cairo, freetype, and glib 
properly be installed" OFF)
+if (HB_BUILD_UTILS)
+  set(HB_HAVE_GLIB ON)
+  set(HB_HAVE_FREETYPE ON)
+endif ()
+
+include_directories(AFTER
+  ${PROJECT_SOURCE_DIR}/src
+  ${PROJECT_BINARY_DIR}/src
+  )
+
+add_definitions(-DHAVE_OT)
+
+if (BUILD_SHARED_LIBS)
+  add_definitions(-DHAVE_ATEXIT)
+endif ()
+
+if (MSVC)
+  add_definitions(-wd4244 -wd4267 -D_CRT_SECURE_NO_WARNINGS 
-D_CRT_NONSTDC_NO_WARNINGS)
+endif ()
+
+if (WIN32 AND NOT MINGW AND BUILD_SHARED_LIBS)
+  add_definitions("-DHB_EXTERN=__declspec(dllexport) extern")
+endif ()
+##
+
+set(IN_HB_DIST FALSE)
+if (EXISTS "${PROJECT_SOURCE_DIR}/src/hb-version.h")
+  # perhaps we are on dist directory
+  set(IN_HB_DIST TRUE)
+  set(HB_VERSION_H "${PROJECT_SOURCE_DIR}/src/hb-version.h")
+endif ()
+
+## Extract variables from Makefile files
+# http://stackoverflow.com/a/27630120/1414809
+function (prepend var prefix)
+  set(listVar "")
+  foreach (f ${ARGN})
+list(APPEND listVar "${prefix}${f}")
+  endforeach ()
+  set(${var} "${listVar}" PARENT_SCOPE)
+endfunction ()
+
+function (extract_make_variable variable file prefix)
+  string(REGEX MATCH "${variable} = ([^$]+)\\$" temp ${file})
+  string(REGEX MATCHALL "[^ \n\t\\]+" list ${CMAKE_MATCH_1})
+  prepend(list ${prefix} ${list})
+  set(${variable} ${list} PARENT_SCOPE)
+endfunction ()
+
+file(READ ${PROJECT_SOURCE_DIR}/src/Makefile.sources SRCSOURCES)
+file(READ ${PROJECT_SOURCE_DIR}/util/Makefile.sources UTILSOURCES)
+file(READ ${PROJECT_SOURCE_DIR}/src/hb-ucdn/Makefile.sources UCDNSOURCES)
+
+extract_make_variable(HB_BASE_sources ${SRCSOURCES} 
"${PROJECT_SOURCE_DIR}/src/")

commit accountsservice for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package accountsservice for openSUSE:Factory 
checked in at 2017-05-18 20:36:47

Comparing /work/SRC/openSUSE:Factory/accountsservice (Old)
 and  /work/SRC/openSUSE:Factory/.accountsservice.new (New)


Package is "accountsservice"

Thu May 18 20:36:47 2017 rev:52 rq:494078 version:0.6.45

Changes:

--- /work/SRC/openSUSE:Factory/accountsservice/accountsservice.changes  
2017-02-26 17:08:03.438813845 +0100
+++ /work/SRC/openSUSE:Factory/.accountsservice.new/accountsservice.changes 
2017-05-18 20:37:17.280674645 +0200
@@ -1,0 +2,10 @@
+Tue Apr 25 08:45:58 UTC 2017 - dims...@opensuse.org
+
+- Update to version 0.6.45:
+  + Wrap password expiration info in libaccountsservice api.
+- Changes from version 0.6.44:
+  + Export password expiration info from shadow file.
+  + Fix user classification logic.
+  + Don't lose track of users when /etc/passwd is reloaded.
+
+---

Old:

  accountsservice-0.6.43.tar.xz

New:

  accountsservice-0.6.45.tar.xz



Other differences:
--
++ accountsservice.spec ++
--- /var/tmp/diff_new_pack.GXGGKg/_old  2017-05-18 20:37:17.968577566 +0200
+++ /var/tmp/diff_new_pack.GXGGKg/_new  2017-05-18 20:37:17.972577002 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package accountsservice
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   accountsservice
-Version:0.6.43
+Version:0.6.45
 Release:0
 Summary:D-Bus Service to Manipulate User Account Information
 License:GPL-3.0+

++ accountsservice-0.6.43.tar.xz -> accountsservice-0.6.45.tar.xz ++
 3703 lines of diff (skipped)




commit vala for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package vala for openSUSE:Factory checked in 
at 2017-05-18 20:37:20

Comparing /work/SRC/openSUSE:Factory/vala (Old)
 and  /work/SRC/openSUSE:Factory/.vala.new (New)


Package is "vala"

Thu May 18 20:37:20 2017 rev:72 rq:494086 version:0.36.2

Changes:

--- /work/SRC/openSUSE:Factory/vala/vala.changes2017-04-11 
12:41:14.803796627 +0200
+++ /work/SRC/openSUSE:Factory/.vala.new/vala.changes   2017-05-18 
20:37:26.931312724 +0200
@@ -1,0 +2,13 @@
+Wed Apr 26 11:36:34 UTC 2017 - dims...@opensuse.org
+
+- Update to version 0.36.2:
+  + Enums require at least one value otherwise report an error.
+  + Bindings:
+ - gstreamer-1.0: Update to 1.11.90+.
+ - gio-2.0: Fix GLib.Task constructor and
+   report_error/report_new_error()
+ - glib-2.0:
+   . Add quark() functions to errordomains.
+   . Add missing version macro and constants.
+
+---

Old:

  vala-0.36.1.tar.xz

New:

  vala-0.36.2.tar.xz



Other differences:
--
++ vala.spec ++
--- /var/tmp/diff_new_pack.AApSoA/_old  2017-05-18 20:37:27.547225805 +0200
+++ /var/tmp/diff_new_pack.AApSoA/_new  2017-05-18 20:37:27.551225240 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   vala
-Version:0.36.1
+Version:0.36.2
 Release:0
 %define vala_version 0.36
 %define vala_libversion 0_36

++ vala-0.36.1.tar.xz -> vala-0.36.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vala-0.36.1/.tarball-version 
new/vala-0.36.2/.tarball-version
--- old/vala-0.36.1/.tarball-version2017-04-03 08:17:40.0 +0200
+++ new/vala-0.36.2/.tarball-version2017-04-25 18:12:14.0 +0200
@@ -1 +1 @@
-0.36.1
+0.36.2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vala-0.36.1/.version new/vala-0.36.2/.version
--- old/vala-0.36.1/.version2017-04-03 08:15:43.0 +0200
+++ new/vala-0.36.2/.version2017-04-25 18:09:38.0 +0200
@@ -1 +1 @@
-0.36.1
+0.36.2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vala-0.36.1/ChangeLog new/vala-0.36.2/ChangeLog
--- old/vala-0.36.1/ChangeLog   2017-04-03 08:17:40.0 +0200
+++ new/vala-0.36.2/ChangeLog   2017-04-25 18:12:14.0 +0200
@@ -1,3 +1,32 @@
+2017-04-25  Rico Tzschichholz  
+
+   Release 0.36.2
+
+   manual: Update from wiki.gnome.org
+
+   vala: Enums require at least one value otherwise report an error
+
+2017-04-19  Rico Tzschichholz  
+
+   gio-2.0: Tweak metadata to avoid duplicated interface dependencies
+
+   gio-2.0: Fix GLib.Task.report_error/report_new_error()
+
+   gio-2.0: Fix GLib.Task constructor
+   https://bugzilla.gnome.org/show_bug.cgi?id=781449
+
+2017-04-17  Rico Tzschichholz  
+
+   glib-2.0: Add quark() functions to errordomains
+
+   build: Add missing '\'
+
+   build: vapigen and vapicheck don't require ccode
+
+2017-04-10  Rico Tzschichholz  
+
+   gstreamer: Update to 1.11.90+
+
 2017-04-03  Rico Tzschichholz  
 
Release 0.36.1
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vala-0.36.1/NEWS new/vala-0.36.2/NEWS
--- old/vala-0.36.1/NEWS2017-04-03 08:10:34.0 +0200
+++ new/vala-0.36.2/NEWS2017-04-25 18:04:29.0 +0200
@@ -1,3 +1,14 @@
+Vala 0.36.2
+===
+ * Various bug fixes:
+  - Enums require at least one value otherwise report an error
+
+ * Bindings:
+  - gstreamer-1.0: Update to 1.11.90+
+  - gio-2.0: Fix GLib.Task constructor and report_error/report_new_error()
+  - glib-2.0: Add quark() functions to errordomains,
+  Add missing version macro and constants,
+
 Vala 0.36.1
 ===
  * Various bug fixes:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/vala-0.36.1/configure new/vala-0.36.2/configure
--- old/vala-0.36.1/configure   2017-04-03 08:15:35.0 +0200
+++ new/vala-0.36.2/configure   2017-04-25 18:09:31.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for vala 0.36.1.
+# Generated by GNU Autoconf 2.69 for vala 0.36.2.
 #
 # Report bugs to .
 #
@@ -651,8 +651,8 @@
 # Identity of this package.
 PACKAGE_NAME='vala'
 PACKAGE_TARNAME='vala'
-PACKAGE_VERSION='0.36.1'
-PACKAGE_STRING='vala 0.36.1'
+PACKAGE_VERSION='0.36.2'
+PACKAGE_STRING='vala 0.36.2'
 

commit libnice for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package libnice for openSUSE:Factory checked 
in at 2017-05-18 20:36:53

Comparing /work/SRC/openSUSE:Factory/libnice (Old)
 and  /work/SRC/openSUSE:Factory/.libnice.new (New)


Package is "libnice"

Thu May 18 20:36:53 2017 rev:41 rq:494081 version:0.1.14

Changes:

--- /work/SRC/openSUSE:Factory/libnice/libnice.changes  2016-06-03 
16:31:52.0 +0200
+++ /work/SRC/openSUSE:Factory/.libnice.new/libnice.changes 2017-05-18 
20:37:19.944298748 +0200
@@ -1,0 +2,12 @@
+Tue Apr 25 09:26:04 UTC 2017 - dims...@opensuse.org
+
+- Update to version 0.1.14:
+  + Improved RFC compliance.
+  + Split verbose logs into a separate option.
+  + Numerous bug fixes.
+  + Use GnuTLS for hash functions.
+  + Implement NewReno in PseudoTCP.
+  + Requires GLib 2.44 GnuTLS 2.12.
+- Add pkgconfig(gnutls) BuildRequires: new dependency.
+
+---

Old:

  libnice-0.1.13.tar.gz

New:

  libnice-0.1.14.tar.gz



Other differences:
--
++ libnice.spec ++
--- /var/tmp/diff_new_pack.J3IaKb/_old  2017-05-18 20:37:20.424231019 +0200
+++ /var/tmp/diff_new_pack.J3IaKb/_new  2017-05-18 20:37:20.428230454 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libnice
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   libnice
-Version:0.1.13
+Version:0.1.14
 Release:0
 Summary:Interactive Connectivity Establishment implementation
 License:MPL-1.1 or LGPL-2.1
@@ -26,7 +26,8 @@
 Source: http://nice.freedesktop.org/releases/%{name}-%{version}.tar.gz
 Source1:baselibs.conf
 BuildRequires:  libgupnp-igd-devel
-BuildRequires:  pkgconfig(glib-2.0) >= 2.30
+BuildRequires:  pkgconfig(glib-2.0) >= 2.44
+BuildRequires:  pkgconfig(gnutls) >= 2.12.0
 BuildRequires:  pkgconfig(gstreamer-1.0) >= 0.11.91
 BuildRequires:  pkgconfig(gstreamer-base-1.0) >= 0.11.91
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ libnice-0.1.13.tar.gz -> libnice-0.1.14.tar.gz ++
 46690 lines of diff (skipped)




commit pkg-config for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package pkg-config for openSUSE:Factory 
checked in at 2017-05-18 20:37:06

Comparing /work/SRC/openSUSE:Factory/pkg-config (Old)
 and  /work/SRC/openSUSE:Factory/.pkg-config.new (New)


Package is "pkg-config"

Thu May 18 20:37:06 2017 rev:33 rq:494083 version:0.29.2

Changes:

--- /work/SRC/openSUSE:Factory/pkg-config/pkg-config.changes2017-03-21 
22:43:54.950566621 +0100
+++ /work/SRC/openSUSE:Factory/.pkg-config.new/pkg-config.changes   
2017-05-18 20:37:24.523652498 +0200
@@ -1,0 +2,23 @@
+Tue Apr 25 10:28:49 UTC 2017 - dims...@opensuse.org
+
+- Update to version 0.29.2:
+  + Improved pkg-config's recursive package list expansion
+performance.
+  + Handle an empty prefix setting correctly when --define-prefix
+is used (fdo#97453).
+  + Lazily load pc files instead of reading all available pc files
+during initialization (fdo#98215).
+  + Check the CPATH environment variable when determining system
+include paths like GCC does. Document the system search path
+behavior (fdo#99224).
+  + Make PKG_CHECK_MODULES show the module list rather than the
+variable prefix in configure output (fdo#98334).
+  + Fix bundled glib build with GCC 6 (fdo#98334).
+  + Handle -isystem and -idirafter when PKG_CONFIG_SYSROOT_DIR is
+set (fdo#97337).
+  + Check the INCLUDE environment variable when determining system
+include paths on Windows builds when --msvc-syntax is used
+(fdo#94729).
+- Drop pkg-config-gdate-fix.patch: fixed upstream.
+
+---

Old:

  pkg-config-0.29.1.tar.gz
  pkg-config-gdate-fix.patch

New:

  pkg-config-0.29.2.tar.gz



Other differences:
--
++ pkg-config.spec ++
--- /var/tmp/diff_new_pack.OaPl6W/_old  2017-05-18 20:37:25.155563322 +0200
+++ /var/tmp/diff_new_pack.OaPl6W/_new  2017-05-18 20:37:25.155563322 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   pkg-config
-Version:0.29.1
+Version:0.29.2
 Release:0
 Summary:A library management system
 License:GPL-2.0+
@@ -31,8 +31,6 @@
 # pkg-config has a virtual internal pkg-config.pc file, so we should provide it
 Provides:   pkgconfig(pkg-config) = %{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-# PATCH-FIX-UPSTREAM pkg-config-gdate-fix.patch mli...@suse.cz -- Fix build 
with GCC 7
-Patch0: pkg-config-gdate-fix.patch
 
 %description
 The pkg-config program is used to retrieve information about installed
@@ -41,7 +39,6 @@
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 %configure\

++ pkg-config-0.29.1.tar.gz -> pkg-config-0.29.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pkg-config-0.29.1/NEWS new/pkg-config-0.29.2/NEWS
--- old/pkg-config-0.29.1/NEWS  2016-03-01 20:40:10.0 +0100
+++ new/pkg-config-0.29.2/NEWS  2017-03-20 18:01:42.0 +0100
@@ -1,3 +1,25 @@
+pkg-config 0.29.2
+=
+
+- Improved pkg-config's recursive package list expansion performance.
+  Thanks to Matthew Hanna for the fix.
+- Handle an empty prefix setting correctly when --define-prefix is used.
+  (#97453)
+- Lazily load pc files instead of reading all available pc files during
+  initialization. Thanks to Marco Diego Aurélio Mesquita for the fix.
+  (#98215)
+- Check the CPATH environment variable when determining system include
+  paths like GCC does. Document the system search path behavior. Thanks
+  to v4hn for the fix. (#99224)
+- Make PKG_CHECK_MODULES show the module list rather than the variable
+  prefix in configure output. Thanks to Russ Albery for the fix.
+  (#98334)
+- Fix bundled glib build with GCC 6. (#98334)
+- Handle -isystem and -idirafter when PKG_CONFIG_SYSROOT_DIR is set.
+  (#97337)
+- Check the INCLUDE environment variable when determining system include
+  paths on Windows builds when --msvc-syntax is used. (#94729)
+
 pkg-config 0.29.1
 =
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pkg-config-0.29.1/check/Makefile.am 
new/pkg-config-0.29.2/check/Makefile.am
--- old/pkg-config-0.29.1/check/Makefile.am 2016-02-26 17:56:52.0 
+0100
+++ new/pkg-config-0.29.2/check/Makefile.am 2017-03-20 17:34:23.0 
+0100
@@ -29,6 +29,8 @@
check-relocatable \
check-variable-override \
check-variables \
+   check-dependencies \
+   check-system-flags \
$(NULL)
 
 EXTRA_DIST = \
@@ -98,8 +100,22 @@
gtk/xproto.pc \
gtk/xrender.pc \
tilde.pc \
+   pkgconfig/empty-prefix.pc \
pkgconfig/prefixdef.pc \
pkgconfig/prefixdef-expanded.pc \
   

commit MozillaFirefox for openSUSE:Factory

2017-05-18 Thread root
Hello community,

here is the log from the commit of package MozillaFirefox for openSUSE:Factory 
checked in at 2017-05-18 20:36:38

Comparing /work/SRC/openSUSE:Factory/MozillaFirefox (Old)
 and  /work/SRC/openSUSE:Factory/.MozillaFirefox.new (New)


Package is "MozillaFirefox"

Thu May 18 20:36:38 2017 rev:253 rq:493642 version:52.1.1

Changes:

--- /work/SRC/openSUSE:Factory/MozillaFirefox/MozillaFirefox.changes
2017-05-04 08:52:14.183313640 +0200
+++ /work/SRC/openSUSE:Factory/.MozillaFirefox.new/MozillaFirefox.changes   
2017-05-18 20:36:43.769403831 +0200
@@ -1,0 +2,13 @@
+Mon May  8 08:28:17 UTC 2017 - w...@rosenauer.org
+
+- update to Firefox 52.1.1
+  MFSA 2017-14
+  * CVE-2017-5031: Use after free in ANGLE (bmo#1328762)
+   (Windows only, Linux not affected)
+- switch to Mozilla's geolocation service (boo#1026989)
+- removed mozilla-preferences.patch obsoleted by overriding via
+  firefox.js
+- fixed KDE integration to avoid crash caused by filepicker
+  (boo#1015998)
+
+---

Old:

  firefox-52.1.0-source.tar.xz
  l10n-52.1.0.tar.xz
  mozilla-preferences.patch

New:

  firefox-52.1.1-source.tar.xz
  l10n-52.1.1.tar.xz
  mozilla-api-key



Other differences:
--
++ MozillaFirefox.spec ++
--- /var/tmp/diff_new_pack.zAsFAg/_old  2017-05-18 20:37:15.904868802 +0200
+++ /var/tmp/diff_new_pack.zAsFAg/_new  2017-05-18 20:37:15.908868237 +0200
@@ -19,9 +19,9 @@
 
 # changed with every update
 %define major 52
-%define mainver %major.1.0
+%define mainver %major.1.1
 %define update_channel esr52
-%define releasedate 2017041300
+%define releasedate 2017050400
 
 # PIE, full relro (x86_64 for now)
 %define build_hardened 1
@@ -147,11 +147,11 @@
 Source15:   firefox-appdata.xml
 Source16:   MozillaFirefox.changes
 Source17:   l10n_changesets.txt
+Source18:   mozilla-api-key
 # Gecko/Toolkit
 Patch1: mozilla-nongnome-proxies.patch
 Patch2: mozilla-shared-nss-db.patch
 Patch3: mozilla-kde.patch
-Patch4: mozilla-preferences.patch
 Patch5: mozilla-language.patch
 Patch6: mozilla-ntlm-full-path.patch
 Patch7: mozilla-openaes-decl.patch
@@ -261,7 +261,6 @@
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
@@ -361,6 +360,7 @@
 ac_add_options --enable-startup-notification
 #ac_add_options --enable-chrome-format=jar
 ac_add_options --enable-update-channel=%{update_channel}
+ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
 %if %branding
 ac_add_options --enable-official-branding
 %endif

++ compare-locales.tar.xz ++

++ create-tar.sh ++
--- /var/tmp/diff_new_pack.zAsFAg/_old  2017-05-18 20:37:16.096841710 +0200
+++ /var/tmp/diff_new_pack.zAsFAg/_new  2017-05-18 20:37:16.096841710 +0200
@@ -7,8 +7,8 @@
 
 CHANNEL="esr52"
 BRANCH="releases/mozilla-$CHANNEL"
-RELEASE_TAG="3ea0e075203185d7f2d42f439455e97735bd1b20"
-VERSION="52.1.0"
+RELEASE_TAG="FIREFOX_52_1_1esr_RELEASE"
+VERSION="52.1.1"
 
 # mozilla
 if [ -d mozilla ]; then

++ firefox-52.1.0-source.tar.xz -> firefox-52.1.1-source.tar.xz ++
/work/SRC/openSUSE:Factory/MozillaFirefox/firefox-52.1.0-source.tar.xz 
/work/SRC/openSUSE:Factory/.MozillaFirefox.new/firefox-52.1.1-source.tar.xz 
differ: char 26, line 1

++ firefox.js ++
--- /var/tmp/diff_new_pack.zAsFAg/_old  2017-05-18 20:37:16.196827600 +0200
+++ /var/tmp/diff_new_pack.zAsFAg/_new  2017-05-18 20:37:16.200827036 +0200
@@ -1 +1,3 @@
+pref("intl.locale.matchOS", true);
 pref("browser.preferences.instantApply", true);
+pref("geo.wifi.uri", 
"https://location.services.mozilla.com/v1/geolocate?key=%MOZILLA_API_KEY%;);

++ l10n-52.1.0.tar.xz -> l10n-52.1.1.tar.xz ++
/work/SRC/openSUSE:Factory/MozillaFirefox/l10n-52.1.0.tar.xz 
/work/SRC/openSUSE:Factory/.MozillaFirefox.new/l10n-52.1.1.tar.xz differ: char 
26, line 1

++ mozilla-api-key ++
4605624048be48fda932495844d16fbb
++ mozilla-kde.patch ++
--- /var/tmp/diff_new_pack.zAsFAg/_old  2017-05-18 20:37:16.292814054 +0200
+++ /var/tmp/diff_new_pack.zAsFAg/_new  2017-05-18 20:37:16.296813490 +0200
@@ -1,5 +1,5 @@
 # HG changeset patch
-# Parent  5f1979729aa3c6bc50f7097202991e73be677e5e
+# Parent  aff14a54f25dc3146ba7a64408ceb9f486a832db
 Description: Add KDE integration to Firefox (toolkit parts)
 Author: Wolfgang Rosenauer 
 Author: Lubos Lunak 
@@ -3347,7 +3347,7 @@
  
mFilters.AppendElement(filter);
mFilterNames.AppendElement(name);
-@@ -371,16 +375,32 @@ nsFilePicker::Show(int16_t *aReturn)
+@@ -371,16 +375,34 @@ nsFilePicker::Show(int16_t *aReturn)
  
  NS_IMETHODIMP
  

  1   2   >