commit latexila for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package latexila for openSUSE:Factory 
checked in at 2017-06-29 15:14:58

Comparing /work/SRC/openSUSE:Factory/latexila (Old)
 and  /work/SRC/openSUSE:Factory/.latexila.new (New)


Package is "latexila"

Thu Jun 29 15:14:58 2017 rev:28 rq:506741 version:3.24.2

Changes:

--- /work/SRC/openSUSE:Factory/latexila/latexila.changes2017-06-13 
16:09:40.797362469 +0200
+++ /work/SRC/openSUSE:Factory/.latexila.new/latexila.changes   2017-06-29 
15:15:17.935496540 +0200
@@ -1,0 +2,7 @@
+Sun Jun 25 10:16:42 UTC 2017 - zai...@opensuse.org
+
+- Update to version 3.24.2:
+  + Fix a crash when moving a tab to a new window (regression in
+3.24).
+
+---

Old:

  latexila-3.24.1.tar.xz

New:

  latexila-3.24.2.tar.xz



Other differences:
--
++ latexila.spec ++
--- /var/tmp/diff_new_pack.I8nahL/_old  2017-06-29 15:15:20.827087773 +0200
+++ /var/tmp/diff_new_pack.I8nahL/_new  2017-06-29 15:15:20.827087773 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   latexila
-Version:3.24.1
+Version:3.24.2
 Release:0
 Summary:Integrated LaTeX Environment for the GNOME desktop
 License:GPL-3.0+

++ latexila-3.24.1.tar.xz -> latexila-3.24.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/latexila-3.24.1/NEWS new/latexila-3.24.2/NEWS
--- old/latexila-3.24.1/NEWS2017-06-11 13:32:36.0 +0200
+++ new/latexila-3.24.2/NEWS2017-06-25 09:42:19.0 +0200
@@ -1,5 +1,9 @@
 LaTeXila NEWS
 
+Release 3.24.2, 2017-06-25
+--
+* Fix a crash when moving a tab to a new window (regression in 3.24).
+
 Release 3.24.1, 2017-06-11
 --
 * Create app menu only if the desktop prefers one, to avoid a double menubar on
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/latexila-3.24.1/README new/latexila-3.24.2/README
--- old/latexila-3.24.1/README  2017-06-11 13:27:57.0 +0200
+++ new/latexila-3.24.2/README  2017-06-25 09:38:17.0 +0200
@@ -1,7 +1,7 @@
 LaTeXila
 
 
-This is the version 3.24.1 of LaTeXila.
+This is the version 3.24.2 of LaTeXila.
 
 LaTeXila is an Integrated LaTeX Environment for the GNOME desktop.
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/latexila-3.24.1/configure 
new/latexila-3.24.2/configure
--- old/latexila-3.24.1/configure   2017-06-11 13:38:42.0 +0200
+++ new/latexila-3.24.2/configure   2017-06-25 09:44:12.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for LaTeXila 3.24.1.
+# Generated by GNU Autoconf 2.69 for LaTeXila 3.24.2.
 #
 # Report bugs to .
 #
@@ -651,8 +651,8 @@
 # Identity of this package.
 PACKAGE_NAME='LaTeXila'
 PACKAGE_TARNAME='latexila'
-PACKAGE_VERSION='3.24.1'
-PACKAGE_STRING='LaTeXila 3.24.1'
+PACKAGE_VERSION='3.24.2'
+PACKAGE_STRING='LaTeXila 3.24.2'
 PACKAGE_BUGREPORT='https://bugzilla.gnome.org/enter_bug.cgi?product=latexila'
 PACKAGE_URL='https://wiki.gnome.org/Apps/LaTeXila'
 
@@ -1515,7 +1515,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures LaTeXila 3.24.1 to adapt to many kinds of systems.
+\`configure' configures LaTeXila 3.24.2 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1585,7 +1585,7 @@
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
- short | recursive ) echo "Configuration of LaTeXila 3.24.1:";;
+ short | recursive ) echo "Configuration of LaTeXila 3.24.2:";;
esac
   cat <<\_ACEOF
 
@@ -1734,7 +1734,7 @@
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-LaTeXila configure 3.24.1
+LaTeXila configure 3.24.2
 generated by GNU Autoconf 2.69
 
 Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2012,7 +2012,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by LaTeXila $as_me 3.24.1, which was
+It was created by LaTeXila $as_me 3.24.2, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   $ $0 $@
@@ -2898,7 +2898,7 @@
 
 # Define the identity of the package.
  PACKAGE='latexila'
- VERSION='3.24.1'
+ VERSION='3.24.2'
 
 
 cat >>confdefs.h <<_ACEOF
@@ -17537,7 +17537,7 @@
 # report actual input values of CONFIG_FILES etc. 

commit cinnamon for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package cinnamon for openSUSE:Factory 
checked in at 2017-06-29 15:17:12

Comparing /work/SRC/openSUSE:Factory/cinnamon (Old)
 and  /work/SRC/openSUSE:Factory/.cinnamon.new (New)


Package is "cinnamon"

Thu Jun 29 15:17:12 2017 rev:18 rq:506898 version:3.4.3

Changes:

--- /work/SRC/openSUSE:Factory/cinnamon/cinnamon.changes2017-06-23 
09:18:38.972021216 +0200
+++ /work/SRC/openSUSE:Factory/.cinnamon.new/cinnamon.changes   2017-06-29 
15:17:27.109236261 +0200
@@ -1,0 +2,12 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 3.4.3:
+  * panel-launchers: Put individual launcher actions back in the
+main popup, having an options and preferences submenu was a
+bit ambiguous.
+  * panel-launchers: Remove an undeclared variable warning.
+  * deskletManager: Correct a call to file.delete.
+  * Add a menu item to toggle the on-screen keyboard.
+- Use update-alternatives to create the default.desktop xsession.
+
+---

Old:

  Cinnamon-3.4.2.tar.gz

New:

  Cinnamon-3.4.3.tar.gz



Other differences:
--
++ cinnamon.spec ++
--- /var/tmp/diff_new_pack.ZxCZ1B/_old  2017-06-29 15:17:28.349060999 +0200
+++ /var/tmp/diff_new_pack.ZxCZ1B/_new  2017-06-29 15:17:28.357059868 +0200
@@ -21,10 +21,10 @@
 %define _name   Cinnamon
 %define _version 3.4.0
 Name:   cinnamon
-Version:3.4.2
+Version:3.4.3
 Release:0
 Summary:GNU/Linux Desktop featuring a traditional layout
-License:GPL-2.0+ and LGPL-2.1
+License:GPL-2.0+ AND LGPL-2.1
 Group:  System/GUI/Other
 Url:https://github.com/linuxmint/Cinnamon
 Source: 
https://github.com/linuxmint/%{_name}/archive/%{version}.tar.gz#/%{_name}-%{version}.tar.gz
@@ -107,6 +107,8 @@
 Requires:   v4l-tools
 Requires:   wget
 Requires:   xdg-utils
+Requires(post): update-alternatives
+Requires(postun): update-alternatives
 Recommends: blueberry
 Recommends: cinnamon-themes
 Recommends: cinnamon-translations >= %{_version}
@@ -210,6 +212,11 @@
 %py_compile .
 done
 
+mkdir -p %{buildroot}%{_sysconfdir}/alternatives/
+touch %{buildroot}%{_sysconfdir}/alternatives/default-xsession.desktop
+ln -s %{_sysconfdir}/alternatives/default-xsession.desktop \
+  %{buildroot}%{_datadir}/xsessions/default.desktop
+
 find %{buildroot} -type f -name "*.la" -delete -print
 %fdupes %{buildroot}%{_datadir}/
 
@@ -226,11 +233,17 @@
 /sbin/ldconfig
 %desktop_database_post
 %icon_theme_cache_post
+%{_sbindir}/update-alternatives --install 
%{_datadir}/xsessions/default.desktop \
+  default-xsession.desktop %{_datadir}/xsessions/%{name}.desktop 20
 
 %postun
 /sbin/ldconfig
 %desktop_database_postun
 %icon_theme_cache_postun
+if [ ! -f %{_datadir}/xsessions/%{name}.desktop ]; then
+%{_sbindir}/update-alternatives --remove default-xsession.desktop \
+  %{_datadir}/xsessions/%{name}.desktop
+fi
 
 %post gschemas
 %glib2_gsettings_schema_post
@@ -244,6 +257,7 @@
 %dir %{_sysconfdir}/xdg/menus/
 %config %{_sysconfdir}/xdg/menus/%{name}-applications.menu
 %config %{_sysconfdir}/xdg/menus/%{name}-applications-merged
+%ghost %{_sysconfdir}/alternatives/default-xsession.desktop
 %{_bindir}/%{name}*
 %{_bindir}/xlet-settings
 %{_libexecdir}/%{name}*/
@@ -257,7 +271,7 @@
 %{_datadir}/%{name}-background-properties
 %exclude %{_datadir}/%{name}/theme/menu*.svg
 %{_datadir}/%{name}-session/
-%{_datadir}/xsessions/%{name}*.desktop
+%{_datadir}/xsessions/*.desktop
 %{_datadir}/applications/%{name}*.desktop
 %{_datadir}/icons/hicolor/*/apps/cinnamon-*.*
 %{_datadir}/icons/hicolor/*/*/cs-*.*

++ Cinnamon-3.4.2.tar.gz -> Cinnamon-3.4.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Cinnamon-3.4.2/configure.ac 
new/Cinnamon-3.4.3/configure.ac
--- old/Cinnamon-3.4.2/configure.ac 2017-06-20 16:17:26.0 +0200
+++ new/Cinnamon-3.4.3/configure.ac 2017-06-26 12:45:06.0 +0200
@@ -1,5 +1,5 @@
 AC_PREREQ(2.63)
-AC_INIT([cinnamon],[3.4.2],[https://github.com/linuxmint/Cinnamon/issues],[cinnamon])
+AC_INIT([cinnamon],[3.4.3],[https://github.com/linuxmint/Cinnamon/issues],[cinnamon])
 
 AC_CONFIG_HEADERS([config.h])
 AC_CONFIG_SRCDIR([src/cinnamon-global.c])
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Cinnamon-3.4.2/debian/changelog 
new/Cinnamon-3.4.3/debian/changelog
--- old/Cinnamon-3.4.2/debian/changelog 2017-06-20 16:17:26.0 +0200
+++ new/Cinnamon-3.4.3/debian/changelog 2017-06-26 12:45:06.0 +0200
@@ -1,3 +1,17 @@
+cinnamon (3.4.3) sonya; urgency=medium
+
+  [ 

commit transactional-update for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package transactional-update for 
openSUSE:Factory checked in at 2017-06-29 15:16:23

Comparing /work/SRC/openSUSE:Factory/transactional-update (Old)
 and  /work/SRC/openSUSE:Factory/.transactional-update.new (New)


Package is "transactional-update"

Thu Jun 29 15:16:23 2017 rev:11 rq:506779 version:1.18

Changes:

--- 
/work/SRC/openSUSE:Factory/transactional-update/transactional-update.changes
2017-06-28 10:36:38.332385131 +0200
+++ 
/work/SRC/openSUSE:Factory/.transactional-update.new/transactional-update.changes
   2017-06-29 15:16:35.056594474 +0200
@@ -1,0 +2,7 @@
+Wed Jun 28 14:13:27 CEST 2017 - ku...@suse.de
+
+- Update to version 1.18
+  - Auto accept product license in non-interactive mode
+
+
+---
@@ -11 +18 @@
-  - [bsc#1045942]
+  - internal changes [bsc#1045942]

Old:

  transactional-update-1.17.tar.bz2

New:

  transactional-update-1.18.tar.bz2



Other differences:
--
++ transactional-update.spec ++
--- /var/tmp/diff_new_pack.RiYxeX/_old  2017-06-29 15:16:37.308276172 +0200
+++ /var/tmp/diff_new_pack.RiYxeX/_new  2017-06-29 15:16:37.312275606 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   transactional-update
-Version:1.17
+Version:1.18
 Release:0
 Summary:Transactional Updates with btrfs and snapshots
 License:GPL-2.0+

++ transactional-update-1.17.tar.bz2 -> transactional-update-1.18.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/transactional-update-1.17/NEWS 
new/transactional-update-1.18/NEWS
--- old/transactional-update-1.17/NEWS  2017-06-27 09:11:33.0 +0200
+++ new/transactional-update-1.18/NEWS  2017-06-28 14:12:44.0 +0200
@@ -2,6 +2,9 @@
 
 Copyright (C) 2016, 2017 Thorsten Kukuk
 
+Version 1.18
+* Auto accept product license in non-interactive mode
+
 Version 1.17
 * Copy some modified config files for bootloader into the snapshot
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/transactional-update-1.17/configure 
new/transactional-update-1.18/configure
--- old/transactional-update-1.17/configure 2017-06-27 09:12:39.0 
+0200
+++ new/transactional-update-1.18/configure 2017-06-28 14:13:11.0 
+0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for transactional-update 1.17.
+# Generated by GNU Autoconf 2.69 for transactional-update 1.18.
 #
 #
 # Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
@@ -576,8 +576,8 @@
 # Identity of this package.
 PACKAGE_NAME='transactional-update'
 PACKAGE_TARNAME='transactional-update'
-PACKAGE_VERSION='1.17'
-PACKAGE_STRING='transactional-update 1.17'
+PACKAGE_VERSION='1.18'
+PACKAGE_STRING='transactional-update 1.18'
 PACKAGE_BUGREPORT=''
 PACKAGE_URL=''
 
@@ -1211,7 +1211,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures transactional-update 1.17 to adapt to many kinds of 
systems.
+\`configure' configures transactional-update 1.18 to adapt to many kinds of 
systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1278,7 +1278,7 @@
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
- short | recursive ) echo "Configuration of transactional-update 1.17:";;
+ short | recursive ) echo "Configuration of transactional-update 1.18:";;
esac
   cat <<\_ACEOF
 
@@ -1358,7 +1358,7 @@
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-transactional-update configure 1.17
+transactional-update configure 1.18
 generated by GNU Autoconf 2.69
 
 Copyright (C) 2012 Free Software Foundation, Inc.
@@ -1375,7 +1375,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by transactional-update $as_me 1.17, which was
+It was created by transactional-update $as_me 1.18, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   $ $0 $@
@@ -2238,7 +2238,7 @@
 
 # Define the identity of the package.
  PACKAGE='transactional-update'
- VERSION='1.17'
+ VERSION='1.18'
 
 
 cat >>confdefs.h <<_ACEOF
@@ -3097,7 +3097,7 @@
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log="
-This file was extended by transactional-update $as_me 1.17, which was
+This file was extended by transactional-update $as_me 1.18, which was
 generated by GNU Autoconf 2.69.  

commit python-Unidecode for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package python-Unidecode for 
openSUSE:Factory checked in at 2017-06-29 15:16:49

Comparing /work/SRC/openSUSE:Factory/python-Unidecode (Old)
 and  /work/SRC/openSUSE:Factory/.python-Unidecode.new (New)


Package is "python-Unidecode"

Thu Jun 29 15:16:49 2017 rev:5 rq:506879 version:0.04.21

Changes:

--- /work/SRC/openSUSE:Factory/python-Unidecode/python-Unidecode.changes
2017-04-17 10:26:24.929328592 +0200
+++ /work/SRC/openSUSE:Factory/.python-Unidecode.new/python-Unidecode.changes   
2017-06-29 15:16:55.885650048 +0200
@@ -1,0 +2,7 @@
+Wed Jun 28 18:15:36 UTC 2017 - benoit.mo...@gmx.fr
+
+- update to Unidecode 0.04.21:
+  * Add U+2116 NUMERO SIGN (thanks to Alan Davidson)
+  * Add U+05BE HEBREW PUNCTUATION MAQAF (thanks to Micha Moskovic)
+
+---

Old:

  Unidecode-0.04.20.tar.gz

New:

  Unidecode-0.04.21.tar.gz



Other differences:
--
++ python-Unidecode.spec ++
--- /var/tmp/diff_new_pack.vluPGB/_old  2017-06-29 15:16:59.873086380 +0200
+++ /var/tmp/diff_new_pack.vluPGB/_new  2017-06-29 15:16:59.877085814 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-Unidecode
-Version:0.04.20
+Version:0.04.21
 Release:0
 Summary:ASCII transliterations of Unicode text
 License:GPL-2.0+

++ Unidecode-0.04.20.tar.gz -> Unidecode-0.04.21.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Unidecode-0.04.20/ChangeLog 
new/Unidecode-0.04.21/ChangeLog
--- old/Unidecode-0.04.20/ChangeLog 2017-01-09 17:34:31.0 +0100
+++ new/Unidecode-0.04.21/ChangeLog 2017-06-28 13:43:20.0 +0200
@@ -1,3 +1,7 @@
+2017-06-28 unidecode 0.04.21
+   * Add U+2116 NUMERO SIGN (thanks to Alan Davidson)
+   * Add U+05BE HEBREW PUNCTUATION MAQAF (thanks to Micha Moskovic)
+
 2017-01-09 unidecode 0.04.20
* Fixed transliteration of circled Latin letters and numbers
  (thanks to Krzysztof Jurewicz).
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Unidecode-0.04.20/PKG-INFO 
new/Unidecode-0.04.21/PKG-INFO
--- old/Unidecode-0.04.20/PKG-INFO  2017-01-09 17:47:49.0 +0100
+++ new/Unidecode-0.04.21/PKG-INFO  2017-06-28 13:56:48.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: Unidecode
-Version: 0.04.20
+Version: 0.04.21
 Summary: ASCII transliterations of Unicode text
 Home-page: UNKNOWN
 Author: Tomaz Solc
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Unidecode-0.04.20/Unidecode.egg-info/PKG-INFO 
new/Unidecode-0.04.21/Unidecode.egg-info/PKG-INFO
--- old/Unidecode-0.04.20/Unidecode.egg-info/PKG-INFO   2017-01-09 
17:47:48.0 +0100
+++ new/Unidecode-0.04.21/Unidecode.egg-info/PKG-INFO   2017-06-28 
13:56:47.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: Unidecode
-Version: 0.04.20
+Version: 0.04.21
 Summary: ASCII transliterations of Unicode text
 Home-page: UNKNOWN
 Author: Tomaz Solc
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Unidecode-0.04.20/setup.py 
new/Unidecode-0.04.21/setup.py
--- old/Unidecode-0.04.20/setup.py  2017-01-09 17:25:35.0 +0100
+++ new/Unidecode-0.04.21/setup.py  2017-06-28 13:43:25.0 +0200
@@ -10,7 +10,7 @@
 
 setup(
 name='Unidecode',
-version='0.04.20',
+version='0.04.21',
 description='ASCII transliterations of Unicode text',
 license='GPL',
 long_description=get_long_description(),
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Unidecode-0.04.20/unidecode/x005.py 
new/Unidecode-0.04.21/unidecode/x005.py
--- old/Unidecode-0.04.20/unidecode/x005.py 2015-11-30 16:45:45.0 
+0100
+++ new/Unidecode-0.04.21/unidecode/x005.py 2017-06-23 11:47:03.0 
+0200
@@ -189,7 +189,7 @@
 'u',# 0xbb
 '\'',# 0xbc
 '',# 0xbd
-'',# 0xbe
+'-',# 0xbe
 '',# 0xbf
 '|',# 0xc0
 '',# 0xc1
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Unidecode-0.04.20/unidecode/x021.py 
new/Unidecode-0.04.21/unidecode/x021.py
--- old/Unidecode-0.04.20/unidecode/x021.py 2017-01-09 17:25:04.0 
+0100
+++ new/Unidecode-0.04.21/unidecode/x021.py 2017-01-17 09:29:24.0 
+0100
@@ -21,7 +21,7 @@
 'l',# 0x13
 '',# 0x14
 'N',# 0x15
-'',# 0x16
+'No. ',# 0x16
 '',# 0x17
 '',# 0x18
 'P',# 0x19




commit a2ps for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package a2ps for openSUSE:Factory checked in 
at 2017-06-29 15:21:49

Comparing /work/SRC/openSUSE:Factory/a2ps (Old)
 and  /work/SRC/openSUSE:Factory/.a2ps.new (New)


Package is "a2ps"

Thu Jun 29 15:21:49 2017 rev:43 rq:506990 version:4.14

Changes:

--- /work/SRC/openSUSE:Factory/a2ps/a2ps.changes2017-06-05 
18:51:17.221226420 +0200
+++ /work/SRC/openSUSE:Factory/.a2ps.new/a2ps.changes   2017-06-29 
15:22:00.942528234 +0200
@@ -1,0 +2,5 @@
+Thu Jun 29 09:14:23 UTC 2017 - wer...@suse.de
+
+- Be more flexible in patching man/a2ps.1
+
+---



Other differences:
--
++ a2ps.spec ++
--- /var/tmp/diff_new_pack.0DPWzL/_old  2017-06-29 15:22:04.422036398 +0200
+++ /var/tmp/diff_new_pack.0DPWzL/_new  2017-06-29 15:22:04.426035833 +0200
@@ -178,6 +178,8 @@
  if test -e man/a2ps.1.rej ; then
 cat man/a2ps.1.rej
 exit 1
+ else
+sed -ri '/^\.B lt-a2ps/{s/lt-(a2ps)/\1/}' man/a2ps.1 || :
  fi
 
 %install

++ a2ps-4.14-manuals.diff ++
--- /var/tmp/diff_new_pack.0DPWzL/_old  2017-06-29 15:22:04.514023395 +0200
+++ /var/tmp/diff_new_pack.0DPWzL/_new  2017-06-29 15:22:04.518022830 +0200
@@ -1,18 +1,9 @@
 ---
- man/a2ps.1 |5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
+ man/a2ps.1 |3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
 
 --- man/a2ps.1
 +++ man/a2ps.1 2014-08-07 14:32:29.0 +
-@@ -3,7 +3,7 @@
- .SH NAME
- a2ps \- format files for printing on a PostScript printer
- .SH SYNOPSIS
--.B lt-a2ps
-+.B a2ps
- [\fIOPTION\fR]... [\fIFILE\fR]...
- .SH DESCRIPTION
- .\" Add any additional description here
 @@ -81,8 +81,7 @@ first fill (DIRECTION=) rows, or columns
  predefined font sizes and layouts for 1.. 9 virtuals
  .TP






commit cfengine for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package cfengine for openSUSE:Factory 
checked in at 2017-06-29 15:16:00

Comparing /work/SRC/openSUSE:Factory/cfengine (Old)
 and  /work/SRC/openSUSE:Factory/.cfengine.new (New)


Package is "cfengine"

Thu Jun 29 15:16:00 2017 rev:68 rq:506774 version:3.10.0

Changes:

--- /work/SRC/openSUSE:Factory/cfengine/cfengine.changes2017-05-18 
20:48:36.432829717 +0200
+++ /work/SRC/openSUSE:Factory/.cfengine.new/cfengine.changes   2017-06-29 
15:16:24.066148104 +0200
@@ -1,0 +2,6 @@
+Fri May 19 18:14:29 UTC 2017 - jeng...@inai.de
+
+- Reword description to have less marketing speak.
+- Remove two unnecessary ldconfig calls.
+
+---



Other differences:
--
++ cfengine.spec ++
--- /var/tmp/diff_new_pack.N9TMNJ/_old  2017-06-29 15:16:29.105435741 +0200
+++ /var/tmp/diff_new_pack.N9TMNJ/_new  2017-06-29 15:16:29.109435175 +0200
@@ -39,7 +39,7 @@
 # This is the place where workdir should be
 #define basedir   /var/lib/%{name}
 #define workdir   %{basedir}/work
-Summary:CFEngine automates large-scale IT computing infrastructure
+Summary:Configuration management framework
 License:GPL-3.0
 Group:  Productivity/Networking/System
 Url:http://www.cfengine.org/
@@ -124,14 +124,10 @@
 %endif
 
 %description
-CFEngine is the core of a configuration management system: ensuring
-the availability, security and compliance of mission-critical
-applications and services. Based on popular and flexible open source
-configuration management software, CFEngine configuration management
-products are highly scalable through decentralized, autonomous agents
-that can continuously monitor, self-repair, and update the IT
-infrastructure of a global multi-site enterprise - with negligible
-impact on system resources or performance.
+CFEngine is the core of a configuration management system. It
+combines modeling and monitoring to move a system into compliance
+with a user-defined model (the Desired State). A domain-specific
+language is used for setting this up.
 
 %package -n %{libsoname}
 Summary:Shared library of cfengine
@@ -151,24 +147,24 @@
 Obsoletes:  %{name}-devel < %{version}
 
 %description -n %{libname}-devel
-A high-speed character set detection library
+A character set detection library.
 
 This package contains the files needed to compile programs that use the
 libpromises library.
 
 %package doc
-Summary:CFEngine automates large-scale IT computing infrastructure - 
documentation
+Summary:Documentation for CFEngine, a config management framework
 Group:  Documentation/Other
 
 %description doc
-Full documentation for cfengine
+Documentation for cfengine.
 
 %package examples
 Summary:CFEngine example promises
 Group:  Documentation/Other
 
 %description examples
-Lots of examples promises for CFEngine.
+Lots of example promises for CFEngine.
 
 %prep
 %setup -q -n %{srcname}
@@ -312,7 +308,6 @@
   %fillup_and_insserv cf-${i}
 done
 %endif
-/sbin/ldconfig
 if [ $1 -lt 2 ]; then
   # first install, generate key pair
   cf-key
@@ -340,7 +335,6 @@
   # clean up inputs cache dir on removal
   rm -rf %{basedir}/inputs/*
 fi
-/sbin/ldconfig
 
 %post   -n %{libsoname} -p /sbin/ldconfig
 




commit blueberry for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package blueberry for openSUSE:Factory 
checked in at 2017-06-29 15:17:27

Comparing /work/SRC/openSUSE:Factory/blueberry (Old)
 and  /work/SRC/openSUSE:Factory/.blueberry.new (New)


Package is "blueberry"

Thu Jun 29 15:17:27 2017 rev:21 rq:506906 version:1.1.15

Changes:

--- /work/SRC/openSUSE:Factory/blueberry/blueberry.changes  2017-06-13 
16:09:59.682700940 +0200
+++ /work/SRC/openSUSE:Factory/.blueberry.new/blueberry.changes 2017-06-29 
15:17:36.799866393 +0200
@@ -1,0 +2,9 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 1.1.15 (changes since 1.1.13):
+  * Fix unicode errors during OBEX file transfers.
+  * Fix more unicode errors and missing arguments.
+  * Obex: Fix non-translated strings.
+  * Update translations.
+
+---

Old:

  blueberry-1.1.13.tar.gz

New:

  blueberry-1.1.15.tar.gz



Other differences:
--
++ blueberry.spec ++
--- /var/tmp/diff_new_pack.KeEHDz/_old  2017-06-29 15:17:38.595612546 +0200
+++ /var/tmp/diff_new_pack.KeEHDz/_new  2017-06-29 15:17:38.595612546 +0200
@@ -18,7 +18,7 @@
 
 %define __requires_exclude typelib\\((St)\\)
 Name:   blueberry
-Version:1.1.13
+Version:1.1.15
 Release:0
 Summary:A configuration tool for Bluetooth
 License:GPL-3.0+

++ blueberry-1.1.13.tar.gz -> blueberry-1.1.15.tar.gz ++
 13989 lines of diff (skipped)




commit cjs for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package cjs for openSUSE:Factory checked in 
at 2017-06-29 15:18:01

Comparing /work/SRC/openSUSE:Factory/cjs (Old)
 and  /work/SRC/openSUSE:Factory/.cjs.new (New)


Package is "cjs"

Thu Jun 29 15:18:01 2017 rev:6 rq:506912 version:3.4.2

Changes:

--- /work/SRC/openSUSE:Factory/cjs/cjs.changes  2017-05-27 13:13:10.319555640 
+0200
+++ /work/SRC/openSUSE:Factory/.cjs.new/cjs.changes 2017-06-29 
15:18:19.265863430 +0200
@@ -1,0 +2,10 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 3.4.2:
+  * tweener: Add undefined property check.
+  * tweener.js: Silence some additional warnings due to
+missing/unused properties.
+  * object: Prevent use-after-free in signal connections.
+  * util-root: Require GjsMaybeOwned callback to reset.
+
+---

Old:

  cjs-3.4.1.tar.gz

New:

  cjs-3.4.2.tar.gz



Other differences:
--
++ cjs.spec ++
--- /var/tmp/diff_new_pack.dF1nwc/_old  2017-06-29 15:18:21.137598845 +0200
+++ /var/tmp/diff_new_pack.dF1nwc/_new  2017-06-29 15:18:21.141598279 +0200
@@ -20,7 +20,7 @@
 %define sover   0
 %define typelib typelib-1_0-CjsPrivate-1_0
 Name:   cjs
-Version:3.4.1
+Version:3.4.2
 Release:0
 Summary:JavaScript module used by Cinnamon
 License:MIT and (MPL-1.1 or GPL-2.0+ or LGPL-2.1+)

++ cjs-3.4.1.tar.gz -> cjs-3.4.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cjs-3.4.1/cjs/jsapi-util-root.h 
new/cjs-3.4.2/cjs/jsapi-util-root.h
--- old/cjs-3.4.1/cjs/jsapi-util-root.h 2017-05-23 16:29:10.0 +0200
+++ new/cjs-3.4.2/cjs/jsapi-util-root.h 2017-06-26 12:19:31.0 +0200
@@ -170,11 +170,12 @@
  * to remove it. */
 m_has_weakref = false;
 
-/* The object is still live across this callback. */
+/* The object is still live entering this callback. The callback
+ * must reset() this wrapper. */
 if (m_notify)
 m_notify(handle(), m_data);
-
-reset();
+else
+reset();
 }
 
 public:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cjs-3.4.1/configure.ac new/cjs-3.4.2/configure.ac
--- old/cjs-3.4.1/configure.ac  2017-05-23 16:29:10.0 +0200
+++ new/cjs-3.4.2/configure.ac  2017-06-26 12:19:31.0 +0200
@@ -3,7 +3,7 @@
 
 m4_define(pkg_major_version, 3)
 m4_define(pkg_minor_version, 4)
-m4_define(pkg_micro_version, 1)
+m4_define(pkg_micro_version, 2)
 m4_define(pkg_version, pkg_major_version.pkg_minor_version.pkg_micro_version)
 m4_define(pkg_int_version, (pkg_major_version * 100 + pkg_minor_version) * 100 
+ pkg_micro_version)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cjs-3.4.1/debian/changelog 
new/cjs-3.4.2/debian/changelog
--- old/cjs-3.4.1/debian/changelog  2017-05-23 16:29:10.0 +0200
+++ new/cjs-3.4.2/debian/changelog  2017-06-26 12:19:31.0 +0200
@@ -1,3 +1,17 @@
+cjs (3.4.2) sonya; urgency=medium
+
+  [ leigh123linux ]
+  * tweener: Add undefined property check (#45)
+
+  [ Michael Webster ]
+  * tweener.js: silence some additional warnings due to missing/unused 
properties.
+
+  [ leigh123linux ]
+  * object: Prevent use-after-free in signal connections
+  * util-root: Require GjsMaybeOwned callback to reset
+
+ -- Clement Lefebvre   Mon, 26 Jun 2017 12:18:57 +0200
+
 cjs (3.4.1) sonya; urgency=medium
 
   [ Clement Lefebvre ]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cjs-3.4.1/gi/object.cpp new/cjs-3.4.2/gi/object.cpp
--- old/cjs-3.4.1/gi/object.cpp 2017-05-23 16:29:10.0 +0200
+++ new/cjs-3.4.2/gi/object.cpp 2017-06-26 12:19:31.0 +0200
@@ -55,6 +55,8 @@
 #include 
 #include 
 
+typedef struct _ConnectData ConnectData;
+
 struct ObjectInstance {
 GIObjectInfo *info;
 GObject *gobj; /* NULL if we are the prototype and not an instance */
@@ -62,7 +64,7 @@
 GType gtype;
 
 /* a list of all signal connections, used when tracing */
-GList *signals;
+std::set signals;
 
 /* the GObjectClass wrapped by this JS Object (only used for
prototypes) */
@@ -74,11 +76,11 @@
 unsigned js_object_finalized : 1;
 };
 
-typedef struct {
+struct _ConnectData {
 ObjectInstance *obj;
-GList *link;
 GClosure *closure;
-} ConnectData;
+unsigned idle_invalidate_id;
+};
 
 static std::stack object_init_list;
 static GHashTable *class_init_properties;
@@ -93,7 +95,7 @@
 GJS_DEFINE_PRIV_FROM_JS(ObjectInstance, 

commit pix for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package pix for openSUSE:Factory checked in 
at 2017-06-29 15:18:21

Comparing /work/SRC/openSUSE:Factory/pix (Old)
 and  /work/SRC/openSUSE:Factory/.pix.new (New)


Package is "pix"

Thu Jun 29 15:18:21 2017 rev:10 rq:506914 version:1.4.5

Changes:

--- /work/SRC/openSUSE:Factory/pix/pix.changes  2017-06-13 16:09:50.268027760 
+0200
+++ /work/SRC/openSUSE:Factory/.pix.new/pix.changes 2017-06-29 
15:18:27.360719153 +0200
@@ -1,0 +2,6 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 1.4.5:
+  * Update translations.
+
+---

Old:

  pix-1.4.4.tar.gz

New:

  pix-1.4.5.tar.gz



Other differences:
--
++ pix.spec ++
--- /var/tmp/diff_new_pack.wCgq8B/_old  2017-06-29 15:18:29.044481140 +0200
+++ /var/tmp/diff_new_pack.wCgq8B/_new  2017-06-29 15:18:29.048480574 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   pix
-Version:1.4.4
+Version:1.4.5
 Release:0
 Summary:Image viewer and browser utility
 License:GPL-2.0+

++ pix-1.4.4.tar.gz -> pix-1.4.5.tar.gz ++
 3059 lines of diff (skipped)




commit mate-session-manager for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package mate-session-manager for 
openSUSE:Factory checked in at 2017-06-29 15:17:00

Comparing /work/SRC/openSUSE:Factory/mate-session-manager (Old)
 and  /work/SRC/openSUSE:Factory/.mate-session-manager.new (New)


Package is "mate-session-manager"

Thu Jun 29 15:17:00 2017 rev:21 rq:506896 version:1.18.0

Changes:

--- 
/work/SRC/openSUSE:Factory/mate-session-manager/mate-session-manager.changes
2017-04-11 09:39:54.665596652 +0200
+++ 
/work/SRC/openSUSE:Factory/.mate-session-manager.new/mate-session-manager.changes
   2017-06-29 15:17:07.815963567 +0200
@@ -1,0 +2,6 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Use update-alternatives to create the default.desktop xsession
+  (boo#1046352).
+
+---



Other differences:
--
++ mate-session-manager.spec ++
--- /var/tmp/diff_new_pack.jIklaB/_old  2017-06-29 15:17:09.779685974 +0200
+++ /var/tmp/diff_new_pack.jIklaB/_new  2017-06-29 15:17:09.779685974 +0200
@@ -47,6 +47,8 @@
 BuildRequires:  pkgconfig(xtrans)
 Requires:   %{name}-branding >= %{_version}
 Requires:   %{name}-gschemas >= %{version}
+Requires(post): update-alternatives
+Requires(postun): update-alternatives
 Recommends: %{name}-lang
 %glib2_gsettings_schema_requires
 %if 0%{?suse_version} > 1320
@@ -112,18 +114,28 @@
 
 %install
 %make_install
-%find_lang %{name} %{?no_lang_C}
+install -Dpm 0644 mate_defaults.conf 
%{buildroot}%{_sysconfdir}/mate_defaults.conf
+
+mkdir -p %{buildroot}%{_sysconfdir}/alternatives/
+touch %{buildroot}%{_sysconfdir}/alternatives/default-xsession.desktop
+ln -s %{_sysconfdir}/alternatives/default-xsession.desktop \
+  %{buildroot}%{_datadir}/xsessions/default.desktop
 
+%find_lang %{name} %{?no_lang_C}
 %suse_update_desktop_file mate-session-properties
 %suse_update_desktop_file %{buildroot}%{_datadir}/xsessions/mate.desktop
 
-install -Dpm 0644 mate_defaults.conf 
%{buildroot}%{_sysconfdir}/mate_defaults.conf
-
 %post
 %icon_theme_cache_post
+%{_sbindir}/update-alternatives --install 
%{_datadir}/xsessions/default.desktop \
+  default-xsession.desktop %{_datadir}/xsessions/mate.desktop 20
 
 %postun
 %icon_theme_cache_postun
+if [ ! -f %{_datadir}/xsessions/mate.desktop ]; then
+%{_sbindir}/update-alternatives --remove default-xsession.desktop \
+  %{_datadir}/xsessions/mate.desktop
+fi
 
 %post gschemas
 %glib2_gsettings_schema_post
@@ -134,9 +146,10 @@
 %files
 %defattr(-,root,root)
 %doc COPYING NEWS README
+%ghost %{_sysconfdir}/alternatives/default-xsession.desktop
 %{_bindir}/mate-*
 %{_datadir}/%{name}/
-%{_datadir}/xsessions/mate.desktop
+%{_datadir}/xsessions/*.desktop
 %{_datadir}/applications/mate-session-properties.desktop
 %{_datadir}/icons/hicolor/*/apps/mate-session-properties.*
 %{_mandir}/man?/mate-*.?%{?ext_man}




commit geary for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package geary for openSUSE:Factory checked 
in at 2017-06-29 15:15:48

Comparing /work/SRC/openSUSE:Factory/geary (Old)
 and  /work/SRC/openSUSE:Factory/.geary.new (New)


Package is "geary"

Thu Jun 29 15:15:48 2017 rev:31 rq:506758 version:0.11.3+20170621

Changes:

--- /work/SRC/openSUSE:Factory/geary/geary.changes  2017-03-17 
15:06:43.528331617 +0100
+++ /work/SRC/openSUSE:Factory/.geary.new/geary.changes 2017-06-29 
15:16:12.343805202 +0200
@@ -1,0 +2,6 @@
+Thu Jun 22 21:59:57 UTC 2017 - zai...@opensuse.org
+
+- Update to version 0.11.3+20170621:
+  + Updated translations.
+
+---

Old:

  geary-0.11.3+20170306.tar.xz

New:

  geary-0.11.3+20170621.tar.xz



Other differences:
--
++ geary.spec ++
--- /var/tmp/diff_new_pack.ibWYuV/_old  2017-06-29 15:16:18.446942448 +0200
+++ /var/tmp/diff_new_pack.ibWYuV/_new  2017-06-29 15:16:18.450941882 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   geary
-Version:0.11.3+20170306
+Version:0.11.3+20170621
 Release:0
 Summary:A lightweight email reader for the GNOME desktop
 License:LGPL-2.0+

++ _servicedata ++
--- /var/tmp/diff_new_pack.ibWYuV/_old  2017-06-29 15:16:18.494935663 +0200
+++ /var/tmp/diff_new_pack.ibWYuV/_new  2017-06-29 15:16:18.498935098 +0200
@@ -1,4 +1,4 @@
 
 
 git://git.gnome.org/geary
-  2f145ac76f8b81da7e9842765641a8fb3377a7b6
\ No newline at end of file
+  a9abfc0819fd16c317731d803296d73e7c6ad354
\ No newline at end of file

++ geary-0.11.3+20170306.tar.xz -> geary-0.11.3+20170621.tar.xz ++
 28712 lines of diff (skipped)




commit nemo for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package nemo for openSUSE:Factory checked in 
at 2017-06-29 15:17:50

Comparing /work/SRC/openSUSE:Factory/nemo (Old)
 and  /work/SRC/openSUSE:Factory/.nemo.new (New)


Package is "nemo"

Thu Jun 29 15:17:50 2017 rev:15 rq:506910 version:3.4.5

Changes:

--- /work/SRC/openSUSE:Factory/nemo/nemo.changes2017-06-26 
15:56:49.869013263 +0200
+++ /work/SRC/openSUSE:Factory/.nemo.new/nemo.changes   2017-06-29 
15:17:58.156847379 +0200
@@ -1,0 +2,18 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 3.4.5:
+  * search (ctrl-f): Don't search for an empty string.
+If the user wants to search for every file, one can use the
+wildcard (*).
+  * nemo-application: Only check/create the config directory at
+startup for nemo, and have nemo-desktop check both config and
+Desktop directories.
+  * nemo-window-menus.c: Fix control-n (new window) action callback
+when used from the desktop process - it should launch the
+preferred file manager instead of attempting to spawn a window
+itself.
+  * configure.ac: Suppress deprecated warnings.
+  * Add --enable-silent-rules to debian/rules, quiet C89 warnings.
+  * l10n: Generate desktop files.
+
+---

Old:

  nemo-3.4.4.tar.gz

New:

  nemo-3.4.5.tar.gz



Other differences:
--
++ nemo.spec ++
--- /var/tmp/diff_new_pack.vRtjRD/_old  2017-06-29 15:18:00.544509861 +0200
+++ /var/tmp/diff_new_pack.vRtjRD/_new  2017-06-29 15:18:00.548509295 +0200
@@ -20,7 +20,7 @@
 %define sover   1
 %define typelib typelib-1_0-Nemo-3_0
 Name:   nemo
-Version:3.4.4
+Version:3.4.5
 Release:0
 Summary:File browser for Cinnamon
 License:GPL-2.0+

++ nemo-3.4.4.tar.gz -> nemo-3.4.5.tar.gz ++
 2071 lines of diff (skipped)




commit tpm2.0-tools for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package tpm2.0-tools for openSUSE:Factory 
checked in at 2017-06-29 15:22:20

Comparing /work/SRC/openSUSE:Factory/tpm2.0-tools (Old)
 and  /work/SRC/openSUSE:Factory/.tpm2.0-tools.new (New)


Package is "tpm2.0-tools"

Thu Jun 29 15:22:20 2017 rev:6 rq:507025 version:2.0.0

Changes:

--- /work/SRC/openSUSE:Factory/tpm2.0-tools/tpm2.0-tools.changes
2017-06-21 13:57:32.304435316 +0200
+++ /work/SRC/openSUSE:Factory/.tpm2.0-tools.new/tpm2.0-tools.changes   
2017-06-29 15:22:29.994421696 +0200
@@ -1,0 +2,7 @@
+Thu Jun 29 09:45:45 UTC 2017 - matthias.gerst...@suse.com
+
+- 0002-kdfa-use-openssl-for-hmac-not-tpm.patch: fixed unexpected leak of
+  cleartext password into the tpm when generating an HMAC in the context of
+  tpm_kdfa() (key derivation function) (bnc#1046402, CVE-2017-7524)
+
+---

New:

  0002-kdfa-use-openssl-for-hmac-not-tpm.patch



Other differences:
--
++ tpm2.0-tools.spec ++
--- /var/tmp/diff_new_pack.XfqDNU/_old  2017-06-29 15:22:32.134119246 +0200
+++ /var/tmp/diff_new_pack.XfqDNU/_new  2017-06-29 15:22:32.142118116 +0200
@@ -29,6 +29,7 @@
 # this fixes an error with an unexpectedly large number of PCRS (bnc#1044419)
 # there's no release containing this fix yet
 Patch2: 0001-tpm2_listpcrs-use-TPM2_GetCapability-to-determine-PC.patch
+Patch3: 0002-kdfa-use-openssl-for-hmac-not-tpm.patch
 BuildRequires:  autoconf-archive
 BuildRequires:  automake
 BuildRequires:  gcc-c++
@@ -52,6 +53,7 @@
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 bash ./bootstrap

++ 0002-kdfa-use-openssl-for-hmac-not-tpm.patch ++
>From c5d72beaab1cbbbe68271f4bc4b6670d69985157 Mon Sep 17 00:00:00 2001
From: William Roberts 
Date: Wed, 21 Jun 2017 09:32:32 -0700
Subject: [PATCH] kdfa: use openssl for hmac not tpm

While not reachable in the current code base tools, a potential
security bug lurked in tpm_kdfa().

If using that routine for an hmac authorization, the hmac was
calculated using the tpm. A user of an object wishing to
authenticate via hmac, would expect that the password is never
sent to the tpm. However, since the hmac calculation relies on
password, and is performed by the tpm, the password ends up
being sent in plain text to the tpm.

The fix is to use openssl to generate the hmac on the host.

Fixes: CVE-2017-7524

Signed-off-by: William Roberts 
---
 Makefile.am   |  4 +--
 configure.ac  |  3 ++-
 lib/tpm_kdfa.c| 76 +++
 lib/tpm_kdfa.h|  2 +-
 lib/tpm_session.c |  2 +-
 5 files changed, 72 insertions(+), 15 deletions(-)

Index: tpm2.0-tools-2.0.0/Makefile.am
===
--- tpm2.0-tools-2.0.0.orig/Makefile.am
+++ tpm2.0-tools-2.0.0/Makefile.am
@@ -35,10 +35,10 @@ ACLOCAL_AMFLAGS = -I m4
 INCLUDE_DIRS = -I$(srcdir)/src -I$(srcdir)/lib
 LIB_COMMON := lib/libcommon.a
 
-AM_CFLAGS:= $(INCLUDE_DIRS) $(TPM20_TSS_CFLAGS) $(EXTRA_CFLAGS)
+AM_CFLAGS:= $(INCLUDE_DIRS) $(TPM20_TSS_CFLAGS) $(EXTRA_CFLAGS) 
$(CRYPTO_FLAGS)
 AM_LDFLAGS   := $(EXTRA_LDFLAGS)
 
-LDADD = $(LIB_COMMON) $(TPM20_TSS_LIBS) $(TCTI_SOCK_LIBS) $(TCTI_DEV_LIBS)
+LDADD = $(LIB_COMMON) $(TPM20_TSS_LIBS) $(TCTI_SOCK_LIBS) $(TCTI_DEV_LIBS) 
$(CRYPTO_LIBS)
 
 sbin_PROGRAMS = \
 tools/tpm2_create \
Index: tpm2.0-tools-2.0.0/configure.ac
===
--- tpm2.0-tools-2.0.0.orig/configure.ac
+++ tpm2.0-tools-2.0.0/configure.ac
@@ -49,7 +49,8 @@ AS_IF(
 [AC_MSG_ERROR(
 [no TCTIs: at least one TCTI library must be enabled],
 [1])])
-PKG_CHECK_MODULES([CURL],[libcurl libcrypto])
+PKG_CHECK_MODULES([CRYPTO],[libcrypto])
+PKG_CHECK_MODULES([CURL],[libcurl])
 AC_ARG_ENABLE([unit],
 [AS_HELP_STRING([--enable-unit],
 [build cmocka unit tests (default is no)])],
Index: tpm2.0-tools-2.0.0/lib/tpm_kdfa.c
===
--- tpm2.0-tools-2.0.0.orig/lib/tpm_kdfa.c
+++ tpm2.0-tools-2.0.0/lib/tpm_kdfa.c
@@ -27,20 +27,40 @@
 
 #include 
 
+ #include 
+#include 
+
 #include "string-bytes.h"
 #include "tpm_hmac.h"
+#include "log.h"
+
+static const EVP_MD *tpm_algorithm_to_openssl_digest(TPMI_ALG_HASH algorithm) {
 
-TPM_RC tpm_kdfa(TSS2_SYS_CONTEXT *sapi_context, TPMI_ALG_HASH hashAlg,
+switch(algorithm) {
+case TPM_ALG_SHA1:
+return EVP_sha1();
+case ALG_SHA256_VALUE:
+return EVP_sha256();
+case TPM_ALG_SHA384:
+return EVP_sha384();
+case TPM_ALG_SHA512:
+

commit ffmpeg2 for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package ffmpeg2 for openSUSE:Factory checked 
in at 2017-06-29 15:16:36

Comparing /work/SRC/openSUSE:Factory/ffmpeg2 (Old)
 and  /work/SRC/openSUSE:Factory/.ffmpeg2.new (New)


Package is "ffmpeg2"

Thu Jun 29 15:16:36 2017 rev:9 rq:506789 version:2.8.12

Changes:

--- /work/SRC/openSUSE:Factory/ffmpeg2/ffmpeg2.changes  2017-06-21 
13:51:30.043535624 +0200
+++ /work/SRC/openSUSE:Factory/.ffmpeg2.new/ffmpeg2.changes 2017-06-29 
15:16:47.362854841 +0200
@@ -6 +6 @@
-full details.
+full details. bsc#1046211



Other differences:
--




commit xdg-desktop-portal-gtk for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package xdg-desktop-portal-gtk for 
openSUSE:Factory checked in at 2017-06-29 15:15:39

Comparing /work/SRC/openSUSE:Factory/xdg-desktop-portal-gtk (Old)
 and  /work/SRC/openSUSE:Factory/.xdg-desktop-portal-gtk.new (New)


Package is "xdg-desktop-portal-gtk"

Thu Jun 29 15:15:39 2017 rev:3 rq:506744 version:0.7

Changes:

--- 
/work/SRC/openSUSE:Factory/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk.changes
2017-01-25 23:31:13.939349428 +0100
+++ 
/work/SRC/openSUSE:Factory/.xdg-desktop-portal-gtk.new/xdg-desktop-portal-gtk.changes
   2017-06-29 15:15:49.147084356 +0200
@@ -1,0 +2,53 @@
+Mon Jun 26 17:54:10 UTC 2017 - zai...@opensuse.org
+
+- Update to version 0.7:
+  + appchooserdialog: Fix CSS loading.
+  + Fix desktop file generation.
+  + Do not dist generated file xdg-desktop-portal-gtk.desktop.in.
+  + Clean and do not distribute generated source files.
+  + .gitignore: Add many generated files.
+  + .desktop: Tell users to not translate icon name.
+  + notification: Fix ::handle-* return values.
+  + notification: Fix 'icon' lookup.
+  + notification: Use 'app-icon' instead of 'image-path' hint.
+  + notification: Support raw data in 'image-data' hint.
+  + Fix a bug in the app chooser.
+  + Drop UI config.
+  + Use a shorter name for apps.
+  + Make the heading bigger.
+  + Use the filename for the heading.
+  + Fully implement the app picker mockup.
+  + Update po files.
+  + Updated translations.
+- Changes from version 0.6:
+  + Avoid gtk_label_set_xalign()
+  + Avoid G_DECLARE_* macros
+  + Avoid gtk_css_provider_load_from_resource()
+  + Avoid gtk_entry_grab_focus_without_selecting()
+  + Avoid gtk_search_entry_handle_event()
+  + Avoid g_autoptr() with GtkPrint types
+  + Avoid gtk_print_job_set_source_fd()
+  + configure: Update GLib and GTK+ versions
+  + appchooserrow: Remove gedit references from UI file
+  + appchooserrow: Don't set NULL icons
+  + Implement org.freedesktop.impl.portal.Email
+  + Update for API changes
+  + email: Support thunderbird
+  + Add a systemd user unit corresponding to the session service
+  + Force the icon size to be 48
+  + notification: Add better debug and error messages
+  + Encode po/Makevars in UTF-8
+  + Some fixes for the filechooser preview
+  + Set the program name to a fixed string
+  + Redo the app chooser
+  + Add an appchooser test
+  + Add an empty state
+  + Cosmetic changes
+  + Make icons 64x64
+  + Allow setting the default in testappchooser
+  + app chooser: Focus the default choice initially
+  + Install a desktop file
+  + Fix POFILES
+  + Updated translations.
+
+---

Old:

  xdg-desktop-portal-gtk-0.5.tar.xz

New:

  xdg-desktop-portal-gtk-0.7.tar.xz



Other differences:
--
++ xdg-desktop-portal-gtk.spec ++
--- /var/tmp/diff_new_pack.3Vbwop/_old  2017-06-29 15:15:51.118805626 +0200
+++ /var/tmp/diff_new_pack.3Vbwop/_new  2017-06-29 15:15:51.126804496 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   xdg-desktop-portal-gtk
-Version:0.5
+Version:0.7
 Release:0
 Summary:Backend implementation for xdg-desktop-portal using GTK+
 License:LGPL-2.1+
@@ -33,7 +33,7 @@
 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
 BuildRequires:  pkgconfig(gtk+-wayland-3.0) >= 3.21.5
 BuildRequires:  pkgconfig(gtk+-x11-3.0)
-BuildRequires:  pkgconfig(xdg-desktop-portal)
+BuildRequires:  pkgconfig(xdg-desktop-portal) >= 0.7
 # Requires the xdg-desktop-portal service to be available
 Requires:   xdg-desktop-portal
 Recommends: %{name}-lang
@@ -68,6 +68,8 @@
 %dir %{_datadir}/xdg-desktop-portal
 %dir %{_datadir}/xdg-desktop-portal/portals
 %{_datadir}/xdg-desktop-portal/portals/gtk.portal
+%{_datadir}/applications/xdg-desktop-portal-gtk.desktop
+%{_userunitdir}/xdg-desktop-portal-gtk.service
 
 %files lang -f %{name}.lang
 %defattr(-,root,root)

++ _service ++
--- /var/tmp/diff_new_pack.3Vbwop/_old  2017-06-29 15:15:51.170798276 +0200
+++ /var/tmp/diff_new_pack.3Vbwop/_new  2017-06-29 15:15:51.170798276 +0200
@@ -4,7 +4,7 @@
 git
 @PARENT_TAG@
 enable
-refs/tags/0.5
+refs/tags/0.7
   
   
 *.tar

++ _servicedata ++
--- /var/tmp/diff_new_pack.3Vbwop/_old  2017-06-29 15:15:51.198794319 +0200
+++ /var/tmp/diff_new_pack.3Vbwop/_new  2017-06-29 15:15:51.198794319 +0200
@@ -1,4 +1,4 @@
 
 
 https://github.com/flatpak/xdg-desktop-portal-gtk.git
-  9df0378bdccc7ea5ab2d59f0f5fcf1e308d2c01e
\ No newline at end of file
+  7df844d243ee0aa001d1c27304c0fc2e2fcbfc6f
\ No newline at end of file

++ xdg-desktop-portal-gtk-0.5.tar.xz -> xdg-desktop-portal-gtk-0.7.tar.xz 
++
 3614 

commit stress-ng for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package stress-ng for openSUSE:Factory 
checked in at 2017-06-29 15:22:12

Comparing /work/SRC/openSUSE:Factory/stress-ng (Old)
 and  /work/SRC/openSUSE:Factory/.stress-ng.new (New)


Package is "stress-ng"

Thu Jun 29 15:22:12 2017 rev:15 rq:507020 version:0.08.07

Changes:

--- /work/SRC/openSUSE:Factory/stress-ng/stress-ng.changes  2017-06-23 
09:18:47.890760975 +0200
+++ /work/SRC/openSUSE:Factory/.stress-ng.new/stress-ng.changes 2017-06-29 
15:22:23.371357876 +0200
@@ -1,0 +2,5 @@
+Thu Jun 29 09:45:32 UTC 2017 - pgeorgia...@suse.com
+
+-  update to version 0.08.07
+
+---

Old:

  stress-ng-0.08.06.tar.gz

New:

  stress-ng-0.08.07.tar.gz



Other differences:
--
++ stress-ng.spec ++
--- /var/tmp/diff_new_pack.JMysHl/_old  2017-06-29 15:22:24.991128919 +0200
+++ /var/tmp/diff_new_pack.JMysHl/_new  2017-06-29 15:22:24.995128353 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   stress-ng
-Version:0.08.06
+Version:0.08.07
 Release:0
 Summary:Tool to load and stress a computer
 License:GPL-2.0

++ stress-ng-0.08.06.tar.gz -> stress-ng-0.08.07.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/stress-ng-0.08.06/Makefile 
new/stress-ng-0.08.07/Makefile
--- old/stress-ng-0.08.06/Makefile  2017-06-21 18:34:24.0 +0200
+++ new/stress-ng-0.08.07/Makefile  2017-06-28 12:10:09.0 +0200
@@ -16,7 +16,7 @@
 # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, 
USA.
 #
 
-VERSION=0.08.06
+VERSION=0.08.07
 #
 # Codename "harmful hardware harasser"
 #
@@ -273,7 +273,8 @@
 HAVE_VECMATH=0 HAVE_ATOMIC=0 HAVE_LIB_SCTP=0 HAVE_ASM_NOP=0 \
 HAVE_ALIGNED_64K=0 HAVE_ALIGNED_64=0 HAVE_ALIGNED_128=0 \
 HAVE_AFFINITY=0 HAVE_MADVISE=0 HAVE_SEM_POSIX=0 HAVE_SEM_SYSV=0 \
-HAVE_MQ_POSIX=0 HAVE_MQ_SYSV=0 HAVE_SHM_SYSV=0
+HAVE_MQ_POSIX=0 HAVE_MQ_SYSV=0 HAVE_SHM_SYSV=0 HAVE_FANOTIFY=0 \
+HAVE_INOTIFY=0
 
 #
 #  Load in current config; use 'make clean' to clear this
@@ -523,6 +524,22 @@
 endif
 endif
 
+ifndef $(HAVE_FANOTIFY)
+HAVE_FANOTIFY = $(shell $(MAKE) --no-print-directory $(HAVE_NOT) have_fanotify)
+ifeq ($(HAVE_FANOTIFY),1)
+   CONFIG_CFLAGS += -DHAVE_FANOTIFY
+$(info autoconfig: using fanotify)
+endif
+endif
+
+ifndef $(HAVE_INOTIFY)
+HAVE_INOTIFY = $(shell $(MAKE) --no-print-directory $(HAVE_NOT) have_inotify)
+ifeq ($(HAVE_INOTIFY),1)
+   CONFIG_CFLAGS += -DHAVE_INOTIFY
+$(info autoconfig: using inotify)
+endif
+endif
+
 endif
 endif
 
@@ -905,7 +922,7 @@
 #
 #  check if we can build using SYSV shared memory
 #
-.PHONY: have_shm_sysv_
+.PHONY: have_shm_sysv
 have_shm_sysv: test-shm-sysv.c
@$(CC) $(CPPFLAGS) test-shm-sysv.c -o test-shm-sysv 2> /dev/null || true
@if [ -f test-shm-sysv ]; then \
@@ -916,6 +933,32 @@
@rm -rf test-shm-sysv
 
 #
+#  check if we can build using fanotify
+#
+.PHONY: have_fanotify
+have_fanotify: test-fanotify.c
+   @$(CC) $(CPPFLAGS) test-fanotify.c -o test-fanotify 2> /dev/null || true
+   @if [ -f test-fanotify ]; then \
+   echo 1 ;\
+   else \
+   echo 0 ;\
+   fi
+   @rm -rf test-fanotify
+
+#
+#  check if we can build using inotify
+#
+.PHONY: have_inotify
+have_inotify: test-inotify.c
+   @$(CC) $(CPPFLAGS) test-inotify.c -o test-inotify 2> /dev/null || true
+   @if [ -f test-inotify ]; then \
+   echo 1 ;\
+   else \
+   echo 0 ;\
+   fi
+   @rm -rf test-inotify
+
+#
 #  extract the PER_* personality enums
 #
 personality.h:
@@ -967,7 +1010,7 @@
test-aligned-128.c usr.bin.pulseaudio.eg perf-event.c \
test-affinity.c test-madvise.c test-sem-posix.c \
test-sem-sysv.c test-mq-posix.c test-mq-sysv.c \
-   test-shm-sysv.c \
+   test-shm-sysv.c test-fanotify.c test-inotify.c \
snapcraft smatchify.sh config TODO \
example-jobs stress-ng-$(VERSION)
tar -zcf stress-ng-$(VERSION).tar.gz stress-ng-$(VERSION)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/stress-ng-0.08.06/stress-cyclic.c 
new/stress-ng-0.08.07/stress-cyclic.c
--- old/stress-ng-0.08.06/stress-cyclic.c   2017-06-21 18:34:24.0 
+0200
+++ new/stress-ng-0.08.07/stress-cyclic.c   2017-06-28 12:10:09.0 
+0200
@@ -79,7 +79,7 @@
uint64_t cyclic_sleep;
 
cyclic_sleep = get_uint64(opt);
-check_range_bytes("cyclic-sleep", cyclic_sleep,
+

commit cinnamon-translations for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package cinnamon-translations for 
openSUSE:Factory checked in at 2017-06-29 15:17:37

Comparing /work/SRC/openSUSE:Factory/cinnamon-translations (Old)
 and  /work/SRC/openSUSE:Factory/.cinnamon-translations.new (New)


Package is "cinnamon-translations"

Thu Jun 29 15:17:37 2017 rev:9 rq:506908 version:3.4.3

Changes:

--- 
/work/SRC/openSUSE:Factory/cinnamon-translations/cinnamon-translations.changes  
2017-05-27 13:19:03.429634042 +0200
+++ 
/work/SRC/openSUSE:Factory/.cinnamon-translations.new/cinnamon-translations.changes
 2017-06-29 15:17:49.402084947 +0200
@@ -1,0 +2,6 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 3.4.3:
+  * Update translations.
+
+---

Old:

  cinnamon-translations-3.4.2.tar.gz

New:

  cinnamon-translations-3.4.3.tar.gz



Other differences:
--
++ cinnamon-translations.spec ++
--- /var/tmp/diff_new_pack.hpeECP/_old  2017-06-29 15:17:50.809885940 +0200
+++ /var/tmp/diff_new_pack.hpeECP/_new  2017-06-29 15:17:50.809885940 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   cinnamon-translations
-Version:3.4.2
+Version:3.4.3
 Release:0
 Summary:Translation files for the Cinnamon desktop
 License:GPL-2.0+

++ cinnamon-translations-3.4.2.tar.gz -> cinnamon-translations-3.4.3.tar.gz 
++
/work/SRC/openSUSE:Factory/cinnamon-translations/cinnamon-translations-3.4.2.tar.gz
 
/work/SRC/openSUSE:Factory/.cinnamon-translations.new/cinnamon-translations-3.4.3.tar.gz
 differ: char 16, line 1




commit xdg-desktop-portal for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package xdg-desktop-portal for 
openSUSE:Factory checked in at 2017-06-29 15:15:20

Comparing /work/SRC/openSUSE:Factory/xdg-desktop-portal (Old)
 and  /work/SRC/openSUSE:Factory/.xdg-desktop-portal.new (New)


Package is "xdg-desktop-portal"

Thu Jun 29 15:15:20 2017 rev:3 rq:506743 version:0.8

Changes:

--- /work/SRC/openSUSE:Factory/xdg-desktop-portal/xdg-desktop-portal.changes
2017-01-25 23:31:06.400485632 +0100
+++ 
/work/SRC/openSUSE:Factory/.xdg-desktop-portal.new/xdg-desktop-portal.changes   
2017-06-29 15:15:40.948243371 +0200
@@ -1,0 +2,44 @@
+Mon Jun 26 12:26:40 UTC 2017 - zai...@opensuse.org
+
+- Update to version 0.8:
+  + Update po files.
+- Changes from version 0.7:
+  + notification: Fix copy+paste error.
+  + notification: Subscribe to the right interface for signals.
+  + If the random request ID creates a collision, pick a new random
+ID.
+  + Add some rationale.
+  + Fix a typo.
+  + Update README.md.
+  + OpenURI: Refuse to handle file: uris.
+  + Add an OpenFile method.
+  + OpenFile: Fix URI.
+  + Cache entire flatpak info file for peer, not just app id.
+  + Store the cached flatpak-info keyfile with the request.
+  + OpenFile: Rewrite app paths in /usr and /app (and /newroot).
+  + OpenFile: Ensure that passed O_PATH fd is correct.
+  + Send more data to the appchooser.
+  + Updated translations.
+- Changes from version 0.6:
+  + Remove what appears to be printing lines from a debugging
+session.
+  + open-uri: Fix segfault crash when no content-type can be
+resolved.
+  + account: Remove debug spew.
+  + Update README.md.
+  + Add an email portal.
+  + Include the email portal in the docs.
+  + build: No need to clean org.freedesktop.portal.Desktop.service
+twice.
+  + Add a systemd user unit corresponding to the session service.
+  + notifications: Add better debug and error messages.
+  + device: Add more detail to error messages.
+  + Handle g_variant_lookup failure.
+  + Encode po/Makevars in UTF-8.
+  + Initialize autofree string variable to NULL.
+  + open-uri: Implement a more permissive policy for the OpenURI
+portal.
+  + data: Fix typo in NetworkMonitor XML definition.
+  + Updated translations.
+
+---

Old:

  xdg-desktop-portal-0.5.tar.xz

New:

  xdg-desktop-portal-0.8.tar.xz



Other differences:
--
++ xdg-desktop-portal.spec ++
--- /var/tmp/diff_new_pack.bzBfrx/_old  2017-06-29 15:15:44.591728316 +0200
+++ /var/tmp/diff_new_pack.bzBfrx/_new  2017-06-29 15:15:44.599727184 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   xdg-desktop-portal
-Version:0.5
+Version:0.8
 Release:0
 Summary:A portal frontend service for Flatpak
 License:LGPL-2.1+
@@ -74,9 +74,11 @@
 %defattr(-,root,root)
 %doc COPYING
 %{_libexecdir}/xdg-desktop-portal
+%{_userunitdir}/xdg-desktop-portal.service
 %{_datadir}/dbus-1/interfaces/org.freedesktop.impl.portal.Access.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.impl.portal.Account.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.impl.portal.AppChooser.xml
+%{_datadir}/dbus-1/interfaces/org.freedesktop.impl.portal.Email.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.impl.portal.FileChooser.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.impl.portal.Inhibit.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.impl.portal.Notification.xml
@@ -85,6 +87,7 @@
 %{_datadir}/dbus-1/interfaces/org.freedesktop.impl.portal.Screenshot.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.portal.Account.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.portal.Device.xml
+%{_datadir}/dbus-1/interfaces/org.freedesktop.portal.Email.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.portal.FileChooser.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.portal.Inhibit.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.portal.NetworkMonitor.xml

++ _service ++
--- /var/tmp/diff_new_pack.bzBfrx/_old  2017-06-29 15:15:44.647720400 +0200
+++ /var/tmp/diff_new_pack.bzBfrx/_new  2017-06-29 15:15:44.651719835 +0200
@@ -4,7 +4,7 @@
 git
 @PARENT_TAG@
 enable
-refs/tags/0.5
+refs/tags/0.8
   
   
 *.tar

++ _servicedata ++
--- /var/tmp/diff_new_pack.bzBfrx/_old  2017-06-29 15:15:44.691714181 +0200
+++ /var/tmp/diff_new_pack.bzBfrx/_new  2017-06-29 15:15:44.695713615 +0200
@@ -1,4 +1,4 @@
 
 
 https://github.com/flatpak/xdg-desktop-portal.git
-  3daad21c289952edb60573752c9aa93a5c56e66d
\ No newline at end of file
+  ea111542b516142a0740ab8f47325566a9c51693
\ No newline at end of file

++ xdg-desktop-portal-0.5.tar.xz -> xdg-desktop-portal-0.8.tar.xz ++
 

commit fio for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package fio for openSUSE:Factory checked in 
at 2017-06-29 15:21:57

Comparing /work/SRC/openSUSE:Factory/fio (Old)
 and  /work/SRC/openSUSE:Factory/.fio.new (New)


Package is "fio"

Thu Jun 29 15:21:57 2017 rev:38 rq:507004 version:2.21

Changes:

--- /work/SRC/openSUSE:Factory/fio/fio.changes  2017-05-29 22:19:54.721767291 
+0200
+++ /work/SRC/openSUSE:Factory/.fio.new/fio.changes 2017-06-29 
15:22:14.324636646 +0200
@@ -1,0 +2,7 @@
+Thu Jun 29 09:22:09 UTC 2017 - ktsa...@suse.com
+
+- Update to version 2.21:
+  * See http://brick.kernel.dk/snaps/fio-2.21.shortlog.txt
+- Enabled tests
+
+---

Old:

  fio-2.20.tar.bz2
  fio-2.20.tar.bz2.asc

New:

  fio-2.21.tar.bz2
  fio-2.21.tar.bz2.asc



Other differences:
--
++ fio.spec ++
--- /var/tmp/diff_new_pack.qfwDcX/_old  2017-06-29 15:22:16.452335891 +0200
+++ /var/tmp/diff_new_pack.qfwDcX/_new  2017-06-29 15:22:16.456335326 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   fio
-Version:2.20
+Version:2.21
 Release:0
 Summary:Flexible I/O Tester/benchmarker
 License:GPL-2.0
@@ -90,6 +90,9 @@
   mandir="%{_mandir}" \
   install
 
+%check
+make %{?_smp_mflags} test
+
 %files
 %defattr(-,root,root)
 %doc COPYING README examples

++ fio-2.20.tar.bz2 -> fio-2.21.tar.bz2 ++
 2178 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/fio-2.20/FIO-VERSION-GEN new/fio-2.21/FIO-VERSION-GEN
--- old/fio-2.20/FIO-VERSION-GEN2017-05-19 16:25:27.0 +0200
+++ new/fio-2.21/FIO-VERSION-GEN2017-06-15 20:25:03.0 +0200
@@ -1,7 +1,7 @@
 #!/bin/sh
 
 GVF=FIO-VERSION-FILE
-DEF_VER=fio-2.20
+DEF_VER=fio-2.21
 
 LF='
 '
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/fio-2.20/HOWTO new/fio-2.21/HOWTO
--- old/fio-2.20/HOWTO  2017-05-19 16:25:27.0 +0200
+++ new/fio-2.21/HOWTO  2017-06-15 20:25:03.0 +0200
@@ -1072,10 +1072,11 @@
 
 .. option:: offset=int
 
-   Start I/O at the given offset in the file. The data before the given 
offset
-   will not be touched. This effectively caps the file size at `real_size -
-   offset`. Can be combined with :option:`size` to constrain the start and
-   end range that I/O will be done within.
+   Start I/O at the provided offset in the file, given as either a fixed 
size or
+   a percentage. If a percentage is given, the next ``blockalign``-ed 
offset
+   will be used. Data before the given offset will not be touched. This
+   effectively caps the file size at `real_size - offset`. Can be combined 
with
+   :option:`size` to constrain the start and end range of the I/O workload.
 
 .. option:: offset_increment=int
 
@@ -1290,7 +1291,7 @@
means default for reads, 8k for writes and trims.
 
**bs=,8k,**
-   means default for reads, 8k for writes, and default for 
writes.
+   means default for reads, 8k for writes, and default for 
trims.
 
 .. option:: blocksize_range=irange[,irange][,irange], 
bsrange=irange[,irange][,irange]
 
@@ -1400,11 +1401,18 @@
 
 .. option:: buffer_pattern=str
 
-   If set, fio will fill the I/O buffers with this pattern. If not set, the
-   contents of I/O buffers is defined by the other options related to 
buffer
-   contents. The setting can be any pattern of bytes, and can be prefixed 
with
-   0x for hex values. It may also be a string, where the string must then 
be
-   wrapped with ``""``, e.g.::
+   If set, fio will fill the I/O buffers with this pattern or with the 
contents
+   of a file. If not set, the contents of I/O buffers are defined by the 
other
+   options related to buffer contents. The setting can be any pattern of 
bytes,
+   and can be prefixed with 0x for hex values. It may also be a string, 
where
+   the string must then be wrapped with ``""``. Or it may also be a 
filename,
+   where the filename must be wrapped with ``''`` in which case the file is
+   opened and read. Note that not all the file contents will 

commit xplayer for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package xplayer for openSUSE:Factory checked 
in at 2017-06-29 15:21:39

Comparing /work/SRC/openSUSE:Factory/xplayer (Old)
 and  /work/SRC/openSUSE:Factory/.xplayer.new (New)


Package is "xplayer"

Thu Jun 29 15:21:39 2017 rev:11 rq:506988 version:1.4.3

Changes:

--- /work/SRC/openSUSE:Factory/xplayer/xplayer.changes  2017-05-27 
13:13:04.348399843 +0200
+++ /work/SRC/openSUSE:Factory/.xplayer.new/xplayer.changes 2017-06-29 
15:21:51.871810402 +0200
@@ -1,0 +2,6 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 1.4.3:
+  * Update translations.
+
+---

Old:

  xplayer-1.4.2.tar.gz

New:

  xplayer-1.4.3.tar.gz



Other differences:
--
++ xplayer.spec ++
--- /var/tmp/diff_new_pack.3n1ih1/_old  2017-06-29 15:21:53.011649282 +0200
+++ /var/tmp/diff_new_pack.3n1ih1/_new  2017-06-29 15:21:53.015648717 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without zeitgeist
 Name:   xplayer
-Version:1.4.2
+Version:1.4.3
 Release:0
 Summary:Generic media player
 License:GPL-2.0+ and LGPL-2.1+

++ xplayer-1.4.2.tar.gz -> xplayer-1.4.3.tar.gz ++
 1979 lines of diff (skipped)




commit coreboot-utils for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package coreboot-utils for openSUSE:Factory 
checked in at 2017-06-29 15:21:13

Comparing /work/SRC/openSUSE:Factory/coreboot-utils (Old)
 and  /work/SRC/openSUSE:Factory/.coreboot-utils.new (New)


Package is "coreboot-utils"

Thu Jun 29 15:21:13 2017 rev:23 rq:506986 version:4.5

Changes:

--- /work/SRC/openSUSE:Factory/coreboot-utils/coreboot-utils.changes
2017-05-16 14:38:11.785793595 +0200
+++ /work/SRC/openSUSE:Factory/.coreboot-utils.new/coreboot-utils.changes   
2017-06-29 15:21:38.405713871 +0200
@@ -1,0 +2,7 @@
+Fri Jun 16 12:00:39 UTC 2017 - alarr...@suse.com
+
+- Add do-explicit-fallthrough.patch to fix a build failure with gcc7
+  with an implicit fallthrough over switch cases (only on TW)
+- Add -fPIC to no-pie.patch and remove -fno-pic to build with gcc7
+
+---

New:

  do-explicit-fallthrough.patch



Other differences:
--
++ coreboot-utils.spec ++
--- /var/tmp/diff_new_pack.s64XKZ/_old  2017-06-29 15:21:47.144478622 +0200
+++ /var/tmp/diff_new_pack.s64XKZ/_new  2017-06-29 15:21:47.144478622 +0200
@@ -26,6 +26,7 @@
 Source0:http://www.coreboot.org/releases/coreboot-%{version}.tar.xz
 Patch1: no-pie.patch
 Patch2: k8resdump.diff
+Patch3: do-explicit-fallthrough.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  gcc-c++
 BuildRequires:  pciutils-devel
@@ -40,8 +41,13 @@
 
 %prep
 %setup -q -n coreboot-%{version}
+%if 0%{?suse_version} > 1320
 %patch1 -p1
+%endif
 %patch2 -p1
+%if 0%{?suse_version} > 1320
+%patch3 -p1
+%endif
 
 %build
 make %{?_smp_mflags} CFLAGS="%{optflags}" -C util/ectool

++ do-explicit-fallthrough.patch ++
Index: coreboot-4.5/util/cbfstool/lz4/lib/lz4frame.c
===
--- coreboot-4.5.orig/util/cbfstool/lz4/lib/lz4frame.c
+++ coreboot-4.5/util/cbfstool/lz4/lib/lz4frame.c
@@ -1091,7 +1091,7 @@ size_t LZ4F_decompress(LZ4F_decompressio
 dctxPtr->tmpInTarget = minFHSize;   /* minimum to attempt 
decode */
 dctxPtr->dStage = dstage_storeHeader;
 }
-
+__attribute__ ((fallthrough));
 case dstage_storeHeader:
 {
 size_t sizeToCopy = dctxPtr->tmpInTarget - dctxPtr->tmpInSize;
++ no-pie.patch ++
--- /var/tmp/diff_new_pack.s64XKZ/_old  2017-06-29 15:21:47.200470707 +0200
+++ /var/tmp/diff_new_pack.s64XKZ/_new  2017-06-29 15:21:47.200470707 +0200
@@ -8,8 +8,8 @@
  PREFIX  = @PREFIX@
 -CFLAGS  = @CFLAGS@ -fno-pic
 -LDFLAGS = @LDFLAGS@
-+CFLAGS  = @CFLAGS@ -fno-pic -fno-PIE
-+LDFLAGS = @LDFLAGS@ -no-pie
++CFLAGS  = @CFLAGS@ -fPIC -fno-PIE
++LDFLAGS = @LDFLAGS@ -fPIC -no-pie
  
  TARGETS = geodegx2.o geodelx.o cs5536.o k8.o intel_pentium3_early.o 
intel_pentium3.o intel_pentium4_early.o intel_pentium4_later.o intel_core1.o 
intel_core2_early.o intel_core2_later.o intel_nehalem.o intel_atom.o
  SYSTEMS = linux.o darwin.o freebsd.o




commit rubygem-facter for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package rubygem-facter for openSUSE:Factory 
checked in at 2017-06-29 15:20:51

Comparing /work/SRC/openSUSE:Factory/rubygem-facter (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-facter.new (New)


Package is "rubygem-facter"

Thu Jun 29 15:20:51 2017 rev:9 rq:506981 version:2.4.6

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-facter/rubygem-facter.changes
2016-10-10 16:21:51.0 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-facter.new/rubygem-facter.changes   
2017-06-29 15:21:06.330247844 +0200
@@ -1,0 +2,6 @@
+Tue Jun 27 16:12:10 UTC 2017 - kstreit...@suse.com
+
+- add facter-vlan_interfaces.patch in order to recognize VLAN
+  tagged interfaces correctly [bsc#1040363] 
+
+---

New:

  facter-vlan_interfaces.patch



Other differences:
--
++ rubygem-facter.spec ++
--- /var/tmp/diff_new_pack.Cu5C0T/_old  2017-06-29 15:21:08.173987224 +0200
+++ /var/tmp/diff_new_pack.Cu5C0T/_new  2017-06-29 15:21:08.173987224 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package rubygem-facter
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -37,12 +37,13 @@
 BuildRequires:  %{rubygem gem2rpm}
 BuildRequires:  update-alternatives
 Url:https://github.com/puppetlabs/facter
-Source: http://rubygems.org/gems/%{mod_full_name}.gem
+Source: https://rubygems.org/gems/%{mod_full_name}.gem
 Source1:%{mod_name}.8
 Source2:gem2rpm.yml
 # MANUAL
 Patch0:  %{mod_name}-ip-interface.patch
 Patch1:  %{mod_name}-detect-recent-opensuse.patch
+Patch2:  %{mod_name}-vlan_interfaces.patch
 # /MANUAL
 Summary:Facter, a system inventory tool
 License:Apache-2.0
@@ -56,6 +57,7 @@
 %gem_unpack
 %patch0 -p1
 %patch1 -p1
+%patch2 -p0
 find -type f -print0 | xargs -0 touch -r %{S:0}
 %gem_build
 

++ facter-vlan_interfaces.patch ++
--- lib/facter/util/ip.rb.orig  2017-06-27 18:24:06.427331472 +0200
+++ lib/facter/util/ip.rb   2017-06-27 18:24:14.203440910 +0200
@@ -83,6 +83,7 @@
 when 'Linux'
   output = Facter::Util::IP.exec_ip(["link"])
   output.gsub!(/^\d+:\s*/, "") # delete 
leading number
+  output.gsub!(/@[^:]+/, "")# delete 
physical interface name in case of tagged vlan like "vlan100@bond0"
 when 'OpenBSD', 'NetBSD', 'FreeBSD', 'Darwin', 'GNU/kFreeBSD', 
'DragonFly', 'AIX'
   output = Facter::Util::IP.exec_ifconfig(["-a","2>/dev/null"])
 when 'SunOS'

++ gem2rpm.yml ++
--- /var/tmp/diff_new_pack.Cu5C0T/_old  2017-06-29 15:21:08.237978180 +0200
+++ /var/tmp/diff_new_pack.Cu5C0T/_new  2017-06-29 15:21:08.237978180 +0200
@@ -25,6 +25,8 @@
   '%{mod_name}-ip-interface.patch': -p1
   # PATCH-FIX-UPSTREAM - FACT-1496
   '%{mod_name}-detect-recent-opensuse.patch': -p1
+  # PATCH-FIX-SUSE - bsc#1040363
+  '%{mod_name}-vlan_interfaces.patch': -p0
 :post_install: |-
   mkdir -p %{buildroot}%{_sysconfdir}/%{mod_name}/facts.d
   install -Dm0444 %{SOURCE1} %{buildroot}%{_mandir}/man8/%{mod_name}.8




commit python-compizconfig for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package python-compizconfig for 
openSUSE:Factory checked in at 2017-06-29 15:21:00

Comparing /work/SRC/openSUSE:Factory/python-compizconfig (Old)
 and  /work/SRC/openSUSE:Factory/.python-compizconfig.new (New)


Package is "python-compizconfig"

Thu Jun 29 15:21:00 2017 rev:7 rq:506985 version:0.8.14

Changes:

--- /work/SRC/openSUSE:Factory/python-compizconfig/python-compizconfig.changes  
2017-05-16 14:46:59.195690384 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-compizconfig.new/python-compizconfig.changes 
2017-06-29 15:21:15.220991105 +0200
@@ -1,0 +2,5 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Fix building on openSUSE older than openSUSE Leap 15.x.
+
+---



Other differences:
--
++ python-compizconfig.spec ++
--- /var/tmp/diff_new_pack.1fJVtj/_old  2017-06-29 15:21:21.568093920 +0200
+++ /var/tmp/diff_new_pack.1fJVtj/_new  2017-06-29 15:21:21.568093920 +0200
@@ -38,7 +38,7 @@
 Requires:   compiz < 0.9
 Obsoletes:  ccs-python < %{version}
 Provides:   ccs-python = %{version}
-%if 0%{?suse_version} > 1320 || 0%{?sle_version} > 120200
+%if 0%{?suse_version} > 1320
 BuildRequires:  python2-Cython
 %else
 BuildRequires:  python-Cython
@@ -50,8 +50,8 @@
 %if 0%{?suse_version} > 1320 || 0%{?sle_version} > 120200
 %package -n python2-compizconfig
 Summary:Python bindings for libraries for compizconfig-settings
-Group:  Development/Libraries/Python
 # python-compizconfig was last used in openSUSE Leap 14.2.
+Group:  Development/Libraries/Python
 Provides:   python-compizconfig = %{version}
 Obsoletes:  python-compizconfig < %{version}
 




commit qpid-cpp for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package qpid-cpp for openSUSE:Factory 
checked in at 2017-06-29 15:20:15

Comparing /work/SRC/openSUSE:Factory/qpid-cpp (Old)
 and  /work/SRC/openSUSE:Factory/.qpid-cpp.new (New)


Package is "qpid-cpp"

Thu Jun 29 15:20:15 2017 rev:7 rq:506946 version:1.36.0

Changes:

--- /work/SRC/openSUSE:Factory/qpid-cpp/qpid-cpp.changes2017-03-12 
20:02:58.186503674 +0100
+++ /work/SRC/openSUSE:Factory/.qpid-cpp.new/qpid-cpp.changes   2017-06-29 
15:20:55.431788385 +0200
@@ -1,0 +2,13 @@
+Wed Jun 28 11:10:28 UTC 2017 - m...@suse.com
+
+- Add patches to fix build failure
+  * 0001-QPID-7674-Broker-bulid-problem-with-GCC-7.patch
+- Fix build problem in broker.
+  * 0001-QPID-7714-Suppress-very-verbose-warnings.patch
+- Suppress warnings per gcc7.
+  * 0001-QPID-7629-Use-the-CMake-SYSTEM-keyword-when-includin.patch
+- Fix compile with newer nss and sasl.
+  * Suppress-maybe-uninitialized-warning.diff
+- Suppress -Werror=maybe-uninitialized if gcc version great than 7.
+
+---

New:

  0001-QPID-7629-Use-the-CMake-SYSTEM-keyword-when-includin.patch
  0001-QPID-7674-Broker-bulid-problem-with-GCC-7.patch
  0001-QPID-7714-Suppress-very-verbose-warnings.patch
  Suppress-maybe-uninitialized-warning.diff



Other differences:
--
++ qpid-cpp.spec ++
--- /var/tmp/diff_new_pack.aSpf9y/_old  2017-06-29 15:20:56.895581471 +0200
+++ /var/tmp/diff_new_pack.aSpf9y/_new  2017-06-29 15:20:56.899580906 +0200
@@ -31,6 +31,14 @@
 Patch3: qpid-cpp-initdir.patch
 Patch4: %{name}-0.30-cmake.patch
 Patch5: %{name}-aarch64.patch
+# PATCH-FIX-UPSTREAM 0001-QPID-7674-Broker-bulid-problem-with-GCC-7.patch
+Patch6: 0001-QPID-7674-Broker-bulid-problem-with-GCC-7.patch
+# PATCH-FIX-UPSTREAM 0001-QPID-7714-Suppress-very-verbose-warnings.patch
+Patch7: 0001-QPID-7714-Suppress-very-verbose-warnings.patch
+# PATCH-FIX-UPSTREAM 
0001-QPID-7629-Use-the-CMake-SYSTEM-keyword-when-includin.patch
+Patch8: 0001-QPID-7629-Use-the-CMake-SYSTEM-keyword-when-includin.patch
+# PATCH-FIX-OPENSUSE Suppress-maybe-uninitialized-warning.diff
+Patch9: Suppress-maybe-uninitialized-warning.diff
 %if 0%{?suse_version} > 1325
 BuildRequires:  libboost_program_options-devel
 BuildRequires:  libboost_system-devel
@@ -374,6 +382,10 @@
 %patch3 -p1 -b .initdir
 %patch4 -p1
 %patch5 -p2
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 %global perftests "qpid-perftest qpid-topic-listener qpid-topic-publisher 
qpid-latency-test qpid-client-test qpid-txtest"
 

++ 0001-QPID-7629-Use-the-CMake-SYSTEM-keyword-when-includin.patch ++
>From f04bc169f11c99be50399341905186b3405a3130 Mon Sep 17 00:00:00 2001
From: Justin Ross 
Date: Thu, 23 Mar 2017 05:53:51 -0700
Subject: [PATCH] QPID-7629: Use the CMake SYSTEM keyword when including
 headers for nss and sasl

---
 src/CMakeLists.txt | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7bc6f2c22..6ee474f29 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -371,7 +371,7 @@ if (BUILD_SASL)
   qpid/sys/cyrus/CyrusSecurityLayer.h
   qpid/sys/cyrus/CyrusSecurityLayer.cpp
  )
-  include_directories (${CYRUS_SASL_INCLUDE_DIR})
+  include_directories (SYSTEM ${CYRUS_SASL_INCLUDE_DIR})
   set(sasl_LIB ${CYRUS_SASL_LIBRARY})
   set(HAVE_SASL 1)
 else (BUILD_SASL)
@@ -451,7 +451,7 @@ if (BUILD_SSL)
   # Add include directories and link directories for NSS
   # unfortunately this doesn't get done automatically for
   # libraries detected by FindPkgConfig
-  include_directories(${ssl_INCLUDES})
+  include_directories(SYSTEM ${ssl_INCLUDES})
   link_directories(${ssl_LIBDIRS})
 endif (BUILD_SSL)
 
-- 
2.12.3

++ 0001-QPID-7674-Broker-bulid-problem-with-GCC-7.patch ++
>From 25e73e5a4c33783ff3e25f24c78a3608b7c32ea6 Mon Sep 17 00:00:00 2001
From: Alan Conway 
Date: Wed, 15 Feb 2017 18:29:12 -0500
Subject: [PATCH] QPID-7674: Broker bulid problem with GCC 7, add version check

Only add the -Wno-implicit-fallthrough flag for GCC >= 7.0.0
---
 CMakeLists.txt | 7 ++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Index: qpid-cpp-1.36.0/CMakeLists.txt
===
--- qpid-cpp-1.36.0.orig/CMakeLists.txt
+++ qpid-cpp-1.36.0/CMakeLists.txt
@@ -142,8 +142,12 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL GNU)
# -Wunreachable-code -Wpadded -Winline
# -Wshadow - warns about boost headers.
set (WARNING_FLAGS
-"-Werror -pedantic -Wall -Wextra -Wno-shadow -Wpointer-arith 
-Wcast-qual -Wcast-align -Wno-long-long 

commit xonotic for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package xonotic for openSUSE:Factory checked 
in at 2017-06-29 15:19:59

Comparing /work/SRC/openSUSE:Factory/xonotic (Old)
 and  /work/SRC/openSUSE:Factory/.xonotic.new (New)


Package is "xonotic"

Thu Jun 29 15:19:59 2017 rev:3 rq:506936 version:0.8.2

Changes:

--- /work/SRC/openSUSE:Factory/xonotic/xonotic.changes  2017-05-22 
10:47:52.877549923 +0200
+++ /work/SRC/openSUSE:Factory/.xonotic.new/xonotic.changes 2017-06-29 
15:20:07.278595068 +0200
@@ -1,0 +2,5 @@
+Tue Jun 27 23:51:05 UTC 2017 - luke.nukem.jo...@gmail.com
+
+- Add appdata xml to enable visibility in software installers
+
+---

New:

  xonotic.appdata.xml



Other differences:
--
++ xonotic.spec ++
--- /var/tmp/diff_new_pack.VdsNCA/_old  2017-06-29 15:20:28.495595936 +0200
+++ /var/tmp/diff_new_pack.VdsNCA/_new  2017-06-29 15:20:28.499595371 +0200
@@ -29,6 +29,7 @@
 Source2:xonotic.service
 Source3:xonotic.init
 Source4:%{name}.changes
+Source100:  xonotic.appdata.xml
 BuildRequires:  SDL2-devel
 BuildRequires:  alsa-devel
 BuildRequires:  d0_blind_id-devel
@@ -110,6 +111,7 @@
 %{buildroot}%{_bindir}/xonotic-dedicated
 install -D -m 644 misc/logos/%{name}_icon.svg \
 %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
+install -D -p -m 644 %{SOURCE100}  
%{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
 install -D -m 0644 %{SOURCE1} 
%{buildroot}%{_datadir}/applications/%{name}.desktop
 mkdir -p %{buildroot}%{_datadir}/xonotic
 cp -r key_0.d0pk server data %{buildroot}%{_datadir}/%{name}
@@ -174,6 +176,7 @@
 %defattr(-,root,root,-)
 %attr(755,root,root) %{_bindir}/%{name}-glx
 %attr(755,root,root) %{_bindir}/%{name}-sdl
+%{_datadir}/appdata/%{name}.appdata.xml
 %{_datadir}/applications/%{name}.desktop
 %dir %{_datadir}/icons/hicolor
 %dir %{_datadir}/icons/hicolor/scalable


++ xonotic.appdata.xml ++




  xonotic.desktop
  CC0-1.0
  

  Xonotic is a free and fast-paced first person shooter which combines
  addictive, arena-style gameplay with rapid movement and a wide array of
  weapons.


  Xonotic is easy to learn, but hard to master! Besides thrilling action for
  the casual player, the game also provides e-sport opportunities for those
  interested in its competitive aspects.
  From mapping contests and monthly quick cups to sponsored tournaments,
  Xonotic allows every e-sport enthusiast to participate in competitions
  hosted by its open-minded community.


  Features such as simple items, fully customizable configs and servers, a
  functioning anticheat system, the spectator mode, and the opportunity to
  watch and record games makes Xonotic attractive to competitive players.

  
  http://www.xonotic.org/
  
http://www.xonotic.org/m/uploads/2012/07/frontpage_005.jpg

http://www.xonotic.org/m/uploads/2012/07/frontpage_006.jpg

http://www.xonotic.org/m/uploads/2012/07/frontpage_007.jpg

http://www.xonotic.org/m/uploads/2012/07/frontpage_008.jpg

http://www.xonotic.org/m/uploads/2012/07/frontpage_003.jpg
  
  




commit mate-menu for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package mate-menu for openSUSE:Factory 
checked in at 2017-06-29 15:19:34

Comparing /work/SRC/openSUSE:Factory/mate-menu (Old)
 and  /work/SRC/openSUSE:Factory/.mate-menu.new (New)


Package is "mate-menu"

Thu Jun 29 15:19:34 2017 rev:16 rq:506924 version:17.10.6

Changes:

--- /work/SRC/openSUSE:Factory/mate-menu/mate-menu.changes  2017-06-20 
09:40:00.167389026 +0200
+++ /work/SRC/openSUSE:Factory/.mate-menu.new/mate-menu.changes 2017-06-29 
15:19:51.432834957 +0200
@@ -1,0 +2,8 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 17.10.6:
+  * places: Fix desktop button.
+  * Allow mate-menu to receive event reports from other windows.
+- Remove mate-menu-17.10.5-desktop-button.patch.
+
+---

Old:

  mate-menu-17.10.5-desktop-button.patch
  mate-menu_17.10.5.orig.tar.gz

New:

  mate-menu_17.10.6.orig.tar.gz



Other differences:
--
++ mate-menu.spec ++
--- /var/tmp/diff_new_pack.1ff8Va/_old  2017-06-29 15:19:56.796076832 +0200
+++ /var/tmp/diff_new_pack.1ff8Va/_new  2017-06-29 15:19:56.796076832 +0200
@@ -17,9 +17,9 @@
 
 
 %define _name   mate_menu
-%define _rev685cf9684b62
+%define _revf42342bc3b49
 Name:   mate-menu
-Version:17.10.5
+Version:17.10.6
 Release:0
 Summary:Advanced MATE menu
 License:GPL-2.0+
@@ -28,8 +28,6 @@
 Source: 
https://launchpad.net/ubuntu/+archive/primary/+files/%{name}_%{version}.orig.tar.gz
 # PATCH-FEATURE-OPENSUSE mate-menu-yast2-software.patch sor.ale...@meowr.ru -- 
Use YaST2 and GNOME PackageKit package managers.
 Patch0: %{name}-yast2-software.patch
-# PATCH-FIX-UPSTREAM mate-menu-17.10.5-desktop-button.patch 
sor.ale...@meowr.ru -- Fix desktop button in Places (commit 7f904dc).
-Patch1: %{name}-17.10.5-desktop-button.patch
 BuildRequires:  gobject-introspection-devel
 BuildRequires:  intltool
 BuildRequires:  python >= 2.7
@@ -68,7 +66,6 @@
 %prep
 %setup -q -n ubuntu-mate-%{name}-%{_rev}
 %patch0 -p1
-%patch1 -p1
 sed -i 's/su-to-root/xdg-su/g' %{_name}/execute.py
 
 %build

++ mate-menu_17.10.5.orig.tar.gz -> mate-menu_17.10.6.orig.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ubuntu-mate-mate-menu-685cf9684b62/lib/mate-menu.py 
new/ubuntu-mate-mate-menu-f42342bc3b49/lib/mate-menu.py
--- old/ubuntu-mate-mate-menu-685cf9684b62/lib/mate-menu.py 2017-06-13 
01:35:03.0 +0200
+++ new/ubuntu-mate-mate-menu-f42342bc3b49/lib/mate-menu.py 2017-06-24 
09:19:30.0 +0200
@@ -19,7 +19,7 @@
 # Free Software Foundation, Inc.,
 # 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
 
-__VERSION__='17.10.5'
+__VERSION__='17.10.6'
 
 import gc
 import gi
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/ubuntu-mate-mate-menu-685cf9684b62/mate_menu/keybinding.py 
new/ubuntu-mate-mate-menu-f42342bc3b49/mate_menu/keybinding.py
--- old/ubuntu-mate-mate-menu-685cf9684b62/mate_menu/keybinding.py  
2017-06-13 01:35:03.0 +0200
+++ new/ubuntu-mate-mate-menu-f42342bc3b49/mate_menu/keybinding.py  
2017-06-24 09:19:30.0 +0200
@@ -85,6 +85,15 @@
 self.keycode = 
self.keymap.get_entries_for_keyval(keyval)[1][0].keycode
 self.modifiers = int(modifiers)
 
+# Request to receive key press/release reports from other windows that 
may not be using modifiers
+catch = error.CatchError(error.BadWindow)
+if self.modifiers:
+self.window.change_attributes(onerror=catch, event_mask = 
X.KeyPressMask | X.KeyReleaseMask)
+else:
+self.window.change_attributes(onerror=catch, event_mask = 
X.NoEventMask)
+if catch.get_error():
+return False
+
 catch = error.CatchError(error.BadAccess)
 for ignored_mask in self.ignored_masks:
 mod = modifiers | ignored_mask
@@ -145,7 +154,9 @@
 GLib.idle_add(self.idle)
 self.display.allow_events(X.AsyncKeyboard, event.time)
 else:
-self.display.send_event(self.window, event, X.KeyPressMask 
| X.KeyReleaseMask, True)
+# If we're not using modifiers, send the event up in case 
another window is listening to it
+if not self.modifiers:
+self.display.send_event(self.window, event, 
X.KeyPressMask | X.KeyReleaseMask, True)
 self.display.allow_events(X.ReplayKeyboard, event.time)
 wait_for_release = False
 except AttributeError:
diff 

commit xviewer for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package xviewer for openSUSE:Factory checked 
in at 2017-06-29 15:19:05

Comparing /work/SRC/openSUSE:Factory/xviewer (Old)
 and  /work/SRC/openSUSE:Factory/.xviewer.new (New)


Package is "xviewer"

Thu Jun 29 15:19:05 2017 rev:10 rq:506922 version:1.4.3

Changes:

--- /work/SRC/openSUSE:Factory/xviewer/xviewer.changes  2017-05-27 
13:19:00.626030397 +0200
+++ /work/SRC/openSUSE:Factory/.xviewer.new/xviewer.changes 2017-06-29 
15:19:25.388516486 +0200
@@ -1,0 +2,6 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 1.4.3:
+  * Update translations.
+
+---

Old:

  xviewer-1.4.2.tar.gz

New:

  xviewer-1.4.3.tar.gz



Other differences:
--
++ xviewer.spec ++
--- /var/tmp/diff_new_pack.EMp5br/_old  2017-06-29 15:19:29.419946617 +0200
+++ /var/tmp/diff_new_pack.EMp5br/_new  2017-06-29 15:19:29.423946052 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   xviewer
-Version:1.4.2
+Version:1.4.3
 Release:0
 Summary:Fast and functional graphics viewer
 License:GPL-2.0+ and LGPL-2.1+

++ xviewer-1.4.2.tar.gz -> xviewer-1.4.3.tar.gz ++
 1935 lines of diff (skipped)




commit xreader for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package xreader for openSUSE:Factory checked 
in at 2017-06-29 15:18:58

Comparing /work/SRC/openSUSE:Factory/xreader (Old)
 and  /work/SRC/openSUSE:Factory/.xreader.new (New)


Package is "xreader"

Thu Jun 29 15:18:58 2017 rev:11 rq:506920 version:1.4.4

Changes:

--- /work/SRC/openSUSE:Factory/xreader/xreader.changes  2017-06-22 
10:40:59.688531708 +0200
+++ /work/SRC/openSUSE:Factory/.xreader.new/xreader.changes 2017-06-29 
15:19:01.895837342 +0200
@@ -1,0 +2,6 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 1.4.4:
+  * Update translations.
+
+---

Old:

  xreader-1.4.3.tar.gz

New:

  xreader-1.4.4.tar.gz



Other differences:
--
++ xreader.spec ++
--- /var/tmp/diff_new_pack.6YksQx/_old  2017-06-29 15:19:03.455616855 +0200
+++ /var/tmp/diff_new_pack.6YksQx/_new  2017-06-29 15:19:03.463615725 +0200
@@ -20,7 +20,7 @@
 %define typelib1 typelib-1_0-XreaderDocument-1_5_0
 %define typelib2 typelib-1_0-XreaderView-1_5_0
 Name:   xreader
-Version:1.4.3
+Version:1.4.4
 Release:0
 Summary:Document viewer for documents like PDF/PostScript
 License:GPL-2.0 and LGPL-2.0

++ xreader-1.4.3.tar.gz -> xreader-1.4.4.tar.gz ++
 4946 lines of diff (skipped)




commit xed for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package xed for openSUSE:Factory checked in 
at 2017-06-29 15:18:29

Comparing /work/SRC/openSUSE:Factory/xed (Old)
 and  /work/SRC/openSUSE:Factory/.xed.new (New)


Package is "xed"

Thu Jun 29 15:18:29 2017 rev:12 rq:506916 version:1.4.4

Changes:

--- /work/SRC/openSUSE:Factory/xed/xed.changes  2017-06-22 10:40:53.905347094 
+0200
+++ /work/SRC/openSUSE:Factory/.xed.new/xed.changes 2017-06-29 
15:18:44.234333930 +0200
@@ -1,0 +2,6 @@
+Wed Jun 28 19:20:44 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 1.4.4:
+  * Update translations.
+
+---

Old:

  xed-1.4.3.tar.gz

New:

  xed-1.4.4.tar.gz



Other differences:
--
++ xed.spec ++
--- /var/tmp/diff_new_pack.lcQUfp/_old  2017-06-29 15:18:45.430164891 +0200
+++ /var/tmp/diff_new_pack.lcQUfp/_new  2017-06-29 15:18:45.434164325 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   xed
-Version:1.4.3
+Version:1.4.4
 Release:0
 Summary:A text editor with highlighting
 License:GPL-2.0+

++ xed-1.4.3.tar.gz -> xed-1.4.4.tar.gz ++
 3549 lines of diff (skipped)




commit tei-roma for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package tei-roma for openSUSE:Factory 
checked in at 2017-06-29 15:18:45

Comparing /work/SRC/openSUSE:Factory/tei-roma (Old)
 and  /work/SRC/openSUSE:Factory/.tei-roma.new (New)


Package is "tei-roma"

Thu Jun 29 15:18:45 2017 rev:18 rq:506919 version:2.11

Changes:

--- /work/SRC/openSUSE:Factory/tei-roma/tei-roma.changes2011-09-23 
12:47:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.tei-roma.new/tei-roma.changes   2017-06-29 
15:18:55.604726637 +0200
@@ -1,0 +2,5 @@
+Sun Jun 25 01:56:09 UTC 2017 - bwiedem...@suse.com
+
+- Add tei-roma-2.11-fix-race.patch to fix race condition during build
+
+---

New:

  tei-roma-2.11-fix-race.patch



Other differences:
--
++ tei-roma.spec ++
--- /var/tmp/diff_new_pack.v4j7Xy/_old  2017-06-29 15:18:58.196360291 +0200
+++ /var/tmp/diff_new_pack.v4j7Xy/_new  2017-06-29 15:18:58.200359725 +0200
@@ -26,6 +26,8 @@
 Group:  Productivity/Publishing/XML
 Source0:
http://ftp1.sourceforge.net/sourceforge/tei/tei-roma-%{version}.zip
 Patch:  roma-dir.diff
+# PATCH-FIX-OPENSUSE tei-roma-2.11-fix-race.patch bmwiedemann@opensuse
+Patch1: tei-roma-2.11-fix-race.patch
 Url:http://www.tei-c.org/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
@@ -52,6 +54,7 @@
 %setup -q
 # unzip -q -a %{SOURCE0}
 %patch -p 1
+%patch1 -p1
 /bin/chmod -Rf a+rX,g-w,o-w .
 
 %build

++ tei-roma-2.11-fix-race.patch ++
From: Bernhard M. Wiedemann 

PATCH-FIX-OPENSUSE
since upstream does not include this anymore
in latest https://github.com/TEIC/TEI.git

In our .spec %install section we call
make release
which copies all files listed into a directory called 'release'

We must not include 'release' in this list
because that creates non-determinism at build time due to
filesystem ordering and races between reader and writer processes

Index: tei-roma-2.11/Makefile
===
--- tei-roma-2.11.orig/Makefile
+++ tei-roma-2.11/Makefile
@@ -6,7 +6,6 @@ FILES=ChangeLog \
notam \
parser \
progressbar \
-   release \
resource \
roma \
roma.sh \




commit varnish for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package varnish for openSUSE:Factory checked 
in at 2017-06-29 15:14:45

Comparing /work/SRC/openSUSE:Factory/varnish (Old)
 and  /work/SRC/openSUSE:Factory/.varnish.new (New)


Package is "varnish"

Thu Jun 29 15:14:45 2017 rev:22 rq:506720 version:5.1.2

Changes:

--- /work/SRC/openSUSE:Factory/varnish/varnish.changes  2017-05-17 
10:55:43.875203740 +0200
+++ /work/SRC/openSUSE:Factory/.varnish.new/varnish.changes 2017-06-29 
15:14:56.818481735 +0200
@@ -1,0 +2,80 @@
+Fri Jun 23 19:42:07 UTC 2017 - antoine.belv...@opensuse.org
+
+- Update to version 5.1.2:
+  * Fix an endless loop in Backend Polling (#2295)
+  * Fix a Chunked bug in tight workspaces (#2207, #2275)
+  * Fix a bug relating to req.body when on waitinglist (#2266)
+  * Handle EPIPE on broken TCP connections (#2267)
+  * Work around the x86 arch's turbo-double FP format in parameter
+setup code. (#1875)
+  * Fix race related to backend probe with proxy header (#2278)
+  * Keep VCL temperature consistent between mgt/worker also when
+worker protests.
+  * A lot of HTTP/2 fixes.
+- Changes introduced by version 5.1.1:
+  * Fix bug introduced by stubborn old bugger right before release
+5.1.0 was cut.
+- Changes introduced by version 5.1.0:
+  * Added varnishd command-line options -I, -x and -?, and
+tightened restrictions on permitted combinations of options.
+  * More progress on support for HTTP/2.
+  * Add ``return(fail)`` to almost all VCL subroutines.
+  * Restored the old hit-for-pass, invoked with
+``return(pass(DURATION))`` from
+``vcl_backend_response``. hit-for-miss remains the default.
+Added the cache_hitmiss stat, and cache_hitpass only counts the
+new/old hit-for-pass cases. Restored HitPass to the Varnish
+log, and added HitMiss. Added the HFP prefix to TTL log entries
+to log a hit-for-pass duration.
+  * Rolled back the fix for #1206. Client delivery decides solely
+whether to send a 304 client response, based on client request
+and response headers.
+  * Added vtest.sh.
+  * Added vxid as a lefthand side for VSL queries.
+  * Added the setenv and write_body commands for Varnish test cases
+(VTCs). err_shell is deprecated. Also added the operators
+-cliexpect, -match and -hdrlen, and -reason replaces -msg.
+Added the ${bad_backend} macro.
+  * varnishtest can be stopped with the TERM, INT and KILL signals,
+but not with HUP.
+  * The fallback director has now an extra, optional parameter to
+keep using the current backend until it falls sick.
+  * VMOD shared libraries are now copied to the workdir, to avoid
+problems when VMODs are updated via packaging systems.
+  * Bump the VRT version to 6.0.
+  * Export more symbols from libvarnishapi.so.
+  * The size of the VSL log is limited to 4G-1b, placing upper
+bounds on the -l option and the vsl_space and vsm_space
+parameters.
+  * Added parameters clock_step, thread_pool_reserve and
+ban_cutoff.
+  * Parameters vcl_dir and vmod_dir are deprecated, use vcl_path
+and vmod_path instead.
+  * All parameters are defined, even on platforms that don't
+support them. An unsupported parameter is documented as such in
+param.show. Setting such a parameter is not an error, but has
+no effect.
+  * Clarified the interpretations of the + and - operators in VCL
+with operands of the various data types.
+  * DURATION types may be used in boolean contexts.
+  * INT, DURATION and REAL values can now be negative.
+  * Response codes 1000 or greater may now be set in VCL
+internally. resp.status is delivered modulo 1000 in client
+responses.
+  * IP addresses can be compared for equality in VCL.
+  * Introduce the STEVEDORE data type, and the objects
+storage.SNAME in VCL. Added req.storage and beresp.storage;
+beresp.storage_hint is deprecated.
+  * Retired the umem stevedore.
+  * req.ttl is deprecated.
+  * Added std.getenv() and std.late_100_continue().
+  * The fetch_failed stat is incremented for any kind of fetch
+failure.
+  * Added the stats n_test_gunzip and
+bans_lurker_obj_killed_cutoff.
+  * Clarified the meanings of the %r, %{X}i and %{X}o formatters in
+varnishncsa.
+- Add varnish-5.1.2-add-fallthrough-comments.patch to fix build
+  with GCC 7 (boo#1041259).
+
+---

Old:

  varnish-5.0.0.tar.gz

New:

  varnish-5.1.2-add-fallthrough-comments.patch
  varnish-5.1.2.tar.gz



Other differences:
--
++ varnish.spec ++
--- /var/tmp/diff_new_pack.LEtoVF/_old  2017-06-29 15:14:58.406257279 +0200
+++ /var/tmp/diff_new_pack.LEtoVF/_new  2017-06-29 15:14:58.410256715 +0200
@@ -21,7 +21,7 

commit perl-Minion for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package perl-Minion for openSUSE:Factory 
checked in at 2017-06-29 15:14:22

Comparing /work/SRC/openSUSE:Factory/perl-Minion (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Minion.new (New)


Package is "perl-Minion"

Thu Jun 29 15:14:22 2017 rev:26 rq:506348 version:7.01

Changes:

--- /work/SRC/openSUSE:Factory/perl-Minion/perl-Minion.changes  2017-06-09 
15:57:57.698975480 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Minion.new/perl-Minion.changes 
2017-06-29 15:14:37.925152593 +0200
@@ -1,0 +2,27 @@
+Mon Jun 26 05:46:05 UTC 2017 - co...@suse.com
+
+- updated to 7.01
+   see /usr/share/doc/packages/perl-Minion/Changes
+
+  7.01  2017-06-25
+- Added note methods to Minion::Job and Minion::Backend::Pg.
+- Added notes option to enqueue methods in Minion and Minion::Backend::Pg.
+- Added notes field to info method in Minion::Job and job_info method in
+  Minion::Backend::Pg.
+- Improved performance of stats and lock methods in Minion::Backend::Pg 
with a
+  new index and other optimizations. (depesz)
+- Improved benchmark script to be more consistent. (depesz)
+
+---
+Tue Jun 20 05:59:26 UTC 2017 - co...@suse.com
+
+- updated to 7.0
+   see /usr/share/doc/packages/perl-Minion/Changes
+
+  7.0  2017-06-18
+- Added support for rate limiting and unique jobs.
+- Added lock and unlock methods to Minion and Minion::Backend::Pg.
+- Improved performance of Minion::Backend::Pg significantly with a new 
index
+  and other optimizations.
+
+---

Old:

  Minion-6.06.tar.gz

New:

  Minion-7.01.tar.gz



Other differences:
--
++ perl-Minion.spec ++
--- /var/tmp/diff_new_pack.Fub7c0/_old  2017-06-29 15:14:41.652625657 +0200
+++ /var/tmp/diff_new_pack.Fub7c0/_new  2017-06-29 15:14:41.652625657 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Minion
-Version:6.06
+Version:7.01
 Release:0
 %define cpan_name Minion
 Summary:Job queue
@@ -37,10 +37,10 @@
 %description
 Minion is a job queue for the at http://mojolicious.org real-time web
 framework, with support for multiple named queues, priorities, delayed
-jobs, job dependencies, job results, retries with backoff, statistics,
-distributed workers, parallel processing, autoscaling, remote control,
-resource leak protection and multiple backends (such as at
-http://www.postgresql.org).
+jobs, job dependencies, job progress, job results, retries with backoff,
+rate limiting, unique jobs, statistics, distributed workers, parallel
+processing, autoscaling, remote control, resource leak protection and
+multiple backends (such as at http://www.postgresql.org).
 
 Job queues allow you to process time and/or computationally intensive tasks
 in background processes, outside of the request/response lifecycle. Among

++ Minion-6.06.tar.gz -> Minion-7.01.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Minion-6.06/Changes new/Minion-7.01/Changes
--- old/Minion-6.06/Changes 2017-06-03 20:01:21.0 +0200
+++ new/Minion-7.01/Changes 2017-06-25 17:50:48.0 +0200
@@ -1,4 +1,19 @@
 
+7.01  2017-06-25
+  - Added note methods to Minion::Job and Minion::Backend::Pg.
+  - Added notes option to enqueue methods in Minion and Minion::Backend::Pg.
+  - Added notes field to info method in Minion::Job and job_info method in
+Minion::Backend::Pg.
+  - Improved performance of stats and lock methods in Minion::Backend::Pg with 
a
+new index and other optimizations. (depesz)
+  - Improved benchmark script to be more consistent. (depesz)
+
+7.0  2017-06-18
+  - Added support for rate limiting and unique jobs.
+  - Added lock and unlock methods to Minion and Minion::Backend::Pg.
+  - Improved performance of Minion::Backend::Pg significantly with a new index
+and other optimizations.
+
 6.06  2017-06-03
   - Added an example application to demonstrate how to integrate background 
jobs
 into well-structured Mojolicious applications.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Minion-6.06/MANIFEST new/Minion-7.01/MANIFEST
--- old/Minion-6.06/MANIFEST2017-06-06 00:14:54.0 +0200
+++ new/Minion-7.01/MANIFEST2017-06-25 20:57:36.0 +0200
@@ -24,6 +24,7 @@
 MANIFEST.bak
 MANIFEST.SKIP
 README.md
+t/backend.t
 t/commands.t
 t/pg.t
 t/pg_lite_app.t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Minion-6.06/META.json new/Minion-7.01/META.json
--- old/Minion-6.06/META.json   2017-06-06 

commit aqbanking for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package aqbanking for openSUSE:Factory 
checked in at 2017-06-29 15:12:50

Comparing /work/SRC/openSUSE:Factory/aqbanking (Old)
 and  /work/SRC/openSUSE:Factory/.aqbanking.new (New)


Package is "aqbanking"

Thu Jun 29 15:12:50 2017 rev:71 rq:505635 version:5.7.6beta

Changes:

--- /work/SRC/openSUSE:Factory/aqbanking/aqbanking.changes  2016-10-18 
10:43:11.0 +0200
+++ /work/SRC/openSUSE:Factory/.aqbanking.new/aqbanking.changes 2017-06-29 
15:13:27.095165581 +0200
@@ -1,0 +2,15 @@
+Tue May 30 21:39:09 UTC 2017 - nico.kru...@gmail.com
+
+- enable paypal back-end
+- enable EBICS back-end (for openSUSE 42.3+)
+- Update to 5.7.6beta
+  + finally fix unclean TLS connection shutdown by HBCI servers
+  + fix passing user flags to the http module
+- Update to 5.7.5beta
+  + support for ZKA cards (by Holger Magnussen)
+  + updated bank information for German banks
+  + some bugfixes
+  + adapted and re-activated the paypal plugin (by Holger Magnussen)
+  + HBCI: allow changing the server address in RDH and DDV mode
+
+---

Old:

  aqbanking-5.7.4beta.tar.gz

New:

  aqbanking-5.7.6beta.tar.gz



Other differences:
--
++ aqbanking.spec ++
--- /var/tmp/diff_new_pack.FAIRLE/_old  2017-06-29 15:13:34.330142790 +0200
+++ /var/tmp/diff_new_pack.FAIRLE/_new  2017-06-29 15:13:34.330142790 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package aqbanking
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,6 +17,13 @@
 
 
 %define  build_ofx 1
+# disable EBICS plugin for older openSUSE versions due to problems linking
+# to xmlsec1-gcrypt:
+%if 0%{?suse_version} > 1320 || 0%{?leap_version} >= 420300
+%define  build_ebics 1
+%else
+%define  build_ebics 0
+%endif
 %define  aq_plugindir   %{_libdir}/aqbanking/plugins/35
 %define  fronts_libdir  %{aq_plugindir}/frontends
 %define  imex_plugindir %{aq_plugindir}/imexporters
@@ -26,7 +33,7 @@
 %define  q4b_cfgmoddir  %{fronts_libdir}/q4banking/cfgmodules
 
 Name:   aqbanking
-Version:5.7.4beta
+Version:5.7.6beta
 Release:0
 Summary:Library for Online Banking Functions and Financial Data Import 
and Export
 License:GPL-2.0 or GPL-3.0
@@ -52,6 +59,10 @@
 %if %build_ofx
 BuildRequires:  libofx-devel
 %endif
+%if %build_ebics
+BuildRequires:  libltdl-devel
+BuildRequires:  xmlsec1-gnutls-devel
+%endif
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
@@ -72,6 +83,10 @@
 %if %build_ofx
 Requires:   libofx-devel
 %endif
+%if %build_ebics
+Requires:   libltdl-devel
+Requires:   xmlsec1-gnutls-devel
+%endif
 
 %description devel
 AqBanking is a generic OnlineBanking interface. It allows multiple
@@ -114,16 +129,43 @@
 access.
 
 %endif
+
+%if %build_ebics
+
+%package ebics
+Summary:Library for Online Banking Functions and Financial Data 
Import/Export
+License:GPL-2.0+
+Group:  Productivity/Office/Finance
+Requires:   %{name} = %{version}
+
+%description ebics
+AqBanking is a generic OnlineBanking interface. It allows multiple
+backends (currently HBCI) and multiple frontends  (e.g. KDE, GNOME,
+console) to be used.
+
+%package -n libaqebics0
+Summary:Connector between Aqbanking and EBICS
+License:GPL-2.0 or GPL-3.0
+Group:  Development/Libraries/C and C++
+
+%description -n libaqebics0
+Conncetor between Aqbanking and EBICS. Necessary for EBICS access.
+
+%endif
 %lang_package
 
 %prep
 %setup -q
 
 %build
-BACKEND_LIST="aqhbci aqnone"
+BACKEND_LIST="aqhbci aqnone aqpaypal"
 %if %build_ofx
 BACKEND_LIST="$BACKEND_LIST aqofxconnect"
 %endif
+%if %build_ebics
+BACKEND_LIST="$BACKEND_LIST aqebics"
+%endif
+
 # quick fix for $CPP being unset and configure failing to handle include dirs 
properly
 CPP=`which cpp`
 export CPP
@@ -138,10 +180,18 @@
 
 %install
 %makeinstall
+mv %{buildroot}%{_includedir}/aqpaypal %{buildroot}%{_includedir}/%{name}5/
+%if %build_ebics
+mv %{buildroot}%{_includedir}/aqebics %{buildroot}%{_includedir}/%{name}5/
+%endif
 find %{buildroot} -type f -name "*.la" -delete -print
 # Remove files that we'll have elsewhere
 rm %{buildroot}%{_datadir}/doc/%{name}/{AUTHORS,COPYING,ChangeLog,README}
 mv %{buildroot}%{_datadir}/doc/aqhbci/aqhbci-tool/README README.aqhbci
+mv %{buildroot}%{_datadir}/doc/aqpaypal/aqpaypal-tool/README README.aqpaypal
+%if %build_ebics
+mv 

commit samba for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package samba for openSUSE:Factory checked 
in at 2017-06-29 15:12:09

Comparing /work/SRC/openSUSE:Factory/samba (Old)
 and  /work/SRC/openSUSE:Factory/.samba.new (New)


Package is "samba"

Thu Jun 29 15:12:09 2017 rev:216 rq:505266 version:4.6.5+git.27.6afd48b1083

Changes:

--- /work/SRC/openSUSE:Factory/samba/samba.changes  2017-06-16 
10:52:51.755722555 +0200
+++ /work/SRC/openSUSE:Factory/.samba.new/samba.changes 2017-06-29 
15:12:38.546028894 +0200
@@ -37,0 +38,6 @@
+Wed Jun  7 13:17:24 UTC 2017 - nopo...@suse.com
+
+- s3: libsmb: Fix error where short name length was read as 2
+  bytes, should be 1; (bso#11822); (bsc#1042419).
+
+---



Other differences:
--



commit sudo for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package sudo for openSUSE:Factory checked in 
at 2017-06-29 15:08:51

Comparing /work/SRC/openSUSE:Factory/sudo (Old)
 and  /work/SRC/openSUSE:Factory/.sudo.new (New)


Package is "sudo"

Thu Jun 29 15:08:51 2017 rev:88 rq:505125 version:1.8.20p2

Changes:

--- /work/SRC/openSUSE:Factory/sudo/sudo.changes2017-06-04 
01:49:11.146421860 +0200
+++ /work/SRC/openSUSE:Factory/.sudo.new/sudo.changes   2017-06-29 
15:09:48.586056469 +0200
@@ -13,0 +14 @@
+   [bsc#1042146], [CVE-2017-1000368]



Other differences:
--





commit daps for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package daps for openSUSE:Factory checked in 
at 2017-06-29 15:07:52

Comparing /work/SRC/openSUSE:Factory/daps (Old)
 and  /work/SRC/openSUSE:Factory/.daps.new (New)


Package is "daps"

Thu Jun 29 15:07:52 2017 rev:40 rq:505092 version:2.4.0

Changes:

--- /work/SRC/openSUSE:Factory/daps/daps.changes2017-06-15 
11:25:59.373409332 +0200
+++ /work/SRC/openSUSE:Factory/.daps.new/daps.changes   2017-06-29 
15:08:38.331988706 +0200
@@ -1,0 +2,6 @@
+Tue Jun 20 13:51:14 UTC 2017 - fsunderme...@opensuse.org
+
+- another try to get the Changelogs for openSUSE and SLES aligned
+  (no code changes)
+
+---
@@ -325,0 +332,9 @@
+
+---
+Wed Aug 26 16:20:24 CEST 2015 - lchiqui...@suse.de
+
+- Do not print warning about deprecated --xsltparam option to
+  standard output.  At least some sub-commands (e.g, package-html)
+  haven't been moved to the new method of passing parameters to
+  the xslt processor, so it is incorrect to say it is deprecated.
+  (bsc#943321)



Other differences:
--



commit python-pyroute2 for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package python-pyroute2 for openSUSE:Factory 
checked in at 2017-06-29 15:06:11

Comparing /work/SRC/openSUSE:Factory/python-pyroute2 (Old)
 and  /work/SRC/openSUSE:Factory/.python-pyroute2.new (New)


Package is "python-pyroute2"

Thu Jun 29 15:06:11 2017 rev:4 rq:505039 version:0.4.15

Changes:

--- /work/SRC/openSUSE:Factory/python-pyroute2/python-pyroute2.changes  
2017-01-25 23:25:38.369932889 +0100
+++ /work/SRC/openSUSE:Factory/.python-pyroute2.new/python-pyroute2.changes 
2017-06-29 15:06:33.825591335 +0200
@@ -1,0 +2,29 @@
+Tue Jun 13 09:49:31 UTC 2017 - dmuel...@suse.com
+
+- update to 0.4.15:
+   * req: #365 -- full and short nla notation fixed, critical
+   * iproute: #364 -- new method, `brport()`
+   * ipdb: -- support bridge port options
+   * event: new genl protocols set: VFS_DQUOT, acpi_event, thermal_event
+   * ipdb: #310 -- fixed priority change on routes
+   * ipdb: #349 -- fix setting ifalias on interfaces
+   * ipdb: #353 -- mitigate kernel oops during bridge creation
+   * ipdb: #354 -- allow to explicitly choose plugins to load
+   * ipdb: #359 -- provide read-only context managers
+   * rtnl: #336 -- vlan flags support
+   * rtnl: #352 -- support interface type plugins
+   * tc: #344 -- mirred action
+   * tc: #346 -- connmark action
+   * netlink: #358 -- memory optimization
+   * config: #360 -- generic asyncio config
+   * iproute: #362 -- allow to change or replace a qdisc
+   * ipset: full rework of the IPSET_ATTR_DATA and IPSET_ATTR_ADT
+ ACHTUNG: this commit may break API compatibility
+   * ipset: hash:mac support
+   * ipset: list:set support
+   * ipdb: throw EEXIST when creates VLAN/VXLAN devs with same ID, but
+ under different names
+   * tests: #329 -- include unit tests into the bundle
+* legal: E/// logo removed
+
+---

Old:

  pyroute2-0.4.12.tar.gz

New:

  pyroute2-0.4.15.tar.gz



Other differences:
--
++ python-pyroute2.spec ++
--- /var/tmp/diff_new_pack.O6UZPk/_old  2017-06-29 15:06:37.865020234 +0200
+++ /var/tmp/diff_new_pack.O6UZPk/_new  2017-06-29 15:06:37.869019669 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python-pyroute2
-Version:0.4.12
+Version:0.4.15
 Release:0
 Summary:Python Netlink library
 License:GPL-2.0+ or Apache-2.0

++ pyroute2-0.4.12.tar.gz -> pyroute2-0.4.15.tar.gz ++
 36757 lines of diff (skipped)




commit perl-MooseX-Types-LoadableClass for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package perl-MooseX-Types-LoadableClass for 
openSUSE:Factory checked in at 2017-06-29 15:06:00

Comparing /work/SRC/openSUSE:Factory/perl-MooseX-Types-LoadableClass (Old)
 and  /work/SRC/openSUSE:Factory/.perl-MooseX-Types-LoadableClass.new (New)


Package is "perl-MooseX-Types-LoadableClass"

Thu Jun 29 15:06:00 2017 rev:12 rq:504920 version:0.015

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-MooseX-Types-LoadableClass/perl-MooseX-Types-LoadableClass.changes
  2015-08-27 08:56:22.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-MooseX-Types-LoadableClass.new/perl-MooseX-Types-LoadableClass.changes
 2017-06-29 15:06:09.241067142 +0200
@@ -1,0 +2,10 @@
+Sat Jun 17 05:56:42 UTC 2017 - co...@suse.com
+
+- updated to 0.015
+   see /usr/share/doc/packages/perl-MooseX-Types-LoadableClass/Changes
+
+  0.015 2017-06-16 23:37:46Z
+- do not create an extra, unused ClassName type (this fixes a problem
+  observed with MooseX::Types and Sub::Defer; see RT#119534)
+
+---

Old:

  MooseX-Types-LoadableClass-0.014.tar.gz

New:

  MooseX-Types-LoadableClass-0.015.tar.gz



Other differences:
--
++ perl-MooseX-Types-LoadableClass.spec ++
--- /var/tmp/diff_new_pack.vZKCoO/_old  2017-06-29 15:06:11.152796857 +0200
+++ /var/tmp/diff_new_pack.vZKCoO/_new  2017-06-29 15:06:11.152796857 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-MooseX-Types-LoadableClass
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,21 +17,22 @@
 
 
 Name:   perl-MooseX-Types-LoadableClass
-Version:0.014
+Version:0.015
 Release:0
 %define cpan_name MooseX-Types-LoadableClass
 Summary:ClassName type constraint with coercion to load the class
 License:Artistic-1.0 or GPL-1.0+
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/MooseX-Types-LoadableClass/
-Source0:
http://www.cpan.org/authors/id/E/ET/ETHER/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/E/ET/ETHER/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl
 BuildRequires:  perl-macros
 BuildRequires:  perl(Class::Load)
-BuildRequires:  perl(Module::Build::Tiny) >= 0.007
+BuildRequires:  perl(Module::Build::Tiny) >= 0.034
+BuildRequires:  perl(Module::Metadata)
 BuildRequires:  perl(Module::Runtime)
 BuildRequires:  perl(Moose)
 BuildRequires:  perl(Moose::Role)

++ MooseX-Types-LoadableClass-0.014.tar.gz -> 
MooseX-Types-LoadableClass-0.015.tar.gz ++
 3259 lines of diff (skipped)




commit perl-Perl-Critic-Pulp for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package perl-Perl-Critic-Pulp for 
openSUSE:Factory checked in at 2017-06-29 15:05:25

Comparing /work/SRC/openSUSE:Factory/perl-Perl-Critic-Pulp (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Perl-Critic-Pulp.new (New)


Package is "perl-Perl-Critic-Pulp"

Thu Jun 29 15:05:25 2017 rev:3 rq:504918 version:94

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Perl-Critic-Pulp/perl-Perl-Critic-Pulp.changes  
2017-05-16 14:33:50.706473684 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Perl-Critic-Pulp.new/perl-Perl-Critic-Pulp.changes
 2017-06-29 15:05:57.122780456 +0200
@@ -1,0 +2,9 @@
+Sun Jun 18 06:07:27 UTC 2017 - co...@suse.com
+
+- updated to 94
+   see /usr/share/doc/packages/perl-Perl-Critic-Pulp/Changes
+
+  Version 94, June 2017
+  - ProhibitUnknownBackslash \N also Perl 5.16
+
+---

Old:

  Perl-Critic-Pulp-93.tar.gz

New:

  Perl-Critic-Pulp-94.tar.gz



Other differences:
--
++ perl-Perl-Critic-Pulp.spec ++
--- /var/tmp/diff_new_pack.goFhiK/_old  2017-06-29 15:05:59.274476243 +0200
+++ /var/tmp/diff_new_pack.goFhiK/_new  2017-06-29 15:05:59.274476243 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Perl-Critic-Pulp
-Version:93
+Version:94
 Release:0
 #Upstream: GPL-1.0+
 %define cpan_name Perl-Critic-Pulp

++ Perl-Critic-Pulp-93.tar.gz -> Perl-Critic-Pulp-94.tar.gz ++
 2658 lines of diff (skipped)




commit perl-Mojolicious-Plugin-AssetPack for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package perl-Mojolicious-Plugin-AssetPack 
for openSUSE:Factory checked in at 2017-06-29 15:04:36

Comparing /work/SRC/openSUSE:Factory/perl-Mojolicious-Plugin-AssetPack (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Mojolicious-Plugin-AssetPack.new 
(New)


Package is "perl-Mojolicious-Plugin-AssetPack"

Thu Jun 29 15:04:36 2017 rev:33 rq:504916 version:1.45

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Mojolicious-Plugin-AssetPack/perl-Mojolicious-Plugin-AssetPack.changes
  2017-05-27 13:19:45.391701726 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Mojolicious-Plugin-AssetPack.new/perl-Mojolicious-Plugin-AssetPack.changes
 2017-06-29 15:05:11.481233422 +0200
@@ -1,0 +2,18 @@
+Tue Jun 20 06:01:05 UTC 2017 - co...@suse.com
+
+- updated to 1.45
+   see /usr/share/doc/packages/perl-Mojolicious-Plugin-AssetPack/Changes
+
+  1.45 2017-06-19T23:49:30+0200
+   - Add Developing guide
+   - Removed deprecated method end_range() from AssetPack::Asset
+   - Removed deprecated method get_chunk() from AssetPack::Asset
+   - Removed deprecated method is_range() from AssetPack::Asset
+   - Removed deprecated method mtime() from AssetPack::Asset
+   - Removed deprecated method start_range() from AssetPack::Asset
+   - Removed deprecated method tag_helper() from AssetPack::Asset
+   - Removed MOJO_ASSETPACK_CLEANUP (only used in test suite)
+   - Can prevent AssetPack::Store from writing assetpack.db while developing
+ with MOJO_ASSETPACK_LAZY=1 (EXPERIMENTAL)
+
+---

Old:

  Mojolicious-Plugin-AssetPack-1.44.tar.gz

New:

  Mojolicious-Plugin-AssetPack-1.45.tar.gz



Other differences:
--
++ perl-Mojolicious-Plugin-AssetPack.spec ++
--- /var/tmp/diff_new_pack.X9EIwD/_old  2017-06-29 15:05:16.640503982 +0200
+++ /var/tmp/diff_new_pack.X9EIwD/_new  2017-06-29 15:05:16.640503982 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Mojolicious-Plugin-AssetPack
-Version:1.44
+Version:1.45
 Release:0
 %define cpan_name Mojolicious-Plugin-AssetPack
 Summary:Compress and convert css, less, sass, javascript and 
coffeescript files

++ Mojolicious-Plugin-AssetPack-1.44.tar.gz -> 
Mojolicious-Plugin-AssetPack-1.45.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-Plugin-AssetPack-1.44/Changes 
new/Mojolicious-Plugin-AssetPack-1.45/Changes
--- old/Mojolicious-Plugin-AssetPack-1.44/Changes   2017-05-21 
23:02:46.0 +0200
+++ new/Mojolicious-Plugin-AssetPack-1.45/Changes   2017-06-19 
23:49:30.0 +0200
@@ -1,5 +1,17 @@
 Revision history for perl distribution Mojolicious-Plugin-AssetPack
 
+1.45 2017-06-19T23:49:30+0200
+ - Add Developing guide
+ - Removed deprecated method end_range() from AssetPack::Asset
+ - Removed deprecated method get_chunk() from AssetPack::Asset
+ - Removed deprecated method is_range() from AssetPack::Asset
+ - Removed deprecated method mtime() from AssetPack::Asset
+ - Removed deprecated method start_range() from AssetPack::Asset
+ - Removed deprecated method tag_helper() from AssetPack::Asset
+ - Removed MOJO_ASSETPACK_CLEANUP (only used in test suite)
+ - Can prevent AssetPack::Store from writing assetpack.db while developing
+   with MOJO_ASSETPACK_LAZY=1 (EXPERIMENTAL)
+
 1.44 2017-05-21T23:02:46+0200
  - Improved documentation #125
Contributor: William Lindley
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-Plugin-AssetPack-1.44/MANIFEST 
new/Mojolicious-Plugin-AssetPack-1.45/MANIFEST
--- old/Mojolicious-Plugin-AssetPack-1.44/MANIFEST  2017-05-21 
23:02:47.0 +0200
+++ new/Mojolicious-Plugin-AssetPack-1.45/MANIFEST  2017-06-19 
23:49:31.0 +0200
@@ -9,6 +9,7 @@
 lib/Mojolicious/Plugin/AssetPack/Asset.pm
 lib/Mojolicious/Plugin/AssetPack/Asset/Null.pm
 lib/Mojolicious/Plugin/AssetPack/Guides/Cookbook.pod
+lib/Mojolicious/Plugin/AssetPack/Guides/Developing.pod
 lib/Mojolicious/Plugin/AssetPack/Guides/Tutorial.pod
 lib/Mojolicious/Plugin/AssetPack/Pipe.pm
 lib/Mojolicious/Plugin/AssetPack/Pipe/CoffeeScript.pm
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-Plugin-AssetPack-1.44/META.json 
new/Mojolicious-Plugin-AssetPack-1.45/META.json
--- old/Mojolicious-Plugin-AssetPack-1.44/META.json 2017-05-21 
23:02:47.0 +0200
+++ new/Mojolicious-Plugin-AssetPack-1.45/META.json 2017-06-19 
23:49:31.0 +0200
@@ -48,6 +48,6 @@
  "url" : 
"https://github.com/jhthorsen/mojolicious-plugin-assetpack.git;
   }
},
-   "version" : "1.44",
+   "version" 

commit tpm-quote-tools for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package tpm-quote-tools for openSUSE:Factory 
checked in at 2017-06-29 15:03:36

Comparing /work/SRC/openSUSE:Factory/tpm-quote-tools (Old)
 and  /work/SRC/openSUSE:Factory/.tpm-quote-tools.new (New)


Package is "tpm-quote-tools"

Thu Jun 29 15:03:36 2017 rev:1 rq:504822 version:1.0.3

Changes:

New Changes file:

--- /dev/null   2017-06-22 07:57:20.067658250 +0200
+++ /work/SRC/openSUSE:Factory/.tpm-quote-tools.new/tpm-quote-tools.changes 
2017-06-29 15:04:27.107507210 +0200
@@ -0,0 +1,9 @@
+---
+Mon Jun 19 15:39:52 UTC 2017 - matthias.gerst...@suse.com
+
+- fix license specification, it's BSD-3-Clause, not BSD
+
+---
+Thu May 18 13:38:18 UTC 2017 - matthias.gerst...@suse.com
+
+- initial package, version 1.0.3

New:

  tpm-quote-tools-1.0.3.tar.gz
  tpm-quote-tools.changes
  tpm-quote-tools.spec



Other differences:
--
++ tpm-quote-tools.spec ++
#
# spec file for package tpm-tools
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:   tpm-quote-tools
Version:1.0.3
Release:0
Summary:Trusted Platform Module (TPM) remote attestation tools
License:BSD-3-Clause
Group:  Productivity/Security
Url:https://sourceforge.net/projects/tpmquotetools
Source0:
https://downloads.sourceforge.net/project/tpmquotetools/%{version}/tpm-quote-tools-%{version}.tar.gz
BuildRequires:  autoconf
BuildRequires:  automake
BuildRequires:  libtool
BuildRequires:  trousers-devel
BuildRoot:  %{_tmppath}/%{name}-%{version}-build

%description
Trusted Computing is a set of specifications published by the Trusted
Computing Group (TCG). The Trusted Platform Module (TPM) is the
hardware component for Trusted Computing. The tpm-quote-tools package
provides additional tools that employ the TPM quote command to facilitate
remote attestation. These tools are based on the trousers TPM 1.2 stack.

%prep
%setup -q

%build
autoreconf -fiv
%configure --disable-static
make %{?_smp_mflags}

%install
%define docdir %{_defaultdocdir}/%{name}
make DESTDIR=%{buildroot} install %{?_smp_mflags}
mkdir -p %{buildroot}/%{docdir}
cp README COPYING %{buildroot}/%{docdir}

%files
%defattr(-,root,root)
%doc README COPYING
%{_mandir}/man8/tpm_*
%{_bindir}/tpm_*

%changelog



commit curl for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package curl for openSUSE:Factory checked in 
at 2017-06-29 15:00:29

Comparing /work/SRC/openSUSE:Factory/curl (Old)
 and  /work/SRC/openSUSE:Factory/.curl.new (New)


Package is "curl"

Thu Jun 29 15:00:29 2017 rev:124 rq:506883 version:7.54.1

Changes:

New Changes file:

--- /dev/null   2017-06-22 07:57:20.067658250 +0200
+++ /work/SRC/openSUSE:Factory/.curl.new/curl-mini.changes  2017-06-29 
15:00:46.218722736 +0200
@@ -0,0 +1,2029 @@
+---
+Wed Jun 28 13:50:08 UTC 2017 - dims...@opensuse.org
+
+- Update License to 'curl' as per review on OBS sr#505976.
+
+---
+Fri Jun 23 10:49:11 UTC 2017 - dims...@opensuse.org
+
+- Have the -mini packages conflict the real ones.
+
+---
+Tue Jun 20 11:30:01 UTC 2017 - idon...@suse.com
+
+- Add curl-invalid-free.patch to fix an invalid free in
+  curl_multi_setopt function.
+
+---
+Wed Jun 14 11:19:16 UTC 2017 - idon...@suse.com
+
+- Update to 7.54.1
+  Changes:
+  * curl now shows release date in --version output
+  Bugfixes:
+  * Fixes CVE-2017-9502: default protocol drive letter
+buffer overflow bsc#1044243
+  * openssl: fix memory leak in servercert
+  * curl: set a 100K buffer size by default
+  * nss: do not leak PKCS #11 slot while loading a key
+  * nss: load libnssckbi.so if no other trust is specified
+  * curl: use utimes instead of obsolescent utime when available
+  * url: fixed a memory leak on OOM while setting CURLOPT_BUFFERSIZE
+  * CURLOPT_BUFFERSIZE: 1024 bytes is now the minimum size
+  * curl: non-boolean command line args reject --no- prefixes
+  * telnet: Write full buffer instead of byte-by-byte
+  * curl: remove --environment and tool_writeenv.c
+  * curl: generate the --help output
+  * curl.1: clarify --config
+  * curl.1: mention --oauth2-bearer's argument
+  * ssh: fix memory leak in disconnect due to timeout
+  * redirect: store the "would redirect to" URL when max redirs is reached
+  * file: make speedcheck use current time for checks
+  * urlglob: fix division by zero 
+
+---
+Tue Jun 13 13:08:21 UTC 2017 - lnus...@suse.de
+
+- Create curl-mini for bootstrapping (boo#1042919) 
+
+---
+Wed Apr 19 08:17:17 UTC 2017 - idon...@suse.com
+
+- Update to 7.54.0
+  Changes:
+  * Add CURL_SSLVERSION_MAX_* constants to CURLOPT_SSLVERSION
+  * Add --max-tls
+  * Add CURLOPT_SUPPRESS_CONNECT_HEADERS
+  * Add --suppress-connect-headers
+  Bugfixes:
+  * CVE-2017-7468: switch off SSL session id when client cert is used
+  * bsc#1033413
+  * tests: use consistent environment variables for setting charset
+  * proxy: fixed a memory leak on OOM
+  * ftp: removed an erroneous free in an OOM path
+  * ftp: fixed a NULL pointer dereference on OOM
+  * gopher: fixed detection of an error condition from Curl_urldecode
+  * url: fix unix-socket support for proxy-disabled builds
+  * fix potential use of uninitialized variables
+  * ares: return error at once if timed out before name resolve starts
+  * URL: return error on malformed URLs with junk after port number
+  * http2: Fix assertion error on redirect with CL=0
+  * --insecure: clarify that this option is for server connections
+  * authneg: clear auth.multi flag at http_done
+  * curl_easy_reset: Also reset the authentication state
+  * proxy: skip SSL initialization for closed connections
+  * http_proxy: ignore TE and CL in CONNECT 2xx responses
+  * multi: fix streamclose() crash in debug mode
+  * openssl: fall back on SSL_ERROR_* string when no error detail
+  * asiohiper: make sure socket is open in event_cb
+  * curl: check for end of input in writeout backslash handling
+  * openssl: exclude DSA code when OPENSSL_NO_DSA is defined
+  * http: Fix proxy connection reuse with basic-auth
+  * pause: handle mixed types of data when paused
+  * http: do not treat FTPS over CONNECT as HTTPS
+  * conncache: make hashkey avoid malloc
+  * multi: fix queueing of pending easy handles
+  * low_speed_limit: improved function for longer time periods
+  * nss: load CA certificates even with --insecure
+  * Curl_expire_latest: ignore already expired timers
+  * http2: fix handle leak in error path
+  * openssl: make SSL_ERROR_to_str more future-proof
+  * openssl: fix thread-safety bugs in error-handling
+  * openssl: don't try to print nonexistant peer private keys
+
+---
+Fri Feb 24 11:42:10 UTC 2017 - idon...@suse.com
+
+- Update to 7.53.1
+  Bugfixes:
+ 

commit libqt5-qtbase for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package libqt5-qtbase for openSUSE:Factory 
checked in at 2017-06-29 14:59:43

Comparing /work/SRC/openSUSE:Factory/libqt5-qtbase (Old)
 and  /work/SRC/openSUSE:Factory/.libqt5-qtbase.new (New)


Package is "libqt5-qtbase"

Thu Jun 29 14:59:43 2017 rev:60 rq:505943 version:5.9.0

Changes:

--- /work/SRC/openSUSE:Factory/libqt5-qtbase/libqt5-qtbase.changes  
2017-06-13 16:06:03.024053118 +0200
+++ /work/SRC/openSUSE:Factory/.libqt5-qtbase.new/libqt5-qtbase.changes 
2017-06-29 15:00:14.119255084 +0200
@@ -1,0 +2,12 @@
+Thu Jun 22 15:02:38 UTC 2017 - fab...@ritter-vogt.de
+
+- Use the correct (edited) version of the revert to not break ABI:
+  * de63bbd2f806b0219a60775017899cedb121581f.patch
+
+---
+Tue Jun 20 15:07:06 UTC 2017 - fab...@ritter-vogt.de
+
+- Add upstream patch to fix version string of CMake modules (boo#1045102)
+  * fix-cmake-module-version.patch
+
+---

New:

  fix-cmake-module-version.patch



Other differences:
--
++ libqt5-qtbase.spec ++
--- /var/tmp/diff_new_pack.78wdQG/_old  2017-06-29 15:00:20.618337434 +0200
+++ /var/tmp/diff_new_pack.78wdQG/_new  2017-06-29 15:00:20.618337434 +0200
@@ -61,8 +61,10 @@
 # patches 1000-2000 and above from upstream 5.9 branch #
 # PATCH-FIX-UPSTREAM
 Patch1000:  native-children-hidpi-offset.patch
-# PATCH-FIX-UPSTREAM Revert to workaround QTBUG-61140
+# PATCH-FIX-UPSTREAM
 Patch1001:  dont-destroy-foreign-windows.patch
+# PATCH-FIX-UPSTREAM
+Patch1002:  fix-cmake-module-version.patch
 # patches 2000-3000 and above from upstream 5.10/dev branch #
 BuildRequires:  alsa-devel
 BuildRequires:  cups-devel
@@ -154,6 +156,7 @@
 %patch13 -p1
 %patch1000 -p1
 %patch1001 -p1
+%patch1002 -p1
 
 # be sure not to use them
 rm -rf src/3rdparty/{libjpeg,freetype,zlib}

++ de63bbd2f806b0219a60775017899cedb121581f.patch ++
--- /var/tmp/diff_new_pack.78wdQG/_old  2017-06-29 15:00:20.714323881 +0200
+++ /var/tmp/diff_new_pack.78wdQG/_new  2017-06-29 15:00:20.726322187 +0200
@@ -16,78 +16,9 @@
 Change-Id: I6b56f68f37670962178693a8983d9fe550540856
 Reviewed-by: Tor Arne Vestbø 
 ---
- src/gui/kernel/qplatformtheme.cpp  | 13 +
- src/gui/kernel/qplatformtheme.h|  1 +
- src/plugins/platforms/cocoa/qcocoatheme.h  |  1 +
- src/plugins/platforms/cocoa/qcocoatheme.mm |  6 ++
  src/widgets/widgets/qdialogbuttonbox.cpp   |  7 +--
  5 files changed, 22 insertions(+), 6 deletions(-)
 
-Index: qtbase-opensource-src-5.9.0/src/gui/kernel/qplatformtheme.cpp
-===
 qtbase-opensource-src-5.9.0.orig/src/gui/kernel/qplatformtheme.cpp
-+++ qtbase-opensource-src-5.9.0/src/gui/kernel/qplatformtheme.cpp
-@@ -678,19 +678,6 @@ QString QPlatformTheme::standardButtonTe
- return QPlatformTheme::defaultStandardButtonText(button);
- }
- 
--/*!
--   Returns the mnemonic that should be used for a standard \a button.
--
--  \since 5.9
--  \sa QPlatformDialogHelper::StandardButton
-- */
--
--QKeySequence QPlatformTheme::standardButtonShortcut(int button) const
--{
--Q_UNUSED(button)
--return QKeySequence();
--}
--
- QString QPlatformTheme::defaultStandardButtonText(int button)
- {
- switch (button) {
-Index: qtbase-opensource-src-5.9.0/src/gui/kernel/qplatformtheme.h
-===
 qtbase-opensource-src-5.9.0.orig/src/gui/kernel/qplatformtheme.h
-+++ qtbase-opensource-src-5.9.0/src/gui/kernel/qplatformtheme.h
-@@ -312,7 +312,6 @@ public:
- #endif
- 
- virtual QString standardButtonText(int button) const;
--virtual QKeySequence standardButtonShortcut(int button) const;
- 
- static QVariant defaultThemeHint(ThemeHint hint);
- static QString defaultStandardButtonText(int button);
-Index: qtbase-opensource-src-5.9.0/src/plugins/platforms/cocoa/qcocoatheme.h
-===
 qtbase-opensource-src-5.9.0.orig/src/plugins/platforms/cocoa/qcocoatheme.h
-+++ qtbase-opensource-src-5.9.0/src/plugins/platforms/cocoa/qcocoatheme.h
-@@ -74,7 +74,6 @@ public:
- 
- QVariant themeHint(ThemeHint hint) const Q_DECL_OVERRIDE;
- QString standardButtonText(int button) const Q_DECL_OVERRIDE;
--QKeySequence standardButtonShortcut(int button) const Q_DECL_OVERRIDE;
- 
- static const char *name;
- 
-Index: qtbase-opensource-src-5.9.0/src/plugins/platforms/cocoa/qcocoatheme.mm
-===
 

commit python-pycurl for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package python-pycurl for openSUSE:Factory 
checked in at 2017-06-29 14:59:34

Comparing /work/SRC/openSUSE:Factory/python-pycurl (Old)
 and  /work/SRC/openSUSE:Factory/.python-pycurl.new (New)


Package is "python-pycurl"

Thu Jun 29 14:59:34 2017 rev:16 rq:505428 version:7.43.0

Changes:

--- /work/SRC/openSUSE:Factory/python-pycurl/python-pycurl.changes  
2017-04-28 10:39:28.396238968 +0200
+++ /work/SRC/openSUSE:Factory/.python-pycurl.new/python-pycurl.changes 
2017-06-29 14:59:39.748108176 +0200
@@ -1,0 +2,11 @@
+Wed Jun 21 09:51:22 UTC 2017 - alarr...@suse.com
+
+- Add increase_test_timeout.diff so tests don't fail when obs is
+  overloaded and it takes more than 1 second to start a service.
+
+---
+Thu Jun  8 16:15:49 UTC 2017 - lnus...@suse.de
+
+- exclude http2 and ssh tests if curl(-mini) doesn't support it
+
+---

New:

  increase_test_timeout.diff



Other differences:
--
++ python-pycurl.spec ++
--- /var/tmp/diff_new_pack.uZDaZ9/_old  2017-06-29 14:59:41.027927470 +0200
+++ /var/tmp/diff_new_pack.uZDaZ9/_new  2017-06-29 14:59:41.031926906 +0200
@@ -28,6 +28,8 @@
 Source: 
https://files.pythonhosted.org/packages/source/p/pycurl/pycurl-%{version}.tar.gz
 # PATCH-FIX-UPSTREAM remove __DATE__ and __TIME__
 Patch0: pycurl-no-runtime-curlvercheck.patch
+# PATCH-FIX-OPENSUSE increase_test_timeout.diff -- Increase the timeout in a 
test so it doesn't fail when obs is overloaded
+Patch1: increase_test_timeout.diff
 BuildRequires:  %{python_module CherryPy}
 BuildRequires:  %{python_module bottle}
 BuildRequires:  %{python_module devel}
@@ -67,6 +69,7 @@
 %prep
 %setup -q -n pycurl-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 export CFLAGS="%{optflags}"
@@ -83,13 +86,16 @@
 rm -f *.so
 make
 popd
-EXCLUDES=""
-%if 0%{?suse_version} < 1320
-# CURL too old to know HTTP/2
-EXCLUDES="-e test_http_version_2_0"
-%endif
+# exclude certain tests
+test_flags='!online'
+if ! pkg-config --variable=supported_features libcurl|grep -qw HTTP2; then
+test_flags="$test_flags,\!http2"
+fi
+if ! pkg-config --variable=supported_protocols libcurl|grep -qw SCP; then
+test_flags="$test_flags,\!ssh"
+fi
 %{python_expand PYTHONPATH=$(ls -d build/lib.*) \
-nosetests-%$python_bin_suffix --with-flaky -a '!online' $EXCLUDES}
+nosetests-%$python_bin_suffix --with-flaky -a "$test_flags"}
 
 %files %{python_files}
 %defattr(-,root,root,-)

++ increase_test_timeout.diff ++
Index: pycurl-7.43.0/tests/runwsgi.py
===
--- pycurl-7.43.0.orig/tests/runwsgi.py
+++ pycurl-7.43.0/tests/runwsgi.py
@@ -55,10 +55,10 @@ def start_bottle_server(app, port, serve
 server_thread.daemon = True
 server_thread.start()
 
-ok = util.wait_for_network_service(('127.0.0.1', port), 0.1, 10)
+ok = util.wait_for_network_service(('127.0.0.1', port), 0.1, 30)
 if not ok:
 import warnings
-warnings.warn('Server did not start after 1 second')
+warnings.warn('Server did not start after 3 seconds')
 
 return server_thread.server
 



commit util-linux for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package util-linux for openSUSE:Factory 
checked in at 2017-06-29 14:58:21

Comparing /work/SRC/openSUSE:Factory/util-linux (Old)
 and  /work/SRC/openSUSE:Factory/.util-linux.new (New)


Package is "util-linux"

Thu Jun 29 14:58:21 2017 rev:218 rq:504843 version:2.30

Changes:

--- /work/SRC/openSUSE:Factory/util-linux/python-libmount.changes   
2017-04-25 08:55:22.398971323 +0200
+++ /work/SRC/openSUSE:Factory/.util-linux.new/python-libmount.changes  
2017-06-29 14:58:41.756296404 +0200
@@ -1,0 +2,48 @@
+Sun Jun 11 12:12:44 UTC 2017 - lnus...@suse.de
+
+- don't conflict with sysvinit-tools in Tumblweed anymore. Needed for Leap 15
+  which wants to use a different release number scheme (lp150.x which produces
+  lower numbers than the conflict).
+
+---
+Thu Jun  8 21:21:12 UTC 2017 - sweet_...@gmx.de
+
+- Update to version 2.30:
+  * Many changes and improvements, most notably:
+* The libblkid library has been improved for hybrid CDROM/DVD
+  media.
+* The deprecated command tailf has been removed. Use "tail -f"
+  from coreutils.
+* blkzone -- NEW COMMAND to run zone commands on block devices
+  that support Zoned Block Commands (ZBC) or Zoned-device ATA
+  Commands (ZAC).
+* fincore -- NEW COMMAND to count pages of file contents in
+  core (memory).
+* lsmem -- NEW COMMAND to list the ranges of available memory
+  with their online status.
+* The command fallocate -- supports an "insert range" operation
+  now.
+* The command "column -t|--table" has been modified to use
+  libsmartcols. It now provides nearly all of that library's
+  functionality from the command line.
+  * Security issues:
+* hwclock - no longer makes any internal permission checks. The
+  System Administrator must set proper permissions to control
+  user access to the RTC. It is NOT recommended to use SUID.
+* CVE-2016-2779 - This security issue is NOT FIXED yet.
+  * More details at:
+https://www.kernel.org/pub/linux/utils/util-linux/v2.30/v2.30-ReleaseNotes
+- Drop upstreamed patch
+  arm64-lscpu-use-sysfs-for-table-access-if-available.patch
+- Refreshed patch
+  util-linux-losetup-Add-support-for-setting-logical-blocksize.patch 
+- fix compiler warnings for mkzimage_cmdline
+
+---
+Thu Jun  8 16:28:41 UTC 2017 - msucha...@suse.com
+
+- When when hypervisor_decode_sysfw fails continue with other
+  detection methods (bsc#1042991, bsc#1039360, bsc#1033718)
+  + util-linux-lscpu-cleanup-DMI-detection-return-codes.patch
+
+---
@@ -181 +229 @@
-  ftp://ftp.kernel.org/pub/linux/utils/util-linux/v2.28/v2.28.2-ReleaseNotes
+  https://www.kernel.org/pub/linux/utils/util-linux/v2.28/v2.28.2-ReleaseNotes
@@ -187 +235 @@
-  ftp://ftp.kernel.org/pub/linux/utils/util-linux/v2.28/v2.28.1-ReleaseNotes
+  https://www.kernel.org/pub/linux/utils/util-linux/v2.28/v2.28.1-ReleaseNotes
@@ -296 +344 @@
-  ftp://ftp.kernel.org/pub/linux/utils/util-linux/v2.27/v2.27.1-ReleaseNotes
+  https://www.kernel.org/pub/linux/utils/util-linux/v2.27/v2.27.1-ReleaseNotes
@@ -1851 +1899 @@
-ftp://ftp.kernel.org/pub/linux/utils/util-linux-ng/v2.18/v2.18-ReleaseNotes
+https://www.kernel.org/pub/linux/utils/util-linux/v2.18/v2.18-ReleaseNotes
util-linux-systemd.changes: same change
util-linux.changes: same change

Old:

  arm64-lscpu-use-sysfs-for-table-access-if-available.patch
  util-linux-2.29.2.tar.sign
  util-linux-2.29.2.tar.xz

New:

  util-linux-2.30.tar.sign
  util-linux-2.30.tar.xz
  util-linux-lscpu-cleanup-DMI-detection-return-codes.patch



Other differences:
--
++ python-libmount.spec ++
--- /var/tmp/diff_new_pack.vKj8Gm/_old  2017-06-29 14:58:52.558771138 +0200
+++ /var/tmp/diff_new_pack.vKj8Gm/_new  2017-06-29 14:58:52.562770572 +0200
@@ -116,7 +116,7 @@
 %endif
 %endif
 #END SECOND STAGE DEPENDENCIES
-Version:2.29.2
+Version:2.30
 Release:0
 # util-linux is a base package and uuidd pre-requiring pwdutils pulls
 # that into the core build cycle.  pwdutils also pulls in the whole
@@ -125,7 +125,7 @@
 # these tools as well
 #!BuildIgnore:  pwdutils
 Url:https://www.kernel.org/pub/linux/utils/util-linux/
-Source: 
https://www.kernel.org/pub/linux/utils/util-linux/v2.29/util-linux-%{version}.tar.xz
+Source: 
https://www.kernel.org/pub/linux/utils/util-linux/v2.30/util-linux-%{version}.tar.xz
 Source1:util-linux-rpmlintrc
 Source4:raw.service
 Source5:etc.raw
@@ -135,7 +135,7 @@
 Source9:

commit lua for openSUSE:Factory

2017-06-29 Thread root
Hello community,

here is the log from the commit of package lua for openSUSE:Factory checked in 
at 2017-06-29 14:57:57

Comparing /work/SRC/openSUSE:Factory/lua (Old)
 and  /work/SRC/openSUSE:Factory/.lua.new (New)


Package is "lua"

Thu Jun 29 14:57:57 2017 rev:41 rq:504500 version:5.3.3

Changes:

--- /work/SRC/openSUSE:Factory/lua/lua.changes  2016-06-29 09:43:05.0 
+0200
+++ /work/SRC/openSUSE:Factory/.lua.new/lua.changes 2017-06-29 
14:58:00.518119062 +0200
@@ -1,0 +2,6 @@
+Tue Jun 13 21:30:38 UTC 2017 - jeng...@inai.de
+
+- Let package description adhere to guidelines: trim redundant
+  or biased wording and strip future goals.
+
+---



Other differences:
--
++ lua.spec ++
--- /var/tmp/diff_new_pack.djueiv/_old  2017-06-29 14:58:05.757379301 +0200
+++ /var/tmp/diff_new_pack.djueiv/_new  2017-06-29 14:58:05.757379301 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package lua
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,7 +21,7 @@
 Name:   lua
 Version:5.3.3
 Release:0
-Summary:Small Embeddable Language with Simple Procedural Syntax
+Summary:Small Embeddable Language with Procedural Syntax
 License:MIT
 Group:  Development/Languages/Other
 Url:http://www.lua.org
@@ -46,16 +46,15 @@
 
 %description
 Lua is a programming language originally designed for extending
-applications, but also frequently used as a general-purpose,
+applications, but is also frequently used as a general-purpose,
 stand-alone language.
 
-Lua combines simple procedural syntax (similar to Pascal) with powerful
+Lua combines procedural syntax (similar to Pascal) with
 data description constructs based on associative arrays and extensible
 semantics. Lua is dynamically typed, interpreted from byte codes, and
-has automatic memory management, making it ideal for configuration,
+has automatic memory management, making it suitable for configuration,
 scripting, and rapid prototyping. Lua is implemented as a small library
-of C functions, written in ANSI C, and the implementation goals are
-simplicity, efficiency, portability, and low embedding cost.
+of C functions, written in ANSI C.
 
 %package devel
 Summary:Development files for lua
@@ -67,7 +66,7 @@
 
 %description devel
 Lua is a programming language originally designed for extending
-applications, but also frequently used as a general-purpose,
+applications, but is also frequently used as a general-purpose,
 stand-alone language.
 
 This package contains files needed for embedding lua into your
@@ -81,16 +80,15 @@
 
 %description -n liblua%{libsuf}
 Lua is a programming language originally designed for extending
-applications, but also frequently used as a general-purpose,
+applications, but is also frequently used as a general-purpose,
 stand-alone language.
 
-Lua combines simple procedural syntax (similar to Pascal) with powerful
+Lua combines procedural syntax (similar to Pascal) with
 data description constructs based on associative arrays and extensible
 semantics. Lua is dynamically typed, interpreted from byte codes, and
-has automatic memory management, making it ideal for configuration,
+has automatic memory management, making it suitable for configuration,
 scripting, and rapid prototyping. Lua is implemented as a small library
-of C functions, written in ANSI C, and the implementation goals are
-simplicity, efficiency, portability, and low embedding cost.
+of C functions, written in ANSI C.
 
 %package doc
 Summary:Documentation for Lua, a small embeddable language
@@ -101,16 +99,15 @@
 
 %description doc
 Lua is a programming language originally designed for extending
-applications, but also frequently used as a general-purpose,
+applications, but is also frequently used as a general-purpose,
 stand-alone language.
 
-Lua combines simple procedural syntax (similar to Pascal) with powerful
+Lua combines procedural syntax (similar to Pascal) with
 data description constructs based on associative arrays and extensible
 semantics. Lua is dynamically typed, interpreted from byte codes, and
-has automatic memory management, making it ideal for configuration,
+has automatic memory management, making it suitable for configuration,
 scripting, and rapid prototyping. Lua is implemented as a small library
-of C functions, written in ANSI C, and the implementation goals are
-simplicity, efficiency, portability, and low embedding cost.
+of C