commit bundle-lang-common for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package bundle-lang-common for 
openSUSE:Factory checked in at 2017-09-04 20:29:46

Comparing /work/SRC/openSUSE:Factory/bundle-lang-common (Old)
 and  /work/SRC/openSUSE:Factory/.bundle-lang-common.new (New)


Package is "bundle-lang-common"

Mon Sep  4 20:29:46 2017 rev:232 rq: version:13.2

Changes:

bundle-lang-gnome.changes: same change
bundle-lang-kde.changes: same change
bundle-lang-other.changes: same change



Other differences:
--
bundle-lang-gnome.spec: same change
++ bundle-lang-kde.spec ++
--- /var/tmp/diff_new_pack.lundfi/_old  2017-09-04 20:29:50.751571275 +0200
+++ /var/tmp/diff_new_pack.lundfi/_new  2017-09-04 20:29:50.763569587 +0200
@@ -10401,7 +10401,7 @@
 
 %package el
 Summary:summary
-Group:  group
+Group:  System/Localization
 Provides:   akonadi-calendar-lang = %(rpm -q --queryformat '%{VERSION}' 
akonadi-calendar-lang)
 Obsoletes:  akonadi-calendar-lang < %(rpm -q --queryformat '%{VERSION}' 
akonadi-calendar-lang)
 Provides:   locale(akonadi-calendar:el)

++ attributes ++
--- /var/tmp/diff_new_pack.lundfi/_old  2017-09-04 20:29:50.859556078 +0200
+++ /var/tmp/diff_new_pack.lundfi/_new  2017-09-04 20:29:50.859556078 +0200
@@ -774,6 +774,7 @@
 group.bundle-lang-kde-cs System/Localization
 group.bundle-lang-kde-da System/Localization
 group.bundle-lang-kde-de System/Localization
+group.bundle-lang-kde-el System/Localization
 group.bundle-lang-kde-en System/Localization
 group.bundle-lang-kde-es System/Localization
 group.bundle-lang-kde-fi System/Localization




commit bundle-lang-common for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package bundle-lang-common for 
openSUSE:Factory checked in at 2017-09-04 20:25:59

Comparing /work/SRC/openSUSE:Factory/bundle-lang-common (Old)
 and  /work/SRC/openSUSE:Factory/.bundle-lang-common.new (New)


Package is "bundle-lang-common"

Mon Sep  4 20:25:59 2017 rev:231 rq: version:13.2

Changes:

bundle-lang-gnome.changes: same change
bundle-lang-kde.changes: same change
bundle-lang-other.changes: same change



Other differences:
--
++ bundle-lang-common.spec ++
--- /var/tmp/diff_new_pack.eoPyPc/_old  2017-09-04 20:26:02.567684688 +0200
+++ /var/tmp/diff_new_pack.eoPyPc/_new  2017-09-04 20:26:02.575683562 +0200
@@ -69,8 +69,6 @@
 BuildRequires:  shared-mime-info-lang
 BuildRequires:  system-config-printer-common-lang
 BuildRequires:  tar-lang
-BuildRequires:  udisks2-lang
-BuildRequires:  upower-lang
 BuildRequires:  util-linux-lang
 BuildRequires:  vorbis-tools-lang
 BuildRequires:  xdg-user-dirs-lang
@@ -217,12 +215,6 @@
 Provides:   tar-lang = %(rpm -q --queryformat '%{VERSION}' tar-lang)
 Obsoletes:  tar-lang < %(rpm -q --queryformat '%{VERSION}' tar-lang)
 Provides:   locale(tar:en)
-Provides:   udisks2-lang = %(rpm -q --queryformat '%{VERSION}' 
udisks2-lang)
-Obsoletes:  udisks2-lang < %(rpm -q --queryformat '%{VERSION}' 
udisks2-lang)
-Provides:   locale(udisks2:en)
-Provides:   upower-lang = %(rpm -q --queryformat '%{VERSION}' upower-lang)
-Obsoletes:  upower-lang < %(rpm -q --queryformat '%{VERSION}' upower-lang)
-Provides:   locale(upower:en)
 Provides:   util-linux-lang = %(rpm -q --queryformat '%{VERSION}' 
util-linux-lang)
 Obsoletes:  util-linux-lang < %(rpm -q --queryformat '%{VERSION}' 
util-linux-lang)
 Provides:   locale(util-linux:en)
@@ -367,12 +359,6 @@
 Provides:   tar-lang = %(rpm -q --queryformat '%{VERSION}' tar-lang)
 Obsoletes:  tar-lang < %(rpm -q --queryformat '%{VERSION}' tar-lang)
 Provides:   locale(tar:de)
-Provides:   udisks2-lang = %(rpm -q --queryformat '%{VERSION}' 
udisks2-lang)
-Obsoletes:  udisks2-lang < %(rpm -q --queryformat '%{VERSION}' 
udisks2-lang)
-Provides:   locale(udisks2:de)
-Provides:   upower-lang = %(rpm -q --queryformat '%{VERSION}' upower-lang)
-Obsoletes:  upower-lang < %(rpm -q --queryformat '%{VERSION}' upower-lang)
-Provides:   locale(upower:de)
 Provides:   util-linux-lang = %(rpm -q --queryformat '%{VERSION}' 
util-linux-lang)
 Obsoletes:  util-linux-lang < %(rpm -q --queryformat '%{VERSION}' 
util-linux-lang)
 Provides:   locale(util-linux:de)
@@ -517,12 +503,6 @@
 Provides:   tar-lang = %(rpm -q --queryformat '%{VERSION}' tar-lang)
 Obsoletes:  tar-lang < %(rpm -q --queryformat '%{VERSION}' tar-lang)
 Provides:   locale(tar:es)
-Provides:   udisks2-lang = %(rpm -q --queryformat '%{VERSION}' 
udisks2-lang)
-Obsoletes:  udisks2-lang < %(rpm -q --queryformat '%{VERSION}' 
udisks2-lang)
-Provides:   locale(udisks2:es)
-Provides:   upower-lang = %(rpm -q --queryformat '%{VERSION}' upower-lang)
-Obsoletes:  upower-lang < %(rpm -q --queryformat '%{VERSION}' upower-lang)
-Provides:   locale(upower:es)
 Provides:   util-linux-lang = %(rpm -q --queryformat '%{VERSION}' 
util-linux-lang)
 Obsoletes:  util-linux-lang < %(rpm -q --queryformat '%{VERSION}' 
util-linux-lang)
 Provides:   locale(util-linux:es)
@@ -667,12 +647,6 @@
 Provides:   tar-lang = %(rpm -q --queryformat '%{VERSION}' tar-lang)
 Obsoletes:  tar-lang < %(rpm -q --queryformat '%{VERSION}' tar-lang)
 Provides:   locale(tar:it)
-Provides:   udisks2-lang = %(rpm -q --queryformat '%{VERSION}' 
udisks2-lang)
-Obsoletes:  udisks2-lang < %(rpm -q --queryformat '%{VERSION}' 
udisks2-lang)
-Provides:   locale(udisks2:it)
-Provides:   upower-lang = %(rpm -q --queryformat '%{VERSION}' upower-lang)
-Obsoletes:  upower-lang < %(rpm -q --queryformat '%{VERSION}' upower-lang)
-Provides:   locale(upower:it)
 Provides:   util-linux-lang = %(rpm -q --queryformat '%{VERSION}' 
util-linux-lang)
 Obsoletes:  util-linux-lang < %(rpm -q --queryformat '%{VERSION}' 
util-linux-lang)
 Provides:   locale(util-linux:it)
@@ -817,12 +791,6 @@
 Provides:   tar-lang = %(rpm -q --queryformat '%{VERSION}' tar-lang)
 Obsoletes:  tar-lang < %(rpm -q --queryformat '%{VERSION}' tar-lang)
 Provides:   locale(tar:fr)
-Provides:   udisks2-lang = %(rpm -q --queryformat '%{VERSION}' 
udisks2-lang)
-Obsoletes:  udisks2-lang < %(rpm -q --queryformat '%{VERSION}' 
udisks2-lang)
-Provides:   locale(udisks2:fr)
-Provides:   upower-lang = %(rpm -q --queryformat '%{VERSION}' upower-lang)
-Obsoletes:  

commit 000product for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2017-09-04 12:39:37

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new (New)


Package is "000product"

Mon Sep  4 12:39:37 2017 rev:78 rq: version:unknown
Mon Sep  4 12:39:36 2017 rev:77 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
_service:product_converter:openSUSE-Addon-Lang-cd-cd-x86_64.kiwi: same change
_service:product_converter:openSUSE-Addon-Lang-release.spec: same change
_service:product_converter:openSUSE-Addon-NonOss-cd-addon-nonoss-i586_x86_64.kiwi:
 same change
_service:product_converter:openSUSE-Addon-NonOss-ftp-ftp-i586_x86_64.kiwi: same 
change
_service:product_converter:openSUSE-Addon-NonOss-release.spec: same change
++ _service:product_converter:openSUSE-Kubic-dvd5-DVD-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.MLcPZQ/_old  2017-09-04 12:39:45.338531250 +0200
+++ /var/tmp/diff_new_pack.MLcPZQ/_new  2017-09-04 12:39:45.342530687 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -34,9 +34,9 @@
   true
   -x -2
   openSUSE
-  20170831
+  20170904
   11
-  cpe:/o:opensuse:opensuse-kubic:20170831,openSUSE 
Kubic
+  cpe:/o:opensuse:opensuse-kubic:20170904,openSUSE 
Kubic
   en_US 
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ _service:product_converter:openSUSE-Kubic-release.spec ++
--- /var/tmp/diff_new_pack.MLcPZQ/_old  2017-09-04 12:39:45.358528436 +0200
+++ /var/tmp/diff_new_pack.MLcPZQ/_new  2017-09-04 12:39:45.366527311 +0200
@@ -20,7 +20,7 @@
 Summary:openSUSE Kubic 
 License:GPL-2.0+
 Group:  System/Fhs
-Version:20170831
+Version:    20170904
 Release:0
 BuildRequires:  skelcd-openSUSE
 Recommends: branding
@@ -31,9 +31,9 @@
 
 Provides:   %name-%version
 Provides:   product() = openSUSE-Kubic
-Provides:   product(openSUSE-Kubic) = 20170831-0
+Provides:   product(openSUSE-Kubic) = 20170904-0
 Provides:   product-label() = openSUSE%20Kubic
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dkubic%3A20170831
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dkubic%3A20170904
 Provides:   product-url(releasenotes) = 
https%3A%2F%2Fwww.suse.com%2Freleasenotes%2F%{_target_cpu}%2FSUSE%2DCAASP%2F1.0%2Frelease%2Dnotes%2Dcaasp.rpm
 Provides:   product-endoflife()
 
@@ -90,7 +90,7 @@
 PRETTY_NAME="openSUSE Kubic"
 ID="opensuse-kubic"
 ANSI_COLOR="0;32"
-CPE_NAME="cpe:/o:opensuse:opensuse-kubic:20170831"
+CPE_NAME="cpe:/o:opensuse:opensuse-kubic:20170904"
 EOF
 
 
@@ -100,11 +100,11 @@
 
   openSUSE
   openSUSE-Kubic
-  20170831
+  20170904
   0
   
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-kubic:20170831
+  cpe:/o:opensuse:opensuse-kubic:20170904
   openSUSE-Kubic
   
 

++ _service:product_converter:openSUSE-cd-mini-i586.kiwi ++
--- /var/tmp/diff_new_pack.MLcPZQ/_old  2017-09-04 12:39:45.418519996 +0200
+++ /var/tmp/diff_new_pack.MLcPZQ/_new  2017-09-04 12:39:45.430518308 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -31,9 +31,9 @@
   true
   -x -2
   openSUSE
-  20170831
+  20170904
   11
-  cpe:/o:opensuse:opensuse:20170831,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20170904,openSUSE 
Tumbleweed
   cs da de en en_GB en_US es fi fr hu it ja nb 
nl pl pt pt_BR ru sv zh zh_CN zh_TW 
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

_service:product_converter:openSUSE-cd-mini-x86_64.kiwi: same change
_service:product_converter:openSUSE-dvd5-dvd-i586.kiwi: same change
++ _service:product_converter:openSUSE-dvd5-dvd-promo-i586.kiwi ++
--- /var/tmp/diff_new_pack.MLcPZQ/_old  2017-09-04 12:39:45.590495801 +0200
+++ /var/tmp/diff_new_pack.MLcPZQ/_new  2017-09-04 12:39:45.594495238 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,9 +32,9 @@
   true
   -x -2
   openSUSE
-  20170831
+  20170904
   11
-  cpe:/o:opensuse:opensuse:20170831,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20170904,openSUSE 
Tumbleweed
   cs da de en en_GB en_US es fi fr hu it ja nb 
nl pl pt pt_BR ru sv zh zh_CN zh_TW 
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

_service:product_converter:openSUSE-dvd5-dvd-promo-x86_64.kiwi: same change
++ _service:product_converter:openSUSE-dvd5-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.MLcPZQ/_old  2017-09-04 12:39:45.694481171 +0200
+++ /var/

commit votca-csg for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package votca-csg for openSUSE:Factory 
checked in at 2017-09-04 12:39:15

Comparing /work/SRC/openSUSE:Factory/votca-csg (Old)
 and  /work/SRC/openSUSE:Factory/.votca-csg.new (New)


Package is "votca-csg"

Mon Sep  4 12:39:15 2017 rev:10 rq:520513 version:1.4.1

Changes:

--- /work/SRC/openSUSE:Factory/votca-csg/votca-csg.changes  2017-02-03 
20:04:45.401324044 +0100
+++ /work/SRC/openSUSE:Factory/.votca-csg.new/votca-csg.changes 2017-09-04 
12:39:18.370325429 +0200
@@ -1,0 +2,13 @@
+Sun Sep  3 13:26:48 UTC 2017 - jungh...@votca.org
+
+- Upgrade to 1.4.1
+  * fix pkg-config files
+  * fix build with gmx-2017
+  * added CSG_MDRUN_OPTS to run_gromacs.sh
+  * table_to_tab.pl: fix forces for LAMMPS
+  * csg_inverse: warn users of bug #179
+  * run_gromacs.sh: check nstxout-compressed
+  * details: https://github.com/votca/csg/blob/master/CHANGELOG.md
+
+
+---

Old:

  votca-csg-1.4.tar.gz
  votca-csg-manual-1.4.pdf
  votca-csg-tutorials-1.4.tar.gz

New:

  votca-csg-1.4.1.tar.gz
  votca-csg-manual-1.4.1.pdf
  votca-csg-tutorials-1.4.1.tar.gz



Other differences:
--
++ votca-csg.spec ++
--- /var/tmp/diff_new_pack.EuxP7B/_old  2017-09-04 12:39:19.634147621 +0200
+++ /var/tmp/diff_new_pack.EuxP7B/_new  2017-09-04 12:39:19.650145370 +0200
@@ -2,7 +2,7 @@
 # spec file for package votca-csg
 #
 # Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
-# Copyright (c) 2013-2016 Christoph Junghans
+# Copyright (c) 2013-2017 Christoph Junghans
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,8 @@
 #
 
 Name:   votca-csg
-Version:1.4
-%define uversion 1.4
+Version:1.4.1
+%define uversion 1.4.1
 Release:0
 Summary:VOTCA coarse-graining engine
 License:Apache-2.0

++ votca-csg-1.4.tar.gz -> votca-csg-1.4.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/csg-1.4/.travis.yml new/csg-1.4.1/.travis.yml
--- old/csg-1.4/.travis.yml 2016-10-29 18:47:47.0 +0200
+++ new/csg-1.4.1/.travis.yml   2017-09-03 01:45:18.0 +0200
@@ -33,14 +33,15 @@
   - cm-super
   - doxygen
   - graphviz
-  - python-numpy
+  - ghostscript
   - gnuplot-nox
   - octave
 
 env:
   global:
-- HDF5_VERSION=1.8.14
-- GMX_MAX_THREADS=8
+- HDF5_VERSION=1.8.18
+- GMX_MAX_THREADS=4
+- CSG_MDRUN_OPTS="-ntmpi 4"
 - CCACHE_CPP2=yes #for clang
 - GVER=4.8
   matrix: #NINJA=1 is currently not support by Travis' cmake, enable when 
>=2.8.9
@@ -51,8 +52,8 @@
 - WALL=yes GMX_DOUBLE=yes J=4
 - WALL=yes GMX_VERSION=5.0 J=4
 - WALL=yes GMX_VERSION=5.0 GMX_DOUBLE=yes J=4
-- WALL=yes GMX_VERSION=2016 J=4
-- WALL=yes GMX_VERSION=2016 GMX_DOUBLE=yes J=4
+- WALL=yes GMX_VERSION=5.1 J=4
+- WALL=yes GMX_VERSION=5.1 GMX_DOUBLE=yes J=4
 - WALL=yes GMX_VERSION= J=4
 - WALL=yes GMX_VERSION= GMX_DOUBLE=yes J=4
 - MINIMAL=yes J=4
@@ -88,7 +89,7 @@
   - wget https://raw.githubusercontent.com/votca/buildutil/master/build.sh && 
chmod 755 build.sh
   - mkdir -p "$HOME/votca/src"
   - if [[ ${MINIMAL} != yes ]]; then 
-  wget -qO- 
https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-${HDF5_VERSION}/src/hdf5-${HDF5_VERSION}.tar.gz
 | tar -xz &&
+  wget -qO- 
https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-${HDF5_VERSION%.*}/hdf5-${HDF5_VERSION}/src/hdf5-${HDF5_VERSION}.tar.gz
 | tar -xz &&
   cd hdf5-${HDF5_VERSION} && ./configure --prefix=$HOME/hdf5 && make -j4 
&> /dev/null && make install && cd ..;
 fi
   - if [[ ${GMX_VERSION} =  ]]; then
@@ -98,9 +99,10 @@
 fi
   - if [[ ${MAN} ]]; then git clone --depth=1 
https://github.com/votca/doxygen.git "$HOME/votca/src/devdoc"; fi 
   - if [[ ${GVER} ]]; then export CC=gcc-${GVER}; export CXX=g++-${GVER}; fi
+  - pip install --user numpy
 
 script:
-  - PATH="$HOME/hdf5:$PATH" ./build.sh -Wu $([[ ${TRAVIS_BRANCH} = stable ]] 
|| echo "--dev") --prefix "$HOME/votca"
+  - PATH="$HOME/hdf5:$PATH" ./build.sh -Wu --prefix "$HOME/votca"
 ${TYPE:+-DCMAKE_BUILD_TYPE=${TYPE}}
 ${TEST:+--runtest=$TEST} ${WERROR:+--warn-to-errors} -DWITH_H5MD=ON 
${MINIMAL:+--minimal} ${MAN:+--devdoc}
 ${J:+-j$J} ${BDIR:+--builddir=$BDIR} ${NINJA:+--ninja} ${WALL:+--Wall} 
${GMX_VERSION:+--gmx-release ${GMX_VERSION}}
@@ -132,4 +134,5 @@
 
 notifications:
   email:
-- votca-comm...@googlegroups.com 
+recipients: #encrypted votca-comm...@googlegroups.com so that fork don't 
notify us 

commit rust for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package rust for openSUSE:Factory checked in 
at 2017-09-04 12:39:25

Comparing /work/SRC/openSUSE:Factory/rust (Old)
 and  /work/SRC/openSUSE:Factory/.rust.new (New)


Package is "rust"

Mon Sep  4 12:39:25 2017 rev:15 rq:520550 version:1.19.0

Changes:

--- /work/SRC/openSUSE:Factory/rust/rust.changes2017-07-19 
11:20:00.689110568 +0200
+++ /work/SRC/openSUSE:Factory/.rust.new/rust.changes   2017-09-04 
12:39:26.877128600 +0200
@@ -1,0 +2,70 @@
+Fri Sep  1 10:14:10 UTC 2017 - luke.nukem.jo...@gmail.com
+
+- adjust build process and add package for Rust source
+- clean-up of useless provides
+- add rpmlintrc
+
+---
+Tue Aug  8 23:06:44 UTC 2017 - luke.nukem.jo...@gmail.com
+
+- Update to version 1.19
+
+- Language updates:
+  + [Numeric fields can now be used for creating tuple structs.][41145] [RFC 
1506]
+For example `struct Point(u32, u32); let x = Point { 0: 7, 1: 0 };`.
+  + [Macro recursion limit increased to 1024 from 64.][41676]
+  + [Added lint for detecting unused macros.][41907]
+  + [`loop` can now return a value with `break`.][42016] [RFC 1624]
+For example: `let x = loop { break 7; };`
+  + [C compatible `union`s are now available.][42068] [RFC 1444] They can only
+contain `Copy` types and cannot have a `Drop` implementation.
+Example: `union Foo { bar: u8, baz: usize }`
+  + [Non capturing closures can now be coerced into `fn`s,][42162] [RFC 1558]
+Example: `let foo: fn(u8) -> u8 = |v: u8| { v };`
+
+- Compiler updates:
+  + [Add support for bootstrapping the Rust compiler toolchain on 
Android.][41370]
+  + [Change `arm-linux-androideabi` to correspond to the `armeabi`
+official ABI.][41656] If you wish to continue targeting the `armeabi-v7a` 
ABI
+you should use `--target armv7-linux-androideabi`.
+  + [Fixed ICE when removing a source file between compilation 
sessions.][41873]
+  + [Minor optimisation of string operations.][42037]
+  + [Compiler error message is now `aborting due to previous error(s)` instead 
of
+`aborting due to N previous errors`][42150] This was previously inaccurate 
and
+would only count certain kinds of errors.
+  + [The compiler now supports Visual Studio 2017][42225]
+  + [The compiler is now built against LLVM 4.0.1 by default][42948]
+  + [Added a lot][42264] of [new error codes][42302]
+  + [Added `target-feature=+crt-static` option][37406] [RFC 1721] Which allows
+libraries with C Run-time Libraries(CRT) to be statically linked.
+  + [Fixed various ARM codegen bugs][42740]
+
+- Librarie updates:
+  + [`String` now implements `FromIterator>` and
+`Extend>`][41449]
+  + [`Vec` now implements `From< [T]>`][41530]
+  + [`Box<[u8]>` now implements `From`][41258]
+  + [`SplitWhitespace` now implements `Clone`][41659]
+  + [`[u8]::reverse` is now 5x faster and `[u16]::reverse` is now
+1.5x faster][41764]
+  + [`eprint!` and `eprintln!` macros added to prelude.][41192] Same as the 
`print!`
+macros, but for printing to stderr.
+
+- Stabilized APIs
+  + [`OsString::shrink_to_fit`]
+  + [`cmp::Reverse`]
+  + [`Command::envs`]
+  + [`thread::ThreadId`]
+  
+- Misc
+  + [Added `rust-windbg.cmd`][39983] for loading rust `.natvis` files in the
+Windows Debugger.
+  + [Rust will now release XZ compressed packages][rust-installer/57]
+  + [rustup will now prefer to download rust packages with
+XZ compression][rustup/1100] over GZip packages.
+  + [Added the ability to escape `#` in rust documentation][41785] By adding
+additional `#`'s ie. `##` is now `#`
+
+- Temporarily disable generation of compiler docs due to build issue
+
+---

Old:

  rustc-1.18.0-src.tar.gz

New:

  rust-rpmlintrc
  rustc-1.19.0-src.tar.gz



Other differences:
--
++ rust.spec ++
--- /var/tmp/diff_new_pack.Vk1JWe/_old  2017-09-04 12:39:30.720587860 +0200
+++ /var/tmp/diff_new_pack.Vk1JWe/_new  2017-09-04 12:39:30.724587298 +0200
@@ -17,7 +17,7 @@
 #
 
 
-%global prev_rust 1.17.0
+%global prev_rust 1.18.0
 %global cargo_version 0.18.0
 %global abi gnu
 %ifarch s390x
@@ -44,9 +44,11 @@
 %endif
 %global rust_triple %{_arch}-unknown-linux-%{abi}
 %global dl_url https://static.rust-lang.org/dist
+%global common_libdir %{_prefix}/lib
+%global rustlibdir %{common_libdir}/rustlib
 %bcond_with bootstrap
 Name:   rust
-Version:1.18.0
+Version:1.19.0
 Release:0
 Summary:A systems programming language
 License:MIT or Apache-2.0
@@ -54,6 +56,7 @@
 Url:http://www.rust-lang.org
 Source0:

commit gpxsee for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package gpxsee for openSUSE:Factory checked 
in at 2017-09-04 12:39:23

Comparing /work/SRC/openSUSE:Factory/gpxsee (Old)
 and  /work/SRC/openSUSE:Factory/.gpxsee.new (New)


Package is "gpxsee"

Mon Sep  4 12:39:23 2017 rev:13 rq:520539 version:4.13

Changes:

--- /work/SRC/openSUSE:Factory/gpxsee/gpxsee.changes2017-08-28 
15:16:41.220757928 +0200
+++ /work/SRC/openSUSE:Factory/.gpxsee.new/gpxsee.changes   2017-09-04 
12:39:24.161510662 +0200
@@ -1,0 +2,6 @@
+Sun Sep  3 21:31:18 CEST 2017 - tu...@cbox.cz
+
+- Update to version 4.13
+  * Added support for high-resolution printing.
+
+---

Old:

  GPXSee-4.12.tar.gz

New:

  GPXSee-4.13.tar.gz



Other differences:
--
++ gpxsee.spec ++
--- /var/tmp/diff_new_pack.nPiAfU/_old  2017-09-04 12:39:25.021389685 +0200
+++ /var/tmp/diff_new_pack.nPiAfU/_new  2017-09-04 12:39:25.033387997 +0200
@@ -19,7 +19,7 @@
 # See also http://en.opensuse.org/openSUSE:Specfile_guidelines
 
 Name:   gpxsee
-Version:4.12
+Version:4.13
 Release:1
 Summary:GPS log files visualizing and analyzing tool
 License:GPL-3.0

++ GPXSee-4.12.tar.gz -> GPXSee-4.13.tar.gz ++
 2255 lines of diff (skipped)

++ debian.changelog ++
--- /var/tmp/diff_new_pack.nPiAfU/_old  2017-09-04 12:39:25.397336793 +0200
+++ /var/tmp/diff_new_pack.nPiAfU/_new  2017-09-04 12:39:25.397336793 +0200
@@ -1,3 +1,9 @@
+gpxsee (4.13) stable; urgency=low
+
+  * Added support for high-resolution printing.
+
+ -- Martin Tuma   Sun, 03 Sep 2017 21:33:01 +0200
+
 gpxsee (4.12) stable; urgency=low
 
   * Fixed broken LCC projection on southern hemisphere.

++ debian.control ++
--- /var/tmp/diff_new_pack.nPiAfU/_old  2017-09-04 12:39:25.461327790 +0200
+++ /var/tmp/diff_new_pack.nPiAfU/_new  2017-09-04 12:39:25.473326102 +0200
@@ -3,10 +3,11 @@
 Priority: optional
 Maintainer: Martin Tuma 
 Build-Depends: debhelper (>= 9), qtbase5-dev, qtbase5-dev-tools, qt5-qmake, 
qttools5-dev-tools, libqt5opengl5-dev
+Homepage: http://www.gpxsee.org
 
 Package: gpxsee
 Architecture: any
 Depends: ${shlibs:Depends}
-Description: GPX visualizing and analyzing tool
+Description: GPS log files visualizing and analyzing tool
  GPXSee is a Qt based tool for visualizing and analyzing GPX, TCX, FIT, KML, 
IGC, NMEA
  and Garmin CSV files.

++ gpxsee.dsc ++
--- /var/tmp/diff_new_pack.nPiAfU/_old  2017-09-04 12:39:25.637303032 +0200
+++ /var/tmp/diff_new_pack.nPiAfU/_new  2017-09-04 12:39:25.649301344 +0200
@@ -1,9 +1,9 @@
 Format: 1.0
 Source: gpxsee
-Version: 4.12
+Version: 4.13
 Binary: gpxsee
 Maintainer: Martin Tuma 
 Architecture: any
 Build-Depends: debhelper (>= 9), qtbase5-dev, qtbase5-dev-tools, qt5-qmake, 
qttools5-dev-tools, libqt5opengl5-dev
 Files:
-  0 GPXSee-4.12.tar.gz
+  0 GPXSee-4.13.tar.gz




commit votca-csgapps for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package votca-csgapps for openSUSE:Factory 
checked in at 2017-09-04 12:39:18

Comparing /work/SRC/openSUSE:Factory/votca-csgapps (Old)
 and  /work/SRC/openSUSE:Factory/.votca-csgapps.new (New)


Package is "votca-csgapps"

Mon Sep  4 12:39:18 2017 rev:9 rq:520514 version:1.4.1

Changes:

--- /work/SRC/openSUSE:Factory/votca-csgapps/votca-csgapps.changes  
2017-02-03 20:04:46.757133205 +0100
+++ /work/SRC/openSUSE:Factory/.votca-csgapps.new/votca-csgapps.changes 
2017-09-04 12:39:20.793984443 +0200
@@ -1,0 +2,6 @@
+Sun Sep  3 13:28:47 UTC 2017 - jungh...@votca.org
+
+- Upgrade to 1.4.1
+  * details: https://github.com/votca/csg/blob/master/CHANGELOG.md
+
+---

Old:

  votca-csgapps-1.4.tar.gz

New:

  votca-csgapps-1.4.1.tar.gz



Other differences:
--
++ votca-csgapps.spec ++
--- /var/tmp/diff_new_pack.HEkjwH/_old  2017-09-04 12:39:21.701856713 +0200
+++ /var/tmp/diff_new_pack.HEkjwH/_new  2017-09-04 12:39:21.701856713 +0200
@@ -2,7 +2,7 @@
 # spec file for package votca-csgapps
 #
 # Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
-# Copyright (c) 2013-2016 Christoph Junghans
+# Copyright (c) 2013-2017 Christoph Junghans
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,8 @@
 #
 
 Name:   votca-csgapps
-Version:1.4
-%define uversion 1.4
+Version:1.4.1
+%define uversion 1.4.1
 Release:0
 Summary:VOTCA coarse-graining engine applications
 Group:  Productivity/Scientific/Chemistry

++ votca-csgapps-1.4.tar.gz -> votca-csgapps-1.4.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/csgapps-1.4/.travis.yml new/csgapps-1.4.1/.travis.yml
--- old/csgapps-1.4/.travis.yml 2016-10-29 18:47:51.0 +0200
+++ new/csgapps-1.4.1/.travis.yml   2017-09-03 01:42:18.0 +0200
@@ -33,13 +33,13 @@
   - cm-super
   - doxygen
   - graphviz
-  - python-numpy
+  - ghostscript
   - gnuplot-nox
   - octave
 
 env:
   global:
-- HDF5_VERSION=1.8.14
+- HDF5_VERSION=1.8.18
 - GMX_MAX_THREADS=8
 - CCACHE_CPP2=yes #for clang
 - GVER=4.8
@@ -55,7 +55,7 @@
   - wget https://raw.githubusercontent.com/votca/buildutil/master/build.sh && 
chmod 755 build.sh
   - mkdir -p "$HOME/votca/src"
   - if [[ ${MINIMAL} != yes ]]; then 
-  wget -qO- 
https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-${HDF5_VERSION}/src/hdf5-${HDF5_VERSION}.tar.gz
 | tar -xz &&
+  wget -qO- 
https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-${HDF5_VERSION%.*}/hdf5-${HDF5_VERSION}/src/hdf5-${HDF5_VERSION}.tar.gz
 | tar -xz &&
   cd hdf5-${HDF5_VERSION} && ./configure --prefix=$HOME/hdf5 && make -j4 
&> /dev/null && make install && cd ..;
 fi
   - if [[ ${GMX_VERSION} =  ]]; then
@@ -65,9 +65,10 @@
 fi
   - if [[ ${MAN} ]]; then git clone --depth=1 
https://github.com/votca/doxygen.git "$HOME/votca/src/devdoc"; fi 
   - if [[ ${GVER} ]]; then export CC=gcc-${GVER}; export CXX=g++-${GVER}; fi
+  - pip install --user numpy
 
 script:
-  - PATH="$HOME/hdf5:$PATH" ./build.sh -Wu $([[ ${TRAVIS_BRANCH} = stable ]] 
|| echo "--dev") --prefix "$HOME/votca"
+  - PATH="$HOME/hdf5:$PATH" ./build.sh -Wu --prefix "$HOME/votca"
 ${TYPE:+-DCMAKE_BUILD_TYPE=${TYPE}}
 ${TEST:+--runtest=$TEST} ${WERROR:+--warn-to-errors} -DWITH_H5MD=ON 
${MINIMAL:+--minimal} ${MAN:+--devdoc}
 ${J:+-j$J} ${BDIR:+--builddir=$BDIR} ${NINJA:+--ninja} ${WALL:+--Wall} 
${GMX_VERSION:+--gmx-release ${GMX_VERSION}}
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/csgapps-1.4/CMakeLists.txt 
new/csgapps-1.4.1/CMakeLists.txt
--- old/csgapps-1.4/CMakeLists.txt  2016-10-29 18:47:51.0 +0200
+++ new/csgapps-1.4.1/CMakeLists.txt2017-09-03 01:42:18.0 +0200
@@ -2,7 +2,7 @@
 
 project(csgapps)
 
-set(PROJECT_VERSION "1.4")
+set(PROJECT_VERSION "1.4.1")
 
 set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/CMakeModules)
 




commit yast2-auth-client for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package yast2-auth-client for 
openSUSE:Factory checked in at 2017-09-04 12:39:29

Comparing /work/SRC/openSUSE:Factory/yast2-auth-client (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-auth-client.new (New)


Package is "yast2-auth-client"

Mon Sep  4 12:39:29 2017 rev:30 rq:520581 version:3.3.17

Changes:

--- /work/SRC/openSUSE:Factory/yast2-auth-client/yast2-auth-client.changes  
2016-10-14 09:06:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-auth-client.new/yast2-auth-client.changes 
2017-09-04 12:39:32.140388107 +0200
@@ -1,0 +2,35 @@
+Tue Aug 29 13:54:21 UTC 2017 - h...@suse.com
+
+- Bump to version 3.3.17 to fix two issues:
+  * Mistake in kerberos config file parser removes default_ccache_name
+key (bsc#1054436).
+  * PAM configuration did not allow local user login if pam_unix2 is
+in use (bsc#1056158).
+
+---
+Fri Jun 16 13:47:40 UTC 2017 - h...@suse.com
+
+- Bump to version 3.3.16 to fix minor issues across UI and backend:
+  * Fix misspelt kerberos option name "noaddresses".
+  * Improve UI captions, consistency.
+  * Introduce module name "auth" as an alias to "auth-client".
+  for bsc#1043211, bsc#1043184, bsc#1032733.
+
+---
+Tue May 23 13:00:19 UTC 2017 - h...@suse.com
+
+- Bump to version 3.3.15 to fix four issues:
+  * Correctly install sss name databases even in the presence of
+special NSS database directives (bsc#1024841).
+  * Fix missing translation of "Leave Domain" button (bsc#1038291).
+  * Do AD's DNS lookup in lower case (bsc#1038720).
+  * Understand XML data exported by SLES 12 SP0 (bsc#1040393).
+
+---
+Fri May 19 11:41:59 UTC 2017 - lsle...@suse.cz
+
+- Translation fix: Ruby gettext cannot extract translatable texts
+  from interpolated strings (bsc#1038077)
+- 3.3.14
+
+---

Old:

  yast2-auth-client-3.3.13.tar.bz2

New:

  yast2-auth-client-3.3.17.tar.bz2



Other differences:
--
++ yast2-auth-client.spec ++
--- /var/tmp/diff_new_pack.bQKLIz/_old  2017-09-04 12:39:32.708308206 +0200
+++ /var/tmp/diff_new_pack.bQKLIz/_new  2017-09-04 12:39:32.724305956 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package yast2-auth-client
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-auth-client
-Version:3.3.13
+Version:3.3.17
 Release:0
 Url:https://github.com/yast/yast-auth-client
 Summary:YaST2 - Centralised System Authentication Configuration

++ yast2-auth-client-3.3.13.tar.bz2 -> yast2-auth-client-3.3.17.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-auth-client-3.3.13/.travis.yml 
new/yast2-auth-client-3.3.17/.travis.yml
--- old/yast2-auth-client-3.3.13/.travis.yml2016-10-13 10:40:51.134014108 
+0200
+++ new/yast2-auth-client-3.3.17/.travis.yml2017-09-04 08:38:24.906690959 
+0200
@@ -1,14 +1,11 @@
-language: cpp
-compiler:
-- gcc
+sudo: required
+language: bash
+services:
+  - docker
+
 before_install:
-# disable rvm, use system Ruby
-- rvm reset
-- wget 
https://raw.githubusercontent.com/yast/yast-devtools/master/travis-tools/travis_setup.sh
-- sh ./travis_setup.sh -p "rake yast2-devtools yast2-testsuite yast2 
yast2-pam yast2-network" -g "rspec:3.3.0 yast-rake gettext"
+  - docker build -t yast-auth-client-image .
 script:
-- rake check:syntax
-- rake check:pot
-- rake check:license
-- rake test:unit
-
+  # the "yast-travis-ruby" script is included in the base yastdevel/ruby image
+  # see https://github.com/yast/docker-yast-ruby/blob/master/yast-travis-ruby
+  - docker run -it -e TRAVIS=1 -e TRAVIS_JOB_ID="$TRAVIS_JOB_ID" 
yast-auth-client-image yast-travis-ruby
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-auth-client-3.3.13/Dockerfile 
new/yast2-auth-client-3.3.17/Dockerfile
--- old/yast2-auth-client-3.3.13/Dockerfile 1970-01-01 01:00:00.0 
+0100
+++ new/yast2-auth-client-3.3.17/Dockerfile 2017-09-04 08:38:24.906690959 
+0200
@@ -0,0 +1,3 @@
+FROM yastdevel/ruby
+COPY . /usr/src/app
+
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit votca-xtp for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package votca-xtp for openSUSE:Factory 
checked in at 2017-09-04 12:39:20

Comparing /work/SRC/openSUSE:Factory/votca-xtp (Old)
 and  /work/SRC/openSUSE:Factory/.votca-xtp.new (New)


Package is "votca-xtp"

Mon Sep  4 12:39:20 2017 rev:2 rq:520515 version:1.4.1

Changes:

--- /work/SRC/openSUSE:Factory/votca-xtp/votca-xtp.changes  2017-02-03 
20:04:48.916829215 +0100
+++ /work/SRC/openSUSE:Factory/.votca-xtp.new/votca-xtp.changes 2017-09-04 
12:39:22.517741926 +0200
@@ -1,0 +2,7 @@
+Sun Sep  3 13:33:35 UTC 2017 - jungh...@votca.org
+
+- Upgrade to 1.4.1
+  * fix pkg-config file
+  * Details: https://github.com/votca/xtp/blob/master/CHANGELOG.md
+
+---

Old:

  votca-xtp-1.4.tar.gz
  votca-xtp-manual-1.4.pdf

New:

  votca-xtp-1.4.1.tar.gz
  votca-xtp-manual-1.4.1.pdf



Other differences:
--
++ votca-xtp.spec ++
--- /var/tmp/diff_new_pack.idHmuf/_old  2017-09-04 12:39:23.725571995 +0200
+++ /var/tmp/diff_new_pack.idHmuf/_new  2017-09-04 12:39:23.729571432 +0200
@@ -2,7 +2,6 @@
 # spec file for package votca-xtp
 #
 # Copyright (c) 2016-2017 SUSE LINUX GmbH, Nuernberg, Germany.
-# Copyright (c) 2016 Christoph Junghans
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,8 +17,8 @@
 
 
 Name:   votca-xtp
-Version:1.4
-%define uversion 1.4
+Version:1.4.1
+%define uversion 1.4.1
 Release:0
 Summary:VOTCA excitation and charge properties module
 License:Apache-2.0

++ votca-xtp-1.4.tar.gz -> votca-xtp-1.4.1.tar.gz ++
/work/SRC/openSUSE:Factory/votca-xtp/votca-xtp-1.4.tar.gz 
/work/SRC/openSUSE:Factory/.votca-xtp.new/votca-xtp-1.4.1.tar.gz differ: char 
12, line 1

++ votca-xtp-manual-1.4.pdf -> votca-xtp-manual-1.4.1.pdf ++
(binary differes)




commit votca-tools for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package votca-tools for openSUSE:Factory 
checked in at 2017-09-04 12:39:10

Comparing /work/SRC/openSUSE:Factory/votca-tools (Old)
 and  /work/SRC/openSUSE:Factory/.votca-tools.new (New)


Package is "votca-tools"

Mon Sep  4 12:39:10 2017 rev:9 rq:520512 version:1.4.1

Changes:

--- /work/SRC/openSUSE:Factory/votca-tools/votca-tools.changes  2017-02-03 
20:04:47.589016113 +0100
+++ /work/SRC/openSUSE:Factory/.votca-tools.new/votca-tools.changes 
2017-09-04 12:39:13.634991647 +0200
@@ -1,0 +2,7 @@
+Sun Sep  3 13:23:09 UTC 2017 - jungh...@votca.org
+
+- Upgrade to 1.4.1
+  * fix pkg-config files
+  * details: https://github.com/votca/csg/blob/master/CHANGELOG.md
+
+---

Old:

  votca-tools-1.4.tar.gz

New:

  votca-tools-1.4.1.tar.gz



Other differences:
--
++ votca-tools.spec ++
--- /var/tmp/diff_new_pack.1aVqCO/_old  2017-09-04 12:39:14.546863355 +0200
+++ /var/tmp/diff_new_pack.1aVqCO/_new  2017-09-04 12:39:14.550862793 +0200
@@ -2,7 +2,7 @@
 # spec file for package votca-tools
 #
 # Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
-# Copyright (c) 2013-2016 Christoph Junghans
+# Copyright (c) 2013-2017 Christoph Junghans
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,8 +21,8 @@
 #
 
 Name:   votca-tools
-Version:1.4
-%define uversion 1.4
+Version:1.4.1
+%define uversion 1.4.1
 Release:0
 Summary:VOTCA tools library
 Group:  Productivity/Scientific/Chemistry

++ votca-tools-1.4.tar.gz -> votca-tools-1.4.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tools-1.4/.travis.yml new/tools-1.4.1/.travis.yml
--- old/tools-1.4/.travis.yml   2016-10-29 18:47:46.0 +0200
+++ new/tools-1.4.1/.travis.yml 2017-09-02 20:49:40.0 +0200
@@ -31,13 +31,12 @@
   - texlive-latex-extra
   - doxygen
   - graphviz
-  - python-numpy
   - gnuplot-nox
   - octave
 
 env:
   global:
-- HDF5_VERSION=1.8.14
+- HDF5_VERSION=1.8.18
 - GMX_MAX_THREADS=8
 - CCACHE_CPP2=yes #for clang
 - GVER=4.8
@@ -57,14 +56,15 @@
   - wget https://raw.githubusercontent.com/votca/buildutil/master/build.sh && 
chmod 755 build.sh
   - mkdir -p "$HOME/votca/src"
   - if [[ ${MINIMAL} != yes ]]; then 
-  wget -qO- 
https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-${HDF5_VERSION}/src/hdf5-${HDF5_VERSION}.tar.gz
 | tar -xz &&
+  wget -qO- 
https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-${HDF5_VERSION%.*}/hdf5-${HDF5_VERSION}/src/hdf5-${HDF5_VERSION}.tar.gz
 | tar -xz &&
   cd hdf5-${HDF5_VERSION} && ./configure --prefix=$HOME/hdf5 && make -j4 
&> /dev/null && make install && cd ..;
 fi
   - if [[ ${MAN} ]]; then git clone --depth=1 
https://github.com/votca/doxygen.git "$HOME/votca/src/devdoc"; fi 
   - if [[ ${GVER} ]]; then export CC=gcc-${GVER}; export CXX=g++-${GVER}; fi
+  - pip install --user numpy
 
 script:
-  - PATH="$HOME/hdf5:$PATH" ./build.sh -Wu $([[ ${TRAVIS_BRANCH} = stable ]] 
|| echo "--dev") --prefix "$HOME/votca"
+  - PATH="$HOME/hdf5:$PATH" ./build.sh -Wu --prefix "$HOME/votca"
 ${TYPE:+-DCMAKE_BUILD_TYPE=${TYPE}}
 ${TEST:+--runtest=$TEST} ${WERROR:+--warn-to-errors} -DWITH_H5MD=ON 
${MINIMAL:+--minimal} ${MAN:+--devdoc}
 ${J:+-j$J} ${BDIR:+--builddir=$BDIR} ${NINJA:+--ninja} ${WALL:+--Wall} 
${GMX_VERSION:+--gmx-release ${GMX_VERSION}}
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tools-1.4/CMakeLists.txt 
new/tools-1.4.1/CMakeLists.txt
--- old/tools-1.4/CMakeLists.txt2016-10-29 18:47:46.0 +0200
+++ new/tools-1.4.1/CMakeLists.txt  2017-09-02 20:49:40.0 +0200
@@ -2,7 +2,7 @@
 
 project(votca-tools)
 
-set(PROJECT_VERSION "1.4")
+set(PROJECT_VERSION "1.4.1")
 string(REGEX REPLACE "^[1-9]+\\.([1-9]+).*$" "\\1" SOVERSION 
"${PROJECT_VERSION}")
 if (NOT ${SOVERSION} MATCHES "[1-9]+")
   message(FATAL_ERROR "Could not determind SOVERSION from ${PROJECT_VERSION}")
@@ -87,7 +87,7 @@
 
 if(MKL_FOUND)
   set(MKL_URL 
"http://software.intel.com/sites/default/files/managed/76/8c/intel-mkl-and-boost-example.zip;)
-  set(MKL_MD5 B957EE63A2167AD21B650B47726CD55C )
+  set(MKL_MD5 b957ee63a2167ad21b650b47726cd55c )
   set(MKL_FILE "intel-mkl-and-boost-example.zip")
   
   include(ExternalProject)
@@ -98,9 +98,10 @@
   BUILD_COMMAND ""
   INSTALL_COMMAND ""
   )
-  set(MKL_INCLUDE_DIR 

commit afl for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package afl for openSUSE:Factory checked in 
at 2017-09-04 12:39:06

Comparing /work/SRC/openSUSE:Factory/afl (Old)
 and  /work/SRC/openSUSE:Factory/.afl.new (New)


Package is "afl"

Mon Sep  4 12:39:06 2017 rev:38 rq:520490 version:2.51b

Changes:

--- /work/SRC/openSUSE:Factory/afl/afl.changes  2017-08-01 09:25:15.160768059 
+0200
+++ /work/SRC/openSUSE:Factory/.afl.new/afl.changes 2017-09-04 
12:39:09.651552081 +0200
@@ -1,0 +2,12 @@
+Sun Sep  3 12:08:41 UTC 2017 - astie...@suse.com
+
+- afl 2.51b:
+  * Make afl-tmin call setsid to prevent glibc traceback junk from
+showing up on the terminal
+- includes changes form 2.50b:
+  * Fix a timing corner case
+  * Address a libtokencap / pthreads incompatibility issue
+  * Add AFL_FAST_CAL.
+  * In-place resume now preserves .synced
+
+---

Old:

  afl-2.49b.tgz

New:

  afl-2.51b.tgz



Other differences:
--
++ afl.spec ++
--- /var/tmp/diff_new_pack.e8WNfC/_old  2017-09-04 12:39:11.247327570 +0200
+++ /var/tmp/diff_new_pack.e8WNfC/_new  2017-09-04 12:39:11.247327570 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   afl
-Version:2.49b
+Version:2.51b
 Release:0
 Summary:American fuzzy lop is a security-oriented fuzzer
 License:Apache-2.0

++ afl-2.49b.tgz -> afl-2.51b.tgz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/afl-2.49b/afl-fuzz.c new/afl-2.51b/afl-fuzz.c
--- old/afl-2.49b/afl-fuzz.c2017-07-01 03:55:06.0 +0200
+++ new/afl-2.51b/afl-fuzz.c2017-08-20 06:34:26.0 +0200
@@ -120,7 +120,8 @@
qemu_mode, /* Running in QEMU mode?*/
skip_requested,/* Skip request, via SIGUSR1*/
run_over10m,   /* Run time over 10 minutes?*/
-   persistent_mode;   /* Running in persistent mode?  */
+   persistent_mode,   /* Running in persistent mode?  */
+   fast_cal;  /* Try to calibrate faster? */
 
 static s32 out_fd,/* Persistent fd for out_file   */
dev_urandom_fd = -1,   /* Persistent fd for /dev/urandom   */
@@ -2433,11 +2434,14 @@
 
   /* Report outcome to caller. */
 
-  if (child_timed_out) return FAULT_TMOUT;
-
   if (WIFSIGNALED(status) && !stop_soon) {
+
 kill_signal = WTERMSIG(status);
+
+if (child_timed_out && kill_signal == SIGKILL) return FAULT_TMOUT;
+
 return FAULT_CRASH;
+
   }
 
   /* A somewhat nasty hack for MSAN, which doesn't support abort_on_error and
@@ -2548,7 +2552,7 @@
   q->cal_failed++;
 
   stage_name = "calibration";
-  stage_max  = CAL_CYCLES;
+  stage_max  = fast_cal ? 3 : CAL_CYCLES;
 
   /* Make sure the forkserver is up before we do anything, and let's not
  count its spin-up time toward binary calibration. */
@@ -3200,6 +3204,12 @@
 write_to_testcase(mem, len);
 new_fault = run_target(argv, hang_tmout);
 
+/* A corner case that one user reported bumping into: increasing the
+   timeout actually uncovers a crash. Make sure we don't discard it if
+   so. */
+
+if (!stop_soon && new_fault == FAULT_CRASH) goto keep_as_crash;
+
 if (stop_soon || new_fault != FAULT_TMOUT) return keeping;
 
   }
@@ -3224,6 +3234,8 @@
 
 case FAULT_CRASH:
 
+keep_as_crash:
+
   /* This is handled in a manner roughly similar to timeouts,
  except for slightly different limits and no need to re-run test
  cases. */
@@ -3689,9 +3701,13 @@
   /* Okay, let's get the ball rolling! First, we need to get rid of the entries
  in /.synced/.../id:*, if any are present. */
 
-  fn = alloc_printf("%s/.synced", out_dir);
-  if (delete_files(fn, NULL)) goto dir_cleanup_failed;
-  ck_free(fn);
+  if (!in_place_resume) {
+
+fn = alloc_printf("%s/.synced", out_dir);
+if (delete_files(fn, NULL)) goto dir_cleanup_failed;
+ck_free(fn);
+
+  }
 
   /* Next, we need to clean up /queue/.state/ subdirectories: */
 
@@ -4420,7 +4436,8 @@
 }
 
 
-/* Find first power of two greater or equal to val. */
+/* Find first power of two greater or equal to val (assuming val under
+   2^31). */
 
 static u32 next_p2(u32 val) {
 
@@ -7128,7 +7145,10 @@
   if (sync_id) {
 
 tmp = alloc_printf("%s/.synced/", out_dir);
-if (mkdir(tmp, 0700)) PFATAL("Unable to create '%s'", tmp);
+
+if (mkdir(tmp, 0700) && (!in_place_resume || errno != EEXIST))
+  PFATAL("Unable to create '%s'", tmp);
+
 ck_free(tmp);
 
   }
@@ -7883,8 +7903,9 @@
 
   if (getenv("AFL_NO_FORKSRV"))

commit rubygem-actionmailer-5_1 for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package rubygem-actionmailer-5_1 for 
openSUSE:Factory checked in at 2017-09-04 12:38:33

Comparing /work/SRC/openSUSE:Factory/rubygem-actionmailer-5_1 (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-actionmailer-5_1.new (New)


Package is "rubygem-actionmailer-5_1"

Mon Sep  4 12:38:33 2017 rev:1 rq:520467 version:5.1.3

Changes:

New Changes file:

--- /dev/null   2017-07-20 07:30:00.335470106 +0200
+++ 
/work/SRC/openSUSE:Factory/.rubygem-actionmailer-5_1.new/rubygem-actionmailer-5_1.changes
   2017-09-04 12:38:44.379107683 +0200
@@ -0,0 +1,161 @@
+---
+Fri Aug  4 08:40:12 UTC 2017 - cbruckma...@suse.com
+
+- update to version 5.1.3
+  see installed CHANGELOG.md
+
+---
+Sat Jun 24 06:13:56 UTC 2017 - adr...@suse.de
+
+- update to version 5.1.1
+
+---
+Fri Aug 12 04:29:25 UTC 2016 - co...@suse.com
+
+- updated to version 5.0.0.1
+ see installed CHANGELOG.md
+
+---
+Mon Jul  4 09:12:49 UTC 2016 - co...@suse.com
+
+- updated to rails 5.0 - see 
http://weblog.rubyonrails.org/2016/6/30/Rails-5-0-final/
+
+---
+Tue Mar  8 05:29:03 UTC 2016 - co...@suse.com
+
+- updated to version 4.2.6
+ see installed CHANGELOG.md
+
+  ## Rails 4.2.6 (March 07, 2016) ##
+  
+  *   No changes.
+
+---
+Tue Mar  1 05:29:41 UTC 2016 - co...@suse.com
+
+- updated to version 4.2.5.2
+ see installed CHANGELOG.md
+
+  ## Rails 4.2.5.2 (February 26, 2016) ##
+  
+  *   No changes.
+  
+  
+  ## Rails 4.2.5.1 (January 25, 2015) ##
+  
+  *   No changes.
+
+---
+Tue Jan 26 05:28:52 UTC 2016 - co...@suse.com
+
+- updated to version 4.2.5.1
+ see installed CHANGELOG.md
+
+---
+Sat Nov 14 05:28:36 UTC 2015 - co...@suse.com
+
+- updated to version 4.2.5
+ see installed CHANGELOG.md
+
+  ## Rails 4.2.5 (November 12, 2015) ##
+  
+  *   No changes.
+
+---
+Tue Aug 25 04:28:46 UTC 2015 - co...@suse.com
+
+- updated to version 4.2.4
+ see installed CHANGELOG.md
+
+  ## Rails 4.2.4 (August 24, 2015) ##
+  
+  * No Changes *
+
+---
+Fri Jun 26 04:29:03 UTC 2015 - co...@suse.com
+
+- updated to version 4.2.3
+ see installed CHANGELOG.md
+
+  ## Rails 4.2.3 (June 25, 2015) ##
+  
+  *   `assert_emails` in block form use the given number as expected value.
+  This makes the error message much easier to understand.
+  
+  *Yuji Yaginuma*
+  
+  *   Mailer preview now uses `url_for` to fix links to emails for apps 
running on
+  a subdirectory.
+  
+  *Remo Mueller*
+  
+  *   Mailer previews no longer crash when the `mail` method wasn't called
+  (`NullMail`).
+  
+  Fixes #19849.
+  
+  *Yves Senn*
+  
+  *   Make sure labels and values line up in mailer previews.
+  
+  *Yves Senn*
+
+---
+Wed Jun 17 04:29:13 UTC 2015 - co...@suse.com
+
+- updated to version 4.2.2
+ see installed CHANGELOG.md
+
+  ## Rails 4.2.2 (June 16, 2015) ##
+  
+  * No Changes *
+
+---
+Fri Mar 20 20:50:19 UTC 2015 - co...@suse.com
+
+- updated to version 4.2.1, no changes
+
+---
+Wed Jan 28 12:28:00 UTC 2015 - adr...@suse.de
+
+- update to version 4.2.0
+
+---
+Mon Jan 19 21:08:53 UTC 2015 - dmuel...@suse.com
+
+- update to 4.1.9:
+  * Attachments can be added while rendering the mail template.
+
+---
+Mon Nov 10 14:00:03 UTC 2014 - tboer...@suse.com
+
+- To get rails 4 running on SLE 11 i have switched the
+  rb_build_versions definition to rub21 as it is activated within
+  devel:languages:ruby. That way we can get running rails 4 on
+  SLE 11 too.
+
+---
+Tue Oct 14 10:05:05 UTC 2014 - co...@suse.com
+
+- updated to version 4.1.6
+ *   Make ActionMailer::Previews methods class methods. Previously they were
+ instance methods and ActionMailer tries to render a message when they
+ are called.
+ 
+ *Cristian Bica*
+ 
+ *   Raise an exception when attachments are added after `mail` was called.
+ This is a safeguard to 

commit perl-B-Hooks-OP-PPAddr for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-B-Hooks-OP-PPAddr for 
openSUSE:Factory checked in at 2017-09-04 12:37:15

Comparing /work/SRC/openSUSE:Factory/perl-B-Hooks-OP-PPAddr (Old)
 and  /work/SRC/openSUSE:Factory/.perl-B-Hooks-OP-PPAddr.new (New)


Package is "perl-B-Hooks-OP-PPAddr"

Mon Sep  4 12:37:15 2017 rev:7 rq:520453 version:0.06

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-B-Hooks-OP-PPAddr/perl-B-Hooks-OP-PPAddr.changes
2016-11-04 21:00:06.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.perl-B-Hooks-OP-PPAddr.new/perl-B-Hooks-OP-PPAddr.changes
   2017-09-04 12:37:22.938565623 +0200
@@ -1,0 +2,9 @@
+Sun Aug 27 05:06:16 UTC 2017 - co...@suse.com
+
+- updated to 0.06
+   see /usr/share/doc/packages/perl-B-Hooks-OP-PPAddr/Changes
+
+  0.06  2017-08-26 20:47:27Z
+- fix builds on older MSVC (PR#1; thanks, Stephan Loyd!)
+
+---

Old:

  B-Hooks-OP-PPAddr-0.05.tar.gz

New:

  B-Hooks-OP-PPAddr-0.06.tar.gz



Other differences:
--
++ perl-B-Hooks-OP-PPAddr.spec ++
--- /var/tmp/diff_new_pack.fR8q2Q/_old  2017-09-04 12:37:23.946423826 +0200
+++ /var/tmp/diff_new_pack.fR8q2Q/_new  2017-09-04 12:37:23.950423263 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-B-Hooks-OP-PPAddr
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,21 +17,20 @@
 
 
 Name:   perl-B-Hooks-OP-PPAddr
-Version:0.05
+Version:0.06
 Release:0
 %define cpan_name B-Hooks-OP-PPAddr
 Summary:Hook into opcode execution
 License:Artistic-1.0 or GPL-1.0+
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/B-Hooks-OP-PPAddr/
-Source0:
http://www.cpan.org/authors/id/E/ET/ETHER/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/E/ET/ETHER/%{cpan_name}-%{version}.tar.gz
 Source1:perl-B-Hooks-OP-PPAddr-rpmlintrc
 Source2:cpanspec.yml
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl
 BuildRequires:  perl-macros
 BuildRequires:  perl(ExtUtils::Depends) >= 0.302
-BuildRequires:  perl(Module::Metadata)
 BuildRequires:  perl(parent)
 Requires:   perl(parent)
 %{perl_requires}

++ B-Hooks-OP-PPAddr-0.05.tar.gz -> B-Hooks-OP-PPAddr-0.06.tar.gz ++
 2381 lines of diff (skipped)




commit mednafen for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package mednafen for openSUSE:Factory 
checked in at 2017-09-04 12:37:28

Comparing /work/SRC/openSUSE:Factory/mednafen (Old)
 and  /work/SRC/openSUSE:Factory/.mednafen.new (New)


Package is "mednafen"

Mon Sep  4 12:37:28 2017 rev:9 rq:520460 version:0.9.47

Changes:

--- /work/SRC/openSUSE:Factory/mednafen/mednafen.changes2017-08-30 
16:24:04.622114520 +0200
+++ /work/SRC/openSUSE:Factory/.mednafen.new/mednafen.changes   2017-09-04 
12:37:32.417232061 +0200
@@ -1,0 +2,5 @@
+Sun Sep  3 08:56:39 UTC 2017 - i...@ilya.pp.ua
+
+- Remove devel files from doc.
+
+---



Other differences:
--
++ mednafen.spec ++
--- /var/tmp/diff_new_pack.GOk4dM/_old  2017-09-04 12:37:33.237116710 +0200
+++ /var/tmp/diff_new_pack.GOk4dM/_new  2017-09-04 12:37:33.241116147 +0200
@@ -73,7 +73,7 @@
 
 %files doc
 %defattr(-,root,root)
-%doc Documentation/*
+%doc Documentation/?*.{css,def,html,png,txt}
 
 %files -f %{name}.lang lang
 %defattr(-,root,root)




commit perl-Date-Manip for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-Date-Manip for openSUSE:Factory 
checked in at 2017-09-04 12:37:23

Comparing /work/SRC/openSUSE:Factory/perl-Date-Manip (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Date-Manip.new (New)


Package is "perl-Date-Manip"

Mon Sep  4 12:37:23 2017 rev:48 rq:520457 version:6.60

Changes:

--- /work/SRC/openSUSE:Factory/perl-Date-Manip/perl-Date-Manip.changes  
2017-06-09 15:58:36.621481937 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Date-Manip.new/perl-Date-Manip.changes 
2017-09-04 12:37:28.833736226 +0200
@@ -1,0 +2,6 @@
+Sat Sep  2 05:24:28 UTC 2017 - co...@suse.com
+
+- updated to 6.60
+   see /usr/share/doc/packages/perl-Date-Manip/Changes
+
+---

Old:

  Date-Manip-6.59.tar.gz

New:

  Date-Manip-6.60.tar.gz



Other differences:
--
++ perl-Date-Manip.spec ++
--- /var/tmp/diff_new_pack.oGoqC4/_old  2017-09-04 12:37:29.609627065 +0200
+++ /var/tmp/diff_new_pack.oGoqC4/_new  2017-09-04 12:37:29.609627065 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Date-Manip
-Version:6.59
+Version:6.60
 Release:0
 %define cpan_name Date-Manip
 Summary:Date manipulation routines

++ Date-Manip-6.59.tar.gz -> Date-Manip-6.60.tar.gz ++
 23232 lines of diff (skipped)




commit rubygem-hashdiff for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package rubygem-hashdiff for 
openSUSE:Factory checked in at 2017-09-04 12:36:51

Comparing /work/SRC/openSUSE:Factory/rubygem-hashdiff (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-hashdiff.new (New)


Package is "rubygem-hashdiff"

Mon Sep  4 12:36:51 2017 rev:5 rq:520437 version:0.3.6

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-hashdiff/rubygem-hashdiff.changes
2017-06-08 15:01:42.198029968 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-hashdiff.new/rubygem-hashdiff.changes   
2017-09-04 12:36:53.602692912 +0200
@@ -1,0 +2,14 @@
+Sun Sep  3 09:04:56 UTC 2017 - co...@suse.com
+
+- updated to version 0.3.6
+ see installed changelog.md
+
+  ## v0.3.6 2017-08-22
+  
+  * add option `use_lcs` #35
+  
+  ## v0.3.5 2017-08-06
+  
+  * add option `array_path` #34
+
+---

Old:

  hashdiff-0.3.4.gem

New:

  hashdiff-0.3.6.gem



Other differences:
--
++ rubygem-hashdiff.spec ++
--- /var/tmp/diff_new_pack.CGFGmy/_old  2017-09-04 12:36:54.350587690 +0200
+++ /var/tmp/diff_new_pack.CGFGmy/_new  2017-09-04 12:36:54.350587690 +0200
@@ -24,7 +24,7 @@
 #
 
 Name:   rubygem-hashdiff
-Version:0.3.4
+Version:0.3.6
 Release:0
 %define mod_name hashdiff
 %define mod_full_name %{mod_name}-%{version}

++ hashdiff-0.3.4.gem -> hashdiff-0.3.6.gem ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/README.md new/README.md
--- old/README.md   2017-05-01 06:02:25.0 +0200
+++ new/README.md   2017-08-22 20:50:23.0 +0200
@@ -72,8 +72,8 @@
 patch example:
 
 ```ruby
-a = {a: 3}
-b = {a: {a1: 1, a2: 2}}
+a = {'a' => 3}
+b = {'a' => {'a1' => 1, 'a2' => 2}}
 
 diff = HashDiff.diff(a, b)
 HashDiff.patch!(a, diff).should == b
@@ -82,8 +82,8 @@
 unpatch example:
 
 ```ruby
-a = [{a: 1, b: 2, c: 3, d: 4, e: 5}, {x: 5, y: 6, z: 3}, 1]
-b = [1, {a: 1, b: 2, c: 3, e: 5}]
+a = [{'a' => 1, 'b' => 2, 'c' => 3, 'd' => 4, 'e' => 5}, {'x' => 5, 'y' => 6, 
'z' => 3}, 1]
+b = [1, {'a' => 1, 'b' => 2, 'c' => 3, 'e' => 5}]
 
 diff = HashDiff.diff(a, b) # diff two array is OK
 HashDiff.unpatch!(b, diff).should == a
@@ -91,8 +91,9 @@
 
 ### Options
 
-There are six options available: `:delimiter`, `:similarity`,
-`:strict`, `:numeric_tolerance`, `:strip` and `:case_insensitive`.
+There are seven options available: `:delimiter`, `:similarity`,
+`:strict`, `:numeric_tolerance`, `:strip`, `:case_insensitive`
+and `:array_path`.
 
  `:delimiter`
 
@@ -140,7 +141,7 @@
 
  `:case_insensitive`
 
-The :case_insensitive option makes string comparisions ignore case.
+The :case_insensitive option makes string comparisons ignore case.
 
 ```ruby
 a = {x:5, s:'FooBar'}
@@ -150,6 +151,39 @@
 diff.should == [["~", "x", 5, 6]]
 ```
 
+ `:array_path`
+
+The :array_path option represents the path of the diff in an array rather than
+a string. This can be used to show differences in between hash key types and
+is useful for `patch!` when used on hashes without string keys.
+
+```ruby
+a = {x:5}
+b = {'x'=>6}
+
+diff = HashDiff.diff(a, b, :array_path => true)
+diff.should == [['-', [:x], 5], ['+', ['x'], 6]]
+```
+
+For cases where there are arrays in paths their index will be added to the 
path.
+```ruby
+a = {x:[0,1]}
+b = {x:[0,2]}
+
+diff = HashDiff.diff(a, b, :array_path => true)
+diff.should == [["-", [:x, 1], 1], ["+", [:x, 1], 2]]
+```
+
+This shouldn't cause problems if you are comparing an array with a hash:
+
+```ruby
+a = {x:{0=>1}}
+b = {x:[1]}
+
+diff = HashDiff.diff(a, b, :array_path => true)
+diff.should == [["~", [:a], [1], {0=>1}]]
+```
+
  Specifying a custom comparison method
 
 It's possible to specify how the values of a key should be compared.
@@ -186,6 +220,8 @@
 
 When a comparison block is given, it'll be given priority over other specified 
options. If the block returns value other than `true` or `false`, then the two 
values will be compared with other specified options.
 
+When used in conjunction with the `array_path` option, the path passed in as 
an argument will be an array. When determining the ordering of an array a key 
of `"*"` will be used in place of the `key[*]` field. It is possible, if you 
have hashes with integer or `"*"` keys, to have problems distinguishing between 
arrays and hashes - although this shouldn't be an issue unless your data is 
very difficult to predict and/or your custom rules are very specific.
+
  Sorting arrays before comparison
 
 An order difference alone between two arrays can create too many diffs to be 
useful. Consider sorting them prior to diffing.
diff -urN '--exclude=CVS' 

commit perl-Cpanel-JSON-XS for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-Cpanel-JSON-XS for 
openSUSE:Factory checked in at 2017-09-04 12:37:11

Comparing /work/SRC/openSUSE:Factory/perl-Cpanel-JSON-XS (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Cpanel-JSON-XS.new (New)


Package is "perl-Cpanel-JSON-XS"

Mon Sep  4 12:37:11 2017 rev:8 rq:520451 version:3.0238

Changes:

--- /work/SRC/openSUSE:Factory/perl-Cpanel-JSON-XS/perl-Cpanel-JSON-XS.changes  
2017-08-28 15:10:32.952533985 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Cpanel-JSON-XS.new/perl-Cpanel-JSON-XS.changes 
2017-09-04 12:37:12.636015097 +0200
@@ -1,0 +2,10 @@
+Sat Aug 26 05:16:44 UTC 2017 - co...@suse.com
+
+- updated to 3.0238
+   see /usr/share/doc/packages/perl-Cpanel-JSON-XS/Changes
+
+  3.0238 2017-08-25 (rurban)
+  - Make printing of numbers on perl's earlier than 5.22 locale
+  insensitive, to produce a dot as decimal sep. (#96)
+
+---

Old:

  Cpanel-JSON-XS-3.0237.tar.gz

New:

  Cpanel-JSON-XS-3.0238.tar.gz



Other differences:
--
++ perl-Cpanel-JSON-XS.spec ++
--- /var/tmp/diff_new_pack.9nrW0X/_old  2017-09-04 12:37:13.271925631 +0200
+++ /var/tmp/diff_new_pack.9nrW0X/_new  2017-09-04 12:37:13.271925631 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Cpanel-JSON-XS
-Version:3.0237
+Version:3.0238
 Release:0
 %define cpan_name Cpanel-JSON-XS
 Summary:Cpanel Fork of Json::Xs, Fast and Correct Serializing

++ Cpanel-JSON-XS-3.0237.tar.gz -> Cpanel-JSON-XS-3.0238.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Cpanel-JSON-XS-3.0237/.appveyor.yml 
new/Cpanel-JSON-XS-3.0238/.appveyor.yml
--- old/Cpanel-JSON-XS-3.0237/.appveyor.yml 2017-07-27 22:15:44.0 
+0200
+++ new/Cpanel-JSON-XS-3.0238/.appveyor.yml 2017-07-29 17:18:21.0 
+0200
@@ -45,4 +45,4 @@
 build: off
 
 test_script:
-  - cmd: 'call t\appveyor-test.bat'
+  - 't\appveyor-test.bat'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Cpanel-JSON-XS-3.0237/.travis.yml 
new/Cpanel-JSON-XS-3.0238/.travis.yml
--- old/Cpanel-JSON-XS-3.0237/.travis.yml   2017-07-27 22:15:44.0 
+0200
+++ new/Cpanel-JSON-XS-3.0238/.travis.yml   2017-07-29 17:18:21.0 
+0200
@@ -59,7 +59,7 @@
 matrix:
   fast_finish: true
   include:
-- perl: "5.26"
+- perl: "5.18"
   env: COVERAGE=1 AUTHOR_TESTING=1  # enables coverage+coveralls reporting
   allow_failures:
 - env: COVERAGE=1 AUTHOR_TESTING=1
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Cpanel-JSON-XS-3.0237/Changes 
new/Cpanel-JSON-XS-3.0238/Changes
--- old/Cpanel-JSON-XS-3.0237/Changes   2017-07-28 11:20:18.0 +0200
+++ new/Cpanel-JSON-XS-3.0238/Changes   2017-08-25 21:36:52.0 +0200
@@ -2,6 +2,10 @@
 
 TODO: http://stevehanov.ca/blog/index.php?id=104 compression
 
+3.0238 2017-08-25 (rurban)
+- Make printing of numbers on perl's earlier than 5.22 locale
+insensitive, to produce a dot as decimal sep. (#96)
+
 3.0237 2017-07-28 (rurban)
 - relax inf/nan tests as in t/op/infnan.t for windows.
   we cannot know if msvcrt.dll or the new ucrt.dll is used.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Cpanel-JSON-XS-3.0237/META.json 
new/Cpanel-JSON-XS-3.0238/META.json
--- old/Cpanel-JSON-XS-3.0237/META.json 2017-07-28 13:14:53.0 +0200
+++ new/Cpanel-JSON-XS-3.0238/META.json 2017-08-25 22:52:34.0 +0200
@@ -48,6 +48,6 @@
  "url" : "https://github.com/rurban/Cpanel-JSON-XS;
   }
},
-   "version" : "3.0237",
+   "version" : "3.0238",
"x_serialization_backend" : "JSON::PP version 2.93"
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Cpanel-JSON-XS-3.0237/META.yml 
new/Cpanel-JSON-XS-3.0238/META.yml
--- old/Cpanel-JSON-XS-3.0237/META.yml  2017-07-28 13:14:53.0 +0200
+++ new/Cpanel-JSON-XS-3.0238/META.yml  2017-08-25 22:52:34.0 +0200
@@ -23,5 +23,5 @@
   bugtracker: https://github.com/rurban/Cpanel-JSON-XS/issues
   license: http://dev.perl.org/licenses/
   repository: https://github.com/rurban/Cpanel-JSON-XS
-version: '3.0237'
+version: '3.0238'
 x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Cpanel-JSON-XS-3.0237/README 
new/Cpanel-JSON-XS-3.0238/README
--- old/Cpanel-JSON-XS-3.0237/README2017-07-28 13:14:54.0 +0200
+++ new/Cpanel-JSON-XS-3.0238/README2017-08-25 

commit rubygem-addressable for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package rubygem-addressable for 
openSUSE:Factory checked in at 2017-09-04 12:37:03

Comparing /work/SRC/openSUSE:Factory/rubygem-addressable (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-addressable.new (New)


Package is "rubygem-addressable"

Mon Sep  4 12:37:03 2017 rev:17 rq:520448 version:2.5.2

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-addressable/rubygem-addressable.changes  
2017-04-17 10:25:31.960829918 +0200
+++ 
/work/SRC/openSUSE:Factory/.rubygem-addressable.new/rubygem-addressable.changes 
2017-09-04 12:37:04.681134276 +0200
@@ -1,0 +2,12 @@
+Sun Sep  3 08:54:03 UTC 2017 - co...@suse.com
+
+- updated to version 2.5.2
+ see installed CHANGELOG.md
+
+  # Addressable 2.5.2
+  - better support for frozen string literals
+  - fixed bug w/ uppercase characters in scheme
+  - IDNA errors w/ emoji URLs
+  - compatibility w/ public_suffix 3.x
+
+---

Old:

  addressable-2.5.1.gem

New:

  addressable-2.5.2.gem



Other differences:
--
++ rubygem-addressable.spec ++
--- /var/tmp/diff_new_pack.jxhLU5/_old  2017-09-04 12:37:05.369037494 +0200
+++ /var/tmp/diff_new_pack.jxhLU5/_new  2017-09-04 12:37:05.369037494 +0200
@@ -24,7 +24,7 @@
 #
 
 Name:   rubygem-addressable
-Version:2.5.1
+Version:2.5.2
 Release:0
 %define mod_name addressable
 %define mod_full_name %{mod_name}-%{version}

++ addressable-2.5.1.gem -> addressable-2.5.2.gem ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CHANGELOG.md new/CHANGELOG.md
--- old/CHANGELOG.md2017-03-29 23:14:40.0 +0200
+++ new/CHANGELOG.md2017-08-25 02:00:11.0 +0200
@@ -1,3 +1,9 @@
+# Addressable 2.5.2
+- better support for frozen string literals
+- fixed bug w/ uppercase characters in scheme
+- IDNA errors w/ emoji URLs
+- compatibility w/ public_suffix 3.x
+
 # Addressable 2.5.1
 - allow unicode normalization to be disabled for URI Template expansion
 - removed duplicate test
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Gemfile new/Gemfile
--- old/Gemfile 2017-03-29 23:14:40.0 +0200
+++ new/Gemfile 2017-08-25 02:00:11.0 +0200
@@ -29,4 +29,4 @@
   end
 end
 
-gem 'idn-ruby', :platform => [:mri_20, :mri_21, :mri_22]
+gem 'idn-ruby', :platform => [:mri_20, :mri_21, :mri_22, :mri_23, :mri_24]
Binary files old/checksums.yaml.gz and new/checksums.yaml.gz differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/addressable/idna/native.rb 
new/lib/addressable/idna/native.rb
--- old/lib/addressable/idna/native.rb  2017-03-29 23:14:40.0 +0200
+++ new/lib/addressable/idna/native.rb  2017-08-25 02:00:11.0 +0200
@@ -35,7 +35,7 @@
 def self.to_ascii(value)
   value.to_s.split('.', -1).map do |segment|
 if segment.size > 0 && segment.size < 64
-  IDN::Idna.toASCII(segment)
+  IDN::Idna.toASCII(segment, IDN::Idna::ALLOW_UNASSIGNED)
 elsif segment.size >= 64
   segment
 else
@@ -47,7 +47,7 @@
 def self.to_unicode(value)
   value.to_s.split('.', -1).map do |segment|
 if segment.size > 0 && segment.size < 64
-  IDN::Idna.toUnicode(segment)
+  IDN::Idna.toUnicode(segment, IDN::Idna::ALLOW_UNASSIGNED)
 elsif segment.size >= 64
   segment
 else
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/addressable/template.rb 
new/lib/addressable/template.rb
--- old/lib/addressable/template.rb 2017-03-29 23:14:40.0 +0200
+++ new/lib/addressable/template.rb 2017-08-25 02:00:11.0 +0200
@@ -743,7 +743,7 @@
 
   vars
 .zip(operator_sequence(operator).take(vars.length))
-.reduce("") do |acc, (varspec, op)|
+.reduce("".dup) do |acc, (varspec, op)|
   _, name, _ =  *varspec.match(VARSPEC)
 
   acc << if mapping.key? name
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/addressable/uri.rb new/lib/addressable/uri.rb
--- old/lib/addressable/uri.rb  2017-03-29 23:14:40.0 +0200
+++ new/lib/addressable/uri.rb  2017-08-25 02:00:11.0 +0200
@@ -436,7 +436,7 @@
   uri = uri.dup
   # Seriously, only use UTF-8. I'm really not kidding!
   uri.force_encoding("utf-8")
-  leave_encoded.force_encoding("utf-8")
+  leave_encoded = leave_encoded.dup.force_encoding("utf-8")
   result = uri.gsub(/%[0-9a-f]{2}/iu) do |sequence|
 c = sequence[1..3].to_i(16).chr
 

commit perl-JSON-XS for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-JSON-XS for openSUSE:Factory 
checked in at 2017-09-04 12:36:33

Comparing /work/SRC/openSUSE:Factory/perl-JSON-XS (Old)
 and  /work/SRC/openSUSE:Factory/.perl-JSON-XS.new (New)


Package is "perl-JSON-XS"

Mon Sep  4 12:36:33 2017 rev:20 rq:520423 version:3.04

Changes:

--- /work/SRC/openSUSE:Factory/perl-JSON-XS/perl-JSON-XS.changes
2016-11-18 22:02:56.0 +0100
+++ /work/SRC/openSUSE:Factory/.perl-JSON-XS.new/perl-JSON-XS.changes   
2017-09-04 12:36:37.676933521 +0200
@@ -1,0 +2,19 @@
+Fri Aug 18 05:38:04 UTC 2017 - co...@suse.com
+
+- updated to 3.04
+   see /usr/share/doc/packages/perl-JSON-XS/Changes
+
+  TODO: move json_xs to types::serialiser
+  
+  3.04 Thu Aug 17 04:30:47 CEST 2017
+   - change exponential realloc algorithm on encoding and string decoding 
to be
+really exponential (this helps slow/debugging allocators such as 
libumem)
+(reported by Matthew Horsfall).
+  - string encoding would needlessly overallocate output space
+(testcase by Matthew Horsfall).
+  - be very paranoid about extending buffer lengths and croak if 
buffers get too large,
+which might (or might not) improve security.
+   - add cbor-packed type to json_xs.
+  - switch from YAML to YAML::XS in json_xs, as YAML is way too buggy 
and outdated.
+
+---

Old:

  JSON-XS-3.03.tar.gz

New:

  JSON-XS-3.04.tar.gz



Other differences:
--
++ perl-JSON-XS.spec ++
--- /var/tmp/diff_new_pack.WiLovY/_old  2017-09-04 12:36:39.140727578 +0200
+++ /var/tmp/diff_new_pack.WiLovY/_new  2017-09-04 12:36:39.152725890 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-JSON-XS
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-JSON-XS
-Version:3.03
+Version:3.04
 Release:0
 #Upstream: CHECK(GPL-1.0+ or Artistic-1.0)
 %define cpan_name JSON-XS
@@ -25,7 +25,7 @@
 License:Artistic-1.0 or GPL-1.0+
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/JSON-XS/
-Source0:
http://www.cpan.org/authors/id/M/ML/MLEHMANN/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/M/ML/MLEHMANN/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl
@@ -47,7 +47,7 @@
 overridden) with no overhead due to emulation (by inheriting constructor
 and methods). If JSON::XS is not available, it will fall back to the
 compatible JSON::PP module as backend, so using JSON instead of JSON::XS
-gives you a portable JSON API that can be fast when you need and doesn't
+gives you a portable JSON API that can be fast when you need it and doesn't
 require a C compiler when that is a problem.
 
 As this is the n-th-something JSON module on CPAN, what was the reason to
@@ -77,6 +77,7 @@
 
 %files -f %{name}.files
 %defattr(-,root,root,755)
-%doc Changes COPYING README
+%doc Changes README
+%license COPYING
 
 %changelog

++ JSON-XS-3.03.tar.gz -> JSON-XS-3.04.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/JSON-XS-3.03/Changes new/JSON-XS-3.04/Changes
--- old/JSON-XS-3.03/Changes2016-11-16 20:21:23.0 +0100
+++ new/JSON-XS-3.04/Changes2017-08-17 04:31:27.0 +0200
@@ -7,6 +7,18 @@
 TODO: investigate magic (Eric Brine)
 TODO: rfc7464
 TODO: Victor Efimov
+TODO: move json_xs to types::serialiser
+
+3.04 Thu Aug 17 04:30:47 CEST 2017
+   - change exponential realloc algorithm on encoding and string decoding 
to be
+  really exponential (this helps slow/debugging allocators such as 
libumem)
+  (reported by Matthew Horsfall).
+- string encoding would needlessly overallocate output space
+  (testcase by Matthew Horsfall).
+- be very paranoid about extending buffer lengths and croak if buffers 
get too large,
+  which might (or might not) improve security.
+   - add cbor-packed type to json_xs.
+- switch from YAML to YAML::XS in json_xs, as YAML is way too buggy 
and outdated.
 
 3.03 Wed Nov 16 20:20:59 CET 2016
- fix a bug introduced by a perl bug workaround that would cause
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/JSON-XS-3.03/META.json 

commit perl-App-Nopaste for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-App-Nopaste for 
openSUSE:Factory checked in at 2017-09-04 12:37:13

Comparing /work/SRC/openSUSE:Factory/perl-App-Nopaste (Old)
 and  /work/SRC/openSUSE:Factory/.perl-App-Nopaste.new (New)


Package is "perl-App-Nopaste"

Mon Sep  4 12:37:13 2017 rev:15 rq:520452 version:1.011

Changes:

--- /work/SRC/openSUSE:Factory/perl-App-Nopaste/perl-App-Nopaste.changes
2017-08-24 18:52:31.176400854 +0200
+++ /work/SRC/openSUSE:Factory/.perl-App-Nopaste.new/perl-App-Nopaste.changes   
2017-09-04 12:37:14.363772017 +0200
@@ -1,0 +2,9 @@
+Sun Aug 27 05:03:53 UTC 2017 - co...@suse.com
+
+- updated to 1.011
+   see /usr/share/doc/packages/perl-App-Nopaste/Changes
+
+  1.011   2017-08-26 20:31:37Z
+  - fix formatting of script pod
+
+---

Old:

  App-Nopaste-1.010.tar.gz

New:

  App-Nopaste-1.011.tar.gz



Other differences:
--
++ perl-App-Nopaste.spec ++
--- /var/tmp/diff_new_pack.MFcn9P/_old  2017-09-04 12:37:15.443620093 +0200
+++ /var/tmp/diff_new_pack.MFcn9P/_new  2017-09-04 12:37:15.467616717 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-App-Nopaste
-Version:1.010
+Version:1.011
 Release:0
 %define cpan_name App-Nopaste
 Summary:Easy access to any pastebin

++ App-Nopaste-1.010.tar.gz -> App-Nopaste-1.011.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/App-Nopaste-1.010/CONTRIBUTING 
new/App-Nopaste-1.011/CONTRIBUTING
--- old/App-Nopaste-1.010/CONTRIBUTING  2017-08-02 06:38:56.0 +0200
+++ new/App-Nopaste-1.011/CONTRIBUTING  2017-08-26 22:31:43.0 +0200
@@ -96,4 +96,4 @@
 
 
 This file was generated via Dist::Zilla::Plugin::GenerateFile::FromShareDir 
0.013 from a
-template file originating in Dist-Zilla-PluginBundle-Author-ETHER-0.126.
+template file originating in Dist-Zilla-PluginBundle-Author-ETHER-0.129.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/App-Nopaste-1.010/Changes 
new/App-Nopaste-1.011/Changes
--- old/App-Nopaste-1.010/Changes   2017-08-02 06:38:56.0 +0200
+++ new/App-Nopaste-1.011/Changes   2017-08-26 22:31:43.0 +0200
@@ -1,5 +1,8 @@
 Revision history for App-Nopaste
 
+1.011   2017-08-26 20:31:37Z
+- fix formatting of script pod
+
 1.010   2017-08-02 04:38:50Z
 - fix shebang in 'nopaste' executable
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/App-Nopaste-1.010/META.json 
new/App-Nopaste-1.011/META.json
--- old/App-Nopaste-1.010/META.json 2017-08-02 06:38:56.0 +0200
+++ new/App-Nopaste-1.011/META.json 2017-08-26 22:31:43.0 +0200
@@ -73,7 +73,7 @@
   },
   "develop" : {
  "recommends" : {
-"Dist::Zilla::PluginBundle::Author::ETHER" : "0.126"
+"Dist::Zilla::PluginBundle::Author::ETHER" : "0.129"
  },
  "requires" : {
 "Browser::Open" : "0",
@@ -148,6 +148,7 @@
 "Dist::Zilla::Plugin::UploadToCPAN" : "0",
 "Dist::Zilla::Plugin::UseUnsafeInc" : "0",
 "Dist::Zilla::PluginBundle::Author::ETHER" : "0.097",
+"Dist::Zilla::PluginBundle::Git::VersionManager" : "0",
 "File::Spec" : "0",
 "IO::Handle" : "0",
 "IPC::Open3" : "0",
@@ -164,8 +165,7 @@
 "Test::Pod" : "1.41",
 "Test::Portability::Files" : "0",
 "Test::Spelling" : "0.12",
-"WWW::Pastebin::PastebinCom::Create" : "1.003",
-"blib" : "1.01"
+"WWW::Pastebin::PastebinCom::Create" : "1.003"
  }
   },
   "runtime" : {
@@ -212,56 +212,56 @@
"provides" : {
   "App::Nopaste" : {
  "file" : "lib/App/Nopaste.pm",
- "version" : "1.010"
+ "version" : "1.011"
   },
   "App::Nopaste::Command" : {
  "file" : "lib/App/Nopaste/Command.pm",
- "version" : "1.010"
+ "version" : "1.011"
   },
   "App::Nopaste::Service" : {
  "file" : "lib/App/Nopaste/Service.pm",
- "version" : "1.010"
+ "version" : "1.011"
   },
   "App::Nopaste::Service::Codepeek" : {
  "file" : "lib/App/Nopaste/Service/Codepeek.pm",
- "version" : "1.010",
+ "version" : "1.011",
  "x_deprecated" : 1
   },
   "App::Nopaste::Service::Debian" : {
  "file" : "lib/App/Nopaste/Service/Debian.pm",
- "version" : "1.010"
+ "version" : "1.011"
   },
   "App::Nopaste::Service::Gist" : {
  "file" : 

commit rubygem-exception_notification for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package rubygem-exception_notification for 
openSUSE:Factory checked in at 2017-09-04 12:36:54

Comparing /work/SRC/openSUSE:Factory/rubygem-exception_notification (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-exception_notification.new (New)


Package is "rubygem-exception_notification"

Mon Sep  4 12:36:54 2017 rev:17 rq:520442 version:4.2.2

Changes:

--- 
/work/SRC/openSUSE:Factory/rubygem-exception_notification/rubygem-exception_notification.changes
2016-07-30 00:27:30.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.rubygem-exception_notification.new/rubygem-exception_notification.changes
   2017-09-04 12:36:55.882372182 +0200
@@ -1,0 +2,13 @@
+Sun Sep  3 09:00:32 UTC 2017 - co...@suse.com
+
+- updated to version 4.2.2
+ see installed CHANGELOG.rdoc
+
+  == 4.2.2
+  
+  * enhancements
+* Error groupiong (by @Martin91)
+* Additional fields for Slack support (by @schurig)
+* Enterprise HipChat support (by @seanhuber)
+
+---

Old:

  exception_notification-4.2.1.gem

New:

  exception_notification-4.2.2.gem



Other differences:
--
++ rubygem-exception_notification.spec ++
--- /var/tmp/diff_new_pack.ORpWOh/_old  2017-09-04 12:36:56.786245015 +0200
+++ /var/tmp/diff_new_pack.ORpWOh/_new  2017-09-04 12:36:56.786245015 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package rubygem-exception_notification
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,7 +24,7 @@
 #
 
 Name:   rubygem-exception_notification
-Version:4.2.1
+Version:4.2.2
 Release:0
 %define mod_name exception_notification
 %define mod_full_name %{mod_name}-%{version}

++ exception_notification-4.2.1.gem -> exception_notification-4.2.2.gem 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CHANGELOG.rdoc new/CHANGELOG.rdoc
--- old/CHANGELOG.rdoc  2016-07-18 01:26:10.0 +0200
+++ new/CHANGELOG.rdoc  2017-08-12 22:52:29.0 +0200
@@ -1,3 +1,10 @@
+== 4.2.2
+
+* enhancements
+  * Error groupiong (by @Martin91)
+  * Additional fields for Slack support (by @schurig)
+  * Enterprise HipChat support (by @seanhuber)
+
 == 4.2.1
 
 * enhancements
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CONTRIBUTING.md new/CONTRIBUTING.md
--- old/CONTRIBUTING.md 2016-07-18 01:26:10.0 +0200
+++ new/CONTRIBUTING.md 2017-08-12 22:52:29.0 +0200
@@ -30,8 +30,9 @@
   bundle
   cd test/dummy
   bundle
-  bundle exec rake db:reset
-  bundle exec rake db:test:prepare
+  bundle exec rake db:reset db:test:prepare
+  cd ../..
+  bundle exec rake test
   ```
 * Create a topic branch from where you want to base your work.
 * Add a test for your change. Only refactoring and documentation changes
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/README.md new/README.md
--- old/README.md   2016-07-18 01:26:10.0 +0200
+++ new/README.md   2017-08-12 22:52:29.0 +0200
@@ -82,7 +82,7 @@
 
 ## Notifiers
 
-ExceptionNotification relies on notifiers to deliver notifications when errors 
occur in your applications. By default, six notifiers are available:
+ExceptionNotification relies on notifiers to deliver notifications when errors 
occur in your applications. By default, 7 notifiers are available:
 
 * [Campfire notifier](#campfire-notifier)
 * [Email notifier](#email-notifier)
@@ -279,6 +279,12 @@
 
 If enabled, remove numbers from subject so they thread as a single one. Use 
`:normalize_subject => true` to enable it.
 
+# include_controller_and_action_names_in_subject
+
+*Boolean, default: true*
+
+If enabled, include the controller and action names in the subject. Use 
`:include_controller_and_action_names_in_subject => false` to exclude them.
+
 # email_format
 
 *Symbol, default: :text*
@@ -393,6 +399,12 @@
 
 Message will appear from this nickname. Default : 'Exception'.
 
+# server_url
+
+*String, optional*
+
+Custom Server URL for self-hosted, Enterprise HipChat Server
+
 For all options & possible values see [Hipchat 
API](https://www.hipchat.com/docs/api/method/rooms/message).
 
 ### IRC notifier
@@ -590,6 +602,12 @@
 
 Contains additional payload for a message (e.g avatar, attachments, etc). See 
[slack-notifier](https://github.com/stevenosloan/slack-notifier#additional-parameters)
 for more information.. Default: '{}'
 

commit perl-Text-SpellChecker for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-Text-SpellChecker for 
openSUSE:Factory checked in at 2017-09-04 12:36:29

Comparing /work/SRC/openSUSE:Factory/perl-Text-SpellChecker (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Text-SpellChecker.new (New)


Package is "perl-Text-SpellChecker"

Mon Sep  4 12:36:29 2017 rev:7 rq:520422 version:0.14

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Text-SpellChecker/perl-Text-SpellChecker.changes
2015-04-25 14:09:11.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Text-SpellChecker.new/perl-Text-SpellChecker.changes
   2017-09-04 12:36:29.758047636 +0200
@@ -1,0 +2,5 @@
+Fri Aug 18 09:16:05 UTC 2017 - tchva...@suse.com
+
+- Drop dependency over aspell wrt fate#323578
+
+---



Other differences:
--
++ perl-Text-SpellChecker.spec ++
--- /var/tmp/diff_new_pack.xIR0tj/_old  2017-09-04 12:36:31.297831002 +0200
+++ /var/tmp/diff_new_pack.xIR0tj/_new  2017-09-04 12:36:31.325827064 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Text-SpellChecker
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,23 +16,20 @@
 #
 
 
+%define cpan_name Text-SpellChecker
 Name:   perl-Text-SpellChecker
 Version:0.14
 Release:0
-%define cpan_name Text-SpellChecker
 Summary:OO interface for spell-checking a block of text
-License:Artistic-1.0 or GPL-1.0+
+License:Artistic-1.0 OR GPL-1.0+
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/Text-SpellChecker/
 Source: 
http://www.cpan.org/authors/id/B/BD/BDUGGAN/%{cpan_name}-%{version}.tar.gz
-BuildArch:  noarch
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl
 BuildRequires:  perl-macros
-BuildRequires:  perl(Text::Aspell)
 BuildRequires:  perl(Text::Hunspell)
-Requires:   perl(Text::Aspell)
 Requires:   perl(Text::Hunspell)
+BuildArch:  noarch
 %{perl_requires}
 
 %description
@@ -49,11 +46,11 @@
 %setup -q -n %{cpan_name}-%{version}
 
 %build
-%{__perl} Makefile.PL INSTALLDIRS=vendor
-%{__make} %{?_smp_mflags}
+perl Makefile.PL INSTALLDIRS=vendor
+make %{?_smp_mflags}
 
 %check
-%{__make} test
+make %{?_smp_mflags} test
 
 %install
 %perl_make_install
@@ -61,7 +58,6 @@
 %perl_gen_filelist
 
 %files -f %{name}.files
-%defattr(-,root,root,755)
 %doc Changes README
 
 %changelog




commit perl-Test-Spec for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-Test-Spec for openSUSE:Factory 
checked in at 2017-09-04 12:36:39

Comparing /work/SRC/openSUSE:Factory/perl-Test-Spec (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Test-Spec.new (New)


Package is "perl-Test-Spec"

Mon Sep  4 12:36:39 2017 rev:13 rq:520424 version:0.52

Changes:

--- /work/SRC/openSUSE:Factory/perl-Test-Spec/perl-Test-Spec.changes
2015-08-02 22:46:18.0 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Test-Spec.new/perl-Test-Spec.changes   
2017-09-04 12:36:39.900620668 +0200
@@ -1,0 +2,14 @@
+Wed Aug 16 06:18:21 UTC 2017 - co...@suse.com
+
+- updated to 0.52
+   see /usr/share/doc/packages/perl-Test-Spec/Changes
+
+  0.52 Tue Aug 15 10:20:00 BST 2017
+- Pass example instance to each test
+  Contributed by @jamhed (issue #30, #41)
+- Fix runtests to run all examples that match any of the patterns
+  Contributed by @mpw96 (issue #37, #38)
+- Ensure META.json includes requirements
+  Reported by @joelrebel (issue #39)
+
+---

Old:

  Test-Spec-0.51.tar.gz

New:

  Test-Spec-0.52.tar.gz



Other differences:
--
++ perl-Test-Spec.spec ++
--- /var/tmp/diff_new_pack.8esxnb/_old  2017-09-04 12:36:41.196438358 +0200
+++ /var/tmp/diff_new_pack.8esxnb/_new  2017-09-04 12:36:41.204437233 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Test-Spec
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,14 @@
 
 
 Name:   perl-Test-Spec
-Version:0.51
+Version:0.52
 Release:0
 %define cpan_name Test-Spec
 Summary:Write tests in a declarative specification style
 License:Artistic-1.0 or GPL-1.0+
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/Test-Spec/
-Source0:
http://www.cpan.org/authors/id/A/AN/ANDYJONES/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/A/AN/ANDYJONES/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -57,7 +57,7 @@
 
 %prep
 %setup -q -n %{cpan_name}-%{version}
-find . -type f -print0 | xargs -0 chmod 644
+find . -type f ! -name \*.pl -print0 | xargs -0 chmod 644
 
 %build
 %{__perl} Makefile.PL INSTALLDIRS=vendor

++ Test-Spec-0.51.tar.gz -> Test-Spec-0.52.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-Spec-0.51/Changes new/Test-Spec-0.52/Changes
--- old/Test-Spec-0.51/Changes  2015-07-27 21:07:38.0 +0200
+++ new/Test-Spec-0.52/Changes  2017-08-15 11:51:50.0 +0200
@@ -1,5 +1,13 @@
 Revision history for Perl extension Test::Spec.
 
+0.52 Tue Aug 15 10:20:00 BST 2017
+  - Pass example instance to each test
+Contributed by @jamhed (issue #30, #41)
+  - Fix runtests to run all examples that match any of the patterns
+Contributed by @mpw96 (issue #37, #38)
+  - Ensure META.json includes requirements
+Reported by @joelrebel (issue #39)
+
 0.51 Mon Jul 27 20:05:00 BST 2015
   - Fixed top level describe blocks running out of order
 Contributed by @mla (issue #28)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-Spec-0.51/MANIFEST new/Test-Spec-0.52/MANIFEST
--- old/Test-Spec-0.51/MANIFEST 2015-07-27 21:14:00.0 +0200
+++ new/Test-Spec-0.52/MANIFEST 2017-08-15 11:54:25.0 +0200
@@ -17,9 +17,12 @@
 t/disabled_spec.pl
 t/dying_spec.pl
 t/empty.t
+t/example_in_handler.t
 t/helper_test.pl
 t/import_strict.t
 t/import_warnings.t
+t/manifest.t
+t/meta.t
 t/mocks.t
 t/mocks_imports.t
 t/ordering.t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-Spec-0.51/META.json new/Test-Spec-0.52/META.json
--- old/Test-Spec-0.51/META.json2015-07-27 21:14:00.0 +0200
+++ new/Test-Spec-0.52/META.json2017-08-15 11:54:25.0 +0200
@@ -4,13 +4,13 @@
   "Philip Garrett "
],
"dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 6.6302, CPAN::Meta::Converter 
version 2.120630",
+   "generated_by" : "ExtUtils::MakeMaker version 7.3, CPAN::Meta::Converter 
version 2.150010",
"license" : [
   "perl_5"
],
"meta-spec" : {
   "url" : "http://search.cpan.org/perldoc?CPAN::Meta::Spec;,
-  "version" : "2"
+  "version" : 2

commit perl-App-MFILE-WWW for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-App-MFILE-WWW for 
openSUSE:Factory checked in at 2017-09-04 12:37:08

Comparing /work/SRC/openSUSE:Factory/perl-App-MFILE-WWW (Old)
 and  /work/SRC/openSUSE:Factory/.perl-App-MFILE-WWW.new (New)


Package is "perl-App-MFILE-WWW"

Mon Sep  4 12:37:08 2017 rev:6 rq:520450 version:0.157

Changes:

--- /work/SRC/openSUSE:Factory/perl-App-MFILE-WWW/perl-App-MFILE-WWW.changes
2017-03-28 15:21:27.328081480 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-App-MFILE-WWW.new/perl-App-MFILE-WWW.changes   
2017-09-04 12:37:09.720425294 +0200
@@ -1,0 +2,18 @@
+Sat Aug 26 05:04:00 UTC 2017 - co...@suse.com
+
+- updated to 0.157
+   see /usr/share/doc/packages/perl-App-MFILE-WWW/Changes
+
+  
+  0.157 2017-08-25 14:01 CEST
+  - doc: start documenting the JavaScript primitives
+  - Implement target stack feature (major refactor)
+  - lib.js: implement isObjEmpty()
+  - stack.js: handle undefined and null obj in push()
+  - start.js: dform restore state only if rememberState is true
+  - stack: unsetFoo functions take no argument
+  - stack: make unwindToTarget take an optional obj argument
+  - stack: implement grep function
+  - stack,start: cleanup
+
+---

Old:

  App-MFILE-WWW-0.156.tar.gz

New:

  App-MFILE-WWW-0.157.tar.gz



Other differences:
--
++ perl-App-MFILE-WWW.spec ++
--- /var/tmp/diff_new_pack.1tsqrd/_old  2017-09-04 12:37:10.468320072 +0200
+++ /var/tmp/diff_new_pack.1tsqrd/_new  2017-09-04 12:37:10.472319510 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-App-MFILE-WWW
-Version:0.156
+Version:0.157
 Release:0
 %define cpan_name App-MFILE-WWW
 Summary:Web UI development toolkit with prototype demo app

++ App-MFILE-WWW-0.156.tar.gz -> App-MFILE-WWW-0.157.tar.gz ++
 2730 lines of diff (skipped)




commit perl-Log-Dispatch-FileRotate for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-Log-Dispatch-FileRotate for 
openSUSE:Factory checked in at 2017-09-04 12:36:46

Comparing /work/SRC/openSUSE:Factory/perl-Log-Dispatch-FileRotate (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Log-Dispatch-FileRotate.new (New)


Package is "perl-Log-Dispatch-FileRotate"

Mon Sep  4 12:36:46 2017 rev:24 rq:520427 version:1.30

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Log-Dispatch-FileRotate/perl-Log-Dispatch-FileRotate.changes
2017-08-28 15:10:35.276207103 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Log-Dispatch-FileRotate.new/perl-Log-Dispatch-FileRotate.changes
   2017-09-04 12:36:47.483553819 +0200
@@ -1,0 +2,14 @@
+Tue Aug 15 05:42:33 UTC 2017 - co...@suse.com
+
+- updated to 1.30
+   see /usr/share/doc/packages/perl-Log-Dispatch-FileRotate/Changes
+
+  1.30 Thu Aug 03 2017
+  - Docs: fix synopsis usage to "name" (incorrect) instead of filename
+(correct) (Thanks Emanuele Tomasi)
+  - improve debug() routine so that all debug messages have the same layout
+(Thanks Emanuele Tomasi)
+  - fix race condition in lockfile-race-condition.t [sic] (Thanks Emanuele
+Tomasi)
+
+---

Old:

  Log-Dispatch-FileRotate-1.29.tar.gz

New:

  Log-Dispatch-FileRotate-1.30.tar.gz



Other differences:
--
++ perl-Log-Dispatch-FileRotate.spec ++
--- /var/tmp/diff_new_pack.G4897J/_old  2017-09-04 12:36:49.423280917 +0200
+++ /var/tmp/diff_new_pack.G4897J/_new  2017-09-04 12:36:49.439278666 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Log-Dispatch-FileRotate
-Version:1.29
+Version:1.30
 Release:0
 %define cpan_name Log-Dispatch-FileRotate
 Summary:Log to Files that Archive/Rotate Themselves

++ Log-Dispatch-FileRotate-1.29.tar.gz -> 
Log-Dispatch-FileRotate-1.30.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Log-Dispatch-FileRotate-1.29/Changes 
new/Log-Dispatch-FileRotate-1.30/Changes
--- old/Log-Dispatch-FileRotate-1.29/Changes2017-07-28 17:15:44.0 
+0200
+++ new/Log-Dispatch-FileRotate-1.30/Changes2017-08-03 22:33:46.0 
+0200
@@ -1,5 +1,13 @@
 Revision history for Perl extension Log::Dispatch::FileRotate.
 
+1.30 Thu Aug 03 2017
+- Docs: fix synopsis usage to "name" (incorrect) instead of filename
+  (correct) (Thanks Emanuele Tomasi)
+- improve debug() routine so that all debug messages have the same layout
+  (Thanks Emanuele Tomasi)
+- fix race condition in lockfile-race-condition.t [sic] (Thanks Emanuele
+  Tomasi)
+
 1.29 Fri Jul 28 2017
 - Fix deadlock on Windows due to the fact that stat() on a filehandle vs a
   path doesn't return the same device field on Windows.
@@ -53,8 +61,6 @@
   installed and only run if TEST_SIGNATURE=1 is passed to make test)
 - Docs: fix synopsis reference to size parameter to make it clear that
   the size is in bytes, not megabytes.  [#88286]
-- Docs: fix synopsis usage to "name" (incorrect) instead of filename
-  (correct)
 
 1.21
 [REMOVED] - accidental release, bad dist.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Log-Dispatch-FileRotate-1.29/META.json 
new/Log-Dispatch-FileRotate-1.30/META.json
--- old/Log-Dispatch-FileRotate-1.29/META.json  2017-07-28 17:15:44.0 
+0200
+++ new/Log-Dispatch-FileRotate-1.30/META.json  2017-08-03 22:33:46.0 
+0200
@@ -16,11 +16,18 @@
"prereqs" : {
   "configure" : {
  "requires" : {
-"ExtUtils::MakeMaker" : "0"
+"ExtUtils::MakeMaker" : "0",
+"perl" : "5.006"
  }
   },
   "develop" : {
  "requires" : {
+"Dist::Zilla" : "5",
+"Dist::Zilla::Plugin::NextRelease" : "0",
+"Dist::Zilla::Plugin::RemovePrereqs" : "0",
+"Dist::Zilla::PluginBundle::Filter" : "0",
+"Dist::Zilla::PluginBundle::MSCHOUT" : "0",
+"Software::License::Perl_5" : "0",
 "Test::Pod" : "1.41"
  }
   },
@@ -33,7 +40,7 @@
 "Log::Dispatch::Output" : "0",
 "Params::Validate" : "0",
 "base" : "0",
-"perl" : "5.005",
+"perl" : "5.006",
 "strict" : "0",
 "version" : "0"
  }
@@ -44,6 +51,7 @@
 "Path::Tiny" : "0.018",
 "Test::More" : "0.88",
 "Test::Warn" : "0",
+"perl" : "5.006",
 "warnings" : "0"
  }
   }
@@ -61,7 +69,7 @@
  "web" : 

commit rubygem-cool.io for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package rubygem-cool.io for openSUSE:Factory 
checked in at 2017-09-04 12:37:00

Comparing /work/SRC/openSUSE:Factory/rubygem-cool.io (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-cool.io.new (New)


Package is "rubygem-cool.io"

Mon Sep  4 12:37:00 2017 rev:4 rq:520444 version:1.5.1

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-cool.io/rubygem-cool.io.changes  
2017-04-20 20:59:19.148954400 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-cool.io.new/rubygem-cool.io.changes 
2017-09-04 12:37:01.621564730 +0200
@@ -1,0 +2,6 @@
+Sun Sep  3 08:58:41 UTC 2017 - co...@suse.com
+
+- updated to version 1.5.1
+ see installed CHANGES.md
+
+---

Old:

  cool.io-1.5.0.gem

New:

  cool.io-1.5.1.gem



Other differences:
--
++ rubygem-cool.io.spec ++
--- /var/tmp/diff_new_pack.cKtuIB/_old  2017-09-04 12:37:02.365460070 +0200
+++ /var/tmp/diff_new_pack.cKtuIB/_new  2017-09-04 12:37:02.373458945 +0200
@@ -24,7 +24,7 @@
 #
 
 Name:   rubygem-cool.io
-Version:1.5.0
+Version:1.5.1
 Release:0
 %define mod_name cool.io
 %define mod_full_name %{mod_name}-%{version}

++ cool.io-1.5.0.gem -> cool.io-1.5.1.gem ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CHANGES.md new/CHANGES.md
--- old/CHANGES.md  2017-04-18 18:01:14.0 +0200
+++ new/CHANGES.md  2017-08-09 12:50:46.0 +0200
@@ -1,4 +1,9 @@
-1.5.0
+1.5.1
+-
+
+* Don't raise an exception when peername failed
+
+ 1.5.0
 -
 
 * Update libev to 4.24
Binary files old/checksums.yaml.gz and new/checksums.yaml.gz differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/cool.io/socket.rb new/lib/cool.io/socket.rb
--- old/lib/cool.io/socket.rb   2017-04-18 18:01:14.0 +0200
+++ new/lib/cool.io/socket.rb   2017-08-09 12:50:46.0 +0200
@@ -137,6 +137,8 @@
 
 private :preinitialize
 
+PEERADDR_FAILED = ["?", 0, "name resolusion failed", "?"]
+
 def initialize(socket)
   unless socket.is_a?(::TCPSocket) or socket.is_a?(TCPConnectSocket)
 raise TypeError, "socket must be a TCPSocket"
@@ -144,7 +146,7 @@
 
   super
 
-  @address_family, @remote_port, @remote_host, @remote_addr = 
socket.peeraddr
+  @address_family, @remote_port, @remote_host, @remote_addr = 
(socket.peeraddr rescue PEERADDR_FAILED)
 end
 
 def peeraddr
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/cool.io/version.rb new/lib/cool.io/version.rb
--- old/lib/cool.io/version.rb  2017-04-18 18:01:14.0 +0200
+++ new/lib/cool.io/version.rb  2017-08-09 12:50:46.0 +0200
@@ -1,5 +1,5 @@
 module Coolio
-  VERSION = "1.5.0"
+  VERSION = "1.5.1"
   
   def self.version
 VERSION
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/metadata new/metadata
--- old/metadata2017-04-18 18:01:14.0 +0200
+++ new/metadata2017-08-09 12:50:46.0 +0200
@@ -1,7 +1,7 @@
 --- !ruby/object:Gem::Specification
 name: cool.io
 version: !ruby/object:Gem::Version
-  version: 1.5.0
+  version: 1.5.1
 platform: ruby
 authors:
 - Tony Arcieri
@@ -9,7 +9,7 @@
 autorequire: 
 bindir: bin
 cert_chain: []
-date: 2017-04-18 00:00:00.0 Z
+date: 2017-08-09 00:00:00.0 Z
 dependencies:
 - !ruby/object:Gem::Dependency
   name: rake-compiler




commit perl-Test-Trap for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-Test-Trap for openSUSE:Factory 
checked in at 2017-09-04 12:37:06

Comparing /work/SRC/openSUSE:Factory/perl-Test-Trap (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Test-Trap.new (New)


Package is "perl-Test-Trap"

Mon Sep  4 12:37:06 2017 rev:8 rq:520449 version:0.3.3

Changes:

--- /work/SRC/openSUSE:Factory/perl-Test-Trap/perl-Test-Trap.changes
2015-04-15 16:27:18.0 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Test-Trap.new/perl-Test-Trap.changes   
2017-09-04 12:37:07.788697070 +0200
@@ -1,0 +2,17 @@
+Thu Aug 24 06:28:24 UTC 2017 - co...@suse.com
+
+- updated to 0.3.3
+   see /usr/share/doc/packages/perl-Test-Trap/Changes
+
+  0.3.3   Tue Aug 22 02:06:09 CEST 2017
+   For this release, many thanks go to Slaven Rezic, who found
+  that Test::More::is() (or Test2::Formatter::TAP::write())
+  clobbers $^E on Windows.
+  - RT #105125 is addressed:  The tests now use a copy of $^E
+taken before Test::More gets a chance to touch it.
+   - Further, the Test::Trap test methods might also clobber $^E
+(via Test::More or other modules), so they now localize $^E
+before invoking the callback.
+  - Regression tests have been added for this.
+
+---

Old:

  Test-Trap-v0.3.2.tar.gz

New:

  Test-Trap-v0.3.3.tar.gz
  cpanspec.yml



Other differences:
--
++ perl-Test-Trap.spec ++
--- /var/tmp/diff_new_pack.5Hz3uj/_old  2017-09-04 12:37:08.352617732 +0200
+++ /var/tmp/diff_new_pack.5Hz3uj/_new  2017-09-04 12:37:08.356617169 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Test-Trap
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,15 @@
 
 
 Name:   perl-Test-Trap
-Version:0.3.2
+Version:0.3.3
 Release:0
 %define cpan_name Test-Trap
 Summary:Trap exit codes, exceptions, output, etc
 License:Artistic-1.0 or GPL-1.0+
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/Test-Trap/
-Source: 
http://www.cpan.org/authors/id/E/EB/EBHANSSEN/%{cpan_name}-v%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/E/EB/EBHANSSEN/%{cpan_name}-v%{version}.tar.gz
+Source1:cpanspec.yml
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl

++ Test-Trap-v0.3.2.tar.gz -> Test-Trap-v0.3.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-Trap-v0.3.2/Changes new/Test-Trap-v0.3.3/Changes
--- old/Test-Trap-v0.3.2/Changes2015-02-24 00:19:39.0 +0100
+++ new/Test-Trap-v0.3.3/Changes2017-08-23 21:57:50.0 +0200
@@ -1,5 +1,16 @@
 Revision history for Test-Trap
 
+0.3.3   Tue Aug 22 02:06:09 CEST 2017
+   For this release, many thanks go to Slaven Rezic, who found
+that Test::More::is() (or Test2::Formatter::TAP::write())
+clobbers $^E on Windows.
+- RT #105125 is addressed:  The tests now use a copy of $^E
+  taken before Test::More gets a chance to touch it.
+   - Further, the Test::Trap test methods might also clobber $^E
+  (via Test::More or other modules), so they now localize $^E
+  before invoking the callback.
+- Regression tests have been added for this.
+
 0.3.2  Tue Feb 24 00:19:23 CET 2015
 The tempfile-preserve strategy was (always) broken on
 non-perlio perls.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-Trap-v0.3.2/META.json 
new/Test-Trap-v0.3.3/META.json
--- old/Test-Trap-v0.3.2/META.json  2015-02-24 00:19:39.0 +0100
+++ new/Test-Trap-v0.3.3/META.json  2017-08-23 21:57:50.0 +0200
@@ -4,7 +4,7 @@
   "Eirik Berg Hanssen "
],
"dynamic_config" : 1,
-   "generated_by" : "Module::Build version 0.421",
+   "generated_by" : "Module::Build version 0.4224",
"license" : [
   "perl_5"
],
@@ -42,23 +42,23 @@
"provides" : {
   "Test::Trap" : {
  "file" : "lib/Test/Trap.pm",
- "version" : "v0.3.2"
+ "version" : "v0.3.3"
   },
   "Test::Trap::Builder" : {
  "file" : "lib/Test/Trap/Builder.pm",
- "version" : "v0.3.2"
+ "version" : "v0.3.3"
   },
   "Test::Trap::Builder::PerlIO" : {
  "file" : 

commit perl-Log-Dispatch for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package perl-Log-Dispatch for 
openSUSE:Factory checked in at 2017-09-04 12:36:41

Comparing /work/SRC/openSUSE:Factory/perl-Log-Dispatch (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Log-Dispatch.new (New)


Package is "perl-Log-Dispatch"

Mon Sep  4 12:36:41 2017 rev:42 rq:520425 version:2.66

Changes:

--- /work/SRC/openSUSE:Factory/perl-Log-Dispatch/perl-Log-Dispatch.changes  
2017-06-21 13:57:26.373271955 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Log-Dispatch.new/perl-Log-Dispatch.changes 
2017-09-04 12:36:41.992326385 +0200
@@ -1,0 +2,11 @@
+Wed Aug 16 05:43:04 UTC 2017 - co...@suse.com
+
+- updated to 2.66
+   see /usr/share/doc/packages/perl-Log-Dispatch/Changes
+
+  2.66 2017-08-14
+  
+  - Fixed the ApacheLog output, which was broken in 2.60. Fixed by Michael
+Schout. GitHub #48 and #49.
+
+---

Old:

  Log-Dispatch-2.65.tar.gz

New:

  Log-Dispatch-2.66.tar.gz



Other differences:
--
++ perl-Log-Dispatch.spec ++
--- /var/tmp/diff_new_pack.7iOLIG/_old  2017-09-04 12:36:43.804071488 +0200
+++ /var/tmp/diff_new_pack.7iOLIG/_new  2017-09-04 12:36:43.812070363 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Log-Dispatch
-Version:2.65
+Version:2.66
 Release:0
 %define cpan_name Log-Dispatch
 Summary:Dispatches messages to one or more outputs

++ Log-Dispatch-2.65.tar.gz -> Log-Dispatch-2.66.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Log-Dispatch-2.65/Changes 
new/Log-Dispatch-2.66/Changes
--- old/Log-Dispatch-2.65/Changes   2017-06-12 01:58:55.0 +0200
+++ new/Log-Dispatch-2.66/Changes   2017-08-15 04:47:14.0 +0200
@@ -1,3 +1,9 @@
+2.66 2017-08-14
+
+- Fixed the ApacheLog output, which was broken in 2.60. Fixed by Michael
+  Schout. GitHub #48 and #49.
+
+
 2.65 2017-06-11
 
 - When Log::Dispatch::File is asked to chmod a file and that fails, show the
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Log-Dispatch-2.65/MANIFEST 
new/Log-Dispatch-2.66/MANIFEST
--- old/Log-Dispatch-2.65/MANIFEST  2017-06-12 01:58:55.0 +0200
+++ new/Log-Dispatch-2.66/MANIFEST  2017-08-15 04:47:14.0 +0200
@@ -1,4 +1,4 @@
-# This file was automatically generated by Dist::Zilla::Plugin::Manifest 
v6.009.
+# This file was automatically generated by Dist::Zilla::Plugin::Manifest 
v6.010.
 CONTRIBUTING.md
 Changes
 INSTALL
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Log-Dispatch-2.65/META.json 
new/Log-Dispatch-2.66/META.json
--- old/Log-Dispatch-2.65/META.json 2017-06-12 01:58:55.0 +0200
+++ new/Log-Dispatch-2.66/META.json 2017-08-15 04:47:14.0 +0200
@@ -4,7 +4,7 @@
   "Dave Rolsky "
],
"dynamic_config" : 0,
-   "generated_by" : "Dist::Zilla version 6.009, CPAN::Meta::Converter version 
2.150010",
+   "generated_by" : "Dist::Zilla version 6.010, CPAN::Meta::Converter version 
2.150010",
"license" : [
   "artistic_2"
],
@@ -109,75 +109,75 @@
"provides" : {
   "Log::Dispatch" : {
  "file" : "lib/Log/Dispatch.pm",
- "version" : "2.65"
+ "version" : "2.66"
   },
   "Log::Dispatch::ApacheLog" : {
  "file" : "lib/Log/Dispatch/ApacheLog.pm",
- "version" : "2.65"
+ "version" : "2.66"
   },
   "Log::Dispatch::Base" : {
  "file" : "lib/Log/Dispatch/Base.pm",
- "version" : "2.65"
+ "version" : "2.66"
   },
   "Log::Dispatch::Code" : {
  "file" : "lib/Log/Dispatch/Code.pm",
- "version" : "2.65"
+ "version" : "2.66"
   },
   "Log::Dispatch::Email" : {
  "file" : "lib/Log/Dispatch/Email.pm",
- "version" : "2.65"
+ "version" : "2.66"
   },
   "Log::Dispatch::Email::MIMELite" : {
  "file" : "lib/Log/Dispatch/Email/MIMELite.pm",
- "version" : "2.65"
+ "version" : "2.66"
   },
   "Log::Dispatch::Email::MailSend" : {
  "file" : "lib/Log/Dispatch/Email/MailSend.pm",
- "version" : "2.65"
+ "version" : "2.66"
   },
   "Log::Dispatch::Email::MailSender" : {
  "file" : "lib/Log/Dispatch/Email/MailSender.pm",
- "version" : "2.65"
+ "version" : "2.66"
   },
   "Log::Dispatch::Email::MailSendmail" : {
  "file" : "lib/Log/Dispatch/Email/MailSendmail.pm",
- "version" : "2.65"
+ "version" : "2.66"
   },
   "Log::Dispatch::File" : {
  "file" : 

commit heaptrack for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package heaptrack for openSUSE:Factory 
checked in at 2017-09-04 12:36:14

Comparing /work/SRC/openSUSE:Factory/heaptrack (Old)
 and  /work/SRC/openSUSE:Factory/.heaptrack.new (New)


Package is "heaptrack"

Mon Sep  4 12:36:14 2017 rev:2 rq:520370 version:1.0.0

Changes:

--- /work/SRC/openSUSE:Factory/heaptrack/heaptrack.changes  2017-05-03 
15:55:39.985132463 +0200
+++ /work/SRC/openSUSE:Factory/.heaptrack.new/heaptrack.changes 2017-09-04 
12:36:15.971987209 +0200
@@ -1,0 +2,6 @@
+Sat Sep  2 15:03:19 UTC 2017 - wba...@tmo.at
+
+- Add fix-build.patch to fix build with glibc 2.26 in Factory
+  (kde#383889)
+
+---

New:

  fix-build.patch



Other differences:
--
++ heaptrack.spec ++
--- /var/tmp/diff_new_pack.dJ1qEX/_old  2017-09-04 12:36:17.139822905 +0200
+++ /var/tmp/diff_new_pack.dJ1qEX/_new  2017-09-04 12:36:17.143822342 +0200
@@ -26,6 +26,8 @@
 Group:  Development/Tools/Other
 Url:   https://userbase.kde.org/Heaptrack
 Source0:
https://download.kde.org/stable/heaptrack/%{version}/src/%{name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM
+Patch:  fix-build.patch
 # Needs office-chart-area icon
 BuildRequires:  breeze5-icons
 BuildRequires:  extra-cmake-modules
@@ -63,6 +65,7 @@
 
 %prep
 %setup -q
+%patch -p1
 # Disable building tests, they're not used and post-build-checks trips over it
 sed -i"" '/add_subdirectory(tests)/d' CMakeLists.txt
 

++ fix-build.patch ++
>From f0a682550118b7019e74af71d9e8624902b8a984 Mon Sep 17 00:00:00 2001
From: Milian Wolff 
Date: Thu, 31 Aug 2017 09:51:34 +0200
Subject: Use check_symbol_exists() to check if cfree() is available

Thanks to Daniel Vratil for the initial work.

heaptrack now compiles on Fedora rawhide and Arch Linux x86_64
with glibc 2.26 or newer.

Differential Revision: https://phabricator.kde.org/D7621
---
 CMakeLists.txt  | 5 +
 src/track/heaptrack_inject.cpp  | 7 +--
 src/track/heaptrack_preload.cpp | 6 +-
 src/util/config.h.cmake | 4 
 tests/manual/CMakeLists.txt | 4 
 tests/manual/test.cpp   | 6 ++
 6 files changed, 21 insertions(+), 11 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0cdde70..7ff93df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,6 +73,11 @@ if (NOT HAVE_LINUX_HEADERS)
 message(FATAL_ERROR "You are missing some Linux headers required to 
compile heaptrack.")
 endif()
 
+# cfree() does not exist in glibc 2.26+.
+# See: https://bugs.kde.org/show_bug.cgi?id=383889
+include(CheckSymbolExists)
+check_symbol_exists(cfree malloc.h HAVE_CFREE)
+
 set(BIN_INSTALL_DIR "bin")
 set(LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)")
 set(LIB_INSTALL_DIR "lib${LIB_SUFFIX}")
diff --git a/src/track/heaptrack_inject.cpp b/src/track/heaptrack_inject.cpp
index 93508e0..c24a266 100644
--- a/src/track/heaptrack_inject.cpp
+++ b/src/track/heaptrack_inject.cpp
@@ -18,6 +18,7 @@
  */
 
 #include "libheaptrack.h"
+#include "util/config.h"
 
 #include 
 #include 
@@ -43,12 +44,6 @@
 #error unsupported word size
 #endif
 
-#if defined(_BSD_SOURCE) || defined(_SVID_SOURCE) || defined(__USE_MISC)
-#define HAVE_CFREE 1
-#else
-#define HAVE_CFREE 0
-#endif
-
 namespace {
 
 namespace Elf {
diff --git a/src/track/heaptrack_preload.cpp b/src/track/heaptrack_preload.cpp
index d8dde24..b4a 100644
--- a/src/track/heaptrack_preload.cpp
+++ b/src/track/heaptrack_preload.cpp
@@ -18,6 +18,7 @@
  */
 
 #include "libheaptrack.h"
+#include "util/config.h"
 
 #include 
 #include 
@@ -30,7 +31,6 @@ using namespace std;
 using namespace std;
 
 #define HAVE_ALIGNED_ALLOC defined(_ISOC11_SOURCE)
-#define HAVE_CFREE (defined(_BSD_SOURCE) || defined(_SVID_SOURCE) || 
defined(__USE_MISC))
 
 namespace {
 
diff --git a/src/util/config.h.cmake b/src/util/config.h.cmake
index 7bad362..861c1f7 100644
--- a/src/util/config.h.cmake
+++ b/src/util/config.h.cmake
@@ -30,4 +30,8 @@
 
 #define HEAPTRACK_DEBUG_BUILD @HEAPTRACK_DEBUG_BUILD@
 
+// cfree() does not exist in glibc 2.26+.
+// See: https://bugs.kde.org/show_bug.cgi?id=383889
+#cmakedefine01 HAVE_CFREE
+
 #endif // HEAPTRACK_CONFIG_H
diff --git a/tests/manual/CMakeLists.txt b/tests/manual/CMakeLists.txt
index fe9602b..8996201 100644
--- a/tests/manual/CMakeLists.txt
+++ b/tests/manual/CMakeLists.txt
@@ -2,6 +2,10 @@ set(CMAKE_BUILD_TYPE Debug)
 
 add_executable(test_c test.c)
 add_executable(test_cpp test.cpp)
+set_target_properties(test_cpp PROPERTIES
+  INCLUDE_DIRECTORIES ${CMAKE_CURRENT_BINARY_DIR}/../../src/
+)
+
 add_executable(threaded threaded.cpp)
 target_link_libraries(threaded 

commit libaal for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package libaal for openSUSE:Factory checked 
in at 2017-09-04 12:35:54

Comparing /work/SRC/openSUSE:Factory/libaal (Old)
 and  /work/SRC/openSUSE:Factory/.libaal.new (New)


Package is "libaal"

Mon Sep  4 12:35:54 2017 rev:6 rq:520346 version:1.0.6

Changes:

--- /work/SRC/openSUSE:Factory/libaal/libaal.changes2014-09-12 
15:25:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.libaal.new/libaal.changes   2017-09-04 
12:36:01.825977323 +0200
@@ -1,0 +2,7 @@
+Sat Sep  2 11:05:17 UTC 2017 - jeng...@inai.de
+
+- Add no-nonsense.diff to resolve build failure with glibc.
+- Redo libaal-1.0.5-rpmoptflags.patch with p1.
+- Drop static library subpackage.
+
+---

New:

  no-nonsense.diff



Other differences:
--
++ libaal.spec ++
--- /var/tmp/diff_new_pack.GJqeQC/_old  2017-09-04 12:36:05.401474383 +0200
+++ /var/tmp/diff_new_pack.GJqeQC/_new  2017-09-04 12:36:05.409473258 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libaal
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,6 +26,7 @@
 
 Source: http://downloads.sf.net/reiser4/libaal-%version.tar.gz
 Patch1: libaal-1.0.5-rpmoptflags.patch
+Patch2: no-nonsense.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  autoconf
 BuildRequires:  automake
@@ -60,25 +61,13 @@
 %description devel
 libaal includes device abstraction, libc independence code, and more.
 
-%package devel-static
-Summary:Static libraries for libaal development
-License:GPL-2.0
-Group:  Development/Libraries/C and C++
-Requires:   %name-devel = %version
-
-%description devel-static
-libaal includes device abstraction, libc independence code, and more.
-
-This subpackage contains the static versions of the libraries, for
-use with programs that require them.
-
 %prep
 %setup -q
-%patch -P 1 -p0
+%patch -P 1 -P 2 -p1
 
 %build
 autoreconf -fi
-%configure --enable-static --with-pic
+%configure --disable-static
 make %{?_smp_mflags}
 
 %install
@@ -106,8 +95,4 @@
 %_includedir/aal
 %_datadir/aclocal
 
-%files devel-static
-%defattr(-,root,root)
-%_libdir/libaal*.a
-
 %changelog

++ libaal-1.0.5-rpmoptflags.patch ++
--- /var/tmp/diff_new_pack.GJqeQC/_old  2017-09-04 12:36:05.509459191 +0200
+++ /var/tmp/diff_new_pack.GJqeQC/_new  2017-09-04 12:36:05.521457503 +0200
@@ -1,6 +1,12 @@
 configure.in
-+++ configure.in
-@@ -126,7 +126,7 @@
+---
+ configure.in |2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: libaal-1.0.6/configure.in
+===
+--- libaal-1.0.6.orig/configure.in
 libaal-1.0.6/configure.in
+@@ -126,7 +126,7 @@ else
ALIGN_FLAGS="-malign-jumps=1 -malign-loops=1 -malign-functions=1"
  fi
  

++ no-nonsense.diff ++
Date: 2017-09-02 13:03:15.353403096 +0200
From: Jan Engelhardt 

Stop redefining libc definitions that cause build failures under glibc-2.26.

[   46s] In file included from /usr/include/sys/types.h:156:0,
[   46s]  from /usr/include/stdlib.h:279,
[   46s]  from malloc.c:15:
[   46s] /usr/include/bits/stdint-intn.h:27:19: error: conflicting types for 
'int64_t'
[   46s]  typedef __int64_t int64_t;
[   46s]^~~
[   46s] In file included from ../include/aal/libaal.h:17:0,
[   46s]  from malloc.c:6:
[   46s] ../include/aal/types.h:35:33: note: previous declaration of 'int64_t' 
was here
[   46s]  typedef long long int   int64_t;


---
 include/aal/types.h |   48 ++--
 1 file changed, 2 insertions(+), 46 deletions(-)

Index: libaal-1.0.6/include/aal/types.h
===
--- libaal-1.0.6.orig/include/aal/types.h
+++ libaal-1.0.6/include/aal/types.h
@@ -26,24 +26,7 @@
 #undef ESTRUCT
 #define ESTRUCT 50
 
-#ifndef __int8_t_defined
-#define __int8_t_defined
-typedef signed char int8_t;
-typedef short int   int16_t;
-typedef int int32_t;
-__extension__
-typedef long long int   int64_t;
-#endif
- 
-typedef unsigned char   uint8_t;
-typedef unsigned short int  uint16_t;
-#ifndef __uint32_t_defined
-#define __uint32_t_defined
-typedef unsigned intuint32_t;
-__extension__
-typedef unsigned long long int  uint64_t;
-#endif
-

commit xbsql for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package xbsql for openSUSE:Factory checked 
in at 2017-09-04 12:36:06

Comparing /work/SRC/openSUSE:Factory/xbsql (Old)
 and  /work/SRC/openSUSE:Factory/.xbsql.new (New)


Package is "xbsql"

Mon Sep  4 12:36:06 2017 rev:22 rq:520352 version:0.11

Changes:

--- /work/SRC/openSUSE:Factory/xbsql/xbsql.changes  2015-04-23 
08:04:13.0 +0200
+++ /work/SRC/openSUSE:Factory/.xbsql.new/xbsql.changes 2017-09-04 
12:36:09.816853180 +0200
@@ -1,0 +2,6 @@
+Sat Sep  2 11:41:18 UTC 2017 - wba...@tmo.at
+
+- Add xbase64.patch to fix build with latest xbase(64) 3.1.2 in
+  Factory
+
+---

New:

  xbase64.patch



Other differences:
--
++ xbsql.spec ++
--- /var/tmp/diff_new_pack.bjFhTk/_old  2017-09-04 12:36:10.704728264 +0200
+++ /var/tmp/diff_new_pack.bjFhTk/_new  2017-09-04 12:36:10.704728264 +0200
@@ -27,6 +27,8 @@
 Source0:%{name}-%{version}.tar.bz2
 Patch0: %{name}.diff
 Patch1: xbsql-0.11-bufferoverflowstrncat.patch
+# PATCH-FIX-OPENSUSE xbase64.patch -- fix build with latest xbase(64) 3.1.2 in 
Factory
+Patch2: xbase64.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  bison
@@ -70,6 +72,7 @@
 %setup -q
 %patch0
 %patch1
+%patch2 -p1
 
 %build
 autoreconf -fi

++ xbase64.patch ++
diff -ur xbsql-0.11.orig/test/Makefile.am xbsql-0.11/test/Makefile.am
--- xbsql-0.11.orig/test/Makefile.am2017-08-30 12:48:09.0 +0200
+++ xbsql-0.11/test/Makefile.am 2017-08-30 12:47:12.0 +0200
@@ -6,5 +6,5 @@
 
 S003_multi_SOURCES = S003_multi.cpp
 
-S003_multi_LDFLAGS = -lxbase $(DEBUG) ../xbsql/libxbsql.la
+S003_multi_LDFLAGS = -lxbase64 $(DEBUG) ../xbsql/libxbsql.la
 
diff -ur xbsql-0.11.orig/xbsql/Makefile.am xbsql-0.11/xbsql/Makefile.am
--- xbsql-0.11.orig/xbsql/Makefile.am   2017-08-30 12:48:09.0 +0200
+++ xbsql-0.11/xbsql/Makefile.am2017-08-30 12:47:34.0 +0200
@@ -16,10 +16,10 @@
  xb_assignlist.cpp xb_create.cpp \
  xbsql.tab.c xb_datetime.cpp
 
-libxbsql_la_LDFLAGS= -lxbase
+libxbsql_la_LDFLAGS= -lxbase64
 
 xql_SOURCES= xql.cpp
-xql_LDADD  = -lxbase -lreadline -l$(CURSES) ./libxbsql.la
+xql_LDADD  = -lxbase64 -lreadline -l$(CURSES) ./libxbsql.la
 
 #
 #
diff -ur xbsql-0.11.orig/xbsql/xbsql.cpp xbsql-0.11/xbsql/xbsql.cpp
--- xbsql-0.11.orig/xbsql/xbsql.cpp 2017-08-30 12:48:09.0 +0200
+++ xbsql-0.11/xbsql/xbsql.cpp  2017-08-30 12:47:12.0 +0200
@@ -207,7 +207,7 @@
break   ;
 
default :
-   e   = xbStrError (rc) ;
+   e   = GetErrorMessage (rc) ;
break   ;
}
 
@@ -230,7 +230,7 @@
chart[1024] ;
va_list aptr;
 
-   strcpy(t, xbStrError (rc)) ;
+   strcpy(t, GetErrorMessage (rc)) ;
strcat(t, ": ") ;
int   l = strlen(t) ;
 
diff -ur xbsql-0.11.orig/xbsql/xbsql.h xbsql-0.11/xbsql/xbsql.h
--- xbsql-0.11.orig/xbsql/xbsql.h   2003-03-28 20:07:31.0 +0100
+++ xbsql-0.11/xbsql/xbsql.h2017-08-30 12:47:12.0 +0200
@@ -43,8 +43,7 @@
 
 #endif
 
-#include   
-#include   
+#include   
 
 class  XBaseSQL;
 class  XBSQLTable  ;



commit reiser4progs for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package reiser4progs for openSUSE:Factory 
checked in at 2017-09-04 12:36:01

Comparing /work/SRC/openSUSE:Factory/reiser4progs (Old)
 and  /work/SRC/openSUSE:Factory/.reiser4progs.new (New)


Package is "reiser4progs"

Mon Sep  4 12:36:01 2017 rev:7 rq:520347 version:1.1.0

Changes:

--- /work/SRC/openSUSE:Factory/reiser4progs/reiser4progs.changes
2015-09-08 18:11:52.0 +0200
+++ /work/SRC/openSUSE:Factory/.reiser4progs.new/reiser4progs.changes   
2017-09-04 12:36:06.505319083 +0200
@@ -1,0 +2,5 @@
+Sat Sep  2 11:15:46 UTC 2017 - jeng...@inai.de
+
+- Add no-static.diff.
+
+---

New:

  no-static.diff



Other differences:
--
++ reiser4progs.spec ++
--- /var/tmp/diff_new_pack.3cmOja/_old  2017-09-04 12:36:07.789138461 +0200
+++ /var/tmp/diff_new_pack.3cmOja/_new  2017-09-04 12:36:07.813135085 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package reiser4progs
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,14 +26,14 @@
 Url:http://sf.net/projects/reiser4/
 
 Source: http://downloads.sf.net/reiser4/%name-%version.tar.gz
+Patch1: no-static.diff
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  automake
 BuildRequires:  libaal-devel
+BuildRequires:  libtool
 BuildRequires:  libuuid-devel
 BuildRequires:  readline-devel
 BuildRequires:  xz
-# There is a dull test which involes gcc -static
-BuildRequires:  glibc-devel-static
-BuildRequires:  libaal-devel-static
 
 %description
 A set of commands for using the Reiser4 file system, including
@@ -76,12 +76,14 @@
 
 %prep
 %setup -q
+%patch -P 1 -p1
 
 %build
 #
 # Disabling hashes only affects minimal library. The options are
 # a recommendation from reiser4progs's shipped .spec file.
 #
+autoreconf -fi
 %configure --disable-static --enable-libminimal --disable-fnv1-hash \
--disable-rupasov-hash --disable-tea-hash --disable-deg-hash
 make %{?_smp_mflags}

++ no-static.diff ++
Date: 2017-09-02 13:14:23.021280169 +0200
From: Jan Engelhardt 

build: make the build work with just shared libs
---
 configure.in   |6 --
 libreiser4/Makefile.am |1 -
 2 files changed, 7 deletions(-)

Index: reiser4progs-1.1.0/configure.in
===
--- reiser4progs-1.1.0.orig/configure.in
+++ reiser4progs-1.1.0/configure.in
@@ -70,9 +70,6 @@ libaal_config_minor_version=`echo $2 | \
 libaal_config_micro_version=`echo $2 | \
 sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
 
-OLD_CFLAGS=$CFLAGS
-CFLAGS="$CFLAGS -static"
-
 # Compare MINIMUM-VERSION with libaal version
 AC_TRY_RUN([
 #include 
@@ -116,8 +113,6 @@ int main() {
AC_MSG_RESULT(no) ; $4,
[echo $ac_n "cross compiling; assumed OK... $ac_c"])
 
-CFLAGS=$OLD_CFLAGS
-
 # Execute ACTION-IF-FOUND
 $3])
 
@@ -126,7 +121,6 @@ AC_ARG_WITH(libaal,
 )
 
 LIBS=""
-CFLAGS="$CFLAGS"
 
 if test x$with_libaal != x; then
LIBS="-L$with_libaal/lib"
Index: reiser4progs-1.1.0/libreiser4/Makefile.am
===
--- reiser4progs-1.1.0.orig/libreiser4/Makefile.am
+++ reiser4progs-1.1.0/libreiser4/Makefile.am
@@ -30,7 +30,6 @@ libreiser4_static_la_LIBADD  = $(top_bui
 
 libreiser4_static_la_SOURCES = $(libreiser4_sources)
 libreiser4_static_la_CFLAGS  = @GENERIC_CFLAGS@
-libreiser4_static_la_LDFLAGS = -static
 
 if ENABLE_MINIMAL
 libreiser4_minimal_la_LIBADD   = $(top_builddir)/libaux/libaux-minimal.la \



commit kawaii-player for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package kawaii-player for openSUSE:Factory 
checked in at 2017-09-04 12:36:11

Comparing /work/SRC/openSUSE:Factory/kawaii-player (Old)
 and  /work/SRC/openSUSE:Factory/.kawaii-player.new (New)


Package is "kawaii-player"

Mon Sep  4 12:36:11 2017 rev:2 rq:520367 version:2.2.0.1

Changes:

--- /work/SRC/openSUSE:Factory/kawaii-player/kawaii-player.changes  
2017-07-05 23:56:58.508600036 +0200
+++ /work/SRC/openSUSE:Factory/.kawaii-player.new/kawaii-player.changes 
2017-09-04 12:36:13.828288807 +0200
@@ -1,0 +2,42 @@
+Sat Sep  2 17:27:35 UTC 2017 - aloi...@gmx.com
+
+- Fixed version number
+
+---
+Thu Aug 31 14:44:15 UTC 2017 - aloi...@gmx.com
+
+- Update to version 2.2.0-1
+  * Improved video management functionalities.
+  * Allows creating new video categories
+  * Allows renaming of title and playlist entries
+  * Group rename of playlist entries
+  * Improved contextmenu with grouping of various categories
+  * Allows getting information for entire collection
+  * TMDB support added
+  * Supports both duckduckgo and google as search engine backend
+for getting information from either TVDB or TMDB.
+  * Keyboard shortcuts have been changed
+  * Allows direct jump on title starting with letter when keyboard
+button pertaining to that letter is pressed
+  * Firefox related bug fixed when loading subtitles
+  * New background image modes with shortcuts (ctrl+0 and ctrl+9)
+added
+  * Some image resizing issues fixed with python-pillow
+  * Allows using the application as both server as well as client
+  * Added new MyServer addon for managing peer-to-peer mode.
+  * Servers can broadcast themselves in the local network so that
+clients can discover it without having to remember local IP
+address of each media server.
+  * Allows modifying broadcast message of server
+  * Users can manually set server's upload speed
+  * mpv now remembers last aspect ratio
+  * Better OSD display on changing aspect ratio
+  * Critical bug fixed in deleting bookmarked playlist
+  version 2.0.0-0:
+  * Various modules separated and major overhaul of large codebase
+  * Headless browser included
+  * Proper support added for qtwebkit along with qtwebengine as
+backend for headless browser
+  * Multiple bug fixes
+
+---

Old:

  kawaii-player-1.4.0-0.tar.gz

New:

  kawaii-player-2.2.0-1.tar.gz



Other differences:
--
++ kawaii-player.spec ++
--- /var/tmp/diff_new_pack.TqQjwD/_old  2017-09-04 12:36:15.108108748 +0200
+++ /var/tmp/diff_new_pack.TqQjwD/_new  2017-09-04 12:36:15.120107060 +0200
@@ -18,15 +18,17 @@
 
 # See also http://en.opensuse.org/openSUSE:Specfile_guidelines
 
-%define _over   1.4.0-0
+%define _over   2.2.0-1
+%define _bver   2.2.0
 Name:   kawaii-player
-Version:1.4.0
+Version:2.2.0.1
 Release:0
 Summary:Multimedia player, library manager and media server
 License:GPL-3.0
 Group:  Productivity/Multimedia/Video/Players
 Url:https://github.com/kanishka-linux/kawaii-player
 Source0:
https://github.com/kanishka-linux/kawaii-player/archive/v%{_over}.tar.gz#/%{name}-%{_over}.tar.gz
+BuildRequires:  fdupes
 BuildRequires:  python3-devel
 BuildRequires:  python3-setuptools
 Requires:   ffmpegthumbnailer
@@ -62,6 +64,7 @@
 mkdir -pv %{buildroot}/%{_datadir}/applications 
%{buildroot}/%{_datadir}/pixmaps
 install -m 0644 ubuntu/%{name}.desktop 
%{buildroot}/%{_datadir}/applications/%{name}.desktop
 install -m 0644 kawaii_player/tray.png 
%{buildroot}/%{_datadir}/pixmaps/%{name}.png
+%fdupes -s %{buildroot}%{python3_sitelib}
 
 %files
 %defattr(-,root,root)
@@ -71,6 +74,6 @@
 %{_datadir}/pixmaps/%{name}.png
 %{_datadir}/applications/%{name}.desktop
 %{python3_sitelib}/kawaii_player
-%{python3_sitelib}/kawaii_player-%{version}-py%{py3_ver}.egg-info
+%{python3_sitelib}/kawaii_player-%{_bver}-py%{py3_ver}.egg-info
 
 %changelog

++ kawaii-player-1.4.0-0.tar.gz -> kawaii-player-2.2.0-1.tar.gz ++
 60497 lines of diff (skipped)




commit adapta-gtk-theme for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package adapta-gtk-theme for 
openSUSE:Factory checked in at 2017-09-04 12:35:38

Comparing /work/SRC/openSUSE:Factory/adapta-gtk-theme (Old)
 and  /work/SRC/openSUSE:Factory/.adapta-gtk-theme.new (New)


Package is "adapta-gtk-theme"

Mon Sep  4 12:35:38 2017 rev:5 rq:520267 version:3.91.2.129

Changes:

--- /work/SRC/openSUSE:Factory/adapta-gtk-theme/adapta-gtk-theme.changes
2017-08-12 20:29:24.573467767 +0200
+++ /work/SRC/openSUSE:Factory/.adapta-gtk-theme.new/adapta-gtk-theme.changes   
2017-09-04 12:35:43.628535984 +0200
@@ -1,0 +2,9 @@
+Fri Sep  1 23:24:48 UTC 2017 - matthias.elias...@gmail.com
+
+- Version bump to 3.91.2.129
+  * Enforced transparent "insensitive" flat-button backgrounds in various 
cases (Gtk+ 3.2x/4.0)
+  * Added a hack for 'inline-progress' widget inside the GtkTreeView (Gtk+ 2.0)
+  * Added 'unchecked' check/radio icon images in GtkMenuItem (Gtk+ 2.0)
+  * Stopped drawing unneeded insensitive state label-shadows of GtkMenuBar's 
GtkMenuItem (Gtk+ 2.0)
+
+---

Old:

  adapta-gtk-theme-3.91.2.15.tar.gz

New:

  adapta-gtk-theme-3.91.2.129.tar.gz



Other differences:
--
++ adapta-gtk-theme.spec ++
--- /var/tmp/diff_new_pack.Fqhe4S/_old  2017-09-04 12:35:44.544407208 +0200
+++ /var/tmp/diff_new_pack.Fqhe4S/_new  2017-09-04 12:35:44.556405521 +0200
@@ -21,7 +21,7 @@
 %define gtk3_min_version3.18
 %define gtk2_min_version2.24
 Name:   adapta-gtk-theme
-Version:3.91.2.15
+Version:3.91.2.129
 Release:0
 Summary:An adaptive Gtk+ theme based on Material Design Guidelines
 License:GPL-2.0 AND CC-BY-SA-4.0

++ adapta-gtk-theme-3.91.2.15.tar.gz -> adapta-gtk-theme-3.91.2.129.tar.gz 
++
 11600 lines of diff (skipped)




commit bindfs for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package bindfs for openSUSE:Factory checked 
in at 2017-09-04 12:35:50

Comparing /work/SRC/openSUSE:Factory/bindfs (Old)
 and  /work/SRC/openSUSE:Factory/.bindfs.new (New)


Package is "bindfs"

Mon Sep  4 12:35:50 2017 rev:15 rq:520339 version:1.13.7

Changes:

--- /work/SRC/openSUSE:Factory/bindfs/bindfs.changes2016-09-27 
13:45:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.bindfs.new/bindfs.changes   2017-09-04 
12:35:54.606992353 +0200
@@ -1,0 +2,6 @@
+Thu Aug 31 21:00:53 UTC 2017 - luc1...@linuxmail.org
+
+- Update to new upstream release 1.13.7
+  * Added --block-devices-as-files.
+
+---

Old:

  bindfs-1.13.2.tar.gz

New:

  bindfs-1.13.7.tar.gz



Other differences:
--
++ bindfs.spec ++
--- /var/tmp/diff_new_pack.LJD2qr/_old  2017-09-04 12:35:55.406879884 +0200
+++ /var/tmp/diff_new_pack.LJD2qr/_new  2017-09-04 12:35:55.410879322 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package bindfs
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   bindfs
-Version:1.13.2
+Version:1.13.7
 Release:0
 Summary:Mount Directories to other Locations and alter Permission Bits
 License:GPL-2.0+

++ bindfs-1.13.2.tar.gz -> bindfs-1.13.7.tar.gz ++
 24047 lines of diff (skipped)




commit erlang for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package erlang for openSUSE:Factory checked 
in at 2017-09-04 12:35:44

Comparing /work/SRC/openSUSE:Factory/erlang (Old)
 and  /work/SRC/openSUSE:Factory/.erlang.new (New)


Package is "erlang"

Mon Sep  4 12:35:44 2017 rev:57 rq:520333 version:20.0.4

Changes:

--- /work/SRC/openSUSE:Factory/erlang/erlang.changes2017-08-28 
15:15:39.733397597 +0200
+++ /work/SRC/openSUSE:Factory/.erlang.new/erlang.changes   2017-09-04 
12:35:49.283740832 +0200
@@ -1,0 +2,32 @@
+Sun Aug 27 14:19:49 UTC 2017 - matwey.korni...@gmail.com
+
+- Update to 20.0.4:
+  * dializer: Fix a bug where merging PLT:s could lose info. The
+bug was introduced in Erlang/OTP 20.0.
+  * erts: A timer internal bit-field used for storing scheduler id
+was too small. As a result, VM internal timer data structures
+could become inconsistent when using 1024 schedulers on the
+system. Note that systems with less than 1024 schedulers are
+not effected by this bug. This bug was introduced in ERTS
+version 7.0 (OTP 18.0).
+  * erts: Automatic cleanup of a BIF timer, when the owner process
+terminated, could race with the timeout of the timer. This
+could cause the VM internal data structures to become
+inconsistent which very likely caused a VM crash. This bug was
+introduced in ERTS version 9.0 (OTP 20.0).
+
+- Update to 20.0.3:
+  * asn1: Default values now work in extension for PER, so if you
+give the atom asn1_DEFAULT instead of a value it will become
+the default value.
+  * compiler: Fail labels on guard BIFs weren't taken into account
+during an optimization pass, and a bug in the validation pass
+sometimes prevented this from being noticed when a fault
+occurred.
+  * erts: Binary append operations did not check for overflow,
+resulting in nonsensical results when huge binaries were
+appended.
+  * ssh: All unknown options are sent to the transport handler
+regardless of type.
+
+---

Old:

  OTP-20.0.2.tar.gz

New:

  OTP-20.0.4.tar.gz



Other differences:
--
++ erlang.spec ++
--- /var/tmp/diff_new_pack.wiXG6y/_old  2017-09-04 12:35:52.215328634 +0200
+++ /var/tmp/diff_new_pack.wiXG6y/_new  2017-09-04 12:35:52.219328072 +0200
@@ -21,7 +21,7 @@
 %endif
 
 Name:   erlang
-Version:20.0.2
+Version:20.0.4
 Release:0
 # not set up to be built with position independend executable support
 #!BuildIgnore: gcc-PIE

++ OTP-20.0.2.tar.gz -> OTP-20.0.4.tar.gz ++
/work/SRC/openSUSE:Factory/erlang/OTP-20.0.2.tar.gz 
/work/SRC/openSUSE:Factory/.erlang.new/OTP-20.0.4.tar.gz differ: char 18, line 1




commit apcupsd for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package apcupsd for openSUSE:Factory checked 
in at 2017-09-04 12:35:35

Comparing /work/SRC/openSUSE:Factory/apcupsd (Old)
 and  /work/SRC/openSUSE:Factory/.apcupsd.new (New)


Package is "apcupsd"

Mon Sep  4 12:35:35 2017 rev:61 rq:520255 version:3.14.14

Changes:

--- /work/SRC/openSUSE:Factory/apcupsd/apcupsd.changes  2016-12-26 
21:45:51.607724894 +0100
+++ /work/SRC/openSUSE:Factory/.apcupsd.new/apcupsd.changes 2017-09-04 
12:35:36.265571256 +0200
@@ -1,0 +2,8 @@
+Thu Aug 31 17:04:39 UTC 2017 - dims...@opensuse.org
+
+- Pass --with-distname=, based on the values of ID_LIKE from
+  /etc/os-release to configure. Since the removal of
+  /etc/SuSE-release, the build system is no longer able to identify
+  us building on a SUSE system. Let's help it.
+
+---



Other differences:
--
++ apcupsd.spec ++
--- /var/tmp/diff_new_pack.WHZ3CN/_old  2017-09-04 12:35:37.605382871 +0200
+++ /var/tmp/diff_new_pack.WHZ3CN/_new  2017-09-04 12:35:37.625380060 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package apcupsd
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -61,10 +61,10 @@
 BuildRequires:  xorg-x11-devel
 Requires:   %{_bindir}/mail
 Requires(post): %fillup_prereq
+Requires(post): %{_bindir}/grep
 # sed and grep are still prerequred to finish upgrade from sysvinit scripts:
-Requires(post): %{_bindir}/sed %{_bindir}/grep
+Requires(post): %{_bindir}/sed
 Suggests:   logrotate
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if 0%{?suse_version} > 1210
 BuildRequires:  systemd-rpm-macros
 BuildRequires:  systemd-sysvinit
@@ -133,7 +133,8 @@
--enable-all \
--enable-nls \
--with-lock-dir=%{_localstatedir}/lock \
-   --with-cgi-bin=%{apache_serverroot}/cgi-bin
+   --with-cgi-bin=%{apache_serverroot}/cgi-bin \
+   --with-distname=$(grep ID_LIKE %{_sysconfdir}/os-release | cut -d = -f 
2 | tr -d '"')
 make %{?_smp_mflags}
 
 %install





commit arping2 for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package arping2 for openSUSE:Factory checked 
in at 2017-09-04 12:35:27

Comparing /work/SRC/openSUSE:Factory/arping2 (Old)
 and  /work/SRC/openSUSE:Factory/.arping2.new (New)


Package is "arping2"

Mon Sep  4 12:35:27 2017 rev:18 rq:520251 version:2.19

Changes:

--- /work/SRC/openSUSE:Factory/arping2/arping2.changes  2016-12-10 
18:30:23.739479026 +0100
+++ /work/SRC/openSUSE:Factory/.arping2.new/arping2.changes 2017-09-04 
12:35:31.742207264 +0200
@@ -1,0 +2,7 @@
+Thu Aug 31 04:30:22 UTC 2017 - luc1...@linuxmail.org
+
+- Update to version 2.19
+  * Make `arping` -w/-W behave like `ping` and `iputils-arping`
+  * Add option -g to specify group to drop privs to
+
+---

Old:

  arping-2.17.tar.gz
  arping-2.17.tar.gz.asc

New:

  arping-2.19.tar.gz
  arping-2.19.tar.gz.asc



Other differences:
--
++ arping2.spec ++
--- /var/tmp/diff_new_pack.tSnR94/_old  2017-09-04 12:35:32.846052058 +0200
+++ /var/tmp/diff_new_pack.tSnR94/_new  2017-09-04 12:35:32.862049809 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package arping2
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   arping2
-Version:2.17
+Version:2.19
 Release:0
 Summary:Layer-2 Ethernet pinger
 License:GPL-2.0+

++ arping-2.17.tar.gz -> arping-2.19.tar.gz ++
 2762 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/arping-2.17/HACKING.md new/arping-2.19/HACKING.md
--- old/arping-2.17/HACKING.md  2016-06-28 00:07:15.0 +0200
+++ new/arping-2.19/HACKING.md  2017-07-09 19:52:08.0 +0200
@@ -12,3 +12,11 @@
 9. Upload to http://www.habets.pp.se/synscan/files/
 10. Update webpage.
 11. Send email to synscan-annou...@googlegroups.com
+
+## Fuzzing
+
+```shell
+CC=/path/to/afl-gcc ./configure
+make
+/path/to/afl-fuzz -i fuzz/pingip/ -o fuzz/out/ ./src/fuzz_pingip
+```
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/arping-2.17/README new/arping-2.19/README
--- old/arping-2.17/README  2016-06-28 00:07:15.0 +0200
+++ new/arping-2.19/README  2017-07-09 19:52:08.0 +0200
@@ -10,7 +10,7 @@
 
 Introduction
 
-Arping is a util to find out it a specific IP address on the LAN is 'taken'
+Arping is a util to find out if a specific IP address on the LAN is 'taken'
 and what MAC address owns it. Sure, you *could* just use 'ping' to find out if
 it's taken and even if the computer blocks ping (and everything else) you still
 get an entry in your ARP cache. But what if you aren't on a routable net? Or
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/arping-2.17/compile new/arping-2.19/compile
--- old/arping-2.17/compile 2016-06-28 00:07:18.0 +0200
+++ new/arping-2.19/compile 2017-07-09 19:52:12.0 +0200
@@ -3,7 +3,7 @@
 
 scriptversion=2012-10-14.11; # UTC
 
-# Copyright (C) 1999-2013 Free Software Foundation, Inc.
+# Copyright (C) 1999-2014 Free Software Foundation, Inc.
 # Written by Tom Tromey .
 #
 # This program is free software; you can redistribute it and/or modify
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/arping-2.17/configure.ac new/arping-2.19/configure.ac
--- old/arping-2.17/configure.ac2016-06-28 00:07:15.0 +0200
+++ new/arping-2.19/configure.ac2017-07-09 19:52:08.0 +0200
@@ -2,7 +2,7 

commit gparted for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package gparted for openSUSE:Factory checked 
in at 2017-09-04 12:35:22

Comparing /work/SRC/openSUSE:Factory/gparted (Old)
 and  /work/SRC/openSUSE:Factory/.gparted.new (New)


Package is "gparted"

Mon Sep  4 12:35:22 2017 rev:39 rq:520245 version:0.29.0

Changes:

--- /work/SRC/openSUSE:Factory/gparted/gparted.changes  2017-02-22 
13:56:28.667190848 +0100
+++ /work/SRC/openSUSE:Factory/.gparted.new/gparted.changes 2017-09-04 
12:35:25.159132878 +0200
@@ -1,0 +2,28 @@
+Wed Aug 09 22:11:23 UTC 2017 - joerg.loren...@ki.tng.de
+
+- Update to version 0.29.0:
+  + Key changes include:
+- Add support for UDF file system
+- Fix segmentation fault on disk with corrupted FAT file system
+- Fix snap-to-alignment of operations creating partitions
+  + Bug Fixes
+- Fix segmentation fault on disk with corrupted FAT file system
+  (bgo#777973).
+- Fix snap-to-alignment of operations creating partitions
+  (bgo#779339).
+- Fix btrfs partitions mounted with whitespace cannot be
+  resized (bgo#782681).
+- Add Google Test C++ test framework (bgo#781978).
+- Fix LVM2 PV detected regardless if second magic matches or not
+  (bgo#783997).
+- Fix no longer detecting btrfs change UUID capability
+  (bgo#784467).
+- Fix setting empty label when creating FAT16/32 file systems
+  (bgo#784564).
+- Add support for UDF file system (bgo#784533).
+- Fix make distcheck fails with *.Po: No such file or directory
+  (bgo#785308).
+  + Updated translations.
+- Recommend udftools: needed for optional udf file system support.
+
+---

Old:

  gparted-0.28.1.tar.gz
  gparted-0.28.1.tar.gz.sig

New:

  gparted-0.29.0.tar.gz
  gparted-0.29.0.tar.gz.sig



Other differences:
--
++ gparted.spec ++
--- /var/tmp/diff_new_pack.WYevVQ/_old  2017-09-04 12:35:26.430954054 +0200
+++ /var/tmp/diff_new_pack.WYevVQ/_new  2017-09-04 12:35:26.470948430 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gparted
-Version:0.28.1
+Version:0.29.0
 Release:0
 Summary:Gnome Partition Editor
 License:GPL-2.0
@@ -57,6 +57,7 @@
 Requires:   xdg-utils
 Requires:   xfsprogs
 Recommends: gpart
+Recommends: udftools
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description

++ gparted-0.28.1.tar.gz -> gparted-0.29.0.tar.gz ++
 73353 lines of diff (skipped)





commit supermin for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package supermin for openSUSE:Factory 
checked in at 2017-09-04 12:34:25

Comparing /work/SRC/openSUSE:Factory/supermin (Old)
 and  /work/SRC/openSUSE:Factory/.supermin.new (New)


Package is "supermin"

Mon Sep  4 12:34:25 2017 rev:4 rq:520161 version:5.1.18

Changes:

--- /work/SRC/openSUSE:Factory/supermin/supermin.changes2017-08-24 
18:38:17.868576253 +0200
+++ /work/SRC/openSUSE:Factory/.supermin.new/supermin.changes   2017-09-04 
12:34:41.189315233 +0200
@@ -1,0 +2,6 @@
+Thu Aug 31 14:09:58 UTC 2017 - cbosdon...@suse.com
+
+- Distro detection: also use ID_LIKE to catch suse distros
+  add patch: suse_release.patch
+
+---

New:

  suse_release.patch



Other differences:
--
++ supermin.spec ++
--- /var/tmp/diff_new_pack.324pa8/_old  2017-09-04 12:34:42.377148219 +0200
+++ /var/tmp/diff_new_pack.324pa8/_new  2017-09-04 12:34:42.397145407 +0200
@@ -30,6 +30,8 @@
 Requires:   zypper
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source0:supermin-%{version}.tar.xz
+# Pending upstream review
+Patch0: suse_release.patch
 %if "%{?_ignore_exclusive_arch}" == ""
 ExclusiveArch:  x86_64 ppc64 ppc64le s390x aarch64
 %endif
@@ -59,6 +61,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 export ZYPPER=zypper

++ suse_release.patch ++
Index: supermin-5.1.18/src/os_release.ml
===
--- supermin-5.1.18.orig/src/os_release.ml
+++ supermin-5.1.18/src/os_release.ml
@@ -29,6 +29,7 @@ let split sep str =
 
 type os_release = {
   id : string;
+  id_like : string list;
 }
 
 let data = ref None
@@ -52,6 +53,7 @@ and parse () =
 let lines = List.filter (fun s -> s.[0] <> '#') lines in
 
 let id = ref "" in
+let id_like = ref [] in
 
 List.iter (
   fun line ->
@@ -65,10 +67,11 @@ and parse () =
   else value in
 match field with
 | "ID" -> id := value
+| "ID_LIKE" -> id_like := string_split " " value
 | _ -> ()
 ) lines;
 
-Some { id = !id; }
+Some { id = !id; id_like = !id_like }
   ) else
 None
 
@@ -76,3 +79,8 @@ let get_id () =
   match get_data () with
   | None -> ""
   | Some d -> d.id
+
+let get_id_like () =
+  match get_data () with
+  | None -> []
+  | Some d -> d.id_like
Index: supermin-5.1.18/src/os_release.mli
===
--- supermin-5.1.18.orig/src/os_release.mli
+++ supermin-5.1.18/src/os_release.mli
@@ -24,3 +24,10 @@ val get_id : unit -> string
 
 An empty string is returned if the file does not exist or cannot
 be read. *)
+
+val get_id_like : unit -> string list
+(** Get the value of the "ID_LIKE" field from the /etc/os-release file
+on the current system.
+
+An empty list is returned if the file does not exist, cannot
+be read or the ID_LIKE field is not defined. *)
Index: supermin-5.1.18/src/ph_rpm.ml
===
--- supermin-5.1.18.orig/src/ph_rpm.ml
+++ supermin-5.1.18/src/ph_rpm.ml
@@ -41,6 +41,7 @@ let opensuse_detect () =
   Config.rpm <> "no" && Config.rpm2cpio <> "no" && rpm_is_available () &&
 Config.zypper <> "no" &&
 (List.mem (Os_release.get_id ()) [ "opensuse"; "sled"; "sles" ] ||
+ List.mem "suse" (Os_release.get_id_like ()) ||
  try (stat "/etc/SuSE-release").st_kind = S_REG with Unix_error _ -> false)
 
 let mageia_detect () =



commit fsarchiver for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package fsarchiver for openSUSE:Factory 
checked in at 2017-09-04 12:34:32

Comparing /work/SRC/openSUSE:Factory/fsarchiver (Old)
 and  /work/SRC/openSUSE:Factory/.fsarchiver.new (New)


Package is "fsarchiver"

Mon Sep  4 12:34:32 2017 rev:23 rq:520164 version:0.8.2

Changes:

--- /work/SRC/openSUSE:Factory/fsarchiver/fsarchiver.changes2017-01-12 
15:57:57.709477732 +0100
+++ /work/SRC/openSUSE:Factory/.fsarchiver.new/fsarchiver.changes   
2017-09-04 12:34:44.384865926 +0200
@@ -1,0 +2,8 @@
+Fri Sep  1 11:48:06 UTC 2017 - lazy.k...@opensuse.org
+
+- Update to 0.8.2.
+  * Add support for the latest ext4 filesystem features.
+  * Improved support of large block device when restoring extfs
+filesystems.
+
+---

Old:

  fsarchiver-0.8.1.tar.gz

New:

  fsarchiver-0.8.2.tar.gz



Other differences:
--
++ fsarchiver.spec ++
--- /var/tmp/diff_new_pack.OLzQSm/_old  2017-09-04 12:34:45.284739400 +0200
+++ /var/tmp/diff_new_pack.OLzQSm/_new  2017-09-04 12:34:45.288738837 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   fsarchiver
-Version:0.8.1
+Version:0.8.2
 Release:0
 Summary:Filesystem Archiver
 License:GPL-2.0

++ fsarchiver-0.8.1.tar.gz -> fsarchiver-0.8.2.tar.gz ++
 4232 lines of diff (skipped)




commit openssl-1_1_0 for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package openssl-1_1_0 for openSUSE:Factory 
checked in at 2017-09-04 12:34:23

Comparing /work/SRC/openSUSE:Factory/openssl-1_1_0 (Old)
 and  /work/SRC/openSUSE:Factory/.openssl-1_1_0.new (New)


Package is "openssl-1_1_0"

Mon Sep  4 12:34:23 2017 rev:6 rq:520158 version:1.1.0f

Changes:

--- /work/SRC/openSUSE:Factory/openssl-1_1_0/openssl-1_1_0.changes  
2017-08-16 16:19:05.364108722 +0200
+++ /work/SRC/openSUSE:Factory/.openssl-1_1_0.new/openssl-1_1_0.changes 
2017-09-04 12:34:37.157882069 +0200
@@ -1,0 +2,9 @@
+Fri Sep  1 11:33:46 UTC 2017 - vci...@suse.com
+
+- update DEFAULT_SUSE cipher list (bsc#1055825)
+  * add CHACHA20-POLY1305
+  * add ECDSA ciphers
+  * remove 3DES
+- modified openssl-1.0.1e-add-suse-default-cipher.patch
+
+---



Other differences:
--
++ openssl-1.0.1e-add-suse-default-cipher.patch ++
--- /var/tmp/diff_new_pack.yF664M/_old  2017-09-04 12:34:38.741659383 +0200
+++ /var/tmp/diff_new_pack.yF664M/_new  2017-09-04 12:34:38.741659383 +0200
@@ -1,8 +1,8 @@
-Index: openssl-1.1.0c/ssl/ssl_ciph.c
+Index: openssl-1.1.0f/ssl/ssl_ciph.c
 ===
 openssl-1.1.0c.orig/ssl/ssl_ciph.c 2016-12-08 16:13:39.990850602 +0100
-+++ openssl-1.1.0c/ssl/ssl_ciph.c  2016-12-08 16:13:40.022851089 +0100
-@@ -1468,7 +1468,14 @@ STACK_OF(SSL_CIPHER) *ssl_create_cipher_
+--- openssl-1.1.0f.orig/ssl/ssl_ciph.c 2017-05-25 14:46:20.0 +0200
 openssl-1.1.0f/ssl/ssl_ciph.c  2017-09-01 11:54:09.848587297 +0200
+@@ -1461,7 +1461,14 @@ STACK_OF(SSL_CIPHER) *ssl_create_cipher_
   */
  ok = 1;
  rule_p = rule_str;
@@ -18,17 +18,19 @@
  ok = ssl_cipher_process_rulestr(SSL_DEFAULT_CIPHER_LIST,
  , , ca_list, c);
  rule_p += 7;
-Index: openssl-1.1.0c/include/openssl/ssl.h
+Index: openssl-1.1.0f/include/openssl/ssl.h
 ===
 openssl-1.1.0c.orig/include/openssl/ssl.h  2016-11-10 15:03:46.0 
+0100
-+++ openssl-1.1.0c/include/openssl/ssl.h   2016-12-08 16:13:40.022851089 
+0100
-@@ -195,6 +195,9 @@ extern "C" {
+--- openssl-1.1.0f.orig/include/openssl/ssl.h  2017-05-25 14:46:20.0 
+0200
 openssl-1.1.0f/include/openssl/ssl.h   2017-09-01 13:16:59.850407734 
+0200
+@@ -195,6 +195,11 @@ extern "C" {
   * an application-defined cipher list string starts with 'DEFAULT'.
   */
  # define SSL_DEFAULT_CIPHER_LIST "ALL:!COMPLEMENTOFDEFAULT:!eNULL"
-+# define SSL_DEFAULT_SUSE_CIPHER_LIST 
"ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:"\
-+
"DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-CAMELLIA256-SHA:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-CAMELLIA128-SHA:"\
-+
"AES256-GCM-SHA384:AES256-SHA256:AES256-SHA:CAMELLIA256-SHA:AES128-GCM-SHA256:AES128-SHA256:AES128-SHA:CAMELLIA128-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:DES-CBC3-SHA"
++# define SSL_DEFAULT_SUSE_CIPHER_LIST 
"ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:"\
++
"ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-SHA256:"\
++
"ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:"\
++
"DHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-CAMELLIA256-SHA:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-RSA-CAMELLIA128-SHA:"\
++
"AES256-GCM-SHA384:AES256-SHA256:AES256-SHA:CAMELLIA256-SHA:AES128-GCM-SHA256:AES128-SHA256:AES128-SHA:CAMELLIA128-SHA"
  /*
   * As of OpenSSL 1.0.0, ssl_create_cipher_list() in ssl/ssl_ciph.c always
   * starts with a reasonable order, and all we have to do for DEFAULT is






commit nodejs8 for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package nodejs8 for openSUSE:Factory checked 
in at 2017-09-04 12:34:20

Comparing /work/SRC/openSUSE:Factory/nodejs8 (Old)
 and  /work/SRC/openSUSE:Factory/.nodejs8.new (New)


Package is "nodejs8"

Mon Sep  4 12:34:20 2017 rev:2 rq:520137 version:8.4.0

Changes:

--- /work/SRC/openSUSE:Factory/nodejs8/nodejs8.changes  2017-08-24 
18:38:07.166084023 +0200
+++ /work/SRC/openSUSE:Factory/.nodejs8.new/nodejs8.changes 2017-09-04 
12:34:31.434686772 +0200
@@ -1,0 +2,65 @@
+Sat Aug 19 05:58:32 UTC 2017 - qantas94he...@gmail.com
+
+- New upstream release 8.4.0
+  * HTTP2: Experimental support for the built-in http2 module has
+been added via the --expose-http2 flag. (#14239)
+  * Inspector:
++ require() is available in the inspector console now. (#8837)
++ Multiple contexts, as created by the vm module, are supported
+  now. (#14465)
+  * N-API: New APIs for creating number values have been
+introduced. (#14573)
+  * Stream: For Duplex streams, the high water mark option can now
+be set independently for the readable and the writable side.
+(#14636)
+  * Util: util.format now supports the %o and %O specifiers for
+printing objects. (#14558)
+- Changes in release 8.3.0
+  * V8: The V8 engine has been upgraded to version 6.0, which has a
+significantly changed performance profile. (#14574)
+  * DNS: Independent DNS resolver instances are supported now, with
+support for  cancelling the corresponding requests. (#14518)
+  * N-API: Multiple N-API functions for error handling have been
+changed to support assigning error codes. (#13988)
+  * REPL: Autocompletion support for require() has been improved.
+(#14409)
+  * Utilities: The WHATWG Encoding Standard (TextDecoder and
+TextEncoder) has been implemented as an experimental feature.
+(#13644)
+
+---
+Wed Aug  2 15:16:57 UTC 2017 - adam.ma...@suse.de
+
+- Fix update-alternative handling in %postun - don't remove
+  links on upgrades.
+
+---
+Thu Jul 27 10:12:36 UTC 2017 - qantas94he...@gmail.com
+
+- New upstream release 8.2.1
+  * http: Writes no longer abort if the Socket is missing.
+  * process, async_hooks: Avoid problems when triggerAsyncId is
+undefined.
+  * zlib: Streams no longer attempt to process data when destroyed.
+- Changes in upstream release 8.2.0
+ * async_hooks: Multiple improvements to Promise support in
+   async_hooks have been made.
+ * build: The compiler version requirement to build Node with GCC
+   has been raised to GCC 4.9.4. [820b011ed6] #13466
+ * cluster: Users now have more fine-grained control over the
+   inspector port used by individual cluster workers. Previously,
+   cluster workers were restricted to incrementing from the
+   master's debug port. [dfc46e262a] #14140
+ * dns:
+   + The server used for DNS queries can now use a custom port.
+ [ebe7bb29aa] #13723
+   + Support for dns.resolveAny() has been added.
+ [6e30e2558e] #13137
+ * npm: The npm CLI has been updated to version 5.3.0. In
+   particular, it now comes with the npx binary, which is also
+   shipped with Node.
+- Modify versioned.patch:
+ * Add support for new npx binary introduced in npm 5.3.0,
+   versioned as `/usr/bin/npx8`.
+
+---
@@ -9 +74 @@
-robust solution is found. (bnc#1048299)
+robust solution is found. (bnc#1048299, CVE-2017-11499)

Old:

  node-v8.1.4.tar.xz

New:

  node-v8.4.0.tar.xz



Other differences:
--
++ nodejs8.spec ++
--- /var/tmp/diff_new_pack.gQnvHn/_old  2017-09-04 12:34:34.782216097 +0200
+++ /var/tmp/diff_new_pack.gQnvHn/_new  2017-09-04 12:34:34.786215535 +0200
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 ###
 #
 #   WARNING! WARNING! WARNING! WARNING! WARNING! WARNING!
@@ -25,7 +26,7 @@
 ###
 
 Name:   nodejs8
-Version:8.1.4
+Version:8.4.0
 Release:0
 
 %if 0%{?sles_version} == 11
@@ -111,8 +112,15 @@
 BuildRequires:  binutils-gold
 %endif
 
+# Node.js 4/6/7 requires GCC 4.8.5+.
+# Upstream asks for GCC 4.9.4+ with 8.x, but that is more for
+# maintenance reasons and potential C++11 issues rather than
+# a failure to compile with GCC 4.8. (GH: nodejs/node, d13a65ad)
+# Only SLE 11 has a default compiler version older than necessary.
 %if 0%{?sles_version} == 11
 BuildRequires:  gcc48-c++
+%define cc_exec  gcc-4.8
+%define cpp_exec g++-4.8
 %else
 BuildRequires:  

commit libguestfs for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package libguestfs for openSUSE:Factory 
checked in at 2017-09-04 12:34:55

Comparing /work/SRC/openSUSE:Factory/libguestfs (Old)
 and  /work/SRC/openSUSE:Factory/.libguestfs.new (New)


Package is "libguestfs"

Mon Sep  4 12:34:55 2017 rev:53 rq:520200 version:1.36.5

Changes:

--- /work/SRC/openSUSE:Factory/libguestfs/libguestfs.changes2017-08-22 
11:07:32.769971394 +0200
+++ /work/SRC/openSUSE:Factory/.libguestfs.new/libguestfs.changes   
2017-09-04 12:35:03.946115530 +0200
@@ -1,0 +2,10 @@
+Thu Aug 31 15:25:06 UTC 2017 - cbosdon...@suse.com
+
+- Fix python binding for python3
+  add patches:
+  * 9d25b4e5-python-add-simple-wrappers-for-PyObject-string-funct.patch
+  * f3f99a09-python-use-right-func-when-PyString_FromStringAndSiz.patch
+- Better fix for SUSE distro detection using ID_LIKE as fallback:
+  * use-idlike.patch
+
+---

New:

  9d25b4e5-python-add-simple-wrappers-for-PyObject-string-funct.patch
  f3f99a09-python-use-right-func-when-PyString_FromStringAndSiz.patch
  use-idlike.patch



Other differences:
--
++ libguestfs.spec ++
--- /var/tmp/diff_new_pack.9h2YnL/_old  2017-09-04 12:35:06.301784311 +0200
+++ /var/tmp/diff_new_pack.9h2YnL/_new  2017-09-04 12:35:06.317782062 +0200
@@ -140,6 +140,11 @@
 License:GPL-2.0
 Group:  System/Filesystems
 Patch0: -hotfix.patch
+# PATCH-FIX-UPSTREAM - python3 fixes
+Patch1: 
9d25b4e5-python-add-simple-wrappers-for-PyObject-string-funct.patch
+Patch2: 
f3f99a09-python-use-right-func-when-PyString_FromStringAndSiz.patch
+# PATCH-FIX-OPENSUSE - pending upstream review, fixing distro detection in OBS
+Patch3: use-idlike.patch
 Patch100:   appliance.patch
 
 Source0:
http://download.libguestfs.org/1.36-stable/libguestfs-%{version}.tar.gz
@@ -301,6 +306,7 @@
 Allows lua scripts to directly use libguestfs.
 %endif
 #
+
 %if %{with python_bindings}
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %package -n python2-libguestfs
@@ -550,6 +556,9 @@
 : _ignore_exclusive_arch '%{?_ignore_exclusive_arch}'
 %setup -q -a 789653
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 %patch100 -p1
 
 %build

++ 9d25b4e5-python-add-simple-wrappers-for-PyObject-string-funct.patch 
++
>From 9d25b4e56471f9c33ea6229a8b620fc800c240f8 Mon Sep 17 00:00:00 2001
From: Pino Toscano 
Date: Tue, 9 May 2017 15:12:40 +0200
Subject: [PATCH] python: add simple wrappers for PyObject<->string functions

The current need for #ifdef's based on the presence of
PyString_FromString makes both the OCaml code of the generator, and the
generated C code a mess to read.

Hence, add three simple wrappers to make both the OCaml, and C code more
readable, and easier to tweak in the future.

This should be just refactoring, with no actual behaviour changes.

Thanks to: Matteo Cafasso
---
 generator/python.ml | 72 -
 python/handle.c | 65 ++-
 2 files changed, 53 insertions(+), 84 deletions(-)

diff --git a/generator/python.ml b/generator/python.ml
index 0162733f9..cf0829489 100644
--- a/generator/python.ml
+++ b/generator/python.ml
@@ -91,6 +91,9 @@ extern PyObject *guestfs_int_py_event_to_string (PyObject 
*self, PyObject *args)
 extern char **guestfs_int_py_get_string_list (PyObject *obj);
 extern PyObject *guestfs_int_py_put_string_list (char * const * const argv);
 extern PyObject *guestfs_int_py_put_table (char * const * const argv);
+extern PyObject *guestfs_int_py_fromstring (const char *str);
+extern PyObject *guestfs_int_py_fromstringsize (const char *str, size_t size);
+extern char *guestfs_int_py_asstring (PyObject *obj);
 
 ";
 
@@ -178,31 +181,16 @@ and generate_python_structs () =
 function
 | name, FString ->
 pr "  PyDict_SetItemString (dict, \"%s\",\n" name;
-pr "#ifdef HAVE_PYSTRING_ASSTRING\n";
-pr "PyString_FromString (%s->%s));\n"
-  typ name;
-pr "#else\n";
-pr "PyUnicode_FromString (%s->%s));\n"
-  typ name;
-pr "#endif\n"
+pr "guestfs_int_py_fromstring (%s->%s));\n"
+  typ name
 | name, FBuffer ->
 pr "  PyDict_SetItemString (dict, \"%s\",\n" name;
-pr "#ifdef HAVE_PYSTRING_ASSTRING\n";
-pr "PyString_FromStringAndSize (%s->%s, 
%s->%s_len));\n"
-  typ name typ name;
-pr "#else\n";
-pr "   

commit python-wikipedia for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-wikipedia for 
openSUSE:Factory checked in at 2017-09-04 12:35:13

Comparing /work/SRC/openSUSE:Factory/python-wikipedia (Old)
 and  /work/SRC/openSUSE:Factory/.python-wikipedia.new (New)


Package is "python-wikipedia"

Mon Sep  4 12:35:13 2017 rev:2 rq:520222 version:1.4.0

Changes:

--- /work/SRC/openSUSE:Factory/python-wikipedia/python-wikipedia.changes
2016-04-28 16:58:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-wikipedia.new/python-wikipedia.changes   
2017-09-04 12:35:18.264102353 +0200
@@ -1,0 +2,5 @@
+Thu Aug 24 13:57:39 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -4,0 +10 @@
+



Other differences:
--
++ python-wikipedia.spec ++
--- /var/tmp/diff_new_pack.BYj5vf/_old  2017-09-04 12:35:19.159976389 +0200
+++ /var/tmp/diff_new_pack.BYj5vf/_new  2017-09-04 12:35:19.163975827 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-wikipedia
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,6 +16,7 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-wikipedia
 Version:1.4.0
 Release:0
@@ -23,20 +24,21 @@
 License:MIT
 Group:  Development/Languages/Python
 Url:https://github.com/goldsmith/Wikipedia
-Source: 
https://pypi.python.org/packages/source/w/wikipedia/wikipedia-%{version}.tar.gz
-BuildRequires:  python-devel
-BuildRequires:  python-nose
-BuildRequires:  python-setuptools
-# REEQUIRED FOR %%check
-BuildRequires:  python-beautifulsoup4
-BuildRequires:  python-requests
+Source: 
https://files.pythonhosted.org/packages/source/w/wikipedia/wikipedia-%{version}.tar.gz
+BuildRequires:  %{python_module beautifulsoup4}
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module nose}
+BuildRequires:  %{python_module requests}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
 Requires:   python-beautifulsoup4
 Requires:   python-requests
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
+%python_subpackages
 
 %description
-**Wikipedia** is a Python library that makes it easy to access and parse
+Wikipedia is a Python library that makes it easy to access and parse
 data from Wikipedia.
 
 Search Wikipedia, get article summaries, get data like links and images
@@ -48,15 +50,16 @@
 %setup -q -n wikipedia-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
 
 %check
-nosetests
+ln -s tests/request_mock_data.py .
+%python_expand nosetests-%{$python_bin_suffix} 
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc LICENSE README.rst
 %{python_sitelib}/*




commit libressl for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package libressl for openSUSE:Factory 
checked in at 2017-09-04 12:35:18

Comparing /work/SRC/openSUSE:Factory/libressl (Old)
 and  /work/SRC/openSUSE:Factory/.libressl.new (New)


Package is "libressl"

Mon Sep  4 12:35:18 2017 rev:32 rq:520239 version:2.6.0

Changes:

--- /work/SRC/openSUSE:Factory/libressl/libressl.changes2017-08-28 
15:17:48.111358661 +0200
+++ /work/SRC/openSUSE:Factory/.libressl.new/libressl.changes   2017-09-04 
12:35:22.263540013 +0200
@@ -1,0 +2,40 @@
+Fri Sep  1 12:09:37 UTC 2017 - jeng...@inai.de
+
+- Update to new upstream release 2.6.0
+  * Added support for providing CRLs to libtls. Once a CRL is
+provided, we enable CRL checking for the full certificate
+chain.
+  * Allow non-compliant clients using IP literal addresses with
+SNI to connect to a server using libtls.
+  * Avoid a potential NULL pointer dereference in
+d2i_ECPrivateKey().
+  * Added definitions for three OIDs used in EV certificates.
+  * Plugged a memory leak in tls_ocsp_free.
+  * Added tls_peer_cert_chain_pem, tls_cert_hash, and
+tls_hex_string to libtls, useful in private certificate
+validation callbacks.
+  * Reworked TLS certificate name verification code to more
+strictly follow RFC 6125.
+  * Added tls_keypair_clear_key for clearing key material.
+  * Removed inconsistent IPv6 handling from
+BIO_get_accept_socket, simplified BIO_get_host_ip and
+BIO_accept.
+  * Fixed the openssl(1) ca command so that is generates
+certificates with RFC 5280-conformant time.
+  * Added ASN1_TIME_set_tm to set an asn1 from a struct tm *.
+  * Added SSL{,_CTX}_set_{min,max}_proto_version() functions.
+  * Added HKDF (HMAC Key Derivation Function) from BoringSSL
+  * Providea a tls_unload_file() function that frees the memory
+returned from a tls_load_file() call, ensuring that it the
+contents become inaccessible. This is specifically needed on
+platforms where the library allocators may be different from
+the application allocator.
+  * Perform reference counting for tls_config. This allows
+tls_config_free() to be called as soon as it has been passed
+to the final tls_configure() call, simplifying lifetime
+tracking for the application.
+  * Moved internal state of SSL and other structures to be
+opaque.
+  * Dropped cipher suites with DSS authentication.
+
+---

Old:

  libressl-2.5.5.tar.gz
  libressl-2.5.5.tar.gz.asc

New:

  libressl-2.6.0.tar.gz
  libressl-2.6.0.tar.gz.asc



Other differences:
--
++ libressl.spec ++
--- /var/tmp/diff_new_pack.geG2yT/_old  2017-09-04 12:35:23.247401677 +0200
+++ /var/tmp/diff_new_pack.geG2yT/_new  2017-09-04 12:35:23.25930 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   libressl
-Version:2.5.5
+Version:2.6.0
 Release:0
 Summary:An SSL/TLS protocol implementation
 License:OpenSSL

++ libressl-2.5.5.tar.gz -> libressl-2.6.0.tar.gz ++
 14191 lines of diff (skipped)




commit memcached for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package memcached for openSUSE:Factory 
checked in at 2017-09-04 12:35:03

Comparing /work/SRC/openSUSE:Factory/memcached (Old)
 and  /work/SRC/openSUSE:Factory/.memcached.new (New)


Package is "memcached"

Mon Sep  4 12:35:03 2017 rev:34 rq:520202 version:1.4.39

Changes:

--- /work/SRC/openSUSE:Factory/memcached/memcached.changes  2017-04-11 
09:37:05.629475205 +0200
+++ /work/SRC/openSUSE:Factory/.memcached.new/memcached.changes 2017-09-04 
12:35:14.212672004 +0200
@@ -1,0 +2,12 @@
+Fri Sep  1 13:54:33 UTC 2017 - tbecht...@suse.com
+
+- update to 1.4.39:
+  https://github.com/memcached/memcached/wiki/ReleaseNotes1439
+  (bsc#1056865) (CVE-2017-9951)
+  https://github.com/memcached/memcached/wiki/ReleaseNotes1438
+  https://github.com/memcached/memcached/wiki/ReleaseNotes1437
+  https://github.com/memcached/memcached/wiki/ReleaseNotes1436
+  https://github.com/memcached/memcached/wiki/ReleaseNotes1435
+  https://github.com/memcached/memcached/wiki/ReleaseNotes1434
+
+---

Old:

  memcached-1.4.33.tar.gz

New:

  memcached-1.4.39.tar.gz



Other differences:
--
++ memcached.spec ++
--- /var/tmp/diff_new_pack.KeCaag/_old  2017-09-04 12:35:15.508489805 +0200
+++ /var/tmp/diff_new_pack.KeCaag/_new  2017-09-04 12:35:15.520488119 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   memcached
-Version:1.4.33
+Version:1.4.39
 Release:0
 Summary:A high-performance, distributed memory object caching system
 License:BSD-3-Clause

++ memcached-1.4.33.tar.gz -> memcached-1.4.39.tar.gz ++
 5960 lines of diff (skipped)

++ memcached-use-endian_h.patch ++
--- /var/tmp/diff_new_pack.KeCaag/_old  2017-09-04 12:35:15.924431322 +0200
+++ /var/tmp/diff_new_pack.KeCaag/_new  2017-09-04 12:35:15.936429635 +0200
@@ -2,7 +2,7 @@
 ===
 --- util.c.orig
 +++ util.c
-@@ -150,30 +150,3 @@ void vperror(const char *fmt, ...) {
+@@ -167,30 +167,3 @@ void vperror(const char *fmt, ...) {
  perror(buf);
  }
  
@@ -37,7 +37,7 @@
 ===
 --- util.h.orig
 +++ util.h
-@@ -11,15 +11,16 @@ bool uriencode(const char *src, char *ds
+@@ -11,16 +11,17 @@ bool uriencode(const char *src, char *ds
   *
   * returns true if conversion succeeded.
   */
@@ -48,6 +48,7 @@
  bool safe_strtoll(const char *str, int64_t *out);
  bool safe_strtoul(const char *str, uint32_t *out);
  bool safe_strtol(const char *str, int32_t *out);
+ bool safe_strtod(const char *str, double *out);
  
 -#ifndef HAVE_HTONLL
 -extern uint64_t htonll(uint64_t);




commit tpm2.0-abrmd for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package tpm2.0-abrmd for openSUSE:Factory 
checked in at 2017-09-04 12:34:51

Comparing /work/SRC/openSUSE:Factory/tpm2.0-abrmd (Old)
 and  /work/SRC/openSUSE:Factory/.tpm2.0-abrmd.new (New)


Package is "tpm2.0-abrmd"

Mon Sep  4 12:34:51 2017 rev:3 rq:520199 version:1.1.1

Changes:

--- /work/SRC/openSUSE:Factory/tpm2.0-abrmd/tpm2.0-abrmd.changes
2017-08-30 16:24:39.977141199 +0200
+++ /work/SRC/openSUSE:Factory/.tpm2.0-abrmd.new/tpm2.0-abrmd.changes   
2017-09-04 12:34:55.975236270 +0200
@@ -1,0 +2,6 @@
+Fri Sep  1 14:37:48 UTC 2017 - matthias.gerst...@suse.com
+
+- package version symlink correctly, belongs into the lib package itself, not
+  the -devel.
+
+---



Other differences:
--
++ tpm2.0-abrmd.spec ++
--- /var/tmp/diff_new_pack.GoaK4O/_old  2017-09-04 12:34:56.819117617 +0200
+++ /var/tmp/diff_new_pack.GoaK4O/_new  2017-09-04 12:34:56.827116492 +0200
@@ -134,12 +134,11 @@
 %defattr(-,root,root)
 %{_includedir}/tcti
 %{_libdir}/*.so
-%{_libdir}/*.so.0
 %{_libdir}/pkgconfig/*.pc
 %{_mandir}/man3/tss2_*
 
 %files -n libtcti-tabrmd0
 %defattr(-,root,root)
-%{_libdir}/libtcti-tabrmd.so.0.0.0
+%{_libdir}/libtcti-tabrmd.so.*
 
 %changelog




commit tpm2-0-tss for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package tpm2-0-tss for openSUSE:Factory 
checked in at 2017-09-04 12:34:45

Comparing /work/SRC/openSUSE:Factory/tpm2-0-tss (Old)
 and  /work/SRC/openSUSE:Factory/.tpm2-0-tss.new (New)


Package is "tpm2-0-tss"

Mon Sep  4 12:34:45 2017 rev:9 rq:520198 version:1.1.0

Changes:

--- /work/SRC/openSUSE:Factory/tpm2-0-tss/tpm2-0-tss.changes2017-08-21 
11:36:46.820387877 +0200
+++ /work/SRC/openSUSE:Factory/.tpm2-0-tss.new/tpm2-0-tss.changes   
2017-09-04 12:34:51.431875087 +0200
@@ -1,0 +2,6 @@
+Fri Sep  1 14:27:33 UTC 2017 - matthias.gerst...@suse.com
+
+- fix the "fix", turns out only the unversioned symlink's supposed to go into
+  -devel.
+
+---



Other differences:
--
++ tpm2-0-tss.spec ++
--- /var/tmp/diff_new_pack.LOlKvm/_old  2017-09-04 12:34:52.303752497 +0200
+++ /var/tmp/diff_new_pack.LOlKvm/_new  2017-09-04 12:34:52.311751372 +0200
@@ -110,19 +110,18 @@
 %{_includedir}/tcti
 %{_includedir}/sapi
 %{_libdir}/*.so
-%{_libdir}/*.so.0
 %{_libdir}/pkgconfig/*.pc
 
 %files -n libsapi0
 %defattr(-,root,root)
-%{_libdir}/libsapi.so.0.0.0
+%{_libdir}/libsapi.so.*
 
 %files -n libtcti-device0
 %defattr(-,root,root)
-%{_libdir}/libtcti-device.so.0.0.0
+%{_libdir}/libtcti-device.so.*
 
 %files -n libtcti-socket0
 %defattr(-,root,root)
-%{_libdir}/libtcti-socket.so.0.0.0
+%{_libdir}/libtcti-socket.so.*
 
 %changelog




commit python-Markups for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-Markups for openSUSE:Factory 
checked in at 2017-09-04 12:33:51

Comparing /work/SRC/openSUSE:Factory/python-Markups (Old)
 and  /work/SRC/openSUSE:Factory/.python-Markups.new (New)


Package is "python-Markups"

Mon Sep  4 12:33:51 2017 rev:5 rq:520062 version:2.0.1

Changes:

--- /work/SRC/openSUSE:Factory/python-Markups/python-Markups.changes
2015-05-15 07:44:15.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-Markups.new/python-Markups.changes   
2017-09-04 12:33:57.183502609 +0200
@@ -1,0 +2,22 @@
+Thu Aug 31 06:25:00 UTC 2017 - toddrme2...@gmail.com
+
+- update to Version 2.0.1
+  * The new MathJax CDN is used, the old one will be shut down soon.
+  * When using MathJax with Markdown, the AMSmath and AMSsymbols extensions are
+now enabled.
+- update to Version 2.0.0, 2016-05-09
+  * Changed the API of pymarkups to clearly separate the conversion step from
+access to the various elements of the result. The old API is deprecated
+and will be removed in a future release. Please see the documentation for
+details on using the new API.
+  * The reStructuredText markup now includes document title and subtitle in
+the HTML body.
+  * Added a ``markup2html.py`` reference script to show API usage.
+  * Improved support for specifying Markdown extensions in the document.
+
+---
+Thu Aug 24 13:45:17 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -55,0 +78 @@
+

Old:

  Markups-0.6.1.tar.gz

New:

  Markups-2.0.1.tar.gz



Other differences:
--
++ python-Markups.spec ++
--- /var/tmp/diff_new_pack.7bUfJs/_old  2017-09-04 12:33:58.579306354 +0200
+++ /var/tmp/diff_new_pack.7bUfJs/_new  2017-09-04 12:33:58.607302418 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-Markups
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,23 +16,20 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-Markups
-Version:0.6.1
+Version:2.0.1
 Release:0
 Summary:A wrapper around various text markups
 License:BSD-3-Clause
 Group:  Development/Languages/Python
 Url:https://github.com/mitya57/pymarkups
-Source: 
http://pypi.python.org/packages/source/M/Markups/Markups-%{version}.tar.gz
-BuildRequires:  python-devel
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-BuildRequires:  python-importlib
-Requires:   python-importlib
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
+Source: 
https://files.pythonhosted.org/packages/source/M/Markups/Markups-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
 BuildArch:  noarch
-%endif
+%python_subpackages
 
 %description
 This module provides a wrapper around the various text markup languages,
@@ -42,14 +39,17 @@
 %setup -q -n Markups-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
 
-%files
+%check
+%python_exec setup.py test
+
+%files %{python_files}
 %defattr(-,root,root,-)
-%doc LICENSE README.rst examples
+%doc LICENSE README.rst changelog
 %{python_sitelib}/*
 
 %changelog

++ Markups-0.6.1.tar.gz -> Markups-2.0.1.tar.gz ++
 2120 lines of diff (skipped)




commit fio for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package fio for openSUSE:Factory checked in 
at 2017-09-04 12:34:07

Comparing /work/SRC/openSUSE:Factory/fio (Old)
 and  /work/SRC/openSUSE:Factory/.fio.new (New)


Package is "fio"

Mon Sep  4 12:34:07 2017 rev:40 rq:520108 version:2.99

Changes:

--- /work/SRC/openSUSE:Factory/fio/fio.changes  2017-07-29 09:02:41.805899676 
+0200
+++ /work/SRC/openSUSE:Factory/.fio.new/fio.changes 2017-09-04 
12:34:07.506051225 +0200
@@ -1,0 +2,5 @@
+Fri Sep  1 08:31:12 UTC 2017 - mplus...@suse.com
+
+- Update describtion and provide more documents
+
+---



Other differences:
--
++ fio.spec ++
--- /var/tmp/diff_new_pack.AqErdi/_old  2017-09-04 12:34:08.365930323 +0200
+++ /var/tmp/diff_new_pack.AqErdi/_new  2017-09-04 12:34:08.377928636 +0200
@@ -20,10 +20,10 @@
 Name:   fio
 Version:2.99
 Release:0
-Summary:Flexible I/O Tester/benchmarker
+Summary:Flexible I/O tester
 License:GPL-2.0
 Group:  System/Benchmark
-Url:http://freshmeat.net/projects/fio/
+Url:http://git.kernel.dk/?p=fio.git;a=summary
 Source: http://brick.kernel.dk/snaps/fio-%{version}.tar.bz2
 Source02:   http://brick.kernel.dk/snaps/fio-%{version}.tar.bz2.asc
 Source03:   %{name}.keyring
@@ -57,6 +57,7 @@
 %package -n gfio
 Summary:Graphical front end for fio
 Group:  System/Benchmark
+Requires:   %{name} = %{version}
 
 %description -n gfio
 gfio is a gtk based graphical front-end for fio.  It is often installed on the
@@ -94,7 +95,8 @@
 
 %files
 %doc COPYING README examples
-%doc HOWTO
+%doc HOWTO MORAL-LICENSE REPORTING-BUGS
+%doc GFIO-TODO SERVER-TODO STEADYSTATE-TODO
 %{_bindir}/fio
 %{_bindir}/fiologparser.py
 %{_bindir}/fio_generate_plots
@@ -112,7 +114,6 @@
 %{_mandir}/man1/fiologparser_hist.py.1%{ext_man}
 
 %files -n gfio
-%doc COPYING README GFIO-TODO
 %{_bindir}/gfio
 
 %changelog






commit mpc-qt for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package mpc-qt for openSUSE:Factory checked 
in at 2017-09-04 12:34:09

Comparing /work/SRC/openSUSE:Factory/mpc-qt (Old)
 and  /work/SRC/openSUSE:Factory/.mpc-qt.new (New)


Package is "mpc-qt"

Mon Sep  4 12:34:09 2017 rev:3 rq:520116 version:17.09

Changes:

--- /work/SRC/openSUSE:Factory/mpc-qt/mpc-qt.changes2017-08-28 
15:16:32.306010572 +0200
+++ /work/SRC/openSUSE:Factory/.mpc-qt.new/mpc-qt.changes   2017-09-04 
12:34:10.345651967 +0200
@@ -1,0 +2,22 @@
+Fri Sep  1 09:26:24 UTC 2017 - aloi...@gmx.com
+
+- Fixed locale path
+
+---
+Fri Sep  1 05:55:42 UTC 2017 - aloi...@gmx.com
+
+- Update to version 17.09
+  * Export MediaInfo to text file (#119)
+  * USe correct mousewheel direction (#118)
+  * Premangle the temporary image filename (#120)
+  * Don't reset the play speed when pressing play (#117)
+  * Honor --size argument (#89)
+  * Add palette editor (some shades are drawn by the system on
+Windows)
+  * Custom icons and basic themeing (#65)
+  * Integration of argon's stats.lua (#104)
+  * Populate audio device lists with mpv 0.26.0 (mentioned in #116)
+  * Add right-click menu (#113)
+  * Simplified resizing code (#114)
+
+---

Old:

  mpc-qt-17.08.tar.gz

New:

  mpc-qt-17.09.tar.gz



Other differences:
--
++ mpc-qt.spec ++
--- /var/tmp/diff_new_pack.5wPdsN/_old  2017-09-04 12:34:11.485491703 +0200
+++ /var/tmp/diff_new_pack.5wPdsN/_new  2017-09-04 12:34:11.489491140 +0200
@@ -19,7 +19,7 @@
 # See also http://en.opensuse.org/openSUSE:Specfile_guidelines
 
 Name:   mpc-qt
-Version:17.08
+Version:17.09
 Release:0
 Summary:Media Player Classic Qute Theater
 License:GPL-2.0
@@ -28,13 +28,13 @@
 Source0:
https://github.com/cmdrkotori/mpc-qt/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
 Source1:%{name}.changes
 BuildRequires:  libqt5-linguist
-BuildRequires:  pkgconfig(mpv) >= 0.24
 BuildRequires:  pkgconfig(Qt5Core)
 BuildRequires:  pkgconfig(Qt5DBus)
 BuildRequires:  pkgconfig(Qt5Gui)
 BuildRequires:  pkgconfig(Qt5Network)
 BuildRequires:  pkgconfig(Qt5Widgets) >= 5.4
 BuildRequires:  pkgconfig(Qt5X11Extras)
+BuildRequires:  pkgconfig(mpv) >= 0.24
 %if 0%{?suse_version} > 1320
 BuildRequires:  gcc-c++
 %else
@@ -70,7 +70,7 @@
 test -x "$(type -p g++-7)" && export CXX=g++-7
 qmake-qt5 \
   QMAKE_CFLAGS+="%{optflags}" QMAKE_CXXFLAGS+="%{optflags}" \
-  QMAKE_CC="${CC}" QMAKE_CXX="${CXX}" \
+  QMAKE_CC="${CC}" QMAKE_CXX="${CXX}" PREFIX=%{_prefix} \
   mpc-qt.pro
 make %{?_smp_mflags}
 
@@ -80,7 +80,7 @@
  %{buildroot}/%{_datadir}/pixmaps \
  %{buildroot}/%{_datadir}/%{name}/translations
 install -m 0755 %{name} %{buildroot}/%{_bindir}
-install -m 0644 images/icon/logo.svg 
%{buildroot}/%{_datadir}/pixmaps/%{name}.svg
+install -m 0644 images/icon/mpc-qt.svg 
%{buildroot}/%{_datadir}/pixmaps/%{name}.svg
 install -m 0644 resources/translations/%{name}_*.qm -t 
%{buildroot}/%{_datadir}/%{name}/translations
 # create .desktop file
 tee %{buildroot}/%{_datadir}/applications/Media\ Player\ Classic\ Qute\ 
Theater.desktop << "EOF"

++ mpc-qt-17.08.tar.gz -> mpc-qt-17.09.tar.gz ++
 3241 lines of diff (skipped)




commit mkvtoolnix for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package mkvtoolnix for openSUSE:Factory 
checked in at 2017-09-04 12:34:11

Comparing /work/SRC/openSUSE:Factory/mkvtoolnix (Old)
 and  /work/SRC/openSUSE:Factory/.mkvtoolnix.new (New)


Package is "mkvtoolnix"

Mon Sep  4 12:34:11 2017 rev:99 rq:520118 version:15.0.0

Changes:

--- /work/SRC/openSUSE:Factory/mkvtoolnix/mkvtoolnix.changes2017-08-29 
11:44:54.069383641 +0200
+++ /work/SRC/openSUSE:Factory/.mkvtoolnix.new/mkvtoolnix.changes   
2017-09-04 12:34:12.857298821 +0200
@@ -1,0 +2,74 @@
+Thu Aug 31 19:10:10 UTC 2017 - r...@fthiessen.de
+
+- Update to 15.0.0:
+  * Requires libebml >= 1.3.5
+  * Dropped disable-update-check.patch (upstream now provides
+configure option for disabling the update check).
+  * mkvmerge, mkvpropedit, GUI's header and chapter editors: the
+programs will no longer add most missing Matroska elements that
+are mandatory but have a default value in the Matroska
+specification (e.g. the `TagLanguage` element with a value of
+`und` if it isn't present in its `SimpleTag` parent).
+  * mkvmerge: the option `--colour-matrix` has been renamed to
+`--colour-matrix-coefficients` in order to match the
+specification more closely. The old option name will
+continue to be recognized as well.
+  * all: bugfix: selecting the program's language (e.g. via the
+`--ui-language`command-line option or via the GUI's
+preferences) did not work on Linux & Unix if the `LANGUAGE`
+environment variable was set and didn't include the desired
+language. 
+  * MKVToolNix GUI: new feature: multiplex tool: added a new entry
+to the "source files" context menu labeled "Set destination
+file name from selected file's name". It will force the GUI
+to consider the selected file to be the reference for
+automatically setting the file name, no matter which file was
+originally added as the first file. It will also force setting
+the destination file name once if automatic destination file
+name generation is turned off in the preferences.
+   new feature: multiplex tool: added an option in the preferences
+on "Multiplexer" → "Output" labeled "Only use the first source
+file that contains a video track". If enabled, only source
+files containing video tracks will be used for setting the
+destination file name. Other files that are added are ignore.
+   new feature: header editor: added support for editing the video
+colour attributes.
+   new feature: header editor: added support for the "video
+projection" track header attributes.
+   new feature: job queue: selected jobs can now be move up and
+down by pressing the `Ctrl+Up` and `Ctrl+Down` keys.
+Additionally, push buttons to move them up & down are shown
+if the corresponding option is enabled in the preferences.
+   bugfix: removed the keyboard shortcuts for switching between
+the different tools (e.g. `Ctrl+Alt+1` for the multiplexer).
+They overlapped with basic functionality on keyboards that
+use an `AltGr` key, e.g. German ones, where `AltGr+7` emits
+`{`. As `AltGr+key` is implemented as `Ctrl+Alt+key` under the
+hood, this means that `AltGr+7` is really `Ctrl+Alt+7` which
+the GUI now took to mean "switch to the job queue" instead of
+"insert `{`".
+   bugfix: header editor: after saving the file the GUI wasn't
+updating its internal file modification timestamp. That lead
+to the GUI wrongfully claiming that the file had been
+modified externally when the user wanted to save the file
+once more, requiring a reload of the file losing all
+modifications made since saving the first time.
+  * mkvmerge: new feature: added support for the
+"video projection" track header attributes.
+   bugfix: DTS handling: some source files provide timestamps for
+audio tracks only once every `n` audio frames.
+In such situations mkvmerge was buffering too much data
+resulting in a single gap in the timestamps of one frame
+duration after frame number `n - 1` (the second audio
+timestamp read from the source file was used one output
+frame too early).
+  * mkvinfo: new feature: added support for the
+"video projection" track header attributes.
+   bugfix: fixed a null pointer dereference if an `EbmlBinary`
+element's data pointer is a null pointer.
+  * mkvpropedit: new feature: added support for editing the
+video colour attributes.
+   new feature: added support for the "video projection"
+track header attributes.
+
+---

Old:

  disable-update-check.patch
  mkvtoolnix-14.0.0.tar.xz
  mkvtoolnix-14.0.0.tar.xz.sig

New:

  mkvtoolnix-15.0.0.tar.xz
  mkvtoolnix-15.0.0.tar.xz.sig


commit python-pylibmc for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-pylibmc for openSUSE:Factory 
checked in at 2017-09-04 12:33:43

Comparing /work/SRC/openSUSE:Factory/python-pylibmc (Old)
 and  /work/SRC/openSUSE:Factory/.python-pylibmc.new (New)


Package is "python-pylibmc"

Mon Sep  4 12:33:43 2017 rev:4 rq:520050 version:1.5.2

Changes:

--- /work/SRC/openSUSE:Factory/python-pylibmc/python-pylibmc.changes
2015-05-16 19:01:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-pylibmc.new/python-pylibmc.changes   
2017-09-04 12:33:49.116636835 +0200
@@ -1,0 +2,14 @@
+Thu Aug 31 21:35:05 UTC 2017 - toddrme2...@gmail.com
+
+- Update to version 1.5.2
+  * Fixes critical memory leaks in common code paths
+introduced in 1.4.2.
+  * Fixes a critical bug in a corner of the zlib inflation code,
+where prior memory errors would trigger a double free.
+
+---
+Thu Aug 24 13:51:15 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -36,0 +51 @@
+

Old:

  pylibmc-1.4.2.tar.gz

New:

  pylibmc-1.5.2.tar.gz



Other differences:
--
++ python-pylibmc.spec ++
--- /var/tmp/diff_new_pack.yz8yan/_old  2017-09-04 12:33:50.752406841 +0200
+++ /var/tmp/diff_new_pack.yz8yan/_new  2017-09-04 12:33:50.788401780 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pylibmc
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,21 +16,26 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%bcond_with test
 Name:   python-pylibmc
-Version:1.4.2
+Version:1.5.2
 Release:0
 Summary:Quick and small memcached client for Python
 License:BSD-3-Clause
 Group:  Development/Languages/Python
 Url:http://sendapatch.se/projects/pylibmc/
-Source: 
https://pypi.python.org/packages/source/p/pylibmc/pylibmc-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/p/pylibmc/pylibmc-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  fdupes
 BuildRequires:  libmemcached-devel
-BuildRequires:  python-devel
+BuildRequires:  python-rpm-macros
 BuildRequires:  zlib-devel
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitearch: %global python_sitearch %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+%if %{with test}
+BuildRequires:  %{python_module nose}
 %endif
+%python_subpackages
 
 %description
 pylibmc is a Python client for memcached written in C.
@@ -39,14 +44,24 @@
 %setup -q -n pylibmc-%{version}
 
 %build
-CFLAGS="%{optflags}" python setup.py build
+export CFLAGS="%{optflags}"
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
+%python_expand %fdupes %{buildroot}%{$python_sitearch}
 
-%files
+%if %{with test}
+%check
+export NOSE_IGNORE_CONFIG_FILES=1
+%{python_expand export PYTHONPATH=%{buildroot}%{$python_sitearch}
+nosetests-%{$python_bin_suffix} tests
+}
+%endif
+
+%files %{python_files}
 %defattr(-,root,root,-)
-%doc README.rst
+%doc LICENSE README.rst
 %{python_sitearch}/*
 
 %changelog

++ pylibmc-1.4.2.tar.gz -> pylibmc-1.5.2.tar.gz ++
 2817 lines of diff (skipped)




commit python-python-memcached for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-python-memcached for 
openSUSE:Factory checked in at 2017-09-04 12:33:38

Comparing /work/SRC/openSUSE:Factory/python-python-memcached (Old)
 and  /work/SRC/openSUSE:Factory/.python-python-memcached.new (New)


Package is "python-python-memcached"

Mon Sep  4 12:33:38 2017 rev:14 rq:520036 version:1.58

Changes:

--- 
/work/SRC/openSUSE:Factory/python-python-memcached/python-python-memcached.changes
  2015-10-08 08:25:01.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-python-memcached.new/python-python-memcached.changes
 2017-09-04 12:33:40.321873404 +0200
@@ -1,0 +2,17 @@
+Thu Aug 24 13:52:44 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
+Tue Nov 15 13:13:46 UTC 2016 - dmuel...@suse.com
+
+- update to 1.58:
+  *  Fixing a performance regression in v1.54 in Python 2, using cPickle again.
+  *  Support for "stats slabs".
+  *  Pin Six version to >= 1.4
+  *  setup.py build process pulls version from memcached.py
+  *  delete() and delete_multi() now default the "time" argument to None,
+ since the protocol doesn't allow a time in some implementations.
+ Patch by oremj #27
+
+---
@@ -131,0 +149 @@
+

Old:

  python-memcached-1.57.tar.gz

New:

  python-memcached-1.58.tar.gz



Other differences:
--
++ python-python-memcached.spec ++
--- /var/tmp/diff_new_pack.xKTe0b/_old  2017-09-04 12:33:41.221746879 +0200
+++ /var/tmp/diff_new_pack.xKTe0b/_new  2017-09-04 12:33:41.221746879 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-python-memcached
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,28 +16,33 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%define oldpython python
+%bcond_with test
 Name:   python-python-memcached
-Version:1.57
+Version:1.58
 Release:0
-Url:http://www.tummy.com/Community/software/python-memcached/
 Summary:Pure python memcached client
 License:Python-2.0
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/p/python-memcached/python-memcached-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  python-devel
-BuildRequires:  python-nose
-BuildRequires:  python-setuptools
-BuildRequires:  python-six
+Url:http://www.tummy.com/Community/software/python-memcached/
+Source: 
https://files.pythonhosted.org/packages/source/p/python-memcached/python-memcached-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  %{python_module six}
+BuildRequires:  python-rpm-macros
+%if %{with test}
+BuildRequires:  %{python_module nose}
+BuildRequires:  memcached
+%endif
+Requires:   memcached
 Requires:   python-six
-
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
 BuildArch:  noarch
+%ifpython2
+Provides:   %{oldpython}-memcached = %{version}
+Obsoletes:  %{oldpython}-memcached < %{version}
 %endif
-Provides:   python-memcached = %{version}
-Obsoletes:  python-memcached < %{version}
+%python_subpackages
 
 %description
 This package was originally written by Evan Martin of Danga.
@@ -52,17 +57,19 @@
 %setup -q -n python-memcached-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
 
+%if %{with test}
 %check
-nosetests
+%python_expand nosetests-%{$python_bin_suffix}
+%endif
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
-%doc README.md
+%doc README.md PSF.LICENSE
 %{python_sitelib}/*
 
 %changelog

++ python-memcached-1.57.tar.gz -> python-memcached-1.58.tar.gz ++
 1613 lines of diff (skipped)




commit caja for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package caja for openSUSE:Factory checked in 
at 2017-09-04 12:33:30

Comparing /work/SRC/openSUSE:Factory/caja (Old)
 and  /work/SRC/openSUSE:Factory/.caja.new (New)


Package is "caja"

Mon Sep  4 12:33:30 2017 rev:26 rq:520009 version:1.18.4

Changes:

--- /work/SRC/openSUSE:Factory/caja/caja.changes2017-05-16 
14:44:48.730021351 +0200
+++ /work/SRC/openSUSE:Factory/.caja.new/caja.changes   2017-09-04 
12:33:32.263006502 +0200
@@ -1,0 +2,13 @@
+Thu Aug 31 12:40:22 UTC 2017 - sor.ale...@meowr.ru
+
+- Update to version 1.18.4:
+  * Fix zoom in list-view.
+  * pathbar: Enable mousewheel scrolling like it was with GTK+2.
+  * open-with-dialog: Set max-char-width for a label.
+  * Fix "Open With" dialog ue"Open" button's text misalignment.
+  * caja-pathbar: Fix off-by-one error.
+  * Fix browsing/autorun media on insertion.
+  * Fix vertical Compact View scrolling in
+fm_icon_view_scroll_event().
+
+---

Old:

  caja-1.18.3.tar.xz

New:

  caja-1.18.4.tar.xz



Other differences:
--
++ caja.spec ++
--- /var/tmp/diff_new_pack.NMgvA5/_old  2017-09-04 12:33:33.458838365 +0200
+++ /var/tmp/diff_new_pack.NMgvA5/_new  2017-09-04 12:33:33.458838365 +0200
@@ -20,7 +20,7 @@
 %define typelib typelib-1_0-Caja-2_0
 %define _version 1.18
 Name:   caja
-Version:1.18.3
+Version:1.18.4
 Release:0
 Summary:File manager for the MATE desktop
 License:GPL-2.0 and LGPL-2.0

++ caja-1.18.3.tar.xz -> caja-1.18.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/caja-1.18.3/ChangeLog new/caja-1.18.4/ChangeLog
--- old/caja-1.18.3/ChangeLog   2017-05-11 07:15:31.0 +0200
+++ new/caja-1.18.4/ChangeLog   2017-08-26 14:04:56.0 +0200
@@ -1,3 +1,111 @@
+commit b959b45afd4c131dc4b761f3c262227b22aa1734
+Author: raveit65 
+Date:   Sat Aug 26 14:02:24 2017 +0200
+
+release 1.18.4
+
+ NEWS | 10 ++
+ configure.ac |  2 +-
+ 2 files changed, 11 insertions(+), 1 deletion(-)
+
+commit ee0de1a5e74cbed5cf49517ea82a73e52dd6424a
+Author: Jury Verrigni 
+Date:   Fri Aug 25 14:56:32 2017 +0100
+
+Adds columns autosizing
+
+ src/file-manager/fm-list-view.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+commit 1f5d0488d54d2affc0bcc54a8f21f8936110c688
+Author: Jury Verrigni 
+Date:   Fri Aug 25 11:14:32 2017 +0100
+
+Refresh all rows on zoom change
+
+ src/file-manager/fm-list-view.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+commit 14ce3294bed72bd6e4ab3cc2685f37ddc3a5b0db
+Author: Jury Verrigni 
+Date:   Thu Aug 24 21:40:55 2017 +0100
+
+Forces widget redraw on zoom
+
+ src/file-manager/fm-list-view.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+commit 9994201d979dbaa6543f280febf3e4023de6dc60
+Author: monsta 
+Date:   Thu Aug 24 15:24:21 2017 +0300
+
+pathbar: enable mousewheel scrolling like it was with GTK+2
+
+fixes https://github.com/mate-desktop/caja/issues/779
+
+ported from:
+
https://git.gnome.org/browse/nautilus/commit/?id=04116ab2876412445c788091be07d7f7321a4a94
+
+ src/caja-pathbar.c | 5 +
+ 1 file changed, 5 insertions(+)
+
+commit 90ccf70a06beee19f55b1d36a4b4ae33000758d5
+Author: raveit65 
+Date:   Sat Aug 19 15:11:49 2017 +0200
+
+open-with-dialog: set max-char-width for a label
+
+use max_char_width for 'Select and application to view his description'
+label, as this can cause a window size jumping for this gui.
+Depends on language translations.
+Ie. german language was affected.
+
+ libcaja-private/caja-open-with-dialog.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+commit 8d17eb9d48491ba9b1d96b3409730455f8cffba1
+Author: lukefromdc 
+Date:   Fri Aug 18 17:48:34 2017 -0400
+
+Fix #828 "Open With" dialog "Open" button's text misaligned
+
+ libcaja-private/caja-open-with-dialog.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+commit d4b4d08300fe27dbb57ad10ba31a91c5cfd54781
+Author: nokangaroo 
+Date:   Wed Jun 21 09:24:54 2017 +0200
+
+Fix off-by-one error in caja-pathbar.c
+
+ src/caja-pathbar.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+commit d3b66148f9b914fa0451508c6ddb075d0fab8fdb
+Author: lukefromdc 
+Date:   Sat Jul 8 15:14:32 2017 -0400
+
+Fix browsing/autorun media on insertion
+
+Fix https://github.com/mate-desktop/caja/issues/807
+
+ src/caja-application.c | 1 +
+ 1 file changed, 1 insertion(+)
+

commit python-virtkey for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-virtkey for openSUSE:Factory 
checked in at 2017-09-04 12:33:49

Comparing /work/SRC/openSUSE:Factory/python-virtkey (Old)
 and  /work/SRC/openSUSE:Factory/.python-virtkey.new (New)


Package is "python-virtkey"

Mon Sep  4 12:33:49 2017 rev:16 rq:520057 version:0.63.0

Changes:

--- /work/SRC/openSUSE:Factory/python-virtkey/python-virtkey.changes
2013-01-17 10:19:12.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-virtkey.new/python-virtkey.changes   
2017-09-04 12:33:51.520298873 +0200
@@ -1,0 +2,5 @@
+Thu Aug 24 13:57:00 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -67,0 +73 @@
+



Other differences:
--
++ python-virtkey.spec ++
--- /var/tmp/diff_new_pack.y4SX6l/_old  2017-09-04 12:33:52.768123425 +0200
+++ /var/tmp/diff_new_pack.y4SX6l/_new  2017-09-04 12:33:52.788120613 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-virtkey
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,54 +16,47 @@
 #
 
 
-%define mod_name virtkey
-%define build_for_python3 0
-
-%if %{build_for_python3}
-%define local_python  python3
-%else
-%define local_python  python
-%endif
-
-Name:   python-%{mod_name}
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+Name:   python-virtkey
 Version:0.63.0
+%define major   0.63
 Release:0
-Url:https://launchpad.net/virtkey
 Summary:Python extension to emulate keypresses
 License:LGPL-3.0+
 Group:  Development/Languages/Python
-Source: %{mod_name}-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+Url:https://launchpad.net/virtkey
+Source: 
https://launchpad.net/virtkey/%{major}/%{version}/+download/virtkey-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
 BuildRequires:  glib2-devel
 BuildRequires:  gtk2-devel
-%if %{build_for_python3}
-BuildRequires:  python3-devel
-BuildRequires:  python3-distribute
-%else
-BuildRequires:  python-devel
-%endif
+BuildRequires:  pkgconfig
+BuildRequires:  python-rpm-macros
 BuildRequires:  pkgconfig(gdk-2.0)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(x11)
 BuildRequires:  pkgconfig(xkbfile)
 BuildRequires:  pkgconfig(xtst)
+%python_subpackages
 
 %description
 python-virtkey is a python extension for emulating keypresses and
 getting the keyboard geometry from the xserver.
 
 %prep
-%setup -q -n %{mod_name}-%{version}
+%setup -q -n virtkey-%{version}
 
 %build
 export CFLAGS="%{optflags}"
-%{local_python} setup.py build
+%python_build
 
 %install
-%{local_python} setup.py install --prefix=%{_prefix} --root=%{buildroot} 
--record-rpm=INSTALLED_FILES
+%python_install
 
-%files -f INSTALLED_FILES
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc AUTHORS COPYING.LESSER NEWS README
+%{python_sitearch}/virtkey*.so
+%{python_sitearch}/virtkey-%{version}-py*.egg-info
 
 %changelog




commit python-pyte for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-pyte for openSUSE:Factory 
checked in at 2017-09-04 12:33:35

Comparing /work/SRC/openSUSE:Factory/python-pyte (Old)
 and  /work/SRC/openSUSE:Factory/.python-pyte.new (New)


Package is "python-pyte"

Mon Sep  4 12:33:35 2017 rev:2 rq:520032 version:0.6.0

Changes:

--- /work/SRC/openSUSE:Factory/python-pyte/python-pyte.changes  2016-10-19 
13:01:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-pyte.new/python-pyte.changes 
2017-09-04 12:33:38.162177063 +0200
@@ -1,0 +2,56 @@
+Thu Aug 31 21:23:16 UTC 2017 - toddrme2...@gmail.com
+
+- Update to 0.6.0
+  * Optimized ``Stream.feed`` for plain-text input. The code was backported
+from ``pymux`` project by Jonathan Slenders.
+  * Optimized ``Screen`` by changing ``Screen.buffer`` to dict-of-dicts. The
+idea was borrowed from ``pymux`` project by Jonathan Slenders. The
+implementation was done by @istarion.
+  * Further optimized ``Stream._parser_fsm`` by forcing static binding between
+``Stream`` events and ``Screen`` methods. The code was backported from
+``pmux`` project by Jonathan Slenders.
+  * Restricted ``Stream`` to a single listener and deprecated ``attach`` and
+``detach``. The old logic can be emulated by a fanout proxy, forwarding
+events to a list of its listeners.
+  * Replaced ``DebugStream`` with ``DebugScreen`` to workaround the single
+listener limitation (previsouly ``DebugStream`` implicitly added a
+listener when instantiated). Unlike other screens ``DebugScreen`` does
+not maintain any state.
+  * Changed ``DebugScreen`` to emit JSON instead of custom text format.
+  * Removed overly generic ``Screen.__before__`` and ``Screen.__after__``.
+  * Renamed ``Screen.set_charset`` to a more appropriate
+``Screen.define_charset``.
+  * Added support for ECMA-035 `DOCS` command to ``ByteStream`` which no longer
+accepts ``encoding`` as an argument and instead sets it as instructed by
+`DOCS`. The default encoding is assumed to be UTF-8.
+  * Added support for OSC sequences allowing to set terminal title and
+icon name.
+  * Allowed 256 and 24bit colours in ``Screen.select_graphic_rendition``.
+  * Added support for ``aixterm`` colours in 
``Screen.select_graphic_rendition``,
+see issue #57 on GitHub.
+  * Changed ``Screen.select_graphic_rendition`` to ignore 0 if it is
+given along with other attributes, ie ``"0;1;2"`` is now equivalent
+to ``"1;2"``.
+  * Fixed rendering of multicolumn characters at ``Screen` boundaries.
+Thanks to @shaform! See PR #55 on GitHub.
+  * Fixed ``Screen.display`` in the case of multicolumn characters. See
+issue #52 on GitHub.
+  * Fixed `DECSTBM` handling in case of missing arguments. See issue #61 on
+GitHub.
+  * Fixed the way ``Screen.cursor_up`` and ``Screen.cursor_down`` interact
+with the scrolling region. See #63 on GitHub.
+  * Added a minimal web terminal example by @demiurg906. For a faster and
+more fully-featured version, see
+`demiurg906/pyte_gui `_.
+  * Fixed ``Screen.cursor_back`` when called after the draw in the last column.
+  * Fixed ``Screen.inser_characters`` when called with an argument larger
+than the number of columns. Thanks to @istarion! See PR #74 on GitHub.
+  * Fixed ``Screen.erase_in_display`` which did not handle all values supported
+by ``TERM=linux``. See #80 on GitHub.
+
+---
+Thu Aug 24 13:52:22 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -4,0 +61 @@
+

Old:

  pyte-0.5.2.tar.gz

New:

  pyte-0.6.0.tar.gz



Other differences:
--
++ python-pyte.spec ++
--- /var/tmp/diff_new_pack.plFeRI/_old  2017-09-04 12:33:39.282019610 +0200
+++ /var/tmp/diff_new_pack.plFeRI/_new  2017-09-04 12:33:39.286019048 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pyte
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,20 +16,25 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%bcond_with test
 Name:   python-pyte
-Version:0.5.2
+Version:0.6.0
 Release:0
 Summary:Simple VTXXX-compatible linux terminal emulator
 License:LGPL-3.0
 Group:  Development/Languages/Python
-Url:http://pyte.readthedocs.org/en/latest/
+Url:

commit target-isns for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package target-isns for openSUSE:Factory 
checked in at 2017-09-04 12:33:32

Comparing /work/SRC/openSUSE:Factory/target-isns (Old)
 and  /work/SRC/openSUSE:Factory/.target-isns.new (New)


Package is "target-isns"

Mon Sep  4 12:33:32 2017 rev:6 rq:520025 version:0.6.3

Changes:

--- /work/SRC/openSUSE:Factory/target-isns/target-isns.changes  2017-08-16 
16:13:29.723222087 +0200
+++ /work/SRC/openSUSE:Factory/.target-isns.new/target-isns.changes 
2017-09-04 12:33:36.674386250 +0200
@@ -1,0 +2,6 @@
+Thu Aug 31 19:10:00 UTC 2017 - ldun...@suse.com
+
+- Upgraded to version v0.6.3 from v0.6.2, replacing
+  the release tarball and updating the SPEC file. (bsc#1056692)
+
+---

Old:

  v0.6.2.tar.gz

New:

  _service
  _servicedata
  target-isns-0.6.3.tar.xz



Other differences:
--
++ target-isns.spec ++
--- /var/tmp/diff_new_pack.asaSxe/_old  2017-09-04 12:33:37.714240044 +0200
+++ /var/tmp/diff_new_pack.asaSxe/_new  2017-09-04 12:33:37.734237233 +0200
@@ -20,10 +20,10 @@
 Summary:Supplies iSNS support for Linux kernel target
 License:GPL-2.0+
 Group:  System/Kernel
-Version:0.6.2
+Version:0.6.3
 Release:0
-Source: 
https://github.com/cvubrugier/%{name}/archive/v%{version}.tar.gz
-Url:https://github.com/cvubrugier/target-isns
+Source: %{name}-%{version}.tar.xz
+Url:https://github.com/open-iscsi/target-isns
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  cmake
 BuildRequires:  flex

++ _service ++

  
git
https://github.com/open-iscsi/target-isns.git

target-isns
0.6.3
v0.6.3
enable
  
  
*target-isns*.tar
xz
  
  

++ _servicedata ++


https://github.com/open-iscsi/target-isns.git
  4e8a1a761beb1e368a2bde47f5b9912800587170



commit steamtricks-data for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package steamtricks-data for 
openSUSE:Factory checked in at 2017-09-04 12:33:25

Comparing /work/SRC/openSUSE:Factory/steamtricks-data (Old)
 and  /work/SRC/openSUSE:Factory/.steamtricks-data.new (New)


Package is "steamtricks-data"

Mon Sep  4 12:33:25 2017 rev:3 rq:519945 version:20170518.71f4ec6

Changes:

--- /work/SRC/openSUSE:Factory/steamtricks-data/steamtricks-data.changes
2017-02-16 17:06:08.282618419 +0100
+++ /work/SRC/openSUSE:Factory/.steamtricks-data.new/steamtricks-data.changes   
2017-09-04 12:33:29.339417566 +0200
@@ -1,0 +2,12 @@
+Fri May 19 02:21:52 UTC 2017 - ji...@boombatower.com
+
+- Update to version 20170518.71f4ec6:
+  * Provide force_system_openssl and utilize for Tomb Raider.
+  * Utilize force_system_openssl for Mad Max.
+
+---
+Fri May 19 00:48:36 UTC 2017 - ji...@boombatower.com
+
+- Drop 0~git prefix from version format to start with date.
+
+---

Old:

  steamtricks-data-0~git20170214.e263295.tar.xz

New:

  steamtricks-data-20170518.71f4ec6.tar.xz



Other differences:
--
++ steamtricks-data.spec ++
--- /var/tmp/diff_new_pack.YFyuce/_old  2017-09-04 12:33:30.419265737 +0200
+++ /var/tmp/diff_new_pack.YFyuce/_new  2017-09-04 12:33:30.431264050 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   steamtricks-data
-Version:0~git20170214.e263295
+Version:20170518.71f4ec6
 Release:0
 Summary:Steamtricks companion data repository
 License:GPL-2.0

++ _service ++
--- /var/tmp/diff_new_pack.YFyuce/_old  2017-09-04 12:33:30.535249429 +0200
+++ /var/tmp/diff_new_pack.YFyuce/_new  2017-09-04 12:33:30.535249429 +0200
@@ -1,6 +1,6 @@
 
   
-0~git%cd.%h
+%cd.%h
 https://github.com/steamtricks/steamtricks-data.git
 git
 enable

++ _servicedata ++
--- /var/tmp/diff_new_pack.YFyuce/_old  2017-09-04 12:33:30.591241556 +0200
+++ /var/tmp/diff_new_pack.YFyuce/_new  2017-09-04 12:33:30.603239869 +0200
@@ -1,6 +1,6 @@
 
   
 https://github.com/steamtricks/steamtricks-data.git
-e2632956231dd517c5e1cdedaa6addb053b269cd
+71f4ec661118b94137e77ed8d3b6a764158b3f18
   
 

++ steamtricks-data-0~git20170214.e263295.tar.xz -> 
steamtricks-data-20170518.71f4ec6.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/steamtricks-data-0~git20170214.e263295/data/00-common/force_system_openssl 
new/steamtricks-data-20170518.71f4ec6/data/00-common/force_system_openssl
--- 
old/steamtricks-data-0~git20170214.e263295/data/00-common/force_system_openssl  
1970-01-01 01:00:00.0 +0100
+++ new/steamtricks-data-20170518.71f4ec6/data/00-common/force_system_openssl   
2017-05-19 04:20:58.0 +0200
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+sed -i '2iexport 
LD_PRELOAD="/lib/libcrypto.so.1.0.0:/lib/libssl.so.1.0.0:$LD_PRELOAD"' "$1"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/steamtricks-data-0~git20170214.e263295/data/203160-Tomb_Raider/00-pre 
new/steamtricks-data-20170518.71f4ec6/data/203160-Tomb_Raider/00-pre
--- old/steamtricks-data-0~git20170214.e263295/data/203160-Tomb_Raider/00-pre   
1970-01-01 01:00:00.0 +0100
+++ new/steamtricks-data-20170518.71f4ec6/data/203160-Tomb_Raider/00-pre
2017-05-19 04:20:58.0 +0200
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+force_system_openssl TombRaider.sh
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/steamtricks-data-0~git20170214.e263295/data/234140-Mad_Max/00-pre 
new/steamtricks-data-20170518.71f4ec6/data/234140-Mad_Max/00-pre
--- old/steamtricks-data-0~git20170214.e263295/data/234140-Mad_Max/00-pre   
1970-01-01 01:00:00.0 +0100
+++ new/steamtricks-data-20170518.71f4ec6/data/234140-Mad_Max/00-pre
2017-05-19 04:20:58.0 +0200
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+force_system_openssl MadMax.sh




commit python-pyinotify for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-pyinotify for 
openSUSE:Factory checked in at 2017-09-04 12:32:53

Comparing /work/SRC/openSUSE:Factory/python-pyinotify (Old)
 and  /work/SRC/openSUSE:Factory/.python-pyinotify.new (New)


Package is "python-pyinotify"

Mon Sep  4 12:32:53 2017 rev:15 rq:519905 version:0.9.6

Changes:

--- /work/SRC/openSUSE:Factory/python-pyinotify/python-pyinotify.changes
2016-01-05 09:41:57.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-pyinotify.new/python-pyinotify.changes   
2017-09-04 12:32:57.223933074 +0200
@@ -1,0 +2,5 @@
+Thu Aug 24 13:50:56 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -61,0 +67 @@
+



Other differences:
--
++ python-pyinotify.spec ++
--- /var/tmp/diff_new_pack.TE6klB/_old  2017-09-04 12:32:58.139804301 +0200
+++ /var/tmp/diff_new_pack.TE6klB/_new  2017-09-04 12:32:58.147803176 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pyinotify
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,6 +16,7 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pyinotify
 Version:0.9.6
 Release:0
@@ -23,15 +24,15 @@
 License:MIT
 Group:  Development/Libraries/Python
 Url:http://github.com/seb-m/pyinotify
-Source: 
https://pypi.python.org/packages/source/p/pyinotify/pyinotify-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/p/pyinotify/pyinotify-%{version}.tar.gz
 Source1:pyinotify
-BuildRequires:  python-devel
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
 BuildArch:  noarch
-%endif
+Requires(post):   update-alternatives
+Requires(postun):  update-alternatives
+%python_subpackages
 
 %description
 pyinotify is a Python module for watching filesystems changes. By its design
@@ -53,18 +54,30 @@
 %setup -q -n pyinotify-%{version}
 # remove unwanted shebang
 sed -i '/^#!/ d' python2/pyinotify.py
+sed -i "s|#!/usr/bin/env python|#!%__python2|" python2/examples/*py
+sed -i "s|#!/usr/bin/env python|#!%__python3|" python3/examples/*py
 
 %build
-python setup.py build
+%python_build
 
 %install
-python ./setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
 install -D -m 0755 %{SOURCE1} %{buildroot}%{_bindir}/pyinotify
+%python_clone -a %{buildroot}%{_bindir}/pyinotify
 
-%files
+%post
+%python_install_alternative pyinotify
+
+%postun
+%python_uninstall_alternative pyinotify
+
+%files %{python_files}
 %defattr(-,root,root)
-%doc ACKS COPYING README.md python2/examples
-%{_bindir}/pyinotify
+%doc ACKS COPYING README.md
+%doc old/ChangeLog old/NEWS
+%python2_only %doc python2/examples
+%python3_only %doc python3/examples
+%python_alternative %{_bindir}/pyinotify
 %{python_sitelib}/*
 
 %changelog




commit autofs for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package autofs for openSUSE:Factory checked 
in at 2017-09-04 12:33:11

Comparing /work/SRC/openSUSE:Factory/autofs (Old)
 and  /work/SRC/openSUSE:Factory/.autofs.new (New)


Package is "autofs"

Mon Sep  4 12:33:11 2017 rev:111 rq:519928 version:5.1.3

Changes:

--- /work/SRC/openSUSE:Factory/autofs/autofs.changes2017-08-24 
18:21:53.231282336 +0200
+++ /work/SRC/openSUSE:Factory/.autofs.new/autofs.changes   2017-09-04 
12:33:12.969719184 +0200
@@ -162,0 +163,2 @@
+  * Updated patches for context:
+autofs-5.1.1-dbus-udisks-monitor.patch



Other differences:
--





commit python-setuptools-git for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-setuptools-git for 
openSUSE:Factory checked in at 2017-09-04 12:33:03

Comparing /work/SRC/openSUSE:Factory/python-setuptools-git (Old)
 and  /work/SRC/openSUSE:Factory/.python-setuptools-git.new (New)


Package is "python-setuptools-git"

Mon Sep  4 12:33:03 2017 rev:10 rq:519907 version:1.2

Changes:

--- 
/work/SRC/openSUSE:Factory/python-setuptools-git/python-setuptools-git.changes  
2015-05-19 23:37:16.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-setuptools-git.new/python-setuptools-git.changes
 2017-09-04 12:33:10.642046461 +0200
@@ -1,0 +2,11 @@
+Thu Aug 31 06:54:17 UTC 2017 - toddrme2...@gmail.com
+
+- update to version 1.2:
+  * no changelog available
+
+---
+Thu Aug 24 13:54:33 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -55,0 +67 @@
+

Old:

  setuptools-git-1.1.tar.gz

New:

  setuptools-git-1.2.tar.gz



Other differences:
--
++ python-setuptools-git.spec ++
--- /var/tmp/diff_new_pack.P4UhvF/_old  2017-09-04 12:33:11.837878324 +0200
+++ /var/tmp/diff_new_pack.P4UhvF/_new  2017-09-04 12:33:11.857875512 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-setuptools-git
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,25 +16,22 @@
 #
 
 
-%define mod_name setuptools-git
-
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-setuptools-git
-Version:1.1
+Version:1.2
 Release:0
 Summary:Setuptools revision control system plugin for Git
 License:BSD-3-Clause
 Group:  Development/Languages/Python
 Url:https://github.com/wichert/setuptools-git
-Source: 
http://pypi.python.org/packages/source/s/setuptools-git/setuptools-git-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/s/setuptools-git/setuptools-git-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
 BuildRequires:  git-core
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
+BuildRequires:  python-rpm-macros
 BuildArch:  noarch
-%endif
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+
+%python_subpackages
 
 %description
 This is a plugin for setuptools that enables git integration. Once
@@ -50,19 +47,21 @@
 %setup -q -n setuptools-git-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
 
 %check
+export LANG=en_US.UTF-8
 # configure git for the test
 git config --global user.email "t...@test.test"
 git config --global user.name "test"
-python setup.py -q test
+%python_exec setup.py test
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
+%doc AUTHORS.txt LICENSE.txt README.rst TODO.txt
 %{python_sitelib}/*
 
 %changelog

++ setuptools-git-1.1.tar.gz -> setuptools-git-1.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools-git-1.1/PKG-INFO 
new/setuptools-git-1.2/PKG-INFO
--- old/setuptools-git-1.1/PKG-INFO 2014-08-16 11:08:11.0 +0200
+++ new/setuptools-git-1.2/PKG-INFO 2017-02-18 01:30:59.0 +0100
@@ -1,10 +1,10 @@
 Metadata-Version: 1.1
 Name: setuptools-git
-Version: 1.1
+Version: 1.2
 Summary: Setuptools revision control system plugin for Git
 Home-page: https://github.com/wichert/setuptools-git
-Author: Wichert Akkerman
-Author-email: wich...@wiggy.net
+Author: Marc Abramowitz
+Author-email: msabr...@gmail.com
 License: BSD
 Description: About
 -
@@ -15,11 +15,11 @@
 inclusion specifications with ``MANIFEST.in``.
 
 A package distribution here refers to a package that you create using
-setup.py, ex::
+setup.py, for example::
 
-  python setup.py sdist
-  python setup.py bdist_rpm
-  python setup.py bdist_egg
+  $> python setup.py sdist
+  $> python setup.py bdist_rpm
+  $> python setup.py bdist_egg
 
 This package was formerly known as gitlsfiles. The name change is the
 result of an 

commit python-django-picklefield for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-django-picklefield for 
openSUSE:Factory checked in at 2017-09-04 12:32:57

Comparing /work/SRC/openSUSE:Factory/python-django-picklefield (Old)
 and  /work/SRC/openSUSE:Factory/.python-django-picklefield.new (New)


Package is "python-django-picklefield"

Mon Sep  4 12:32:57 2017 rev:12 rq:519906 version:1.0.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-django-picklefield/python-django-picklefield.changes
  2015-05-07 09:22:27.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-django-picklefield.new/python-django-picklefield.changes
 2017-09-04 12:33:03.827004669 +0200
@@ -1,0 +2,11 @@
+Thu Aug 31 06:59:35 UTC 2017 - toddrme2...@gmail.com
+
+- Update to version 1.0.0
+  * No changelog
+
+---
+Thu Aug 24 13:37:21 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -93,0 +105 @@
+

Old:

  django-picklefield-0.3.1.tar.gz

New:

  django-picklefield-1.0.0.tar.gz



Other differences:
--
++ python-django-picklefield.spec ++
--- /var/tmp/diff_new_pack.38m96E/_old  2017-09-04 12:33:05.142819663 +0200
+++ /var/tmp/diff_new_pack.38m96E/_new  2017-09-04 12:33:05.146819101 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-django-picklefield
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,23 +16,25 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%bcond_with test
 Name:   python-django-picklefield
-Version:0.3.1
+Version:1.0.0
 Release:0
-Url:http://github.com/gintas/django-picklefield
 Summary:Pickled object field for Django
 License:MIT
 Group:  Development/Languages/Python
-Source: 
https://pypi.python.org/packages/source/d/django-picklefield/django-picklefield-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
-Requires:   python-django
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
-BuildArch:  noarch
+Url:http://github.com/gintas/django-picklefield
+Source: 
https://files.pythonhosted.org/packages/source/d/django-picklefield/django-picklefield-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
+%if %{with test}
+BuildRequires:  %{python_module Django}
 %endif
+Requires:   python-Django
+BuildArch:  noarch
+%python_subpackages
 
 %description
 django-picklefield provides an implementation of a pickled object field.
@@ -47,14 +49,19 @@
 %setup -q -n django-picklefield-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
+
+%if %{with test}
+%check
+%python_exec setup.py test
+%endif
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
-%doc README
+%doc README.rst
 %{python_sitelib}/*
 
 %changelog

++ django-picklefield-0.3.1.tar.gz -> django-picklefield-1.0.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/django-picklefield-0.3.1/PKG-INFO 
new/django-picklefield-1.0.0/PKG-INFO
--- old/django-picklefield-0.3.1/PKG-INFO   2013-11-15 22:25:57.0 
+0100
+++ new/django-picklefield-1.0.0/PKG-INFO   2017-06-30 01:46:31.0 
+0200
@@ -1,25 +1,31 @@
 Metadata-Version: 1.1
 Name: django-picklefield
-Version: 0.3.1
+Version: 1.0.0
 Summary: Pickled object field for Django
 Home-page: http://github.com/gintas/django-picklefield
 Author: Gintautas Miliauskas
 Author-email: gintau...@miliauskas.lt
 License: UNKNOWN
-Description: -
+Description: .. image:: 
https://travis-ci.org/gintas/django-picklefield.svg?branch=master
+:target: https://travis-ci.org/gintas/django-picklefield
+
+.. image:: 
https://coveralls.io/repos/gintas/django-picklefield/badge.svg?branch=master=github
+:target: 
https://coveralls.io/github/gintas/django-picklefield?branch=master
+
+-
 About
 -
 
 **django-picklefield** provides an implementation of a pickled object 
field.
 Such 

commit hawk2 for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package hawk2 for openSUSE:Factory checked 
in at 2017-09-04 12:32:20

Comparing /work/SRC/openSUSE:Factory/hawk2 (Old)
 and  /work/SRC/openSUSE:Factory/.hawk2.new (New)


Package is "hawk2"

Mon Sep  4 12:32:20 2017 rev:41 rq:519900 version:2.1.0+git.1504122466.88c339b3

Changes:

--- /work/SRC/openSUSE:Factory/hawk2/hawk2.changes  2017-06-10 
17:51:37.398555164 +0200
+++ /work/SRC/openSUSE:Factory/.hawk2.new/hawk2.changes 2017-09-04 
12:32:37.974639556 +0200
@@ -1,0 +2,30 @@
+Thu Aug 31 09:30:33 UTC 2017 - kgronl...@suse.com
+
+- Require hawk-apiserver (fate#323437) 
+
+---
+Wed Aug 30 19:55:12 UTC 2017 - kgronl...@suse.com
+
+- Update to version 2.1.0+git.1504122466.88c339b3:
+  * Upgrade to Rails 5
+  * Drop support for bundling rubygems (fate#321115)
+  * Move hawk data files out of /srv/www (fate#321020)
+  * Remove the Strange char in Dashboard (bsc#1037430)
+  * Add have-watchdog to list of readonly options
+  * UI: Move sidebar down slightly when batch mode is enabled
+  * UI: Fix typo in template.rb
+  * Low: tools: crmd and pengine executables have moved to %_libdir/pacemaker
+  * Medium: Don't offset failure time by 10 minutes in notification 
(bsc#1056483)
+
+- Remove 0001-Don-t-drop-any-gems-from-bundle.patch
+- Remove json-1.8.1.gem
+- Remove rake-10.1.0.gem
+- Remove rake-10.4.2.gem
+
+---
+Mon Jul 24 11:20:59 UTC 2017 - kgronl...@suse.com
+
+- Update to version 2.1.0+git.1500894042.99eca950:
+  * generate-ssl-cert: Make sure commonName isn't too long (bsc#1046820)
+
+---

Old:

  0001-Don-t-drop-any-gems-from-bundle.patch
  hawk2-2.1.0+git.1496403895.2d3dbf1f.tar.bz2
  json-1.8.1.gem
  rake-10.1.0.gem
  rake-10.4.2.gem

New:

  hawk2-2.1.0+git.1504122466.88c339b3.tar.bz2



Other differences:
--
++ hawk2.spec ++
--- /var/tmp/diff_new_pack.ewQHgF/_old  2017-09-04 12:32:41.546137398 +0200
+++ /var/tmp/diff_new_pack.ewQHgF/_new  2017-09-04 12:32:41.558135711 +0200
@@ -17,45 +17,43 @@
 
 
 %if 0%{?suse_version}
-%definewww_base/srv/www
 %definevendor_ruby vendor_ruby
 %defineinit_style  suse
 %definepkg_group   Productivity/Clustering/HA
 %else
-%definewww_base/var/www
 %definevendor_ruby site_ruby
 %defineinit_style  redhat
 %definepkg_group   System Environment/Daemons
 %endif
 
-%define bundle_gems 1
+%define www_base %{_datadir}
+%define www_tmp  %{_localstatedir}/lib/hawk/tmp
+%define www_log  %{_localstatedir}/log/hawk
+
+%define rb_build_versions ruby24
+%define rb_ruby_abi ruby:2.4.0
+%define rb_ruby_suffix ruby2.4
 
 %definegname   haclient
 %defineuname   hacluster
 
-%define version_unconverted 2.1.0+git.1496403895.2d3dbf1f
-
 Name:   hawk2
 Summary:HA Web Konsole
 License:GPL-2.0
 Group:  %{pkg_group}
-Version:2.1.0+git.1496403895.2d3dbf1f
+Version:2.1.0+git.1504122466.88c339b3
 Release:0
 Url:http://www.clusterlabs.org/wiki/Hawk
 Source: %{name}-%{version}.tar.bz2
-Source10:   rake-10.4.2.gem
-Source11:   json-1.8.1.gem
-Source12:   rake-10.1.0.gem
 Source100:  hawk-rpmlintrc
-# PATCH-FIX-OPENSUSE: Don't drop any gems from bundle
-Patch1: 0001-Don-t-drop-any-gems-from-bundle.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Provides:   ha-cluster-webui
 Obsoletes:  hawk <= 1.1.0
 Provides:   hawk = %{version}
-Requires:   crmsh >= 2.2.0+git.1464237560
+Requires:   crmsh >= 3.0.0
 Requires:   graphviz
 Requires:   graphviz-gd
+Requires:   hawk-apiserver
 Requires(post): %fillup_prereq
 # Need a font of some kind for graphviz to work correctly (bsc#931950)
 Requires:   dejavu
@@ -64,7 +62,7 @@
 Requires:   rubypick
 BuildRequires:  rubypick
 %endif
-Requires:   rubygem(%{rb_default_ruby_abi}:bundler)
+Requires:   rubygem(%{rb_ruby_abi}:bundler)
 %if 0%{?suse_version}
 Recommends: graphviz-gnome
 Requires:   iproute2
@@ -80,68 +78,45 @@
 BuildRequires:  pacemaker-libs-devel
 %endif
 
-BuildRequires:  rubygem(%{rb_default_ruby_abi}:builder) >= 3.2
-BuildRequires:  rubygem(%{rb_default_ruby_abi}:byebug) >= 3.5
-BuildRequires:  rubygem(%{rb_default_ruby_abi}:fast_gettext) >= 0.9.2
-BuildRequires:  rubygem(%{rb_default_ruby_abi}:gettext:3) >= 3.1
-BuildRequires:  rubygem(%{rb_default_ruby_abi}:gettext_i18n_rails:1) >= 1.2
-BuildRequires:  

commit python-versiontools for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-versiontools for 
openSUSE:Factory checked in at 2017-09-04 12:32:33

Comparing /work/SRC/openSUSE:Factory/python-versiontools (Old)
 and  /work/SRC/openSUSE:Factory/.python-versiontools.new (New)


Package is "python-versiontools"

Mon Sep  4 12:32:33 2017 rev:13 rq:519903 version:1.9.1

Changes:

--- /work/SRC/openSUSE:Factory/python-versiontools/python-versiontools.changes  
2013-10-25 11:34:28.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-versiontools.new/python-versiontools.changes 
2017-09-04 12:32:53.58793 +0200
@@ -1,0 +2,5 @@
+Thu Aug 24 13:56:58 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -124,0 +130 @@
+



Other differences:
--
++ python-versiontools.spec ++
--- /var/tmp/diff_new_pack.fjwD8b/_old  2017-09-04 12:32:54.368334576 +0200
+++ /var/tmp/diff_new_pack.fjwD8b/_new  2017-09-04 12:32:54.380332889 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-versiontools
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,23 +16,22 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-versiontools
 Version:1.9.1
 Release:0
-Url:https://launchpad.net/versiontools
 Summary:Smart replacement for plain tuple used in __version__
 License:LGPL-3.0+
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/v/versiontools/versiontools-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
+Url:https://launchpad.net/versiontools
+Source: 
https://files.pythonhosted.org/packages/source/v/versiontools/versiontools-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
 Requires:   python-setuptools
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
-%endif
+%python_subpackages
 
 %description
 Smart replacement for plain tuple used in __version__.
@@ -50,12 +49,12 @@
 sed -i "1d" versiontools/{git_support,hg_support,bzr_support}.py # Fix 
non-executable scripts
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc doc/*
 %{python_sitelib}/*




commit python-piston-mini-client for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-piston-mini-client for 
openSUSE:Factory checked in at 2017-09-04 12:32:44

Comparing /work/SRC/openSUSE:Factory/python-piston-mini-client (Old)
 and  /work/SRC/openSUSE:Factory/.python-piston-mini-client.new (New)


Package is "python-piston-mini-client"

Mon Sep  4 12:32:44 2017 rev:10 rq:519904 version:0.7.5

Changes:

--- 
/work/SRC/openSUSE:Factory/python-piston-mini-client/python-piston-mini-client.changes
  2013-10-25 11:26:44.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-piston-mini-client.new/python-piston-mini-client.changes
 2017-09-04 12:32:54.880262598 +0200
@@ -1,0 +2,5 @@
+Thu Aug 24 13:49:24 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -43,0 +49 @@
+



Other differences:
--
++ python-piston-mini-client.spec ++
--- /var/tmp/diff_new_pack.KgMsHh/_old  2017-09-04 12:32:55.764138324 +0200
+++ /var/tmp/diff_new_pack.KgMsHh/_new  2017-09-04 12:32:55.776136637 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-piston-mini-client
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,24 +16,36 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%define oldpython python
+%bcond_with test
 Name:   python-piston-mini-client
 Version:0.7.5
 Release:0
-Url:https://launchpad.net/piston-mini-client
 Summary:A small package to consume Django-Piston web services
 License:LGPL-3.0
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/p/piston-mini-client/piston-mini-client-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
-Provides:   python-piston-mini = %{version}
-Obsoletes:  python-piston-mini < %{version}
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
-BuildArch:  noarch
+Url:https://launchpad.net/piston-mini-client
+Source: 
https://files.pythonhosted.org/packages/source/p/piston-mini-client/piston-mini-client-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
+%if %{with test}
+BuildRequires:  %{python_module Sphinx}
+BuildRequires:  %{python_module httplib2}
+BuildRequires:  %{python_module mock}
+BuildRequires:  %{python_module nose}
+BuildRequires:  %{python_module oauthlib}
+BuildRequires:  %{python_module pep8}
+BuildRequires:  python3-tox
+%endif
+Requires:   python-oauthlib
+%ifpython2
+Provides:   %{oldpython}-piston-mini = %{version}
+Obsoletes:  %{oldpython}-piston-mini < %{version}
 %endif
+BuildArch:  noarch
+%python_subpackages
 
 %description
 A small generic library for writing clients for Django's Piston REST APIs.
@@ -42,12 +54,17 @@
 %setup -q -n piston-mini-client-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
+
+%if %{with test}
+%check
+tox --sitepackages --skip-missing-interpreters
+%endif
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc LICENSE README
 %{python_sitelib}/*




commit python-Frozen-Flask for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-Frozen-Flask for 
openSUSE:Factory checked in at 2017-09-04 12:32:24

Comparing /work/SRC/openSUSE:Factory/python-Frozen-Flask (Old)
 and  /work/SRC/openSUSE:Factory/.python-Frozen-Flask.new (New)


Package is "python-Frozen-Flask"

Mon Sep  4 12:32:24 2017 rev:3 rq:519902 version:0.15

Changes:

--- /work/SRC/openSUSE:Factory/python-Frozen-Flask/python-Frozen-Flask.changes  
2017-02-03 18:56:58.185142697 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-Frozen-Flask.new/python-Frozen-Flask.changes 
2017-09-04 12:32:50.848829425 +0200
@@ -1,0 +2,16 @@
+Thu Aug 31 05:54:28 UTC 2017 - toddrme2...@gmail.com
+
+- Update to version 0.15
+  * Add Freezer.freeze_yield() method to make progress
+reporting easier.
+- Update to version 0.14
+  * Add the FREEZER_SKIP_EXISTING configuration to skip generation
+of files already in the build directory.
+  * Add shared superclass FrozenFlaskWarning for all warnings.
+
+---
+Thu Aug 24 13:39:03 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -15,0 +32 @@
+

Old:

  v0.13.tar.gz

New:

  Frozen-Flask-0.15.tar.gz



Other differences:
--
++ python-Frozen-Flask.spec ++
--- /var/tmp/diff_new_pack.9NnTJo/_old  2017-09-04 12:32:53.392471784 +0200
+++ /var/tmp/diff_new_pack.9NnTJo/_new  2017-09-04 12:32:53.392471784 +0200
@@ -16,36 +16,48 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-Frozen-Flask
-Version:0.13
+Version:0.15
 Release:0
 Summary:A Flask application into a set of static files
 License:BSD-2-Clause
 Group:  Development/Languages/Python
-Url:http://pythonhosted.org/Frozen-Flask
-Source: 
https://github.com/Frozen-Flask/Frozen-Flask/archive/v%{version}.tar.gz
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
+Url:https://github.com/Frozen-Flask/Frozen-Flask
+Source: 
https://files.pythonhosted.org/packages/source/F/Frozen-Flask/Frozen-Flask-%{version}.tar.gz
+BuildRequires:  %{python_module Flask}
+BuildRequires:  %{python_module Werkzeug}
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
 Requires:   python-Flask
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+Requires:   python-Werkzeug
 BuildArch:  noarch
+%python_subpackages
 
 %description
-Frozen-Flask freezes a Flask application into a set of static files. The 
result can be hosted without any server-side software other than a traditional 
web server.
+Frozen-Flask freezes a Flask application into a set of static files.
+The result can be hosted without any server-side software other than
+a traditional web server.
 
 %prep
 %setup -q -n Frozen-Flask-%{version}
 
 %build
-python2 setup.py build
+%python_build
 
 %install
-python2 setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
 
-%files
+%check
+export LANG=en_US.UTF-8
+%python_exec -m flask_frozen.tests
+
+%files %{python_files}
 %defattr(-,root,root)
-%{python_sitelib}/Frozen_Flask-%{version}-py%{py_ver}.egg-info/
-%{python_sitelib}/flask_frozen/
 %doc README.rst LICENSE
+%doc docs/build/html
+%{python_sitelib}/flask_frozen/
+%{python_sitelib}/Frozen_Flask-%{version}-py*.egg-info
 
 %changelog




commit rubygem-mocha for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package rubygem-mocha for openSUSE:Factory 
checked in at 2017-09-04 12:31:56

Comparing /work/SRC/openSUSE:Factory/rubygem-mocha (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-mocha.new (New)


Package is "rubygem-mocha"

Mon Sep  4 12:31:56 2017 rev:24 rq:519889 version:1.3.0

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-mocha/rubygem-mocha.changes  
2016-11-07 12:23:03.0 +0100
+++ /work/SRC/openSUSE:Factory/.rubygem-mocha.new/rubygem-mocha.changes 
2017-09-04 12:32:01.239804512 +0200
@@ -1,0 +2,25 @@
+Fri Aug 25 08:08:48 UTC 2017 - mschnit...@suse.com
+
+- updated to version 1.3.0
+  * Ensure all tests run individually - thanks to @chrisroos (#267)
+  * Update Travis CI build status badge to show master branch status (#264)
+  * Correct RSpec section of the README - thanks to @myronmarston (0cc039c8)
+  * Fix pretty printing of quotes in String#mocha_inspect (#215 & #223)
+  * Add release instructions to README - thanks to @chrisroos (70a5febd & 
3c664df7)
+  * Require at least Ruby v1.8.7 in gemspec - thanks to @knappe (3e20be8e)
+  * Remove redundant InstanceMethod#method_exists? - thanks to @chrisroos 
(8f58eddf)
+  * Reduce risk of hitting bug 12832 in Ruby v2.3 - thanks to @chrisroos (#277 
& eca7560c)
+  * Fix JRuby build - thanks to @headius (jruby/jruby#4250) & @chrisroos (#274)
+  * Add latest stable version of JRuby to Travis CI build matrix (#288)
+  * Fix Ruby v1.8.7 builds on Travis CI (928b5a40 & 460dce5b)
+  * Deprecate passing block to mock object constructor (#290)
+  * Add a known issue to README for Ruby bug 12876 (#276)
+  * Add Ruby 2.4 and ruby-head to Travis CI build matrix - thanks to @junaruga 
(#297)
+  * Fix Mocha::ParameterMatchers#includes for Array values - thanks to 
@timcraft (#302)
+  * Use faster container-based virtual environments for Travis CI builds (#305)
+  * Rename Mocha::ParameterMatchers::QueryStringMatches to QueryString (#306)
+  * Handle blank parameter value for query string matcher - thanks to @weynsee 
(#303 & #304)
+  * Rename Mocha::ParameterMatchers::QueryString -> EquivalentUri (#307)
+  * Use do ... end instead of { ... } in acceptance tests - thanks to 
@chrisroos (#294) 
+
+---

Old:

  mocha-1.2.1.gem

New:

  mocha-1.3.0.gem



Other differences:
--
++ rubygem-mocha.spec ++
--- /var/tmp/diff_new_pack.KwZU3W/_old  2017-09-04 12:32:01.947704981 +0200
+++ /var/tmp/diff_new_pack.KwZU3W/_new  2017-09-04 12:32:01.947704981 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package rubygem-mocha
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,16 +24,16 @@
 #
 
 Name:   rubygem-mocha
-Version:1.2.1
+Version:1.3.0
 Release:0
 %define mod_name mocha
 %define mod_full_name %{mod_name}-%{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  %{rubygem gem2rpm}
-BuildRequires:  %{ruby}
 BuildRequires:  ruby-macros >= 5
+BuildRequires:  %{ruby >= 1.8.7}
+BuildRequires:  %{rubygem gem2rpm}
 Url:http://gofreerange.com/mocha/docs
-Source: http://rubygems.org/gems/%{mod_full_name}.gem
+Source: https://rubygems.org/gems/%{mod_full_name}.gem
 Source1:gem2rpm.yml
 Summary:Mocking and stubbing library
 License:MIT and BSD-2-Clause

++ mocha-1.2.1.gem -> mocha-1.3.0.gem ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/README.md new/README.md
--- old/README.md   2016-10-15 15:09:06.0 +0200
+++ new/README.md   2017-08-24 23:44:56.0 +0200
@@ -1,4 +1,4 @@
-## Mocha [![build 
status](https://secure.travis-ci.org/freerange/mocha.png)](https://secure.travis-ci.org/freerange/mocha)
 [![Gem 
Version](https://badge.fury.io/rb/mocha.png)](http://badge.fury.io/rb/mocha) 
[![OpenCollective](https://opencollective.com/mocha/backers/badge.svg)](#backers)
 
[![OpenCollective](https://opencollective.com/mocha/sponsors/badge.svg)](#sponsors)
+## Mocha [![Build 
Status](https://travis-ci.org/freerange/mocha.svg?branch=master)](https://travis-ci.org/freerange/mocha)
 [![Gem 
Version](https://badge.fury.io/rb/mocha.png)](http://badge.fury.io/rb/mocha) 
[![OpenCollective](https://opencollective.com/mocha/backers/badge.svg)](#backers)
 
[![OpenCollective](https://opencollective.com/mocha/sponsors/badge.svg)](#sponsors)
 
 
 ### Description
@@ -78,7 +78,7 @@
 
 # RSpec
 
-Assuming you are using 

commit python-lesscpy for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-lesscpy for openSUSE:Factory 
checked in at 2017-09-04 12:31:31

Comparing /work/SRC/openSUSE:Factory/python-lesscpy (Old)
 and  /work/SRC/openSUSE:Factory/.python-lesscpy.new (New)


Package is "python-lesscpy"

Mon Sep  4 12:31:31 2017 rev:7 rq:519853 version:0.12.0

Changes:

--- /work/SRC/openSUSE:Factory/python-lesscpy/python-lesscpy.changes
2016-08-17 12:05:34.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-lesscpy.new/python-lesscpy.changes   
2017-09-04 12:31:39.310887726 +0200
@@ -1,0 +2,11 @@
+Thu Aug 31 06:55:58 UTC 2017 - toddrme2...@gmail.com
+
+- update to 0.12.0
+  * no changelog available
+
+---
+Thu Aug 24 13:44:20 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -42,0 +54 @@
+

Old:

  lesscpy-0.10.2.tar.gz

New:

  lesscpy-0.12.0.tar.gz



Other differences:
--
++ python-lesscpy.spec ++
--- /var/tmp/diff_new_pack.4ejwrH/_old  2017-09-04 12:31:40.266753332 +0200
+++ /var/tmp/diff_new_pack.4ejwrH/_new  2017-09-04 12:31:40.282751083 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-lesscpy
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,32 +16,29 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-lesscpy
-Version:0.10.2
+Version:0.12.0
 Release:0
-Url:https://github.com/robotis/lesscpy
 Summary:Lesscss compiler
 License:MIT
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/l/lesscpy/lesscpy-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  python-devel
-BuildRequires:  python-ply
-BuildRequires:  python-setuptools
-BuildRequires:  python-six
-# Test requirements:
-BuildRequires:  python-coverage
-BuildRequires:  python-flake8
-BuildRequires:  python-nose
+Url:https://github.com/robotis/lesscpy
+Source: 
https://files.pythonhosted.org/packages/source/l/lesscpy/lesscpy-%{version}.tar.gz
+BuildRequires:  %{python_module coverage}
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module flake8}
+BuildRequires:  %{python_module nose}
+BuildRequires:  %{python_module ply}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  %{python_module six}
+BuildRequires:  python-rpm-macros
 Requires:   python-ply
 Requires:   python-six
-Requires(post): update-alternatives
-Requires(preun): update-alternatives
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
 BuildArch:  noarch
-%endif
+Requires(post):   update-alternatives
+Requires(postun):  update-alternatives
+%python_subpackages
 
 %description
 python LessCss Compiler.
@@ -58,33 +55,26 @@
 rm test/test_{bootstrap3,less,issues}.py
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
-mkdir -p %{buildroot}%{_sysconfdir}/alternatives
-mv %{buildroot}%{_bindir}/lesscpy %{buildroot}%{_bindir}/lesscpy-%{py_ver}
-ln -sf %{_sysconfdir}/alternatives/lesscpy %{buildroot}%{_bindir}/lesscpy
-
-%check
-python setup.py -q test
+%python_install
+%python_clone -a %{buildroot}%{_bindir}/lesscpy
 
 %post
-%_sbindir/update-alternatives \
---install %{_bindir}/lesscpy lesscpy %{_bindir}/lesscpy-%{py_ver} 20
+%python_install_alternative lesscpy
 
-%preun
-if [ $1 -eq 0 ] ; then
-%_sbindir/update-alternatives --remove lesscpy %{_bindir}/lesscpy-%{py_ver}
-fi
+%postun
+%python_uninstall_alternative lesscpy
+
+%check
+%python_exec setup.py test
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc LICENSE README.rst
-%{_bindir}/lesscpy
-%{_bindir}/lesscpy-%{py_ver}
-%ghost %{_sysconfdir}/alternatives/lesscpy
+%python_alternative %{_bindir}/lesscpy
 %{python_sitelib}/lesscpy
-%{python_sitelib}/lesscpy-%{version}-py%{py_ver}.egg-info
+%{python_sitelib}/lesscpy-%{version}-py*.egg-info
 
 %changelog

++ lesscpy-0.10.2.tar.gz -> lesscpy-0.12.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lesscpy-0.10.2/PKG-INFO new/lesscpy-0.12.0/PKG-INFO
--- old/lesscpy-0.10.2/PKG-INFO 2014-11-26 21:50:54.0 +0100
+++ 

commit python-Trolly for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-Trolly for openSUSE:Factory 
checked in at 2017-09-04 12:31:46

Comparing /work/SRC/openSUSE:Factory/python-Trolly (Old)
 and  /work/SRC/openSUSE:Factory/.python-Trolly.new (New)


Package is "python-Trolly"

Mon Sep  4 12:31:46 2017 rev:6 rq:519857 version:0.2.2

Changes:

--- /work/SRC/openSUSE:Factory/python-Trolly/python-Trolly.changes  
2015-05-18 22:35:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-Trolly.new/python-Trolly.changes 
2017-09-04 12:31:47.929675923 +0200
@@ -1,0 +2,11 @@
+Thu Aug 31 07:07:44 UTC 2017 - toddrme2...@gmail.com
+
+- update to version 0.2.2
+  * No upstream changelog
+
+---
+Thu Aug 24 13:56:23 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -24,0 +36 @@
+

Old:

  Trolly-0.2.1.zip

New:

  Trolly-0.2.2.zip



Other differences:
--
++ python-Trolly.spec ++
--- /var/tmp/diff_new_pack.W1GYU8/_old  2017-09-04 12:31:48.801553337 +0200
+++ /var/tmp/diff_new_pack.W1GYU8/_new  2017-09-04 12:31:48.805552774 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-Trolly
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,26 +16,27 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%bcond_with test
 Name:   python-Trolly
-Version:0.2.1
+Version:0.2.2
 Release:0
 Summary:Trello api
 License:MIT
 Group:  Development/Languages/Python
 Url:https://github.com/plish/Trolly
-Source: 
http://pypi.python.org/packages/source/T/Trolly/Trolly-%{version}.zip
-BuildRequires:  python-devel
+Source: 
https://files.pythonhosted.org/packages/source/T/Trolly/Trolly-%{version}.zip
+BuildRequires:  %{python_module devel}
+BuildRequires:  python-rpm-macros
 BuildRequires:  unzip
-## Test requirements:
-#BuildRequires:  python-nose
-#BuildRequires:  python-httplib2
+%if %{with test}
+BuildRequires:  %{python_module nose}
+BuildRequires:  %{python_module httplib2}
+%endif
 Requires:   python-httplib2
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
 BuildArch:  noarch
-%endif
+
+%python_subpackages
 
 %description
 A Python wrapper around the Trello API. Provides a group of Python classes to 
represent Trello Objects. None of the 
@@ -48,15 +49,17 @@
 %setup -q -n Trolly-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
 
-#%%check
-#nosetests
+%if %{with test}
+%check
+%python_expand nosetests-%{$python_bin_suffix}
+%endif
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %{python_sitelib}/*
 




commit ha-cluster-bootstrap for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package ha-cluster-bootstrap for 
openSUSE:Factory checked in at 2017-09-04 12:32:02

Comparing /work/SRC/openSUSE:Factory/ha-cluster-bootstrap (Old)
 and  /work/SRC/openSUSE:Factory/.ha-cluster-bootstrap.new (New)


Package is "ha-cluster-bootstrap"

Mon Sep  4 12:32:02 2017 rev:33 rq:519890 version:0.5

Changes:

--- 
/work/SRC/openSUSE:Factory/ha-cluster-bootstrap/ha-cluster-bootstrap.changes
2017-02-20 13:14:10.428229171 +0100
+++ 
/work/SRC/openSUSE:Factory/.ha-cluster-bootstrap.new/ha-cluster-bootstrap.changes
   2017-09-04 12:32:02.767589704 +0200
@@ -1,0 +2,5 @@
+Tue Jul 25 13:31:00 UTC 2017 - kgronl...@suse.com
+
+- Recommend sbd, resource-agents and fence-agents (bsc#1050427) 
+
+---



Other differences:
--
++ ha-cluster-bootstrap.spec ++
--- /var/tmp/diff_new_pack.haKeba/_old  2017-09-04 12:32:03.651465431 +0200
+++ /var/tmp/diff_new_pack.haKeba/_new  2017-09-04 12:32:03.655464868 +0200
@@ -28,6 +28,7 @@
 
 BuildRequires:  crmsh >= 3
 BuildRequires:  help2man
+BuildRequires:  python2-parallax
 Requires:   crmsh >= 3
 Requires:   ha-cluster-webui
 Requires:   iproute2
@@ -35,6 +36,9 @@
 Requires:   util-linux
 Recommends: hawk2
 Recommends: ocfs2-tools
+Recommends: sbd
+Recommends: resource-agents
+Recommends: fence-agents
 # These three are required for ocfs2 setup, but not generic setup
 Recommends: parted
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build




commit python-django-appconf for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-django-appconf for 
openSUSE:Factory checked in at 2017-09-04 12:31:16

Comparing /work/SRC/openSUSE:Factory/python-django-appconf (Old)
 and  /work/SRC/openSUSE:Factory/.python-django-appconf.new (New)


Package is "python-django-appconf"

Mon Sep  4 12:31:16 2017 rev:13 rq:519786 version:1.0.2

Changes:

--- 
/work/SRC/openSUSE:Factory/python-django-appconf/python-django-appconf.changes  
2016-12-08 00:29:41.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-django-appconf.new/python-django-appconf.changes
 2017-09-04 12:31:17.154002982 +0200
@@ -1,0 +2,5 @@
+Thu Aug 24 13:36:21 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -72,0 +78 @@
+



Other differences:
--
++ python-django-appconf.spec ++
--- /var/tmp/diff_new_pack.A0H5H2/_old  2017-09-04 12:31:18.797771869 +0200
+++ /var/tmp/diff_new_pack.A0H5H2/_new  2017-09-04 12:31:18.805770745 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-django-appconf
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,39 +16,36 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-django-appconf
 Version:1.0.2
 Release:0
-Url:http://django-appconf.readthedocs.org/
 Summary:A Helper Class for Handling Configuration Defaults of Packaged 
Apps
 License:BSD-3-Clause
 Group:  Development/Languages/Python
-Source: 
https://pypi.io/packages/source/d/django-appconf/django-appconf-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
+Url:http://django-appconf.readthedocs.org/
+Source: 
https://files.pythonhosted.org/packages/source/d/django-appconf/django-appconf-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
 Requires:   python-six
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
 BuildArch:  noarch
-%endif
+%python_subpackages
 
 %description
 A helper class for handling configuration defaults of packaged Django apps
 gracefully.
 
-
 %prep
 %setup -q -n django-appconf-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc AUTHORS LICENSE README.rst docs
 %{python_sitelib}/*




commit python-distutils-extra for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-distutils-extra for 
openSUSE:Factory checked in at 2017-09-04 12:31:07

Comparing /work/SRC/openSUSE:Factory/python-distutils-extra (Old)
 and  /work/SRC/openSUSE:Factory/.python-distutils-extra.new (New)


Package is "python-distutils-extra"

Mon Sep  4 12:31:07 2017 rev:26 rq:519784 version:2.38

Changes:

--- 
/work/SRC/openSUSE:Factory/python-distutils-extra/python-distutils-extra.changes
2013-09-09 19:47:37.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-distutils-extra.new/python-distutils-extra.changes
   2017-09-04 12:31:15.046299325 +0200
@@ -1,0 +2,5 @@
+Thu Aug 24 13:36:16 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -157,0 +163 @@
+



Other differences:
--
++ python-distutils-extra.spec ++
--- /var/tmp/diff_new_pack.i8s5Uv/_old  2017-09-04 12:31:16.066155934 +0200
+++ /var/tmp/diff_new_pack.i8s5Uv/_new  2017-09-04 12:31:16.074154809 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-distutils-extra
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,6 +16,7 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-distutils-extra
 Version:2.38
 Release:0
@@ -24,14 +25,11 @@
 Group:  Development/Libraries/Python
 Url:https://launchpad.net/python-distutils-extra
 Source: 
http://launchpad.net/python-distutils-extra/trunk/%{version}/+download/python-distutils-extra-%{version}.tar.gz
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
 BuildArch:  noarch
-%endif
+%python_subpackages
 
 %description
 This package adds support for common build additions to distutils. This
@@ -42,15 +40,15 @@
   * program icons
 
 %prep
-%setup -q -n "%{name}-%{version}"
+%setup -q
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix="%{_prefix}" --root=%{buildroot}
+%python_install
 
-%files
+%files %{python_files}
 %defattr(-,root,root)
 %doc LICENSE doc/*
 %{python_sitelib}/*




commit python-blessings for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-blessings for 
openSUSE:Factory checked in at 2017-09-04 12:31:03

Comparing /work/SRC/openSUSE:Factory/python-blessings (Old)
 and  /work/SRC/openSUSE:Factory/.python-blessings.new (New)


Package is "python-blessings"

Mon Sep  4 12:31:03 2017 rev:2 rq:519781 version:1.6

Changes:

--- /work/SRC/openSUSE:Factory/python-blessings/python-blessings.changes
2016-10-20 23:07:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-blessings.new/python-blessings.changes   
2017-09-04 12:31:08.267252456 +0200
@@ -1,0 +2,5 @@
+Thu Aug 24 13:33:25 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -4,0 +10 @@
+



Other differences:
--
++ python-blessings.spec ++
--- /var/tmp/diff_new_pack.x8Ktyr/_old  2017-09-04 12:31:10.874885824 +0200
+++ /var/tmp/diff_new_pack.x8Ktyr/_new  2017-09-04 12:31:10.894883012 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-blessings
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,6 +16,7 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-blessings
 Version:1.6
 Release:0
@@ -24,11 +25,14 @@
 Group:  Development/Languages/Python
 Url:https://github.com/erikrose/blessings
 Source: 
https://files.pythonhosted.org/packages/source/b/blessings/blessings-%{version}.tar.gz
-BuildRequires:  python-devel
-BuildRequires:  python-nose
-BuildRequires:  python-setuptools
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  %{python_module curses}
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module nose}
+BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
+Requires:   python-curses
 BuildArch:  noarch
+%python_subpackages
 
 %description
 Curses-like terminal wrapper with a display based on compositing 2d
@@ -38,14 +42,14 @@
 %setup -q -n blessings-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
-%{python_sitelib}/*
 %doc LICENSE README.rst
+%{python_sitelib}/*
 
 %changelog




commit python-biplist for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-biplist for openSUSE:Factory 
checked in at 2017-09-04 12:31:28

Comparing /work/SRC/openSUSE:Factory/python-biplist (Old)
 and  /work/SRC/openSUSE:Factory/.python-biplist.new (New)


Package is "python-biplist"

Mon Sep  4 12:31:28 2017 rev:10 rq:519841 version:1.0.2

Changes:

--- /work/SRC/openSUSE:Factory/python-biplist/python-biplist.changes
2015-04-27 13:05:35.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-biplist.new/python-biplist.changes   
2017-09-04 12:31:31.036051169 +0200
@@ -1,0 +2,21 @@
+Thu Aug 31 06:07:29 UTC 2017 - toddrme2...@gmail.com
+
+- Update to version 1.0.2
+  * Sort sets and dictionaries by key when writing.
+- Update to version 1.0.1
+  * Adding back in Python 2.6 support. This will be removed again in a future 
version.
+- Update to version 1.0.0
+  * This release changes the type of `Uid` from a subclass of `int` to a 
subclass of `object`.
+  * This change was made to address GitHub issue Ints are being turned into 
Uids and vice versa when both are present in a plist.
+  * This release also bumps the minimum supported Python versions to 2.7 and 
3.4.
+- Update to version 0.9.1
+  * Fixes GitHub issue ERROR: testLargeDates (test_valid.TestValidPlistFile)
+  * Fixes Empty Data object converted as empty string
+  * Creates 1-byte strings when possible
+
+---
+Thu Aug 24 13:33:20 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -38,0 +60 @@
+

Old:

  biplist-0.9.tar.gz

New:

  biplist-1.0.2.tar.gz



Other differences:
--
++ python-biplist.spec ++
--- /var/tmp/diff_new_pack.zuKIGu/_old  2017-09-04 12:31:32.275876850 +0200
+++ /var/tmp/diff_new_pack.zuKIGu/_new  2017-09-04 12:31:32.283875725 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-biplist
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,26 +15,31 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+%ifarch x86_64
+%bcond_without  test
+%else
+%bcond_with test
+%endif
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-biplist
-Version:0.9
+Version:1.0.2
 Release:0
-Url:https://bitbucket.org/wooster/biplist
 Summary:A library for reading/writing binary plists
 License:BSD-3-Clause
 Group:  Development/Languages/Python
-Source: 
http://pypi.python.org/packages/source/b/biplist/biplist-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+Url:https://bitbucket.org/wooster/biplist
+Source: 
https://files.pythonhosted.org/packages/source/b/biplist/biplist-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
-BuildRequires:  python-coverage
-BuildRequires:  python-devel >= 2.7
-BuildRequires:  python-nose
-BuildRequires:  python-setuptools
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110
-%{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%else
-BuildArch:  noarch
+BuildRequires:  python-rpm-macros
+%if %{with test}
+BuildRequires:  %{python_module coverage}
+BuildRequires:  %{python_module nose}
 %endif
+BuildArch:  noarch
+%python_subpackages
 
 %description
 biplist is a binary plist parser/generator for Python.
@@ -47,16 +52,18 @@
 %setup -q -n biplist-%{version}
 
 %build
-python setup.py build
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
-%fdupes %buildroot/%_prefix
+%python_install
+%python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%if %{with test}
 %check
-python setup.py -q test
+%python_exec setup.py test
+%endif
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc AUTHORS LICENSE README.md
 %{python_sitelib}/*

++ biplist-0.9.tar.gz -> biplist-1.0.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/biplist-0.9/PKG-INFO new/biplist-1.0.2/PKG-INFO
--- old/biplist-0.9/PKG-INFO2014-10-26 20:09:20.0 +0100
+++ new/biplist-1.0.2/PKG-INFO  2017-05-11 01:02:57.0 +0200
@@ -1,19 +1,19 @@
 Metadata-Version: 1.1
 Name: biplist
-Version: 0.9
+Version: 1.0.2
 Summary: biplist is a library for reading/writing binary plists.
 

commit python-Durus for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-Durus for openSUSE:Factory 
checked in at 2017-09-04 12:31:22

Comparing /work/SRC/openSUSE:Factory/python-Durus (Old)
 and  /work/SRC/openSUSE:Factory/.python-Durus.new (New)


Package is "python-Durus"

Mon Sep  4 12:31:22 2017 rev:8 rq:519793 version:3.9

Changes:

--- /work/SRC/openSUSE:Factory/python-Durus/python-Durus.changes
2013-04-15 11:16:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-Durus.new/python-Durus.changes   
2017-09-04 12:31:26.216728765 +0200
@@ -1,0 +2,5 @@
+Thu Aug 24 13:37:52 UTC 2017 - jmate...@suse.com
+
+- singlespec auto-conversion
+
+---
@@ -15,0 +21 @@
+



Other differences:
--
++ python-Durus.spec ++
--- /var/tmp/diff_new_pack.wIw6sn/_old  2017-09-04 12:31:28.000477970 +0200
+++ /var/tmp/diff_new_pack.wIw6sn/_new  2017-09-04 12:31:28.020475159 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-Durus
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,23 +16,26 @@
 #
 
 
+%define oldpython python
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-Durus
 Version:3.9
 Release:0
-Url:http://www.mems-exchange.org/software/durus/
 Summary:A Python Object Database
 License:CNRI-Python
 Group:  Development/Languages/Python
-Source: Durus-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  python-devel
-BuildRequires:  python-nose
-%if 0%{?suse_version}
-%py_requires
+Url:http://www.mems-exchange.org/software/durus/
+Source: 
https://files.pythonhosted.org/packages/source/D/Durus/Durus-%{version}.tar.gz
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module nose}
+BuildRequires:  python-rpm-macros
+%ifpython2
+Provides:   %{oldpython}-durus = %{version}
+Obsoletes:  %{oldpython}-durus < %{version}
 %endif
-Provides:   python-durus = %{version}
-Obsoletes:  python-durus < %{version}
-%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+Requires(post):   update-alternatives
+Requires(postun):  update-alternatives
+%python_subpackages
 
 %description
 Serves and manages changes to persistent objects being used in
@@ -43,18 +46,26 @@
 sed -i "1d" {db_renumber,__main__}.py # Fix non-executable scripts
 
 %build
-CFLAGS="%{optflags}" python setup.py build
+export CFLAGS="%{optflags}"
+%python_build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+%python_install
+%python_clone -a %{buildroot}%{_bindir}/durus
+
+%post
+%python_install_alternative durus
+
+%postun
+%python_uninstall_alternative durus
 
 %check
-nosetests
+%python_expand nosetests-%{$python_bin_suffix}
 
-%files
+%files %{python_files}
 %defattr(-,root,root,-)
 %doc ACKS.txt CHANGES.txt LICENSE.txt README.txt doc/FAQ.txt
-%{_bindir}/durus
+%python_alternative %{_bindir}/durus
 %{python_sitearch}/*
 
 %changelog




commit crmsh for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package crmsh for openSUSE:Factory checked 
in at 2017-09-04 12:30:59

Comparing /work/SRC/openSUSE:Factory/crmsh (Old)
 and  /work/SRC/openSUSE:Factory/.crmsh.new (New)


Package is "crmsh"

Mon Sep  4 12:30:59 2017 rev:127 rq:519746 version:3.0.1+git.1504075678.b5dce7ab

Changes:

--- /work/SRC/openSUSE:Factory/crmsh/crmsh.changes  2017-08-10 
14:13:09.275571019 +0200
+++ /work/SRC/openSUSE:Factory/.crmsh.new/crmsh.changes 2017-09-04 
12:31:02.888008774 +0200
@@ -1,0 +2,82 @@
+Wed Aug 30 20:12:00 UTC 2017 - kgronl...@suse.com
+
+- Update to version 3.0.1+git.1504075678.b5dce7ab:
+  * low: utils: is_process did not work
+  * low: utils: Use /proc for process discovery
+  * low: bootstrap: Fix formatting of confirmation prompt (bsc#1028704)
+  * medium: bootstrap: Set expected_votes based on actual node count 
(bsc#1033288)
+  * remove bindnetaddr for unicast(bsc#1030437)
+  * lsb, service, stonith and systemd don't have any providers; so, it 
shouldn't be completed when type 'tab' after these ra classes.
+  * doc: Document lifetime parameter format
+  * medium: Add support for pacemaker PR#1208
+  * Feature: add rules support to operations
+  * low: bootstrap: Fall back to logging into $TMPDIR/ha-cluster-bootstrap.log
+  * Improved cd completion
+  * Improve ls command outputs
+  * Remove "up/back/end" option at root level
+  * medium: ui_context: Make all the options can be completed
+  * medium: ui_ra: Improve resource agents completion
+  * medium: ui_cluster: Add enable/disable option to enable/disable pacemaker 
service
+  * medium:command:adjust the 'ls' print width for long options
+  * low:scripts:health: save health-report when run "crm cluster health"
+  * low: ui_cluster: add "delete" alias for "remove" option
+  * low: bootstrap: give a confirm message when remove node
+  * medium: bootstrap: add callback function to check valid port range
+  * medium: ui_cluster: Add cluster rename command
+  * low: ui_cluster: when use help option, do not exit, just print help 
messages and return
+  * low: ui_cluster: when have an error for optparse, just return and stay at 
shell
+  * low: ui_cluster: complete node name once
+  * low: help: adjust the help print width
+  * low: ui_cluster: show cluster name in cluster status command
+  * Add missing ')'
+  * low: completers: filter out ms resource when doing promote/demote
+  * low: bootstrap: Don't rely on ha-cluster-* shortcuts
+  * low: bootstrap: Improve message when sbd is not installed (bsc#1050427)
+  * low: ui_cluster: run command on a specific node
+  * medium: bootstrap: run "csync2_update" for all files after new joining 
node call csync2_remote
+  * low: ui_cluster: change cluster name need restart cluster service
+  * medium: bootstrap: disable completion and history when running bootstrap
+  * high: bootstrap: expected votes wouldn't update in unicast mode
+  * medium: bootstrap: configure with IPv6(mcast)
+  * medium: bootstrap: configure with IPv6(unicast)
+  * medium: bootstrap: validation for bindnetaddr/mcastaddr
+  * medium: bootstrap: validation for admin IP
+  * medium: utils: list_cluster_nodes: read nodes list from cib.xml
+  * low: main: add hostname in promptstr
+  * medium: enable adding a second heartbeat ring for mcast
+  * low: bootstrap: give error hints when use sbd without watchdog
+  * medium: ui_resource: start stopped resources and stop started resources
+  * Detect firewall by checking installed packages
+  * Fix SBD configuration when using SBD device (Fixes #235)
+  * medium: bootstrap: Add support for chrony
+  * low: bootstrap: Check for firewalld before SuSEfirewall2
+  * medium: ui_configure: in modgroup, add free id and remove id in group
+  * medium: ui_node: node utilization is about node attr, not for resources
+
+- Drop merged patches:
+  * Remove 0001-Allow-empty-fencing_topology-bsc-1025393.patch
+  * Remove 0002-low-bootstrap-Fix-warning-for-formatting-SBD-device-.patch
+  * Remove 0003-medium-ui_cluster-Fix-init-with-no-arguments-bsc-102.patch
+  * Remove 0004-low-utils-Use-proc-for-process-discovery.patch
+  * Remove 0005-medium-scripts-health-Make-health-script-available-a.patch
+  * Remove 0006-remove-bindnetaddr-for-unicast-bsc-1030437.patch
+  * Remove 0007-medium-bootstrap-Set-expected_votes-based-on-actual-.patch
+  * Remove 0008-high-cibconfig-Graph-file-output-option-was-reversed.patch
+  * Remove 0009-medium-bootstrap-Enable-help-geo-init-etc.-bsc-10374.patch
+  * Remove 0010-medium-bootstrap-Handle-failure-to-fetch-config-grac.patch
+  * Remove 0011-medium-bootstrap-Check-required-arguments-to-geo-joi.patch
+  * Remove 0012-doc-geo-join-requires-clusters-argument-bsc-1037442.patch
+  * Remove 0013-medium-bootstrap-Make-arbitrator-argument-optional-b.patch
+  * Remove 

commit sqlitebrowser for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package sqlitebrowser for openSUSE:Factory 
checked in at 2017-09-04 12:30:35

Comparing /work/SRC/openSUSE:Factory/sqlitebrowser (Old)
 and  /work/SRC/openSUSE:Factory/.sqlitebrowser.new (New)


Package is "sqlitebrowser"

Mon Sep  4 12:30:35 2017 rev:9 rq:519688 version:3.10.0

Changes:

--- /work/SRC/openSUSE:Factory/sqlitebrowser/sqlitebrowser.changes  
2017-01-24 10:38:06.750269861 +0100
+++ /work/SRC/openSUSE:Factory/.sqlitebrowser.new/sqlitebrowser.changes 
2017-09-04 12:30:36.955654839 +0200
@@ -1,0 +2,34 @@
+Wed Aug 30 14:24:07 UTC 2017 - mplus...@suse.com
+
+- Correct license
+- Use more cmake macros
+- Use shared qscintilla library
+
+---
+Tue Aug 29 16:59:44 UTC 2017 - wba...@tmo.at
+
+- update to version 3.10.0
+  * Highlights
+- DBHub.io integration
+  + Uploading and downloading of databases works
+  + Branching, forking, starring works, as does creating tags and releases
+  + There's a 100MB per database limit at the moment though, as it's still 
in development
+  + Backups aren't done on it (yet), so don't use it as your only place 
for storing important things (!!!)
+  + The front page is... not great. We're working on it.
+  + Still lots of upcoming stuff needing to be done. An API to query your 
databases, a cli, merging, discussions/issues
+  + Please report bugs, ideas, suggestions (etc) on the dbhub.io repo 
issue tracker as you find them.
+- Many plot improvements (NULL values, progress dialog, remember settings, 
better colours, and bug fixes)
+- Better table editing (foreign key editor, toggling the WITHOUT ROWID 
flag, temporary tables, ...)
+- Better Import CSV dialog. It can now handle multiple CSV files at once
+- Improved Index dialog and better index handling in general
+- Better handling of virtual tables
+- Filter improvements (ranges, NULL search)
+- The usual improvements to the grammar parser
+  * See the full list of changes under
+https://github.com/sqlitebrowser/sqlitebrowser/releases/tag/v3.10.0
+- switch back to cmake build
+- use system antlr on openSUSE, the problems seem to be fixed
+- unconditionally build with Qt5, Qt4 support has been dropped in
+  this release
+
+---

Old:

  sqlitebrowser-3.9.1.tar.gz

New:

  sqlitebrowser-3.10.0.tar.gz



Other differences:
--
++ sqlitebrowser.spec ++
--- /var/tmp/diff_new_pack.ALUcej/_old  2017-09-04 12:30:37.823532816 +0200
+++ /var/tmp/diff_new_pack.ALUcej/_new  2017-09-04 12:30:37.827532254 +0200
@@ -17,35 +17,34 @@
 
 
 Name:   sqlitebrowser
-Version:3.9.1
+Version:3.10.0
 Release:0
 Summary:Create, design and edit SQLite Databases
-License:GPL-3.0+ or MPL-2.0
+License:GPL-3.0+ AND MPL-2.0
 Group:  Productivity/Office/Organizers
 Url:http://sqlitebrowser.org/
 Source0:
https://github.com/sqlitebrowser/sqlitebrowser/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
 Source1:sqlitebrowser.1
 BuildRequires:  gcc-c++
 BuildRequires:  hicolor-icon-theme
+BuildRequires:  libqscintilla_qt5-devel
+BuildRequires:  libqt5-linguist-devel
+BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
+BuildRequires:  pkgconfig(Qt5Gui)
+BuildRequires:  pkgconfig(Qt5Network)
+BuildRequires:  pkgconfig(Qt5PrintSupport)
+BuildRequires:  pkgconfig(Qt5Test)
+BuildRequires:  pkgconfig(Qt5Widgets)
+BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(sqlite3)
 Requires(post): hicolor-icon-theme
 Requires(post): update-desktop-files
 Requires(postun): hicolor-icon-theme
 Requires(postun): update-desktop-files
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 # not on SLE-12
 %if 0%{?suse_version} != 1315 || 0%{?is_opensuse}
-#BuildRequires:  antlr-devel
-BuildRequires:  libqt5-linguist-devel
-BuildRequires:  pkgconfig(Qt5Gui)
-BuildRequires:  pkgconfig(Qt5Network)
-BuildRequires:  pkgconfig(Qt5PrintSupport)
-BuildRequires:  pkgconfig(Qt5Test)
-BuildRequires:  pkgconfig(Qt5Widgets)
-BuildRequires:  pkgconfig(glib-2.0)
-%else
-BuildRequires:  libqt4-devel
+BuildRequires:  antlr-devel
 %endif
 
 %description
@@ -71,21 +70,18 @@
 %setup -q
 
 %build
-%if 0%{?suse_version} == 1315 && ! 0%{?is_opensuse}
-%qmake CONFIG+=debug
-%else
-%qmake5 CONFIG+=debug
-%endif
-
-make %{?_smp_mflags}
+%cmake \
+  -DQSCINTILLA_INCLUDE_DIR=%{_includedir}/qt5/Qsci \
+  -DQSCINTILLA_LIBRARY=%{_libdir}/libqscintilla2_qt5.so \
+  -DBUILD_SHARED_LIBS=OFF \
+  -Wno-dev
+%make_jobs
 
 %install
-install -Dm 0755 src/%{name} 

commit hivex for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package hivex for openSUSE:Factory checked 
in at 2017-09-04 12:30:26

Comparing /work/SRC/openSUSE:Factory/hivex (Old)
 and  /work/SRC/openSUSE:Factory/.hivex.new (New)


Package is "hivex"

Mon Sep  4 12:30:26 2017 rev:8 rq:519683 version:1.3.14

Changes:

--- /work/SRC/openSUSE:Factory/hivex/hivex.changes  2015-11-04 
15:34:27.0 +0100
+++ /work/SRC/openSUSE:Factory/.hivex.new/hivex.changes 2017-09-04 
12:30:35.287889325 +0200
@@ -1,0 +2,6 @@
+Mon Jul 31 09:42:50 UTC 2017 - cbosdon...@suse.com
+
+- Update to version 3.14
+- Build OCAML binding
+
+---

Old:

  hivex-1.3.12.tar.gz
  hivex-1.3.12.tar.gz.sig

New:

  hivex-1.3.14.tar.gz
  hivex-1.3.14.tar.gz.sig



Other differences:
--
++ hivex.spec ++
--- /var/tmp/diff_new_pack.7TrzWj/_old  2017-09-04 12:30:36.095775737 +0200
+++ /var/tmp/diff_new_pack.7TrzWj/_new  2017-09-04 12:30:36.103774613 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package hivex
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2011 Michal Hrusecky 
 #
 # All modifications and additions to the file contributed by third parties
@@ -17,8 +17,9 @@
 #
 
 
-%define with_perl 1
-%define with_python 1
+%bcond_without perl_bingings
+%bcond_without python_bindings
+%bcond_without ocaml_bindings
 
 Name:   hivex
 BuildRequires:  autoconf
@@ -37,7 +38,7 @@
 Summary:Windows "Registry Hive" extraction library
 License:LGPL-2.1 and GPL-2.0
 Group:  System/Filesystems
-Version:1.3.12
+Version:1.3.14
 Release:0
 Source: http://libguestfs.org/download/hivex/%name-%version.tar.gz
 Source2:http://libguestfs.org/download/hivex/%name-%version.tar.gz.sig
@@ -64,7 +65,7 @@
 %description -n libhivex0
 Hivex is a Windows Registry Hive extraction library.
 
-%if %with_perl
+%if %{with perl_bingings}
 %package -n perl-Win-Hivex
 Summary:Perl bindings for hivex
 Group:  System/Filesystems
@@ -83,7 +84,7 @@
 
 %endif
 
-%if %with_python
+%if %{with python_bindings}
 %package -n python-hivex
 %define pyver %(python -c "import sys; print sys.version[:3]")
 BuildRequires:  python
@@ -96,6 +97,27 @@
 Hivex is a Windows Registry Hive extraction library.
 %endif
 
+%if %{with ocaml_bindings}
+%package -n ocaml-hivex
+BuildRequires:  ocaml
+BuildRequires:  ocaml-findlib
+
+Summary:OCAML bindings for libhivex
+Group:  System/Filesystems
+
+%description -n ocaml-hivex
+This subpackage contains the OCAML bindings for hivex.
+Hivex is a Windows Registry Hive extraction library.
+
+%package -n ocaml-hivex-devel
+Summary:OCAML bindings development files for libhivex
+Group:  Development/Libraries/Other
+
+%description -n ocaml-hivex-devel
+This subpackage contains the OCAML bindings development file
+for hivex. Hivex is a Windows Registry Hive extraction library.
+%endif
+
 %lang_package
 
 %prep
@@ -116,12 +138,15 @@
%{?_smp_mflags}
 
 %install
-%make_install
+%make_install INSTALLDIRS=vendor
+
+%if %{with perl_bingings}
 %perl_process_packlist
 %perl_gen_filelist
 # the macro above packages everything, here only the perl files are desrired
 grep "%perl_vendorarch/" %name.files | tee t
 mv t %name.files
+%endif
 #
 rm -f %buildroot/%_libdir/*.{l,}a
 touch %name.lang
@@ -146,13 +171,13 @@
 %defattr(-,root,root)
 %_libdir/*.so.*
 
-%if %with_python
+%if %{with python_bindings}
 %files -n python-hivex
 %defattr(-,root,root)
 %_libdir/python%pyver/site-packages/*
 %endif
 
-%if %with_perl
+%if %{with perl_bingings}
 %post -n perl-Win-Hivex -p /sbin/ldconfig
 
 %postun -n perl-Win-Hivex -p /sbin/ldconfig
@@ -162,6 +187,22 @@
 %endif
 #
 
+%if %{with ocaml_bindings}
+%files -n ocaml-hivex
+%defattr(-,root,root)
+%dir %{_libdir}/ocaml/hivex
+%{_libdir}/ocaml/hivex/META
+%{_libdir}/ocaml/hivex/hivex.cmi
+%{_libdir}/ocaml/hivex/mlhivex.cma
+%{_libdir}/ocaml/stublibs/*hivex.so*
+
+%files -n ocaml-hivex-devel
+%defattr(-,root,root)
+%{_libdir}/ocaml/hivex/*hivex.a
+%{_libdir}/ocaml/hivex/*hivex.cmx*
+%{_libdir}/ocaml/hivex/hivex.mli
+%endif
+
 %files lang -f %name.lang
 
 %changelog

++ hivex-1.3.12.tar.gz -> hivex-1.3.14.tar.gz ++
 9958 lines of diff (skipped)




commit open-iscsi for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package open-iscsi for openSUSE:Factory 
checked in at 2017-09-04 12:28:42

Comparing /work/SRC/openSUSE:Factory/open-iscsi (Old)
 and  /work/SRC/openSUSE:Factory/.open-iscsi.new (New)


Package is "open-iscsi"

Mon Sep  4 12:28:42 2017 rev:64 rq:520364 version:unknown

Changes:

--- /work/SRC/openSUSE:Factory/open-iscsi/open-iscsi.changes2017-08-12 
19:32:49.093368296 +0200
+++ /work/SRC/openSUSE:Factory/.open-iscsi.new/open-iscsi.changes   
2017-09-04 12:28:42.907689697 +0200
@@ -1,0 +2,15 @@
+Sat Sep 02 16:35:14 UTC 2017 - ldun...@suse.com
+
+- Update to latest upstream 2.0.875, with a few SUSE-only
+  modifications, replacing the 2.0.874-suse tarball with a
+  2.0.875-suse version, and resetting the SUSE-latest-diff
+  file to contain changes from 2.0.875-suse forward (bsc#1056689)
+
+---
+Mon Aug 28 13:45:52 PDT 2017 - ldun...@suse.com
+
+- Add missing coreutils dependency for initrd macros (bsc#1055492)
+  in SPEC file, which (as always) changes:
+  * open-iscsi-SUSE-latest.diff.bz2
+
++---

Old:

  open-iscsi-2.0.874-suse.tar.bz2

New:

  open-iscsi-2.0.875-suse.tar.bz2



Other differences:
--
++ open-iscsi.spec ++
--- /var/tmp/diff_new_pack.PClWcB/_old  2017-09-04 12:28:43.523603102 +0200
+++ /var/tmp/diff_new_pack.PClWcB/_new  2017-09-04 12:28:43.527602540 +0200
@@ -30,13 +30,14 @@
 BuildRequires:  suse-module-tools
 BuildRequires:  systemd
 Url:http://www.open-iscsi.com
-Version:2.0.874
+Version:2.0.875
 Release:0
 %{?systemd_requires}
-%define iscsi_release 874-suse
+%define iscsi_release 875-suse
 Summary:Linux* Open-iSCSI Software Initiator
 License:GPL-2.0+
 Group:  Productivity/Networking/Other
+Requires(post): coreutils
 Source: %{name}-2.0.%{iscsi_release}.tar.bz2
 Patch1: %{name}-SUSE-latest.diff.bz2
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ open-iscsi-2.0.874-suse.tar.bz2 -> open-iscsi-2.0.875-suse.tar.bz2 ++
 4588 lines of diff (skipped)

++ open-iscsi-SUSE-latest.diff.bz2 ++
 4847 lines (skipped)
 between 
/work/SRC/openSUSE:Factory/open-iscsi/open-iscsi-SUSE-latest.diff.bz2
 and 
/work/SRC/openSUSE:Factory/.open-iscsi.new/open-iscsi-SUSE-latest.diff.bz2




commit ovmf for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package ovmf for openSUSE:Factory checked in 
at 2017-09-04 12:28:30

Comparing /work/SRC/openSUSE:Factory/ovmf (Old)
 and  /work/SRC/openSUSE:Factory/.ovmf.new (New)


Package is "ovmf"

Mon Sep  4 12:28:30 2017 rev:16 rq:519253 version:2017+git1502826981.a136bc3ccf

Changes:

--- /work/SRC/openSUSE:Factory/ovmf/ovmf.changes2017-08-22 
11:05:20.536595743 +0200
+++ /work/SRC/openSUSE:Factory/.ovmf.new/ovmf.changes   2017-09-04 
12:28:32.833106144 +0200
@@ -1,0 +2,6 @@
+Mon Aug 28 08:54:14 UTC 2017 - g...@suse.com
+
+- Update ovmf-embed-default-keys.patch to handle the empty
+  certificate files correctly
+
+---



Other differences:
--











++ ovmf-embed-default-keys.patch ++
--- /var/tmp/diff_new_pack.jQ0PSf/_old  2017-09-04 12:28:34.928811497 +0200
+++ /var/tmp/diff_new_pack.jQ0PSf/_new  2017-09-04 12:28:34.936810372 +0200
@@ -1,7 +1,7 @@
-From 6bf96df236dbe46c1e4591b6a59553928bfd603c Mon Sep 17 00:00:00 2001
+From b967e8dc2bea98736d8544d9ee2565f71ac06d08 Mon Sep 17 00:00:00 2001
 From: Gary Ching-Pang Lin 
 Date: Fri, 10 May 2013 10:27:51 +0800
-Subject: [PATCH 1/2] Add a stub to allow keys to be embedded at build time
+Subject: [PATCH 1/3] Add a stub to allow keys to be embedded at build time
 
 Signed-off-by: Gary Ching-Pang Lin 
 ---
@@ -18,7 +18,7 @@
  create mode 100644 SecurityPkg/Library/AuthVariableLib/Default_PK.h
 
 diff --git a/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.c 
b/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.c
-index c4fbb64..9e12588 100644
+index 792a1232ae..f5f954e534 100644
 --- a/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.c
 +++ b/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.c
 @@ -23,6 +23,10 @@ WITHOUT WARRANTIES OR REPRESENTATIONS OF ANY KIND, EITHER 
EXPRESS OR IMPLIED.
@@ -223,7 +223,7 @@
// Reserve runtime buffer for public key database. The size excludes 
variable header and name size.
//
 diff --git a/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.inf 
b/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.inf
-index 572ba4e..1a46019 100644
+index 572ba4e120..1a46019a5f 100644
 --- a/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.inf
 +++ b/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.inf
 @@ -33,6 +33,10 @@ [Sources]
@@ -239,7 +239,7 @@
MdePkg/MdePkg.dec
 diff --git a/SecurityPkg/Library/AuthVariableLib/Default_DB.h 
b/SecurityPkg/Library/AuthVariableLib/Default_DB.h
 new file mode 100644
-index 000..4d13894
+index 00..4d13894216
 --- /dev/null
 +++ b/SecurityPkg/Library/AuthVariableLib/Default_DB.h
 @@ -0,0 +1,2 @@
@@ -247,7 +247,7 @@
 +unsigned int Default_DB_len = 0;
 diff --git a/SecurityPkg/Library/AuthVariableLib/Default_DBX.h 
b/SecurityPkg/Library/AuthVariableLib/Default_DBX.h
 new file mode 100644
-index 000..5fd3cdc
+index 00..5fd3cdc0f4
 --- /dev/null
 +++ b/SecurityPkg/Library/AuthVariableLib/Default_DBX.h
 @@ -0,0 +1,2 @@
@@ -255,7 +255,7 @@
 +unsigned int Default_DBX_len = 0;
 diff --git a/SecurityPkg/Library/AuthVariableLib/Default_KEK.h 
b/SecurityPkg/Library/AuthVariableLib/Default_KEK.h
 new file mode 100644
-index 000..80883de
+index 00..80883de1ae
 --- /dev/null
 +++ b/SecurityPkg/Library/AuthVariableLib/Default_KEK.h
 @@ -0,0 +1,2 @@
@@ -263,20 +263,20 @@
 +unsigned int Default_KEK_len = 0;
 diff --git a/SecurityPkg/Library/AuthVariableLib/Default_PK.h 
b/SecurityPkg/Library/AuthVariableLib/Default_PK.h
 new file mode 100644
-index 000..23b90e4
+index 00..23b90e45f0
 --- /dev/null
 +++ b/SecurityPkg/Library/AuthVariableLib/Default_PK.h
 @@ -0,0 +1,2 @@
 +unsigned char *Default_PK = NULL;
 +unsigned int Default_PK_len = 0;
 -- 
-2.8.1
+2.14.1
 
 
-From a627dbe16f6ebe1a1f294c82c30f7ad9745baf04 Mon Sep 17 00:00:00 2001
+From 5e76fc193363471e9720005bdb8e4c62fb15de6b Mon Sep 17 00:00:00 2001
 From: Gary Lin 
 Date: Tue, 15 Dec 2015 16:54:54 +0800
-Subject: [PATCH 2/2] Add DB_EX to include one more DB cert
+Subject: [PATCH 2/3] Add DB_EX to include one more DB cert
 
 Signed-off-by: Gary Lin 
 ---
@@ -286,7 +286,7 @@
  create mode 100644 SecurityPkg/Library/AuthVariableLib/Default_DB_EX.h
 
 diff --git a/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.c 
b/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.c
-index 9e12588..523b0e4 100644
+index f5f954e534..803b77d178 100644
 --- a/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.c
 +++ b/SecurityPkg/Library/AuthVariableLib/AuthVariableLib.c
 @@ -26,6 +26,7 @@ WITHOUT WARRANTIES OR REPRESENTATIONS OF ANY KIND, EITHER 
EXPRESS OR IMPLIED.
@@ -353,12 

commit python-sip for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package python-sip for openSUSE:Factory 
checked in at 2017-09-04 12:28:25

Comparing /work/SRC/openSUSE:Factory/python-sip (Old)
 and  /work/SRC/openSUSE:Factory/.python-sip.new (New)


Package is "python-sip"

Mon Sep  4 12:28:25 2017 rev:94 rq:519231 version:4.19.3

Changes:

--- /work/SRC/openSUSE:Factory/python-sip/python-sip.changes2017-06-01 
16:22:59.601536174 +0200
+++ /work/SRC/openSUSE:Factory/.python-sip.new/python-sip.changes   
2017-09-04 12:28:26.026063187 +0200
@@ -1,0 +2,10 @@
+Mon Aug 28 21:03:01 UTC 2017 - toddrme2...@gmail.com
+
+- Update to 4.19.3
+  * Added support for type hints for properties.
+  * Added sipEventType and sipRegisterEventHandler() to the C API.
+  * Added sipInstanceDestroyed() to the C API.
+  * Added sipPrintObject() to the C API.
+  * Bug fixes.
+
+---

Old:

  sip-4.19.2.tar.gz

New:

  sip-4.19.3.tar.gz



Other differences:
--
++ python-sip.spec ++
--- /var/tmp/diff_new_pack.Yq2Vty/_old  2017-09-04 12:28:27.325880438 +0200
+++ /var/tmp/diff_new_pack.Yq2Vty/_new  2017-09-04 12:28:27.329879876 +0200
@@ -16,11 +16,11 @@
 #
 
 
-%define python_sip_api 12.1
+%define python_sip_api 12.2
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-sip
-Version:4.19.2
+Version:4.19.3
 Release:0
 Summary:SIP tool to use python sip bindings
 License:GPL-2.0 or GPL-3.0 or SUSE-SIP

++ sip-4.19.2.tar.gz -> sip-4.19.3.tar.gz ++
 16931 lines of diff (skipped)




commit corosync for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package corosync for openSUSE:Factory 
checked in at 2017-09-04 12:28:36

Comparing /work/SRC/openSUSE:Factory/corosync (Old)
 and  /work/SRC/openSUSE:Factory/.corosync.new (New)


Package is "corosync"

Mon Sep  4 12:28:36 2017 rev:42 rq:519300 version:2.4.2

Changes:

--- /work/SRC/openSUSE:Factory/corosync/corosync.changes2017-08-24 
18:26:46.306006460 +0200
+++ /work/SRC/openSUSE:Factory/.corosync.new/corosync.changes   2017-09-04 
12:28:37.924390330 +0200
@@ -1,0 +2,6 @@
+Tue Aug 29 07:50:16 UTC 2017 - b...@suse.com
+
+- corosync.service should be marked as a static service(bsc#1055585)
+Added: 0012-mark-corosync-as-a-static-service.patch
+
+---
@@ -21,0 +28 @@
+   3) remove macro tpmfiles_create define from corosync.spec.

New:

  0012-mark-corosync-as-a-static-service.patch



Other differences:
--
++ corosync.spec ++
--- /var/tmp/diff_new_pack.arywkS/_old  2017-09-04 12:28:39.108223888 +0200
+++ /var/tmp/diff_new_pack.arywkS/_new  2017-09-04 12:28:39.116222763 +0200
@@ -32,10 +32,6 @@
 %bcond_without qdevices
 %bcond_without qnetd
 
-%if !%{defined tmpfiles_create}
-%define tmpfiles_create systemd-tmpfiles --create ||:
-%endif
-
 %if 0%{?sles_version} == 12
 %ifnarch s390 s390x
 %define buildib 1
@@ -75,6 +71,7 @@
 Patch19:0009-totem-Propagate-totem-initialization-failure.patch
 Patch20:0010-fix-ifdown-udp.patch
 Patch21:0011-fix-tmpfiles-create.patch
+Patch22:0012-mark-corosync-as-a-static-service.patch
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 # openais is indeed gone and should be uninstalled. Yes, we do not
@@ -154,6 +151,7 @@
 %patch19 -p1
 %patch20 -p1
 %patch21 -p1
+%patch22 -p1
 
 %build
 %if %{with runautogen}

++ 0012-mark-corosync-as-a-static-service.patch ++
--- corosync-2.4.2.orig/init/corosync.service.in2017-08-29 
15:47:18.131052520 +0800
+++ corosync-2.4.2/init/corosync.service.in 2017-08-29 15:46:24.949842298 
+0800
@@ -23,4 +23,4 @@
 #ExecStartPre=/sbin/modprobe softdog soft_margin=60
 
 [Install]
-WantedBy=multi-user.target
+#WantedBy=multi-user.target



commit pcp for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package pcp for openSUSE:Factory checked in 
at 2017-09-04 12:27:37

Comparing /work/SRC/openSUSE:Factory/pcp (Old)
 and  /work/SRC/openSUSE:Factory/.pcp.new (New)


Package is "pcp"

Mon Sep  4 12:27:37 2017 rev:41 rq:519807 version:3.11.9

Changes:

--- /work/SRC/openSUSE:Factory/pcp/pcp.changes  2017-06-24 08:34:19.589473201 
+0200
+++ /work/SRC/openSUSE:Factory/.pcp.new/pcp.changes 2017-09-04 
12:27:38.300773136 +0200
@@ -1,0 +2,17 @@
+Wed Aug 30 23:30:36 UTC 2017 - dd...@suse.com
+
+- Enable QT5 builds for Factory (suse_version > 1320); (bsc#1056477).
+
+---
+Wed Aug 30 12:38:58 UTC 2017 - dd...@suse.com
+
+- Ensure sysconfig files are populated from templates during installation;
+  (bsc#1056397).
+
+---
+Thu Aug 24 15:42:33 UTC 2017 - dd...@suse.com
+
+- Add weak pcp dependency to pmdas that were split out from the base package
+  in the 3.10->3.11 update; (bsc#1055503).
+
+---



Other differences:
--
++ pcp.spec ++
--- /var/tmp/diff_new_pack.UqOWop/_old  2017-09-04 12:27:39.620587577 +0200
+++ /var/tmp/diff_new_pack.UqOWop/_new  2017-09-04 12:27:39.644584203 +0200
@@ -173,6 +173,10 @@
 # Qt development and runtime environment missing components before el6
 %if 0%{?rhel} == 0 || 0%{?rhel} > 5
 %global disable_qt 0
+# We need qt5 for fedora and openSUSE / SLE factory
+%if 0%{?fedora} != 0 || 0%{?suse_version} > 1320
+%global default_qt 5
+%endif
 %else
 %global disable_qt 1
 %endif
@@ -280,12 +284,22 @@
 %endif
 %if !%{disable_qt}
 BuildRequires:  desktop-file-utils
+%if 0%{?default_qt} != 5
 %if 0%{?suse_version}
 BuildRequires:  libqt4-devel >= 4.4
-%else
+%else  # suse_version
 BuildRequires:  qt4-devel >= 4.4
-%endif
-%endif
+%endif # suse_version
+%else  # default_qt
+%if 0%{?suse_version}
+BuildRequires:  libqt5-qtbase-devel
+BuildRequires:  libqt5-qtsvg-devel
+%else  # suse_version
+BuildRequires:  qt5-qtbase-devel
+BuildRequires:  qt5-qtsvg-devel
+%endif # suse_version
+%endif # default_qt
+%endif # !disable_qt
 %if !%{disable_selinux}
 Requires:   pcp-selinux = %{version}-%{release}
 %endif
@@ -962,6 +976,7 @@
 Group:  %{pcp_gr}
 Url:http://www.pcp.io
 Requires:   perl-PCP-PMDA = %{version}-%{release}
+Supplements:pcp
 
 %description pmda-bonding
 This package contains the PCP Performance Metrics Domain Agent (PMDA) for
@@ -977,6 +992,7 @@
 Group:  %{pcp_gr}
 Url:http://www.pcp.io
 Requires:   perl-PCP-PMDA = %{version}-%{release}
+Supplements:pcp
 
 %description pmda-dbping
 This package contains the PCP Performance Metrics Domain Agent (PMDA) for
@@ -1030,6 +1046,7 @@
 Requires:   perl-PCP-PMDA = %{version}-%{release}
 Requires:   perl(LWP::UserAgent)
 BuildRequires:  perl(LWP::UserAgent)
+Supplements:pcp
 
 %description pmda-elasticsearch
 This package contains the PCP Performance Metrics Domain Agent (PMDA) for
@@ -1060,6 +1077,7 @@
 Group:  %{pcp_gr}
 Url:http://www.pcp.io
 Requires:   perl-PCP-PMDA = %{version}-%{release}
+Supplements:pcp
 
 %description pmda-gpsd
 This package contains the PCP Performance Metrics Domain Agent (PMDA) for
@@ -1075,6 +1093,7 @@
 Group:  %{pcp_gr}
 Url:http://www.pcp.io
 Requires:   perl-PCP-PMDA = %{version}-%{release}
+Supplements:pcp
 
 %description pmda-kvm
 This package contains the PCP Performance Metrics Domain Agent (PMDA) for
@@ -1122,6 +1141,7 @@
 Requires:   %{lib_pkg} = %{version}-%{release}
 %endif
 Requires:   pcp = %{version}-%{release}
+Supplements:pcp
 
 %description pmda-lustrecomm
 This package contains the PCP Performance Metrics Domain Agent (PMDA) for
@@ -1137,6 +1157,7 @@
 Group:  %{pcp_gr}
 Url:http://www.pcp.io
 Requires:   perl-PCP-PMDA = %{version}-%{release}
+Supplements:pcp
 
 %description pmda-memcache
 This package contains the PCP Performance Metrics Domain Agent (PMDA) for
@@ -1156,6 +1177,7 @@
 Requires:   perl(DBI)
 BuildRequires:  perl(DBD::mysql)
 BuildRequires:  perl(DBI)
+Supplements:pcp
 
 %description pmda-mysql
 This package contains the PCP Performance Metrics Domain Agent (PMDA) for
@@ -1171,6 +1193,7 @@
 Group:  %{pcp_gr}
 Url:http://www.pcp.io
 Requires:   perl-PCP-PMDA = %{version}-%{release}
+Supplements:pcp
 
 %description pmda-named
 This package contains the PCP Performance Metrics Domain Agent (PMDA) for
@@ -1185,6 +1208,7 @@
 Group:  %{pcp_gr}
 Url:http://www.pcp.io
 Requires:   

commit akonadi-server for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package akonadi-server for openSUSE:Factory 
checked in at 2017-09-04 12:27:50

Comparing /work/SRC/openSUSE:Factory/akonadi-server (Old)
 and  /work/SRC/openSUSE:Factory/.akonadi-server.new (New)


Package is "akonadi-server"

Mon Sep  4 12:27:50 2017 rev:33 rq:519895 version:17.08.0

Changes:

--- /work/SRC/openSUSE:Factory/akonadi-server/akonadi-server.changes
2017-08-24 17:41:48.325941353 +0200
+++ /work/SRC/openSUSE:Factory/.akonadi-server.new/akonadi-server.changes   
2017-09-04 12:27:52.850727487 +0200
@@ -1,0 +2,13 @@
+Thu Aug 31 10:02:46 UTC 2017 - lbeltr...@kde.org
+
+- Add upstream consider-collections-that-not-match-mimetype.patch:
+  * Fixes Korganizer reminders not showing up
+
+---
+Sat Aug 26 10:25:05 UTC 2017 - wba...@tmo.at
+
+- Add Fix-SQLite-DB-schema-upgrade.patch to fix Akonadi not
+  starting when the sqlite plugin is used because the database
+  schema upgrade fails due to unsupported syntax (kde#384024)
+
+---

New:

  Fix-SQLite-DB-schema-upgrade.patch
  consider-collections-that-not-match-mimetype.patch



Other differences:
--
++ akonadi-server.spec ++
--- /var/tmp/diff_new_pack.hPX2Oz/_old  2017-09-04 12:27:53.806593097 +0200
+++ /var/tmp/diff_new_pack.hPX2Oz/_new  2017-09-04 12:27:53.814591972 +0200
@@ -31,6 +31,10 @@
 Url:http://akonadi-project.org
 Source: %{rname}-%{version}.tar.xz
 Source99:   akonadi-server-rpmlintrc
+# PATCH-FIX-UPSTREAM
+Patch0: Fix-SQLite-DB-schema-upgrade.patch
+# PATCH-FIX-UPSTREAM
+Patch1: consider-collections-that-not-match-mimetype.patch
 %if 0%{?suse_version} > 1325
 BuildRequires:  libboost_headers-devel
 %else
@@ -172,6 +176,8 @@
 
 %prep
 %setup -q -n %{rname}-%{version}
+%patch0 -p1
+%patch1 -p1
 
 %build
   %cmake_kf5 -d build -- -DINSTALL_QSQLITE_IN_QT_PREFIX=TRUE 
-DQT_PLUGINS_DIR=%{_kf5_plugindir}

++ Fix-SQLite-DB-schema-upgrade.patch ++
>From 2fcd7c4c4f6cc512de9d7778ab67d637934e7638 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= 
Date: Sat, 26 Aug 2017 12:03:40 +0200
Subject: Fix SQLite DB schema upgrade to version 35

SQLite does not support DROP COLUMN and our upgrade language is not
expressive enough to handle that in another way, so for now we just
leave the 'external' column in PartTable on SQLite, it will simply
be ignored. On other backends the column is removed as expected.

BUG: 384024
FIXED-IN: 5.6.1
---
 src/server/storage/dbupdate.xml | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/src/server/storage/dbupdate.xml b/src/server/storage/dbupdate.xml
index 80fb9d7..c5f9777 100644
--- a/src/server/storage/dbupdate.xml
+++ b/src/server/storage/dbupdate.xml
@@ -323,7 +323,8 @@
 
   
 UPDATE PartTable SET storage = 
external;
-ALTER TABLE PartTable DROP COLUMN 
external;
+ALTER TABLE PartTable DROP COLUMN 
external;
+
 UPDATE PartTable SET storage = cast(external as 
integer);
 ALTER TABLE PartTable DROP COLUMN 
external;
   
-- 
cgit v0.11.2

++ consider-collections-that-not-match-mimetype.patch ++
>From d3c6ba904798768b0c83c2e182c27b1c624f78ca Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= 
Date: Tue, 15 Aug 2017 12:16:48 +0200
Subject: ETM: consider collections that don't match mimetype filter populated

After commit 0741892fe the ETM only runs ItemFetchJob for collections
that match the current mimetype filter. This caused collections that
don't match the filter (like top-level collections) to never be marked
as populated, breaking applications like korgac that check the
IsPopulatedRole of all collections in the tree.
---
 src/core/models/entitytreemodel_p.cpp | 7 +++
 1 file changed, 7 insertions(+)

diff --git a/src/core/models/entitytreemodel_p.cpp 
b/src/core/models/entitytreemodel_p.cpp
index 94c080b..879ba57 100644
--- a/src/core/models/entitytreemodel_p.cpp
+++ b/src/core/models/entitytreemodel_p.cpp
@@ -473,6 +473,13 @@ void EntityTreeModelPrivate::collectionsFetched(const 
Akonadi::Collection::List
 const auto col = m_collections.value(collectionId);
 if (m_mimeChecker.wantedMimeTypes().isEmpty() || 
m_mimeChecker.isWantedCollection(col)) {
 fetchItems(m_collections.value(collectionId));
+} else {
+// Consider collections that don't contain relevant 
mimetypes to be populated
+m_populatedCols.insert(collectionId);
+Q_EMIT q_ptr->collectionPopulated(collectionId);
+

commit seahorse-nautilus for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package seahorse-nautilus for 
openSUSE:Factory checked in at 2017-09-04 12:27:22

Comparing /work/SRC/openSUSE:Factory/seahorse-nautilus (Old)
 and  /work/SRC/openSUSE:Factory/.seahorse-nautilus.new (New)


Package is "seahorse-nautilus"

Mon Sep  4 12:27:22 2017 rev:17 rq:519631 version:3.11.92

Changes:

--- /work/SRC/openSUSE:Factory/seahorse-nautilus/seahorse-nautilus.changes  
2016-02-23 16:53:47.0 +0100
+++ /work/SRC/openSUSE:Factory/.seahorse-nautilus.new/seahorse-nautilus.changes 
2017-09-04 12:27:24.298741745 +0200
@@ -1,0 +2,5 @@
+Tue Aug 29 11:33:06 UTC 2017 - dims...@opensuse.org
+
+- Add 2.2 to the list of accepted GPG versions.
+
+---



Other differences:
--
++ seahorse-nautilus.spec ++
--- /var/tmp/diff_new_pack.FEKCW2/_old  2017-09-04 12:27:25.070633222 +0200
+++ /var/tmp/diff_new_pack.FEKCW2/_new  2017-09-04 12:27:25.090630410 +0200
@@ -58,7 +58,7 @@
 %lang_package
 %prep
 %setup -q
-sed -i "s:1.2 1.4 2.0:1.2 1.4 2.0 2.1:" configure
+sed -i "s:1.2 1.4 2.0:1.2 1.4 2.0 2.1 2.2:" configure
 
 %build
 %configure




commit resource-agents for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package resource-agents for openSUSE:Factory 
checked in at 2017-09-04 12:27:56

Comparing /work/SRC/openSUSE:Factory/resource-agents (Old)
 and  /work/SRC/openSUSE:Factory/.resource-agents.new (New)


Package is "resource-agents"

Mon Sep  4 12:27:56 2017 rev:76 rq:520014 version:4.0.1+git.1504207605.22ac330c

Changes:

--- /work/SRC/openSUSE:Factory/resource-agents/resource-agents.changes  
2017-08-12 19:59:53.845568887 +0200
+++ /work/SRC/openSUSE:Factory/.resource-agents.new/resource-agents.changes 
2017-09-04 12:27:57.742039793 +0200
@@ -1,0 +2,60 @@
+Thu Aug 31 19:31:11 UTC 2017 - kgronl...@suse.com
+
+- Update to version 4.0.1+git.1504207605.22ac330c: (bsc#1053207)
+  * galera: Honor "safe_to_bootstrap" flag in grastate.dat (bsc#1055017)
+  * galera: Fix instance name in master_exists() (bsc#1056635)
+
+---
+Thu Aug 31 09:06:09 UTC 2017 - kgronl...@suse.com
+
+- Update to version 4.0.1+git.1504170332.70fbcd8a:
+  * Medium: ocf-shellfuncs: improve locking (ocf_take_lock)
+  * Low: ocf-shellfuncs: Avoid printing empty INFO messages (bsc#1053621)
+  * Low: SAPInstance: Mention monitor support in documentation (bsc#1051913)
+  * High: lvmlockd: add resource agent for lvmlockd daemon (fate#323822)
+  * High: rkt: Add agent for managing rkt containers
+  * Medium: varnish: Compatibility for version 4.0
+
+---
+Mon Aug 28 08:07:15 UTC 2017 - kgronl...@suse.com
+
+- Update to version 4.0.1+git.1503904762.b4582bdb:
+  * Low: mysql: Fixed bug where crm_admin is never called, leaving master 
scores to -1 in certain conditions.
+  * Low: exportfs: check fsid parameter for not containing a comma
+  * Low: mysql: don't run ocf_is_ms check in a subshell
+  * Low: redis: add check for redis-check-rdb
+  * Low: redis: wait for pid file to appear after start
+  * High: pgsql: Allow dynamic membership
+  * Medium: CTDB: fix issue with --logfile being replace with --logging
+  * Medium: oraasm: new resource agent for Oracle ASM Disk Groups
+  * Medium: rabbitmq-cluster: Backup and restore policies
+  * Low: Raid1: Clean up spelling and whitespace
+  * Medium: LVM: use vgscan --cache to update metadata during start/relocate
+  * Medium: LVM: warn when cache mode is not writethrough
+  * Medium: iSCSILogicalUnit: add emulate parameters
+  * Medium: mysql: Properly Detect read_only State
+  * Medium: anything: Allow multiple instances of binfiles to be run (pidfile 
will be unique)
+  * Medium: anything: Start should return OCF_RUNNING if monitor succeeds
+  * Medium: anything: Attempt to fix missing PID directory before starting
+  * Medium: kamailio fixes and enhancements for v5.0
+  * Low: portblock: dont log dd "0+0 records in/out"
+  * Medium: Raid1: Handle case when mddev is a symlink
+  * Low: sg_persist: Read empty value when when no attribute exists 
(bsc#1048288)
+  * Medium: VirtualDomain: new attributes migrateuri, remoteuri, migration_user
+  * Low: sapdb: Add hdbnameserver to monitor services
+  * High: CTDB: Don't fail on empty directory (bsc#1052577)
+  * High: minio: Resource agent for the minio storage server
+  * High: ZFS: Add ZFS Resource Agent
+  * High: awseip/awsvip: fixes and improvements
+  * Medium: VirtualDomain: new configuration option shutdown_mode
+  * Medium: Route: Resource key for the address family (ip4, ip6 or detect)
+  * Low: aws-vpc-route53: Fix missing ocf_log in log message
+
+- Remove patches merged upstream:
+  * Remove 0005-Medium-CTDB-Use-logging-syntax-for-ctdbd-bsc-981863.patch
+  * Remove 0008-Low-sg_persist-Read-empty-value-when-when-no-attribu.patch
+  * Remove 0010-High-CTDB-Don-t-fail-on-empty-directory-bsc-1052577.patch
+  * Remove 0009-High-aws-vpc-route53-Add-agent-for-AWS-Route-53-fate.patch
+  * Remove 0007-Medium-Raid1-Handle-case-when-mddev-is-a-symlink.patch
+
+---

Old:

  0005-Medium-CTDB-Use-logging-syntax-for-ctdbd-bsc-981863.patch
  0007-Medium-Raid1-Handle-case-when-mddev-is-a-symlink.patch
  0008-Low-sg_persist-Read-empty-value-when-when-no-attribu.patch
  0009-High-aws-vpc-route53-Add-agent-for-AWS-Route-53-fate.patch
  0010-High-CTDB-Don-t-fail-on-empty-directory-bsc-1052577.patch
  resource-agents-4.0.1+git.1495055229.643177f1.tar.xz

New:

  resource-agents-4.0.1+git.1504207605.22ac330c.tar.xz



Other differences:
--
++ resource-agents.spec ++
--- /var/tmp/diff_new_pack.0ZiapG/_old  2017-09-04 12:27:58.765895843 +0200
+++ /var/tmp/diff_new_pack.0ZiapG/_new  2017-09-04 12:27:58.797891345 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   resource-agents

commit libcryptui for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package libcryptui for openSUSE:Factory 
checked in at 2017-09-04 12:27:26

Comparing /work/SRC/openSUSE:Factory/libcryptui (Old)
 and  /work/SRC/openSUSE:Factory/.libcryptui.new (New)


Package is "libcryptui"

Mon Sep  4 12:27:26 2017 rev:21 rq:519681 version:3.12.2

Changes:

--- /work/SRC/openSUSE:Factory/libcryptui/libcryptui.changes2014-12-17 
19:18:51.0 +0100
+++ /work/SRC/openSUSE:Factory/.libcryptui.new/libcryptui.changes   
2017-09-04 12:27:27.698263792 +0200
@@ -1,0 +2,5 @@
+Wed Aug 30 12:24:52 UTC 2017 - dims...@opensuse.org
+
+- Add 2.2 to the list of accepted GPG versions.
+
+---



Other differences:
--
++ libcryptui.spec ++
--- /var/tmp/diff_new_pack.lWAR8E/_old  2017-09-04 12:27:29.510009070 +0200
+++ /var/tmp/diff_new_pack.lWAR8E/_new  2017-09-04 12:27:29.522007384 +0200
@@ -102,7 +102,7 @@
 %lang_package
 %prep
 %setup -q
-sed -i "s:1.2 1.4 2.0:1.2 1.4 2.0 2.1:" configure
+sed -i "s:1.2 1.4 2.0:1.2 1.4 2.0 2.1 2.2:" configure
 translation-update-upstream
 
 %build




commit Mesa for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package Mesa for openSUSE:Factory checked in 
at 2017-09-04 12:27:08

Comparing /work/SRC/openSUSE:Factory/Mesa (Old)
 and  /work/SRC/openSUSE:Factory/.Mesa.new (New)


Package is "Mesa"

Mon Sep  4 12:27:08 2017 rev:300 rq:519329 version:unknown

Changes:

--- /work/SRC/openSUSE:Factory/Mesa/Mesa.changes2017-08-24 
18:18:13.350242203 +0200
+++ /work/SRC/openSUSE:Factory/.Mesa.new/Mesa.changes   2017-09-04 
12:27:09.360841927 +0200
@@ -1,0 +2,22 @@
+Mon Aug 28 14:17:25 UTC 2017 - mimi...@gmail.com
+
+- update to 17.1.8 
+ * fdo#101334 - AMD SI cards: Some vulkan apps freeze the system
+ * fdo#101766 - Assertion `!invalid type' failed when constant
+expression involves literal of different type<
+ * fdo#102024 - FORMAT_FEATURE_SAMPLED_IMAGE_BIT not supported for D16_UNORM
+and D32_SFLOAT
+ * fdo#102148 - Crash when running qopenglwidget example on mesa llvmpipe win32
+ * fdo#102241 - gallium/wgl: SwapBuffers freezing regularly with swap
+interval enabled
+ * fdo#101910 - [BYT]
+
ES31-CTS.functional.copy_image.non_compressed.viewclass_96_bits.rgb32f_rgb32f
+  * fdo#102308 - segfault in glCompressedTextureSubImage3D
+
+---
+Mon Aug 28 12:53:03 UTC 2017 - fv...@suse.com
+
+- Add patch to fix strtod on non-EN locale (boo#1055929):
+  * n_force-xlocale-funcs.patch
+
+---

Old:

  mesa-17.1.6.tar.xz
  mesa-17.1.6.tar.xz.sig

New:

  mesa-17.1.8.tar.xz
  mesa-17.1.8.tar.xz.sig
  n_force-xlocale-funcs.patch



Other differences:
--
++ Mesa.spec ++
--- /var/tmp/diff_new_pack.W5IUhB/_old  2017-09-04 12:27:11.520538287 +0200
+++ /var/tmp/diff_new_pack.W5IUhB/_new  2017-09-04 12:27:11.524537725 +0200
@@ -22,7 +22,7 @@
 %endif
 %define glamor 1
 %define _name_archive mesa
-%define _version 17.1.6
+%define _version 17.1.8
 %define with_opencl 0
 %define with_vulkan 0
 %ifarch %ix86 x86_64 %arm aarch64 ppc ppc64 ppc64le s390x
@@ -81,6 +81,8 @@
 Patch18:n_VDPAU-XVMC-libs-Replace-hardlinks-with-copies.patch
 # never to be upstreamed
 Patch21:n_Define-GLAPIVAR-separate-from-GLAPI.patch
+# never to be upstreamed
+Patch22:n_force-xlocale-funcs.patch
 # currently needed for libglvnd support
 Patch31:archlinux_0001-Fix-linkage-against-shared-glapi.patch
 Patch32:archlinux_glvnd-fix-gl-dot-pc.patch
@@ -652,6 +654,7 @@
 %patch12 -p1
 %patch18 -p1
 %patch21 -p1
+%patch22 -p1
 
 %if 0%{?libglvnd}
 %patch31 -p1


++ mesa-17.1.6.tar.xz -> mesa-17.1.8.tar.xz ++
/work/SRC/openSUSE:Factory/Mesa/mesa-17.1.6.tar.xz 
/work/SRC/openSUSE:Factory/.Mesa.new/mesa-17.1.8.tar.xz differ: char 25, line 1

++ n_force-xlocale-funcs.patch ++
From: Fabian Vogt 
Subject: Force use of strtod_l and friends
Patch-mainline: never
References: boo#1055929

With glibc 2.26, xlocale.h got removed, but the used functions
are available as part of local.h since POSIX2008, so use them
unconditionally.
This is necessary to fix strod with non-EN locales.

Index: mesa-17.1.6/src/util/strtod.c
===
--- mesa-17.1.6.orig/src/util/strtod.c
+++ mesa-17.1.6/src/util/strtod.c
@@ -28,11 +28,9 @@
 
 #ifdef _GNU_SOURCE
 #include 
-#ifdef HAVE_XLOCALE_H
-#include 
+#define HAVE_XLOCALE_H
 static locale_t loc;
 #endif
-#endif
 
 #include "strtod.h"
 



commit discover for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package discover for openSUSE:Factory 
checked in at 2017-09-04 12:27:15

Comparing /work/SRC/openSUSE:Factory/discover (Old)
 and  /work/SRC/openSUSE:Factory/.discover.new (New)


Package is "discover"

Mon Sep  4 12:27:15 2017 rev:24 rq:519502 version:5.10.5

Changes:

--- /work/SRC/openSUSE:Factory/discover/discover.changes2017-07-25 
11:36:14.967477845 +0200
+++ /work/SRC/openSUSE:Factory/.discover.new/discover.changes   2017-09-04 
12:27:17.119751070 +0200
@@ -1,0 +2,27 @@
+Mon Aug 28 15:25:02 UTC 2017 - fab...@ritter-vogt.de
+
+- Adjust License tag
+
+---
+Tue Aug 22 19:11:30 CEST 2017 - fab...@ritter-vogt.de
+
+- Update to 5.10.5
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.10.5.php
+- Changes since 5.10.4:
+  * auto generate desktop file for url handling
+  * Revert "auto generate desktop file for url handling"
+  * auto generate desktop file for url handling
+  * Remove the navigationEnabled concept (kde#383294)
+  * Fix license, comply with our naming scheme
+  * Don't disable the updates action when there are no updates (kde#383294)
+  * Some elements aren't reporting a big preview
+  * Fallback to the package icon if there isn't a stock icon as well
+  * Prevent memory leak
+  * Make sure we don't crash when opening flatpakrepo files
+  * Make it possible to prevent some resources from being Reviewed
+  * Don't show the version if there's none on the ApplicationPage (kde#383036)
+  * Make sure we don't render HTML on the Discover page header
+
+---

Old:

  discover-5.10.4.tar.xz

New:

  discover-5.10.5.tar.xz



Other differences:
--
++ discover.spec ++
--- /var/tmp/diff_new_pack.9BrYZS/_old  2017-09-04 12:27:18.295585755 +0200
+++ /var/tmp/diff_new_pack.9BrYZS/_new  2017-09-04 12:27:18.299585192 +0200
@@ -18,10 +18,10 @@
 
 %bcond_without lang
 Name:   discover
-Version:5.10.4
+Version:5.10.5
 Release:0
 Summary:KDE Software Installer
-License:GPL-2.0
+License:GPL-2.0 AND GPL-3.0 AND GPL-3.0+
 Group:  System/GUI/KDE
 Url:https://quickgit.kde.org/?p=discover.git
 Source: 
http://download.kde.org/stable/plasma/%{version}/discover-%{version}.tar.xz
@@ -46,6 +46,7 @@
 BuildRequires:  cmake(KF5Notifications)
 BuildRequires:  cmake(KF5Plasma)
 BuildRequires:  cmake(KF5TextWidgets)
+BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  cmake(Qca-qt5)
 BuildRequires:  cmake(Qt5Concurrent)
 BuildRequires:  cmake(Qt5DBus)
@@ -113,6 +114,7 @@
 %{_kf5_plugindir}/discover/
 %{_kf5_qmldir}/
 %{_kf5_applicationsdir}/org.kde.discover.desktop
+%{_kf5_applicationsdir}/org.kde.discover.urlhandler.desktop
 %{_kf5_iconsdir}/hicolor/*/apps/plasmadiscover.*
 %{_kf5_notifydir}/discoverabstractnotifier.notifyrc
 %{_kf5_kxmlguidir}/plasmadiscover/

++ discover-5.10.4.tar.xz -> discover-5.10.5.tar.xz ++
/work/SRC/openSUSE:Factory/discover/discover-5.10.4.tar.xz 
/work/SRC/openSUSE:Factory/.discover.new/discover-5.10.5.tar.xz differ: char 
25, line 1




commit gpg2 for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package gpg2 for openSUSE:Factory checked in 
at 2017-09-04 12:26:32

Comparing /work/SRC/openSUSE:Factory/gpg2 (Old)
 and  /work/SRC/openSUSE:Factory/.gpg2.new (New)


Package is "gpg2"

Mon Sep  4 12:26:32 2017 rev:119 rq:519193 version:2.2.0

Changes:

--- /work/SRC/openSUSE:Factory/gpg2/gpg2.changes2017-08-04 
11:56:54.336583235 +0200
+++ /work/SRC/openSUSE:Factory/.gpg2.new/gpg2.changes   2017-09-04 
12:26:34.789702409 +0200
@@ -1,0 +2,34 @@
+Mon Aug 28 17:21:30 UTC 2017 - astie...@suse.com
+
+- GnuPG 2.2.0:
+  * New long term stable branch, replacing the 2.0.x series
+  * gpg: Reverted change in 2.1.23 so that --no-auto-key-retrieve
+is again the default boo#1054088
+  * Fixed a few minor bugs
+
+---
+Sat Aug 12 16:56:26 UTC 2017 - astie...@suse.com
+
+- GnuPG 2.1.23:
+  * gpg: Options --auto-key-retrieve and --auto-key-locate "local,wkd"
+are now used by default.  Note: this enables keyserver and Web Key
+Directory operators to notice when a signature from a locally
+non-available key is being verified for the first time or when
+you intend to encrypt to a mail address without having the key
+locally.  This new behaviour will eventually make key discovery
+much easier and mostly automatic.  Disable this by adding
+  no-auto-key-retrieve
+  auto-key-locate local
+to your gpg.conf.
+  * agent: Option --no-grab is now the default.  The new option --grab
+allows to revert this.
+  * gpg: New import option "show-only".
+  * gpg: New option --disable-dirmngr to entirely disable network
+access for gpg.
+  * gpg,gpgsm: Tweaked DE-VS compliance behaviour.
+  * New configure flag --enable-all-tests to run more extensive tests
+during "make check".
+  * gpgsm: The keygrip is now always printed in colon mode as
+documented in the man page.
+
+---

Old:

  gnupg-2.1.22.tar.bz2
  gnupg-2.1.22.tar.bz2.sig

New:

  gnupg-2.2.0.tar.bz2
  gnupg-2.2.0.tar.bz2.sig



Other differences:
--
++ gpg2.spec ++
--- /var/tmp/diff_new_pack.EkfFsC/_old  2017-09-04 12:26:36.277493237 +0200
+++ /var/tmp/diff_new_pack.EkfFsC/_new  2017-09-04 12:26:36.281492673 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gpg2
-Version:2.1.22
+Version:2.2.0
 Release:0
 Summary:File encryption, decryption, signature creation and 
verification utility
 License:GPL-3.0+
@@ -103,8 +103,9 @@
 --enable-large-secmem \
 --enable-wks-tools \
 --with-gnu-ld \
---with-default-trust-store=%{_sysconfdir}/ssl/ca-bundle.pem \
+--with-default-trust-store-file=%{_sysconfdir}/ssl/ca-bundle.pem \
 --enable-build-timestamp=$date \
+--enable-gpg-is-gpg2 \
 
 make %{?_smp_mflags}
 

++ gnupg-2.0.18-files-are-digests.patch ++
--- /var/tmp/diff_new_pack.EkfFsC/_old  2017-09-04 12:26:36.325486488 +0200
+++ /var/tmp/diff_new_pack.EkfFsC/_new  2017-09-04 12:26:36.329485926 +0200
@@ -4,11 +4,11 @@
  g10/sign.c|   68 
--
  3 files changed, 67 insertions(+), 6 deletions(-)
 
-Index: gnupg-2.1.22/g10/gpg.c
+Index: gnupg-2.1.23/g10/gpg.c
 ===
 gnupg-2.1.22.orig/g10/gpg.c
-+++ gnupg-2.1.22/g10/gpg.c
-@@ -379,6 +379,7 @@ enum cmd_and_opt_values
+--- gnupg-2.1.23.orig/g10/gpg.c2017-08-09 15:46:17.0 +0200
 gnupg-2.1.23/g10/gpg.c 2017-08-10 16:21:26.692847431 +0200
+@@ -380,6 +380,7 @@ enum cmd_and_opt_values
  oTTYtype,
  oLCctype,
  oLCmessages,
@@ -16,7 +16,7 @@
  oXauthority,
  oGroup,
  oUnGroup,
-@@ -828,6 +829,7 @@ static ARGPARSE_OPTS opts[] = {
+@@ -829,6 +830,7 @@ static ARGPARSE_OPTS opts[] = {
ARGPARSE_s_s (oWeakDigest, "weak-digest","@"),
ARGPARSE_s_n (oUnwrap, "unwrap", "@"),
ARGPARSE_s_n (oOnlySignTextIDs, "only-sign-text-ids", "@"),
@@ -24,15 +24,15 @@
  
/* Aliases.  I constantly mistype these, and assume other people do
   as well. */
-@@ -2383,6 +2385,7 @@ main (int argc, char **argv)
+@@ -2388,6 +2390,7 @@ main (int argc, char **argv)
  opt.def_cert_expire = "0";
  gnupg_set_homedir (NULL);
  opt.passphrase_repeat = 1;
 +opt.files_are_digests=0;
  opt.emit_version = 0;
  opt.weak_digests = NULL;
- additional_weak_digest("MD5");
-@@ -2944,6 +2947,7 @@ main (int argc, char **argv)
+ 
+@@ -2952,6 +2955,7 @@ main (int argc, char **argv)
opt.verify_options&=~VERIFY_SHOW_PHOTOS;
break;
  case oPhotoViewer: opt.photo_viewer = pargs.r.ret_str; break;

commit libksi for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package libksi for openSUSE:Factory checked 
in at 2017-09-04 12:26:43

Comparing /work/SRC/openSUSE:Factory/libksi (Old)
 and  /work/SRC/openSUSE:Factory/.libksi.new (New)


Package is "libksi"

Mon Sep  4 12:26:43 2017 rev:4 rq:519202 version:3.4.0.5

Changes:

--- /work/SRC/openSUSE:Factory/libksi/libksi.changes2017-02-20 
14:27:52.329122260 +0100
+++ /work/SRC/openSUSE:Factory/.libksi.new/libksi.changes   2017-09-04 
12:26:44.488338846 +0200
@@ -1,0 +2,6 @@
+Tue Aug 22 10:58:00 UTC 2017 - pmonrealgonza...@suse.com
+
+- Fixed errors when building with openssl-1.1.0 [bsc#1042656]
+  * Added patch libksi-build-with-openssl-1.1.0.patch
+
+---

New:

  libksi-build-with-openssl-1.1.0.patch



Other differences:
--
++ libksi.spec ++
--- /var/tmp/diff_new_pack.p3xGFf/_old  2017-09-04 12:26:45.292225824 +0200
+++ /var/tmp/diff_new_pack.p3xGFf/_new  2017-09-04 12:26:45.300224700 +0200
@@ -27,6 +27,8 @@
 # https://github.com/rsyslog/libksi
 # extracted from 
http://rpms.adiscon.com/v8-stable/epel-7/x86_64/RPMS/libksi1-3.4.0.5-2.el7.src.rpm
 Source0:%{name}-%{version}.tar.gz
+# PATCH-FIX-OPENSUSE bsc#1042656 -- Fix errors building with openssl-1.1.0
+Patch0: libksi-build-with-openssl-1.1.0.patch
 BuildRequires:  curl-devel
 BuildRequires:  openssl-devel
 BuildRequires:  pkg-config
@@ -54,6 +56,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure \

++ libksi-build-with-openssl-1.1.0.patch ++
Index: libksi-3.4.0.5/src/ksi/hash_openssl.c
===
--- libksi-3.4.0.5.orig/src/ksi/hash_openssl.c
+++ libksi-3.4.0.5/src/ksi/hash_openssl.c
@@ -102,7 +102,9 @@ int KSI_isHashAlgorithmSupported(KSI_Has
 
 void KSI_DataHasher_free(KSI_DataHasher *hasher) {
if (hasher != NULL) {
-   KSI_free(hasher->hashContext);
+   if (hasher->hashContext != NULL) {
+   EVP_MD_CTX_destroy(hasher->hashContext);
+   }
KSI_free(hasher);
}
 }
@@ -171,7 +173,7 @@ int KSI_DataHasher_reset(KSI_DataHasher
 
context = hasher->hashContext;
if (context == NULL) {
-   context = KSI_new(EVP_MD_CTX);
+   context = EVP_MD_CTX_create();
if (context == NULL) {
KSI_pushError(hasher->ctx, res = KSI_OUT_OF_MEMORY, 
NULL);
goto cleanup;
@@ -179,7 +181,7 @@ int KSI_DataHasher_reset(KSI_DataHasher
 
hasher->hashContext = context;
} else {
-   EVP_MD_CTX_cleanup(context);
+   EVP_MD_CTX_destroy(context);
}
 
if (!EVP_DigestInit(context, evp_md)) {
Index: libksi-3.4.0.5/src/ksi/pkitruststore_openssl.c
===
--- libksi-3.4.0.5.orig/src/ksi/pkitruststore_openssl.c
+++ libksi-3.4.0.5/src/ksi/pkitruststore_openssl.c
@@ -907,13 +907,13 @@ cleanup:
 int KSI_PKITruststore_verifyRawSignature(KSI_CTX *ctx, const unsigned char 
*data, size_t data_len, const char *algoOid, const unsigned char *signature, 
size_t signature_len, const KSI_PKICertificate *certificate) {
int res;
ASN1_OBJECT* algorithm = NULL;
-EVP_MD_CTX md_ctx;
+EVP_MD_CTX *md_ctx;
 X509 *x509 = NULL;
const EVP_MD *evp_md;
EVP_PKEY *pubKey = NULL;
 
/* Needs to be initialized before jumping to cleanup. */
-EVP_MD_CTX_init(_ctx);
+   md_ctx = EVP_MD_CTX_create();
 
KSI_ERR_clearErrors(ctx);
 
@@ -956,17 +956,17 @@ int KSI_PKITruststore_verifyRawSignature
goto cleanup;
}
 
-if (!EVP_VerifyInit(_ctx, evp_md)) {
+if (!EVP_VerifyInit(md_ctx, evp_md)) {
KSI_pushError(ctx, res = KSI_CRYPTO_FAILURE, NULL);
goto cleanup;
 }
 
-if (!EVP_VerifyUpdate(_ctx, (unsigned char *)data, data_len)) {
+if (!EVP_VerifyUpdate(md_ctx, (unsigned char *)data, data_len)) {
KSI_pushError(ctx, res = KSI_CRYPTO_FAILURE, NULL);
goto cleanup;
 }
 
-res = EVP_VerifyFinal(_ctx, (unsigned char *)signature, 
(unsigned)signature_len, pubKey);
+res = EVP_VerifyFinal(md_ctx, (unsigned char *)signature, 
(unsigned)signature_len, pubKey);
 if (res < 0) {
KSI_pushError(ctx, res = KSI_CRYPTO_FAILURE, NULL);
goto cleanup;
@@ -982,7 +982,7 @@ int KSI_PKITruststore_verifyRawSignature
 
 cleanup:
 
-   EVP_MD_CTX_cleanup(_ctx);
+   EVP_MD_CTX_destroy(md_ctx);
if (algorithm != NULL) ASN1_OBJECT_free(algorithm);
if (pubKey != NULL) EVP_PKEY_free(pubKey);
 



commit spice-gtk for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package spice-gtk for openSUSE:Factory 
checked in at 2017-09-04 12:26:52

Comparing /work/SRC/openSUSE:Factory/spice-gtk (Old)
 and  /work/SRC/openSUSE:Factory/.spice-gtk.new (New)


Package is "spice-gtk"

Mon Sep  4 12:26:52 2017 rev:35 rq:519322 version:0.34

Changes:

--- /work/SRC/openSUSE:Factory/spice-gtk/spice-gtk.changes  2017-03-03 
17:32:31.322980715 +0100
+++ /work/SRC/openSUSE:Factory/.spice-gtk.new/spice-gtk.changes 2017-09-04 
12:26:54.138982028 +0200
@@ -1,0 +2,32 @@
+Mon Aug 28 09:02:32 UTC 2017 - cbosdon...@suse.com
+
+- Update to version 0.34 (bsc#1055295):
+  + NOTE: this is the last release with the spice-controller library
+  + add VP9 codec support
+  + API: add spice_display_change_preferred_video_codec_type()
+  + API: add new SpiceCursorChannel:cursor property, deprecate "cursor-set" 
signal
+  + API: spice_audio_new() is no longer in public header
+  + fix clipboard crash and other regressions from 0.33
+  + report invalid or stopped streams to the server
+  + use playbin instead of decodebin with gstreamer > 1.9
+  + support GST_DEBUG_BIN_TO_DOT_FILE debug
+  + deprecate a few esoteric options from --spice group:
+--spice-color-depth, --spice-cache-size, --spice-glz-window-size used
+mainly for development. They may be available with spicy in the future.
+  + win32: handle failures when starting win-usb manager
+  + win32: removed windows usb-clerk support, replaced by UsbDk
+  + win32: fix alt-tab & grab issues
+  + spicy learned to tweak codec preference, cancel transfer, and resize
+precisely for debugging purposes
+  + use keycodemapdb submodule, drop perl(Text::CSV) dependency
+  + file-xfer: fix bad filename encoding
+  + file-xfer: handle new error kind
+  + build-sys fixes for macos
+  + replace some deprecated gtk code
+  + memory leak fixes, new tests
+- Drop now useless patches:
+  + 48da2c66-fix-lz4-deps.patch
+  + spice-gtk-remove-pygtk-bindings-leftovers.patch
+
+
+---

Old:

  48da2c66-fix-lz4-deps.patch
  spice-gtk-0.33.tar.bz2
  spice-gtk-remove-pygtk-bindings-leftovers.patch

New:

  spice-gtk-0.34.tar.bz2



Other differences:
--
++ spice-gtk.spec ++
--- /var/tmp/diff_new_pack.4GsjGf/_old  2017-09-04 12:26:54.714901057 +0200
+++ /var/tmp/diff_new_pack.4GsjGf/_new  2017-09-04 12:26:54.714901057 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   spice-gtk
-Version:0.33
+Version:0.34
 Release:0
 # FIXME: /usr/bin/spice-client-glib-usb-acl-helper should be installed u+s, 
see bnc#744251.
 # FIXME: Once phodav is packaged and available in openSUSE, enable 
pkgconfig(libphodav-2.0)
@@ -29,10 +29,6 @@
 Source: http://spice-space.org/download/gtk/%{name}-%{version}.tar.bz2
 # PATCH-FIX-OPENSUSE spice-gtk-polkit-privs.patch bnc#804184 
dims...@opensuse.org -- Set the polkit defaults to auth_admin
 Patch0: spice-gtk-polkit-privs.patch
-# PATCH-FIX-UPSTREAM 48da2c66-fix-lz4-deps.patch cbosdon...@suse.com -- better 
lz4 checks
-Patch1: 48da2c66-fix-lz4-deps.patch
-# PATCH-FIX-UPSTREAM spice-gtk-remove-pygtk-bindings-leftovers.patch 
zai...@opensuse.org -- Remove pygtk leftover bindings
-Patch2: spice-gtk-remove-pygtk-bindings-leftovers.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  cyrus-sasl-devel
@@ -74,7 +70,7 @@
 BuildRequires:  pkgconfig(pixman-1) >= 0.17.7
 BuildRequires:  pkgconfig(polkit-gobject-1) >= 0.96
 # spice-protocol is bundled, but we still need the system-wide .pc file for 
the pkgconfig() requires magic
-BuildRequires:  pkgconfig(spice-protocol) >= 0.12.12
+BuildRequires:  pkgconfig(spice-protocol) >= 0.12.13
 BuildRequires:  pkgconfig(usbutils)
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -143,8 +139,6 @@
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
 
 %build
 autoreconf -fi

++ spice-gtk-0.33.tar.bz2 -> spice-gtk-0.34.tar.bz2 ++
 51010 lines of diff (skipped)




commit spice-protocol for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package spice-protocol for openSUSE:Factory 
checked in at 2017-09-04 12:26:24

Comparing /work/SRC/openSUSE:Factory/spice-protocol (Old)
 and  /work/SRC/openSUSE:Factory/.spice-protocol.new (New)


Package is "spice-protocol"

Mon Sep  4 12:26:24 2017 rev:22 rq:519132 version:0.12.13

Changes:

--- /work/SRC/openSUSE:Factory/spice-protocol/spice-protocol.changes
2017-02-14 00:36:24.023890186 +0100
+++ /work/SRC/openSUSE:Factory/.spice-protocol.new/spice-protocol.changes   
2017-09-04 12:26:26.810824184 +0200
@@ -1,0 +2,12 @@
+Mon Aug 28 09:41:14 UTC 2017 - cbosdon...@suse.com
+
+- Update to version 0.12.13:
+  + add DISPLAY_PREFERRED_VIDEO_CODEC_TYPE
+  + add VP9 codec type
+  + add VD_AGENT_CLEAR_CAPABILITY() macro
+  + add VD_AGENT_CAP_FILE_XFER_DISABLED
+  + add VD_AGENT_FILE_XFER_STATUS_NOT_ENOUGH_SPACE
+  + add new file-xfer statuses for detailed error
+  + Change enums.h license to MIT
+
+---

Old:

  spice-protocol-0.12.12.tar.bz2

New:

  spice-protocol-0.12.13.tar.bz2



Other differences:
--
++ spice-protocol.spec ++
--- /var/tmp/diff_new_pack.091o3B/_old  2017-09-04 12:26:27.726695419 +0200
+++ /var/tmp/diff_new_pack.091o3B/_new  2017-09-04 12:26:27.730694857 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   spice-protocol
-Version:0.12.12
+Version:0.12.13
 Release:0
 Url:http://www.spice-space.org/
 Summary:SPICE-protocol definitions

++ spice-protocol-0.12.12.tar.bz2 -> spice-protocol-0.12.13.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/spice-protocol-0.12.12/Makefile.in 
new/spice-protocol-0.12.13/Makefile.in
--- old/spice-protocol-0.12.12/Makefile.in  2016-08-04 13:50:00.0 
+0200
+++ new/spice-protocol-0.12.13/Makefile.in  2017-02-20 10:35:28.0 
+0100
@@ -187,7 +187,7 @@
 DIST_SUBDIRS = $(SUBDIRS)
 am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config.h.in \
$(srcdir)/spice-protocol.pc.in AUTHORS COPYING ChangeLog \
-   INSTALL NEWS README compile depcomp install-sh missing
+   INSTALL NEWS README install-sh missing
 DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
 distdir = $(PACKAGE)-$(VERSION)
 top_distdir = $(distdir)
@@ -573,7 +573,7 @@
  ! -type d ! -perm -444 -exec $(install_sh) -c -m a+r {} {} \; \
|| chmod -R a+r "$(distdir)"
 dist-gzip: distdir
-   tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c 
>$(distdir).tar.gz
+   tardir=$(distdir) && $(am__tar) | eval GZIP= gzip $(GZIP_ENV) -c 
>$(distdir).tar.gz
$(am__post_remove_distdir)
 dist-bzip2: distdir
tardir=$(distdir) && $(am__tar) | BZIP2=$${BZIP2--9} bzip2 -c 
>$(distdir).tar.bz2
@@ -598,7 +598,7 @@
@echo WARNING: "Support for shar distribution archives is" \
   "deprecated." >&2
@echo WARNING: "It will be removed altogether in Automake 2.0" >&2
-   shar $(distdir) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).shar.gz
+   shar $(distdir) | eval GZIP= gzip $(GZIP_ENV) -c >$(distdir).shar.gz
$(am__post_remove_distdir)
 
 dist-zip: distdir
@@ -616,7 +616,7 @@
 distcheck: dist
case '$(DIST_ARCHIVES)' in \
*.tar.gz*) \
- GZIP=$(GZIP_ENV) gzip -dc $(distdir).tar.gz | $(am__untar) ;;\
+ eval GZIP= gzip $(GZIP_ENV) -dc $(distdir).tar.gz | $(am__untar) ;;\
*.tar.bz2*) \
  bzip2 -dc $(distdir).tar.bz2 | $(am__untar) ;;\
*.tar.lz*) \
@@ -626,7 +626,7 @@
*.tar.Z*) \
  uncompress -c $(distdir).tar.Z | $(am__untar) ;;\
*.shar.gz*) \
- GZIP=$(GZIP_ENV) gzip -dc $(distdir).shar.gz | unshar ;;\
+ eval GZIP= gzip $(GZIP_ENV) -dc $(distdir).shar.gz | unshar ;;\
*.zip*) \
  unzip $(distdir).zip ;;\
esac
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/spice-protocol-0.12.12/NEWS 
new/spice-protocol-0.12.13/NEWS
--- old/spice-protocol-0.12.12/NEWS 2016-07-07 15:19:59.0 +0200
+++ new/spice-protocol-0.12.13/NEWS 2017-07-03 13:14:24.0 +0200
@@ -1,3 +1,13 @@
+Major changes in 0.12.13
+
+* add DISPLAY_PREFERRED_VIDEO_CODEC_TYPE
+* add VP9 codec type
+* add VD_AGENT_CLEAR_CAPABILITY() macro
+* add VD_AGENT_CAP_FILE_XFER_DISABLED
+* add VD_AGENT_FILE_XFER_STATUS_NOT_ENOUGH_SPACE
+* add new file-xfer statuses for detailed error
+* Change enums.h license to MIT
+
 Major changes in 0.12.12
 
 * protocol: Add lz4 compression support to the SpiceVMC channel
diff -urN '--exclude=CVS' 

commit libzip for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package libzip for openSUSE:Factory checked 
in at 2017-09-04 12:25:44

Comparing /work/SRC/openSUSE:Factory/libzip (Old)
 and  /work/SRC/openSUSE:Factory/.libzip.new (New)


Package is "libzip"

Mon Sep  4 12:25:44 2017 rev:29 rq:519094 version:1.2.0

Changes:

--- /work/SRC/openSUSE:Factory/libzip/libzip.changes2017-06-30 
18:38:03.366470801 +0200
+++ /work/SRC/openSUSE:Factory/.libzip.new/libzip.changes   2017-09-04 
12:25:48.924150770 +0200
@@ -1,0 +2,7 @@
+Mon Aug 28 10:38:05 UTC 2017 - pgaj...@suse.com
+
+- security update:
+  * CVE-2017-12858 [bsc#1055377]
++ libzip-CVE-2017-12858.patch
+
+---

New:

  libzip-CVE-2017-12858.patch



Other differences:
--
++ libzip.spec ++
--- /var/tmp/diff_new_pack.pVNFpO/_old  2017-09-04 12:25:50.203970837 +0200
+++ /var/tmp/diff_new_pack.pVNFpO/_new  2017-09-04 12:25:50.207970274 +0200
@@ -28,6 +28,7 @@
 Source1:baselibs.conf
 # PATCH-FIX-OPENSUSE: close on exec, upstream is aware, will be probably fixes 
next release
 Patch1: libzip-ocloexec.patch
+Patch2: libzip-CVE-2017-12858.patch
 BuildRequires:  libtool
 BuildRequires:  pkgconfig
 # for tests
@@ -80,6 +81,7 @@
 %prep
 %setup -q
 %patch1 -p1
+%patch2 -p1
 
 %build
 %configure \

++ libzip-CVE-2017-12858.patch ++
--- a/lib/zip_dirent.c
+++ b/lib/zip_dirent.c
@@ -579,9 +579,6 @@ _zip_dirent_read(zip_dirent_t *zde, zip_source_t *src, 
zip_buffer_t *buffer, boo
 }
 
 if (!_zip_dirent_process_winzip_aes(zde, error)) {
-   if (!from_buffer) {
-   _zip_buffer_free(buffer);
-   }
return -1;
 }



commit java-1_7_0-openjdk for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package java-1_7_0-openjdk for 
openSUSE:Factory checked in at 2017-09-04 12:25:08

Comparing /work/SRC/openSUSE:Factory/java-1_7_0-openjdk (Old)
 and  /work/SRC/openSUSE:Factory/.java-1_7_0-openjdk.new (New)


Package is "java-1_7_0-openjdk"

Mon Sep  4 12:25:08 2017 rev:88 rq:518880 version:1.7.0.151

Changes:

--- 
/work/SRC/openSUSE:Factory/java-1_7_0-openjdk/java-1_7_0-openjdk-bootstrap.changes
  2017-08-13 14:53:41.339107681 +0200
+++ 
/work/SRC/openSUSE:Factory/.java-1_7_0-openjdk.new/java-1_7_0-openjdk-bootstrap.changes
 2017-09-04 12:25:10.833505998 +0200
@@ -1,0 +2,7 @@
+Sat Aug 26 10:37:11 UTC 2017 - fst...@suse.com
+
+- Added patch:
+  * fix-aarch64-build.patch
+- Fix build breakage in aarch64 port
+
+---
java-1_7_0-openjdk.changes: same change

New:

  fix-aarch64-build.patch



Other differences:
--
++ java-1_7_0-openjdk-bootstrap.spec ++
--- /var/tmp/diff_new_pack.lgtb3g/_old  2017-09-04 12:25:13.297159629 +0200
+++ /var/tmp/diff_new_pack.lgtb3g/_new  2017-09-04 12:25:13.301159067 +0200
@@ -201,6 +201,7 @@
 # remove unsused definition of min conflicting with macro
 Patch201:   aarch64-remove-unused-code.patch
 Patch202:   no-exec-shield-workaround.patch
+Patch203:   fix-aarch64-build.patch
 #
 # Optional component packages
 #
@@ -632,6 +633,7 @@
 patch -p0 -i %{PATCH200}
 patch -p0 -i %{PATCH201}
 patch -p0 -i %{PATCH202}
+patch -p0 -i %{PATCH203}
 
 %if ! %{with zero}
 patch -p0 -i %{PATCH403}

java-1_7_0-openjdk.spec: same change
++ fix-aarch64-build.patch ++
--- openjdk/hotspot/src/cpu/aarch64/vm/aarch64.ad   Tue Jul 04 21:23:37 
2017 +0100
+++ openjdk/hotspot/src/cpu/aarch64/vm/aarch64.ad   Tue Aug 22 18:17:20 
2017 +0100
@@ -1540,10 +1540,14 @@
   return 0;
 }
 
-bool Matcher::is_short_branch_offset(int rule, int br_size, int offset)
-{
-  Unimplemented();
-  return false;
+// Is this branch offset short enough that a short branch can be used?
+//
+// NOTE: If the platform does not provide any short branch variants, then
+//   this method should return false for offset 0.
+bool Matcher::is_short_branch_offset(int rule, int br_size, int offset) {
+  // The passed offset is relative to address of the branch.
+
+  return (-32768 <= offset && offset < 32768);
 }
 
 const bool Matcher::isSimpleConstant64(jlong value) {
@@ -11153,7 +11157,8 @@
 
 // Test bit and Branch
 
-instruct cmpL_branch_sign(cmpOp cmp, iRegL op1, immL0 op2, label labl, 
rFlagsReg cr) %{
+// Patterns for short (< 32KiB) variants
+instruct cmpL_branch_sign(cmpOp cmp, iRegL op1, immL0 op2, label labl) %{
   match(If cmp (CmpL op1 op2));
   predicate(n->in(1)->as_Bool()->_test._test == BoolTest::lt
 || n->in(1)->as_Bool()->_test._test == BoolTest::ge);
@@ -11163,16 +11168,15 @@
   format %{ "cb$cmp   $op1, $labl # long" %}
   ins_encode %{
 Label* L = $labl$$label;
-Assembler::Condition cond = (Assembler::Condition)$cmp$$cmpcode;
-if (cond == Assembler::LT)
-  __ tbnz($op1$$Register, 63, *L);
-else
-  __ tbz($op1$$Register, 63, *L);
+Assembler::Condition cond =
+  ((Assembler::Condition)$cmp$$cmpcode == Assembler::LT) ? Assembler::NE : 
Assembler::EQ;
+__ tbr(cond, $op1$$Register, 63, *L);
   %}
   ins_pipe(pipe_cmp_branch);
-%}
-
-instruct cmpI_branch_sign(cmpOp cmp, iRegIorL2I op1, immI0 op2, label labl, 
rFlagsReg cr) %{
+  ins_short_branch(1);
+%}
+
+instruct cmpI_branch_sign(cmpOp cmp, iRegIorL2I op1, immI0 op2, label labl) %{
   match(If cmp (CmpI op1 op2));
   predicate(n->in(1)->as_Bool()->_test._test == BoolTest::lt
 || n->in(1)->as_Bool()->_test._test == BoolTest::ge);
@@ -11182,16 +11186,15 @@
   format %{ "cb$cmp   $op1, $labl # int" %}
   ins_encode %{
 Label* L = $labl$$label;
-Assembler::Condition cond = (Assembler::Condition)$cmp$$cmpcode;
-if (cond == Assembler::LT)
-  __ tbnz($op1$$Register, 31, *L);
-else
-  __ tbz($op1$$Register, 31, *L);
+Assembler::Condition cond =
+  ((Assembler::Condition)$cmp$$cmpcode == Assembler::LT) ? Assembler::NE : 
Assembler::EQ;
+__ tbr(cond, $op1$$Register, 31, *L);
   %}
   ins_pipe(pipe_cmp_branch);
-%}
-
-instruct cmpL_branch_bit(cmpOp cmp, iRegL op1, immL op2, immL0 op3, label 
labl, rFlagsReg cr) %{
+  ins_short_branch(1);
+%}
+
+instruct cmpL_branch_bit(cmpOp cmp, iRegL op1, immL op2, immL0 op3, label 
labl) %{
   match(If cmp (CmpL (AndL op1 op2) op3));
   predicate((n->in(1)->as_Bool()->_test._test == BoolTest::ne
 || n->in(1)->as_Bool()->_test._test == BoolTest::eq)
@@ -11204,15 +11207,13 @@
 Label* L = $labl$$label;
 Assembler::Condition cond = 

commit jsoncpp for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package jsoncpp for openSUSE:Factory checked 
in at 2017-09-04 12:25:29

Comparing /work/SRC/openSUSE:Factory/jsoncpp (Old)
 and  /work/SRC/openSUSE:Factory/.jsoncpp.new (New)


Package is "jsoncpp"

Mon Sep  4 12:25:29 2017 rev:19 rq:519093 version:1.8.2

Changes:

--- /work/SRC/openSUSE:Factory/jsoncpp/jsoncpp.changes  2017-07-17 
09:01:56.453823496 +0200
+++ /work/SRC/openSUSE:Factory/.jsoncpp.new/jsoncpp.changes 2017-09-04 
12:25:31.282631024 +0200
@@ -1,0 +2,9 @@
+Mon Aug 28 10:32:13 UTC 2017 - mplus...@suse.com
+
+- Update to version 1.8.2:
+  * Some C++ "move" operators.
+  * Fix uninitialized value detected by valgrind.
+  * Other minor improvements.
+  * Moved most READ docs to Wiki.
+
+---

Old:

  jsoncpp-1.8.1.tar.gz

New:

  jsoncpp-1.8.2.tar.gz



Other differences:
--
++ jsoncpp.spec ++
--- /var/tmp/diff_new_pack.U7zqCs/_old  2017-09-04 12:25:32.654438160 +0200
+++ /var/tmp/diff_new_pack.U7zqCs/_new  2017-09-04 12:25:32.670435911 +0200
@@ -18,7 +18,7 @@
 
 %define sover   11
 Name:   jsoncpp
-Version:1.8.1
+Version:1.8.2
 Release:0
 Summary:C++ library that allows manipulating with JSON
 License:MIT
@@ -92,7 +92,7 @@
 %{_libdir}/lib%{name}.so.%{version}
 
 %files devel
-%doc AUTHORS LICENSE NEWS.txt README.md
+%doc AUTHORS LICENSE README.md
 %{_libdir}/pkgconfig/%{name}.pc
 %{_libdir}/cmake/%{name}
 %{_libdir}/lib%{name}.so

++ jsoncpp-1.8.1.tar.gz -> jsoncpp-1.8.2.tar.gz ++
 1881 lines of diff (skipped)




commit parted for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package parted for openSUSE:Factory checked 
in at 2017-09-04 12:26:03

Comparing /work/SRC/openSUSE:Factory/parted (Old)
 and  /work/SRC/openSUSE:Factory/.parted.new (New)


Package is "parted"

Mon Sep  4 12:26:03 2017 rev:117 rq:519107 version:3.2

Changes:

--- /work/SRC/openSUSE:Factory/parted/parted.changes2017-08-23 
11:53:01.708796663 +0200
+++ /work/SRC/openSUSE:Factory/.parted.new/parted.changes   2017-09-04 
12:26:07.005608656 +0200
@@ -1,0 +2,13 @@
+Thu Aug 24 16:51:37 CEST 2017 - sparscha...@suse.de
+
+- Drop using deprecated configure option "--disable-Werror"
+- Drop (SUSE specific) support for hybrid pMBR (gpt_sync_mbr
+  label) (fate#317849, bsc#1041322)
+  - remove: parted-gpt-mbr-sync.patch
+  - remove: libparted-ppc-prepboot-in-syncmbr.patch
+  - remove: parted-workaround-windows7-gpt-implementation.patch
+  - refresh patches
+- libparted: Fix starting CHS in protective MBR (bsc#969165)
+  - add: libparted-fix-starting-CHS-in-protective-MBR.patch
+
+---

Old:

  libparted-ppc-prepboot-in-syncmbr.patch
  parted-gpt-mbr-sync.patch
  parted-workaround-windows7-gpt-implementation.patch

New:

  libparted-fix-starting-CHS-in-protective-MBR.patch



Other differences:
--
++ parted.spec ++
--- /var/tmp/diff_new_pack.qWY47z/_old  2017-09-04 12:26:08.341420850 +0200
+++ /var/tmp/diff_new_pack.qWY47z/_new  2017-09-04 12:26:08.345420288 +0200
@@ -37,9 +37,6 @@
 Patch12:libparted-partition-naming.patch
 #PATCH-FEATURE-SUSE more-reliable-informing-the-kernel.patch bnc#657360 
petr.u...@suse.cz
 Patch13:more-reliable-informing-the-kernel.patch
-Patch14:parted-gpt-mbr-sync.patch
-Patch15:libparted-ppc-prepboot-in-syncmbr.patch
-Patch16:parted-workaround-windows7-gpt-implementation.patch
 Patch17:dummy-bootcode-only-for-x86.patch
 Patch18:parted-type.patch
 Patch19:parted-mac.patch
@@ -80,6 +77,7 @@
 Patch49:libparted-set-swap-flag-on-GPT-partitions.patch
 Patch50:libparted-dasd-add-swap-flag-handling-for-DASD-CDL.patch
 Patch51:parted-mkpart-allow-empty-gpt-part-name.patch
+Patch52:libparted-fix-starting-CHS-in-protective-MBR.patch
 Patch100:   parted-fatresize-autoconf.patch
 BuildRequires:  check-devel
 BuildRequires:  device-mapper-devel >= 1.02.33
@@ -136,9 +134,6 @@
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%patch14 -p1
-%patch15 -p1
-%patch16 -p1
 %patch17 -p1
 %patch18 -p1
 %patch19 -p1
@@ -174,6 +169,7 @@
 %patch49 -p1
 %patch50 -p1
 %patch51 -p1
+%patch52 -p1
 %patch100 -p1
 
 %build
@@ -184,7 +180,6 @@
--enable-device-mapper=yes  \
--enable-dynamic-loading=no \
--enable-selinux\
-   --disable-Werror\
--disable-silent-rules
 make %{?_smp_mflags}
 

++ libparted-fix-starting-CHS-in-protective-MBR.patch ++
From: Petr Uzel 
Date: Thu, 10 Mar 2016 14:18:52 +0100
Subject: libparted: Fix starting CHS in protective MBR
References: bsc#969165
Patch-mainline: v3.3
Git-commit: df6770d213b60320426a3ee0bed118d063b40fc5

The CHS address for protective partition start in protective MBR
should be 0/0/2, according to UEFI spec (v2.6, section 5.2.1).

* libparted/labels/gpt.c (_write_pmbr): Fix starting CHS address

Reported by Steffen Winterfeldt in https://bugzilla.suse.com/969165

Signed-off-by: Petr Uzel 
---
 libparted/labels/gpt.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--- a/libparted/labels/gpt.c
+++ b/libparted/labels/gpt.c
@@ -1143,7 +1143,7 @@ _write_pmbr (PedDevice *dev, bool pmbr_b
 
   pmbr->Signature = PED_CPU_TO_LE16 (MSDOS_MBR_SIGNATURE);
   pmbr->PartitionRecord[0].OSType = EFI_PMBR_OSTYPE_EFI;
-  pmbr->PartitionRecord[0].StartSector = 1;
+  pmbr->PartitionRecord[0].StartSector = 2;
   pmbr->PartitionRecord[0].EndHead = 0xFE;
   pmbr->PartitionRecord[0].EndSector = 0xFF;
   pmbr->PartitionRecord[0].EndTrack = 0xFF;
++ libparted-make-BLKRRPART-more-robust.patch ++
--- /var/tmp/diff_new_pack.qWY47z/_old  2017-09-04 12:26:08.521395547 +0200
+++ /var/tmp/diff_new_pack.qWY47z/_new  2017-09-04 12:26:08.525394985 +0200
@@ -2,11 +2,9 @@
  libparted/arch/linux.c |   10 +++---
  1 file changed, 7 insertions(+), 3 deletions(-)
 
-Index: parted-3.1/libparted/arch/linux.c
-===
 parted-3.1.orig/libparted/arch/linux.c
-+++ parted-3.1/libparted/arch/linux.c
-@@ -40,6 +40,7 @@
+--- a/libparted/arch/linux.c
 b/libparted/arch/linux.c
+@@ -39,6 +39,7 @@
  #include 
  #include 
 

commit nghttp2 for openSUSE:Factory

2017-09-04 Thread root
Hello community,

here is the log from the commit of package nghttp2 for openSUSE:Factory checked 
in at 2017-09-04 12:25:53

Comparing /work/SRC/openSUSE:Factory/nghttp2 (Old)
 and  /work/SRC/openSUSE:Factory/.nghttp2.new (New)


Package is "nghttp2"

Mon Sep  4 12:25:53 2017 rev:44 rq:519099 version:1.25.0

Changes:

--- /work/SRC/openSUSE:Factory/nghttp2/nghttp2.changes  2017-07-21 
22:37:56.729670630 +0200
+++ /work/SRC/openSUSE:Factory/.nghttp2.new/nghttp2.changes 2017-09-04 
12:25:54.995297214 +0200
@@ -1,0 +2,8 @@
+Mon Aug 28 10:58:52 UTC 2017 - mplus...@suse.com
+
+- Update to version 1.25.0:
+  * lib: add nghttp2_rcbuf_is_static() (Patch from Anna Henningsen) (GH-983)
+  * nghttpx: Fix bug that forwarded for is not affected by proxy protocol 
(GH-979)
+  * nghttpx: Update mruby to 1.3.0 (GH-957)
+
+---

Old:

  nghttp2-1.24.0.tar.xz

New:

  nghttp2-1.25.0.tar.xz



Other differences:
--
++ nghttp2.spec ++
--- /var/tmp/diff_new_pack.SBMahh/_old  2017-09-04 12:25:56.179130776 +0200
+++ /var/tmp/diff_new_pack.SBMahh/_new  2017-09-04 12:25:56.187129651 +0200
@@ -21,7 +21,7 @@
 %define soname_asio libnghttp2_asio
 %define sover_asio 1
 Name:   nghttp2
-Version:1.24.0
+Version:1.25.0
 Release:0
 Summary:Implementation of Hypertext Transfer Protocol version 2 in C
 License:MIT

++ nghttp2-1.24.0.tar.xz -> nghttp2-1.25.0.tar.xz ++
 27621 lines of diff (skipped)




  1   2   >