commit 000product for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2018-03-31 01:29:00

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new (New)


Package is "000product"

Sat Mar 31 01:29:00 2018 rev:48 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
_service:product_converter:openSUSE-Addon-NonOss-ftp-ftp-i586_x86_64.kiwi: same 
change
_service:product_converter:openSUSE-Addon-NonOss-release.spec: same change
_service:product_converter:openSUSE-Tumbleweed-Kubic-dvd5-dvd-x86_64.kiwi: same 
change
_service:product_converter:openSUSE-Tumbleweed-Kubic-release.spec: same change
_service:product_converter:openSUSE-cd-mini-i586.kiwi: same change
_service:product_converter:openSUSE-cd-mini-x86_64.kiwi: same change
_service:product_converter:openSUSE-dvd5-dvd-i586.kiwi: same change
_service:product_converter:openSUSE-dvd5-dvd-x86_64.kiwi: same change
_service:product_converter:openSUSE-ftp-ftp-i586_x86_64.kiwi: same change
++ _service:product_converter:openSUSE-release.spec ++
--- /var/tmp/diff_new_pack.sqMFUm/_old  2018-03-31 01:29:08.469111096 +0200
+++ /var/tmp/diff_new_pack.sqMFUm/_new  2018-03-31 01:29:08.489110373 +0200
@@ -8592,6 +8592,7 @@
 Provides: weakremover(rustc-1_9)
 Provides: weakremover(rustc-1_9-doc)
 Provides: weakremover(rustc-stage0)
+Provides: weakremover(systemd-mini-bash-completion)
 Provides: weakremover(texlive-beamerthemephnompenh)
 Provides: weakremover(texlive-beamerthemephnompenh-doc)
 Provides: weakremover(texlive-detlev-cm)
@@ -10875,11 +10876,17 @@
 Provides: weakremover(libaubio4)
 Provides: weakremover(libaubio4-32bit)
 Provides: weakremover(libavcodec56)
+Provides: weakremover(libavcodec56-32bit)
 Provides: weakremover(libavdevice56)
+Provides: weakremover(libavdevice56-32bit)
 Provides: weakremover(libavfilter5)
+Provides: weakremover(libavfilter5-32bit)
 Provides: weakremover(libavformat56)
+Provides: weakremover(libavformat56-32bit)
 Provides: weakremover(libavresample2)
+Provides: weakremover(libavresample2-32bit)
 Provides: weakremover(libavutil54)
+Provides: weakremover(libavutil54-32bit)
 Provides: weakremover(libbind9-140)
 Provides: weakremover(libbind9-140-32bit)
 Provides: weakremover(libbotan-1_10-1)
@@ -11026,6 +11033,7 @@
 Provides: weakremover(libpoppler72)
 Provides: weakremover(libpoppler72-32bit)
 Provides: weakremover(libpostproc53)
+Provides: weakremover(libpostproc53-32bit)
 Provides: weakremover(libpt1_11)
 Provides: weakremover(libpt1_11-32bit)
 Provides: weakremover(libqalculate13)
@@ -11049,7 +11057,9 @@
 Provides: weakremover(libstorage-devel)
 Provides: weakremover(libstorage-testsuite)
 Provides: weakremover(libswresample1)
+Provides: weakremover(libswresample1-32bit)
 Provides: weakremover(libswscale3)
+Provides: weakremover(libswscale3-32bit)
 Provides: weakremover(libtcmu-devel)
 Provides: weakremover(libtcmu1)
 Provides: weakremover(libtelepathy-qt4-2)
@@ -11402,7 +11412,9 @@
 Provides: weakremover(python-rtslib)
 Provides: weakremover(python-rtslib-doc)
 Provides: weakremover(python-rtslib-fb-doc)
+Provides: weakremover(python-sanlock)
 Provides: weakremover(python-seacucumber)
+Provides: weakremover(python-selinux)
 Provides: weakremover(python-taskflow)
 Provides: weakremover(python-taskflow-doc)
 Provides: weakremover(python-tempest-lib)
@@ -12448,6 +12460,7 @@
 Provides: weakremover(synapse-lang)
 Provides: weakremover(sysdig-kmp-pae)
 Provides: weakremover(syslog-ng-java)
+Provides: weakremover(systemd-bash-completion)
 Provides: weakremover(tcmu-runner-devel)
 Provides: weakremover(telepathy-qt4-devel)
 Provides: weakremover(tepl-3-lang)
@@ -12497,6 +12510,7 @@
 Provides: weakremover(clang-devel-static)
 Provides: weakremover(libjson-c3)
 Provides: weakremover(libjson-c3-32bit)
+Provides: weakremover(R-crayon)
 Provides: weakremover(python2-node-semver)
 Provides: weakremover(ruby2.4-rubygem-attr_required)
 Provides: weakremover(ruby2.4-rubygem-attr_required-doc)
@@ -12639,6 +12653,7 @@
 Provides: weakremover(libSPIRV-Tools-suse5-32bit)
 Provides: weakremover(libTMCG11)
 Provides: weakremover(libieee1284-3)
+Provides: weakremover(libieee1284-3-32bit)
 Provides: weakremover(libieee1284-utils)
 Provides: weakremover(python2-libieee1284)
 Provides: weakremover(libgsoap-2_8_62)
@@ -21603,6 +21618,7 @@
 rustc-1_9
 rustc-1_9-doc
 rustc-stage0
+systemd-mini-bash-completion
 texlive-beamerthemephnompenh
 texlive-beamerthemephnompenh-doc
 texlive-detlev-cm
@@ -23886,11 +23902,17 @@
 libaubio4
 libaubio4-32bit
 libavcodec56
+libavcodec56-32bit
 libavdevice56
+libavdevice56-32bit
 libavfilter5
+

commit 000product for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2018-03-31 01:01:19

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new (New)


Package is "000product"

Sat Mar 31 01:01:19 2018 rev:47 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
_service:product_converter:openSUSE-Addon-NonOss-ftp-ftp-i586_x86_64.kiwi: same 
change
_service:product_converter:openSUSE-Addon-NonOss-release.spec: same change
++ 
_service:product_converter:openSUSE-Tumbleweed-Kubic-dvd5-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.enrFzp/_old  2018-03-31 01:01:27.689231384 +0200
+++ /var/tmp/diff_new_pack.enrFzp/_new  2018-03-31 01:01:27.693231240 +0200
@@ -598,7 +598,6 @@
   
   
   
-  
   
   
   
@@ -675,6 +674,7 @@
   
   
   
+  
   
   
   

_service:product_converter:openSUSE-cd-mini-i586.kiwi: same change
_service:product_converter:openSUSE-cd-mini-x86_64.kiwi: same change
++ _service:product_converter:openSUSE-dvd5-dvd-i586.kiwi ++
--- /var/tmp/diff_new_pack.enrFzp/_old  2018-03-31 01:01:27.753229065 +0200
+++ /var/tmp/diff_new_pack.enrFzp/_new  2018-03-31 01:01:27.757228920 +0200
@@ -2678,6 +2678,7 @@
   
   
   
+  
   
   
   
@@ -5015,7 +5016,7 @@
   
   
   
-  
+  
   
   
   

++ _service:product_converter:openSUSE-dvd5-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.enrFzp/_old  2018-03-31 01:01:27.781228051 +0200
+++ /var/tmp/diff_new_pack.enrFzp/_new  2018-03-31 01:01:27.785227906 +0200
@@ -2735,6 +2735,7 @@
   
   
   
+  
   
   
   
@@ -5169,7 +5170,7 @@
   
   
   
-  
+  
   
   
   

_service:product_converter:openSUSE-release.spec: same change
openSUSE-Tumbleweed-Kubic-release.spec: same change
openSUSE-release.spec: same change
++ DVD5-i586.group ++
--- /var/tmp/diff_new_pack.enrFzp/_old  2018-03-31 01:01:27.913223267 +0200
+++ /var/tmp/diff_new_pack.enrFzp/_new  2018-03-31 01:01:27.917223122 +0200
@@ -2798,6 +2798,7 @@
 
 
 
+
 
 
 
@@ -4959,7 +4960,7 @@
 
 
 
-
+
 
 
 

++ DVD5-x86_64.group ++
--- /var/tmp/diff_new_pack.enrFzp/_old  2018-03-31 01:01:27.94153 +0200
+++ /var/tmp/diff_new_pack.enrFzp/_new  2018-03-31 01:01:27.94153 +0200
@@ -2872,6 +2872,7 @@
 
 
 
+
 
 
 
@@ -5115,7 +5116,7 @@
 
 
 
-
+
 
 
 

++ openSUSE-Kubic-DVD.group ++
--- /var/tmp/diff_new_pack.enrFzp/_old  2018-03-31 01:01:28.141215005 +0200
+++ /var/tmp/diff_new_pack.enrFzp/_new  2018-03-31 01:01:28.141215005 +0200
@@ -197,7 +197,6 @@
 
 
 
-
 
 
 
@@ -216,6 +215,7 @@
 
 
 
+
 
 
 




commit python-kiwi for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package python-kiwi for openSUSE:Factory 
checked in at 2018-03-30 21:48:41

Comparing /work/SRC/openSUSE:Factory/python-kiwi (Old)
 and  /work/SRC/openSUSE:Factory/.python-kiwi.new (New)


Package is "python-kiwi"

Fri Mar 30 21:48:41 2018 rev:24 rq: version:9.13.5

Changes:

--- /work/SRC/openSUSE:Factory/python-kiwi/python-kiwi.changes  2018-03-29 
11:51:35.647068514 +0200
+++ /work/SRC/openSUSE:Factory/.python-kiwi.new/python-kiwi.changes 
2018-03-30 21:48:43.867966158 +0200
@@ -2,316 +1,0 @@
-Fri Mar 23 10:34:37 CET 2018 - m...@suse.de
-
-- Bump version: 9.13.9 → 9.14.0
-  

-Fri Mar 23 10:33:08 CET 2018 - m...@suse.de
-  
-- Rebuild online schema documentation
-  

-Fri Mar 23 09:29:43 CET 2018 - m...@suse.de
-  
-- XSL Auto update descriptions due to schema change
-  

-Fri Mar 23 09:19:11 CET 2018 - m...@suse.de
-  
-- Delete obsolete hybrid attribute from type
-  
-  Any iso image we create will be a hybrid image. That was
-  already the default for any install iso image and was a
-  configuration option for live images. The optional selection
-  only existed for systems which do not provide tools to
-  make an iso hybrid. All distributions kiwi supports provides
-  this capabilities and there is no good reason why a live
-  or install iso should not be hybrid and bootable as iso
-  and as disk. Also the boot in disk mode became the preferred
-  boot method for the majority of our users which requires
-  to provide a hybrid iso
-  

-Thu Mar 22 18:36:53 CET 2018 - dcass...@suse.com
-  
-- Add efiparttable type attribute
-  
-  This commit allows to choose the partition table type for efi firmwares
-  using the efiparttable type attribute.
-  
-  Fixes #638
-  

-Thu Mar 22 17:40:54 CET 2018 - m...@suse.de
-  
-- Update spec file to require xorriso
-  

-Thu Mar 22 16:54:05 CET 2018 - m...@suse.de
-  
-- Cleanup hybrid call and use of iso tool options
-  
-  The extra isohybrid call is only needed if the mkisofs
-  tool category is used. Thus it should be only visible
-  at the place where the isofs is created and not as an
-  extra step in the builder tasks. Additionally the handling
-  of extra options was mkisofs specific and should be
-  better done as a common meta_data record. The tool
-  specific options should only appear in the tool specific
-  class implementations
-  

-Thu Mar 22 10:33:01 CET 2018 - m...@suse.de
-  
-- Allow to configure iso tool category
-  
-  Switch to xorriso by default but allow to setup cdrtools
-  in the runtime configuration file
-  

-Wed Mar 21 15:54:25 CET 2018 - dcass...@suse.com
-  
-- Remove xml_parse.py shebang in spec
-  
-  It removes the shebang from the autogenerated file and also removes
-  the exception in rpmlint to ignore non-executable-script warning.
-  
-  Fixes #666
-  

-Mon Mar 19 16:34:15 CET 2018 - dcass...@suse.com
-  
-- Remove unneeded shebangs from dracut modules
-  
-  Fixes #668
-  

-Mon Mar 19 14:22:40 CET 2018 - m...@suse.de
-  
-- Added IsoToolsXorrIso class
-  
-  As an alternative to mkisofs/genisoimage there is now the
-  IsoToolsXorrIso class which implements the IsoTools interface
-  by using xorriso. This Fixes #635
-  

-Mon Mar 19 10:07:19 CET 2018 - m...@suse.de
-  
-- Update package MANIFEST.in
-  
-  Include new iso_tools directory
-  

-Fri Mar 16 21:03:30 CET 2018 - m...@suse.de
-  
-- Added iso_tools api documentation
-  

-Fri Mar 16 20:55:57 CET 2018 - m...@suse.de
-  
-- Add list_iso method to iso_tools api
-  

-Fri Mar 16 15:26:29 CET 2018 - dcass...@suse.com
-  
-- Update FSF address
-  
-  The address has been taken from the header example published here
-  https://www.gnu.org/licenses/old-licenses/gpl-2.0.html
-  
-  Fixes #667
-  

-Fri Mar 16 11:02:35 CET 2018 - m...@suse.de
-  
-- Add create_iso 

commit 000product for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2018-03-30 12:09:30

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new (New)


Package is "000product"

Fri Mar 30 12:09:30 2018 rev:46 rq: version:unknown
Fri Mar 30 12:09:28 2018 rev:45 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
_service:product_converter:openSUSE-Addon-NonOss-ftp-ftp-i586_x86_64.kiwi: same 
change
_service:product_converter:openSUSE-Addon-NonOss-release.spec: same change
++ 
_service:product_converter:openSUSE-Tumbleweed-Kubic-dvd5-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.LNEiWR/_old  2018-03-30 12:10:06.32391 +0200
+++ /var/tmp/diff_new_pack.LNEiWR/_new  2018-03-30 12:10:06.32391 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,9 +35,9 @@
   true
   -x -2
   openSUSE
-  20180329
+  20180330
   11
-  cpe:/o:opensuse:opensuse-tumbleweed-kubic:20180329,openSUSE 
Tumbleweed Kubic
+  cpe:/o:opensuse:opensuse-tumbleweed-kubic:20180330,openSUSE 
Tumbleweed Kubic
   en_US 
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ _service:product_converter:openSUSE-Tumbleweed-Kubic-release.spec ++
--- /var/tmp/diff_new_pack.LNEiWR/_old  2018-03-30 12:10:06.339913865 +0200
+++ /var/tmp/diff_new_pack.LNEiWR/_new  2018-03-30 12:10:06.343913721 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   openSUSE-Tumbleweed-Kubic-release
-Version:20180329
+Version:    20180330
 Release:0
 Summary:openSUSE Tumbleweed Kubic 
 License:GPL-2.0-or-later
@@ -38,9 +38,9 @@
 ExclusiveArch:  %ix86 x86_64 ppc64le s390x aarch64
 Provides:   %name-%version
 Provides:   product() = openSUSE-Tumbleweed-Kubic
-Provides:   product(openSUSE-Tumbleweed-Kubic) = 20180329-0
+Provides:   product(openSUSE-Tumbleweed-Kubic) = 20180330-0
 Provides:   product-label() = openSUSE%20Tumbleweed%20Kubic
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dtumbleweed%2Dkubic%3A20180329
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dtumbleweed%2Dkubic%3A20180330
 Provides:   product-url(releasenotes) = 
http%3A%2F%2Fdoc.opensuse.org%2Frelease%2Dnotes%2Fx86_64%2FopenSUSE%2FTumbleweed%2Frelease%2Dnotes%2DopenSUSE.rpm
 Provides:   product-endoflife()
 Requires:   product_flavor(openSUSE-Tumbleweed-Kubic)
@@ -61,7 +61,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(dvd)
-Provides:   product_flavor(openSUSE-Tumbleweed-Kubic) = 20180329-0
+Provides:   product_flavor(openSUSE-Tumbleweed-Kubic) = 20180330-0
 Summary:openSUSE Tumbleweed Kubic
 
 %description dvd
@@ -123,11 +123,11 @@
 
   openSUSE
   openSUSE-Tumbleweed-Kubic
-  20180329
+  20180330
   0
   
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-tumbleweed-kubic:20180329
+  cpe:/o:opensuse:opensuse-tumbleweed-kubic:20180330
   openSUSE-Tumbleweed-Kubic
   
 

++ _service:product_converter:openSUSE-cd-mini-i586.kiwi ++
--- /var/tmp/diff_new_pack.LNEiWR/_old  2018-03-30 12:10:06.363912998 +0200
+++ /var/tmp/diff_new_pack.LNEiWR/_new  2018-03-30 12:10:06.363912998 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,9 +32,9 @@
   true
   -x -2
   openSUSE
-  20180329
+  20180330
   11
-  cpe:/o:opensuse:opensuse:20180329,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20180330,openSUSE 
Tumbleweed
   cs da de en en_GB en_US es fi fr hu it ja nb 
nl pl pt pt_BR ru sv zh zh_CN zh_TW 
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

_service:product_converter:openSUSE-cd-mini-x86_64.kiwi: same change
_service:product_converter:openSUSE-dvd5-dvd-i586.kiwi: same change
_service:product_converter:openSUSE-dvd5-dvd-x86_64.kiwi: same change
++ _service:product_converter:openSUSE-ftp-ftp-i586_x86_64.kiwi ++
--- /var/tmp/diff_new_pack.LNEiWR/_old  2018-03-30 12:10:06.467909238 +0200
+++ /var/tmp/diff_new_pack.LNEiWR/_new  2018-03-30 12:10:06.467909238 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -24,7 +24,7 @@
   openSUSE
   ftp
   true
-  openSUSE-20180329-i586-x86_64
+  openSUSE-20180330-i586-x86_64
   true
   /
   $DISTNAME-$FLAVOR
@@ -36,9 +36,9 @@
   true
   -x -2
   openSUSE
-  20180329
+  20180330
   11
-  cpe:/o:opensuse:opensuse:20180329,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20180330,openSUSE 
Tumbleweed
   cs da de en en_GB en_US es fi fr hu it ja nb

commit julia for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package julia for openSUSE:Factory checked 
in at 2018-03-30 12:09:14

Comparing /work/SRC/openSUSE:Factory/julia (Old)
 and  /work/SRC/openSUSE:Factory/.julia.new (New)


Package is "julia"

Fri Mar 30 12:09:14 2018 rev:29 rq:592451 version:0.6.2

Changes:

--- /work/SRC/openSUSE:Factory/julia/julia-compat.changes   2017-12-22 
12:21:45.643247942 +0100
+++ /work/SRC/openSUSE:Factory/.julia.new/julia-compat.changes  2018-03-30 
12:09:16.509715465 +0200
@@ -1,0 +2,5 @@
+Tue Mar 27 09:18:51 UTC 2018 - guillaume.gar...@opensuse.org
+
+- Pass right march option for %arm and aarch64
+
+---
julia.changes: same change



Other differences:
--
++ julia-compat.spec ++
--- /var/tmp/diff_new_pack.zUpwP7/_old  2018-03-30 12:09:17.721671647 +0200
+++ /var/tmp/diff_new_pack.zUpwP7/_new  2018-03-30 12:09:17.721671647 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package julia
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -98,11 +98,11 @@
 %endif
 %if 0%{?compat_mode} == 0
 Summary:High-level, high-performance dynamic programming language
-License:MIT and GPL-2.0+ and BSD-3-Clause and Zlib
+License:MIT AND GPL-2.0-or-later AND BSD-3-Clause AND Zlib
 Group:  Development/Languages/Other
 %else
 Summary:High-level, high-performance dynamic programming language 
(without CPU optimizations)
-License:MIT and GPL-2.0+ and BSD-3-Clause and Zlib
+License:MIT AND GPL-2.0-or-later AND BSD-3-Clause AND Zlib
 Group:  Development/Languages/Other
 %endif
 %if 0%{?compat_mode}
@@ -192,14 +192,24 @@
 
 %if 0%{?compat_mode} == 0
 %ifarch x86_64
-
 %define julia_march core2
 %endif
 
 %ifarch %{ix86}
-
 %define julia_march pentium4
 %endif
+
+%ifarch aarch64
+%define julia_march armv8-a
+%endif
+
+%ifarch armv7l armv7hl
+   %define julia_march armv7-a
+%endif
+
+%ifarch armv6l armv6hl
+%define julia_march armv6
+%endif
 %else
 # compat_mode is only defined for 64-bit architecture.
 

++ julia.spec ++
--- /var/tmp/diff_new_pack.zUpwP7/_old  2018-03-30 12:09:17.745670780 +0200
+++ /var/tmp/diff_new_pack.zUpwP7/_new  2018-03-30 12:09:17.749670634 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package julia
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -98,11 +98,11 @@
 %endif
 %if 0%{?compat_mode} == 0
 Summary:High-level, high-performance dynamic programming language
-License:MIT and GPL-2.0+ and BSD-3-Clause and Zlib
+License:MIT AND GPL-2.0-or-later AND BSD-3-Clause AND Zlib
 Group:  Development/Languages/Other
 %else
 Summary:High-level, high-performance dynamic programming language 
(without CPU optimizations)
-License:MIT and GPL-2.0+ and BSD-3-Clause and Zlib
+License:MIT AND GPL-2.0-or-later AND BSD-3-Clause AND Zlib
 Group:  Development/Languages/Other
 %endif
 %if 0%{?compat_mode}
@@ -192,14 +192,24 @@
 
 %if 0%{?compat_mode} == 0
 %ifarch x86_64
-
 %define julia_march core2
 %endif
 
 %ifarch %{ix86}
-
 %define julia_march pentium4
 %endif
+
+%ifarch aarch64
+%define julia_march armv8-a
+%endif
+
+%ifarch armv7l armv7hl
+   %define julia_march armv7-a
+%endif
+
+%ifarch armv6l armv6hl
+%define julia_march armv6
+%endif
 %else
 # compat_mode is only defined for 64-bit architecture.
 




commit praat for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package praat for openSUSE:Factory checked 
in at 2018-03-30 12:09:23

Comparing /work/SRC/openSUSE:Factory/praat (Old)
 and  /work/SRC/openSUSE:Factory/.praat.new (New)


Package is "praat"

Fri Mar 30 12:09:23 2018 rev:12 rq:592528 version:6.0.38

Changes:

--- /work/SRC/openSUSE:Factory/praat/praat.changes  2018-02-06 
16:47:23.733005700 +0100
+++ /work/SRC/openSUSE:Factory/.praat.new/praat.changes 2018-03-30 
12:09:34.789054577 +0200
@@ -1,0 +2,8 @@
+Fri Mar 30 07:11:28 UTC 2018 - aloi...@gmx.com
+
+- Update to version 6.0.38
+  * Concordance: ##TextGrid: Tabulate occurrences...#.
+  * Some Independent Component Analysis on EEG.
+  * Removed many small bugs
+
+---

Old:

  praat-6.0.37.tar.gz

New:

  praat-6.0.38.tar.gz



Other differences:
--
++ praat.spec ++
--- /var/tmp/diff_new_pack.8F78TL/_old  2018-03-30 12:09:36.748983716 +0200
+++ /var/tmp/diff_new_pack.8F78TL/_new  2018-03-30 12:09:36.752983571 +0200
@@ -17,10 +17,10 @@
 
 
 Name:   praat
-Version:6.0.37
+Version:6.0.38
 Release:0
 Summary:Phonetics by computer
-License:GPL-3.0+
+License:GPL-3.0-or-later
 Group:  Productivity/Scientific/Other
 Url:http://www.praat.org
 Source0:
https://github.com/praat/praat/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz

++ praat-6.0.37.tar.gz -> praat-6.0.38.tar.gz ++
/work/SRC/openSUSE:Factory/praat/praat-6.0.37.tar.gz 
/work/SRC/openSUSE:Factory/.praat.new/praat-6.0.38.tar.gz differ: char 14, line 
1




commit pdsh for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package pdsh for openSUSE:Factory checked in 
at 2018-03-30 12:09:19

Comparing /work/SRC/openSUSE:Factory/pdsh (Old)
 and  /work/SRC/openSUSE:Factory/.pdsh.new (New)


Package is "pdsh"

Fri Mar 30 12:09:19 2018 rev:36 rq:592455 version:2.33

Changes:

--- /work/SRC/openSUSE:Factory/pdsh/pdsh.changes2018-03-28 
10:34:33.902175484 +0200
+++ /work/SRC/openSUSE:Factory/.pdsh.new/pdsh.changes   2018-03-30 
12:09:22.745490010 +0200
@@ -1,0 +2,12 @@
+Thu Mar 29 13:34:48 UTC 2018 - jjo...@suse.com
+
+- removed patch: pdsh-exclude-slurm-list-namespace.patch:
+  Patch is not an acceptable work-around for upstream
+- added patch: pdsh-rename-list-to-xlist.patch
+  Renamed 'struct list' to 'struct xlist' to match upstream slurm
+  change (bsc#1086736).
+  Original upstream commit message:
+to avoid name collisions with c++ list types. gdb started showing
+the wrong type when the full lib was created.
+
+---

Old:

  pdsh-exclude-slurm-list-namespace.patch

New:

  pdsh-rename-list-to-xlist.patch



Other differences:
--
++ pdsh.spec ++
--- /var/tmp/diff_new_pack.dCQ85M/_old  2018-03-30 12:09:23.349468174 +0200
+++ /var/tmp/diff_new_pack.dCQ85M/_new  2018-03-30 12:09:23.353468029 +0200
@@ -46,7 +46,7 @@
 License:GPL-2.0+
 Group:  Productivity/Clustering/Computing
 Source: 
https://github.com/chaos/%{name}/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
-Patch1: pdsh-exclude-slurm-list-namespace.patch
+Patch1: pdsh-rename-list-to-xlist.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 # Prereq: 
 # Set this to 1 to build with genders support and framework for

++ pdsh-rename-list-to-xlist.patch ++
diff --git a/src/common/list.c b/src/common/list.c
index 4612d84..a814820 100644
--- a/src/common/list.c
+++ b/src/common/list.c
@@ -95,7 +95,7 @@ struct listNode {
 };
 
 struct listIterator {
-struct list  *list; /* the list being iterated   */
+struct xlist *list; /* the list being iterated   */
 struct listNode  *pos;  /* the next node to be iterated  */
 struct listNode **prev; /* addr of 'next' ptr to prv It node */
 struct listIterator  *iNext;/* iterator chain for list_destroy() */
@@ -104,7 +104,7 @@ struct listIterator {
 #endif /* !NDEBUG */
 };
 
-struct list {
+struct xlist {
 struct listNode  *head; /* head of the list  */
 struct listNode **tail; /* addr of last node's 'next' ptr*/
 struct listIterator  *iNext;/* iterator chain for list_destroy() */
@@ -727,7 +727,7 @@ list_node_destroy (List l, ListNode *pp)
 static List
 list_alloc (void)
 {
-return(list_alloc_aux(sizeof(struct list), _free_lists));
+return(list_alloc_aux(sizeof(struct xlist), _free_lists));
 }
 
 
diff --git a/src/common/list.h b/src/common/list.h
index 2976ea1..ab5f646 100644
--- a/src/common/list.h
+++ b/src/common/list.h
@@ -55,7 +55,7 @@
  *  Data Types  *
  /
 
-typedef struct list * List;
+typedef struct xlist * List;
 /*
  *  List opaque data type.
  */



commit kurso-de-esperanto for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kurso-de-esperanto for 
openSUSE:Factory checked in at 2018-03-30 12:08:56

Comparing /work/SRC/openSUSE:Factory/kurso-de-esperanto (Old)
 and  /work/SRC/openSUSE:Factory/.kurso-de-esperanto.new (New)


Package is "kurso-de-esperanto"

Fri Mar 30 12:08:56 2018 rev:2 rq:592371 version:4.1.2

Changes:

--- /work/SRC/openSUSE:Factory/kurso-de-esperanto/kurso-de-esperanto.changes
2018-03-28 10:31:10.853478309 +0200
+++ 
/work/SRC/openSUSE:Factory/.kurso-de-esperanto.new/kurso-de-esperanto.changes   
2018-03-30 12:09:02.846209472 +0200
@@ -1,0 +2,5 @@
+Thu Mar 29 18:58:13 UTC 2018 - bwiedem...@suse.com
+
+- Use convert -strip to make build reproducible (boo#1047218)
+
+---



Other differences:
--
++ kurso-de-esperanto.spec ++
--- /var/tmp/diff_new_pack.j5LcNu/_old  2018-03-30 12:09:04.670143527 +0200
+++ /var/tmp/diff_new_pack.j5LcNu/_new  2018-03-30 12:09:04.670143527 +0200
@@ -77,7 +77,7 @@
 inc=0
 for size in 256x256 128x128 64x64 48x48 32x32 24x24 16x16; do
 mkdir -p %{buildroot}%{_datadir}/icons/hicolor/$size/apps/
-convert "ico:%{_name}%{_version}.ico[$inc]" 
"png:%{buildroot}%{_datadir}/icons/hicolor/$size/apps/%{name}.png"
+convert -strip "ico:%{_name}%{_version}.ico[$inc]" 
"png:%{buildroot}%{_datadir}/icons/hicolor/$size/apps/%{name}.png"
 inc=$(($inc + 1))
 done
 %suse_update_desktop_file br.com.kurso.%{_name}




commit openSUSE-release-tools for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package openSUSE-release-tools for 
openSUSE:Factory checked in at 2018-03-30 12:08:09

Comparing /work/SRC/openSUSE:Factory/openSUSE-release-tools (Old)
 and  /work/SRC/openSUSE:Factory/.openSUSE-release-tools.new (New)


Package is "openSUSE-release-tools"

Fri Mar 30 12:08:09 2018 rev:75 rq:592280 version:20180329.9ad18cf

Changes:

--- 
/work/SRC/openSUSE:Factory/openSUSE-release-tools/openSUSE-release-tools.changes
2018-03-29 11:57:20.706617442 +0200
+++ 
/work/SRC/openSUSE:Factory/.openSUSE-release-tools.new/openSUSE-release-tools.changes
   2018-03-30 12:08:16.815873723 +0200
@@ -1,0 +2,12 @@
+Thu Mar 29 11:10:23 UTC 2018 - opensuse-releaset...@opensuse.org
+
+- Update to version 20180329.9ad18cf:
+  * Staging accept: run service in ports 000product
+
+---
+Thu Mar 29 09:02:47 UTC 2018 - opensuse-releaset...@opensuse.org
+
+- Update to version 20180329.8097ab6:
+  * conf: make sure variable is not None before do lower()
+
+---

Old:

  openSUSE-release-tools-20180328.f195bc7.obscpio

New:

  openSUSE-release-tools-20180329.9ad18cf.obscpio



Other differences:
--
++ openSUSE-release-tools.spec ++
--- /var/tmp/diff_new_pack.wxzOnF/_old  2018-03-30 12:08:18.647807487 +0200
+++ /var/tmp/diff_new_pack.wxzOnF/_new  2018-03-30 12:08:18.655807198 +0200
@@ -20,7 +20,7 @@
 %define source_dir openSUSE-release-tools
 %define announcer_filename factory-package-news
 Name:   openSUSE-release-tools
-Version:20180328.f195bc7
+Version:20180329.9ad18cf
 Release:0
 Summary:Tools to aid in staging and release work for openSUSE/SUSE
 License:GPL-2.0-or-later AND MIT

++ _servicedata ++
--- /var/tmp/diff_new_pack.wxzOnF/_old  2018-03-30 12:08:18.711805174 +0200
+++ /var/tmp/diff_new_pack.wxzOnF/_new  2018-03-30 12:08:18.711805174 +0200
@@ -1,6 +1,6 @@
 
   
 https://github.com/openSUSE/openSUSE-release-tools.git
-f195bc7998040de0894dcec41acd111492f05fd1
+64bd11baf498f4832256420a5b4c8a570494fc60
   
 

++ openSUSE-release-tools-20180328.f195bc7.obscpio -> 
openSUSE-release-tools-20180329.9ad18cf.obscpio ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/openSUSE-release-tools-20180328.f195bc7/osclib/accept_command.py 
new/openSUSE-release-tools-20180329.9ad18cf/osclib/accept_command.py
--- old/openSUSE-release-tools-20180328.f195bc7/osclib/accept_command.py
2018-03-28 11:50:02.0 +0200
+++ new/openSUSE-release-tools-20180329.9ad18cf/osclib/accept_command.py
2018-03-29 13:05:23.0 +0200
@@ -301,7 +301,7 @@
 for ports in ports_prjs:
 project = self.api.project + ':' + ports
 if self.api.item_exists(project):
-baseurl = ['source', project, '_product']
+baseurl = ['source', project, '000product']
 url = self.api.makeurl(baseurl, query=service)
 self.api.retried_POST(url)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/openSUSE-release-tools-20180328.f195bc7/osclib/conf.py 
new/openSUSE-release-tools-20180329.9ad18cf/osclib/conf.py
--- old/openSUSE-release-tools-20180328.f195bc7/osclib/conf.py  2018-03-28 
11:50:02.0 +0200
+++ new/openSUSE-release-tools-20180329.9ad18cf/osclib/conf.py  2018-03-29 
13:05:23.0 +0200
@@ -172,7 +172,7 @@
 
 
 def str2bool(v):
-return v.lower() in ("yes", "true", "t", "1")
+return (v is not None and v.lower() in ("yes", "true", "t", "1"))
 
 
 class Config(object):

++ openSUSE-release-tools.obsinfo ++
--- /var/tmp/diff_new_pack.wxzOnF/_old  2018-03-30 12:08:19.451778419 +0200
+++ /var/tmp/diff_new_pack.wxzOnF/_new  2018-03-30 12:08:19.455778275 +0200
@@ -1,5 +1,5 @@
 name: openSUSE-release-tools
-version: 20180328.f195bc7
-mtime: 1522230602
-commit: f195bc7998040de0894dcec41acd111492f05fd1
+version: 20180329.9ad18cf
+mtime: 1522321523
+commit: 9ad18cf55f51716afde390433628cf1bd602a5e9
 




commit o2scl for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package o2scl for openSUSE:Factory checked 
in at 2018-03-30 12:08:35

Comparing /work/SRC/openSUSE:Factory/o2scl (Old)
 and  /work/SRC/openSUSE:Factory/.o2scl.new (New)


Package is "o2scl"

Fri Mar 30 12:08:35 2018 rev:3 rq:592296 version:0.921

Changes:

--- /work/SRC/openSUSE:Factory/o2scl/o2scl.changes  2018-03-11 
15:25:24.646871985 +0100
+++ /work/SRC/openSUSE:Factory/.o2scl.new/o2scl.changes 2018-03-30 
12:08:37.691118964 +0200
@@ -1,0 +2,6 @@
+Tue Mar 27 15:09:27 UTC 2018 - badshah...@gmail.com
+
+- Disable tests on i586 until test codes are fixed, typically
+  simply by increasing tolerances (gh#awsteiner/o2scl#7).
+
+---



Other differences:
--
++ o2scl.spec ++
--- /var/tmp/diff_new_pack.jwyuSh/_old  2018-03-30 12:08:38.875076157 +0200
+++ /var/tmp/diff_new_pack.jwyuSh/_new  2018-03-30 12:08:38.879076012 +0200
@@ -21,7 +21,7 @@
 Version:0.921
 Release:0
 Summary:Object-oriented Scientific Computing Library
-License:GPL-3.0
+License:GPL-3.0-only
 Group:  Productivity/Scientific/Math
 Url:http://web.utk.edu/~asteine1/o2scl
 Source: 
https://github.com/awsteiner/o2scl/releases/download/v%{version}/%{name}-%{version}.tar.gz
@@ -114,8 +114,11 @@
 
 %fdupes %{buildroot}%{_docdir}/%{name}/
 
+# Tests fail on i586 due to tolerances in the test codes being set too low. 
Disable for i586 until fixed
+%ifnarch i586
 %check
 make %{?_smp_mflags} check
+%endif
 
 %post -n %{shlib} -p /sbin/ldconfig
 %postun -n %{shlib} -p /sbin/ldconfig




commit lollypop for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package lollypop for openSUSE:Factory 
checked in at 2018-03-30 12:08:29

Comparing /work/SRC/openSUSE:Factory/lollypop (Old)
 and  /work/SRC/openSUSE:Factory/.lollypop.new (New)


Package is "lollypop"

Fri Mar 30 12:08:29 2018 rev:33 rq:592290 version:0.9.403

Changes:

--- /work/SRC/openSUSE:Factory/lollypop/lollypop.changes2018-03-09 
10:47:37.168466178 +0100
+++ /work/SRC/openSUSE:Factory/.lollypop.new/lollypop.changes   2018-03-30 
12:08:35.715190405 +0200
@@ -1,0 +2,15 @@
+Wed Mar 28 18:54:41 UTC 2018 - antoine.belv...@opensuse.org
+
+- Update to version 0.9.403:
+  * Workaround bgo#766284.
+  * Show notifications when window is not visible.
+  * Close notification on quit.
+  * Fix a crash when trying to love a None track id.
+- Update to version 0.9.402:
+  * Quit app on SIGTERM/SIGINT.
+  * Bugfixes.
+- Update to version 0.9.401:
+  * Fix an issue in Collection scanner.
+  * Add an option to disable compilations.
+
+---

Old:

  lollypop-0.9.400.tar.xz

New:

  lollypop-0.9.403.tar.xz



Other differences:
--
++ lollypop.spec ++
--- /var/tmp/diff_new_pack.eFBBoi/_old  2018-03-30 12:08:36.235171605 +0200
+++ /var/tmp/diff_new_pack.eFBBoi/_new  2018-03-30 12:08:36.235171605 +0200
@@ -19,7 +19,7 @@
 %global gobject_introspection_version 1.35.9
 %global gtk3_version 3.20
 Name:   lollypop
-Version:0.9.400
+Version:0.9.403
 Release:0
 Summary:GNOME music playing application
 License:GPL-3.0-or-later

++ _service ++
--- /var/tmp/diff_new_pack.eFBBoi/_old  2018-03-30 12:08:36.267170447 +0200
+++ /var/tmp/diff_new_pack.eFBBoi/_new  2018-03-30 12:08:36.267170447 +0200
@@ -1,7 +1,7 @@
 
   
 enable
-0.9.400
+0.9.403
 git
 https://gitlab.gnome.org/gnumdk/lollypop.git
 @PARENT_TAG@

++ _servicedata ++
--- /var/tmp/diff_new_pack.eFBBoi/_old  2018-03-30 12:08:36.283169869 +0200
+++ /var/tmp/diff_new_pack.eFBBoi/_new  2018-03-30 12:08:36.283169869 +0200
@@ -1,4 +1,4 @@
 
 
 https://gitlab.gnome.org/gnumdk/lollypop.git
-  721a14a92c81f6ab120eafe6017df6ed5fc1b40d
\ No newline at end of file
+  da04dbd0d6cbaf932c8c150892e9202d0dd4
\ No newline at end of file

++ lollypop-0.9.400.tar.xz -> lollypop-0.9.403.tar.xz ++
 28846 lines of diff (skipped)




commit virt-manager for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package virt-manager for openSUSE:Factory 
checked in at 2018-03-30 12:08:50

Comparing /work/SRC/openSUSE:Factory/virt-manager (Old)
 and  /work/SRC/openSUSE:Factory/.virt-manager.new (New)


Package is "virt-manager"

Fri Mar 30 12:08:50 2018 rev:176 rq:592352 version:1.5.0

Changes:

--- /work/SRC/openSUSE:Factory/virt-manager/virt-manager.changes
2018-03-28 10:34:15.250846327 +0200
+++ /work/SRC/openSUSE:Factory/.virt-manager.new/virt-manager.changes   
2018-03-30 12:08:51.866606442 +0200
@@ -1,0 +2,7 @@
+Thu Mar 29 09:06:00 MDT 2018 - carn...@suse.com
+
+- Fallback to latest version of openSUSE when opensuse-unknown is
+  detected for the ISO (bsc#1085757)
+  virtinst-use-latest-opensuse-version-when-unknown-media.patch
+
+---

New:

  virtinst-use-latest-opensuse-version-when-unknown-media.patch



Other differences:
--
++ virt-manager.spec ++
--- /var/tmp/diff_new_pack.y7qiWu/_old  2018-03-30 12:08:52.974566384 +0200
+++ /var/tmp/diff_new_pack.y7qiWu/_new  2018-03-30 12:08:52.978566239 +0200
@@ -85,6 +85,7 @@
 Patch170:   virtinst-osdict-get_supported.patch
 Patch171:   virtinst-dont-use-special-copy-cpu-features.patch
 Patch172:   virtinst-dont-set-cpu-model-when-caps-mismatch.patch
+Patch173:   virtinst-use-latest-opensuse-version-when-unknown-media.patch
 # Python2 to Python3 patches
 Patch200:   virtmisc-python2-to-python3-conversion.patch
 Patch201:   virtcli-python2-to-python3-conversion.patch
@@ -227,6 +228,7 @@
 %patch170 -p1
 %patch171 -p1
 %patch172 -p1
+%patch173 -p1
 # Python2 to Python3 patches
 %patch200 -p1
 %patch201 -p1

++ virtinst-python2-to-python3-conversion.patch ++
--- /var/tmp/diff_new_pack.y7qiWu/_old  2018-03-30 12:08:53.102561756 +0200
+++ /var/tmp/diff_new_pack.y7qiWu/_new  2018-03-30 12:08:53.106561612 +0200
@@ -92,7 +92,7 @@
  sorted_distro_list.sort()
  sortpref.reverse()
  for prefer in sortpref:
-@@ -258,7 +258,7 @@ class _OSDB(object):
+@@ -264,7 +264,7 @@ class _OSDB(object):
  """
  sortmap = {}
  

++ virtinst-use-latest-opensuse-version-when-unknown-media.patch ++
References: bsc#1085757

When a version openSUSE is under development, the lookup fails to
detect the version of openSUSE ISO media (it changes with every build).
When 'opensuse-unknown' is detected, look up the most current version
of openSUSE and default to that. This is the same way fedora does it.

Index: virt-manager-1.5.0/virtinst/osdict.py
===
--- virt-manager-1.5.0.orig/virtinst/osdict.py
+++ virt-manager-1.5.0/virtinst/osdict.py
@@ -241,6 +241,12 @@ class _OSDB(object):
 "Converting that to the latest fedora OS version=%s",
 location, osname)
 
+if osname == "opensuse-unknown":
+osname = self.latest_opensuse_version()
+logging.debug("Detected location=%s as os=opensuse-unknown. "
+"Converting that to the latest opensuse OS version=%s",
+location, osname)
+
 return osname
 
 def list_types(self):
@@ -275,6 +281,16 @@ class _OSDB(object):
 # First fedora* occurrence should be the newest
 return osinfo.name
 
+def latest_opensuse_version(self):
+os_info = None
+for osinfo in self.list_os():
+if (osinfo.name.startswith("opensuse") and
+"unknown" not in osinfo.name and
+"tumbleweed" not in osinfo.name and
+"factory" not in osinfo.name and
+"42" not in osinfo.name):
+# openSUSE Leap 42 is not the latest anymore
+return osinfo.name
 
 #
 # OsVariant classes #



commit python-more-itertools for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package python-more-itertools for 
openSUSE:Factory checked in at 2018-03-30 12:08:43

Comparing /work/SRC/openSUSE:Factory/python-more-itertools (Old)
 and  /work/SRC/openSUSE:Factory/.python-more-itertools.new (New)


Package is "python-more-itertools"

Fri Mar 30 12:08:43 2018 rev:3 rq:592319 version:4.1.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-more-itertools/python-more-itertools.changes  
2018-03-26 13:16:39.600013959 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-more-itertools.new/python-more-itertools.changes
 2018-03-30 12:08:46.466801674 +0200
@@ -1,0 +2,7 @@
+Thu Mar 29 13:32:39 UTC 2018 - mimi...@gmail.com
+
+- spec-cleaned
+- use of %license macro
+- removed unneded dependency
+
+---



Other differences:
--
++ python-more-itertools.spec ++
--- /var/tmp/diff_new_pack.oeBd5L/_old  2018-03-30 12:08:47.130777668 +0200
+++ /var/tmp/diff_new_pack.oeBd5L/_new  2018-03-30 12:08:47.134777524 +0200
@@ -26,11 +26,9 @@
 Url:https://github.com/erikrose/more-itertools
 Source: 
https://files.pythonhosted.org/packages/source/m/more-itertools/more-itertools-%{version}.tar.gz
 BuildRequires:  %{python_module base}
-BuildRequires:  %{python_module nose}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
 %python_subpackages
 
@@ -60,8 +58,8 @@
 %python_exec setup.py test
 
 %files %{python_files}
-%defattr(-,root,root,-)
-%doc LICENSE README.rst
+%doc README.rst
+%license LICENSE
 %{python_sitelib}/more_itertools/
 %{python_sitelib}/more_itertools-%{version}-py%{python_version}.egg-info
 




commit ganglia for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package ganglia for openSUSE:Factory checked 
in at 2018-03-30 12:08:47

Comparing /work/SRC/openSUSE:Factory/ganglia (Old)
 and  /work/SRC/openSUSE:Factory/.ganglia.new (New)


Package is "ganglia"

Fri Mar 30 12:08:47 2018 rev:5 rq:592349 version:3.7.2

Changes:

--- /work/SRC/openSUSE:Factory/ganglia/ganglia.changes  2018-03-14 
19:40:44.905556423 +0100
+++ /work/SRC/openSUSE:Factory/.ganglia.new/ganglia.changes 2018-03-30 
12:08:50.834643754 +0200
@@ -1,0 +2,10 @@
+Thu Mar 29 12:17:33 UTC 2018 - cg...@suse.com
+
+- detect_aarch.patch: 
+  detect architecture correctly for aarch64 in module sys, 
+  backported from upstream (bsc#1087257)
+- add_unknown_arch.patch:
+  arch for gmond module sys defaults to unknown if arch can not be 
+  deteced with precompiler macros, backported from upstream
+
+---

New:

  add_unknown_arch.patch
  detect_aarch.patch



Other differences:
--
++ ganglia.spec ++
--- /var/tmp/diff_new_pack.3ZCAYf/_old  2018-03-30 12:08:51.494619892 +0200
+++ /var/tmp/diff_new_pack.3ZCAYf/_new  2018-03-30 12:08:51.494619892 +0200
@@ -32,6 +32,8 @@
 # PATCH-FIX-OPENSUSE ganglia-3.7.1-no-private-apr.patch
 Patch1: ganglia-3.7.2-no-private-apr.patch
 Patch2: gmetad-service-btrfs-check.patch
+Patch3: detect_aarch.patch
+Patch4: add_unknown_arch.patch
 BuildRequires:  fdupes
 BuildRequires:  libapr1-devel
 BuildRequires:  libart_lgpl-devel
@@ -155,6 +157,8 @@
 %setup -q
 %patch1 -p1
 %patch2
+%patch3
+%patch4
 
 %build
 export LIBS="-ltirpc"

++ add_unknown_arch.patch ++
--- ./libmetrics/linux/metrics.c.orig   2018-03-29 17:05:23.884576752 +0200
+++ ./libmetrics/linux/metrics.c2018-03-29 17:07:28.228537714 +0200
@@ -593,39 +593,30 @@
 
 #ifdef __i386__
snprintf(val.str, MAX_G_STRING_SIZE, "x86");
-#endif
-#ifdef __x86_64__
+#elif __x86_64__
snprintf(val.str, MAX_G_STRING_SIZE, "x86_64");
-#endif
-#ifdef __ia64__
+#elif __ia64__
snprintf(val.str, MAX_G_STRING_SIZE, "ia64");
-#endif
-#ifdef __sparc__
+#elif __sparc__
snprintf(val.str, MAX_G_STRING_SIZE, "sparc");
-#endif
-#ifdef __alpha__
+#elif __alpha__
snprintf(val.str, MAX_G_STRING_SIZE, "alpha");
-#endif
-#ifdef __powerpc__
+#elif __powerpc__
snprintf(val.str, MAX_G_STRING_SIZE, "powerpc");
-#endif
-#ifdef __m68k__
+#elif __m68k__
snprintf(val.str, MAX_G_STRING_SIZE, "m68k");
-#endif
-#ifdef __mips__
+#elif __mips__
snprintf(val.str, MAX_G_STRING_SIZE, "mips");
-#endif
-#ifdef __arm__
+#elif __arm__
snprintf(val.str, MAX_G_STRING_SIZE, "arm");
-#endif
-#ifdef __aarch64__
+#elif __aarch64__
snprintf(val.str, MAX_G_STRING_SIZE, "aarch64");
-#endif
-#ifdef __hppa__
+#elif __hppa__
snprintf(val.str, MAX_G_STRING_SIZE, "hppa");
-#endif
-#ifdef __s390__
+#elif __s390__
snprintf(val.str, MAX_G_STRING_SIZE, "s390");
+#else 
+   snprintf(val.str, MAX_G_STRING_SIZE, "unknown");
 #endif
 
return val;
++ detect_aarch.patch ++
--- ./libmetrics/linux/metrics.c.orig   2018-03-29 14:51:41.974310218 +0200
+++ ./libmetrics/linux/metrics.c2018-03-29 15:08:05.861449768 +0200
@@ -618,6 +618,9 @@
 #ifdef __arm__
snprintf(val.str, MAX_G_STRING_SIZE, "arm");
 #endif
+#ifdef __aarch64__
+   snprintf(val.str, MAX_G_STRING_SIZE, "aarch64");
+#endif
 #ifdef __hppa__
snprintf(val.str, MAX_G_STRING_SIZE, "hppa");
 #endif



commit snd for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package snd for openSUSE:Factory checked in 
at 2018-03-30 12:08:39

Comparing /work/SRC/openSUSE:Factory/snd (Old)
 and  /work/SRC/openSUSE:Factory/.snd.new (New)


Package is "snd"

Fri Mar 30 12:08:39 2018 rev:34 rq:592299 version:17.1

Changes:

--- /work/SRC/openSUSE:Factory/snd/snd.changes  2017-02-18 03:18:11.927981017 
+0100
+++ /work/SRC/openSUSE:Factory/.snd.new/snd.changes 2018-03-30 
12:08:42.698937903 +0200
@@ -1,0 +2,5 @@
+Wed Mar 28 12:55:23 UTC 2018 - guillaume.gar...@opensuse.org
+
+- Build only for x86* and ppc* since other archs are not supported
+
+---



Other differences:
--
++ snd.spec ++
--- /var/tmp/diff_new_pack.RCnIP2/_old  2018-03-30 12:08:43.462910282 +0200
+++ /var/tmp/diff_new_pack.RCnIP2/_new  2018-03-30 12:08:43.466910137 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package snd
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -29,7 +29,7 @@
 BuildRequires:  libsamplerate-devel
 BuildRequires:  update-desktop-files
 Summary:Powerful Sound File Editor
-License:LGPL-2.1+
+License:LGPL-2.1-or-later
 Group:  Productivity/Multimedia/Sound/Editors and Convertors
 Version:17.1
 Release:0
@@ -41,6 +41,7 @@
 Patch2: snd-drop-date-time.diff
 Url:https://ccrma.stanford.edu/software/snd/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+ExclusiveArch:  %ix86 x86_64 %ppc ppc64 ppc64le
 
 %description
 Snd is a sound editor modelled loosely after Emacs and an old,





commit bspwm for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package bspwm for openSUSE:Factory checked 
in at 2018-03-30 12:07:54

Comparing /work/SRC/openSUSE:Factory/bspwm (Old)
 and  /work/SRC/openSUSE:Factory/.bspwm.new (New)


Package is "bspwm"

Fri Mar 30 12:07:54 2018 rev:5 rq:592196 version:0.9.4

Changes:

--- /work/SRC/openSUSE:Factory/bspwm/bspwm.changes  2018-03-28 
10:34:32.970209005 +0200
+++ /work/SRC/openSUSE:Factory/.bspwm.new/bspwm.changes 2018-03-30 
12:07:58.468537088 +0200
@@ -1,0 +2,19 @@
+Thu Mar 29 02:52:28 UTC 2018 - avin...@opensuse.org
+
+- Update to 0.9.4
+- Changes
+  * The following events: node_{manage,unmanage} are now
+node_{add,remove}.
+- Additions
+  * New monitor/desktop/node descriptors: any, newest.
+  * New node flag: marked.
+  * New monitor descriptor: pointed.
+  * New wm command: --reorder-monitors.
+  * Receptacles are now described in the manual.
+  * New --follow option added to node -{m,d,n,s} and desktop
+-{m,s}.
+  * The subscribe command now has the following options: --fifo,
+--count.
+  * New settings: ignore_ewmh_fullscreen, mapping_events_count.
+
+---

Old:

  bspwm-0.9.3.tar.gz

New:

  bspwm-0.9.4.tar.gz



Other differences:
--
++ bspwm.spec ++
--- /var/tmp/diff_new_pack.jAzkL2/_old  2018-03-30 12:08:00.088478517 +0200
+++ /var/tmp/diff_new_pack.jAzkL2/_new  2018-03-30 12:08:00.092478372 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   bspwm
-Version:0.9.3
+Version:0.9.4
 Release:0
 Summary:A tiling window manager based on binary space partitioning
 License:BSD-2-Clause

++ bspwm-0.9.3.tar.gz -> bspwm-0.9.4.tar.gz ++
 4431 lines of diff (skipped)




commit netdata for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package netdata for openSUSE:Factory checked 
in at 2018-03-30 12:07:37

Comparing /work/SRC/openSUSE:Factory/netdata (Old)
 and  /work/SRC/openSUSE:Factory/.netdata.new (New)


Package is "netdata"

Fri Mar 30 12:07:37 2018 rev:6 rq:591762 version:1.10.0

Changes:

--- /work/SRC/openSUSE:Factory/netdata/netdata.changes  2018-01-13 
21:44:39.550432985 +0100
+++ /work/SRC/openSUSE:Factory/.netdata.new/netdata.changes 2018-03-30 
12:07:43.589075072 +0200
@@ -1,0 +2,235 @@
+Tue Mar 27 20:06:12 UTC 2018 - 9+suse@cirno.systems
+
+- Remove _service
+- Add GPG signature
+- Use %license macro
+- Update to v1.10.0
+  * new plugins:
+- BTRFS - monitor the allocations of BTRFS filesystems (netdata can now
+  properly detect when btrfs is going out of space)
+- BCACHE - monitor the caching block layer that allows building hybrid
+  disks using normal HDDs and SSDs
+- Ceph - monitor ceph distributed storage
+- nginx plus - monitor the nginx+ web servers
+- libreswan - monitor IPSEC tunnels
+- Traefik - monitor traefik reverse proxies
+- icecast - monitor icecast streaming servers
+- ntpd - monitor NTP servers
+- httpcheck - monitor any remote web server
+- portcheck - monitor any remote TCP port
+- spring-boot - monitor java spring boot applications
+- dnsdist - monitor dnsdist name servers
+- hugepages - monitor the allocation of Linux hugepages
+  * enhanced/improved plugins:
+- statsd
+  + statsd dimensions now support the options the external plugin
+dimensions support (currently the only usable option is hidden to add
+the dimension, but make it hidden on the dashboard - a hidden
+dimension can participate in various calculations, including alarms).
+  + statsd now reports the CPU usage of its threads at the netdata
+section.
+  + statsd metrics are logged to access.log the first time they are
+encountered.
+  + statsd metrics now accept the special value zinit to allow them get
+initialized without altering their values (this is useful if you have
+rare metrics that you need to initialize when netdata starts).
+  + statsd over TCP is now a lot faster - netdata can process up to 3.5mil
+statsd metrics / second using just one core. Added options to control
+the timeouts of TCP statsd connections.
+  + fixed the title and context of statsd private charts
+  + statsd private charts can now be hidden from the dashboard
+- web_log
+  + Added web server response timings histogram
+- containers monitoring
+  + netdata now monitors systemd-nspawn containers.
+  + netdata now renames charts of kubernetes containers.
+  + virsh is now called with -r to avoid prompting for password
+  + cgroup-network is now a lot more strict, preventing unauthorized
+privilege escalation
+  + cgroup-network now searches for container processes in sub-cgroups
+too - this improves the mapping of network interfaces to containers
+  + cgroup-network now works even when there are no veth interfaces
+in the system
+- system memory
+  + treat slab memory as cached
+  + added a new chart for monitoring the memory available for use,
+before hitting swap
+  + netdata now monitors Linux hugepages and (transparent) hugepages
+- diskspace
+  + support huge amounts of mountpoints - netdata was crashing with stack
+overflow due to recursion - now it is a loop, so any number of mount
+points is supported
+- network interfaces
+  + moved tcp passive and active opens to a separate chart, to allow the
+TCP issues dimensions scale better by default
+  + updated the information presented on TCP charts to match the latest
+v4.15 kernel source
+- postgres
+  + new charts:
+checkpointer
+bgwriter
+autovacuum
+replication delta
+WAL archive
+WAL
+temporary files
+  + The postgres plugin now also works when postgres is in recovery mode.
+- rabbitmq
+  + added Erlang run queue chart. This is useful in conjunction with the
+existing Erlang processes chart to get a better overall idea of what's
+going on in the Erlang VM.
+  + added rabbitmq information on the dashboard to complement the charts.
+- apps.plugin
+  netdata prior to this version was detecting the user and group of
+  processes by examining the ownership of /proc/PID/stat. Unfortunately it
+  seems that the owneship of files in /proc do not change when the process
+  switches user. So, netdata could not detect the user and group of
+  processes that started as root and then switched 

commit lollypop-portal for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package lollypop-portal for openSUSE:Factory 
checked in at 2018-03-30 12:08:26

Comparing /work/SRC/openSUSE:Factory/lollypop-portal (Old)
 and  /work/SRC/openSUSE:Factory/.lollypop-portal.new (New)


Package is "lollypop-portal"

Fri Mar 30 12:08:26 2018 rev:6 rq:592288 version:0.9.7

Changes:

--- /work/SRC/openSUSE:Factory/lollypop-portal/lollypop-portal.changes  
2018-03-11 15:25:43.746186810 +0100
+++ /work/SRC/openSUSE:Factory/.lollypop-portal.new/lollypop-portal.changes 
2018-03-30 12:08:29.299422371 +0200
@@ -1,0 +2,6 @@
+Thu Mar 29 11:07:38 UTC 2018 - badshah...@opensuse.org
+
+- Update to version 0.9.7:
+  * Do not allow portal to execute random commands
+
+---

Old:

  lollypop-portal-0.9.6.tar.xz

New:

  lollypop-portal-0.9.7.tar.xz



Other differences:
--
++ lollypop-portal.spec ++
--- /var/tmp/diff_new_pack.xjWnOM/_old  2018-03-30 12:08:30.171390844 +0200
+++ /var/tmp/diff_new_pack.xjWnOM/_new  2018-03-30 12:08:30.171390844 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   lollypop-portal
-Version:0.9.6
+Version:0.9.7
 Release:0
 Summary:Lollypop flatpak portal (advanced features for Lollypop)
 License:GPL-3.0-or-later

++ _service ++
--- /var/tmp/diff_new_pack.xjWnOM/_old  2018-03-30 12:08:30.203389687 +0200
+++ /var/tmp/diff_new_pack.xjWnOM/_new  2018-03-30 12:08:30.203389687 +0200
@@ -1,7 +1,7 @@
 
   
 enable
-0.9.6
+0.9.7
 git
 https://gitlab.gnome.org/gnumdk/lollypop-portal.git
 @PARENT_TAG@

++ _servicedata ++
--- /var/tmp/diff_new_pack.xjWnOM/_old  2018-03-30 12:08:30.223388964 +0200
+++ /var/tmp/diff_new_pack.xjWnOM/_new  2018-03-30 12:08:30.227388820 +0200
@@ -1,4 +1,4 @@
 
 
 https://gitlab.gnome.org/gnumdk/lollypop-portal.git
-  48442e9f54b32eb5aada606a6ef8d8475d0904bb
\ No newline at end of file
+  7ffa717b7892112aa3e8bcbf94a869a740f68e57
\ No newline at end of file

++ lollypop-portal-0.9.6.tar.xz -> lollypop-portal-0.9.7.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lollypop-portal-0.9.6/lollypop-portal.in 
new/lollypop-portal-0.9.7/lollypop-portal.in
--- old/lollypop-portal-0.9.6/lollypop-portal.in2018-03-07 
12:05:33.0 +0100
+++ new/lollypop-portal-0.9.7/lollypop-portal.in2018-03-27 
21:59:41.0 +0200
@@ -158,6 +158,9 @@
 return False
 
 def LaunchTagEditor(self, editor, f):
+TAG_EDITORS = ["kid3-qt", "exfalso", "easytag", "picard", "puddletag"]
+if editor not in TAG_EDITORS:
+return
 argv = [editor, f]
 GLib.spawn_async(argv, flags=GLib.SpawnFlags.SEARCH_PATH)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lollypop-portal-0.9.6/meson.build 
new/lollypop-portal-0.9.7/meson.build
--- old/lollypop-portal-0.9.6/meson.build   2018-03-07 12:05:33.0 
+0100
+++ new/lollypop-portal-0.9.7/meson.build   2018-03-27 21:59:41.0 
+0200
@@ -1,5 +1,5 @@
 project('lollypop-portal',
-  version: '0.9.6',
+  version: '0.9.7',
   meson_version: '>= 0.40.0'
 )
 python = import('python3')




commit squid for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package squid for openSUSE:Factory checked 
in at 2018-03-30 12:07:45

Comparing /work/SRC/openSUSE:Factory/squid (Old)
 and  /work/SRC/openSUSE:Factory/.squid.new (New)


Package is "squid"

Fri Mar 30 12:07:45 2018 rev:57 rq:592192 version:4.0.24

Changes:

--- /work/SRC/openSUSE:Factory/squid/squid.changes  2018-02-20 
17:56:17.275844576 +0100
+++ /work/SRC/openSUSE:Factory/.squid.new/squid.changes 2018-03-30 
12:07:50.152837751 +0200
@@ -1,0 +2,11 @@
+Wed Mar 28 09:01:14 UTC 2018 - adam.ma...@suse.de
+
+- New upstream version 4.2.24
+  + Bug 4505: SMP caches sometimes do not purge entries
+  + TPROXY: Fix clientside_mark and client port logging
+  + Native FTP: Fix "Cannot assign requested address" with TPROXY
+  + SSL-Bump: Fix authentication with types other than Basic
+  + ... and some documentation fixes
+- install license correctly (bsc#1082318) and transition to SPDXv3
+
+---

Old:

  squid-4.0.23.tar.xz
  squid-4.0.23.tar.xz.asc

New:

  squid-4.0.24.tar.xz
  squid-4.0.24.tar.xz.asc



Other differences:
--
++ squid.spec ++
--- /var/tmp/diff_new_pack.L1OWSd/_old  2018-03-30 12:07:51.140802030 +0200
+++ /var/tmp/diff_new_pack.L1OWSd/_new  2018-03-30 12:07:51.144801885 +0200
@@ -19,10 +19,10 @@
 %define squidlibdir %{_libdir}/squid
 %define squidconfdir %{_sysconfdir}/squid
 Name:   squid
-Version:4.0.23
+Version:4.0.24
 Release:0
 Summary:Caching and forwarding HTTP web proxy
-License:GPL-2.0+
+License:GPL-2.0-or-later
 Group:  Productivity/Networking/Web/Proxy
 Url:http://www.squid-cache.org
 Source0:http://www.squid-cache.org/Versions/v4/squid-%{version}.tar.xz
@@ -240,7 +240,8 @@
 
 %files
 %defattr(-,root,root)
-%doc ChangeLog CONTRIBUTORS COPYING CREDITS
+%license COPYING
+%doc ChangeLog CONTRIBUTORS CREDITS
 %doc QUICKSTART README RELEASENOTES.html SPONSORS*
 %doc README.kerberos
 %doc doc/contrib doc/scripts

++ squid-4.0.23.tar.xz -> squid-4.0.24.tar.xz ++
 9136 lines of diff (skipped)

++ squid-4.0.23.tar.xz.asc -> squid-4.0.24.tar.xz.asc ++
--- /work/SRC/openSUSE:Factory/squid/squid-4.0.23.tar.xz.asc2018-01-24 
15:32:23.209079848 +0100
+++ /work/SRC/openSUSE:Factory/.squid.new/squid-4.0.24.tar.xz.asc   
2018-03-30 12:07:49.324867687 +0200
@@ -1,25 +1,25 @@
-File: squid-4.0.23.tar.xz
-Date: Fri Jan 19 13:39:51 UTC 2018
-Size: 2415132
-MD5 : 04eb448f1dc31b4b2d73fee6a91c240c
-SHA1: 0bd4248b412e88087ba37686bc27b08480995a9d
+File: squid-4.0.24.tar.xz
+Date: Wed Mar  7 15:09:08 UTC 2018
+Size: 2420076
+MD5 : dcb167d7677ff469c1c59b0baad8a5be
+SHA1: 8c9bbe539af5f1060d93d30d7e099a6badc1f3e1
 Key : CD6DBF8EF3B17D3E 
 B068 84ED B779 C89B 044E  64E3 CD6D BF8E F3B1 7D3E
   keyring = http://www.squid-cache.org/pgp.asc
   keyserver = pool.sks-keyservers.net
 -BEGIN PGP SIGNATURE-
 
-iQIzBAABCgAdFiEEsGiE7bd5yJsETmTjzW2/jvOxfT4FAlph9S8ACgkQzW2/jvOx
-fT4Acg/+JmF+1Y+pwI/cFwFJNbgY3+9Lo2jWtV929Faip/h7MoRdm4eGUB6DW4ts
-3xn0prfIlOHSzg+GO7wda+/AWUe2V2VY3UKfd7HrxJ9PIr9RCUYOTFucIvW+7Jpd
-MqxHhohURQKKUfOHHPzenGPoZdnI+pyf6sK7xL11rnDNyPd7P8MqZc6QCa4WrfI9
-Z9fmTwuXH7r4kP4uPhqi1pEa5awM1UEJPPF+ovl5s8JcfsYPtN/c6FKAZf0wzz+s
-SxuJIx/6JB4wIepOVMNEMObOzfhLqM96w3CAFGaDLi1w4dVfBqMknVEikArlbEKV
-zvtkKevYsnkbmOYbFdsyqyr4+8VnzAor+RBauXc3H5DT5yUFryBLXzQxIc7EgBOn
-b69pr3VhLctjtsHpdWRGFzxRh//EDNEYSHspoOqURivUTtR1U/qIV/pJ5P38hBfr
-udXy7gFTrrny3nA3fGvK7Lr+yDW72V2z2oMqR0TKPKAJkrmDAyX11svdEBBNJjpt
-yzQUWHoWvlzZ8YJlBbTh1gGjXT1SEhSVQBbYcgZJb7fy/WVJg2TS5uf965Xckvig
-uFGdHnjkWeJHLFZUciHabxwdXroIj/rRymR+vRb/sqmuVroT4pMaS1sx96SUHfyD
-OoGK/KeCHeP9xYywlAFb/mzd+bRkL9O2+sb0yjLtgSEMB9A5HQs=
-=z1t9
+iQIzBAABCgAdFiEEsGiE7bd5yJsETmTjzW2/jvOxfT4FAlqgAJwACgkQzW2/jvOx
+fT7HgBAAnyzIsJ95aFGQGKsXxxzXMQkjrWu2XQS6Fg9oJ/jFtS99msvoRZXLzpTs
+m5/n0QIk9h9xXPs8iOsfJLUymslw8LLOMIfljFVfxBId8pb4wcKf+OTGRjnmrqFy
+5btu1xr5kZuKSbNzP5KXet6KOitkkC+siuCfaZ5a8Zuf+aJRQBoc9v9ETbfnXesg
+kJWUd7G7BgvxCYC8x/dstabi3iA8qWk1zE01fZ2V9Xa5Cx4zYe7G6XFqG79VoMyd
+uaLBWhC055Xf8Pt87KSBDrSgQMrFTlnwi/ybAROIXbF3B0FEVtBbRmjI9YvOAhIM
+dMassujNGwFFcIFq2ghh6EHgChreV+zRqLOghGRy5+A0d9lUNKRGTOFHhJAMauKs
+ipMFJuc6oKL22TGaFyRJmQjY+F/Fkow99k7M3XMtMp8Ybl0APgCU35ac0F9UkeSh
+lU68Y4ZzBn2//z+vRDF4AtJuwCAec1uHWFp8LsXjVMJHa3xKONy766LYIZJnYU4p
+Pco0UGDT0bKl5xSA0a3Awx2FYsQn7Ng9TSmgk2G+GJrWNfqEPqdZ9xaCuW78GwvG
+41QYQTALAsfWjzVYVvPxSkELPNdZp7tn8PKrJZhEoLDkxO3cC1p1WrOUrLFzsTi+
++iDtv9RNtvHpGuzQ8MDl5Ek7pYOlNhP/ecDAJQ1/gXljspYZoIo=
+=3OwY
 -END PGP SIGNATURE-





commit unrar_wrapper for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package unrar_wrapper for openSUSE:Factory 
checked in at 2018-03-30 12:08:17

Comparing /work/SRC/openSUSE:Factory/unrar_wrapper (Old)
 and  /work/SRC/openSUSE:Factory/.unrar_wrapper.new (New)


Package is "unrar_wrapper"

Fri Mar 30 12:08:17 2018 rev:2 rq:592285 version:1.0.0

Changes:

--- /work/SRC/openSUSE:Factory/unrar_wrapper/unrar_wrapper.changes  
2018-03-24 16:14:23.537634057 +0100
+++ /work/SRC/openSUSE:Factory/.unrar_wrapper.new/unrar_wrapper.changes 
2018-03-30 12:08:25.047576099 +0200
@@ -1,0 +2,6 @@
+Thu Mar 29 10:37:17 UTC 2018 - kstreit...@suse.com
+
+- remove python3-devel BuildRequires that is not needed 
+- fix license
+
+---



Other differences:
--
++ unrar_wrapper.spec ++
--- /var/tmp/diff_new_pack.GFIuyL/_old  2018-03-30 12:08:25.847547176 +0200
+++ /var/tmp/diff_new_pack.GFIuyL/_new  2018-03-30 12:08:25.859546742 +0200
@@ -20,11 +20,10 @@
 Version:1.0.0
 Release:0
 Summary:Provides a backwards compatibility between unar and unrar
-License:GPL-3.0-only
+License:GPL-3.0
 Group:  Productivity/Archiving/Compression
 URL:https://github.com/openSUSE/unrar_wrapper
 Source: 
https://github.com/openSUSE/unrar_wrapper/archive/unrar_wrapper-%{version}.tar.gz
-BuildRequires:  python3-devel
 BuildRequires:  python3-setuptools
 Requires:   unar
 Conflicts:  unrar




commit datamash for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package datamash for openSUSE:Factory 
checked in at 2018-03-30 12:07:30

Comparing /work/SRC/openSUSE:Factory/datamash (Old)
 and  /work/SRC/openSUSE:Factory/.datamash.new (New)


Package is "datamash"

Fri Mar 30 12:07:30 2018 rev:2 rq:591694 version:1.3

Changes:

--- /work/SRC/openSUSE:Factory/datamash/datamash.changes2018-03-20 
22:00:06.354231035 +0100
+++ /work/SRC/openSUSE:Factory/.datamash.new/datamash.changes   2018-03-30 
12:07:33.389443852 +0200
@@ -1,0 +2,8 @@
+Fri Mar 23 08:43:03 UTC 2018 - guillaume.gar...@opensuse.org
+
+- Disable broken test with upstream patch:
+  * upstream-disable-broken-test.patch
+- Fix another test
+  * upstream-fix-test.patch
+
+---

New:

  upstream-disable-broken-test.patch
  upstream-fix-test.patch



Other differences:
--
++ datamash.spec ++
--- /var/tmp/diff_new_pack.xdIwjc/_old  2018-03-30 12:07:37.933279563 +0200
+++ /var/tmp/diff_new_pack.xdIwjc/_new  2018-03-30 12:07:37.937279419 +0200
@@ -20,12 +20,16 @@
 Version:1.3
 Release:0
 Summary:Statistical, numerical and textual operations in the command 
line
-License:GPL-3.0+
+License:GPL-3.0-or-later
 Group:  Productivity/Scientific/Math
-URL:https://www.gnu.org/software/datamash/
+Url:https://www.gnu.org/software/datamash/
 Source: https://ftp.gnu.org/gnu/datamash/%{name}-%{version}.tar.gz
 Source2:https://ftp.gnu.org/gnu/datamash/%{name}-%{version}.tar.gz.sig
 Source3:
https://savannah.gnu.org/project/memberlist-gpgkeys.php?group=datamash=1#/%{name}.keyring
+# PTACH-FIX-UPSTREAM upstream-disable-broken-test.patch guilla...@opensuse.org 
-- Disable broken test (fix AArch64)
+Patch0: upstream-disable-broken-test.patch
+# PATCH-FIX-UPSTREAM upstream-fix-test.patch guilla...@opensuse.org -- Rework 
a test (fix armv7l and PPC64)
+Patch1: upstream-fix-test.patch
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(openssl)
 Requires(post): %{install_info_prereq}
@@ -37,6 +41,8 @@
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 
 %build
 %configure \



++ upstream-disable-broken-test.patch ++
>From f4871963974a96d6e69cb80b9c2fac7ff0c1d472 Mon Sep 17 00:00:00 2001
From: Assaf Gordon 
Date: Thu, 22 Mar 2018 11:18:13 -0600
Subject: tests: disable --format="%a" test

Valid output can differ (e.g. 0x8.000p-3 vs 0x1.000p+0).

* tests/datamash-output-format.pl: Disable 'a1' test.
---
 tests/datamash-output-format.pl | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/tests/datamash-output-format.pl b/tests/datamash-output-format.pl
index ca99bb0..5e90ae0 100755
--- a/tests/datamash-output-format.pl
+++ b/tests/datamash-output-format.pl
@@ -90,7 +90,9 @@ my @Tests =
   ['e2', '--format "%.3e"  sum 1', {IN_PIPE=>$in1}, {OUT=>"1.000e+00\n"}],
 
   # Test Custom formats: %a
-  ['a1', '--format "%0.3a" sum 1', {IN_PIPE=>$in1}, {OUT=>"0x8.000p-3\n"}],
+  # Disable the test for now. Valid output can differ (e.g. 0x8.000p-3 and
+  # 0x1.000p0 ).
+  # ['a1', '--format "%0.3a" sum 1', {IN_PIPE=>$in1}, {OUT=>"0x8.000p-3\n"}],
 
 
   # Custom formats can use lots of memory
-- 
cgit v1.0-41-gc330

++ upstream-fix-test.patch ++
>From d446dba317aa067440d6312d955d523129949327 Mon Sep 17 00:00:00 2001
From: Assaf Gordon 
Date: Thu, 22 Mar 2018 11:00:34 -0600
Subject: tests: fix --format='%4000f' expected output

Can be 1.09... or 1.08999, depending on representation.

* tests/datamash-output-format.pl: Check only the first 5 digits.
---
 tests/datamash-output-format.pl | 9 +
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/tests/datamash-output-format.pl b/tests/datamash-output-format.pl
index 52c68a2..ca99bb0 100755
--- a/tests/datamash-output-format.pl
+++ b/tests/datamash-output-format.pl
@@ -98,12 +98,13 @@ my @Tests =
{OUT => "0" x 3999 . "1\n"}],
 
   # due to binary floating representation, some decimal point digits won't be
-  # zero (e.g. 1.09052345325432000...).
-  # The OUT_SUBST replaces exactly 3994 digits (as expected from the format)
+  # zero (e.g. 1.09052345325432000... or
+  # 1.0899...).
+  # The OUT_SUBST replaces exactly 3995 digits (as expected from the format)
   # with an "X".
   ['m2', '--format "%.4000f"   sum 1',  {IN_PIPE=>$in1},
-   {OUT => "1.09X\n"},
-   {OUT_SUBST => 's/^(1\.09)([0-9]{3994})$/\1X/'}],
+   {OUT => "1.0X\n"},
+   {OUT_SUBST => 's/^(1\.0)([0-9]{3995})$/\1X/'}],
 
 );
 
-- 
cgit v1.0-41-gc330




commit yast2-auth-server for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package yast2-auth-server for 
openSUSE:Factory checked in at 2018-03-30 12:07:58

Comparing /work/SRC/openSUSE:Factory/yast2-auth-server (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-auth-server.new (New)


Package is "yast2-auth-server"

Fri Mar 30 12:07:58 2018 rev:18 rq:592204 version:3.2.2

Changes:

--- /work/SRC/openSUSE:Factory/yast2-auth-server/yast2-auth-server.changes  
2018-02-20 17:59:27.161008442 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-auth-server.new/yast2-auth-server.changes 
2018-03-30 12:08:03.368359929 +0200
@@ -1,0 +2,6 @@
+Mon Mar 19 09:30:15 UTC 2018 - h...@suse.com
+
+- Fix unreliable server setup routine caused by incorrect handling
+  of external program IO (bsc#1081324), bump to version 3.2.2.
+
+---

Old:

  yast2-auth-server-3.2.1.tar.bz2

New:

  yast2-auth-server-3.2.2.tar.bz2



Other differences:
--
++ yast2-auth-server.spec ++
--- /var/tmp/diff_new_pack.5uARzy/_old  2018-03-30 12:08:04.136332163 +0200
+++ /var/tmp/diff_new_pack.5uARzy/_new  2018-03-30 12:08:04.136332163 +0200
@@ -20,7 +20,7 @@
 Summary:A tool for creating identity management server instances
 License:GPL-2.0+
 Group:  System/YaST
-Version:3.2.1
+Version:3.2.2
 Release:0
 Source0:%{name}-%{version}.tar.bz2
 Url:https://github.com/yast/yast-auth-server

++ yast2-auth-server-3.2.1.tar.bz2 -> yast2-auth-server-3.2.2.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-auth-server-3.2.1/package/yast2-auth-server.changes 
new/yast2-auth-server-3.2.2/package/yast2-auth-server.changes
--- old/yast2-auth-server-3.2.1/package/yast2-auth-server.changes   
2018-02-20 13:52:11.0 +0100
+++ new/yast2-auth-server-3.2.2/package/yast2-auth-server.changes   
2018-03-29 11:34:33.0 +0200
@@ -1,4 +1,10 @@
 ---
+Mon Mar 19 09:30:15 UTC 2018 - h...@suse.com
+
+- Fix unreliable server setup routine caused by incorrect handling
+  of external program IO (bsc#1081324), bump to version 3.2.2.
+
+---
 Mon Feb 19 13:49:24 UTC 2018 - h...@suse.com
 
 - Upgrade to version 3.2.1 that resolves issues in setting up
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-auth-server-3.2.1/package/yast2-auth-server.spec 
new/yast2-auth-server-3.2.2/package/yast2-auth-server.spec
--- old/yast2-auth-server-3.2.1/package/yast2-auth-server.spec  2018-02-20 
13:52:11.0 +0100
+++ new/yast2-auth-server-3.2.2/package/yast2-auth-server.spec  2018-03-29 
11:34:33.0 +0200
@@ -18,7 +18,7 @@
 Name:   yast2-auth-server
 Group: System/YaST
 Summary:   A tool for creating identity management server instances
-Version:3.2.1
+Version:3.2.2
 Release:0
 License:GPL-2.0+
 Source0:%{name}-%{version}.tar.bz2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-auth-server-3.2.1/src/lib/authserver/dir/client.rb 
new/yast2-auth-server-3.2.2/src/lib/authserver/dir/client.rb
--- old/yast2-auth-server-3.2.1/src/lib/authserver/dir/client.rb
2018-02-20 13:52:11.0 +0100
+++ new/yast2-auth-server-3.2.2/src/lib/authserver/dir/client.rb
2018-03-29 11:34:33.0 +0200
@@ -55,7 +55,7 @@
   def change_password(dn, new_pass)
 stdin, stdouterr, result = Open3.popen2e('/usr/bin/ldappasswd', '-H', 
@url, '-x', '-D', @bind_dn, '-w', @bind_pw, '-s', new_pass, dn)
 stdin.close
-return [stdouterr.gets, result.value.exitstatus == 0]
+return [stdouterr.readlines.join('\n'), result.value.exitstatus == 0]
   end
 
   # aci_allow_modify adds an ACI rule that allows user to modify a tree.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-auth-server-3.2.1/src/lib/authserver/dir/ds389.rb 
new/yast2-auth-server-3.2.2/src/lib/authserver/dir/ds389.rb
--- old/yast2-auth-server-3.2.1/src/lib/authserver/dir/ds389.rb 2018-02-20 
13:52:11.0 +0100
+++ new/yast2-auth-server-3.2.2/src/lib/authserver/dir/ds389.rb 2018-03-29 
11:34:33.0 +0200
@@ -58,9 +58,9 @@
   # Returns true only if setup was successful.
   def self.exec_setup(content)
 open(DS_SETUP_INI_PATH, 'w') {|fh| fh.puts(content)}
-_, stdouterr, result = Open3.popen2e('/usr/sbin/setup-ds.pl', '--debug', 
'--silent', '-f', DS_SETUP_INI_PATH)
-append_to_log(stdouterr.gets)
-stdouterr.close
+   

commit engauge-digitizer for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package engauge-digitizer for 
openSUSE:Factory checked in at 2018-03-30 12:07:23

Comparing /work/SRC/openSUSE:Factory/engauge-digitizer (Old)
 and  /work/SRC/openSUSE:Factory/.engauge-digitizer.new (New)


Package is "engauge-digitizer"

Fri Mar 30 12:07:23 2018 rev:20 rq:591657 version:10.4

Changes:

--- /work/SRC/openSUSE:Factory/engauge-digitizer/engauge-digitizer.changes  
2018-03-07 10:38:51.701423157 +0100
+++ /work/SRC/openSUSE:Factory/.engauge-digitizer.new/engauge-digitizer.changes 
2018-03-30 12:07:29.597580952 +0200
@@ -1,0 +2,13 @@
+Tue Mar 27 04:03:59 UTC 2018 - stefan.bru...@rwth-aachen.de
+
+- Fix build on Leap 42.x, remove space in OPENJPEG_INCLUDE
+- Cleanup spec file/build
+  + Do not build source documentation in PDF format, drop TeXlive
+BuildRequires
+  + Move source documentation to devel-doc subpackage
+  + Move standalone HTML user manual to doc subpackage
+  + Fix path to QCH help files
+  + Shrink documentation images using optipng
+  + trivial cleanups
+
+---



Other differences:
--
++ engauge-digitizer.spec ++
--- /var/tmp/diff_new_pack.oBX1RC/_old  2018-03-30 12:07:30.589545086 +0200
+++ /var/tmp/diff_new_pack.oBX1RC/_new  2018-03-30 12:07:30.589545086 +0200
@@ -30,11 +30,8 @@
 BuildRequires:  gcc-c++
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  icns-utils
+BuildRequires:  optipng
 BuildRequires:  pkgconfig
-BuildRequires:  texlive-epstopdf-bin
-BuildRequires:  texlive-latex-bin
-BuildRequires:  texlive-makeindex-bin
-BuildRequires:  texlive-metafont-bin
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(Qt5Core)
 BuildRequires:  pkgconfig(Qt5Gui)
@@ -49,29 +46,9 @@
 BuildRequires:  pkgconfig(libopenjp2)
 BuildRequires:  pkgconfig(log4cpp)
 BuildRequires:  pkgconfig(poppler-qt5)
-BuildRequires:  tex(8r.enc)
-BuildRequires:  tex(adjustbox.sty)
-BuildRequires:  tex(caption.sty)
-BuildRequires:  tex(colortbl.sty)
-BuildRequires:  tex(fancyhdr.sty)
-BuildRequires:  tex(float.sty)
-BuildRequires:  tex(geometry.sty)
-BuildRequires:  tex(helvet.sty)
-BuildRequires:  tex(hyperref.sty)
-BuildRequires:  tex(multirow.sty)
-BuildRequires:  tex(natbib.sty)
-BuildRequires:  tex(pcrr8t.tfm)
-BuildRequires:  tex(phvr8t.tfm)
-BuildRequires:  tex(sectsty.sty)
-BuildRequires:  tex(tabu.sty)
-BuildRequires:  tex(textcomp.sty)
-BuildRequires:  tex(tocloft.sty)
-BuildRequires:  tex(wasy7.tfm)
-BuildRequires:  tex(wasysym.sty)
-BuildRequires:  tex(xtab.sty)
 Requires(post): desktop-file-utils
 Requires(postun): desktop-file-utils
-Recommends: %{name}-doc
+Suggests:   %{name}-doc
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -89,67 +66,66 @@
 %description doc
 This package contains the documentation for Engauge Digitizer.
 
+%package devel-doc
+Summary:Development documentation for Engauge Digitizer
+Group:  Documentation/HTML
+Requires:   %{name} = %{version}
+BuildArch:  noarch
+
+%description devel-doc
+This package contains the development documentation for Engauge Digitizer.
+
 %prep
 %setup -q
 
 %build
 # ADD JPEG2000 SUPPORT
-export OPENJPEG_INCLUDE=$(pkg-config --cflags-only-I libopenjp2 | sed -e 
's@-I@@g')
+export OPENJPEG_INCLUDE=$(pkg-config --cflags-only-I libopenjp2 | sed -e 
's@-I\(\S\+\).*@\1@g')
 export OPENJPEG_LIB=%{_libdir}
 export POPPLER_INCLUDE=%{_includedir}/poppler/qt5
 export POPPLER_LIB=%{_libdir}
 
 qmake-qt5 engauge.pro \
-  "DEFINES+=HELPDIR=%{_docdir}/%{name}/help" \
+  "DEFINES+=HELPDIR=%{_docdir}/%{name}/" \
   QMAKE_CFLAGS="%optflags -fno-strict-aliasing" \
   QMAKE_CXXFLAGS="%optflags -fno-strict-aliasing" \
   CONFIG+="pdf jpeg2000"
 make %{?_smp_mflags}
 
-#HELP files
+# HELP files
 pushd help
+# CRLF -> LF
+sed -i 's/\r$//' engauge.qhcp dateformats.css dateformats.html
+optipng -o2 *png
 qcollectiongenerator-qt5 engauge.qhcp -o engauge.qhc
-mv engauge.qch ../bin/documentation
-mv engauge.qhc ../bin/documentation
-rm -f build
-rm .gitignore
-for f in engauge.qhcp dateformats.css
-do
-  sed -i 's/\r$//' ${f}
-done
+mv engauge.qch engauge.qhc ../
+rm build build.mingw engauge.qhcp .gitignore
 popd
 
-#HTML/Latex documentation files
+# Generate source code documentation in HTML format
 pushd src
+sed -i 's/\(GENERATE_LATEX.*\)=.*/\1 = NO/' Doxyfile
 doxygen
 popd
 
-pushd doc/doxygen/latex
-make pdf
-popd
-
 %install
 install -Dm 755 bin/engauge %{buildroot}%{_bindir}/engauge
 
-#INSTALL HI-RES ICONS
+# INSTALL HI-RES ICONS
 pushd src/img
 icns2png -x digitizer.icns
-for sz in 16 32 128 256 512;
-do
+for sz in 16 32 128 256 512; do
   install -Dm 0644 digitizer_${sz}x${sz}x32.png 

commit WoeUSB for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package WoeUSB for openSUSE:Factory checked 
in at 2018-03-30 12:07:50

Comparing /work/SRC/openSUSE:Factory/WoeUSB (Old)
 and  /work/SRC/openSUSE:Factory/.WoeUSB.new (New)


Package is "WoeUSB"

Fri Mar 30 12:07:50 2018 rev:4 rq:592195 version:3.1.5

Changes:

--- /work/SRC/openSUSE:Factory/WoeUSB/WoeUSB.changes2018-03-20 
22:00:28.813422410 +0100
+++ /work/SRC/openSUSE:Factory/.WoeUSB.new/WoeUSB.changes   2018-03-30 
12:07:54.580677657 +0200
@@ -1,0 +2,21 @@
+Thu Mar 29 05:43:11 UTC 2018 - guoyunhebr...@gmail.com
+
+- Version 3.1.5
+  * Packaging: Debian: Downgrade debian/compat to 9 to match debian/control
+  * Packaging: Debian: Downgrade debhelper dependency to v9 to support Ubuntu 
14.04(till April 2019)
+  * Packaging: Debian: Add missing build dependency: dh-autoreconf
+  * Packaging: Debian: Depend on grub2-common instead of grub-common
+  * Packaging: Debian: Add gettext package as build dependencies
+  * Merge branch 'master' of github.com:slacka/WoeUSB
+  * Manpages: woeusbgui(1): Fix typo
+  * Add VCS- fields to debian/control
+  * Remove versioned dependencies where satisfied by all releases since 
oldoldstable (Wheezy)
+  * Remove dependencies on essential packages as they're always there
+  * Fix priority-extra-is-replaced-by-priority-optional
+  * Bump Debian Standards Version to 4.1.1
+  * build-depends-on-1-revision build-depends: coreutils (>= 8.23-1)
+  * Remove trailing whitespace
+  * Fix obsolete-relation-form-in-source in woeusb depends: bash (>4.3)
+  * core: Eliminate abused double quotes
+
+---

Old:

  WoeUSB-3.1.4.tar.gz

New:

  WoeUSB-3.1.5.tar.gz



Other differences:
--
++ WoeUSB.spec ++
--- /var/tmp/diff_new_pack.Pa7Cp2/_old  2018-03-30 12:07:55.112658423 +0200
+++ /var/tmp/diff_new_pack.Pa7Cp2/_new  2018-03-30 12:07:55.112658423 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   WoeUSB
-Version:3.1.4
+Version:3.1.5
 Release:0
 Summary:Windows USB installation media creator
 License:GPL-3.0-or-later

++ WoeUSB-3.1.4.tar.gz -> WoeUSB-3.1.5.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/WoeUSB-3.1.4/debian/changelog 
new/WoeUSB-3.1.5/debian/changelog
--- old/WoeUSB-3.1.4/debian/changelog   2017-11-12 07:43:44.0 +0100
+++ new/WoeUSB-3.1.5/debian/changelog   2018-03-19 22:28:23.0 +0100
@@ -3,5 +3,5 @@
   * This is a fake changelog for packaging purpose, for the actual changelog 
pl-
 ease refer Commits · slacka/WoeUSB
 
-   
- -- 林博仁 (Buo-Ren, Lin)   Mon, 12 Jun 2017 09:04:00 +0100
+
+ -- 林博仁 (Buo-Ren, Lin)   Wed, 15 Nov 2017 09:04:00 +0100
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/WoeUSB-3.1.4/debian/compat 
new/WoeUSB-3.1.5/debian/compat
--- old/WoeUSB-3.1.4/debian/compat  2017-11-12 07:43:44.0 +0100
+++ new/WoeUSB-3.1.5/debian/compat  2018-03-19 22:28:23.0 +0100
@@ -1 +1 @@
-10
+9
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/WoeUSB-3.1.4/debian/control 
new/WoeUSB-3.1.5/debian/control
--- old/WoeUSB-3.1.4/debian/control 2017-11-12 07:43:44.0 +0100
+++ new/WoeUSB-3.1.5/debian/control 2018-03-19 22:28:23.0 +0100
@@ -1,28 +1,29 @@
 Source: woeusb
 Homepage: https://github.com/slacka/WoeUSB
 Section: utils
-Priority: extra
+Priority: optional
 Maintainer: 林博仁 (Buo-Ren, Lin) 
-Build-Depends: debhelper (>= 10),
+Build-Depends: debhelper (>= 9),
+   dh-autoreconf,
git-core,
-   libwxgtk2.8-dev (>= 2.8.4) | libwxgtk3.0-dev,
-   realpath | coreutils (>= 8.23-1)
-Standards-Version: 3.8.1
+   libwxgtk2.8-dev | libwxgtk3.0-dev,
+   realpath | coreutils (>= 8.23)
+Standards-Version: 4.1.1
+Vcs-Browser: https://github.com/slacka/WoeUSB/
+Vcs-Git: https://github.com/slacka/WoeUSB.git
 
 Package: woeusb
 Architecture: any
-Depends: bash (>4.3),
+Depends: bash (>=4.3),
  dosfstools,
- findutils,
- grep,
- grub-common,
+ gettext,
+ grub2-common,
  grub-pc-bin,
- ntfsprogs | ntfs-3g (>= 1:2011),
+ ntfsprogs | ntfs-3g,
  p7zip-full,
  parted,
  policykit-1,
  realpath | coreutils (>= 8.23),
- util-linux, 
  wget,
  ${misc:Depends},
  ${shlibs:Depends}
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 

commit ntpsec for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package ntpsec for openSUSE:Factory checked 
in at 2018-03-30 12:08:04

Comparing /work/SRC/openSUSE:Factory/ntpsec (Old)
 and  /work/SRC/openSUSE:Factory/.ntpsec.new (New)


Package is "ntpsec"

Fri Mar 30 12:08:04 2018 rev:8 rq:592276 version:1.1.0

Changes:

--- /work/SRC/openSUSE:Factory/ntpsec/ntpsec.changes2017-12-01 
15:54:12.122819527 +0100
+++ /work/SRC/openSUSE:Factory/.ntpsec.new/ntpsec.changes   2018-03-30 
12:08:04.576316254 +0200
@@ -1,0 +2,21 @@
+Thu Mar 29 10:43:16 UTC 2018 - tchva...@suse.com
+
+- Version update to 1.1.0:
+  * Digests longer then 20 bytes will be truncated.
+  * We have merged NTP Classic's fix for CVE-2018-7182.
+  * we have dropped support for Broadcast servers.  We had kept it for
+older desktop operating systems listening on the local network
+broadcast domain, a use case that is now no longer in use at sane
+enviroments, and no longer necessary for modern desktop OSs.
+  * It is now possible to unpeer refclocks using a type/unit specification
+rather than a magic IP address.  This was the last obligatory use of
+magic IP addresses in the configuration grammar.
+  * OpenBSD has been removed from the list of supported platforms for
+ntpd. It will be restored if and when its clock API supports drift
+adjustment via ntp_adjtime() or equivalent facility.
+  * Mac OS X support has been dropped pending the implementation of
+ntp_adjtime(2).
+  * A bug that caused the rejection of 33% of packets from Amazon time
+service has been fixed.
+
+---

Old:

  ntpsec-1.0.0.tar.gz
  ntpsec-1.0.0.tar.gz.asc

New:

  ntpsec-1.1.0.tar.gz
  ntpsec-1.1.0.tar.gz.asc



Other differences:
--
++ ntpsec.spec ++
--- /var/tmp/diff_new_pack.QpxvNx/_old  2018-03-30 12:08:05.776272869 +0200
+++ /var/tmp/diff_new_pack.QpxvNx/_new  2018-03-30 12:08:05.776272869 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package ntpsec
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2016 Malcolm J Lewis 
 #
 # All modifications and additions to the file contributed by third parties
@@ -18,12 +18,12 @@
 
 
 Name:   ntpsec
-Version:1.0.0
+Version:1.1.0
 Release:0
 Summary:Improved implementation of Network Time Protocol
 License:BSD-2-Clause AND NTP AND BSD-3-Clause AND MIT
 Group:  System/Base
-Url:https://www.ntpsec.org/
+URL:https://www.ntpsec.org/
 Source0:ftp://ftp.ntpsec.org/pub/releases/%{name}-%{version}.tar.gz
 Source1:ftp://ftp.ntpsec.org/pub/releases/%{name}-%{version}.tar.gz.asc
 Source3:%{name}.changes
@@ -53,7 +53,7 @@
 Recommends: logrotate
 # For ntpleapfetch
 Recommends: wget
-Conflicts:  otherproviders(ntp-daemon)
+Conflicts:  ntp-daemon
 Provides:   ntp-daemon
 
 %description
@@ -173,6 +173,7 @@
 %{_bindir}/ntpviz
 %{_bindir}/ntpwait
 %{_bindir}/ntplogtemp
+%{_bindir}/ntpsnmpd
 %{_mandir}/man1/ntploggps.1%{?ext_man}
 %{_mandir}/man1/ntpdig.1%{?ext_man}
 %{_mandir}/man8/ntpkeygen.8%{?ext_man}
@@ -183,11 +184,13 @@
 %{_mandir}/man1/ntpviz.1%{?ext_man}
 %{_mandir}/man8/ntpwait.8%{?ext_man}
 %{_mandir}/man1/ntplogtemp.1%{?ext_man}
+%{_mandir}/man8/ntpsnmpd.8%{?ext_man}
 %{_sbindir}/rcntp-wait
 %{_unitdir}/ntp-wait.service
 
 %files
-%doc NEWS README LICENSE
+%license LICENSE
+%doc NEWS README
 %config(noreplace) %{_sysconfdir}/ntp.conf
 %{_sbindir}/rcntpd
 %{_bindir}/ntpfrob

++ ntpsec-1.0.0.tar.gz -> ntpsec-1.1.0.tar.gz ++
 37920 lines of diff (skipped)




commit perl-IPC-Run for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package perl-IPC-Run for openSUSE:Factory 
checked in at 2018-03-30 12:07:43

Comparing /work/SRC/openSUSE:Factory/perl-IPC-Run (Old)
 and  /work/SRC/openSUSE:Factory/.perl-IPC-Run.new (New)


Package is "perl-IPC-Run"

Fri Mar 30 12:07:43 2018 rev:34 rq:592070 version:0.97

Changes:

--- /work/SRC/openSUSE:Factory/perl-IPC-Run/perl-IPC-Run.changes
2018-01-06 18:51:01.954063893 +0100
+++ /work/SRC/openSUSE:Factory/.perl-IPC-Run.new/perl-IPC-Run.changes   
2018-03-30 12:07:45.325012306 +0200
@@ -1,0 +2,18 @@
+Wed Mar 28 14:35:32 UTC 2018 - pmonrealgonza...@suse.com
+
+- Fixed build on ppc and ppc64 architectures.
+- Refreshed spec file with spec-clean.
+
+---
+Tue Mar 27 05:27:33 UTC 2018 - co...@suse.com
+
+- updated to 0.97
+   see /usr/share/doc/packages/perl-IPC-Run/Changes
+
+  0.97 Mon Mar 26 2018
+   - Update meta and POD to point to GitHub issues not RT.
+   - Update README with pod changes.
+   - Fix variable name in synopsis - [Github #47]
+   - Fix t/run.t to work on "perl in space" - [Github #100]
+
+---

Old:

  IPC-Run-0.96.tar.gz

New:

  IPC-Run-0.97.tar.gz



Other differences:
--
++ perl-IPC-Run.spec ++
--- /var/tmp/diff_new_pack.hc6iSG/_old  2018-03-30 12:07:45.868992638 +0200
+++ /var/tmp/diff_new_pack.hc6iSG/_new  2018-03-30 12:07:45.872992494 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-IPC-Run
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,13 +18,13 @@
 
 %define cpan_name IPC-Run
 Name:   perl-IPC-Run
-Version:0.96
+Version:0.97
 Release:0
 Summary:System() and Background Procs W/ Piping, Redirs, Ptys (Unix, 
Win32)
-License:Artistic-1.0 OR GPL-1.0+
+License:Artistic-1.0 OR GPL-1.0-or-later
 Group:  Development/Libraries/Perl
 Url:http://search.cpan.org/dist/IPC-Run/
-Source0:
http://www.cpan.org/authors/id/T/TO/TODDR/%{cpan_name}-%{version}.tar.gz
+Source0:
https://cpan.metacpan.org/authors/id/T/TO/TODDR/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 Patch0: IPC-Run-0.89-path.diff
 BuildRequires:  perl
@@ -68,6 +68,8 @@
 %perl_gen_filelist
 
 %files -f %{name}.files
-%doc Changes LICENSE README TODO
+%defattr(-,root,root,755)
+%doc Changes README TODO
+%license LICENSE
 
 %changelog

++ IPC-Run-0.96.tar.gz -> IPC-Run-0.97.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/IPC-Run-0.96/META.json new/IPC-Run-0.97/META.json
--- old/IPC-Run-0.96/META.json  2017-05-12 15:47:24.0 +0200
+++ new/IPC-Run-0.97/META.json  2018-03-26 23:41:45.0 +0200
@@ -4,7 +4,7 @@
   "Barrie Slaymaker "
],
"dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 7.1002, CPAN::Meta::Converter 
version 2.150005",
+   "generated_by" : "ExtUtils::MakeMaker version 7.24, CPAN::Meta::Converter 
version 2.150010",
"license" : [
   "perl_5"
],
@@ -53,6 +53,6 @@
  "url" : "https://github.com/toddr/IPC-Run;
   }
},
-   "version" : "0.96",
-   "x_serialization_backend" : "JSON::PP version 2.27300_01"
+   "version" : "0.97",
+   "x_serialization_backend" : "JSON::PP version 2.27400_02"
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/IPC-Run-0.96/META.yml new/IPC-Run-0.97/META.yml
--- old/IPC-Run-0.96/META.yml   2017-05-12 15:47:24.0 +0200
+++ new/IPC-Run-0.97/META.yml   2018-03-26 23:41:44.0 +0200
@@ -8,7 +8,7 @@
 configure_requires:
   ExtUtils::MakeMaker: '0'
 dynamic_config: 1
-generated_by: 'ExtUtils::MakeMaker version 7.1002, CPAN::Meta::Converter 
version 2.150005'
+generated_by: 'ExtUtils::MakeMaker version 7.24, CPAN::Meta::Converter version 
2.150010'
 license: perl
 meta-spec:
   url: http://module-build.sourceforge.net/META-spec-v1.4.html
@@ -27,5 +27,5 @@
   bugtracker: https://github.com/toddr/IPC-Run/issues
   license: http://dev.perl.org/licenses/
   repository: https://github.com/toddr/IPC-Run
-version: '0.96'
+version: '0.97'
 x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/IPC-Run-0.96/README new/IPC-Run-0.97/README
--- old/IPC-Run-0.96/README 2017-05-12 15:35:53.0 +0200
+++ 

commit plasma5-workspace for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package plasma5-workspace for 
openSUSE:Factory checked in at 2018-03-30 12:06:38

Comparing /work/SRC/openSUSE:Factory/plasma5-workspace (Old)
 and  /work/SRC/openSUSE:Factory/.plasma5-workspace.new (New)


Package is "plasma5-workspace"

Fri Mar 30 12:06:38 2018 rev:88 rq:592013 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/plasma5-workspace/plasma5-workspace.changes  
2018-03-20 21:49:51.676364100 +0100
+++ /work/SRC/openSUSE:Factory/.plasma5-workspace.new/plasma5-workspace.changes 
2018-03-30 12:06:53.690879217 +0200
@@ -1,0 +2,46 @@
+Wed Mar 28 11:46:36 UTC 2018 - fab...@ritter-vogt.de
+
+- Don't require plasma5-workspace in plasma5-workspace-devel,
+  it pulls in a lot of unnecessary requirements and can cause
+  build loops
+
+---
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * [notifications applet] Fix two qml warnings about assigning [undefined]
+  * Remove long-time deprecated Encoding=UTF-8 from desktop format files
+  * [Run Command] Pass "event" to runCurrentIndex
+  * Move to KRunner's second results item with a single keypress (kde#392197)
+  * Pass proper click coordinates to SNI ContextMenu calls
+  * libdbusmenu-qt: Remove nonexistant actions directly from the menu
+  * Set a transient parent for SNI context menus
+  * [DeviceNotifications Engine] Never show safely remove message when 
mounting (kde#391180)
+  * Use dbus-run-session instead of dbus-launch --exit-with-session
+  * [System Tray] Fix hiding applets with HiddenStatus
+  * [Notifications] Remove NoAccessNetworkAccessManagerFactory
+  * Improve By Desktop sorting for task groups (kde#384747)
+  * Use separate config group for each wallpaper plugin
+  * Fix duplicated [Desktop Entry] sections in two menu directory files
+- Remove patches, now upstream:
+  * 0001-Use-dbus-run-session-instead-of-dbus-launch-exit-wit.patch
+
+---
+Sat Mar 24 11:11:34 UTC 2018 - fab...@ritter-vogt.de
+
+- Add patches to not set QT_QPA_PLATFORM in a wayland session:
+  * 0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch
+  * 0002-Add-platform-detection-to-KWorkspace-library-to-adju.patch
+  * 0003-No-longer-export-QT_QPA_PLATFORM-env-variable-to-the.patch
+  * 0001-Set-XDG_SESSION_TYPE-wayland-in-startplasmacomposito.patch
+- Set GDK_BACKEND=x11 to work around GTK3 bugs:
+  * 0001-Set-GTK_BACKEND-x11-in-a-wayland-session.patch
+- Add a suffix to the wayland session's name:
+  * 0001-Add-suffix-to-the-wayland-session-s-name.patch
+- Apply upstream patches before downstream patches
+
+---

Old:

  0001-Use-dbus-run-session-instead-of-dbus-launch-exit-wit.patch
  plasma-workspace-5.12.3.tar.xz

New:

  0001-Add-suffix-to-the-wayland-session-s-name.patch
  0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch
  0001-Set-GTK_BACKEND-x11-in-a-wayland-session.patch
  0001-Set-XDG_SESSION_TYPE-wayland-in-startplasmacomposito.patch
  0002-Add-platform-detection-to-KWorkspace-library-to-adju.patch
  0003-No-longer-export-QT_QPA_PLATFORM-env-variable-to-the.patch
  plasma-workspace-5.12.4.tar.xz



Other differences:
--
++ plasma5-workspace.spec ++
--- /var/tmp/diff_new_pack.2bWMEM/_old  2018-03-30 12:06:57.158753829 +0200
+++ /var/tmp/diff_new_pack.2bWMEM/_new  2018-03-30 12:06:57.162753685 +0200
@@ -27,7 +27,7 @@
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}
 # Lasted ABI-stable Plasma (e.g. 5.8 in KF5, but 5.9.1 in KUF)
 %{!?_plasma5_version: %global _plasma5_version %(echo %{_plasma5_bugfix} | awk 
-F. '{print $1"."$2}')}
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:The KDE Plasma Workspace Components
 License:GPL-2.0+
@@ -35,13 +35,21 @@
 Url:http://www.kde.org/
 Source: 
http://download.kde.org/stable/plasma/%{version}/plasma-workspace-%{version}.tar.xz
 Source1:baselibs.conf
+# PATCHES 000-100 and above are from upstream 5.12 branch
+# PATCHES 101-500 are from upstream master/5.13 branch
+Patch201:   0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch
+Patch202:   0002-Add-platform-detection-to-KWorkspace-library-to-adju.patch
+Patch203:   0003-No-longer-export-QT_QPA_PLATFORM-env-variable-to-the.patch
+# PATCHES 501-??? are PATCH-FIX-OPENSUSE
 # PATCH-FIX-OPENSUSE 0001-Rename-qdbus-in-startkde.patch cgiboude...@gmx.com 
-- Rename the 

commit kde-cli-tools5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kde-cli-tools5 for openSUSE:Factory 
checked in at 2018-03-30 12:06:32

Comparing /work/SRC/openSUSE:Factory/kde-cli-tools5 (Old)
 and  /work/SRC/openSUSE:Factory/.kde-cli-tools5.new (New)


Package is "kde-cli-tools5"

Fri Mar 30 12:06:32 2018 rev:66 rq:592011 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kde-cli-tools5/kde-cli-tools5.changes
2018-03-09 10:31:13.303894746 +0100
+++ /work/SRC/openSUSE:Factory/.kde-cli-tools5.new/kde-cli-tools5.changes   
2018-03-30 12:06:32.415648465 +0200
@@ -1,0 +2,18 @@
+Wed Mar 28 08:20:00 UTC 2018 - fab...@ritter-vogt.de
+
+- Add patches to support wayland sessions without QT_QPA_PLUGIN:
+  * 0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch
+  * 0002-Use-platform-detection-from-KWorkSpace-in-KCMShell.patch
+  * 0003-Fix-build-in-kcmshell5-accidentially-landed-the-wron.patch
+
+---
+Tue Mar 27 15:40:47 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  kde-cli-tools-5.12.3.tar.xz

New:

  0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch
  0002-Use-platform-detection-from-KWorkSpace-in-KCMShell.patch
  0003-Fix-build-in-kcmshell5-accidentially-landed-the-wron.patch
  kde-cli-tools-5.12.4.tar.xz



Other differences:
--
++ kde-cli-tools5.spec ++
--- /var/tmp/diff_new_pack.1NZcxF/_old  2018-03-30 12:06:33.039625904 +0200
+++ /var/tmp/diff_new_pack.1NZcxF/_new  2018-03-30 12:06:33.039625904 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   kde-cli-tools5
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:Additional CLI tools for KDE applications
 License:GPL-2.0+
@@ -27,9 +27,14 @@
 Source: 
http://download.kde.org/stable/plasma/%{version}/kde-cli-tools-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE kdesu-add-some-i18n-love.patch -- boo#852256
 Patch0: kdesu-add-some-i18n-love.patch
+# PATCH-FIX-UPSTREAM
+Patch1: 0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch
+Patch2: 0002-Use-platform-detection-from-KWorkSpace-in-KCMShell.patch
+Patch3: 0003-Fix-build-in-kcmshell5-accidentially-landed-the-wron.patch
 BuildRequires:  extra-cmake-modules >= 1.3.0
 BuildRequires:  kf5-filesystem
 BuildRequires:  xz
+# Needs KWorkSpace::detectPlatform
 BuildRequires:  cmake(KF5Activities) >= 5.16.0
 BuildRequires:  cmake(KF5Config) >= 5.16.0
 BuildRequires:  cmake(KF5DocTools) >= 5.16.0
@@ -41,6 +46,7 @@
 BuildRequires:  cmake(KF5KIO) >= 5.16.0
 BuildRequires:  cmake(KF5Su) >= 5.16.0
 BuildRequires:  cmake(KF5WindowSystem) >= 5.16.0
+BuildRequires:  cmake(LibKWorkspace) >= 5.12.3
 BuildRequires:  cmake(Qt5DBus) >= 5.4.0
 BuildRequires:  cmake(Qt5Svg) >= 5.4.0
 BuildRequires:  cmake(Qt5Test) >= 5.4.0
@@ -63,7 +69,7 @@
 %lang_package
 %prep
 %setup -q -n kde-cli-tools-%{version}
-%patch0 -p1
+%autopatch -p1
 
 %build
   %cmake_kf5 -d build

++ 0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch ++
>From e83437e6e5caf39c1c5df4e7ab5600440e43ff28 Mon Sep 17 00:00:00 2001
From: "Friedrich W. H. Kossebau" 
Date: Sat, 10 Feb 2018 14:04:57 +0100
Subject: [PATCH 1/3] Call KLocalizedString::setApplicationDomain after Q*App
 creation

As now recommended, to ensure all locale settings are done from Qt side
---
 kcmshell/main.cpp | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kcmshell/main.cpp b/kcmshell/main.cpp
index dd4ed1c..93dd6f8 100644
--- a/kcmshell/main.cpp
+++ b/kcmshell/main.cpp
@@ -173,9 +173,9 @@ void KCMShell::appExit(const QString , const QString 
, const QStri
 
 extern "C" Q_DECL_EXPORT int kdemain(int _argc, char *_argv[])
 {
+KCMShell app(_argc, _argv);
 KLocalizedString::setApplicationDomain("kcmshell5");
 
-KCMShell app(_argc, _argv);
 app.setAttribute(Qt::AA_UseHighDpiPixmaps, true);
 
 KAboutData aboutData("kcmshell5", i18n("System Settings Module"),
-- 
2.16.2

++ 0002-Use-platform-detection-from-KWorkSpace-in-KCMShell.patch ++
>From cc5f6765b3e25f411120d2100fb14f0d69de75a1 Mon Sep 17 00:00:00 2001
From: Fabian Vogt 
Date: Tue, 27 Mar 2018 09:24:09 +0200
Subject: [PATCH 2/3] Use platform detection from KWorkSpace in KCMShell

Summary: In a Wayland session, KCMs need to use the wayland platform plugin.

Test Plan: kcmshell5 kscreen now works properly.

Reviewers: #plasma, romangg

Reviewed By: #plasma, romangg


commit plasma5-openSUSE for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package plasma5-openSUSE for 
openSUSE:Factory checked in at 2018-03-30 12:06:50

Comparing /work/SRC/openSUSE:Factory/plasma5-openSUSE (Old)
 and  /work/SRC/openSUSE:Factory/.plasma5-openSUSE.new (New)


Package is "plasma5-openSUSE"

Fri Mar 30 12:06:50 2018 rev:69 rq:592080 
version:15.0~git20180328T172058~30e1414

Changes:

--- /work/SRC/openSUSE:Factory/plasma5-openSUSE/plasma5-openSUSE.changes
2018-03-09 10:33:34.662806006 +0100
+++ /work/SRC/openSUSE:Factory/.plasma5-openSUSE.new/plasma5-openSUSE.changes   
2018-03-30 12:07:05.906437541 +0200
@@ -1,0 +2,19 @@
+Wed Mar 28 15:24:24 UTC 2018 - fab...@ritter-vogt.de
+
+- Update to 20180328T172058~30e1414:
+  * Enable native file dialogs in digikam and showfoto
+
+---
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+
+---
+Thu Mar 22 14:23:54 UTC 2018 - fab...@ritter-vogt.de
+
+- Update to 20180322T150725~d7ae3c4:
+  * Provide kcm-about-distrorc in the tarball
+  * Add a new distributor icon
+  * Add a new splash screen
+
+---

Old:

  plasma-opensuse-15.0~git20180116T134836~c3ce1b2.tar.xz

New:

  _service
  plasma-opensuse-15.0~git20180328T172058~30e1414.tar.xz



Other differences:
--
++ plasma5-openSUSE.spec ++
--- /var/tmp/diff_new_pack.fyFvnW/_old  2018-03-30 12:07:06.914401097 +0200
+++ /var/tmp/diff_new_pack.fyFvnW/_new  2018-03-30 12:07:06.918400952 +0200
@@ -16,9 +16,9 @@
 #
 
 
-%define plasma_version 5.12.3
+%define plasma_version 5.12.4
 Name:   plasma5-openSUSE
-Version:15.0~git20180116T134836~c3ce1b2
+Version:15.0~git20180328T172058~30e1414
 Release:0
 Summary:openSUSE KDE Extension
 License:GPL-2.0+ AND CC-BY-SA-4.0
@@ -133,9 +133,6 @@
 mkdir -p %{buildroot}/%{_sysconfdir}/kde4/share/config/
 cp %{buildroot}/%{_kf5_configdir}/kdeglobals 
%{buildroot}/%{_sysconfdir}/kde4/share/config/
 
-# Distro icon (kinfocenter)
-echo -e 
"[General]\nLogoPath=%{_kf5_sharedir}/icons/hicolor/128x128/apps/SUSEgreeter.png\nWebsite=http://www.opensuse.org/;
 > %{buildroot}/%{_kf5_configdir}/kcm-about-distrorc
-
 # Look-and-feel package (copy over everything that is not already in the .tar, 
then apply patch)
 rsync -av --ignore-existing 
%{_kf5_plasmadir}/look-and-feel/org.kde.breeze.desktop/ 
%{buildroot}%{_kf5_plasmadir}/look-and-feel/org.openSUSE.desktop/
 pushd %{buildroot}%{_kf5_plasmadir}/look-and-feel/org.openSUSE.desktop/

++ _service ++

  
git://github.com/openSUSE/plasma-opensuse.git
git
15.0~git%ci~%h
leap-15.x
  
  
  
*.tar
xz
  
  

++ plasma-opensuse-15.0~git20180116T134836~c3ce1b2.tar.xz -> 
plasma-opensuse-15.0~git20180328T172058~30e1414.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/plasma-opensuse-15.0~git20180116T134836~c3ce1b2/config-files/etc/xdg/digikamrc
 
new/plasma-opensuse-15.0~git20180328T172058~30e1414/config-files/etc/xdg/digikamrc
--- 
old/plasma-opensuse-15.0~git20180116T134836~c3ce1b2/config-files/etc/xdg/digikamrc
  1970-01-01 01:00:00.0 +0100
+++ 
new/plasma-opensuse-15.0~git20180328T172058~30e1414/config-files/etc/xdg/digikamrc
  2018-03-28 17:20:58.0 +0200
@@ -0,0 +1,2 @@
+[General Settings]
+Use Native File Dialog=true
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/plasma-opensuse-15.0~git20180116T134836~c3ce1b2/config-files/etc/xdg/kcm-about-distrorc
 
new/plasma-opensuse-15.0~git20180328T172058~30e1414/config-files/etc/xdg/kcm-about-distrorc
--- 
old/plasma-opensuse-15.0~git20180116T134836~c3ce1b2/config-files/etc/xdg/kcm-about-distrorc
 1970-01-01 01:00:00.0 +0100
+++ 
new/plasma-opensuse-15.0~git20180328T172058~30e1414/config-files/etc/xdg/kcm-about-distrorc
 2018-03-28 17:20:58.0 +0200
@@ -0,0 +1,4 @@
+[General]
+LogoPath=/usr/share/icons/hicolor/scalable/apps/openSUSE-distributor-logo.svg
+Website=http://www.opensuse.org
+
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/plasma-opensuse-15.0~git20180116T134836~c3ce1b2/config-files/etc/xdg/showfotorc
 
new/plasma-opensuse-15.0~git20180328T172058~30e1414/config-files/etc/xdg/showfotorc
--- 
old/plasma-opensuse-15.0~git20180116T134836~c3ce1b2/config-files/etc/xdg/showfotorc
 1970-01-01 01:00:00.0 +0100
+++ 
new/plasma-opensuse-15.0~git20180328T172058~30e1414/config-files/etc/xdg/showfotorc
 2018-03-28 17:20:58.0 +0200
@@ -0,0 +1,2 @@
+[ImageViewer 

commit polkit-kde-agent-5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package polkit-kde-agent-5 for 
openSUSE:Factory checked in at 2018-03-30 12:06:10

Comparing /work/SRC/openSUSE:Factory/polkit-kde-agent-5 (Old)
 and  /work/SRC/openSUSE:Factory/.polkit-kde-agent-5.new (New)


Package is "polkit-kde-agent-5"

Fri Mar 30 12:06:10 2018 rev:55 rq:591856 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/polkit-kde-agent-5/polkit-kde-agent-5.changes
2018-03-09 10:33:20.855303082 +0100
+++ 
/work/SRC/openSUSE:Factory/.polkit-kde-agent-5.new/polkit-kde-agent-5.changes   
2018-03-30 12:06:14.288303900 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:49 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  polkit-kde-agent-1-5.12.3.tar.xz

New:

  polkit-kde-agent-1-5.12.4.tar.xz



Other differences:
--
++ polkit-kde-agent-5.spec ++
--- /var/tmp/diff_new_pack.2wEFbi/_old  2018-03-30 12:06:15.916245037 +0200
+++ /var/tmp/diff_new_pack.2wEFbi/_new  2018-03-30 12:06:15.920244892 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   polkit-kde-agent-5
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:PolicyKit authentication agent for KDE
 License:GPL-2.0 and LGPL-2.1+

++ polkit-kde-agent-1-5.12.3.tar.xz -> polkit-kde-agent-1-5.12.4.tar.xz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/polkit-kde-agent-1-5.12.3/CMakeLists.txt 
new/polkit-kde-agent-1-5.12.4/CMakeLists.txt
--- old/polkit-kde-agent-1-5.12.3/CMakeLists.txt2018-03-06 
14:04:38.0 +0100
+++ new/polkit-kde-agent-1-5.12.4/CMakeLists.txt2018-03-27 
13:29:56.0 +0200
@@ -1,5 +1,5 @@
 project(polkit-kde-agent-1)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 
 # minimal requirements
 cmake_minimum_required (VERSION 2.8.12 FATAL_ERROR)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/polkit-kde-agent-1-5.12.3/po/ca@valencia/polkit-kde-authentication-agent-1.po
 
new/polkit-kde-agent-1-5.12.4/po/ca@valencia/polkit-kde-authentication-agent-1.po
--- 
old/polkit-kde-agent-1-5.12.3/po/ca@valencia/polkit-kde-authentication-agent-1.po
   2018-03-06 14:04:18.0 +0100
+++ 
new/polkit-kde-agent-1-5.12.4/po/ca@valencia/polkit-kde-authentication-agent-1.po
   2018-03-27 13:29:42.0 +0200
@@ -99,7 +99,7 @@
 "Authentication is required to perform this action."
 msgstr ""
 "Una aplicació està intentant de dur a terme una acció que requereix "
-"privilegis. Cal autentificar-se per dur a terme esta acció."
+"privilegis. Cal autentificar-se per dur a terme aquesta acció."
 
 #: AuthDialog.cpp:222
 #, kde-format
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/polkit-kde-agent-1-5.12.3/po/zh_CN/polkit-kde-authentication-agent-1.po 
new/polkit-kde-agent-1-5.12.4/po/zh_CN/polkit-kde-authentication-agent-1.po
--- old/polkit-kde-agent-1-5.12.3/po/zh_CN/polkit-kde-authentication-agent-1.po 
2018-03-06 14:04:38.0 +0100
+++ new/polkit-kde-agent-1-5.12.4/po/zh_CN/polkit-kde-authentication-agent-1.po 
2018-03-27 13:29:56.0 +0200
@@ -8,7 +8,7 @@
 "Project-Id-Version: kdeorg\n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 "POT-Creation-Date: 2016-11-19 20:22+0100\n"
-"PO-Revision-Date: 2018-03-05 17:19-0500\n"
+"PO-Revision-Date: 2018-03-18 19:40-0400\n"
 "Last-Translator: guoyunhebrave \n"
 "Language-Team: Chinese Simplified\n"
 "Language: zh_CN\n"




commit powerdevil5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package powerdevil5 for openSUSE:Factory 
checked in at 2018-03-30 12:06:18

Comparing /work/SRC/openSUSE:Factory/powerdevil5 (Old)
 and  /work/SRC/openSUSE:Factory/.powerdevil5.new (New)


Package is "powerdevil5"

Fri Mar 30 12:06:18 2018 rev:62 rq:591857 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/powerdevil5/powerdevil5.changes  2018-03-09 
10:33:26.195110847 +0100
+++ /work/SRC/openSUSE:Factory/.powerdevil5.new/powerdevil5.changes 
2018-03-30 12:06:21.548041407 +0200
@@ -1,0 +2,16 @@
+Tue Mar 27 15:40:49 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---
+Sat Mar 24 10:57:58 UTC 2018 - fab...@ritter-vogt.de
+
+- Add patch to support wayland sessions without QT_QPA_PLATFORM:
+  * 0001-Use-platform-detection-from-KWorkspace-in-Powerdevil.patch
+
+---

Old:

  powerdevil-5.12.3.tar.xz

New:

  0001-Use-platform-detection-from-KWorkspace-in-Powerdevil.patch
  powerdevil-5.12.4.tar.xz



Other differences:
--
++ powerdevil5.spec ++
--- /var/tmp/diff_new_pack.SiCsDE/_old  2018-03-30 12:06:22.256015808 +0200
+++ /var/tmp/diff_new_pack.SiCsDE/_new  2018-03-30 12:06:22.260015664 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   powerdevil5
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}
@@ -29,8 +29,9 @@
 Group:  System/GUI/KDE
 Url:http://www.kde.org
 Source: 
http://download.kde.org/stable/plasma/%{version}/powerdevil-%{version}.tar.xz
-# PATCHES 100-200 and above are from upstream 5.9 branch
-# PATCHES 201-300 and above are from upstream master/5.10 branch
+# PATCHES 000-100 and above are from upstream 5.12 branch
+# PATCHES 101-200 and above are from upstream master/5.13 branch
+Patch101:   0001-Use-platform-detection-from-KWorkspace-in-Powerdevil.patch
 BuildRequires:  extra-cmake-modules >= 1.2.0
 BuildRequires:  kf5-filesystem
 BuildRequires:  xz
@@ -76,6 +77,7 @@
 %lang_package
 %prep
 %setup -q -n powerdevil-%{version}
+%autopatch -p1
 
 %build
   %cmake_kf5 -d build -- -DCMAKE_INSTALL_LOCALEDIR=%{_kf5_localedir}

++ 0001-Use-platform-detection-from-KWorkspace-in-Powerdevil.patch ++
>From 381c7bd212fb4b0ea0afd0c8bc0e7e92319c6b33 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Martin=20Fl=C3=B6ser?= 
Date: Sun, 18 Mar 2018 09:55:05 +0100
Subject: [PATCH] Use platform detection from KWorkspace in Powerdevil

Summary: On a wayland session powerdevil needs to use Wayland platform.

Test Plan:
Only compile tested, changes are identical to the tested
systemsettings patch.

Reviewers: #plasma

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D11446
---
 CMakeLists.txt   | 2 ++
 daemon/CMakeLists.txt| 1 +
 daemon/powerdevilapp.cpp | 3 +++
 3 files changed, 6 insertions(+)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index c239067..20a11ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,8 @@ add_feature_info(
 "Support turning off signal-transmitting devices to save energy"
 )
 
+find_package(LibKWorkspace ${PROJECT_VERSION} REQUIRED)
+
 find_package(UDev REQUIRED)
 
 find_package(XCB REQUIRED COMPONENTS XCB RANDR DPMS)
diff --git a/daemon/CMakeLists.txt b/daemon/CMakeLists.txt
index fcc9c07..828f284 100644
--- a/daemon/CMakeLists.txt
+++ b/daemon/CMakeLists.txt
@@ -124,6 +124,7 @@ target_link_libraries(powerdevil
 KF5::CoreAddons
 KF5::I18n
 KF5::DBusAddons
+PW::KWorkspace
 powerdevilcore
 )
 if (XCB_FOUND)
diff --git a/daemon/powerdevilapp.cpp b/daemon/powerdevilapp.cpp
index 0737b22..2d292b7 100644
--- a/daemon/powerdevilapp.cpp
+++ b/daemon/powerdevilapp.cpp
@@ -42,6 +42,8 @@
 #include 
 #include 
 
+#include 
+
 PowerDevilApp::PowerDevilApp(int , char **argv)
 : QGuiApplication(argc, argv)
 , m_core(Q_NULLPTR)
@@ -195,6 +197,7 @@ void PowerDevilApp::migratePre512KeyboardShortcuts()
 int main(int argc, char **argv)
 {
 QGuiApplication::setDesktopSettingsAware(false);
+KWorkSpace::detectPlatform(argc, argv);
 PowerDevilApp app(argc, argv);
 
 KDBusService service(KDBusService::Unique);
-- 
2.16.2

++ powerdevil-5.12.3.tar.xz -> powerdevil-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/powerdevil-5.12.3/CMakeLists.txt 

commit plasma5-pa for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package plasma5-pa for openSUSE:Factory 
checked in at 2018-03-30 12:06:02

Comparing /work/SRC/openSUSE:Factory/plasma5-pa (Old)
 and  /work/SRC/openSUSE:Factory/.plasma5-pa.new (New)


Package is "plasma5-pa"

Fri Mar 30 12:06:02 2018 rev:48 rq:591851 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/plasma5-pa/plasma5-pa.changes2018-03-09 
10:33:06.879806202 +0100
+++ /work/SRC/openSUSE:Factory/.plasma5-pa.new/plasma5-pa.changes   
2018-03-30 12:06:09.688470217 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * call beginRemoveRows before removing the data
+
+---

Old:

  plasma-pa-5.12.3.tar.xz

New:

  plasma-pa-5.12.4.tar.xz



Other differences:
--
++ plasma5-pa.spec ++
--- /var/tmp/diff_new_pack.ypeeco/_old  2018-03-30 12:06:10.332446932 +0200
+++ /var/tmp/diff_new_pack.ypeeco/_new  2018-03-30 12:06:10.332446932 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   plasma5-pa
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:The new Plasma5 Volume Manager
 License:GPL-2.0+

++ plasma-pa-5.12.3.tar.xz -> plasma-pa-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/plasma-pa-5.12.3/CMakeLists.txt 
new/plasma-pa-5.12.4/CMakeLists.txt
--- old/plasma-pa-5.12.3/CMakeLists.txt 2018-03-06 13:58:55.0 +0100
+++ new/plasma-pa-5.12.4/CMakeLists.txt 2018-03-27 13:24:56.0 +0200
@@ -1,7 +1,7 @@
 project(plasma-volume-control)
 cmake_minimum_required(VERSION 2.8.12)
 
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 
 set(QT_MIN_VERSION "5.7.0")
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/plasma-pa-5.12.3/po/ca@valencia/kcm_pulseaudio.po 
new/plasma-pa-5.12.4/po/ca@valencia/kcm_pulseaudio.po
--- old/plasma-pa-5.12.3/po/ca@valencia/kcm_pulseaudio.po   2018-03-06 
13:58:00.0 +0100
+++ new/plasma-pa-5.12.4/po/ca@valencia/kcm_pulseaudio.po   2018-03-27 
13:24:16.0 +0200
@@ -112,7 +112,7 @@
 #, kde-format
 msgctxt "@label"
 msgid "No Applications Recording Audio"
-msgstr "No hi ha cap aplicació gravant àudio"
+msgstr "No hi ha cap aplicació enregistrant àudio"
 
 #: kcm/package/contents/ui/CardListItem.qml:51
 #, kde-format
@@ -167,7 +167,7 @@
 #: kcm/package/contents/ui/main.qml:38
 #, kde-format
 msgid "This module allows to set up the Pulseaudio sound subsystem."
-msgstr "Este mòdul permet configurar el subsistema de so PulseAudio."
+msgstr "Aquest mòdul permet configurar el subsistema de so PulseAudio."
 
 #: kcm/package/contents/ui/main.qml:64
 #, kde-format
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/plasma-pa-5.12.3/po/ca@valencia/plasma_applet_org.kde.plasma.volume.po 
new/plasma-pa-5.12.4/po/ca@valencia/plasma_applet_org.kde.plasma.volume.po
--- old/plasma-pa-5.12.3/po/ca@valencia/plasma_applet_org.kde.plasma.volume.po  
2018-03-06 13:58:00.0 +0100
+++ new/plasma-pa-5.12.4/po/ca@valencia/plasma_applet_org.kde.plasma.volume.po  
2018-03-27 13:24:16.0 +0200
@@ -205,7 +205,7 @@
 #: contents/ui/main.qml:446
 #, kde-format
 msgid "No applications playing or recording audio"
-msgstr "No hi ha cap aplicació reproduint o gravant àudio"
+msgstr "No hi ha cap aplicació reproduint o enregistrant àudio"
 
 #: contents/ui/main.qml:458
 #, kde-format
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/plasma-pa-5.12.3/po/fi/plasma_applet_org.kde.plasma.volume.po 
new/plasma-pa-5.12.4/po/fi/plasma_applet_org.kde.plasma.volume.po
--- old/plasma-pa-5.12.3/po/fi/plasma_applet_org.kde.plasma.volume.po   
2018-03-06 13:58:07.0 +0100
+++ new/plasma-pa-5.12.4/po/fi/plasma_applet_org.kde.plasma.volume.po   
2018-03-27 13:24:21.0 +0200
@@ -1,7 +1,7 @@
 # Copyright (C) YEAR This_file_is_part_of_KDE
 # This file is distributed under the same license as the PACKAGE package.
 # Lasse Liehu , 2015, 2016, 2017.
-# Tommi Nieminen , 2016, 2017.
+# Tommi Nieminen , 2016, 2017, 2018.
 #
 msgid ""
 msgstr ""
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/plasma-pa-5.12.3/po/zh_CN/kcm_pulseaudio.po 
new/plasma-pa-5.12.4/po/zh_CN/kcm_pulseaudio.po
--- 

commit plasma5-desktop for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package plasma5-desktop for openSUSE:Factory 
checked in at 2018-03-30 12:05:47

Comparing /work/SRC/openSUSE:Factory/plasma5-desktop (Old)
 and  /work/SRC/openSUSE:Factory/.plasma5-desktop.new (New)


Package is "plasma5-desktop"

Fri Mar 30 12:05:47 2018 rev:81 rq:591848 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/plasma5-desktop/plasma5-desktop.changes  
2018-03-09 10:32:57.168155819 +0100
+++ /work/SRC/openSUSE:Factory/.plasma5-desktop.new/plasma5-desktop.changes 
2018-03-30 12:06:02.340735893 +0200
@@ -1,0 +2,23 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * [Folder View] Fix selecting text with Shift+Home/End (kde#392318)
+  * Make Select/Deselect All operate on the filtered rows.
+  * Remove long-time deprecated Encoding=UTF-8 from desktop format files
+  * [touchpad kded] Work around kded fail on X-KDE-OnlyShowOnQtPlatforms lists
+  * [Touchpad KCM] Sync values to UI on Defaults in Wayland session 
(kde#392029)
+  * [Workspace Options KCM] sync() after writing settings
+  * bad textarea width for rename file if filename too short (kde#386546)
+  * Fix scrollbar on empty search results (kde#391644)
+  * kimpanel: Fix the window positioning when plasma uses native-qt scaling.
+  * Load correct wallpaper plugin configuration in the dialog
+  * Don't skip certain recent documents in kicker and taskmanager
+  * Improve multi-desktop folderview behavior (kde#390676)
+  * Use QUrl in the ScreenMapper API
+  * use opacity instead of visible (kde#391432)
+
+---

Old:

  plasma-desktop-5.12.3.tar.xz

New:

  plasma-desktop-5.12.4.tar.xz



Other differences:
--
++ plasma5-desktop.spec ++
--- /var/tmp/diff_new_pack.avX6hY/_old  2018-03-30 12:06:03.104708270 +0200
+++ /var/tmp/diff_new_pack.avX6hY/_new  2018-03-30 12:06:03.108708124 +0200
@@ -20,7 +20,7 @@
 
 %bcond_without lang
 Name:   plasma5-desktop
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.9.3)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ plasma-desktop-5.12.3.tar.xz -> plasma-desktop-5.12.4.tar.xz ++
/work/SRC/openSUSE:Factory/plasma5-desktop/plasma-desktop-5.12.3.tar.xz 
/work/SRC/openSUSE:Factory/.plasma5-desktop.new/plasma-desktop-5.12.4.tar.xz 
differ: char 25, line 1




commit systemsettings5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package systemsettings5 for openSUSE:Factory 
checked in at 2018-03-30 12:06:25

Comparing /work/SRC/openSUSE:Factory/systemsettings5 (Old)
 and  /work/SRC/openSUSE:Factory/.systemsettings5.new (New)


Package is "systemsettings5"

Fri Mar 30 12:06:25 2018 rev:64 rq:591858 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/systemsettings5/systemsettings5.changes  
2018-03-09 10:33:30.590952595 +0100
+++ /work/SRC/openSUSE:Factory/.systemsettings5.new/systemsettings5.changes 
2018-03-30 12:06:29.755744639 +0200
@@ -1,0 +2,16 @@
+Tue Mar 27 15:40:49 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---
+Sat Mar 24 11:09:18 UTC 2018 - fab...@ritter-vogt.de
+
+- Support wayland sessions without QT_QPA_PLATFORM set:
+  * 0001-Use-platform-detection-in-SystemSettings.patch
+
+---

Old:

  systemsettings-5.12.3.tar.xz

New:

  0001-Use-platform-detection-in-SystemSettings.patch
  systemsettings-5.12.4.tar.xz



Other differences:
--
++ systemsettings5.spec ++
--- /var/tmp/diff_new_pack.pLvi4v/_old  2018-03-30 12:06:31.127695033 +0200
+++ /var/tmp/diff_new_pack.pLvi4v/_new  2018-03-30 12:06:31.131694889 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   systemsettings5
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:KDE's control center
 License:GPL-2.0+
@@ -29,6 +29,8 @@
 Patch0: install_administration_category.diff
 # PATCH-FIX-OPENSUSE systemsettings-desktop.diff -- rename application name to 
Configure Desktop, in order to cause less confusion for KDE4 users
 Patch1: systemsettings-desktop.diff
+# PATCH-FIX-UPSTREAM
+Patch2: 0001-Use-platform-detection-in-SystemSettings.patch
 BuildRequires:  extra-cmake-modules >= 1.2.0
 BuildRequires:  kf5-filesystem
 BuildRequires:  kirigami2-devel
@@ -51,6 +53,7 @@
 BuildRequires:  cmake(KF5Service)
 BuildRequires:  cmake(KF5WindowSystem)
 BuildRequires:  cmake(KF5XmlGui)
+BuildRequires:  cmake(LibKWorkspace)
 BuildRequires:  cmake(Qt5QuickWidgets) >= 5.4.0
 BuildRequires:  cmake(Qt5Widgets) >= 5.4.0
 Requires:   kirigami2 >= 2.1
@@ -74,8 +77,7 @@
 %lang_package
 %prep
 %setup -q -n systemsettings-%{version}
-%patch0 -p1
-%patch1 -p1
+%autopatch -p1
 
 %build
   %cmake_kf5 -d build -- -DCMAKE_INSTALL_LOCALEDIR=%{_kf5_localedir}

++ 0001-Use-platform-detection-in-SystemSettings.patch ++
>From 5405ba3d72482ccfd50c06cdb0bb9df62a9d88cf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Martin=20Fl=C3=B6ser?= 
Date: Sun, 18 Mar 2018 09:48:54 +0100
Subject: [PATCH] Use platform detection in SystemSettings

Summary:
SystemSettings needs to run on Wayland in a Wayland session and on X11
in an X11 session.

Test Plan:
unset QT_QPA_PLATFORM and XDG_SESSION_TYPE -> x11 window,
reset XDG_SESSION_TYPE to wayland -> wayland window

Reviewers: #plasma

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D11445
---
 CMakeLists.txt | 2 ++
 app/CMakeLists.txt | 1 +
 app/main.cpp   | 3 +++
 3 files changed, 6 insertions(+)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 147a4e5..c1d8ec4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,8 @@ ecm_find_qmlmodule(org.kde.kcm 1.0)
 
 find_package(KF5Kirigami2 2.1 REQUIRED)
 
+find_package(LibKWorkspace ${PROJECT_VERSION} REQUIRED)
+
 add_subdirectory(core)
 add_subdirectory(app)
 add_subdirectory(categories)
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index cb97e63..6db59a5 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -28,6 +28,7 @@ target_link_libraries( systemsettings5 systemsettingsview
 KF5::XmlGui
 KF5::DBusAddons
 KF5::ConfigGui
+PW::KWorkspace
 )
 
 install( TARGETS systemsettings5 ${INSTALL_TARGETS_DEFAULT_ARGS} )
diff --git a/app/main.cpp b/app/main.cpp
index ae0d65d..3f1cd34 100644
--- a/app/main.cpp
+++ b/app/main.cpp
@@ -25,6 +25,8 @@
 #include 
 #include 
 
+#include 
+
 #include "SystemSettingsApp.h"
 #include "SettingsBase.h"
 
@@ -33,6 +35,7 @@ int main( int argc, char *argv[] )
 //exec is systemsettings5, but we need the QPT to use the right config 
from the qApp constructor
 //which is before KAboutData::setApplicationData
 QCoreApplication::setApplicationName("systemsettings");
+KWorkSpace::detectPlatform(argc, argv);
 SystemSettingsApp application(argc, argv);
 KCrash::initialize();
 
-- 
2.16.2


commit plasma5-integration for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package plasma5-integration for 
openSUSE:Factory checked in at 2018-03-30 12:05:55

Comparing /work/SRC/openSUSE:Factory/plasma5-integration (Old)
 and  /work/SRC/openSUSE:Factory/.plasma5-integration.new (New)


Package is "plasma5-integration"

Fri Mar 30 12:05:55 2018 rev:41 rq:591849 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/plasma5-integration/plasma5-integration.changes  
2018-03-09 10:33:01.587996706 +0100
+++ 
/work/SRC/openSUSE:Factory/.plasma5-integration.new/plasma5-integration.changes 
2018-03-30 12:06:08.140526187 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  plasma-integration-5.12.3.tar.xz

New:

  plasma-integration-5.12.4.tar.xz



Other differences:
--
++ plasma5-integration.spec ++
--- /var/tmp/diff_new_pack.j0HtXj/_old  2018-03-30 12:06:08.820501600 +0200
+++ /var/tmp/diff_new_pack.j0HtXj/_new  2018-03-30 12:06:08.824501456 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   plasma5-integration
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ plasma-integration-5.12.3.tar.xz -> plasma-integration-5.12.4.tar.xz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/plasma-integration-5.12.3/CMakeLists.txt 
new/plasma-integration-5.12.4/CMakeLists.txt
--- old/plasma-integration-5.12.3/CMakeLists.txt2018-03-06 
13:55:50.0 +0100
+++ new/plasma-integration-5.12.4/CMakeLists.txt2018-03-27 
13:22:41.0 +0200
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.8.12)
 
 project(PlasmaIntegration)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 
 include(FeatureSummary)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/plasma-integration-5.12.3/po/ca@valencia/plasmaintegration5.po 
new/plasma-integration-5.12.4/po/ca@valencia/plasmaintegration5.po
--- old/plasma-integration-5.12.3/po/ca@valencia/plasmaintegration5.po  
2018-03-06 13:56:07.0 +0100
+++ new/plasma-integration-5.12.4/po/ca@valencia/plasmaintegration5.po  
2018-03-27 13:22:52.0 +0200
@@ -98,7 +98,7 @@
 #: platformtheme/kdirselectdialog.cpp:171
 #, kde-format
 msgid "You do not have permission to create that folder."
-msgstr "No teniu permís per crear esta carpeta."
+msgstr "No teniu permís per crear aquesta carpeta."
 
 #: platformtheme/kdirselectdialog.cpp:285
 #, kde-format
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/plasma-integration-5.12.3/po/zh_CN/plasmaintegration5.po 
new/plasma-integration-5.12.4/po/zh_CN/plasmaintegration5.po
--- old/plasma-integration-5.12.3/po/zh_CN/plasmaintegration5.po
2018-03-06 13:56:29.0 +0100
+++ new/plasma-integration-5.12.4/po/zh_CN/plasmaintegration5.po
2018-03-27 13:23:06.0 +0200
@@ -7,7 +7,7 @@
 "Project-Id-Version: kdeorg\n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 "POT-Creation-Date: 2018-01-26 05:50+0100\n"
-"PO-Revision-Date: 2018-03-05 17:18-0500\n"
+"PO-Revision-Date: 2018-03-18 19:39-0400\n"
 "Last-Translator: guoyunhebrave \n"
 "Language-Team: Chinese Simplified\n"
 "Language: zh_CN\n"




commit oxygen5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package oxygen5 for openSUSE:Factory checked 
in at 2018-03-30 12:05:29

Comparing /work/SRC/openSUSE:Factory/oxygen5 (Old)
 and  /work/SRC/openSUSE:Factory/.oxygen5.new (New)


Package is "oxygen5"

Fri Mar 30 12:05:29 2018 rev:65 rq:591843 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/oxygen5/oxygen5.changes  2018-03-09 
10:32:44.712604213 +0100
+++ /work/SRC/openSUSE:Factory/.oxygen5.new/oxygen5.changes 2018-03-30 
12:05:31.901836492 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  oxygen-5.12.3.tar.xz

New:

  oxygen-5.12.4.tar.xz



Other differences:
--
++ oxygen5.spec ++
--- /var/tmp/diff_new_pack.7lUaeM/_old  2018-03-30 12:05:32.589811616 +0200
+++ /var/tmp/diff_new_pack.7lUaeM/_new  2018-03-30 12:05:32.589811616 +0200
@@ -20,7 +20,7 @@
 %define kwin_deco 1
 
 Name:   oxygen5
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ oxygen-5.12.3.tar.xz -> oxygen-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oxygen-5.12.3/CMakeLists.txt 
new/oxygen-5.12.4/CMakeLists.txt
--- old/oxygen-5.12.3/CMakeLists.txt2018-03-06 13:53:12.0 +0100
+++ new/oxygen-5.12.4/CMakeLists.txt2018-03-27 13:20:08.0 +0200
@@ -1,5 +1,5 @@
 project(oxygen)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oxygen-5.12.3/po/ca@valencia/liboxygenstyleconfig.po 
new/oxygen-5.12.4/po/ca@valencia/liboxygenstyleconfig.po
--- old/oxygen-5.12.3/po/ca@valencia/liboxygenstyleconfig.po2018-03-06 
13:53:31.0 +0100
+++ new/oxygen-5.12.4/po/ca@valencia/liboxygenstyleconfig.po2018-03-27 
13:20:20.0 +0200
@@ -54,7 +54,7 @@
 #: ui/oxygengenericanimationconfigbox.ui:38
 #, kde-format
 msgid "Duration:"
-msgstr "Duració:"
+msgstr "Durada:"
 
 #. i18n: ectx: property (suffix), widget (QSpinBox, durationSpinBox)
 #: ui/oxygengenericanimationconfigbox.ui:64
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oxygen-5.12.3/po/ca@valencia/oxygen_kdecoration.po 
new/oxygen-5.12.4/po/ca@valencia/oxygen_kdecoration.po
--- old/oxygen-5.12.3/po/ca@valencia/oxygen_kdecoration.po  2018-03-06 
13:53:31.0 +0100
+++ new/oxygen-5.12.4/po/ca@valencia/oxygen_kdecoration.po  2018-03-27 
13:20:20.0 +0200
@@ -109,7 +109,7 @@
 #: config/oxygenexceptionmodel.cpp:83
 #, kde-format
 msgid "Enable/disable this exception"
-msgstr "Habilita/inhabilita esta excepció"
+msgstr "Habilita/inhabilita aquesta excepció"
 
 #. i18n: ectx: attribute (title), widget (QWidget, tab)
 #: config/ui/oxygenconfigurationui.ui:24
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oxygen-5.12.3/po/ca@valencia/oxygen_style_config.po 
new/oxygen-5.12.4/po/ca@valencia/oxygen_style_config.po
--- old/oxygen-5.12.3/po/ca@valencia/oxygen_style_config.po 2018-03-06 
13:53:31.0 +0100
+++ new/oxygen-5.12.4/po/ca@valencia/oxygen_style_config.po 2018-03-27 
13:20:20.0 +0200
@@ -168,13 +168,13 @@
 #: ui/oxygenfollowmouseanimationconfigbox.ui:59
 #, kde-format
 msgid "Fade duration:"
-msgstr "Duració de l'esvaïment:"
+msgstr "Durada de l'esvaïment:"
 
 #. i18n: ectx: property (text), widget (QLabel, followMouseDurationLabel)
 #: ui/oxygenfollowmouseanimationconfigbox.ui:72
 #, kde-format
 msgid "Follow mouse duration:"
-msgstr "Duració del seguiment del ratolí:"
+msgstr "Durada del seguiment del ratolí:"
 
 #. i18n: ectx: property (suffix), widget (QSpinBox, durationSpinBox)
 #. i18n: ectx: property (suffix), widget (QSpinBox, followMouseDurationSpinBox)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oxygen-5.12.3/po/ca@valencia/oxygen_style_demo.po 
new/oxygen-5.12.4/po/ca@valencia/oxygen_style_demo.po
--- old/oxygen-5.12.3/po/ca@valencia/oxygen_style_demo.po   2018-03-06 
13:53:31.0 +0100
+++ new/oxygen-5.12.4/po/ca@valencia/oxygen_style_demo.po   2018-03-27 
13:20:20.0 +0200
@@ -220,7 +220,7 @@
 #: oxygensimulator.h:91
 #, kde-format
 msgid "This is a sample text"
-msgstr "Este és un 

commit plasma5-addons for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package plasma5-addons for openSUSE:Factory 
checked in at 2018-03-30 12:05:40

Comparing /work/SRC/openSUSE:Factory/plasma5-addons (Old)
 and  /work/SRC/openSUSE:Factory/.plasma5-addons.new (New)


Package is "plasma5-addons"

Fri Mar 30 12:05:40 2018 rev:59 rq:591847 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/plasma5-addons/plasma5-addons.changes
2018-03-09 10:32:50.736387360 +0100
+++ /work/SRC/openSUSE:Factory/.plasma5-addons.new/plasma5-addons.changes   
2018-03-30 12:05:44.553379040 +0200
@@ -1,0 +2,13 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * [konsoleprofiles applet] Do not try to set plasmoid.aspectRatioMode
+  * Fix default colour used by Swap monitor
+  * Drop unused X-Plasma-Requires-* entries from applet metadata
+  * Remove long-time deprecated Encoding=UTF-8 from desktop format files
+
+---

Old:

  kdeplasma-addons-5.12.3.tar.xz

New:

  kdeplasma-addons-5.12.4.tar.xz



Other differences:
--
++ plasma5-addons.spec ++
--- /var/tmp/diff_new_pack.XHUmDO/_old  2018-03-30 12:05:45.485345343 +0200
+++ /var/tmp/diff_new_pack.XHUmDO/_new  2018-03-30 12:05:45.485345343 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   plasma5-addons
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ kdeplasma-addons-5.12.3.tar.xz -> kdeplasma-addons-5.12.4.tar.xz ++
 2345 lines of diff (skipped)




commit milou5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package milou5 for openSUSE:Factory checked 
in at 2018-03-30 12:05:24

Comparing /work/SRC/openSUSE:Factory/milou5 (Old)
 and  /work/SRC/openSUSE:Factory/.milou5.new (New)


Package is "milou5"

Fri Mar 30 12:05:24 2018 rev:62 rq:591842 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/milou5/milou5.changes2018-03-09 
10:32:39.816780458 +0100
+++ /work/SRC/openSUSE:Factory/.milou5.new/milou5.changes   2018-03-30 
12:05:26.478032606 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  milou-5.12.3.tar.xz

New:

  milou-5.12.4.tar.xz



Other differences:
--
++ milou5.spec ++
--- /var/tmp/diff_new_pack.bwXnRl/_old  2018-03-30 12:05:27.042012213 +0200
+++ /var/tmp/diff_new_pack.bwXnRl/_new  2018-03-30 12:05:27.042012213 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   milou5
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:Dedicated search application built on top of Baloo
 License:GPL-2.0+ and LGPL-2.1+

++ milou-5.12.3.tar.xz -> milou-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/milou-5.12.3/CMakeLists.txt 
new/milou-5.12.4/CMakeLists.txt
--- old/milou-5.12.3/CMakeLists.txt 2018-03-06 13:53:08.0 +0100
+++ new/milou-5.12.4/CMakeLists.txt 2018-03-27 13:20:05.0 +0200
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.8.12)
 
 project(Milou)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 
 set(QT_MIN_VERSION "5.9.0")
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/milou-5.12.3/plasmoid/package/metadata.desktop 
new/milou-5.12.4/plasmoid/package/metadata.desktop
--- old/milou-5.12.3/plasmoid/package/metadata.desktop  2018-03-06 
13:52:10.0 +0100
+++ new/milou-5.12.4/plasmoid/package/metadata.desktop  2018-03-27 
13:19:22.0 +0200
@@ -3,7 +3,7 @@
 Name[ast]=Guetar
 Name[bs]=Pretrazivanje
 Name[ca]=Cerca
-Name[ca@valencia]=Busca
+Name[ca@valencia]=Cerca
 Name[cs]=Hledat
 Name[da]=Søg
 Name[de]=Suche
@@ -45,7 +45,7 @@
 Comment=Search and Launch
 Comment[bs]=Traženje i pokretanje
 Comment[ca]=Cerca i llança
-Comment[ca@valencia]=Busca i llança
+Comment[ca@valencia]=Cerca i llança
 Comment[cs]=Hledat a spustit
 Comment[da]=Søg og start
 Comment[de]=Suchen und ausführen
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/milou-5.12.3/po/ca@valencia/milou.po 
new/milou-5.12.4/po/ca@valencia/milou.po
--- old/milou-5.12.3/po/ca@valencia/milou.po2018-03-06 13:52:30.0 
+0100
+++ new/milou-5.12.4/po/ca@valencia/milou.po2018-03-27 13:19:36.0 
+0200
@@ -34,7 +34,7 @@
 #: previews/audioplugin.cpp:59
 #, kde-format
 msgid "Duration:"
-msgstr "Duració:"
+msgstr "Durada:"
 
 #: previews/emailplugin.cpp:99
 #, kde-format
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/milou-5.12.3/po/ca@valencia/plasma_applet_org.kde.milou.po 
new/milou-5.12.4/po/ca@valencia/plasma_applet_org.kde.milou.po
--- old/milou-5.12.3/po/ca@valencia/plasma_applet_org.kde.milou.po  
2018-03-06 13:52:30.0 +0100
+++ new/milou-5.12.4/po/ca@valencia/plasma_applet_org.kde.milou.po  
2018-03-27 13:19:36.0 +0200
@@ -24,21 +24,21 @@
 #: applet.cpp:69
 #, kde-format
 msgid "Search Results"
-msgstr "Resultats de la busca"
+msgstr "Resultats de la cerca"
 
 #: configwidget.cpp:61
 #, kde-format
 msgid "Only the selected components are shown in the search results"
 msgstr ""
-"Només es mostren els components seleccionats en els resultats de la busca"
+"Només es mostren els components seleccionats en els resultats de la cerca"
 
 #: configwidget.cpp:65
 #, kde-format
 msgid "Drag categories to change the order in which results appear"
 msgstr ""
-"Arrossegueu les categories per canviar l'orde en què apareixen els resultats"
+"Arrossegueu les categories per canviar l'ordre en què apareixen els resultats"
 
 #: package/contents/ui/SearchField.qml:54
 #, kde-format
 msgid "Search"
-msgstr "Busca"
\ No newline at end of file
+msgstr "Cerca"
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/milou-5.12.3/po/eu/milou.po 
new/milou-5.12.4/po/eu/milou.po
--- old/milou-5.12.3/po/eu/milou.po 1970-01-01 

commit libksysguard5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package libksysguard5 for openSUSE:Factory 
checked in at 2018-03-30 12:05:19

Comparing /work/SRC/openSUSE:Factory/libksysguard5 (Old)
 and  /work/SRC/openSUSE:Factory/.libksysguard5.new (New)


Package is "libksysguard5"

Fri Mar 30 12:05:19 2018 rev:63 rq:591841 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/libksysguard5/libksysguard5.changes  
2018-03-09 10:32:33.709000333 +0100
+++ /work/SRC/openSUSE:Factory/.libksysguard5.new/libksysguard5.changes 
2018-03-30 12:05:21.694205579 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  libksysguard-5.12.3.tar.xz

New:

  libksysguard-5.12.4.tar.xz



Other differences:
--
++ libksysguard5.spec ++
--- /var/tmp/diff_new_pack.ol1hz1/_old  2018-03-30 12:05:22.382180703 +0200
+++ /var/tmp/diff_new_pack.ol1hz1/_new  2018-03-30 12:05:22.386180559 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   libksysguard5
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:Task management and system monitoring library
 License:GPL-2.0+

++ libksysguard-5.12.3.tar.xz -> libksysguard-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libksysguard-5.12.3/CMakeLists.txt 
new/libksysguard-5.12.4/CMakeLists.txt
--- old/libksysguard-5.12.3/CMakeLists.txt  2018-03-06 13:52:05.0 
+0100
+++ new/libksysguard-5.12.4/CMakeLists.txt  2018-03-27 13:19:16.0 
+0200
@@ -1,5 +1,5 @@
 project(libksysguard)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libksysguard-5.12.3/po/ca@valencia/processui.po 
new/libksysguard-5.12.4/po/ca@valencia/processui.po
--- old/libksysguard-5.12.3/po/ca@valencia/processui.po 2018-03-06 
13:51:25.0 +0100
+++ new/libksysguard-5.12.4/po/ca@valencia/processui.po 2018-03-27 
13:18:46.0 +0200
@@ -36,7 +36,7 @@
 #: ksysguardprocesslist.cpp:205
 #, kde-format
 msgid "Jump to Process Debugging This One"
-msgstr "Salta als processos que depuren este"
+msgstr "Salta als processos que depuren aquest"
 
 #: ksysguardprocesslist.cpp:206
 #, kde-format
@@ -105,7 +105,7 @@
 #: ksysguardprocesslist.cpp:225
 #, kde-format
 msgid "Focus on Quick Search"
-msgstr "Focus a la busca ràpida"
+msgstr "Focus a la cerca ràpida"
 
 #: ksysguardprocesslist.cpp:380
 #, kde-format
@@ -196,7 +196,7 @@
 #: ksysguardprocesslist.cpp:756
 #, kde-format
 msgid "Display command line options"
-msgstr "Mostra les opcions de la línia d'ordes"
+msgstr "Mostra les opcions de la línia d'ordres"
 
 #: ksysguardprocesslist.cpp:763
 #, kde-format
@@ -282,11 +282,11 @@
 "Are you sure you want to end these %1 processes?  Any unsaved work may be "
 "lost"
 msgstr[0] ""
-"Esteu segur que voleu finalitzar este procés? Es perdrà qualsevol treball no "
-"guardat."
-msgstr[1] ""
-"Esteu segur que voleu matar estos %1 processos? Es perdrà qualsevol treball "
+"Esteu segur que voleu finalitzar aquest procés? Es perdrà qualsevol treball "
 "no guardat."
+msgstr[1] ""
+"Esteu segur que voleu matar aquests %1 processos? Es perdrà qualsevol "
+"treball no guardat."
 
 #: ksysguardprocesslist.cpp:1342
 #, kde-format
@@ -310,11 +310,11 @@
 "Are you sure you want to immediately and forcibly kill these %1 "
 "processes?  Any unsaved work may be lost"
 msgstr[0] ""
-"Esteu segur que voleu matar immediatament i forçadament este "
+"Esteu segur que voleu matar immediatament i forçadament aquest "
 "procés? Es perdrà qualsevol treball no guardat."
 msgstr[1] ""
-"Esteu segur que voleu matar immediatament i forçadament estos %1 "
-"processos? Es perdrà qualsevol treball no guardat."
+"Esteu segur que voleu matar immediatament i forçadament aquests "
+"%1 processos? Es perdrà qualsevol treball no guardat."
 
 #: ksysguardprocesslist.cpp:1349
 #, kde-format
@@ -369,7 +369,7 @@
 msgid ""
 "- Process has been stopped. It will not respond to user input at the moment."
 msgstr ""
-"- El procés està aturat. No respondrà a les entrades de l'usuari en este "
+"- El procés està aturat. No respondrà a les entrades de l'usuari en aquest "
 "moment."
 
 #: ProcessModel.cpp:608
@@ -389,12 +389,12 @@
 #: ProcessModel.cpp:981
 #, kde-format
 msgid "The user who owns this process."
-msgstr "L'usuari 

commit libkdecoration2 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package libkdecoration2 for openSUSE:Factory 
checked in at 2018-03-30 12:05:08

Comparing /work/SRC/openSUSE:Factory/libkdecoration2 (Old)
 and  /work/SRC/openSUSE:Factory/.libkdecoration2.new (New)


Package is "libkdecoration2"

Fri Mar 30 12:05:08 2018 rev:53 rq:591839 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/libkdecoration2/libkdecoration2.changes  
2018-03-09 10:32:26.061275642 +0100
+++ /work/SRC/openSUSE:Factory/.libkdecoration2.new/libkdecoration2.changes 
2018-03-30 12:05:12.130551382 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  kdecoration-5.12.3.tar.xz

New:

  kdecoration-5.12.4.tar.xz



Other differences:
--
++ libkdecoration2.spec ++
--- /var/tmp/diff_new_pack.qyzqfC/_old  2018-03-30 12:05:12.786527664 +0200
+++ /var/tmp/diff_new_pack.qyzqfC/_new  2018-03-30 12:05:12.790527519 +0200
@@ -19,7 +19,7 @@
 %define lname   libkdecorations2-5
 %define lname_private   libkdecorations2private5
 Name:   libkdecoration2
-Version:5.12.3
+Version:5.12.4
 Release:0
 BuildRequires:  cmake >= 2.8.12
 BuildRequires:  extra-cmake-modules >= 0.0.11

++ kdecoration-5.12.3.tar.xz -> kdecoration-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kdecoration-5.12.3/CMakeLists.txt 
new/kdecoration-5.12.4/CMakeLists.txt
--- old/kdecoration-5.12.3/CMakeLists.txt   2018-03-06 13:37:48.0 
+0100
+++ new/kdecoration-5.12.4/CMakeLists.txt   2018-03-27 13:07:54.0 
+0200
@@ -1,5 +1,5 @@
 project(decoration-api)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 
 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
 




commit libkscreen2 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package libkscreen2 for openSUSE:Factory 
checked in at 2018-03-30 12:05:14

Comparing /work/SRC/openSUSE:Factory/libkscreen2 (Old)
 and  /work/SRC/openSUSE:Factory/.libkscreen2.new (New)


Package is "libkscreen2"

Fri Mar 30 12:05:14 2018 rev:65 rq:591840 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/libkscreen2/libkscreen2.changes  2018-03-09 
10:32:29.225161746 +0100
+++ /work/SRC/openSUSE:Factory/.libkscreen2.new/libkscreen2.changes 
2018-03-30 12:05:16.926377975 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  libkscreen-5.12.3.tar.xz

New:

  libkscreen-5.12.4.tar.xz



Other differences:
--
++ libkscreen2.spec ++
--- /var/tmp/diff_new_pack.NuJsu9/_old  2018-03-30 12:05:17.738348615 +0200
+++ /var/tmp/diff_new_pack.NuJsu9/_new  2018-03-30 12:05:17.742348471 +0200
@@ -18,7 +18,7 @@
 
 %define lname   libKF5Screen7
 Name:   libkscreen2
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ libkscreen-5.12.3.tar.xz -> libkscreen-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libkscreen-5.12.3/CMakeLists.txt 
new/libkscreen-5.12.4/CMakeLists.txt
--- old/libkscreen-5.12.3/CMakeLists.txt2018-03-06 13:50:38.0 
+0100
+++ new/libkscreen-5.12.4/CMakeLists.txt2018-03-27 13:18:17.0 
+0200
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.8.12)
 
 project(libkscreen)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 
 set(REQUIRED_QT_VERSION "5.9.0")
 set(KF5_MIN_VERSION "5.42.0")




commit plasma-nm5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package plasma-nm5 for openSUSE:Factory 
checked in at 2018-03-30 12:05:34

Comparing /work/SRC/openSUSE:Factory/plasma-nm5 (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm5.new (New)


Package is "plasma-nm5"

Fri Mar 30 12:05:34 2018 rev:69 rq:591845 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm5/plasma-nm5.changes2018-03-09 
10:33:16.867446646 +0100
+++ /work/SRC/openSUSE:Factory/.plasma-nm5.new/plasma-nm5.changes   
2018-03-30 12:05:38.365602777 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  plasma-nm-5.12.3.tar.xz

New:

  plasma-nm-5.12.4.tar.xz



Other differences:
--
++ plasma-nm5.spec ++
--- /var/tmp/diff_new_pack.Owef8R/_old  2018-03-30 12:05:38.921582673 +0200
+++ /var/tmp/diff_new_pack.Owef8R/_new  2018-03-30 12:05:38.925582529 +0200
@@ -19,7 +19,7 @@
 %bcond_without lang
 %define mm_support 1
 Name:   plasma-nm5
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:Plasma applet written in QML for managing network connections
 License:(LGPL-2.1 or LGPL-3.0) and (GPL-2.0 or GPL-3.0)

++ plasma-nm-5.12.3.tar.xz -> plasma-nm-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/plasma-nm-5.12.3/CMakeLists.txt 
new/plasma-nm-5.12.4/CMakeLists.txt
--- old/plasma-nm-5.12.3/CMakeLists.txt 2018-03-06 13:57:35.0 +0100
+++ new/plasma-nm-5.12.4/CMakeLists.txt 2018-03-27 13:23:56.0 +0200
@@ -3,7 +3,7 @@
 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
 set(QT_MIN_VERSION "5.4.0")
 
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 
 # set KDE specific information #
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/plasma-nm-5.12.3/po/ca@valencia/plasmanetworkmanagement-kcm.po 
new/plasma-nm-5.12.4/po/ca@valencia/plasmanetworkmanagement-kcm.po
--- old/plasma-nm-5.12.3/po/ca@valencia/plasmanetworkmanagement-kcm.po  
2018-03-06 13:56:53.0 +0100
+++ new/plasma-nm-5.12.4/po/ca@valencia/plasmanetworkmanagement-kcm.po  
2018-03-27 13:23:23.0 +0200
@@ -85,7 +85,7 @@
 
 #: qml/main.qml:69
 msgid "Type here to search connections..."
-msgstr "Escriviu ací per a buscar les connexions..."
+msgstr "Escriviu ací per a cercar les connexions..."
 
 #: qml/main.qml:144
 msgid "Add new connection"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/plasma-nm-5.12.3/po/ca@valencia/plasmanetworkmanagement-kded.po 
new/plasma-nm-5.12.4/po/ca@valencia/plasmanetworkmanagement-kded.po
--- old/plasma-nm-5.12.3/po/ca@valencia/plasmanetworkmanagement-kded.po 
2018-03-06 13:56:53.0 +0100
+++ new/plasma-nm-5.12.4/po/ca@valencia/plasmanetworkmanagement-kded.po 
2018-03-27 13:23:23.0 +0200
@@ -474,7 +474,7 @@
 "The VPN connection changed state because the device it was using was "
 "disconnected."
 msgstr ""
-"La connexió VPN ha canviat l'estat atès que el dispositiu usat s'ha "
+"La connexió VPN ha canviat l'estat atés que el dispositiu usat s'ha "
 "desconnectat."
 
 #: notification.cpp:497
@@ -761,4 +761,4 @@
 #: portalmonitor.cpp:57
 #, kde-format
 msgid "You need to log in to this network"
-msgstr "Cal iniciar la sessió en esta xarxa"
\ No newline at end of file
+msgstr "Cal iniciar la sessió en aquesta xarxa"
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/plasma-nm-5.12.3/po/ca@valencia/plasmanetworkmanagement-libs.po 
new/plasma-nm-5.12.4/po/ca@valencia/plasmanetworkmanagement-libs.po
--- old/plasma-nm-5.12.3/po/ca@valencia/plasmanetworkmanagement-libs.po 
2018-03-06 13:56:53.0 +0100
+++ new/plasma-nm-5.12.4/po/ca@valencia/plasmanetworkmanagement-libs.po 
2018-03-27 13:23:23.0 +0200
@@ -368,7 +368,7 @@
 #: editor/settings/ipv4widget.cpp:443 editor/settings/ipv6widget.cpp:434
 #, kde-format
 msgid "Edit DNS search domains"
-msgstr "Edita els dominis per a la busca de DNS"
+msgstr "Edita els dominis per a la cerca de DNS"
 
 #: editor/settings/ipv6widget.cpp:53 editor/widgets/ipv6routeswidget.cpp:39
 #, kde-format
@@ -400,14 +400,14 @@
 "li>EMAIL: emailURI: uri, e.g. http://www.kde.org;
 ""
 msgstr ""
-"Esta entrada ha de ser una de les següents:DNS: nom o adreça "
-"IPEMAIL: correu electrònicURI: URI, p. 

commit kactivitymanagerd for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kactivitymanagerd for 
openSUSE:Factory checked in at 2018-03-30 12:03:33

Comparing /work/SRC/openSUSE:Factory/kactivitymanagerd (Old)
 and  /work/SRC/openSUSE:Factory/.kactivitymanagerd.new (New)


Package is "kactivitymanagerd"

Fri Mar 30 12:03:33 2018 rev:41 rq:591823 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kactivitymanagerd/kactivitymanagerd.changes  
2018-03-09 10:31:03.844235262 +0100
+++ /work/SRC/openSUSE:Factory/.kactivitymanagerd.new/kactivitymanagerd.changes 
2018-03-30 12:04:14.236644740 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:47 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  kactivitymanagerd-5.12.3.tar.xz

New:

  kactivitymanagerd-5.12.4.tar.xz



Other differences:
--
++ kactivitymanagerd.spec ++
--- /var/tmp/diff_new_pack.v8yUlZ/_old  2018-03-30 12:04:14.964618418 +0200
+++ /var/tmp/diff_new_pack.v8yUlZ/_new  2018-03-30 12:04:14.964618418 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   kactivitymanagerd
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:KDE Plasma Activities support
 License:GPL-2.0+

++ kactivitymanagerd-5.12.3.tar.xz -> kactivitymanagerd-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kactivitymanagerd-5.12.3/po/zh_CN/kactivities5.po 
new/kactivitymanagerd-5.12.4/po/zh_CN/kactivities5.po
--- old/kactivitymanagerd-5.12.3/po/zh_CN/kactivities5.po   2018-03-06 
13:36:28.0 +0100
+++ new/kactivitymanagerd-5.12.4/po/zh_CN/kactivities5.po   2018-03-27 
13:06:45.0 +0200
@@ -9,7 +9,7 @@
 "Project-Id-Version: kdeorg\n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 "POT-Creation-Date: 2016-11-19 20:20+0100\n"
-"PO-Revision-Date: 2018-03-05 17:18-0500\n"
+"PO-Revision-Date: 2018-03-18 19:39-0400\n"
 "Last-Translator: guoyunhebrave \n"
 "Language-Team: Chinese Simplified\n"
 "Language: zh_CN\n"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/kactivitymanagerd-5.12.3/src/service/plugins/virtualdesktopswitch/kactivitymanagerd-plugin-virtualdesktopswitch.json
 
new/kactivitymanagerd-5.12.4/src/service/plugins/virtualdesktopswitch/kactivitymanagerd-plugin-virtualdesktopswitch.json
--- 
old/kactivitymanagerd-5.12.3/src/service/plugins/virtualdesktopswitch/kactivitymanagerd-plugin-virtualdesktopswitch.json
2018-03-06 13:35:52.0 +0100
+++ 
new/kactivitymanagerd-5.12.4/src/service/plugins/virtualdesktopswitch/kactivitymanagerd-plugin-virtualdesktopswitch.json
2018-03-27 13:06:21.0 +0200
@@ -16,7 +16,7 @@
 "Category": "",
 "Dependencies": [],
 "Description": "When switching to an activity, opens the virtual 
desktop last used with that activity",
-"Description[ca@valencia]": "En canviar a una activitat, obri el 
darrer escriptori virtual utilitzat amb esta activitat",
+"Description[ca@valencia]": "En canviar a una activitat, obri el 
darrer escriptori virtual utilitzat amb aquesta activitat",
 "Description[ca]": "En canviar a una activitat, obre el darrer 
escriptori virtual utilitzat amb aquesta activitat",
 "Description[da]": "Åbner det senest brugte virtuelle skrivebord for 
aktiviteten ved skift til en aktivitet",
 "Description[de]": "Beim Wechseln zu einer Aktivität wird die 
virtuelle Arbeitsfläche geöffnet, auf der zuletzt diese Aktivität benutzt 
wurde",




commit kscreen5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kscreen5 for openSUSE:Factory 
checked in at 2018-03-30 12:04:29

Comparing /work/SRC/openSUSE:Factory/kscreen5 (Old)
 and  /work/SRC/openSUSE:Factory/.kscreen5.new (New)


Package is "kscreen5"

Fri Mar 30 12:04:29 2018 rev:57 rq:591832 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kscreen5/kscreen5.changes2018-03-09 
10:31:52.538482407 +0100
+++ /work/SRC/openSUSE:Factory/.kscreen5.new/kscreen5.changes   2018-03-30 
12:04:34.267920434 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  kscreen-5.12.3.tar.xz

New:

  kscreen-5.12.4.tar.xz



Other differences:
--
++ kscreen5.spec ++
--- /var/tmp/diff_new_pack.jTEa8U/_old  2018-03-30 12:04:34.979894690 +0200
+++ /var/tmp/diff_new_pack.jTEa8U/_new  2018-03-30 12:04:34.983894546 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   kscreen5
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ kscreen-5.12.3.tar.xz -> kscreen-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kscreen-5.12.3/CMakeLists.txt 
new/kscreen-5.12.4/CMakeLists.txt
--- old/kscreen-5.12.3/CMakeLists.txt   2018-03-06 13:44:57.0 +0100
+++ new/kscreen-5.12.4/CMakeLists.txt   2018-03-27 13:13:42.0 +0200
@@ -1,5 +1,5 @@
 project(KScreen)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 
 cmake_minimum_required(VERSION 2.8.12)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/kscreen-5.12.3/po/ca@valencia/kcm_displayconfiguration.po 
new/kscreen-5.12.4/po/ca@valencia/kcm_displayconfiguration.po
--- old/kscreen-5.12.3/po/ca@valencia/kcm_displayconfiguration.po   
2018-03-06 13:44:18.0 +0100
+++ new/kscreen-5.12.4/po/ca@valencia/kcm_displayconfiguration.po   
2018-03-27 13:13:08.0 +0200
@@ -44,8 +44,8 @@
 #: qml/main.qml:98
 msgid "Your system only supports up to %1 active screen"
 msgid_plural "Your system only supports up to %1 active screens"
-msgstr[0] "Este sistema només permet fins a %1 pantalla activa"
-msgstr[1] "Este sistema només permet fins a %1 pantalles actives"
+msgstr[0] "Aquest sistema només permet fins a %1 pantalla activa"
+msgstr[1] "Aquest sistema només permet fins a %1 pantalles actives"
 
 #: qml/main.qml:120
 msgid "Identify outputs"
@@ -120,7 +120,7 @@
 "Common reasons are that the overall screen size is too big, or you enabled "
 "more displays than supported by your GPU."
 msgstr ""
-"No es pot aplicar esta configuració.\n"
+"No es pot aplicar aquesta configuració.\n"
 "\n"
 "El motiu més normal és que la mida de la pantalla és massa gran, o que heu "
 "activat més pantalles que les que permet la GPU."
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kscreen-5.12.3/po/nb/kcm_displayconfiguration.po 
new/kscreen-5.12.4/po/nb/kcm_displayconfiguration.po
--- old/kscreen-5.12.3/po/nb/kcm_displayconfiguration.po2018-03-06 
13:44:39.0 +0100
+++ new/kscreen-5.12.4/po/nb/kcm_displayconfiguration.po2018-03-27 
13:13:27.0 +0200
@@ -5,7 +5,7 @@
 msgstr ""
 "Project-Id-Version: \n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
-"POT-Creation-Date: 2017-10-24 03:18+0200\n"
+"POT-Creation-Date: 2018-03-06 06:09+0100\n"
 "PO-Revision-Date: 2015-08-27 16:59+0200\n"
 "Last-Translator: Bjørn Steensrud \n"
 "Language-Team: Norwegian Bokmål \n"
@@ -29,21 +29,21 @@
 msgid "Your emails"
 msgstr "bjor...@skogkatt.homelinux.org"
 
-#: qml/main.qml:82
+#: qml/main.qml:80
 msgid "Tip: Hold Ctrl while dragging a display to disable snapping"
 msgstr "Tip: Hold Ctrl mens du drar et skjermbilde for å slå av festing"
 
-#: qml/main.qml:90
+#: qml/main.qml:88
 msgid "Warning: There are no active outputs!"
 msgstr "Advarsel: Det er ingen aktive utganger."
 
-#: qml/main.qml:100
+#: qml/main.qml:98
 msgid "Your system only supports up to %1 active screen"
 msgid_plural "Your system only supports up to %1 active screens"
 msgstr[0] "Systemet ditt støtter bare høyst %1 aktiv skjerm"
 msgstr[1] "Systemet ditt støtter bare høyst %1 aktive skjermer"
 
-#: qml/main.qml:122
+#: qml/main.qml:120
 msgid "Identify outputs"
 msgstr "Identifiser utganger"
 
@@ -275,27 +275,27 @@
 

commit ksshaskpass5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package ksshaskpass5 for openSUSE:Factory 
checked in at 2018-03-30 12:04:43

Comparing /work/SRC/openSUSE:Factory/ksshaskpass5 (Old)
 and  /work/SRC/openSUSE:Factory/.ksshaskpass5.new (New)


Package is "ksshaskpass5"

Fri Mar 30 12:04:43 2018 rev:55 rq:591834 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/ksshaskpass5/ksshaskpass5.changes
2018-03-09 10:32:04.174063549 +0100
+++ /work/SRC/openSUSE:Factory/.ksshaskpass5.new/ksshaskpass5.changes   
2018-03-30 12:04:44.987532828 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  ksshaskpass-5.12.3.tar.xz

New:

  ksshaskpass-5.12.4.tar.xz



Other differences:
--
++ ksshaskpass5.spec ++
--- /var/tmp/diff_new_pack.aG74Ap/_old  2018-03-30 12:04:46.615473964 +0200
+++ /var/tmp/diff_new_pack.aG74Ap/_new  2018-03-30 12:04:46.619473820 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   ksshaskpass5
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:Plasma 5 version of ssh-askpass
 License:GPL-2.0+

++ ksshaskpass-5.12.3.tar.xz -> ksshaskpass-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ksshaskpass-5.12.3/CMakeLists.txt 
new/ksshaskpass-5.12.4/CMakeLists.txt
--- old/ksshaskpass-5.12.3/CMakeLists.txt   2018-03-06 13:46:40.0 
+0100
+++ new/ksshaskpass-5.12.4/CMakeLists.txt   2018-03-27 13:15:04.0 
+0200
@@ -1,6 +1,6 @@
 project(ksshaskpass)
 cmake_minimum_required(VERSION 2.8.12)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 
 find_package(Qt5 REQUIRED COMPONENTS Core)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ksshaskpass-5.12.3/po/zh_CN/ksshaskpass.po 
new/ksshaskpass-5.12.4/po/zh_CN/ksshaskpass.po
--- old/ksshaskpass-5.12.3/po/zh_CN/ksshaskpass.po  2018-03-06 
13:46:40.0 +0100
+++ new/ksshaskpass-5.12.4/po/zh_CN/ksshaskpass.po  2018-03-27 
13:15:00.0 +0200
@@ -7,7 +7,7 @@
 "Project-Id-Version: kdeorg\n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 "POT-Creation-Date: 2018-01-22 05:38+0100\n"
-"PO-Revision-Date: 2018-03-05 17:18-0500\n"
+"PO-Revision-Date: 2018-03-18 19:40-0400\n"
 "Last-Translator: guoyunhebrave \n"
 "Language-Team: Chinese Simplified\n"
 "Language: zh_CN\n"




commit kwayland-integration for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kwayland-integration for 
openSUSE:Factory checked in at 2018-03-30 12:04:58

Comparing /work/SRC/openSUSE:Factory/kwayland-integration (Old)
 and  /work/SRC/openSUSE:Factory/.kwayland-integration.new (New)


Package is "kwayland-integration"

Fri Mar 30 12:04:58 2018 rev:47 rq:591836 version:5.12.4

Changes:

--- 
/work/SRC/openSUSE:Factory/kwayland-integration/kwayland-integration.changes
2018-03-09 10:32:14.121705450 +0100
+++ 
/work/SRC/openSUSE:Factory/.kwayland-integration.new/kwayland-integration.changes
   2018-03-30 12:04:59.726999873 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  kwayland-integration-5.12.3.tar.xz

New:

  kwayland-integration-5.12.4.tar.xz



Other differences:
--
++ kwayland-integration.spec ++
--- /var/tmp/diff_new_pack.70SYzc/_old  2018-03-30 12:05:00.386976009 +0200
+++ /var/tmp/diff_new_pack.70SYzc/_new  2018-03-30 12:05:00.390975865 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   kwayland-integration
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ kwayland-integration-5.12.3.tar.xz -> kwayland-integration-5.12.4.tar.xz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kwayland-integration-5.12.3/CMakeLists.txt 
new/kwayland-integration-5.12.4/CMakeLists.txt
--- old/kwayland-integration-5.12.3/CMakeLists.txt  2018-03-06 
13:48:18.0 +0100
+++ new/kwayland-integration-5.12.4/CMakeLists.txt  2018-03-27 
13:16:17.0 +0200
@@ -1,5 +1,5 @@
 project(kwayland-integration)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 
 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)




commit kwin5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kwin5 for openSUSE:Factory checked 
in at 2018-03-30 12:05:03

Comparing /work/SRC/openSUSE:Factory/kwin5 (Old)
 and  /work/SRC/openSUSE:Factory/.kwin5.new (New)


Package is "kwin5"

Fri Mar 30 12:05:03 2018 rev:76 rq:591837 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kwin5/kwin5.changes  2018-03-20 
21:49:54.344268026 +0100
+++ /work/SRC/openSUSE:Factory/.kwin5.new/kwin5.changes 2018-03-30 
12:05:03.466864646 +0200
@@ -1,0 +2,12 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * [colorcorrection] Apply current color temperature on screen hot plug 
(kde#391623)
+  * [effects/coverswitch] Fix broken reflection on multi-monitor setup 
(kde#378688)
+  * [AppMenu] Ignore show request when application menu isn't configured 
(kde#392012)
+
+---

Old:

  kwin-5.12.3.tar.xz

New:

  kwin-5.12.4.tar.xz



Other differences:
--
++ kwin5.spec ++
--- /var/tmp/diff_new_pack.LyuVU6/_old  2018-03-30 12:05:04.978809977 +0200
+++ /var/tmp/diff_new_pack.LyuVU6/_new  2018-03-30 12:05:04.982809832 +0200
@@ -21,7 +21,7 @@
 %global wayland (0%{?suse_version} >= 1330)
 %bcond_without lang
 Name:   kwin5
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ kwin-5.12.3.tar.xz -> kwin-5.12.4.tar.xz ++
 5262 lines of diff (skipped)




commit kscreenlocker for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kscreenlocker for openSUSE:Factory 
checked in at 2018-03-30 12:04:35

Comparing /work/SRC/openSUSE:Factory/kscreenlocker (Old)
 and  /work/SRC/openSUSE:Factory/.kscreenlocker.new (New)


Package is "kscreenlocker"

Fri Mar 30 12:04:35 2018 rev:44 rq:591833 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kscreenlocker/kscreenlocker.changes  
2018-03-09 10:31:59.026248860 +0100
+++ /work/SRC/openSUSE:Factory/.kscreenlocker.new/kscreenlocker.changes 
2018-03-30 12:04:40.667689028 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  kscreenlocker-5.12.3.tar.xz

New:

  kscreenlocker-5.12.4.tar.xz



Other differences:
--
++ kscreenlocker.spec ++
--- /var/tmp/diff_new_pack.PJ4Zjj/_old  2018-03-30 12:04:41.543657354 +0200
+++ /var/tmp/diff_new_pack.PJ4Zjj/_new  2018-03-30 12:04:41.547657209 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   kscreenlocker
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:Library and components for secure lock screen architecture
 License:GPL-2.0+

++ kscreenlocker-5.12.3.tar.xz -> kscreenlocker-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kscreenlocker-5.12.3/CMakeLists.txt 
new/kscreenlocker-5.12.4/CMakeLists.txt
--- old/kscreenlocker-5.12.3/CMakeLists.txt 2018-03-06 13:45:59.0 
+0100
+++ new/kscreenlocker-5.12.4/CMakeLists.txt 2018-03-27 13:14:30.0 
+0200
@@ -1,4 +1,4 @@
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 
 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kscreenlocker-5.12.3/po/ca/screenlocker_kcm.po 
new/kscreenlocker-5.12.4/po/ca/screenlocker_kcm.po
--- old/kscreenlocker-5.12.3/po/ca/screenlocker_kcm.po  2018-03-06 
13:45:20.0 +0100
+++ new/kscreenlocker-5.12.4/po/ca/screenlocker_kcm.po  2018-03-27 
13:13:58.0 +0200
@@ -10,7 +10,7 @@
 "Project-Id-Version: screenlocker_kcm\n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 "POT-Creation-Date: 2018-01-10 05:10+0100\n"
-"PO-Revision-Date: 2018-01-09 20:26+0100\n"
+"PO-Revision-Date: 2018-03-16 22:22+0100\n"
 "Last-Translator: Josep Ma. Ferrer \n"
 "Language-Team: Catalan \n"
 "Language: ca\n"
@@ -111,4 +111,4 @@
 #: kcm.ui:176
 #, kde-format
 msgid "Wallpaper :"
-msgstr " de fons d'escriptori:"
\ No newline at end of file
+msgstr " de fons de pantalla:"
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kscreenlocker-5.12.3/po/ca@valencia/kscreenlocker.po 
new/kscreenlocker-5.12.4/po/ca@valencia/kscreenlocker.po
--- old/kscreenlocker-5.12.3/po/ca@valencia/kscreenlocker.po2018-03-06 
13:45:20.0 +0100
+++ new/kscreenlocker-5.12.4/po/ca@valencia/kscreenlocker.po2018-03-27 
13:13:58.0 +0200
@@ -34,7 +34,7 @@
 msgstr ""
 "El bloqueig de la pantalla falla i es desbloqueja si ja no és possible.\n"
 "Per tal de desbloquejar-lo des d'una consola virtual (p. ex., Ctrl+Alt+F2),\n"
-"inicieu una sessió i executeu l'orde:\n"
+"inicieu una sessió i executeu l'ordre:\n"
 "\n"
 "loginctl unlock-session %1\n"
 "\n"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/kscreenlocker-5.12.3/po/ca@valencia/screenlocker_kcm.po 
new/kscreenlocker-5.12.4/po/ca@valencia/screenlocker_kcm.po
--- old/kscreenlocker-5.12.3/po/ca@valencia/screenlocker_kcm.po 2018-03-06 
13:45:20.0 +0100
+++ new/kscreenlocker-5.12.4/po/ca@valencia/screenlocker_kcm.po 2018-03-27 
13:13:58.0 +0200
@@ -10,7 +10,7 @@
 "Project-Id-Version: screenlocker_kcm\n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 "POT-Creation-Date: 2018-01-10 05:10+0100\n"
-"PO-Revision-Date: 2018-01-09 20:26+0100\n"
+"PO-Revision-Date: 2018-03-16 22:22+0100\n"
 "Last-Translator: Josep Ma. Ferrer \n"
 "Language-Team: Catalan \n"
 "Language: ca@valencia\n"
@@ -111,4 +111,4 @@
 #: kcm.ui:176
 #, kde-format
 msgid "Wallpaper :"
-msgstr " de fons d'escriptori:"
\ No newline at end of file
+msgstr " de fons de pantalla:"
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit kcm_sddm for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kcm_sddm for openSUSE:Factory 
checked in at 2018-03-30 12:03:40

Comparing /work/SRC/openSUSE:Factory/kcm_sddm (Old)
 and  /work/SRC/openSUSE:Factory/.kcm_sddm.new (New)


Package is "kcm_sddm"

Fri Mar 30 12:03:40 2018 rev:53 rq:591824 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kcm_sddm/kcm_sddm.changes2018-03-09 
10:31:08.540066228 +0100
+++ /work/SRC/openSUSE:Factory/.kcm_sddm.new/kcm_sddm.changes   2018-03-30 
12:04:15.308605979 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:47 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  sddm-kcm-5.12.3.tar.xz

New:

  sddm-kcm-5.12.4.tar.xz



Other differences:
--
++ kcm_sddm.spec ++
--- /var/tmp/diff_new_pack.VhRPJg/_old  2018-03-30 12:04:16.224572859 +0200
+++ /var/tmp/diff_new_pack.VhRPJg/_new  2018-03-30 12:04:16.228572714 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   kcm_sddm
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:A sddm control module for KDE
 License:GPL-2.0

++ sddm-kcm-5.12.3.tar.xz -> sddm-kcm-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sddm-kcm-5.12.3/CMakeLists.txt 
new/sddm-kcm-5.12.4/CMakeLists.txt
--- old/sddm-kcm-5.12.3/CMakeLists.txt  2018-03-06 14:06:33.0 +0100
+++ new/sddm-kcm-5.12.4/CMakeLists.txt  2018-03-27 13:31:46.0 +0200
@@ -1,6 +1,6 @@
 project(sddm-kcm)
 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(QT_MIN_VERSION "5.4.0")
 find_package(ECM 1.0.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} 
${CMAKE_CURRENT_SOURCE_DIR}/cmake)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sddm-kcm-5.12.3/kcm_sddm.actions 
new/sddm-kcm-5.12.4/kcm_sddm.actions
--- old/sddm-kcm-5.12.3/kcm_sddm.actions2018-03-06 14:05:55.0 
+0100
+++ new/sddm-kcm-5.12.4/kcm_sddm.actions2018-03-27 13:31:16.0 
+0200
@@ -196,7 +196,7 @@
 Description[gl]=Extrae un ficheiro zip que contén un tema de SDDM no lugar 
onde se almacenan os temas de SDDM.
 Description[he]=חילוץ קובץ ערכת נושא של SDDM למיקום ערכות הנושא של SDDM
 Description[hu]=Kibont egy SDDM témát tartalmazó ZIP-fájlt az SDDM témák közé
-Description[id]=Extrak sebuah file zip berisi sebuah tema SDDM ke loksi tema 
SDDM
+Description[id]=Extrak sebuah fail zip berisi sebuah tema SDDM ke loksi tema 
SDDM
 Description[it]=Estrai un file zip contenente un tema di SDDM nella posizione 
dei temi di SDDM
 Description[ko]=SDDM 테마 설치 위치에 SDDM 테마 ZIP 압축 파일 해제
 Description[lt]=Išpakuoja ZIP archyvą, kuriame yra SDDM apipavidalinimas į 
SDDM apipavidalinimų saugojimo vietą
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sddm-kcm-5.12.3/po/ca@valencia/kcm_sddm.po 
new/sddm-kcm-5.12.4/po/ca@valencia/kcm_sddm.po
--- old/sddm-kcm-5.12.3/po/ca@valencia/kcm_sddm.po  2018-03-06 
14:06:13.0 +0100
+++ new/sddm-kcm-5.12.4/po/ca@valencia/kcm_sddm.po  2018-03-27 
13:31:29.0 +0200
@@ -208,19 +208,19 @@
 #: src/ui/advanceconfig.ui:148
 #, kde-format
 msgid "Commands"
-msgstr "Ordes"
+msgstr "Ordres"
 
 #. i18n: ectx: property (text), widget (QLabel, label)
 #: src/ui/advanceconfig.ui:154
 #, kde-format
 msgid "Halt Command:"
-msgstr "Orde d'aturada:"
+msgstr "Ordre d'aturada:"
 
 #. i18n: ectx: property (text), widget (QLabel, label_2)
 #: src/ui/advanceconfig.ui:164
 #, kde-format
 msgid "Reboot Command:"
-msgstr "Orde de reinici:"
+msgstr "Ordre de reinici:"
 
 #. i18n: ectx: property (title), widget (QGroupBox, customizeBox)
 #: src/ui/themeconfig.ui:53
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sddm-kcm-5.12.3/po/zh_CN/kcm_sddm.po 
new/sddm-kcm-5.12.4/po/zh_CN/kcm_sddm.po
--- old/sddm-kcm-5.12.3/po/zh_CN/kcm_sddm.po2018-03-06 14:06:33.0 
+0100
+++ new/sddm-kcm-5.12.4/po/zh_CN/kcm_sddm.po2018-03-27 13:31:43.0 
+0200
@@ -9,7 +9,7 @@
 "Project-Id-Version: kdeorg\n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 "POT-Creation-Date: 2017-10-17 03:43+0200\n"
-"PO-Revision-Date: 2018-03-05 17:18-0500\n"
+"PO-Revision-Date: 2018-03-18 19:39-0400\n"
 "Last-Translator: guoyunhebrave \n"
 "Language-Team: Chinese Simplified\n"
 "Language: zh_CN\n"




commit kde-gtk-config5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kde-gtk-config5 for openSUSE:Factory 
checked in at 2018-03-30 12:03:49

Comparing /work/SRC/openSUSE:Factory/kde-gtk-config5 (Old)
 and  /work/SRC/openSUSE:Factory/.kde-gtk-config5.new (New)


Package is "kde-gtk-config5"

Fri Mar 30 12:03:49 2018 rev:57 rq:591826 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kde-gtk-config5/kde-gtk-config5.changes  
2018-03-09 10:31:17.735735214 +0100
+++ /work/SRC/openSUSE:Factory/.kde-gtk-config5.new/kde-gtk-config5.changes 
2018-03-30 12:04:16.488563313 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  kde-gtk-config-5.12.3.tar.xz

New:

  kde-gtk-config-5.12.4.tar.xz



Other differences:
--
++ kde-gtk-config5.spec ++
--- /var/tmp/diff_new_pack.Stdnxy/_old  2018-03-30 12:04:17.464528023 +0200
+++ /var/tmp/diff_new_pack.Stdnxy/_new  2018-03-30 12:04:17.468527879 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   kde-gtk-config5
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:KCM Module to Configure GTK2 and GTK3 Applications Appearance 
Under KDE
 License:LGPL-3.0+ and GPL-3.0+

++ kde-gtk-config-5.12.3.tar.xz -> kde-gtk-config-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kde-gtk-config-5.12.3/CMakeLists.txt 
new/kde-gtk-config-5.12.4/CMakeLists.txt
--- old/kde-gtk-config-5.12.3/CMakeLists.txt2018-03-06 13:38:53.0 
+0100
+++ new/kde-gtk-config-5.12.4/CMakeLists.txt2018-03-27 13:08:40.0 
+0200
@@ -1,5 +1,5 @@
 project(kde-gtk-config)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 cmake_minimum_required(VERSION 2.8.12)
 
 find_package(ECM 0.0.9 REQUIRED NO_MODULE)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/kde-gtk-config-5.12.3/po/ca@valencia/kde-gtk-config.po 
new/kde-gtk-config-5.12.4/po/ca@valencia/kde-gtk-config.po
--- old/kde-gtk-config-5.12.3/po/ca@valencia/kde-gtk-config.po  2018-03-06 
13:38:32.0 +0100
+++ new/kde-gtk-config-5.12.4/po/ca@valencia/kde-gtk-config.po  2018-03-27 
13:08:26.0 +0200
@@ -51,22 +51,22 @@
 #: src/dialog_installer.cpp:128
 #, kde-format
 msgid "This GTK theme can be installed"
-msgstr "Este tema GTK es pot instal·lar"
+msgstr "Aquest tema GTK es pot instal·lar"
 
 #: src/dialog_installer.cpp:131
 #, kde-format
 msgid "This GTK theme cannot be installed"
-msgstr "Este tema GTK no es pot instal·lar"
+msgstr "Aquest tema GTK no es pot instal·lar"
 
 #: src/dialog_installer.cpp:154
 #, kde-format
 msgid "This icons theme can be installed"
-msgstr "Este tema d'icones es pot instal·lar"
+msgstr "Aquest tema d'icones es pot instal·lar"
 
 #: src/dialog_installer.cpp:157
 #, kde-format
 msgid "This icons theme cannot be installed"
-msgstr "Este tema d'icones no es pot instal·lar"
+msgstr "Aquest tema d'icones no es pot instal·lar"
 
 #: src/dialog_installer.cpp:177
 #, kde-format
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kde-gtk-config-5.12.3/po/id/kde-gtk-config.po 
new/kde-gtk-config-5.12.4/po/id/kde-gtk-config.po
--- old/kde-gtk-config-5.12.3/po/id/kde-gtk-config.po   2018-03-06 
13:38:39.0 +0100
+++ new/kde-gtk-config-5.12.4/po/id/kde-gtk-config.po   2018-03-27 
13:08:31.0 +0200
@@ -1,6 +1,6 @@
 # Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
 # This file is distributed under the same license as the PACKAGE package.
-# Wantoyo , 2017.
+# Wantoyo , 2017, 2018.
 #
 # Martin Lee, 2010.
 msgid ""
@@ -8,9 +8,9 @@
 "Project-Id-Version: \n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 "POT-Creation-Date: 2018-02-09 06:04+0100\n"
-"PO-Revision-Date: 2017-12-12 21:21+0700\n"
+"PO-Revision-Date: 2018-03-02 22:16+0700\n"
 "Last-Translator: Wantoyo \n"
-"Language-Team: Indonesian \n"
+"Language-Team: Indonesian \n"
 "Language: id\n"
 "MIME-Version: 1.0\n"
 "Content-Type: text/plain; charset=UTF-8\n"
@@ -227,7 +227,7 @@
 #: src/ui/dialog_installer.ui:82 src/ui/dialog_installer.ui:198
 #, kde-format
 msgid "Select the theme file you want to install:"
-msgstr "Pilih file tema yang Anda inginkan untuk dipasang:"
+msgstr "Pilih fail tema yang Anda inginkan untuk dipasang:"
 
 #. i18n: ectx: property (text), widget (QLabel, 

commit kgamma5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kgamma5 for openSUSE:Factory checked 
in at 2018-03-30 12:04:00

Comparing /work/SRC/openSUSE:Factory/kgamma5 (Old)
 and  /work/SRC/openSUSE:Factory/.kgamma5.new (New)


Package is "kgamma5"

Fri Mar 30 12:04:00 2018 rev:42 rq:591828 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kgamma5/kgamma5.changes  2018-03-09 
10:31:28.291355243 +0100
+++ /work/SRC/openSUSE:Factory/.kgamma5.new/kgamma5.changes 2018-03-30 
12:04:21.568379633 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  kgamma5-5.12.3.tar.xz

New:

  kgamma5-5.12.4.tar.xz



Other differences:
--
++ kgamma5.spec ++
--- /var/tmp/diff_new_pack.spJEb7/_old  2018-03-30 12:04:22.440348103 +0200
+++ /var/tmp/diff_new_pack.spJEb7/_new  2018-03-30 12:04:22.444347959 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   kgamma5
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:Display gamma configuration
 License:GPL-2.0+

++ kgamma5-5.12.3.tar.xz -> kgamma5-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kgamma5-5.12.3/CMakeLists.txt 
new/kgamma5-5.12.4/CMakeLists.txt
--- old/kgamma5-5.12.3/CMakeLists.txt   2018-03-06 13:40:36.0 +0100
+++ new/kgamma5-5.12.4/CMakeLists.txt   2018-03-27 13:10:00.0 +0200
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.8.9)
 project(kgamma)
 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(QT_MIN_VERSION "5.4.0")
 find_package(ECM 1.0.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} 
${CMAKE_CURRENT_SOURCE_DIR}/cmake)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kgamma5-5.12.3/po/ca@valencia/kcmkgamma.po 
new/kgamma5-5.12.4/po/ca@valencia/kcmkgamma.po
--- old/kgamma5-5.12.3/po/ca@valencia/kcmkgamma.po  2018-03-06 
13:40:15.0 +0100
+++ new/kgamma5-5.12.4/po/ca@valencia/kcmkgamma.po  2018-03-27 
13:09:46.0 +0200
@@ -110,8 +110,8 @@
 "own KDE settings. On multi head systems you can correct the gamma values "
 "separately for all screens."
 msgstr ""
-"Monitor Gamma Esta és una eina per a canviar la correcció gamma del "
-"monitor. Empreu els quatre controls lliscants per a definir la correcció "
+"Monitor Gamma Aquesta és una eina per a canviar la correcció gamma "
+"del monitor. Empreu els quatre controls lliscants per a definir la correcció "
 "gamma, bé com un únic valor, o bé per separat en els components roig, verd i "
 "blau. Potser vos caldrà corregir els paràmetres de brillantor i contrast del "
 "monitor per a obtindre bons resultats. Les imatges de prova vos ajudaran a "
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kgamma5-5.12.3/po/zh_CN/kcmkgamma.po 
new/kgamma5-5.12.4/po/zh_CN/kcmkgamma.po
--- old/kgamma5-5.12.3/po/zh_CN/kcmkgamma.po2018-03-06 13:40:36.0 
+0100
+++ new/kgamma5-5.12.4/po/zh_CN/kcmkgamma.po2018-03-27 13:10:00.0 
+0200
@@ -7,7 +7,7 @@
 "Project-Id-Version: kdeorg\n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 "POT-Creation-Date: 2017-05-18 03:02+0200\n"
-"PO-Revision-Date: 2018-03-05 17:18-0500\n"
+"PO-Revision-Date: 2018-03-18 19:39-0400\n"
 "Last-Translator: guoyunhebrave \n"
 "Language-Team: Chinese Simplified\n"
 "Language: zh_CN\n"




commit kde-user-manager for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kde-user-manager for 
openSUSE:Factory checked in at 2018-03-30 12:03:54

Comparing /work/SRC/openSUSE:Factory/kde-user-manager (Old)
 and  /work/SRC/openSUSE:Factory/.kde-user-manager.new (New)


Package is "kde-user-manager"

Fri Mar 30 12:03:54 2018 rev:48 rq:591827 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kde-user-manager/kde-user-manager.changes
2018-03-09 10:31:22.827551924 +0100
+++ /work/SRC/openSUSE:Factory/.kde-user-manager.new/kde-user-manager.changes   
2018-03-30 12:04:19.556452381 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  user-manager-5.12.3.tar.xz

New:

  user-manager-5.12.4.tar.xz



Other differences:
--
++ kde-user-manager.spec ++
--- /var/tmp/diff_new_pack.es1xaa/_old  2018-03-30 12:04:21.088396989 +0200
+++ /var/tmp/diff_new_pack.es1xaa/_new  2018-03-30 12:04:21.088396989 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   kde-user-manager
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:KDE System Settings module to manage users
 License:GPL-2.0+

++ user-manager-5.12.3.tar.xz -> user-manager-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/user-manager-5.12.3/CMakeLists.txt 
new/user-manager-5.12.4/CMakeLists.txt
--- old/user-manager-5.12.3/CMakeLists.txt  2018-03-06 14:08:04.0 
+0100
+++ new/user-manager-5.12.4/CMakeLists.txt  2018-03-27 13:32:57.0 
+0200
@@ -1,6 +1,6 @@
 project(user-manager)
 cmake_minimum_required(VERSION 2.8.12)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 
 find_package(ECM 1.3.0 REQUIRED NO_MODULE)
 set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/user-manager-5.12.3/po/ca@valencia/user_manager.po 
new/user-manager-5.12.4/po/ca@valencia/user_manager.po
--- old/user-manager-5.12.3/po/ca@valencia/user_manager.po  2018-03-06 
14:07:43.0 +0100
+++ new/user-manager-5.12.4/po/ca@valencia/user_manager.po  2018-03-27 
13:32:42.0 +0200
@@ -62,7 +62,7 @@
 #: src/account.ui:208
 #, kde-format
 msgid "Enable administrator privileges for this user"
-msgstr "Habilita privilegis d'administrador per a este usuari"
+msgstr "Habilita privilegis d'administrador per a aquest usuari"
 
 #. i18n: ectx: property (text), widget (QLabel, automaticLoginLabel)
 #: src/account.ui:222
@@ -94,7 +94,7 @@
 #: src/accountinfo.cpp:301
 #, kde-format
 msgid "This username is already used"
-msgstr "Este nom d'usuari ja està en ús"
+msgstr "Aquest nom d'usuari ja està en ús"
 
 #: src/accountinfo.cpp:311
 #, kde-format
@@ -117,7 +117,7 @@
 #: src/accountinfo.cpp:381
 #, kde-format
 msgid "This e-mail address is incorrect"
-msgstr "Esta adreça de correu electrònic és incorrecta"
+msgstr "Aquesta adreça de correu electrònic és incorrecta"
 
 #: src/accountinfo.cpp:426
 #, kde-format
@@ -179,22 +179,22 @@
 #: src/passworddialog.cpp:127
 #, kde-format
 msgid "This password is weak"
-msgstr "Esta contrasenya és feble"
+msgstr "Aquesta contrasenya és feble"
 
 #: src/passworddialog.cpp:130
 #, kde-format
 msgid "This password is good"
-msgstr "Esta contrasenya és bona"
+msgstr "Aquesta contrasenya és bona"
 
 #: src/passworddialog.cpp:133
 #, kde-format
 msgid "This password is very good"
-msgstr "Esta contrasenya és molt bona"
+msgstr "Aquesta contrasenya és molt bona"
 
 #: src/passworddialog.cpp:136
 #, kde-format
 msgid "This password is excellent"
-msgstr "Esta contrasenya és excel·lent"
+msgstr "Aquesta contrasenya és excel·lent"
 
 #: src/passworddialog.cpp:152
 #, kde-format
@@ -284,7 +284,7 @@
 #, kde-format
 msgctxt "Error returned when the password is invalid"
 msgid "This password can't be used, it is too simple"
-msgstr "Esta contrasenya no es pot usar, és massa simple"
+msgstr "Aquesta contrasenya no es pot usar, és massa simple"
 
 #: src/passworddialog.cpp:204
 #, kde-format
@@ -312,8 +312,8 @@
 msgid ""
 "This user is using the system right now, removing it will cause problems"
 msgstr ""
-"Este usuari està utilitzant el sistema en este moment, la seua eliminació "
-"causarà problemes"
+"Aquest usuari està utilitzant el sistema en aquest moment, la seua "
+"eliminació causarà problemes"
 
 #: src/usermanager.cpp:131
 #, kde-format
diff -urN '--exclude=CVS' '--exclude=.cvsignore' 

commit ksysguard5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package ksysguard5 for openSUSE:Factory 
checked in at 2018-03-30 12:04:48

Comparing /work/SRC/openSUSE:Factory/ksysguard5 (Old)
 and  /work/SRC/openSUSE:Factory/.ksysguard5.new (New)


Package is "ksysguard5"

Fri Mar 30 12:04:48 2018 rev:63 rq:591835 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/ksysguard5/ksysguard5.changes2018-03-09 
10:32:09.325878092 +0100
+++ /work/SRC/openSUSE:Factory/.ksysguard5.new/ksysguard5.changes   
2018-03-30 12:04:52.287268881 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  ksysguard-5.12.3.tar.xz

New:

  ksysguard-5.12.4.tar.xz



Other differences:
--
++ ksysguard5.spec ++
--- /var/tmp/diff_new_pack.u5O7UR/_old  2018-03-30 12:04:52.979243860 +0200
+++ /var/tmp/diff_new_pack.u5O7UR/_new  2018-03-30 12:04:52.983243716 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   ksysguard5
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ ksysguard-5.12.3.tar.xz -> ksysguard-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ksysguard-5.12.3/CMakeLists.txt 
new/ksysguard-5.12.4/CMakeLists.txt
--- old/ksysguard-5.12.3/CMakeLists.txt 2018-03-06 13:47:47.0 +0100
+++ new/ksysguard-5.12.4/CMakeLists.txt 2018-03-27 13:15:51.0 +0200
@@ -1,5 +1,5 @@
 project(ksysguard)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
 
 set(KSYSGUARD_VERSION 4.98.0)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ksysguard-5.12.3/example/ksysguard.notifyrc 
new/ksysguard-5.12.4/example/ksysguard.notifyrc
--- old/ksysguard-5.12.3/example/ksysguard.notifyrc 2018-03-06 
13:46:57.0 +0100
+++ new/ksysguard-5.12.4/example/ksysguard.notifyrc 2018-03-27 
13:15:15.0 +0200
@@ -156,7 +156,7 @@
 Comment[bn]=সন্ধান করা প্যাটার্ন-এর মিল পাওয়া গেছে
 Comment[bs]=Pronađen je obrazac pretrage
 Comment[ca]=S'ha trobat el patró de cerca
-Comment[ca@valencia]=S'ha trobat el patró de busca
+Comment[ca@valencia]=S'ha trobat el patró de cerca
 Comment[cs]=Hledání vzorku odpovídá
 Comment[csb]=Mùster szëkbë nalazłi
 Comment[da]=Søgemønsteret matchede
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ksysguard-5.12.3/po/ca@valencia/ksysguard.po 
new/ksysguard-5.12.4/po/ca@valencia/ksysguard.po
--- old/ksysguard-5.12.3/po/ca@valencia/ksysguard.po2018-03-06 
13:47:12.0 +0100
+++ new/ksysguard-5.12.4/po/ca@valencia/ksysguard.po2018-03-27 
13:15:25.0 +0200
@@ -63,8 +63,8 @@
 #, kde-format
 msgid "Select this to use the secure shell to login to the remote host."
 msgstr ""
-"Seleccioneu esta opció per a usar l'intèrpret d'ordes segur per a accedir a "
-"la màquina remota."
+"Seleccioneu aquesta opció per a usar l'intèrpret d'ordres segur per a "
+"accedir a la màquina remota."
 
 #: HostConnector.cpp:85
 #, kde-format
@@ -75,8 +75,8 @@
 #, kde-format
 msgid "Select this to use the remote shell to login to the remote host."
 msgstr ""
-"Seleccioneu esta opció per a usar l'intèrpret d'ordes segur per a accedir a "
-"la màquina remota."
+"Seleccioneu aquesta opció per a usar l'intèrpret d'ordres segur per a "
+"accedir a la màquina remota."
 
 #: HostConnector.cpp:89
 #, kde-format
@@ -89,14 +89,14 @@
 "Select this if you want to connect to a ksysguard daemon that is running on "
 "the machine you want to connect to, and is listening for client requests."
 msgstr ""
-"Seleccioneu esta opció si voleu connectar a un dimoni del ksysguard que "
+"Seleccioneu aquesta opció si voleu connectar a un dimoni del ksysguard que "
 "s'està executant en la màquina a la qual voleu connectar i que escolta les "
 "peticions de clients."
 
 #: HostConnector.cpp:93
 #, kde-format
 msgid "Custom command"
-msgstr "Orde personalitzada"
+msgstr "Ordre personalitzada"
 
 #: HostConnector.cpp:94
 #, kde-format
@@ -104,7 +104,7 @@
 "Select this to use the command you entered below to start ksysguardd on the "
 "remote host."
 msgstr ""
-"Seleccioneu esta opció si voleu usar l'orde que introduireu a sota per a "
+"Seleccioneu aquesta opció si voleu usar l'ordre que introduireu a sota per a "
 "iniciar el ksysguardd en la màquina remota."
 
 #: 

commit discover for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package discover for openSUSE:Factory 
checked in at 2018-03-30 12:03:15

Comparing /work/SRC/openSUSE:Factory/discover (Old)
 and  /work/SRC/openSUSE:Factory/.discover.new (New)


Package is "discover"

Fri Mar 30 12:03:15 2018 rev:36 rq:591820 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/discover/discover.changes2018-03-09 
10:30:55.220545683 +0100
+++ /work/SRC/openSUSE:Factory/.discover.new/discover.changes   2018-03-30 
12:04:05.824948898 +0200
@@ -1,0 +2,32 @@
+Tue Mar 27 15:40:47 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * Simplify the tasks view (kde#391760)
+  * Remove unneeded includes
+  * Fix dbus path
+  * Include a test for cancelling flatpak installations
+  * Improve status of FlatpakTransaction
+  * Remove pointless i18n call
+  * KNS: Only indicate that it's fetching if already fetching reviews
+  * Include a test that makes sure we can list origins
+  * Solve some inconsistencies found when testing flatpak
+  * Introduce a flatpak test
+  * No need to pass the extra arguments on the Update Action (kde#391801)
+  * Add Qt5::Xml
+  * Simplify KNSTransaction creation (kde#390236)
+  * Fix test
+  * Add a test to make sure we don't add resources with the wrong URL
+  * kns: Fix logic for adding screenshots (kde#391190)
+  * Add debug information when the searched URI is wrong
+
+---
+Fri Mar 23 20:42:00 UTC 2018 - fab...@ritter-vogt.de
+
+- Add patch to show an informative warning when adding FlatHub:
+  * 0001-Warning-for-FlatHub.patch
+
+---

Old:

  discover-5.12.3.tar.xz

New:

  0001-Warning-for-FlatHub.patch
  discover-5.12.4.tar.xz



Other differences:
--
++ discover.spec ++
--- /var/tmp/diff_new_pack.EbKvTx/_old  2018-03-30 12:04:07.008906087 +0200
+++ /var/tmp/diff_new_pack.EbKvTx/_new  2018-03-30 12:04:07.012905943 +0200
@@ -18,13 +18,15 @@
 
 %bcond_without lang
 Name:   discover
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:KDE Software Installer
 License:GPL-2.0 and GPL-3.0 and GPL-3.0+
 Group:  System/GUI/KDE
 Url:https://quickgit.kde.org/?p=discover.git
 Source: 
http://download.kde.org/stable/plasma/%{version}/discover-%{version}.tar.xz
+# PATCH-FIX-OPENSUSE
+Patch1: 0001-Warning-for-FlatHub.patch
 %if 0%{?suse_version} < 1330
 # It does not build with the default compiler (GCC 4.8) on Leap 42.x
 %if 0%{?sle_version} < 120300
@@ -96,6 +98,7 @@
 
 %prep
 %setup -q
+%autopatch -p1
 
 %build
   %if 0%{?suse_version} < 1330

++ 0001-Warning-for-FlatHub.patch ++
>From 74a4eff529e6b71f6a822841d9112d9b71b44d24 Mon Sep 17 00:00:00 2001
From: Fabian Vogt 
Date: Sat, 13 Jan 2018 15:16:39 +0100
Subject: [PATCH] Warning for FlatHub

---
 .../backends/FlatpakBackend/FlatpakSourcesBackend.cpp  | 14 +-
 1 file changed, 13 insertions(+), 1 deletion(-)

diff --git a/libdiscover/backends/FlatpakBackend/FlatpakSourcesBackend.cpp 
b/libdiscover/backends/FlatpakBackend/FlatpakSourcesBackend.cpp
index e96dd5bc..77646179 100644
--- a/libdiscover/backends/FlatpakBackend/FlatpakSourcesBackend.cpp
+++ b/libdiscover/backends/FlatpakBackend/FlatpakSourcesBackend.cpp
@@ -24,6 +24,8 @@
 #include "FlatpakBackend.h"
 #include 
 #include 
+#include 
+#include 
 #include 
 #include 
 #include 
@@ -57,7 +59,17 @@ FlatpakSourcesBackend::FlatpakSourcesBackend(const 
QVectorsetToolTip(QStringLiteral("flathub"));
 connect(m_flathubAction, ::triggered, this, [this](){
-
addSource(QStringLiteral("https://flathub.org/repo/flathub.flatpakrepo;));
+auto *warnBox = new QMessageBox(QMessageBox::Information, i18n("Adding 
a third-party source"),
+i18n("FlatHub is not part of the openSUSE 
distribution.\n"
+ "It contains packages of unknown quality 
which might not be tested to work correctly "
+ "on openSUSE. Prefer to install software from 
the official openSUSE repository."),
+QMessageBox::Ok | QMessageBox::Abort);
+connect(warnBox, ::buttonClicked, this, [this, 
warnBox](QAbstractButton *button) {
+if (warnBox->standardButton(button) == QMessageBox::Ok)
+
addSource(QStringLiteral("https://flathub.org/repo/flathub.flatpakrepo;));
+});
+warnBox->setAttribute(Qt::WA_DeleteOnClose);
+

commit kinfocenter5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kinfocenter5 for openSUSE:Factory 
checked in at 2018-03-30 12:04:16

Comparing /work/SRC/openSUSE:Factory/kinfocenter5 (Old)
 and  /work/SRC/openSUSE:Factory/.kinfocenter5.new (New)


Package is "kinfocenter5"

Fri Mar 30 12:04:16 2018 rev:65 rq:591830 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kinfocenter5/kinfocenter5.changes
2018-03-09 10:31:39.278959718 +0100
+++ /work/SRC/openSUSE:Factory/.kinfocenter5.new/kinfocenter5.changes   
2018-03-30 12:04:29.276100931 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * kcm_energyinfo: Allow changing of the timespan if no data available
+
+---

Old:

  kinfocenter-5.12.3.tar.xz

New:

  kinfocenter-5.12.4.tar.xz



Other differences:
--
++ kinfocenter5.spec ++
--- /var/tmp/diff_new_pack.oVJNLp/_old  2018-03-30 12:04:30.012074319 +0200
+++ /var/tmp/diff_new_pack.oVJNLp/_new  2018-03-30 12:04:30.016074175 +0200
@@ -20,7 +20,7 @@
 
 %bcond_without lang
 Name:   kinfocenter5
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ kinfocenter-5.12.3.tar.xz -> kinfocenter-5.12.4.tar.xz ++
 6063 lines of diff (skipped)




commit kmenuedit5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kmenuedit5 for openSUSE:Factory 
checked in at 2018-03-30 12:04:22

Comparing /work/SRC/openSUSE:Factory/kmenuedit5 (Old)
 and  /work/SRC/openSUSE:Factory/.kmenuedit5.new (New)


Package is "kmenuedit5"

Fri Mar 30 12:04:22 2018 rev:60 rq:591831 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/kmenuedit5/kmenuedit5.changes2018-03-09 
10:31:47.870650438 +0100
+++ /work/SRC/openSUSE:Factory/.kmenuedit5.new/kmenuedit5.changes   
2018-03-30 12:04:33.295955579 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * Fix pixelated icon scaling for HiDPI screens (kde#390737)
+
+---

Old:

  kmenuedit-5.12.3.tar.xz

New:

  kmenuedit-5.12.4.tar.xz



Other differences:
--
++ kmenuedit5.spec ++
--- /var/tmp/diff_new_pack.PTn1GJ/_old  2018-03-30 12:04:33.879934463 +0200
+++ /var/tmp/diff_new_pack.PTn1GJ/_new  2018-03-30 12:04:33.879934463 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   kmenuedit5
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ kmenuedit-5.12.3.tar.xz -> kmenuedit-5.12.4.tar.xz ++
 11014 lines of diff (skipped)




commit khotkeys5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package khotkeys5 for openSUSE:Factory 
checked in at 2018-03-30 12:04:07

Comparing /work/SRC/openSUSE:Factory/khotkeys5 (Old)
 and  /work/SRC/openSUSE:Factory/.khotkeys5.new (New)


Package is "khotkeys5"

Fri Mar 30 12:04:07 2018 rev:62 rq:591829 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/khotkeys5/khotkeys5.changes  2018-03-09 
10:31:33.139180734 +0100
+++ /work/SRC/openSUSE:Factory/.khotkeys5.new/khotkeys5.changes 2018-03-30 
12:04:25.764227916 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:48 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  khotkeys-5.12.3.tar.xz

New:

  khotkeys-5.12.4.tar.xz



Other differences:
--
++ khotkeys5.spec ++
--- /var/tmp/diff_new_pack.Q1LA0A/_old  2018-03-30 12:04:27.304172234 +0200
+++ /var/tmp/diff_new_pack.Q1LA0A/_new  2018-03-30 12:04:27.308172089 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   khotkeys5
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ khotkeys-5.12.3.tar.xz -> khotkeys-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/khotkeys-5.12.3/CMakeLists.txt 
new/khotkeys-5.12.4/CMakeLists.txt
--- old/khotkeys-5.12.3/CMakeLists.txt  2018-03-06 13:41:41.0 +0100
+++ new/khotkeys-5.12.4/CMakeLists.txt  2018-03-27 13:10:58.0 +0200
@@ -1,5 +1,5 @@
 project(khotkeys)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 
 cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/khotkeys-5.12.3/data/defaults.khotkeys 
new/khotkeys-5.12.4/data/defaults.khotkeys
--- old/khotkeys-5.12.3/data/defaults.khotkeys  2018-03-06 13:40:53.0 
+0100
+++ new/khotkeys-5.12.4/data/defaults.khotkeys  2018-03-27 13:10:16.0 
+0200
@@ -229,7 +229,7 @@
 Name[bn]=অনুসন্ধান
 Name[bs]=Pretraga
 Name[ca]=Cerca
-Name[ca@valencia]=Busca
+Name[ca@valencia]=Cerca
 Name[cs]=Hledat
 Name[csb]=Szëkba
 Name[da]=Søg
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/khotkeys-5.12.3/data/kde32b1.khotkeys 
new/khotkeys-5.12.4/data/kde32b1.khotkeys
--- old/khotkeys-5.12.3/data/kde32b1.khotkeys   2018-03-06 13:40:53.0 
+0100
+++ new/khotkeys-5.12.4/data/kde32b1.khotkeys   2018-03-27 13:10:16.0 
+0200
@@ -8,7 +8,7 @@
 Comment[bg]=Тази група съдържа различни примери, демонстриращи повечето от 
функциите на горещите клавиши. (Имайте предвид, че групата по подразбиране е 
изключена.)
 Comment[bs]=Grupa koja sadrži razne primjere primjena mogućnosti K‑prečica 
(ova grupa i sve radnje u njoj podrazumijevano su isključene).
 Comment[ca]=Aquest grup conté diversos exemples que demostren la majoria de 
les funcionalitats del KHotkeys (tingueu en compte que aquest grup i totes les 
seves accions estan desactivats per omissió).
-Comment[ca@valencia]=Este grup conté diversos exemples que demostren la 
majoria de les funcionalitats del KHotkeys (tingueu en compte que este grup i 
totes les seues accions estan desactivats per omissió).
+Comment[ca@valencia]=Aquest grup conté diversos exemples que demostren la 
majoria de les funcionalitats del KHotkeys (tingueu en compte que aquest grup i 
totes les seues accions estan desactivats per omissió).
 Comment[cs]=Skupina obsahující mnoho příkladů demonstrujících většinu 
vlastností KHotKeys. (Tato skupina i všechny činnosti nejsou ve výchozím  stavu 
povoleny.)(
 Comment[csb]=Na grëpa zamëkô w se przëmiôrë dlô wikszoscë fùnkcëjów dlô 
Skrodzënów ë gestów (KHotkeys) (Bôczënk: No karno ë jegò dzejania są w 
domëslnym nastôwie deaktiwòwòné)
 Comment[da]=Denne gruppe indeholder diverse eksempler som demonstrerer de 
fleste af KHotkeys' funktioner. (Bemærk at denne gruppe og alle dens handlinger 
er deaktiveret som standard.)
@@ -848,7 +848,7 @@
 Comment[bg]=Това действие стартира конзола при натискането на Ctrl+Alt+T.
 Comment[bs]=Ova radnja pokreće Konzolu po pritisku Ctrl+Alt+T.
 Comment[ca]=Aquesta acció executa el Konsole, després de prémer Ctrl+Alt+T.
-Comment[ca@valencia]=Esta acció executa el Konsole, després de prémer 
Ctrl+Alt+T.
+Comment[ca@valencia]=Aquesta acció executa el Konsole, després de prémer 
Ctrl+Alt+T.
 Comment[cs]=Tato činnost spustí po stisknutí Ctrl-Alt-t program Konsole.
 

commit drkonqi5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package drkonqi5 for openSUSE:Factory 
checked in at 2018-03-30 12:03:24

Comparing /work/SRC/openSUSE:Factory/drkonqi5 (Old)
 and  /work/SRC/openSUSE:Factory/.drkonqi5.new (New)


Package is "drkonqi5"

Fri Mar 30 12:03:24 2018 rev:12 rq:591821 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/drkonqi5/drkonqi5.changes2018-03-09 
10:31:00.156368012 +0100
+++ /work/SRC/openSUSE:Factory/.drkonqi5.new/drkonqi5.changes   2018-03-30 
12:04:08.828840281 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:47 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  drkonqi-5.12.3.tar.xz

New:

  drkonqi-5.12.4.tar.xz



Other differences:
--
++ drkonqi5.spec ++
--- /var/tmp/diff_new_pack.ZTppmT/_old  2018-03-30 12:04:09.564813668 +0200
+++ /var/tmp/diff_new_pack.ZTppmT/_new  2018-03-30 12:04:09.568813524 +0200
@@ -23,7 +23,7 @@
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}
 # Latest ABI-stable Plasma (e.g. 5.8 in KF5, but 5.9.1 in KUF)
 %{!?_plasma5_version: %global _plasma5_version %(echo %{_plasma5_bugfix} | awk 
-F. '{print $1"."$2}')}
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:Helper for debugging and reporting crashes
 License:GPL-2.0+

++ drkonqi-5.12.3.tar.xz -> drkonqi-5.12.4.tar.xz ++
 2782 lines of diff (skipped)




commit breeze-gtk for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package breeze-gtk for openSUSE:Factory 
checked in at 2018-03-30 12:03:09

Comparing /work/SRC/openSUSE:Factory/breeze-gtk (Old)
 and  /work/SRC/openSUSE:Factory/.breeze-gtk.new (New)


Package is "breeze-gtk"

Fri Mar 30 12:03:09 2018 rev:42 rq:591819 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/breeze-gtk/breeze-gtk.changes2018-03-09 
10:30:49.840739335 +0100
+++ /work/SRC/openSUSE:Factory/.breeze-gtk.new/breeze-gtk.changes   
2018-03-30 12:03:58.597210246 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:47 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  breeze-gtk-5.12.3.tar.xz

New:

  breeze-gtk-5.12.4.tar.xz



Other differences:
--
++ breeze-gtk.spec ++
--- /var/tmp/diff_new_pack.fIDItF/_old  2018-03-30 12:03:59.217187829 +0200
+++ /var/tmp/diff_new_pack.fIDItF/_new  2018-03-30 12:03:59.221187683 +0200
@@ -18,7 +18,7 @@
 
 %define _name   breeze
 Name:   breeze-gtk
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:GTK+ theme matching KDE's Breeze
 License:LGPL-2.1

++ breeze-gtk-5.12.3.tar.xz -> breeze-gtk-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/breeze-gtk-5.12.3/CMakeLists.txt 
new/breeze-gtk-5.12.4/CMakeLists.txt
--- old/breeze-gtk-5.12.3/CMakeLists.txt2018-03-06 13:33:09.0 
+0100
+++ new/breeze-gtk-5.12.4/CMakeLists.txt2018-03-27 13:03:47.0 
+0200
@@ -1,5 +1,5 @@
 project(breeze-gtk)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 
 cmake_minimum_required(VERSION 2.8.12)




commit breeze for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package breeze for openSUSE:Factory checked 
in at 2018-03-30 12:03:02

Comparing /work/SRC/openSUSE:Factory/breeze (Old)
 and  /work/SRC/openSUSE:Factory/.breeze.new (New)


Package is "breeze"

Fri Mar 30 12:03:02 2018 rev:63 rq:591818 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/breeze/breeze.changes2018-03-09 
10:30:45.512895121 +0100
+++ /work/SRC/openSUSE:Factory/.breeze.new/breeze.changes   2018-03-30 
12:03:53.713386841 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:47 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * - Moved shadowSize from anonymous namespace to static member function - 
calculate proper shadow size for Mdi windows - fix mdi windows shadow 
renderning.
+
+---
breeze4-style.changes: same change

Old:

  breeze-5.12.3.tar.xz

New:

  breeze-5.12.4.tar.xz



Other differences:
--
++ breeze.spec ++
--- /var/tmp/diff_new_pack.ULUwdj/_old  2018-03-30 12:03:55.021339546 +0200
+++ /var/tmp/diff_new_pack.ULUwdj/_new  2018-03-30 12:03:55.037338968 +0200
@@ -18,7 +18,7 @@
 
 %bcond_without lang
 Name:   breeze
-Version:5.12.3
+Version:5.12.4
 Release:0
 # Full Plasma 5 version (e.g. 5.8.95)
 %{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}

++ breeze4-style.spec ++
--- /var/tmp/diff_new_pack.ULUwdj/_old  2018-03-30 12:03:55.085337232 +0200
+++ /var/tmp/diff_new_pack.ULUwdj/_new  2018-03-30 12:03:55.089337088 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   breeze4-style
-Version:5.12.3
+Version:5.12.4
 Release:0
 BuildRequires:  automoc4
 BuildRequires:  cmake >= 2.8.12

++ breeze-5.12.3.tar.xz -> breeze-5.12.4.tar.xz ++
/work/SRC/openSUSE:Factory/breeze/breeze-5.12.3.tar.xz 
/work/SRC/openSUSE:Factory/.breeze.new/breeze-5.12.4.tar.xz differ: char 25, 
line 1




commit bluedevil5 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package bluedevil5 for openSUSE:Factory 
checked in at 2018-03-30 12:02:57

Comparing /work/SRC/openSUSE:Factory/bluedevil5 (Old)
 and  /work/SRC/openSUSE:Factory/.bluedevil5.new (New)


Package is "bluedevil5"

Fri Mar 30 12:02:57 2018 rev:55 rq:591817 version:5.12.4

Changes:

--- /work/SRC/openSUSE:Factory/bluedevil5/bluedevil5.changes2018-03-09 
10:30:40.553073654 +0100
+++ /work/SRC/openSUSE:Factory/.bluedevil5.new/bluedevil5.changes   
2018-03-30 12:03:00.383315229 +0200
@@ -1,0 +2,10 @@
+Tue Mar 27 15:40:47 CEST 2018 - fab...@ritter-vogt.de
+
+- Update to 5.12.4
+  * New bugfix release
+  * For more details please see:
+  * https://www.kde.org/announcements/plasma-5.12.4.php
+- Changes since 5.12.3:
+  * None
+
+---

Old:

  bluedevil-5.12.3.tar.xz

New:

  bluedevil-5.12.4.tar.xz



Other differences:
--
++ bluedevil5.spec ++
--- /var/tmp/diff_new_pack.lQquTu/_old  2018-03-30 12:03:00.983293534 +0200
+++ /var/tmp/diff_new_pack.lQquTu/_new  2018-03-30 12:03:00.983293534 +0200
@@ -19,7 +19,7 @@
 
 %bcond_without lang
 Name:   bluedevil5
-Version:5.12.3
+Version:5.12.4
 Release:0
 Summary:Bluetooth Manager for KDE Plasma
 License:GPL-2.0+

++ bluedevil-5.12.3.tar.xz -> bluedevil-5.12.4.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bluedevil-5.12.3/CMakeLists.txt 
new/bluedevil-5.12.4/CMakeLists.txt
--- old/bluedevil-5.12.3/CMakeLists.txt 2018-03-06 13:20:20.0 +0100
+++ new/bluedevil-5.12.4/CMakeLists.txt 2018-03-27 13:01:53.0 +0200
@@ -1,5 +1,5 @@
 project(bluedevil)
-set(PROJECT_VERSION "5.12.3")
+set(PROJECT_VERSION "5.12.4")
 set(PROJECT_VERSION_MAJOR 5)
 
 cmake_minimum_required(VERSION 2.8.12)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bluedevil-5.12.3/po/ca@valencia/bluedevil.po 
new/bluedevil-5.12.4/po/ca@valencia/bluedevil.po
--- old/bluedevil-5.12.3/po/ca@valencia/bluedevil.po2018-03-06 
13:19:37.0 +0100
+++ new/bluedevil-5.12.4/po/ca@valencia/bluedevil.po2018-03-27 
13:01:17.0 +0200
@@ -499,7 +499,7 @@
 "Show a notification asking to authorize or deny access to this computer from "
 "Bluetooth.The %1 is the name of the bluetooth device"
 msgid "%1 is requesting access to this computer"
-msgstr "%1 està sol·licitant accés a este ordinador"
+msgstr "%1 està sol·licitant accés a aquest ordinador"
 
 #: kded/helpers/requestauthorization.cpp:45
 #, kde-format
@@ -570,8 +570,8 @@
 "In order to pair this computer with %1, you have to enter a PIN. Please do "
 "it below."
 msgstr ""
-"Per tal d'emparellar este ordinador amb %1 heu d'introduir un PIN, feu-ho a "
-"sota."
+"Per tal d'emparellar aquest ordinador amb %1 heu d'introduir un PIN, feu-ho "
+"a sota."
 
 #. i18n: ectx: property (text), widget (QLabel, label)
 #: kded/helpers/requestpin.ui:52
@@ -650,7 +650,7 @@
 #: kio/bluetooth/kiobluetooth.cpp:106
 #, kde-format
 msgid "This address is unavailable."
-msgstr "Esta adreça no està disponible."
+msgstr "Aquesta adreça no està disponible."
 
 #: kio/bluetooth/kiobluetooth.cpp:155
 #, kde-format
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bluedevil-5.12.3/po/id/bluedevil.po 
new/bluedevil-5.12.4/po/id/bluedevil.po
--- old/bluedevil-5.12.3/po/id/bluedevil.po 2018-03-06 13:19:51.0 
+0100
+++ new/bluedevil-5.12.4/po/id/bluedevil.po 2018-03-27 13:01:31.0 
+0200
@@ -10,7 +10,7 @@
 "Project-Id-Version: KDE Frameworks 5 Applications\n"
 "Report-Msgid-Bugs-To: http://bugs.kde.org\n;
 "POT-Creation-Date: 2018-03-02 06:08+0100\n"
-"PO-Revision-Date: 2018-02-22 23:35+0700\n"
+"PO-Revision-Date: 2018-03-14 20:59+0700\n"
 "Last-Translator: Wantoyo \n"
 "Language-Team: Indonesian \n"
 "Language: id\n"
@@ -342,7 +342,7 @@
 #: kcmodule/devices/devicedetails.ui:180 kio/bluetooth/kiobluetooth.cpp:58
 #, kde-format
 msgid "Send File"
-msgstr "Kirim File"
+msgstr "Kirim Fail"
 
 #. i18n: ectx: property (text), widget (QPushButton, napButton)
 #: kcmodule/devices/devicedetails.ui:187
@@ -452,25 +452,25 @@
 #: kcmodule/global/global.ui:40
 #, kde-format
 msgid "Receiving files"
-msgstr "Penerimaan file"
+msgstr "Penerimaan fail"
 
 #. i18n: ectx: property (text), widget (QCheckBox, kcfg_enabled)
 #: kcmodule/global/global.ui:47
 #, kde-format
 msgid "Receive files from remote devices"
-msgstr "Terima file dari peranti jarak jauh"
+msgstr "Terima fail dari peranti jarak jauh"
 
 #. i18n: ectx: property (text), widget 

commit patterns-base for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package patterns-base for openSUSE:Factory 
checked in at 2018-03-30 12:02:20

Comparing /work/SRC/openSUSE:Factory/patterns-base (Old)
 and  /work/SRC/openSUSE:Factory/.patterns-base.new (New)


Package is "patterns-base"

Fri Mar 30 12:02:20 2018 rev:18 rq:592048 version:20170319

Changes:

--- /work/SRC/openSUSE:Factory/patterns-base/patterns-base.changes  
2018-03-09 10:33:58.941931933 +0100
+++ /work/SRC/openSUSE:Factory/.patterns-base.new/patterns-base.changes 
2018-03-30 12:02:22.580682177 +0200
@@ -1,0 +2,11 @@
+Wed Mar 28 13:04:28 UTC 2018 - f...@suse.com
+
+- Add systemd-coredump to the list of recommended of miminal_base
+
+  Latest systemd package split off its coredump management facility
+  into a sub-package. Recommend this package so this functionnality is
+  still available by default on Factory but give the possibility to
+  block it by using a soft dep (Recommends:). This might be needed on
+  live images for example where space is rather low.
+
+---



Other differences:
--
++ patterns-base.spec ++
--- /var/tmp/diff_new_pack.bs9RWb/_old  2018-03-30 12:02:23.184660337 +0200
+++ /var/tmp/diff_new_pack.bs9RWb/_new  2018-03-30 12:02:23.188660193 +0200
@@ -538,6 +538,7 @@
 Recommends: system-group-wheel
 Recommends: system-user-bin
 Recommends: system-user-daemon
+Recommends: systemd-coredump
 Recommends: sysvinit-tools
 Recommends: udev
 Suggests:   ed




commit systemd for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package systemd for openSUSE:Factory checked 
in at 2018-03-30 12:02:25

Comparing /work/SRC/openSUSE:Factory/systemd (Old)
 and  /work/SRC/openSUSE:Factory/.systemd.new (New)


Package is "systemd"

Fri Mar 30 12:02:25 2018 rev:275 rq:592081 version:237

Changes:

--- /work/SRC/openSUSE:Factory/systemd/systemd-mini.changes 2018-03-16 
10:38:35.938735605 +0100
+++ /work/SRC/openSUSE:Factory/.systemd.new/systemd-mini.changes
2018-03-30 12:02:27.760494873 +0200
@@ -1,0 +2,83 @@
+Wed Mar 28 15:19:45 UTC 2018 - f...@suse.com
+
+- Drop systemd-bash-completion sub-package
+
+  Now we directly ship the completion scripts from the main package as
+  we already do for zsh. I couldn't see any advantages in this split.
+
+---
+Wed Mar 28 15:12:26 UTC 2018 - f...@suse.com
+
+- Be more accurate when specifiying the tools version we provide
+
+---
+Wed Mar 28 15:00:24 UTC 2018 - f...@suse.com
+
+- Make sure rpm won't expand %autopatch even if it's commented
+
+---
+Wed Mar 28 14:55:36 UTC 2018 - f...@suse.com
+
+- stat(1) as well as systemctl are not use in %post section of udev
+
+  So remove stat(1) from the list of dep and move systemctl to the
+  requirements of %postun since it's called from there.
+
+---
+Wed Mar 28 12:30:31 UTC 2018 - f...@suse.com
+
+- Import commit 14b3e00c3ccb8c1c82c8a2e99a9534750880a09e
+
+  e0a8285e2 pid1: when creating service directories, don't chown existing 
files (#8181) (boo#1085971)
+  fb25886b1 Fix format-truncation compile failure by typecasting USB IDs 
(#8250) (bsc#1084638)
+  5a6e9c92e sysusers: make sure to reset errno before calling fget*ent()
+  c2e1ee488 sysusers: also add support for NIS entries in /etc/shadow
+  51cb94fa1 sysusers: do not append entries after the NIS ones (bsc#1085062 
bsc#1045092)
+  783f3d368 basic/macros: rename noreturn into _noreturn_ (#8456)
+
+- Drop 0001-basic-macros-rename-noreturn-into-_noreturn_.patch
+
+  It's been merged in the git repo.
+
+---
+Wed Mar 28 12:13:03 UTC 2018 - f...@suse.com
+
+- Rename the tarball
+
+  So it's clear that it contains some additional patches on top of the
+  upstream version. Use the commit hash in the name so the exact
+  version can easily be identified.
+
+  Provide _service file which can be used to retrieve the tarball from
+  the git repo (with "osc service disabledrun").
+
+---
+Wed Mar 28 11:58:10 UTC 2018 - f...@suse.com
+
+- Split systemd-coredump sub-package off (bsc#1083849)
+
+---
+Tue Mar 27 15:58:34 UTC 2018 - f...@suse.com
+
+- Don't ship machines.target in systemd-container but in systemd main package
+
+  machines.target is supposed to be a standard target for
+  starting/stopping all containers. systemd-nspawn is the main user of
+  it but other container managers could also make use of it.
+
+---
+Sun Mar 25 11:04:04 UTC 2018 - f...@suse.com
+
+- Build a mini variant of systemd-container
+
+  So we don't have to manually track and remove all files that should
+  be shipped by systemd-container in the case of a bootstrap build.
+
+---
+Thu Mar 22 17:09:36 UTC 2018 - f...@suse.com
+
+- Run migrate-sysconfig-i18n.sh also during package installation (bsc#1086164)
+
+  This is needed when we upgrade from SLE11.
+
+---
systemd.changes: same change

Old:

  0001-basic-macros-rename-noreturn-into-_noreturn_.patch
  systemd-237.tar.xz

New:

  _service
  systemd-v237+suse.52.g14b3e00c3.tar.xz



Other differences:
--
++ systemd-mini.spec ++
--- /var/tmp/diff_new_pack.OzJbyU/_old  2018-03-30 12:02:28.964451338 +0200
+++ /var/tmp/diff_new_pack.OzJbyU/_new  2018-03-30 12:02:29.000450036 +0200
@@ -26,6 +26,7 @@
 # WARNING: please do not edit this auto generated spec file. Use the 
systemd.spec! #
 %define mini -mini
 %define min_kernel_version 4.5
+%define suse_version +suse.52.g14b3e00c3
 
 %bcond_with gnuefi
 %if 0%{?bootstrap}
@@ -120,7 +121,6 @@
 Requires:   udev = %{version}-%{release}
 Requires:   util-linux >= 2.27.1
 Requires:   group(lock)
-Recommends: %{name}-bash-completion
 Requires(post): coreutils
 Requires(post): 

commit okular for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package okular for openSUSE:Factory checked 
in at 2018-03-30 12:02:51

Comparing /work/SRC/openSUSE:Factory/okular (Old)
 and  /work/SRC/openSUSE:Factory/.okular.new (New)


Package is "okular"

Fri Mar 30 12:02:51 2018 rev:96 rq:591743 version:17.12.3

Changes:

--- /work/SRC/openSUSE:Factory/okular/okular.changes2018-03-20 
21:42:23.172509712 +0100
+++ /work/SRC/openSUSE:Factory/.okular.new/okular.changes   2018-03-30 
12:02:53.711556480 +0200
@@ -1,0 +2,8 @@
+Tue Mar 27 12:16:21 UTC 2018 - wba...@tmo.at
+
+- Add some build requirements to enable additional features:
+  * Qt5TextToSpeech for text-to-speech support
+  * purpose-devel for enabling the share menu
+  * libmarkdown-devel for displaying Markdown documents
+
+---



Other differences:
--
++ okular.spec ++
--- /var/tmp/diff_new_pack.KIeYBs/_old  2018-03-30 12:02:54.567525528 +0200
+++ /var/tmp/diff_new_pack.KIeYBs/_new  2018-03-30 12:02:54.571525383 +0200
@@ -55,6 +55,7 @@
 BuildRequires:  libepub-devel
 BuildRequires:  libjpeg-devel
 BuildRequires:  libkexiv2-devel
+BuildRequires:  libmarkdown-devel
 BuildRequires:  libpoppler-qt5-devel
 BuildRequires:  libqca-qt5-devel
 BuildRequires:  libspectre-devel
@@ -63,6 +64,7 @@
 BuildRequires:  mobipocket-devel
 BuildRequires:  phonon4qt5-devel
 BuildRequires:  pkgconfig
+BuildRequires:  purpose-devel
 BuildRequires:  threadweaver-devel
 BuildRequires:  zlib-devel
 BuildRequires:  pkgconfig(Qt5Core) >= 5.6.0
@@ -72,6 +74,7 @@
 BuildRequires:  pkgconfig(Qt5Quick) >= 5.6.0
 BuildRequires:  pkgconfig(Qt5Svg) >= 5.6.0
 BuildRequires:  pkgconfig(Qt5Test) >= 5.6.0
+BuildRequires:  pkgconfig(Qt5TextToSpeech)
 BuildRequires:  pkgconfig(Qt5Widgets) >= 5.6.0
 Obsoletes:  okular5 < %{version}
 Provides:   okular5 = %{version}




commit libqt5-qtbase for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package libqt5-qtbase for openSUSE:Factory 
checked in at 2018-03-30 12:02:43

Comparing /work/SRC/openSUSE:Factory/libqt5-qtbase (Old)
 and  /work/SRC/openSUSE:Factory/.libqt5-qtbase.new (New)


Package is "libqt5-qtbase"

Fri Mar 30 12:02:43 2018 rev:79 rq:591726 version:5.10.0

Changes:

--- /work/SRC/openSUSE:Factory/libqt5-qtbase/libqt5-qtbase.changes  
2018-03-12 12:03:17.717574767 +0100
+++ /work/SRC/openSUSE:Factory/.libqt5-qtbase.new/libqt5-qtbase.changes 
2018-03-30 12:02:49.619704441 +0200
@@ -1,0 +2,6 @@
+Tue Mar 27 18:22:40 UTC 2018 - fab...@ritter-vogt.de
+
+- Add patch to fix build with GCC 8 (boo#1087073):
+  * 0001-Do-a-static_cast-in-bit-blasts-that-are-UB.patch
+
+---

New:

  0001-Do-a-static_cast-in-bit-blasts-that-are-UB.patch



Other differences:
--
++ libqt5-qtbase.spec ++
--- /var/tmp/diff_new_pack.doKUsA/_old  2018-03-30 12:02:51.227646298 +0200
+++ /var/tmp/diff_new_pack.doKUsA/_new  2018-03-30 12:02:51.231646153 +0200
@@ -101,6 +101,7 @@
 Patch2026:  0016-CUPS-Rework-set-clearCupsOption-API.patch
 Patch2027:  0017-Cups-Print-Dialog-Change-the-message-box-titles-to-C.patch
 Patch2028:  0018-Fix-build-due-to-missing-QDebug-include.patch
+Patch2029:  0001-Do-a-static_cast-in-bit-blasts-that-are-UB.patch
 BuildRequires:  alsa-devel
 BuildRequires:  cups-devel
 BuildRequires:  double-conversion-devel

++ 0001-Do-a-static_cast-in-bit-blasts-that-are-UB.patch ++
>From 5a53a9893c50cf01fb3b93d256bbc669f99c16ea Mon Sep 17 00:00:00 2001
From: Ville Voutilainen 
Date: Fri, 12 Jan 2018 16:29:00 +0200
Subject: [PATCH] Do a static_cast in bit-blasts that are UB
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Without this, building Qt and Qt applications fails with GCC 8.
The errors look like this:
writing to an object of type ‘class QPointer’ with no 
trivial copy-assignment; use copy-assignment or copy-initialization instead 
[-Werror=class-memaccess]

Task-number: QTBUG-65691
Change-Id: Ie5a30814125deca7a160b9a61f5aa3f944ee1ac9
Reviewed-by: Qt CI Bot 
Reviewed-by: Thiago Macieira 
---
 src/gui/painting/qmatrix.h| 4 ++--
 src/gui/painting/qtransform.h | 6 +++---
 src/gui/text/qtextengine_p.h  | 8 
 src/gui/text/qtextobject.h| 4 ++--
 4 files changed, 11 insertions(+), 11 deletions(-)

diff --git a/src/gui/painting/qmatrix.h b/src/gui/painting/qmatrix.h
index 15e0ab5be1..dafb746bc6 100644
--- a/src/gui/painting/qmatrix.h
+++ b/src/gui/painting/qmatrix.h
@@ -65,10 +65,10 @@ public:
 #if QT_VERSION < QT_VERSION_CHECK(6, 0, 0)
 // ### Qt 6: remove; the compiler-generated ones are fine!
 QMatrix =(QMatrix &) Q_DECL_NOTHROW // = default
-{ memcpy(this, , sizeof(QMatrix)); return *this; }
+{ memcpy(static_cast(this), static_cast(), 
sizeof(QMatrix)); return *this; }
 QMatrix =(const QMatrix &) Q_DECL_NOTHROW; // = default
 QMatrix(QMatrix &) Q_DECL_NOTHROW // = default
-{ memcpy(this, , sizeof(QMatrix)); }
+{ memcpy(static_cast(this), static_cast(), 
sizeof(QMatrix)); }
 QMatrix(const QMatrix ) Q_DECL_NOTHROW; // = default
 #endif
 
diff --git a/src/gui/painting/qtransform.h b/src/gui/painting/qtransform.h
index 06ae611861..efb0fd7e83 100644
--- a/src/gui/painting/qtransform.h
+++ b/src/gui/painting/qtransform.h
@@ -78,14 +78,14 @@ public:
 #if QT_VERSION < QT_VERSION_CHECK(6, 0, 0)
 // ### Qt 6: remove; the compiler-generated ones are fine!
 QTransform =(QTransform &) Q_DECL_NOTHROW // = default
-{ memcpy(this, , sizeof(QTransform)); return *this; }
+{ memcpy(static_cast(this), static_cast(), 
sizeof(QTransform)); return *this; }
 QTransform =(const QTransform &) Q_DECL_NOTHROW; // = default
 QTransform(QTransform &) Q_DECL_NOTHROW // = default
 : affine(Qt::Uninitialized)
-{ memcpy(this, , sizeof(QTransform)); }
+{ memcpy(static_cast(this), static_cast(), 
sizeof(QTransform)); }
 QTransform(const QTransform ) Q_DECL_NOTHROW // = default
 : affine(Qt::Uninitialized)
-{ memcpy(this, , sizeof(QTransform)); }
+{ memcpy(static_cast(this), static_cast(), 
sizeof(QTransform)); }
 #endif
 
 bool isAffine() const;
diff --git a/src/gui/text/qtextengine_p.h b/src/gui/text/qtextengine_p.h
index 89f1328241..90c1a12acd 100644
--- a/src/gui/text/qtextengine_p.h
+++ b/src/gui/text/qtextengine_p.h
@@ -236,13 +236,13 @@ struct QGlyphLayout
 last = numGlyphs;
 if (first == 0 && last == numGlyphs
 && reinterpret_cast(offsets + numGlyphs) == 

commit spirv-tools for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package spirv-tools for openSUSE:Factory 
checked in at 2018-03-30 12:01:54

Comparing /work/SRC/openSUSE:Factory/spirv-tools (Old)
 and  /work/SRC/openSUSE:Factory/.spirv-tools.new (New)


Package is "spirv-tools"

Fri Mar 30 12:01:54 2018 rev:9 rq:592078 version:2018.2

Changes:

--- /work/SRC/openSUSE:Factory/spirv-tools/spirv-tools.changes  2018-03-12 
12:07:27.540621053 +0100
+++ /work/SRC/openSUSE:Factory/.spirv-tools.new/spirv-tools.changes 
2018-03-30 12:01:59.909501978 +0200
@@ -1,0 +2,5 @@
+Wed Mar 28 10:20:48 UTC 2018 - meiss...@suse.com
+
+- add spirv-tools-devel for baselibs, for wine usage.
+
+---



Other differences:
--
++ baselibs.conf ++
--- /var/tmp/diff_new_pack.AWZSec/_old  2018-03-30 12:02:00.649475221 +0200
+++ /var/tmp/diff_new_pack.AWZSec/_new  2018-03-30 12:02:00.649475221 +0200
@@ -1 +1,2 @@
 libSPIRV-Tools-suse6
+spirv-tools-devel




commit openssl-1_1 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package openssl-1_1 for openSUSE:Factory 
checked in at 2018-03-30 12:01:42

Comparing /work/SRC/openSUSE:Factory/openssl-1_1 (Old)
 and  /work/SRC/openSUSE:Factory/.openssl-1_1.new (New)


Package is "openssl-1_1"

Fri Mar 30 12:01:42 2018 rev:2 rq:592073 version:1.1.0h

Changes:

--- /work/SRC/openSUSE:Factory/openssl-1_1/openssl-1_1.changes  2018-03-01 
12:05:25.379235790 +0100
+++ /work/SRC/openSUSE:Factory/.openssl-1_1.new/openssl-1_1.changes 
2018-03-30 12:01:45.154035547 +0200
@@ -1,0 +2,24 @@
+Wed Mar 28 14:34:49 UTC 2018 - vci...@suse.com
+
+- Tolerate a Certificate using a non-supported group on server side
+  (boo#1084651)
+  * https://github.com/openssl/openssl/pull/5607
+  * add 0001-Tolerate-a-Certificate-using-a-non-supported-group-o.patch
+
+---
+Tue Mar 27 14:42:36 UTC 2018 - vci...@suse.com
+
+- Update to 1.1.0h
+  OpenSSL Security Advisory [27 Mar 2018]
+  * Constructed ASN.1 types with a recursive definition could exceed
+the stack (CVE-2018-0739) (bsc#1087102)
+  * rsaz_1024_mul_avx2 overflow bug on x86_64 (CVE-2017-3738)
+(bsc#1071906)
+- refresh patches:
+  * 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
+  * openssl-1.1.0-fips.patch
+  * openssl-pkgconfig.patch
+  * openssl-rsakeygen-minimum-distance.patch
+  * openssl-static-deps.patch
+
+---

Old:

  openssl-1.1.0g.tar.gz
  openssl-1.1.0g.tar.gz.asc

New:

  0001-Tolerate-a-Certificate-using-a-non-supported-group-o.patch
  openssl-1.1.0h.tar.gz
  openssl-1.1.0h.tar.gz.asc



Other differences:
--
++ openssl-1_1.spec ++
--- /var/tmp/diff_new_pack.1tc961/_old  2018-03-30 12:01:46.090001702 +0200
+++ /var/tmp/diff_new_pack.1tc961/_new  2018-03-30 12:01:46.090001702 +0200
@@ -20,7 +20,7 @@
 %define maj_min 1.1
 %define _rname  openssl
 Name:   openssl-1_1
-Version:1.1.0g
+Version:1.1.0h
 Release:0
 Summary:Secure Sockets and Transport Layer Security
 License:OpenSSL
@@ -74,6 +74,8 @@
 Patch70:0011-crypto-aes-asm-aes-s390x.pl-add-CFI-annotations-KMA-.patch
 Patch71:0012-s390x-assembly-pack-add-KMA-code-path-for-aes-gcm.patch
 Patch72:0013-crypto-aes-asm-aes-s390x.pl-add-CFI-annotations-KMA-.patch
+# PATCH-FIX-UPSTREAM (boo#1084651)
+Patch73:0001-Tolerate-a-Certificate-using-a-non-supported-group-o.patch
 BuildRequires:  bc
 BuildRequires:  ed
 BuildRequires:  pkgconfig

++ 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch ++
--- /var/tmp/diff_new_pack.1tc961/_old  2018-03-30 12:01:46.141999822 +0200
+++ /var/tmp/diff_new_pack.1tc961/_new  2018-03-30 12:01:46.141999822 +0200
@@ -4,11 +4,11 @@
 Subject: [PATCH] Axe builtin printf implementation, use glibc instead
 
 
-Index: openssl-1.1.0g/crypto/bio/b_print.c
+Index: openssl-1.1.0h/crypto/bio/b_print.c
 ===
 openssl-1.1.0g.orig/crypto/bio/b_print.c   2017-11-02 15:29:02.0 
+0100
-+++ openssl-1.1.0g/crypto/bio/b_print.c2017-11-02 20:48:01.240953505 
+0100
-@@ -21,831 +21,6 @@
+--- openssl-1.1.0h.orig/crypto/bio/b_print.c   2018-03-27 15:50:37.0 
+0200
 openssl-1.1.0h/crypto/bio/b_print.c2018-03-27 16:31:15.425784205 
+0200
+@@ -21,830 +21,6 @@
   * on all source code distributions.
   */
  
@@ -656,7 +656,7 @@
 -iconvert[iplace++] = "0123456789"[intpart % 10];
 -intpart = (intpart / 10);
 -} while (intpart && (iplace < (int)sizeof(iconvert)));
--if (iplace == sizeof iconvert)
+-if (iplace == sizeof(iconvert))
 -iplace--;
 -iconvert[iplace] = 0;
 -
@@ -674,7 +674,7 @@
 -fracpart = (fracpart / 10);
 -}
 -
--if (fplace == sizeof fconvert)
+-if (fplace == sizeof(fconvert))
 -fplace--;
 -fconvert[fplace] = 0;
 -
@@ -836,11 +836,10 @@
 -}
 -
 -/***/
--
+ 
  int BIO_printf(BIO *bio, const char *format, ...)
  {
- va_list args;
-@@ -859,30 +34,36 @@ int BIO_printf(BIO *bio, const char *for
+@@ -859,30 +35,36 @@ int BIO_printf(BIO *bio, const char *for
  return (ret);
  }
  
@@ -898,7 +897,7 @@
  return (ret);
  }
  
-@@ -898,29 +79,21 @@ int BIO_snprintf(char *buf, size_t n, co
+@@ -898,29 +80,21 @@ int BIO_snprintf(char *buf, size_t n, co
  int ret;
  
  va_start(args, format);
@@ -936,10 +935,10 @@
 -return (retlen <= INT_MAX) ? (int)retlen : -1;
 +return (ret);
  }
-Index: openssl-1.1.0g/test/bioprinttest.c
+Index: openssl-1.1.0h/test/bioprinttest.c
 

commit perl-XML-LibXSLT for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package perl-XML-LibXSLT for 
openSUSE:Factory checked in at 2018-03-30 12:01:15

Comparing /work/SRC/openSUSE:Factory/perl-XML-LibXSLT (Old)
 and  /work/SRC/openSUSE:Factory/.perl-XML-LibXSLT.new (New)


Package is "perl-XML-LibXSLT"

Fri Mar 30 12:01:15 2018 rev:35 rq:591954 version:1.96

Changes:

--- /work/SRC/openSUSE:Factory/perl-XML-LibXSLT/perl-XML-LibXSLT.changes
2017-12-14 10:50:25.216072360 +0100
+++ /work/SRC/openSUSE:Factory/.perl-XML-LibXSLT.new/perl-XML-LibXSLT.changes   
2018-03-30 12:01:17.935019816 +0200
@@ -1,0 +2,11 @@
+Wed Mar 28 09:11:29 UTC 2018 - pmonrealgonza...@suse.com
+
+- updated to 1.96
+1.962018-02-21
+- Apply patch from RT#83028
+- $Config{libs} is not needed
+- Move to git/GitHub:
+- https://github.com/shlomif/perl-XML-LibXSLT .
+- For Travis-CI/etc.
+
+---

Old:

  XML-LibXSLT-1.95.tar.gz

New:

  XML-LibXSLT-1.96.tar.gz



Other differences:
--
++ perl-XML-LibXSLT.spec ++
--- /var/tmp/diff_new_pack.pH7cmo/_old  2018-03-30 12:01:18.670993202 +0200
+++ /var/tmp/diff_new_pack.pH7cmo/_new  2018-03-30 12:01:18.674993057 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-XML-LibXSLT
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   perl-XML-LibXSLT
-Version:1.95
+Version:1.96
 Release:0
 %define cpan_name XML-LibXSLT
 Summary:Interface to the GNOME libxslt library

++ XML-LibXSLT-1.95.tar.gz -> XML-LibXSLT-1.96.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/XML-LibXSLT-1.95/Changes new/XML-LibXSLT-1.96/Changes
--- old/XML-LibXSLT-1.95/Changes2016-07-30 13:09:21.0 +0200
+++ new/XML-LibXSLT-1.96/Changes2018-02-21 11:14:28.0 +0100
@@ -1,5 +1,12 @@
 Revision history for Perl extension XML::LibXSLT.
 
+1.962018-02-21
+- Apply patch from RT#83028
+- $Config{libs} is not needed
+- Move to git/GitHub:
+- https://github.com/shlomif/perl-XML-LibXSLT .
+- For Travis-CI/etc.
+
 1.952016-07-30
 - Hopefully fix RT#116461
 - https://rt.cpan.org/Public/Bug/Display.html?id=116461
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/XML-LibXSLT-1.95/LibXSLT.pm 
new/XML-LibXSLT-1.96/LibXSLT.pm
--- old/XML-LibXSLT-1.95/LibXSLT.pm 2016-07-30 13:10:57.0 +0200
+++ new/XML-LibXSLT-1.96/LibXSLT.pm 2018-02-21 11:15:25.0 +0100
@@ -29,7 +29,7 @@
 
 require Exporter;
 
-$VERSION = '1.95';
+$VERSION = '1.96';
 
 require DynaLoader;
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/XML-LibXSLT-1.95/META.json 
new/XML-LibXSLT-1.96/META.json
--- old/XML-LibXSLT-1.95/META.json  2016-07-30 13:12:00.0 +0200
+++ new/XML-LibXSLT-1.96/META.json  2018-02-21 11:23:13.0 +0100
@@ -4,7 +4,7 @@
   "Matt Sergeant"
],
"dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 7.16, CPAN::Meta::Converter 
version 2.150005",
+   "generated_by" : "ExtUtils::MakeMaker version 7.24, CPAN::Meta::Converter 
version 2.150010",
"license" : [
   "perl_5"
],
@@ -43,11 +43,11 @@
"release_status" : "stable",
"resources" : {
   "repository" : {
- "type" : "hg",
- "url" : "https://bitbucket.org/shlomif/perl-xml-libxslt;,
- "web" : "https://bitbucket.org/shlomif/perl-xml-libxslt;
+ "type" : "git",
+ "url" : "https://github.com/shlomif/perl-XML-LibXSLT;,
+ "web" : "https://github.com/shlomif/perl-XML-LibXSLT;
   }
},
-   "version" : "1.95",
-   "x_serialization_backend" : "JSON::PP version 2.27300"
+   "version" : "1.96",
+   "x_serialization_backend" : "JSON::PP version 2.27400_02"
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/XML-LibXSLT-1.95/META.yml 
new/XML-LibXSLT-1.96/META.yml
--- old/XML-LibXSLT-1.95/META.yml   2016-07-30 13:12:00.0 +0200
+++ new/XML-LibXSLT-1.96/META.yml   2018-02-21 11:23:13.0 +0100
@@ -7,7 +7,7 @@
 configure_requires:
   ExtUtils::MakeMaker: '0'
 dynamic_config: 1
-generated_by: 'ExtUtils::MakeMaker version 7.16, CPAN::Meta::Converter version 
2.150005'
+generated_by: 'ExtUtils::MakeMaker version 7.24, CPAN::Meta::Converter version 
2.150010'
 

commit gstreamer-plugins-ugly for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package gstreamer-plugins-ugly for 
openSUSE:Factory checked in at 2018-03-30 12:02:00

Comparing /work/SRC/openSUSE:Factory/gstreamer-plugins-ugly (Old)
 and  /work/SRC/openSUSE:Factory/.gstreamer-plugins-ugly.new (New)


Package is "gstreamer-plugins-ugly"

Fri Mar 30 12:02:00 2018 rev:50 rq:592331 version:1.12.5

Changes:

--- 
/work/SRC/openSUSE:Factory/gstreamer-plugins-ugly/gstreamer-plugins-ugly.changes
2018-03-02 21:08:42.535412110 +0100
+++ 
/work/SRC/openSUSE:Factory/.gstreamer-plugins-ugly.new/gstreamer-plugins-ugly.changes
   2018-03-30 12:02:00.845468134 +0200
@@ -1,0 +2,16 @@
+Thu Mar 29 12:22:25 UTC 2018 - bjorn@gmail.com
+
+- Update to version 1.12.5:
+  + Bugs fixed: bgo#792111.
+- Drop gst-ugly-amrnwbdec-fixes.patch and
+  gst-x264enc-fix-build-x264-multiple-bit-depths.patch: Fixed
+  upstream.
+
+---
+Mon Mar 26 23:18:19 UTC 2018 - bjorn@gmail.com
+
+- Add gst-x264enc-fix-build-x264-multiple-bit-depths.patch:
+  x264enc: fix build with newer x264 with support for multiple bit
+  depths (bgo#792111).
+
+---

Old:

  gst-plugins-ugly-1.12.4.tar.xz
  gst-ugly-amrnwbdec-fixes.patch

New:

  gst-plugins-ugly-1.12.5.tar.xz



Other differences:
--
++ gstreamer-plugins-ugly.spec ++
--- /var/tmp/diff_new_pack.sn1b0o/_old  2018-03-30 12:02:01.785434144 +0200
+++ /var/tmp/diff_new_pack.sn1b0o/_new  2018-03-30 12:02:01.793433854 +0200
@@ -25,7 +25,7 @@
 # Get minimum gstreamer and gstreamer-plugins-base required versions from 
configure.ac
 %define gstreamer_plugins_ugly_req %(xzgrep --text "^GST.*_REQ" %{SOURCE0} | 
sort -u | sed 's/GST_REQ=/gstreamer >= /;s/GSTPB_REQ=/gstreamer-plugins-base >= 
/' | tr '\\n' ' ')
 Name:   gstreamer-plugins-ugly
-Version:1.12.4
+Version:1.12.5
 Release:0
 Summary:GStreamer Streaming-Media Framework Plug-Ins
 License:LGPL-2.1-or-later
@@ -33,8 +33,6 @@
 URL:http://gstreamer.freedesktop.org/
 Source: 
https://gstreamer.freedesktop.org/src/gst-plugins-ugly/%{_name}-%{version}.tar.xz
 Source99:   baselibs.conf
-# PATCH-FIX-UPSTREAM gst-ugly-amrnwbdec-fixes.patch bjorn@gmail.com -- 
Fixes for amr plugins, only built on third party
-Patch0: gst-ugly-amrnwbdec-fixes.patch
 BuildRequires:  gcc-c++
 BuildRequires:  gtk-doc >= 1.12
 BuildRequires:  liba52-devel
@@ -118,7 +116,6 @@
 
 %prep
 %setup -q -n %{_name}-%{version}
-%patch0 -p1
 
 %build
 export PYTHON=%{_bindir}/python3

++ gst-plugins-ugly-1.12.4.tar.xz -> gst-plugins-ugly-1.12.5.tar.xz ++
 2784 lines of diff (skipped)




commit zstd for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package zstd for openSUSE:Factory checked in 
at 2018-03-30 12:01:48

Comparing /work/SRC/openSUSE:Factory/zstd (Old)
 and  /work/SRC/openSUSE:Factory/.zstd.new (New)


Package is "zstd"

Fri Mar 30 12:01:48 2018 rev:5 rq:592074 version:1.3.4

Changes:

--- /work/SRC/openSUSE:Factory/zstd/zstd.changes2018-02-12 
10:09:45.265312337 +0100
+++ /work/SRC/openSUSE:Factory/.zstd.new/zstd.changes   2018-03-30 
12:01:52.549768111 +0200
@@ -1,0 +2,23 @@
+Wed Mar 28 15:04:25 UTC 2018 - idon...@suse.com
+
+- Update to 1.3.4
+  * perf: faster speed (especially decoding speed) on recent cpus
+(haswell+)
+  * perf: much better performance associating --long with
+multi-threading
+  * perf: better compression at levels 13-15
+  * cli : asynchronous compression by default, for faster
+experience (use --single-thread for former behavior)
+  * cli : smoother status report in multi-threading mode
+  * cli : added command --fast=#, for faster compression modes
+  * cli : fix crash when not overwriting existing files
+  * api : `nbThreads` becomes `nbWorkers` : 1 triggers
+asynchronous mode
+  * api : compression levels can be negative, for even more speed
+  * api : ZSTD_getFrameProgression() : get precise progress
+status of ZSTDMT anytime
+  * api : ZSTDMT can accept new compression parameters during
+compression
+  * api : implemented all advanced dictionary decompression prototypes
+
+---

Old:

  zstd-1.3.3.tar.gz

New:

  zstd-1.3.4.tar.gz



Other differences:
--
++ zstd.spec ++
--- /var/tmp/diff_new_pack.ocDzOS/_old  2018-03-30 12:01:53.477734555 +0200
+++ /var/tmp/diff_new_pack.ocDzOS/_new  2018-03-30 12:01:53.477734555 +0200
@@ -19,10 +19,10 @@
 %define major 1
 %define libname lib%{name}%{major}
 Name:   zstd
-Version:%{major}.3.3
+Version:%{major}.3.4
 Release:0
 Summary:Zstandard compression tools
-License:BSD-3-Clause and GPL-2.0
+License:BSD-3-Clause AND GPL-2.0-only
 Group:  Productivity/Archiving/Compression
 Url:https://github.com/facebook/zstd
 Source0:
https://github.com/facebook/zstd/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz

++ zstd-1.3.3.tar.gz -> zstd-1.3.4.tar.gz ++
 21721 lines of diff (skipped)




commit libedit for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package libedit for openSUSE:Factory checked 
in at 2018-03-30 12:01:11

Comparing /work/SRC/openSUSE:Factory/libedit (Old)
 and  /work/SRC/openSUSE:Factory/.libedit.new (New)


Package is "libedit"

Fri Mar 30 12:01:11 2018 rev:27 rq:591878 version:3.1.snap20150325

Changes:

--- /work/SRC/openSUSE:Factory/libedit/libedit.changes  2015-07-02 
22:44:52.0 +0200
+++ /work/SRC/openSUSE:Factory/.libedit.new/libedit.changes 2018-03-30 
12:01:12.743207558 +0200
@@ -1,0 +2,12 @@
+Wed Mar 28 09:30:51 UTC 2018 - dmuel...@suse.com
+
+- move Changelog back to runtime package as it might not
+  be only developer documentation
+
+---
+Mon Mar 26 15:54:26 CEST 2018 - ku...@suse.de
+
+- Use %license instead of %doc [bsc#1082318]
+- Move development docu into -devel subpackage 
+
+---



Other differences:
--
++ libedit.spec ++
--- /var/tmp/diff_new_pack.2xlDk3/_old  2018-03-30 12:01:13.319186730 +0200
+++ /var/tmp/diff_new_pack.2xlDk3/_new  2018-03-30 12:01:13.335186151 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libedit
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -100,7 +100,8 @@
 %{_libdir}/libedit.so.%{soname}
 %{_libdir}/libedit.so.%{soname}.*
 %{_mandir}/man5/editrc.5%{ext_man}
-%doc README.SUSE THANKS ChangeLog COPYING examples/*c
+%license COPYING
+%doc ChangeLog
 
 %files -n libedit-devel
 %defattr(-,root,root,-)
@@ -109,5 +110,6 @@
 %{_includedir}/editline/
 %{_mandir}/man3/*.3%{ext_man}
 %{_libdir}/pkgconfig/libedit.pc
+%doc examples/*c THANKS README.SUSE
 
 %changelog




commit kded for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package kded for openSUSE:Factory checked in 
at 2018-03-30 12:01:05

Comparing /work/SRC/openSUSE:Factory/kded (Old)
 and  /work/SRC/openSUSE:Factory/.kded.new (New)


Package is "kded"

Fri Mar 30 12:01:05 2018 rev:52 rq:591865 version:5.44.0

Changes:

--- /work/SRC/openSUSE:Factory/kded/kded.changes2018-03-20 
21:45:14.210353775 +0100
+++ /work/SRC/openSUSE:Factory/.kded.new/kded.changes   2018-03-30 
12:01:08.227370856 +0200
@@ -1,0 +2,6 @@
+Wed Mar 28 08:28:45 UTC 2018 - fab...@ritter-vogt.de
+
+- Add patch to support Wayland sessions without QT_QPA_PLATFORM:
+  * 0001-Add-platform-detection-and-adjustment-to-kded.patch
+
+---

New:

  0001-Add-platform-detection-and-adjustment-to-kded.patch



Other differences:
--
++ kded.spec ++
--- /var/tmp/diff_new_pack.0ifKNz/_old  2018-03-30 12:01:09.311331659 +0200
+++ /var/tmp/diff_new_pack.0ifKNz/_new  2018-03-30 12:01:09.311331659 +0200
@@ -52,6 +52,8 @@
 Group:  System/GUI/KDE
 Url:http://www.kde.org
 Source: 
http://download.kde.org/stable/frameworks/%{_tar_path}/%{name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM
+Patch1: 0001-Add-platform-detection-and-adjustment-to-kded.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -72,6 +74,7 @@
 %lang_package
 %prep
 %setup -q
+%autopatch -p1
 
 %build
   %cmake_kf5 -d build

++ 0001-Add-platform-detection-and-adjustment-to-kded.patch ++
>From e213b408ac85f54d01eab82f71bc4210a92a28e1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Martin=20Fl=C3=B6ser?= 
Date: Wed, 28 Mar 2018 10:28:02 +0200
Subject: [PATCH] Add platform detection and adjustment to kded

Summary:
Current Plasma/master branch does no longer set the QT_QPA_PLATFORM env
variable on Wayland. As kded is a process tightly connected to the
workspace it also needs to pick wayland QPA in a Wayland session. This
change brings in the adjustment from plasma-workspace and ensures that
kded works correctly on any Wayland desktop environment, being it
Plasma, GNOME or Weston.

Test Plan: Restarted session, kscreen got layout correctly

Reviewers: #frameworks, #plasma, apol, romangg

Reviewed By: #plasma, romangg

Tags: #frameworks

Differential Revision: https://phabricator.kde.org/D11583
---
 src/kded.cpp | 32 
 1 file changed, 32 insertions(+)

diff --git a/src/kded.cpp b/src/kded.cpp
index b1f02ea..182555e 100644
--- a/src/kded.cpp
+++ b/src/kded.cpp
@@ -689,6 +689,33 @@ static void setupAppInfo(QApplication *app)
 app->setApplicationVersion(QStringLiteral(KDED_VERSION_STRING));
 }
 
+static bool detectPlatform(int argc, char **argv)
+{
+if (qEnvironmentVariableIsSet("QT_QPA_PLATFORM")) {
+return false;
+}
+for (int i = 0; i < argc; i++) {
+if (qstrcmp(argv[i], "-platform") == 0 ||
+qstrcmp(argv[i], "--platform") == 0 ||
+QByteArray(argv[i]).startsWith("-platform=") ||
+QByteArray(argv[i]).startsWith("--platform=")) {
+return false;
+}
+}
+const QByteArray sessionType = qgetenv("XDG_SESSION_TYPE");
+if (sessionType.isEmpty()) {
+return false;
+}
+if (qstrcmp(sessionType, "wayland") == 0) {
+qputenv("QT_QPA_PLATFORM", "wayland");
+return true;
+} else if (qstrcmp(sessionType, "x11") == 0) {
+qputenv("QT_QPA_PLATFORM", "xcb");
+return true;
+}
+return false;
+}
+
 extern "C" Q_DECL_EXPORT int kdemain(int argc, char *argv[])
 {
 #ifdef Q_OS_OSX
@@ -710,11 +737,16 @@ extern "C" Q_DECL_EXPORT int kdemain(int argc, char 
*argv[])
 // WABA: Make sure not to enable session management.
 qunsetenv("SESSION_MANAGER");
 
+const bool unsetQpa = detectPlatform(argc, argv);
+
 // In older versions, QApplication creation was postponed until after
 // testing for --check, in which case, only a QCoreApplication was created.
 // Since that option is no longer used at startup, we removed that speed
 // optimization for code clarity and easier support of standard parameters.
 QApplication app(argc, argv);
+if (unsetQpa) {
+qunsetenv("QT_QPA_PLATFORM");
+}
 setupAppInfo();
 app.setQuitOnLastWindowClosed(false);
 
-- 
2.16.2




commit Mesa for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package Mesa for openSUSE:Factory checked in 
at 2018-03-30 12:01:21

Comparing /work/SRC/openSUSE:Factory/Mesa (Old)
 and  /work/SRC/openSUSE:Factory/.Mesa.new (New)


Package is "Mesa"

Fri Mar 30 12:01:21 2018 rev:320 rq:591959 version:unknown

Changes:

--- /work/SRC/openSUSE:Factory/Mesa/Mesa-drivers.changes2018-03-24 
16:07:02.877519174 +0100
+++ /work/SRC/openSUSE:Factory/.Mesa.new/Mesa-drivers.changes   2018-03-30 
12:01:26.270718387 +0200
@@ -1,0 +2,40 @@
+Wed Mar 28 09:24:25 UTC 2018 - sndir...@suse.com
+
+- Update to 18.0.0 final
+  * one-and-only change since 18.0.0-rc5: updated release notes
+- Changes since 17.3  
+  * The top highlights include:
++ Cannonlake support on i965 and anv
++ GL 4.3/GLES 3.1 support  on r600/evergreen with hw fp64 support
++ Meson build system
+  * ANV Extensions:
++ VK_EXT_external_memory_dma_buf
+  * RADV Extensions:
++ VK_ANDROID_native_buffer
++ VK_KHR_external_fence
++ VK_KHR_external_fence_capabilities
++ VK_KHR_external_fence_fd
++ VK_KHR_get_surface_capabilities2
++ VK_EXT_discard_rectangles
++ VK_EXT_external_memory_dma_buf
++ VK_AMD_shader_info
+  * EGL:
++ Support for RGBA/RGBX 1010102 formats
++ EGL_EXT_pixel_format_float
++ Final planned release to ship wayland-egl. Now provided by wayland.
+  * GLX:
++ Darwin/Apple fixes
+  * Mesa core
++ Support 1 binary format for GL_ARB_get_program_binary on i965
++ drirc workarounds:
+  (*) Unreal 4 Editor
+  (*) Observer
+  (*) Steamroll
+  (*) Refunct
+  * drirc mesa_glthread whitelists:
++ Mount and Blade Warband
+- i965:
+  * Disk shader cache when MESA_GLSL_CACHE_DISABLE is set to "false"
+  * GL_EXT_disjoint_timer_query on gen6+
+
+---
Mesa.changes: same change

Old:

  mesa-18.0.0-rc5.tar.xz
  mesa-18.0.0-rc5.tar.xz.sig

New:

  mesa-18.0.0.tar.xz
  mesa-18.0.0.tar.xz.sig



Other differences:
--
++ Mesa-drivers.spec ++
--- /var/tmp/diff_new_pack.lrCfqT/_old  2018-03-30 12:01:29.274609763 +0200
+++ /var/tmp/diff_new_pack.lrCfqT/_new  2018-03-30 12:01:29.282609473 +0200
@@ -43,7 +43,7 @@
 
 %define glamor 1
 %define _name_archive mesa
-%define _version 18.0.0-rc5
+%define _version 18.0.0
 %define with_opencl 0
 %define with_vulkan 0
 %define with_llvm 0

Mesa.spec: same change

++ mesa-18.0.0-rc5.tar.xz -> mesa-18.0.0.tar.xz ++
/work/SRC/openSUSE:Factory/Mesa/mesa-18.0.0-rc5.tar.xz 
/work/SRC/openSUSE:Factory/.Mesa.new/mesa-18.0.0.tar.xz differ: char 26, line 1




commit xen for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package xen for openSUSE:Factory checked in 
at 2018-03-30 12:00:34

Comparing /work/SRC/openSUSE:Factory/xen (Old)
 and  /work/SRC/openSUSE:Factory/.xen.new (New)


Package is "xen"

Fri Mar 30 12:00:34 2018 rev:245 rq:591751 version:4.10.0_16

Changes:

--- /work/SRC/openSUSE:Factory/xen/xen.changes  2018-03-20 21:50:48.542316318 
+0100
+++ /work/SRC/openSUSE:Factory/.xen.new/xen.changes 2018-03-30 
12:00:43.480265750 +0200
@@ -1,0 +2,12 @@
+Mon Mar 26 08:20:45 MDT 2018 - carn...@suse.com
+
+- Upstream patches from Jan (bsc#1027519) and fixes related to
+  Page Table Isolation (XPTI). See also bsc#1074562 XSA-254
+  5a856a2b-x86-xpti-hide-almost-all-of-Xen-image-mappings.patch
+  5a9eb7f1-x86-xpti-dont-map-stack-guard-pages.patch
+  5a9eb85c-x86-slightly-reduce-XPTI-overhead.patch
+  5a9eb890-x86-remove-CR-reads-from-exit-to-guest-path.patch
+  5aa2b6b9-cpufreq-ondemand-CPU-offlining-race.patch
+  5aaa9878-x86-vlapic-clear-TMR-bit-for-edge-triggered-intr.patch
+
+---

New:

  5a856a2b-x86-xpti-hide-almost-all-of-Xen-image-mappings.patch
  5a9eb7f1-x86-xpti-dont-map-stack-guard-pages.patch
  5a9eb85c-x86-slightly-reduce-XPTI-overhead.patch
  5a9eb890-x86-remove-CR-reads-from-exit-to-guest-path.patch
  5aa2b6b9-cpufreq-ondemand-CPU-offlining-race.patch
  5aaa9878-x86-vlapic-clear-TMR-bit-for-edge-triggered-intr.patch



Other differences:
--
++ xen.spec ++
--- /var/tmp/diff_new_pack.XjVnAv/_old  2018-03-30 12:00:46.148169274 +0200
+++ /var/tmp/diff_new_pack.XjVnAv/_new  2018-03-30 12:00:46.152169129 +0200
@@ -126,7 +126,7 @@
 BuildRequires:  pesign-obs-integration
 %endif
 
-Version:4.10.0_14
+Version:4.10.0_16
 Release:0
 Summary:Xen Virtualization: Hypervisor (aka VMM aka Microkernel)
 License:GPL-2.0
@@ -211,13 +211,19 @@
 Patch48:
5a843807-x86-spec_ctrl-fix-bugs-in-SPEC_CTRL_ENTRY_FROM_INTR_IST.patch
 Patch49:5a856a2b-x86-emul-fix-64bit-decoding-of-segment-overrides.patch
 Patch50:5a856a2b-x86-use-32bit-xors-for-clearing-GPRs.patch
-Patch51:5a8be788-x86-nmi-start-NMI-watchdog-on-CPU0-after-SMP.patch
-Patch52:5a95373b-x86-PV-avoid-leaking-other-guests-MSR_TSC_AUX.patch
-Patch53:5a95571f-memory-dont-implicitly-unpin-in-decrease-res.patch
-Patch54:5a95576c-gnttab-ARM-dont-corrupt-shared-GFN-array.patch
-Patch55:5a955800-gnttab-dont-free-status-pages-on-ver-change.patch
-Patch56:5a955854-x86-disallow-HVM-creation-without-LAPIC-emul.patch
-Patch57:
5a956747-x86-HVM-dont-give-wrong-impression-of-WRMSR-success.patch
+Patch51:5a856a2b-x86-xpti-hide-almost-all-of-Xen-image-mappings.patch
+Patch52:5a8be788-x86-nmi-start-NMI-watchdog-on-CPU0-after-SMP.patch
+Patch53:5a95373b-x86-PV-avoid-leaking-other-guests-MSR_TSC_AUX.patch
+Patch54:5a95571f-memory-dont-implicitly-unpin-in-decrease-res.patch
+Patch55:5a95576c-gnttab-ARM-dont-corrupt-shared-GFN-array.patch
+Patch56:5a955800-gnttab-dont-free-status-pages-on-ver-change.patch
+Patch57:5a955854-x86-disallow-HVM-creation-without-LAPIC-emul.patch
+Patch58:
5a956747-x86-HVM-dont-give-wrong-impression-of-WRMSR-success.patch
+Patch59:5a9eb7f1-x86-xpti-dont-map-stack-guard-pages.patch
+Patch60:5a9eb85c-x86-slightly-reduce-XPTI-overhead.patch
+Patch61:5a9eb890-x86-remove-CR-reads-from-exit-to-guest-path.patch
+Patch62:5aa2b6b9-cpufreq-ondemand-CPU-offlining-race.patch
+Patch63:5aaa9878-x86-vlapic-clear-TMR-bit-for-edge-triggered-intr.patch
 # Our platform specific patches
 Patch400:   xen-destdir.patch
 Patch401:   vif-bridge-no-iptables.patch
@@ -465,6 +471,12 @@
 %patch55 -p1
 %patch56 -p1
 %patch57 -p1
+%patch58 -p1
+%patch59 -p1
+%patch60 -p1
+%patch61 -p1
+%patch62 -p1
+%patch63 -p1
 # Our platform specific patches
 %patch400 -p1
 %patch401 -p1

++ 5a856a2b-x86-xpti-hide-almost-all-of-Xen-image-mappings.patch ++
# Commit 422588e88511d17984544c0f017a927de3315290
# Date 2018-02-15 11:08:27 +
# Author Andrew Cooper 
# Committer Andrew Cooper 
x86/xpti: Hide almost all of .text and all .data/.rodata/.bss mappings

The current XPTI implementation isolates the directmap (and therefore a lot of
guest data), but a large quantity of CPU0's state (including its stack)
remains visible.

Furthermore, an attacker able to read .text is in a vastly superior position
to normal when it comes to fingerprinting Xen for known vulnerabilities, or
scanning for ROP/Spectre gadgets.

Collect together the entrypoints in 

commit python-pbr for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package python-pbr for openSUSE:Factory 
checked in at 2018-03-30 12:00:53

Comparing /work/SRC/openSUSE:Factory/python-pbr (Old)
 and  /work/SRC/openSUSE:Factory/.python-pbr.new (New)


Package is "python-pbr"

Fri Mar 30 12:00:53 2018 rev:33 rq:591779 version:4.0.0

Changes:

--- /work/SRC/openSUSE:Factory/python-pbr/python-pbr-doc.changes
2017-07-04 11:56:35.464595048 +0200
+++ /work/SRC/openSUSE:Factory/.python-pbr.new/python-pbr-doc.changes   
2018-03-30 12:00:56.543793351 +0200
@@ -1,0 +2,40 @@
+Wed Mar 28 04:42:26 UTC 2018 - tbecht...@suse.com
+
+- update to 4.0.0:
+  * builddoc: Treat '[pbr] autodoc\_tree\_excludes' as a multi-line opt
+  * update parse test to use reliable comparison
+  * Make docs on env vars a little clearer
+  * Updated from global requirements
+  * future-proof invocation of apidoc
+  * emit warning correctly
+  * deprecations: Deprecate support for '-py{N}' requirements
+  * doc: Minor rework of usage doc
+  * doc: Rework features doc
+  * Support v version
+  * Deprecate testr and nose integration
+  * tests: Increase coverage of requirements parsing
+  * trivial: Move packaging tests to test\_packaging
+  * Put test-requirements into an extra named 'test'
+  * Support Description-Content-Type metadata
+  * Avoid tox\_install.sh for constraints support
+  * Test on Python 3.6
+  * Support PEP 345 Project-URL metadata
+  * Remove setting of version/release from releasenotes
+  * Use 'build\_reno' setuptools extension if available
+  * Remove unnecessary 'if True'
+  * Discover Distribution through the class hierarchy
+  * Add reno for release notes management
+  * Remove support for command hooks
+  * Remove dead code
+  * Deprecate support for Sphinx < 1.6
+  * builddoc: Use '[sphinx\_build] builders' with Sphinx < 1.6
+  * Remove win32/nt checks for wrapper script gen
+  * Remove py26 support
+  * Update URLs in documents according to document migration
+  * gitignore: Ignore .venv
+  * switch from oslosphinx to openstackdocstheme
+  * Trivial: Fix docstring
+  * turn on warning-as-error flag for doc build
+  * rearrange existing documentation using the new standard layout
+
+---
python-pbr.changes: same change

Old:

  pbr-3.1.1.tar.gz

New:

  pbr-4.0.0.tar.gz



Other differences:
--
++ python-pbr-doc.spec ++
--- /var/tmp/diff_new_pack.dmjEum/_old  2018-03-30 12:00:58.507722333 +0200
+++ /var/tmp/diff_new_pack.dmjEum/_new  2018-03-30 12:00:58.511722188 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pbr-doc
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pbr-doc
-Version:3.1.1
+Version:4.0.0
 Release:0
 Summary:Documentation for python-pbr
 License:Apache-2.0
@@ -28,7 +28,7 @@
 Source1:python-pbr-rpmlintrc
 BuildRequires:  fdupes
 # Documentation requirements:
-BuildRequires:  python3-Sphinx >= 1.1.2
+BuildRequires:  python3-Sphinx >= 1.6.2
 BuildRequires:  python3-setuptools
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch

++ python-pbr.spec ++
--- /var/tmp/diff_new_pack.dmjEum/_old  2018-03-30 12:00:58.547720886 +0200
+++ /var/tmp/diff_new_pack.dmjEum/_new  2018-03-30 12:00:58.559720452 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pbr
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -22,7 +22,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pbr
-Version:3.1.1
+Version:4.0.0
 Release:0
 Summary:Python Build Reasonableness
 License:Apache-2.0

++ pbr-3.1.1.tar.gz -> pbr-4.0.0.tar.gz ++
 4141 lines of diff (skipped)




commit rebootmgr for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package rebootmgr for openSUSE:Factory 
checked in at 2018-03-30 12:01:30

Comparing /work/SRC/openSUSE:Factory/rebootmgr (Old)
 and  /work/SRC/openSUSE:Factory/.rebootmgr.new (New)


Package is "rebootmgr"

Fri Mar 30 12:01:30 2018 rev:9 rq:592031 version:0.17

Changes:

--- /work/SRC/openSUSE:Factory/rebootmgr/rebootmgr.changes  2018-03-26 
11:56:30.109019395 +0200
+++ /work/SRC/openSUSE:Factory/.rebootmgr.new/rebootmgr.changes 2018-03-30 
12:01:36.106362719 +0200
@@ -1,0 +2,6 @@
+Wed Mar 28 13:35:47 CEST 2018 - ku...@suse.de
+
+- Update to version 0.17
+  - fix some bugs around etcd locks and reboot fast path
+
+---

Old:

  rebootmgr-0.16.tar.bz2

New:

  rebootmgr-0.17.tar.bz2



Other differences:
--
++ rebootmgr.spec ++
--- /var/tmp/diff_new_pack.npEaJD/_old  2018-03-30 12:01:37.034329163 +0200
+++ /var/tmp/diff_new_pack.npEaJD/_new  2018-03-30 12:01:37.038329019 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   rebootmgr
-Version:0.16
+Version:0.17
 Release:0
 Summary:Automatic controlled reboot during a maintenance window
 License:GPL-2.0-only AND LGPL-2.1-or-later

++ rebootmgr-0.16.tar.bz2 -> rebootmgr-0.17.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/rebootmgr-0.16/NEWS new/rebootmgr-0.17/NEWS
--- old/rebootmgr-0.16/NEWS 2018-01-10 10:05:26.0 +0100
+++ new/rebootmgr-0.17/NEWS 2018-03-28 13:32:52.0 +0200
@@ -2,6 +2,10 @@
 
 Copyright (C) 2016, 2017, 2018 Thorsten Kukuk
 
+Version 0.17
+* Fix fast reboot with etcd lock [issues/4]
+* Release etcd lock if reboot got canceled
+
 Version 0.16
 * Remove -Werror
 * Use unsigned integers for json-c loops
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/rebootmgr-0.16/configure new/rebootmgr-0.17/configure
--- old/rebootmgr-0.16/configure2018-01-10 10:05:32.0 +0100
+++ new/rebootmgr-0.17/configure2018-03-28 13:32:58.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for rebootmgr 0.16.
+# Generated by GNU Autoconf 2.69 for rebootmgr 0.17.
 #
 #
 # Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
@@ -577,8 +577,8 @@
 # Identity of this package.
 PACKAGE_NAME='rebootmgr'
 PACKAGE_TARNAME='rebootmgr'
-PACKAGE_VERSION='0.16'
-PACKAGE_STRING='rebootmgr 0.16'
+PACKAGE_VERSION='0.17'
+PACKAGE_STRING='rebootmgr 0.17'
 PACKAGE_BUGREPORT=''
 PACKAGE_URL=''
 
@@ -1326,7 +1326,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures rebootmgr 0.16 to adapt to many kinds of systems.
+\`configure' configures rebootmgr 0.17 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1396,7 +1396,7 @@
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
- short | recursive ) echo "Configuration of rebootmgr 0.16:";;
+ short | recursive ) echo "Configuration of rebootmgr 0.17:";;
esac
   cat <<\_ACEOF
 
@@ -1511,7 +1511,7 @@
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-rebootmgr configure 0.16
+rebootmgr configure 0.17
 generated by GNU Autoconf 2.69
 
 Copyright (C) 2012 Free Software Foundation, Inc.
@@ -1876,7 +1876,7 @@
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by rebootmgr $as_me 0.16, which was
+It was created by rebootmgr $as_me 0.17, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   $ $0 $@
@@ -2740,7 +2740,7 @@
 
 # Define the identity of the package.
  PACKAGE='rebootmgr'
- VERSION='0.16'
+ VERSION='0.17'
 
 
 cat >>confdefs.h <<_ACEOF
@@ -8627,7 +8627,7 @@
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log="
-This file was extended by rebootmgr $as_me 0.16, which was
+This file was extended by rebootmgr $as_me 0.17, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   CONFIG_FILES= $CONFIG_FILES
@@ -8693,7 +8693,7 @@
 cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
 ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; 
s/[\\""\`\$]/&/g'`"
 ac_cs_version="\\
-rebootmgr config.status 0.16
+rebootmgr config.status 0.17
 configured by $0, generated by GNU Autoconf 2.69,
   with options \\"\$ac_cs_config\\"
 
diff -urN '--exclude=CVS' 

commit osinfo-db for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package osinfo-db for openSUSE:Factory 
checked in at 2018-03-30 12:00:46

Comparing /work/SRC/openSUSE:Factory/osinfo-db (Old)
 and  /work/SRC/openSUSE:Factory/.osinfo-db.new (New)


Package is "osinfo-db"

Fri Mar 30 12:00:46 2018 rev:10 rq:591757 version:20180311

Changes:

--- /work/SRC/openSUSE:Factory/osinfo-db/osinfo-db.changes  2018-03-19 
23:33:21.312225468 +0100
+++ /work/SRC/openSUSE:Factory/.osinfo-db.new/osinfo-db.changes 2018-03-30 
12:00:47.75628 +0200
@@ -1,0 +2,7 @@
+Fri Mar 23 13:51:30 MDT 2018 - carn...@suse.com
+
+- bsc#1086715 - SLE15 patch for osinfo-db has wrong information
+  in it
+  add-sle15-support.patch
+
+---



Other differences:
--
++ add-sle15-support.patch ++
--- /var/tmp/diff_new_pack.PyGsFi/_old  2018-03-30 12:00:48.276092325 +0200
+++ /var/tmp/diff_new_pack.PyGsFi/_new  2018-03-30 12:00:48.280092180 +0200
@@ -19,7 +19,7 @@
 +
 +  
 +LINUX
-+SLE-15-Server-DVD-x86_64
++SLE-15-Installer-DVD-x86_64
 +  
 +  boot/x86_64/loader/linux
 +  boot/x86_64/loader/initrd
@@ -28,7 +28,7 @@
 +
 +  
 +LINUX
-+SLE-15-Server-DVD-aarch64
++SLE-15-Installer-DVD-aarch64
 +  
 +  boot/aarch64/linux
 +  boot/aarch64/initrd
@@ -37,7 +37,7 @@
 +
 +  
 +LINUX
-+SLE-15-Server-DVD-ppc64le
++SLE-15-Installer-DVD-ppc64le
 +  
 +  boot/ppc64le/linux
 +  boot/ppc64le/initrd
@@ -46,7 +46,7 @@
 +
 +  
 +LINUX
-+SLE-15-Server-DVD-s390x
++SLE-15-Installer-DVD-s390x
 +  
 +  boot/s390x/linux
 +  boot/s390x/initrd
@@ -82,12 +82,12 @@
 +http://suse.com/sled/12.3"/>
 +http://suse.com/sled/12.3"/>
 +
-+2017-00-00
++2018-00-00
 +
 +
 +  
 +LINUX
-+SLE-15-Desktop-DVD-x86_64
++SLE-15-Installer-DVD-x86_64
 +  
 +  boot/x86_64/loader/linux
 +  boot/x86_64/loader/initrd




commit openssl for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package openssl for openSUSE:Factory checked 
in at 2018-03-30 12:00:06

Comparing /work/SRC/openSUSE:Factory/openssl (Old)
 and  /work/SRC/openSUSE:Factory/.openssl.new (New)


Package is "openssl"

Fri Mar 30 12:00:06 2018 rev:144 rq:591688 version:1.1.0h

Changes:

--- /work/SRC/openSUSE:Factory/openssl/openssl.changes  2018-03-01 
12:04:43.732730080 +0100
+++ /work/SRC/openSUSE:Factory/.openssl.new/openssl.changes 2018-03-30 
12:00:24.192963215 +0200
@@ -1,0 +2,5 @@
+Tue Mar 27 14:29:04 UTC 2018 - vci...@suse.com
+
+- Update to 1.1.0h release
+
+---



Other differences:
--
++ openssl.spec ++
--- /var/tmp/diff_new_pack.I3dQcu/_old  2018-03-30 12:00:26.176891471 +0200
+++ /var/tmp/diff_new_pack.I3dQcu/_new  2018-03-30 12:00:26.180891327 +0200
@@ -18,7 +18,7 @@
 
 %define _sonum  1_1
 Name:   openssl
-Version:1.1.0g
+Version:1.1.0h
 Release:0
 Summary:Secure Sockets and Transport Layer Security
 # Yes there is no license but to not confuse people keep it aligned to the pkg




commit grub2 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package grub2 for openSUSE:Factory checked 
in at 2018-03-30 12:01:00

Comparing /work/SRC/openSUSE:Factory/grub2 (Old)
 and  /work/SRC/openSUSE:Factory/.grub2.new (New)


Package is "grub2"

Fri Mar 30 12:01:00 2018 rev:179 rq:591814 version:2.02

Changes:

--- /work/SRC/openSUSE:Factory/grub2/grub2.changes  2018-03-19 
23:30:34.894228962 +0100
+++ /work/SRC/openSUSE:Factory/.grub2.new/grub2.changes 2018-03-30 
12:01:03.707534300 +0200
@@ -1,0 +2,6 @@
+Mon Mar 26 11:37:13 UTC 2018 - msucha...@suse.com
+
+- Fix incorrect netmask on ppc64 (bsc#1085419)
+  * grub2-Fix-incorrect-netmask-on-ppc64.patch
+
+---

New:

  grub2-Fix-incorrect-netmask-on-ppc64.patch



Other differences:
--
++ grub2.spec ++
--- /var/tmp/diff_new_pack.77DXVk/_old  2018-03-30 12:01:05.591466175 +0200
+++ /var/tmp/diff_new_pack.77DXVk/_new  2018-03-30 12:01:05.599465885 +0200
@@ -213,8 +213,7 @@
 Patch82:grub2-diskfilter-support-pv-without-metadatacopies.patch
 Patch83:grub2-efi-uga-64bit-fb.patch
 Patch84:grub2-s390x-09-improve-zipl-setup.patch
-Patch85:
grub2-install-remove-useless-check-PReP-partition-is-empty.patch
-Patch86:grub2-getroot-scan-disk-pv.patch
+Patch85:grub2-getroot-scan-disk-pv.patch
 # Btrfs snapshot booting related patches
 Patch101:   grub2-btrfs-01-add-ability-to-boot-from-subvolumes.patch
 Patch102:   grub2-btrfs-02-export-subvolume-envvars.patch
@@ -247,6 +246,8 @@
 Patch235:   0002-Add-Virtual-LAN-support.patch 
 Patch236:   grub2-efi_gop-avoid-low-resolution.patch
 Patch277:   grub2-ppc64-cas-reboot-support.patch
+Patch278:   
grub2-install-remove-useless-check-PReP-partition-is-empty.patch
+Patch279:   grub2-Fix-incorrect-netmask-on-ppc64.patch
 # Support HTTP Boot IPv4 and IPv6 (fate#320129)
 Patch280:   0001-misc-fix-invalid-character-recongition-in-strto-l.patch
 Patch281:   0002-net-read-bracketed-ipv6-addrs-and-port-numbers.patch
@@ -492,7 +493,6 @@
 %patch83 -p1
 %patch84 -p1
 %patch85 -p1
-%patch86 -p1
 %patch101 -p1
 %patch102 -p1
 %patch103 -p1
@@ -519,6 +519,8 @@
 %patch235 -p1
 %patch236 -p1
 %patch277 -p1
+%patch278 -p1
+%patch279 -p1
 %patch280 -p1
 %patch281 -p1
 %patch282 -p1


++ grub2-Fix-incorrect-netmask-on-ppc64.patch ++
From: Masahiro Matsuya 

The netmask configured in firmware is not respected on ppc64 (big endian).
When 255.255.252.0 is set as netmask in firmware, the following is the value of 
bootpath string in grub_ieee1275_parse_bootpath().

 
/vdevice/l-lan@3002:speed=auto,duplex=auto,192.168.88.10,,192.168.89.113,192.168.88.1,5,5,255.255.252.0,512

The netmask in this bootpath is no problem, since it's a value specified in 
firmware. But,
The value of 'subnet_mask.ipv4' was set with 0xfc00, and __builtin_ctz 
(~grub_le_to_cpu32 (subnet_mask.ipv4)) returned 16 (not 22).
As a result, 16 was used for netmask wrongly.

     1100   # subnet_mask.ipv4 (=0xfc00)
   1100     # grub_le_to_cpu32 (subnet_mask.ipv4)
   0011     # ~grub_le_to_cpu32 (subnet_mask.ipv4)

And, the count of zero with __builtin_ctz can be 16.
This patch changes it as below.

     1100   # subnet_mask.ipv4 (=0xfc00)
   1100     # grub_le_to_cpu32 (subnet_mask.ipv4)
     1100   # grub_swap_bytes32(grub_le_to_cpu32 
(subnet_mask.ipv4))
     0011   # ~grub_swap_bytes32(grub_le_to_cpu32 
(subnet_mask.ipv4))

The count of zero with __builtin_clz can be 22. (clz counts the number of one 
bits preceding the most significant zero bit)
---
 grub-core/net/drivers/ieee1275/ofnet.c | 2 +-
 1 file changed, 1 insertion(+), 2 deletions(-)

diff -ur grub-2.02~/grub-core/net/drivers/ieee1275/ofnet.c 
grub-2.02/grub-core/net/drivers/ieee1275/ofnet.c
--- grub-2.02~/grub-core/net/drivers/ieee1275/ofnet.c   2018-03-26 
13:49:55.399558334 +0200
+++ grub-2.02/grub-core/net/drivers/ieee1275/ofnet.c2018-03-26 
13:51:03.092656921 +0200
@@ -232,7 +232,7 @@
 }
 
   grub_net_add_ipv4_local (inter,
-  __builtin_ctz (~grub_le_to_cpu32 
(subnet_mask.ipv4)));
+  __builtin_clz (~ (subnet_mask.ipv4)));
 }
 
   if (gateway_addr.ipv4 != 0)




commit gdm-branding-openSUSE for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package gdm-branding-openSUSE for 
openSUSE:Factory checked in at 2018-03-30 12:00:28

Comparing /work/SRC/openSUSE:Factory/gdm-branding-openSUSE (Old)
 and  /work/SRC/openSUSE:Factory/.gdm-branding-openSUSE.new (New)


Package is "gdm-branding-openSUSE"

Fri Mar 30 12:00:28 2018 rev:30 rq:591731 version:42.3

Changes:

--- 
/work/SRC/openSUSE:Factory/gdm-branding-openSUSE/gdm-branding-openSUSE.changes  
2018-03-08 10:43:15.376103591 +0100
+++ 
/work/SRC/openSUSE:Factory/.gdm-branding-openSUSE.new/gdm-branding-openSUSE.changes
 2018-03-30 12:00:31.812687670 +0200
@@ -1,0 +2,7 @@
+Tue Mar 27 09:37:38 UTC 2018 - yfji...@suse.com
+
+- Append InitialSetupEnable=False in custom.conf on Leap, disabling
+  the gnome-initial-setup gdm mode, making it consistent with the
+  behavior of SLE (bsc#1067976 boo#1086056).
+
+---



Other differences:
--
++ gdm-branding-openSUSE.spec ++
--- /var/tmp/diff_new_pack.EQ8Fuo/_old  2018-03-30 12:00:32.780652667 +0200
+++ /var/tmp/diff_new_pack.EQ8Fuo/_new  2018-03-30 12:00:32.784652522 +0200
@@ -23,7 +23,7 @@
 Summary:The GNOME Display Manager -- openSUSE default configuration
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
-URL:http://projects.gnome.org/gdm/
+Url:http://projects.gnome.org/gdm/
 Source0:distributor.svg
 Source99:   gdm-branding-openSUSE-rpmlintrc
 # For directory ownership:
@@ -32,6 +32,9 @@
 # WARNING: As this package conflicts with gdm-branding-openSUSE, you cannot
 #  reuse build root. You have to build in a clean build root every 
time!
 BuildRequires:  gdm-branding-upstream
+%if 0%{?sle_version} >= 120300
+BuildRequires:  sed
+%endif
 Requires:   gdm
 Supplements:packageand(gdm:branding-openSUSE)
 Conflicts:  gdm-branding
@@ -53,6 +56,9 @@
 mkdir -p %{buildroot}%{_datadir}/gdm/greeter/images/
 install -d %{buildroot}%{_sysconfdir}/gdm
 install -m0644 custom.conf %{buildroot}%{_sysconfdir}/gdm/custom.conf
+%if 0%{?sle_version} >= 120300
+sed -i -e "s/\[daemon\]/\[daemon\]\nInitialSetupEnable=False/g" 
%{buildroot}%{_sysconfdir}/gdm/custom.conf
+%endif
 cp %{SOURCE0} %{buildroot}%{_datadir}/gdm/greeter/images/
 
 %files





commit MozillaFirefox for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package MozillaFirefox for openSUSE:Factory 
checked in at 2018-03-30 11:59:39

Comparing /work/SRC/openSUSE:Factory/MozillaFirefox (Old)
 and  /work/SRC/openSUSE:Factory/.MozillaFirefox.new (New)


Package is "MozillaFirefox"

Fri Mar 30 11:59:39 2018 rev:268 rq:591686 version:59.0.2

Changes:

--- /work/SRC/openSUSE:Factory/MozillaFirefox/MozillaFirefox.changes
2018-03-20 21:52:28.314723536 +0100
+++ /work/SRC/openSUSE:Factory/.MozillaFirefox.new/MozillaFirefox.changes   
2018-03-30 11:59:54.026054116 +0200
@@ -1,0 +2,35 @@
+Tue Mar 27 14:07:11 UTC 2018 - sch...@suse.de
+
+- Reduce constraints on aarch64
+
+---
+Tue Mar 27 06:40:25 UTC 2018 - w...@rosenauer.org
+
+- update to Firefox 59.0.2
+  * Invalid page rendering with hardware acceleration enabled (bmo#1435472)
+  * Browser keyboard shortcuts (eg copy Ctrl+C) don't work on sites
+that use those keys with resistFingerprinting enabled (bmo#1433592)
+  * High CPU / memory churn caused by third-party software on some
+computers (bmo#1446280)
+  * Users who have configured an "automatic proxy configuration URL"
+and want to reload their proxy settings from the URL will find
+the Reload button disabled in the Connection Settings dialog when
+they select Preferences/Options>Network Proxy>Settings... (bmo#1445991)
+  * URL Fragment Identifiers Break Service Worker Responses (bmo#1443850)
+  * User's trying to cancel a print around the time it completes will
+continue to get intermittent crashes (bmo#1441598)
+  MFSA 2018-10 (bsc#1087059)
+  * CVE-2018-5148 (bmo#1440717)
+Use-after-free in compositor
+- removed obsolete patch mozilla-bmo1446062.patch
+
+---
+Wed Mar 21 17:14:24 UTC 2018 - cgrobert...@suse.com
+
+- Added patches:
+  * mozilla-i586-DecoderDoctorLogger.patch - bmo#1447070
+fixes non-unified build error
+  * mozilla-i586-domPrefs.patch - DOMPrefs.h
+fixes 32bit build error
+
+---

Old:

  firefox-59.0.1-source.tar.xz
  l10n-59.0.1.tar.xz
  mozilla-bmo1446062.patch

New:

  firefox-59.0.2-source.tar.xz
  l10n-59.0.2.tar.xz
  mozilla-i586-DecoderDoctorLogger.patch
  mozilla-i586-domPrefs.patch



Other differences:
--
++ MozillaFirefox.spec ++
--- /var/tmp/diff_new_pack.vm2Vvk/_old  2018-03-30 12:00:19.285140691 +0200
+++ /var/tmp/diff_new_pack.vm2Vvk/_new  2018-03-30 12:00:19.289140547 +0200
@@ -19,10 +19,10 @@
 
 # changed with every update
 %define major 59
-%define mainver %major.0.1
+%define mainver %major.0.2
 %define update_channel release
 %define branding 1
-%define releasedate 20180315233128
+%define releasedate 20180323154952
 
 # PIE, full relro (x86_64 for now)
 %define build_hardened 1
@@ -151,7 +151,8 @@
 Patch7: mozilla-aarch64-startup-crash.patch
 Patch8: mozilla-bmo256180.patch
 Patch9: mozilla-bmo1005535.patch
-Patch10:mozilla-bmo1446062.patch
+Patch10:mozilla-i586-DecoderDoctorLogger.patch
+Patch11:mozilla-i586-domPrefs.patch
 # Firefox/browser
 Patch101:   firefox-kde.patch
 Patch102:   firefox-branded-icons.patch
@@ -263,7 +264,10 @@
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%ifarch %ix86
 %patch10 -p1
+%patch11 -p1
+%endif
 # Firefox
 %patch101 -p1
 %patch102 -p1

++ _constraints ++
--- /var/tmp/diff_new_pack.vm2Vvk/_old  2018-03-30 12:00:19.393136786 +0200
+++ /var/tmp/diff_new_pack.vm2Vvk/_new  2018-03-30 12:00:19.393136786 +0200
@@ -19,4 +19,14 @@
   
 
   
+  
+
+  aarch64
+
+
+  
+9
+  
+
+  
 

++ compare-locales.tar.xz ++

++ create-tar.sh ++
--- /var/tmp/diff_new_pack.vm2Vvk/_old  2018-03-30 12:00:19.493133169 +0200
+++ /var/tmp/diff_new_pack.vm2Vvk/_new  2018-03-30 12:00:19.497133025 +0200
@@ -7,8 +7,8 @@
 
 CHANNEL="release"
 BRANCH="releases/mozilla-$CHANNEL"
-RELEASE_TAG="FIREFOX_59_0_1_RELEASE"
-VERSION="59.0.1"
+RELEASE_TAG="FIREFOX_59_0_2_RELEASE"
+VERSION="59.0.2"
 
 # check required tools
 test -x /usr/bin/hg || ( echo "hg missing: execute zypper in mercurial"; exit 
5 )

++ firefox-59.0.1-source.tar.xz -> firefox-59.0.2-source.tar.xz ++
/work/SRC/openSUSE:Factory/MozillaFirefox/firefox-59.0.1-source.tar.xz 
/work/SRC/openSUSE:Factory/.MozillaFirefox.new/firefox-59.0.2-source.tar.xz 
differ: char 26, line 1

++ l10n-59.0.1.tar.xz -> l10n-59.0.2.tar.xz ++
/work/SRC/openSUSE:Factory/MozillaFirefox/l10n-59.0.1.tar.xz 
/work/SRC/openSUSE:Factory/.MozillaFirefox.new/l10n-59.0.2.tar.xz differ: char 
26, line 1

++ 

commit libnfnetlink for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package libnfnetlink for openSUSE:Factory 
checked in at 2018-03-30 12:00:19

Comparing /work/SRC/openSUSE:Factory/libnfnetlink (Old)
 and  /work/SRC/openSUSE:Factory/.libnfnetlink.new (New)


Package is "libnfnetlink"

Fri Mar 30 12:00:19 2018 rev:20 rq:591708 version:1.0.1

Changes:

--- /work/SRC/openSUSE:Factory/libnfnetlink/libnfnetlink.changes
2014-12-10 23:45:49.0 +0100
+++ /work/SRC/openSUSE:Factory/.libnfnetlink.new/libnfnetlink.changes   
2018-03-30 12:00:27.204854298 +0200
@@ -1,0 +2,5 @@
+Tue Mar 27 13:12:25 CEST 2018 - ku...@suse.de
+
+- Use %license instead of %doc [bsc#1082318]
+
+---



Other differences:
--
++ libnfnetlink.spec ++
--- /var/tmp/diff_new_pack.MTk3Zw/_old  2018-03-30 12:00:28.064823200 +0200
+++ /var/tmp/diff_new_pack.MTk3Zw/_new  2018-03-30 12:00:28.068823056 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libnfnetlink
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,7 +21,7 @@
 Version:1.0.1
 Release:0
 Summary:Low-level library for Netfilter-related kernel/userspace 
communication
-License:GPL-2.0
+License:GPL-2.0-only
 Group:  Productivity/Networking/Security
 Url:http://netfilter.org/projects/libnfnetlink/
 
@@ -99,7 +99,8 @@
 
 %files -n %libsoname
 %defattr(-,root,root)
-%doc COPYING README
+%license COPYING
+%doc README
 %_libdir/libnfnetlink.so.0*
 
 %files devel





commit yp-tools for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package yp-tools for openSUSE:Factory 
checked in at 2018-03-30 11:59:16

Comparing /work/SRC/openSUSE:Factory/yp-tools (Old)
 and  /work/SRC/openSUSE:Factory/.yp-tools.new (New)


Package is "yp-tools"

Fri Mar 30 11:59:16 2018 rev:30 rq:591643 version:4.2.3

Changes:

--- /work/SRC/openSUSE:Factory/yp-tools/yp-tools.changes2018-02-25 
11:33:05.330821145 +0100
+++ /work/SRC/openSUSE:Factory/.yp-tools.new/yp-tools.changes   2018-03-30 
11:59:19.451304429 +0200
@@ -1,0 +2,7 @@
+Tue Mar 27 15:43:48 CEST 2018 - ku...@suse.de
+
+- Update to version 4.2.3
+  - Re-add yptest [issues/#4]
+  - Lower compiler warnings [bsc#1084633]
+
+---

Old:

  yp-tools-4.2.2.tar.bz2

New:

  yp-tools-4.2.3.tar.bz2



Other differences:
--
++ yp-tools.spec ++
--- /var/tmp/diff_new_pack.gLJhIM/_old  2018-03-30 11:59:20.035283311 +0200
+++ /var/tmp/diff_new_pack.gLJhIM/_new  2018-03-30 11:59:20.039283166 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   yp-tools
-Version:4.2.2
+Version:4.2.3
 Release:0
 Summary:Network Information Service (YP) client utilities
 License:GPL-2.0 AND LGPL-2.1
 Group:  Productivity/Networking/NIS
-URL:http://www.linux-nis.org/
-Source: 
http://www.linux-nis.org/download/yp-tools/yp-tools-%{version}.tar.bz2
+URL:https://github.com/thkukuk/yp-tools
+Source: yp-tools-%{version}.tar.bz2
 Source1:match_printcap
 Source2:yp-tools.conf
 BuildRequires:  fdupes
@@ -91,5 +91,6 @@
 %{_sbindir}/yppoll
 %{_sbindir}/ypset
 %{_sbindir}/yp_dump_binding
+%{_sbindir}/yptest
 
 %changelog


++ yp-tools-4.2.2.tar.bz2 -> yp-tools-4.2.3.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yp-tools-4.2.2/ChangeLog new/yp-tools-4.2.3/ChangeLog
--- old/yp-tools-4.2.2/ChangeLog2016-03-14 16:18:03.0 +0100
+++ new/yp-tools-4.2.3/ChangeLog2016-04-05 12:39:59.0 +0200
@@ -3,6 +3,7 @@
* release version 4.2.2
 
* lib/yp_all_host.c: Revert last change.
+   * src/yppoll.c: Use callrpc instead of rpc_call.
 
* release version 4.2.1
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yp-tools-4.2.2/NEWS new/yp-tools-4.2.3/NEWS
--- old/yp-tools-4.2.2/NEWS 2016-03-14 16:18:19.0 +0100
+++ new/yp-tools-4.2.3/NEWS 2018-03-27 15:47:31.0 +0200
@@ -4,8 +4,13 @@
 
 Please send bug reports, questions and suggestions to .
 
+Version 4.2.3
+* Adjustements for newer gcc versions
+* Re-add yptest
+
 Version 4.2.2
 * Revert removal of netdb.h
+* yppoll: Replace IPv4 only code with IPv6 functions
 
 Version 4.2.1
 * Fix configure checks if sunrpc code in glibc is marked as deprecated
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yp-tools-4.2.2/aclocal.m4 
new/yp-tools-4.2.3/aclocal.m4
--- old/yp-tools-4.2.2/aclocal.m4   2016-03-14 16:18:23.0 +0100
+++ new/yp-tools-4.2.3/aclocal.m4   2018-03-27 15:05:51.0 +0200
@@ -375,10 +375,9 @@
 # configured tree to be moved without reconfiguration.
 
 AC_DEFUN([AM_AUX_DIR_EXPAND],
-[dnl Rely on autoconf to set up CDPATH properly.
-AC_PREREQ([2.50])dnl
-# expand $ac_aux_dir to an absolute path
-am_aux_dir=`cd $ac_aux_dir && pwd`
+[AC_REQUIRE([AC_CONFIG_AUX_DIR_DEFAULT])dnl
+# Expand $ac_aux_dir to an absolute path.
+am_aux_dir=`cd "$ac_aux_dir" && pwd`
 ])
 
 # AM_CONDITIONAL-*- Autoconf -*-
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yp-tools-4.2.2/configure new/yp-tools-4.2.3/configure
--- old/yp-tools-4.2.2/configure2016-03-14 16:18:24.0 +0100
+++ new/yp-tools-4.2.3/configure2018-03-27 15:05:54.0 +0200
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for yp-tools 4.2.2.
+# Generated by GNU Autoconf 2.69 for yp-tools 4.2.3.
 #
 # Report bugs to .
 #
@@ -590,8 +590,8 @@
 # Identity of this package.
 PACKAGE_NAME='yp-tools'
 PACKAGE_TARNAME='yp-tools'
-PACKAGE_VERSION='4.2.2'
-PACKAGE_STRING='yp-tools 4.2.2'
+PACKAGE_VERSION='4.2.3'
+PACKAGE_STRING='yp-tools 4.2.3'
 PACKAGE_BUGREPORT='ku...@linux-nis.org'
 PACKAGE_URL=''
 
@@ -1359,7 +1359,7 @@
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures yp-tools 4.2.2 

commit xorg-x11-server for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package xorg-x11-server for openSUSE:Factory 
checked in at 2018-03-30 11:59:22

Comparing /work/SRC/openSUSE:Factory/xorg-x11-server (Old)
 and  /work/SRC/openSUSE:Factory/.xorg-x11-server.new (New)


Package is "xorg-x11-server"

Fri Mar 30 11:59:22 2018 rev:357 rq:591648 version:1.19.6

Changes:

--- /work/SRC/openSUSE:Factory/xorg-x11-server/xorg-x11-server.changes  
2018-03-08 10:56:17.075961230 +0100
+++ /work/SRC/openSUSE:Factory/.xorg-x11-server.new/xorg-x11-server.changes 
2018-03-30 11:59:23.703150670 +0200
@@ -1,0 +2,6 @@
+Tue Mar 27 14:42:18 UTC 2018 - m...@suse.com
+
+- Update and re-enable n_xserver-optimus-autoconfig-hack.patch.
+  (bnc#1084411)
+
+---



Other differences:
--
++ xorg-x11-server.spec ++
--- /var/tmp/diff_new_pack.VTrK2u/_old  2018-03-30 11:59:24.835109736 +0200
+++ /var/tmp/diff_new_pack.VTrK2u/_new  2018-03-30 11:59:24.835109736 +0200
@@ -361,8 +361,7 @@
 %patch216 -p1
 %patch217 -p1
 
-### disabled for now
-#%patch1000 -p1
+%patch1000 -p1
 
 ### disabled for now
 #%patch1162 -p1

++ n_xserver-optimus-autoconfig-hack.patch ++
--- /var/tmp/diff_new_pack.VTrK2u/_old  2018-03-30 11:59:24.943105830 +0200
+++ /var/tmp/diff_new_pack.VTrK2u/_new  2018-03-30 11:59:24.943105830 +0200
@@ -8,6 +8,11 @@
 
 v2: fix if config or slave config is NULL
 v3: fix multi useful slaves
+
+v4: do not unbound GPUs before attaching them
+compatibility fix for 5c7af02b10
+  -- Michal Srb 
+
 DO NOT UPSTREAM.
 
 Signed-off-by: Dave Airlie 
@@ -17,11 +22,11 @@
  hw/xfree86/modes/xf86Crtc.c | 32 
  3 files changed, 47 insertions(+)
 
-diff --git a/hw/xfree86/common/xf86Init.c b/hw/xfree86/common/xf86Init.c
-index 1e95061..c58fd2b 100644
 a/hw/xfree86/common/xf86Init.c
-+++ b/hw/xfree86/common/xf86Init.c
-@@ -361,6 +361,16 @@ xf86CreateRootWindow(WindowPtr pWin)
+Index: xorg-server-1.19.6/hw/xfree86/common/xf86Init.c
+===
+--- xorg-server-1.19.6.orig/hw/xfree86/common/xf86Init.c
 xorg-server-1.19.6/hw/xfree86/common/xf86Init.c
+@@ -297,6 +297,16 @@ xf86PrivsElevated(void)
  return privsElevated;
  }
  
@@ -38,7 +43,7 @@
  static void
  InstallSignalHandlers(void)
  {
-@@ -931,6 +941,8 @@ InitOutput(ScreenInfo * pScreenInfo, int argc, char **argv)
+@@ -872,6 +882,8 @@ InitOutput(ScreenInfo * pScreenInfo, int
  for (i = 0; i < xf86NumGPUScreens; i++)
  AttachUnboundGPU(xf86Screens[0]->pScreen, xf86GPUScreens[i]->pScreen);
  
@@ -47,11 +52,11 @@
  xf86VGAarbiterWrapFunctions();
  if (sigio_blocked)
  input_unlock();
-diff --git a/hw/xfree86/common/xf86platformBus.c 
b/hw/xfree86/common/xf86platformBus.c
-index 33b2b7d..be3bdd9 100644
 a/hw/xfree86/common/xf86platformBus.c
-+++ b/hw/xfree86/common/xf86platformBus.c
-@@ -393,6 +393,8 @@ xf86platformProbeDev(DriverPtr drvp)
+Index: xorg-server-1.19.6/hw/xfree86/common/xf86platformBus.c
+===
+--- xorg-server-1.19.6.orig/hw/xfree86/common/xf86platformBus.c
 xorg-server-1.19.6/hw/xfree86/common/xf86platformBus.c
+@@ -489,6 +489,8 @@ xf86platformProbeDev(DriverPtr drvp)
  return foundScreen;
  }
  
@@ -60,7 +65,7 @@
  int
  xf86platformAddDevice(int index)
  {
-@@ -465,6 +467,7 @@ xf86platformAddDevice(int index)
+@@ -560,6 +562,7 @@ xf86platformAddDevice(int index)
 }
 /* attach unbound to 0 protocol screen */
 AttachUnboundGPU(xf86Screens[0]->pScreen, xf86GPUScreens[i]->pScreen);
@@ -68,11 +73,11 @@
  
 RRResourcesChanged(xf86Screens[0]->pScreen);
 RRTellChanged(xf86Screens[0]->pScreen);
-diff --git a/hw/xfree86/modes/xf86Crtc.c b/hw/xfree86/modes/xf86Crtc.c
-index a441fd1..c1a56a5 100644
 a/hw/xfree86/modes/xf86Crtc.c
-+++ b/hw/xfree86/modes/xf86Crtc.c
-@@ -3383,3 +3383,35 @@ xf86DetachAllCrtc(ScrnInfoPtr scrn)
+Index: xorg-server-1.19.6/hw/xfree86/modes/xf86Crtc.c
+===
+--- xorg-server-1.19.6.orig/hw/xfree86/modes/xf86Crtc.c
 xorg-server-1.19.6/hw/xfree86/modes/xf86Crtc.c
+@@ -3462,3 +3462,29 @@ xf86DetachAllCrtc(ScrnInfoPtr scrn)
  crtc->x = crtc->y = 0;
  }
  }
@@ -83,7 +88,6 @@
 +RRProviderPtr master_provider;
 +xf86CrtcConfigPtr config = XF86_CRTC_CONFIG_PTR(master);
 +xf86CrtcConfigPtr slave_config = XF86_CRTC_CONFIG_PTR(pScrn);
-+Bool unbound = FALSE;
 +
 +if (!config || !slave_config)
 +return;
@@ -92,22 +96,14 @@
 +
 +if ((master->capabilities & RR_Capability_SinkOffload) &&
 +  

commit python-cryptography for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package python-cryptography for 
openSUSE:Factory checked in at 2018-03-30 11:59:02

Comparing /work/SRC/openSUSE:Factory/python-cryptography (Old)
 and  /work/SRC/openSUSE:Factory/.python-cryptography.new (New)


Package is "python-cryptography"

Fri Mar 30 11:59:02 2018 rev:38 rq:591618 version:2.2.1

Changes:

--- /work/SRC/openSUSE:Factory/python-cryptography/python-cryptography.changes  
2018-03-06 10:44:37.926041007 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-cryptography.new/python-cryptography.changes 
2018-03-30 11:59:12.715548014 +0200
@@ -1,0 +2,31 @@
+Mon Mar 26 07:44:53 UTC 2018 - tchva...@suse.com
+
+- Cleanup with spec-cleaner
+- Use %setup to unpack all archives do not rely on tar calls
+
+---
+Sun Mar 25 20:39:43 UTC 2018 - mich...@stroeder.com
+
+- Update to upstream release 2.2.1:
+  * Reverted a change to GeneralNames which prohibited having zero elements,
+due to breakages.
+  * Fixed a bug in
+:func:`~cryptography.hazmat.primitives.keywrap.aes_key_unwrap_with_padding`
+that caused it to raise InvalidUnwrap when key length modulo 8 was zero.
+  * BACKWARDS INCOMPATIBLE: Support for Python 2.6 has been dropped.
+  * Resolved a bug in HKDF that incorrectly constrained output size.
+  * Added
+:class:`~cryptography.hazmat.primitives.asymmetric.ec.BrainpoolP256R1`,
+:class:`~cryptography.hazmat.primitives.asymmetric.ec.BrainpoolP384R1`, and
+:class:`~cryptography.hazmat.primitives.asymmetric.ec.BrainpoolP512R1` to
+support inter-operating with systems like German smart meters.
+  * Added token rotation support to :doc:`Fernet ` with
+:meth:`~cryptography.fernet.MultiFernet.rotate`.
+  * Fixed a memory leak in
+:func:`~cryptography.hazmat.primitives.asymmetric.ec.derive_private_key`.
+  * Added support for AES key wrapping with padding via
+:func:`~cryptography.hazmat.primitives.keywrap.aes_key_wrap_with_padding` 
and
+
:func:`~cryptography.hazmat.primitives.keywrap.aes_key_unwrap_with_padding` .
+* Allow loading DSA keys with 224 bit q.
+
+---

Old:

  cryptography-2.1.4.tar.gz
  cryptography-2.1.4.tar.gz.asc
  cryptography_vectors-2.1.4.tar.gz
  cryptography_vectors-2.1.4.tar.gz.asc

New:

  cryptography-2.2.1.tar.gz
  cryptography-2.2.1.tar.gz.asc
  cryptography_vectors-2.2.1.tar.gz
  cryptography_vectors-2.2.1.tar.gz.asc



Other differences:
--
++ python-cryptography.spec ++
--- /var/tmp/diff_new_pack.OcKaaI/_old  2018-03-30 11:59:13.919504475 +0200
+++ /var/tmp/diff_new_pack.OcKaaI/_new  2018-03-30 11:59:13.919504475 +0200
@@ -19,17 +19,18 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %bcond_without python2
 Name:   python-cryptography
-Version:2.1.4
+Version:2.2.1
 Release:0
 Summary:Python library which exposes cryptographic recipes and 
primitives
 License:Apache-2.0 OR BSD-3-Clause
 Group:  Development/Languages/Python
-Url:https://cryptography.io/en/latest/
+URL:https://cryptography.io/en/latest/
 Source0:
https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
 Source1:
https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz.asc
 Source2:%{name}.keyring
-Source3:
https://files.pythonhosted.org/packages/source/c/cryptography_vectors/cryptography_vectors-%{version}.tar.gz
-Source4:
https://files.pythonhosted.org/packages/source/c/cryptography_vectors/cryptography_vectors-%{version}.tar.gz.asc
+# found on pypi but not on pythonhosted :/
+Source3:cryptography_vectors-%{version}.tar.gz
+Source4:cryptography_vectors-%{version}.tar.gz.asc
 # PATCH-FIX-SLE disable-uneven-sizes-tests.patch bnc#944204
 Patch1: disable-uneven-sizes-tests.patch
 Patch2: skip_openssl_memleak_test.patch
@@ -89,11 +90,7 @@
 functions.
 
 %prep
-%setup -q -n cryptography-%{version}
-
-# prepare vectors module
-tar xvzf %{SOURCE3}
-
+%setup -q -n cryptography-%{version} -a3
 %patch1 -p1
 %patch2 -p1
 
@@ -122,7 +119,7 @@
 }
 
 %files %{python_files}
-%doc LICENSE LICENSE.APACHE LICENSE.BSD
+%license LICENSE LICENSE.APACHE LICENSE.BSD
 %doc AUTHORS.rst CONTRIBUTING.rst CHANGELOG.rst README.rst
 %{python_sitearch}/*
 

++ cryptography-2.1.4.tar.gz -> cryptography-2.2.1.tar.gz ++
 3466 lines of diff (skipped)

++ cryptography_vectors-2.1.4.tar.gz -> cryptography_vectors-2.2.1.tar.gz 
++

commit sanlock for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package sanlock for openSUSE:Factory checked 
in at 2018-03-30 11:59:27

Comparing /work/SRC/openSUSE:Factory/sanlock (Old)
 and  /work/SRC/openSUSE:Factory/.sanlock.new (New)


Package is "sanlock"

Fri Mar 30 11:59:27 2018 rev:18 rq:591650 version:3.6.0

Changes:

--- /work/SRC/openSUSE:Factory/sanlock/sanlock.changes  2017-12-12 
21:16:57.451841183 +0100
+++ /work/SRC/openSUSE:Factory/.sanlock.new/sanlock.changes 2018-03-30 
11:59:32.810821312 +0200
@@ -1,0 +2,22 @@
+Mon Mar 26 16:36:05 UTC 2018 - jfeh...@suse.com
+
+- Fix module initialization to work with both python2 and python3
+  Updated sanlock-python3.patch
+  bsc#1076414
+
+---
+Wed Mar 21 12:58:08 UTC 2018 - tchva...@suse.com
+
+- Add code to build with both python2 and python3 bindings with
+  provided condition so we can later on optionalize python2 builds
+  sanlock-python3.patch
+  bsc#1076414
+
+---
+Wed Mar 21 12:44:29 UTC 2018 - tchva...@suse.com
+
+- Cleanup with spec-cleaner (only support SLE12 and newer)
+- Add -fno-strict-aliasing to python subpkg
+- Create rcsanlk-resetd link for the service control
+
+---

New:

  sanlock-python3.patch



Other differences:
--
++ sanlock.spec ++
--- /var/tmp/diff_new_pack.VsLmAn/_old  2018-03-30 11:59:33.538794986 +0200
+++ /var/tmp/diff_new_pack.VsLmAn/_new  2018-03-30 11:59:33.542794842 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package sanlock
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,43 +16,24 @@
 #
 
 
-#Compat macro for new _fillupdir macro introduced in Nov 2017
-%if ! %{defined _fillupdir}
-  %define _fillupdir /var/adm/fillup-templates
-%endif
-
 %define with_fence_sanlockd 0
 %define with_sanlk_reset0
-
 %if 0%{?suse_version} > 1320
 %define with_fence_sanlockd 1
 %define with_sanlk_reset1
 %endif
-
+#Compat macro for new _fillupdir macro introduced in Nov 2017
+%if ! %{defined _fillupdir}
+  %define _fillupdir %{_localstatedir}/adm/fillup-templates
+%endif
+%bcond_without python2
 Name:   sanlock
 Version:3.6.0
 Release:0
 Summary:A shared disk lock manager
-License:GPL-2.0 and GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0-only AND GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/Base
-
 Url:https://pagure.io/sanlock
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  libaio-devel
-BuildRequires:  libblkid-devel
-BuildRequires:  python
-BuildRequires:  python-devel
-BuildRequires:  systemd
-%{?systemd_requires}
-BuildRequires:  xz
-Requires(pre):  %fillup_prereq
-%if 0%{?suse_version} > 1320
-Requires(pre):  group(disk)
-%endif
-Requires(pre):  %{_sbindir}/groupadd
-Requires(pre):  %{_sbindir}/useradd
-Requires:   %{name}-lib = %{version}-%{release}
-Recommends: logrotate
 Source0:%{name}-%{version}.tar.gz
 Source1:sysconfig.sanlock
 Source2:sysconfig.wdmd
@@ -66,8 +47,20 @@
 Patch104:   suse-no-date-time.patch
 # bsc#1030060
 Patch105:   suse-fix-link-errors.patch
-
-%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+Patch106:   sanlock-python3.patch
+BuildRequires:  %{python_module devel}
+BuildRequires:  libaio-devel
+BuildRequires:  pkgconfig
+BuildRequires:  python-rpm-macros
+BuildRequires:  systemd-rpm-macros
+BuildRequires:  pkgconfig(blkid)
+Requires(pre):  %fillup_prereq
+Requires(pre):  shadow
+Recommends: logrotate
+%{?systemd_requires}
+%if 0%{?suse_version} >= 1500
+Requires(pre):  group(disk)
+%endif
 
 %description
 sanlock uses disk paxos to manage leases on shared storage.
@@ -75,25 +68,36 @@
 access to the shared disks.
 
 %package-n libsanlock1
-Provides:   sanlock-lib
 Summary:A shared disk lock manager library
 Group:  Development/Libraries/C and C++
+Provides:   sanlock-lib = %{version}
 
 %description-n libsanlock1
 The runtime libraries for sanlock, a shared disk lock manager.
 Hosts connected to a common SAN can use this to synchronize their
 access to the shared disks.
 
-%package-n python-%name
+%package-n python2-%{name}
+Summary:Python bindings for the sanlock library
+Group:  Development/Libraries/Python
+Requires:   libsanlock1 

commit libogg for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package libogg for openSUSE:Factory checked 
in at 2018-03-30 11:58:15

Comparing /work/SRC/openSUSE:Factory/libogg (Old)
 and  /work/SRC/openSUSE:Factory/.libogg.new (New)


Package is "libogg"

Fri Mar 30 11:58:15 2018 rev:33 rq:591555 version:1.3.3

Changes:

--- /work/SRC/openSUSE:Factory/libogg/libogg.changes2017-03-16 
09:34:01.278588348 +0100
+++ /work/SRC/openSUSE:Factory/.libogg.new/libogg.changes   2018-03-30 
11:58:19.217482683 +0200
@@ -1,0 +2,7 @@
+Tue Mar 27 07:29:22 UTC 2018 - 9+suse@cirno.systems
+
+- Use %license macro
+- Update to version 1.3.3
+  * Fix an issue with corrupt continued packet handling.
+
+---

Old:

  libogg-1.3.2.tar.xz

New:

  libogg-1.3.3.tar.xz



Other differences:
--
++ libogg.spec ++
--- /var/tmp/diff_new_pack.7XPhiR/_old  2018-03-30 11:58:21.101414553 +0200
+++ /var/tmp/diff_new_pack.7XPhiR/_new  2018-03-30 11:58:21.105414409 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libogg
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,7 +19,7 @@
 %define _SO_nr 0
 
 Name:   libogg
-Version:1.3.2
+Version:1.3.3
 Release:0
 Summary:Ogg Bitstream Library
 License:BSD-3-Clause
@@ -89,7 +89,8 @@
 
 %files -n libogg%{_SO_nr}
 %defattr(0644,root,root,0755)
-%doc AUTHORS CHANGES COPYING README
+%doc AUTHORS CHANGES README.md
+%license COPYING
 %{_libdir}/libogg.so.%{_SO_nr}*
 
 %files devel

++ libogg-1.3.2.tar.xz -> libogg-1.3.3.tar.xz ++
 27663 lines of diff (skipped)




commit nodejs8 for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package nodejs8 for openSUSE:Factory checked 
in at 2018-03-30 11:58:42

Comparing /work/SRC/openSUSE:Factory/nodejs8 (Old)
 and  /work/SRC/openSUSE:Factory/.nodejs8.new (New)


Package is "nodejs8"

Fri Mar 30 11:58:42 2018 rev:15 rq:591578 version:8.10.0

Changes:

--- /work/SRC/openSUSE:Factory/nodejs8/nodejs8.changes  2018-02-25 
11:35:37.661290011 +0100
+++ /work/SRC/openSUSE:Factory/.nodejs8.new/nodejs8.changes 2018-03-30 
11:58:47.764450324 +0200
@@ -1,0 +2,38 @@
+Thu Mar 22 10:38:46 UTC 2018 - adam.ma...@suse.de
+
+- New upstream LTS release 8.10.0:
+  * deps:
++ update V8 to 6.2.414.46
++ revert ABI breaking changes in V8 6.2
++ upgrade libuv to 1.19.1
++ re land npm 5.6.0
+  * crypto:
++ Support both OpenSSL 1.1.0 and 1.0.2. This allows us to drop
+  openssl11.patch
++ warn on invalid authentication tag length
+  * async_hooks:
++ update defaultTriggerAsyncIdScope for perf
++ use typed array stack as fast path
++ use scope for defaultTriggerAsyncId
++ separate missing from default context
++ deprecate undocumented API
+  * n-api: add helper for addons to get the event loop
+  * cli: add --stack-trace-limit to NODE_OPTIONS
+  * console: add support for console.debug
+  * module:
++ add builtinModules
++ replace default paths in require.resolve()
+  * src: add process.ppid
+  * http:
++ support generic Duplex streams
++ add rawPacket in err of clientError event
++ better support for IPv6 addresses
+  * tls: unconsume stream on destroy
+  * process: improve unhandled rejection message
+  * stream: remove usage of *State.highWaterMark
+  * trace_events: add executionAsyncId to init events
+- remove any old manpage files in %pre from before update-alternatives
+  were used to manage symlinks to these manpages.
+- versioned.patch: refreshed
+
+---

Old:

  node-v8.9.4.tar.xz
  openssl11.patch

New:

  node-v8.10.0.tar.xz



Other differences:
--
++ nodejs8.spec ++
--- /var/tmp/diff_new_pack.C7SBiz/_old  2018-03-30 11:58:52.660273276 +0200
+++ /var/tmp/diff_new_pack.C7SBiz/_new  2018-03-30 11:58:52.660273276 +0200
@@ -26,7 +26,7 @@
 ###
 
 Name:   nodejs8
-Version:8.9.4
+Version:8.10.0
 Release:0
 
 %define node_version_number 8
@@ -96,7 +96,6 @@
 Source3:nodejs.keyring
 
 ## UPSTREAM PATCHES HERE, if any
-Patch2: openssl11.patch
 Patch3: fix_ci_tests.patch
 
 ## Our patches
@@ -167,10 +166,13 @@
 BuildRequires:  fdupes
 BuildRequires:  pkg-config
 BuildRequires:  procps
-BuildRequires:  python
-BuildRequires:  python2
 BuildRequires:  xz
 BuildRequires:  zlib-devel
+%if 0%{?suse_version} >= 1500
+BuildRequires:  python2
+%else
+BuildRequires:  python
+%endif
 
 %if ! %{with intree_openssl}
 
@@ -248,7 +250,11 @@
 Obsoletes:  nodejs-npm < 4.0.0
 Provides:   npm = %{version}
 Provides:   npm(npm) = 5.6.0
+%if 0%{?suse_version} >= 1500
 Recommends: python2
+%else
+Recommends: python
+%endif
 
 %description -n npm8
 A package manager for Node.js that allows developers to install and
@@ -268,7 +274,6 @@
 %prep
 echo "`grep node-v%{version}.tar.xz %{S:1} | head -n1 | cut -c1-64`  %{S:0}" | 
sha256sum -c
 %setup -q -n node-v%{version}
-%patch2 -p1
 %patch3 -p1
 %if ! %{with intree_openssl}
 %endif
@@ -350,8 +355,11 @@
 # remove .bak files, if any
 find %{buildroot} -name \*.bak -print -delete
 
-# npm man page
+# npm/npx man page
 install -D -m 644 deps/npm/man/man1/npm.1 
%{buildroot}%{_mandir}/man1/npm%{node_version_number}.1
+%if %{node_version_number} >= 8
+install -D -m 644 deps/npm/man/man1/npx.1 
%{buildroot}%{_mandir}/man1/npx%{node_version_number}.1
+%endif
 
 #node-gyp needs common.gypi too
 install -D -m 644 common.gypi \
@@ -445,6 +453,7 @@
 
 %if %{node_version_number} >= 8
 %{_bindir}/npx%{node_version_number}
+%{_mandir}/man1/npx%{node_version_number}.1%{ext_man}
 %ghost %{_bindir}/npx-default
 %ghost %{_mandir}/man1/npx.1%{ext_man}
 %ghost %{_sysconfdir}/alternatives/npx-default
@@ -462,6 +471,12 @@
 %defattr(-,root,root)
 %doc doc/api
 
+%pre
+# remove files that are no longer owned but provided by update-alternatives
+if ! [ -L %{_mandir}/man1/node.1%{ext_man} ]; then
+rm -f %{_mandir}/man1/node.1%{ext_man}
+fi
+
 %post
 update-alternatives \
 --install %{_bindir}/node-default node-default 
%{_bindir}/node%{node_version_number} %{node_version_number} \
@@ -472,6 +487,12 @@
 update-alternatives --remove node-default 
%{_bindir}/node%{node_version_number}
 fi
 
+%pre -n npm%{node_version_number}
+# remove 

commit openucx for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package openucx for openSUSE:Factory checked 
in at 2018-03-30 11:58:56

Comparing /work/SRC/openSUSE:Factory/openucx (Old)
 and  /work/SRC/openSUSE:Factory/.openucx.new (New)


Package is "openucx"

Fri Mar 30 11:58:56 2018 rev:7 rq:591614 version:1.2.2

Changes:

--- /work/SRC/openSUSE:Factory/openucx/openucx.changes  2018-01-25 
12:34:54.630433697 +0100
+++ /work/SRC/openSUSE:Factory/.openucx.new/openucx.changes 2018-03-30 
11:58:59.384030122 +0200
@@ -1,0 +2,6 @@
+Tue Mar 27 07:12:37 UTC 2018 - nmoreychaisemar...@suse.com
+
+- Add UCT-UD-fixed-compilation-by-gcc8.patch to fix compilation
+  with GCC8 (bsc#1084635)
+
+---

New:

  UCT-UD-fixed-compilation-by-gcc8.patch



Other differences:
--
++ openucx.spec ++
--- /var/tmp/diff_new_pack.USmMkC/_old  2018-03-30 11:58:59.952009582 +0200
+++ /var/tmp/diff_new_pack.USmMkC/_new  2018-03-30 11:58:59.952009582 +0200
@@ -28,6 +28,7 @@
 #Git-Web:  https://github.com/openucx/ucx
 Source: 
https://github.com/openucx/ucx/releases/download/v%version/ucx-%version.tar.gz
 Patch1: openucx-s390x-support.patch
+Patch2: UCT-UD-fixed-compilation-by-gcc8.patch
 BuildRequires:  autoconf >= 2.63
 BuildRequires:  automake >= 1.10
 BuildRequires:  binutils-devel
@@ -127,6 +128,7 @@
 %prep
 %setup -qn ucx-%version
 %patch -P 1 -p1
+%patch2
 
 %build
 autoreconf -fi

++ UCT-UD-fixed-compilation-by-gcc8.patch ++
commit 851a26c3e553f88386658129ad2d4dca060e164c
Author: Sergey Oblomov 
Date:   Mon Mar 19 07:25:32 2018 +0200

UCT/UD: fixed compilation by gcc8

- removed 'packed' attribute from uct_ud_send_skb_inl_t structure

diff --git src/uct/ib/ud/base/ud_def.h src/uct/ib/ud/base/ud_def.h
index 0ccc0bb8495a..44d50ec643f8 100644
--- src/uct/ib/ud/base/ud_def.h
+++ src/uct/ib/ud/base/ud_def.h
@@ -172,8 +172,8 @@ typedef struct uct_ud_zcopy_desc {
 
 typedef struct uct_ud_send_skb_inl {
 uct_ud_send_skb_t  super;
-uct_ud_neth_t  neth;
-} UCS_S_PACKED uct_ud_send_skb_inl_t;
+uct_ud_neth_t  neth; /* placeholder for super.neth, should not be used 
directly */
+} uct_ud_send_skb_inl_t;
 
 
 typedef struct uct_ud_recv_skb {



commit perl-Bootloader for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package perl-Bootloader for openSUSE:Factory 
checked in at 2018-03-30 11:58:06

Comparing /work/SRC/openSUSE:Factory/perl-Bootloader (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Bootloader.new (New)


Package is "perl-Bootloader"

Fri Mar 30 11:58:06 2018 rev:182 rq:591553 version:0.919

Changes:

--- /work/SRC/openSUSE:Factory/perl-Bootloader/perl-Bootloader.changes  
2017-05-20 14:29:11.477706466 +0200
+++ /work/SRC/openSUSE:Factory/.perl-Bootloader.new/perl-Bootloader.changes 
2018-03-30 11:58:11.865748549 +0200
@@ -0,0 +1,5 @@
+---
+Mon Mar 26 15:49:57 CEST 2018 - ku...@suse.de
+
+- Use %license instead of %doc [bsc#1082318]
+



Other differences:
--
++ perl-Bootloader.spec ++
--- /var/tmp/diff_new_pack.FPkbe6/_old  2018-03-30 11:58:12.765716003 +0200
+++ /var/tmp/diff_new_pack.FPkbe6/_new  2018-03-30 11:58:12.769715859 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Bootloader
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,7 @@
 Requires:   perl-base = %{perl_version}
 Recommends: perl-gettext
 Summary:Library for Configuring Boot Loaders
-License:GPL-2.0+
+License:GPL-2.0-or-later
 Group:  System/Boot
 Source: %{name}-%{version}.tar.xz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -96,7 +96,7 @@
 
 %files
 %defattr(-, root, root)
-%doc COPYING
+%license COPYING
 %doc %{_mandir}/man?/*
 %{perl_vendorarch}/auto/Bootloader
 %{perl_vendorlib}/Bootloader




commit skelcd-openSUSE for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package skelcd-openSUSE for openSUSE:Factory 
checked in at 2018-03-30 11:58:34

Comparing /work/SRC/openSUSE:Factory/skelcd-openSUSE (Old)
 and  /work/SRC/openSUSE:Factory/.skelcd-openSUSE.new (New)


Package is "skelcd-openSUSE"

Fri Mar 30 11:58:34 2018 rev:100 rq:591573 version:84.87.20180322.65c3317

Changes:

--- /work/SRC/openSUSE:Factory/skelcd-openSUSE/skelcd-openSUSE.changes  
2017-11-24 10:52:25.464769515 +0100
+++ /work/SRC/openSUSE:Factory/.skelcd-openSUSE.new/skelcd-openSUSE.changes 
2018-03-30 11:58:41.532675686 +0200
@@ -1,0 +2,9 @@
+Tue Mar 27 11:25:27 UTC 2018 - opensuse-packag...@opensuse.org
+
+- Update to version 84.87.20180322.65c3317:
+  * Update year to 2018
+  * Translated using Weblate (Ukrainian)
+  * Translated using Weblate (Danish)
+  * Translated using Weblate (Portuguese (Brazil))
+
+---

Old:

  skelcd-openSUSE-84.87.20170814.54da904.tar.xz

New:

  skelcd-openSUSE-84.87.20180322.65c3317.tar.xz



Other differences:
--
++ skelcd-openSUSE.spec ++
--- /var/tmp/diff_new_pack.D5ZiUB/_old  2018-03-30 11:58:42.424643429 +0200
+++ /var/tmp/diff_new_pack.D5ZiUB/_new  2018-03-30 11:58:42.428643285 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package skelcd-openSUSE
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,7 +16,7 @@
 #
 
 
-%define version_unconverted 84.87.20170814.54da904
+%define version_unconverted 84.87.20180322.65c3317
 # changed by pre_checkin
 %define is_non_oss 0
 #
@@ -28,7 +28,7 @@
 %bcond_without  java
 #
 Name:   skelcd-openSUSE
-Version:84.87.20170814.54da904
+Version:84.87.20180322.65c3317
 Release:0
 Summary:Skeleton for openSUSE OSS Media Sets
 License:MIT

++ _servicedata ++
--- /var/tmp/diff_new_pack.D5ZiUB/_old  2018-03-30 11:58:42.476641549 +0200
+++ /var/tmp/diff_new_pack.D5ZiUB/_new  2018-03-30 11:58:42.480641404 +0200
@@ -1,4 +1,4 @@
 
 
 git://github.com/openSUSE/skelcd-openSUSE.git
-  54da904b42a07b268ccd2db81a6c8591a35917db
\ No newline at end of file
+  65c3317d07d27e0c73b73104ad52ffa68da80251
\ No newline at end of file

++ skelcd-openSUSE-84.87.20170814.54da904.tar.xz -> 
skelcd-openSUSE-84.87.20180322.65c3317.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/skelcd-openSUSE-84.87.20170814.54da904/license/TEMPLATE 
new/skelcd-openSUSE-84.87.20180322.65c3317/license/TEMPLATE
--- old/skelcd-openSUSE-84.87.20170814.54da904/license/TEMPLATE 2017-08-14 
10:45:57.0 +0200
+++ new/skelcd-openSUSE-84.87.20180322.65c3317/license/TEMPLATE 2018-03-22 
17:52:01.0 +0100
@@ -103,7 +103,7 @@
 Alternate III (Dec 2007), FAR  52.227-19 (Dec 2007), or DFARS
 252.227-7013(b)(3) (Nov 1995), or applicable successor clauses.
 
-Copyright © 2008-2017 The openSUSE Project. All rights
+Copyright © 2008-2018 The openSUSE Project. All rights
 reserved. "SUSE" and "openSUSE" are registered trademarks of SUSE LLC,
 or its affiliates, which founded, sponsors, and is designated by, The openSUSE
 Project. "Linux" is a registered trademark of Linus Torvalds. All
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/skelcd-openSUSE-84.87.20170814.54da904/license/license.ar.po 
new/skelcd-openSUSE-84.87.20180322.65c3317/license/license.ar.po
--- old/skelcd-openSUSE-84.87.20170814.54da904/license/license.ar.po
2017-08-14 10:45:57.0 +0200
+++ new/skelcd-openSUSE-84.87.20180322.65c3317/license/license.ar.po
2018-03-22 17:52:01.0 +0100
@@ -264,14 +264,14 @@
 
 #: license/TEMPLATE:106
 msgid ""
-"Copyright © 2008-2017 The openSUSE Project. All rights\n"
+"Copyright © 2008-2018 The openSUSE Project. All rights\n"
 "reserved. \"SUSE\" and \"openSUSE\" are registered trademarks of SUSE LLC,\n"
 "or its affiliates, which founded, sponsors, and is designated by, The "
 "openSUSE\n"
 "Project. \"Linux\" is a registered trademark of Linus Torvalds. All\n"
 "other trademarks are the property of their respective owners."
 msgstr ""
-"حقوق التأليف والنشر © 2008-2017 مشروع أوبن سوزي جميع الحقوق\n"
+"حقوق التأليف والنشر © 2008-2018 مشروع أوبن سوزي جميع الحقوق\n"
 "محفوظة. العلامات التجارية \"سوسي\" و\"أوبن سوزي\" تم تسجيلها من SUSE ذ م م،\n"
 "أو الشركات التابعة لها،  والجهات الراعية، أوبن سوزي\n"
 "مشروع. \"لينكس\" هي علامة تجارية مسجلة لينوس تورفالدس. جميع\n"
diff -urN 

commit libyajl for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package libyajl for openSUSE:Factory checked 
in at 2018-03-30 11:57:57

Comparing /work/SRC/openSUSE:Factory/libyajl (Old)
 and  /work/SRC/openSUSE:Factory/.libyajl.new (New)


Package is "libyajl"

Fri Mar 30 11:57:57 2018 rev:21 rq:591552 version:2.1.0

Changes:

--- /work/SRC/openSUSE:Factory/libyajl/libyajl.changes  2015-04-28 
20:42:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.libyajl.new/libyajl.changes 2018-03-30 
11:58:02.230097012 +0200
@@ -1,0 +2,6 @@
+Tue Mar 27 11:44:33 CEST 2018 - ku...@suse.de
+
+- Use %license instead of %doc [bsc#1082318]
+- Move other docu to -devel package where it better fits
+
+---



Other differences:
--
++ libyajl.spec ++
--- /var/tmp/diff_new_pack.G0cYyt/_old  2018-03-30 11:58:03.094065767 +0200
+++ /var/tmp/diff_new_pack.G0cYyt/_new  2018-03-30 11:58:03.094065767 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libyajl
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -109,12 +109,13 @@
 
 %files -n %{name}%{soname}
 %defattr(-,root,root)
-%doc COPYING README TODO
+%license COPYING
 %{_libdir}/libyajl.so.%{soname}
 %{_libdir}/libyajl.so.%{soname}.*
 
 %files -n %{name}-devel
 %defattr(-,root,root)
+%doc README TODO
 %{_includedir}/yajl
 %{_libdir}/libyajl.so
 %{_datadir}/pkgconfig/yajl.pc




commit lsof for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package lsof for openSUSE:Factory checked in 
at 2018-03-30 11:58:22

Comparing /work/SRC/openSUSE:Factory/lsof (Old)
 and  /work/SRC/openSUSE:Factory/.lsof.new (New)


Package is "lsof"

Fri Mar 30 11:58:22 2018 rev:35 rq:591567 version:4.91

Changes:

--- /work/SRC/openSUSE:Factory/lsof/lsof.changes2018-02-21 
14:08:41.228205502 +0100
+++ /work/SRC/openSUSE:Factory/.lsof.new/lsof.changes   2018-03-30 
11:58:31.425041213 +0200
@@ -1,0 +2,7 @@
+Tue Mar 27 09:46:50 UTC 2018 - kstreit...@suse.com
+
+- Update to version 4.91
+  * This revision applies two fixes that correct the Linux PTY
+ endpoint processing bug [bsc#1082900]
+
+---

Old:

  lsof_4.90_src_repacked.tar.xz

New:

  lsof_4.91_src_repacked.tar.xz



Other differences:
--
++ lsof.spec ++
--- /var/tmp/diff_new_pack.f0vqRX/_old  2018-03-30 11:58:33.924950808 +0200
+++ /var/tmp/diff_new_pack.f0vqRX/_new  2018-03-30 11:58:33.928950663 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   lsof
-Version:4.90
+Version:4.91
 Release:0
 Summary:A Program That Lists Information about Files Opened by 
Processes
 License:Zlib

++ lsof_4.90_src_repacked.tar.xz -> lsof_4.91_src_repacked.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lsof_4.90_src/00DIST new/lsof_4.91_src/00DIST
--- old/lsof_4.90_src/00DIST2018-02-14 15:42:00.0 +0100
+++ new/lsof_4.91_src/00DIST2018-03-26 23:49:26.0 +0200
@@ -119,6 +119,7 @@
4.88, October 13, 2014
4.89, July 7, 2015
4.90, February 14, 2018
+   4.91, March 26, 2018
 
 
 Dialects Supported
@@ -4872,5 +4873,15 @@
Corrected Linux command extraction for commands that include
parentheses -- e.g., "(sd-pam)".

+4.91   March 26, 2018
+
+   A bug has been reported in the PTY endpoint processing of
+   Linux lsof 4.90 by Peter Wu , making it
+   necessary for me to release another revision of lsof.
+
+   This revision applies two fixes that correct the Linux PTY
+   endpoint processing bug. Masatake YAMATO 
+   supplied the fixes.
+
 Vic Abell 
-February 14, 2018
+March 26, 2018
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lsof_4.90_src/00LSOF-L new/lsof_4.91_src/00LSOF-L
--- old/lsof_4.90_src/00LSOF-L  2015-09-16 21:22:23.0 +0200
+++ new/lsof_4.91_src/00LSOF-L  2018-03-19 20:58:28.0 +0100
@@ -63,13 +63,12 @@
 security issues.  Postings don't appear until I've approved them.
 
 
-Send Bug Reports to Me Via E-Mail
-=
+Send Bug Reports to lsof-l, too
+===
 
-DON'T SEND BUG REPORTS TO lsof-l.  Send them directly to me via e-mail
-at .  Make sure lsof appears in the "Subject:" line and
-make sure you first read the "Bug Reports" section of the 00README file
-of the lsof distribution.
+Since I am no longer actively supporting lsof -- 4.91 is probably the
+last revision I will distribute --  bug reports should be sent to
+lsof-l.  There are readers of lsof-l who may be able to help you.
 
 
 Unsubscribing
@@ -97,4 +96,4 @@
 
 
 Vic Abell 
-September 16, 2015
+March ??? 2018
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lsof_4.90_src/dialects/linux/dnode.c 
new/lsof_4.91_src/dialects/linux/dnode.c
--- old/lsof_4.90_src/dialects/linux/dnode.c2018-02-14 15:26:45.0 
+0100
+++ new/lsof_4.91_src/dialects/linux/dnode.c2018-03-26 23:52:34.0 
+0200
@@ -32,7 +32,7 @@
 #ifndef lint
 static char copyright[] =
 "@(#) Copyright 1997 Purdue Research Foundation.\nAll rights reserved.\n";
-static char *rcsid = "$Id: dnode.c,v 1.26 2018/02/14 14:26:38 abe Exp $";
+static char *rcsid = "$Id: dnode.c,v 1.27 2018/03/26 21:52:29 abe Exp $";
 #endif
 
 
@@ -737,7 +737,8 @@
Lf->rdev_def = 1;
 
 #ifdefined(HASEPTOPTS) && defined(HASPTYEPT)
-   if ((Ntype == N_CHR)
+   if (FeptE
+   &&  (Ntype == N_CHR)
&&  is_pty_slave(GET_MAJ_DEV(Lf->rdev))
) {
enter_ptmxi(GET_MIN_DEV(Lf->rdev));
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lsof_4.90_src/dialects/linux/dproc.c 
new/lsof_4.91_src/dialects/linux/dproc.c
--- old/lsof_4.90_src/dialects/linux/dproc.c

commit biosdevname for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package biosdevname for openSUSE:Factory 
checked in at 2018-03-30 11:57:49

Comparing /work/SRC/openSUSE:Factory/biosdevname (Old)
 and  /work/SRC/openSUSE:Factory/.biosdevname.new (New)


Package is "biosdevname"

Fri Mar 30 11:57:49 2018 rev:44 rq:591550 version:0.7.3

Changes:

--- /work/SRC/openSUSE:Factory/biosdevname/biosdevname.changes  2017-10-02 
16:51:00.849252112 +0200
+++ /work/SRC/openSUSE:Factory/.biosdevname.new/biosdevname.changes 
2018-03-30 11:57:55.742331635 +0200
@@ -1,0 +2,5 @@
+Tue Mar 27 11:52:38 CEST 2018 - ku...@suse.de
+
+- Use %license instead of %doc [bsc#1082318]
+
+---



Other differences:
--
++ biosdevname.spec ++
--- /var/tmp/diff_new_pack.99PwNC/_old  2018-03-30 11:57:57.210278549 +0200
+++ /var/tmp/diff_new_pack.99PwNC/_new  2018-03-30 11:57:57.214278404 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package biosdevname
 #
-# Copyright (c) 2017 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -21,7 +21,7 @@
 Version:0.7.3
 Release:0
 Summary:Udev helper for naming devices per BIOS names
-License:GPL-2.0
+License:GPL-2.0-only
 Group:  System/Base
 Url:https://github.com/dell/%{name}
 Source0:%{name}-%{version}.tar.xz
@@ -86,7 +86,8 @@
 
 %files
 %defattr(-,root,root,-)
-%doc COPYING README
+%license COPYING
+%doc README
 /sbin/%{name}
 %{_udevrulesdir}/71-biosdevname.rules
 




commit libzypp-plugin-appdata for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package libzypp-plugin-appdata for 
openSUSE:Factory checked in at 2018-03-30 11:57:33

Comparing /work/SRC/openSUSE:Factory/libzypp-plugin-appdata (Old)
 and  /work/SRC/openSUSE:Factory/.libzypp-plugin-appdata.new (New)


Package is "libzypp-plugin-appdata"

Fri Mar 30 11:57:33 2018 rev:17 rq:592387 version:1.0.1+git.20180327

Changes:

--- 
/work/SRC/openSUSE:Factory/libzypp-plugin-appdata/libzypp-plugin-appdata.changes
2018-03-24 16:08:20.906706308 +0100
+++ 
/work/SRC/openSUSE:Factory/.libzypp-plugin-appdata.new/libzypp-plugin-appdata.changes
   2018-03-30 11:57:37.446993272 +0200
@@ -1,0 +2,19 @@
+Tue Mar 27 11:26:55 UTC 2018 - dims...@opensuse.org
+
+- Update to version 1.0.1+git.20180327:
+  * AsHelper: normalize the repo alias names
+
+---
+Tue Mar 27 08:27:00 UTC 2018 - dims...@opensuse.org
+
+- Start zypper lr with ZYPP_PLUGIN_APPDATA_FORCE_COLLECT=1 post
+  installation (boo#1009745).
+- Add relevant Requires(post) to ensure packages are installed in
+  the right order:
+  + appstream-glib >= 0.3.6
+  + python3-cmdln
+  + python3-createrepo_c
+  + libzypp >= 16.13.1
+  + zypper
+
+---

Old:

  openSUSE-appstream-1.0.1+git.20180321.tar.xz

New:

  openSUSE-appstream-1.0.1+git.20180327.tar.xz



Other differences:
--
++ libzypp-plugin-appdata.spec ++
--- /var/tmp/diff_new_pack.IzaYyh/_old  2018-03-30 11:57:38.778945102 +0200
+++ /var/tmp/diff_new_pack.IzaYyh/_new  2018-03-30 11:57:38.782944958 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   libzypp-plugin-appdata
-Version:1.0.1+git.20180321
+Version:1.0.1+git.20180327
 Release:0
 Summary:Extend libzypp to handle AppStream metadata
 License:MIT AND CC0-1.0
@@ -30,9 +30,15 @@
 Requires:   appstream-glib >= 0.3.6
 # appdata hook was introduced in libzypp 14.29.4
 Requires:   libzypp >= 14.29.4
-Requires:   python3-cmdln
 # AsHelper is a python program with few dependencies
+Requires:   python3-cmdln
 Requires:   python3-createrepo_c
+Requires(post): appstream-glib >= 0.3.6
+# libzypp 16.13.1 was the version gaingin support for 
ZYPP_PLUGIN_APPDATA_FORCE_COLLECT
+Requires(post): libzypp >= 16.13.1
+Requires(post): python3-cmdln
+Requires(post): python3-createrepo_c
+Requires(post): zypper
 # This is one way of providing valid appstream metadata to applications 
(currently the only implemented one)
 Provides:   appstream-provider
 BuildArch:  noarch
@@ -64,6 +70,17 @@
 install -Dm 0755 InstallAppdata.sh 
%{buildroot}%{_prefix}/lib/zypp/plugins/appdata/InstallAppdata.sh
 install -Dm 0755 AsHelper.py %{buildroot}%{_libexecdir}/AsHelper
 
+%post
+# On initial installation, we enforce an AppStream refresh
+# ZYPP_PLUGIN_APPDATA_FORCE_COLLECT=1 instructs zypper to fire off the appdata 
plugin
+# which normally would only happen on repo refresh; but for 'non-rolling' 
products,
+# the default repos are all static and don't refresh. This would leave 
software centers
+# in a unusable state
+# Addresses https://bugzilla.opensuse.org/show_bug.cgi?id=1009745
+if [ $1 = 1 ]; then
+  ZYPP_PLUGIN_APPDATA_FORCE_COLLECT=1 zypper -n lr >/dev/null 2>&1
+fi
+
 %files
 # zypp plugin triggering AppData update on repo refresh
 %dir %{_prefix}/lib/zypp

++ _servicedata ++
--- /var/tmp/diff_new_pack.IzaYyh/_old  2018-03-30 11:57:38.830943222 +0200
+++ /var/tmp/diff_new_pack.IzaYyh/_new  2018-03-30 11:57:38.830943222 +0200
@@ -1,4 +1,4 @@
 
 
 https://github.com/DimStar77/openSUSE-appstream.git
-  58e1e4e128dfe67484342418afcc61efe6e592bf
\ No newline at end of file
+  4852b6d6bcdc33e1d8c315657e3ffb8dfbf81410
\ No newline at end of file

++ openSUSE-appstream-1.0.1+git.20180321.tar.xz -> 
openSUSE-appstream-1.0.1+git.20180327.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/openSUSE-appstream-1.0.1+git.20180321/AsHelper.py 
new/openSUSE-appstream-1.0.1+git.20180327/AsHelper.py
--- old/openSUSE-appstream-1.0.1+git.20180321/AsHelper.py   2018-03-21 
20:05:22.0 +0100
+++ new/openSUSE-appstream-1.0.1+git.20180327/AsHelper.py   2018-03-27 
13:24:05.0 +0200
@@ -64,7 +64,7 @@
   print("Repotype %s unknown" % opts.type)
 
   if RET:
-  os.system(CMD.format(NAME=opts.alias, APPDATA=RET['appdata'], 
ICONS=RET['appdata-icons']))
+  os.system(CMD.format(NAME=opts.alias.replace(':','_'), 
APPDATA=RET['appdata'], ICONS=RET['appdata-icons']))
   else:
   print("could not find appdata tarball and/or icons")
 
@@ 

commit libgweather for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package libgweather for openSUSE:Factory 
checked in at 2018-03-30 11:57:01

Comparing /work/SRC/openSUSE:Factory/libgweather (Old)
 and  /work/SRC/openSUSE:Factory/.libgweather.new (New)


Package is "libgweather"

Fri Mar 30 11:57:01 2018 rev:96 rq:592267 version:3.28.1

Changes:

--- /work/SRC/openSUSE:Factory/libgweather/libgweather.changes  2018-03-14 
19:25:46.025480012 +0100
+++ /work/SRC/openSUSE:Factory/.libgweather.new/libgweather.changes 
2018-03-30 11:57:04.016202282 +0200
@@ -1,0 +2,7 @@
+Sun Mar 25 01:13:07 UTC 2018 - luc1...@linuxmail.org
+
+- Update to version 3.28.1:
+  + Fix memory and D-Bus match rule leaks.
+  + Updated translations.
+
+---

Old:

  libgweather-3.28.0.tar.xz

New:

  libgweather-3.28.1.tar.xz



Other differences:
--
++ libgweather.spec ++
--- /var/tmp/diff_new_pack.BqoqxL/_old  2018-03-30 11:57:04.820173206 +0200
+++ /var/tmp/diff_new_pack.BqoqxL/_new  2018-03-30 11:57:04.824173062 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   libgweather
-Version:3.28.0
+Version:3.28.1
 Release:0
 Summary:Library to get online weather information
 License:GPL-2.0-or-later

++ libgweather-3.28.0.tar.xz -> libgweather-3.28.1.tar.xz ++
 8315 lines of diff (skipped)




commit gnome-keyring for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package gnome-keyring for openSUSE:Factory 
checked in at 2018-03-30 11:57:06

Comparing /work/SRC/openSUSE:Factory/gnome-keyring (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-keyring.new (New)


Package is "gnome-keyring"

Fri Mar 30 11:57:06 2018 rev:131 rq:592268 version:3.28.0.2

Changes:

--- /work/SRC/openSUSE:Factory/gnome-keyring/gnome-keyring.changes  
2018-03-26 12:47:09.371778550 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-keyring.new/gnome-keyring.changes 
2018-03-30 11:57:09.164016113 +0200
@@ -1,0 +2,7 @@
+Mon Mar 26 02:58:56 UTC 2018 - luc1...@linuxmail.org
+
+- Update to version 3.28.0.2:
+  + Fix glitches in ssh-agent (bgo#794361, bgo#794368, bgo#794369,
+bgo#794500, bgo#794631).
+
+---

Old:

  gnome-keyring-3.28.0.1.tar.xz

New:

  gnome-keyring-3.28.0.2.tar.xz



Other differences:
--
++ gnome-keyring.spec ++
--- /var/tmp/diff_new_pack.JejEcF/_old  2018-03-30 11:57:09.751994849 +0200
+++ /var/tmp/diff_new_pack.JejEcF/_new  2018-03-30 11:57:09.755994703 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-keyring
-Version:3.28.0.1
+Version:3.28.0.2
 Release:0
 Summary:GNOME Keyring
 License:GPL-2.0-or-later AND LGPL-2.1-or-later

++ gnome-keyring-3.28.0.1.tar.xz -> gnome-keyring-3.28.0.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gnome-keyring-3.28.0.1/ChangeLog 
new/gnome-keyring-3.28.0.2/ChangeLog
--- old/gnome-keyring-3.28.0.1/ChangeLog2018-03-13 07:02:19.0 
+0100
+++ new/gnome-keyring-3.28.0.2/ChangeLog2018-03-25 10:13:49.0 
+0200
@@ -1,5 +1,156 @@
 # Generate automatically. Do not edit.
 
+commit 4dd8fb181d70abef2b0d8cbb5fb11e8203b14c46
+Author: Daiki Ueno 
+Date:   2018-03-25
+
+Release 3.28.0.2
+
+ NEWS | 3 +++
+ configure.ac | 2 +-
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+commit a0526d18152028e967b7baa5bc039c38a487672a
+Author: Daiki Ueno 
+Date:   2018-03-24
+
+login: Use password from login keyring once for the same interaction
+
+https://bugzilla.gnome.org/show_bug.cgi?id=794631
+
+ daemon/login/gkd-login-interaction.c | 20 +---
+ 1 file changed, 13 insertions(+), 7 deletions(-)
+
+commit a6a5c89dfe81abb1541bfd824087c910451767f8
+Author: Daiki Ueno 
+Date:   2018-03-23
+
+egg: Port cosmetic fixes to egg-secure-memory.c from libsecret
+
+ egg/egg-secure-memory.c | 8 
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+commit b70a10e0953a7e0a13ca3705677aa974451e2fa1
+Author: Daiki Ueno 
+Date:   2018-03-20
+
+login: Use the same label as before when storing password
+
+https://bugzilla.gnome.org/show_bug.cgi?id=794500
+
+ daemon/login/gkd-login-interaction.c | 6 +-
+ po/POTFILES.in   | 1 +
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+commit afbdb0a04b3c737003a3dc0cec0095ba0c2256c2
+Author: Daiki Ueno 
+Date:   2018-03-20
+
+ssh-agent: Don't be too verbose on password prompt
+
+This partially reverts the change in 869b5c6d, so as not to display
+duplicate words on the password prompt.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=794500
+
+ daemon/ssh-agent/gkd-ssh-agent-service.c | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+commit e360238029de47cafa974f4e0c2bd4ec793cd84b
+Author: Daiki Ueno 
+Date:   2018-03-20
+
+build: Suppress compiler warnings with -Wdiscarded-qualifiers
+
+ daemon/login/gkd-login-interaction.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+commit 0db5a03011040fb68021ed4d034627e1ac06b86f
+Author: Daiki Ueno 
+Date:   2018-03-16
+
+ssh-agent: Make EOF handling robuster
+
+https://bugzilla.gnome.org/show_bug.cgi?id=794369
+
+ daemon/ssh-agent/gkd-ssh-agent-service.c  | 3 ++-
+ daemon/ssh-agent/gkd-ssh-agent-util.c | 6 ++
+ daemon/ssh-agent/test-gkd-ssh-agent-service.c | 8 
+ 3 files changed, 12 insertions(+), 5 deletions(-)
+
+commit a19966ba0ef403e8eed733cc9be8b1d45a3787e4
+Author: Daiki Ueno 
+Date:   2018-03-16
+
+ssh-agent: Allow opening multiple connections to inferior ssh-agent
+
+Previously, it keeps only one connection to the inferior ssh-agent
+process.  That prevented simultaneous access to gnome-keyring's
+ssh-agent service.  With this patch, it always opens a new connection
+to the inferior ssh-agent process when a new client connects.
+
+   

commit devhelp for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package devhelp for openSUSE:Factory checked 
in at 2018-03-30 11:57:21

Comparing /work/SRC/openSUSE:Factory/devhelp (Old)
 and  /work/SRC/openSUSE:Factory/.devhelp.new (New)


Package is "devhelp"

Fri Mar 30 11:57:21 2018 rev:76 rq:592273 version:3.28.0

Changes:

--- /work/SRC/openSUSE:Factory/devhelp/devhelp.changes  2018-03-26 
12:55:16.110214481 +0200
+++ /work/SRC/openSUSE:Factory/.devhelp.new/devhelp.changes 2018-03-30 
11:57:25.367430122 +0200
@@ -1,0 +2,7 @@
+Wed Mar 28 13:52:37 UTC 2018 - badshah...@gmail.com
+
+- Add Requires: devhelp for vim, emac and gedit plugins as these
+  plugins, which are supposed to pop up the devhelp window to
+  search for the selected word/phrase, don't work otherwise.
+
+---



Other differences:
--
++ devhelp.spec ++
--- /var/tmp/diff_new_pack.Y4hPSE/_old  2018-03-30 11:57:25.927409871 +0200
+++ /var/tmp/diff_new_pack.Y4hPSE/_new  2018-03-30 11:57:25.931409726 +0200
@@ -24,7 +24,7 @@
 Summary:Developer's Help Program for GNOME
 License:GPL-2.0-or-later
 Group:  Development/Tools/Other
-URL:https://wiki.gnome.org/Apps/Devhelp
+Url:https://wiki.gnome.org/Apps/Devhelp
 Source0:
http://download.gnome.org/sources/devhelp/3.28/%{name}-%{version}.tar.xz
 BuildRequires:  fdupes
 BuildRequires:  gobject-introspection-devel >= 1.30.0
@@ -67,6 +67,7 @@
 %package -n emacs-plugin-devhelp
 Summary:Devhelp plugin for Emacs
 Group:  Development/Tools/Other
+Requires:   %{name} = %{version}
 Requires:   emacs
 
 %description -n emacs-plugin-devhelp
@@ -77,6 +78,7 @@
 %package -n gedit-plugin-devhelp
 Summary:Devhelp plugin for Gedit
 Group:  Development/Tools/Other
+Requires:   %{name} = %{version}
 Requires:   gedit
 
 %description -n gedit-plugin-devhelp
@@ -87,6 +89,7 @@
 %package -n vim-plugin-devhelp
 Summary:Devhelp plugin for Vim
 Group:  Development/Tools/Other
+Requires:   %{name} = %{version}
 Requires:   vim
 
 %description -n vim-plugin-devhelp




commit python-gobject for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package python-gobject for openSUSE:Factory 
checked in at 2018-03-30 11:57:16

Comparing /work/SRC/openSUSE:Factory/python-gobject (Old)
 and  /work/SRC/openSUSE:Factory/.python-gobject.new (New)


Package is "python-gobject"

Fri Mar 30 11:57:16 2018 rev:72 rq:592272 version:3.28.2

Changes:

--- /work/SRC/openSUSE:Factory/python-gobject/python-gobject.changes
2018-03-24 16:09:56.955243884 +0100
+++ /work/SRC/openSUSE:Factory/.python-gobject.new/python-gobject.changes   
2018-03-30 11:57:16.383755013 +0200
@@ -1,0 +2,11 @@
+Tue Mar 27 23:29:51 UTC 2018 - luc1...@linuxmail.org
+
+- Update to version 3.28.2:
+  + Fix:
+- __str__ return type of Gtk.TreePath with depth == 0
+  (glgo#GNOME/pygobject#143);
+- A crash when setting a str property with a value containing
+  surrogates (glgo#GNOME/pygobject#169).
+  + Tests: Fix a potential crash during tests.
+
+---

Old:

  pygobject-3.28.1.tar.xz

New:

  pygobject-3.28.2.tar.xz



Other differences:
--
++ python-gobject.spec ++
--- /var/tmp/diff_new_pack.ZirK4L/_old  2018-03-30 11:57:16.907736063 +0200
+++ /var/tmp/diff_new_pack.ZirK4L/_new  2018-03-30 11:57:16.907736063 +0200
@@ -22,7 +22,7 @@
 %global __requires_exclude_from 
^%{python2_sitearch}/gi/__init__.py|%{python3_sitearch}/gi/__init__.py$
 %define _name   pygobject
 Name:   python-gobject
-Version:3.28.1
+Version:3.28.2
 Release:0
 Summary:Python bindings for GObject
 License:LGPL-2.1-or-later

++ pygobject-3.28.1.tar.xz -> pygobject-3.28.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pygobject-3.28.1/ChangeLog 
new/pygobject-3.28.2/ChangeLog
--- old/pygobject-3.28.1/ChangeLog  2018-03-17 19:07:10.0 +0100
+++ new/pygobject-3.28.2/ChangeLog  2018-03-27 22:51:16.0 +0200
@@ -1,3 +1,111 @@
+commit 3ba1f36ebd63ce4477fab1c0d1c9d7fc817f19a8
+Author: Christoph Reiter 
+Date:   Tue Mar 27 22:48:17 2018 +0200
+
+release
+
+ NEWS | 11 +++
+ 1 file changed, 11 insertions(+)
+
+commit 8eb973ec4cafa6bbedb47e8d12bd02e6ed318273
+Author: Christoph Reiter 
+Date:   Sun Mar 25 19:12:54 2018 +0200
+
+resulttuple: fix a wrong decref
+
+We don't get ownership here so don't unref.
+Thist function is only used in the test suite.
+
+ gi/pygi-resulttuple.c | 2 --
+ tests/test_resulttuple.py | 6 --
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+commit 1c962cb74cd99e0169abed45cf813550574a2a80
+Author: Christoph Reiter 
+Date:   Fri Mar 23 07:23:21 2018 +0100
+
+autotools: define PY_SSIZE_T_CLEAN for the test extension
+
+ tests/Makefile.am | 8 ++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+commit 1b072bb45b07bbb461bf9c8318a81a26e0d65a18
+Author: Christoph Reiter 
+Date:   Fri Mar 23 07:07:26 2018 +0100
+
+setup.py: always define PY_SSIZE_T_CLEAN. Fixes #185
+
+ gi/pyglib-python-compat.h | 6 ++
+ setup.py  | 5 +++--
+ 2 files changed, 9 insertions(+), 2 deletions(-)
+
+commit 997f6d95f3a1d8ce8376eb10e3f2d76d3b5e29d3
+Author: Christoph Reiter 
+Date:   Mon Mar 19 13:52:21 2018 +0100
+
+properties: fix a crash when setting a str value containing
+surrogates. Fixes #169
+
+In Python 3 decoding unicode fails if it contains surrogates. Handle
+that case.
+This ususally happens with filenames where undecodable bytes get
+converted to surrogates.
+
+ gi/pygi-value.c  |  4 
+ gi/pygobject-object.c|  4 ++--
+ tests/test_properties.py | 12 +++-
+ 3 files changed, 17 insertions(+), 3 deletions(-)
+
+commit c9cfde92d7a1eb558c66dc9e8e1959816fcbf0cc
+Author: Christoph Reiter 
+Date:   Sun Mar 18 07:33:19 2018 +0100
+
+gtk overrides: Fix return type Gtk.TreePath with depth == 0. Fixes
+#143
+
+compare() also errors out with depth == 0, but str() shouldn't fail
+as it's important for debugging.
+
+ gi/overrides/Gtk.py | 2 +-
+ tests/test_overrides_gtk.py | 4 
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+commit c6d57734cf97b7eb7b11b21a9096d70dd1465865
+Author: Christoph Reiter 
+Date:   Sun Mar 18 21:57:07 2018 +0100
+
+setup.py: build the test extension in a separate build dir. Fixes #181
+
+The install command just copies the whole build tree as is when
+installing
+which installs the test extension when tests are build before install.
+
+

commit baobab for openSUSE:Factory

2018-03-30 Thread root
Hello community,

here is the log from the commit of package baobab for openSUSE:Factory checked 
in at 2018-03-30 11:57:27

Comparing /work/SRC/openSUSE:Factory/baobab (Old)
 and  /work/SRC/openSUSE:Factory/.baobab.new (New)


Package is "baobab"

Fri Mar 30 11:57:27 2018 rev:40 rq:592381 version:3.28.0

Changes:

--- /work/SRC/openSUSE:Factory/baobab/baobab.changes2018-03-14 
19:27:41.813368589 +0100
+++ /work/SRC/openSUSE:Factory/.baobab.new/baobab.changes   2018-03-30 
11:57:30.647239180 +0200
@@ -1,0 +2,11 @@
+Thu Mar 22 13:41:31 UTC 2018 - bjorn@gmail.com
+
+- Drop gnome-utils Conflicts, not needed for a long time.
+- Drop update-desktop-files BuildRequires and no longer pass
+  suse_update_desktop_file macro.
+- Add baobab-fix-linguas-build-issues.patch: build: Fix setting
+  GNOMELOCALEDIR (bgo#794381), and build: Use LINGUAS file for help
+  (bgo#794449).
+- Update URL to new home in GNOME wiki.
+
+---

New:

  baobab-fix-linguas-build-issues.patch



Other differences:
--
++ baobab.spec ++
--- /var/tmp/diff_new_pack.bfYbjj/_old  2018-03-30 11:57:31.251217338 +0200
+++ /var/tmp/diff_new_pack.bfYbjj/_new  2018-03-30 11:57:31.255217193 +0200
@@ -18,18 +18,20 @@
 
 
 %define glib2_version 2.44
+
 Name:   baobab
 Version:3.28.0
 Release:0
 Summary:Disk Usage Analyzer
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
-URL:http://www.gnome.org
-Source: 
http://download.gnome.org/sources/baobab/3.28/%{name}-%{version}.tar.xz
+URL:https://wiki.gnome.org/Apps/DiskUsageAnalyzer
+Source0:
https://download.gnome.org/sources/baobab/3.28/%{name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM baobab-fix-linguas-build-issues.patch bgo#794381 
bgo#794449 bjorn@gmail.com -- Fix various linguas issues.
+Patch0: baobab-fix-linguas-build-issues.patch
 BuildRequires:  fdupes
 BuildRequires:  meson
 BuildRequires:  pkgconfig
-BuildRequires:  update-desktop-files
 BuildRequires:  vala >= 0.38.0.11
 BuildRequires:  yelp-tools
 BuildRequires:  pkgconfig(gio-2.0) >= %{glib2_version}
@@ -38,7 +40,6 @@
 BuildRequires:  pkgconfig(gobject-2.0) >= %{glib2_version}
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.20
 Recommends: %{name}-lang
-Conflicts:  gnome-utils < 3.3.1
 
 %description
 Disk Usage Analyzer is a graphical, menu-driven application to analyse
@@ -54,6 +55,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %meson
@@ -62,7 +64,6 @@
 %install
 %meson_install
 
-%suse_update_desktop_file org.gnome.%{name}
 %find_lang %{name} %{?no_lang_C}
 %fdupes %{buildroot}%{_datadir}
 
@@ -75,7 +76,6 @@
 %{_datadir}/icons/hicolor/*/apps/%{name}*.*
 %{_datadir}/glib-2.0/schemas/org.gnome.baobab.gschema.xml
 %{_datadir}/applications/org.gnome.%{name}.desktop
-%dir %{_datadir}/metainfo/
 %{_datadir}/metainfo/org.gnome.baobab.appdata.xml
 %{_datadir}/dbus-1/services/org.gnome.baobab.service
 

++ baobab-fix-linguas-build-issues.patch ++
>From 884fb555173c46fcb4a80a5cc9cbd32bad8186ba Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Piotr=20Dr=C4=85g?= 
Date: Fri, 16 Mar 2018 19:57:53 +0100
Subject: build: Fix setting GNOMELOCALEDIR

https://bugzilla.gnome.org/show_bug.cgi?id=794381
---
 meson.build | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meson.build b/meson.build
index 30d996d..ad1b1d3 100644
--- a/meson.build
+++ b/meson.build
@@ -23,7 +23,7 @@ conf.set_quoted('PACKAGE_NAME', meson.project_name())
 conf.set_quoted('PACKAGE_VERSION', meson.project_version())
 conf.set_quoted('VERSION', meson.project_version())
 conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
-conf.set_quoted('GNOMELOCALEDIR', join_paths(get_option('prefix'), 
get_option('datadir'), '/locale'))
+conf.set_quoted('GNOMELOCALEDIR', join_paths(get_option('prefix'), 
get_option('localedir')))
 configure_file(output: 'config.h', configuration: conf)
 config_h_dir = include_directories('.')
 
-- 
cgit v0.12


>From aee08d643c880f649923c18a1a4bac1045820fd4 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Piotr=20Dr=C4=85g?= 
Date: Sun, 18 Mar 2018 18:01:45 +0100
Subject: build: Use LINGUAS file for help

The old method is deprecated.

https://bugzilla.gnome.org/show_bug.cgi?id=794449
---
 help/LINGUAS | 21 +
 help/meson.build | 27 +--
 2 files changed, 22 insertions(+), 26 deletions(-)
 create mode 100644 help/LINGUAS

diff --git a/help/LINGUAS b/help/LINGUAS
new file mode 100644
index 000..9f7af5e
--- /dev/null
+++ b/help/LINGUAS
@@ -0,0 +1,21 @@
+ca
+cs
+da
+de
+el
+es
+fi
+fr
+gl
+hr
+hu
+id
+it
+ko
+pl
+pt
+pt_BR
+ru
+sl
+sv
+zh_CN

  1   2   >