commit 000product for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-07-02 21:03:26

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.4615 (New)


Package is "000product"

Tue Jul  2 21:03:26 2019 rev:1389 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ openSUSE-Addon-NonOss-ftp-ftp-i586_x86_64.kiwi ++
--- /var/tmp/diff_new_pack.JSNDM8/_old  2019-07-02 21:03:42.691672515 +0200
+++ /var/tmp/diff_new_pack.JSNDM8/_new  2019-07-02 21:03:42.695672522 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -36,11 +36,11 @@
   true
   -x -2
   openSUSE
-  20190701
+  20190702
   11
-  cpe:/o:opensuse:opensuse-addon-nonoss:20190701,openSUSE NonOSS 
Addon
+  cpe:/o:opensuse:opensuse-addon-nonoss:20190702,openSUSE NonOSS 
Addon
   af ar be_BY bg br ca cy el et ga gl gu_IN he 
hi_IN hr ka km ko lt mk nn pa_IN rw sk sl sr_CS ss st tg th tr uk ve vi xh zu 

-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190701/i586
 
obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190701/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190702/i586
 
obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190702/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.JSNDM8/_old  2019-07-02 21:03:42.711672546 +0200
+++ /var/tmp/diff_new_pack.JSNDM8/_new  2019-07-02 21:03:42.715672552 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20190701
+  20190702
   11
-  cpe:/o:opensuse:opensuse-microos:20190701,openSUSE 
MicroOS
+  cpe:/o:opensuse:opensuse-microos:20190702,openSUSE 
MicroOS
   en_US 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20190701/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20190702/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
++ openSUSE-cd-mini-i586.kiwi ++
--- /var/tmp/diff_new_pack.JSNDM8/_old  2019-07-02 21:03:42.747672601 +0200
+++ /var/tmp/diff_new_pack.JSNDM8/_new  2019-07-02 21:03:42.747672601 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,11 +32,11 @@
   true
   -x -2
   openSUSE
-  20190701
+  20190702
   11
-  cpe:/o:opensuse:opensuse:20190701,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20190702,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190701/i586
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190702/i586
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-cd-mini-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.JSNDM8/_old  2019-07-02 21:03:42.763672625 +0200
+++ /var/tmp/diff_new_pack.JSNDM8/_new  2019-07-02 21:03:42.763672625 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20190701
+  20190702
   11
-  cpe:/o:opensuse:opensuse:20190701,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20190702,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190701/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190702/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-dvd5-dvd-i586.kiwi ++
--- /var/tmp/diff_new_pack.JSNDM8/_old  2019-07-02 21:03:42.775672643 +0200
+++ /var/tmp/diff_new_pack.JSNDM8/_new  2019-07-02 21:03:42.775672643 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,11 +32,11 @@
   true
   -x -2
   openSUSE
-  20190701
+  20190702
   11
-  cpe:/o:opensuse:opensuse:20190701,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20190702,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  

commit 000update-repos for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-07-02 21:03:22

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.4615 (New)


Package is "000update-repos"

Tue Jul  2 21:03:22 2019 rev:389 rq: version:unknown
Tue Jul  2 21:03:13 2019 rev:388 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.1:update_1562048919.packages.xz
  42.3:update_1562052227.packages.xz



Other differences:
--















































































































































































































































































































































































































































































































































































commit 000update-repos for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-07-02 21:03:09

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.4615 (New)


Package is "000update-repos"

Tue Jul  2 21:03:09 2019 rev:387 rq: version:unknown
Tue Jul  2 21:03:01 2019 rev:386 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.0:update_1562048377.packages.xz
  factory:non-oss_1385.1.packages.xz



Other differences:
--













































































































































































































































































































































































































































































































































































commit 000release-packages for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package 000release-packages for 
openSUSE:Factory checked in at 2019-07-02 21:03:22

Comparing /work/SRC/openSUSE:Factory/000release-packages (Old)
 and  /work/SRC/openSUSE:Factory/.000release-packages.new.4615 (New)


Package is "000release-packages"

Tue Jul  2 21:03:22 2019 rev:187 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ openSUSE-Addon-NonOss-release.spec ++
--- /var/tmp/diff_new_pack.JL3STN/_old  2019-07-02 21:03:40.739669542 +0200
+++ /var/tmp/diff_new_pack.JL3STN/_new  2019-07-02 21:03:40.739669542 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package openSUSE-Addon-NonOss-release (Version 20190701)
+# spec file for package openSUSE-Addon-NonOss-release (Version 20190702)
 #
 # Copyright (c) 2019 openSUSE.
 #
@@ -16,16 +16,16 @@
 Name:   openSUSE-Addon-NonOss-release
 %define product openSUSE-Addon-NonOss
 Summary:openSUSE NonOSS Addon
-Version:20190701
+Version:    20190702
 Release:0
 License:BSD-3-Clause
 Group:  System/Fhs
 
 Provides:   %name-%version
 Provides:   product() = openSUSE-Addon-NonOss
-Provides:   product(openSUSE-Addon-NonOss) = 20190701-0
+Provides:   product(openSUSE-Addon-NonOss) = 20190702-0
 Provides:   product-label() = non%20oss%20addon
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Daddon%2Dnonoss%3A20190701
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Daddon%2Dnonoss%3A20190702
 
 
 AutoReqProv:on
@@ -49,10 +49,10 @@
 
   openSUSE
   openSUSE-Addon-NonOss
-  20190701
+  20190702
   0
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-addon-nonoss:20190701
+  cpe:/o:opensuse:opensuse-addon-nonoss:20190702
   
 
 

++ openSUSE-MicroOS-release.spec ++
--- /var/tmp/diff_new_pack.JL3STN/_old  2019-07-02 21:03:40.771669590 +0200
+++ /var/tmp/diff_new_pack.JL3STN/_new  2019-07-02 21:03:40.775669597 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   openSUSE-MicroOS-release
-Version:20190701
+Version:    20190702
 Release:0
 Summary:openSUSE MicroOS 
 License:GPL-2.0-or-later
@@ -40,9 +40,9 @@
 ExclusiveArch:  %ix86 x86_64 ppc64le s390x aarch64
 Provides:   %name-%version
 Provides:   product() = openSUSE-MicroOS
-Provides:   product(openSUSE-MicroOS) = 20190701-0
+Provides:   product(openSUSE-MicroOS) = 20190702-0
 Provides:   product-label() = openSUSE%20MicroOS
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dmicroos%3A20190701
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dmicroos%3A20190702
 Provides:   product-url(releasenotes) = 
http%3A%2F%2Fdoc.opensuse.org%2Frelease%2Dnotes%2Fx86_64%2FopenSUSE%2FTumbleweed%2Frelease%2Dnotes%2DopenSUSE.rpm
 Provides:   product-endoflife()
 Requires:   product_flavor(openSUSE-MicroOS)
@@ -58,7 +58,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(dvd)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190701-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190702-0
 Summary:openSUSE MicroOS
 
 %description dvd
@@ -74,7 +74,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(kubic-dvd)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190701-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190702-0
 Summary:openSUSE MicroOS
 
 %description kubic-dvd
@@ -90,7 +90,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(appliance)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190701-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190702-0
 Summary:openSUSE MicroOS
 
 %description appliance
@@ -106,7 +106,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(appliance-kubic)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190701-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190702-0
 Summary:openSUSE MicroOS
 
 %description appliance-kubic
@@ -164,11 +164,11 @@
 
   openSUSE
   openSUSE-MicroOS
-  20190701
+  20190702
   0
   
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-microos:20190701
+  cpe:/o:opensuse:opensuse-microos:20190702
   openSUSE-MicroOS
   
 

++ openSUSE-release.spec ++
--- /var/tmp/diff_new_pack.JL3STN/_old  2019-07-02 21:03:40.791669621 +0200
+++ /var/tmp/diff_new_pack.JL3STN/_new  2019-07-02 21:03:40.795669627 +0200
@@ -20,7 +20,7 @@
 #define betaversion %{nil}
 %define codename Tumbleweed
 Name:   openSUSE-release
-Version:20190701
+Version:    2019070

commit 000update-repos for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-07-02 21:02:59

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.4615 (New)


Package is "000update-repos"

Tue Jul  2 21:02:59 2019 rev:385 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  factory_20190701.packages.xz



Other differences:
--












































































































































































































































































































































































































































































































































































commit pavucontrol for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package pavucontrol for openSUSE:Factory 
checked in at 2019-07-02 15:18:29

Comparing /work/SRC/openSUSE:Factory/pavucontrol (Old)
 and  /work/SRC/openSUSE:Factory/.pavucontrol.new.4615 (New)


Package is "pavucontrol"

Tue Jul  2 15:18:29 2019 rev:30 rq:713025 version:4.0

Changes:

--- /work/SRC/openSUSE:Factory/pavucontrol/pavucontrol.changes  2017-01-23 
11:40:38.838158060 +0100
+++ /work/SRC/openSUSE:Factory/.pavucontrol.new.4615/pavucontrol.changes
2019-07-02 15:18:31.650752475 +0200
@@ -1,0 +2,29 @@
+Sun Jun 30 23:17:05 UTC 2019 - Avindra Goolcharan 
+
+- Update to version 4.0:
+  * There can now be only one pavucontrol window open at a time.
+Trying to start pavucontrol for a second time brings the first
+window to foreground.
+  * Added a "Show volume meters" checkbox to the Configuration tab.
+Disabling the volume meters reduces CPU use.
+  * Improve the use of space (remove useless margins and paddings).
+  * Use a more appropriate icon for the channel lock button.
+  * Better channel label layout, prevents volume sliders from getting
+unaligned.
+  * Maximum latency offset increased from 2 to 5 seconds to
+accommodate AirPlay devices that often have higher latency than
+2 seconds (this is not that useful on newer PulseAudio versions,
+though, because the latency is reported much more accurately
+than before).
+  * New --version command line option.
+  * Dropped support for Gtk+ 2.
+  * Bumped the minimum supported libpulse version to 5.0.
+  * Improved compatibility with newer Glade versions.
+  * New translations: Chinese (Taiwan), Croatian, Korean, Norwegian
+Nynorsk, Lithuanian, Valencian.
+  * Updated translations: Finnish, French, German, Italian,
+Japanese, Polish, Swedish.
+- cleanup with spec-cleaner
+- drop pavucontrol-use-C++11-for-building.patch (upstreamed)
+
+---

Old:

  pavucontrol-3.0.tar.xz
  pavucontrol-use-C++11-for-building.patch

New:

  pavucontrol-4.0.tar.xz



Other differences:
--
++ pavucontrol.spec ++
--- /var/tmp/diff_new_pack.Z5ynyJ/_old  2019-07-02 15:18:32.414753648 +0200
+++ /var/tmp/diff_new_pack.Z5ynyJ/_new  2019-07-02 15:18:32.418753654 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package pavucontrol
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,39 +12,30 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   pavucontrol
+Version:4.0
+Release:0
 Summary:PulseAudio Volume Control
-License:GPL-2.0+
+License:GPL-2.0-or-later
 Group:  Productivity/Multimedia/Sound/Mixers
-Version:3.0
-Release:0
-Url:http://freedesktop.org/software/pulseaudio/pavucontrol/
-Source: 
http://freedesktop.org/software/pulseaudio/pavucontrol/%{name}-%{version}.tar.xz
-# PATCH-FIX-UPSTREAM pavucontrol-use-C++11-for-building.patch 
zai...@opensuse.org -- Use C++11 for building
-Patch0: pavucontrol-use-C++11-for-building.patch
+URL:https://freedesktop.org/software/pulseaudio/pavucontrol/
+Source: 
https://freedesktop.org/software/pulseaudio/pavucontrol/%{name}-%{version}.tar.xz
 BuildRequires:  gcc-c++
 BuildRequires:  intltool
-# Needed for patch0 as it touches buildsystem.
-BuildRequires:  libtool
+BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
 # Only needed because we don't (and won't) support building xz tarballs by 
default... See bnc#697467
 BuildRequires:  xz
-%if 0%{?favor_gtk2}
-BuildRequires:  pkgconfig(gtkmm-2.4) >= 2.16
-BuildRequires:  pkgconfig(libcanberra-gtk) >= 0.16
-%else
-BuildRequires:  pkgconfig(gtkmm-3.0) >= 2.99
-BuildRequires:  pkgconfig(libcanberra-gtk3) >= 0.16
-%endif
 BuildRequires:  pkgconfig(libpulse) >= 0.9.16
 BuildRequires:  pkgconfig(libpulse-mainloop-glib) >= 0.9.16
 BuildRequires:  pkgconfig(sigc++-2.0)
 Recommends: %{name}-lang
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  pkgconfig(gtkmm-3.0) >= 2.99
+BuildRequires:  pkgconfig(libcanberra-gtk3) >= 0.16
 
 %description
 PulseAudio Volume Control (pavucontrol) is a simple GTK based volume
@@ -53,21 +44,21 @@
 hardware devices and of each playback stream separately.
 
 %lang_package
+

commit vulkan-validationlayers for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package vulkan-validationlayers for 
openSUSE:Factory checked in at 2019-07-02 15:18:13

Comparing /work/SRC/openSUSE:Factory/vulkan-validationlayers (Old)
 and  /work/SRC/openSUSE:Factory/.vulkan-validationlayers.new.4615 (New)


Package is "vulkan-validationlayers"

Tue Jul  2 15:18:13 2019 rev:6 rq:712364 version:1.1.112

Changes:

--- 
/work/SRC/openSUSE:Factory/vulkan-validationlayers/vulkan-validationlayers.changes
  2019-06-19 21:05:00.710325733 +0200
+++ 
/work/SRC/openSUSE:Factory/.vulkan-validationlayers.new.4615/vulkan-validationlayers.changes
2019-07-02 15:18:15.242726030 +0200
@@ -1,0 +2,14 @@
+Fri Jun 28 08:07:45 UTC 2019 - Jan Engelhardt 
+
+- Update to new upstream release 1.1.112
+  * layers: Validate VK_NV_shader_subgroup_partitioned,
+VK_NV_compute_shader_derivatives,
+VK_NV_fragment_shader_barycentric,
+VK_NV_shader_image_footprint
+  * corechecks: Add some BufferImageCopy VUs
+  * corechecks: Add VU checks for CUBE_COMPAT images
+  * chassis: Make chassis report device extensions
+  * layers: Add subgroup validation
+  * layers: Validate bind image and swapchain
+
+---

Old:

  Vulkan-ValidationLayers-1.1.107.g31.tar.xz

New:

  Vulkan-ValidationLayers-1.1.112.tar.xz



Other differences:
--
++ vulkan-validationlayers.spec ++
--- /var/tmp/diff_new_pack.5epvcu/_old  2019-07-02 15:18:16.322727976 +0200
+++ /var/tmp/diff_new_pack.5epvcu/_new  2019-07-02 15:18:16.326727984 +0200
@@ -16,10 +16,10 @@
 #
 
 
-%define version_unconverted 1.1.107.g31
+%define version_unconverted 1.1.112
 
 Name:   vulkan-validationlayers
-Version:1.1.107.g31
+Version:1.1.112
 Release:0
 Summary:Validation layers for Vulkan
 License:Apache-2.0
@@ -43,14 +43,6 @@
 
 This package contains the Khronos official Vulkan validation layers.
 
-%package devel
-Summary:Development files for Vulkan validation layers
-Group:  Development/Libraries/C and C++
-
-%description devel
-This subpackage contains header files and a static library for
-Vulkan validation layers.
-
 %prep
 %setup -qn Vulkan-ValidationLayers-%version
 
@@ -60,14 +52,12 @@
 
 %install
 %cmake_install
+# no header files
+rm -f "%buildroot/%_libdir"/*.a
 
 %files
 %license LICENSE.txt
 %_libdir/libVkLayer*.so
 %_datadir/vulkan/
 
-%files devel
-%_includedir/*
-%_libdir/*.a
-
 %changelog

++ Vulkan-ValidationLayers-1.1.107.g31.tar.xz -> 
Vulkan-ValidationLayers-1.1.112.tar.xz ++
 73350 lines of diff (skipped)

++ _service ++
--- /var/tmp/diff_new_pack.5epvcu/_old  2019-07-02 15:18:16.802728842 +0200
+++ /var/tmp/diff_new_pack.5epvcu/_new  2019-07-02 15:18:16.806728849 +0200
@@ -2,9 +2,9 @@

git
https://github.com/KhronosGroup/Vulkan-ValidationLayers
-   10a98fac8fae947e20f18b84f2b91fe5250227c2
-   v1.1.107
-   1.1.107.g@TAG_OFFSET@
+   52787ac40c8f945d734da3f550b10d92e3f5225e
+   52787ac40c8f945d734da3f550b10d92e3f5225e
+   1.1.112


*.tar




commit platformsh-cli for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package platformsh-cli for openSUSE:Factory 
checked in at 2019-07-02 15:18:11

Comparing /work/SRC/openSUSE:Factory/platformsh-cli (Old)
 and  /work/SRC/openSUSE:Factory/.platformsh-cli.new.4615 (New)


Package is "platformsh-cli"

Tue Jul  2 15:18:11 2019 rev:75 rq:712275 version:3.43.2

Changes:

--- /work/SRC/openSUSE:Factory/platformsh-cli/platformsh-cli.changes
2019-06-14 20:42:31.090380869 +0200
+++ /work/SRC/openSUSE:Factory/.platformsh-cli.new.4615/platformsh-cli.changes  
2019-07-02 15:18:12.838721695 +0200
@@ -1,0 +2,47 @@
+Thu Jun 27 15:54:02 UTC 2019 - ji...@boombatower.com
+
+- Update to version 3.43.2:
+  * Release v3.43.2
+  * Note --max is not recommended
+  * Installer: version constraints via --min and --max
+  * Allow plans not to have prices in create command
+  * Sync manifest.json with master branch
+  * Do not error for empty JSON object/array in decode command
+  * Output nothing instead of "null" for null properties
+
+---
+Wed Jun 26 00:46:32 UTC 2019 - ji...@boombatower.com
+
+- Update to version 3.43.1:
+  * Release v3.43.1
+  * Fix db:size miscalculation for older mysql databases
+
+---
+Tue Jun 25 04:03:25 UTC 2019 - ji...@boombatower.com
+
+- Update to version 3.43.0:
+  * Release v3.43.0
+  * Add decode command to README.md
+  * Rename variable:decode to decode
+  * Review fixes
+  * Add variable:decode command
+  * Support local variable in environment:relationships (relationships) command
+  * Property defaults
+  * Adapt route:list command
+  * Support reading routes from the local environment in route:get command
+  * Add --id and --primary options to route:get command
+  * Move test files so they don't interfere
+  * Add Platform.sh build files
+  * The --cleanup command can now ask the user if it should do a cleanup, and 
actually do it
+  * MariaDB 10.0 does not support my stuff :(, so adding extra check
+  * adding --cleanup option to check if InnoDB tables can be optimized
+  * Use bytes as the base to work on. Improve PGSQL correctness as well.
+  * rounding up forcing because php is weird
+  * rounding up is probably slightly better
+  * removing switch(true)
+  * Adding -B bytes option like mount:size
+  * Using the builting symfony formatMemory thing (even though it's worse)
+  * Made a mistake there
+  * Splitting up the code in functions, adding check that will estimate the 
Mysql disk size more closely
+
+---

Old:

  platformsh-cli-3.42.2.tar.xz

New:

  platformsh-cli-3.43.2.tar.xz



Other differences:
--
++ platformsh-cli.spec ++
--- /var/tmp/diff_new_pack.E2yY6V/_old  2019-07-02 15:18:14.010723808 +0200
+++ /var/tmp/diff_new_pack.E2yY6V/_new  2019-07-02 15:18:14.014723816 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   platformsh-cli
-Version:3.42.2
+Version:3.43.2
 Release:0
 Summary:Tool for managing Platform.sh services from the command line
 # See licenses.txt for dependency licenses.

++ _service ++
--- /var/tmp/diff_new_pack.E2yY6V/_old  2019-07-02 15:18:14.050723880 +0200
+++ /var/tmp/diff_new_pack.E2yY6V/_new  2019-07-02 15:18:14.054723888 +0200
@@ -2,7 +2,7 @@
   
 @PARENT_TAG@
 v(.*)
-refs/tags/v3.42.2
+refs/tags/v3.43.2
 git://github.com/platformsh/platformsh-cli.git
 git
 enable

++ _servicedata ++
--- /var/tmp/diff_new_pack.E2yY6V/_old  2019-07-02 15:18:14.074723924 +0200
+++ /var/tmp/diff_new_pack.E2yY6V/_new  2019-07-02 15:18:14.078723931 +0200
@@ -1,6 +1,6 @@
 
   
 git://github.com/platformsh/platformsh-cli.git
-354cffafe574e6441be6abebfe6cc8c8790ce644
+a59718a8f1fda77feae7c0dbada291e6fbbddadd
   
 

++ licenses.txt ++
--- /var/tmp/diff_new_pack.E2yY6V/_old  2019-07-02 15:18:14.138724039 +0200
+++ /var/tmp/diff_new_pack.E2yY6V/_new  2019-07-02 15:18:14.138724039 +0200
@@ -16,7 +16,7 @@
 padraic/phar-updaterv1.0.6   BSD-3-Clause  
 paragonie/random_compat v2.0.18  MIT   
 pjcdawkins/guzzle-oauth2-plugin v2.2.0   MIT   
-platformsh/client   v0.26.0  MIT   
+platformsh/client   v0.27.0  MIT   
 platformsh/console-form v0.0.23  MIT   
 psr/container   1.0.0MIT   
 psr/log 1.1.0MIT   

++ platformsh-cli-3.42.2.tar.xz -> platformsh-cli-3.43.2.tar.xz ++
 2318 lines of diff (skipped)

++ platformsh-cli-vendor.tar.xz ++
diff -urN '--exclude=CVS' 

commit vulkan-tools for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package vulkan-tools for openSUSE:Factory 
checked in at 2019-07-02 15:18:15

Comparing /work/SRC/openSUSE:Factory/vulkan-tools (Old)
 and  /work/SRC/openSUSE:Factory/.vulkan-tools.new.4615 (New)


Package is "vulkan-tools"

Tue Jul  2 15:18:15 2019 rev:7 rq:712365 version:1.1.112

Changes:

--- /work/SRC/openSUSE:Factory/vulkan-tools/vulkan-tools.changes
2019-06-19 21:04:58.754323962 +0200
+++ /work/SRC/openSUSE:Factory/.vulkan-tools.new.4615/vulkan-tools.changes  
2019-07-02 15:18:17.090729361 +0200
@@ -1,0 +2,8 @@
+Fri Jun 28 07:32:59 UTC 2019 - Jan Engelhardt 
+
+- Update to new upstream release 1.1.112
+  * vulkaninfo: Fix issues 195, 202
+  * cube: Add subpass dependencies
+  * vulkaninfo: Fix HTML format for multi-GPU computer
+
+---

Old:

  Vulkan-Tools-1.1.108.tar.xz

New:

  Vulkan-Tools-1.1.112.tar.xz



Other differences:
--
++ vulkan-tools.spec ++
--- /var/tmp/diff_new_pack.LRuA1E/_old  2019-07-02 15:18:20.954736056 +0200
+++ /var/tmp/diff_new_pack.LRuA1E/_new  2019-07-02 15:18:20.958736061 +0200
@@ -16,10 +16,10 @@
 #
 
 
-%define version_unconverted 1.1.108
+%define version_unconverted 1.1.112
 
 Name:   vulkan-tools
-Version:1.1.108
+Version:1.1.112
 Release:0
 Summary:Reference ICD loader for Vulkan
 License:Apache-2.0
@@ -29,10 +29,10 @@
 Source: Vulkan-Tools-%version.tar.xz
 BuildRequires:  cmake >= 3.4
 BuildRequires:  gcc-c++ >= 4.8
-BuildRequires:  glslang-devel >= 7.11.3188
+BuildRequires:  glslang-devel >= 7.11.3226
 BuildRequires:  pkg-config
 BuildRequires:  python3-base
-BuildRequires:  pkgconfig(vulkan) >= 1.1.108
+BuildRequires:  pkgconfig(vulkan) >= %version
 BuildRequires:  pkgconfig(x11)
 BuildRequires:  pkgconfig(xcb)
 Obsoletes:  vulkan < %version-%release

++ Vulkan-Tools-1.1.108.tar.xz -> Vulkan-Tools-1.1.112.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Vulkan-Tools-1.1.108/.appveyor.yml 
new/Vulkan-Tools-1.1.112/.appveyor.yml
--- old/Vulkan-Tools-1.1.108/.appveyor.yml  2019-05-29 18:22:32.0 
+0200
+++ new/Vulkan-Tools-1.1.112/.appveyor.yml  2019-06-25 21:08:41.0 
+0200
@@ -17,15 +17,22 @@
 environment:
   PYTHON_PATH: "C:/Python35"
   PYTHON_PACKAGE_PATH: "C:/Python35/Scripts"
+  CMAKE_URL: "http://cmake.org/files/v3.10/cmake-3.10.2-win64-x64.zip;
 
 branches:
   only:
 - master
 
+# Install desired CMake version 3.10.2 before any other building
+install:
+  - appveyor DownloadFile %CMAKE_URL% -FileName cmake.zip
+  - 7z x cmake.zip -oC:\cmake > nul
+  - set path=C:\cmake\bin;%path%
+  - cmake --version
+
 before_build:
   - "SET PATH=C:\\Python35;C:\\Python35\\Scripts;%PATH%"
   - echo Starting build for %APPVEYOR_REPO_NAME% in %APPVEYOR_BUILD_FOLDER%
-  - cmake --version
   # Generate build files using CMake for the build step.
   - echo Generating Vulkan-Tools CMake files for %PLATFORM% %CONFIGURATION%
   - cd %APPVEYOR_BUILD_FOLDER%
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Vulkan-Tools-1.1.108/.travis.yml 
new/Vulkan-Tools-1.1.112/.travis.yml
--- old/Vulkan-Tools-1.1.108/.travis.yml2019-05-29 18:22:32.0 
+0200
+++ new/Vulkan-Tools-1.1.112/.travis.yml2019-06-25 21:08:41.0 
+0200
@@ -45,6 +45,17 @@
 
 before_install:
   - set -e
+  - CMAKE_VERSION=3.10.2
+  - |
+if [[ "${TRAVIS_OS_NAME}" == "linux" ]]; then
+  
CMAKE_URL="https://cmake.org/files/v${CMAKE_VERSION%.*}/cmake-${CMAKE_VERSION}-Linux-x86_64.tar.gz;
+  echo CMAKE_URL=${CMAKE_URL}
+  mkdir cmake-${CMAKE_VERSION} && travis_retry wget --no-check-certificate 
-O - ${CMAKE_URL} | tar --strip-components=1 -xz -C cmake-${CMAKE_VERSION}
+  export PATH=${PWD}/cmake-${CMAKE_VERSION}/bin:${PATH}
+else
+  brew install cmake || brew upgrade cmake
+fi
+cmake --version
   - |
 if [[ "$VULKAN_BUILD_TARGET" == "LINUX" ]] || [[ "$VULKAN_BUILD_TARGET" == 
"GN" ]]; then
   # Install the appropriate Linux packages.
@@ -73,7 +84,6 @@
 
 script:
   - set -e
-  - cmake --version
   - |
 if [[ "$VULKAN_BUILD_TARGET" == "LINUX" ]]; then
   # Build Vulkan-Tools
@@ -134,7 +144,6 @@
 notifications:
   email:
 recipients:
-  - k...@lunarg.com
   - cnorth...@google.com
   - tob...@google.com
   - chrisfor...@google.com
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/Vulkan-Tools-1.1.108/build-android/vulkan-headers_revision_android 
new/Vulkan-Tools-1.1.112/build-android/vulkan-headers_revision_android

commit fence-agents for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package fence-agents for openSUSE:Factory 
checked in at 2019-07-02 15:18:22

Comparing /work/SRC/openSUSE:Factory/fence-agents (Old)
 and  /work/SRC/openSUSE:Factory/.fence-agents.new.4615 (New)


Package is "fence-agents"

Tue Jul  2 15:18:22 2019 rev:46 rq:712824 version:4.4.0+git.1558595666.5f79f9e9

Changes:

--- /work/SRC/openSUSE:Factory/fence-agents/fence-agents.changes
2019-06-19 21:09:22.178565827 +0200
+++ /work/SRC/openSUSE:Factory/.fence-agents.new.4615/fence-agents.changes  
2019-07-02 15:18:26.810745046 +0200
@@ -1,0 +2,6 @@
+Mon Jul  1 11:27:59 UTC 2019 - Diego Vinicius Akechi 
+
+- White list the aliyun fence agent to get it included and provided
+  by the fence-agent package (bsc#1139913) 
+
+---



Other differences:
--
++ fence-agents.spec ++
--- /var/tmp/diff_new_pack.mPVVo1/_old  2019-07-02 15:18:27.498746102 +0200
+++ /var/tmp/diff_new_pack.mPVVo1/_new  2019-07-02 15:18:27.502746107 +0200
@@ -23,7 +23,7 @@
 %endif
 
 %global plugin_dir %{_libdir}/stonith/plugins/rhcs
-%define agent_list alom amt amt_ws apc apc_snmp azure_arm bladecenter brocade 
cisco_mds cisco_ucs compute docker drac5 dummy eaton_snmp emerson eps evacuate 
gce hds_cb hpblade ibmblade ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular 
ipdu ipmilan ironic kdump ldom lpar mpath netio openstack powerman pve raritan 
rcd_serial redfish rhevm rsa rsb sanbox2 sbd scsi vbox virsh vmware vmware_rest 
wti xenapi zvm
+%define agent_list aliyun alom amt amt_ws apc apc_snmp azure_arm bladecenter 
brocade cisco_mds cisco_ucs compute docker drac5 dummy eaton_snmp emerson eps 
evacuate gce hds_cb hpblade ibmblade ifmib ilo ilo_moonshot ilo_mp ilo_ssh 
intelmodular ipdu ipmilan ironic kdump ldom lpar mpath netio openstack powerman 
pve raritan rcd_serial redfish rhevm rsa rsb sanbox2 sbd scsi vbox virsh vmware 
vmware_rest wti xenapi zvm
 
 Name:   fence-agents
 Summary:Fence Agents for High Availability




commit otrs for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package otrs for openSUSE:Factory checked in 
at 2019-07-02 15:18:17

Comparing /work/SRC/openSUSE:Factory/otrs (Old)
 and  /work/SRC/openSUSE:Factory/.otrs.new.4615 (New)


Package is "otrs"

Tue Jul  2 15:18:17 2019 rev:64 rq:712523 version:6.0.19

Changes:

--- /work/SRC/openSUSE:Factory/otrs/otrs.changes2019-03-26 
15:40:51.668290233 +0100
+++ /work/SRC/openSUSE:Factory/.otrs.new.4615/otrs.changes  2019-07-02 
15:18:23.886740556 +0200
@@ -1,0 +2,63 @@
+Sat Jun 29 10:55:31 UTC 2019 - ch...@computersalat.de
+
+- Update to 6.0.19
+  https://community.otrs.com/release-notes-otrs-6-patch-level-19/
+- fix for boo#1137614
+  * (CVE-2019-12497, OSA-2019-09)
+Information Disclosure
+In the customer or external frontend, personal information of agents
+can be disclosed like Name and mail address in external notes.
+- fix for boo#1137615
+  * (CVE-2019-12248, OSA-2019-08)
+Loading External Image Resources
+An attacker could send a malicious email to an OTRS system. If a
+logged in agent user quotes it, the email could cause the browser
+to load external image resources.
+- Update to 6.0.18
+  https://community.otrs.com/release-notes-otrs-6-patch-level-18/
+- fix for boo#1139406
+  * (CVE-2019-10066, OSA-2019-06)
+Stored XSS
+An attacker who is logged into OTRS as an agent with appropriate
+permissions may create a carefully crafted calendar appointment
+in order to cause execution of JavaScript in the context of OTRS.
+- fix for boo#1139406
+  * (CVE-2019-10067, OSA-2019-05)
+Reflected and Stored XSS
+An attacker who is logged into OTRS as an agent user with appropriate
+permissions may manipulate the URL to cause execution of JavaScript
+in the context of OTRS.
+- fix for boo#1139406
+  * (CVE-2019-9892, OSA-2019-04)
+XXE Processing
+An attacker who is logged into OTRS as an agent user with appropriate
+permissions may try to import carefully crafted Report Statistics XML
+that will result in reading of arbitrary files of OTRS filesystem.
+- Update to 6.0.17
+  https://community.otrs.com/release-notes-otrs-6-patch-level-17/
+- fix for boo#1129755
+  * (CVE-2019-9751, OSA-2019-02)
+XSS
+An attacker who is logged into OTRS as an admin user may manipulate
+the URL to cause execution of JavaScript in the context of OTRS.
+- rebase otrs-perm_test.patch
+
+---
+Sat Jun 22 22:33:42 UTC 2019 - ch...@computersalat.de
+
+- fix changes file (chronological order)
+- update missing CVE for OSA-2018-10, OSA-2019-01
+
+---
+Fri Feb 22 07:29:57 UTC 2019 - Franck Bui 
+
+- Drop use of $FIRST_ARG in .spec
+
+  The use of $FIRST_ARG was probably required because of the
+  %service_* rpm macros were playing tricks with the shell positional
+  parameters. This is bad practice and error prones so let's assume
+  that no macros should do that anymore and hence it's safe to assume
+  that positional parameters remains unchanged after any rpm macro
+  call.
+
+---
@@ -24 +87 @@
-  * (CVE-n/a, OSA-2019-01)
+  * (CVE-2019-9752, OSA-2019-01)
@@ -62 +125 @@
-  * (CVE-n/a, OSA-2018-10)
+  * (CVE-2018-20800, OSA-2018-10)

Old:

  itsm-6.0.16.tar.bz2
  otrs-6.0.16.tar.bz2

New:

  itsm-6.0.19.tar.bz2
  otrs-6.0.19.tar.bz2



Other differences:
--
++ otrs.spec ++
--- /var/tmp/diff_new_pack.hJmjPs/_old  2019-07-02 15:18:26.354744345 +0200
+++ /var/tmp/diff_new_pack.hJmjPs/_new  2019-07-02 15:18:26.358744352 +0200
@@ -23,8 +23,8 @@
 
 Name:   otrs
 
-%define otrs_ver 6.0.16
-%define itsm_ver 6.0.16
+%define otrs_ver 6.0.19
+%define itsm_ver 6.0.19
 %define itsm_min 6
 %define otrs_root /srv/%{name}
 %define otrsdoc_dir_files AUTHORS* CHANGES* COPYING* CREDITS README* 
UPGRADING.SUSE doc
@@ -343,7 +343,7 @@
   /usr/sbin/a2enmod version >/dev/null
 %endif
 # Update ?
-if [ ${FIRST_ARG:-0} -gt 1 ]; then
+if [ $1 -gt 1 ]; then
   # OTRS_ROOT changed from /opt to /srv
   if [ -f /opt/%{name}/Kernel/Config.pm.rpmsave ]; then
 mv /opt/%{name}/Kernel/Config.pm.rpmsave %{otrs_root}/Kernel/
@@ -355,7 +355,7 @@
   fi
 fi
 # if rpm is not in update mode
-if ! [ ${FIRST_ARG:-0} -gt 1 ]; then
+if ! [ $1 -gt 1 ]; then
if [ -z "${YAST_IS_RUNNING}" ]; then
if [ -n "$LC_ALL" ]; then
lang="$LC_ALL"

++ itsm-6.0.16.tar.bz2 -> itsm-6.0.19.tar.bz2 ++
/work/SRC/openSUSE:Factory/otrs/itsm-6.0.16.tar.bz2 
/work/SRC/openSUSE:Factory/.otrs.new.4615/itsm-6.0.19.tar.bz2 differ: char 11, 
line 1

++ 

commit jython for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package jython for openSUSE:Factory checked 
in at 2019-07-02 15:18:01

Comparing /work/SRC/openSUSE:Factory/jython (Old)
 and  /work/SRC/openSUSE:Factory/.jython.new.4615 (New)


Package is "jython"

Tue Jul  2 15:18:01 2019 rev:28 rq:712782 version:2.2.1

Changes:

--- /work/SRC/openSUSE:Factory/jython/jython.changes2019-03-01 
20:25:25.814068709 +0100
+++ /work/SRC/openSUSE:Factory/.jython.new.4615/jython.changes  2019-07-02 
15:18:02.546703139 +0200
@@ -1,0 +2,5 @@
+Wed Jun 26 15:53:35 UTC 2019 - Fridrich Strba 
+
+- Add maven artifact alias
+
+---



Other differences:
--
++ jython.spec ++
--- /var/tmp/diff_new_pack.u85RrW/_old  2019-07-02 15:18:03.314704524 +0200
+++ /var/tmp/diff_new_pack.u85RrW/_new  2019-07-02 15:18:03.318704531 +0200
@@ -214,7 +214,7 @@
 # pom
 install -d -m 755 %{buildroot}%{_mavenpomdir}
 install -m 644 build/maven/pom.xml %{buildroot}%{_mavenpomdir}/JPP-%{name}.pom
-%add_maven_depmap JPP-%{name}.pom %{name}.jar -a org.python:jython-standalone
+%add_maven_depmap JPP-%{name}.pom %{name}.jar -a 
org.python:jython-standalone,jython:jython
 
 # javadoc
 install -d -m 755 %{buildroot}%{_javadocdir}/%{name}




commit desktop-file-utils for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package desktop-file-utils for 
openSUSE:Factory checked in at 2019-07-02 15:17:49

Comparing /work/SRC/openSUSE:Factory/desktop-file-utils (Old)
 and  /work/SRC/openSUSE:Factory/.desktop-file-utils.new.4615 (New)


Package is "desktop-file-utils"

Tue Jul  2 15:17:49 2019 rev:61 rq:712751 version:0.23

Changes:

--- /work/SRC/openSUSE:Factory/desktop-file-utils/desktop-file-utils.changes
2019-05-16 22:01:58.582709888 +0200
+++ 
/work/SRC/openSUSE:Factory/.desktop-file-utils.new.4615/desktop-file-utils.changes
  2019-07-02 15:17:50.450681332 +0200
@@ -1,0 +2,6 @@
+Wed Jun 19 10:05:28 UTC 2019 - Cliff Zhao 
+
+- Add desktop-file-utils-add-Pantheon.patch: Backporting upstream 
+  patch to Add Pantheon to desktop env list(fdo#105785 bnc#1094774).
+
+---

New:

  desktop-file-utils-add-Pantheon.patch



Other differences:
--
++ desktop-file-utils.spec ++
--- /var/tmp/diff_new_pack.qcv9eR/_old  2019-07-02 15:17:51.190682666 +0200
+++ /var/tmp/diff_new_pack.qcv9eR/_new  2019-07-02 15:17:51.194682673 +0200
@@ -28,6 +28,8 @@
 Source2:macros.desktop-file-utils
 # PATCH-FEATURE-OPENSUSE desktop-file-utils-suse-keys.patch vu...@opensuse.org 
-- Handle SUSE-specific keys in validator. This is not strictly necessary, 
since they are prefixed with X-, but we can verify that the value has the right 
type.
 Patch0: desktop-file-utils-suse-keys.patch
+# PATCH-FIX-UPSTREAM desktop-file-utils-add-Pantheon.patch fdo#105785 
bnc#1094774 qz...@suse.com -- Backporting upstream patch to Add Pantheon to 
desktop env list.
+Patch1: desktop-file-utils-add-Pantheon.patch
 BuildRequires:  glib2-devel
 BuildRequires:  pkgconfig
 BuildRequires:  xz
@@ -46,6 +48,7 @@
 %prep
 %setup -q
 %patch0
+%patch1 -p1
 
 %build
 %configure \

++ desktop-file-utils-add-Pantheon.patch ++
diff -Nura desktop-file-utils-0.23/src/validate.c 
desktop-file-utils-0.23_new/src/validate.c
--- desktop-file-utils-0.23/src/validate.c  2016-06-19 01:00:22.0 
+0800
+++ desktop-file-utils-0.23_new/src/validate.c  2019-06-19 17:58:15.104352109 
+0800
@@ -366,8 +366,9 @@
   { DESKTOP_STRING_TYPE,"Exec",   TRUE,  FALSE, FALSE, 
handle_exec_key }
 };
 
+/* This should be the same list as in xdg-specs/menu/menu-spec.xml */
 static const char *show_in_registered[] = {
-"GNOME", "KDE", "LXDE", "LXQt", "MATE", "Razor", "ROX", "TDE", "Unity", 
"XFCE", "Cinnamon", "EDE", "Old"
+"GNOME", "KDE", "LXDE", "LXQt", "MATE", "Razor", "ROX", "TDE", "Unity", 
"XFCE", "EDE", "Cinnamon", "Pantheon", "Old"
 };
 
 static struct {



commit libsodium for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package libsodium for openSUSE:Factory 
checked in at 2019-07-02 15:17:56

Comparing /work/SRC/openSUSE:Factory/libsodium (Old)
 and  /work/SRC/openSUSE:Factory/.libsodium.new.4615 (New)


Package is "libsodium"

Tue Jul  2 15:17:56 2019 rev:26 rq:712754 version:1.0.18

Changes:

--- /work/SRC/openSUSE:Factory/libsodium/libsodium.changes  2019-02-08 
13:45:15.178837866 +0100
+++ /work/SRC/openSUSE:Factory/.libsodium.new.4615/libsodium.changes
2019-07-02 15:17:57.522694082 +0200
@@ -1,0 +2,35 @@
+Sun Jun 16 10:04:32 UTC 2019 - ec...@opensuse.org
+
+- Update to 1.0.18
+  - Enterprise versions of Visual Studio are now supported.
+  - Visual Studio 2019 is now supported.
+  - 32-bit binaries for Visual Studio 2010 are now provided.
+  - A test designed to trigger an OOM condition didn't work on 
+Linux systems with memory overcommit turned on. It has been 
+removed in order to fix Ansible builds.
+  - Emscripten: print and printErr functions are overridden to send
+errors to the console, if there is one.
+  - Emscripten: UTF8ToString() is now exported since 
+Pointer_stringify() has been deprecated.
+  - Libsodium version detection has been fixed in the CMake recipe.
+  - Generic hashing got a 10% speedup on AVX2.
+  - New target: WebAssembly/WASI 
+(compile with dist-builds/wasm32-wasi.sh).
+  - New functions to map a hash to an edwards25519 point 
+or get a random point: 
+core_ed25519_from_hash() and core_ed25519_random().
+  - crypto_core_ed25519_scalar_mul() has been implemented for 
+scalar*scalar (mod L) multiplication.
+  - Support for the Ristretto group has been implemented for 
+interoperability with wasm-crypto.
+  - Improvements have been made to the test suite.
+  - Portability improvements have been made.
+  - getentropy() is now used on systems providing this system call.
+  - randombytes_salsa20 has been renamed to randombytes_internal.
+  - Support for NativeClient has been removed.
+  - Most ((nonnull)) attributes have been relaxed to allow 0-length
+inputs to be NULL.
+  - The -ftree-vectorize and -ftree-slp-vectorize compiler switches
+are now used, if available, for optimized builds.
+
+---

Old:

  libsodium-1.0.17.tar.gz
  libsodium-1.0.17.tar.gz.sig

New:

  libsodium-1.0.18.tar.gz
  libsodium-1.0.18.tar.gz.sig



Other differences:
--
++ libsodium.spec ++
--- /var/tmp/diff_new_pack.udp1rC/_old  2019-07-02 15:17:58.186695279 +0200
+++ /var/tmp/diff_new_pack.udp1rC/_new  2019-07-02 15:17:58.186695279 +0200
@@ -12,21 +12,21 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 %define sover   23
 %define lname   %{name}%{sover}
 Name:   libsodium
-Version:1.0.17
+Version:1.0.18
 Release:0
 Summary:Portable NaCl-based crypto library
 License:ISC
 Group:  System/Libraries
 URL:https://github.com/jedisct1/libsodium
-Source0:
https://github.com/jedisct1/libsodium/releases/download/%{version}/%{name}-%{version}.tar.gz
-Source1:
https://github.com/jedisct1/libsodium/releases/download/%{version}/%{name}-%{version}.tar.gz.sig
+Source0:
https://download.libsodium.org/libsodium/releases/%{name}-%{version}.tar.gz
+Source1:
https://download.libsodium.org/libsodium/releases/%{name}-%{version}.tar.gz.sig
 Source2:%{name}.keyring
 Source99:   baselibs.conf
 BuildRequires:  pkgconfig

++ libsodium-1.0.17.tar.gz -> libsodium-1.0.18.tar.gz ++
 18164 lines of diff (skipped)





commit qemu for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package qemu for openSUSE:Factory checked in 
at 2019-07-02 15:17:39

Comparing /work/SRC/openSUSE:Factory/qemu (Old)
 and  /work/SRC/openSUSE:Factory/.qemu.new.4615 (New)


Package is "qemu"

Tue Jul  2 15:17:39 2019 rev:158 rq:712740 version:4.0.0

Changes:

qemu-testsuite.changes: same change
--- /work/SRC/openSUSE:Factory/qemu/qemu.changes2019-06-20 
18:54:10.892745631 +0200
+++ /work/SRC/openSUSE:Factory/.qemu.new.4615/qemu.changes  2019-07-02 
15:17:40.350663122 +0200
@@ -1,0 +2,5 @@
+Tue Jun 11 09:47:44 UTC 2019 - Christian Goll 
+
+- fixed regression for ksm.service was (bsc#1112646) 
+
+---



Other differences:
--
qemu-testsuite.spec: same change
qemu.spec: same change
++ ksm.service ++
--- /var/tmp/diff_new_pack.BRrezb/_old  2019-07-02 15:17:43.030667954 +0200
+++ /var/tmp/diff_new_pack.BRrezb/_new  2019-07-02 15:17:43.030667954 +0200
@@ -6,8 +6,8 @@
 [Service]
 Type=oneshot
 RemainAfterExit=yes
-ExecStart=/bin/echo 1 > /sys/kernel/mm/ksm/run
-ExecStop=/bin/echo 0 > /sys/kernel/mm/ksm/run
+ExecStart=/bin/bash -c "/bin/echo 1 > /sys/kernel/mm/ksm/run"
+ExecStop=/bin/bash -c "/bin/echo 0 > /sys/kernel/mm/ksm/run"
 
 [Install]
 WantedBy=multi-user.target







commit Mesa for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package Mesa for openSUSE:Factory checked in 
at 2019-07-02 15:17:32

Comparing /work/SRC/openSUSE:Factory/Mesa (Old)
 and  /work/SRC/openSUSE:Factory/.Mesa.new.4615 (New)


Package is "Mesa"

Tue Jul  2 15:17:32 2019 rev:351 rq:712676 version:unknown

Changes:

--- /work/SRC/openSUSE:Factory/Mesa/Mesa-drivers.changes2019-06-27 
15:52:11.727822439 +0200
+++ /work/SRC/openSUSE:Factory/.Mesa.new.4615/Mesa-drivers.changes  
2019-07-02 15:17:33.686651107 +0200
@@ -1,0 +2,9 @@
+Thu Jun 27 20:18:07 UTC 2019 - Bjørn Lie 
+
+- Update to version 19.1.1:
+  * Mostly in fixes for different drivers (RADV, ANV, Nouveau,
+Virgl, V3D, R300g, ...).
+  * Also different fixes for different parts (Meson build, GLX,
+etc).
+
+---
Mesa.changes: same change

Old:

  mesa-19.1.0.tar.xz
  mesa-19.1.0.tar.xz.sig

New:

  mesa-19.1.1.tar.xz
  mesa-19.1.1.tar.xz.sig



Other differences:
--
++ Mesa-drivers.spec ++
--- /var/tmp/diff_new_pack.HZAk7a/_old  2019-07-02 15:17:35.294654007 +0200
+++ /var/tmp/diff_new_pack.HZAk7a/_new  2019-07-02 15:17:35.298654014 +0200
@@ -42,7 +42,7 @@
 
 %define glamor 1
 %define _name_archive mesa
-%define _version 19.1.0
+%define _version 19.1.1
 %define with_opencl 0
 %define with_vulkan 0
 %define with_llvm 0
@@ -110,7 +110,7 @@
 %endif
 
 Name:   Mesa-drivers
-Version:19.1.0
+Version:19.1.1
 Release:0
 Summary:System for rendering 3-D graphics
 License:MIT

Mesa.spec: same change

++ mesa-19.1.0.tar.xz -> mesa-19.1.1.tar.xz ++
/work/SRC/openSUSE:Factory/Mesa/mesa-19.1.0.tar.xz 
/work/SRC/openSUSE:Factory/.Mesa.new.4615/mesa-19.1.1.tar.xz differ: char 27, 
line 1




commit powerpc-utils for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package powerpc-utils for openSUSE:Factory 
checked in at 2019-07-02 10:49:27

Comparing /work/SRC/openSUSE:Factory/powerpc-utils (Old)
 and  /work/SRC/openSUSE:Factory/.powerpc-utils.new.4615 (New)


Package is "powerpc-utils"

Tue Jul  2 10:49:27 2019 rev:97 rq:712513 version:1.3.7

Changes:

--- /work/SRC/openSUSE:Factory/powerpc-utils/powerpc-utils.changes  
2019-06-22 11:22:53.509303124 +0200
+++ /work/SRC/openSUSE:Factory/.powerpc-utils.new.4615/powerpc-utils.changes
2019-07-02 10:49:28.551602239 +0200
@@ -1,0 +2,6 @@
+Thu Jun 27 15:35:42 UTC 2019 - Michal Suchanek 
+
+- Drop compat patch on SLE 12 SP5.
+- Remove unused macro
+
+---
@@ -4 +10 @@
-- Update to version 1.3.7:
+- Update to version 1.3.7 (jsc#SLE-6176, bsc#1139456).
@@ -24,2 +30,2 @@
-  [jsc#SLE-6176, ofpathname_powernv.patch,
-   Revert-lparstat-Show-available-physical-processors-i.patch]
+  - Refresh ofpathname_powernv.patch, systemd-dir.patch,
+  Revert-lparstat-Show-available-physical-processors-i.patch



Other differences:
--
++ powerpc-utils.spec ++
--- /var/tmp/diff_new_pack.5JFZE6/_old  2019-07-02 10:49:29.115603109 +0200
+++ /var/tmp/diff_new_pack.5JFZE6/_new  2019-07-02 10:49:29.115603109 +0200
@@ -12,11 +12,10 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
-%define version_unconverted 1.3.6
 Name:   powerpc-utils
 Version:1.3.7
 Release:0
@@ -61,7 +60,7 @@
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%if 0%{?sle_version} <= 15
+%if 0%{?sle_version} <= 120400 || 0%{?sle_version} == 15
 %patch5 -p1
 %endif
 




commit bluez for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package bluez for openSUSE:Factory checked 
in at 2019-07-02 10:49:38

Comparing /work/SRC/openSUSE:Factory/bluez (Old)
 and  /work/SRC/openSUSE:Factory/.bluez.new.4615 (New)


Package is "bluez"

Tue Jul  2 10:49:38 2019 rev:162 rq:712640 version:5.50

Changes:

--- /work/SRC/openSUSE:Factory/bluez/bluez.changes  2019-05-03 
22:07:05.850879001 +0200
+++ /work/SRC/openSUSE:Factory/.bluez.new.4615/bluez.changes2019-07-02 
10:49:39.487619108 +0200
@@ -1,0 +2,8 @@
+Tue Jun 25 13:19:30 UTC 2019 - Frederic Crozat 
+
+- Add avinfo to bluez-test, useful for debugging.
+- Only BuildRequires pkgconfig(ell) on Tumbleweed.
+- Add bluez-5.50-a2dp-backports.patch: A2DP fixes for newer codecs
+  (upstream backport).
+
+---

New:

  bluez-5.50-a2dp-backports.patch



Other differences:
--
++ bluez.spec ++
--- /var/tmp/diff_new_pack.MWTCrX/_old  2019-07-02 10:49:40.235620262 +0200
+++ /var/tmp/diff_new_pack.MWTCrX/_new  2019-07-02 10:49:40.239620269 +0200
@@ -40,6 +40,8 @@
 Patch6: disable_some_obex_tests.patch
 # PATCH-FIX-UPSTREAM: improve profile availability on some audio devices
 Patch7: 0001-policy-Add-logic-to-connect-a-Sink.patch
+# PATCH-FIX-UPSTREAM a2dp fixes for newer codecs
+Patch8:bluez-5.50-a2dp-backports.patch
 # Upstream suggests to use btmon instead of hcidump and does not want those 
patches
 # => PATCH-FIX-OPENSUSE for those two :-)
 # fix some memory leak with malformed packet (reported upstream but not yet 
fixed)
@@ -60,7 +62,9 @@
 BuildRequires:  pkgconfig(alsa)
 BuildRequires:  pkgconfig(check)
 BuildRequires:  pkgconfig(dbus-1) >= 1.6
+%if 0%{?suse_version} >= 1550
 BuildRequires:  pkgconfig(ell) >= 0.3
+%endif
 BuildRequires:  pkgconfig(glib-2.0) >= 2.28
 # json-c is needed for --enable-mesh
 BuildRequires:  pkgconfig(json-c)
@@ -160,6 +164,7 @@
 %patch6 -p1
 %endif
 %patch7 -p1
+%patch8 -p1
 %patch101 -p1
 %patch102 -p1
 mkdir dbus-apis
@@ -183,7 +188,9 @@
--enable-library\
--enable-tools  \
--enable-cups   \
+%if 0%{?suse_version} >= 1550
--enable-mesh   \
+%endif
--enable-midi   \
--enable-test   \
--enable-experimental   \
@@ -217,6 +224,8 @@
 install -m0755 tools/btgatt-client %{buildroot}%{_bindir}
 # btmgmt can be useful
 install -m0755 tools/btmgmt %{buildroot}%{_bindir}
+# avinfo can be useful for debugging
+install -m0755 tools/avinfo $RPM_BUILD_ROOT%{_bindir}
 
 # for auto-enable subpackage
 find . -name main.conf
@@ -282,7 +291,9 @@
 %{_libexecdir}/bluetooth/obexd
 %{_bindir}/bluetoothctl
 %{_bindir}/btmon
+%if 0%{?suse_version} >= 1550
 %{_bindir}/meshctl
+%endif
 %{_bindir}/hcidump
 %{_bindir}/bccmd
 %{_libexecdir}/udev/
@@ -327,6 +338,7 @@
 
 %files test
 %defattr(-,root,root)
+%{_bindir}/avinfo
 #{_bindir}/hciemu
 %{_bindir}/l2test
 %{_bindir}/rctest

++ bluez-5.50-a2dp-backports.patch ++
 4714 lines (skipped)




commit rubygem-gem2rpm for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package rubygem-gem2rpm for openSUSE:Factory 
checked in at 2019-07-02 10:49:33

Comparing /work/SRC/openSUSE:Factory/rubygem-gem2rpm (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-gem2rpm.new.4615 (New)


Package is "rubygem-gem2rpm"

Tue Jul  2 10:49:33 2019 rev:27 rq:712555 version:0.10.1

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-gem2rpm/rubygem-gem2rpm.changes  
2019-02-28 21:24:42.861906797 +0100
+++ 
/work/SRC/openSUSE:Factory/.rubygem-gem2rpm.new.4615/rubygem-gem2rpm.changes
2019-07-02 10:49:34.323611142 +0200
@@ -1,0 +2,10 @@
+Sun Jun 23 02:24:56 UTC 2019 - Marcus Rueckert 
+
+- build without gem docs
+
+---
+Sun Jun 23 02:12:56 UTC 2019 - Marcus Rueckert 
+
+- added support for 2.7.0
+
+---



Other differences:
--
++ rubygem-gem2rpm.spec ++
--- /var/tmp/diff_new_pack.BlabwV/_old  2019-07-02 10:49:35.075612303 +0200
+++ /var/tmp/diff_new_pack.BlabwV/_new  2019-07-02 10:49:35.079612309 +0200
@@ -17,9 +17,11 @@
 
 
 %bcond_without  gem2rpm_bootstrap
+%if 0%{?suse_version} && 0%{?suse_version} < 1315
 %bcond_with ruby18
 %bcond_with ruby19
 %bcond_with ruby20
+%endif
 %bcond_with ruby21
 %if ! (0%{?suse_version} == 1315)
 %bcond_with ruby22
@@ -28,6 +30,7 @@
 %endif
 %bcond_with ruby25
 %bcond_with ruby26
+%bcond_with ruby27
 %bcond_with rubinius25
 
 Name:   rubygem-gem2rpm
@@ -37,8 +40,6 @@
 %define mod_full_name %{mod_name}-%{version}
 %define mod_branch -%{version}
 %define mod_weight 1001
-#define rb_build_versions %{rb_default_ruby}
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  %{ruby}
 BuildRequires:  ruby-macros >= 5
 %if %{with gem2rpm_bootstrap}
@@ -136,7 +137,7 @@
 %gem_build
 
 %install
-%gem_install -f --symlink-binaries --doc-files="AUTHORS LICENSE README"
+%gem_install -f --no-rdoc --no-ri --symlink-binaries --doc-files="AUTHORS 
LICENSE README"
 for i in %{buildroot}%{_docdir}/*rubygem-gem2rpm*/ ; do
   install -m 0644 %{S:1} $i/gem2rpm.yml
 done
@@ -194,10 +195,12 @@
 %{_libdir}/ruby/gems/2.1.0/gems/gem2rpm-%{version}
 %{_libdir}/ruby/gems/2.1.0/specifications/gem2rpm-%{version}.gemspec
 
+%if %{with docs}
 %files -n ruby2.1-rubygem-gem2rpm-doc
 %defattr(-,root,root,-)
 %doc %{_libdir}/ruby/gems/2.1.0/doc/gem2rpm-%{version}
 %endif
+%endif
 
 %if %{with ruby18}
 %package -n ruby1.8-rubygem-gem2rpm
@@ -251,10 +254,12 @@
 %{_libdir}/ruby/gems/1.8/gems/gem2rpm-%{version}
 %{_libdir}/ruby/gems/1.8/specifications/gem2rpm-%{version}.gemspec
 
+%if %{with docs}
 %files -n ruby1.8-rubygem-gem2rpm-doc
 %defattr(-,root,root,-)
 %doc %{_libdir}/ruby/gems/1.8/doc/gem2rpm-%{version}
 %endif
+%endif
 
 %if %{with ruby19}
 %package -n ruby1.9-rubygem-gem2rpm
@@ -308,10 +313,12 @@
 %{_libdir}/ruby/gems/1.9.1/gems/gem2rpm-%{version}
 %{_libdir}/ruby/gems/1.9.1/specifications/gem2rpm-%{version}.gemspec
 
+%if %{with docs}
 %files -n ruby1.9-rubygem-gem2rpm-doc
 %defattr(-,root,root,-)
 %doc %{_libdir}/ruby/gems/1.9.1/doc/gem2rpm-%{version}
 %endif
+%endif
 
 %if %{with ruby20}
 %package -n ruby2.0-rubygem-gem2rpm
@@ -365,10 +372,12 @@
 %{_libdir}/ruby/gems/2.0.0/gems/gem2rpm-%{version}
 %{_libdir}/ruby/gems/2.0.0/specifications/gem2rpm-%{version}.gemspec
 
+%if %{with docs}
 %files -n ruby2.0-rubygem-gem2rpm-doc
 %defattr(-,root,root,-)
 %doc %{_libdir}/ruby/gems/2.0.0/doc/gem2rpm-%{version}
 %endif
+%endif
 
 %if %{with ruby22}
 %package -n ruby2.2-rubygem-gem2rpm
@@ -422,10 +431,12 @@
 %{_libdir}/ruby/gems/2.2.0/gems/gem2rpm-%{version}
 %{_libdir}/ruby/gems/2.2.0/specifications/gem2rpm-%{version}.gemspec
 
+%if %{with docs}
 %files -n ruby2.2-rubygem-gem2rpm-doc
 %defattr(-,root,root,-)
 %doc %{_libdir}/ruby/gems/2.2.0/doc/gem2rpm-%{version}
 %endif
+%endif
 
 %if %{with ruby23}
 %package -n ruby2.3-rubygem-gem2rpm
@@ -479,10 +490,12 @@
 %{_libdir}/ruby/gems/2.3.0/gems/gem2rpm-%{version}
 %{_libdir}/ruby/gems/2.3.0/specifications/gem2rpm-%{version}.gemspec
 
+%if %{with docs}
 %files -n ruby2.3-rubygem-gem2rpm-doc
 %defattr(-,root,root,-)
 %doc %{_libdir}/ruby/gems/2.3.0/doc/gem2rpm-%{version}
 %endif
+%endif
 
 %if %{with ruby24}
 %package -n ruby2.4-rubygem-gem2rpm
@@ -536,10 +549,12 @@
 %{_libdir}/ruby/gems/2.4.0/gems/gem2rpm-%{version}
 %{_libdir}/ruby/gems/2.4.0/specifications/gem2rpm-%{version}.gemspec
 
+%if %{with docs}
 %files -n ruby2.4-rubygem-gem2rpm-doc
 %defattr(-,root,root,-)
 %doc %{_libdir}/ruby/gems/2.4.0/doc/gem2rpm-%{version}
 %endif
+%endif
 
 %if %{with ruby25}
 %package -n ruby2.5-rubygem-gem2rpm
@@ -593,10 +608,12 @@
 

commit 000product for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-07-02 10:39:50

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.4615 (New)


Package is "000product"

Tue Jul  2 10:39:50 2019 rev:1386 rq: version:unknown
Tue Jul  2 10:39:50 2019 rev:1387 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi: same change
openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
openSUSE-cd-mini-i586.kiwi: same change
openSUSE-cd-mini-x86_64.kiwi: same change
openSUSE-dvd5-dvd-i586.kiwi: same change
openSUSE-dvd5-dvd-x86_64.kiwi: same change
openSUSE-ftp-ftp-i586_x86_64.kiwi: same change
stub.kiwi: same change
++ openSUSE-Addon-NonOss.product ++
--- /var/tmp/diff_new_pack.6V9RzF/_old  2019-07-02 10:39:53.050717705 +0200
+++ /var/tmp/diff_new_pack.6V9RzF/_new  2019-07-02 10:39:53.050717705 +0200
@@ -4,7 +4,7 @@
  
 openSUSE
 openSUSE-Addon-NonOss
-20190701
+    20190702
 0 
 openSUSE NonOSS Addon
 non oss addon

++ openSUSE.product ++
--- /var/tmp/diff_new_pack.6V9RzF/_old  2019-07-02 10:39:53.074717742 +0200
+++ /var/tmp/diff_new_pack.6V9RzF/_new  2019-07-02 10:39:53.078717747 +0200
@@ -4,7 +4,7 @@
 
   openSUSE
   openSUSE
-  20190701
+  20190702
   0
 
   openSUSE




commit python-pyhibp for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package python-pyhibp for openSUSE:Factory 
checked in at 2019-07-02 10:39:46

Comparing /work/SRC/openSUSE:Factory/python-pyhibp (Old)
 and  /work/SRC/openSUSE:Factory/.python-pyhibp.new.4615 (New)


Package is "python-pyhibp"

Tue Jul  2 10:39:46 2019 rev:2 rq:712996 version:3.1.0

Changes:

--- /work/SRC/openSUSE:Factory/python-pyhibp/python-pyhibp.changes  
2019-02-01 11:45:44.184534553 +0100
+++ /work/SRC/openSUSE:Factory/.python-pyhibp.new.4615/python-pyhibp.changes
2019-07-02 10:39:47.186708781 +0200
@@ -1,0 +2,24 @@
+Mon Jul  1 12:34:45 UTC 2019 - Martin Hauke 
+
+- Update to version 3.1.0
+  * New function: pwnedpasswords.suffix_search(hash_prefix=prefix)
+was created in order to have a dedicated function return the
+suffix list.
+  * Function modification notice: pwnedpasswords.is_password_breached
+will be modified in an upcoming release to remove the ability
+to search for suffixes; use suffix_search(hash_prefix=prefix)
+instead. The parameter first_5_hash_chars will be removed as a
+consequence.
+  * Upcoming return type change for empty sets: For the functions
+get_account_breaches, get_all_breaches, get_single_breach, and
+get_pastes--all contained in the pyhibp module--when no items
+would be returned from the HIBP backend, the returned item will
+be an empty object matching the standard return type for the
+function, and not a Boolean False.
+This will occur when v4.0.0 is released. Return types will be:
+- get_account_breaches -> [] / list
+- get_all_breaches -> [] / list
+- get_single_breach -> {} / dict
+- get_pastes -> [] / list
+
+---

Old:

  pyhibp-3.0.0.tar.gz

New:

  pyhibp-3.1.0.tar.gz



Other differences:
--
++ python-pyhibp.spec ++
--- /var/tmp/diff_new_pack.YoruMU/_old  2019-07-02 10:39:47.642709476 +0200
+++ /var/tmp/diff_new_pack.YoruMU/_new  2019-07-02 10:39:47.646709481 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package python-pyHIBP
+# spec file for package python-pyhibp
 #
 # Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
@@ -12,12 +12,13 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pyhibp
-Version:3.0.0
+Version:3.1.0
 Release:0
 Summary:An interface to Troy Hunt's 'Have I Been Pwned' public API
 License:AGPL-3.0-or-later
@@ -50,7 +51,7 @@
 
 ### Tests need network access to https://haveibeenpwned.com
 #%%check
-#%%python_expand PYTHONPATH=%%{buildroot}%%{$python_sitelib} 
py.test-%%{$python_version}
+#%%pytest
 
 %files %{python_files}
 %license LICENSE

++ pyhibp-3.0.0.tar.gz -> pyhibp-3.1.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pyhibp-3.0.0/CHANGELOG.md 
new/pyhibp-3.1.0/CHANGELOG.md
--- old/pyhibp-3.0.0/CHANGELOG.md   2018-11-10 01:39:46.0 +0100
+++ new/pyhibp-3.1.0/CHANGELOG.md   2019-06-30 10:46:01.0 +0200
@@ -1,11 +1,34 @@
 pyHIBP Changelog
 
-v3.0.0 (UNRELEASED)
+v3.1.0 (In progress...)
+---
+- **New function**: ``pwnedpasswords.suffix_search(hash_prefix=prefix)`` was 
created in order to have a dedicated function
+  return the suffix list.
+- **Function modification notice**: ``pwnedpasswords.is_password_breached`` 
will be modified in an upcoming release to
+  remove the ability to search for suffixes; use 
``suffix_search(hash_prefix=prefix)`` instead. The parameter
+  ``first_5_hash_chars`` will be removed as a consequence.
+- **Upcoming return type change for empty sets**: For the functions 
``get_account_breaches``, ``get_all_breaches``,
+  ``get_single_breach``, and ``get_pastes``--all contained in the ``pyhibp`` 
module--when no items would be returned
+  from the HIBP backend, the returned item will be an empty object matching 
the standard return type for the function,
+  and not a Boolean ``False``. This will occur when ``v4.0.0`` is released. 
Return types will be:
+- ``get_account_breaches`` -> ``[] / list``
+- ``get_all_breaches`` -> ``[] / list``
+- ``get_single_breach`` -> ``{} / dict``
+- ``get_pastes`` -> ``[] / list``
+- As a reminder, Python 2.7 support will be dropped from support in the near 
future. This will occur at the same time
+  as the removal of the range search functionality available 

commit csound for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package csound for openSUSE:Factory checked 
in at 2019-07-02 10:39:47

Comparing /work/SRC/openSUSE:Factory/csound (Old)
 and  /work/SRC/openSUSE:Factory/.csound.new.4615 (New)


Package is "csound"

Tue Jul  2 10:39:47 2019 rev:29 rq:712999 version:6.12.2

Changes:

--- /work/SRC/openSUSE:Factory/csound/csound.changes2017-11-24 
10:55:10.874727534 +0100
+++ /work/SRC/openSUSE:Factory/.csound.new.4615/csound.changes  2019-07-02 
10:39:50.318713547 +0200
@@ -1,0 +2,33 @@
+Wed Jun 26 08:00:12 UTC 2019 - Dave Plater 
+
+- Renamed sndifo to csndinfo again to fix conflict with snd package
+  using csound-rename-sndinfo.patch this time.
+
+---
+Wed Jun  5 13:57:01 UTC 2019 - Dave Plater 
+
+- Added pre_checkin.sh to remove undistributable scansyn files from
+  the source tarball.
+- Relicenced to GPL-2.0-or-later AND BSD-3-Clause AND PostgreSQL
+  GPL-2.0 or later source file which relicenses the LGPL sources
+- Added COPYING_gpl2+.txt to licenses.
+
+---
+Tue Apr  9 07:29:47 UTC 2019 - Jan Engelhardt 
+
+- Update summaries.
+
+---
+Sat Apr  6 11:05:19 UTC 2019 - plater 
+
+- Update to version 6.12.2 and fix Factory build.
+- Remove obsolete patches:
+  csound-scons-on-py3.patch and csound-strncat-fix.patch
+- Added fluidsynth2.patch from Arch linux
+- Added csound-6.08-default-pulse.patch, csound-6.08-xdg-open.patch
+  from Fedora.
+- Now builds with cmake
+- For upstream changes see:
+  /usr/share/doc/packages/csound/Release_Notes/
+
+---

Old:

  Csound5.18.02.tar.gz
  csound-scons-on-py3.patch
  csound-strncat-fix.patch

New:

  COPYING_gpl2+.txt
  csound-6.08-default-pulse.patch
  csound-6.08-xdg-open.patch
  csound-6.12.2-distibutable.tar.xz
  csound-rename-sndinfo.patch
  fluidsynth2.patch
  pre_checkin.sh



Other differences:
--
++ csound.spec ++
--- /var/tmp/diff_new_pack.RKtb3c/_old  2019-07-02 10:39:51.190714874 +0200
+++ /var/tmp/diff_new_pack.RKtb3c/_new  2019-07-02 10:39:51.194714880 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package csound
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,103 +12,206 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
-%define support_fltk 0
+%define py3version %(pkg-config python3 --modversion)
+%define support_fltk 1
+%bcond_with python
+
+%if 0%{?suse_version} > 1500
+%bcond_without java
+%else
+%bcond_with java
+%endif
+
+%define maj 6
+%define min 0
 
 Name:   csound
+Version:6.12.2
+Release:0
+Summary:Computer Sound Synthesis and Composition Program
+License:GPL-2.0-or-later AND BSD-3-Clause AND PostgreSQL
+Group:  Productivity/Multimedia/Sound/Utilities
+Url:http://www.csounds.com
+#Source: 
https://github.com/%%{name}/%%{name}/archive/%%{version}.tar.gz#/%%{name}-%%{version}.tar.gz
+Source0:%{name}-%{version}-distibutable.tar.xz
+Source1:README.SUSE
+Source2:COPYING_gpl2+.txt
+#Update and remove undistributable files from the sources and repack with this 
script
+#Usage = sh pre_checkin.sh
+Source3:pre_checkin.sh
+# Default to using pulseaudio instead of portaudio
+Patch2: csound-6.08-default-pulse.patch
+# Use xdg-open to open a browser to view the manual
+Patch4: csound-6.08-xdg-open.patch
+Patch6: fluidsynth2.patch
+Patch7: csound-rename-sndinfo.patch
 BuildRequires:  alsa-devel
 BuildRequires:  bison
+BuildRequires:  cmake
+BuildRequires:  doxygen
+BuildRequires:  eigen3-devel
 BuildRequires:  fdupes
 BuildRequires:  flex
 BuildRequires:  fluidsynth-devel
 BuildRequires:  gcc-c++
 BuildRequires:  jack-devel
+%if %{with java}
+BuildRequires:  java-devel-openjdk
+%endif
+BuildRequires:  libboost_atomic-devel
+BuildRequires:  libboost_filesystem-devel
+BuildRequires:  libboost_locale-devel
+BuildRequires:  libboost_regex-devel
+BuildRequires:  libboost_thread-devel
 BuildRequires:  liblo-devel
 BuildRequires:  libsndfile-devel
+BuildRequires:  lua-devel
 BuildRequires:  portaudio-devel
-BuildRequires:  python-devel

commit 000product for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-07-02 10:39:51

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.4615 (New)


Package is "000product"

Tue Jul  2 10:39:51 2019 rev:1388 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi: same change
openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
openSUSE-cd-mini-i586.kiwi: same change
openSUSE-cd-mini-x86_64.kiwi: same change
openSUSE-dvd5-dvd-i586.kiwi: same change
openSUSE-dvd5-dvd-x86_64.kiwi: same change
openSUSE-ftp-ftp-i586_x86_64.kiwi: same change
stub.kiwi: same change
++ openSUSE-MicroOS.product ++
--- /var/tmp/diff_new_pack.2nMeXo/_old  2019-07-02 10:39:55.534721485 +0200
+++ /var/tmp/diff_new_pack.2nMeXo/_new  2019-07-02 10:39:55.538721491 +0200
@@ -6,7 +6,7 @@
   openSUSE-MicroOS
   openSUSE-MicroOS-release
   
-  20190701
+  20190702
   
   0
   openSUSE-MicroOS




commit perl-PDF-API2 for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package perl-PDF-API2 for openSUSE:Factory 
checked in at 2019-07-02 10:39:37

Comparing /work/SRC/openSUSE:Factory/perl-PDF-API2 (Old)
 and  /work/SRC/openSUSE:Factory/.perl-PDF-API2.new.4615 (New)


Package is "perl-PDF-API2"

Tue Jul  2 10:39:37 2019 rev:16 rq:712936 version:2.034

Changes:

--- /work/SRC/openSUSE:Factory/perl-PDF-API2/perl-PDF-API2.changes  
2017-07-21 22:47:43.838850957 +0200
+++ /work/SRC/openSUSE:Factory/.perl-PDF-API2.new.4615/perl-PDF-API2.changes
2019-07-02 10:39:40.662698853 +0200
@@ -1,0 +2,36 @@
+Sun Jun 30 05:21:25 UTC 2019 - Stephan Kulow 
+
+- updated to 2.034
+   see /usr/share/doc/packages/perl-PDF-API2/Changes
+
+  2.034 2019-06-29
+  
+  - SUPPORTED PERL VERSIONS: Starting with this release, PDF::API2 will
+support major Perl versions released in the past six years, plus the 
major
+release before that one.  This should provide backward compatibility 
for
+the life of most LTS server distributions, while eliminating the need 
to
+troubleshoot warnings and bugs that only show up in 
increasingly-ancient
+versions of Perl.
+  
+For this release, it means that the minimum supported Perl is 5.18, 
which
+was first released on 2013-05-18.
+  
+  - Add support for cross-reference streams using 64-bit field widths.
+  
+  - When the utf8 flag is set for a PDF string, automatically encode it as
+UCS-16BE instead of requiring a separate flag to be set in the PDF 
object.
+This resolves [RT #33497] and [RT #117031] in addition to making the 
code
+easier to maintain.
+  
+  - [RT #126274] Fix alignment when using UniFont with text_center or
+text_right when all characters are in the same block.
+  
+  - [RT #121911] Fix adding pages to a document structure with nested Pages
+elements.  This included a fairly substantial rewrite of the relevant
+code, so please report any new bugs related to adding pages (report and
+troubleshooting by Vadim Repin).
+  
+  - Renamed pdfile() to pdf_file() in PDF::API2::Annotation and
+PDF::API2::Outline.  The old name continues to work, but is deprecated.
+
+---

Old:

  PDF-API2-2.033.tar.gz

New:

  PDF-API2-2.034.tar.gz



Other differences:
--
++ perl-PDF-API2.spec ++
--- /var/tmp/diff_new_pack.qV0T7k/_old  2019-07-02 10:39:41.394699967 +0200
+++ /var/tmp/diff_new_pack.qV0T7k/_new  2019-07-02 10:39:41.394699967 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-PDF-API2
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,18 +12,18 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   perl-PDF-API2
-Version:2.033
+Version:2.034
 Release:0
 %define cpan_name PDF-API2
 Summary:Facilitates the creation and modification of PDF files
-License:LGPL-2.1+
+License:LGPL-2.1-or-later
 Group:  Development/Libraries/Perl
-Url:http://search.cpan.org/dist/PDF-API2/
+Url:https://metacpan.org/release/%{cpan_name}
 Source0:
https://cpan.metacpan.org/authors/id/S/SS/SSIMMS/%{cpan_name}-%{version}.tar.gz
 Source1:cpanspec.yml
 BuildArch:  noarch
@@ -45,11 +45,11 @@
 %setup -q -n %{cpan_name}-%{version}
 
 %build
-%{__perl} Makefile.PL INSTALLDIRS=vendor
-%{__make} %{?_smp_mflags}
+perl Makefile.PL INSTALLDIRS=vendor
+make %{?_smp_mflags}
 
 %check
-%{__make} test
+make test
 
 %install
 %perl_make_install
@@ -58,7 +58,7 @@
 
 %files -f %{name}.files
 %defattr(-,root,root,755)
-%doc Changes PATENTS README
+%doc Changes contrib PATENTS README
 %license LICENSE
 
 %changelog

++ PDF-API2-2.033.tar.gz -> PDF-API2-2.034.tar.gz ++
 6008 lines of diff (skipped)




commit perl-Mojolicious-Plugin-NYTProf for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package perl-Mojolicious-Plugin-NYTProf for 
openSUSE:Factory checked in at 2019-07-02 10:39:33

Comparing /work/SRC/openSUSE:Factory/perl-Mojolicious-Plugin-NYTProf (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Mojolicious-Plugin-NYTProf.new.4615 
(New)


Package is "perl-Mojolicious-Plugin-NYTProf"

Tue Jul  2 10:39:33 2019 rev:4 rq:712934 version:0.22

Changes:

--- 
/work/SRC/openSUSE:Factory/perl-Mojolicious-Plugin-NYTProf/perl-Mojolicious-Plugin-NYTProf.changes
  2018-10-15 09:42:28.983426793 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Mojolicious-Plugin-NYTProf.new.4615/perl-Mojolicious-Plugin-NYTProf.changes
2019-07-02 10:39:34.706689790 +0200
@@ -1,0 +2,11 @@
+Mon Jul  1 18:06:02 UTC 2019 - Stephan Kulow 
+
+- updated to 0.22
+   see /usr/share/doc/packages/perl-Mojolicious-Plugin-NYTProf/Changes
+
+  0.22 2019-07-01
+  - Bump Mojolicious version requirement to 8.00
+  - Add nonblocking example to ExampleApp
+  - Document caveats with using async code with profiling
+
+---

Old:

  Mojolicious-Plugin-NYTProf-0.21.tar.gz

New:

  Mojolicious-Plugin-NYTProf-0.22.tar.gz
  cpanspec.yml



Other differences:
--
++ perl-Mojolicious-Plugin-NYTProf.spec ++
--- /var/tmp/diff_new_pack.pXHtZY/_old  2019-07-02 10:39:35.350690770 +0200
+++ /var/tmp/diff_new_pack.pXHtZY/_new  2019-07-02 10:39:35.354690776 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Mojolicious-Plugin-NYTProf
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,12 +12,12 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   perl-Mojolicious-Plugin-NYTProf
-Version:0.21
+Version:0.22
 Release:0
 %define cpan_name Mojolicious-Plugin-NYTProf
 Summary:Auto handling of Devel::NYTProf in your Mojolicious app
@@ -25,23 +25,24 @@
 Group:  Development/Libraries/Perl
 Url:https://metacpan.org/release/%{cpan_name}
 Source0:
https://cpan.metacpan.org/authors/id/L/LE/LEEJO/%{cpan_name}-%{version}.tar.gz
+Source1:cpanspec.yml
 BuildArch:  noarch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl
 BuildRequires:  perl-macros
 BuildRequires:  perl(Algorithm::Combinatorics) >= 0.27
-BuildRequires:  perl(Devel::NYTProf) >= 5.07
+BuildRequires:  perl(Devel::NYTProf) >= 6.06
 BuildRequires:  perl(File::Spec::Functions) >= 3.30
 BuildRequires:  perl(File::Temp) >= 0.22
 BuildRequires:  perl(File::Which) >= 1.09
-BuildRequires:  perl(Mojolicious) >= 6.00
+BuildRequires:  perl(Mojolicious) >= 8.00
 BuildRequires:  perl(Test::Exception) >= 0.32
 BuildRequires:  perl(Time::HiRes) >= 1.9719
-Requires:   perl(Devel::NYTProf) >= 5.07
+Requires:   perl(Devel::NYTProf) >= 6.06
 Requires:   perl(File::Spec::Functions) >= 3.30
 Requires:   perl(File::Temp) >= 0.22
 Requires:   perl(File::Which) >= 1.09
-Requires:   perl(Mojolicious) >= 6.00
+Requires:   perl(Mojolicious) >= 8.00
 Requires:   perl(Time::HiRes) >= 1.9719
 %{perl_requires}
 
@@ -54,18 +55,15 @@
 %setup -q -n %{cpan_name}-%{version}
 
 %build
-%{__perl} Makefile.PL INSTALLDIRS=vendor
-%{__make} %{?_smp_mflags}
+perl Makefile.PL INSTALLDIRS=vendor
+make %{?_smp_mflags}
 
 %check
-%{__make} test
+make test
 
 %install
 %perl_make_install
 %perl_process_packlist
-if [ -f %{buildroot}/%{perl_vendorlib}/Mojolicious/Plugin/README.pod ]; then
-mv %{buildroot}/%{perl_vendorlib}/Mojolicious/Plugin/README{,-NYTProf}.pod
-fi
 %perl_gen_filelist
 
 %files -f %{name}.files

++ Mojolicious-Plugin-NYTProf-0.21.tar.gz -> 
Mojolicious-Plugin-NYTProf-0.22.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-Plugin-NYTProf-0.21/Changes 
new/Mojolicious-Plugin-NYTProf-0.22/Changes
--- old/Mojolicious-Plugin-NYTProf-0.21/Changes 2018-10-01 14:28:37.0 
+0200
+++ new/Mojolicious-Plugin-NYTProf-0.22/Changes 2019-06-28 09:43:58.0 
+0200
@@ -1,5 +1,10 @@
 Revision history for Mojolicious-Plugin-NYTProf
 
+0.22 2019-07-01
+- Bump Mojolicious version requirement to 8.00
+- Add nonblocking example to ExampleApp
+- Document caveats with 

commit php7-redis for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package php7-redis for openSUSE:Factory 
checked in at 2019-07-02 10:39:44

Comparing /work/SRC/openSUSE:Factory/php7-redis (Old)
 and  /work/SRC/openSUSE:Factory/.php7-redis.new.4615 (New)


Package is "php7-redis"

Tue Jul  2 10:39:44 2019 rev:15 rq:712984 version:5.0.0

Changes:

--- /work/SRC/openSUSE:Factory/php7-redis/php7-redis.changes2019-03-18 
10:38:33.575488189 +0100
+++ /work/SRC/openSUSE:Factory/.php7-redis.new.4615/php7-redis.changes  
2019-07-02 10:39:46.162707223 +0200
@@ -1,0 +2,31 @@
+Tue Jul  2 06:31:59 UTC 2019 - Johannes Weberhofer 
+
+- Update to 5.0.0
+  This release contains important improvements and breaking changes.
+  The most interesting are: drop PHP5 support, RedisCluster slots caching,
+  JSON and msgpack serializers, soft deprecation of non-Redis commands.
+
+  * Remove HAVE_SPL
+  * Allow compilation without JSON serialization enabled and fixes for
+deprecated helper methods.
+  * Enable connection pooling by default 
+  * Soft deprecate methods that aren't actually Redis commands
+  * Enable pooling for cluster slave nodes
+  * xInfo response format
+  * Make the XREADGROUP optional COUNT and BLOCK arguments nullable
+  * Allow PING to take an optional argument
+  * Allow ZRANGE to be called either with `true` or `['withscores' => true]`
+  * Allow to specify server address as schema://host
+  * Allow persistent_id to be passed as NULL with strict_types enabled
+  * Add server address to exception message
+  * Adds OPT_REPLY_LITERAL for rawCommand and EVAL
+  * JSON serializer
+  * Add support for STREAM to the type command
+  * Fix TypeError when using built-in constants in `setOption`
+  * Handle references in MGET
+  * msgpack serializer
+  * Add Cluster slots caching
+  * Drop PHP5 support
+  * Documentation improvements
+
+---

Old:

  redis-4.3.0.tgz

New:

  redis-5.0.0.tgz



Other differences:
--
++ php7-redis.spec ++
--- /var/tmp/diff_new_pack.oEqOQn/_old  2019-07-02 10:39:46.742708105 +0200
+++ /var/tmp/diff_new_pack.oEqOQn/_new  2019-07-02 10:39:46.746708112 +0200
@@ -12,14 +12,14 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 %define php_namephp7
 %define pkg_nameredis
 Name:   %{php_name}-%{pkg_name}
-Version:4.3.0
+Version:5.0.0
 Release:0
 Summary:API for communicating with Redis servers
 License:PHP-3.01

++ redis-4.3.0.tgz -> redis-5.0.0.tgz ++
 74450 lines of diff (skipped)




commit kakoune for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package kakoune for openSUSE:Factory checked 
in at 2019-07-02 10:39:42

Comparing /work/SRC/openSUSE:Factory/kakoune (Old)
 and  /work/SRC/openSUSE:Factory/.kakoune.new.4615 (New)


Package is "kakoune"

Tue Jul  2 10:39:42 2019 rev:13 rq:712982 version:2019.07.01

Changes:

--- /work/SRC/openSUSE:Factory/kakoune/kakoune.changes  2019-01-24 
14:13:17.975370467 +0100
+++ /work/SRC/openSUSE:Factory/.kakoune.new.4615/kakoune.changes
2019-07-02 10:39:44.538704752 +0200
@@ -1,0 +2,27 @@
+Tue Jul  2 06:56:50 UTC 2019 - mvet...@suse.com
+
+- Update to 2018.07.01:
+  * Re-organized bundled script files directory hierarchy.
+  * Introduced helpers to write/read from file in scripts with
+%file{...} expansion and echo -to-file .
+  * Added ClientCreate and ClientClose hooks
+  * edit -scratch with no buffer name will create a new
+scratch buffer with a unique autogenerated name.
+  * info -placement is now info -style and supports
+menu and modal additional styles.
+  * completions option type docstring are now arbitrary
+kakoune commands that are run on item select.
+  * InsertCompletionSelect hook has been removed as
+completions commands now provides a similar feature.
+  * Introduced a module system using the provide-module and
+require-module commands that allows for lazily loading language
+support files with dependency resolution.
+  * Added a new hook ModuleLoaded which is run after a module is
+loaded, allowing for module specific configuration.
+  * Shell quoting of lists is not automatic anymore, $kak_quoted_...
+makes it opt-in, and works for all option types.
+  * Lower case function key syntax is not accepted anymore,
+ should be converted to .
+- Change to gnu++17 standard
+
+---

Old:

  kakoune-2019.01.20.tar.bz2

New:

  kakoune-2019.07.01.tar.bz2



Other differences:
--
++ kakoune.spec ++
--- /var/tmp/diff_new_pack.MTVxsK/_old  2019-07-02 10:39:45.374706024 +0200
+++ /var/tmp/diff_new_pack.MTVxsK/_new  2019-07-02 10:39:45.378706030 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   kakoune
-Version:2019.01.20
+Version:2019.07.01
 Release:0
 Summary:A code editor heavily inspired by Vim
 License:Unlicense
@@ -48,7 +48,7 @@
 %if 0%{?suse_version} < 1320
 export CXX=g++-5
 %endif
-make %{?_smp_mflags} CXXFLAGS="%{optflags} -std=gnu++14"
+make %{?_smp_mflags} CXXFLAGS="%{optflags} -std=gnu++17"
 
 %install
 make %{?_smp_mflags} install PREFIX=%{buildroot}%{_prefix}

++ kakoune-2019.01.20.tar.bz2 -> kakoune-2019.07.01.tar.bz2 ++
 28159 lines of diff (skipped)




commit vapoursynth for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package vapoursynth for openSUSE:Factory 
checked in at 2019-07-02 10:39:21

Comparing /work/SRC/openSUSE:Factory/vapoursynth (Old)
 and  /work/SRC/openSUSE:Factory/.vapoursynth.new.4615 (New)


Package is "vapoursynth"

Tue Jul  2 10:39:21 2019 rev:6 rq:712894 version:46

Changes:

--- /work/SRC/openSUSE:Factory/vapoursynth/vapoursynth.changes  2019-01-08 
12:31:31.056073505 +0100
+++ /work/SRC/openSUSE:Factory/.vapoursynth.new.4615/vapoursynth.changes
2019-07-02 10:39:24.966674968 +0200
@@ -1,0 +2,19 @@
+Mon Jul  1 11:21:05 UTC 2019 - mvet...@suse.com
+
+- Update to version 46: 
+  * added a fallback to how the appdata path is retrieved which
+works even if %USERPROFILE% isn't set
+  * the default number of threads used is now based on the process
+affinity on windows, linux and bsd
+  * added an option to vspipe to make it not modify the current
+working directory
+  * added a better equality check for the Format class in python
+  * fixed doubleweave sometimes using the opposite field order (dubhater)
+  * fixed broken output when stride wasn't equal to width in the
+python output function (stuxcrystal)
+  * relaxed mask clip requirements in maskedmerge (dubhater)
+  * fixed overflow with int16 in maskedmerge (dubhater)
+  * fixed swapped fields in doubleweave (dubhater)
+  * fixed selectevery breaking and leaking when there are no frames to return
+
+---

Old:

  vapoursynth-R45.tar.gz

New:

  vapoursynth-R46.tar.gz



Other differences:
--
++ vapoursynth.spec ++
--- /var/tmp/diff_new_pack.AAnR9K/_old  2019-07-02 10:39:25.630675979 +0200
+++ /var/tmp/diff_new_pack.AAnR9K/_new  2019-07-02 10:39:25.630675979 +0200
@@ -12,12 +12,12 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via https://bugs.opensuse.org/
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
 
 Name:   vapoursynth
-Version:45
+Version:46
 Release:0
 Summary:A video processing framework
 License:LGPL-2.1-only AND OFL-1.1

++ vapoursynth-R45.tar.gz -> vapoursynth-R46.tar.gz ++
 2027 lines of diff (skipped)




commit etherape for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package etherape for openSUSE:Factory 
checked in at 2019-07-02 10:39:31

Comparing /work/SRC/openSUSE:Factory/etherape (Old)
 and  /work/SRC/openSUSE:Factory/.etherape.new.4615 (New)


Package is "etherape"

Tue Jul  2 10:39:31 2019 rev:31 rq:712931 version:0.9.18

Changes:

--- /work/SRC/openSUSE:Factory/etherape/etherape.changes2018-05-29 
10:32:21.236327549 +0200
+++ /work/SRC/openSUSE:Factory/.etherape.new.4615/etherape.changes  
2019-07-02 10:39:33.558688043 +0200
@@ -1,0 +2,8 @@
+Mon Jul  1 11:37:17 UTC 2019 - Wolfgang Frisch 
+
+- Update to version 0.9.18:
+  * EtherApe now is a pure GTK 3 application.
+- Changes from version 0.9.17:
+  * Replaced gnome-canvas with canvas supplied by GooCanvas.
+
+---

Old:

  etherape-0.9.17.tar.gz

New:

  etherape-0.9.18.tar.gz



Other differences:
--
++ etherape.spec ++
--- /var/tmp/diff_new_pack.vQSoKg/_old  2019-07-02 10:39:34.286689152 +0200
+++ /var/tmp/diff_new_pack.vQSoKg/_new  2019-07-02 10:39:34.290689157 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package etherape
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,12 +12,12 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   etherape
-Version:0.9.17
+Version:0.9.18
 Release:0
 Summary:A Graphical Network Monitor
 License:GPL-2.0-or-later
@@ -27,14 +27,15 @@
 Patch0: etherape-0.9.12-desktop.patch
 BuildRequires:  docbook_4
 BuildRequires:  fdupes
+BuildRequires:  goocanvas-devel
 BuildRequires:  libpcap-devel
 BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
 BuildRequires:  yelp-tools
-BuildRequires:  pkgconfig(glib-2.0)
-BuildRequires:  pkgconfig(libglade-2.0)
-BuildRequires:  pkgconfig(libgnomecanvas-2.0)
 BuildRequires:  pkgconfig(popt)
+%if 0%{?is_opensuse}
+BuildRequires:  autoconf-archive
+%endif
 Requires(post): update-desktop-files
 Requires(postun): update-desktop-files
 Recommends: %{name}-lang

++ etherape-0.9.17.tar.gz -> etherape-0.9.18.tar.gz ++
 21997 lines of diff (skipped)




commit matomo for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package matomo for openSUSE:Factory checked 
in at 2019-07-02 10:39:39

Comparing /work/SRC/openSUSE:Factory/matomo (Old)
 and  /work/SRC/openSUSE:Factory/.matomo.new.4615 (New)


Package is "matomo"

Tue Jul  2 10:39:39 2019 rev:14 rq:712941 version:3.10.0

Changes:

--- /work/SRC/openSUSE:Factory/matomo/matomo.changes2019-03-22 
15:12:26.401291015 +0100
+++ /work/SRC/openSUSE:Factory/.matomo.new.4615/matomo.changes  2019-07-02 
10:39:42.998702408 +0200
@@ -1,0 +2,30 @@
+Tue Jul  2 05:49:07 UTC 2019 - ec...@opensuse.org
+
+- Update to 3.10.0
+  * Breaking Changes
+- When giving a user superuser access through the 
+  UsersManager.setSuperUserAccess API, a new parameter 
+  passwordConfirmation needs to be sent along with the request
+  containing the current password of the user issuing the API 
+  request.
+- Website referrer URLs are now detected using domain only 
+  instead of domain and path. This means if you have two 
+  different websites on the same domain, but different paths,
+  and a visitor visits from one to the other, it won't have 
+  a referrer website set.
+- Custom Dimensions values set with setCustomDimension are now 
+  URL encoded (they previously weren't). If you were manually
+  URL encoding the custom dimension values before calling 
+  setCustomDimension, your custom dimension values appearing in
+  reports and Visits log/Visitor profile may now be double URL
+  encoded. To solve the double encoding issue, you can remove 
+  your URL encoding and trust that Matomo JavaScript Tracker 
+  will URL encode the values correctly.
+  * New APIs
+- A new tracker method ping has been added to send a ping 
+  request manually instead of using the heart beat timer.
+- Added new event ViewDataTable.configure.end, triggered after
+  view configuration properties have been overwritten by saved
+  settings and query parameters.
+
+---

Old:

  matomo-3.9.1.tar.gz

New:

  matomo-3.10.0.tar.gz



Other differences:
--
++ matomo.spec ++
--- /var/tmp/diff_new_pack.o7z1K5/_old  2019-07-02 10:39:43.958703869 +0200
+++ /var/tmp/diff_new_pack.o7z1K5/_new  2019-07-02 10:39:43.966703881 +0200
@@ -31,7 +31,7 @@
 %endif
 
 Name:   matomo
-Version:3.9.1
+Version:3.10.0
 Release:0
 Summary:Web analytics platform
 License:GPL-3.0-or-later

++ matomo-3.9.1.tar.gz -> matomo-3.10.0.tar.gz ++
/work/SRC/openSUSE:Factory/matomo/matomo-3.9.1.tar.gz 
/work/SRC/openSUSE:Factory/.matomo.new.4615/matomo-3.10.0.tar.gz differ: char 
5, line 1




commit python-neovim-remote for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package python-neovim-remote for 
openSUSE:Factory checked in at 2019-07-02 10:39:25

Comparing /work/SRC/openSUSE:Factory/python-neovim-remote (Old)
 and  /work/SRC/openSUSE:Factory/.python-neovim-remote.new.4615 (New)


Package is "python-neovim-remote"

Tue Jul  2 10:39:25 2019 rev:3 rq:712896 version:2.1.7

Changes:

--- 
/work/SRC/openSUSE:Factory/python-neovim-remote/python-neovim-remote.changes
2019-04-30 13:05:30.593928640 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-neovim-remote.new.4615/python-neovim-remote.changes
  2019-07-02 10:39:25.930676436 +0200
@@ -1,0 +2,5 @@
+Sat Jun 29 16:35:45 CEST 2019 - Matej Cepl 
+
+- Add missing requirement python-psutil.
+
+---



Other differences:
--
++ python-neovim-remote.spec ++
--- /var/tmp/diff_new_pack.Xk5K8I/_old  2019-07-02 10:39:26.466677251 +0200
+++ /var/tmp/diff_new_pack.Xk5K8I/_new  2019-07-02 10:39:26.466677251 +0200
@@ -33,6 +33,7 @@
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
+Requires:   python-psutil
 BuildArch:  noarch
 
 %python_subpackages




commit rdesktop for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package rdesktop for openSUSE:Factory 
checked in at 2019-07-02 10:39:04

Comparing /work/SRC/openSUSE:Factory/rdesktop (Old)
 and  /work/SRC/openSUSE:Factory/.rdesktop.new.4615 (New)


Package is "rdesktop"

Tue Jul  2 10:39:04 2019 rev:40 rq:712854 version:1.8.6

Changes:

--- /work/SRC/openSUSE:Factory/rdesktop/rdesktop.changes2019-06-19 
21:14:36.010874740 +0200
+++ /work/SRC/openSUSE:Factory/.rdesktop.new.4615/rdesktop.changes  
2019-07-02 10:39:08.302649610 +0200
@@ -1,0 +2,6 @@
+Mon Jul  1 13:03:04 UTC 2019 - ch...@computersalat.de
+
+- update changes file
+  * add missing info about bugzilla 1121448
+
+---
@@ -30 +36 @@
-- update to 1.8.4
+- update to 1.8.4 (fix for boo#1121448)



Other differences:
--



commit rofi for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package rofi for openSUSE:Factory checked in 
at 2019-07-02 10:39:10

Comparing /work/SRC/openSUSE:Factory/rofi (Old)
 and  /work/SRC/openSUSE:Factory/.rofi.new.4615 (New)


Package is "rofi"

Tue Jul  2 10:39:10 2019 rev:16 rq:712862 version:1.5.4

Changes:

--- /work/SRC/openSUSE:Factory/rofi/rofi.changes2019-06-24 
21:54:02.468137440 +0200
+++ /work/SRC/openSUSE:Factory/.rofi.new.4615/rofi.changes  2019-07-02 
10:39:11.406654334 +0200
@@ -1,0 +2,6 @@
+Mon Jul  1 11:12:09 UTC 2019 - mvet...@suse.com
+
+- Update to version 1.5.4:
+  * Fix crash in SSH dialog
+
+---

Old:

  rofi-1.5.3.tar.xz

New:

  rofi-1.5.4.tar.xz



Other differences:
--
++ rofi.spec ++
--- /var/tmp/diff_new_pack.PVTDak/_old  2019-07-02 10:39:11.974655198 +0200
+++ /var/tmp/diff_new_pack.PVTDak/_new  2019-07-02 10:39:11.974655198 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   rofi
-Version:1.5.3
+Version:1.5.4
 Release:0
 Summary:A window switcher, run dialog and dmenu replacement
 License:MIT

++ rofi-1.5.3.tar.xz -> rofi-1.5.4.tar.xz ++
 8813 lines of diff (skipped)




commit openSUSE-Tumbleweed-Vagrant for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package openSUSE-Tumbleweed-Vagrant for 
openSUSE:Factory checked in at 2019-07-02 10:39:17

Comparing /work/SRC/openSUSE:Factory/openSUSE-Tumbleweed-Vagrant (Old)
 and  /work/SRC/openSUSE:Factory/.openSUSE-Tumbleweed-Vagrant.new.4615 (New)


Package is "openSUSE-Tumbleweed-Vagrant"

Tue Jul  2 10:39:17 2019 rev:5 rq:712881 version:1.0

Changes:

--- /work/SRC/openSUSE:Factory/openSUSE-Tumbleweed-Vagrant/Tumbleweed.changes   
2019-06-28 16:37:02.318879075 +0200
+++ 
/work/SRC/openSUSE:Factory/.openSUSE-Tumbleweed-Vagrant.new.4615/Tumbleweed.changes
 2019-07-02 10:39:18.55229 +0200
@@ -1,0 +2,5 @@
+Wed Jun 26 12:53:08 UTC 2019 - Guillaume GARDET 
+
+- Enable build of libvirt flavor for aarch64
+
+---



Other differences:
--
++ Tumbleweed.kiwi ++
--- /var/tmp/diff_new_pack.rzlPmP/_old  2019-07-02 10:39:19.34416 +0200
+++ /var/tmp/diff_new_pack.rzlPmP/_new  2019-07-02 10:39:19.34416 +0200
@@ -2,7 +2,7 @@
 
 
 
-
+
 
 
 
@@ -14,7 +14,7 @@
 
 
 
-
+
 
 
 1.0
@@ -28,7 +28,7 @@
 openSUSE
 
 
-
+
 
 42
 
@@ -59,7 +59,8 @@
 
 
 
-
+
+
 
 
 




commit conky for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package conky for openSUSE:Factory checked 
in at 2019-07-02 10:39:29

Comparing /work/SRC/openSUSE:Factory/conky (Old)
 and  /work/SRC/openSUSE:Factory/.conky.new.4615 (New)


Package is "conky"

Tue Jul  2 10:39:29 2019 rev:25 rq:712925 version:1.11.4

Changes:

--- /work/SRC/openSUSE:Factory/conky/conky.changes  2019-06-24 
21:54:03.712138397 +0200
+++ /work/SRC/openSUSE:Factory/.conky.new.4615/conky.changes2019-07-02 
10:39:31.850685444 +0200
@@ -1,0 +2,5 @@
+Fri Jun 28 09:31:44 UTC 2019 - Dead Mozay 
+
+- Add conky-memory-leak-fix.patch Fixes a memory leak in Conky 
+
+---

New:

  conky-memory-leak-fix.patch



Other differences:
--
++ conky.spec ++
--- /var/tmp/diff_new_pack.dGcWy2/_old  2019-07-02 10:39:32.470686388 +0200
+++ /var/tmp/diff_new_pack.dGcWy2/_new  2019-07-02 10:39:32.470686388 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -37,6 +37,7 @@
 Source3:README.SUSE
 Patch1: conky-1.10.1-avoid-git.patch
 Patch2: conky.timestamp.patch
+Patch3: conky-memory-leak-fix.patch
 BuildRequires:  cmake
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  docbook2x
@@ -50,6 +51,7 @@
 BuildRequires:  libxslt-tools
 BuildRequires:  lua53-devel
 BuildRequires:  ncurses-devel
+BuildRequires:  ninja
 BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(glib-2.0)
@@ -138,7 +140,7 @@
 %autopatch -p1
 
 %build
-%cmake \
+%cmake -G Ninja \
-DBUILD_APCUPSD=ON \
-DBUILD_ARGB=ON \
 %if %{with audacious}
@@ -205,7 +207,7 @@
-DOWN_WINDOW=ON \
-DBUILD_XMMS2=OFF
 
-%cmake_build
+%ninja_build
 
 # build doc
 cd ../doc
@@ -224,7 +226,7 @@
 gzip conky.1
 
 %install
-%cmake_install
+%ninja_install -C build
 
 # not doc
 rm -rf %{buildroot}%{_datadir}/doc/%{name}-%{version}

++ conky-memory-leak-fix.patch ++
diff --git a/src/specials.cc b/src/specials.cc
index 70ac491b..3ddcf505 100644
--- a/src/specials.cc
+++ b/src/specials.cc
@@ -508,7 +508,7 @@ graph_buf_end:
 }
 
 double *copy_graph(double *original_graph, int graph_width) {
-  double *new_graph = new double[graph_width];
+  double *new_graph = static_cast(malloc(graph_width * 
sizeof(double)));
 
   memcpy(new_graph, original_graph, graph_width * sizeof(double));
 
@@ -517,7 +517,7 @@ double *copy_graph(double *original_graph, int graph_width) 
{
 
 double *retrieve_graph(int graph_id, int graph_width) {
   if (graphs.find(graph_id) == graphs.end()) {
-return new double[graph_width];
+return static_cast(calloc(1, graph_width * sizeof(double)));
   } else {
 return copy_graph(graphs[graph_id], graph_width);
   }
@@ -527,7 +527,10 @@ void store_graph(int graph_id, struct special_t *s) {
   if (s->graph == nullptr) {
 graphs[graph_id] = nullptr;
   } else {
-graphs[graph_id] = copy_graph(s->graph, s->graph_width);
+if (graphs.find(graph_id)!=graphs.end()) {
+  free(graphs[graph_id]);
+}
+graphs[graph_id] = s->graph;
   }
 }
 
@@ -572,6 +575,7 @@ void new_graph(struct text_object *obj, char *buf, int 
buf_max_size,
 }
 s->graph = graph;
 s->graph_allocated = s->graph_width;
+graphs[g->id] = graph;
   }
   s->height = g->height;
   s->first_colour = adjust_colours(g->first_colour);



commit perl-Test-Compile for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package perl-Test-Compile for 
openSUSE:Factory checked in at 2019-07-02 10:39:34

Comparing /work/SRC/openSUSE:Factory/perl-Test-Compile (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Test-Compile.new.4615 (New)


Package is "perl-Test-Compile"

Tue Jul  2 10:39:34 2019 rev:7 rq:712935 version:2.1.1

Changes:

--- /work/SRC/openSUSE:Factory/perl-Test-Compile/perl-Test-Compile.changes  
2019-06-28 16:37:01.774878275 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Test-Compile.new.4615/perl-Test-Compile.changes
2019-07-02 10:39:35.706691312 +0200
@@ -1,0 +2,6 @@
+Mon Jul  1 05:30:35 UTC 2019 - Stephan Kulow 
+
+- updated to 2.1.1
+   see /usr/share/doc/packages/perl-Test-Compile/Changes
+
+---

Old:

  Test-Compile-v2.1.0.tar.gz

New:

  Test-Compile-v2.1.1.tar.gz



Other differences:
--
++ perl-Test-Compile.spec ++
--- /var/tmp/diff_new_pack.9gztmX/_old  2019-07-02 10:39:36.966693229 +0200
+++ /var/tmp/diff_new_pack.9gztmX/_new  2019-07-02 10:39:36.970693235 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Test-Compile
-Version:2.1.0
+Version:2.1.1
 Release:0
 %define cpan_name Test-Compile
 Summary:Check whether Perl files compile correctly

++ Test-Compile-v2.1.0.tar.gz -> Test-Compile-v2.1.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-Compile-v2.1.0/Changes 
new/Test-Compile-v2.1.1/Changes
--- old/Test-Compile-v2.1.0/Changes 2019-06-27 12:26:28.0 +0200
+++ new/Test-Compile-v2.1.1/Changes 2019-07-01 03:20:51.0 +0200
@@ -1,6 +1,9 @@
 Revision history for Perl extension Test-Compile
 
-v2.1.02019-XX-XX
+v2.1.12019-07-01  (Evan Giles )
+- Correct the POD
+
+v2.1.02019-06-29  (Evan Giles )
 - Update copyright
 - Add all_pm_files_ok() and all_pl_files_ok() methods to the internal class
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-Compile-v2.1.0/MANIFEST 
new/Test-Compile-v2.1.1/MANIFEST
--- old/Test-Compile-v2.1.0/MANIFEST2019-06-27 12:26:28.0 +0200
+++ new/Test-Compile-v2.1.1/MANIFEST2019-07-01 03:20:51.0 +0200
@@ -12,6 +12,7 @@
 t/100-internal--find-files.t
 t/100-internal--is-in-taint-mode.t
 t/100-internal--read-shebang.t
+t/100-internal--test-methods.t
 t/100-internal-all-pl-files.t
 t/100-internal-all-pm-files.t
 t/100-internal-basic.t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-Compile-v2.1.0/META.json 
new/Test-Compile-v2.1.1/META.json
--- old/Test-Compile-v2.1.0/META.json   2019-06-27 12:26:28.0 +0200
+++ new/Test-Compile-v2.1.1/META.json   2019-07-01 03:20:51.0 +0200
@@ -35,11 +35,11 @@
"provides" : {
   "Test::Compile" : {
  "file" : "lib/Test/Compile.pm",
- "version" : "v2.1.0"
+ "version" : "v2.1.1"
   },
   "Test::Compile::Internal" : {
  "file" : "lib/Test/Compile/Internal.pm",
- "version" : "v2.1.0"
+ "version" : "v2.1.1"
   }
},
"release_status" : "stable",
@@ -51,6 +51,6 @@
  "url" : "http://github.com/egiles/test-compile;
   }
},
-   "version" : "v2.1.0",
+   "version" : "v2.1.1",
"x_serialization_backend" : "JSON::PP version 2.27400_02"
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-Compile-v2.1.0/META.yml 
new/Test-Compile-v2.1.1/META.yml
--- old/Test-Compile-v2.1.0/META.yml2019-06-27 12:26:28.0 +0200
+++ new/Test-Compile-v2.1.1/META.yml2019-07-01 03:20:51.0 +0200
@@ -15,10 +15,10 @@
 provides:
   Test::Compile:
 file: lib/Test/Compile.pm
-version: v2.1.0
+version: v2.1.1
   Test::Compile::Internal:
 file: lib/Test/Compile/Internal.pm
-version: v2.1.0
+version: v2.1.1
 recommends:
   Devel::CheckOS: '0'
 requires:
@@ -30,5 +30,5 @@
 resources:
   license: http://dev.perl.org/licenses/
   repository: http://github.com/egiles/test-compile
-version: v2.1.0
+version: v2.1.1
 x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Test-Compile-v2.1.0/Makefile.PL 
new/Test-Compile-v2.1.1/Makefile.PL
--- old/Test-Compile-v2.1.0/Makefile.PL 2019-06-27 12:26:28.0 +0200
+++ new/Test-Compile-v2.1.1/Makefile.PL 2019-07-01 03:20:51.0 +0200
@@ -3,16 +3,16 @@
 use ExtUtils::MakeMaker;
 WriteMakefile
 (
-  'NAME' => 'Test::Compile',
-  'INSTALLDIRS' => 'site',
-  'EXE_FILES' => [],
   'PREREQ_PM' => {
- 

commit python3-pyside2 for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package python3-pyside2 for openSUSE:Factory 
checked in at 2019-07-02 10:39:27

Comparing /work/SRC/openSUSE:Factory/python3-pyside2 (Old)
 and  /work/SRC/openSUSE:Factory/.python3-pyside2.new.4615 (New)


Package is "python3-pyside2"

Tue Jul  2 10:39:27 2019 rev:5 rq:712917 version:5.13.0

Changes:

--- /work/SRC/openSUSE:Factory/python3-pyside2/python3-pyside2.changes  
2019-05-22 11:10:57.834597913 +0200
+++ 
/work/SRC/openSUSE:Factory/.python3-pyside2.new.4615/python3-pyside2.changes
2019-07-02 10:39:29.578681986 +0200
@@ -1,0 +2,22 @@
+Mon Jul  1 18:00:38 UTC 2019 - Stefan Brüns 
+
+- Remove "CFLAGS=-I/usr/include/linux" export, otherwise pthreads.h
+  includes linux/time.h instead of time.h. As a result CMake no longer
+  finds a valid pthreads.h and aborts.
+- Drop "docs", which included building and installing instructions only,
+  as done upstream. See https://doc.qt.io/qtforpython/ and
+  https://wiki.qt.io/Qt_for_Python/Tutorial for developer documentation.
+
+---
+Thu Jun 27 07:58:17 UTC 2019 - Christophe Giboudeaux 
+
+- Update to 5.13.0
+  * Add bindings for 5.13
+  * Support the qApp macro in "scriptable application"
+  * Doc: Add QML Integration tutorial
+  * Docs: Add Expenses tool tutorial
+  * Regenerate all example forms using the python-extended rcc of 5.14
+  * Fix type name for lookup of QFlags<> converters
+  Check the changes-* files for older changes.
+  
+---

Old:

  pyside-setup-everywhere-src-5.12.3.tar.xz

New:

  pyside-setup-everywhere-src-5.13.0.tar.xz



Other differences:
--
++ python3-pyside2.spec ++
--- /var/tmp/diff_new_pack.56ZpMe/_old  2019-07-02 10:39:30.274683046 +0200
+++ /var/tmp/diff_new_pack.56ZpMe/_new  2019-07-02 10:39:30.278683052 +0200
@@ -22,7 +22,7 @@
 BuildRequires:  python3-devel
 BuildRequires:  python3-setuptools
 Name:   python3-pyside2
-Version:5.12.3
+Version:5.13.0
 Release:0
 Summary:Python bindings for Qt
 # shiboken2 is licensed under GPL-3.0-with-Qt-Company-Qt-exception-1.1
@@ -41,8 +41,8 @@
 
 # essential modules
 BuildRequires:  cmake(Qt5Concurrent)
-BuildConflicts: cmake(Qt5Core) >= 5.13
-BuildRequires:  cmake(Qt5Core) >= 5.12
+BuildConflicts: cmake(Qt5Core) >= 5.14
+BuildRequires:  cmake(Qt5Core) >= 5.13
 BuildRequires:  cmake(Qt5Network)
 BuildRequires:  cmake(Qt5PrintSupport)
 BuildRequires:  cmake(Qt5Sql)
@@ -96,6 +96,7 @@
 
 %package devel
 Summary:Header Files for PySide2
+License:LGPL-3.0-only OR (GPL-2.0-only OR GPL-3.0-or-later) AND 
GPL-3.0-with-Qt-Company-Qt-exception-1.1
 Group:  Development/Languages/Python
 Requires:   %{name} = %{version}
 
@@ -105,6 +106,7 @@
 
 %package examples
 Summary:Examples for using PySide2
+License:BSD-3-Clause
 Group:  Development/Languages/Python
 Requires:   %{name} = %{version}
 
@@ -120,7 +122,6 @@
 
 %build
 export LLVM_INSTALL_DIR=%{_prefix}
-export CFLAGS=-I/usr/include/linux
 # Workaround for PYSIDE-880
 export LC_ALL=C.utf8
 %{mypython} setup.py build --reuse-build --ignore-git 
%{?jobs:--parallel=%{jobs}} \
@@ -168,11 +169,6 @@
 
 %fdupes %{buildroot}%{_datadir}/PySide2/examples/
 
-# docu generation
-cd docs
-make html
-cd -
-
 %check
 %if %{with tests}
 %{mypython} testrunner.py test
@@ -189,7 +185,6 @@
 %{python_sitearch}/*
 
 %files devel
-%doc docs/_build/html
 %{_datadir}/PySide2/
 %exclude %{_datadir}/PySide2/examples
 %{_includedir}/*

++ pyside-setup-everywhere-src-5.12.3.tar.xz -> 
pyside-setup-everywhere-src-5.13.0.tar.xz ++
 54933 lines of diff (skipped)




commit maven-surefire for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package maven-surefire for openSUSE:Factory 
checked in at 2019-07-02 10:39:06

Comparing /work/SRC/openSUSE:Factory/maven-surefire (Old)
 and  /work/SRC/openSUSE:Factory/.maven-surefire.new.4615 (New)


Package is "maven-surefire"

Tue Jul  2 10:39:06 2019 rev:2 rq:712859 version:2.22.0

Changes:

New Changes file:

--- /dev/null   2019-06-21 11:18:06.406367250 +0200
+++ 
/work/SRC/openSUSE:Factory/.maven-surefire.new.4615/maven-surefire-provider-junit5.changes
  2019-07-02 10:39:08.958650609 +0200
@@ -0,0 +1,4 @@
+---
+Mon Jul  1 13:28:26 UTC 2019 - Fridrich Strba 
+
+- Intial packaging of junit 5 provider for maven surefire

New:

  maven-surefire-provider-junit5.changes
  maven-surefire-provider-junit5.spec



Other differences:
--
++ maven-surefire-plugins.spec ++
--- /var/tmp/diff_new_pack.TigUiW/_old  2019-07-02 10:39:09.506651443 +0200
+++ /var/tmp/diff_new_pack.TigUiW/_new  2019-07-02 10:39:09.510651449 +0200
@@ -1,7 +1,7 @@
 #
-# spec file for package maven-surefire
+# spec file for package maven
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
+
 %global base_name maven-surefire
 Name:   %{base_name}-plugins
 Version:2.22.0
@@ -37,16 +38,16 @@
 BuildRequires:  mvn(commons-io:commons-io)
 BuildRequires:  mvn(org.apache.commons:commons-lang3)
 BuildRequires:  mvn(org.apache.maven.doxia:doxia-site-renderer)
-BuildRequires:  mvn(org.apache.maven:maven-model)
-BuildRequires:  mvn(org.apache.maven:maven-parent:pom:)
-BuildRequires:  mvn(org.apache.maven:maven-plugin-api)
-BuildRequires:  mvn(org.apache.maven.plugins:maven-plugin-plugin)
 BuildRequires:  mvn(org.apache.maven.plugin-tools:maven-plugin-annotations)
+BuildRequires:  mvn(org.apache.maven.plugins:maven-plugin-plugin)
 BuildRequires:  mvn(org.apache.maven.reporting:maven-reporting-impl)
 BuildRequires:  mvn(org.apache.maven.shared:maven-shared-utils)
 BuildRequires:  mvn(org.apache.maven.surefire:maven-surefire-common)
 BuildRequires:  mvn(org.apache.maven.surefire:surefire-logger-api)
 BuildRequires:  mvn(org.apache.maven.surefire:surefire-report-parser)
+BuildRequires:  mvn(org.apache.maven:maven-model)
+BuildRequires:  mvn(org.apache.maven:maven-parent:pom:)
+BuildRequires:  mvn(org.apache.maven:maven-plugin-api)
 BuildRequires:  mvn(org.codehaus.plexus:plexus-utils)
 BuildRequires:  mvn(org.fusesource.jansi:jansi)
 #!BuildRequires: maven-compiler-plugin-bootstrap
@@ -62,18 +63,21 @@
 
 %package -n maven-surefire-plugin
 Summary:Surefire plugin for maven
+Group:  Development/Libraries/Java
 
 %description -n maven-surefire-plugin
 Maven surefire plugin for running tests via the surefire framework.
 
 %package -n maven-surefire-report-plugin
 Summary:Surefire reports plugin for maven
+Group:  Development/Libraries/Java
 
 %description -n maven-surefire-report-plugin
 Plugin for generating reports from surefire test runs.
 
 %package -n maven-failsafe-plugin
 Summary:Maven plugin for running integration tests
+Group:  Development/Libraries/Java
 
 %description -n maven-failsafe-plugin
 The Failsafe Plugin is designed to run integration tests while the
@@ -94,6 +98,7 @@
 
 %package javadoc
 Summary:Javadoc for %{name}
+Group:  Development/Libraries/Java
 
 %description javadoc
 Javadoc for %{name}.

++ maven-surefire-provider-junit5.spec ++
#
# spec file for package maven
#
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%global base_name maven-surefire
Name:   %{base_name}-provider-junit5
Version:2.22.0
Release:0
Summary:JUnit 5 provider for Maven Surefire
License:Apache-2.0 AND CPL-1.0
Group:  

commit tuned for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package tuned for openSUSE:Factory checked 
in at 2019-07-02 10:39:19

Comparing /work/SRC/openSUSE:Factory/tuned (Old)
 and  /work/SRC/openSUSE:Factory/.tuned.new.4615 (New)


Package is "tuned"

Tue Jul  2 10:39:19 2019 rev:21 rq:712885 version:2.12.0

Changes:

--- /work/SRC/openSUSE:Factory/tuned/tuned.changes  2019-06-12 
13:12:24.580935559 +0200
+++ /work/SRC/openSUSE:Factory/.tuned.new.4615/tuned.changes2019-07-02 
10:39:19.64874 +0200
@@ -1,0 +2,6 @@
+Mon Jul  1 15:10:26 UTC 2019 - tr...@suse.de
+
+- Upgrade to latest 2.12.0 version(git commit b514cda168878c330b70416676)
+  - Removes sap-hana-vmware profile
+
+---

Old:

  tuned-2.11.0+git20190405.b4d9dfc.tar.xz

New:

  tuned-2.12.0.tar.xz



Other differences:
--
++ tuned.spec ++
--- /var/tmp/diff_new_pack.vJgWDE/_old  2019-07-02 10:39:20.162667658 +0200
+++ /var/tmp/diff_new_pack.vJgWDE/_new  2019-07-02 10:39:20.17664 +0200
@@ -18,7 +18,7 @@
 
 %{!?_tmpfilesdir:%global _tmpfilesdir %{_libexecdir}/tmpfiles.d}
 Name:   tuned
-Version:2.11.0+git20190405.b4d9dfc
+Version:2.12.0
 Release:0
 Summary:A dynamic adaptive system tuning daemon
 License:GPL-2.0-or-later
@@ -207,7 +207,6 @@
 %exclude %{_libexecdir}/tuned/realtime-virtual-host
 %exclude %{_libexecdir}/tuned/sap-netweaver
 %exclude %{_libexecdir}/tuned/sap-hana
-%exclude %{_libexecdir}/tuned/sap-hana-vmware
 %exclude %{_mandir}/man7/tuned-profiles-sap*.7.gz
 %exclude %{_libexecdir}/tuned/atomic-host
 %exclude %{_libexecdir}/tuned/atomic-guest
@@ -222,7 +221,6 @@
 %config(noreplace) %{_sysconfdir}/tuned/cpu-partitioning-variables.conf
 %config(noreplace) %{_sysconfdir}/tuned/tuned-main.conf
 %config(noreplace) %{_sysconfdir}/tuned/profile_mode
-%config(noreplace) %{_sysconfdir}/tuned/sap-hana-vmware-variables.conf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/tuned/bootcmdline
 %dir %{_sysconfdir}/dbus-1
 %dir %{_sysconfdir}/dbus-1/system.d
@@ -258,7 +256,6 @@
 
 %files profiles-sap-hana
 %{_libexecdir}/tuned/sap-hana
-%{_libexecdir}/tuned/sap-hana-vmware
 %{_mandir}/man7/tuned-profiles-sap-hana.7%{?ext_man}
 %endif
 

++ _service ++
--- /var/tmp/diff_new_pack.vJgWDE/_old  2019-07-02 10:39:20.198667713 +0200
+++ /var/tmp/diff_new_pack.vJgWDE/_new  2019-07-02 10:39:20.198667713 +0200
@@ -2,10 +2,11 @@
   
 git
 https://github.com/redhat-performance/tuned
-2.11.0+git%cd.%h
 
+2.12.0
+disable
   
   
 tuned*.tar

++ tuned-2.11.0+git20190405.b4d9dfc.tar.xz -> tuned-2.12.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tuned-2.11.0+git20190405.b4d9dfc/Makefile 
new/tuned-2.12.0/Makefile
--- old/tuned-2.11.0+git20190405.b4d9dfc/Makefile   2019-04-05 
10:49:17.0 +0200
+++ new/tuned-2.12.0/Makefile   2019-06-27 17:08:55.0 +0200
@@ -175,8 +175,6 @@

$(DESTDIR)$(SYSCONFDIR)/tuned/realtime-virtual-host-variables.conf
mv 
$(DESTDIR)$(TUNED_PROFILESDIR)/cpu-partitioning/cpu-partitioning-variables.conf 
\
$(DESTDIR)$(SYSCONFDIR)/tuned/cpu-partitioning-variables.conf
-   mv 
$(DESTDIR)$(TUNED_PROFILESDIR)/sap-hana-vmware/sap-hana-vmware-variables.conf \
-   $(DESTDIR)$(SYSCONFDIR)/tuned/sap-hana-vmware-variables.conf
install -pm 0644 recommend.conf 
$(DESTDIR)$(TUNED_RECOMMEND_DIR)/50-tuned.conf
 
# bash completion
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/tuned-2.11.0+git20190405.b4d9dfc/com.redhat.tuned.policy 
new/tuned-2.12.0/com.redhat.tuned.policy
--- old/tuned-2.11.0+git20190405.b4d9dfc/com.redhat.tuned.policy
2019-04-05 10:49:17.0 +0200
+++ new/tuned-2.12.0/com.redhat.tuned.policy2019-06-27 17:08:55.0 
+0200
@@ -181,8 +181,8 @@
 Get plugins which Tuned daemon can acces
 Authentication is required to get Tuned plugins
 
-  yes
-  yes
+  auth_admin
+  auth_admin
   yes
 
   
@@ -191,8 +191,8 @@
 Get documentation of tuned plugin
 Authentication is required to get documentation of tuned 
plugin
 
-  yes
-  yes
+  auth_admin
+  auth_admin
   yes
 
   
@@ -201,8 +201,8 @@
 Get hints for parameters of Tuned plugin
 Authentication is required to get hints for parameters of Tuned 
plugin
 
-  yes
-  yes
+  auth_admin
+  auth_admin
   yes
 
   
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit gitolite for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package gitolite for openSUSE:Factory 
checked in at 2019-07-02 10:39:15

Comparing /work/SRC/openSUSE:Factory/gitolite (Old)
 and  /work/SRC/openSUSE:Factory/.gitolite.new.4615 (New)


Package is "gitolite"

Tue Jul  2 10:39:15 2019 rev:9 rq:712874 version:3.6.11

Changes:

--- /work/SRC/openSUSE:Factory/gitolite/gitolite.changes2019-01-21 
10:54:13.935737474 +0100
+++ /work/SRC/openSUSE:Factory/.gitolite.new.4615/gitolite.changes  
2019-07-02 10:39:16.426661974 +0200
@@ -1,0 +2,6 @@
+Mon Jul  1 14:31:09 UTC 2019 - ch...@computersalat.de
+
+- update changes file
+  * add missing info about bugzilla 1096814
+
+---
@@ -34 +40 @@
-- Update to 3.6.7
+- Update to 3.6.7 (fix for boo#1096814)



Other differences:
--



commit erlang for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package erlang for openSUSE:Factory checked 
in at 2019-07-02 10:38:56

Comparing /work/SRC/openSUSE:Factory/erlang (Old)
 and  /work/SRC/openSUSE:Factory/.erlang.new.4615 (New)


Package is "erlang"

Tue Jul  2 10:38:56 2019 rev:84 rq:712820 version:22.0.4

Changes:

--- /work/SRC/openSUSE:Factory/erlang/erlang.changes2019-06-17 
21:35:12.554998967 +0200
+++ /work/SRC/openSUSE:Factory/.erlang.new.4615/erlang.changes  2019-07-02 
10:39:01.146638722 +0200
@@ -1,0 +2,26 @@
+Tue Jun 25 10:23:44 UTC 2019 - Gabriele Santomaggio 
+
+- Version 22.0.4:
+  * http://erlang.org/download/OTP-22.0.4.README
+  - Bug Fixes
+  * erts: Fixed a buffer overflow when binary_to_existing_atom/2
+and list_to_existing_atom/2 was used with the latin1
+encoding.
+  * erts: The runtime system disconnected a connection if it
+received an exit/2 signal where the recipient was a
+process on an old incarnation of the current node. That
+is, the receiving node had the same node name, but
+another "creation" number. The signal will now just be
+dropped since the receiving process no longer exists. 
+  * kernel: user/user_drv could respond to io requests before they
+had been processed, which could cause data to be
+dropped if the emulator was halted soon after a call to
+io:format/2, such as in an escript.
+  * ssl: Correct handshake handling, might cause strange
+symptoms such as ASN.1 certificate decoding issues.
+  * ssl: Fix handling of the signature_algorithms_cert extension
+in the ClientHello handshake message.
+  * ssl:Handle new ClientHello extensions when handshake is
+paused by the {handshake, hello} ssl option.
+
+---

Old:

  OTP-22.0.tar.gz

New:

  OTP-22.0.4.tar.gz



Other differences:
--
++ erlang.spec ++
--- /var/tmp/diff_new_pack.N1SXRj/_old  2019-07-02 10:39:02.578640900 +0200
+++ /var/tmp/diff_new_pack.N1SXRj/_new  2019-07-02 10:39:02.582640906 +0200
@@ -26,7 +26,7 @@
 %endif
 
 Name:   erlang
-Version:22.0
+Version:22.0.4
 Release:0
 # not set up to be built with position independend executable support
 #!BuildIgnore: gcc-PIE

++ OTP-22.0.tar.gz -> OTP-22.0.4.tar.gz ++
/work/SRC/openSUSE:Factory/erlang/OTP-22.0.tar.gz 
/work/SRC/openSUSE:Factory/.erlang.new.4615/OTP-22.0.4.tar.gz differ: char 29, 
line 1




commit terraform for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package terraform for openSUSE:Factory 
checked in at 2019-07-02 10:38:58

Comparing /work/SRC/openSUSE:Factory/terraform (Old)
 and  /work/SRC/openSUSE:Factory/.terraform.new.4615 (New)


Package is "terraform"

Tue Jul  2 10:38:58 2019 rev:4 rq:712852 version:0.12.0

Changes:

--- /work/SRC/openSUSE:Factory/terraform/terraform.changes  2019-06-24 
21:54:11.192144153 +0200
+++ /work/SRC/openSUSE:Factory/.terraform.new.4615/terraform.changes
2019-07-02 10:39:04.410643688 +0200
@@ -1,0 +2,5 @@
+Mon Jul  1 12:22:10 UTC 2019 - Petr Cervinka 
+
+- Fix versionformat in service file 
+
+---

Old:

  terraform-v0.12.0.obscpio
  terraform-v0.12.0.tar.xz

New:

  terraform-0.12.0.obscpio
  terraform-0.12.0.tar.xz



Other differences:
--
++ terraform.spec ++
--- /var/tmp/diff_new_pack.IMeawH/_old  2019-07-02 10:39:05.794645794 +0200
+++ /var/tmp/diff_new_pack.IMeawH/_new  2019-07-02 10:39:05.798645800 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   terraform
-Version:v0.12.0
+Version:0.12.0
 Release:0
 Summary:Tool for building infrastructure safely and efficiently
 License:MPL-2.0
@@ -25,9 +25,9 @@
 URL:https://www.terraform.io/
 Source: %{name}-%{version}.tar.xz
 Source99:   terraform-rpmlintrc
-BuildRequires:  golang(API) >= 1.11
 BuildRequires:  golang-packaging
 BuildRequires:  xz
+BuildRequires:  golang(API) >= 1.11
 %{go_nostrip}
 %{go_provides}
 

++ _service ++
--- /var/tmp/diff_new_pack.IMeawH/_old  2019-07-02 10:39:05.818645830 +0200
+++ /var/tmp/diff_new_pack.IMeawH/_new  2019-07-02 10:39:05.822645836 +0200
@@ -3,7 +3,7 @@
 https://github.com/hashicorp/terraform.git
 git
 terraform
-v0.12.0
+0.12.0
 v0.12.0
 .git
   

++ terraform-v0.12.0.obscpio -> terraform-0.12.0.obscpio ++
/work/SRC/openSUSE:Factory/terraform/terraform-v0.12.0.obscpio 
/work/SRC/openSUSE:Factory/.terraform.new.4615/terraform-0.12.0.obscpio differ: 
char 102, line 1

++ terraform-v0.12.0.tar.xz -> terraform-0.12.0.tar.xz ++

++ terraform.obsinfo ++
--- /var/tmp/diff_new_pack.IMeawH/_old  2019-07-02 10:39:08.174649416 +0200
+++ /var/tmp/diff_new_pack.IMeawH/_new  2019-07-02 10:39:08.178649422 +0200
@@ -1,5 +1,5 @@
 name: terraform
-version: v0.12.0
+version: 0.12.0
 mtime: 1558556075
 commit: 08918475dd08f0c45fc5aa084bacd2595c6e6c07
 




commit proftpd for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package proftpd for openSUSE:Factory checked 
in at 2019-07-02 10:39:12

Comparing /work/SRC/openSUSE:Factory/proftpd (Old)
 and  /work/SRC/openSUSE:Factory/.proftpd.new.4615 (New)


Package is "proftpd"

Tue Jul  2 10:39:12 2019 rev:33 rq:712870 version:1.3.6

Changes:

--- /work/SRC/openSUSE:Factory/proftpd/proftpd.changes  2019-05-27 
08:38:12.287075198 +0200
+++ /work/SRC/openSUSE:Factory/.proftpd.new.4615/proftpd.changes
2019-07-02 10:39:13.634657724 +0200
@@ -1,0 +2,6 @@
+Mon Jul  1 13:50:01 UTC 2019 - ch...@computersalat.de
+
+- update changes file
+  * add missing info about bugzilla 1113041
+
+---
@@ -5 +11 @@
-  to build with.
+  to build with. (fix for boo#1113041)



Other differences:
--




commit lutris for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package lutris for openSUSE:Factory checked 
in at 2019-07-02 10:38:52

Comparing /work/SRC/openSUSE:Factory/lutris (Old)
 and  /work/SRC/openSUSE:Factory/.lutris.new.4615 (New)


Package is "lutris"

Tue Jul  2 10:38:52 2019 rev:8 rq:712810 version:0.5.2.2

Changes:

--- /work/SRC/openSUSE:Factory/lutris/lutris.changes2019-05-24 
11:33:36.853361550 +0200
+++ /work/SRC/openSUSE:Factory/.lutris.new.4615/lutris.changes  2019-07-02 
10:38:52.586625695 +0200
@@ -1,0 +2,7 @@
+Mon Jul  1 11:05:43 UTC 2019 - mvet...@suse.com
+
+- Update to 0.5.2.2:
+  * Fix installation of Wine Steam runner
+  * Restore and preserve original d3d .dll files when DXVK option is not active
+
+---

Old:

  lutris_0.5.2.1.tar.xz

New:

  lutris_0.5.2.2.tar.xz



Other differences:
--
++ lutris.spec ++
--- /var/tmp/diff_new_pack.DJkEsd/_old  2019-07-02 10:38:53.150626553 +0200
+++ /var/tmp/diff_new_pack.DJkEsd/_new  2019-07-02 10:38:53.150626553 +0200
@@ -18,7 +18,7 @@
 
 %global appid net.lutris.Lutris
 Name:   lutris
-Version:0.5.2.1
+Version:0.5.2.2
 Release:0
 Summary:Manager for game installation and execution
 License:GPL-3.0-or-later

++ lutris_0.5.2.1.tar.xz -> lutris_0.5.2.2.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lutris/debian/changelog new/lutris/debian/changelog
--- old/lutris/debian/changelog 2019-04-10 04:46:02.0 +0200
+++ new/lutris/debian/changelog 2019-06-27 06:20:13.0 +0200
@@ -1,3 +1,10 @@
+lutris (0.5.2.2) disco; urgency=high
+
+  * Fix installation of Wine Steam runner
+  * Restore and preserve original d3d .dll files when DXVK option is not active
+
+ -- Mathieu Comandon   Wed, 26 Jun 2019 21:20:13 -0700
+
 lutris (0.5.2.1) cosmic; urgency=high
 
   * Handle distributions where ldconfig is not in $PATH, like Debian
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lutris/lutris/__init__.py 
new/lutris/lutris/__init__.py
--- old/lutris/lutris/__init__.py   2019-04-10 04:44:41.0 +0200
+++ new/lutris/lutris/__init__.py   2019-06-27 06:12:21.0 +0200
@@ -1,3 +1,3 @@
 """Main Lutris package"""
 
-__version__ = "0.5.2.1"
+__version__ = "0.5.2.2"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lutris/lutris/runners/winesteam.py 
new/lutris/lutris/runners/winesteam.py
--- old/lutris/lutris/runners/winesteam.py  2019-03-27 06:45:06.0 
+0100
+++ new/lutris/lutris/runners/winesteam.py  2019-06-27 06:10:36.0 
+0200
@@ -24,7 +24,7 @@
 install_cab_component,
 )
 
-STEAM_INSTALLER_URL = "http://lutris.net/files/runners/SteamInstall.msi;
+STEAM_INSTALLER_URL = 
"https://lutris.nyc3.cdn.digitaloceanspaces.com/runners/winesteam/SteamSetup.exe;
 
 
 def is_running():
@@ -275,7 +275,7 @@
 return system.fix_path_case(registry.get_unix_path(steam_path))
 
 def install(self, version=None, downloader=None, callback=None):
-installer_path = os.path.join(settings.TMP_PATH, "SteamInstall.msi")
+installer_path = os.path.join(settings.TMP_PATH, "SteamSetup.exe")
 
 def on_steam_downloaded(*_args):
 prefix = self.get_or_create_default_prefix()
@@ -286,13 +286,11 @@
 prefix=prefix,
 wine_path=self.get_executable()
 )
-self.msi_exec(
+wineexec(
 installer_path,
-quiet=True,
+args="/S",
 prefix=prefix,
 wine_path=self.get_executable(),
-working_dir="/tmp",
-blocking=True,
 )
 if callback:
 callback()
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lutris/lutris/util/wine/dxvk.py 
new/lutris/lutris/util/wine/dxvk.py
--- old/lutris/lutris/util/wine/dxvk.py 2019-04-08 06:13:08.0 +0200
+++ new/lutris/lutris/util/wine/dxvk.py 2019-06-27 06:10:19.0 +0200
@@ -124,18 +124,20 @@
 
 def enable_dxvk_dll(self, system_dir, dxvk_arch, dll):
 """Copies DXVK dlls to the appropriate destination"""
-wine_dll_path = os.path.join(system_dir, "%s.dll" % dll)
-logger.info("Replacing %s/%s with DXVK version", system_dir, dll)
-if not self.is_dxvk_dll(wine_dll_path):
-# Backing up original version (may not be needed)
-if system.path_exists(wine_dll_path):
-shutil.move(wine_dll_path, wine_dll_path + ".orig")
 # 

commit R-rlang for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package R-rlang for openSUSE:Factory checked 
in at 2019-07-02 10:38:25

Comparing /work/SRC/openSUSE:Factory/R-rlang (Old)
 and  /work/SRC/openSUSE:Factory/.R-rlang.new.4615 (New)


Package is "R-rlang"

Tue Jul  2 10:38:25 2019 rev:3 rq:712744 version:0.4.0

Changes:

--- /work/SRC/openSUSE:Factory/R-rlang/R-rlang.changes  2019-05-28 
09:43:31.553838869 +0200
+++ /work/SRC/openSUSE:Factory/.R-rlang.new.4615/R-rlang.changes
2019-07-02 10:38:27.282587189 +0200
@@ -1,0 +2,11 @@
+Mon Jul  1 07:44:03 UTC 2019 - Pierre Bonamy 
+
+- Update to 0.4.0:
+  * Interpolate function inputs with the curly-curly operator `{{`
+  * More robust .env pronoun
+  * New functions (pairlist2(), is_bool()) and features 
+  * Bugfixes and small improvements
+  * More at:
+  https://cran.r-project.org/web/packages/rlang/news/news.html
+
+---

Old:

  rlang_0.3.4.tar.gz

New:

  rlang_0.4.0.tar.gz



Other differences:
--
++ R-rlang.spec ++
--- /var/tmp/diff_new_pack.YTvpJj/_old  2019-07-02 10:38:27.982588254 +0200
+++ /var/tmp/diff_new_pack.YTvpJj/_new  2019-07-02 10:38:27.986588260 +0200
@@ -19,7 +19,7 @@
 %global packname  rlang
 %global rlibdir   %{_libdir}/R/library
 Name:   R-%{packname}
-Version:0.3.4
+Version:0.4.0
 Release:0
 Summary:Functions for Base Types and Core R and 'Tidyverse' Features
 License:GPL-3.0-only

++ rlang_0.3.4.tar.gz -> rlang_0.4.0.tar.gz ++
 13681 lines of diff (skipped)




commit imv for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package imv for openSUSE:Factory checked in 
at 2019-07-02 10:38:54

Comparing /work/SRC/openSUSE:Factory/imv (Old)
 and  /work/SRC/openSUSE:Factory/.imv.new.4615 (New)


Package is "imv"

Tue Jul  2 10:38:54 2019 rev:4 rq:712812 version:3.1.2

Changes:

--- /work/SRC/openSUSE:Factory/imv/imv.changes  2019-06-24 21:54:04.852139275 
+0200
+++ /work/SRC/openSUSE:Factory/.imv.new.4615/imv.changes2019-07-02 
10:38:55.554630212 +0200
@@ -1,0 +2,7 @@
+Mon Jul  1 11:16:36 UTC 2019 - mvet...@suse.com
+
+- Update to 3.1.2:
+  * Fix manpage packaging regression introduced in v3.1.1
+- Remove imv-fixbuild.patch: upstreamed
+
+---

Old:

  imv-fixbuild.patch
  v3.1.1.tar.gz

New:

  v3.1.2.tar.gz



Other differences:
--
++ imv.spec ++
--- /var/tmp/diff_new_pack.IXfUBB/_old  2019-07-02 10:38:56.594631795 +0200
+++ /var/tmp/diff_new_pack.IXfUBB/_new  2019-07-02 10:38:56.598631800 +0200
@@ -17,15 +17,13 @@
 
 
 Name:   imv
-Version:3.1.1
+Version:3.1.2
 Release:0
 Summary:Image viewer for X11/Wayland
 License:MIT AND GPL-2.0-or-later
 Group:  Productivity/Graphics/Viewers
 URL:https://github.com/eXeC64/imv
 Source: https://github.com/eXeC64/imv/archive/v%{version}.tar.gz
-# FIX-UPSTREAM mvet...@suse.com - https://github.com/eXeC64/imv/issues/160
-Patch0: imv-fixbuild.patch
 BuildRequires:  asciidoc
 BuildRequires:  freeimage-devel
 BuildRequires:  libjpeg8-devel
@@ -41,7 +39,6 @@
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 make %{?_smp_mflags} \

++ v3.1.1.tar.gz -> v3.1.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/imv-3.1.1/CHANGELOG new/imv-3.1.2/CHANGELOG
--- old/imv-3.1.1/CHANGELOG 2019-06-22 22:40:25.0 +0200
+++ new/imv-3.1.2/CHANGELOG 2019-06-24 09:09:42.0 +0200
@@ -1,6 +1,10 @@
 imv Changelog
 =
 
+v3.1.2 - 2019-06-24
+
+* Fix manpage packaging regression introduced in v3.1.1
+
 v3.1.1 - 2019-06-22
 
 * Adjusted Makefile to improve packaging on BSDs
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/imv-3.1.1/Makefile new/imv-3.1.2/Makefile
--- old/imv-3.1.1/Makefile  2019-06-22 22:40:25.0 +0200
+++ new/imv-3.1.2/Makefile  2019-06-24 09:09:42.0 +0200
@@ -71,7 +71,7 @@
 OBJECTS := $(patsubst src/%.c,$(BUILDDIR)/%.o,$(SOURCES))
 TESTS := $(patsubst test/%.c,$(BUILDDIR)/test_%,$(TEST_SOURCES))
 
-VERSION != git describe --dirty --always --tags 2> /dev/null || echo v3.1.1
+VERSION != git describe --dirty --always --tags 2> /dev/null || echo v3.1.2
 
 override CPPFLAGS += -DIMV_VERSION=\""$(VERSION)"\"
 
@@ -112,8 +112,9 @@
 install: $(TARGET) doc
mkdir -p $(DESTDIR)$(BINPREFIX)
$(INSTALL_PROGRAM) $(TARGET) $(DESTDIR)$(BINPREFIX)/imv
-   mkdir -p $(DESTDIR)$(MANPREFIX)
+   mkdir -p $(DESTDIR)$(MANPREFIX)/man1
$(INSTALL_MAN) doc/imv.1 $(DESTDIR)$(MANPREFIX)/man1/imv.1
+   mkdir -p $(DESTDIR)$(MANPREFIX)/man5
$(INSTALL_MAN) doc/imv.5 $(DESTDIR)$(MANPREFIX)/man5/imv.5
mkdir -p $(DESTDIR)$(DATAPREFIX)/applications
$(INSTALL_DATA) files/imv.desktop 
$(DESTDIR)$(DATAPREFIX)/applications/imv.desktop




commit jline for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package jline for openSUSE:Factory checked 
in at 2019-07-02 10:38:47

Comparing /work/SRC/openSUSE:Factory/jline (Old)
 and  /work/SRC/openSUSE:Factory/.jline.new.4615 (New)


Package is "jline"

Tue Jul  2 10:38:47 2019 rev:23 rq:712781 version:2.14.6

Changes:

--- /work/SRC/openSUSE:Factory/jline/jline.changes  2019-03-10 
09:32:28.700218627 +0100
+++ /work/SRC/openSUSE:Factory/.jline.new.4615/jline.changes2019-07-02 
10:38:49.190620527 +0200
@@ -1,0 +2,6 @@
+Thu Jun 27 09:06:19 UTC 2019 - Fridrich Strba 
+
+- Work around a problem with dependency resolution, where variables
+  are not resolved
+
+---



Other differences:
--
++ jline.spec ++
--- /var/tmp/diff_new_pack.kf4zoP/_old  2019-07-02 10:38:49.870621562 +0200
+++ /var/tmp/diff_new_pack.kf4zoP/_new  2019-07-02 10:38:49.870621562 +0200
@@ -50,6 +50,7 @@
 
 %prep
 %setup -q -n jline2-jline-%{version}
+%pom_change_dep org.fusesource.jansi:jansi org.fusesource.jansi:jansi:1.12
 cp %{SOURCE1} build.xml
 mkdir -p lib
 




commit notmuch for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package notmuch for openSUSE:Factory checked 
in at 2019-07-02 10:38:30

Comparing /work/SRC/openSUSE:Factory/notmuch (Old)
 and  /work/SRC/openSUSE:Factory/.notmuch.new.4615 (New)


Package is "notmuch"

Tue Jul  2 10:38:30 2019 rev:20 rq:712760 version:0.29.1

Changes:

--- /work/SRC/openSUSE:Factory/notmuch/notmuch.changes  2019-06-12 
13:17:26.200619280 +0200
+++ /work/SRC/openSUSE:Factory/.notmuch.new.4615/notmuch.changes
2019-07-02 10:38:31.726593952 +0200
@@ -1,0 +2,6 @@
+Thu Jun 20 09:50:39 UTC 2019 - Dan Čermák 
+
+- Update to notmuch 0.29.1:
+  * Fix for installation failure with `configure --without-emacs`.
+
+---

Old:

  notmuch-0.29.tar.xz
  notmuch-0.29.tar.xz.asc

New:

  notmuch-0.29.1.tar.xz
  notmuch-0.29.1.tar.xz.asc



Other differences:
--
++ notmuch.spec ++
--- /var/tmp/diff_new_pack.ZsSMXQ/_old  2019-07-02 10:38:32.374594938 +0200
+++ /var/tmp/diff_new_pack.ZsSMXQ/_new  2019-07-02 10:38:32.378594944 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   notmuch
-Version:0.29
+Version:0.29.1
 Release:0
 Summary:The mail indexer
 License:GPL-3.0-or-later

++ notmuch-0.29.tar.xz -> notmuch-0.29.1.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/notmuch-0.29/NEWS new/notmuch-0.29.1/NEWS
--- old/notmuch-0.29/NEWS   2019-06-07 11:46:30.0 +0200
+++ new/notmuch-0.29.1/NEWS 2019-06-12 01:16:48.0 +0200
@@ -1,3 +1,11 @@
+Notmuch 0.29.1 (2019-06-11)
+===
+
+Build
+-
+
+Fix for installation failure with `configure --without-emacs`.
+
 Notmuch 0.29 (2019-06-07)
 =
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/notmuch-0.29/bindings/python/notmuch/version.py 
new/notmuch-0.29.1/bindings/python/notmuch/version.py
--- old/notmuch-0.29/bindings/python/notmuch/version.py 2019-06-07 
11:46:30.0 +0200
+++ new/notmuch-0.29.1/bindings/python/notmuch/version.py   2019-06-12 
01:16:48.0 +0200
@@ -1,3 +1,3 @@
 # this file should be kept in sync with ../../../version
-__VERSION__ = '0.29'
+__VERSION__ = '0.29.1'
 SOVERSION = '5'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/notmuch-0.29/debian/changelog 
new/notmuch-0.29.1/debian/changelog
--- old/notmuch-0.29/debian/changelog   2019-06-07 11:46:30.0 +0200
+++ new/notmuch-0.29.1/debian/changelog 2019-06-12 01:16:48.0 +0200
@@ -1,4 +1,12 @@
-notmuch (0.29-1) experimental; urgency=medium
+notmuch (0.29.1-1) experimental; urgency=medium
+
+  * New upstream bug fix release
+- fix for building and installing without emacs, does not occur
+  in Debian builds.
+
+ -- David Bremner   Tue, 11 Jun 2019 20:16:03 -0300
+
+notmuch (0.29-2) experimental; urgency=medium
 
   * New upstream feature release. See /usr/share/doc/notmuch/NEWS.gz for
 details.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/notmuch-0.29/debian/elpa-notmuch.install 
new/notmuch-0.29.1/debian/elpa-notmuch.install
--- old/notmuch-0.29/debian/elpa-notmuch.install2019-06-07 
11:46:30.0 +0200
+++ new/notmuch-0.29.1/debian/elpa-notmuch.install  1970-01-01 
01:00:00.0 +0100
@@ -1 +0,0 @@
-usr/share/applications/notmuch-emacs-mua.desktop
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/notmuch-0.29/debian/notmuch.install 
new/notmuch-0.29.1/debian/notmuch.install
--- old/notmuch-0.29/debian/notmuch.install 2019-06-07 11:46:30.0 
+0200
+++ new/notmuch-0.29.1/debian/notmuch.install   2019-06-12 01:16:48.0 
+0200
@@ -2,3 +2,4 @@
 usr/bin/notmuch-emacs-mua
 usr/share/bash-completion
 usr/share/zsh/vendor-completions
+emacs/notmuch-emacs-mua.desktop usr/share/applications
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/notmuch-0.29/doc/Makefile.local 
new/notmuch-0.29.1/doc/Makefile.local
--- old/notmuch-0.29/doc/Makefile.local 2019-06-07 11:46:30.0 +0200
+++ new/notmuch-0.29.1/doc/Makefile.local   2019-06-12 01:16:48.0 
+0200
@@ -4,7 +4,7 @@
 
 # You can set these variables from the command line.
 SPHINXOPTS:= -q
-SPHINXBUILD   = HAVE_EMACS=${HAVE_EMACS} sphinx-build
+SPHINXBUILD   = HAVE_EMACS=${HAVE_EMACS} WITH_EMACS=${WITH_EMACS} sphinx-build
 DOCBUILDDIR  := $(dir)/_build
 
 # Internal variables.
@@ -28,7 +28,11 @@
 MAN1_TEXI := $(patsubst 
$(srcdir)/doc/man1/%.rst,$(DOCBUILDDIR)/texinfo/%.texi,$(MAN1_RST))
 

commit gssproxy for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package gssproxy for openSUSE:Factory 
checked in at 2019-07-02 10:38:50

Comparing /work/SRC/openSUSE:Factory/gssproxy (Old)
 and  /work/SRC/openSUSE:Factory/.gssproxy.new.4615 (New)


Package is "gssproxy"

Tue Jul  2 10:38:50 2019 rev:2 rq:712804 version:0.8.2

Changes:

--- /work/SRC/openSUSE:Factory/gssproxy/gssproxy.changes2017-10-09 
19:48:50.105964911 +0200
+++ /work/SRC/openSUSE:Factory/.gssproxy.new.4615/gssproxy.changes  
2019-07-02 10:38:51.770624453 +0200
@@ -1,0 +2,18 @@
+Mon Jul  1 10:35:35 UTC 2019 - Tomáš Chvátal 
+
+- Add patch to disable one test that fails in OBS only:
+  * disable-failing-test.patch
+
+---
+Wed May 22 07:38:02 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.8.2:
+  * no actual changelog, many bugfixes and friends
+- Remove no longer appplicable stuff:
+  * 0001-Add-support-for-the-NO_CI_FLAG-credentials-option.REVERT
+  * 0002-Add-test-to-check-setting-cred-options.REVERT
+  * 0003-Include-header-for-writev.patch
+  * gp_config.fix
+- Remove localy created .pc files
+
+---

Old:

  0001-Add-support-for-the-NO_CI_FLAG-credentials-option.REVERT
  0002-Add-test-to-check-setting-cred-options.REVERT
  0003-Include-header-for-writev.patch
  gp_config.fix
  gssproxy-0.7.0.tar.gz
  ini_config.pc
  libverto.pc

New:

  disable-failing-test.patch
  gssproxy-0.8.2.tar.gz



Other differences:
--
++ gssproxy.spec ++
--- /var/tmp/diff_new_pack.XNJc0Q/_old  2019-07-02 10:38:52.286625239 +0200
+++ /var/tmp/diff_new_pack.XNJc0Q/_new  2019-07-02 10:38:52.290625244 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gssproxy
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,35 +12,39 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   gssproxy
-Version:0.7.0
+Version:0.8.2
 Release:0
 Summary:Daemon for managing gss-api requests
 License:MIT
 Group:  Productivity/Networking/System
-Url:https://pagure.io/gssproxy
+URL:https://pagure.io/gssproxy
 Source0:https://releases.pagure.org/gssproxy/%{name}-%{version}.tar.gz
-Source1:libverto.pc
-Source2:ini_config.pc
-Patch2: gp_config.fix
-Patch3: 0001-Add-support-for-the-NO_CI_FLAG-credentials-option.REVERT
-Patch4: 0002-Add-test-to-check-setting-cred-options.REVERT
-Patch5: 0003-Include-header-for-writev.patch
+# PATCH-FIX-SUSE tchva...@suse.com disable test that fails only on OBS builds
+Patch0: disable-failing-test.patch
 BuildRequires:  docbook-xsl-stylesheets
+BuildRequires:  doxygen
+BuildRequires:  krb5-client
+BuildRequires:  krb5-plugin-kdb-ldap
 BuildRequires:  libtool
+BuildRequires:  openldap2
+BuildRequires:  openldap2-client
 BuildRequires:  pkgconfig
+BuildRequires:  systemd-rpm-macros
+BuildRequires:  valgrind
+BuildRequires:  pkgconfig(ini_config) >= 1.2.0
 BuildRequires:  pkgconfig(krb5-gssapi) >= 1.12.0
-BuildRequires:  pkgconfig(ini_config)
 BuildRequires:  pkgconfig(libselinux)
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(libxslt)
+BuildRequires:  pkgconfig(nss_wrapper)
 BuildRequires:  pkgconfig(popt)
+BuildRequires:  pkgconfig(socket_wrapper)
 BuildRequires:  pkgconfig(systemd)
-BuildRequires:  systemd-rpm-macros
 %{?systemd_requires}
 %if 0%{?suse_version} > 1315
 # in earlier versions, libverto is in krb5-devel
@@ -59,39 +63,33 @@
 
 %prep
 %setup -q
-%if 0%{?suse_version} <= 1315
-# patch is needed to disable ini_config_augment, which is
-# not available in the version on SLE12-SP1
-%patch2 -p1
-# These two patches remove use of GSS_KRB5_CRED_NO_CI_FLAGS_X
-# which was not added to krb5 until k5b5-1.14
-%patch3 -p1
-%patch4 -p1
-%endif
-%patch5 -p1
+%patch0 -p1
+# add more paths for krb binaries in tests
+sed \
+-e 
's#/sbin:/bin:%{_prefix}/sbin:%{_prefix}/bin#/sbin:/bin:%{_prefix}/sbin:%{_prefix}/bin:%{_prefix}/lib/mit/sbin#'
 \
+-i tests/runtests.py \
+-i tests/testlib.py
+# fix path for krb5 ldap schema
+sed -i \
+-e 's#%{_datadir}/doc/krb5-server-ldap\*/#%{_datadir}/kerberos/ldap/#g' \
+tests/testlib.py
 
 %build
-autoreconf -f -i
-%if 0%{?suse_version} 

commit tdom for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package tdom for openSUSE:Factory checked in 
at 2019-07-02 10:38:38

Comparing /work/SRC/openSUSE:Factory/tdom (Old)
 and  /work/SRC/openSUSE:Factory/.tdom.new.4615 (New)


Package is "tdom"

Tue Jul  2 10:38:38 2019 rev:21 rq:712763 version:0.8.3

Changes:

--- /work/SRC/openSUSE:Factory/tdom/tdom.changes2013-07-02 
07:46:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.tdom.new.4615/tdom.changes  2019-07-02 
10:38:39.394605620 +0200
@@ -1,0 +2,6 @@
+Mon Jul  1 09:03:22 UTC 2019 - Martin Liška 
+
+- Use FAT LTO objects in order to provide proper static
+  library (boo#1138797).
+
+---



Other differences:
--
++ tdom.spec ++
--- /var/tmp/diff_new_pack.ikdQ7M/_old  2019-07-02 10:38:40.238606905 +0200
+++ /var/tmp/diff_new_pack.ikdQ7M/_new  2019-07-02 10:38:40.242606911 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package tdom
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -59,6 +59,7 @@
 %patch2
 
 %build
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
 autoreconf --force
 mkdir build
 cd build




commit ccls for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package ccls for openSUSE:Factory checked in 
at 2019-07-02 10:38:28

Comparing /work/SRC/openSUSE:Factory/ccls (Old)
 and  /work/SRC/openSUSE:Factory/.ccls.new.4615 (New)


Package is "ccls"

Tue Jul  2 10:38:28 2019 rev:3 rq:712746 version:0.20190314

Changes:

--- /work/SRC/openSUSE:Factory/ccls/ccls.changes2019-06-21 
09:58:42.392690775 +0200
+++ /work/SRC/openSUSE:Factory/.ccls.new.4615/ccls.changes  2019-07-02 
10:38:29.370590366 +0200
@@ -1,0 +2,8 @@
+Mon Jul  1 08:21:11 UTC 2019 - Dan Čermák 
+
+- Drop 0001-Don-t-add-include-paths-as-SYSTEM.patch
+  Add 0001-Only-add-include-directories-for-LLVM-clang-rapidjso.patch
+  This fixes compilation issues with gcc9 in general and has been
+  upstreamed.
+
+---

Old:

  0001-Don-t-add-include-paths-as-SYSTEM.patch

New:

  0001-Only-add-include-directories-for-LLVM-clang-rapidjso.patch



Other differences:
--
++ ccls.spec ++
--- /var/tmp/diff_new_pack.WPN3yW/_old  2019-07-02 10:38:30.210591645 +0200
+++ /var/tmp/diff_new_pack.WPN3yW/_new  2019-07-02 10:38:30.214591651 +0200
@@ -27,9 +27,10 @@
 
 URL:https://github.com/MaskRay/ccls
 Source0:%{URL}/archive/%{version}/%{name}-%{version}.tar.gz
-# PATCH-FIX-UPSTREAM 0001-Don-t-add-include-paths-as-SYSTEM.patch
-# This fixes compilation failures on PowerPC, ARM & zSystem with gcc9
-Patch0: 0001-Don-t-add-include-paths-as-SYSTEM.patch
+# FIXME: drop this on the next upstream release
+# PATCH-FIX-UPSTREAM 
0001-Only-add-include-directories-for-LLVM-clang-rapidjso.patch
+# This fixes compilation failures with libstdc++ from gcc9
+Patch0: 0001-Only-add-include-directories-for-LLVM-clang-rapidjso.patch
 
 BuildRequires:  clang-devel >= 5.0
 BuildRequires:  cmake >= 3.8
@@ -70,7 +71,7 @@
 
 %build
 pushd .
-%cmake
+%cmake -DUSE_SYSTEM_RAPIDJSON=ON
 
 # ccls currently consumes ~1GB of memory during compilation per thread
 %limit_build -m 1500

++ 0001-Only-add-include-directories-for-LLVM-clang-rapidjso.patch ++
>From 990925d806989f1dbd3f703ac02f8c442492c42c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20=C4=8Cerm=C3=A1k?= 
Date: Thu, 27 Jun 2019 12:19:11 +0200
Subject: [PATCH] Only add include directories for LLVM, clang & rapidjson if
 they are not in CMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES

/usr/include/c++/9 comes before /usr/include in `{clang,gcc} -v -fsyntax-only 
-xc++ /dev/null`.

target_include_directories(ccls SYSTEM PRIVATE ${RapidJSON_INCLUDE_DIRS})

If ${RapidJSON_INCLUDE_DIRS} resolves to /usr/include, /usr/include will
be shuffled before /usr/include/c++/9 and will cause `#include_next `
issues (see https://github.com/MaskRay/ccls/pull/417).

Check if the include directories are already in 
CMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES.
---
 CMakeLists.txt | 18 +-
 1 file changed, 13 insertions(+), 5 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index efca2ba9..baaa6a39 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -143,17 +143,25 @@ set_property(SOURCE src/utils.cc APPEND PROPERTY 
COMPILE_DEFINITIONS
 
 ### Includes
 
-target_include_directories(ccls PRIVATE src)
-target_include_directories(ccls SYSTEM PRIVATE
-  third_party ${LLVM_INCLUDE_DIRS} ${CLANG_INCLUDE_DIRS})
-
 if(USE_SYSTEM_RAPIDJSON)
   find_package(RapidJSON QUIET)
 endif()
 if(NOT RapidJSON_FOUND)
   set(RapidJSON_INCLUDE_DIRS third_party/rapidjson/include)
 endif()
-target_include_directories(ccls SYSTEM PRIVATE ${RapidJSON_INCLUDE_DIRS})
+
+target_include_directories(ccls PRIVATE src)
+
+foreach(include_dir third_party
+${LLVM_INCLUDE_DIRS} ${CLANG_INCLUDE_DIRS} ${RapidJSON_INCLUDE_DIRS})
+  get_filename_component(include_dir_realpath ${include_dir} REALPATH)
+  # Don't add as SYSTEM if they are in CMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES.
+  # It would reorder the system search paths and cause issues with libstdc++'s
+  # use of #include_next. See https://github.com/MaskRay/ccls/pull/417
+  if(NOT "${include_dir_realpath}" IN_LIST 
CMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES)
+target_include_directories(ccls SYSTEM PRIVATE ${include_dir})
+  endif()
+endforeach()
 
 ### Install
 
-- 
2.22.0




commit aqute-bnd for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package aqute-bnd for openSUSE:Factory 
checked in at 2019-07-02 10:38:40

Comparing /work/SRC/openSUSE:Factory/aqute-bnd (Old)
 and  /work/SRC/openSUSE:Factory/.aqute-bnd.new.4615 (New)


Package is "aqute-bnd"

Tue Jul  2 10:38:40 2019 rev:4 rq:712778 version:3.5.0

Changes:

--- /work/SRC/openSUSE:Factory/aqute-bnd/aqute-bnd.changes  2019-03-27 
16:22:41.983513557 +0100
+++ /work/SRC/openSUSE:Factory/.aqute-bnd.new.4615/aqute-bnd.changes
2019-07-02 10:38:41.518608852 +0200
@@ -1,0 +2,5 @@
+Wed Jun 26 15:29:03 UTC 2019 - Fridrich Strba 
+
+- Add aliases for the aqute-bnd artifact
+
+---



Other differences:
--
++ aqute-bnd.spec ++
--- /var/tmp/diff_new_pack.mGEqVw/_old  2019-07-02 10:38:43.118611287 +0200
+++ /var/tmp/diff_new_pack.mGEqVw/_new  2019-07-02 10:38:43.122611293 +0200
@@ -173,7 +173,7 @@
 install -pm 0644 biz.aQute.bndlib/pom.xml 
%{buildroot}%{_mavenpomdir}/%{name}/biz.aQute.bndlib.pom
 %add_maven_depmap %{name}/biz.aQute.bndlib.pom %{name}/biz.aQute.bndlib.jar -f 
bndlib -a biz.aQute.bnd:bndlib,biz.aQute:bndlib
 install -pm 0644 biz.aQute.bnd/pom.xml 
%{buildroot}%{_mavenpomdir}/%{name}/biz.aQute.bnd.pom
-%add_maven_depmap %{name}/biz.aQute.bnd.pom %{name}/biz.aQute.bnd.jar
+%add_maven_depmap %{name}/biz.aQute.bnd.pom %{name}/biz.aQute.bnd.jar -a 
biz.aQute.bnd:bnd,biz.aQute:bnd
 # javadoc
 install -dm 0755 %{buildroot}%{_javadocdir}/%{name}
 mv biz.aQute.bnd.annotation/target/site/apidocs 
%{buildroot}%{_javadocdir}/%{name}/biz.aQute.bnd.annotation




commit jansi for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package jansi for openSUSE:Factory checked 
in at 2019-07-02 10:38:45

Comparing /work/SRC/openSUSE:Factory/jansi (Old)
 and  /work/SRC/openSUSE:Factory/.jansi.new.4615 (New)


Package is "jansi"

Tue Jul  2 10:38:45 2019 rev:3 rq:712780 version:1.17.1

Changes:

--- /work/SRC/openSUSE:Factory/jansi/jansi.changes  2019-04-11 
12:19:30.796998284 +0200
+++ /work/SRC/openSUSE:Factory/.jansi.new.4615/jansi.changes2019-07-02 
10:38:46.466616381 +0200
@@ -1,0 +2,7 @@
+Thu Jun 27 07:34:53 UTC 2019 - Fridrich Strba 
+
+- Remove the reference to jansi-project parent from jansi pom
+- Resolve manually jansi-native-version variable so that ivy
+  understands it
+
+---



Other differences:
--
++ jansi.spec ++
--- /var/tmp/diff_new_pack.hjMzdx/_old  2019-07-02 10:38:46.934617094 +0200
+++ /var/tmp/diff_new_pack.hjMzdx/_new  2019-07-02 10:38:46.938617100 +0200
@@ -75,7 +75,11 @@
 %pom_remove_dep :jansi-linux64
 popd
 
-%pom_remove_parent .
+%pom_remove_parent jansi
+%pom_xpath_inject pom:project "
+  org.fusesource.jansi
+  %{version}" jansi
+%pom_change_dep ::\${jansi-native-version} ::1.8 jansi
 
 %build
 mkdir -p jansi/lib
@@ -93,8 +97,6 @@
 install -pm 0644 jansi/target/%{name}-%{version}.jar 
%{buildroot}%{_javadir}/%{name}/%{name}.jar
 # pom
 install -dm 0755 %{buildroot}%{_mavenpomdir}/%{name}
-install -pm 0644 pom.xml 
%{buildroot}%{_mavenpomdir}/%{name}/%{name}-project.pom
-%add_maven_depmap %{name}/%{name}-project.pom
 install -pm 0644 jansi/pom.xml %{buildroot}%{_mavenpomdir}/%{name}/%{name}.pom
 %add_maven_depmap %{name}/%{name}.pom %{name}/%{name}.jar
 # javadoc




commit tkimg for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package tkimg for openSUSE:Factory checked 
in at 2019-07-02 10:38:34

Comparing /work/SRC/openSUSE:Factory/tkimg (Old)
 and  /work/SRC/openSUSE:Factory/.tkimg.new.4615 (New)


Package is "tkimg"

Tue Jul  2 10:38:34 2019 rev:19 rq:712762 version:1.4

Changes:

--- /work/SRC/openSUSE:Factory/tkimg/tkimg.changes  2013-07-23 
20:59:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.tkimg.new.4615/tkimg.changes2019-07-02 
10:38:37.294602425 +0200
@@ -1,0 +2,6 @@
+Mon Jul  1 09:04:46 UTC 2019 - Martin Liška 
+
+- Use FAT LTO objects in order to provide proper static
+  library (boo#1138797).
+
+---



Other differences:
--
++ tkimg.spec ++
--- /var/tmp/diff_new_pack.ho5U4K/_old  2019-07-02 10:38:37.818603222 +0200
+++ /var/tmp/diff_new_pack.ho5U4K/_new  2019-07-02 10:38:37.822603228 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package tkimg
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -47,6 +47,7 @@
 %setup -q -n %name%{version}
 
 %build
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
 %configure \
 --libdir=%tcl_archdir \
 --with-tcl=%_libdir \




commit aws-cli for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package aws-cli for openSUSE:Factory checked 
in at 2019-07-02 10:38:23

Comparing /work/SRC/openSUSE:Factory/aws-cli (Old)
 and  /work/SRC/openSUSE:Factory/.aws-cli.new.4615 (New)


Package is "aws-cli"

Tue Jul  2 10:38:23 2019 rev:26 rq:712413 version:1.16.189

Changes:

--- /work/SRC/openSUSE:Factory/aws-cli/aws-cli.changes  2019-06-27 
15:25:22.741388323 +0200
+++ /work/SRC/openSUSE:Factory/.aws-cli.new.4615/aws-cli.changes
2019-07-02 10:38:24.994583707 +0200
@@ -1,0 +2,9 @@
+Fri Jun 28 12:33:49 UTC 2019 - John Paul Adrian Glaubitz 

+
+- Update to version 1.16.189
+  + For detailed changes see
+https://github.com/aws/aws-cli/blob/1.16.189/CHANGELOG.rst
+  + Forward port hide_py_pckgmgmt.patch
+  + Update Requires in spec file from setup.py
+
+---

Old:

  aws-cli-1.16.182.tar.gz

New:

  aws-cli-1.16.189.tar.gz



Other differences:
--
++ aws-cli.spec ++
--- /var/tmp/diff_new_pack.yG5jSb/_old  2019-07-02 10:38:25.666584730 +0200
+++ /var/tmp/diff_new_pack.yG5jSb/_new  2019-07-02 10:38:25.670584736 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   aws-cli
-Version:1.16.182
+Version:1.16.189
 Release:0
 Summary:Amazon Web Services Command Line Interface
 License:Apache-2.0
@@ -30,7 +30,7 @@
 Requires:   python3
 Requires:   python3-PyYAML <= 6.0.0
 Requires:   python3-PyYAML >= 3.10
-Requires:   python3-botocore  >= 1.12.172
+Requires:   python3-botocore  >= 1.12.179
 Requires:   python3-colorama  <= 0.4.1
 Requires:   python3-colorama  >= 0.2.5
 Requires:   python3-docutils  >= 0.10

++ aws-cli-1.16.182.tar.gz -> aws-cli-1.16.189.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aws-cli-1.16.182/.changes/1.16.183.json 
new/aws-cli-1.16.189/.changes/1.16.183.json
--- old/aws-cli-1.16.182/.changes/1.16.183.json 1970-01-01 01:00:00.0 
+0100
+++ new/aws-cli-1.16.189/.changes/1.16.183.json 2019-06-27 20:24:53.0 
+0200
@@ -0,0 +1,32 @@
+[
+  {
+"category": "``rds``", 
+"description": "Update rds command to latest version", 
+"type": "api-change"
+  }, 
+  {
+"category": "``opsworks``", 
+"description": "Update opsworks command to latest version", 
+"type": "api-change"
+  }, 
+  {
+"category": "``glue``", 
+"description": "Update glue command to latest version", 
+"type": "api-change"
+  }, 
+  {
+"category": "``acm-pca``", 
+"description": "Update acm-pca command to latest version", 
+"type": "api-change"
+  }, 
+  {
+"category": "``health``", 
+"description": "Update health command to latest version", 
+"type": "api-change"
+  }, 
+  {
+"category": "``iotevents-data``", 
+"description": "Update iotevents-data command to latest version", 
+"type": "api-change"
+  }
+]
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aws-cli-1.16.182/.changes/1.16.184.json 
new/aws-cli-1.16.189/.changes/1.16.184.json
--- old/aws-cli-1.16.182/.changes/1.16.184.json 1970-01-01 01:00:00.0 
+0100
+++ new/aws-cli-1.16.189/.changes/1.16.184.json 2019-06-27 20:24:53.0 
+0200
@@ -0,0 +1,22 @@
+[
+  {
+"category": "``mediapackage``", 
+"description": "Update mediapackage command to latest version", 
+"type": "api-change"
+  }, 
+  {
+"category": "``devicefarm``", 
+"description": "Update devicefarm command to latest version", 
+"type": "api-change"
+  }, 
+  {
+"category": "``kinesis-video-media``", 
+"description": "Update kinesis-video-media command to latest version", 
+"type": "api-change"
+  }, 
+  {
+"category": "``iam``", 
+"description": "Update iam command to latest version", 
+"type": "api-change"
+  }
+]
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aws-cli-1.16.182/.changes/1.16.185.json 
new/aws-cli-1.16.189/.changes/1.16.185.json
--- old/aws-cli-1.16.182/.changes/1.16.185.json 1970-01-01 01:00:00.0 
+0100
+++ new/aws-cli-1.16.189/.changes/1.16.185.json 2019-06-27 20:24:53.0 
+0200
@@ -0,0 +1,47 @@
+[
+  {
+"category": "``apigateway``", 
+"description": "Update apigateway command to latest version", 
+"type": "api-change"
+  }, 
+  {
+"category": "``ssm``", 
+"description": "Update ssm command to latest version", 
+"type": "api-change"
+  }, 
+  {
+"category": "``apigatewayv2``", 
+"description": "Update apigatewayv2 command to latest version", 
+"type": 

commit courier-imap for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package courier-imap for openSUSE:Factory 
checked in at 2019-07-02 10:38:00

Comparing /work/SRC/openSUSE:Factory/courier-imap (Old)
 and  /work/SRC/openSUSE:Factory/.courier-imap.new.4615 (New)


Package is "courier-imap"

Tue Jul  2 10:38:00 2019 rev:52 rq:710237 version:4.18.2

Changes:

--- /work/SRC/openSUSE:Factory/courier-imap/courier-imap.changes
2019-02-08 12:11:05.757521160 +0100
+++ /work/SRC/openSUSE:Factory/.courier-imap.new.4615/courier-imap.changes  
2019-07-02 10:38:03.786551435 +0200
@@ -1,0 +2,6 @@
+Tue Jun 11 12:38:44 UTC 2019 - Dominique Leuenberger 
+
+- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
+  shortcut the build queues by allowing usage of systemd-mini
+
+---



Other differences:
--
++ courier-imap.spec ++
--- /var/tmp/diff_new_pack.V8ywBX/_old  2019-07-02 10:38:04.638552731 +0200
+++ /var/tmp/diff_new_pack.V8ywBX/_new  2019-07-02 10:38:04.638552731 +0200
@@ -75,7 +75,7 @@
 Requires:   openssl
 
 %if 0%{?suse_version} >= 1210
-BuildRequires:  systemd
+BuildRequires:  pkgconfig(systemd)
 %{?systemd_requires}
 %define has_systemd 1
 %endif





commit bzip2 for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package bzip2 for openSUSE:Factory checked 
in at 2019-07-02 10:37:05

Comparing /work/SRC/openSUSE:Factory/bzip2 (Old)
 and  /work/SRC/openSUSE:Factory/.bzip2.new.4615 (New)


Package is "bzip2"

Tue Jul  2 10:37:05 2019 rev:64 rq:712352 version:1.0.7

Changes:

--- /work/SRC/openSUSE:Factory/bzip2/bzip2.changes  2019-04-26 
22:41:17.513740283 +0200
+++ /work/SRC/openSUSE:Factory/.bzip2.new.4615/bzip2.changes2019-07-02 
10:37:07.882466364 +0200
@@ -1,0 +2,23 @@
+Fri Jun 28 07:42:24 UTC 2019 - Martin Pluskal 
+
+- Update bug reference
+- Fix downloaded patches
+
+---
+Thu Jun 27 21:01:36 UTC 2019 - Bjørn Lie 
+
+- Update to version 1.0.7:
+  * Fix undefined behavior in the macros SET_BH, CLEAR_BH, &
+ISSET_BH.
+  * bzip2: Fix return value when combining --test,-t and -q.
+  * bzip2recover: Fix buffer overflow for large argv[0].
+  * bzip2recover: Fix use after free issue with outFile
+(CVE-2016-3189).
+  * Make sure nSelectors is not out of range (CVE-2019-12900
+bsc#1139083)
+- Drop patches fixed upstream:
+  * bzip2-unsafe_strcpy.patch.
+  * bzip2-1.0.6-CVE-2016-3189.patch.
+- Refresh patches with quilt.
+
+---

Old:

  bzip2-1.0.6-CVE-2016-3189.patch
  bzip2-1.0.6.tar.gz
  bzip2-unsafe_strcpy.patch

New:

  bzip2-1.0.7.tar.gz



Other differences:
--
++ bzip2.spec ++
--- /var/tmp/diff_new_pack.lePdUM/_old  2019-07-02 10:37:08.830467806 +0200
+++ /var/tmp/diff_new_pack.lePdUM/_new  2019-07-02 10:37:08.834467812 +0200
@@ -12,13 +12,13 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 %define libname libbz2-1
 Name:   bzip2
-Version:1.0.6
+Version:1.0.7
 Release:0
 Summary:A Program for Compressing Files
 License:BSD-3-Clause
@@ -32,12 +32,10 @@
 # PATCH-FEATURE-OPENSUSE bzip2-1.0.6-autoconfiscated.patch sbra...@suse.cz -- 
Convert to a standard autoconf based package.
 Patch0: 
ftp://ftp.suse.com/pub/people/sbrabec/bzip2/for_downstream/bzip2-1.0.6.2-autoconfiscated.patch
 Patch1: bzip2-1.0.6-fix-bashisms.patch
-Patch2: bzip2-unsafe_strcpy.patch
 Patch3: bzip2-point-to-doc-pkg.patch
 Patch4: bzip2-ocloexec.patch
 # PATCH-FIX-UPSTREAM bnc#970260 kstreit...@suse.com -- fix a wrong exit code 
when grepping multiple archives
 Patch5: bzip2-1.0.6-bzgrep_return_value.patch
-Patch6: bzip2-1.0.6-CVE-2016-3189.patch
 BuildRequires:  autoconf >= 2.57
 BuildRequires:  libtool
 BuildRequires:  pkgconfig
@@ -77,11 +75,9 @@
 %setup -q
 %patch0
 %patch1 -p1
-%patch2
 %patch3 -p1
-%patch4
+%patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 %build
 autoreconf -fiv
@@ -91,7 +87,7 @@
 %if 0%{?do_profiling}
   make %{?_smp_mflags} CFLAGS="%{optflags} %{cflags_profile_generate}"
   make %{?_smp_mflags} CFLAGS="%{optflags} %{cflags_profile_generate}" test
-  make clean
+  make %{?_smp_mflags} clean
   make %{?_smp_mflags} CFLAGS="%{optflags} %{cflags_profile_feedback}"
 %else
   make %{?_smp_mflags} CFLAGS="%{optflags}"

++ bzip2-1.0.6-bzgrep_return_value.patch ++
--- /var/tmp/diff_new_pack.lePdUM/_old  2019-07-02 10:37:08.878467880 +0200
+++ /var/tmp/diff_new_pack.lePdUM/_new  2019-07-02 10:37:08.878467880 +0200
@@ -1,7 +1,7 @@
-Index: bzip2-1.0.6/bzgrep
+Index: bzip2-1.0.7/bzgrep
 ===
 bzip2-1.0.6.orig/bzgrep
-+++ bzip2-1.0.6/bzgrep
+--- bzip2-1.0.7.orig/bzgrep2019-06-27 23:10:21.375272508 +0200
 bzip2-1.0.7/bzgrep 2019-06-27 23:10:21.415272635 +0200
 @@ -65,8 +65,20 @@ for i do
else
  j=$(echo "$i" | sed 's/\\/&&/g;s/|/\\&/g;s/&/\\&/g')

++ bzip2-1.0.6-fix-bashisms.patch ++
--- /var/tmp/diff_new_pack.lePdUM/_old  2019-07-02 10:37:08.890467898 +0200
+++ /var/tmp/diff_new_pack.lePdUM/_new  2019-07-02 10:37:08.890467898 +0200
@@ -1,6 +1,7 @@
-diff -Ndurp bzip2-1.0.6/bzgrep bzip2-1.0.6-fix-bashisms/bzgrep
 bzip2-1.0.6/bzgrep 2007-01-03 04:00:55.0 +0200
-+++ bzip2-1.0.6-fix-bashisms/bzgrep2014-10-19 02:07:30.036033876 +0300
+Index: bzip2-1.0.7/bzgrep
+===
+--- bzip2-1.0.7.orig/bzgrep2019-06-27 20:15:39.0 +0200
 bzip2-1.0.7/bzgrep 2019-06-27 23:12:37.027916706 +0200
 @@ -63,9 +63,7 @@ for i do
  bzip2 -cdfq "$i" | $grep $opt "$pat"
  r=$?

++ bzip2-1.0.6.tar.gz -> 

commit guile for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package guile for openSUSE:Factory checked 
in at 2019-07-02 10:37:19

Comparing /work/SRC/openSUSE:Factory/guile (Old)
 and  /work/SRC/openSUSE:Factory/.guile.new.4615 (New)


Package is "guile"

Tue Jul  2 10:37:19 2019 rev:57 rq:712657 version:2.2.5

Changes:

--- /work/SRC/openSUSE:Factory/guile/guile.changes  2019-02-04 
21:21:23.947654235 +0100
+++ /work/SRC/openSUSE:Factory/.guile.new.4615/guile.changes2019-07-02 
10:37:21.814487565 +0200
@@ -1,0 +2,43 @@
+Tue Jun 25 08:02:58 UTC 2019 - Jonathan Brielmaier 
+
+- Update to version 2.2.5 
+  Notable changes compared to 2.2.5:
+  * Notable improvements
+  ** Greatly improved performance of bidirectional pipes.
+  ** New 'get-bytevector-some!' I/O primitive.
+  ** get-bytevector-{n!,some,some!} now support suspendable I/O.
+  * Compiler improvements
+  ** guild compile: Add -Wshadowed-toplevel.
+  ** guild compile: Add '-x' flag.
+  * Miscellaneous improvements
+  ** Bootstrap optimization
+  ** put-u8 now always writes a single byte, regardless of the port encoding.
+  ** Optimize fixnum exact integer square roots.
+  ** scm_mkstrport: Optimize the POS -> BYTE_POS conversion.
+  ** SRFI-19: Support ~N in string->date.
+  ** SRFI-19: Update the leap second table.
+  ** stexi->shtml: Add support for @i, @math, @tie and @dots.
+  ** Define AT_SYMLINK_NOFOLLOW, AT_NO_AUTOMOUNT, and AT_EMPTY_PATH.
+  ** Improvements to the 'time' macro from (ice-9 time).
+  * Bug fixes
+  ** Avoid regexp ranges in HTTP inter-protocol exploitation check.
+  ** Fixes to the SRFI-19 time/date library.
+  ** Improve overflow checks in bytevector, string, and I/O operations.
+  ** Fix type inferencing for 'nil?' and 'null?' predicates.
+  ** Fix 'atomic-box-compare-and-swap!'.
+  ** Make URI handling locale independent.
+  ** Strings, i18n: Limit the use of alloca to approximately 8 kilobytes.
+  ** Fix documentation of R6RS 'binary-port?' to reflect reality.
+  ** Avoid passing NULL to 'memcpy' and 'memcmp'.
+  ** Save and restore errno in the signal handler.
+  ** Various smaller bug fixes
+  More details: /usr/share/doc/packages/guile/NEWS
+- add patches:
+  * revert-http-reader-change.patch: Fixes https://bugs.gnu.org/36350.
+- remove patches:
+  * guile-add-test-ja_JP.sjis.patch: proper fix included in 2.2.5
+  * guile-use-utf8.patch: included in 2.2.5
+  * disable-posix-crypt-test.patch: test succeeds now 
+- reorder patches
+
+---

Old:

  disable-posix-crypt-test.patch
  guile-2.2.4.tar.xz
  guile-2.2.4.tar.xz.sig
  guile-add-test-ja_JP.sjis.patch
  guile-use-utf8.patch

New:

  guile-2.2.5.tar.xz
  guile-2.2.5.tar.xz.sig
  revert-http-reader-change.patch



Other differences:
--
++ guile.spec ++
--- /var/tmp/diff_new_pack.bzPC71/_old  2019-07-02 10:37:22.690488898 +0200
+++ /var/tmp/diff_new_pack.bzPC71/_new  2019-07-02 10:37:22.690488898 +0200
@@ -23,7 +23,7 @@
 %define libgver 1
 %define gsuff   %{guilemaj}_%{guilemin}-%{libgver}
 Name:   guile
-Version:%{guilevers}.4
+Version:%{guilevers}.5
 Release:0
 Summary:GNU's Ubiquitous Intelligent Language for Extension
 License:GFDL-1.3-only AND GPL-3.0-or-later AND LGPL-3.0-or-later
@@ -33,13 +33,12 @@
 Source1:https://ftp.gnu.org/gnu/guile/%{name}-%{version}.tar.xz.sig
 Source2:
https://savannah.gnu.org/project/memberlist-gpgkeys.php?group=guile=1#/%{name}.keyring
 Source3:guile-rpmlintrc
-Patch0: guile-2.2-gc_pkgconfig_private.patch
-Patch1: guile-add-test-ja_JP.sjis.patch
-Patch2: guile-use-utf8.patch
-# glibc EINVAL failure
-Patch3: disable-posix-crypt-test.patch
+# PATCH-FIX-UPSTREAM revert-http-reader-change.patch https://bugs.gnu.org/36350
+Patch0: revert-http-reader-change.patch
+# Fix the resulting /usr/lib64/pkgconfig/guile-2.2.pc
+Patch1: guile-2.2-gc_pkgconfig_private.patch
 # test fails always with heap error
-Patch4: disable-test-out-of-memory.patch
+Patch2: disable-test-out-of-memory.patch
 BuildRequires:  gmp-devel
 BuildRequires:  libffi-devel
 BuildRequires:  libltdl-devel
@@ -105,10 +104,7 @@
 %setup -q
 %patch0 -p1
 %patch1 -p1
-chmod +x test-suite/standalone/test-ja_JP.sjis
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 # remove broken prebuilt objects
 rm -r prebuilt/32-bit-big-endian

++ guile-2.2.4.tar.xz -> guile-2.2.5.tar.xz ++
/work/SRC/openSUSE:Factory/guile/guile-2.2.4.tar.xz 
/work/SRC/openSUSE:Factory/.guile.new.4615/guile-2.2.5.tar.xz differ: char 26, 
line 1


++ revert-http-reader-change.patch ++
>From e1225d013ed8673382d6d8f9300dd6b175c8b820 Mon Sep 17 

commit courier-authlib for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package courier-authlib for openSUSE:Factory 
checked in at 2019-07-02 10:37:57

Comparing /work/SRC/openSUSE:Factory/courier-authlib (Old)
 and  /work/SRC/openSUSE:Factory/.courier-authlib.new.4615 (New)


Package is "courier-authlib"

Tue Jul  2 10:37:57 2019 rev:43 rq:710236 version:0.68.0

Changes:

--- /work/SRC/openSUSE:Factory/courier-authlib/courier-authlib.changes  
2019-04-09 20:19:26.057903632 +0200
+++ 
/work/SRC/openSUSE:Factory/.courier-authlib.new.4615/courier-authlib.changes
2019-07-02 10:37:58.258543023 +0200
@@ -1,0 +2,6 @@
+Tue Jun 11 12:38:04 UTC 2019 - Dominique Leuenberger 
+
+- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
+  shortcut the build queues by allowing usage of systemd-mini
+
+---



Other differences:
--
++ courier-authlib.spec ++
--- /var/tmp/diff_new_pack.LzEJnd/_old  2019-07-02 10:37:59.002544155 +0200
+++ /var/tmp/diff_new_pack.LzEJnd/_new  2019-07-02 10:37:59.006544161 +0200
@@ -50,7 +50,7 @@
 Requires:   expect
 
 %if 0%{?suse_version} >= 1210
-BuildRequires:  systemd
+BuildRequires:  pkgconfig(systemd)
 %{?systemd_requires}
 %define has_systemd 1
 %endif





commit rubygem-fog-json for openSUSE:Factory

2019-07-02 Thread root
Hello community,

here is the log from the commit of package rubygem-fog-json for 
openSUSE:Factory checked in at 2019-07-02 10:37:48

Comparing /work/SRC/openSUSE:Factory/rubygem-fog-json (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-fog-json.new.4615 (New)


Package is "rubygem-fog-json"

Tue Jul  2 10:37:48 2019 rev:1 rq:709710 version:1.2.0

Changes:

New Changes file:

--- /dev/null   2019-06-21 11:18:06.406367250 +0200
+++ 
/work/SRC/openSUSE:Factory/.rubygem-fog-json.new.4615/rubygem-fog-json.changes  
2019-07-02 10:37:50.122530642 +0200
@@ -0,0 +1,49 @@
+---
+Fri Jun 22 09:04:37 UTC 2018 - factory-a...@kulow.org
+
+- updated to version 1.2.0
+ see installed CHANGELOG.md
+
+  v1.2.0
+  
+  * Fix time parsing issue
+  * Remove duplicated software licence
+  * Remove `fog-core` version dependency
+
+---
+Tue Jan  9 07:29:04 UTC 2018 - co...@suse.com
+
+- updated to version 1.1.0
+ see installed CHANGELOG.md
+
+  v1.1.0
+  
+  * bump fog-core dependency
+
+---
+Sun May 31 04:31:04 UTC 2015 - co...@suse.com
+
+- updated to version 1.0.2
+ see installed CHANGELOG.md
+
+  v1.0.2
+  
+  Changes:
+  
+  * bump multi-json dependency
+
+---
+Wed Apr  8 04:34:59 UTC 2015 - co...@suse.com
+
+- updated to version 1.0.1
+
+---
+Mon Oct 13 12:09:11 UTC 2014 - co...@suse.com
+
+- adapt to new rubygem packaging
+
+---
+Mon Jun  2 13:14:56 UTC 2014 - tboer...@suse.com
+
+- Initial packaging of version 1.0.0
+

New:

  fog-json-1.2.0.gem
  gem2rpm.yml
  rubygem-fog-json.changes
  rubygem-fog-json.spec



Other differences:
--
++ rubygem-fog-json.spec ++
#
# spec file for package rubygem-fog-json
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


#
# This file was generated with a gem2rpm.yml and not just plain gem2rpm.
# All sections marked as MANUAL, license headers, summaries and descriptions
# can be maintained in that file. Please consult this file before editing any
# of those fields
#

Name:   rubygem-fog-json
Version:1.2.0
Release:0
%define mod_name fog-json
%define mod_full_name %{mod_name}-%{version}
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
BuildRequires:  %{rubygem gem2rpm}
BuildRequires:  %{ruby}
BuildRequires:  ruby-macros >= 5
Url:http://github.com/fog/fog-json
Source: https://rubygems.org/gems/%{mod_full_name}.gem
Source1:gem2rpm.yml
Summary:JSON parsing for fog providers
License:MIT
Group:  Development/Languages/Ruby

%description
Extraction of the JSON parsing tools shared between a
number of providers in the 'fog' gem.

%prep

%build

%install
%gem_install \
  --doc-files="CHANGELOG.md LICENSE.md README.md" \
  -f

%gem_packages

%changelog
++ gem2rpm.yml ++
# ---
# ## used by gem2rpm
# :summary: this is a custom summary
# ## used by gem2rpm
# :description: |-
#   this is a custom description
#
#   it can be multiline
# ## used by gem2rpm
# :license: MIT or Ruby
# ## used by gem2rpm and gem_packages
# :version_suffix: -x_y
# ## used by gem2rpm and gem_packages
# :disable_docs: true
# ## used by gem2rpm
# :disable_automatic_rdoc_dep: true
# ## used by gem2rpm
# :preamble: |-
#   BuildRequires: foobar
#   Requires: foobar
# ## used by gem2rpm
# :patches:
#   foo.patch: -p1
#   bar.patch: 
# ## used by gem2rpm
:sources:
# - foo.desktop
# - bar.desktop
# :gem_install_args: ''
# ## used by gem2rpm
# :pre_install: |-
#   %if 0%{?use_system_libev}
#   export USE_VENDORED_LIBEV="no"
#   %endif
# ## used by gem2rpm
# :post_install: |-
#   # delete custom files here or do other fancy stuff
#   install -D -m 0644 %{S:1} %{buildroot}%{_bindir}/gem2rpm-opensuse
# ## used by gem2rpm
# :testsuite_command: |-
#   (pushd