commit 000product for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-07-24 03:06:05

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.4126 (New)


Package is "000product"

Wed Jul 24 03:06:05 2019 rev:1447 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ openSUSE-Addon-NonOss-ftp-ftp-i586_x86_64.kiwi ++
--- /var/tmp/diff_new_pack.kmPJfy/_old  2019-07-24 03:06:08.319747121 +0200
+++ /var/tmp/diff_new_pack.kmPJfy/_new  2019-07-24 03:06:08.319747121 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -36,11 +36,11 @@
   true
   -x -2
   openSUSE
-  20190722
+  20190723
   11
-  cpe:/o:opensuse:opensuse-addon-nonoss:20190722,openSUSE NonOSS 
Addon
+  cpe:/o:opensuse:opensuse-addon-nonoss:20190723,openSUSE NonOSS 
Addon
   af ar be_BY bg br ca cy el et ga gl gu_IN he 
hi_IN hr ka km ko lt mk nn pa_IN rw sk sl sr_CS ss st tg th tr uk ve vi xh zu 

-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190722/i586
 
obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190722/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190723/i586
 
obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190723/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.kmPJfy/_old  2019-07-24 03:06:08.335747118 +0200
+++ /var/tmp/diff_new_pack.kmPJfy/_new  2019-07-24 03:06:08.335747118 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20190722
+  20190723
   11
-  cpe:/o:opensuse:opensuse-microos:20190722,openSUSE 
MicroOS
+  cpe:/o:opensuse:opensuse-microos:20190723,openSUSE 
MicroOS
   en_US 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20190722/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20190723/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
++ openSUSE-cd-mini-i586.kiwi ++
--- /var/tmp/diff_new_pack.kmPJfy/_old  2019-07-24 03:06:08.459747093 +0200
+++ /var/tmp/diff_new_pack.kmPJfy/_new  2019-07-24 03:06:08.471747091 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,11 +32,11 @@
   true
   -x -2
   openSUSE
-  20190722
+  20190723
   11
-  cpe:/o:opensuse:opensuse:20190722,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20190723,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190722/i586
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190723/i586
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-cd-mini-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.kmPJfy/_old  2019-07-24 03:06:08.795747028 +0200
+++ /var/tmp/diff_new_pack.kmPJfy/_new  2019-07-24 03:06:08.815747024 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20190722
+  20190723
   11
-  cpe:/o:opensuse:opensuse:20190722,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20190723,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190722/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190723/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-dvd5-dvd-i586.kiwi ++
--- /var/tmp/diff_new_pack.kmPJfy/_old  2019-07-24 03:06:09.047746979 +0200
+++ /var/tmp/diff_new_pack.kmPJfy/_new  2019-07-24 03:06:09.047746979 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,11 +32,11 @@
   true
   -x -2
   openSUSE
-  20190722
+  20190723
   11
-  cpe:/o:opensuse:opensuse:20190722,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20190723,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  

commit 000release-packages for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package 000release-packages for 
openSUSE:Factory checked in at 2019-07-24 03:05:59

Comparing /work/SRC/openSUSE:Factory/000release-packages (Old)
 and  /work/SRC/openSUSE:Factory/.000release-packages.new.4126 (New)


Package is "000release-packages"

Wed Jul 24 03:05:59 2019 rev:208 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _service_error



Other differences:
--
++ openSUSE-Addon-NonOss-release.spec ++
--- /var/tmp/diff_new_pack.jUzNhu/_old  2019-07-24 03:06:02.135748324 +0200
+++ /var/tmp/diff_new_pack.jUzNhu/_new  2019-07-24 03:06:02.175748317 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package openSUSE-Addon-NonOss-release (Version 20190722)
+# spec file for package openSUSE-Addon-NonOss-release (Version 20190723)
 #
 # Copyright (c) 2019 openSUSE.
 #
@@ -16,16 +16,16 @@
 Name:   openSUSE-Addon-NonOss-release
 %define product openSUSE-Addon-NonOss
 Summary:openSUSE NonOSS Addon
-Version:20190722
+Version:    20190723
 Release:0
 License:BSD-3-Clause
 Group:  System/Fhs
 
 Provides:   %name-%version
 Provides:   product() = openSUSE-Addon-NonOss
-Provides:   product(openSUSE-Addon-NonOss) = 20190722-0
+Provides:   product(openSUSE-Addon-NonOss) = 20190723-0
 Provides:   product-label() = non%20oss%20addon
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Daddon%2Dnonoss%3A20190722
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Daddon%2Dnonoss%3A20190723
 
 
 AutoReqProv:on
@@ -49,10 +49,10 @@
 
   openSUSE
   openSUSE-Addon-NonOss
-  20190722
+  20190723
   0
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-addon-nonoss:20190722
+  cpe:/o:opensuse:opensuse-addon-nonoss:20190723
   
 
 

++ openSUSE-MicroOS-release.spec ++
--- /var/tmp/diff_new_pack.jUzNhu/_old  2019-07-24 03:06:02.391748275 +0200
+++ /var/tmp/diff_new_pack.jUzNhu/_new  2019-07-24 03:06:02.399748273 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   openSUSE-MicroOS-release
-Version:20190722
+Version:    20190723
 Release:0
 Summary:openSUSE MicroOS 
 License:GPL-2.0-or-later
@@ -40,9 +40,9 @@
 ExclusiveArch:  %ix86 x86_64 ppc64le s390x aarch64
 Provides:   %name-%version
 Provides:   product() = openSUSE-MicroOS
-Provides:   product(openSUSE-MicroOS) = 20190722-0
+Provides:   product(openSUSE-MicroOS) = 20190723-0
 Provides:   product-label() = openSUSE%20MicroOS
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dmicroos%3A20190722
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dmicroos%3A20190723
 Provides:   product-url(releasenotes) = 
http%3A%2F%2Fdoc.opensuse.org%2Frelease%2Dnotes%2Fx86_64%2FopenSUSE%2FTumbleweed%2Frelease%2Dnotes%2DopenSUSE.rpm
 Provides:   product-endoflife()
 Requires:   product_flavor(openSUSE-MicroOS)
@@ -58,7 +58,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(dvd)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190722-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190723-0
 Summary:openSUSE MicroOS
 
 %description dvd
@@ -74,7 +74,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(kubic-dvd)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190722-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190723-0
 Summary:openSUSE MicroOS
 
 %description kubic-dvd
@@ -90,7 +90,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(appliance)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190722-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190723-0
 Summary:openSUSE MicroOS
 
 %description appliance
@@ -106,7 +106,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(appliance-kubic)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190722-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190723-0
 Summary:openSUSE MicroOS
 
 %description appliance-kubic
@@ -164,11 +164,11 @@
 
   openSUSE
   openSUSE-MicroOS
-  20190722
+  20190723
   0
   
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-microos:20190722
+  cpe:/o:opensuse:opensuse-microos:20190723
   openSUSE-MicroOS
   
 

++ openSUSE-release.spec ++
--- /var/tmp/diff_new_pack.jUzNhu/_old  2019-07-24 03:06:02.603748233 +0200
+++ /var/tmp/diff_new_pack.jUzNhu/_new  2019-07-24 03:06:02.651748224 +0200
@@ -20,7 +20,7 @@
 #define betaversion %{nil}
 %define codename Tumbleweed
 Name:   openSUSE-release
-Version:  

commit 000product for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-07-23 22:57:00

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.4126 (New)


Package is "000product"

Tue Jul 23 22:57:00 2019 rev:1445 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi: same change
openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
openSUSE-cd-mini-i586.kiwi: same change
openSUSE-cd-mini-x86_64.kiwi: same change
openSUSE-dvd5-dvd-i586.kiwi: same change
openSUSE-dvd5-dvd-x86_64.kiwi: same change
openSUSE-ftp-ftp-i586_x86_64.kiwi: same change
stub.kiwi: same change
++ openSUSE.product ++
--- /var/tmp/diff_new_pack.7XbOO2/_old  2019-07-23 22:57:03.186149443 +0200
+++ /var/tmp/diff_new_pack.7XbOO2/_new  2019-07-23 22:57:03.190149441 +0200
@@ -4,7 +4,7 @@
 
   openSUSE
   openSUSE
-  20190722
+  20190723
   0
 
   openSUSE




commit 000product for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-07-23 22:57:05

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.4126 (New)


Package is "000product"

Tue Jul 23 22:57:05 2019 rev:1446 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi: same change
openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
openSUSE-cd-mini-i586.kiwi: same change
openSUSE-cd-mini-x86_64.kiwi: same change
openSUSE-dvd5-dvd-i586.kiwi: same change
openSUSE-dvd5-dvd-x86_64.kiwi: same change
openSUSE-ftp-ftp-i586_x86_64.kiwi: same change
stub.kiwi: same change
++ openSUSE-MicroOS.product ++
--- /var/tmp/diff_new_pack.OIA9iu/_old  2019-07-23 22:57:07.322147212 +0200
+++ /var/tmp/diff_new_pack.OIA9iu/_new  2019-07-23 22:57:07.322147212 +0200
@@ -6,7 +6,7 @@
   openSUSE-MicroOS
   openSUSE-MicroOS-release
   
-  20190722
+  20190723
   
   0
   openSUSE-MicroOS




commit python-pyface for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-pyface for openSUSE:Factory 
checked in at 2019-07-23 22:56:29

Comparing /work/SRC/openSUSE:Factory/python-pyface (Old)
 and  /work/SRC/openSUSE:Factory/.python-pyface.new.4126 (New)


Package is "python-pyface"

Tue Jul 23 22:56:29 2019 rev:3 rq:718002 version:6.1.2

Changes:

--- /work/SRC/openSUSE:Factory/python-pyface/python-pyface.changes  
2019-04-20 17:13:17.850935519 +0200
+++ /work/SRC/openSUSE:Factory/.python-pyface.new.4126/python-pyface.changes
2019-07-23 22:56:33.222165864 +0200
@@ -1,0 +2,33 @@
+Tue Jul 23 20:23:21 UTC 2019 - Todd R 
+
+- Update to 6.1.2
+  + Enhancements
+* Application classes
+* New API for Timers
+* Support simple widgets in toolbars
+* Experimental support of Pyside2
+* Support single codebase for Python 2 and 3
+* Support ui dispatch for Traits even if TraitsUI not available
+  + Fixes
+* Remove use of deprecated Traits get() method
+* Fix pyqt5 webkit imports
+* Remove use of cmp in fix_introspection_bug
+* Update CI infrastructure
+* Update unittest imports
+* Fix bug in argspec usage
+* Fix regression in DoLaterTimer API
+* Fix context menu behaviour
+* Remove TraitsUI dependency in GuiTestAssistant
+* Fixes for ProgressDialog
+* Fixes for toolbar and statusbar life cycles
+* Fixes for CI
+* Fix usages of event_loop() in tests
+* Fix SplitEditorAreaPane tab dragging on Qt5
+* Fix resource warnings in test suite from un-closed files
+* Remove uses of deprecated HasTraits.set() method
+* Add Qt5 support for deprecated Qt Style options that Mayavi needs
+* Various fixes around Qt API selection
+* Fixes for setup.py
+
+
+---

Old:

  pyface-6.0.0.tar.gz

New:

  pyface-6.1.2.tar.gz



Other differences:
--
++ python-pyface.spec ++
--- /var/tmp/diff_new_pack.01dcyW/_old  2019-07-23 22:56:33.862165502 +0200
+++ /var/tmp/diff_new_pack.01dcyW/_new  2019-07-23 22:56:33.882165491 +0200
@@ -22,7 +22,7 @@
 %define oldpython python
 %define X_display ":98"
 Name:   python-pyface
-Version:6.0.0
+Version:6.1.2
 Release:0
 Summary:Traits-capable windowing framework
 License:BSD-3-Clause and EPL-1.0 and LGPL-2.1 and LGPL-3.0 and 
SUSE-Public-Domain
@@ -31,7 +31,6 @@
 # and details are inside image_LICENSE.txt
 Url:https://github.com/enthought/pyface
 Source: 
https://files.pythonhosted.org/packages/source/p/pyface/pyface-%{version}.tar.gz
-BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module numpy}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{python_module traits}
@@ -92,7 +91,6 @@
 %endif
 
 %files %{python_files}
-%defattr(-,root,root,-)
 %doc CHANGES.txt README.rst TODO.txt
 %license LICENSE.txt image_LICENSE*.txt
 %{python_sitelib}/pyface/

++ pyface-6.0.0.tar.gz -> pyface-6.1.2.tar.gz ++
 24832 lines of diff (skipped)




commit python-pyDOE2 for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-pyDOE2 for openSUSE:Factory 
checked in at 2019-07-23 22:56:24

Comparing /work/SRC/openSUSE:Factory/python-pyDOE2 (Old)
 and  /work/SRC/openSUSE:Factory/.python-pyDOE2.new.4126 (New)


Package is "python-pyDOE2"

Tue Jul 23 22:56:24 2019 rev:3 rq:718000 version:1.2.0

Changes:

--- /work/SRC/openSUSE:Factory/python-pyDOE2/python-pyDOE2.changes  
2019-01-24 14:03:54.832017310 +0100
+++ /work/SRC/openSUSE:Factory/.python-pyDOE2.new.4126/python-pyDOE2.changes
2019-07-23 22:56:25.466170253 +0200
@@ -1,0 +2,6 @@
+Tue Jul 23 20:22:11 UTC 2019 - Todd R 
+
+- Update to version 1.2.0
+  * BUG make sure to compute the correlation coeff properly
+
+---

Old:

  pyDOE2-1.1.2.tar.gz

New:

  pyDOE2-1.2.0.tar.gz



Other differences:
--
++ python-pyDOE2.spec ++
--- /var/tmp/diff_new_pack.v81dDt/_old  2019-07-23 22:56:26.990169391 +0200
+++ /var/tmp/diff_new_pack.v81dDt/_new  2019-07-23 22:56:27.006169382 +0200
@@ -18,18 +18,16 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pyDOE2
-Version:1.1.2
+Version:1.2.0
 Release:0
 Summary:Design of experiments for Python
 License:BSD-3-Clause
 Group:  Development/Languages/Python
 Url:https://github.com/clicumu/pyDOE2
 Source: 
https://files.pythonhosted.org/packages/source/p/pyDOE2/pyDOE2-%{version}.tar.gz
-BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
-BuildRequires:  unzip
 # SECTION test requirements
 BuildRequires:  %{python_module numpy}
 BuildRequires:  %{python_module scipy}

++ pyDOE2-1.1.2.tar.gz -> pyDOE2-1.2.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pyDOE2-1.1.2/PKG-INFO new/pyDOE2-1.2.0/PKG-INFO
--- old/pyDOE2-1.1.2/PKG-INFO   2018-11-13 09:04:44.0 +0100
+++ new/pyDOE2-1.2.0/PKG-INFO   2019-04-01 09:42:12.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: pyDOE2
-Version: 1.1.2
+Version: 1.2.0
 Summary: Design of experiments for Python
 Home-page: https://github.com/clicumu/pyDOE2
 Author: Rickard Sjoegren
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pyDOE2-1.1.2/pyDOE2/doe_lhs.py 
new/pyDOE2-1.2.0/pyDOE2/doe_lhs.py
--- old/pyDOE2-1.1.2/pyDOE2/doe_lhs.py  2018-01-31 15:45:46.0 +0100
+++ new/pyDOE2-1.2.0/pyDOE2/doe_lhs.py  2019-04-01 09:30:06.0 +0200
@@ -201,7 +201,7 @@
 for i in range(iterations):
 # Generate a random LHS
 Hcandidate = _lhsclassic(n, samples, randomstate)
-R = np.corrcoef(Hcandidate)
+R = np.corrcoef(Hcandidate.T)
 if np.max(np.abs(R[R!=1]))https://github.com/clicumu/pyDOE2
 Author: Rickard Sjoegren
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pyDOE2-1.1.2/setup.cfg new/pyDOE2-1.2.0/setup.cfg
--- old/pyDOE2-1.1.2/setup.cfg  2018-11-13 09:04:44.0 +0100
+++ new/pyDOE2-1.2.0/setup.cfg  2019-04-01 09:42:12.0 +0200
@@ -1,5 +1,4 @@
 [egg_info]
 tag_build = 
 tag_date = 0
-tag_svn_revision = 0
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pyDOE2-1.1.2/setup.py new/pyDOE2-1.2.0/setup.py
--- old/pyDOE2-1.1.2/setup.py   2018-11-13 09:02:30.0 +0100
+++ new/pyDOE2-1.2.0/setup.py   2019-04-01 09:38:24.0 +0200
@@ -7,7 +7,7 @@
 
 setup(
 name='pyDOE2',
-version="1.1.2",
+version="1.2.0",
 author='Rickard Sjoegren',
 author_email='r.sjogre...@gmail.com',
 description='Design of experiments for Python',




commit gnome-getting-started-docs for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package gnome-getting-started-docs for 
openSUSE:Factory checked in at 2019-07-23 22:56:06

Comparing /work/SRC/openSUSE:Factory/gnome-getting-started-docs (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-getting-started-docs.new.4126 (New)


Package is "gnome-getting-started-docs"

Tue Jul 23 22:56:06 2019 rev:21 rq:717989 version:3.32.2

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-getting-started-docs/gnome-getting-started-docs.changes
2019-05-03 22:45:58.927707994 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-getting-started-docs.new.4126/gnome-getting-started-docs.changes
  2019-07-23 22:56:09.598172362 +0200
@@ -1,0 +2,7 @@
+Thu Jul 18 18:08:44 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.32.2:
+  + Updates to Getting Started.
+  + Updated translations.
+
+---

Old:

  gnome-getting-started-docs-3.32.1.tar.xz

New:

  gnome-getting-started-docs-3.32.2.tar.xz



Other differences:
--
++ gnome-getting-started-docs.spec ++
--- /var/tmp/diff_new_pack.q56lrc/_old  2019-07-23 22:56:10.986172759 +0200
+++ /var/tmp/diff_new_pack.q56lrc/_new  2019-07-23 22:56:10.990172760 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-getting-started-docs
-Version:3.32.1
+Version:3.32.2
 Release:0
 Summary:Getting started with GNOME - Documentation
 License:CC-BY-SA-3.0

++ gnome-getting-started-docs-3.32.1.tar.xz -> 
gnome-getting-started-docs-3.32.2.tar.xz ++
/work/SRC/openSUSE:Factory/gnome-getting-started-docs/gnome-getting-started-docs-3.32.1.tar.xz
 
/work/SRC/openSUSE:Factory/.gnome-getting-started-docs.new.4126/gnome-getting-started-docs-3.32.2.tar.xz
 differ: char 26, line 1




commit gamemode for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package gamemode for openSUSE:Factory 
checked in at 2019-07-23 22:56:17

Comparing /work/SRC/openSUSE:Factory/gamemode (Old)
 and  /work/SRC/openSUSE:Factory/.gamemode.new.4126 (New)


Package is "gamemode"

Tue Jul 23 22:56:17 2019 rev:5 rq:717991 version:1.4

Changes:

--- /work/SRC/openSUSE:Factory/gamemode/gamemode.changes2019-06-12 
13:11:24.540998516 +0200
+++ /work/SRC/openSUSE:Factory/.gamemode.new.4126/gamemode.changes  
2019-07-23 22:56:18.510174189 +0200
@@ -1,0 +2,27 @@
+Tue Jul 23 11:19:07 UTC 2019 - Andreas Prittwitz 
+
+- Update to version 1.4
+
+  * Add new D-Bus methods/properties for use by external tools 
+such as the GameMode GNOME Shell extension.
+  * Fix I/O priority and niceness optimisations to apply to the 
+whole process rather than just the thread that 
+requests GameMode.
+  * gamemoded will now automatically reload the configuration 
+file when it is changed and update optimisations on 
+current clients.
+  * Add support for using the client library inside Flatpak by 
+communicating with the daemon via a portal.
+  * Client library now uses libdbus rather than sd-bus.
+  * Fix gamemoderun to use the correct library path depending on 
+whether the app is 32-bit or 64-bit.
+  * Support the GAMEMODERUNEXEC environment variable to specify 
+an extra wrapper command for games launched with gamemoderun
+(e.g. a hybrid GPU wrapper such as optirun).
+  * Various other fixes and improvements.
+
+- Removed gpuctl-fixes.patch already included in 1.4 
+- Added "BuildRequires:  pkgconfig(dbus-1)" to spec file which
+  is needed by version 1.4
+
+---

Old:

  gamemode-1.3.1.tar.xz
  gpuctl-fixes.patch

New:

  gamemode-1.4.tar.xz



Other differences:
--
++ gamemode.spec ++
--- /var/tmp/diff_new_pack.BuOkQo/_old  2019-07-23 22:56:18.974173926 +0200
+++ /var/tmp/diff_new_pack.BuOkQo/_new  2019-07-23 22:56:18.978173924 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   gamemode
-Version:1.3.1
+Version:1.4
 Release:0
 Summary:Daemon/library combo for changing Linux system performance on 
demand
 License:BSD-3-Clause
@@ -28,12 +28,12 @@
 Source1:gamemode-rpmlintrc
 Source2:README.openSUSE
 Source3:baselibs.conf
-Patch1: gpuctl-fixes.patch
 BuildRequires:  cmake
 BuildRequires:  meson
 BuildRequires:  ninja
 BuildRequires:  pkgconfig
 BuildRequires:  polkit-devel
+BuildRequires:  pkgconfig(dbus-1)
 # Yes, it needs both
 BuildRequires:  pkgconfig(libsystemd)
 BuildRequires:  pkgconfig(systemd)
@@ -110,7 +110,7 @@
 
 %prep
 %setup -q
-%patch1 -p1
+
 cp %{SOURCE2} .
 
 %build

++ _service ++
--- /var/tmp/diff_new_pack.BuOkQo/_old  2019-07-23 22:56:19.006173908 +0200
+++ /var/tmp/diff_new_pack.BuOkQo/_new  2019-07-23 22:56:19.010173906 +0200
@@ -2,7 +2,7 @@
   
 https://github.com/FeralInteractive/gamemode.git
 git
-1.3.1
+1.4
 @PARENT_TAG@
 enable
   

++ _servicedata ++
--- /var/tmp/diff_new_pack.BuOkQo/_old  2019-07-23 22:56:19.022173899 +0200
+++ /var/tmp/diff_new_pack.BuOkQo/_new  2019-07-23 22:56:19.022173899 +0200
@@ -1,4 +1,4 @@
 
 
 https://github.com/FeralInteractive/gamemode.git
-  bc20bef283fb947d7cee23306860af04f723ae9f
+  7ced21f4b30cc4ceb67928889bc57af8784f1009

++ gamemode-1.3.1.tar.xz -> gamemode-1.4.tar.xz ++
 10361 lines of diff (skipped)




commit python-palettable for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-palettable for 
openSUSE:Factory checked in at 2019-07-23 22:56:22

Comparing /work/SRC/openSUSE:Factory/python-palettable (Old)
 and  /work/SRC/openSUSE:Factory/.python-palettable.new.4126 (New)


Package is "python-palettable"

Tue Jul 23 22:56:22 2019 rev:3 rq:717998 version:3.2.0

Changes:

--- /work/SRC/openSUSE:Factory/python-palettable/python-palettable.changes  
2019-01-08 12:28:23.728277611 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-palettable.new.4126/python-palettable.changes
2019-07-23 22:56:23.478171377 +0200
@@ -1,0 +2,7 @@
+Tue Jul 23 20:20:37 UTC 2019 - Todd R 
+
+- Update to 3.2.0
+  * Light & Bartlein palettes
+  * Drop official support for Python 2.6 and 3.3
+
+---

Old:

  palettable-3.1.1.tar.gz

New:

  palettable-3.2.0.tar.gz



Other differences:
--
++ python-palettable.spec ++
--- /var/tmp/diff_new_pack.FO2SAt/_old  2019-07-23 22:56:23.894171143 +0200
+++ /var/tmp/diff_new_pack.FO2SAt/_new  2019-07-23 22:56:23.894171143 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-palettable
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,14 +19,13 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %bcond_without test
 Name:   python-palettable
-Version:3.1.1
+Version:3.2.0
 Release:0
 Summary:Color palettes for Python
 License:MIT
 Group:  Development/Languages/Python
 Url:https://jiffyclub.github.io/palettable/
 Source: 
https://files.pythonhosted.org/packages/source/p/palettable/palettable-%{version}.tar.gz
-BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros

++ palettable-3.1.1.tar.gz -> palettable-3.2.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/palettable-3.1.1/PKG-INFO 
new/palettable-3.2.0/PKG-INFO
--- old/palettable-3.1.1/PKG-INFO   2018-05-14 16:54:51.0 +0200
+++ new/palettable-3.2.0/PKG-INFO   2019-07-12 01:24:45.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: palettable
-Version: 3.1.1
+Version: 3.2.0
 Summary: Color palettes for Python
 Home-page: https://jiffyclub.github.io/palettable/
 Author: Matt Davis
@@ -40,11 +40,10 @@
 Classifier: License :: OSI Approved :: MIT License
 Classifier: Programming Language :: Python
 Classifier: Programming Language :: Python :: 2
-Classifier: Programming Language :: Python :: 2.6
 Classifier: Programming Language :: Python :: 2.7
 Classifier: Programming Language :: Python :: 3
-Classifier: Programming Language :: Python :: 3.3
 Classifier: Programming Language :: Python :: 3.4
 Classifier: Programming Language :: Python :: 3.5
 Classifier: Programming Language :: Python :: 3.6
+Classifier: Programming Language :: Python :: 3.7
 Classifier: Topic :: Scientific/Engineering :: Visualization
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/palettable-3.1.1/license.txt 
new/palettable-3.2.0/license.txt
--- old/palettable-3.1.1/license.txt2015-03-04 07:18:35.0 +0100
+++ new/palettable-3.2.0/license.txt2019-07-12 01:03:53.0 +0200
@@ -1,5 +1,5 @@
 palettable
-Copyright (c) 2012 Matt Davis
+Copyright (c) 2019 Matt Davis
 
 Permission is hereby granted, free of charge, to any person obtaining a copy 
of this software
 and associated documentation files (the "Software"), to deal in the Software 
without
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/palettable-3.1.1/palettable/__init__.py 
new/palettable-3.2.0/palettable/__init__.py
--- old/palettable-3.1.1/palettable/__init__.py 2018-05-14 16:54:02.0 
+0200
+++ new/palettable-3.2.0/palettable/__init__.py 2019-07-12 01:23:46.0 
+0200
@@ -10,9 +10,10 @@
 from . import cartocolors
 from . import colorbrewer
 from . import cubehelix
+from . import lightbartlein
 from . import matplotlib
 from . import mycarta
 from . import wesanderson
 from . import tableau
 
-version = __version__ = '3.1.1'
+version = __version__ = '3.2.0'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/palettable-3.1.1/palettable/lightbartlein/__init__.py 
new/palettable-3.2.0/palettable/lightbartlein/__init__.py
--- 

commit 000product for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-07-23 22:45:07

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.4126 (New)


Package is "000product"

Tue Jul 23 22:45:07 2019 rev:1444 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi: same change
openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
openSUSE-cd-mini-i586.kiwi: same change
openSUSE-cd-mini-x86_64.kiwi: same change
openSUSE-dvd5-dvd-i586.kiwi: same change
openSUSE-dvd5-dvd-x86_64.kiwi: same change
openSUSE-ftp-ftp-i586_x86_64.kiwi: same change
stub.kiwi: same change
++ openSUSE-Addon-NonOss.product ++
--- /var/tmp/diff_new_pack.qJePiX/_old  2019-07-23 22:47:56.106443345 +0200
+++ /var/tmp/diff_new_pack.qJePiX/_new  2019-07-23 22:47:56.106443345 +0200
@@ -4,7 +4,7 @@
  
 openSUSE
 openSUSE-Addon-NonOss
-20190722
+    20190723
 0 
 openSUSE NonOSS Addon
 non oss addon




commit python-PsychoPy for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-PsychoPy for openSUSE:Factory 
checked in at 2019-07-23 22:44:26

Comparing /work/SRC/openSUSE:Factory/python-PsychoPy (Old)
 and  /work/SRC/openSUSE:Factory/.python-PsychoPy.new.4126 (New)


Package is "python-PsychoPy"

Tue Jul 23 22:44:26 2019 rev:3 rq:717966 version:3.1.5

Changes:

--- /work/SRC/openSUSE:Factory/python-PsychoPy/python-PsychoPy.changes  
2019-03-26 22:32:30.553704527 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-PsychoPy.new.4126/python-PsychoPy.changes
2019-07-23 22:44:34.438667822 +0200
@@ -1,0 +2,90 @@
+Tue Jul 23 17:06:57 UTC 2019 - Todd R 
+
+- Update to version 3.1.5
+  + Fixed
+* a new small rendering glitch. When using an image with
+  mask=None and interpolate=False the opacity of the image was
+  reduced at the edges of the stimulus
+- Update to version 3.1.4
+  + Fixed
+* further fix to Mic for experiments created under the previous
+  version (our last fix only solved the problem for new Mic
+  Components being inserted)
+* fixed demo timeByFrames which was set to use Qt4 for plotting
+  instead of Qt5 (which has been the default version provided
+  since the switch to Python3)
+* fixed crash in the new Keyboard class caused by psychtoolbox
+  lib incorrectly converting unicode characters in the device
+  name that needed repackaging
+* error with Variable Component trying to save start/stop
+  times (that might not exist for that variable)
+* some data could get orphaned (and not saved) by being
+  collected in the outer section of a nested loop
+* when using Mouse.getPos() with retina display and
+win.units=='pix' the mouse pos was double the expected
+value
+- Update to version 3.1.3
+  + Fixed
+* StairHandler code from Builder was failing in 3.1 due to
+  new tStartRefresh
+* data being sent to wrong method (addData not addOtherData)
+* Routines in online studies that weren't included in
+  (or before) a loop were
+  not having their data saved
+* Fix to audio capture error "bad argument at position 0"
+  from Builder experiments
+* PsychoPy app didn't recognise projects that were pointing
+  to gitlab ssh targets (e.g. created in terminal) 
+- Update to version 3.1.2
+  + Fixed
+* teething problems with new Keyboard class:
+  > in Builder there was stuttering of sounds and lags in frame
+timing caused by accidentally creating lots of Kyeboards
+while checking for 'escape'
+  > durations were being reported with correct magnitude but
+as negative values
+  > problem on Windows if keyboard device name contained unicode
+(that problem was actually in psychtoolbox package, now
+updated in Standalone)
+  > on Windows, the 'return' key was being called 'num_enter'
+* videos were not running online commit:9779579b6
+* fixed rounding error in filtering of NoiseStim
+* iohub waitKeys should act like getKeys if maxWait<=0
+* error if unicode items in the new Form class
+  + Added
+* videos in Builder now have a Loop playback parameter
+* Standalone distributions now include tobii-research package
+- Update to version 3.1.1
+  + Fixed
+* The new Keyboard class wasn't clearing all events when
+  requested (e.g. at the beginning of stimulus onset)
+* Microphone on windows failed if user didn't manually set pyo
+  to be preferred lib. That isn't now needed
+* pyo lib is now provided in the 64 bit Python3 Standalone (win)
+* Parallel port lib in the Windows 32-bit version wasn't
+  working (installed a new dll)
+* OpenCV in Mac Standalone wasn't working (updated to be a
+  package not a single file)
+* Sounds with variable duration didn't stop properly
+* Fix to JS output when useVersion was set to something
+* Cedrus XID lib is now working on Python3 (although their
+  official one is yet to come)
+  + Added
+* Added the loop playback parameter to Movie Components
+- Update to version 3.1.0
+  + Highlights:
+* Adds the new Keyboard class
+* Improved ioHub and eyetracker compatibility for Python3
+  (although this is still very much in a beta state)
+- Update to version 3.0.7
+  + Fixed
+* local project repeatedly asking to Create New Pavlovia
+  project when one already exists
+* Fixed "No module named 'PyQt4'" on MacOS<10.10 caused by
+  PyQt dropping support for Mac10.9 in PyQt5.9
+* don't allow movie->online to use units 'from experiment
+  settings'
+* Py3 string/byte fixes for CRS ColorCal
+* various fixes to Japanese translations
+
+---

Old:

  PsychoPy-3.0.6.zip

New:

  

commit python-scikit-sound for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-scikit-sound for 
openSUSE:Factory checked in at 2019-07-23 22:44:01

Comparing /work/SRC/openSUSE:Factory/python-scikit-sound (Old)
 and  /work/SRC/openSUSE:Factory/.python-scikit-sound.new.4126 (New)


Package is "python-scikit-sound"

Tue Jul 23 22:44:01 2019 rev:2 rq:717940 version:0.2.3

Changes:

--- /work/SRC/openSUSE:Factory/python-scikit-sound/python-scikit-sound.changes  
2018-06-02 12:13:59.227943089 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-scikit-sound.new.4126/python-scikit-sound.changes
2019-07-23 22:44:02.422697079 +0200
@@ -1,0 +2,6 @@
+Tue Jul 23 15:39:16 UTC 2019 - Todd R 
+
+- Update to 0.2.3
+  * problem with Sound.write() when used without input fixed
+
+---

Old:

  scikit-sound-0.2.1.tar.gz

New:

  scikit-sound-0.2.3.tar.gz



Other differences:
--
++ python-scikit-sound.spec ++
--- /var/tmp/diff_new_pack.CTMD6d/_old  2019-07-23 22:44:03.242696330 +0200
+++ /var/tmp/diff_new_pack.CTMD6d/_new  2019-07-23 22:44:03.246696326 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-scikit-sound
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,14 +19,13 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-scikit-sound
-Version:0.2.1
+Version:0.2.3
 Release:0
 Summary:Python utilities for working with sound signals
 License:BSD-2-Clause
 Group:  Development/Languages/Python
 Url:http://work.thaslwanter.at/sksound/html
 Source: 
https://files.pythonhosted.org/packages/source/s/scikit-sound/scikit-sound-%{version}.tar.gz
-BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros

++ scikit-sound-0.2.1.tar.gz -> scikit-sound-0.2.3.tar.gz ++
 13605 lines of diff (skipped)




commit guile-cairo for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package guile-cairo for openSUSE:Factory 
checked in at 2019-07-23 22:44:05

Comparing /work/SRC/openSUSE:Factory/guile-cairo (Old)
 and  /work/SRC/openSUSE:Factory/.guile-cairo.new.4126 (New)


Package is "guile-cairo"

Tue Jul 23 22:44:05 2019 rev:3 rq:717946 version:1.10.0

Changes:

--- /work/SRC/openSUSE:Factory/guile-cairo/guile-cairo.changes  2019-01-21 
10:52:33.155859268 +0100
+++ /work/SRC/openSUSE:Factory/.guile-cairo.new.4126/guile-cairo.changes
2019-07-23 22:44:06.522693332 +0200
@@ -1,0 +2,5 @@
+Tue Jul 16 15:28:45 UTC 2019 - Jonathan Brielmaier 
+
+- build require cairo-devel >= 1.10.0 
+
+---



Other differences:
--
++ guile-cairo.spec ++
--- /var/tmp/diff_new_pack.1YvDjL/_old  2019-07-23 22:44:07.010692887 +0200
+++ /var/tmp/diff_new_pack.1YvDjL/_new  2019-07-23 22:44:07.014692883 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -26,7 +26,7 @@
 URL:https://www.nongnu.org/guile-cairo/
 Source0:%{name}-%{version}.tar.gz
 Source1:%{name}-%{version}.tar.gz.sig
-BuildRequires:  cairo-devel
+BuildRequires:  cairo-devel >= 1.10.0
 BuildRequires:  guile-devel
 Requires(post): %{install_info_prereq}
 Requires(preun): %{install_info_prereq}





commit crawl for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package crawl for openSUSE:Factory checked 
in at 2019-07-23 22:43:49

Comparing /work/SRC/openSUSE:Factory/crawl (Old)
 and  /work/SRC/openSUSE:Factory/.crawl.new.4126 (New)


Package is "crawl"

Tue Jul 23 22:43:49 2019 rev:31 rq:717935 version:0.23.2

Changes:

--- /work/SRC/openSUSE:Factory/crawl/crawl.changes  2018-08-31 
10:44:48.743228998 +0200
+++ /work/SRC/openSUSE:Factory/.crawl.new.4126/crawl.changes2019-07-23 
22:43:50.366708096 +0200
@@ -1,0 +2,11 @@
+Sun Jul 21 16:44:16 UTC 2019 - Simon Puchert 
+
+- Update to version 0.23.2
+  * Trap system overhaul
+  * New Gauntlet portal to replace Labyrinths
+  * Nemelex Xobeh rework
+  * Nine unrandarts reworked and the new "Rift" unrandart added
+  * Support for seeded dungeon play
+  * build requires python and python-pyYAML
+
+---

Old:

  stone_soup-0.22.0-nodeps.tar.xz

New:

  stone_soup-0.23.2-nodeps.tar.xz



Other differences:
--
++ crawl.spec ++
--- /var/tmp/diff_new_pack.DerwqV/_old  2019-07-23 22:43:51.434707120 +0200
+++ /var/tmp/diff_new_pack.DerwqV/_new  2019-07-23 22:43:51.438707116 +0200
@@ -17,12 +17,12 @@
 #
 
 
-%define major_ver 0.22
+%define major_ver 0.23
 %define about Crawl is a fun game in the grand tradition of games like Rogue, 
Hack, and Moria.\
 Your objective is to travel deep into a subterranean cave complex and retrieve 
the Orb of Zot, \
 which is guarded by many horrible and hideous creatures.
 Name:   crawl
-Version:%{major_ver}.0
+Version:%{major_ver}.2
 Release:0
 Summary:Roguelike dungeon exploration game
 License:GPL-2.0-or-later
@@ -51,6 +51,8 @@
 BuildRequires:  pkgconfig(glu)
 BuildRequires:  pkgconfig(sdl2)
 BuildRequires:  pkgconfig(sqlite3)
+BuildRequires:  python
+BuildRequires:  python-PyYAML
 Requires:   %{name}-data = %{version}
 %if 0%{?suse_version} >= 1330
 Requires:   group(games)

++ stone_soup-0.22.0-nodeps.tar.xz -> stone_soup-0.23.2-nodeps.tar.xz ++
/work/SRC/openSUSE:Factory/crawl/stone_soup-0.22.0-nodeps.tar.xz 
/work/SRC/openSUSE:Factory/.crawl.new.4126/stone_soup-0.23.2-nodeps.tar.xz 
differ: char 25, line 1




commit qxmledit for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package qxmledit for openSUSE:Factory 
checked in at 2019-07-23 22:43:55

Comparing /work/SRC/openSUSE:Factory/qxmledit (Old)
 and  /work/SRC/openSUSE:Factory/.qxmledit.new.4126 (New)


Package is "qxmledit"

Tue Jul 23 22:43:55 2019 rev:19 rq:717936 version:0.9.13

Changes:

--- /work/SRC/openSUSE:Factory/qxmledit/qxmledit.changes2019-05-05 
21:21:59.309370212 +0200
+++ /work/SRC/openSUSE:Factory/.qxmledit.new.4126/qxmledit.changes  
2019-07-23 22:43:56.606702393 +0200
@@ -1,0 +2,5 @@
+Mon Jul 22 20:45:55 UTC 2019 - Luigi Baldoni 
+
+- Added qxmledit-no_warnings_as_errors.patch to fix Factory build
+
+---

New:

  qxmledit-no_warnings_as_errors.patch



Other differences:
--
++ qxmledit.spec ++
--- /var/tmp/diff_new_pack.5XOYir/_old  2019-07-23 22:43:57.330701732 +0200
+++ /var/tmp/diff_new_pack.5XOYir/_new  2019-07-23 22:43:57.334701728 +0200
@@ -27,6 +27,8 @@
 URL:http://qxmledit.org/
 Source: 
https://github.com/lbellonda/qxmledit/archive/%{_version}.tar.gz#/%{name}-%{_version}.tar.gz
 Source99:   baselibs.conf
+# PATCH-FIX-UPSTREAM qxmledit-no_warnings_as_errors.patch
+Patch0: qxmledit-no_warnings_as_errors.patch
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
@@ -101,6 +103,9 @@
 
 %prep
 %setup -q -n %{name}-%{_version}
+%if 0%{?suse_version} > 1500
+%patch0 -p1
+%endif
 
 %build
 export QXMLEDIT_INST_DATA_DIR=%{_datadir}/%{name}/

++ qxmledit-no_warnings_as_errors.patch ++
From: Luigi Baldoni 
Date: 2019-07-22 22:33:15 +0200
Subject: Deprecated functions in Qt 5.13
References: https://github.com/lbellonda/qxmledit/issues/62

Do no fail on warnings for deprecated Qt functions

Index: qxmledit-0.9.13/src/QXmlEditWidget.pro
===
--- qxmledit-0.9.13.orig/src/QXmlEditWidget.pro
+++ qxmledit-0.9.13/src/QXmlEditWidget.pro
@@ -76,6 +76,7 @@ win32-msvc2010 {
 } else {
 QMAKE_CXXFLAGS += -Wall
 QMAKE_CXXFLAGS +=-Werror
+QMAKE_CXXFLAGS +=-Wno-error=deprecated-declarations
 #QMAKE_CXXFLAGS += -Winvalid-pch
 }
 
Index: qxmledit-0.9.13/src/sessions/QXmlEditSessions.pro
===
--- qxmledit-0.9.13.orig/src/sessions/QXmlEditSessions.pro
+++ qxmledit-0.9.13/src/sessions/QXmlEditSessions.pro
@@ -76,6 +76,7 @@ win32-msvc2010 {
 } else {
 QMAKE_CXXFLAGS += -Wall
 QMAKE_CXXFLAGS +=-Werror
+QMAKE_CXXFLAGS +=-Wno-error=deprecated-declarations
 }
 
 equals(INST_USE_C11, "y") {
Index: qxmledit-0.9.13/src/QXmlEdit.pro
===
--- qxmledit-0.9.13.orig/src/QXmlEdit.pro
+++ qxmledit-0.9.13/src/QXmlEdit.pro
@@ -98,6 +98,7 @@ win32-msvc2010 {
 } else {
 QMAKE_CXXFLAGS += -Wall
 QMAKE_CXXFLAGS +=-Werror
+QMAKE_CXXFLAGS +=-Wno-error=deprecated-declarations
 }
 
 lessThan(QT_MAJOR_VERSION, 5) {



commit python-blosc for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-blosc for openSUSE:Factory 
checked in at 2019-07-23 22:43:45

Comparing /work/SRC/openSUSE:Factory/python-blosc (Old)
 and  /work/SRC/openSUSE:Factory/.python-blosc.new.4126 (New)


Package is "python-blosc"

Tue Jul 23 22:43:45 2019 rev:12 rq:717934 version:1.8.1

Changes:

--- /work/SRC/openSUSE:Factory/python-blosc/python-blosc.changes
2019-01-08 12:28:17.732284162 +0100
+++ /work/SRC/openSUSE:Factory/.python-blosc.new.4126/python-blosc.changes  
2019-07-23 22:43:46.638711502 +0200
@@ -1,0 +2,21 @@
+Mon Jul 22 16:25:44 UTC 2019 - Todd R 
+
+- Update to 1.8.1
+  * Fix a bug that prevented the source distribution from PyPi to
+be compiled. Specifcally, *.inc were not included via the
+manifest.
+- Update to 1.8.0
+  * Include C-Blosc v1.16.2
+  * Fix cpuinfo.py usage on Windows.
+  * Implement Python access to the C function cbuffer_validate which
+was added to c-blosc in version 1.16.0
+  * Check if compiler supports CPU capabilities.
+  * Many minor improvements and fixes
+- Update to 1.7.0
+  * Include C-Blosc v1.15.1
+  * Remove Support for Python 2.6 and 3.3
+  * Fix vendored cpuinfo.py
+  * Rework Windows CI via Appveyor
+  * Various minor bugfixes
+
+---

Old:

  blosc-1.6.2.tar.gz

New:

  blosc-1.8.1.tar.gz



Other differences:
--
++ python-blosc.spec ++
--- /var/tmp/diff_new_pack.NORv5z/_old  2019-07-23 22:43:47.198710991 +0200
+++ /var/tmp/diff_new_pack.NORv5z/_new  2019-07-23 22:43:47.202710987 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-blosc
-Version:1.6.2
+Version:1.8.1
 Release:0
 Summary:Blosc data compressor for Python
 License:MIT

++ blosc-1.6.2.tar.gz -> blosc-1.8.1.tar.gz ++
 125923 lines of diff (skipped)




commit python-QtPy for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-QtPy for openSUSE:Factory 
checked in at 2019-07-23 22:42:36

Comparing /work/SRC/openSUSE:Factory/python-QtPy (Old)
 and  /work/SRC/openSUSE:Factory/.python-QtPy.new.4126 (New)


Package is "python-QtPy"

Tue Jul 23 22:42:36 2019 rev:10 rq:717930 version:1.8.0

Changes:

--- /work/SRC/openSUSE:Factory/python-QtPy/python-QtPy.changes  2019-05-24 
11:32:27.101388191 +0200
+++ /work/SRC/openSUSE:Factory/.python-QtPy.new.4126/python-QtPy.changes
2019-07-23 22:42:37.542777433 +0200
@@ -1,0 +2,6 @@
+Mon Jul 22 16:56:02 UTC 2019 - Todd R 
+
+- Update to 1.8.0
+  * Add support for several Qt 3D modules.
+
+---

Old:

  QtPy-1.7.1.tar.gz

New:

  QtPy-1.8.0.tar.gz



Other differences:
--
++ python-QtPy.spec ++
--- /var/tmp/diff_new_pack.B8b3rh/_old  2019-07-23 22:42:38.070776763 +0200
+++ /var/tmp/diff_new_pack.B8b3rh/_new  2019-07-23 22:42:38.074776759 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-QtPy
-Version:1.7.1
+Version:1.8.0
 Release:0
 Summary:Abstraction layer on top of Qt bindings
 License:MIT

++ QtPy-1.7.1.tar.gz -> QtPy-1.8.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/QtPy-1.7.1/PKG-INFO new/QtPy-1.8.0/PKG-INFO
--- old/QtPy-1.7.1/PKG-INFO 2019-05-05 09:54:16.0 +0200
+++ new/QtPy-1.8.0/PKG-INFO 2019-06-12 13:18:26.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: QtPy
-Version: 1.7.1
+Version: 1.8.0
 Summary: Provides an abstraction layer on top of the various Qt bindings 
(PyQt5, PyQt4 and PySide) and additional custom QWidgets.
 Home-page: https://github.com/spyder-ide/qtpy
 Author: Colin Duquesnoy, The Spyder Development Team
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/QtPy-1.7.1/QtPy.egg-info/PKG-INFO 
new/QtPy-1.8.0/QtPy.egg-info/PKG-INFO
--- old/QtPy-1.7.1/QtPy.egg-info/PKG-INFO   2019-05-05 09:54:15.0 
+0200
+++ new/QtPy-1.8.0/QtPy.egg-info/PKG-INFO   2019-06-12 13:18:25.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: QtPy
-Version: 1.7.1
+Version: 1.8.0
 Summary: Provides an abstraction layer on top of the various Qt bindings 
(PyQt5, PyQt4 and PySide) and additional custom QWidgets.
 Home-page: https://github.com/spyder-ide/qtpy
 Author: Colin Duquesnoy, The Spyder Development Team
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/QtPy-1.7.1/QtPy.egg-info/SOURCES.txt 
new/QtPy-1.8.0/QtPy.egg-info/SOURCES.txt
--- old/QtPy-1.7.1/QtPy.egg-info/SOURCES.txt2019-05-05 09:54:15.0 
+0200
+++ new/QtPy-1.8.0/QtPy.egg-info/SOURCES.txt2019-06-12 13:18:25.0 
+0200
@@ -9,8 +9,15 @@
 QtPy.egg-info/SOURCES.txt
 QtPy.egg-info/dependency_links.txt
 QtPy.egg-info/top_level.txt
+qtpy/Qt3DAnimation.py
+qtpy/Qt3DCore.py
+qtpy/Qt3DExtras.py
+qtpy/Qt3DInput.py
+qtpy/Qt3DLogic.py
+qtpy/Qt3DRender.py
 qtpy/QtCharts.py
 qtpy/QtCore.py
+qtpy/QtDatavisualization.py
 qtpy/QtDesigner.py
 qtpy/QtGui.py
 qtpy/QtHelp.py
@@ -49,8 +56,15 @@
 qtpy/tests/test_patch_qcombobox.py
 qtpy/tests/test_patch_qheaderview.py
 qtpy/tests/test_qdesktopservice_split.py
+qtpy/tests/test_qt3danimation.py
+qtpy/tests/test_qt3dcore.py
+qtpy/tests/test_qt3dextras.py
+qtpy/tests/test_qt3dinput.py
+qtpy/tests/test_qt3dlogic.py
+qtpy/tests/test_qt3drender.py
 qtpy/tests/test_qtcharts.py
 qtpy/tests/test_qtcore.py
+qtpy/tests/test_qtdatavisualization.py
 qtpy/tests/test_qtdesigner.py
 qtpy/tests/test_qthelp.py
 qtpy/tests/test_qtlocation.py
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/QtPy-1.7.1/qtpy/Qt3DAnimation.py 
new/QtPy-1.8.0/qtpy/Qt3DAnimation.py
--- old/QtPy-1.7.1/qtpy/Qt3DAnimation.py1970-01-01 01:00:00.0 
+0100
+++ new/QtPy-1.8.0/qtpy/Qt3DAnimation.py2019-06-12 13:16:09.0 
+0200
@@ -0,0 +1,22 @@
+# -*- coding: utf-8 -*-
+# -
+# Copyright © 2009- The Spyder Development Team
+#
+# Licensed under the terms of the MIT License
+# (see LICENSE.txt for details)
+# -
+"""Provides Qt3DAnimation classes and functions."""
+
+# Local imports
+from . import PYQT5, PYSIDE2, PythonQtError
+
+if PYQT5:
+from PyQt5.Qt3DAnimation import *
+elif PYSIDE2:
+# https://bugreports.qt.io/projects/PYSIDE/issues/PYSIDE-1026
+import PySide2.Qt3DAnimation as __temp
+import 

commit python-moban for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-moban for openSUSE:Factory 
checked in at 2019-07-23 22:42:26

Comparing /work/SRC/openSUSE:Factory/python-moban (Old)
 and  /work/SRC/openSUSE:Factory/.python-moban.new.4126 (New)


Package is "python-moban"

Tue Jul 23 22:42:26 2019 rev:2 rq:717923 version:0.5.0

Changes:

--- /work/SRC/openSUSE:Factory/python-moban/python-moban.changes
2019-02-28 21:38:11.521644175 +0100
+++ /work/SRC/openSUSE:Factory/.python-moban.new.4126/python-moban.changes  
2019-07-23 22:42:27.506790154 +0200
@@ -1,0 +2,7 @@
+Tue Jul 23 14:05:47 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.5.0:
+  * various fixes and tests updates
+  * See CHANGELOG.rst
+
+---

Old:

  moban-0.3.8.tar.gz

New:

  moban-0.5.0.tar.gz



Other differences:
--
++ python-moban.spec ++
--- /var/tmp/diff_new_pack.nTTWom/_old  2019-07-23 22:42:28.210789262 +0200
+++ /var/tmp/diff_new_pack.nTTWom/_new  2019-07-23 22:42:28.218789252 +0200
@@ -18,34 +18,38 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-moban
-Version:0.3.8
+Version:0.5.0
 Release:0
 Summary:Yet another jinja2 CLI for static text generation
 License:MIT
 Group:  Development/Languages/Python
-Url:https://github.com/moremoban/moban
+URL:https://github.com/moremoban/moban
 Source: 
https://files.pythonhosted.org/packages/source/m/moban/moban-%{version}.tar.gz
-BuildRequires:  %{python_module setuptools}
-BuildRequires:  python-rpm-macros
-# SECTION test requirements
+BuildRequires:  %{python_module GitPython >= 2.0.0}
+BuildRequires:  %{python_module Jinja2 >= 2.7.1}
+BuildRequires:  %{python_module appdirs >= 1.2.0}
+BuildRequires:  %{python_module crayons >= 0.1.0}
+BuildRequires:  %{python_module git-url-parse >= 1.2.2}
+BuildRequires:  %{python_module jinja2-time}
+BuildRequires:  %{python_module lml >= 0.0.9}
 BuildRequires:  %{python_module mock}
 BuildRequires:  %{python_module nose}
 BuildRequires:  %{python_module pip}
-BuildRequires:  git-core
-# Package dependencies
-BuildRequires:  %{python_module Jinja2 >= 2.8}
-BuildRequires:  %{python_module crayons >= 0.1.2}
-BuildRequires:  %{python_module lml >= 0.0.7}
-BuildRequires:  %{python_module ruamel.yaml >= 0.15.80}
-# /SECTION
+BuildRequires:  %{python_module ruamel.yaml >= 0.15.98}
+BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
-BuildArch:  noarch
+BuildRequires:  git-core
+BuildRequires:  python-rpm-macros
 Requires:   git-core
-Requires:   python-Jinja2 >= 2.8
-Requires:   python-crayons >= 0.1.2
-Requires:   python-lml >= 0.0.7
-Requires:   python-ruamel.yaml >= 0.15.80
-
+Requires:   python-GitPython >= 2.0.0
+Requires:   python-Jinja2 >= 2.7.1
+Requires:   python-appdirs >= 1.2.0
+Requires:   python-crayons >= 0.1.0
+Requires:   python-git-url-parse >= 1.2.2
+Requires:   python-jinja2-time
+Requires:   python-lml >= 0.0.9
+Requires:   python-ruamel.yaml >= 0.15.98
+BuildArch:  noarch
 %python_subpackages
 
 %description
@@ -57,6 +61,8 @@
 
 %prep
 %setup -q -n moban-%{version}
+# integration tests need network
+rm -r tests/integration_tests
 
 %build
 %python_build
@@ -69,7 +75,8 @@
 # test_level_9 depends on package pypi-mobans-pkg
 # test_level_10 depends on access to github.com
 # test_level_11 depends on moban-handlebars
-%python_exec %{_bindir}/nosetests --with-doctest --doctest-extension=.rst -e 
'test_level_(9|10|11)' README.rst tests docs moban
+# test_handle_targets_sequence fails on wrong arg count
+%python_exec %{_bindir}/nosetests --with-doctest --doctest-extension=.rst -e 
'test_level_(9|10|11)|test_handle_targets_sequence' README.rst tests docs moban
 
 %files %{python_files}
 %{python_sitelib}/*

++ moban-0.3.8.tar.gz -> moban-0.5.0.tar.gz ++
 8026 lines of diff (skipped)




commit python-mutt-ics for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-mutt-ics for openSUSE:Factory 
checked in at 2019-07-23 22:42:16

Comparing /work/SRC/openSUSE:Factory/python-mutt-ics (Old)
 and  /work/SRC/openSUSE:Factory/.python-mutt-ics.new.4126 (New)


Package is "python-mutt-ics"

Tue Jul 23 22:42:16 2019 rev:4 rq:717916 version:0.9.2

Changes:

--- /work/SRC/openSUSE:Factory/python-mutt-ics/python-mutt-ics.changes  
2019-05-25 13:20:53.764321811 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-mutt-ics.new.4126/python-mutt-ics.changes
2019-07-23 22:42:17.646802652 +0200
@@ -1,0 +2,6 @@
+Tue Jul 23 13:54:58 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.9.2:
+  * Include license in the distribution
+
+---

Old:

  LICENSE.mit
  mutt_ics-0.9.1.tar.gz

New:

  mutt_ics-0.9.2.tar.gz



Other differences:
--
++ python-mutt-ics.spec ++
--- /var/tmp/diff_new_pack.cRliA0/_old  2019-07-23 22:42:18.134802034 +0200
+++ /var/tmp/diff_new_pack.cRliA0/_new  2019-07-23 22:42:18.134802034 +0200
@@ -18,15 +18,13 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-mutt-ics
-Version:0.9.1
+Version:0.9.2
 Release:0
 Summary:A tool to show calendar event details in Mutt
 License:MIT
 Group:  Development/Languages/Python
 URL:https://github.com/dmedvinsky/mutt-ics
 Source0:
https://files.pythonhosted.org/packages/source/m/mutt_ics/mutt_ics-%{version}.tar.gz
-# https://github.com/dmedvinsky/mutt-ics/issues/20
-Source1:LICENSE.mit
 BuildRequires:  %{python_module icalendar >= 3.9.0}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
@@ -52,7 +50,6 @@
 %install
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
-install -pm 0644 %{SOURCE1} LICENSE
 
 %check
 exit_code=0
@@ -63,7 +60,6 @@
 
 %files %{python_files}
 %doc README.md
-%license LICENSE
 %python3_only %{_bindir}/mutt-ics
 %{python_sitelib}/*
 

++ mutt_ics-0.9.1.tar.gz -> mutt_ics-0.9.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mutt_ics-0.9.1/LICENSE new/mutt_ics-0.9.2/LICENSE
--- old/mutt_ics-0.9.1/LICENSE  1970-01-01 01:00:00.0 +0100
+++ new/mutt_ics-0.9.2/LICENSE  2019-05-26 17:54:13.0 +0200
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 Dmitry Medvinsky
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mutt_ics-0.9.1/MANIFEST.in 
new/mutt_ics-0.9.2/MANIFEST.in
--- old/mutt_ics-0.9.1/MANIFEST.in  2019-03-27 10:35:42.0 +0100
+++ new/mutt_ics-0.9.2/MANIFEST.in  2019-05-26 17:54:42.0 +0200
@@ -1,3 +1,4 @@
+include LICENSE
 include README.md
 include requirements.txt
 include samples/*
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mutt_ics-0.9.1/PKG-INFO new/mutt_ics-0.9.2/PKG-INFO
--- old/mutt_ics-0.9.1/PKG-INFO 2019-03-27 10:47:54.0 +0100
+++ new/mutt_ics-0.9.2/PKG-INFO 2019-05-26 17:55:37.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: mutt_ics
-Version: 0.9.1
+Version: 0.9.2
 Summary: A tool to show calendar event details in Mutt.
 Home-page: https://github.com/dmedvinsky/mutt-ics
 Author: Dmitry Medvinsky
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mutt_ics-0.9.1/mutt_ics.egg-info/PKG-INFO 
new/mutt_ics-0.9.2/mutt_ics.egg-info/PKG-INFO
--- old/mutt_ics-0.9.1/mutt_ics.egg-info/PKG-INFO   2019-03-27 
10:47:54.0 +0100
+++ new/mutt_ics-0.9.2/mutt_ics.egg-info/PKG-INFO   

commit jwt_verify_lib for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package jwt_verify_lib for openSUSE:Factory 
checked in at 2019-07-23 22:42:21

Comparing /work/SRC/openSUSE:Factory/jwt_verify_lib (Old)
 and  /work/SRC/openSUSE:Factory/.jwt_verify_lib.new.4126 (New)


Package is "jwt_verify_lib"

Tue Jul 23 22:42:21 2019 rev:3 rq:717921 version:20181125

Changes:

--- /work/SRC/openSUSE:Factory/jwt_verify_lib/jwt_verify_lib.changes
2019-03-01 16:48:49.233767463 +0100
+++ /work/SRC/openSUSE:Factory/.jwt_verify_lib.new.4126/jwt_verify_lib.changes  
2019-07-23 22:42:22.502796497 +0200
@@ -1,0 +2,5 @@
+Tue Jul 23 13:14:51 UTC 2019 - Guillaume GARDET 
+
+- Use Bazel0.19 as build fails with latest bazel (0.26)
+
+---



Other differences:
--
++ jwt_verify_lib.spec ++
--- /var/tmp/diff_new_pack.Kqn5IP/_old  2019-07-23 22:42:23.142795686 +0200
+++ /var/tmp/diff_new_pack.Kqn5IP/_new  2019-07-23 22:42:23.162795660 +0200
@@ -29,7 +29,7 @@
 Source: %{name}-%{version}.tar.xz
 Patch0: bazel-unbundle-dependencies.patch
 BuildRequires:  abseil-cpp-devel
-BuildRequires:  bazel
+BuildRequires:  bazel0.19
 BuildRequires:  boringssl-devel
 BuildRequires:  gcc-c++
 BuildRequires:  gtest




commit python-nltk for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-nltk for openSUSE:Factory 
checked in at 2019-07-23 22:41:54

Comparing /work/SRC/openSUSE:Factory/python-nltk (Old)
 and  /work/SRC/openSUSE:Factory/.python-nltk.new.4126 (New)


Package is "python-nltk"

Tue Jul 23 22:41:54 2019 rev:5 rq:717915 version:3.4.4

Changes:

--- /work/SRC/openSUSE:Factory/python-nltk/python-nltk.changes  2019-05-24 
11:33:04.737373816 +0200
+++ /work/SRC/openSUSE:Factory/.python-nltk.new.4126/python-nltk.changes
2019-07-23 22:41:55.586830615 +0200
@@ -1,0 +2,20 @@
+Tue Jul 23 13:52:24 UTC 2019 - Tomáš Chvátal 
+
+- Update to 3.4.4:
+  * fix bug in plot function (probability.py)
+  * add improved PanLex Swadesh corpus reader
+  * add Text.generate()
+  * add QuadgramAssocMeasures
+  * add SSP to tokenizers
+  * return confidence of best tag from AveragedPerceptron
+  * make plot methods return Axes objects
+  * don't require list arguments to PositiveNaiveBayesClassifier.train
+  * fix Tree classes to work with native Python copy library
+  * fix inconsistency for NomBank
+  * fix random seeding in LanguageModel.generate
+  * fix ConditionalFreqDist mutation on tabulate/plot call
+  * fix broken links in documentation
+  * fix misc Wordnet issues
+  * update installation instructions
+
+---

Old:

  nltk-3.4.1.zip

New:

  nltk-3.4.4.zip



Other differences:
--
++ python-nltk.spec ++
--- /var/tmp/diff_new_pack.YH2cQW/_old  2019-07-23 22:41:56.122829935 +0200
+++ /var/tmp/diff_new_pack.YH2cQW/_new  2019-07-23 22:41:56.126829930 +0200
@@ -18,25 +18,22 @@
 
 %{!?python_module:%define python_module() python-%{**} python3-%{**}}
 %define interps python python3
-
 %define pyname nltk
 Name:   python-nltk
-Version:3.4.1
+Version:3.4.4
 Release:0
 Summary:Natural Language Toolkit
 License:Apache-2.0
 Group:  Development/Languages/Python
-Url:http://nltk.org/
+URL:http://nltk.org/
 Source: 
https://files.pythonhosted.org/packages/source/n/nltk/%{pyname}-%{version}.zip
 BuildRequires:  %{interps}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{python_module six}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
+BuildRequires:  python-singledispatch
 BuildRequires:  unzip
-%ifpython2
-Requires:   python2-singledispatch
-%endif
 Requires:   python-six
 Recommends: python-gensim
 Recommends: python-matplotlib
@@ -44,11 +41,16 @@
 Recommends: python-pyparsing
 Recommends: python-python-crfsuite 
 Recommends: python-requests
-Recommends: python-scipy
 Recommends: python-scikit-learn 
+Recommends: python-scipy
 Recommends: python-twython
 BuildArch:  noarch
-
+%ifpython2
+Requires:   python-singledispatch
+%endif
+%ifpython2
+Requires:   python2-singledispatch
+%endif
 %python_subpackages
 
 %description




commit bazel0.26 for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package bazel0.26 for openSUSE:Factory 
checked in at 2019-07-23 22:41:25

Comparing /work/SRC/openSUSE:Factory/bazel0.26 (Old)
 and  /work/SRC/openSUSE:Factory/.bazel0.26.new.4126 (New)


Package is "bazel0.26"

Tue Jul 23 22:41:25 2019 rev:3 rq:717911 version:0.26.0

Changes:

--- /work/SRC/openSUSE:Factory/bazel0.26/bazel0.26.changes  2019-07-21 
11:33:25.700786584 +0200
+++ /work/SRC/openSUSE:Factory/.bazel0.26.new.4126/bazel0.26.changes
2019-07-23 22:41:27.542866162 +0200
@@ -1,0 +2,5 @@
+Tue Jul 23 12:45:55 UTC 2019 - Guillaume GARDET 
+
+- Use openjdk 11/12 for aarch64 to workaround boo#1138529
+
+---



Other differences:
--
++ bazel0.26.spec ++
--- /var/tmp/diff_new_pack.EisA4T/_old  2019-07-23 22:41:30.950861842 +0200
+++ /var/tmp/diff_new_pack.EisA4T/_new  2019-07-23 22:41:30.950861842 +0200
@@ -19,6 +19,18 @@
 %define bashcompdir %(pkg-config --variable=completionsdir bash-completion 
2>/dev/null)
 %define shortname bazel
 %define shortver 0.26
+
+#Workaround for aarch64 boo#1138529
+%ifarch aarch64
+%if 0%{?suse_version} > 1500
+%define openjdktouse java-12-openjdk-devel
+%else
+%define openjdktouse java-11-openjdk-devel
+%endif
+%else
+%define openjdktouse java-1_8_0-openjdk-devel
+%endif
+
 Name:   bazel%{shortver}
 Version:0.26.0
 Release:0
@@ -28,8 +40,8 @@
 URL:http://bazel.io/
 Source0:
https://github.com/bazelbuild/bazel/releases/download/%{version}/%{shortname}-%{version}-dist.zip
 Source1:
https://github.com/bazelbuild/bazel/releases/download/%{version}/%{shortname}-%{version}-dist.zip.sig
+BuildRequires:  %{openjdktouse}
 BuildRequires:  gcc-c++
-BuildRequires:  java-1_8_0-openjdk-devel
 BuildRequires:  pkgconfig
 BuildRequires:  python
 BuildRequires:  unzip
@@ -38,7 +50,7 @@
 BuildRequires:  pkgconfig(zlib)
 Requires(post):update-alternatives
 Requires(postun): update-alternatives
-Requires:   java-1_8_0-openjdk-devel
+Requires:   %{openjdktouse}
 Provides:   bazel = %{version}
 %ifarch armv7l
 ExclusiveArch:  do_not_build






commit python-partd for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-partd for openSUSE:Factory 
checked in at 2019-07-23 22:40:48

Comparing /work/SRC/openSUSE:Factory/python-partd (Old)
 and  /work/SRC/openSUSE:Factory/.python-partd.new.4126 (New)


Package is "python-partd"

Tue Jul 23 22:40:48 2019 rev:4 rq:717898 version:1.0.0

Changes:

--- /work/SRC/openSUSE:Factory/python-partd/python-partd.changes
2019-06-06 18:15:57.756709918 +0200
+++ /work/SRC/openSUSE:Factory/.python-partd.new.4126/python-partd.changes  
2019-07-23 22:40:54.538907997 +0200
@@ -1,0 +2,6 @@
+Tue Jul 23 13:20:27 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.0.0:
+  * no upstream changelog
+
+---

Old:

  partd-0.3.10.tar.gz

New:

  partd-1.0.0.tar.gz



Other differences:
--
++ python-partd.spec ++
--- /var/tmp/diff_new_pack.3be456/_old  2019-07-23 22:40:55.126907251 +0200
+++ /var/tmp/diff_new_pack.3be456/_new  2019-07-23 22:40:55.130907246 +0200
@@ -18,30 +18,29 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-partd
-Version:0.3.10
+Version:1.0.0
 Release:0
 Summary:Appendable key-value storage
 License:BSD-3-Clause
 Group:  Development/Languages/Python
-Url:http://github.com/mrocklin/partd/
+URL:https://github.com/mrocklin/partd/
 Source: 
https://files.pythonhosted.org/packages/source/p/partd/partd-%{version}.tar.gz
 BuildRequires:  %{python_module locket}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{python_module toolz}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
-# SECTION test requirements
-BuildRequires:  %{python_module pytest}
-# /SECTION
 Requires:   python-locket
 Requires:   python-toolz
 Recommends: python-blosc
+Recommends: python-msgpack-python
 Recommends: python-numpy >= 1.9.0
 Recommends: python-pandas
 Recommends: python-pyzmq
-Recommends: python-msgpack-python
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
+# SECTION test requirements
+BuildRequires:  %{python_module pytest}
+# /SECTION
 %python_subpackages
 
 %description
@@ -67,7 +66,6 @@
 %pytest
 
 %files %{python_files}
-%defattr(-,root,root,-)
 %doc README.rst
 %license LICENSE.txt
 %{python_sitelib}/*

++ partd-0.3.10.tar.gz -> partd-1.0.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/partd-0.3.10/PKG-INFO new/partd-1.0.0/PKG-INFO
--- old/partd-0.3.10/PKG-INFO   2019-03-14 19:12:53.0 +0100
+++ new/partd-1.0.0/PKG-INFO2019-06-25 09:00:22.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: partd
-Version: 0.3.10
+Version: 1.0.0
 Summary: Appendable key-value storage
 Home-page: http://github.com/dask/partd/
 Maintainer: Matthew Rocklin
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/partd-0.3.10/partd/__init__.py 
new/partd-1.0.0/partd/__init__.py
--- old/partd-0.3.10/partd/__init__.py  2019-03-14 19:12:01.0 +0100
+++ new/partd-1.0.0/partd/__init__.py   2019-06-25 08:59:23.0 +0200
@@ -16,4 +16,4 @@
 from .zmq import Client, Server
 
 
-__version__ = '0.3.10'
+__version__ = '1.0.0'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/partd-0.3.10/partd/compressed.py 
new/partd-1.0.0/partd/compressed.py
--- old/partd-0.3.10/partd/compressed.py2019-03-11 17:19:11.0 
+0100
+++ new/partd-1.0.0/partd/compressed.py 2019-06-25 08:58:40.0 +0200
@@ -9,7 +9,9 @@
 return b''.join(L)
 
 
-with ignoring(ImportError):
+with ignoring(ImportError, AttributeError):
+# In case snappy is not installed, or another package called snappy that 
does not implement compress / decompress.
+# For example, SnapPy (https://pypi.org/project/snappy/)
 import snappy
 Snappy = partial(Encode,
  snappy.compress,
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/partd-0.3.10/partd/utils.py 
new/partd-1.0.0/partd/utils.py
--- old/partd-0.3.10/partd/utils.py 2019-03-11 17:19:11.0 +0100
+++ new/partd-1.0.0/partd/utils.py  2019-06-25 08:58:40.0 +0200
@@ -105,7 +105,6 @@
 return (nested_get(i, coll, lazy=lazy) for i in ind)
 else:
 return [nested_get(i, coll, lazy=lazy) for i in ind]
-return seq
 else:
 return coll[ind]
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/partd-0.3.10/partd.egg-info/PKG-INFO 

commit thunar for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package thunar for openSUSE:Factory checked 
in at 2019-07-23 22:40:44

Comparing /work/SRC/openSUSE:Factory/thunar (Old)
 and  /work/SRC/openSUSE:Factory/.thunar.new.4126 (New)


Package is "thunar"

Tue Jul 23 22:40:44 2019 rev:77 rq:717891 version:1.8.8

Changes:

--- /work/SRC/openSUSE:Factory/thunar/thunar.changes2019-07-11 
13:15:44.234817599 +0200
+++ /work/SRC/openSUSE:Factory/.thunar.new.4126/thunar.changes  2019-07-23 
22:40:50.414913224 +0200
@@ -1,0 +2,12 @@
+Fri Jul 19 23:32:15 UTC 2019 - Marcel Kuehlhorn 
+
+- Update to version 1.8.8
+  * Do not register "send to" as last used app (bxo#14118)
+  * Use https where possible
+  * Dont restart the folder monitor on each refresh (bxo#13364)
+  * Fix XML declaratation in uca.xml (bxo#13623)
+  * Always show the executable checkbox (bxo#15605)
+  * Replace Trash action with Delete as needed (bxo#15352)
+  * Translation updates
+
+---

Old:

  Thunar-1.8.7.tar.bz2

New:

  Thunar-1.8.8.tar.bz2



Other differences:
--
++ thunar.spec ++
--- /var/tmp/diff_new_pack.btMBCP/_old  2019-07-23 22:40:51.374912008 +0200
+++ /var/tmp/diff_new_pack.btMBCP/_new  2019-07-23 22:40:51.390911987 +0200
@@ -19,7 +19,7 @@
 %define libname libthunarx-3-0
 %bcond_with git
 Name:   thunar
-Version:1.8.7
+Version:1.8.8
 Release:0
 Summary:File Manager for the Xfce Desktop Environment
 License:GPL-2.0-or-later

++ Thunar-1.8.7.tar.bz2 -> Thunar-1.8.8.tar.bz2 ++
 9419 lines of diff (skipped)




commit bazel0.25 for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package bazel0.25 for openSUSE:Factory 
checked in at 2019-07-23 22:41:39

Comparing /work/SRC/openSUSE:Factory/bazel0.25 (Old)
 and  /work/SRC/openSUSE:Factory/.bazel0.25.new.4126 (New)


Package is "bazel0.25"

Tue Jul 23 22:41:39 2019 rev:2 rq:717912 version:0.25.3

Changes:

--- /work/SRC/openSUSE:Factory/bazel0.25/bazel0.25.changes  2019-06-19 
21:08:15.394503001 +0200
+++ /work/SRC/openSUSE:Factory/.bazel0.25.new.4126/bazel0.25.changes
2019-07-23 22:41:41.106848969 +0200
@@ -1,0 +2,5 @@
+Tue Jul 23 12:45:55 UTC 2019 - Guillaume GARDET 
+
+- Use openjdk 11/12 for aarch64 to workaround boo#1138529
+
+---



Other differences:
--
++ bazel0.25.spec ++
--- /var/tmp/diff_new_pack.0Lni6E/_old  2019-07-23 22:41:44.938844112 +0200
+++ /var/tmp/diff_new_pack.0Lni6E/_new  2019-07-23 22:41:44.938844112 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package bazel
+# spec file for package bazel0.25
 #
 # Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
@@ -16,6 +16,17 @@
 #
 
 
+#Workaround for aarch64 boo#1138529
+%ifarch aarch64
+%if 0%{?suse_version} > 1500
+%define openjdktouse java-12-openjdk-devel
+%else
+%define openjdktouse java-11-openjdk-devel
+%endif
+%else
+%define openjdktouse java-1_8_0-openjdk-devel
+%endif
+
 %define bashcompdir %(pkg-config --variable=completionsdir bash-completion 
2>/dev/null)
 %define shortname bazel
 %define shortver 0.25
@@ -28,8 +39,8 @@
 URL:http://bazel.io/
 Source0:
https://github.com/bazelbuild/bazel/releases/download/%{version}/%{shortname}-%{version}-dist.zip
 Source1:
https://github.com/bazelbuild/bazel/releases/download/%{version}/%{shortname}-%{version}-dist.zip.sig
+BuildRequires:  %{openjdktouse}
 BuildRequires:  gcc-c++
-BuildRequires:  java-1_8_0-openjdk-devel
 BuildRequires:  pkgconfig
 BuildRequires:  python
 BuildRequires:  unzip
@@ -38,7 +49,7 @@
 BuildRequires:  pkgconfig(zlib)
 Requires(post):update-alternatives
 Requires(postun): update-alternatives
-Requires:   java-1_8_0-openjdk-devel
+Requires:   %{openjdktouse}
 Provides:   bazel = %{version}
 %ifarch armv7l
 ExclusiveArch:  do_not_build






commit bazel0.24 for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package bazel0.24 for openSUSE:Factory 
checked in at 2019-07-23 22:41:12

Comparing /work/SRC/openSUSE:Factory/bazel0.24 (Old)
 and  /work/SRC/openSUSE:Factory/.bazel0.24.new.4126 (New)


Package is "bazel0.24"

Tue Jul 23 22:41:12 2019 rev:2 rq:717910 version:0.24.1

Changes:

--- /work/SRC/openSUSE:Factory/bazel0.24/bazel0.24.changes  2019-06-19 
21:07:44.602474792 +0200
+++ /work/SRC/openSUSE:Factory/.bazel0.24.new.4126/bazel0.24.changes
2019-07-23 22:41:14.410882808 +0200
@@ -1,0 +2,5 @@
+Tue Jul 23 12:45:55 UTC 2019 - Guillaume GARDET 
+
+- Use openjdk 11/12 for aarch64 to workaround boo#1138529
+
+---



Other differences:
--
++ bazel0.24.spec ++
--- /var/tmp/diff_new_pack.6MPDAf/_old  2019-07-23 22:41:17.222879244 +0200
+++ /var/tmp/diff_new_pack.6MPDAf/_new  2019-07-23 22:41:17.226879238 +0200
@@ -19,6 +19,18 @@
 %define bashcompdir %(pkg-config --variable=completionsdir bash-completion 
2>/dev/null)
 %define shortname bazel
 %define shortver 0.24
+
+#Workaround for aarch64 boo#1138529
+%ifarch aarch64
+%if 0%{?suse_version} > 1500
+%define openjdktouse java-12-openjdk-devel
+%else
+%define openjdktouse java-11-openjdk-devel
+%endif
+%else
+%define openjdktouse java-1_8_0-openjdk-devel
+%endif
+
 Name:   bazel%{shortver}
 Version:0.24.1
 Release:0
@@ -28,8 +40,8 @@
 URL:http://bazel.io/
 Source0:
https://github.com/bazelbuild/bazel/releases/download/%{version}/%{shortname}-%{version}-dist.zip
 Source1:
https://github.com/bazelbuild/bazel/releases/download/%{version}/%{shortname}-%{version}-dist.zip.sig
+BuildRequires:  %{openjdktouse}
 BuildRequires:  gcc-c++
-BuildRequires:  java-1_8_0-openjdk-devel
 BuildRequires:  pkgconfig
 BuildRequires:  python
 BuildRequires:  unzip
@@ -38,7 +50,7 @@
 BuildRequires:  pkgconfig(zlib)
 Requires(post):update-alternatives
 Requires(postun): update-alternatives
-Requires:   java-1_8_0-openjdk-devel
+Requires:   %{openjdktouse}
 Provides:   bazel = %{version}
 %ifarch armv7l
 ExclusiveArch:  do_not_build






commit python-openapi-core for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-openapi-core for 
openSUSE:Factory checked in at 2019-07-23 22:40:55

Comparing /work/SRC/openSUSE:Factory/python-openapi-core (Old)
 and  /work/SRC/openSUSE:Factory/.python-openapi-core.new.4126 (New)


Package is "python-openapi-core"

Tue Jul 23 22:40:55 2019 rev:3 rq:717909 version:0.11.0

Changes:

--- /work/SRC/openSUSE:Factory/python-openapi-core/python-openapi-core.changes  
2019-06-06 18:18:13.196670257 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-openapi-core.new.4126/python-openapi-core.changes
2019-07-23 22:41:01.306899418 +0200
@@ -1,0 +2,11 @@
+Tue Jul 23 13:45:01 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.11.0:
+  * End of Python 3.4 support (#136)
+  * Add support for one-of with any type (#133)
+  * Modify FlaskOpenAPIRequest to accommodate path variables (#141)
+  * Primitive types unmarshallers (#138)
+  * attr errors hashable fix (#143)
+  * Parameters on path item object support (#144)
+
+---

Old:

  0.10.0.tar.gz

New:

  0.11.0.tar.gz



Other differences:
--
++ python-openapi-core.spec ++
--- /var/tmp/diff_new_pack.GC3GWq/_old  2019-07-23 22:41:01.814898774 +0200
+++ /var/tmp/diff_new_pack.GC3GWq/_new  2019-07-23 22:41:01.814898774 +0200
@@ -17,9 +17,8 @@
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
-# remove with update to > 0.5.0; atm it is not working on py2 at all
 Name:   python-openapi-core
-Version:0.10.0
+Version:0.11.0
 Release:0
 Summary:Adds client-side and server-side support for the oas3
 License:BSD-3-Clause

++ 0.10.0.tar.gz -> 0.11.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/openapi-core-0.10.0/.travis.yml 
new/openapi-core-0.11.0/.travis.yml
--- old/openapi-core-0.10.0/.travis.yml 2019-05-21 14:21:42.0 +0200
+++ new/openapi-core-0.11.0/.travis.yml 2019-06-18 23:42:44.0 +0200
@@ -3,7 +3,6 @@
 matrix:
   include:
   - python: 2.7
-  - python: 3.4
   - python: 3.5
   - python: 3.6
   - python: 3.7
@@ -14,12 +13,12 @@
   allow_failures:
   - python: nightly
 before_install:
-- if [[ $TRAVIS_PYTHON_VERSION == '3.2' ]]; then pip install 'coverage<4.0.0'; 
fi
 - pip install codecov
 - pip install 'py>=1.5.0'
 install:
-- pip install -e .
+- pip install -r requirements.txt
 - pip install -r requirements_dev.txt
+- pip install -e .
 script:
 - python setup.py test
 after_success:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/openapi-core-0.10.0/openapi_core/__init__.py 
new/openapi-core-0.11.0/openapi_core/__init__.py
--- old/openapi-core-0.10.0/openapi_core/__init__.py2019-05-21 
14:21:42.0 +0200
+++ new/openapi-core-0.11.0/openapi_core/__init__.py2019-06-18 
23:42:44.0 +0200
@@ -6,7 +6,7 @@
 
 __author__ = 'Artur Maciag'
 __email__ = 'maciag.ar...@gmail.com'
-__version__ = '0.10.0'
+__version__ = '0.11.0'
 __url__ = 'https://github.com/p1c2u/openapi-core'
 __license__ = 'BSD 3-Clause License'
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/openapi-core-0.10.0/openapi_core/schema/content/exceptions.py 
new/openapi-core-0.11.0/openapi_core/schema/content/exceptions.py
--- old/openapi-core-0.10.0/openapi_core/schema/content/exceptions.py   
2019-05-21 14:21:42.0 +0200
+++ new/openapi-core-0.11.0/openapi_core/schema/content/exceptions.py   
2019-06-18 23:42:44.0 +0200
@@ -1,13 +1,13 @@
-from openapi_core.schema.exceptions import OpenAPIMappingError
-
 import attr
 
+from openapi_core.schema.exceptions import OpenAPIMappingError
+
 
 class OpenAPIContentError(OpenAPIMappingError):
 pass
 
 
-@attr.s
+@attr.s(hash=True)
 class MimeTypeNotFound(OpenAPIContentError):
 mimetype = attr.ib()
 availableMimetypes = attr.ib()
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/openapi-core-0.10.0/openapi_core/schema/content/models.py 
new/openapi-core-0.11.0/openapi_core/schema/content/models.py
--- old/openapi-core-0.10.0/openapi_core/schema/content/models.py   
2019-05-21 14:21:42.0 +0200
+++ new/openapi-core-0.11.0/openapi_core/schema/content/models.py   
2019-06-18 23:42:44.0 +0200
@@ -18,4 +18,4 @@
 if fnmatch.fnmatch(mimetype, key):
 return value
 
-raise MimeTypeNotFound(mimetype, self.keys())
+raise MimeTypeNotFound(mimetype, list(self.keys()))
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit python-peewee for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-peewee for openSUSE:Factory 
checked in at 2019-07-23 22:40:35

Comparing /work/SRC/openSUSE:Factory/python-peewee (Old)
 and  /work/SRC/openSUSE:Factory/.python-peewee.new.4126 (New)


Package is "python-peewee"

Tue Jul 23 22:40:35 2019 rev:8 rq:717890 version:3.9.6

Changes:

--- /work/SRC/openSUSE:Factory/python-peewee/python-peewee.changes  
2019-05-13 14:52:41.919114925 +0200
+++ /work/SRC/openSUSE:Factory/.python-peewee.new.4126/python-peewee.changes
2019-07-23 22:40:40.278926072 +0200
@@ -1,0 +2,12 @@
+Tue Jul 23 11:32:26 UTC 2019 - Tomáš Chvátal 
+
+- Update to 3.9.6:
+  * Support nesting the Database instance as a context-manager. The outermost 
block will handle opening and closing the connection along with wrapping 
everything in a transaction. Nested blocks will use savepoints.
+  * Add new session_start(), session_commit() and session_rollback() 
interfaces to the Database object to support using transactional controls in 
situations where a context-manager or decorator is awkward.
+  * Fix error that would arise when attempting to do an empty bulk-insert.
+  * Set isolation_level=None in SQLite connection constructor rather than 
afterwards using the setter.
+  * Add create_table() method to Select query to implement CREATE TABLE AS.
+  * Cleanup some declarations in the Sqlite C extension.
+  * Add new example showing how to implement Reddit's ranking algorithm in SQL.
+
+---

Old:

  peewee-3.9.5.tar.gz

New:

  peewee-3.9.6.tar.gz



Other differences:
--
++ python-peewee.spec ++
--- /var/tmp/diff_new_pack.NAijU5/_old  2019-07-23 22:40:41.170924942 +0200
+++ /var/tmp/diff_new_pack.NAijU5/_new  2019-07-23 22:40:41.206924896 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-peewee
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-peewee
-Version:3.9.5
+Version:3.9.6
 Release:0
 Summary:An expressive ORM that supports multiple SQL backends
 License:BSD-3-Clause

++ peewee-3.9.5.tar.gz -> peewee-3.9.6.tar.gz ++
 84153 lines of diff (skipped)




commit python-ordered-namespace for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-ordered-namespace for 
openSUSE:Factory checked in at 2019-07-23 22:40:51

Comparing /work/SRC/openSUSE:Factory/python-ordered-namespace (Old)
 and  /work/SRC/openSUSE:Factory/.python-ordered-namespace.new.4126 (New)


Package is "python-ordered-namespace"

Tue Jul 23 22:40:51 2019 rev:5 rq:717901 version:2019.6.8

Changes:

--- 
/work/SRC/openSUSE:Factory/python-ordered-namespace/python-ordered-namespace.changes
2019-06-06 18:16:17.932704010 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-ordered-namespace.new.4126/python-ordered-namespace.changes
  2019-07-23 22:40:55.454906835 +0200
@@ -1,0 +2,8 @@
+Tue Jul 23 13:40:19 UTC 2019 - Tomáš Chvátal 
+
+- Update to 2019.6.8:
+  * Jupyter/iPython pretty printing works even better than before. Everything 
lines up and is easier to read at a glance.
+  * Tab auto-completion now shows both class methods and data attribute. 
Previously it only showed data attributes.
+  * Full support for pickle serialization/deserialization.
+
+---

Old:

  ordered_namespace-2018.6.26.tar.gz

New:

  ordered_namespace-2019.6.8.tar.gz



Other differences:
--
++ python-ordered-namespace.spec ++
--- /var/tmp/diff_new_pack.x51m1i/_old  2019-07-23 22:40:56.102906015 +0200
+++ /var/tmp/diff_new_pack.x51m1i/_new  2019-07-23 22:40:56.122905989 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-ordered-namespace
-Version:2018.6.26
+Version:2019.6.8
 Release:0
 Summary:Python namespace class
 License:MIT

++ ordered_namespace-2018.6.26.tar.gz -> ordered_namespace-2019.6.8.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ordered_namespace-2018.6.26/PKG-INFO 
new/ordered_namespace-2019.6.8/PKG-INFO
--- old/ordered_namespace-2018.6.26/PKG-INFO2018-06-27 01:54:24.0 
+0200
+++ new/ordered_namespace-2019.6.8/PKG-INFO 2019-06-09 05:57:42.0 
+0200
@@ -1,11 +1,11 @@
 Metadata-Version: 1.0
 Name: ordered_namespace
-Version: 2018.6.26
-Summary: An easy-to-use Python namespace class derived from OrderedDict, 
including tab-completion
+Version: 2019.6.8
+Summary: An easy-to-use Python namespace class derived from OrderedDict, 
includes tab-completion
 Home-page: https://github.com/who8mylunch/OrderedNamespace
 Author: Pierre V. Villeneuve
 Author-email: pierre.villene...@gmail.com
 License: MIT
 Description: UNKNOWN
-Keywords: namespace,ordereddict,structure
+Keywords: namespace,ordereddict,structure,dotdict,tab-completion
 Platform: UNKNOWN
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ordered_namespace-2018.6.26/README.md 
new/ordered_namespace-2019.6.8/README.md
--- old/ordered_namespace-2018.6.26/README.md   2017-07-18 04:03:52.0 
+0200
+++ new/ordered_namespace-2019.6.8/README.md2019-06-08 23:05:09.0 
+0200
@@ -1,6 +1,6 @@
 # OrderedNamespace
 
-Namespaces are a great idea and this one is mine.
+Dot-accessible attributes and namespaces are great ideas and this one is mine.
 
 What's the big deal?  Python dicts are just fine, but in the Jupyter/IPython 
interactive environment I hate having to deal with brackets and quotes when 
using tab-based auto-completion to get a quick glance at the contents of an 
object.
 
@@ -68,4 +68,3 @@
 - http://ipython.readthedocs.io/en/stable/config/integrating.html
 - https://github.com/ipython/ipython/blob/master/IPython/lib/pretty.py
 - https://docs.python.org/3/library/functions.html#dir
-
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/ordered_namespace-2018.6.26/ordered_namespace/core.py 
new/ordered_namespace-2019.6.8/ordered_namespace/core.py
--- old/ordered_namespace-2018.6.26/ordered_namespace/core.py   2018-06-27 
01:51:59.0 +0200
+++ new/ordered_namespace-2019.6.8/ordered_namespace/core.py2019-06-09 
05:48:13.0 +0200
@@ -1,46 +1,48 @@
 from collections import OrderedDict, UserDict
 import re
 
+__all__ = ['Struct']
 
 
-
-def convert_to_struct(value):
+def safe_convert_to_struct(value, nested=False):
 """Convert the following to Structs:
- dicts
- list elements that are dicts
- ???
 
-This function is harmless to call on arbitrary variables.
+This function is harmless to call on un-handled variables.
 """
 direct_converts = [dict, OrderedDict, UserDict]
 if type(value) in direct_converts:
 # Convert dict-like things to Struct
-value = Struct(value)
+value = 

commit python-portalocker for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-portalocker for 
openSUSE:Factory checked in at 2019-07-23 22:39:56

Comparing /work/SRC/openSUSE:Factory/python-portalocker (Old)
 and  /work/SRC/openSUSE:Factory/.python-portalocker.new.4126 (New)


Package is "python-portalocker"

Tue Jul 23 22:39:56 2019 rev:4 rq:717856 version:1.5.0

Changes:

--- /work/SRC/openSUSE:Factory/python-portalocker/python-portalocker.changes
2019-02-15 10:02:17.895627757 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-portalocker.new.4126/python-portalocker.changes
  2019-07-23 22:39:57.634939394 +0200
@@ -1,0 +2,7 @@
+Tue Jul 23 11:18:57 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.5.0:
+  * No upstream changelog
+- Switch to github tarball to include tests
+
+---

Old:

  portalocker-1.4.0.tar.gz

New:

  v1.5.0.tar.gz



Other differences:
--
++ python-portalocker.spec ++
--- /var/tmp/diff_new_pack.j13xrI/_old  2019-07-23 22:39:58.442939228 +0200
+++ /var/tmp/diff_new_pack.j13xrI/_new  2019-07-23 22:39:58.462939223 +0200
@@ -18,13 +18,13 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-portalocker
-Version:1.4.0
+Version:1.5.0
 Release:0
 Summary:Locking library for Python
 License:Python-2.0
 Group:  Development/Languages/Python
 URL:https://github.com/WoLpH/portalocker
-Source: 
https://files.pythonhosted.org/packages/source/p/portalocker/portalocker-%{version}.tar.gz
+Source: https://github.com/WoLpH/portalocker/archive/v%{version}.tar.gz
 BuildRequires:  %{python_module Sphinx >= 1.7.1}
 BuildRequires:  %{python_module pytest >= 3.4.0}
 BuildRequires:  %{python_module setuptools >= 38.3.0}
@@ -43,6 +43,8 @@
 
 %prep
 %setup -q -n portalocker-%{version}
+# do not bother with benchmark and cov
+rm pytest.ini
 
 %build
 %python_build
@@ -50,10 +52,9 @@
 %install
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
-%python_expand rm -rf %{buildroot}%{$python_sitelib}/tests/
 
 %check
-%python_expand PYTHONPATH=%{buildroot}%{$python_sitelib} 
py.test-%{$python_bin_suffix} tests/t*.py
+%pytest
 
 %files %{python_files}
 %license LICENSE




commit kubic-cilium-image for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package kubic-cilium-image for 
openSUSE:Factory checked in at 2019-07-23 22:40:32

Comparing /work/SRC/openSUSE:Factory/kubic-cilium-image (Old)
 and  /work/SRC/openSUSE:Factory/.kubic-cilium-image.new.4126 (New)


Package is "kubic-cilium-image"

Tue Jul 23 22:40:32 2019 rev:2 rq:717883 version:4.0.0

Changes:




Other differences:
--
++ kubic-cilium-image.kiwi ++
--- /var/tmp/diff_new_pack.TumPpu/_old  2019-07-23 22:40:35.926931491 +0200
+++ /var/tmp/diff_new_pack.TumPpu/_new  2019-07-23 22:40:35.926931491 +0200
@@ -1,4 +1,5 @@
 
+
 
 
 
   
@@ -12,16 +13,18 @@
   derived_from="obsrepositories:/_BASEIMAGE_">
   
+additionaltags="%%LONG_VERSION%%,%%LONG_VERSION%%-%RELEASE%">
 
 
-  
+  
 
 
 
 
+
+
   
 
 Cilium Container
@@ -50,5 +53,4 @@
 -->
 
   
-_EXTRA_BOOTSTRAP_PACKAGES_
 

++ pre_checkin.sh ++
--- /var/tmp/diff_new_pack.TumPpu/_old  2019-07-23 22:40:36.018931466 +0200
+++ /var/tmp/diff_new_pack.TumPpu/_new  2019-07-23 22:40:36.018931466 +0200
@@ -48,10 +48,12 @@
 product='kubic'
 baseimage="opensuse/tumbleweed#latest"
 distro="openSUSE Kubic"
+label_prefix="org.opensuse.kubic"
 elif [[ "${namespace}" =~ ^caasp/.* ]]; then
 product='caasp'
-baseimage="suse/sle15#latest"
-distro="SLES15"
+baseimage="suse/sle15#15.1"
+distro="SLES15 SP1"
+label_prefix="com.suse.caasp"
 else
 usage
 abort "Unknown product. Product needs to match 'kubic|caasp/.*'"
@@ -92,6 +94,7 @@
 -e "s@_DISTRO_@${distro}@g" \
 -e "s@_NAMESPACE_@${namespace}@g" \
 -e "s@_PRODUCT_@${product}@g" \
+-e "s@_LABEL_PREFIX_@${label_prefix}@g" \
 -e "/^\n" \




commit python-pika for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-pika for openSUSE:Factory 
checked in at 2019-07-23 22:40:14

Comparing /work/SRC/openSUSE:Factory/python-pika (Old)
 and  /work/SRC/openSUSE:Factory/.python-pika.new.4126 (New)


Package is "python-pika"

Tue Jul 23 22:40:14 2019 rev:15 rq:717865 version:1.1.0

Changes:

--- /work/SRC/openSUSE:Factory/python-pika/python-pika.changes  2019-06-19 
21:10:38.446639928 +0200
+++ /work/SRC/openSUSE:Factory/.python-pika.new.4126/python-pika.changes
2019-07-23 22:40:15.946935614 +0200
@@ -1,0 +2,7 @@
+Tue Jul 23 11:28:43 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.1.0:
+  * various bugfixes
+- Drop merged patch e95001e480ec30f1617c47e77fb92e0384ff9e78.patch
+
+---

Old:

  1.0.1.tar.gz
  e95001e480ec30f1617c47e77fb92e0384ff9e78.patch

New:

  1.1.0.tar.gz



Other differences:
--
++ python-pika.spec ++
--- /var/tmp/diff_new_pack.kSULMZ/_old  2019-07-23 22:40:17.190935358 +0200
+++ /var/tmp/diff_new_pack.kSULMZ/_new  2019-07-23 22:40:17.194935357 +0200
@@ -19,15 +19,13 @@
 %define mod_name pika
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-%{mod_name}
-Version:1.0.1
+Version:1.1.0
 Release:0
 Summary:Pika Python AMQP Client Library
 License:BSD-3-Clause
 Group:  Development/Languages/Python
 URL:https://github.com/pika/pika
 Source: https://github.com/pika/pika/archive/%{version}.tar.gz
-# PATCH-FIX-UPSTREAM e95001e480ec30f1617c47e77fb92e0384ff9e78.patch -- 
https://github.com/pika/pika/commit/e95001e480ec30f1617c47e77fb92e0384ff9e78
-Patch0: e95001e480ec30f1617c47e77fb92e0384ff9e78.patch
 BuildRequires:  %{python_module Twisted}
 BuildRequires:  %{python_module mock}
 BuildRequires:  %{python_module nose}
@@ -49,7 +47,6 @@
 
 %prep
 %setup -q -n %{mod_name}-%{version}
-%patch0 -p1
 # acceptance needs running configured server
 rm -rf tests/acceptance/
 sed -i -e 's:,tests/acceptance::' setup.cfg

++ 1.0.1.tar.gz -> 1.1.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pika-1.0.1/CHANGELOG.rst new/pika-1.1.0/CHANGELOG.rst
--- old/pika-1.0.1/CHANGELOG.rst2019-04-12 19:45:56.0 +0200
+++ new/pika-1.1.0/CHANGELOG.rst2019-07-16 19:51:33.0 +0200
@@ -1,6 +1,11 @@
 Version History
 ===
 
+1.1.0 2019-07-16
+
+
+`GitHub milestone `_
+
 1.0.1 2019-04-12
 
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pika-1.0.1/README.rst new/pika-1.1.0/README.rst
--- old/pika-1.0.1/README.rst   2019-04-12 19:45:56.0 +0200
+++ new/pika-1.1.0/README.rst   2019-07-16 19:51:33.0 +0200
@@ -112,8 +112,8 @@
 
 Messages processed in another thread may not be acknowledged directly from that
 thread, since all accesses to the connection adapter instance must be from a
-single thread—the thread that is running the adapter's I/O loop. However, this
-may be accomplished by requesting a callback to be executed in the adapter's
+single thread, which is the thread running the adapter's I/O loop. This is
+accomplished by requesting a callback to be executed in the adapter's
 I/O loop thread. For example, the callback function's implementation might look
 like this:
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pika-1.0.1/docs/conf.py new/pika-1.1.0/docs/conf.py
--- old/pika-1.0.1/docs/conf.py 2019-04-12 19:45:56.0 +0200
+++ new/pika-1.1.0/docs/conf.py 2019-07-16 19:51:33.0 +0200
@@ -1,7 +1,7 @@
 # -*- coding: utf-8 -*-
 import sys
 sys.path.insert(0, '../')
-#needs_sphinx = '1.0'
+# needs_sphinx = '1.0'
 
 extensions = ['sphinx.ext.autodoc', 'sphinx.ext.viewcode',
   'sphinx.ext.intersphinx']
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/pika-1.0.1/docs/examples/blocking_delivery_confirmations.rst 
new/pika-1.1.0/docs/examples/blocking_delivery_confirmations.rst
--- old/pika-1.0.1/docs/examples/blocking_delivery_confirmations.rst
2019-04-12 19:45:56.0 +0200
+++ new/pika-1.1.0/docs/examples/blocking_delivery_confirmations.rst
2019-07-16 19:51:33.0 +0200
@@ -18,11 +18,12 @@
 channel.confirm_delivery()
 
 # Send a message
-if channel.basic_publish(exchange='test',
- routing_key='test',
- body='Hello World!',
- 

commit python-phonenumbers for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-phonenumbers for 
openSUSE:Factory checked in at 2019-07-23 22:40:17

Comparing /work/SRC/openSUSE:Factory/python-phonenumbers (Old)
 and  /work/SRC/openSUSE:Factory/.python-phonenumbers.new.4126 (New)


Package is "python-phonenumbers"

Tue Jul 23 22:40:17 2019 rev:6 rq:717868 version:8.10.15

Changes:

--- /work/SRC/openSUSE:Factory/python-phonenumbers/python-phonenumbers.changes  
2019-06-06 18:15:59.776709326 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-phonenumbers.new.4126/python-phonenumbers.changes
2019-07-23 22:40:25.178933709 +0200
@@ -1,0 +2,6 @@
+Tue Jul 23 11:30:41 UTC 2019 - Tomáš Chvátal 
+
+- Update to 8.10.15:
+  * updates to metadata informations
+
+---

Old:

  phonenumbers-8.10.13.tar.gz

New:

  phonenumbers-8.10.15.tar.gz



Other differences:
--
++ python-phonenumbers.spec ++
--- /var/tmp/diff_new_pack.ASgsCp/_old  2019-07-23 22:40:25.730933595 +0200
+++ /var/tmp/diff_new_pack.ASgsCp/_new  2019-07-23 22:40:25.730933595 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-phonenumbers
-Version:8.10.13
+Version:8.10.15
 Release:0
 Summary:Python version of Google's common library for international 
phone numbers
 License:Apache-2.0

++ phonenumbers-8.10.13.tar.gz -> phonenumbers-8.10.15.tar.gz ++
 13398 lines of diff (skipped)




commit python-shaptools for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-shaptools for 
openSUSE:Factory checked in at 2019-07-23 22:40:21

Comparing /work/SRC/openSUSE:Factory/python-shaptools (Old)
 and  /work/SRC/openSUSE:Factory/.python-shaptools.new.4126 (New)


Package is "python-shaptools"

Tue Jul 23 22:40:21 2019 rev:5 rq:717873 version:0.3.1

Changes:

--- /work/SRC/openSUSE:Factory/python-shaptools/python-shaptools.changes
2019-07-21 11:33:40.348784109 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-shaptools.new.4126/python-shaptools.changes  
2019-07-23 22:40:26.514933434 +0200
@@ -1,0 +2,11 @@
+Tue Jul 23 11:04:25 UTC 2019 - Xabier Arbulu Insausti 
+
+- Create package version 0.3.1
+- Add support for Power machines 
+
+---
+Thu Jul 18 08:46:15 UTC 2019 - Xabier Arbulu Insausti 
+
+- Add an option to run the commands in remote nodes to shapcli
+
+---

Old:

  shaptools-0.3.0.tar.gz

New:

  shaptools-0.3.1.tar.gz



Other differences:
--
++ python-shaptools.spec ++
--- /var/tmp/diff_new_pack.5aSiMD/_old  2019-07-23 22:40:26.926933349 +0200
+++ /var/tmp/diff_new_pack.5aSiMD/_new  2019-07-23 22:40:26.930933348 +0200
@@ -22,7 +22,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-shaptools
-Version:0.3.0
+Version:0.3.1
 Release:0
 Summary:Python tools to interact with SAP HANA utilities
 License:Apache-2.0

++ shaptools-0.3.0.tar.gz -> shaptools-0.3.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/shaptools-0.3.0/docs/SHAPCLI.md 
new/shaptools-0.3.1/docs/SHAPCLI.md
--- old/shaptools-0.3.0/docs/SHAPCLI.md 2019-07-18 11:03:12.820176367 +0200
+++ new/shaptools-0.3.1/docs/SHAPCLI.md 2019-07-23 13:12:24.071282674 +0200
@@ -49,3 +49,17 @@
 ```
 shapcli hana -h
 ```
+
+### Running commands in remote nodes
+
+The commands can be executed in remote nodes too. For that the `-r` or 
`--remote` flag have to be
+used (or adding the `remote` entry in the configuration file [the `-r` flag 
has priority over the configuration file entry]).
+
+```
+shapcli -c config.json -r remotehost hana version
+```
+
+If the ssh keys of the current node is not installed in the remote host, the 
password must be
+provided after the command. To avoid this, the ssh key of the current node can 
be authorized in the
+remote node. By default, the ssh public key must be added in: 
`/usr/sap/PRD/home/.ssh/authorized_keys`
+(where `PRD` is the SAP HANA instanse sid in uppercase)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/shaptools-0.3.0/python-shaptools.changes 
new/shaptools-0.3.1/python-shaptools.changes
--- old/shaptools-0.3.0/python-shaptools.changes2019-07-18 
11:03:12.820176367 +0200
+++ new/shaptools-0.3.1/python-shaptools.changes2019-07-23 
13:12:24.071282674 +0200
@@ -1,8 +1,19 @@
 ---
+Tue Jul 23 11:04:25 UTC 2019 - Xabier Arbulu Insausti 
+
+- Create package version 0.3.1
+- Add support for Power machines 
+
+---
+Thu Jul 18 08:46:15 UTC 2019 - Xabier Arbulu Insausti 
+
+- Add an option to run the commands in remote nodes to shapcli
+
+---
 Wed Jul 17 09:34:22 UTC 2019 - Xabier Arbulu Insausti 
 
 - Create package version 0.3.0
-- shapcli is provided to expose shaptools api methods as command line tool 
+- shapcli is provided to expose shaptools api methods as command line tool
 
 ---
 Tue Jun 11 11:29:44 UTC 2019 - Xabier Arbulu Insausti 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/shaptools-0.3.0/python-shaptools.spec 
new/shaptools-0.3.1/python-shaptools.spec
--- old/shaptools-0.3.0/python-shaptools.spec   2019-07-18 11:03:12.820176367 
+0200
+++ new/shaptools-0.3.1/python-shaptools.spec   2019-07-23 13:12:24.071282674 
+0200
@@ -22,7 +22,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-shaptools
-Version:0.3.0
+Version:0.3.1
 Release:0
 Summary:Python tools to interact with SAP HANA utilities
 License:Apache-2.0
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/shaptools-0.3.0/shaptools/__init__.py 
new/shaptools-0.3.1/shaptools/__init__.py
--- 

commit python-pip-api for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-pip-api for openSUSE:Factory 
checked in at 2019-07-23 22:40:09

Comparing /work/SRC/openSUSE:Factory/python-pip-api (Old)
 and  /work/SRC/openSUSE:Factory/.python-pip-api.new.4126 (New)


Package is "python-pip-api"

Tue Jul 23 22:40:09 2019 rev:4 rq:717861 version:0.0.12

Changes:

--- /work/SRC/openSUSE:Factory/python-pip-api/python-pip-api.changes
2019-06-20 18:54:47.968796427 +0200
+++ /work/SRC/openSUSE:Factory/.python-pip-api.new.4126/python-pip-api.changes  
2019-07-23 22:40:11.606936511 +0200
@@ -1,0 +2,6 @@
+Tue Jul 23 11:27:24 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.0.12:
+  * Bugfix with relative paths (#39)
+
+---

Old:

  pip-api-0.0.10.tar.gz

New:

  pip-api-0.0.12.tar.gz



Other differences:
--
++ python-pip-api.spec ++
--- /var/tmp/diff_new_pack.wf9qxG/_old  2019-07-23 22:40:12.126936403 +0200
+++ /var/tmp/diff_new_pack.wf9qxG/_new  2019-07-23 22:40:12.126936403 +0200
@@ -18,12 +18,12 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pip-api
-Version:0.0.10
+Version:0.0.12
 Release:0
 Summary:The official unofficial pip API
 License:Apache-2.0
 Group:  Development/Languages/Python
-URL:http://github.com/di/pip-api
+URL:https://github.com/di/pip-api
 Source: 
https://files.pythonhosted.org/packages/source/p/pip-api/pip-api-%{version}.tar.gz
 Patch0: unvendor.patch
 BuildRequires:  %{python_module packaging >= 16.1}

++ pip-api-0.0.10.tar.gz -> pip-api-0.0.12.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pip-api-0.0.10/PKG-INFO new/pip-api-0.0.12/PKG-INFO
--- old/pip-api-0.0.10/PKG-INFO 2019-06-07 06:27:43.0 +0200
+++ new/pip-api-0.0.12/PKG-INFO 2019-07-09 18:40:22.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: pip-api
-Version: 0.0.10
+Version: 0.0.12
 Summary: An unofficial, importable pip API
 Home-page: http://github.com/di/pip-api
 Author: Dustin Ingram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pip-api-0.0.10/pip_api/_parse_requirements.py 
new/pip-api-0.0.12/pip_api/_parse_requirements.py
--- old/pip-api-0.0.10/pip_api/_parse_requirements.py   2019-06-06 
22:24:25.0 +0200
+++ new/pip-api-0.0.12/pip_api/_parse_requirements.py   2019-07-09 
11:56:43.0 +0200
@@ -177,6 +177,7 @@
 
 while to_parse:
 filename = to_parse.pop()
+dirname = os.path.dirname(filename)
 parsed.add(filename)
 
 # Combine multi-line commands
@@ -203,8 +204,9 @@
 raise
 
 elif known.requirements:
-if known.requirements not in parsed:
-to_parse.add(known.requirements)
+full_path = os.path.join(dirname, known.requirements)
+if full_path not in parsed:
+to_parse.add(full_path)
 elif known.editable:
 name, url = _parse_editable(known.editable)
 req = requirements.Requirement("%s @ %s" % (name, url))
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pip-api-0.0.10/pip_api.egg-info/PKG-INFO 
new/pip-api-0.0.12/pip_api.egg-info/PKG-INFO
--- old/pip-api-0.0.10/pip_api.egg-info/PKG-INFO2019-06-07 
06:27:43.0 +0200
+++ new/pip-api-0.0.12/pip_api.egg-info/PKG-INFO2019-07-09 
18:40:22.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: pip-api
-Version: 0.0.10
+Version: 0.0.12
 Summary: An unofficial, importable pip API
 Home-page: http://github.com/di/pip-api
 Author: Dustin Ingram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pip-api-0.0.10/setup.py new/pip-api-0.0.12/setup.py
--- old/pip-api-0.0.10/setup.py 2019-06-07 06:27:15.0 +0200
+++ new/pip-api-0.0.12/setup.py 2019-07-09 18:39:53.0 +0200
@@ -24,5 +24,5 @@
 python_requires=">=2.7,!=3.0,!=3.1,!=3.2,!=3.3",
 url="http://github.com/di/pip-api;,
 summary="An unofficial, importable pip API",
-version="0.0.10",
+version="0.0.12",
 )
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pip-api-0.0.10/tests/test_parse_requirements.py 
new/pip-api-0.0.12/tests/test_parse_requirements.py
--- old/pip-api-0.0.10/tests/test_parse_requirements.py 2019-06-06 
22:24:25.0 +0200
+++ new/pip-api-0.0.12/tests/test_parse_requirements.py 2019-07-09 
11:56:43.0 +0200
@@ -176,3 +176,15 @@
 

commit python-precis-i18n for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-precis-i18n for 
openSUSE:Factory checked in at 2019-07-23 22:39:45

Comparing /work/SRC/openSUSE:Factory/python-precis-i18n (Old)
 and  /work/SRC/openSUSE:Factory/.python-precis-i18n.new.4126 (New)


Package is "python-precis-i18n"

Tue Jul 23 22:39:45 2019 rev:2 rq:717855 version:1.0.1

Changes:

--- /work/SRC/openSUSE:Factory/python-precis-i18n/python-precis-i18n.changes
2018-11-20 22:43:29.662259274 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-precis-i18n.new.4126/python-precis-i18n.changes
  2019-07-23 22:39:51.982940561 +0200
@@ -1,0 +2,9 @@
+Tue Jul 23 11:14:01 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.0.1:
+  * Fixed a dict/set syntax typo that has no runtime effect (6ae6876).
+  * Test forward compatibility of derived props test files as Unicode version 
increases.
+  * Test Unicode 11.0 (Python 3.7).
+- Switch to github tarball for all test fixtures
+
+---

Old:

  precis_i18n-1.0.0.tar.gz

New:

  v1.0.1.tar.gz



Other differences:
--
++ python-precis-i18n.spec ++
--- /var/tmp/diff_new_pack.LEh5PI/_old  2019-07-23 22:39:53.322940284 +0200
+++ /var/tmp/diff_new_pack.LEh5PI/_new  2019-07-23 22:39:53.338940281 +0200
@@ -1,7 +1,7 @@
 #
-# spec file for package precis-i18n
+# spec file for package python-precis-i18n
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,13 +20,13 @@
 %define skip_python2 1
 %define _name   precis_i18n
 Name:   python-precis-i18n
-Version:1.0.0
+Version:1.0.1
 Release:0
 Summary:Internationalised Usernames and Passwords
 License:MIT
 Group:  Development/Languages/Python
 URL:https://github.com/byllyfish/precis_i18n
-Source: 
https://files.pythonhosted.org/packages/source/p/%{_name}/%{_name}-%{version}.tar.gz
+Source: 
https://github.com/byllyfish/precis_i18n/archive/v%{version}.tar.gz
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros




commit python-prometheus_client for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-prometheus_client for 
openSUSE:Factory checked in at 2019-07-23 22:39:26

Comparing /work/SRC/openSUSE:Factory/python-prometheus_client (Old)
 and  /work/SRC/openSUSE:Factory/.python-prometheus_client.new.4126 (New)


Package is "python-prometheus_client"

Tue Jul 23 22:39:26 2019 rev:5 rq:717851 version:0.7.1

Changes:

--- 
/work/SRC/openSUSE:Factory/python-prometheus_client/python-prometheus_client.changes
2019-06-20 19:04:43.437612233 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-prometheus_client.new.4126/python-prometheus_client.changes
  2019-07-23 22:39:27.322945650 +0200
@@ -1,0 +2,7 @@
+Tue Jul 23 11:11:01 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.7.1:
+  * [BUGFIX] multiprocess: don't crash on missing gauge_live/sum files (#424)
+  * [BUGFIX] correctly bind method on Python 2.x (#403)
+
+---

Old:

  v0.7.0.tar.gz

New:

  v0.7.1.tar.gz



Other differences:
--
++ python-prometheus_client.spec ++
--- /var/tmp/diff_new_pack.QNzjAm/_old  2019-07-23 22:39:28.006945509 +0200
+++ /var/tmp/diff_new_pack.QNzjAm/_new  2019-07-23 22:39:28.010945508 +0200
@@ -18,18 +18,18 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-prometheus_client
-Version:0.7.0
+Version:0.7.1
 Release:0
 Summary:Python client for the Prometheus monitoring system
 License:Apache-2.0
 Group:  Development/Languages/Python
 URL:https://github.com/prometheus/client_python
-#Source: 
https://files.pythonhosted.org/packages/source/p/prometheus_client/prometheus_client-%{version}.tar.gz
 Source: 
https://github.com/prometheus/client_python/archive/v%{version}.tar.gz
 BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
+BuildRequires:  python2-futures
 Suggests:   python-twisted
 BuildArch:  noarch
 %python_subpackages
@@ -48,9 +48,7 @@
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
 %check
-# test_core.py needs concurrent.futures, which is only in python3
-py.test2 --ignore=tests/test_core.py tests
-py.test3 tests
+%pytest
 
 %files %{python_files}
 %doc README.md

++ v0.7.0.tar.gz -> v0.7.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/client_python-0.7.0/prometheus_client/metrics.py 
new/client_python-0.7.1/prometheus_client/metrics.py
--- old/client_python-0.7.0/prometheus_client/metrics.py2019-06-07 
12:36:14.0 +0200
+++ new/client_python-0.7.1/prometheus_client/metrics.py2019-06-20 
15:33:44.0 +0200
@@ -14,6 +14,10 @@
 
 if sys.version_info > (3,):
 unicode = str
+create_bound_method = types.MethodType
+else:
+def create_bound_method(func, obj):
+return types.MethodType(func, obj, obj.__class__)
 
 
 def _build_full_name(metric_type, name, namespace, subsystem, unit):
@@ -369,7 +373,7 @@
 def samples(self):
 return (('', {}, float(f())),)
 
-self._child_samples = types.MethodType(samples, self)
+self._child_samples = create_bound_method(samples, self)
 
 def _child_samples(self):
 return (('', {}, self._value.get()),)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/client_python-0.7.0/prometheus_client/multiprocess.py 
new/client_python-0.7.1/prometheus_client/multiprocess.py
--- old/client_python-0.7.0/prometheus_client/multiprocess.py   2019-06-07 
12:36:14.0 +0200
+++ new/client_python-0.7.1/prometheus_client/multiprocess.py   2019-06-20 
15:33:44.0 +0200
@@ -12,6 +12,11 @@
 from .samples import Sample
 from .utils import floatToGoString
 
+try:  # Python3
+FileNotFoundError
+except NameError:  # Python >= 2.5
+FileNotFoundError = IOError
+
 MP_METRIC_HELP = 'Multiprocess metric'
 
 
@@ -54,7 +59,16 @@
 for f in files:
 parts = os.path.basename(f).split('_')
 typ = parts[0]
-for key, value, pos in MmapedDict.read_all_values_from_file(f):
+try:
+file_values = MmapedDict.read_all_values_from_file(f)
+except FileNotFoundError:
+if typ == 'gauge' and parts[1] in ('liveall', 'livesum'):
+# Those files can disappear between the glob of collect
+# and now (via a mark_process_dead call) so don't fail if
+# the file is missing
+continue
+raise
+for key, value, pos in 

commit python-py-ubjson for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-py-ubjson for 
openSUSE:Factory checked in at 2019-07-23 22:38:57

Comparing /work/SRC/openSUSE:Factory/python-py-ubjson (Old)
 and  /work/SRC/openSUSE:Factory/.python-py-ubjson.new.4126 (New)


Package is "python-py-ubjson"

Tue Jul 23 22:38:57 2019 rev:4 rq:717847 version:0.14.0

Changes:

--- /work/SRC/openSUSE:Factory/python-py-ubjson/python-py-ubjson.changes
2019-06-07 18:02:12.893780591 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-py-ubjson.new.4126/python-py-ubjson.changes  
2019-07-23 22:38:58.546951589 +0200
@@ -1,0 +2,12 @@
+Tue Jul 23 10:52:11 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.14.0:
+  - Fix DecoderException not including offset when C-extension in use, expose
+property for it.
+  - Fix decoding via C extension reading too much data from file-like objects
+  - Test suite exercises both pure & extension modules when extension enabled
+  - Expand test suite to increase C extension (line) coverage
+  - Remove need for pypandoc/rst (use original README.md)
+  - Fix spelling errors in cli util (hoenn)
+
+---

Old:

  py-ubjson-0.13.0.tar.gz

New:

  py-ubjson-0.14.0.tar.gz



Other differences:
--
++ python-py-ubjson.spec ++
--- /var/tmp/diff_new_pack.4qgS8d/_old  2019-07-23 22:38:59.154951464 +0200
+++ /var/tmp/diff_new_pack.4qgS8d/_new  2019-07-23 22:38:59.162951462 +0200
@@ -19,13 +19,13 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define modname py-ubjson
 Name:   python-py-ubjson
-Version:0.13.0
+Version:0.14.0
 Release:0
 Summary:Universal Binary JSON encoder/decoder
 License:Apache-2.0
 Group:  Development/Languages/Python
-Url:https://github.com/Iotic-Labs/py-ubjson
-Source: 
https://files.pythonhosted.org/packages/source/p/%{modname}/%{modname}-%{version}.tar.gz
+URL:https://github.com/Iotic-Labs/py-ubjson
+Source: 
https://files.pythonhosted.org/packages/source/p/py-ubjson/%{modname}-%{version}.tar.gz
 BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes

++ py-ubjson-0.13.0.tar.gz -> py-ubjson-0.14.0.tar.gz ++
 1745 lines of diff (skipped)




commit skiboot for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package skiboot for openSUSE:Factory checked 
in at 2019-07-23 22:39:17

Comparing /work/SRC/openSUSE:Factory/skiboot (Old)
 and  /work/SRC/openSUSE:Factory/.skiboot.new.4126 (New)


Package is "skiboot"

Tue Jul 23 22:39:17 2019 rev:16 rq:717849 version:6.2.2

Changes:

--- /work/SRC/openSUSE:Factory/skiboot/skiboot.changes  2019-03-14 
15:02:15.223681226 +0100
+++ /work/SRC/openSUSE:Factory/.skiboot.new.4126/skiboot.changes
2019-07-23 22:39:18.698947430 +0200
@@ -1,0 +2,9 @@
+Tue Jul 23 08:18:39 UTC 2019 - Michal Suchanek 
+
+- Fix aligment error with gcc9.
+- add errorlog-Prevent-alignment-error-buiding-with-gcc9.patch
+- add hdata-vpd-fix-printing-char-0x00.patch
+- add struct-p9_sbe_msg-doesn-t-need-to-be-packed.patch
+- refresh libffs-fix-string-truncation.patch
+
+---

New:

  errorlog-Prevent-alignment-error-buiding-with-gcc9.patch
  hdata-vpd-fix-printing-char-0x00.patch
  struct-p9_sbe_msg-doesn-t-need-to-be-packed.patch



Other differences:
--
++ skiboot.spec ++
--- /var/tmp/diff_new_pack.Zvq1Vq/_old  2019-07-23 22:39:19.346947297 +0200
+++ /var/tmp/diff_new_pack.Zvq1Vq/_new  2019-07-23 22:39:19.350947296 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -27,6 +27,9 @@
 Url:https://github.com/open-power/skiboot
 Source: skiboot-%{version}.tar.gz
 Patch1: libffs-fix-string-truncation.patch
+Patch2: struct-p9_sbe_msg-doesn-t-need-to-be-packed.patch
+Patch3: hdata-vpd-fix-printing-char-0x00.patch
+Patch4: errorlog-Prevent-alignment-error-buiding-with-gcc9.patch
 BuildRequires:  libopenssl-devel
 BuildRequires:  linux-glibc-devel
 BuildRequires:  systemd-rpm-macros

++ errorlog-Prevent-alignment-error-buiding-with-gcc9.patch ++
>From a3d976ddfd376cd1c5b6ae7aa3c5e7139a5a4032 Mon Sep 17 00:00:00 2001
From: Michal Suchanek 
Date: Tue, 23 Jul 2019 10:04:22 +0200
Subject: [PATCH] errorlog: Prevent alignment error buiding with gcc9.

Fixes this build error:
[ 52s] hw/fsp/fsp-elog-write.c: In function 'opal_elog_read':
[ 52s] hw/fsp/fsp-elog-write.c:213:12: error: taking address of packed member 
of 'struct errorlog' may result in an unaligned pointer value 
[-Werror=address-of-packed-member]
[ 52s] 213 | list_del(_data->link);
[ 52s] | ^~~

Fixes: https://github.com/open-power/skiboot/issues/247
Signed-off-by: Michal Suchanek 
---
 include/errorlog.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/errorlog.h b/include/errorlog.h
index 6da96649e048..b4cc163ced39 100644
--- a/include/errorlog.h
+++ b/include/errorlog.h
@@ -119,7 +119,7 @@ struct __attribute__((__packed__))elog_user_data_section {
  * needs to populate this structure using pre-defined interfaces
  * only
  */
-struct __attribute__((__packed__)) errorlog {
+struct __attribute__((__packed__)) __attribute__ ((aligned (8))) errorlog {
 
uint16_t component_id;
uint8_t error_event_type;
-- 
2.22.0

++ hdata-vpd-fix-printing-char-0x00.patch ++
>From ba977f2e4406f9de318afcdf5d666e77585ef269 Mon Sep 17 00:00:00 2001
From: Stewart Smith 
Date: Tue, 18 Jun 2019 16:06:44 +1000
Subject: [PATCH] hdata/vpd: fix printing (char*)0x00
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

GCC9 now catches this bug:

In file included from hdata/vpd.c:17:
In function ‘vpd_vini_parse’,
inlined from ‘vpd_data_parse’ at hdata/vpd.c:416:3:
/home/stewart/skiboot/include/skiboot.h:93:31: error: ‘%s’ directive argument 
is null [-Werror=format-overflow=]
   93 | #define prlog(l, f, ...) do { _prlog(l, pr_fmt(f), ##__VA_ARGS__); } 
while(0)
  |   ^~~
hdata/vpd.c:390:5: note: in expansion of macro ‘prlog’
  390 | prlog(PR_WARNING,
  | ^
hdata/vpd.c: In function ‘vpd_data_parse’:
hdata/vpd.c:391:46: note: format string is defined here
  391 |   "VPD: CCIN desc not available for: %s\n",
  |  ^~
cc1: all warnings being treated as errors

Signed-off-by: Stewart Smith 
---
 hdata/vpd.c | 9 +
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/hdata/vpd.c b/hdata/vpd.c
index 129b5062356a..5a01bcc9f6fa 100644
--- a/hdata/vpd.c
+++ b/hdata/vpd.c
@@ -328,6 +328,7 @@ static void vpd_vini_parse(struct dt_node *node,
   

commit python-publicsuffixlist for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-publicsuffixlist for 
openSUSE:Factory checked in at 2019-07-23 22:39:11

Comparing /work/SRC/openSUSE:Factory/python-publicsuffixlist (Old)
 and  /work/SRC/openSUSE:Factory/.python-publicsuffixlist.new.4126 (New)


Package is "python-publicsuffixlist"

Tue Jul 23 22:39:11 2019 rev:7 rq:717848 version:0.6.9

Changes:

--- 
/work/SRC/openSUSE:Factory/python-publicsuffixlist/python-publicsuffixlist.changes
  2019-05-20 13:18:43.867895219 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-publicsuffixlist.new.4126/python-publicsuffixlist.changes
2019-07-23 22:39:12.378948735 +0200
@@ -1,0 +2,6 @@
+Tue Jul 23 10:56:41 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.6.9:
+  * no upstream changelog
+
+---

Old:

  publicsuffixlist-0.6.7.tar.gz

New:

  publicsuffixlist-0.6.9.tar.gz



Other differences:
--
++ python-publicsuffixlist.spec ++
--- /var/tmp/diff_new_pack.zpcZvU/_old  2019-07-23 22:39:12.862948635 +0200
+++ /var/tmp/diff_new_pack.zpcZvU/_new  2019-07-23 22:39:12.866948634 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-publicsuffixlist
-Version:0.6.7
+Version:0.6.9
 Release:0
 Summary:Public suffix list implementaion in Python
 License:MPL-2.0

++ publicsuffixlist-0.6.7.tar.gz -> publicsuffixlist-0.6.9.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/publicsuffixlist-0.6.7/PKG-INFO 
new/publicsuffixlist-0.6.9/PKG-INFO
--- old/publicsuffixlist-0.6.7/PKG-INFO 2019-05-02 23:18:31.0 +0200
+++ new/publicsuffixlist-0.6.9/PKG-INFO 2019-07-13 13:38:35.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: publicsuffixlist
-Version: 0.6.7
+Version: 0.6.9
 Summary: publicsuffixlist implement
 Home-page: https://github.com/ko-zu/psl
 Author: ko-zu
@@ -135,5 +135,5 @@
 Classifier: Topic :: Text Processing :: Filters
 Classifier: Operating System :: OS Independent
 Description-Content-Type: text/markdown
-Provides-Extra: readme
 Provides-Extra: update
+Provides-Extra: readme
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/publicsuffixlist-0.6.7/publicsuffixlist/public_suffix_list.dat 
new/publicsuffixlist-0.6.9/publicsuffixlist/public_suffix_list.dat
--- old/publicsuffixlist-0.6.7/publicsuffixlist/public_suffix_list.dat  
2019-05-02 23:10:41.0 +0200
+++ new/publicsuffixlist-0.6.9/publicsuffixlist/public_suffix_list.dat  
2019-07-13 13:38:17.0 +0200
@@ -586,6 +586,7 @@
 sorocaba.br
 srv.br
 taxi.br
+tc.br
 teo.br
 the.br
 tmp.br
@@ -5891,17 +5892,15 @@
 mil.ru
 test.ru
 
-// rw : http://www.nic.rw/cgi-bin/policy.pl
+// rw : 
https://www.ricta.org.rw/sites/default/files/resources/registry_registrar_contract_0.pdf
 rw
-gov.rw
-net.rw
-edu.rw
 ac.rw
-com.rw
 co.rw
-int.rw
+coop.rw
+gov.rw
 mil.rw
-gouv.rw
+net.rw
+org.rw
 
 // sa : http://www.nic.net.sa/
 sa
@@ -7058,9 +7057,9 @@
 
 
 // newGTLDs
-// List of new gTLDs imported from https://newgtlds.icann.org/newgtlds.csv on 
2018-05-08T19:40:37Z
-// This list is auto-generated, don't edit it manually.
 
+// List of new gTLDs imported from 
https://www.icann.org/resources/registries/gtlds/v2/gtlds.json on 
2019-06-14T10:00:50-04:00
+// This list is auto-generated, don't edit it manually.
 // aaa : 2015-02-26 American Automobile Association, Inc.
 aaa
 
@@ -7106,7 +7105,7 @@
 // aco : 2015-01-08 ACO Severin Ahlmann GmbH & Co. KG
 aco
 
-// actor : 2013-12-12 United TLD Holdco Ltd.
+// actor : 2013-12-12 Dog Beach, LLC
 actor
 
 // adac : 2015-07-16 Allgemeiner Deutscher Automobil-Club e.V. (ADAC)
@@ -7148,7 +7147,7 @@
 // airbus : 2015-07-30 Airbus S.A.S.
 airbus
 
-// airforce : 2014-03-06 United TLD Holdco Ltd.
+// airforce : 2014-03-06 Dog Beach, LLC
 airforce
 
 // airtel : 2014-10-24 Bharti Airtel Limited
@@ -7232,10 +7231,10 @@
 // aramco : 2014-11-20 Aramco Services Company
 aramco
 
-// archi : 2014-02-06 Afilias plc
+// archi : 2014-02-06 Afilias Limited
 archi
 
-// army : 2014-03-06 United TLD Holdco Ltd.
+// army : 2014-03-06 Dog Beach, LLC
 army
 
 // art : 2016-03-24 UK Creative Ideas Limited
@@ -7253,10 +7252,10 @@
 // athleta : 2015-07-30 The Gap, Inc.
 athleta
 
-// attorney : 2014-03-20 United TLD Holdco Ltd.
+// attorney : 2014-03-20 Dog Beach, LLC
 attorney
 
-// auction : 2014-03-20 United TLD Holdco Ltd.
+// auction : 2014-03-20 Dog Beach, LLC
 auction
 
 // audi : 2015-05-21 AUDI Aktiengesellschaft
@@ -7292,7 +7291,7 @@
 // azure : 2014-12-18 Microsoft Corporation
 azure
 
-// baby : 2015-04-09 Johnson & Johnson 

commit python-pyOCD for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-pyOCD for openSUSE:Factory 
checked in at 2019-07-23 22:38:52

Comparing /work/SRC/openSUSE:Factory/python-pyOCD (Old)
 and  /work/SRC/openSUSE:Factory/.python-pyOCD.new.4126 (New)


Package is "python-pyOCD"

Tue Jul 23 22:38:52 2019 rev:3 rq:717846 version:0.21.0

Changes:

--- /work/SRC/openSUSE:Factory/python-pyOCD/python-pyOCD.changes
2018-12-24 11:41:39.405438041 +0100
+++ /work/SRC/openSUSE:Factory/.python-pyOCD.new.4126/python-pyOCD.changes  
2019-07-23 22:38:53.658952598 +0200
@@ -1,0 +2,6 @@
+Tue Jul 23 10:48:33 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.21.0:
+  * Too many changes to enumerate
+
+---

Old:

  pyOCD-0.8.1a1.tar.gz

New:

  pyocd-0.21.0.tar.gz



Other differences:
--
++ python-pyOCD.spec ++
--- /var/tmp/diff_new_pack.h3yoKk/_old  2019-07-23 22:38:54.270952472 +0200
+++ /var/tmp/diff_new_pack.h3yoKk/_new  2019-07-23 22:38:54.274952471 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pyOCD
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,44 +18,47 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pyOCD
-Version:0.8.1a1
+Version:0.21.0
 Release:0
 Summary:CMSIS-DAP debugger for python
 License:Apache-2.0
 Group:  Development/Languages/Python
-Url:https://github.com/mbedmicro/pyOCD
-Source: 
https://files.pythonhosted.org/packages/source/p/pyOCD/pyOCD-%{version}.tar.gz
+URL:https://github.com/mbedmicro/pyOCD
+Source: 
https://files.pythonhosted.org/packages/source/p/pyocd/pyocd-%{version}.tar.gz
+BuildRequires:  %{python_module setuptools_scm_git_archive}
 BuildRequires:  %{python_module setuptools_scm}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
 Requires:   python-usb
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+Provides:   python-pyocd = %{version}
+Obsoletes:  python-pyocd < %{version}
 BuildArch:  noarch
-
 %python_subpackages
 
 %description
 On-chip debugger and flasher tool for ARM microcontrollers.
 
 %prep
-%setup -q -n pyOCD-%{version}
+%setup -q -n pyocd-%{version}
 
 %build
 %python_build
 
 %install
 %python_install
+%python_clone %{buildroot}%{_bindir}/pyocd
 %python_clone %{buildroot}%{_bindir}/pyocd-flashtool
 %python_clone %{buildroot}%{_bindir}/pyocd-gdbserver
 %python_clone %{buildroot}%{_bindir}/pyocd-tool
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
 %files %{python_files}
-%defattr(-,root,root,-)
 %{_bindir}/pyocd-flashtool-%{python_bin_suffix}
 %{_bindir}/pyocd-gdbserver-%{python_bin_suffix}
 %{_bindir}/pyocd-tool-%{python_bin_suffix}
+%{_bindir}/pyocd-%{python_bin_suffix}
+%python3_only %{_bindir}/pyocd
 %python3_only %{_bindir}/pyocd-flashtool
 %python3_only %{_bindir}/pyocd-gdbserver
 %python3_only %{_bindir}/pyocd-tool




commit python-pydicom for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-pydicom for openSUSE:Factory 
checked in at 2019-07-23 22:38:24

Comparing /work/SRC/openSUSE:Factory/python-pydicom (Old)
 and  /work/SRC/openSUSE:Factory/.python-pydicom.new.4126 (New)


Package is "python-pydicom"

Tue Jul 23 22:38:24 2019 rev:8 rq:717833 version:1.3.0

Changes:

--- /work/SRC/openSUSE:Factory/python-pydicom/python-pydicom.changes
2019-03-10 09:39:27.240117638 +0100
+++ /work/SRC/openSUSE:Factory/.python-pydicom.new.4126/python-pydicom.changes  
2019-07-23 22:38:31.566957158 +0200
@@ -1,0 +2,6 @@
+Tue Jul 23 09:10:15 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.3.0:
+  * no upstream changelog
+
+---

Old:

  pydicom-1.2.2.tar.gz

New:

  pydicom-1.3.0.tar.gz



Other differences:
--
++ python-pydicom.spec ++
--- /var/tmp/diff_new_pack.X5G0UZ/_old  2019-07-23 22:38:32.170957033 +0200
+++ /var/tmp/diff_new_pack.X5G0UZ/_new  2019-07-23 22:38:32.174957032 +0200
@@ -19,7 +19,7 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define oldpython python
 Name:   python-pydicom
-Version:1.2.2
+Version:1.3.0
 Release:0
 Summary:Pure python package for DICOM medical file reading and writing
 License:MIT
@@ -59,7 +59,7 @@
 
 %check
 export LANG=en_US.UTF-8
-%python_expand PYTHONPATH=%{buildroot}%{$python_sitelib} 
py.test-%{$python_version} pydicom/tests
+%pytest pydicom/tests
 
 %files %{python_files}
 %license LICENSE

++ pydicom-1.2.2.tar.gz -> pydicom-1.3.0.tar.gz ++
/work/SRC/openSUSE:Factory/python-pydicom/pydicom-1.2.2.tar.gz 
/work/SRC/openSUSE:Factory/.python-pydicom.new.4126/pydicom-1.3.0.tar.gz 
differ: char 5, line 1




commit coredns for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package coredns for openSUSE:Factory checked 
in at 2019-07-23 22:38:44

Comparing /work/SRC/openSUSE:Factory/coredns (Old)
 and  /work/SRC/openSUSE:Factory/.coredns.new.4126 (New)


Package is "coredns"

Tue Jul 23 22:38:44 2019 rev:3 rq:717844 version:1.3.1

Changes:

--- /work/SRC/openSUSE:Factory/coredns/coredns.changes  2019-06-06 
18:18:19.660668364 +0200
+++ /work/SRC/openSUSE:Factory/.coredns.new.4126/coredns.changes
2019-07-23 22:38:46.718954031 +0200
@@ -1,0 +2,22 @@
+Mon Jul 22 18:58:18 CEST 2019 - ku...@suse.de
+
+- Remove systemd support, not needed on openSUSE Kubic
+- Build with pie (security policy)
+
+---
+Tue Jul  2 23:55:24 UTC 2019 - Daniel Orf 
+
+- Update to version 1.3.1:
+  * log now allows multiple names to be specified
+  * import was added to give it a README.md to make it’s documentation more 
discoverable
+  * kubernetes TTL is also applied to negative responses (NXDOMAIN, etc)
+
+- Changed included from version 1.3.0:
+  * EDNS0 handling in the server and make it compliant with 
https://dnsflagday.net/
+  * k8s_external a new plugin that allows external zones to point to 
Kubernetes in-cluster services.
+  * rewrite fixes a bug where a rule would eat the first character of a name
+  * log now supported the metadata labels. It also fixes a bug in the 
formatting of a plugin logging a info/failure/warning
+  * forward removes the dynamic read timeout and uses a fixed value now.
+  * kubernetes now checks if a zone transfer is allowed. Also allow a TTL of 0 
to avoid caching in the cache plugin.
+
+---
@@ -5,0 +28,5 @@
+
+---
+Tue Mar 26 03:45:07 UTC 2019 - Daniel Orf 
+
+- Update spec file BuildRequires golang(API) >= 1.11

Old:

  coredns-1.2.6.tar.xz

New:

  coredns-1.3.1.tar.xz



Other differences:
--
++ coredns.spec ++
--- /var/tmp/diff_new_pack.YW5TNi/_old  2019-07-23 22:38:47.654953837 +0200
+++ /var/tmp/diff_new_pack.YW5TNi/_new  2019-07-23 22:38:47.658953837 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package coredns
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,12 +12,13 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
+
 %define project github.com/coredns/coredns
 Name:   coredns
-Version:1.2.6
+Version:1.3.1
 Release:0
 Summary:DNS server written in Go
 License:Apache-2.0
@@ -37,8 +38,8 @@
 Source10:   Corefile
 Source11:   coredns.service
 BuildRequires:  fdupes
-BuildRequires:  golang(API) >= 1.10
-%if 0%{?suse_version} >= 1210
+BuildRequires:  golang(API) >= 1.12
+%if !0%{?is_opensuse}
 BuildRequires:  pkgconfig(systemd)
 %endif
 
@@ -86,7 +87,7 @@
 ln -s $HOME/go/src/github.com/golang/protobuf 
$HOME/go/src/code.google.com/p/goprotobuf
 
 cd $HOME/go/src/%{project}
-make %{?_smp_mflags} coredns CHECKS=
+make %{?_smp_mflags} coredns CHECKS= BUILDOPTS="-v -buildmode=pie"
 
 %check
 # Too many tests fail due to the restricted permissions in the build 
enviroment.
@@ -97,6 +98,9 @@
 
 # Binaries
 install -D -m 0755 %{name} %{buildroot}%{_sbindir}/%{name}
+
+# On openSUSE, we don't need systemd support
+%if !0%{?is_opensuse}
 ln -s service %{buildroot}%{_sbindir}/rccoredns
 
 # Configuration
@@ -113,9 +117,11 @@
 install -m 0644 man/coredns-*.7 %{buildroot}/%{_mandir}/man7
 # Configs
 # Completion
+%endif
 
 %fdupes %{buildroot}/%{_prefix}
 
+%if !0%{?is_opensuse}
 %pre
 %service_add_pre %{name}.service
 
@@ -128,10 +134,12 @@
 
 %postun
 %service_del_postun %{name}.service
+%endif
 
 %files
 # Binaries
 %{_sbindir}/coredns
+%if !0%{?is_opensuse}
 %{_sbindir}/rccoredns
 # Manpages
 %{_mandir}/man1/coredns*
@@ -142,6 +150,7 @@
 %config(noreplace) %{_sysconfdir}/%{name}/Corefile
 %{_unitdir}/%{name}.service
 # Completion
+%endif
 # License
 %license LICENSE
 

++ _service ++
--- /var/tmp/diff_new_pack.YW5TNi/_old  2019-07-23 22:38:47.702953827 +0200
+++ /var/tmp/diff_new_pack.YW5TNi/_new  2019-07-23 22:38:47.702953827 +0200
@@ -3,8 +3,8 @@
 https://github.com/coredns/coredns
 git
 coredns
-1.2.6
-v1.2.6
+1.3.1
+v1.3.1
 
 
 
@@ -12,7 +12,7 @@
 git
 mholt-caddy
 

commit perl-Mojo-Pg for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package perl-Mojo-Pg for openSUSE:Factory 
checked in at 2019-07-23 22:38:37

Comparing /work/SRC/openSUSE:Factory/perl-Mojo-Pg (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Mojo-Pg.new.4126 (New)


Package is "perl-Mojo-Pg"

Tue Jul 23 22:38:37 2019 rev:18 rq:717836 version:4.14

Changes:

--- /work/SRC/openSUSE:Factory/perl-Mojo-Pg/perl-Mojo-Pg.changes
2019-01-28 20:49:50.921816349 +0100
+++ /work/SRC/openSUSE:Factory/.perl-Mojo-Pg.new.4126/perl-Mojo-Pg.changes  
2019-07-23 22:38:38.426955742 +0200
@@ -1,0 +2,12 @@
+Tue Jul 23 05:19:15 UTC 2019 - Stephan Kulow 
+
+- updated to 4.14
+   see /usr/share/doc/packages/perl-Mojo-Pg/Changes
+
+  4.14  2019-07-22
+- Improved connection cache to be more than an order of magnitude faster 
for
+  blocking queries.
+- Fixed a bug in Mojo::Pg::PubSub where listen/unlisten did not work while
+  reconnecting.
+
+---

Old:

  Mojo-Pg-4.13.tar.gz

New:

  Mojo-Pg-4.14.tar.gz



Other differences:
--
++ perl-Mojo-Pg.spec ++
--- /var/tmp/diff_new_pack.CzAH1x/_old  2019-07-23 22:38:38.986955626 +0200
+++ /var/tmp/diff_new_pack.CzAH1x/_new  2019-07-23 22:38:38.986955626 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Mojo-Pg
-Version:4.13
+Version:4.14
 Release:0
 %define cpan_name Mojo-Pg
 Summary:Wrapper around DBD::Pg for using PostgreSql with Mojolicious

++ Mojo-Pg-4.13.tar.gz -> Mojo-Pg-4.14.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojo-Pg-4.13/Changes new/Mojo-Pg-4.14/Changes
--- old/Mojo-Pg-4.13/Changes2019-01-20 23:32:08.0 +0100
+++ new/Mojo-Pg-4.14/Changes2019-07-22 18:50:36.0 +0200
@@ -1,4 +1,10 @@
 
+4.14  2019-07-22
+  - Improved connection cache to be more than an order of magnitude faster for
+blocking queries.
+  - Fixed a bug in Mojo::Pg::PubSub where listen/unlisten did not work while
+reconnecting.
+
 4.13  2019-01-20
   - Added support for multi-column joins to SQL::Abstract::Pg. (rsindlin)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojo-Pg-4.13/META.json new/Mojo-Pg-4.14/META.json
--- old/Mojo-Pg-4.13/META.json  2019-01-20 23:33:32.0 +0100
+++ new/Mojo-Pg-4.14/META.json  2019-07-22 20:16:50.0 +0200
@@ -4,7 +4,7 @@
   "Sebastian Riedel "
],
"dynamic_config" : 0,
-   "generated_by" : "ExtUtils::MakeMaker version 7.34, CPAN::Meta::Converter 
version 2.150010",
+   "generated_by" : "ExtUtils::MakeMaker version 7.36, CPAN::Meta::Converter 
version 2.150010",
"license" : [
   "artistic_2"
],
@@ -57,6 +57,6 @@
   },
   "x_IRC" : "irc://irc.freenode.net/#mojo"
},
-   "version" : "4.13",
-   "x_serialization_backend" : "JSON::PP version 4.00"
+   "version" : "4.14",
+   "x_serialization_backend" : "JSON::PP version 4.04"
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojo-Pg-4.13/META.yml new/Mojo-Pg-4.14/META.yml
--- old/Mojo-Pg-4.13/META.yml   2019-01-20 23:33:32.0 +0100
+++ new/Mojo-Pg-4.14/META.yml   2019-07-22 20:16:50.0 +0200
@@ -7,7 +7,7 @@
 configure_requires:
   ExtUtils::MakeMaker: '0'
 dynamic_config: 0
-generated_by: 'ExtUtils::MakeMaker version 7.34, CPAN::Meta::Converter version 
2.150010'
+generated_by: 'ExtUtils::MakeMaker version 7.36, CPAN::Meta::Converter version 
2.150010'
 license: artistic_2
 meta-spec:
   url: http://module-build.sourceforge.net/META-spec-v1.4.html
@@ -30,5 +30,5 @@
   homepage: https://mojolicious.org
   license: http://www.opensource.org/licenses/artistic-license-2.0
   repository: https://github.com/mojolicious/mojo-pg.git
-version: '4.13'
+version: '4.14'
 x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojo-Pg-4.13/lib/Mojo/Pg/Database.pm 
new/Mojo-Pg-4.14/lib/Mojo/Pg/Database.pm
--- old/Mojo-Pg-4.13/lib/Mojo/Pg/Database.pm2018-11-22 21:26:38.0 
+0100
+++ new/Mojo-Pg-4.14/lib/Mojo/Pg/Database.pm2019-07-22 18:41:26.0 
+0200
@@ -135,8 +135,16 @@
 
 sub _notifications {
   my $self = shift;
-  my $dbh  = $self->dbh;
-  while (my $n = $dbh->pg_notifies) { $self->emit(notification => @$n) }
+
+  my $dbh = $self->dbh;
+  my $n;
+  return undef unless $n = $dbh->pg_notifies;
+  while ($n) {
+$self->emit(notification => @$n);
+$n = $dbh->pg_notifies;
+  }
+
+  return 1;
 }
 
 sub _unwatch {
@@ -152,6 +160,7 @@
   return if $self->{watching} || $self->{watching}++;
 
   my $dbh = $self->dbh;
+  

commit fwts for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package fwts for openSUSE:Factory checked in 
at 2019-07-23 22:38:32

Comparing /work/SRC/openSUSE:Factory/fwts (Old)
 and  /work/SRC/openSUSE:Factory/.fwts.new.4126 (New)


Package is "fwts"

Tue Jul 23 22:38:32 2019 rev:41 rq:717835 version:19.06.00

Changes:

--- /work/SRC/openSUSE:Factory/fwts/fwts.changes2019-06-01 
09:52:21.151265850 +0200
+++ /work/SRC/openSUSE:Factory/.fwts.new.4126/fwts.changes  2019-07-23 
22:38:34.158956623 +0200
@@ -1,0 +2,9 @@
+Tue Jul 23 10:15:09 UTC 2019 - Martin Pluskal 
+
+- Update to version 19.06.00:
+  * acpi/fadt: update latest FADT revision to 6.3
+  * uefitime: add checking the EFI_UNSUPPORTED return code
+  * uefirtvariable: add checking the EFI_UNSUPPORTED return code
+  * uefirtmisc: add checking the EFI_UNSUPPORTED return code
+
+---

Old:

  fwts-V19.05.00.tar.gz

New:

  fwts-V19.06.00.tar.gz



Other differences:
--
++ fwts.spec ++
--- /var/tmp/diff_new_pack.y8ONgO/_old  2019-07-23 22:38:34.706956510 +0200
+++ /var/tmp/diff_new_pack.y8ONgO/_new  2019-07-23 22:38:34.706956510 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   fwts
-Version:19.05.00
+Version:19.06.00
 Release:0
 Summary:Firmware Test Suite
 License:GPL-2.0-or-later

++ fwts-V19.05.00.tar.gz -> fwts-V19.06.00.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/debian/changelog new/debian/changelog
--- old/debian/changelog2019-05-16 10:29:51.0 +0200
+++ new/debian/changelog2019-06-12 19:25:20.0 +0200
@@ -1,3 +1,38 @@
+fwts (19.06.00-0ubuntu1) eoan; urgency=medium
+
+  [Alex Hung]
+  * acpi/fadt: update latest FADT revision to 6.3
+  * apic: apicedge: remove irq < 16 is edge only
+  * mtrr: set severity to critical for incorrect attributes
+
+  [Colin Ian King]
+  * acpi: s3: fix two memory leaks on fwts_get() calls and minor clean-ups
+  * fwts_summary: check for list creation failure
+  * fwts_modprobe: fix potential null pointer dereference
+  * cpu: cpufreq: avoid division by zero by initializing cpu_top_perf to 1
+  * fwts_args: check for null text pointer
+  * fwts_log_plaintext: check for null pointer
+  * acpi: s3: check for null pointer
+  * lib: fwts_cpu: only assign a string if it has not yet been assigned
+  * acpi: syntaxcheck: nullify pointers to clean up static analysis warnings
+  * lib: fwts_log_scan: ensure accumulated error count is initialized
+  * lib: fwts_acpi_tables: remove redundant initialization of ret
+  * acpi: tcpa: remove redundant initialization of boolean passed
+  * acpi: dscdump: reduce scope of loop counter i
+  * acpi: method: reduce scope of boolean flag matching_levels
+  * lib: fwts_formatting: use simpler style for assigments
+  * uefi: uefirttime: make status static, cleans up cppcheck warnings
+
+  [Erico Nunes]
+  * dsddump: fix Package loop condition
+
+  [Ivan Hu]
+  * uefitime: add checking the EFI_UNSUPPORTED return code
+  * uefirtvariable: add checking the EFI_UNSUPPORTED return code
+  * uefirtmisc: add checking the EFI_UNSUPPORTED return code
+
+ -- Alex Hung   Wed, 12 Jun 2019 10:24:53 -0700
+
 fwts (19.05.00-0ubuntu1) eoan; urgency=medium
 
   [Alex Hung]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/snapcraft.yaml new/snapcraft.yaml
--- old/snapcraft.yaml  2019-05-16 10:29:51.0 +0200
+++ new/snapcraft.yaml  2019-06-12 19:25:20.0 +0200
@@ -1,5 +1,5 @@
 name: fwts
-version: V19.05.00
+version: V19.06.00
 summary: The Firmware Test Suite (FWTS)
 description: This is a firmware test suite that performs sanity checks on 
system firmware. It is intended to identify BIOS and ACPI errors and if 
appropriate it will try to explain the errors and give advice to help 
workaround or fix firmware bugs.  It is primarily intended to be a 
Linux-centric firmware troubleshooting tool.
 confinement: strict
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/src/acpi/dsddump/dsddump.c 
new/src/acpi/dsddump/dsddump.c
--- old/src/acpi/dsddump/dsddump.c  2019-05-16 10:29:51.0 +0200
+++ new/src/acpi/dsddump/dsddump.c  2019-06-12 19:25:20.0 +0200
@@ -87,7 +87,7 @@
ACPI_OBJECT *sub_pkg = >Package.Elements[1];
uint32_t j;
 
-   for (j = 0; i < sub_pkg->Package.Count; j++)
+   for (j = 0; j < sub_pkg->Package.Count; j++)
print_package_element(fw, 
_pkg->Package.Elements[j]);
} else
   

commit ceph-csi-image for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package ceph-csi-image for openSUSE:Factory 
checked in at 2019-07-23 22:38:12

Comparing /work/SRC/openSUSE:Factory/ceph-csi-image (Old)
 and  /work/SRC/openSUSE:Factory/.ceph-csi-image.new.4126 (New)


Package is "ceph-csi-image"

Tue Jul 23 22:38:12 2019 rev:1 rq:717826 version:1.0.0

Changes:

New Changes file:

--- /dev/null   2019-07-18 00:53:00.979475821 +0200
+++ /work/SRC/openSUSE:Factory/.ceph-csi-image.new.4126/ceph-csi-image.changes  
2019-07-23 22:38:24.734958568 +0200
@@ -0,0 +1,9 @@
+---
+Tue Jul 23 09:28:44 UTC 2019 - Denis Kondratenko 
+
+- Add LICENSE for kiwi descriptions 
+
+---
+Thu Jul 11 16:26:46 UTC 2019 - Denis Kondratenko 
+
+- Initial ceph-csi CSI driver image 

New:

  LICENSE
  README
  _service
  ceph-csi-image.changes
  ceph-csi-image.kiwi
  ceph-csi-image.xsl
  config.sh
  leap15_1.xml
  ses6.xml
  tumbleweed.xml



Other differences:
--
++ ceph-csi-image.kiwi ++


  
Denis Kondratenko
denis.kondrate...@suse.com
Ceph CSI driver container
  
  

  


  








  

New Ceph CSI image
  

1.0.0
zypper
false
true
en_US
us.map.gz
  
  

  
  


  
  




  

++ LICENSE ++
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
++ README ++
# HOWTO generate kiwi file for different platfoms

* xsltproc ceph-csi-image.xsl tumbleweed.xml > ceph-csi-image.kiwi
* xsltproc ceph-csi-image.xsl leap15_1.xml > ceph-csi-image.kiwi
* xsltproc ceph-csi-image.xsl ses6.xml > ceph-csi-image.kiwi
++ _service ++




ceph-csi-image.kiwi
patch
%PKG_VERSION%
ceph-csi


ceph-csi-image.kiwi
%PKG_COMMIT_NUM%
offset
ceph-csi



++ ceph-csi-image.xsl ++

http://www.w3.org/1999/XSL/Transform;>






  
Denis Kondratenko
denis.kondrate...@suse.com
Ceph CSI driver container
  

  

  

  
  

  




 

  

  



  

  








  

  





  

  
 
  
  

  

  

  
  

  

  



New Ceph CSI image
 

1.0.0
zypper
false
true
en_US
us.map.gz
  

  

  

  



  

  

  


  

  




  

  

  


  





 ++ config.sh ++
#!/bin/bash
#
# FILE  : config.sh
#
# PROJECT   : OpenSuSE KIWI Image System
# COPYRIGHT : (c) 2013 SUSE LLC
#   :
# AUTHOR: Robert Schweikert 
#   :
# BELONGS TO: Operating System images
#   :
# DESCRIPTION   : configuration script for SUSE based
#   : operating systems
#   :
#   :
# STATUS: BETA
#
#==
# Functions...
#--
test -f /.kconfig && . /.kconfig
test -f /.profile && . /.profile


commit clementine for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package clementine for openSUSE:Factory 
checked in at 2019-07-23 22:38:02

Comparing /work/SRC/openSUSE:Factory/clementine (Old)
 and  /work/SRC/openSUSE:Factory/.clementine.new.4126 (New)


Package is "clementine"

Tue Jul 23 22:38:02 2019 rev:52 rq:717812 version:1.3.1+git20190713

Changes:

--- /work/SRC/openSUSE:Factory/clementine/clementine.changes2019-07-22 
12:19:57.623671137 +0200
+++ /work/SRC/openSUSE:Factory/.clementine.new.4126/clementine.changes  
2019-07-23 22:38:04.026962842 +0200
@@ -1,0 +2,10 @@
+Tue Jul 23 08:15:30 UTC 2019 - Dave Plater 
+
+- Updated memory leak patch (boo#114144):
+  delete_the_allocated_memory_in_respective_destructors.patch
+- Fixed boo#1137785 with upstream patch from git:
+  0001-Fix-crash-in-messagereply-6372.patch
+- Added patch from git:
+  0001-Introduce-limit-for-number-of-tag-client-processes.patch
+
+---

New:

  0001-Fix-crash-in-messagereply-6372.patch
  0001-Introduce-limit-for-number-of-tag-client-processes.patch



Other differences:
--
++ clementine.spec ++
--- /var/tmp/diff_new_pack.tkSVCX/_old  2019-07-23 22:38:05.838962468 +0200
+++ /var/tmp/diff_new_pack.tkSVCX/_new  2019-07-23 22:38:05.858962464 +0200
@@ -64,7 +64,12 @@
 Patch18:0001-Simplify-some-statements.patch
 Patch19:0001-Set-non-zero-minimum-for-fade-times.patch
 Patch20:0001-Fix-a-number-of-potential-zero-value-field-values.patch
+# From Jiri Slaby via boo#1141444
 Patch21:delete_the_allocated_memory_in_respective_destructors.patch
+#PATCH-FIX-GIT from areading's pull, will maybe fix bugs
+Patch22:0001-Introduce-limit-for-number-of-tag-client-processes.patch
+#PATCH-FIX-GIT cures issue#6372
+Patch23:0001-Fix-crash-in-messagereply-6372.patch
 BuildRequires:  cmake
 BuildRequires:  fdupes
 BuildRequires:  freeglut-devel

++ 0001-Fix-crash-in-messagereply-6372.patch ++
>From 5bb35bf08a6189db3cc8456f377768a07313cdcb Mon Sep 17 00:00:00 2001
From: Jonas Kvinge 
Date: Sat, 20 Jul 2019 19:52:37 +0200
Subject: [PATCH] Fix crash in messagereply (#6372)

* Fix crash in messagereply

* Fix formatting
---
 ext/libclementine-common/core/messagereply.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/ext/libclementine-common/core/messagereply.h 
b/ext/libclementine-common/core/messagereply.h
index 72904e765..764b5ce18 100644
--- a/ext/libclementine-common/core/messagereply.h
+++ b/ext/libclementine-common/core/messagereply.h
@@ -86,9 +86,9 @@ void MessageReply::SetReply(const MessageType& 
message) {
   finished_ = true;
   success_ = true;
 
-  emit Finished(success_);
   qLog(Debug) << "Releasing ID" << id() << "(finished)";
   semaphore_.release();
+  emit Finished(success_);
 }
 
 #endif  // MESSAGEREPLY_H
-- 
2.16.4

++ 0001-Introduce-limit-for-number-of-tag-client-processes.patch ++
>From c76697b42c30d50f87efc4b0beeca5a2e89795f3 Mon Sep 17 00:00:00 2001
From: Andrew Reading 
Date: Thu, 28 Mar 2019 09:37:54 -0700
Subject: [PATCH] Introduce limit for number of tag client processes.

Previously, the number of processes spawned was always
QThread::idealThreadCount() (returning the number of logical CPU
cores). On new systems with many cores, however, this can result
in 12, 16, 24, or ... processes being spawned, which is a bit
excessive.

This establishes a new config variable,
'max_numprocs_tagclients' within the Settings group, in order
to limit the maximum number of tag client processes that get
spawned. It also adds a means of setting this via the Behavior
page in Settings. It can be set to any integer in the interval
[1, QThread::idealThreadCount()]; it defaults to the maximal value
so as to emulate the old behavior.
---
 src/core/tagreaderclient.cpp |  9 -
 src/ui/behavioursettingspage.cpp | 20 +++
 src/ui/behavioursettingspage.h   |  1 +
 src/ui/behavioursettingspage.ui  | 42 
 4 files changed, 71 insertions(+), 1 deletion(-)

diff --git a/src/core/tagreaderclient.cpp b/src/core/tagreaderclient.cpp
index 96434be52..853c2733e 100644
--- a/src/core/tagreaderclient.cpp
+++ b/src/core/tagreaderclient.cpp
@@ -18,6 +18,7 @@
along with Clementine.  If not, see .
 */
 
+#include "player.h"
 #include "tagreaderclient.h"
 
 #include 
@@ -34,8 +35,14 @@ TagReaderClient::TagReaderClient(QObject* parent)
 : QObject(parent), worker_pool_(new WorkerPool(this)) {
   sInstance = this;
 
+  QSettings s;
+  s.beginGroup(Player::kSettingsGroup);
+
+  int max_workers = QThread::idealThreadCount();
+  int num_workers = s.value("max_numprocs_tagclients", 

commit perl-BerkeleyDB for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package perl-BerkeleyDB for openSUSE:Factory 
checked in at 2019-07-23 22:37:48

Comparing /work/SRC/openSUSE:Factory/perl-BerkeleyDB (Old)
 and  /work/SRC/openSUSE:Factory/.perl-BerkeleyDB.new.4126 (New)


Package is "perl-BerkeleyDB"

Tue Jul 23 22:37:48 2019 rev:39 rq:717805 version:0.63

Changes:

--- /work/SRC/openSUSE:Factory/perl-BerkeleyDB/perl-BerkeleyDB.changes  
2019-07-22 12:21:41.899643777 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-BerkeleyDB.new.4126/perl-BerkeleyDB.changes
2019-07-23 22:37:53.926964927 +0200
@@ -1,0 +2,12 @@
+Tue Jul 23 05:03:59 UTC 2019 - Stephan Kulow 
+
+- updated to 0.63
+   see /usr/share/doc/packages/perl-BerkeleyDB/Changes
+
+  0.63  21 July 2019
+  
+  * added 000preret.t 
+Dump version info in "make test"
+9e17580d74662b6a3186990dd3b1469df2829503
+
+---

Old:

  BerkeleyDB-0.62.tar.gz

New:

  BerkeleyDB-0.63.tar.gz



Other differences:
--
++ perl-BerkeleyDB.spec ++
--- /var/tmp/diff_new_pack.9OpWyK/_old  2019-07-23 22:37:54.594964788 +0200
+++ /var/tmp/diff_new_pack.9OpWyK/_new  2019-07-23 22:37:54.594964788 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-BerkeleyDB
-Version:0.62
+Version:0.63
 Release:0
 %define cpan_name BerkeleyDB
 Summary:Perl extension for Berkeley DB version 2, 3, 4, 5 or 6

++ BerkeleyDB-0.62.tar.gz -> BerkeleyDB-0.63.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/BerkeleyDB-0.62/BerkeleyDB.pm 
new/BerkeleyDB-0.63/BerkeleyDB.pm
--- old/BerkeleyDB-0.62/BerkeleyDB.pm   2019-07-20 19:28:43.0 +0200
+++ new/BerkeleyDB-0.63/BerkeleyDB.pm   2019-07-21 14:48:34.0 +0200
@@ -17,7 +17,7 @@
 use vars qw($VERSION @ISA @EXPORT $AUTOLOAD
$use_XSLoader);
 
-$VERSION = '0.62';
+$VERSION = '0.63';
 
 require Exporter;
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/BerkeleyDB-0.62/Changes new/BerkeleyDB-0.63/Changes
--- old/BerkeleyDB-0.62/Changes 2019-07-20 19:38:48.0 +0200
+++ new/BerkeleyDB-0.63/Changes 2019-07-21 15:00:29.0 +0200
@@ -1,5 +1,11 @@
 Revision history for Perl extension BerkeleyDB.
 
+0.63  21 July 2019
+
+* added 000preret.t 
+  Dump version info in "make test"
+  9e17580d74662b6a3186990dd3b1469df2829503
+
 0.62  20 July 2019
 
 * default to /usr/local/BerkeleyDB
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/BerkeleyDB-0.62/MANIFEST new/BerkeleyDB-0.63/MANIFEST
--- old/BerkeleyDB-0.62/MANIFEST2019-03-16 15:36:35.0 +0100
+++ new/BerkeleyDB-0.63/MANIFEST2019-07-20 20:28:28.0 +0200
@@ -18,6 +18,7 @@
 mkpod
 ppport.h
 README
+t/000prereq.t
 t/blob.t
 t/btree.t
 t/cds.t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/BerkeleyDB-0.62/META.json 
new/BerkeleyDB-0.63/META.json
--- old/BerkeleyDB-0.62/META.json   2019-07-20 19:51:00.0 +0200
+++ new/BerkeleyDB-0.63/META.json   2019-07-21 15:02:30.0 +0200
@@ -43,6 +43,6 @@
  "web" : "https://github.com/pmqs/BerkeleyDB;
   }
},
-   "version" : "0.62",
+   "version" : "0.63",
"x_serialization_backend" : "JSON::PP version 2.27300"
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/BerkeleyDB-0.62/META.yml new/BerkeleyDB-0.63/META.yml
--- old/BerkeleyDB-0.62/META.yml2019-07-20 19:51:00.0 +0200
+++ new/BerkeleyDB-0.63/META.yml2019-07-21 15:02:30.0 +0200
@@ -21,5 +21,5 @@
   bugtracker: https://github.com/pmqs/BerkeleyDB/issues
   homepage: https://github.com/pmqs/BerkeleyDB
   repository: git://github.com/pmqs/BerkeleyDB.git
-version: '0.62'
+version: '0.63'
 x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/BerkeleyDB-0.62/README new/BerkeleyDB-0.63/README
--- old/BerkeleyDB-0.62/README  2019-07-20 19:31:58.0 +0200
+++ new/BerkeleyDB-0.63/README  2019-07-21 14:58:38.0 +0200
@@ -1,8 +1,8 @@
 BerkeleyDB
 
-   Version 0.62
+   Version 0.63
 
-  20th July 2019
+  21sth July 2019
   
 
  Copyright (c) 1997-2019 Paul Marquess. All rights reserved. This
@@ -599,10 +599,11 @@
 FEEDBACK
 
 
-General feedback/questions/bug reports can be sent 

commit python-pyfuse3 for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-pyfuse3 for openSUSE:Factory 
checked in at 2019-07-23 22:37:45

Comparing /work/SRC/openSUSE:Factory/python-pyfuse3 (Old)
 and  /work/SRC/openSUSE:Factory/.python-pyfuse3.new.4126 (New)


Package is "python-pyfuse3"

Tue Jul 23 22:37:45 2019 rev:3 rq:717803 version:1.3.1

Changes:

--- /work/SRC/openSUSE:Factory/python-pyfuse3/python-pyfuse3.changes
2019-06-17 21:35:18.134997704 +0200
+++ /work/SRC/openSUSE:Factory/.python-pyfuse3.new.4126/python-pyfuse3.changes  
2019-07-23 22:37:52.654965189 +0200
@@ -1,0 +2,6 @@
+Tue Jul 23 08:46:49 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.3.1:
+  *  Fixed a bug in the :file:`hello_asyncio.py` example.
+
+---

Old:

  pyfuse3-1.3.tar.gz

New:

  pyfuse3-1.3.1.tar.gz



Other differences:
--
++ python-pyfuse3.spec ++
--- /var/tmp/diff_new_pack.CG895c/_old  2019-07-23 22:37:53.334965049 +0200
+++ /var/tmp/diff_new_pack.CG895c/_new  2019-07-23 22:37:53.334965049 +0200
@@ -20,13 +20,13 @@
 %define skip_python2 1
 %define pname   pyfuse3
 Name:   python-%{pname}
-Version:1.3
+Version:1.3.1
 Release:0
 Summary:Python Bindings for the low-level FUSE3 API
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/Python
 URL:https://github.com/libfuse/pyfuse3
-Source: 
https://github.com/libfuse/pyfuse3/archive/v%{version}.tar.gz#/%{pname}-%{version}.tar.gz
+Source: 
https://github.com/libfuse/pyfuse3/archive/release-%{version}.tar.gz#/%{pname}-%{version}.tar.gz
 BuildRequires:  %{python_module Cython}
 BuildRequires:  %{python_module contextvars >= 2.1}
 BuildRequires:  %{python_module devel}
@@ -43,7 +43,7 @@
 pyfuse3 is a set of Python 3 bindings for libfuse 3. It provides an 
asynchronous API compatible with Trio and asyncio, and enables you to easily 
write a full-featured Linux filesystem in Python.
 
 %prep
-%setup -q -n %{pname}-%{version}
+%setup -q -n %{pname}-release-%{version}
 
 %build
 %python_expand $python setup.py build_cython

++ pyfuse3-1.3.tar.gz -> pyfuse3-1.3.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pyfuse3-1.3/Changes.rst 
new/pyfuse3-release-1.3.1/Changes.rst
--- old/pyfuse3-1.3/Changes.rst 2019-06-02 14:50:16.0 +0200
+++ new/pyfuse3-release-1.3.1/Changes.rst   2019-07-17 17:13:16.0 
+0200
@@ -4,10 +4,15 @@
 
 .. currentmodule:: pyfuse3
 
+Release 1.3.1 (2019-07-17)
+==
+
+* Fixed a bug in the :file:`hello_asyncio.py` example.
+
 Release 1.3 (2019-06-02)
 
 
-* Fixed a bug in the `tmpfs.py` and `passthroughfs.py` example
+* Fixed a bug in the :file:`tmpfs.py` and :file:`passthroughfs.py` example
   file systems (so rename operations no longer fail).
 
 Release 1.2 (2018-12-22)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pyfuse3-1.3/examples/hello_asyncio.py 
new/pyfuse3-release-1.3.1/examples/hello_asyncio.py
--- old/pyfuse3-1.3/examples/hello_asyncio.py   2019-06-02 14:50:16.0 
+0200
+++ new/pyfuse3-release-1.3.1/examples/hello_asyncio.py 2019-07-17 
17:13:16.0 +0200
@@ -81,7 +81,7 @@
 async def lookup(self, parent_inode, name, ctx=None):
 if parent_inode != pyfuse3.ROOT_INODE or name != self.hello_name:
 raise pyfuse3.FUSEError(errno.ENOENT)
-return self.getattr(self.hello_inode)
+return await self.getattr(self.hello_inode)
 
 async def opendir(self, inode, ctx):
 if inode != pyfuse3.ROOT_INODE:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pyfuse3-1.3/setup.py 
new/pyfuse3-release-1.3.1/setup.py
--- old/pyfuse3-1.3/setup.py2019-06-02 14:50:16.0 +0200
+++ new/pyfuse3-release-1.3.1/setup.py  2019-07-17 17:13:16.0 +0200
@@ -57,7 +57,7 @@
 # to work properly
 sys.path.insert(0, os.path.join(basedir, 'src'))
 
-PYFUSE3_VERSION = '1.3'
+PYFUSE3_VERSION = '1.3.1'
 
 def main():
 




commit jgmenu for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package jgmenu for openSUSE:Factory checked 
in at 2019-07-23 22:37:16

Comparing /work/SRC/openSUSE:Factory/jgmenu (Old)
 and  /work/SRC/openSUSE:Factory/.jgmenu.new.4126 (New)


Package is "jgmenu"

Tue Jul 23 22:37:16 2019 rev:8 rq:717740 version:3.3

Changes:

--- /work/SRC/openSUSE:Factory/jgmenu/jgmenu.changes2019-07-21 
11:33:35.476784932 +0200
+++ /work/SRC/openSUSE:Factory/.jgmenu.new.4126/jgmenu.changes  2019-07-23 
22:37:31.110969635 +0200
@@ -1,0 +2,9 @@
+Tue Jul 23 05:34:04 UTC 2019 - mvet...@suse.com
+
+- Update to 3.3:
+  * In the obtheme module, add support for parsing BunsenLabs Lithium's
+bl-rc.xml to obtain the current openbox theme, thereby supporting
+jgmenu init --apply-obtheme without having to set an environment
+variable.
+
+---

Old:

  v3.2.tar.gz

New:

  v3.3.tar.gz



Other differences:
--
++ jgmenu.spec ++
--- /var/tmp/diff_new_pack.DgrVnw/_old  2019-07-23 22:37:32.506969347 +0200
+++ /var/tmp/diff_new_pack.DgrVnw/_new  2019-07-23 22:37:32.510969346 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   jgmenu
-Version:3.2
+Version:3.3
 Release:0
 Summary:Small X11 menu intended to be used with openbox and tint2
 License:GPL-2.0-only

++ v3.2.tar.gz -> v3.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jgmenu-3.2/.gitignore new/jgmenu-3.3/.gitignore
--- old/jgmenu-3.2/.gitignore   2019-07-16 22:45:50.0 +0200
+++ new/jgmenu-3.3/.gitignore   2019-07-22 22:21:41.0 +0200
@@ -15,3 +15,4 @@
 binsiz.log
 .d/
 checkdeps
+tags
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jgmenu-3.2/NEWS.md new/jgmenu-3.3/NEWS.md
--- old/jgmenu-3.2/NEWS.md  2019-07-16 22:45:50.0 +0200
+++ new/jgmenu-3.3/NEWS.md  2019-07-22 22:21:41.0 +0200
@@ -6,6 +6,7 @@
 
 ## Recent releases
 
+[v3.3](docs/relnotes/3.3.txt)  
 [v3.2](docs/relnotes/3.2.txt)  
 [v3.1](docs/relnotes/3.1.txt)  
 [v3.0](docs/relnotes/3.0.txt)  
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jgmenu-3.2/debian/changelog 
new/jgmenu-3.3/debian/changelog
--- old/jgmenu-3.2/debian/changelog 2019-07-16 22:45:50.0 +0200
+++ new/jgmenu-3.3/debian/changelog 2019-07-22 22:21:41.0 +0200
@@ -1,5 +1,5 @@
-jgmenu (3.2-1) lithium; urgency=medium
+jgmenu (3.3-1) lithium; urgency=medium
 
   * New upstream release
 
- -- Johan Malm   Tue, 16 Jul 2019 21:44:24 +0100
+ -- Johan Malm   Mon, 22 Jul 2019 21:19:12 +0100
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jgmenu-3.2/docs/manual/Makefile 
new/jgmenu-3.3/docs/manual/Makefile
--- old/jgmenu-3.2/docs/manual/Makefile 2019-07-16 22:45:50.0 +0200
+++ new/jgmenu-3.3/docs/manual/Makefile 2019-07-22 22:21:41.0 +0200
@@ -1,13 +1,5 @@
-INSTALL = install
-variant = 
--from=markdown_strict+backtick_code_blocks+pipe_tables+pandoc_title_block
-css = jg.css
-
-man1pages  = jgmenu.1 jgmenu_run.1
-
-man1pages += jgmenu-pmenu.1 jgmenu-lx.1 jgmenu-ob.1
-
+man1pages  = jgmenu.1 jgmenu_run.1 jgmenu-pmenu.1 jgmenu-lx.1 jgmenu-ob.1
 man7pages  = jgmenututorial.7
-
 manpages   = $(man1pages) $(man7pages)
 
 prefix ?= /usr/local
@@ -20,13 +12,12 @@
 $(manpages): % : %.md
@echo "PANDOC" $^
@pandoc -s -t man $^ -o $@
-   @pandoc -s $(variant) --css=$(css) -o $@.html $^
 
 install:
-   @$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)
-   @$(INSTALL) -d -m 755 $(DESTDIR)$(man7dir)
-   @$(INSTALL) -m 644 $(man1pages) $(DESTDIR)$(man1dir)
-   @$(INSTALL) -m 644 $(man7pages) $(DESTDIR)$(man7dir)
+   @install -d -m 755 $(DESTDIR)$(man1dir)
+   @install -d -m 755 $(DESTDIR)$(man7dir)
+   @install -m 644 $(man1pages) $(DESTDIR)$(man1dir)
+   @install -m 644 $(man7pages) $(DESTDIR)$(man7dir)
 
 clean:
-   rm -f $(manpages) *.html
+   @rm -f $(manpages)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jgmenu-3.2/docs/manual/jgmenu-lx.1 
new/jgmenu-3.3/docs/manual/jgmenu-lx.1
--- old/jgmenu-3.2/docs/manual/jgmenu-lx.1  2019-07-16 22:45:50.0 
+0200
+++ new/jgmenu-3.3/docs/manual/jgmenu-lx.1  2019-07-22 22:21:41.0 
+0200
@@ -1,63 +1,42 @@
-.\" Automatically generated by Pandoc 2.7.1
+.\" Automatically generated by Pandoc 2.2.1
 .\"
-.TH "JGMENU-LX" "1" "16 Apr, 2019" "" ""
+.TH "JGMENU\-LX" "1" "20 Jul, 2019" "" ""
 .hy
 .SH NAME
 .PP
-jgmenu-lx - generate jgmenu flavoured CSV menu data for an XDG menu

commit python-cufflinks for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-cufflinks for 
openSUSE:Factory checked in at 2019-07-23 22:37:07

Comparing /work/SRC/openSUSE:Factory/python-cufflinks (Old)
 and  /work/SRC/openSUSE:Factory/.python-cufflinks.new.4126 (New)


Package is "python-cufflinks"

Tue Jul 23 22:37:07 2019 rev:3 rq:717726 version:0.16

Changes:

--- /work/SRC/openSUSE:Factory/python-cufflinks/python-cufflinks.changes
2019-06-04 12:13:05.103807143 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-cufflinks.new.4126/python-cufflinks.changes  
2019-07-23 22:37:29.278970013 +0200
@@ -1,0 +2,7 @@
+Tue Jul 23 01:14:08 UTC 2019 - Todd R 
+
+- Update to version 0.16
+  * Fix issue with multiple y-axis datapoints
+  * make the theme parameter case insensitive.
+
+---

Old:

  cufflinks-0.15.tar.gz

New:

  cufflinks-0.16.tar.gz



Other differences:
--
++ python-cufflinks.spec ++
--- /var/tmp/diff_new_pack.zBGOAJ/_old  2019-07-23 22:37:29.786969908 +0200
+++ /var/tmp/diff_new_pack.zBGOAJ/_new  2019-07-23 22:37:29.786969908 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-cufflinks
-Version:0.15
+Version:0.16
 Release:0
 Summary:Productivity Tools for Plotly + Pandas
 License:MIT

++ cufflinks-0.15.tar.gz -> cufflinks-0.16.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cufflinks-0.15/PKG-INFO new/cufflinks-0.16/PKG-INFO
--- old/cufflinks-0.15/PKG-INFO 2019-04-03 10:48:00.0 +0200
+++ new/cufflinks-0.16/PKG-INFO 2019-06-28 18:24:25.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: cufflinks
-Version: 0.15
+Version: 0.16
 Summary: Productivity Tools for Plotly + Pandas
 Home-page: https://github.com/santosjorge/cufflinks
 Author: Jorge Santos
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cufflinks-0.15/cufflinks/plotlytools.py 
new/cufflinks-0.16/cufflinks/plotlytools.py
--- old/cufflinks-0.15/cufflinks/plotlytools.py 2019-03-20 23:26:06.0 
+0100
+++ new/cufflinks-0.16/cufflinks/plotlytools.py 2019-06-15 15:00:08.0 
+0200
@@ -823,10 +823,9 @@
if x:
df=df.set_index(x)
if y and secondary_y:
-   if isinstance(secondary_y, str):
-   df=df[[y, secondary_y]]
-   else:
-   df=df[[y] + secondary_y]
+   _y = [y] if not isinstance(y, list) 
else y
+   _secondary_y = [secondary_y] if not 
isinstance(secondary_y, list) else secondary_y
+   df=df[_y + _secondary_y]
elif y:
df=df[y]
if kind=='area':
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cufflinks-0.15/cufflinks/tools.py 
new/cufflinks-0.16/cufflinks/tools.py
--- old/cufflinks-0.15/cufflinks/tools.py   2019-03-07 20:41:23.0 
+0100
+++ new/cufflinks-0.16/cufflinks/tools.py   2019-04-29 20:21:29.0 
+0200
@@ -5,6 +5,7 @@
 import plotly.offline as py_offline
 import plotly.plotly as py
 from plotly.graph_objs import Figure, Scatter, Line
+from plotly.tools import make_subplots
 # from plotly.graph_objs.layout import XAxis, YAxis
 
 from . import auth, ta
@@ -891,7 +892,7 @@
theme = auth.get_config_file()['theme']
 
layout= base_layout if base_layout else 
getLayout(theme,**check_kwargs(kwargs,__LAYOUT_AXIS))
-   
sp=py.plotly.tools.make_subplots(rows=rows,cols=cols,shared_xaxes=shared_xaxes,
+   sp=make_subplots(rows=rows,cols=cols,shared_xaxes=shared_xaxes,

   shared_yaxes=shared_yaxes,print_grid=False,

start_cell=start_cell,**kwargs)
sp, grid_ref = sp.to_dict(), sp._grid_ref
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/cufflinks-0.15/cufflinks/version.py 
new/cufflinks-0.16/cufflinks/version.py
--- old/cufflinks-0.15/cufflinks/version.py 2019-04-02 20:37:19.0 
+0200
+++ new/cufflinks-0.16/cufflinks/version.py 2019-06-28 18:20:06.0 
+0200
@@ -1 +1 @@
-__version__ = 

commit python2-pandas for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python2-pandas for openSUSE:Factory 
checked in at 2019-07-23 22:36:43

Comparing /work/SRC/openSUSE:Factory/python2-pandas (Old)
 and  /work/SRC/openSUSE:Factory/.python2-pandas.new.4126 (New)


Package is "python2-pandas"

Tue Jul 23 22:36:43 2019 rev:1 rq:717707 version:0.24.2

Changes:

New Changes file:

--- /dev/null   2019-07-18 00:53:00.979475821 +0200
+++ /work/SRC/openSUSE:Factory/.python2-pandas.new.4126/python2-pandas.changes  
2019-07-23 22:37:20.774971769 +0200
@@ -0,0 +1,1791 @@
+---
+Mon Jul 22 16:30:18 UTC 2019 - Todd R 
+
+- Create python2 only version of python-pandas since the latest
+  version of pandas is python3-only.  This is a critical dependency
+  of many packages so a python2 version is needed for now.
+
+---
+Sat Mar 16 22:35:08 UTC 2019 - Arun Persaud 
+
+- specfile:
+  * requier pytest-mock
+
+- update to version 0.24.2:
+  * Fixed Regressions
++ Fixed regression in DataFrame.all() and DataFrame.any() where
+  bool_only=True was ignored (GH25101)
++ Fixed issue in DataFrame construction with passing a mixed list
+  of mixed types could segfault. (GH25075)
++ Fixed regression in DataFrame.apply() causing RecursionError
+  when dict-like classes were passed as argument. (GH25196)
++ Fixed regression in DataFrame.replace() where regex=True was
+  only replacing patterns matching the start of the string
+  (GH25259)
++ Fixed regression in DataFrame.duplicated(), where empty
+  dataframe was not returning a boolean dtyped Series. (GH25184)
++ Fixed regression in Series.min() and Series.max() where
+  numeric_only=True was ignored when the Series contained
+  Categorical data (GH25299)
++ Fixed regression in subtraction between Series objects with
+  datetime64[ns] dtype incorrectly raising OverflowError when the
+  Series on the right contains null values (GH25317)
++ Fixed regression in TimedeltaIndex where np.sum(index)
+  incorrectly returned a zero-dimensional object instead of a
+  scalar (GH25282)
++ Fixed regression in IntervalDtype construction where passing an
+  incorrect string with ‘Interval’ as a prefix could result in a
+  RecursionError. (GH25338)
++ Fixed regression in creating a period-dtype array from a
+  read-only NumPy array of period objects. (GH25403)
++ Fixed regression in Categorical, where constructing it from a
+  categorical Series and an explicit categories= that differed
+  from that in the Series created an invalid object which could
+  trigger segfaults. (GH25318)
++ Fixed regression in to_timedelta() losing precision when
+  converting floating data to Timedelta data (GH25077).
++ Fixed pip installing from source into an environment without
+  NumPy (GH25193)
++ Fixed regression in DataFrame.replace() where large strings of
+  numbers would be coerced into int64, causing an OverflowError
+  (GH25616)
++ Fixed regression in factorize() when passing a custom
+  na_sentinel value with sort=True (GH25409).
++ Fixed regression in DataFrame.to_csv() writing duplicate line
+  endings with gzip compress (GH25311)
+  * Bug Fixes
++ I/O
+  o Better handling of terminal printing when the terminal
+dimensions are not known (GH25080)
+  o Bug in reading a HDF5 table-format DataFrame created in Python
+2, in Python 3 (GH24925)
+  o Bug in reading a JSON with orient='table' generated by
+DataFrame.to_json() with index=False (GH25170)
+  o Bug where float indexes could have misaligned values when
+printing (GH25061)
++ Reshaping
+  o Bug in transform() where applying a function to a timezone aware
+column would return a timezone naive result (GH24198)
+  o Bug in DataFrame.join() when joining on a timezone aware
+DatetimeIndex (GH23931)
+  o Visualization
+  o Bug in Series.plot() where a secondary y axis could not be set
+to log scale (GH25545)
++ Other
+  o Bug in Series.is_unique() where single occurrences of NaN were
+not considered unique (GH25180)
+  o Bug in merge() when merging an empty DataFrame with an Int64
+column or a non-empty DataFrame with an Int64 column that is all
+NaN (GH25183)
+  o Bug in IntervalTree where a RecursionError occurs upon
+construction due to an overflow when adding endpoints, which
+also causes IntervalIndex to crash during indexing operations
+(GH25485)
+  o Bug in Series.size raising for some extension-array-backed
+Series, rather than returning the size 

commit gsequencer for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package gsequencer for openSUSE:Factory 
checked in at 2019-07-23 22:37:22

Comparing /work/SRC/openSUSE:Factory/gsequencer (Old)
 and  /work/SRC/openSUSE:Factory/.gsequencer.new.4126 (New)


Package is "gsequencer"

Tue Jul 23 22:37:22 2019 rev:47 rq:71 version:2.2.23

Changes:

--- /work/SRC/openSUSE:Factory/gsequencer/gsequencer.changes2019-07-21 
11:35:12.748767626 +0200
+++ /work/SRC/openSUSE:Factory/.gsequencer.new.4126/gsequencer.changes  
2019-07-23 22:37:47.322966289 +0200
@@ -1,0 +2,6 @@
+Mon Jul 22 15:58:38 UTC 2019 - Joël Krähemann 
+
+- new upstream v2.2.23 replaced hard-coded font names.
+- fixed timing issue with relative counters.
+
+---

Old:

  gsequencer-2.2.22.tar.gz

New:

  gsequencer-2.2.23.tar.gz



Other differences:
--
++ gsequencer.spec ++
--- /var/tmp/diff_new_pack.sl2RBn/_old  2019-07-23 22:37:47.886966173 +0200
+++ /var/tmp/diff_new_pack.sl2RBn/_new  2019-07-23 22:37:47.890966172 +0200
@@ -21,7 +21,7 @@
 # activated with --with run_functional_tests command line switch.
 %bcond_with run_functional_tests
 Name:   gsequencer
-Version:2.2.22
+Version:2.2.23
 Release:0
 Summary:Audio processing engine
 License:GPL-3.0+ AND AGPL-3.0+ AND GFDL-1.3

++ gsequencer-2.2.22.tar.gz -> gsequencer-2.2.23.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gsequencer-2.2.22/ChangeLog 
new/gsequencer-2.2.23/ChangeLog
--- old/gsequencer-2.2.22/ChangeLog 2019-07-18 10:58:57.0 +0200
+++ new/gsequencer-2.2.23/ChangeLog 2019-07-21 16:43:56.0 +0200
@@ -1,3 +1,14 @@
+ags (2.2.23)
+
+   [ Joël Krähemann (Maintainer of Advanced Gtk+ Sequencer) ]
+   * fixed relative counters and time fraction issues
+   * improved replacing hard-coded font
+   * refactored AgsDial to use PangoLayout
+   * refactored AgsLevel to use PangoLayout
+   * refactored AgsScale to use PangoLayout
+   * refactored AgsRuler to use PangoLayout
+   * refactored AgsCartesian to use PangoLayout
+
 ags (2.2.22)
 
[ Joël Krähemann (Maintainer of Advanced Gtk+ Sequencer) ]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gsequencer-2.2.22/TODO new/gsequencer-2.2.23/TODO
--- old/gsequencer-2.2.22/TODO  2019-06-24 17:33:32.0 +0200
+++ new/gsequencer-2.2.23/TODO  2019-07-21 12:03:35.0 +0200
@@ -7,6 +7,7 @@
 A copy of the license is included in the section entitled "GNU
 Free Documentation License".
 
+* TODO:JK: fix envelope related functions in ags_midi_util.h
 * TODO:JK: check recall id cleanup
 * TODO:JK: improved AgsRecallContainer detection of ags_recall_factory.c
 * TODO:JK: implemented AgsSoundContainer manager
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gsequencer-2.2.22/ags/audio/ags_devin.c 
new/gsequencer-2.2.23/ags/audio/ags_devin.c
--- old/gsequencer-2.2.22/ags/audio/ags_devin.c 2019-04-29 20:06:18.0 
+0200
+++ new/gsequencer-2.2.23/ags/audio/ags_devin.c 2019-07-21 15:00:31.0 
+0200
@@ -2622,7 +2622,7 @@
 #endif
   
   devin->tact_counter = 0.0;
-  devin->delay_counter = 0.0;
+  devin->delay_counter = 
floor(ags_soundcard_get_absolute_delay(AGS_SOUNDCARD(devin)));
   devin->tic_counter = 0;
 
   devin->nth_ring_buffer = 0;
@@ -3950,7 +3950,7 @@
 
   pthread_mutex_unlock(devin_mutex);
 
-  if((guint) delay_counter + 1 >= (guint) delay){
+  if(delay_counter + 1.0 >= delay){
 if(do_loop &&
note_offset + 1 == loop_right){
   ags_soundcard_set_note_offset(soundcard,
@@ -3970,7 +3970,7 @@
 /* reset - delay counter */
 pthread_mutex_lock(devin_mutex);
 
-devin->delay_counter = 0.0;
+devin->delay_counter = delay_counter + 1.0 - delay;
 devin->tact_counter += 1.0;
 
 pthread_mutex_unlock(devin_mutex);
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gsequencer-2.2.22/ags/audio/ags_devout.c 
new/gsequencer-2.2.23/ags/audio/ags_devout.c
--- old/gsequencer-2.2.22/ags/audio/ags_devout.c2019-06-01 
20:20:05.0 +0200
+++ new/gsequencer-2.2.23/ags/audio/ags_devout.c2019-07-21 
14:57:21.0 +0200
@@ -2674,7 +2674,7 @@
 #endif
   
   devout->tact_counter = 0.0;
-  devout->delay_counter = 0.0;
+  devout->delay_counter = 
floor(ags_soundcard_get_absolute_delay(AGS_SOUNDCARD(devout)));
   devout->tic_counter = 0;
 
   devout->nth_ring_buffer = 0;
@@ -3499,7 +3499,7 @@
 #endif
 
   devout->tact_counter = 0.0;
-  devout->delay_counter = 0.0;
+  

commit mpd for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package mpd for openSUSE:Factory checked in 
at 2019-07-23 22:37:27

Comparing /work/SRC/openSUSE:Factory/mpd (Old)
 and  /work/SRC/openSUSE:Factory/.mpd.new.4126 (New)


Package is "mpd"

Tue Jul 23 22:37:27 2019 rev:11 rq:717785 version:0.21.9

Changes:

--- /work/SRC/openSUSE:Factory/mpd/mpd.changes  2019-06-01 09:58:31.511131243 
+0200
+++ /work/SRC/openSUSE:Factory/.mpd.new.4126/mpd.changes2019-07-23 
22:37:48.766965991 +0200
@@ -1,0 +2,5 @@
+Tue Jul 23 07:42:13 UTC 2019 - Илья Индиго 
+
+- Remove patch GCC9-buildfix.patch (upsteamed)
+
+---

Old:

  GCC9-buildfix.patch



Other differences:
--
++ mpd.spec ++
--- /var/tmp/diff_new_pack.o1MspM/_old  2019-07-23 22:37:49.234965895 +0200
+++ /var/tmp/diff_new_pack.o1MspM/_new  2019-07-23 22:37:49.238965894 +0200
@@ -40,8 +40,6 @@
 Patch3: mpd-docs.patch
 # PATCH-FIX-OPENSUSE mpd-sndfile.patch
 Patch4: mpd-sndfile.patch
-# PATCH-FIX-UPSTREAM GCC9-buildfix.patch
-Patch5: GCC9-buildfix.patch
 %if 0%{?suse_version} >= 1500
 BuildRequires:  libboost_headers-devel >= 1.58
 %else




commit python-GridDataFormats for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-GridDataFormats for 
openSUSE:Factory checked in at 2019-07-23 22:36:48

Comparing /work/SRC/openSUSE:Factory/python-GridDataFormats (Old)
 and  /work/SRC/openSUSE:Factory/.python-GridDataFormats.new.4126 (New)


Package is "python-GridDataFormats"

Tue Jul 23 22:36:48 2019 rev:2 rq:717721 version:0.5.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-GridDataFormats/python-GridDataFormats.changes
2018-05-29 10:29:18.527076700 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-GridDataFormats.new.4126/python-GridDataFormats.changes
  2019-07-23 22:37:24.394971021 +0200
@@ -1,0 +2,17 @@
+Tue Jul 23 02:20:35 UTC 2019 - Todd R 
+
+- Update to 0.5.0
+  + Changes
+* supported/tested on Python 2.7, >=3.5 (official 3.4 support was
+  dropped: it might still work but is not tested anymore)
+  + Enhancements
+* Allow parsing DX files by NAMD's GridForces module (new typequote 
keyword)
+* New keyword argument ``Grid(grid=, file_format=)`` to set 
file format when
+  reading from a file
+  + Fixes
+* Allow parsing DX files by Pymol's buggy floating-point parser
+* Fixed loading of pickle files with .pkl suffix
+* Better input handling when constructing a Grid object
+- Remove upstream-included no_float128.patch
+
+---

Old:

  GridDataFormats-0.4.0.tar.gz
  no_float128.patch

New:

  GridDataFormats-0.5.0.tar.gz



Other differences:
--
++ python-GridDataFormats.spec ++
--- /var/tmp/diff_new_pack.r92WM2/_old  2019-07-23 22:37:26.450970597 +0200
+++ /var/tmp/diff_new_pack.r92WM2/_new  2019-07-23 22:37:26.450970597 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-GridDataFormats
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,32 +15,25 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-# Tests fail due to missing test directory
-%bcond_without tests
-
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-GridDataFormats
-Version:0.4.0
+Version:0.5.0
 Release:0
 Summary:Python Tools for Reading and writing of data on regular grids
 License:GPL-3.0
 Group:  Development/Libraries/Python
 Url:https://github.com/MDAnalysis/GridDataFormats/
 Source0:
https://files.pythonhosted.org/packages/source/G/GridDataFormats/GridDataFormats-%{version}.tar.gz
-# PATCH-FIX-UPSTREAM no_float128.patch -- 
https://github.com/MDAnalysis/GridDataFormats/issues/44
-Patch0: no_float128.patch
-BuildRequires:  fdupes
-BuildRequires:  python-rpm-macros
-BuildRequires:  %{python_module devel}
-BuildRequires:  %{python_module setuptools}
-BuildRequires:  %{python_module paramiko}
 BuildRequires:  %{python_module numpy >= 1.0.3}
+BuildRequires:  %{python_module paramiko}
+BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{python_module six}
 BuildRequires:  %{python_module xml}
-%if %{with tests}
-BuildRequires:  %{python_module nose}
-%endif
+BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
+# SECTION test requirements
+BuildRequires:  %{python_module pytest}
+# /SECTION
 Requires:   python-numpy >= 1.0.3
 Requires:   python-six
 Requires:   python-xml
@@ -56,7 +49,6 @@
 
 %prep
 %setup -n GridDataFormats-%{version}
-%patch0 -p1
 
 %build
 %python_build
@@ -65,13 +57,10 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
-%if %{with tests}
 %check
-%python_expand nosetests-%{$python_bin_suffix}
-%endif
+%pytest
 
 %files %{python_files}
-%defattr(-,root,root)
 %doc AUTHORS CHANGELOG README.rst
 %license COPYING*
 %{python_sitelib}/gridData

++ GridDataFormats-0.4.0.tar.gz -> GridDataFormats-0.5.0.tar.gz ++
 2236 lines of diff (skipped)




commit python-PyWavelets for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-PyWavelets for 
openSUSE:Factory checked in at 2019-07-23 22:37:01

Comparing /work/SRC/openSUSE:Factory/python-PyWavelets (Old)
 and  /work/SRC/openSUSE:Factory/.python-PyWavelets.new.4126 (New)


Package is "python-PyWavelets"

Tue Jul 23 22:37:01 2019 rev:6 rq:717724 version:1.0.3

Changes:

--- /work/SRC/openSUSE:Factory/python-PyWavelets/python-PyWavelets.changes  
2019-03-13 09:15:58.819382087 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-PyWavelets.new.4126/python-PyWavelets.changes
2019-07-23 22:37:26.926970499 +0200
@@ -1,0 +2,9 @@
+Tue Jul 23 02:28:20 UTC 2019 - Todd R 
+
+- Update to version 1.0.3
+  PyWavelets 1.0.3 is functionally equivalent to the 1.0.2 release.
+  It was made to archive the JOSS paper about PyWavelets to the
+  1.0.x branch and serve as a reference corresponding to the
+  version that was peer reviewed.
+
+---

Old:

  PyWavelets-1.0.2.tar.gz

New:

  PyWavelets-1.0.3.tar.gz



Other differences:
--
++ python-PyWavelets.spec ++
--- /var/tmp/diff_new_pack.I4ZRzv/_old  2019-07-23 22:37:27.618970356 +0200
+++ /var/tmp/diff_new_pack.I4ZRzv/_new  2019-07-23 22:37:27.622970355 +0200
@@ -18,23 +18,25 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-PyWavelets
-Version:1.0.2
+Version:1.0.3
 Release:0
 Summary:PyWavelets is a Python wavelet transforms module
 License:MIT
 Group:  Development/Libraries/Python
-URL:http://pypi.python.org/pypi/PyWavelets/
+URL:https://github.com/PyWavelets/pywt
 Source0:
https://files.pythonhosted.org/packages/source/P/PyWavelets/PyWavelets-%{version}.tar.gz
 Source10:   
https://media.readthedocs.org/pdf/pywavelets/v%{version}/pywavelets.pdf
 Source11:   
https://media.readthedocs.org/htmlzip/pywavelets/v%{version}/pywavelets.zip
 BuildRequires:  %{python_module Cython}
 BuildRequires:  %{python_module devel}
-BuildRequires:  %{python_module nose}
 BuildRequires:  %{python_module numpy-devel >= 1.9.1}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
 BuildRequires:  unzip
+# SECTION test requirements
+BuildRequires:  %{python_module nose}
+# /SECTION
 Requires:   python-numpy >= 1.9.1
 %python_subpackages
 

++ PyWavelets-1.0.2.tar.gz -> PyWavelets-1.0.3.tar.gz ++
 75777 lines of diff (skipped)

++ pywavelets.pdf ++
(binary differes)

++ pywavelets.zip ++
Binary files /var/tmp/diff_new_pack.I4ZRzv/_old and 
/var/tmp/diff_new_pack.I4ZRzv/_new differ




commit otrs for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package otrs for openSUSE:Factory checked in 
at 2019-07-23 22:36:08

Comparing /work/SRC/openSUSE:Factory/otrs (Old)
 and  /work/SRC/openSUSE:Factory/.otrs.new.4126 (New)


Package is "otrs"

Tue Jul 23 22:36:08 2019 rev:65 rq:717673 version:6.0.20

Changes:

--- /work/SRC/openSUSE:Factory/otrs/otrs.changes2019-07-02 
15:18:23.886740556 +0200
+++ /work/SRC/openSUSE:Factory/.otrs.new.4126/otrs.changes  2019-07-23 
22:36:12.958985765 +0200
@@ -1,0 +2,25 @@
+Sat Jul 20 11:26:28 UTC 2019 - ch...@computersalat.de
+
+- Update to 6.0.20
+  https://community.otrs.com/release-notes-otrs-6-patch-level-20/
+- fix for boo#1141432
+  * (CVE-2019-13458, OSA-2019-12)
+Information Disclosure
+An attacker who is logged into OTRS as an agent user with
+appropriate permissions can leverage OTRS tags in templates in
+order to disclose hashed user passwords.
+- fix for boo#1141431
+  * (CVE-2019-13457, OSA-2019-11)
+Information Disclosure
+A customer user can use the search results to disclose information
+from their “company” tickets (with the same CustomerID), even when
+CustomerDisableCompanyTicketAccess setting is turned on.
+- fix for boo#1141430
+  * (CVE-2019-12746, OSA-2019-10)
+Session ID Disclosure
+A user logged into OTRS as an agent might unknowingly disclose
+their session ID by sharing the link of an embedded ticket article
+with third parties. This identifier can be then potentially abused
+in order to impersonate the agent user.
+
+---

Old:

  itsm-6.0.19.tar.bz2
  otrs-6.0.19.tar.bz2

New:

  itsm-6.0.20.tar.bz2
  otrs-6.0.20.tar.bz2



Other differences:
--
++ otrs.spec ++
--- /var/tmp/diff_new_pack.qGNHT2/_old  2019-07-23 22:36:14.982985347 +0200
+++ /var/tmp/diff_new_pack.qGNHT2/_new  2019-07-23 22:36:15.002985343 +0200
@@ -23,8 +23,8 @@
 
 Name:   otrs
 
-%define otrs_ver 6.0.19
-%define itsm_ver 6.0.19
+%define otrs_ver 6.0.20
+%define itsm_ver 6.0.20
 %define itsm_min 6
 %define otrs_root /srv/%{name}
 %define otrsdoc_dir_files AUTHORS* CHANGES* COPYING* CREDITS README* 
UPGRADING.SUSE doc

++ itsm-6.0.19.tar.bz2 -> itsm-6.0.20.tar.bz2 ++
/work/SRC/openSUSE:Factory/otrs/itsm-6.0.19.tar.bz2 
/work/SRC/openSUSE:Factory/.otrs.new.4126/itsm-6.0.20.tar.bz2 differ: char 11, 
line 1

++ otrs-6.0.19.tar.bz2 -> otrs-6.0.20.tar.bz2 ++
/work/SRC/openSUSE:Factory/otrs/otrs-6.0.19.tar.bz2 
/work/SRC/openSUSE:Factory/.otrs.new.4126/otrs-6.0.20.tar.bz2 differ: char 11, 
line 1




commit minder for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package minder for openSUSE:Factory checked 
in at 2019-07-23 22:36:04

Comparing /work/SRC/openSUSE:Factory/minder (Old)
 and  /work/SRC/openSUSE:Factory/.minder.new.4126 (New)


Package is "minder"

Tue Jul 23 22:36:04 2019 rev:10 rq:717670 version:1.4.1

Changes:

--- /work/SRC/openSUSE:Factory/minder/minder.changes2019-07-15 
22:44:26.907896123 +0200
+++ /work/SRC/openSUSE:Factory/.minder.new.4126/minder.changes  2019-07-23 
22:36:05.578987288 +0200
@@ -1,0 +2,10 @@
+Mon Jul 15 10:09:59 UTC 2019 - Alexei Podvalsky 
+
+- Update to 1.4.1:
+  * Merge branch 'master' of github.com:phase1geo/Minder
+  * Fixing automatic layout issue.
+  * Fixed spelling error in README
+  * Fixing version number within meson.build.
+  * Merge pull request #75 from NathanBnm/update-fr
+
+---

Old:

  Minder-1.4.0.tar.gz

New:

  Minder-1.4.1.tar.gz



Other differences:
--
++ minder.spec ++
--- /var/tmp/diff_new_pack.WQ9aDJ/_old  2019-07-23 22:36:06.042987193 +0200
+++ /var/tmp/diff_new_pack.WQ9aDJ/_new  2019-07-23 22:36:06.046987192 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   minder
-Version:1.4.0
+Version:1.4.1
 Release:0
 Summary:Mind-mapping app
 License:GPL-3.0-or-later

++ Minder-1.4.0.tar.gz -> Minder-1.4.1.tar.gz ++
 5550 lines of diff (skipped)




commit yast2-s390 for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package yast2-s390 for openSUSE:Factory 
checked in at 2019-07-23 22:36:17

Comparing /work/SRC/openSUSE:Factory/yast2-s390 (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-s390.new.4126 (New)


Package is "yast2-s390"

Tue Jul 23 22:36:17 2019 rev:12 rq:717676 version:4.2.2

Changes:

--- /work/SRC/openSUSE:Factory/yast2-s390/yast2-s390.changes2019-07-18 
15:22:33.848121103 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-s390.new.4126/yast2-s390.changes  
2019-07-23 22:36:18.918984535 +0200
@@ -1,0 +2,6 @@
+Fri Jul 19 11:57:09 CEST 2019 - aschn...@suse.com
+
+- handle setting diag mode on active DASDs (part of bsc#1134927)
+- 4.2.2
+
+---

Old:

  yast2-s390-4.2.1.tar.bz2

New:

  yast2-s390-4.2.2.tar.bz2



Other differences:
--
++ yast2-s390.spec ++
--- /var/tmp/diff_new_pack.Bspi8E/_old  2019-07-23 22:36:19.570984401 +0200
+++ /var/tmp/diff_new_pack.Bspi8E/_new  2019-07-23 22:36:19.578984399 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-s390
-Version:4.2.1
+Version:4.2.2
 Release:0
 Summary:YaST2 - S/390 Specific Features Configuration
 License:GPL-2.0-only

++ yast2-s390-4.2.1.tar.bz2 -> yast2-s390-4.2.2.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-s390-4.2.1/package/yast2-s390.changes 
new/yast2-s390-4.2.2/package/yast2-s390.changes
--- old/yast2-s390-4.2.1/package/yast2-s390.changes 2019-07-17 
18:22:59.0 +0200
+++ new/yast2-s390-4.2.2/package/yast2-s390.changes 2019-07-22 
21:03:57.0 +0200
@@ -1,4 +1,10 @@
 ---
+Fri Jul 19 11:57:09 CEST 2019 - aschn...@suse.com
+
+- handle setting diag mode on active DASDs (part of bsc#1134927)
+- 4.2.2
+
+---
 Tue Jul 16 11:27:09 CEST 2019 - aschn...@suse.com
 
 - sort DASDs by channel ID (part of bsc#1134927)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-s390-4.2.1/package/yast2-s390.spec 
new/yast2-s390-4.2.2/package/yast2-s390.spec
--- old/yast2-s390-4.2.1/package/yast2-s390.spec2019-07-17 
18:22:59.0 +0200
+++ new/yast2-s390-4.2.2/package/yast2-s390.spec2019-07-22 
21:03:57.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-s390
-Version:4.2.1
+Version:4.2.2
 Release:0
 Group:  System/YaST
 License:GPL-2.0-only
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-s390-4.2.1/src/include/s390/dasd/dialogs.rb 
new/yast2-s390-4.2.2/src/include/s390/dasd/dialogs.rb
--- old/yast2-s390-4.2.1/src/include/s390/dasd/dialogs.rb   2019-07-17 
18:22:59.0 +0200
+++ new/yast2-s390-4.2.2/src/include/s390/dasd/dialogs.rb   2019-07-22 
21:03:57.0 +0200
@@ -285,8 +285,8 @@
   [id, "resource", "io", 0, "active"],
   false
 )
+DASDController.ActivateDiag(channel, value) if active
 Ops.set(DASDController.diag, channel, value)
-DASDController.ActivateDisk(channel, value) if active
   end
   DASDController.ProbeDisks
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-s390-4.2.1/src/modules/DASDController.rb 
new/yast2-s390-4.2.2/src/modules/DASDController.rb
--- old/yast2-s390-4.2.1/src/modules/DASDController.rb  2019-07-17 
18:22:59.0 +0200
+++ new/yast2-s390-4.2.2/src/modules/DASDController.rb  2019-07-22 
21:03:57.0 +0200
@@ -570,6 +570,16 @@
   nil
 end
 
+# Activate or deactivate diag on active disk
+# @param [String] channel string Name of the disk to operate on
+# @param [Boolean] diag boolean Activate DIAG or not
+def ActivateDiag(channel, diag)
+  old_diag = DASDController.diag.fetch(channel, false)
+  return if diag == old_diag
+  DeactivateDisk(channel, old_diag)
+  ActivateDisk(channel, diag)
+end
+
 # Format disks
 # @param [Array] disks_list list List of disks to be 
formatted
 # @param [Fixnum] par integer Number of disks that can be formated in 
parallel
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-s390-4.2.1/test/dasd_controller_test.rb 
new/yast2-s390-4.2.2/test/dasd_controller_test.rb
--- old/yast2-s390-4.2.1/test/dasd_controller_test.rb   2019-07-17 
18:22:59.0 +0200
+++ new/yast2-s390-4.2.2/test/dasd_controller_test.rb   2019-07-22 
21:03:57.0 +0200
@@ 

commit orcania for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package orcania for openSUSE:Factory checked 
in at 2019-07-23 22:35:53

Comparing /work/SRC/openSUSE:Factory/orcania (Old)
 and  /work/SRC/openSUSE:Factory/.orcania.new.4126 (New)


Package is "orcania"

Tue Jul 23 22:35:53 2019 rev:5 rq:717660 version:2.0.1

Changes:

--- /work/SRC/openSUSE:Factory/orcania/orcania.changes  2019-07-08 
15:11:45.455387262 +0200
+++ /work/SRC/openSUSE:Factory/.orcania.new.4126/orcania.changes
2019-07-23 22:35:55.398989390 +0200
@@ -1,0 +2,9 @@
+Fri Jul 12 20:59:29 UTC 2019 - Martin Hauke 
+
+- Update to version 2.0.1
+  * Fix double free() on `pointer_list_remove_at`
+  * Clean build process
+  * Fix config option STRTSR so cmake and makefile will use the
+same name
+
+---

Old:

  orcania-2.0.0.tar.gz

New:

  orcania-2.0.1.tar.gz



Other differences:
--
++ orcania.spec ++
--- /var/tmp/diff_new_pack.dqUEee/_old  2019-07-23 22:35:55.874989291 +0200
+++ /var/tmp/diff_new_pack.dqUEee/_new  2019-07-23 22:35:55.878989290 +0200
@@ -19,7 +19,7 @@
 
 %define sover 2_0
 Name:   orcania
-Version:2.0.0
+Version:2.0.1
 Release:0
 Summary:MISC function Library
 License:LGPL-2.1-or-later

++ orcania-2.0.0.tar.gz -> orcania-2.0.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/orcania-2.0.0/.travis.yml 
new/orcania-2.0.1/.travis.yml
--- old/orcania-2.0.0/.travis.yml   2019-06-27 23:54:43.0 +0200
+++ new/orcania-2.0.1/.travis.yml   2019-07-09 16:14:08.0 +0200
@@ -5,18 +5,35 @@
 language: c
 addons:
   apt:
-packages: [ check, libsubunit-dev, cppcheck ]
+packages: [ check, libsubunit-dev, cppcheck, pkg-config ]
 matrix:
   include:
-- os: linux
+- env: LABEL=linux-gcc
+  os: linux
   compiler: gcc
-- os: linux
+- env: LABEL=lnux-clang
+  os: linux
   compiler: clang
 - env: LABEL=cppcheck
+  os: osx
+  addons:
+homebrew:
+  packages:
+  - check
+  - pkg-config
+  update: true
+  script:
+- mkdir build && cd build
+- cmake -DBUILD_ORCANIA_TESTING=on ..
+- make test
+- env: LABEL=osx
   os: linux
   script:
 - cppcheck --force --enable=warning,missingInclude --error-exitcode=1 
. >build.log 2>&1 || (cat build.log && exit 1)
 script:
+  - pushd test
+  - make test
+  - popd
   - mkdir build && cd build
   - cmake -DBUILD_ORCANIA_TESTING=on ..
   - make test package
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/orcania-2.0.0/CHANGELOG.md 
new/orcania-2.0.1/CHANGELOG.md
--- old/orcania-2.0.0/CHANGELOG.md  2019-06-27 23:54:43.0 +0200
+++ new/orcania-2.0.1/CHANGELOG.md  2019-07-09 16:14:08.0 +0200
@@ -1,5 +1,12 @@
 # Orcania Changelog
 
+## 2.0.1
+
+- Fix double free() on `pointer_list_remove_at`
+- Fix build for MacOSX (thanks JohnAZoidberg!)
+- Clean build process
+- Fix config option STRTSR so cmake and makefile will use the same name
+
 ## 2.0.0
 
 - Add struct _pointer_list to manage arrays of pointers
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/orcania-2.0.0/CMakeLists.txt 
new/orcania-2.0.1/CMakeLists.txt
--- old/orcania-2.0.0/CMakeLists.txt2019-06-27 23:54:43.0 +0200
+++ new/orcania-2.0.1/CMakeLists.txt2019-07-09 16:14:08.0 +0200
@@ -30,7 +30,7 @@
 set(PROJECT_BUGREPORT_PATH "https://github.com/babelouest/orcania/issues;)
 set(LIBRARY_VERSION_MAJOR "2")
 set(LIBRARY_VERSION_MINOR "0")
-set(LIBRARY_VERSION_PATCH "0")
+set(LIBRARY_VERSION_PATCH "1")
 set(LIBS "-lm")
 
 set(PROJECT_VERSION 
"${LIBRARY_VERSION_MAJOR}.${LIBRARY_VERSION_MINOR}.${LIBRARY_VERSION_PATCH}")
@@ -74,9 +74,9 @@
 
 option(WITH_STRSTR "Use inline implementation of strstr" OFF)
 if (WITH_STRSTR)
-set(STRSTR ON)
+set(O_STRSTR ON)
 else ()
-set(STRSTR OFF)
+set(O_STRSTR OFF)
 endif ()
 
 set(PKGCONF_REQ "")
@@ -115,13 +115,13 @@
 
 # tests
 
-option(BUILD_ORCANIA_TESTING "Build the testing tree." OFF) # because we don 
not use include(CTest)
+option(BUILD_ORCANIA_TESTING "Build the testing tree." OFF) # because we do 
not use include(CTest)
 
 if (BUILD_ORCANIA_TESTING)
 include(FindCheck)
 find_package(Check)
 if (CHECK_FOUND)
-if (NOT WIN32)
+if (NOT WIN32 AND NOT APPLE)
 include(FindSubunit)
 find_package(Subunit REQUIRED)
 endif ()
@@ -134,13 +134,20 @@
 set(LIBS orcania ${LIBS} ${CHECK_LIBRARIES})
 if (NOT WIN32)
 

commit yder for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package yder for openSUSE:Factory checked in 
at 2019-07-23 22:35:55

Comparing /work/SRC/openSUSE:Factory/yder (Old)
 and  /work/SRC/openSUSE:Factory/.yder.new.4126 (New)


Package is "yder"

Tue Jul 23 22:35:55 2019 rev:5 rq:717663 version:1.4.7

Changes:

--- /work/SRC/openSUSE:Factory/yder/yder.changes2019-07-08 
15:11:43.775385649 +0200
+++ /work/SRC/openSUSE:Factory/.yder.new.4126/yder.changes  2019-07-23 
22:35:56.182989227 +0200
@@ -1,0 +2,9 @@
+Fri Jul 12 21:03:56 UTC 2019 - Martin Hauke 
+
+- Update to version 1.4.7
+  * Clean build process
+  * Clean static variables if error initializing logs with file
+- Drop not longer needed patch:
+  * yder-fix-build.patch
+
+---

Old:

  yder-1.4.6.tar.gz
  yder-fix-build.patch

New:

  yder-1.4.7.tar.gz



Other differences:
--
++ yder.spec ++
--- /var/tmp/diff_new_pack.ZZ7Gi3/_old  2019-07-23 22:35:56.762989108 +0200
+++ /var/tmp/diff_new_pack.ZZ7Gi3/_new  2019-07-23 22:35:56.762989108 +0200
@@ -19,14 +19,13 @@
 
 %define sover 1_4
 Name:   yder
-Version:1.4.6
+Version:1.4.7
 Release:0
 Summary:Logging library written in C
 License:LGPL-2.1-or-later
 Group:  Development/Languages/C and C++
 URL:https://github.com/babelouest/yder
 Source: 
https://github.com/babelouest/yder/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
-Patch0: yder-fix-build.patch
 BuildRequires:  cmake
 BuildRequires:  gcc-c++
 BuildRequires:  pkgconfig
@@ -61,7 +60,6 @@
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 %cmake \

++ yder-1.4.6.tar.gz -> yder-1.4.7.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yder-1.4.6/.travis.yml new/yder-1.4.7/.travis.yml
--- old/yder-1.4.6/.travis.yml  2019-07-01 01:53:21.0 +0200
+++ new/yder-1.4.7/.travis.yml  2019-07-09 16:17:28.0 +0200
@@ -5,13 +5,27 @@
 language: c
 addons:
   apt:
-packages: [ libjansson-dev, check, libsubunit-dev, cppcheck ]
+packages: [ check, libsubunit-dev, cppcheck, pkg-config ]
 matrix:
   include:
-- os: linux
+- env: LABEL=linux-gcc
+  os: linux
   compiler: gcc
-- os: linux
+- env: LABEL=linux-clang
+  os: linux
   compiler: clang
+- env: LABEL=osx
+  os: osx
+  addons:
+homebrew:
+  packages:
+  - check
+  - pkg-config
+  update: true
+  script:
+- mkdir build && cd build
+- cmake -DBUILD_YDER_TESTING=on -DWITH_JOURNALD=off ..
+- make test
 - env: LABEL=cppcheck
   os: linux
   script:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yder-1.4.6/CHANGELOG.md new/yder-1.4.7/CHANGELOG.md
--- old/yder-1.4.6/CHANGELOG.md 2019-07-01 01:53:21.0 +0200
+++ new/yder-1.4.7/CHANGELOG.md 2019-07-09 16:17:28.0 +0200
@@ -1,5 +1,11 @@
 # Yder Changelog
 
+## 1.4.7
+
+- Fix build for MacOSX (thanks JohnAZoidberg!)
+- Clean build process
+- Clean static variables if error initializing logs with file
+
 ## 1.4.6
 
 - Fix package dependencies in cmake script
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yder-1.4.6/CMakeLists.txt 
new/yder-1.4.7/CMakeLists.txt
--- old/yder-1.4.6/CMakeLists.txt   2019-07-01 01:53:21.0 +0200
+++ new/yder-1.4.7/CMakeLists.txt   2019-07-09 16:17:28.0 +0200
@@ -30,12 +30,12 @@
 set(PROJECT_BUGREPORT_PATH "https://github.com/babelouest/yder/issues;)
 set(LIBRARY_VERSION_MAJOR "1")
 set(LIBRARY_VERSION_MINOR "4")
-set(LIBRARY_VERSION_PATCH "6")
+set(LIBRARY_VERSION_PATCH "7")
 set(PROJECT_VERSION 
"${LIBRARY_VERSION_MAJOR}.${LIBRARY_VERSION_MINOR}.${LIBRARY_VERSION_PATCH}")
 
 set(LIBRARY_VERSION 
"${LIBRARY_VERSION_MAJOR}.${LIBRARY_VERSION_MINOR}.${LIBRARY_VERSION_PATCH}")
 set(LIBRARY_SOVERSION "${LIBRARY_VERSION_MAJOR}.${LIBRARY_VERSION_MINOR}")
-set(ORCANIA_VERSION_REQUIRED "2.0.0")
+set(ORCANIA_VERSION_REQUIRED "2.0.1")
 
 # cmake modules
 
@@ -80,11 +80,10 @@
   if (SYSTEMD_FOUND)
   set(SYSTEMD_LIBRARIES systemd)
   include_directories(${SYSTEMD_INCLUDE_DIRS})
-  set(DISABLE_JOURNALD OFF)
+  set(Y_DISABLE_JOURNALD OFF)
   endif ()
 else()
-  add_definitions(-DY_DISABLE_JOURNALD)
-  set(DISABLE_JOURNALD ON)
+  set(Y_DISABLE_JOURNALD ON)
 endif ()
 
 # shared library
@@ -101,8 +100,6 @@
 set_target_properties(yder PROPERTIES SUFFIX 
"-${LIBRARY_VERSION_MAJOR}.dll")
 endif ()
 
-target_link_libraries(yder ${LIBS} ${ORCANIA_LIBRARIES} ${SYSTEMD_LIBRARIES})
-
 # static library
 
 

commit python-tables for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-tables for openSUSE:Factory 
checked in at 2019-07-23 22:36:20

Comparing /work/SRC/openSUSE:Factory/python-tables (Old)
 and  /work/SRC/openSUSE:Factory/.python-tables.new.4126 (New)


Package is "python-tables"

Tue Jul 23 22:36:20 2019 rev:12 rq:717679 version:3.5.2

Changes:

--- /work/SRC/openSUSE:Factory/python-tables/python-tables.changes  
2019-02-14 14:36:25.887569101 +0100
+++ /work/SRC/openSUSE:Factory/.python-tables.new.4126/python-tables.changes
2019-07-23 22:36:21.610983980 +0200
@@ -1,0 +2,34 @@
+Mon Jul 22 16:58:48 UTC 2019 - Todd R 
+
+- Update to 3.5.2
+  * Fixed compatibility with python 3.8: Fixed `Dictonary keys changed during
+iteration` RuntimeError while moving/renameing a node.
+Thanks to Christoph Gohlke for reporting and Miro Hroncok for help with
+building PyTables for python 3.8alpha (cython compatibility).
+  * Fixed a bug in offset calculations producing floats instead of ints
+affecting python 3. See PR #736. Thanks to Brad Montgomery.
+- Update to 3.5.1
+  * Maintenance release to fix how PyPi repo is handling wheel versions.
+- Update to 3.5.0
+  * When copying data from native HDF5 files with padding in compound types,
+the padding is not removed now by default.  This allows for better
+compatibility with existing HDF5 applications that expect the padding
+to stay there.
+Also, when the `description` is a NumPy struct array with padding, this
+is honored now.  The previous behaviour (i.e. getting rid of paddings) can
+be replicated by passing the new `allow_padding` parameter when opening
+a file.  For some examples, see the new `examples/tables-with-padding.py`
+and `examples/attrs-with-padding.py`.  For details on the implementation
+  * Added a new flag `--dont-allow-padding` in `ptrepack` utility so as to
+replicate the previous behaviour of removing padding during file copies.
+The default is to honor the original padding in copies.
+  * Improve compatibility with numpy 1.16.
+  * Improve detection of the LZO2 library at build time.
+  * Suppress several warnings.
+  * Add AVX2 support for Windows.
+- Rebase Never-use-the-msse2-flag-explicitly.patch
+- Remove upstream-included patches:
+  * pytables_no_unsafe_write.patch
+  * pytables_fix_exception_check.patch
+
+---

Old:

  pytables_fix_exception_check.patch
  pytables_no_unsafe_write.patch
  tables-3.4.4.tar.gz

New:

  tables-3.5.2.tar.gz



Other differences:
--
++ python-tables.spec ++
--- /var/tmp/diff_new_pack.Tdavtv/_old  2019-07-23 22:36:31.690981899 +0200
+++ /var/tmp/diff_new_pack.Tdavtv/_new  2019-07-23 22:36:31.694981898 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-tables
-Version:3.4.4
+Version:3.5.2
 Release:0
 Summary:Hierarchical datasets for Python
 License:BSD-3-Clause
@@ -26,10 +26,6 @@
 URL:https://github.com/PyTables/PyTables
 Source0:
https://files.pythonhosted.org/packages/source/t/tables/tables-%{version}.tar.gz
 Patch0: Never-use-the-msse2-flag-explicitly.patch
-# PATCH-FIX-UPSTREAM pytables_no_unsafe_write.patch -- Fix for unsafe behavior 
forbidden in numpy 1.16
-Patch1: pytables_no_unsafe_write.patch
-# PATCH-FIX-UPSTREAM pytables_fix_exception_check.patch -- Fix for new 
exception in numpy 1.16
-Patch2: pytables_fix_exception_check.patch
 BuildRequires:  %{python_module Cython}
 BuildRequires:  %{python_module devel}
 # Python 3 version needs mock too for some reason
@@ -76,8 +72,6 @@
 %prep
 %setup -q -n tables-%{version}
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
 
 %build
 export CFLAGS="%{optflags} -fno-strict-aliasing"

++ Never-use-the-msse2-flag-explicitly.patch ++
--- /var/tmp/diff_new_pack.Tdavtv/_old  2019-07-23 22:36:31.714981894 +0200
+++ /var/tmp/diff_new_pack.Tdavtv/_new  2019-07-23 22:36:31.714981894 +0200
@@ -12,21 +12,21 @@
 index ee769e6..2cd6b1d 100755
 --- a/setup.py
 +++ b/setup.py
-@@ -836,7 +836,7 @@ if 'BLOSC' not in optional_libs:
- os.remove(fd.name)
+@@ -869,7 +869,7 @@
+ os.remove(fd.name)
  
- # SSE2
--if 'sse2' in cpu_flags:
-+if False and 'sse2' in cpu_flags:
- print('SSE2 detected')
- CFLAGS.append('-DSHUFFLE_SSE2_ENABLED')
- if os.name == 'nt':
-@@ -850,7 +850,7 @@ if 'BLOSC' not in optional_libs:
-   if 'sse2' in f]
- # AVX2
- # Detection code for AVX2 only works for gcc/clang, not for MSVC yet
--if ('avx2' in cpu_flags and
-+if (False and 

commit python-pysaml2 for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-pysaml2 for openSUSE:Factory 
checked in at 2019-07-23 22:35:30

Comparing /work/SRC/openSUSE:Factory/python-pysaml2 (Old)
 and  /work/SRC/openSUSE:Factory/.python-pysaml2.new.4126 (New)


Package is "python-pysaml2"

Tue Jul 23 22:35:30 2019 rev:12 rq:717622 version:4.8.0

Changes:

--- /work/SRC/openSUSE:Factory/python-pysaml2/python-pysaml2.changes
2019-06-06 18:17:07.684689441 +0200
+++ /work/SRC/openSUSE:Factory/.python-pysaml2.new.4126/python-pysaml2.changes  
2019-07-23 22:35:31.626994296 +0200
@@ -1,0 +2,20 @@
+Mon Jul 22 14:57:53 UTC 2019 - Tomáš Chvátal 
+
+- Update to 4.8.0:
+  * Refactor the way ForceAuthn is set: check for "true" and "1"
+  * Allow to set NameQualifier and SPNameQualifier attributes for ePTID
+  * Parse assertions with Holder-of-Key profile
+  * Add created_at timestamps to all mongodb documents
+  * Look for existing persistent id's before creating new ones
+  * Do not add AllowCreate property for default transient NameID
+  * Enable entity category import from module search path
+  * Add SAML subject identifier attributes to saml2_uri attributemap
+  * Fix deprecation warning regarding the cgi module - use the html module 
when available
+  * Misc minor improvements
+  * tests: Be compatible with latest pytest
+  * tests: Make tests pass after 2024
+  * tests: Add py37 as a test target
+  * docs: Correct instructions to run tests
+  * docs: Fix misc typos
+
+---

Old:

  v4.7.0.tar.gz

New:

  v4.8.0.tar.gz



Other differences:
--
++ python-pysaml2.spec ++
--- /var/tmp/diff_new_pack.3zMpmW/_old  2019-07-23 22:35:33.906993825 +0200
+++ /var/tmp/diff_new_pack.3zMpmW/_new  2019-07-23 22:35:33.942993817 +0200
@@ -19,7 +19,7 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %global modname pysaml2
 Name:   python-pysaml2
-Version:4.7.0
+Version:4.8.0
 Release:0
 Summary:Python implementation of SAML Version 2 to be used in a WSGI 
environment
 License:Apache-2.0

++ v4.7.0.tar.gz -> v4.8.0.tar.gz ++
 1814 lines of diff (skipped)




commit krita for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package krita for openSUSE:Factory checked 
in at 2019-07-23 22:35:11

Comparing /work/SRC/openSUSE:Factory/krita (Old)
 and  /work/SRC/openSUSE:Factory/.krita.new.4126 (New)


Package is "krita"

Tue Jul 23 22:35:11 2019 rev:36 rq:717485 version:4.2.3

Changes:

--- /work/SRC/openSUSE:Factory/krita/krita.changes  2019-07-21 
11:33:15.084788377 +0200
+++ /work/SRC/openSUSE:Factory/.krita.new.4126/krita.changes2019-07-23 
22:35:16.618997393 +0200
@@ -1,0 +2,52 @@
+Wed Jul 17 12:51:15 UTC 2019 - wba...@tmo.at
+
+- Update to 4.2.3:
+  * See https://krita.org/en/item/krita-4-2-3-released/
+  * Fix the caption of the Background Color color selection dialog
+(kde#407658)
+  * Fix the tag selector combobox so it is possible to select
+resources that have a tag that's longer than fits in the
+combobox (kde#408053)
+  * Make it possible for the Krita startup window to become as
+narrow as before adding the news widget (kde#408504)
+  * Fix copy/pasting of animation frames (kde#408421, kde#404595)
+  * Make the polygon and outline selection tool handle the control
+modifier correctly (kde#376007)
+  * Add a reload script button to the Python scripter plugin
+  * Fix a crash in the Overview docker when there is no image open
+  * Fix drag and drop of fill layers between opened files
+(kde#408019)
+  * Fix loading EXR files that have more than one layer with the
+same name (kde#409552)
+  * Hide vanishing points preview lines when assistants are hidden
+(kde#396158)
+  * Fix the Mirror All Layers Horizontally function
+  * Fix switching profile to default when changing channel depth in
+the New Image dialog (kde#406700)
+  * Disable AVG optimizations for some 32 bit blending modes
+(kde#404133)
+  * Fix a crash when pressing cancel when trying to create an 8
+bit/channel linear gamma RGB image
+  * Make sure Stroke Selection paint correctly with the selection
+border in the middle of the selection (kde#409254)
+  * Fix saving Krita when perspective assistants are present
+(kde#409249)
+  * Fix issues with transformations being pixelated (kde#409280)
+  * Make it possible to hide all layers except the selected one
+with shift-click (kde#376086)
+  * Fix cloning keyframe channels that are not opacity channels
+  * Fix a hang when trying to paint while playing an animation of
+an empty image (kde#408749)
+  * Fix Isolated Mode when multiple windows are open (kde#408150)
+  * Make the gradient editor show the right editor for stop and
+segmented gradients (but creating new gradients in Krita is
+still broken)
+  * Fix a freeze when pressing delete when making a polygonal
+selection (kde#408843)
+  * Fix the –export commandline option to return 0 when the export
+is successful (kde#409133)
+  * Fix support for the KDE Plasma global menu (kde#408015)
+  * Fix a crash when using the shrink option of the deform brush
+(kde#408887)
+
+---

Old:

  krita-4.2.2.tar.xz

New:

  krita-4.2.3.tar.xz



Other differences:
--
++ krita.spec ++
--- /var/tmp/diff_new_pack.nui1FW/_old  2019-07-23 22:35:19.546996788 +0200
+++ /var/tmp/diff_new_pack.nui1FW/_new  2019-07-23 22:35:19.550996788 +0200
@@ -24,7 +24,7 @@
 %bcond_with vc
 %endif
 Name:   krita
-Version:4.2.2
+Version:4.2.3
 Release:0
 Summary:Digital Painting Application
 License:GPL-2.0-or-later AND LGPL-2.0-or-later AND LGPL-2.1-or-later 
AND GPL-3.0-or-later AND BSD-2-Clause AND CC0-1.0 AND LGPL-2.0-only

++ krita-4.2.2.tar.xz -> krita-4.2.3.tar.xz ++
/work/SRC/openSUSE:Factory/krita/krita-4.2.2.tar.xz 
/work/SRC/openSUSE:Factory/.krita.new.4126/krita-4.2.3.tar.xz differ: char 27, 
line 1




commit openSUSE-release-tools for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package openSUSE-release-tools for 
openSUSE:Factory checked in at 2019-07-23 22:35:25

Comparing /work/SRC/openSUSE:Factory/openSUSE-release-tools (Old)
 and  /work/SRC/openSUSE:Factory/.openSUSE-release-tools.new.4126 (New)


Package is "openSUSE-release-tools"

Tue Jul 23 22:35:25 2019 rev:194 rq:717607 version:20190722.14459251

Changes:

--- 
/work/SRC/openSUSE:Factory/openSUSE-release-tools/openSUSE-release-tools.changes
2019-07-22 12:21:34.543645707 +0200
+++ 
/work/SRC/openSUSE:Factory/.openSUSE-release-tools.new.4126/openSUSE-release-tools.changes
  2019-07-23 22:35:28.354994971 +0200
@@ -1,0 +2,12 @@
+Mon Jul 22 14:35:58 UTC 2019 - opensuse-releaset...@opensuse.org
+
+- Update to version 20190722.14459251:
+  * Fix 15.1 images by introducing them again
+
+---
+Mon Jul 22 07:51:49 UTC 2019 - opensuse-releaset...@opensuse.org
+
+- Update to version 20190722.35dabf52:
+  * rabbit-openqa: Catch exceptions as PUT to openqa might result in 404
+
+---

Old:

  openSUSE-release-tools-20190719.297ecd02.obscpio

New:

  openSUSE-release-tools-20190722.14459251.obscpio



Other differences:
--
++ openSUSE-release-tools.spec ++
--- /var/tmp/diff_new_pack.LvaTVk/_old  2019-07-23 22:35:29.038994830 +0200
+++ /var/tmp/diff_new_pack.LvaTVk/_new  2019-07-23 22:35:29.050994827 +0200
@@ -20,7 +20,7 @@
 %define source_dir openSUSE-release-tools
 %define announcer_filename factory-package-news
 Name:   openSUSE-release-tools
-Version:20190719.297ecd02
+Version:20190722.14459251
 Release:0
 Summary:Tools to aid in staging and release work for openSUSE/SUSE
 License:GPL-2.0-or-later AND MIT

++ _servicedata ++
--- /var/tmp/diff_new_pack.LvaTVk/_old  2019-07-23 22:35:29.150994807 +0200
+++ /var/tmp/diff_new_pack.LvaTVk/_new  2019-07-23 22:35:29.150994807 +0200
@@ -1,6 +1,6 @@
 
   
 https://github.com/openSUSE/openSUSE-release-tools.git
-297ecd02c8182f693b30a585106f86f104758205
+cf5776c304fcc841bdc667061f2bd52f0fc0c7ac
   
 

++ openSUSE-release-tools-20190719.297ecd02.obscpio -> 
openSUSE-release-tools-20190722.14459251.obscpio ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/openSUSE-release-tools-20190719.297ecd02/gocd/rabbit-openqa.py 
new/openSUSE-release-tools-20190722.14459251/gocd/rabbit-openqa.py
--- old/openSUSE-release-tools-20190719.297ecd02/gocd/rabbit-openqa.py  
2019-07-19 17:14:31.0 +0200
+++ new/openSUSE-release-tools-20190722.14459251/gocd/rabbit-openqa.py  
2019-07-22 16:32:48.0 +0200
@@ -14,7 +14,7 @@
 from osclib.stagingapi import StagingAPI
 from lxml import etree as ET
 from openqa_client.client import OpenQA_Client
-from openqa_client.exceptions import ConnectionError
+from openqa_client.exceptions import ConnectionError, RequestError
 from urllib.error import HTTPError, URLError
 from urllib.parse import quote_plus
 
@@ -209,7 +209,10 @@
 # notify openQA to sync the projects - the plugin will check itself it
 # the project is to be synced. For now we notify about every 'images' 
repo
 if payload['repo'] == 'images':
-self.openqa.openqa_request('PUT', 'obs_rsync', 
str(payload['project']), 'runs')
+try:
+self.openqa.openqa_request('PUT', 
'obs_rsync/{}/runs'.format(payload['project']), retries=0)
+except RequestError as e:
+self.logger.info("Got exception on syncing repository: 
{}".format(e))
 
 def on_openqa_job(self, iso):
 self.logger.debug('openqa_job_change %s', iso)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/openSUSE-release-tools-20190719.297ecd02/gocd/totestmanager.gocd.yaml 
new/openSUSE-release-tools-20190722.14459251/gocd/totestmanager.gocd.yaml
--- old/openSUSE-release-tools-20190719.297ecd02/gocd/totestmanager.gocd.yaml   
2019-07-19 17:14:31.0 +0200
+++ new/openSUSE-release-tools-20190722.14459251/gocd/totestmanager.gocd.yaml   
2019-07-22 16:32:48.0 +0200
@@ -105,6 +105,48 @@
 - script: |-
 install -D /home/go/config/openqa-client.conf 
/home/go/.config/openqa/client.conf
 scripts/totest-manager.py -A https://api.opensuse.org --debug run 
openSUSE:Leap:15.0:Images
+  TTM.Leap_15.1_Images:
+group: openSUSE.Checkers
+lock_behavior: unlockWhenFinished
+environment_variables:
+  OSC_CONFIG: /home/go/config/oscrc-totest-manager
+materials:
+  script:
+git: 

commit python-pypng for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package python-pypng for openSUSE:Factory 
checked in at 2019-07-23 22:35:39

Comparing /work/SRC/openSUSE:Factory/python-pypng (Old)
 and  /work/SRC/openSUSE:Factory/.python-pypng.new.4126 (New)


Package is "python-pypng"

Tue Jul 23 22:35:39 2019 rev:4 rq:717625 version:0.0.20

Changes:

--- /work/SRC/openSUSE:Factory/python-pypng/python-pypng.changes
2019-03-05 12:19:36.128946092 +0100
+++ /work/SRC/openSUSE:Factory/.python-pypng.new.4126/python-pypng.changes  
2019-07-23 22:35:41.014992358 +0200
@@ -1,0 +2,6 @@
+Mon Jul 22 15:05:42 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.0.20:
+  * no changelog
+
+---

Old:

  pypng-0.0.19.tar.gz

New:

  pypng-0.0.20.tar.gz



Other differences:
--
++ python-pypng.spec ++
--- /var/tmp/diff_new_pack.5KwiW9/_old  2019-07-23 22:35:41.506992257 +0200
+++ /var/tmp/diff_new_pack.5KwiW9/_new  2019-07-23 22:35:41.506992257 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pypng
-Version:0.0.19
+Version:0.0.20
 Release:0
 Summary:Pure Python PNG image encoder/decoder
 License:MIT
@@ -51,8 +51,8 @@
 %python_expand PYTHONPATH=%{buildroot}%{$python_sitelib}:code $python 
code/test_png.py
 
 %files %{python_files}
-%doc README.md
 %license LICENCE
 %{python_sitelib}/*
+%python3_only %{_bindir}/*
 
 %changelog

++ pypng-0.0.19.tar.gz -> pypng-0.0.20.tar.gz ++
 27429 lines of diff (skipped)




commit testdisk for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package testdisk for openSUSE:Factory 
checked in at 2019-07-23 22:35:34

Comparing /work/SRC/openSUSE:Factory/testdisk (Old)
 and  /work/SRC/openSUSE:Factory/.testdisk.new.4126 (New)


Package is "testdisk"

Tue Jul 23 22:35:34 2019 rev:5 rq:717623 version:7.1

Changes:

--- /work/SRC/openSUSE:Factory/testdisk/testdisk.changes2019-05-22 
11:08:52.706608653 +0200
+++ /work/SRC/openSUSE:Factory/.testdisk.new.4126/testdisk.changes  
2019-07-23 22:35:36.314993328 +0200
@@ -1,0 +2,7 @@
+Wed Jul 17 19:10:09 UTC 2019 - opensuse.lietuviu.ka...@gmail.com
+
+- update to 7.1 stable version
+  * PhotoRec & QPhotoRec improvements
+  - Recover more fragmented files.
+
+---

Old:

  testdisk-7.1-WIP.tar.bz2

New:

  testdisk-7.1.tar.bz2



Other differences:
--
++ testdisk.spec ++
--- /var/tmp/diff_new_pack.eVGkCt/_old  2019-07-23 22:35:37.150993156 +0200
+++ /var/tmp/diff_new_pack.eVGkCt/_new  2019-07-23 22:35:37.154993155 +0200
@@ -23,7 +23,7 @@
 License:GPL-2.0
 Group:  System/Filesystems
 Url:http://www.cgsecurity.org/wiki/TestDisk
-Source0:http://www.cgsecurity.org/%{name}-%{version}-WIP.tar.bz2
+Source0:http://www.cgsecurity.org/%{name}-%{version}.tar.bz2
 Patch0: testdisk-file-contains-date-and-time.patch
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  libewf-devel
@@ -67,7 +67,7 @@
 More user friendly, it recognizes the same file formats.
 
 %prep
-%define TAR_TOP_FOLDER %{name}-%{version}-WIP
+%define TAR_TOP_FOLDER %{name}-%{version}
 %setup -q -n %{TAR_TOP_FOLDER}
 %patch0 -p1
 cp README.md README

++ testdisk-7.1-WIP.tar.bz2 -> testdisk-7.1.tar.bz2 ++
 3053 lines of diff (skipped)




commit xinput for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package xinput for openSUSE:Factory checked 
in at 2019-07-23 22:35:28

Comparing /work/SRC/openSUSE:Factory/xinput (Old)
 and  /work/SRC/openSUSE:Factory/.xinput.new.4126 (New)


Package is "xinput"

Tue Jul 23 22:35:28 2019 rev:11 rq:717618 version:1.6.3

Changes:

--- /work/SRC/openSUSE:Factory/xinput/xinput.changes2015-10-22 
12:59:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.xinput.new.4126/xinput.changes  2019-07-23 
22:35:30.626994502 +0200
@@ -1,0 +2,13 @@
+Fri Jul 19 13:25:18 UTC 2019 - Stefan Dirsch 
+
+- Update to version 1.6.3
+  * xinput 1.6.3 is now available, incorporating the best of the
+last (checks calendar) four years. Most of this is buildsystem
+tidyup that mattered back then but is less exciting now in
+these modern times.
+The only user-visible change is that xinput will now print a
+warning when run against XWayland in the hope that this will
+reduce the number of confused users or misguided bugs. Or
+both, ideally.
+
+---

Old:

  xinput-1.6.2.tar.bz2

New:

  xinput-1.6.3.tar.bz2



Other differences:
--
++ xinput.spec ++
--- /var/tmp/diff_new_pack.SomwSX/_old  2019-07-23 22:35:30.974994430 +0200
+++ /var/tmp/diff_new_pack.SomwSX/_new  2019-07-23 22:35:30.974994430 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package xinput
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,15 +12,15 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   xinput
-Version:1.6.2
+Version:1.6.3
 Release:0
 Summary:Utility to configure and test X input devices
-License:MIT and HPND
+License:MIT AND HPND
 Group:  System/X11/Utilities
 Url:http://xorg.freedesktop.org/
 Source0:
http://xorg.freedesktop.org/releases/individual/app/%{name}-%{version}.tar.bz2

++ xinput-1.6.2.tar.bz2 -> xinput-1.6.3.tar.bz2 ++
 9423 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/xinput-1.6.2/ChangeLog new/xinput-1.6.3/ChangeLog
--- old/xinput-1.6.2/ChangeLog  2015-10-19 23:36:40.0 +0200
+++ new/xinput-1.6.3/ChangeLog  2019-07-17 07:30:12.0 +0200
@@ -1,3 +1,124 @@
+commit cef07c0c8280d7e7b82c3bcc62a1dfbe8cc43ff8
+Author: Peter Hutterer 
+Date:   Wed Jul 17 15:25:10 2019 +1000
+
+xinput 1.6.3
+
+Signed-off-by: Peter Hutterer 
+
+commit d0a77e79a73177090ae7dceb7a9802f98db6d9f0
+Author: Peter Hutterer 
+Date:   Tue Mar 26 16:06:44 2019 +1000
+
+Warn if you're running against an XWayland server
+
+Because there's a 99% chance you don't want this.
+
+Signed-off-by: Peter Hutterer 
+
+commit c7ca2b99c099456d0c0e83309d6f426c5feacb25
+Author: Alan Coopersmith 
+Date:   Wed Nov 21 17:10:59 2018 -0800
+
+Update configure.ac bug URL for gitlab migration
+
+Signed-off-by: Alan Coopersmith 
+
+commit 5a8f3121c7f64dbb47fad99c027389e7d78453e4
+Author: Peter Hutterer 
+Date:   Thu Sep 13 09:39:22 2018 +1000
+
+test-xi2: add an extra NULL-check
+
+Shuts up coverity because it doesn't know that by the time we get here, 
we're
+guaranteed that the device exists. Otherwise the list() call a few lines 
above
+would've failed and we wouldn't get here.
+
+Signed-off-by: Peter Hutterer 
+
+commit 3ea8f02027b18cf06774c8f26a719e321e9a78f2
+Author: Peter Hutterer 
+Date:   Wed Sep 12 14:49:21 2018 +1000
+
+property: plug a memory leak
+
+Not that it matters since we'll exit after this call anyway, but coverity 
is
+unhappy and that makes us all unhappy, doesn't it?
+
+Signed-off-by: Peter Hutterer 
+
+commit 988488127cdf49b47cd075a698c78f25ee193467
+Author: Peter Hutterer 
+Date:   Tue Jul 25 14:32:56 2017 +1000
+
+man: document an example for a set-prop call
+
+Because it's 99% of the use-cases people use libinput for these days.
+
+Signed-off-by: Peter Hutterer 
+

commit sigil for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package sigil for openSUSE:Factory checked 
in at 2019-07-23 22:35:05

Comparing /work/SRC/openSUSE:Factory/sigil (Old)
 and  /work/SRC/openSUSE:Factory/.sigil.new.4126 (New)


Package is "sigil"

Tue Jul 23 22:35:05 2019 rev:8 rq:717457 version:0.9.16

Changes:

--- /work/SRC/openSUSE:Factory/sigil/sigil.changes  2019-07-11 
13:15:07.090831001 +0200
+++ /work/SRC/openSUSE:Factory/.sigil.new.4126/sigil.changes2019-07-23 
22:35:06.978999383 +0200
@@ -1,0 +2,32 @@
+Mon Jul 22 07:19:12 UTC 2019 - ec...@opensuse.org
+
+- Update to 0.9.16
+  * New Features
+- added epub3 tool: Generate NCX/Guide for epub2 e-readers
+- added epub3 tool: Remove NCX and Guide
+- added right click on link in Preview copies url to 
+  clipboard
+- added check mark indicator for current semantic set in 
+  AddSemantics dialog
+- opf guide is no longer used/updated in epub3, unless new 
+  epub3 tool menu is used
+- harden Sigil against maliciously crafted epub zip archives 
+  (aka zip-slip attacks)
+- added bk.getnavid() to the plugin framework and 
+  navprocessor.py for plugin devs
+- updated build documents to the latest Qt 5.12.3 and Python 
+  3.7.2)
+  * Bug Fixes
+- add missing title tag to nav head to make epubcheck happy
+- add dcterms:modified to empty epub 3 opf to keep epubcheck 
+  happy
+- fix lost Preview-CodeView sync when internal links are 
+  followed in Preview
+- fix macOS specific bug with newer versions of PIL (Pillow) 
+  used by plugins
+- prevent MS VC++ automatic reboots during Windows installs
+- prevent user from changing semantics of the nav file itself 
+  (it must be set to “toc”)
+- fix bug that dropped nav from spine when HTML TOC created
+
+---
@@ -1117 +1148,0 @@
-

Old:

  0.9.15.tar.gz

New:

  0.9.16.tar.gz



Other differences:
--
++ sigil.spec ++
--- /var/tmp/diff_new_pack.AR8fAW/_old  2019-07-23 22:35:07.766999220 +0200
+++ /var/tmp/diff_new_pack.AR8fAW/_new  2019-07-23 22:35:07.766999220 +0200
@@ -19,7 +19,7 @@
 %define sigil_doc_version 2019.06.25
 
 Name:   sigil
-Version:0.9.15
+Version:0.9.16
 Release:0
 Summary:WYSIWYG Ebook Editor
 License:GPL-3.0-only
@@ -46,6 +46,7 @@
 BuildRequires:  libxslt-devel
 BuildRequires:  make
 BuildRequires:  pcre-devel
+# upstream use 3.7.2
 BuildRequires:  python3-devel >= 3.4
 BuildRequires:  unzip
 BuildRequires:  update-desktop-files
@@ -70,7 +71,7 @@
 BuildRequires:  python3-html5lib >= 1.0.1
 # upstream use for python3-lxml 4.2.6
 BuildRequires:  python3-lxml
-# upstream use for python3-qt5 5.12
+# upstream use for python3-qt5 5.12.3
 BuildRequires:  python3-qt5
 # upstream use for python3-regex 2018.11.12
 BuildRequires:  python3-regex

++ 0.9.15.tar.gz -> 0.9.16.tar.gz ++
/work/SRC/openSUSE:Factory/sigil/0.9.15.tar.gz 
/work/SRC/openSUSE:Factory/.sigil.new.4126/0.9.16.tar.gz differ: char 15, line 1





commit QtAV for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package QtAV for openSUSE:Factory checked in 
at 2019-07-23 22:34:48

Comparing /work/SRC/openSUSE:Factory/QtAV (Old)
 and  /work/SRC/openSUSE:Factory/.QtAV.new.4126 (New)


Package is "QtAV"

Tue Jul 23 22:34:48 2019 rev:5 rq:715638 version:1.13.0

Changes:

--- /work/SRC/openSUSE:Factory/QtAV/QtAV.changes2018-07-10 
16:14:27.321627203 +0200
+++ /work/SRC/openSUSE:Factory/.QtAV.new.4126/QtAV.changes  2019-07-23 
22:34:49.643002960 +0200
@@ -1,0 +2,21 @@
+Thu Jul 11 20:26:12 UTC 2019 - wba...@tmo.at
+
+- Update to 1.13.0
+  * Add python bindings
+  * More apis for qml player
+  * Auto rotate video
+  * Apple store
+  * Fix ios plugin not found
+  * Support chapters
+  * Muxer, encoder, transcoder improvements
+  * Compatible with new ffmpeg
+  * videotoolbox: hevc,
+  * cuda: new devices
+  * Android: no longer depends on private qt module
+  * Fix opensl error
+  * mediacodec: 0-copy via a plugin from https://github.com/wang-bin/mdk-sdk
+- Drop patches merged upstream:
+  * fix-build-newer-ffmpeg.patch
+  * disable-use-of-deprecated-header.patch
+
+---

Old:

  QtAV-1.12.0.obscpio
  disable-use-of-deprecated-header.patch
  fix-build-newer-ffmpeg.patch

New:

  QtAV-1.13.0.obscpio



Other differences:
--
++ QtAV.spec ++
--- /var/tmp/diff_new_pack.kdsiYA/_old  2019-07-23 22:34:50.903002701 +0200
+++ /var/tmp/diff_new_pack.kdsiYA/_new  2019-07-23 22:34:50.907002700 +0200
@@ -21,7 +21,7 @@
 %define Qt_name %{src_name}
 %define ffmpeg_includedir -I%(pkg-config --variable=includedir libavutil)
 Name:   QtAV
-Version:1.12.0
+Version:1.13.0
 Release:0
 Summary:Qt multimedia framework
 License:LGPL-2.1-or-later AND GPL-3.0-only
@@ -30,10 +30,6 @@
 Source0:QtAV-%{version}.tar.xz
 Patch1: fix-linking.patch
 Patch2: disable_cuda.patch
-# PATCH-FIX-UPSTREAM
-Patch3: fix-build-newer-ffmpeg.patch
-# PATCH-FIX-UPSTREAM
-Patch4: disable-use-of-deprecated-header.patch
 BuildRequires:  ImageMagick
 BuildRequires:  dos2unix
 BuildRequires:  hicolor-icon-theme

++ QtAV-1.12.0.obscpio -> QtAV-1.13.0.obscpio ++
/work/SRC/openSUSE:Factory/QtAV/QtAV-1.12.0.obscpio 
/work/SRC/openSUSE:Factory/.QtAV.new.4126/QtAV-1.13.0.obscpio differ: char 7, 
line 1

++ QtAV.obsinfo ++
--- /var/tmp/diff_new_pack.kdsiYA/_old  2019-07-23 22:34:50.951002691 +0200
+++ /var/tmp/diff_new_pack.kdsiYA/_new  2019-07-23 22:34:50.951002691 +0200
@@ -1,5 +1,5 @@
 name: QtAV
-version: 1.12.0
-mtime: 1498009635
-commit: f672e4a6964463e13403d55d58aa71876c798ed2
+version: 1.13.0
+mtime: 1562806739
+commit: b51fee72a82fab049faf932fd0414d6a58e6caec
 

++ _service ++
--- /var/tmp/diff_new_pack.kdsiYA/_old  2019-07-23 22:34:50.971002687 +0200
+++ /var/tmp/diff_new_pack.kdsiYA/_new  2019-07-23 22:34:50.971002687 +0200
@@ -2,8 +2,8 @@
   
 https://github.com/wang-bin/QtAV.git
 git
-v1.12.0
-1.12.0
+v1.13.0
+1.13.0
 
 */src/cuda/dllapi/cuviddec.h
 */src/cuda/dllapi/nvcuvid.h




commit exa for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package exa for openSUSE:Factory checked in 
at 2019-07-23 22:34:44

Comparing /work/SRC/openSUSE:Factory/exa (Old)
 and  /work/SRC/openSUSE:Factory/.exa.new.4126 (New)


Package is "exa"

Tue Jul 23 22:34:44 2019 rev:3 rq:715592 version:0.9.0

Changes:

--- /work/SRC/openSUSE:Factory/exa/exa.changes  2018-05-15 10:34:12.982393538 
+0200
+++ /work/SRC/openSUSE:Factory/.exa.new.4126/exa.changes2019-07-23 
22:34:44.639003993 +0200
@@ -1,0 +2,27 @@
+Tue Jul 16 07:34:54 UTC 2019 - mvet...@suse.com
+
+- Update to 0.9.0:
+  Additions:
+  * Icon support with --icons (9497b30)
+  * New sort options .name and .Name which ignore a leading dot (a156d96)
+  * Support TIME_STYLE environment variable (9917810)
+  * New option to only display directories, --only-dirs (054cac6)
+  * Support 24-bit colours (dc2009a)
+  * Display if a file is ignored by Git (80b0d9d)
+  Changes:
+  * Replace the mi colour with bO overlay colour (59d9e90)
+  * Pre-release versions have their build number shown (c7497f3)
+  * Add --classify to man page (9c77a95)
+  * Highlighting for file types .zst (5fae489), Bazel and Ant (c635031), .ts 
(e711dbc), .m4v (9b446c0), and .jpf (9916742)
+  * Create worker threads only once for performance (8cbde76)
+  Fixes:
+  * Allow zero-padded numbers in $LS_COLORS (afc9657, ce3f05c)
+  * Make non-uppercase README files immediate (d9c9dbe)
+  * Highlight README~ as temporary, not immediate (57e4c08)
+  * Use more accurate time to fix inconsistent sorting (649744d)
+  * Prevent infinite loop with -aaR (e936d7e)
+  * Fix panic in certain timezones (9f76f94 and this fix)
+  * Fix sorting by created time (faed8f9)
+  * Fix Git status not working for paths containing ../ (f1a5b64)
+
+---

Old:

  v0.8.0.tar.gz

New:

  v0.9.0.tar.gz



Other differences:
--
++ exa.spec ++
--- /var/tmp/diff_new_pack.60I52w/_old  2019-07-23 22:34:45.531003809 +0200
+++ /var/tmp/diff_new_pack.60I52w/_new  2019-07-23 22:34:45.535003808 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package exa
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   exa
-Version:0.8.0
+Version:0.9.0
 Release:0
 Summary:Replacement for ls written in Rust
 License:MIT

++ v0.8.0.tar.gz -> v0.9.0.tar.gz ++
 5824 lines of diff (skipped)

++ vendor.tar.xz ++
/work/SRC/openSUSE:Factory/exa/vendor.tar.xz 
/work/SRC/openSUSE:Factory/.exa.new.4126/vendor.tar.xz differ: char 25, line 1




commit gdal for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package gdal for openSUSE:Factory checked in 
at 2019-07-23 22:34:39

Comparing /work/SRC/openSUSE:Factory/gdal (Old)
 and  /work/SRC/openSUSE:Factory/.gdal.new.4126 (New)


Package is "gdal"

Tue Jul 23 22:34:39 2019 rev:42 rq:715535 version:3.0.1

Changes:

--- /work/SRC/openSUSE:Factory/gdal/gdal.changes2019-07-11 
13:16:34.002801920 +0200
+++ /work/SRC/openSUSE:Factory/.gdal.new.4126/gdal.changes  2019-07-23 
22:34:40.775004791 +0200
@@ -1,0 +2,9 @@
+Mon Jul  8 13:34:52 UTC 2019 - Dirk Stoecker 
+
+- update to 3.0.1
+  Full changelogs:
+  https://trac.osgeo.org/gdal/wiki/Release/3.0.1-News
+  https://trac.osgeo.org/gdal/wiki/Release/3.0.0-News
+  Patch pkg-config-libpq.patch included upstream
+
+---

Old:

  gdal-2.4.2.tar.xz
  gdal-2.4.2.tar.xz.md5
  pkg-config-libpq.patch

New:

  gdal-3.0.1.tar.xz
  gdal-3.0.1.tar.xz.md5



Other differences:
--
++ gdal.spec ++
--- /var/tmp/diff_new_pack.UUV7ny/_old  2019-07-23 22:34:42.615004411 +0200
+++ /var/tmp/diff_new_pack.UUV7ny/_new  2019-07-23 22:34:42.643004405 +0200
@@ -18,7 +18,7 @@
 
 # Soname should be bumped on API/ABI break
 # http://trac.osgeo.org/gdal/ticket/4543
-%define soversion 20
+%define soversion 26
 %define sourcename gdal
 # Uppercase GDAL is the canonical name for this package in Python
 %define pypi_package_name GDAL
@@ -26,7 +26,7 @@
 %bcond_with ecw5_support
 %bcond_with fgdb_support
 Name:   gdal
-Version:2.4.2
+Version:3.0.1
 Release:0
 Summary:GDAL/OGR - a translator library for raster and vector 
geospatial data formats
 License:MIT AND BSD-3-Clause AND SUSE-Public-Domain
@@ -37,8 +37,6 @@
 Patch0: gdal-perl.patch
 # Fix occasional parallel build failure
 Patch1: GDALmake.opt.in.patch
-# Fix UPSTREAM Patch (pr#1418 in progress) upstream issue #1412
-Patch2: pkg-config-libpq.patch
 BuildRequires:  KEALib-devel
 BuildRequires:  blas-devel
 BuildRequires:  chrpath
@@ -124,8 +122,8 @@
 Group:  Development/Languages/C and C++
 Requires:   lib%{name}%{soversion} = %{version}
 Requires:   pkgconfig(libopenjp2)
-Provides:   lib%{name}%{soversion}-devel
-Provides:   lib%{name}-devel
+Provides:   lib%{name}%{soversion}-devel = %{version}
+Provides:   lib%{name}-devel = %{version}
 
 %description devel
 Development Libraries for the GDAL file format library

++ gdal-2.4.2.tar.xz -> gdal-3.0.1.tar.xz ++
/work/SRC/openSUSE:Factory/gdal/gdal-2.4.2.tar.xz 
/work/SRC/openSUSE:Factory/.gdal.new.4126/gdal-3.0.1.tar.xz differ: char 25, 
line 1

++ gdal-2.4.2.tar.xz.md5 -> gdal-3.0.1.tar.xz.md5 ++
--- /work/SRC/openSUSE:Factory/gdal/gdal-2.4.2.tar.xz.md5   2019-07-11 
13:16:33.974801929 +0200
+++ /work/SRC/openSUSE:Factory/.gdal.new.4126/gdal-3.0.1.tar.xz.md5 
2019-07-23 22:34:40.763004794 +0200
@@ -1 +1 @@
-7b9e293b9426ffaa2d7287a4880d7139  gdal-2.4.2.tar.xz
+f3bcf494f8285861dedaa5b9aa6e9479  gdal-3.0.1.tar.xz




commit Mesa for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package Mesa for openSUSE:Factory checked in 
at 2019-07-23 22:33:27

Comparing /work/SRC/openSUSE:Factory/Mesa (Old)
 and  /work/SRC/openSUSE:Factory/.Mesa.new.4126 (New)


Package is "Mesa"

Tue Jul 23 22:33:27 2019 rev:353 rq:717526 version:unknown

Changes:

--- /work/SRC/openSUSE:Factory/Mesa/Mesa-drivers.changes2019-07-12 
12:07:54.403863387 +0200
+++ /work/SRC/openSUSE:Factory/.Mesa.new.4126/Mesa-drivers.changes  
2019-07-23 22:33:28.403019728 +0200
@@ -1,0 +2,16 @@
+Mon Jul 22 09:42:33 UTC 2019 - Stefan Dirsch 
+
+- n_drirc-disable-rgb10-for-chromium-on-amd.patch
+  * added totem as another affected application (boo#1142270) 
+
+---
+Fri Jul 12 10:16:59 UTC 2019 - Stefan Dirsch 
+
+- Add v3d support (VC5/V6 driver) for %arm and aarch64 
+
+---
+Fri Jul 12 08:46:16 UTC 2019 - Guillaume GARDET 
+
+- Add kmsro for %arm and aarch64
+
+---
Mesa.changes: same change



Other differences:
--
++ Mesa-drivers.spec ++
--- /var/tmp/diff_new_pack.3e2oew/_old  2019-07-23 22:33:29.223019558 +0200
+++ /var/tmp/diff_new_pack.3e2oew/_new  2019-07-23 22:33:29.223019558 +0200
@@ -807,7 +807,7 @@
   %else
   %ifarch %{arm} aarch64
 -Ddri-drivers=nouveau \
-
-Dgallium-drivers=r300,r600,nouveau,swrast,virgl,freedreno,vc4,etnaviv,lima,panfrost
 \
+
-Dgallium-drivers=r300,r600,nouveau,swrast,virgl,freedreno,vc4,etnaviv,lima,panfrost,kmsro,v3d
 \
   %else
   %ifarch ppc64 ppc64le
 -Ddri-drivers=nouveau \

Mesa.spec: same change


++ n_drirc-disable-rgb10-for-chromium-on-amd.patch ++
--- /var/tmp/diff_new_pack.3e2oew/_old  2019-07-23 22:33:29.367019529 +0200
+++ /var/tmp/diff_new_pack.3e2oew/_new  2019-07-23 22:33:29.367019529 +0200
@@ -1,8 +1,8 @@
-Index: mesa-19.1.0/src/util/00-mesa-defaults.conf
+Index: mesa-19.1.2/src/util/00-mesa-defaults.conf
 ===
 mesa-19.1.0.orig/src/util/00-mesa-defaults.conf2019-06-11 
17:12:51.0 +0200
-+++ mesa-19.1.0/src/util/00-mesa-defaults.conf 2019-06-11 22:12:04.431893217 
+0200
-@@ -451,6 +451,11 @@ TODO: document the other workarounds.
+--- mesa-19.1.2.orig/src/util/00-mesa-defaults.conf
 mesa-19.1.2/src/util/00-mesa-defaults.conf
+@@ -451,6 +451,17 @@ TODO: document the other workarounds.
  
  
  
@@ -11,6 +11,12 @@
 +
 +
 +
++
++
++
++
++
++
  
  
  




commit hwinfo for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package hwinfo for openSUSE:Factory checked 
in at 2019-07-23 22:33:12

Comparing /work/SRC/openSUSE:Factory/hwinfo (Old)
 and  /work/SRC/openSUSE:Factory/.hwinfo.new.4126 (New)


Package is "hwinfo"

Tue Jul 23 22:33:12 2019 rev:169 rq:717098 version:21.67

Changes:

--- /work/SRC/openSUSE:Factory/hwinfo/hwinfo.changes2019-05-25 
13:34:28.788009907 +0200
+++ /work/SRC/openSUSE:Factory/.hwinfo.new.4126/hwinfo.changes  2019-07-23 
22:33:14.343022630 +0200
@@ -1,0 +2,8 @@
+Fri Jul 19 13:56:55 UTC 2019 - wfe...@opensuse.org
+
+- merge gh#openSUSE/hwinfo#81
+- fix DASD detection (bsc#1136475)
+- don't include bcache devices
+- 21.67
+
+

Old:

  hwinfo-21.66.tar.xz

New:

  hwinfo-21.67.tar.xz



Other differences:
--
++ hwinfo.spec ++
--- /var/tmp/diff_new_pack.ZJFgRS/_old  2019-07-23 22:33:14.847022526 +0200
+++ /var/tmp/diff_new_pack.ZJFgRS/_new  2019-07-23 22:33:14.847022526 +0200
@@ -37,7 +37,7 @@
 License:GPL-2.0-or-later
 Group:  Hardware/Other
 Url:http://gitorious.org/opensuse/hwinfo
-Version:21.66
+Version:21.67
 Release:0
 Source: %{name}-%{version}.tar.xz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ hwinfo-21.66.tar.xz -> hwinfo-21.67.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hwinfo-21.66/VERSION new/hwinfo-21.67/VERSION
--- old/hwinfo-21.66/VERSION2019-05-23 15:32:53.0 +0200
+++ new/hwinfo-21.67/VERSION2019-07-19 15:56:55.0 +0200
@@ -1 +1 @@
-21.66
+21.67
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hwinfo-21.66/changelog new/hwinfo-21.67/changelog
--- old/hwinfo-21.66/changelog  2019-05-23 15:32:53.0 +0200
+++ new/hwinfo-21.67/changelog  2019-07-19 15:56:55.0 +0200
@@ -1,3 +1,8 @@
+2019-07-19:21.67
+   - merge gh#openSUSE/hwinfo#81
+   - fix DASD detection (bsc#1136475)
+   - don't include bcache devices
+
 2019-05-23:21.66
- merge gh#openSUSE/hwinfo#80
- fix Makefile and allow building for old distros
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hwinfo-21.66/src/hd/block.c 
new/hwinfo-21.67/src/hd/block.c
--- old/hwinfo-21.66/src/hd/block.c 2019-05-23 15:32:53.0 +0200
+++ new/hwinfo-21.67/src/hd/block.c 2019-07-19 15:56:55.0 +0200
@@ -525,36 +525,37 @@
 
   if(hd->sysfs_id) {
 if(
-  sscanf(hd->sysfs_id, "/block/cciss!c%ud%u", , ) == 2
+  sscanf(hd->sysfs_id, "/class/block/cciss!c%ud%u", , ) == 2
 ) {
   hd->slot = (u0 << 8) + u1;
   str_printf(>device.name, 0, "CCISS disk %u/%u", u0, u1);
 }
 else if(
-  sscanf(hd->sysfs_id, "/block/ida!c%ud%u", , ) == 2
+  sscanf(hd->sysfs_id, "/class/block/ida!c%ud%u", , ) == 2
 ) {
   hd->slot = (u0 << 8) + u1;
   str_printf(>device.name, 0, "SMART Array %u/%u", u0, u1);
 }
 else if(
-  sscanf(hd->sysfs_id, "/block/rd!c%ud%u", , ) == 2
+  sscanf(hd->sysfs_id, "/class/block/rd!c%ud%u", , ) == 2
 ) {
   hd->slot = (u0 << 8) + u1;
   str_printf(>device.name, 0, "DAC960 RAID Array %u/%u", u0, u1);
 }
 else if(
-  sscanf(hd->sysfs_id, "/block/i2o!hd%c", ) == 1 &&
+  sscanf(hd->sysfs_id, "/class/block/i2o!hd%c", ) == 1 &&
   c >= 'a'
 ) {
   hd->slot = c - 'a';
   str_printf(>device.name, 0, "I2O disk %u", hd->slot);
 }
 else if(
-  sscanf(hd->sysfs_id, "/block/dasd%c", ) == 1 &&
+  sscanf(hd->sysfs_id, "/class/block/dasd%c", ) == 1 &&
   c >= 'a'
 ) {
   hd->slot = c - 'a';
   hd->device.name = new_str("S390 Disk");
+  hd_set_hw_class(hd, hw_redasd);
 }
   }
 
@@ -1221,7 +1222,8 @@
   hd_data->flags.list_md ||
   (
 strncmp(name, "md", sizeof "md" - 1) &&
-strncmp(name, "dm-", sizeof "dm-" - 1)
+strncmp(name, "dm-", sizeof "dm-" - 1) &&
+strncmp(name, "bcache", sizeof "bcache" - 1)
   )
 )
   ) {
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hwinfo-21.66/src/hd/hd.c new/hwinfo-21.67/src/hd/hd.c
--- old/hwinfo-21.66/src/hd/hd.c2019-05-23 15:32:53.0 +0200
+++ new/hwinfo-21.67/src/hd/hd.c2019-07-19 15:56:55.0 +0200
@@ -4783,13 +4783,6 @@
   ) {
 hd_set_hw_class(hd, hw_tape);
   }
-
-  if(
-hd->base_class.id == bc_storage_device &&
-hd->sub_class.id == sc_sdev_disk
-  ) {
-hd_set_hw_class(hd, hw_redasd);
-  }
 }
 
 




commit grub2 for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package grub2 for openSUSE:Factory checked 
in at 2019-07-23 22:32:21

Comparing /work/SRC/openSUSE:Factory/grub2 (Old)
 and  /work/SRC/openSUSE:Factory/.grub2.new.4126 (New)


Package is "grub2"

Tue Jul 23 22:32:21 2019 rev:208 rq:716998 version:2.02

Changes:

--- /work/SRC/openSUSE:Factory/grub2/grub2.changes  2019-07-16 
08:37:41.851098322 +0200
+++ /work/SRC/openSUSE:Factory/.grub2.new.4126/grub2.changes2019-07-23 
22:32:22.419033347 +0200
@@ -1,0 +2,6 @@
+Thu Jul 18 09:54:14 UTC 2019 - mch...@suse.com
+
+- Revert grub2-ieee1275-FCP-methods-for-WWPN-and-LUNs.patch until merged by
+  upstream (bsc#1134287, bsc#1139345, LTC#177836, LTC#174229).
+
+---

Old:

  grub2-ieee1275-FCP-methods-for-WWPN-and-LUNs.patch



Other differences:
--
++ grub2.spec ++
--- /var/tmp/diff_new_pack.6fkRxG/_old  2019-07-23 22:32:27.091032382 +0200
+++ /var/tmp/diff_new_pack.6fkRxG/_new  2019-07-23 22:32:27.091032382 +0200
@@ -267,7 +267,6 @@
 Patch213:   grub2-Fix-incorrect-netmask-on-ppc64.patch
 Patch215:   grub2-ppc64-cas-new-scope.patch
 Patch216:   0001-ofnet-Initialize-structs-in-bootpath-parser.patch
-Patch217:   grub2-ieee1275-FCP-methods-for-WWPN-and-LUNs.patch
 Patch218:   grub2-ppc64-cas-fix-double-free.patch
 Patch233:   grub2-use-stat-instead-of-udevadm-for-partition-lookup.patch
 Patch234:   
fix-grub2-use-stat-instead-of-udevadm-for-partition-lookup-with-new-glibc.patch
@@ -581,7 +580,6 @@
 %patch213 -p1
 %patch215 -p1
 %patch216 -p1
-%patch217 -p1
 %patch218 -p1
 %patch233 -p1
 %patch234 -p1






commit skelcd-control-MicroOS for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package skelcd-control-MicroOS for 
openSUSE:Factory checked in at 2019-07-23 22:32:50

Comparing /work/SRC/openSUSE:Factory/skelcd-control-MicroOS (Old)
 and  /work/SRC/openSUSE:Factory/.skelcd-control-MicroOS.new.4126 (New)


Package is "skelcd-control-MicroOS"

Tue Jul 23 22:32:50 2019 rev:6 rq:717085 version:20190619

Changes:

--- 
/work/SRC/openSUSE:Factory/skelcd-control-MicroOS/skelcd-control-MicroOS.changes
2019-06-18 14:54:42.257466483 +0200
+++ 
/work/SRC/openSUSE:Factory/.skelcd-control-MicroOS.new.4126/skelcd-control-MicroOS.changes
  2019-07-23 22:32:51.359027373 +0200
@@ -1,0 +2,6 @@
+Wed Jun 19 13:55:23 UTC 2019 - Richard Brown 
+
+- Add /boot/writable subvolume [boo#1138725]
+- 20190619
+
+---

Old:

  skelcd-control-MicroOS-20190613.tar.bz2

New:

  skelcd-control-MicroOS-20190619.tar.bz2



Other differences:
--
++ skelcd-control-MicroOS.spec ++
--- /var/tmp/diff_new_pack.stfIlH/_old  2019-07-23 22:32:51.759027291 +0200
+++ /var/tmp/diff_new_pack.stfIlH/_new  2019-07-23 22:32:51.763027290 +0200
@@ -117,7 +117,7 @@
 
 Url:https://github.com/yast/skelcd-control-MicroOS
 AutoReqProv:off
-Version:20190613
+Version:20190619
 Release:0
 Summary:The MicroOS control file needed for installation
 License:MIT

++ skelcd-control-MicroOS-20190613.tar.bz2 -> 
skelcd-control-MicroOS-20190619.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/skelcd-control-MicroOS-20190613/control/control.MicroOS.xml 
new/skelcd-control-MicroOS-20190619/control/control.MicroOS.xml
--- old/skelcd-control-MicroOS-20190613/control/control.MicroOS.xml 
2019-06-14 14:51:09.0 +0200
+++ new/skelcd-control-MicroOS-20190619/control/control.MicroOS.xml 
2019-07-19 14:44:22.0 +0200
@@ -162,6 +162,9 @@
 
 srv
 
+   
+   boot/writable
+
 
 
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/skelcd-control-MicroOS-20190613/package/skelcd-control-MicroOS.changes 
new/skelcd-control-MicroOS-20190619/package/skelcd-control-MicroOS.changes
--- old/skelcd-control-MicroOS-20190613/package/skelcd-control-MicroOS.changes  
2019-06-14 14:51:09.0 +0200
+++ new/skelcd-control-MicroOS-20190619/package/skelcd-control-MicroOS.changes  
2019-07-19 14:44:22.0 +0200
@@ -1,4 +1,10 @@
 ---
+Wed Jun 19 13:55:23 UTC 2019 - Richard Brown 
+
+- Add /boot/writable subvolume [boo#1138725]
+- 20190619
+
+---
 Thu Jun 13 14:57:51 UTC 2019 - Richard Brown 
 
 - Add srv as a subvolume [boo#1132436]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/skelcd-control-MicroOS-20190613/package/skelcd-control-MicroOS.spec 
new/skelcd-control-MicroOS-20190619/package/skelcd-control-MicroOS.spec
--- old/skelcd-control-MicroOS-20190613/package/skelcd-control-MicroOS.spec 
2019-06-14 14:51:09.0 +0200
+++ new/skelcd-control-MicroOS-20190619/package/skelcd-control-MicroOS.spec 
2019-07-19 14:44:22.0 +0200
@@ -117,7 +117,7 @@
 
 Url:https://github.com/yast/skelcd-control-MicroOS
 AutoReqProv:off
-Version:20190613
+Version:20190619
 Release:0
 Summary:The MicroOS control file needed for installation
 License:MIT




commit libkleo for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package libkleo for openSUSE:Factory checked 
in at 2019-07-23 22:32:05

Comparing /work/SRC/openSUSE:Factory/libkleo (Old)
 and  /work/SRC/openSUSE:Factory/.libkleo.new.4126 (New)


Package is "libkleo"

Tue Jul 23 22:32:05 2019 rev:42 rq:716743 version:19.04.3

Changes:

--- /work/SRC/openSUSE:Factory/libkleo/libkleo.changes  2019-07-16 
08:35:39.759379944 +0200
+++ /work/SRC/openSUSE:Factory/.libkleo.new.4126/libkleo.changes
2019-07-23 22:32:06.715036588 +0200
@@ -1,0 +2,5 @@
+Thu Jul 18 21:37:42 UTC 2019 - Stefan Brüns 
+
+- Use kf5_debugdir macro for specifying the logging categories location
+
+---



Other differences:
--
++ libkleo.spec ++
--- /var/tmp/diff_new_pack.JbUrV9/_old  2019-07-23 22:32:07.319036463 +0200
+++ /var/tmp/diff_new_pack.JbUrV9/_new  2019-07-23 22:32:07.327036461 +0200
@@ -106,8 +106,8 @@
 
 %files
 %config %{_kf5_configdir}/libkleopatrarc
-%config %{_kf5_configdir}/libkleo.categories
-%config %{_kf5_configdir}/libkleo.renamecategories
+%{_kf5_debugdir}/libkleo.categories
+%{_kf5_debugdir}/libkleo.renamecategories
 %{_kf5_sharedir}/libkleopatra/
 
 %files -n libKF5Libkleo5




commit libkgapi for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package libkgapi for openSUSE:Factory 
checked in at 2019-07-23 22:31:53

Comparing /work/SRC/openSUSE:Factory/libkgapi (Old)
 and  /work/SRC/openSUSE:Factory/.libkgapi.new.4126 (New)


Package is "libkgapi"

Tue Jul 23 22:31:53 2019 rev:49 rq:716742 version:19.04.3

Changes:

--- /work/SRC/openSUSE:Factory/libkgapi/libkgapi.changes2019-07-16 
08:35:28.515381767 +0200
+++ /work/SRC/openSUSE:Factory/.libkgapi.new.4126/libkgapi.changes  
2019-07-23 22:31:54.383038984 +0200
@@ -1,0 +2,5 @@
+Thu Jul 18 21:36:53 UTC 2019 - Stefan Brüns 
+
+- Use kf5_debugdir macro for specifying the logging categories location
+
+---



Other differences:
--
++ libkgapi.spec ++
--- /var/tmp/diff_new_pack.sXaQk3/_old  2019-07-23 22:31:54.931038903 +0200
+++ /var/tmp/diff_new_pack.sXaQk3/_new  2019-07-23 22:31:54.939038903 +0200
@@ -192,7 +192,7 @@
 %files -n libKPimGAPICore5
 %license LICENSE
 %{_kf5_libdir}/libKPimGAPICore.so.*
-%config %{_kf5_configdir}/libkgapi.categories
+%{_kf5_debugdir}/libkgapi.categories
 
 %files -n libKPimGAPIDrive5
 %license LICENSE




commit java-1_8_0-openjdk for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package java-1_8_0-openjdk for 
openSUSE:Factory checked in at 2019-07-23 22:31:30

Comparing /work/SRC/openSUSE:Factory/java-1_8_0-openjdk (Old)
 and  /work/SRC/openSUSE:Factory/.java-1_8_0-openjdk.new.4126 (New)


Package is "java-1_8_0-openjdk"

Tue Jul 23 22:31:30 2019 rev:65 rq:716731 version:1.8.0.222

Changes:

--- /work/SRC/openSUSE:Factory/java-1_8_0-openjdk/java-1_8_0-openjdk.changes
2019-07-08 15:00:49.810516883 +0200
+++ 
/work/SRC/openSUSE:Factory/.java-1_8_0-openjdk.new.4126/java-1_8_0-openjdk.changes
  2019-07-23 22:31:32.231042203 +0200
@@ -1,0 +2,556 @@
+Fri Jul 19 06:28:01 UTC 2019 - Fridrich Strba 
+
+- Update to version jdk8u222 (icedtea 3.13.0)
+  * Security fixes
++ S8191073: JpegImageReader throws IndexOutOfBoundsException
+  when trying to read image data from tables-only image
++ S8208698, CVE-2019-2745, bsc#1141784: Improved ECC
+  Implementation
++ S8212328, CVE-2019-2762, bsc#1141782: Exceptional throw cases
++ S8213431, CVE-2019-2766, bsc#1141789: Improve file protocol
+  handling
++ S8213432, CVE-2019-2769, bsc#1141783: Better copies of
+  CopiesList
++ S8216381, CVE-2019-2786, bsc#1141787: More limited privilege
+  usage
++ S8217563: Improve realm maintenance
++ S8218863: Better endpoint checks
++ S8218873: Improve JSSE endpoint checking
++ S8218876, CVE-2019-7317, bsc#1141780: Improve PNG support
+  options
++ S8219018: Adjust positions of glyphs
++ S8219020: Table alternate substitutions
++ S8219775: Certificate validation improvements
++ S8220192: Better outlook for SecureRandom
++ S8220517: Enhanced GIF support
++ S8221518, CVE-2019-2816, bsc#1141785: Normalize normalization
++ S8223511, CVE-2019-2842, bsc#1141786: Extended AES support
+  * New features
++ PR3743: Support EA builds
+  * Import of OpenJDK 8 u222 build 01
++ S8022879: TEST_BUG: sun/nio/cs/MalformedSurrogates.java
+  fails intermittently
++ S8025209: Intermittent test failure
+  java/net/Socket/asyncClose/AsyncClose.java
++ S8030690: TEST_BUG java/nio/Buffer/Chars.java fails
+  intermittently
++ S8031563: TEST_BUG:
+  java/nio/channels/Selector/ChangingInterests.java failed once
++ S8031666: TEST_BUG: java/net/ipv6tests/UdpTest.java failed
+  because of SocketTimeoutException
++ S8048782: OpenJDK: PiscesCache : xmax/ymax rounding up can
+  cause RasterFormatException
++ S8055814: [TESTBUG] runtime/NMT/NMTWithCDS.java fails with
+  product builds due to missing UnlockDiagnosticVMOptions
++ S8073078: java/nio/file/FileStore/Basic.java sensitive to
+  NFS configuration
++ S8129988: JSSE should create a single instance of the
+  cacerts KeyStore
++ S8137231: sun/security/rsa/SpecTest.java timeout with Agent
+  error: java.lang.Exception
++ S8150013: ParNew: Prune nmethods scavengable list.
++ S8151225: Mark SpecTest.java as intermittently failing
++ S8154156: PPC64: improve array copy stubs by using vector
+  instructions
++ S8156035: Remove intermittent key from
+  sun/security/rsa/SpecTest.java
++ S8157287: java/nio/file/FileStore/Basic.java failed with
+  "java.nio.file.AccessDeniedException : /zones/zoneone/root "
++ S8192854: FONTCONFIG_CFLAGS missing from spec.gmk.in
++ S8202768: [macos] Appkit thread slows when any Window
+  Manager active
++ S8203627: Swing applications with JRadioButton and JCheckbox
+  fail to render correctly when using GTK3 and the GTK L
++ S8205916: [test] Fix jdk/tools/launcher/RunpathTest to
+  handle both, RPATH and RUNPATH
++ S8206955: MethodHandleProxies.asInterfaceInstance does not
+  support default methods
++ S8207760: SAXException: Invalid UTF-16 surrogate detected:
+  d83c ?
++ S8209951: Problematic sparc intrinsic:
+  com.sun.crypto.provider.CipherBlockChaining
++ S8213825: assert(false) failed: Non-balanced monitor
+  enter/exit! Likely JNI locking
++ S8214109: XToolkit is not correctly displayed color on
+  16-bit high color setting
++ S8214111: There is no icon in all JOptionPane target image
++ S8214112: The whole text in target JPasswordField image are
+  not selected
++ S8214252: Expanded & Collapsed nodes of a JTree look the
+  same on GTK3
++ S8214253: Tooltip is transparent rather than having a black
+  background
++ S8217263: Automate DashOffset test
++ S8217597: [TESTBUG] old version docker does not support
+  --cpus
++ S8218469: JSlider display issue with slider for
+  GTKLookAndFeel
++ S8218470: JScrollBar display issue with GTKLookAndFeel
++ S8218472: JProgressBar display issue with GTKLookAndFeel
++ S8218473: 

commit libkdepim for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package libkdepim for openSUSE:Factory 
checked in at 2019-07-23 22:31:43

Comparing /work/SRC/openSUSE:Factory/libkdepim (Old)
 and  /work/SRC/openSUSE:Factory/.libkdepim.new.4126 (New)


Package is "libkdepim"

Tue Jul 23 22:31:43 2019 rev:42 rq:716741 version:19.04.3

Changes:

--- /work/SRC/openSUSE:Factory/libkdepim/libkdepim.changes  2019-07-16 
08:35:16.627383693 +0200
+++ /work/SRC/openSUSE:Factory/.libkdepim.new.4126/libkdepim.changes
2019-07-23 22:31:44.415040432 +0200
@@ -1,0 +2,5 @@
+Thu Jul 18 21:51:47 UTC 2019 - Stefan Brüns 
+
+- Use kf5_debugdir macro for specifying the logging categories location
+
+---



Other differences:
--
++ libkdepim.spec ++
--- /var/tmp/diff_new_pack.qX8fqm/_old  2019-07-23 22:31:44.871040365 +0200
+++ /var/tmp/diff_new_pack.qX8fqm/_new  2019-07-23 22:31:44.875040365 +0200
@@ -131,8 +131,8 @@
 
 %files
 %license COPYING*
-%config %{_kf5_configdir}/libkdepim.categories
-%config %{_kf5_configdir}/libkdepim.renamecategories
+%{_kf5_debugdir}/libkdepim.categories
+%{_kf5_debugdir}/libkdepim.renamecategories
 %{_kf5_dbusinterfacesdir}/org.kde.addressbook.service.xml
 %{_kf5_dbusinterfacesdir}/org.kde.mailtransport.service.xml
 %{_kf5_plugindir}/designer/




commit libuv for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package libuv for openSUSE:Factory checked 
in at 2019-07-23 22:31:12

Comparing /work/SRC/openSUSE:Factory/libuv (Old)
 and  /work/SRC/openSUSE:Factory/.libuv.new.4126 (New)


Package is "libuv"

Tue Jul 23 22:31:12 2019 rev:16 rq:713849 version:1.30.1

Changes:

--- /work/SRC/openSUSE:Factory/libuv/libuv.changes  2019-04-04 
12:02:19.293357982 +0200
+++ /work/SRC/openSUSE:Factory/.libuv.new.4126/libuv.changes2019-07-23 
22:31:13.651044903 +0200
@@ -1,0 +2,66 @@
+Wed Jul  3 08:28:41 CEST 2019 - Matej Cepl 
+
+- Upgrade to 1.30.1:
+  * doc: fix incorrect versionchanged (cjihrig)
+  * test: allow UV_ECONNRESET in tcp_try_write_error (cjihrig)
+  * unix: add uv_get_constrained_memory() cygwin stub (cjihrig)
+  * build: fix android cmake build (Ben Noordhuis)
+  * unix: squelch -Wcast-function-type warning (Ben Noordhuis)
+  * build: fix compile error with uClibc (zlargon)* darwin: fall
+back to F_BARRIERFSYNC (Ben Noordhuis)
+  * darwin: add 32 bit close$NOCANCEL implementation
+(ken-cunningham-webuse)
+  * build, core, unix: add support for Haiku (Leorize)
+  * darwin,linux: more conservative minimum stack size (Ben Noordhuis)
+  * threadpool: increase UV_THREADPOOL_SIZE limit (Vlad A)
+  * unix: return actual error from `uv_try_write()` (Anna Henningsen)
+  * darwin: fix build error with macos 10.10 (Ben Noordhuis)
+  * unix: make uv_cwd() report UV_ENOBUFS (Ben Noordhuis)
+  * unix: make uv_fs_read() fill all buffers (Ben Noordhuis)
+  * test: give hrtime test a custom 10s timeout (Ben Noordhuis)
+  * fs: fix uv_fs_copyfile if same src and dst (Santiago Gimeno)
+  * build: add cmake option to skip building tests (Niels Lohmann)
+  * doc: add link to nodejs.org (Jenil Christo)
+  * unix: fix a comment typo in signal.c (Evgeny Ermakov)
+  * unix: remove redundant cast in process.c (gengjiawen)
+  * doc: fix wrong mutex function prototypes (Leo Chung)
+  * unix: simplify uv/posix.h include logic (cjihrig)
+  * test: increase test timeout (cjihrig)
+  * linux: fix sscanf() overflows reading from /proc (Ben Noordhuis)
+  * ibmi: read memory and CPU usage info (Xu Meng)
+  * doc: update the cmake testing instruction (zlargon)
+  * unix: fix race condition in uv_async_send() (Ben Noordhuis)
+  * linux: use O_CLOEXEC instead of EPOLL_CLOEXEC (Ben Noordhuis)
+  * doc: mark uv_async_send() as async-signal-safe (Ben Noordhuis)
+  * linux: init st_flags and st_gen when using statx (Oscar Waddell)
+  * linux: read free/total memory from /proc/meminfo (Ben Noordhuis)
+  * test: test zero-sized uv_fs_sendfile() writes (Ben Noordhuis)
+  * unix: don't assert on UV_PROCESS_WINDOWS_* flags (Ben Noordhuis)
+  * linux: set correct mac address for IP-aliases (Santiago Gimeno)
+  * win,util: fix null pointer dereferencing (Tobias Nießen)
+  * unix,win: fix `uv_fs_poll_stop()` when active (Anna Henningsen)
+  * doc: add missing uv_fs_type entries (Michele Caini)
+  * doc: fix build with sphinx 2.x (FX Coudert)
+  * unix: don't make statx system call on Android (George Zhao)
+  * unix: fix clang scan-build warning (Kyle Edwards)
+  * unix: fall back to kqueue on older macOS systems (ken-cunningham-webuse)
+  * unix,win: add uv_get_constrained_memory() (Kelvin Jin)
+  * darwin: fix thread cancellation fd leak (Ben Noordhuis)
+  * linux: fix thread cancellation fd leak (Ben Noordhuis)
+  * unix,win: add uv_gettimeofday() (cjihrig)
+  * unix,win: add uv_fs_{open,read,close}dir() (cjihrig)
+  * unix: fix uv_interface_addresses() (Andreas Rohner)
+  * fs: remove macOS-specific copyfile(3) (Rich Trott)
+  * fs: add test for copyfile() respecting permissions (Rich Trott)
+  * build: partially revert 5234b1c (Ben Noordhuis)
+  * zos: fix setsockopt error when using AF_UNIX (Milad Farazmand)
+  * unix: suppress EINTR/EINPROGRESS in uv_fs_close() (Ben Noordhuis)
+  * build: use cmake APPLE variable to detect platform (zlargon)
+  * distcheck: remove duplicate test/ entry (Jameson Nash)
+  * unix: remove unused cmpxchgl() function (Ben Noordhuis)
+  * unix: support sockaddr_un in uv_udp_send() (Yury Selivanov)
+  * unix: guard use of PTHREAD_STACK_MIN (Kamil Rytarowski)
+  * unix,win: introduce uv_timeval64_t (cjihrig)
+  * doc: document uv_timeval_t and uv_timeval64_t (cjihrig)
+
+---

Old:

  libuv-1.27.0.tar.gz

New:

  libuv-1.30.1.tar.gz



Other differences:
--
++ libuv.spec ++
--- /var/tmp/diff_new_pack.2wldB6/_old  2019-07-23 22:31:15.207044676 +0200
+++ /var/tmp/diff_new_pack.2wldB6/_new  2019-07-23 22:31:15.255044670 +0200
@@ -18,7 +18,7 @@
 
 %define somajor 1
 Name:   libuv
-Version:1.27.0
+Version:1.30.1
 Release:

commit linuxrc for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package linuxrc for openSUSE:Factory checked 
in at 2019-07-23 22:28:21

Comparing /work/SRC/openSUSE:Factory/linuxrc (Old)
 and  /work/SRC/openSUSE:Factory/.linuxrc.new.4126 (New)


Package is "linuxrc"

Tue Jul 23 22:28:21 2019 rev:271 rq:716803 version:6.0.13

Changes:

--- /work/SRC/openSUSE:Factory/linuxrc/linuxrc.changes  2019-06-12 
13:04:41.685224031 +0200
+++ /work/SRC/openSUSE:Factory/.linuxrc.new.4126/linuxrc.changes
2019-07-23 22:28:22.599069761 +0200
@@ -1,0 +2,17 @@
+Fri Jul 19 08:47:42 UTC 2019 - lsle...@suse.cz
+
+- merge gh#openSUSE/linuxrc#192
+- Added support for a multi-repository installation medium
+  (bsc#1141889)
+- Travis CI: Use the Docker image from OBS
+- Updated linuxrc_repo.md documentation
+- 6.0.13
+
+
+Wed Jul 17 13:56:13 UTC 2019 - shundham...@suse.de
+
+- merge gh#openSUSE/linuxrc#191
+- Disable MD/RAID auto-assembly by default (bsc#1132688)
+- 6.0.12
+
+

Old:

  linuxrc-6.0.11.tar.xz

New:

  linuxrc-6.0.13.tar.xz



Other differences:
--
++ linuxrc.spec ++
--- /var/tmp/diff_new_pack.xObA9a/_old  2019-07-23 22:28:23.091069690 +0200
+++ /var/tmp/diff_new_pack.xObA9a/_new  2019-07-23 22:28:23.091069690 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   linuxrc
-Version:6.0.11
+Version:6.0.13
 Release:0
 Summary:SUSE Installation Program
 License:GPL-3.0+

++ linuxrc-6.0.11.tar.xz -> linuxrc-6.0.13.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/linuxrc-6.0.11/Dockerfile 
new/linuxrc-6.0.13/Dockerfile
--- old/linuxrc-6.0.11/Dockerfile   2019-05-29 16:10:51.0 +0200
+++ new/linuxrc-6.0.13/Dockerfile   2019-07-19 10:47:42.0 +0200
@@ -1,4 +1,4 @@
-FROM yastdevel/cpp
+FROM registry.opensuse.org/yast/head/containers/yast-cpp:latest
 
 RUN zypper --non-interactive in --no-recommends \
   e2fsprogs-devel \
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/linuxrc-6.0.11/VERSION new/linuxrc-6.0.13/VERSION
--- old/linuxrc-6.0.11/VERSION  2019-05-29 16:10:51.0 +0200
+++ new/linuxrc-6.0.13/VERSION  2019-07-19 10:47:42.0 +0200
@@ -1 +1 @@
-6.0.11
+6.0.13
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/linuxrc-6.0.11/changelog new/linuxrc-6.0.13/changelog
--- old/linuxrc-6.0.11/changelog2019-05-29 16:10:51.0 +0200
+++ new/linuxrc-6.0.13/changelog2019-07-19 10:47:42.0 +0200
@@ -1,3 +1,14 @@
+2019-07-19:6.0.13
+   - merge gh#openSUSE/linuxrc#192
+   - Added support for a multi-repository installation medium
+ (bsc#1141889)
+   - Travis CI: Use the Docker image from OBS
+   - Updated linuxrc_repo.md documentation
+
+2019-07-17:6.0.12
+   - merge gh#openSUSE/linuxrc#191
+   - Disable MD/RAID auto-assembly by default (bsc#1132688)
+
 2019-05-29:6.0.11
- merge gh#openSUSE/linuxrc#189
- iterate through device list in sorted order (bsc#1058039)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/linuxrc-6.0.11/linuxrc.c new/linuxrc-6.0.13/linuxrc.c
--- old/linuxrc-6.0.11/linuxrc.c2019-05-29 16:10:51.0 +0200
+++ new/linuxrc-6.0.13/linuxrc.c2019-07-19 10:47:42.0 +0200
@@ -800,7 +800,7 @@
   config.udev_mods = 1;
   config.devtmpfs = 1;
   config.kexec = 2;/* kexec if necessary, with user dialog */
-  config.auto_assembly = 1;/* default to allow MD/RAID auto-assembly for 
now (bsc#1132688) */
+  config.auto_assembly = 0;/* default to disable MD/RAID auto-assembly 
(bsc#1132688) */
 
   // defaults for self-update feature
   config.self_update_url = NULL;
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/linuxrc-6.0.11/linuxrc_repo.md 
new/linuxrc-6.0.13/linuxrc_repo.md
--- old/linuxrc-6.0.11/linuxrc_repo.md  2019-05-29 16:10:51.0 +0200
+++ new/linuxrc-6.0.13/linuxrc_repo.md  2019-07-19 10:47:42.0 +0200
@@ -1,9 +1,12 @@
 # specifying installation repositories in linuxrc
 
-## 1. regular install media
+## 1. SUSE tags install media
 
 *(repo meta data are in /suse/setup/descr/)*
 
+:warning: *Note: This is obsolete since SLE15/openSUSE Leap 15, the newer
+products use the repomd repositories on the installation media, see below.*
+
 linuxrc identifies this repo by checking for a file '/content' in the
 installation repository. The file must have a valid signature
 ('/content.asc'). 

commit open-iscsi for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package open-iscsi for openSUSE:Factory 
checked in at 2019-07-23 22:28:05

Comparing /work/SRC/openSUSE:Factory/open-iscsi (Old)
 and  /work/SRC/openSUSE:Factory/.open-iscsi.new.4126 (New)


Package is "open-iscsi"

Tue Jul 23 22:28:05 2019 rev:83 rq:716094 version:unknown

Changes:

--- /work/SRC/openSUSE:Factory/open-iscsi/open-iscsi.changes2019-07-13 
13:58:58.662924038 +0200
+++ /work/SRC/openSUSE:Factory/.open-iscsi.new.4126/open-iscsi.changes  
2019-07-23 22:28:05.423072257 +0200
@@ -1,0 +2,7 @@
+Wed Jul 17 11:58:21 UTC 2019 - Bernhard Wiedemann 
+
+- Ensure /etc/iscsi/initiatorname.iscsi has reproducible size
+  works around https://github.com/rpm-software-management/rpm/pull/229,
+  updating the SPEC file
+
+---



Other differences:
--
++ open-iscsi.spec ++
--- /var/tmp/diff_new_pack.AyiVQB/_old  2019-07-23 22:28:06.007072172 +0200
+++ /var/tmp/diff_new_pack.AyiVQB/_new  2019-07-23 22:28:06.011072172 +0200
@@ -128,7 +128,7 @@
 ln -s %{_sbindir}/service %{buildroot}%{_sbindir}/rciscsid
 ln -s %{_sbindir}/service %{buildroot}%{_sbindir}/rciscsiuio
 (cd %{buildroot}/etc; ln -sf iscsi/iscsid.conf iscsid.conf)
-touch %{buildroot}%{_sysconfdir}/iscsi/initiatorname.iscsi
+echo > %{buildroot}%{_sysconfdir}/iscsi/initiatorname.iscsi
 install -m 0755 usr/iscsistart %{buildroot}/sbin
 %make_install -C iscsiuio
 # rename iscsiuio logrotate file to proper name




commit rpmlint for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package rpmlint for openSUSE:Factory checked 
in at 2019-07-23 22:27:55

Comparing /work/SRC/openSUSE:Factory/rpmlint (Old)
 and  /work/SRC/openSUSE:Factory/.rpmlint.new.4126 (New)


Package is "rpmlint"

Tue Jul 23 22:27:55 2019 rev:320 rq:716085 version:1.11

Changes:

--- /work/SRC/openSUSE:Factory/rpmlint/rpmlint-tests.changes2019-03-27 
16:11:35.927664548 +0100
+++ /work/SRC/openSUSE:Factory/.rpmlint.new.4126/rpmlint-tests.changes  
2019-07-23 22:27:56.159073603 +0200
@@ -1,0 +2,6 @@
+Wed Jul 17 14:51:58 UTC 2019 - jseg...@suse.de
+
+- Update to version 84.87+git20190717.48212cf:
+  * added LTO errors as expected for debug tests
+
+---

Old:

  rpmlint-tests-84.87+git20190318.caf1835.tar.xz

New:

  rpmlint-tests-84.87+git20190717.48212cf.tar.xz



Other differences:
--
++ rpmlint-tests.spec ++
--- /var/tmp/diff_new_pack.L9PKGk/_old  2019-07-23 22:27:58.103073321 +0200
+++ /var/tmp/diff_new_pack.L9PKGk/_new  2019-07-23 22:27:58.107073320 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 # icecream 0
 
@@ -24,7 +24,7 @@
 BuildRequires:  rpmlint-mini
 
 Name:   rpmlint-tests
-Version:84.87+git20190318.caf1835
+Version:84.87+git20190717.48212cf
 Release:0
 Summary:rpmlint regression tests
 License:SUSE-Public-Domain

++ rpmlint.spec ++
--- /var/tmp/diff_new_pack.L9PKGk/_old  2019-07-23 22:27:58.127073317 +0200
+++ /var/tmp/diff_new_pack.L9PKGk/_new  2019-07-23 22:27:58.131073316 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 

++ _servicedata ++
--- /var/tmp/diff_new_pack.L9PKGk/_old  2019-07-23 22:27:58.231073302 +0200
+++ /var/tmp/diff_new_pack.L9PKGk/_new  2019-07-23 22:27:58.235073301 +0200
@@ -1,6 +1,6 @@
 
 
 https://github.com/openSUSE/rpmlint-tests.git
-  2fbd3ef0768256777b6cc68d686138f5e3968758
+  75524278ef7de3efc70f0fa14016f1aac4e77d36
 https://github.com/openSUSE/rpmlint-checks.git
   2d11e76027fc32be4005f955a71fab84c3a5407d
\ No newline at end of file

++ rpmlint-tests-84.87+git20190318.caf1835.tar.xz -> 
rpmlint-tests-84.87+git20190717.48212cf.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/rpmlint-tests-84.87+git20190318.caf1835/tests/debug.ref 
new/rpmlint-tests-84.87+git20190717.48212cf/tests/debug.ref
--- old/rpmlint-tests-84.87+git20190318.caf1835/tests/debug.ref 2019-03-18 
09:51:27.0 +0100
+++ new/rpmlint-tests-84.87+git20190717.48212cf/tests/debug.ref 2019-07-17 
16:41:37.0 +0200
@@ -2,4 +2,6 @@
 debug: W: static-library-without-symtab /usr/lib/foo/t2.a
 debug: E: devel-file-in-non-devel-package (Badness: 50) /usr/lib/foo/t.a
 debug: E: devel-file-in-non-devel-package (Badness: 50) /usr/lib/foo/t2.a
-1 packages and 0 specfiles checked; 2 errors, 2 warnings.
+debug: E: lto-bytecode (Badness: 1) /usr/lib/foo/t.a
+debug: E: lto-bytecode (Badness: 1) /usr/lib/foo/t2.a
+1 packages and 0 specfiles checked; 4 errors, 2 warnings.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/rpmlint-tests-84.87+git20190318.caf1835/tests/debug1.ref 
new/rpmlint-tests-84.87+git20190717.48212cf/tests/debug1.ref
--- old/rpmlint-tests-84.87+git20190318.caf1835/tests/debug1.ref
2019-03-18 09:51:27.0 +0100
+++ new/rpmlint-tests-84.87+git20190717.48212cf/tests/debug1.ref
2019-07-17 16:41:37.0 +0200
@@ -2,4 +2,6 @@
 debug1: W: static-library-without-symtab /usr/lib/foo/t2.a
 debug1: E: devel-file-in-non-devel-package (Badness: 50) /usr/lib/foo/t.a
 debug1: E: devel-file-in-non-devel-package (Badness: 50) /usr/lib/foo/t2.a
-1 packages and 0 specfiles checked; 2 errors, 2 warnings.
+debug1: E: lto-bytecode (Badness: 1) /usr/lib/foo/t.a
+debug1: E: lto-bytecode (Badness: 1) /usr/lib/foo/t2.a
+1 packages and 0 specfiles checked; 4 errors, 2 warnings.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/rpmlint-tests-84.87+git20190318.caf1835/tests/debug2.ref 
new/rpmlint-tests-84.87+git20190717.48212cf/tests/debug2.ref
--- 

commit rubygem-cfa for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package rubygem-cfa for openSUSE:Factory 
checked in at 2019-07-23 22:27:41

Comparing /work/SRC/openSUSE:Factory/rubygem-cfa (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-cfa.new.4126 (New)


Package is "rubygem-cfa"

Tue Jul 23 22:27:41 2019 rev:12 rq:716079 version:1.0.1

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-cfa/rubygem-cfa.changes  2019-06-25 
22:17:38.752738287 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-cfa.new.4126/rubygem-cfa.changes
2019-07-23 22:27:42.499075588 +0200
@@ -1,0 +2,7 @@
+Wed Jul 17 06:25:41 UTC 2019 - Josef Reidinger 
+
+- fix writting subtree when element change to collection and vice
+  versa (bsc#1132362)
+- 1.0.1
+
+---

Old:

  cfa-1.0.0.gem

New:

  cfa-1.0.1.gem



Other differences:
--
++ rubygem-cfa.spec ++
--- /var/tmp/diff_new_pack.r0lgdU/_old  2019-07-23 22:27:43.219075484 +0200
+++ /var/tmp/diff_new_pack.r0lgdU/_new  2019-07-23 22:27:43.219075484 +0200
@@ -12,12 +12,12 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   rubygem-cfa
-Version:1.0.0
+Version:1.0.1
 Release:0
 %define mod_name cfa
 %define mod_full_name %{mod_name}-%{version}

++ cfa-1.0.0.gem -> cfa-1.0.1.gem ++
Binary files old/checksums.yaml.gz and new/checksums.yaml.gz differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/cfa/augeas_parser/writer.rb 
new/lib/cfa/augeas_parser/writer.rb
--- old/lib/cfa/augeas_parser/writer.rb 2019-06-21 10:23:49.0 +0200
+++ new/lib/cfa/augeas_parser/writer.rb 2019-07-17 09:25:50.0 +0200
@@ -301,12 +301,35 @@
   # @param preceding [LocatedEntry]
   def path_after(preceding)
 paths = aug.match(preceding.prefix + "/*")
-preceding_index = paths.index(preceding.path)
-# it can happen, that insertion change previous entry from
-# e.g. #comment to #comment[1]. Can happen only if it switch from
-# single entry to collection
-preceding_index ||= paths.index(preceding.path + "[1]")
-paths[preceding_index + 1]
+paths[find_preceding_index(paths, preceding) + 1]
+  end
+
+  def find_preceding_index(paths, preceding)
+path = preceding.path
+# common case, just included
+return paths.index(path) if paths.include?(path)
+
+# not found, so it means that some collection or single entry switch
+new_path = +"/"
+path.split("/").each do |element|
+  new_path << "/" unless new_path.end_with?("/")
+  new_path << pick_candidate(paths, new_path, element)
+end
+
+paths.index(new_path) ||
+  raise("Cannot find path #{preceding.path} in #{paths.inspect}")
+  end
+
+  # it returns variant of element that exists in path
+  def pick_candidate(paths, new_path, element)
+# NOTE: order here is important due to early matching
+candidates = [element + "/", element + "[1]",
+  element.sub(/\[\d+\]/, ""), element]
+paths.each do |p|
+  candidates.each do |c|
+return c if p.start_with?(new_path + c)
+  end
+end
   end
 end
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/metadata new/metadata
--- old/metadata2019-06-21 10:27:02.0 +0200
+++ new/metadata2019-07-17 09:26:11.0 +0200
@@ -1,14 +1,14 @@
 --- !ruby/object:Gem::Specification
 name: cfa
 version: !ruby/object:Gem::Version
-  version: 1.0.0
+  version: 1.0.1
 platform: ruby
 authors:
 - Josef Reidinger
 autorequire: 
 bindir: bin
 cert_chain: []
-date: 2019-06-21 00:00:00.0 Z
+date: 2019-07-17 00:00:00.0 Z
 dependencies:
 - !ruby/object:Gem::Dependency
   name: ruby-augeas




commit 000update-repos for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-07-23 21:08:26

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.4126 (New)


Package is "000update-repos"

Tue Jul 23 21:08:26 2019 rev:425 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.1:update_1563884838.packages.xz



Other differences:
--




















































































































































































































































































































































































































































































































































































































commit 000update-repos for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-07-23 21:08:23

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.4126 (New)


Package is "000update-repos"

Tue Jul 23 21:08:23 2019 rev:424 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.0:update_1563884099.packages.xz



Other differences:
--



















































































































































































































































































































































































































































































































































































































commit 000release-packages for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package 000release-packages for 
openSUSE:Factory checked in at 2019-07-23 12:17:18

Comparing /work/SRC/openSUSE:Factory/000release-packages (Old)
 and  /work/SRC/openSUSE:Factory/.000release-packages.new.4126 (New)


Package is "000release-packages"

Tue Jul 23 12:17:18 2019 rev:207 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-release.spec: same change
openSUSE-release.spec: same change
stub.spec: same change
++ weakremovers.inc ++
--- /var/tmp/diff_new_pack.kBpme2/_old  2019-07-23 12:17:20.899732585 +0200
+++ /var/tmp/diff_new_pack.kBpme2/_new  2019-07-23 12:17:20.903732585 +0200
@@ -13566,7 +13566,6 @@
 Provides: weakremover(libdbi-drivers-dbd-sqlite)
 Provides: weakremover(libdbus-1-qt3-0)
 Provides: weakremover(libdbus-1-qt3-0-devel)
-Provides: weakremover(libdc1394-22)
 Provides: weakremover(libdframeworkdbus1)
 Provides: weakremover(libdialog14)
 Provides: weakremover(libdico1)
@@ -21005,7 +21004,6 @@
 Provides: weakremover(libdb-4_5-32bit)
 Provides: weakremover(libdb-4_5-devel-32bit)
 Provides: weakremover(libdbus-1-qt3-0-32bit)
-Provides: weakremover(libdc1394-22-32bit)
 Provides: weakremover(libdm0-32bit)
 Provides: weakremover(libdns165-32bit)
 Provides: weakremover(libdouble-conversion1-32bit)




commit 000product for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-07-23 12:17:21

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.4126 (New)


Package is "000product"

Tue Jul 23 12:17:21 2019 rev:1443 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi: same change
openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
openSUSE-cd-mini-i586.kiwi: same change
openSUSE-cd-mini-x86_64.kiwi: same change
++ openSUSE-dvd5-dvd-i586.kiwi ++
--- /var/tmp/diff_new_pack.SdcRvl/_old  2019-07-23 12:17:23.819731972 +0200
+++ /var/tmp/diff_new_pack.SdcRvl/_new  2019-07-23 12:17:23.819731972 +0200
@@ -684,7 +684,7 @@
   
   
   
-  
+  
   
   
   
@@ -1463,7 +1463,7 @@
   
   
   
-  
+  
   
   
   
@@ -1530,7 +1530,7 @@
   
   
   
-  
+  
   
   
   
@@ -1611,7 +1611,7 @@
   
   
   
-  
+  
   
   
   
@@ -1662,7 +1662,7 @@
   
   
   
-  
+  
   
   
   
@@ -1691,14 +1691,14 @@
   
   
   
-  
-  
+  
+  
   
   
   
   
   
-  
+  
   
   
   
@@ -1906,7 +1906,7 @@
   
   
   
-  
+  
   
   
   
@@ -2035,7 +2035,7 @@
   
   
   
-  
+  
   
   
   
@@ -2286,7 +2286,7 @@
   
   
   
-  
+  
   
   
   
@@ -2320,7 +2320,7 @@
   
   
   
-  
+  
   
   
   
@@ -2428,7 +2428,7 @@
   
   
   
-  
+  
   
   
   
@@ -2517,9 +2517,9 @@
   
   
   
-  
+  
   
-  
+  
   
   
   
@@ -2716,7 +2716,7 @@
   
   
   
-  
+  
   
   
   
@@ -2816,7 +2816,7 @@
   
   
   
-  
+  
   
   
   
@@ -2862,11 +2862,11 @@
   
   
   
-  
+  
   
   
   
-  
+  
   
   
   
@@ -2883,7 +2883,7 @@
   
   
   
-  
+  
   
   
   
@@ -2920,8 +2920,8 @@
   
   
   
-  
-  
+  
+  
   
   
   
@@ -5249,12 +5249,12 @@
   
   
   
-  
-  
-  
-  
-  
-  
+  
+  
+  
+  
+  
+  
   
   
   

++ openSUSE-dvd5-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.SdcRvl/_old  2019-07-23 12:17:23.843731967 +0200
+++ /var/tmp/diff_new_pack.SdcRvl/_new  2019-07-23 12:17:23.847731967 +0200
@@ -704,6 +704,7 @@
   
   
   
+  
   
   
   
@@ -1497,6 +1498,7 @@
   
   
   
+  
   
   
   
@@ -1571,6 +1573,7 @@
   
   
   
+  
   
   
   
@@ -1661,6 +1664,7 @@
   
   
   
+  
   
   
   
@@ -1722,7 +1726,7 @@
   
   
   
-  
+  
   
   
   
@@ -1754,11 +1758,14 @@
   
   
   
+  
+  
   
   
   
   
   
+  
   
   
   
@@ -1986,6 +1993,7 @@
   
   
   
+  
   
   
   
@@ -2124,6 +2132,7 @@
   
   
   
+  
   
   
   
@@ -2383,6 +2392,7 @@
   
   
   
+  
   
   
   
@@ -2421,6 +2431,7 @@
   
   
   
+  
   
   
   
@@ -2542,6 +2553,7 @@
   
   
   
+  
   
   
   
@@ -2640,7 +2652,9 @@
   
   
   
+  
   
+  
   
   
   
@@ -2851,6 +2865,7 @@
   
   
   
+  
   
   
   
@@ -2961,6 +2976,7 @@
   
   
   
+  
   
   
   
@@ -3015,9 +3031,11 @@
   
   
   
+  
   
   
   
+  
   
   
   
@@ -3035,6 +3053,7 @@
   
   
   
+  
   
   
   
@@ -3080,6 +3099,8 @@
   
   
   
+  
+  
   
   
   
@@ -5484,6 +5505,12 @@
   
   
   
+  
+  
+  
+  
+  
+  
   
   
   

stub.kiwi: same change
++ dvd.group ++
--- /var/tmp/diff_new_pack.SdcRvl/_old  2019-07-23 12:17:23.987731937 +0200
+++ /var/tmp/diff_new_pack.SdcRvl/_new  2019-07-23 12:17:23.991731936 +0200
@@ -682,6 +682,7 @@
  
  
  
+ 
  
  
  
@@ -1453,6 +1454,7 @@
  
  
  
+ 

  
  
  
@@ -1692,12 +1694,13 @@
  
  
  
- 
+ 
  
  
  
 

commit libdc1394 for openSUSE:Factory

2019-07-23 Thread root
Hello community,

here is the log from the commit of package libdc1394 for openSUSE:Factory 
checked in at 2019-07-23 08:39:20

Comparing /work/SRC/openSUSE:Factory/libdc1394 (Old)
 and  /work/SRC/openSUSE:Factory/.libdc1394.new.4126 (New)


Package is "libdc1394"

Tue Jul 23 08:39:20 2019 rev:48 rq: version:2.2.5

Changes:

--- /work/SRC/openSUSE:Factory/libdc1394/libdc1394.changes  2019-07-22 
12:15:47.719737826 +0200
+++ /work/SRC/openSUSE:Factory/.libdc1394.new.4126/libdc1394.changes
2019-07-23 08:39:22.143933823 +0200
@@ -2,8 +1,0 @@
-Sat Jul  6 13:34:52 UTC 2019 - Matwey V. Kornilov 
-
-- Update to 2.2.6:
-   - Fix a few compilation warnings with a recent GCC
-   - Fix argument type in dc1394_get_image_size_from_video_mode()
-   - Fix USB3 transfer errors
-


Old:

  libdc1394-2.2.6.tar.gz

New:

  libdc1394-2.2.5.tar.gz



Other differences:
--
++ libdc1394.spec ++
--- /var/tmp/diff_new_pack.JgEmpG/_old  2019-07-23 08:39:22.643933735 +0200
+++ /var/tmp/diff_new_pack.JgEmpG/_new  2019-07-23 08:39:22.643933735 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libdc1394
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,15 +12,15 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via https://bugs.opensuse.org/
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
 
 Name:   libdc1394
-Version:2.2.6
+Version:2.2.5
 Release:0
 Summary:1394-Based Digital Camera Control Library
-License:LGPL-2.1-or-later
+License:LGPL-2.1+
 Group:  Hardware/Camera
 Url:http://damien.douxchamps.net/ieee1394/libdc1394/
 Source0:
https://downloads.sourceforge.net/project/libdc1394/libdc1394-2/%{version}/%{name}-%{version}.tar.gz
@@ -54,11 +54,11 @@
 the low-level functionality provided by libraw1394 to communicate with
 the camera.
 
-%package 25
+%package 22
 Summary:1394-based Digital Camera Control library
 Group:  System/Libraries
 
-%description 25
+%description 22
 This library provides functionality for controlling any camera that
 conforms to the 1394-Based Digital Camera Specification (which can be
 found at 
http://www.1394ta.org/Download/Technology/Specifications/Camera120.pdf).
@@ -69,7 +69,7 @@
 Summary:Development libraries and header files for dc1394
 Group:  Development/Libraries/C and C++
 Requires:   %{name}-tools = %{version}
-Requires:   libdc1394-25 = %{version}
+Requires:   libdc1394-22 = %{version}
 Requires:   libraw1394-devel
 
 %description devel
@@ -109,9 +109,9 @@
 rm -f %{buildroot}%{_mandir}/man1/grab_*_image.1*
 find %{buildroot} -type f -name "*.la" -delete -print
 
-%post 25 -p /sbin/ldconfig
+%post 22 -p /sbin/ldconfig
 
-%postun 25 -p /sbin/ldconfig
+%postun 22 -p /sbin/ldconfig
 
 %files tools
 %defattr(-,root,root)
@@ -119,9 +119,9 @@
 %{_bindir}/dc1394_reset_bus
 %{_mandir}/man1/dc1394_reset_bus.1*
 
-%files 25
+%files 22
 %defattr(-,root,root)
-%{_libdir}/libdc1394.so.25*
+%{_libdir}/libdc1394.so.22*
 
 %files devel
 %defattr(-,root,root)

++ baselibs.conf ++
--- /var/tmp/diff_new_pack.JgEmpG/_old  2019-07-23 08:39:22.711933723 +0200
+++ /var/tmp/diff_new_pack.JgEmpG/_new  2019-07-23 08:39:22.711933723 +0200
@@ -1 +1 @@
-libdc1394-25
+libdc1394-22

++ libdc1394-2.2.6.tar.gz -> libdc1394-2.2.5.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libdc1394-2.2.6/AUTHORS new/libdc1394-2.2.5/AUTHORS
--- old/libdc1394-2.2.6/AUTHORS 2017-04-19 09:27:35.0 +0200
+++ new/libdc1394-2.2.5/AUTHORS 2016-12-22 09:29:16.0 +0100
@@ -21,7 +21,6 @@
 Tim Canham
 Jim Cassidy
 Paul Chavent
-Natanael Copa
 Hugo Costelha
 danalien
 Damien Delannay
@@ -106,5 +105,5 @@
 Thomas Woellert
 Jonathan Wonders
 Daniel Westhoff
-Michael Zahniser
 Boris Zingerman
+
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libdc1394-2.2.6/configure 
new/libdc1394-2.2.5/configure
--- old/libdc1394-2.2.6/configure   2019-04-28 02:36:21.0 +0200
+++ new/libdc1394-2.2.5/configure   2016-12-22 09:26:26.0 +0100
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for libdc1394 2.2.6.
+# Generated by GNU