commit 000product for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-09-13 22:03:37

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.7948 (New)


Package is "000product"

Fri Sep 13 22:03:37 2019 rev:1591 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ openSUSE-Addon-NonOss-ftp-ftp-i586_x86_64.kiwi ++
--- /var/tmp/diff_new_pack.R3nTJg/_old  2019-09-13 22:03:42.821578141 +0200
+++ /var/tmp/diff_new_pack.R3nTJg/_new  2019-09-13 22:03:42.821578141 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -36,11 +36,11 @@
   true
   -x -2
   openSUSE
-  20190911
+  20190913
   11
-  cpe:/o:opensuse:opensuse-addon-nonoss:20190911,openSUSE NonOSS 
Addon
+  cpe:/o:opensuse:opensuse-addon-nonoss:20190913,openSUSE NonOSS 
Addon
   af ar be_BY bg br ca cy el et ga gl gu_IN he 
hi_IN hr ka km ko lt mk nn pa_IN rw sk sl sr_CS ss st tg th tr uk ve vi xh zu 

-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190911/i586
 
obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190911/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190913/i586
 
obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190913/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.R3nTJg/_old  2019-09-13 22:03:42.837578138 +0200
+++ /var/tmp/diff_new_pack.R3nTJg/_new  2019-09-13 22:03:42.837578138 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20190911
+  20190913
   11
-  cpe:/o:opensuse:opensuse-microos:20190911,openSUSE 
MicroOS
+  cpe:/o:opensuse:opensuse-microos:20190913,openSUSE 
MicroOS
   en_US 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20190911/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20190913/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
++ openSUSE-cd-mini-i586.kiwi ++
--- /var/tmp/diff_new_pack.R3nTJg/_old  2019-09-13 22:03:42.873578132 +0200
+++ /var/tmp/diff_new_pack.R3nTJg/_new  2019-09-13 22:03:42.877578132 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,11 +32,11 @@
   true
   -x -2
   openSUSE
-  20190911
+  20190913
   11
-  cpe:/o:opensuse:opensuse:20190911,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20190913,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190911/i586
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190913/i586
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-cd-mini-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.R3nTJg/_old  2019-09-13 22:03:42.897578128 +0200
+++ /var/tmp/diff_new_pack.R3nTJg/_new  2019-09-13 22:03:42.897578128 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20190911
+  20190913
   11
-  cpe:/o:opensuse:opensuse:20190911,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20190913,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190911/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190913/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-dvd5-dvd-i586.kiwi ++
--- /var/tmp/diff_new_pack.R3nTJg/_old  2019-09-13 22:03:42.917578125 +0200
+++ /var/tmp/diff_new_pack.R3nTJg/_new  2019-09-13 22:03:42.921578124 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,11 +32,11 @@
   true
   -x -2
   openSUSE
-  20190911
+  20190913
   11
-  cpe:/o:opensuse:opensuse:20190911,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20190913,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  

commit 000release-packages for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package 000release-packages for 
openSUSE:Factory checked in at 2019-09-13 22:03:33

Comparing /work/SRC/openSUSE:Factory/000release-packages (Old)
 and  /work/SRC/openSUSE:Factory/.000release-packages.new.7948 (New)


Package is "000release-packages"

Fri Sep 13 22:03:33 2019 rev:252 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ openSUSE-Addon-NonOss-release.spec ++
--- /var/tmp/diff_new_pack.nAgCHM/_old  2019-09-13 22:03:36.189579226 +0200
+++ /var/tmp/diff_new_pack.nAgCHM/_new  2019-09-13 22:03:36.189579226 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package openSUSE-Addon-NonOss-release (Version 20190911)
+# spec file for package openSUSE-Addon-NonOss-release (Version 20190913)
 #
 # Copyright (c) 2019 openSUSE.
 #
@@ -16,16 +16,16 @@
 Name:   openSUSE-Addon-NonOss-release
 %define product openSUSE-Addon-NonOss
 Summary:openSUSE NonOSS Addon
-Version:20190911
+Version:    20190913
 Release:0
 License:BSD-3-Clause
 Group:  System/Fhs
 
 Provides:   %name-%version
 Provides:   product() = openSUSE-Addon-NonOss
-Provides:   product(openSUSE-Addon-NonOss) = 20190911-0
+Provides:   product(openSUSE-Addon-NonOss) = 20190913-0
 Provides:   product-label() = non%20oss%20addon
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Daddon%2Dnonoss%3A20190911
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Daddon%2Dnonoss%3A20190913
 
 
 AutoReqProv:on
@@ -49,10 +49,10 @@
 
   openSUSE
   openSUSE-Addon-NonOss
-  20190911
+  20190913
   0
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-addon-nonoss:20190911
+  cpe:/o:opensuse:opensuse-addon-nonoss:20190913
   
 
 

++ openSUSE-MicroOS-release.spec ++
--- /var/tmp/diff_new_pack.nAgCHM/_old  2019-09-13 22:03:36.213579222 +0200
+++ /var/tmp/diff_new_pack.nAgCHM/_new  2019-09-13 22:03:36.217579222 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   openSUSE-MicroOS-release
-Version:20190911
+Version:    20190913
 Release:0
 Summary:openSUSE MicroOS 
 License:GPL-2.0-or-later
@@ -43,9 +43,9 @@
 ExclusiveArch:  %ix86 x86_64 ppc64le s390x aarch64
 Provides:   %name-%version
 Provides:   product() = openSUSE-MicroOS
-Provides:   product(openSUSE-MicroOS) = 20190911-0
+Provides:   product(openSUSE-MicroOS) = 20190913-0
 Provides:   product-label() = openSUSE%20MicroOS
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dmicroos%3A20190911
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dmicroos%3A20190913
 Provides:   product-url(releasenotes) = 
http%3A%2F%2Fdoc.opensuse.org%2Frelease%2Dnotes%2Fx86_64%2FopenSUSE%2FTumbleweed%2Frelease%2Dnotes%2DopenSUSE.rpm
 Provides:   product-endoflife()
 Requires:   product_flavor(openSUSE-MicroOS)
@@ -61,7 +61,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(dvd)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190911-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190913-0
 Summary:openSUSE MicroOS
 
 %description dvd
@@ -77,7 +77,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(kubic-dvd)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190911-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190913-0
 Summary:openSUSE MicroOS
 
 %description kubic-dvd
@@ -93,7 +93,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(appliance)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190911-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190913-0
 Summary:openSUSE MicroOS
 
 %description appliance
@@ -109,7 +109,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(appliance-kubic)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190911-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190913-0
 Summary:openSUSE MicroOS
 
 %description appliance-kubic
@@ -167,11 +167,11 @@
 
   openSUSE
   openSUSE-MicroOS
-  20190911
+  20190913
   0
   
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-microos:20190911
+  cpe:/o:opensuse:opensuse-microos:20190913
   openSUSE-MicroOS
   
 

++ openSUSE-release.spec ++
--- /var/tmp/diff_new_pack.nAgCHM/_old  2019-09-13 22:03:36.237579219 +0200
+++ /var/tmp/diff_new_pack.nAgCHM/_new  2019-09-13 22:03:36.237579219 +0200
@@ -20,7 +20,7 @@
 #define betaversion %{nil}
 %define codename Tumbleweed
 Name:   openSUSE-release
-Version:20190911
+Version:    2019091

commit 000update-repos for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-09-13 21:04:44

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.7948 (New)


Package is "000update-repos"

Fri Sep 13 21:04:44 2019 rev:538 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.0:update_1568401359.packages.xz



Other differences:
--





































































































































































































































































































































































































































































































































































































































































































































commit 000product for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-09-13 15:03:58

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.7948 (New)


Package is "000product"

Fri Sep 13 15:03:58 2019 rev:1590 rq: version:unknown
Fri Sep 13 15:03:57 2019 rev:1589 rq: version:unknown
Fri Sep 13 15:03:55 2019 rev:1588 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi: same change
openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
openSUSE-cd-mini-i586.kiwi: same change
openSUSE-cd-mini-x86_64.kiwi: same change
openSUSE-dvd5-dvd-i586.kiwi: same change
openSUSE-dvd5-dvd-x86_64.kiwi: same change
openSUSE-ftp-ftp-i586_x86_64.kiwi: same change
stub.kiwi: same change
++ openSUSE-Addon-NonOss.product ++
--- /var/tmp/diff_new_pack.bekTUI/_old  2019-09-13 15:05:20.217256499 +0200
+++ /var/tmp/diff_new_pack.bekTUI/_new  2019-09-13 15:05:20.217256499 +0200
@@ -4,7 +4,7 @@
  
 openSUSE
 openSUSE-Addon-NonOss
-20190911
+    20190913
 0 
 openSUSE NonOSS Addon
 non oss addon

++ openSUSE-MicroOS.product ++
--- /var/tmp/diff_new_pack.bekTUI/_old  2019-09-13 15:05:20.237256495 +0200
+++ /var/tmp/diff_new_pack.bekTUI/_new  2019-09-13 15:05:20.237256495 +0200
@@ -6,7 +6,7 @@
   openSUSE-MicroOS
   openSUSE-MicroOS-release
   
-  20190911
+  20190913
   
   0
   openSUSE-MicroOS

++ openSUSE.product ++
--- /var/tmp/diff_new_pack.bekTUI/_old  2019-09-13 15:05:20.261256490 +0200
+++ /var/tmp/diff_new_pack.bekTUI/_new  2019-09-13 15:05:20.261256490 +0200
@@ -4,7 +4,7 @@
 
   openSUSE
   openSUSE
-  20190911
+  20190913
   0
 
   openSUSE




commit python-esptool for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-esptool for openSUSE:Factory 
checked in at 2019-09-13 15:03:08

Comparing /work/SRC/openSUSE:Factory/python-esptool (Old)
 and  /work/SRC/openSUSE:Factory/.python-esptool.new.7948 (New)


Package is "python-esptool"

Fri Sep 13 15:03:08 2019 rev:4 rq:730626 version:2.7

Changes:

--- /work/SRC/openSUSE:Factory/python-esptool/python-esptool.changes
2019-03-05 12:20:47.688924268 +0100
+++ /work/SRC/openSUSE:Factory/.python-esptool.new.7948/python-esptool.changes  
2019-09-13 15:04:51.581262586 +0200
@@ -1,0 +2,9 @@
+Fri Sep 13 07:57:08 UTC 2019 - Tomáš Chvátal 
+
+- Update to 2.7:
+  * New option write_flash --flash-size keep will keep whatever flash size is
+set in the bootloader header
+  * write_flash no longer updates the flash header if the file being written
+to the bootloader offset isn't a valid image file for the chip
+
+---

Old:

  esptool-2.6.tar.gz

New:

  esptool-2.7.tar.gz



Other differences:
--
++ python-esptool.spec ++
--- /var/tmp/diff_new_pack.bhy9VA/_old  2019-09-13 15:04:52.069262483 +0200
+++ /var/tmp/diff_new_pack.bhy9VA/_new  2019-09-13 15:04:52.069262483 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-esptool
-Version:2.6
+Version:2.7
 Release:0
 Summary:A serial utility to communicate & flash code to Espressif 
ESP8266 & ESP32 chips
 License:GPL-2.0-or-later
@@ -28,14 +28,15 @@
 BuildRequires:  %{python_module ecdsa}
 BuildRequires:  %{python_module pyaes}
 BuildRequires:  %{python_module pyelftools}
-BuildRequires:  %{python_module pyserial >= 2.5}
+BuildRequires:  %{python_module pyserial >= 3.0}
+BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  openssl
 BuildRequires:  python-rpm-macros
 Requires:   python-ecdsa
 Requires:   python-pyaes
-Requires:   python-pyserial >= 2.5
+Requires:   python-pyserial >= 3.0
 BuildArch:  noarch
 
 %python_subpackages
@@ -48,7 +49,6 @@
 %prep
 %setup -q -n esptool-%{version}
 rm -r ecdsa pyaes
-sed -i '/flake8/d' setup.py
 sed -i '/^#!/d' flasher_stub/*.py
 chmod a-x flasher_stub/*.py
 
@@ -64,7 +64,9 @@
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
 %check
-%python_exec setup.py test
+# there are more tests but upstream runs only those in .travis.yml
+%pytest test/test_imagegen.py
+%pytest test/test_espsecure.py
 
 %files %{python_files}
 %license LICENSE

++ esptool-2.6.tar.gz -> esptool-2.7.tar.gz ++
 1723 lines of diff (skipped)




commit python-dns-lexicon for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dns-lexicon for 
openSUSE:Factory checked in at 2019-09-13 15:03:24

Comparing /work/SRC/openSUSE:Factory/python-dns-lexicon (Old)
 and  /work/SRC/openSUSE:Factory/.python-dns-lexicon.new.7948 (New)


Package is "python-dns-lexicon"

Fri Sep 13 15:03:24 2019 rev:9 rq:730635 version:3.3.3

Changes:

--- /work/SRC/openSUSE:Factory/python-dns-lexicon/python-dns-lexicon.changes
2019-07-26 17:34:04.380093231 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dns-lexicon.new.7948/python-dns-lexicon.changes
  2019-09-13 15:05:01.597260457 +0200
@@ -1,0 +2,8 @@
+Fri Sep 13 08:42:44 UTC 2019 - Tomáš Chvátal 
+
+- Update to 3.3.3:
+  * Failsafe list of records when some content is missing
+  * Update provider specific dependencies link 
+  * Add DirectAdmin Provider (#418) * Add provider skeleton for DirectAdmin
+
+---

Old:

  lexicon-3.3.1.tar.gz

New:

  lexicon-3.3.3.tar.gz



Other differences:
--
++ python-dns-lexicon.spec ++
--- /var/tmp/diff_new_pack.Adz20c/_old  2019-09-13 15:05:02.197260330 +0200
+++ /var/tmp/diff_new_pack.Adz20c/_new  2019-09-13 15:05:02.197260330 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-dns-lexicon
-Version:3.3.1
+Version:3.3.3
 Release:0
 Summary:DNS record manipulation utility
 License:MIT
@@ -30,6 +30,7 @@
 BuildRequires:  %{python_module beautifulsoup4}
 BuildRequires:  %{python_module boto3}
 BuildRequires:  %{python_module cryptography}
+BuildRequires:  %{python_module dnspython >= 1.15.0}
 BuildRequires:  %{python_module future}
 BuildRequires:  %{python_module localzone}
 BuildRequires:  %{python_module mock >= 2.0.0}
@@ -49,6 +50,7 @@
 Requires:   python-beautifulsoup4
 Requires:   python-boto3
 Requires:   python-cryptography
+Requires:   python-dnspython >= 1.15.0
 Requires:   python-future
 Requires:   python-localzone
 Requires:   python-requests

++ lexicon-3.3.1.tar.gz -> lexicon-3.3.3.tar.gz ++
 6691 lines of diff (skipped)




commit python-dephell-discover for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dephell-discover for 
openSUSE:Factory checked in at 2019-09-13 15:03:50

Comparing /work/SRC/openSUSE:Factory/python-dephell-discover (Old)
 and  /work/SRC/openSUSE:Factory/.python-dephell-discover.new.7948 (New)


Package is "python-dephell-discover"

Fri Sep 13 15:03:50 2019 rev:3 rq:730650 version:0.2.8

Changes:

--- 
/work/SRC/openSUSE:Factory/python-dephell-discover/python-dephell-discover.changes
  2019-08-24 18:49:09.701741339 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dephell-discover.new.7948/python-dephell-discover.changes
2019-09-13 15:05:13.217257987 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 09:18:23 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.2.8:
+  * ship tests
+
+---

Old:

  dephell_discover-0.2.1.tar.gz

New:

  dephell_discover-0.2.8.tar.gz



Other differences:
--
++ python-dephell-discover.spec ++
--- /var/tmp/diff_new_pack.nOY4UD/_old  2019-09-13 15:05:14.129257793 +0200
+++ /var/tmp/diff_new_pack.nOY4UD/_new  2019-09-13 15:05:14.133257792 +0200
@@ -19,23 +19,23 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-dephell-discover
-Version:0.2.1
+Version:0.2.8
 Release:0
-Summary:Module to find project modules and data files (packages and 
package_data for setup.py)
+Summary:Module to find project modules and data files
 License:MIT
 Group:  Development/Languages/Python
-Url:https://github.com/dephell/dephell_discover
-Source: 
https://files.pythonhosted.org/packages/source/d/dephell-discover/dephell_discover-%{version}.tar.gz
+URL:https://github.com/dephell/dephell_discover
+Source: 
https://files.pythonhosted.org/packages/source/d/dephell_discover/dephell_discover-%{version}.tar.gz
 BuildRequires:  %{python_module base >= 3.5}
 BuildRequires:  %{python_module setuptools}
+BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
+Requires:   python-attr
+BuildArch:  noarch
 # SECTION test requirements
 BuildRequires:  %{python_module attr}
+BuildRequires:  %{python_module pytest}
 # /SECTION
-BuildRequires:  fdupes
-Requires:   python-attr
-BuildArch:  noarch
-
 %python_subpackages
 
 %description
@@ -51,6 +51,9 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+%pytest
+
 %files %{python_files}
 %license LICENSE
 %doc README.md

++ dephell_discover-0.2.1.tar.gz -> dephell_discover-0.2.8.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_discover-0.2.1/PKG-INFO 
new/dephell_discover-0.2.8/PKG-INFO
--- old/dephell_discover-0.2.1/PKG-INFO 1970-01-01 01:00:00.0 +0100
+++ new/dephell_discover-0.2.8/PKG-INFO 1970-01-01 01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
-Name: dephell_discover
-Version: 0.2.1
+Name: dephell-discover
+Version: 0.2.8
 Summary: Find project modules and data files (packages and package_data for 
setup.py).
 Project-URL: Repository, https://github.com/dephell/dephell_discover
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_discover-0.2.1/dephell_discover/__init__.py 
new/dephell_discover-0.2.8/dephell_discover/__init__.py
--- old/dephell_discover-0.2.1/dephell_discover/__init__.py 2019-05-19 
14:54:08.0 +0200
+++ new/dephell_discover-0.2.8/dephell_discover/__init__.py 2019-07-15 
15:53:26.0 +0200
@@ -9,7 +9,7 @@
 from ._root import Root
 
 
-__version__ = '0.2.1'
+__version__ = '0.2.8'
 __author__ = 'Gram (@orsinium)'
 __license__ = 'MIT'
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_discover-0.2.1/dephell_discover/_line.py 
new/dephell_discover-0.2.8/dephell_discover/_line.py
--- old/dephell_discover-0.2.1/dephell_discover/_line.py2019-05-18 
19:49:53.0 +0200
+++ new/dephell_discover-0.2.8/dephell_discover/_line.py2019-07-15 
15:52:45.0 +0200
@@ -41,7 +41,7 @@
 if type(tree) is not ast.Module:
 return None
 # check is assigment
-if type(tree.body[0]) is not ast.Assign:  # type: ignore
+if not tree.body or type(tree.body[0]) is not ast.Assign:  # type: 
ignore
 return None
 # check is correct target
 target = tree.body[0].targets[0]  # type: ignore
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_discover-0.2.1/dephell_discover/_metainfo.py 

commit python-ebcdic for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-ebcdic for openSUSE:Factory 
checked in at 2019-09-13 15:03:11

Comparing /work/SRC/openSUSE:Factory/python-ebcdic (Old)
 and  /work/SRC/openSUSE:Factory/.python-ebcdic.new.7948 (New)


Package is "python-ebcdic"

Fri Sep 13 15:03:11 2019 rev:2 rq:730630 version:1.1.1

Changes:

--- /work/SRC/openSUSE:Factory/python-ebcdic/python-ebcdic.changes  
2019-08-05 10:39:19.763313282 +0200
+++ /work/SRC/openSUSE:Factory/.python-ebcdic.new.7948/python-ebcdic.changes
2019-09-13 15:04:52.437262405 +0200
@@ -1,0 +2,7 @@
+Fri Sep 13 08:18:58 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.1.1:
+  * supporrt for more codepages
+- Switch to github archive and generate everything properly
+
+---

Old:

  ebcdic-1.0.2.zip

New:

  v1.1.1.tar.gz



Other differences:
--
++ python-ebcdic.spec ++
--- /var/tmp/diff_new_pack.2ZGEyI/_old  2019-09-13 15:04:52.893262308 +0200
+++ /var/tmp/diff_new_pack.2ZGEyI/_new  2019-09-13 15:04:52.893262308 +0200
@@ -18,17 +18,17 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-ebcdic
-Version:1.0.2
+Version:1.1.1
 Release:0
 Summary:Additional EBCDIC codecs for Python
 License:BSD-2-Clause
 Group:  Development/Languages/Python
-URL:https://pypi.python.org/pypi/ebcdic
-Source: 
https://files.pythonhosted.org/packages/source/e/ebcdic/ebcdic-%{version}.zip
+URL:https://github.com/roskakori/CodecMapper
+Source: 
https://github.com/roskakori/CodecMapper/archive/v%{version}.tar.gz
 BuildRequires:  %{python_module setuptools}
+BuildRequires:  ant
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
-BuildRequires:  unzip
 BuildArch:  noarch
 %python_subpackages
 
@@ -36,15 +36,25 @@
 Additional EBCDIC codecs for Python.
 
 %prep
-%setup -q -n ebcdic-%{version}
+%setup -q -n CodecMapper-%{version}/ebcdic
+# do not use venv python
+sed -i -e 's:"${basedir}/venv/bin/python":"/usr/bin/python3":' ../build.xml
 
 %build
+# first generate the py files
+pushd ..
+ant ebcdic
+popd
 %python_build
 
 %install
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+export LANG="en_US.UTF8"
+%python_exec setup.py test
+
 %files %{python_files}
 %doc README.rst
 %license LICENSE.txt




commit weechat for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package weechat for openSUSE:Factory checked 
in at 2019-09-13 15:03:54

Comparing /work/SRC/openSUSE:Factory/weechat (Old)
 and  /work/SRC/openSUSE:Factory/.weechat.new.7948 (New)


Package is "weechat"

Fri Sep 13 15:03:54 2019 rev:52 rq:730661 version:2.6

Changes:

--- /work/SRC/openSUSE:Factory/weechat/weechat.changes  2019-09-04 
09:14:47.002942808 +0200
+++ /work/SRC/openSUSE:Factory/.weechat.new.7948/weechat.changes
2019-09-13 15:05:16.493257291 +0200
@@ -1,0 +2,15 @@
+Fri Sep 13 09:18:32 UTC 2019 - Maximilian Trummer 
+
+- update to 2.6
+ * use Python 3 by default
+ * add support of 32767 color pairs
+ * add option "close" in command /window
+ * add infos "term_colors" and "term_color_pairs"
+ * add infolist "buflist" with list of buffer pointers
+ * evaluate option exec.command.shell, change default value to "${env:SHELL}"
+ * add filters "h=xxx" and "he=xxx" to filter options by description in fset 
buffer (translated or in English)
+ * make command char optional in server option "command"
+ * remove default aliases /ame and /amsg
+ * many bugs fixed.
+
+---

Old:

  weechat-2.5.tar.xz
  weechat-2.5.tar.xz.asc

New:

  weechat-2.6.tar.xz
  weechat-2.6.tar.xz.asc



Other differences:
--
++ weechat.spec ++
--- /var/tmp/diff_new_pack.6oWi3p/_old  2019-09-13 15:05:17.213257138 +0200
+++ /var/tmp/diff_new_pack.6oWi3p/_new  2019-09-13 15:05:17.213257138 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   weechat
-Version:2.5
+Version:2.6
 Release:0
 Summary:Multi-protocol extensible Chat Client
 License:GPL-3.0-or-later
@@ -118,7 +118,7 @@
 Group:  Productivity/Networking/IRC
 Requires:   %{name} = %{version}
 Supplements:(%{name} and enchant-2-backend-hunspell)
-Obsoletes:  %{name}-aspell < 2.5
+Obsoletes:  %{name}-aspell < 2.6
 Provides:   %{name}-aspell = %{version}
 
 %description spell

++ weechat-2.5.tar.xz -> weechat-2.6.tar.xz ++
 16494 lines of diff (skipped)





commit python-dephell-venvs for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dephell-venvs for 
openSUSE:Factory checked in at 2019-09-13 15:03:28

Comparing /work/SRC/openSUSE:Factory/python-dephell-venvs (Old)
 and  /work/SRC/openSUSE:Factory/.python-dephell-venvs.new.7948 (New)


Package is "python-dephell-venvs"

Fri Sep 13 15:03:28 2019 rev:2 rq:730638 version:0.1.16

Changes:

--- 
/work/SRC/openSUSE:Factory/python-dephell-venvs/python-dephell-venvs.changes
2019-08-13 13:27:01.429327448 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dephell-venvs.new.7948/python-dephell-venvs.changes
  2019-09-13 15:05:04.497259841 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 08:58:24 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.1.16:
+  * minor fixes only
+
+---

Old:

  dephell_venvs-0.1.15.tar.gz

New:

  dephell_venvs-0.1.16.tar.gz



Other differences:
--
++ python-dephell-venvs.spec ++
--- /var/tmp/diff_new_pack.VTxIdT/_old  2019-09-13 15:05:05.365259656 +0200
+++ /var/tmp/diff_new_pack.VTxIdT/_new  2019-09-13 15:05:05.365259656 +0200
@@ -12,30 +12,31 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-dephell-venvs
-Version:0.1.15
+Version:0.1.16
 Release:0
-License:MIT
 Summary:Dephell plugin to manage virtual environments
-Url:https://github.com/dephell/dephell_venvs
+License:MIT
 Group:  Development/Languages/Python
-Source: 
https://files.pythonhosted.org/packages/source/d/dephell-venvs/dephell_venvs-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
+URL:https://github.com/dephell/dephell_venvs
+Source: 
https://files.pythonhosted.org/packages/source/d/dephell_venvs/dephell_venvs-%{version}.tar.gz
 BuildRequires:  %{python_module setuptools}
-# SECTION test requirements
-BuildRequires:  %{python_module attrs}
-BuildRequires:  %{python_module dephell-pythons}
-# /SECTION
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-attrs
 Requires:   python-dephell-pythons
 BuildArch:  noarch
-
+# SECTION test requirements
+BuildRequires:  %{python_module attrs}
+BuildRequires:  %{python_module dephell-pythons}
+BuildRequires:  %{python_module pytest}
+# /SECTION
 %python_subpackages
 
 %description
@@ -51,6 +52,9 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+%pytest
+
 %files %{python_files}
 %license LICENSE
 %doc README.md

++ dephell_venvs-0.1.15.tar.gz -> dephell_venvs-0.1.16.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_venvs-0.1.15/PKG-INFO 
new/dephell_venvs-0.1.16/PKG-INFO
--- old/dephell_venvs-0.1.15/PKG-INFO   1970-01-01 01:00:00.0 +0100
+++ new/dephell_venvs-0.1.16/PKG-INFO   1970-01-01 01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
-Name: dephell_venvs
-Version: 0.1.15
+Name: dephell-venvs
+Version: 0.1.16
 Summary: Manage virtual environments
 Project-URL: Repository, https://github.com/dephell/dephell_venvs
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_venvs-0.1.15/dephell_venvs.egg-info/PKG-INFO 
new/dephell_venvs-0.1.16/dephell_venvs.egg-info/PKG-INFO
--- old/dephell_venvs-0.1.15/dephell_venvs.egg-info/PKG-INFO1970-01-01 
01:00:00.0 +0100
+++ new/dephell_venvs-0.1.16/dephell_venvs.egg-info/PKG-INFO1970-01-01 
01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
-Name: dephell_venvs
-Version: 0.1.15
+Name: dephell-venvs
+Version: 0.1.16
 Summary: Manage virtual environments
 Project-URL: Repository, https://github.com/dephell/dephell_venvs
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_venvs-0.1.15/setup.py 
new/dephell_venvs-0.1.16/setup.py
--- old/dephell_venvs-0.1.15/setup.py   2019-05-19 14:57:48.0 +0200
+++ new/dephell_venvs-0.1.16/setup.py   2019-05-23 20:43:58.0 +0200
@@ -13,13 +13,15 @@
 
 readme = ''
 here = os.path.abspath(os.path.dirname(__file__))
-with open(os.path.join(here, 'README.rst'), 'rb') as stream:
-readme = stream.read().decode('utf8')
+readme_path = os.path.join(here, 'README.rst')
+if os.path.exists(readme_path):
+with open(readme_path, 'rb') as stream:
+readme = 

commit python-dephell-links for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dephell-links for 
openSUSE:Factory checked in at 2019-09-13 15:03:45

Comparing /work/SRC/openSUSE:Factory/python-dephell-links (Old)
 and  /work/SRC/openSUSE:Factory/.python-dephell-links.new.7948 (New)


Package is "python-dephell-links"

Fri Sep 13 15:03:45 2019 rev:2 rq:730647 version:0.1.4

Changes:

--- 
/work/SRC/openSUSE:Factory/python-dephell-links/python-dephell-links.changes
2019-08-13 13:26:43.657332125 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dephell-links.new.7948/python-dephell-links.changes
  2019-09-13 15:05:10.673258528 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 09:13:05 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.1.4:
+  * ship tests
+
+---

Old:

  dephell_links-0.1.3.tar.gz

New:

  dephell_links-0.1.4.tar.gz



Other differences:
--
++ python-dephell-links.spec ++
--- /var/tmp/diff_new_pack.164oGK/_old  2019-09-13 15:05:11.729258304 +0200
+++ /var/tmp/diff_new_pack.164oGK/_new  2019-09-13 15:05:11.733258303 +0200
@@ -12,29 +12,30 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-dephell-links
-Version:0.1.3
+Version:0.1.4
 Release:0
-License:MIT
 Summary:Dephell library to parse dependency links
-Url:https://github.com/dephell/dephell-links
+License:MIT
 Group:  Development/Languages/Python
-Source: 
https://files.pythonhosted.org/packages/source/d/dephell-links/dephell_links-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
+URL:https://github.com/dephell/dephell_links
+Source: 
https://files.pythonhosted.org/packages/source/d/dephell_links/dephell_links-%{version}.tar.gz
 BuildRequires:  %{python_module base >= 3.5}
 BuildRequires:  %{python_module setuptools}
-# SECTION test requirements
-BuildRequires:  %{python_module attrs}
-# /SECTION
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-attrs
 BuildArch:  noarch
-
+# SECTION test requirements
+BuildRequires:  %{python_module attrs}
+BuildRequires:  %{python_module pytest}
+# /SECTION
 %python_subpackages
 
 %description
@@ -50,6 +51,9 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+%pytest
+
 %files %{python_files}
 %license LICENSE
 %doc README.md

++ dephell_links-0.1.3.tar.gz -> dephell_links-0.1.4.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_links-0.1.3/PKG-INFO 
new/dephell_links-0.1.4/PKG-INFO
--- old/dephell_links-0.1.3/PKG-INFO1970-01-01 01:00:00.0 +0100
+++ new/dephell_links-0.1.4/PKG-INFO1970-01-01 01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
-Name: dephell_links
-Version: 0.1.3
+Name: dephell-links
+Version: 0.1.4
 Summary: Parse dependency links
 Project-URL: Repository, https://github.com/dephell/dephell_links
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_links-0.1.3/dephell_links.egg-info/PKG-INFO 
new/dephell_links-0.1.4/dephell_links.egg-info/PKG-INFO
--- old/dephell_links-0.1.3/dephell_links.egg-info/PKG-INFO 1970-01-01 
01:00:00.0 +0100
+++ new/dephell_links-0.1.4/dephell_links.egg-info/PKG-INFO 1970-01-01 
01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
-Name: dephell_links
-Version: 0.1.3
+Name: dephell-links
+Version: 0.1.4
 Summary: Parse dependency links
 Project-URL: Repository, https://github.com/dephell/dephell_links
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_links-0.1.3/setup.py 
new/dephell_links-0.1.4/setup.py
--- old/dephell_links-0.1.3/setup.py2019-05-19 14:52:41.0 +0200
+++ new/dephell_links-0.1.4/setup.py2019-05-23 20:41:16.0 +0200
@@ -13,13 +13,15 @@
 
 readme = ''
 here = os.path.abspath(os.path.dirname(__file__))
-with open(os.path.join(here, 'README.rst'), 'rb') as stream:
-readme = stream.read().decode('utf8')
+readme_path = os.path.join(here, 'README.rst')
+if os.path.exists(readme_path):
+with open(readme_path, 'rb') as stream:
+readme = stream.read().decode('utf8')
 
 setup(
 long_description=readme,
 name='dephell_links',
-version='0.1.3',
+version='0.1.4',
 

commit python-dephell-markers for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dephell-markers for 
openSUSE:Factory checked in at 2019-09-13 15:03:42

Comparing /work/SRC/openSUSE:Factory/python-dephell-markers (Old)
 and  /work/SRC/openSUSE:Factory/.python-dephell-markers.new.7948 (New)


Package is "python-dephell-markers"

Fri Sep 13 15:03:42 2019 rev:2 rq:730646 version:1.0.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-dephell-markers/python-dephell-markers.changes
2019-08-13 13:26:48.893330747 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dephell-markers.new.7948/python-dephell-markers.changes
  2019-09-13 15:05:09.385258802 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 09:10:21 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.0.0:
+  * ship tests
+
+---

Old:

  dephell_markers-0.2.5.tar.gz

New:

  dephell_markers-1.0.0.tar.gz



Other differences:
--
++ python-dephell-markers.spec ++
--- /var/tmp/diff_new_pack.w2NTU5/_old  2019-09-13 15:05:10.453258575 +0200
+++ /var/tmp/diff_new_pack.w2NTU5/_new  2019-09-13 15:05:10.457258574 +0200
@@ -12,33 +12,34 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-dephell-markers
-Version:0.2.5
+Version:1.0.0
 Release:0
-License:MIT
 Summary:Dephell library to use environment markers (PEP-496)
-Url:https://github.com/dephell/dephell_markers
+License:MIT
 Group:  Development/Languages/Python
-Source: 
https://files.pythonhosted.org/packages/source/d/dephell-markers/dephell_markers-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
+URL:https://github.com/dephell/dephell_markers
+Source: 
https://files.pythonhosted.org/packages/source/d/dephell_markers/dephell_markers-%{version}.tar.gz
 BuildRequires:  %{python_module base >= 3.5}
 BuildRequires:  %{python_module setuptools}
-# SECTION test requirements
-BuildRequires:  %{python_module attrs}
-BuildRequires:  %{python_module dephell-specifier}
-BuildRequires:  %{python_module packaging}
-# /SECTION
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-attrs
 Requires:   python-dephell-specifier
 Requires:   python-packaging
 BuildArch:  noarch
-
+# SECTION test requirements
+BuildRequires:  %{python_module attrs}
+BuildRequires:  %{python_module dephell-specifier}
+BuildRequires:  %{python_module packaging}
+BuildRequires:  %{python_module pytest}
+# /SECTION
 %python_subpackages
 
 %description
@@ -54,6 +55,9 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+%pytest
+
 %files %{python_files}
 %license LICENSE
 %doc README.md

++ dephell_markers-0.2.5.tar.gz -> dephell_markers-1.0.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_markers-0.2.5/PKG-INFO 
new/dephell_markers-1.0.0/PKG-INFO
--- old/dephell_markers-0.2.5/PKG-INFO  1970-01-01 01:00:00.0 +0100
+++ new/dephell_markers-1.0.0/PKG-INFO  1970-01-01 01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
-Name: dephell_markers
-Version: 0.2.5
+Name: dephell-markers
+Version: 1.0.0
 Summary: Work with environment markers (PEP-496)
 Project-URL: Repository, https://github.com/dephell/dephell_markers
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_markers-0.2.5/dephell_markers/_markers.py 
new/dephell_markers-1.0.0/dephell_markers/_markers.py
--- old/dephell_markers-0.2.5/dephell_markers/_markers.py   2019-04-19 
13:21:45.0 +0200
+++ new/dephell_markers-1.0.0/dephell_markers/_markers.py   2019-07-07 
12:42:43.0 +0200
@@ -5,7 +5,7 @@
 # external
 from dephell_specifier import RangeSpecifier
 from packaging import markers as packaging
-from packaging.markers import Variable
+from packaging.markers import Variable, Op, Value
 
 # app
 from ._marker import BaseMarker, StringMarker, VersionMarker
@@ -141,18 +141,7 @@
 for marker in markers:
 # single marker
 if isinstance(marker, tuple):
-lhs, op, rhs = marker
-var = lhs.value if isinstance(lhs, Variable) else rhs.value
-if var in STRING_VARIABLES:
-marker_cls = StringMarker  # type: Type[BaseMarker]
-elif var in VERSION_VARIABLES:

commit python-dephell-pythons for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dephell-pythons for 
openSUSE:Factory checked in at 2019-09-13 15:03:40

Comparing /work/SRC/openSUSE:Factory/python-dephell-pythons (Old)
 and  /work/SRC/openSUSE:Factory/.python-dephell-pythons.new.7948 (New)


Package is "python-dephell-pythons"

Fri Sep 13 15:03:40 2019 rev:2 rq:730644 version:0.1.12

Changes:

--- 
/work/SRC/openSUSE:Factory/python-dephell-pythons/python-dephell-pythons.changes
2019-08-13 13:26:53.957329415 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dephell-pythons.new.7948/python-dephell-pythons.changes
  2019-09-13 15:05:08.537258982 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 09:07:36 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.1.12:
+  * ship tests
+
+---

Old:

  dephell_pythons-0.1.10.tar.gz

New:

  dephell_pythons-0.1.12.tar.gz



Other differences:
--
++ python-dephell-pythons.spec ++
--- /var/tmp/diff_new_pack.q6QMHI/_old  2019-09-13 15:05:09.097258863 +0200
+++ /var/tmp/diff_new_pack.q6QMHI/_new  2019-09-13 15:05:09.101258862 +0200
@@ -12,33 +12,35 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-dephell-pythons
-Version:0.1.10
+Version:0.1.12
 Release:0
-License:MIT
 Summary:Dephell library to manage python versions
-Url:https://github.com/dephell/dephell_pythons
+License:MIT
 Group:  Development/Languages/Python
-Source: 
https://files.pythonhosted.org/packages/source/d/dephell-pythons/dephell_pythons-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
+URL:https://github.com/dephell/dephell_pythons
+Source: 
https://files.pythonhosted.org/packages/source/d/dephell_pythons/dephell_pythons-%{version}.tar.gz
 BuildRequires:  %{python_module base >= 3.5}
 BuildRequires:  %{python_module setuptools}
-# SECTION test requirements
-BuildRequires:  %{python_module attrs}
-BuildRequires:  %{python_module dephell-specifier}
-BuildRequires:  %{python_module packaging}
-# /SECTION
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-attrs
 Requires:   python-dephell-specifier
 Requires:   python-packaging
 BuildArch:  noarch
-
+# SECTION test requirements
+BuildRequires:  %{python_module attrs}
+BuildRequires:  %{python_module dephell-specifier}
+BuildRequires:  %{python_module packaging}
+BuildRequires:  %{python_module pytest}
+BuildRequires:  python2-base
+# /SECTION
 %python_subpackages
 
 %description
@@ -54,6 +56,10 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+# test_lib_paths - /usr/bin added by pytest calls in IBS
+%pytest -k 'not test_lib_paths'
+
 %files %{python_files}
 %license LICENSE
 %doc README.md

++ dephell_pythons-0.1.10.tar.gz -> dephell_pythons-0.1.12.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_pythons-0.1.10/PKG-INFO 
new/dephell_pythons-0.1.12/PKG-INFO
--- old/dephell_pythons-0.1.10/PKG-INFO 1970-01-01 01:00:00.0 +0100
+++ new/dephell_pythons-0.1.12/PKG-INFO 1970-01-01 01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
-Name: dephell_pythons
-Version: 0.1.10
+Name: dephell-pythons
+Version: 0.1.12
 Summary: Work with python versions
 Project-URL: Repository, https://github.com/dephell/dephell
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/dephell_pythons-0.1.10/dephell_pythons/pep514tools/__init__.py 
new/dephell_pythons-0.1.12/dephell_pythons/pep514tools/__init__.py
--- old/dephell_pythons-0.1.10/dephell_pythons/pep514tools/__init__.py  
2019-05-19 14:55:22.0 +0200
+++ new/dephell_pythons-0.1.12/dephell_pythons/pep514tools/__init__.py  
2019-05-23 20:45:28.0 +0200
@@ -6,6 +6,6 @@
 #-
 
 __author__ = 'Steve Dower '
-__version__ = '0.1.10'
+__version__ = '0.1.12'
 
 from .environment import findall, find, findone
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/dephell_pythons-0.1.10/dephell_pythons.egg-info/PKG-INFO 
new/dephell_pythons-0.1.12/dephell_pythons.egg-info/PKG-INFO
--- old/dephell_pythons-0.1.10/dephell_pythons.egg-info/PKG-INFO
1970-01-01 01:00:00.0 +0100
+++ 

commit python-dynaconf for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dynaconf for openSUSE:Factory 
checked in at 2019-09-13 15:03:18

Comparing /work/SRC/openSUSE:Factory/python-dynaconf (Old)
 and  /work/SRC/openSUSE:Factory/.python-dynaconf.new.7948 (New)


Package is "python-dynaconf"

Fri Sep 13 15:03:18 2019 rev:3 rq:730632 version:2.1.0

Changes:

--- /work/SRC/openSUSE:Factory/python-dynaconf/python-dynaconf.changes  
2019-07-26 17:34:59.916072290 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dynaconf.new.7948/python-dynaconf.changes
2019-09-13 15:04:54.105262050 +0200
@@ -1,0 +2,9 @@
+Fri Sep 13 08:25:34 UTC 2019 - Tomáš Chvátal 
+
+- Update to 2.1.0:
+  * Nested envvars w/ DUNDER__KEYS
+  * .from_env easy access to different envs
+  * $dynaconf list -o export your settings as a file
+  * @hashicorp #Vault & @RedisLabs supports multiple envs
+
+---

Old:

  2.0.3.tar.gz

New:

  2.1.0.tar.gz



Other differences:
--
++ python-dynaconf.spec ++
--- /var/tmp/diff_new_pack.yBYhb6/_old  2019-09-13 15:04:54.577261949 +0200
+++ /var/tmp/diff_new_pack.yBYhb6/_new  2019-09-13 15:04:54.581261949 +0200
@@ -19,7 +19,7 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-dynaconf
-Version:2.0.3
+Version:2.1.0
 Release:0
 Summary:The dynamic configurator for your Python Project
 License:MIT

++ 2.0.3.tar.gz -> 2.1.0.tar.gz ++
 3410 lines of diff (skipped)




commit python-easydev for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-easydev for openSUSE:Factory 
checked in at 2019-09-13 15:03:15

Comparing /work/SRC/openSUSE:Factory/python-easydev (Old)
 and  /work/SRC/openSUSE:Factory/.python-easydev.new.7948 (New)


Package is "python-easydev"

Fri Sep 13 15:03:15 2019 rev:3 rq:730631 version:0.9.38

Changes:

--- /work/SRC/openSUSE:Factory/python-easydev/python-easydev.changes
2018-12-13 19:43:27.685089557 +0100
+++ /work/SRC/openSUSE:Factory/.python-easydev.new.7948/python-easydev.changes  
2019-09-13 15:04:53.181262246 +0200
@@ -1,0 +2,7 @@
+Fri Sep 13 08:20:09 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.9.38:
+  * synchronized with pypi. Just an updated travis version to get rid of
+py3.3 and removing deprecated messages.
+
+---

Old:

  easydev-0.9.37.tar.gz

New:

  easydev-0.9.38.tar.gz



Other differences:
--
++ python-easydev.spec ++
--- /var/tmp/diff_new_pack.xpAEbY/_old  2019-09-13 15:04:53.589262160 +0200
+++ /var/tmp/diff_new_pack.xpAEbY/_new  2019-09-13 15:04:53.593262159 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-easydev
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-easydev
-Version:0.9.37
+Version:0.9.38
 Release:0
 Summary:Common utilities to ease the development of Python packages
 License:BSD-3-Clause
@@ -41,6 +41,7 @@
 Requires:   python-colorama
 Requires:   python-colorlog
 Requires:   python-pexpect
+Requires:   python-setuptools
 Recommends: python-line_profiler
 BuildArch:  noarch
 
@@ -55,6 +56,7 @@
 %prep
 %setup -q -n easydev-%{version}
 sed -i -e '/^#!\//, 1d' easydev/appdirs.py
+rm -r easydev/share/__pycache__
 
 %build
 %python_build

++ easydev-0.9.37.tar.gz -> easydev-0.9.38.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/easydev-0.9.37/PKG-INFO new/easydev-0.9.38/PKG-INFO
--- old/easydev-0.9.37/PKG-INFO 2018-04-11 21:52:36.0 +0200
+++ new/easydev-0.9.38/PKG-INFO 2019-08-23 10:54:51.0 +0200
@@ -1,10 +1,10 @@
 Metadata-Version: 1.1
 Name: easydev
-Version: 0.9.37
+Version: 0.9.38
 Summary: Common utilities to ease the development of Python packages
 Home-page: ['http://packages.python.org/easydev/']
 Author: Thomas Cokelaer
-Author-email: cokel...@ebi.ac.uk
+Author-email: thomas.cokel...@pasteur.fr
 License: new BSD
 Download-URL: ['http://pypi.python.org/pypi/easydev']
 Description-Content-Type: UNKNOWN
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/easydev-0.9.37/easydev/__init__.py 
new/easydev-0.9.38/easydev/__init__.py
--- old/easydev-0.9.37/easydev/__init__.py  2018-04-11 21:45:41.0 
+0200
+++ new/easydev-0.9.38/easydev/__init__.py  2019-08-23 10:45:35.0 
+0200
@@ -19,7 +19,7 @@
 #from __future__ import absolute_import
 
 
-__version__ = "0.9.36"
+__version__ = "0.9.38"
 try:
 import pkg_resources
 except ImportError as err:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/easydev-0.9.37/easydev/config_tools.py 
new/easydev-0.9.38/easydev/config_tools.py
--- old/easydev-0.9.37/easydev/config_tools.py  2017-12-22 22:49:43.0 
+0100
+++ new/easydev-0.9.38/easydev/config_tools.py  2019-08-23 10:34:18.0 
+0200
@@ -421,7 +421,7 @@
   "has not been installed. Please install "
   "PyYAML to use YAML config files.")
 try:
-return yaml.load(f)
+return yaml.load(f, Loader=yaml.FullLoader)
 except yaml.YAMLError:
 raise IOError("Config file is not valid JSON or YAML. "
   "In case of YAML, make sure to not mix "
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/easydev-0.9.37/easydev.egg-info/PKG-INFO 
new/easydev-0.9.38/easydev.egg-info/PKG-INFO
--- old/easydev-0.9.37/easydev.egg-info/PKG-INFO2018-04-11 
21:52:36.0 +0200
+++ new/easydev-0.9.38/easydev.egg-info/PKG-INFO2019-08-23 
10:54:50.0 +0200
@@ -1,10 +1,10 @@
 Metadata-Version: 1.1
 Name: easydev
-Version: 0.9.37
+Version: 0.9.38
 Summary: Common utilities to ease the development of Python packages
 

commit python-djangorestframework-simplejwt for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-djangorestframework-simplejwt 
for openSUSE:Factory checked in at 2019-09-13 15:03:26

Comparing /work/SRC/openSUSE:Factory/python-djangorestframework-simplejwt (Old)
 and  
/work/SRC/openSUSE:Factory/.python-djangorestframework-simplejwt.new.7948 (New)


Package is "python-djangorestframework-simplejwt"

Fri Sep 13 15:03:26 2019 rev:2 rq:730636 version:4.3.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-djangorestframework-simplejwt/python-djangorestframework-simplejwt.changes
2019-04-23 14:35:40.005456395 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-djangorestframework-simplejwt.new.7948/python-djangorestframework-simplejwt.changes
  2019-09-13 15:05:03.289260097 +0200
@@ -1,0 +2,9 @@
+Fri Sep 13 08:46:31 UTC 2019 - Tomáš Chvátal 
+
+- Update to 4.3.0:
+  * Added JTI_CLAIM setting to allow storing token identifiers under a 
different claim.
+  * We now return HTTP 401 for user not found or inactive.
+  * Restricted setup.py config to Python 3 only.
+  * Included translation files in release package.
+
+---

Old:

  djangorestframework_simplejwt-4.1.3.tar.gz

New:

  djangorestframework_simplejwt-4.3.0.tar.gz



Other differences:
--
++ python-djangorestframework-simplejwt.spec ++
--- /var/tmp/diff_new_pack.cjjKK8/_old  2019-09-13 15:05:03.941259959 +0200
+++ /var/tmp/diff_new_pack.cjjKK8/_new  2019-09-13 15:05:03.949259957 +0200
@@ -12,31 +12,31 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-djangorestframework-simplejwt
-Version:4.1.3
+Version:4.3.0
 Release:0
-License:MIT
 Summary:JSON Web Token authentication for Django REST Framework
-Url:https://github.com/davesque/django-rest-framework-simplejwt
+License:MIT
 Group:  Development/Languages/Python
-Source: 
https://github.com/davesque/django-rest-framework-simplejwt/archive/v4.1.3.tar.gz#/djangorestframework_simplejwt-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
+URL:https://github.com/davesque/django-rest-framework-simplejwt
+Source: 
https://github.com/davesque/django-rest-framework-simplejwt/archive/v%{version}.tar.gz#/djangorestframework_simplejwt-%{version}.tar.gz
 BuildRequires:  %{python_module PyJWT}
 BuildRequires:  %{python_module djangorestframework}
 BuildRequires:  %{python_module pytest-django}
 BuildRequires:  %{python_module python-jose}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-PyJWT
 Requires:   python-djangorestframework
 Recommends: python-python-jose
 BuildArch:  noarch
-
 %python_subpackages
 
 %description
@@ -56,7 +56,7 @@
 
 %check
 export LANG=en_US.UTF-8
-%python_exec -m pytest
+%pytest
 
 %files %{python_files}
 %license LICENSE.txt licenses/*

++ djangorestframework_simplejwt-4.1.3.tar.gz -> 
djangorestframework_simplejwt-4.3.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/django-rest-framework-simplejwt-4.1.3/.travis.yml 
new/django-rest-framework-simplejwt-4.3.0/.travis.yml
--- old/django-rest-framework-simplejwt-4.1.3/.travis.yml   2019-04-04 
21:04:57.0 +0200
+++ new/django-rest-framework-simplejwt-4.3.0/.travis.yml   2019-04-16 
04:25:16.0 +0200
@@ -14,6 +14,7 @@
 - DJANGO=1.11
 - DJANGO=2.0
 - DJANGO=2.1
+- DJANGO=2.2
 - DJANGO=master
 
 matrix:
@@ -27,6 +28,8 @@
   - python: "3.5"
 env: DJANGO=2.1
   - python: "3.5"
+env: DJANGO=2.2
+  - python: "3.5"
 env: DJANGO=master
   - python: "3.6"
 env: DJANGO=master
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/django-rest-framework-simplejwt-4.1.3/CHANGELOG.md 
new/django-rest-framework-simplejwt-4.3.0/CHANGELOG.md
--- old/django-rest-framework-simplejwt-4.1.3/CHANGELOG.md  2019-04-04 
21:04:57.0 +0200
+++ new/django-rest-framework-simplejwt-4.3.0/CHANGELOG.md  2019-04-16 
04:25:16.0 +0200
@@ -1,3 +1,20 @@
+## Version 4.3
+
+* Added `JTI_CLAIM` setting to allow storing token identifiers under a
+  different claim.
+
+## Version 4.2
+
+* We now return HTTP 401 for user not found or inactive.
+
+## Version 4.1.5
+
+* 

commit python-dephell-licenses for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dephell-licenses for 
openSUSE:Factory checked in at 2019-09-13 15:03:47

Comparing /work/SRC/openSUSE:Factory/python-dephell-licenses (Old)
 and  /work/SRC/openSUSE:Factory/.python-dephell-licenses.new.7948 (New)


Package is "python-dephell-licenses"

Fri Sep 13 15:03:47 2019 rev:2 rq:730649 version:0.1.6

Changes:

--- 
/work/SRC/openSUSE:Factory/python-dephell-licenses/python-dephell-licenses.changes
  2019-08-13 13:14:38.213514409 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dephell-licenses.new.7948/python-dephell-licenses.changes
2019-09-13 15:05:11.989258248 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 09:14:15 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.1.6:
+  * ship tests
+
+---

Old:

  dephell-licenses-0.1.5.tar.gz

New:

  dephell-licenses-0.1.6.tar.gz



Other differences:
--
++ python-dephell-licenses.spec ++
--- /var/tmp/diff_new_pack.21wWAx/_old  2019-09-13 15:05:12.853258065 +0200
+++ /var/tmp/diff_new_pack.21wWAx/_new  2019-09-13 15:05:12.853258065 +0200
@@ -12,31 +12,32 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-dephell-licenses
-Version:0.1.5
+Version:0.1.6
 Release:0
-License:MIT
 Summary:Dephell library to get info about OSS licenses
-Url:https://github.com/dephell/dephell_licenses
+License:MIT
 Group:  Development/Languages/Python
+URL:https://github.com/dephell/dephell_licenses
 Source: 
https://files.pythonhosted.org/packages/source/d/dephell-licenses/dephell-licenses-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
 BuildRequires:  %{python_module base >= 3.5}
 BuildRequires:  %{python_module setuptools}
-# SECTION test requirements
-BuildRequires:  %{python_module attrs}
-BuildRequires:  %{python_module requests}
-# /SECTION
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-attrs
 Requires:   python-requests
 BuildArch:  noarch
-
+# SECTION test requirements
+BuildRequires:  %{python_module attrs}
+BuildRequires:  %{python_module pytest}
+BuildRequires:  %{python_module requests}
+# /SECTION
 %python_subpackages
 
 %description
@@ -52,6 +53,10 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+# test_make_text - online test
+%pytest -k 'not test_make_text'
+
 %files %{python_files}
 %doc README.md
 %license LICENSE

++ dephell-licenses-0.1.5.tar.gz -> dephell-licenses-0.1.6.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell-licenses-0.1.5/PKG-INFO 
new/dephell-licenses-0.1.6/PKG-INFO
--- old/dephell-licenses-0.1.5/PKG-INFO 1970-01-01 01:00:00.0 +0100
+++ new/dephell-licenses-0.1.6/PKG-INFO 1970-01-01 01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: dephell-licenses
-Version: 0.1.5
+Version: 0.1.6
 Summary: Get info about OSS licenses
 Project-URL: Repository, https://github.com/dephell/dephell_licenses
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/dephell-licenses-0.1.5/dephell-licenses.egg-info/PKG-INFO 
new/dephell-licenses-0.1.6/dephell-licenses.egg-info/PKG-INFO
--- old/dephell-licenses-0.1.5/dephell-licenses.egg-info/PKG-INFO   
1970-01-01 01:00:00.0 +0100
+++ new/dephell-licenses-0.1.6/dephell-licenses.egg-info/PKG-INFO   
1970-01-01 01:00:00.0 +0100
@@ -1,115 +0,0 @@
-Metadata-Version: 2.1
-Name: dephell-licenses
-Version: 0.1.5
-Summary: Get info about OSS licenses
-Project-URL: Repository, https://github.com/dephell/dephell_licenses
-Author: Gram
-Author-email: master_f...@mail.ru
-License: MIT
-Requires-Python: >=3.5
-Keywords: dephell,packaging,licenses,pypi
-Classifier: Development Status :: 4 - Beta
-Classifier: Intended Audience :: Developers
-Classifier: License :: OSI Approved :: MIT License
-Classifier: Programming Language :: Python
-Classifier: Topic :: Software Development :: Libraries :: Python Modules
-Classifier: Programming Language :: Python :: 3.5
-Classifier: Programming Language :: Python :: 3.6
-Classifier: Programming Language :: Python :: 3.7
-Classifier: Programming Language :: Python :: 3.8
-Classifier: Programming Language :: Python :: Implementation :: CPython
-Classifier: 

commit python-zdaemon for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-zdaemon for openSUSE:Factory 
checked in at 2019-09-13 15:03:20

Comparing /work/SRC/openSUSE:Factory/python-zdaemon (Old)
 and  /work/SRC/openSUSE:Factory/.python-zdaemon.new.7948 (New)


Package is "python-zdaemon"

Fri Sep 13 15:03:20 2019 rev:21 rq:730634 version:4.3

Changes:

--- /work/SRC/openSUSE:Factory/python-zdaemon/python-zdaemon.changes
2019-05-14 13:30:31.527364961 +0200
+++ /work/SRC/openSUSE:Factory/.python-zdaemon.new.7948/python-zdaemon.changes  
2019-09-13 15:04:54.849261892 +0200
@@ -1,0 +2,6 @@
+Thu Sep 12 17:12:56 UTC 2019 - Tomáš Chvátal 
+
+- Patch out flaky tests that seldomly fails in obs:
+  * obs-timeout.patch
+
+---

New:

  obs-timeout.patch



Other differences:
--
++ python-zdaemon.spec ++
--- /var/tmp/diff_new_pack.b2LXJQ/_old  2019-09-13 15:04:55.213261814 +0200
+++ /var/tmp/diff_new_pack.b2LXJQ/_new  2019-09-13 15:04:55.217261814 +0200
@@ -26,6 +26,7 @@
 Group:  Development/Languages/Python
 URL:https://github.com/zopefoundation/zdaemon
 Source: 
https://files.pythonhosted.org/packages/source/z/zdaemon/%{modname}-%{version}.tar.gz
+Patch0: obs-timeout.patch
 BuildRequires:  %{python_module ZConfig}
 BuildRequires:  %{python_module manuel}
 BuildRequires:  %{python_module mock}
@@ -49,6 +50,7 @@
 
 %prep
 %setup -q -n %{modname}-%{version}
+%patch0 -p1
 # remove unwanted shebang
 sed -i '1 { /^#!/ d }' src/zdaemon/tests/nokill.py
 rm -rf src/zdaemon.egg-info

++ obs-timeout.patch ++
Index: zdaemon-4.3/src/zdaemon/tests/tests.py
===
--- zdaemon-4.3.orig/src/zdaemon/tests/tests.py
+++ zdaemon-4.3/src/zdaemon/tests/tests.py
@@ -264,77 +264,6 @@ def test_log_rotation():
 """
 
 
-def test_start_test_program():
-"""
->>> write('t.py',
-... '''
-... import time
-... time.sleep(1)
-... open('x', 'w').close()
-... time.sleep(99)
-... ''')
-
->>> write('conf',
-... '''
-... 
-...   program %s t.py
-...   start-test-program cat x
-... 
-... ''' % sys.executable)
-
->>> import os
-
->>> system("./zdaemon -Cconf start")
-. .
-daemon process started, pid=21446
-
->>> os.path.exists('x')
-True
->>> os.remove('x')
-
->>> system("./zdaemon -Cconf restart")
-. . .
-daemon process restarted, pid=19622
->>> os.path.exists('x')
-True
-
->>> system("./zdaemon -Cconf stop")
-
-daemon process stopped
-"""
-
-
-def test_start_timeout():
-"""
->>> write('t.py',
-... '''
-... import time
-... time.sleep(9)
-... ''')
-
->>> write('conf',
-... '''
-... 
-...   program %s t.py
-...   start-test-program cat x
-...   start-timeout 1
-... 
-... ''' % sys.executable)
-
->>> import time
->>> start = time.time()
-
->>> system("./zdaemon -Cconf start")
-
-Program took too long to start
-Failed: 1
-
->>> system("./zdaemon -Cconf stop")
-
-daemon process stopped
-"""
-
-
 def DAEMON_MANAGER_MODE_leak():
 """
 Zdaemon used an environment variable to flag that it's running in



commit python-dephell-specifier for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dephell-specifier for 
openSUSE:Factory checked in at 2019-09-13 15:03:35

Comparing /work/SRC/openSUSE:Factory/python-dephell-specifier (Old)
 and  /work/SRC/openSUSE:Factory/.python-dephell-specifier.new.7948 (New)


Package is "python-dephell-specifier"

Fri Sep 13 15:03:35 2019 rev:2 rq:730640 version:0.2.1

Changes:

--- 
/work/SRC/openSUSE:Factory/python-dephell-specifier/python-dephell-specifier.changes
2019-08-13 13:26:59.389327985 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dephell-specifier.new.7948/python-dephell-specifier.changes
  2019-09-13 15:05:06.657259382 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 09:01:42 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.2.1:
+  * no upstream changelog
+
+---

Old:

  dephell_specifier-0.1.5.tar.gz

New:

  dephell_specifier-0.2.1.tar.gz



Other differences:
--
++ python-dephell-specifier.spec ++
--- /var/tmp/diff_new_pack.xemgOs/_old  2019-09-13 15:05:07.297259246 +0200
+++ /var/tmp/diff_new_pack.xemgOs/_new  2019-09-13 15:05:07.301259245 +0200
@@ -12,30 +12,31 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-dephell-specifier
-Version:0.1.5
+Version:0.2.1
 Release:0
-License:MIT
 Summary:Dephell library for Python package version specifiers
-Url:https://github.com/dephell/dephell_specifier
+License:MIT
 Group:  Development/Languages/Python
-Source: 
https://files.pythonhosted.org/packages/source/d/dephell-specifier/dephell_specifier-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
+URL:https://github.com/dephell/dephell_specifier
+Source: 
https://files.pythonhosted.org/packages/source/d/dephell_specifier/dephell_specifier-%{version}.tar.gz
 BuildRequires:  %{python_module base >= 3.5}
 BuildRequires:  %{python_module setuptools}
-# SECTION test requirements
-BuildRequires:  %{python_module packaging}
-# /SECTION
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-base >= 3.5
 Requires:   python-packaging
 BuildArch:  noarch
-
+# SECTION test requirements
+BuildRequires:  %{python_module packaging >= 17.1}
+BuildRequires:  %{python_module pytest}
+# /SECTION
 %python_subpackages
 
 %description
@@ -51,6 +52,9 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+%pytest
+
 %files %{python_files}
 %license LICENSE
 %doc README.md

++ dephell_specifier-0.1.5.tar.gz -> dephell_specifier-0.2.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_specifier-0.1.5/PKG-INFO 
new/dephell_specifier-0.2.1/PKG-INFO
--- old/dephell_specifier-0.1.5/PKG-INFO1970-01-01 01:00:00.0 
+0100
+++ new/dephell_specifier-0.2.1/PKG-INFO1970-01-01 01:00:00.0 
+0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
-Name: dephell_specifier
-Version: 0.1.5
+Name: dephell-specifier
+Version: 0.2.1
 Summary: Work with version specifiers.
 Author: orsinium
 Requires-Python: >=3.5
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/dephell_specifier-0.1.5/dephell_specifier/constants.py 
new/dephell_specifier-0.2.1/dephell_specifier/constants.py
--- old/dephell_specifier-0.1.5/dephell_specifier/constants.py  2019-03-20 
14:09:31.0 +0100
+++ new/dephell_specifier-0.2.1/dephell_specifier/constants.py  2019-07-07 
17:57:48.0 +0200
@@ -12,3 +12,5 @@
 PYTHONS_POPULAR = ('3.5', '3.6', '3.7')
 PYTHONS_UNRELEASED = ('3.8', '4.0')
 PYTHONS = PYTHONS_POPULAR + PYTHONS_DEPRECATED + PYTHONS_UNRELEASED
+
+OPERATOR_SYMBOLS = '!><=[]()~^,'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/dephell_specifier-0.1.5/dephell_specifier/range_specifier.py 
new/dephell_specifier-0.2.1/dephell_specifier/range_specifier.py
--- old/dephell_specifier-0.1.5/dephell_specifier/range_specifier.py
2019-04-21 09:26:43.0 +0200
+++ new/dephell_specifier-0.2.1/dephell_specifier/range_specifier.py
2019-07-07 17:57:48.0 +0200
@@ -1,13 +1,20 @@
+import re
+from typing import Set, List
+
 # external
 from packaging.specifiers import InvalidSpecifier
 from packaging.version import LegacyVersion, parse, Version
 
 # app
-from .constants 

commit python-dephell-shells for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dephell-shells for 
openSUSE:Factory checked in at 2019-09-13 15:03:37

Comparing /work/SRC/openSUSE:Factory/python-dephell-shells (Old)
 and  /work/SRC/openSUSE:Factory/.python-dephell-shells.new.7948 (New)


Package is "python-dephell-shells"

Fri Sep 13 15:03:37 2019 rev:2 rq:730643 version:0.1.3

Changes:

--- 
/work/SRC/openSUSE:Factory/python-dephell-shells/python-dephell-shells.changes  
2019-08-13 13:26:56.981328619 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dephell-shells.new.7948/python-dephell-shells.changes
2019-09-13 15:05:07.585259184 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 09:03:07 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.1.3:
+  * distribute tests
+
+---

Old:

  dephell_shells-0.1.2.tar.gz

New:

  dephell_shells-0.1.3.tar.gz



Other differences:
--
++ python-dephell-shells.spec ++
--- /var/tmp/diff_new_pack.0mH10c/_old  2019-09-13 15:05:08.277259037 +0200
+++ /var/tmp/diff_new_pack.0mH10c/_new  2019-09-13 15:05:08.277259037 +0200
@@ -12,33 +12,34 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-dephell-shells
-Version:0.1.2
+Version:0.1.3
 Release:0
-License:MIT
 Summary:Dephell plugin to activate virtual environment for the current 
shell
-Url:https://github.com/dephell/dephell_shells
+License:MIT
 Group:  Development/Languages/Python
-Source: 
https://files.pythonhosted.org/packages/source/d/dephell-shells/dephell_shells-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
+URL:https://github.com/dephell/dephell_shells
+Source: 
https://files.pythonhosted.org/packages/source/d/dephell_shells/dephell_shells-%{version}.tar.gz
 BuildRequires:  %{python_module base >= 3.5}
 BuildRequires:  %{python_module setuptools}
-# SECTION test requirements
-BuildRequires:  %{python_module attrs}
-BuildRequires:  %{python_module pexpect}
-BuildRequires:  %{python_module shellingham}
-# /SECTION
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-attrs
 Requires:   python-pexpect
 Requires:   python-shellingham
 BuildArch:  noarch
-
+# SECTION test requirements
+BuildRequires:  %{python_module attrs}
+BuildRequires:  %{python_module pexpect}
+BuildRequires:  %{python_module pytest}
+BuildRequires:  %{python_module shellingham}
+# /SECTION
 %python_subpackages
 
 %description
@@ -54,6 +55,10 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+# name and path expect the default shell to be bash
+%pytest -k 'not test_name and not test_path'
+
 %files %{python_files}
 %license LICENSE
 %doc README.md

++ dephell_shells-0.1.2.tar.gz -> dephell_shells-0.1.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_shells-0.1.2/PKG-INFO 
new/dephell_shells-0.1.3/PKG-INFO
--- old/dephell_shells-0.1.2/PKG-INFO   1970-01-01 01:00:00.0 +0100
+++ new/dephell_shells-0.1.3/PKG-INFO   1970-01-01 01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
-Name: dephell_shells
-Version: 0.1.2
+Name: dephell-shells
+Version: 0.1.3
 Summary: activate virtual environment for current shell
 Project-URL: Repository, https://github.com/dephell/dephell_venvs
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/dephell_shells-0.1.2/dephell_shells.egg-info/PKG-INFO 
new/dephell_shells-0.1.3/dephell_shells.egg-info/PKG-INFO
--- old/dephell_shells-0.1.2/dephell_shells.egg-info/PKG-INFO   1970-01-01 
01:00:00.0 +0100
+++ new/dephell_shells-0.1.3/dephell_shells.egg-info/PKG-INFO   1970-01-01 
01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
-Name: dephell_shells
-Version: 0.1.2
+Name: dephell-shells
+Version: 0.1.3
 Summary: activate virtual environment for current shell
 Project-URL: Repository, https://github.com/dephell/dephell_venvs
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell_shells-0.1.2/setup.py 
new/dephell_shells-0.1.3/setup.py
--- old/dephell_shells-0.1.2/setup.py   2019-05-19 14:56:13.0 +0200
+++ new/dephell_shells-0.1.3/setup.py   2019-05-23 20:43:22.0 +0200
@@ -13,13 +13,15 @@
 
 readme = ''
 

commit python-dephell-archive for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-dephell-archive for 
openSUSE:Factory checked in at 2019-09-13 15:03:52

Comparing /work/SRC/openSUSE:Factory/python-dephell-archive (Old)
 and  /work/SRC/openSUSE:Factory/.python-dephell-archive.new.7948 (New)


Package is "python-dephell-archive"

Fri Sep 13 15:03:52 2019 rev:2 rq:730651 version:0.1.5

Changes:

--- 
/work/SRC/openSUSE:Factory/python-dephell-archive/python-dephell-archive.changes
2019-08-13 13:26:35.697334220 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-dephell-archive.new.7948/python-dephell-archive.changes
  2019-09-13 15:05:14.361257744 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 09:20:12 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.1.5:
+  * ship tests
+
+---

Old:

  dephell-archive-0.1.4.tar.gz

New:

  dephell-archive-0.1.5.tar.gz



Other differences:
--
++ python-dephell-archive.spec ++
--- /var/tmp/diff_new_pack.Bcq67t/_old  2019-09-13 15:05:15.033257601 +0200
+++ /var/tmp/diff_new_pack.Bcq67t/_new  2019-09-13 15:05:15.033257601 +0200
@@ -12,29 +12,30 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-dephell-archive
-Version:0.1.4
+Version:0.1.5
 Release:0
-License:MIT
 Summary:Pathlib for archives
-Url:https://github.com/dephell/dephell_archive
+License:MIT
 Group:  Development/Languages/Python
+URL:https://github.com/dephell/dephell_archive
 Source: 
https://files.pythonhosted.org/packages/source/d/dephell-archive/dephell-archive-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
 BuildRequires:  %{python_module base >= 3.5}
 BuildRequires:  %{python_module setuptools}
-# SECTION test requirements
-BuildRequires:  %{python_module attrs}
-# /SECTION
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-attrs
 BuildArch:  noarch
-
+# SECTION test requirements
+BuildRequires:  %{python_module attrs}
+BuildRequires:  %{python_module pytest}
+# /SECTION
 %python_subpackages
 
 %description
@@ -50,6 +51,9 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+%pytest
+
 %files %{python_files}
 %license LICENSE
 %doc README.md

++ dephell-archive-0.1.4.tar.gz -> dephell-archive-0.1.5.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dephell-archive-0.1.4/PKG-INFO 
new/dephell-archive-0.1.5/PKG-INFO
--- old/dephell-archive-0.1.4/PKG-INFO  1970-01-01 01:00:00.0 +0100
+++ new/dephell-archive-0.1.5/PKG-INFO  1970-01-01 01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: dephell-archive
-Version: 0.1.4
+Version: 0.1.5
 Summary: pathlib for archives
 Project-URL: Repository, https://github.com/dephell/dephell_archive
 Author: Gram
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/dephell-archive-0.1.4/dephell-archive.egg-info/PKG-INFO 
new/dephell-archive-0.1.5/dephell-archive.egg-info/PKG-INFO
--- old/dephell-archive-0.1.4/dephell-archive.egg-info/PKG-INFO 1970-01-01 
01:00:00.0 +0100
+++ new/dephell-archive-0.1.5/dephell-archive.egg-info/PKG-INFO 1970-01-01 
01:00:00.0 +0100
@@ -1,82 +0,0 @@
-Metadata-Version: 2.1
-Name: dephell-archive
-Version: 0.1.4
-Summary: pathlib for archives
-Project-URL: Repository, https://github.com/dephell/dephell_archive
-Author: Gram
-Author-email: master_f...@mail.ru
-License: MIT
-Requires-Python: >=3.5
-Keywords: dephell,pathlib,archive,tar,zip,wheel,sdist
-Classifier: Development Status :: 4 - Beta
-Classifier: Environment :: Console
-Classifier: Intended Audience :: Developers
-Classifier: License :: OSI Approved :: MIT License
-Classifier: Programming Language :: Python
-Classifier: Topic :: Software Development :: Libraries :: Python Modules
-Classifier: Topic :: System :: Archiving :: Packaging
-Classifier: Topic :: System :: Archiving
-Classifier: Topic :: System :: Filesystems
-Classifier: Programming Language :: Python :: 3.5
-Classifier: Programming Language :: Python :: 3.6
-Classifier: Programming Language :: Python :: 3.7
-Classifier: Programming Language :: Python :: 3.8
-Classifier: Programming Language :: Python :: Implementation :: CPython
-Classifier: Programming Language :: Python :: Implementation :: PyPy
-Classifier: Operating 

commit python-deprecation for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-deprecation for 
openSUSE:Factory checked in at 2019-09-13 15:03:34

Comparing /work/SRC/openSUSE:Factory/python-deprecation (Old)
 and  /work/SRC/openSUSE:Factory/.python-deprecation.new.7948 (New)


Package is "python-deprecation"

Fri Sep 13 15:03:34 2019 rev:4 rq:730639 version:2.0.7

Changes:

--- /work/SRC/openSUSE:Factory/python-deprecation/python-deprecation.changes
2019-03-10 09:35:53.836168742 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-deprecation.new.7948/python-deprecation.changes
  2019-09-13 15:05:05.617259603 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 08:56:51 UTC 2019 - Tomáš Chvátal 
+
+- Update to 2.0.7:
+  * no upstream changelog
+
+---

Old:

  deprecation-2.0.6.tar.gz

New:

  deprecation-2.0.7.tar.gz



Other differences:
--
++ python-deprecation.spec ++
--- /var/tmp/diff_new_pack.WbZlqc/_old  2019-09-13 15:05:06.421259432 +0200
+++ /var/tmp/diff_new_pack.WbZlqc/_new  2019-09-13 15:05:06.421259432 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-deprecation
-Version:2.0.6
+Version:2.0.7
 Release:0
 Summary:A library to handle automated deprecations
 License:Apache-2.0

++ deprecation-2.0.6.tar.gz -> deprecation-2.0.7.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/deprecation-2.0.6/MANIFEST.in 
new/deprecation-2.0.7/MANIFEST.in
--- old/deprecation-2.0.6/MANIFEST.in   2018-05-06 17:32:55.0 +0200
+++ new/deprecation-2.0.7/MANIFEST.in   2019-08-13 00:03:16.0 +0200
@@ -1,2 +1,3 @@
 include LICENSE
 include tests/*.py
+graft docs
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/deprecation-2.0.6/PKG-INFO 
new/deprecation-2.0.7/PKG-INFO
--- old/deprecation-2.0.6/PKG-INFO  2018-09-26 23:43:06.0 +0200
+++ new/deprecation-2.0.7/PKG-INFO  2019-08-13 00:08:50.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.2
 Name: deprecation
-Version: 2.0.6
+Version: 2.0.7
 Summary: A library to handle automated deprecations
 Home-page: http://deprecation.readthedocs.io/
 Author: Brian Curtin
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/deprecation-2.0.6/deprecation.egg-info/PKG-INFO 
new/deprecation-2.0.7/deprecation.egg-info/PKG-INFO
--- old/deprecation-2.0.6/deprecation.egg-info/PKG-INFO 2018-09-26 
23:43:06.0 +0200
+++ new/deprecation-2.0.7/deprecation.egg-info/PKG-INFO 2019-08-13 
00:08:50.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.2
 Name: deprecation
-Version: 2.0.6
+Version: 2.0.7
 Summary: A library to handle automated deprecations
 Home-page: http://deprecation.readthedocs.io/
 Author: Brian Curtin
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/deprecation-2.0.6/deprecation.egg-info/SOURCES.txt 
new/deprecation-2.0.7/deprecation.egg-info/SOURCES.txt
--- old/deprecation-2.0.6/deprecation.egg-info/SOURCES.txt  2018-09-26 
23:43:06.0 +0200
+++ new/deprecation-2.0.7/deprecation.egg-info/SOURCES.txt  2019-08-13 
00:08:50.0 +0200
@@ -9,5 +9,10 @@
 deprecation.egg-info/dependency_links.txt
 deprecation.egg-info/requires.txt
 deprecation.egg-info/top_level.txt
+docs/Makefile
+docs/conf.py
+docs/index.rst
+docs/sample.py
+docs/sample.rst
 tests/__init__.py
 tests/test_deprecation.py
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/deprecation-2.0.6/deprecation.py 
new/deprecation-2.0.7/deprecation.py
--- old/deprecation-2.0.6/deprecation.py2018-09-26 23:42:03.0 
+0200
+++ new/deprecation-2.0.7/deprecation.py2019-08-13 00:03:16.0 
+0200
@@ -16,7 +16,7 @@
 
 from packaging import version
 
-__version__ = "2.0.6"
+__version__ = "2.0.7"
 
 # This is mostly here so automodule docs are ordered more ideally.
 __all__ = ["deprecated", "message_location", "fail_if_not_removed",
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/deprecation-2.0.6/docs/Makefile 
new/deprecation-2.0.7/docs/Makefile
--- old/deprecation-2.0.6/docs/Makefile 1970-01-01 01:00:00.0 +0100
+++ new/deprecation-2.0.7/docs/Makefile 2019-03-27 16:31:24.0 +0100
@@ -0,0 +1,20 @@
+# Minimal makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS=
+SPHINXBUILD   = sphinx-build
+SPHINXPROJ= deprecation
+SOURCEDIR = .
+BUILDDIR  = _build
+
+# Put it first so 

commit python-fire for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-fire for openSUSE:Factory 
checked in at 2019-09-13 15:02:51

Comparing /work/SRC/openSUSE:Factory/python-fire (Old)
 and  /work/SRC/openSUSE:Factory/.python-fire.new.7948 (New)


Package is "python-fire"

Fri Sep 13 15:02:51 2019 rev:6 rq:730554 version:0.2.1

Changes:

--- /work/SRC/openSUSE:Factory/python-fire/python-fire.changes  2019-07-30 
12:39:38.130931283 +0200
+++ /work/SRC/openSUSE:Factory/.python-fire.new.7948/python-fire.changes
2019-09-13 15:04:19.233269463 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 07:44:29 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.2.1:
+  * Improves robustness of docstring parser in the face of unexpected format 
docstrings. #183
+
+---

Old:

  fire-0.2.0.tar.gz

New:

  fire-0.2.1.tar.gz



Other differences:
--
++ python-fire.spec ++
--- /var/tmp/diff_new_pack.HTh9cD/_old  2019-09-13 15:04:19.693269365 +0200
+++ /var/tmp/diff_new_pack.HTh9cD/_new  2019-09-13 15:04:19.697269364 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-fire
-Version:0.2.0
+Version:0.2.1
 Release:0
 Summary:A library for automatically generating command line interfaces
 License:Apache-2.0

++ fire-0.2.0.tar.gz -> fire-0.2.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fire-0.2.0/PKG-INFO new/fire-0.2.1/PKG-INFO
--- old/fire-0.2.0/PKG-INFO 2019-07-26 19:24:16.0 +0200
+++ new/fire-0.2.1/PKG-INFO 2019-08-01 20:21:19.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: fire
-Version: 0.2.0
+Version: 0.2.1
 Summary: A library for automatically generating command line interfaces.
 Home-page: https://github.com/google/python-fire
 Author: David Bieber
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fire-0.2.0/fire/__init__.py 
new/fire-0.2.1/fire/__init__.py
--- old/fire-0.2.0/fire/__init__.py 2019-07-26 19:14:05.0 +0200
+++ new/fire-0.2.1/fire/__init__.py 2019-08-01 20:19:04.0 +0200
@@ -21,4 +21,4 @@
 from fire.core import Fire
 
 __all__ = ['Fire']
-__version__ = '0.2.0'
+__version__ = '0.2.1'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fire-0.2.0/fire/docstrings.py 
new/fire-0.2.1/fire/docstrings.py
--- old/fire-0.2.0/fire/docstrings.py   2019-07-26 19:14:05.0 +0200
+++ new/fire-0.2.1/fire/docstrings.py   2019-08-01 20:19:04.0 +0200
@@ -188,14 +188,9 @@
   yields = _join_lines(state.yields.lines)
   raises = _join_lines(state.raises.lines)
 
-  args = [
-  ArgInfo(
-  name=arg.name,
-  type=_cast_to_known_type(_join_lines(arg.type.lines)),
-  description=_join_lines(arg.description.lines),
-  )
-  for arg in state.args
-  ]
+  args = [ArgInfo(
+  name=arg.name, type=_cast_to_known_type(_join_lines(arg.type.lines)),
+  description=_join_lines(arg.description.lines)) for arg in state.args]
 
   return DocstringInfo(
   summary=summary,
@@ -503,10 +498,12 @@
   line_info.remaining_raw = line_info.line
   line_info.remaining = line_info.stripped
   line_info.indentation = len(line) - len(line.lstrip())
+  # TODO(dbieber): If next_line is blank, use the next non-blank line.
   line_info.next.line = next_line
-  line_info.next.stripped = next_line.strip() if next_line else None
+  next_line_exists = next_line is not None
+  line_info.next.stripped = next_line.strip() if next_line_exists else None
   line_info.next.indentation = (
-  len(next_line) - len(next_line.lstrip()) if next_line else None)
+  len(next_line) - len(next_line.lstrip()) if next_line_exists else None)
   # Note: This counts all whitespace equally.
   return line_info
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fire-0.2.0/fire/docstrings_test.py 
new/fire-0.2.1/fire/docstrings_test.py
--- old/fire-0.2.0/fire/docstrings_test.py  2019-07-26 19:14:05.0 
+0200
+++ new/fire-0.2.1/fire/docstrings_test.py  2019-08-01 20:19:04.0 
+0200
@@ -34,7 +34,7 @@
 expected_docstring_info = DocstringInfo(
 summary='A simple one line docstring.',
 )
-self.assertEqual(docstring_info, expected_docstring_info)
+self.assertEqual(expected_docstring_info, docstring_info)
 
   def test_one_line_simple_whitespace(self):
 docstring = """
@@ -44,7 +44,7 @@
 expected_docstring_info = DocstringInfo(
 summary='A simple one line docstring.',
 )
-self.assertEqual(docstring_info, 

commit calibre for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package calibre for openSUSE:Factory checked 
in at 2019-09-13 15:02:58

Comparing /work/SRC/openSUSE:Factory/calibre (Old)
 and  /work/SRC/openSUSE:Factory/.calibre.new.7948 (New)


Package is "calibre"

Fri Sep 13 15:02:58 2019 rev:216 rq:730599 version:3.48.0

Changes:

--- /work/SRC/openSUSE:Factory/calibre/calibre.changes  2019-09-04 
09:11:47.666967737 +0200
+++ /work/SRC/openSUSE:Factory/.calibre.new.7948/calibre.changes
2019-09-13 15:04:38.953265271 +0200
@@ -1,0 +2,12 @@
+Fri Sep 13 07:26:08 UTC 2019 - ec...@opensuse.org
+
+- Update to 3.48.0
+  New Features
+  - Driver for Kobo Libra H2O
+  Bug Fixes
+  - kobo driver: Fix some annotations getting missed for kepubs
+  Improved news sources
+  - Boston Globe
+  - Scientific American
+
+---

Old:

  calibre-3.47.1.tar.xz
  calibre-3.47.1.tar.xz.sig

New:

  calibre-3.48.0.tar.xz
  calibre-3.48.0.tar.xz.sig



Other differences:
--
++ calibre.spec ++
--- /var/tmp/diff_new_pack.WlBaPF/_old  2019-09-13 15:04:39.969265055 +0200
+++ /var/tmp/diff_new_pack.WlBaPF/_new  2019-09-13 15:04:39.969265055 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   calibre
-Version:3.47.1
+Version:3.48.0
 Release:0
 Summary:EBook Management Application
 License:GPL-3.0-only

++ calibre-3.47.1.tar.xz -> calibre-3.48.0.tar.xz ++
/work/SRC/openSUSE:Factory/calibre/calibre-3.47.1.tar.xz 
/work/SRC/openSUSE:Factory/.calibre.new.7948/calibre-3.48.0.tar.xz differ: char 
25, line 1





commit librsync for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package librsync for openSUSE:Factory 
checked in at 2019-09-13 15:02:38

Comparing /work/SRC/openSUSE:Factory/librsync (Old)
 and  /work/SRC/openSUSE:Factory/.librsync.new.7948 (New)


Package is "librsync"

Fri Sep 13 15:02:38 2019 rev:25 rq:730530 version:2.1.0

Changes:

--- /work/SRC/openSUSE:Factory/librsync/librsync.changes2015-04-05 
02:02:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.librsync.new.7948/librsync.changes  
2019-09-13 15:04:12.221270954 +0200
@@ -1,0 +2,11 @@
+Fri Sep 13 07:20:41 UTC 2019 - Tomáš Chvátal 
+
+- Update to 2.1.0:
+- Remove no longer applicable patches:
+  * blake2-config.patch
+  * librsync-0.9.7-getopt.patch
+  * librsync-0.9.7-strictalias.diff
+  * librsync-exports.patch
+  * librsync-man-example.diff
+
+---

Old:

  blake2-config.patch
  librsync-0.9.7-getopt.patch
  librsync-0.9.7-strictalias.diff
  librsync-exports.patch
  librsync-man-example.diff
  v1.0.0.tar.gz

New:

  v2.1.0.tar.gz



Other differences:
--
++ librsync.spec ++
--- /var/tmp/diff_new_pack.jQsieu/_old  2019-09-13 15:04:13.797270619 +0200
+++ /var/tmp/diff_new_pack.jQsieu/_new  2019-09-13 15:04:13.801270618 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package librsync
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,29 +12,24 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 %define lname   librsync2
 Name:   librsync
-Version:1.0.0
+Version:2.1.0
 Release:0
 Summary:A Library for Generating Network Deltas
-License:LGPL-2.1+
+License:LGPL-2.1-or-later
 Group:  Development/Libraries/C and C++
-Url:http://librsync.sourceforge.net/
+URL:https://github.com/librsync/librsync
 Source: https://github.com/librsync/%{name}/archive/v%{version}.tar.gz
-Patch0: librsync-0.9.7-strictalias.diff
-Patch1: librsync-man-example.diff
-Patch2: librsync-0.9.7-getopt.patch
-Patch3: librsync-exports.patch
-Patch4: blake2-config.patch
-BuildRequires:  libbz2-devel
-BuildRequires:  libtool
-BuildRequires:  popt-devel
-BuildRequires:  zlib-devel
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  cmake
+BuildRequires:  pkgconfig
+BuildRequires:  pkgconfig(bzip2)
+BuildRequires:  pkgconfig(popt)
+BuildRequires:  pkgconfig(zlib)
 
 %description
 librsync implements the "rsync" algorithm, which allows remote
@@ -44,8 +39,8 @@
 
 %package -n %{lname}
 Summary:A Library for Generating Network Deltas
-Group:  System/Libraries
 # O/P added 2011-11-26
+Group:  System/Libraries
 Obsoletes:  librsync < %{version}-%{release}
 Provides:   librsync = %{version}-%{release}
 
@@ -75,44 +70,33 @@
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %build
-autoreconf -fvi
-%configure \
-   --enable-shared \
-   --disable-static \
-   --with-pic
-make %{?_smp_mflags}
+%cmake \
+  -DENABLE_COMPRESSION=ON
+%cmake_build
 
 %install
-make DESTDIR=%{buildroot} install %{?_smp_mflags}
-rm %{buildroot}%{_libdir}/*.la
+%cmake_install
 
 %check
-make %{?_smp_mflags} check
+export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
+%ctest
 
 %post -n %{lname} -p /sbin/ldconfig
-
 %postun -n %{lname} -p /sbin/ldconfig
 
 %files -n %{lname}
-%defattr(-,root,root)
 %{_libdir}/librsync.so.*
-%doc AUTHORS COPYING NEWS README.md THANKS TODO.md
+%license COPYING
+%doc AUTHORS NEWS.md README.md THANKS TODO.md
 
 %files devel
-%defattr(-,root,root)
 %{_libdir}/librsync.so
 %{_mandir}/man3/*
 %{_includedir}/*.h
 
 %files -n rdiff
-%defattr(-,root,root)
 %{_bindir}/rdiff
 %{_mandir}/man1/*
 

++ v1.0.0.tar.gz -> v2.1.0.tar.gz ++
 31081 lines of diff (skipped)




commit python-flake8-comprehensions for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-flake8-comprehensions for 
openSUSE:Factory checked in at 2019-09-13 15:02:44

Comparing /work/SRC/openSUSE:Factory/python-flake8-comprehensions (Old)
 and  /work/SRC/openSUSE:Factory/.python-flake8-comprehensions.new.7948 
(New)


Package is "python-flake8-comprehensions"

Fri Sep 13 15:02:44 2019 rev:2 rq:730532 version:2.2.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-flake8-comprehensions/python-flake8-comprehensions.changes
2019-08-19 21:26:54.148652220 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-flake8-comprehensions.new.7948/python-flake8-comprehensions.changes
  2019-09-13 15:04:16.317270083 +0200
@@ -1,0 +2,7 @@
+Fri Sep 13 07:29:08 UTC 2019 - Tomáš Chvátal 
+
+- Update to 2.2.0:
+  * Update Python support to 3.5-3.7, as 3.4 has reached its end of life.
+  * C412 rule that complains about using list comprehension with in.
+
+---

Old:

  2.1.0.tar.gz

New:

  2.2.0.tar.gz



Other differences:
--
++ python-flake8-comprehensions.spec ++
--- /var/tmp/diff_new_pack.MPKC5r/_old  2019-09-13 15:04:16.805269980 +0200
+++ /var/tmp/diff_new_pack.MPKC5r/_new  2019-09-13 15:04:16.809269979 +0200
@@ -19,7 +19,7 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-flake8-comprehensions
-Version:2.1.0
+Version:2.2.0
 Release:0
 Summary:A flake8 plugin to help you write better list/set/dict 
comprehensions
 License:ISC

++ 2.1.0.tar.gz -> 2.2.0.tar.gz ++
 1827 lines of diff (skipped)




commit python-fakeredis for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-fakeredis for 
openSUSE:Factory checked in at 2019-09-13 15:03:02

Comparing /work/SRC/openSUSE:Factory/python-fakeredis (Old)
 and  /work/SRC/openSUSE:Factory/.python-fakeredis.new.7948 (New)


Package is "python-fakeredis"

Fri Sep 13 15:03:02 2019 rev:3 rq:730624 version:1.0.5

Changes:

--- /work/SRC/openSUSE:Factory/python-fakeredis/python-fakeredis.changes
2019-08-22 10:55:56.973671082 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-fakeredis.new.7948/python-fakeredis.changes  
2019-09-13 15:04:40.153265016 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 07:55:04 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.0.5:
+  * No upstream changelog
+
+---

Old:

  fakeredis-1.0.4.tar.gz

New:

  fakeredis-1.0.5.tar.gz



Other differences:
--
++ python-fakeredis.spec ++
--- /var/tmp/diff_new_pack.LdFRRQ/_old  2019-09-13 15:04:40.649264911 +0200
+++ /var/tmp/diff_new_pack.LdFRRQ/_new  2019-09-13 15:04:40.649264911 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-fakeredis
-Version:1.0.4
+Version:1.0.5
 Release:0
 Summary:Fake implementation of redis API for testing purposes
 License:BSD-3-Clause AND MIT
@@ -37,7 +37,6 @@
 Suggests:   python-lupa
 BuildArch:  noarch
 # SECTION test requirements
-# bug in https://github.com/jamesls/fakeredis/issues/235
 BuildRequires:  %{python_module future}
 BuildRequires:  %{python_module lupa}
 BuildRequires:  %{python_module redis}

++ fakeredis-1.0.4.tar.gz -> fakeredis-1.0.5.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fakeredis-1.0.4/PKG-INFO new/fakeredis-1.0.5/PKG-INFO
--- old/fakeredis-1.0.4/PKG-INFO2019-08-14 11:55:44.0 +0200
+++ new/fakeredis-1.0.5/PKG-INFO2019-09-05 11:51:08.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: fakeredis
-Version: 1.0.4
+Version: 1.0.5
 Summary: Fake implementation of redis API for testing purposes.
 Home-page: https://github.com/jamesls/fakeredis
 Author: James Saryerwinnie
@@ -233,7 +233,6 @@
  * object
  * restore
  * touch
- * unlink
  * wait
 
 
@@ -381,6 +380,12 @@
 Revision history
 
 
+1.0.5
+-
+- `#247 `_ Support 
NX/XX/CH flags in ZADD command
+- `#250 `_ Implement 
UNLINK command
+- `#252 `_ Fix 
implementation of ZSCAN
+
 1.0.4
 -
 - `#240 `_ `#242 
`_ Support for ``redis==3.3``
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fakeredis-1.0.4/README.rst 
new/fakeredis-1.0.5/README.rst
--- old/fakeredis-1.0.4/README.rst  2019-08-14 11:31:28.0 +0200
+++ new/fakeredis-1.0.5/README.rst  2019-09-05 11:38:09.0 +0200
@@ -223,7 +223,6 @@
  * object
  * restore
  * touch
- * unlink
  * wait
 
 
@@ -371,6 +370,12 @@
 Revision history
 
 
+1.0.5
+-
+- `#247 `_ Support NX/XX/CH 
flags in ZADD command
+- `#250 `_ Implement UNLINK 
command
+- `#252 `_ Fix implementation 
of ZSCAN
+
 1.0.4
 -
 - `#240 `_ `#242 
`_ Support for ``redis==3.3``
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fakeredis-1.0.4/fakeredis/__init__.py 
new/fakeredis-1.0.5/fakeredis/__init__.py
--- old/fakeredis-1.0.4/fakeredis/__init__.py   2019-08-14 11:30:05.0 
+0200
+++ new/fakeredis-1.0.5/fakeredis/__init__.py   2019-09-05 11:38:17.0 
+0200
@@ -1,4 +1,4 @@
 from ._server import FakeServer, FakeRedis, FakeStrictRedis, FakeConnection   
# noqa: F401
 
 
-__version__ = '1.0.4'
+__version__ = '1.0.5'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/fakeredis-1.0.4/fakeredis/_server.py 
new/fakeredis-1.0.5/fakeredis/_server.py
--- old/fakeredis-1.0.4/fakeredis/_server.py2019-08-14 11:07:24.0 
+0200
+++ new/fakeredis-1.0.5/fakeredis/_server.py2019-09-05 11:34:50.0 
+0200
@@ -47,6 +47,7 @@
 SRC_DST_SAME_MSG = 

commit miller for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package miller for openSUSE:Factory checked 
in at 2019-09-13 15:02:35

Comparing /work/SRC/openSUSE:Factory/miller (Old)
 and  /work/SRC/openSUSE:Factory/.miller.new.7948 (New)


Package is "miller"

Fri Sep 13 15:02:35 2019 rev:7 rq:730525 version:5.6.0

Changes:

--- /work/SRC/openSUSE:Factory/miller/miller.changes2019-09-02 
13:26:33.197298836 +0200
+++ /work/SRC/openSUSE:Factory/.miller.new.7948/miller.changes  2019-09-13 
15:04:06.933272078 +0200
@@ -1,0 +2,33 @@
+Fri Sep 13 05:54:23 UTC 2019 - Luigi Baldoni 
+
+- Update to version 5.6.0
+  Features:
+  * The new system DSL function allows you to run arbitrary
+shell commands and store them in field values. Some example
+usages are documented here. This is in response to issues #246
+and #209.
+  * There is now support for ASV and USV file formats. This is
+in response to issue #245.
+  * The new format-values verb allows you to apply numerical
+formatting across all record values. This is in response to
+issue #252.
+  Documentation:
+  * The new DKVP I/O in Python sample code now works for Python
+2 as well as Python 3.
+  * There is a new cookbook entry on doing multiple joins. This
+is in response to issue #235.
+  Bugfixes:
+  * The toupper, tolower, and capitalize DSL functions are now
+UTF-8 aware, thanks to @sheredom's marvelous
+https://github.com/sheredom/utf8.h. The internationalization
+page has also been expanded. This is in response to issue #254.
+  * #250 fixes a bug using in-place mode in conjunction with
+verbs (such as rename or sort) which take field-name lists as
+arguments.
+  * #253 fixes a bug in the label when one or more names are
+common between old and new.
+  * #251 fixes a corner-case bug when (a) input is CSV; (b) the
+last field ends with a comma and no newline; (c) input is from
+standard input and/or --no-mmap is supplied.
+
+---

Old:

  miller-5.5.0.tar.gz

New:

  miller-5.6.0.tar.gz



Other differences:
--
++ miller.spec ++
--- /var/tmp/diff_new_pack.BJ6dWD/_old  2019-09-13 15:04:07.925271867 +0200
+++ /var/tmp/diff_new_pack.BJ6dWD/_new  2019-09-13 15:04:07.925271867 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   miller
-Version:5.5.0
+Version:5.6.0
 Release:0
 Summary:Name-indexed data processing tool
 # c/lib/netbsd_strptime.c is BSD-4-Clause

++ miller-5.5.0.tar.gz -> miller-5.6.0.tar.gz ++
 9864 lines of diff (skipped)




commit bazel0.19 for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package bazel0.19 for openSUSE:Factory 
checked in at 2019-09-13 15:02:46

Comparing /work/SRC/openSUSE:Factory/bazel0.19 (Old)
 and  /work/SRC/openSUSE:Factory/.bazel0.19.new.7948 (New)


Package is "bazel0.19"

Fri Sep 13 15:02:46 2019 rev:2 rq:730534 version:0.19.2

Changes:

--- /work/SRC/openSUSE:Factory/bazel0.19/bazel0.19.changes  2019-06-19 
21:08:58.734543049 +0200
+++ /work/SRC/openSUSE:Factory/.bazel0.19.new.7948/bazel0.19.changes
2019-09-13 15:04:17.025269933 +0200
@@ -1,0 +2,5 @@
+Fri Sep 13 07:31:09 UTC 2019 - Christian Goll 
+
+- removed i586 buils as they are failing 
+
+---



Other differences:
--
++ bazel0.19.spec ++
--- /var/tmp/diff_new_pack.QR0xKe/_old  2019-09-13 15:04:18.693269578 +0200
+++ /var/tmp/diff_new_pack.QR0xKe/_new  2019-09-13 15:04:18.697269577 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package bazel19
+# spec file for package bazel0.19
 #
 # Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
@@ -38,10 +38,9 @@
 Provides:   bazel = %{version}
 Conflicts:  bazel > %{version}
 
+ExcludeArch:armv7l i586
+
 %define bashcompdir %(pkg-config --variable=completionsdir bash-completion 
2>/dev/null)
-%ifarch armv7l
-ExclusiveArch:  do_not_build
-%endif
 
 %description
 Tool for the automation of building and testing of software. It supports Java,






commit python-flake8-docstrings for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-flake8-docstrings for 
openSUSE:Factory checked in at 2019-09-13 15:02:40

Comparing /work/SRC/openSUSE:Factory/python-flake8-docstrings (Old)
 and  /work/SRC/openSUSE:Factory/.python-flake8-docstrings.new.7948 (New)


Package is "python-flake8-docstrings"

Fri Sep 13 15:02:40 2019 rev:5 rq:730531 version:1.4.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-flake8-docstrings/python-flake8-docstrings.changes
2019-08-05 10:42:25.995291577 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-flake8-docstrings.new.7948/python-flake8-docstrings.changes
  2019-09-13 15:04:15.141270333 +0200
@@ -1,0 +2,14 @@
+Fri Sep 13 07:26:58 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.4.0:
+  * Add --docstring-convention option which allows selection of conventions
+besides the default pep257.  Available options are based on those
+available from pydocstyle and are currently pep257, google, and
+numpy.  flake8-docstrings also adds a special all docstring
+convention which will enable all rules from pydocstyle.  Note that
+pydocstyle defines some conflicting rules so you'll want to use
+ignore / extend-ignore when selecting docstring-convention = all
+  * Bump minimum flake8 version to 3
+  * Fix proper handling of stdin via --stdin-display-name
+
+---

Old:

  flake8-docstrings-1.3.1.tar.gz

New:

  flake8-docstrings-1.4.0.tar.gz



Other differences:
--
++ python-flake8-docstrings.spec ++
--- /var/tmp/diff_new_pack.MlqnY3/_old  2019-09-13 15:04:16.005270149 +0200
+++ /var/tmp/diff_new_pack.MlqnY3/_new  2019-09-13 15:04:16.009270149 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-flake8-docstrings
-Version:1.3.1
+Version:1.4.0
 Release:0
 Summary:Extension for flake8 which uses pydocstyle to check docstrings
 License:MIT
@@ -28,7 +28,7 @@
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
-Requires:   python-flake8
+Requires:   python-flake8 >= 3
 Requires:   python-flake8-polyfill
 Requires:   python-pydocstyle >= 2.1.0
 BuildArch:  noarch

++ flake8-docstrings-1.3.1.tar.gz -> flake8-docstrings-1.4.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/flake8-docstrings-1.3.1/HISTORY.rst 
new/flake8-docstrings-1.4.0/HISTORY.rst
--- old/flake8-docstrings-1.3.1/HISTORY.rst 2019-08-02 17:29:13.0 
+0200
+++ new/flake8-docstrings-1.4.0/HISTORY.rst 2019-08-26 18:33:14.0 
+0200
@@ -1,6 +1,21 @@
 History/Changelog
 =
 
+1.4.0
+-
+
+- Add ``--docstring-convention`` option which allows selection of conventions
+  besides the default ``pep257``.  Available options are based on those
+  available from ``pydocstyle`` and are currently ``pep257``, ``google``, and
+  ``numpy``.  ``flake8-docstrings`` also adds a special ``all`` docstring
+  convention which will enable all rules from ``pydocstyle``.  Note that
+  ``pydocstyle`` defines some conflicting rules so you'll want to use
+  ``ignore`` / ``extend-ignore`` when selecting ``docstring-convention = all``
+
+- Bump minimum flake8 version to 3
+
+- Fix proper handling of ``stdin`` via ``--stdin-display-name``
+
 1.3.1
 -
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/flake8-docstrings-1.3.1/PKG-INFO 
new/flake8-docstrings-1.4.0/PKG-INFO
--- old/flake8-docstrings-1.3.1/PKG-INFO2019-08-02 17:31:21.0 
+0200
+++ new/flake8-docstrings-1.4.0/PKG-INFO2019-08-26 18:35:25.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.2
 Name: flake8-docstrings
-Version: 1.3.1
+Version: 1.4.0
 Summary: Extension for flake8 which uses pydocstyle to check docstrings
 Home-page: https://gitlab.com/pycqa/flake8-docstrings
 Author: Simon ANDRÉ
@@ -20,16 +20,41 @@
 
 and run flake8.
 
+You can set the pydocstyle convention_ at the command line using::
+
+$ flake8 --docstring-convention numpy ...
+
+Or, adding ``docstring-convention=numpy`` to your flake8 configuration 
file.
+The available set of conventions depends on the version of pydocstyle 
installed.
+The default is ``pep257``, pydocstyle v2.0.0 added ``numpy`` (for the 
numpydoc
+standard), while pydocstyle v4.0.0 added ``google``.
+
 Report any issues on our `bug tracker`_.
 
 .. _pydocstyle: https://github.com/pycqa/pydocstyle
 .. _flake8: 

commit python-emoji for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-emoji for openSUSE:Factory 
checked in at 2019-09-13 15:03:05

Comparing /work/SRC/openSUSE:Factory/python-emoji (Old)
 and  /work/SRC/openSUSE:Factory/.python-emoji.new.7948 (New)


Package is "python-emoji"

Fri Sep 13 15:03:05 2019 rev:5 rq:730625 version:0.5.3

Changes:

--- /work/SRC/openSUSE:Factory/python-emoji/python-emoji.changes
2019-04-30 13:00:37.402169433 +0200
+++ /work/SRC/openSUSE:Factory/.python-emoji.new.7948/python-emoji.changes  
2019-09-13 15:04:40.857264866 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 07:59:56 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.5.3:
+  * no upstream changelog
+
+---

Old:

  emoji-0.5.2.tar.gz

New:

  emoji-0.5.3.tar.gz



Other differences:
--
++ python-emoji.spec ++
--- /var/tmp/diff_new_pack.6xgbAZ/_old  2019-09-13 15:04:41.457264739 +0200
+++ /var/tmp/diff_new_pack.6xgbAZ/_new  2019-09-13 15:04:41.461264738 +0200
@@ -19,7 +19,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-emoji
-Version:0.5.2
+Version:0.5.3
 Release:0
 Summary:Emoji for Python
 License:BSD-3-Clause

++ emoji-0.5.2.tar.gz -> emoji-0.5.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/emoji-0.5.2/PKG-INFO new/emoji-0.5.3/PKG-INFO
--- old/emoji-0.5.2/PKG-INFO2019-04-06 01:11:04.0 +0200
+++ new/emoji-0.5.3/PKG-INFO2019-07-30 19:46:12.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: emoji
-Version: 0.5.2
+Version: 0.5.3
 Summary: Emoji for Python
 Home-page: https://github.com/carpedm20/emoji/
 Author: Taehoon Kim and Kevin Wurster
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/emoji-0.5.2/emoji/__init__.py 
new/emoji-0.5.3/emoji/__init__.py
--- old/emoji-0.5.2/emoji/__init__.py   2019-04-06 01:10:30.0 +0200
+++ new/emoji-0.5.3/emoji/__init__.py   2019-07-30 19:46:04.0 +0200
@@ -25,7 +25,7 @@
 from emoji.unicode_codes import UNICODE_EMOJI
 from emoji.unicode_codes import UNICODE_EMOJI_ALIAS
 
-__version__ = '0.5.2'
+__version__ = '0.5.3'
 __author__ = 'Taehoon Kim and Kevin Wurster'
 __email__ = 'carped...@gmail.com'
 # and wurst...@gmail.com
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/emoji-0.5.2/emoji/core.py 
new/emoji-0.5.3/emoji/core.py
--- old/emoji-0.5.2/emoji/core.py   2019-04-06 01:10:19.0 +0200
+++ new/emoji-0.5.3/emoji/core.py   2019-07-30 19:45:48.0 +0200
@@ -52,11 +52,11 @@
 return pattern.sub(replace, string)
 
 
-def demojize(string, delimiters=(_DEFAULT_DELIMITER,_DEFAULT_DELIMITER)):
+def demojize(string, use_aliases=False, 
delimiters=(_DEFAULT_DELIMITER,_DEFAULT_DELIMITER)):
 
 """Replace unicode emoji in a string with emoji shortcodes. Useful for 
storage.
-
 :param string: String contains unicode characters. MUST BE UNICODE.
+:param use_aliases: (optional) Return emoji aliases.  See 
``emoji.UNICODE_EMOJI_ALIAS``.
 :param delimiters: (optional) User delimiters other than _DEFAULT_DELIMITER
 >>> import emoji
 >>> print(emoji.emojize("Python is fun :thumbs_up:"))
@@ -68,7 +68,8 @@
 """
 
 def replace(match):
-val = unicode_codes.UNICODE_EMOJI.get(match.group(0), match.group(0))
+codes_dict = unicode_codes.UNICODE_EMOJI_ALIAS if use_aliases else 
unicode_codes.UNICODE_EMOJI
+val = codes_dict.get(match.group(0), match.group(0))
 return delimiters[0] + val[1:-1] + delimiters[1]
 
 return re.sub(u'\ufe0f','',(get_emoji_regexp().sub(replace, string)))
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/emoji-0.5.2/emoji/unicode_codes.py 
new/emoji-0.5.3/emoji/unicode_codes.py
--- old/emoji-0.5.2/emoji/unicode_codes.py  2019-04-06 01:10:19.0 
+0200
+++ new/emoji-0.5.3/emoji/unicode_codes.py  2019-07-30 19:45:48.0 
+0200
@@ -351,6 +351,7 @@
 u':Zambia:': u'\U0001F1FF\U0001F1F2',
 u':Zimbabwe:': u'\U0001F1FF\U0001F1FC',
 u':abacus:': u'\U0001F9EE',
+u':adhesive_bandage:': u'\U0001FA79',
 u':admission_tickets:': u'\U0001F39F',
 u':adult:': u'\U0001F9D1',
 u':adult_dark_skin_tone:': u'\U0001F9D1\U0001F3FF',
@@ -381,8 +382,10 @@
 u':artist_palette:': u'\U0001F3A8',
 u':astonished_face:': u'\U0001F632',
 u':atom_symbol:': u'\U269B',
+u':auto_rickshaw:': u'\U0001F6FA',
 u':automobile:': u'\U0001F697',
 u':avocado:': u'\U0001F951',
+u':axe:': u'\U0001FA93',
 u':baby:': 

commit python-fanficfare for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-fanficfare for 
openSUSE:Factory checked in at 2019-09-13 15:02:54

Comparing /work/SRC/openSUSE:Factory/python-fanficfare (Old)
 and  /work/SRC/openSUSE:Factory/.python-fanficfare.new.7948 (New)


Package is "python-fanficfare"

Fri Sep 13 15:02:54 2019 rev:12 rq:730595 version:3.11.0

Changes:

--- /work/SRC/openSUSE:Factory/python-fanficfare/python-fanficfare.changes  
2019-08-06 17:27:27.636686174 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-fanficfare.new.7948/python-fanficfare.changes
2019-09-13 15:04:22.017268871 +0200
@@ -1,0 +2,12 @@
+Fri Sep 13 07:48:06 UTC 2019 - Tomáš Chvátal 
+
+- Update to 3.11.0:
+  * Install attached plugin zip file, or use Calibre's 'Get plugins' feature.
+  * Add URL prefix for XF2 authorUrl if relative. Circa Aug 23, 2019 SV 
changed the author URL FFF collects to a relative link and I didn't notice it 
until now.
+  * Add dedup_chapter_list option for buggy chapter lists. Optional in case 
they're not buggy.
+  * Add fetch_last_page for base_xenforo--SB doesn't send notice emails if 
user not up-to-date now.
+  * Fix for corner-case with deleting Rejects.
+  * Fix for XF1 regression caused by XF2 threadmarks metadata code.
+  * Add XF2 threadmarks_cover/status/desc/title options.
+
+---

Old:

  FanFicFare-3.10.5.tar.gz

New:

  FanFicFare-3.11.0.tar.gz



Other differences:
--
++ python-fanficfare.spec ++
--- /var/tmp/diff_new_pack.Pq376i/_old  2019-09-13 15:04:22.649268737 +0200
+++ /var/tmp/diff_new_pack.Pq376i/_new  2019-09-13 15:04:22.653268736 +0200
@@ -20,7 +20,7 @@
 %define modnamedown fanficfare
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-fanficfare
-Version:3.10.5
+Version:3.11.0
 Release:0
 Summary:Tool for making eBooks from stories on fanfiction and other 
web sites
 License:GPL-3.0-only

++ FanFicFare-3.10.5.tar.gz -> FanFicFare-3.11.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/FanFicFare-3.10.5/calibre-plugin/__init__.py 
new/FanFicFare-3.11.0/calibre-plugin/__init__.py
--- old/FanFicFare-3.10.5/calibre-plugin/__init__.py2019-07-30 
16:06:56.0 +0200
+++ new/FanFicFare-3.11.0/calibre-plugin/__init__.py2019-09-04 
16:44:56.0 +0200
@@ -33,7 +33,7 @@
 from calibre.customize import InterfaceActionBase
 
 # pulled out from FanFicFareBase for saving in prefs.py
-__version__ = (3, 10, 5)
+__version__ = (3, 11, 0)
 
 ## Apparently the name for this class doesn't matter--it was still
 ## 'demo' for the first few versions.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/FanFicFare-3.10.5/calibre-plugin/dialogs.py 
new/FanFicFare-3.11.0/calibre-plugin/dialogs.py
--- old/FanFicFare-3.10.5/calibre-plugin/dialogs.py 2019-07-30 
16:06:56.0 +0200
+++ new/FanFicFare-3.11.0/calibre-plugin/dialogs.py 2019-09-04 
16:44:56.0 +0200
@@ -148,7 +148,7 @@
 
 def to_line(self):
 # always 'url,'
-return self.url+","+self.fullnote()
+return "%s,%s"%(self.url,self.fullnote())
 
 @classmethod
 def from_data(cls,data):
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/FanFicFare-3.10.5/calibre-plugin/plugin-defaults.ini 
new/FanFicFare-3.11.0/calibre-plugin/plugin-defaults.ini
--- old/FanFicFare-3.10.5/calibre-plugin/plugin-defaults.ini2019-07-30 
16:06:56.0 +0200
+++ new/FanFicFare-3.11.0/calibre-plugin/plugin-defaults.ini2019-09-04 
16:44:56.0 +0200
@@ -263,6 +263,10 @@
 # https://forums.spacebattles.com/posts/10157299/
 # 
https://forums.spacebattles.com/threads/lengthy-thread-name.100849/#post-10157400
 
+## Rarely, some stories on some sites (observed on SpaceBattles) might
+## have the same chapter URL listed more than once.  Set true for
+## those stories.
+#dedup_chapter_list:false
 
 ## Some readers don't show horizontal rule () tags correctly.
 ## This replaces them all with a centered '* * *'.  (Note centering
@@ -756,7 +760,36 @@
 # .bbCodeSpoilerContainer { border: 1px solid black; padding: 2px; }
 
 [base_xenforo2forum]
-## So far, only SV. [base_xenforoforum] also applied.
+## [base_xenforoforum] also applied, but [base_xenforo2forum] takes
+## precedence.  SV is the only XF2 site as of Jul 2019.
+
+## Some additional 'thread' metadata entries.
+add_to_extra_valid_entries:,threadmarks_title,threadmarks_description,threadmarks_status
+#add_to_extra_titlepage_entries:,threadmarks_title,threadmarks_description,threadmarks_status
+

commit votca-csg for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package votca-csg for openSUSE:Factory 
checked in at 2019-09-13 15:02:33

Comparing /work/SRC/openSUSE:Factory/votca-csg (Old)
 and  /work/SRC/openSUSE:Factory/.votca-csg.new.7948 (New)


Package is "votca-csg"

Fri Sep 13 15:02:33 2019 rev:13 rq:730484 version:1.5

Changes:

--- /work/SRC/openSUSE:Factory/votca-csg/votca-csg.changes  2019-04-03 
09:28:46.983836944 +0200
+++ /work/SRC/openSUSE:Factory/.votca-csg.new.7948/votca-csg.changes
2019-09-13 15:04:02.457273030 +0200
@@ -1,0 +2,5 @@
+Thu Sep 12 23:25:13 UTC 2019 - Christoph Junghans 
+
+- Disable some more test on i585
+
+---



Other differences:
--
++ votca-csg.spec ++
--- /var/tmp/diff_new_pack.0cid0m/_old  2019-09-13 15:04:04.205272658 +0200
+++ /var/tmp/diff_new_pack.0cid0m/_new  2019-09-13 15:04:04.209272657 +0200
@@ -167,7 +167,7 @@
 #check
 # https://github.com/votca/csg/issues/313
 %ifarch i586
-%global testargs ARGS='-E Compare_csg_fmatch_3body_output1'
+%global testargs ARGS='-E 
\\(Compare_csg_fmatch_3body_output1\\|Compare_csg_fmatch_output\\)'
 %endif
 make -C build test CTEST_OUTPUT_ON_FAILURE=1 %{?testargs:%{testargs}}
 




commit python-fs for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-fs for openSUSE:Factory 
checked in at 2019-09-13 15:02:13

Comparing /work/SRC/openSUSE:Factory/python-fs (Old)
 and  /work/SRC/openSUSE:Factory/.python-fs.new.7948 (New)


Package is "python-fs"

Fri Sep 13 15:02:13 2019 rev:9 rq:730453 version:2.4.11

Changes:

--- /work/SRC/openSUSE:Factory/python-fs/python-fs.changes  2019-07-26 
17:35:21.228064909 +0200
+++ /work/SRC/openSUSE:Factory/.python-fs.new.7948/python-fs.changes
2019-09-13 15:03:50.473275577 +0200
@@ -1,0 +2,15 @@
+Thu Sep 12 12:00:45 UTC 2019 - Tomáš Chvátal 
+
+- Update to 2.4.11:
+  * Restored fs.path import
+  * Fixed potential race condition in makedirs. Fixes #310
+  * Added missing methods to WrapFS. Fixed #294
+  * MemFS now immediately releases all memory it holds when close() is called, 
rather than when it gets garbage collected. Closes issue #308.
+  * FTPFS now translates EOFError into RemoteConnectionError. Closes #292
+  * Added automatic close for filesystems that go out of scope. Fixes #298
+  * Fixed broken WrapFS.movedir #322
+  * Added geturl for TarFS and ZipFS for 'fs' purpose. NoURL for 'download' 
purpose.
+  * Added helpful root path in CreateFailed exception #340
+- remove patch more-relaxed-requirements.patch replaced by sed
+
+---

Old:

  fs-2.4.8.tar.gz
  more-relaxed-requirements.patch

New:

  conftest.py
  fs-2.4.11.tar.gz



Other differences:
--
++ python-fs.spec ++
--- /var/tmp/diff_new_pack.EdXwQV/_old  2019-09-13 15:03:51.125275439 +0200
+++ /var/tmp/diff_new_pack.EdXwQV/_new  2019-09-13 15:03:51.125275439 +0200
@@ -19,21 +19,19 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-fs
-Version:2.4.8
+Version:2.4.11
 Release:0
 Summary:Python's filesystem abstraction layer
 License:MIT
 Group:  Development/Languages/Python
-Url:https://github.com/PyFilesystem/pyfilesystem2
+URL:https://github.com/PyFilesystem/pyfilesystem2
 Source: 
https://files.pythonhosted.org/packages/source/f/fs/fs-%{version}.tar.gz
-# PATCH-FIX-UPSTREAM more-relaxed-requirements.patch sebix+novell@sebix.at 
-- Weaken the version dependencies
-Patch0: more-relaxed-requirements.patch
+Source1:
https://raw.githubusercontent.com/PyFilesystem/pyfilesystem2/master/tests/conftest.py
 BuildRequires:  %{python_module appdirs >= 1.4.3}
-BuildRequires:  %{python_module mock}
-BuildRequires:  %{python_module nose}
 BuildRequires:  %{python_module psutil}
 BuildRequires:  %{python_module pyftpdlib}
 BuildRequires:  %{python_module pysendfile}
+BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module pytz}
 BuildRequires:  %{python_module scandir >= 1.5}
 BuildRequires:  %{python_module setuptools}
@@ -41,6 +39,8 @@
 BuildRequires:  %{python_module typing >= 3.6}
 BuildRequires:  fdupes
 BuildRequires:  python-backports.os >= 0.1
+BuildRequires:  python-enum34 >= 1.1.6
+BuildRequires:  python-mock
 BuildRequires:  python-rpm-macros
 Requires:   python-appdirs >= 1.4.3
 Requires:   python-psutil
@@ -49,8 +49,9 @@
 Requires:   python-six >= 1.10.0
 Requires:   python-typing >= 3.6
 Recommends: python-pyftpdlib
+BuildArch:  noarch
 %ifpython2
-Requires:   python-backports.os
+Requires:   python-backports.os >= 0.1
 %endif
 %if %{python_version_nodots} < 34
 Requires:   python-enum34 >= 1.1.6
@@ -59,8 +60,6 @@
 %if %{python3_version_nodots} < 35
 Recommends: python-scandir >= 1.5
 %endif
-BuildArch:  noarch
-
 %python_subpackages
 
 %description
@@ -72,7 +71,8 @@
 
 %prep
 %setup -q -n fs-%{version}
-%patch0 -p1
+sed -i -e 's:~=:>=:g' setup.py
+cp %{SOURCE1} tests/
 
 %build
 %python_build
@@ -83,7 +83,8 @@
 
 %check
 export LANG=en_US.UTF-8
-%python_exec  setup.py test
+export PYTHONDONTWRITEBYTECODE=1
+%pytest
 
 %files %{python_files}
 %doc README.md

++ conftest.py ++
import pytest

try:
from unittest import mock
except ImportError:
import mock


@pytest.fixture
@mock.patch("appdirs.user_data_dir", autospec=True, spec_set=True)
@mock.patch("appdirs.site_data_dir", autospec=True, spec_set=True)
@mock.patch("appdirs.user_config_dir", autospec=True, spec_set=True)
@mock.patch("appdirs.site_config_dir", autospec=True, spec_set=True)
@mock.patch("appdirs.user_cache_dir", autospec=True, spec_set=True)
@mock.patch("appdirs.user_state_dir", autospec=True, spec_set=True)
@mock.patch("appdirs.user_log_dir", autospec=True, spec_set=True)
def mock_appdir_directories(
user_log_dir_mock,
user_state_dir_mock,
user_cache_dir_mock,

commit yast2-aduc for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package yast2-aduc for openSUSE:Factory 
checked in at 2019-09-13 15:02:22

Comparing /work/SRC/openSUSE:Factory/yast2-aduc (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-aduc.new.7948 (New)


Package is "yast2-aduc"

Fri Sep 13 15:02:22 2019 rev:5 rq:730465 version:1.6

Changes:

--- /work/SRC/openSUSE:Factory/yast2-aduc/yast2-aduc.changes2019-08-01 
15:48:23.885740988 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-aduc.new.7948/yast2-aduc.changes  
2019-09-13 15:03:54.169274791 +0200
@@ -1,0 +2,8 @@
+Thu Sep 12 18:12:56 UTC 2019 - dmul...@suse.com
+
+- Update to 1.6:
+  + Remove the dependency on python-ldap
+  + Module throws exception when smb.conf contains failing include
+  + Unused xset may cause exception in appimage; (bsc#1150612);
+
+---

Old:

  yast2-aduc-1.5.tar.bz2

New:

  yast2-aduc-1.6.tar.bz2



Other differences:
--
++ yast2-aduc.spec ++
--- /var/tmp/diff_new_pack.ABIZT7/_old  2019-09-13 15:03:54.649274689 +0200
+++ /var/tmp/diff_new_pack.ABIZT7/_new  2019-09-13 15:03:54.649274689 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-aduc
-Version:1.5
+Version:1.6
 Release:0
 Summary:Active Directory Users and Computers for YaST
 License:GPL-3.0-only
@@ -35,7 +35,6 @@
 BuildRequires:  rubygem(%rb_default_ruby_abi:yast-rake)
 
 Requires:   krb5-client
-Requires:   python3-ldap
 Requires:   samba-client
 Requires:   samba-python3
 Requires:   yast2

++ yast2-aduc-1.5.tar.bz2 -> yast2-aduc-1.6.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-aduc-1.5/package/yast2-aduc.changes 
new/yast2-aduc-1.6/package/yast2-aduc.changes
--- old/yast2-aduc-1.5/package/yast2-aduc.changes   2019-07-05 
18:43:56.0 +0200
+++ new/yast2-aduc-1.6/package/yast2-aduc.changes   2019-09-12 
22:19:06.0 +0200
@@ -1,4 +1,12 @@
 ---
+Thu Sep 12 18:12:56 UTC 2019 - dmul...@suse.com
+
+- Update to 1.6:
+  + Remove the dependency on python-ldap
+  + Module throws exception when smb.conf contains failing include
+  + Unused xset may cause exception in appimage; (bsc#1150612);
+
+---
 Mon Jul 01 17:17:59 UTC 2019 - dmul...@suse.com
 
 - Update to 1.5:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-aduc-1.5/package/yast2-aduc.spec 
new/yast2-aduc-1.6/package/yast2-aduc.spec
--- old/yast2-aduc-1.5/package/yast2-aduc.spec  2019-07-05 18:43:56.0 
+0200
+++ new/yast2-aduc-1.6/package/yast2-aduc.spec  2019-09-12 22:19:06.0 
+0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-aduc
-Version:1.5
+Version:1.6
 Release:0
 Summary:Active Directory Users and Computers for YaST
 License:GPL-3.0-only
@@ -39,7 +39,6 @@
 Requires:   samba-python3
 Requires:   yast2
 Requires:   yast2-python3-bindings >= 4.0.0
-Requires:   python3-ldap
 Requires:   yast2-adcommon-python >= 0.7
 
 Provides:   yast-aduc = %{version}
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-aduc-1.5/src/clients/aduc.py 
new/yast2-aduc-1.6/src/clients/aduc.py
--- old/yast2-aduc-1.5/src/clients/aduc.py  2019-07-05 18:43:56.0 
+0200
+++ new/yast2-aduc-1.6/src/clients/aduc.py  2019-09-12 22:19:06.0 
+0200
@@ -39,7 +39,10 @@
 if os.getenv("SMB_CONF_PATH") is not None:
 lp.load(os.getenv("SMB_CONF_PATH"))
 else:
-lp.load_default()
+try:
+lp.load_default()
+except RuntimeError:
+ycpbuiltins.y2error('Failed to load default smb.conf!')
 
 # Initialize the session
 creds = Credentials()
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-aduc-1.5/src/include/aduc/dialogs.py 
new/yast2-aduc-1.6/src/include/aduc/dialogs.py
--- old/yast2-aduc-1.5/src/include/aduc/dialogs.py  2019-07-05 
18:43:56.0 +0200
+++ new/yast2-aduc-1.6/src/include/aduc/dialogs.py  2019-09-12 
22:19:06.0 +0200
@@ -8,17 +8,18 @@
 import_module('UI')
 from yast import *
 import six
-from ldap.filter import filter_format
 from adcommon.yldap import SCOPE_SUBTREE as SUBTREE
 from adcommon.creds import YCreds, switch_domains
 from adcommon.ui import CreateMenu, DeleteButtonBox
 import traceback
 
-def have_x():
-from subprocess import Popen, PIPE
-p = Popen(['xset', '-q'], stdout=PIPE, stderr=PIPE)
-return p.wait() 

commit yast2-gpmc for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package yast2-gpmc for openSUSE:Factory 
checked in at 2019-09-13 15:02:31

Comparing /work/SRC/openSUSE:Factory/yast2-gpmc (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-gpmc.new.7948 (New)


Package is "yast2-gpmc"

Fri Sep 13 15:02:31 2019 rev:5 rq:730469 version:1.4.6

Changes:

--- /work/SRC/openSUSE:Factory/yast2-gpmc/yast2-gpmc.changes2019-09-10 
00:06:52.717193790 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-gpmc.new.7948/yast2-gpmc.changes  
2019-09-13 15:03:57.713274038 +0200
@@ -1,0 +2,12 @@
+Thu Sep 12 14:47:41 MDT 2019 - dmul...@suse.com
+
+- Remove ldap module use of MOD_DELETE and MOD_ADD; (bsc#1150616);
+- 1.4.6
+
+---
+Thu Sep 12 20:26:18 UTC 2019 - dmul...@suse.com
+
+- Ignore directory listing if directory doesn't exist; (bsc#1150614);
+- 1.4.5
+
+---

Old:

  yast2-gpmc-1.4.4.tar.bz2

New:

  yast2-gpmc-1.4.6.tar.bz2



Other differences:
--
++ yast2-gpmc.spec ++
--- /var/tmp/diff_new_pack.3Nmfif/_old  2019-09-13 15:03:58.277273918 +0200
+++ /var/tmp/diff_new_pack.3Nmfif/_new  2019-09-13 15:03:58.277273918 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-gpmc
-Version:1.4.4
+Version:1.4.6
 Release:0
 Summary:Group Policy Management Console for YaST
 License:GPL-3.0-only

++ yast2-gpmc-1.4.4.tar.bz2 -> yast2-gpmc-1.4.6.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-gpmc-1.4.4/package/yast2-gpmc.changes 
new/yast2-gpmc-1.4.6/package/yast2-gpmc.changes
--- old/yast2-gpmc-1.4.4/package/yast2-gpmc.changes 2019-09-09 
17:47:33.0 +0200
+++ new/yast2-gpmc-1.4.6/package/yast2-gpmc.changes 2019-09-12 
22:51:03.0 +0200
@@ -1,4 +1,16 @@
 ---
+Thu Sep 12 14:47:41 MDT 2019 - dmul...@suse.com
+
+- Remove ldap module use of MOD_DELETE and MOD_ADD; (bsc#1150616);
+- 1.4.6
+
+---
+Thu Sep 12 20:26:18 UTC 2019 - dmul...@suse.com
+
+- Ignore directory listing if directory doesn't exist; (bsc#1150614);
+- 1.4.5
+
+---
 Thu Aug 22 19:31:25 UTC 2019 - dmul...@suse.com
 
 - SamDB interface now allows gpmc to use krb5 auth; (boo#1146898);
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-gpmc-1.4.4/package/yast2-gpmc.spec 
new/yast2-gpmc-1.4.6/package/yast2-gpmc.spec
--- old/yast2-gpmc-1.4.4/package/yast2-gpmc.spec2019-09-09 
17:47:33.0 +0200
+++ new/yast2-gpmc-1.4.6/package/yast2-gpmc.spec2019-09-12 
22:51:03.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-gpmc
-Version:1.4.4
+Version:1.4.6
 Release:0
 Summary:Group Policy Management Console for YaST
 License:GPL-3.0-only
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-gpmc-1.4.4/src/include/gpmc/complex.py 
new/yast2-gpmc-1.4.6/src/include/gpmc/complex.py
--- old/yast2-gpmc-1.4.4/src/include/gpmc/complex.py2019-09-09 
17:47:33.0 +0200
+++ new/yast2-gpmc-1.4.6/src/include/gpmc/complex.py2019-09-12 
22:51:03.0 +0200
@@ -29,6 +29,7 @@
 from adcommon.creds import kinit_for_gssapi
 from adcommon.yldap import Ldap, LdapException, SCOPE_SUBTREE, SCOPE_ONELEVEL, 
SCOPE_BASE, addlist, modlist
 from adcommon.strings import strcmp, strcasecmp
+from samba import NTSTATUSError
 
 def open_bytes(filename):
 if six.PY3:
@@ -250,9 +251,9 @@
 
 if gplist:
 gplink_str = encode_gplink(gplist)
-self.ldap_modify(container_dn, stringify_ldap([(ldap.MOD_DELETE, 
'gPLink', None), (ldap.MOD_ADD, 'gPLink', [gplink_str.encode('utf-8')])]))
+self.ldap_modify(container_dn, stringify_ldap([(1, 'gPLink', 
None), (0, 'gPLink', [gplink_str.encode('utf-8')])]))
 else:
-self.ldap_modify(container_dn, stringify_ldap([(ldap.MOD_DELETE, 
'gPLink', None)]))
+self.ldap_modify(container_dn, stringify_ldap([(1, 'gPLink', 
None)]))
 
 def delete_gpo(self, displayName):
 msg = self.gpo_list(displayName)
@@ -417,7 +418,14 @@
 
 def list(self, path):
 path = os.path.relpath(os.path.join(self.path, path).replace('\\', 
'/'))
-return self.conn.list(path)
+try:
+return self.conn.list(path)
+except NTSTATUSError as e:
+if e.args[0] == 0xC034: # Object not found
+

commit kvm_stat for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package kvm_stat for openSUSE:Factory 
checked in at 2019-09-13 15:02:28

Comparing /work/SRC/openSUSE:Factory/kvm_stat (Old)
 and  /work/SRC/openSUSE:Factory/.kvm_stat.new.7948 (New)


Package is "kvm_stat"

Fri Sep 13 15:02:28 2019 rev:9 rq:730468 version:MACRO

Changes:

--- /work/SRC/openSUSE:Factory/kvm_stat/kvm_stat.changes2019-08-07 
14:00:32.200853437 +0200
+++ /work/SRC/openSUSE:Factory/.kvm_stat.new.7948/kvm_stat.changes  
2019-09-13 15:03:54.877274641 +0200
@@ -1,0 +2,5 @@
+Thu Sep 12 17:42:23 UTC 2019 - Bruce Rogers 
+
+- Detect SLE15-SP2 / Leap 15.2 and patch accordingly
+
+---



Other differences:
--
++ kvm_stat.spec ++
--- /var/tmp/diff_new_pack.LYJjEu/_old  2019-09-13 15:03:55.897274424 +0200
+++ /var/tmp/diff_new_pack.LYJjEu/_new  2019-09-13 15:03:55.901274423 +0200
@@ -97,12 +97,12 @@
 # copy necessary files from kernel-source
 (tar -C /usr/src/linux -c COPYING tools scripts) | tar -x
 
-%define SLE15_SP1   0%{?sle_version} == 150100 && 0%{?is_opensuse} != 1
-%define FACTORY 0%{?is_opensuse} && 0%{?suse_version} > 1500
-%define SLE_LEAP_15 0%{?sle_version} <= 15 && 0%{?suse_version} <= 1500
-
+%define SLE15_SP1   (0%{?sle_version} == 150100 && 0%{?is_opensuse} != 1)
+%define FACTORY (0%{?is_opensuse} && 0%{?suse_version} > 1500)
+%define SLE_LEAP_15 (0%{?sle_version} <= 15 && 0%{?suse_version} <= 1500)
+%define SLE_LEAP_15_2 (0%{?sle_version} == 150200 && 0%{?suse_version} <= 1500)
 # Only apply the first few patches to SLES15-SP1
-%if 0%{?SLE15_SP1}
+%if %{SLE15_SP1}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -152,12 +152,12 @@
 %endif
 
 # If the build is SLE15 / Leap 15 or older
-%if 0%{?SLE_LEAP_15}
+%if %{SLE_LEAP_15}
 %patch46 -p1
 %endif
 
-# If the build is Factory or Tumbleweed only
-%if 0%{?FACTORY}
+# If the build is Factory or Tumbleweed or SLE15SP2 / Leap 15.2
+%if %{FACTORY} || %{SLE_LEAP_15_2}
 %patch47 -p1
 %patch49 -p1
 %else




commit freshplayerplugin for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package freshplayerplugin for 
openSUSE:Factory checked in at 2019-09-13 15:02:18

Comparing /work/SRC/openSUSE:Factory/freshplayerplugin (Old)
 and  /work/SRC/openSUSE:Factory/.freshplayerplugin.new.7948 (New)


Package is "freshplayerplugin"

Fri Sep 13 15:02:18 2019 rev:14 rq:730458 version:0.3.11

Changes:

--- /work/SRC/openSUSE:Factory/freshplayerplugin/freshplayerplugin.changes  
2018-08-15 10:39:27.932408845 +0200
+++ 
/work/SRC/openSUSE:Factory/.freshplayerplugin.new.7948/freshplayerplugin.changes
2019-09-13 15:03:52.397275168 +0200
@@ -1,0 +2,13 @@
+Thu Sep 12 17:36:16 UTC 2019 - Luigi Baldoni 
+
+- Update to version 0.3.11
+  * misc: build compatibility with newer FFmpeg (AV-prefixed
+macros);
+  * misc: stop using __thread for thread-local variables;
+  * graphics: add explicit fullscreen window position
+configuration;
+  * misc: fix tests on big-endian machines;
+  * misc: mention that v0.3.10 existed, but without a changelog
+entry.
+
+---

Old:

  freshplayerplugin-0.3.9.tar.gz

New:

  freshplayerplugin-0.3.11.tar.gz



Other differences:
--
++ freshplayerplugin.spec ++
--- /var/tmp/diff_new_pack.EPmkkE/_old  2019-09-13 15:03:53.065275026 +0200
+++ /var/tmp/diff_new_pack.EPmkkE/_new  2019-09-13 15:03:53.069275026 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package freshplayerplugin
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,13 +12,13 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 %bcond_with restricted
 Name:   freshplayerplugin
-Version:0.3.9
+Version:0.3.11
 Release:0
 Summary:PPAPI2NPAPI compatibility layer
 License:MIT

++ freshplayerplugin-0.3.9.tar.gz -> freshplayerplugin-0.3.11.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/freshplayerplugin-0.3.9/CMakeLists.txt 
new/freshplayerplugin-0.3.11/CMakeLists.txt
--- old/freshplayerplugin-0.3.9/CMakeLists.txt  2017-12-23 15:34:01.0 
+0100
+++ new/freshplayerplugin-0.3.11/CMakeLists.txt 2019-05-24 13:33:09.0 
+0200
@@ -4,7 +4,7 @@
 # version
 set(VER_MAJOR 0)
 set(VER_MINOR 3)
-set(VER_MICRO 9)
+set(VER_MICRO 11)
 
 # setup compiler flags
 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -fPIC -pthread")
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/freshplayerplugin-0.3.9/ChangeLog 
new/freshplayerplugin-0.3.11/ChangeLog
--- old/freshplayerplugin-0.3.9/ChangeLog   2017-12-23 15:34:01.0 
+0100
+++ new/freshplayerplugin-0.3.11/ChangeLog  2019-05-24 13:33:09.0 
+0200
@@ -1,3 +1,12 @@
+2019-05-24  Rinat Ibragimov  
+
+   * release v0.3.11
+   * misc: build compatibility with newer FFmpeg (AV-prefixed macros)
+   * misc: stop using __thread for thread-local variables
+   * graphics: add explicit fullscreen window position configuration
+   * misc: fix tests on big-endian machines
+   * misc: mention that v0.3.10 existed, but without a changelog entry
+
 2017-12-23  Rinat Ibragimov  
 
* release v0.3.9
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/freshplayerplugin-0.3.9/cmake/ffmpeg-compat/CMakeLists.txt 
new/freshplayerplugin-0.3.11/cmake/ffmpeg-compat/CMakeLists.txt
--- old/freshplayerplugin-0.3.9/cmake/ffmpeg-compat/CMakeLists.txt  
2017-12-23 15:34:01.0 +0100
+++ new/freshplayerplugin-0.3.11/cmake/ffmpeg-compat/CMakeLists.txt 
2019-05-24 13:33:09.0 +0200
@@ -29,6 +29,7 @@
 MACRO_C_SOURCE_CHECK(cfg_avcodecid.c HAVE_AVCodecID)
 MACRO_C_SOURCE_CHECK(cfg_avcodeccontext_get_buffer2.c 
HAVE_AVCodecContext_get_buffer2)
 MACRO_C_SOURCE_CHECK(cfg_AVVDPAUContext.c HAVE_AVVDPAUContext)
+MACRO_C_SOURCE_CHECK(cfg_avcodecflags.c HAVE_AV_CODEC_FLAGS)
 
 MACRO_SYMBOL_CHECK(av_frame_alloc "libavcodec/avcodec.h" HAVE_av_frame_alloc)
 MACRO_SYMBOL_CHECK(av_frame_free "libavcodec/avcodec.h" HAVE_av_frame_free)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/freshplayerplugin-0.3.9/cmake/ffmpeg-compat/cfg_avcodecflags.c 

commit python-logreduce for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-logreduce for 
openSUSE:Factory checked in at 2019-09-13 15:02:09

Comparing /work/SRC/openSUSE:Factory/python-logreduce (Old)
 and  /work/SRC/openSUSE:Factory/.python-logreduce.new.7948 (New)


Package is "python-logreduce"

Fri Sep 13 15:02:09 2019 rev:9 rq:730452 version:0.4.0

Changes:

--- /work/SRC/openSUSE:Factory/python-logreduce/python-logreduce.changes
2019-04-02 09:23:49.684771208 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-logreduce.new.7948/python-logreduce.changes  
2019-09-13 15:03:47.265276259 +0200
@@ -1,0 +2,6 @@
+Thu Sep 12 17:38:32 UTC 2019 - Tomáš Chvátal 
+
+- Add aptch to fix build with new scikit:
+  * scikit.patch
+
+---

New:

  scikit.patch



Other differences:
--
++ python-logreduce.spec ++
--- /var/tmp/diff_new_pack.mjuFic/_old  2019-09-13 15:03:48.345276030 +0200
+++ /var/tmp/diff_new_pack.mjuFic/_new  2019-09-13 15:03:48.353276028 +0200
@@ -26,6 +26,7 @@
 Group:  Development/Languages/Python
 URL:https://logreduce.softwarefactory-project.io/
 Source: 
https://files.pythonhosted.org/packages/source/l/logreduce/logreduce-%{version}.tar.gz
+Patch0: scikit.patch
 BuildRequires:  %{python_module pbr}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
@@ -79,6 +80,8 @@
 
 %prep
 %setup -q -n logreduce-%{version}
+%patch0 -p1
+
 sed -i -e 's,flake8.*,,' test-requirements.txt
 
 %build

++ scikit.patch ++
>From e815b790c41a96ef7518a23ab28d9e3bec088541 Mon Sep 17 00:00:00 2001
From: Tristan Cacqueray 
Date: Tue, 30 Jul 2019 14:03:12 +
Subject: Fix scikit-learn 0.21.3 support

Recent scikit release doesn't embed the joblib.

Change-Id: Ie8ad434ea08bf72e7418b116b71ed335b38e1252
---
 logreduce/process.py| 10 +++---
 logreduce/tests/test_process.py |  8 ++--
 2 files changed, 13 insertions(+), 5 deletions(-)

diff --git a/logreduce/process.py b/logreduce/process.py
index f0c8d9b..c934840 100644
--- a/logreduce/process.py
+++ b/logreduce/process.py
@@ -22,7 +22,11 @@ import uuid
 import numpy as np
 import sklearn.utils.validation
 import sklearn.exceptions
-import sklearn.externals
+try:
+from sklearn.externals import joblib
+except ImportError:
+# Recent sklearn library doesn't vendor joblib anymore
+import joblib
 
 from logreduce.models import models
 from logreduce.tokenizer import remove_ansible_std_lines_lists
@@ -63,7 +67,7 @@ class Classifier:
 fileobj = open(fileobj, 'wb')
 fileobj.write(b'LGRD')
 fileobj.write(struct.pack('I', self.version))
-sklearn.externals.joblib.dump(self, fileobj, compress=True)
+joblib.dump(self, fileobj, compress=True)
 self.log.debug("%s: written" % fileobj.name)
 
 @staticmethod
@@ -81,7 +85,7 @@ class Classifier:
 if isinstance(fileobj, str):
 fileobj = open(fileobj, 'rb')
 Classifier.check(fileobj)
-return sklearn.externals.joblib.load(fileobj)
+return joblib.load(fileobj)
 
 @staticmethod
 def filename2modelname(filename):
diff --git a/logreduce/tests/test_process.py b/logreduce/tests/test_process.py
index 0889bb6..b27e692 100644
--- a/logreduce/tests/test_process.py
+++ b/logreduce/tests/test_process.py
@@ -43,8 +43,12 @@ class ProcessTests(unittest.TestCase):
 logreduce.process.Classifier.check(model)
 # joblib load reset the seek for io bytes, bypass model check in test
 model = io.BytesIO(model.read())
-import sklearn
-clf = sklearn.externals.joblib.load(model)
+try:
+from sklearn.externals import joblib
+except ImportError:
+# Recent sklearn library doesn't vendor joblib anymore
+import joblib
+clf = joblib.load(model)
 
 # Re-use the model with another test file
 target = os.path.join(os.path.dirname(baseline), "test_units.py")
-- 
cgit v1.2.1




commit python-treq for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-treq for openSUSE:Factory 
checked in at 2019-09-13 15:02:02

Comparing /work/SRC/openSUSE:Factory/python-treq (Old)
 and  /work/SRC/openSUSE:Factory/.python-treq.new.7948 (New)


Package is "python-treq"

Fri Sep 13 15:02:02 2019 rev:3 rq:730449 version:18.6.0

Changes:

--- /work/SRC/openSUSE:Factory/python-treq/python-treq.changes  2019-03-10 
09:34:34.152187824 +0100
+++ /work/SRC/openSUSE:Factory/.python-treq.new.7948/python-treq.changes
2019-09-13 15:03:43.205277122 +0200
@@ -1,0 +2,6 @@
+Thu Sep 12 17:21:23 UTC 2019 - Tomáš Chvátal 
+
+- Add patch to fix build with new Twisted releases:
+  * urlparsing.patch
+
+---

New:

  urlparsing.patch



Other differences:
--
++ python-treq.spec ++
--- /var/tmp/diff_new_pack.Cft3xT/_old  2019-09-13 15:03:44.801276783 +0200
+++ /var/tmp/diff_new_pack.Cft3xT/_new  2019-09-13 15:03:44.801276783 +0200
@@ -26,6 +26,7 @@
 URL:https://github.com/twisted/treq
 Source: 
https://files.pythonhosted.org/packages/source/t/treq/treq-%{version}.tar.gz
 Patch0: python37.patch
+Patch1: urlparsing.patch
 BuildRequires:  %{python_module Twisted >= 16.4.0}
 BuildRequires:  %{python_module attrs}
 BuildRequires:  %{python_module httpbin}
@@ -50,7 +51,7 @@
 
 %prep
 %setup -q -n treq-%{version}
-%patch0 -p1
+%autopatch -p1
 
 %build
 %python_build

++ urlparsing.patch ++
>From 2a81fb782353666f60151d52a79fc5a034dd2ebe Mon Sep 17 00:00:00 2001
From: Glyph 
Date: Tue, 11 Jun 2019 12:14:53 -0700
Subject: [PATCH] Fix to accommodate Twisted's new URL validity checking

---
 src/treq/test/test_testing.py | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/treq/test/test_testing.py b/src/treq/test/test_testing.py
index 6a13881..20797bd 100644
--- a/src/treq/test/test_testing.py
+++ b/src/treq/test/test_testing.py
@@ -138,9 +138,9 @@ def test_handles_invalid_schemes(self):
 so even after a successful request.
 """
 stub = StubTreq(_StaticTestResource())
-self.failureResultOf(stub.get(""), SchemeNotSupported)
+self.failureResultOf(stub.get("x-unknown-1:"), SchemeNotSupported)
 self.successResultOf(stub.get("http://url.com;))
-self.failureResultOf(stub.get(""), SchemeNotSupported)
+self.failureResultOf(stub.get("x-unknown-2:"), SchemeNotSupported)
 
 def test_files_are_rejected(self):
 """



commit python-freetype-py for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-freetype-py for 
openSUSE:Factory checked in at 2019-09-13 15:01:02

Comparing /work/SRC/openSUSE:Factory/python-freetype-py (Old)
 and  /work/SRC/openSUSE:Factory/.python-freetype-py.new.7948 (New)


Package is "python-freetype-py"

Fri Sep 13 15:01:02 2019 rev:4 rq:730392 version:2.1.0.post1

Changes:

--- /work/SRC/openSUSE:Factory/python-freetype-py/python-freetype-py.changes
2019-06-12 13:13:25.680871489 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-freetype-py.new.7948/python-freetype-py.changes
  2019-09-13 15:03:18.073282465 +0200
@@ -1,0 +2,6 @@
+Thu Sep 12 12:08:16 UTC 2019 - Tomáš Chvátal 
+
+- Update to 2.1.0.post1:
+  * no changelog given
+
+---

Old:

  freetype-py-2.1.0.tar.gz

New:

  freetype-py-2.1.0.post1.tar.gz



Other differences:
--
++ python-freetype-py.spec ++
--- /var/tmp/diff_new_pack.RjZCUy/_old  2019-09-13 15:03:18.889282292 +0200
+++ /var/tmp/diff_new_pack.RjZCUy/_new  2019-09-13 15:03:18.893282291 +0200
@@ -20,7 +20,7 @@
 # Upstream performs tests only for Python 3.5
 %bcond_with test
 Name:   python-freetype-py
-Version:2.1.0
+Version:2.1.0.post1
 Release:0
 Summary:Freetype python bindings
 License:BSD-3-Clause




commit python-pygit2 for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-pygit2 for openSUSE:Factory 
checked in at 2019-09-13 15:01:20

Comparing /work/SRC/openSUSE:Factory/python-pygit2 (Old)
 and  /work/SRC/openSUSE:Factory/.python-pygit2.new.7948 (New)


Package is "python-pygit2"

Fri Sep 13 15:01:20 2019 rev:21 rq:730403 version:0.28.2

Changes:

--- /work/SRC/openSUSE:Factory/python-pygit2/python-pygit2.changes  
2019-05-16 22:09:16.962323935 +0200
+++ /work/SRC/openSUSE:Factory/.python-pygit2.new.7948/python-pygit2.changes
2019-09-13 15:03:26.861280597 +0200
@@ -1,0 +2,9 @@
+Mon Jun  3 10:20:16 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.28.2:
+  * Fix crash in reflog iteration #901
+  * Support symbolic references in branches.with_commit(..) #910
+  * Documentation updates #909
+  * Test updates #911
+
+---

Old:

  pygit2-0.28.1.tar.gz

New:

  pygit2-0.28.2.tar.gz



Other differences:
--
++ python-pygit2.spec ++
--- /var/tmp/diff_new_pack.f2cYMC/_old  2019-09-13 15:03:28.073280339 +0200
+++ /var/tmp/diff_new_pack.f2cYMC/_new  2019-09-13 15:03:28.101280333 +0200
@@ -19,7 +19,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pygit2
-Version:0.28.1
+Version:0.28.2
 Release:0
 Summary:Python bindings for libgit2
 License:GPL-2.0-only
@@ -61,6 +61,7 @@
 %python_expand %fdupes %{buildroot}%{$python_sitearch}
 
 %check
+rm -rf pygit2
 %pytest_arch
 
 %files %{python_files}

++ pygit2-0.28.1.tar.gz -> pygit2-0.28.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pygit2-0.28.1/AUTHORS.rst 
new/pygit2-0.28.2/AUTHORS.rst
--- old/pygit2-0.28.1/AUTHORS.rst   2019-04-19 10:09:33.0 +0200
+++ new/pygit2-0.28.2/AUTHORS.rst   2019-05-26 10:45:58.0 +0200
@@ -107,6 +107,7 @@
   Bryan O'Sullivan
   CJ Harries
   Cam Cope
+  Chad Birch
   Chason Chaffin
   Chris Jerdonek
   Chris Rebert
@@ -115,6 +116,7 @@
   Cyril Jouve
   Daniel Bruce
   Daniele Esposti
+  David Black
   David Fischer
   David Sanders
   David Six
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pygit2-0.28.1/CHANGELOG.rst 
new/pygit2-0.28.2/CHANGELOG.rst
--- old/pygit2-0.28.1/CHANGELOG.rst 2019-04-19 10:05:31.0 +0200
+++ new/pygit2-0.28.2/CHANGELOG.rst 2019-05-26 10:39:44.0 +0200
@@ -1,3 +1,19 @@
+0.28.2 (2019-05-26)
+-
+
+- Fix crash in reflog iteration
+  `#901 `_
+
+- Support symbolic references in ``branches.with_commit(..)``
+  `#910 `_
+
+- Documentation updates
+  `#909 `_
+
+- Test updates
+  `#911 `_
+
+
 0.28.1 (2019-04-19)
 -
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pygit2-0.28.1/Makefile new/pygit2-0.28.2/Makefile
--- old/pygit2-0.28.1/Makefile  1970-01-01 01:00:00.0 +0100
+++ new/pygit2-0.28.2/Makefile  2019-04-19 20:09:09.0 +0200
@@ -0,0 +1,4 @@
+.PHONY: build
+
+build:
+   python setup.py build_ext --inplace
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pygit2-0.28.1/PKG-INFO new/pygit2-0.28.2/PKG-INFO
--- old/pygit2-0.28.1/PKG-INFO  2019-04-19 10:22:29.0 +0200
+++ new/pygit2-0.28.2/PKG-INFO  2019-05-26 11:42:43.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.2
 Name: pygit2
-Version: 0.28.1
+Version: 0.28.2
 Summary: Python bindings for libgit2.
 Home-page: http://github.com/libgit2/pygit2
 Maintainer: J. David Ibáñez
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pygit2-0.28.1/appveyor.yml 
new/pygit2-0.28.2/appveyor.yml
--- old/pygit2-0.28.1/appveyor.yml  2019-02-23 22:49:59.0 +0100
+++ new/pygit2-0.28.2/appveyor.yml  2019-05-19 17:19:45.0 +0200
@@ -9,63 +9,62 @@
   matrix:
   - GENERATOR: 'Visual Studio 10'
 PYTHON: 'C:\Python27\python.exe'
-TOXENV: py27
   - GENERATOR: 'Visual Studio 10 Win64'
 PYTHON: 'C:\Python27-x64\python.exe'
-TOXENV: py27
   - GENERATOR: 'Visual Studio 10'
 PYTHON: 'C:\Python34\python.exe'
-TOXENV: py34
   - GENERATOR: 'Visual Studio 10 Win64'
 PYTHON: 'C:\Python34-x64\python.exe'
-TOXENV: py34
   - GENERATOR: 'Visual Studio 14'
 PYTHON: 'C:\Python35\python.exe'
-TOXENV: py35
   - GENERATOR: 'Visual Studio 14 Win64'
 PYTHON: 'C:\Python35-x64\python.exe'
-TOXENV: 

commit robinhood for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package robinhood for openSUSE:Factory 
checked in at 2019-09-13 15:01:04

Comparing /work/SRC/openSUSE:Factory/robinhood (Old)
 and  /work/SRC/openSUSE:Factory/.robinhood.new.7948 (New)


Package is "robinhood"

Fri Sep 13 15:01:04 2019 rev:6 rq:730394 version:3.1.5

Changes:

--- /work/SRC/openSUSE:Factory/robinhood/robinhood.changes  2019-09-04 
09:15:53.078933623 +0200
+++ /work/SRC/openSUSE:Factory/.robinhood.new.7948/robinhood.changes
2019-09-13 15:03:19.237282218 +0200
@@ -1,0 +2,5 @@
+Thu Sep 12 12:16:15 UTC 2019 - Christian Goll 
+
+- removed i586 builds 
+
+---



Other differences:
--
++ robinhood.spec ++
--- /var/tmp/diff_new_pack.sZWVNS/_old  2019-09-13 15:03:19.837282090 +0200
+++ /var/tmp/diff_new_pack.sZWVNS/_new  2019-09-13 15:03:19.837282090 +0200
@@ -51,6 +51,7 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %{?systemd_requires}
 Requires(post): %fillup_prereq
+ExcludeArch:i586
 
 %description
 The Robinhood Policy Engine is a tool to manage contents of large




commit ffcall for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package ffcall for openSUSE:Factory checked 
in at 2019-09-13 15:01:46

Comparing /work/SRC/openSUSE:Factory/ffcall (Old)
 and  /work/SRC/openSUSE:Factory/.ffcall.new.7948 (New)


Package is "ffcall"

Fri Sep 13 15:01:46 2019 rev:11 rq:730438 version:2.2

Changes:

--- /work/SRC/openSUSE:Factory/ffcall/ffcall.changes2019-08-27 
10:24:39.919926463 +0200
+++ /work/SRC/openSUSE:Factory/.ffcall.new.7948/ffcall.changes  2019-09-13 
15:03:38.173278192 +0200
@@ -1,0 +2,10 @@
+Thu Sep 12 13:52:51 UTC 2019 - Andreas Schwab 
+
+- Add riscv64 to ffcall_arches
+
+---
+Tue Sep 10 20:17:14 UTC 2019 - Christophe Giboudeaux 
+
+- Use -ffat-lto-objects when building static libraries.
+
+---



Other differences:
--
++ ffcall.spec ++
--- /var/tmp/diff_new_pack.9Tpfc1/_old  2019-09-13 15:03:38.961278024 +0200
+++ /var/tmp/diff_new_pack.9Tpfc1/_new  2019-09-13 15:03:38.961278024 +0200
@@ -21,7 +21,7 @@
 # This package uses assembly to do its work.  This is the entire list of
 # supported architectures understood by RPM, even those not currently supported
 # by Fedora.  RPM hasn't heard about line continuations, hence the mess.
-%global ffcall_arches %ix86 x86_64 %alpha %arm aarch64 parisc hppa1.0 hppa1.1 
hppa1.2 hppa2.0 ia64 m68k mips mipsel ppc ppc64 ppc64le ppc8260 ppc8560 
ppc32dy4 ppciseries ppcpseries s390 s390x %sparc sparc64
+%global ffcall_arches %ix86 x86_64 %alpha %arm aarch64 parisc hppa1.0 hppa1.1 
hppa1.2 hppa2.0 ia64 m68k mips mipsel ppc ppc64 ppc64le ppc8260 ppc8560 
ppc32dy4 ppciseries ppcpseries riscv64 s390 s390x %sparc sparc64
 
 Name:   ffcall
 Version:2.2
@@ -83,6 +83,7 @@
 find . -name \*.o | xargs rm -f
 
 %build
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
 export CFLAGS="%{optflags} -g -fPIC -fno-strict-aliasing"
 export STRIP=true STRIPPROG=true
 %configure --disable-rpath --with-gnu-ld --enable-thread=posix





commit python-tox-travis for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-tox-travis for 
openSUSE:Factory checked in at 2019-09-13 15:02:06

Comparing /work/SRC/openSUSE:Factory/python-tox-travis (Old)
 and  /work/SRC/openSUSE:Factory/.python-tox-travis.new.7948 (New)


Package is "python-tox-travis"

Fri Sep 13 15:02:06 2019 rev:2 rq:730450 version:0.12

Changes:

--- /work/SRC/openSUSE:Factory/python-tox-travis/python-tox-travis.changes  
2019-04-05 11:57:20.918365877 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-tox-travis.new.7948/python-tox-travis.changes
2019-09-13 15:03:45.569276620 +0200
@@ -1,0 +2,6 @@
+Thu Sep 12 17:24:38 UTC 2019 - Tomáš Chvátal 
+
+- Add patch to build with new tox releases:
+  * enviroment.patch
+
+---

New:

  enviroment.patch



Other differences:
--
++ python-tox-travis.spec ++
--- /var/tmp/diff_new_pack.oucgDL/_old  2019-09-13 15:03:45.985276531 +0200
+++ /var/tmp/diff_new_pack.oucgDL/_new  2019-09-13 15:03:45.989276530 +0200
@@ -23,19 +23,17 @@
 Summary:Seamless integration of Tox into Travis CI
 License:MIT
 Group:  Development/Languages/Python
-Url:https://github.com/tox-dev/tox-travis
+URL:https://github.com/tox-dev/tox-travis
 Source: 
https://files.pythonhosted.org/packages/source/t/tox-travis/tox-travis-%{version}.tar.gz
+Patch0: enviroment.patch
 BuildRequires:  %{python_module pytest-mock}
 BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module setuptools}
-BuildRequires:  python-rpm-macros
-# SECTION test requirements
 BuildRequires:  %{python_module tox >= 2.0}
-# /SECTION
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-tox >= 2.0
 BuildArch:  noarch
-
 %python_subpackages
 
 %description
@@ -43,6 +41,7 @@
 
 %prep
 %setup -q -n tox-travis-%{version}
+%patch0 -p1
 
 %build
 %python_build
@@ -55,7 +54,7 @@
 # Without isolating the python and tox binaries, py37 would polute the py27
 # site-packages, probably related to how tox loads all available pythons.
 export PYTHONDONTWRITEBYTECODE=1
-%python_expand PYTHONPATH=%{buildroot}%{$python_sitelib} $python -m pytest
+%pytest
 
 %files %{python_files}
 %doc README.rst docs/*.rst

++ enviroment.patch ++
>From 8c57631a869da172d103141c17f374f031b2d296 Mon Sep 17 00:00:00 2001
From: Ryan Hiebert 
Date: Tue, 30 Jul 2019 11:24:44 -0500
Subject: [PATCH] Override default_envlist to fix tests (#137)

* Override default_envlist to fix tests

* Upgrade pip for AppVeyor

Lifted from https://github.com/rpkilby/tox-factor
---
 .appveyor.yml   | 5 +++--
 src/tox_travis/hooks.py | 4 +++-
 tests/test_envlist.py   | 8 
 3 files changed, 14 insertions(+), 3 deletions(-)

diff --git a/src/tox_travis/hooks.py b/src/tox_travis/hooks.py
index 9b84632..e4661dd 100644
--- a/src/tox_travis/hooks.py
+++ b/src/tox_travis/hooks.py
@@ -44,7 +44,9 @@ def tox_configure(config):
   'envs that Tox should run are declared in the tox config.',
   file=sys.stderr)
 autogen_envconfigs(config, undeclared)
-config.envlist = envlist
+# Also set envlist_default to allow us to inspect outcomes
+# via tox -l in the tests, until a better solution arrives.
+config.envlist_default = config.envlist = envlist
 
 # Override ignore_outcomes
 if override_ignore_outcome(ini):
diff --git a/tests/test_envlist.py b/tests/test_envlist.py
index 3de3cf3..4a3b167 100644
--- a/tests/test_envlist.py
+++ b/tests/test_envlist.py
@@ -2,6 +2,7 @@
 import py
 import re
 import subprocess
+import pytest
 from contextlib import contextmanager
 
 
@@ -293,6 +294,13 @@ def test_travis_override(self, tmpdir, monkeypatch):
 with self.configure(tmpdir, monkeypatch, tox_ini, 'CPython', 2, 7):
 assert self.tox_envs() == ['py27', 'docs']
 
+# XFAIL because of changes to tox -l to make it show declared envs
+# rather than the envs that will actually run, which is what we
+# need to test. When a better option is available, we can get this
+# test working again.
+#
+# # https://github.com/tox-dev/tox/pull/1284#issuecomment-488411553
+@pytest.mark.xfail
 def test_respect_overridden_toxenv(self, tmpdir, monkeypatch):
 """Ensure that TOXENV if given is not changed."""
 with self.configure(tmpdir, monkeypatch, tox_ini, 'CPython', 2, 7):



commit flatpak-builder for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package flatpak-builder for openSUSE:Factory 
checked in at 2019-09-13 15:01:51

Comparing /work/SRC/openSUSE:Factory/flatpak-builder (Old)
 and  /work/SRC/openSUSE:Factory/.flatpak-builder.new.7948 (New)


Package is "flatpak-builder"

Fri Sep 13 15:01:51 2019 rev:12 rq:730444 version:1.0.8

Changes:

--- /work/SRC/openSUSE:Factory/flatpak-builder/flatpak-builder.changes  
2019-06-01 09:56:19.711184406 +0200
+++ 
/work/SRC/openSUSE:Factory/.flatpak-builder.new.7948/flatpak-builder.changes
2019-09-13 15:03:40.377277724 +0200
@@ -1,0 +2,9 @@
+Wed Sep 11 17:17:28 UTC 2019 - Bjørn Lie 
+
+- Update to version 1.0.8:
+  + Support multiple instances of --install-dep-from.
+  + Ensure shallow git mirrors are updated when the git ref
+changes.
+  + Improved error reporting.
+
+---

Old:

  flatpak-builder-1.0.7.tar.xz

New:

  flatpak-builder-1.0.8.tar.xz



Other differences:
--
++ flatpak-builder.spec ++
--- /var/tmp/diff_new_pack.yvyv0t/_old  2019-09-13 15:03:40.853277622 +0200
+++ /var/tmp/diff_new_pack.yvyv0t/_new  2019-09-13 15:03:40.857277621 +0200
@@ -17,13 +17,14 @@
 
 
 Name:   flatpak-builder
-Version:1.0.7
+Version:1.0.8
 Release:0
 Summary:Tool to build flatpaks from source
 License:LGPL-2.1-or-later
 Group:  Development/Tools/Building
 URL:http://flatpak.org/
-Source: 
https://github.com/flatpak/flatpak-builder/releases/download/%{version}/%{name}-%{version}.tar.xz
+Source0:
https://github.com/flatpak/flatpak-builder/releases/download/%{version}/%{name}-%{version}.tar.xz
+
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  gettext
 BuildRequires:  gtk-doc

++ flatpak-builder-1.0.7.tar.xz -> flatpak-builder-1.0.8.tar.xz ++
 3576 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/flatpak-builder-1.0.7/NEWS new/flatpak-builder-1.0.8/NEWS
--- old/flatpak-builder-1.0.7/NEWS  2019-05-10 09:28:17.0 +0200
+++ new/flatpak-builder-1.0.8/NEWS  2019-06-26 12:43:54.0 +0200
@@ -1,3 +1,10 @@
+Changes in 1.0.8
+
+
+ * Support multiple instances of --install-dep-from
+ * Ensure shallow git mirrors are updated when the git ref changes
+ * Improved error reporting
+
 Changes in 1.0.7
 
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/flatpak-builder-1.0.7/configure.ac new/flatpak-builder-1.0.8/configure.ac
--- old/flatpak-builder-1.0.7/configure.ac  2019-05-10 09:26:53.0 
+0200
+++ new/flatpak-builder-1.0.8/configure.ac  2019-06-26 12:44:03.0 
+0200
@@ -15,7 +15,7 @@
 
 m4_define([flatpak_builder_major_version], [1])
 m4_define([flatpak_builder_minor_version], [0])
-m4_define([flatpak_builder_micro_version], [7])
+m4_define([flatpak_builder_micro_version], [8])
 m4_define([flatpak_builder_version],
   
[flatpak_builder_major_version.flatpak_builder_minor_version.flatpak_builder_micro_version])
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/flatpak-builder-1.0.7/src/builder-git.c 
new/flatpak-builder-1.0.8/src/builder-git.c
--- old/flatpak-builder-1.0.7/src/builder-git.c 2019-02-08 11:18:07.0 
+0100
+++ new/flatpak-builder-1.0.8/src/builder-git.c 2019-06-26 12:42:09.0 
+0200
@@ -531,8 +531,10 @@
   else
 cached_git_dir = g_object_ref (cache_mirror_dir);
 
-  /* If we're not updating, only pull from cache to avoid network i/o */
-  if (!update)
+  /* If the ref already exists (it may not with a shallow mirror
+   * if it has changed) and we're not updating, only pull from
+   * cache to avoid network i/o. */
+  if (already_exists && !update)
 {
   if (cached_git_dir)
 origin = g_file_get_uri (cached_git_dir);
diff -urN '--exclude=CVS' 

commit fence-agents for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package fence-agents for openSUSE:Factory 
checked in at 2019-09-13 15:00:53

Comparing /work/SRC/openSUSE:Factory/fence-agents (Old)
 and  /work/SRC/openSUSE:Factory/.fence-agents.new.7948 (New)


Package is "fence-agents"

Fri Sep 13 15:00:53 2019 rev:47 rq:730358 version:4.4.0+git.1568100905.307de6f2

Changes:

--- /work/SRC/openSUSE:Factory/fence-agents/fence-agents.changes
2019-07-02 15:18:26.810745046 +0200
+++ /work/SRC/openSUSE:Factory/.fence-agents.new.7948/fence-agents.changes  
2019-09-13 15:03:11.125283942 +0200
@@ -1,0 +2,16 @@
+Thu Sep 12 10:04:23 UTC 2019 - dake...@suse.com
+
+- Update to version 4.4.0+git.1568100905.307de6f2:
+  * fence_openstack: use -n/--plug/port parameter to be able to use 
pcmk_host_map
+  * fence_apc_snmp: Add Tripplite WEBCARDLX PDU support
+  * Update fence_aliyun.xml (bsc#1150504)
+  * Fix argument parsing for region_name
+  * fence_ilo_ssh*: add timeout warning in metadata/manpage
+  * remove 'man' page formating strings to improve '-o metadata' output
+  * filter out 'man' formating strings from 'longdesc' field
+  * Update fence_aliyun.py (#279) (bsc#1150504)
+  * Fixed issue with SUSPENDED VMs
+  * Changed encoding for the raritan telnet connection to latin1
+  * fence_scsi watchdog: dont exit when command fails using retry parameter
+
+---

Old:

  fence-agents-4.4.0+git.1558595666.5f79f9e9.tar.xz

New:

  fence-agents-4.4.0+git.1568100905.307de6f2.tar.xz



Other differences:
--
++ fence-agents.spec ++
--- /var/tmp/diff_new_pack.d9zJqm/_old  2019-09-13 15:03:11.921283773 +0200
+++ /var/tmp/diff_new_pack.d9zJqm/_new  2019-09-13 15:03:11.921283773 +0200
@@ -29,7 +29,7 @@
 Summary:Fence Agents for High Availability
 License:GPL-2.0-only AND LGPL-2.1-only
 Group:  Productivity/Clustering/HA
-Version:4.4.0+git.1558595666.5f79f9e9
+Version:4.4.0+git.1568100905.307de6f2
 Release:0
 Url:https://github.com/ClusterLabs/fence-agents
 Source0:%{name}-%{version}.tar.xz

++ _servicedata ++
--- /var/tmp/diff_new_pack.d9zJqm/_old  2019-09-13 15:03:11.957283765 +0200
+++ /var/tmp/diff_new_pack.d9zJqm/_new  2019-09-13 15:03:11.961283764 +0200
@@ -1,4 +1,4 @@
 
 
 git://github.com/ClusterLabs/fence-agents.git
-  1c4a64ca803831b44c96c75022abe5bb8713cd1a
\ No newline at end of file
+  307de6f2da5666b66eafa209520a5835a0cc92fc
\ No newline at end of file

++ fence-agents-4.4.0+git.1558595666.5f79f9e9.tar.xz -> 
fence-agents-4.4.0+git.1568100905.307de6f2.tar.xz ++
 1802 lines of diff (skipped)




commit python-flake8-future-import for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-flake8-future-import for 
openSUSE:Factory checked in at 2019-09-13 15:01:10

Comparing /work/SRC/openSUSE:Factory/python-flake8-future-import (Old)
 and  /work/SRC/openSUSE:Factory/.python-flake8-future-import.new.7948 (New)


Package is "python-flake8-future-import"

Fri Sep 13 15:01:10 2019 rev:4 rq:730400 version:0.4.6

Changes:

--- 
/work/SRC/openSUSE:Factory/python-flake8-future-import/python-flake8-future-import.changes
  2019-02-01 11:48:28.896365410 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-flake8-future-import.new.7948/python-flake8-future-import.changes
2019-09-13 15:03:21.161281809 +0200
@@ -1,0 +2,7 @@
+Thu Sep 12 12:35:38 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.4.6:
+  * fixes for new python releases
+- Remove patch python37.patch
+
+---

Old:

  flake8-future-import-0.4.5.tar.gz
  python37.patch

New:

  flake8-future-import-0.4.6.tar.gz



Other differences:
--
++ python-flake8-future-import.spec ++
--- /var/tmp/diff_new_pack.4qRbcV/_old  2019-09-13 15:03:22.033281623 +0200
+++ /var/tmp/diff_new_pack.4qRbcV/_new  2019-09-13 15:03:22.033281623 +0200
@@ -18,14 +18,13 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-flake8-future-import
-Version:0.4.5
+Version:0.4.6
 Release:0
 Summary:__future__ import checker, plugin for flake8
 License:MIT
 Group:  Development/Languages/Python
 URL:https://github.com/xZise/flake8-future-import
 Source: 
https://files.pythonhosted.org/packages/source/f/flake8-future-import/flake8-future-import-%{version}.tar.gz
-Patch0: python37.patch
 BuildRequires:  %{python_module flake8}
 BuildRequires:  %{python_module pip}
 BuildRequires:  %{python_module setuptools}
@@ -49,7 +48,6 @@
 
 %prep
 %setup -q -n flake8-future-import-%{version}
-%patch0 -p1
 mv test_flake8_future_import.py test_flake8_future_import.py.in
 
 %build

++ flake8-future-import-0.4.5.tar.gz -> flake8-future-import-0.4.6.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/flake8-future-import-0.4.5/PKG-INFO 
new/flake8-future-import-0.4.6/PKG-INFO
--- old/flake8-future-import-0.4.5/PKG-INFO 2018-04-15 14:55:13.0 
+0200
+++ new/flake8-future-import-0.4.6/PKG-INFO 2019-08-04 15:08:39.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: flake8-future-import
-Version: 0.4.5
+Version: 0.4.6
 Summary: __future__ import checker, plugin for flake8
 Home-page: https://github.com/xZise/flake8-future-import
 Author: Fabian Neundorf
@@ -10,7 +10,7 @@
 Description: __future__ import checker
 =
 
-.. image:: 
https://secure.travis-ci.org/xZise/flake8-future-import.png?branch=0.4.5
+.. image:: 
https://secure.travis-ci.org/xZise/flake8-future-import.png?branch=0.4.6
:alt: Build Status
:target: https://travis-ci.org/xZise/flake8-future-import
 
@@ -52,7 +52,7 @@
 is available in ``flake8``::
 
   $ flake8 --version
-  2.0 (pep8: 1.4.2, flake8-future-imports: 0.4.3, pyflakes: 0.6.1)
+  3.5.0 (flake8-future-imports: 0.4.6, mccabe: 0.6.1, pycodestyle: 
2.3.1, pyflakes: 1.6.0)
 
 By default the plugin will check for all the future imports but with
 ``--ignore`` it's possible to define which imports from ``__future__`` 
are
@@ -101,6 +101,8 @@
 +--+--+
 | FI17 | ``__future__`` import "generators" missing   |
 +--+--+
+| FI12 | ``__future__`` import "annotations" missing  |
++--+--+
 +--+--+
 | FI50 | ``__future__`` import "division" present |
 +--+--+
@@ -118,6 +120,8 @@
 +--+--+
 | FI57 | ``__future__`` import "generators" present   |
 +--+--+
+| FI58 | ``__future__`` import "annotations" present  |
++--+--+
 +--+--+
 | FI90 | ``__future__`` import does not exist |
 +--+--+
@@ -140,19 

commit chromium for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package chromium for openSUSE:Factory 
checked in at 2019-09-13 15:00:29

Comparing /work/SRC/openSUSE:Factory/chromium (Old)
 and  /work/SRC/openSUSE:Factory/.chromium.new.7948 (New)


Package is "chromium"

Fri Sep 13 15:00:29 2019 rev:229 rq:730345 version:77.0.3865.75

Changes:

--- /work/SRC/openSUSE:Factory/chromium/chromium.changes2019-09-04 
09:35:07.258696162 +0200
+++ /work/SRC/openSUSE:Factory/.chromium.new.7948/chromium.changes  
2019-09-13 15:02:51.569288099 +0200
@@ -1,0 +2,70 @@
+Thu Sep 12 08:34:01 UTC 2019 - Tomáš Chvátal 
+
+- Update to chromium 77.0.3865.75 bsc#1150425:
+  * CVE-2019-5870: Use-after-free in media
+  * CVE-2019-5871: Heap overflow in Skia
+  * CVE-2019-5872: Use-after-free in Mojo
+  * CVE-2019-5874: External URIs may trigger other browsers
+  * CVE-2019-5875: URL bar spoof via download redirect
+  * CVE-2019-5876: Use-after-free in media
+  * CVE-2019-5877: Out-of-bounds access in V8
+  * CVE-2019-5878: Use-after-free in V8
+  * CVE-2019-5879: Extension can bypass same origin policy
+  * CVE-2019-5880: SameSite cookie bypass
+  * CVE-2019-5881: Arbitrary read in SwiftShader
+  * CVE-2019-13659: URL spoof
+  * CVE-2019-13660: Full screen notification overlap
+  * CVE-2019-13661: Full screen notification spoof
+  * CVE-2019-13662: CSP bypass
+  * CVE-2019-13663: IDN spoof
+  * CVE-2019-13664: CSRF bypass
+  * CVE-2019-13665: Multiple file download protection bypass
+  * CVE-2019-13666: Side channel using storage size estimate
+  * CVE-2019-13667: URI bar spoof when using external app URIs
+  * CVE-2019-13668: Global window leak via console
+  * CVE-2019-13669: HTTP authentication spoof
+  * CVE-2019-13670: V8 memory corruption in regex
+  * CVE-2019-13671: Dialog box fails to show origin
+  * CVE-2019-13673: Cross-origin information leak using devtools
+  * CVE-2019-13674: IDN spoofing
+  * CVE-2019-13675: Extensions can be disabled by trailing slash
+  * CVE-2019-13676: Google URI shown for certificate warning
+  * CVE-2019-13677: Chrome web store origin needs to be isolated
+  * CVE-2019-13678: Download dialog spoofing
+  * CVE-2019-13679: User gesture needed for printing
+  * CVE-2019-13680: IP address spoofing to servers
+  * CVE-2019-13681: Bypass on download restrictions
+  * CVE-2019-13682: Site isolation bypass
+  * CVE-2019-13683: Exceptions leaked by devtools
+- Added patches:
+* chromium-77-blink-include.patch
+* chromium-77-fix-gn-gen.patch
+* chromium-77-gcc-abstract.patch
+* chromium-77-gcc-include.patch
+* chromium-77-system-hb.patch
+* chromium-unbundle-zlib.patch
+- Removed merged patches:
+* chromium-76-gcc-ambiguous-nodestructor.patch
+* chromium-76-gcc-blink-constexpr.patch
+* chromium-76-gcc-blink-namespace1.patch
+* chromium-76-gcc-blink-namespace2.patch
+* chromium-76-gcc-gl-init.patch
+* chromium-76-gcc-include.patch
+* chromium-76-gcc-noexcept.patch
+* chromium-76-gcc-private.patch
+* chromium-76-gcc-pure-virtual.patch
+* chromium-76-gcc-uint32.patch
+* chromium-76-gcc-vulkan.patch
+* chromium-76-quiche.patch
+* chromium-angle-inline.patch
+* chromium-fix-char_traits.patch
+* chromium-skia-aarch64-buildfix.patch
+* chromium-vaapi-fix.patch
+* gcc-lto-rsp-clobber.patch
+  - Refreshed patches:
+* chromium-prop-codecs.patch
+* chromium-system-icu.patch
+* chromium-vaapi.patch
+* old-libva.patch
+
+---

Old:

  chromium-76-gcc-ambiguous-nodestructor.patch
  chromium-76-gcc-blink-constexpr.patch
  chromium-76-gcc-blink-namespace1.patch
  chromium-76-gcc-blink-namespace2.patch
  chromium-76-gcc-gl-init.patch
  chromium-76-gcc-include.patch
  chromium-76-gcc-noexcept.patch
  chromium-76-gcc-private.patch
  chromium-76-gcc-pure-virtual.patch
  chromium-76-gcc-uint32.patch
  chromium-76-gcc-vulkan.patch
  chromium-76-quiche.patch
  chromium-76.0.3809.132.tar.xz
  chromium-angle-inline.patch
  chromium-fix-char_traits.patch
  chromium-skia-aarch64-buildfix.patch
  chromium-vaapi-fix.patch
  gcc-lto-rsp-clobber.patch

New:

  chromium-77-blink-include.patch
  chromium-77-fix-gn-gen.patch
  chromium-77-gcc-abstract.patch
  chromium-77-gcc-include.patch
  chromium-77-system-hb.patch
  chromium-77.0.3865.75.tar.xz
  chromium-unbundle-zlib.patch



Other differences:
--
++ chromium.spec ++
--- /var/tmp/diff_new_pack.6h04P0/_old  2019-09-13 15:03:05.761285082 +0200
+++ /var/tmp/diff_new_pack.6h04P0/_new  2019-09-13 15:03:05.761285082 +0200
@@ -57,7 +57,7 @@
 %bcond_with clang
 %bcond_with wayland
 Name:   chromium
-Version:76.0.3809.132
+Version:

commit ipxe for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package ipxe for openSUSE:Factory checked in 
at 2019-09-13 15:01:29

Comparing /work/SRC/openSUSE:Factory/ipxe (Old)
 and  /work/SRC/openSUSE:Factory/.ipxe.new.7948 (New)


Package is "ipxe"

Fri Sep 13 15:01:29 2019 rev:6 rq:730405 version:1.0.0+git20190817.0b3000bb

Changes:

--- /work/SRC/openSUSE:Factory/ipxe/ipxe.changes2018-12-04 
20:55:06.816800493 +0100
+++ /work/SRC/openSUSE:Factory/.ipxe.new.7948/ipxe.changes  2019-09-13 
15:03:29.785279975 +0200
@@ -1,0 +2,21 @@
+Thu Sep 12 11:59:33 UTC 2019 - bwiedem...@suse.com
+
+- Update to version 1.0.0+git20190817.0b3000bb:
+  * [golan] Fix address-of-pointer bug for multicast attach/detach
+  * [ethernet] Avoid false positive Coverity warning
+  * [coverity] Override assumptions about wcrtomb() and hmac_init()
+  * [crypto] Profile the various stages of modular multiplication
+  * [crypto] Drag in configured digestInfo prefixes for any use of RSA
+  * [tls] Add missing call to tls_tx_resume() when restarting negotiation
+  * [peerdist] Limit number of concurrent raw block downloads
+  * [peerdist] Start block download timers from within opener methods
+  * [process] Add PROC_INIT() for initialising static processes
+  * [build] Add predefined shortcut for Raspberry Pi builds
+  * [build] Workaround compilation error with gcc 9.1
+  * [build] Fix "'%s' directive argument is null" error
+- Drop obsolete/upstream patches:
+  * ipxe-aarch64-inline-asm-const-modifier.patch
+  * ipxe-efi-guard-strncpy-with-gcc-warning-ignore-pragma.patch
+  * ipxe-efi-recognize-plt32-relocation.patch
+
+---

Old:

  ipxe-1.0.0+git20180203.546dd51d.tar.gz
  ipxe-aarch64-inline-asm-const-modifier.patch
  ipxe-efi-guard-strncpy-with-gcc-warning-ignore-pragma.patch
  ipxe-efi-recognize-plt32-relocation.patch

New:

  ipxe-1.0.0+git20190817.0b3000bb.tar.gz



Other differences:
--
++ ipxe.spec ++
--- /var/tmp/diff_new_pack.ZhM4fx/_old  2019-09-13 15:03:31.033279710 +0200
+++ /var/tmp/diff_new_pack.ZhM4fx/_new  2019-09-13 15:03:31.045279707 +0200
@@ -17,29 +17,22 @@
 
 
 Name:   ipxe
-Version:1.0.0+git20180203.546dd51d
+Version:1.0.0+git20190817.0b3000bb
 Release:0
 Summary:A Network Boot Firmware
 License:GPL-2.0-only
 Group:  System/Boot
 Url:http://ipxe.org/
 Source: %{name}-%{version}.tar.gz
-# PATCH-FIX-SUSE: See 
http://lists.ipxe.org/pipermail/ipxe-devel/2018-April/006139.html
-# We can probably drop this since the gcc option has been dropped during build
-# See http://lists.ipxe.org/pipermail/ipxe-devel/2018-April/006146.html
-# and 
https://github.com/ipxe/ipxe/commit/8ed4e3049f5fcb3a0b32f5190940e78c61654cff#diff-55d8c3cd8df4b3cc4beb7239822b6c95
-Patch0: ipxe-efi-guard-strncpy-with-gcc-warning-ignore-pragma.patch
-# PATCH-FIX-SUSE: See 
http://lists.ipxe.org/pipermail/ipxe-devel/2018-August/006267.html
-# to check if it was applied upstream or not
-Patch1: ipxe-efi-recognize-plt32-relocation.patch
-Patch2: ipxe-aarch64-inline-asm-const-modifier.patch
 BuildRequires:  /usr/bin/mkisofs
 BuildRequires:  binutils-devel
+%ifarch x86_64
 %if 0%{?sle_version} >= 15 && 0%{?sle_version} < 15
 BuildRequires:  cross-aarch64-gcc7
 %else
 BuildRequires:  cross-aarch64-gcc8
 %endif
+%endif
 BuildRequires:  perl
 BuildRequires:  syslinux
 BuildRequires:  xz-devel
@@ -68,9 +61,6 @@
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
 
 %build
 cd src

++ ipxe-1.0.0+git20180203.546dd51d.tar.gz -> 
ipxe-1.0.0+git20190817.0b3000bb.tar.gz ++
 13369 lines of diff (skipped)




commit gradio for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package gradio for openSUSE:Factory checked 
in at 2019-09-13 15:01:01

Comparing /work/SRC/openSUSE:Factory/gradio (Old)
 and  /work/SRC/openSUSE:Factory/.gradio.new.7948 (New)


Package is "gradio"

Fri Sep 13 15:01:01 2019 rev:9 rq:730369 version:7.3

Changes:

--- /work/SRC/openSUSE:Factory/gradio/gradio.changes2018-12-28 
12:35:33.455953594 +0100
+++ /work/SRC/openSUSE:Factory/.gradio.new.7948/gradio.changes  2019-09-13 
15:03:13.841283364 +0200
@@ -1,0 +2,14 @@
+Thu Sep 12 06:42:53 UTC 2019 - mvet...@suse.com
+
+- Update to 7.3:
+  * This will probably be the last version of Gradio.
+It includes updated translations and small minor improvements.
+The successor of Gradio will be Shortwave.
+  * Update de.haeckerfelix.gradio.json 
+  * The Appdata files now go to /usr/share/metainfo
+  * Fix animation in app menu
+  * Fix menubutton because glade destroyed it
+  * Fix vala warnings
+  * Update translations
+
+---

Old:

  v7.2.tar.gz

New:

  v7.3.tar.gz



Other differences:
--
++ gradio.spec ++
--- /var/tmp/diff_new_pack.45raj5/_old  2019-09-13 15:03:15.013283116 +0200
+++ /var/tmp/diff_new_pack.45raj5/_new  2019-09-13 15:03:15.013283116 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gradio
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,17 +12,17 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via https://bugs.opensuse.org/
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
 
 Name:   gradio
-Version:7.2
+Version:7.3
 Release:0
 Summary:GTK3 app for finding and listening to internet radio stations
 License:GPL-3.0-or-later
 Group:  Productivity/Multimedia/Sound/Players
-Url:https://github.com/haecker-felix/gradio
+URL:https://github.com/haecker-felix/gradio
 Source: 
https://github.com/haecker-felix/gradio/archive/v%{version}.tar.gz
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
@@ -55,11 +55,11 @@
 %setup -q -n Gradio-%{version}
 
 %build
-%{meson}
-%{meson_build}
+%meson
+%meson_build
 
 %install
-%{meson_install}
+%meson_install
 
 %fdupes %{buildroot}%{_prefix}
 %find_lang %{name}
@@ -68,7 +68,7 @@
 %license LICENSE.md
 %doc README.md
 %{_bindir}/gradio
-%{_datadir}/appdata/de.haeckerfelix.gradio.appdata.xml
+%{_datadir}/metainfo/de.haeckerfelix.gradio.appdata.xml
 %{_datadir}/applications/de.haeckerfelix.gradio.desktop
 %{_datadir}/icons/hicolor/*/apps/de.haeckerfelix.gradio.png
 %{_datadir}/icons/hicolor/scalable/apps/de.haeckerfelix.gradio.svg

++ v7.2.tar.gz -> v7.3.tar.gz ++
 2511 lines of diff (skipped)




commit python-cluster-preflight-check for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-cluster-preflight-check for 
openSUSE:Factory checked in at 2019-09-13 15:00:47

Comparing /work/SRC/openSUSE:Factory/python-cluster-preflight-check (Old)
 and  /work/SRC/openSUSE:Factory/.python-cluster-preflight-check.new.7948 
(New)


Package is "python-cluster-preflight-check"

Fri Sep 13 15:00:47 2019 rev:2 rq:730354 version:0.0.29

Changes:

--- 
/work/SRC/openSUSE:Factory/python-cluster-preflight-check/python-cluster-preflight-check.changes
2019-08-27 10:25:07.635924576 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-cluster-preflight-check.new.7948/python-cluster-preflight-check.changes
  2019-09-13 15:03:08.137284577 +0200
@@ -1,0 +2,5 @@
+Tue Aug 27 05:27:15 UTC 2019 - Jan Engelhardt 
+
+- Language fixes to the description.
+
+---



Other differences:
--
++ python-cluster-preflight-check.spec ++
--- /var/tmp/diff_new_pack.lyvrg3/_old  2019-09-13 15:03:08.909284413 +0200
+++ /var/tmp/diff_new_pack.lyvrg3/_new  2019-09-13 15:03:08.913284412 +0200
@@ -20,7 +20,7 @@
 Name:   python-cluster-preflight-check
 Version:0.0.29
 Release:0
-Summary:Tool for Standardize Testing of Basic Cluster Functionality
+Summary:Tool for Standardized Testing of Basic Cluster Functionality
 License:BSD-3-Clause
 Group:  Development/Languages/Python
 URL:https://github.com/liangxin1300/cluster_preflight_check.git
@@ -40,7 +40,7 @@
 %python_subpackages
 
 %description
-Tool for Standardize Testing of Basic Cluster Functionality
+Tool for Standardized Testing of Basic Cluster Functionality
 
 %prep
 %setup -q -n cluster-preflight-check-%{version}




commit grubby for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package grubby for openSUSE:Factory checked 
in at 2019-09-13 15:01:35

Comparing /work/SRC/openSUSE:Factory/grubby (Old)
 and  /work/SRC/openSUSE:Factory/.grubby.new.7948 (New)


Package is "grubby"

Fri Sep 13 15:01:35 2019 rev:8 rq:730414 version:20190801.fc69ba6

Changes:

--- /work/SRC/openSUSE:Factory/grubby/grubby.changes2018-04-30 
22:54:09.274935003 +0200
+++ /work/SRC/openSUSE:Factory/.grubby.new.7948/grubby.changes  2019-09-13 
15:03:34.469278979 +0200
@@ -1,0 +2,5 @@
+Thu Sep  5 13:52:46 UTC 2019 - o...@aepfle.de
+
+- Update to 20190801.fc69ba6
+
+---

Old:

  grubby-8.40.tar.bz2

New:

  _service
  grubby-20190801.fc69ba6.tar.xz



Other differences:
--
++ grubby.spec ++
--- /var/tmp/diff_new_pack.yYetEL/_old  2019-09-13 15:03:34.889278890 +0200
+++ /var/tmp/diff_new_pack.yYetEL/_new  2019-09-13 15:03:34.893278889 +0200
@@ -17,19 +17,17 @@
 
 
 Name:   grubby
-Version:8.40
+Version:20190801.fc69ba6
 Release:0
 Summary:Command line tool for updating bootloader configs
 License:GPL-2.0-or-later
 Group:  System/Base
-Url:https://github.com/rhinstaller/grubby.git
-Source0:%{name}-%{version}.tar.bz2
+Url:https://github.com/rhboot/grubby
+Source0:%{name}-%{version}.tar.xz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  git
-BuildRequires:  glib2-devel
-BuildRequires:  libblkid-devel
-BuildRequires:  pkgconfig
-BuildRequires:  popt-devel
+BuildRequires:  pkg-config
+BuildRequires:  pkgconfig(blkid)
+BuildRequires:  pkgconfig(popt)
 # for make test / getopt:
 BuildRequires:  grub2
 BuildRequires:  util-linux
@@ -48,15 +46,27 @@
 environment.
 
 %prep
-%setup -q
+%autosetup -p1
 
 %build
-make %{?_smp_mflags}
+sed -i~ '
+/^LDFLAGS/d
+/^CFLAGS/d
+/^grubby_LIBS/d
+/^VERBOSE_TEST/d
+' Makefile
+diff -u "$_"~ "$_" && exit 1
+CFLAGS="%{optflags} -std=gnu99 $(pkg-config --cflags blkid popt)"
+LDFLAGS=
+grubby_LIBS="$(pkg-config --libs blkid popt)"
+make %{?_smp_mflags} CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" 
grubby_LIBS="${grubby_LIBS}" VERSION='%{version}'
 
-%ifnarch aarch64
 %check
-make test
-%endif
+sed -i~ '
+s@/vmlinuz-foo@/boot/vmlinuz-foo@
+' test/results/add/g2-1.16
+diff -u "$_"~ "$_" && exit 1
+make test VERBOSE_TEST="-b grub2"
 
 %install
 make install DESTDIR="%{buildroot}" mandir="%{_mandir}"

++ _service ++

  
https://github.com/rhboot/grubby
git
%cd.%h
master
grubby
  
  
*.tar
xz
  
  




commit python-beniget for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-beniget for openSUSE:Factory 
checked in at 2019-09-13 15:01:17

Comparing /work/SRC/openSUSE:Factory/python-beniget (Old)
 and  /work/SRC/openSUSE:Factory/.python-beniget.new.7948 (New)


Package is "python-beniget"

Fri Sep 13 15:01:17 2019 rev:3 rq:730401 version:0.2.0

Changes:

--- /work/SRC/openSUSE:Factory/python-beniget/python-beniget.changes
2019-08-27 10:20:50.503941742 +0200
+++ /work/SRC/openSUSE:Factory/.python-beniget.new.7948/python-beniget.changes  
2019-09-13 15:03:24.253281151 +0200
@@ -1,0 +2,6 @@
+Thu Sep 12 12:45:20 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.2.0:
+  * python 3.8 support
+
+---

Old:

  beniget-0.1.0.tar.gz

New:

  beniget-0.2.0.tar.gz



Other differences:
--
++ python-beniget.spec ++
--- /var/tmp/diff_new_pack.ltyEa7/_old  2019-09-13 15:03:25.185280953 +0200
+++ /var/tmp/diff_new_pack.ltyEa7/_new  2019-09-13 15:03:25.189280952 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-beniget
-Version:0.1.0
+Version:0.2.0
 Release:0
 Summary:Module to extract semantic information about static Python code
 License:BSD-3-Clause
@@ -28,10 +28,10 @@
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
-Requires:   python-gast >= 0.2.2
+Requires:   python-gast >= 0.3.0
 BuildArch:  noarch
 # SECTION test requirements
-BuildRequires:  %{python_module gast >= 0.2.2}
+BuildRequires:  %{python_module gast >= 0.3.0}
 # /SECTION
 %python_subpackages
 

++ beniget-0.1.0.tar.gz -> beniget-0.2.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/beniget-0.1.0/LICENSE new/beniget-0.2.0/LICENSE
--- old/beniget-0.1.0/LICENSE   2019-01-13 09:44:58.0 +0100
+++ new/beniget-0.2.0/LICENSE   2019-03-18 22:02:52.0 +0100
@@ -1,4 +1,4 @@
-Copyright (c) 2016, Serge Guelton
+Copyright (c) 2019, Serge Guelton
 All rights reserved.
 
 Redistribution and use in source and binary forms, with or without
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/beniget-0.1.0/PKG-INFO new/beniget-0.2.0/PKG-INFO
--- old/beniget-0.1.0/PKG-INFO  2019-03-14 21:05:10.0 +0100
+++ new/beniget-0.2.0/PKG-INFO  2019-09-07 17:51:31.0 +0200
@@ -1,12 +1,11 @@
 Metadata-Version: 1.2
 Name: beniget
-Version: 0.1.0
+Version: 0.2.0
 Summary: Extract semantic information about static Python code
 Home-page: https://github.com/serge-sans-paille/beniget/
 Author: serge-sans-paille
 Author-email: serge.guel...@telecom-bretagne.eu
 License: BSD 3-Clause
-Description-Content-Type: UNKNOWN
 Description: 
 A static analyzer for Python2 and Python3 code.
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/beniget-0.1.0/beniget/beniget.py 
new/beniget-0.2.0/beniget/beniget.py
--- old/beniget-0.1.0/beniget/beniget.py2019-03-14 11:44:38.0 
+0100
+++ new/beniget-0.2.0/beniget/beniget.py2019-09-07 17:50:27.0 
+0200
@@ -755,12 +755,10 @@
 
 visit_Repr = visit_Await
 
-def visit_Num(self, node):
+def visit_Constant(self, node):
 dnode = self.chains.setdefault(node, Def(node))
 return dnode
 
-visit_Str = visit_Num
-
 def visit_FormattedValue(self, node):
 dnode = self.chains.setdefault(node, Def(node))
 self.visit(node.value).add_user(dnode)
@@ -774,10 +772,6 @@
 self.visit(value).add_user(dnode)
 return dnode
 
-visit_Bytes = visit_Num
-visit_NameConstant = visit_Num
-visit_Ellipsis = visit_Num
-
 visit_Attribute = visit_Await
 
 def visit_Subscript(self, node):
@@ -899,8 +893,12 @@
 for arg in node.args:
 self.visit(arg)
 
+for arg in node.posonlyargs:
+self.visit(arg)
+
 if node.vararg:
 self.visit(node.vararg)
+
 for arg in node.kwonlyargs:
 self.visit(arg)
 if node.kwarg:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/beniget-0.1.0/beniget.egg-info/PKG-INFO 
new/beniget-0.2.0/beniget.egg-info/PKG-INFO
--- old/beniget-0.1.0/beniget.egg-info/PKG-INFO 2019-03-14 21:05:10.0 
+0100
+++ new/beniget-0.2.0/beniget.egg-info/PKG-INFO 2019-09-07 17:51:31.0 
+0200
@@ -1,12 +1,11 @@
 Metadata-Version: 1.2
 Name: beniget
-Version: 0.1.0
+Version: 0.2.0
 Summary: Extract semantic information about static Python code
 Home-page: 

commit youtube-dl for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package youtube-dl for openSUSE:Factory 
checked in at 2019-09-13 15:00:26

Comparing /work/SRC/openSUSE:Factory/youtube-dl (Old)
 and  /work/SRC/openSUSE:Factory/.youtube-dl.new.7948 (New)


Package is "youtube-dl"

Fri Sep 13 15:00:26 2019 rev:115 rq:730324 version:2019.09.12.1

Changes:

--- /work/SRC/openSUSE:Factory/youtube-dl/python-youtube-dl.changes 
2019-09-09 12:35:43.277469020 +0200
+++ /work/SRC/openSUSE:Factory/.youtube-dl.new.7948/python-youtube-dl.changes   
2019-09-13 15:00:44.217283385 +0200
@@ -1,0 +2,7 @@
+Wed Sep  11 20:45:42 UTC 2019 - Fritz Reichwald 
+
+- Update to release 2019.09.12.1
+  * nickjr: Add support for nickelodeonjunior.fr
+  * youtube: Add support for invidious tor instances
+
+---
youtube-dl.changes: same change

Old:

  youtube-dl-2019.09.01.tar.gz
  youtube-dl-2019.09.01.tar.gz.sig

New:

  youtube-dl-2019.09.12.1.tar.gz
  youtube-dl-2019.09.12.1.tar.gz.sig



Other differences:
--
++ python-youtube-dl.spec ++
--- /var/tmp/diff_new_pack.yayjyC/_old  2019-09-13 15:00:48.053283547 +0200
+++ /var/tmp/diff_new_pack.yayjyC/_new  2019-09-13 15:00:48.061283548 +0200
@@ -19,7 +19,7 @@
 %define modname youtube-dl
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-youtube-dl
-Version:2019.09.01
+Version:2019.09.12.1
 Release:0
 Summary:A Python module for downloading from video sites for offline 
watching
 License:SUSE-Public-Domain AND CC-BY-SA-3.0

++ youtube-dl.spec ++
--- /var/tmp/diff_new_pack.yayjyC/_old  2019-09-13 15:00:48.077283548 +0200
+++ /var/tmp/diff_new_pack.yayjyC/_new  2019-09-13 15:00:48.077283548 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   youtube-dl
-Version:2019.09.01
+Version:2019.09.12.1
 Release:0
 Summary:A tool for downloading from video sites for offline watching
 License:SUSE-Public-Domain AND CC-BY-SA-3.0

++ youtube-dl-2019.09.01.tar.gz -> youtube-dl-2019.09.12.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/youtube-dl/ChangeLog new/youtube-dl/ChangeLog
--- old/youtube-dl/ChangeLog2019-08-31 22:32:58.0 +0200
+++ new/youtube-dl/ChangeLog2019-09-11 21:53:49.0 +0200
@@ -1,3 +1,15 @@
+version 2019.09.12.1
+
+Extractors
+* [youtube] Remove quality and tbr for itag 43 (#22372)
+
+
+version 2019.09.12
+
+Extractors
+* [youtube] Quick extraction tempfix (#22367, #22163)
+
+
 version 2019.09.01
 
 Core
Binary files old/youtube-dl/youtube-dl and new/youtube-dl/youtube-dl differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/youtube-dl/youtube_dl/extractor/nick.py 
new/youtube-dl/youtube_dl/extractor/nick.py
--- old/youtube-dl/youtube_dl/extractor/nick.py 2019-08-31 22:32:46.0 
+0200
+++ new/youtube-dl/youtube_dl/extractor/nick.py 2019-09-11 21:52:44.0 
+0200
@@ -85,7 +85,8 @@
 https?://
 (?:
 
(?P(?:www\.)?nickjr|mundonick\.uol)\.com\.br|
-(?:www\.)?nickjr\.[a-z]{2}
+(?:www\.)?nickjr\.[a-z]{2}|
+(?:www\.)?nickelodeonjunior\.fr
 )
 
/(?:programas/)?[^/]+/videos/(?:episodios/)?(?P[^/?\#.]+)
 '''
@@ -101,6 +102,9 @@
 }, {
 'url': 
'http://www.nickjr.de/blaze-und-die-monster-maschinen/videos/f6caaf8f-e4e8-4cc1-b489-9380d6dcd059/',
 'only_matching': True,
+}, {
+'url': 
'http://www.nickelodeonjunior.fr/paw-patrol-la-pat-patrouille/videos/episode-401-entier-paw-patrol/',
+'only_matching': True,
 }]
 
 def _real_extract(self, url):
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/youtube-dl/youtube_dl/extractor/platzi.py 
new/youtube-dl/youtube_dl/extractor/platzi.py
--- old/youtube-dl/youtube_dl/extractor/platzi.py   2019-08-31 
22:32:46.0 +0200
+++ new/youtube-dl/youtube_dl/extractor/platzi.py   2019-09-11 
21:52:44.0 +0200
@@ -18,43 +18,10 @@
 )
 
 
-class PlatziIE(InfoExtractor):
-_VALID_URL = r'''(?x)
-https?://
-(?:
-platzi\.com/clases|   # es version
-courses\.platzi\.com/classes  # en version
-)/[^/]+/(?P\d+)-[^/?\#&]+
-'''
+class PlatziBaseIE(InfoExtractor):
 _LOGIN_URL = 'https://platzi.com/login/'
 

commit python-holidays for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-holidays for openSUSE:Factory 
checked in at 2019-09-13 15:00:25

Comparing /work/SRC/openSUSE:Factory/python-holidays (Old)
 and  /work/SRC/openSUSE:Factory/.python-holidays.new.7948 (New)


Package is "python-holidays"

Fri Sep 13 15:00:25 2019 rev:3 rq:730322 version:0.9.11

Changes:

--- /work/SRC/openSUSE:Factory/python-holidays/python-holidays.changes  
2019-04-05 12:02:57.682576636 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-holidays.new.7948/python-holidays.changes
2019-09-13 15:00:37.561283103 +0200
@@ -1,0 +2,17 @@
+Thu Sep 12 09:00:03 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.9.11:
+  - Added Japanese holidays for new Emperor (kokinamura)
+  - Fixed Australian Canberra day holiday (explodingdinosaurs, dr-p)
+  - Added support for Estonian holidays (RaulVS14)
+  - Added support for Iceland and Kenya (justinasfour04)
+  - Added support for Aruba (orson1282)
+  - Added support for Hong Kong (polifaces)
+  - Added support for Peru (manuelvalino)
+  - Switzerland fixes (spasche)
+  - Croatia fix (pave121, dr-p)
+  - Polish deprecation: replaced by Poland (dr-p)
+  - Czech(ia) - Slovak(ia) fixes (dr-p)
+  - Allow passing years to CountryHoliday (mr.shu)
+
+---

Old:

  holidays-0.9.10.tar.gz

New:

  holidays-0.9.11.tar.gz



Other differences:
--
++ python-holidays.spec ++
--- /var/tmp/diff_new_pack.bN9zUO/_old  2019-09-13 15:00:38.445283140 +0200
+++ /var/tmp/diff_new_pack.bN9zUO/_new  2019-09-13 15:00:38.449283140 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-holidays
-Version:0.9.10
+Version:0.9.11
 Release:0
 Summary:Python library for generating holidays on the fly
 License:MIT

++ holidays-0.9.10.tar.gz -> holidays-0.9.11.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/holidays-0.9.10/CHANGES new/holidays-0.9.11/CHANGES
--- old/holidays-0.9.10/CHANGES 2019-03-12 22:36:43.0 +0100
+++ new/holidays-0.9.11/CHANGES 2019-07-28 19:01:11.0 +0200
@@ -1,3 +1,21 @@
+Version 0.9.11
+==
+
+Released July 28, 2019
+
+- Added Japanese holidays for new Emperor (kokinamura)
+- Fixed Australian Canberra day holiday (explodingdinosaurs, dr-p)
+- Added support for Estonian holidays (RaulVS14)
+- Added support for Iceland and Kenya (justinasfour04)
+- Added support for Aruba (orson1282)
+- Added support for Hong Kong (polifaces)
+- Added support for Peru (manuelvalino)
+- Switzerland fixes (spasche)
+- Croatia fix (pave121, dr-p)
+- Polish deprecation: replaced by Poland (dr-p)
+- Czech(ia) - Slovak(ia) fixes (dr-p)
+- Allow passing years to CountryHoliday (mr.shu)
+
 Version 0.9.10
 ==
 
@@ -73,6 +91,7 @@
 - Added Switzerland with all cantons (Phil)
 - Canada holiday updates (goodfore)
 - Various inspection fixes
+- Czech deprecation: replaced by Czechia (janpipek)
 
 Version 0.9.2
 =
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/holidays-0.9.10/PKG-INFO new/holidays-0.9.11/PKG-INFO
--- old/holidays-0.9.10/PKG-INFO2019-03-12 22:39:18.0 +0100
+++ new/holidays-0.9.11/PKG-INFO2019-07-28 19:04:08.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: holidays
-Version: 0.9.10
+Version: 0.9.11
 Summary: Generate and work with holidays in Python
 Home-page: https://github.com/dr-prodigy/python-holidays
 Author: dr-prodigy
@@ -107,6 +107,7 @@
 Country Abbr Provinces/States Available
 ===  
=
 Argentina   AR   None
+Aruba   AW   None
 Australia   AU   prov = **ACT** (default), NSW, NT, QLD, 
SA, TAS, VIC, WA
 Austria AT   prov = B, K, N, O, S, ST, T, V, **W** 
(default)
 Belarus BY   None
@@ -118,9 +119,10 @@
  PE, QC, SK, YU
 ColombiaCO   None
 Croatia HR   None
-Czech   CZ   None
+Czechia CZ   None
 Denmark DK   None
 England  None
+Estonia EE   None
 EuropeanCentralBank ECB,TAR  Trans-European Automated Real-time Gross 
Settlement (TARGET2)
 Finland FI   None
 France  FRA  **Métropole** (default), Alsace-Moselle, 
Guadeloupe, Guyane,
@@ 

commit ibus-typing-booster for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package ibus-typing-booster for 
openSUSE:Factory checked in at 2019-09-13 15:00:19

Comparing /work/SRC/openSUSE:Factory/ibus-typing-booster (Old)
 and  /work/SRC/openSUSE:Factory/.ibus-typing-booster.new.7948 (New)


Package is "ibus-typing-booster"

Fri Sep 13 15:00:19 2019 rev:24 rq:730297 version:2.6.6

Changes:

--- /work/SRC/openSUSE:Factory/ibus-typing-booster/ibus-typing-booster.changes  
2019-08-29 17:27:29.495268138 +0200
+++ 
/work/SRC/openSUSE:Factory/.ibus-typing-booster.new.7948/ibus-typing-booster.changes
2019-09-13 15:00:24.865282564 +0200
@@ -1,0 +2,11 @@
+Wed Sep 11 14:44:35 UTC 2019 - maiku.fab...@gmail.com
+
+- Update to 2.6.6
+- When checking whether to show inline completion, normalize the first 
candidate as well
+- Two more test cases in hunspell_suggest.py
+- Make it work correctly with newer French hunspell dictionaries
+- Skip some unittests when dictionaries or python modules needed are not 
installed
+- Update emoji annotations from CLDR
+- Add more test cases to m17n_translit_test.py for si-sayura.mim
+
+---

Old:

  ibus-typing-booster-2.6.5.tar.gz

New:

  ibus-typing-booster-2.6.6.tar.gz



Other differences:
--
++ ibus-typing-booster.spec ++
--- /var/tmp/diff_new_pack.fzD0Bi/_old  2019-09-13 15:00:26.257282624 +0200
+++ /var/tmp/diff_new_pack.fzD0Bi/_new  2019-09-13 15:00:26.269282624 +0200
@@ -15,7 +15,7 @@
 #
 
 Name:   ibus-typing-booster
-Version:2.6.5
+Version:2.6.6
 Release:0 
 Summary:An input completion utility
 License:GPL-3.0+

++ ibus-typing-booster-2.6.5.tar.gz -> ibus-typing-booster-2.6.6.tar.gz 
++
/work/SRC/openSUSE:Factory/ibus-typing-booster/ibus-typing-booster-2.6.5.tar.gz 
/work/SRC/openSUSE:Factory/.ibus-typing-booster.new.7948/ibus-typing-booster-2.6.6.tar.gz
 differ: char 5, line 1




commit liboping for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package liboping for openSUSE:Factory 
checked in at 2019-09-13 15:00:10

Comparing /work/SRC/openSUSE:Factory/liboping (Old)
 and  /work/SRC/openSUSE:Factory/.liboping.new.7948 (New)


Package is "liboping"

Fri Sep 13 15:00:10 2019 rev:13 rq:730235 version:1.9.0

Changes:

--- /work/SRC/openSUSE:Factory/liboping/liboping.changes2016-09-16 
11:00:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.liboping.new.7948/liboping.changes  
2019-09-13 15:00:19.433282335 +0200
@@ -1,0 +2,5 @@
+Tue Sep 10 20:22:16 UTC 2019 - Christophe Giboudeaux 
+
+- Use -ffat-lto-objects when building static libraries.
+
+---



Other differences:
--
++ liboping.spec ++
--- /var/tmp/diff_new_pack.jHC4BI/_old  2019-09-13 15:00:20.013282359 +0200
+++ /var/tmp/diff_new_pack.jHC4BI/_new  2019-09-13 15:00:20.025282359 +0200
@@ -118,6 +118,7 @@
 %__sed -i 's/-${am__api_version}//g' configure
 
 %build
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
 aclocal && automake
 %configure \
 --with-perl-bindings="INSTALLDIRS=vendor"




commit zipkin-cpp-opentracing for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package zipkin-cpp-opentracing for 
openSUSE:Factory checked in at 2019-09-13 15:00:21

Comparing /work/SRC/openSUSE:Factory/zipkin-cpp-opentracing (Old)
 and  /work/SRC/openSUSE:Factory/.zipkin-cpp-opentracing.new.7948 (New)


Package is "zipkin-cpp-opentracing"

Fri Sep 13 15:00:21 2019 rev:2 rq:730319 version:0.3.1

Changes:

--- 
/work/SRC/openSUSE:Factory/zipkin-cpp-opentracing/zipkin-cpp-opentracing.changes
2018-06-29 22:34:49.954083458 +0200
+++ 
/work/SRC/openSUSE:Factory/.zipkin-cpp-opentracing.new.7948/zipkin-cpp-opentracing.changes
  2019-09-13 15:00:26.717282643 +0200
@@ -1,0 +2,6 @@
+Tue Sep 10 20:19:05 UTC 2019 - Christophe Giboudeaux 
+
+- Use -ffat-lto-objects when building static libraries.
+- Remove unneeded cmake parameters. These are already defined by %cmake.
+
+---



Other differences:
--
++ zipkin-cpp-opentracing.spec ++
--- /var/tmp/diff_new_pack.GU0nPy/_old  2019-09-13 15:00:27.641282682 +0200
+++ /var/tmp/diff_new_pack.GU0nPy/_new  2019-09-13 15:00:27.653282683 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package zipkin-cpp-opentracing
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -27,8 +27,8 @@
 Patch0: cmake-lib-install-dir.patch
 BuildRequires:  cmake
 BuildRequires:  gcc-c++
-BuildRequires:  pkgconfig(libcurl)
 BuildRequires:  opentracing-cpp-devel
+BuildRequires:  pkgconfig(libcurl)
 
 %description
 OpenTracing Tracet implementation for Zipkin in a form of library in C++
@@ -61,7 +61,8 @@
 %patch0 -p1
 
 %build
-%cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=ON 
-DBUILD_STATIC_LIBS=ON -DBUILD_TESTING=OFF -DLIB_INSTALL_DIR=%{_libdir}
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
+%cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_STATIC_LIBS=ON -DBUILD_TESTING=OFF
 
 %install
 %cmake_install




commit python-html2text for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-html2text for 
openSUSE:Factory checked in at 2019-09-13 15:00:23

Comparing /work/SRC/openSUSE:Factory/python-html2text (Old)
 and  /work/SRC/openSUSE:Factory/.python-html2text.new.7948 (New)


Package is "python-html2text"

Fri Sep 13 15:00:23 2019 rev:20 rq:730321 version:2019.8.11

Changes:

--- /work/SRC/openSUSE:Factory/python-html2text/python-html2text.changes
2018-12-24 11:38:09.277624483 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-html2text.new.7948/python-html2text.changes  
2019-09-13 15:00:28.777282730 +0200
@@ -1,0 +2,14 @@
+Thu Sep 12 08:45:34 UTC 2019 - Tomáš Chvátal 
+
+- Update to 2019.8.11:
+  * Fix #201: handle / marks mid-text within stressed tags or right 
after stressed tags.
+  * Feature #213: images_as_html config option to always generate an img html 
tag. preserves "height", "width" and "alt" if possible.
+  * Remove support for end-of-life Pythons. Now requires Python 2.7 or 3.4+.
+  * Remove support for retrieving HTML over the network.
+  * Add __main__.py module to allow running the CLI using python -m html2text 

+  * Fix #238: correct spacing when a HTML entity follows a non-stressed tags 
which follow a stressed tag.
+  * Remove unused or deprecated: * html2text.compat.escape() * 
html2text.config.RE_UNESCAPE * html2text.HTML2Text.replaceEntities() * 
html2text.HTML2Text.unescape() * html2text.unescape()
+  * Fix #208: handle LEFT-TO-RIGHT MARK after a stressed tag.
+- Remove patch remove_unittest2.patch
+
+---

Old:

  html2text-2018.1.9.tar.gz
  remove_unittest2.patch

New:

  html2text-2019.8.11.tar.gz



Other differences:
--
++ python-html2text.spec ++
--- /var/tmp/diff_new_pack.sla7A6/_old  2019-09-13 15:00:30.149282789 +0200
+++ /var/tmp/diff_new_pack.sla7A6/_new  2019-09-13 15:00:30.189282790 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-html2text
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,20 +16,17 @@
 #
 
 
-#
 %define upname html2text
-
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
-%bcond_without tests
 Name:   python-%{upname}
-Version:2018.1.9
+Version:2019.8.11
 Release:0
 Summary:Python script for turning HTML into Markdown text
 License:GPL-3.0-only
 Group:  Development/Languages/Python
 URL:https://github.com/Alir3z4/html2text/
 Source: 
https://files.pythonhosted.org/packages/source/h/%{upname}/%{upname}-%{version}.tar.gz
-Patch0: remove_unittest2.patch
+BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
@@ -44,7 +41,6 @@
 
 %prep
 %setup -q -n %{upname}-%{version}
-%patch0 -p1
 # remove useless shebang
 sed -i '/^#!/d' %{upname}/__init__.py
 
@@ -66,10 +62,8 @@
 %postun
 %python_uninstall_alternative html2text
 
-%if %{with tests}
 %check
-%python_exec setup.py test
-%endif
+%pytest
 
 %files %{python_files}
 %license COPYING

++ html2text-2018.1.9.tar.gz -> html2text-2019.8.11.tar.gz ++
 3464 lines of diff (skipped)




commit blogc for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package blogc for openSUSE:Factory checked 
in at 2019-09-13 15:00:13

Comparing /work/SRC/openSUSE:Factory/blogc (Old)
 and  /work/SRC/openSUSE:Factory/.blogc.new.7948 (New)


Package is "blogc"

Fri Sep 13 15:00:13 2019 rev:16 rq:730285 version:0.18.0

Changes:

--- /work/SRC/openSUSE:Factory/blogc/blogc.changes  2019-05-03 
22:47:33.655925465 +0200
+++ /work/SRC/openSUSE:Factory/.blogc.new.7948/blogc.changes2019-09-13 
15:00:23.257282496 +0200
@@ -1,0 +2,11 @@
+Thu Sep 12 06:39:29 UTC 2019 - mvet...@suse.com
+
+- Update to 0.18.0:
+  * blogc-make(1) now includes the pagination_tags rule, to build
+pagination pages for each tag.
+  * Fixed a bug in blogc(1) that prevented digits in -D
+command-line arguments.
+  * Do not show error message when evaluating variables with
+blogc(1)'s -p command-line argument.
+
+---

Old:

  blogc-0.17.0.tar.xz

New:

  blogc-0.18.0.tar.xz



Other differences:
--
++ blogc.spec ++
--- /var/tmp/diff_new_pack.aqAHLm/_old  2019-09-13 15:00:23.841282521 +0200
+++ /var/tmp/diff_new_pack.aqAHLm/_new  2019-09-13 15:00:23.845282522 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   blogc
-Version:0.17.0
+Version:0.18.0
 Release:0
 Summary:Blog compiler
 License:BSD-3-Clause

++ blogc-0.17.0.tar.xz -> blogc-0.18.0.tar.xz ++
 2122 lines of diff (skipped)




commit scdoc for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package scdoc for openSUSE:Factory checked 
in at 2019-09-13 15:00:11

Comparing /work/SRC/openSUSE:Factory/scdoc (Old)
 and  /work/SRC/openSUSE:Factory/.scdoc.new.7948 (New)


Package is "scdoc"

Fri Sep 13 15:00:11 2019 rev:11 rq:730284 version:1.10.0

Changes:

--- /work/SRC/openSUSE:Factory/scdoc/scdoc.changes  2019-08-23 
11:10:07.370455571 +0200
+++ /work/SRC/openSUSE:Factory/.scdoc.new.7948/scdoc.changes2019-09-13 
15:00:20.753282390 +0200
@@ -1,0 +2,8 @@
+Thu Sep 12 06:36:28 UTC 2019 - mvet...@suse.com
+
+- Update to 1.10.0:
+  * tables: add expand options
+  * Add contrib/_incr_version
+- Update scdoc-1.6.1-makefile.patch
+
+---

Old:

  1.9.7.tar.gz

New:

  1.10.0.tar.gz



Other differences:
--
++ scdoc.spec ++
--- /var/tmp/diff_new_pack.dsFn9M/_old  2019-09-13 15:00:21.905282439 +0200
+++ /var/tmp/diff_new_pack.dsFn9M/_new  2019-09-13 15:00:21.929282440 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   scdoc
-Version:1.9.7
+Version:1.10.0
 Release:0
 Summary:A man page generator written in C99
 License:MIT

++ 1.9.7.tar.gz -> 1.10.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/scdoc-1.9.7/Makefile new/scdoc-1.10.0/Makefile
--- old/scdoc-1.9.7/Makefile2019-08-16 02:23:43.0 +0200
+++ new/scdoc-1.10.0/Makefile   2019-09-11 21:15:23.0 +0200
@@ -1,4 +1,4 @@
-VERSION=1.9.6
+VERSION=1.10.0
 CFLAGS+=-g -DVERSION='"$(VERSION)"' -Wall -Wextra -Werror -Wno-unused-parameter
 LDFLAGS+=-static
 INCLUDE+=-Iinclude
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/scdoc-1.9.7/contrib/_incr_version 
new/scdoc-1.10.0/contrib/_incr_version
--- old/scdoc-1.9.7/contrib/_incr_version   1970-01-01 01:00:00.0 
+0100
+++ new/scdoc-1.10.0/contrib/_incr_version  2019-09-11 21:15:23.0 
+0200
@@ -0,0 +1,4 @@
+#!/bin/sh -eux
+sed -i Makefile -e "s/^VERSION=${1}/VERSION=${2}/"
+git add Makefile
+git commit -m "Update version to ${2}"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/scdoc-1.9.7/scdoc.5.scd new/scdoc-1.10.0/scdoc.5.scd
--- old/scdoc-1.9.7/scdoc.5.scd 2019-08-16 02:23:43.0 +0200
+++ new/scdoc-1.10.0/scdoc.5.scd2019-09-11 21:15:23.0 +0200
@@ -155,6 +155,21 @@
 :  世界
!
 
+You may also cause columns to expand to fill the available space with < (left
+align), = (center align), and > (right align), like so:
+
+```
+[[ *Normal column*
+:< Expanded column
+|  *Foo*
+:  Bar
+```
+
+[[ *Normal column*
+:< Expanded column
+|  *Foo*
+:  Bar
+
 ## LITERAL TEXT
 
 You may turn off scdoc formatting and output literal text with escape codes and
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/scdoc-1.9.7/src/main.c new/scdoc-1.10.0/src/main.c
--- old/scdoc-1.9.7/src/main.c  2019-08-16 02:23:43.0 +0200
+++ new/scdoc-1.10.0/src/main.c 2019-09-11 21:15:23.0 +0200
@@ -434,6 +434,9 @@
ALIGN_LEFT,
ALIGN_CENTER,
ALIGN_RIGHT,
+   ALIGN_LEFT_EXPAND,
+   ALIGN_CENTER_EXPAND,
+   ALIGN_RIGHT_EXPAND,
 };
 
 struct table_row {
@@ -508,6 +511,15 @@
case ']':
curcell->align = ALIGN_RIGHT;
break;
+   case '<':
+   curcell->align = ALIGN_LEFT_EXPAND;
+   break;
+   case '=':
+   curcell->align = ALIGN_CENTER_EXPAND;
+   break;
+   case '>':
+   curcell->align = ALIGN_RIGHT_EXPAND;
+   break;
case ' ':
if (prevrow) {
struct table_cell *pcell = prevrow->cell;
@@ -576,8 +588,28 @@
while (currow) {
curcell = currow->cell;
while (curcell) {
-   fprintf(p->output, "%c%s", "lcr"[curcell->align],
-   curcell->next ? " " : "");
+   char *align = "";
+   switch (curcell->align) {
+   case ALIGN_LEFT:
+   align = "l";
+   break;
+   case ALIGN_CENTER:
+   align = "c";
+   break;
+   case ALIGN_RIGHT:
+   align = "r";
+   break;
+   case ALIGN_LEFT_EXPAND:
+  

commit python-influxdb for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-influxdb for openSUSE:Factory 
checked in at 2019-09-13 14:59:59

Comparing /work/SRC/openSUSE:Factory/python-influxdb (Old)
 and  /work/SRC/openSUSE:Factory/.python-influxdb.new.7948 (New)


Package is "python-influxdb"

Fri Sep 13 14:59:59 2019 rev:5 rq:730200 version:5.2.3

Changes:

--- /work/SRC/openSUSE:Factory/python-influxdb/python-influxdb.changes  
2019-05-16 22:07:55.770397697 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-influxdb.new.7948/python-influxdb.changes
2019-09-13 15:00:02.101281600 +0200
@@ -1,0 +2,13 @@
+Wed Sep 11 14:50:13 UTC 2019 - Tomáš Chvátal 
+
+- Update to 5.2.3:
+  * Add consistency param to InfluxDBClient.write_points (#643 thx @RonRothman)
+  * Add UDP example (#648 thx @shantanoo-desai)
+  * Add consistency paramter to write_points (#664 tx @RonRothman)
+  * The query() function now accepts a bind_params argument for parameter 
binding (#678 thx @clslgrnc)
+  * Add get_list_continuous_queries, drop_continuous_query, and 
create_continuous_query management methods for continuous queries (#681 thx 
@lukaszdudek-silvair)
+  * Mutual TLS authentication (#702 thx @LloydW93)
+- Drop merged patches:
+  * python-influxdb-d5d1249.patch
+
+---

Old:

  python-influxdb-d5d1249.patch
  v5.2.2.tar.gz

New:

  v5.2.3.tar.gz



Other differences:
--
++ python-influxdb.spec ++
--- /var/tmp/diff_new_pack.LYxuvz/_old  2019-09-13 15:00:02.821281630 +0200
+++ /var/tmp/diff_new_pack.LYxuvz/_new  2019-09-13 15:00:02.825281631 +0200
@@ -18,15 +18,13 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-influxdb
-Version:5.2.2
+Version:5.2.3
 Release:0
 Summary:InfluxDB client
 License:MIT
 Group:  Development/Languages/Python
-Url:https://github.com/influxdb/influxdb-python
+URL:https://github.com/influxdb/influxdb-python
 Source: 
https://github.com/influxdata/influxdb-python/archive/v%{version}.tar.gz
-# recent changes in master to fix tests
-Patch0: python-influxdb-d5d1249.patch
 # fix module 'distutils' has no attribute 'spawn'
 Patch1: python-influxdb-fix-testsuite.patch
 BuildRequires:  %{python_module python-dateutil >= 2.0.0}
@@ -36,22 +34,21 @@
 BuildRequires:  %{python_module six >= 1.9.0}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
+Requires:   python-python-dateutil >= 2.6.0
+Requires:   python-pytz
+Requires:   python-requests >= 1.17.0
+Requires:   python-six >= 1.10.0
+BuildArch:  noarch
 # SECTION test requirements
-%if 0%{?suse_version} >= 1500
-BuildRequires:  hostname
-%endif
 BuildRequires:  %{python_module mock}
 BuildRequires:  %{python_module nose}
 BuildRequires:  %{python_module pandas}
 BuildRequires:  %{python_module requests-mock}
 BuildRequires:  influxdb
+%if 0%{?suse_version} >= 1500
+BuildRequires:  hostname
+%endif
 # /SECTION
-Requires:   python-python-dateutil >= 2.6.0
-Requires:   python-pytz
-Requires:   python-requests >= 1.17.0
-Requires:   python-six >= 1.10.0
-BuildArch:  noarch
-
 %python_subpackages
 
 %description
@@ -59,14 +56,13 @@
 
 %prep
 %setup -q -n influxdb-python-%{version}
-%patch0 -p1
 %patch1 -p1
 
 %build
 %python_build
 
 %check
-%python_expand nosetests-%{$python_bin_suffix}
+%python_expand nosetests-%{$python_bin_suffix} -v
 
 %install
 %python_install

++ v5.2.2.tar.gz -> v5.2.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/influxdb-python-5.2.2/.travis.yml 
new/influxdb-python-5.2.3/.travis.yml
--- old/influxdb-python-5.2.2/.travis.yml   2019-03-14 15:19:55.0 
+0100
+++ new/influxdb-python-5.2.3/.travis.yml   2019-08-26 19:25:51.0 
+0200
@@ -8,10 +8,12 @@
   - "pypy3"
 
 env:
-  - INFLUXDB_VER=1.2.4
-  - INFLUXDB_VER=1.3.9
-  - INFLUXDB_VER=1.4.2
-  - INFLUXDB_VER=1.5.4
+  - INFLUXDB_VER=1.2.4  # 2017-05-08
+  - INFLUXDB_VER=1.3.9  # 2018-01-19
+  - INFLUXDB_VER=1.4.3  # 2018-01-30
+  - INFLUXDB_VER=1.5.4  # 2018-06-22
+  - INFLUXDB_VER=1.6.4  # 2018-10-24
+  - INFLUXDB_VER=1.7.4  # 2019-02-14
 
 addons:
   apt:
@@ -20,7 +22,31 @@
 
 matrix:
   include:
-- python: 2.7
+- python: 3.7
+  dist: xenial
+  sudo: true
+  env: INFLUXDB_VER=1.2.4
+- python: 3.7
+  dist: xenial
+  sudo: true
+  env: INFLUXDB_VER=1.3.9
+- python: 3.7
+  dist: xenial
+  sudo: true
+  env: INFLUXDB_VER=1.4.3
+- python: 3.7
+  dist: xenial
+  sudo: true
+  env: INFLUXDB_VER=1.5.4
+- python: 3.7
+  dist: xenial
+   

commit yast2-adcommon-python for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package yast2-adcommon-python for 
openSUSE:Factory checked in at 2019-09-13 15:00:06

Comparing /work/SRC/openSUSE:Factory/yast2-adcommon-python (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-adcommon-python.new.7948 (New)


Package is "yast2-adcommon-python"

Fri Sep 13 15:00:06 2019 rev:8 rq:730226 version:1.1

Changes:

--- 
/work/SRC/openSUSE:Factory/yast2-adcommon-python/yast2-adcommon-python.changes  
2019-08-23 11:09:47.822457988 +0200
+++ 
/work/SRC/openSUSE:Factory/.yast2-adcommon-python.new.7948/yast2-adcommon-python.changes
2019-09-13 15:00:10.973281976 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 16:35:17 UTC 2019 - dmul...@suse.com
+
+- Reconnect the ldap session if it times out; (bsc#1150394);
+- 1.1
+
+---

Old:

  yast2-adcommon-python-1.0.tar.bz2

New:

  yast2-adcommon-python-1.1.tar.bz2



Other differences:
--
++ yast2-adcommon-python.spec ++
--- /var/tmp/diff_new_pack.ibWceD/_old  2019-09-13 15:00:11.561282001 +0200
+++ /var/tmp/diff_new_pack.ibWceD/_new  2019-09-13 15:00:11.565282001 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-adcommon-python
-Version:1.0
+Version:1.1
 Release:0
 Summary:Common code for the yast python ad modules
 License:GPL-3.0-or-later

++ yast2-adcommon-python-1.0.tar.bz2 -> yast2-adcommon-python-1.1.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-adcommon-python-1.0/adcommon/yldap.py 
new/yast2-adcommon-python-1.1/adcommon/yldap.py
--- old/yast2-adcommon-python-1.0/adcommon/yldap.py 2019-08-22 
21:51:25.0 +0200
+++ new/yast2-adcommon-python-1.1/adcommon/yldap.py 2019-09-11 
22:32:13.0 +0200
@@ -123,13 +123,26 @@
 ycpbuiltins.y2error('Failed to initialize ldap connection')
 raise Exception('Failed to initialize ldap connection')
 
+def __ldap_disconnect(self, e):
+if e.args[0] == ldb.ERR_OPERATIONS_ERROR and \
+  ('connection to remote LDAP server dropped' in e.args[1] or 
'NT_STATUS_CONNECTION_RESET' in e.args[1]):
+return True
+return False
+
 def ldap_search_s(self, *args):
 return self.ldap_search(*args)
 
 def ldap_search(self, base=None, scope=None, expression=None, attrs=None, 
controls=None):
 try:
 attrs = [a.decode() if type(a) is six.binary_type else a for a in 
attrs]
-return [(str(m.get('dn')), {k: [bytes(v) for v in m.get(k)] for k 
in m.keys() if k != 'dn'}) for m in self.search(base, scope, expression, attrs, 
controls)]
+try:
+return [(str(m.get('dn')), {k: [bytes(v) for v in m.get(k)] 
for k in m.keys() if k != 'dn'}) for m in self.search(base, scope, expression, 
attrs, controls)]
+except ldb.LdbError as e:
+if self.__ldap_disconnect(e):
+self.__ldap_connect()
+return [(str(m.get('dn')), {k: [bytes(v) for v in 
m.get(k)] for k in m.keys() if k != 'dn'}) for m in self.search(base, scope, 
expression, attrs, controls)]
+else:
+raise
 except ldb.LdbError as e:
 y2error_dialog(self.__ldap_exc_msg(e))
 except Exception as e:
@@ -139,7 +152,14 @@
 def ldap_add(self, dn, attrs):
 try:
 attrs['dn'] = dn
-return self.add(attrs)
+try:
+return self.add(attrs)
+except ldb.LdbError as e:
+if self.__ldap_disconnect(e):
+self.__ldap_connect()
+return self.add(attrs)
+else:
+raise
 except Exception as e:
 raise LdapException(self.__ldap_exc_msg(e), 
self.__ldap_exc_info(e))
 
@@ -150,7 +170,14 @@
 attrs = {m[1].decode() if type(m[1]) is six.binary_type else m[1]: 
m[2].decode() if type(m[2]) is six.binary_type else str(m[2]) for m in attrs if 
m[0] == 0}
 try:
 attrs['dn'] = dn
-return self.modify(ldb.Message.from_dict(self, attrs))
+try:
+return self.modify(ldb.Message.from_dict(self, attrs))
+except ldb.LdbError as e:
+if self.__ldap_disconnect(e):
+self.__ldap_connect()
+return self.modify(ldb.Message.from_dict(self, attrs))
+else:
+raise
 except ldb.LdbError as e:
 y2error_dialog(self.__ldap_exc_msg(e))
 except Exception as e:
@@ -159,7 +186,14 @@
 
 def ldap_delete(self, *args):
 try:

commit python-identify for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-identify for openSUSE:Factory 
checked in at 2019-09-13 14:59:54

Comparing /work/SRC/openSUSE:Factory/python-identify (Old)
 and  /work/SRC/openSUSE:Factory/.python-identify.new.7948 (New)


Package is "python-identify"

Fri Sep 13 14:59:54 2019 rev:5 rq:730196 version:1.4.7

Changes:

--- /work/SRC/openSUSE:Factory/python-identify/python-identify.changes  
2019-07-31 14:28:04.238172150 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-identify.new.7948/python-identify.changes
2019-09-13 14:59:54.417281275 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 15:00:28 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.4.7:
+  * no upstream changelog
+
+---

Old:

  identify-1.4.5.tar.gz

New:

  identify-1.4.7.tar.gz



Other differences:
--
++ python-identify.spec ++
--- /var/tmp/diff_new_pack.wc3ad5/_old  2019-09-13 14:59:54.825281292 +0200
+++ /var/tmp/diff_new_pack.wc3ad5/_new  2019-09-13 14:59:54.829281292 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-identify
-Version:1.4.5
+Version:1.4.7
 Release:0
 Summary:File identification library for Python
 License:MIT

++ identify-1.4.5.tar.gz -> identify-1.4.7.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/identify-1.4.5/identify/extensions.py 
new/identify-1.4.7/identify/extensions.py
--- old/identify-1.4.5/identify/extensions.py   2019-06-15 16:59:33.0 
+0200
+++ new/identify-1.4.7/identify/extensions.py   2019-08-27 15:51:13.0 
+0200
@@ -90,6 +90,7 @@
 'nim': {'text', 'nim'},
 'nims': {'text', 'nim'},
 'nimble': {'text', 'nimble'},
+'nix': {'text', 'nix'},
 'otf': {'binary', 'otf'},
 'p12': {'binary', 'p12'},
 'patch': {'text', 'diff'},
@@ -189,6 +190,7 @@
 '.npmignore': {'text', 'npmignore'},
 '.yamllint': {'text', 'yaml', 'yamllint'},
 'AUTHORS': EXTENSIONS['txt'],
+'CMakeLists.txt': EXTENSIONS['cmake'],
 'COPYING': EXTENSIONS['txt'],
 'Dockerfile': {'text', 'dockerfile'},
 'Gemfile': EXTENSIONS['rb'],
@@ -199,6 +201,7 @@
 'NOTICE': EXTENSIONS['txt'],
 'PATENTS': EXTENSIONS['txt'],
 'Pipfile': EXTENSIONS['toml'],
+'Pipfile.lock': EXTENSIONS['json'],
 'README': EXTENSIONS['txt'],
 'Rakefile': EXTENSIONS['rb'],
 'setup.cfg': EXTENSIONS['ini'],
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/identify-1.4.5/identify/identify.py 
new/identify-1.4.7/identify/identify.py
--- old/identify-1.4.5/identify/identify.py 2019-06-15 16:59:33.0 
+0200
+++ new/identify-1.4.7/identify/identify.py 2019-08-27 15:51:13.0 
+0200
@@ -80,7 +80,7 @@
 ret = set()
 
 # Allow e.g. "Dockerfile.xenial" to match "Dockerfile"
-for part in {filename} | set(filename.split('.')):
+for part in [filename] + filename.split('.'):
 if part in extensions.NAMES:
 ret.update(extensions.NAMES[part])
 break
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/identify-1.4.5/setup.cfg new/identify-1.4.7/setup.cfg
--- old/identify-1.4.5/setup.cfg2019-06-15 16:59:33.0 +0200
+++ new/identify-1.4.7/setup.cfg2019-08-27 15:51:13.0 +0200
@@ -1,6 +1,6 @@
 [metadata]
 name = identify
-version = 1.4.5
+version = 1.4.7
 description = File identification library for Python
 long_description = file: README.md
 long_description_content_type = text/markdown
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/identify-1.4.5/tests/identify_test.py 
new/identify-1.4.7/tests/identify_test.py
--- old/identify-1.4.5/tests/identify_test.py   2019-06-15 16:59:33.0 
+0200
+++ new/identify-1.4.7/tests/identify_test.py   2019-08-27 15:51:13.0 
+0200
@@ -118,6 +118,8 @@
 ('Dockerfile', {'text', 'dockerfile'}),
 ('Dockerfile.xenial', {'text', 'dockerfile'}),
 ('xenial.Dockerfile', {'text', 'dockerfile'}),
+('Pipfile', {'text', 'toml'}),
+('Pipfile.lock', {'text', 'json'}),
 ('mod/test.py', {'text', 'python'}),
 ('mod/Dockerfile', {'text', 'dockerfile'}),
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/identify-1.4.5/tox.ini new/identify-1.4.7/tox.ini
--- old/identify-1.4.5/tox.ini  2019-06-15 16:59:33.0 +0200
+++ new/identify-1.4.7/tox.ini  2019-08-27 15:51:13.0 +0200
@@ -12,11 +12,6 @@
 pre-commit install -f 

commit python-jeepney for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-jeepney for openSUSE:Factory 
checked in at 2019-09-13 14:59:40

Comparing /work/SRC/openSUSE:Factory/python-jeepney (Old)
 and  /work/SRC/openSUSE:Factory/.python-jeepney.new.7948 (New)


Package is "python-jeepney"

Fri Sep 13 14:59:40 2019 rev:2 rq:730190 version:0.4.1

Changes:

--- /work/SRC/openSUSE:Factory/python-jeepney/python-jeepney.changes
2019-06-19 21:10:36.850638377 +0200
+++ /work/SRC/openSUSE:Factory/.python-jeepney.new.7948/python-jeepney.changes  
2019-09-13 14:59:43.545280814 +0200
@@ -1,0 +2,8 @@
+Wed Sep 11 14:40:14 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.4.1:
+  * Avoid using :class:`asyncio.Future` for the blocking integration.
+  * Set the 'destination' field on method return and error messages to the
+'sender' from the parent message.
+
+---

Old:

  jeepney-0.4.tar.gz

New:

  jeepney-0.4.1.tar.gz



Other differences:
--
++ python-jeepney.spec ++
--- /var/tmp/diff_new_pack.2JtbbE/_old  2019-09-13 14:59:44.409280851 +0200
+++ /var/tmp/diff_new_pack.2JtbbE/_new  2019-09-13 14:59:44.413280851 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package xpython-jeepney
+# spec file for package python-jeepney
 #
 # Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
@@ -19,16 +19,16 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-jeepney
-Version:0.4
+Version:0.4.1
 Release:0
 Summary:Low-level, pure Python DBus protocol wrapper
 License:MIT
 Group:  Development/Languages/Python
 URL:https://gitlab.com/takluyver/jeepney
 Source: 
https://files.pythonhosted.org/packages/source/j/jeepney/jeepney-%{version}.tar.gz
+BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{python_module testpath}
-BuildRequires:  %{python_module pytest}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
 BuildArch:  noarch

++ jeepney-0.4.tar.gz -> jeepney-0.4.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jeepney-0.4/PKG-INFO new/jeepney-0.4.1/PKG-INFO
--- old/jeepney-0.4/PKG-INFO1970-01-01 01:00:00.0 +0100
+++ new/jeepney-0.4.1/PKG-INFO  1970-01-01 01:00:00.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: jeepney
-Version: 0.4
+Version: 0.4.1
 Summary: Low-level, pure Python DBus protocol wrapper.
 Home-page: https://gitlab.com/takluyver/jeepney
 Author: Thomas Kluyver
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jeepney-0.4/docs/release-notes.rst 
new/jeepney-0.4.1/docs/release-notes.rst
--- old/jeepney-0.4/docs/release-notes.rst  2018-09-24 12:23:34.639535000 
+0200
+++ new/jeepney-0.4.1/docs/release-notes.rst2019-08-11 12:55:34.956099300 
+0200
@@ -1,6 +1,15 @@
 Release notes
 =
 
+0.4.1
+-
+
+* Avoid using :class:`asyncio.Future` for the blocking integration.
+* Set the 'destination' field on method return and error messages to the
+  'sender' from the parent message.
+
+Thanks to Oscar Caballero and Thomas Grainger for contributing to this release.
+
 0.4
 ---
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jeepney-0.4/jeepney/__init__.py 
new/jeepney-0.4.1/jeepney/__init__.py
--- old/jeepney-0.4/jeepney/__init__.py 2018-09-24 12:06:38.586247000 +0200
+++ new/jeepney-0.4.1/jeepney/__init__.py   2019-08-11 12:52:49.375820900 
+0200
@@ -5,4 +5,4 @@
 from .bus import find_session_bus, find_system_bus
 from .wrappers import *
 
-__version__ = '0.4'
+__version__ = '0.4.1'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jeepney-0.4/jeepney/integrate/blocking.py 
new/jeepney-0.4.1/jeepney/integrate/blocking.py
--- old/jeepney-0.4/jeepney/integrate/blocking.py   2018-09-24 
12:03:49.135421300 +0200
+++ new/jeepney-0.4.1/jeepney/integrate/blocking.py 2019-08-11 
12:50:37.797772600 +0200
@@ -1,6 +1,5 @@
 """Synchronous IO wrappers around jeepney
 """
-from asyncio import Future
 import functools
 import socket
 
@@ -11,11 +10,32 @@
 from jeepney.routing import Router
 from jeepney.bus_messages import message_bus
 
+
+class _Future:
+def __init__(self):
+self._result = None
+
+def done(self):
+return bool(self._result)
+
+def set_exception(self, exception):
+self._result = (False, exception)
+
+def set_result(self, result): 
+self._result = (True, result)
+
+def result(self):
+success, value = 

commit telegram-desktop for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package telegram-desktop for 
openSUSE:Factory checked in at 2019-09-13 14:59:55

Comparing /work/SRC/openSUSE:Factory/telegram-desktop (Old)
 and  /work/SRC/openSUSE:Factory/.telegram-desktop.new.7948 (New)


Package is "telegram-desktop"

Fri Sep 13 14:59:55 2019 rev:22 rq:730197 version:1.8.8

Changes:

--- /work/SRC/openSUSE:Factory/telegram-desktop/telegram-desktop.changes
2019-09-09 12:36:26.701461914 +0200
+++ 
/work/SRC/openSUSE:Factory/.telegram-desktop.new.7948/telegram-desktop.changes  
2019-09-13 14:59:58.353281441 +0200
@@ -1,0 +2,24 @@
+Tue Sep 10 16:01:53 UTC 2019 - Marcel Kuehlhorn 
+
+- Update to 1.8.8
+  * Create new themes based on your color and wallpaper choices.
+  * Share your themes with other users via links.
+  * Update your theme for all its users when you change something.
+
+---
+Tue Sep 10 08:32:42 UTC 2019 - Marcel Kuehlhorn 
+
+- Update to 1.8.7 (beta)
+  * Bug fixes and other minor improvements.
+- Disable GTK integration again due to Cinnamon hard requiring
+  libqt5-qtstyleplugins-platformtheme-gtk2 (boo#1149130)
+
+---
+Mon Sep  9 09:03:52 UTC 2019 - Marcel Kuehlhorn 
+
+- Update to 1.8.5 (beta)
+  * Create new themes based on your color and wallpaper choices.
+  * Share your themes with other users via links.
+  * Update your theme for all its users when you change something.
+
+---

Old:

  v1.8.4.tar.gz

New:

  v1.8.8.tar.gz



Other differences:
--
++ telegram-desktop.spec ++
--- /var/tmp/diff_new_pack.vqmo7S/_old  2019-09-13 15:00:00.053281513 +0200
+++ /var/tmp/diff_new_pack.vqmo7S/_new  2019-09-13 15:00:00.053281513 +0200
@@ -29,7 +29,7 @@
 %endif
 
 Name:   telegram-desktop
-Version:1.8.4
+Version:1.8.8
 Release:0
 Summary:Messaging application with a focus on speed and security
 License:GPL-3.0-only
@@ -143,7 +143,6 @@
 Requires:   hicolor-icon-theme
 Requires:   icu
 Requires:   openssl
-Conflicts:  libqt5-qtstyleplugins-platformtheme-gtk2
 ExclusiveArch:  x86_64
 
 %description





++ patch.py ++
--- /var/tmp/diff_new_pack.vqmo7S/_old  2019-09-13 15:00:00.141281517 +0200
+++ /var/tmp/diff_new_pack.vqmo7S/_new  2019-09-13 15:00:00.141281517 +0200
@@ -135,13 +135,13 @@
 child.remove("'<(linux_path_va)/lib'")
 child.remove("'<(linux_path_vdpau)/lib'")
 child.append("'/usr/lib64/'")
-
+
 child = jsonobj["'conditions'"][0][1]["'libraries'"]
 child.remove("'breakpad_client'")
 child.remove("'composeplatforminputcontextplugin'")
 child.remove("'ibusplatforminputcontextplugin'")
 child.remove("'fcitxplatforminputcontextplugin'")
-child.remove("'himeplatforminputcontextplugin'")
+child.remove("'himeplatforminputcontextplugin'")
 child.remove("'nimfplatforminputcontextplugin'")
 child.remove("'liblzma.a'")
 child.remove("'libopenal.a'")
@@ -184,7 +184,7 @@
 child["'qt_lib_prefix'"] = "''"
 child["'qt_lib_debug_postfix'"] = "''"
 child["'qt_lib_release_postfix'"] = "''"
-
+
 child = 
jsonobj["'variables'"]["'variables'"]["'variables'"]["'conditions'"][3][1]["'qt_libs'"];
 child.remove("'qxcb'")
 child.remove("'Qt5XcbQpa'")
@@ -222,7 +222,7 @@
 child.append("'/usr/include/qt5/QtCore/<(qt_version)'")
 child.append("'/usr/include/qt5/QtGui/<(qt_version)/QtGui'")
 child.append("'/usr/include/qt5/QtCore/<(qt_version)/QtCore'")
-
+
 child = jsonobj["'conditions'"][0][1]["'libraries'"]
 child.remove("'<(linux_path_xkbcommon)/lib/libxkbcommon.a'")
 child.remove("'<(linux_lib_ssl)'")
@@ -269,7 +269,7 @@
 child.append("'TDESKTOP_DISABLE_AUTOUPDATE'")
 child.append("'TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME'")
 child.append("'TDESKTOP_DISABLE_UNITY_INTEGRATION'")
-# child.append("'TDESKTOP_DISABLE_GTK_INTEGRATION'")
+child.append("'TDESKTOP_DISABLE_GTK_INTEGRATION'")
 child.append("'TDESKTOP_DISABLE_OPENAL_EFFECTS'")
 child.remove("'AL_LIBTYPE_STATIC'")
 child = jsonobj["'targets'"][0]["'include_dirs'"]
@@ -298,9 +298,9 @@
 json = load_json(filename)
 json = op(json)
 save_json(json, filename)
-
-tl_path = './Telegram/gyp/telegram_linux.gypi' 
-settings_path = './Telegram/gyp/settings_linux.gypi' 
+
+tl_path = './Telegram/gyp/telegram_linux.gypi'
+settings_path = './Telegram/gyp/settings_linux.gypi'
 qt_path = './Telegram/gyp/qt.gypi'
 tg_path = './Telegram/gyp/Telegram.gyp'
 moc_path = './Telegram/gyp/qt_moc.gypi'



++ v1.8.4.tar.gz -> 

commit libdevil for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package libdevil for openSUSE:Factory 
checked in at 2019-09-13 15:00:00

Comparing /work/SRC/openSUSE:Factory/libdevil (Old)
 and  /work/SRC/openSUSE:Factory/.libdevil.new.7948 (New)


Package is "libdevil"

Fri Sep 13 15:00:00 2019 rev:9 rq:730204 version:1.7.8

Changes:

--- /work/SRC/openSUSE:Factory/libdevil/libdevil.changes2019-08-22 
10:53:44.34961 +0200
+++ /work/SRC/openSUSE:Factory/.libdevil.new.7948/libdevil.changes  
2019-09-13 15:00:03.177281646 +0200
@@ -1,0 +2,5 @@
+Wed Aug 21 08:05:03 UTC 2019 - Jan Engelhardt 
+
+- Remove bias and marketing wording from descriptions.
+
+---



Other differences:
--
++ libdevil.spec ++
--- /var/tmp/diff_new_pack.k1XSGf/_old  2019-09-13 15:00:04.125281686 +0200
+++ /var/tmp/diff_new_pack.k1XSGf/_new  2019-09-13 15:00:04.129281686 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -21,9 +21,9 @@
 Name:   libdevil
 Version:1.7.8
 Release:0
-Summary:A full featured cross platform image library
+Summary:A cross-platform image library
 License:LGPL-2.1-only
-Group:  System/Libraries
+Group:  Development/Libraries/C and C++
 URL:http://openil.sourceforge.net/
 Source: 
http://sourceforge.net/projects/openil/files/DevIL/1.7.8/DevIL-%{version}.tar.gz
 Patch0: DevIL-%{version}-return-random-data.patch
@@ -53,12 +53,11 @@
 BuildRequires:  pkgconfig(xrender)
 
 %description
-Developer's Image Library (DevIL) is a programmer's library to develop
-applications with very powerful image loading capabilities, yet is easy
-for a developer to learn and use. Ultimate control of images is left
-to the developer, so unnecessary conversions, etc. are not performed.
-DevIL utilizes a simple, yet powerful, syntax. DevIL can load, save,
-convert, manipulate, filter and display a wide variety of image formats.
+Developer's Image Library (DevIL) is a programmer's library to
+develop applications with image loading capabilities. Control of
+images is left to the developer, so unnecessary conversions, etc. are
+not performed. DevIL can load, save, convert, manipulate, filter and
+display a wide variety of image formats.
 
 Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .jpg,
 .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic, .png, .ppm,
@@ -67,14 +66,12 @@
 .pbm, .pcx, .hdr, .pgm,.png, .ppm, .raw, .sgi, .tga and .tif.
 
 DevIL currently supports the following APIs for display: OpenGL,
-Windows GDI, SDL, DirectX and Allegro. Compilers that can compile
-DevIL or use it include Djgpp, MSVC++, Linux gcc, Delphi, Visual
-Basic, Power Basic and Dev-C++.
+SDL and Allegro.
 
 %package tools
 Summary:Tools that can be used when using DevIL libraries
 License:LGPL-2.1-only AND GPL-3.0-or-later
-Group:  System/Libraries
+Group:  Development/Tools/Other
 Requires:   libIL%{libIL} = %{version}
 
 %description tools
@@ -82,7 +79,7 @@
 formats.
 
 %package -n libIL%{libIL}
-Summary:A full featured cross platform image library
+Summary:A cross-platform image library
 License:LGPL-2.1-only
 Group:  System/Libraries
 Provides:   libdevil1 = %{version}
@@ -93,12 +90,11 @@
 %endif
 
 %description -n  libIL%{libIL}
-Developer's Image Library (DevIL) is a programmer's library to develop
-applications with very powerful image loading capabilities, yet is easy
-for a developer to learn and use. Ultimate control of images is left
-to the developer, so unnecessary conversions, etc. are not performed.
-DevIL utilizes a simple, yet powerful, syntax. DevIL can load, save,
-convert, manipulate, filter and display a wide variety of image formats.
+Developer's Image Library (DevIL) is a programmer's library to
+develop applications with image loading capabilities. Control of
+images is left to the developer, so unnecessary conversions, etc. are
+not performed. DevIL can load, save, convert, manipulate, filter and
+display a wide variety of image formats.
 
 Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .jpg,
 .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic, .png, .ppm,
@@ -107,12 +103,10 @@
 .pbm, .pcx, .hdr, .pgm,.png, .ppm, .raw, .sgi, .tga and .tif.
 
 DevIL currently supports the following APIs for display: OpenGL,
-Windows GDI, SDL, DirectX and Allegro. Compilers that can compile
-DevIL or use it 

commit python-jellyfish for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-jellyfish for 
openSUSE:Factory checked in at 2019-09-13 14:59:36

Comparing /work/SRC/openSUSE:Factory/python-jellyfish (Old)
 and  /work/SRC/openSUSE:Factory/.python-jellyfish.new.7948 (New)


Package is "python-jellyfish"

Fri Sep 13 14:59:36 2019 rev:4 rq:730189 version:0.7.2

Changes:

--- /work/SRC/openSUSE:Factory/python-jellyfish/python-jellyfish.changes
2019-04-04 12:07:49.893416265 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-jellyfish.new.7948/python-jellyfish.changes  
2019-09-13 14:59:41.349280721 +0200
@@ -1,0 +2,8 @@
+Wed Sep 11 14:35:56 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.7.2:
+  * fix CJellyfish damerau_levenshtein w/ unicode, thanks to immerrr
+  * fix final H in NYSIIS
+  * fix issue w/ trailing W in metaphone
+
+---

Old:

  jellyfish-0.7.1.tar.gz

New:

  jellyfish-0.7.2.tar.gz



Other differences:
--
++ python-jellyfish.spec ++
--- /var/tmp/diff_new_pack.RfcMtD/_old  2019-09-13 14:59:42.129280754 +0200
+++ /var/tmp/diff_new_pack.RfcMtD/_new  2019-09-13 14:59:42.133280754 +0200
@@ -19,7 +19,7 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-jellyfish
-Version:0.7.1
+Version:0.7.2
 Release:0
 Summary:A library for doing approximate and phonetic matching of 
strings
 License:BSD-2-Clause
@@ -56,6 +56,7 @@
 %python_expand %fdupes %{buildroot}%{$python_sitearch}
 
 %check
+export PYTHONDONTWRITEBYTECODE=1
 %pytest %{buildroot}%{$python_sitearch}/jellyfish/test.py
 
 %files %{python_files}

++ jellyfish-0.7.1.tar.gz -> jellyfish-0.7.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jellyfish-0.7.1/PKG-INFO new/jellyfish-0.7.2/PKG-INFO
--- old/jellyfish-0.7.1/PKG-INFO2019-01-11 05:35:53.0 +0100
+++ new/jellyfish-0.7.2/PKG-INFO2019-06-05 17:04:54.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.2
 Name: jellyfish
-Version: 0.7.1
+Version: 0.7.2
 Summary: a library for doing approximate and phonetic matching of strings.
 Home-page: http://github.com/jamesturk/jellyfish
 License: UNKNOWN
@@ -8,8 +8,8 @@
 jellyfish
 =
 
-.. image:: https://travis-ci.org/jamesturk/jellyfish.svg?branch=master
-:target: https://travis-ci.org/jamesturk/jellyfish
+.. image:: https://travis-ci.com/jamesturk/jellyfish.svg?branch=master
+:target: https://travis-ci.com/jamesturk/jellyfish
 
 .. image:: 
https://coveralls.io/repos/jamesturk/jellyfish/badge.png?branch=master
 :target: https://coveralls.io/r/jamesturk/jellyfish
@@ -97,5 +97,6 @@
 Classifier: Programming Language :: Python :: 3.4
 Classifier: Programming Language :: Python :: 3.5
 Classifier: Programming Language :: Python :: 3.6
+Classifier: Programming Language :: Python :: 3.7
 Classifier: Topic :: Text Processing :: Linguistic
 Requires-Python: >3.4
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jellyfish-0.7.1/README.rst 
new/jellyfish-0.7.2/README.rst
--- old/jellyfish-0.7.1/README.rst  2019-01-11 05:30:23.0 +0100
+++ new/jellyfish-0.7.2/README.rst  2019-06-05 02:01:29.0 +0200
@@ -2,8 +2,8 @@
 jellyfish
 =
 
-.. image:: https://travis-ci.org/jamesturk/jellyfish.svg?branch=master
-:target: https://travis-ci.org/jamesturk/jellyfish
+.. image:: https://travis-ci.com/jamesturk/jellyfish.svg?branch=master
+:target: https://travis-ci.com/jamesturk/jellyfish
 
 .. image:: 
https://coveralls.io/repos/jamesturk/jellyfish/badge.png?branch=master
 :target: https://coveralls.io/r/jamesturk/jellyfish
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jellyfish-0.7.1/cjellyfish/damerau_levenshtein.c 
new/jellyfish-0.7.2/cjellyfish/damerau_levenshtein.c
--- old/jellyfish-0.7.1/cjellyfish/damerau_levenshtein.c2019-01-11 
05:32:26.0 +0100
+++ new/jellyfish-0.7.2/cjellyfish/damerau_levenshtein.c2019-06-05 
01:39:11.0 +0200
@@ -3,6 +3,139 @@
 #include 
 #include 
 
+/*
+
+  Trie is a nested search tree, where each node's key is broken down into parts
+  and looking up a certain key means a sequence of lookups in small associative
+  arrays. They are usually used for strings, where a word "foo" would be
+  basically looked up as trie["f"]["o"]["o"].
+
+  In this case, the tries split the incoming integer into segments, omitting
+  upper zero ones, and they are looked up as follows:
+
+  I.e. for segments 

commit python-importlab for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-importlab for 
openSUSE:Factory checked in at 2019-09-13 14:59:52

Comparing /work/SRC/openSUSE:Factory/python-importlab (Old)
 and  /work/SRC/openSUSE:Factory/.python-importlab.new.7948 (New)


Package is "python-importlab"

Fri Sep 13 14:59:52 2019 rev:2 rq:730195 version:0.5.1

Changes:

--- /work/SRC/openSUSE:Factory/python-importlab/python-importlab.changes
2019-03-04 09:21:38.984587220 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-importlab.new.7948/python-importlab.changes  
2019-09-13 14:59:53.773281247 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 14:58:59 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.5.1:
+  * FIX: Correct a broken import
+
+---

Old:

  importlab-0.5.tar.gz

New:

  importlab-0.5.1.tar.gz



Other differences:
--
++ python-importlab.spec ++
--- /var/tmp/diff_new_pack.MnKExf/_old  2019-09-13 14:59:54.189281265 +0200
+++ /var/tmp/diff_new_pack.MnKExf/_new  2019-09-13 14:59:54.189281265 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-importlab
-Version:0.5
+Version:0.5.1
 Release:0
 Summary:A library to calculate python dependency graphs
 License:Apache-2.0

++ importlab-0.5.tar.gz -> importlab-0.5.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/importlab-0.5/CHANGELOG new/importlab-0.5.1/CHANGELOG
--- old/importlab-0.5/CHANGELOG 2018-12-26 23:11:35.0 +0100
+++ new/importlab-0.5.1/CHANGELOG   2019-05-24 20:29:51.0 +0200
@@ -1,3 +1,6 @@
+Version 0.5.1 (2019-05-24)
+* FIX: Correct a broken import
+
 Version 0.5 (2018-12-26)
 * Support `from . import Symbol` style of relative imports
 * Set the default target Python version to the host version
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/importlab-0.5/PKG-INFO new/importlab-0.5.1/PKG-INFO
--- old/importlab-0.5/PKG-INFO  2019-01-07 13:27:20.0 +0100
+++ new/importlab-0.5.1/PKG-INFO2019-05-24 20:47:35.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.2
 Name: importlab
-Version: 0.5
+Version: 0.5.1
 Summary: A library to calculate python dependency graphs.
 Home-page: https://github.com/google/importlab
 Maintainer: Google Inc.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/importlab-0.5/importlab/import_finder.py 
new/importlab-0.5.1/importlab/import_finder.py
--- old/importlab-0.5/importlab/import_finder.py2018-12-26 
19:43:06.0 +0100
+++ new/importlab-0.5.1/importlab/import_finder.py  2019-05-24 
20:29:51.0 +0200
@@ -12,7 +12,21 @@
 # Pytype doesn't recognize the `major` attribute:
 # https://github.com/google/pytype/issues/127.
 if sys.version_info[0] >= 3:
-import importlib
+# Note that `import importlib` does not work: accessing `importlib.util`
+# will give an attribute error. This is hard to reproduce in a unit test 
but
+# can be seen by install importlab in a Python 3 environment and running
+# `importlab --tree --trim` on a file that imports one of:
+#   * jsonschema (`pip install jsonschema`)
+#   * pytype (`pip install pytype`),
+#   * dotenv (`pip install python-dotenv`)
+#   * IPython (`pip install ipython`)
+# A correct output will look like:
+#   Reading 1 files
+#   Source tree:
+#   + foo.py
+#   :: jsonschema/__init__.py
+# An incorrect output will be missing the line with the import.
+import importlib.util
 else:
 import imp
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/importlab-0.5/importlab.egg-info/PKG-INFO 
new/importlab-0.5.1/importlab.egg-info/PKG-INFO
--- old/importlab-0.5/importlab.egg-info/PKG-INFO   2019-01-07 
13:27:20.0 +0100
+++ new/importlab-0.5.1/importlab.egg-info/PKG-INFO 2019-05-24 
20:47:35.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.2
 Name: importlab
-Version: 0.5
+Version: 0.5.1
 Summary: A library to calculate python dependency graphs.
 Home-page: https://github.com/google/importlab
 Maintainer: Google Inc.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/importlab-0.5/setup.py new/importlab-0.5.1/setup.py
--- old/importlab-0.5/setup.py  2018-12-26 23:11:47.0 +0100
+++ new/importlab-0.5.1/setup.py2019-05-24 20:29:51.0 +0200
@@ -13,7 +13,7 @@
 EMAIL = 'pytype-...@google.com'
 AUTHOR = 'Google Inc.'
 REQUIRES_PYTHON = '>=2.7.0'
-VERSION = '0.5'
+VERSION = '0.5.1'
 
 

commit python-ioflo for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-ioflo for openSUSE:Factory 
checked in at 2019-09-13 14:59:46

Comparing /work/SRC/openSUSE:Factory/python-ioflo (Old)
 and  /work/SRC/openSUSE:Factory/.python-ioflo.new.7948 (New)


Package is "python-ioflo"

Fri Sep 13 14:59:46 2019 rev:14 rq:730192 version:1.7.6

Changes:

--- /work/SRC/openSUSE:Factory/python-ioflo/python-ioflo.changes
2019-03-26 22:34:40.053673275 +0100
+++ /work/SRC/openSUSE:Factory/.python-ioflo.new.7948/python-ioflo.changes  
2019-09-13 14:59:52.257281183 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 14:42:12 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.7.6:
+  * Some bug fixes
+
+---

Old:

  ioflo-1.7.5.tar.gz

New:

  ioflo-1.7.6.tar.gz



Other differences:
--
++ python-ioflo.spec ++
--- /var/tmp/diff_new_pack.6EAgI9/_old  2019-09-13 14:59:52.901281210 +0200
+++ /var/tmp/diff_new_pack.6EAgI9/_new  2019-09-13 14:59:52.905281210 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-ioflo
-Version:1.7.5
+Version:1.7.6
 Release:0
 Summary:Python framework for programming autonomous systems
 License:Apache-2.0
@@ -45,6 +45,9 @@
 
 %prep
 %setup -q -n ioflo-%{version}
+# invalid syntax
+rm -r ioflo/aio/http/test
+rm -r ioflo/aid/test
 
 %build
 %python_build
@@ -55,8 +58,7 @@
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
 %check
-# The tests actually fail with syntax error, upstream should sort it out
-#%%python_expand PYTHONPATH=%{buildroot}%{$python_sitelib} $python -m unittest 
discover
+%pytest
 
 %files %{python_files}
 %license LICENSE* LEGAL

++ ioflo-1.7.5.tar.gz -> ioflo-1.7.6.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ioflo-1.7.5/ChangeLog.md new/ioflo-1.7.6/ChangeLog.md
--- old/ioflo-1.7.5/ChangeLog.md2018-09-15 19:45:41.0 +0200
+++ new/ioflo-1.7.6/ChangeLog.md2019-08-21 01:49:25.0 +0200
@@ -3,7 +3,17 @@
 ---
 
 
-20180915  Not released yet
+20190820
+
+
+1.7.6
+
+Some bug fixes
+
+
+
+
+20180915
 
 
 1.7.5
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ioflo-1.7.5/PKG-INFO new/ioflo-1.7.6/PKG-INFO
--- old/ioflo-1.7.5/PKG-INFO2018-09-15 19:55:45.0 +0200
+++ new/ioflo-1.7.6/PKG-INFO2019-08-26 21:50:16.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: ioflo
-Version: 1.7.5
+Version: 1.7.6
 Summary: Flow Based Programming Automated Reasoning Engine and Automation 
Operation System
 Home-page: https://github.com/ioflo/ioflo
 Author: Samuel M. Smith
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ioflo-1.7.5/ioflo/__metadata__.py 
new/ioflo-1.7.6/ioflo/__metadata__.py
--- old/ioflo-1.7.5/ioflo/__metadata__.py   2017-09-13 18:13:41.0 
+0200
+++ new/ioflo-1.7.6/ioflo/__metadata__.py   2019-08-21 02:17:48.0 
+0200
@@ -2,7 +2,7 @@
 Ioflo package metadata
 '''
 
-__version_info__ = (1, 7, 5)
+__version_info__ = (1, 7, 6)
 __version__ = '{0}.{1}.{2}'.format(*__version_info__)
 __author__ = "Samuel M. Smith"
 __license__ = "Apache 2.0"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ioflo-1.7.5/ioflo/aio/http/serving.py 
new/ioflo-1.7.6/ioflo/aio/http/serving.py
--- old/ioflo-1.7.5/ioflo/aio/http/serving.py   2017-09-15 18:59:15.0 
+0200
+++ new/ioflo-1.7.6/ioflo/aio/http/serving.py   2019-08-21 06:16:47.0 
+0200
@@ -101,6 +101,10 @@
 if connection and "keep-alive" in connection.lower():
 self.persisted = True
 
+if self.persisted:  # override timeout so server never timesout
+self.incomer.timeout =  0.0  # never timesout
+
+
 def parseHead(self):
 """
 Generator to parse headers in heading of .msg
@@ -146,7 +150,6 @@
 self.hostname = pathSplits.hostname
 self.port = pathSplits.port
 self.query = pathSplits.query  # WSGI spec leaves it quoted do not 
unquote
-#self.query = httping.unquoteQuery(pathSplits.query)  # unquote only 
the values
 self.fragment = pathSplits.fragment
 
 leaderParser = httping.parseLeader(raw=self.msg,
@@ -316,6 +319,9 @@
 """
 Close any resources
 """
+if not self.closed and not self.ended:
+self.write(b'')  # in case chunked send empty chunk to terminate
+self.ended = True
 self.closed = True
 
 def reset(self, environ, 

commit libguestfs for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package libguestfs for openSUSE:Factory 
checked in at 2019-09-13 14:59:43

Comparing /work/SRC/openSUSE:Factory/libguestfs (Old)
 and  /work/SRC/openSUSE:Factory/.libguestfs.new.7948 (New)


Package is "libguestfs"

Fri Sep 13 14:59:43 2019 rev:68 rq:730191 version:1.38.0

Changes:

--- /work/SRC/openSUSE:Factory/libguestfs/libguestfs.changes2019-08-23 
11:07:47.378472880 +0200
+++ /work/SRC/openSUSE:Factory/.libguestfs.new.7948/libguestfs.changes  
2019-09-13 14:59:46.177280925 +0200
@@ -1,0 +2,18 @@
+Tue Sep 10 09:59:19 UTC 2019 - Christophe Giboudeaux 
+
+- Use -ffat-lto-objects when building static libraries.
+
+---
+Mon Sep  9 16:32:56 UTC 2019 - Larry Dewey 
+
+- Added lvm2 to Requires for using virt-resize of xfs images.
+  (bsc#1138860)
+
+---
+Wed Aug 28 20:10:11 UTC 2019 - Guilherme Moro 
+
+- Add sysconfig-netconfig to appliance (boo#1136878)
+  Patches added:
+netconfig.patch
+
+---

New:

  netconfig.patch



Other differences:
--
++ libguestfs.spec ++
--- /var/tmp/diff_new_pack.Xr8EyN/_old  2019-09-13 14:59:46.921280957 +0200
+++ /var/tmp/diff_new_pack.Xr8EyN/_new  2019-09-13 14:59:46.921280957 +0200
@@ -153,6 +153,7 @@
 Patch52:0003-inspector-rpm-summary-and-description-may-not-be-utf.patch
 # Our patches
 Patch100:   appliance.patch
+Patch101:   netconfig.patch
 
 Source0:
http://download.libguestfs.org/1.38-stable/libguestfs-%{version}.tar.gz
 Source1:libguestfs.rpmlintrc
@@ -168,6 +169,7 @@
 
 #
 Requires:   guestfs-tools
+Requires:   lvm2
 Requires:   virt-v2v = %{version}
 
 %description
@@ -409,7 +411,6 @@
 BuildRequires:  syslinux
 %endif
 BuildRequires:  ldmtool
-BuildRequires:  pkgconfig(systemd)
 BuildRequires:  systemd-sysvinit
 BuildRequires:  tar
 BuildRequires:  terminfo-base
@@ -419,6 +420,7 @@
 BuildRequires:  util-linux-lang
 BuildRequires:  xfsprogs
 BuildRequires:  xz
+BuildRequires:  pkgconfig(systemd)
 
 # Needed by guestfsd which is burried in the appliance
 #
@@ -568,8 +570,10 @@
 %patch51 -p1
 %patch52 -p1
 %patch100 -p1
+%patch101 -p1
 
 %build
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
 bison --version
 # [Bug 789653] sles11 perl obsoletes perl-Pod-Simple unconditionally
 export PERLLIB=`echo $PWD/Pod-Simple-*/lib`

++ netconfig.patch ++
diff -up ./appliance/packagelist.in.netconfig ./appliance/packagelist.in
--- ./appliance/packagelist.in.netconfig2019-08-28 19:26:50.290462768 
+0100
+++ ./appliance/packagelist.in  2019-08-28 19:27:05.530462557 +0100
@@ -161,6 +161,7 @@ ifelse(SUSE,1,
   ntfs-3g
   reiserfs
   squashfs
+  sysconfig-netconfig
   systemd
   vim
   xz



commit python-jenkins-job-builder for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-jenkins-job-builder for 
openSUSE:Factory checked in at 2019-09-13 14:59:35

Comparing /work/SRC/openSUSE:Factory/python-jenkins-job-builder (Old)
 and  /work/SRC/openSUSE:Factory/.python-jenkins-job-builder.new.7948 (New)


Package is "python-jenkins-job-builder"

Fri Sep 13 14:59:35 2019 rev:19 rq:730188 version:3.0.2

Changes:

--- 
/work/SRC/openSUSE:Factory/python-jenkins-job-builder/python-jenkins-job-builder.changes
2019-08-13 13:27:31.581319514 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-jenkins-job-builder.new.7948/python-jenkins-job-builder.changes
  2019-09-13 14:59:39.209280630 +0200
@@ -1,0 +2,9 @@
+Wed Sep 11 14:31:14 UTC 2019 - Tomáš Chvátal 
+
+- Update to 3.0.2:
+  * Added missing 'filters' parameters for rabbitmq trigger plugin
+  * Add support of "disableDeferredWipeout" option to workspace cleanup plugin
+  * Avoid ResourceWarning by closing file handlers when finished
+  * Add support for two new plugins, and a new version of one
+
+---

Old:

  jenkins-job-builder-3.0.1.tar.gz

New:

  jenkins-job-builder-3.0.2.tar.gz



Other differences:
--
++ python-jenkins-job-builder.spec ++
--- /var/tmp/diff_new_pack.VsNmT7/_old  2019-09-13 14:59:40.509280685 +0200
+++ /var/tmp/diff_new_pack.VsNmT7/_new  2019-09-13 14:59:40.513280685 +0200
@@ -19,7 +19,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-jenkins-job-builder
-Version:3.0.1
+Version:3.0.2
 Release:0
 Summary:Program for configuring Jenkins jobs with YAML
 License:Apache-2.0

++ jenkins-job-builder-3.0.1.tar.gz -> jenkins-job-builder-3.0.2.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jenkins-job-builder-3.0.1/AUTHORS 
new/jenkins-job-builder-3.0.2/AUTHORS
--- old/jenkins-job-builder-3.0.1/AUTHORS   2019-07-29 21:49:12.0 
+0200
+++ new/jenkins-job-builder-3.0.2/AUTHORS   2019-08-15 21:08:43.0 
+0200
@@ -1,3 +1,4 @@
+Achim Leitner 
 Adam Harwell 
 Adam Kaufman 
 Adam Spiers 
@@ -271,7 +272,9 @@
 Sebastian Schuberth 
 Sergey Kolekonov 
 Sergey Kulanov 
+Sergey Lebedev 
 Sergey Yudin 
+Sergii Kipot 
 Shane Wang 
 Simon Gomizelj 
 Simon Kuhnle 
@@ -321,6 +324,7 @@
 Vishal Bhoj 
 Vitaliy Lotorev 
 Vitaliy Lotorev 
+Waldemar Znoinski 
 Wayne 
 Wayne Warren 
 Wayne Warren 
@@ -340,6 +344,7 @@
 hayderimran7 
 hayderimran7 
 imran 
+kendallpcdoctor 
 liyuanzhen 
 mhuin 
 mlua 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jenkins-job-builder-3.0.1/ChangeLog 
new/jenkins-job-builder-3.0.2/ChangeLog
--- old/jenkins-job-builder-3.0.1/ChangeLog 2019-07-29 21:49:12.0 
+0200
+++ new/jenkins-job-builder-3.0.2/ChangeLog 2019-08-15 21:08:43.0 
+0200
@@ -1,10 +1,20 @@
 CHANGES
 ===
 
+3.0.2
+-
+
+* Add support of "disableDeferredWipeout" option to workspace cleanup plugin
+* Fix encoding error in builder.py
+* Added missing 'filters' parameters for rabbitmq trigger plugin
+* add support for 'override-topic' in jms-messaging trigger
+
 3.0.1
 -
 
 * Revert "Add support for rendering jinja template as yaml"
+* Avoid ResourceWarning by closing file handlers when finished
+* Add support for two new plugins, and a new version of one
 
 3.0.0
 -
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jenkins-job-builder-3.0.1/PKG-INFO 
new/jenkins-job-builder-3.0.2/PKG-INFO
--- old/jenkins-job-builder-3.0.1/PKG-INFO  2019-07-29 21:49:13.0 
+0200
+++ new/jenkins-job-builder-3.0.2/PKG-INFO  2019-08-15 21:08:44.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: jenkins-job-builder
-Version: 3.0.1
+Version: 3.0.2
 Summary: Manage Jenkins jobs with YAML
 Home-page: https://docs.openstack.org/infra/jenkins-job-builder/
 Author: OpenStack Infrastructure Team
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/jenkins-job-builder-3.0.1/jenkins_job_builder.egg-info/PKG-INFO 
new/jenkins-job-builder-3.0.2/jenkins_job_builder.egg-info/PKG-INFO
--- old/jenkins-job-builder-3.0.1/jenkins_job_builder.egg-info/PKG-INFO 
2019-07-29 21:49:12.0 +0200
+++ new/jenkins-job-builder-3.0.2/jenkins_job_builder.egg-info/PKG-INFO 
2019-08-15 21:08:43.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: jenkins-job-builder
-Version: 3.0.1
+Version: 3.0.2
 Summary: Manage Jenkins jobs with YAML
 Home-page: https://docs.openstack.org/infra/jenkins-job-builder/
 Author: OpenStack Infrastructure Team
diff -urN 

commit linux32 for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package linux32 for openSUSE:Factory checked 
in at 2019-09-13 14:59:30

Comparing /work/SRC/openSUSE:Factory/linux32 (Old)
 and  /work/SRC/openSUSE:Factory/.linux32.new.7948 (New)


Package is "linux32"

Fri Sep 13 14:59:30 2019 rev:22 rq:730179 version:1.0

Changes:

--- /work/SRC/openSUSE:Factory/linux32/linux32.changes  2011-10-21 
16:32:53.0 +0200
+++ /work/SRC/openSUSE:Factory/.linux32.new.7948/linux32.changes
2019-09-13 14:59:35.389280468 +0200
@@ -1,0 +2,6 @@
+Mon Sep  9 13:40:11 UTC 2019 - Martin Pluskal 
+
+- Cleanup spec file with spec-cleaner
+- Fix dependencies (recommend xterm) 
+
+---



Other differences:
--
++ linux32.spec ++
--- /var/tmp/diff_new_pack.s0k4WI/_old  2019-09-13 14:59:36.233280504 +0200
+++ /var/tmp/diff_new_pack.s0k4WI/_new  2019-09-13 14:59:36.233280504 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package linux32
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,30 +12,29 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
-
 Name:   linux32
-BuildRequires:  update-desktop-files
-BuildRequires:  hicolor-icon-theme
-Url:ftp://ftp.x86-64.org/pub/linux/tools/linux32/
-License:GPL-2.0+
-Group:  System/Kernel
-Summary:32-Bit Emulation Utility for x86-64
 Version:1.0
-Release:478
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-ExclusiveArch:  x86_64
-Source2:%name.desktop
+Release:0
+Summary:32-Bit Emulation Utility for x86-64
+License:GPL-2.0-or-later
+Group:  System/Kernel
+URL:http://ftp.x86-64.org/pub/linux/tools/linux32/
+Source2:%{name}.desktop
 Source3:konsole-linux32-24.png
 Source4:konsole-linux32-32.png
 Source5:konsole-linux32-48.png
 Source6:konsole-linux32-64.png
 Source7:konsole-linux32-128.png
 Source8:konsole-linux32-256.png
+BuildRequires:  hicolor-icon-theme
+BuildRequires:  update-desktop-files
 Requires:   util-linux >= 2.16
+Recommends: xterm-bin
+ExclusiveArch:  x86_64
 
 %description
 This is a small tool for 32-bit emulation in Linux/x86-64. It allows
@@ -44,41 +43,20 @@
 not affect the current shell or processes above it in the process
 hierarchy.
 
-
-
-Authors:
-
-Andi Kleen 
-
 %prep
 
 %build
 
 %install
-install -D -m 644 %{S:3} 
%{buildroot}%{_datadir}/icons/hicolor/24x24/apps/konsole-linux32.png
-install -D -m 644 %{S:4} 
%{buildroot}%{_datadir}/icons/hicolor/32x32/apps/konsole-linux32.png
-install -D -m 644 %{S:5} 
%{buildroot}%{_datadir}/icons/hicolor/48x48/apps/konsole-linux32.png
-install -D -m 644 %{S:6} 
%{buildroot}%{_datadir}/icons/hicolor/64x64/apps/konsole-linux32.png
-install -D -m 644 %{S:7} 
%{buildroot}%{_datadir}/icons/hicolor/128x128/apps/konsole-linux32.png
-install -D -m 644 %{S:8} 
%{buildroot}%{_datadir}/icons/hicolor/256x256/apps/konsole-linux32.png
-%suse_update_desktop_file -i %name
-
-%post
-%if 0%{?suse_version} > 1130
-%icon_theme_cache_post
-%else
-gtk-update-icon-cache %{_datadir}/icons/hicolor || true
-%endif
-
-%postun
-%if 0%{?suse_version} > 1130
-%icon_theme_cache_postun
-%else
-gtk-update-icon-cache %{_datadir}/icons/hicolor || true
-%endif
+install -D -m 644 %{SOURCE3} 
%{buildroot}%{_datadir}/icons/hicolor/24x24/apps/konsole-linux32.png
+install -D -m 644 %{SOURCE4} 
%{buildroot}%{_datadir}/icons/hicolor/32x32/apps/konsole-linux32.png
+install -D -m 644 %{SOURCE5} 
%{buildroot}%{_datadir}/icons/hicolor/48x48/apps/konsole-linux32.png
+install -D -m 644 %{SOURCE6} 
%{buildroot}%{_datadir}/icons/hicolor/64x64/apps/konsole-linux32.png
+install -D -m 644 %{SOURCE7} 
%{buildroot}%{_datadir}/icons/hicolor/128x128/apps/konsole-linux32.png
+install -D -m 644 %{SOURCE8} 
%{buildroot}%{_datadir}/icons/hicolor/256x256/apps/konsole-linux32.png
+%suse_update_desktop_file -i %{name}
 
 %files
-%defattr(-,root,root)
 %{_datadir}/applications/*
 %{_datadir}/icons/hicolor/*/apps/konsole-linux32.png
 










commit python-certbot-dns-nsone for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-nsone for 
openSUSE:Factory checked in at 2019-09-13 14:59:20

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-nsone (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-nsone.new.7948 (New)


Package is "python-certbot-dns-nsone"

Fri Sep 13 14:59:20 2019 rev:11 rq:730171 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-nsone/python-certbot-dns-nsone.changes
2019-08-28 16:04:39.362771873 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-nsone.new.7948/python-certbot-dns-nsone.changes
  2019-09-13 14:59:21.689279888 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:30:54 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-nsone-0.37.2.tar.gz

New:

  certbot-dns-nsone-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-nsone.spec ++
--- /var/tmp/diff_new_pack.lRocWK/_old  2019-09-13 14:59:22.113279905 +0200
+++ /var/tmp/diff_new_pack.lRocWK/_new  2019-09-13 14:59:22.117279906 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-nsone
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:NS1 Authenticator plugin for Certbot
 License:Apache-2.0

++ certbot-dns-nsone-0.37.2.tar.gz -> certbot-dns-nsone-0.38.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-nsone-0.37.2/PKG-INFO 
new/certbot-dns-nsone-0.38.0/PKG-INFO
--- old/certbot-dns-nsone-0.37.2/PKG-INFO   2019-08-21 23:49:13.0 
+0200
+++ new/certbot-dns-nsone-0.38.0/PKG-INFO   2019-09-03 21:43:11.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-nsone
-Version: 0.37.2
+Version: 0.38.0
 Summary: NS1 DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-nsone-0.37.2/certbot_dns_nsone.egg-info/PKG-INFO 
new/certbot-dns-nsone-0.38.0/certbot_dns_nsone.egg-info/PKG-INFO
--- old/certbot-dns-nsone-0.37.2/certbot_dns_nsone.egg-info/PKG-INFO
2019-08-21 23:49:13.0 +0200
+++ new/certbot-dns-nsone-0.38.0/certbot_dns_nsone.egg-info/PKG-INFO
2019-09-03 21:43:11.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-nsone
-Version: 0.37.2
+Version: 0.38.0
 Summary: NS1 DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-nsone-0.37.2/setup.py 
new/certbot-dns-nsone-0.38.0/setup.py
--- old/certbot-dns-nsone-0.37.2/setup.py   2019-08-21 23:48:41.0 
+0200
+++ new/certbot-dns-nsone-0.38.0/setup.py   2019-09-03 21:42:37.0 
+0200
@@ -2,7 +2,7 @@
 from setuptools import find_packages
 
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit python-certbot-nginx for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-nginx for 
openSUSE:Factory checked in at 2019-09-13 14:59:25

Comparing /work/SRC/openSUSE:Factory/python-certbot-nginx (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-nginx.new.7948 (New)


Package is "python-certbot-nginx"

Fri Sep 13 14:59:25 2019 rev:11 rq:730174 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-nginx/python-certbot-nginx.changes
2019-08-28 16:04:45.510770949 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-nginx.new.7948/python-certbot-nginx.changes
  2019-09-13 14:59:26.673280099 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:31:27 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * Disable session tickets for Nginx users when appropriate.
+
+---

Old:

  certbot-nginx-0.37.2.tar.gz

New:

  certbot-nginx-0.38.0.tar.gz



Other differences:
--
++ python-certbot-nginx.spec ++
--- /var/tmp/diff_new_pack.T45RqV/_old  2019-09-13 14:59:27.501280134 +0200
+++ /var/tmp/diff_new_pack.T45RqV/_new  2019-09-13 14:59:27.529280135 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-nginx
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:Nginx plugin for Certbot
 License:Apache-2.0

++ certbot-nginx-0.37.2.tar.gz -> certbot-nginx-0.38.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-nginx-0.37.2/PKG-INFO 
new/certbot-nginx-0.38.0/PKG-INFO
--- old/certbot-nginx-0.37.2/PKG-INFO   2019-08-21 23:48:52.0 +0200
+++ new/certbot-nginx-0.38.0/PKG-INFO   2019-09-03 21:42:49.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-nginx
-Version: 0.37.2
+Version: 0.38.0
 Summary: Nginx plugin for Certbot
 Home-page: https://github.com/letsencrypt/letsencrypt
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-nginx-0.37.2/certbot_nginx/tests/parser_test.py 
new/certbot-nginx-0.38.0/certbot_nginx/tests/parser_test.py
--- old/certbot-nginx-0.37.2/certbot_nginx/tests/parser_test.py 2019-08-21 
23:48:40.0 +0200
+++ new/certbot-nginx-0.38.0/certbot_nginx/tests/parser_test.py 2019-09-03 
21:42:35.0 +0200
@@ -30,8 +30,16 @@
 self.assertEqual(nparser.root, self.config_path)
 
 def test_root_absolute(self):
-nparser = parser.NginxParser(os.path.relpath(self.config_path))
-self.assertEqual(nparser.root, self.config_path)
+curr_dir = os.getcwd()
+try:
+# On Windows current directory may be on a different drive than 
self.tempdir.
+# However a relative path between two different drives is invalid. 
So we move to
+# self.tempdir to ensure that we stay on the same drive.
+os.chdir(self.temp_dir)
+nparser = parser.NginxParser(os.path.relpath(self.config_path))
+self.assertEqual(nparser.root, self.config_path)
+finally:
+os.chdir(curr_dir)
 
 def test_root_no_trailing_slash(self):
 nparser = parser.NginxParser(self.config_path + os.path.sep)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-nginx-0.37.2/certbot_nginx/tests/util.py 
new/certbot-nginx-0.38.0/certbot_nginx/tests/util.py
--- old/certbot-nginx-0.37.2/certbot_nginx/tests/util.py2019-08-21 
23:48:40.0 +0200
+++ new/certbot-nginx-0.38.0/certbot_nginx/tests/util.py2019-09-03 
21:42:35.0 +0200
@@ -3,7 +3,6 @@
 import shutil
 import tempfile
 import unittest
-import warnings
 
 import josepy as jose
 import mock
@@ -11,6 +10,7 @@
 import zope.component
 
 from certbot import configuration
+from certbot import util
 from certbot.compat import os
 from certbot.plugins import common
 from certbot.tests import util as test_util
@@ -34,20 +34,16 @@
 "rsa512_key.pem"))
 
 def tearDown(self):
-# On Windows we have various files which are not correctly closed at 
the time of tearDown.
-# For know, we log them until a proper file close handling is written.
-# Useful for development only, so no warning when we are on a CI 
process.
-def onerror_handler(_, path, excinfo):
-"""On error handler"""
-if not os.environ.get('APPVEYOR'):  # pragma: no cover
-message = ('Following error occurred when deleting path {0}'
-   'during tearDown process: {1}'.format(path, 
str(excinfo)))
-

commit python-certbot-dns-rfc2136 for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-rfc2136 for 
openSUSE:Factory checked in at 2019-09-13 14:59:21

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-rfc2136 (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-rfc2136.new.7948 (New)


Package is "python-certbot-dns-rfc2136"

Fri Sep 13 14:59:21 2019 rev:11 rq:730172 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-rfc2136/python-certbot-dns-rfc2136.changes
2019-08-28 16:04:43.562771242 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-rfc2136.new.7948/python-certbot-dns-rfc2136.changes
  2019-09-13 14:59:23.405279960 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:31:11 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-rfc2136-0.37.2.tar.gz

New:

  certbot-dns-rfc2136-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-rfc2136.spec ++
--- /var/tmp/diff_new_pack.rv2wmc/_old  2019-09-13 14:59:23.885279981 +0200
+++ /var/tmp/diff_new_pack.rv2wmc/_new  2019-09-13 14:59:23.889279981 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-rfc2136
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:RFC 2136 DNS Authenticator plugin for Certbot
 License:Apache-2.0

++ certbot-dns-rfc2136-0.37.2.tar.gz -> certbot-dns-rfc2136-0.38.0.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-rfc2136-0.37.2/PKG-INFO 
new/certbot-dns-rfc2136-0.38.0/PKG-INFO
--- old/certbot-dns-rfc2136-0.37.2/PKG-INFO 2019-08-21 23:49:17.0 
+0200
+++ new/certbot-dns-rfc2136-0.38.0/PKG-INFO 2019-09-03 21:43:16.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-rfc2136
-Version: 0.37.2
+Version: 0.38.0
 Summary: RFC 2136 DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-rfc2136-0.37.2/certbot_dns_rfc2136.egg-info/PKG-INFO 
new/certbot-dns-rfc2136-0.38.0/certbot_dns_rfc2136.egg-info/PKG-INFO
--- old/certbot-dns-rfc2136-0.37.2/certbot_dns_rfc2136.egg-info/PKG-INFO
2019-08-21 23:49:17.0 +0200
+++ new/certbot-dns-rfc2136-0.38.0/certbot_dns_rfc2136.egg-info/PKG-INFO
2019-09-03 21:43:16.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-rfc2136
-Version: 0.37.2
+Version: 0.38.0
 Summary: RFC 2136 DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-rfc2136-0.37.2/setup.py 
new/certbot-dns-rfc2136-0.38.0/setup.py
--- old/certbot-dns-rfc2136-0.37.2/setup.py 2019-08-21 23:48:41.0 
+0200
+++ new/certbot-dns-rfc2136-0.38.0/setup.py 2019-09-03 21:42:37.0 
+0200
@@ -2,7 +2,7 @@
 from setuptools import find_packages
 
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit python-certbot-dns-dnsmadeeasy for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-dnsmadeeasy for 
openSUSE:Factory checked in at 2019-09-13 14:59:13

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-dnsmadeeasy (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-dnsmadeeasy.new.7948 
(New)


Package is "python-certbot-dns-dnsmadeeasy"

Fri Sep 13 14:59:13 2019 rev:11 rq:730167 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-dnsmadeeasy/python-certbot-dns-dnsmadeeasy.changes
2019-08-28 16:04:28.602773491 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-dnsmadeeasy.new.7948/python-certbot-dns-dnsmadeeasy.changes
  2019-09-13 14:59:13.917279558 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:29:58 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-dnsmadeeasy-0.37.2.tar.gz

New:

  certbot-dns-dnsmadeeasy-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-dnsmadeeasy.spec ++
--- /var/tmp/diff_new_pack.lsmQuN/_old  2019-09-13 14:59:14.349279576 +0200
+++ /var/tmp/diff_new_pack.lsmQuN/_new  2019-09-13 14:59:14.349279576 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-dnsmadeeasy
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:DNS Made Easy Authenticator plugin for Certbot
 License:Apache-2.0

++ certbot-dns-dnsmadeeasy-0.37.2.tar.gz -> 
certbot-dns-dnsmadeeasy-0.38.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-dnsmadeeasy-0.37.2/PKG-INFO 
new/certbot-dns-dnsmadeeasy-0.38.0/PKG-INFO
--- old/certbot-dns-dnsmadeeasy-0.37.2/PKG-INFO 2019-08-21 23:49:02.0 
+0200
+++ new/certbot-dns-dnsmadeeasy-0.38.0/PKG-INFO 2019-09-03 21:43:00.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-dnsmadeeasy
-Version: 0.37.2
+Version: 0.38.0
 Summary: DNS Made Easy DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-dnsmadeeasy-0.37.2/certbot_dns_dnsmadeeasy.egg-info/PKG-INFO 
new/certbot-dns-dnsmadeeasy-0.38.0/certbot_dns_dnsmadeeasy.egg-info/PKG-INFO
--- 
old/certbot-dns-dnsmadeeasy-0.37.2/certbot_dns_dnsmadeeasy.egg-info/PKG-INFO
2019-08-21 23:49:02.0 +0200
+++ 
new/certbot-dns-dnsmadeeasy-0.38.0/certbot_dns_dnsmadeeasy.egg-info/PKG-INFO
2019-09-03 21:43:00.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-dnsmadeeasy
-Version: 0.37.2
+Version: 0.38.0
 Summary: DNS Made Easy DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-dnsmadeeasy-0.37.2/setup.py 
new/certbot-dns-dnsmadeeasy-0.38.0/setup.py
--- old/certbot-dns-dnsmadeeasy-0.37.2/setup.py 2019-08-21 23:48:41.0 
+0200
+++ new/certbot-dns-dnsmadeeasy-0.38.0/setup.py 2019-09-03 21:42:36.0 
+0200
@@ -2,7 +2,7 @@
 from setuptools import find_packages
 
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit python-certbot-dns-luadns for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-luadns for 
openSUSE:Factory checked in at 2019-09-13 14:59:18

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-luadns (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-luadns.new.7948 (New)


Package is "python-certbot-dns-luadns"

Fri Sep 13 14:59:18 2019 rev:11 rq:730170 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-luadns/python-certbot-dns-luadns.changes
  2019-08-28 16:04:36.942772237 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-luadns.new.7948/python-certbot-dns-luadns.changes
2019-09-13 14:59:19.769279806 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:30:42 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-luadns-0.37.2.tar.gz

New:

  certbot-dns-luadns-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-luadns.spec ++
--- /var/tmp/diff_new_pack.GZ88ju/_old  2019-09-13 14:59:20.197279824 +0200
+++ /var/tmp/diff_new_pack.GZ88ju/_new  2019-09-13 14:59:20.201279824 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-luadns
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:LuaDNS Authenticator plugin for Certbot
 License:Apache-2.0

++ certbot-dns-luadns-0.37.2.tar.gz -> certbot-dns-luadns-0.38.0.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-luadns-0.37.2/PKG-INFO 
new/certbot-dns-luadns-0.38.0/PKG-INFO
--- old/certbot-dns-luadns-0.37.2/PKG-INFO  2019-08-21 23:49:11.0 
+0200
+++ new/certbot-dns-luadns-0.38.0/PKG-INFO  2019-09-03 21:43:09.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-luadns
-Version: 0.37.2
+Version: 0.38.0
 Summary: LuaDNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-luadns-0.37.2/certbot_dns_luadns.egg-info/PKG-INFO 
new/certbot-dns-luadns-0.38.0/certbot_dns_luadns.egg-info/PKG-INFO
--- old/certbot-dns-luadns-0.37.2/certbot_dns_luadns.egg-info/PKG-INFO  
2019-08-21 23:49:11.0 +0200
+++ new/certbot-dns-luadns-0.38.0/certbot_dns_luadns.egg-info/PKG-INFO  
2019-09-03 21:43:09.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-luadns
-Version: 0.37.2
+Version: 0.38.0
 Summary: LuaDNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-luadns-0.37.2/setup.py 
new/certbot-dns-luadns-0.38.0/setup.py
--- old/certbot-dns-luadns-0.37.2/setup.py  2019-08-21 23:48:41.0 
+0200
+++ new/certbot-dns-luadns-0.38.0/setup.py  2019-09-03 21:42:37.0 
+0200
@@ -2,7 +2,7 @@
 from setuptools import find_packages
 
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit exim for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package exim for openSUSE:Factory checked in 
at 2019-09-13 14:59:26

Comparing /work/SRC/openSUSE:Factory/exim (Old)
 and  /work/SRC/openSUSE:Factory/.exim.new.7948 (New)


Package is "exim"

Fri Sep 13 14:59:26 2019 rev:53 rq:730177 version:4.92.2

Changes:

--- /work/SRC/openSUSE:Factory/exim/exim.changes2019-07-26 
12:42:39.673848205 +0200
+++ /work/SRC/openSUSE:Factory/.exim.new.7948/exim.changes  2019-09-13 
14:59:30.289280252 +0200
@@ -0,0 +1,8 @@
+---
+Sat Sep  7 18:22:08 UTC 2019 - po...@cmdline.net
+
+- update to exim 4.92.2
+  * CVE-2019-15846: fix against remote attackers executing arbitrary code as
+root via a trailing backslash
+
+---

Old:

  exim-4.92.1.tar.bz2
  exim-4.92.1.tar.bz2.asc

New:

  exim-4.92.2.tar.bz2
  exim-4.92.2.tar.bz2.asc



Other differences:
--
++ exim.spec ++
--- /var/tmp/diff_new_pack.Qopg5T/_old  2019-09-13 14:59:31.229280292 +0200
+++ /var/tmp/diff_new_pack.Qopg5T/_new  2019-09-13 14:59:31.229280292 +0200
@@ -72,7 +72,7 @@
 %endif
 Requires(pre):  fileutils textutils
 %endif
-Version:4.92.1
+Version:4.92.2
 Release:0
 %if %{with_mysql}
 BuildRequires:  mysql-devel

++ exim-4.92.1.tar.bz2 -> exim-4.92.2.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/exim-4.92.1/doc/ChangeLog 
new/exim-4.92.2/doc/ChangeLog
--- old/exim-4.92.1/doc/ChangeLog   2019-07-18 20:55:56.0 +0200
+++ new/exim-4.92.2/doc/ChangeLog   2019-09-02 23:57:27.0 +0200
@@ -4,6 +4,11 @@
 affect Exim's operation, with an unchanged configuration file.  For new
 options, and new features, see the NewStuff file next to this ChangeLog.
 
+Exim version 4.92.2
+---
+
+HS/01 Handle trailing backslash gracefully. (CVE-2019-15846)
+
 
 Exim version 4.92.1
 ---
File old/exim-4.92.1/doc/cve-2019-13917 is a regular file while file 
new/exim-4.92.2/doc/cve-2019-13917 is a directory
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/exim-4.92.1/doc/cve-2019-15846/cve.txt 
new/exim-4.92.2/doc/cve-2019-15846/cve.txt
--- old/exim-4.92.1/doc/cve-2019-15846/cve.txt  1970-01-01 01:00:00.0 
+0100
+++ new/exim-4.92.2/doc/cve-2019-15846/cve.txt  2019-09-02 23:57:27.0 
+0200
@@ -0,0 +1,45 @@
+CVE ID: CVE-2019-15846
+Date:   2019-09-02 (CVE assigned)
+Credits:Zerons  for the initial report
+Qualys https://www.qualys.com/ for the analysis
+Version(s): all versions up to and including 4.92.1
+Issue:  A local or remote attacker can execute programs with root
+privileges.
+
+Conditions to be vulnerable
+===
+
+If your Exim server accepts TLS connections, it is vulnerable. This does
+not depend on the TLS libray, so both, GnuTLS and OpenSSL are affected.
+
+Details
+===
+
+The vulnerability is exploitable by sending a SNI ending in a
+backslash-null sequence during the initial TLS handshake. The exploit
+exists as a POC. For more details see the document qualys.mbx
+
+Mitigation
+==
+
+Do not offer TLS. (This mitigation is not recommended.)
+
+Fix
+===
+
+Download and build a fixed version:
+
+Tarballs: https://ftp.exim.org/pub/exim/exim4/
+Git:  https://github.com/Exim/exim.git
+  - tagexim-4.92.2
+  - branch exim-4.92.2+fixes
+
+The tagged commit is the officially released version. The +fixes branch
+isn't officially maintained, but contains the security fix *and* useful
+fixes.
+
+If you can't install the above versions, ask your package maintainer for
+a version containing the backported fix. On request and depending on our
+resources we will support you in backporting the fix.  (Please note,
+the Exim project officially doesn't support versions prior the current
+stable version.)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/exim-4.92.1/doc/cve-2019-15846/mitre.mbx 
new/exim-4.92.2/doc/cve-2019-15846/mitre.mbx
--- old/exim-4.92.1/doc/cve-2019-15846/mitre.mbx1970-01-01 
01:00:00.0 +0100
+++ new/exim-4.92.2/doc/cve-2019-15846/mitre.mbx2019-09-02 
23:57:27.0 +0200
@@ -0,0 +1,84 @@
+From cve-requ...@mitre.org Mon Sep  2 18:12:21 2019
+Return-Path: 
+Authentication-Results: mx.net.schlittermann.de; iprev=pass
+ (smtpvbsrv1.mitre.org) smtp.remote-ip=198.49.146.234; spf=pass
+ smtp.mailfrom=mitre.org; dkim=pass header.d=mitre.org header.s=selector1
+ header.a=rsa-sha256; dmarc=pass 

commit python-certbot-dns-route53 for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-route53 for 
openSUSE:Factory checked in at 2019-09-13 14:59:23

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-route53 (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-route53.new.7948 (New)


Package is "python-certbot-dns-route53"

Fri Sep 13 14:59:23 2019 rev:11 rq:730173 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-route53/python-certbot-dns-route53.changes
2019-08-28 18:35:04.093288024 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-route53.new.7948/python-certbot-dns-route53.changes
  2019-09-13 14:59:25.753280060 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:31:19 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-route53-0.37.2.tar.gz

New:

  certbot-dns-route53-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-route53.spec ++
--- /var/tmp/diff_new_pack.hmfvR5/_old  2019-09-13 14:59:26.245280081 +0200
+++ /var/tmp/diff_new_pack.hmfvR5/_new  2019-09-13 14:59:26.249280081 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-route53
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:Route53 DNS Authenticator plugin for Certbot
 License:Apache-2.0

++ certbot-dns-route53-0.37.2.tar.gz -> certbot-dns-route53-0.38.0.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-route53-0.37.2/PKG-INFO 
new/certbot-dns-route53-0.38.0/PKG-INFO
--- old/certbot-dns-route53-0.37.2/PKG-INFO 2019-08-21 23:49:19.0 
+0200
+++ new/certbot-dns-route53-0.38.0/PKG-INFO 2019-09-03 21:43:18.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.2
 Name: certbot-dns-route53
-Version: 0.37.2
+Version: 0.38.0
 Summary: Route53 DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-route53-0.37.2/certbot_dns_route53.egg-info/PKG-INFO 
new/certbot-dns-route53-0.38.0/certbot_dns_route53.egg-info/PKG-INFO
--- old/certbot-dns-route53-0.37.2/certbot_dns_route53.egg-info/PKG-INFO
2019-08-21 23:49:19.0 +0200
+++ new/certbot-dns-route53-0.38.0/certbot_dns_route53.egg-info/PKG-INFO
2019-09-03 21:43:18.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.2
 Name: certbot-dns-route53
-Version: 0.37.2
+Version: 0.38.0
 Summary: Route53 DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-route53-0.37.2/setup.py 
new/certbot-dns-route53-0.38.0/setup.py
--- old/certbot-dns-route53-0.37.2/setup.py 2019-08-21 23:48:41.0 
+0200
+++ new/certbot-dns-route53-0.38.0/setup.py 2019-09-03 21:42:37.0 
+0200
@@ -1,7 +1,7 @@
 from setuptools import setup
 from setuptools import find_packages
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit python-certbot-dns-linode for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-linode for 
openSUSE:Factory checked in at 2019-09-13 14:59:16

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-linode (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-linode.new.7948 (New)


Package is "python-certbot-dns-linode"

Fri Sep 13 14:59:16 2019 rev:2 rq:730169 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-linode/python-certbot-dns-linode.changes
  2019-09-11 10:33:43.971325155 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-linode.new.7948/python-certbot-dns-linode.changes
2019-09-13 14:59:18.261279742 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:30:15 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-linode-0.37.2.tar.gz

New:

  certbot-dns-linode-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-linode.spec ++
--- /var/tmp/diff_new_pack.zVJYIo/_old  2019-09-13 14:59:19.193279782 +0200
+++ /var/tmp/diff_new_pack.zVJYIo/_new  2019-09-13 14:59:19.197279782 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-linode
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:Linode DNS Authenticator plugin for Certbot
 License:Apache-2.0
@@ -28,17 +28,17 @@
 BuildRequires:  %{python_module acme >= 0.25.0}
 BuildRequires:  %{python_module boto3}
 BuildRequires:  %{python_module certbot >= 0.34.0}
+BuildRequires:  %{python_module dns-lexicon >= 2.2.3}
 BuildRequires:  %{python_module mock}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{python_module zope.interface}
-BuildRequires:  %{python_module dns-lexicon >= 2.2.3}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
 Requires:   python-acme >= 0.29.0
 Requires:   python-boto3
 Requires:   python-certbot >= 0.34.0
-Requires:   python-zope.interface
 Requires:  python-dns-lexicon
+Requires:   python-zope.interface
 BuildArch:  noarch
 %python_subpackages
 

++ certbot-dns-linode-0.37.2.tar.gz -> certbot-dns-linode-0.38.0.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-linode-0.37.2/PKG-INFO 
new/certbot-dns-linode-0.38.0/PKG-INFO
--- old/certbot-dns-linode-0.37.2/PKG-INFO  2019-08-21 23:49:09.0 
+0200
+++ new/certbot-dns-linode-0.38.0/PKG-INFO  2019-09-03 21:43:07.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-linode
-Version: 0.37.2
+Version: 0.38.0
 Summary: Linode DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-linode-0.37.2/certbot_dns_linode.egg-info/PKG-INFO 
new/certbot-dns-linode-0.38.0/certbot_dns_linode.egg-info/PKG-INFO
--- old/certbot-dns-linode-0.37.2/certbot_dns_linode.egg-info/PKG-INFO  
2019-08-21 23:49:09.0 +0200
+++ new/certbot-dns-linode-0.38.0/certbot_dns_linode.egg-info/PKG-INFO  
2019-09-03 21:43:07.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-linode
-Version: 0.37.2
+Version: 0.38.0
 Summary: Linode DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-linode-0.37.2/setup.py 
new/certbot-dns-linode-0.38.0/setup.py
--- old/certbot-dns-linode-0.37.2/setup.py  2019-08-21 23:48:41.0 
+0200
+++ new/certbot-dns-linode-0.38.0/setup.py  2019-09-03 21:42:37.0 
+0200
@@ -1,7 +1,7 @@
 from setuptools import setup
 from setuptools import find_packages
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Please update tox.ini when modifying dependency version requirements
 install_requires = [




commit python-certbot-dns-dnsimple for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-dnsimple for 
openSUSE:Factory checked in at 2019-09-13 14:59:10

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-dnsimple (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-dnsimple.new.7948 (New)


Package is "python-certbot-dns-dnsimple"

Fri Sep 13 14:59:10 2019 rev:11 rq:730166 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-dnsimple/python-certbot-dns-dnsimple.changes
  2019-08-28 16:04:24.742774072 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-dnsimple.new.7948/python-certbot-dns-dnsimple.changes
2019-09-13 14:59:13.305279533 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:29:49 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-dnsimple-0.37.2.tar.gz

New:

  certbot-dns-dnsimple-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-dnsimple.spec ++
--- /var/tmp/diff_new_pack.B7s1IG/_old  2019-09-13 14:59:13.713279550 +0200
+++ /var/tmp/diff_new_pack.B7s1IG/_new  2019-09-13 14:59:13.713279550 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-dnsimple
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:DNSimple Authenticator plugin for Certbot
 License:Apache-2.0

++ certbot-dns-dnsimple-0.37.2.tar.gz -> certbot-dns-dnsimple-0.38.0.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-dnsimple-0.37.2/PKG-INFO 
new/certbot-dns-dnsimple-0.38.0/PKG-INFO
--- old/certbot-dns-dnsimple-0.37.2/PKG-INFO2019-08-21 23:49:00.0 
+0200
+++ new/certbot-dns-dnsimple-0.38.0/PKG-INFO2019-09-03 21:42:58.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-dnsimple
-Version: 0.37.2
+Version: 0.38.0
 Summary: DNSimple DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-dnsimple-0.37.2/certbot_dns_dnsimple.egg-info/PKG-INFO 
new/certbot-dns-dnsimple-0.38.0/certbot_dns_dnsimple.egg-info/PKG-INFO
--- old/certbot-dns-dnsimple-0.37.2/certbot_dns_dnsimple.egg-info/PKG-INFO  
2019-08-21 23:49:00.0 +0200
+++ new/certbot-dns-dnsimple-0.38.0/certbot_dns_dnsimple.egg-info/PKG-INFO  
2019-09-03 21:42:58.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-dnsimple
-Version: 0.37.2
+Version: 0.38.0
 Summary: DNSimple DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-dnsimple-0.37.2/setup.py 
new/certbot-dns-dnsimple-0.38.0/setup.py
--- old/certbot-dns-dnsimple-0.37.2/setup.py2019-08-21 23:48:41.0 
+0200
+++ new/certbot-dns-dnsimple-0.38.0/setup.py2019-09-03 21:42:36.0 
+0200
@@ -3,7 +3,7 @@
 from setuptools import find_packages
 
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit libmediainfo for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package libmediainfo for openSUSE:Factory 
checked in at 2019-09-13 14:58:56

Comparing /work/SRC/openSUSE:Factory/libmediainfo (Old)
 and  /work/SRC/openSUSE:Factory/.libmediainfo.new.7948 (New)


Package is "libmediainfo"

Fri Sep 13 14:58:56 2019 rev:17 rq:730153 version:19.09

Changes:

--- /work/SRC/openSUSE:Factory/libmediainfo/libmediainfo.changes
2019-07-18 15:22:30.284121739 +0200
+++ /work/SRC/openSUSE:Factory/.libmediainfo.new.7948/libmediainfo.changes  
2019-09-13 14:58:56.605278825 +0200
@@ -1,0 +2,23 @@
+Wed Sep 11 13:04:20 UTC 2019 - Luigi Baldoni 
+
+- Update to version 19.09
+  Added:
+  * AC-4: basic detection, raw, in MP4 or TS
+  * AC-3/E-AC-3: display time code of the first frame
+  * Don't show anymore by default "encoded" bit rates and stream
+sizes
+  * MOV: Decode more language codes
+  Corrections:
+  * MXF: some metadata were missing
+  * AC-3: AC-3 actually has no bit depth, removing the default
+16 value
+  * AC-3/E-AC-3: fix bitrate info (so duration) with streams
+having a time code
+  * AC-3: parse more frames also when in MP4, in order to better
+detect JOC (Atmos)
+  * MP4: do not show audio bit depth if it is the "default" 16
+(value is not trustable enough)
+  * ProRes RAW: we know only width and height
+  * SubRip: bad handling of files having a quote character
+
+---

Old:

  libmediainfo_19.07.tar.xz

New:

  libmediainfo_19.09.tar.xz



Other differences:
--
++ libmediainfo.spec ++
--- /var/tmp/diff_new_pack.Ozoa5z/_old  2019-09-13 14:58:57.241278852 +0200
+++ /var/tmp/diff_new_pack.Ozoa5z/_new  2019-09-13 14:58:57.241278852 +0200
@@ -19,7 +19,7 @@
 
 %define sover  0
 Name:   libmediainfo
-Version:19.07
+Version:19.09
 Release:0
 Summary:Library for supplying technical and tag information about a 
video or audio file
 License:BSD-2-Clause
@@ -39,8 +39,8 @@
 BuildRequires:  pkgconfig(zlib)
 
 %description
-MediaInfo supplies technical and tag information about a video or
-audio file.
+MediaInfo is a library that supplies technical and tag information about a
+video or audio file.
 
 %package -n %{name}%{sover}
 Summary:Library for supplying technical and tag information about a 
video or audio file

++ libmediainfo_19.07.tar.xz -> libmediainfo_19.09.tar.xz ++
 4050 lines of diff (skipped)




commit python-certbot-dns-digitalocean for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-digitalocean for 
openSUSE:Factory checked in at 2019-09-13 14:59:09

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-digitalocean (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-digitalocean.new.7948 
(New)


Package is "python-certbot-dns-digitalocean"

Fri Sep 13 14:59:09 2019 rev:10 rq:730165 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-digitalocean/python-certbot-dns-digitalocean.changes
  2019-08-28 16:04:23.002774332 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-digitalocean.new.7948/python-certbot-dns-digitalocean.changes
2019-09-13 14:59:10.561279416 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:29:41 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-digitalocean-0.37.2.tar.gz

New:

  certbot-dns-digitalocean-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-digitalocean.spec ++
--- /var/tmp/diff_new_pack.ppXVk5/_old  2019-09-13 14:59:10.997279435 +0200
+++ /var/tmp/diff_new_pack.ppXVk5/_new  2019-09-13 14:59:10.997279435 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-digitalocean
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:DigitalOcean Authenticator plugin for Certbot
 License:Apache-2.0

++ certbot-dns-digitalocean-0.37.2.tar.gz -> 
certbot-dns-digitalocean-0.38.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-digitalocean-0.37.2/PKG-INFO 
new/certbot-dns-digitalocean-0.38.0/PKG-INFO
--- old/certbot-dns-digitalocean-0.37.2/PKG-INFO2019-08-21 
23:48:58.0 +0200
+++ new/certbot-dns-digitalocean-0.38.0/PKG-INFO2019-09-03 
21:42:56.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-digitalocean
-Version: 0.37.2
+Version: 0.38.0
 Summary: DigitalOcean DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-digitalocean-0.37.2/certbot_dns_digitalocean.egg-info/PKG-INFO 
new/certbot-dns-digitalocean-0.38.0/certbot_dns_digitalocean.egg-info/PKG-INFO
--- 
old/certbot-dns-digitalocean-0.37.2/certbot_dns_digitalocean.egg-info/PKG-INFO  
2019-08-21 23:48:58.0 +0200
+++ 
new/certbot-dns-digitalocean-0.38.0/certbot_dns_digitalocean.egg-info/PKG-INFO  
2019-09-03 21:42:56.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-digitalocean
-Version: 0.37.2
+Version: 0.38.0
 Summary: DigitalOcean DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-digitalocean-0.37.2/setup.py 
new/certbot-dns-digitalocean-0.38.0/setup.py
--- old/certbot-dns-digitalocean-0.37.2/setup.py2019-08-21 
23:48:41.0 +0200
+++ new/certbot-dns-digitalocean-0.38.0/setup.py2019-09-03 
21:42:36.0 +0200
@@ -2,7 +2,7 @@
 from setuptools import find_packages
 
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit python-certbot-apache for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-apache for 
openSUSE:Factory checked in at 2019-09-13 14:59:04

Comparing /work/SRC/openSUSE:Factory/python-certbot-apache (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-apache.new.7948 (New)


Package is "python-certbot-apache"

Fri Sep 13 14:59:04 2019 rev:11 rq:730162 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-apache/python-certbot-apache.changes  
2019-08-28 16:04:01.698777535 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-apache.new.7948/python-certbot-apache.changes
2019-09-13 14:59:06.901279261 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:29:13 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * Fixed OS detection in the Apache plugin on Scientific Linux.
+
+---

Old:

  certbot-apache-0.37.2.tar.gz

New:

  certbot-apache-0.38.0.tar.gz



Other differences:
--
++ python-certbot-apache.spec ++
--- /var/tmp/diff_new_pack.3RBUf8/_old  2019-09-13 14:59:07.361279280 +0200
+++ /var/tmp/diff_new_pack.3RBUf8/_new  2019-09-13 14:59:07.361279280 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-apache
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:Apache plugin for Certbot
 License:Apache-2.0

++ certbot-apache-0.37.2.tar.gz -> certbot-apache-0.38.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-apache-0.37.2/PKG-INFO 
new/certbot-apache-0.38.0/PKG-INFO
--- old/certbot-apache-0.37.2/PKG-INFO  2019-08-21 23:48:50.0 +0200
+++ new/certbot-apache-0.38.0/PKG-INFO  2019-09-03 21:42:45.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-apache
-Version: 0.37.2
+Version: 0.38.0
 Summary: Apache plugin for Certbot
 Home-page: https://github.com/letsencrypt/letsencrypt
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-apache-0.37.2/certbot_apache/entrypoint.py 
new/certbot-apache-0.38.0/certbot_apache/entrypoint.py
--- old/certbot-apache-0.37.2/certbot_apache/entrypoint.py  2019-08-21 
23:48:40.0 +0200
+++ new/certbot-apache-0.38.0/certbot_apache/entrypoint.py  2019-09-03 
21:42:35.0 +0200
@@ -31,6 +31,8 @@
 "gentoo base system": override_gentoo.GentooConfigurator,
 "opensuse": override_suse.OpenSUSEConfigurator,
 "suse": override_suse.OpenSUSEConfigurator,
+"scientific": override_centos.CentOSConfigurator,
+"scientific linux": override_centos.CentOSConfigurator,
 }
 
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-apache-0.37.2/certbot_apache.egg-info/PKG-INFO 
new/certbot-apache-0.38.0/certbot_apache.egg-info/PKG-INFO
--- old/certbot-apache-0.37.2/certbot_apache.egg-info/PKG-INFO  2019-08-21 
23:48:50.0 +0200
+++ new/certbot-apache-0.38.0/certbot_apache.egg-info/PKG-INFO  2019-09-03 
21:42:45.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-apache
-Version: 0.37.2
+Version: 0.38.0
 Summary: Apache plugin for Certbot
 Home-page: https://github.com/letsencrypt/letsencrypt
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-apache-0.37.2/setup.py 
new/certbot-apache-0.38.0/setup.py
--- old/certbot-apache-0.37.2/setup.py  2019-08-21 23:48:41.0 +0200
+++ new/certbot-apache-0.38.0/setup.py  2019-09-03 21:42:36.0 +0200
@@ -4,7 +4,7 @@
 import sys
 
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit python-jsbeautifier for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-jsbeautifier for 
openSUSE:Factory checked in at 2019-09-13 14:58:57

Comparing /work/SRC/openSUSE:Factory/python-jsbeautifier (Old)
 and  /work/SRC/openSUSE:Factory/.python-jsbeautifier.new.7948 (New)


Package is "python-jsbeautifier"

Fri Sep 13 14:58:57 2019 rev:5 rq:730158 version:1.10.2

Changes:

--- /work/SRC/openSUSE:Factory/python-jsbeautifier/python-jsbeautifier.changes  
2019-07-24 20:36:20.662568759 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-jsbeautifier.new.7948/python-jsbeautifier.changes
2019-09-13 14:58:59.065278929 +0200
@@ -1,0 +2,7 @@
+Wed Sep 11 13:28:59 UTC 2019 - Tomáš Chvátal 
+
+- Update to 1.10.2:
+  * Please update CodeMirror Addon (#1695)
+  * Nested braces indentation (#223)
+
+---

Old:

  jsbeautifier-1.10.1.tar.gz

New:

  jsbeautifier-1.10.2.tar.gz



Other differences:
--
++ python-jsbeautifier.spec ++
--- /var/tmp/diff_new_pack.7t2Hhq/_old  2019-09-13 14:59:00.205278977 +0200
+++ /var/tmp/diff_new_pack.7t2Hhq/_new  2019-09-13 14:59:00.209278977 +0200
@@ -18,28 +18,27 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-jsbeautifier
-Version:1.10.1
+Version:1.10.2
 Release:0
 Summary:JavaScript unobfuscator and beautifier
 License:MIT
 Group:  Development/Languages/Python
-Url:http://jsbeautifier.org
+URL:http://jsbeautifier.org
 Source0:
https://files.pythonhosted.org/packages/source/j/jsbeautifier/jsbeautifier-%{version}.tar.gz
 # https://github.com/beautify-web/js-beautify/issues/1674
 Source1:
https://raw.githubusercontent.com/beautify-web/js-beautify/master/LICENSE
 BuildRequires:  %{python_module setuptools}
+BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
+Requires:   python-EditorConfig >= 0.12.0
+Requires:   python-setuptools
+Requires:   python-six >= 1.6.1
+BuildArch:  noarch
 # SECTION test requirements
 BuildRequires:  %{python_module EditorConfig >= 0.12.0}
 BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module six >= 1.6.1}
 # /SECTION
-BuildRequires:  fdupes
-Requires:   python-EditorConfig >= 0.12.0
-Requires:   python-setuptools
-Requires:   python-six >= 1.6.1
-BuildArch:  noarch
-
 %python_subpackages
 
 %description
@@ -60,7 +59,6 @@
 %python_exec setup.py test
 
 %files %{python_files}
-%defattr(-,root,root,-)
 %license LICENSE
 %python3_only %{_bindir}/js-beautify
 %{python_sitelib}/jsbeautifier

++ jsbeautifier-1.10.1.tar.gz -> jsbeautifier-1.10.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jsbeautifier-1.10.1/PKG-INFO 
new/jsbeautifier-1.10.2/PKG-INFO
--- old/jsbeautifier-1.10.1/PKG-INFO2019-07-18 00:56:14.0 +0200
+++ new/jsbeautifier-1.10.2/PKG-INFO2019-08-06 20:14:40.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.0
 Name: jsbeautifier
-Version: 1.10.1
+Version: 1.10.2
 Summary: JavaScript unobfuscator and beautifier.
 Home-page: https://beautifier.io
 Author: Liam Newman, Einar Lielmanis, et al.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jsbeautifier-1.10.1/jsbeautifier/__version__.py 
new/jsbeautifier-1.10.2/jsbeautifier/__version__.py
--- old/jsbeautifier-1.10.1/jsbeautifier/__version__.py 2019-07-18 
00:54:38.0 +0200
+++ new/jsbeautifier-1.10.2/jsbeautifier/__version__.py 2019-08-06 
20:12:39.0 +0200
@@ -1 +1 @@
-__version__ = '1.10.1'
+__version__ = '1.10.2'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/jsbeautifier-1.10.1/jsbeautifier/core/templatablepattern.py 
new/jsbeautifier-1.10.2/jsbeautifier/core/templatablepattern.py
--- old/jsbeautifier-1.10.1/jsbeautifier/core/templatablepattern.py 
2019-06-06 19:35:11.0 +0200
+++ new/jsbeautifier-1.10.2/jsbeautifier/core/templatablepattern.py 
2019-08-06 20:12:39.0 +0200
@@ -38,6 +38,7 @@
 def __init__(self, input_scanner):
 pattern = Pattern(input_scanner)
 self.handlebars_comment = 
pattern.starting_with(r'{{!--').until_after(r'--}}')
+self.handlebars_unescaped = 
pattern.starting_with(r'{{{').until_after(r'}}}')
 self.handlebars = pattern.starting_with(r'{{').until_after(r'}}')
 self.php = pattern.starting_with(r'<\?(?:[=]|php)').until_after(r'\?>')
 self.erb = pattern.starting_with(r'<%[^%]').until_after(r'[^%]%>')
@@ -157,6 +158,8 @@
 resulting_string = resulting_string or \
 

commit python-certbot-dns-google for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-google for 
openSUSE:Factory checked in at 2019-09-13 14:59:15

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-google (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-google.new.7948 (New)


Package is "python-certbot-dns-google"

Fri Sep 13 14:59:15 2019 rev:10 rq:730168 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-google/python-certbot-dns-google.changes
  2019-08-28 16:04:31.086773117 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-google.new.7948/python-certbot-dns-google.changes
2019-09-13 14:59:16.761279679 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:30:07 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-google-0.37.2.tar.gz

New:

  certbot-dns-google-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-google.spec ++
--- /var/tmp/diff_new_pack.zHtK6U/_old  2019-09-13 14:59:17.125279694 +0200
+++ /var/tmp/diff_new_pack.zHtK6U/_new  2019-09-13 14:59:17.125279694 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-google
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:Google Cloud Authenticator plugin for Certbot
 License:Apache-2.0

++ certbot-dns-google-0.37.2.tar.gz -> certbot-dns-google-0.38.0.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-google-0.37.2/PKG-INFO 
new/certbot-dns-google-0.38.0/PKG-INFO
--- old/certbot-dns-google-0.37.2/PKG-INFO  2019-08-21 23:49:07.0 
+0200
+++ new/certbot-dns-google-0.38.0/PKG-INFO  2019-09-03 21:43:05.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-google
-Version: 0.37.2
+Version: 0.38.0
 Summary: Google Cloud DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-google-0.37.2/certbot_dns_google.egg-info/PKG-INFO 
new/certbot-dns-google-0.38.0/certbot_dns_google.egg-info/PKG-INFO
--- old/certbot-dns-google-0.37.2/certbot_dns_google.egg-info/PKG-INFO  
2019-08-21 23:49:07.0 +0200
+++ new/certbot-dns-google-0.38.0/certbot_dns_google.egg-info/PKG-INFO  
2019-09-03 21:43:05.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-google
-Version: 0.37.2
+Version: 0.38.0
 Summary: Google Cloud DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-google-0.37.2/setup.py 
new/certbot-dns-google-0.38.0/setup.py
--- old/certbot-dns-google-0.37.2/setup.py  2019-08-21 23:48:41.0 
+0200
+++ new/certbot-dns-google-0.38.0/setup.py  2019-09-03 21:42:37.0 
+0200
@@ -2,7 +2,7 @@
 from setuptools import find_packages
 
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit python-certbot-dns-cloudxns for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-cloudxns for 
openSUSE:Factory checked in at 2019-09-13 14:59:08

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-cloudxns (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-cloudxns.new.7948 (New)


Package is "python-certbot-dns-cloudxns"

Fri Sep 13 14:59:08 2019 rev:11 rq:730164 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-cloudxns/python-certbot-dns-cloudxns.changes
  2019-08-28 16:04:15.102775520 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-cloudxns.new.7948/python-certbot-dns-cloudxns.changes
2019-09-13 14:59:08.333279322 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:29:32 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-cloudxns-0.37.2.tar.gz

New:

  certbot-dns-cloudxns-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-cloudxns.spec ++
--- /var/tmp/diff_new_pack.qAofrv/_old  2019-09-13 14:59:08.757279340 +0200
+++ /var/tmp/diff_new_pack.qAofrv/_new  2019-09-13 14:59:08.757279340 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-cloudxns
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:CloudXNS Authenticator plugin for Certbot
 License:Apache-2.0

++ certbot-dns-cloudxns-0.37.2.tar.gz -> certbot-dns-cloudxns-0.38.0.tar.gz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-cloudxns-0.37.2/PKG-INFO 
new/certbot-dns-cloudxns-0.38.0/PKG-INFO
--- old/certbot-dns-cloudxns-0.37.2/PKG-INFO2019-08-21 23:48:56.0 
+0200
+++ new/certbot-dns-cloudxns-0.38.0/PKG-INFO2019-09-03 21:42:54.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-cloudxns
-Version: 0.37.2
+Version: 0.38.0
 Summary: CloudXNS DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-cloudxns-0.37.2/certbot_dns_cloudxns.egg-info/PKG-INFO 
new/certbot-dns-cloudxns-0.38.0/certbot_dns_cloudxns.egg-info/PKG-INFO
--- old/certbot-dns-cloudxns-0.37.2/certbot_dns_cloudxns.egg-info/PKG-INFO  
2019-08-21 23:48:56.0 +0200
+++ new/certbot-dns-cloudxns-0.38.0/certbot_dns_cloudxns.egg-info/PKG-INFO  
2019-09-03 21:42:54.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-cloudxns
-Version: 0.37.2
+Version: 0.38.0
 Summary: CloudXNS DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-cloudxns-0.37.2/setup.py 
new/certbot-dns-cloudxns-0.38.0/setup.py
--- old/certbot-dns-cloudxns-0.37.2/setup.py2019-08-21 23:48:41.0 
+0200
+++ new/certbot-dns-cloudxns-0.38.0/setup.py2019-09-03 21:42:36.0 
+0200
@@ -2,7 +2,7 @@
 from setuptools import find_packages
 
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit python-certbot for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot for openSUSE:Factory 
checked in at 2019-09-13 14:59:01

Comparing /work/SRC/openSUSE:Factory/python-certbot (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot.new.7948 (New)


Package is "python-certbot"

Fri Sep 13 14:59:01 2019 rev:17 rq:730161 version:0.38.0

Changes:

--- /work/SRC/openSUSE:Factory/python-certbot/python-certbot.changes
2019-08-28 16:03:58.318778043 +0200
+++ /work/SRC/openSUSE:Factory/.python-certbot.new.7948/python-certbot.changes  
2019-09-13 14:59:03.553279119 +0200
@@ -1,0 +2,9 @@
+Wed Sep 11 12:29:03 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * If Certbot fails to rollback your server configuration, the 
+error message links to the Let's Encrypt forum.
+  * Replace platform.linux_distribution with distro.linux_distribution 
+as a step towards Python 3.8 support in Certbot.
+
+---

Old:

  certbot-0.37.2.tar.gz

New:

  certbot-0.38.0.tar.gz



Other differences:
--
++ python-certbot.spec ++
--- /var/tmp/diff_new_pack.rZfY1Z/_old  2019-09-13 14:59:04.013279139 +0200
+++ /var/tmp/diff_new_pack.rZfY1Z/_new  2019-09-13 14:59:04.017279139 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:ACME client
 License:Apache-2.0
@@ -29,6 +29,7 @@
 BuildRequires:  %{python_module configargparse >= 0.9.3}
 BuildRequires:  %{python_module configobj}
 BuildRequires:  %{python_module cryptography >= 1.2.3}
+BuildRequires:  %{python_module distro >= 1.0.1}
 BuildRequires:  %{python_module future}
 BuildRequires:  %{python_module josepy >= 1.1.0}
 BuildRequires:  %{python_module mock}
@@ -46,6 +47,7 @@
 Requires:   python-configargparse >= 0.9.3
 Requires:   python-configobj
 Requires:   python-cryptography >= 1.2.3
+Requires:   python-distro >= 1.0.1
 Requires:   python-future
 Requires:   python-josepy >= 1.1.0
 Requires:   python-mock

++ certbot-0.37.2.tar.gz -> certbot-0.38.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-0.37.2/CHANGELOG.md 
new/certbot-0.38.0/CHANGELOG.md
--- old/certbot-0.37.2/CHANGELOG.md 2019-08-21 23:48:40.0 +0200
+++ new/certbot-0.38.0/CHANGELOG.md 2019-09-03 21:42:35.0 +0200
@@ -2,10 +2,28 @@
 
 Certbot adheres to [Semantic Versioning](https://semver.org/).
 
-## 0.37.2 - 2019-08-21
+## 0.38.0 - 2019-09-03
+
+### Added
+
+*
+
+### Changed
+
+* If Certbot fails to rollback your server configuration, the error message
+  links to the Let's Encrypt forum. Change the link to the Help category now
+  that the Server category has been closed.
+* Replace platform.linux_distribution with distro.linux_distribution as a step
+  towards Python 3.8 support in Certbot.
 
 ### Fixed
 
+* Fixed OS detection in the Apache plugin on Scientific Linux.
+
+More details about these changes can be found on our GitHub repo.
+
+## 0.37.2 - 2019-08-21
+
 * Stop disabling TLS session tickets in Nginx as it caused TLS failures on
   some systems.
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-0.37.2/PKG-INFO new/certbot-0.38.0/PKG-INFO
--- old/certbot-0.37.2/PKG-INFO 2019-08-21 23:48:42.0 +0200
+++ new/certbot-0.38.0/PKG-INFO 2019-09-03 21:42:38.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot
-Version: 0.37.2
+Version: 0.38.0
 Summary: ACME client
 Home-page: https://github.com/letsencrypt/letsencrypt
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-0.37.2/certbot/__init__.py 
new/certbot-0.38.0/certbot/__init__.py
--- old/certbot-0.37.2/certbot/__init__.py  2019-08-21 23:48:41.0 
+0200
+++ new/certbot-0.38.0/certbot/__init__.py  2019-09-03 21:42:37.0 
+0200
@@ -1,4 +1,4 @@
 """Certbot client."""
 
 # version number like 1.2.3a0, must have at least 2 parts, like 1.2
-__version__ = '0.37.2'
+__version__ = '0.38.0'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-0.37.2/certbot/client.py 
new/certbot-0.38.0/certbot/client.py
--- old/certbot-0.37.2/certbot/client.py2019-08-21 23:48:40.0 
+0200
+++ new/certbot-0.38.0/certbot/client.py2019-09-03 21:42:35.0 
+0200
@@ -624,7 +624,7 @@
 reporter.add_message(
 "An error occurred and we failed to restore your config and "
 

commit python-certbot-dns-cloudflare for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-certbot-dns-cloudflare for 
openSUSE:Factory checked in at 2019-09-13 14:59:06

Comparing /work/SRC/openSUSE:Factory/python-certbot-dns-cloudflare (Old)
 and  /work/SRC/openSUSE:Factory/.python-certbot-dns-cloudflare.new.7948 
(New)


Package is "python-certbot-dns-cloudflare"

Fri Sep 13 14:59:06 2019 rev:10 rq:730163 version:0.38.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-certbot-dns-cloudflare/python-certbot-dns-cloudflare.changes
  2019-08-28 16:04:06.094776874 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-certbot-dns-cloudflare.new.7948/python-certbot-dns-cloudflare.changes
2019-09-13 14:59:07.693279295 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:29:22 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  certbot-dns-cloudflare-0.37.2.tar.gz

New:

  certbot-dns-cloudflare-0.38.0.tar.gz



Other differences:
--
++ python-certbot-dns-cloudflare.spec ++
--- /var/tmp/diff_new_pack.BrQ1zN/_old  2019-09-13 14:59:08.133279313 +0200
+++ /var/tmp/diff_new_pack.BrQ1zN/_new  2019-09-13 14:59:08.133279313 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-certbot-dns-cloudflare
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:Cloudflare Authenticator plugin for Certbot
 License:Apache-2.0

++ certbot-dns-cloudflare-0.37.2.tar.gz -> 
certbot-dns-cloudflare-0.38.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-cloudflare-0.37.2/PKG-INFO 
new/certbot-dns-cloudflare-0.38.0/PKG-INFO
--- old/certbot-dns-cloudflare-0.37.2/PKG-INFO  2019-08-21 23:48:54.0 
+0200
+++ new/certbot-dns-cloudflare-0.38.0/PKG-INFO  2019-09-03 21:42:52.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-cloudflare
-Version: 0.37.2
+Version: 0.38.0
 Summary: Cloudflare DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/certbot-dns-cloudflare-0.37.2/certbot_dns_cloudflare.egg-info/PKG-INFO 
new/certbot-dns-cloudflare-0.38.0/certbot_dns_cloudflare.egg-info/PKG-INFO
--- old/certbot-dns-cloudflare-0.37.2/certbot_dns_cloudflare.egg-info/PKG-INFO  
2019-08-21 23:48:54.0 +0200
+++ new/certbot-dns-cloudflare-0.38.0/certbot_dns_cloudflare.egg-info/PKG-INFO  
2019-09-03 21:42:52.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: certbot-dns-cloudflare
-Version: 0.37.2
+Version: 0.38.0
 Summary: Cloudflare DNS Authenticator plugin for Certbot
 Home-page: https://github.com/certbot/certbot
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/certbot-dns-cloudflare-0.37.2/setup.py 
new/certbot-dns-cloudflare-0.38.0/setup.py
--- old/certbot-dns-cloudflare-0.37.2/setup.py  2019-08-21 23:48:41.0 
+0200
+++ new/certbot-dns-cloudflare-0.38.0/setup.py  2019-09-03 21:42:36.0 
+0200
@@ -2,7 +2,7 @@
 from setuptools import find_packages
 
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Remember to update local-oldest-requirements.txt when changing the minimum
 # acme/certbot version.




commit python-marshmallow for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-marshmallow for 
openSUSE:Factory checked in at 2019-09-13 14:58:49

Comparing /work/SRC/openSUSE:Factory/python-marshmallow (Old)
 and  /work/SRC/openSUSE:Factory/.python-marshmallow.new.7948 (New)


Package is "python-marshmallow"

Fri Sep 13 14:58:49 2019 rev:10 rq:730134 version:3.0.3

Changes:

--- /work/SRC/openSUSE:Factory/python-marshmallow/python-marshmallow.changes
2019-08-27 10:27:32.451913742 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-marshmallow.new.7948/python-marshmallow.changes
  2019-09-13 14:58:51.373278603 +0200
@@ -1,0 +2,8 @@
+Wed Sep 11 12:45:35 UTC 2019 - Tomáš Chvátal 
+
+- Update to 3.0.3:
+  * Handle when data_key is an empty string
+  * Includes bug fix from 2.20.3
+  * Fix incorrect super() call in SchemaMeta.__init__
+
+---

Old:

  marshmallow-3.0.1.tar.gz

New:

  marshmallow-3.0.3.tar.gz



Other differences:
--
++ python-marshmallow.spec ++
--- /var/tmp/diff_new_pack.Pq5jJ2/_old  2019-09-13 14:58:51.833278623 +0200
+++ /var/tmp/diff_new_pack.Pq5jJ2/_new  2019-09-13 14:58:51.833278623 +0200
@@ -19,7 +19,7 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-marshmallow
-Version:3.0.1
+Version:3.0.3
 Release:0
 Summary:ORM/ODM/framework-agnostic library to convert datatypes 
from/to Python types
 License:MIT AND BSD-3-Clause

++ marshmallow-3.0.1.tar.gz -> marshmallow-3.0.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/marshmallow-3.0.1/AUTHORS.rst 
new/marshmallow-3.0.3/AUTHORS.rst
--- old/marshmallow-3.0.1/AUTHORS.rst   2019-08-21 19:56:09.0 +0200
+++ new/marshmallow-3.0.3/AUTHORS.rst   2019-09-05 03:44:00.0 +0200
@@ -136,3 +136,5 @@
 - Stanislav Rogovskiy `@atmo `_
 - Cristi Scoarta `@cristi23 `_
 - Anthony Sottile `@asottile `_
+- Charles-Axel Dein `@charlax `_
+- `@phrfpeixoto `_
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/marshmallow-3.0.1/CHANGELOG.rst 
new/marshmallow-3.0.3/CHANGELOG.rst
--- old/marshmallow-3.0.1/CHANGELOG.rst 2019-08-21 19:56:09.0 +0200
+++ new/marshmallow-3.0.3/CHANGELOG.rst 2019-09-05 03:44:00.0 +0200
@@ -1,6 +1,22 @@
 Changelog
 -
 
+3.0.3 (2019-09-04)
+++
+
+Bug fixes:
+
+- Handle when ``data_key`` is an empty string (:issue:`1378`).
+  Thanks :user:`jtrakk` for reporting.
+
+3.0.2 (2019-09-04)
+++
+
+Bug fixes:
+
+- Includes bug fix from 2.20.3 (:pr:`1376`).
+- Fix incorrect ``super()`` call in ``SchemaMeta.__init__`` (:pr:`1362`).
+
 3.0.1 (2019-08-21)
 ++
 
@@ -243,6 +259,12 @@
 
 - Restore ``Schema.TYPE_MAPPING``, which was removed in 3.0.0b17 
(:issue:`1012`).
 
+Other changes:
+
+- *Backwards-incompatible*: ``_serialize`` and ``_deserialize`` methods of
+all ``fields.Field`` subclasses must accept ``**kwargs`` (:pr:`1007`).
+
+
 3.0.0b18 (2018-10-15)
 +
 
@@ -595,6 +617,13 @@
 - Remove ``func`` parameter of ``fields.Function``. Remove ``method_name`` 
parameter of ``fields.Method`` (issue:`325`). Use the ``serialize`` parameter 
instead.
 - Remove ``extra`` parameter from ``Schema``. Use a ``@post_dump`` method to 
add additional data.
 
+2.20.3 (2019-09-04)
+***
+
+Bug fixes:
+
+- Don't swallow ``TypeError`` exceptions raised by ``Field._bind_to_schema`` 
or ``Schema.on_bind_field`` (:pr:`1376`).
+
 2.20.2 (2019-08-20)
 ***
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/marshmallow-3.0.1/PKG-INFO 
new/marshmallow-3.0.3/PKG-INFO
--- old/marshmallow-3.0.1/PKG-INFO  2019-08-21 19:56:22.0 +0200
+++ new/marshmallow-3.0.3/PKG-INFO  2019-09-05 03:44:12.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: marshmallow
-Version: 3.0.1
+Version: 3.0.3
 Summary: A lightweight library for converting complex datatypes to and from 
native Python datatypes.
 Home-page: https://github.com/marshmallow-code/marshmallow
 Author: Steven Loria
@@ -187,7 +187,7 @@
 Classifier: Programming Language :: Python :: 3.6
 Classifier: Programming Language :: Python :: 3.7
 Requires-Python: >=3.5
-Provides-Extra: docs
 Provides-Extra: tests
-Provides-Extra: dev
 Provides-Extra: lint
+Provides-Extra: docs
+Provides-Extra: dev
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 

commit python-mechanize for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-mechanize for 
openSUSE:Factory checked in at 2019-09-13 14:58:41

Comparing /work/SRC/openSUSE:Factory/python-mechanize (Old)
 and  /work/SRC/openSUSE:Factory/.python-mechanize.new.7948 (New)


Package is "python-mechanize"

Fri Sep 13 14:58:41 2019 rev:23 rq:730131 version:0.4.3

Changes:

--- /work/SRC/openSUSE:Factory/python-mechanize/python-mechanize.changes
2019-05-20 13:17:59.783927068 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-mechanize.new.7948/python-mechanize.changes  
2019-09-13 14:58:42.757278238 +0200
@@ -1,0 +2,9 @@
+Wed Sep 11 12:36:30 UTC 2019 - Tomáš Chvátal 
+
+- Update to 0.4.3:
+  * When filling forms with unicode strings automatically encode them into
+the correct encoding fr the HTML page being viewed
+  * Guess content type when uploading files if not specified
+  * py3 compat - Have the version of simple cookies be 0 rather than None
+
+---

Old:

  mechanize-0.4.2.tar.gz

New:

  mechanize-0.4.3.tar.gz



Other differences:
--
++ python-mechanize.spec ++
--- /var/tmp/diff_new_pack.4Rsv6v/_old  2019-09-13 14:58:43.141278254 +0200
+++ /var/tmp/diff_new_pack.4Rsv6v/_new  2019-09-13 14:58:43.141278254 +0200
@@ -19,17 +19,16 @@
 %define modname mechanize
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-mechanize
-Version:0.4.2
+Version:0.4.3
 Release:0
 Summary:Stateful programmatic web browsing
 License:(BSD-3-Clause OR ZPL-2.1) AND BSD-3-Clause
 Group:  Development/Languages/Python
 URL:https://github.com/python-mechanize/mechanize
 Source: 
https://files.pythonhosted.org/packages/source/m/mechanize/%{modname}-%{version}.tar.gz
+BuildRequires:  %{python_module Twisted}
 BuildRequires:  %{python_module html5lib}
 BuildRequires:  %{python_module setuptools}
-# For testing
-BuildRequires:  %{python_module Twisted}
 BuildRequires:  %{python_module zope.interface}
 BuildRequires:  fdupes
 BuildRequires:  python

++ mechanize-0.4.2.tar.gz -> mechanize-0.4.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mechanize-0.4.2/ChangeLog 
new/mechanize-0.4.3/ChangeLog
--- old/mechanize-0.4.2/ChangeLog   1970-01-01 01:00:00.0 +0100
+++ new/mechanize-0.4.3/ChangeLog   2019-08-18 10:06:45.0 +0200
@@ -0,0 +1,639 @@
+This isn't really in proper GNU ChangeLog format, it just happens to
+look that way.
+
+2019-08-18 Kovid Goyal
+   * 0.4.3 release
+   * When filling forms with unicode strings automatically encode them into
+   the correct encoding fr the HTML page being viewed
+   * Guess content type when uploading files if not specified
+   * py3 compat - Have the version of simple cookies be 0 rather than None
+
+2019-04-12 Kovid Goyal
+   * 0.4.2 release
+   * A couple of python 3 specific fixes for proxy authorization and
+   * adding controls to forms
+
+   
+2019-03-16 Kovid Goyal
+   * 0.4.1 release
+   * A couple of python 3 specific fixes for servers with missing 
robots.txt
+   files and also errors when using basic/digest auth
+
+   
+2019-01-16 Kovid Goyal
+   * 0.4.0 release
+   * Python 3 compatibility
+   * Add a finalize_request_headers callback to Browser to allow users full
+   control of what headers are sent with every request
+   * Preserve header ordering when making HTTP requests
+
+2018-09-11 Kovid Goyal
+   * 0.3.7 release
+   * Fix processing of http-equiv meta tags incorrectly lower casing the 
content
+   * Fix error when a textbox contained within a form contains unicode 
characters
+
+2017-10-13 Kovid Goyal
+   * 0.3.6 release.
+   * Use html5-parser for parsing HTML, when available instead of html5lib
+   for a big performance boost.
+   * Fix error when trying to submit forms with non-ascii values on systems
+   where the default encoding is ascii.
+   * Fix errors on python environments with broken threading
+
+2017-06-24 Kovid Goyal
+   * 0.3.5 release.
+   * Fix error when trying to open pages that contain HTML entities that
+ decode to unicode characters in their  sections
+
+2017-05-05 Kovid Goyal
+   * 0.3.3 release.
+   * Add get() and __getitem__ methods to the response object for 
conveninent access to response headers
+
+2017-04-29 Kovid Goyal
+   * 0.3.2 release.
+   * Allow overriding of Host headers via addheaders 
+   * Fix using unicode strings in addheaders and trying to send data with 
a request failing
+

commit inn for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package inn for openSUSE:Factory checked in 
at 2019-09-13 14:58:54

Comparing /work/SRC/openSUSE:Factory/inn (Old)
 and  /work/SRC/openSUSE:Factory/.inn.new.7948 (New)


Package is "inn"

Fri Sep 13 14:58:54 2019 rev:36 rq:730143 version:2.6.2

Changes:

--- /work/SRC/openSUSE:Factory/inn/inn.changes  2019-01-08 12:25:48.384447679 
+0100
+++ /work/SRC/openSUSE:Factory/.inn.new.7948/inn.changes2019-09-13 
14:58:55.781278790 +0200
@@ -1,0 +2,5 @@
+Tue Sep 10 11:51:20 UTC 2019 - Christophe Giboudeaux 
+
+- Use -ffat-lto-objects when building static libraries.
+
+---



Other differences:
--
++ inn.spec ++
--- /var/tmp/diff_new_pack.cTcIQX/_old  2019-09-13 14:58:56.445278818 +0200
+++ /var/tmp/diff_new_pack.cTcIQX/_new  2019-09-13 14:58:56.445278818 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package inn
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -86,6 +86,7 @@
 cp -a $RPM_SOURCE_DIR/pubring.pgp .
 
 %build
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
 LDFLAGS="-pie" CFLAGS="$RPM_OPT_FLAGS -pipe -fno-strict-aliasing 
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fPIE -fstack-protector" ./configure 
\
--enable-dual-socket \
--enable-uucp-rnews \






commit bmake for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package bmake for openSUSE:Factory checked 
in at 2019-09-13 14:58:52

Comparing /work/SRC/openSUSE:Factory/bmake (Old)
 and  /work/SRC/openSUSE:Factory/.bmake.new.7948 (New)


Package is "bmake"

Fri Sep 13 14:58:52 2019 rev:18 rq:730140 version:20181221

Changes:

--- /work/SRC/openSUSE:Factory/bmake/bmake.changes  2018-08-07 
09:43:09.725318791 +0200
+++ /work/SRC/openSUSE:Factory/.bmake.new.7948/bmake.changes2019-09-13 
14:58:54.177278722 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:52:21 UTC 2019 - Martin Pluskal 
+
+- Update to version 20181221:
+  * For full list of changes see provided Changelog
+
+---

Old:

  bmake-20180512.tar.gz

New:

  bmake-20181221.tar.gz



Other differences:
--
++ bmake.spec ++
--- /var/tmp/diff_new_pack.oxvmBi/_old  2019-09-13 14:58:54.561278738 +0200
+++ /var/tmp/diff_new_pack.oxvmBi/_new  2019-09-13 14:58:54.561278738 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package bmake
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,17 +12,17 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   bmake
-Version:20180512
+Version:20181221
 Release:0
 Summary:The NetBSD make(1) tool
 License:BSD-2-Clause AND BSD-3-Clause AND BSD-4-Clause
 Group:  Development/Tools/Building
-Url:https://ftp.NetBSD.org/pub/NetBSD/misc/sjg/
+URL:https://ftp.NetBSD.org/pub/NetBSD/misc/sjg/
 Source0:
https://ftp.NetBSD.org/pub/NetBSD/misc/sjg/bmake-%{version}.tar.gz
 # PATCH-FEATURE-OPENSUSE allow-overriding-compiler-variables.patch -- Based on 
Linux.sys.mk which was previously shipped with this package
 # patch generated using `git diff master opensuse` from 
https://github.com/RichardsonAlex/bmake
@@ -61,7 +61,7 @@
   --sysconfdir="%{_sysconfdir}" \
   --with-default-sys-path="%{_datadir}/mk" \
   --install-prefix="%{_prefix}" \
-  --install-destdir="%{buildroot}" \
+  --install-destdir=%{buildroot} \
   op=install
 mv "%{buildroot}%{_mandir}/cat1" "%{buildroot}%{_mandir}/man1"
 
@@ -69,10 +69,9 @@
 ./boot-strap op=test
 
 %files
-%defattr(-,root,root)
 %doc ChangeLog README
 %{_bindir}/bmake
-%{_mandir}/man1/bmake.1%{ext_man}
+%{_mandir}/man1/bmake.1%{?ext_man}
 %{_datadir}/mk/
 
 %changelog

++ bmake-20180512.tar.gz -> bmake-20181221.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/ChangeLog new/bmake/ChangeLog
--- old/bmake/ChangeLog 2018-05-12 20:20:29.0 +0200
+++ new/bmake/ChangeLog 2018-12-22 01:40:23.0 +0100
@@ -1,3 +1,37 @@
+2018-12-21  Simon J Gerraty  
+
+   * VERSION: 20181221
+ Merge with NetBSD make, pick up
+ o parse.c: ParseVErrorInternal use .PARSEDIR
+   and apply if relative, and then use .PARSEFILE
+   for consistent result.
+
+2018-12-20  Simon J Gerraty  
+
+   * VERSION: 20181220
+ Merge with NetBSD make, pick up
+ o parse.c: ParseVErrorInternal use .CURDIR if .PARSEDIR
+   is relative
+ o var.c: avoid SEGFAULT in .unexport-env
+   when MAKELEVEL is not set
+
+2018-12-16  Simon J Gerraty  
+
+   * VERSION: 20181216
+ Merge with NetBSD make, pick up
+ o fix for unit-tests/varquote.mk on Debian
+
+2018-09-21  Simon J. Gerraty  
+
+   * VERSION: 20180919
+ Merge with NetBSD make, pick up
+ o var.c: add :q
+ o dir.c: cleanup caching of stats
+
+2018-09-21  Simon J Gerraty  
+
+   * Makefile.config.in: use += where it makes sense.
+
 2018-05-12  Simon J. Gerraty  
 
* VERSION: 20180512
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/FILES new/bmake/FILES
--- old/bmake/FILES 2017-08-13 02:35:02.0 +0200
+++ new/bmake/FILES 2018-09-21 23:54:20.0 +0200
@@ -163,6 +163,8 @@
 unit-tests/varcmd.mk
 unit-tests/varmisc.exp
 unit-tests/varmisc.mk
+unit-tests/varquote.exp
+unit-tests/varquote.mk
 unit-tests/varshell.exp
 unit-tests/varshell.mk
 util.c
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/bmake/Makefile.config.in new/bmake/Makefile.config.in
--- 

commit python-acme for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package python-acme for openSUSE:Factory 
checked in at 2019-09-13 14:59:00

Comparing /work/SRC/openSUSE:Factory/python-acme (Old)
 and  /work/SRC/openSUSE:Factory/.python-acme.new.7948 (New)


Package is "python-acme"

Fri Sep 13 14:59:00 2019 rev:35 rq:730160 version:0.38.0

Changes:

--- /work/SRC/openSUSE:Factory/python-acme/python-acme.changes  2019-08-28 
16:03:49.626779350 +0200
+++ /work/SRC/openSUSE:Factory/.python-acme.new.7948/python-acme.changes
2019-09-13 14:59:00.485278989 +0200
@@ -1,0 +2,6 @@
+Wed Sep 11 12:28:33 UTC 2019 - Marketa Calabkova 
+
+- update to version 0.38.0
+  * sync with main certbot package
+
+---

Old:

  acme-0.37.2.tar.gz
  acme-0.37.2.tar.gz.asc

New:

  acme-0.38.0.tar.gz
  acme-0.38.0.tar.gz.asc



Other differences:
--
++ python-acme.spec ++
--- /var/tmp/diff_new_pack.QVzbJl/_old  2019-09-13 14:59:00.925279008 +0200
+++ /var/tmp/diff_new_pack.QVzbJl/_new  2019-09-13 14:59:00.929279008 +0200
@@ -19,7 +19,7 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define libname acme
 Name:   python-%{libname}
-Version:0.37.2
+Version:0.38.0
 Release:0
 Summary:Python library for the ACME protocol
 License:Apache-2.0

++ acme-0.37.2.tar.gz -> acme-0.38.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/acme-0.37.2/PKG-INFO new/acme-0.38.0/PKG-INFO
--- old/acme-0.37.2/PKG-INFO2019-08-21 23:48:47.0 +0200
+++ new/acme-0.38.0/PKG-INFO2019-09-03 21:42:42.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: acme
-Version: 0.37.2
+Version: 0.38.0
 Summary: ACME protocol implementation in Python
 Home-page: https://github.com/letsencrypt/letsencrypt
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/acme-0.37.2/acme.egg-info/PKG-INFO 
new/acme-0.38.0/acme.egg-info/PKG-INFO
--- old/acme-0.37.2/acme.egg-info/PKG-INFO  2019-08-21 23:48:47.0 
+0200
+++ new/acme-0.38.0/acme.egg-info/PKG-INFO  2019-09-03 21:42:42.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: acme
-Version: 0.37.2
+Version: 0.38.0
 Summary: ACME protocol implementation in Python
 Home-page: https://github.com/letsencrypt/letsencrypt
 Author: Certbot Project
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/acme-0.37.2/setup.py new/acme-0.38.0/setup.py
--- old/acme-0.37.2/setup.py2019-08-21 23:48:41.0 +0200
+++ new/acme-0.38.0/setup.py2019-09-03 21:42:36.0 +0200
@@ -3,7 +3,7 @@
 from setuptools.command.test import test as TestCommand
 import sys
 
-version = '0.37.2'
+version = '0.38.0'
 
 # Please update tox.ini when modifying dependency version requirements
 install_requires = [





commit subtitleeditor for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package subtitleeditor for openSUSE:Factory 
checked in at 2019-09-13 14:58:51

Comparing /work/SRC/openSUSE:Factory/subtitleeditor (Old)
 and  /work/SRC/openSUSE:Factory/.subtitleeditor.new.7948 (New)


Package is "subtitleeditor"

Fri Sep 13 14:58:51 2019 rev:4 rq:730137 version:0.54.0

Changes:

--- /work/SRC/openSUSE:Factory/subtitleeditor/subtitleeditor.changes
2019-09-11 10:33:18.751332477 +0200
+++ /work/SRC/openSUSE:Factory/.subtitleeditor.new.7948/subtitleeditor.changes  
2019-09-13 14:58:52.141278636 +0200
@@ -1,0 +2,7 @@
+Tue Sep 10 16:56:44 UTC 2019 - Bjørn Lie 
+
+- Replace iso-codes-devel with pkgconfig(iso-codes) BuildRequires:
+  that was overlooked in the last change.
+- Use modern macros.
+
+---



Other differences:
--
++ subtitleeditor.spec ++
--- /var/tmp/diff_new_pack.DN2MKN/_old  2019-09-13 14:58:52.701278659 +0200
+++ /var/tmp/diff_new_pack.DN2MKN/_new  2019-09-13 14:58:52.701278659 +0200
@@ -24,8 +24,8 @@
 License:GPL-3.0
 Group:  Productivity/Multimedia/Video/Editors and Convertors
 # http://home.gna.org/subtitleeditor is now dead
-Url:https://github.com/kitone/subtitleeditor
-Source0:
https://github.com/kitone/subtitleeditor/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
+URL:https://github.com/kitone/subtitleeditor
+Source0:%{url}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
 BuildRequires:  automake
 BuildRequires:  fdupes
 %if 0%{?suse_version} >= 1500
@@ -35,7 +35,6 @@
 BuildRequires:  gcc7-c++
 %endif
 BuildRequires:  intltool
-BuildRequires:  iso-codes-devel
 BuildRequires:  libtool
 BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
@@ -46,6 +45,7 @@
 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
 BuildRequires:  pkgconfig(gstreamermm-1.0) >= 1.0.0
 BuildRequires:  pkgconfig(gtkmm-3.0) >= 3.10
+BuildRequires:  pkgconfig(iso-codes)
 BuildRequires:  pkgconfig(libxml++-2.6)
 
 %description
@@ -73,7 +73,7 @@
 %lang_package
 
 %prep
-%setup -q
+%autosetup -p1
 
 %build
 export CC=gcc
@@ -82,7 +82,7 @@
 test -x "$(type -p g++-7)" && export CXX=g++-7
 autoreconf -fiv
 %configure
-make %{?_smp_mflags}
+%make_build
 
 %install
 %make_install




commit perl-Text-Template for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package perl-Text-Template for 
openSUSE:Factory checked in at 2019-09-13 14:58:43

Comparing /work/SRC/openSUSE:Factory/perl-Text-Template (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Text-Template.new.7948 (New)


Package is "perl-Text-Template"

Fri Sep 13 14:58:43 2019 rev:23 rq:730132 version:1.57

Changes:

--- /work/SRC/openSUSE:Factory/perl-Text-Template/perl-Text-Template.changes
2019-07-29 17:31:34.602158817 +0200
+++ 
/work/SRC/openSUSE:Factory/.perl-Text-Template.new.7948/perl-Text-Template.changes
  2019-09-13 14:58:45.453278352 +0200
@@ -1,0 +2,8 @@
+Tue Sep 10 09:28:05 UTC 2019 -  
+
+- updated to 1.57
+   see /usr/share/doc/packages/perl-Text-Template/Changes
+
+  1.57  2019-09-09
+
+---

Old:

  Text-Template-1.56.tar.gz

New:

  Text-Template-1.57.tar.gz



Other differences:
--
++ perl-Text-Template.spec ++
--- /var/tmp/diff_new_pack.cqVwKZ/_old  2019-09-13 14:58:46.165278382 +0200
+++ /var/tmp/diff_new_pack.cqVwKZ/_new  2019-09-13 14:58:46.165278382 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Text-Template
-Version:1.56
+Version:1.57
 Release:0
 %define cpan_name Text-Template
 Summary:Expand template text with embedded Perl

++ Text-Template-1.56.tar.gz -> Text-Template-1.57.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Text-Template-1.56/Changes 
new/Text-Template-1.57/Changes
--- old/Text-Template-1.56/Changes  2019-07-09 15:27:23.0 +0200
+++ new/Text-Template-1.57/Changes  2019-09-09 15:52:49.0 +0200
@@ -1,5 +1,7 @@
 Revision history for Text::Template
 
+1.57  2019-09-09
+
 1.56  2019-07-09
 - Fix typos in Changes
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Text-Template-1.56/META.json 
new/Text-Template-1.57/META.json
--- old/Text-Template-1.56/META.json2019-07-09 15:27:23.0 +0200
+++ new/Text-Template-1.57/META.json2019-09-09 15:52:49.0 +0200
@@ -57,11 +57,11 @@
"provides" : {
   "Text::Template" : {
  "file" : "lib/Text/Template.pm",
- "version" : "1.56"
+ "version" : "1.57"
   },
   "Text::Template::Preprocess" : {
  "file" : "lib/Text/Template/Preprocess.pm",
- "version" : "1.56"
+ "version" : "1.57"
   }
},
"release_status" : "stable",
@@ -76,7 +76,7 @@
  "web" : "https://github.com/mschout/perl-text-template;
   }
},
-   "version" : "1.56",
+   "version" : "1.57",
"x_generated_by_perl" : "v5.26.2",
"x_serialization_backend" : "Cpanel::JSON::XS version 4.04"
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Text-Template-1.56/META.yml 
new/Text-Template-1.57/META.yml
--- old/Text-Template-1.56/META.yml 2019-07-09 15:27:23.0 +0200
+++ new/Text-Template-1.57/META.yml 2019-09-09 15:52:49.0 +0200
@@ -25,10 +25,10 @@
 provides:
   Text::Template:
 file: lib/Text/Template.pm
-version: '1.56'
+version: '1.57'
   Text::Template::Preprocess:
 file: lib/Text/Template/Preprocess.pm
-version: '1.56'
+version: '1.57'
 requires:
   Carp: '0'
   Encode: '0'
@@ -41,6 +41,6 @@
   bugtracker: https://github.com/mschout/perl-text-template/issues
   homepage: https://github.com/mschout/perl-text-template
   repository: https://github.com/mschout/perl-text-template.git
-version: '1.56'
+version: '1.57'
 x_generated_by_perl: v5.26.2
 x_serialization_backend: 'YAML::Tiny version 1.73'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Text-Template-1.56/Makefile.PL 
new/Text-Template-1.57/Makefile.PL
--- old/Text-Template-1.56/Makefile.PL  2019-07-09 15:27:23.0 +0200
+++ new/Text-Template-1.57/Makefile.PL  2019-09-09 15:52:49.0 +0200
@@ -34,7 +34,7 @@
 "utf8" => 0,
 "vars" => 0
   },
-  "VERSION" => "1.56",
+  "VERSION" => "1.57",
   "test" => {
 "TESTS" => "t/*.t"
   }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Text-Template-1.56/README 
new/Text-Template-1.57/README
--- old/Text-Template-1.56/README   2019-07-09 15:27:23.0 +0200
+++ new/Text-Template-1.57/README   2019-09-09 15:52:49.0 +0200
@@ -1,5 +1,5 @@
 
-Text::Template v1.46
+Text::Template
 
 This is a library for generating form letters, building HTML pages, or
 filling in templates generally.  A `template' is a piece of text that
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit wxMaxima for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package wxMaxima for openSUSE:Factory 
checked in at 2019-09-13 14:58:13

Comparing /work/SRC/openSUSE:Factory/wxMaxima (Old)
 and  /work/SRC/openSUSE:Factory/.wxMaxima.new.7948 (New)


Package is "wxMaxima"

Fri Sep 13 14:58:13 2019 rev:37 rq:730098 version:19.09.0

Changes:

--- /work/SRC/openSUSE:Factory/wxMaxima/wxMaxima.changes2019-08-23 
11:07:36.546474298 +0200
+++ /work/SRC/openSUSE:Factory/.wxMaxima.new.7948/wxMaxima.changes  
2019-09-13 14:58:23.521277423 +0200
@@ -1,0 +2,10 @@
+Wed Sep 11 07:44:19 UTC 2019 - Atri Bhattacharya 
+
+- Update to version 19.09.0:
+  * Handle timeouts when writing to maxima and partial writes.
+  * Worksheet text disappeared on scrolling on some platforms.
+  * Sped up sending code to maxima.
+  * Removed quoting of Unicode characters within strings sent to
+maxima.
+
+---

Old:

  Version-19.08.1.tar.gz

New:

  Version-19.09.0.tar.gz



Other differences:
--
++ wxMaxima.spec ++
--- /var/tmp/diff_new_pack.Ib6o8O/_old  2019-09-13 14:58:24.869277480 +0200
+++ /var/tmp/diff_new_pack.Ib6o8O/_new  2019-09-13 14:58:24.869277480 +0200
@@ -18,7 +18,7 @@
 
 %define tarname wxmaxima
 Name:   wxMaxima
-Version:19.08.1
+Version:19.09.0
 Release:0
 Summary:Graphical User Interface for the maxima Computer Algebra System
 License:GPL-2.0-or-later

++ Version-19.08.1.tar.gz -> Version-19.09.0.tar.gz ++
/work/SRC/openSUSE:Factory/wxMaxima/Version-19.08.1.tar.gz 
/work/SRC/openSUSE:Factory/.wxMaxima.new.7948/Version-19.09.0.tar.gz differ: 
char 13, line 1




commit iio-sensor-proxy for openSUSE:Factory

2019-09-13 Thread root
Hello community,

here is the log from the commit of package iio-sensor-proxy for 
openSUSE:Factory checked in at 2019-09-13 14:58:08

Comparing /work/SRC/openSUSE:Factory/iio-sensor-proxy (Old)
 and  /work/SRC/openSUSE:Factory/.iio-sensor-proxy.new.7948 (New)


Package is "iio-sensor-proxy"

Fri Sep 13 14:58:08 2019 rev:17 rq:730088 version:2.8

Changes:

--- /work/SRC/openSUSE:Factory/iio-sensor-proxy/iio-sensor-proxy.changes
2019-06-26 16:04:06.931636314 +0200
+++ 
/work/SRC/openSUSE:Factory/.iio-sensor-proxy.new.7948/iio-sensor-proxy.changes  
2019-09-13 14:58:15.337277076 +0200
@@ -1,0 +2,8 @@
+Wed Sep 11 08:10:23 UTC 2019 - Atri Bhattacharya 
+
+- Update to version 2.8:
+  + Add support for accelerometers in ChromeBooks.
+  + Fix screen orientation in favour of portrait when rotating
+display instead of favouring the previous orientation.
+
+---

Old:

  iio-sensor-proxy-2.7.tar.xz

New:

  iio-sensor-proxy-2.8.tar.xz



Other differences:
--
++ iio-sensor-proxy.spec ++
--- /var/tmp/diff_new_pack.Z4Culi/_old  2019-09-13 14:58:17.169277153 +0200
+++ /var/tmp/diff_new_pack.Z4Culi/_new  2019-09-13 14:58:17.169277153 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   iio-sensor-proxy
-Version:2.7
+Version:2.8
 Release:0
 Summary:Proxy for IIO and input subsystems
 License:GPL-3.0-only

++ iio-sensor-proxy-2.7.tar.xz -> iio-sensor-proxy-2.8.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/iio-sensor-proxy-2.7/Makefile.decl 
new/iio-sensor-proxy-2.8/Makefile.decl
--- old/iio-sensor-proxy-2.7/Makefile.decl  1970-01-01 01:00:00.0 
+0100
+++ new/iio-sensor-proxy-2.8/Makefile.decl  2019-09-04 16:04:13.0 
+0200
@@ -0,0 +1,54 @@
+# Note, we need this set for umockdev to be available in tests
+GTESTER= gtester   # in $PATH for non-GLIB packages
+GTESTER_REPORT = gtester-report# in $PATH for non-GLIB packages
+
+# initialize variables for unconditional += appending
+TEST_PROGS =
+
+# test: run all tests in cwd and subdirs
+test:  ${TEST_PROGS}
+   @test -z "${TEST_PROGS}" || ${GTESTER} --verbose ${TEST_PROGS}
+   @ for subdir in $(SUBDIRS) . ; do \
+   test "$$subdir" = "." -o "$$subdir" = "po" || \
+   ( cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $@ ) || exit $? ; \
+ done
+
+# test-report: run tests in subdirs and generate report
+# perf-report: run tests in subdirs with -m perf and generate report
+# full-report: like test-report: with -m perf and -m slow
+test-report perf-report full-report:   ${TEST_PROGS}
+   @test -z "${TEST_PROGS}" || { \
+ case $@ in \
+ test-report) test_options="-k";; \
+ perf-report) test_options="-k -m=perf";; \
+ full-report) test_options="-k -m=perf -m=slow";; \
+ esac ; \
+ if test -z "$$GTESTER_LOGDIR" ; then  \
+   ${GTESTER} --verbose $$test_options -o test-report.xml 
${TEST_PROGS} ; \
+ elif test -n "${TEST_PROGS}" ; then \
+   ${GTESTER} --verbose $$test_options -o `mktemp 
"$$GTESTER_LOGDIR/log-XX"` ${TEST_PROGS} ; \
+ fi ; \
+   }
+   @ ignore_logdir=true ; \
+ if test -z "$$GTESTER_LOGDIR" ; then \
+   GTESTER_LOGDIR=`mktemp -d "\`pwd\`/.testlogs-XX"`; export 
GTESTER_LOGDIR ; \
+   ignore_logdir=false ; \
+ fi ; \
+ for subdir in $(SUBDIRS) . ; do \
+   test "$$subdir" = "." -o "$$subdir" = "po" || \
+   ( cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $@ ) || exit $? ; \
+ done ; \
+ $$ignore_logdir || { \
+   echo '' > $@.xml ; \
+   echo ''  >> $@.xml ; \
+   for lf in `ls -L "$$GTESTER_LOGDIR"/.` ; do \
+ sed '1,1s/^?]*?>//' <"$$GTESTER_LOGDIR"/"$$lf" >> 
$@.xml ; \
+   done ; \
+   echo >> $@.xml ; \
+   echo '' >> $@.xml ; \
+   rm -rf "$$GTESTER_LOGDIR"/ ; \
+   ${GTESTER_REPORT} --version 2>/dev/null 1>&2 ; test "$$?" != 0 || 
${GTESTER_REPORT} $@.xml >$@.html ; \
+ }
+.PHONY: test test-report perf-report full-report
+# run make test as part of make check
+check-local: test
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/iio-sensor-proxy-2.7/NEWS 
new/iio-sensor-proxy-2.8/NEWS
--- old/iio-sensor-proxy-2.7/NEWS   2019-05-20 10:57:03.0 +0200
+++ new/iio-sensor-proxy-2.8/NEWS   2019-09-04 18:16:51.0 +0200
@@ -1,3 +1,10 @@
+2.8
+---
+
+This release adds support for accelerometers in ChromeBooks, and also
+fixes the screen orientation in 

  1   2   >