commit 000product for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-09-24 07:06:52

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.7948 (New)


Package is "000product"

Tue Sep 24 07:06:52 2019 rev:1619 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ openSUSE-Addon-NonOss-ftp-ftp-i586_x86_64.kiwi ++
--- /var/tmp/diff_new_pack.JVXtjF/_old  2019-09-24 07:06:55.654515488 +0200
+++ /var/tmp/diff_new_pack.JVXtjF/_new  2019-09-24 07:06:55.654515488 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -36,11 +36,11 @@
   true
   -x -2
   openSUSE
-  20190921
+  20190923
   11
-  cpe:/o:opensuse:opensuse-addon-nonoss:20190921,openSUSE NonOSS 
Addon
+  cpe:/o:opensuse:opensuse-addon-nonoss:20190923,openSUSE NonOSS 
Addon
   af ar be_BY bg br ca cy el et ga gl gu_IN he 
hi_IN hr ka km ko lt mk nn pa_IN rw sk sl sr_CS ss st tg th tr uk ve vi xh zu 

-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190921/i586
 
obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190921/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190923/i586
 
obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20190923/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.JVXtjF/_old  2019-09-24 07:06:55.670515488 +0200
+++ /var/tmp/diff_new_pack.JVXtjF/_new  2019-09-24 07:06:55.674515488 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20190921
+  20190923
   11
-  cpe:/o:opensuse:opensuse-microos:20190921,openSUSE 
MicroOS
+  cpe:/o:opensuse:opensuse-microos:20190923,openSUSE 
MicroOS
   en_US 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20190921/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20190923/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
@@ -373,8 +373,6 @@
   
   
   
-  
-  
   
   
   

++ openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.JVXtjF/_old  2019-09-24 07:06:55.690515488 +0200
+++ /var/tmp/diff_new_pack.JVXtjF/_new  2019-09-24 07:06:55.690515488 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20190921
+  20190923
   11
-  cpe:/o:opensuse:opensuse-microos:20190921,openSUSE 
MicroOS
+  cpe:/o:opensuse:opensuse-microos:20190923,openSUSE 
MicroOS
   en_US 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20190921/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20190923/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
@@ -270,8 +270,7 @@
   
   
   
-  
-  
+  
   
   
   
@@ -438,8 +437,6 @@
   
   
   
-  
-  
   
   
   

++ openSUSE-cd-mini-i586.kiwi ++
--- /var/tmp/diff_new_pack.JVXtjF/_old  2019-09-24 07:06:55.710515488 +0200
+++ /var/tmp/diff_new_pack.JVXtjF/_new  2019-09-24 07:06:55.714515488 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,11 +32,11 @@
   true
   -x -2
   openSUSE
-  20190921
+  20190923
   11
-  cpe:/o:opensuse:opensuse:20190921,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20190923,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190921/i586
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20190923/i586
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-cd-mini-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.JVXtjF/_old  2019-09-24 07:06:55.734515488 +0200
+++ /var/tmp/diff_new_pack.JVXtjF/_new  2019-09-24 07:06:55.734515488 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20190921
+  20190923
   11
-  cpe:/o:opensuse:opensuse:2019092

commit 000release-packages for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package 000release-packages for 
openSUSE:Factory checked in at 2019-09-24 07:06:42

Comparing /work/SRC/openSUSE:Factory/000release-packages (Old)
 and  /work/SRC/openSUSE:Factory/.000release-packages.new.7948 (New)


Package is "000release-packages"

Tue Sep 24 07:06:42 2019 rev:260 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ openSUSE-Addon-NonOss-release.spec ++
--- /var/tmp/diff_new_pack.5qBtW0/_old  2019-09-24 07:06:49.534515474 +0200
+++ /var/tmp/diff_new_pack.5qBtW0/_new  2019-09-24 07:06:49.534515474 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package openSUSE-Addon-NonOss-release (Version 20190921)
+# spec file for package openSUSE-Addon-NonOss-release (Version 20190923)
 #
 # Copyright (c) 2019 openSUSE.
 #
@@ -16,16 +16,16 @@
 Name:   openSUSE-Addon-NonOss-release
 %define product openSUSE-Addon-NonOss
 Summary:openSUSE NonOSS Addon
-Version:20190921
+Version:    20190923
 Release:0
 License:BSD-3-Clause
 Group:  System/Fhs
 
 Provides:   %name-%version
 Provides:   product() = openSUSE-Addon-NonOss
-Provides:   product(openSUSE-Addon-NonOss) = 20190921-0
+Provides:   product(openSUSE-Addon-NonOss) = 20190923-0
 Provides:   product-label() = non%20oss%20addon
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Daddon%2Dnonoss%3A20190921
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Daddon%2Dnonoss%3A20190923
 
 
 AutoReqProv:on
@@ -49,10 +49,10 @@
 
   openSUSE
   openSUSE-Addon-NonOss
-  20190921
+  20190923
   0
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-addon-nonoss:20190921
+  cpe:/o:opensuse:opensuse-addon-nonoss:20190923
   
 
 

++ openSUSE-MicroOS-release.spec ++
--- /var/tmp/diff_new_pack.5qBtW0/_old  2019-09-24 07:06:49.550515474 +0200
+++ /var/tmp/diff_new_pack.5qBtW0/_new  2019-09-24 07:06:49.550515474 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   openSUSE-MicroOS-release
-Version:20190921
+Version:    20190923
 Release:0
 Summary:openSUSE MicroOS 
 License:GPL-2.0-or-later
@@ -43,9 +43,9 @@
 ExclusiveArch:  %ix86 x86_64 ppc64le s390x aarch64
 Provides:   %name-%version
 Provides:   product() = openSUSE-MicroOS
-Provides:   product(openSUSE-MicroOS) = 20190921-0
+Provides:   product(openSUSE-MicroOS) = 20190923-0
 Provides:   product-label() = openSUSE%20MicroOS
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dmicroos%3A20190921
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dmicroos%3A20190923
 Provides:   product-url(releasenotes) = 
http%3A%2F%2Fdoc.opensuse.org%2Frelease%2Dnotes%2Fx86_64%2FopenSUSE%2FTumbleweed%2Frelease%2Dnotes%2DopenSUSE.rpm
 Provides:   product-endoflife()
 Requires:   product_flavor(openSUSE-MicroOS)
@@ -61,7 +61,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(dvd)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190921-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190923-0
 Summary:openSUSE MicroOS
 
 %description dvd
@@ -77,7 +77,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(kubic-dvd)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190921-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190923-0
 Summary:openSUSE MicroOS
 
 %description kubic-dvd
@@ -93,7 +93,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(appliance)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190921-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190923-0
 Summary:openSUSE MicroOS
 
 %description appliance
@@ -109,7 +109,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(appliance-kubic)
-Provides:   product_flavor(openSUSE-MicroOS) = 20190921-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20190923-0
 Summary:openSUSE MicroOS
 
 %description appliance-kubic
@@ -167,11 +167,11 @@
 
   openSUSE
   openSUSE-MicroOS
-  20190921
+  20190923
   0
   
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-microos:20190921
+  cpe:/o:opensuse:opensuse-microos:20190923
   openSUSE-MicroOS
   
 

++ openSUSE-release.spec ++
--- /var/tmp/diff_new_pack.5qBtW0/_old  2019-09-24 07:06:49.562515474 +0200
+++ /var/tmp/diff_new_pack.5qBtW0/_new  2019-09-24 07:06:49.566515474 +0200
@@ -20,7 +20,7 @@
 #define betaversion %{nil}
 %define codename Tumbleweed
 Name:   openSUSE-release
-Version:20190921
+Version:    2019092

commit 000update-repos for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-09-23 21:03:55

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.7948 (New)


Package is "000update-repos"

Mon Sep 23 21:03:55 2019 rev:564 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.1:update_1569263679.packages.xz



Other differences:
--































































































































































































































































































































































































































































































































































































































































































































































commit 000update-repos for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-09-23 21:03:50

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.7948 (New)


Package is "000update-repos"

Mon Sep 23 21:03:50 2019 rev:563 rq: version:unknown
Mon Sep 23 21:03:40 2019 rev:562 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.0:update_1569265284.packages.xz
  factory:non-oss_1615.2.packages.xz



Other differences:
--





























































































































































































































































































































































































































































































































































































































































































































































commit 000update-repos for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-09-23 21:03:38

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.7948 (New)


Package is "000update-repos"

Mon Sep 23 21:03:38 2019 rev:561 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  factory_20190921.packages.xz



Other differences:
--




























































































































































































































































































































































































































































































































































































































































































































































commit yast2-installation-control for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-installation-control for 
openSUSE:Factory checked in at 2019-09-23 13:17:12

Comparing /work/SRC/openSUSE:Factory/yast2-installation-control (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-installation-control.new.7948 (New)


Package is "yast2-installation-control"

Mon Sep 23 13:17:12 2019 rev:28 rq:732616 version:4.2.7

Changes:

--- 
/work/SRC/openSUSE:Factory/yast2-installation-control/yast2-installation-control.changes
2019-08-27 15:24:37.100743265 +0200
+++ 
/work/SRC/openSUSE:Factory/.yast2-installation-control.new.7948/yast2-installation-control.changes
  2019-09-23 13:17:13.565107012 +0200
@@ -1,0 +2,14 @@
+Mon Sep 23 07:02:00 UTC 2019 - Ladislav Slezák 
+
+- Use "display_name" tag for the product label, "label" marks a
+  translatable text (jsc#SLE-7214)
+- 4.2.7
+
+---
+Fri Sep 20 15:09:21 UTC 2019 - Ladislav Slezák 
+
+- Allow specifying the base products for the online installation
+  medium (jsc#SLE-7214)
+- 4.2.6
+
+---

Old:

  yast2-installation-control-4.2.5.tar.bz2

New:

  yast2-installation-control-4.2.7.tar.bz2



Other differences:
--
++ yast2-installation-control.spec ++
--- /var/tmp/diff_new_pack.Snq7XI/_old  2019-09-23 13:17:14.041106927 +0200
+++ /var/tmp/diff_new_pack.Snq7XI/_new  2019-09-23 13:17:14.045106925 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-installation-control
-Version:4.2.5
+Version:4.2.7
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-installation-control-4.2.5.tar.bz2 -> 
yast2-installation-control-4.2.7.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-installation-control-4.2.5/control/control.rnc 
new/yast2-installation-control-4.2.7/control/control.rnc
--- old/yast2-installation-control-4.2.5/control/control.rnc2019-08-27 
10:09:00.0 +0200
+++ new/yast2-installation-control-4.2.7/control/control.rnc2019-09-23 
09:22:57.0 +0200
@@ -315,6 +315,7 @@
 | optional_default_patterns
 | upgrade
 | minimalistic_libzypp_config
+| base_products
 
 ## The name of the product which should be selected,
 ## useful to choose it without asking the user (bsc#1124590).
@@ -460,6 +461,20 @@
 ## Minimalistic libzypp configuration (only requires, no documentation and no 
multiversion)
 minimalistic_libzypp_config = element minimalistic_libzypp_config { BOOLEAN }
 
+base_products = element base_products {
+LIST,
+base_product+
+}
+
+base_product = element base_product {
+element special_product { BOOLEAN }? &
+element display_name { text } &
+element name { text } &
+element version { text } &
+element register_target { text } &
+element archs { text }?
+}
+
 # software
 
 # partitioning
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-installation-control-4.2.5/control/control.rng 
new/yast2-installation-control-4.2.7/control/control.rng
--- old/yast2-installation-control-4.2.5/control/control.rng2019-08-27 
10:09:00.0 +0200
+++ new/yast2-installation-control-4.2.7/control/control.rng2019-09-23 
09:22:57.0 +0200
@@ -602,6 +602,7 @@
   
   
   
+  
 
   
   
@@ -938,6 +939,42 @@
   
 
   
+  
+
+  
+  
+
+  
+
+  
+  
+
+  
+
+  
+
+  
+
+
+  
+
+
+  
+
+
+  
+
+
+  
+
+
+  
+
+  
+
+  
+
+  
   
   
   

commit yast2-dns-server for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-dns-server for 
openSUSE:Factory checked in at 2019-09-23 13:17:17

Comparing /work/SRC/openSUSE:Factory/yast2-dns-server (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-dns-server.new.7948 (New)


Package is "yast2-dns-server"

Mon Sep 23 13:17:17 2019 rev:80 rq:732623 version:4.2.4

Changes:

--- /work/SRC/openSUSE:Factory/yast2-dns-server/yast2-dns-server.changes
2019-08-27 10:13:03.611972840 +0200
+++ 
/work/SRC/openSUSE:Factory/.yast2-dns-server.new.7948/yast2-dns-server.changes  
2019-09-23 13:17:18.865106060 +0200
@@ -1,0 +2,14 @@
+Mon Sep 23 07:12:04 UTC 2019 - Knut Anderssen 
+
+- Permit the user to force an netconfig update when netconfig was
+  not able to change the configuration. (bsc#1123985)
+- 4.2.4
+
+---
+Fri Sep 20 14:12:10 UTC 2019 - Knut Anderssen 
+
+- Do not modify the service when finishing the wizard dialog as
+  the configuration has not been written yet. (bsc#1123985)
+- 4.2.3
+
+---

Old:

  yast2-dns-server-4.2.2.tar.bz2

New:

  yast2-dns-server-4.2.4.tar.bz2



Other differences:
--
++ yast2-dns-server.spec ++
--- /var/tmp/diff_new_pack.Dott2A/_old  2019-09-23 13:17:19.385105967 +0200
+++ /var/tmp/diff_new_pack.Dott2A/_new  2019-09-23 13:17:19.389105966 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-dns-server
-Version:4.2.2
+Version:4.2.4
 Release:0
 Url:https://github.com/yast/yast-dns-server
 Summary:YaST2 - DNS Server Configuration

++ yast2-dns-server-4.2.2.tar.bz2 -> yast2-dns-server-4.2.4.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-dns-server-4.2.2/package/yast2-dns-server.changes 
new/yast2-dns-server-4.2.4/package/yast2-dns-server.changes
--- old/yast2-dns-server-4.2.2/package/yast2-dns-server.changes 2019-08-22 
12:29:41.0 +0200
+++ new/yast2-dns-server-4.2.4/package/yast2-dns-server.changes 2019-09-23 
09:49:54.0 +0200
@@ -1,4 +1,18 @@
 ---
+Mon Sep 23 07:12:04 UTC 2019 - Knut Anderssen 
+
+- Permit the user to force an netconfig update when netconfig was
+  not able to change the configuration. (bsc#1123985)
+- 4.2.4
+
+---
+Fri Sep 20 14:12:10 UTC 2019 - Knut Anderssen 
+
+- Do not modify the service when finishing the wizard dialog as
+  the configuration has not been written yet. (bsc#1123985)
+- 4.2.3
+
+---
 Thu Aug 22 11:42:15 CEST 2019 - sch...@suse.de
 
 - Using rb_default_ruby_abi tag in the spec file in order to
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-dns-server-4.2.2/package/yast2-dns-server.spec 
new/yast2-dns-server-4.2.4/package/yast2-dns-server.spec
--- old/yast2-dns-server-4.2.2/package/yast2-dns-server.spec2019-08-22 
12:29:41.0 +0200
+++ new/yast2-dns-server-4.2.4/package/yast2-dns-server.spec2019-09-23 
09:49:54.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package yast2-dns-server
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-dns-server
-Version:4.2.2
+Version:4.2.4
 Release:0
 Url:https://github.com/yast/yast-dns-server
 Summary:YaST2 - DNS Server Configuration
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-dns-server-4.2.2/src/include/dns-server/dialog-installwizard.rb 
new/yast2-dns-server-4.2.4/src/include/dns-server/dialog-installwizard.rb
--- old/yast2-dns-server-4.2.2/src/include/dns-server/dialog-installwizard.rb   
2019-08-22 12:29:41.0 +0200
+++ new/yast2-dns-server-4.2.4/src/include/dns-server/dialog-installwizard.rb   
2019-09-23 09:49:54.0 +0200
@@ -28,14 +28,6 @@
   Yast.import "CWMFirewallInterfaces"
 end
 
-# Writes settings and saves the service
-#
-# @return [Boolean] true if service is saved successfully; false otherwise
-def write_dns_settings
-  service_widget.store
-  service.save
-end
-
 def runInstallWizardForwardersDialog
   caption =
 # Dialog caption (before a colon)
@@ -261,7 +253,7 @@
   end
 
   if ret == :next || 

commit yast2-trans for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-trans for openSUSE:Factory 
checked in at 2019-09-23 13:17:01

Comparing /work/SRC/openSUSE:Factory/yast2-trans (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-trans.new.7948 (New)


Package is "yast2-trans"

Mon Sep 23 13:17:01 2019 rev:165 rq:732556 version:84.87.20190922.d5dcfb03ab

Changes:

--- /work/SRC/openSUSE:Factory/yast2-trans/yast2-trans.changes  2019-09-07 
12:32:33.681679466 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-trans.new.7948/yast2-trans.changes
2019-09-23 13:17:05.325108491 +0200
@@ -1,0 +2,92 @@
+Mon Sep 23 05:12:48 UTC 2019 - g...@opensuse.org
+
+- Update to version 84.87.20190922.d5dcfb03ab:
+  * Translated using Weblate (German)
+  * Translated using Weblate (Chinese (China))
+  * Translated using Weblate (Chinese (China))
+  * Translated using Weblate (Chinese (China))
+  * Translated using Weblate (Slovak)
+  * Translated using Weblate (Slovak)
+  * Translated using Weblate (Catalan)
+  * Translated using Weblate (Catalan)
+  * Translated using Weblate (Czech)
+  * Translated using Weblate (Czech)
+  * Translated using Weblate (Japanese)
+  * Translated using Weblate (Japanese)
+  * New POT for text domain 'registration'.
+  * New POT for text domain 'packager'.
+  * New POT for text domain 'languages_db'.
+  * New POT for text domain 'installation'.
+  * New POT for text domain 'dns-server'.
+  * New POT for text domain 'country'.
+  * Translated using Weblate (Slovak)
+  * Translated using Weblate (Slovak)
+  * Translated using Weblate (Portuguese (Brazil))
+  * Translated using Weblate (Japanese)
+  * Translated using Weblate (Dutch)
+  * Translated using Weblate (Czech)
+  * Translated using Weblate (Catalan)
+  * New POT for text domain 'storage'.
+  * New POT for text domain 'qt'.
+  * Translated using Weblate (Slovak)
+  * Translated using Weblate (German)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Portuguese (Brazil))
+  * Translated using Weblate (Czech)
+  * Translated using Weblate (Catalan)
+  * Translated using Weblate (Dutch)
+  * Translated using Weblate (Japanese)
+  * New POT for text domain 'storage'.
+  * Translated using Weblate (Catalan)
+  * Translated using Weblate (Catalan)
+  * Translated using Weblate (Catalan)
+
+---
+Mon Sep 16 05:12:49 UTC 2019 - g...@opensuse.org
+
+- Update to version 84.87.20190914.95e52b2a7e:
+  * Translated using Weblate (Danish)
+  * Translated using Weblate (Danish)
+  * Translated using Weblate (Danish)
+  * Translated using Weblate (Polish)
+  * Translated using Weblate (Polish)
+  * Translated using Weblate (Polish)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Danish)
+  * Translated using Weblate (Danish)
+  * Translated using Weblate (Polish)
+  * Translated using Weblate (Polish)
+  * Translated using Weblate (Danish)
+  * Translated using Weblate (Albanian)
+  * New POT for text domain 'network'.
+  * Translated using Weblate (Danish)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Chinese (China))
+  * Translated using Weblate (Catalan)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (German)
+
+---
+Mon Sep 09 05:12:51 UTC 2019 - g...@opensuse.org
+
+- Update to version 84.87.20190908.31319e7018:
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Slovak)
+  * Translated using Weblate (Finnish)
+  * Translated using Weblate (Portuguese (Brazil))
+  * Translated using Weblate (Dutch)
+  * Translated using Weblate (Albanian)
+  * Translated using Weblate (Japanese)
+  * Translated using Weblate (Czech)
+  * New POT for text domain 'storage'.
+  * New POT for text domain 'security'.
+  * New POT for text domain 'storage'.
+
+---

Old:

  yast2-trans-84.87.20190901.3784ecca69.tar.xz

New:

  yast2-trans-84.87.20190922.d5dcfb03ab.tar.xz



Other differences:
--
++ yast2-trans.spec ++
--- /var/tmp/diff_new_pack.3OZvLT/_old  2019-09-23 13:17:06.649108254 +0200
+++ /var/tmp/diff_new_pack.3OZvLT/_new  2019-09-23 13:17:06.657108252 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-trans
-Version:84.87.20190901.3784ecca69
+Version:84.87.20190922.d5dcfb03ab
 Release:0
 Summary:

commit yast2 for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2 for openSUSE:Factory checked 
in at 2019-09-23 13:17:22

Comparing /work/SRC/openSUSE:Factory/yast2 (Old)
 and  /work/SRC/openSUSE:Factory/.yast2.new.7948 (New)


Package is "yast2"

Mon Sep 23 13:17:22 2019 rev:460 rq:732625 version:4.2.23

Changes:

--- /work/SRC/openSUSE:Factory/yast2/yast2.changes  2019-09-04 
08:58:40.659072095 +0200
+++ /work/SRC/openSUSE:Factory/.yast2.new.7948/yast2.changes2019-09-23 
13:17:24.613105028 +0200
@@ -1,0 +2,27 @@
+Mon Sep 23 07:27:27 UTC 2019 - Ladislav Slezák 
+
+- Use "display_name" tag for the product label, "label" marks a
+  translatable text (jsc#SLE-7214)
+- 4.2.23
+
+---
+Thu Sep 19 12:05:17 UTC 2019 - Ladislav Slezák 
+
+- Added support for reading products from control.xml file
+  (jsc#SLE-7104)
+- 4.2.22
+
+---
+Tue Sep 10 07:57:34 UTC 2019 - Steffen Winterfeldt 
+
+- support reading licenses from tar archive (jsc#SLE-7214)
+- 4.2.21
+
+---
+Fri Sep  6 11:15:40 UTC 2019 - Imobach Gonzalez Sosa 
+
+- Fix a problem when long warnings reports in command line
+  (bsc#1149776).
+- 4.2.20
+
+---

Old:

  yast2-4.2.19.tar.bz2

New:

  yast2-4.2.23.tar.bz2



Other differences:
--
++ yast2.spec ++
--- /var/tmp/diff_new_pack.kCzutQ/_old  2019-09-23 13:17:25.457104876 +0200
+++ /var/tmp/diff_new_pack.kCzutQ/_new  2019-09-23 13:17:25.465104875 +0200
@@ -17,8 +17,9 @@
 
 
 Name:   yast2
-Version:4.2.19
+Version:4.2.23
 Release:0
+
 Summary:YaST2 Main Package
 License:GPL-2.0-only
 Group:  System/YaST

++ yast2-4.2.19.tar.bz2 -> yast2-4.2.23.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-4.2.19/library/general/src/modules/Report.rb 
new/yast2-4.2.23/library/general/src/modules/Report.rb
--- old/yast2-4.2.19/library/general/src/modules/Report.rb  2019-08-30 
11:55:44.0 +0200
+++ new/yast2-4.2.23/library/general/src/modules/Report.rb  2019-09-23 
09:58:23.0 +0200
@@ -566,7 +566,7 @@
 
   if @display_warnings
 if Mode.commandline
-  CommandLine.Print("Warning: #{error_string}")
+  CommandLine.Print("Warning: #{warning_string}")
 elsif Ops.greater_than(@timeout_warnings, 0)
   Popup.TimedLongWarningGeometry(warning_string, @timeout_warnings, 
width, height)
 else
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-4.2.19/library/general/test/report_test.rb 
new/yast2-4.2.23/library/general/test/report_test.rb
--- old/yast2-4.2.19/library/general/test/report_test.rb2019-08-30 
11:55:44.0 +0200
+++ new/yast2-4.2.23/library/general/test/report_test.rb2019-09-23 
09:58:23.0 +0200
@@ -108,6 +108,17 @@
   subject.LongWarning("Message")
   expect(subject.GetMessages(0, 1, 0, 0)).to match(/Message/)
 end
+
+context "when running on command line mode" do
+  before do
+allow(Yast::Mode).to receive(:commandline).and_return(true)
+  end
+
+  it "prints the message" do
+expect(Yast::CommandLine).to receive(:Print).with("Warning: message")
+subject.LongWarning("message")
+  end
+end
   end
 
   describe ".LongError" do
@@ -128,6 +139,17 @@
   subject.LongError("Message")
   expect(subject.GetMessages(0, 1, 0, 0)).to match(/Message/)
 end
+
+context "when running on command line mode" do
+  before do
+allow(Yast::Mode).to receive(:commandline).and_return(true)
+  end
+
+  it "prints the message" do
+expect(Yast::CommandLine).to receive(:Print).with("Error: message")
+subject.LongError("message")
+  end
+end
   end
 
   describe ".Settings" do
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-4.2.19/library/packages/src/lib/y2packager/licenses_fetchers/archive.rb
 
new/yast2-4.2.23/library/packages/src/lib/y2packager/licenses_fetchers/archive.rb
--- 
old/yast2-4.2.19/library/packages/src/lib/y2packager/licenses_fetchers/archive.rb
   1970-01-01 01:00:00.0 +0100
+++ 
new/yast2-4.2.23/library/packages/src/lib/y2packager/licenses_fetchers/archive.rb
   2019-09-23 09:58:23.0 +0200
@@ -0,0 +1,167 @@
+# 
--
+# Copyright (c) 2018 SUSE LLC, All Rights Reserved.
+#
+# This program 

commit yast2-storage-ng for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-storage-ng for 
openSUSE:Factory checked in at 2019-09-23 13:16:36

Comparing /work/SRC/openSUSE:Factory/yast2-storage-ng (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-storage-ng.new.7948 (New)


Package is "yast2-storage-ng"

Mon Sep 23 13:16:36 2019 rev:56 rq:731930 version:4.2.40

Changes:

--- /work/SRC/openSUSE:Factory/yast2-storage-ng/yast2-storage-ng.changes
2019-08-27 15:23:30.400776835 +0200
+++ 
/work/SRC/openSUSE:Factory/.yast2-storage-ng.new.7948/yast2-storage-ng.changes  
2019-09-23 13:16:38.161113369 +0200
@@ -1,0 +2,40 @@
+Thu Sep 19 07:57:35 UTC 2019 - David Diaz 
+
+- Partitioner: allow creating encrypted swap with random
+  password (bsc#1088641).
+- Partitioner: allow importing mount points from encrypted swap
+  with random password.
+- Storage: fix an encryption type inconsistency (bsc#1151079).
+- 4.2.40
+
+---
+Tue Sep 17 14:41:01 UTC 2019 - Steffen Winterfeldt 
+
+- add warning if /boot is on a LUKS2 encrypted partition
+- 4.2.39
+
+---
+Thu Sep  5 15:03:50 UTC 2019 - Ancor Gonzalez Sosa 
+
+- Partitioner: better handling of existing encryptions, including
+  the possibility of reusing them (related to jsc#SLE-7376).
+
+---
+Wed Sep 04 14:46:12 CEST 2019 - aschn...@suse.com
+
+- added translation for new EncryptionType::PLAIN (bsc#1088641)
+- 4.2.38
+
+---
+Fri Aug 30 09:25:52 UTC 2019 - Steffen Winterfeldt 
+
+- bind-mount /run from inst-sys to target system during install (bsc#1136463)
+- 4.2.37
+
+---
+Wed Aug 28 15:13:44 UTC 2019 - Ancor Gonzalez Sosa 
+
+- Partitioner: display encryption type (related to jsc#SLE-7376).
+- 4.2.36
+
+---

Old:

  yast2-storage-ng-4.2.35.tar.bz2

New:

  yast2-storage-ng-4.2.40.tar.bz2



Other differences:
--
++ yast2-storage-ng.spec ++
--- /var/tmp/diff_new_pack.FPk81C/_old  2019-09-23 13:16:38.789113256 +0200
+++ /var/tmp/diff_new_pack.FPk81C/_new  2019-09-23 13:16:38.793113255 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-storage-ng
-Version:4.2.35
+Version:4.2.40
 Release:0
 Summary:YaST2 - Storage Configuration
 License:GPL-2.0-only OR GPL-3.0-only
@@ -26,8 +26,8 @@
 
 Source: %{name}-%{version}.tar.bz2
 
-# Resize multi-device Btrfs
-BuildRequires:  libstorage-ng-ruby >= 4.1.121
+# PlainEncyption
+BuildRequires:  libstorage-ng-ruby >= 4.2.4
 BuildRequires:  update-desktop-files
 # CWM::Dialog#next_handler (4.1 branch) and improved CWM::Dialog
 BuildRequires:  yast2 >= 4.1.11
@@ -48,8 +48,8 @@
 
 # findutils for xargs
 Requires:   findutils
-# Resize multi-device Btrfs
-Requires:   libstorage-ng-ruby >= 4.1.121
+# PlainEncyption
+Requires:   libstorage-ng-ruby >= 4.2.4
 # CWM::Dialog#next_handler (4.1 branch) and improved CWM::Dialog
 Requires:   yast2 >= 4.1.11
 # Y2Packager::Repository

++ yast2-storage-ng-4.2.35.tar.bz2 -> yast2-storage-ng-4.2.40.tar.bz2 ++
/work/SRC/openSUSE:Factory/yast2-storage-ng/yast2-storage-ng-4.2.35.tar.bz2 
/work/SRC/openSUSE:Factory/.yast2-storage-ng.new.7948/yast2-storage-ng-4.2.40.tar.bz2
 differ: char 11, line 1




commit libyui for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package libyui for openSUSE:Factory checked 
in at 2019-09-23 13:16:25

Comparing /work/SRC/openSUSE:Factory/libyui (Old)
 and  /work/SRC/openSUSE:Factory/.libyui.new.7948 (New)


Package is "libyui"

Mon Sep 23 13:16:25 2019 rev:41 rq:731911 version:3.8.0

Changes:

--- /work/SRC/openSUSE:Factory/libyui/libyui.changes2019-07-08 
15:01:32.658581668 +0200
+++ /work/SRC/openSUSE:Factory/.libyui.new.7948/libyui.changes  2019-09-23 
13:16:26.937115384 +0200
@@ -1,0 +2,13 @@
+Thu Sep 19 09:34:27 UTC 2019 - Stefan Hundhammer 
+
+- Added ItemSelector widget (bsc#1084674)
+- 3.8.0
+
+---
+Thu Sep 12 11:27:12 CEST 2019 - aschn...@suse.com
+
+- Allow to get and set scrollbar position of RichText widget
+  (bsc#1150498)
+- 3.7.0
+
+---

Old:

  libyui-3.6.0.tar.bz2

New:

  libyui-3.8.0.tar.bz2



Other differences:
--
++ libyui-doc.spec ++
--- /var/tmp/diff_new_pack.SK5ITv/_old  2019-09-23 13:16:27.697115247 +0200
+++ /var/tmp/diff_new_pack.SK5ITv/_new  2019-09-23 13:16:27.709115245 +0200
@@ -20,7 +20,7 @@
 %define so_version 10
 
 Name:   %{parent}-doc
-Version:3.6.0
+Version:3.8.0
 Release:0
 Source: %{parent}-%{version}.tar.bz2
 

++ libyui.spec ++
--- /var/tmp/diff_new_pack.SK5ITv/_old  2019-09-23 13:16:27.805115228 +0200
+++ /var/tmp/diff_new_pack.SK5ITv/_new  2019-09-23 13:16:27.821115225 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   libyui
-Version:3.6.0
+Version:3.8.0
 Release:0
 Source: %{name}-%{version}.tar.bz2
 

++ libyui-3.6.0.tar.bz2 -> libyui-3.8.0.tar.bz2 ++
 9537 lines of diff (skipped)




commit yast2-packager for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-packager for openSUSE:Factory 
checked in at 2019-09-23 13:16:41

Comparing /work/SRC/openSUSE:Factory/yast2-packager (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-packager.new.7948 (New)


Package is "yast2-packager"

Mon Sep 23 13:16:41 2019 rev:379 rq:732113 version:4.2.27

Changes:

--- /work/SRC/openSUSE:Factory/yast2-packager/yast2-packager.changes
2019-09-02 13:20:57.805360595 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-packager.new.7948/yast2-packager.changes  
2019-09-23 13:16:43.241112457 +0200
@@ -1,0 +2,20 @@
+Wed Sep 18 11:28:23 UTC 2019 - Ladislav Slezák 
+
+- Support for the online installation medium (jsc#SLE-7214)
+- 4.2.27
+
+---
+Wed Sep 18 06:40:17 UTC 2019 - Ladislav Slezák 
+
+- Properly initialize the used base product name at upgrade
+  (bsc#1150856)
+- 4.2.26
+
+---
+Wed Sep  4 14:32:20 UTC 2019 - Ladislav Slezák 
+
+- Added Y2Packager::MediumType class for detecting the installation
+  medium type (related to jsc#SLE-7214)
+- 4.2.25
+
+---

Old:

  yast2-packager-4.2.24.tar.bz2

New:

  yast2-packager-4.2.27.tar.bz2



Other differences:
--
++ yast2-packager.spec ++
--- /var/tmp/diff_new_pack.lgo3VJ/_old  2019-09-23 13:16:43.709112373 +0200
+++ /var/tmp/diff_new_pack.lgo3VJ/_new  2019-09-23 13:16:43.709112373 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-packager
-Version:4.2.24
+Version:4.2.27
 Release:0
 Summary:YaST2 - Package Library
 License:GPL-2.0-or-later
@@ -35,8 +35,8 @@
 BuildRequires:  yast2-storage-ng >= 4.0.141
 # break the yast2-packager -> yast2-storage-ng -> yast2-packager build cycle
 #!BuildIgnore: yast2-packager
-# inst_rpmcopy.rb: SlideShow.RebuildDialog(true)
-BuildRequires:  yast2 >= 4.2.8
+# Y2Packager::ProductControlProduct
+BuildRequires:  yast2 >= 4.2.22
 # Pkg::Resolvables
 BuildRequires:  yast2-pkg-bindings >= 4.2.0
 # Augeas lenses
@@ -47,8 +47,8 @@
 Requires:   yast2-country-data >= 2.16.3
 # Pkg::Resolvables
 Requires:   yast2-pkg-bindings >= 4.2.0
-# Y2Packager::Product.forced_base_product
-Requires:   yast2 >= 4.2.17
+# Y2Packager::ProductControlProduct
+Requires:   yast2 >= 4.2.22
 # unzipping license file
 Requires:   unzip
 # HTTP, FTP, HTTPS modules (inst_productsources.ycp)

++ yast2-packager-4.2.24.tar.bz2 -> yast2-packager-4.2.27.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-packager-4.2.24/package/yast2-packager.changes 
new/yast2-packager-4.2.27/package/yast2-packager.changes
--- old/yast2-packager-4.2.24/package/yast2-packager.changes2019-08-29 
10:32:55.0 +0200
+++ new/yast2-packager-4.2.27/package/yast2-packager.changes2019-09-20 
11:36:49.0 +0200
@@ -1,4 +1,24 @@
 ---
+Wed Sep 18 11:28:23 UTC 2019 - Ladislav Slezák 
+
+- Support for the online installation medium (jsc#SLE-7214)
+- 4.2.27
+
+---
+Wed Sep 18 06:40:17 UTC 2019 - Ladislav Slezák 
+
+- Properly initialize the used base product name at upgrade
+  (bsc#1150856)
+- 4.2.26
+
+---
+Wed Sep  4 14:32:20 UTC 2019 - Ladislav Slezák 
+
+- Added Y2Packager::MediumType class for detecting the installation
+  medium type (related to jsc#SLE-7214)
+- 4.2.25
+
+---
 Wed Aug 28 12:59:14 UTC 2019 - José Iván López González 
 
 - Avoid error when generating some warnings (bsc#1148536).
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-packager-4.2.24/package/yast2-packager.spec 
new/yast2-packager-4.2.27/package/yast2-packager.spec
--- old/yast2-packager-4.2.24/package/yast2-packager.spec   2019-08-29 
10:32:55.0 +0200
+++ new/yast2-packager-4.2.27/package/yast2-packager.spec   2019-09-20 
11:36:49.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-packager
-Version:4.2.24
+Version:4.2.27
 Release:0
 Summary:YaST2 - Package Library
 License:GPL-2.0-or-later
@@ -35,8 +35,8 @@
 BuildRequires:  yast2-storage-ng >= 4.0.141
 # break the yast2-packager -> yast2-storage-ng -> yast2-packager build cycle
 #!BuildIgnore: yast2-packager
-# inst_rpmcopy.rb: SlideShow.RebuildDialog(true)
-BuildRequires:  yast2 >= 4.2.8
+# Y2Packager::ProductControlProduct

commit libyui-ncurses for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package libyui-ncurses for openSUSE:Factory 
checked in at 2019-09-23 13:16:08

Comparing /work/SRC/openSUSE:Factory/libyui-ncurses (Old)
 and  /work/SRC/openSUSE:Factory/.libyui-ncurses.new.7948 (New)


Package is "libyui-ncurses"

Mon Sep 23 13:16:08 2019 rev:47 rq:730776 version:2.52.1

Changes:

--- /work/SRC/openSUSE:Factory/libyui-ncurses/libyui-ncurses.changes
2019-07-08 14:59:46.634421363 +0200
+++ /work/SRC/openSUSE:Factory/.libyui-ncurses.new.7948/libyui-ncurses.changes  
2019-09-23 13:16:09.853118451 +0200
@@ -1,0 +2,7 @@
+Fri Sep 13 16:08:14 CEST 2019 - aschn...@suse.com
+
+- handle new libyui feature dealing with scrollbar position
+  of RichText widget (bsc#1150498)
+- 2.50.1
+
+---

Old:

  libyui-ncurses-2.52.0.tar.bz2

New:

  libyui-ncurses-2.52.1.tar.bz2



Other differences:
--
++ libyui-ncurses-doc.spec ++
--- /var/tmp/diff_new_pack.q22vwp/_old  2019-09-23 13:16:10.321118367 +0200
+++ /var/tmp/diff_new_pack.q22vwp/_new  2019-09-23 13:16:10.321118367 +0200
@@ -20,7 +20,7 @@
 %define so_version 10
 
 Name:   %{parent}-doc
-Version:2.52.0
+Version:2.52.1
 Release:0
 Source: %{parent}-%{version}.tar.bz2
 

++ libyui-ncurses.spec ++
--- /var/tmp/diff_new_pack.q22vwp/_old  2019-09-23 13:16:10.333118365 +0200
+++ /var/tmp/diff_new_pack.q22vwp/_new  2019-09-23 13:16:10.341118364 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   libyui-ncurses
-Version:2.52.0
+Version:2.52.1
 Release:0
 Source: %{name}-%{version}.tar.bz2
 

++ libyui-ncurses-2.52.0.tar.bz2 -> libyui-ncurses-2.52.1.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-ncurses-2.52.0/VERSION.cmake 
new/libyui-ncurses-2.52.1/VERSION.cmake
--- old/libyui-ncurses-2.52.0/VERSION.cmake 2019-07-02 15:44:07.0 
+0200
+++ new/libyui-ncurses-2.52.1/VERSION.cmake 2019-09-13 17:09:30.0 
+0200
@@ -1,6 +1,6 @@
 SET( VERSION_MAJOR "2" )
 SET( VERSION_MINOR "52" )
-SET( VERSION_PATCH "0" )
+SET( VERSION_PATCH "1" )
 SET( VERSION 
"${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}${GIT_SHA1_VERSION}" )
 
 # This is need for the libyui core, ONLY.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/libyui-ncurses-2.52.0/package/libyui-ncurses-doc.spec 
new/libyui-ncurses-2.52.1/package/libyui-ncurses-doc.spec
--- old/libyui-ncurses-2.52.0/package/libyui-ncurses-doc.spec   2019-07-02 
15:44:07.0 +0200
+++ new/libyui-ncurses-2.52.1/package/libyui-ncurses-doc.spec   2019-09-13 
17:09:30.0 +0200
@@ -19,7 +19,7 @@
 %define so_version 10
 
 Name:   %{parent}-doc
-Version:2.52.0
+Version:2.52.1
 Release:0
 Source: %{parent}-%{version}.tar.bz2
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-ncurses-2.52.0/package/libyui-ncurses.changes 
new/libyui-ncurses-2.52.1/package/libyui-ncurses.changes
--- old/libyui-ncurses-2.52.0/package/libyui-ncurses.changes2019-07-02 
15:44:07.0 +0200
+++ new/libyui-ncurses-2.52.1/package/libyui-ncurses.changes2019-09-13 
17:09:30.0 +0200
@@ -1,4 +1,11 @@
 ---
+Fri Sep 13 16:08:14 CEST 2019 - aschn...@suse.com
+
+- handle new libyui feature dealing with scrollbar position
+  of RichText widget (bsc#1150498)
+- 2.50.1
+
+---
 Fri Jun 28 13:52:07 UTC 2019 - Ladislav Slezák 
 
 - Send the notify events also when some widgets are changed via the
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-ncurses-2.52.0/package/libyui-ncurses.spec 
new/libyui-ncurses-2.52.1/package/libyui-ncurses.spec
--- old/libyui-ncurses-2.52.0/package/libyui-ncurses.spec   2019-07-02 
15:44:07.0 +0200
+++ new/libyui-ncurses-2.52.1/package/libyui-ncurses.spec   2019-09-13 
17:09:30.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   libyui-ncurses
-Version:2.52.0
+Version:2.52.1
 Release:0
 Source: %{name}-%{version}.tar.bz2
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-ncurses-2.52.0/src/NCPad.cc 
new/libyui-ncurses-2.52.1/src/NCPad.cc
--- old/libyui-ncurses-2.52.0/src/NCPad.cc  2019-07-02 15:44:07.0 
+0200
+++ new/libyui-ncurses-2.52.1/src/NCPad.cc  2019-09-13 17:09:30.0 
+0200
@@ -90,14 +90,14 @@
 
 if ( nsze.H > 

commit libblockdev for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package libblockdev for openSUSE:Factory 
checked in at 2019-09-23 13:16:19

Comparing /work/SRC/openSUSE:Factory/libblockdev (Old)
 and  /work/SRC/openSUSE:Factory/.libblockdev.new.7948 (New)


Package is "libblockdev"

Mon Sep 23 13:16:19 2019 rev:9 rq:731527 version:2.22

Changes:

--- /work/SRC/openSUSE:Factory/libblockdev/libblockdev.changes  2019-06-22 
11:20:40.709159750 +0200
+++ /work/SRC/openSUSE:Factory/.libblockdev.new.7948/libblockdev.changes
2019-09-23 13:16:20.837116479 +0200
@@ -1,0 +2,6 @@
+Thu Sep 17 10:48:00 UTC 2019 - Heming Zhao 
+
+- lvm2-clvm doesn't exist in lvm2-2.03, so change SPEC file
+  libbd_lvm-dbus requires from lvm2-clvm to lvm2
+
+---



Other differences:
--
++ libblockdev.spec ++
--- /var/tmp/diff_new_pack.7Fmjp6/_old  2019-09-23 13:16:21.529116355 +0200
+++ /var/tmp/diff_new_pack.7Fmjp6/_new  2019-09-23 13:16:21.533116354 +0200
@@ -17,7 +17,6 @@
 
 
 %define bcachetools_version 1.0.8
-%define lvm2_clvm_version   2.02.156
 %define somajor 2
 %define libname %{name}%{somajor}
 %bcond_with python2
@@ -284,7 +283,7 @@
 Summary:The LVM plugin for the LibBlockDev library
 Group:  System/Libraries
 Requires:   libbd_utils%{somajor} >= %{version}
-Requires:   lvm2-clvm >= %{lvm2_clvm_version}
+Requires:   lvm2
 # For thin_metadata_size.
 Requires:   thin-provisioning-tools
 Provides:   libblockdev-lvm-dbus = %{version}




commit libyui-qt for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package libyui-qt for openSUSE:Factory 
checked in at 2019-09-23 13:16:31

Comparing /work/SRC/openSUSE:Factory/libyui-qt (Old)
 and  /work/SRC/openSUSE:Factory/.libyui-qt.new.7948 (New)


Package is "libyui-qt"

Mon Sep 23 13:16:31 2019 rev:61 rq:731912 version:2.51.0

Changes:

--- /work/SRC/openSUSE:Factory/libyui-qt/libyui-qt.changes  2019-09-07 
11:30:49.118453807 +0200
+++ /work/SRC/openSUSE:Factory/.libyui-qt.new.7948/libyui-qt.changes
2019-09-23 13:16:33.213114257 +0200
@@ -1,0 +2,13 @@
+Wed Sep 18 15:37:28 UTC 2019 - Stefan Hundhammer 
+
+- Implemented ItemSelector widget (bsc#1084674)
+- 2.50.7 
+
+---
+Thu Sep 12 12:10:56 CEST 2019 - aschn...@suse.com
+
+- handle new libyui feature dealing with scrollbar position
+  of RichText widget (bsc#1150498)
+- 2.50.6
+
+---

Old:

  libyui-qt-2.50.5.tar.bz2

New:

  libyui-qt-2.51.0.tar.bz2



Other differences:
--
++ libyui-qt-doc.spec ++
--- /var/tmp/diff_new_pack.ky7EXq/_old  2019-09-23 13:16:33.789114153 +0200
+++ /var/tmp/diff_new_pack.ky7EXq/_new  2019-09-23 13:16:33.789114153 +0200
@@ -21,7 +21,7 @@
 
 Name:   %{parent}-doc
 # DO NOT manually bump the version here; instead, use   rake version:bump
-Version:2.50.5
+Version:2.51.0
 Release:0
 Source: %{parent}-%{version}.tar.bz2
 
@@ -32,7 +32,7 @@
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  graphviz-gnome
-BuildRequires:  libyui-devel >= 3.5.0
+BuildRequires:  libyui-devel >= 3.8.0
 BuildRequires:  texlive-latex
 
 Url:http://github.com/libyui/

++ libyui-qt.spec ++
--- /var/tmp/diff_new_pack.ky7EXq/_old  2019-09-23 13:16:33.809114150 +0200
+++ /var/tmp/diff_new_pack.ky7EXq/_new  2019-09-23 13:16:33.825114147 +0200
@@ -18,7 +18,7 @@
 
 Name:   libyui-qt
 # DO NOT manually bump the version here; instead, use   rake version:bump
-Version:2.50.5
+Version:2.51.0
 Release:0
 Source: %{name}-%{version}.tar.bz2
 
@@ -30,7 +30,7 @@
 BuildRequires:  gcc-c++
 BuildRequires:  pkg-config
 
-%define libyui_devel_version libyui-devel >= 3.5.0
+%define libyui_devel_version libyui-devel >= 3.8.0
 BuildRequires:  %{libyui_devel_version}
 BuildRequires:  fontconfig-devel
 BuildRequires:  pkgconfig(Qt5Core)
@@ -56,7 +56,7 @@
 Requires:   libyui%{so_version}
 Provides:   %{name} = %{version}
 Provides:   yast2-qt = %{version}
-Obsoletes:  yast2-qt < 2.42.0
+Obsoletes:  yast2-qt < 2.51.0
 
 Url:http://github.com/libyui/
 Summary:Libyui - Qt User Interface

++ libyui-qt-2.50.5.tar.bz2 -> libyui-qt-2.51.0.tar.bz2 ++
 5807 lines of diff (skipped)




commit yast2-installation for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-installation for 
openSUSE:Factory checked in at 2019-09-23 13:16:56

Comparing /work/SRC/openSUSE:Factory/yast2-installation (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-installation.new.7948 (New)


Package is "yast2-installation"

Mon Sep 23 13:16:56 2019 rev:432 rq:732211 version:4.2.14

Changes:

--- /work/SRC/openSUSE:Factory/yast2-installation/yast2-installation.changes
2019-09-11 10:16:08.607542404 +0200
+++ 
/work/SRC/openSUSE:Factory/.yast2-installation.new.7948/yast2-installation.changes
  2019-09-23 13:16:57.577109883 +0200
@@ -1,0 +2,12 @@
+Fri Sep 20 13:39:18 UTC 2019 - Ladislav Slezák 
+
+- Support for the online installation medium (jsc#SLE-7214)
+- 4.2.14
+
+---
+Wed Sep 11 13:17:21 UTC 2019 - Steffen Winterfeldt 
+
+- do NOT remove /mnt/run, it's a mounted directory (bsc#1149011)
+- 4.2.13
+
+---

Old:

  yast2-installation-4.2.12.tar.bz2

New:

  yast2-installation-4.2.14.tar.bz2



Other differences:
--
++ yast2-installation.spec ++
--- /var/tmp/diff_new_pack.RikRiQ/_old  2019-09-23 13:16:58.045109799 +0200
+++ /var/tmp/diff_new_pack.RikRiQ/_new  2019-09-23 13:16:58.049109798 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-installation
-Version:4.2.12
+Version:4.2.14
 Release:0
 Summary:YaST2 - Installation Parts
 License:GPL-2.0-only
@@ -36,10 +36,10 @@
 BuildRequires:  yast2-xml
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:rspec)
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:yast-rake)
-# Yast::Execute.stdout
-BuildRequires:  yast2 >= 4.1.42
-# Y2Packager::KnownRepositories
-BuildRequires:  yast2-packager >= 4.1.27
+# Y2Packager::ProductControlProduct
+BuildRequires:  yast2 >= 4.2.22
+# Y2Packager::MediumType
+BuildRequires:  yast2-packager >= 4.2.27
 # Y2Storage::Inhibitors including systemd masking
 BuildRequires:  yast2-storage-ng >= 4.0.194
 ## y2remote based version
@@ -67,8 +67,8 @@
 Requires:   yast2-country-data >= 2.16.11
 # Pkg::ProvidePackage
 Requires:   yast2-pkg-bindings >= 3.1.33
-# Y2Packager::KnownRepositories
-Requires:   yast2-packager >= 4.1.27
+# Y2Packager::MediumType
+Requires:   yast2-packager >= 4.2.22
 # use in startup scripts
 Requires:   initviocons
 # Proxy settings for 2nd stage (bnc#764951)
@@ -76,8 +76,8 @@
 # Systemd default target and services. This version supports
 # writing settings in the first installation stage.
 Requires:   yast2-services-manager >= 3.2.1
-# Y2Packager::Product.forced_base_product
-Requires:   yast2 >= 4.2.17
+# Y2Packager::ProductControlProduct
+Requires:   yast2 >= 4.2.22
 Requires:   yast2-network >= 4.0.13
 # for AbortException and handle direct abort
 Requires:   yast2-ruby-bindings >= 4.0.6

++ yast2-installation-4.2.12.tar.bz2 -> yast2-installation-4.2.14.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-installation-4.2.12/doc/SELF_UPDATE.md 
new/yast2-installation-4.2.14/doc/SELF_UPDATE.md
--- old/yast2-installation-4.2.12/doc/SELF_UPDATE.md2019-08-28 
13:44:54.0 +0200
+++ new/yast2-installation-4.2.14/doc/SELF_UPDATE.md2019-09-20 
17:04:45.0 +0200
@@ -5,6 +5,16 @@
 installation even after the media has been released. Check
 [FATE#319716](https://fate.suse.com/319716) for a more in-depth rationale.
 
+### :information_source: Note
+
+The self update feature is removed from the updated SLE Service Pack media
+(the updated media released after the initial SP release), these media already
+contain the updated installer and the included updates could conflict with
+the self updates.
+
+If you need to patch the installer on these updated media you have to use
+a driver update disk (DUD).
+
 ## Disabling Updates
 
 Starting in SUSE Linux Enterprise 12 SP3, self-update is enabled by default.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-installation-4.2.12/package/yast2-installation.changes 
new/yast2-installation-4.2.14/package/yast2-installation.changes
--- old/yast2-installation-4.2.12/package/yast2-installation.changes
2019-08-28 13:44:54.0 +0200
+++ new/yast2-installation-4.2.14/package/yast2-installation.changes
2019-09-20 17:04:45.0 +0200
@@ -1,4 +1,16 @@
 ---
+Fri Sep 20 13:39:18 UTC 2019 - Ladislav Slezák 
+
+- Support for the online installation medium (jsc#SLE-7214)
+- 4.2.14
+

commit yast2-country for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-country for openSUSE:Factory 
checked in at 2019-09-23 13:16:46

Comparing /work/SRC/openSUSE:Factory/yast2-country (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-country.new.7948 (New)


Package is "yast2-country"

Mon Sep 23 13:16:46 2019 rev:206 rq:732146 version:4.2.5

Changes:

--- /work/SRC/openSUSE:Factory/yast2-country/yast2-country.changes  
2019-08-19 20:47:55.125091653 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-country.new.7948/yast2-country.changes
2019-09-23 13:16:48.137111577 +0200
@@ -1,0 +2,7 @@
+Wed Sep 18 08:52:48 UTC 2019 - David Diaz 
+
+- Add missing Persian/Farsi language and keyboard layout
+  (bsc#1092920).
+- 4.2.5
+
+---

Old:

  yast2-country-4.2.4.tar.bz2

New:

  yast2-country-4.2.5.tar.bz2



Other differences:
--
++ yast2-country.spec ++
--- /var/tmp/diff_new_pack.OCtijt/_old  2019-09-23 13:16:48.613111492 +0200
+++ /var/tmp/diff_new_pack.OCtijt/_new  2019-09-23 13:16:48.613111492 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-country
-Version:4.2.4
+Version:4.2.5
 Release:0
 Summary:YaST2 - Country Settings (Language, Keyboard, and Timezone)
 License:GPL-2.0-only

++ yast2-country-4.2.4.tar.bz2 -> yast2-country-4.2.5.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-country-4.2.4/README 
new/yast2-country-4.2.5/README
--- old/yast2-country-4.2.4/README  2019-08-16 16:37:06.0 +0200
+++ new/yast2-country-4.2.5/README  1970-01-01 01:00:00.0 +0100
@@ -1,2 +0,0 @@
-Country specific data and configuration modules (language, keyboard,
-timezone) for YaST2.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-country-4.2.4/README.markdown 
new/yast2-country-4.2.5/README.markdown
--- old/yast2-country-4.2.4/README.markdown 2019-08-16 16:37:06.0 
+0200
+++ new/yast2-country-4.2.5/README.markdown 2019-09-20 13:57:42.0 
+0200
@@ -20,3 +20,130 @@
 ## Links ##
 
   * See more at http://en.opensuse.org/openSUSE:YaST_development
+
+## Adding a New Country
+
+- console/src/data/consolefonts.json
+
+- key: locale_id
+- font: /usr/share/kbd/consolefonts/%s.gz (kbd.rpm)
+- unicodeMap: ?
+- screenMap: ?
+- magic: ?
+
+---
+
+```json
+"en_GB": {
+"font": "eurlatgr.psfu",
+"unicodeMap": "",
+"screenMap": "",
+"magic": ""
+}
+```
+
+---
+
+- keyboard/src/data/keyboard_raw.ycp
+
+Console keyboard layout
+
+- key: yast_keyboard_id
+- value: pair of translatable_string, more_data:
+- key: keyboard_hardware (pc104, macintosh, type4, type5, type5_euro)
+- value: more_data:
+- ncurses: /usr/share/kbd/keymaps/xkb/%s
+- compose: ? (optional)
+
+---
+
+```js
+"english-uk": [
+_("English (UK)"),
+$[
+"pc104":  $[ "ncurses": "gb.map.gz"],
+"macintosh":  $[ "ncurses": "gb-mac.map.gz" ],
+"type4":  $[ "ncurses": "us.map.gz"],
+"type5":  $[ "ncurses": "us.map.gz"],
+"type5_euro": $[ "ncurses": "us.map.gz"],
+]
+]
+
+```
+
+---
+
+- keyboard/src/data/lang2keyboard.ycp (TODO convert)
+- key: locale_id
+- value: yast_keyboard_id
+
+---
+
+```js
+"en_GB": "english-uk"
+```
+
+---
+
+- keyboard/src/data/xkblayout2keyboard.ycp (TODO convert)
+
+man xkeyboard-config
+
+- key: xkblayout_id ?
+- value: yast_keyboard_id
+
+---
+
+```js
+"gb": "english-uk"
+```
+
+---
+
+- language/src/data/languages/language_%s.ycp (ll_TT)
+- ll_TT: 5-tuple
+- (native) name in unicode
+- (native) name in ascii
+- utf-8 modifier
+- non-utf-8 modifier
+- translatable name
+- timezone: tz_id
+- keyboard: yast_keyboard_id
+
+---
+
+```js
+$[
+"en_GB": [
+"English (UK)",
+"English (UK)",
+".UTF-8",
+"",
+_("English (UK)")
+],
+"timezone" : "Europe/London",
+"keyboard" : "english-uk",
+]
+```
+
+---
+
+- timezone/src/data/lang2tz.ycp
+
+> NOTE: it is also in language_xx_XX.ycp
+
+- key: locale_id
+- value: tz_id
+
+---
+
+```js
+"en_GB": "Europe/London"
+```
+
+---
+
+- timezone/src/data/timezone_raw.ycp
+
+Translatable TZ names (timezone_db.pot)
+
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 

commit yast2-ycp-ui-bindings for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-ycp-ui-bindings for 
openSUSE:Factory checked in at 2019-09-23 13:16:03

Comparing /work/SRC/openSUSE:Factory/yast2-ycp-ui-bindings (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-ycp-ui-bindings.new.7948 (New)


Package is "yast2-ycp-ui-bindings"

Mon Sep 23 13:16:03 2019 rev:73 rq:730756 version:4.2.1

Changes:

--- 
/work/SRC/openSUSE:Factory/yast2-ycp-ui-bindings/yast2-ycp-ui-bindings.changes  
2018-11-01 18:58:29.913985751 +0100
+++ 
/work/SRC/openSUSE:Factory/.yast2-ycp-ui-bindings.new.7948/yast2-ycp-ui-bindings.changes
2019-09-23 13:16:04.509119411 +0200
@@ -1,0 +2,14 @@
+Fri Sep 13 15:05:16 CEST 2019 - aschn...@suse.com
+
+- added example using scrollbar positions of RichText widget with
+  hyperlinks (bsc#1150498)
+- 4.2.1
+
+---
+Thu Sep 12 12:46:46 CEST 2019 - aschn...@suse.com
+
+- added example using scrollbar positions of RichText widget
+  (bsc#1150498)
+- 4.2.0
+
+---

Old:

  yast2-ycp-ui-bindings-4.1.0.tar.bz2

New:

  yast2-ycp-ui-bindings-4.2.1.tar.bz2



Other differences:
--
++ yast2-ycp-ui-bindings.spec ++
--- /var/tmp/diff_new_pack.YhlkHP/_old  2019-09-23 13:16:04.937119334 +0200
+++ /var/tmp/diff_new_pack.YhlkHP/_new  2019-09-23 13:16:04.941119333 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package yast2-ycp-ui-bindings
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-ycp-ui-bindings
-Version:4.1.0
+Version:4.2.1
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-ycp-ui-bindings-4.1.0.tar.bz2 -> 
yast2-ycp-ui-bindings-4.2.1.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-ycp-ui-bindings-4.1.0/Dockerfile 
new/yast2-ycp-ui-bindings-4.2.1/Dockerfile
--- old/yast2-ycp-ui-bindings-4.1.0/Dockerfile  2018-10-16 17:43:55.0 
+0200
+++ new/yast2-ycp-ui-bindings-4.2.1/Dockerfile  2019-09-13 16:13:52.0 
+0200
@@ -1,2 +1,2 @@
-FROM yastdevel/cpp
+FROM registry.opensuse.org/yast/head/containers/yast-cpp:latest
 COPY . /usr/src/app
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-ycp-ui-bindings-4.1.0/examples/RichText7.rb 
new/yast2-ycp-ui-bindings-4.2.1/examples/RichText7.rb
--- old/yast2-ycp-ui-bindings-4.1.0/examples/RichText7.rb   1970-01-01 
01:00:00.0 +0100
+++ new/yast2-ycp-ui-bindings-4.2.1/examples/RichText7.rb   2019-09-13 
16:13:52.0 +0200
@@ -0,0 +1,82 @@
+# encoding: utf-8
+
+# Example for controlling scrollbars of a RichText widget
+module Yast
+  class RichText7Client < Client
+def main
+  Yast.import 'UI'
+
+  text = ''
+  for n in 1..50 do
+text += "n = #{n}, 2^n = #{2**n}\n"
+  end
+
+  UI.OpenDialog(
+Opt(:defaultsize),
+VBox(
+  RichText(Id(:text), text),
+  HBox(
+PushButton(Id(:reset), 'Reset'),
+PushButton(Id(:append), 'Append')
+  ),
+  HBox(
+PushButton(Id(:vertical_minimum), 'Vertical Minimum'),
+PushButton(Id(:vertical_maximum), 'Vertical Maximum')
+  ),
+  HBox(
+PushButton(Id(:horizontal_minimum), 'Horizontal Minimum'),
+PushButton(Id(:horizontal_maximum), 'Horizontal Maximum')
+  ),
+  PushButton(Id(:close), Opt(:default), 'Close')
+)
+  )
+
+  input = nil
+  begin
+input = UI.UserInput
+
+case input
+
+when :reset
+  text = ''
+  for n in 1..50 do
+text += "n = #{n}, 2^n = #{2**n}\n"
+  end
+
+  vertical_scroll_value = UI.QueryWidget(Id(:text), :VScrollValue)
+  horizontal_scroll_value = UI.QueryWidget(Id(:text), :HScrollValue)
+  UI.ChangeWidget(Id(:text), :Value, text)
+  UI.ChangeWidget(Id(:text), :VScrollValue, vertical_scroll_value)
+  UI.ChangeWidget(Id(:text), :HScrollValue, horizontal_scroll_value)
+
+when :append
+  n += 1
+  text += "n = #{n}, 2^n = #{2**n}\n"
+
+  vertical_scroll_value = UI.QueryWidget(Id(:text), :VScrollValue)
+  horizontal_scroll_value = UI.QueryWidget(Id(:text), :HScrollValue)
+  UI.ChangeWidget(Id(:text), :Value, text)
+  UI.ChangeWidget(Id(:text), 

commit yast2-control-center for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-control-center for 
openSUSE:Factory checked in at 2019-09-23 13:15:58

Comparing /work/SRC/openSUSE:Factory/yast2-control-center (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-control-center.new.7948 (New)


Package is "yast2-control-center"

Mon Sep 23 13:15:58 2019 rev:80 rq:730537 version:4.2.2

Changes:

--- 
/work/SRC/openSUSE:Factory/yast2-control-center/yast2-control-center.changes
2019-07-31 14:17:21.062700581 +0200
+++ 
/work/SRC/openSUSE:Factory/.yast2-control-center.new.7948/yast2-control-center.changes
  2019-09-23 13:16:01.077120027 +0200
@@ -1,0 +2,6 @@
+Tue Sep 10 22:23:37 UTC 2019 - Stasiek Michalski 
+
+- Fix appdata for new spec (fate#319035)
+- 4.2.2
+
+---

Old:

  yast2-control-center-4.2.1.tar.bz2

New:

  yast2-control-center-4.2.2.tar.bz2



Other differences:
--
++ yast2-control-center.spec ++
--- /var/tmp/diff_new_pack.iALqdm/_old  2019-09-23 13:16:01.501119951 +0200
+++ /var/tmp/diff_new_pack.iALqdm/_new  2019-09-23 13:16:01.501119951 +0200
@@ -17,11 +17,15 @@
 
 
 Name:   yast2-control-center
-Version:4.2.1
+Version:4.2.2
 Release:0
+Url:https://github.com/yast/yast-control-center
+Summary:YaST2 - Control Center
+License:GPL-2.0-only
+Group:  System/YaST
 
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Source0:yast2-control-center-%{version}.tar.bz2
+
 BuildRequires:  cmake
 BuildRequires:  libdrm-devel
 BuildRequires:  libjpeg-devel
@@ -31,11 +35,6 @@
 BuildRequires:  pkgconfig(Qt5Core)
 BuildRequires:  pkgconfig(Qt5Gui)
 BuildRequires:  pkgconfig(Qt5Widgets)
-
-# control-center-gnome is dropped and this one should be used instead
-Obsoletes:  yast2-control-center-gnome < %{version}
-Provides:   yast2-control-center-gnome = %{version}
-
 %if 0%{?force_gcc_46}
 BuildRequires:  gcc46
 BuildRequires:  gcc46-c++
@@ -43,37 +42,36 @@
 BuildRequires:  gcc-c++ >= 4.6
 %endif
 
-Url:https://github.com/yast/yast-control-center
-Summary:YaST2 - Control Center
-License:GPL-2.0-only
-Group:  System/YaST
 Requires:   yast2
 Requires:   yast2-control-center-binary
 
+# control-center-gnome is dropped and this one should be used instead
+Obsoletes:  yast2-control-center-gnome < %{version}
+Provides:   yast2-control-center-gnome = %{version}
+
 %description
 This package contains the menu selection component for YaST2.
 
 %package qt
 Summary:YaST2 - Control Center (Qt Version)
 Group:  System/YaST
-Requires:   yast2-control-center
-Provides:   yast2-control-center-binary
-Provides:   yast2-control-center:%{_prefix}/lib/YaST2/bin/y2controlcenter
-Requires:   libyui-qt
 
+Requires:   libyui-qt
+Requires:   yast2-control-center
 # bsc#1130700: Need Qt SVG support for icons
 Requires:   libQt5Svg5
 
-Supplements:kdebase3
-Supplements:kdebase4-session
-Supplements:plasma5-session
+Provides:   yast2-control-center-binary
+Provides:   yast2-control-center:%{_prefix}/lib/YaST2/bin/y2controlcenter
+
+Supplements:(yast2 and plasma5-session)
 
 %description qt
 This package contains the menu selection component for YaST2 using the
 Qt toolkit.
 
 %prep
-%setup
+%setup -q
 
 %build
 mkdir build
@@ -94,20 +92,16 @@
 
 %install
 cd build
-make install DESTDIR=$RPM_BUILD_ROOT
+make install DESTDIR=%{buildroot}
 cd ..
 
-%suse_update_desktop_file -G "Administrator Settings"  
%{buildroot}%{_datadir}/applications/org.openSUSE.YaST.desktop Core-System 
X-SuSE-ControlCenter-System X-GNOME-SystemSettings
+%suse_update_desktop_file -G "Administrator Settings"  
%{buildroot}%{_datadir}/applications/org.opensuse.YaST.desktop Core-System 
X-SuSE-ControlCenter-System X-GNOME-SystemSettings
 %suse_update_desktop_file 
%{buildroot}%{_datadir}/kde4/services/YaST-systemsettings.desktop 
 
-%clean
-rm -rf "$RPM_BUILD_ROOT"
-
 %files
-%defattr(-,root,root)
 %dir %{_datadir}/metainfo
-%{_datadir}/metainfo/org.openSUSE.YaST.appdata.xml
-%{_datadir}/applications/org.openSUSE.YaST.desktop
+%{_datadir}/metainfo/org.opensuse.YaST.appdata.xml
+%{_datadir}/applications/org.opensuse.YaST.desktop
 %dir %{_datadir}/kde4/
 %dir %{_datadir}/kde4/services
 %{_datadir}/kde4/services/YaST-systemsettings.desktop
@@ -116,8 +110,7 @@
 %{yast_icondir}
 
 %files qt
-%defattr(-,root,root)
-%{_prefix}/lib/YaST2/bin/y2controlcenter
+%{_libexecdir}/YaST2/bin/y2controlcenter
 %license COPYING.GPL2
 
 %changelog

++ yast2-control-center-4.2.1.tar.bz2 -> yast2-control-center-4.2.2.tar.bz2 
++
diff -urN '--exclude=CVS' 

commit libyui-qt-graph for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package libyui-qt-graph for openSUSE:Factory 
checked in at 2019-09-23 13:16:14

Comparing /work/SRC/openSUSE:Factory/libyui-qt-graph (Old)
 and  /work/SRC/openSUSE:Factory/.libyui-qt-graph.new.7948 (New)


Package is "libyui-qt-graph"

Mon Sep 23 13:16:14 2019 rev:24 rq:731511 version:2.45.3

Changes:

--- /work/SRC/openSUSE:Factory/libyui-qt-graph/libyui-qt-graph.changes  
2019-06-28 16:34:53.782690008 +0200
+++ 
/work/SRC/openSUSE:Factory/.libyui-qt-graph.new.7948/libyui-qt-graph.changes
2019-09-23 13:16:15.697117402 +0200
@@ -1,0 +2,6 @@
+Thu Sep 12 14:29:09 UTC 2019 - Martin Vidner 
+
+- Make scroll-up mean zoom-in (bsc#1149158)
+- 2.45.3
+
+---

Old:

  libyui-qt-graph-2.45.2.tar.bz2

New:

  libyui-qt-graph-2.45.3.tar.bz2



Other differences:
--
++ libyui-qt-graph-doc.spec ++
--- /var/tmp/diff_new_pack.YfeDmW/_old  2019-09-23 13:16:16.245117303 +0200
+++ /var/tmp/diff_new_pack.YfeDmW/_new  2019-09-23 13:16:16.249117303 +0200
@@ -20,7 +20,7 @@
 %define so_version 10
 
 Name:   %{parent}-doc
-Version:2.45.2
+Version:2.45.3
 Release:0
 Source: %{parent}-%{version}.tar.bz2
 

++ libyui-qt-graph.spec ++
--- /var/tmp/diff_new_pack.YfeDmW/_old  2019-09-23 13:16:16.265117300 +0200
+++ /var/tmp/diff_new_pack.YfeDmW/_new  2019-09-23 13:16:16.265117300 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   libyui-qt-graph
-Version:2.45.2
+Version:2.45.3
 Release:0
 Source: %{name}-%{version}.tar.bz2
 

++ libyui-qt-graph-2.45.2.tar.bz2 -> libyui-qt-graph-2.45.3.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-qt-graph-2.45.2/VERSION.cmake 
new/libyui-qt-graph-2.45.3/VERSION.cmake
--- old/libyui-qt-graph-2.45.2/VERSION.cmake2019-05-07 14:17:25.0 
+0200
+++ new/libyui-qt-graph-2.45.3/VERSION.cmake2019-09-17 13:26:22.0 
+0200
@@ -1,6 +1,6 @@
 SET(VERSION_MAJOR "2")
 SET(VERSION_MINOR "45")
-SET(VERSION_PATCH "2")
+SET(VERSION_PATCH "3")
 SET( VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}" )
 
 # This is need for the libyui core, ONLY.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/libyui-qt-graph-2.45.2/package/libyui-qt-graph-doc.spec 
new/libyui-qt-graph-2.45.3/package/libyui-qt-graph-doc.spec
--- old/libyui-qt-graph-2.45.2/package/libyui-qt-graph-doc.spec 2019-05-07 
14:17:25.0 +0200
+++ new/libyui-qt-graph-2.45.3/package/libyui-qt-graph-doc.spec 2019-09-17 
13:26:22.0 +0200
@@ -20,7 +20,7 @@
 %define so_version 10
 
 Name:   %{parent}-doc
-Version:2.45.2
+Version:2.45.3
 Release:0
 Source: %{parent}-%{version}.tar.bz2
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/libyui-qt-graph-2.45.2/package/libyui-qt-graph.changes 
new/libyui-qt-graph-2.45.3/package/libyui-qt-graph.changes
--- old/libyui-qt-graph-2.45.2/package/libyui-qt-graph.changes  2019-05-07 
14:17:25.0 +0200
+++ new/libyui-qt-graph-2.45.3/package/libyui-qt-graph.changes  2019-09-17 
13:26:22.0 +0200
@@ -1,4 +1,10 @@
 ---
+Thu Sep 12 14:29:09 UTC 2019 - Martin Vidner 
+
+- Make scroll-up mean zoom-in (bsc#1149158)
+- 2.45.3
+
+---
 Tue May  7 12:02:03 UTC 2019 - Stefan Hundhammer 
 
 - Fixed empty labels in graph elements (bsc#1130502):
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-qt-graph-2.45.2/package/libyui-qt-graph.spec 
new/libyui-qt-graph-2.45.3/package/libyui-qt-graph.spec
--- old/libyui-qt-graph-2.45.2/package/libyui-qt-graph.spec 2019-05-07 
14:17:25.0 +0200
+++ new/libyui-qt-graph-2.45.3/package/libyui-qt-graph.spec 2019-09-17 
13:26:22.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   libyui-qt-graph
-Version:2.45.2
+Version:2.45.3
 Release:0
 Source: %{name}-%{version}.tar.bz2
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-qt-graph-2.45.2/src/QY2Graph.cc 
new/libyui-qt-graph-2.45.3/src/QY2Graph.cc
--- old/libyui-qt-graph-2.45.2/src/QY2Graph.cc  2019-05-07 14:17:25.0 
+0200
+++ new/libyui-qt-graph-2.45.3/src/QY2Graph.cc  2019-09-17 13:26:22.0 
+0200
@@ -95,15 +95,21 @@
 void
 QY2Graph::wheelEvent(QWheelEvent* event)
 {
-scaleView(pow(2.0, -event->delta() / 240.0));
+// 1 step of a typical mouse wheel 

commit yast2-registration for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-registration for 
openSUSE:Factory checked in at 2019-09-23 13:16:51

Comparing /work/SRC/openSUSE:Factory/yast2-registration (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-registration.new.7948 (New)


Package is "yast2-registration"

Mon Sep 23 13:16:51 2019 rev:39 rq:732160 version:4.2.8

Changes:

--- /work/SRC/openSUSE:Factory/yast2-registration/yast2-registration.changes
2019-08-27 10:17:05.919956701 +0200
+++ 
/work/SRC/openSUSE:Factory/.yast2-registration.new.7948/yast2-registration.changes
  2019-09-23 13:16:52.653110767 +0200
@@ -1,0 +2,6 @@
+Fri Sep 20 09:27:04 UTC 2019 - Ladislav Slezák 
+
+- Support for the online installation medium (jsc#SLE-7214)
+- 4.2.8
+
+---

Old:

  yast2-registration-4.2.7.tar.bz2

New:

  yast2-registration-4.2.8.tar.bz2



Other differences:
--
++ yast2-registration.spec ++
--- /var/tmp/diff_new_pack.bT8QKQ/_old  2019-09-23 13:16:53.101110686 +0200
+++ /var/tmp/diff_new_pack.bT8QKQ/_new  2019-09-23 13:16:53.101110686 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-registration
-Version:4.2.7
+Version:4.2.8
 Release:0
 Summary:YaST2 - Registration Module
 License:GPL-2.0-only
@@ -26,20 +26,20 @@
 
 Source0:%{name}-%{version}.tar.bz2
 
-# Y2Packager::ProductLicense
 BuildRequires:  update-desktop-files
-BuildRequires:  yast2 >= 4.0.63
+# Y2Packager::ProductControlProduct
+BuildRequires:  yast2 >= 4.2.22
 BuildRequires:  yast2-devtools >= 4.2.2
 BuildRequires:  yast2-slp >= 3.1.9
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:rspec)
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:suse-connect) >= 0.3.11
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:yast-rake) >= 0.2.5
-# updated product renames
-BuildRequires:  yast2-packager >= 4.0.40
+# Y2Packager::MediumType
+BuildRequires:  yast2-packager >= 4.2.27
 BuildRequires:  yast2-update >= 3.1.36
 
-# Y2Packager::ProductLicense
-Requires:   yast2 >= 4.0.63
+# Y2Packager::ProductControlProduct
+Requires:   yast2 >= 4.2.22
 # "dupAllowVendorChange" option in Pkg.SetSolverFlags()
 Requires:   yast2-pkg-bindings >= 3.1.34
 # N_() method
@@ -54,8 +54,8 @@
 Requires:   SUSEConnect >= 0.2.37
 Requires:   yast2-add-on >= 3.1.8
 Requires:   yast2-slp >= 3.1.9
-# Packager ProductLicense#HandleLicenseDialogRet allowing "refuse" action
-Requires:   yast2-packager >= 4.2.16
+# Y2Packager::MediumType
+Requires:   yast2-packager >= 4.2.27
 Requires:   yast2-update >= 3.1.36
 
 BuildArch:  noarch

++ yast2-registration-4.2.7.tar.bz2 -> yast2-registration-4.2.8.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-registration-4.2.7/package/yast2-registration.changes 
new/yast2-registration-4.2.8/package/yast2-registration.changes
--- old/yast2-registration-4.2.7/package/yast2-registration.changes 
2019-08-22 17:18:15.0 +0200
+++ new/yast2-registration-4.2.8/package/yast2-registration.changes 
2019-09-20 14:20:27.0 +0200
@@ -1,4 +1,10 @@
 ---
+Fri Sep 20 09:27:04 UTC 2019 - Ladislav Slezák 
+
+- Support for the online installation medium (jsc#SLE-7214)
+- 4.2.8
+
+---
 Thu Aug 22 16:54:42 CEST 2019 - sch...@suse.de
 
 - Using rb_default_ruby_abi tag in the spec file in order to
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-registration-4.2.7/package/yast2-registration.spec 
new/yast2-registration-4.2.8/package/yast2-registration.spec
--- old/yast2-registration-4.2.7/package/yast2-registration.spec
2019-08-22 17:18:15.0 +0200
+++ new/yast2-registration-4.2.8/package/yast2-registration.spec
2019-09-20 14:20:27.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-registration
-Version:4.2.7
+Version:4.2.8
 Release:0
 Summary:YaST2 - Registration Module
 License:GPL-2.0-only
@@ -26,20 +26,20 @@
 
 Source0:%{name}-%{version}.tar.bz2
 
-# Y2Packager::ProductLicense
 BuildRequires:  update-desktop-files
-BuildRequires:  yast2 >= 4.0.63
+# Y2Packager::ProductControlProduct
+BuildRequires:  yast2 >= 4.2.22
 BuildRequires:  yast2-devtools >= 4.2.2
 BuildRequires:  yast2-slp >= 3.1.9
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:rspec)
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:suse-connect) >= 0.3.11
 BuildRequires:  rubygem(%{rb_default_ruby_abi}:yast-rake) >= 0.2.5
-# updated product renames
-BuildRequires:  

commit rubygem-yast-rake for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package rubygem-yast-rake for 
openSUSE:Factory checked in at 2019-09-23 13:15:06

Comparing /work/SRC/openSUSE:Factory/rubygem-yast-rake (Old)
 and  /work/SRC/openSUSE:Factory/.rubygem-yast-rake.new.7948 (New)


Package is "rubygem-yast-rake"

Mon Sep 23 13:15:06 2019 rev:30 rq:728968 version:0.2.36

Changes:

--- /work/SRC/openSUSE:Factory/rubygem-yast-rake/rubygem-yast-rake.changes  
2019-07-31 14:21:50.658512263 +0200
+++ 
/work/SRC/openSUSE:Factory/.rubygem-yast-rake.new.7948/rubygem-yast-rake.changes
2019-09-23 13:15:07.457129654 +0200
@@ -1,0 +2,14 @@
+Fri Sep  6 10:44:43 UTC 2019 - Ladislav Slezák 
+
+- Submit the SLE12-SP5 packages to Updates (not to GA) (bsc#1149771)
+- Added the SLE15-SP2 target
+- 0.2.36
+
+---
+Thu Aug 22 10:35:10 CEST 2019 - sch...@suse.de
+
+- Using rb_default_ruby_abi tag in the spec file in order to
+  handle several ruby versions (bsc#1146403).
+- 0.2.35
+
+---

Old:

  yast-rake-0.2.34.gem

New:

  yast-rake-0.2.36.gem



Other differences:
--
++ rubygem-yast-rake.spec ++
--- /var/tmp/diff_new_pack.ERQZgT/_old  2019-09-23 13:15:08.125129535 +0200
+++ /var/tmp/diff_new_pack.ERQZgT/_new  2019-09-23 13:15:08.129129534 +0200
@@ -17,14 +17,14 @@
 
 
 Name:   rubygem-yast-rake
-Version:0.2.34
+Version:0.2.36
 Release:0
 %define mod_name yast-rake
 %define mod_full_name %{mod_name}-%{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  %{rubygem gem2rpm}
 BuildRequires:  %{ruby}
 BuildRequires:  ruby-macros >= 5
+BuildRequires:  rubygem(%{rb_default_ruby_abi}:gem2rpm)
 Url:http://github.org/openSUSE/yast-rake
 Source: http://rubygems.org/gems/%{mod_full_name}.gem
 Summary:Rake tasks providing basic work-flow for Yast development

++ yast-rake-0.2.34.gem -> yast-rake-0.2.36.gem ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/VERSION new/VERSION
--- old/VERSION 2019-06-27 16:55:34.0 +0200
+++ new/VERSION 2019-09-06 13:27:01.0 +0200
@@ -1 +1 @@
-0.2.34
+0.2.36
Binary files old/checksums.yaml.gz and new/checksums.yaml.gz differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/data/targets.yml new/data/targets.yml
--- old/data/targets.yml2019-06-27 16:55:34.0 +0200
+++ new/data/targets.yml2019-09-06 13:27:01.0 +0200
@@ -63,8 +63,8 @@
 :sle12sp5:
   obs_api: "https://api.suse.de/;
   obs_project: "Devel:YaST:SLE-12-SP5"
-  obs_sr_project: "SUSE:SLE-12-SP5:GA"
-  obs_target: "SLE_12_SP5"
+  obs_sr_project: "SUSE:SLE-12-SP5:Update"
+  obs_target: "SUSE_SLE-12-SP5_Update"
 :sle15:
   obs_api: "https://api.suse.de/;
   obs_project: "Devel:YaST:SLE-15"
@@ -75,6 +75,11 @@
   obs_project: "Devel:YaST:SLE-15-SP1"
   obs_sr_project: "SUSE:SLE-15-SP1:Update"
   obs_target: "SUSE_SLE-15-SP1_Update"
+:sle15sp2:
+  obs_api: "https://api.suse.de/;
+  obs_project: "Devel:YaST:SLE-15-SP2"
+  obs_sr_project: "SUSE:SLE-15-SP2:Update"
+  obs_target: "SUSE_SLE-15-SP2_Update"
 :sle_latest:
   obs_api: "https://api.suse.de/;
   obs_project: "Devel:YaST:Head"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/metadata new/metadata
--- old/metadata2019-06-27 16:55:37.0 +0200
+++ new/metadata2019-09-06 13:27:01.0 +0200
@@ -1,14 +1,14 @@
 --- !ruby/object:Gem::Specification
 name: yast-rake
 version: !ruby/object:Gem::Version
-  version: 0.2.34
+  version: 0.2.36
 platform: ruby
 authors:
 - Josef Reidinger
 autorequire: 
 bindir: bin
 cert_chain: []
-date: 2019-06-27 00:00:00.0 Z
+date: 2019-09-06 00:00:00.0 Z
 dependencies:
 - !ruby/object:Gem::Dependency
   name: packaging_rake_tasks
@@ -80,8 +80,7 @@
 - !ruby/object:Gem::Version
   version: '0'
 requirements: []
-rubyforge_project: 
-rubygems_version: 2.7.3
+rubygems_version: 3.0.3
 signing_key: 
 specification_version: 4
 summary: Rake tasks providing basic work-flow for Yast development




commit lvm2 for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package lvm2 for openSUSE:Factory checked in 
at 2019-09-23 13:15:40

Comparing /work/SRC/openSUSE:Factory/lvm2 (Old)
 and  /work/SRC/openSUSE:Factory/.lvm2.new.7948 (New)


Package is "lvm2"

Mon Sep 23 13:15:40 2019 rev:126 rq:730344 version:2.03.05

Changes:

--- /work/SRC/openSUSE:Factory/lvm2/lvm2.changes2019-07-15 
22:42:36.923922250 +0200
+++ /work/SRC/openSUSE:Factory/.lvm2.new.7948/lvm2.changes  2019-09-23 
13:15:46.801122590 +0200
@@ -1,0 +2,46 @@
+Mon Sep  9 12:00:00 UTC 2019 - heming.z...@suse.com
+
+- Update lvm2.spec: make baselibs.conf to a common source.
+
+---
+Mon Sep  9 11:00:25 UTC 2019 - g...@suse.com
+
+- Avoid creation of mixed-blocksize PV on LVM volume groups (bsc#1149408)
+  + bug-1149408_Fix-rounding-writes-up-to-sector-size.patch
+  + bug-1149408_vgcreate-vgextend-restrict-PVs-with-mixed-block-size.patch
+- Update lvm.conf files
+  - add devices/allow_mixed_block_sizes item
+
+---
+Mon Sep 02 11:21:03 UTC 2019 - heming.z...@suse.com
+
+- Update to LVM2.2.03.05
+  - To drop lvm2-clvm and lvm2-cmirrord rpms (jsc#PM-1324)
+  - Fix Out of date package (bsc#734)
+  - Fix occasional slow shutdowns with kernel 5.0.0 and up (bsc#1137648)
+  - Remove clvmd
+  - Remove lvmlib (api)
+  - Remove lvmetad
+- Drop patches that have been merged into upstream
+  - bug-1114113_metadata-prevent-writing-beyond-metadata-area.patch
+  - bug-1137296_pvremove-vgextend-fix-using-device-aliases-with-lvmetad.patch
+  - bug-1135984_cache-support-no_discard_passdown.patch
+- Drop patches that have been nonexist/unsupport in upstream
+  - bsc1080299-detect-clvm-properly.patch
+  - bug-998893_make_pvscan_service_after_multipathd.patch
+  - bug-978055_clvmd-try-to-refresh-device-cache-on-the-first-failu.patch
+  - bug-950089_test-fix-lvm2-testsuite-build-error.patch
+  - bug-1072624_test-lvmetad_dump-always-timed-out-when-using-nc.patch
+  - tests-specify-python3-as-the-script-interpreter.patch
+- Update spec files
+  - merge device-mapper, lvm2-lockd, lvm2 into one spec file
+  - clvmd/lvmlib (api)/lvmetad had been removed, so delete related context in 
spec file
+- Update lvm.conf files
+  - remove all lvmetad lines/keywords
+  - add event_activation
+  - remove fallback_to_lvm1 & related items
+  - remove 
locking_type/fallback_to_clustered_locking/fallback_to_local_locking items
+  - remove locking_library item
+  - remove all special filter rules
+
+---

Old:

  LVM2.2.02.180.tgz
  LVM2.2.02.180.tgz.asc
  bsc1080299-detect-clvm-properly.patch
  bug-1072624_test-lvmetad_dump-always-timed-out-when-using-nc.patch
  bug-1114113_metadata-prevent-writing-beyond-metadata-area.patch
  bug-1135984_cache-support-no_discard_passdown.patch
  bug-1137296_pvremove-vgextend-fix-using-device-aliases-with-lvmetad.patch
  bug-950089_test-fix-lvm2-testsuite-build-error.patch
  bug-978055_clvmd-try-to-refresh-device-cache-on-the-first-failu.patch
  bug-998893_make_pvscan_service_after_multipathd.patch
  device-mapper.changes
  device-mapper.spec
  lvm2-clvm.changes
  lvm2-clvm.spec
  pre_checkin.sh
  tests-specify-python3-as-the-script-interpreter.patch

New:

  LVM2.2.03.05.tgz
  LVM2.2.03.05.tgz.asc
  _multibuild
  bug-1149408_Fix-rounding-writes-up-to-sector-size.patch
  bug-1149408_vgcreate-vgextend-restrict-PVs-with-mixed-block-size.patch



Other differences:
--
++ lvm2.spec ++
 744 lines (skipped)
 between /work/SRC/openSUSE:Factory/lvm2/lvm2.spec
 and /work/SRC/openSUSE:Factory/.lvm2.new.7948/lvm2.spec

++ LVM2.2.02.180.tgz -> LVM2.2.03.05.tgz ++
 143808 lines of diff (skipped)

++ _multibuild ++

  devicemapper
  lockd

++ bug-1149408_Fix-rounding-writes-up-to-sector-size.patch ++
>From 7f347698e3d09b15b4f9aed9c61239fda7b9e8c8 Mon Sep 17 00:00:00 2001
From: David Teigland 
Date: Fri, 26 Jul 2019 14:21:08 -0500
Subject: [PATCH] Fix rounding writes up to sector size

Do this at two levels, although one would be enough to
fix the problem seen recently:

- Ignore any reported sector size other than 512 of 4096.
  If either sector size (physical or logical) is reported
  as 512, then use 512.  If neither are reported as 512,
  and one or the other is reported as 4096, then use 4096.
  If neither is reported as either 512 or 4096, then use 512.

- When rounding up a limited write in bcache to be a multiple
  of the sector size, check that the resulting write size is
  not larger than the bcache block itself.  (This shouldn't
  happen if the sector size is 512 or 4096.)

commit yast2-schema for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-schema for openSUSE:Factory 
checked in at 2019-09-23 13:15:35

Comparing /work/SRC/openSUSE:Factory/yast2-schema (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-schema.new.7948 (New)


Package is "yast2-schema"

Mon Sep 23 13:15:35 2019 rev:51 rq:730317 version:4.2.3

Changes:

--- /work/SRC/openSUSE:Factory/yast2-schema/yast2-schema.changes
2019-09-11 10:15:57.471543786 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-schema.new.7948/yast2-schema.changes  
2019-09-23 13:15:36.729124399 +0200
@@ -1,0 +2,7 @@
+Thu Sep 12 10:08:49 CEST 2019 - sch...@suse.de
+
+- Ignoring X-SuSE-YaST-AutoInstResourceAliases entries in desktop
+  files while evaluating resources (bsc#1144894).
+- 4.2.3
+
+---

Old:

  yast2-schema-4.2.2.tar.bz2

New:

  yast2-schema-4.2.3.tar.bz2



Other differences:
--
++ yast2-schema.spec ++
--- /var/tmp/diff_new_pack.Ftird4/_old  2019-09-23 13:15:37.229124309 +0200
+++ /var/tmp/diff_new_pack.Ftird4/_new  2019-09-23 13:15:37.233124308 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-schema
-Version:4.2.2
+Version:4.2.3
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-schema-4.2.2.tar.bz2 -> yast2-schema-4.2.3.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-schema-4.2.2/package/yast2-schema.changes 
new/yast2-schema-4.2.3/package/yast2-schema.changes
--- old/yast2-schema-4.2.2/package/yast2-schema.changes 2019-08-28 
13:30:53.0 +0200
+++ new/yast2-schema-4.2.3/package/yast2-schema.changes 2019-09-12 
10:29:55.0 +0200
@@ -1,4 +1,11 @@
 ---
+Thu Sep 12 10:08:49 CEST 2019 - sch...@suse.de
+
+- Ignoring X-SuSE-YaST-AutoInstResourceAliases entries in desktop
+  files while evaluating resources (bsc#1144894).
+- 4.2.3
+
+---
 Tue Aug 27 19:07:49 CEST 2019 - sch...@suse.de
 
 - Report warning if X_SuSE_YaST_AutoInstResource has not been set
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-schema-4.2.2/package/yast2-schema.spec 
new/yast2-schema-4.2.3/package/yast2-schema.spec
--- old/yast2-schema-4.2.2/package/yast2-schema.spec2019-08-28 
13:30:53.0 +0200
+++ new/yast2-schema-4.2.3/package/yast2-schema.spec2019-09-12 
10:29:55.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-schema
-Version:4.2.2
+Version:4.2.3
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-schema-4.2.2/scripts/collect.sh 
new/yast2-schema-4.2.3/scripts/collect.sh
--- old/yast2-schema-4.2.2/scripts/collect.sh   2019-08-28 13:30:53.0 
+0200
+++ new/yast2-schema-4.2.3/scripts/collect.sh   2019-09-12 10:29:55.0 
+0200
@@ -34,7 +34,7 @@
 
 X_SuSE_YaST_AutoInstSchema=`grep "^X-SuSE-YaST-AutoInstSchema" $desktop`
 X_SuSE_YaST_AutoInstSchema=${X_SuSE_YaST_AutoInstSchema##*=}
-X_SuSE_YaST_AutoInstResource=`grep "^X-SuSE-YaST-AutoInstResource" 
$desktop`
+X_SuSE_YaST_AutoInstResource=`grep "^X-SuSE-YaST-AutoInstResource=" 
$desktop` # do not take AutoInstResourceAliases
 X_SuSE_YaST_AutoInstResource=${X_SuSE_YaST_AutoInstResource##*=}
 X_SuSE_YaST_AutoInstPath=`grep "^X-SuSE-YaST-AutoInstPath" $desktop`
 X_SuSE_YaST_AutoInstPath=${X_SuSE_YaST_AutoInstPath##*=}




commit libyui-ncurses-pkg for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package libyui-ncurses-pkg for 
openSUSE:Factory checked in at 2019-09-23 13:15:11

Comparing /work/SRC/openSUSE:Factory/libyui-ncurses-pkg (Old)
 and  /work/SRC/openSUSE:Factory/.libyui-ncurses-pkg.new.7948 (New)


Package is "libyui-ncurses-pkg"

Mon Sep 23 13:15:11 2019 rev:37 rq:728988 version:2.49.1

Changes:

--- /work/SRC/openSUSE:Factory/libyui-ncurses-pkg/libyui-ncurses-pkg.changes
2019-06-28 16:34:29.682654557 +0200
+++ 
/work/SRC/openSUSE:Factory/.libyui-ncurses-pkg.new.7948/libyui-ncurses-pkg.changes
  2019-09-23 13:15:12.865128684 +0200
@@ -1,0 +2,8 @@
+Thu Sep  5 15:39:32 UTC 2019 - Ladislav Slezák 
+
+- Added a new generic dependency to force upgrade from all previous
+  versions (e.g. from libyui-ncurses-pkg9 to libyui-ncurses-pkg10)
+  (bsc#1148622)
+- 2.49.1
+
+---

Old:

  libyui-ncurses-pkg-2.49.0.tar.bz2

New:

  libyui-ncurses-pkg-2.49.1.tar.bz2



Other differences:
--
++ libyui-ncurses-pkg-doc.spec ++
--- /var/tmp/diff_new_pack.XjWSTI/_old  2019-09-23 13:15:13.497128570 +0200
+++ /var/tmp/diff_new_pack.XjWSTI/_new  2019-09-23 13:15:13.501128569 +0200
@@ -20,7 +20,7 @@
 %define so_version 10
 
 Name:   %{parent}-doc
-Version:2.49.0
+Version:2.49.1
 Release:0
 Source: %{parent}-%{version}.tar.bz2
 

++ libyui-ncurses-pkg.spec ++
--- /var/tmp/diff_new_pack.XjWSTI/_old  2019-09-23 13:15:13.525128565 +0200
+++ /var/tmp/diff_new_pack.XjWSTI/_new  2019-09-23 13:15:13.525128565 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   libyui-ncurses-pkg
-Version:2.49.0
+Version:2.49.1
 Release:0
 Source: %{name}-%{version}.tar.bz2
 
@@ -57,6 +57,10 @@
 Provides:   yast2-ncurses-pkg = 2.42.0
 Obsoletes:  yast2-ncurses-pkg < 2.42.0
 
+# force removal of all previous library versions (bsc#1148622),
+# expands to: libyui-ncurses-pkg1 libyui-ncurses-pkg2 ... 
libyui-ncurses-pkg{so_version - 1}
+Obsoletes:  %(echo `seq -s " " -f "libyui-ncurses-pkg%.f" $(expr 
%{so_version} - 1)`)
+
 Provides:   libyui_pkg
 Supplements:packageand(libyui-ncurses:yast2-packager)
 

++ libyui-ncurses-pkg-2.49.0.tar.bz2 -> libyui-ncurses-pkg-2.49.1.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-ncurses-pkg-2.49.0/VERSION.cmake 
new/libyui-ncurses-pkg-2.49.1/VERSION.cmake
--- old/libyui-ncurses-pkg-2.49.0/VERSION.cmake 2019-04-17 15:42:59.0 
+0200
+++ new/libyui-ncurses-pkg-2.49.1/VERSION.cmake 2019-09-06 15:55:18.0 
+0200
@@ -1,6 +1,6 @@
 SET( VERSION_MAJOR "2" )
 SET( VERSION_MINOR "49" )
-SET( VERSION_PATCH "0" )
+SET( VERSION_PATCH "1" )
 SET( VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}" )
 
 # This is need for the libyui core, ONLY.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/libyui-ncurses-pkg-2.49.0/package/libyui-ncurses-pkg-doc.spec 
new/libyui-ncurses-pkg-2.49.1/package/libyui-ncurses-pkg-doc.spec
--- old/libyui-ncurses-pkg-2.49.0/package/libyui-ncurses-pkg-doc.spec   
2019-04-17 15:42:59.0 +0200
+++ new/libyui-ncurses-pkg-2.49.1/package/libyui-ncurses-pkg-doc.spec   
2019-09-06 15:55:18.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libyui-ncurses-pkg-doc
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,7 +19,7 @@
 %define so_version 10
 
 Name:   %{parent}-doc
-Version:2.49.0
+Version:2.49.1
 Release:0
 Source: %{parent}-%{version}.tar.bz2
 
@@ -35,7 +35,7 @@
 
 Url:http://github.com/libyui/
 Summary:Libyui-ncurses-pkg documentation
-License:LGPL-2.1 or LGPL-3.0
+License:LGPL-2.1-only OR LGPL-3.0-only
 Group:  Documentation/HTML
 
 %description
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/libyui-ncurses-pkg-2.49.0/package/libyui-ncurses-pkg.changes 
new/libyui-ncurses-pkg-2.49.1/package/libyui-ncurses-pkg.changes
--- old/libyui-ncurses-pkg-2.49.0/package/libyui-ncurses-pkg.changes
2019-04-17 15:42:59.0 +0200
+++ new/libyui-ncurses-pkg-2.49.1/package/libyui-ncurses-pkg.changes
2019-09-06 15:55:18.0 +0200
@@ -1,4 +1,12 @@
 ---
+Thu Sep  5 15:39:32 UTC 2019 - Ladislav Slezák 
+
+- Added a new generic dependency to force 

commit yast2-network for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-network for openSUSE:Factory 
checked in at 2019-09-23 13:15:49

Comparing /work/SRC/openSUSE:Factory/yast2-network (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-network.new.7948 (New)


Package is "yast2-network"

Mon Sep 23 13:15:49 2019 rev:409 rq:730364 version:4.2.12

Changes:

--- /work/SRC/openSUSE:Factory/yast2-network/yast2-network.changes  
2019-07-31 14:26:52.494245841 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-network.new.7948/yast2-network.changes
2019-09-23 13:15:50.449121935 +0200
@@ -1,0 +2,12 @@
+Tue Sep 10 07:40:04 UTC 2019 - Michal Filka 
+
+- bnc#1149234
+  - apply udev rule from AY profile according to device's mac
+value when permanent_mac is missing in list of the device's
+options
+- bsc#1133442
+  - Increased the DHCP timeout when NetworkManager is in use to
+its default (45 seconds).
+- 4.2.12
+
+---

Old:

  yast2-network-4.2.11.tar.bz2

New:

  yast2-network-4.2.12.tar.bz2



Other differences:
--
++ yast2-network.spec ++
--- /var/tmp/diff_new_pack.6EZJ9K/_old  2019-09-23 13:15:50.865121861 +0200
+++ /var/tmp/diff_new_pack.6EZJ9K/_new  2019-09-23 13:15:50.865121861 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-network
-Version:4.2.11
+Version:4.2.12
 Release:0
 Summary:YaST2 - Network Configuration
 License:GPL-2.0-only

++ yast2-network-4.2.11.tar.bz2 -> yast2-network-4.2.12.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-network-4.2.11/package/yast2-network.changes 
new/yast2-network-4.2.12/package/yast2-network.changes
--- old/yast2-network-4.2.11/package/yast2-network.changes  2019-07-31 
10:03:50.0 +0200
+++ new/yast2-network-4.2.12/package/yast2-network.changes  2019-09-12 
12:39:31.0 +0200
@@ -1,4 +1,16 @@
 ---
+Tue Sep 10 07:40:04 UTC 2019 - Michal Filka 
+
+- bnc#1149234
+  - apply udev rule from AY profile according to device's mac
+value when permanent_mac is missing in list of the device's
+options
+- bsc#1133442
+  - Increased the DHCP timeout when NetworkManager is in use to
+its default (45 seconds).
+- 4.2.12
+
+---
 Tue Jul 30 11:14:04 UTC 2019 - Dominique Leuenberger 
 
 - Requires hostname: there are many places where the module calls
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-network-4.2.11/package/yast2-network.spec 
new/yast2-network-4.2.12/package/yast2-network.spec
--- old/yast2-network-4.2.11/package/yast2-network.spec 2019-07-31 
10:03:50.0 +0200
+++ new/yast2-network-4.2.12/package/yast2-network.spec 2019-09-12 
12:39:31.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-network
-Version:4.2.11
+Version:4.2.12
 Release:0
 Summary:YaST2 - Network Configuration
 License:GPL-2.0-only
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-network-4.2.11/src/lib/network/edit_nic_name.rb 
new/yast2-network-4.2.12/src/lib/network/edit_nic_name.rb
--- old/yast2-network-4.2.11/src/lib/network/edit_nic_name.rb   2019-07-31 
10:03:50.0 +0200
+++ new/yast2-network-4.2.12/src/lib/network/edit_nic_name.rb   2019-09-12 
12:39:31.0 +0200
@@ -40,7 +40,7 @@
   end
 
   if current_item["hwinfo"]
-@mac = current_item["hwinfo"]["permanent_mac"]
+@mac = LanItems.item_mac(LanItems.current)
 @bus_id = current_item["hwinfo"]["busid"]
   else
 @mac = ""
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-network-4.2.11/src/lib/network/network_autoyast.rb 
new/yast2-network-4.2.12/src/lib/network/network_autoyast.rb
--- old/yast2-network-4.2.11/src/lib/network/network_autoyast.rb
2019-07-31 10:03:50.0 +0200
+++ new/yast2-network-4.2.12/src/lib/network/network_autoyast.rb
2019-09-12 12:39:31.0 +0200
@@ -339,6 +339,8 @@
   # Match also parent busid if exist (bsc#1129012)
   parent_busid = i["hwinfo"]["parent_busid"] || busid
   mac = i["hwinfo"]["permanent_mac"]
+  # use mac if permanent_mac is missing (bsc#1149234)
+  mac = i["hwinfo"]["mac"] if mac.nil? || mac.empty?
 
   [busid, parent_busid, mac].any? { |v| v.casecmp(key).zero? }
 end
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit libyui-qt-pkg for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package libyui-qt-pkg for openSUSE:Factory 
checked in at 2019-09-23 13:15:18

Comparing /work/SRC/openSUSE:Factory/libyui-qt-pkg (Old)
 and  /work/SRC/openSUSE:Factory/.libyui-qt-pkg.new.7948 (New)


Package is "libyui-qt-pkg"

Mon Sep 23 13:15:18 2019 rev:47 rq:728989 version:2.46.7

Changes:

--- /work/SRC/openSUSE:Factory/libyui-qt-pkg/libyui-qt-pkg.changes  
2019-06-28 16:27:22.602010244 +0200
+++ /work/SRC/openSUSE:Factory/.libyui-qt-pkg.new.7948/libyui-qt-pkg.changes
2019-09-23 13:15:19.705127455 +0200
@@ -1,0 +2,8 @@
+Fri Sep  6 07:36:04 UTC 2019 - Ladislav Slezák 
+
+- Added a new generic dependency to force upgrade from all previous
+  versions (e.g. from libyui-qt-pkg9 to libyui-qt-pkg10)
+  (bsc#1148622)
+- 2.46.7
+
+---

Old:

  libyui-qt-pkg-2.46.6.tar.bz2

New:

  libyui-qt-pkg-2.46.7.tar.bz2



Other differences:
--
++ libyui-qt-pkg-doc.spec ++
--- /var/tmp/diff_new_pack.ZGuqaP/_old  2019-09-23 13:15:20.185127369 +0200
+++ /var/tmp/diff_new_pack.ZGuqaP/_new  2019-09-23 13:15:20.185127369 +0200
@@ -20,7 +20,7 @@
 %define so_version 10
 
 Name:   %{parent}-doc
-Version:2.46.6
+Version:2.46.7
 Release:0
 Source: %{parent}-%{version}.tar.bz2
 

++ libyui-qt-pkg.spec ++
--- /var/tmp/diff_new_pack.ZGuqaP/_old  2019-09-23 13:15:20.209127365 +0200
+++ /var/tmp/diff_new_pack.ZGuqaP/_new  2019-09-23 13:15:20.213127364 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   libyui-qt-pkg
-Version:2.46.6
+Version:2.46.7
 Release:0
 Source: %{name}-%{version}.tar.bz2
 
@@ -63,6 +63,10 @@
 Provides:   yast2-qt-pkg = 2.42.0
 Obsoletes:  yast2-qt-pkg < 2.42.0
 
+# force removal of all previous library versions (bsc#1148622),
+# expands to: libyui-qt-pkg1 libyui-qt-pkg2 ... libyui-qt-pkg{so_version - 1}
+Obsoletes:  %(echo `seq -s " " -f "libyui-qt-pkg%.f" $(expr %{so_version} 
- 1)`)
+
 Provides:   libyui_pkg
 Supplements:packageand(libyui-qt:yast2-packager)
 # control center gnome requires graphical pkg and gtk is dropped (bnc#999031)

++ libyui-qt-pkg-2.46.6.tar.bz2 -> libyui-qt-pkg-2.46.7.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-qt-pkg-2.46.6/VERSION.cmake 
new/libyui-qt-pkg-2.46.7/VERSION.cmake
--- old/libyui-qt-pkg-2.46.6/VERSION.cmake  2019-06-19 12:48:47.0 
+0200
+++ new/libyui-qt-pkg-2.46.7/VERSION.cmake  2019-09-06 15:55:34.0 
+0200
@@ -1,6 +1,6 @@
 SET( VERSION_MAJOR "2" )
 SET( VERSION_MINOR "46" )
-SET( VERSION_PATCH "6" )
+SET( VERSION_PATCH "7" )
 SET( VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}" )
 
 # This is need for the libyui core, ONLY.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-qt-pkg-2.46.6/package/libyui-qt-pkg-doc.spec 
new/libyui-qt-pkg-2.46.7/package/libyui-qt-pkg-doc.spec
--- old/libyui-qt-pkg-2.46.6/package/libyui-qt-pkg-doc.spec 2019-06-19 
12:48:47.0 +0200
+++ new/libyui-qt-pkg-2.46.7/package/libyui-qt-pkg-doc.spec 2019-09-06 
15:55:34.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libyui-qt-pkg-doc
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,7 +20,7 @@
 %define so_version 10
 
 Name:   %{parent}-doc
-Version:2.46.6
+Version:2.46.7
 Release:0
 Source: %{parent}-%{version}.tar.bz2
 
@@ -36,7 +36,7 @@
 
 Url:http://github.com/libyui/
 Summary:Libyui-qt-pkg documentation
-License:LGPL-2.1 or LGPL-3.0
+License:LGPL-2.1-only OR LGPL-3.0-only
 Group:  Documentation/HTML
 
 %description
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libyui-qt-pkg-2.46.6/package/libyui-qt-pkg.changes 
new/libyui-qt-pkg-2.46.7/package/libyui-qt-pkg.changes
--- old/libyui-qt-pkg-2.46.6/package/libyui-qt-pkg.changes  2019-06-19 
12:48:47.0 +0200
+++ new/libyui-qt-pkg-2.46.7/package/libyui-qt-pkg.changes  2019-09-06 
15:55:34.0 +0200
@@ -1,4 +1,12 @@
 ---
+Fri Sep  6 07:36:04 UTC 2019 - Ladislav Slezák 
+
+- Added a new generic dependency to force upgrade from all previous
+  versions (e.g. from libyui-qt-pkg9 to libyui-qt-pkg10)
+  (bsc#1148622)
+- 2.46.7
+

commit yast2-services-manager for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-services-manager for 
openSUSE:Factory checked in at 2019-09-23 13:15:24

Comparing /work/SRC/openSUSE:Factory/yast2-services-manager (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-services-manager.new.7948 (New)


Package is "yast2-services-manager"

Mon Sep 23 13:15:24 2019 rev:51 rq:729370 version:4.2.5

Changes:

--- 
/work/SRC/openSUSE:Factory/yast2-services-manager/yast2-services-manager.changes
2019-08-30 14:39:18.805441235 +0200
+++ 
/work/SRC/openSUSE:Factory/.yast2-services-manager.new.7948/yast2-services-manager.changes
  2019-09-23 13:15:25.605126396 +0200
@@ -1,0 +2,7 @@
+Fri Sep  6 14:28:55 CEST 2019 - sch...@suse.de
+
+- Set BaseTargets::GRAPHICAL and Target::GRAPHICAL if package "xdm"
+  will be installed (instead of xorg-x11-server) (bsc#1140735).
+- 4.2.5
+
+---

Old:

  yast2-services-manager-4.2.4.tar.bz2

New:

  yast2-services-manager-4.2.5.tar.bz2



Other differences:
--
++ yast2-services-manager.spec ++
--- /var/tmp/diff_new_pack.TeiBf1/_old  2019-09-23 13:15:26.213126287 +0200
+++ /var/tmp/diff_new_pack.TeiBf1/_new  2019-09-23 13:15:26.237126283 +0200
@@ -24,7 +24,7 @@
 ##
 
 Name:   yast2-services-manager
-Version:4.2.4
+Version:4.2.5
 Release:0
 Summary:YaST2 - Services Manager
 License:GPL-2.0-or-later

++ yast2-services-manager-4.2.4.tar.bz2 -> 
yast2-services-manager-4.2.5.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-services-manager-4.2.4/package/yast2-services-manager.changes 
new/yast2-services-manager-4.2.5/package/yast2-services-manager.changes
--- old/yast2-services-manager-4.2.4/package/yast2-services-manager.changes 
2019-08-27 19:47:38.0 +0200
+++ new/yast2-services-manager-4.2.5/package/yast2-services-manager.changes 
2019-09-09 11:07:40.0 +0200
@@ -1,4 +1,11 @@
 ---
+Fri Sep  6 14:28:55 CEST 2019 - sch...@suse.de
+
+- Set BaseTargets::GRAPHICAL and Target::GRAPHICAL if package "xdm"
+  will be installed (instead of xorg-x11-server) (bsc#1140735).
+- 4.2.5
+
+---
 Tue Aug 27 18:33:52 CEST 2019 - sch...@suse.de
 
 - Set X-SuSE-YaST-AutoInstResource in desktop file (bsc#144894).
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-services-manager-4.2.4/package/yast2-services-manager.spec 
new/yast2-services-manager-4.2.5/package/yast2-services-manager.spec
--- old/yast2-services-manager-4.2.4/package/yast2-services-manager.spec
2019-08-27 19:47:38.0 +0200
+++ new/yast2-services-manager-4.2.5/package/yast2-services-manager.spec
2019-09-09 11:07:40.0 +0200
@@ -24,7 +24,7 @@
 ##
 
 Name:   yast2-services-manager
-Version:4.2.4
+Version:4.2.5
 Release:0
 Summary:YaST2 - Services Manager
 Group:  System/YaST
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-services-manager-4.2.4/src/lib/services-manager/clients/default_target_proposal.rb
 
new/yast2-services-manager-4.2.5/src/lib/services-manager/clients/default_target_proposal.rb
--- 
old/yast2-services-manager-4.2.4/src/lib/services-manager/clients/default_target_proposal.rb
2019-08-27 19:47:38.0 +0200
+++ 
new/yast2-services-manager-4.2.5/src/lib/services-manager/clients/default_target_proposal.rb
2019-09-09 11:07:40.0 +0200
@@ -234,7 +234,7 @@
 
   def detect_target
 self.default_target =
-  if Arch.x11_setup_needed && Pkg.IsSelected("xorg-x11-server")
+  if Arch.x11_setup_needed && Pkg.IsSelected("xdm")
 give_reason _("X11 packages have been selected for installation")
 Target::GRAPHICAL
   elsif Mode.live_installation
@@ -257,7 +257,7 @@
   elsif Linuxrc.usessh
 give_reason _("SSH installation mode assumes no GUI on the target 
system")
 Target::MULTIUSER
-  elsif !(Arch.x11_setup_needed && Pkg.IsSelected("xorg-x11-server"))
+  elsif !(Arch.x11_setup_needed && Pkg.IsSelected("xdm"))
 give_reason _("X11 packages have not been selected for 
installation")
 Target::MULTIUSER
   else
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 

commit libstorage-ng for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package libstorage-ng for openSUSE:Factory 
checked in at 2019-09-23 13:15:29

Comparing /work/SRC/openSUSE:Factory/libstorage-ng (Old)
 and  /work/SRC/openSUSE:Factory/.libstorage-ng.new.7948 (New)


Package is "libstorage-ng"

Mon Sep 23 13:15:29 2019 rev:63 rq:729926 version:4.2.11

Changes:

--- /work/SRC/openSUSE:Factory/libstorage-ng/libstorage-ng.changes  
2019-08-28 16:02:47.370788709 +0200
+++ /work/SRC/openSUSE:Factory/.libstorage-ng.new.7948/libstorage-ng.changes
2019-09-23 13:15:30.869125451 +0200
@@ -1,0 +2,84 @@
+Tue Sep 10 12:04:57 UTC 2019 - opensuse-packag...@opensuse.org
+
+- Translated using Weblate (Catalan) (bsc#1149754)
+- 4.2.11
+
+
+Mon Sep 9 09:44:22 UTC 2019 - aschn...@suse.com
+
+- merge gh#openSUSE/libstorage-ng#671
+- added integration test
+- 4.2.10
+
+
+Fri Sep 6 10:09:55 UTC 2019 - aschn...@suse.com
+
+- merge gh#openSUSE/libstorage-ng#670
+- added notes
+- 4.2.9
+
+
+Thu Sep 5 07:35:12 UTC 2019 - aschn...@suse.com
+
+- merge gh#openSUSE/libstorage-ng#668
+- removed unneeded code
+- cleanup integration tests
+- code cleanup
+- 4.2.8
+
+
+Wed Sep 4 22:22:17 UTC 2019 - opensuse-packag...@opensuse.org
+
+- Translated using Weblate (Japanese)
+- 4.2.7
+
+
+Wed Sep 4 13:37:54 UTC 2019 - opensuse-packag...@opensuse.org
+
+- Translated using Weblate (Slovak)
+- 4.2.6
+
+
+Wed Sep 4 13:37:53 UTC 2019 - opensuse-packag...@opensuse.org
+
+- Translated using Weblate (Portuguese (Brazil))
+
+
+Wed Sep 4 13:08:37 UTC 2019 - fr...@opensuse.org
+
+- Translated using Weblate (Dutch)
+
+
+Wed Sep 4 12:32:35 UTC 2019 - opensuse-packag...@opensuse.org
+
+- Translated using Weblate (Czech)
+
+
+Wed Sep 4 12:23:45 UTC 2019 - aschn...@suse.com
+
+- merge gh#openSUSE/libstorage-ng#667
+- update pot and po files
+- 4.2.5
+
+
+Wed Sep 4 10:42:29 UTC 2019 - aschn...@suse.com
+
+- merge gh#openSUSE/libstorage-ng#666
+- added note
+- use dev_t to save major and minor numbers
+- improved unit test
+- coding style
+- consistent function name
+- added support for plain encryption (bsc#1088641)
+- added unit test
+- added integration tests
+- 4.2.4
+
+
+Mon Sep 2 13:05:38 UTC 2019 - aschn...@suse.com
+
+- merge gh#openSUSE/libstorage-ng#665
+- extended documentation
+- 4.2.3
+
+

Old:

  libstorage-ng-4.2.2.tar.xz

New:

  libstorage-ng-4.2.11.tar.xz



Other differences:
--
++ libstorage-ng.spec ++
--- /var/tmp/diff_new_pack.naTSJV/_old  2019-09-23 13:15:31.541125330 +0200
+++ /var/tmp/diff_new_pack.naTSJV/_new  2019-09-23 13:15:31.553125328 +0200
@@ -18,7 +18,7 @@
 
 %define libname %{name}1
 Name:   libstorage-ng
-Version:4.2.2
+Version:4.2.11
 Release:0
 Summary:Library for storage management
 License:GPL-2.0-only

++ libstorage-ng-4.2.2.tar.xz -> libstorage-ng-4.2.11.tar.xz ++
 7142 lines of diff (skipped)




commit installation-images for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package installation-images for 
openSUSE:Factory checked in at 2019-09-23 13:15:00

Comparing /work/SRC/openSUSE:Factory/installation-images (Old)
 and  /work/SRC/openSUSE:Factory/.installation-images.new.7948 (New)


Package is "installation-images"

Mon Sep 23 13:15:00 2019 rev:76 rq:728789 version:14.435

Changes:

--- /work/SRC/openSUSE:Factory/installation-images/installation-images.changes  
2019-09-04 09:03:28.783037086 +0200
+++ 
/work/SRC/openSUSE:Factory/.installation-images.new.7948/installation-images.changes
2019-09-23 13:15:00.881130835 +0200
@@ -1,0 +2,6 @@
+Fri Sep 6 08:40:01 UTC 2019 - wfe...@opensuse.org
+
+- fix sshd location so that it works with fips enabled (bsc#1140169)
+- 14.435
+
+

Old:

  installation-images-14.434.tar.xz

New:

  installation-images-14.435.tar.xz



Other differences:
--
++ installation-images.spec ++
--- /var/tmp/diff_new_pack.zCRIGE/_old  2019-09-23 13:15:01.365130748 +0200
+++ /var/tmp/diff_new_pack.zCRIGE/_new  2019-09-23 13:15:01.369130748 +0200
@@ -599,7 +599,7 @@
 Summary:Installation Image Files for %theme
 License:GPL-2.0+
 Group:  Metapackages
-Version:14.434
+Version:14.435
 Release:0
 Provides:   installation-images = %version-%release
 Conflicts:  otherproviders(installation-images)

++ installation-images-14.434.tar.xz -> installation-images-14.435.tar.xz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/installation-images-14.434/VERSION 
new/installation-images-14.435/VERSION
--- old/installation-images-14.434/VERSION  2019-08-30 15:41:05.0 
+0200
+++ new/installation-images-14.435/VERSION  2019-09-06 10:40:01.0 
+0200
@@ -1 +1 @@
-14.434
+14.435
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/installation-images-14.434/changelog 
new/installation-images-14.435/changelog
--- old/installation-images-14.434/changelog2019-08-30 15:41:05.0 
+0200
+++ new/installation-images-14.435/changelog2019-09-06 10:40:01.0 
+0200
@@ -1,3 +1,6 @@
+2019-09-06:14.435
+   - fix sshd location so that it works with fips enabled (bsc#1140169)
+
 2019-08-30:14.434
- merge gh#openSUSE/installation-images#329
- handle compressed modules
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/installation-images-14.434/data/initrd/initrd.file_list 
new/installation-images-14.435/data/initrd/initrd.file_list
--- old/installation-images-14.434/data/initrd/initrd.file_list 2019-08-30 
15:41:05.0 +0200
+++ new/installation-images-14.435/data/initrd/initrd.file_list 2019-09-06 
10:40:01.0 +0200
@@ -438,9 +438,6 @@
 
 ?libopenssl*_*-hmac:
 
-?openssh-fips:
-?openssh-hmac:
-
 openssh: nodeps
   E prein
   d etc/ssh
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/installation-images-14.434/data/rescue/rescue.file_list 
new/installation-images-14.435/data/rescue/rescue.file_list
--- old/installation-images-14.434/data/rescue/rescue.file_list 2019-08-30 
15:41:05.0 +0200
+++ new/installation-images-14.435/data/rescue/rescue.file_list 2019-09-06 
10:40:01.0 +0200
@@ -325,6 +325,8 @@
 multipath-tools:
 nfs-client:
 
+?openssh-fips:
+
 openssh:
   /
   d /etc/sysconfig
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/installation-images-14.434/data/root/root.file_list 
new/installation-images-14.435/data/root/root.file_list
--- old/installation-images-14.434/data/root/root.file_list 2019-08-30 
15:41:05.0 +0200
+++ new/installation-images-14.435/data/root/root.file_list 2019-09-06 
10:40:01.0 +0200
@@ -631,6 +631,8 @@
   yast2-storage: ignore
 endif
 
+?openssh-fips:
+
 openssh:
   /
   t /etc/sysconfig/ssh




commit yast2-security for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package yast2-security for openSUSE:Factory 
checked in at 2019-09-23 13:14:51

Comparing /work/SRC/openSUSE:Factory/yast2-security (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-security.new.7948 (New)


Package is "yast2-security"

Mon Sep 23 13:14:51 2019 rev:84 rq:728474 version:4.2.2

Changes:

--- /work/SRC/openSUSE:Factory/yast2-security/yast2-security.changes
2019-08-27 10:15:53.291961538 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-security.new.7948/yast2-security.changes  
2019-09-23 13:14:52.509132338 +0200
@@ -1,0 +2,7 @@
+Thu Sep  5 10:22:29 CEST 2019 - sch...@suse.de
+
+- AY: Supporting user defined permission files like
+  "/etc/permissions.ultra". (bsc#1147173)
+- 4.2.2
+
+---

Old:

  yast2-security-4.2.1.tar.bz2

New:

  yast2-security-4.2.2.tar.bz2



Other differences:
--
++ yast2-security.spec ++
--- /var/tmp/diff_new_pack.XsRUwb/_old  2019-09-23 13:14:53.745132117 +0200
+++ /var/tmp/diff_new_pack.XsRUwb/_new  2019-09-23 13:14:53.781132110 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-security
-Version:4.2.1
+Version:4.2.2
 Release:0
 Summary:YaST2 - Security Configuration
 License:GPL-2.0-only

++ yast2-security-4.2.1.tar.bz2 -> yast2-security-4.2.2.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-security-4.2.1/package/yast2-security.changes 
new/yast2-security-4.2.2/package/yast2-security.changes
--- old/yast2-security-4.2.1/package/yast2-security.changes 2019-08-22 
17:00:57.0 +0200
+++ new/yast2-security-4.2.2/package/yast2-security.changes 2019-09-05 
13:09:00.0 +0200
@@ -1,4 +1,11 @@
 ---
+Thu Sep  5 10:22:29 CEST 2019 - sch...@suse.de
+
+- AY: Supporting user defined permission files like
+  "/etc/permissions.ultra". (bsc#1147173)
+- 4.2.2
+
+---
 Thu Aug 22 15:52:45 CEST 2019 - sch...@suse.de
 
 - Using rb_default_ruby_abi tag in the spec file in order to
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-security-4.2.1/package/yast2-security.spec 
new/yast2-security-4.2.2/package/yast2-security.spec
--- old/yast2-security-4.2.1/package/yast2-security.spec2019-08-22 
17:00:57.0 +0200
+++ new/yast2-security-4.2.2/package/yast2-security.spec2019-09-05 
13:09:00.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-security
-Version:4.2.1
+Version:4.2.2
 Release:0
 Group:  System/YaST
 License:GPL-2.0-only
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-security-4.2.1/src/modules/Security.rb 
new/yast2-security-4.2.2/src/modules/Security.rb
--- old/yast2-security-4.2.1/src/modules/Security.rb2019-08-22 
17:00:57.0 +0200
+++ new/yast2-security-4.2.2/src/modules/Security.rb2019-09-05 
13:09:00.0 +0200
@@ -395,21 +395,18 @@
 end
 
 def read_permissions
-  perm = case @Settings["PERMISSION_SECURITY"].to_s
-  when /easy/
-"easy"
-  when /paranoid/
-"paranoid"
-  else
-"secure"
-  end
+  # Removing "local" from the string
+  permissions = @Settings["PERMISSION_SECURITY"].to_s.split(" ")
+  @Settings["PERMISSION_SECURITY"] = permissions.delete_if {|p|
+p == "local" }.join(" ")
 
-  @Settings["PERMISSION_SECURITY"] = perm
+  # default value
+  @Settings["PERMISSION_SECURITY"] = "secure" if 
@Settings["PERMISSION_SECURITY"].empty?
 
-  log.debug "PERMISSION SECURITY (after #{__callee__}): " \
+  log.debug "PERMISSION_SECURITY (after #{__callee__}): " \
 "#{@Settings['PERMISSION_SECURITY']}"
 
-  perm
+  @Settings['PERMISSION_SECURITY']
 end
 
 def read_polkit_settings
@@ -672,7 +669,9 @@
   # Write security settings
   return false if Abort()
   Progress.NextStage
-  @Settings["PERMISSION_SECURITY"] << " local"
+  if !@Settings["PERMISSION_SECURITY"].include?("local")
+@Settings["PERMISSION_SECURITY"] << " local"
+  end
   write_to_locations
 
   # Write inittab settings
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-security-4.2.1/test/security_test.rb 
new/yast2-security-4.2.2/test/security_test.rb
--- old/yast2-security-4.2.1/test/security_test.rb  2019-08-22 
17:00:57.0 +0200
+++ 

commit plantuml for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package plantuml for openSUSE:Factory 
checked in at 2019-09-23 12:46:49

Comparing /work/SRC/openSUSE:Factory/plantuml (Old)
 and  /work/SRC/openSUSE:Factory/.plantuml.new.7948 (New)


Package is "plantuml"

Mon Sep 23 12:46:49 2019 rev:3 rq:732615 version:1.2019.11

Changes:

--- /work/SRC/openSUSE:Factory/plantuml/plantuml.changes2019-09-17 
13:39:49.377819767 +0200
+++ /work/SRC/openSUSE:Factory/.plantuml.new.7948/plantuml.changes  
2019-09-23 12:46:53.301516472 +0200
@@ -1,0 +2,6 @@
+Sun Sep 22 19:16:37 UTC 2019 - Martin Hauke 
+
+- Update to version 1.2019.11
+  See http://plantuml.com/de/changes for all changes
+
+---

Old:

  plantuml-1.2019.10.tar.gz

New:

  plantuml-1.2019.11.tar.gz



Other differences:
--
++ plantuml.spec ++
--- /var/tmp/diff_new_pack.2S0fSj/_old  2019-09-23 12:46:53.901516373 +0200
+++ /var/tmp/diff_new_pack.2S0fSj/_new  2019-09-23 12:46:53.901516373 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   plantuml
-Version:1.2019.10
+Version:1.2019.11
 Release:0
 Summary:Java UML Tool
 License:GPL-3.0-or-later

++ plantuml-1.2019.10.tar.gz -> plantuml-1.2019.11.tar.gz ++
 2043 lines of diff (skipped)




commit 000product for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-09-23 12:47:01

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.7948 (New)


Package is "000product"

Mon Sep 23 12:47:01 2019 rev:1617 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi: same change
openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
openSUSE-cd-mini-i586.kiwi: same change
openSUSE-cd-mini-x86_64.kiwi: same change
openSUSE-dvd5-dvd-i586.kiwi: same change
openSUSE-dvd5-dvd-x86_64.kiwi: same change
openSUSE-ftp-ftp-i586_x86_64.kiwi: same change
stub.kiwi: same change
++ openSUSE.product ++
--- /var/tmp/diff_new_pack.U2JlNz/_old  2019-09-23 12:47:05.021513833 +0200
+++ /var/tmp/diff_new_pack.U2JlNz/_new  2019-09-23 12:47:05.025513832 +0200
@@ -4,7 +4,7 @@
 
   openSUSE
   openSUSE
-  20190921
+  20190923
   0
 
   openSUSE




commit coreboot-utils for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package coreboot-utils for openSUSE:Factory 
checked in at 2019-09-23 12:46:44

Comparing /work/SRC/openSUSE:Factory/coreboot-utils (Old)
 and  /work/SRC/openSUSE:Factory/.coreboot-utils.new.7948 (New)


Package is "coreboot-utils"

Mon Sep 23 12:46:44 2019 rev:27 rq:732613 version:4.10

Changes:

--- /work/SRC/openSUSE:Factory/coreboot-utils/coreboot-utils.changes
2018-12-27 00:29:55.951636482 +0100
+++ /work/SRC/openSUSE:Factory/.coreboot-utils.new.7948/coreboot-utils.changes  
2019-09-23 12:46:49.617517078 +0200
@@ -1,0 +2,9 @@
+Sat Sep 21 20:44:50 UTC 2019 - Martin Hauke 
+
+- Update to 4.10
+  * Full changelog:
+https://coreboot.org/releases/coreboot-4.10-relnotes.txt
+- Update coreboot-utils.keyring
+  Old key 0x269C04E1 got superseeded by 0xAA103F48728F5291
+
+---

Old:

  coreboot-4.9.tar.xz
  coreboot-4.9.tar.xz.sig

New:

  coreboot-4.10.tar.xz
  coreboot-4.10.tar.xz.sig



Other differences:
--
++ coreboot-utils.spec ++
--- /var/tmp/diff_new_pack.UJEEby/_old  2019-09-23 12:46:50.669516905 +0200
+++ /var/tmp/diff_new_pack.UJEEby/_new  2019-09-23 12:46:50.673516904 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package coreboot-utils
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,12 +12,12 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   coreboot-utils
-Version:4.9
+Version:4.10
 Release:0
 Summary:A universal flash programming utility
 License:GPL-2.0-only
@@ -25,7 +25,6 @@
 URL:https://coreboot.org/
 Source0:https://www.coreboot.org/releases/coreboot-%{version}.tar.xz
 Source1:
https://www.coreboot.org/releases/coreboot-%{version}.tar.xz.sig
-#http://keyserver.ubuntu.com:11371/pks/lookup?op=get=0x269C04E1#/%%{name}.keyring
 Source3:%{name}.keyring
 Patch1: no-pie.patch
 Patch2: k8resdump.diff

++ coreboot-4.9.tar.xz -> coreboot-4.10.tar.xz ++
/work/SRC/openSUSE:Factory/coreboot-utils/coreboot-4.9.tar.xz 
/work/SRC/openSUSE:Factory/.coreboot-utils.new.7948/coreboot-4.10.tar.xz 
differ: char 27, line 1

++ coreboot-utils.keyring ++
--- /var/tmp/diff_new_pack.UJEEby/_old  2019-09-23 12:46:50.713516897 +0200
+++ /var/tmp/diff_new_pack.UJEEby/_new  2019-09-23 12:46:50.717516897 +0200
@@ -1,486 +1,109 @@
-
-http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd; >
-http://www.w3.org/1999/xhtml;>
-
-Public Key Server -- Get "0x269c04e1 "
-
-
-/**/
-Public Key Server -- Get "0x269c04e1 "
-
 -BEGIN PGP PUBLIC KEY BLOCK-
-Version: SKS 1.1.6
-Comment: Hostname: keyserver.ubuntu.com
 
-mQINBFJ1WyQBEADLaB2N0xwuK2K9QiTtFQgSVWPCQVr0f3EsMVKKSbgD3x+DX4LArt5VEVzo
-BYm2mMgt2Jqn4ffDIR8vvqgQRngf/YRMH1NPfYjq5dYJu9juxE4b1wvf915av1xzNUZaoz1M
-UEYcS6LqvXXTYRle7eDweAWf9CWi/duFqOGMz8nBIOdCbth1CAdH+ZLv7sBabZO1bjN7/Li1
-exd2Chajv+0QtXBCvq6bPsxdXzGF+1hxG1IiDKwV92mfX5qF3yzP6pAbEhYnGEWjfRNPMqCK
-OuXH0ec/urVPHQTQjumrCRlkboOeivHWRBbP9jQ7NEp1rfYvsqfoofFxxyg0AYNQgEKEh4Mf
-w3H2Qiq8mOQ9HXnSlRwNG4QVU2O6qAyjnZomEhZkzWMsNzQOQZESbW7o5jL2TU/er3RbPOs4
-ztmNvfG3DgoM+XP+8ziAnm2cnwAHTkfzOmLZ2h66eMDLlXqNlxcfpmFXm4JTHx1mI2a4pXCm
-R/inkeLRhhnsITZoUSmU2Kq++hng/xUa7IbeuAi4UAyjGeGurXMJL1KR/KPFmZ4+Dow7hcng
-OlqsTgDLk3NUavUDAm7i6vznkswXQuoAwpKIvHHvBr3Uwzbctor3RdPEflEA+8ymFydRUYVW
-ndDygcCtKWHtryCTzuMzZ6kgDEBNIgvokbCdnJZGRbFbz6gNfQARAQABtCZQYXRyaWNrIEdl
-b3JnaSA8cGF0cmlja0BnZW9yZ2kuZmFtaWx5PokCTgQTAQgAOBYhBNhhq3T7kzJgGTOZaWsk
-nXcmnAThBQJYxcz4AhsDBQsJCAcCBhUICQoLAgQWAgMBAh4BAheAAAoJEGsknXcmnAThmvQP
-/RYyHfKLc5fiCVMAehmPIf5yNiRLy7TRuRWa6eHH+JhvbrD9HeZTzyziojWcYlI8STQnuK7S
-nvthguLP55oxsMRZNNCqzDZDWfKDMsZxWgZpWSC1STc8PF5QW/QQAx8P+ImAhhm4aXgtRk84
-0ZwlFNYOARmydfmopcDyT8gK2vhvc5DkURt5C7p8MzZbcmRTmAchEHWav+f+l5JiAkyMORC5
-c2Hx1KjbKFm/RE6kq69x7rPg07W1gPhw0uWnvvsvgpBEtyl6gjG4IzJeRGf4gwHW1+BIl7De
-9RB2BqSwhsLOa3Nk0oQIJCfd57y8lQBQOxsbsBOi26AVeDz8s2FYAtzD73z+aArAVrcxN7EM
-FjQGzsXsL9AtGhhVVd1zfA9MKY9683rbUc62pQmqRrVQOtZLHJADBpgetf+o7e/vgBS6kxyQ
-7lzPUWSovCKvjBHcJQLj4KnbzmNZxkq+Q6+msF4Z0dao3byfoJPtSy3+BN3T0LRBTB3HGbQA
-w9nZGuQjo1T1d3H9u0HBe6704phDcST3uzMOmeC+td5ecD7J0N4ULPivPvLSrWbHaUsBTA30

commit opera for openSUSE:Factory:NonFree

2019-09-23 Thread root
Hello community,

here is the log from the commit of package opera for openSUSE:Factory:NonFree 
checked in at 2019-09-23 12:46:52

Comparing /work/SRC/openSUSE:Factory:NonFree/opera (Old)
 and  /work/SRC/openSUSE:Factory:NonFree/.opera.new.7948 (New)


Package is "opera"

Mon Sep 23 12:46:52 2019 rev:86 rq:732370 version:63.0.3368.94

Changes:

--- /work/SRC/openSUSE:Factory:NonFree/opera/opera.changes  2019-09-16 
10:53:32.323147858 +0200
+++ /work/SRC/openSUSE:Factory:NonFree/.opera.new.7948/opera.changes
2019-09-23 12:46:56.733515907 +0200
@@ -1,0 +2,7 @@
+Sat Sep 21 06:08:24 UTC 2019 - Carsten Ziepke 
+
+- Update to version 63.0.3368.94
+  - CHR-7516 Update chromium on master to 78.0.3887.7
+  - DNA-80966 [Linux] Integrate a new key into our packages
+
+---

Old:

  opera-stable_63.0.3368.88_amd64.rpm

New:

  opera-stable_63.0.3368.94_amd64.rpm



Other differences:
--
++ opera.spec ++
--- /var/tmp/diff_new_pack.MMtNnX/_old  2019-09-23 12:46:58.085515685 +0200
+++ /var/tmp/diff_new_pack.MMtNnX/_new  2019-09-23 12:46:58.085515685 +0200
@@ -20,7 +20,7 @@
 # libffmpeg.so*, libfreetype.so* and libGLESv2.so* are currently bundled.
 %global __requires_exclude ^lib(ffmpeg|freetype|GLESv2)\\.so.*$
 Name:   opera
-Version:63.0.3368.88
+Version:63.0.3368.94
 Release:0
 Summary:Proprietary web browser
 License:NonFree

++ opera-stable_63.0.3368.88_amd64.rpm -> 
opera-stable_63.0.3368.94_amd64.rpm ++
/work/SRC/openSUSE:Factory:NonFree/opera/opera-stable_63.0.3368.88_amd64.rpm 
/work/SRC/openSUSE:Factory:NonFree/.opera.new.7948/opera-stable_63.0.3368.94_amd64.rpm
 differ: char 34, line 1




commit python-alembic for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package python-alembic for openSUSE:Factory 
checked in at 2019-09-23 12:46:41

Comparing /work/SRC/openSUSE:Factory/python-alembic (Old)
 and  /work/SRC/openSUSE:Factory/.python-alembic.new.7948 (New)


Package is "python-alembic"

Mon Sep 23 12:46:41 2019 rev:46 rq:732612 version:1.2.0

Changes:

--- /work/SRC/openSUSE:Factory/python-alembic/python-alembic.changes
2019-09-02 13:26:01.641304776 +0200
+++ /work/SRC/openSUSE:Factory/.python-alembic.new.7948/python-alembic.changes  
2019-09-23 12:46:44.341517946 +0200
@@ -1,0 +2,79 @@
+Sat Sep 21 19:10:16 UTC 2019 - Arun Persaud 
+
+- update to version 1.2.0:
+  * feature
++ Added new --purge flag to the alembic stamp command, which will
+  unconditionally erase the version table before stamping
+  anything. This is useful for development where non-existent
+  version identifiers might be left within the table. Additionally,
+  alembic.stamp now supports a list of revision identifiers, which
+  are intended to allow setting up muliple heads at once. Overall
+  handling of version identifiers within the alembic.stamp command
+  has been improved with many new tests and use cases added.
+  References: #473
++ Added new feature MigrationContext.autocommit_block(), a special
+  directive which will provide for a non-transactional block inside
+  of a migration script. The feature requres that: the database
+  driver (e.g. DBAPI) supports the AUTOCOMMIT isolation mode. The
+  directive also necessarily needs to COMMIT the existing
+  transaction in progress in order to enter autocommit mode.  See
+  also MigrationContext.autocommit_block() References: #123
+  + Added “post write hooks” to revision generation. These allow
+  custom logic to run after a revision Python script is generated,
+  typically for the purpose of running code formatters such as
+  “Black” or “autopep8”, but may be used for any arbitrary
+  post-render hook as well, including custom Python functions or
+  scripts. The hooks are enabled by providing a [post_write_hooks]
+  section in the alembic.ini file. A single hook is provided which
+  runs an arbitrary Python executable on the newly generated
+  revision script, which can be configured to run code formatters
+  such as Black; full examples are included in the documentation.
+  See also Applying Post Processing and Python Code Formatters to
+  Generated Revisions References: #307
++ Added new flag --package to alembic init. For environments where
+  the Alembic migration files and such are within the package tree
+  and importable as modules, this flag can be specified which will
+  add the additional __init__.py files in the version location and
+  the environment location.  References: #463
+  * bug
++ Improved the Python rendering of a series of migration
+  operations such that a single “pass” is rendered for a
+  UpgradeOps or DowngradeOps based on if no lines of Python code
+  actually rendered under the operation, rather than whether or
+  not sub-directives exist. Removed extra “pass” lines that would
+  generate from the ModifyTableOps directive so that these aren’t
+  duplicated under operation rewriting scenarios.  References:
+  #550
++ Fixed bug where rendering of comment text for table-level
+  comments within Operations.create_table_comment() and
+  Operations.drop_table_comment() was not properly quote-escaped
+  within rendered Python code for autogenerate.  References: #549
++ Modified the logic of the Rewriter object such that it keeps a
+  memoization of which directives it has processed, so that it can
+  ensure it processes a particular directive only once, and
+  additionally fixed Rewriter so that it functions correctly for
+  multiple-pass autogenerate schemes, such as the one illustrated
+  in the “multidb” template. By tracking which directives have
+  been processed, a multiple-pass scheme which calls upon the
+  Rewriter multiple times for the same structure as elements are
+  added can work without running duplicate operations on the same
+  elements more than once.  References: #505
+  * usecase
++ Added autogenerate support for Column objects that have
+  dialect-specific **kwargs, support first added in SQLAlchemy
+  1.3. This includes SQLite “on conflict” as well as options used
+  by some third party dialects.  References: #518
++ Added rendering for SQLAlchemy Variant datatypes, which render
+  as the base type plus one or more .with_variant() method calls.
+  References: #131
++ Made the command interface revision lookup behavior more strict
+   

commit 000product for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-09-23 12:47:06

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.7948 (New)


Package is "000product"

Mon Sep 23 12:47:06 2019 rev:1618 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi: same change
openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
openSUSE-cd-mini-i586.kiwi: same change
openSUSE-cd-mini-x86_64.kiwi: same change
openSUSE-dvd5-dvd-i586.kiwi: same change
openSUSE-dvd5-dvd-x86_64.kiwi: same change
openSUSE-ftp-ftp-i586_x86_64.kiwi: same change
stub.kiwi: same change
++ openSUSE-MicroOS.product ++
--- /var/tmp/diff_new_pack.hbkvWJ/_old  2019-09-23 12:47:08.473512843 +0200
+++ /var/tmp/diff_new_pack.hbkvWJ/_new  2019-09-23 12:47:08.473512843 +0200
@@ -6,7 +6,7 @@
   openSUSE-MicroOS
   openSUSE-MicroOS-release
   
-  20190921
+  20190923
   
   0
   openSUSE-MicroOS




commit 000product for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-09-23 12:46:56

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.7948 (New)


Package is "000product"

Mon Sep 23 12:46:56 2019 rev:1616 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi: same change
openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
openSUSE-cd-mini-i586.kiwi: same change
openSUSE-cd-mini-x86_64.kiwi: same change
openSUSE-dvd5-dvd-i586.kiwi: same change
openSUSE-dvd5-dvd-x86_64.kiwi: same change
openSUSE-ftp-ftp-i586_x86_64.kiwi: same change
stub.kiwi: same change
++ openSUSE-Addon-NonOss.product ++
--- /var/tmp/diff_new_pack.OWuUb9/_old  2019-09-23 12:46:59.649515374 +0200
+++ /var/tmp/diff_new_pack.OWuUb9/_new  2019-09-23 12:46:59.653515374 +0200
@@ -4,7 +4,7 @@
  
 openSUSE
 openSUSE-Addon-NonOss
-20190921
+    20190923
 0 
 openSUSE NonOSS Addon
 non oss addon




commit percona-toolkit for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package percona-toolkit for openSUSE:Factory 
checked in at 2019-09-23 12:46:35

Comparing /work/SRC/openSUSE:Factory/percona-toolkit (Old)
 and  /work/SRC/openSUSE:Factory/.percona-toolkit.new.7948 (New)


Package is "percona-toolkit"

Mon Sep 23 12:46:35 2019 rev:34 rq:732608 version:3.1.0

Changes:

--- /work/SRC/openSUSE:Factory/percona-toolkit/percona-toolkit.changes  
2018-11-26 10:31:48.964921804 +0100
+++ 
/work/SRC/openSUSE:Factory/.percona-toolkit.new.7948/percona-toolkit.changes
2019-09-23 12:46:39.441518752 +0200
@@ -1,0 +2,13 @@
+Sun Sep 22 12:10:47 UTC 2019 - Andreas Stieger 
+
+- update to Percona Toolkit 3.1.0:
+ * the new pt-pg-summary tool supports PostgreSQL data collection
+   in a way similar to other PT summary tools
+ * Add options to pt-stalk that allow limiting the disk space use
+ * pt-online-schema-change will not run under MySQL 8.0.14...17
+   if the table has foreign keys to avoid triggering a bug  
+- includes changes from 3.0.13:
+  * MariaDB 10+ compatibility fixes
+  * various bug fixes in multiple tools
+  
+---

Old:

  percona-toolkit-3.0.12.tar.gz

New:

  percona-toolkit-3.1.0.tar.gz



Other differences:
--
++ percona-toolkit.spec ++
--- /var/tmp/diff_new_pack.uAT6MQ/_old  2019-09-23 12:46:40.265518617 +0200
+++ /var/tmp/diff_new_pack.uAT6MQ/_new  2019-09-23 12:46:40.269518616 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   percona-toolkit
-Version:3.0.12
+Version:3.1.0
 Release:0
 Summary:Advanced MySQL and system command-line tools
 License:GPL-2.0-only

++ percona-toolkit-3.0.12.tar.gz -> percona-toolkit-3.1.0.tar.gz ++
/work/SRC/openSUSE:Factory/percona-toolkit/percona-toolkit-3.0.12.tar.gz 
/work/SRC/openSUSE:Factory/.percona-toolkit.new.7948/percona-toolkit-3.1.0.tar.gz
 differ: char 5, line 1




commit drbd for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package drbd for openSUSE:Factory checked in 
at 2019-09-23 12:46:32

Comparing /work/SRC/openSUSE:Factory/drbd (Old)
 and  /work/SRC/openSUSE:Factory/.drbd.new.7948 (New)


Package is "drbd"

Mon Sep 23 12:46:32 2019 rev:80 rq:732597 version:9.0.19~1+git.8e93a5d9

Changes:

--- /work/SRC/openSUSE:Factory/drbd/drbd.changes2019-09-11 
10:34:03.139319590 +0200
+++ /work/SRC/openSUSE:Factory/.drbd.new.7948/drbd.changes  2019-09-23 
12:46:35.545519393 +0200
@@ -1,0 +2,12 @@
+Wed Sep 20 08:22:12 UTC 2019 - nick wang 
+
+- bsc#1151579, fix collinelle default path and always trigger in obs
+  Add patch suse-coccinelle.patch
+
+---
+Tue Sep 17 04:31:08 UTC 2019 - nw...@suse.com
+
+- bsc#1146117, disallow dual primaries when not configured.
+  Modify patch rely-on-sb-handles.patch
+
+---

New:

  suse-coccinelle.patch



Other differences:
--
++ drbd.spec ++
--- /var/tmp/diff_new_pack.9CpV3W/_old  2019-09-23 12:46:36.341519262 +0200
+++ /var/tmp/diff_new_pack.9CpV3W/_new  2019-09-23 12:46:36.341519262 +0200
@@ -22,7 +22,6 @@
 %define buildrt 1
 %endif
 %endif
-
 Name:   drbd
 Version:9.0.19~1+git.8e93a5d9
 Release:0
@@ -37,11 +36,12 @@
 Source3:drbd_git_revision
 Patch1: fix-resync-finished-with-syncs-have-bits-set.patch
 Patch2: rely-on-sb-handlers.patch
+Patch3: suse-coccinelle.patch
+#https://github.com/openSUSE/rpmlint-checks/blob/master/KMPPolicyCheck.py
+BuildRequires:  coccinelle
 BuildRequires:  kernel-source
 BuildRequires:  kernel-syms
 BuildRequires:  libelf-devel
-#https://github.com/openSUSE/rpmlint-checks/blob/master/KMPPolicyCheck.py
-BuildRequires:  coccinelle
 BuildRequires:  modutils
 Requires:   drbd-utils >= 9.2.0
 Supplements:drbd-utils >= 9.2.0
@@ -61,7 +61,7 @@
 %package KMP
 Summary:Kernel driver
 Group:  Productivity/Clustering/HA
-Url:http://drbd.linbit.com/
+URL:http://drbd.linbit.com/
 
 %description KMP
 This module is the kernel-dependent driver for DRBD. This is split out so
@@ -72,6 +72,7 @@
 %setup -q -n drbd-%{version}
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 mkdir source
 cp -a drbd/. source/. || :
@@ -85,13 +86,14 @@
 export WANT_DRBD_REPRODUCIBLE_BUILD=1
 export CONFIG_BLK_DEV_DRBD=m
 export EXTRA_CFLAGS='-DVERSION=\"%{version}\"'
+export ALWAYS_WANT_SPATCH='yes'
 
 for flavor in %{flavors_to_build}; do
 rm -rf $flavor
 cp -r source $flavor
 cp %{_sourcedir}/Module.supported $flavor
 export DRBDSRC="$PWD/obj/$flavor"
-make -C %{kernel_source $flavor} modules M=$PWD/$flavor
+make %{?_smp_mflags} -C %{kernel_source $flavor} modules M=$PWD/$flavor
 
 #Check the compat result
 cat $PWD/$flavor/compat.h
@@ -109,7 +111,7 @@
 rm -f drbd.conf
 
 %files
-%doc COPYING
+%license COPYING
 %doc ChangeLog
 %{_sbindir}/rc%{name}
 

++ rely-on-sb-handlers.patch ++
--- /var/tmp/diff_new_pack.9CpV3W/_old  2019-09-23 12:46:36.397519253 +0200
+++ /var/tmp/diff_new_pack.9CpV3W/_new  2019-09-23 12:46:36.401519252 +0200
@@ -1,96 +1,45 @@
-diff -Naur drbd-9.0.15+git.c46d2790.orig/drbd/drbd_state.c 
drbd-9.0.15+git.c46d2790/drbd/drbd_state.c
 drbd-9.0.15+git.c46d2790.orig/drbd/drbd_state.c2019-01-10 
13:10:28.152414247 +0800
-+++ drbd-9.0.15+git.c46d2790/drbd/drbd_state.c 2019-01-10 13:10:38.140407675 
+0800
-@@ -251,6 +251,27 @@
-   return rv;
- }
- 
-+static bool is_sb_handlers_configured(struct drbd_connection *connection)
-+{
-+   bool configured = false;
-+
-+enum drbd_after_sb_p after_sb_0p = -1;
-+enum drbd_after_sb_p after_sb_1p = -1;
-+enum drbd_after_sb_p after_sb_2p = -1;
-+
-+after_sb_0p = 
rcu_dereference(connection->transport.net_conf)->after_sb_0p;
-+after_sb_1p = 
rcu_dereference(connection->transport.net_conf)->after_sb_1p;
-+after_sb_2p = 
rcu_dereference(connection->transport.net_conf)->after_sb_2p;
-+
-+   if (after_sb_2p != 0 || after_sb_0p != 0 || after_sb_1p != 0) {
-+   drbd_info(connection, "Split-brain handler configured, rely on it.\n");
-+   configured = true;
-+   }
-+
-+   return configured;
-+}
-+
-+
- bool resource_is_suspended(struct drbd_resource *resource, enum which_state 
which)
- {
-   bool rv = resource->susp_user[which] || resource->susp_nod[which];
-@@ -1465,7 +1486,8 @@
-   if (!nc || nc->two_primaries)
-   continue;
-   if (connection->peer_role[NEW] == R_PRIMARY)
--  return SS_TWO_PRIMARIES;
-+  if 

commit git-cola for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package git-cola for openSUSE:Factory 
checked in at 2019-09-23 12:46:39

Comparing /work/SRC/openSUSE:Factory/git-cola (Old)
 and  /work/SRC/openSUSE:Factory/.git-cola.new.7948 (New)


Package is "git-cola"

Mon Sep 23 12:46:39 2019 rev:23 rq:732609 version:3.5

Changes:

--- /work/SRC/openSUSE:Factory/git-cola/git-cola.changes2019-07-30 
12:39:13.590935361 +0200
+++ /work/SRC/openSUSE:Factory/.git-cola.new.7948/git-cola.changes  
2019-09-23 12:46:41.577518400 +0200
@@ -1,0 +2,49 @@
+Mon Sep 23 06:59:02 UTC 2019 - Marcin Bajor 
+
+- Update to 3.5
+- Usability, bells and whistles
+* Auto-completion for filenames can now be disabled.  This speeds up
+  revision completion when working in large repositories with many files.
+  https://github.com/git-cola/git-cola/pull/981
+* The Stash dialog now shows the stash date as a tooltip when hovering
+  over a stashed change.
+  https://github.com/git-cola/git-cola/pull/982>
+* Qt HiDPI settings are overriden by the `git cola` HiDPI appearance settings.
+  These overrides can now be disabled by selecting the "Disable" mode.
+  This allows users to control Qt's HiDPI settings through environment
+  variables.  Additionally, the "Auto" mode now detects the presence of
+  the Qt HiDPI variables and no longer overrides them when the user has
+  configured their environment explicitly.
+  https://github.com/git-cola/git-cola/issues/963
+* Confirmation dialogs can now focus buttons using the Tab key.
+  Previously, the "Y" and "N" keys could be used to confirm or deny
+  using the keyboard, but "Tab" is more familiar.
+  https://github.com/git-cola/git-cola/issues/965
+* Error dialogs (for example, when a commit hook fails) will now always
+  show the details.  The details were previously hidden behind a toggle.
+  https://github.com/git-cola/git-cola/issues/968
+- Translations
+* Updated Japanese translation.
+  https://github.com/git-cola/git-cola/pull/973
+  https://github.com/git-cola/git-cola/pull/974
+* Updated Simplified Chinese translation.
+  https://github.com/git-cola/git-cola/pull/950
+- Fixes
+* The filesystem monitor no longer logs that it has been enabled after the
+  inotify watch limit is reached on Linux.
+  https://github.com/git-cola/git-cola/pull/984
+* Better unicode robustness.
+  https://github.com/git-cola/git-cola/issues/990
+  https://github.com/git-cola/git-cola/issues/991
+* The "Branches" widget did not always update itself when deleting branches
+  (for example, when inotify is disabled or unavailable).
+  https://github.com/git-cola/git-cola/issues/978
+* Non-ascii unicode byte strings are more robustly handled by the log widget.
+  https://github.com/git-cola/git-cola/issues/977
+* Non-unicode results from the `gettext` library are more robustly handled.
+  https://github.com/git-cola/git-cola/issues/969
+* Launching `git cola` from within a directory that has since been deleted
+  would previously result in a traceback, and is now robustly handled.
+  https://github.com/git-cola/git-cola/issues/961
+
+---

Old:

  v3.4.tar.gz

New:

  v3.5.tar.gz



Other differences:
--
++ git-cola.spec ++
--- /var/tmp/diff_new_pack.WD9r75/_old  2019-09-23 12:46:42.209518296 +0200
+++ /var/tmp/diff_new_pack.WD9r75/_new  2019-09-23 12:46:42.209518296 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   git-cola
-Version:3.4
+Version:3.5
 Release:0
 Summary:A GUI for Git
 License:GPL-2.0-or-later

++ v3.4.tar.gz -> v3.5.tar.gz ++
 3552 lines of diff (skipped)




commit platformsh-cli for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package platformsh-cli for openSUSE:Factory 
checked in at 2019-09-23 12:46:29

Comparing /work/SRC/openSUSE:Factory/platformsh-cli (Old)
 and  /work/SRC/openSUSE:Factory/.platformsh-cli.new.7948 (New)


Package is "platformsh-cli"

Mon Sep 23 12:46:29 2019 rev:80 rq:732549 version:3.48.0

Changes:

--- /work/SRC/openSUSE:Factory/platformsh-cli/platformsh-cli.changes
2019-08-29 17:29:03.311253545 +0200
+++ /work/SRC/openSUSE:Factory/.platformsh-cli.new.7948/platformsh-cli.changes  
2019-09-23 12:46:31.761520016 +0200
@@ -1,0 +2,17 @@
+Sun Sep 22 21:09:49 UTC 2019 - ji...@boombatower.com
+
+- Update to version 3.48.0:
+  * Release v3.48.0
+  * Update dependencies (Symfony -> 3.4.31)
+  * Implement streaming activity logs (#854)
+  * Update API client to reduce unnecessary calls in integration:list command
+  * Report real progress time in activity log (#851)
+  * Significantly reduce default cache lifetimes (#849)
+  * Clarify when mounts share the same disk (#848)
+  * Clean up db:size innodb try/catch
+  * bugfixing some PE customers (#846)
+  * No need to check backup access for inactive/dirty environments
+  * Rename snapshot -> backup
+- Replace @version-placeholder@ in config.yaml with package version
+
+---

Old:

  platformsh-cli-3.47.0.tar.xz

New:

  platformsh-cli-3.48.0.tar.xz



Other differences:
--
++ platformsh-cli.spec ++
--- /var/tmp/diff_new_pack.qjDeZB/_old  2019-09-23 12:46:32.677519865 +0200
+++ /var/tmp/diff_new_pack.qjDeZB/_new  2019-09-23 12:46:32.681519864 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   platformsh-cli
-Version:3.47.0
+Version:3.48.0
 Release:0
 Summary:Tool for managing Platform.sh services from the command line
 # See licenses.txt for dependency licenses.
@@ -47,6 +47,7 @@
 
 %build
 find . -name ".travis.yml" -delete
+sed -i 's/@version-placeholder@/%{version}/' config.yaml
 
 %install
 # install drush source

++ _service ++
--- /var/tmp/diff_new_pack.qjDeZB/_old  2019-09-23 12:46:32.709519860 +0200
+++ /var/tmp/diff_new_pack.qjDeZB/_new  2019-09-23 12:46:32.709519860 +0200
@@ -2,7 +2,7 @@
   
 @PARENT_TAG@
 v(.*)
-refs/tags/v3.47.0
+refs/tags/v3.48.0
 git://github.com/platformsh/platformsh-cli.git
 git
 enable

++ _servicedata ++
--- /var/tmp/diff_new_pack.qjDeZB/_old  2019-09-23 12:46:32.725519857 +0200
+++ /var/tmp/diff_new_pack.qjDeZB/_new  2019-09-23 12:46:32.725519857 +0200
@@ -1,6 +1,6 @@
 
   
 git://github.com/platformsh/platformsh-cli.git
-07ca8e4c26adceede977eda1d189b8d207730eae
+c64df424857511299deb42aa582df794f98050dd
   
 

++ licenses.txt ++
--- /var/tmp/diff_new_pack.qjDeZB/_old  2019-09-23 12:46:32.761519851 +0200
+++ /var/tmp/diff_new_pack.qjDeZB/_new  2019-09-23 12:46:32.761519851 +0200
@@ -16,20 +16,20 @@
 padraic/phar-updaterv1.0.6   BSD-3-Clause  
 paragonie/random_compat v2.0.18  MIT   
 pjcdawkins/guzzle-oauth2-plugin v2.2.0   MIT   
-platformsh/client   v0.29.1  MIT   
+platformsh/client   v0.30.0  MIT   
 platformsh/console-form v0.0.23  MIT   
 psr/container   1.0.0MIT   
 psr/log 1.1.0MIT   
 react/promise   v2.7.1   MIT   
 stecman/symfony-console-completion  0.10.1   MIT   
-symfony/config  v3.4.27  MIT   
-symfony/console v3.4.27  MIT   
-symfony/debug   v3.4.27  MIT   
-symfony/dependency-injectionv3.4.27  MIT   
-symfony/event-dispatcherv3.4.27  MIT   
-symfony/filesystem  v3.4.27  MIT   
-symfony/finder  v3.4.27  MIT   
-symfony/polyfill-ctype  v1.11.0  MIT   
-symfony/polyfill-mbstring   v1.11.0  MIT   
-symfony/process v3.4.27  MIT   
-symfony/yamlv3.4.27  MIT   
+symfony/config  v3.4.31  MIT   
+symfony/console v3.4.31  MIT   
+symfony/debug   v3.4.31  MIT   
+symfony/dependency-injectionv3.4.31  MIT   
+symfony/event-dispatcherv3.4.31  MIT   
+symfony/filesystem  v3.4.31  MIT   
+symfony/finder  v3.4.31  MIT   
+symfony/polyfill-ctype  v1.12.0  MIT   
+symfony/polyfill-mbstring   

commit python-slycot for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package python-slycot for openSUSE:Factory 
checked in at 2019-09-23 12:46:25

Comparing /work/SRC/openSUSE:Factory/python-slycot (Old)
 and  /work/SRC/openSUSE:Factory/.python-slycot.new.7948 (New)


Package is "python-slycot"

Mon Sep 23 12:46:25 2019 rev:4 rq:732528 version:0.3.5.0

Changes:

--- /work/SRC/openSUSE:Factory/python-slycot/python-slycot.changes  
2019-07-08 16:39:42.384847689 +0200
+++ /work/SRC/openSUSE:Factory/.python-slycot.new.7948/python-slycot.changes
2019-09-23 12:46:29.233520431 +0200
@@ -1,0 +2,6 @@
+Sun Sep 22 16:42:44 UTC 2019 - Benjamin Greiner 
+
+- Make sure the correct F2PY flavor is executed
+- Enforce Unix Makefile generator for CMake
+
+---



Other differences:
--
++ python-slycot.spec ++
--- /var/tmp/diff_new_pack.xxiBnx/_old  2019-09-23 12:46:29.789520340 +0200
+++ /var/tmp/diff_new_pack.xxiBnx/_new  2019-09-23 12:46:29.789520340 +0200
@@ -52,10 +52,12 @@
 
 %build
 export CFLAGS="%{optflags}"
-%python_build
+%{python_expand # make sure the correct f2py flavor is executed
+%{$python_build} --generator "Unix Makefiles" -- 
-DF2PY_EXECUTABLE=/usr/bin/f2py%{$python_bin_suffix}
+}
 
 %install
-%python_expand %{$python_install} --install-lib %{$python_sitearch}
+%python_expand %{$python_install} --install-lib %{$python_sitearch} 
--generator "Unix Makefiles"
 %python_expand %fdupes %{buildroot}%{$python_sitearch}
 
 %check




commit tryton for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package tryton for openSUSE:Factory checked 
in at 2019-09-23 12:46:21

Comparing /work/SRC/openSUSE:Factory/tryton (Old)
 and  /work/SRC/openSUSE:Factory/.tryton.new.7948 (New)


Package is "tryton"

Mon Sep 23 12:46:21 2019 rev:32 rq:732524 version:4.6.23

Changes:

--- /work/SRC/openSUSE:Factory/tryton/tryton.changes2019-09-11 
10:33:24.131330915 +0200
+++ /work/SRC/openSUSE:Factory/.tryton.new.7948/tryton.changes  2019-09-23 
12:46:21.445521713 +0200
@@ -1,0 +2,5 @@
+Sun Sep 15 16:38:31 UTC 2019 - Axel Braun 
+
+- Version 4.6.23 - Bugfix Release
+
+---

Old:

  tryton-4.6.22.tar.gz

New:

  tryton-4.6.23.tar.gz



Other differences:
--
++ tryton.spec ++
--- /var/tmp/diff_new_pack.VfqJpR/_old  2019-09-23 12:46:21.905521637 +0200
+++ /var/tmp/diff_new_pack.VfqJpR/_new  2019-09-23 12:46:21.905521637 +0200
@@ -19,7 +19,7 @@
 
 %define majorver 4.6
 Name:   tryton
-Version:%{majorver}.22
+Version:%{majorver}.23
 Release:0
 Summary:The client of the Tryton application platform
 License:GPL-3.0-only

++ tryton-4.6.22.tar.gz -> tryton-4.6.23.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tryton-4.6.22/.hgtags new/tryton-4.6.23/.hgtags
--- old/tryton-4.6.22/.hgtags   2019-09-01 23:39:18.0 +0200
+++ new/tryton-4.6.23/.hgtags   2019-09-15 14:19:04.0 +0200
@@ -39,3 +39,4 @@
 73a5a3a71476466a10c19c3344523f2aeadbe74e 4.6.20
 8e54efd58b258863ff27f5e49f08310ac1fd0ed0 4.6.21
 a6bc12fe3478de061e21184753d4291539eb908b 4.6.22
+cd43aea578ecba3ef04100d1fba6d887d4ea924f 4.6.23
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tryton-4.6.22/CHANGELOG new/tryton-4.6.23/CHANGELOG
--- old/tryton-4.6.22/CHANGELOG 2019-09-01 23:39:17.0 +0200
+++ new/tryton-4.6.23/CHANGELOG 2019-09-15 14:19:03.0 +0200
@@ -1,3 +1,6 @@
+Version 4.6.23 - 2019-09-15
+* Bug fixes (see mercurial logs for details)
+
 Version 4.6.22 - 2019-09-01
 * Bug fixes (see mercurial logs for details)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tryton-4.6.22/PKG-INFO new/tryton-4.6.23/PKG-INFO
--- old/tryton-4.6.22/PKG-INFO  2019-09-01 23:39:19.0 +0200
+++ new/tryton-4.6.23/PKG-INFO  2019-09-15 14:19:05.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: tryton
-Version: 4.6.22
+Version: 4.6.23
 Summary: Tryton client
 Home-page: http://www.tryton.org/
 Author: Tryton
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tryton-4.6.22/tryton/__init__.py 
new/tryton-4.6.23/tryton/__init__.py
--- old/tryton-4.6.22/tryton/__init__.py2019-07-01 21:37:27.0 
+0200
+++ new/tryton-4.6.23/tryton/__init__.py2019-09-01 23:39:34.0 
+0200
@@ -1,3 +1,3 @@
 # This file is part of Tryton.  The COPYRIGHT file at the top level of
 # this repository contains the full copyright notices and license terms.
-__version__ = "4.6.22"
+__version__ = "4.6.23"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tryton-4.6.22/tryton/common/domain_inversion.py 
new/tryton-4.6.23/tryton/common/domain_inversion.py
--- old/tryton-4.6.22/tryton/common/domain_inversion.py 2018-12-30 
19:01:29.0 +0100
+++ new/tryton-4.6.23/tryton/common/domain_inversion.py 2019-09-12 
23:23:24.0 +0200
@@ -105,7 +105,7 @@
 if domain in ('AND', 'OR'):
 return domain
 elif is_leaf(domain):
-if 'child_of' in domain[1]:
+if 'child_of' in domain[1] and '.' not in domain[0]:
 if len(domain) == 3:
 return domain
 else:
Binary files old/tryton-4.6.22/tryton/data/locale/bg/LC_MESSAGES/tryton.mo and 
new/tryton-4.6.23/tryton/data/locale/bg/LC_MESSAGES/tryton.mo differ
Binary files old/tryton-4.6.22/tryton/data/locale/ca/LC_MESSAGES/tryton.mo and 
new/tryton-4.6.23/tryton/data/locale/ca/LC_MESSAGES/tryton.mo differ
Binary files old/tryton-4.6.22/tryton/data/locale/cs/LC_MESSAGES/tryton.mo and 
new/tryton-4.6.23/tryton/data/locale/cs/LC_MESSAGES/tryton.mo differ
Binary files old/tryton-4.6.22/tryton/data/locale/de/LC_MESSAGES/tryton.mo and 
new/tryton-4.6.23/tryton/data/locale/de/LC_MESSAGES/tryton.mo differ
Binary files old/tryton-4.6.22/tryton/data/locale/es/LC_MESSAGES/tryton.mo and 
new/tryton-4.6.23/tryton/data/locale/es/LC_MESSAGES/tryton.mo differ
Binary files old/tryton-4.6.22/tryton/data/locale/es_419/LC_MESSAGES/tryton.mo 
and new/tryton-4.6.23/tryton/data/locale/es_419/LC_MESSAGES/tryton.mo 

commit proteus for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package proteus for openSUSE:Factory checked 
in at 2019-09-23 12:46:18

Comparing /work/SRC/openSUSE:Factory/proteus (Old)
 and  /work/SRC/openSUSE:Factory/.proteus.new.7948 (New)


Package is "proteus"

Mon Sep 23 12:46:18 2019 rev:11 rq:732523 version:4.6.7

Changes:

--- /work/SRC/openSUSE:Factory/proteus/proteus.changes  2019-06-01 
09:48:00.107354971 +0200
+++ /work/SRC/openSUSE:Factory/.proteus.new.7948/proteus.changes
2019-09-23 12:46:20.753521827 +0200
@@ -1,0 +2,5 @@
+Sun Sep 15 16:38:50 UTC 2019 - Axel Braun 
+
+- Version 4.6.7 - Bugfix Release
+
+---

Old:

  proteus-4.6.6.tar.gz

New:

  proteus-4.6.7.tar.gz



Other differences:
--
++ proteus.spec ++
--- /var/tmp/diff_new_pack.6wWyy2/_old  2019-09-23 12:46:21.157521760 +0200
+++ /var/tmp/diff_new_pack.6wWyy2/_new  2019-09-23 12:46:21.161521759 +0200
@@ -19,7 +19,7 @@
 
 %define majorver 4.6
 Name:   proteus
-Version:%{majorver}.6
+Version:%{majorver}.7
 Release:0
 Summary:A library to access Tryton's modules like a client
 License:GPL-3.0-or-later

++ proteus-4.6.6.tar.gz -> proteus-4.6.7.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/proteus-4.6.6/.hgtags new/proteus-4.6.7/.hgtags
--- old/proteus-4.6.6/.hgtags   2019-04-22 10:41:27.0 +0200
+++ new/proteus-4.6.7/.hgtags   2019-09-15 14:27:30.0 +0200
@@ -19,3 +19,4 @@
 1357255a797f53827a663cd4ea3d08a5448ab9df 4.6.4
 4b75c46d9bf62a307b5c6e23a13e5500a6f1f24f 4.6.5
 8d23b72d421c4b63f59c547c127be62d561a0e31 4.6.6
+8dbfcb22e5c639fafe68c6b6ff7043216aa89b33 4.6.7
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/proteus-4.6.6/CHANGELOG new/proteus-4.6.7/CHANGELOG
--- old/proteus-4.6.6/CHANGELOG 2019-04-22 10:41:26.0 +0200
+++ new/proteus-4.6.7/CHANGELOG 2019-09-15 14:27:30.0 +0200
@@ -1,3 +1,6 @@
+Version 4.6.7 - 2019-09-15
+* Bug fixes (see mercurial logs for details)
+
 Version 4.6.6 - 2019-04-22
 * Bug fixes (see mercurial logs for details)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/proteus-4.6.6/PKG-INFO new/proteus-4.6.7/PKG-INFO
--- old/proteus-4.6.6/PKG-INFO  2019-04-22 10:41:27.0 +0200
+++ new/proteus-4.6.7/PKG-INFO  2019-09-15 14:27:31.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: proteus
-Version: 4.6.6
+Version: 4.6.7
 Summary: Library to access Tryton server as a client
 Home-page: http://www.tryton.org/
 Author: Tryton
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/proteus-4.6.6/proteus/__init__.py 
new/proteus-4.6.7/proteus/__init__.py
--- old/proteus-4.6.6/proteus/__init__.py   2018-12-03 00:48:04.0 
+0100
+++ new/proteus-4.6.7/proteus/__init__.py   2019-09-12 23:23:23.0 
+0200
@@ -19,7 +19,7 @@
 
 import proteus.config
 
-__version__ = "4.6.6"
+__version__ = "4.6.7"
 __all__ = ['Model', 'Wizard', 'Report']
 
 _MODELS = threading.local()
@@ -855,8 +855,19 @@
 'Return dictionary values'
 if fields is None:
 fields = self._values.keys()
-return dict((x, getattr(self, '__%s_value' % x)) for x in fields
-if x not in ('id', '_timestamp'))
+values = {}
+for name in fields:
+if name in ['id', '_timestamp']:
+continue
+definition = self._fields[name]
+if definition.get('readonly') and definition['type'] != 'one2many':
+continue
+values[name] = getattr(self, '__%s_value' % name)
+# Sending an empty X2Many fields breaks ModelFieldAccess.check
+if (definition['type'] in {'one2many', 'many2many'}
+and not values[name]):
+del values[name]
+return values
 
 @property
 def _timestamp(self):
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/proteus-4.6.6/proteus.egg-info/PKG-INFO 
new/proteus-4.6.7/proteus.egg-info/PKG-INFO
--- old/proteus-4.6.6/proteus.egg-info/PKG-INFO 2019-04-22 10:41:27.0 
+0200
+++ new/proteus-4.6.7/proteus.egg-info/PKG-INFO 2019-09-15 14:27:31.0 
+0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: proteus
-Version: 4.6.6
+Version: 4.6.7
 Summary: Library to access Tryton server as a client
 Home-page: http://www.tryton.org/
 Author: Tryton




commit DisplayCAL for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package DisplayCAL for openSUSE:Factory 
checked in at 2019-09-23 12:46:12

Comparing /work/SRC/openSUSE:Factory/DisplayCAL (Old)
 and  /work/SRC/openSUSE:Factory/.DisplayCAL.new.7948 (New)


Package is "DisplayCAL"

Mon Sep 23 12:46:12 2019 rev:34 rq:732516 version:3.8.7.0

Changes:

--- /work/SRC/openSUSE:Factory/DisplayCAL/DisplayCAL.changes2019-09-11 
10:40:36.687217723 +0200
+++ /work/SRC/openSUSE:Factory/.DisplayCAL.new.7948/DisplayCAL.changes  
2019-09-23 12:46:14.581522842 +0200
@@ -1,0 +2,14 @@
+Sun Sep 22 13:24:43 UTC 2019 - obs-packag...@displaycal.net
+
+- Update to 3.8.7:
+  * [Trivial] Don't automatically disable interactive display
+adjustment when setting calibration tone curve to “As measured”
+(unintended behavioral change introduced in DisplayCAL 3.8.6,
+SVN revision r6194).
+  * [Minor] (GNOME on Wayland) Latency incurred by a large
+measurement window size was not accounted for, introducing the
+possibility of measurements failing due to loss of
+synchronization.
+  * [Minor] (GNOME on Wayland) Limited range (16..235) support.
+
+---

Old:

  DisplayCAL-3.8.6.0.tar.gz

New:

  DisplayCAL-3.8.7.0.tar.gz



Other differences:
--
++ DisplayCAL.spec ++
--- /var/tmp/diff_new_pack.1qobUI/_old  2019-09-23 12:46:15.257522731 +0200
+++ /var/tmp/diff_new_pack.1qobUI/_new  2019-09-23 12:46:15.257522731 +0200
@@ -30,7 +30,7 @@
 License:GPL-3.0+
 Group:  Productivity/Graphics/Other
 Name:   DisplayCAL
-Version:3.8.6.0
+Version:3.8.7.0
 Release:0
 Source0:http://displaycal.net/download/%{name}-%version.tar.gz
 Url:https://displaycal.net/

++ DisplayCAL-3.8.6.0.tar.gz -> DisplayCAL-3.8.7.0.tar.gz ++
/work/SRC/openSUSE:Factory/DisplayCAL/DisplayCAL-3.8.6.0.tar.gz 
/work/SRC/openSUSE:Factory/.DisplayCAL.new.7948/DisplayCAL-3.8.7.0.tar.gz 
differ: char 5, line 1




commit trytond for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package trytond for openSUSE:Factory checked 
in at 2019-09-23 12:46:22

Comparing /work/SRC/openSUSE:Factory/trytond (Old)
 and  /work/SRC/openSUSE:Factory/.trytond.new.7948 (New)


Package is "trytond"

Mon Sep 23 12:46:22 2019 rev:35 rq:732525 version:4.6.20

Changes:

--- /work/SRC/openSUSE:Factory/trytond/trytond.changes  2019-08-28 
18:36:21.997274477 +0200
+++ /work/SRC/openSUSE:Factory/.trytond.new.7948/trytond.changes
2019-09-23 12:46:25.145521104 +0200
@@ -1,0 +2,5 @@
+Sun Sep 15 16:38:13 UTC 2019 - Axel Braun 
+
+- Version 4.6.20 - Bugfix Release
+
+---

Old:

  trytond-4.6.19.tar.gz

New:

  trytond-4.6.20.tar.gz



Other differences:
--
++ trytond.spec ++
--- /var/tmp/diff_new_pack.RCV9Dn/_old  2019-09-23 12:46:25.781520999 +0200
+++ /var/tmp/diff_new_pack.RCV9Dn/_new  2019-09-23 12:46:25.785520999 +0200
@@ -20,7 +20,7 @@
 %define majorver 4.6
 %define base_name tryton
 Name:   trytond
-Version:%{majorver}.19
+Version:%{majorver}.20
 Release:0
 
 Summary:An Enterprise Resource Planning (ERP) system

++ trytond-4.6.19.tar.gz -> trytond-4.6.20.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trytond-4.6.19/.hgtags new/trytond-4.6.20/.hgtags
--- old/trytond-4.6.19/.hgtags  2019-08-17 11:54:43.0 +0200
+++ new/trytond-4.6.20/.hgtags  2019-09-15 14:11:58.0 +0200
@@ -36,3 +36,4 @@
 b05891693d5db22f2e585246559825f4b047f62c 4.6.17
 2fab4255222aaa45586f14ecc9a91c7cba633a69 4.6.18
 d93c88d939d937c37beced393d7d9628529232eb 4.6.19
+1d3c174a7e052deba0816c8ae6138a42a525086e 4.6.20
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trytond-4.6.19/CHANGELOG new/trytond-4.6.20/CHANGELOG
--- old/trytond-4.6.19/CHANGELOG2019-08-17 11:54:43.0 +0200
+++ new/trytond-4.6.20/CHANGELOG2019-09-15 14:11:57.0 +0200
@@ -1,3 +1,6 @@
+Version 4.6.20 - 2019-09-15
+* Bug fixes (see mercurial logs for details)
+
 Version 4.6.19 - 2019-08-17
 * Bug fixes (see mercurial logs for details)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trytond-4.6.19/PKG-INFO new/trytond-4.6.20/PKG-INFO
--- old/trytond-4.6.19/PKG-INFO 2019-08-17 11:54:44.0 +0200
+++ new/trytond-4.6.20/PKG-INFO 2019-09-15 14:11:59.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: trytond
-Version: 4.6.19
+Version: 4.6.20
 Summary: Tryton server
 Home-page: http://www.tryton.org/
 Author: Tryton
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trytond-4.6.19/trytond/__init__.py 
new/trytond-4.6.20/trytond/__init__.py
--- old/trytond-4.6.19/trytond/__init__.py  2019-08-01 23:00:54.0 
+0200
+++ new/trytond-4.6.20/trytond/__init__.py  2019-08-17 11:55:19.0 
+0200
@@ -5,7 +5,7 @@
 import warnings
 from email import charset
 
-__version__ = "4.6.19"
+__version__ = "4.6.20"
 
 os.environ['TZ'] = 'UTC'
 if hasattr(time, 'tzset'):
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trytond-4.6.19/trytond/ir/action.py 
new/trytond-4.6.20/trytond/ir/action.py
--- old/trytond-4.6.19/trytond/ir/action.py 2018-08-20 22:55:19.0 
+0200
+++ new/trytond-4.6.20/trytond/ir/action.py 2019-09-04 20:39:09.0 
+0200
@@ -654,9 +654,8 @@
 
 @fields.depends('name', 'template_extension')
 def on_change_with_report_content_name(self, name=None):
-if not self.name:
-return
-return ''.join([self.name, os.extsep, self.template_extension])
+return ''.join(
+filter(None, [self.name, os.extsep, self.template_extension]))
 
 @classmethod
 def get_pyson(cls, reports, name):
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/trytond-4.6.19/trytond/sendmail.py 
new/trytond-4.6.20/trytond/sendmail.py
--- old/trytond-4.6.19/trytond/sendmail.py  2018-08-20 22:55:19.0 
+0200
+++ new/trytond-4.6.20/trytond/sendmail.py  2019-09-12 23:23:25.0 
+0200
@@ -4,6 +4,7 @@
 import smtplib
 import urllib
 from email.message import Message
+from email.utils import formatdate
 from urlparse import parse_qs
 
 from .config import config, parse_uri
@@ -30,6 +31,8 @@
 quit = True
 else:
 quit = False
+if 'Date' not in msg:
+msg['Date'] = formatdate()
 try:
 senderrs = server.sendmail(from_addr, to_addrs, msg.as_string())
 except smtplib.SMTPException:
diff -urN '--exclude=CVS' 

commit hub for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package hub for openSUSE:Factory checked in 
at 2019-09-23 12:39:34

Comparing /work/SRC/openSUSE:Factory/hub (Old)
 and  /work/SRC/openSUSE:Factory/.hub.new.7948 (New)


Package is "hub"

Mon Sep 23 12:39:34 2019 rev:8 rq:732500 version:2.12.6

Changes:

--- /work/SRC/openSUSE:Factory/hub/hub.changes  2019-09-09 12:39:33.929431277 
+0200
+++ /work/SRC/openSUSE:Factory/.hub.new.7948/hub.changes2019-09-23 
12:39:55.385585228 +0200
@@ -1,0 +2,7 @@
+Sat Sep 21 19:50:01 UTC 2019 - Martin Hauke 
+
+- Update to version 2.12.6
+  * Added hub pr to fish completions script
+  * Have fish completions script wrap git if hub is aliased
+
+---

Old:

  hub-2.12.4.tar.gz

New:

  hub-2.12.6.tar.gz



Other differences:
--
++ hub.spec ++
--- /var/tmp/diff_new_pack.ow4OTS/_old  2019-09-23 12:39:55.725585171 +0200
+++ /var/tmp/diff_new_pack.ow4OTS/_new  2019-09-23 12:39:55.729585171 +0200
@@ -18,7 +18,7 @@
 
 %define ver %{version}
 Name:   hub
-Version:2.12.4
+Version:2.12.6
 Release:0
 Summary:Command-line wrapper for git and GitHub
 License:MIT

++ hub-2.12.4.tar.gz -> hub-2.12.6.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hub-2.12.4/etc/hub.fish_completion 
new/hub-2.12.6/etc/hub.fish_completion
--- old/hub-2.12.4/etc/hub.fish_completion  2019-09-06 23:00:06.0 
+0200
+++ new/hub-2.12.6/etc/hub.fish_completion  2019-09-21 17:30:41.0 
+0200
@@ -1,3 +1,5 @@
+complete -c hub --wraps git
+
 function __fish_hub_needs_command
   set cmd (commandline -opc)
   if [ (count $cmd) -eq 1 ]
@@ -9,12 +11,17 @@
 
 function  __fish_hub_using_command
   set cmd (commandline -opc)
-  if [ (count $cmd) -gt 1 ]
-if [ $argv[1] = $cmd[2] ]
-  return 0
+  set subcmd_count (count $argv)
+  if [ (count $cmd) -gt "$subcmd_count" ]
+for i in (seq 1 "$subcmd_count")
+  if [ "$argv[$i]" != $cmd[(math "$i" + 1)] ]
+return 1
+  end
 end
+return 0
+  else
+return 1
   end
-  return 1
 end
 
 complete -f -c hub -n '__fish_hub_needs_command' -a alias -d "show shell 
instructions for wrapping git"
@@ -24,7 +31,7 @@
 complete -f -c hub -n '__fish_hub_needs_command' -a delete -d "delete a GitHub 
repo"
 complete -f -c hub -n '__fish_hub_needs_command' -a fork -d "fork origin repo 
on GitHub"
 complete -f -c hub -n '__fish_hub_needs_command' -a pull-request -d "open a 
pull request on GitHub"
-complete -f -c hub -n '__fish_hub_needs_command' -a pr -d "list or checkout a 
GitHub release"
+complete -f -c hub -n '__fish_hub_needs_command' -a pr -d "list or checkout 
GitHub pull requests"
 complete -f -c hub -n '__fish_hub_needs_command' -a issue -d "list or create a 
GitHub issue"
 complete -f -c hub -n '__fish_hub_needs_command' -a release -d "list or create 
a GitHub release"
 complete -f -c hub -n '__fish_hub_needs_command' -a ci-status -d "display 
GitHub Status information for a commit"
@@ -44,6 +51,19 @@
 complete -f -c hub -n ' __fish_hub_using_command pull-request' -s a -d 'A 
comma-separated list of GitHub handles to assign to this pull request'
 complete -f -c hub -n ' __fish_hub_using_command pull-request' -s M -d "The 
milestone name to add to this pull request. Passing the milestone number is 
deprecated."
 complete -f -c hub -n ' __fish_hub_using_command pull-request' -s l -d "Add a 
comma-separated list of labels to this pull request"
+# pr
+complete -f -c hub -n ' __fish_hub_using_command pr' -l color -xa 'always 
never auto' -d 'enable colored output even if stdout is not a terminal. WHEN 
can be one of "always" (default for --color), "never", or "auto" (default).'
+## pr list
+complete -f -c hub -n ' __fish_hub_using_command pr' -a list -d "list pull 
requests in the current repository"
+complete -f -c hub -n ' __fish_hub_using_command pr list' -s s -l state -xa 
'open closed merged all' -d 'filter pull requests by STATE. default: open'
+complete -f -c hub -n ' __fish_hub_using_command pr list' -s h -l head -d 
'show pull requests started from the specified head BRANCH in "[OWNER:]BRANCH" 
format'
+complete -f -c hub -n ' __fish_hub_using_command pr list' -s b -l base -d 
'show pull requests based off the specified BRANCH'
+complete -f -c hub -n ' __fish_hub_using_command pr list' -s o -l sort -xa 
'created updated popularity long-running' -d 'default: created'
+complete -f -c hub -n ' __fish_hub_using_command pr list' -s '^' -l 
sort-ascending -d 'sort by ascending dates instead of descending'
+complete -f -c hub -n ' __fish_hub_using_command pr list' -s f -l format -d 
'pretty print 

commit qimgv for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package qimgv for openSUSE:Factory checked 
in at 2019-09-23 12:39:21

Comparing /work/SRC/openSUSE:Factory/qimgv (Old)
 and  /work/SRC/openSUSE:Factory/.qimgv.new.7948 (New)


Package is "qimgv"

Mon Sep 23 12:39:21 2019 rev:10 rq:732425 version:0.8.4

Changes:

--- /work/SRC/openSUSE:Factory/qimgv/qimgv.changes  2019-09-20 
14:56:01.526848825 +0200
+++ /work/SRC/openSUSE:Factory/.qimgv.new.7948/qimgv.changes2019-09-23 
12:39:51.533585861 +0200
@@ -1,0 +2,7 @@
+Sun Sep 22 04:49:34 UTC 2019 - Luigi Baldoni 
+
+- Update to version 0.8.4
+  * fix rename window (regression)
+  * show error when a file operation fails
+
+---

Old:

  qimgv-0.8.3.tar.gz

New:

  qimgv-0.8.4.tar.gz



Other differences:
--
++ qimgv.spec ++
--- /var/tmp/diff_new_pack.cMUi4p/_old  2019-09-23 12:39:52.033585779 +0200
+++ /var/tmp/diff_new_pack.cMUi4p/_new  2019-09-23 12:39:52.037585778 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   qimgv
-Version:0.8.3
+Version:0.8.4
 Release:0
 Summary:Qt5 image viewer
 License:GPL-3.0-only

++ qimgv-0.8.3.tar.gz -> qimgv-0.8.4.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/qimgv-0.8.3/README.md new/qimgv-0.8.4/README.md
--- old/qimgv-0.8.3/README.md   2019-09-19 17:21:20.0 +0200
+++ new/qimgv-0.8.4/README.md   2019-09-21 22:52:26.0 +0200
@@ -1,4 +1,4 @@
-qimgv | Current version: 0.8.3
+qimgv | Current version: 0.8.4
 =
 Qt5 image viewer. Fast, configurable, easy to use. Optional video support.
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/qimgv-0.8.3/qimgv/appversion.cpp 
new/qimgv-0.8.4/qimgv/appversion.cpp
--- old/qimgv-0.8.3/qimgv/appversion.cpp2019-09-19 17:21:20.0 
+0200
+++ new/qimgv-0.8.4/qimgv/appversion.cpp2019-09-21 22:52:26.0 
+0200
@@ -1,3 +1,3 @@
 #include "appversion.h"
 
-QVersionNumber appVersion(0,8,3);
+QVersionNumber appVersion(0,8,4);
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/qimgv-0.8.3/qimgv/components/directorymanager/directorymanager.cpp 
new/qimgv-0.8.4/qimgv/components/directorymanager/directorymanager.cpp
--- old/qimgv-0.8.3/qimgv/components/directorymanager/directorymanager.cpp  
2019-09-19 17:21:20.0 +0200
+++ new/qimgv-0.8.4/qimgv/components/directorymanager/directorymanager.cpp  
2019-09-21 22:52:26.0 +0200
@@ -121,6 +121,10 @@
 return true;
 }
 
+QString DirectoryManager::directory() {
+return currentPath;
+}
+
 int DirectoryManager::indexOf(QString fileName) const {
 auto item = find_if(entryVec.begin(), entryVec.end(), [fileName](const 
Entry& e) {
 return e.path == fileName;
@@ -202,7 +206,7 @@
 void DirectoryManager::moveToTrash(QString file) {
 QFileInfo fileinfo( file );
 if( !fileinfo.exists() )
-qDebug() << "File doesnt exists, cant move to trash";
+return;
 WCHAR from[ MAX_PATH ];
 memset( from, 0, sizeof( from ));
 int l = fileinfo.absoluteFilePath().toWCharArray( from );
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/qimgv-0.8.3/qimgv/components/directorymanager/directorymanager.h 
new/qimgv-0.8.4/qimgv/components/directorymanager/directorymanager.h
--- old/qimgv-0.8.3/qimgv/components/directorymanager/directorymanager.h
2019-09-19 17:21:20.0 +0200
+++ new/qimgv-0.8.4/qimgv/components/directorymanager/directorymanager.h
2019-09-21 22:52:26.0 +0200
@@ -64,6 +64,7 @@
 DirectoryManager();
 // ignored if the same dir is already opened
 bool setDirectory(QString);
+QString directory();
 // returns index in file list
 // -1 if not found
 int indexOf(QString fileName) const;
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/qimgv-0.8.3/qimgv/components/directorymanager/watchers/windows/windowsworker.cpp
 
new/qimgv-0.8.4/qimgv/components/directorymanager/watchers/windows/windowsworker.cpp
--- 
old/qimgv-0.8.3/qimgv/components/directorymanager/watchers/windows/windowsworker.cpp
2019-09-19 17:21:20.0 +0200
+++ 
new/qimgv-0.8.4/qimgv/components/directorymanager/watchers/windows/windowsworker.cpp
2019-09-21 22:52:26.0 +0200
@@ -5,7 +5,7 @@
 }
 
 void WindowsWorker::setDirectoryHandle(HANDLE hDir) {
-qDebug() << "setHandle" << this->hDir << " -> " << hDir;
+//qDebug() << "setHandle" << this->hDir << " -> " << hDir;
 this->hDir = hDir;
 }
 
diff -urN 

commit gnuradio for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package gnuradio for openSUSE:Factory 
checked in at 2019-09-23 12:39:16

Comparing /work/SRC/openSUSE:Factory/gnuradio (Old)
 and  /work/SRC/openSUSE:Factory/.gnuradio.new.7948 (New)


Package is "gnuradio"

Mon Sep 23 12:39:16 2019 rev:34 rq:732420 version:3.8.0.0

Changes:

--- /work/SRC/openSUSE:Factory/gnuradio/gnuradio.changes2019-05-03 
22:46:47.303819053 +0200
+++ /work/SRC/openSUSE:Factory/.gnuradio.new.7948/gnuradio.changes  
2019-09-23 12:39:47.865586464 +0200
@@ -1,0 +2,89 @@
+Thu Sep 19 16:37:47 UTC 2019 - Stefan Brüns 
+
+- Use pkgconfig(py3cairo) to specify pycairo dependency, package got
+  renamed between Leap 15.x and TW, and pkgconfig(py3cairo) fits both.
+- Add log4cpp-devel to -devel Requires, always required by gr-runtime.
+
+---
+Wed Sep 18 20:16:50 UTC 2019 - Martin Hauke 
+
+- Use correct shared library name
+
+---
+Thu Sep 12 16:49:33 UTC 2019 - Stefan Brüns 
+
+- Update to version 3.8.0.0:
+  * Changed on Project Scope
++ C++11
++ merged the wholeness of the next branch
++ Dependency version bumps: CMake, GCC, MSVC, Swig, Boost
++ New dependencies: MPIR/GMP, Qt5, gsm, codec2
++ Removed dependencies: libusb, Qt4, CppUnit
++ Python: Python 2 & Python 3 compatible. 3.8 will be the last 
Py2k-compatible
++ release series
++ gengen was replaced by templates (if you don't know gengen, don't do any
++ research; save yourself that sorrow)
++ Modern CMake (as far as feasible at this point)
++ VOLK version updated to v2.0.0
++ .clang-format file now dictates coding style
++ clang-format'ed the whole tree.
++ installed CMake files now tell about configuration
+  * gnuradio-runtime 
++ reworked fractional tag time handling, especially in the context of 
resamplers
+  * GRC
++ C++ generation as option
++ YAML instead of XML
++ removed blks2
++ much better canvas tooling
++ consistent gobject usage
++ ROUNDED ARROWS
+  * gr-qtgui
++ moving from Qt4 to Qt5
+  * gr-utils 
++ gr_modtool now vastly improved
+  * gr-vocoder
++ improved versatility
++ removed in-tree libgsm, libcodec2, use system-wide libs
+  * Removed
++ Project Scope: Modules gr-comedi, gr-fcd and gr-wxgui are gone
++ gr-comedi: nobody could remember who used this, or for what. It has seen 0
+  active code contributions in the 3.7 lifecycle
++ gr-digital: python-based packet_encoder and related tools: Bugs that were
+  sporadic and never fixed, so after long deprecation, we're removing it
++ gr-fcd: since it's currently untestable by the CI, it's being removed, as
+  there was no code contributions. Generally, we strive to include all
+  batteries with GNU Radio. Re-integration within a more general SDR 
interface
+  would be desirable.
++ gr-utils: removed PyQwt (dead) based tools
++ gr-wxgui: Unmaintained, breaks on increasingly many systems, always was 
slower than
+  Qtgui. We've been starting to tell people to migrate to Qt since at
+  least 2015. Now, we're finally removing it.
+- Packaging changes:
+  * Use system libvolk, now packaged separately
+  * Cleanup spec file, mostly Qt4 and WxWidgets related
+  * Use Python3
+  * Patches:
+- rebased missing_libraries.patch
+- Drop obsolete 
qt5-maint-0001-CMake-Update-required-minimum-version-to-2.8.12.patch
+- Drop obsolete 
qt5-maint-0002-CMake-FindQwt-Find-the-Qt5-version-of-QWT-instead-of.patch
+- Drop obsolete qt5-maint-0003-gr-qtgui-update-for-Qt5.patch
+- Drop obsolete 
qt5-maint-0004-grc-Generate-Python-scripts-that-use-PyQt5.patch
+- Drop obsolete 
qt5-maint-0005-gr-qtgui-Add-a-workaround-for-an-upstream-bug-of-uic.patch
+- Drop obsolete 
qt5-maint-0006-qtgui-fixed-examples-for-Qt5-compatibility.patch
+- Drop obsolete 
qt5-maint-0007-qtgui-Fixes-for-edit_box_msg-to-work-with-QT5.patch
+- Drop obsolete 
qt5-maint-0008-gr-qtgui-Allow-build-with-Qt4-or-Qt5-default.patch
+- Drop obsolete 
qt5-maint-0009-gr-qtgui-Fix-PyQt-4-5-include-in-XMLs-for-GRC.patch
+- Drop obsolete 
qt5-maint-0010-gr-qtgui-Fix-range.py-to-work-with-both-Qt4-and-Qt5.patch
+- Drop obsolete 
qt5-maint-0011-gr-qtgui-Re-introduce-some-Qt4-specific-code.patch
+- Drop obsolete 
qt5-maint-0012-grc-Fix-generation-of-Python-code-for-Qt4-and-Qt5.patch
+- Drop obsolete 
qt5-maint-0013-grc-replace-templated-xml-files-with-search-and-repl.patch
+- Drop obsolete 
qt5-maint-0014-qtgui-replace-templated-xml-files-with-search-and-re.patch
+- Drop obsolete qt5-maint-0017-qtgui-fix-stylesheet-for-qt5.patch
+- Drop obsolete 

commit fcitx-qt5 for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package fcitx-qt5 for openSUSE:Factory 
checked in at 2019-09-23 12:39:18

Comparing /work/SRC/openSUSE:Factory/fcitx-qt5 (Old)
 and  /work/SRC/openSUSE:Factory/.fcitx-qt5.new.7948 (New)


Package is "fcitx-qt5"

Mon Sep 23 12:39:18 2019 rev:16 rq:732423 version:1.2.2

Changes:

--- /work/SRC/openSUSE:Factory/fcitx-qt5/fcitx-qt5.changes  2018-04-29 
19:37:38.937751398 +0200
+++ /work/SRC/openSUSE:Factory/.fcitx-qt5.new.7948/fcitx-qt5.changes
2019-09-23 12:39:50.609586013 +0200
@@ -1,0 +2,6 @@
+Sat Sep 21 15:38:37 UTC 2019 - Yunhe Guo 
+
+- Add upstream patch fix-remove-paths-warnings.patch
+- Change COPYING from %doc to %license 
+
+---

New:

  fix-remove-paths-warnings.patch



Other differences:
--
++ fcitx-qt5.spec ++
--- /var/tmp/diff_new_pack.UUaQKy/_old  2019-09-23 12:39:51.245585908 +0200
+++ /var/tmp/diff_new_pack.UUaQKy/_new  2019-09-23 12:39:51.249585908 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package fcitx-qt5
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -27,6 +27,7 @@
 Source99:   baselibs.conf
 # PATCH-FIX-UPSTREAM: fix compilation with Qt 5.11 (missing include)
 Patch0: fix-compilation-with-qt-5.11.patch
+Patch1: fix-remove-paths-warnings.patch
 BuildRequires:  cmake
 BuildRequires:  extra-cmake-modules
 BuildRequires:  fcitx-devel >= 4.2.9.1
@@ -71,7 +72,7 @@
 
 %files -f fcitx-qt5.lang
 %defattr(-,root,root)
-%doc COPYING
+%license COPYING
 %dir %{_libdir}/fcitx/qt
 %{_libdir}/fcitx/libexec/fcitx-qt5-gui-wrapper
 %{_libdir}/libFcitxQt5*Addons.so.1

++ fix-remove-paths-warnings.patch ++
diff --git a/platforminputcontext/fcitxwatcher.cpp 
b/platforminputcontext/fcitxwatcher.cpp
index 
1a2b4baa215237012fdd0c62e793d786d4e58b0c..6165a5bdd45146efc83545982cf37a5927c5613e
 100644
--- a/platforminputcontext/fcitxwatcher.cpp
+++ b/platforminputcontext/fcitxwatcher.cpp
@@ -256,8 +256,12 @@ void FcitxWatcher::watchSocketFile() {
 }
 
 void FcitxWatcher::unwatchSocketFile() {
-m_fsWatcher->removePaths(m_fsWatcher->files());
-m_fsWatcher->removePaths(m_fsWatcher->directories());
+if (!m_fsWatcher->files().isEmpty()) {
+m_fsWatcher->removePaths(m_fsWatcher->files());
+}
+if (!m_fsWatcher->directories().isEmpty()) {
+m_fsWatcher->removePaths(m_fsWatcher->directories());
+}
 m_fsWatcher->disconnect(SIGNAL(fileChanged(QString)));
 m_fsWatcher->disconnect(SIGNAL(directoryChanged(QString)));
 }



commit OpenSubdiv for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package OpenSubdiv for openSUSE:Factory 
checked in at 2019-09-23 12:39:31

Comparing /work/SRC/openSUSE:Factory/OpenSubdiv (Old)
 and  /work/SRC/openSUSE:Factory/.OpenSubdiv.new.7948 (New)


Package is "OpenSubdiv"

Mon Sep 23 12:39:31 2019 rev:2 rq:732499 version:3.4.0

Changes:

--- /work/SRC/openSUSE:Factory/OpenSubdiv/OpenSubdiv.changes2019-09-20 
14:50:51.754910485 +0200
+++ /work/SRC/openSUSE:Factory/.OpenSubdiv.new.7948/OpenSubdiv.changes  
2019-09-23 12:39:54.537585367 +0200
@@ -1,0 +2,6 @@
+Sun Sep 22 10:52:23 UTC 2019 - Hans-Peter Jansen 
+
+- Use tbb-devel BuildRequires instead of cmake(TBB), the latter is not
+  available in Leap 15.x
+
+---



Other differences:
--
++ OpenSubdiv.spec ++
--- /var/tmp/diff_new_pack.hJWxaB/_old  2019-09-23 12:39:55.213585256 +0200
+++ /var/tmp/diff_new_pack.hJWxaB/_new  2019-09-23 12:39:55.213585256 +0200
@@ -13,9 +13,10 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
+
 %define pkgver %(v=%version; echo -n "${v//\./_}")
 %define libname libosdCPU%{pkgver}
 
@@ -30,16 +31,16 @@
 BuildRequires:  cmake >= 2.8.6
 BuildRequires:  gcc-c++
 BuildRequires:  pkgconfig
+BuildRequires:  tbb-devel
 BuildRequires:  pkgconfig(gl)
-BuildRequires:  pkgconfig(glu)
 BuildRequires:  pkgconfig(glew)
 BuildRequires:  pkgconfig(glfw3)
+BuildRequires:  pkgconfig(glu)
 BuildRequires:  pkgconfig(xcursor)
 BuildRequires:  pkgconfig(xi)
 BuildRequires:  pkgconfig(xinerama)
 BuildRequires:  pkgconfig(xrandr)
 BuildRequires:  pkgconfig(xxf86vm)
-BuildRequires:  cmake(TBB)
 
 %description
 %{name} is a set of libraries that implement subdivision surface




commit phpMyAdmin for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package phpMyAdmin for openSUSE:Factory 
checked in at 2019-09-23 12:39:12

Comparing /work/SRC/openSUSE:Factory/phpMyAdmin (Old)
 and  /work/SRC/openSUSE:Factory/.phpMyAdmin.new.7948 (New)


Package is "phpMyAdmin"

Mon Sep 23 12:39:12 2019 rev:159 rq:732410 version:4.9.1

Changes:

--- /work/SRC/openSUSE:Factory/phpMyAdmin/phpMyAdmin.changes2019-07-01 
10:44:30.809491035 +0200
+++ /work/SRC/openSUSE:Factory/.phpMyAdmin.new.7948/phpMyAdmin.changes  
2019-09-23 12:39:44.953586944 +0200
@@ -1,0 +2,19 @@
+Sat Sep 21 19:16:35 UTC 2019 - Andreas Stieger 
+
+- phpMyAdmin 4.9.1:
+  * CVE-2019-12922: hardening against CSRF (boo#1150914)
+  * Editing columns with CURRENT_TIMESTAMP for MySQL versions 8.0.13
+and newer
+  * Compatibility issues with PHP 8
+  * Export of GIS visualization
+  * Enhanced descriptions for several collation types
+  * Creating a user with a single quote in the password string
+  * Unexpected quotes during import and export on text fields
+  * Improvements to adding new tables to Designer
+  * Fix an issue where an authenticated user could trigger heavy
+traffic between the database server and web server
+  * Fix a weakness where an attacker, under certain conditions,
+working at the same time as an administrator is using the setup
+script, could delete a server from the setup script
+
+---

Old:

  phpMyAdmin-4.9.0.1-all-languages.tar.xz
  phpMyAdmin-4.9.0.1-all-languages.tar.xz.asc

New:

  phpMyAdmin-4.9.1-all-languages.tar.xz
  phpMyAdmin-4.9.1-all-languages.tar.xz.asc



Other differences:
--
++ phpMyAdmin.spec ++
--- /var/tmp/diff_new_pack.rH1Sme/_old  2019-09-23 12:39:45.481586857 +0200
+++ /var/tmp/diff_new_pack.rH1Sme/_new  2019-09-23 12:39:45.485586856 +0200
@@ -29,7 +29,7 @@
 %define ap_grp nogroup
 %endif
 Name:   phpMyAdmin
-Version:4.9.0.1
+Version:4.9.1
 Release:0
 Summary:Administration of MySQL over the web
 License:GPL-2.0-or-later

++ phpMyAdmin-4.9.0.1-all-languages.tar.xz -> 
phpMyAdmin-4.9.1-all-languages.tar.xz ++
 46966 lines of diff (skipped)





commit mosquitto for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package mosquitto for openSUSE:Factory 
checked in at 2019-09-23 12:39:09

Comparing /work/SRC/openSUSE:Factory/mosquitto (Old)
 and  /work/SRC/openSUSE:Factory/.mosquitto.new.7948 (New)


Package is "mosquitto"

Mon Sep 23 12:39:09 2019 rev:11 rq:732378 version:1.6.5

Changes:

--- /work/SRC/openSUSE:Factory/mosquitto/mosquitto.changes  2019-07-18 
15:19:42.180151743 +0200
+++ /work/SRC/openSUSE:Factory/.mosquitto.new.7948/mosquitto.changes
2019-09-23 12:39:42.765587304 +0200
@@ -1,0 +2,128 @@
+Sat Sep 21 14:38:08 UTC 2019 - Martin Hauke 
+
+- Update to version 1.6.5
+  Fix CVE-2019-11779:
+  * In Eclipse Mosquitto 1.5.0 to 1.6.5 inclusive, if a malicious MQTT
+client sends a SUBSCRIBE packet containing a topic that consists
+of approximately 65400 or more '/' characters, i.e. the topic
+hierarchy separator, then a stack overflow will occur.
+  Broker:
+  * Fix v5 DISCONNECT packets with remaining length == 2 being
+treated as a protocol error.
+  * Fix support for libwebsockets 3.x.
+  * Fix slow websockets performance when sending large messages.
+  * Fix clients authorised using `use_identity_as_username` or
+`use_subject_as_username` being disconnected on SIGHUP.
+  * Improve error messages in some situations when clients disconnect.
+Reduces the number of "Socket error on client X, disconnecting"
+messages.
+  * Fix Will for v5 clients not being sent if will delay interval was
+greater than the session expiry interval.
+  * Fix CRL file not being reloaded on HUP.
+  Client library:
+  * Fix reconnect backoff for the situation where connections are
+dropped rather than refused.
+  * Fix missing locks on `mosq->state`.
+
+- Update to version 1.6.4
+  Fix CVE-2019-11778:
+  * If an MQTT v5 client connects to Eclipse Mosquitto versions 1.6.0
+to 1.6.4 inclusive, sets a last will and testament, sets a will
+delay interval, sets a session expiry interval, and the will delay
+interval is set longer than the session expiry interval, then a
+use after free error occurs, which has the potential to cause a
+crash in some situations.
+  Broker:
+  * Fix incoming QoS 2 messages being blocked when
+`max_inflight_messages` was set to 1.
+  * Fix incoming messages not being removed for a client if the topic
+being published to does not have any subscribers.
+  Client library:
+  * Fix MQTT v5 subscription options being incorrectly set for
+MQTT v3 subscriptions.
+  * Make behaviour of `mosquitto_connect_async()` consistent with
+`mosquitto_connect()` when connecting to a non-existent server.
+  * `mosquitto_string_option(mosq, MOSQ_OPT_TLS_KEYFORM, ...)` was
+incorrectly returning `MOSQ_ERR_INVAL` with valid input. This has
+been fixed.
+  * on_connect callback is now called with the correct v5 reason code
+if a v5 client connects to a v3.x broker and is sent a CONNACK with
+the "unacceptable protocol version" connack reason code.
+  * Fix memory leak when setting v5 properties in mosquitto_connect_v5().
+  * Fix properties not being sent on QoS>0 PUBLISH messages.
+  Clients:
+  * mosquitto_pub: fix error codes not being returned when
+mosquitto_pub exits.
+  * All clients: improve error messages when connecting to a v3.x broker
+when in v5 mode.
+  Other:
+  - Various documentation fixes.
+
+- Update to version 1.6.3
+  Broker:
+  * Fix detection of incoming v3.1/v3.1.1 bridges.
+  * Fix default max_topic_alias listener config not being copied to
+the in-use listener when compiled without TLS support.
+  * Fix random number generation if compiling using `WITH_TLS=no` and
+on Linux with glibc >= 2.25. Without this fix, no random numbers
+would be generated for e.g. on broker client id generation, and so
+clients connecting expecting this feature would be unable to connect.
+  * Fix compilation problem related to `getrandom()` on non-glibc systems.
+  * Fix Will message for a persistent client incorrectly being sent when the
+client reconnects after a clean disconnect.
+  - Fix Will message for a persistent client not being sent on disconnect.
+  * Improve documentation around the upgrading of persistence files.
+  * Add 'extern "C"' on mosquitto_broker.h and mosquitto_plugin.h for
+C++ plugin writing.
+  * Fix persistent Websockets clients not receiving messages after they
+reconnect, having sent DISCONNECT on a previous session
+  * Disable TLS renegotiation. Client initiated renegotiation is considered to
+be a potential attack vector against servers.
+  * Fix incorrect shared subscription topic '$shared'.
+  * Fix zero length client ids being rejected for MQTT v5 clients with clean
+start set to true.
+  * Fix MQTT v5 overlapping subscription behaviour. Clients now 

commit doh for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package doh for openSUSE:Factory checked in 
at 2019-09-23 12:39:14

Comparing /work/SRC/openSUSE:Factory/doh (Old)
 and  /work/SRC/openSUSE:Factory/.doh.new.7948 (New)


Package is "doh"

Mon Sep 23 12:39:14 2019 rev:2 rq:732412 version:0.1

Changes:

--- /work/SRC/openSUSE:Factory/doh/doh.changes  2019-09-17 13:39:44.273820581 
+0200
+++ /work/SRC/openSUSE:Factory/.doh.new.7948/doh.changes2019-09-23 
12:39:47.273586562 +0200
@@ -1,0 +2,12 @@
+Tue Sep 17 21:08:59 UTC 2019 - Martin Hauke 
+
+- Update to initial upstream release 0.1:
+  * doh.1: initial man page
+  * doh: sort the -h options alphabetically
+  * version: add header file, support -V and call it version 0.1 now
+  * README: show the current cloudflare URL in the example output
+  * Update Google Public DNS DoH endpoint in example
+  * doh_encode: fix the comparison for long host names
+  * doh: added -k for insecure mode - skips server cert validation
+
+---

Old:

  _service
  _servicedata
  doh-0.0.0+git.20190908.tar.xz

New:

  doh-0.1.tar.gz



Other differences:
--
++ doh.spec ++
--- /var/tmp/diff_new_pack.Io3RLw/_old  2019-09-23 12:39:47.649586500 +0200
+++ /var/tmp/diff_new_pack.Io3RLw/_new  2019-09-23 12:39:47.649586500 +0200
@@ -1,6 +1,7 @@
 #
 # spec file for package doh
 #
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2019, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
@@ -17,14 +18,14 @@
 
 
 Name:   doh
-Version:0.0.0+git.20190908
+Version:0.1
 Release:0
 Summary:Simple DoH (DNS-over-HTTPS) client
 License:MIT
 Group:  Productivity/Networking/DNS/Utilities
 URL:https://github.com/curl/doh
 #Git-Clone: https://github.com/curl/doh.git
-Source: %{name}-%{version}.tar.xz
+Source: 
https://github.com/curl/%{name}/archive/%{name}-%{version}.tar.gz
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(libcurl)
 
@@ -34,7 +35,7 @@
 This code uses POST requests unconditionally for this.
 
 %prep
-%setup -q
+%setup -q -n doh-doh-%{version}
 
 %build
 export CFLAGS="%{optflags}"
@@ -42,10 +43,12 @@
 
 %install
 install -Dm 0755 doh %{buildroot}%{_bindir}/doh
+install -Dm 0644 doh.1 %{buildroot}%{_mandir}/man1/%{name}.1
 
 %files
 %license LICENSE
 %doc README.md
 %{_bindir}/doh
+%{_mandir}/man1/%{name}.1%{?ext_man}
 
 %changelog




commit kig for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package kig for openSUSE:Factory checked in 
at 2019-09-23 12:39:07

Comparing /work/SRC/openSUSE:Factory/kig (Old)
 and  /work/SRC/openSUSE:Factory/.kig.new.7948 (New)


Package is "kig"

Mon Sep 23 12:39:07 2019 rev:107 rq:732357 version:19.08.1

Changes:

--- /work/SRC/openSUSE:Factory/kig/kig.changes  2019-09-11 10:29:24.587400469 
+0200
+++ /work/SRC/openSUSE:Factory/.kig.new.7948/kig.changes2019-09-23 
12:39:41.485587514 +0200
@@ -1,0 +2,6 @@
+Sat Sep 21 11:42:07 UTC 2019 - Wolfgang Bauer 
+
+- Set Boost_NO_BOOST_CMAKE for cmake to fix build with latest boost
+  in Factory
+
+---



Other differences:
--
++ kig.spec ++
--- /var/tmp/diff_new_pack.gLlY9L/_old  2019-09-23 12:39:42.589587333 +0200
+++ /var/tmp/diff_new_pack.gLlY9L/_new  2019-09-23 12:39:42.593587332 +0200
@@ -76,7 +76,7 @@
 %setup -q
 
 %build
-  %cmake_kf5 -d build
+  %cmake_kf5 -d build -- -DBoost_NO_BOOST_CMAKE=ON
   %make_jobs
 
 %install






commit openSUSE-release-tools for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package openSUSE-release-tools for 
openSUSE:Factory checked in at 2019-09-23 12:38:52

Comparing /work/SRC/openSUSE:Factory/openSUSE-release-tools (Old)
 and  /work/SRC/openSUSE:Factory/.openSUSE-release-tools.new.7948 (New)


Package is "openSUSE-release-tools"

Mon Sep 23 12:38:52 2019 rev:220 rq:732304 version:20190920.155606e3

Changes:

--- 
/work/SRC/openSUSE:Factory/openSUSE-release-tools/openSUSE-release-tools.changes
2019-09-20 14:52:37.750889387 +0200
+++ 
/work/SRC/openSUSE:Factory/.openSUSE-release-tools.new.7948/openSUSE-release-tools.changes
  2019-09-23 12:39:27.725589778 +0200
@@ -1,0 +2,37 @@
+Fri Sep 20 11:05:25 UTC 2019 - opensuse-releaset...@opensuse.org
+
+- Update to version 20190920.155606e3:
+  * factory-package-news: fixes for Tumbleweed
+
+---
+Thu Sep 19 07:51:10 UTC 2019 - opensuse-releaset...@opensuse.org
+
+- Update to version 20190919.8df44507:
+  * gocd/monitors: *.OriginManagerUpdate: set timeout to 10 minutes.
+
+---
+Thu Sep 19 01:32:31 UTC 2019 - opensuse-releaset...@opensuse.org
+
+- Update to version 20190918.c185be8c:
+  * ReviewBot: add_review(): handle 403 as expected when superseded/rovoked.
+
+---
+Thu Sep 19 00:54:16 UTC 2019 - opensuse-releaset...@opensuse.org
+
+- Update to version 20190918.abb40adc:
+  * ReviewBot: _set_review(): handle review being revoked or superseded.
+
+---
+Thu Sep 19 00:39:15 UTC 2019 - opensuse-releaset...@opensuse.org
+
+- Update to version 20190918.abd6f65f:
+  * osclib/core: request_create_delete(): utilize pusedo osc.core function.
+  * osclib/core: provide create_delete_request().
+
+---
+Wed Sep 18 22:21:43 UTC 2019 - opensuse-releaset...@opensuse.org
+
+- Update to version 20190918.d0e2b71e:
+  * osclib/origin_listener: skip patchinfo packages.
+
+---

Old:

  openSUSE-release-tools-20190918.1d4c6836.obscpio

New:

  openSUSE-release-tools-20190920.155606e3.obscpio



Other differences:
--
++ openSUSE-release-tools.spec ++
--- /var/tmp/diff_new_pack.018JBy/_old  2019-09-23 12:39:28.261589690 +0200
+++ /var/tmp/diff_new_pack.018JBy/_new  2019-09-23 12:39:28.265589689 +0200
@@ -20,7 +20,7 @@
 %define source_dir openSUSE-release-tools
 %define announcer_filename factory-package-news
 Name:   openSUSE-release-tools
-Version:20190918.1d4c6836
+Version:20190920.155606e3
 Release:0
 Summary:Tools to aid in staging and release work for openSUSE/SUSE
 License:GPL-2.0-or-later AND MIT

++ _servicedata ++
--- /var/tmp/diff_new_pack.018JBy/_old  2019-09-23 12:39:28.309589682 +0200
+++ /var/tmp/diff_new_pack.018JBy/_new  2019-09-23 12:39:28.309589682 +0200
@@ -1,6 +1,6 @@
 
   
 https://github.com/openSUSE/openSUSE-release-tools.git
-3175c0d7f678933f2c0d4124cf00aad0d56d8fd8
+155606e3d848327ec20ff6713282a1dc54ae7484
   
 

++ openSUSE-release-tools-20190918.1d4c6836.obscpio -> 
openSUSE-release-tools-20190920.155606e3.obscpio ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/openSUSE-release-tools-20190918.1d4c6836/ReviewBot.py 
new/openSUSE-release-tools-20190920.155606e3/ReviewBot.py
--- old/openSUSE-release-tools-20190918.1d4c6836/ReviewBot.py   2019-09-18 
23:59:51.0 +0200
+++ new/openSUSE-release-tools-20190920.155606e3/ReviewBot.py   2019-09-20 
13:02:48.0 +0200
@@ -268,10 +268,15 @@
 if doit == True:
 self.logger.debug("setting %s to %s"%(req.reqid, state))
 if not self.dryrun:
-osc.core.change_review_state(apiurl = self.apiurl,
+try:
+osc.core.change_review_state(apiurl=self.apiurl,
 reqid = req.reqid, newstate = newstate,
 by_group=self.review_group,
 by_user=self.review_user, message=msg)
+except HTTPError as e:
+if e.code != 403:
+raise e
+self.logger.info('unable to change review state (likely 
superseded or revoked)')
 else:
 self.logger.debug("%s review not changed"%(req.reqid))
 
@@ -317,7 +322,15 @@
 key = request_action_key(self.action)
 msg = yaml.dump({key: msg}, default_flow_style=False)
 
-r = 

commit terraform for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package terraform for openSUSE:Factory 
checked in at 2019-09-23 12:39:06

Comparing /work/SRC/openSUSE:Factory/terraform (Old)
 and  /work/SRC/openSUSE:Factory/.terraform.new.7948 (New)


Package is "terraform"

Mon Sep 23 12:39:06 2019 rev:9 rq:732354 version:0.12.9

Changes:

--- /work/SRC/openSUSE:Factory/terraform/terraform.changes  2019-09-17 
13:39:40.029821258 +0200
+++ /work/SRC/openSUSE:Factory/.terraform.new.7948/terraform.changes
2019-09-23 12:39:37.521588166 +0200
@@ -1,0 +2,15 @@
+Wed Sep 18 06:27:30 UTC 2019 - Petr Cervinka 
+
+- Update to 0.12.9
+  NOTES:
+   * core: `ignore_changes` is now processed (in addition to existing 
behaviors) before the provider plan is run. This means that users may see fewer 
planned changes when using `ignore_changes`, as before this change, changes to 
ignored attributes were still being sent to CustomizeDiff in providers (which 
could mean cascading changes for some resources). This should be indicative 
that providers are no longer getting changes that were marked as ignored, but 
if unexpected plans are seen while using `ignore_changes`, investigate the 
settings in the `ignore_changes` block to ensure the appropriate attributes are 
set. ([#22520](https://github.com/hashicorp/terraform/issues/22520))
+  ENHANCEMENTS:
+   * provisioners/habitat: `accept_license` argument available to automate 
accepting the EULA, now required by this client 
([#22745](https://github.com/hashicorp/terraform/issues/22745))
+   * config: add source addressing to unknown value errors in `for_each` 
([#22760](https://github.com/hashicorp/terraform/issues/22760))
+  BUG FIXES:
+   * command/console: support -var and -var-file flags 
([#22145](https://github.com/hashicorp/terraform/issues/22145))
+   * command/show: Fixed bug with wrong errors being returned or swallowed. 
([#22772](https://github.com/hashicorp/terraform/issues/22772))
+   * config: The `cidrhost`, `cidrsubnet`, and `cidrnetmask` functions now 
behave correctly with IPv6 prefixes that are short enough for the host portion 
to be greater than 64-bit or 32-bit (depending on the target architecture). 
([#22505](https://github.com/hashicorp/terraform/issues/22505))
+   * config: Fixed bug on empty sets with `for_each` 
([#22281](https://github.com/hashicorp/terraform/issues/22281)) 
+
+---

Old:

  terraform-0.12.8.obscpio
  terraform-0.12.8.tar.xz

New:

  terraform-0.12.9.obscpio
  terraform-0.12.9.tar.xz



Other differences:
--
++ terraform.spec ++
--- /var/tmp/diff_new_pack.TAhHyY/_old  2019-09-23 12:39:38.933587934 +0200
+++ /var/tmp/diff_new_pack.TAhHyY/_new  2019-09-23 12:39:38.937587934 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   terraform
-Version:0.12.8
+Version:0.12.9
 Release:0
 Summary:Tool for building infrastructure safely and efficiently
 License:MPL-2.0

++ _service ++
--- /var/tmp/diff_new_pack.TAhHyY/_old  2019-09-23 12:39:38.961587929 +0200
+++ /var/tmp/diff_new_pack.TAhHyY/_new  2019-09-23 12:39:38.961587929 +0200
@@ -3,8 +3,8 @@
 https://github.com/hashicorp/terraform.git
 git
 terraform
-0.12.8
-v0.12.8
+0.12.9
+v0.12.9
 .git
   
   

++ terraform-0.12.8.obscpio -> terraform-0.12.9.obscpio ++
/work/SRC/openSUSE:Factory/terraform/terraform-0.12.8.obscpio 
/work/SRC/openSUSE:Factory/.terraform.new.7948/terraform-0.12.9.obscpio differ: 
char 49, line 1

++ terraform-0.12.8.tar.xz -> terraform-0.12.9.tar.xz ++
 47630 lines of diff (skipped)

++ terraform.obsinfo ++
--- /var/tmp/diff_new_pack.TAhHyY/_old  2019-09-23 12:39:41.329587540 +0200
+++ /var/tmp/diff_new_pack.TAhHyY/_new  2019-09-23 12:39:41.329587540 +0200
@@ -1,5 +1,5 @@
 name: terraform
-version: 0.12.8
-mtime: 1567621057
-commit: e97ad4ebef504883229a1c299be617dfb7bec017
+version: 0.12.9
+mtime: 1568747942
+commit: abec0acf40d8e31ac612a244cf3886fb3bcce0bb
 




commit python-rarfile for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package python-rarfile for openSUSE:Factory 
checked in at 2019-09-23 12:39:11

Comparing /work/SRC/openSUSE:Factory/python-rarfile (Old)
 and  /work/SRC/openSUSE:Factory/.python-rarfile.new.7948 (New)


Package is "python-rarfile"

Mon Sep 23 12:39:11 2019 rev:2 rq:732398 version:3.1

Changes:

--- /work/SRC/openSUSE:Factory/python-rarfile/python-rarfile.changes
2017-04-14 13:34:55.559092621 +0200
+++ /work/SRC/openSUSE:Factory/.python-rarfile.new.7948/python-rarfile.changes  
2019-09-23 12:39:43.445587192 +0200
@@ -1,0 +2,6 @@
+Sat Sep 21 13:58:36 UTC 2019 - Luigi Baldoni 
+
+- Update to version 3.1 (no changelog available)
+- Spec cleanup
+
+---

Old:

  rarfile-3.0.tar.gz

New:

  rarfile-3.1.tar.gz



Other differences:
--
++ python-rarfile.spec ++
--- /var/tmp/diff_new_pack.QIBzJ4/_old  2019-09-23 12:39:44.021587097 +0200
+++ /var/tmp/diff_new_pack.QIBzJ4/_new  2019-09-23 12:39:44.021587097 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-rarfile
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,26 +12,25 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-rarfile
-Version:3.0
+Version:3.1
 Release:0
 Summary:RAR Archive Reader for Python
 License:ISC
 Group:  Development/Languages/Python
-Url:https://rarfile.readthedocs.org/
-Source0:
https://pypi.io/packages/source/r/rarfile/rarfile-%{version}.tar.gz
+URL:https://rarfile.readthedocs.org/
+Source0:
https://files.pythonhosted.org/packages/source/r/rarfile/rarfile-%{version}.tar.gz
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
 BuildRequires:  python3-Sphinx >= 1.3
 Requires:   bsdtar
 Recommends: unrar
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
 %python_subpackages
 
@@ -59,21 +58,19 @@
 %python_build
 make %{?_smp_mflags} -C doc html
 rm doc/_build/html/.buildinfo
-sed -i 's/\r$//' doc/_build/html/objects.inv
 
 %install
 %python_install
 %python_expand %fdupes -s %{buildroot}%{$python_sitelib}
 
 %files %{python_files}
-%defattr(-,root,root,-)
-%doc LICENSE
+%license LICENSE
 %pycache_only %{python_sitelib}/__pycache__/rarfile.*.py*
 %{python_sitelib}/rarfile.py*
 %{python_sitelib}/rarfile-%{version}-py%{python_version}.egg-info
 
 %files %{python_files doc}
-%defattr(-,root,root,-)
-%doc LICENSE doc/_build/html/
+%license LICENSE
+%doc doc/_build/html/
 
 %changelog

++ rarfile-3.0.tar.gz -> rarfile-3.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/rarfile-3.0/LICENSE new/rarfile-3.1/LICENSE
--- old/rarfile-3.0/LICENSE 2016-06-08 22:14:13.0 +0200
+++ new/rarfile-3.1/LICENSE 2019-09-15 15:51:09.0 +0200
@@ -1,5 +1,5 @@
 
-Copyright (c) 2005-2016 Marko Kreen 
+Copyright (c) 2005-2019 Marko Kreen 
 
 Permission to use, copy, modify, and/or distribute this software for any
 purpose with or without fee is hereby granted, provided that the above
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/rarfile-3.0/MANIFEST.in new/rarfile-3.1/MANIFEST.in
--- old/rarfile-3.0/MANIFEST.in 2016-06-08 22:14:13.0 +0200
+++ new/rarfile-3.1/MANIFEST.in 2019-03-29 12:45:00.0 +0100
@@ -1,3 +1,3 @@
 include README.rst Makefile MANIFEST.in LICENSE dumprar.py
 include doc/*.rst doc/Makefile doc/conf.py doc/make.bat
-include test/Makefile test/*.sh test/files/*.rar test/files/*.exp
+include test/Makefile test/*.sh test/files/*.rar test/files/*.r[0-9][0-9] 
test/files/*.exp
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/rarfile-3.0/Makefile new/rarfile-3.1/Makefile
--- old/rarfile-3.0/Makefile2016-06-08 23:49:55.0 +0200
+++ new/rarfile-3.1/Makefile2019-09-15 14:42:30.0 +0200
@@ -1,15 +1,19 @@
 
+VER := $(shell python3 setup.py --version)
+TGZ = dist/rarfile-$(VER).tar.gz
+
 prefix = /usr/local
 
 all:
pyflakes3 rarfile.py
-   tox
+   tox -e lint
+  

commit utox for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package utox for openSUSE:Factory checked in 
at 2019-09-23 12:39:29

Comparing /work/SRC/openSUSE:Factory/utox (Old)
 and  /work/SRC/openSUSE:Factory/.utox.new.7948 (New)


Package is "utox"

Mon Sep 23 12:39:29 2019 rev:2 rq:732477 version:0.17.1

Changes:

--- /work/SRC/openSUSE:Factory/utox/utox.changes2019-02-28 
21:38:16.937642471 +0100
+++ /work/SRC/openSUSE:Factory/.utox.new.7948/utox.changes  2019-09-23 
12:39:53.597585522 +0200
@@ -1,0 +2,39 @@
+Sun Sep 22 07:28:50 UTC 2019 - Andrey Karepin 
+
+- update utox.keyring
+- update to 0.17.1
+  * Add --allow-root option: Now you can't run uTox as root by accident 
(1b491cd)
+  * Add right click menu to Xlib (5f5f570)
+  *  Add support for loading groupchats (049ca56)
+  * More *BSD support! (FreeBSD, NetBSD, OpenBSD, DragonFlyBSD) (@mazocomp)
+  * Groupchat creation screen implemented
+  * Fix a crash when changing to a video input device that fails to init 
(e36e475)
+  * Fix: a friendlist bug related to the Tox profile having no friends and
+groups (d81d276)
+  * Don't flip video preview button status if preview fails (8f73ee2)
+  * Xlib: Clean up zombies if xdg-open is not installed (dfc5f50)
+  * Add border to QR code to make it actually readable to QR code scanners
+(3643744)
+  * Fix file transfer text (72b7347)
+  * Prevent a crash related to having too many friends (1e41307)
+  * Fix crash related to dropdowns (b0b3167)
+  * Fix ignoring friend requests (ed55880)
+  * Close dropdowns on changing tabs (4dd4ae0)
+  * Fix crash on startup related to QR code (@ColumPaget) (41c5044)
+  * Fix group settings layout
+  * Fix a crash related to Tox savedata being too large (363e486)
+  * Fix two possible memory leaks (a549f11 168eb78)
+  * Fix a crash related to text undo in message input field (@cyisfor) 
(e1371e4)
+  * Fix a crash related to the password input field (8891616)
+  * Fix crash related to FPS value input field (d297e0d)
+  * Fix selection bug: Selection on double-click doesn't leak into neighbouring
+line anymore (06f85ab)
+  * Fix HOME key (3833c13)
+  * Fix END key and make ctrl+shift+end work (6fa9df6)
+  * Sort languages enum by their native names alphabetically (b8d33d4)
+  * Move Language setting from "Profile" to "User Interface" tab (234f027)
+  * Updated translations: German (d96d309 4328777 9757f05),  English (e2901e8),
+Polish (96f7c02 542b19a), Swedish (@jony0008) (eda5a41 38e4ae7), Hungarian
+(@baloo79) (9d9f24b)
+
+---

Old:

  uTox-0.17.0-full.tar.gz
  uTox-0.17.0-full.tar.gz.asc

New:

  uTox-0.17.1-full.tar.gz
  uTox-0.17.1-full.tar.gz.asc



Other differences:
--
++ utox.spec ++
--- /var/tmp/diff_new_pack.9DvaGg/_old  2019-09-23 12:39:53.989585457 +0200
+++ /var/tmp/diff_new_pack.9DvaGg/_new  2019-09-23 12:39:53.989585457 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package utox
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,14 +18,14 @@
 
 %define realname uTox
 Name:   utox
-Version:0.17.0
+Version:0.17.1
 Release:0
 Summary:The lightweight Tox client
 License:MIT
 Group:  Productivity/Networking/Instant Messenger
 URL:https://utox.org/
 Source: 
https://github.com/uTox/uTox/releases/download/v%{version}/%{realname}-%{version}-full.tar.gz
-Source1:
https://github.com/uTox/uTox/releases/download/v0.17.0/uTox-0.17.0-full.tar.gz.asc
+Source1:
https://github.com/uTox/uTox/releases/download/v%{version}/%{realname}-%{version}-full.tar.gz.asc
 Source2:uTox.keyring
 BuildRequires:  c-toxcore-devel
 BuildRequires:  cmake >= 3.2
@@ -55,7 +55,10 @@
 
 %build
 %cmake \
-  -DENABLE_ASAN=OFF
+  -DENABLE_ASAN=OFF \
+  -DENABLE_TESTS=OFF \
+  -DENABLE_AUTOUPDATE=OFF \
+  -DENABLE_LTO=ON
 %make_jobs V=1
 
 %install

++ uTox-0.17.0-full.tar.gz -> uTox-0.17.1-full.tar.gz ++
 317784 lines of diff (skipped)

++ uTox.keyring ++
--- /var/tmp/diff_new_pack.9DvaGg/_old  2019-09-23 12:39:54.445585382 +0200
+++ /var/tmp/diff_new_pack.9DvaGg/_new  2019-09-23 12:39:54.445585382 +0200
@@ -1,104 +1,57 @@
-pub   rsa4096/0x601A604B7E605776 2015-10-04 [SCA]
-  Key fingerprint = B700 8FF1 2C07 9BF6 E6EA  19D1 601A 604B 7E60 5776
-uid   [ unknown] Robin Lindén 
-uid   [ unknown] Robin Lindén <_...@robinlinden.eu>
-uid   [ unknown] Robin 

commit miller for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package miller for openSUSE:Factory checked 
in at 2019-09-23 12:39:27

Comparing /work/SRC/openSUSE:Factory/miller (Old)
 and  /work/SRC/openSUSE:Factory/.miller.new.7948 (New)


Package is "miller"

Mon Sep 23 12:39:27 2019 rev:8 rq:732427 version:5.6.2

Changes:

--- /work/SRC/openSUSE:Factory/miller/miller.changes2019-09-13 
15:04:06.933272078 +0200
+++ /work/SRC/openSUSE:Factory/.miller.new.7948/miller.changes  2019-09-23 
12:39:52.449585711 +0200
@@ -1,0 +2,7 @@
+Sun Sep 22 04:53:59 UTC 2019 - Luigi Baldoni 
+
+- Update to version 5.6.2
+  * #271 fixes a corner-case bug with more than 100 CSV/TSV files
+with headers of varying lengths.
+
+---

Old:

  miller-5.6.0.tar.gz

New:

  miller-5.6.2.tar.gz



Other differences:
--
++ miller.spec ++
--- /var/tmp/diff_new_pack.chlwLn/_old  2019-09-23 12:39:52.917585633 +0200
+++ /var/tmp/diff_new_pack.chlwLn/_new  2019-09-23 12:39:52.921585633 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   miller
-Version:5.6.0
+Version:5.6.2
 Release:0
 Summary:Name-indexed data processing tool
 # c/lib/netbsd_strptime.c is BSD-4-Clause

++ miller-5.6.0.tar.gz -> miller-5.6.2.tar.gz ++
 23285 lines of diff (skipped)




commit libacars for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package libacars for openSUSE:Factory 
checked in at 2019-09-23 12:38:53

Comparing /work/SRC/openSUSE:Factory/libacars (Old)
 and  /work/SRC/openSUSE:Factory/.libacars.new.7948 (New)


Package is "libacars"

Mon Sep 23 12:38:53 2019 rev:4 rq:732325 version:1.3.1

Changes:

--- /work/SRC/openSUSE:Factory/libacars/libacars.changes2019-08-27 
10:28:05.191911293 +0200
+++ /work/SRC/openSUSE:Factory/.libacars.new.7948/libacars.changes  
2019-09-23 12:39:30.009589402 +0200
@@ -1,0 +2,8 @@
+Fri Sep 20 19:13:04 UTC 2019 - Martin Hauke 
+
+- Update to version 1.3.1
+  * Downgraded optimization level for release builds from -O3 to
+-O2 to reduce chances of similar problems for cross-platform
+builds.
+
+---

Old:

  libacars-1.3.0.tar.gz

New:

  libacars-1.3.1.tar.gz



Other differences:
--
++ libacars.spec ++
--- /var/tmp/diff_new_pack.sFx6zD/_old  2019-09-23 12:39:30.413589336 +0200
+++ /var/tmp/diff_new_pack.sFx6zD/_new  2019-09-23 12:39:30.413589336 +0200
@@ -20,7 +20,7 @@
 %define sover   1
 %define libname libacars%{sover}
 Name:   libacars
-Version:1.3.0
+Version:1.3.1
 Release:0
 Summary:A library for decoding various ACARS message payloads
 License:MIT

++ libacars-1.3.0.tar.gz -> libacars-1.3.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libacars-1.3.0/CHANGELOG.md 
new/libacars-1.3.1/CHANGELOG.md
--- old/libacars-1.3.0/CHANGELOG.md 2019-08-09 15:20:33.0 +0200
+++ new/libacars-1.3.1/CHANGELOG.md 2019-09-20 20:35:01.0 +0200
@@ -1,5 +1,12 @@
 # ChangeLog
 
+## Version 1.3.1 (2019-09-20):
+* Binary releases for Windows were mistakenly built with AVX instruction set
+  enabled which caused the lib to fail on older CPUs 
(https://github.com/szpajder/libacars/issues/3).
+  Thanks to G7GQW for reporting and to Jonti Olds for analysis.
+* Downgraded optimization level for release builds from -O3 to -O2 to reduce
+  chances of similar problems for cross-platform builds.
+
 ## Version 1.3.0 (2019-08-09):
 * JSON output support for all message types. Any protocol tree can be
   serialized into a JSON string with `la_proto_tree_format_json()` function.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libacars-1.3.0/CMakeLists.txt 
new/libacars-1.3.1/CMakeLists.txt
--- old/libacars-1.3.0/CMakeLists.txt   2019-08-09 15:20:33.0 +0200
+++ new/libacars-1.3.1/CMakeLists.txt   2019-09-20 20:35:01.0 +0200
@@ -3,7 +3,7 @@
 
 set (LA_VERSION_MAJOR 1)
 set (LA_VERSION_MINOR 3)
-set (LA_VERSION_PATCH 0)
+set (LA_VERSION_PATCH 1)
 set (LA_VERSION "${LA_VERSION_MAJOR}.${LA_VERSION_MINOR}.${LA_VERSION_PATCH}"
 )
 set (CMAKE_C_STANDARD 11)
@@ -22,6 +22,7 @@
 
 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra")
 set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DDEBUG")
+set(CMAKE_C_FLAGS_RELEASE "-O2 -DNDEBUG")
 
 if(MINGW)
add_definitions(-D__USE_MINGW_ANSI_STDIO=1)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libacars-1.3.0/README.md new/libacars-1.3.1/README.md
--- old/libacars-1.3.0/README.md2019-08-09 15:20:33.0 +0200
+++ new/libacars-1.3.1/README.md2019-09-20 20:35:01.0 +0200
@@ -2,7 +2,7 @@
 
 libacars is a library for decoding ACARS message contents.
 
-Current stable version: **1.3.0** (released Aug 9, 2019)
+Current stable version: **1.3.1** (released Sep 20, 2019)
 
 ## Supported message types
 




commit drpm for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package drpm for openSUSE:Factory checked in 
at 2019-09-23 12:38:44

Comparing /work/SRC/openSUSE:Factory/drpm (Old)
 and  /work/SRC/openSUSE:Factory/.drpm.new.7948 (New)


Package is "drpm"

Mon Sep 23 12:38:44 2019 rev:2 rq:732265 version:0.4.1

Changes:

--- /work/SRC/openSUSE:Factory/drpm/drpm.changes2019-09-13 
14:58:36.201277960 +0200
+++ /work/SRC/openSUSE:Factory/.drpm.new.7948/drpm.changes  2019-09-23 
12:39:24.185590360 +0200
@@ -1,0 +2,15 @@
+Sat Sep 21 02:31:40 UTC 2019 - Neal Gompa 
+
+- Rework zstd enablement conditional and simplify it
+
+---
+Sat Sep 21 02:27:26 UTC 2019 - Neal Gompa 
+
+- Fix the conditional for disabling zstd for Leap 15.1 and lower
+
+---
+Fri Sep 13 18:04:04 UTC 2019 - Neal Gompa 
+
+- Disable zstd for Leap 15.1 and lower due to broken zstd
+
+---



Other differences:
--
++ drpm.spec ++
--- /var/tmp/diff_new_pack.zQYeBE/_old  2019-09-23 12:39:24.513590306 +0200
+++ /var/tmp/diff_new_pack.zQYeBE/_new  2019-09-23 12:39:24.517590306 +0200
@@ -27,11 +27,11 @@
 %bcond_without tests
 %endif
 
-%if (0%{?suse_version} && 0%{?suse_version} < 1500) || (0%{?is_opensuse} == 0 
&& 0%{?suse_version} == 1500)
-# Disable zstd for SLE 15 and older
-%bcond_with zstd
-%else
+%if 0%{?suse_version} > 1500 || 0%{?sle_version} >= 150200
+# Enable zstd when not SLE 15.1 and older
 %bcond_without zstd
+%else
+%bcond_with zstd
 %endif
 
 Name:   drpm




commit treeline for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package treeline for openSUSE:Factory 
checked in at 2019-09-23 12:38:16

Comparing /work/SRC/openSUSE:Factory/treeline (Old)
 and  /work/SRC/openSUSE:Factory/.treeline.new.7948 (New)


Package is "treeline"

Mon Sep 23 12:38:16 2019 rev:24 rq:732182 version:3.1.1

Changes:

--- /work/SRC/openSUSE:Factory/treeline/treeline.changes2016-02-26 
00:46:22.0 +0100
+++ /work/SRC/openSUSE:Factory/.treeline.new.7948/treeline.changes  
2019-09-23 12:39:06.341593296 +0200
@@ -1,0 +2,7 @@
+Fri Sep 20 08:57:19 UTC 2019 - Christophe Giboudeaux 
+
+- Update to 3.1.1 to use PyQt5 instead of PyQt4.
+  * No changelog available
+- Run spec-cleaner
+
+---

Old:

  treeline-2.0.2.tar.gz
  treeline.desktop
  treeline.png

New:

  treeline-3.1.1.tar.gz



Other differences:
--
++ treeline.spec ++
--- /var/tmp/diff_new_pack.6Z1TrH/_old  2019-09-23 12:39:06.677593241 +0200
+++ /var/tmp/diff_new_pack.6Z1TrH/_new  2019-09-23 12:39:06.681593240 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package treeline
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,30 +12,27 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   treeline
-Version:2.0.2
+Version:3.1.1
 Release:0
 Summary:Versatile Tree-Style Outliner for Defining Custom Data Schemas
-License:GPL-2.0+
+License:GPL-2.0-or-later
 Group:  Productivity/Office/Other
-Url:http://treeline.bellz.org
-Source0:
http://sourceforge.net/projects/treeline/files/%{version}/treeline-%{version}.tar.gz
-Source1:%{name}.desktop
-Source2:x-%{name}.desktop
-Source3:x-%{name}-gz.desktop
-Source4:x-treepad.desktop
-Source5:treeline.png
+URL:https://treeline.bellz.org
+Source0:
https://github.com/doug-101/TreeLine/releases/download/v%{version}/%{name}-%{version}.tar.gz
+Source1:x-%{name}.desktop
+Source2:x-%{name}-gz.desktop
+Source3:x-treepad.desktop
 Source99:   treeline-rpmlintrc
 BuildRequires:  fdupes
 BuildRequires:  perl
 BuildRequires:  python3-devel
 BuildRequires:  update-desktop-files
-Requires:   python3-qt4
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+Requires:   python3-qt5
 BuildArch:  noarch
 
 %description
@@ -75,6 +72,7 @@
 %install
 python3 install.py -x \
-p "%{_prefix}" \
+   -i "%{_datadir}/%{name}/icons" \
-d "%{_docdir}/%{name}" \
-b %{buildroot}
 
@@ -84,31 +82,34 @@
 
 install -d "%{buildroot}%{_datadir}/mimelnk/application"
 install -m0644 \
+"%{SOURCE1}" \
 "%{SOURCE2}" \
 "%{SOURCE3}" \
-"%{SOURCE4}" \
 "%{buildroot}%{_datadir}/mimelnk/application/"
 
-install -D -m0644 "%{SOURCE5}" "%{buildroot}%{_datadir}/pixmaps/treeline.png"
-
 %suse_update_desktop_file -i treeline Office ProjectManagement
 
 %fdupes -s "%{buildroot}%{_datadir}"
 
-find %{buildroot}%{_docdir} -type f -name "INSTALL" -print -delete
+rm -f %{buildroot}%{_docdir}/%{name}/{INSTALL,LICENSE}
 
 %files
-%defattr(-,root,root,-)
+%license doc/LICENSE
+%dir %{_datadir}/icons/hicolor
+%dir %{_datadir}/icons/hicolor/48x48
+%dir %{_datadir}/icons/hicolor/48x48/apps
+%dir %{_datadir}/icons/hicolor/scalable
+%dir %{_datadir}/icons/hicolor/scalable/apps
+%dir %{_datadir}/mimelnk
+%dir %{_datadir}/mimelnk/application
 %doc %{_docdir}/%{name}
 %{_bindir}/treeline
-%{_datadir}/treeline/
 %{_datadir}/applications/%{name}.desktop
-%{_datadir}/pixmaps/treeline.png
-%{_datadir}/icons/treeline
-%dir %{_datadir}/mimelnk
-%dir %{_datadir}/mimelnk/application
+%{_datadir}/icons/hicolor/48x48/apps/treeline-icon.png
+%{_datadir}/icons/hicolor/scalable/apps/treeline-icon.svg
 %{_datadir}/mimelnk/application/x-treeline-gz.desktop
 %{_datadir}/mimelnk/application/x-treeline.desktop
 %{_datadir}/mimelnk/application/x-treepad.desktop
+%{_datadir}/treeline/
 
 %changelog

++ treeline-2.0.2.tar.gz -> treeline-3.1.1.tar.gz ++
 43730 lines of diff (skipped)




commit mopac7 for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package mopac7 for openSUSE:Factory checked 
in at 2019-09-23 12:38:22

Comparing /work/SRC/openSUSE:Factory/mopac7 (Old)
 and  /work/SRC/openSUSE:Factory/.mopac7.new.7948 (New)


Package is "mopac7"

Mon Sep 23 12:38:22 2019 rev:6 rq:732206 version:1.15

Changes:

--- /work/SRC/openSUSE:Factory/mopac7/mopac7.changes2019-06-01 
09:48:49.199338211 +0200
+++ /work/SRC/openSUSE:Factory/.mopac7.new.7948/mopac7.changes  2019-09-23 
12:39:07.549593097 +0200
@@ -1,0 +2,5 @@
+Fri Sep 20 14:30:54 UTC 2019 - Martin Pluskal 
+
+- Modernise spec file by using latest macros
+
+---



Other differences:
--
++ mopac7.spec ++
--- /var/tmp/diff_new_pack.z4sAIH/_old  2019-09-23 12:39:07.989593025 +0200
+++ /var/tmp/diff_new_pack.z4sAIH/_new  2019-09-23 12:39:07.989593025 +0200
@@ -23,7 +23,7 @@
 Summary:Semi-empirical quantum mechanics suite
 License:SUSE-Public-Domain
 Group:  Productivity/Scientific/Chemistry
-Url:http://sourceforge.net/projects/mopac7/
+URL:https://sourceforge.net/projects/mopac7/
 Source0:
http://www.bioinformatics.org/ghemical/download/current/%{name}-%{version}.tar.gz
 Patch1: mopac7-1.14-random_data.patch
 Patch2: mopac7-1.14-libdir.patch
@@ -67,10 +67,7 @@
 This package contains development files.
 
 %prep
-%setup -q
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
+%autosetup -p1
 
 %build
 autoreconf -fiv
@@ -78,7 +75,7 @@
 export FFLAGS="%{optflags} -std=legacy -fno-automatic"
 %configure \
   --disable-static
-make %{?_smp_mflags}
+%make_build
 
 %install
 %make_install
@@ -92,22 +89,15 @@
 %postun -n %{libname} -p /sbin/ldconfig
 
 %files
-%defattr(-,root,root)
 %doc AUTHORS ChangeLog NEWS README tests
-%if 0%{?suse_version} >= 01500
-%license COPYING
-%else
-%doc COPYING
-%endif
 %attr(755,root,root) %{_bindir}/run_mopac7
 %{_bindir}/%{name}
 
 %files -n %{libname}
-%defattr(-,root,root)
+%license COPYING
 %{_libdir}/libmopac7.so.*
 
 %files -n %{libname}-devel
-%defattr(-,root,root)
 %{_includedir}/%{name}
 %{_libdir}/libmopac7.so
 %{_libdir}/pkgconfig/libmopac7.pc




commit python-watcherclient for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package python-watcherclient for 
openSUSE:Factory checked in at 2019-09-23 12:37:42

Comparing /work/SRC/openSUSE:Factory/python-watcherclient (Old)
 and  /work/SRC/openSUSE:Factory/.python-watcherclient.new.7948 (New)


Package is "python-watcherclient"

Mon Sep 23 12:37:42 2019 rev:3 rq:732097 version:2.2.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-watcherclient/python-watcherclient.changes
2019-05-03 22:43:27.791372412 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-watcherclient.new.7948/python-watcherclient.changes
  2019-09-23 12:38:39.845597655 +0200
@@ -1,0 +2,5 @@
+Fri Sep 20 07:58:59 UTC 2019 - Dirk Mueller 
+
+- update requires to be able to drop tempest
+
+---



Other differences:
--
++ python-watcherclient.spec ++
--- /var/tmp/diff_new_pack.Vt9Tnc/_old  2019-09-23 12:38:40.177597601 +0200
+++ /var/tmp/diff_new_pack.Vt9Tnc/_new  2019-09-23 12:38:40.181597600 +0200
@@ -25,7 +25,6 @@
 URL:https://launchpad.net/%{name}
 Source0:
https://files.pythonhosted.org/packages/source/p/%{name}/%{name}-%{version}.tar.gz
 BuildRequires:  openstack-macros
-BuildRequires:  openstack-tempest
 BuildRequires:  python-PrettyTable >= 0.7.2
 BuildRequires:  python-PyYAML >= 3.12
 BuildRequires:  python-cliff >= 2.11.0
@@ -34,6 +33,7 @@
 BuildRequires:  python-mock
 BuildRequires:  python-osc-lib >= 1.10.0
 BuildRequires:  python-oslo.i18n >= 3.20.0
+BuildRequires:  python-oslo.serialization
 BuildRequires:  python-oslo.utils >= 3.36.0
 BuildRequires:  python-oslotest
 BuildRequires:  python-pbr >= 3.1.1




commit perl-MCE for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package perl-MCE for openSUSE:Factory 
checked in at 2019-09-23 12:38:04

Comparing /work/SRC/openSUSE:Factory/perl-MCE (Old)
 and  /work/SRC/openSUSE:Factory/.perl-MCE.new.7948 (New)


Package is "perl-MCE"

Mon Sep 23 12:38:04 2019 rev:12 rq:732126 version:1.862

Changes:

--- /work/SRC/openSUSE:Factory/perl-MCE/perl-MCE.changes2019-09-18 
13:11:45.852685805 +0200
+++ /work/SRC/openSUSE:Factory/.perl-MCE.new.7948/perl-MCE.changes  
2019-09-23 12:38:44.717596854 +0200
@@ -1,0 +2,22 @@
+Fri Sep 20 08:28:49 UTC 2019 -  
+
+- updated to 1.862
+   see /usr/share/doc/packages/perl-MCE/Changes
+
+  1.862 Wed Sep 18 22:00:00 EST 2019
+  
+* Hotfix for 1.861.
+
+---
+Thu Sep 19 07:55:03 UTC 2019 -  
+
+- updated to 1.861
+   see /usr/share/doc/packages/perl-MCE/Changes
+
+  1.861 Wed Sep 18 08:30:00 EST 2019
+  
+* Hotfix for 1.849-1.860. The edge cases regarding signal handling have
+  been finally resolved for MCE::Child. Thank you, Richard Kelsch for the
+  use case involving ctrl-c. See mce-examples/framebuffer on GitHub.
+
+---

Old:

  MCE-1.860.tar.gz

New:

  MCE-1.862.tar.gz



Other differences:
--
++ perl-MCE.spec ++
--- /var/tmp/diff_new_pack.VrABIc/_old  2019-09-23 12:38:45.053596798 +0200
+++ /var/tmp/diff_new_pack.VrABIc/_new  2019-09-23 12:38:45.053596798 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-MCE
-Version:1.860
+Version:1.862
 Release:0
 %define cpan_name MCE
 Summary:Many-Core Engine for Perl providing parallel processing 
capabilities

++ MCE-1.860.tar.gz -> MCE-1.862.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/MCE-1.860/Changes new/MCE-1.862/Changes
--- old/MCE-1.860/Changes   2019-09-16 03:00:19.0 +0200
+++ new/MCE-1.862/Changes   2019-09-19 04:21:21.0 +0200
@@ -1,6 +1,16 @@
 
 Revision history for Perl module MCE.
 
+1.862 Wed Sep 18 22:00:00 EST 2019
+
+  * Hotfix for 1.861.
+
+1.861 Wed Sep 18 08:30:00 EST 2019
+
+  * Hotfix for 1.849-1.860. The edge cases regarding signal handling have
+been finally resolved for MCE::Child. Thank you, Richard Kelsch for the
+use case involving ctrl-c. See mce-examples/framebuffer on GitHub.
+
 1.860 Sun Sep 15 20:00:00 EST 2019
 
   * Signal-handling update release.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/MCE-1.860/META.json new/MCE-1.862/META.json
--- old/MCE-1.860/META.json 2019-09-16 03:05:31.0 +0200
+++ new/MCE-1.862/META.json 2019-09-19 04:43:12.0 +0200
@@ -65,123 +65,123 @@
"provides" : {
   "MCE" : {
  "file" : "lib/MCE.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Candy" : {
  "file" : "lib/MCE/Candy.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Channel" : {
  "file" : "lib/MCE/Channel.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Channel::Mutex" : {
  "file" : "lib/MCE/Channel/Mutex.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Channel::Simple" : {
  "file" : "lib/MCE/Channel/Simple.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Channel::Threads" : {
  "file" : "lib/MCE/Channel/Threads.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Child" : {
  "file" : "lib/MCE/Child.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Core::Input::Generator" : {
  "file" : "lib/MCE/Core/Input/Generator.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Core::Input::Handle" : {
  "file" : "lib/MCE/Core/Input/Handle.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Core::Input::Iterator" : {
  "file" : "lib/MCE/Core/Input/Iterator.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Core::Input::Request" : {
  "file" : "lib/MCE/Core/Input/Request.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Core::Input::Sequence" : {
  "file" : "lib/MCE/Core/Input/Sequence.pm",
- "version" : "1.860"
+ "version" : "1.862"
   },
   "MCE::Core::Manager" : {
  "file" : "lib/MCE/Core/Manager.pm",
- "version" : "1.860"
+ 

commit perl-AnyEvent for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package perl-AnyEvent for openSUSE:Factory 
checked in at 2019-09-23 12:38:48

Comparing /work/SRC/openSUSE:Factory/perl-AnyEvent (Old)
 and  /work/SRC/openSUSE:Factory/.perl-AnyEvent.new.7948 (New)


Package is "perl-AnyEvent"

Mon Sep 23 12:38:48 2019 rev:35 rq:732302 version:7.17

Changes:

--- /work/SRC/openSUSE:Factory/perl-AnyEvent/perl-AnyEvent.changes  
2019-07-22 17:18:46.437940147 +0200
+++ /work/SRC/openSUSE:Factory/.perl-AnyEvent.new.7948/perl-AnyEvent.changes
2019-09-23 12:39:25.357590168 +0200
@@ -1,0 +2,26 @@
+Wed Sep 18 08:14:03 UTC 2019 -  
+
+- updated to 7.17
+   see /usr/share/doc/packages/perl-AnyEvent/Changes
+
+  TODO: document TCP_*** constants
+  TODO: add debug/trace logging to some modules
+  TODO: use the eval-with-cb-call trick also to speed up JSON?
+  TODO: FAQ: common pitfalls? invoke-before-return
+  TODO: FAQ: scope-ids? hosts file order?
+  TODO: AnyEvent::Handle with AnyEvent::IO?
+  TODO: invalid. and localhost. specialcasing inside AEDNS and not AESocket 
(rfc6761)
+  TODO: maybe implement env variable to give hosts precedence
+  TODO: more formats for parse_ipv6 (single ipv6 address without port, ...p80, 
...#80)
+  TODO: inet_aton maybe pack C4? no, add a comment why not
+  TODO: socket prepare callbacks, can they easily signal failure as well?
+  TODO: Олег Г , empty A record response causes
+  AnyEvent::resolve_sockaddr to eventually call pack_sockaddr with undef -
+  broken dns server, but maybe improve the response.
+  
+  7.17 Wed Sep 18 03:04:49 CEST 2019
+   - work around antique openssl version in RHEL 7  by formatting
+dh parameters differently (reported by several people).
+   - add t/13_weaken.t.
+
+---

Old:

  AnyEvent-7.16.tar.gz

New:

  AnyEvent-7.17.tar.gz



Other differences:
--
++ perl-AnyEvent.spec ++
--- /var/tmp/diff_new_pack.K6yCGR/_old  2019-09-23 12:39:25.721590107 +0200
+++ /var/tmp/diff_new_pack.K6yCGR/_new  2019-09-23 12:39:25.725590107 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-AnyEvent
-Version:7.16
+Version:7.17
 Release:0
 #Upstream: CHECK(Artistic-1.0 or GPL-1.0-or-later)
 %define cpan_name AnyEvent

++ AnyEvent-7.16.tar.gz -> AnyEvent-7.17.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/AnyEvent-7.16/Changes new/AnyEvent-7.17/Changes
--- old/AnyEvent-7.16/Changes   2019-07-19 18:01:05.0 +0200
+++ new/AnyEvent-7.17/Changes   2019-09-18 03:04:53.0 +0200
@@ -1,5 +1,25 @@
 Revision history for Perl extension AnyEvent.
 
+TODO: document TCP_*** constants
+TODO: add debug/trace logging to some modules
+TODO: use the eval-with-cb-call trick also to speed up JSON?
+TODO: FAQ: common pitfalls? invoke-before-return
+TODO: FAQ: scope-ids? hosts file order?
+TODO: AnyEvent::Handle with AnyEvent::IO?
+TODO: invalid. and localhost. specialcasing inside AEDNS and not AESocket 
(rfc6761)
+TODO: maybe implement env variable to give hosts precedence
+TODO: more formats for parse_ipv6 (single ipv6 address without port, ...p80, 
...#80)
+TODO: inet_aton maybe pack C4? no, add a comment why not
+TODO: socket prepare callbacks, can they easily signal failure as well?
+TODO: Олег Г , empty A record response causes
+AnyEvent::resolve_sockaddr to eventually call pack_sockaddr with undef -
+broken dns server, but maybe improve the response.
+
+7.17 Wed Sep 18 03:04:49 CEST 2019
+   - work around antique openssl version in RHEL 7  by formatting
+  dh parameters differently (reported by several people).
+   - add t/13_weaken.t.
+
 7.16 Fri Jul 19 18:00:21 CEST 2019
- add ffdhe group dh parameters from RFC 7919, and use ffdhe3072
   as new default, instead of schmorp1539.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/AnyEvent-7.16/MANIFEST new/AnyEvent-7.17/MANIFEST
--- old/AnyEvent-7.16/MANIFEST  2019-07-19 18:01:28.0 +0200
+++ new/AnyEvent-7.17/MANIFEST  2019-09-18 03:10:47.0 +0200
@@ -51,6 +51,7 @@
 t/io_common
 t/11_io_perl.t
 t/12_io_ioaio.t
+t/13_weaken.t
 t/handle/01_readline.t
 t/handle/02_write.t
 t/handle/03_http_req.t
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/AnyEvent-7.16/META.json new/AnyEvent-7.17/META.json
--- old/AnyEvent-7.16/META.json 2019-07-19 18:01:28.0 +0200
+++ new/AnyEvent-7.17/META.json 2019-09-18 03:10:47.0 +0200
@@ -4,13 +4,13 @@
   "unknown"
],
"dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 7.34, CPAN::Meta::Converter 
version 

commit telegraf for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package telegraf for openSUSE:Factory 
checked in at 2019-09-23 12:38:39

Comparing /work/SRC/openSUSE:Factory/telegraf (Old)
 and  /work/SRC/openSUSE:Factory/.telegraf.new.7948 (New)


Package is "telegraf"

Mon Sep 23 12:38:39 2019 rev:3 rq:732254 version:1.12.0

Changes:

--- /work/SRC/openSUSE:Factory/telegraf/telegraf.changes2019-09-11 
10:33:01.447337502 +0200
+++ /work/SRC/openSUSE:Factory/.telegraf.new.7948/telegraf.changes  
2019-09-23 12:39:22.717590602 +0200
@@ -1,0 +2,6 @@
+Tue Sep 10 07:46:24 UTC 2019 - Jan Engelhardt 
+
+- Trim future goals from description, it is not in the scope
+  of openSUSE package descriptions.
+
+---



Other differences:
--
++ telegraf.spec ++
--- /var/tmp/diff_new_pack.VnIOnF/_old  2019-09-23 12:39:24.053590382 +0200
+++ /var/tmp/diff_new_pack.VnIOnF/_new  2019-09-23 12:39:24.057590382 +0200
@@ -46,9 +46,6 @@
 %description
 Telegraf is an agent written in Go for collecting, processing, aggregating, 
and writing metrics.
 
-Design goals are to have a minimal memory footprint with a plugin system so 
that developers in the community can
-easily add support for collecting metrics from local or remote services.
-
 %prep
 mkdir -p %{_influxdata_dir}
 tar -C %{_influxdata_dir} -xzf %{SOURCE0}
@@ -100,7 +97,7 @@
 %license src/github.com/influxdata/%{name}/LICENSE
 %doc src/github.com/influxdata/%{name}/README.md
 %dir %{_config_dir}
-%config %{_config_dir}/%{name}.conf
+%config(noreplace) %{_config_dir}/%{name}.conf
 %{_bindir}/%{name}
 
 %changelog




commit gzdoom for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package gzdoom for openSUSE:Factory checked 
in at 2019-09-23 12:38:12

Comparing /work/SRC/openSUSE:Factory/gzdoom (Old)
 and  /work/SRC/openSUSE:Factory/.gzdoom.new.7948 (New)


Package is "gzdoom"

Mon Sep 23 12:38:12 2019 rev:8 rq:732152 version:4.2.1

Changes:

--- /work/SRC/openSUSE:Factory/gzdoom/gzdoom.changes2019-08-24 
18:46:18.769757838 +0200
+++ /work/SRC/openSUSE:Factory/.gzdoom.new.7948/gzdoom.changes  2019-09-23 
12:39:04.465593605 +0200
@@ -1,0 +2,14 @@
+Fri Sep 13 11:39:15 UTC 2019 - Jan Engelhardt 
+
+- Update to release 4.2.1
+  * Level compatibility additions for Scythe 2 and Hell Revealed.
+  * Add current, max and average velocity as stat.
+  * Let Hexen Cleric and Mage use unique health chains.
+  * Allow custom status bars to override notification and
+centered message display.
+  * Improve crosshair health color to be more informative.
+  * Added obituary fallbacks for actors that do not have
+any defined.
+- Remove fl2.patch (merged)
+
+---

Old:

  fl2.patch
  g4.2.0.tar.gz

New:

  g4.2.1.tar.gz



Other differences:
--
++ gzdoom.spec ++
--- /var/tmp/diff_new_pack.O9X9pg/_old  2019-09-23 12:39:06.141593329 +0200
+++ /var/tmp/diff_new_pack.O9X9pg/_new  2019-09-23 12:39:06.141593329 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gzdoom
-Version:4.2.0
+Version:4.2.1
 Release:0
 Summary:A DOOM source port with graphic and modding extensions
 License:GPL-3.0-only
@@ -27,9 +27,8 @@
 #Git-Clone: https://github.com/coelckers/gzdoom
 Source: https://github.com/coelckers/gzdoom/archive/g%version.tar.gz
 Patch1: gzdoom-waddir.patch
-Patch4: fl2.patch
-Patch5: gzdoom-lzma.patch
-Patch6: gzdoom-vulkan.patch
+Patch2: gzdoom-lzma.patch
+Patch3: gzdoom-vulkan.patch
 BuildRequires:  cmake >= 2.8.7
 BuildRequires:  gcc-c++
 BuildRequires:  glslang-devel
@@ -68,6 +67,7 @@
 Provides:   bundled(dumb) = 0.9.3
 Provides:   bundled(gdtoa)
 Provides:   bundled(re2c) = 0.16.0
+Provides:   bundled(xbrz) = 1.7
 
 %description
 GZDoom is a port (a modification) of the original Doom source code, featuring:
@@ -83,13 +83,13 @@
 
 %prep
 %setup -q -n %name-g%version
-%patch -P 1 -P 4 -p1
+%patch -P 1 -p1
 
 %if 0%{?suse_version} >= 1500
-%patch -P 5 -p1
+%patch -P 2 -p1
 %endif
 %if 0%{?suse_version} >= 1550
-%patch -P 6 -p1
+%patch -P 3 -p1
 rm -Rfv glslang src/rendering/vulkan/thirdparty/vulkan
 %endif
 perl -i -pe 's{__DATE__}{""}g' src/posix/sdl/i_main.cpp

++ g4.2.0.tar.gz -> g4.2.1.tar.gz ++
/work/SRC/openSUSE:Factory/gzdoom/g4.2.0.tar.gz 
/work/SRC/openSUSE:Factory/.gzdoom.new.7948/g4.2.1.tar.gz differ: char 25, line 
1




commit xiphos for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package xiphos for openSUSE:Factory checked 
in at 2019-09-23 12:38:58

Comparing /work/SRC/openSUSE:Factory/xiphos (Old)
 and  /work/SRC/openSUSE:Factory/.xiphos.new.7948 (New)


Package is "xiphos"

Mon Sep 23 12:38:58 2019 rev:20 rq:732333 version:4.1.0

Changes:

--- /work/SRC/openSUSE:Factory/xiphos/xiphos.changes2018-08-24 
17:11:41.558612700 +0200
+++ /work/SRC/openSUSE:Factory/.xiphos.new.7948/xiphos.changes  2019-09-23 
12:39:30.789589274 +0200
@@ -1,0 +2,11 @@
+Wed Sep 11 10:14:48 UTC 2019 - Bjørn Lie 
+
+- Add conditional variant of suse_update_desktop_file for Factory
+  and newer versions of openSUSE, fixes build in Factory.
+- Add conditional xiphos-build-without-scrollkeeper.patch and
+  xiphos-remove-gconf-2.0.patch, make scrollkeeper and
+  pkgconfig(gconf-2.0) BuildRequires conditional. No longer depend
+  on scrollkeeper and gconf in Factory and newer versions of
+  openSUSE. Patches borrowed from debian.
+
+---

New:

  xiphos-build-without-scrollkeeper.patch
  xiphos-remove-gconf-2.0.patch



Other differences:
--
++ xiphos.spec ++
--- /var/tmp/diff_new_pack.rjW51h/_old  2019-09-23 12:39:31.589589142 +0200
+++ /var/tmp/diff_new_pack.rjW51h/_new  2019-09-23 12:39:31.593589141 +0200
@@ -25,17 +25,17 @@
 Url:http://xiphos.org/
 Source0:
https://github.com/crosswire/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
 Source1:%{name}.desktop
+Patch0: xiphos-build-without-scrollkeeper.patch
+Patch1: xiphos-remove-gconf-2.0.patch
 BuildRequires:  docbook-utils-minimal
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  gnome-doc-utils-devel
 BuildRequires:  intltool
 BuildRequires:  pkgconfig
-BuildRequires:  scrollkeeper
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(biblesync) >= 1.1.2
 BuildRequires:  pkgconfig(dbus-glib-1)
-BuildRequires:  pkgconfig(gconf-2.0)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(gmodule-2.0)
 BuildRequires:  pkgconfig(gtk+-3.0)
@@ -53,6 +53,10 @@
 Provides:   sword-frontend
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+%if 0%{?suse_version} < 1550
+BuildRequires:  scrollkeeper
+BuildRequires:  pkgconfig(gconf-2.0)
+%endif
 
 %description
 Bible Study Software for the Linux community. Lookup and search Bible texts and
@@ -66,6 +70,9 @@
 
 %prep
 %setup -q
+%if 0%{?suse_version} >= 1550
+%autopatch -p1
+%endif
 
 %build
 export CFLAGS="%{optflags}"
@@ -78,8 +85,12 @@
 
 %install
 ./waf install --destdir=%{buildroot}
+%if 0%{?suse_version} < 1550
 install -D -m 644 %{SOURCE1} 
%{buildroot}%{_datadir}/applications/%{name}.desktop
 %suse_update_desktop_file -n 
%{buildroot}%{_datadir}/applications/%{name}.desktop
+%else
+%suse_update_desktop_file %{name} Education Spirituality
+%endif
 # package docs with macro
 rm -frv %{buildroot}/%{_datadir}/doc/%{name}
 install -Dm644 xiphos.1 %{buildroot}%{_mandir}/man1/xiphos.1
@@ -87,11 +98,13 @@
 %fdupes -s %{buildroot}/%{_datadir}
 %find_lang %{name}
 
+%if 0%{?suse_version} < 1330
 %post
 %icon_theme_cache_post
 
 %postun
 %icon_theme_cache_postun
+%endif
 
 %files
 %defattr(-,root,root)
@@ -104,7 +117,9 @@
 %dir %{_datadir}/appdata
 %{_datadir}/appdata/xiphos.appdata.xml
 %{_mandir}/man1/*
+%if 0%{?suse_version} < 1550
 %dir %{_datadir}/omf
+%endif
 
 %files lang -f %{name}.lang
 %defattr(-, root, root)

++ xiphos-build-without-scrollkeeper.patch ++
From: Jeremy Bicha 
Date: Mon, 22 Oct 2018 08:42:57 -0400
Subject: build without scrollkeeper

---
 help/Guidelines|  2 +-
 help/xiphos.omf.in |  9 -
 waffles/gnome.py   | 36 
 wscript|  1 -
 4 files changed, 1 insertion(+), 47 deletions(-)
 delete mode 100644 help/xiphos.omf.in

diff --git a/help/Guidelines b/help/Guidelines
index 6676912..69ec156 100644
--- a/help/Guidelines
+++ b/help/Guidelines
@@ -21,7 +21,7 @@ in PDF format, please email one of the Documentation 
developers.
Also, using xmllint can save a lot of frustration: "xmllint xiphos.xml"
 
 This also helps with finding errors and debugging. 
-3. Please make sure that you have properly edited xiphos-manual-(lang).omf and 
Makefile.am.
+3. Please make sure that you have properly edited Makefile.am.
 -
 Translations
 -
diff --git a/help/xiphos.omf.in b/help/xiphos.omf.in
deleted file mode 100644
index e796583..000
--- a/help/xiphos.omf.in
+++ /dev/null
@@ -1,9 +0,0 @@
-
-
-  
-
-manual
-
-
-  
-
diff --git a/waffles/gnome.py b/waffles/gnome.py
index 58bbb0d..b5c2290 100644
--- 

commit libqt5-creator for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package libqt5-creator for openSUSE:Factory 
checked in at 2019-09-23 12:37:50

Comparing /work/SRC/openSUSE:Factory/libqt5-creator (Old)
 and  /work/SRC/openSUSE:Factory/.libqt5-creator.new.7948 (New)


Package is "libqt5-creator"

Mon Sep 23 12:37:50 2019 rev:69 rq:732111 version:4.10.0

Changes:

--- /work/SRC/openSUSE:Factory/libqt5-creator/libqt5-creator.changes
2019-09-11 10:40:39.975217138 +0200
+++ /work/SRC/openSUSE:Factory/.libqt5-creator.new.7948/libqt5-creator.changes  
2019-09-23 12:38:41.541597376 +0200
@@ -1,0 +2,5 @@
+Thu Sep 19 21:46:57 UTC 2019 - Herbert Graeber 
+
+- Add new pri file to plugin-devel subpackage
+
+---



Other differences:
--
++ libqt5-creator.spec ++
--- /var/tmp/diff_new_pack.GFeaF3/_old  2019-09-23 12:38:42.197597268 +0200
+++ /var/tmp/diff_new_pack.GFeaF3/_new  2019-09-23 12:38:42.201597268 +0200
@@ -135,7 +135,7 @@
 
 # plugin development files
 mkdir %{buildroot}%{_datadir}/qtcreator-devel
-cp qtcreator.pri %{buildroot}%{_datadir}/qtcreator-devel
+cp *.pri %{buildroot}%{_datadir}/qtcreator-devel
 find src \( \
-name '*.h' -o -name '*.hpp' -o -name '*.pri' -o -iname 'license*.txt' -o \
-name 'QtConcurrentTools' \




commit rsibreak for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package rsibreak for openSUSE:Factory 
checked in at 2019-09-23 12:39:04

Comparing /work/SRC/openSUSE:Factory/rsibreak (Old)
 and  /work/SRC/openSUSE:Factory/.rsibreak.new.7948 (New)


Package is "rsibreak"

Mon Sep 23 12:39:04 2019 rev:37 rq:732337 version:0.12.11

Changes:

--- /work/SRC/openSUSE:Factory/rsibreak/rsibreak.changes2019-07-21 
11:33:19.800787580 +0200
+++ /work/SRC/openSUSE:Factory/.rsibreak.new.7948/rsibreak.changes  
2019-09-23 12:39:31.789589109 +0200
@@ -1,0 +2,9 @@
+Sat Sep 21 10:41:35 UTC 2019 - wba...@tmo.at
+
+- Update to 0.12.11:
+  * Improve notification integration with the notification KCM
+  * Translation improvements
+  * Minor code cleanup
+- Switch Qt5/KF5 BuildRequires to cmake() style
+
+---

Old:

  rsibreak-0.12.10.tar.xz

New:

  rsibreak-0.12.11.tar.xz



Other differences:
--
++ rsibreak.spec ++
--- /var/tmp/diff_new_pack.F26CVv/_old  2019-09-23 12:39:32.245589034 +0200
+++ /var/tmp/diff_new_pack.F26CVv/_new  2019-09-23 12:39:32.249589034 +0200
@@ -18,7 +18,7 @@
 
 %define base_ver 0.12
 Name:   rsibreak
-Version:0.12.10
+Version:0.12.11
 Release:0
 Summary:Repetetive Strain Injury recovery and prevention assistance 
utility
 License:GPL-2.0-or-later
@@ -27,25 +27,22 @@
 Source0:
https://download.kde.org/stable/rsibreak/%{base_ver}/rsibreak-%{version}.tar.xz
 BuildRequires:  extra-cmake-modules
 BuildRequires:  fdupes
-BuildRequires:  kconfig-devel
-BuildRequires:  kconfigwidgets-devel
-BuildRequires:  kcrash-devel
-BuildRequires:  kdbusaddons-devel
-BuildRequires:  kdoctools-devel
-BuildRequires:  ki18n-devel
-BuildRequires:  kiconthemes-devel
-BuildRequires:  kidletime-devel
-BuildRequires:  knotifications-devel
-BuildRequires:  knotifyconfig-devel
-BuildRequires:  ktextwidgets-devel
-BuildRequires:  kwindowsystem-devel
-BuildRequires:  kxmlgui-devel
-BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
-BuildRequires:  pkgconfig(Qt5Core) >= 5.3.0
-BuildRequires:  pkgconfig(Qt5DBus) >= 5.3.0
-BuildRequires:  pkgconfig(Qt5Gui) >= 5.3.0
-BuildRequires:  pkgconfig(Qt5Test) >= 5.3.0
+BuildRequires:  cmake(KF5Config)
+BuildRequires:  cmake(KF5ConfigWidgets)
+BuildRequires:  cmake(KF5Crash)
+BuildRequires:  cmake(KF5DBusAddons)
+BuildRequires:  cmake(KF5DocTools)
+BuildRequires:  cmake(KF5I18n)
+BuildRequires:  cmake(KF5IconThemes)
+BuildRequires:  cmake(KF5IdleTime)
+BuildRequires:  cmake(KF5Notifications)
+BuildRequires:  cmake(KF5NotifyConfig)
+BuildRequires:  cmake(KF5TextWidgets)
+BuildRequires:  cmake(KF5WindowSystem)
+BuildRequires:  cmake(KF5XmlGui)
+BuildRequires:  cmake(Qt5DBus) >= 5.6.0
+BuildRequires:  cmake(Qt5Test) >= 5.6.0
 Requires:   hicolor-icon-theme
 Recommends: %{name}-lang = %{version}
 Obsoletes:  %{name}-doc < %{version}

++ rsibreak-0.12.10.tar.xz -> rsibreak-0.12.11.tar.xz ++
 1954 lines of diff (skipped)




commit ibus-anthy for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package ibus-anthy for openSUSE:Factory 
checked in at 2019-09-23 12:38:46

Comparing /work/SRC/openSUSE:Factory/ibus-anthy (Old)
 and  /work/SRC/openSUSE:Factory/.ibus-anthy.new.7948 (New)


Package is "ibus-anthy"

Mon Sep 23 12:38:46 2019 rev:27 rq:732268 version:1.5.10

Changes:

--- /work/SRC/openSUSE:Factory/ibus-anthy/ibus-anthy.changes2018-04-03 
12:12:21.794816129 +0200
+++ /work/SRC/openSUSE:Factory/.ibus-anthy.new.7948/ibus-anthy.changes  
2019-09-23 12:39:24.641590285 +0200
@@ -1,0 +2,6 @@
+Fri Sep 20 22:26:20 UTC 2019 - Cliff Zhao 
+
+- update ibus-anthy.spec: update to depending anthy-devel, make it
+  can build successful in SLE15(openSUSE-leap-15). 
+
+---



Other differences:
--
++ ibus-anthy.spec ++
--- /var/tmp/diff_new_pack.RpDmx0/_old  2019-09-23 12:39:25.141590203 +0200
+++ /var/tmp/diff_new_pack.RpDmx0/_new  2019-09-23 12:39:25.141590203 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package ibus-anthy
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,11 +12,12 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   ibus-anthy
+BuildRequires:  anthy-devel
 BuildRequires:  fdupes
 BuildRequires:  intltool
 BuildRequires:  pkgconfig
@@ -24,14 +25,13 @@
 BuildRequires:  python3-gobject2-devel
 BuildRequires:  swig
 BuildRequires:  update-desktop-files
-BuildRequires:  pkgconfig(anthy)
 BuildRequires:  pkgconfig(gobject-introspection-1.0)
 BuildRequires:  pkgconfig(ibus-1.0) >= 1.4.99
 BuildRequires:  pkgconfig(python3)
 Version:1.5.10
 Release:0
 Summary:The Anthy engine for IBus input platform
-License:GPL-2.0+
+License:GPL-2.0-or-later
 Group:  System/I18n/Japanese
 Url:https://github.com/ibus/ibus-anthy
 Source: 
https://github.com/ibus/ibus-anthy/releases/download/%{version}/%{name}-%{version}.tar.gz
@@ -86,7 +86,8 @@
 
 %files -f %{name}.lang
 %defattr(-,root,root,-)
-%doc AUTHORS COPYING README
+%doc AUTHORS README
+%license COPYING
 %{_libexecdir}/ibus-*
 %{_datadir}/ibus-anthy
 %{_datadir}/ibus




commit python-smbprotocol for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package python-smbprotocol for 
openSUSE:Factory checked in at 2019-09-23 12:37:54

Comparing /work/SRC/openSUSE:Factory/python-smbprotocol (Old)
 and  /work/SRC/openSUSE:Factory/.python-smbprotocol.new.7948 (New)


Package is "python-smbprotocol"

Mon Sep 23 12:37:54 2019 rev:4 rq:732117 version:0.2.0

Changes:

--- /work/SRC/openSUSE:Factory/python-smbprotocol/python-smbprotocol.changes
2019-01-03 18:09:27.579989461 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-smbprotocol.new.7948/python-smbprotocol.changes
  2019-09-23 12:38:42.473597223 +0200
@@ -1,0 +2,9 @@
+Thu Sep 19 18:50:13 UTC 2019 - Martin Hauke 
+
+- Update to version 0.2.0
+  * Fix issue where timeout was not being applied to the new
+connection
+  * Fix various deprecated regex escape patterns
+  * Simplified the fallback NTLM context object
+
+---

Old:

  python-smbprotocol-0.1.1.tar.gz

New:

  python-smbprotocol-0.2.0.tar.gz



Other differences:
--
++ python-smbprotocol.spec ++
--- /var/tmp/diff_new_pack.qxPlZu/_old  2019-09-23 12:38:42.809597168 +0200
+++ /var/tmp/diff_new_pack.qxPlZu/_new  2019-09-23 12:38:42.813597167 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-smbprotocol
-Version:0.1.1
+Version:0.2.0
 Release:0
 Summary:SMBv2/v3 client for Python 2 and 3
 License:MIT
@@ -26,7 +26,12 @@
 URL:https://github.com/jborean93/smbprotocol
 #Source: 
https://files.pythonhosted.org/packages/source/s/smbprotocol/smbprotocol-%%{version}.tar.gz
 Source: 
https://github.com/jborean93/smbprotocol/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
+BuildRequires:  %{python_module cryptography >= 2.0}
+BuildRequires:  %{python_module ntlm-auth}
+BuildRequires:  %{python_module pyasn1}
+BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module setuptools}
+BuildRequires:  %{python_module six}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
 Requires:   python-cryptography >= 2.0
@@ -36,11 +41,6 @@
 Suggests:   python-gssapi >= 1.4.1
 Suggests:   python-ordereddict
 BuildArch:  noarch
-BuildRequires:  %{python_module cryptography >= 2.0}
-BuildRequires:  %{python_module ntlm-auth}
-BuildRequires:  %{python_module pyasn1}
-BuildRequires:  %{python_module pytest}
-BuildRequires:  %{python_module six}
 %python_subpackages
 
 %description
@@ -71,7 +71,7 @@
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
 %check
-%python_expand PYTHONPATH=%{buildroot}%{$python_sitelib} 
py.test-%{$python_version}
+%pytest
 
 %files %{python_files}
 %license LICENSE

++ python-smbprotocol-0.1.1.tar.gz -> python-smbprotocol-0.2.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/smbprotocol-0.1.1/.travis.yml 
new/smbprotocol-0.2.0/.travis.yml
--- old/smbprotocol-0.1.1/.travis.yml   2018-09-14 02:25:45.0 +0200
+++ new/smbprotocol-0.2.0/.travis.yml   2019-09-19 04:18:09.0 +0200
@@ -2,19 +2,25 @@
 
 language: python
 
-python:
-- 2.6
-- 2.7
-- 3.4
-- 3.5
-- 3.6
+dist: xenial
 
-# Python 3.7 requires 16.04 (Xenial), this is a hack to get that specific
-# distro running that version until I can swap the rest over officially
 matrix:
   include:
+  - python: 2.6
+dist: trusty
+  - python: 2.7
+  - python: 3.4
+dist: trusty
+  - python: 3.5
+dist: trusty
+  - python: 3.6
   - python: 3.7
-dist: xenial
+  - python: 3.8-dev
+
+  # 3.8 is still a beta and I'm running it to see if anything breaks but
+  # don't want it to stop the build
+  allow_failures:
+  - python: 3.8-dev
 
 services:
 - docker
@@ -30,14 +36,14 @@
 install:
 - docker run -d -p $SMB_PORT:445 -v $(pwd)/build-scripts:/app -w /app -e 
SMB_USER=$SMB_USER -e SMB_PASSWORD=$SMB_PASSWORD -e SMB_SHARE=$SMB_SHARE 
centos:7 /bin/bash /app/setup_samba.sh;
 - pip install --upgrade pip setuptools
-- pip install .
 - pip install -r requirements-test.txt
+- pip install .
 - pip install coveralls
 # make sure the Samba service on the container is up and running
 - python ./build-scripts/check_samba.py
 
 script:
-- py.test -v --instafail --pep8 --cov smbprotocol --cov-report term-missing
+- py.test -v --pep8 --cov smbprotocol --cov-report term-missing
 
 after_success:
 - coveralls
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/smbprotocol-0.1.1/CHANGELOG.md 
new/smbprotocol-0.2.0/CHANGELOG.md
--- old/smbprotocol-0.1.1/CHANGELOG.md  2018-09-14 02:25:45.0 +0200
+++ new/smbprotocol-0.2.0/CHANGELOG.md  2019-09-19 

commit drbd-utils for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package drbd-utils for openSUSE:Factory 
checked in at 2019-09-23 12:37:47

Comparing /work/SRC/openSUSE:Factory/drbd-utils (Old)
 and  /work/SRC/openSUSE:Factory/.drbd-utils.new.7948 (New)


Package is "drbd-utils"

Mon Sep 23 12:37:47 2019 rev:33 rq:732101 version:9.10.0

Changes:

--- /work/SRC/openSUSE:Factory/drbd-utils/drbd-utils.changes2019-09-11 
10:41:58.715203114 +0200
+++ /work/SRC/openSUSE:Factory/.drbd-utils.new.7948/drbd-utils.changes  
2019-09-23 12:38:40.897597482 +0200
@@ -1,0 +2,6 @@
+Fri Sep 20 06:18:33 UTC 2019 - nick wang 
+
+- bsc#1145296, fix the wrong return code with cib_apply_diff
+  Add patch cibadmin-return-code-convert.patch
+
+---

New:

  cibadmin-return-code-convert.patch



Other differences:
--
++ drbd-utils.spec ++
--- /var/tmp/diff_new_pack.bQPz4U/_old  2019-09-23 12:38:41.313597414 +0200
+++ /var/tmp/diff_new_pack.bQPz4U/_new  2019-09-23 12:38:41.313597414 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package drbd-utils
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -25,7 +25,7 @@
 Version:9.10.0
 Release:0
 Summary:Distributed Replicated Block Device
-License:GPL-2.0+
+License:GPL-2.0-or-later
 Group:  Productivity/Clustering/HA
 Url:http://www.drbd.org/
 Source: 
http://www.linbit.com/downloads/drbd/utils/%{name}-%{version}.tar.gz
@@ -40,6 +40,7 @@
 # Bach port patch for kernel v5.2
 Patch6: netlink-prepare-for-kernel-v5.2.patch
 Patch7: netlink-Add-NLA_F_NESTED-flag-to-nested-attribute.patch
+Patch8: cibadmin-return-code-convert.patch
 
 Provides:   drbd-bash-completion = %{version}
 Provides:   drbd-pacemaker = %{version}
@@ -66,8 +67,8 @@
 BuildRequires:  libxslt
 BuildRequires:  make
 BuildRequires:  pkgconfig
-BuildRequires:  pkgconfig(systemd)
 BuildRequires:  udev
+BuildRequires:  pkgconfig(systemd)
 %if %{with drbdmon}
 BuildRequires:  gcc-c++
 %endif
@@ -92,6 +93,7 @@
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
 
 %build
 export WANT_DRBD_REPRODUCIBLE_BUILD=1

++ cibadmin-return-code-convert.patch ++
diff -Naur drbd-utils-9.6.0.orig/scripts/crm-fence-peer.9.sh 
drbd-utils-9.6.0/scripts/crm-fence-peer.9.sh
--- drbd-utils-9.6.0.orig/scripts/crm-fence-peer.9.sh   2019-09-03 
14:13:56.861585246 +0800
+++ drbd-utils-9.6.0/scripts/crm-fence-peer.9.sh2019-09-03 
14:17:42.478881632 +0800
@@ -146,7 +146,7 @@
break
;;
 
-   205): "205 aka pcmk_err_old_data ==> going to retry in a 
bit"
+   103): "103 CRM_EX_OLD, aka 205 pcmk_err_old_data in 
cib_apply_diff ==> going to retry in a bit"
(( $SECONDS >= $timeout )) && break
sleep 1
continue



commit cinnamon-session for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package cinnamon-session for 
openSUSE:Factory checked in at 2019-09-23 12:34:55

Comparing /work/SRC/openSUSE:Factory/cinnamon-session (Old)
 and  /work/SRC/openSUSE:Factory/.cinnamon-session.new.7948 (New)


Package is "cinnamon-session"

Mon Sep 23 12:34:55 2019 rev:18 rq:732042 version:4.2.1

Changes:

--- /work/SRC/openSUSE:Factory/cinnamon-session/cinnamon-session.changes
2019-07-22 12:21:10.515652012 +0200
+++ 
/work/SRC/openSUSE:Factory/.cinnamon-session.new.7948/cinnamon-session.changes  
2019-09-23 12:38:28.497599522 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 17:20:37 UTC 2019 - Bjørn Lie 
+
+- Replace pkgconfig(pangox) with pkgconfig(pango) and
+  pkgconfig(pangoxft) BuildRequires: This is what meson checks for.
+
+---



Other differences:
--
++ cinnamon-session.spec ++
--- /var/tmp/diff_new_pack.nOnSLV/_old  2019-09-23 12:38:28.933599451 +0200
+++ /var/tmp/diff_new_pack.nOnSLV/_new  2019-09-23 12:38:28.933599451 +0200
@@ -42,7 +42,8 @@
 BuildRequires:  pkgconfig(json-glib-1.0)
 BuildRequires:  pkgconfig(libcanberra)
 BuildRequires:  pkgconfig(libsystemd)
-BuildRequires:  pkgconfig(pangox)
+BuildRequires:  pkgconfig(pango)
+BuildRequires:  pkgconfig(pangoxft)
 BuildRequires:  pkgconfig(sm)
 BuildRequires:  pkgconfig(xapp) >= 1.2.0
 BuildRequires:  pkgconfig(xcomposite)




commit perl-PDF-API2 for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package perl-PDF-API2 for openSUSE:Factory 
checked in at 2019-09-23 12:38:06

Comparing /work/SRC/openSUSE:Factory/perl-PDF-API2 (Old)
 and  /work/SRC/openSUSE:Factory/.perl-PDF-API2.new.7948 (New)


Package is "perl-PDF-API2"

Mon Sep 23 12:38:06 2019 rev:18 rq:732132 version:2.036

Changes:

--- /work/SRC/openSUSE:Factory/perl-PDF-API2/perl-PDF-API2.changes  
2019-08-15 12:28:42.446530935 +0200
+++ /work/SRC/openSUSE:Factory/.perl-PDF-API2.new.7948/perl-PDF-API2.changes
2019-09-23 12:38:49.997595985 +0200
@@ -1,0 +2,10 @@
+Wed Sep 18 08:19:06 UTC 2019 -  
+
+- updated to 2.036
+   see /usr/share/doc/packages/perl-PDF-API2/Changes
+
+  2.036 2019-09-17
+  
+  - Eliminate another uninitialized value warning in BaseFont.pm.
+
+---

Old:

  PDF-API2-2.035.tar.gz

New:

  PDF-API2-2.036.tar.gz



Other differences:
--
++ perl-PDF-API2.spec ++
--- /var/tmp/diff_new_pack.YEqh4P/_old  2019-09-23 12:38:51.245595780 +0200
+++ /var/tmp/diff_new_pack.YEqh4P/_new  2019-09-23 12:38:51.245595780 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-PDF-API2
-Version:2.035
+Version:2.036
 Release:0
 %define cpan_name PDF-API2
 Summary:Facilitates the creation and modification of PDF files

++ PDF-API2-2.035.tar.gz -> PDF-API2-2.036.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/PDF-API2-2.035/Changes new/PDF-API2-2.036/Changes
--- old/PDF-API2-2.035/Changes  2019-08-09 19:41:43.0 +0200
+++ new/PDF-API2-2.036/Changes  2019-09-17 18:37:12.0 +0200
@@ -1,3 +1,8 @@
+2.036 2019-09-17
+
+- Eliminate another uninitialized value warning in BaseFont.pm.
+
+
 2.035 2019-08-09
 
 - The bounding box methods (mediabox, cropbox, bleedbox, trimbox, and
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/PDF-API2-2.035/META.json new/PDF-API2-2.036/META.json
--- old/PDF-API2-2.035/META.json2019-08-09 19:41:43.0 +0200
+++ new/PDF-API2-2.036/META.json2019-09-17 18:37:12.0 +0200
@@ -47,7 +47,7 @@
  "web" : "https://github.com/ssimms/pdfapi2;
   }
},
-   "version" : "2.035",
+   "version" : "2.036",
"x_generated_by_perl" : "v5.22.1",
"x_serialization_backend" : "Cpanel::JSON::XS version 4.04"
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/PDF-API2-2.035/META.yml new/PDF-API2-2.036/META.yml
--- old/PDF-API2-2.035/META.yml 2019-08-09 19:41:43.0 +0200
+++ new/PDF-API2-2.036/META.yml 2019-09-17 18:37:12.0 +0200
@@ -20,6 +20,6 @@
   perl: v5.10.0
 resources:
   repository: git://github.com/ssimms/pdfapi2.git
-version: '2.035'
+version: '2.036'
 x_generated_by_perl: v5.22.1
 x_serialization_backend: 'YAML::Tiny version 1.73'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/PDF-API2-2.035/Makefile.PL 
new/PDF-API2-2.036/Makefile.PL
--- old/PDF-API2-2.035/Makefile.PL  2019-08-09 19:41:43.0 +0200
+++ new/PDF-API2-2.036/Makefile.PL  2019-09-17 18:37:12.0 +0200
@@ -24,7 +24,7 @@
 "Test::Exception" => 0,
 "Test::Memory::Cycle" => 0
   },
-  "VERSION" => "2.035",
+  "VERSION" => "2.036",
   "test" => {
 "TESTS" => "t/*.t"
   }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/PDF-API2-2.035/README new/PDF-API2-2.036/README
--- old/PDF-API2-2.035/README   2019-08-09 19:41:43.0 +0200
+++ new/PDF-API2-2.036/README   2019-09-17 18:37:12.0 +0200
@@ -1,5 +1,5 @@
 This archive contains the distribution PDF-API2,
-version 2.035:
+version 2.036:
 
   Facilitates the creation and modification of PDF files
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/PDF-API2-2.035/dist.ini new/PDF-API2-2.036/dist.ini
--- old/PDF-API2-2.035/dist.ini 2019-08-09 19:41:43.0 +0200
+++ new/PDF-API2-2.036/dist.ini 2019-09-17 18:37:12.0 +0200
@@ -1,5 +1,5 @@
 name = PDF-API2
-author  = Steve Simms 
+author = Steve Simms 
 license = LGPL_2_1
 copyright_holder = Steve Simms
 
@@ -32,7 +32,7 @@
 [Git::Tag]
 tag_format = %v
 
-[GatherDir]
+[Git::GatherDir]
 include_dotfiles = 1
 exclude_match = ^\.(?!perlcriticrc$)
 
@@ -52,3 +52,4 @@
 [TestRelease]
 [ConfirmRelease]
 [UploadToCPAN]
+[Git::Push]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/PDF-API2-2.035/lib/PDF/API2/Annotation.pm 
new/PDF-API2-2.036/lib/PDF/API2/Annotation.pm
--- 

commit paraview for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package paraview for openSUSE:Factory 
checked in at 2019-09-23 12:38:33

Comparing /work/SRC/openSUSE:Factory/paraview (Old)
 and  /work/SRC/openSUSE:Factory/.paraview.new.7948 (New)


Package is "paraview"

Mon Sep 23 12:38:33 2019 rev:26 rq:732252 version:5.6.2

Changes:

--- /work/SRC/openSUSE:Factory/paraview/paraview.changes2019-08-19 
21:39:29.568312785 +0200
+++ /work/SRC/openSUSE:Factory/.paraview.new.7948/paraview.changes  
2019-09-23 12:39:20.397590983 +0200
@@ -1,0 +2,11 @@
+Fri Sep 20 06:14:35 UTC 2019 - Atri Bhattacharya 
+
+- Update to version 5.6.2:
+  * Fixes a trackpad interaction bug on macOS.
+
+---
+Fri Sep 20 05:46:33 UTC 2019 - Atri Bhattacharya 
+
+- Pass -ffat-lto-objects for static libs.
+
+---

Old:

  ParaView-v5.6.1.tar.xz
  ParaViewGuide-5.6.1.pdf

New:

  ParaView-v5.6.2.tar.xz
  ParaViewGuide-5.6.2.pdf



Other differences:
--
++ paraview.spec ++
--- /var/tmp/diff_new_pack.pnAZrW/_old  2019-09-23 12:39:22.357590661 +0200
+++ /var/tmp/diff_new_pack.pnAZrW/_new  2019-09-23 12:39:22.361590661 +0200
@@ -19,7 +19,7 @@
 %define major_ver 5.6
 
 Name:   paraview
-Version:5.6.1
+Version:5.6.2
 Release:0
 Summary:Data analysis and visualization application
 License:BSD-3-Clause
@@ -120,6 +120,8 @@
 %patch9 -p1
 
 %build
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
+
 # Prepare for gcc 4.9.0: work around gcc 4.9.0 regression
 # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=61294
 sed -i -e 's/-Wl,--fatal-warnings//' VTK/CMake/vtkCompilerExtraFlags.cmake

++ ParaView-v5.6.1.tar.xz -> ParaView-v5.6.2.tar.xz ++
/work/SRC/openSUSE:Factory/paraview/ParaView-v5.6.1.tar.xz 
/work/SRC/openSUSE:Factory/.paraview.new.7948/ParaView-v5.6.2.tar.xz differ: 
char 26, line 1

++ ParaViewGuide-5.6.1.pdf -> ParaViewGuide-5.6.2.pdf ++




commit enigmail for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package enigmail for openSUSE:Factory 
checked in at 2019-09-23 12:38:29

Comparing /work/SRC/openSUSE:Factory/enigmail (Old)
 and  /work/SRC/openSUSE:Factory/.enigmail.new.7948 (New)


Package is "enigmail"

Mon Sep 23 12:38:29 2019 rev:35 rq:732243 version:2.1.2

Changes:

--- /work/SRC/openSUSE:Factory/enigmail/enigmail.changes2019-08-30 
14:41:36.057419749 +0200
+++ /work/SRC/openSUSE:Factory/.enigmail.new.7948/enigmail.changes  
2019-09-23 12:39:09.669592749 +0200
@@ -1,0 +2,6 @@
+Fri Sep 20 20:20:13 UTC 2019 - Andreas Stieger 
+
+- boo#1151317: SeaMonkey is no longer supported. Update description
+  and no longer put in SeaMonkey addons path
+
+---



Other differences:
--
++ enigmail.spec ++
--- /var/tmp/diff_new_pack.TNrV3S/_old  2019-09-23 12:39:10.841592556 +0200
+++ /var/tmp/diff_new_pack.TNrV3S/_new  2019-09-23 12:39:10.845592555 +0200
@@ -20,7 +20,7 @@
 Name:   enigmail
 Version:2.1.2
 Release:0
-Summary:OpenPGP addon for Thunderbird and SeaMonkey
+Summary:OpenPGP addon for Mozilla Thunderbird
 License:MPL-2.0
 Group:  Productivity/Networking/Email/Clients
 URL:https://www.enigmail.net/
@@ -37,7 +37,7 @@
 Requires:   pinentry-gui
 
 %description
-This package contains the Enigmail OpenPGP Addon for Thunderbird and SeaMonkey.
+This package contains the Enigmail OpenPGP Addon for Mozilla Thunderbird.
 
 %prep
 %setup -q -n enigmail
@@ -55,10 +55,6 @@
 mkdir -p $_enig_dir
 (cd $_enig_dir; unzip $RPM_BUILD_DIR/enigmail/build/enigmail-*.xpi)
 #rm $_enig_dir/*.xpi
-# SeaMonkey location
-mkdir -p 
%{buildroot}%{_libdir}/mozilla/extensions/\{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a\}
-(cd 
%{buildroot}%{_libdir}/mozilla/extensions/\{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a\};
 \
-  ln -s 
../\{3550f703-e582-4d05-9a08-453d09bdfdc6\}/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
 )
 
 mkdir -p %{buildroot}%{_datadir}/appdata/
 install -m644 public/thunderbird-enigmail.metainfo.xml 
%{buildroot}%{_datadir}/appdata/enigmail.appdata.xml






commit asio for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package asio for openSUSE:Factory checked in 
at 2019-09-23 12:38:09

Comparing /work/SRC/openSUSE:Factory/asio (Old)
 and  /work/SRC/openSUSE:Factory/.asio.new.7948 (New)


Package is "asio"

Mon Sep 23 12:38:09 2019 rev:27 rq:732140 version:1.12.2

Changes:

--- /work/SRC/openSUSE:Factory/asio/asio.changes2018-04-22 
14:41:19.329314846 +0200
+++ /work/SRC/openSUSE:Factory/.asio.new.7948/asio.changes  2019-09-23 
12:38:53.569595397 +0200
@@ -1,0 +2,25 @@
+Fri Sep 20 08:08:33 UTC 2019 - ec...@opensuse.org
+
+- Version update to 1.12.2:
+  * Fixed a problem with the detection of std::future availability with 
libstdc++.
+  * Fixed compile error in regex overload of read_until.
+  * Fixed a timer heap corruption issue that can occur when moving a cancelled 
timer.
+  * Fixed detection of std::experimental::string_view and std::string_view 
with newer clang/libc++.
+  * Fixed MSVC version detection for availability of std::invoke_result.
+  * Fixed the buffer sequence traits to test the new requirements, if decltype 
is available.
+  * Fixed an MSVC issue when building with exceptions disabled.
+  * Added SSL context options for TLS v1.3.
+  * Added a compile-time test for TLS v1 support.
+  * Fixed the macro used to test for TLS v1.2 support.
+  * Prevented global objects from being created once per thread on Windows.
+  * Fixed a crash when using size(), max_size() or empty() on 
default-constructed resolver results.
+  * Changed to move the return value in basic_resolver_results::begin() to 
avoid copying.
+  * Enabled move support for the Intel Compiler.
+  * Fixed std::string_view detection issue when using clang-cl.
+  * Fixed the handler tracking operation name for 
io_context::executor_type::dispatch.
+  * Fixed a buffer overflow that could occur when parsing an address string 
with a 64-bit scope id.
+  * Added examples showing how to write composed operations.
+  * Added C++11 versions of the Timeouts, Timers, SOCKS4 and SSL examples.
+  * Fixed minor issues in documentation and examples.
+
+---

Old:

  asio-1.12.1.tar.bz2

New:

  asio-1.12.2.tar.bz2



Other differences:
--
++ asio.spec ++
--- /var/tmp/diff_new_pack.JXjMH6/_old  2019-09-23 12:38:54.001595326 +0200
+++ /var/tmp/diff_new_pack.JXjMH6/_new  2019-09-23 12:38:54.001595326 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package asio
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,12 +12,12 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   asio
-Version:1.12.1
+Version:1.12.2
 Release:0
 Summary:A cross-platform C++ library for network and low-level I/O 
programming
 License:BSD-3-Clause

++ asio-1.12.1.tar.bz2 -> asio-1.12.2.tar.bz2 ++
 28577 lines of diff (skipped)




commit chromium for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package chromium for openSUSE:Factory 
checked in at 2019-09-23 12:35:02

Comparing /work/SRC/openSUSE:Factory/chromium (Old)
 and  /work/SRC/openSUSE:Factory/.chromium.new.7948 (New)


Package is "chromium"

Mon Sep 23 12:35:02 2019 rev:232 rq:732044 version:77.0.3865.90

Changes:

--- /work/SRC/openSUSE:Factory/chromium/chromium.changes2019-09-19 
15:52:43.711270286 +0200
+++ /work/SRC/openSUSE:Factory/.chromium.new.7948/chromium.changes  
2019-09-23 12:38:29.461599364 +0200
@@ -1,0 +2,5 @@
+Thu Sep 19 12:55:15 UTC 2019 - Jan Ritzerfeld 
+
+- Added patch chromium-vaapi-fix.patch again to fix boo#1146219
+
+---

New:

  chromium-vaapi-fix.patch



Other differences:
--
++ chromium.spec ++
--- /var/tmp/diff_new_pack.2Dt6O3/_old  2019-09-23 12:38:35.581598357 +0200
+++ /var/tmp/diff_new_pack.2Dt6O3/_new  2019-09-23 12:38:35.585598356 +0200
@@ -104,6 +104,7 @@
 #  (default on) compared to the PR
 Patch100:   chromium-vaapi.patch
 Patch101:   old-libva.patch
+Patch102:   chromium-vaapi-fix.patch
 # PATCH-FIX-SUSE: allow prop codecs to be set with chromium branding
 Patch200:   chromium-prop-codecs.patch
 BuildRequires:  SDL-devel

++ chromium-vaapi-fix.patch ++
>From fe61d25580bd22d68b20323e7cd684dcba0cd3f4 Mon Sep 17 00:00:00 2001
From: Akarshan Biswas 
Date: Tue, 9 Jul 2019 18:39:54 +0530
Subject: [PATCH] Disable VAProfileNone on Linux and fix vaapi drm

---
 .../gpu_video_decode_accelerator_factory.cc   |  2 ++
 .../vaapi/vaapi_video_decode_accelerator.cc   | 21 
 media/gpu/vaapi/vaapi_wrapper.cc  | 24 +++
 3 files changed, 42 insertions(+), 5 deletions(-)

Index: chromium-77.0.3865.90/media/gpu/gpu_video_decode_accelerator_factory.cc
===
--- chromium-77.0.3865.90.orig/media/gpu/gpu_video_decode_accelerator_factory.cc
+++ chromium-77.0.3865.90/media/gpu/gpu_video_decode_accelerator_factory.cc
@@ -171,6 +171,8 @@ GpuVideoDecodeAcceleratorFactory::Create
 vda = (this->*create_vda_function)(workarounds, gpu_preferences, 
media_log);
 if (vda && vda->Initialize(config, client))
   return vda;
+  else
+  LOG(ERROR) << "Initialization of one or more VDAs failed.";
   }
 
   return nullptr;
Index: chromium-77.0.3865.90/media/gpu/vaapi/vaapi_video_decode_accelerator.cc
===
--- chromium-77.0.3865.90.orig/media/gpu/vaapi/vaapi_video_decode_accelerator.cc
+++ chromium-77.0.3865.90/media/gpu/vaapi/vaapi_video_decode_accelerator.cc
@@ -63,6 +63,9 @@ void ReportToUMA(VAVDADecoderFailure fai
 VAVDA_DECODER_FAILURES_MAX + 1);
 }
 
+// Move this thing to chromeos only as build can fail if treat warnings as 
errors been set to true
+#if defined(OS_ANDROID) || defined(OS_CHROMEOS)
+
 // Returns true if the CPU is an Intel Gemini Lake or later (including Kaby
 // Lake) Cpu platform id's are referenced from the following file in kernel
 // source arch/x86/include/asm/intel-family.h
@@ -76,6 +79,8 @@ bool IsGeminiLakeOrLater() {
   return is_geminilake_or_later;
 }
 
+#endif
+
 }  // namespace
 
 #define RETURN_AND_NOTIFY_ON_FAILURE(result, log, error_code, ret) \
@@ -631,6 +636,13 @@ void VaapiVideoDecodeAccelerator::Assign
   va_surface_format_ = GetVaFormatForVideoCodecProfile(profile_);
   std::vector va_surface_ids;
 
+  // Nvidia doesn't support VAProfileNone, so don't try to create a temporary
+  // copy buffer there. It's not needed anyways for hardware video decoding
+  // to work.
+  
+  #if defined(OS_ANDROID) || defined(OS_CHROMEOS)
+
+
   // If we aren't in BufferAllocationMode::kNone, we have to allocate a
   // |vpp_vaapi_wrapper_| for VaapiPicture to DownloadFromSurface() the VA's
   // internal decoded frame.
@@ -644,15 +656,20 @@ void VaapiVideoDecodeAccelerator::Assign
   NotifyError(PLATFORM_FAILURE);
 }
   }
+  #endif
 
   for (size_t i = 0; i < buffers.size(); ++i) {
 // If we aren't in BufferAllocationMode::kNone, this |picture| is
 // only used as a copy destination. Therefore, the VaapiWrapper used and
 // owned by |picture| is |vpp_vaapi_wrapper_|.
 std::unique_ptr picture = vaapi_picture_factory_->Create(
+   #if defined(OS_LINUX) && !defined(OS_ANDROID) && !defined(OS_CHROMEOS)
+vaapi_wrapper_,
+#else
 (buffer_allocation_mode_ == BufferAllocationMode::kNone)
 ? vaapi_wrapper_
 : vpp_vaapi_wrapper_,
+#endif
 make_context_current_cb_, bind_image_cb_, buffers[i]);
 

commit python-renderspec for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package python-renderspec for 
openSUSE:Factory checked in at 2019-09-23 12:37:16

Comparing /work/SRC/openSUSE:Factory/python-renderspec (Old)
 and  /work/SRC/openSUSE:Factory/.python-renderspec.new.7948 (New)


Package is "python-renderspec"

Mon Sep 23 12:37:16 2019 rev:8 rq:732093 version:1.12.0

Changes:

--- /work/SRC/openSUSE:Factory/python-renderspec/python-renderspec.changes  
2017-10-13 14:18:08.350816367 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-renderspec.new.7948/python-renderspec.changes
2019-09-23 12:38:38.429597888 +0200
@@ -1,0 +2,52 @@
+Fri Sep 20 07:49:13 UTC 2019 - Dirk Mueller 
+
+- add conflict for the impossible to workaround staging failures
+
+---
+Thu Jul 11 17:22:15 UTC 2019 - cloud-de...@suse.de
+
+- update to version 1.12.0
+  - Add contextfunctions 'py2' and 'py3'
+
+---
+Wed Jun 26 15:37:43 UTC 2019 - Dirk Mueller 
+
+- switch to python 3.x only package
+
+---
+Mon Jun 17 10:07:53 UTC 2019 - cloud-de...@suse.de
+
+- update to version 1.11.1
+  - Switch to TOX_CONSTRAINTS_FILE
+  - Update flake8 version to latest release
+  - Switch to openstackdocstheme
+  - OpenDev Migration Patch
+  - Preserve list order in _pymod2pkg_translate
+  - Fix _pymod2pkg_translate when skip_pyversion is None
+  - Follow opendev rebranding
+
+---
+Thu Apr 25 08:41:10 UTC 2019 - cloud-de...@suse.de
+
+- update to version 1.10.0
+  - fix tox python3 overrides
+  - Update home-page
+  - Update links in README
+  - Switch to stestr
+  - Change openstack-dev to openstack-discuss
+  - Move linter dependencies out of test-requirements
+  - Removed older version of python added 3.5
+  - Avoid tox_install.sh for constraints support
+  - switch documentation job to new PTI
+  - Update to a somewhat recent flake8 version
+  - add python 3.6 unit test job
+  - Updated from global requirements
+  - import zuul job settings from project-config
+- convert to singlespec
+
+---
+Wed Apr 10 10:48:02 UTC 2019 - Dirk Mueller 
+
+- refresh spec file from master
+
+---

Old:

  renderspec-1.9.1.tar.gz

New:

  renderspec-1.12.0.tar.gz



Other differences:
--
++ python-renderspec.spec ++
--- /var/tmp/diff_new_pack.okQR9G/_old  2019-09-23 12:38:38.785597829 +0200
+++ /var/tmp/diff_new_pack.okQR9G/_new  2019-09-23 12:38:38.785597829 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-renderspec
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,67 +12,96 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
-%global sname renderspec
+%global oldpython python
 Name:   python-renderspec
-Version:1.9.1
+Version:1.12.0
 Release:0
 Summary:Generate spec files from Jinja2 templates
 License:Apache-2.0
 Group:  Development/Languages/Python
-Url:http://launchpad.net/%{sname}
-Source0:
https://pypi.io/packages/source/r/%{sname}/%{sname}-%{version}.tar.gz
+URL:https://launchpad.net/renderspec
+Source0:
https://files.pythonhosted.org/packages/source/r/renderspec/renderspec-%{version}.tar.gz
 BuildRequires:  openstack-macros
-BuildRequires:  python-devel
-BuildRequires:  python-pbr >= 2.0.0
-Requires:   python-Jinja2 >= 2.8
-Requires:   python-PyYAML >= 3.10.0
+BuildRequires:  python2-Jinja2 >= 2.10
+BuildRequires:  python2-ddt
+BuildRequires:  python2-mock
+BuildRequires:  python2-packaging >= 16.5
+BuildRequires:  python2-pbr
+BuildRequires:  python2-pymod2pkg >= 0.7.0
+BuildRequires:  python2-stestr
+BuildRequires:  python3-Jinja2 >= 2.10
+BuildRequires:  python3-ddt
+BuildRequires:  python3-mock
+BuildRequires:  python3-packaging >= 16.5
+BuildRequires:  python3-pbr
+BuildRequires:  python3-pymod2pkg >= 0.7.0
+BuildRequires:  python3-stestr
+Requires:   python-Jinja2 >= 2.10
+Requires:   python-PyYAML >= 3.10
 Requires:   python-packaging >= 16.5
 Requires:   python-pymod2pkg >= 

commit python-Pweave for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package python-Pweave for openSUSE:Factory 
checked in at 2019-09-23 12:33:51

Comparing /work/SRC/openSUSE:Factory/python-Pweave (Old)
 and  /work/SRC/openSUSE:Factory/.python-Pweave.new.7948 (New)


Package is "python-Pweave"

Mon Sep 23 12:33:51 2019 rev:4 rq:731697 version:0.30.3

Changes:

--- /work/SRC/openSUSE:Factory/python-Pweave/python-Pweave.changes  
2019-03-06 15:50:06.348432788 +0100
+++ /work/SRC/openSUSE:Factory/.python-Pweave.new.7948/python-Pweave.changes
2019-09-23 12:37:41.621607234 +0200
@@ -1,0 +2,7 @@
+Wed Sep 18 09:24:15 UTC 2019 - Tomáš Chvátal 
+
+- Skip one more test that fails due to extra output from
+  new matplotlib:
+  * testFIR_FilterExampleTex
+
+---



Other differences:
--
++ python-Pweave.spec ++
--- /var/tmp/diff_new_pack.0iQcaw/_old  2019-09-23 12:37:43.609606907 +0200
+++ /var/tmp/diff_new_pack.0iQcaw/_new  2019-09-23 12:37:43.609606907 +0200
@@ -81,7 +81,8 @@
 
 %check
 # tests.test_readers.test_url - online
-%python_expand PYTHONPATH=%{buildroot}%{$python_sitelib} 
nosetests-%{$python_bin_suffix} -v -e test_url
+# testFIR_FilterExampleTex - contains warning from matplotlib that changes the 
output
+%python_expand PYTHONPATH=%{buildroot}%{$python_sitelib} 
nosetests-%{$python_bin_suffix} -v -e '(test_url|testFIR_FilterExampleTex)'
 
 %files %{python_files}
 %doc CHANGELOG.txt README.rst




commit eclipse-swt for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package eclipse-swt for openSUSE:Factory 
checked in at 2019-09-23 12:34:01

Comparing /work/SRC/openSUSE:Factory/eclipse-swt (Old)
 and  /work/SRC/openSUSE:Factory/.eclipse-swt.new.7948 (New)


Package is "eclipse-swt"

Mon Sep 23 12:34:01 2019 rev:27 rq:731724 version:4.3.1

Changes:

--- /work/SRC/openSUSE:Factory/eclipse-swt/eclipse-swt.changes  2019-01-24 
14:13:02.611388200 +0100
+++ /work/SRC/openSUSE:Factory/.eclipse-swt.new.7948/eclipse-swt.changes
2019-09-23 12:37:49.081606007 +0200
@@ -1,0 +2,7 @@
+Wed Sep 18 11:30:54 UTC 2019 - Bjørn Lie 
+
+- Drop gnome-vfs2-devel, libgnome-devel and libgnomeui-devel
+  BuildRequires: No longer build support for gnome-2.0 desktop, we
+  have not shipped that in years.
+
+---



Other differences:
--
++ eclipse-swt.spec ++
--- /var/tmp/diff_new_pack.MxTTj8/_old  2019-09-23 12:37:49.861605879 +0200
+++ /var/tmp/diff_new_pack.MxTTj8/_new  2019-09-23 12:37:49.865605878 +0200
@@ -45,14 +45,11 @@
 BuildRequires:  gcc
 BuildRequires:  gcc-c++
 BuildRequires:  glib2-devel
-BuildRequires:  gnome-vfs2-devel
 BuildRequires:  gtk2-devel
 BuildRequires:  java-devel >= 1.8
 BuildRequires:  javapackages-tools
 BuildRequires:  libXt-devel
 BuildRequires:  libXtst-devel
-BuildRequires:  libgnome-devel
-BuildRequires:  libgnomeui-devel
 BuildRequires:  make
 BuildRequires:  mozilla-nspr-devel
 BuildRequires:  pkgconfig




commit winetricks for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package winetricks for openSUSE:Factory 
checked in at 2019-09-23 12:36:45

Comparing /work/SRC/openSUSE:Factory/winetricks (Old)
 and  /work/SRC/openSUSE:Factory/.winetricks.new.7948 (New)


Package is "winetricks"

Mon Sep 23 12:36:45 2019 rev:5 rq:732082 version:20190912

Changes:

--- /work/SRC/openSUSE:Factory/winetricks/winetricks.changes2019-06-22 
11:25:12.645449250 +0200
+++ /work/SRC/openSUSE:Factory/.winetricks.new.7948/winetricks.changes  
2019-09-23 12:38:37.737598002 +0200
@@ -1,0 +2,6 @@
+Fri Sep 13 06:48:09 UTC 2019 - Marcus Meissner 
+
+- Update to 20190912
+  - lots of changes and updates
+
+---

Old:

  winetricks-20190615.tar.gz

New:

  winetricks-20190912.tar.gz



Other differences:
--
++ winetricks.spec ++
--- /var/tmp/diff_new_pack.2IBLHO/_old  2019-09-23 12:38:38.121597939 +0200
+++ /var/tmp/diff_new_pack.2IBLHO/_new  2019-09-23 12:38:38.125597938 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   winetricks
-Version:20190615
+Version:20190912
 Release:0
 Summary:A way to work around problems in WINE
 License:LGPL-2.1-or-later

++ winetricks-20190615.tar.gz -> winetricks-20190912.tar.gz ++
 1929 lines of diff (skipped)




commit SampleICC for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package SampleICC for openSUSE:Factory 
checked in at 2019-09-23 12:34:14

Comparing /work/SRC/openSUSE:Factory/SampleICC (Old)
 and  /work/SRC/openSUSE:Factory/.SampleICC.new.7948 (New)


Package is "SampleICC"

Mon Sep 23 12:34:14 2019 rev:9 rq:731998 version:1.6.8

Changes:

--- /work/SRC/openSUSE:Factory/SampleICC/SampleICC.changes  2014-09-10 
17:03:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.SampleICC.new.7948/SampleICC.changes
2019-09-23 12:37:57.113604686 +0200
@@ -1,0 +2,6 @@
+Tue Sep 10 12:01:56 UTC 2019 - Christophe Giboudeaux 
+
+- Use -ffat-lto-objects when building static libraries.
+- Run spec-cleaner
+
+---



Other differences:
--
++ SampleICC.spec ++
--- /var/tmp/diff_new_pack.eX4Jxx/_old  2019-09-23 12:37:57.797604573 +0200
+++ /var/tmp/diff_new_pack.eX4Jxx/_new  2019-09-23 12:37:57.801604572 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package SampleICC
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2011-2014 Kai-Uwe Behrmann
 #
 # All modifications and additions to the file contributed by third parties
@@ -13,21 +13,18 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   SampleICC
-Url:http://sourceforge.net/projects/sampleicc/
 Version:1.6.8
 Release:0
-Source: %{name}-%{version}.tar.gz
 Summary:Color Management System
 License:BSD-3-Clause
 Group:  Development/Libraries/Other
-
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-
+URL:https://sourceforge.net/projects/sampleicc/
+Source: %{name}-%{version}.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  gcc-c++
 BuildRequires:  gettext
@@ -50,7 +47,6 @@
 %description
 SampleICC provides an open source platform independent C++ library for 
reading, writing, manipulating, and applying ICC profiles along with 
applications that make use of this library.
 
-
 %description -n lib%{name}1
 SampleICC provides an open source platform independent C++ library for 
reading, writing, manipulating, and applying ICC profiles along with 
applications that make use of this library.
 
@@ -58,36 +54,35 @@
 Header files, libraries and documentation for development of Color Management
 applications.
 
-
 %prep
-%setup -n %{name}-%{version}
+%setup -q
 
 %build
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
 %configure
 
 %install
-make %{_smp_mflags}
-make DESTDIR=%{buildroot} install
-rm  %{buildroot}/%{_libdir}/lib*.la
+make  %{?_smp_mflags}
+%make_install
+find %{buildroot} -type f -name "*.la" -delete -print
 
 %post -n lib%{name}1 -p /sbin/ldconfig
-
 %postun -n lib%{name}1 -p /sbin/ldconfig
 
 %files
-%defattr(-, root, root)
-%doc AUTHORS COPYING ChangeLog README
+%license COPYING
+%doc AUTHORS ChangeLog README
 %{_bindir}/*
 
 %files -n lib%{name}1
-%defattr(-, root, root)
-%doc AUTHORS COPYING ChangeLog README
+%license COPYING
+%doc AUTHORS ChangeLog README
 %{_libdir}/lib%{name}.so.*
 %{_libdir}/libICC_utils.so.*
 
 %files -n lib%{name}-devel
-%defattr(-, root, root)
-%doc AUTHORS COPYING ChangeLog README
+%license COPYING
+%doc AUTHORS ChangeLog README
 %{_libdir}/lib%{name}.so
 %dir %{_includedir}/%{name}
 %{_includedir}/%{name}/*.h




commit vtk for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package vtk for openSUSE:Factory checked in 
at 2019-09-23 12:36:18

Comparing /work/SRC/openSUSE:Factory/vtk (Old)
 and  /work/SRC/openSUSE:Factory/.vtk.new.7948 (New)


Package is "vtk"

Mon Sep 23 12:36:18 2019 rev:42 rq:732075 version:8.2.0

Changes:

--- /work/SRC/openSUSE:Factory/vtk/vtk.changes  2019-04-15 11:53:05.454580270 
+0200
+++ /work/SRC/openSUSE:Factory/.vtk.new.7948/vtk.changes2019-09-23 
12:38:36.777598160 +0200
@@ -1,0 +2,5 @@
+Tue Sep 10 20:00:01 UTC 2019 - Christophe Giboudeaux 
+
+- Use -ffat-lto-objects when building static libraries.
+
+---



Other differences:
--
++ vtk.spec ++
--- /var/tmp/diff_new_pack.0vwzq6/_old  2019-09-23 12:38:37.565598030 +0200
+++ /var/tmp/diff_new_pack.0vwzq6/_new  2019-09-23 12:38:37.565598030 +0200
@@ -351,6 +351,7 @@
 grep -rl '\.\./\.\./\.\./\.\./VTKData' . | xargs -r perl -pi 
-e's,\.\./\.\./\.\./\.\./VTKData,%{_datadir}/vtkdata,g'
 
 %build
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
 %if %{with mpi}
 source %{mpiprefix}/bin/mpivars.sh
 export CC=mpicc




commit synnefo for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package synnefo for openSUSE:Factory checked 
in at 2019-09-23 12:34:37

Comparing /work/SRC/openSUSE:Factory/synnefo (Old)
 and  /work/SRC/openSUSE:Factory/.synnefo.new.7948 (New)


Package is "synnefo"

Mon Sep 23 12:34:37 2019 rev:3 rq:731999 version:1.1.0

Changes:

--- /work/SRC/openSUSE:Factory/synnefo/synnefo.changes  2017-02-07 
12:03:12.515819247 +0100
+++ /work/SRC/openSUSE:Factory/.synnefo.new.7948/synnefo.changes
2019-09-23 12:38:01.537603958 +0200
@@ -1,0 +2,7 @@
+Tue Sep 10 11:19:21 UTC 2019 - Christophe Giboudeaux 
+
+- Use -ffat-lto-objects when building static libraries.
+- Fix the package category
+- Run spec-cleaner
+
+---



Other differences:
--
++ synnefo.spec ++
--- /var/tmp/diff_new_pack.XwGWkJ/_old  2019-09-23 12:38:02.197603849 +0200
+++ /var/tmp/diff_new_pack.XwGWkJ/_new  2019-09-23 12:38:02.201603849 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package synnefo
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2013-2016 Kai-Uwe Behrmann 
 #
 # All modifications and additions to the file contributed by third parties
@@ -13,30 +13,28 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
+%define desktopdir  %{_datadir}/applications
+Name:   synnefo
 Version:1.1.0
 Release:0
-Name:   synnefo
-Url:http://www.oyranos.org/synnefo
-Source: synnefo_%{version}.orig.tar.bz2
-%define desktopdir  /usr/share/applications
-
 Summary:Color Management Settings GUI
 License:BSD-2-Clause
 Group:  System/GUI/Other
-
-BuildRequires:  liboyranos-devel
-# we need the oyranos_logo.png icon
-Requires:   oyranos
+URL:https://www.oyranos.org/synnefo
+Source: synnefo_%{version}.orig.tar.bz2
 BuildRequires:  cmake
 BuildRequires:  desktop-file-utils
 BuildRequires:  gcc-c++
+BuildRequires:  liboyranos-devel
+BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(Qt5DBus)
 BuildRequires:  pkgconfig(Qt5Widgets)
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+# we need the oyranos_logo.png icon
+Requires:   oyranos
 
 %package  -n libOyranosSynnefo1
 Summary:Oyranos Settings GUI
@@ -44,7 +42,7 @@
 
 %package  -n libOyranosSynnefo-devel
 Summary:Headers, configuration and documentation for synnefo
-Group:  Development/Libraries/C++
+Group:  Development/Languages/C and C++
 Requires:   libOyranosSynnefo1 = %{version}
 Requires:   liboyranos-devel
 
@@ -71,8 +69,9 @@
 %setup -q
 
 %build
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
 %cmake
-make VERBOSE=1 %{_smp_mflags}
+make VERBOSE=1 %{?_smp_mflags}
 
 %install
 %if 0%{?suse_version} > 0
@@ -81,11 +80,9 @@
 %cmake_install
 
 %post -n libOyranosSynnefo1 -p /sbin/ldconfig
-
 %postun -n libOyranosSynnefo1 -p /sbin/ldconfig
 
 %files
-%defattr(-, root, root)
 %doc README.md
 %{_bindir}/*%{name}
 %{_mandir}/man1/*%{name}*
@@ -93,12 +90,10 @@
 %{desktopdir}/*%{name}.desktop
 
 %files -n libOyranosSynnefo1
-%defattr(-, root, root)
 %doc README.md
 %{_libdir}/libOyranosSynnefo*.so.*
 
 %files -n libOyranosSynnefo-devel
-%defattr(-, root, root)
 %doc README.md
 %dir %{_includedir}/synnefo/
 %{_includedir}/synnefo/*
@@ -108,7 +103,6 @@
 %{_libdir}/libOyranosSynnefo*.so
 
 %files -n libOyranosSynnefo-devel-static
-%defattr(-,root,root)
 %{_libdir}/libOyranosSynnefo*-static.a
 
 %changelog




commit python-pymediainfo for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package python-pymediainfo for 
openSUSE:Factory checked in at 2019-09-23 12:34:04

Comparing /work/SRC/openSUSE:Factory/python-pymediainfo (Old)
 and  /work/SRC/openSUSE:Factory/.python-pymediainfo.new.7948 (New)


Package is "python-pymediainfo"

Mon Sep 23 12:34:04 2019 rev:6 rq:731753 version:4.1

Changes:

--- /work/SRC/openSUSE:Factory/python-pymediainfo/python-pymediainfo.changes
2019-09-16 10:52:47.799153625 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-pymediainfo.new.7948/python-pymediainfo.changes
  2019-09-23 12:37:50.473605778 +0200
@@ -1,0 +2,7 @@
+Wed Sep 18 14:25:50 UTC 2019 - Luigi Baldoni 
+
+- Update to version 4.1
+  * Added an argument to pass custom options to the parse method
+(#71)
+
+---

Old:

  pymediainfo-4.0.tar.gz

New:

  pymediainfo-4.1.tar.gz



Other differences:
--
++ python-pymediainfo.spec ++
--- /var/tmp/diff_new_pack.NtJifU/_old  2019-09-23 12:37:50.845605716 +0200
+++ /var/tmp/diff_new_pack.NtJifU/_new  2019-09-23 12:37:50.849605716 +0200
@@ -16,9 +16,8 @@
 #
 
 
-%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pymediainfo
-Version:4.0
+Version:4.1
 Release:0
 Summary:Python wrapper for the mediainfo library
 License:MIT

++ pymediainfo-4.0.tar.gz -> pymediainfo-4.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pymediainfo-4.0/PKG-INFO new/pymediainfo-4.1/PKG-INFO
--- old/pymediainfo-4.0/PKG-INFO2019-04-04 17:46:38.0 +0200
+++ new/pymediainfo-4.1/PKG-INFO2019-09-18 14:58:03.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: pymediainfo
-Version: 4.0
+Version: 4.1
 Summary: A Python wrapper for the mediainfo library.
 Home-page: https://github.com/sbraz/pymediainfo
 Author: Louis Sautier
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pymediainfo-4.0/appveyor.yml 
new/pymediainfo-4.1/appveyor.yml
--- old/pymediainfo-4.0/appveyor.yml2019-04-04 17:46:33.0 +0200
+++ new/pymediainfo-4.1/appveyor.yml2019-09-18 14:57:58.0 +0200
@@ -1,5 +1,5 @@
 environment:
-  MEDIAINFO_VERSION: 18.12
+  MEDIAINFO_VERSION: 19.09
   TWINE_PASSWORD:
 secure: /EO8CxTxhQVNsGNZZvU51jjHwPW524rgddNlwOAyLoA=
   matrix:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pymediainfo-4.0/pymediainfo/__init__.py 
new/pymediainfo-4.1/pymediainfo/__init__.py
--- old/pymediainfo-4.0/pymediainfo/__init__.py 2019-04-04 17:46:33.0 
+0200
+++ new/pymediainfo-4.1/pymediainfo/__init__.py 2019-09-18 14:57:58.0 
+0200
@@ -5,6 +5,7 @@
 import json
 import ctypes
 import sys
+import warnings
 from pkg_resources import get_distribution, DistributionNotFound
 import xml.etree.ElementTree as ET
 
@@ -199,7 +200,11 @@
 lib.MediaInfo_Delete.restype  = None
 lib.MediaInfo_Close.argtypes = [ctypes.c_void_p]
 lib.MediaInfo_Close.restype = None
-return lib
+# Obtain the library version
+lib_version_str = lib.MediaInfo_Option(None, "Info_Version", 
"")
+lib_version_str = re.search(r"^MediaInfoLib - v(\S+)", 
lib_version_str).group(1)
+lib_version = tuple(int(_) for _ in lib_version_str.split("."))
+return (lib, lib_version_str, lib_version)
 except OSError:
 # If we've tried all possible filenames
 if i == len(library_names):
@@ -219,7 +224,7 @@
 @classmethod
 def parse(cls, filename, library_file=None, cover_data=False,
 encoding_errors="strict", parse_speed=0.5, text=False,
-full=True, legacy_stream_display=False):
+full=True, legacy_stream_display=False, mediainfo_options=None):
 """
 Analyze a media file using libmediainfo.
 If libmediainfo is located in a non-standard location, the 
`library_file` parameter can be used:
@@ -243,6 +248,8 @@
 :param bool full: display additional tags, including computer-readable 
values
 for sizes and durations.
 :param bool legacy_stream_display: display additional information 
about streams.
+:param dict mediainfo_options: additional options that will be passed 
to the `MediaInfo_Option` function,
+for example: ``{"Language": "raw"}``
 :type filename: str or pathlib.Path
 :rtype: str if `text` is ``True``.
 :rtype: :class:`MediaInfo` otherwise.
@@ -253,7 +260,7 @@
 

commit mame for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package mame for openSUSE:Factory checked in 
at 2019-09-23 12:34:43

Comparing /work/SRC/openSUSE:Factory/mame (Old)
 and  /work/SRC/openSUSE:Factory/.mame.new.7948 (New)


Package is "mame"

Mon Sep 23 12:34:43 2019 rev:17 rq:732030 version:0.211

Changes:

--- /work/SRC/openSUSE:Factory/mame/mame.changes2019-05-03 
22:46:20.667757904 +0200
+++ /work/SRC/openSUSE:Factory/.mame.new.7948/mame.changes  2019-09-23 
12:38:04.345603496 +0200
@@ -1,0 +2,25 @@
+Thu Sep 19 11:56:56 UTC 2019 - Stefan Brüns 
+
+- Add LTO flags to LDFLAGS, avoids failing builds due to timeouts
+  during linking.
+
+---
+Thu Aug 22 19:20:55 UTC 2019 - Stefan Brüns 
+
+- Remove conditionals for EOLed distro versions
+- Adjust _constraints and limits to fix failing builds
+
+---
+Fri Jul  5 06:35:25 UTC 2019 - Martin Hauke 
+
+- Update to version 0.211
+  See http://mamedev.org/releases/whatsnew_0211.txt for details
+
+---
+Thu May 30 18:13:17 UTC 2019 - Martin Hauke 
+
+- Update to version 0.210
+  See http://mamedev.org/releases/whatsnew_0210.txt for details
+- Add BuildRequires "pkgconfig(xi)"
+
+---

Old:

  mame0209.tar.gz
  whatsnew_0209.txt

New:

  mame0211.tar.gz
  whatsnew_0211.txt



Other differences:
--
++ mame.spec ++
--- /var/tmp/diff_new_pack.bUahLN/_old  2019-09-23 12:38:26.825599797 +0200
+++ /var/tmp/diff_new_pack.bUahLN/_new  2019-09-23 12:38:26.829599797 +0200
@@ -16,7 +16,7 @@
 #
 
 
-%define fver209
+%define fver211
 
 # Build mame-mess by default, and use system libraries
 %bcond_without  mess
@@ -54,14 +54,11 @@
 BuildRequires:  pkgconfig(fontconfig)
 BuildRequires:  pkgconfig(sdl2)
 BuildRequires:  pkgconfig(x11)
+BuildRequires:  pkgconfig(xi)
 BuildRequires:  pkgconfig(xinerama)
 Requires(post): desktop-file-utils
 Requires(postun): desktop-file-utils
-%if 0%{?suse_version} <= 1315
-BuildRequires:  gcc7-c++
-%else
 BuildRequires:  gcc-c++
-%endif
 %if %{with systemlibs}
 BuildRequires:  libexpat-devel
 BuildRequires:  libjpeg8-devel
@@ -102,7 +99,6 @@
 %description tools
 Tools for use with MAME/MESS roms and images.
 
-%if %{with mess}
 %package mess
 Summary:Multi Emulator Super System
 Group:  System/Emulators/Other
@@ -120,7 +116,6 @@
 MESS is an emulator for many game consoles and computer systems, based on
 the MAME core and now a part of MAME. MESS emulates portable and console
 gaming systems, computer platforms, and calculators.
-%endif
 
 %package data
 Summary:Data files required by all builds of MAME
@@ -159,35 +154,27 @@
 sed -i "s@\. -s@\. %{myoptflags}@" 3rdparty/genie/build/gmake.linux/genie.make
 
 %build
-%limit_build -m 1600
+%limit_build -m 1800
 # Memory mapped files occupy the limited 32bit address space
 %ifarch %ix86 %arm
-export LDFLAGS="${LDFLAGS} -Wl,-v -fuse-ld=gold -Wl,--no-keep-files-mapped 
-Wl,--no-map-whole-files -Wl,--no-mmap-output-file"
+export LDFLAGS="${LDFLAGS} -Wl,-v -fuse-ld=gold -Wl,--no-keep-files-mapped 
-Wl,--no-map-whole-files -Wl,--no-mmap-output-file %{?_lto_cflags}"
 %else
-export LDFLAGS="${LDFLAGS} -Wl,-v -fuse-ld=gold"
+export LDFLAGS="${LDFLAGS} -Wl,-v -fuse-ld=gold %{?_lto_cflags}"
 %endif
 
-%if 0%{?suse_version} > 1320
 export CFLAGS=$(pkg-config --cflags lua)
-%endif
 
 COMMON_FLAGS="\
 NOWERROR=1 \
 VERBOSE=1 \
 OPTIMIZE=3 \
-%if 0%{?suse_version} <= 1315
-OVERRIDE_CC=gcc-7 \
-OVERRIDE_CXX=g++-7 \
-%endif
 %if %{with systemlibs}
 USE_SYSTEM_LIB_EXPAT=1 \
 USE_SYSTEM_LIB_ZLIB=1 \
 USE_SYSTEM_LIB_JPEG=1 \
 USE_SYSTEM_LIB_FLAC=1 \
-%if 0%{?suse_version} > 1320
 USE_SYSTEM_LIB_LUA=1 \
 USE_SYSTEM_LIB_UV=1 \
-%endif
 USE_SYSTEM_LIB_SQLITE3=1 \
 USE_SYSTEM_LIB_PORTMIDI=1 \
 USE_SYSTEM_LIB_PORTAUDIO=1 \
@@ -340,8 +327,8 @@
 %{_mandir}/man1/ldverify.1%{ext_man}
 %{_mandir}/man1/romcmp.1%{ext_man}
 
-%if %{with mess}
 %files mess
+%if %{with mess}
 %doc README.md whatsnew-%{version}.txt
 %license docs/LICENSE LICENSE.md
 %{_bindir}/mame-mess

++ _constraints ++
--- /var/tmp/diff_new_pack.bUahLN/_old  2019-09-23 12:38:26.861599792 +0200
+++ /var/tmp/diff_new_pack.bUahLN/_new  2019-09-23 12:38:26.865599791 +0200
@@ -1,14 +1,27 @@
 
   
 4
+
+  8
+
+
+  8
+
+  
+
+  
+
+  aarch64
+  x86_64
+  ppc64le
+
+
   
-42
+12
   
-  
-8
-  
   
-11
+13500
   
-  
+
+  

commit crmsh for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package crmsh for openSUSE:Factory checked 
in at 2019-09-23 12:34:10

Comparing /work/SRC/openSUSE:Factory/crmsh (Old)
 and  /work/SRC/openSUSE:Factory/.crmsh.new.7948 (New)


Package is "crmsh"

Mon Sep 23 12:34:10 2019 rev:162 rq:731950 version:4.1.0+git.1567524903.fff07b88

Changes:

--- /work/SRC/openSUSE:Factory/crmsh/crmsh.changes  2019-08-22 
10:52:54.365695588 +0200
+++ /work/SRC/openSUSE:Factory/.crmsh.new.7948/crmsh.changes2019-09-23 
12:37:54.665605088 +0200
@@ -1,0 +2,21 @@
+Tue Sep 03 15:39:31 UTC 2019 - kgronl...@suse.com
+
+- Update to version 4.1.0+git.1567524903.fff07b88:
+  * Doc: ui_resource: resolve maintenance vs is-managed conflict
+  * Test: ui_resource: resolve maintenance vs is-managed conflict
+  * Dev: ui_resource: resolve maintenance vs is-managed conflict
+
+---
+Tue Aug 27 13:41:08 UTC 2019 - kgronl...@suse.com
+
+- Update to version 4.1.0+git.1566912937.ad2608af:
+  * Test: ui_resource: maintenance: stop using crm_resource
+  * Dev: ui_resource: maintenance: stop using crm_resource
+
+---
+Thu Aug 22 08:36:44 UTC 2019 - dake...@suse.com
+
+- Update to version 4.1.0+git.1566462738.45748f84:
+  * Revert "dev: Suggestion: Try to centralized command options in one file"
+
+---

Old:

  crmsh-4.1.0+git.1566218232.dbdf060c.tar.bz2

New:

  crmsh-4.1.0+git.1567524903.fff07b88.tar.bz2



Other differences:
--
++ crmsh.spec ++
--- /var/tmp/diff_new_pack.HfJ2EY/_old  2019-09-23 12:37:55.181605003 +0200
+++ /var/tmp/diff_new_pack.HfJ2EY/_new  2019-09-23 12:37:55.181605003 +0200
@@ -36,7 +36,7 @@
 Summary:High Availability cluster command-line interface
 License:GPL-2.0-or-later
 Group:  %{pkg_group}
-Version:4.1.0+git.1566218232.dbdf060c
+Version:4.1.0+git.1567524903.fff07b88
 Release:0
 Url:http://crmsh.github.io
 Source0:%{name}-%{version}.tar.bz2

++ _servicedata ++
--- /var/tmp/diff_new_pack.HfJ2EY/_old  2019-09-23 12:37:55.213604998 +0200
+++ /var/tmp/diff_new_pack.HfJ2EY/_new  2019-09-23 12:37:55.213604998 +0200
@@ -1,4 +1,4 @@
 
 
 git://github.com/ClusterLabs/crmsh.git
-  dbdf060c6e4809cf562ff7beafbd5afff8de6ebf
\ No newline at end of file
+  f01ad01a93385b981987dad29a4c7ae019bfdd6b
\ No newline at end of file

++ crmsh-4.1.0+git.1566218232.dbdf060c.tar.bz2 -> 
crmsh-4.1.0+git.1567524903.fff07b88.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/crmsh-4.1.0+git.1566218232.dbdf060c/crmsh/options.py 
new/crmsh-4.1.0+git.1567524903.fff07b88/crmsh/options.py
--- old/crmsh-4.1.0+git.1566218232.dbdf060c/crmsh/options.py2019-08-19 
14:37:12.0 +0200
+++ new/crmsh-4.1.0+git.1567524903.fff07b88/crmsh/options.py2019-09-03 
17:35:03.0 +0200
@@ -16,77 +16,3 @@
 scriptdir = ""
 # set to true when completing non-interactively
 shell_completion = False
-
-
-arg_parameter_key = ["action", "dest", "metavar", "default", "type", "help"]
-
-cluster_init_base_options_value = [
-("-h", "--help", "store_true", "help", "", None, None, "Show this help 
message"),
-
-("-q", "--quiet", "store_true", "quiet", "", None, None,
- "Be quiet (don't describe what's happening, just do it)"),
-
-("-y", "--yes", "store_true", "yes_to_all", "", None, None,
- 'Answer "yes" to all prompts (use with caution, this is destructive, 
especially during the "storage" stage)'),
-
-("-t", "--template", "store", "template", "", None, None,
- 'Optionally configure cluster with template "name" (currently only 
"ocfs2" is valid here)'),
-
-("-n", "--name", "store", "name", "NAME", "hacluster", None,
- 'Set the name of the configured cluster.'),
-
-("-N", "--nodes", "store", "nodes", "NODES", None, None,
- 'Additional nodes to add to the created cluster. ' +
- 'May include the current node, which will always be the initial cluster 
node.'),
-
-("-S", "--enable-sbd", "store_true", "diskless_sbd", "", None, None,
- "Enable SBD even if no SBD device is configured (diskless mode)"),
-
-("-w", "--watchdog", "store", "watchdog", "WATCHDOG", None, None, "Use the 
given watchdog device")
-]
-
-cluster_init_net_options_value = [
-("-i", "--interface", "store", "nic", "IF", None, str, "Bind to IP address 
on interface IF"),
-
-("-u", "--unicast", "store_true", "unicast", "", None, None,
- "Configure corosync to communicate over unicast (UDP), and not multicast. 
" +
- 

commit openSUSE-MicroOS for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package openSUSE-MicroOS for 
openSUSE:Factory checked in at 2019-09-23 12:33:22

Comparing /work/SRC/openSUSE:Factory/openSUSE-MicroOS (Old)
 and  /work/SRC/openSUSE:Factory/.openSUSE-MicroOS.new.7948 (New)


Package is "openSUSE-MicroOS"

Mon Sep 23 12:33:22 2019 rev:4 rq:731673 version:16.0.0

Changes:

--- /work/SRC/openSUSE:Factory/openSUSE-MicroOS/openSUSE-MicroOS.changes
2019-08-24 18:45:47.809760827 +0200
+++ 
/work/SRC/openSUSE:Factory/.openSUSE-MicroOS.new.7948/openSUSE-MicroOS.changes  
2019-09-23 12:37:10.365612377 +0200
@@ -1,0 +2,18 @@
+Mon Sep  9 13:53:08 UTC 2019 - Fabian Vogt 
+
+- Regain sanity: Add replacebootconfig.sh to use the actual GRUB
+  config the system would generate itself
+- Mount by-uuid
+- Add rd.neednet=0 to work around dracut bug
+- Set ignition.platform.id in the cmdline
+- Remove swap for Pine64 and RPi3 and the pointless swapaccount
+  parameter from all flavours (boo#1149663)
+
+---
+Thu Aug 29 15:25:19 UTC 2019 - Fabian Vogt 
+
+- Use creative kiwi approach for modifying /etc/fstab (boo#1129566)
+- Use ignition-dracut
+- Add /boot/writable subvolume
+
+---

New:

  replacebootconfig.sh



Other differences:
--
++ openSUSE-MicroOS.kiwi ++
--- /var/tmp/diff_new_pack.Yz4ng5/_old  2019-09-23 12:37:16.593611352 +0200
+++ /var/tmp/diff_new_pack.Yz4ng5/_new  2019-09-23 12:37:16.593611352 +0200
@@ -99,13 +99,14 @@
 bootloader="grub2"
 bootloader_console="gfxterm"
 firmware="uefi"
-kernelcmdline="plymouth.enable=0 console=ttyS0,115200 console=tty0 
net.ifnames=0 swapaccount=1"
+kernelcmdline="plymouth.enable=0 console=ttyS0,115200 console=tty0 
net.ifnames=0 $ignition_firstboot ignition.platform.id=qemu rd.neednet=0"
 bootpartition="false"
 bootkernel="custom"
-devicepersistency="by-label"
+devicepersistency="by-uuid"
 btrfs_root_is_snapshot="true"
 btrfs_root_is_readonly_snapshot="true"
 btrfs_quota_groups="false"
+editbootinstall="replacebootconfig.sh"
 >
 
 
@@ -115,6 +116,7 @@
 
 
 
+
 
 
 
@@ -134,13 +136,14 @@
 bootloader="grub2"
 bootloader_console="gfxterm"
 firmware="uefi"
-kernelcmdline="plymouth.enable=0 console=ttyS0,115200 console=tty0 
swapaccount=1"
+kernelcmdline="plymouth.enable=0 console=ttyS0,115200 console=tty0 
$ignition_firstboot ignition.platform.id=vmware rd.neednet=0"
 bootpartition="false"
 bootkernel="custom"
-devicepersistency="by-label"
+devicepersistency="by-uuid"
 btrfs_root_is_snapshot="true"
 btrfs_root_is_readonly_snapshot="true"
 btrfs_quota_groups="false"
+editbootinstall="replacebootconfig.sh"
 >
 
 
@@ -150,6 +153,7 @@
 
 
 
+
 
 
 
@@ -170,13 +174,14 @@
 bootloader="grub2"
 bootloader_console="gfxterm"
 firmware="uefi"
-kernelcmdline="plymouth.enable=0 console=ttyS0,115200 console=tty0 
net.ifnames=0 swapaccount=1"
+kernelcmdline="plymouth.enable=0 console=ttyS0,115200 console=tty0 
net.ifnames=0 $ignition_firstboot ignition.platform.id=openstack rd.neednet=0"
 bootpartition="false"
 bootkernel="custom"
-devicepersistency="by-label"
+devicepersistency="by-uuid"
 btrfs_root_is_snapshot="true"
 btrfs_root_is_readonly_snapshot="true"
 btrfs_quota_groups="false"
+editbootinstall="replacebootconfig.sh"
 >
 
 
@@ -186,6 +191,7 @@
 
 
 
+
 
 
 
@@ -206,13 +212,14 @@
 bootloader="grub2"
 bootloader_console="gfxterm"
 firmware="uefi"
-kernelcmdline="plymouth.enable=0 USE_BY_UUID_DEVICE_NAMES=1 
rootdelay=300 console=ttyS0,115200 console=tty0 earlyprintk=ttyS0,115200 
swapaccount=1"
+kernelcmdline="plymouth.enable=0 rootdelay=300 
console=ttyS0,115200 console=tty0 earlyprintk=ttyS0,115200 $ignition_firstboot 
ignition.platform.id=metal"
 

commit python-aiohttp for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package python-aiohttp for openSUSE:Factory 
checked in at 2019-09-23 12:33:10

Comparing /work/SRC/openSUSE:Factory/python-aiohttp (Old)
 and  /work/SRC/openSUSE:Factory/.python-aiohttp.new.7948 (New)


Package is "python-aiohttp"

Mon Sep 23 12:33:10 2019 rev:15 rq:731668 version:3.6.0

Changes:

--- /work/SRC/openSUSE:Factory/python-aiohttp/python-aiohttp.changes
2019-09-16 10:50:46.387169352 +0200
+++ /work/SRC/openSUSE:Factory/.python-aiohttp.new.7948/python-aiohttp.changes  
2019-09-23 12:36:40.093617357 +0200
@@ -1,0 +2,7 @@
+Wed Sep 18 07:34:10 UTC 2019 - Matthias Fehring 
+
+- Add patch to fix type error with old multidict:
+  * aiohttp-3.6.0-fix-typeerror.patch
+- Require python-multidict 4.5 or newer
+
+---

New:

  aiohttp-3.6.0-fix-typeerror.patch



Other differences:
--
++ python-aiohttp.spec ++
--- /var/tmp/diff_new_pack.zhBIwp/_old  2019-09-23 12:36:42.673616932 +0200
+++ /var/tmp/diff_new_pack.zhBIwp/_new  2019-09-23 12:36:42.677616932 +0200
@@ -26,12 +26,14 @@
 Group:  Development/Languages/Python
 URL:https://github.com/aio-libs/aiohttp
 Source: 
https://files.pythonhosted.org/packages/source/a/aiohttp/aiohttp-%{version}.tar.gz
+# PATCH-FIX-UPSTREAM aiohttp-3.6.0-fix-typeerror.patch
+Patch0: aiohttp-3.6.0-fix-typeerror.patch
 BuildRequires:  %{python_module Cython}
 BuildRequires:  %{python_module async_timeout >= 3.0}
 BuildRequires:  %{python_module attrs >= 17.3.0}
 BuildRequires:  %{python_module chardet >= 2.0}
 BuildRequires:  %{python_module devel >= 3.5.3}
-BuildRequires:  %{python_module multidict >= 4.0}
+BuildRequires:  %{python_module multidict >= 4.5}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
@@ -41,7 +43,7 @@
 Requires:   python-brotlipy
 Requires:   python-chardet >= 2.0
 Requires:   python-gunicorn
-Requires:   python-multidict >= 4.0
+Requires:   python-multidict >= 4.5
 Requires:   python-yarl >= 1.0
 Recommends: python-aiodns
 Recommends: python-cChardet
@@ -93,6 +95,7 @@
 
 %prep
 %setup -q -n aiohttp-%{version}
+%patch0 -p1
 
 %build
 export CFLAGS="%{optflags}"

++ aiohttp-3.6.0-fix-typeerror.patch ++
From: Matthias Fehring 
Date: 2019-09-18 09:23:00 +0200
Subject: fix type error
Upstream: merged (https://github.com/aio-libs/aiohttp/pull/4057)

At least multidict 4.5 is now required.

---
 setup.py |2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--- a/setup.py  2019-09-06 14:54:33.0 +0200
+++ b/setup.py  2019-09-18 09:19:56.227118006 +0200
@@ -71,7 +71,7 @@
 install_requires = [
 'attrs>=17.3.0',
 'chardet>=2.0,<4.0',
-'multidict>=4.0,<5.0',
+'multidict>=4.5,<5.0',
 'async_timeout>=3.0,<4.0',
 'yarl>=1.0,<2.0',
 'idna-ssl>=1.0; python_version<"3.7"',



commit rclone for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package rclone for openSUSE:Factory checked 
in at 2019-09-23 12:32:54

Comparing /work/SRC/openSUSE:Factory/rclone (Old)
 and  /work/SRC/openSUSE:Factory/.rclone.new.7948 (New)


Package is "rclone"

Mon Sep 23 12:32:54 2019 rev:12 rq:731656 version:1.49.3

Changes:

--- /work/SRC/openSUSE:Factory/rclone/rclone.changes2019-09-09 
12:39:02.373436440 +0200
+++ /work/SRC/openSUSE:Factory/.rclone.new.7948/rclone.changes  2019-09-23 
12:35:10.157632153 +0200
@@ -1,0 +2,9 @@
+Sun Sep 15 17:21:05 UTC 2019 - Ismail Dönmez 
+
+- Update to version 1.49.3
+  * Bug Fixes
+- accounting
+  + Fix total duration calculation (Aleksandar Jankovic)
+  + Fix “file already closed” on transfer retries (Nick Craig-Wood)
+
+---

Old:

  rclone-1.49.2.obscpio

New:

  rclone-1.49.3.obscpio



Other differences:
--
++ rclone.spec ++
--- /var/tmp/diff_new_pack.rgplzh/_old  2019-09-23 12:35:20.769630407 +0200
+++ /var/tmp/diff_new_pack.rgplzh/_new  2019-09-23 12:35:20.773630406 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   rclone
-Version:1.49.2
+Version:1.49.3
 Release:0
 Summary:Rsync for cloud storage
 License:MIT

++ _service ++
--- /var/tmp/diff_new_pack.rgplzh/_old  2019-09-23 12:35:20.809630401 +0200
+++ /var/tmp/diff_new_pack.rgplzh/_new  2019-09-23 12:35:20.809630401 +0200
@@ -3,8 +3,8 @@
 https://github.com/ncw/rclone.git
 git
 .git
-1.49.2
-v1.49.2
+1.49.3
+v1.49.3
 rclone
   
   

++ rclone-1.49.2.obscpio -> rclone-1.49.3.obscpio ++
/work/SRC/openSUSE:Factory/rclone/rclone-1.49.2.obscpio 
/work/SRC/openSUSE:Factory/.rclone.new.7948/rclone-1.49.3.obscpio differ: char 
50, line 1

++ rclone.obsinfo ++
--- /var/tmp/diff_new_pack.rgplzh/_old  2019-09-23 12:35:20.857630393 +0200
+++ /var/tmp/diff_new_pack.rgplzh/_new  2019-09-23 12:35:20.857630393 +0200
@@ -1,5 +1,5 @@
 name: rclone
-version: 1.49.2
-mtime: 1567957734
-commit: f1a9d821e46aa41d6a12857fc297ef50a7645569
+version: 1.49.3
+mtime: 1568562130
+commit: 1bdab29eabaa2a8216ecc90a26cf1cb92378b3d3
 




commit python-tap.py for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package python-tap.py for openSUSE:Factory 
checked in at 2019-09-23 12:32:35

Comparing /work/SRC/openSUSE:Factory/python-tap.py (Old)
 and  /work/SRC/openSUSE:Factory/.python-tap.py.new.7948 (New)


Package is "python-tap.py"

Mon Sep 23 12:32:35 2019 rev:2 rq:731649 version:2.6.1

Changes:

--- /work/SRC/openSUSE:Factory/python-tap.py/python-tap.py.changes  
2019-03-22 15:10:25.905335455 +0100
+++ /work/SRC/openSUSE:Factory/.python-tap.py.new.7948/python-tap.py.changes
2019-09-23 12:32:40.461656781 +0200
@@ -1,0 +2,6 @@
+Wed Sep 18 07:28:19 UTC 2019 - Tomáš Chvátal 
+
+- Update to 2.6.1:
+  * Fix to work with new releases of more-itertools
+
+---

Old:

  tap.py-2.5.tar.gz

New:

  tap.py-2.6.1.tar.gz



Other differences:
--
++ python-tap.py.spec ++
--- /var/tmp/diff_new_pack.ULVgNV/_old  2019-09-23 12:32:42.005656527 +0200
+++ /var/tmp/diff_new_pack.ULVgNV/_new  2019-09-23 12:32:42.009656527 +0200
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-tap.py
-Version:2.5
+Version:2.6.1
 Release:0
 Summary:Test Anything Protocol (TAP) tools
 License:BSD-2-Clause

++ tap.py-2.5.tar.gz -> tap.py-2.6.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tap.py-2.5/LICENSE new/tap.py-2.6.1/LICENSE
--- old/tap.py-2.5/LICENSE  2018-01-07 03:13:00.0 +0100
+++ new/tap.py-2.6.1/LICENSE2019-09-17 02:58:18.0 +0200
@@ -1,4 +1,4 @@
-Copyright (c) 2018, Matt Layman and contributors. See AUTHORS for more details.
+Copyright (c) 2019, Matt Layman and contributors. See AUTHORS for more details.
 All rights reserved.
 
 Redistribution and use in source and binary forms, with or without
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tap.py-2.5/PKG-INFO new/tap.py-2.6.1/PKG-INFO
--- old/tap.py-2.5/PKG-INFO 2018-09-15 02:18:40.0 +0200
+++ new/tap.py-2.6.1/PKG-INFO   2019-09-17 15:36:47.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: tap.py
-Version: 2.5
+Version: 2.6.1
 Summary: Test Anything Protocol (TAP) tools
 Home-page: https://github.com/python-tap/tappy
 Author: Matt Layman
@@ -19,6 +19,17 @@
 Releases
 
 
+Version 2.6.1, Released September 17, 2019
+--
+
+* Fix TAP version 13 support from more-itertools behavior change.
+
+Version 2.6, Released September 16, 2019
+
+
+* Add support for Python 3.7.
+* Drop support for Python 3.4 (it is end-of-life).
+
 Version 2.5, Released September 15, 2018
 
 
@@ -175,9 +186,9 @@
 Classifier: License :: OSI Approved :: BSD License
 Classifier: Operating System :: OS Independent
 Classifier: Programming Language :: Python :: 2.7
-Classifier: Programming Language :: Python :: 3.4
 Classifier: Programming Language :: Python :: 3.5
 Classifier: Programming Language :: Python :: 3.6
+Classifier: Programming Language :: Python :: 3.7
 Classifier: Programming Language :: Python :: Implementation :: PyPy
 Classifier: Topic :: Software Development :: Testing
 Provides-Extra: yaml
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tap.py-2.5/Pipfile new/tap.py-2.6.1/Pipfile
--- old/tap.py-2.5/Pipfile  2018-09-15 01:32:59.0 +0200
+++ new/tap.py-2.6.1/Pipfile2019-01-23 19:31:06.0 +0100
@@ -6,7 +6,7 @@
 [dev-packages]
 Babel = "*"
 coverage = "*"
-"flake8" = "*"
+"flake8" = "==3.6.0"
 mock = "*"
 requests = "*"
 Sphinx = "*"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tap.py-2.5/README.md new/tap.py-2.6.1/README.md
--- old/tap.py-2.5/README.md2018-05-15 15:23:06.0 +0200
+++ new/tap.py-2.6.1/README.md  2019-09-17 03:43:18.0 +0200
@@ -29,9 +29,9 @@
 tappy is available for download from [PyPI][pypi]. tappy is currently supported
 on Python
 2.7,
-3.4,
 3.5,
 3.6,
+3.7,
 and PyPy.
 It is continuously tested on Linux, OS X, and Windows.
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/tap.py-2.5/docs/conf.py new/tap.py-2.6.1/docs/conf.py
--- old/tap.py-2.5/docs/conf.py 2018-01-07 03:13:55.0 +0100
+++ new/tap.py-2.6.1/docs/conf.py   2019-09-17 02:58:18.0 +0200
@@ -52,7 +52,7 @@
 
 # General information about 

commit perl-Pango for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package perl-Pango for openSUSE:Factory 
checked in at 2019-09-23 12:32:49

Comparing /work/SRC/openSUSE:Factory/perl-Pango (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Pango.new.7948 (New)


Package is "perl-Pango"

Mon Sep 23 12:32:49 2019 rev:23 rq:731655 version:1.227

Changes:

--- /work/SRC/openSUSE:Factory/perl-Pango/perl-Pango.changes2016-01-15 
10:42:25.0 +0100
+++ /work/SRC/openSUSE:Factory/.perl-Pango.new.7948/perl-Pango.changes  
2019-09-23 12:32:52.317654831 +0200
@@ -1,0 +2,17 @@
+Mon Sep 16 17:35:41 UTC 2019 - Tina Mueller 
+
+- Override description in cpanspec
+
+---
+Fri Sep  6 21:01:49 UTC 2019 - Tina Mueller 
+
+- Remove fix-pangocairo_libs.patch (not needed anymore)
+   Add custom dependencies and test to cpanspec.yml
+
+---
+Wed Apr  3 07:21:56 UTC 2019 - Stephan Kulow 
+
+- updated to 1.227
+   see /usr/share/doc/packages/perl-Pango/ChangeLog.pre-git
+
+---

Old:

  Pango-1.226.tar.gz
  fix-pangocairo_libs.patch

New:

  Pango-1.227.tar.gz
  cpanspec.yml



Other differences:
--
++ perl-Pango.spec ++
--- /var/tmp/diff_new_pack.mQN0A8/_old  2019-09-23 12:32:53.341654662 +0200
+++ /var/tmp/diff_new_pack.mQN0A8/_new  2019-09-23 12:32:53.345654662 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package perl-Pango
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,50 +12,42 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
-%bcond_with Gtk2
-
 Name:   perl-Pango
-Version:1.226
+Version:1.227
 Release:0
 %define cpan_name Pango
-Summary:Pango Perl module
-License:LGPL-2.1+
+Summary:Layout and render international text
+License:LGPL-2.1-or-later
 Group:  Development/Libraries/Perl
-Url:http://search.cpan.org/dist/Pango/
-Source: 
http://www.cpan.org/authors/id/X/XA/XAOC/%{cpan_name}-%{version}.tar.gz
-# PATCH-FIX-UPSTREAM fix-pangocairo_libs.patch 
https://rt.cpan.org/Public/Bug/Display.html?id=17
-Patch0: fix-pangocairo_libs.patch
-#
+Url:https://metacpan.org/release/%{cpan_name}
+Source0:
https://cpan.metacpan.org/authors/id/X/XA/XAOC/%{cpan_name}-%{version}.tar.gz
+Source1:cpanspec.yml
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  perl
 BuildRequires:  perl-macros
-BuildRequires:  update-desktop-files
+BuildRequires:  perl(Cairo) >= 1.000
+BuildRequires:  perl(ExtUtils::Depends) >= 0.300
+BuildRequires:  perl(ExtUtils::PkgConfig) >= 1.03
+BuildRequires:  perl(Glib) >= 1.220
+Requires:   perl(Cairo) >= 1.000
+Requires:   perl(ExtUtils::Depends) >= 0.300
+Requires:   perl(ExtUtils::PkgConfig) >= 1.03
+Requires:   perl(Glib) >= 1.220
+%{perl_requires}
+# MANUAL BEGIN
 BuildRequires:  xorg-x11
 BuildRequires:  xorg-x11-Xvfb
 BuildRequires:  xorg-x11-server
 BuildRequires:  pkgconfig(cairo)
 BuildRequires:  pkgconfig(pango)
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%{perl_requires}
 %if %{with Gtk2}
 BuildRequires:  perl(Gtk2) >= 1.220
 %endif
-#
-BuildRequires:  perl(Cairo) >= 1.000
-BuildRequires:  perl(ExtUtils::Depends) >= 0.300
-BuildRequires:  perl(ExtUtils::MakeMaker)
-#BuildRequires:  perl(ExtUtils::PkgConfig) >= 1.030
-BuildRequires:  perl(ExtUtils::PkgConfig) >= 1.03
-BuildRequires:  perl(Glib) >= 1.220
-#
-Requires:   perl(Cairo) >= 1.000
-Requires:   perl(ExtUtils::Depends) >= 0.300
-#Requires:   perl(ExtUtils::PkgConfig) >= 1.030
-Requires:   perl(ExtUtils::PkgConfig) >= 1.03
-Requires:   perl(Glib) >= 1.220
+# MANUAL END
 
 %description
 Pango is a library for laying out and rendering text, with an emphasis on
@@ -76,7 +68,6 @@
 
 %prep
 %setup -q -n %{cpan_name}-%{version}
-%patch0
 
 %build
 perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
@@ -103,11 +94,9 @@
 %perl_process_packlist
 %perl_gen_filelist
 
-%clean
-rm -rf %{buildroot}
-
 %files -f %{name}.files
-%defattr(-,root,root,-)
-%doc AUTHORS ChangeLog.pre-git doctypes LICENSE maps-1.0 maps-1.10 maps-1.16 
maps-1.18 maps-1.4 maps-1.6 maps-1.8 NEWS pango.exports 

commit firecracker for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package firecracker for openSUSE:Factory 
checked in at 2019-09-23 12:31:54

Comparing /work/SRC/openSUSE:Factory/firecracker (Old)
 and  /work/SRC/openSUSE:Factory/.firecracker.new.7948 (New)


Package is "firecracker"

Mon Sep 23 12:31:54 2019 rev:2 rq:730766 version:0.17.0

Changes:

--- /work/SRC/openSUSE:Factory/firecracker/firecracker.changes  2019-09-11 
10:41:06.299212449 +0200
+++ /work/SRC/openSUSE:Factory/.firecracker.new.7948/firecracker.changes
2019-09-23 12:32:02.373663047 +0200
@@ -1,0 +2,5 @@
+Fri Sep 13 14:45:15 UTC 2019 - Jan Engelhardt 
+
+- Trim marketing wording from description.
+
+---



Other differences:
--
++ firecracker.spec ++
--- /var/tmp/diff_new_pack.hATDrA/_old  2019-09-23 12:32:04.053662771 +0200
+++ /var/tmp/diff_new_pack.hATDrA/_new  2019-09-23 12:32:04.053662771 +0200
@@ -12,16 +12,17 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
+
 # Use hardening ldflags.
 %define cargo_home cargo-home
 
 Name:   firecracker
 Version:0.17.0
 Release:0
-Summary:Secure and fast microVMs for serverless computing
+Summary:Virtual Machine Monitor for creating microVMs
 License:Apache-2.0
 Group:  System/Management
 URL:https://firecracker-microvm.github.io/
@@ -36,9 +37,8 @@
 ExclusiveArch:  x86_64 aarch64
 
 %description
-Firecracker is an open source virtualization technology that is purpose-built
-for creating and managing secure, multi-tenant container and function-based
-services.
+Firecracker is a virtualization technology for creating and managing
+multi-tenant container and function-based services.
 
 %prep
 %setup -q -a1




commit embree for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package embree for openSUSE:Factory checked 
in at 2019-09-23 12:32:14

Comparing /work/SRC/openSUSE:Factory/embree (Old)
 and  /work/SRC/openSUSE:Factory/.embree.new.7948 (New)


Package is "embree"

Mon Sep 23 12:32:14 2019 rev:2 rq:731334 version:3.5.2

Changes:

--- /work/SRC/openSUSE:Factory/embree/embree.changes2019-09-11 
10:33:11.799334497 +0200
+++ /work/SRC/openSUSE:Factory/.embree.new.7948/embree.changes  2019-09-23 
12:32:17.141660618 +0200
@@ -1,0 +2,5 @@
+Mon Sep  9 17:40:25 UTC 2019 - Jan Engelhardt 
+
+- Trim marketing from description.
+
+---



Other differences:
--
++ embree.spec ++
--- /var/tmp/diff_new_pack.PafP2e/_old  2019-09-23 12:32:18.173660448 +0200
+++ /var/tmp/diff_new_pack.PafP2e/_new  2019-09-23 12:32:18.173660448 +0200
@@ -19,10 +19,10 @@
 Name:   embree
 Version:3.5.2
 Release:0
-Summary:High Performance Ray Tracing Kernels
+Summary:Ray Tracing Kernels
 License:Apache-2.0
 Group:  Development/Libraries/C and C++
-Url:https://github.com/embree/embree
+URL:https://github.com/embree/embree
 Source: 
https://github.com/%{name}/%{name}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
 BuildRequires:  cmake >= 2.8.6
 BuildRequires:  gcc-c++
@@ -34,16 +34,16 @@
 ExclusiveArch:  x86_64
 
 %description
-Intel Embree is a collection of high-performance ray tracing kernels, developed
+Intel Embree is a collection of ray tracing kernels originally developed
 at Intel. The target users of Intel Embree are graphics application engineers
 who want to improve the performance of their photo-realistic rendering
-application by leveraging Embree's performance-optimized ray tracing kernels.
+application by leveraging Embree's ray tracing kernels.
 
 Note:
 This version is specifically dedicated to Blender Cycles, as it is using the
-build options, that are required for it. In order to reduce the risk of
-incompatibilities, it is build as static libraries, which is also enforced by
-the Blender Cycles build for the time being..
+build options that are required for it. In order to reduce the risk of
+incompatibilities, it is built as static libraries, which is also enforced by
+the Blender Cycles build for the time being.
 
 %package   devel-static
 Summary:Development files for embree




commit ltxml for openSUSE:Factory

2019-09-23 Thread root
Hello community,

here is the log from the commit of package ltxml for openSUSE:Factory checked 
in at 2019-09-23 12:31:46

Comparing /work/SRC/openSUSE:Factory/ltxml (Old)
 and  /work/SRC/openSUSE:Factory/.ltxml.new.7948 (New)


Package is "ltxml"

Mon Sep 23 12:31:46 2019 rev:19 rq:730763 version:1.2.7

Changes:

--- /work/SRC/openSUSE:Factory/ltxml/ltxml.changes  2019-09-11 
10:41:58.119203220 +0200
+++ /work/SRC/openSUSE:Factory/.ltxml.new.7948/ltxml.changes2019-09-23 
12:31:51.537664830 +0200
@@ -1,0 +2,5 @@
+Fri Sep 13 13:56:29 UTC 2019 - Jan Engelhardt 
+
+- Redo boilerplate descriptions.
+
+---



Other differences:
--
++ ltxml.spec ++
--- /var/tmp/diff_new_pack.MEbGGc/_old  2019-09-23 12:31:53.201664556 +0200
+++ /var/tmp/diff_new_pack.MEbGGc/_new  2019-09-23 12:31:53.205664556 +0200
@@ -31,7 +31,7 @@
 Requires:   python
 
 %description
-LT XML is an integrated set of XML tools and a developers' tool kit,
+LT XML is an integrated set of XML tools and a developer's tool kit,
 including a C-based API.
 
 The LT XML tool kit includes stand-alone tools for a wide range of
@@ -52,14 +52,13 @@
 those parts of an XML document which are of interest.
 
 %package devel
-Summary:Include Files and Libraries mandatory for Development
+Summary:Header files for ltxml
 Group:  Development/Libraries/C and C++
 Requires:   ltxml
-#Provides:
 
 %description devel
 This package contains all necessary include files and libraries needed
-to develop applications that require these.
+to develop applications that want to make use of ltxml.
 
 %define INSTALL install -m755 -s
 %define INSTALL_SCRIPT install -m755
@@ -89,9 +88,6 @@
 make %{?_smp_mflags} test CFLAGS="%{optflags}"
 
 %install
-if [ ! "x" = "x$RPM_BUILD_ROOT" ] ; then
-   %{INSTALL_DIR} %{buildroot}
-fi
 pushd build
 make install CFLAGS="%{optflags}" \
  prefix=%{buildroot}%{_prefix} \




  1   2   3   >