commit 000product for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package 000product for openSUSE:Factory 
checked in at 2019-10-18 02:07:19

Comparing /work/SRC/openSUSE:Factory/000product (Old)
 and  /work/SRC/openSUSE:Factory/.000product.new.2352 (New)


Package is "000product"

Fri Oct 18 02:07:19 2019 rev:1692 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ openSUSE-Addon-NonOss-ftp-ftp-i586_x86_64.kiwi ++
--- /var/tmp/diff_new_pack.XjcxQ4/_old  2019-10-18 02:07:22.730102604 +0200
+++ /var/tmp/diff_new_pack.XjcxQ4/_new  2019-10-18 02:07:22.734102594 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -36,11 +36,11 @@
   true
   -x -2
   openSUSE
-  20191016
+  20191017
   11
-  cpe:/o:opensuse:opensuse-addon-nonoss:20191016,openSUSE NonOSS 
Addon
+  cpe:/o:opensuse:opensuse-addon-nonoss:20191017,openSUSE NonOSS 
Addon
   af ar be_BY bg br ca cy el et ga gl gu_IN he 
hi_IN hr ka km ko lt mk nn pa_IN rw sk sl sr_CS ss st tg th tr uk ve vi xh zu 

-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20191016/i586
 
obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20191016/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20191017/i586
 
obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-Addon-NonOss/20191017/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-MicroOS-dvd5-dvd-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.XjcxQ4/_old  2019-10-18 02:07:22.762102523 +0200
+++ /var/tmp/diff_new_pack.XjcxQ4/_new  2019-10-18 02:07:22.762102523 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20191016
+  20191017
   11
-  cpe:/o:opensuse:opensuse-microos:20191016,openSUSE 
MicroOS
+  cpe:/o:opensuse:opensuse-microos:20191017,openSUSE 
MicroOS
   en_US 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20191016/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE-MicroOS/20191017/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
@@ -231,7 +231,7 @@
   
   
   
-  
+  
   
   
   

openSUSE-MicroOS-dvd5-kubic-dvd-x86_64.kiwi: same change
++ openSUSE-cd-mini-i586.kiwi ++
--- /var/tmp/diff_new_pack.XjcxQ4/_old  2019-10-18 02:07:22.822102371 +0200
+++ /var/tmp/diff_new_pack.XjcxQ4/_new  2019-10-18 02:07:22.822102371 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,11 +32,11 @@
   true
   -x -2
   openSUSE
-  20191016
+  20191017
   11
-  cpe:/o:opensuse:opensuse:20191016,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20191017,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20191016/i586
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20191017/i586
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-cd-mini-x86_64.kiwi ++
--- /var/tmp/diff_new_pack.XjcxQ4/_old  2019-10-18 02:07:22.858102279 +0200
+++ /var/tmp/diff_new_pack.XjcxQ4/_new  2019-10-18 02:07:22.862102269 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -35,11 +35,11 @@
   true
   -x -2
   openSUSE
-  20191016
+  20191017
   11
-  cpe:/o:opensuse:opensuse:20191016,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20191017,openSUSE 
Tumbleweed
   cs da de el en en_GB en_US es fr hu it ja pl 
pt pt_BR ru zh zh_CN zh_TW 
-  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20191016/x86_64
+  obsproduct://build.opensuse.org/openSUSE:Factory/openSUSE/20191017/x86_64
   openSUSE
   /usr/share/kiwi/modules/plugins/suse-tumbleweed
   /usr/share/kiwi/modules/plugins/suse-tumbleweed

++ openSUSE-dvd5-dvd-i586.kiwi ++
--- /var/tmp/diff_new_pack.XjcxQ4/_old  2019-10-18 02:07:22.890102198 +0200
+++ /var/tmp/diff_new_pack.XjcxQ4/_new  2019-10-18 02:07:22.894102188 +0200
@@ -1,4 +1,4 @@
-
+
   
 The SUSE Team
 bu...@opensuse.org
@@ -32,11 +32,11 @@
   true
   -x -2
   openSUSE
-  20191016
+  20191017
   11
-  cpe:/o:opensuse:opensuse:20191016,openSUSE 
Tumbleweed
+  cpe:/o:opensuse:opensuse:20191017,openSUSE 
Tumbleweed
   cs da de e

commit 000release-packages for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package 000release-packages for 
openSUSE:Factory checked in at 2019-10-18 02:07:15

Comparing /work/SRC/openSUSE:Factory/000release-packages (Old)
 and  /work/SRC/openSUSE:Factory/.000release-packages.new.2352 (New)


Package is "000release-packages"

Fri Oct 18 02:07:15 2019 rev:286 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ openSUSE-Addon-NonOss-release.spec ++
--- /var/tmp/diff_new_pack.C99rfO/_old  2019-10-18 02:07:18.502113315 +0200
+++ /var/tmp/diff_new_pack.C99rfO/_new  2019-10-18 02:07:18.510113295 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package openSUSE-Addon-NonOss-release (Version 20191016)
+# spec file for package openSUSE-Addon-NonOss-release (Version 20191017)
 #
 # Copyright (c) 2019 openSUSE.
 #
@@ -16,16 +16,16 @@
 Name:   openSUSE-Addon-NonOss-release
 %define product openSUSE-Addon-NonOss
 Summary:openSUSE NonOSS Addon
-Version:20191016
+Version:    20191017
 Release:0
 License:BSD-3-Clause
 Group:  System/Fhs
 
 Provides:   %name-%version
 Provides:   product() = openSUSE-Addon-NonOss
-Provides:   product(openSUSE-Addon-NonOss) = 20191016-0
+Provides:   product(openSUSE-Addon-NonOss) = 20191017-0
 Provides:   product-label() = non%20oss%20addon
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Daddon%2Dnonoss%3A20191016
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Daddon%2Dnonoss%3A20191017
 
 
 AutoReqProv:on
@@ -49,10 +49,10 @@
 
   openSUSE
   openSUSE-Addon-NonOss
-  20191016
+  20191017
   0
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-addon-nonoss:20191016
+  cpe:/o:opensuse:opensuse-addon-nonoss:20191017
   
 
 

++ openSUSE-MicroOS-release.spec ++
--- /var/tmp/diff_new_pack.C99rfO/_old  2019-10-18 02:07:18.530113245 +0200
+++ /var/tmp/diff_new_pack.C99rfO/_new  2019-10-18 02:07:18.538113224 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   openSUSE-MicroOS-release
-Version:20191016
+Version:    20191017
 Release:0
 Summary:openSUSE MicroOS 
 License:GPL-2.0-or-later
@@ -43,9 +43,9 @@
 ExclusiveArch:  %ix86 x86_64 ppc64le s390x aarch64 %arm
 Provides:   %name-%version
 Provides:   product() = openSUSE-MicroOS
-Provides:   product(openSUSE-MicroOS) = 20191016-0
+Provides:   product(openSUSE-MicroOS) = 20191017-0
 Provides:   product-label() = openSUSE%20MicroOS
-Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dmicroos%3A20191016
+Provides:   product-cpeid() = 
cpe%3A%2Fo%3Aopensuse%3Aopensuse%2Dmicroos%3A20191017
 Provides:   product-url(releasenotes) = 
http%3A%2F%2Fdoc.opensuse.org%2Frelease%2Dnotes%2Fx86_64%2FopenSUSE%2FTumbleweed%2Frelease%2Dnotes%2DopenSUSE.rpm
 Provides:   product-endoflife()
 Requires:   product_flavor(openSUSE-MicroOS)
@@ -61,7 +61,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(dvd)
-Provides:   product_flavor(openSUSE-MicroOS) = 20191016-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20191017-0
 Summary:openSUSE MicroOS
 
 %description dvd
@@ -77,7 +77,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(kubic-dvd)
-Provides:   product_flavor(openSUSE-MicroOS) = 20191016-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20191017-0
 Summary:openSUSE MicroOS
 
 %description kubic-dvd
@@ -93,7 +93,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(appliance)
-Provides:   product_flavor(openSUSE-MicroOS) = 20191016-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20191017-0
 Summary:openSUSE MicroOS
 
 %description appliance
@@ -109,7 +109,7 @@
 Group:  System/Fhs
 Provides:   product_flavor()
 Provides:   flavor(appliance-kubic)
-Provides:   product_flavor(openSUSE-MicroOS) = 20191016-0
+Provides:   product_flavor(openSUSE-MicroOS) = 20191017-0
 Summary:openSUSE MicroOS
 
 %description appliance-kubic
@@ -167,11 +167,11 @@
 
   openSUSE
   openSUSE-MicroOS
-  20191016
+  20191017
   0
   
   %{_target_cpu}
-  cpe:/o:opensuse:opensuse-microos:20191016
+  cpe:/o:opensuse:opensuse-microos:20191017
   openSUSE-MicroOS
   
 

++ openSUSE-release.spec ++
--- /var/tmp/diff_new_pack.C99rfO/_old  2019-10-18 02:07:18.566113153 +0200
+++ /var/tmp/diff_new_pack.C99rfO/_new  2019-10-18 02:07:18.570113143 +0200
@@ -20,7 +20,7 @@
 #define betaversion %{nil}
 %define codename Tumbleweed
 Name:   openSUSE-release
-Version:20191016
+Version:  

commit 000update-repos for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-10-17 21:06:35

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.2352 (New)


Package is "000update-repos"

Thu Oct 17 21:06:35 2019 rev:629 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.0:update_1571308434.packages.xz



Other differences:
--
































































































































































































































































































































































































































































































































































































































































































































































































































commit 000update-repos for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2019-10-17 21:06:41

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.2352 (New)


Package is "000update-repos"

Thu Oct 17 21:06:41 2019 rev:630 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.1:update_1571302991.packages.xz



Other differences:
--

































































































































































































































































































































































































































































































































































































































































































































































































































commit gnome-user-docs for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-user-docs for openSUSE:Factory 
checked in at 2019-10-17 13:08:45

Comparing /work/SRC/openSUSE:Factory/gnome-user-docs (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-user-docs.new.2352 (New)


Package is "gnome-user-docs"

Thu Oct 17 13:08:45 2019 rev:73 rq:739032 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-user-docs/gnome-user-docs.changes  
2019-07-26 12:06:29.262886704 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-user-docs.new.2352/gnome-user-docs.changes
2019-10-17 13:08:47.691849039 +0200
@@ -1,0 +2,21 @@
+Thu Oct 17 08:09:07 UTC 2019 - Dominique Leuenberger 
+
+- Change License tag to "CC-BY-3.0", as stated in README.md.
+
+---
+Wed Sep 11 11:10:45 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + Updates to GNOME Help.
+  + Updates to System Admin Guide.
+  + Updated translations.
+
+---
+Fri Sep  6 10:45:24 CST 2019 - qk...@suse.com
+
+- Update to version 3.33.90:
+  + Updates to GNOME Help.
+  + Updates to System Admin Guide.
+  + Updated translations.
+
+---

Old:

  gnome-user-docs-3.32.3.tar.xz

New:

  gnome-user-docs-3.34.0.tar.xz



Other differences:
--
++ gnome-user-docs.spec ++
--- /var/tmp/diff_new_pack.vXkJqx/_old  2019-10-17 13:08:48.475847020 +0200
+++ /var/tmp/diff_new_pack.vXkJqx/_new  2019-10-17 13:08:48.483847000 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   gnome-user-docs
-Version:3.32.3
+Version:3.34.0
 Release:0
 Summary:GNOME Desktop Documentation
-License:GFDL-1.1-only
+License:CC-BY-3.0
 Group:  Documentation/Other
 URL:https://www.gnome.org
-Source0:
https://download.gnome.org/sources/gnome-user-docs/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-user-docs/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 BuildRequires:  yelp-tools

++ gnome-user-docs-3.32.3.tar.xz -> gnome-user-docs-3.34.0.tar.xz ++
/work/SRC/openSUSE:Factory/gnome-user-docs/gnome-user-docs-3.32.3.tar.xz 
/work/SRC/openSUSE:Factory/.gnome-user-docs.new.2352/gnome-user-docs-3.34.0.tar.xz
 differ: char 26, line 1




commit libical for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libical for openSUSE:Factory checked 
in at 2019-10-17 13:08:40

Comparing /work/SRC/openSUSE:Factory/libical (Old)
 and  /work/SRC/openSUSE:Factory/.libical.new.2352 (New)


Package is "libical"

Thu Oct 17 13:08:40 2019 rev:45 rq:738861 version:3.0.6

Changes:

--- /work/SRC/openSUSE:Factory/libical/libical.changes  2019-10-10 
11:51:23.191649079 +0200
+++ /work/SRC/openSUSE:Factory/.libical.new.2352/libical.changes
2019-10-17 13:08:41.931863873 +0200
@@ -1,0 +2,23 @@
+Wed Oct 16 10:45:43 UTC 2019 - Dominique Leuenberger 
+
+- Fix glib-devel dependencies on the typelib files after they were
+  renamed to match the correct names.
+
+---
+Wed Oct 16 09:55:21 UTC 2019 - Dominique Leuenberger 
+
+- Add libical-glib3 to baselibs.conf: dependency to evolution.
+
+---
+Wed Oct  9 21:08:22 UTC 2019 - Jan Engelhardt 
+
+- Update to release 3.0.6
+  * Handle both COUNT and UNTIL in RRULEs
+  * Fix RRULE BYDAY with INTERVAL=2 conflict
+  * Various fuzzification fixes
+  * New publicly available function:
+icaltimezone_truncate_vtimezone()
+  * Add option to disable building the test suite
+  * Built-in timezones updated to tzdata2019c
+
+---

Old:

  libical-3.0.5.tar.gz

New:

  libical-3.0.6.tar.gz



Other differences:
--
++ libical.spec ++
--- /var/tmp/diff_new_pack.iFPo5q/_old  2019-10-17 13:08:42.715861854 +0200
+++ /var/tmp/diff_new_pack.iFPo5q/_new  2019-10-17 13:08:42.715861854 +0200
@@ -26,7 +26,7 @@
 %bcond_with glib
 %endif
 Name:   libical%{name_ext}
-Version:3.0.5
+Version:3.0.6
 Release:0
 %if %{without glib}
 Summary:An Implementation of Basic iCAL Protocols
@@ -37,8 +37,7 @@
 License:MPL-2.0 OR LGPL-2.1-only
 Group:  Development/Libraries/C and C++
 %endif
-Url:http://sourceforge.net/projects/freeassociation/
-#Git-Clone: https://github.com/libical/libical
+URL:https://github.com/libical/libical
 Source: 
https://github.com/libical/libical/releases/download/v%{version}/libical-%{version}.tar.gz
 Source2:baselibs.conf
 Source3:libical-rpmlintrc
@@ -125,7 +124,8 @@
 Group:  Development/Libraries/C and C++
 Requires:   %{name} = %{version}
 Requires:   libical%{sonum} = %{version}
-Requires:   typelib-1_0-%{name}%{sonum} = %{version}
+Requires:   typelib-1_0-ICal-3_0 = %{version}
+Requires:   typelib-1_0-ICalGLib-3_0 = %{version}
 
 %description devel
 Development files for building against %{name}%{sonum}
@@ -138,18 +138,18 @@
 %description doc
 Documentation files for %{name}%{sonum}
 
-%package -n typelib-1_0-libical%{sonum}
+%package -n typelib-1_0-ICal-3_0
 Summary:Introspection bindings for libical
 Group:  Development/Libraries/C and C++
 
-%description -n typelib-1_0-libical%{sonum}
+%description -n typelib-1_0-ICal-3_0
 This package provides the gobject-introspection bindings for libical.
 
-%package -n typelib-1_0-%{name}%{sonum}
+%package -n typelib-1_0-ICalGLib-3_0
 Summary:Introspection bindings for the libical glib bindings.
 Group:  Development/Libraries/C and C++
 
-%description -n typelib-1_0-%{name}%{sonum}
+%description -n typelib-1_0-ICalGLib-3_0
 This package provides the gobject-introspection bindings for libical-glib.
 %endif
 
@@ -231,10 +231,10 @@
 %files doc
 %{_datadir}/gtk-doc/html/libical-glib
 
-%files -n typelib-1_0-libical%{sonum}
+%files -n typelib-1_0-ICal-3_0
 %{_libdir}/girepository-1.0/ICal-3.0.typelib
 
-%files -n typelib-1_0-%{name}%{sonum}
+%files -n typelib-1_0-ICalGLib-3_0
 %{_libdir}/girepository-1.0/ICalGLib-3.0.typelib
 %endif
 

++ baselibs.conf ++
--- /var/tmp/diff_new_pack.iFPo5q/_old  2019-10-17 13:08:42.759861740 +0200
+++ /var/tmp/diff_new_pack.iFPo5q/_new  2019-10-17 13:08:42.759861740 +0200
@@ -1 +1,2 @@
 libical3
+libical-glib3

++ libical-3.0.5.tar.gz -> libical-3.0.6.tar.gz ++
 18574 lines of diff (skipped)




commit telepathy-accounts-signon for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package telepathy-accounts-signon for 
openSUSE:Factory checked in at 2019-10-17 13:08:31

Comparing /work/SRC/openSUSE:Factory/telepathy-accounts-signon (Old)
 and  /work/SRC/openSUSE:Factory/.telepathy-accounts-signon.new.2352 (New)


Package is "telepathy-accounts-signon"

Thu Oct 17 13:08:31 2019 rev:2 rq:738848 version:2.0

Changes:

--- 
/work/SRC/openSUSE:Factory/telepathy-accounts-signon/telepathy-accounts-signon.changes
  2015-10-03 20:16:31.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.telepathy-accounts-signon.new.2352/telepathy-accounts-signon.changes
2019-10-17 13:08:34.915881941 +0200
@@ -1,0 +2,8 @@
+Wed Oct 16 09:09:38 UTC 2019 - christo...@krop.fr
+
+- Update to version 2.0
+- Add a _service file
+- Run spec-cleaner
+- Fix the license tag. telepathy-accounts-signon is LGPL-2.1-or-later
+
+---

Old:

  telepathy-accounts-signon-1.0-a4ae42797a9799fcbecb4c15bd9bd408e34c2eeb.tar.gz

New:

  _service
  _servicedata
  telepathy-accounts-signon-2.0.tar.xz



Other differences:
--
++ telepathy-accounts-signon.spec ++
--- /var/tmp/diff_new_pack.3CjXIy/_old  2019-10-17 13:08:35.379880746 +0200
+++ /var/tmp/diff_new_pack.3CjXIy/_new  2019-10-17 13:08:35.379880746 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package telepathy-accounts-signon
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,44 +12,41 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   telepathy-accounts-signon
-Version:1.0
+Version:2.0
 Release:0
 Summary:A mission control plugin for Telepathy
-License:LGPL-2.1
-Group:  System/GUI/KDE
-Source: 
%{name}-%{version}-a4ae42797a9799fcbecb4c15bd9bd408e34c2eeb.tar.gz
-BuildRequires:  pkgconfig(Qt5Core)
-BuildRequires:  kf5-filesystem
+License:LGPL-2.1-or-later
+Group:  Productivity/Networking/Instant Messenger
+URL:https://gitlab.com/accounts-sso/telepathy-accounts-signon
+Source: %{name}-%{version}.tar.xz
 BuildRequires:  libaccounts-glib-devel
 BuildRequires:  libsignon-glib-devel
+BuildRequires:  meson
 BuildRequires:  telepathy-mission-control-devel
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 A mission control plugin for Telepathy, integrating with libaccounts and 
libsignon
 to provide IM accounts and authentication. This code is based on Nemo Mobile's
 fork of the plugin from Empathy's ubuntu-online-account support.
 
-
 %prep
-%setup -q -n %{name}-%{version}-a4ae42797a9799fcbecb4c15bd9bd408e34c2eeb
+%setup -q
 
 %build
-  qmake-qt5
-  %make_jobs
+%meson
+%meson_build
 
 %install
-  make install INSTALL_ROOT=%{buildroot}
-  
+%meson_install
 
 %files
-%defattr(-,root,root)
-%doc COPYING COPYING.LGPL NOTES README
+%license COPYING.LGPL
+%doc README.md
 %{_libdir}/mission-control-plugins.0/mcp-account-manager-accounts-sso.so
 
 %changelog

++ _service ++

  
@PARENT_TAG@
refs/tags/2.0
https://gitlab.com/accounts-sso/telepathy-accounts-signon.git
git
enable
  
  
xz
*.tar
  
  

++ _servicedata ++


https://gitlab.com/accounts-sso/telepathy-accounts-signon.git
  ea3c58c691d487c31e16754308afd074606a0e33


commit gnome-builder for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-builder for openSUSE:Factory 
checked in at 2019-10-17 13:08:22

Comparing /work/SRC/openSUSE:Factory/gnome-builder (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-builder.new.2352 (New)


Package is "gnome-builder"

Thu Oct 17 13:08:22 2019 rev:45 rq:738843 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/gnome-builder/gnome-builder.changes  
2019-07-21 11:31:03.252810649 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-builder.new.2352/gnome-builder.changes
2019-10-17 13:08:24.227909465 +0200
@@ -1,0 +2,109 @@
+Wed Oct 16 07:48:45 UTC 2019 - Dominique Leuenberger 
+
+- Disable sysprof for the time being: sysprof is still under
+  security review.
+
+---
+Sat Oct  5 08:20:22 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Added gitg to newcomers projects.
+  + Fix user disabling of quick-highlight plugin.
+  + Tweak bottom margin of editors for overlay scrollbars.
+  + Improve guessing of source code languages from basename.
+  + Fix branch selection from clone dialog.
+  + Fix podman invocations to use absolute directory path.
+  + Load search engine when loading a project.
+  + Build system fixes.
+  + Updated translations.
+
+---
+Thu Sep 12 09:49:49 CST 2019 - sck...@suse.com
+
+- Update to version 3.34.0:
+  + Support for negative line numbers in "Go To Line" popover.
+  + Terminal workspaces are disabled for 3.34.
+  + Documentation fixes.
+  + Fix Escape usage in various search entries.
+  + Build system fixes.
+  + Updated translations.
+
+---
+Thu Sep  5 15:05:43 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + A new Rust GNOME project template has been added in addition to
+general improvements in the project creation assistant.
+  + Improvements to Vim emulation.
+  + Menu items within the glade designer pages have been fixed.
+  + Search improvements when regex and escape characters are used.
+  + Fixes for various keyboard shortcuts.
+  + Fix disappearance of Flatpak SDK installation popover.
+  + Fix saving of Glade documents when there are errors.
+  + Bug fixes to directory view and html-preview plugins.
+  + Buffer monitor tracking fixes.
+  + Improve drawing of transfer information in popovers.
+  + Updated translations.
+
+---
+Thu Aug 15 11:50:24 CEST 2019 - bjorn@gmail.com
+
+- Update to version 3.33.90:
+  + Fix deprecations from recent GLib changes.
+  + Update for recent Sysprof API changes.
+  + Multiple cursors improvements in editor.
+  + Fix meson tests use of IdeRunner.
+  + Sort commands in command-bar by priority.
+  + A new shellcmd plugin to execute shell commands from host,
+build, or runtime environments including support for keyboard
+shortcuts.
+  + Fix a number of "execve()" errors in build system usage.
+  + Project template improvements.
+  + Updated translations.
+- Changes from version 3.33.4:
+  + The greeter will disable input while opening a project.
+  + The sysprof plugin includes many new data sources.
+  + Git status in the project tree no longer uses color, instead
+opting for an open circle for changes, and closed circle for
+new files (along with bold).
+  + The UI tries to be more consistent in using italics for changes
+as bold is used for new files in the project tree.
+  + Various project tree styling changes.
+  + Discovery of programs within Flatpak runtimes no longer
+requires using `which'. The files are located directly using
+known PATH.
+  + Various FreeBSD compilation fixes with Clang.
+  + Many other bug fixes and improvements.
+- Changes from version 3.33.3:
+  + The sysprof dependency has been bumped to 3.33.3. Note that
+sysprof 3.33.3 introduces a new org.gnome.Sysprof3 service we
+rely on, but also provides org.gnome.Sysprof2 for compat with
+older systems.
+  + Validate application IDs when creating projects.
+  + Improvements to the golang language server integration.
+  + Improved formatting with `format-decls` comand-bar action.
+  + Updates for newcomer workflow.
+  + Improvements to Vim emulation.
+  + Cargo build system integration improvements.
+  + Improved gtkmm templates.
+  + Use --watch-bus when emulating rofiles-fuse to host.
+  + Improvements to completion-window opacity on Ctrl
+key-press/release.
+  + Window stacking fixes.
+  + Directory names are now indexed and can be used to open a
+file-browser.
+  + Foundry improvements including unit testing and PTY usage.
+  + Avoid displaying notifications in some situations.
+  + Terminal spawning has been redesigned 

commit libaccounts-glib for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libaccounts-glib for 
openSUSE:Factory checked in at 2019-10-17 13:07:48

Comparing /work/SRC/openSUSE:Factory/libaccounts-glib (Old)
 and  /work/SRC/openSUSE:Factory/.libaccounts-glib.new.2352 (New)


Package is "libaccounts-glib"

Thu Oct 17 13:07:48 2019 rev:6 rq:738824 version:1.24

Changes:

--- /work/SRC/openSUSE:Factory/libaccounts-glib/libaccounts-glib.changes
2017-11-09 16:20:36.119061952 +0100
+++ 
/work/SRC/openSUSE:Factory/.libaccounts-glib.new.2352/libaccounts-glib.changes  
2019-10-17 13:07:50.719995757 +0200
@@ -1,0 +2,18 @@
+Fri Oct 11 09:12:52 UTC 2019 - Bjørn Lie 
+
+- Update to version 1.24:
+  * ag-tool: fix typos.
+  * Remove Nokia backup conf files.
+  * Now using the meson build system.
+  * Bump soname.
+- Switch to source service checkout, use explicit released tag.
+- Add meson BuildRequires and macros following upstreams port.
+- Add pkgconfig(vapigen) BuildRequires: New dependency.
+- Drop python-libaccounts subpackage, no longer built.
+- Drop autoconf, automake, libtool and pkgconfig(python2)
+  BuildRequires: No longer needed.
+- Drop _version define, not needed as we are now using source
+  service.
+- Modernize spec, drop no longer needed tweaks and workarounds.
+
+---

Old:

  libaccounts-glib-VERSION_1.23-8d14b10652b2fe6c25d8ad8334e2d5023d254313.tar.gz

New:

  _service
  libaccounts-glib-1.24.obscpio
  libaccounts-glib.obsinfo



Other differences:
--
++ libaccounts-glib.spec ++
--- /var/tmp/diff_new_pack.7M11hz/_old  2019-10-17 13:07:51.623993429 +0200
+++ /var/tmp/diff_new_pack.7M11hz/_new  2019-10-17 13:07:51.627993419 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libaccounts-glib
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,26 +12,25 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 %define typelib typelib-1_0-Accounts-1_0
-%define sover   0
-%define _version VERSION_1.23-8d14b10652b2fe6c25d8ad8334e2d5023d254313
+%define sover   1
+
 Name:   libaccounts-glib
-Version:1.23
+Version:1.24
 Release:0
 Summary:Account management library for GLib Applications
-License:LGPL-2.1
+License:LGPL-2.1-only
 Group:  System/Libraries
 Url:https://gitlab.com/accounts-sso/libaccounts-glib
-Source: 
https://gitlab.com/accounts-sso/%{name}/repository/VERSION_%{version}/archive.tar.gz#/%{name}-%{_version}.tar.gz
+Source: %{name}-%{version}.tar.xz
 Source1:baselibs.conf
-BuildRequires:  autoconf >= 2.64
-BuildRequires:  automake
+
 BuildRequires:  gtk-doc
-BuildRequires:  libtool
+BuildRequires:  meson
 BuildRequires:  pkg-config
 BuildRequires:  python3-gobject
 BuildRequires:  pkgconfig(check) >= 0.9.4
@@ -42,9 +41,9 @@
 BuildRequires:  pkgconfig(gobject-introspection-1.0) >= 1.30.0
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(pygobject-3.0)
-BuildRequires:  pkgconfig(python2)
 BuildRequires:  pkgconfig(python3)
 BuildRequires:  pkgconfig(sqlite3) >= 3.7.0
+BuildRequires:  pkgconfig(vapigen)
 
 %description
 This package contains the shared libraries for use by applications.
@@ -56,14 +55,6 @@
 %description -n %{name}%{sover}
 This package contains the shared libraries for use by applications.
 
-%package -n python-libaccounts
-Summary:Python bindings for the Account management library
-Group:  Development/Languages/Python
-
-%description -n python-libaccounts
-This package contains the python bindings for the account
-management library.
-
 %package -n python3-libaccounts
 Summary:Python bindings for the Account management library
 Group:  Development/Languages/Python
@@ -85,7 +76,6 @@
 Group:  Development/Libraries/C and C++
 Requires:   %{name}%{sover} = %{version}
 Requires:   %{typelib} = %{version}
-Requires:   python-libaccounts = %{version}
 Requires:   python3-libaccounts = %{version}
 
 %description devel
@@ -110,57 +100,32 @@
 This package contains the tools for the accounts-glib library.
 
 %prep
-%setup -q -n %{name}-%{_version}
+%autosetup -p1
 
 %build
-gtkdocize --copy --flavour no-tmpl
-autoreconf -fi
-%global _configure ../configure
-for python in python2 

commit libdbusmenu for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libdbusmenu for openSUSE:Factory 
checked in at 2019-10-17 13:08:10

Comparing /work/SRC/openSUSE:Factory/libdbusmenu (Old)
 and  /work/SRC/openSUSE:Factory/.libdbusmenu.new.2352 (New)


Package is "libdbusmenu"

Thu Oct 17 13:08:10 2019 rev:8 rq:738840 version:16.04.0

Changes:

--- /work/SRC/openSUSE:Factory/libdbusmenu/libdbusmenu.changes  2019-08-19 
20:51:36.805044142 +0200
+++ /work/SRC/openSUSE:Factory/.libdbusmenu.new.2352/libdbusmenu.changes
2019-10-17 13:08:12.207940420 +0200
@@ -1,0 +2,7 @@
+Wed Oct 16 08:34:16 UTC 2019 - Dominique Leuenberger 
+
+- Inject -Wno-error into CFLAGS. It's kinda ridiculous for code
+  that is not maintained upstream to pass -Werror by default and
+  then not catching up. So for now we accept warnings.
+
+---



Other differences:
--
++ libdbusmenu.spec ++
--- /var/tmp/diff_new_pack.YVXIbN/_old  2019-10-17 13:08:12.947938514 +0200
+++ /var/tmp/diff_new_pack.YVXIbN/_new  2019-10-17 13:08:12.951938504 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libdbusmenu
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -178,6 +178,7 @@
 %setup -q
 
 %build
+export CFLAGS="%{optflags} -Wno-error"
 %global _configure ../configure
 NOCONFIGURE=1 gnome-autogen.sh --enable-gtk-doc
 for ver in 2 3; do




commit branding-openSUSE for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package branding-openSUSE for 
openSUSE:Factory checked in at 2019-10-17 13:07:40

Comparing /work/SRC/openSUSE:Factory/branding-openSUSE (Old)
 and  /work/SRC/openSUSE:Factory/.branding-openSUSE.new.2352 (New)


Package is "branding-openSUSE"

Thu Oct 17 13:07:40 2019 rev:110 rq:738656 version:84.87.20191004

Changes:

--- /work/SRC/openSUSE:Factory/branding-openSUSE/branding-openSUSE.changes  
2019-10-11 15:10:46.845181710 +0200
+++ 
/work/SRC/openSUSE:Factory/.branding-openSUSE.new.2352/branding-openSUSE.changes
2019-10-17 13:07:43.320014814 +0200
@@ -1,0 +2,7 @@
+Tue Oct 15 15:32:39 UTC 2019 - Dominique Leuenberger 
+
+- BuildRequires rsvg-convert instead of rsvg-view on suse_version
+  >= 1550. rsvg-view no longer exists and the sub-package from
+  librsvg was renamed accordingly.
+
+---



Other differences:
--
++ branding-openSUSE.spec ++
--- /var/tmp/diff_new_pack.WAWHW3/_old  2019-10-17 13:07:45.588008973 +0200
+++ /var/tmp/diff_new_pack.WAWHW3/_new  2019-10-17 13:07:45.624008881 +0200
@@ -43,7 +43,13 @@
 BuildRequires:  fdupes
 BuildRequires:  fribidi
 BuildRequires:  optipng
+%if 0%{?suse_version} >= 1550
+# rsvg-convert used to be packaged together with rsvg-view in one package. 
With the removal
+# of the rsvg-view program, this package was renamed to rsvg-convert (which is 
more fitting)
+BuildRequires:  rsvg-convert
+%else
 BuildRequires:  rsvg-view
+%endif
 BuildRequires:  suse-module-tools
 BuildRequires:  unzip
 BuildRequires:  update-desktop-files





commit libindicator for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libindicator for openSUSE:Factory 
checked in at 2019-10-17 13:08:04

Comparing /work/SRC/openSUSE:Factory/libindicator (Old)
 and  /work/SRC/openSUSE:Factory/.libindicator.new.2352 (New)


Package is "libindicator"

Thu Oct 17 13:08:04 2019 rev:9 rq:738839 version:16.10.0+bzr20171205

Changes:

--- /work/SRC/openSUSE:Factory/libindicator/libindicator.changes
2018-03-26 11:56:43.956519818 +0200
+++ /work/SRC/openSUSE:Factory/.libindicator.new.2352/libindicator.changes  
2019-10-17 13:08:07.283953100 +0200
@@ -1,0 +2,7 @@
+Wed Oct 16 08:35:28 UTC 2019 - Dominique Leuenberger 
+
+- Inject -Wno-error into CFLAGS. It's kinda ridiculous for code
+  that is not maintained upstream to pass -Werror by default and
+  then not catching up. So for now we accept warnings.
+
+---



Other differences:
--
++ libindicator.spec ++
--- /var/tmp/diff_new_pack.vsv71C/_old  2019-10-17 13:08:08.291950505 +0200
+++ /var/tmp/diff_new_pack.vsv71C/_new  2019-10-17 13:08:08.291950505 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libindicator
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -82,7 +82,7 @@
 %patch0 -p1
 
 %build
-
+export CFLAGS="%{optflags} -Wno-error"
 %global _configure ../configure
 NOCONFIGURE=1 gnome-autogen.sh
 for ver in 2 3; do




commit gnome-online-accounts for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-online-accounts for 
openSUSE:Factory checked in at 2019-10-17 13:08:16

Comparing /work/SRC/openSUSE:Factory/gnome-online-accounts (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-online-accounts.new.2352 (New)


Package is "gnome-online-accounts"

Thu Oct 17 13:08:16 2019 rev:79 rq:738842 version:3.34.1

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-online-accounts/gnome-online-accounts.changes  
2019-05-03 22:10:33.911292615 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-online-accounts.new.2352/gnome-online-accounts.changes
2019-10-17 13:08:19.219922362 +0200
@@ -1,0 +2,40 @@
+Wed Oct 16 04:32:47 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Bugs fixed: icons: Unbreak providers without any visual
+identity.
+  + Updated translations.
+
+---
+Wed Sep 11 18:53:06 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Thu Sep  5 12:51:34 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Updated translations.
+
+---
+Sat Aug 31 05:15:29 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.91:
+  + Support Fedora Account System.
+  + Bugs fixed:
+- owncloud: Use "Nextcloud", not "ownCloud", in user-visible
+  errors.
+- build: Allow building with gettext ≥ 0.20.
+- webview: Make it more flexible in terms of its size.
+- kerberos: Use GTask's task data slot to leverage the
+  compiler.
+- daemon: Return a D-Bus error if AddAccount fails to list all
+  providers.
+- kerberos: Use GTask's task data slot to leverage the
+  compiler.
+- build: Support the use of g_autolist with GoaObject.
+  - Port to GTask from GSimpleAsyncResult.
+  + Updated translations.
+
+---

Old:

  gnome-online-accounts-3.32.0.tar.xz

New:

  gnome-online-accounts-3.34.1.tar.xz



Other differences:
--
++ gnome-online-accounts.spec ++
--- /var/tmp/diff_new_pack.fHfX6E/_old  2019-10-17 13:08:19.719921074 +0200
+++ /var/tmp/diff_new_pack.fHfX6E/_new  2019-10-17 13:08:19.723921064 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   gnome-online-accounts
-Version:3.32.0
+Version:3.34.1
 Release:0
 Summary:GNOME service to access online accounts
 License:LGPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Projects/GnomeOnlineAccounts
-Source0:
https://download.gnome.org/sources/gnome-online-accounts/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-online-accounts/3.34/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 
 BuildRequires:  docbook-xsl-stylesheets

++ gnome-online-accounts-3.32.0.tar.xz -> 
gnome-online-accounts-3.34.1.tar.xz ++
 44883 lines of diff (skipped)




commit gnome-screenshot for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-screenshot for 
openSUSE:Factory checked in at 2019-10-17 13:07:13

Comparing /work/SRC/openSUSE:Factory/gnome-screenshot (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-screenshot.new.2352 (New)


Package is "gnome-screenshot"

Thu Oct 17 13:07:13 2019 rev:39 rq:738537 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-screenshot/gnome-screenshot.changes
2019-05-03 22:16:44.264021551 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-screenshot.new.2352/gnome-screenshot.changes  
2019-10-17 13:07:13.844090722 +0200
@@ -1,0 +2,23 @@
+Mon Oct 14 17:17:04 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Tue Sep  3 19:42:29 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.90:
+  + Add a flatpak-based CI job.
+  + Relax sandboxing options in flatpak manifest.
+  + Run flatpak in interactive mode by default.
+  + Support saving both to disk and clipboard from CLI.
+  + Fix alignment of labels in save dialog.
+  + Make file chooser dialog modal.
+  + Fix crash when using the fallback X11 code path on HiDpi.
+  + Fix window screenshot size when using the fallback X11 code
+path on HiDpi.
+  + Fix area selection flash when using the fallback X11 code path.
+  + Translation updates.
+- Require meson >= 0.50.0.
+
+---

Old:

  gnome-screenshot-3.32.0.tar.xz

New:

  gnome-screenshot-3.34.0.tar.xz



Other differences:
--
++ gnome-screenshot.spec ++
--- /var/tmp/diff_new_pack.cLuofF/_old  2019-10-17 13:07:14.452089156 +0200
+++ /var/tmp/diff_new_pack.cLuofF/_new  2019-10-17 13:07:14.452089156 +0200
@@ -17,17 +17,18 @@
 
 
 Name:   gnome-screenshot
-Version:3.32.0
+Version:3.34.0
 Release:0
 Summary:Utility to take pictures of your screen
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://www.gnome.org
-#Source0:   
https://download.gnome.org/sources/gnome-screenshot/3.30/%%{name}-%%{version}.tar.xz
+#Source0:   
https://download.gnome.org/sources/gnome-screenshot/3.33/%%{name}-%%{version}.tar.xz
 Source: %{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE gnome-screenshot-onlyshowin.patch dims...@opensuse.org -- 
OnlyShowIn=GNOME: fix brp build check, allowing to use the icon from the gnome 
theme.
 Patch0: gnome-screenshot-onlyshowin.patch
-BuildRequires:  meson >= 0.40.1
+
+BuildRequires:  meson >= 0.50.0
 BuildRequires:  pkgconfig
 BuildRequires:  translation-update-upstream
 BuildRequires:  pkgconfig(appstream-glib)

++ _service ++
--- /var/tmp/diff_new_pack.cLuofF/_old  2019-10-17 13:07:14.484089074 +0200
+++ /var/tmp/diff_new_pack.cLuofF/_new  2019-10-17 13:07:14.484089074 +0200
@@ -3,7 +3,7 @@
 https://gitlab.gnome.org/GNOME/gnome-screenshot.git
 git
 
-3.32.0
+refs/tags/3.34.0
 @PARENT_TAG@
 

commit yelp-xsl for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package yelp-xsl for openSUSE:Factory 
checked in at 2019-10-17 13:07:34

Comparing /work/SRC/openSUSE:Factory/yelp-xsl (Old)
 and  /work/SRC/openSUSE:Factory/.yelp-xsl.new.2352 (New)


Package is "yelp-xsl"

Thu Oct 17 13:07:34 2019 rev:43 rq:738649 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/yelp-xsl/yelp-xsl.changes2019-05-03 
22:14:40.531774710 +0200
+++ /work/SRC/openSUSE:Factory/.yelp-xsl.new.2352/yelp-xsl.changes  
2019-10-17 13:07:35.616034654 +0200
@@ -1,0 +2,21 @@
+Mon Sep  9 14:32:11 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Mon Sep  2 11:02:06 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.92:
+  + Updated translations.
+
+---
+Sat Aug 31 19:01:24 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.4:
+  + Update highlight.pack.js to 9.15.8, added awk and shell.
+  + Removed intltool and other build updates.
+  + Updated translations.
+- Drop intltool dependency.
+
+---

Old:

  yelp-xsl-3.32.1.tar.xz

New:

  yelp-xsl-3.34.0.tar.xz



Other differences:
--
++ yelp-xsl.spec ++
--- /var/tmp/diff_new_pack.tGnnCN/_old  2019-10-17 13:07:36.048033541 +0200
+++ /var/tmp/diff_new_pack.tGnnCN/_new  2019-10-17 13:07:36.052033531 +0200
@@ -18,15 +18,14 @@
 
 
 Name:   yelp-xsl
-Version:3.32.1
+Version:3.34.0
 Release:0
 Summary:XSL stylesheets for the yelp help browser
 License:GPL-2.0-or-later AND LGPL-2.1-or-later AND MIT
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Apps/Yelp
-Source0:
https://download.gnome.org/sources/yelp-xsl/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/yelp-xsl/3.34/%{name}-%{version}.tar.xz
 
-BuildRequires:  intltool
 BuildRequires:  itstool >= 1.2.0
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(libxml-2.0)

++ yelp-xsl-3.32.1.tar.xz -> yelp-xsl-3.34.0.tar.xz ++
 21232 lines of diff (skipped)




commit libsoup for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libsoup for openSUSE:Factory checked 
in at 2019-10-17 13:07:28

Comparing /work/SRC/openSUSE:Factory/libsoup (Old)
 and  /work/SRC/openSUSE:Factory/.libsoup.new.2352 (New)


Package is "libsoup"

Thu Oct 17 13:07:28 2019 rev:117 rq:738642 version:2.68.2

Changes:

--- /work/SRC/openSUSE:Factory/libsoup/libsoup.changes  2019-09-17 
13:34:16.601872825 +0200
+++ /work/SRC/openSUSE:Factory/.libsoup.new.2352/libsoup.changes
2019-10-17 13:07:30.372048158 +0200
@@ -1,0 +2,104 @@
+Tue Oct 15 14:41:04 UTC 2019 - Dominique Leuenberger 
+
+- Disable NTLM for the time being (causes build cycle):
+  + Drop samba-winbind BuildRequires.
+  + Pass -Dntlm=disabled to meson.
+
+---
+Wed Oct  9 10:34:03 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.68.2:
+  + Documentation fixes.
+  + Windows compatibility test fixes.
+  + WebSockets: client_max_window_bits in server must have a value.
+  + build: improve diagnostics when detecting Apache.
+  + NTLM: Make v2 authentication more robust.
+  + Updated translations.
+
+---
+Thu Sep 12 02:05:49 UTC 2019 - Michael Gorse 
+
+- Update to version 2.68.1:
+  + Several memory leaks fixed in tests, examples, and parsing
+code.
+  + SoupServer: Fixes to Windows path handling.
+  + Changes in version 2.68.0:
+  + Updated translations.
+  + Changes in version 2.67.93:
+  + SoupMessage: Handle Transfer-Encoding: identity for
+compatibility reasons.
+  + WebSockets: Only poll IO stream when needed.
+  + WebSockets: Properly set cookies received during handshake.
+  + WebSockets: Plug a couple of memory leaks and fix a few
+read-after-free memory errors.
+  + WebSockets: document how web socket extensions should treat
+buffers in case of error.
+  + SoupSession: Don't reset user GCancellable internally.
+  + Tests: Make tests installable.
+  + Remove deprecate GTimeVal internal usage.
+  + CI: increase coverage by enabling all features during testing.
+  + Updated translations.
+
+---
+Wed Sep 11 15:01:18 UTC 2019 - mgo...@suse.com
+
+- Update to version 2.67.92:
+  + Silence GTimeVal deprecation warnings.
+  + API documentation and annotation fixes.
+  + Plug a couple of NTLM authentication memory leaks.
+  + Meson: Use feature options.
+  + Meson: Do not fallback to system krb5-config for
+cross-compilation.
+  + NTLM: Fix build with NTLM enabled.
+  + Updated translations.
+- Changes from version 2.67.91:
+  + HSTS: New API to retrieve information about existing HSTS
+policies.
+  + Updated translations.
+- Changes from version 2.67.90:
+  + WebSockets: add support for WebSocket extensions via new
+SoupWebsocketExtensionManager and SoupWebsocketExtension API.
+  + WebSockets: add support for the permessage-deflate extension,
+enabled by default in SoupServer and in the client side only if
+SoupWebsocketExtensionManager is added to a session.
+  + WebSockets: Allow sending close frames with no body.
+  + WebSockets: ignore messages after close has been sent and
+received.
+  + Meson: tls-check improved.
+  + Meson: improve Apache checks.
+- Changes from version 2.67.3:
+  + WebSockets: allow sending empty binary data.
+  + WebSockets: fail and load the connection on invalid payload
+length.
+  + WebSockets: allow NULL characters in text messages data.
+  + WebSockets: Close connection on wrongly masked/unmasked frame
+as per RFC.
+  + WebSockets: other code fixes.
+  + NTLM: Fix NTLMv2 authentication.
+  + SoupMessage: fix several deprecation warnings related to
+private data.
+- Changes from version 2.67.2:
+  + gobject-introspection: Fix annotation for soup_auth_new().
+  + brotli: Do not advertise the decoder as it's failing with some
+websites.
+  + Meson: Fix xml2 and sqlite fallbacks.
+  + HSTS: Add SoupHSTSEnforcer:hsts-enforced signal.
+  + HSTS: Fixes to the types used to store policies in the SQLite
+storage.
+  + HSTS: Accept Strict-Transport-Security regardless of casing.
+  + WebSockets: Ensure messages finishes when handshake fails.
+  + WebSockets: Fix critical warnings and test failures.
+- Changes from version 2.67.1:
+  + Add a brotli decoder. This adds a new dependency on libbrotli.
+  + Add strict secure cookies support.
+  + Add HSTS enforcer SoupSession feature (with both memory and
+sqlite backends).
+  + meson gtk-doc documentation fixes.
+- Add libbrotlidec to BuildRequires.
+- Adjust meson: need "enabled" rather than "true" in a few places.
+- Add samba-winbind to BuildRequires: meson checks for ntlm_auth.
+- Meson: doc option is now gtk_doc.
+- Add libsoup-disable-hsts-tests.patch: these 

commit libsignon-glib for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libsignon-glib for openSUSE:Factory 
checked in at 2019-10-17 13:07:56

Comparing /work/SRC/openSUSE:Factory/libsignon-glib (Old)
 and  /work/SRC/openSUSE:Factory/.libsignon-glib.new.2352 (New)


Package is "libsignon-glib"

Thu Oct 17 13:07:56 2019 rev:4 rq:738825 version:2.1

Changes:

--- /work/SRC/openSUSE:Factory/libsignon-glib/libsignon-glib.changes
2017-11-09 16:23:11.049405347 +0100
+++ /work/SRC/openSUSE:Factory/.libsignon-glib.new.2352/libsignon-glib.changes  
2019-10-17 13:08:00.791969819 +0200
@@ -1,0 +2,33 @@
+Fri Oct 11 17:46:31 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.1:
+  * Rename `debug` option to `debugging`
+  * Fix racing build when using the enum header
+  * Add option to specify path to pygobject override directory
+- Changes from version 2.0:
+  * Support new signond 8.60
+  * New SignonSecurityContext with system and application contexts
+  * Add signon_list_available_mechanisms() method
+  * Remove a couple of obsolete methods
+  * Use the GTask API
+  * Build: switch to Meson build system
+  * Tests: increase code coverage
+- Changes from version 1.15:
+  * Do not build-depend on signond
+  * Update to the new signond D-Bus api with application context
+  * Create the Vala file at build time
+  * Handle the case where signond objects have been unregistered
+  * Respect thread affinity in callbacks
+  * Fix a memory leak
+  * Tests: make tests more robust
+- Switch to git checkout via source service, explict released tag.
+- Add meson BuildRequires and macros following upstreams port.
+- Bump sover following upstreams bumps.
+- Add explicit python3-gobject-devel and pkgconfig(vapigen)
+  BuildRequires, new dependencies.
+- Drop libtool, python-devel pkgconfig(check) and
+  pkgconfig(signond) BuildRequries, no longer needed.
+- Modernize spec.
+- Add new sub-package python3-libsignon-glib.
+
+---

Old:

  libsignon-glib-VERSION_1.14-e90302e342bfd27bc8c9132ab9d0ea3d8723fd03.tar.bz2

New:

  _service
  libsignon-glib-2.1.obscpio
  libsignon-glib.obsinfo



Other differences:
--
++ libsignon-glib.spec ++
--- /var/tmp/diff_new_pack.QV6WHT/_old  2019-10-17 13:08:01.735967388 +0200
+++ /var/tmp/diff_new_pack.QV6WHT/_new  2019-10-17 13:08:01.735967388 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libsignon-glib
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,41 +12,41 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
-%define _version VERSION_1.14-e90302e342bfd27bc8c9132ab9d0ea3d8723fd03
+%define sover 2
 
 Name:   libsignon-glib
-Version:1.14
+Version:2.1
 Release:0
 Summary:Library for signond
-License:LGPL-2.1
+License:LGPL-2.1-only
 Group:  System/Libraries
-Url:https://gitlab.com/accounts-sso/libsignon-glib
-Source: 
https://gitlab.com/accounts-sso/%{name}/repository/VERSION_%{version}/archive.tar.bz2#/%{name}-%{_version}.tar.bz2
+URL:https://gitlab.com/accounts-sso/libsignon-glib
+Source: %{name}-%{version}.tar.xz
+
 BuildRequires:  gtk-doc
-BuildRequires:  libtool >= 2.2
-BuildRequires:  python-devel
-BuildRequires:  pkgconfig(check) >= 0.9.4
+BuildRequires:  meson
+BuildRequires:  pkgconfig
+BuildRequires:  python3-gobject-devel
 BuildRequires:  pkgconfig(gio-2.0) >= 2.36
 BuildRequires:  pkgconfig(gio-unix-2.0)
 BuildRequires:  pkgconfig(glib-2.0) >= 2.32
 BuildRequires:  pkgconfig(gobject-2.0) >= 2.35.1
 BuildRequires:  pkgconfig(gobject-introspection-1.0)
-BuildRequires:  pkgconfig(signond) >= 8.40
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  pkgconfig(vapigen)
 
 %description
 GLib-based client library for applications handling account
 authentication through the Online Accounts Single Sign-On service
 
-%package -n libsignon-glib1
+%package -n libsignon-glib%{sover}
 Summary:Library for signond
 Group:  System/Libraries
 
-%description -n libsignon-glib1
+%description -n libsignon-glib%{sover}
 GLib-based client library for applications handling account
 authentication through the Online Accounts Single Sign-On service
 
@@ -55,7 +55,7 @@
 %package devel
 Summary:Development headers for 

commit swell-foop for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package swell-foop for openSUSE:Factory 
checked in at 2019-10-17 13:07:20

Comparing /work/SRC/openSUSE:Factory/swell-foop (Old)
 and  /work/SRC/openSUSE:Factory/.swell-foop.new.2352 (New)


Package is "swell-foop"

Thu Oct 17 13:07:20 2019 rev:27 rq:738632 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/swell-foop/swell-foop.changes2019-04-01 
12:31:43.549771091 +0200
+++ /work/SRC/openSUSE:Factory/.swell-foop.new.2352/swell-foop.changes  
2019-10-17 13:07:22.836067565 +0200
@@ -1,0 +2,19 @@
+Tue Oct 15 11:03:54 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Fixed crash.
+  + Updated translations.
+
+---
+Tue Sep 10 06:17:42 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Wed Sep  4 14:48:14 CEST 2019 - dims...@opensuse.org
+
+- Update to version 3.33.92:
+  + Updated translations.
+
+---

Old:

  swell-foop-3.32.0.tar.xz

New:

  swell-foop-3.34.1.tar.xz



Other differences:
--
++ swell-foop.spec ++
--- /var/tmp/diff_new_pack.f5xqzx/_old  2019-10-17 13:07:23.520065804 +0200
+++ /var/tmp/diff_new_pack.f5xqzx/_new  2019-10-17 13:07:23.520065804 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   swell-foop
-Version:3.32.0
+Version:3.34.1
 Release:0
 Summary:Same Game for GNOME
 License:GPL-2.0-or-later
 Group:  Amusements/Games/Board/Puzzle
 URL:https://wiki.gnome.org/Apps/Swell_Foop
-Source0:
https://download.gnome.org/sources/swell-foop/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/swell-foop/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 BuildRequires:  hicolor-icon-theme

++ swell-foop-3.32.0.tar.xz -> swell-foop-3.34.1.tar.xz ++
 1948 lines of diff (skipped)




commit gobject-introspection for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gobject-introspection for 
openSUSE:Factory checked in at 2019-10-17 13:06:25

Comparing /work/SRC/openSUSE:Factory/gobject-introspection (Old)
 and  /work/SRC/openSUSE:Factory/.gobject-introspection.new.2352 (New)


Package is "gobject-introspection"

Thu Oct 17 13:06:25 2019 rev:89 rq:738475 version:1.62.0

Changes:

--- 
/work/SRC/openSUSE:Factory/gobject-introspection/gobject-introspection.changes  
2019-08-19 20:49:07.273076190 +0200
+++ 
/work/SRC/openSUSE:Factory/.gobject-introspection.new.2352/gobject-introspection.changes
2019-10-17 13:06:28.756206835 +0200
@@ -1,0 +2,38 @@
+Sat Oct 12 20:53:47 UTC 2019 - Stefan Brüns 
+
+- Depend on the specific Python ABI version the module was built with,
+  as the _giscanner binary module is ABI dependent. Fixes boo#1153837
+
+---
+Mon Sep  9 15:29:12 CDT 2019 - mgo...@suse.com
+
+- Update to version 1.62.0:
+  + No changes since 1.61.2.
+
+---
+Fri Aug 30 12:18:00 CDT 2019 - mgo...@suse.com
+
+- Update to version 1.61.2:
+  + dumper: Use the distutils linker.
+  + structinfo: Fix offset in find_method().
+  + tests: Don't include "config.h" in installed files.
+  + meson: Make meson.override_find_program working on more complex
+use cases.
+- Changes from version 1.61.1:
+  + Drop autotools build system.
+  + meson: require 0.49.2.
+  + Update glib annotations.
+  + Add documentation to the RelaxNG schema.
+  + Unused variable fixes.
+  + cachestore: handle cache getting deleted while loading it.
+  + Add Vulkan gir.
+  + Make g_irepository_get_object_gtype_interfaces actually work.
+  + gimarshallingtests: Add a marshalling test case for GPtrArrays
+and GArrays of structures.
+  + scanner: parse and expose function macros.
+  + meson: use pkg-config directly for libffi cflags and libs.
+  + meson: Fix wrong dependency type check for gio-unix.
+  + regress: Add regression test for signal with GError param.
+- Add Vulkan to typelib template.
+
+---

Old:

  gobject-introspection-1.60.2.tar.xz

New:

  gobject-introspection-1.62.0.tar.xz



Other differences:
--
++ gobject-introspection.spec ++
--- /var/tmp/diff_new_pack.ItjFRc/_old  2019-10-17 13:06:29.388205207 +0200
+++ /var/tmp/diff_new_pack.ItjFRc/_new  2019-10-17 13:06:29.388205207 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gobject-introspection
-Version:1.60.2
+Version:1.62.0
 Release:0
 # FIXME: Find a way to identify if we need python3-gobject or python-gobject 
from gi-find-deps.sh.
 Summary:GObject Introspection Tools
@@ -25,7 +25,7 @@
 Group:  Development/Libraries/GNOME
 URL:https://wiki.gnome.org/Projects/GObjectIntrospection
 
-Source0:
https://download.gnome.org/sources/gobject-introspection/1.60/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gobject-introspection/1.62/%{name}-%{version}.tar.xz
 # gi-find-deps.sh is a rpm helper for Provides and Requires. Script creates 
typelib()-style Provides/Requires.
 Source1:gi-find-deps.sh
 Source2:gobjectintrospection.attr
@@ -37,7 +37,7 @@
 BuildRequires:  fdupes
 BuildRequires:  flex
 BuildRequires:  gtk-doc
-BuildRequires:  meson >= 0.47
+BuildRequires:  meson >= 0.49.2
 BuildRequires:  pkgconfig
 BuildRequires:  python3-Mako
 BuildRequires:  python3-Markdown
@@ -58,6 +58,7 @@
 # gi-find-deps uses the enhanced grep variant in order to do multi-line 
matching (for pkg.requires(..))
 Requires:   pcre-tools
 Requires:   python3-xml
+Requires:   python(abi) = %{python3_version}
 
 %description
 The goal of the project is to describe the APIs and collect them in

++ gobject-introspection-1.60.2.tar.xz -> 
gobject-introspection-1.62.0.tar.xz ++
 108840 lines of diff (skipped)

++ gobject-introspection-typelib.template ++
--- /var/tmp/diff_new_pack.ItjFRc/_old  2019-10-17 13:06:30.104203364 +0200
+++ /var/tmp/diff_new_pack.ItjFRc/_new  2019-10-17 13:06:30.104203364 +0200
@@ -6,6 +6,7 @@
 typelib(GModule) = 2.0
 typelib(GObject) = 2.0
 typelib(Gio) = 2.0
+typelib(Vulkan) = 1.0
 typelib(cairo) = 1.0
 typelib(fontconfig) = 2.0
 typelib(freetype2) = 2.0




commit mutter for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package mutter for openSUSE:Factory checked 
in at 2019-10-17 13:06:32

Comparing /work/SRC/openSUSE:Factory/mutter (Old)
 and  /work/SRC/openSUSE:Factory/.mutter.new.2352 (New)


Package is "mutter"

Thu Oct 17 13:06:32 2019 rev:138 rq:738479 version:3.34.1+21

Changes:

--- /work/SRC/openSUSE:Factory/mutter/mutter.changes2019-07-31 
14:15:55.846726771 +0200
+++ /work/SRC/openSUSE:Factory/.mutter.new.2352/mutter.changes  2019-10-17 
13:06:39.404179414 +0200
@@ -1,0 +2,221 @@
+Sun Oct 13 17:58:09 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.1+21:
+  + x11: Map mimetypes back to selection atoms
+  + wayland:
+- Figure out better the right selection source for a
+  wl_data_offer
+- Set dummy selection source on .set_selection(null)
+- Simplify MetaSelectionSourceWayland
+- Check resource before emitting cancelled event
+- Emit wl/primary offer after changing selection
+- Chain up to the right finalize on
+  MetaWaylandDataSourceWayland
+- Drop field from MetaWaylandDataSourcePrimary
+- Plug MetaSelectionSourceWayland leaks
+  + clutter/shader-effect: Initialize shader-type properly
+  + ci: Change the without-native-backend to not build with Wayland
+too
+  + main: Warn instead of error in meta_test_init()
+- Switch to the now available 3-34 stable branch in service.
+
+---
+Thu Oct 10 21:46:49 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.1+9:
+  + kms/crtc: Read gamma state when prediction failed.
+  + kms: Always predict state after processing update.
+  + clutter-backend-x11: Don't push keymap events to clutter.
+  + event-x11: Use CLUTTER prefix for X11 filter docs.
+  + x11: Translate well known selection atoms to mimetypes.
+  + wayland/actor-surface: Queue redraw for frame callback.
+  + wayland/surface: Some minor coding style clean up.
+  + cogl-pango/meson.build: Remove extraneous quoting.
+  + backends: Update inhibited state for the monitor and respect
+that state.
+
+---
+Wed Oct  9 09:38:35 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Fix startup of X11 session services on wayland.
+  + Fix _NET_ACTIVE_WINDOW emission.
+  + Fix initial view perspective.
+  + Fix screenshots and window animations when scaled.
+  + Re-enable coredumps when capabilities are set.
+  + Fix scaling of DND surface actors.
+  + Optimize blitting of untransformed offscreen stage views.
+  + Fix freeze of pointer event delivery on X11.
+  + Fix scaling of stylus input coordinates with HiDPI.
+  + Fix memory leak when using implicit animations.
+  + Fix numlock state for native backend.
+  + Fixed crashes.
+  + Misc. bug fixes and cleanups.
+  + Updated translations.
+
+---
+Thu Oct  3 10:17:28 UTC 2019 - Frederic Crozat 
+
+- Disable sysprof support until it get security team approval.
+
+---
+Sat Sep 21 17:08:50 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.0+30:
+  + window-actor: Use surface coordinates for the fast path in
+get_image()
+  + shaped-texture: Use surface coordinates in get_image()
+  + shaped-texture: Declare that we inherit from GObject
+  + window/surface-actor: Add docstrings
+  + shaped-texture: Mark set the clip and return value nullable
+  + clutter/actor: Cancel delayed timelines on removal
+  + clutter/timeline: Don't emit ::paused signal on delayed
+timelines
+  + clutter/timeline: Use a function to cancel the delay timeout
+  + wayland/dma-buf: Handle zero modifiers from
+eglQueryDmaBufModifiersEXT
+  + stage: Compute view perspective when parameters changed
+  + build: Compile with `-ffloat-store` on x86 (32 bit)
+  + kms-impl-device: Use portable formatting for 64-bit integers
+  + output-kms: Use portable formatting for 64-bit integers
+  + input-settings: Use portable formatting for 64-bit integers
+  + clutter/stage-cogl: Use portable formatting for 64-bit integers
+  + clutter/paint-node: Convert safely from pointer to integer
+
+---
+Tue Sep 17 09:06:26 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.0+14:
+  + idle-monitor: Reset timeout before firing watch
+  + idle-monitor: Remove redundant type cast
+  + idle-monitor: Make helper function static
+  + kms-device: Free path when finalizing
+  + kms-device: Handle impl device creation failure
+  + x11: Minor refactor of input focus handling code
+  + x11: Use the currently focused X window for _NET_ACTIVE_WINDOW
+
+---
+Fri 

commit librsvg for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package librsvg for openSUSE:Factory checked 
in at 2019-10-17 13:07:04

Comparing /work/SRC/openSUSE:Factory/librsvg (Old)
 and  /work/SRC/openSUSE:Factory/.librsvg.new.2352 (New)


Package is "librsvg"

Thu Oct 17 13:07:04 2019 rev:93 rq:738536 version:2.46.2

Changes:

--- /work/SRC/openSUSE:Factory/librsvg/librsvg.changes  2019-09-11 
10:20:23.983510716 +0200
+++ /work/SRC/openSUSE:Factory/.librsvg.new.2352/librsvg.changes
2019-10-17 13:07:07.768106369 +0200
@@ -1,0 +2,280 @@
+Mon Oct 14 17:06:58 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.46.2:
+  + Patterns and gradients reused across more than one element will
+only get resolved once now; this should make things marginally
+faster for patterns or gradients with fallbacks.
+  + glgo#GNOME/librsvg#515: Librsvg now has limits on the number of
+loaded XML elements, and the number of referenced elements
+within an SVG document. This is to mitigate malicious SVGs
+which try to consume all memory, and those which try to consume
+an exponential amount of CPU time.
+
+---
+Mon Oct  7 16:57:23 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.46.1:
+  + Fix empty patterns which reference a fallback pattern with
+children.
+
+---
+Mon Sep  9 19:36:58 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.46.0:
+  + All of librsvg.so is now implemented in Rust! That is, except
+for a very thin wrapper over the public API functions.
+Hopefully we can remove this wrapper when Cargo gets some more
+features around controlling the linking step. This release
+requires at least Rust 1.34.
+  + Librsvg now comes with a Rust crate that can be used from Rust
+applications. See librsvg_crate/examples. This Rust API is
+designed to be idiomatic; if you want a Rust binding to the
+shared library instead, please use the "rsvg-rs" crate from
+crates.io.
+  + The following API functions are new in the C library:
+- rsvg_handle_get_intrinsic_dimensions()
+- rsvg_handle_render_document()
+- rsvg_handle_render_layer()
+- rsvg_handle_render_element()
+- rsvg_handle_get_geometry_for_layer()
+- rsvg_handle_get_geometry_for_element()
+- Correspondingly, there is a new chapter in the documentation,
+  called "Recommendations for Applications". These new APIs
+  conform better with the web platform's idea of how SVG
+  sizing/positioning should work. Applications should now find
+  it easier to scale and render SVGs in a single call, instead
+  of having to obtain image dimensions first.
+  + A bunch of functions have been deprecated but are still
+available:
+- rsvg_handle_write()/close() are deprecated in favor of the
+  stream functions. Unfortunately the write()/close() pair
+  require buffering the entire document, in case it is a .svgz
+  compressed file; the streaming functions do not have this
+  problem.
+- Functions that return RsvgDimensionData and RsvgPositionData
+  are deprecated, since they just use integers instead of
+  floating point numbers. They are replaced with the
+  _get_geometry_*() functions above.
+  + The library is a lot more strict now in terms of detecting that
+the API functions are called in the correct order. For example,
+calling rsvg_handle_get_dimensions() before rsvg_handle_close()
+will now emit a critical warning.
+  + Librsvg is gradually moving towards using code from Mozilla's
+Servo. We haven't quite gotten rid of libcroco and libxml2 yet,
+but this is in progress.
+
+---
+Mon Sep  2 21:56:12 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.45.92:
+  + Fix glgo#GNOME/librsvg#496: Ensure all lengths and angles parse
+as finite numbers.
+  + Fix glgo#GNOME/librsvg#497: Don't panic on paths with
+all-invalid commands.
+  + Fix glgo#GNOME/librsvg#500: Added additional SVG blend-modes
+for the feBlend filter primitive.
+  + Some changes in the build structure to allow for faster builds.
+
+---
+Mon Sep  2 21:56:11 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.45.90:
+  + New API functions:
+- rsvg_handle_render_document().
+- rsvg_handle_render_layer().
+- rsvg_handle_render_element().
+- rsvg_handle_get_geometry_for_layer().
+- rsvg_handle_get_geometry_for_element().
+  + CairoRenderer in the librsvg_crate has corresponding functions
+as well.
+  + Fix builds with gettext ≥ 0.20.
+  + If the C API is called out of order, downgrade hard panics to
+g_critical() to cope with incorrect/old 

commit gvfs for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gvfs for openSUSE:Factory checked in 
at 2019-10-17 13:06:42

Comparing /work/SRC/openSUSE:Factory/gvfs (Old)
 and  /work/SRC/openSUSE:Factory/.gvfs.new.2352 (New)


Package is "gvfs"

Thu Oct 17 13:06:42 2019 rev:160 rq:738532 version:1.42.1

Changes:

--- /work/SRC/openSUSE:Factory/gvfs/gvfs.changes2019-07-21 
11:31:45.524803508 +0200
+++ /work/SRC/openSUSE:Factory/.gvfs.new.2352/gvfs.changes  2019-10-17 
13:06:43.988167609 +0200
@@ -1,0 +2,68 @@
+Mon Oct 14 07:17:45 UTC 2019 - QK ZHU 
+
+- Rebase SLE patches for version 1.42.1:
+  + gvfs-nds.patch
+  + gvfs-nvvfs.patch
+
+---
+Mon Oct  7 07:47:29 UTC 2019 - Bjørn Lie 
+
+- Update to version 1.42.1:
+  + dav: Fix mounting when 403 is returned for the parent folder.
+  + Revert "sftp: Always use port 22 if not specified".
+  + Updated translations.
+
+---
+Sun Sep 15 19:24:28 UTC 2019 - Michael Gorse 
+
+- Fix Requires on -fuse package: now needs fuse3, not fuse. 
+
+---
+Tue Sep 10 17:40:44 UTC 2019 - Bjørn Lie 
+
+- Update to version 1.42.0:
+  + Updated translations.
+
+---
+Fri Aug 30 19:56:41 CDT 2019 - mgo...@suse.com
+
+- Update to version 1.41.91:
+  + fuse: Remove max_write limit.
+  + Several smaller bugfixes.
+  + Updated translations.
+- Changes from version 1.41.90:
+  + udisks2: Change display name for crypto_unknown devices.
+  + google: Disable deletion of non-empty directories.
+  + google: Fix crashes when deleting if the file isn't found.
+  + google: Fix issue with stale entries remaining after rename
+operation.
+  + build: Define gvfs_rpath for libgvfsdaemon.so.
+  + proxy: Don't leak a GVfsDBusDaemon.
+  + Updated translations.
+- Changes from version 1.41.4:
+  + google: Do not enumerate volatile entries if title matches id.
+  + build: Add dependency on gsettings-desktop-schemas.
+  + daemon/udisks2: Handle lockdown option to disable writing.
+  + fuse: Define RENAME_* macros when they are not defined.
+  + google: Check ownership in is_owner() without additional HTTP
+request.
+  + Several smaller bugfixes.
+  + Updated translations.
+- Changes from version 1.41.3:
+  + Updated translations.
+- Changes from version 1.41.2:
+  + build: Several meson improvements.
+  + build: Bump required meson version to 0.50.0.
+  + google: Support deleting shared Google Drive files.
+  + admin: Prevent core dumps when daemon is manually started.
+  + Several smaller bugfixes.
+  + Updated translations.
+- Changes from version 1.41.1:
+  + fuse: Adapt gvfsd-fuse to use fuse 3.x.
+  + daemon: Unify some translatable strings.
+  + Updated translations.
+- Specify meson version requirement.
+- Require fuse >= 3.0.0.
+- Require gsettings-desktop-schemas: new dependency.
+
+---

Old:

  gvfs-1.40.2.tar.xz

New:

  gvfs-1.42.1.tar.xz



Other differences:
--
++ gvfs.spec ++
--- /var/tmp/diff_new_pack.lc3Ti7/_old  2019-10-17 13:06:44.596166043 +0200
+++ /var/tmp/diff_new_pack.lc3Ti7/_new  2019-10-17 13:06:44.596166043 +0200
@@ -18,13 +18,13 @@
 
 %bcond_without  cdda
 Name:   gvfs
-Version:1.40.2
+Version:1.42.1
 Release:0
 Summary:Virtual File System functionality for GLib
 License:LGPL-2.0-or-later AND GPL-3.0-only
 Group:  Development/Libraries/C and C++
 URL:https://wiki.gnome.org/Projects/gvfs
-Source0:
https://download.gnome.org/sources/gvfs/1.40/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gvfs/1.42/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 
 ### NOTE: Please, keep SLE-only patches at bottom (starting on 1000).
@@ -35,7 +35,7 @@
 
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  libgcrypt-devel >= 1.2.2
-BuildRequires:  meson
+BuildRequires:  meson >= 0.50.0
 BuildRequires:  openssh
 BuildRequires:  pkgconfig
 BuildRequires:  translation-update-upstream
@@ -43,13 +43,14 @@
 BuildRequires:  pkgconfig(avahi-client) >= 0.6
 BuildRequires:  pkgconfig(avahi-glib) >= 0.6
 BuildRequires:  pkgconfig(dbus-1)
-BuildRequires:  pkgconfig(fuse) >= 2.8.0
+BuildRequires:  pkgconfig(fuse3) >= 3.0.0
 BuildRequires:  pkgconfig(gcr-base-3)
 BuildRequires:  pkgconfig(gio-2.0)
 BuildRequires:  pkgconfig(gio-unix-2.0)
 BuildRequires:  pkgconfig(glib-2.0) >= 2.57.2
 BuildRequires:  pkgconfig(goa-1.0) >= 3.17.1
 BuildRequires:  pkgconfig(gobject-2.0)
+BuildRequires:  

commit bijiben for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package bijiben for openSUSE:Factory checked 
in at 2019-10-17 13:06:49

Comparing /work/SRC/openSUSE:Factory/bijiben (Old)
 and  /work/SRC/openSUSE:Factory/.bijiben.new.2352 (New)


Package is "bijiben"

Thu Oct 17 13:06:49 2019 rev:47 rq:738534 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/bijiben/bijiben.changes  2019-07-26 
12:06:16.722888688 +0200
+++ /work/SRC/openSUSE:Factory/.bijiben.new.2352/bijiben.changes
2019-10-17 13:06:49.792152662 +0200
@@ -1,0 +2,38 @@
+Mon Oct 14 16:38:31 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Updated translations.
+
+---
+Thu Sep 12 09:25:53 CST 2019 - sck...@suse.com
+
+- Update to version 3.34.0:
+  + Added intltool as a flatpak dependency.
+  + Added missing icons in editor toolbar.
+  + Added new API to get human time.
+  + Changed settings window to use the same color chooser as editor window.
+  + Fixed missing notes from main view.
+  + Improved application model by removing duplicated note id objects.
+  + Improved Own/NextCloud notes management.
+  + Improved README to use markdown.
+  + Ported to libecal-2.0.
+  + Updated translations.
+
+---
+Fri Sep  6 23:16:33 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Added missing icons in editor toolbar.
+  + Added new API to get human time.
+  + Changed settings window to use the same color chooser as
+editor window.
+  + Fixed appdata screenshot urls.
+  + Fixed missing notes from main view.
+  + Improved application model by removing duplicated note id
+objects.
+  + Improved Own/NextCloud notes management.
+  + Ported to libecal-2.0.
+- Replace pkgconfig(libecal-1.2) with pkgconfig(libecal-2.0)
+  BuildRequires following upstreams port.
+
+---

Old:

  bijiben-3.32.2.tar.xz

New:

  bijiben-3.34.1.tar.xz



Other differences:
--
++ bijiben.spec ++
--- /var/tmp/diff_new_pack.IaBhCc/_old  2019-10-17 13:06:51.660147851 +0200
+++ /var/tmp/diff_new_pack.IaBhCc/_new  2019-10-17 13:06:51.668147831 +0200
@@ -19,14 +19,15 @@
 %bcond_with zeitgeist
 
 Name:   bijiben
-Version:3.32.2
+Version:3.34.1
 Release:0
 Summary:Note editor for GNOME
 License:GPL-3.0-or-later AND CC-BY-SA-3.0
 Group:  Productivity/Text/Editors
 URL:https://wiki.gnome.org/Apps/Bijiben
-Source0:
https://download.gnome.org/sources/bijiben/3.32/%{name}-%{version}.tar.xz
+Source0:
http://download.gnome.org/sources/bijiben/3.34/%{name}-%{version}.tar.xz
 
+BuildRequires:  cmake
 BuildRequires:  fdupes
 BuildRequires:  gettext
 BuildRequires:  meson
@@ -34,12 +35,12 @@
 BuildRequires:  update-desktop-files
 BuildRequires:  yelp-tools
 BuildRequires:  pkgconfig(gio-unix-2.0)
-BuildRequires:  pkgconfig(glib-2.0) >= 2.28
+BuildRequires:  pkgconfig(glib-2.0) >= 2.58
 BuildRequires:  pkgconfig(goa-1.0)
 BuildRequires:  pkgconfig(gobject-introspection-1.0)
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.19.3
-BuildRequires:  pkgconfig(libecal-1.2) >= 3.13.90
-BuildRequires:  pkgconfig(libedataserver-1.2) >= 3.13.90
+BuildRequires:  pkgconfig(libecal-2.0) >= 3.33.92
+BuildRequires:  pkgconfig(libedataserver-1.2) >= 3.33.92
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(tracker-sparql-2.0)
 BuildRequires:  pkgconfig(uuid)
@@ -86,7 +87,7 @@
 
 %files
 %license COPYING
-%doc AUTHORS NEWS README TODO
+%doc AUTHORS NEWS README.md TODO
 %dir %{_datadir}/help
 %dir %{_datadir}/help/C
 %doc %{_datadir}/help/C/%{name}/

++ bijiben-3.32.2.tar.xz -> bijiben-3.34.1.tar.xz ++
 8880 lines of diff (skipped)




commit gcr for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gcr for openSUSE:Factory checked in 
at 2019-10-17 13:06:58

Comparing /work/SRC/openSUSE:Factory/gcr (Old)
 and  /work/SRC/openSUSE:Factory/.gcr.new.2352 (New)


Package is "gcr"

Thu Oct 17 13:06:58 2019 rev:34 rq:738535 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gcr/gcr.changes  2019-01-26 22:17:18.735103878 
+0100
+++ /work/SRC/openSUSE:Factory/.gcr.new.2352/gcr.changes2019-10-17 
13:07:00.468125169 +0200
@@ -1,0 +2,33 @@
+Mon Oct 14 16:40:55 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + gcr-prompt-dialog: Allow the use of mnemonics in the choice
+label (glgo#GNOME/gcr!22).
+  + Use python3 shebang in ui/icons/render-icons.py
+(glgo#GNOME/gcr!21).
+  + configure: Use PKG_PROG_PKG_CONFIG instead of reinventing it
+(glgo#GNOME/gcr!20).
+  + Replace tap-gtester with one that relies on GLib 2.38+ TAP
+output (glgo#GNOME/gcr!19).
+  + Remove SKS network from keyserver defaults (glgo#GNOME/gcr!18).
+  + Updated translations.
+
+---
+Sat Aug 31 20:04:28 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.4:
+  + Move from intltool to gettext.
+  + Fix parameter type for signal handler causing stack smashing on
+ppc64le.
+  + cleanup: Don't use deprecated g_type_class_add_private()
+anymore.
+  + Fix GIR annotations.
+  + Fix hashtable ordering assumptions.
+  + build: Fix gcr-trust symbols not appearing in GIR, and hence
+also VAPI.
+  + Update gcr_pkcs11_get_trust_{store|lookup}_slot URI checks.
+  + build: Update tap scripts for Python 3 compat.
+  + Updated translations.
+- Drop intltool dependency, and add gettext.
+
+---

Old:

  gcr-3.28.1.tar.xz

New:

  gcr-3.34.0.tar.xz



Other differences:
--
++ gcr.spec ++
--- /var/tmp/diff_new_pack.DEV12O/_old  2019-10-17 13:07:01.032123716 +0200
+++ /var/tmp/diff_new_pack.DEV12O/_new  2019-10-17 13:07:01.032123716 +0200
@@ -17,24 +17,24 @@
 
 
 Name:   gcr
-Version:3.28.1
+Version:3.34.0
 Release:0
 # FIXME: Verify if the requires in typelib-1_0-Gcr-3 is still correct and 
required (see bgo#725501).
 Summary:Library for Crypto UI related tasks
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/GNOME
 URL:http://www.gnome.org
-Source0:
http://download.gnome.org/sources/gcr/3.28/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gcr/3.34/%{name}-%{version}.tar.xz
 Source1:baselibs.conf
 # PATCH-FIX-SLE gcr-bsc932232-use-libgcrypt-allocators.patch bsc#932232 
h...@suse.com -- use libgcrypt allocators for FIPS mode
 Patch1: gcr-bsc932232-use-libgcrypt-allocators.patch
 # For directory ownership
 BuildRequires:  dbus-1
+BuildRequires:  gettext >= 0.19.8
 BuildRequires:  gobject-introspection-devel >= 1.34
 # configure is looking for the gpg2 path
 BuildRequires:  gpg2
 BuildRequires:  gtk-doc
-BuildRequires:  intltool
 BuildRequires:  libgcrypt-devel >= 1.4.5
 BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files

++ gcr-3.28.1.tar.xz -> gcr-3.34.0.tar.xz ++
 35060 lines of diff (skipped)




commit tracker-miners for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package tracker-miners for openSUSE:Factory 
checked in at 2019-10-17 13:06:20

Comparing /work/SRC/openSUSE:Factory/tracker-miners (Old)
 and  /work/SRC/openSUSE:Factory/.tracker-miners.new.2352 (New)


Package is "tracker-miners"

Thu Oct 17 13:06:20 2019 rev:15 rq:738474 version:2.3.1

Changes:

--- /work/SRC/openSUSE:Factory/tracker-miners/tracker-miners.changes
2019-05-06 21:12:30.260267250 +0200
+++ /work/SRC/openSUSE:Factory/.tracker-miners.new.2352/tracker-miners.changes  
2019-10-17 13:06:22.024224172 +0200
@@ -1,0 +2,54 @@
+Sat Oct 12 16:23:44 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.3.1:
+  + Improved .odt extraction, fixing issues with hyphenated words.
+  + OpenBSD: Fixed build.
+  + functional-tests: Fixed a cause of intermittent failures,
+removed some unused data files.
+  + Minor compiler warning and build system fixes.
+
+---
+Tue Sep 10 05:56:18 CDT 2019 - mgo...@suse.com
+
+- Update to version 2.3.0:
+  + No changes since 2.2.99.1.
+
+---
+Thu Sep  5 18:50:30 CDT 2019 - mgo...@suse.com
+
+- Update to version 2.2.99.1:
+  + The ~/Downloads folder is now indexed non-recursively by
+default. This reduces the risk of Tracker unnecessarily
+crawling large directories of source code or video game data.
+  - If users are storing data such as music or photos in
+subfolders of the Downloads folder, they will need to move it
+to an appropriate place (~/Music, ~/Pictures, etc.) so that
+it is still indexed.
+  + Dispose TrackerResource objects before unref.
+  + Fixes in Musicbrainz metadata extraction.
+  + Translations: ca, eu.
+
+---
+Mon Aug 26 16:38:55 CST 2019 - yfji...@suse.com
+
+- Update to version 2.2.99.0:
+  + Support for reading Musicbrainz metadata from audio files.
+  + Tracker Writeback now uses GStreamer to write metadata to audio
+files, instead of depending on taglib directly.
+  + Directories will now be ignored if they contain a file named
+`.nomedia`. A file named `.trackerignore` has the same effect,
+but the `.nomedia` file brings us in line with Android.
+  + Removed obsolete 'max-media-art-width' setting.
+- libtracker-miners-common is built as a static library and only
+  used in build time. So remove it in the %install section.
+- Add a new BuildRequires pkgconfig(gstreamer-audio-1.0).
+- Drop an unused BuildRequires pkgconfig(taglib_c).
+
+---
+Tue Jun 25 22:04:32 UTC 2019 - Bjørn Lie 
+
+- Drop pkgconfig(libgrss) BuildRequires and subpackage
+  tracker-miner-rss: libfrss is dropped upstream. Following this,
+  add tracker-miner-rss Obsoletes to main tracker-miners package.
+
+---

Old:

  tracker-miners-2.2.2.tar.xz

New:

  tracker-miners-2.3.1.tar.xz



Other differences:
--
++ tracker-miners.spec ++
--- /var/tmp/diff_new_pack.uGgwFR/_old  2019-10-17 13:06:22.548222822 +0200
+++ /var/tmp/diff_new_pack.uGgwFR/_new  2019-10-17 13:06:22.548222822 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   tracker-miners
-Version:2.2.2
+Version:2.3.1
 Release:0
 Summary:Various miners for Tracker
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Projects/Tracker
-Source0:
https://download.gnome.org/sources/tracker-miners/2.2/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/tracker-miners/2.3/%{name}-%{version}.tar.xz
 
 BuildRequires:  giflib-devel
 BuildRequires:  intltool >= 0.40.0
@@ -41,6 +41,7 @@
 BuildRequires:  pkgconfig(glib-2.0) >= 2.44.0
 BuildRequires:  pkgconfig(gmodule-2.0) >= 2.44.0
 BuildRequires:  pkgconfig(gstreamer-1.0) >= 0.10.31
+BuildRequires:  pkgconfig(gstreamer-audio-1.0) >= 0.10.31
 BuildRequires:  pkgconfig(gstreamer-pbutils-1.0) >= 0.10.31
 BuildRequires:  pkgconfig(gstreamer-tag-1.0) >= 0.10.31
 BuildRequires:  pkgconfig(icu-i18n) >= 4.8.1.1
@@ -50,7 +51,6 @@
 BuildRequires:  pkgconfig(libavutil)
 BuildRequires:  pkgconfig(libcue)
 BuildRequires:  pkgconfig(libexif) >= 0.6
-BuildRequires:  pkgconfig(libgrss) >= 0.7
 BuildRequires:  pkgconfig(libgsf-1) >= 1.14.24
 BuildRequires:  pkgconfig(libgxps)
 BuildRequires:  pkgconfig(libiptcdata)
@@ -59,7 +59,6 @@
 BuildRequires:  pkgconfig(libseccomp) >= 2.0
 BuildRequires:  pkgconfig(libxml-2.0) >= 2.6
 BuildRequires:  pkgconfig(poppler-glib) >= 0.16.0
-BuildRequires:  pkgconfig(taglib_c) >= 1.6
 BuildRequires:  

commit tracker for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package tracker for openSUSE:Factory checked 
in at 2019-10-17 13:06:14

Comparing /work/SRC/openSUSE:Factory/tracker (Old)
 and  /work/SRC/openSUSE:Factory/.tracker.new.2352 (New)


Package is "tracker"

Thu Oct 17 13:06:14 2019 rev:122 rq:738473 version:2.3.1

Changes:

--- /work/SRC/openSUSE:Factory/tracker/tracker.changes  2019-07-18 
15:18:48.216161374 +0200
+++ /work/SRC/openSUSE:Factory/.tracker.new.2352/tracker.changes
2019-10-17 13:06:17.172236667 +0200
@@ -1,0 +2,46 @@
+Sat Oct 12 16:21:51 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.3.1:
+  + Fixed a case where old data was not deleted correctly from the
+store when inserting new values. This was causing
+tracker-extract to log errors for multi-disc music albums
+stored as FLAC files with embedded CUE sheets.
+  + Updated translations.
+
+---
+Tue Sep 10 05:53:31 CDT 2019 - mgo...@suse.com
+
+- Update to version 2.3.0:
+  + No changes since 2.2.99.1.
+
+---
+Thu Sep  5 18:48:13 CDT 2019 - mgo...@suse.com
+
+- Update to version 2.2.99.1:
+  + Handle circular references in TrackerResource.
+  + Removed stress tests.
+  + Handle application/x-zero-size.
+  + Refactors and cleanups in functional testing infrastructure.
+  + Documentation improvements.
+  + Make tracker_sparql_escape_string() escape single quotes.
+  + Don't make tracker:referenceSource a subproperty of
+nie:identifier.
+  + Translations: eu.
+- Add trackertestutils to -devel package.
+
+---
+Thu Aug 22 16:59:05 CST 2019 - yfji...@suse.com
+
+- Update to version 2.2.99.0:
+  + Support for storing Musicbrainz metadata in the multimedia
+ontology.
+  + Doc cleanups.
+  + Test suite improvements.
+  + Build fixes.
+  + Fix detection of files that need writeback.
+  + Fix crashes and invalid memory writes.
+- libtracker-common is built as a static library and only used in
+  build time. So remove it in the %install section.
+- Drop fix-tracker-miner-fs-lto-crash.patch: fixed upstream.
+
+---

Old:

  fix-tracker-miner-fs-lto-crash.patch
  tracker-2.2.2.tar.xz

New:

  tracker-2.3.1.tar.xz



Other differences:
--
++ tracker.spec ++
--- /var/tmp/diff_new_pack.zjT5XA/_old  2019-10-17 13:06:17.732235225 +0200
+++ /var/tmp/diff_new_pack.zjT5XA/_new  2019-10-17 13:06:17.736235214 +0200
@@ -21,15 +21,13 @@
 %define RPMTrackerAPI 2_0
 
 Name:   tracker
-Version:2.2.2
+Version:2.3.1
 Release:0
 Summary:Object database, tag/metadata database, search tool and indexer
 License:GPL-2.0-or-later
 Group:  Productivity/Other
 URL:https://wiki.gnome.org/Projects/Tracker
-Source0:
https://download.gnome.org/sources/tracker/2.2/%{name}-%{version}.tar.xz
-# PATCH-FIX-UPSTREAM fix-tracker-miner-fs-lto-crash.patch -- Fix build with 
LTO enabled
-Patch0: fix-tracker-miner-fs-lto-crash.patch
+Source0:
https://download.gnome.org/sources/tracker/2.3/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
@@ -233,6 +231,7 @@
 
 %fdupes %{buildroot}%{_datadir}/vala/
 %fdupes %{buildroot}%{_datadir}/gtk-doc
+rm -f %{buildroot}%{_libdir}/tracker-%{TrackerAPI}/libtracker-common.a
 
 %post -n libtracker-control-%{RPMTrackerAPI}-0 -p /sbin/ldconfig
 %postun -n libtracker-control-%{RPMTrackerAPI}-0 -p /sbin/ldconfig
@@ -267,7 +266,6 @@
 %{_mandir}/man1/tracker-tag.1%{ext_man}
 
 %files -n libtracker-common-%{RPMTrackerAPI}
-%{_libdir}/tracker-%{TrackerAPI}/libtracker-common.so
 %{_libdir}/tracker-%{TrackerAPI}/libtracker-data.so
 %{_datadir}/glib-2.0/schemas/org.freedesktop.Tracker.enums.xml
 
@@ -292,6 +290,7 @@
 %files -n tracker-devel
 %doc AUTHORS README.md NEWS
 %{_libdir}/lib*.so
+%{_libdir}/tracker-%{TrackerAPI}/trackertestutils
 %{_includedir}/tracker-%{TrackerAPI}/
 %{_libdir}/pkgconfig/tracker-control-%{TrackerAPI}.pc
 %{_libdir}/pkgconfig/tracker-miner-%{TrackerAPI}.pc

++ tracker-2.2.2.tar.xz -> tracker-2.3.1.tar.xz ++
 10478 lines of diff (skipped)




commit ido for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package ido for openSUSE:Factory checked in 
at 2019-10-17 13:05:38

Comparing /work/SRC/openSUSE:Factory/ido (Old)
 and  /work/SRC/openSUSE:Factory/.ido.new.2352 (New)


Package is "ido"

Thu Oct 17 13:05:38 2019 rev:4 rq:737937 version:13.10.0+bzr20161028

Changes:

--- /work/SRC/openSUSE:Factory/ido/ido.changes  2018-03-26 12:03:34.533719271 
+0200
+++ /work/SRC/openSUSE:Factory/.ido.new.2352/ido.changes2019-10-17 
13:05:46.312316139 +0200
@@ -1,0 +2,9 @@
+Sat Oct 12 08:07:32 UTC 2019 - Dominique Leuenberger 
+
+- Add ido-fix-maintainer-cflags.patch: Do not pass -Werror
+  unconditionally. This is already part of
+  --enable-maintainer-flags, which is default enabled on the
+  unstable branch. For the stable branch, we accept new warnings
+  coming from updated toolchains and gnome stacks.
+
+---

New:

  ido-fix-maintainer-cflags.patch



Other differences:
--
++ ido.spec ++
--- /var/tmp/diff_new_pack.FbgZqv/_old  2019-10-17 13:05:46.808314862 +0200
+++ /var/tmp/diff_new_pack.FbgZqv/_new  2019-10-17 13:05:46.812314852 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package ido
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -32,6 +32,8 @@
 Source1:baselibs.conf
 # PATCH-FIX-OPENSUSE ido-optional-ubuntu-private.patch sor.ale...@meowr.ru -- 
Make Ubuntu GTK+ Private API optional.
 Patch0: ido-optional-ubuntu-private.patch
+# PATCH-FIX-OPENSUSE ido-fix-maintainer-cflags.patch dims...@opensuse.org -- 
Strip -Werror from unconditional CFLAGS. This is part of maintainer_CFLAGS; 
fixes build with more recent toolchains/gnome stacks
+Patch1: ido-fix-maintainer-cflags.patch
 BuildRequires:  gcc-c++
 BuildRequires:  gnome-common
 BuildRequires:  pkgconfig
@@ -84,6 +86,7 @@
 %prep
 %setup -q -c
 %patch0 -p1
+%patch1 -p1
 
 %build
 NOCONFIGURE=1 gnome-autogen.sh

++ ido-fix-maintainer-cflags.patch ++
Index: ido-13.10.0+bzr20161028/src/Makefile.am
===
--- ido-13.10.0+bzr20161028.orig/src/Makefile.am
+++ ido-13.10.0+bzr20161028/src/Makefile.am
@@ -66,7 +66,7 @@ AM_CPPFLAGS = \
$(GCC_FLAGS)\
$(GTK_CFLAGS)   \
$(MAINTAINER_CFLAGS)\
-   -Wall -Werror -Wextra -Wno-unused-parameter 
-Wno-error=deprecated-declarations
+   -Wall -Wextra -Wno-unused-parameter -Wno-error=deprecated-declarations
 
 if USE_UBUNTU_PRIVATE_API
 AM_CPPFLAGS += -DUSE_UBUNTU_PRIVATE_API



commit gnome-settings-daemon for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-settings-daemon for 
openSUSE:Factory checked in at 2019-10-17 13:06:02

Comparing /work/SRC/openSUSE:Factory/gnome-settings-daemon (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-settings-daemon.new.2352 (New)


Package is "gnome-settings-daemon"

Thu Oct 17 13:06:02 2019 rev:159 rq:738472 version:3.34.1+0

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-settings-daemon/gnome-settings-daemon.changes  
2019-08-15 12:24:58.294612610 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-settings-daemon.new.2352/gnome-settings-daemon.changes
2019-10-17 13:06:07.640261214 +0200
@@ -1,0 +2,109 @@
+Sat Oct 12 16:56:25 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.1+0:
+  + power: Fix rounding of brightness value.
+
+---
+Wed Oct 09 19:45:45 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.0+10:
+  + smartcard:
+- Change timeout on spurious event error
+- Change manager to non-blocking
+  + GsdSmartcardService: Use correct parent type for structs
+  + media-keys: Divide keyboard brightness value by 100
+  + Updated translations.
+- Switch to git checkout via source service, use upstream stable
+  branch.
+- Drop gsd-smartcard-parent-type.patch: Fixed upstream.
+
+---
+Tue Oct  8 10:36:50 UTC 2019 - Yifan Jiang 
+
+- Rebase gnome-settings-daemon-notify-idle-resumed.patch:
+  Add the newly added parameter NOTIFICATION_PRIVACY_SYSTEM for the
+  function of create_notification.
+
+---
+Fri Sep 20 17:19:51 UTC 2019 - Felix Zhang 
+
+- Apply gnome-settings-daemon-sle-configure-timeout-blank.patch
+  correctly.
+- Rebase gnome-settings-daemon-notify-idle-resumed.patch.
+
+---
+Tue Sep 17 19:33:05 UTC 2019 - Michael Gorse 
+
+- Add gsd-smartcard-parent-type.patch: use correct parent type for
+  structs.
+
+---
+Tue Sep 10 05:51:17 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Fri Sep  6 11:40:02 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Media-keys: Fix MPRIS controller no longer working.
+  + XSettings: Make plugin able to run on demand.
+  + Ensure plugin is started after the shell.
+  + Replace deprecated 'g_type_class_add_private' in
+GnomeSettingsPluginInfo.
+  + Updated translations.
+
+---
+Sat Aug 31 05:37:59 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.90:
+  + Add systemd user service files for all the plugins.
+- With the exception of gsd-xsettings, daemons do not use the
+  GDK X11 backend anymore.
+  + WWAN: New daemon, handles WWAN device settings.
+  + Mouse: Removed daemon, everything is now implemented in mutter.
+  + Clipboard: - Removed daemon, everything is now implemented in
+mutter.
+  + Color: Use Planckian calculations on night light.
+  + Rfkill: - Handle airplane mode for WWAN interfaces.
+  + XSettings: Round Xft.dpi setting to an integer.
+  + Add entry for overlay scrolling setting.
+  + Media-keys: - Use device node from AcceleratorActivated
+arguments.
+  + Updated translations.
+- Changes from version 3.33.0:
+  + Compile warning fixes.
+  + Media-keys:
+- Keygrabbing has been reworked. The new UngrabAccelerators
+  DBus API on the shell is now required. Non-GNOME Desktops
+  using g-s-d will need to be updated for this.
+- Add mapping for screen brightness cycle key.
+- Fix launched clients inheriting DESKTOP_AUTOSTART_ID.
+- Allow mapping of hard-coded keys.
+  + Power:
+- Fix memory leak.
+- Remove special handling of tablet devices.
+  + Mouse:
+- Remove locate-pointer, in favor of gnome-shell handling.
+- Remove mousetweaks support, in favor of gnome-shell handling.
+  + Keyboard: Remove numlock persistence, in favor of gnome-shell
+handling.
+  + Updated translations.
+- Up colord, gsettings-desktop-schemas, polkit-gobject, and
+  upower-glib dependencies.
+- Add systemd dependency.
+- Add gcr and mm-glib dependencies for wwan.
+- Drop gnome-settings-daemon-round-xft_dpi-to-integer.patch: fixed
+  upstream.
+- Rebase patches: gnome-settings-daemon-initial-keyboard.patch,
+  gnome-settings-daemon-bgo793253.patch., and SLED patches:
+  gnome-settings-daemon-bnc873545-hide-warnings.patch,
+  gnome-settings-daemon-more-power-button-actions.patch,
+  gnome-settings-daemon-notify-idle-resumed.patch, and
+  gnome-settings-daemon-sle-configure-timeout-blank.patch.

commit vte for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package vte for openSUSE:Factory checked in 
at 2019-10-17 13:05:06

Comparing /work/SRC/openSUSE:Factory/vte (Old)
 and  /work/SRC/openSUSE:Factory/.vte.new.2352 (New)


Package is "vte"

Thu Oct 17 13:05:06 2019 rev:118 rq:737894 version:0.58.2

Changes:

--- /work/SRC/openSUSE:Factory/vte/vte.changes  2019-08-16 15:29:33.061980127 
+0200
+++ /work/SRC/openSUSE:Factory/.vte.new.2352/vte.changes2019-10-17 
13:05:17.216391069 +0200
@@ -1,0 +2,110 @@
+Fri Oct 11 19:15:14 UTC 2019 - bjorn@gmail.com
+
+- Update to version 0.58.2:
+  + ring: Fix an incorrect assertion.
+  + pty: Fix error check for ioctl(TIOCGPTPEER) failure.
+
+---
+Mon Oct 07 20:23:55 UTC 2019 - bjorn@gmail.com
+
+- Update to version 0.58.1:
+  + emulation: Ensure the cursor remains onscreen when moving down.
+  + widget: Don't scroll to bottom on keystroke in read-only mode.
+  + Updated translations.
+
+---
+Mon Sep 09 19:47:50 UTC 2019 - bjorn@gmail.com
+
+- Update to version 0.58.0:
+  + build: Don't pass C warning flags to the C++ compiler.
+- Update URL to point to gitlab home.
+
+---
+Sun Aug 11 10:51:42 UTC 2019 - bjorn@gmail.com
+
+- Update to version 0.57.90:
+  + draw: #include  for std::max
+  + pty: Prefer using TIOCGPTPEER ioctl
+  + pty: Use O_NOCTTY when VTE_PTY_NOCTTY is set
+  + bidi: Disable Arabic ligatures
+  + Updated translations.
+- Changes from version 0.57.3:
+  + Add barebones README
+  + all: Add installation & debugging information
+  + app: Plug mem leaks
+  + bidi:
+- Add API to enable or disable bidirectional text support
+- Find the BiDi mapping for the RingView's contents
+  + build:
+- Add debug flags when debug is enabled
+- Add missing file
+- Check gcc version
+- Do not allow disabling asserts
+- Fix build on meson 0.49
+- Ignore everything in the build directory
+- Increase test timeout
+- List Wextra warnings
+- Port to meson build system
+- Use our own warning flags
+  + docs:
+- Add index for API new in 0.56
+- Add index for API new in 0.58
+  + docs,bidi: Clarify the relation between get_text API methods
+and BiDi
+  + draw:
+- Align the baseline across font styles
+- Measure characters individually
+- Optimise invalidation and painting
+  + emulation,bidi: Add keyboard swapping mode
+  + emulation:
+- Fix background color handling of DCH and ECH
+- Improve docs
+- Make certain operataions convert line endings to hard newline
+- Track BiDi parameters
+  + gir: Fix introspection annotations
+  + l10n:
+- Add POTFILES.skip back
+- Re-rename POTFILES to POTFILES.in
+  + mev: Fix an implicit fallthrough warning
+  + parser: glue: Correct parameter collection
+  + perf,bidi: Add BiDi demo and info files
+  + pty: Make vte_pty_child_setup() useful for flatpack
+  + reflect: Fix compiler warnings
+  + regex: Fix doc comment
+  + Revert "parser: glue: Use std::clamp"
+  + ring:
+- fix printf format
+- Keep an additional row writable
+- Silence some warnings with debug disabled
+  + ringview: Add RingView infrastructure
+  + vala:
+- Make binding tests compile without warning
+- Make the vala test build without warnings
+  + vte.sh: Remove control chars for window title
+  + widget:
+- Add valist signal marshallers
+  + widget: Avoid double painting of letters
+- Cancel autoscroll on ending selecting
+- Clean up invalidating in insert_char()
+- Deprecate vte_terminal_[sg]et_rewrap_on_resize()
+- Don't clamp before invalidating from process_incoming()
+- Find contiguous LTR and RTL runs of decoration
+- Fix invalidation with scrolling region
+- Fix misleading comments in cursor_down()
+- Increase minimum width to 2 cells plus padding
+- Invalidate the entire paragraph when its contents change
+- Merge identical m_color_defaults and m_fill_defaults
+- Move out a common condition for painting the background
+- Refactor offscreen cursor detection
+- Remove line_is_wrappable()
+- Revert to paint unused rows
+- Set the soft_wrapped flag via wrapper methods
+- Throw away remaining incoming data on finalize
+  + widget,bidi:
+   - Denote the direction in the I-beam cursor
+   - Display according to the BiDi mapping
+- Add meson BuildRequires and macro following upstreams port.
+- Drop gnome-common BuildRequires and autogen call, no longer
+  needed with meson buildsystem.
+
+---

Old:

  vte-0.56.3.tar.xz

New:

  vte-0.58.2.tar.xz


commit MozillaThunderbird for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package MozillaThunderbird for 
openSUSE:Factory checked in at 2019-10-17 13:05:14

Comparing /work/SRC/openSUSE:Factory/MozillaThunderbird (Old)
 and  /work/SRC/openSUSE:Factory/.MozillaThunderbird.new.2352 (New)


Package is "MozillaThunderbird"

Thu Oct 17 13:05:14 2019 rev:218 rq:737931 version:68.1.2

Changes:

--- /work/SRC/openSUSE:Factory/MozillaThunderbird/MozillaThunderbird.changes
2019-10-10 11:49:23.275967344 +0200
+++ 
/work/SRC/openSUSE:Factory/.MozillaThunderbird.new.2352/MozillaThunderbird.changes
  2019-10-17 13:05:26.124368128 +0200
@@ -1,0 +2,16 @@
+Thu Oct 10 14:30:09 UTC 2019 - Wolfgang Rosenauer 
+
+- Mozilla Thunderbird 68.1.2
+  Bugfixes
+  * Some attachments couldn't be opened in messages originating from
+MS Outlook 2016
+  * Address book import from CSV
+  * Performance problem in message body search
+  * Ctrl+Enter to send a message would open an attachment if the
+attachment pane had focus
+  * Calendar: Issues with "Today Pane" start-up
+  * Calendar: Glitches with custom repeat and reminder number input
+  * Calendar: Problems with WCAP provider
+- add mozilla-bmo1585099.patch to fix build with rust >= 1.38
+
+---

Old:

  l10n-68.1.1.tar.xz
  thunderbird-68.1.1.source.tar.xz
  thunderbird-68.1.1.source.tar.xz.asc

New:

  l10n-68.1.2.tar.xz
  mozilla-bmo1585099.patch
  thunderbird-68.1.2.source.tar.xz
  thunderbird-68.1.2.source.tar.xz.asc



Other differences:
--
++ MozillaThunderbird.spec ++
--- /var/tmp/diff_new_pack.pQ4Zeq/_old  2019-10-17 13:05:45.700317715 +0200
+++ /var/tmp/diff_new_pack.pQ4Zeq/_new  2019-10-17 13:05:45.704317705 +0200
@@ -26,11 +26,11 @@
 # major 69
 # mainver %major.99
 %define major   68
-%define mainver %major.1.1
-%define orig_version68.1.1
+%define mainver %major.1.2
+%define orig_version68.1.2
 %define orig_suffix %{nil}
 %define update_channel  release
-%define releasedate 20190924105435
+%define releasedate 20191008153335
 %define source_prefix   thunderbird-%{mainver}
 
 # always build with GCC as SUSE Security Team requires that
@@ -55,11 +55,7 @@
 %define __provides_exclude ^lib.*\\.so.*$
 %define __requires_exclude 
^(libmoz.*|liblgpllibs.*|libxul.*|libldap.*|libldif.*|libprldap.*)$
 %define localize 1
-%ifarch %ix86 x86_64
-%define crashreporter 1
-%else
 %define crashreporter 0
-%endif
 
 %define has_system_cairo 0
 
@@ -178,6 +174,7 @@
 Patch22:mozilla-nestegg-big-endian.patch
 Patch23:mozilla-bmo1512162.patch
 Patch24:mozilla-fix-top-level-asm.patch
+Patch25:mozilla-bmo1585099.patch
 Patch100:   thunderbird-broken-locales-build.patch
 %endif # only_print_mozconfig
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -185,15 +182,8 @@
 Recommends: libcanberra0
 Recommends: libpulse0
 ### build options
-%ifarch aarch64 ppc ppc64 ppc64le s390 s390x ia64 %arm
-%define crashreporter 0
-%else
-%define crashreporter 1
-%endif
 %define has_system_cairo 0
 ### build options end
-%define __provides_exclude ^lib.*\\.so.*$
-%define __requires_exclude 
^(libmoz.*|liblgpllibs.*|libxul.*|libldap.*|libldif.*|libprldap.*)$
 Requires:   mozilla-nspr >= %(rpm -q --queryformat '%%{VERSION}' 
mozilla-nspr)
 Requires:   mozilla-nss >= %(rpm -q --queryformat '%%{VERSION}' 
mozilla-nss)
 Requires(post): desktop-file-utils
@@ -266,7 +256,7 @@
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%ifarch s390x
+%ifarch s390x ppc64
 %patch11 -p1
 %endif
 %patch12 -p1
@@ -282,6 +272,7 @@
 %patch22 -p1
 %patch23 -p1
 %patch24 -p1
+%patch25 -p1
 # Thunderbird
 %patch100 -p1
 %endif # only_print_mozconfig
@@ -308,6 +299,7 @@
 export MOZ_BUILD_DATE=%{releasedate}
 export MOZILLA_OFFICIAL=1
 export BUILD_OFFICIAL=1
+export MOZ_TELEMETRY_REPORTING=1
 %if 0%{?suse_version} <= 1320
 export CC=gcc-7
 %else
@@ -329,9 +321,6 @@
 %endif
 %endif
 export CXXFLAGS="$CFLAGS"
-%ifarch %{arm} aarch64
-export RUSTFLAGS="-Cdebuginfo=0"
-%endif
 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
 %if %{with only_print_mozconfig}
 echo "export CC=$CC"
@@ -345,6 +334,7 @@
 %limit_build -m 2000
 export MOZ_DEBUG_FLAGS="-pipe"
 cat << EOF > $MOZCONFIG
+%endif
 mk_add_options MOZILLA_OFFICIAL=1
 mk_add_options BUILD_OFFICIAL=1
 mk_add_options MOZ_MILESTONE_RELEASE=1
@@ -356,11 +346,11 @@
 %endif
 %endif
 mk_add_options MOZ_OBJDIR=$RPM_BUILD_DIR/obj
-ac_add_options --enable-application=comm/mail
-ac_add_options --enable-calendar
 ac_add_options --prefix=%{_prefix}
 ac_add_options --libdir=%{progdir}
 ac_add_options --includedir=%{_includedir}
+ac_add_options --enable-application=comm/mail
+ac_add_options --enable-calendar
 

commit adwaita-icon-theme for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package adwaita-icon-theme for 
openSUSE:Factory checked in at 2019-10-17 13:04:53

Comparing /work/SRC/openSUSE:Factory/adwaita-icon-theme (Old)
 and  /work/SRC/openSUSE:Factory/.adwaita-icon-theme.new.2352 (New)


Package is "adwaita-icon-theme"

Thu Oct 17 13:04:53 2019 rev:21 rq:737893 version:3.34.0+13

Changes:

--- /work/SRC/openSUSE:Factory/adwaita-icon-theme/adwaita-icon-theme.changes
2019-05-03 22:15:37.663888610 +0200
+++ 
/work/SRC/openSUSE:Factory/.adwaita-icon-theme.new.2352/adwaita-icon-theme.changes
  2019-10-17 13:05:12.628402885 +0200
@@ -1,0 +2,41 @@
+Sat Oct 12 11:00:10 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.0+13:
+  + Symbolic:
+- refined preferences-system-parental-controls
+- add preferences-system-parental-controls
+- fix missized copy icon; fix stroke in folder-new
+- view-more use circles
+- be less clever in the document icons
+- symbolic: refine clear icons; retire brush metaphor for
+  clear-all
+- refine alarm shape
+- Switch to git checkout, explicit commit from master branch.
+  Following this, add libtool BuildRequires and pass autogen.sh,
+  needed to boostrap since we are now using a checkout.
+
+---
+Thu Sep 12 16:23:04 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + Fullcolor: update media-optical to the new style.
+
+---
+Sun Sep  8 09:33:14 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + symbolic:
+- send-to metaphor.
+- battery-missing-symbolic.
+- pixel perfect question mark.
+- mail-attachment metrics.
+- view-reveal, view-conceal for passwords.
+- keyboard.
+- folders as inode.
+- orientation icons.
+- touch-disabled.
+- weather-tornado.
+- battery level icons.
+  + fullcolor: colorful packages.
+
+---

Old:

  adwaita-icon-theme-3.32.0.tar.xz

New:

  _service
  _servicedata
  adwaita-icon-theme-3.34.0+13.obscpio
  adwaita-icon-theme.obsinfo



Other differences:
--
++ adwaita-icon-theme.spec ++
--- /var/tmp/diff_new_pack.9OYrn3/_old  2019-10-17 13:05:14.788397322 +0200
+++ /var/tmp/diff_new_pack.9OYrn3/_new  2019-10-17 13:05:14.792397311 +0200
@@ -17,16 +17,17 @@
 
 
 Name:   adwaita-icon-theme
-Version:3.32.0
+Version:3.34.0+13
 Release:0
 Summary:GNOME Icon Theme
 License:LGPL-3.0-or-later OR CC-BY-SA-3.0
 Group:  System/GUI/GNOME
 URL:https://gitlab.gnome.org/GNOME/adwaita-icon-theme
-Source0:
https://download.gnome.org/sources/adwaita-icon-theme/3.32/%{name}-%{version}.tar.xz
+Source0:%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 BuildRequires:  gdk-pixbuf-loader-rsvg
+BuildRequires:  libtool
 BuildRequires:  pkgconfig
 # To make sure the icon theme cache gets generated
 Requires(post): gtk3-tools
@@ -40,6 +41,7 @@
 %autosetup
 
 %build
+NOCONFIGURE=1 ./autogen.sh
 %configure
 %make_build
 

++ _service ++

  
https://gitlab.gnome.org/GNOME/adwaita-icon-theme.git
git
e4547491
@PARENT_TAG@+@TAG_OFFSET@
enable
  
  
  
*.tar
xz
  
  

++ _servicedata ++


https://gitlab.gnome.org/GNOME/adwaita-icon-theme.git
  e454749159c79966ddd9a7412f46be08ed526994++
 adwaita-icon-theme.obsinfo ++
name: adwaita-icon-theme
version: 3.34.0+13
mtime: 1570215131
commit: e454749159c79966ddd9a7412f46be08ed526994




commit PackageKit for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package PackageKit for openSUSE:Factory 
checked in at 2019-10-17 13:05:55

Comparing /work/SRC/openSUSE:Factory/PackageKit (Old)
 and  /work/SRC/openSUSE:Factory/.PackageKit.new.2352 (New)


Package is "PackageKit"

Thu Oct 17 13:05:55 2019 rev:192 rq:738470 version:1.1.12

Changes:

--- /work/SRC/openSUSE:Factory/PackageKit/PackageKit.changes2019-09-11 
10:18:17.487526412 +0200
+++ /work/SRC/openSUSE:Factory/.PackageKit.new.2352/PackageKit.changes  
2019-10-17 13:05:56.880288924 +0200
@@ -1,0 +2,15 @@
+Mon Oct 14 07:00:32 UTC 2019 - Jonathan Kang 
+
+- Remove zypp-Switch-to-doUpgrade-solver-when-required-by-distribution.patch,
+  rebase zypp-perform-actions-disallowed-by-update-in-upgrade-mode.patch,
+  add 
PackageKit-zypp-dont-set-upgrade-mode-on-updating-specific-packages.patch:
+  zypp: Don't set upgrade mode in update-packages
+  (gh#hughsie/PackageKit#345).
+
+---
+Wed Oct  9 06:19:11 UTC 2019 - Jonathan Kang 
+
+- Add PackageKit-zypp-get-updates-dup-or-up.patch: Fix get-updates
+  in Tumbleweed(gh#hughsie/PackageKit#343).
+
+---

Old:

  zypp-Switch-to-doUpgrade-solver-when-required-by-distribution.patch

New:

  PackageKit-zypp-dont-set-upgrade-mode-on-updating-specific-packages.patch
  PackageKit-zypp-get-updates-dup-or-up.patch



Other differences:
--
++ PackageKit.spec ++
--- /var/tmp/diff_new_pack.Ma0Y6D/_old  2019-10-17 13:05:57.916286256 +0200
+++ /var/tmp/diff_new_pack.Ma0Y6D/_new  2019-10-17 13:05:57.920286246 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via https://bugs.opensuse.org/
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
 
@@ -47,16 +47,19 @@
 Patch2: PackageKit-add-mutex-lock-to-protect-backend-priv-eulas.patch
 # PATCH-FEATURE-OPENSUSE PackageKit-systemd-timers.patch bsc#1115410 
sck...@suse.com -- Migrate from cron to systemd timers
 Patch3: PackageKit-systemd-timers.patch
-Patch4: 
zypp-Switch-to-doUpgrade-solver-when-required-by-distribution.patch
 # PATCH-FIX-OPENSUSE PackageKit-remove-polkit-rules.patch bsc#1125434 
sck...@suse.com -- Remove polkit rules file
-Patch5: PackageKit-remove-polkit-rules.patch
-Patch6: zypp-perform-actions-disallowed-by-update-in-upgrade-mode.patch
+Patch4: PackageKit-remove-polkit-rules.patch
 # PATCH-FIX-UPSTREAM PackageKit-zypp-fix-newest-filter.patch bsc#1137019 
gh#hughsie/PackageKit#329 sck...@suse.com -- zypp: Emit installed package for 
newest filter
-Patch7: PackageKit-zypp-fix-newest-filter.patch
+Patch5: PackageKit-zypp-fix-newest-filter.patch
 # PATCH-FIX-UPSTREAM PackageKit-zypp-fix-what-provides-newest-filter.patch 
bsc#984865, gh#hughsie/PackageKit#335 sck...@suse.com -- zypp: Add support for 
newest filter in what-provides
-Patch8: PackageKit-zypp-fix-what-provides-newest-filter.patch
+Patch6: PackageKit-zypp-fix-what-provides-newest-filter.patch
 # PATCH-FIX-UPSTREAM PackageKit-drop-gtk2.patch gh#/hughsie/PackageKit#333 - 
Port away from gtk2 dependency
-Patch9: PackageKit-drop-gtk2.patch
+Patch7: PackageKit-drop-gtk2.patch
+# PATCH-FIX-UPSTREAM PackageKit-zypp-get-updates-dup-or-up.patch 
gh#hughsie/PackageKit#343 sck...@suse.com -- zypp: Fix get-updates in Tumbleweed
+Patch8: PackageKit-zypp-get-updates-dup-or-up.patch
+# PATCH-FIX-UPSTREAM 
PackageKit-zypp-dont-set-upgrade-mode-on-updating-specific-packages.patch 
gh#hughsie/PackageKit#345 sck...@suse.com -- zypp: Don't set upgrade mode in 
update-packages
+Patch9: 
PackageKit-zypp-dont-set-upgrade-mode-on-updating-specific-packages.patch
+Patch10:zypp-perform-actions-disallowed-by-update-in-upgrade-mode.patch
 
 BuildRequires:  autoconf-archive
 BuildRequires:  fdupes


++ 
PackageKit-zypp-dont-set-upgrade-mode-on-updating-specific-packages.patch ++
>From 44a2887864b7c0ac54d342126069b6a7ff3c5822 Mon Sep 17 00:00:00 2001
From: Jonathan Kang 
Date: Mon, 14 Oct 2019 15:17:34 +0800
Subject: [PATCH] zypp: Don't set upgrade mode in update-packages

update-packages does two things: 1. update the whole system. 2. update
specific packages. setting upgrade mode to TRUE in update-packages can
lead to inability to update specific packages, as the resolver always
trys to upgrade the whole system in upgrade mode.

Since calling "pkcon update" in Tumbleweed invokes get-updates where
upgrade mode is set to TRUE, we don't have to set it in update-packages
anymore. 

commit gnome-terminal for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-terminal for openSUSE:Factory 
checked in at 2019-10-17 13:05:48

Comparing /work/SRC/openSUSE:Factory/gnome-terminal (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-terminal.new.2352 (New)


Package is "gnome-terminal"

Thu Oct 17 13:05:48 2019 rev:125 rq:738089 version:3.34.2

Changes:

--- /work/SRC/openSUSE:Factory/gnome-terminal/gnome-terminal.changes
2019-05-10 09:16:59.192204653 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-terminal.new.2352/gnome-terminal.changes  
2019-10-17 13:05:51.556302635 +0200
@@ -1,0 +2,32 @@
+Fri Oct 11 16:53:28 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.2:
+  + Updated translations.
+
+---
+Mon Oct  7 20:28:14 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + client: legacy: Block one more undesirable environment
+variable.
+  + build: Add required gio-unix-2.0 dependency.
+  + window: Ignore resize if fullscreen.
+  + Updated translations.
+
+---
+Mon Sep  9 19:57:28 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + build: Fix ChangeLog rule to work on a git worktree.
+  + Updated translations.
+
+---
+Sun Aug 11 12:35:50 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.33.90:
+  + Updated translations.
+- Changes from version 3.33.3:
+  + profile: Add hidden BiDi and shaping preferences.
+  + Updated translations.
+
+---
@@ -21,0 +54 @@
+

Old:

  gnome-terminal-3.32.2.tar.xz

New:

  gnome-terminal-3.34.2.tar.xz



Other differences:
--
++ gnome-terminal.spec ++
--- /var/tmp/diff_new_pack.OPAKws/_old  2019-10-17 13:05:52.060301337 +0200
+++ /var/tmp/diff_new_pack.OPAKws/_new  2019-10-17 13:05:52.064301326 +0200
@@ -17,16 +17,18 @@
 
 
 Name:   gnome-terminal
-Version:3.32.2
+Version:3.34.2
 Release:0
 Summary:GNOME Terminal
 License:GPL-3.0-or-later AND LGPL-2.1-or-later
 Group:  System/X11/Terminals
 URL:https://wiki.gnome.org/Apps/Terminal
-Source0:
https://download.gnome.org/sources/gnome-terminal/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-terminal/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
-# Needed for search provider. It should not be needed in my opionion, we have 
to take this up with upstream, or just provide search provider interface 
definition file as source.
+# Needed for search provider. It should not be needed in my opinion,
+# we have to take this up with upstream, or just provide search
+# provider interface definition file as source.
 BuildRequires:  gnome-shell
 BuildRequires:  intltool >= 0.50.1
 BuildRequires:  pkgconfig
@@ -42,7 +44,7 @@
 BuildRequires:  pkgconfig(libnautilus-extension) >= 3.0.0
 BuildRequires:  pkgconfig(libpcre2-8) >= 10.00
 BuildRequires:  pkgconfig(uuid)
-BuildRequires:  pkgconfig(vte-2.91) >= 0.56.2
+BuildRequires:  pkgconfig(vte-2.91) >= 0.58.0
 BuildRequires:  pkgconfig(x11)
 Requires(pre):  filesystem
 Recommends: %{name}-lang
@@ -91,7 +93,8 @@
 --disable-migration \
 %endif
 --with-gtk=3.0 \
---with-nautilus-extension
+   --with-nautilus-extension \
+   %{nil}
 %make_build
 
 %install

++ gnome-terminal-3.32.2.tar.xz -> gnome-terminal-3.34.2.tar.xz ++
 36350 lines of diff (skipped)




commit open-vm-tools for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package open-vm-tools for openSUSE:Factory 
checked in at 2019-10-17 13:04:39

Comparing /work/SRC/openSUSE:Factory/open-vm-tools (Old)
 and  /work/SRC/openSUSE:Factory/.open-vm-tools.new.2352 (New)


Package is "open-vm-tools"

Thu Oct 17 13:04:39 2019 rev:88 rq:737499 version:11.0.0

Changes:

--- /work/SRC/openSUSE:Factory/open-vm-tools/open-vm-tools.changes  
2019-10-05 16:19:56.277494604 +0200
+++ /work/SRC/openSUSE:Factory/.open-vm-tools.new.2352/open-vm-tools.changes
2019-10-17 13:04:41.812482244 +0200
@@ -1,0 +2,13 @@
+Fri Oct 11 11:47:05 UTC 2019 - Bjørn Lie 
+
+- Add gcc9-static-inline.patch: Fix static inline when building
+  with gcc9.
+
+---
+Wed Oct  9 14:02:35 UTC 2019 - Kirk Allan 
+
+- Fix memory leak in VixToolsListAuthAliases and VixToolsListMappedAliases.
+  (bsc#1153271)
+  + Add patch fix-leaks-Aliases-MappedAliases.patch
+
+---

New:

  fix-leaks-Aliases-MappedAliases.patch
  gcc9-static-inline.patch



Other differences:
--
++ open-vm-tools.spec ++
--- /var/tmp/diff_new_pack.nCRBRk/_old  2019-10-17 13:04:42.556480327 +0200
+++ /var/tmp/diff_new_pack.nCRBRk/_new  2019-10-17 13:04:42.560480317 +0200
@@ -161,6 +161,8 @@
 Supplements:modalias(pci:v15ADd*sv*sd*bc*sc*i*)
 ExclusiveArch:  %ix86 x86_64
 #Upstream patches
+Patch0: fix-leaks-Aliases-MappedAliases.patch
+Patch1: gcc9-static-inline.patch
 
 %systemd_requires
 
@@ -227,6 +229,8 @@
 # fix for an rpmlint warning regarding wrong line feeds
 sed -i -e "s/\r//" README
 #Upstream patches
+%patch0 -p2
+%patch1 -p2
 
 %build
 %if %{with_X}
@@ -391,7 +395,8 @@
 
 %files
 %defattr(-, root, root)
-%doc AUTHORS COPYING ChangeLog NEWS README
+%license COPYING
+%doc AUTHORS ChangeLog NEWS README
 %{_bindir}/vmtoolsd
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/plugins

++ fix-leaks-Aliases-MappedAliases.patch ++
commit 9bc72f0b09702754b429115658a85223cb3058bd
Author: Oliver Kurth 
Date:   Wed Oct 2 17:48:35 2019 -0700

Fix leaks in ListAliases and ListMappedAliases.

The 'record' for each alias was being leaked.

diff --git a/open-vm-tools/services/plugins/vix/vixTools.c 
b/open-vm-tools/services/plugins/vix/vixTools.c
index 6352b915..9ba55073 100644
--- a/open-vm-tools/services/plugins/vix/vixTools.c
+++ b/open-vm-tools/services/plugins/vix/vixTools.c
@@ -9762,7 +9762,6 @@ VixToolsListAuthAliases(VixCommandReques
char *destPtr;
char *endDestPtr;
char *tmpBuf = NULL;
-   char *recordBuf;
size_t recordSize;
char *escapedStr = NULL;
char *escapedStr2 = NULL;
@@ -9822,6 +9821,8 @@ VixToolsListAuthAliases(VixCommandReques
destPtr += Str_Sprintf(destPtr, endDestPtr - destPtr, "%s",
   VIX_XML_ESCAPED_TAG);
for (i = 0; i < num; i++) {
+  char *recordBuf = NULL;
+
   escapedStr = VixToolsEscapeXMLString(uaList[i].pemCert);
   if (escapedStr == NULL) {
  err = VIX_E_OUT_OF_MEMORY;
@@ -9895,6 +9896,8 @@ VixToolsListAuthAliases(VixCommandReques
  Log("%s: ListAuth list results too large, truncating", __FUNCTION__);
  goto abort;
   }
+  free(recordBuf);
+  recordBuf = NULL;
}
 
*result = resultBuffer;
@@ -9960,7 +9963,6 @@ VixToolsListMappedAliases(VixCommandRequ
char *destPtr;
char *endDestPtr;
char *tmpBuf = NULL;
-   char *recordBuf;
char *escapedStr = NULL;
char *escapedStr2 = NULL;
size_t recordSize;
@@ -10014,6 +10016,8 @@ VixToolsListMappedAliases(VixCommandRequ
destPtr += Str_Sprintf(destPtr, endDestPtr - destPtr, "%s",
   VIX_XML_ESCAPED_TAG);
for (i = 0; i < num; i++) {
+  char *recordBuf = NULL;
+
   escapedStr = VixToolsEscapeXMLString(maList[i].pemCert);
   if (escapedStr == NULL) {
  err = VIX_E_OUT_OF_MEMORY;
@@ -10085,6 +10089,8 @@ VixToolsListMappedAliases(VixCommandRequ
  Log("%s: ListMapped results too large, truncating", __FUNCTION__);
  goto abort;
   }
+  free(recordBuf);
+  recordBuf = NULL;
}
 
*result = resultBuffer;
++ gcc9-static-inline.patch ++
diff --git a/open-vm-tools/lib/include/vmware/tools/plugin.h 
b/open-vm-tools/lib/include/vmware/tools/plugin.h
index f9acc6a29..deefd1f3d 100644
--- a/open-vm-tools/lib/include/vmware/tools/plugin.h
+++ b/open-vm-tools/lib/include/vmware/tools/plugin.h
@@ -290,7 +290,7 @@ typedef struct ToolsAppCtx {
  *
  * @return TRUE if COM is initialized when the function returns.
  */
-G_INLINE_FUNC gboolean
+static inline gboolean
 ToolsCore_InitializeCOM(ToolsAppCtx *ctx)
 {

commit NetworkManager for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package NetworkManager for openSUSE:Factory 
checked in at 2019-10-17 13:04:33

Comparing /work/SRC/openSUSE:Factory/NetworkManager (Old)
 and  /work/SRC/openSUSE:Factory/.NetworkManager.new.2352 (New)


Package is "NetworkManager"

Thu Oct 17 13:04:33 2019 rev:201 rq:736805 version:1.18.4

Changes:

--- /work/SRC/openSUSE:Factory/NetworkManager/NetworkManager.changes
2019-08-07 13:54:42.200857298 +0200
+++ /work/SRC/openSUSE:Factory/.NetworkManager.new.2352/NetworkManager.changes  
2019-10-17 13:04:34.792500322 +0200
@@ -1,0 +2,13 @@
+Wed Oct  9 15:26:34 UTC 2019 - Bjørn Lie 
+
+- Update to version 1.18.4:
+  + Improve handling of externally added policy routing rules and
+for rules that are taken over after a restart of NetworkManager
+service.
+  + Fix taking over OVS devices after restart of NetworkManager.
+  + Bugfix reapplying IP configuration while activating.
+  + Allow reapplying Wi-Fi profile when seen-bssids changes.
+  + Various other bugfixes for minor issues and memory leaks.
+  + Various build and test fixes.
+
+---
@@ -190 +203 @@
-  (bsc#1074074).
+  (bsc#1074074, bsc#1146935).

Old:

  NetworkManager-1.18.2.tar.xz

New:

  NetworkManager-1.18.4.tar.xz



Other differences:
--
++ NetworkManager.spec ++
--- /var/tmp/diff_new_pack.qHcJJp/_old  2019-10-17 13:04:35.388498787 +0200
+++ /var/tmp/diff_new_pack.qHcJJp/_new  2019-10-17 13:04:35.392498776 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -22,7 +22,7 @@
 %define with_cacert_patch 0
 %define _udevdir %(pkg-config --variable udevdir udev)
 Name:   NetworkManager
-Version:1.18.2
+Version:1.18.4
 Release:0
 Summary:Network Link Manager and user applications for it
 License:GPL-2.0-or-later

++ NetworkManager-1.18.2.tar.xz -> NetworkManager-1.18.4.tar.xz ++
 19454 lines of diff (skipped)




commit gdm for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gdm for openSUSE:Factory checked in 
at 2019-10-17 13:04:46

Comparing /work/SRC/openSUSE:Factory/gdm (Old)
 and  /work/SRC/openSUSE:Factory/.gdm.new.2352 (New)


Package is "gdm"

Thu Oct 17 13:04:46 2019 rev:218 rq:737582 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/gdm/gdm.changes  2019-08-15 12:24:43.782616230 
+0200
+++ /work/SRC/openSUSE:Factory/.gdm.new.2352/gdm.changes2019-10-17 
13:04:50.244460529 +0200
@@ -1,0 +2,71 @@
+Tue Oct  8 11:37:53 UTC 2019 - Felix Zhang 
+
+- Add gdm-initial-setup-hardening.patch: Introduce a persistent
+  state file to prevent gnome-initial-setup from running if any
+  regular users has previously logged into the system, replacing
+  the current runtime state file that pervents initial-setup from
+  running more than once per boot, so as to reduce the security
+  attack surface.
+  Make this fix openSUSE only for now as upstream discussion is
+  heading another way involving more complicated mechanisms
+  (boo#1140851, glgo#GNOME/gnome-initial-setup#76).
+- Rebase gdm-disable-gnome-initial-setup.patch.
+
+---
+Mon Oct  7 10:02:43 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + De-duplicate sessions on pure Xorg too.
+  + Fix fast user switching by assuming the login screen VT is
+always the initial one.
+  + Updated translations.
+
+---
+Wed Sep 18 02:59:55 UTC 2019 - Xiaoguang Wang 
+
+- Update gdm-switch-to-tty1.patch: switch tty after plymouth
+  terminates.
+
+---
+Wed Sep 11 16:25:58 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Thu Sep  5 12:30:54 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Fix typo in debug message
+  + Revert vt changing fix, because it exposes logind bug and it
+wasn't quite right anyway
+  + Ensure login screen gets reaped when user switching
+  + Translation updates
+
+---
+Sun Sep  1 01:53:57 UTC 2019 - Michael Gorse 
+
+- Update to version 3.33.90:
+  + Update for changes to gnome-settings-daemon.
+  + initial-setup permissions fix.
+  + allow users to set PATH from ~/.config/environment.
+  + support systemd user sessions.
+  + misc warning fixes.
+  + leak fix in libgdm.
+  + vt changing fix.
+  + drop some deprecations.
+  + drop unused icons.
+  + Translation updates.
+  + Changes in version 3.33.4:
+  + Fix session search directories.
+  + Kill user sessions when stopping gdm.
+  + Add way for sessions to register when they successfully started
+  + Translation updates.
+- Rebased gdm-xauthlocalhostname.patch and
+gdm-disable-gnome-initial-setup.patch.
+- Drop gdm-fails-to-restart-gnome-shell.patch,
+  gdm-kill-user-session.patch, and
+  gdm-remove-duplicate-sessions.patch: fixed upstream.
+- Drop icons and pixmaps from files.
+
+---

Old:

  _servicedata
  gdm-3.32.0+2.obscpio
  gdm-fails-to-restart-gnome-shell.patch
  gdm-kill-user-session.patch
  gdm-remove-duplicate-sessions.patch

New:

  gdm-3.34.1.obscpio
  gdm-initial-setup-hardening.patch



Other differences:
--
++ gdm.spec ++
--- /var/tmp/diff_new_pack.PLbN8j/_old  2019-10-17 13:04:51.796456532 +0200
+++ /var/tmp/diff_new_pack.PLbN8j/_new  2019-10-17 13:04:51.800456522 +0200
@@ -19,14 +19,15 @@
 %define systemdsystemunitdir %(pkg-config --variable=systemdsystemunitdir 
systemd)
 # FIXME: need to check what should be done to enable this (at least adapt the 
pam files). See bnc#69
 %define enable_split_authentication 0
+
 Name:   gdm
-Version:3.32.0+2
+Version:3.34.1
 Release:0
 Summary:The GNOME Display Manager
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Projects/GDM
-# We are using source services, so no download url for source
+
 Source0:%{name}-%{version}.tar.xz
 Source1:gdm.pamd
 Source2:gdm-autologin.pamd
@@ -54,16 +55,12 @@
 Patch4: gdm-xauthlocalhostname.patch
 # PATCH-FIX-OPENSUSE gdm-switch-to-tty1.patch bsc#1113700 xw...@suse.com -- 
switch to tty1 when stopping gdm service
 Patch6: gdm-switch-to-tty1.patch
-# PATCH-FIX-UPSTREAM gdm-fails-to-restart-gnome-shell.patch bsc#981976 
glgo#GNOME/gdm#266 ty...@suse.com -- Gdm should stop after a few times fails
-Patch7: gdm-fails-to-restart-gnome-shell.patch
 # 

commit NetworkManager-applet for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package NetworkManager-applet for 
openSUSE:Factory checked in at 2019-10-17 13:04:28

Comparing /work/SRC/openSUSE:Factory/NetworkManager-applet (Old)
 and  /work/SRC/openSUSE:Factory/.NetworkManager-applet.new.2352 (New)


Package is "NetworkManager-applet"

Thu Oct 17 13:04:28 2019 rev:27 rq:736724 version:1.8.24

Changes:

--- 
/work/SRC/openSUSE:Factory/NetworkManager-applet/NetworkManager-applet.changes  
2019-06-24 21:45:41.419751627 +0200
+++ 
/work/SRC/openSUSE:Factory/.NetworkManager-applet.new.2352/NetworkManager-applet.changes
2019-10-17 13:04:29.940512817 +0200
@@ -1,0 +2,20 @@
+Wed Oct  9 16:30:56 UTC 2019 - Michael Gorse 
+
+- Update translation-update-upstream and find_lang invocations.
+The potfile name has changed.
+
+---
+Wed Oct  9 15:22:29 UTC 2019 - Bjørn Lie 
+
+- Update to version 1.8.24:
+  + Fixed external UI mode without interactive secrets.
+  + Ad-Hoc networks now support WPA2 authentication.
+  + Support for SAE authentication (WPA3 Personal) was added.
+  + Fixed applet operation on graphical servers other than X11
+(such as Wayland).
+  + Various other bug fixes and enhancements.
+  + Added EXPERIMENTAL libnma-gtk4 library for use with GTK4. Not
+recommended for production use!
+  + Updated translations.
+
+---

Old:

  network-manager-applet-1.8.22.tar.xz

New:

  network-manager-applet-1.8.24.tar.xz



Other differences:
--
++ NetworkManager-applet.spec ++
--- /var/tmp/diff_new_pack.A2VU1R/_old  2019-10-17 13:04:31.088509861 +0200
+++ /var/tmp/diff_new_pack.A2VU1R/_new  2019-10-17 13:04:31.092509850 +0200
@@ -25,13 +25,13 @@
 %endif
 %bcond_with meson
 Name:   NetworkManager-applet
-Version:1.8.22
+Version:1.8.24
 Release:0
 Summary:GTK+ tray applet for use with NetworkManager
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 Url:https://gnome.org/projects/NetworkManager
-Source: 
http://download.gnome.org/sources/network-manager-applet/1.8/%{_name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/network-manager-applet/1.8/%{_name}-%{version}.tar.xz
 # PATCH-NEEDS-REBASE nm-applet-private-connection.patch boo#751211 bgo#646187 
dims...@opensuse.org -- Create private connections if the user is not 
authorised. Allows to create wifi connections without root access. Patch under 
discussion upstream. (WAS: PATCH-FIX-UPSTREAM)
 Patch0: nm-applet-private-connection.patch
 # PATCH-FIX-OPENSUSE 
NetworkManager-gnome-bsc1003069-default-agent-owned-secrets.patch bsc#1003069 
h...@suse.com -- Make sure secrets default to agent-owned (encrypted keyring).
@@ -143,7 +143,7 @@
 %if %{with appindicator}
 %patch2 -p1
 %endif
-translation-update-upstream po network-manager-applet
+translation-update-upstream po nm-applet
 
 %build
 %if %{with meson}
@@ -176,7 +176,7 @@
 find %{buildroot} -type f -name "*.la" -delete -print
 %endif
 %suse_update_desktop_file -r nm-connection-editor GTK GNOME System 
X-SuSE-ServiceConfiguration
-%find_lang network-manager-applet %{?no_lang_C}
+%find_lang nm-applet %{?no_lang_C}
 
 %if 0%{?suse_version} < 1330
 %post
@@ -207,7 +207,7 @@
 %{_datadir}/icons/hicolor/*/apps/*.svg
 %{_mandir}/man1/nm-applet.1%{?ext_man}
 
-%files lang -f network-manager-applet.lang
+%files lang -f nm-applet.lang
 
 %files -n NetworkManager-connection-editor
 %{_bindir}/nm-connection-editor

++ network-manager-applet-1.8.22.tar.xz -> 
network-manager-applet-1.8.24.tar.xz ++
 375665 lines of diff (skipped)




commit orca for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package orca for openSUSE:Factory checked in 
at 2019-10-17 13:03:11

Comparing /work/SRC/openSUSE:Factory/orca (Old)
 and  /work/SRC/openSUSE:Factory/.orca.new.2352 (New)


Package is "orca"

Thu Oct 17 13:03:11 2019 rev:142 rq:736597 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/orca/orca.changes2019-05-03 
22:13:18.931613188 +0200
+++ /work/SRC/openSUSE:Factory/.orca.new.2352/orca.changes  2019-10-17 
13:03:19.908690751 +0200
@@ -1,0 +2,162 @@
+Mon Sep  9 13:55:37 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Web:
+- Complete *initial* support for Chrome/Chromium. Important:
+  In order - for this support to work, you will need a version
+  of Chrome/Chromium - which has not yet been released.
+- Don't auto-enter focus mode for embedded role if reading PDF.
+- Ensure we respect the choice to temporarily turn live
+  regions off.
+- Ignore "document" load events for images emitted by Gecko.
+- Eliminate some chattiness with popup button elements.
+  + Thunderbird: Attempt to improve performance by ignoring some
+event spam.
+  + General:
+- Several stability fixes for objects and applications going
+  defunct.
+- Fix regression introduced by Shift Lock change.
+- Improve reliability of mouse review when multiple objects
+  report same bounding box.
+  + New and updated translations.
+
+---
+Sat Aug 31 13:35:06 UTC 2019 - Michael Gorse 
+
+- Re-enable translation-update-upstream, and fix invocation. 
+
+---
+Fri Aug 30 15:33:51 UTC 2019 - Michael Gorse 
+
+- Update to version 3.33.91: 
+  + Web:
+- Improve performance with structural navigation amongst
+  large objects.
+-  Also fix performance regression introduced in unstable
+  release.
+- Treat headings as paragraphs for the purpose of structural
+  navigation
+- Treat push buttons with state has-popup as focus-mode
+  widgets
+- Fix chattiness resulting from svg elements with no
+  information
+- Don't generate tutorial messages for widgets in document
+  content
+- Eliminate some chattiness with Google Drive menus
+- Improve presentation of widgets which are destroyed and
+  recreated  while focused
+- Improve detection and presentation of content which is
+  exposed to  us incorrectly due to CSS properties
+- Ongoing work on Chromium support.
+  + GNOME Shell: Eliminate some chattiness with Dash
+  + Updated translations.
+- Changes from version 3.33.90:
+  + Web:
+- Try to include results count during find in page searches
+- Fix bugs preventing SayAll on page load from working
+- Fix bug in braille presentation of new Firefox location
+  input
+- Work around another instance of CSSed text being exposed
+  as one char  per line
+- Improve presentation of treegrids
+- Reduce chattiness with editable comboboxes and with
+  auto-focused  descendants
+- Never treat layout-only-table cells as focus-mode widgets
+- Make finding clickables more performant
+- Ensure we present final word in element when navigating
+  by word
+- Present caret-moved events from mouse clicks even if
+  element hasn't  changed
+  + Mouse Review:
+- Improve overall presentation of units of text under
+  the pointer
+- Improve logic filtering out irrelevant mouse movements
+  during review
+- Apply non-mousereview cell/row presentation preferences
+  for a  more consistent experience
+- Don't present description for mouse review if tooltip
+  presentation  is off
+  + General:
+- Add support for Shift Lock
+- Add initial support for AtspiText's scrollSubstringTo
+- Add fall backs for click-at-point failures
+- Also check for "underline:spelling" as indication of
+  spelling error
+- Improve response time for mouse input events
+- Allow building with gettext ≥ 0.20
+- Changes from version 3.33.3:
+  + Web:
+- Improve presentation of Google Sheets when native
+  accessibility  support is being used rather than
+  live-region-based support.
+- Add support for in-process ARIA feature for alternative
+  text for  cell indices
+- Fix bug in live region support causing some information
+  to not be  presented
+- Improve presentation of off-screen content (so that it isn't
+  spoken as if each word is on its own line)
+- Ensure we present newly-focused widget when current
+  widget gets  destroyed
+- Fix presentation of description-term and description-value
+  roles
+- Fix bug causing basic context information to be 

commit seahorse for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package seahorse for openSUSE:Factory 
checked in at 2019-10-17 13:03:43

Comparing /work/SRC/openSUSE:Factory/seahorse (Old)
 and  /work/SRC/openSUSE:Factory/.seahorse.new.2352 (New)


Package is "seahorse"

Thu Oct 17 13:03:43 2019 rev:108 rq:736606 version:3.34

Changes:

--- /work/SRC/openSUSE:Factory/seahorse/seahorse.changes2019-05-22 
10:56:18.758992194 +0200
+++ /work/SRC/openSUSE:Factory/.seahorse.new.2352/seahorse.changes  
2019-10-17 13:03:45.308626402 +0200
@@ -1,0 +2,23 @@
+Tue Oct  1 08:17:25 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34:
+  + gkr: Fix use-after-free in password interaction.
+  + Add OARS Metadata tags.
+  + Cleanup flatpak manifest.
+  + gkr: Fix a build failure due to a GKR GIR breakage.
+  + Depend on meson version >= 0.49.
+  + Fix a crash for some Epiphany passwords.
+  + Add mnemonics.
+  + ssh: Use Posix.Signal.TERM to unbreak building with valac
+<= 0.40.
+  + Enable type-to-search.
+  + pgp: Fix a segfault when syncing GPG keys to an HKP server.
+  + gkr: Update user documentation for keyrings.
+  + Generate manpage from XML file.
+  + Implement GApplication.open() so we can import files from the
+command line.
+  + pgp: Fix build related to GPG(ME) versions.
+- Add docbook-xsl-stylesheets and libxslt-tools BuildRequires and
+  pass manpage=true to meson: Build manpages.
+
+---

Old:

  seahorse-3.32.2.tar.xz

New:

  seahorse-3.34.tar.xz



Other differences:
--
++ seahorse.spec ++
--- /var/tmp/diff_new_pack.AyUcO4/_old  2019-10-17 13:03:45.912624872 +0200
+++ /var/tmp/diff_new_pack.AyUcO4/_new  2019-10-17 13:03:45.916624862 +0200
@@ -17,18 +17,20 @@
 
 
 Name:   seahorse
-Version:3.32.2
+Version:3.34
 Release:0
 Summary:GNOME interface for gnupg
 License:GPL-2.0-or-later AND LGPL-2.1-or-later AND GFDL-1.1-only
 Group:  Productivity/Security
 URL:https://wiki.gnome.org/Apps/Seahorse
-Source0:
https://download.gnome.org/sources/seahorse/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/seahorse/3.34/%{name}-%{version}.tar.xz
 
+BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  fdupes
 BuildRequires:  gpg2
 BuildRequires:  libgpgme-devel
-BuildRequires:  meson
+BuildRequires:  libxslt-tools
+BuildRequires:  meson >= 0.49
 BuildRequires:  openldap2-devel
 BuildRequires:  openssh
 BuildRequires:  pkcs11-helper-devel
@@ -80,6 +82,7 @@
-Dhkp-support=true \
-Dldap-support=true \
-Dkey-sharing=true \
+   -Dmanpage=true \
%{nil}
 %meson_build
 

++ seahorse-3.32.2.tar.xz -> seahorse-3.34.tar.xz ++
 37797 lines of diff (skipped)




commit zenity for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package zenity for openSUSE:Factory checked 
in at 2019-10-17 13:04:22

Comparing /work/SRC/openSUSE:Factory/zenity (Old)
 and  /work/SRC/openSUSE:Factory/.zenity.new.2352 (New)


Package is "zenity"

Thu Oct 17 13:04:22 2019 rev:63 rq:736620 version:3.32.0

Changes:

--- /work/SRC/openSUSE:Factory/zenity/zenity.changes2019-05-03 
22:10:58.815343183 +0200
+++ /work/SRC/openSUSE:Factory/.zenity.new.2352/zenity.changes  2019-10-17 
13:04:24.112527825 +0200
@@ -1,0 +2,6 @@
+Thu Sep 26 12:55:24 UTC 2019 - Bjørn Lie 
+
+- Add zenity-Fix-segfault-on-multiple-lists.patch: src/forms.c: Fix
+  segfault on multiple lists without values.
+
+---

New:

  zenity-Fix-segfault-on-multiple-lists.patch



Other differences:
--
++ zenity.spec ++
--- /var/tmp/diff_new_pack.9n9DNU/_old  2019-10-17 13:04:24.580526620 +0200
+++ /var/tmp/diff_new_pack.9n9DNU/_new  2019-10-17 13:04:24.580526620 +0200
@@ -24,6 +24,8 @@
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Projects/Zenity
 Source0:
https://download.gnome.org/sources/zenity/3.32/%{name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM zenity-Fix-segfault-on-multiple-lists.patch -- 
src/forms.c: Fix segfault on multiple lists without values.
+Patch0: zenity-Fix-segfault-on-multiple-lists.patch
 
 BuildRequires:  fdupes
 BuildRequires:  pkgconfig

++ zenity-Fix-segfault-on-multiple-lists.patch ++
>From cd636315a5ff60567ff6a49ea10f326b69337029 Mon Sep 17 00:00:00 2001
From: quartenium 
Date: Mon, 11 Sep 2017 17:59:11 +0300
Subject: [PATCH] src/forms.c: Fix segfault on multiple lists without values

If was not provided enought list-values for add-list options
then column_types is NULL. Therefore need set it to default
value.
If count of columns values less than count of list values
then set column nubmer to zero.
---
 src/forms.c | 13 -
 1 file changed, 12 insertions(+), 1 deletion(-)

diff --git a/src/forms.c b/src/forms.c
index 4e6fca5..15df718 100644
--- a/src/forms.c
+++ b/src/forms.c
@@ -110,8 +110,15 @@ zenity_forms_create_and_fill_list (
tree_view = gtk_tree_view_new ();
 
if (forms_data->column_values) {
+   int columns_values_count =
+   g_slist_length (forms_data->column_values);
+   int column_number = 0;
+   if (list_number < columns_values_count) {
+   column_number = list_number;
+   }
+
column_values =
-   g_slist_nth_data (forms_data->column_values, 
list_number);
+   g_slist_nth_data (forms_data->column_values, 
column_number);
if (column_values) {
gchar **values = g_strsplit_set (column_values, "|", 
-1);
if (values) {
@@ -130,6 +137,10 @@ zenity_forms_create_and_fill_list (
column_index++;
}
}
+   } else {
+   /* If no values available, add one with string type*/
+   column_types = g_new (GType, n_columns);
+   column_types[0] = G_TYPE_STRING;
}
}
 
-- 
2.22.0




commit python-gobject for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package python-gobject for openSUSE:Factory 
checked in at 2019-10-17 13:03:36

Comparing /work/SRC/openSUSE:Factory/python-gobject (Old)
 and  /work/SRC/openSUSE:Factory/.python-gobject.new.2352 (New)


Package is "python-gobject"

Thu Oct 17 13:03:36 2019 rev:78 rq:736603 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/python-gobject/python-gobject.changes
2019-06-30 10:17:36.859257879 +0200
+++ /work/SRC/openSUSE:Factory/.python-gobject.new.2352/python-gobject.changes  
2019-10-17 13:03:40.316639049 +0200
@@ -1,0 +2,15 @@
+Mon Sep  9 15:37:58 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + No changes since 3.33.1.
+
+---
+Sat Aug 31 09:06:02 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.1:
+  + Make GLib.Variant.unpack a bit less costly.
+  + pygobject: ignore GParameter deprecations.
+  + pygobject-object: fix refcount of floating return values.
+  + pygi-info: remove some dead code.
+
+---

Old:

  pygobject-3.32.2.tar.xz

New:

  pygobject-3.34.0.tar.xz



Other differences:
--
++ python-gobject.spec ++
--- /var/tmp/diff_new_pack.wNfaXE/_old  2019-10-17 13:03:41.064637154 +0200
+++ /var/tmp/diff_new_pack.wNfaXE/_new  2019-10-17 13:03:41.068637144 +0200
@@ -22,13 +22,13 @@
 %global __requires_exclude_from 
^%{python2_sitearch}/gi/__init__.py|%{python3_sitearch}/gi/__init__.py$
 %define _name   pygobject
 Name:   python-gobject
-Version:3.32.2
+Version:3.34.0
 Release:0
 Summary:Python bindings for GObject
 License:LGPL-2.1-or-later
 Group:  Development/Languages/Python
 URL:https://wiki.gnome.org/Projects/PyGObject/
-Source0:
https://download.gnome.org/sources/pygobject/3.32/%{_name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/pygobject/3.34/%{_name}-%{version}.tar.xz
 
 BuildRequires:  %{python_module cairo >= 1.11.1}
 BuildRequires:  %{python_module cairo-devel}

++ pygobject-3.32.2.tar.xz -> pygobject-3.34.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pygobject-3.32.2/.gitlab-ci/Dockerfile 
new/pygobject-3.34.0/.gitlab-ci/Dockerfile
--- old/pygobject-3.32.2/.gitlab-ci/Dockerfile  2019-06-23 15:34:36.0 
+0200
+++ new/pygobject-3.34.0/.gitlab-ci/Dockerfile  2019-09-09 21:31:15.0 
+0200
@@ -39,12 +39,12 @@
 
 RUN curl -L 
https://raw.githubusercontent.com/pyenv/pyenv-installer/master/bin/pyenv-installer
 | bash
 
-RUN pyenv install pypy2.7-7.0.0
-RUN pyenv install pypy3.5-7.0.0
-RUN pyenv install pypy3.6-7.0.0
-RUN pyenv install --debug 2.7.15
-RUN pyenv install 3.5.6
+RUN pyenv install pypy2.7-7.1.0
+RUN pyenv install pypy3.6-7.1.0
+RUN pyenv install --debug 2.7.16
+RUN pyenv install 3.5.7
 RUN pyenv install 3.6.8
-RUN pyenv install --debug 3.7.2
+RUN pyenv install --debug 3.7.3
+RUN pyenv install --debug 3.8-dev
 
 ENV PATH="/usr/lib/ccache:${PATH}"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pygobject-3.32.2/.gitlab-ci/Dockerfile.gtk4 
new/pygobject-3.34.0/.gitlab-ci/Dockerfile.gtk4
--- old/pygobject-3.32.2/.gitlab-ci/Dockerfile.gtk4 2019-06-23 
15:34:36.0 +0200
+++ new/pygobject-3.34.0/.gitlab-ci/Dockerfile.gtk4 2019-06-23 
15:47:14.0 +0200
@@ -1,4 +1,4 @@
-FROM registry.gitlab.gnome.org/gnome/pygobject/main:v10
+FROM registry.gitlab.gnome.org/gnome/pygobject/main:v11
 
 USER root
 
@@ -25,4 +25,4 @@
 && rm -Rf gtk
 
 USER user
-ENV PYENV_VERSION 3.7.2-debug
+ENV PYENV_VERSION 3.7.3-debug
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pygobject-3.32.2/.gitlab-ci/run-docker-gtk4.sh 
new/pygobject-3.34.0/.gitlab-ci/run-docker-gtk4.sh
--- old/pygobject-3.32.2/.gitlab-ci/run-docker-gtk4.sh  2019-06-23 
15:34:36.0 +0200
+++ new/pygobject-3.34.0/.gitlab-ci/run-docker-gtk4.sh  2019-06-23 
15:47:14.0 +0200
@@ -2,7 +2,7 @@
 
 set -e
 
-TAG="registry.gitlab.gnome.org/gnome/pygobject/gtk4:v3"
+TAG="registry.gitlab.gnome.org/gnome/pygobject/gtk4:v4"
 
 sudo docker build --tag "${TAG}" --file "Dockerfile.gtk4" .
 sudo docker run --rm --security-opt label=disable \
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pygobject-3.32.2/.gitlab-ci/run-docker-runtime.sh 
new/pygobject-3.34.0/.gitlab-ci/run-docker-runtime.sh
--- old/pygobject-3.32.2/.gitlab-ci/run-docker-runtime.sh   1970-01-01 
01:00:00.0 +0100
+++ new/pygobject-3.34.0/.gitlab-ci/run-docker-runtime.sh 

commit yelp for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package yelp for openSUSE:Factory checked in 
at 2019-10-17 13:04:14

Comparing /work/SRC/openSUSE:Factory/yelp (Old)
 and  /work/SRC/openSUSE:Factory/.yelp.new.2352 (New)


Package is "yelp"

Thu Oct 17 13:04:14 2019 rev:107 rq:736618 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/yelp/yelp.changes2019-05-10 
09:18:06.836309252 +0200
+++ /work/SRC/openSUSE:Factory/.yelp.new.2352/yelp.changes  2019-10-17 
13:04:20.008538394 +0200
@@ -1,0 +2,14 @@
+Mon Sep  9 14:28:40 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Stable release. No changes since 3.33.92.
+
+---
+Mon Sep  2 11:25:46 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.92:
+  + Allow the application name to be translated.
+  + Enable WebKit back-forward swipe gesture.
+  + Updated translations.
+
+---

Old:

  yelp-3.32.2.tar.xz

New:

  yelp-3.34.0.tar.xz



Other differences:
--
++ yelp.spec ++
--- /var/tmp/diff_new_pack.o5GKWV/_old  2019-10-17 13:04:20.988535870 +0200
+++ /var/tmp/diff_new_pack.o5GKWV/_new  2019-10-17 13:04:20.988535870 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   yelp
-Version:3.32.2
+Version:3.34.0
 Release:0
 Summary:Help Browser for the GNOME Desktop
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Apps/Yelp
-Source0:
https://download.gnome.org/sources/yelp/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/yelp/3.34/%{name}-%{version}.tar.xz
 # PATCH-FEATURE-OPENSUSE yelp-lang-bundle.patch bnc#689979 vu...@opensuse.org 
-- Support help documents shipped in bundles
 Patch1: yelp-lang-bundle.patch
 BuildRequires:  fdupes

++ yelp-3.32.2.tar.xz -> yelp-3.34.0.tar.xz ++
 2332 lines of diff (skipped)




commit totem for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package totem for openSUSE:Factory checked 
in at 2019-10-17 13:04:03

Comparing /work/SRC/openSUSE:Factory/totem (Old)
 and  /work/SRC/openSUSE:Factory/.totem.new.2352 (New)


Package is "totem"

Thu Oct 17 13:04:03 2019 rev:141 rq:736612 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/totem/totem.changes  2019-07-16 
08:28:45.835388363 +0200
+++ /work/SRC/openSUSE:Factory/.totem.new.2352/totem.changes2019-10-17 
13:04:04.852576889 +0200
@@ -1,0 +2,44 @@
+Fri Oct  4 17:48:13 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Fix broken symbolic icon.
+  + Updated translations.
+- Drop totem-fix-symbolic-icon.patch: Fixed upstream.
+
+---
+Mon Sep 30 13:10:04 UTC 2019 - Bjørn Lie 
+
+- Add totem-fix-symbolic-icon.patch: Fix symbolic icon.
+
+---
+Fri Sep  6 17:02:01 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Make introspection non-optional for the plugin system to work.
+  + Updated translations.
+
+---
+Wed Sep  4 16:48:45 UTC 2019 - Bjørn Lie 
+
+- Add totem-revert-vaapi-disable.patch: Revert upstreams disabling
+  of vaapi support, it works fine on openSUSE.
+
+---
+Tue Sep  3 10:32:38 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.90:
+  + Update application icon.
+  + Use title case for the "Open Containing Folder" menu item.
+  + Disable VAAPI support for now, it's too buggy.
+  + Changes in version 3.33.0:
+  + Add "Open containing folder" menu item.
+  + Include "totem" in the desktop keywords.
+  + Make --version command-line option public.
+  + Reduce GSettings writes on startup.
+  + Fix menu sensitivity for OpenSubtitles plugin.
+- Add open-directory plugin.
+  + Remove obsolete LIRC and Brasero plugins.
+- Remove/obsolete -plugin-brasero package: removed upstream.
+- Remove comments related to lirc: plugin removed upstream.
+
+---

Old:

  totem-3.32.1.tar.xz

New:

  totem-3.34.1.tar.xz
  totem-revert-vaapi-disable.patch



Other differences:
--
++ totem.spec ++
--- /var/tmp/diff_new_pack.i2uVer/_old  2019-10-17 13:04:05.536575156 +0200
+++ /var/tmp/diff_new_pack.i2uVer/_new  2019-10-17 13:04:05.540575146 +0200
@@ -18,13 +18,15 @@
 
 %define build_zeitgeist_plugin 0
 Name:   totem
-Version:3.32.1
+Version:3.34.1
 Release:0
 Summary:Movie Player for the GNOME Desktop
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  Productivity/Multimedia/Video/Players
 URL:https://wiki.gnome.org/Apps/Videos
-Source0:
https://download.gnome.org/sources/totem/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/totem/3.34/%{name}-%{version}.tar.xz
+# PATCH-FEATURE-OPENSUSE totem-revert-vaapi-disable.patch -- Revert upstreams 
disabling of vaapi support
+Patch0: totem-revert-vaapi-disable.patch
 
 BuildRequires:  appstream-glib
 BuildRequires:  fdupes
@@ -34,8 +36,6 @@
 BuildRequires:  gstreamer-utils >= 0.11.93
 BuildRequires:  gtk-doc
 BuildRequires:  intltool
-# FIXME meson does not recognise lirc_client
-#BuildRequires:  lirc-devel
 BuildRequires:  meson
 BuildRequires:  pkgconfig
 BuildRequires:  python3-pylint
@@ -75,6 +75,8 @@
 Recommends: gstreamer-plugins-ugly
 Recommends: totem-plugins
 Suggests:   gnome-dvb-daemon
+# totem-plugin-brasero has been removed.
+Obsoletes:  totem-plugin-brasero
 # totem-plugin-upnp has been substituted by a grilo plugin.
 Obsoletes:  totem-plugin-upnp <= %{version}
 # The browser plugins were dropped with totem 3.13.90
@@ -108,18 +110,6 @@
 
 This package includes plugins for Totem, to add advanced features.
 
-%package plugin-brasero
-Summary:Brasero support for the Totem movie player
-Group:  Productivity/Multimedia/Video/Players
-Requires:   %{name} = %{version}
-Requires:   brasero
-Supplements:packageand(%{name}:brasero)
-
-%description plugin-brasero
-Totem is movie player for the GNOME desktop based on GStreamer.
-
-This package includes the Brasero plugin for Totem.
-
 %if %{build_zeitgeist_plugin}
 %package plugin-zeitgeist
 Summary:Zeitgeist support for the Totem movie player
@@ -151,8 +141,6 @@
 translation-update-upstream po totem
 
 %build
-# FIXME once we figure out whats wrong with lirc-devel, add this to meson calls
-#  -Dwith-plugins=all \
 %meson \
-D enable-easy-codec-installation=yes \

commit xdg-user-dirs-gtk for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package xdg-user-dirs-gtk for 
openSUSE:Factory checked in at 2019-10-17 13:04:09

Comparing /work/SRC/openSUSE:Factory/xdg-user-dirs-gtk (Old)
 and  /work/SRC/openSUSE:Factory/.xdg-user-dirs-gtk.new.2352 (New)


Package is "xdg-user-dirs-gtk"

Thu Oct 17 13:04:09 2019 rev:24 rq:736617 version:0.10+13

Changes:

--- /work/SRC/openSUSE:Factory/xdg-user-dirs-gtk/xdg-user-dirs-gtk.changes  
2018-03-14 19:24:19.484552768 +0100
+++ 
/work/SRC/openSUSE:Factory/.xdg-user-dirs-gtk.new.2352/xdg-user-dirs-gtk.changes
2019-10-17 13:04:10.928561496 +0200
@@ -1,0 +2,15 @@
+Thu Oct 03 19:38:07 UTC 2019 - bjorn@gmail.com
+
+- Update to version 0.10+13:
+  + Comment invalid  in DOAP file to pass git pre-receive
+hook.
+  + Make the 'Don't ask again' checkbox work properly.
+  + Updated translations.
+- Switch to git checkout, current master, via source service,
+  explicit commit.
+- Add gnome-common BuildRequires and pass autogen.sh, needed to
+  bootstrap the checkout.
+- Also pass export CFLAGS='-Wno-error=deprecated-declarations'.
+- Use modern macros and tweak Summary to silence rpmlint.
+
+---

Old:

  xdg-user-dirs-gtk-0.10.tar.xz

New:

  _service
  _servicedata
  xdg-user-dirs-gtk-0.10+13.obscpio
  xdg-user-dirs-gtk.obsinfo



Other differences:
--
++ xdg-user-dirs-gtk.spec ++
--- /var/tmp/diff_new_pack.7hQ8HC/_old  2019-10-17 13:04:11.624559733 +0200
+++ /var/tmp/diff_new_pack.7hQ8HC/_new  2019-10-17 13:04:11.624559733 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package xdg-user-dirs-gtk
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,20 +12,22 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   xdg-user-dirs-gtk
-Version:0.10
+Version:0.10+13
 Release:0
-Summary:xdg-user-dir support for Gnome and Gtk+ applications
+Summary:Xdg-user-dir support for Gnome and Gtk+ applications
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:http://download.gnome.org/sources/xdg-user-dirs-gtk
-Source0:
http://download.gnome.org/sources/xdg-user-dirs-gtk/0.10/%{name}-%{version}.tar.xz
+Source0:%{name}-%{version}.tar.xz
 # PATCH-FIX-UPSTREAM xdg-user-dirs-gtk-XFCE-LXDE-autostart.patch fdo#33107 
g...@opensuse.org -- Start xdg-user-dirs-gtk in Xfce sessions as well
 Patch1: %{name}-XFCE-autostart.patch
+
+BuildRequires:  gnome-common
 BuildRequires:  gtk3-devel
 BuildRequires:  intltool
 BuildRequires:  translation-update-upstream
@@ -42,16 +44,17 @@
 %lang_package
 
 %prep
-%setup -q
-%patch1 -p1
+%autosetup -p1
 translation-update-upstream
 
 %build
+NOCONFIGURE=1 ./autogen.sh
+export CFLAGS='-Wno-error=deprecated-declarations'
 %configure
-make %{?_smp_mflags}
+%make_build
 
 %install
-%makeinstall
+%make_install
 %suse_update_desktop_file user-dirs-update-gtk
 %find_lang %{name}
 

++ _service ++

  
https://gitlab.gnome.org/GNOME/xdg-user-dirs-gtk.git
git
de85967a
@PARENT_TAG@+@TAG_OFFSET@
enable
  
  
  
*.tar
xz
  
  

++ _servicedata ++


https://gitlab.gnome.org/GNOME/xdg-user-dirs-gtk.git
  de85967aff2e52ac1ff42c44e84a0478b683fcf3++
 xdg-user-dirs-gtk.obsinfo ++
name: xdg-user-dirs-gtk
version: 0.10+13
mtime: 1565615804
commit: de85967aff2e52ac1ff42c44e84a0478b683fcf3




commit python-atspi for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package python-atspi for openSUSE:Factory 
checked in at 2019-10-17 13:03:30

Comparing /work/SRC/openSUSE:Factory/python-atspi (Old)
 and  /work/SRC/openSUSE:Factory/.python-atspi.new.2352 (New)


Package is "python-atspi"

Thu Oct 17 13:03:30 2019 rev:61 rq:736602 version:2.34.0

Changes:

--- /work/SRC/openSUSE:Factory/python-atspi/python-atspi.changes
2019-05-03 22:17:39.748133033 +0200
+++ /work/SRC/openSUSE:Factory/.python-atspi.new.2352/python-atspi.changes  
2019-10-17 13:03:32.924657776 +0200
@@ -1,0 +2,32 @@
+Mon Sep  9 15:15:54 CDT 2019 - mgo...@suse.com
+
+- Update to version 2.34.0:
+  + Updated doap, and include it in the tarball.
+
+---
+Mon Sep  2 18:16:45 CDT 2019 - mgo...@suse.com
+
+- Update to version 2.33.92:
+  + Several test fixes.
+  + Add license header on some test files.
+
+---
+Fri Aug 30 09:41:41 CDT 2019 - mgo...@suse.com
+
+- Update to version 2.33.90:
+  + Fix typo in get_imageLocale.
+  + event.str(): show event sender.
+  + Remove wrapper for atspi_text_notify_reading_position,
+as the function has been removed from at-spi2-core.
+  + events: replace object:text:reading-position with
+screen-reader:region-changed.
+  + Add wrapper for atspi_set_reference_window.
+- Changes from version 2.33.2:
+  + Add support for ROLE_CONTENT_DELETION and
+ROLE_CONTENT_INSERTION.
+- Changes from version 2.33.1:
+  + Add accessibleId property.
+  + Add text.notifyReadingPosition.
+  + Fix print usage in example, for python 3 compatibility.
+
+---

Old:

  pyatspi-2.32.1.tar.xz

New:

  pyatspi-2.34.0.tar.xz



Other differences:
--
++ python-atspi.spec ++
--- /var/tmp/diff_new_pack.VtgvZK/_old  2019-10-17 13:03:33.488656347 +0200
+++ /var/tmp/diff_new_pack.VtgvZK/_new  2019-10-17 13:03:33.492656337 +0200
@@ -19,13 +19,13 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define _name   pyatspi
 Name:   python-atspi
-Version:2.32.1
+Version:2.34.0
 Release:0
 Summary:Python bindings for the Assistive Technology Service Provider 
Interface
 License:LGPL-2.0-only
 Group:  Development/Libraries/Python
 URL:http://www.gnome.org/
-Source0:
https://download.gnome.org/sources/pyatspi/2.32/%{_name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/pyatspi/2.34/%{_name}-%{version}.tar.xz
 
 BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module gobject >= 2.90.1}

++ pyatspi-2.32.1.tar.xz -> pyatspi-2.34.0.tar.xz ++
 2167 lines of diff (skipped)




commit polari for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package polari for openSUSE:Factory checked 
in at 2019-10-17 13:03:22

Comparing /work/SRC/openSUSE:Factory/polari (Old)
 and  /work/SRC/openSUSE:Factory/.polari.new.2352 (New)


Package is "polari"

Thu Oct 17 13:03:22 2019 rev:36 rq:736600 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/polari/polari.changes2019-06-02 
15:13:16.366159037 +0200
+++ /work/SRC/openSUSE:Factory/.polari.new.2352/polari.changes  2019-10-17 
13:03:26.100675064 +0200
@@ -1,0 +2,29 @@
+Tue Sep 10 13:51:20 CST 2019 - qk...@suse.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Sat Sep  7 22:03:58 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.33.92:
+  + Support profiling with sysprof.
+  + Improve network reachability check.
+  + Misc. bug fixes and cleanups: glgo#GNOME/polari!125,
+glgo#GNOME/polari!124, glgo#GNOME/polari!126,
+glgo#GNOME/polari!127, glgo#GNOME/polari!128,
+glgo#GNOME/polari!129, glgo#GNOME/polari!131,
+glgo#GNOME/polari!130, glgo#GNOME/polari!133.
+- Drop unneded hicolor-icon-theme BuildRequires.
+
+---
+Tue Sep  3 14:55:38 CST 2019 - yfji...@suse.com
+
+- Update to version 3.33.2:
+  + Display error message on failure to join room.
+  + Polish the no-results placeholder in userlist.
+  + Allow user-list to take up all available height.
+  + Show a clear indication when offline.
+  + Add a --quit command line option.
+
+---

Old:

  polari-3.32.2.tar.xz

New:

  polari-3.34.0.tar.xz



Other differences:
--
++ polari.spec ++
--- /var/tmp/diff_new_pack.bAxyPx/_old  2019-10-17 13:03:26.868673118 +0200
+++ /var/tmp/diff_new_pack.bAxyPx/_new  2019-10-17 13:03:26.872673108 +0200
@@ -18,16 +18,16 @@
 
 
 Name:   polari
-Version:3.32.2
+Version:3.34.0
 Release:0
 Summary:An IRC Client for GNOME
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  Productivity/Networking/IRC
 URL:https://wiki.gnome.org/Apps/Polari
-Source0:
https://download.gnome.org/sources/polari/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/polari/3.34/%{name}-%{version}.tar.xz
 Source99:   polari-rpmlintrc
+
 BuildRequires:  gjs >= 1.45.0
-BuildRequires:  hicolor-icon-theme
 BuildRequires:  meson >= 0.43.0
 BuildRequires:  mozjs60
 BuildRequires:  pkgconfig

++ polari-3.32.2.tar.xz -> polari-3.34.0.tar.xz ++
 31964 lines of diff (skipped)




commit template-glib for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package template-glib for openSUSE:Factory 
checked in at 2019-10-17 13:03:55

Comparing /work/SRC/openSUSE:Factory/template-glib (Old)
 and  /work/SRC/openSUSE:Factory/.template-glib.new.2352 (New)


Package is "template-glib"

Thu Oct 17 13:03:55 2019 rev:8 rq:736611 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/template-glib/template-glib.changes  
2019-04-01 12:30:26.853747229 +0200
+++ /work/SRC/openSUSE:Factory/.template-glib.new.2352/template-glib.changes
2019-10-17 13:03:56.692597562 +0200
@@ -1,0 +2,14 @@
+Tue Sep 10 06:08:00 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + No changes since 3.33.92.
+
+---
+Fri Sep  6 12:03:18 CST 2019 - qk...@suse.com
+
+- Update to version 3.33.92:
+  + Updated meson build requirement.
+  + Build fixes for macOS.
+  + Translation updates.
+
+---

Old:

  template-glib-3.32.0.tar.xz

New:

  template-glib-3.34.0.tar.xz



Other differences:
--
++ template-glib.spec ++
--- /var/tmp/diff_new_pack.5fmTr0/_old  2019-10-17 13:03:58.052594116 +0200
+++ /var/tmp/diff_new_pack.5fmTr0/_new  2019-10-17 13:03:58.052594116 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   template-glib
-Version:3.32.0
+Version:3.34.0
 Release:0
 Summary:Library for generating text based on a template and user 
defined state
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/GNOME
 Url:https://git.gnome.org/browse/template-glib/
-Source0:
https://download.gnome.org/sources/template-glib/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/template-glib/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  bison
 BuildRequires:  flex

++ template-glib-3.32.0.tar.xz -> template-glib-3.34.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/template-glib-3.32.0/NEWS 
new/template-glib-3.34.0/NEWS
--- old/template-glib-3.32.0/NEWS   2019-03-13 08:17:06.0 +0100
+++ new/template-glib-3.34.0/NEWS   2019-09-10 02:55:02.0 +0200
@@ -1,4 +1,20 @@
 ==
+Version 3.34.0
+==
+
+No changes since 3.33.92.
+
+===
+Version 3.33.92
+===
+
+Changes in this release:
+
+ • Updated meson build requirement
+ • Build fixes for macOS
+ • Translation updates
+
+==
 Version 3.32.0
 ==
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/template-glib-3.32.0/meson.build 
new/template-glib-3.34.0/meson.build
--- old/template-glib-3.32.0/meson.build2019-03-13 08:17:06.0 
+0100
+++ new/template-glib-3.34.0/meson.build2019-09-10 02:55:02.0 
+0200
@@ -1,7 +1,7 @@
 project('template-glib', 'c',
-  version: '3.32.0',
+  version: '3.34.0',
   license: 'LGPLv2.1+',
-meson_version: '>= 0.40.1',
+meson_version: '>= 0.50.0',
   default_options: [ 'warning_level=1', 'buildtype=debugoptimized', 
'c_std=gnu11' ],
 )
 
@@ -26,6 +26,8 @@
 revision = template_glib_interface_age
 libversion = '@0@.@1@.@2@'.format(soversion, current, revision)
 
+darwin_versions = [current + 1, '@0@.@1@'.format(current + 1, revision)]
+
 config_h = configuration_data()
 config_h.set_quoted('GETTEXT_PACKAGE', 'libtemplate_glib')
 config_h.set_quoted('LOCALEDIR', join_paths(get_option('prefix'), 
get_option('localedir')))
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/template-glib-3.32.0/po/LINGUAS 
new/template-glib-3.34.0/po/LINGUAS
--- old/template-glib-3.32.0/po/LINGUAS 2019-03-13 08:17:06.0 +0100
+++ new/template-glib-3.34.0/po/LINGUAS 2019-09-10 02:55:02.0 +0200
@@ -4,6 +4,7 @@
 da
 de
 el
+en_GB
 es
 fur
 hu
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/template-glib-3.32.0/po/en_GB.po 
new/template-glib-3.34.0/po/en_GB.po
--- old/template-glib-3.32.0/po/en_GB.po1970-01-01 01:00:00.0 
+0100
+++ new/template-glib-3.34.0/po/en_GB.po2019-09-10 02:55:02.0 
+0200
@@ -0,0 +1,39 @@
+# British English translation for template-glib.
+# Copyright (C) 2019 template-glib's COPYRIGHT HOLDER
+# This file is distributed under the same license as the template-glib package.
+# Zander Brown , 2019.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: template-glib master\n"
+"Report-Msgid-Bugs-To: https://gitlab.gnome.org/GNOME/template-glib/issues\n;
+"POT-Creation-Date: 2019-03-13 18:34+\n"
+"PO-Revision-Date: 

commit system-config-printer for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package system-config-printer for 
openSUSE:Factory checked in at 2019-10-17 13:03:48

Comparing /work/SRC/openSUSE:Factory/system-config-printer (Old)
 and  /work/SRC/openSUSE:Factory/.system-config-printer.new.2352 (New)


Package is "system-config-printer"

Thu Oct 17 13:03:48 2019 rev:94 rq:736610 version:1.5.7

Changes:

--- 
/work/SRC/openSUSE:Factory/system-config-printer/system-config-printer.changes  
2019-06-24 21:46:04.495769042 +0200
+++ 
/work/SRC/openSUSE:Factory/.system-config-printer.new.2352/system-config-printer.changes
2019-10-17 13:03:50.668612823 +0200
@@ -1,0 +2,6 @@
+Sun Sep  8 08:50:01 UTC 2019 - Bjørn Lie 
+
+- Fix printer icon location again, needed due to changes in
+  Adwaita. Now back to old location.
+
+---



Other differences:
--
++ system-config-printer.spec ++
--- /var/tmp/diff_new_pack.xpOsiy/_old  2019-10-17 13:03:51.324611161 +0200
+++ /var/tmp/diff_new_pack.xpOsiy/_new  2019-10-17 13:03:51.336611131 +0200
@@ -60,11 +60,11 @@
 BuildRequires:  pkgconfig
 BuildRequires:  python3-devel
 BuildRequires:  python3-lxml
-BuildRequires:  pkgconfig(systemd)
 BuildRequires:  update-desktop-files
 BuildRequires:  xmlto
 BuildRequires:  pkgconfig(libudev) >= 172
 BuildRequires:  pkgconfig(libusb-1.0)
+BuildRequires:  pkgconfig(systemd)
 BuildRequires:  pkgconfig(udev)
 Requires:   %{name}-common = %{version}
 Requires:   python3-cups
@@ -179,9 +179,9 @@
 %install
 %make_install udevrulesdir=%{_prefix}/lib/udev/rules.d 
udevhelperdir=%{_prefix}/lib/udev
 for size in 8x8 16x16 22x22 24x24 32x32 48x48 256x256; do
-   if test -f %{_datadir}/icons/%{_iconlocation}/$size/legacy/printer.png; 
then
+   if test -f 
%{_datadir}/icons/%{_iconlocation}/$size/devices/printer.png; then
mkdir -p %{buildroot}/%{_datadir}/icons/hicolor/$size/apps
-   cp -a 
%{_datadir}/icons/%{_iconlocation}/$size/legacy/printer.png 
%{buildroot}/%{_datadir}/icons/hicolor/$size/apps/%{name}.png
+   cp -a 
%{_datadir}/icons/%{_iconlocation}/$size/devices/printer.png 
%{buildroot}/%{_datadir}/icons/hicolor/$size/apps/%{name}.png
fi
 done
 %suse_update_desktop_file print-applet






commit lightsoff for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package lightsoff for openSUSE:Factory 
checked in at 2019-10-17 13:03:00

Comparing /work/SRC/openSUSE:Factory/lightsoff (Old)
 and  /work/SRC/openSUSE:Factory/.lightsoff.new.2352 (New)


Package is "lightsoff"

Thu Oct 17 13:03:00 2019 rev:25 rq:736594 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/lightsoff/lightsoff.changes  2019-04-01 
12:31:59.197775961 +0200
+++ /work/SRC/openSUSE:Factory/.lightsoff.new.2352/lightsoff.changes
2019-10-17 13:03:01.796736636 +0200
@@ -1,0 +2,12 @@
+Tue Sep 10 18:12:14 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Wed Sep  4 14:51:46 CEST 2019 - dims...@opensuse.org
+
+- Update to version 3.33.92:
+  + Updated translations.
+
+---

Old:

  lightsoff-3.32.0.tar.xz

New:

  lightsoff-3.34.0.tar.xz



Other differences:
--
++ lightsoff.spec ++
--- /var/tmp/diff_new_pack.F6XOVj/_old  2019-10-17 13:03:02.564734690 +0200
+++ /var/tmp/diff_new_pack.F6XOVj/_new  2019-10-17 13:03:02.576734659 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   lightsoff
-Version:3.32.0
+Version:3.34.0
 Release:0
 Summary:Lights Out Game for GNOME
 License:GPL-2.0-or-later
 Group:  Amusements/Games/Board/Other
 URL:https://wiki.gnome.org/Apps/Lightsoff
-Source0:
https://download.gnome.org/sources/lightsoff/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/lightsoff/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 BuildRequires:  gettext >= 0.19.8

++ lightsoff-3.32.0.tar.xz -> lightsoff-3.34.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lightsoff-3.32.0/NEWS new/lightsoff-3.34.0/NEWS
--- old/lightsoff-3.32.0/NEWS   2019-03-11 18:18:38.0 +0100
+++ new/lightsoff-3.34.0/NEWS   2019-09-09 21:05:17.0 +0200
@@ -1,3 +1,13 @@
+Lights Off 3.34.0
+==
+
+* Updated translations
+
+Lights Off 3.33.92
+==
+
+* Updated translations
+
 Lights Off 3.32.0
 ==
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/lightsoff-3.32.0/data/org.gnome.LightsOff.appdata.xml.in 
new/lightsoff-3.34.0/data/org.gnome.LightsOff.appdata.xml.in
--- old/lightsoff-3.32.0/data/org.gnome.LightsOff.appdata.xml.in
2019-03-11 18:18:38.0 +0100
+++ new/lightsoff-3.34.0/data/org.gnome.LightsOff.appdata.xml.in
2019-09-09 21:05:17.0 +0200
@@ -64,6 +64,22 @@
 none
   
   
+
+  
+Overview of changes in lightsoff 3.34.0
+
+  Updated translations
+
+  
+
+
+  
+Overview of changes in lightsoff 3.33.92
+
+  Updated translations
+
+  
+
 
   
 Overview of changes in lightsoff 3.32.0
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lightsoff-3.32.0/meson.build 
new/lightsoff-3.34.0/meson.build
--- old/lightsoff-3.32.0/meson.build2019-03-11 18:18:38.0 +0100
+++ new/lightsoff-3.34.0/meson.build2019-09-09 21:05:17.0 +0200
@@ -1,5 +1,5 @@
 project('lightsoff', ['c','vala'],
-   version: '3.32.0',
+   version: '3.34.0',
meson_version: '>= 0.43.0',
license: 'GPLv2+'
 )
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lightsoff-3.32.0/po/da.po 
new/lightsoff-3.34.0/po/da.po
--- old/lightsoff-3.32.0/po/da.po   2019-03-11 18:18:38.0 +0100
+++ new/lightsoff-3.34.0/po/da.po   2019-09-09 21:05:17.0 +0200
@@ -14,7 +14,7 @@
 msgstr ""
 "Project-Id-Version: gnome-games\n"
 "Report-Msgid-Bugs-To: https://gitlab.gnome.org/GNOME/lightsoff/issues\n;
-"POT-Creation-Date: 2019-01-19 20:15+\n"
+"POT-Creation-Date: 2019-03-26 18:32+\n"
 "PO-Revision-Date: 2019-02-13 00:21+0100\n"
 "Last-Translator: Ask Hjorth Larsen \n"
 "Language-Team: Danish \n"
@@ -81,11 +81,6 @@
 msgid "game;logic;board;tiles;adjacent;puzzle;"
 msgstr "spil;logik;bræt;brikker;tilstødende;omgivende;hjernebryder;"
 
-#. Translators: Do NOT translate or transliterate this text (this is an icon 
file name)!
-#: data/org.gnome.LightsOff.desktop.in:8
-msgid "org.gnome.LightsOff"
-msgstr "org.gnome.LightsOff"
-
 #: data/org.gnome.LightsOff.gschema.xml:6
 msgid "The current level"
 msgstr "Den nuværende bane"
@@ -104,12 +99,14 @@
 "Ole Laursen\n"
 "Ask Hjorth Larsen\n"
 "\n"
-"Dansk-gruppen \n"
-"Mere info: 

commit nautilus for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package nautilus for openSUSE:Factory 
checked in at 2019-10-17 13:03:05

Comparing /work/SRC/openSUSE:Factory/nautilus (Old)
 and  /work/SRC/openSUSE:Factory/.nautilus.new.2352 (New)


Package is "nautilus"

Thu Oct 17 13:03:05 2019 rev:175 rq:736596 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/nautilus/nautilus.changes2019-08-09 
16:51:00.945501666 +0200
+++ /work/SRC/openSUSE:Factory/.nautilus.new.2352/nautilus.changes  
2019-10-17 13:03:08.232720331 +0200
@@ -1,0 +2,31 @@
+Mon Oct  7 11:55:59 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Fix criticals and crashes when closing properties dialog.
+  + Fix opening file previews in Sushi.
+  + Fix criticals after trashing file.
+- Drop nautilus-fix-criticals-move-file-trash.patch: Fixed
+  upstream.
+
+---
+Thu Sep 26 12:39:50 UTC 2019 - Bjørn Lie 
+
+- Add nautilus-fix-criticals-move-file-trash.patch: window: Fix
+  criticals when moving file to trash.
+
+---
+Tue Sep 10 21:00:05 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + Fix emblems not appearing on files in some cases.
+  + Respect recursivity setting in shell search provider.
+  + Make recursive permission changes apply only to children.
+
+---
+Tue Sep  3 11:35:21 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.90:
+  + Add tooltip to view menu button
+  + Show warning in read-only directories when pasting files.
+
+---

Old:

  nautilus-3.32.3.tar.xz

New:

  nautilus-3.34.1.tar.xz



Other differences:
--
++ nautilus.spec ++
--- /var/tmp/diff_new_pack.jgyOen/_old  2019-10-17 13:03:09.344717514 +0200
+++ /var/tmp/diff_new_pack.jgyOen/_new  2019-10-17 13:03:09.344717514 +0200
@@ -17,14 +17,14 @@
 
 
 Name:   nautilus
-Version:3.32.3
+Version:3.34.1
 Release:0
 Summary:File Manager for the GNOME Desktop
 License:GPL-3.0-or-later AND LGPL-2.1-or-later
 Group:  Productivity/File utilities
 URL:https://wiki.gnome.org/Apps/Nautilus
 
-Source0:
https://download.gnome.org/sources/nautilus/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/nautilus/3.34/%{name}-%{version}.tar.xz
 # fate#308344 bgo#602147
 Source1:mount-archive.desktop
 Source2:set_trusted.desktop
@@ -113,7 +113,7 @@
 %lang_package
 
 %prep
-%setup -q
+%autosetup -p1
 translation-update-upstream
 
 %build

++ nautilus-3.32.3.tar.xz -> nautilus-3.34.1.tar.xz ++
 123400 lines of diff (skipped)




commit libdazzle for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libdazzle for openSUSE:Factory 
checked in at 2019-10-17 13:02:24

Comparing /work/SRC/openSUSE:Factory/libdazzle (Old)
 and  /work/SRC/openSUSE:Factory/.libdazzle.new.2352 (New)


Package is "libdazzle"

Thu Oct 17 13:02:24 2019 rev:17 rq:736587 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/libdazzle/libdazzle.changes  2019-07-31 
14:13:24.538907839 +0200
+++ /work/SRC/openSUSE:Factory/.libdazzle.new.2352/libdazzle.changes
2019-10-17 13:02:25.596828345 +0200
@@ -1,0 +2,53 @@
+Sat Oct  5 08:14:53 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + panel: hide handles when animations are disabled.
+- Drop libdazzle-remove-counters-from-docs.patch: Fixed upstream.
+
+---
+Mon Sep 16 10:26:15 UTC 2019 - Bjørn Lie 
+
+- Add libdazzle-remove-counters-from-docs.patch: Fix build with
+  gtk-doc 1.32 or newer.
+- Rename main package to dazzle-list-counters, it is a more
+  descriptive name of what the package provide and added bonus it
+  will silence rpmlint.
+
+---
+Tue Sep 10 05:58:28 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Set NO_AT_BRIDGE=1 in automated tests.
+  + Allow Escape to clear/reset GtkSearchEntry based widgets.
+
+---
+Thu Aug 15 11:38:18 CEST 2019 - bjorn@gmail.com
+
+- Update to version 3.33.90:
+  + Add helper for shortcuts to remove accels.
+  + Tweak styling for Adwaita.
+- Changes from version 3.33.4:
+  + Work around recent changes in GTK action muxing.
+  + Autoptr additions.
+  + Improve fuzzy text matches.
+  + Various fixes for alternative compilers.
+- Changes from version 3.33.3:
+  + libdazzle provides a backported GtkEventControllerMotion when
+compiled against GTK versions <= 3.22. This means that
+libdazzle now effectively supports 3.22 in addition to 3.24.
+  + libdazzle has been backported to support GLib 2.50 so that it
+can be used on older platforms.
+  + Various API additions to simply use from bindings.
+  + A new compact mode for DzlSuggestionEntry.
+  + Improvements to shortcut activation.
+  + The fuzzy highlighter has been improved to work around some
+embedded markup.
+  + Correctness fixes.
+  + The panel now has support for "needs-attention".
+- Changes from version 3.33.1:
+  + Do not reset child positions on DzlMultiPaned::add.
+  + Treat . as a break character in DzlPatternSpec.
+  + A new DzlSuggestionButton widget was added that transitions
+from a GtkButton to a DzlSuggestionEntry.
+
+---

Old:

  libdazzle-3.32.3.tar.xz

New:

  libdazzle-3.34.1.tar.xz



Other differences:
--
++ libdazzle.spec ++
--- /var/tmp/diff_new_pack.RaVV4r/_old  2019-10-17 13:02:26.276826622 +0200
+++ /var/tmp/diff_new_pack.RaVV4r/_new  2019-10-17 13:02:26.280826612 +0200
@@ -17,16 +17,16 @@
 
 
 Name:   libdazzle
-Version:3.32.3
+Version:3.34.1
 Release:0
 Summary:Collection of fancy features for GLib and Gtk+
 License:GPL-3.0-or-later AND LGPL-2.1-or-later
 Group:  Development/Tools/Other
 URL:https://gitlab.gnome.org/GNOME/libdazzle
-Source0:
https://download.gnome.org/sources/libdazzle/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/libdazzle/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  gtk-doc
-BuildRequires:  meson
+BuildRequires:  meson >= 0.49.0
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(gio-2.0) >= 2.55.0
 BuildRequires:  pkgconfig(glib-2.0)
@@ -42,6 +42,14 @@
 wildly out of scope for those libraries. In other cases, the design
 isn't quite generic enough to work for everyone.
 
+%package -n dazzle-list-counters
+Summary:Collection of fancy features for GLib and Gtk+
+Group:  Development/Tools/Other
+
+%description -n dazzle-list-counters
+This package provides the dazzle-list-counters binary.
+
+
 %package -n libdazzle-1_0-0
 Summary:Collection of fancy features for GLib and Gtk+ -- Library file
 Group:  System/Libraries
@@ -71,7 +79,8 @@
 %packagedevel
 Summary:Collection of fancy features for GLib and Gtk+ -- Development 
Files
 Group:  Development/Tools/Other
-Requires:   %{name} = %{version}
+Requires:   dazzle-list-counters = %{version}
+Requires:   libdazzle-1_0-0 = %{version}
 Requires:   typelib-1_0-libdazzle-1_0 = %{version}
 
 %descriptiondevel
@@ -108,7 +117,7 @@
 %post -n libdazzle-1_0-0 -p /sbin/ldconfig
 %postun -n 

commit libgweather for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libgweather for openSUSE:Factory 
checked in at 2019-10-17 13:02:32

Comparing /work/SRC/openSUSE:Factory/libgweather (Old)
 and  /work/SRC/openSUSE:Factory/.libgweather.new.2352 (New)


Package is "libgweather"

Thu Oct 17 13:02:32 2019 rev:101 rq:736588 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/libgweather/libgweather.changes  2019-07-08 
15:04:38.598862805 +0200
+++ /work/SRC/openSUSE:Factory/.libgweather.new.2352/libgweather.changes
2019-10-17 13:02:37.648797812 +0200
@@ -1,0 +2,26 @@
+Tue Oct  8 10:04:54 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Thu Sep  5 09:22:01 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.92:
+  + This version fixes a bug when using the yr.no and NOAA weather
+services together failing in some circumstances, and also fix
+the iwin service.
+- Now requires meson >= 0.50.0.
+
+---
+Fri Aug 30 21:11:32 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.0:
+  + This version of the library bumps the soname after an ABI break
+in 3.28.0 that went unnoticed. If you see strange crashes,
+make sure to bump the required version of libgweather to 3.28.0
+or newer.
+- Update package name for the API version bump.
+- Up meson requirement to 0.48.0 and glib requirement to 2.44.0.
+
+---

Old:

  libgweather-3.32.2.tar.xz

New:

  libgweather-3.34.0.tar.xz



Other differences:
--
++ libgweather.spec ++
--- /var/tmp/diff_new_pack.WC9qIO/_old  2019-10-17 13:02:38.296796170 +0200
+++ /var/tmp/diff_new_pack.WC9qIO/_new  2019-10-17 13:02:38.300796160 +0200
@@ -17,22 +17,22 @@
 
 
 Name:   libgweather
-Version:3.32.2
+Version:3.34.0
 Release:0
 Summary:Library to get online weather information
 License:GPL-2.0-or-later
 Group:  Development/Libraries/GNOME
 URL:https://wiki.gnome.org/Projects/LibGWeather
-Source0:
https://download.gnome.org/sources/libgweather/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/libgweather/3.34/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 
 BuildRequires:  gobject-introspection-devel
 BuildRequires:  gtk-doc
 BuildRequires:  intltool
-BuildRequires:  meson >= 0.43.0
+BuildRequires:  meson >= 0.50.0
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(geocode-glib-1.0)
-BuildRequires:  pkgconfig(gio-2.0) >= 2.35.1
+BuildRequires:  pkgconfig(gio-2.0) >= 2.44.0
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.13.5
 BuildRequires:  pkgconfig(libsoup-2.4) >= 2.44.0
 BuildRequires:  pkgconfig(libxml-2.0) >= 2.6.0
@@ -44,7 +44,7 @@
 %package -n gweather-data
 Summary:Auxiliary schema data for libgweather
 Group:  Development/Libraries/GNOME
-Requires:   libgweather-3-15 = %{version}
+Requires:   libgweather-3-16 = %{version}
 Recommends: %{name}-lang
 Provides:   %{name} = %{version}
 Obsoletes:  %{name} < %{version}
@@ -59,19 +59,19 @@
 %package devel
 Summary:Development files for libgweather, a weather info retrieval 
library
 Group:  Development/Libraries/GNOME
-Requires:   libgweather-3-15 = %{version}
+Requires:   libgweather-3-16 = %{version}
 Requires:   typelib-1_0-GWeather-3_0 = %{version}
 
 %description devel
 This is a library to download weather information from online sources.
 This package provides the development files.
 
-%package -n libgweather-3-15
+%package -n libgweather-3-16
 Summary:Library to get online weather information
 Group:  Development/Libraries/GNOME
 Requires:   gweather-data >= %{version}
 
-%description -n libgweather-3-15
+%description -n libgweather-3-16
 This is a library to download weather information from online sources.
 
 %package -n typelib-1_0-GWeather-3_0
@@ -103,15 +103,15 @@
 %find_lang libgweather-3.0 %{?no_lang_C}
 %find_lang libgweather-locations libgweather-3.0.lang %{?no_lang_C}
 
-%post -n libgweather-3-15 -p /sbin/ldconfig
-%postun -n libgweather-3-15 -p /sbin/ldconfig
+%post -n libgweather-3-16 -p /sbin/ldconfig
+%postun -n libgweather-3-16 -p /sbin/ldconfig
 
 %files -n gweather-data
 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.enums.xml
 %{_datadir}/glib-2.0/schemas/org.gnome.GWeather.gschema.xml
 %{_datadir}/libgweather/
 
-%files -n libgweather-3-15
+%files -n libgweather-3-16
 %license COPYING
 %{_libdir}/*.so.*
 

++ baselibs.conf ++
--- /var/tmp/diff_new_pack.WC9qIO/_old  2019-10-17 

commit libpeas for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libpeas for openSUSE:Factory checked 
in at 2019-10-17 13:02:44

Comparing /work/SRC/openSUSE:Factory/libpeas (Old)
 and  /work/SRC/openSUSE:Factory/.libpeas.new.2352 (New)


Package is "libpeas"

Thu Oct 17 13:02:44 2019 rev:39 rq:736590 version:1.24.0

Changes:

--- /work/SRC/openSUSE:Factory/libpeas/libpeas.changes  2019-09-02 
13:20:51.105361626 +0200
+++ /work/SRC/openSUSE:Factory/.libpeas.new.2352/libpeas.changes
2019-10-17 13:02:47.888771870 +0200
@@ -1,0 +2,46 @@
+Fri Oct  4 13:20:19 UTC 2019 - Michael Gorse 
+
+- Require gettext, rather than gettext-runtime-mini. 
+
+---
+Tue Sep 10 05:23:41 CDT 2019 - mgo...@suse.com
+
+- Update to version 1.24.0:
+  + Setup troubleshooting environment when running automated tests.
+  + Translation updates.
+
+---
+Thu Sep  5 09:10:50 CDT 2019 - mgo...@suse.com
+
+- Update to version 1.23.92:
+  + Fix soname usage to match 1.22.x.
+  + Fix typo in deprecation ignores.
+  + Fix gtk_menu_popup() deprecations.
+  + Fix meson build warning.
+  + Translation updates.
+- Soname is 1.0-0 again.
+- Reinstate demo package; it is being installed again.
+
+---
+Sat Aug 31 09:55:53 CDT 2019 - mgo...@suse.com
+
+- Update to version 1.23.90.1:
+  + Ensure that programs linking against libpeas-1.0 also link
+against gobject-introspection-1.0.
+  + Changes in version 1.23.90:
+  + Port to meson build system, autotools has been removed.
+  + Support for python3.8 in the python3 loader.
+  + Reduce warning impact of GParameter deprecations on API
+consumers.
+  + Fix a number of deprecations in internal API.
+  + Remove use of intltool in favor of gettext.
+  + Add versioning macros and hide non-public symbols.
+  + Translation updates.
+- Switch to meson.
+- Drop intltool from BuildRequires; require gettext-runtime-mini.
+- Pass libpeas-1.0 to %find_lang.
+- Python 2 loader is now named libpython2loader.so.
+- Update package names: soname is now 1_0-1.
+- Remove demo package: no longer installed.
+
+---

Old:

  libpeas-1.22.0.tar.xz

New:

  libpeas-1.24.0.tar.xz



Other differences:
--
++ libpeas.spec ++
--- /var/tmp/diff_new_pack.2DTN3Q/_old  2019-10-17 13:02:48.604770057 +0200
+++ /var/tmp/diff_new_pack.2DTN3Q/_new  2019-10-17 13:02:48.608770046 +0200
@@ -20,17 +20,17 @@
 %bcond_without python2
 %bcond_without python3
 Name:   libpeas
-Version:1.22.0
+Version:1.24.0
 Release:0
 Summary:GObject-based Plugin Engine
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/GNOME
 URL:https://wiki.gnome.org/Projects/Libpeas
 # Source based on git _service
-Source: %{name}-%{version}.tar.xz
+Source: 
https://download.gnome.org/sources/libpeas/1.24/%{name}-%{version}.tar.xz
 #Source: 
http://download.gnome.org/sources/libpeas/1.20/%%{name}-%%{version}.tar.xz
-BuildRequires:  gnome-common
-BuildRequires:  intltool
+BuildRequires:  gettext
+BuildRequires:  meson >= 0.49.0
 BuildRequires:  pkgconfig
 BuildRequires:  translation-update-upstream
 BuildRequires:  pkgconfig(gio-2.0) >= 2.32.0
@@ -172,23 +172,24 @@
 
 %prep
 %setup -q
-translation-update-upstream
+translation-update-upstream po %{name}
 
 %build
-NOCONFIGURE=1 ./autogen.sh
-%configure \
---enable-glade-catalog \
---enable-gtk-doc \
-%if %{with lua51}
---enable-lua5.1 \
+%meson \
+   -Dgtk_doc=true \
+%if !%{with lua51}
+   -Dlua51=false \
+%endif
+%if %{with python2}
+   -Dpython2=true \
 %endif
 %{nil}
-%make_build
+%meson_build
 
 %install
-%make_install
+%meson_install
 find %{buildroot} -type f -name "*.la" -delete -print
-%find_lang %{name} %{?no_lang_C}
+%find_lang %{name}-1.0 %{?no_lang_C}
 
 %post -n libpeas-1_0-0 -p /sbin/ldconfig
 %postun -n libpeas-1_0-0 -p /sbin/ldconfig
@@ -215,7 +216,7 @@
 
 %if %{with python2}
 %files loader-python
-%{_libdir}/libpeas-1.0/loaders/libpythonloader.so
+%{_libdir}/libpeas-1.0/loaders/libpython2loader.so
 %endif
 
 %if %{with python3}
@@ -245,6 +246,6 @@
 %{_datadir}/gir-1.0/Peas-1.0.gir
 %{_datadir}/gir-1.0/PeasGtk-1.0.gir
 
-%files lang -f %{name}.lang
+%files lang -f %{name}-1.0.lang
 
 %changelog

++ libpeas-1.22.0.tar.xz -> libpeas-1.24.0.tar.xz ++
 12683 lines of diff (skipped)




commit libhandy for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libhandy for openSUSE:Factory 
checked in at 2019-10-17 13:02:39

Comparing /work/SRC/openSUSE:Factory/libhandy (Old)
 and  /work/SRC/openSUSE:Factory/.libhandy.new.2352 (New)


Package is "libhandy"

Thu Oct 17 13:02:39 2019 rev:8 rq:736589 version:0.0.11

Changes:

--- /work/SRC/openSUSE:Factory/libhandy/libhandy.changes2019-06-22 
11:20:47.729167459 +0200
+++ /work/SRC/openSUSE:Factory/.libhandy.new.2352/libhandy.changes  
2019-10-17 13:02:40.684790121 +0200
@@ -1,0 +2,7 @@
+Thu Sep 12 18:55:18 UTC 2019 - Bjørn Lie 
+
+- Update to version 0.0.11:
+  + Various build and bug fixes.
+- Switch to source service.
+
+---

Old:

  libhandy-v0.0.10.tar.bz2

New:

  _service
  libhandy-0.0.11.obscpio
  libhandy.obsinfo



Other differences:
--
++ libhandy.spec ++
--- /var/tmp/diff_new_pack.8e9NNH/_old  2019-10-17 13:02:41.280788611 +0200
+++ /var/tmp/diff_new_pack.8e9NNH/_new  2019-10-17 13:02:41.280788611 +0200
@@ -19,13 +19,13 @@
 %define shlib %{name}-0_0-0
 
 Name:   libhandy
-Version:0.0.10
+Version:0.0.11
 Release:0
 Summary:A GTK+ library to develop UI for mobile devices
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/GNOME
 URL:https://source.puri.sm/Librem5/libhandy/
-Source0:%{url}-/archive/v%{version}/%{name}-v%{version}.tar.bz2
+Source0:%{name}-%{version}.tar.xz
 
 BuildRequires:  gtk-doc
 BuildRequires:  meson >= 0.47.0
@@ -82,7 +82,7 @@
 libhandy widgets in Glade.
 
 %prep
-%autosetup -p1 -n %{name}-v%{version}
+%autosetup -p1
 
 %build
 %meson \

++ _service ++

  
https://source.puri.sm/Librem5/libhandy.git
git
refs/tags/v0.0.11
v(.*)
@PARENT_TAG@
  
  
  
*.tar
xz
  
  

++ libhandy.obsinfo ++
name: libhandy
version: 0.0.11
mtime: 1566903429
commit: f5909a897f70143bdd2f89f47a63c1bf848330ce




commit libsecret for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package libsecret for openSUSE:Factory 
checked in at 2019-10-17 13:02:52

Comparing /work/SRC/openSUSE:Factory/libsecret (Old)
 and  /work/SRC/openSUSE:Factory/.libsecret.new.2352 (New)


Package is "libsecret"

Thu Oct 17 13:02:52 2019 rev:22 rq:736592 version:0.19.1

Changes:

--- /work/SRC/openSUSE:Factory/libsecret/libsecret.changes  2019-03-08 
12:00:01.599968864 +0100
+++ /work/SRC/openSUSE:Factory/.libsecret.new.2352/libsecret.changes
2019-10-17 13:02:56.704749536 +0200
@@ -1,0 +2,16 @@
+Sun Sep  8 10:51:30 NZST 2019 - l...@ljones.dev
+
+- Update to version 0.19.1:
+  + service: Fix secret_service_ensure_session_finish error
+propagation.
+- Changes from version 0.19.0:
+  + secret-password: Add necessary functions to migrate from D-Bus
+based API.
+  + egg: Request that secure memory not be dumped to disk.
+  + Add version macros.
+  + Add missing GType to flags in .gir.
+  + paths: Port from GSimpleAsyncResult to GTask.
+  + build: Bump meson_version to 0.50.
+  + Build and test fixes.
+
+---

Old:

  libsecret-0.18.8.tar.xz

New:

  libsecret-0.19.1.tar.xz



Other differences:
--
++ libsecret.spec ++
--- /var/tmp/diff_new_pack.PxF2Yy/_old  2019-10-17 13:02:57.600747266 +0200
+++ /var/tmp/diff_new_pack.PxF2Yy/_new  2019-10-17 13:02:57.608747245 +0200
@@ -18,13 +18,13 @@
 
 %define have_lang 1
 Name:   libsecret
-Version:0.18.8
+Version:0.19.1
 Release:0
 Summary:Library for accessing the Secret Service API
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/GNOME
 URL:https://wiki.gnome.org/Projects/Libsecret
-Source0:
http://download.gnome.org/sources/libsecret/0.18/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/libsecret/0.19/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 
 ## SLE-only patches start at 1000
@@ -34,7 +34,9 @@
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  fdupes
 BuildRequires:  gobject-introspection-devel >= 1.29
+BuildRequires:  gtk-doc
 BuildRequires:  libgcrypt-devel >= 1.2.2
+BuildRequires:  meson >= 0.50
 BuildRequires:  pkgconfig
 BuildRequires:  translation-update-upstream
 BuildRequires:  vala >= 0.17.2.12
@@ -100,12 +102,12 @@
 translation-update-upstream
 
 %build
-%configure \
---disable-static
-make %{?_smp_mflags} V=1
+%meson \
+%{nil}
+%meson_build
 
 %install
-%make_install
+%meson_install
 find %{buildroot} -type f -name "*.la" -delete -print
 %if %{have_lang}
 %find_lang %{name} %{?no_lang_C}

++ libsecret-0.18.8.tar.xz -> libsecret-0.19.1.tar.xz ++
 52310 lines of diff (skipped)




commit gnome-tweaks for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-tweaks for openSUSE:Factory 
checked in at 2019-10-17 13:01:24

Comparing /work/SRC/openSUSE:Factory/gnome-tweaks (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-tweaks.new.2352 (New)


Package is "gnome-tweaks"

Thu Oct 17 13:01:24 2019 rev:8 rq:736569 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-tweaks/gnome-tweaks.changes
2019-05-03 22:11:52.871447097 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-tweaks.new.2352/gnome-tweaks.changes  
2019-10-17 13:01:25.724980024 +0200
@@ -1,0 +2,18 @@
+Fri Sep 27 11:52:41 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + Update gsettings schema for the Activities Overview Hot Corner.
+  + Fix an assertion with the new libhandy integration.
+  + Updated translations.
+
+---
+Sat Aug 31 20:24:00 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.90:
+  + Use libhandy so the app displays better on narrower screens.
+  + Drop obsolete Application Menu tweak.
+  + Update GTK+ to GTK.
+  + Adapt to GNOME 3.33/3.34 gsettings schema changes.
+  + Updated translations.
+
+---

Old:

  gnome-tweaks-3.32.0.tar.xz

New:

  gnome-tweaks-3.34.0.tar.xz



Other differences:
--
++ gnome-tweaks.spec ++
--- /var/tmp/diff_new_pack.e3tWOQ/_old  2019-10-17 13:01:26.372978383 +0200
+++ /var/tmp/diff_new_pack.e3tWOQ/_new  2019-10-17 13:01:26.380978362 +0200
@@ -18,13 +18,13 @@
 
 
 Name:   gnome-tweaks
-Version:3.32.0
+Version:3.34.0
 Release:0
 Summary:A tool to customize advanced GNOME 3 options
 License:GPL-3.0-or-later AND CC0-1.0
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Apps/Tweaks
-Source0:
https://download.gnome.org/sources/gnome-tweaks/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-tweaks/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 # GI is needed to have typelib() Requires
@@ -55,7 +55,7 @@
 %lang_package
 
 %prep
-%setup -q
+%autosetup -p1
 translation-update-upstream
 # Tiny tweak to shut up rpmlint
 sed -i 's:Pantheon:X-Pantheon:g' */org.gnome.tweaks.desktop.in

++ gnome-tweaks-3.32.0.tar.xz -> gnome-tweaks-3.34.0.tar.xz ++
 11729 lines of diff (skipped)




commit grilo for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package grilo for openSUSE:Factory checked 
in at 2019-10-17 13:01:38

Comparing /work/SRC/openSUSE:Factory/grilo (Old)
 and  /work/SRC/openSUSE:Factory/.grilo.new.2352 (New)


Package is "grilo"

Thu Oct 17 13:01:38 2019 rev:38 rq:736574 version:0.3.10

Changes:

--- /work/SRC/openSUSE:Factory/grilo/grilo.changes  2019-07-21 
11:31:38.524804691 +0200
+++ /work/SRC/openSUSE:Factory/.grilo.new.2352/grilo.changes2019-10-17 
13:01:40.684942125 +0200
@@ -1,0 +2,10 @@
+Sat Sep 14 08:13:55 UTC 2019 - bjorn@gmail.com
+
+- Update to version 0.3.10:
+  + build: Use variables in pc files.
+  + Fix grl_data_add_related_keys annotation.
+  + Use only one primary header for style.
+- Add optional pkgconfig(oauth) BuildRequires: Build oauth support.
+- Enable check section and run meson_test.
+
+---

Old:

  grilo-0.3.9.tar.xz

New:

  grilo-0.3.10.tar.xz



Other differences:
--
++ grilo.spec ++
--- /var/tmp/diff_new_pack.oa2S87/_old  2019-10-17 13:01:42.076938598 +0200
+++ /var/tmp/diff_new_pack.oa2S87/_new  2019-10-17 13:01:42.080938588 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   grilo
-Version:0.3.9
+Version:0.3.10
 Release:0
 Summary:Framework for browsing and searching media content
 License:LGPL-2.1-or-later
@@ -28,7 +28,7 @@
 BuildRequires:  fdupes
 BuildRequires:  gtk-doc
 BuildRequires:  intltool
-BuildRequires:  meson
+BuildRequires:  meson >= 0.46.0
 BuildRequires:  pkgconfig
 BuildRequires:  vala
 BuildRequires:  pkgconfig(gio-2.0) >= 2.44
@@ -39,6 +39,7 @@
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.0
 BuildRequires:  pkgconfig(libsoup-2.4) >= 2.41.3
 BuildRequires:  pkgconfig(libxml-2.0)
+BuildRequires:  pkgconfig(oauth)
 BuildRequires:  pkgconfig(totem-plparser) >= 3.4.1
 BuildRequires:  pkgconfig(vapigen) >= 0.27
 
@@ -87,7 +88,7 @@
 various sources using a single API.
 
 %package -n typelib-1_0-GrlNet-0_3
-Summary:Framework for browsing and searching media content -- 
Networking Helper Library, Introspection bindings
+Summary:Introspection bindings for grilo
 Group:  System/Libraries
 
 %description -n typelib-1_0-GrlNet-0_3
@@ -98,7 +99,7 @@
 libgrlnet library.
 
 %package -n typelib-1_0-GrlPls-0_3
-Summary:Framework for browsing and searching media content -- Playlist 
Helper Library, Introspection bindings
+Summary:Introspection bindings for grilo
 Group:  System/Libraries
 
 %description -n typelib-1_0-GrlPls-0_3
@@ -152,9 +153,8 @@
 install -d %{buildroot}%{_datadir}/grilo-0.3/plugins
 %fdupes %{buildroot}%{_datadir}
 
-# make check disabled: it requires grilo to be installed to /usr beforehand 
(in order to load the plugins)
-#%%check
-#make check
+%check
+%meson_test
 
 %post -n libgrilo-0_3-0 -p /sbin/ldconfig
 %postun -n libgrilo-0_3-0 -p /sbin/ldconfig

++ grilo-0.3.9.tar.xz -> grilo-0.3.10.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/grilo-0.3.9/NEWS new/grilo-0.3.10/NEWS
--- old/grilo-0.3.9/NEWS2019-07-17 10:56:58.0 +0200
+++ new/grilo-0.3.10/NEWS   2019-09-12 17:01:01.0 +0200
@@ -1,3 +1,16 @@
+NEW in 0.3.10
+=
+  * !48 - build: Use variables in pc files
+  * !47 - fix grl_data_add_related_keys annotation
+  * !46 - Use only one primary header for style
+
+  * Contributors to this release:
+Jan Tojnar 
+Jean Felder 
+Roger 
+Victor Toso 
+worldofpeace 
+
 NEW in 0.3.9
 
   * !43 - grl-metadata-key: fix introspection
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/grilo-0.3.9/README.md new/grilo-0.3.10/README.md
--- old/grilo-0.3.9/README.md   2019-07-17 10:56:58.0 +0200
+++ new/grilo-0.3.10/README.md  2019-09-12 17:01:01.0 +0200
@@ -1,44 +1,47 @@
+# Grilo
+
 Thanks for using Grilo!
 
-# What is Grilo?
+## What is Grilo?
 
 Grilo is a framework for browsing and searching media content from various
 sources using a single API.
 
-# Where can I find more?
+## Where can I find more?
 
 We have a [wiki page](https://wiki.gnome.org/Projects/Grilo)
 
 You can subscribe to our [mailing 
list](http://mail.gnome.org/mailman/listinfo/grilo-list)
 
 You can join us on the IRC:
+
 #grilo on GIMPNet
 
-# How do I start?
+## How do I start?
 
 Once you have Grilo installed, you may want to play around with the
 examples (See section "Examples") or check its documentation
 and tutorials (See section "Documentation").
 
-## Fedora
+### Fedora
 
 ```
 sudo dnf install grilo
 ```
 
-## Archlinux
+### Arch Linux
 
 ```
 sudo pacman -S grilo
 ```

commit gnome-user-share for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-user-share for 
openSUSE:Factory checked in at 2019-10-17 13:01:31

Comparing /work/SRC/openSUSE:Factory/gnome-user-share (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-user-share.new.2352 (New)


Package is "gnome-user-share"

Thu Oct 17 13:01:31 2019 rev:59 rq:736572 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-user-share/gnome-user-share.changes
2019-05-03 22:16:27.851988567 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-user-share.new.2352/gnome-user-share.changes  
2019-10-17 13:01:33.592960092 +0200
@@ -1,0 +2,16 @@
+Fri Sep  6 17:00:03 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Fix installation location of systemd unit file on Fedora 64-bit
+systems.
+  + Updated translations.
+
+---
+Fri Aug 30 21:28:39 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.1:
+  + Port to meson build system.
+  + Remove autotools as build system.
+- Add meson BuildRequires and macros.
+
+---

Old:

  gnome-user-share-3.32.0.1.tar.xz

New:

  gnome-user-share-3.34.0.tar.xz



Other differences:
--
++ gnome-user-share.spec ++
--- /var/tmp/diff_new_pack.7wJ52P/_old  2019-10-17 13:01:34.292958318 +0200
+++ /var/tmp/diff_new_pack.7wJ52P/_new  2019-10-17 13:01:34.296958308 +0200
@@ -17,20 +17,21 @@
 
 
 Name:   gnome-user-share
-Version:3.32.0.1
+Version:3.34.0
 Release:0
 Summary:GNOME user file sharing
 License:GPL-2.0-or-later
 Group:  Productivity/Networking/File-Sharing
 URL:http://www.gnome.org/
-Source0:
https://download.gnome.org/sources/gnome-user-share/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-user-share/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
+BuildRequires:  meson >= 0.50.0
 BuildRequires:  pkgconfig
 BuildRequires:  translation-update-upstream
 BuildRequires:  update-desktop-files
 BuildRequires:  yelp-tools
-BuildRequires:  pkgconfig(glib-2.0) >= 2.28
+BuildRequires:  pkgconfig(glib-2.0) >= 2.58
 BuildRequires:  pkgconfig(gtk+-3.0)
 BuildRequires:  pkgconfig(libcanberra-gtk3)
 BuildRequires:  pkgconfig(libnautilus-extension) >= 3.27.90
@@ -57,16 +58,18 @@
 
 %prep
 %autosetup -p1
-translation-update-upstream
+translation-update-upstream po %{name}
 
 %build
-%configure \
---with-modules-path=%{_libdir}/apache2/ \
---libexecdir=%{_libexecdir}/gnome-user-share
-%make_build
+%meson \
+   -Dmodules_path=%{_libdir}/apache2/ \
+   --libexecdir=%{_libexecdir}/gnome-user-share \
+   -Dsystemduserunitdir=%{_userunitdir} \
+   %{nil}
+%meson_build
 
 %install
-%make_install
+%meson_install
 
 find %{buildroot} -type f -name "*.la" -delete -print
 %suse_update_desktop_file gnome-user-share-webdav Network FileTransfer

++ gnome-user-share-3.32.0.1.tar.xz -> gnome-user-share-3.34.0.tar.xz ++
 68517 lines of diff (skipped)




commit gtksourceview4 for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gtksourceview4 for openSUSE:Factory 
checked in at 2019-10-17 13:02:08

Comparing /work/SRC/openSUSE:Factory/gtksourceview4 (Old)
 and  /work/SRC/openSUSE:Factory/.gtksourceview4.new.2352 (New)


Package is "gtksourceview4"

Thu Oct 17 13:02:08 2019 rev:15 rq:736580 version:4.4.0

Changes:

--- /work/SRC/openSUSE:Factory/gtksourceview4/gtksourceview4.changes
2019-06-02 15:13:57.906141058 +0200
+++ /work/SRC/openSUSE:Factory/.gtksourceview4.new.2352/gtksourceview4.changes  
2019-10-17 13:02:13.396859252 +0200
@@ -1,0 +2,30 @@
+Wed Sep 11 05:52:35 UTC 2019 - Bjørn Lie 
+
+- Update to version 4.4.0:
+  + Set NO_AT_BRIDGE=1 when running automated tests.
+  + Speed up GtkSourceView rendering when space drawer is unused.
+
+---
+Thu Sep  5 21:48:53 NZST 2019 - 
+
+- Update to version 4.3.92:
+  + New syntax highlighting definition file for: ASCII Doc,
+Dockerfile.
+  + Improvements to the syntax highlighting of: CSS, Gradle, HTML,
+C, PHP, YAML, and Grovvy.
+  + Performance improvements in line number drawing.
+  + GtkSourceView now requires GTK 3.22 or newer.
+  + GtkSourceView no longer uses many deprecated APIs from GTK.
+  + GtkSourceView now uses fribidi directly to determine
+bidriectional direction for cursors.
+  + GtkSourceView now relies on GObject for correct marsharllers as
+well as va_marshallers or provides its own. This improves
+profiling with kernel stack unwinders such as Linux's perf.
+  + Visual column detection is improved to use the tab-width
+instead of the indent-width.
+  + Support for DnD from GIMPs color palette has been improved.
+  + A performance optimization has been added to avoid painting
+mark backgrounds if no GtkSourceMarks have been registered.
+  + Updated translations.
+
+---

Old:

  gtksourceview-4.2.0.tar.xz

New:

  gtksourceview-4.4.0.tar.xz



Other differences:
--
++ gtksourceview4.spec ++
--- /var/tmp/diff_new_pack.5f1lpV/_old  2019-10-17 13:02:13.968857803 +0200
+++ /var/tmp/diff_new_pack.5f1lpV/_new  2019-10-17 13:02:13.980857773 +0200
@@ -18,22 +18,25 @@
 
 %define _name   gtksourceview
 Name:   gtksourceview4
-Version:4.2.0
+Version:4.4.0
 Release:0
 Summary:GTK+ Source Editing Widget
 License:LGPL-2.1-or-later
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Projects/GtkSourceView
-Source0:
https://download.gnome.org/sources/gtksourceview/4.2/%{_name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gtksourceview/4.4/%{_name}-%{version}.tar.xz
 Source1:changes.lang
+
 BuildRequires:  gobject-introspection-devel
+BuildRequires:  gtk-doc
+BuildRequires:  meson
 BuildRequires:  pkgconfig
 BuildRequires:  vala
 BuildRequires:  valgrind
 BuildRequires:  pkgconfig(gio-2.0) >= 2.48
 BuildRequires:  pkgconfig(gladeui-2.0) >= 3.9
 BuildRequires:  pkgconfig(glib-2.0) >= 2.48
-BuildRequires:  pkgconfig(gtk+-3.0) >= 3.20
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.22
 BuildRequires:  pkgconfig(libxml-2.0) >= 2.6
 
 %description
@@ -108,12 +111,15 @@
 %setup -q -n %{_name}-%{version}
 
 %build
-%configure --disable-static \
---enable-glade-catalog
-make %{?_smp_mflags}
+%global _lto_cflags %{_lto_cflags} -ffat-lto-objects
+%meson \
+-Dglade_catalog=true \
+-Dgtk_doc=true \
+%{nil}
+%meson_build
 
 %install
-%make_install
+%meson_install
 find %{buildroot} -type f -name "*.la" -delete -print
 %find_lang %{_name}-4
 # Install language definition for *.changes files:

++ gtksourceview-4.2.0.tar.xz -> gtksourceview-4.4.0.tar.xz ++
 370359 lines of diff (skipped)




commit jsonrpc-glib for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package jsonrpc-glib for openSUSE:Factory 
checked in at 2019-10-17 13:02:16

Comparing /work/SRC/openSUSE:Factory/jsonrpc-glib (Old)
 and  /work/SRC/openSUSE:Factory/.jsonrpc-glib.new.2352 (New)


Package is "jsonrpc-glib"

Thu Oct 17 13:02:16 2019 rev:9 rq:736586 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/jsonrpc-glib/jsonrpc-glib.changes
2019-07-08 15:02:51.450700800 +0200
+++ /work/SRC/openSUSE:Factory/.jsonrpc-glib.new.2352/jsonrpc-glib.changes  
2019-10-17 13:02:19.340844193 +0200
@@ -1,0 +2,15 @@
+Tue Sep 10 18:13:20 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + No changes.
+
+---
+Thu Aug 15 11:38:36 CEST 2019 - bjorn@gmail.com
+
+- Update to version 3.33.3:
+  + Custom marshallers are now provided for all signals to improve
+the stack-unwinding capability from kernel tooling such as
+Linux `perf`.
+  + Various build system improvements.
+
+---

Old:

  jsonrpc-glib-3.32.0.tar.xz

New:

  jsonrpc-glib-3.34.0.tar.xz



Other differences:
--
++ jsonrpc-glib.spec ++
--- /var/tmp/diff_new_pack.QX8QIP/_old  2019-10-17 13:02:19.788843059 +0200
+++ /var/tmp/diff_new_pack.QX8QIP/_new  2019-10-17 13:02:19.788843059 +0200
@@ -18,16 +18,16 @@
 
 %define sover 1_0-1
 Name:   jsonrpc-glib
-Version:3.32.0
+Version:3.34.0
 Release:0
 Summary:Library to communicate with JSON-RPC based peers
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/GNOME
 URL:https://gitlab.gnome.org/GNOME/jsonrpc-glib
-Source0:
https://download.gnome.org/sources/jsonrpc-glib/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/jsonrpc-glib/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  gtk-doc
-BuildRequires:  meson >= 0.40.1
+BuildRequires:  meson >= 0.49.2
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(gio-2.0)
 BuildRequires:  pkgconfig(gio-unix-2.0)

++ jsonrpc-glib-3.32.0.tar.xz -> jsonrpc-glib-3.34.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jsonrpc-glib-3.32.0/NEWS new/jsonrpc-glib-3.34.0/NEWS
--- old/jsonrpc-glib-3.32.0/NEWS2019-03-13 08:15:09.0 +0100
+++ new/jsonrpc-glib-3.34.0/NEWS2019-09-10 02:47:58.0 +0200
@@ -1,4 +1,14 @@
 ==
+Version 3.33.3
+==
+
+Changes in this release:
+
+ • Custom marshallers are now provided for all signals to improve the
+   stack-unwinding capability from kernel tooling such as Linux `perf`.
+ • Various build system improvements.
+
+==
 Version 3.32.0
 ==
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jsonrpc-glib-3.32.0/meson.build 
new/jsonrpc-glib-3.34.0/meson.build
--- old/jsonrpc-glib-3.32.0/meson.build 2019-03-13 08:15:09.0 +0100
+++ new/jsonrpc-glib-3.34.0/meson.build 2019-09-10 02:47:58.0 +0200
@@ -1,7 +1,7 @@
 project('jsonrpc-glib', 'c',
-  version: '3.32.0',
+  version: '3.33.3',
   license: 'LGPLv2.1+',
-meson_version: '>= 0.40.1',
+meson_version: '>= 0.49.2',
   default_options: [ 'warning_level=1', 'buildtype=debugoptimized', 
'c_std=gnu11' ],
 )
 
@@ -26,6 +26,8 @@
 revision = jsonrpc_glib_interface_age
 libversion = '@0@.@1@.@2@'.format(soversion, current, revision)
 
+darwin_versions = [current + 1, '@0@.@1@'.format(current + 1, revision)]
+
 config_h = configuration_data()
 config_h.set_quoted('GETTEXT_PACKAGE', 'libjsonrpc_glib')
 config_h.set_quoted('LOCALEDIR', join_paths(get_option('prefix'), 
get_option('localedir')))
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/jsonrpc-glib-3.32.0/src/jsonrpc-client.c 
new/jsonrpc-glib-3.34.0/src/jsonrpc-client.c
--- old/jsonrpc-glib-3.32.0/src/jsonrpc-client.c2019-03-13 
08:15:09.0 +0100
+++ new/jsonrpc-glib-3.34.0/src/jsonrpc-client.c2019-09-10 
02:47:58.0 +0200
@@ -58,6 +58,7 @@
 #include "jsonrpc-client.h"
 #include "jsonrpc-input-stream.h"
 #include "jsonrpc-input-stream-private.h"
+#include "jsonrpc-marshalers.h"
 #include "jsonrpc-output-stream.h"
 
 typedef struct
@@ -504,11 +505,8 @@
   G_SIGNAL_RUN_LAST,
   G_STRUCT_OFFSET (JsonrpcClientClass, failed),
   NULL, NULL,
-  g_cclosure_marshal_VOID__VOID,
+  NULL,
   G_TYPE_NONE, 0);
-  g_signal_set_va_marshaller (signals [FAILED],
-  

commit gnome-software for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-software for openSUSE:Factory 
checked in at 2019-10-17 13:01:18

Comparing /work/SRC/openSUSE:Factory/gnome-software (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-software.new.2352 (New)


Package is "gnome-software"

Thu Oct 17 13:01:18 2019 rev:66 rq:736562 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/gnome-software/gnome-software.changes
2019-07-22 12:17:58.631702360 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-software.new.2352/gnome-software.changes  
2019-10-17 13:01:20.512993228 +0200
@@ -1,0 +2,37 @@
+Mon Oct  7 16:55:15 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Fix firmware updates where the device needed a manual detach.
+  + Fix installing webapps.
+  + Fix signal blocking for search.
+  + Fix third party repo enabling.
+  + Hide the shortcut buttons for parentally filtered apps.
+  + Make disabled flatpak remote enabling work.
+  + Show snap channels as app alternates.
+  + Show the correct application when clicking from the GNOME Shell
+menu.
+  + Updated translations.
+
+---
+Mon Sep  9 14:34:44 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Add a link to the privacy policy in the review dialog.
+  + Add and improve many overview banners.
+  + Add support for download scheduling using Mogwai.
+  + Allow installing locale data automatically.
+  + Allow snaps to be shown by AppStream ID.
+  + Don't apply drop shadow on stock symbolic icons.
+  + Don't install queued apps when the network changes and is
+metered.
+  + Fix the 'localised in my language' kudo.
+  + Hide addons that are not available in repos.
+  + Localize ESRB content rating strings.
+  + Never show the installation progress bar going backwards.
+  + Notify the user when an application can escape the sandbox.
+  + Refactor screenshots and hide those unavailable when offline.
+  + Select the rating systems selected based by territory.
+  + Use smaller default size for main window when required.
+  + Updated Translations.
+
+---

Old:

  gnome-software-3.32.4.tar.xz

New:

  gnome-software-3.34.1.tar.xz



Other differences:
--
++ gnome-software.spec ++
--- /var/tmp/diff_new_pack.pGfEjc/_old  2019-10-17 13:01:21.692990239 +0200
+++ /var/tmp/diff_new_pack.pGfEjc/_new  2019-10-17 13:01:21.696990229 +0200
@@ -18,13 +18,13 @@
 
 %define gs_plugin_api 13
 Name:   gnome-software
-Version:3.32.4
+Version:3.34.1
 Release:0
 Summary:GNOME Software Store
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Apps/Software
-Source0:
https://download.gnome.org/sources/gnome-software/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-software/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  gtk-doc
 BuildRequires:  meson
@@ -130,14 +130,13 @@
 %{_includedir}/%{name}/gnome-software.h
 %{_includedir}/%{name}/gs-app-list.h
 %{_includedir}/%{name}/gs-app.h
-%{_includedir}/%{name}/gs-auth.h
 %{_includedir}/%{name}/gs-category.h
+%{_includedir}/%{name}/gs-metered.h
 %{_includedir}/%{name}/gs-os-release.h
 %{_includedir}/%{name}/gs-plugin-vfuncs.h
 %{_includedir}/%{name}/gs-plugin.h
 %{_includedir}/%{name}/gs-plugin-event.h
 %{_includedir}/%{name}/gs-plugin-types.h
-%{_includedir}/%{name}/gs-price.h
 %{_includedir}/%{name}/gs-utils.h
 %{_libdir}/pkgconfig/gnome-software.pc
 

++ gnome-software-3.32.4.tar.xz -> gnome-software-3.34.1.tar.xz ++
 123193 lines of diff (skipped)




commit gtk3 for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gtk3 for openSUSE:Factory checked in 
at 2019-10-17 13:01:59

Comparing /work/SRC/openSUSE:Factory/gtk3 (Old)
 and  /work/SRC/openSUSE:Factory/.gtk3.new.2352 (New)


Package is "gtk3"

Thu Oct 17 13:01:59 2019 rev:148 rq:736579 version:3.24.12

Changes:

--- /work/SRC/openSUSE:Factory/gtk3/gtk3.changes2019-09-11 
10:20:34.827509370 +0200
+++ /work/SRC/openSUSE:Factory/.gtk3.new.2352/gtk3.changes  2019-10-17 
13:02:11.772863366 +0200
@@ -1,0 +2,12 @@
+Fri Oct  4 11:03:57 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.24.12:
+  + file chooser: allow sorting by file type.
+  + dnd: fix pointer offsets under X11 and Wayland.
+  + broadway: Fix a font problem.
+  + mir Drop this backend.
+  + printing: Get PPD from original host if needed.
+  + a11y: Fix interference with clutter a11y impl.
+  + Updated translations.
+
+---

Old:

  gtk+-3.24.11.tar.xz

New:

  gtk+-3.24.12.tar.xz



Other differences:
--
++ gtk3.spec ++
--- /var/tmp/diff_new_pack.0cxmsT/_old  2019-10-17 13:02:13.024860195 +0200
+++ /var/tmp/diff_new_pack.0cxmsT/_new  2019-10-17 13:02:13.024860195 +0200
@@ -22,7 +22,7 @@
 %define _name   gtk+
 %bcond_without  broadway
 Name:   gtk3
-Version:3.24.11
+Version:3.24.12
 Release:0
 Summary:The GTK+ toolkit library (version 3)
 License:LGPL-2.1-or-later

++ gtk+-3.24.11.tar.xz -> gtk+-3.24.12.tar.xz ++
/work/SRC/openSUSE:Factory/gtk3/gtk+-3.24.11.tar.xz 
/work/SRC/openSUSE:Factory/.gtk3.new.2352/gtk+-3.24.12.tar.xz differ: char 27, 
line 1




commit gsettings-desktop-schemas for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gsettings-desktop-schemas for 
openSUSE:Factory checked in at 2019-10-17 13:01:54

Comparing /work/SRC/openSUSE:Factory/gsettings-desktop-schemas (Old)
 and  /work/SRC/openSUSE:Factory/.gsettings-desktop-schemas.new.2352 (New)


Package is "gsettings-desktop-schemas"

Thu Oct 17 13:01:54 2019 rev:53 rq:736576 version:3.34.0

Changes:

--- 
/work/SRC/openSUSE:Factory/gsettings-desktop-schemas/gsettings-desktop-schemas.changes
  2019-05-03 22:15:25.723864844 +0200
+++ 
/work/SRC/openSUSE:Factory/.gsettings-desktop-schemas.new.2352/gsettings-desktop-schemas.changes
2019-10-17 13:01:55.936903485 +0200
@@ -1,0 +2,30 @@
+Tue Sep 10 05:46:01 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Translation updates.
+
+---
+Fri Sep  6 11:43:18 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Translation updates.
+
+---
+Fri Aug 30 20:36:48 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.90:
+  + Add 'middle-click-emulation' setting.
+  + Updated translations.
+- Changes from version 3.33.1:
+  + Add 'enable-hot-corners' setting.
+  + Updated translations.
+- Changes from version 3.33.0:
+  + Add mount-removable-storage-devices-as-read-only lockdown
+option.
+  + Add setting for overlay scrolling.
+  + Add locate-pointer setting.
+  + Add settings to store numlock state.
+  + Updated translations.
+- Require meson >= 0.50.0.
+
+---

Old:

  gsettings-desktop-schemas-3.32.0.tar.xz

New:

  gsettings-desktop-schemas-3.34.0.tar.xz



Other differences:
--
++ gsettings-desktop-schemas.spec ++
--- /var/tmp/diff_new_pack.GDEu2f/_old  2019-10-17 13:01:56.512902026 +0200
+++ /var/tmp/diff_new_pack.GDEu2f/_new  2019-10-17 13:01:56.516902017 +0200
@@ -18,19 +18,19 @@
 
 
 Name:   gsettings-desktop-schemas
-Version:3.32.0
+Version:3.34.0
 Release:0
 Summary:Shared GSettings Schemas for the Desktop
 License:LGPL-2.1-or-later
 Group:  System/GUI/GNOME
 URL:https://gnome.org/
-Source0:
https://download.gnome.org/sources/gsettings-desktop-schemas/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gsettings-desktop-schemas/3.34/%{name}-%{version}.tar.xz
 
 # PATCH-FEATURE-OPENSUSE 
gsettings-desktop-schemas-fate324570-Add-key-for-GDM-background-configuration.patch
 fate#324570, glgo#GNOME/gnome-shell#680 qk...@suse.com -- This key is used by 
gnome-shell-fate324570-Make-GDM-background-image-configurable.patch
 Patch0: 
gsettings-desktop-schemas-fate324570-Add-key-for-GDM-background-configuration.patch
 
 BuildRequires:  gobject-introspection-devel >= 1.31.0
-BuildRequires:  meson
+BuildRequires:  meson >= 0.50.0
 BuildRequires:  pkgconfig
 BuildRequires:  translation-update-upstream
 BuildRequires:  pkgconfig(gio-2.0) >= 2.31.0

++ gsettings-desktop-schemas-3.32.0.tar.xz -> 
gsettings-desktop-schemas-3.34.0.tar.xz ++
 28054 lines of diff (skipped)




commit gnome-shell-extensions for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-shell-extensions for 
openSUSE:Factory checked in at 2019-10-17 13:01:12

Comparing /work/SRC/openSUSE:Factory/gnome-shell-extensions (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-shell-extensions.new.2352 (New)


Package is "gnome-shell-extensions"

Thu Oct 17 13:01:12 2019 rev:90 rq:736561 version:3.34.1

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-shell-extensions/gnome-shell-extensions.changes
2019-08-15 12:26:11.434594363 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-shell-extensions.new.2352/gnome-shell-extensions.changes
  2019-10-17 13:01:14.729007882 +0200
@@ -1,0 +2,62 @@
+Wed Oct  9 10:32:09 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Adjust to gnome-settings-daemon plugin removals.
+  + Updated translations.
+
+---
+Tue Oct  8 04:35:27 UTC 2019 - Xiaoguang Wang 
+
+- Add requires gnome-shell-extension-desktop-icons for package
+  gnome-shell-classic, when start sle-classic session, enable
+  extension desktop-icons automatically (bsc#1148036).
+
+---
+Wed Sep 11 07:09:01 UTC 2019 - Xiaoguang Wang 
+
+- Update gse-sle-classic-ext.patch: Missing the solution for
+  boo#1094148, add it back.
+
+---
+Mon Sep  9 16:31:41 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Fri Sep  6 01:04:26 UTC 2019 - Xiaoguang Wang 
+
+- Update to version 3.33.92:
+  + Translators: Марко Костић [sr], Tim Sabsch [de],
+Rūdolfs Mazurs [lv], Matej Urbančič [sl], Balázs Úr [hu],
+Claude Paroz [fr], Fran Dieguez [gl], Changwoo Ryu [ko],
+Ryuta Fujii [ja], Fabio Tomat [fur], Goran Vidović [hr].
+- Adapt sle-classic to 3.33.92
+  + Update file sle-classic.json
+  + Update sle-clas...@suse.com.tar.gz
+  + Update gse-sle-classic-ext.patch
+- Drop gnome-shell-favorites-menu-at-end.patch:
+  Merge this function to gse-sle-classic-ext.patch.
+
+---
+Wed Sep  4 02:17:34 UTC 2019 - Xiaoguang Wang 
+
+- Update to version 3.33.91:
+  + window-list: Support showing windows from all workspaces.
+  + Misc. bug fixes and cleanups.
+  + Make GNOME Classic more classic:
+- Disable GNOME 3 overview.
+- Add window picker button to window list.
+- Style improvements and fixes.
+- Support horizontal workspace layout in window list.
+- Add draggable previews to window list workspace switcher.
+- Arrange workspaces horizontally.
+  + workspace-indicator: Support horizontal workspace layout.
+  + workspace-indicator: Add draggable previews.
+- Drop gse-apps-menu-Add_missing_chain-up.patch: Fixed upstream.
+- Rebase gnome-shell-add-app-to-desktop.patch
+- Rebase gnome-shell-favorites-menu-at-end.patch
+- Rebase gse-sle-classic-ext.patch
+- Rebase sle-classic-lock-screen-background.patch
+
+---

Old:

  gnome-shell-extensions-3.32.1.tar.xz
  gnome-shell-favorites-menu-at-end.patch
  gse-apps-menu-Add_missing_chain-up.patch

New:

  gnome-shell-extensions-3.34.1.tar.xz



Other differences:
--
++ gnome-shell-extensions.spec ++
--- /var/tmp/diff_new_pack.yM8473/_old  2019-10-17 13:01:16.073004477 +0200
+++ /var/tmp/diff_new_pack.yM8473/_new  2019-10-17 13:01:16.077004466 +0200
@@ -19,13 +19,13 @@
 
 %global __requires_exclude typelib\\(Meta\\)
 Name:   gnome-shell-extensions
-Version:3.32.1
+Version:3.34.1
 Release:0
 Summary:A collection of extensions for GNOME Shell
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Projects/GnomeShell/Extensions
-Source0:
https://download.gnome.org/sources/gnome-shell-extensions/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-shell-extensions/3.34/%{name}-%{version}.tar.xz
 Source1:README.SUSE
 Source2:sle-classic.desktop
 Source3:SLE-theme.tar.gz
@@ -35,12 +35,8 @@
 Source7:00_org.gnome.shell.extensions.sle-classic.gschema.override
 # PATCH-FEATURE-OPENSUSE gnome-shell-add-app-to-desktop.patch bnc#870580 
dli...@suse.com --  allow adding app shortcut to desktop easily.
 Patch1: gnome-shell-add-app-to-desktop.patch
-# PATCH-FEATURE-OPENSUSE sle-classic-favorites-menu-at-end.patch bnc#890989 
cxi...@suse.com -- put the favorites at the end of the app catogories for 
accessibility reason -- cxi...@suse.com bnc#890989
-Patch2: 

commit gnome-session for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-session for openSUSE:Factory 
checked in at 2019-10-17 13:00:54

Comparing /work/SRC/openSUSE:Factory/gnome-session (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-session.new.2352 (New)


Package is "gnome-session"

Thu Oct 17 13:00:54 2019 rev:185 rq:736558 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/gnome-session/gnome-session.changes  
2019-08-15 12:24:38.522617542 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-session.new.2352/gnome-session.changes
2019-10-17 13:00:56.237054730 +0200
@@ -1,0 +2,50 @@
+Mon Oct  7 09:57:51 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Drop accidentally included `--debug` when launching
+`gnome-session-binary`.
+  + Introduce a list of variables to potentially unset in launched
+sessions.
+  + Updated translations.
+- Drop gnome-session-no-debug.patch: Fixed upstream.
+
+---
+Tue Sep 17 22:16:07 UTC 2019 - Bjørn Lie 
+
+- Add gnome-session-no-debug.patch: Disable debug log spam in
+  journald. Patch/bug to be sent upstream.
+
+---
+Wed Sep 11 16:33:05 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Thu Sep  5 11:52:46 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + More systemd --user fixes
+  + Updated translations.
+
+---
+Sun Sep  1 13:53:21 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.90:
+  + Add support to manage the session using the systemd user
+instance.
+  + Update session definitions to match new gnome-settings-daemon.
+  + Don't show logout button in fail whale when not logged in.
+  + Handle apps exiting abruptly at log out better.
+  + Updated translations.
+- Changes from version 3.33.4:
+  + Fix warning in log spew with dbus activated services.
+  + Fix idle detection.
+  + Advertize support for GDM's session registration API
+  + Updated translations.
+- Drop
+  gnome-session-presence-Enable-idle-detection-when-screen-locked.patch:
+  fixed upstream.
+- Add systemd user unit files.
+
+---

Old:

  _servicedata
  gnome-session-3.32.0+5.obscpio
  gnome-session-presence-Enable-idle-detection-when-screen-locked.patch

New:

  gnome-session-3.34.1.obscpio



Other differences:
--
++ gnome-session.spec ++
--- /var/tmp/diff_new_pack.siQE5h/_old  2019-10-17 13:00:56.997052804 +0200
+++ /var/tmp/diff_new_pack.siQE5h/_new  2019-10-17 13:00:56.997052804 +0200
@@ -17,21 +17,18 @@
 
 
 Name:   gnome-session
-Version:3.32.0+5
+Version:3.34.1
 Release:0
 Summary:Session Tools for the GNOME Desktop
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://www.gnome.org
-# We are using source services, so no download url for source
 Source0:%{name}-%{version}.tar.xz
 Source1:gnome
 Source2:gnome.desktop
 
 # PATCH-FIX-UPSTREAM gnome-session-better-handle-empty-xdg_session_type.patch 
bsc#1084756 bgo#794256 yfji...@suse.com -- solution provided by m...@suse.com 
using a more reasonable way to handle gpu acceleration check
 Patch0: gnome-session-better-handle-empty-xdg_session_type.patch
-# PATCH-FIX-UPSTREAM 
gnome-session-presence-Enable-idle-detection-when-screen-locked.patch 
bsc#1118286 glgo#GNOME/gnome-shell#900 xw...@suse.com -- Enable dimming screen 
when screen is locked
-Patch1: 
gnome-session-presence-Enable-idle-detection-when-screen-locked.patch
 # PATCH-FIX-OPENSUSE gnome-session-s390-not-require-g-s-d_wacom.patch 
bsc#1129412 yfji...@suse.com -- Remove the runtime requirement of g-s-d Wacom 
plugin
 Patch2: gnome-session-s390-not-require-g-s-d_wacom.patch
 
@@ -109,7 +106,6 @@
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 %ifarch s390 s390x
 %patch2 -p1
 %endif
@@ -204,8 +200,28 @@
 %{_libexecdir}/gnome-session-check-accelerated
 %{_libexecdir}/gnome-session-check-accelerated-gl-helper
 %{_libexecdir}/gnome-session-check-accelerated-gles-helper
+%{_libexecdir}/gnome-session-ctl
 %{_libexecdir}/gnome-session-failed
 %{_datadir}/gnome-session/hardware-compatibility
+%{_userunitdir}/gnome-session-failed.service
+%{_userunitdir}/gnome-session-failed.target
+%{_userunitdir}/gnome-session-initialized.target
+%{_userunitdir}/gnome-session-manager.target
+%{_userunitdir}/gnome-session-manager@.service
+%{_userunitdir}/gnome-session-monitor.service
+%{_userunitdir}/gnome-session-pre.target

commit gnome-online-miners for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-online-miners for 
openSUSE:Factory checked in at 2019-10-17 13:00:42

Comparing /work/SRC/openSUSE:Factory/gnome-online-miners (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-online-miners.new.2352 (New)


Package is "gnome-online-miners"

Thu Oct 17 13:00:42 2019 rev:22 rq:736553 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-online-miners/gnome-online-miners.changes  
2018-10-17 08:10:49.731143805 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-online-miners.new.2352/gnome-online-miners.changes
2019-10-17 13:00:44.753083823 +0200
@@ -1,0 +2,12 @@
+Wed Sep 11 18:09:53 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + No changes, stable version bump only.
+
+---
+Thu Sep  5 14:42:46 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Use Files GOA feature for document miners
+
+---

Old:

  gnome-online-miners-3.30.0.tar.xz

New:

  gnome-online-miners-3.34.0.tar.xz



Other differences:
--
++ gnome-online-miners.spec ++
--- /var/tmp/diff_new_pack.Zb3Hcr/_old  2019-10-17 13:00:45.329082364 +0200
+++ /var/tmp/diff_new_pack.Zb3Hcr/_new  2019-10-17 13:00:45.333082354 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gnome-online-miners
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2013 Dominique Leuenberger, Amsterdam, The Netherlands
 #
 # All modifications and additions to the file contributed by third parties
@@ -13,18 +13,19 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   gnome-online-miners
-Version:3.30.0
+Version:3.34.0
 Release:0
 Summary:Crawls through your online content
 License:GPL-2.0-or-later
 Group:  System/Libraries
-URL:http://download.gnome.org/sources/gnome-online-miners
-Source: 
http://download.gnome.org/sources/gnome-online-miners/3.30/%{name}-%{version}.tar.xz
+URL:https://wiki.gnome.org/Projects/GnomeOnlineMiners
+Source: 
https://download.gnome.org/sources/gnome-online-miners/3.34/%{name}-%{version}.tar.xz
+
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(gio-2.0)
 BuildRequires:  pkgconfig(glib-2.0) >= 2.35.1

++ gnome-online-miners-3.30.0.tar.xz -> gnome-online-miners-3.34.0.tar.xz 
++
 4201 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/gnome-online-miners-3.30.0/NEWS new/gnome-online-miners-3.34.0/NEWS
--- old/gnome-online-miners-3.30.0/NEWS 2018-09-04 12:25:14.0 +0200
+++ new/gnome-online-miners-3.34.0/NEWS 2019-09-11 17:21:47.0 +0200
@@ -1,3 +1,16 @@
+Overview of changes in 3.34.0
+=
+
+* None
+
+
+Overview of changes in 3.33.92
+==
+
+* Bugs fixed:
+ !34 Use Files GOA feature for document miners
+
+
 Overview of changes in 3.30.0
 =
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/gnome-online-miners-3.30.0/config/compile 
new/gnome-online-miners-3.34.0/config/compile
--- old/gnome-online-miners-3.30.0/config/compile   2018-09-04 
12:27:49.0 +0200
+++ new/gnome-online-miners-3.34.0/config/compile   2019-09-11 
17:23:53.0 +0200
@@ -1,9 +1,9 @@
 #! /bin/sh
 # Wrapper for compilers which do not understand '-c -o'.
 
-scriptversion=2016-01-11.22; # UTC
+scriptversion=2018-03-07.03; # UTC
 
-# Copyright (C) 1999-2017 Free Software Foundation, Inc.
+# Copyright (C) 1999-2018 Free Software Foundation, Inc.
 # Written by Tom Tromey .
 #
 # This program is free software; you can redistribute it and/or modify
@@ -17,7 +17,7 @@
 # GNU General Public License for more details.
 #
 # You should have received a copy of the GNU General Public License
-# along with this program.  If not, see 

commit gnome-photos for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-photos for openSUSE:Factory 
checked in at 2019-10-17 13:00:49

Comparing /work/SRC/openSUSE:Factory/gnome-photos (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-photos.new.2352 (New)


Package is "gnome-photos"

Thu Oct 17 13:00:49 2019 rev:49 rq:736554 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-photos/gnome-photos.changes
2019-08-24 18:42:58.741777130 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-photos.new.2352/gnome-photos.changes  
2019-10-17 13:00:50.797068511 +0200
@@ -1,0 +2,22 @@
+Wed Sep 11 17:50:04 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Sat Aug 31 09:14:56 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.91:
+  + build: Style fixes.
+  + flatpak:
+- Fix the exiv2 build.
+- Delete CMake-specific build files.
+- Update LibRaw to 0.19.4.
+- Fix the exiv2 build.
+- Switch babl to Meson.
+- Switch GEGL to Meson.
+- Switch libgdata to Meson.
+  + icons: Update the application icon
+- Require meson 0.50.0.
+
+---

Old:

  gnome-photos-3.32.1.tar.xz

New:

  gnome-photos-3.34.0.tar.xz



Other differences:
--
++ gnome-photos.spec ++
--- /var/tmp/diff_new_pack.0jhZ4j/_old  2019-10-17 13:00:51.353067103 +0200
+++ /var/tmp/diff_new_pack.0jhZ4j/_new  2019-10-17 13:00:51.357067093 +0200
@@ -17,19 +17,19 @@
 
 
 Name:   gnome-photos
-Version:3.32.1
+Version:3.34.0
 Release:0
 Summary:Photo viewer for GNOME
 License:GPL-3.0-or-later
 Group:  Productivity/Graphics/Viewers
 URL:https://wiki.gnome.org/Design/Apps/Photos
-Source0:
https://download.gnome.org/sources/gnome-photos/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-photos/3.34/%{name}-%{version}.tar.xz
 # PATCH-FIX-UPSTREAM gnome-photos-on-demand-activate-dleyna.patch bsc#992420, 
glgo#GNOME/gnome-photos#75 sck...@suse.com -- Activate dleyna-renderer-service 
on demand instead of on start-up.
 Patch0: gnome-photos-on-demand-activate-dleyna.patch
 
 BuildRequires:  desktop-file-utils
 BuildRequires:  fdupes
-BuildRequires:  meson
+BuildRequires:  meson >= 0.50.0
 # Technically seen, glib2-tools would require this, but it introduces a loop 
there. So explictly require here
 BuildRequires:  gdk-pixbuf-loader-rsvg
 BuildRequires:  itstool

++ gnome-photos-3.32.1.tar.xz -> gnome-photos-3.34.0.tar.xz ++
 4371 lines of diff (skipped)




commit gnome-shell for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-shell for openSUSE:Factory 
checked in at 2019-10-17 13:01:02

Comparing /work/SRC/openSUSE:Factory/gnome-shell (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-shell.new.2352 (New)


Package is "gnome-shell"

Thu Oct 17 13:01:02 2019 rev:165 rq:736560 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/gnome-shell/gnome-shell.changes  2019-07-31 
14:16:03.790724608 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-shell.new.2352/gnome-shell.changes
2019-10-17 13:01:05.757030612 +0200
@@ -1,0 +2,217 @@
+Wed Oct  9 10:26:03 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Fix "Frequent" view icons disappearing on hover
+  + Allow editing app folder names.
+  + Skip property transitions while hidden.
+  + Make menu animations more consistent.
+  + Improve performance when enabling/disabling all extensions.
+  + Fix extra icons appearing in "Frequent" view animation.
+  + Fix fading out desktop icons.
+  + Fix box-shadow glitch with prerendered resources.
+  + Fix accidentally skipped animations.
+  + Fix screenshots and window animations when scaled.
+  + Don't leak NOTIFY_SOCKET environment variable to applications.
+  + Fix lock-up on X11 when ibus is already running on startup.
+  + Fix screen dimming on idle.
+  + Do not notify systemd before initialization is complete.
+  + Support SAE secrets in network agent.
+  + Fix various regressions with dynamic workspaces.
+  + Fixed crashes.
+  + Misc. bug fixes and cleanups.
+  + Updated translations.
+
+---
+Sat Sep 21 17:10:28 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.0+148:
+  + shell-util: Do not scale the clip in
+get_content_for_window_actor()
+  + Update Galician translation
+  + screenShield: Stop using deprecated actor property
+  + unlockDialog: Use inheritance instead of composition
+  + loginDialog: Stop using deprecated actor property
+  + environment: Try harder to find a transition
+  + layout: Don't use the actors pick workaround on update regions
+  + renameFolderMenu: Use a custom menu item inheriting from
+PopupBaseMenuItem
+  + renameFolderMenu: Move to non-legacy coding style
+  + renameFolderMenu: Set the entry as menu focus actor
+  + popupMenu: Add focusActor property to define the default focus
+actor
+  + popupBaseMenuItem: Add support for Hidden Ornament
+  + renameFolderMenu: Don't save the source
+  + folderIcon: Remove duplicated addMenu call
+  + workspace: Fix an incorrect signal check
+  + appDisplay: Animate DnD app icons at the position they were
+dropped
+  + appDisplay: Add API to animate launch at given position
+  + workspace: Return results of forwarded acceptDrop
+  + overview: Only accept AppIcon drops if the app can open a new
+window
+  + shell-app: Never allow opening new windows while an app is
+starting
+  + workspace: Use AppIcon.app to check action-support by the drag
+source
+  + introspect: Check whitelist also for GetRunningWindows()
+  + st: Fix box-shadow drawing with prerendered_texture
+  + workspace: Remove unused properties of WindowClone
+  + viewSelector: Only reset search entry if it has key focus
+  + workspace: Reset idle hide timeout for overlays on reentry
+  + workspace: Make title of overlay reactive
+  + workspace: Continue overlay idle hide timeout when pointing at
+close button
+  + Updated translations.
+
+---
+Tue Sep 17 09:11:28 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.0+117:
+  + util: Handle trailing LTR/RTL markers in URLs
+  + cleanup: Don't add linebreak before operators
+  + cleanup: Disambiguate assignments in arrow functions
+  + cleanup: Remove trailing spaces
+  + cleanup: Fix up "special" comments
+  + cleanup: Use consistent brace style of blocks
+  + cleanup: Avoid pointless "renames" in destructuring
+  + cleanup: Avoid unnecessary parentheses in arrow functions
+  + cleanup: Avoid useless return statements
+  + cleanup: Don't use Array/Object constructors
+
+---
+Tue Sep 17 06:58:17 UTC 2019 - Chingkai Chu 
+
+- Rebase gnome-shell-864872-unlock-by-mouse-motion.patch to 3.34. 
+
+---
+Fri Sep 13 14:29:24 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.0+94:
+  + lookingGlass: Only update window list when visible
+  + ci: Disable MR handling for now
+  + ci: Disallow legacy style in merge requests
+  + ci: Fail on any common lint errors
+  + cleanup: Don't assume hasOwnProperty() method on objects
+  + cleanup: "Only" use two indentation styles for object literals
+  + cleanup: Stop using Mainloop module
+- Switch 

commit gnome-music for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-music for openSUSE:Factory 
checked in at 2019-10-17 13:00:37

Comparing /work/SRC/openSUSE:Factory/gnome-music (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-music.new.2352 (New)


Package is "gnome-music"

Thu Oct 17 13:00:37 2019 rev:45 rq:736549 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-music/gnome-music.changes  2019-07-13 
14:00:33.514895045 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-music.new.2352/gnome-music.changes
2019-10-17 13:00:38.665099246 +0200
@@ -1,0 +2,54 @@
+Tue Sep 10 09:58:19 CST 2019 - qk...@suse.com
+
+- Update to version 3.34.0:
+  + This release marks the first stable release after a invasive
+rewrite of Music internals and may still be rough around the edges.
+Regressions and known issues are kept track of in #299.
+  + A flatpak issue with cover art retrieval was fixed.
+  + Updated translations.
+
+---
+Sun Sep  8 10:05:11 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Bug fixes.
+
+---
+Sat Aug 31 09:21:15 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.90:
+  + Bug fixes.
+  + Search view rewrite and style update.
+  + Display an empty view if Tracker version is outdated.
+  + Updated translations.
+- Changes from version 3.33.4:
+  + Rewrite of the core of Music.
+  + Support gapless playback.
+  + MPRIS support rewrite.
+  + Playlists rewrite.
+  + Updated translations.
+- Changes from version 3.33.2:
+  + Improve Smooth progressbar support.
+  + Improve display of information for songs with no tags.
+  + Select a random song at launch when playing a playlist in
+shuffle mode.
+  + AppData tags update.
+  + MPRIS misc cleanups.
+  + Lots of general cleanups.
+  + Bugs fixed:
+- gnome-music crashes on startup.
+-  Stop using GtkBox:padding, GtkBox:fill and GtkBox:expand.
+- Do not rely on Tracker generated metadata.
+-  MPRIS2 reports wrong .desktop file name.
+-  Order of search and select buttons incorrect.
+- flatpak nightly: Clicking on MPRIS player launches wrong
+  version.
+- Incorrect timeline (progress bar) position for m4a file.
+- HeaderBar in selection mode has the search/cancel button
+  order wrong.
+- Repeat All Does Not Repeat Single Songs From Search.
+- Resuming Playback Actually Restarts Song.
+  + Updated translations.
+- Up gtk3, tracker-sparql, grilo, and grilo-plugins dependencies.
+
+---

Old:

  gnome-music-3.32.2.tar.xz

New:

  gnome-music-3.34.0.tar.xz



Other differences:
--
++ gnome-music.spec ++
--- /var/tmp/diff_new_pack.6zmod2/_old  2019-10-17 13:00:39.197097899 +0200
+++ /var/tmp/diff_new_pack.6zmod2/_new  2019-10-17 13:00:39.197097899 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   gnome-music
-Version:3.32.2
+Version:3.34.0
 Release:0
 Summary:Music Player for GNOME
 License:SUSE-GPL-2.0-with-plugin-exception AND LGPL-2.1-or-later
 Group:  Productivity/Multimedia/Sound/Players
 URL:https://www.gnome.org
-Source0:
https://download.gnome.org/sources/gnome-music/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-music/3.34/%{name}-%{version}.tar.xz
 Source99:   %{name}-rpmlintrc
 
 BuildRequires:  fdupes
@@ -34,15 +34,15 @@
 BuildRequires:  pkgconfig(glib-2.0) >= 2.36.0
 BuildRequires:  pkgconfig(goa-1.0)
 BuildRequires:  pkgconfig(gobject-introspection-1.0) >= 1.35.0
-BuildRequires:  pkgconfig(grilo-0.3) >= 0.3.4
-BuildRequires:  pkgconfig(grilo-plugins-0.3)
-BuildRequires:  pkgconfig(gtk+-3.0) >= 3.19.3
+BuildRequires:  pkgconfig(grilo-0.3) >= 0.3.8
+BuildRequires:  pkgconfig(grilo-plugins-0.3) >= 0.3.9
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.24.7
 BuildRequires:  pkgconfig(libdazzle-1.0) >= 3.28.0
 BuildRequires:  pkgconfig(libmediaart-2.0) >= 1.9.1
 BuildRequires:  pkgconfig(libsoup-2.4)
 BuildRequires:  pkgconfig(py3cairo) >= 1.14
 BuildRequires:  pkgconfig(pygobject-3.0) >= 3.29.1
-BuildRequires:  pkgconfig(tracker-sparql-2.0) >= 1.99.1
+BuildRequires:  pkgconfig(tracker-sparql-2.0) >= 2.2.0
 Requires:   dbus-1-python3
 # gnome-music requires grilo-plugin-tracker to interact with tracker and find 
files (bsc#1083659)
 Requires:   grilo-plugin-tracker

++ gnome-music-3.32.2.tar.xz -> gnome-music-3.34.0.tar.xz ++
 36611 lines of diff (skipped)




commit gnome-maps for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-maps for openSUSE:Factory 
checked in at 2019-10-17 13:00:27

Comparing /work/SRC/openSUSE:Factory/gnome-maps (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-maps.new.2352 (New)


Package is "gnome-maps"

Thu Oct 17 13:00:27 2019 rev:47 rq:736547 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/gnome-maps/gnome-maps.changes2019-06-03 
18:49:56.980545842 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-maps.new.2352/gnome-maps.changes  
2019-10-17 13:00:32.201115622 +0200
@@ -1,0 +2,67 @@
+Mon Oct  7 19:57:49 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Update tile size to 512 px when using --local option.
+  + Updated translations.
+
+---
+Tue Sep 10 13:47:23 CST 2019 - qk...@suse.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Sat Sep  7 22:41:01 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.33.92:
+  + Update OSM POI types.
+  + Fix performance issue when there's lots of location updates.
+  + Updated translations.
+
+---
+Sat Aug 31 18:43:43 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.91:
+  + Updated translations.
+  + Changes in version 3.33.90:
+  + Fix bug going back to already selected place from the search
+result list.
+  + Start immediatly at the last viewed location when app was
+closed last.
+  + Remember the map type (street or aerial) from when the app
+was closed last.
+  + Updated translations.
+  + Changes in version 3.33.4:
+  + Handle opening OpenStreetMap URLs pointing to either an
+object or bare coordinates by pasting it into the search entry
+and also as a program argument, in the same manner as with
+geo: URIs.
+  + Updated translations.
+  + Changes in version 3.33.3:
+  + Auto-complete searches ("search-as-you-type") using
+GraphHopper geocoder / Photon.
+  + Redesigned Send to-dialog with ability to copy and send
+locations in e-mails and better integration with Weather and
+Clocks.
+  + Show clockwise roundabout icons for turn-by-turn routing in
+left-hand traffic countries and territories.
+  + Update appdata screenshots with tile style.
+  + Fix a crash when there's many contacts with addresses in
+an Evolution address book.
+  + Updated translations.
+  + Changes in version 3.33.2:
+  + Accept additional formats when entering raw coordinates in
+the search entry (decimal lat/lon degrees format with literal
+° symbol, and degrees, minutes, second format).
+  + Updated translations.
+  + Changes in version 3.33.1:
+  + Stop using GtkOffscreenWindow (prerequisite for eventually
+porting to GTK 4).
+  + Fix printing dialog not closing in some circumstances.
+  + Add some missing appstream metadata.
+  + Add tests validating appdata and desktop files.
+  + Remove some unnessesary instructions in turn-by-turn route
+searches.
+  + Updated translations.
+
+---

Old:

  gnome-maps-3.32.2.1.tar.xz

New:

  gnome-maps-3.34.1.tar.xz



Other differences:
--
++ gnome-maps.spec ++
--- /var/tmp/diff_new_pack.umG8VE/_old  2019-10-17 13:00:33.057113454 +0200
+++ /var/tmp/diff_new_pack.umG8VE/_new  2019-10-17 13:00:33.065113434 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   gnome-maps
-Version:3.32.2.1
+Version:3.34.1
 Release:0
 Summary:Maps Application for GNOME
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Apps/Maps
-Source0:
https://download.gnome.org/sources/gnome-maps/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-maps/3.34/%{name}-%{version}.tar.xz
 
 # Needed for typelib() Requires
 BuildRequires:  gobject-introspection

++ gnome-maps-3.32.2.1.tar.xz -> gnome-maps-3.34.1.tar.xz ++
 36551 lines of diff (skipped)




commit gnome-logs for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-logs for openSUSE:Factory 
checked in at 2019-10-17 13:00:21

Comparing /work/SRC/openSUSE:Factory/gnome-logs (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-logs.new.2352 (New)


Package is "gnome-logs"

Thu Oct 17 13:00:21 2019 rev:33 rq:736545 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-logs/gnome-logs.changes2019-05-03 
22:10:41.923308884 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-logs.new.2352/gnome-logs.changes  
2019-10-17 13:00:22.641139842 +0200
@@ -1,0 +2,25 @@
+Tue Sep 10 06:01:38 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Avoid segfault when updating the boot menu.
+  + Fix application name in about dialog.
+  + Fixed unfunctional translations in meson.
+  + updates to Basque, Friulian, Persian and Catalan translations.
+
+---
+Mon Sep  2 19:49:49 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.2:
+  + removing tests option in meson build system.
+  + update to Chinese (China) translation.
+  + Changes in version 3.33.1:
+  + Fixed abnormal headerbar height.
+  + Dropped autotools support.
+  + Fixed manpage check and version number in meson.
+  + Adding flatpak manifest and gitlab ci.
+  + Updates to Croatian and Danish translations.
+- Don't pass -Dtests=false to meson anymore; option was deleted
+  from meson.build.
+- Remove ABOUT-NLS and ChangeLog from files: no longer installed.
+
+---

Old:

  gnome-logs-3.32.1.tar.xz

New:

  gnome-logs-3.34.0.tar.xz



Other differences:
--
++ gnome-logs.spec ++
--- /var/tmp/diff_new_pack.1LcAYB/_old  2019-10-17 13:00:23.141138575 +0200
+++ /var/tmp/diff_new_pack.1LcAYB/_new  2019-10-17 13:00:23.145138565 +0200
@@ -18,13 +18,13 @@
 
 
 Name:   gnome-logs
-Version:3.32.1
+Version:3.34.0
 Release:0
 Summary:GNOME System Log Viewer
 License:GPL-3.0-or-later
 Group:  System/X11/Utilities
 URL:https://wiki.gnome.org/Apps/Logs
-Source0:
https://download.gnome.org/sources/gnome-logs/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-logs/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  fdupes
@@ -52,7 +52,6 @@
 
 %build
 %meson \
-   -Dtests=false \
-Dman=true \
%{nil}
 %meson_build
@@ -65,7 +64,7 @@
 
 %files
 %license COPYING
-%doc ABOUT-NLS AUTHORS ChangeLog NEWS README
+%doc AUTHORS NEWS README
 %doc %{_datadir}/help/C/gnome-logs/
 %{_bindir}/%{name}
 %{_datadir}/metainfo/org.gnome.Logs.appdata.xml

++ gnome-logs-3.32.1.tar.xz -> gnome-logs-3.34.0.tar.xz ++
 39567 lines of diff (skipped)




commit gnome-keyring for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-keyring for openSUSE:Factory 
checked in at 2019-10-17 13:00:13

Comparing /work/SRC/openSUSE:Factory/gnome-keyring (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-keyring.new.2352 (New)


Package is "gnome-keyring"

Thu Oct 17 13:00:13 2019 rev:136 rq:736543 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-keyring/gnome-keyring.changes  
2019-05-03 22:17:23.940101291 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-keyring.new.2352/gnome-keyring.changes
2019-10-17 13:00:17.325153309 +0200
@@ -1,0 +2,10 @@
+Mon Sep 30 09:50:54 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + dbus-environment: Race fix in Setenv request to gnome-session.
+  + egg: Request that secure memory not be dumped to disk.
+  + Build and test fixes.
+  + Updated translations.
+- Refresh gnome-keyring-pam-auth-prompt-password.patch with quilt.
+
+---

Old:

  gnome-keyring-3.31.91.tar.xz

New:

  gnome-keyring-3.34.0.tar.xz



Other differences:
--
++ gnome-keyring.spec ++
--- /var/tmp/diff_new_pack.sHgaCZ/_old  2019-10-17 13:00:18.205151080 +0200
+++ /var/tmp/diff_new_pack.sHgaCZ/_new  2019-10-17 13:00:18.205151080 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   gnome-keyring
-Version:3.31.91
+Version:3.34.0
 Release:0
 Summary:GNOME Keyring
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/GUI/GNOME
 Url:https://wiki.gnome.org/Projects/GnomeKeyring
-Source0:
https://download.gnome.org/sources/gnome-keyring/3.31/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-keyring/3.34/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 
 # PATCH-FIX-OPENSUSE gnome-keyring-pam-auth-prompt-password.patch bnc#466732 
bgo#560488 vu...@novell.com -- Make the pam module prompt the password in auth, 
so we can use pam-config. This is a workaround until bnc#477488 is implemented.

++ gnome-keyring-3.31.91.tar.xz -> gnome-keyring-3.34.0.tar.xz ++
 9592 lines of diff (skipped)

++ gnome-keyring-pam-auth-prompt-password.patch ++
--- /var/tmp/diff_new_pack.sHgaCZ/_old  2019-10-17 13:00:18.841149469 +0200
+++ /var/tmp/diff_new_pack.sHgaCZ/_new  2019-10-17 13:00:18.841149469 +0200
@@ -1,8 +1,8 @@
-Index: gnome-keyring-3.31.90/pam/gkr-pam-module.c
+Index: gnome-keyring-3.34.0/pam/gkr-pam-module.c
 ===
 gnome-keyring-3.31.90.orig/pam/gkr-pam-module.c2018-12-29 
16:41:53.0 +0100
-+++ gnome-keyring-3.31.90/pam/gkr-pam-module.c 2019-02-21 11:49:08.910227458 
+0100
-@@ -872,12 +872,27 @@ pam_sm_authenticate (pam_handle_t *ph, i
+--- gnome-keyring-3.34.0.orig/pam/gkr-pam-module.c
 gnome-keyring-3.34.0/pam/gkr-pam-module.c
+@@ -874,12 +874,27 @@ pam_sm_authenticate (pam_handle_t *ph, i
/* Look up the password */
ret = pam_get_item (ph, PAM_AUTHTOK, (const void**));
if (ret != PAM_SUCCESS || password == NULL) {




commit gnome-boxes for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-boxes for openSUSE:Factory 
checked in at 2019-10-17 12:59:19

Comparing /work/SRC/openSUSE:Factory/gnome-boxes (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-boxes.new.2352 (New)


Package is "gnome-boxes"

Thu Oct 17 12:59:19 2019 rev:64 rq:736528 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/gnome-boxes/gnome-boxes.changes  2019-09-11 
10:18:12.231527064 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-boxes.new.2352/gnome-boxes.changes
2019-10-17 12:59:21.589294511 +0200
@@ -1,0 +2,58 @@
+Mon Oct  7 16:52:56 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Prevent machine names from expanding the icon view.
+  + Recommend Debian 10 and Endless OS 3.6 in "Download an OS".
+  + Updated translations.
+
+---
+Tue Sep 10 10:29:34 CST 2019 - qk...@suse.com
+
+- Update to version 3.34.0:
+  + Only show supported architectures in "Download an OS" page.
+  + Fix crash with media enumeration.
+  + Adjust appdata to pass the strict validation.
+  + Updated translations.
+
+---
+Fri Sep  6 21:00:13 UTC 2019 - mgo...@suse.com
+
+- Update to version 3.33.90:
+  + Auto enable boot menu for VMs with a CD/DVD assigned.
+  + Modernize the unnatended installation code.
+  + Prefer initrd over disk as injection method.
+  + Various Flatpak/CI build fixes.
+  + Print '-h' as the help commandline option (instead of -?).
+  + Wrap size and DnD overlays in OSD for better readability.
+  + Updated translations.
+- Changes from version 3.33.3:
+  + Split new box assistant into two (remote and virtual machines).
+  + Use 3.32 Sdk and Runtime for CI.
+  + Drop option to Share Clipboard (now it is always shared).
+  + Add tooltips for media entries in the assistant.
+  + Updated translations.
+  + Changes in version 3.33.2:
+  + Add 3D acceleration option to VM Properties dialog.
+  + Convert collection switcher to GtkRadioButtons to avoid
+multi-selection.
+  + Stop enabling virtio-gpu by default to new installs (make
+it opt-in).
+  + Use spice_main_channel_file_copy_async instead of deprecated
+API.
+  + Pass username and port to openssh while connecting.
+  + Take screenshots with Gtk, instead of delegating to the
+display widget.
+  + Don't duplicate Recommended Downloads in the "Show All" list.
+  + Updated translations.
+- Changes from version 3.33.1:
+  + Drop oVirt support.
+  + Add missing oxford comma to wizard-source.
+  + Use GtkFileChooserNative for the CD/DVD chooser.
+  + Don't steal input from username entry in express installs.
+  + Fix "Download an OS" search issue with modifier keys.
+  + Rename pango attribute incorrectly localized.
+  + Add CentOS logo.
+  + Updated translations.
+- Drop govirt dependency.
+
+---

Old:

  gnome-boxes-3.32.2.tar.xz

New:

  gnome-boxes-3.34.1.tar.xz



Other differences:
--
++ gnome-boxes.spec ++
--- /var/tmp/diff_new_pack.6twpMc/_old  2019-10-17 12:59:22.577292008 +0200
+++ /var/tmp/diff_new_pack.6twpMc/_new  2019-10-17 12:59:22.581291998 +0200
@@ -22,13 +22,13 @@
 %define govf_sover 0.1
 %define gfrdp_sover 0.1
 Name:   gnome-boxes
-Version:3.32.2
+Version:3.34.1
 Release:0
 Summary:A GNOME 3 application to access remote or virtual systems
 License:LGPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Design/Apps/Boxes
-Source0:
https://download.gnome.org/sources/gnome-boxes/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-boxes/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 BuildRequires:  meson >= 0.47.0
@@ -42,12 +42,11 @@
 BuildRequires:  pkgconfig(glib-2.0) >= 2.44.0
 BuildRequires:  pkgconfig(gobject-2.0) >= 2.44.0
 BuildRequires:  pkgconfig(gobject-introspection-1.0) >= 0.9.6
-BuildRequires:  pkgconfig(govirt-1.0) >= 0.3.4
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.22.20
 BuildRequires:  pkgconfig(gtk-vnc-2.0) >= 0.4.4
 BuildRequires:  pkgconfig(gudev-1.0) >= 165
 BuildRequires:  pkgconfig(libarchive) >= 3.0.0
-BuildRequires:  pkgconfig(libosinfo-1.0) >= 1.1.0
+BuildRequires:  pkgconfig(libosinfo-1.0) >= 1.4.0
 BuildRequires:  pkgconfig(libsecret-1)
 BuildRequires:  pkgconfig(libsoup-2.4) >= 2.38
 BuildRequires:  pkgconfig(libusb-1.0) >= 1.0.9

++ gnome-boxes-3.32.2.tar.xz -> gnome-boxes-3.34.1.tar.xz ++
 30866 lines of diff (skipped)




commit gnome-control-center for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-control-center for 
openSUSE:Factory checked in at 2019-10-17 12:59:42

Comparing /work/SRC/openSUSE:Factory/gnome-control-center (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-control-center.new.2352 (New)


Package is "gnome-control-center"

Thu Oct 17 12:59:42 2019 rev:182 rq:736535 version:3.34.1

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-control-center/gnome-control-center.changes
2019-08-15 12:24:49.218614874 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-control-center.new.2352/gnome-control-center.changes
  2019-10-17 12:59:49.381224103 +0200
@@ -1,0 +2,77 @@
+Sat Oct  5 14:34:11 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Background:
+- Allow load background file relative to XML file.
+- Update clock in both preview modes.
+  + Date & Time: Allow changing the timezone when auto-update is
+prohibited.
+  + Network:
+- Disable the "Apply" button until a change has been made.
+- Fix Add Connection dialog.
+- Accept empty values for the cloned mac address.
+  + Online Accounts: Fix a crash.
+  + Printers:
+- Give printer name fewer characters in width.
+- Check whether URI is valid while searching for printers.
+  + Region & Language: Fix crash in keyboard layout population.
+  + Search: Fix crash on clicking 'Search Locations'.
+  + Sharing: Set new shared folder visible as soon as it gets
+added.
+  + Sound: Remove leftover canberra-gtk header inclusion.
+  + Updated translations.
+- Drop patches fixed upstream:
+  + gnome-control-center-Remove-leftover-canberra-gtk.patch.
+  + control-center-network-fix-ce-apply-button.patch.
+
+---
+Sat Sep 21 09:38:32 UTC 2019 - Bjørn Lie 
+
+- Add gnome-control-center-Remove-leftover-canberra-gtk.patch:
+  sound: Remove leftover canberra-gtk header inclusion. Following
+  this, drop pkgconfig(libcanberra-gtk3) BuildRequires: No longer
+  needed, nor used.
+- Add explicit xorg-x11-server-Xvfb BuildRequires: Previously
+  pulled in by libcanberra-gtk3. Needed for tests to succeed.
+
+---
+Mon Sep  9 14:46:21 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0.1:
+  + Sound: fix sliders not behaving properly.
+  + Changes in version 3.34.0:
+  + Updated translations.
+
+---
+Wed Sep  4 15:28:03 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.90:
+  + Background: Clarify remove background button.
+  + Display: Various bugfixes.
+  + Search:
+- Introduce Drag n' Drop
+- Visual polishment.
+  + Updated translations.
+- Changes from version 3.33.3:
+  + Various minor improvements from the Every Detail Matters
+session.
+  + Add shadows to application icons
+  + Documented Communication Guidelines
+  + Development builds with Flatpak working again
+  + Background: Redesigned panel.
+  + Display: Move Night Light to a tab, instead of a dialog.
+  + Keyboard Shortcuts:
+- Panel renamed from "Keyboard".
+- Minor UI adjustments.
+  + Mouse & Touchpad: Reinstate keyboard navitation.
+  + Power: Don't treat all batteries as laptop batteries.
+  + Sharing: Use a HdyLeaflet.
+  + User Accounts: Present the default avatar in the avatar
+popover.
+  + Wacom: Ensure calibrator UI CSS only applies to its UI.
+  + Updated translations.
+- Remove control-center-fix-mtu-label.patch
+- Remove control-center-network-add-domain-suffix-match.patch
+- Remove gnome-control-center-disable-error-message-for-NM.patch
+
+---

Old:

  _servicedata
  control-center-fix-mtu-label.patch
  control-center-network-add-domain-suffix-match.patch
  control-center-network-fix-ce-apply-button.patch
  gnome-control-center-3.32.2+9.obscpio
  gnome-control-center-disable-error-message-for-NM.patch

New:

  gnome-control-center-3.34.1.obscpio



Other differences:
--
++ gnome-control-center.spec ++
--- /var/tmp/diff_new_pack.4rrua0/_old  2019-10-17 12:59:50.777220566 +0200
+++ /var/tmp/diff_new_pack.4rrua0/_new  2019-10-17 12:59:50.781220556 +0200
@@ -26,24 +26,14 @@
 %endif
 
 Name:   gnome-control-center
-Version:3.32.2+9
+Version:3.34.1
 Release:0
 Summary:The GNOME Control Center
 License:GPL-2.0-or-later
 Group:  System/GUI/GNOME
 URL:https://www.gnome.org
-# We are using source services, so no download url for source
 Source0:%{name}-%{version}.tar.xz
 
-# PATCH-NEEDS-OPENSUSE gnome-control-center-disable-error-message-for-NM.patch 
bsc#989801 

commit gnome-disk-utility for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-disk-utility for 
openSUSE:Factory checked in at 2019-10-17 12:59:58

Comparing /work/SRC/openSUSE:Factory/gnome-disk-utility (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-disk-utility.new.2352 (New)


Package is "gnome-disk-utility"

Thu Oct 17 12:59:58 2019 rev:66 rq:736537 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-disk-utility/gnome-disk-utility.changes
2019-05-03 22:14:00.419695028 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-disk-utility.new.2352/gnome-disk-utility.changes
  2019-10-17 13:00:00.209196671 +0200
@@ -1,0 +2,45 @@
+Sun Sep  8 21:15:52 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Flatpak: Remove unnecessary udev module.
+  + Convert README to markdown.
+  + Updated translations.
+- README -> README.md in %doc.
+
+---
+Tue Sep  3 10:27:30 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.92:
+  + Build documentation for Flatpak.
+  + Flatpak manifest fixes.
+  + Updated translations.
+
+---
+Sun Sep  1 12:26:27 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.91:
+  + Updated translations.
+  + Changes in version 3.33.90:
+  + Labels for toolbar items added for accessibility.
+  + Mark missing string for translation.
+  + Updated translations.
+  + Changes in version 3.33.4:
+  + build: Various meson updates (many commits).
+  + build: Add flatpak manifest.
+  + ci: Add basic CI support.
+  + ci: Add support for flatpak building.
+  + README/INSTALL update and info for Flatpak usage for development
+  + Updated translations.
+  + Changes in version 3.33.3:
+  + build: Define logind as combo option of 'libsystemd',
+'libelogind', 'none'.
+  + Don't require filesystem label when formatting.
+  + build: remove autodetection of features and require a recent
+UDisks.
+  + build: add elogind support for seat retrieval.
+  + Rephrase English confirmation message.
+  + Updated translations.
+- Up udisks dependency.
+- Require meson >= 0.50.0.
+
+---

Old:

  gnome-disk-utility-3.32.1.tar.xz

New:

  gnome-disk-utility-3.34.0.tar.xz



Other differences:
--
++ gnome-disk-utility.spec ++
--- /var/tmp/diff_new_pack.yuTTlL/_old  2019-10-17 13:00:00.645195567 +0200
+++ /var/tmp/diff_new_pack.yuTTlL/_new  2019-10-17 13:00:00.649195556 +0200
@@ -17,16 +17,16 @@
 
 
 Name:   gnome-disk-utility
-Version:3.32.1
+Version:3.34.0
 Release:0
 Summary:Disks application for dealing with storage devices
 License:GPL-2.0-or-later
 Group:  Hardware/Other
 URL:https://wiki.gnome.org/Apps/Disks
-Source0:
https://download.gnome.org/sources/gnome-disk-utility/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-disk-utility/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  docbook-xsl-stylesheets
-BuildRequires:  meson
+BuildRequires:  meson >= 0.50.0
 BuildRequires:  pkgconfig
 BuildRequires:  translation-update-upstream
 BuildRequires:  update-desktop-files
@@ -41,7 +41,7 @@
 BuildRequires:  pkgconfig(libsecret-1) >= 0.7
 BuildRequires:  pkgconfig(libsystemd) >= 209
 BuildRequires:  pkgconfig(pwquality) >= 1.0.0
-BuildRequires:  pkgconfig(udisks2) >= 2.7.2
+BuildRequires:  pkgconfig(udisks2) >= 2.7.6
 Requires:   udisks2
 
 %description
@@ -68,7 +68,7 @@
 
 %files
 %license COPYING
-%doc AUTHORS HACKING NEWS README TODO
+%doc AUTHORS HACKING NEWS README.md TODO
 %{_bindir}/gnome-disks
 %{_bindir}/gnome-disk-image-mounter
 %{_datadir}/applications/*.desktop

++ gnome-disk-utility-3.32.1.tar.xz -> gnome-disk-utility-3.34.0.tar.xz 
++
 43543 lines of diff (skipped)




commit gnome-documents for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-documents for openSUSE:Factory 
checked in at 2019-10-17 13:00:03

Comparing /work/SRC/openSUSE:Factory/gnome-documents (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-documents.new.2352 (New)


Package is "gnome-documents"

Thu Oct 17 13:00:03 2019 rev:65 rq:736538 version:3.33.90

Changes:

--- /work/SRC/openSUSE:Factory/gnome-documents/gnome-documents.changes  
2019-08-16 15:29:38.913978426 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-documents.new.2352/gnome-documents.changes
2019-10-17 13:00:04.837184946 +0200
@@ -1,0 +2,6 @@
+Thu Sep  5 20:18:57 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.90:
+  + Update translations.
+
+---

Old:

  gnome-documents-3.32.0.tar.xz

New:

  gnome-documents-3.33.90.tar.xz



Other differences:
--
++ gnome-documents.spec ++
--- /var/tmp/diff_new_pack.2Py0mN/_old  2019-10-17 13:00:05.621182961 +0200
+++ /var/tmp/diff_new_pack.2Py0mN/_new  2019-10-17 13:00:05.633182930 +0200
@@ -21,13 +21,13 @@
 %global __requires_exclude typelib\\(LOKDocView\\)
 %endif
 Name:   gnome-documents
-Version:3.32.0
+Version:3.33.90
 Release:0
 Summary:Document Manager for GNOME
 License:GPL-2.0-or-later
 Group:  Productivity/Office/Other
 URL:https://wiki.gnome.org/Apps/Documents
-Source0:
https://download.gnome.org/sources/gnome-documents/3.32/%{name}-%{version}.tar.xz
+Source0:
http://download.gnome.org/sources/gnome-documents/3.33/%{name}-%{version}.tar.xz
 
 BuildRequires:  desktop-file-utils
 BuildRequires:  fdupes

++ gnome-documents-3.32.0.tar.xz -> gnome-documents-3.33.90.tar.xz ++
 17872 lines of diff (skipped)




commit gnome-contacts for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-contacts for openSUSE:Factory 
checked in at 2019-10-17 12:59:34

Comparing /work/SRC/openSUSE:Factory/gnome-contacts (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-contacts.new.2352 (New)


Package is "gnome-contacts"

Thu Oct 17 12:59:34 2019 rev:57 rq:736534 version:3.34

Changes:

--- /work/SRC/openSUSE:Factory/gnome-contacts/gnome-contacts.changes
2019-06-22 11:23:30.309343235 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-contacts.new.2352/gnome-contacts.changes  
2019-10-17 12:59:37.501254199 +0200
@@ -1,0 +2,30 @@
+Wed Sep 11 21:17:51 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34:
+  + Updated translations.
+
+---
+Wed Sep  4 09:06:43 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.92:
+  + Updated the man page.
+  + Updated translations.
+  + Changes in version 3.33.91:
+  + Make the avatars more in line with the other apps in the GNOME
+ecosystem.
+  + Fix searching contacts from GNOME Shell returning no results.
+  + Add a small description of the --search option.
+  + Updated translations.
+  + Changes in version 3.33.4:
+  + Flatpak: Allow webcam access (and other small fixes).
+  + Even better integration with CI.
+  + Add mnemonics to the setup window.
+  + Updated translations.
+  + Changes in version 3.33.1:
+  + Added a show-contact application action, so other applications
+can activate Contacts to show a specific contact.
+  + Updated translations.
+- Drop gnome-contacts-disambiguate_Gtk.HeaderBar.patch: fixed
+upstream.
+
+---

Old:

  gnome-contacts-3.32.1.tar.xz
  gnome-contacts-disambiguate_Gtk.HeaderBar.patch

New:

  gnome-contacts-3.34.tar.xz



Other differences:
--
++ gnome-contacts.spec ++
--- /var/tmp/diff_new_pack.ObJMWl/_old  2019-10-17 12:59:37.893253206 +0200
+++ /var/tmp/diff_new_pack.ObJMWl/_new  2019-10-17 12:59:37.897253196 +0200
@@ -17,15 +17,13 @@
 
 
 Name:   gnome-contacts
-Version:3.32.1
+Version:3.34
 Release:0
 Summary:Contacts Manager for GNOME
 License:GPL-2.0-or-later
 Group:  Productivity/Office/Other
 URL:https://wiki.gnome.org/Apps/Contacts
-Source0:
https://download.gnome.org/sources/gnome-contacts/3.32/%{name}-%{version}.tar.xz
-# PATCH-FIX-UPSTREAM gnome-contacts-disambiguate_Gtk.HeaderBar.patch -- 
window: Disambiguate Gtk.HeaderBar
-Patch0: gnome-contacts-disambiguate_Gtk.HeaderBar.patch
+Source0:
https://download.gnome.org/sources/gnome-contacts/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  docbook_4

++ gnome-contacts-3.32.1.tar.xz -> gnome-contacts-3.34.tar.xz ++
 14615 lines of diff (skipped)




commit gnome-calculator for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-calculator for 
openSUSE:Factory checked in at 2019-10-17 12:59:24

Comparing /work/SRC/openSUSE:Factory/gnome-calculator (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-calculator.new.2352 (New)


Package is "gnome-calculator"

Thu Oct 17 12:59:24 2019 rev:44 rq:736530 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/gnome-calculator/gnome-calculator.changes
2019-06-30 10:19:53.863470720 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-calculator.new.2352/gnome-calculator.changes  
2019-10-17 12:59:25.609284327 +0200
@@ -1,0 +2,50 @@
+Mon Oct  7 07:45:36 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Created nightly app icon.
+  + Snap build improvements.
+  + Updated translations.
+
+---
+Tue Sep 10 10:15:35 CST 2019 - qk...@suse.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Mon Sep  2 19:20:17 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.33.92:
+  + README updates.
+  + Updated translations.
+- Changes from version 3.33.90:
+  + Flatpak build cleanup.
+  + Debug messages cleanup.
+  + Updated translations.
+- Changes from version 3.33.3:
+  + calculator library build fixes.
+  + CI build fixes.
+  + Added mnemonics for primary menu items.
+  + Dropped leading zeros octal prefix.
+  + Updated translations.
+- Changes from version 3.33.2:
+  + Separated calculator library.
+  + Ensure icon is available for shell.
+  + Support entering left/right shift with keyboard.
+  + Fixed CFA conversion rate.
+  + Remove copy icon from search provider results.
+  + Do not assume octal base for binary numbers.
+  + Show thousands separator in unit converter.
+  + Use currency name instead of display name for conversion.
+  + Quit warns and closes all windows.
+  + Avoid normalizing the equation twice in search.
+  + Ignore keypresses while calculating results.
+  + Only allow one decimal point in numbers.
+  + Application icon updated in help.
+  + Updated translations.
+- Add pkgconfig(gee-0.8) BuildRequires: New dependency.
+- Package new sub-packages gnome-calculator-devel and libgcalc-1.
+  Also handle shared library in post(un), and set needed Requires
+  in devel package.
+
+---

Old:

  gnome-calculator-3.32.2.tar.xz

New:

  gnome-calculator-3.34.1.tar.xz



Other differences:
--
++ gnome-calculator.spec ++
--- /var/tmp/diff_new_pack.MeGkrS/_old  2019-10-17 12:59:26.085283121 +0200
+++ /var/tmp/diff_new_pack.MeGkrS/_new  2019-10-17 12:59:26.089283110 +0200
@@ -16,14 +16,16 @@
 #
 
 
+%define sover 1-0_0_0
+
 Name:   gnome-calculator
-Version:3.32.2
+Version:3.34.1
 Release:0
 Summary:A GNOME Calculator Application
 License:GPL-3.0-or-later
 Group:  Productivity/Scientific/Math
 URL:https://wiki.gnome.org/Apps/Calculator
-Source0:
https://download.gnome.org/sources/gnome-calculator/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-calculator/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 BuildRequires:  meson
@@ -33,6 +35,7 @@
 BuildRequires:  translation-update-upstream
 BuildRequires:  vala
 BuildRequires:  yelp-tools
+BuildRequires:  pkgconfig(gee-0.8)
 BuildRequires:  pkgconfig(gio-2.0) >= 2.40
 BuildRequires:  pkgconfig(glib-2.0) >= 2.40
 BuildRequires:  pkgconfig(gmodule-export-2.0)
@@ -55,6 +58,23 @@
 This package contains a search provider to enable GNOME Shell to get
 search results from GNOME Calculator.
 
+%package -n libgcalc-%{sover}
+Summary:Shared library for %{name}
+Group:  System/Libraries
+
+%description -n libgcalc-%{sover}
+This package contains the shared library for %{name}.
+
+%package devel
+Summary:Development files for %{name}
+Group:  Development/Libraries/GNOME
+Requires:   %{name} = %{version}
+Requires:   libgcalc-%{sover} = %{version}
+
+%description devel
+The %{name}-devel package contains libraries and header files for
+developing applications that use %{name}.
+
 %lang_package
 
 %prep
@@ -73,6 +93,9 @@
 %check
 %meson_test
 
+%post -n libgcalc-%{sover} -p /sbin/ldconfig
+%postun -n libgcalc-%{sover} -p /sbin/ldconfig
+
 %files
 %license COPYING
 %doc NEWS
@@ -93,6 +116,22 @@
 
%{_datadir}/gnome-shell/search-providers/org.gnome.Calculator-search-provider.ini
 %{_libexecdir}/gnome-calculator-search-provider
 
+%files -n libgcalc-%{sover}
+%{_libdir}/libgcalc-1.so.*
+
+%files devel
+%dir %{_includedir}/gcalc-1
+%dir %{_includedir}/gcalc-1/gcalc

commit gnome-clocks for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-clocks for openSUSE:Factory 
checked in at 2019-10-17 12:59:29

Comparing /work/SRC/openSUSE:Factory/gnome-clocks (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-clocks.new.2352 (New)


Package is "gnome-clocks"

Thu Oct 17 12:59:29 2019 rev:39 rq:736533 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-clocks/gnome-clocks.changes
2019-05-03 22:10:26.799278174 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-clocks.new.2352/gnome-clocks.changes  
2019-10-17 12:59:31.761268741 +0200
@@ -1,0 +2,15 @@
+Wed Sep 11 05:48:06 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Sat Aug 31 19:11:38 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.1:
+  + Expose world clock locations to gnome-shell.
+  + Updated translations.
+- Remove /usr/share/gnome-clocks from files: images have been
+  moved to a GResource.
+
+---

Old:

  gnome-clocks-3.32.0.tar.xz

New:

  gnome-clocks-3.34.0.tar.xz



Other differences:
--
++ gnome-clocks.spec ++
--- /var/tmp/diff_new_pack.4HrD3c/_old  2019-10-17 12:59:32.165267718 +0200
+++ /var/tmp/diff_new_pack.4HrD3c/_new  2019-10-17 12:59:32.165267718 +0200
@@ -18,16 +18,16 @@
 
 
 Name:   gnome-clocks
-Version:3.32.0
+Version:3.34.0
 Release:0
 Summary:Clock application designed for GNOME 3
 License:GPL-2.0-or-later
 Group:  Productivity/Office/Other
 URL:https://live.gnome.org/Design/Apps/Clock
-Source0:
https://download.gnome.org/sources/gnome-clocks/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-clocks/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
-BuildRequires:  meson >= 0.41.0
+BuildRequires:  meson >= 0.50.0
 BuildRequires:  pkgconfig
 BuildRequires:  translation-update-upstream
 BuildRequires:  vala >= 0.23.3
@@ -74,10 +74,9 @@
 
 %files
 %license COPYING
-%doc README
+%doc README.md
 %doc %{_datadir}/help/C/gnome-clocks/
 %{_bindir}/%{name}
-%{_datadir}/%{name}/
 %dir %{_datadir}/metainfo
 %{_datadir}/metainfo/org.gnome.clocks.appdata.xml
 %{_datadir}/dbus-1/services/org.gnome.clocks.service

++ gnome-clocks-3.32.0.tar.xz -> gnome-clocks-3.34.0.tar.xz ++
 2725 lines of diff (skipped)




commit gnome-desktop for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-desktop for openSUSE:Factory 
checked in at 2019-10-17 12:59:53

Comparing /work/SRC/openSUSE:Factory/gnome-desktop (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-desktop.new.2352 (New)


Package is "gnome-desktop"

Thu Oct 17 12:59:53 2019 rev:151 rq:736536 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/gnome-desktop/gnome-desktop.changes  
2019-05-10 09:17:21.640239365 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-desktop.new.2352/gnome-desktop.changes
2019-10-17 12:59:55.153209480 +0200
@@ -1,0 +2,42 @@
+Tue Oct  8 08:19:00 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Updated translations.
+
+---
+Tue Sep 10 05:47:42 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Wed Sep  4 20:55:25 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.92.1:
+  + tests/wall*: Do not fail if some of the locales is missing.
+- Changes in version 3.33.92:
+  + Updated translations.
+- Changes in version 3.33.91:
+  + Updated translations.
+- Changes in version 3.33.90:
+  + Avoid using g_type_class_add_private().
+  + Updated translations.
+- Changes in version 3.33.4:
+  + Support common_name in ISO 639.
+  + Display locale @modifiers properly.
+  + Fix detection of builtin display on NVIDIA.
+  + GnomeBGSlideShow filename property replaced with a file
+property.
+- Changes in version 3.33.3:
+  + Updated translations.
+- Changes in version 3.33.2:
+  + thumbnailer: Correctly cleanup stale thumbnailer directories.
+  + Updated translations.
+- Changes in version 3.33.1:
+  + gnome-languages: Use uselocale to avoid threadsafety issues.
+  + Add default keyboard layout for Indonesia.
+  + Updated translations.
+- API version is now 18.
+- Rebase gnome-desktop-switch-Japanese-default-input-to-mozc.patch.
+
+---

Old:

  gnome-desktop-3.32.2.tar.xz

New:

  gnome-desktop-3.34.1.tar.xz



Other differences:
--
++ gnome-desktop.spec ++
--- /var/tmp/diff_new_pack.9WNOAI/_old  2019-10-17 12:59:55.605208335 +0200
+++ /var/tmp/diff_new_pack.9WNOAI/_new  2019-10-17 12:59:55.609208325 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   gnome-desktop
-Version:3.32.2
+Version:3.34.1
 Release:0
 Summary:The GNOME Desktop API Library
 License:LGPL-2.1-or-later
 Group:  System/GUI/GNOME
 URL:https://www.gnome.org
-Source0:
https://download.gnome.org/sources/gnome-desktop/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-desktop/3.34/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 
 # PATCH-FIX-OPENSUSE gnome-desktop-switch-Japanese-default-input-to-mozc.patch 
bnc#1029083 boo#1056289 qz...@suse.com -- Switch new user's default input 
engine from "anthy" to "mozc" in gnome-desktop with Japanese language and ibus 
input frame-work condition.
@@ -70,7 +70,7 @@
 
 This package contains data files used by libgnome-dekstop.
 
-%package -n libgnome-desktop-3-17
+%package -n libgnome-desktop-3-18
 Summary:The GNOME Desktop API Library
 # the library calls out to bwrap in order to fire up thumbnailers in a secure 
container
 Group:  System/Libraries
@@ -82,7 +82,7 @@
 Provides:   %{name} = %{version}
 Obsoletes:  %{name} < %{version}
 
-%description -n libgnome-desktop-3-17
+%description -n libgnome-desktop-3-18
 The libgnome-desktop library provides API shared by several applications
 on the desktop, but that cannot live in the platform for various
 reasons.
@@ -102,7 +102,7 @@
 %package -n libgnome-desktop-3-devel
 Summary:Development files for the GNOME Desktop API library
 Group:  Development/Libraries/GNOME
-Requires:   libgnome-desktop-3-17 = %{version}
+Requires:   libgnome-desktop-3-18 = %{version}
 # Needed as /usr/include/gnome-desktop-3.0/libgnome-desktop/gnome-xkb-info.h 
includes X11/extensions/XKBrules.h
 Requires:   libxkbfile-devel
 Requires:   typelib-1_0-GnomeDesktop-3_0 = %{version}
@@ -141,10 +141,10 @@
 
 %fdupes %{buildroot}/%{_prefix}
 
-%post -n libgnome-desktop-3-17 -p /sbin/ldconfig
-%postun -n libgnome-desktop-3-17 -p /sbin/ldconfig
+%post -n libgnome-desktop-3-18 -p /sbin/ldconfig
+%postun -n libgnome-desktop-3-18 -p /sbin/ldconfig
 
-%files -n libgnome-desktop-3-17
+%files -n libgnome-desktop-3-18
 %license COPYING.LIB
 %doc AUTHORS NEWS README
 %{_libdir}/libgnome-desktop-3.so.*

++ baselibs.conf ++
--- /var/tmp/diff_new_pack.9WNOAI/_old  2019-10-17 

commit gmime for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gmime for openSUSE:Factory checked 
in at 2019-10-17 12:59:08

Comparing /work/SRC/openSUSE:Factory/gmime (Old)
 and  /work/SRC/openSUSE:Factory/.gmime.new.2352 (New)


Package is "gmime"

Thu Oct 17 12:59:08 2019 rev:67 rq:736524 version:3.2.4

Changes:

--- /work/SRC/openSUSE:Factory/gmime/gmime.changes  2018-12-10 
12:25:23.598703426 +0100
+++ /work/SRC/openSUSE:Factory/.gmime.new.2352/gmime.changes2019-10-17 
12:59:10.993321355 +0200
@@ -1,0 +2,14 @@
+Thu Oct  3 17:06:17 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.2.4:
+  + Replaced calls to g_memmove with memmove.
+  + Added a new GMIME_DECRYPT_NO_VERIFY flag that disables
+signature verification.
+  + Modified GMimeParser to not set the OpenPGP state for
+base64/uuencoded content.
+  + Added reporting of RFC 5322 addr-spec syntax violations to the
+GMimeParserWarning API.
+  + Fixed a stack underflow error in the uudecode.c sample.
+  + Improved Vala bindings.
+
+---

Old:

  gmime-3.2.3.tar.xz

New:

  gmime-3.2.4.tar.xz



Other differences:
--
++ gmime.spec ++
--- /var/tmp/diff_new_pack.K6ZBUg/_old  2019-10-17 12:59:11.589319845 +0200
+++ /var/tmp/diff_new_pack.K6ZBUg/_new  2019-10-17 12:59:11.593319835 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gmime
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -22,13 +22,13 @@
 # NOTE - also update baselibs.conf when bumping this
 %define so_ver 3_0
 Name:   gmime
-Version:3.2.3
+Version:3.2.4
 Release:0
 Summary:MIME Parser and Utility Library
 License:LGPL-2.1-or-later
 Group:  Productivity/Networking/Email/Utilities
 URL:http://spruce.sourceforge.net/gmime/
-Source: 
http://download.gnome.org/sources/gmime/3.2/%{name}-%{version}.tar.xz
+Source: 
https://download.gnome.org/sources/gmime/3.2/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 BuildRequires:  gobject-introspection-devel >= 1.30.0
 BuildRequires:  gpgme-devel

++ gmime-3.2.3.tar.xz -> gmime-3.2.4.tar.xz ++
 7001 lines of diff (skipped)




commit glibmm2_4 for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package glibmm2_4 for openSUSE:Factory 
checked in at 2019-10-17 12:59:03

Comparing /work/SRC/openSUSE:Factory/glibmm2_4 (Old)
 and  /work/SRC/openSUSE:Factory/.glibmm2_4.new.2352 (New)


Package is "glibmm2_4"

Thu Oct 17 12:59:03 2019 rev:10 rq:736523 version:2.62.0

Changes:

--- /work/SRC/openSUSE:Factory/glibmm2_4/glibmm2_4.changes  2019-03-26 
15:38:24.852348627 +0100
+++ /work/SRC/openSUSE:Factory/.glibmm2_4.new.2352/glibmm2_4.changes
2019-10-17 12:59:05.409335501 +0200
@@ -1,0 +2,32 @@
+Wed Sep 18 19:07:49 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.62.0:
+  + Glib:
+- Add ustring::make_valid()
+- Use convert_return_gchar_ptr_to_*() in a couple of ustring
+  methods
+- Add ustring::sprintf(), wrapping g_strdup_printf()
+- Fix callback races in glibmm when GSource is destructed
+- Checksum, Datetime, TimeZone: Add Glib::Value
+  specializations
+- Property: Add const get_proxy() returning ReadOnly. Getting
+  Proxy from ReadOnly is const
+- Property: Update for compatibility with Gtk::Builder
+- Fix memory leak in Variant>::create()
+- Deprecate TimeVal
+  + Gio:
+- Add Application::add_option_group()
+- DBus::Object: Fix refcounts in some vfuncs
+- Gio::DBus: Add ObjectProxy, ObjectSkeleton, ObjectManager,
+  ObjectManagerClient, ObjectManagerServer
+- Drive, MountOperation, ThemedIcon, TlsDatabase,
+  VolumeMonitor: Fix ownership of some lists and arrays (Fixes
+  memory leaks and dangling pointers)
+- Add SocketControlMessage::add_deserialize_func()
+  + gmmproc: Update for new glib deprecation macros
+  + Build: Require glib-2.0 >= 2.61.2
+  + Documentation:
+- Glib::init(), Gio::init(): Improve the documentation
+- Glib::ustring can't always replace std::string.
+
+---

Old:

  glibmm-2.60.0.tar.xz

New:

  glibmm-2.62.0.tar.xz



Other differences:
--
++ glibmm2_4.spec ++
--- /var/tmp/diff_new_pack.A8b2EQ/_old  2019-10-17 12:59:06.001334002 +0200
+++ /var/tmp/diff_new_pack.A8b2EQ/_new  2019-10-17 12:59:06.005333991 +0200
@@ -20,19 +20,19 @@
 %define so_ver -2_4-1
 %define _name glibmm
 Name:   glibmm2_4
-Version:2.60.0
+Version:2.62.0
 Release:0
 Summary:C++ Interface for Glib
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/C and C++
 URL:http://www.gtkmm.org/
-Source0:
https://download.gnome.org/sources/glibmm/2.60/%{_name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/glibmm/2.62/%{_name}-%{version}.tar.xz
 Source99:   baselibs.conf
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(gio-2.0)
-BuildRequires:  pkgconfig(glib-2.0) >= 2.59.2
+BuildRequires:  pkgconfig(glib-2.0) >= 2.61.2
 BuildRequires:  pkgconfig(gmodule-2.0) >= 2.49.7
 BuildRequires:  pkgconfig(gobject-2.0) >= 2.49.7
 BuildRequires:  pkgconfig(sigc++-2.0) >= 2.9.1

++ glibmm-2.60.0.tar.xz -> glibmm-2.62.0.tar.xz ++
/work/SRC/openSUSE:Factory/glibmm2_4/glibmm-2.60.0.tar.xz 
/work/SRC/openSUSE:Factory/.glibmm2_4.new.2352/glibmm-2.62.0.tar.xz differ: 
char 26, line 1




commit gnome-bluetooth for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gnome-bluetooth for openSUSE:Factory 
checked in at 2019-10-17 12:59:14

Comparing /work/SRC/openSUSE:Factory/gnome-bluetooth (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-bluetooth.new.2352 (New)


Package is "gnome-bluetooth"

Thu Oct 17 12:59:14 2019 rev:94 rq:736527 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gnome-bluetooth/gnome-bluetooth.changes  
2019-05-03 22:16:01.871936795 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-bluetooth.new.2352/gnome-bluetooth.changes
2019-10-17 12:59:16.613307118 +0200
@@ -1,0 +2,15 @@
+Fri Sep  6 21:52:56 UTC 2019 - Michael Gorse 
+
+- Update to version 3.34.0:
+  + Fix possible use-after-free when using some gnome-shell
+extensions.
+  + Updated translations.
+
+---
+Mon Sep  2 10:35:46 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.90:
+  + Describe "Reveal" as "Open Containing Folder".
+  + Updated translations.
+
+---

Old:

  gnome-bluetooth-3.32.1.tar.xz

New:

  gnome-bluetooth-3.34.0.tar.xz



Other differences:
--
++ gnome-bluetooth.spec ++
--- /var/tmp/diff_new_pack.slJiAP/_old  2019-10-17 12:59:17.045306023 +0200
+++ /var/tmp/diff_new_pack.slJiAP/_new  2019-10-17 12:59:17.045306023 +0200
@@ -18,13 +18,13 @@
 
 %define _udevdir %(pkg-config --variable udevdir udev)
 Name:   gnome-bluetooth
-Version:3.32.1
+Version:3.34.0
 Release:0
 Summary:GNOME Bluetooth graphical utilities
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/GUI/GNOME
 URL:https://wiki.gnome.org/Projects/GnomeBluetooth
-Source0:
https://download.gnome.org/sources/gnome-bluetooth/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gnome-bluetooth/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 BuildRequires:  gobject-introspection-devel

++ gnome-bluetooth-3.32.1.tar.xz -> gnome-bluetooth-3.34.0.tar.xz ++
 8952 lines of diff (skipped)




commit glibmm2 for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package glibmm2 for openSUSE:Factory checked 
in at 2019-10-17 12:58:57

Comparing /work/SRC/openSUSE:Factory/glibmm2 (Old)
 and  /work/SRC/openSUSE:Factory/.glibmm2.new.2352 (New)


Package is "glibmm2"

Thu Oct 17 12:58:57 2019 rev:96 rq:736522 version:2.61.1

Changes:

--- /work/SRC/openSUSE:Factory/glibmm2/glibmm2.changes  2018-12-21 
08:21:24.217570873 +0100
+++ /work/SRC/openSUSE:Factory/.glibmm2.new.2352/glibmm2.changes
2019-10-17 12:58:58.745352384 +0200
@@ -1,0 +2,47 @@
+Mon Sep  9 17:22:13 UTC 2019 - Bjørn Lie 
+
+- Drop glibmm2 Provides and Obsoletes: Only glibmm2_4 compat
+  package should provide this.
+
+---
+Fri Aug 30 16:44:10 CDT 2019 - mgo...@suse.com
+
+- Update to version 2.61.1:
+  + Glib:
+- Add DateTime::get_timezone()
+- Add KeyFile::get_locale_for_key()
+- Add TimeZone::get_identifier()
+- KeyFile: Make it a refcounted class
+- Add Value_RefPtrBoxed<>
+- Add Value> specializations and other
+  Value
+- specializations that are necessary for _WRAP_PROPERTY
+  + Gio:
+- Put _WRAP_VFUNC in protected sections
+- Add AppInfo::launch_uris_async() and launch_uris_async()
+- Add DBusConnection::get_flags()and property_flags()
+- TlsClientConnection: Remove property_accepted_cas()
+- ThemedIcon: Add create(const std::vector&
+  + iconnames:
+- Remove NO_GTYPE from some _WRAP_ENUMs
+- TlsConnection: Remove rehandshake API
+- Application: Add signal_name_lost()
+  + Glib and Gio:
+- Use {} for function arguments initialisation
+- Issue glgo#GNOME/glibmm#20
+  + gmmproc:
+- generate_wrap_init.pl.in: Don't exclude any Gtk classes
+- _WRAP_PROPERTY: generate a static_assert() that checks if
+- the data type is acceptable
+- Add _IS_REFCOUNTED_BOXEDTYPE
+- _WRAP_ENUM and _WRAP_GERROR: Add gtype_func parameter
+  + Build:
+- glibmmconfig.h.in: Remove unused configuration constants
+- Change the ABI to glibmm-2.62
+  + Documentation:
+- README: Add installation instructions
+- Don’t use @retval on out args, use @param[out]
+- Update so_ver and base_ver
+- Update versions in baselibs.conf
+
+---

Old:

  glibmm-2.59.1.tar.xz

New:

  glibmm-2.61.1.tar.xz



Other differences:
--
++ glibmm2.spec ++
--- /var/tmp/diff_new_pack.VFxCfq/_old  2019-10-17 12:58:59.437350631 +0200
+++ /var/tmp/diff_new_pack.VFxCfq/_new  2019-10-17 12:58:59.441350620 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package glibmm2
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,20 +17,22 @@
 
 
 # Update baselibs.conf when changing this
-%define so_ver -2_60-1
+%define so_ver -2_62-1
 # Define a baseversion to ease updates
-%define base_ver 2.60
+%define base_ver 2.62
 # Define upstream name
 %define _name glibmm
+
 Name:   glibmm2
-Version:2.59.1
+Version:2.61.1
 Release:0
 Summary:C++ Interface for Glib
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/C and C++
 URL:https://www.gtkmm.org/
-Source0:
http://download.gnome.org/sources/glibmm/2.59/%{_name}-%{version}.tar.xz
+Source0:
http://download.gnome.org/sources/glibmm/2.61/%{_name}-%{version}.tar.xz
 Source99:   baselibs.conf
+
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  pkgconfig
@@ -48,8 +50,6 @@
 %package -n libglibmm%{so_ver}
 Summary:C++ Interface for Glib
 Group:  System/Libraries
-Provides:   glibmm2 = %{version}
-Obsoletes:  glibmm2 < %{version}
 
 %description -n libglibmm%{so_ver}
 Glibmm is the official C++ interface for the popular cross-platform

++ baselibs.conf ++
--- /var/tmp/diff_new_pack.VFxCfq/_old  2019-10-17 12:58:59.473350539 +0200
+++ /var/tmp/diff_new_pack.VFxCfq/_new  2019-10-17 12:58:59.473350539 +0200
@@ -1,4 +1,4 @@
-libglibmm-2_60-1
+libglibmm-2_62-1
   provides "glibmm2- = "
   obsoletes "glibmm2- < "
-libgiomm-2_60-1
+libgiomm-2_62-1

++ glibmm-2.59.1.tar.xz -> glibmm-2.61.1.tar.xz ++
/work/SRC/openSUSE:Factory/glibmm2/glibmm-2.59.1.tar.xz 
/work/SRC/openSUSE:Factory/.glibmm2.new.2352/glibmm-2.61.1.tar.xz differ: char 
27, line 1




commit glib-networking for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package glib-networking for openSUSE:Factory 
checked in at 2019-10-17 12:58:38

Comparing /work/SRC/openSUSE:Factory/glib-networking (Old)
 and  /work/SRC/openSUSE:Factory/.glib-networking.new.2352 (New)


Package is "glib-networking"

Thu Oct 17 12:58:38 2019 rev:65 rq:736520 version:2.62.1

Changes:

--- /work/SRC/openSUSE:Factory/glib-networking/glib-networking.changes  
2019-09-04 08:58:54.419070525 +0200
+++ 
/work/SRC/openSUSE:Factory/.glib-networking.new.2352/glib-networking.changes
2019-10-17 12:58:42.465393628 +0200
@@ -1,0 +2,36 @@
+Sat Oct  5 08:22:43 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.62.1:
+  + Fix two memory leaks.
+
+---
+Sat Sep  7 13:44:42 CDT 2019 - mgo...@suse.com
+
+- Update to version 2.62.0:
+  + Revert broken queued data fix for
+glgo#GNOME/glib-networking#15.
+
+---
+Mon Sep  2 00:45:58 UTC 2019 - Michael Gorse 
+
+- Update to version 2.61.92:
+  + Discard queued data after interrupted writes.
+  + Verify socket timeouts are respected.
+  + Fix a couple broken error messages.
+  + Changes in version 2.61.90:
+  + Fix translations of certain error messages
+  + Changes in version 2.61.2:
+  + Improve certain handshake error messages.
+  + Fix regressions introduced in 2.61.1.
+  + Changes in version 2.61.1:
+  + This release contains a major refactoring of the TLS
+codebase. The GnuTLS backend now shares the same base classes
+as the OpenSSL backend, to avoid duplicating as much code as
+possible. The base classes, previously used only by the
+OpenSSL backend and originally forked from glib-networking
+several years ago, have been enhanced to achieve feature-parity
+with the current state of the GnuTLS backend.  Please note
+that the OpenSSL backend remains experimental. Further planned
+work is required before this backend will be production-ready.
+
+---

Old:

  glib-networking-2.60.3.tar.xz

New:

  glib-networking-2.62.1.tar.xz



Other differences:
--
++ glib-networking.spec ++
--- /var/tmp/diff_new_pack.sQ16BW/_old  2019-10-17 12:58:43.121391966 +0200
+++ /var/tmp/diff_new_pack.sQ16BW/_new  2019-10-17 12:58:43.121391966 +0200
@@ -18,13 +18,13 @@
 
 %define gio_real_package %(rpm -q --qf '%%{name}' --whatprovides gio)
 Name:   glib-networking
-Version:2.60.3
+Version:2.62.1
 Release:0
 Summary:Network-related GIO modules for glib
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/C and C++
 URL:https://www.gnome.org
-Source0:
https://download.gnome.org/sources/glib-networking/2.60/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/glib-networking/2.62/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 
 BuildRequires:  ca-certificates-mozilla

++ glib-networking-2.60.3.tar.xz -> glib-networking-2.62.1.tar.xz ++
 23293 lines of diff (skipped)




commit gedit-plugins for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gedit-plugins for openSUSE:Factory 
checked in at 2019-10-17 12:58:28

Comparing /work/SRC/openSUSE:Factory/gedit-plugins (Old)
 and  /work/SRC/openSUSE:Factory/.gedit-plugins.new.2352 (New)


Package is "gedit-plugins"

Thu Oct 17 12:58:28 2019 rev:52 rq:736518 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gedit-plugins/gedit-plugins.changes  
2019-05-22 10:55:54.519010147 +0200
+++ /work/SRC/openSUSE:Factory/.gedit-plugins.new.2352/gedit-plugins.changes
2019-10-17 12:58:29.697425974 +0200
@@ -1,0 +2,28 @@
+Mon Sep  9 18:00:44 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Small fix.
+  + Translation updates.
+
+---
+Sun Sep  8 10:20:24 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Small cleanup in top-level files.
+  + Updated translations.
+
+---
+Sat Aug 31 06:45:18 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.90:
+  + Switch from Autotools to Meson.
+  + Add CI to test buildability and enforce Flake8.
+  + Add new session saver plugin.
+  + Remove synctex plugin.
+  + Update Commander activation shortcut to Ctrl+.
+  + Many more fixes.
+- Switch to meson.
+- Add session-saver package, and remove synctex package.
+- Remove __pycache__ directory from files.
+
+---

Old:

  gedit-plugins-3.32.2.tar.xz

New:

  gedit-plugins-3.34.0.tar.xz



Other differences:
--
++ gedit-plugins.spec ++
--- /var/tmp/diff_new_pack.sf5vx1/_old  2019-10-17 12:58:30.153424819 +0200
+++ /var/tmp/diff_new_pack.sf5vx1/_new  2019-10-17 12:58:30.157424809 +0200
@@ -18,19 +18,19 @@
 
 
 Name:   gedit-plugins
-Version:3.32.2
+Version:3.34.0
 Release:0
 Summary:A collection of plugins for gedit
 License:GPL-2.0-or-later
 Group:  Productivity/Text/Editors
 URL:https://wiki.gnome.org/Apps/Gedit/PluginsLists
-Source0:
https://download.gnome.org/sources/gedit-plugins/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gedit-plugins/3.34/%{name}-%{version}.tar.xz
 Source1:gedit-plugins.SUSE
 # PATCH-FIX-UPSTREAM bracketcompletion-use-key-release-event-to-work-wi.patch 
boo#1027448 bgo#778737 hillw...@opensuse.org -- Switch to use key release event 
for ibus pinyin input method
 Patch0: bracketcompletion-use-key-release-event-to-work-wi.patch
 
 BuildRequires:  fdupes
-BuildRequires:  libtool
+BuildRequires:  meson >= 0.49.0
 BuildRequires:  pkgconfig
 BuildRequires:  python3-base
 BuildRequires:  translation-update-upstream
@@ -66,7 +66,7 @@
 Suggests:   gedit-plugin-joinlines
 Suggests:   gedit-plugin-multiedit
 Suggests:   gedit-plugin-smartspaces
-Suggests:   gedit-plugin-synctex
+Suggests:   gedit-plugin-session-saver
 Suggests:   gedit-plugin-terminal
 Suggests:   gedit-plugin-textsize
 Suggests:   gedit-plugin-wordcompletion
@@ -215,14 +215,14 @@
 %description -n gedit-plugin-smartspaces
 The gedit smartspaces plugin
 
-%package -n gedit-plugin-synctex
-Summary:Gedit synctex plugin
+%package -n gedit-plugin-session-saver
+Summary:Gedit session-saver plugin
 Group:  Productivity/Text/Editors
 Requires:   %{name}-data = %{version}
-Provides:   gedit-plugins:%{_libdir}/gedit/plugins/synctex.plugin
+Provides:   gedit-plugins:%{_libdir}/gedit/plugins/session-saver.plugin
 
-%description -n gedit-plugin-synctex
-The gedit synctex plugin
+%description -n gedit-plugin-session-saver
+The gedit session-saver plugin
 
 %package -n gedit-plugin-terminal
 Summary:Gedit terminal plugin
@@ -278,14 +278,14 @@
 %autosetup -p1
 
 install -m644 %{SOURCE1} .
-translation-update-upstream
+translation-update-upstream po %{name}
 
 %build
-%configure
-make %{?_smp_mflags}
+%meson
+%meson_build
 
 %install
-%make_install
+%meson_install
 find %{buildroot} -type f -name "*.la" -delete -print
 %find_lang %{name} %{?no_lang_C}
 %find_lang gedit %{name}.lang %{?no_lang_C}
@@ -298,8 +298,6 @@
 %files -n %{name}-data
 # Common files
 %{_libdir}/gedit/plugins/gpdefs.py*
-%dir %{_libdir}/gedit/plugins/__pycache__
-%{_libdir}/gedit/plugins/__pycache__/gpdefs*.pyc
 
 %files -n gedit-plugin-bookmarks
 ## Explicitly list all plugins so we know when we miss one
@@ -313,7 +311,6 @@
 %{_datadir}/metainfo/gedit-bracketcompletion.metainfo.xml
 %{_libdir}/gedit/plugins/bracketcompletion.plugin
 %{_libdir}/gedit/plugins/bracketcompletion.py*
-%{_libdir}/gedit/plugins/__pycache__/bracketcompletion*.pyc
 
 %files 

commit gedit for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gedit for openSUSE:Factory checked 
in at 2019-10-17 12:58:19

Comparing /work/SRC/openSUSE:Factory/gedit (Old)
 and  /work/SRC/openSUSE:Factory/.gedit.new.2352 (New)


Package is "gedit"

Thu Oct 17 12:58:19 2019 rev:130 rq:736517 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/gedit/gedit.changes  2019-05-22 
10:55:46.815015854 +0200
+++ /work/SRC/openSUSE:Factory/.gedit.new.2352/gedit.changes2019-10-17 
12:58:21.745446120 +0200
@@ -1,0 +2,24 @@
+Mon Sep  9 17:57:24 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Translation updates.
+
+---
+Sun Sep  8 10:11:53 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Updated documentation.
+
+---
+Mon Sep  2 15:46:28 CST 2019 - yfji...@suse.com
+
+- Update to version 3.33.90:
+  + Add "gedit" to .desktop keywords as search workaround for Flatpak
+and Snap.
+  + Build fixes.
+  + Updated translations.
+- Remove %{_libexecdir}/gedit/gedit-bugreport.sh and
+  %{_libexecdir}/gedit from spec since they have been taken out
+  from upstream code.
+
+---

Old:

  gedit-3.32.2.tar.xz

New:

  gedit-3.34.0.tar.xz



Other differences:
--
++ gedit.spec ++
--- /var/tmp/diff_new_pack.zPjWlY/_old  2019-10-17 12:58:22.497444214 +0200
+++ /var/tmp/diff_new_pack.zPjWlY/_new  2019-10-17 12:58:22.501444204 +0200
@@ -18,13 +18,13 @@
 
 %bcond_without  python_bindings
 Name:   gedit
-Version:3.32.2
+Version:3.34.0
 Release:0
 Summary:UTF-8 text editor
 License:GPL-2.0-or-later
 Group:  Productivity/Text/Editors
 URL:https://wiki.gnome.org/Apps/Gedit
-Source0:
https://download.gnome.org/sources/gedit/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gedit/3.34/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE gedit-desktop.patch -- Adds more MIME types.
 Patch0: gedit-desktop.patch
 # PATCH-FIX-OPENSUSE gedit-plugins-python-env.patch bjorn@gmail.com -- Fix 
python env
@@ -139,6 +139,7 @@
 %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.filebrowser.enums.xml
 %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.filebrowser.gschema.xml
 %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.pythonconsole.gschema.xml
+%{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.spell.gschema.xml
 %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.time.enums.xml
 %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.time.gschema.xml
 %dir %{_libdir}/gedit/
@@ -168,10 +169,6 @@
 %{_libdir}/gedit/plugins/libtime.so
 %{_libdir}/gedit/plugins/quickhighlight.plugin
 %{_libdir}/gedit/plugins/libquickhighlight.so
-%if "%{_libdir}" != "%{_libexecdir}"
-%dir %{_libexecdir}/gedit
-%endif
-%{_libexecdir}/gedit/gedit-bugreport.sh
 %{_mandir}/man1/gedit.1%{?ext_man}
 %{_datadir}/icons/hicolor/*/apps/*
 
@@ -181,7 +178,7 @@
 %endif
 
 %files devel
-%doc AUTHORS HACKING MAINTAINERS
+%doc AUTHORS CONTRIBUTING.md
 %doc %{_datadir}/gtk-doc/html/gedit/
 %{_datadir}/gedit/gir-1.0/
 %{_includedir}/*

++ gedit-3.32.2.tar.xz -> gedit-3.34.0.tar.xz ++
/work/SRC/openSUSE:Factory/gedit/gedit-3.32.2.tar.xz 
/work/SRC/openSUSE:Factory/.gedit.new.2352/gedit-3.34.0.tar.xz differ: char 26, 
line 1




commit gjs for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gjs for openSUSE:Factory checked in 
at 2019-10-17 12:58:34

Comparing /work/SRC/openSUSE:Factory/gjs (Old)
 and  /work/SRC/openSUSE:Factory/.gjs.new.2352 (New)


Package is "gjs"

Thu Oct 17 12:58:34 2019 rev:82 rq:736519 version:1.58.1

Changes:

--- /work/SRC/openSUSE:Factory/gjs/gjs.changes  2019-05-10 09:17:58.072295700 
+0200
+++ /work/SRC/openSUSE:Factory/.gjs.new.2352/gjs.changes2019-10-17 
12:58:35.573411088 +0200
@@ -1,0 +2,132 @@
+Mon Oct  7 07:42:54 UTC 2019 - Bjørn Lie 
+
+- Update to version 1.58.1:
+  + Closed bugs and merge requests:
+- Import wiki documentation.
+- Smaller CI, phase 1.
+- Crashes after setting child property 'icon-name' on GtkStack
+  then displaying another GtkStack.
+- GLib.strdelimit crashes.
+
+---
+Sat Sep  7 15:45:12 CDT 2019 - mgo...@suse.com
+
+- Update to version 1.58.0:
+  + No changes.
+
+---
+Thu Sep  5 14:51:49 NZST 2019 - l...@ljones.dev
+
+- Update to version 1.57.92:
+  + Enable regression test cases for GPtrArrays and GArrays
+of structures.
+  * Various maintenance.
+
+---
+Thu Aug 29 09:38:16 UTC 2019 - Luke Jones 
+
+- Update to version 1.57.91:
+  + GJS no longer links to libgtk-3. This makes it possible to load the Gtk-4.0
+typelib in GJS and write programs that use GTK 4.
+  + The heapgraph tool has gained some improvements; it is now possible to 
print a
+heap graph of multiple targets. You can also mark an object for better
+identification in the heap graph by assigning a magic property: for 
example,
+myObject.__heapgraph_name = 'Button' will make that object identify itself 
as
+"Button" in heap graphs.
+  + Closed bugs and merge requests:
+- Remove usage of Lang in non legacy code.
+- GTK4.
+- JS syntax fixes.
+- gi: Avoid infinite recursion when converting GValues.
+- Implement all GObject-introspection test suites.
+- Heapgraph improvements.
+
+- Update to version 1.57.90:
+  + New JS API: GLib.Variant has gained a recursiveUnpack() method which
+transforms the variant entirely into a JS object, discarding all type
+information. This can be useful for dealing with a{sv} dictionaries, where
+deepUnpack() will keep the values as GLib.Variant instances in order to
+preserve the type information.
+  + New JS API: GLib.Variant has gained a deepUnpack() method which is exactly 
the
+same as the already existing deep_unpack(), but fits with the other 
camelCase
+APIs that GJS adds.
+  + Closed bugs and merge requests:
+- Marshalling of GPtrArray broken.
+- Fix locale chooser.
+- dbus-wrapper: Remove interface skeleton flush idle on dispose.
+- gobject: Use auto-compartment when getting property as well.
+- modules/signals: Use array destructuring in _emit.
+- GJS can't call glibtop_init function from libgtop.
+- GLib's VariantDict is missing lookup.
+- toString on an object implementing an interface fails.
+- Regression in GstPbutils.Discoverer::discovered callback.
+- GLib.Variant.deep_unpack not working properly with a{sv} variants.
+- Various maintenance.
+  + Various CI fixes.
+
+- Update to version 1.57.4:
+  + Closed bugs and merge requests:
+- gjs 1.57 requires a recent sysprof version for sysprof-capture-3.
+  + Misc documentation changes.
+
+
+- Update to version 1.57.3:
+  + The GJS profiler is now integrated directly into Sysprof 3, via the
+GJS_TRACE_FD environment variable. Call stack information and garbage
+collector timing will show up in Sysprof. See also GNOME/Initiatives#10
+  + New JS API: System.addressOfGObject(obj) will return a string with the hex
+address of the underlying GObject of `obj` if it is a GObject wrapper, or
+throw an exception if it is not. This is intended for debugging.
+  + New JS API: It's now possible to pass a value from Gio.DBusProxyFlags to 
the
+constructor of a class created by Gio.DBusProxy.makeProxyWrapper().
+  + Backwards-incompatible change: Trying to read a write-only property on a 
DBus
+proxy object, or write a read-only property, will now throw an exception.
+Previously it would fail silently. It seems unlikely any code is relying on
+the old behaviour, and if so then it was probably masking a bug.
+  + Closed bugs and merge requests:
+- Build failure on Continuous.
+- build: Bump glib requirement.
+- profiler: avoid clearing 512 bytes of stack.
+- system: add addressOfGObject method.
+- Add support for GJS_TRACE_FD.
+- Gio: Make possible to pass DBusProxyFlags to proxy wrapper.
+- 

commit glib2 for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package glib2 for openSUSE:Factory checked 
in at 2019-10-17 12:58:49

Comparing /work/SRC/openSUSE:Factory/glib2 (Old)
 and  /work/SRC/openSUSE:Factory/.glib2.new.2352 (New)


Package is "glib2"

Thu Oct 17 12:58:49 2019 rev:216 rq:736521 version:2.62.1

Changes:

--- /work/SRC/openSUSE:Factory/glib2/glib2.changes  2019-09-11 
10:20:16.427511653 +0200
+++ /work/SRC/openSUSE:Factory/.glib2.new.2352/glib2.changes2019-10-17 
12:58:53.089366713 +0200
@@ -1,0 +2,92 @@
+Fri Oct  4 12:12:46 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.62.1:
+  + Fix regression in g_file_copy() when passing
+`G_FILE_COPY_TARGET_DEFAULT_PERMS` flag; the destination
+permissions would be private rather than following the process’
+umask.
+  + Several `GDateTime` parsing fixes.
+  + Always build the tests if installed-tests are enabled, so that
+the tests can actually be installed.
+  + Bugs fixed: glgo#GNOME/GLib#174, glgo#GNOME/GLib#1865,
+glgo#GNOME/GLib#1875, glgo#GNOME/GLib#1887,
+glgo#GNOME/GLib#1888, glgo#GNOME/GLib!1021,
+glgo#GNOME/GLib!1094, glgo#GNOME/GLib!1101,
+glgo#GNOME/GLib!1102, glgo#GNOME/GLib!1103,
+glgo#GNOME/GLib!1127, glgo#GNOME/GLib!1128,
+glgo#GNOME/GLib!1140, glgo#GNOME/GLib!1141,
+glgo#GNOME/GLib!1142.
+  + Updated translations.
+
+---
+Fri Sep  6 10:31:47 NZST 2019 - l...@ljones.dev
+
+- Update to version 2.62.0:
+  + Fix new `GFileInfo` APIs to work when
+`G_FILE_ATTRIBUTE_TIME_MODIFIED_USEC` was not queried.
+  + Bugs fixed: glgo#GNOME/GLib#487, glgo#GNOME/GLib!1084,
+glgo#GNOME/GLib!1086,glgo#GNOME/GLib!1087.
+
+---
+Thu Sep  5 20:24:54 NZST 2019 - l...@ljones.dev
+
+- Update to version 2.61.3:
+  + Support setting thread name on BSD systems.
+  + Install previously-uninstalled headers for public
+`GNativeSocketAddress` object.
+  + Very initial support for Windows apps (UWP).
+  + Add various new valgrind suppressions to `glib.supp`.
+  + Bugs fixed: glgo#GNOME/GLib!83, glgo#GNOME/GLib!512,
+glgo#GNOME/GLib!873, glgo#GNOME/GLib!905, glgo#GNOME/GLib!1057,
+glgo#GNOME/GLib!1309, glgo#GNOME/GLib!1620,
+glgo#GNOME/GLib!1761, glgo#GNOME/GLib!1803,
+glgo#GNOME/GLib!1819, glgo#GNOME/GLib!1852,
+glgo#GNOME/GLib!1854, glgo#GNOME/GLib!1860,
+glgo#GNOME/GLib!1863, glgo#GNOME/GLib!1867,
+glgo#GNOME/GLib!1870, glgo#GNOME/GLib!1879,
+glgo#GNOME/GLib!1880, glgo#GNOME/GLib!1881,
+glgo#GNOME/GLib!1002, glgo#GNOME/GLib!1011,
+glgo#GNOME/GLib!1015, glgo#GNOME/GLib!1016,
+glgo#GNOME/GLib!1017, glgo#GNOME/GLib!1023,
+glgo#GNOME/GLib!1026, glgo#GNOME/GLib!1027,
+glgo#GNOME/GLib!1031, glgo#GNOME/GLib!1032,
+glgo#GNOME/GLib!1033, glgo#GNOME/GLib!1034,
+glgo#GNOME/GLib!1036, glgo#GNOME/GLib!1037,
+glgo#GNOME/GLib!1044, glgo#GNOME/GLib!1049,
+glgo#GNOME/GLib!1050, glgo#GNOME/GLib!1054,
+glgo#GNOME/GLib!1057, glgo#GNOME/GLib!1059,
+glgo#GNOME/GLib!1066, glgo#GNOME/GLib!1068,
+glgo#GNOME/GLib!1071, glgo#GNOME/GLib!1074,
+glgo#GNOME/GLib!1075.
+---
+Mon Sep  2 18:04:38 UTC 2019 - Dominique Leuenberger 
+
+- Update to version 2.61.2:
+  + Add various new array functions (#236, #269, #373).
+  + Rework how D-Bus connections are closed/unreffed when
+`g_test_dbus_down()` is called. Tests which leak a
+`GDBusConnection` may now time out and abort, rather than
+silently leaking. (#787)
+  + Add a deprecation macro for GLib macros, and use it;
+third-party uses of long-deprecated GLib macros may now start
+causing warnings. (#1060).
+  + Deprecate `GTime` and `GTimeVal`, and various functions which
+use them. Use `GDateTime` and `guint64` UNIX timestamps
+instead.
+  + Stop using `G_DISABLE_DEPRECATED` to allow disabling
+deprecation warnings; third-party code should now be using
+`GLIB_VERSION_{MIN_REQUIRED, MAX_ALLOWED}` to control symbol
+usage.
+  + Improve `GNetworkMonitor` detection of offline states (#1788).
+  + Fix CVE-2019-12450, wide permissions of files when copying
+using GIO.
+- Changes from version 2.61.1:
+  + Upgrade to Unicode Character Database v12.1.
+  + Improve network availability detection with NetworkManager to
+treat lower levels of connectivity as having reduced
+availability.
+- Changes from version 2.61.0:
+  + Add coloured output support to `gdbus introspect.
+  + Updated translations.
+
+---

Old:

  glib-2.60.7.tar.xz

New:

  glib-2.62.1.tar.xz



Other differences:

commit gdk-pixbuf for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package gdk-pixbuf for openSUSE:Factory 
checked in at 2019-10-17 12:58:11

Comparing /work/SRC/openSUSE:Factory/gdk-pixbuf (Old)
 and  /work/SRC/openSUSE:Factory/.gdk-pixbuf.new.2352 (New)


Package is "gdk-pixbuf"

Thu Oct 17 12:58:11 2019 rev:76 rq:736514 version:2.40.0

Changes:

--- /work/SRC/openSUSE:Factory/gdk-pixbuf/gdk-pixbuf.changes2019-09-11 
10:18:22.711525764 +0200
+++ /work/SRC/openSUSE:Factory/.gdk-pixbuf.new.2352/gdk-pixbuf.changes  
2019-10-17 12:58:14.249465110 +0200
@@ -1,0 +2,19 @@
+Tue Oct  8 11:52:24 UTC 2019 - Bjørn Lie 
+
+- Update to version 2.40.0:
+  + Allow creating a GdkPixbuf instance without any property.
+
+---
+Mon Sep  9 08:46:09 UTC 2019 - mgo...@suse.com
+
+- Update to version 2.39.2:
+  + Add gdk_pixbuf_init_modules() for applications with GdkPixbuf
+loader modules in a separate directory.
+  + Add subproject fallback for dependencies.
+  + Handle large XPM without crashing.
+  + Use the appropriate gdk-pixbuf-query-loaders on install.
+  + Disable deprecation warnings introduced by GLib 2.62.
+  + Escape GIF version in error messages.
+  + Render GIF frames on demand.
+
+---

Old:

  gdk-pixbuf-2.38.2.tar.xz

New:

  gdk-pixbuf-2.40.0.tar.xz



Other differences:
--
++ gdk-pixbuf.spec ++
--- /var/tmp/diff_new_pack.0idWaM/_old  2019-10-17 12:58:14.877463520 +0200
+++ /var/tmp/diff_new_pack.0idWaM/_new  2019-10-17 12:58:14.881463509 +0200
@@ -20,14 +20,14 @@
 %define gdk_pixbuf_binary_version 2.10.0
 
 Name:   gdk-pixbuf
-Version:2.38.2
+Version:2.40.0
 Release:0
 Summary:An image loading library
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/GNOME
 URL:https://www.gnome.org/
 
-Source0:
https://download.gnome.org/sources/gdk-pixbuf/2.38/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/gdk-pixbuf/2.40/%{name}-%{version}.tar.xz
 Source1:macros.gdk-pixbuf
 Source2:README.SUSE
 Source3:gdk-pixbuf-rpmlintrc

++ gdk-pixbuf-2.38.2.tar.xz -> gdk-pixbuf-2.40.0.tar.xz ++
 12211 lines of diff (skipped)




commit evolution-data-server for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package evolution-data-server for 
openSUSE:Factory checked in at 2019-10-17 12:57:55

Comparing /work/SRC/openSUSE:Factory/evolution-data-server (Old)
 and  /work/SRC/openSUSE:Factory/.evolution-data-server.new.2352 (New)


Package is "evolution-data-server"

Thu Oct 17 12:57:55 2019 rev:205 rq:736509 version:3.34.1

Changes:

--- 
/work/SRC/openSUSE:Factory/evolution-data-server/evolution-data-server.changes  
2019-07-21 11:31:09.752809551 +0200
+++ 
/work/SRC/openSUSE:Factory/.evolution-data-server.new.2352/evolution-data-server.changes
2019-10-17 12:57:57.721506982 +0200
@@ -1,0 +2,147 @@
+Mon Oct  7 08:00:29 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Miscellaneous: Correct a developer comment for
+SECTION:e-cancellable-locks.
+  + Bugs fixed: glgo#GNOME/evolution-data-server#145,
+glgo#GNOME/evolution-data-server#151,
+glgo#GNOME/evolution-data-server#156, glgo#GNOME/evolution#635.
+  + Updated translations.
+
+---
+Thu Oct  3 23:49:49 UTC 2019 - Bjørn Lie 
+
+- Add explict pkgconfig(libical) BuildRequires: Needed after the
+  multibuild split of libical and libical-glib.
+
+---
+Thu Sep 19 12:45:30 UTC 2019 - Bjørn Lie 
+
+- Disable docs, fails to build with gtk-doc-1.32. Issue to be filed
+  upstream.
+
+---
+Mon Sep  9 16:01:41 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Thu Sep  5 11:55:54 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Avoid possible use after free caused in
+vee_folder_set_expression()
+  + Bug Fixes: glgo#GNOME/evolution-data-server#136,
+glgo#GNOME/evolution-data-server#141,
+glgo#GNOME/evolution-data-server#147
+glgo#GNOME/evolution-data-server#148
+evo-glgo#GNOME/evolution-data-server#551
+
+---
+Thu Aug 29 10:31:32 UTC 2019 - Luke Jones 
+
+- Update to version 3.33.91:
+  + Bugs fixed: glgo#GNOME/evolution-data-server#68,
+glgo#GNOME/evolution-data-server#138,
+glgo#GNOME/evolution-data-server#142,
+glgo#GNOME/evolution#559, glgo#GNOME/evolution#568.
+  + Include also CFLAGS in gtkdoc-scangobj command line
+  + EDataFactory: Free backend when no client connects to it
+  + Correct typo in a developer comment
+  + GOA module: Run EWS autodiscovery asynchronously
+  + Fix two memory leaks
+  + Updated translations.
+- Changes from version 3.33.90:
+  + Bugs fixed: glgo#GNOME/evolution-data-server#112,
+glgo#GNOME/evolution-data-server#137.
+  + EWebDAVDiscover can report failure on success and hide
+collections
+  + e_webdav_discover_dialog_new: Set default response button for
+the dialog
+  + Let the message-location check also real message location in
+the search folders
+  + Updated translations.
+- Changes from version 3.33.4
+  + Bugs fixed: glgo#GNOME/evolution-data-server#128,
+glgo#GNOME/evolution-data-server#130, glgo#GNOME/evolution#479.
+  + [LDAP] Fix several memory leaks
+  + Prefer built-in timezone component in
+e_cal_util_copy_timezone()
+  + Fix a memory leak in e_cal_recur_generate_instances_sync()
+  + Miscellaneous changes in ecmb_modify_object_sync()
+  + Updated translations.
+- Changes from version 3.33.3:
+  + Bugs fixed: glgo#GNOME/evolution-data-server#108,
+glgo#GNOME/evolution-data-server#117,
+glgo#GNOME/evolution-data-server#120,
+glgo#GNOME/evolution-data-server#121,
+glgo#GNOME/evolution-data-server#123.
+  + EDataBook/EDataCal: Flush GDBus connection on backend property
+change
+  + Add workaround for D-Bus property change into get-revision
+tests
+  + Expose E-Book/Cal-BackendSExp lock
+  + Update overdue time immediately after the reminders' window is
+mapped
+  + Add ESourceLocal::writable extension property
+  + CamelOperation can be used by other thread while in its
+finalize()
+  + Memos cannot have set reminders according to RFC 5545
+  + Change how CamelOfflineStore goes online
+  + [IMAPx] Prefer local search in folders fully synchronized for
+offline
+  + Correct e_cal_component_get_start_plus_duration()
+  + Updated translations.
+- Changes from version 3.33.2:
+  + The calendar part begun to use libical-glib, instead of
+libical, which includes change from API version 1.2 to 2.0.
+  + The addressbook part and the calendar part changed client APIs,
+which modified also D-Bus API, thus D-Bus services' versions
+had been bumped as well.
+  + All the C libraries generate GObject introspection and Vala
+bindings.

commit evolution for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package evolution for openSUSE:Factory 
checked in at 2019-10-17 12:57:46

Comparing /work/SRC/openSUSE:Factory/evolution (Old)
 and  /work/SRC/openSUSE:Factory/.evolution.new.2352 (New)


Package is "evolution"

Thu Oct 17 12:57:46 2019 rev:229 rq:736507 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/evolution/evolution.changes  2019-08-15 
12:24:27.530620284 +0200
+++ /work/SRC/openSUSE:Factory/.evolution.new.2352/evolution.changes
2019-10-17 12:57:50.721524716 +0200
@@ -1,0 +2,186 @@
+Mon Oct  7 08:16:46 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + EWebView: Pile calls to Web Extension proxy only when such
+exists.
+  + Fix several memory leaks in ECalModel and its descendants.
+  + help:
+- Update application logo.
+- Fix a typo (semi-colon instead of colon).
+  + Bugs fixed: glgo#GNOME/evolution#524, glgo#GNOME/evolution#587,
+glgo#GNOME/evolution#603, glgo#GNOME/evolution#610,
+glgo#GNOME/evolution#611, glgo#GNOME/evolution#615,
+glgo#GNOME/evolution#617, glgo#GNOME/evolution#623,
+glgo#GNOME/evolution#624, glgo#GNOME/evolution#636,
+glgo#GNOME/evolution#641, glgo#GNOME/evolution#644,
+glgo#GNOME/evolution#645.
+  + Updated translations.
+
+---
+Mon Sep  9 16:02:51 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + help: Fix broken markup in cs help translation.
+  + help: Remove XInclude for Account settings' \"Identity\"
+section.
+  + help: Cover server-side search behavior for remote accounts.
+  + help: Remove unproven statement about search speed.
+  + Updated translations.
+
+---
+Thu Sep  5 12:28:53 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + itip-formatter: Doesn't match attendee when an alias address is
+used.
+  + ECompEditor: Set window's urgency hint after error when not
+focused.
+  + Bug Fixes: glgo#GNOME/evolution#528, glgo#GNOME/evolution#551,
+glgo#GNOME/evolution#562, glgo#GNOME/evolution#574,
+glgo#GNOME/evolution#578, glgo#GNOME/evolution#583,
+glgo#GNOME/evolution#588, glgo#GNOME/evolution#592,
+glgo#GNOME/evolution#593, glgo#GNOME/evolution#601.
+
+---
+Wed Sep  4 06:36:28 UTC 2019 - Luke Jones 
+
+- Update to version 3.33.92
+  + itip-formatter: Doesn't match attendee when an alias address is
+used.
+  + ECompEditor: Set window's urgency hint after error when not
+focused.
+  + Bug Fixes: glgo#GNOME/evolution#528, glgo#GNOME/evolution#551,
+glgo#GNOME/evolution#562, glgo#GNOME/evolution#574,
+glgo#GNOME/evolution#578, glgo#GNOME/evolution#583,
+glgo#GNOME/evolution#588, glgo#GNOME/evolution#592,
+glgo#GNOME/evolution#593, glgo#GNOME/evolution#601.
+- Update to version 3.33.91
+  + Include also CFLAGS in gtkdoc-scangobj command line.
+  + Fix few memory leaks in internal test programs.
+  + ECellTree: Limit deep threads indent up to 70% of the cell
+width.
+  + EDayView: Time zone name not always updated on time zone change
+in UI.
+  + Bug Fixes: glgo#GNOME/evolution#518, glgo#GNOME/evolution#541,
+glgo#GNOME/evolution#554, glgo#GNOME/evolution#563,
+glgo#GNOME/evolution#568, glgo#GNOME/evolution#576.
+- Update to version 3.33.90
+  + Add refresh interval settings for CardDAV address books.
+  + killev: Search for killall/pkill in runtime, rather than in
+compile time.
+  + Use Unicode triple-dots in translatable strings.
+  + help: Replace an external redirect link by its direct link.
+  + help: Fix xmlns for XInclude (must be http) so pages validate.
+  + help: Cover formatting of received HTML mail, e.g. showing
+Plain Text.
+  + Bug Fixes: glgo#GNOME/evolution#549, glgo#GNOME/evolution#564.
+- Update to version 3.33.4
+  + Use GtkPopover for EColorCombo widget.
+  + Do not unfold DKIM and ARC headers in message preview.
+  + Remember source message information when re-editing in Drafts
+or Outbox.
+  + [ECalModel] Cache value for E_CAL_MODEL_FIELD_ICON.
+  + Inconsistent background color in ETable for Memos, Tasks and
+List View.
+  + Incorrect timezone selected in ETimezoneDialog.
+  + Remove useless runtime check in date_time_list_finalize().
+  + Correct coding typo in e_day_view_on_editing_stopped().
+  + Refer to 'Evolution Website' only as 'Website' in the About
+dialog.
+  + [ECompEditor] Ensure attendee changes stored before save.
+  + Check whether enum-based ICalParameter had been created before
+using it.
+  + Test whether referenced column exists when loading ETableState.
+  + Search for Bogofilter/SpamAssassin binaries during configure
+time.
+  + [addressbook] Claim what 

commit folks for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package folks for openSUSE:Factory checked 
in at 2019-10-17 12:58:05

Comparing /work/SRC/openSUSE:Factory/folks (Old)
 and  /work/SRC/openSUSE:Factory/.folks.new.2352 (New)


Package is "folks"

Thu Oct 17 12:58:05 2019 rev:48 rq:736511 version:0.13.1

Changes:

--- /work/SRC/openSUSE:Factory/folks/folks.changes  2019-05-03 
22:17:32.220117924 +0200
+++ /work/SRC/openSUSE:Factory/.folks.new.2352/folks.changes2019-10-17 
12:58:07.245482854 +0200
@@ -1,0 +2,35 @@
+Fri Sep  6 02:05:31 UTC 2019 - l...@ljones.dev
+
+- Disable lto in build due to lto causing segfault in Geary.
+
+---
+Wed Sep  4 10:20:18 CDT 2019 - mgo...@suse.com
+
+- Update to version 0.13.1:
+  + Remove libsocialweb backend.
+- Changes in version 0.12.1:
+  + Disabled tests that were failing to be able to build a tarball.
+- Changes in version 0.12.0:
+  + Dropped depedency on libvaladoc (we now use the binary
+directly).
+  + Bumped minimal GLib version to 2.44.
+  + Folks is now being built using meson.
+  + The autotools build definition was dropped.
+  + Dropped support for building without vala.
+  + Migrated to the GNOME GitLab and now use a CI-backed workflow.
+  + Moved from intltool to gettext.
+  + Various fixes for warnings.
+  + Lots of translation updates.
+  + Bugs fixed:
+- Bug 784544 - Fatal error building git master.
+- Bug 739997 - Crash when selecting contact.
+- Bug 792238 - PotentialMatch: don't rely on null-terminated
+  string.
+- Bug 792567 - Individual.display_name: don't fallback on
+  persona's display_id if it equals the IID.
+- Switch to meson.
+- Drop intltool dependency. Depend on gettext..
+- Drop folks-tracker.2.0.patch: fixed upstream.
+- Module_version is now 45.
+
+---

Old:

  folks-0.11.4.tar.xz
  folks-tracker.2.0.patch

New:

  folks-0.13.1.tar.xz



Other differences:
--
++ folks.spec ++
--- /var/tmp/diff_new_pack.0uWSXI/_old  2019-10-17 12:58:07.649481831 +0200
+++ /var/tmp/diff_new_pack.0uWSXI/_new  2019-10-17 12:58:07.653481820 +0200
@@ -17,29 +17,28 @@
 
 
 %define soversion  25
-%define module_version 43
+%define module_version 45
 %define with_zeitgeist  0
 Name:   folks
-Version:0.11.4
+Version:0.13.1
 Release:0
 Summary:Library to create metacontacts from multiple sources
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/C and C++
 URL:http://telepathy.freedesktop.org/wiki/Folks
-Source: 
http://download.gnome.org/sources/folks/0.11/%{name}-%{version}.tar.xz
-# PATCH-FIX-UPSTREAM folks-tracker.2.0.patch dims...@opensuse.org -- Switch to 
tracker version 2.0, patch not upstream-ready
-Patch0: folks-tracker.2.0.patch
+Source: 
https://download.gnome.org/sources/folks/0.13/%{name}-%{version}.tar.xz
+BuildRequires:  gettext
 BuildRequires:  gobject-introspection-devel
-BuildRequires:  intltool >= 0.50.0
+BuildRequires:  meson >= 0.49
 BuildRequires:  pkgconfig
 BuildRequires:  readline-devel
 BuildRequires:  vala >= 0.22.0.28
 BuildRequires:  pkgconfig(dbus-glib-1)
 BuildRequires:  pkgconfig(gee-0.8) >= 0.8.6
-BuildRequires:  pkgconfig(gobject-2.0) >= 2.40.0
+BuildRequires:  pkgconfig(gobject-2.0) >= 2.44.0
 BuildRequires:  pkgconfig(libebook-1.2) >= 3.13.90
 BuildRequires:  pkgconfig(libebook-contacts-1.2) >= 3.7.90
-BuildRequires:  pkgconfig(libedataserver-1.2) >= 3.13.90
+BuildRequires:  pkgconfig(libedataserver-1.2) >= 3.33.2
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(telepathy-glib) >= 0.19.9
 BuildRequires:  pkgconfig(tracker-sparql-2.0)
@@ -176,17 +175,17 @@
 %autosetup -p1
 
 %build
-%configure \
-   --disable-static \
-   --enable-eds-backend \
-   --enable-tracker-backend \
-   --disable-libsocialweb-backend \
-   --disable-fatal-warnings \
+%define _lto_cflags %{nil}
+%meson \
+   -Dtracker_backend=true \
+%if %{with_zeitgeist}
+   -Dzeitgeist=true \
+%endif
%{nil}
-%make_build
+%meson_build
 
 %install
-%make_install
+%meson_install
 find %{buildroot} -type f -name "*.la" -delete -print
 %find_lang folks %{?no_lang_C}
 
@@ -204,7 +203,7 @@
 
 %files -n libfolks%{soversion}
 %license COPYING
-%doc AUTHORS ChangeLog NEWS README
+%doc AUTHORS NEWS README.md
 %{_libdir}/libfolks.so.%{soversion}*
 %{_libdir}/libfolks-dummy.so.%{soversion}*
 %dir %{_libdir}/folks
@@ -216,7 +215,6 @@
 %{_libdir}/folks/%{module_version}/backends/ofono/
 
 %files -n libfolks-data
-%{_datadir}/GConf/gsettings/folks.convert
 

commit evolution-ews for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package evolution-ews for openSUSE:Factory 
checked in at 2019-10-17 12:58:00

Comparing /work/SRC/openSUSE:Factory/evolution-ews (Old)
 and  /work/SRC/openSUSE:Factory/.evolution-ews.new.2352 (New)


Package is "evolution-ews"

Thu Oct 17 12:58:00 2019 rev:97 rq:736510 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/evolution-ews/evolution-ews.changes  
2019-05-10 09:16:31.892162438 +0200
+++ /work/SRC/openSUSE:Factory/.evolution-ews.new.2352/evolution-ews.changes
2019-10-17 12:58:01.785496687 +0200
@@ -1,0 +2,63 @@
+Mon Oct  7 08:22:29 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Prefill email address as user name when creating new account.
+  + Autodiscover: Do not change user name with RedirectAddr.
+  + Bugs fixed: glgo#GNOME/evolution-ews#65,
+glgo#GNOME/evolution-ews#66, glgo#GNOME/evolution-ews#69,
+glgo#GNOME/evolution-ews#71.
+  + Updated translations.
+
+---
+Mon Sep 16 01:42:40 UTC 2019 - Michael Gorse 
+
+- Pass --DCMAKE_SKIP_RPATH=OFF and
+  -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON to cmake again. Otherwise,
+  the EDS backends don't have the library directory in their rpath.
+
+---
+Mon Sep  9 16:05:25 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.34.0:
+  + No code/translation changes.
+
+---
+Sat Sep  7 20:52:08 UTC 2019 - Bjørn Lie 
+
+- Replace pkgconfig(libedata-cal-1.2) with
+  pkgconfig(libedata-cal-2.0) BuildRequires following upstreams
+  changes.
+- Use autosetup and cmake_build macros.
+- Stop passing -DCMAKE_SKIP_RPATH=OFF and
+  -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON to cmake, no longer needed.
+- Replace gcc-c++ with the genric c++_compiler BuildRequires.
+
+---
+Thu Sep  5 13:37:26 NZST 2019 - l...@ljones.dev
+
+- Update to version 3.33.92:
+  + Fix a memory leak in camel_ews_store_ensure_virtual_folders().
+  + Bugs fixed: glgo#GNOME/evolution-ews#60.
+- Update to version 3.33.91:
+  + Bugs fixed: glgo#GNOME/evolution-ews#55,
+glgo#GNOME/evolution-ews#56, glgo#GNOME/evolution-ews#57.
+- Update to version 3.33.4:
+  + Fix few memory leaks in e_cal_backend_ews_rid_to_index()
+  + Count with an ICalTimezone without internal component in
+ewscal_set_availability_timezone().
+  + Categories property cannot be deleted.
+  + Bugs fixed: glgo#GNOME/evolution-ews#53.
+- Update to version 3.33.3:
+  + Fix issues found during 'make check'.
+  + Fix some compiler warnings reported by Clang in the test code.
+  + Bugs fixed: glgo#GNOME/evolution-ews#42,
+glgo#GNOME/evolution-ews#49.
+- Update to version 3.33.2:
+  + Add refresh interval options to non-mail sources.
+  + Port to libecal-2.0 and adapt to address book API changes.
+- Update to version 3.33.1:
+  + Use lower-case "mailto:; consistently in the code.
+  + Bugs fixed: glgo#GNOME/evolution-ews#41,
+glgo#GNOME/evolution-ews#39.
+  
+---

Old:

  evolution-ews-3.32.2.tar.xz

New:

  evolution-ews-3.34.1.tar.xz



Other differences:
--
++ evolution-ews.spec ++
--- /var/tmp/diff_new_pack.Q7dt1p/_old  2019-10-17 12:58:02.337495288 +0200
+++ /var/tmp/diff_new_pack.Q7dt1p/_new  2019-10-17 12:58:02.337495288 +0200
@@ -16,21 +16,21 @@
 #
 
 
-# _version needs to be %{version} stripped to major.minor.micro only...
+# _version needs to be %%{version} stripped to major.minor.micro only...
 %define _version %(echo %{version} | grep -E -o '[0-9]+\.[0-9]+\.[0-9]+')
 
 Name:   evolution-ews
-Version:3.32.2
+Version:3.34.1
 Release:0
 Summary:Exchange Connector for Evolution, compatible with Exchange 
2007 and later
 License:LGPL-2.1-only
 Group:  Productivity/Networking/Email/Clients
 URL:https://wiki.gnome.org/Apps/Evolution
-Source0:
https://download.gnome.org/sources/evolution-ews/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/evolution-ews/3.34/%{name}-%{version}.tar.xz
 
+BuildRequires:  c++_compiler
 BuildRequires:  cmake
 BuildRequires:  fdupes
-BuildRequires:  gcc-c++
 BuildRequires:  intltool
 BuildRequires:  pkgconfig
 BuildRequires:  translation-update-upstream
@@ -43,9 +43,9 @@
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.10
 BuildRequires:  pkgconfig(libebackend-1.2) >= %{_version}
 BuildRequires:  pkgconfig(libebook-1.2) >= %{_version}
-BuildRequires:  pkgconfig(libecal-1.2) >= %{_version}
+BuildRequires:  pkgconfig(libecal-2.0) >= %{_version}
 

commit evince for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package evince for openSUSE:Factory checked 
in at 2019-10-17 12:57:34

Comparing /work/SRC/openSUSE:Factory/evince (Old)
 and  /work/SRC/openSUSE:Factory/.evince.new.2352 (New)


Package is "evince"

Thu Oct 17 12:57:34 2019 rev:142 rq:736506 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/evince/evince.changes2019-09-11 
10:19:36.359516625 +0200
+++ /work/SRC/openSUSE:Factory/.evince.new.2352/evince.changes  2019-10-17 
12:57:40.845549736 +0200
@@ -1,0 +2,32 @@
+Mon Oct  7 20:05:48 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + accessibility:
+- Fix erroneous cast.
+- Initialize private fields.
+  + build: Distribute meson build files when using autotools.
+  + flatpak: Update dependency versions.
+  + i18n: Fix typo in Ukrainian translation for Download.
+  + icon:
+- Create a nightly app icon.
+- Fix logo in README and add flatpak button.
+  + shell:
+- Ignore higher mouse buttons on links.
+- Fix slow scrolling on last pages of big pdf's.
+  + Updated translations.
+
+---
+Mon Sep 30 08:48:49 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.34.0:
+  + AppData: Add release information to AppData.
+- Switch to using explicit tag in _service.
+
+---
+Mon Sep 30 08:45:16 UTC 2019 - bjorn@gmail.com
+
+- Update to version 3.32.1+0:
+  + AppData: Add 3.30 major release date.
+  + Add release information to AppData.
+
+---

Old:

  _servicedata
  evince-3.32.0+28.obscpio

New:

  evince-3.34.1.obscpio



Other differences:
--
++ evince.spec ++
--- /var/tmp/diff_new_pack.Wjy64i/_old  2019-10-17 12:57:43.105544010 +0200
+++ /var/tmp/diff_new_pack.Wjy64i/_new  2019-10-17 12:57:43.105544010 +0200
@@ -20,7 +20,7 @@
 %define pluginAPI 4
 
 Name:   evince
-Version:3.32.0+28
+Version:3.34.1
 Release:0
 Summary:GNOME Document Viewer
 License:GPL-2.0-or-later

++ _service ++
--- /var/tmp/diff_new_pack.Wjy64i/_old  2019-10-17 12:57:43.141543919 +0200
+++ /var/tmp/diff_new_pack.Wjy64i/_new  2019-10-17 12:57:43.141543919 +0200
@@ -2,9 +2,8 @@
   
 https://gitlab.gnome.org/GNOME/evince.git
 git
-gnome-3-32
-@PARENT_TAG@+@TAG_OFFSET@
-enable
+refs/tags/3.34.1
+@PARENT_TAG@
   
   
   

++ evince-3.32.0+28.obscpio -> evince-3.34.1.obscpio ++
/work/SRC/openSUSE:Factory/evince/evince-3.32.0+28.obscpio 
/work/SRC/openSUSE:Factory/.evince.new.2352/evince-3.34.1.obscpio differ: char 
49, line 1

++ evince.obsinfo ++
--- /var/tmp/diff_new_pack.Wjy64i/_old  2019-10-17 12:57:43.177543829 +0200
+++ /var/tmp/diff_new_pack.Wjy64i/_new  2019-10-17 12:57:43.181543818 +0200
@@ -1,5 +1,5 @@
 name: evince
-version: 3.32.0+28
-mtime: 1567865230
-commit: aeeb3d2d47bcf95ddb8a149df3f6c28284ca7c19
+version: 3.34.1
+mtime: 1570477055
+commit: 6f9b550f42ad236185d4bc650ffe6ade04fd09ab
 




commit devhelp for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package devhelp for openSUSE:Factory checked 
in at 2019-10-17 12:57:20

Comparing /work/SRC/openSUSE:Factory/devhelp (Old)
 and  /work/SRC/openSUSE:Factory/.devhelp.new.2352 (New)


Package is "devhelp"

Thu Oct 17 12:57:20 2019 rev:81 rq:736503 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/devhelp/devhelp.changes  2019-05-03 
22:15:52.847918833 +0200
+++ /work/SRC/openSUSE:Factory/.devhelp.new.2352/devhelp.changes
2019-10-17 12:57:21.981597526 +0200
@@ -1,0 +2,8 @@
+Thu Sep 12 07:49:51 CST 2019 - qk...@suse.com
+
+- Update to version 3.34.0:
+  + Enable back-forward swipe gesture in the HTML pages.
+  + Write more contributor docs.
+  + Updated translations.
+
+---

Old:

  devhelp-3.32.0.tar.xz

New:

  devhelp-3.34.0.tar.xz



Other differences:
--
++ devhelp.spec ++
--- /var/tmp/diff_new_pack.3mo0Wo/_old  2019-10-17 12:57:22.509596188 +0200
+++ /var/tmp/diff_new_pack.3mo0Wo/_new  2019-10-17 12:57:22.513596178 +0200
@@ -20,13 +20,13 @@
 %define vim_plugin_dir %{_datadir}/vim/site/plugin
 
 Name:   devhelp
-Version:3.32.0
+Version:3.34.0
 Release:0
 Summary:Developer's Help Program for GNOME
 License:GPL-3.0-or-later
 Group:  Development/Tools/Other
 URL:https://wiki.gnome.org/Apps/Devhelp
-Source0:
https://download.gnome.org/sources/devhelp/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/devhelp/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 BuildRequires:  gobject-introspection-devel >= 1.30.0

++ devhelp-3.32.0.tar.xz -> devhelp-3.34.0.tar.xz ++
 3011 lines of diff (skipped)




commit eog for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package eog for openSUSE:Factory checked in 
at 2019-10-17 12:57:27

Comparing /work/SRC/openSUSE:Factory/eog (Old)
 and  /work/SRC/openSUSE:Factory/.eog.new.2352 (New)


Package is "eog"

Thu Oct 17 12:57:27 2019 rev:139 rq:736504 version:3.34.1

Changes:

--- /work/SRC/openSUSE:Factory/eog/eog.changes  2019-06-03 18:44:48.784651691 
+0200
+++ /work/SRC/openSUSE:Factory/.eog.new.2352/eog.changes2019-10-17 
12:57:30.153576823 +0200
@@ -1,0 +2,38 @@
+Mon Oct  7 20:45:13 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.1:
+  + Bug fixes:
+- Check errors after rsvg_handle_close().
+- icon: create a nightly app icon.
+- EogApplication: Initialize debug before plugin engine
+  + Updated translations.
+
+---
+Wed Sep 11 11:13:54 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + Updated translations.
+
+---
+Thu Aug 29 09:44:16 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.33.91:
+  + Updated translations.
+- Changes from version 3.33.90:
+  + Updated translations.
+- Changes from version 3.33.3:
+  + Improve meson port.
+  + build: Use #ifdef consistently.
+  + Updated translations.
+
+---
+Tue Jun 25 22:46:13 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.33.2:
+  + Bug fixes: Unreasonable limitation of scaling in print dialog.
+  + Updated translations.
+- Changes from version 3.33.1:
+  + Various help doc improvements.
+  + Bug fixes: glgo#GNOME/eog!20.
+
+--

Old:

  eog-3.32.2.tar.xz

New:

  eog-3.34.1.tar.xz



Other differences:
--
++ eog.spec ++
--- /var/tmp/diff_new_pack.1r3K5a/_old  2019-10-17 12:57:30.705575424 +0200
+++ /var/tmp/diff_new_pack.1r3K5a/_new  2019-10-17 12:57:30.709575414 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   eog
-Version:3.32.2
+Version:3.34.1
 Release:0
 Summary:Image Viewer for GNOME
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  Productivity/Graphics/Viewers
 URL:https://wiki.gnome.org/Apps/EyeOfGnome
-Source0:
https://download.gnome.org/sources/eog/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/eog/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  fdupes
 BuildRequires:  gtk-doc
@@ -46,7 +46,7 @@
 BuildRequires:  pkgconfig(libexif)
 BuildRequires:  pkgconfig(libpeas-1.0) >= 0.7.4
 BuildRequires:  pkgconfig(libpeas-gtk-1.0) >= 0.7.4
-BuildRequires:  pkgconfig(librsvg-2.0) >= 2.36.2
+BuildRequires:  pkgconfig(librsvg-2.0) >= 2.44.0
 BuildRequires:  pkgconfig(shared-mime-info) >= 0.20
 Recommends: %{name}-lang
 

++ eog-3.32.2.tar.xz -> eog-3.34.1.tar.xz ++
 25314 lines of diff (skipped)




commit colord for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package colord for openSUSE:Factory checked 
in at 2019-10-17 12:56:59

Comparing /work/SRC/openSUSE:Factory/colord (Old)
 and  /work/SRC/openSUSE:Factory/.colord.new.2352 (New)


Package is "colord"

Thu Oct 17 12:56:59 2019 rev:78 rq:736499 version:1.4.3

Changes:

--- /work/SRC/openSUSE:Factory/colord/colord.changes2019-06-30 
10:20:04.431487138 +0200
+++ /work/SRC/openSUSE:Factory/.colord.new.2352/colord.changes  2019-10-17 
12:57:01.441649562 +0200
@@ -1,0 +2,5 @@
+Tue Oct  8 19:42:53 UTC 2019 - Christian Boltz 
+
+- Also allow /var/lib/colord/icc/ in AppArmor profile (boo#1112230)
+
+---



Other differences:
--


++ usr.lib.colord ++
--- /var/tmp/diff_new_pack.D8KzDj/_old  2019-10-17 12:57:02.445647019 +0200
+++ /var/tmp/diff_new_pack.D8KzDj/_new  2019-10-17 12:57:02.445647019 +0200
@@ -47,6 +47,7 @@
   /usr/share/locale-bundle/**.mo r,
   /usr/share/mime/** r,
   /var/lib/color/icc/ r,
+  /var/lib/colord/icc/ r,
   /var/lib/colord/.cache/ rw,
   /var/lib/colord/.cache/** rw,
   /var/lib/colord/mapping.db rwk,




commit cheese for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package cheese for openSUSE:Factory checked 
in at 2019-10-17 12:56:51

Comparing /work/SRC/openSUSE:Factory/cheese (Old)
 and  /work/SRC/openSUSE:Factory/.cheese.new.2352 (New)


Package is "cheese"

Thu Oct 17 12:56:51 2019 rev:106 rq:736498 version:3.34.0

Changes:

--- /work/SRC/openSUSE:Factory/cheese/cheese.changes2019-05-03 
22:08:57.895099433 +0200
+++ /work/SRC/openSUSE:Factory/.cheese.new.2352/cheese.changes  2019-10-17 
12:56:54.317667610 +0200
@@ -1,0 +2,23 @@
+Tue Sep 10 20:02:34 UTC 2019 - Bjørn Lie 
+
+- Update to version 3.34.0:
+  + build: Don't use 'lib' prefix in find_library. Meson passes it
+directly to -l option, so an extra 'lib' can cause error
+because it tells the linker to find liblibcanberra-gtk3.so.
+  + Add translator comments to the desktop file.
+  + Updated translations.
+
+---
+Sat Aug 31 16:38:15 CDT 2019 - mgo...@suse.com
+
+- Update to version 3.33.90.1:
+  + Drop libcanberra-gtk (GTK 2) dependency introduced in previous
+release.
+- Changes from version 3.33.90:
+  + Switch to meson build system.
+  + New keyboard shortcuts window.
+  + Updated translations.
+- Switch to meson.
+- Appdata is now installed in /usr/share/metainfo.
+
+---

Old:

  cheese-3.32.1.tar.xz

New:

  cheese-3.34.0.tar.xz



Other differences:
--
++ cheese.spec ++
--- /var/tmp/diff_new_pack.zwBEBc/_old  2019-10-17 12:56:54.933666049 +0200
+++ /var/tmp/diff_new_pack.zwBEBc/_new  2019-10-17 12:56:54.933666049 +0200
@@ -18,19 +18,21 @@
 
 %define lib_major 8
 %define lib_gtk_major 25
+
 Name:   cheese
-Version:3.32.1
+Version:3.34.0
 Release:0
 Summary:Webcam Booth for GNOME
 License:GPL-2.0-or-later
 Group:  Productivity/Multimedia/Other
 URL:https://wiki.gnome.org/Apps/Cheese
-Source0:
https://download.gnome.org/sources/cheese/3.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/cheese/3.34/%{name}-%{version}.tar.xz
 
 BuildRequires:  docbook-xsl-stylesheets
 BuildRequires:  fdupes
 BuildRequires:  gobject-introspection-devel
-BuildRequires:  intltool >= 0.50.0
+BuildRequires:  gtk-doc
+BuildRequires:  meson >= 0.50.0
 BuildRequires:  pkgconfig
 BuildRequires:  translation-update-upstream
 BuildRequires:  update-desktop-files
@@ -124,16 +126,14 @@
 
 %prep
 %autosetup -p1
-translation-update-upstream
+translation-update-upstream po %{name}
 
 %build
-%configure \
-   --disable-static \
-   --disable-scrollkeeper
-%make_build
+%meson
+%meson_build
 
 %install
-%make_install
+%meson_install
 find %{buildroot} -type f -name "*.la" -delete -print
 %find_lang %{name} %{?no_lang_C}
 %suse_update_desktop_file org.gnome.Cheese
@@ -149,8 +149,8 @@
 %doc AUTHORS README ChangeLog
 %doc %{_datadir}/help/C/%{name}/
 %{_bindir}/cheese
-%dir %{_datadir}/appdata
-%{_datadir}/appdata/org.gnome.Cheese.appdata.xml
+%dir %{_datadir}/metainfo
+%{_datadir}/metainfo/org.gnome.Cheese.appdata.xml
 %{_datadir}/applications/org.gnome.Cheese.desktop
 %{_datadir}/icons/hicolor/*/apps/org.gnome.Cheese*.*
 %{_mandir}/man1/cheese.1%{?ext_man}

++ cheese-3.32.1.tar.xz -> cheese-3.34.0.tar.xz ++
 131333 lines of diff (skipped)




commit dconf for openSUSE:Factory

2019-10-17 Thread root
Hello community,

here is the log from the commit of package dconf for openSUSE:Factory checked 
in at 2019-10-17 12:57:08

Comparing /work/SRC/openSUSE:Factory/dconf (Old)
 and  /work/SRC/openSUSE:Factory/.dconf.new.2352 (New)


Package is "dconf"

Thu Oct 17 12:57:08 2019 rev:49 rq:736500 version:0.34.0

Changes:

--- /work/SRC/openSUSE:Factory/dconf/dconf.changes  2019-05-03 
22:12:45.215547833 +0200
+++ /work/SRC/openSUSE:Factory/.dconf.new.2352/dconf.changes2019-10-17 
12:57:09.857628241 +0200
@@ -1,0 +2,17 @@
+Thu Sep 12 14:28:34 CST 2019 - qk...@suse.com
+
+- Update to version 0.34.0:
+  + Increment version number following 0.34 release. 
+
+---
+Fri Aug 30 14:52:11 CDT 2019 - mgo...@suse.com
+
+- Update to version 0.33.2:
+  + Drop references to GDBusConnection objects when D-Bus
+connections are closed.
+- Changes from version 0.33.1:
+  + Factor out a common method to route completion of D-Bus
+methods through.
+  + build: Use weak bindings in gvdb to fix linking with LLD.
+
+---

Old:

  dconf-0.32.0.tar.xz

New:

  dconf-0.34.0.tar.xz



Other differences:
--
++ dconf.spec ++
--- /var/tmp/diff_new_pack.Xo4iBo/_old  2019-10-17 12:57:10.233627289 +0200
+++ /var/tmp/diff_new_pack.Xo4iBo/_new  2019-10-17 12:57:10.233627289 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   dconf
-Version:0.32.0
+Version:0.34.0
 Release:0
 Summary:Key-based configuration system
 License:LGPL-2.1-or-later
 Group:  System/Libraries
 URL:https://live.gnome.org/dconf
-Source0:
https://download.gnome.org/sources/dconf/0.32/%{name}-%{version}.tar.xz
+Source0:
https://download.gnome.org/sources/dconf/0.34/%{name}-%{version}.tar.xz
 Source99:   baselibs.conf
 # PATCH-FIX-UPSTREAM 0001-gvdb-Restore-permissions-on-changed-files.patch 
bsc#1025721 bsc#971074 bgo#758066 fezh...@suse.com -- Restore permissions on 
files changed by dconf update.
 Patch0: 0001-gvdb-Restore-permissions-on-changed-files.patch

++ dconf-0.32.0.tar.xz -> dconf-0.34.0.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dconf-0.32.0/NEWS new/dconf-0.34.0/NEWS
--- old/dconf-0.32.0/NEWS   2019-03-11 19:15:41.0 +0100
+++ new/dconf-0.34.0/NEWS   2019-09-10 00:56:47.0 +0200
@@ -1,3 +1,17 @@
+Changes in dconf 0.33.2
+===
+
+ - Drop references to GDBusConnection objects when D-Bus connections are closed
+   (Andre Magalhaes, #51)
+
+Changes in dconf 0.33.1
+===
+
+ - Factor out a common method to route completion of D-Bus methods through
+   (Cosimo Cecchi, #29)
+ - build: Use weak bindings in gvdb to fix linking with LLD
+   (Ting-Wei Lan, #28)
+
 Changes in dconf 0.32.0
 ===
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/dconf-0.32.0/engine/dconf-engine.h 
new/dconf-0.34.0/engine/dconf-engine.h
--- old/dconf-0.32.0/engine/dconf-engine.h  2019-03-11 19:15:41.0 
+0100
+++ new/dconf-0.34.0/engine/dconf-engine.h  2019-09-10 00:56:47.0 
+0200
@@ -67,6 +67,17 @@
  const 
GVariantType  *expected_type,
  
GError **error);
 
+/* Helper function used by the client library to handle bus disconnection */
+G_GNUC_INTERNAL
+voiddconf_engine_dbus_handle_connection_closed  
(GDBusConnection *connection,
+ 
gboolean remote_peer_vanished,
+ 
GError  *error,
+ 
GMutex  *bus_lock,
+ 
gboolean*bus_is_error,
+ 
gpointer*bus_data,
+ 
GCallbackbus_closed_callback,
+ 
gpointer bus_closed_callback_user_data);
+
 /* Notifies that a change occured.
  *
  * The engine lock is never held when calling this function so it is
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 

  1   2   >