commit 00Meta for openSUSE:Leap:15.2:PowerPC

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 00Meta for 
openSUSE:Leap:15.2:PowerPC checked in at 2020-03-19 00:46:55

Comparing /work/SRC/openSUSE:Leap:15.2:PowerPC/00Meta (Old)
 and  /work/SRC/openSUSE:Leap:15.2:PowerPC/.00Meta.new.3160 (New)


Package is "00Meta"

Thu Mar 19 00:46:55 2020 rev:106 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ version_totest ++
--- /var/tmp/diff_new_pack.gnyqG2/_old  2020-03-19 00:46:56.801045292 +0100
+++ /var/tmp/diff_new_pack.gnyqG2/_new  2020-03-19 00:46:56.805045294 +0100
@@ -1 +1 @@
-171.1
\ No newline at end of file
+171.2
\ No newline at end of file




commit 000release-packages for openSUSE:Leap:15.2:PowerPC

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 000release-packages for 
openSUSE:Leap:15.2:PowerPC checked in at 2020-03-18 21:34:19

Comparing /work/SRC/openSUSE:Leap:15.2:PowerPC/000release-packages (Old)
 and  /work/SRC/openSUSE:Leap:15.2:PowerPC/.000release-packages.new.3160 
(New)


Package is "000release-packages"

Wed Mar 18 21:34:19 2020 rev:145 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
openSUSE-release.spec: same change
stub.spec: same change
++ weakremovers.inc ++
--- /var/tmp/diff_new_pack.8HsRRM/_old  2020-03-18 21:34:20.957768757 +0100
+++ /var/tmp/diff_new_pack.8HsRRM/_new  2020-03-18 21:34:20.957768757 +0100
@@ -4964,6 +4964,7 @@
 Provides: weakremover(libsrt1-64bit)
 Provides: weakremover(libssh2-1-64bit)
 Provides: weakremover(libssh4-64bit)
+Provides: weakremover(libsuperlu5-64bit)
 Provides: weakremover(libswresample3-64bit)
 Provides: weakremover(libswscale5-64bit)
 Provides: weakremover(libsystemd0-64bit)
@@ -13102,9 +13103,6 @@
 Provides: weakremover(libsundials_nvec5-openmpi2)
 Provides: weakremover(libsundials_nvec5-openmpi3)
 Provides: weakremover(libsunpinyin3)
-Provides: weakremover(libsuperlu-gnu-hpc)
-Provides: weakremover(libsuperlu5)
-Provides: weakremover(libsuperlu_5_2_1-gnu-hpc)
 Provides: weakremover(libsvm-devel)
 Provides: weakremover(libsvm2)
 Provides: weakremover(libsvrcore0)
@@ -18201,12 +18199,6 @@
 Provides: weakremover(sunpinyin-tools)
 Provides: weakremover(sunwait)
 Provides: weakremover(sunxi-tools)
-Provides: weakremover(superlu-devel)
-Provides: weakremover(superlu-doc)
-Provides: weakremover(superlu-examples)
-Provides: weakremover(superlu_5_2_1-gnu-hpc-devel)
-Provides: weakremover(superlu_5_2_1-gnu-hpc-doc)
-Provides: weakremover(superlu_5_2_1-gnu-hpc-examples)
 Provides: weakremover(supermin)
 Provides: weakremover(supertuxkart)
 Provides: weakremover(sushi)
@@ -21443,6 +21435,9 @@
 Provides: weakremover(libstorage-ng-ruby)
 Provides: weakremover(libstorage-ng-utils)
 Provides: weakremover(libstorage-ng1)
+Provides: weakremover(libsuperlu-gnu-hpc)
+Provides: weakremover(libsuperlu5)
+Provides: weakremover(libsuperlu_5_2_1-gnu-hpc)
 Provides: weakremover(libsvn_auth_gnome_keyring-1-0)
 Provides: weakremover(libsvn_auth_kwallet-1-0)
 Provides: weakremover(libswresample2)
@@ -22895,6 +22890,12 @@
 Provides: weakremover(sudo)
 Provides: weakremover(sudo-devel)
 Provides: weakremover(sudo-test)
+Provides: weakremover(superlu-devel)
+Provides: weakremover(superlu-doc)
+Provides: weakremover(superlu-examples)
+Provides: weakremover(superlu_5_2_1-gnu-hpc-devel)
+Provides: weakremover(superlu_5_2_1-gnu-hpc-doc)
+Provides: weakremover(superlu_5_2_1-gnu-hpc-examples)
 Provides: weakremover(suse-hpc)
 Provides: weakremover(suse-module-tools)
 Provides: weakremover(suse-module-tools-legacy)




commit 000release-packages for openSUSE:Leap:15.2:ARM

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 000release-packages for 
openSUSE:Leap:15.2:ARM checked in at 2020-03-18 21:29:00

Comparing /work/SRC/openSUSE:Leap:15.2:ARM/000release-packages (Old)
 and  /work/SRC/openSUSE:Leap:15.2:ARM/.000release-packages.new.3160 (New)


Package is "000release-packages"

Wed Mar 18 21:29:00 2020 rev:115 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
stub.spec: same change
++ weakremovers.inc ++
 696 lines (skipped)
 between 
/work/SRC/openSUSE:Leap:15.2:ARM/000release-packages/weakremovers.inc
 and 
/work/SRC/openSUSE:Leap:15.2:ARM/.000release-packages.new.3160/weakremovers.inc




commit 000update-repos for openSUSE:Leap:15.2:PowerPC

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 000update-repos for 
openSUSE:Leap:15.2:PowerPC checked in at 2020-03-18 21:07:09

Comparing /work/SRC/openSUSE:Leap:15.2:PowerPC/000update-repos (Old)
 and  /work/SRC/openSUSE:Leap:15.2:PowerPC/.000update-repos.new.3160 (New)


Package is "000update-repos"

Wed Mar 18 21:07:09 2020 rev:137 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.1:ppc:update_1584561286.packages.xz



Other differences:
--
































































































































































































































































































commit 000update-repos for openSUSE:Leap:15.2

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 000update-repos for 
openSUSE:Leap:15.2 checked in at 2020-03-18 21:04:24

Comparing /work/SRC/openSUSE:Leap:15.2/000update-repos (Old)
 and  /work/SRC/openSUSE:Leap:15.2/.000update-repos.new.3160 (New)


Package is "000update-repos"

Wed Mar 18 21:04:24 2020 rev:559 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.1:update_1584559483.packages.xz



Other differences:
--






























































































































































































































































































































































































































































































































































































































commit 000update-repos for openSUSE:Leap:15.2:ARM

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 000update-repos for 
openSUSE:Leap:15.2:ARM checked in at 2020-03-18 21:04:27

Comparing /work/SRC/openSUSE:Leap:15.2:ARM/000update-repos (Old)
 and  /work/SRC/openSUSE:Leap:15.2:ARM/.000update-repos.new.3160 (New)


Package is "000update-repos"

Wed Mar 18 21:04:27 2020 rev:81 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.2:arm_130.1.packages.xz



Other differences:
--




















































































































































































































































































































































commit 000update-repos for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 000update-repos for openSUSE:Factory 
checked in at 2020-03-18 21:03:18

Comparing /work/SRC/openSUSE:Factory/000update-repos (Old)
 and  /work/SRC/openSUSE:Factory/.000update-repos.new.3160 (New)


Package is "000update-repos"

Wed Mar 18 21:03:18 2020 rev:950 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  15.1:update_1584559483.packages.xz



Other differences:
--

































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































commit 00Meta for openSUSE:Leap:15.1:Images

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 00Meta for openSUSE:Leap:15.1:Images 
checked in at 2020-03-18 21:00:48

Comparing /work/SRC/openSUSE:Leap:15.1:Images/00Meta (Old)
 and  /work/SRC/openSUSE:Leap:15.1:Images/.00Meta.new.3160 (New)


Package is "00Meta"

Wed Mar 18 21:00:48 2020 rev:326 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ version_totest ++
--- /var/tmp/diff_new_pack.jxZPjW/_old  2020-03-18 21:00:50.148611856 +0100
+++ /var/tmp/diff_new_pack.jxZPjW/_new  2020-03-18 21:00:50.156611859 +0100
@@ -1 +1 @@
-8.11.3
\ No newline at end of file
+8.11.5
\ No newline at end of file




commit patchinfo.12116 for openSUSE:Leap:15.1:Update

2020-03-18 Thread root
Hello community,

here is the log from the commit of package patchinfo.12116 for 
openSUSE:Leap:15.1:Update checked in at 2020-03-18 20:17:38

Comparing /work/SRC/openSUSE:Leap:15.1:Update/patchinfo.12116 (Old)
 and  /work/SRC/openSUSE:Leap:15.1:Update/.patchinfo.12116.new.3160 (New)


Package is "patchinfo.12116"

Wed Mar 18 20:17:38 2020 rev:1 rq:784708 version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _patchinfo



Other differences:
--
++ _patchinfo ++

  recommended
  moderate
  msmeissn
  Recommended update for pam
  
This update for PAM fixes the following issue:

- The license of libdb linked against pam_userdb is not always wanted,
  so we temporary disabled pam_userdb again. It will be published
  in a different package at a later time. (bsc#1166510)
  
This update was imported from the SUSE:SLE-15:Update update 
project.
  new libdb dependency released with pam 
update




commit patchinfo.12117 for openSUSE:Leap:15.1:Update

2020-03-18 Thread root
Hello community,

here is the log from the commit of package patchinfo.12117 for 
openSUSE:Leap:15.1:Update checked in at 2020-03-18 20:17:47

Comparing /work/SRC/openSUSE:Leap:15.1:Update/patchinfo.12117 (Old)
 and  /work/SRC/openSUSE:Leap:15.1:Update/.patchinfo.12117.new.3160 (New)


Package is "patchinfo.12117"

Wed Mar 18 20:17:47 2020 rev:1 rq:784709 version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _patchinfo



Other differences:
--
++ _patchinfo ++

  new secur...@suse.de key for 
2020-2022
  msmeissn
  moderate
  recommended
  Recommended update for suse-build-key
  This update for suse-build-key fixes the following issues:

- created a new secur...@suse.de communication key (bsc#1166334)

This update was imported from the SUSE:SLE-15:Update update 
project.




commit pam for openSUSE:Leap:15.1:Update

2020-03-18 Thread root
Hello community,

here is the log from the commit of package pam for openSUSE:Leap:15.1:Update 
checked in at 2020-03-18 20:17:36

Comparing /work/SRC/openSUSE:Leap:15.1:Update/pam (Old)
 and  /work/SRC/openSUSE:Leap:15.1:Update/.pam.new.3160 (New)


Package is "pam"

Wed Mar 18 20:17:36 2020 rev:2 rq:784708 version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.A4sQnD/_old  2020-03-18 20:17:38.559184929 +0100
+++ /var/tmp/diff_new_pack.A4sQnD/_new  2020-03-18 20:17:38.563184931 +0100
@@ -1 +1 @@
-
+




commit 000product for openSUSE:Leap:15.2:ARM

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 000product for 
openSUSE:Leap:15.2:ARM checked in at 2020-03-18 18:24:19

Comparing /work/SRC/openSUSE:Leap:15.2:ARM/000product (Old)
 and  /work/SRC/openSUSE:Leap:15.2:ARM/.000product.new.3160 (New)


Package is "000product"

Wed Mar 18 18:24:19 2020 rev:131 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ openSUSE-dvd5-dvd-aarch64.kiwi ++
--- /var/tmp/diff_new_pack.RVPtL8/_old  2020-03-18 18:24:21.427987266 +0100
+++ /var/tmp/diff_new_pack.RVPtL8/_new  2020-03-18 18:24:21.427987266 +0100
@@ -3568,7 +3568,9 @@
   
   
   
+  
   
+  
   
   
   

openSUSE-ftp-ftp-armv7hl.kiwi: same change
stub.kiwi: same change
++ dvd.group ++
--- /var/tmp/diff_new_pack.RVPtL8/_old  2020-03-18 18:24:21.539987321 +0100
+++ /var/tmp/diff_new_pack.RVPtL8/_new  2020-03-18 18:24:21.543987323 +0100
@@ -3517,7 +3517,9 @@
  
  
  
+ 

  
+ 

  
  
  

++ openSUSE-dvd5-dvd-aarch64.kwd ++
--- /var/tmp/diff_new_pack.RVPtL8/_old  2020-03-18 18:24:21.567987335 +0100
+++ /var/tmp/diff_new_pack.RVPtL8/_new  2020-03-18 18:24:21.567987335 +0100
@@ -3516,7 +3516,9 @@
 trytond_stock_lot: +Kwd:\nsupport_unsupported\n-Kwd:
 trytond_stock_supply: +Kwd:\nsupport_unsupported\n-Kwd:
 tumbler: +Kwd:\nsupport_unsupported\n-Kwd:
+tumbler-folder-thumbnailer: +Kwd:\nsupport_unsupported\n-Kwd:
 tumbler-lang: +Kwd:\nsupport_unsupported\n-Kwd:
+tumbler-webp-thumbnailer: +Kwd:\nsupport_unsupported\n-Kwd:
 tuned: +Kwd:\nsupport_unsupported\n-Kwd:
 twm: +Kwd:\nsupport_unsupported\n-Kwd:
 typelib-1_0-AccountsService-1_0: +Kwd:\nsupport_unsupported\n-Kwd:

++ unsorted.yml ++
--- /var/tmp/diff_new_pack.RVPtL8/_old  2020-03-18 18:24:21.607987355 +0100
+++ /var/tmp/diff_new_pack.RVPtL8/_new  2020-03-18 18:24:21.611987356 +0100
@@ -1967,6 +1967,7 @@
   - crash-doc 
   - crash-eppic 
   - crash-kmp-default 
+  - crash-kmp-preempt 
   - crawl 
   - crawl-data 
   - crawl-sdl 
@@ -8557,7 +8558,7 @@
   - libgda-ui-5_0-plugins 
   - libgda-ui-5_0-tools 
   - libgda-xslt-5_0-4 
-  - libgdal20 
+  - libgdal26 
   - libgdata-devel 
   - libgdiplus-devel 
   - libgdiplus0 
@@ -8578,7 +8579,7 @@
   - libgeners0 
   - libgeos-3_6_2 
   - libgeos_c1 
-  - libgeotiff2 
+  - libgeotiff5 
   - libgepub-0_6-0 
   - libgepub-devel 
   - libgerbv1 
@@ -9993,8 +9994,7 @@
   - libprimesieve9 
   - libprison-devel 
   - libprofiler0 
-  - libproj-devel 
-  - libproj12 
+  - libproj15 
   - libprojectM-libvisual 
   - libprojectM-qt1 
   - libprojectM2 
@@ -14454,6 +14454,7 @@
   - pcb-doc 
   - pcfclock 
   - pcfclock-kmp-default 
+  - pcfclock-kmp-preempt 
   - pciutils-devel 
   - pcmanfm 
   - pcmanfm-devel 
@@ -16337,6 +16338,7 @@
   - proguard 
   - proguard-gui 
   - proj 
+  - proj-devel 
   - projectM 
   - projectM-data 
   - projectM-devel 




commit 00Meta for openSUSE:Leap:15.2:ARM:Images

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 00Meta for 
openSUSE:Leap:15.2:ARM:Images checked in at 2020-03-18 16:46:33

Comparing /work/SRC/openSUSE:Leap:15.2:ARM:Images/00Meta (Old)
 and  /work/SRC/openSUSE:Leap:15.2:ARM:Images/.00Meta.new.3160 (New)


Package is "00Meta"

Wed Mar 18 16:46:33 2020 rev:42 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ version_totest ++
--- /var/tmp/diff_new_pack.ekDtxM/_old  2020-03-18 16:46:34.601458250 +0100
+++ /var/tmp/diff_new_pack.ekDtxM/_new  2020-03-18 16:46:34.601458250 +0100
@@ -1 +1 @@
-1.25
\ No newline at end of file
+1.30
\ No newline at end of file




commit salt for openSUSE:Leap:15.1:Update

2020-03-18 Thread root
Hello community,

here is the log from the commit of package salt for openSUSE:Leap:15.1:Update 
checked in at 2020-03-18 16:18:45

Comparing /work/SRC/openSUSE:Leap:15.1:Update/salt (Old)
 and  /work/SRC/openSUSE:Leap:15.1:Update/.salt.new.3160 (New)


Package is "salt"

Wed Mar 18 16:18:45 2020 rev:4 rq:784680 version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.RGTK03/_old  2020-03-18 16:18:48.528435024 +0100
+++ /var/tmp/diff_new_pack.RGTK03/_new  2020-03-18 16:18:48.528435024 +0100
@@ -1 +1 @@
-
+




commit icewm-theme-branding for openSUSE:Leap:15.1:Update

2020-03-18 Thread root
Hello community,

here is the log from the commit of package icewm-theme-branding for 
openSUSE:Leap:15.1:Update checked in at 2020-03-18 14:18:40

Comparing /work/SRC/openSUSE:Leap:15.1:Update/icewm-theme-branding (Old)
 and  /work/SRC/openSUSE:Leap:15.1:Update/.icewm-theme-branding.new.3160 
(New)


Package is "icewm-theme-branding"

Wed Mar 18 14:18:40 2020 rev:1 rq:784646 version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _link



Other differences:
--
++ _link ++




commit patchinfo.12113 for openSUSE:Leap:15.1:Update

2020-03-18 Thread root
Hello community,

here is the log from the commit of package patchinfo.12113 for 
openSUSE:Leap:15.1:Update checked in at 2020-03-18 14:18:59

Comparing /work/SRC/openSUSE:Leap:15.1:Update/patchinfo.12113 (Old)
 and  /work/SRC/openSUSE:Leap:15.1:Update/.patchinfo.12113.new.3160 (New)


Package is "patchinfo.12113"

Wed Mar 18 14:18:59 2020 rev:1 rq:784646 version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _patchinfo



Other differences:
--
++ _patchinfo ++

  [Build C.121.1] The web-browser icon on 
icewm toolbar does not display.
  yfjiang
  moderate
  recommended
  Recommended update for icewm-theme-branding
  This update for icewm-theme-branding fixes the following issue:

- icewm can not find default web-browser toolbar icon. (bsc#1157930)
  This update adds the adwaita legacy path to the IconPath in preferences. 
  adwaita-icon-theme has its main icon updated to symbolic style, while icewm's
  style is more suitable for legacy-style icons (eg. web-browser).

This update was imported from the SUSE:SLE-15:Update update 
project.




commit 00Meta for openSUSE:Leap:15.1:Images

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 00Meta for openSUSE:Leap:15.1:Images 
checked in at 2020-03-18 13:45:40

Comparing /work/SRC/openSUSE:Leap:15.1:Images/00Meta (Old)
 and  /work/SRC/openSUSE:Leap:15.1:Images/.00Meta.new.3160 (New)


Package is "00Meta"

Wed Mar 18 13:45:40 2020 rev:325 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ version_totest ++
--- /var/tmp/diff_new_pack.YDiyy4/_old  2020-03-18 13:45:42.906556386 +0100
+++ /var/tmp/diff_new_pack.YDiyy4/_new  2020-03-18 13:45:42.938556404 +0100
@@ -1 +1 @@
-8.11.2
\ No newline at end of file
+8.11.3
\ No newline at end of file




commit libffi-AGGR for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package libffi-AGGR for openSUSE:Factory 
checked in at 2020-03-18 13:02:02

Comparing /work/SRC/openSUSE:Factory/libffi-AGGR (Old)
 and  /work/SRC/openSUSE:Factory/.libffi-AGGR.new.3160 (New)


Package is "libffi-AGGR"

Wed Mar 18 13:02:02 2020 rev:1 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!

New:

  _aggregate



Other differences:
--
++ _aggregate ++

  
libffi
  




commit dracut for openSUSE:Leap:15.1:Update

2020-03-18 Thread root
Hello community,

here is the log from the commit of package dracut for openSUSE:Leap:15.1:Update 
checked in at 2020-03-18 12:54:09

Comparing /work/SRC/openSUSE:Leap:15.1:Update/dracut (Old)
 and  /work/SRC/openSUSE:Leap:15.1:Update/.dracut.new.3160 (New)


Package is "dracut"

Wed Mar 18 12:54:09 2020 rev:4 rq:784584 version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ _link ++
--- /var/tmp/diff_new_pack.cIr2Lt/_old  2020-03-18 12:58:31.097430077 +0100
+++ /var/tmp/diff_new_pack.cIr2Lt/_new  2020-03-18 12:58:31.101430079 +0100
@@ -1 +1 @@
-
+




commit openSUSE-MicroOS for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package openSUSE-MicroOS for 
openSUSE:Factory checked in at 2020-03-18 12:48:32

Comparing /work/SRC/openSUSE:Factory/openSUSE-MicroOS (Old)
 and  /work/SRC/openSUSE:Factory/.openSUSE-MicroOS.new.3160 (New)


Package is "openSUSE-MicroOS"

Wed Mar 18 12:48:32 2020 rev:22 rq:786124 version:16.0.0

Changes:

--- /work/SRC/openSUSE:Factory/openSUSE-MicroOS/openSUSE-MicroOS.changes
2020-03-12 23:12:38.487331863 +0100
+++ 
/work/SRC/openSUSE:Factory/.openSUSE-MicroOS.new.3160/openSUSE-MicroOS.changes  
2020-03-18 12:52:36.145218073 +0100
@@ -1,0 +2,6 @@
+Wed Mar 18 09:47:11 UTC 2020 - Fabian Vogt 
+
+- Make check for kubelet in config.sh more generic to work after
+  the package rename
+
+---



Other differences:
--
++ config.sh ++
--- /var/tmp/diff_new_pack.rCefHp/_old  2020-03-18 12:52:36.925218539 +0100
+++ /var/tmp/diff_new_pack.rCefHp/_new  2020-03-18 12:52:36.925218539 +0100
@@ -117,7 +117,7 @@
 #==
 # Enable kubelet if installed
 #--
-if rpm -q kubernetes-kubelet >/dev/null; then
+if [ -e /usr/lib/systemd/system/kubelet.service ]; then
suseInsertService kubelet
 fi
 




commit nsd for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package nsd for openSUSE:Factory checked in 
at 2020-03-18 12:47:16

Comparing /work/SRC/openSUSE:Factory/nsd (Old)
 and  /work/SRC/openSUSE:Factory/.nsd.new.3160 (New)


Package is "nsd"

Wed Mar 18 12:47:16 2020 rev:15 rq:786102 version:4.3.0

Changes:

--- /work/SRC/openSUSE:Factory/nsd/nsd.changes  2019-12-12 23:20:42.786199753 
+0100
+++ /work/SRC/openSUSE:Factory/.nsd.new.3160/nsd.changes2020-03-18 
12:52:23.217210351 +0100
@@ -1,0 +2,62 @@
+Tue Mar 17 20:52:34 UTC 2020 - Michael Ströder 
+
+- New upstream release 4.3.0
+
+FEATURES:
+- Fix to use getrandom() for randomness, if available.
+- Fix #56: Drop sparse TSIG signing support in NSD.
+  Sign every axfr packet with TSIG, according to the latest
+  draft-ietf-dnsop-rfc2845bis-06, Section 5.3.1.
+- Merge pull request #59 from buddyns: add FreeBSD support
+  for conf key ip-transparent.
+- Add feature to pin server processes to specific cpus.
+- Add feature to pin IP addresses to selected server processes.
+- Set process title to identify individual processes.
+- Merge PR#22: minimise-any: prefer polular and not large RRset,
+  from Daisuke Higashi.
+- Add support for SO_BINDTODEVICE on Linux.
+- Add support for SO_SETFIB on FreeBSD.
+- Add feature to drop queries with opcode UPDATE.
+
+BUG FIXES:
+- Fix fname null check of fname in namedb_read_zonefile.
+- Fix implicit cast of size in udb_radnode_array_grow.
+- Fix ignore of return value of ssl_printf in remote.c.
+- Fix unused check of fd in parent_handle_reload_command.
+- Attempt to fix signedness of nscount lookup in ixfr query_process.
+- Fix identical branches for ssl_print of errors in remote.c.
+- Fix type cast bounds, signedness of opt_rdlen in edns_parse_record.
+- Fix to separate header and data lines in parse_zone_list_file.
+- Fix to define max number of EDNS records we are willing to
+  spend time on.
+- Fix size of string len and capacity type cast in udbradtree.
+- Fix to protect rrcount in tsig_find_rr from overflow.
+- Annotate radix_find_prefix_node not reachable trail code.
+- Fix to protect rrcount in packet_find_notify_serial from overflow.
+- Fix to close socket on error in create_tcp_accept_sock.
+- Fix to log on failure to chmod for socket for remote control.
+- Fix to remove unneeded if in open of socket for remote control.
+- Fix to restore input parameter on call failure in create_dirs.
+- Please checker by terminating and initialising string read
+  by remote control.
+- Fix to define upper bounds on rr counts read from untrusted packet
+  data.
+- Separate acl_addr_match_range functions for ip4 and ip6, to
+  please checkers.
+- Avoid unused variable warning in new match_range_v4 function.
+- Fix whitespace in nsd.conf.sample.in, patch from Paul Wouters.
+- use-systemd is ignored in nsd.conf, when NSD is compiled with
+  libsystemd it always signals readiness, if possible.
+- Note that use-systemd is not necessary and ignored in man page.
+- Fix unreachable code in ssl set options code.
+- Fix bad shift in assertion code analyzer complaint.
+- Fix responses for IXFR so that the authority section is not echoed
+  in the response.
+- Merge PR#60: Minor portability fixes from michaelforney, with
+  avoid pointer arithmetic on void* and avoid unnecessary VLA.
+- Fix that the retry wait does not exceed one day for zone transfers.
+
+CHANGES:
+- Set FD_CLOEXEC on opened sockets.
+
+---

Old:

  nsd-4.2.4.tar.gz
  nsd-4.2.4.tar.gz.asc

New:

  nsd-4.3.0.tar.gz
  nsd-4.3.0.tar.gz.asc



Other differences:
--
++ nsd.spec ++
--- /var/tmp/diff_new_pack.NRnBWi/_old  2020-03-18 12:52:24.661211214 +0100
+++ /var/tmp/diff_new_pack.NRnBWi/_new  2020-03-18 12:52:24.661211214 +0100
@@ -23,7 +23,7 @@
 %define zonesdir   %{configdir}/zones
 %define pidfile%{_rundir}/nsd/nsd.pid
 Name:   nsd
-Version:4.2.4
+Version:4.3.0
 Release:0
 #
 Summary:An authoritative-only domain name server

++ nsd-4.2.4.tar.gz -> nsd-4.3.0.tar.gz ++
 12688 lines of diff (skipped)





commit cacti for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package cacti for openSUSE:Factory checked 
in at 2020-03-18 12:47:51

Comparing /work/SRC/openSUSE:Factory/cacti (Old)
 and  /work/SRC/openSUSE:Factory/.cacti.new.3160 (New)


Package is "cacti"

Wed Mar 18 12:47:51 2020 rev:29 rq:786099 version:1.2.10

Changes:

--- /work/SRC/openSUSE:Factory/cacti/cacti.changes  2020-02-18 
13:29:47.984748530 +0100
+++ /work/SRC/openSUSE:Factory/.cacti.new.3160/cacti.changes2020-03-18 
12:52:32.073215641 +0100
@@ -1,0 +2,12 @@
+Sun Mar 15 16:44:23 UTC 2020 - Paolo Stivanin 
+
+- cacti 1.2.10:
+  * CVE-2020-8813: when guest users have access to realtime graphs,
+remote code could be executed
+  * When using User Domains, global template user is used instead of
+the configured domain template user
+  * Unix timestamps after Sep 13 2020 are rejected as graph start/end
+arguments
+  * many bug fixes
+
+---

Old:

  cacti-1.2.9.tar.gz

New:

  cacti-1.2.10.tar.gz



Other differences:
--
++ cacti.spec ++
--- /var/tmp/diff_new_pack.jPCG9w/_old  2020-03-18 12:52:34.281216960 +0100
+++ /var/tmp/diff_new_pack.jPCG9w/_new  2020-03-18 12:52:34.281216960 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package cacti
 #
-# Copyright (c) 2020 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -22,7 +22,7 @@
 %define cacti_dir %{apache_datadir}/cacti
 %endif
 Name:   cacti
-Version:1.2.9
+Version:1.2.10
 Release:0
 Summary:Web Front-End to Monitor System Data via RRDtool
 License:GPL-2.0-or-later

++ cacti-1.2.9.tar.gz -> cacti-1.2.10.tar.gz ++
/work/SRC/openSUSE:Factory/cacti/cacti-1.2.9.tar.gz 
/work/SRC/openSUSE:Factory/.cacti.new.3160/cacti-1.2.10.tar.gz differ: char 5, 
line 1




commit python-python-dotenv for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-python-dotenv for 
openSUSE:Factory checked in at 2020-03-18 12:45:59

Comparing /work/SRC/openSUSE:Factory/python-python-dotenv (Old)
 and  /work/SRC/openSUSE:Factory/.python-python-dotenv.new.3160 (New)


Package is "python-python-dotenv"

Wed Mar 18 12:45:59 2020 rev:5 rq:786117 version:0.12.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-python-dotenv/python-python-dotenv.changes
2019-07-22 17:20:15.481896644 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-python-dotenv.new.3160/python-python-dotenv.changes
  2020-03-18 12:51:56.733194533 +0100
@@ -1,0 +2,6 @@
+Wed Mar 18 09:17:07 UTC 2020 - Tomáš Chvátal 
+
+- Update to 0.12.0:
+  * various fixes
+
+---

Old:

  python-dotenv-0.10.3.tar.gz

New:

  python-dotenv-0.12.0.tar.gz



Other differences:
--
++ python-python-dotenv.spec ++
--- /var/tmp/diff_new_pack.Npe34t/_old  2020-03-18 12:51:58.553195620 +0100
+++ /var/tmp/diff_new_pack.Npe34t/_new  2020-03-18 12:51:58.553195620 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-python-dotenv
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,15 +18,15 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-python-dotenv
-Version:0.10.3
+Version:0.12.0
 Release:0
 Summary:Python library for .env support
 License:BSD-3-Clause
-Group:  Development/Languages/Python
-URL:http://github.com/theskumar/python-dotenv
+URL:https://github.com/theskumar/python-dotenv
 Source: 
https://github.com/theskumar/python-dotenv/archive/v%{version}.tar.gz#/python-dotenv-%{version}.tar.gz
 BuildRequires:  %{python_module click >= 5.0}
 BuildRequires:  %{python_module jupyter_ipython}
+BuildRequires:  %{python_module mock}
 BuildRequires:  %{python_module pytest >= 3.0.5}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{python_module sh >= 1.09}

++ python-dotenv-0.10.3.tar.gz -> python-dotenv-0.12.0.tar.gz ++
 2577 lines of diff (skipped)




commit darktable for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package darktable for openSUSE:Factory 
checked in at 2020-03-18 12:46:41

Comparing /work/SRC/openSUSE:Factory/darktable (Old)
 and  /work/SRC/openSUSE:Factory/.darktable.new.3160 (New)


Package is "darktable"

Wed Mar 18 12:46:41 2020 rev:86 rq:786116 version:3.0.1

Changes:

--- /work/SRC/openSUSE:Factory/darktable/darktable.changes  2020-02-13 
10:13:48.152419551 +0100
+++ /work/SRC/openSUSE:Factory/.darktable.new.3160/darktable.changes
2020-03-18 12:52:14.213204974 +0100
@@ -1,0 +2,8 @@
+Tue Mar 10 16:28:28 UTC 2020 - Andreas Schneider 
+
+- Update to version 3.0.1
+  * https://github.com/darktable-org/darktable/releases/tag/release-3.0.1
+- added 
https://github.com/darktable-org/darktable/commit/8bceae80bd8459f4ec5929df75d6ec0471c3d26c.patch
+  to fix regression in the basic adjustment module.
+
+---

Old:

  darktable-3.0.0.tar.xz
  darktable-3.0.0.tar.xz.asc

New:

  8bceae80bd8459f4ec5929df75d6ec0471c3d26c.patch
  darktable-3.0.1.tar.xz
  darktable-3.0.1.tar.xz.asc



Other differences:
--
++ darktable.spec ++
--- /var/tmp/diff_new_pack.8YhvBG/_old  2020-03-18 12:52:19.237207974 +0100
+++ /var/tmp/diff_new_pack.8YhvBG/_new  2020-03-18 12:52:19.237207974 +0100
@@ -55,10 +55,10 @@
 %endif
 
 Name:   darktable
-Version:3.0.0
+Version:3.0.1
 Release:0
 %define pkg_name darktable
-%define pkg_version 3.0.0
+%define pkg_version 3.0.1
 URL:http://www.darktable.org/
 Source0:%{pkg_name}-%{pkg_version}.tar.xz
 Source1:
https://github.com/darktable-org/darktable/releases/download/release-3.0.0/darktable-usermanual.pdf
@@ -71,6 +71,7 @@
 Source98:   debian.tar.xz
 Source99:   README.openSUSE
 Patch:  darktable-old-glib.patch
+Patch1: 
https://github.com/darktable-org/darktable/commit/8bceae80bd8459f4ec5929df75d6ec0471c3d26c.patch
 
 ExclusiveArch:  x86_64 aarch64 ppc64le
 # build time tools

++ 8bceae80bd8459f4ec5929df75d6ec0471c3d26c.patch ++
>From 8bceae80bd8459f4ec5929df75d6ec0471c3d26c Mon Sep 17 00:00:00 2001
From: coolcom200 
Date: Mon, 9 Mar 2020 20:47:16 -0400
Subject: [PATCH] Fix: Missing legacy_params in Basic Adjustment module

---
 src/iop/basicadj.c | 24 
 1 file changed, 24 insertions(+)

diff --git a/src/iop/basicadj.c b/src/iop/basicadj.c
index fa24e32ae4..9b79690d7d 100644
--- a/src/iop/basicadj.c
+++ b/src/iop/basicadj.c
@@ -90,6 +90,30 @@ typedef struct dt_iop_basicadj_global_data_t
   int kernel_basicadj;
 } dt_iop_basicadj_global_data_t;
 
+int legacy_params(dt_iop_module_t *self, const void *const old_params, const 
int old_version, void *new_params,
+  const int new_version)
+{
+  if(old_version == 1 && new_version == 2)
+  {
+const dt_iop_basicadj_params_t *old = old_params;
+dt_iop_basicadj_params_t *new = new_params;
+
+new->black_point = old->black_point;
+new->exposure = old->exposure;
+new->hlcompr = old->hlcompr;
+new->hlcomprthresh = old->hlcomprthresh;
+new->contrast = old->contrast;
+new->preserve_colors = old->preserve_colors;
+new->middle_grey = old->middle_grey;
+new->brightness = old->brightness;
+new->saturation = old->saturation;
+new->clip = old->clip;
+new->vibrance = 0;
+return 0;
+  }
+  return 1;
+}
+
 const char *name()
 {
   return _("basic adjustments");
++ darktable-3.0.0.tar.xz -> darktable-3.0.1.tar.xz ++
 39268 lines of diff (skipped)

++ darktable.dsc ++
--- /var/tmp/diff_new_pack.8YhvBG/_old  2020-03-18 12:52:20.401208670 +0100
+++ /var/tmp/diff_new_pack.8YhvBG/_new  2020-03-18 12:52:20.401208670 +0100
@@ -4,7 +4,7 @@
 Priority: optional
 Binary: darktable darktable-tools-basecurve darktable-tools-noise
 Architecture: any-amd64 any-arm64
-Version: 3.0.0-1.1
+Version: 3.0.1-1.1
 Homepage: http://www.darktable.org/
 Build-Depends: cmake,
debhelper (>= 10),

++ debian.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/debian/changelog new/debian/changelog
--- old/debian/changelog2020-01-19 23:12:20.997237660 +0100
+++ new/debian/changelog2020-03-10 17:31:11.242726820 +0100
@@ -1,3 +1,11 @@
+darktable (3.0.1-1.1) experimental; urgency=medium
+
+  * update to 3.0.1
+https://github.com/darktable-org/darktable/releases/tag/release-3.0.1
+  * added 
https://github.com/darktable-org/darktable/commit/8bceae80bd8459f4ec5929df75d6ec0471c3d26c.patch
+to fix regression in the basic adjustment module.
+
+ -- Andreas Schneider   Tue, 10 Mar 2020 15:31:00 -
 darktable (3.0.0-1.1) 

commit pfstools for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package pfstools for openSUSE:Factory 
checked in at 2020-03-18 12:46:36

Comparing /work/SRC/openSUSE:Factory/pfstools (Old)
 and  /work/SRC/openSUSE:Factory/.pfstools.new.3160 (New)


Package is "pfstools"

Wed Mar 18 12:46:36 2020 rev:39 rq:786115 version:2.1.0

Changes:

--- /work/SRC/openSUSE:Factory/pfstools/pfstools.changes2019-02-05 
11:18:41.800897934 +0100
+++ /work/SRC/openSUSE:Factory/.pfstools.new.3160/pfstools.changes  
2020-03-18 12:52:09.445202126 +0100
@@ -1,0 +2,6 @@
+Wed Mar 11 09:32:14 UTC 2020 - Christophe Giboudeaux 
+
+- Require freeglut-devel instead of pkgconfig(freeglut).
+  The pkgconfig name changed in Tumbleweed.
+
+---



Other differences:
--
++ pfstools.spec ++
--- /var/tmp/diff_new_pack.fsroum/_old  2020-03-18 12:52:11.357203268 +0100
+++ /var/tmp/diff_new_pack.fsroum/_new  2020-03-18 12:52:11.377203280 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package pfstools
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -41,6 +41,7 @@
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  fftw3-threads-devel
+BuildRequires:  freeglut-devel
 BuildRequires:  hdf5-devel
 BuildRequires:  lapack
 BuildRequires:  libnetpbm-devel
@@ -51,7 +52,6 @@
 BuildRequires:  pkgconfig(OpenEXR)
 BuildRequires:  pkgconfig(Qt5Core)
 BuildRequires:  pkgconfig(Qt5Widgets)
-BuildRequires:  pkgconfig(freeglut)
 BuildRequires:  pkgconfig(glu)
 BuildRequires:  pkgconfig(gsl)
 BuildRequires:  pkgconfig(libexif)




commit python-portalocker for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-portalocker for 
openSUSE:Factory checked in at 2020-03-18 12:45:55

Comparing /work/SRC/openSUSE:Factory/python-portalocker (Old)
 and  /work/SRC/openSUSE:Factory/.python-portalocker.new.3160 (New)


Package is "python-portalocker"

Wed Mar 18 12:45:55 2020 rev:6 rq:786107 version:1.5.2

Changes:

--- /work/SRC/openSUSE:Factory/python-portalocker/python-portalocker.changes
2019-09-23 12:06:18.993916206 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-portalocker.new.3160/python-portalocker.changes
  2020-03-18 12:51:45.265187684 +0100
@@ -1,0 +2,6 @@
+Wed Mar 18 08:44:55 UTC 2020 - Marketa Calabkova 
+
+- Update to 1.5.2
+  * Allow for development setuptools
+
+---

Old:

  v1.5.1.tar.gz

New:

  v1.5.2.tar.gz



Other differences:
--
++ python-portalocker.spec ++
--- /var/tmp/diff_new_pack.zew5Sc/_old  2020-03-18 12:51:52.621192077 +0100
+++ /var/tmp/diff_new_pack.zew5Sc/_new  2020-03-18 12:51:52.653192096 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-portalocker
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-portalocker
-Version:1.5.1
+Version:1.5.2
 Release:0
 Summary:Locking library for Python
 License:Python-2.0

++ v1.5.1.tar.gz -> v1.5.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/portalocker-1.5.1/CHANGELOG.rst 
new/portalocker-1.5.2/CHANGELOG.rst
--- old/portalocker-1.5.1/CHANGELOG.rst 2019-08-04 20:06:01.0 +0200
+++ new/portalocker-1.5.2/CHANGELOG.rst 2019-11-12 00:08:05.0 +0100
@@ -1,3 +1,26 @@
+1.5:
+
+ * Moved tests to prevent collisions with other packages
+
+1.4:
+
+ * Added optional file open parameters
+
+1.3:
+
+ * Improved documentation
+ * Added file handle to locking exceptions
+
+1.2:
+
+ * Added signed releases and tags to PyPI and Git
+
+
+1.1:
+
+ * Added support for Python 3.6+
+ * Using real time to calculate timeout
+
 1.0:
 
  * Complete code refactor.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/portalocker-1.5.1/portalocker/__about__.py 
new/portalocker-1.5.2/portalocker/__about__.py
--- old/portalocker-1.5.1/portalocker/__about__.py  2019-08-04 
20:06:01.0 +0200
+++ new/portalocker-1.5.2/portalocker/__about__.py  2019-11-12 
00:08:05.0 +0100
@@ -1,7 +1,7 @@
 __package_name__ = 'portalocker'
 __author__ = 'Rick van Hattem'
 __email__ = 'wo...@wol.ph'
-__version__ = '1.5.0'
+__version__ = '1.5.1'
 __description__ = '''Wraps the portalocker recipe for easy usage'''
 __url__ = 'https://github.com/WoLpH/portalocker'
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/portalocker-1.5.1/portalocker/__init__.py 
new/portalocker-1.5.2/portalocker/__init__.py
--- old/portalocker-1.5.1/portalocker/__init__.py   2019-08-04 
20:06:01.0 +0200
+++ new/portalocker-1.5.2/portalocker/__init__.py   2019-11-12 
00:08:05.0 +0100
@@ -11,7 +11,7 @@
 #: Current author's email address
 __email__ = __about__.__email__
 #: Version number
-__version__ = '1.5.0'
+__version__ = '1.5.1'
 #: Package description for Pypi
 __description__ = __about__.__description__
 #: Package homepage
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/portalocker-1.5.1/setup.py 
new/portalocker-1.5.2/setup.py
--- old/portalocker-1.5.1/setup.py  2019-08-04 20:06:01.0 +0200
+++ new/portalocker-1.5.2/setup.py  2019-11-12 00:08:05.0 +0100
@@ -4,11 +4,11 @@
 import sys
 import setuptools
 from setuptools.command.test import test as TestCommand
-from distutils.version import StrictVersion
+from distutils.version import LooseVersion
 from setuptools import __version__ as setuptools_version
 
 
-if StrictVersion(setuptools_version) < StrictVersion('38.3.0'):
+if LooseVersion(setuptools_version) < LooseVersion('38.3.0'):
 raise SystemExit(
 'Your `setuptools` version is old. '
 'Please upgrade setuptools by running `pip install -U setuptools` '
@@ -47,7 +47,7 @@
 import pytest
 errno = pytest.main(shlex.split(self.pytest_args))
 sys.exit(errno)
-
+
 
 class Combine(setuptools.Command):
 description = 'Build single combined portalocker file'
@@ 

commit python-ptr for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-ptr for openSUSE:Factory 
checked in at 2020-03-18 12:46:15

Comparing /work/SRC/openSUSE:Factory/python-ptr (Old)
 and  /work/SRC/openSUSE:Factory/.python-ptr.new.3160 (New)


Package is "python-ptr"

Wed Mar 18 12:46:15 2020 rev:2 rq:786121 version:20.2.26

Changes:

--- /work/SRC/openSUSE:Factory/python-ptr/python-ptr.changes2020-01-02 
14:42:39.072942852 +0100
+++ /work/SRC/openSUSE:Factory/.python-ptr.new.3160/python-ptr.changes  
2020-03-18 12:52:08.417201512 +0100
@@ -1,0 +2,13 @@
+Wed Mar 18 09:25:42 UTC 2020 - Tomáš Chvátal 
+
+- Update to 20.2.26:
+  - Add support for passing `--system-site-packages` during venv creation - 
PR: #80
+  - Add ability to create partial `.ptrconfig` files - PR: #83
+  - Use native recursive file search for black and flake8 - PR: #81
+  - Fix documentation for some new arguments - Thanks @omikader
+  - Windows now defaults to updating pip + setuptools
+  - Rely on setting current working directory with subprocess and remove 
coverage file environment setting
+  - f-string everything via [flynt](https://pypi.org/project/flynt/) now we're 
>= 3.6
+  - Enable pyre for Python 3.8 now it's fully supported
+
+---

Old:

  ptr-19.11.21.tar.gz

New:

  ptr-20.2.26.tar.gz



Other differences:
--
++ python-ptr.spec ++
--- /var/tmp/diff_new_pack.tcIyCs/_old  2020-03-18 12:52:09.157201954 +0100
+++ /var/tmp/diff_new_pack.tcIyCs/_new  2020-03-18 12:52:09.161201956 +0100
@@ -19,7 +19,7 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-ptr
-Version:19.11.21
+Version:20.2.26
 Release:0
 Summary:Parallel asyncio Python setup(cfg|py) test runner
 License:MIT

++ ptr-19.11.21.tar.gz -> ptr-20.2.26.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ptr-19.11.21/CHANGES.md new/ptr-20.2.26/CHANGES.md
--- old/ptr-19.11.21/CHANGES.md 2019-11-22 04:51:01.0 +0100
+++ new/ptr-20.2.26/CHANGES.md  2020-02-27 01:05:45.0 +0100
@@ -2,6 +2,42 @@
 
 Each release to PyPI I'm going to give a codename as to where I am or was in 
the world .
 
+### 2020.2.26
+
+Codename: **Month after Straya Day **
+
+*1 month since @cooperlees was in AU for Australia day!*
+
+- Enable pyre for Python 3.8 now it's fully supported
+
+### 2019.12.25
+
+Codename: **Vernon Hills, IL **
+
+*@cooperlees visiting girlfriend's family in IL*
+
+- Fix documentation for some new arguments - Thanks @omikader
+- Windows now defaults to updating pip + setuptools
+- Rely on setting current working directory with subprocess and remove 
coverage file environment setting
+- f-string everything via [flynt](https://pypi.org/project/flynt/) now we're 
>= 3.6
+
+### 2019.12.13
+
+Codename: **College Park, MD **
+
+*@omikader studied at the University of Maryland, College Park*
+
+- Add ability to create partial `.ptrconfig` files - PR: #83
+- Use native recursive file search for black and flake8 - PR: #81
+
+### 2019.12.12
+
+Codename: **Sapporo, Japan **
+
+*@omikader is going skiing there in February*
+
+- Add support for passing `--system-site-packages` during venv creation - PR: 
#80
+
 ### 2019.11.21
 
 Codename: **Santa Clara, CA**
@@ -67,7 +103,7 @@
 Codename: **Ellicott City**
 
 *@omikader who reported and tested the fix for AST parsing is from there.*
-*Ellicott City is also home to one of the oldest surving train stations in the 
US!*
+*Ellicott City is also home to one of the oldest surviving train stations in 
the US!*
 
 - Fix AST parsing to ignore AST targets that do not have an `id` attribute - 
Issue: #54
 - Renable `black` by default on 3.7 now that it runs on > 3.7.2 - Issue: #41
@@ -97,7 +133,7 @@
 
 * @cooperlees + @jreese are at PyCon US in Cleveland, OH 礪*
 
-- Print step name in failue output - Issue: #31
+- Print step name in failure output - Issue: #31
 - Add in `pyre` Type Checking step support - Issue: #38 + #40
 
 **Known Bug:** `black.exe` does not run in Windows 3.7 - **disabled** by 
*default* on Python 3.7 on Windows
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/ptr-19.11.21/PKG-INFO new/ptr-20.2.26/PKG-INFO
--- old/ptr-19.11.21/PKG-INFO   2019-11-22 04:51:12.0 +0100
+++ new/ptr-20.2.26/PKG-INFO2020-02-27 01:05:58.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: ptr
-Version: 19.11.21
+Version: 20.2.26
 Summary: Parallel asyncio Python setup.(cfg|py) Test Runner
 Home-page: http://github.com/facebookincubator/ptr
 Author: Cooper Lees
@@ -65,7 +65,7 @@
   

commit python-pyftpdlib for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-pyftpdlib for 
openSUSE:Factory checked in at 2020-03-18 12:46:07

Comparing /work/SRC/openSUSE:Factory/python-pyftpdlib (Old)
 and  /work/SRC/openSUSE:Factory/.python-pyftpdlib.new.3160 (New)


Package is "python-pyftpdlib"

Wed Mar 18 12:46:07 2020 rev:9 rq:786119 version:1.5.6

Changes:

--- /work/SRC/openSUSE:Factory/python-pyftpdlib/python-pyftpdlib.changes
2019-06-01 09:47:49.931358445 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-pyftpdlib.new.3160/python-pyftpdlib.changes  
2020-03-18 12:52:05.717199899 +0100
@@ -1,0 +2,8 @@
+Wed Mar 18 09:21:28 UTC 2020 - Tomáš Chvátal 
+
+- Update to 1.5.6:
+  - #467: added pre-fork concurrency model, spawn()ing worker processes to 
split
+load.
+  - #520: directory LISTing is now 3.7x times faster.
+
+---

Old:

  pyftpdlib-1.5.5.tar.gz

New:

  pyftpdlib-1.5.6.tar.gz



Other differences:
--
++ python-pyftpdlib.spec ++
--- /var/tmp/diff_new_pack.t9Rnzb/_old  2020-03-18 12:52:07.409200910 +0100
+++ /var/tmp/diff_new_pack.t9Rnzb/_new  2020-03-18 12:52:07.417200914 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pyftpdlib
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 # Copyright (c) 2016 LISA GmbH, Bingen, Germany.
 #
 # All modifications and additions to the file contributed by third parties
@@ -21,7 +21,7 @@
 # Tests randomly fail: https://github.com/giampaolo/pyftpdlib/issues/386
 %bcond_with test
 Name:   python-pyftpdlib
-Version:1.5.5
+Version:1.5.6
 Release:0
 Summary:Asynchronous FTP server library for Python
 License:MIT
@@ -57,6 +57,7 @@
 
 %install
 %python_install
+%python_expand rm -r %{buildroot}%{$python_sitelib}/pyftpdlib/test
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
 %if %{with test}

++ pyftpdlib-1.5.5.tar.gz -> pyftpdlib-1.5.6.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pyftpdlib-1.5.5/HISTORY.rst 
new/pyftpdlib-1.5.6/HISTORY.rst
--- old/pyftpdlib-1.5.5/HISTORY.rst 2019-04-04 11:10:16.0 +0200
+++ new/pyftpdlib-1.5.6/HISTORY.rst 2020-02-16 16:39:33.0 +0100
@@ -1,5 +1,14 @@
 Bug tracker at https://github.com/giampaolo/pyftpdlib/issues
 
+Version: 1.5.6 - 2020-02-16
+===
+
+**Enhancements**
+
+- #467: added pre-fork concurrency model, spawn()ing worker processes to split
+  load.
+- #520: directory LISTing is now 3.7x times faster.
+
 Version: 1.5.5 - 2019-04-04
 ===
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pyftpdlib-1.5.5/LICENSE new/pyftpdlib-1.5.6/LICENSE
--- old/pyftpdlib-1.5.5/LICENSE 2017-12-30 09:44:57.0 +0100
+++ new/pyftpdlib-1.5.6/LICENSE 2019-10-22 06:45:18.0 +0200
@@ -1,22 +1,21 @@
-==
-Copyright (C) 2007-2016  Giampaolo Rodola' 
+MIT License
 
- All Rights Reserved
+Copyright (c) 2007 Giampaolo Rodola'
 
-Permission to use, copy, modify, and distribute this software and
-its documentation for any purpose and without fee is hereby
-granted, provided that the above copyright notice appear in all
-copies and that both that copyright notice and this permission
-notice appear in supporting documentation, and that the name of
-Giampaolo Rodola' not be used in advertising or publicity pertaining to
-distribution of the software without specific, written prior
-permission.
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
 
-Giampaolo Rodola' DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
-INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
-NO EVENT Giampaolo Rodola' BE LIABLE FOR ANY SPECIAL, INDIRECT OR
-CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
-OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
-NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
-CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-==
+The above copyright notice and this permission notice shall be included in all
+copies or 

commit python-pook for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-pook for openSUSE:Factory 
checked in at 2020-03-18 12:45:48

Comparing /work/SRC/openSUSE:Factory/python-pook (Old)
 and  /work/SRC/openSUSE:Factory/.python-pook.new.3160 (New)


Package is "python-pook"

Wed Mar 18 12:45:48 2020 rev:2 rq:786100 version:0.2.8

Changes:

--- /work/SRC/openSUSE:Factory/python-pook/python-pook.changes  2019-09-23 
12:32:45.853655894 +0200
+++ /work/SRC/openSUSE:Factory/.python-pook.new.3160/python-pook.changes
2020-03-18 12:51:39.325184136 +0100
@@ -1,0 +2,6 @@
+Wed Mar 18 08:39:21 UTC 2020 - Marketa Calabkova 
+
+- Update to 0.2.8
+  * fix collections import warning
+
+---

Old:

  pook-0.2.6.tar.gz

New:

  pook-0.2.8.tar.gz



Other differences:
--
++ python-pook.spec ++
--- /var/tmp/diff_new_pack.XbCssY/_old  2020-03-18 12:51:40.889185070 +0100
+++ /var/tmp/diff_new_pack.XbCssY/_new  2020-03-18 12:51:40.893185072 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pook
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,30 +12,31 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-pook
-Version:0.2.6
+Version:0.2.8
 Release:0
-License:MIT
 Summary:HTTP traffic mocking and expectations
-Url:https://github.com/h2non/pook
+License:MIT
 Group:  Development/Languages/Python
+URL:https://github.com/h2non/pook
 Source: 
https://files.pythonhosted.org/packages/source/p/pook/pook-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
 BuildRequires:  %{python_module setuptools}
+BuildRequires:  python-rpm-macros
 # SECTION test requirements
 BuildRequires:  %{python_module furl >= 0.5.6}
 BuildRequires:  %{python_module jsonschema >= 2.5.1}
-BuildRequires:  %{python_module xmltodict >= 0.10.2}
 BuildRequires:  %{python_module mocket >= 1.6.0}
-BuildRequires:  %{python_module nose >= 1.3.7}
 BuildRequires:  %{python_module mock}
+BuildRequires:  %{python_module nose >= 1.3.7}
 BuildRequires:  %{python_module pytest < 5}
 BuildRequires:  %{python_module requests >= 2.20.0}
 BuildRequires:  %{python_module urllib3 >= 1.19.1}
+BuildRequires:  %{python_module xmltodict >= 0.10.2}
 # /SECTION
 BuildRequires:  fdupes
 Requires:   python-furl >= 0.5.6

++ pook-0.2.6.tar.gz -> pook-0.2.8.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pook-0.2.6/History.rst new/pook-0.2.8/History.rst
--- old/pook-0.2.6/History.rst  2019-02-01 13:21:33.0 +0100
+++ new/pook-0.2.8/History.rst  2019-10-31 10:52:23.0 +0100
@@ -1,8 +1,17 @@
 
-
 History
 ===
 
+v0.2.8 / 2019-10-31
+---
+
+  * fix collections import warning (#61) 
+
+v0.2.7 / 2019-10-21
+---
+
+  * fix collections import warning (#61)
+
 v0.2.6 / 2019-02-01
 ---
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pook-0.2.6/LICENSE new/pook-0.2.8/LICENSE
--- old/pook-0.2.6/LICENSE  2017-10-03 12:06:08.0 +0200
+++ new/pook-0.2.8/LICENSE  2019-10-22 21:27:11.0 +0200
@@ -1,6 +1,6 @@
 MIT License
 
-Copyright (c) 2016-2017 Tomás Aparicio
+Copyright (c) 2016-2019 Tomás Aparicio
 
 Permission is hereby granted, free of charge, to any person obtaining a copy
 of this software and associated documentation files (the "Software"), to deal
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pook-0.2.6/PKG-INFO new/pook-0.2.8/PKG-INFO
--- old/pook-0.2.6/PKG-INFO 2019-02-01 13:22:49.0 +0100
+++ new/pook-0.2.8/PKG-INFO 2019-10-31 10:56:02.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: pook
-Version: 0.2.6
+Version: 0.2.8
 Summary: HTTP traffic mocking and expectations made easy
 Home-page: https://github.com/h2non/pook
 Author: Tomas Aparicio
@@ -335,10 +335,19 @@
 
 
 
-
 History
 ===
 
+v0.2.8 / 2019-10-31
+---
+
+  * fix collections import warning (#61) 
+
+v0.2.7 / 2019-10-21
+   

commit python-requests-hawk for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-requests-hawk for 
openSUSE:Factory checked in at 2020-03-18 12:45:43

Comparing /work/SRC/openSUSE:Factory/python-requests-hawk (Old)
 and  /work/SRC/openSUSE:Factory/.python-requests-hawk.new.3160 (New)


Package is "python-requests-hawk"

Wed Mar 18 12:45:43 2020 rev:3 rq:786095 version:1.0.1

Changes:

--- 
/work/SRC/openSUSE:Factory/python-requests-hawk/python-requests-hawk.changes
2018-12-24 11:43:20.409348489 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-requests-hawk.new.3160/python-requests-hawk.changes
  2020-03-18 12:51:28.701177790 +0100
@@ -1,0 +2,7 @@
+Wed Mar 18 08:29:29 UTC 2020 - Tomáš Chvátal 
+
+- Update to 1.0.1:
+  - Add Python 3 support. (#22)
+- Enable tests
+
+---

Old:

  requests-hawk-1.0.0.tar.gz

New:

  requests-hawk-1.0.1.tar.gz



Other differences:
--
++ python-requests-hawk.spec ++
--- /var/tmp/diff_new_pack.FBi5QH/_old  2020-03-18 12:51:32.513180067 +0100
+++ /var/tmp/diff_new_pack.FBi5QH/_new  2020-03-18 12:51:32.545180086 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-requests-hawk
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 # Copyright (c) 2017 The openSUSE Project.
 #
 # All modifications and additions to the file contributed by third parties
@@ -18,25 +18,21 @@
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
-%bcond_with test
 Name:   python-requests-hawk
-Version:1.0.0
+Version:1.0.1
 Release:0
 Summary:Hawk authentication strategy for the requests python library
 License:Apache-2.0
-Group:  Development/Languages/Python
 URL:https://github.com/mozilla-services/requests-hawk
 Source: 
https://files.pythonhosted.org/packages/source/r/requests-hawk/requests-hawk-%{version}.tar.gz
+BuildRequires:  %{python_module mohawk}
+BuildRequires:  %{python_module requests}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
 Requires:   python-mohawk
 Requires:   python-requests
 BuildArch:  noarch
-%if %{with test}
-BuildRequires:  %{python_module mohawk}
-BuildRequires:  %{python_module requests}
-%endif
 %python_subpackages
 
 %description
@@ -57,10 +53,8 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
-%if %{with test}
 %check
 %python_exec setup.py test
-%endif
 
 %files %{python_files}
 %license LICENSE.txt

++ requests-hawk-1.0.0.tar.gz -> requests-hawk-1.0.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/requests-hawk-1.0.0/CHANGES.txt 
new/requests-hawk-1.0.1/CHANGES.txt
--- old/requests-hawk-1.0.0/CHANGES.txt 2015-12-15 14:53:05.0 +0100
+++ new/requests-hawk-1.0.1/CHANGES.txt 2020-01-20 11:35:24.0 +0100
@@ -1,6 +1,12 @@
 CHANGELOG
 =
 
+1.0.1 (2020-01-20)
+--
+
+- Add Python 3 support. (#22)
+
+
 1.0.0 (2015-12-15)
 --
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/requests-hawk-1.0.0/PKG-INFO 
new/requests-hawk-1.0.1/PKG-INFO
--- old/requests-hawk-1.0.0/PKG-INFO2015-12-15 14:53:06.0 +0100
+++ new/requests-hawk-1.0.1/PKG-INFO2020-01-20 11:35:24.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: requests-hawk
-Version: 1.0.0
+Version: 1.0.1
 Summary: requests-hawk
 Home-page: https://github.com/mozilla-services/requests-hawk
 Author: Mozilla Services
@@ -24,15 +24,15 @@
 Great, how can I use it?
 
 
-First, you'll need to install it::
+First, you'll need to install it:
 
-  .. code-block:: bash
+.. code-block:: bash
 
 pip install requests-hawk
 
-Then, in your project, if you know the `id` and `key`, you can use::
+Then, in your project, if you know the `id` and `key`, you can use:
 
-  .. code-block:: python
+.. code-block:: python
 
 import requests
 from requests_hawk import HawkAuth
@@ -40,9 +40,9 @@
 hawk_auth = HawkAuth(id='my-hawk-id', key='my-hawk-secret-key')
 requests.post("https://example.com/url;, auth=hawk_auth)
 
-Or if you need to derive them from the hawk session token, instead 
use::
+Or if you need to derive them from the hawk session token, instead use:
 
-  .. code-block:: python
+.. code-block:: python
 
 import requests
 

commit python-plyvel for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-plyvel for openSUSE:Factory 
checked in at 2020-03-18 12:45:15

Comparing /work/SRC/openSUSE:Factory/python-plyvel (Old)
 and  /work/SRC/openSUSE:Factory/.python-plyvel.new.3160 (New)


Package is "python-plyvel"

Wed Mar 18 12:45:15 2020 rev:9 rq:786088 version:1.2.0

Changes:

--- /work/SRC/openSUSE:Factory/python-plyvel/python-plyvel.changes  
2019-05-22 11:15:49.838536020 +0200
+++ /work/SRC/openSUSE:Factory/.python-plyvel.new.3160/python-plyvel.changes
2020-03-18 12:50:49.801154556 +0100
@@ -1,0 +2,7 @@
+Wed Mar 18 07:35:14 UTC 2020 - Marketa Calabkova 
+
+- update to 1.2.0
+  * Add Python 3.8 support
+  * Drop Python 3.4 support
+
+---

Old:

  plyvel-1.1.0.tar.gz

New:

  plyvel-1.2.0.tar.gz



Other differences:
--
++ python-plyvel.spec ++
--- /var/tmp/diff_new_pack.Y5aOIM/_old  2020-03-18 12:50:50.705155097 +0100
+++ /var/tmp/diff_new_pack.Y5aOIM/_new  2020-03-18 12:50:50.709155099 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-plyvel
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-plyvel
-Version:1.1.0
+Version:1.2.0
 Release:0
 Summary:Python interface to LevelDB
 License:BSD-3-Clause

++ plyvel-1.1.0.tar.gz -> plyvel-1.2.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/plyvel-1.1.0/Makefile new/plyvel-1.2.0/Makefile
--- old/plyvel-1.1.0/Makefile   2019-05-02 11:45:29.0 +0200
+++ new/plyvel-1.2.0/Makefile   2020-01-22 13:32:52.0 +0100
@@ -1,4 +1,4 @@
-.PHONY: all cython ext doc clean test wheels
+.PHONY: all cython ext doc clean test docker-build-env release
 
 all: cython ext
 
@@ -25,23 +25,14 @@
find . -name __pycache__ -delete
 
 test: ext
-   py.test
+   pytest
 
-wheels: cython
-   # Note: this should run inside the docker container.
-   for dir in /opt/python/*; do \
-   $${dir}/bin/python setup.py build --force; \
-   $${dir}/bin/python setup.py bdist_wheel; \
-   done
-   for wheel in dist/*.whl; do \
-   auditwheel show $${wheel}; \
-   auditwheel repair -w /dist/ $${wheel}; \
-   done
-
-sdist: cython
-   # Note: this should run inside the docker container.
-   python setup.py sdist --dist-dir /dist
-
-release:
+docker-build-env:
docker build -t plyvel-build .
-   docker run -i -t -v $(pwd)/dist/:/dist plyvel-build
+
+release: docker-build-env
+   CIBW_BUILD='*-manylinux1_x86_64' \
+   CIBW_MANYLINUX1_X86_64_IMAGE=plyvel-build \
+   CIBW_BEFORE_BUILD=scripts/cibuildwheel-before-build.sh \
+   CIBW_PLATFORM=linux \
+   cibuildwheel --output-dir dist
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/plyvel-1.1.0/NEWS.rst new/plyvel-1.2.0/NEWS.rst
--- old/plyvel-1.1.0/NEWS.rst   2019-05-02 11:41:17.0 +0200
+++ new/plyvel-1.2.0/NEWS.rst   2020-01-22 20:22:55.0 +0100
@@ -2,6 +2,24 @@
 Version history
 ===
 
+Plyvel 1.2.0
+
+
+Release date: 2020-01-22
+
+* Add Python 3.8 support
+  (`pr #109 `_)
+
+* Drop Python 3.4 support
+  (`pr #109 `_)
+
+* Build Linux wheels against Snappy 1.1.8, LevelDB 1.22, and produce Python 
3.8 wheels
+  (`issue #108 `_,
+  `pr #111 `_, )
+
+* Improve compilation flags for Darwin (OSX) builds
+  (`pr #107 `_)
+
 Plyvel 1.1.0
 
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/plyvel-1.1.0/PKG-INFO new/plyvel-1.2.0/PKG-INFO
--- old/plyvel-1.1.0/PKG-INFO   2019-05-02 11:48:03.0 +0200
+++ new/plyvel-1.2.0/PKG-INFO   2020-01-22 20:33:00.412627700 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: plyvel
-Version: 1.1.0
+Version: 1.2.0
 Summary: Plyvel, a fast and feature-rich Python interface to LevelDB
 Home-page: https://github.com/wbolster/plyvel
 Author: Wouter Bolsterlee
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/plyvel-1.1.0/plyvel/_plyvel.cpp 
new/plyvel-1.2.0/plyvel/_plyvel.cpp
--- 

commit perl-Type-Tiny for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package perl-Type-Tiny for openSUSE:Factory 
checked in at 2020-03-18 12:45:36

Comparing /work/SRC/openSUSE:Factory/perl-Type-Tiny (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Type-Tiny.new.3160 (New)


Package is "perl-Type-Tiny"

Wed Mar 18 12:45:36 2020 rev:16 rq:786097 version:1.010001

Changes:

--- /work/SRC/openSUSE:Factory/perl-Type-Tiny/perl-Type-Tiny.changes
2020-02-20 14:59:58.482828953 +0100
+++ /work/SRC/openSUSE:Factory/.perl-Type-Tiny.new.3160/perl-Type-Tiny.changes  
2020-03-18 12:51:14.817169498 +0100
@@ -1,0 +2,14 @@
+Tue Mar 17 03:18:01 UTC 2020 -  
+
+- updated to 1.010001
+   see /usr/share/doc/packages/perl-Type-Tiny/Changes
+
+  1.010001 2020-03-16
+  
+   [ Documentation ]
+   - MooX::Pression mentions in documentation now refer to Zydeco.
+  
+   [ Test Suite ]
+   - Test suite passes in cperl, albeit with warnings.
+
+---

Old:

  Type-Tiny-1.01.tar.gz

New:

  Type-Tiny-1.010001.tar.gz



Other differences:
--
++ perl-Type-Tiny.spec ++
--- /var/tmp/diff_new_pack.ckj6C3/_old  2020-03-18 12:51:16.629170580 +0100
+++ /var/tmp/diff_new_pack.ckj6C3/_new  2020-03-18 12:51:16.641170587 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Type-Tiny
-Version:1.01
+Version:1.010001
 Release:0
 %define cpan_name Type-Tiny
 Summary:Tiny, yet Moo(se)-compatible type constraint

++ Type-Tiny-1.01.tar.gz -> Type-Tiny-1.010001.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Type-Tiny-1.01/COPYRIGHT 
new/Type-Tiny-1.010001/COPYRIGHT
--- old/Type-Tiny-1.01/COPYRIGHT2020-02-19 21:38:55.0 +0100
+++ new/Type-Tiny-1.010001/COPYRIGHT2020-03-16 15:38:28.0 +0100
@@ -351,13 +351,6 @@
 Copyright: This software is copyright (c) 2017-2020 by Toby Inkster.
 License: GPL-1.0+ or Artistic-1.0
 
-Files: t/20-unit/Types-Common-Numeric/basic.t
- t/20-unit/Types-Common-String/basic.t
- t/20-unit/Types-Common-String/coerce.t
- t/20-unit/Types-Common-String/unicode.t
-Copyright: This software is copyright (c) 2013-2014, 2017-2020 by Matt S Trout 
- mst (at) shadowcatsystems.co.uk (L).
-License: GPL-1.0+ or Artistic-1.0
-
 Files: t/20-unit/Type-Library/recursive-type-definitions.t
  t/20-unit/Type-Registry/parent.t
  t/40-regression/rt131401.t
@@ -365,6 +358,13 @@
 Copyright: This software is copyright (c) 2020 by Toby Inkster.
 License: GPL-1.0+ or Artistic-1.0
 
+Files: META.json
+ META.yml
+ NEWS
+ doap.ttl
+Copyright: Copyright 2020 Toby Inkster.
+License: GPL-1.0+ or Artistic-1.0
+
 Files: lib/Type/Tiny/_HalfOp.pm
  t/20-unit/Type-Tiny-_HalfOp/overload-precedence.t
  t/40-regression/73f51e2d.pl
@@ -372,109 +372,109 @@
 Copyright: This software is copyright (c) 2014, 2017-2020 by Graham Knop.
 License: GPL-1.0+ or Artistic-1.0
 
+Files: t/20-unit/Types-Common-Numeric/basic.t
+ t/20-unit/Types-Common-String/basic.t
+ t/20-unit/Types-Common-String/coerce.t
+ t/20-unit/Types-Common-String/unicode.t
+Copyright: This software is copyright (c) 2013-2014, 2017-2020 by Matt S Trout 
- mst (at) shadowcatsystems.co.uk (L).
+License: GPL-1.0+ or Artistic-1.0
+
 Files: t/40-regression/rt85911.t
  t/40-regression/rt86004.t
  t/40-regression/rt90096-2.t
 Copyright: This software is copyright (c) 2013-2014, 2017-2020 by Diab Jerius.
 License: GPL-1.0+ or Artistic-1.0
 
-Files: META.json
- META.yml
- doap.ttl
-Copyright: Copyright 2020 Toby Inkster.
-License: GPL-1.0+ or Artistic-1.0
-
 Files: COPYRIGHT
  SIGNATURE
 Copyright: None
 License: public-domain
 
+Files: inc/archaic/Test/More.pm
+ inc/archaic/Test/Simple.pm
+Copyright: Copyright 2001-2008 by Michael G Schwern .
+License: GPL-1.0+ or Artistic-1.0
+
 Files: t/40-regression/rt86233.t
  t/40-regression/rt86239.t
 Copyright: This software is copyright (c) 2013-2014, 2017-2020 by Vyacheslav 
Matyukhin.
 License: GPL-1.0+ or Artistic-1.0
 
-Files: inc/archaic/Test/More.pm
- inc/archaic/Test/Simple.pm
-Copyright: Copyright 2001-2008 by Michael G Schwern .
+Files: t/40-regression/ttxs-gh1.t
+Copyright: This software is copyright (c) 2014, 2017-2020 by Jed Lund.
 License: GPL-1.0+ or Artistic-1.0
 
-Files: CONTRIBUTING
- NEWS
-Copyright: Copyright 2019 Toby Inkster.
+Files: inc/Test/Requires.pm
+Copyright: Copyright 2019 MATSUNO Tokuhiro.
 License: GPL-1.0+ or Artistic-1.0
 
-Files: examples/benchmarking/benchmark-coercions.pl
-Copyright: This software is copyright (c) 2013-2014, 2017 by Toby Inkster.
+Files: inc/archaic/Test/Builder/IO/Scalar.pm
+Copyright: Copyright (c) 1996 by Eryq.  All 

commit python-plumbum for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-plumbum for openSUSE:Factory 
checked in at 2020-03-18 12:45:03

Comparing /work/SRC/openSUSE:Factory/python-plumbum (Old)
 and  /work/SRC/openSUSE:Factory/.python-plumbum.new.3160 (New)


Package is "python-plumbum"

Wed Mar 18 12:45:03 2020 rev:4 rq:786084 version:1.6.8

Changes:

--- /work/SRC/openSUSE:Factory/python-plumbum/python-plumbum.changes
2019-06-06 18:15:53.448711179 +0200
+++ /work/SRC/openSUSE:Factory/.python-plumbum.new.3160/python-plumbum.changes  
2020-03-18 12:50:36.717146742 +0100
@@ -1,0 +2,12 @@
+Wed Mar 18 07:29:06 UTC 2020 - Marketa Calabkova 
+
+- Update to 1.6.8
+  * Exceptions: Changed ProcessExecutionError's formatting to be more 
user-friendly
+  * Commands: support for per-line timeout with iter_lines
+  * Commands: support for piping stdout/stderr to a logger
+  * Commands: execute local/remote commands via a magic .cmd attribute
+  * Paths: support composing paths using subscription operations
+  * CLI: Improved 'Set' validator to allow non-string types, and CSV params
+  * TypedEnv: Facility for modeling environment-variables into python data 
types
+
+---

Old:

  v1.6.7.tar.gz

New:

  v1.6.8.tar.gz



Other differences:
--
++ python-plumbum.spec ++
--- /var/tmp/diff_new_pack.yihsK7/_old  2020-03-18 12:50:40.217148832 +0100
+++ /var/tmp/diff_new_pack.yihsK7/_new  2020-03-18 12:50:40.217148832 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-plumbum
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,16 +18,17 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-plumbum
-Version:1.6.7
+Version:1.6.8
 Release:0
 Summary:Shell combinators library
 License:MIT
 Group:  Development/Languages/Python
-Url:https://github.com/tomerfiliba/plumbum
+URL:https://github.com/tomerfiliba/plumbum
 Source: 
https://github.com/tomerfiliba/plumbum/archive/v%{version}.tar.gz
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
+BuildArch:  noarch
 # SECTION test requirements
 BuildRequires:  %{python_module paramiko}
 BuildRequires:  %{python_module psutil}
@@ -37,8 +38,6 @@
 BuildRequires:  openssh
 BuildRequires:  sudo
 # /SECTION
-BuildArch:  noarch
-
 %python_subpackages
 
 %description

++ v1.6.7.tar.gz -> v1.6.8.tar.gz ++
 2527 lines of diff (skipped)




commit python-yappi for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-yappi for openSUSE:Factory 
checked in at 2020-03-18 12:45:28

Comparing /work/SRC/openSUSE:Factory/python-yappi (Old)
 and  /work/SRC/openSUSE:Factory/.python-yappi.new.3160 (New)


Package is "python-yappi"

Wed Mar 18 12:45:28 2020 rev:4 rq:786089 version:1.2.3

Changes:

--- /work/SRC/openSUSE:Factory/python-yappi/python-yappi.changes
2020-03-17 13:08:14.925711590 +0100
+++ /work/SRC/openSUSE:Factory/.python-yappi.new.3160/python-yappi.changes  
2020-03-18 12:50:54.845157569 +0100
@@ -1,0 +2,6 @@
+Tue Mar 17 23:52:17 UTC 2020 - Hans-Peter Jansen 
+
+- add more testing requirements
+- disable a test, that relies on asyncio.run for py < 3.7
+
+---



Other differences:
--
++ python-yappi.spec ++
--- /var/tmp/diff_new_pack.OOOfP5/_old  2020-03-18 12:50:56.613158625 +0100
+++ /var/tmp/diff_new_pack.OOOfP5/_new  2020-03-18 12:50:56.617158628 +0100
@@ -25,8 +25,10 @@
 License:MIT
 URL:https://github.com/sumerc/yappi
 Source: 
https://files.pythonhosted.org/packages/source/y/yappi/yappi-%{version}.tar.gz
+BuildRequires:  %{python_module contextvars}
 BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module nose}
+BuildRequires:  %{python_module pytest-asyncio}
 BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
@@ -52,7 +54,12 @@
 export PYTHONPATH="tests/"
 export PATH="$PATH:%{buildroot}/%{_bindir}"
 # Skip two flaky tests
-%pytest_arch -k 'not (test_basic_old_style or test_basic)'
+skip_tests="not test_basic_old_style and not test_basic"
+%if %{python3_version_nodots} < 37
+# this test relies on asyncio.run method
+skip_tests="$skip_tests and not test_asyncio_context_vars" 
+%endif
+%pytest_arch -k "$skip_tests"
 
 %files %{python_files}
 %doc README.md




commit python-PyInstaller for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-PyInstaller for 
openSUSE:Factory checked in at 2020-03-18 12:44:45

Comparing /work/SRC/openSUSE:Factory/python-PyInstaller (Old)
 and  /work/SRC/openSUSE:Factory/.python-PyInstaller.new.3160 (New)


Package is "python-PyInstaller"

Wed Mar 18 12:44:45 2020 rev:3 rq:786082 version:3.6

Changes:

--- /work/SRC/openSUSE:Factory/python-PyInstaller/python-PyInstaller.changes
2020-01-18 12:18:34.395153135 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-PyInstaller.new.3160/python-PyInstaller.changes
  2020-03-18 12:50:28.421141787 +0100
@@ -1,0 +2,11 @@
+Wed Mar 18 07:22:03 UTC 2020 - Tomáš Chvátal 
+
+- Disable functional tests as it takes ages and basic checks
+  are okay with unittests
+
+---
+Tue Mar 10 09:31:11 UTC 2020 - Tomáš Chvátal 
+
+- Use xdist for test execution as otherwise it takes ages
+
+---



Other differences:
--
++ python-PyInstaller.spec ++
--- /var/tmp/diff_new_pack.9n2dNx/_old  2020-03-18 12:50:30.473143012 +0100
+++ /var/tmp/diff_new_pack.9n2dNx/_new  2020-03-18 12:50:30.477143015 +0100
@@ -24,7 +24,6 @@
 Release:0
 Summary:Bundle a Python application and all its dependencies into a 
single package
 License:GPL-2.0-only
-Group:  Development/Languages/Python
 URL:https://www.pyinstaller.org
 Source: 
https://files.pythonhosted.org/packages/source/P/PyInstaller/PyInstaller-%{version}.tar.gz
 BuildRequires:  %{python_module devel}
@@ -53,13 +52,14 @@
 BuildRequires:  %{python_module pefile >= 2017.8.1}
 BuildRequires:  %{python_module psutil}
 BuildRequires:  %{python_module pycountry}
+BuildRequires:  %{python_module pytest-xdist}
 BuildRequires:  %{python_module pytest}
 BuildRequires:  %{python_module qt5}
 BuildRequires:  %{python_module setuptools}
+BuildRequires:  upx
 %if %{with python2}
 BuildRequires:  python-dis3
 %endif
-BuildRequires:  upx
 %endif
 %ifpython2
 Requires:   python-dis3
@@ -103,7 +103,8 @@
 %if %{with test}
 %check
 export LANG=en_US.UTF-8
-%pytest_arch tests/unit tests/functional 
--ignore=tests/functional/test_libraries.py 
--ignore=tests/functional/test_hooks -k 'not test_find_module and not test_egg 
and not test_nspkg1'
+# test_get_co_using_ctypes, test_get_co_using_ctypes_from_extension, 
test_replace_paths_in_code broken with python 3.8 on PyInstall 3.6
+%pytest_arch -n auto tests/unit -k 'not (test_find_module or test_egg and not 
test_nspkg1 or test_get_co_using_ctypes or 
test_get_co_using_ctypes_from_extension or test_replace_paths_in_code)'
 %endif
 
 %post




commit python3-tomate for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python3-tomate for openSUSE:Factory 
checked in at 2020-03-18 12:44:29

Comparing /work/SRC/openSUSE:Factory/python3-tomate (Old)
 and  /work/SRC/openSUSE:Factory/.python3-tomate.new.3160 (New)


Package is "python3-tomate"

Wed Mar 18 12:44:29 2020 rev:2 rq:786028 version:0.12.0

Changes:

--- /work/SRC/openSUSE:Factory/python3-tomate/python3-tomate.changes
2019-07-26 12:42:51.617843087 +0200
+++ /work/SRC/openSUSE:Factory/.python3-tomate.new.3160/python3-tomate.changes  
2020-03-18 12:49:45.665116250 +0100
@@ -1,0 +2,5 @@
+Tue Mar 17 20:09:54 UTC 2020 - Sebastian Wagner 
+
+- add fix-tests.patch to fix compatibility with curreny pytest mock version.
+
+---

New:

  fix-tests.patch



Other differences:
--
++ python3-tomate.spec ++
--- /var/tmp/diff_new_pack.aWJVBb/_old  2020-03-18 12:49:50.065118877 +0100
+++ /var/tmp/diff_new_pack.aWJVBb/_new  2020-03-18 12:49:50.065118877 +0100
@@ -1,7 +1,7 @@
 #
-# spec file for package python-tomate
+# spec file for package python3-tomate
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 # Copyright (c) 2014 Elio Esteves Duarte 
 #
 # All modifications and additions to the file contributed by third parties
@@ -25,6 +25,8 @@
 Group:  Productivity/Other
 URL:https://github.com/eliostvs/tomate
 Source: tomate-%{version}.tar.gz
+# PATCH-FIX-UPSTEAM fix-tests.patch -- 
https://github.com/eliostvs/tomate/issues/19 
https://github.com/eliostvs/tomate/pull/20
+Patch0: fix-tests.patch
 BuildRequires:  python3-setuptools
 Requires:   /usr/bin/aplay
 Requires:   dbus-1-python3
@@ -56,7 +58,8 @@
 Provides the library for tomate, a Pomodoro timer.
 
 %prep
-%autosetup -n tomate-%{version}
+%setup -q -n tomate-%{version}
+%patch0 -p1
 touch tests/__init__.py
 
 %build

++ fix-tests.patch ++
diff -Naur orig/tests/test_app.py tomate-0.12.0/tests/test_app.py
--- orig/tests/test_app.py  2019-02-28 20:44:36.0 +0100
+++ tomate-0.12.0/tests/test_app.py 2020-03-17 21:08:06.667872366 +0100
@@ -1,3 +1,4 @@
+import contextlib
 import dbus
 import pytest
 
@@ -24,10 +25,11 @@
 
 assert isinstance(app, Application)
 
-with mocker.patch(
-"tomate.app.dbus.SessionBus.return_value.request_name",
-return_value=dbus.bus.REQUEST_NAME_REPLY_EXISTS,
-):
+with contextlib.ExitStack() as stack:
+stack.enter_context(mocker.patch(
+"tomate.app.dbus.SessionBus.return_value.request_name",
+return_value=dbus.bus.REQUEST_NAME_REPLY_EXISTS,
+))
 dbus_app = Application.from_graph(graph)
 
 assert isinstance(dbus_app, dbus.Interface)



commit kube-prometheus for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package kube-prometheus for openSUSE:Factory 
checked in at 2020-03-18 12:44:37

Comparing /work/SRC/openSUSE:Factory/kube-prometheus (Old)
 and  /work/SRC/openSUSE:Factory/.kube-prometheus.new.3160 (New)


Package is "kube-prometheus"

Wed Mar 18 12:44:37 2020 rev:3 rq:786079 version:0.3.0+git20200317.502f81b

Changes:

--- /work/SRC/openSUSE:Factory/kube-prometheus/kube-prometheus.changes  
2020-03-12 23:12:29.739328410 +0100
+++ 
/work/SRC/openSUSE:Factory/.kube-prometheus.new.3160/kube-prometheus.changes
2020-03-18 12:50:10.077130830 +0100
@@ -1,0 +2,13 @@
+Wed Mar 18 06:25:32 UTC 2020 - ku...@suse.com
+
+- Update to version 0.3.0+git20200317.502f81b:
+  * manifests: regenerate
+  * jsonnet/prometheus-adapter: use irate for CPU queries
+  * Updated the doc as grafana deployment needs modifications
+  * Fixed the port name for weave-net metrics endpoint
+  * Fixed the label for weave net selector
+  * fix invalid Usage section reference
+  - Includes 448.patch
+- Refresh vendor.tar.xz
+
+---

Old:

  448.patch
  kube-prometheus-0.3.0+git20200305.66c625d.tar.xz

New:

  kube-prometheus-0.3.0+git20200317.502f81b.tar.xz



Other differences:
--
++ kube-prometheus.spec ++
--- /var/tmp/diff_new_pack.ON6j2Z/_old  2020-03-18 12:50:17.661135360 +0100
+++ /var/tmp/diff_new_pack.ON6j2Z/_new  2020-03-18 12:50:17.661135360 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   kube-prometheus
-Version:0.3.0+git20200305.66c625d
+Version:0.3.0+git20200317.502f81b
 Release:0
 Summary:Manifests to use Prometheus to monitor Kubernetes
 License:Apache-2.0
@@ -26,7 +26,6 @@
 Source1:vendor.tar.xz
 Source2:update-vendor.sh
 Source3:kubic.jsonnet
-Patch0: 448.patch
 BuildRequires:  gojsontoyaml
 BuildRequires:  jsonnet
 BuildArch:  noarch
@@ -62,7 +61,6 @@
 
 %prep
 %setup -q -a1
-%patch0 -p1
 
 %build
 cp %{SOURCE3} kubic.jsonnet

++ _servicedata ++
--- /var/tmp/diff_new_pack.ON6j2Z/_old  2020-03-18 12:50:17.713135391 +0100
+++ /var/tmp/diff_new_pack.ON6j2Z/_new  2020-03-18 12:50:17.713135391 +0100
@@ -1,6 +1,6 @@
 
   
 git://github.com/coreos/kube-prometheus.git
-66c625d0bfbc080f40ee453ea093c66faa8e1cc0
+502f81b235a84484b55493af5cf96623ae37ef80
  
 
\ No newline at end of file

++ kube-prometheus-0.3.0+git20200305.66c625d.tar.xz -> 
kube-prometheus-0.3.0+git20200317.502f81b.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kube-prometheus-0.3.0+git20200305.66c625d/README.md 
new/kube-prometheus-0.3.0+git20200317.502f81b/README.md
--- old/kube-prometheus-0.3.0+git20200305.66c625d/README.md 2020-03-05 
11:56:54.0 +0100
+++ new/kube-prometheus-0.3.0+git20200317.502f81b/README.md 2020-03-17 
14:20:31.0 +0100
@@ -278,7 +278,7 @@
 
 ## Configuration
 
-Jsonnet has the concept of hidden fields. These are fields, that are not going 
to be rendered in a result. This is used to configure the kube-prometheus 
components in jsonnet. In the example jsonnet code of the above [Usage 
section](#Usage), you can see an example of this, where the `namespace` is 
being configured to be `monitoring`. In order to not override the whole object, 
use the `+::` construct of jsonnet, to merge objects, this way you can override 
individual settings, but retain all other settings and defaults.
+Jsonnet has the concept of hidden fields. These are fields, that are not going 
to be rendered in a result. This is used to configure the kube-prometheus 
components in jsonnet. In the example jsonnet code of the above [Customizing 
Kube-Prometheus section](#customizing-kube-prometheus), you can see an example 
of this, where the `namespace` is being configured to be `monitoring`. In order 
to not override the whole object, use the `+::` construct of jsonnet, to merge 
objects, this way you can override individual settings, but retain all other 
settings and defaults.
 
 These are the available fields with their respective default values:
 ```
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/kube-prometheus-0.3.0+git20200305.66c625d/docs/weave-net-support.md 
new/kube-prometheus-0.3.0+git20200317.502f81b/docs/weave-net-support.md
--- old/kube-prometheus-0.3.0+git20200305.66c625d/docs/weave-net-support.md 
2020-03-05 11:56:54.0 +0100
+++ new/kube-prometheus-0.3.0+git20200317.502f81b/docs/weave-net-support.md 
2020-03-17 14:20:31.0 +0100
@@ -64,4 +64,5 @@
 kubectl create -f prometheus-serviceMonitorWeaveNet.yaml
 kubectl apply -f  

commit metacity for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package metacity for openSUSE:Factory 
checked in at 2020-03-18 12:44:19

Comparing /work/SRC/openSUSE:Factory/metacity (Old)
 and  /work/SRC/openSUSE:Factory/.metacity.new.3160 (New)


Package is "metacity"

Wed Mar 18 12:44:19 2020 rev:6 rq:786021 version:3.36.0

Changes:

--- /work/SRC/openSUSE:Factory/metacity/metacity.changes2020-02-28 
15:22:40.354055742 +0100
+++ /work/SRC/openSUSE:Factory/.metacity.new.3160/metacity.changes  
2020-03-18 12:49:33.077108731 +0100
@@ -1,0 +2,8 @@
+Tue Mar 17 16:49:37 UTC 2020 - Alexei Sorokin 
+
+- Update to version 3.36.0:
+  * Use ARGB visual for window frame.
+  * Fix fullscreen regression.
+  * Remove some dead code.
+
+---

Old:

  metacity-3.35.1.tar.xz

New:

  metacity-3.36.0.tar.xz



Other differences:
--
++ metacity.spec ++
--- /var/tmp/diff_new_pack.vFbHmN/_old  2020-03-18 12:49:34.133109362 +0100
+++ /var/tmp/diff_new_pack.vFbHmN/_new  2020-03-18 12:49:34.137109364 +0100
@@ -18,13 +18,12 @@
 
 %define soname  libmetacity
 %define sover   1
-%define _version 3.35
+%define _version 3.36
 Name:   metacity
-Version:3.35.1
+Version:3.36.0
 Release:0
 Summary:Window Manager for the MATE and GNOME Flashback desktops
 License:GPL-2.0-or-later
-Group:  System/Libraries
 URL:https://wiki.gnome.org/Projects/Metacity
 Source: 
https://download.gnome.org/sources/metacity/%{_version}/%{name}-%{version}.tar.xz
 BuildRequires:  autoconf
@@ -36,9 +35,9 @@
 BuildRequires:  update-desktop-files
 BuildRequires:  yelp-tools
 BuildRequires:  zenity
-BuildRequires:  pkgconfig(glib-2.0) >= 2.44
+BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(gsettings-desktop-schemas) >= 3.3.0
-BuildRequires:  pkgconfig(gtk+-3.0) >= 3.22
+BuildRequires:  pkgconfig(gtk+-3.0)
 BuildRequires:  pkgconfig(libcanberra-gtk3)
 BuildRequires:  pkgconfig(libgtop-2.0)
 BuildRequires:  pkgconfig(libstartup-notification-1.0)
@@ -62,28 +61,26 @@
 %endif
 
 %description
-Metacity is a small window manager, using GTK+ to do everything.
+Metacity is a small window manager, using GTK to do everything.
 It is developed mainly for the MATE and GNOME Flashback desktops.
 
 %lang_package
 
 %package -n %{soname}%{sover}
 Summary:Window Manager for the MATE Desktop -- Library to render themes
-Group:  System/Libraries
 
 %description -n %{soname}%{sover}
-Metacity is a small window manager, using GTK+ to do everything.
+Metacity is a small window manager, using GTK to do everything.
 It is developed mainly for the MATE and GNOME Flashback desktops.
 
 This package contains a library to render themes.
 
 %package tools
 Summary:Window Manager for the MATE Desktop -- Tools
-Group:  System/GUI/Other
 Requires:   %{name} = %{version}
 
 %description tools
-Metacity is a small window manager, using GTK+ to do everything.
+Metacity is a small window manager, using GTK to do everything.
 It is developed mainly for the MATE and GNOME Flashback desktops.
 
 This package contains tools related to metacity, including an
@@ -92,11 +89,10 @@
 
 %package devel
 Summary:Window Manager for the MATE Desktop -- Development Files
-Group:  Development/Libraries/C and C++
 Requires:   %{soname}%{sover} = %{version}
 
 %description devel
-Metacity is a small window manager, using GTK+ to do everything.
+Metacity is a small window manager, using GTK to do everything.
 It is developed mainly for the MATE and GNOME Flashback desktops.
 
 This package contains all necessary include files and libraries

++ metacity-3.35.1.tar.xz -> metacity-3.36.0.tar.xz ++
 4304 lines of diff (skipped)




commit mate-power-manager for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package mate-power-manager for 
openSUSE:Factory checked in at 2020-03-18 12:43:53

Comparing /work/SRC/openSUSE:Factory/mate-power-manager (Old)
 and  /work/SRC/openSUSE:Factory/.mate-power-manager.new.3160 (New)


Package is "mate-power-manager"

Wed Mar 18 12:43:53 2020 rev:26 rq:786020 version:1.24.1

Changes:

--- /work/SRC/openSUSE:Factory/mate-power-manager/mate-power-manager.changes
2020-03-03 10:17:55.754860026 +0100
+++ 
/work/SRC/openSUSE:Factory/.mate-power-manager.new.3160/mate-power-manager.changes
  2020-03-18 12:49:06.269092720 +0100
@@ -1,0 +2,16 @@
+Tue Mar 17 16:49:37 UTC 2020 - Alexei Sorokin 
+
+- Update to version 1.24.1:
+  * glib-genmarshal: Replace deprecated tokens NONE and BOOL.
+  * Read authors (updated) from mate-power-manager.about.
+  * Use gtk_show_about_dialog to show about dialogue.
+  * Remove the CPU wakeups feature.
+  * Update copyright year in the About dialogue.
+  * Generate missing gpm-* PNGs from new SVGs.
+  * Add missing gpm-phone SVGs.
+  * Add missing gpm-keboard SVGs.
+  * Add missing gpm-mouse SVGs.
+  * Update translations.
+- Rebase mate-power-manager-upower-0.99.7.patch.
+
+---

Old:

  mate-power-manager-1.24.0.tar.xz

New:

  mate-power-manager-1.24.1.tar.xz



Other differences:
--
++ mate-power-manager.spec ++
--- /var/tmp/diff_new_pack.3Pr4gm/_old  2020-03-18 12:49:12.513096449 +0100
+++ /var/tmp/diff_new_pack.3Pr4gm/_new  2020-03-18 12:49:12.513096449 +0100
@@ -18,7 +18,7 @@
 
 %define _version 1.24
 Name:   mate-power-manager
-Version:1.24.0
+Version:1.24.1
 Release:0
 Summary:MATE Desktop UPower policy management
 License:GPL-2.0-only

++ mate-power-manager-1.24.0.tar.xz -> mate-power-manager-1.24.1.tar.xz 
++
 115397 lines of diff (skipped)

++ mate-power-manager-upower-0.99.7.patch ++
--- /var/tmp/diff_new_pack.3Pr4gm/_old  2020-03-18 12:49:14.057097371 +0100
+++ /var/tmp/diff_new_pack.3Pr4gm/_new  2020-03-18 12:49:14.057097371 +0100
@@ -41,10 +41,10 @@
g_object_get (device,
 --- a/src/gpm-statistics.c
 +++ b/src/gpm-statistics.c
-@@ -1764,7 +1764,12 @@ main (int argc, char *argv[])
+@@ -1407,7 +1407,12 @@ main (int argc, char *argv[])
+ 
+   client = up_client_new ();
  
-   wakeups = up_wakeups_new ();
-   g_signal_connect (wakeups, "data-changed", G_CALLBACK 
(gpm_stats_data_changed_cb), NULL);
 +#if UP_CHECK_VERSION(0, 99, 8)
devices = up_client_get_devices2 (client);
 +#else




commit noson-app for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package noson-app for openSUSE:Factory 
checked in at 2020-03-18 12:43:33

Comparing /work/SRC/openSUSE:Factory/noson-app (Old)
 and  /work/SRC/openSUSE:Factory/.noson-app.new.3160 (New)


Package is "noson-app"

Wed Mar 18 12:43:33 2020 rev:5 rq:786017 version:4.2.6

Changes:

--- /work/SRC/openSUSE:Factory/noson-app/noson-app.changes  2020-01-30 
09:41:53.465505847 +0100
+++ /work/SRC/openSUSE:Factory/.noson-app.new.3160/noson-app.changes
2020-03-18 12:48:42.465078502 +0100
@@ -1,0 +2,9 @@
+Tue Mar 17 14:52:25 UTC 2020 - Dominique Leuenberger 
+
+- Add libqt5-qtgraphicaleffects and libqt5-qtquickcontrols2
+  dependencies: those Qt5 extensions are required to start the
+  application.
+- Drop update-alternatives dependencies: u-a is not used at all
+  here.
+
+---



Other differences:
--
++ noson-app.spec ++
--- /var/tmp/diff_new_pack.Q4zJxa/_old  2020-03-18 12:48:47.105081273 +0100
+++ /var/tmp/diff_new_pack.Q4zJxa/_new  2020-03-18 12:48:47.129081287 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package noson-app
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -22,7 +22,7 @@
 Summary:SONOS device controller
 License:GPL-3.0-or-later
 Group:  Productivity/Multimedia/Sound/Players
-URL:http://janbar.github.io/noson-app/index.html
+URL:https://janbar.github.io/noson-app/index.html
 Source0:https://github.com/janbar/noson-app/archive/%{version}.tar.gz
 BuildRequires:  cmake
 BuildRequires:  extra-cmake-modules
@@ -40,8 +40,8 @@
 BuildRequires:  pkgconfig(Qt5Svg)
 BuildRequires:  pkgconfig(Qt5Xml)
 BuildRequires:  pkgconfig(noson) = 2.3.0
-Requires(post): update-desktop-files
-Requires(postun): update-desktop-files
+Requires:   libqt5-qtgraphicaleffects
+Requires:   libqt5-qtquickcontrols2
 
 %description
 A controller for SONOS devices. It allows for browsing the music




commit rapid-photo-downloader for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package rapid-photo-downloader for 
openSUSE:Factory checked in at 2020-03-18 12:42:52

Comparing /work/SRC/openSUSE:Factory/rapid-photo-downloader (Old)
 and  /work/SRC/openSUSE:Factory/.rapid-photo-downloader.new.3160 (New)


Package is "rapid-photo-downloader"

Wed Mar 18 12:42:52 2020 rev:10 rq:785999 version:0.9.19

Changes:

--- 
/work/SRC/openSUSE:Factory/rapid-photo-downloader/rapid-photo-downloader.changes
2020-03-17 13:11:34.753865028 +0100
+++ 
/work/SRC/openSUSE:Factory/.rapid-photo-downloader.new.3160/rapid-photo-downloader.changes
  2020-03-18 12:47:45.505044472 +0100
@@ -1,0 +2,65 @@
+Tue Mar 17 16:20:27 UTC 2020 - Marcus Rueckert 
+
+- Update to version 0.9.19 
+  - Fixed errors in appstream metainfo file.
+  - To better conform to appstream metadata requirements, renamed
+destktop and metadata files to
+net.damonlynch.rapid_photo_downloader.desktop and
+net.damonlynch.rapid_photo_downloader.metainfo.xml. The
+metainfo file is now installed in share/metainfo/, not
+share/appdata/.
+  - Added Zorin OS to install.py script.
+  - Only install symlinks to the program in a bin directory the
+users's home directory (i.e. ~/bin) if necessary. On recent
+installations of Debian / Ubuntu / LinuxMint etc. with a
+default profile setup, this is no longer necessary.
+  - When uninstalling the program that was previously installed
+with install.py script, remove any symlinks to it created in
+~/bin.
+  - Removed setup.cfg configuration file.
+  - Removed notification informing the Timeline or provisional
+download folders was rebuilt.
+  - Updated Dutch, Hungarian, Russian, Spanish, Russian, and
+Turkish translations.
+  - Improved fix for a bug where thumbnails would not be able to
+have their checkmark set on or off with the mouse on recent
+versions of Qt. The fix in 0.9.19b2 did not always work. The
+environment variable RPD_THUMBNAIL_MARK_FIX introduced in
+0.9.19b2 is no longer needed, and will be ignored.
+  - Fixed bug #1842060: Wrong value saved for stored number.
+  - Updated Czech, Dutch, French, and Spanish translations.
+  - Fixed a bug where thumbnails would not be able to have their
+checkmark set on or off with the mouse on recent versions of
+Qt. See the release notes for details.
+  - Improved visual appearance on high DPI screens.
+  - Added HEIF / HEIC support. See the Release Notes for details.
+  - Added support for CentOS 8 to installer script. Dropped support
+for Fedora 29 and older. Installer script no longer installs
+PyQt5 from PyPI on KDE Neon, because KDE Neon PyQt5 package is
+always up-to-date.
+  - Added '__MACOSX' and to list of paths to ignore while scanning
+a device for photos and videos, and if the list of ignored
+paths is customized, add it and 'THMBNL' to the existing list
+of ignored paths.
+  - No longer look for photos or videos in any directory on a
+camera or phone that contains a '.nomedia' file.
+  - Made Timeline and thumbnails render more quickly and accurately
+on displays with fractional scaling.
+  - Fixed bug #1861591: install.py should handle cases with no LANG
+variable set.
+  - Fixed bug #1833525: when using the filename and subfolder name
+preference editor, under some desktop styles the example file
+and subfolder names would shrink to the extent they would be
+truncated.
+  - Fixed bug where Rapid Photo Downloader would crash when the
+Preferences dialog window was closed with the escape key.
+  - Fixed bug where under some desktop styles the right side panel
+would always be open even if it had been closed when Rapid
+Photo Downloader last exited.
+  - Improved support for high DPI screens. Requires Qt5.6 or newer.
+Please report any remaining problems when running on high DPI
+screens. For now, if you change the desktop's screen scaling
+while Rapid Photo Downloader is running, please restart it.
+- add recommends for python3-pyheif
+
+---

Old:

  rapid-photo-downloader-0.9.18.tar.gz
  rapid-photo-downloader-0.9.18.tar.gz.asc

New:

  rapid-photo-downloader-0.9.19.tar.gz
  rapid-photo-downloader-0.9.19.tar.gz.asc



Other differences:
--
++ rapid-photo-downloader.spec ++
--- /var/tmp/diff_new_pack.LeHIOy/_old  2020-03-18 12:47:52.401048600 +0100
+++ /var/tmp/diff_new_pack.LeHIOy/_new  2020-03-18 12:47:52.405048602 +0100
@@ -20,7 +20,7 @@
 
 %global __requires_exclude ^typelib\\(Unity\\).*$
 Name:   rapid-photo-downloader
-Version:0.9.18
+Version:0.9.19
 Release:0
 Summary:Parallel 

commit perl-Mojolicious for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package perl-Mojolicious for 
openSUSE:Factory checked in at 2020-03-18 12:43:11

Comparing /work/SRC/openSUSE:Factory/perl-Mojolicious (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Mojolicious.new.3160 (New)


Package is "perl-Mojolicious"

Wed Mar 18 12:43:11 2020 rev:124 rq:786004 version:8.34

Changes:

--- /work/SRC/openSUSE:Factory/perl-Mojolicious/perl-Mojolicious.changes
2020-02-13 10:11:57.432355341 +0100
+++ 
/work/SRC/openSUSE:Factory/.perl-Mojolicious.new.3160/perl-Mojolicious.changes  
2020-03-18 12:48:25.273068234 +0100
@@ -1,0 +2,23 @@
+Tue Mar 17 03:14:21 UTC 2020 -  
+
+- updated to 8.34
+   see /usr/share/doc/packages/perl-Mojolicious/Changes
+
+  8.34  2020-03-16
+- Removed experimental status from proxy->get_p, proxy->post_p and
+  proxy->start_p helpers in Mojolicious::Plugin::DefaultHelpers.
+- Removed experimental status from compress and min_compress_size 
attributes
+  in Mojolicious::Renderer.
+- Removed experimental status from high_water_mark attribute in
+  Mojo::IOLoop::Stream.
+- Removed experimental status from respond method in Mojolicious::Renderer.
+- Removed experimental status from bytes_waiting and can_write methods in
+  Mojo::IOLoop::Stream.
+- Removed experimental status from dehop method in Mojo::Headers.
+- Removed experimental status from scope_guard function in Mojo::Util.
+- Improved size check in Mojolicious::Validator to only require one 
argument.
+- Fixed Mojolicious::Validator to also validate empty string values 
instead of
+  ignoring them. This behaviour had caused a lot of confusion in the past.
+- Fixed plugin generator not to use an __END__ section.
+
+---

Old:

  Mojolicious-8.33.tar.gz

New:

  Mojolicious-8.34.tar.gz



Other differences:
--
++ perl-Mojolicious.spec ++
--- /var/tmp/diff_new_pack.lwF5QG/_old  2020-03-18 12:48:33.021072861 +0100
+++ /var/tmp/diff_new_pack.lwF5QG/_new  2020-03-18 12:48:33.021072861 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Mojolicious
-Version:8.33
+Version:8.34
 Release:0
 %define cpan_name Mojolicious
 Summary:Real-time web framework

++ Mojolicious-8.33.tar.gz -> Mojolicious-8.34.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-8.33/Changes new/Mojolicious-8.34/Changes
--- old/Mojolicious-8.33/Changes2020-02-11 13:00:49.0 +0100
+++ new/Mojolicious-8.34/Changes2020-03-16 16:52:00.0 +0100
@@ -1,4 +1,21 @@
 
+8.34  2020-03-16
+  - Removed experimental status from proxy->get_p, proxy->post_p and
+proxy->start_p helpers in Mojolicious::Plugin::DefaultHelpers.
+  - Removed experimental status from compress and min_compress_size attributes
+in Mojolicious::Renderer.
+  - Removed experimental status from high_water_mark attribute in
+Mojo::IOLoop::Stream.
+  - Removed experimental status from respond method in Mojolicious::Renderer.
+  - Removed experimental status from bytes_waiting and can_write methods in
+Mojo::IOLoop::Stream.
+  - Removed experimental status from dehop method in Mojo::Headers.
+  - Removed experimental status from scope_guard function in Mojo::Util.
+  - Improved size check in Mojolicious::Validator to only require one argument.
+  - Fixed Mojolicious::Validator to also validate empty string values instead 
of
+ignoring them. This behaviour had caused a lot of confusion in the past.
+  - Fixed plugin generator not to use an __END__ section.
+
 8.33  2020-02-11
   - Added EXPERIMENTAL humanize_bytes function to Mojo::Util. (kraih, coolo)
   - Added EXPERIMENTAL humanize_bytes method to Mojo::ByteStream.
@@ -2229,8 +2246,8 @@
 4.49  2013-10-17
   - Added tls_ciphers option to Mojo::IOLoop::Server::listen.
   - Added ciphers parameter to Mojo::Server::Daemon::listen.
-  - Removed experimental status from Mojolicioua::Validator.
-  - Removed experimental status from Mojolicioua::Validator::Validation.
+  - Removed experimental status from Mojolicious::Validator.
+  - Removed experimental status from Mojolicious::Validator::Validation.
   - Removed experimental status from validation method in
 Mojolicious::Controller.
   - Removed experimental status from validator attribute in Mojolicious.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Mojolicious-8.33/META.json 
new/Mojolicious-8.34/META.json
--- old/Mojolicious-8.33/META.json  2020-02-11 21:24:26.0 +0100
+++ new/Mojolicious-8.34/META.json  2020-03-16 18:26:07.0 +0100
@@ 

commit twilio-utils for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package twilio-utils for openSUSE:Factory 
checked in at 2020-03-18 12:42:39

Comparing /work/SRC/openSUSE:Factory/twilio-utils (Old)
 and  /work/SRC/openSUSE:Factory/.twilio-utils.new.3160 (New)


Package is "twilio-utils"

Wed Mar 18 12:42:39 2020 rev:9 rq:785967 version:1.2.0

Changes:

--- /work/SRC/openSUSE:Factory/twilio-utils/twilio-utils.changes
2020-03-11 18:50:14.283537838 +0100
+++ /work/SRC/openSUSE:Factory/.twilio-utils.new.3160/twilio-utils.changes  
2020-03-18 12:47:10.557022367 +0100
@@ -1,0 +2,5 @@
+Tue Mar 17 15:29:23 UTC 2020 - Archie Cobbs 
+
+- Update project URL in spec file 
+
+---



Other differences:
--
++ twilio-utils.spec ++
--- /var/tmp/diff_new_pack.edgCD1/_old  2020-03-18 12:47:14.125024623 +0100
+++ /var/tmp/diff_new_pack.edgCD1/_new  2020-03-18 12:47:14.165024649 +0100
@@ -28,7 +28,7 @@
 License:Apache-2.0
 Group:  Productivity/Text/Utilities
 Source: %{name}-%{version}.tar.gz
-URL:http://twilio-utils.googlecode.com/
+URL:https://github.com/archiecobbs/twilio-utils
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  curl
 BuildRequires:  gcc




commit wesnoth for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package wesnoth for openSUSE:Factory checked 
in at 2020-03-18 12:42:06

Comparing /work/SRC/openSUSE:Factory/wesnoth (Old)
 and  /work/SRC/openSUSE:Factory/.wesnoth.new.3160 (New)


Package is "wesnoth"

Wed Mar 18 12:42:06 2020 rev:14 rq:785992 version:1.15.3

Changes:

--- /work/SRC/openSUSE:Factory/wesnoth/wesnoth.changes  2019-08-23 
11:10:37.230451880 +0200
+++ /work/SRC/openSUSE:Factory/.wesnoth.new.3160/wesnoth.changes
2020-03-18 12:46:40.981003659 +0100
@@ -1,0 +2,6 @@
+Tue Mar 10 06:53:44 UTC 2020 - Michael Vetter 
+
+- Update to 1.15.3:
+  * Too many changes to list. Please see changelog.md.
+
+---

Old:

  1.15.1.tar.gz

New:

  1.15.3.tar.gz



Other differences:
--
++ wesnoth.spec ++
--- /var/tmp/diff_new_pack.E0q5Jb/_old  2020-03-18 12:46:49.585009102 +0100
+++ /var/tmp/diff_new_pack.E0q5Jb/_new  2020-03-18 12:46:49.585009102 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package wesnoth
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,13 +12,13 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 %define boost_min_version 1.56
 Name:   wesnoth
-Version:1.15.1
+Version:1.15.3
 Release:0
 Summary:Fantasy Turn-Based Strategy Game
 License:GPL-2.0-or-later AND EPL-1.0
@@ -149,7 +149,7 @@
 
 %files data -f %{name}.lang
 %license COPYING copyright
-%doc changelog.md CONTRIBUTING.md README.md
+%doc changelog.md README.md
 %{_datadir}/wesnoth/
 %{_docdir}/wesnoth/
 

++ 1.15.1.tar.gz -> 1.15.3.tar.gz ++
/work/SRC/openSUSE:Factory/wesnoth/1.15.1.tar.gz 
/work/SRC/openSUSE:Factory/.wesnoth.new.3160/1.15.3.tar.gz differ: char 15, 
line 1




commit libvisio2svg for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package libvisio2svg for openSUSE:Factory 
checked in at 2020-03-18 12:41:18

Comparing /work/SRC/openSUSE:Factory/libvisio2svg (Old)
 and  /work/SRC/openSUSE:Factory/.libvisio2svg.new.3160 (New)


Package is "libvisio2svg"

Wed Mar 18 12:41:18 2020 rev:3 rq:785955 version:0.5.5

Changes:

--- /work/SRC/openSUSE:Factory/libvisio2svg/libvisio2svg.changes
2018-07-09 13:27:29.834965781 +0200
+++ /work/SRC/openSUSE:Factory/.libvisio2svg.new.3160/libvisio2svg.changes  
2020-03-18 12:45:53.128973391 +0100
@@ -1,0 +2,6 @@
+Mon Mar 16 08:09:01 UTC 2020 - Christophe Giboudeaux 
+
+- Disable RPATH for building libvision2svg.
+- Spec cleanup.
+
+---



Other differences:
--
++ libvisio2svg.spec ++
--- /var/tmp/diff_new_pack.hyTbO9/_old  2020-03-18 12:45:54.072973989 +0100
+++ /var/tmp/diff_new_pack.hyTbO9/_new  2020-03-18 12:45:54.076973991 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libvisio2svg
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,25 +12,25 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
-%define soversion 0
 
+%define soversion 0
 Name:   libvisio2svg
 Version:0.5.5
 Release:0
-License:GPL-2.0
 Summary:Library to convert Visio Documents and Stencils (VSS and VSD) 
to SVG
-Url:https://github.com/kakwa/libvisio2svg
+License:GPL-2.0-only
 Group:  Productivity/Graphics/Convertors
+URL:https://github.com/kakwa/libvisio2svg
 Source0:
https://github.com/kakwa/libvisio2svg/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
 BuildRequires:  cmake
 BuildRequires:  freetype2-devel
 %if 0%{?suse_version} > 1320
 BuildRequires:  gcc-c++
 %else
-# Leap 42.2+ / SLE12SP2Backports
+# SLE12
 BuildRequires:  gcc7-c++
 #!Buildignore:  libgcc_s1
 %endif
@@ -39,7 +39,6 @@
 BuildRequires:  libvisio-devel
 BuildRequires:  libwmf-devel
 BuildRequires:  libxml2-devel
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 Library for conversion of Visio Documents and Stencils (VSS and VSD) to SVG.
@@ -81,32 +80,28 @@
 %build
 test -x "$(type -p gcc-7)" && export CC=gcc-7
 test -x "$(type -p g++-7)" && export CXX=g++-7
-%cmake
-make %{?_smp_mflags}
+%cmake -DCMAKE_SKIP_RPATH=TRUE
+%cmake_build
 
 %install
 %cmake_install
 
 %post -n %{name}%{soversion} -p /sbin/ldconfig
-
 %postun -n %{name}%{soversion} -p /sbin/ldconfig
 
 %files -n %{name}%{soversion}
-%defattr(-,root,root)
 %doc README.md
 %license LICENSE
 %{_libdir}/libTitleGenerator.*so.*
 %{_libdir}/libVisio2Svg.*so.*
 
 %files devel
-%defattr(-,root,root)
 %{_libdir}/libTitleGenerator.*so
 %{_libdir}/libVisio2Svg.*so
 %dir %{_includedir}/visio2svg/
 %{_includedir}/visio2svg/*.h
 
 %files -n visio2svg-conv
-%defattr(-,root,root)
 %{_bindir}/vss2svg-conv
 %{_bindir}/vsd2svg-conv
 




commit libite for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package libite for openSUSE:Factory checked 
in at 2020-03-18 12:41:03

Comparing /work/SRC/openSUSE:Factory/libite (Old)
 and  /work/SRC/openSUSE:Factory/.libite.new.3160 (New)


Package is "libite"

Wed Mar 18 12:41:03 2020 rev:4 rq:785962 version:2.2.0

Changes:

--- /work/SRC/openSUSE:Factory/libite/libite.changes2019-08-28 
18:35:07.869287367 +0200
+++ /work/SRC/openSUSE:Factory/.libite.new.3160/libite.changes  2020-03-18 
12:45:41.776966211 +0100
@@ -1,0 +2,13 @@
+Tue Mar 17 08:53:03 UTC 2020 - Martin Hauke 
+
+- Update to versino 2.2.0
+  Changes
+  * Add support for systemf(), formatted string system() replacement
+  * Add support for fmkpath(), formatted string mkpath()
+  * Add support for fopenf(), formatted string fopen() replacement
+  Fixes
+  * Fix possible memory leak in rsync(), found by Coverity Scan
+  * Check return value of fstat() to prevent bogus destination file
+times when using copyfile(), found by Coverity Scan
+
+---

Old:

  libite-2.1.0.tar.gz

New:

  libite-2.2.0.tar.gz



Other differences:
--
++ libite.spec ++
--- /var/tmp/diff_new_pack.S1rCoF/_old  2020-03-18 12:45:44.208967750 +0100
+++ /var/tmp/diff_new_pack.S1rCoF/_new  2020-03-18 12:45:44.25296 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libite
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 # Copyright (c) 2018, Martin Hauke 
 #
 # All modifications and additions to the file contributed by third parties
@@ -19,7 +19,7 @@
 
 %define sover 5
 Name:   libite
-Version:2.1.0
+Version:2.2.0
 Release:0
 Summary:BSD function library
 License:MIT AND X11

++ libite-2.1.0.tar.gz -> libite-2.2.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libite-2.1.0/.gitignore new/libite-2.2.0/.gitignore
--- old/libite-2.1.0/.gitignore 2019-08-26 21:59:57.0 +0200
+++ new/libite-2.2.0/.gitignore 2020-03-16 17:41:44.0 +0100
@@ -1,16 +1,8 @@
 *~
-*.d
-*.o
-*.so
-*.so.*
-*.a
-.deps
-.libs
 ID
 GPATH
 GRTAGS
 GTAGS
-tmp/
 compile
 config.*
 configure
@@ -25,5 +17,5 @@
 aclocal.m4
 ar-lib
 autom4te.cache
-libite*
-test-driver
\ No newline at end of file
+test-driver
+libite.pc
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libite-2.1.0/.travis.yml new/libite-2.2.0/.travis.yml
--- old/libite-2.1.0/.travis.yml2019-08-26 21:59:57.0 +0200
+++ new/libite-2.2.0/.travis.yml2020-03-16 17:41:44.0 +0100
@@ -10,6 +10,25 @@
   - gcc
   - clang
 
+env:
+  global:
+   # The next declaration is the encrypted COVERITY_SCAN_TOKEN, created
+   #   via the "travis encrypt" command using the project repo's public key
+   - secure: 
"EcWeDUONZnl7IHBWD2rc92LwTWGIlqBZ7wQrLfe3mFXOnB+IZjJIBnDsJDnHDWwA8fGF9NaJbRz4BThroafueUwkDXNyvph1Mdaxm6mdMPyjNJ4H1AFkd9Fz0LYdLNXCPl43tm6s1BR6OWts17lWF6sMnMmIu8gUgXJVg2qsDBl3O9eCoRvQ/h4elLfXZ03fHi4XzzzQvZVyDCg8MCzXIgHJzdkv4llpiCLWQExFbIAVy39euDnx+UuWYB7WDdUbOc7HkkUwf0/vX9PhKVQFKOkXn1ddN0iCsWRH3ti5KXWrBeRO3RPu6Z5YtR8l1WK7iqCYOLuMBW23tXsBQsIW09f1+fFgJ8Ig5hHRRbDinbTUb+mHUJZmNv9ZTc3hPYH4Fyev/ljk42VVDdIBy9AqO42jj8VGmDmiIq47aqNJZUGYZgQlGXGqk9MtavJrqEVcFSgyfEtI+c4n4fzvMRpcEwjnbp482s1xNzHQZ1GQI77Td5UUXXWyNSCoQoE/VpkAesYJAw8KwXOXveDr3Qu0HhuQu1oyLmWHlZHYDu+TInjY81gpGw9Cm7/SdFoA0Ag49PlAXdPRymbP01B50MqrCTxtXEHtdXxhrkDvaoUp7heSuvO0fS+mI5F7eQ4Ji2JdyRSt1KpXVNAyL1FrO/yznM3EwcXPmWmrc+QjFtC9vY4="
+
+before_install:
+  - echo -n | openssl s_client -connect scan.coverity.com:443 | sed -ne 
'/-BEGIN CERTIFICATE-/,/-END CERTIFICATE-/p' | sudo tee -a /etc/ssl/certs/ca-
+
+addons:
+  coverity_scan:
+project:
+  name: "troglobit/libite"
+  description: "That missing frog DNA you've been looking for"
+notification_email: troglo...@gmail.com
+build_command_prepend: "./autogen.sh && ./configure --prefix=/tmp 
--disable-silent-rules"
+build_command: "make clean all"
+branch_pattern: dev
+
 script:
   - ./autogen.sh
   - ./configure --prefix=/tmp --disable-silent-rules
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libite-2.1.0/ChangeLog.md 
new/libite-2.2.0/ChangeLog.md
--- old/libite-2.1.0/ChangeLog.md   2019-08-26 21:59:57.0 +0200
+++ new/libite-2.2.0/ChangeLog.md   2020-03-16 17:41:44.0 +0100
@@ -3,6 +3,39 @@
 
 All notable changes to the project are documented in this file.
 
+
+[v2.2.0][] - 2020-03-16
+---
+
+### Changes
+- Add support for `systemf()`, formatted string `system()` replacement
+- Add support 

commit bless for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package bless for openSUSE:Factory checked 
in at 2020-03-18 12:41:24

Comparing /work/SRC/openSUSE:Factory/bless (Old)
 and  /work/SRC/openSUSE:Factory/.bless.new.3160 (New)


Package is "bless"

Wed Mar 18 12:41:24 2020 rev:3 rq:785989 version:0.6.2

Changes:

--- /work/SRC/openSUSE:Factory/bless/bless.changes  2019-07-26 
12:40:21.093908592 +0200
+++ /work/SRC/openSUSE:Factory/.bless.new.3160/bless.changes2020-03-18 
12:45:56.348975429 +0100
@@ -1,0 +2,8 @@
+Tue Mar 17 15:41:41 UTC 2020 - Marguerite Su 
+
+- update version 0.6.2
+  * see git commits
+- add bless-0.6.2-Range-ambiguous-reference.patch
+  * Fix building error CS0104: 'Range' is an ambiguous reference
+
+---

Old:

  alf82-key.gpg
  bless-0.6.0.tar.gz
  bless-0.6.0.tar.gz.sig

New:

  bless-0.6.2-Range-ambiguous-reference.patch
  bless-0.6.2.tar.gz



Other differences:
--
++ bless.spec ++
--- /var/tmp/diff_new_pack.v8wPgK/_old  2020-03-18 12:45:57.452976127 +0100
+++ /var/tmp/diff_new_pack.v8wPgK/_new  2020-03-18 12:45:57.456976129 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package bless
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,17 +17,17 @@
 
 
 Name:   bless
-Version:0.6.0
+Version:0.6.2
 Release:0
 Summary:Gtk#-based Hex-editor written in C#
 License:GPL-2.0-only
 Group:  Development/Tools/Other
-Url:http://home.gna.org/bless
-Source: http://download.gna.org/bless/%{name}-%{version}.tar.gz
-Source1:http://download.gna.org/bless/bless-0.6.0.tar.gz.sig
-Source2:http://gna.org/people/viewgpg.php?user_id=1269#/alf82-key.gpg
+URL:https://github.com/afrantzis/bless
+Source: 
https://github.com/afrantzis/bless/archive/v%{version}/%{name}-%{version}.tar.gz
 #PATCH-FIX-UPSTREAM jbi...@debian.org - build without scrollkeeper/rarian
-Patch:  dont-require-rarian.patch
+Patch0: dont-require-rarian.patch
+#PATCH-FIX-UPSTREAM Fix building error CS0104: 'Range' is an ambiguous 
reference
+Patch1: bless-0.6.2-Range-ambiguous-reference.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  fdupes
@@ -36,7 +36,6 @@
 BuildRequires:  pkgconfig(glade-sharp-2.0)
 BuildRequires:  pkgconfig(gtk-sharp-2.0)
 BuildRequires:  pkgconfig(mono)
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 Bless is a hex editor written in Mono/Gtk#. It features:
@@ -62,15 +61,18 @@
 This package contains the documentation.
 
 %prep
-%autosetup -p1
+%setup -q
+%patch -p1
+%patch1 -p1
+./autogen.sh
 # Fix Build for Mono 4.0
-sed -i 's/gmcs/mcs/' configure{,.ac} builder/ModuleBuilder.cs
-autoreconf -fi
+sed -i 's/gmcs/mcs/' configure builder/ModuleBuilder.cs
+#autoreconf -fi
 
 %build
 %configure --without-scrollkeeper
 sed -i 's/$(MKDIR_P)/mkdir -p/' po/Makefile
-make %{?_smp_mflags}
+%make_build
 
 %install
 %make_install
@@ -85,8 +87,8 @@
 %desktop_database_postun
 
 %files
-%defattr(-,root,root)
-%doc AUTHORS ChangeLog COPYING NEWS README
+%license COPYING
+%doc AUTHORS ChangeLog NEWS README
 %{_bindir}/bless
 %{_libdir}/bless
 %{_datadir}/applications/bless.desktop
@@ -94,7 +96,6 @@
 %{_datadir}/pixmaps/*
 
 %files doc
-%defattr(-,root,root)
 %{_datadir}/doc/bless/
 %{_datadir}/doc/bless/user/
 %{_datadir}/doc/bless/user/figures/

++ bless-0.6.2-Range-ambiguous-reference.patch ++
>From 84801988f908e51d9843c3e0ee8f2cd05c0a2d97 Mon Sep 17 00:00:00 2001
From: davidcim 
Date: Thu, 3 Oct 2019 12:38:25 +0200
Subject: [PATCH] Fix building error CS0104: 'Range' is an ambiguous reference

---
 src/buffers/ByteBuffer.cs|  2 +-
 src/gui/DataBookFinder.cs|  4 ++--
 src/gui/areas/AreaGroup.cs   | 20 ++--
 src/tools/find/FindOperations.cs |  6 +++---
 src/tools/find/IFindStrategy.cs  | 10 +-
 src/tools/find/IFinder.cs|  4 ++--
 6 files changed, 23 insertions(+), 23 deletions(-)

diff --git a/src/buffers/ByteBuffer.cs b/src/buffers/ByteBuffer.cs
index b9d9a24..72c1b42 100644
--- a/src/buffers/ByteBuffer.cs
+++ b/src/buffers/ByteBuffer.cs
@@ -671,7 +671,7 @@ public byte[] RangeToByteArray(IRange range)
/// Returns as a SegmentCollection the data contained in 
/// the specified range in the buffer.  
///
-   public SegmentCollection RangeToSegmentCollection(Range range)
+   public SegmentCollection RangeToSegmentCollection(Util.Range range)
  

commit python-sortinghat for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-sortinghat for 
openSUSE:Factory checked in at 2020-03-18 12:41:37

Comparing /work/SRC/openSUSE:Factory/python-sortinghat (Old)
 and  /work/SRC/openSUSE:Factory/.python-sortinghat.new.3160 (New)


Package is "python-sortinghat"

Wed Mar 18 12:41:37 2020 rev:5 rq:785968 version:0.7.7

Changes:

--- /work/SRC/openSUSE:Factory/python-sortinghat/python-sortinghat.changes  
2020-02-28 15:21:50.061953353 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-sortinghat.new.3160/python-sortinghat.changes
2020-03-18 12:46:06.620981926 +0100
@@ -1,0 +2,6 @@
+Tue Mar 17 14:11:53 UTC 2020 - pgaj...@suse.com
+
+- version update to 0.7.7
+  * no minor version changelog found
+
+---

Old:

  sortinghat-0.7.6.tar.gz
  tests.tar.bz2

New:

  sortinghat-0.7.7.tar.gz



Other differences:
--
++ python-sortinghat.spec ++
--- /var/tmp/diff_new_pack.WsZKjg/_old  2020-03-18 12:46:09.272983603 +0100
+++ /var/tmp/diff_new_pack.WsZKjg/_new  2020-03-18 12:46:09.280983608 +0100
@@ -19,15 +19,13 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-sortinghat
-Version:0.7.6
+Version:0.7.7
 Release:0
 Summary:A tool to manage identities
 License:GPL-3.0-only
 Group:  Development/Languages/Python
 URL:https://github.com/grimoirelab/sortinghat
 Source0:
https://files.pythonhosted.org/packages/source/s/sortinghat/sortinghat-%{version}.tar.gz
-# 
https://github.com/chaoss/grimoirelab-sortinghat/issues/207#issuecomment-534094890
-Source1:tests.tar.bz2
 # workaround for https://github.com/chaoss/grimoirelab-sortinghat/issues/121
 # reverting 
https://github.com/chaoss/grimoirelab-sortinghat/commit/5f69ed899c94584de17d47b37152098f64012e10
 # plus, test_is_top_domain_invalid_type and test_is_bot_invalid_type tests 
exception thrown from
@@ -87,9 +85,9 @@
 into unique identities (and maybe affiliate them).
 
 %prep
-%setup -q -a1 -n sortinghat-%{version}
+%setup -q -n sortinghat-%{version}
 %patch0 -p1
-sed -i "s/\('pandoc'\|'wheel',\)//" setup.py
+sed -i -e "s/\('pandoc'\|'wheel',\)//" -e 's/==/>=/' setup.py
 
 %build
 %python_build
@@ -111,10 +109,15 @@
 #
 # running the test
 #
-cp tests/tests.conf.sample tests/tests.conf
-sed -i -e "s/3306/$port/" \
-   -e "s/\(user=\)/\1$user/" \
-   -e "s/\(password=\)/\1$pass/" tests/tests.conf
+cat << EOF > tests/tests.conf
+[Database]
+name=testhat
+host=127.0.0.1
+port=$port
+user=$user
+password=$pass
+create=False
+EOF
 sed -i -e "s/'3306'/self.kwargs['port']/" tests/test_cmd_init.py
 %{python_expand $python setup.py test || exit_code=1}
 #

++ sortinghat-0.7.6.tar.gz -> sortinghat-0.7.7.tar.gz ++
 25494 lines of diff (skipped)




commit wt for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package wt for openSUSE:Factory checked in 
at 2020-03-18 12:41:10

Comparing /work/SRC/openSUSE:Factory/wt (Old)
 and  /work/SRC/openSUSE:Factory/.wt.new.3160 (New)


Package is "wt"

Wed Mar 18 12:41:10 2020 rev:37 rq:785964 version:4.2.2

Changes:

--- /work/SRC/openSUSE:Factory/wt/wt.changes2019-12-09 21:36:49.566060282 
+0100
+++ /work/SRC/openSUSE:Factory/.wt.new.3160/wt.changes  2020-03-18 
12:45:47.300969706 +0100
@@ -1,0 +2,10 @@
+Mon Mar 16 13:46:49 UTC 2020 - Paolo Stivanin 
+
+- Update to new upstream release 4.2.2:
+  * ensure that tooltips are always on top, even inside of a dialog
+  * fixed text format being reset when the text of a WAnchor is cleared
+  * fixed panning not working properly for a WCartesianChart with plain 
tooltips
+  * fixed JavaScript memory leak related to deferred or HTML tooltips
+  * and lots of other fixes 
(https://webtoolkit.eu/wt/doc/reference/html/Releasenotes.html)
+
+---

Old:

  4.2.0.tar.gz

New:

  4.2.2.tar.gz



Other differences:
--
++ wt.spec ++
--- /var/tmp/diff_new_pack.qkrzQC/_old  2020-03-18 12:45:49.032970801 +0100
+++ /var/tmp/diff_new_pack.qkrzQC/_new  2020-03-18 12:45:49.056970816 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package wt
 #
-# Copyright (c) 2019 SUSE LLC
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,9 +18,9 @@
 
 %define WTSRVDIR /srv/wt
 %define WTRUNDIR %{WTSRVDIR}/run
-%define so_version 4_2_0
+%define so_version 4_2_2
 Name:   wt
-Version:4.2.0
+Version:4.2.2
 Release:0
 #
 #

++ 4.2.0.tar.gz -> 4.2.2.tar.gz ++
/work/SRC/openSUSE:Factory/wt/4.2.0.tar.gz 
/work/SRC/openSUSE:Factory/.wt.new.3160/4.2.2.tar.gz differ: char 22, line 1




commit python-softlayer for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-softlayer for 
openSUSE:Factory checked in at 2020-03-18 12:41:51

Comparing /work/SRC/openSUSE:Factory/python-softlayer (Old)
 and  /work/SRC/openSUSE:Factory/.python-softlayer.new.3160 (New)


Package is "python-softlayer"

Wed Mar 18 12:41:51 2020 rev:7 rq:785970 version:5.8.5

Changes:

--- /work/SRC/openSUSE:Factory/python-softlayer/python-softlayer.changes
2019-09-11 10:35:24.851295864 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-softlayer.new.3160/python-softlayer.changes  
2020-03-18 12:46:14.096986654 +0100
@@ -1,0 +2,43 @@
+Tue Mar 17 14:29:19 UTC 2020 - pgaj...@suse.com
+
+- version update to 5.8.5
+  ## [5.8.5] - 2012-01-29
+  -  #1195 Fixed an issue with `slcli vs dns-sync --ptr`. Added `slcli hw 
dns-sync`
+  -  #1199 Fix File Storage failback and failover.
+  -  #1198 Fix issue where the summary command fails due to None being 
provided as the datacenter name.
+  -  #1208 Added The following commands:
+  - `slcli block volume-limits`
+  - `slcli file  volume-limits`
+  - #1209  Add testing/CI for python 3.8.
+  - #1212 Fix vs detail erroring on servers pending cancellation.
+  - #1210 support subnet ACL management through cli
+  + `slcli block subnets-list`
+  + `slcli block subnets-assign`
+  + `slcli block subnets-remove`
+  - #1215 Added documentation for all SLCLI commands.
+  ## [5.8.4] - 2019-12-20
+  - #1199 Fix block storage failback and failover.
+  - #1202 Order a virtual server private.
+  ## [5.8.3] - 2019-12-11
+  - #771 Fixed unicode errors in image list (for windows)
+  - #1191 Fixed ordering virtual server dedicated from the CLI
+  - #1155 Fixed capacity restriction when ordering storage quotes
+  - #1192 Fixed hardware detail bandwidth allocation errors.
+  ## [5.8.2] - 2019-11-15
+  + #1186 Fixed a unit test that could fail if the test took too long to run.
+  + #1183 Added a check to ensure subnet and vlan options are properly added 
to the order for virtual servers.
+  + #1184 Fixed a readme misspelling.
+  + #1182 Fixed vs reboot unable to resolve vs names.
+  + #1095 Handle missing Fixtures better for unit tests.
+  + #1169 Drop python 2.7 support
+  + #1170 Added CS# to ticket listing
+  + #1162 Fixed issue looking up OS keyName instead of referenceCode
+  + #627 Autoscale support
+  * slcli autoscale detail
+  * slcli autoscale edit
+  * slcli autoscale list
+  * slcli autoscale logs
+  * slcli autoscale scale
+  * slcli autoscale tag
+
+---

Old:

  v5.8.0.tar.gz

New:

  v5.8.5.tar.gz



Other differences:
--
++ python-softlayer.spec ++
--- /var/tmp/diff_new_pack.7BQjxK/_old  2020-03-18 12:46:16.276988033 +0100
+++ /var/tmp/diff_new_pack.7BQjxK/_new  2020-03-18 12:46:16.280988036 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-softlayer
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,9 @@
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%define skip_python2 1
 Name:   python-softlayer
-Version:5.8.0
+Version:5.8.5
 Release:0
 Summary:A set of Python libraries that assist in calling the SoftLayer 
API
 License:MIT
@@ -26,7 +27,7 @@
 URL:https://github.com/softlayer/softlayer-python
 Source: 
https://github.com/softlayer/softlayer-python/archive/v%{version}.tar.gz
 BuildRequires:  %{python_module PrettyTable >= 0.7.0}
-BuildRequires:  %{python_module click}
+BuildRequires:  %{python_module click >= 7}
 BuildRequires:  %{python_module mock}
 BuildRequires:  %{python_module prompt_toolkit >= 2}
 BuildRequires:  %{python_module pygments >= 2.0.0}
@@ -39,7 +40,7 @@
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
 Requires:   python-PrettyTable >= 0.7.0
-Requires:   python-click
+Requires:   python-click >= 7
 Requires:   python-prompt_toolkit >= 2
 Requires:   python-pygments >= 2.0.0
 Requires:   python-requests >= 2.20.0

++ v5.8.0.tar.gz -> v5.8.5.tar.gz ++
 6154 lines of diff (skipped)




commit python-simplekml for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-simplekml for 
openSUSE:Factory checked in at 2020-03-18 12:41:32

Comparing /work/SRC/openSUSE:Factory/python-simplekml (Old)
 and  /work/SRC/openSUSE:Factory/.python-simplekml.new.3160 (New)


Package is "python-simplekml"

Wed Mar 18 12:41:32 2020 rev:3 rq:785966 version:1.3.3

Changes:

--- /work/SRC/openSUSE:Factory/python-simplekml/python-simplekml.changes
2020-03-16 10:20:32.343641019 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-simplekml.new.3160/python-simplekml.changes  
2020-03-18 12:45:59.308977301 +0100
@@ -1,0 +2,6 @@
+Tue Mar 17 15:03:55 UTC 2020 - pgaj...@suse.com
+
+- version update to 1.3.3
+  * no upstream changelog found
+
+---

Old:

  simplekml-1.3.1.tar.gz

New:

  simplekml-1.3.3.tar.gz



Other differences:
--
++ python-simplekml.spec ++
--- /var/tmp/diff_new_pack.I02XMj/_old  2020-03-18 12:46:00.436978014 +0100
+++ /var/tmp/diff_new_pack.I02XMj/_new  2020-03-18 12:46:00.440978016 +0100
@@ -19,7 +19,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-simplekml
-Version:1.3.1
+Version:1.3.3
 Release:0
 Summary:A Simple KML creator
 #HG-Clone:  https://bitbucket.org/KyleLancaster/simplekml

++ simplekml-1.3.1.tar.gz -> simplekml-1.3.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/simplekml-1.3.1/PKG-INFO new/simplekml-1.3.3/PKG-INFO
--- old/simplekml-1.3.1/PKG-INFO2018-08-08 19:09:02.0 +0200
+++ new/simplekml-1.3.3/PKG-INFO2020-01-28 15:53:55.0 +0100
@@ -1,32 +1,32 @@
-Metadata-Version: 1.1
-Name: simplekml
-Version: 1.3.1
-Summary: A Simple KML creator
-Home-page: http://readthedocs.org/projects/simplekml/
-Author: Kyle Lancaster
-Author-email: kyle@gmail.com
-License: GNU Lesser General Public License v3+
-Description: Simplekml is a python package which enables you to generate KML 
with as little effort as possible.
-
-At the time of making this package nothing was available (at least I 
could not find anything) that could create KML files easily. You needed a lot 
of bloated code to even create a simple point. This is understandable because 
the KML standard is quite extensive, but what if you just work with the simple 
elements of KML like Document, Folder, Point, LineString and Polygon? This 
package supports those elements and everything documented in the KML Reference. 
With simplekml creating a KML file containing a point as simple as::
-
-import simplekml
-kml = simplekml.Kml()
-kml.newpoint(name="Kirstenbosch", coords=[(18.432314,-33.988862)])
-kml.save("botanicalgarden.kml")
-
-See the Homepage_ for usage, documentation and a reference.
-
-.. _Homepage: http://readthedocs.org/projects/simplekml/
-
-
-Platform: UNKNOWN
-Classifier: Development Status :: 5 - Production/Stable
-Classifier: Programming Language :: Python
-Classifier: Programming Language :: Python :: 2.6
-Classifier: Programming Language :: Python :: 2.7
-Classifier: Programming Language :: Python :: 3
-Classifier: License :: OSI Approved :: GNU Lesser General Public License v3 or 
later (LGPLv3+)
-Classifier: Operating System :: OS Independent
-Classifier: Topic :: Scientific/Engineering :: GIS
-Classifier: Topic :: Software Development :: Libraries :: Python Modules
+Metadata-Version: 1.1
+Name: simplekml
+Version: 1.3.3
+Summary: A Simple KML creator
+Home-page: http://readthedocs.org/projects/simplekml/
+Author: 2011-2016 Kyle Lancaster | 2019 Patrick Eisoldt
+Author-email: patr...@eisoldt.com
+License: GNU Lesser General Public License v3+
+Description: Simplekml is a python package which enables you to generate KML 
with as little effort as possible.
+
+At the time of making this package nothing was available (at least I 
could not find anything) that could create KML files easily. You needed a lot 
of bloated code to even create a simple point. This is understandable because 
the KML standard is quite extensive, but what if you just work with the simple 
elements of KML like Document, Folder, Point, LineString and Polygon? This 
package supports those elements and everything documented in the KML Reference. 
With simplekml creating a KML file containing a point as simple as::
+
+import simplekml
+kml = simplekml.Kml()
+kml.newpoint(name="Kirstenbosch", coords=[(18.432314,-33.988862)])
+kml.save("botanicalgarden.kml")
+
+

commit pcsx2 for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package pcsx2 for openSUSE:Factory checked 
in at 2020-03-18 12:40:49

Comparing /work/SRC/openSUSE:Factory/pcsx2 (Old)
 and  /work/SRC/openSUSE:Factory/.pcsx2.new.3160 (New)


Package is "pcsx2"

Wed Mar 18 12:40:49 2020 rev:9 rq:785942 version:1.5.0~git20200229

Changes:

--- /work/SRC/openSUSE:Factory/pcsx2/pcsx2.changes  2020-03-07 
21:41:32.880406225 +0100
+++ /work/SRC/openSUSE:Factory/.pcsx2.new.3160/pcsx2.changes2020-03-18 
12:45:26.720956688 +0100
@@ -1,0 +2,7 @@
+Fri Mar 06 22:13:49 UTC 2020 - pousadua...@gmail.com
+
+- Update to version 1.5.0~git20200229:
+  * gsdx-d3d11: Truncate fog in tfx.fx shader.
+  * Locales: Add Lithuanian Translations lt_LT. (#3267)
+
+---

Old:

  pcsx2-1.5.0~git20200222.tar.xz

New:

  pcsx2-1.5.0~git20200229.tar.xz



Other differences:
--
++ pcsx2.spec ++
--- /var/tmp/diff_new_pack.udYaky/_old  2020-03-18 12:45:28.660957915 +0100
+++ /var/tmp/diff_new_pack.udYaky/_new  2020-03-18 12:45:28.664957918 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   pcsx2
-Version:1.5.0~git20200222
+Version:1.5.0~git20200229
 Release:0
 Summary:Sony PlayStation 2 Emulator
 License:LGPL-3.0-only

++ _servicedata ++
--- /var/tmp/diff_new_pack.udYaky/_old  2020-03-18 12:45:28.692957935 +0100
+++ /var/tmp/diff_new_pack.udYaky/_new  2020-03-18 12:45:28.696957937 +0100
@@ -1,4 +1,4 @@
 
 
 https://github.com/PCSX2/pcsx2.git
-  6e22efe790a99d9750b407acd4690cc8b93d34d5
\ No newline at end of file
+  79db01d7ed01a4f3de06a8d8dc5c5e7099ef9d2e
\ No newline at end of file

++ pcsx2-1.5.0~git20200222.tar.xz -> pcsx2-1.5.0~git20200229.tar.xz ++
/work/SRC/openSUSE:Factory/pcsx2/pcsx2-1.5.0~git20200222.tar.xz 
/work/SRC/openSUSE:Factory/.pcsx2.new.3160/pcsx2-1.5.0~git20200229.tar.xz 
differ: char 26, line 1




commit python-spotipy for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-spotipy for openSUSE:Factory 
checked in at 2020-03-18 12:40:57

Comparing /work/SRC/openSUSE:Factory/python-spotipy (Old)
 and  /work/SRC/openSUSE:Factory/.python-spotipy.new.3160 (New)


Package is "python-spotipy"

Wed Mar 18 12:40:57 2020 rev:3 rq:785944 version:2.9.0

Changes:

--- /work/SRC/openSUSE:Factory/python-spotipy/python-spotipy.changes
2019-01-24 14:14:34.731281806 +0100
+++ /work/SRC/openSUSE:Factory/.python-spotipy.new.3160/python-spotipy.changes  
2020-03-18 12:45:35.888962486 +0100
@@ -1,0 +2,33 @@
+Tue Mar 17 13:57:10 UTC 2020 - pgaj...@suse.com
+
+- version update to 2.9.0
+  * Support `position_ms` optional parameter in `start_playback`
+  * Add `requests_timeout` parameter to authentication methods
+  * Make cache optional in `get_access_token`
+  * Support for `playlist_cover_image`
+  * Support `after` and `before` parameter in `current_user_recently_played`
+  * CI for unit tests
+  * Automatic `token` refresh
+  * `auth_manager` and `oauth_manager` optional parameters added to 
`Spotify`'s init.
+  * Optional `username` parameter to be passed to `SpotifyOAuth`, to infer a 
`cache_path` automatically
+  * Optional `as_dict` parameter to control `SpotifyOAuth`'s 
`get_access_token` output type. However, this is going to be deprecated in the 
future, and the method will always return a token string
+  * Optional `show_dialog` parameter to be passed to `SpotifyOAuth`
+  * Both `SpotifyClientCredentials` and `SpotifyOAuth` inherit from a common 
`SpotifyAuthBase` which handles common parameters and logics.
+  * Support for `playlist_tracks`
+  * Support for `playlist_upload_cover_image`
+  * `user_playlist_tracks` doesn't require a user anymore (accepts `None`)
+  * Deprecated `user_playlist` and `user_playlist_tracks`
+  * Fixed broken examples in README, examples and doc
+  * Allow session keepalive
+  * Bump requests to 2.20.0
+  * Fixed inconsistent behaviour with some API methods when
+   a full HTTP URL is passed.
+  * Fixed invalid calls to logging warn method
+  * Support for `playlist` to get a playlist without specifying a user
+  * Support for `current_user_saved_albums_delete`
+  * Support for `current_user_saved_albums_contains`
+  * Support for `user_unfollow_artists`
+  * Support for `user_unfollow_users`
+  * Added follow and player endpoints
+
+---

Old:

  spotipy-2.4.4.tar.gz

New:

  2.9.0.tar.gz



Other differences:
--
++ python-spotipy.spec ++
--- /var/tmp/diff_new_pack.YinZO7/_old  2020-03-18 12:45:37.048963220 +0100
+++ /var/tmp/diff_new_pack.YinZO7/_new  2020-03-18 12:45:37.052963223 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-spotipy
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,23 +18,27 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-spotipy
-Version:2.4.4
+Version:2.9.0
 Release:0
 Summary:Client for the Spotify Web API
 License:MIT
 Group:  Development/Languages/Python
-Url:http://spotipy.readthedocs.org/
-Source: 
https://files.pythonhosted.org/packages/source/s/spotipy/spotipy-%{version}.tar.gz
+URL:https://spotipy.readthedocs.org/
+# https://github.com/plamere/spotipy/issues/454
+Source: https://github.com/plamere/spotipy/archive/%{version}.tar.gz
 BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module setuptools}
-BuildRequires:  python-rpm-macros
-# SECTION test requirements
-BuildRequires:  %{python_module requests >= 1.0}
-# /SECTION
 BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-requests >= 1.0
+Requires:   python-six >= 1.10.0
 BuildArch:  noarch
-
+# SECTION test requirements
+BuildRequires:  %{python_module mock >= 2.0.0}
+BuildRequires:  %{python_module pytest}
+BuildRequires:  %{python_module requests >= 2.20.0}
+BuildRequires:  %{python_module six >= 1.10.0}
+# /SECTION
 %python_subpackages
 
 %description
@@ -55,9 +59,12 @@
 %python_install
 %python_expand %fdupes %{buildroot}%{$python_sitelib}
 
+%check
+%pytest tests/unit/
+
 %files %{python_files}
-%license LICENSE.txt
-%doc CHANGES.txt
+%license LICENSE.md
+%doc CHANGELOG.md
 %{python_sitelib}/*
 
 %changelog

++ spotipy-2.4.4.tar.gz -> 2.9.0.tar.gz ++
 6721 lines of diff (skipped)




commit python-ssdeep for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-ssdeep for openSUSE:Factory 
checked in at 2020-03-18 12:40:18

Comparing /work/SRC/openSUSE:Factory/python-ssdeep (Old)
 and  /work/SRC/openSUSE:Factory/.python-ssdeep.new.3160 (New)


Package is "python-ssdeep"

Wed Mar 18 12:40:18 2020 rev:2 rq:785940 version:3.4

Changes:

--- /work/SRC/openSUSE:Factory/python-ssdeep/python-ssdeep.changes  
2018-08-24 17:01:30.501886719 +0200
+++ /work/SRC/openSUSE:Factory/.python-ssdeep.new.3160/python-ssdeep.changes
2020-03-18 12:44:43.132929118 +0100
@@ -1,0 +2,11 @@
+Tue Mar 17 13:01:23 UTC 2020 - pgaj...@suse.com
+
+- version update to 3.4
+  * Update documentation
+  * Replace Jenkins and Travis CI with Drone CI
+  * Add new copy() function to Hash() and PseudoHash() class
+  * Add new attributes to Hash() and PseudoHash() class
+* name
+* block_size
+
+---

Old:

  python-ssdeep-3.3.tar.gz

New:

  python-ssdeep-3.4.tar.gz



Other differences:
--
++ python-ssdeep.spec ++
--- /var/tmp/diff_new_pack.Sq0r5H/_old  2020-03-18 12:44:44.616930056 +0100
+++ /var/tmp/diff_new_pack.Sq0r5H/_new  2020-03-18 12:44:44.620930058 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-ssdeep
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,34 +12,35 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
+#
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-ssdeep
-Version:3.3
+Version:3.4
 Release:0
-License:LGPL-3.0+
 Summary:Python wrapper for the ssdeep library
-Url:http://github.com/DinoTools/python-ssdeep
+License:LGPL-3.0-or-later
 Group:  Development/Languages/Python
+URL:https://github.com/DinoTools/python-ssdeep
 #Source: 
https://files.pythonhosted.org/packages/source/s/ssdeep/ssdeep-%%{version}.tar.gz
 # no docs here, see https://github.com/DinoTools/python-ssdeep/issues/37
 Source: 
https://github.com/DinoTools/python-ssdeep/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
-BuildRequires:  python-rpm-macros
+BuildRequires:  %{python_module cffi >= 0.8.6}
 BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module setuptools}
-BuildRequires:  %{python_module cffi >= 0.8.6}
+BuildRequires:  fdupes
+BuildRequires:  libfuzzy-devel
+BuildRequires:  python-rpm-macros
+Requires:   python-cffi
+Requires:   ssdeep
 # SECTION tests
 BuildRequires:  %{python_module pytest-runner}
 # /SECTION
 # SECTION docs
-BuildRequires:  python-sphinx
 BuildRequires:  python-mock
+BuildRequires:  python-sphinx
 # /SECTION
-BuildRequires:  libfuzzy-devel
-BuildRequires:  fdupes
-Requires:   ssdeep
-
 %python_subpackages
 
 %description
@@ -53,7 +54,7 @@
 %build
 %python_build
 pushd docs
-make html
+%make_build html
 rm build/html/.buildinfo
 popd
 

++ python-ssdeep-3.3.tar.gz -> python-ssdeep-3.4.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/python-ssdeep-3.3/.drone.yml 
new/python-ssdeep-3.4/.drone.yml
--- old/python-ssdeep-3.3/.drone.yml1970-01-01 01:00:00.0 +0100
+++ new/python-ssdeep-3.4/.drone.yml2019-10-03 21:17:12.0 +0200
@@ -0,0 +1,366 @@
+---
+### Python 2.7
+kind: pipeline
+name: Python 2.7
+
+steps:
+- name: test
+  image: registry.dinotools.org/docker-ci/python:2.7
+  commands:
+  - apt-get update
+  - apt-get install -y build-essential libffi-dev libfuzzy-dev
+  - . /opt/python/venv/bin/activate
+  - python --version
+  - pip install tox
+  - BUILD_LIB=0 tox --recreate -vvv -e py27
+
+---
+### Python 3.5
+kind: pipeline
+name: Python 3.5
+
+steps:
+- name: test
+  image: registry.dinotools.org/docker-ci/python:3.5
+  commands:
+  - apt-get update
+  - apt-get install -y build-essential libffi-dev libfuzzy-dev
+  - . /opt/python/venv/bin/activate
+  - python --version
+  - pip install tox
+  - BUILD_LIB=0 tox --recreate -vvv -e py35
+
+---
+### Python 3.6
+kind: pipeline
+name: Python 3.6
+
+steps:
+- name: test
+  image: registry.dinotools.org/docker-ci/python:3.6
+  commands:
+  - apt-get update
+  - apt-get install -y build-essential libffi-dev libfuzzy-dev
+  - . /opt/python/venv/bin/activate
+  - python --version
+  

commit python-stem for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-stem for openSUSE:Factory 
checked in at 2020-03-18 12:40:35

Comparing /work/SRC/openSUSE:Factory/python-stem (Old)
 and  /work/SRC/openSUSE:Factory/.python-stem.new.3160 (New)


Package is "python-stem"

Wed Mar 18 12:40:35 2020 rev:4 rq:785941 version:1.8.0

Changes:

--- /work/SRC/openSUSE:Factory/python-stem/python-stem.changes  2019-12-11 
12:14:49.488516598 +0100
+++ /work/SRC/openSUSE:Factory/.python-stem.new.3160/python-stem.changes
2020-03-18 12:44:56.084937310 +0100
@@ -1,0 +2,8 @@
+Tue Mar 17 12:55:55 UTC 2020 - pgaj...@suse.com
+
+- version update to 1.8.0
+  * many changes, see
+https://stem.torproject.org/change_log.html#version-1-8
+- Drop merged python38.patch
+
+---

Old:

  python38.patch
  stem-1.7.1.tar.gz

New:

  stem-1.8.0.tar.gz



Other differences:
--
++ python-stem.spec ++
--- /var/tmp/diff_new_pack.hr8r6z/_old  2020-03-18 12:45:02.220941191 +0100
+++ /var/tmp/diff_new_pack.hr8r6z/_new  2020-03-18 12:45:02.228941196 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-stem
 #
-# Copyright (c) 2019 SUSE LLC
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,17 +19,18 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define skip_python2 1
 Name:   python-stem
-Version:1.7.1
+Version:1.8.0
 Release:0
 Summary:Python controller library for Tor
 License:LGPL-3.0-only
 URL:https://stem.torproject.org/
 Source: 
https://files.pythonhosted.org/packages/source/s/stem/stem-%{version}.tar.gz
-Patch0: python38.patch
+BuildRequires:  %{python_module cryptography}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{pythons}
 BuildRequires:  fdupes
 Requires:   python
+Requires:   python-cryptography
 BuildArch:  noarch
 %python_subpackages
 
@@ -39,7 +40,6 @@
 
 %prep
 %setup -q -n stem-%{version}
-%patch0 -p1
 
 %build
 %python_build

++ stem-1.7.1.tar.gz -> stem-1.8.0.tar.gz ++
 19701 lines of diff (skipped)




commit python-Mathics for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-Mathics for openSUSE:Factory 
checked in at 2020-03-18 12:40:40

Comparing /work/SRC/openSUSE:Factory/python-Mathics (Old)
 and  /work/SRC/openSUSE:Factory/.python-Mathics.new.3160 (New)


Package is "python-Mathics"

Wed Mar 18 12:40:40 2020 rev:2 rq:785937 version:1.0

Changes:

--- /work/SRC/openSUSE:Factory/python-Mathics/python-Mathics.changes
2018-04-19 15:26:44.077802324 +0200
+++ /work/SRC/openSUSE:Factory/.python-Mathics.new.3160/python-Mathics.changes  
2020-03-18 12:45:08.248945004 +0100
@@ -1,0 +2,5 @@
+Sun Mar 15 07:58:36 UTC 2020 - Tomáš Chvátal 
+
+- Fix build without python2
+
+---



Other differences:
--
++ python-Mathics.spec ++
--- /var/tmp/diff_new_pack.Tn7pQU/_old  2020-03-18 12:45:10.968946724 +0100
+++ /var/tmp/diff_new_pack.Tn7pQU/_new  2020-03-18 12:45:10.992946740 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-Mathics
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,9 +12,10 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
+
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %define pyname Mathics
 Name:   python-Mathics
@@ -22,28 +23,26 @@
 Release:0
 Summary:A general-purpose computer algebra system
 # Mathics itself is licensed as GPL-3.0 but it includes third-party software 
with MIT, BSD-3-Clause, and Apache-2.0 Licensing; also includes data from 
wikipedia licensed under CC-BY-SA-3.0 and GFDL-1.3
-License:GPL-3.0 and BSD-3-Clause and MIT and Apache-2.0
-Group:  Development/Languages/Python
-Url:https://mathics.github.io/
+License:GPL-3.0-only AND BSD-3-Clause AND MIT AND Apache-2.0
+URL:https://mathics.github.io/
 Source: https://github.com/mathics/Mathics/archive/v%{version}.tar.gz
-BuildRequires:  fdupes
-BuildRequires:  python-rpm-macros
+BuildRequires:  %{python_module Django >= 1.8}
 BuildRequires:  %{python_module colorama}
 BuildRequires:  %{python_module devel}
-BuildRequires:  %{python_module Django >= 1.8}
 BuildRequires:  %{python_module mpmath >= 0.19}
+BuildRequires:  %{python_module numpy}
 BuildRequires:  %{python_module pexpect}
 BuildRequires:  %{python_module python-dateutil}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{python_module six >= 1.10}
 BuildRequires:  %{python_module sympy}
+BuildRequires:  fdupes
+BuildRequires:  python-rpm-macros
 Requires:   python-Django >= 1.8
 Requires:   python-mpmath >= 0.19
 Requires:   python-python-dateutil
 Requires:   python-six >= 1.10
 Requires:   python-sympy
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-
 %python_subpackages
 
 %description
@@ -51,6 +50,7 @@
 
 %prep
 %setup -q -n %{pyname}-%{version}
+%autopatch -p1
 
 # FIX SPURIOUS EXEC PERMISSIONS
 find ./mathics/web/media/js -name "*.js" -exec chmod -x '{}' \;
@@ -73,18 +73,17 @@
 
 %install
 %python_install
+%python_expand %fdupes %{buildroot}%{$python_sitelib}
 
-#FIXME: Errors with check
-#%%check
+%check
+# Tests fail with new sympy, probably worth fixing upstream
 #%%python_exec setup.py test
 
-%python_expand %fdupes %{buildroot}%{$python_sitelib}/
-
-%files %python_files
-%defattr(-,root,root)
-%doc README.rst COPYING.txt AUTHORS.txt
+%files %{python_files}
+%license COPYING.txt
+%doc README.rst AUTHORS.txt
 %{python_sitelib}/mathics/
-%{python_sitelib}/%{pyname}-%{version}-py%{py_ver}.egg-info/
+%{python_sitelib}/%{pyname}-%{version}-py%{python_version}.egg-info/
 %python3_only %{_bindir}/mathicsscript
 %python3_only %{_bindir}/mathicsserver
 %python3_only %{_bindir}/mathics




commit varnish for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package varnish for openSUSE:Factory checked 
in at 2020-03-18 12:39:49

Comparing /work/SRC/openSUSE:Factory/varnish (Old)
 and  /work/SRC/openSUSE:Factory/.varnish.new.3160 (New)


Package is "varnish"

Wed Mar 18 12:39:49 2020 rev:30 rq:785931 version:6.4.0

Changes:

--- /work/SRC/openSUSE:Factory/varnish/varnish.changes  2020-03-04 
09:39:52.80190 +0100
+++ /work/SRC/openSUSE:Factory/.varnish.new.3160/varnish.changes
2020-03-18 12:44:24.476917317 +0100
@@ -1,0 +2,12 @@
+Tue Mar 17 12:59:44 UTC 2020 - Jan Engelhardt 
+
+- Update to release 6.4.0
+  * The MAIN.sess_drop counter is gone.
+  * backend "none" was added for "no backend".
+  * The hash algorithm of the hash director was changed, so
+backend selection will change once only when upgrading.
+  * It is now possible for VMOD authors to customize the
+connection pooling of a dynamic backend.
+  * For more, see changes.rst.
+
+---

Old:

  varnish-6.3.2.tgz

New:

  varnish-6.4.0.tgz



Other differences:
--
++ varnish.spec ++
--- /var/tmp/diff_new_pack.jZU0mP/_old  2020-03-18 12:44:27.152919010 +0100
+++ /var/tmp/diff_new_pack.jZU0mP/_new  2020-03-18 12:44:27.152919010 +0100
@@ -26,7 +26,7 @@
 %define pkg_logdir   %_localstatedir/log/%name
 %define pkg_cachedir %_localstatedir/cache/%name
 Name:   varnish
-Version:6.3.2
+Version:6.4.0
 Release:0
 Summary:Accelerator for HTTP services
 License:BSD-2-Clause

++ varnish-6.3.2.tgz -> varnish-6.4.0.tgz ++
 91796 lines of diff (skipped)




commit python-strictyaml for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-strictyaml for 
openSUSE:Factory checked in at 2020-03-18 12:40:02

Comparing /work/SRC/openSUSE:Factory/python-strictyaml (Old)
 and  /work/SRC/openSUSE:Factory/.python-strictyaml.new.3160 (New)


Package is "python-strictyaml"

Wed Mar 18 12:40:02 2020 rev:4 rq:785938 version:1.0.6

Changes:

--- /work/SRC/openSUSE:Factory/python-strictyaml/python-strictyaml.changes  
2019-10-10 11:53:30.847310271 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-strictyaml.new.3160/python-strictyaml.changes
2020-03-18 12:44:31.528921778 +0100
@@ -1,0 +2,9 @@
+Tue Mar 17 12:35:33 UTC 2020 - pgaj...@suse.com
+
+- version update to 1.0.6
+  * BUGFIX : Fix accidental python 2 breakage.
+  * BUGFIX : Accidental misrecognition of boolean values as numbers - cause of 
#85.
+  * BUGFIX : Fix for #86 - handle changing multiline strings.
+  * BUGFIX: handle deprecated collections import in the parser (#82)
+
+---

Old:

  strictyaml-1.0.5.tar.gz

New:

  strictyaml-1.0.6.tar.gz



Other differences:
--
++ python-strictyaml.spec ++
--- /var/tmp/diff_new_pack.ghYchT/_old  2020-03-18 12:44:36.040924632 +0100
+++ /var/tmp/diff_new_pack.ghYchT/_new  2020-03-18 12:44:36.056924641 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-strictyaml
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,12 +18,12 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-strictyaml
-Version:1.0.5
+Version:1.0.6
 Release:0
 Summary:Strict, typed YAML parser
 License:MIT
 URL:https://hitchdev.com/strictyaml
-Source: 
https://github.com/crdoconnor/strictyaml/archive/%{version}.tar.gz#/strictyaml-%{version}.tar.gz
+Source: 
https://files.pythonhosted.org/packages/source/s/strictyaml/strictyaml-%{version}.tar.gz
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros

++ strictyaml-1.0.5.tar.gz -> strictyaml-1.0.6.tar.gz ++
 3368 lines of diff (skipped)




commit honggfuzz for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package honggfuzz for openSUSE:Factory 
checked in at 2020-03-18 12:39:40

Comparing /work/SRC/openSUSE:Factory/honggfuzz (Old)
 and  /work/SRC/openSUSE:Factory/.honggfuzz.new.3160 (New)


Package is "honggfuzz"

Wed Mar 18 12:39:40 2020 rev:8 rq:785933 version:2.1

Changes:

--- /work/SRC/openSUSE:Factory/honggfuzz/honggfuzz.changes  2018-03-09 
10:46:28.726931488 +0100
+++ /work/SRC/openSUSE:Factory/.honggfuzz.new.3160/honggfuzz.changes
2020-03-18 12:44:02.912903678 +0100
@@ -1,0 +2,18 @@
+Tue Mar 17 13:07:16 UTC 2020 - Martin Pluskal 
+
+- Update to version 2.1:
+  * string/int comparison enabled for targets built with *SAN, but
+w/o hfuzz-cc
+  * Parallel work made faster by using faster ATOMIC constructs
+(check first, then update)
+  * Implement --experimental_const_feedback - const string/integer
+feedback (used as an additional dictionary)
+  * Sanitizer report files are "better"-deleted (i.e. based on PID
+and not TID)
+  * New patches for fuzzing added (e.g. for bind-9.16.0/9.15.7)
+* Buffered output enabled in display.c
+* Some functions moved from per-arch arch.c to common subproc.c
+* Added suport for bfd/binutils-2.33
+  - And more from previous releases - see provided CHANGELOG
+
+---

Old:

  honggfuzz-1.5.tar.gz

New:

  honggfuzz-2.1.tar.gz



Other differences:
--
++ honggfuzz.spec ++
--- /var/tmp/diff_new_pack.SAp8eE/_old  2020-03-18 12:44:09.268907698 +0100
+++ /var/tmp/diff_new_pack.SAp8eE/_new  2020-03-18 12:44:09.300907718 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package honggfuzz
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,17 +12,17 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   honggfuzz
-Version:1.5
+Version:2.1
 Release:0
 Summary:Security-oriented fuzzer with various analysis options
 License:Apache-2.0
 Group:  Development/Tools/Other
-URL:http://honggfuzz.com
+URL:https://honggfuzz.com
 Source: 
https://github.com/google/honggfuzz/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
 BuildRequires:  binutils-devel
 BuildRequires:  libunwind-devel
@@ -38,7 +38,7 @@
 
 %build
 export CFLAGS="%{optflags}"
-make %{?_smp_mflags} ARCH_LDFLAGS="-L/usr/local/include -L/usr/include 
-lpthread -lunwind-ptrace -lunwind-generic -lbfd -lopcodes -lrt -liberty -lz 
-ldl"
+%make_build ARCH_LDFLAGS="-L/usr/local/include -L/usr/include -lpthread 
-lunwind-ptrace -lunwind-generic -lbfd -lopcodes -lrt -liberty -lz -ldl"
 
 %install
 install -Dpm 0755 %{name} \

++ honggfuzz-1.5.tar.gz -> honggfuzz-2.1.tar.gz ++
/work/SRC/openSUSE:Factory/honggfuzz/honggfuzz-1.5.tar.gz 
/work/SRC/openSUSE:Factory/.honggfuzz.new.3160/honggfuzz-2.1.tar.gz differ: 
char 12, line 1




commit perl-Convert-UUlib for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package perl-Convert-UUlib for 
openSUSE:Factory checked in at 2020-03-18 12:35:25

Comparing /work/SRC/openSUSE:Factory/perl-Convert-UUlib (Old)
 and  /work/SRC/openSUSE:Factory/.perl-Convert-UUlib.new.3160 (New)


Package is "perl-Convert-UUlib"

Wed Mar 18 12:35:25 2020 rev:31 rq:785919 version:1.71

Changes:

--- /work/SRC/openSUSE:Factory/perl-Convert-UUlib/perl-Convert-UUlib.changes
2020-03-05 23:18:17.153177386 +0100
+++ 
/work/SRC/openSUSE:Factory/.perl-Convert-UUlib.new.3160/perl-Convert-UUlib.changes
  2020-03-18 12:42:43.588853503 +0100
@@ -1,0 +2,9 @@
+Tue Mar 17 03:10:13 UTC 2020 -  
+
+- updated to 1.71
+   see /usr/share/doc/packages/perl-Convert-UUlib/Changes
+
+  1.71 Tue Mar 17 00:54:06 CET 2020
+   - backport to c89 (patch by Paul Howarth).
+
+---

Old:

  Convert-UUlib-1.7.tar.gz

New:

  Convert-UUlib-1.71.tar.gz



Other differences:
--
++ perl-Convert-UUlib.spec ++
--- /var/tmp/diff_new_pack.53jdRX/_old  2020-03-18 12:42:46.704855474 +0100
+++ /var/tmp/diff_new_pack.53jdRX/_new  2020-03-18 12:42:46.704855474 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   perl-Convert-UUlib
-Version:1.7
+Version:1.71
 Release:0
 #Upstream: CHECK(Artistic-1.0 or GPL-1.0-or-later)
 %define cpan_name Convert-UUlib

++ Convert-UUlib-1.7.tar.gz -> Convert-UUlib-1.71.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Convert-UUlib-1.7/Changes 
new/Convert-UUlib-1.71/Changes
--- old/Convert-UUlib-1.7/Changes   2020-02-29 22:08:37.0 +0100
+++ new/Convert-UUlib-1.71/Changes  2020-03-17 00:54:11.0 +0100
@@ -1,5 +1,8 @@
 Revision history for Perl extension Convert::UUlib.
 
+1.71 Tue Mar 17 00:54:06 CET 2020
+   - backport to c89 (patch by Paul Howarth).
+
 1.7  Sat Feb 29 22:07:54 CET 2020
- new function: GetFileList.
- experimental perlmulticore support (see manpage).
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Convert-UUlib-1.7/META.json 
new/Convert-UUlib-1.71/META.json
--- old/Convert-UUlib-1.7/META.json 2020-02-29 22:08:58.0 +0100
+++ new/Convert-UUlib-1.71/META.json2020-03-17 00:54:18.0 +0100
@@ -38,5 +38,5 @@
   }
},
"release_status" : "stable",
-   "version" : 1.7
+   "version" : 1.71
 }
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Convert-UUlib-1.7/META.yml 
new/Convert-UUlib-1.71/META.yml
--- old/Convert-UUlib-1.7/META.yml  2020-02-29 22:08:58.0 +0100
+++ new/Convert-UUlib-1.71/META.yml 2020-03-17 00:54:18.0 +0100
@@ -20,4 +20,4 @@
 - inc
 requires:
   common::sense: '3.74'
-version: 1.7
+version: 1.71
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Convert-UUlib-1.7/UUlib.pm 
new/Convert-UUlib-1.71/UUlib.pm
--- old/Convert-UUlib-1.7/UUlib.pm  2020-02-29 22:08:43.0 +0100
+++ new/Convert-UUlib-1.71/UUlib.pm 2020-03-17 00:54:15.0 +0100
@@ -7,7 +7,7 @@
 require Exporter;
 require DynaLoader;
 
-our $VERSION = 1.7;
+our $VERSION = 1.71;
 
 our @ISA = qw(Exporter DynaLoader);
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Convert-UUlib-1.7/UUlib.xs 
new/Convert-UUlib-1.71/UUlib.xs
--- old/Convert-UUlib-1.7/UUlib.xs  2020-02-28 18:32:52.0 +0100
+++ new/Convert-UUlib-1.71/UUlib.xs 2020-03-02 23:20:58.0 +0100
@@ -410,8 +410,12 @@
 void
 GetFileList ()
PPCODE:
-for (uulist *iter = UUGlobalFileList; iter; iter = iter->NEXT)
+{
+   uulist *iter;
+
+for (iter = UUGlobalFileList; iter; iter = iter->NEXT)
  XPUSHs (sv_setref_pv (sv_newmortal (), "Convert::UUlib::Item", iter));
+}
 
 MODULE = Convert::UUlibPACKAGE = Convert::UUlib::Item
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/Convert-UUlib-1.7/uulib/crc32.c 
new/Convert-UUlib-1.71/uulib/crc32.c
--- old/Convert-UUlib-1.7/uulib/crc32.c 2020-02-27 18:20:56.0 +0100
+++ new/Convert-UUlib-1.71/uulib/crc32.c2020-03-02 23:20:58.0 
+0100
@@ -689,6 +689,7 @@
 /* merge two CRC32 such that result = crc32(dataB, lengthB, crc32(dataA, 
lengthA)) */
 uint32_t uu_crc32_combine(uint32_t crcA, uint32_t crcB, size_t lengthB)
 {
+  int i;
   /*
* based on Mark Adler's crc_combine from
* https://github.com/madler/pigz/blob/master/pigz.c
@@ -730,26 +731,28 @@
 
   /* put operator for one zero bit in odd */
   odd[0] = Polynomial;
-  for (int i = 

commit python-unittest-xml-reporting for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-unittest-xml-reporting for 
openSUSE:Factory checked in at 2020-03-18 12:39:10

Comparing /work/SRC/openSUSE:Factory/python-unittest-xml-reporting (Old)
 and  /work/SRC/openSUSE:Factory/.python-unittest-xml-reporting.new.3160 
(New)


Package is "python-unittest-xml-reporting"

Wed Mar 18 12:39:10 2020 rev:19 rq:785932 version:3.0.2

Changes:

--- 
/work/SRC/openSUSE:Factory/python-unittest-xml-reporting/python-unittest-xml-reporting.changes
  2020-02-11 22:24:27.643536521 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-unittest-xml-reporting.new.3160/python-unittest-xml-reporting.changes
2020-03-18 12:43:42.168890556 +0100
@@ -1,0 +2,6 @@
+Tue Mar 10 12:56:35 UTC 2020 - pgaj...@suse.com
+
+- version update to 3.0.2
+  * no upstream changelog found
+
+---

Old:

  2.5.2.tar.gz

New:

  3.0.2.tar.gz



Other differences:
--
++ python-unittest-xml-reporting.spec ++
--- /var/tmp/diff_new_pack.92dXis/_old  2020-03-18 12:43:43.448891366 +0100
+++ /var/tmp/diff_new_pack.92dXis/_new  2020-03-18 12:43:43.448891366 +0100
@@ -17,8 +17,9 @@
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%define skip_python2 1
 Name:   python-unittest-xml-reporting
-Version:2.5.2
+Version:3.0.2
 Release:0
 Summary:PyUnit-based test runner with JUnit like XML reporting
 License:LGPL-3.0-or-later
@@ -33,9 +34,6 @@
 Requires:   python-six >= 1.4.0
 Provides:   python-xmlrunner = %{version}
 BuildArch:  noarch
-%ifpython2
-BuildRequires:  python2-mock
-%endif
 %python_subpackages
 
 %description

++ 2.5.2.tar.gz -> 3.0.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/unittest-xml-reporting-2.5.2/.travis.yml 
new/unittest-xml-reporting-3.0.2/.travis.yml
--- old/unittest-xml-reporting-2.5.2/.travis.yml2019-11-08 
06:47:00.0 +0100
+++ new/unittest-xml-reporting-3.0.2/.travis.yml2020-02-20 
03:44:01.0 +0100
@@ -4,14 +4,9 @@
 
 matrix:
   include:
-- python: 2.7
-  env: TOXENV=py27
-- python: 2.7
-  env: TOXENV=py27-djangolts
-- python: 2.7
-  env: TOXENV=py27-djangocurr
-- python: 2.7
-  env: TOXENV=quality
+- os: linux
+  python: pypy3.5-6.0
+  env: TOXENV=pypy3
 - python: 3.5
   env: TOXENV=py35
 - python: 3.6
@@ -20,20 +15,14 @@
   env: TOXENV=py37
 - python: 3.8
   env: TOXENV=py38
+- python: 3.8
+  env: TOXENV=py38-djangolts
+- python: 3.8
+  env: TOXENV=py38-djangocurr
+- python: 3.8
+  env: TOXENV=quality
 - python: 3.8-dev
   env: TOXENV=pytest
-- os: linux
-  dist: xenial
-  python: pypy2.7-6.0
-  env: TOXENV=pypy
-  services:
-- docker
-- os: linux
-  dist: xenial
-  python: pypy3.5-6.0
-  env: TOXENV=pypy3
-  services:
-- docker
 
 before_install:
   - python --version
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/unittest-xml-reporting-2.5.2/README.md 
new/unittest-xml-reporting-3.0.2/README.md
--- old/unittest-xml-reporting-2.5.2/README.md  2019-11-08 06:47:00.0 
+0100
+++ new/unittest-xml-reporting-3.0.2/README.md  2020-02-20 03:44:01.0 
+0100
@@ -14,33 +14,82 @@
 The files can be consumed by a wide range of tools, such as build systems, IDEs
 and continuous integration servers.
 
-## Schema
 
-There are many schemas with minor differences.
-We use one that is compatible with Jenkins xUnit plugin, a copy is
-available under `tests/vendor/jenkins/xunit-plugin/junit-10.xsd` (see attached 
license).
+## Requirements
+
+* Python 3.5+
+* Please note Python 2.7 end-of-life was in Jan 2020, last version supporting 
2.7 was 2.5.2
+* Please note Python 3.4 end-of-life was in Mar 2019, last version supporting 
3.4 was 2.5.2
+* Please note Python 2.6 end-of-life was in Oct 2013, last version supporting 
2.6 was 1.14.0
+
+
+## Limited support for `unittest.TestCase.subTest`
+
+https://docs.python.org/3/library/unittest.html#unittest.TestCase.subTest
+
+`unittest` has the concept of sub-tests for a `unittest.TestCase`; this 
doesn't map well to an existing xUnit concept, so you won't find it in the 
schema. What that means, is that you lose some granularity
+in the reports for sub-tests.
+
+`unittest` also does not report successful sub-tests, so the accounting won't 
be exact.
+
+## Jenkins plugins
+
+- Jenkins JUnit plugin : https://plugins.jenkins.io/junit/
+- Jenkins xUnit plugin : https://plugins.jenkins.io/xunit/
+
+### Jenkins JUnit plugin
+

commit hxtools for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package hxtools for openSUSE:Factory checked 
in at 2020-03-18 12:37:46

Comparing /work/SRC/openSUSE:Factory/hxtools (Old)
 and  /work/SRC/openSUSE:Factory/.hxtools.new.3160 (New)


Package is "hxtools"

Wed Mar 18 12:37:46 2020 rev:37 rq:785920 version:20200310

Changes:

--- /work/SRC/openSUSE:Factory/hxtools/hxtools.changes  2020-02-11 
22:26:22.731599572 +0100
+++ /work/SRC/openSUSE:Factory/.hxtools.new.3160/hxtools.changes
2020-03-18 12:43:22.408878058 +0100
@@ -1,0 +2,8 @@
+Tue Mar 10 12:15:27 UTC 2020 - Jan Engelhardt 
+
+- Update to release 20200310
+  * vfontas: add new N1 vectorizer
+  * vfontas: new -saven1 command to use N1
+  * vfontas: remove -xbrz scaler
+
+---

Old:

  hxtools-20200126.tar.asc
  hxtools-20200126.tar.xz

New:

  hxtools-20200310.tar.asc
  hxtools-20200310.tar.xz



Other differences:
--
++ hxtools.spec ++
--- /var/tmp/diff_new_pack.fC52pt/_old  2020-03-18 12:43:27.328881169 +0100
+++ /var/tmp/diff_new_pack.fC52pt/_new  2020-03-18 12:43:27.328881169 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   hxtools
-Version:20200126
+Version:20200310
 Release:0
 Summary:Collection of day-to-day tools (binaries)
 License:GPL-2.0+ and WTFPL
@@ -37,7 +37,6 @@
 BuildRequires:  pkgconfig(libpci) >= 3
 BuildRequires:  pkgconfig(mount) >= 2.20
 BuildRequires:  pkgconfig(xcb) >= 1
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires:   %name-scripts = %version
 Recommends: %name-man = %version
 Recommends: hardlink
@@ -51,12 +50,9 @@
 %description
 A collection of various tools. Some of the important ones:
 
-* declone(1) — break hardlinks
 * fd0ssh(1) — pipe for password-over-stdin support to ssh
 * ofl(1) — open file lister (replaces fuser and lsof -m)
 * tailhex(1) — hex dumper with tail-following support
-* utmp_register(1) — make entries in the utmp/wtmp database
-* vfontas(1) — Bitmap font transformation utility
 
 %package scripts
 Summary:Collection of day-to-day tools (scripts)
@@ -156,6 +152,16 @@
 lsof/fuser in that it can scan recursively and won't bluntly look at
 an entire mount.
 
+%package -n vfontas
+Summary:Bitmap font file transformation utility
+Group:  System/Console
+Provides:   hxtools:/usr/bin/vfontas
+
+%description -n vfontas
+vfontas (originally "VGA font file assembler") can transform raster
+font files in various ways - scaling, moving, row-filling, convert
+between formats (bdf/clt/pbm/psf/raw) and vector export to sfd/ttf.
+
 %prep
 %setup -q
 
@@ -169,7 +175,6 @@
 mv "$b/%_bindir"/extract_* "$b/%_libexecdir/%name/"
 mv "$b/%_bindir/rot13" "$b/%_libexecdir/%name/"
 install -dm0755 "$b/%_datadir/mc/syntax"
-install -pm0644 cooledit/*.syntax "$b/%_datadir/mc/syntax/"
 install -dm0755 "$b/%_sysconfdir/openldap/schema"
 ln -s "%_datadir/hxtools/rfc2307bis-utf8.schema" \
"$b/%_sysconfdir/openldap/schema/"
@@ -186,8 +191,7 @@
 %fdupes %buildroot/%_prefix
 
 %files
-%defattr(-,root,root)
-%doc LICENSE*
+%license LICENSE*
 %_bindir/bin2c
 %_bindir/bsvplay
 %_bindir/declone
@@ -198,7 +202,6 @@
 %_bindir/proc_stat_parse
 %_bindir/qplay
 %_bindir/tailhex
-%_bindir/vfontas
 %_bindir/xcp
 %dir %hldir
 %hldir/cctypeinfo
@@ -208,7 +211,6 @@
 %hldir/utmp_register
 
 %files scripts
-%defattr(-,root,root)
 %_bindir/aumeta
 %_bindir/checkbrack
 %_bindir/cwdiff
@@ -240,13 +242,13 @@
 %hldir/vcsaview
 
 %files man
-%defattr(-,root,root)
 %doc %_mandir/man*/*
 %exclude %_mandir/man*/fd0ssh.1*
 %exclude %_mandir/man*/ofl.1*
+%exclude %_mandir/man1/sysinfo.1*
+%exclude %_mandir/man*/vfontas.1*
 
 %files data
-%defattr(-,root,root)
 %dir %_sysconfdir/openldap
 %dir %_sysconfdir/openldap/schema
 %config %_sysconfdir/openldap/schema/*
@@ -257,7 +259,6 @@
 %if 0%{?build_profile}
 
 %files profile
-%defattr(-,root,root)
 %config %_sysconfdir/hxloginpref.conf
 %dir %_sysconfdir/bashrc.d
 %config %_sysconfdir/bashrc.d/*
@@ -265,13 +266,11 @@
 %endif
 
 %files -n fd0ssh
-%defattr(-,root,root)
 %dir %hldir
 %hldir/fd0ssh
 %_mandir/man1/fd0ssh.1*
 
 %files -n ofl
-%defattr(-,root,root)
 %_bindir/ofl
 %_mandir/man1/ofl.1*
 
@@ -279,10 +278,15 @@
 %defattr(-,root,root)
 %_bindir/pmap_dirty
 %_bindir/sysinfo
+%_mandir/man1/sysinfo.1*
 %dir %hldir
 %hldir/clock_info
 %hldir/hxnetload
 %hldir/paddrspacesize
 %hldir/proc_stat_signal_decode
 
+%files -n vfontas
+%_bindir/vfontas
+%_mandir/man1/vfontas.1*
+
 %changelog

++ hxtools-20200126.tar.xz -> hxtools-20200310.tar.xz ++
 4614 lines of diff (skipped)




commit python-structlog for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-structlog for 
openSUSE:Factory checked in at 2020-03-18 12:36:17

Comparing /work/SRC/openSUSE:Factory/python-structlog (Old)
 and  /work/SRC/openSUSE:Factory/.python-structlog.new.3160 (New)


Package is "python-structlog"

Wed Mar 18 12:36:17 2020 rev:3 rq:785923 version:20.1.0

Changes:

--- /work/SRC/openSUSE:Factory/python-structlog/python-structlog.changes
2019-10-17 12:22:55.983075386 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-structlog.new.3160/python-structlog.changes  
2020-03-18 12:43:04.384866657 +0100
@@ -1,0 +2,21 @@
+Tue Mar 17 11:33:05 UTC 2020 - pgaj...@suse.com
+
+- version update to 20.1.0
+  - This is the last version to support Python 2.7 (including PyPy) and 3.5.
+All following versions will only support Python 3.6 or later.
+  - Added a new module ``structlog.contextvars`` that allows to have a global 
but context-local ``structlog`` context the same way as with 
``structlog.threadlocal`` since 19.2.0.
+`#201 `_,
+`#236 `_
+  - Added a new module ``structlog.testing`` for first class testing support.
+The first entry is the context manager ``capture_logs()`` that allows to 
make assertions about structured log calls.
+`#14 `_,
+`#234 `_
+  - Added ``structlog.threadlocal.unbind_threadlocal()``.
+`#239 `_
+  - The logger created by ``structlog.get_logger()`` is not detected as an 
abstract method anymore, when attached to an abstract base class.
+`#229 `_
+  - ``colorama`` isn't initialized lazily on Windows anymore because it breaks 
rendering.
+`#232 `_,
+`#242 `_
+
+---

Old:

  19.2.0.tar.gz

New:

  20.1.0.tar.gz



Other differences:
--
++ python-structlog.spec ++
--- /var/tmp/diff_new_pack.bX781J/_old  2020-03-18 12:43:09.444869857 +0100
+++ /var/tmp/diff_new_pack.bX781J/_new  2020-03-18 12:43:09.448869861 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-structlog
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,10 @@
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
+# because of acyncio for tests
+%define skip_python2 1
 Name:   python-structlog
-Version:19.2.0
+Version:20.1.0
 Release:0
 Summary:Structured Logging for Python
 License:Apache-2.0 OR MIT
@@ -30,6 +32,8 @@
 BuildRequires:  %{python_module freezegun >= 0.2.8}
 BuildRequires:  %{python_module pretend}
 BuildRequires:  %{python_module pytest >= 3.3.0}
+BuildRequires:  %{python_module pytest-asyncio}
+BuildRequires:  %{python_module python-rapidjson}
 BuildRequires:  %{python_module setuptools}
 BuildRequires:  %{python_module simplejson}
 BuildRequires:  %{python_module six}
@@ -37,9 +41,6 @@
 BuildRequires:  python-rpm-macros
 Requires:   python-six
 BuildArch:  noarch
-%if %{python_version_nodots} >= 36
-BuildRequires:  python3-rapidjson
-%endif
 %python_subpackages
 
 %description

++ 19.2.0.tar.gz -> 20.1.0.tar.gz ++
 3546 lines of diff (skipped)




commit tensorflow for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package tensorflow for openSUSE:Factory 
checked in at 2020-03-18 12:33:04

Comparing /work/SRC/openSUSE:Factory/tensorflow (Old)
 and  /work/SRC/openSUSE:Factory/.tensorflow.new.3160 (New)


Package is "tensorflow"

Wed Mar 18 12:33:04 2020 rev:16 rq:785855 version:1.15.2

Changes:

--- /work/SRC/openSUSE:Factory/tensorflow/tensorflow.changes2020-03-01 
21:27:37.668509405 +0100
+++ /work/SRC/openSUSE:Factory/.tensorflow.new.3160/tensorflow.changes  
2020-03-18 12:42:29.572844638 +0100
@@ -1,0 +2,57 @@
+Mon Mar 16 15:00:51 UTC 2020 - Christian Goll 
+
+- fixed mpi and hpc builds, added file 
+  * fix-mpi-build.patch
+
+---
+Thu Mar 12 10:50:38 UTC 2020 - Christian Goll 
+
+- Fixed python3.8 build and logging with the the two patches
+  * Fix-build-failures-for-python-3.8.patch which fixes the build
+  * Fix-TensorFlow-on-Python-3.8-logger-issue.patch which fixes the logging
+
+---
+Wed Mar 11 10:12:39 UTC 2020 - Christian Goll 
+
+- updated to latest stable v1 version 1.15.2 which fixes 
+  CVE-2019-16778 (bsc#1159338)
+- Highlights of this version are:
+  * MKL-DNN contraction kernels on by default
+  * Fixes a security vulnerability where converting a Python string 
+to a tf.float16 value produces a segmentation fault (CVE-2020-5215)
+  see RELEASE.md for full changelog
+- updated following sources:
+  * tensorflow-1.15.2.tar.gz
+  * bazel-toolchains.tar.gz
+  * eigen.tar.gz
+  * gemmlowp.zip
+  * google-cloud-cpp.tar.gz
+  * license.rst.txt
+  * rules_closure.tar.gz
+- added following patches:
+ * removed-docker-tools.patch to remove docker build during package build
+ * right-json-location.patch to make syslibs point to json
+ * tensorflow-make_aws_sdk_work_on_aarch64.patch
+ * fix-lite.patch
+ * json-feature-name.patch
+- removed follwing sources
+ * abseil-pypi-v0.2.2.tar.gz
+ * aws-sdk-cpp-1.3.15.tar.gz
+ * boring_ssl.tar.gz
+ * double_conversion.zip
+ * fft.tgz
+ * flatbuffers_v1.9.0.tar.gz
+ * gast-0.2.0.tar.gz
+ * google-flatbuffers-1.10.0~pre.tar.gz
+ * google-nsync-1.20.1.tar.gz
+ * python-license.txt
+ * unicode-org-icu.tar.gz
+- removed following patches:
+ * fix_mvapich_mpi_bzl.patch
+ * grpc-namespace-corrections.patch
+ * remove-keras.patch
+ * tensorflow-fix_lite.patch
+ * support-new-bazel.patch
+
+
+---

Old:

  816a4ae622e964763ca0862d9dbd19324a1eaf45.tar.gz
  abseil-pypi-v0.2.2.tar.gz
  aws-sdk-cpp-1.3.15.tar.gz
  boring_ssl.tar.gz
  double_conversion.zip
  fft.tgz
  fix_mvapich_mpi_bzl.patch
  flatbuffers_v1.9.0.tar.gz
  gast-0.2.0.tar.gz
  google-flatbuffers-1.10.0~pre.tar.gz
  google-nsync-1.20.1.tar.gz
  grpc-namespace-corrections.patch
  json-cpp-1.8.4.tar.gz
  nsync_1.20.0.tar.gz
  python-license.txt
  remove-keras.patch
  support-new-bazel.patch
  tensorflow-1.13.2.tar.gz
  tensorflow-fix_lite.patch
  tensorflow-make_aws_sdk_work_on_aarch64.patch
  unicode-org-icu.tar.gz

New:

  Fix-TensorFlow-on-Python-3.8-logger-issue.patch
  Fix-build-failures-for-python-3.8.patch
  fft2d.tgz
  fix-lite.patch
  fix-mpi-build.patch
  functools32-3.2.3-2.tar.gz
  gast-0.2.2.tar.gz
  json-feature-name.patch
  kissfft.tar.gz
  llvm.tar.gz
  mkl-dnn.tar.gz
  pybind11-v2.3.0.tar.gz
  removed-docker-tools.patch
  right-json-location.patch
  tensorflow-1.15.2.tar.gz



Other differences:
--
++ tensorflow.spec ++
 636 lines (skipped)
 between /work/SRC/openSUSE:Factory/tensorflow/tensorflow.spec
 and /work/SRC/openSUSE:Factory/.tensorflow.new.3160/tensorflow.spec


++ Fix-TensorFlow-on-Python-3.8-logger-issue.patch ++
>From 0cdd66245dc10cdb255c55e617c1b2852579bd11 Mon Sep 17 00:00:00 2001
From: Yong Tang 
Date: Sun, 3 Nov 2019 19:52:04 +
Subject: [PATCH 3/3] Fix TensorFlow on Python 3.8 logger issue

This fix tries to address the issue raised in 33799
where running tensorflow on python 3.8 (Ubuntu 18.04)
raised the following error:
```
TypeError: _logger_find_caller() takes from 0 to 1 positional arguments but 2 
were given
```

The issue was that findCaller changed in Python 3.8

This PR fixes the issue.

This PR fixes 33799

Signed-off-by: Yong Tang 
---
 tensorflow/python/platform/tf_logging.py | 13 +++--
 1 file changed, 11 insertions(+), 2 deletions(-)

diff --git a/tensorflow/python/platform/tf_logging.py 
b/tensorflow/python/platform/tf_logging.py
index 86a4957c9d..a397393e7f 100644
--- a/tensorflow/python/platform/tf_logging.py
+++ b/tensorflow/python/platform/tf_logging.py
@@ -57,9 +57,18 @@ def _get_caller(offset=3):
 f = f.f_back
   return None, 

commit eclipse for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package eclipse for openSUSE:Factory checked 
in at 2020-03-18 12:30:41

Comparing /work/SRC/openSUSE:Factory/eclipse (Old)
 and  /work/SRC/openSUSE:Factory/.eclipse.new.3160 (New)


Package is "eclipse"

Wed Mar 18 12:30:41 2020 rev:6 rq:785650 version:4.9.0

Changes:

--- /work/SRC/openSUSE:Factory/eclipse/eclipse.changes  2019-12-16 
15:20:56.455124862 +0100
+++ /work/SRC/openSUSE:Factory/.eclipse.new.3160/eclipse.changes
2020-03-18 12:41:23.700802973 +0100
@@ -1,0 +2,6 @@
+Mon Mar 16 14:07:32 UTC 2020 - Fridrich Strba 
+
+- Fix sequence of building against bootstrap/non-bootstrap packages
+  in order to have a working eclipse (bsc#1166426)
+
+---



Other differences:
--
++ eclipse.spec ++
--- /var/tmp/diff_new_pack.rILqS6/_old  2020-03-18 12:41:28.584806062 +0100
+++ /var/tmp/diff_new_pack.rILqS6/_new  2020-03-18 12:41:28.588806064 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package eclipse
 #
-# Copyright (c) 2019 SUSE LLC
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -144,8 +144,6 @@
 BuildRequires:  cbi-plugins
 BuildRequires:  desktop-file-utils
 BuildRequires:  easymock
-BuildRequires:  eclipse-ecf-core >= 3.14.1
-BuildRequires:  eclipse-emf-core > 2.14.99
 BuildRequires:  eclipse-license2
 BuildRequires:  gcc
 BuildRequires:  glassfish-el > 3.0.0
@@ -221,18 +219,25 @@
 # Build deps that are excluded when bootstrapping
 %if %{without bootstrap}
 # For contributor tools
+BuildRequires:  eclipse-ecf-core >= 3.14.1
 BuildRequires:  eclipse-egit
+BuildRequires:  eclipse-emf-core > 2.14.99
 BuildRequires:  eclipse-emf-runtime
 BuildRequires:  eclipse-pde-bootstrap
 BuildRequires:  eclipse-platform-bootstrap
 BuildRequires:  jgit
 BuildRequires:  tycho
+#!BuildIgnore:  eclipse-ecf-core-bootstrap
+#!BuildIgnore:  eclipse-emf-core-bootstrap
 #!BuildIgnore:  eclipse-platform
 #!BuildIgnore:  jgit-bootstrap
 #!BuildIgnore:  tycho-bootstrap
 %else
+BuildRequires:  eclipse-ecf-core-bootstrap
+BuildRequires:  eclipse-emf-core-bootstrap
 BuildRequires:  jgit-bootstrap
 BuildRequires:  tycho-bootstrap
+#!BuildIgnore:  eclipse-ecf-core
 #!BuildIgnore:  eclipse-emf-core
 #!BuildIgnore:  jgit
 #!BuildIgnore:  tycho

++ eclipse-platform-sources-4.9-clean.tar.xz ++
/work/SRC/openSUSE:Factory/eclipse/eclipse-platform-sources-4.9-clean.tar.xz 
/work/SRC/openSUSE:Factory/.eclipse.new.3160/eclipse-platform-sources-4.9-clean.tar.xz
 differ: char 27, line 1




commit python-nodeenv for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-nodeenv for openSUSE:Factory 
checked in at 2020-03-18 12:29:50

Comparing /work/SRC/openSUSE:Factory/python-nodeenv (Old)
 and  /work/SRC/openSUSE:Factory/.python-nodeenv.new.3160 (New)


Package is "python-nodeenv"

Wed Mar 18 12:29:50 2020 rev:2 rq:785590 version:1.3.5

Changes:

--- /work/SRC/openSUSE:Factory/python-nodeenv/python-nodeenv.changes
2019-10-31 18:14:46.613980740 +0100
+++ /work/SRC/openSUSE:Factory/.python-nodeenv.new.3160/python-nodeenv.changes  
2020-03-18 12:40:47.664780178 +0100
@@ -1,0 +2,5 @@
+Mon Mar 16 10:52:58 UTC 2020 - Dirk Mueller 
+
+- update to 1.3.5
+
+---

Old:

  nodeenv-1.3.3.tar.gz

New:

  nodeenv-1.3.5.tar.gz



Other differences:
--
++ python-nodeenv.spec ++
--- /var/tmp/diff_new_pack.dGv02t/_old  2020-03-18 12:40:48.528780725 +0100
+++ /var/tmp/diff_new_pack.dGv02t/_new  2020-03-18 12:40:48.548780738 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-nodeenv
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-nodeenv
-Version:1.3.3
+Version:1.3.5
 Release:0
 Summary:Nodejs virtual environment builder
 License:BSD-2-Clause

++ nodeenv-1.3.3.tar.gz -> nodeenv-1.3.5.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/nodeenv-1.3.3/.coveragerc 
new/nodeenv-1.3.5/.coveragerc
--- old/nodeenv-1.3.3/.coveragerc   2018-11-06 13:58:49.0 +0100
+++ new/nodeenv-1.3.5/.coveragerc   2020-02-04 09:12:51.0 +0100
@@ -5,7 +5,6 @@
 omit =
 .tox/*
 /usr/*
-*/tmp*
 setup.py
 # Don't complain if non-runnable code isn't run
 */__main__.py
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/nodeenv-1.3.3/AUTHORS new/nodeenv-1.3.5/AUTHORS
--- old/nodeenv-1.3.3/AUTHORS   2018-11-06 13:58:49.0 +0100
+++ new/nodeenv-1.3.5/AUTHORS   2020-02-04 09:12:51.0 +0100
@@ -13,9 +13,9 @@
 -  Pierre Le Marre 
 -  Doug Turnbull 
 -  Anton Parkhomenko 
--  syndbg 
 -  Vyacheslav Levit 
 -  Travis Miller 
+-  syndbg 
 -  Spencer Rathbun 
 -  Luis Orduz 
 -  Lucas Cimon 
@@ -28,39 +28,45 @@
 -  Andrzej Pragacz 
 -  Alex Couper 
 -  0Xellos 
--  urbandove 
--  michael 
--  jiho 
--  dkgitdev 
--  dhilipsiva 
--  cmehay 
 -  Zenobius Jiricek 
 -  Yi-Feng Tzeng 
 -  Willem Jan Withagen 
+-  Walter dos Santos Filho 
 -  Vladimír Gorej 
 -  Vincent Bernat 
+-  urbandove 
 -  Uman Shahzad 
 -  Terseus 
 -  Stan Seibert 
 -  Shubhang Mani 
+-  sam 
 -  Rik 
+-  rachmadaniHaryono 
 -  Philipp Dieter 
 -  Mrinal Wadhwa 
 -  Michal Kolodziejski 
+-  michael 
 -  Max Liebkies 
 -  Marc-Antoine Parent 
 -  Marc Abramowitz 
 -  Laust Rud Jacobsen 
 -  Ken Struys 
 -  Kai Weber 
+-  Josh Soref 
+-  Joby Harding 
+-  jiho 
 -  Jesse Dhillon 
 -  Jeremy Banks 
 -  Geoffrey Huntley 
 -  Fabricio C Zuardi 
+-  dkgitdev 
+-  dhilipsiva 
 -  Dennis Flanigan 
 -  Dan North 
 -  Dan Fuchs 
 -  Damien Nozay 
+-  cmehay 
 -  Brian Jacobel 
 -  Ben Davis 
+-  Andreas Wirooks 
 -  Alexey Poryadin 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/nodeenv-1.3.3/CHANGES new/nodeenv-1.3.5/CHANGES
--- old/nodeenv-1.3.3/CHANGES   2018-11-06 13:58:49.0 +0100
+++ new/nodeenv-1.3.5/CHANGES   2020-02-04 09:12:51.0 +0100
@@ -3,47 +3,47 @@
 
 Version 1.3.1
 -
-- Windows related fix `#207 https://github.com/ekalinin/nodeenv/pull/207`
-- Fixed url for arm64 `#210 https://github.com/ekalinin/nodeenv/pull/210`_
-- Fixed fish support `#212 https://github.com/ekalinin/nodeenv/pull/212`_
+- Windows related fix `#207 `_
+- Fixed url for arm64 `#210 `_
+- Fixed fish support `#212 `_
 
 
 Version 1.3.0
 -
-- Fixed symlink creation `#189 https://github.com/ekalinin/nodeenv/issues/189`_
-- Python3.6 support `#200 https://github.com/ekalinin/nodeenv/pull/200`_
-- Added `activate` for fish `#201 
https://github.com/ekalinin/nodeenv/pull/201`_
-- Fixed cp866 `#202 https://github.com/ekalinin/nodeenv/pull/202`_
-- Added Conda support `#203 https://github.com/ekalinin/nodeenv/pull/203`_
+- Fixed symlink creation `#189 

commit eclipse-ecf for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package eclipse-ecf for openSUSE:Factory 
checked in at 2020-03-18 12:31:03

Comparing /work/SRC/openSUSE:Factory/eclipse-ecf (Old)
 and  /work/SRC/openSUSE:Factory/.eclipse-ecf.new.3160 (New)


Package is "eclipse-ecf"

Wed Mar 18 12:31:03 2020 rev:3 rq:785880 version:3.14.1

Changes:

--- /work/SRC/openSUSE:Factory/eclipse-ecf/eclipse-ecf.changes  2019-11-28 
13:50:38.334700120 +0100
+++ /work/SRC/openSUSE:Factory/.eclipse-ecf.new.3160/eclipse-ecf.changes
2020-03-18 12:41:31.812808104 +0100
@@ -1,0 +2,6 @@
+Thu Mar 12 12:19:57 UTC 2020 - Fridrich Strba 
+
+- Change the way the bootstrap/non-bootstrap packages are built in
+  order to have a working eclipse as a final product (bsc#1166426)
+
+---



Other differences:
--
++ eclipse-ecf.spec ++
--- /var/tmp/diff_new_pack.qYh3X3/_old  2020-03-18 12:41:32.768808708 +0100
+++ /var/tmp/diff_new_pack.qYh3X3/_new  2020-03-18 12:41:32.772808710 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package eclipse-ecf
 #
-# Copyright (c) 2019 SUSE LLC
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -58,7 +58,7 @@
 Name:   eclipse-ecf
 %endif
 %if %{without bootstrap}
-BuildRequires:  eclipse-ecf-core
+BuildRequires:  eclipse-ecf-core-bootstrap
 BuildRequires:  eclipse-emf-core
 BuildRequires:  eclipse-emf-runtime
 BuildRequires:  eclipse-pde-bootstrap
@@ -86,18 +86,24 @@
 compliant implementation of the OSGi Remote Services standard.
 
 %if %{with bootstrap}
-
-%package -n eclipse-ecf-core
+%package   -n eclipse-ecf-core-bootstrap
+%else
+%package   core
+Obsoletes:  eclipse-ecf-core-bootstrap
+%endif
 Summary:Eclipse ECF Core
 Group:  Development/Libraries/Java
 Requires:   httpcomponents-client
 Requires:   httpcomponents-core
 
-%description -n eclipse-ecf-core
-ECF bundles required by eclipse-platform.
-
+%if %{with bootstrap}
+%description -n eclipse-ecf-core-bootstrap
 %else
+%description core
+%endif
+ECF bundles required by eclipse-platform.
 
+%if %{without bootstrap}
 %package runtime
 Summary:Eclipse Communication Framework (ECF) Eclipse plug-in
 Group:  Development/Libraries/Java
@@ -116,7 +122,6 @@
 %description sdk
 Documentation and developer resources for the Eclipse Communication Framework
 (ECF) plug-in.
-
 %endif
 
 %prep
@@ -210,21 +215,6 @@
 
providers/bundles/org.eclipse.ecf.provider.filetransfer.httpclient4.ssl
 providers/bundles/org.eclipse.ecf.provider.filetransfer.ssl
 "
-%else
-%pom_disable_module releng/features/org.eclipse.ecf.core.feature
-%pom_disable_module releng/features/org.eclipse.ecf.core.ssl.feature
-%pom_disable_module releng/features/org.eclipse.ecf.filetransfer.feature
-%pom_disable_module 
releng/features/org.eclipse.ecf.filetransfer.httpclient4.feature
-%pom_disable_module 
releng/features/org.eclipse.ecf.filetransfer.httpclient4.ssl.feature
-%pom_disable_module releng/features/org.eclipse.ecf.filetransfer.ssl.feature
-%pom_disable_module framework/bundles/org.eclipse.ecf
-%pom_disable_module framework/bundles/org.eclipse.ecf.identity
-%pom_disable_module framework/bundles/org.eclipse.ecf.filetransfer
-%pom_disable_module framework/bundles/org.eclipse.ecf.ssl
-%pom_disable_module providers/bundles/org.eclipse.ecf.provider.filetransfer
-%pom_disable_module 
providers/bundles/org.eclipse.ecf.provider.filetransfer.httpclient4
-%pom_disable_module 
providers/bundles/org.eclipse.ecf.provider.filetransfer.httpclient4.ssl
-%pom_disable_module providers/bundles/org.eclipse.ecf.provider.filetransfer.ssl
 %endif
 
 # TODO: Figure out why this is necessary
@@ -260,7 +250,6 @@
 %install
 %mvn_install
 
-%if %{with bootstap}
 # Move to libdir due to being part of core platform
 install -d -m 755 %{buildroot}%{_eclipsedir}
 mv %{buildroot}%{_datadir}/eclipse/droplets/ecf/{plugins,features} 
%{buildroot}%{_eclipsedir}
@@ -271,7 +260,6 @@
 sed -i -e 
's|%{_datadir}/eclipse/droplets/ecf/features/|%{_eclipsedir}/features/|' \
-e 
's|%{_datadir}/eclipse/droplets/ecf/plugins/|%{_eclipsedir}/plugins/|' .mfiles
 sed -i -e '/droplets/d' .mfiles
-%endif
 
 # Remove any symlinks that might be created during bootstrapping due to 
missing platform bundles
 for del in $( (cd %{buildroot}%{_eclipsedir}/plugins && ls | grep -v -e 
'^org\.eclipse\.ecf' ) ) ; do
@@ -308,16 +296,16 @@
 %fdupes -s %{buildroot}
 
 %if %{with bootstrap}
-
-%files -n eclipse-ecf-core -f .mfiles
-%{_javadir}/eclipse
-
+%files -n eclipse-ecf-core-bootstrap -f .mfiles
 %else
+%files core -f .mfiles
+%endif

commit eclipse-emf for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package eclipse-emf for openSUSE:Factory 
checked in at 2020-03-18 12:32:08

Comparing /work/SRC/openSUSE:Factory/eclipse-emf (Old)
 and  /work/SRC/openSUSE:Factory/.eclipse-emf.new.3160 (New)


Package is "eclipse-emf"

Wed Mar 18 12:32:08 2020 rev:2 rq:785882 version:2.15.0~gitd1e5fdd

Changes:

--- /work/SRC/openSUSE:Factory/eclipse-emf/eclipse-emf.changes  2019-11-19 
13:43:50.916430026 +0100
+++ /work/SRC/openSUSE:Factory/.eclipse-emf.new.3160/eclipse-emf.changes
2020-03-18 12:41:35.788810618 +0100
@@ -1,0 +2,6 @@
+Mon Mar 16 13:55:11 UTC 2020 - Fridrich Strba 
+
+- Change the way the bootstrap/non-bootstrap packages are built in
+  order to have a working eclipse as a final product (bsc#1166426)
+
+---



Other differences:
--
++ eclipse-emf.spec ++
--- /var/tmp/diff_new_pack.jgnYcb/_old  2020-03-18 12:41:37.532811721 +0100
+++ /var/tmp/diff_new_pack.jgnYcb/_new  2020-03-18 12:41:37.532811721 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package eclipse-emf
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -33,7 +33,7 @@
 URL:https://www.eclipse.org/modeling/emf/
 Source0:
http://git.eclipse.org/c/emf/org.eclipse.emf.git/snapshot/org.eclipse.emf-%{emf_tag}.tar.xz
 Source1:
http://git.eclipse.org/c/xsd/org.eclipse.xsd.git/snapshot/org.eclipse.xsd-%{xsd_tag}.tar.xz
-# Avoid hard build-time dep on nebula (not in Fedora)
+# Avoid hard build-time dep on nebula
 Patch0: remove-nebula-dep.patch
 # Remove test that requires internet connection
 Patch1: remove-network-tests.patch
@@ -41,6 +41,7 @@
 Patch2: remove-timezone-test.patch
 # Remove unnecessary imports of JRE packages that are supplied by the system 
bundle
 Patch3: remove-unnecessary-imports.patch
+BuildRequires:  fdupes
 BuildRequires:  tycho-extras
 BuildRequires:  xz
 BuildConflicts: java-devel >= 9
@@ -49,11 +50,9 @@
 %else
 Name:   eclipse-emf
 %endif
-BuildRequires:  fdupes
 %if %{without bootstrap}
-BuildRequires:  eclipse-ecf-core
-BuildRequires:  eclipse-emf-core
-BuildRequires:  eclipse-emf-core-sdk
+BuildRequires:  eclipse-ecf-core-bootstrap
+BuildRequires:  eclipse-emf-core-bootstrap
 BuildRequires:  eclipse-pde-bootstrap
 BuildRequires:  eclipse-platform-bootstrap
 BuildRequires:  jgit-bootstrap
@@ -73,25 +72,22 @@
 The Eclipse Modeling Framework (EMF) and XML Schema Definition (XSD) plug-ins.
 
 %if %{with bootstrap}
-
-%package   -n eclipse-emf-core
+%package   -n eclipse-emf-core-bootstrap
+%else
+%package   core
+Obsoletes:  eclipse-emf-core-bootstrap
+%endif
 Summary:Eclipse EMF Core Bundles
 Group:  Development/Libraries/Java
 
-%description -n eclipse-emf-core
-Core EMF bundles required by the Eclipse platform.
-
-%package   -n eclipse-emf-core-sdk
-Summary:Eclipse EMF Core Bundles (Sources and source features)
-Group:  Development/Libraries/Java
-BuildArch:  noarch
-
-%description -n eclipse-emf-core-sdk
-Core EMF bundles required by the Eclipse platform.
-This package contains the corresponding sources and source features
-
+%if %{with bootstrap}
+%description -n eclipse-emf-core-bootstrap
 %else
+%description core
+%endif
+Core EMF bundles required by the Eclipse platform.
 
+%if %{without bootstrap}
 %package   runtime
 Summary:Eclipse Modeling Framework (EMF) Eclipse plug-in
 Group:  Development/Libraries/Java
@@ -119,12 +115,12 @@
 %package   sdk
 Summary:Eclipse EMF and XSD SDK
 Group:  Development/Libraries/Java
+Obsoletes:  %{name}-core-sdk
 BuildArch:  noarch
 
 %description sdk
 Documentation and developer resources for the Eclipse Modeling Framework
 (EMF) plug-in and XML Schema Definition (XSD) plug-in.
-
 %endif
 
 %prep
@@ -183,14 +179,6 @@
 ../../../plugins/org.eclipse.emf.ecore.xmi
 ../../../plugins/org.eclipse.emf.ecore
 " releng/org.eclipse.emf.parent/plugins
-%else
-%pom_disable_module ../../../features/org.eclipse.emf.base-feature 
releng/org.eclipse.emf.parent/features
-%pom_disable_module ../../../features/org.eclipse.emf.common-feature 
releng/org.eclipse.emf.parent/features
-%pom_disable_module ../../../features/org.eclipse.emf.ecore-feature 
releng/org.eclipse.emf.parent/features
-%pom_disable_module ../../../plugins/org.eclipse.emf.common 
releng/org.eclipse.emf.parent/plugins
-%pom_disable_module ../../../plugins/org.eclipse.emf.ecore.change 
releng/org.eclipse.emf.parent/plugins

commit tycho for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package tycho for openSUSE:Factory checked 
in at 2020-03-18 12:30:27

Comparing /work/SRC/openSUSE:Factory/tycho (Old)
 and  /work/SRC/openSUSE:Factory/.tycho.new.3160 (New)


Package is "tycho"

Wed Mar 18 12:30:27 2020 rev:2 rq:785646 version:1.2.0

Changes:

--- /work/SRC/openSUSE:Factory/tycho/tycho.changes  2019-11-19 
13:43:45.084432905 +0100
+++ /work/SRC/openSUSE:Factory/.tycho.new.3160/tycho.changes2020-03-18 
12:40:55.084784872 +0100
@@ -1,0 +2,5 @@
+Mon Mar 16 14:00:25 UTC 2020 - Fridrich Strba 
+
+- Build against the right bootstrap packages to avoid cycles
+
+---



Other differences:
--
++ tycho.spec ++
--- /var/tmp/diff_new_pack.98WPOA/_old  2020-03-18 12:40:58.252786875 +0100
+++ /var/tmp/diff_new_pack.98WPOA/_new  2020-03-18 12:40:58.268786886 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package tycho
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -141,6 +141,8 @@
 BuildRequires:  eclipse-platform-bootstrap >= 4.8.0
 Requires:   eclipse-platform >= 4.8.0
 Obsoletes:  %{name}-bootstrap
+#!BuildRequires: eclipse-emf-core-bootstrap
+#!BuildRequires: eclipse-ecf-core-bootstrap
 %else
 # For bootstrapping, we just need the dependencies of the Eclipse bundles we 
use
 BuildRequires:  osgi(com.ibm.icu)




commit python-zict for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-zict for openSUSE:Factory 
checked in at 2020-03-18 12:30:15

Comparing /work/SRC/openSUSE:Factory/python-zict (Old)
 and  /work/SRC/openSUSE:Factory/.python-zict.new.3160 (New)


Package is "python-zict"

Wed Mar 18 12:30:15 2020 rev:6 rq:785598 version:2.0.0

Changes:

--- /work/SRC/openSUSE:Factory/python-zict/python-zict.changes  2019-07-22 
17:19:17.281915586 +0200
+++ /work/SRC/openSUSE:Factory/.python-zict.new.3160/python-zict.changes
2020-03-18 12:40:51.416782551 +0100
@@ -1,0 +2,12 @@
+Mon Mar  9 10:51:00 UTC 2020 - pgaj...@suse.com
+
+- version update to 2.0.0
+  * Create CONTRIBUTING.md (:pr:`28`) Jacob Tomlinson
+  * Import ABC from collections.abc instead of collections for Python 3.9 
compatibility (:pr:`31`) Karthikeyan Singaravelan
+  * Drop Python 2 / 3.5 and add Python 3.7 / 3.8 support (:pr:`34`) James 
Bourbeau
+  * Duplicate keys fast slow (:pr:`32`) fjetter
+  * Fix dask cuda worker's race condition failure (:pr:`33`) Pradipta Ghosh
+  * Changed default lmdb encoding to utf-8 (:pr:`36`) Alex Davies
+  * Add code linting and style check (:pr:`35`) James Bourbeau
+
+---

Old:

  zict-1.0.0.tar.gz

New:

  zict-2.0.0.tar.gz



Other differences:
--
++ python-zict.spec ++
--- /var/tmp/diff_new_pack.QjquuF/_old  2020-03-18 12:40:53.080783605 +0100
+++ /var/tmp/diff_new_pack.QjquuF/_new  2020-03-18 12:40:53.084783607 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-zict
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,9 @@
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%define skip_python2 1
 Name:   python-zict
-Version:1.0.0
+Version:2.0.0
 Release:0
 Summary:Mutable mapping tools
 License:BSD-3-Clause

++ zict-1.0.0.tar.gz -> zict-2.0.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zict-1.0.0/PKG-INFO new/zict-2.0.0/PKG-INFO
--- old/zict-1.0.0/PKG-INFO 2019-06-25 08:58:10.0 +0200
+++ new/zict-2.0.0/PKG-INFO 2020-02-28 16:22:17.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.2
 Name: zict
-Version: 1.0.0
+Version: 2.0.0
 Summary: Mutable mapping tools
 Home-page: http://zict.readthedocs.io/en/latest/
 Maintainer: Matthew Rocklin
@@ -19,3 +19,7 @@
 
 Keywords: mutable mapping,dict,dask
 Platform: UNKNOWN
+Classifier: Programming Language :: Python
+Classifier: Programming Language :: Python :: 3.6
+Classifier: Programming Language :: Python :: 3.7
+Classifier: Programming Language :: Python :: 3.8
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zict-1.0.0/setup.cfg new/zict-2.0.0/setup.cfg
--- old/zict-1.0.0/setup.cfg2019-06-25 08:58:10.0 +0200
+++ new/zict-2.0.0/setup.cfg2020-02-28 16:22:17.0 +0100
@@ -1,3 +1,13 @@
+[flake8]
+exclude = __init__.py
+max-line-length = 120
+ignore = 
+   E731,   # Assigning lambda expression
+   E741# Ambiguous variable names
+
+[tool:pytest]
+addopts = -v --doctest-modules
+
 [egg_info]
 tag_build = 
 tag_date = 0
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zict-1.0.0/setup.py new/zict-2.0.0/setup.py
--- old/zict-1.0.0/setup.py 2019-06-25 08:56:50.0 +0200
+++ new/zict-2.0.0/setup.py 2020-02-28 16:20:44.0 +0100
@@ -4,7 +4,7 @@
 from setuptools import setup
 
 setup(name='zict',
-  version='1.0.0',
+  version='2.0.0',
   description='Mutable mapping tools',
   url='http://zict.readthedocs.io/en/latest/',
   maintainer='Matthew Rocklin',
@@ -15,4 +15,10 @@
   install_requires=open('requirements.txt').read().strip().split('\n'),
   long_description=(open('README.rst').read() if 
os.path.exists('README.rst')
 else ''),
+  classifiers=[
+  "Programming Language :: Python",
+  "Programming Language :: Python :: 3.6",
+  "Programming Language :: Python :: 3.7",
+  "Programming Language :: Python :: 3.8",
+  ],
   zip_safe=False)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zict-1.0.0/zict/__init__.py 
new/zict-2.0.0/zict/__init__.py
--- old/zict-1.0.0/zict/__init__.py 2019-06-25 08:56:58.0 +0200
+++ new/zict-2.0.0/zict/__init__.py 2020-02-28 16:20:44.0 +0100
@@ 

commit python-pip-licenses for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-pip-licenses for 
openSUSE:Factory checked in at 2020-03-18 12:28:43

Comparing /work/SRC/openSUSE:Factory/python-pip-licenses (Old)
 and  /work/SRC/openSUSE:Factory/.python-pip-licenses.new.3160 (New)


Package is "python-pip-licenses"

Wed Mar 18 12:28:43 2020 rev:2 rq:785586 version:2.1.1

Changes:

--- /work/SRC/openSUSE:Factory/python-pip-licenses/python-pip-licenses.changes  
2020-01-02 14:44:03.788976331 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-pip-licenses.new.3160/python-pip-licenses.changes
2020-03-18 12:40:35.268772338 +0100
@@ -1,0 +2,12 @@
+Mon Mar 16 10:17:11 UTC 2020 - Marketa Calabkova 
+
+- Update to 2.1.1
+  * Suppress errors when opening license files
+  * Implement new option --format=plain-vertical
+  * Support for outputting license file named COPYING *
+  * Better license file open handling in Python 3
+  * Dropped support Python 2.7
+  * Options like --format-* were marked obsolete
+  * Implement new option --no-license-path
+
+---

Old:

  pip-licenses-1.18.0.tar.gz

New:

  pip-licenses-2.1.1.tar.gz



Other differences:
--
++ python-pip-licenses.spec ++
--- /var/tmp/diff_new_pack.rkZmNG/_old  2020-03-18 12:40:37.356773659 +0100
+++ /var/tmp/diff_new_pack.rkZmNG/_new  2020-03-18 12:40:37.384773676 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-pip-licenses
 #
-# Copyright (c) 2019 SUSE LLC
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,9 @@
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%define skip_python2 1
 Name:   python-pip-licenses
-Version:1.18.0
+Version:2.1.1
 Release:0
 Summary:Python packages license list
 License:MIT

++ pip-licenses-1.18.0.tar.gz -> pip-licenses-2.1.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pip-licenses-1.18.0/CHANGELOG.md 
new/pip-licenses-2.1.1/CHANGELOG.md
--- old/pip-licenses-1.18.0/CHANGELOG.md2019-12-22 05:16:08.0 
+0100
+++ new/pip-licenses-2.1.1/CHANGELOG.md 2020-02-16 06:42:14.0 +0100
@@ -1,5 +1,31 @@
 ## CHANGELOG
 
+### 2.1.1
+
+* Suppress errors when opening license files
+
+### 2.1.0
+
+* Implement new option `--format=plain-vertical`
+* Support for outputting license file named `COPYING *`
+
+### 2.0.1
+
+* Better license file open handling in Python 3
+
+### 2.0.0
+
+* Dropped support Python 2.7
+* Breaking changes
+* Removed migration path to obsolete options
+* `--from-classifier`
+* `--format-markdown`
+* `--format-rst`
+* `--format-confluence`
+* `--format-html`
+* `--format-json`
+* Implement new option `--no-license-path`
+
 ### 1.18.0
 
 * Supports compatibility to work with either PTable or prettytable
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/pip-licenses-1.18.0/PKG-INFO 
new/pip-licenses-2.1.1/PKG-INFO
--- old/pip-licenses-1.18.0/PKG-INFO2019-12-22 05:33:46.0 +0100
+++ new/pip-licenses-2.1.1/PKG-INFO 2020-02-16 06:45:05.292676400 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: pip-licenses
-Version: 1.18.0
+Version: 2.1.1
 Summary: Dump the software license list of Python packages installed with pip.
 Home-page: https://github.com/raimon49/pip-licenses
 Author: raimon
@@ -9,7 +9,7 @@
 
 
 |Build Status| |PyPI - Python Version| |PyPI version| |GitHub Release|
-|Codecov| |BSD License| |Requirements Status|
+|Codecov| |GitHub contributors| |BSD License| |Requirements Status|
 
 Dump the software license list of Python packages installed with pip.
 
@@ -22,9 +22,6 @@
 -  `Command-Line Options <#command-line-options>`__
 
-  `Option: from <#option-from>`__
-
-  -  `Deprecated from-classifier <#deprecated-from-classifier>`__
-
-  `Option: with-system <#option-with-system>`__
-  `Option: with-authors <#option-with-authors>`__
-  `Option: with-urls <#option-with-urls>`__
@@ -41,7 +38,7 @@
   -  `JSON <#json>`__
   -  `JSON LicenseFinder <#json-licensefinder>`__
   -  `CSV <#csv>`__
-  -  `Deprecated options <#deprecated-options>`__
+  -  `Plain Vertical <#plain-vertical>`__
 
-  `Option: summary <#option-summary>`__
-  `Option: 

commit python-icalendar for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-icalendar for 
openSUSE:Factory checked in at 2020-03-18 12:27:54

Comparing /work/SRC/openSUSE:Factory/python-icalendar (Old)
 and  /work/SRC/openSUSE:Factory/.python-icalendar.new.3160 (New)


Package is "python-icalendar"

Wed Mar 18 12:27:54 2020 rev:26 rq:785585 version:4.0.4

Changes:

--- /work/SRC/openSUSE:Factory/python-icalendar/python-icalendar.changes
2019-08-22 10:56:03.653670186 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-icalendar.new.3160/python-icalendar.changes  
2020-03-18 12:40:18.308761611 +0100
@@ -1,0 +2,6 @@
+Mon Mar 16 10:46:58 UTC 2020 - Dirk Mueller 
+
+- update to 4.0.4:
+  - Reduce Hypothesis iterations to speed up testing, allowing PRs to pass
+
+---

Old:

  icalendar-4.0.3.tar.gz

New:

  icalendar-4.0.4.tar.gz



Other differences:
--
++ python-icalendar.spec ++
--- /var/tmp/diff_new_pack.FFhJqZ/_old  2020-03-18 12:40:21.076763362 +0100
+++ /var/tmp/diff_new_pack.FFhJqZ/_new  2020-03-18 12:40:21.080763364 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-icalendar
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 # Copyright (c) 2011 open-slx GmbH 
 # Copyright (c) 2009 - 7/2011 Sascha Manns 
 #
@@ -21,7 +21,7 @@
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 %definemodname icalendar
 Name:   python-%{modname}
-Version:4.0.3
+Version:4.0.4
 Release:0
 Summary:Python parser/generator of iCalendar files package
 License:BSD-2-Clause

++ icalendar-4.0.3.tar.gz -> icalendar-4.0.4.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/icalendar-4.0.3/CHANGES.rst 
new/icalendar-4.0.4/CHANGES.rst
--- old/icalendar-4.0.3/CHANGES.rst 2018-10-10 09:41:19.0 +0200
+++ new/icalendar-4.0.4/CHANGES.rst 2019-11-25 22:32:02.0 +0100
@@ -1,6 +1,15 @@
 Changelog
 =
 
+4.0.4 (2019-11-25)
+--
+
+Bug fixes:
+
+- Reduce Hypothesis iterations to speed up testing, allowing PRs to pass
+  [UniversalSuperBox]
+
+
 4.0.3 (2018-10-10)
 --
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/icalendar-4.0.3/PKG-INFO new/icalendar-4.0.4/PKG-INFO
--- old/icalendar-4.0.3/PKG-INFO2018-10-10 09:41:19.0 +0200
+++ new/icalendar-4.0.4/PKG-INFO2019-11-25 22:32:02.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: icalendar
-Version: 4.0.3
+Version: 4.0.4
 Summary: iCalendar parser/generator
 Home-page: https://github.com/collective/icalendar
 Author: Plone Foundation
@@ -69,6 +69,15 @@
 Changelog
 =
 
+4.0.4 (2019-11-25)
+--
+
+Bug fixes:
+
+- Reduce Hypothesis iterations to speed up testing, allowing PRs to 
pass
+  [UniversalSuperBox]
+
+
 4.0.3 (2018-10-10)
 --
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/icalendar-4.0.3/docs/credits.rst 
new/icalendar-4.0.4/docs/credits.rst
--- old/icalendar-4.0.3/docs/credits.rst2018-10-10 09:41:19.0 
+0200
+++ new/icalendar-4.0.4/docs/credits.rst2019-11-25 22:32:02.0 
+0100
@@ -54,6 +54,7 @@
 - TomTry 
 - Andreas Ruppen 
 - Clive Stevens 
+- Dalton Durst 
 
 Find out who contributed::
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/icalendar-4.0.3/src/icalendar/__init__.py 
new/icalendar-4.0.4/src/icalendar/__init__.py
--- old/icalendar-4.0.3/src/icalendar/__init__.py   2018-10-10 
09:41:19.0 +0200
+++ new/icalendar-4.0.4/src/icalendar/__init__.py   2019-11-25 
22:32:02.0 +0100
@@ -1,5 +1,5 @@
 # -*- coding: utf-8 -*-
-__version__ = '4.0.3'
+__version__ = '4.0.4'
 
 from icalendar.cal import (
 Calendar,
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/icalendar-4.0.3/src/icalendar/tests/hypothesis/test_fuzzing.py 
new/icalendar-4.0.4/src/icalendar/tests/hypothesis/test_fuzzing.py
--- old/icalendar-4.0.3/src/icalendar/tests/hypothesis/test_fuzzing.py  
2018-10-10 09:41:19.0 +0200
+++ new/icalendar-4.0.4/src/icalendar/tests/hypothesis/test_fuzzing.py  
2019-11-25 22:32:02.0 +0100
@@ -17,14 +17,13 @@
 key = st.text(string.ascii_letters + string.digits, min_size=1)
 value = printable_characters(blacklist_characters='\\;:\"')
 
-
 class TestFuzzing(unittest.TestCase):
 
 

commit python-oci-sdk for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-oci-sdk for openSUSE:Factory 
checked in at 2020-03-18 12:29:31

Comparing /work/SRC/openSUSE:Factory/python-oci-sdk (Old)
 and  /work/SRC/openSUSE:Factory/.python-oci-sdk.new.3160 (New)


Package is "python-oci-sdk"

Wed Mar 18 12:29:31 2020 rev:3 rq:785587 version:2.11.0

Changes:

--- /work/SRC/openSUSE:Factory/python-oci-sdk/python-oci-sdk.changes
2020-02-07 16:00:52.051710538 +0100
+++ /work/SRC/openSUSE:Factory/.python-oci-sdk.new.3160/python-oci-sdk.changes  
2020-03-18 12:40:39.512775023 +0100
@@ -1,0 +2,38 @@
+Mon Mar 16 10:41:25 UTC 2020 - John Paul Adrian Glaubitz 

+
+- Update to version 2.11.0
+  + Support for Events service integration with alerts in the Budgets service
+  + The parameters sort_by and lifecycle_state type from Budgets
+service are changed from str to enum
+- from version 2.10.7
+  + Support for updating the shape of a Database System in the Database service
+  + Support for generating CPE configurations for download in the Networking 
service
+  + Support for private IPs and fault domains of cluster nodes in the Container
+Engine for Kubernetes service
+  + Support for calling Oracle Cloud Infrastructure services in the 
ca-montreal-1 region
+  + Fixed missed parameter when invoking request signing for delegation token
+- from version 2.10.6
+  + Support for restarting autonomous databases in the Database service
+  + Support for private endpoints on autonomous databases in the Database 
service
+  + Support for IP-based policies in the Identity service
+  + Support for management of OAuth 2.0 client credentials in the Identity 
service
+  + Support for OCI Functions as a subscription protocol in the Notifications 
service
+- from version 2.10.5
+  + Support for the NoSQL Database service
+  + Support for filtering database versions by storage management
+type in the Database service
+  + Support for specifying paid listing types within pricing models
+in the Marketplace service
+  + Support for primary and non-primary instance types in the
+Content and Experience service
+- from version 2.10.4
+  + Support for listing supported database versions for Autonomous Database 
Serverless,
+and selecting a version at provisioning time in the Database service
+  + Support for TCP proxy protocol versions on listener connection
+configurations in the Load Balancer service
+  + Support for calling the Notifications service in alternate realms
+  + Support for calling Oracle Cloud Infrastructure services in the
+eu-amsterdam-1 and me-jeddah-1 regions
+- Update file list to fix Python imports for unvendoring
+
+---

Old:

  v2.10.3.tar.gz

New:

  v2.11.0.tar.gz



Other differences:
--
++ python-oci-sdk.spec ++
--- /var/tmp/diff_new_pack.GTY51V/_old  2020-03-18 12:40:41.092776022 +0100
+++ /var/tmp/diff_new_pack.GTY51V/_new  2020-03-18 12:40:41.092776022 +0100
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-oci-sdk
-Version:2.10.3
+Version:2.11.0
 Release:0
 Summary:Oracle Cloud Infrastructure Python SDK
 License:UPL-1.0 OR Apache-2.0
@@ -75,7 +75,7 @@
 rm -rf src/oci/_vendor/
 # Fix includes
 sed -i 's/from \._vendor //' src/oci/*.py
-sed -i 's/from oci._vendor //' src/oci/*.py src/oci/analytics/*.py 
src/oci/apigateway/*.py src/oci/application_migration/*.py 
src/oci/announcements_service/*.py src/oci/audit/*.py src/oci/auth/*.py 
src/oci/auth/signers/*.py src/oci/autoscaling/*.py src/oci/budget/*.py 
src/oci/container_engine/*.py src/oci/dns/*.py src/oci/core/*.py 
src/oci/database/*.py src/oci/data_catalog/*.py src/oci/data_flow/*.py 
src/oci/data_science/*.py src/oci/dts/*.py src/oci/email/*.py 
src/oci/events/*.py src/oci/file_storage/*.py src/oci/functions/*.py 
src/oci/healthchecks/*.py src/oci/integration/*.py src/oci/key_management/*.py 
src/oci/marketplace/*.py src/oci/limits/*.py src/oci/load_balancer/*.py 
src/oci/monitoring/*.py src/oci/oda/*.py src/oci/object_storage/*.py 
src/oci/oce/*.py src/oci/ons/*.py src/oci/object_storage/transfer/*.py 
src/oci/object_storage/transfer/internal/*.py src/oci/os_management/*.py 
src/oci/resource_manager/*.py src/oci/streaming/*.py src/oci/identity/*.py 
src/oci/resource_search/*.py src/oci/waas/*.py src/oci/work_requests/*.py 
tests/*.py
+sed -i 's/from oci._vendor //' src/oci/*.py src/oci/analytics/*.py 
src/oci/apigateway/*.py src/oci/application_migration/*.py 
src/oci/announcements_service/*.py src/oci/audit/*.py src/oci/auth/*.py 
src/oci/auth/signers/*.py src/oci/autoscaling/*.py src/oci/budget/*.py 

commit rpmlint-Factory for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package rpmlint-Factory for openSUSE:Factory 
checked in at 2020-03-18 12:25:58

Comparing /work/SRC/openSUSE:Factory/rpmlint-Factory (Old)
 and  /work/SRC/openSUSE:Factory/.rpmlint-Factory.new.3160 (New)


Package is "rpmlint-Factory"

Wed Mar 18 12:25:58 2020 rev:53 rq:784615 version:1.0

Changes:

--- /work/SRC/openSUSE:Factory/rpmlint-Factory/rpmlint-Factory.changes  
2020-02-09 21:01:17.815315403 +0100
+++ 
/work/SRC/openSUSE:Factory/.rpmlint-Factory.new.3160/rpmlint-Factory.changes
2020-03-18 12:39:42.372738880 +0100
@@ -1,0 +2,10 @@
+Thu Mar 12 12:57:19 UTC 2020 - matthias.gerst...@suse.com
+
+- Add also badness for unauthorized set*id bits on directories (bsc#1150189).
+
+---
+Tue Mar  3 09:25:51 UTC 2020 - matthias.gerst...@suse.com
+
+- Add badness for unauthorized or changed cron job files (bsc#1150175).
+
+---



Other differences:
--
++ config ++
--- /var/tmp/diff_new_pack.9g71Ss/_old  2020-03-18 12:39:44.208740041 +0100
+++ /var/tmp/diff_new_pack.9g71Ss/_new  2020-03-18 12:39:44.232740057 +0100
@@ -82,6 +82,7 @@
 setBadness('polkit-untracked-privilege', 10)
 setBadness('permissions-unauthorized-file', 10)
 setBadness('permissions-file-setuid-bit', 10)
+setBadness('permissions-directory-setuid-bit', 10)
 setBadness('permissions-world-writable', 10)
 setBadness('suse-filelist-forbidden', 1)
 setBadness('suse-filelist-forbidden-sysconfig', 1)
@@ -105,6 +106,9 @@
 setBadness('non-position-independent-executable', 1)
 setBadness('lto-bytecode', 1)
 setBadness('lto-no-text-in-archive', 1)
+setBadness('cronjob-unauthorized-file', 10)
+setBadness('cronjob-changed-file', 10)
+setBadness('cronjob-ghost-file', 10)
 
 setFilterException('suse-dbus-unauthorized-service')
 setFilterException('polkit-unauthorized-file')

++ config.strict ++
--- /var/tmp/diff_new_pack.9g71Ss/_old  2020-03-18 12:39:44.412740171 +0100
+++ /var/tmp/diff_new_pack.9g71Ss/_new  2020-03-18 12:39:44.428740181 +0100
@@ -32,6 +32,10 @@
 setBadness('polkit-untracked-privilege', 1)
 setBadness('permissions-unauthorized-file', 1)
 setBadness('permissions-file-setuid-bit', 1)
+setBadness('permissions-directory-setuid-bit', 1)
 setBadness('permissions-world-writable', 1)
 setBadness('suse-dbus-unauthorized-service', 1)
 setBadness('suse-pam-unauthorized-module', 1)
+setBadness('cronjob-unauthorized-file', 1)
+setBadness('cronjob-changed-file', 1)
+setBadness('cronjob-ghost-file', 1)




commit python-PyKMIP for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package python-PyKMIP for openSUSE:Factory 
checked in at 2020-03-18 12:27:07

Comparing /work/SRC/openSUSE:Factory/python-PyKMIP (Old)
 and  /work/SRC/openSUSE:Factory/.python-PyKMIP.new.3160 (New)


Package is "python-PyKMIP"

Wed Mar 18 12:27:07 2020 rev:3 rq:785582 version:0.10.0

Changes:

--- /work/SRC/openSUSE:Factory/python-PyKMIP/python-PyKMIP.changes  
2019-07-26 12:41:48.677869621 +0200
+++ /work/SRC/openSUSE:Factory/.python-PyKMIP.new.3160/python-PyKMIP.changes
2020-03-18 12:40:02.776751786 +0100
@@ -1,0 +2,24 @@
+Mon Mar 16 10:39:58 UTC 2020 - Dirk Mueller 
+
+- update to 0.10.0
+  * Add server debug logging for message encodings
+  * Add server Locate filtering for all currently supported attributes
+  * Add server Locate filtering using offset and maximum item constraints
+  * Add server cryptography engine support for AES GCM mode
+  * Add server support for the SplitKey object
+  * Add client/server support for the ApplicationSpecificInformation attribute
+  * Add client/server support for the ObjectGroup and Sensitive attributes
+  * Add client/server support for the DeleteAttribute operation
+  * Add client/server support for the SetAttribute operation
+  * Add client/server support for the ModifyAttribute operation
+  * Add a variety of unit and integration tests to cover all new functionality
+  * Add new ProxyKmipClient demo scripts to show how to use the new operations
+  * Add pending deprecation warnings for Python 2.7 and 3.4 due to their EOL
+  * Update server Locate filtering to return results sorted by creation date
+  * Update encoding support for SplitKey objects
+  * Update the Travis CI configuration to better support default Python 
versions
+  * Update library and testing dependencies to maintain Python 3.4 support
+  * Update the library documentation to reflect new features and security 
details
+  * Fix a bug with how key pair names are handled by the client for KMIP 2.0
+
+---

Old:

  PyKMIP-0.9.1.tar.gz

New:

  PyKMIP-0.10.0.tar.gz



Other differences:
--
++ python-PyKMIP.spec ++
--- /var/tmp/diff_new_pack.VAeho4/_old  2020-03-18 12:40:05.996753823 +0100
+++ /var/tmp/diff_new_pack.VAeho4/_new  2020-03-18 12:40:05.996753823 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-PyKMIP
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -18,7 +18,7 @@
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-PyKMIP
-Version:0.9.1
+Version:0.10.0
 Release:0
 Summary:KMIP v11 library
 License:Apache-2.0

++ PyKMIP-0.9.1.tar.gz -> PyKMIP-0.10.0.tar.gz ++
 21944 lines of diff (skipped)




commit tensorflow2 for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package tensorflow2 for openSUSE:Factory 
checked in at 2020-03-18 12:26:26

Comparing /work/SRC/openSUSE:Factory/tensorflow2 (Old)
 and  /work/SRC/openSUSE:Factory/.tensorflow2.new.3160 (New)


Package is "tensorflow2"

Wed Mar 18 12:26:26 2020 rev:4 rq:785546 version:2.1.0

Changes:

--- /work/SRC/openSUSE:Factory/tensorflow2/tensorflow2.changes  2020-03-11 
18:51:50.379580804 +0100
+++ /work/SRC/openSUSE:Factory/.tensorflow2.new.3160/tensorflow2.changes
2020-03-18 12:39:48.348742660 +0100
@@ -1,0 +2,8 @@
+Fri Mar 13 15:25:38 UTC 2020 - Christian Goll 
+
+- removed sources of bazel sources and replaced them by internal packages
+ * rules-cc.zip removed
+ * bazel-toolchains.tar.gz removed
+ * bazel-skylib.0.8.0.tar.gz removed
+
+---

Old:

  bazel-skylib.0.8.0.tar.gz
  bazel-toolchains.tar.gz
  rules_cc.zip



Other differences:
--
++ tensorflow2.spec ++
--- /var/tmp/diff_new_pack.iW7j2c/_old  2020-03-18 12:39:52.808745481 +0100
+++ /var/tmp/diff_new_pack.iW7j2c/_new  2020-03-18 12:39:52.812745484 +0100
@@ -151,18 +151,12 @@
 Source34:   
https://github.com/edenhill/librdkafka/archive/v0.11.5.tar.gz#/kafka-v0.11.5.tar.gz
 # License35: Apache-2.0
 Source35:   
https://github.com/GoogleCloudPlatform/google-cloud-cpp/archive/v0.4.0.tar.gz#/google-cloud-cpp.tar.gz
-# License36: Apache-2.0
-Source36:   
https://github.com/bazelbuild/bazel-toolchains/archive/92dd8a7a518a2fb7ba992d47c8b38299fe0be825.tar.gz#/bazel-toolchains.tar.gz
 # License37: Apache-2.0
 Source37:   
https://github.com/bazelbuild/rules_docker/archive/a9bb1dab84cdf46e34d1b34b53a17bda129b5eba.tar.gz#/rules_docker.tar.gz
 # License44: BSD like
 Source44:   
https://github.com/nanopb/nanopb/archive/f8ac463766281625ad710900479130c7fcb4d63b.tar.gz#/nanopb.tar.gz
 # License45: Python license itself, do need as sha256b have to match so could 
not use system one
 Source45:   
https://storage.googleapis.com/mirror.tensorflow.org/docs.python.org/2.7/_sources/license.rst.txt#/python-license.txt
-# License50: Apache-2.0
-Source50:   
https://github.com/bazelbuild/bazel-skylib/releases/download/0.8.0/bazel-skylib.0.8.0.tar.gz
-# License51: Apache-2.0
-Source51:   
https://github.com/bazelbuild/rules_cc/archive/0d5f3f2768c6ca2faca0079a997a97ce22997a0c.zip#/rules_cc.zip
 # License52:
 Source52:   
https://github.com/pybind/pybind11/archive/v2.3.0.tar.gz#/pybind11-v2.3.0.tar.gz
 # Deps sources for Tensorflow-Lite (use same eigen, gemmlowp and abseil_cpp 
packages as non lite version)
@@ -207,10 +201,11 @@
 %else
 Provides:   python3-tensorflow
 %endif
-%if !%{is_lite}
 Provides:   tensorflow
-%endif
 BuildRequires:  bazel = 0.29.1
+BuildRequires:  bazel-rules-cc-source
+BuildRequires:  bazel-skylib-source
+BuildRequires:  bazel-toolchains-source
 BuildRequires:  curl
 %if %{with cuda}
 BuildRequires:  cuda-compiler-10-1
@@ -434,12 +429,9 @@
 %makebazelcache %{SOURCE30}
 %makebazelcache %{SOURCE34}
 %makebazelcache %{SOURCE35}
-%makebazelcache %{SOURCE36}
 %makebazelcache %{SOURCE37}
 %makebazelcache %{SOURCE44}
 %makebazelcache %{SOURCE45}
-%makebazelcache %{SOURCE50}
-%makebazelcache %{SOURCE51}
 %makebazelcache %{SOURCE52}
 %makebazelcache %{SOURCE53}
 %makebazelcache %{SOURCE54}
@@ -596,18 +588,26 @@
 #  --repository_cache=%{bz_cachdir} \
 #  'attr(visibility, "//visibility:public", //tensorflow:*)'
 ./configure
-bazel build \
-  --repository_cache=%{bz_cachdir} \
-  --ignore_unsupported_sandboxing \
-   --verbose_failures \
-  --cxxopt="-D_GLIBCXX_USE_CXX11_ABI=1" \
-  --config=v2 \
-  --config=noaws \
-  --define=build_with_mkl_dnn_only=true \
-  --define=tensorflow_mkldnn_contraction_kernel=0 \
-  --incompatible_no_support_tools_in_action_inputs=false \
-   %{?copts} --jobs %{?jobs} \
-   //tensorflow/tools/pip_package:build_pip_package
+
+%define bazelopts \\\
+  -c opt \\\
+  --repository_cache=%{bz_cachdir} \\\
+  --ignore_unsupported_sandboxing \\\
+  --verbose_failures \\\
+  --cxxopt="-D_GLIBCXX_USE_CXX11_ABI=1" \\\
+  --config=v2 \\\
+  --config=noaws \\\
+  --define=build_with_mkl_dnn_only=true \\\
+  --define=tensorflow_mkldnn_contraction_kernel=0 \\\
+  --incompatible_no_support_tools_in_action_inputs=false \\\
+  --override_repository="rules_cc=/usr/src/bazel-rules-cc" \\\
+  --override_repository="bazel_skylib=/usr/src/bazel-skylib"\\\
+  --override_repository="rules_toolchains=/usr/src/bazel-rules-toolchains" \\\
+  %{?copts} \\\
+  --jobs %{?jobs} \\\
+%{nil}
+
+bazel build %{bazelopts} tensorflow/tools/pip_package:build_pip_package
 
 bazel-bin/tensorflow/tools/pip_package/build_pip_package 

commit libffi for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package libffi for openSUSE:Factory checked 
in at 2020-03-18 12:25:45

Comparing /work/SRC/openSUSE:Factory/libffi (Old)
 and  /work/SRC/openSUSE:Factory/.libffi.new.3160 (New)


Package is "libffi"

Wed Mar 18 12:25:45 2020 rev:9 rq:783284 version:3.3.git30

Changes:

--- /work/SRC/openSUSE:Factory/libffi/libffi.changes2019-10-17 
12:17:41.863863447 +0200
+++ /work/SRC/openSUSE:Factory/.libffi.new.3160/libffi.changes  2020-03-18 
12:39:11.348719257 +0100
@@ -1,0 +2,24 @@
+Tue Mar 10 09:57:24 UTC 2020 - Richard Biener 
+
+- Update to commit b844a9c7f1ca based on libffi 3.3 with the
+  following changes:
+
+Add RISC-V support.
+New API in support of GO closures.
+Add IEEE754 binary128 long double support for 64-bit Power
+Default to Microsoft's 64 bit long double ABI with Visual C++.
+GNU compiler uses 80 bits (128 in memory) FFI_GNUW64 ABI.
+Add Windows on ARM64 (WOA) support.
+Add Windows 32-bit ARM support.
+Raw java (gcj) API deprecated.
+Add pre-built PDF documentation to source distribution.
+Many new test cases and bug fixes.
+
+- SONAME change to libffi.so.8
+- stdcall.patch is now upstream
+- Adjust baselibs.conf for SONAME change
+- Adjust aarch64.patch for upstream changes
+- Drop gccbug.patch XFAILing testcases that now PASS with fixed
+  GCC 9.3
+
+---

Old:

  gccbug.patch
  libffi-3.2.1.git505.tar.xz
  stdcall.patch

New:

  libffi-3.3.git30.tar.xz



Other differences:
--
++ libffi.spec ++
--- /var/tmp/diff_new_pack.buJoFT/_old  2020-03-18 12:39:18.868724013 +0100
+++ /var/tmp/diff_new_pack.buJoFT/_new  2020-03-18 12:39:18.868724013 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package libffi
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,19 +16,17 @@
 #
 
 
-%define libffi_sover 7
+%define libffi_sover 8
 
 Name:   libffi
-Version:3.2.1.git505
+Version:3.3.git30
 Release:0
 Summary:Foreign Function Interface Library
 License:MIT
 Group:  Development/Languages/C and C++
-Url:https://github.com/libffi/
+URL:https://github.com/libffi/
 Source: %name-%version.tar.xz
 Source99:   baselibs.conf
-Patch1: gccbug.patch
-Patch2: stdcall.patch
 # Workaround from https://github.com/libffi/libffi/issues/498
 Patch3: aarch64.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -82,8 +80,6 @@
 
 %prep
 %setup -q
-%patch1 -p1
-%patch2 -p1
 %patch3 -p1
 
 %build

++ _service ++
--- /var/tmp/diff_new_pack.buJoFT/_old  2020-03-18 12:39:18.892724029 +0100
+++ /var/tmp/diff_new_pack.buJoFT/_new  2020-03-18 12:39:18.892724029 +0100
@@ -4,8 +4,8 @@
https://github.com/libffi/libffi
master
libffi
-   v3.2.1
-   3.2.1.git@TAG_OFFSET@
+   v3.3
+   3.3.git@TAG_OFFSET@


*.tar

++ aarch64.patch ++
--- /var/tmp/diff_new_pack.buJoFT/_old  2020-03-18 12:39:18.896724031 +0100
+++ /var/tmp/diff_new_pack.buJoFT/_new  2020-03-18 12:39:18.896724031 +0100
@@ -11,15 +11,4 @@
  #endif
  
closure->cif = cif;
-diff -purN libffi-3.2.1.git505.orig/src/closures.c 
libffi-3.2.1.git505/src/closures.c
 libffi-3.2.1.git505.orig/src/closures.c2019-08-07 20:57:45.0 
+0200
-+++ libffi-3.2.1.git505/src/closures.c 2019-10-11 08:43:59.265151289 +0200
-@@ -925,6 +925,8 @@ void *
- ffi_data_to_code_pointer (void *data)
- {
-   msegmentptr seg = segment_holding (gm, data);
-+  if (seg == NULL)
-+return NULL;
-   return add_segment_exec_offset (data, seg);
- }
- 
+

++ baselibs.conf ++
--- /var/tmp/diff_new_pack.buJoFT/_old  2020-03-18 12:39:18.908724039 +0100
+++ /var/tmp/diff_new_pack.buJoFT/_new  2020-03-18 12:39:18.912724041 +0100
@@ -1,3 +1,3 @@
-libffi7
+libffi8
 libffi-devel
-  requires "libffi7- = "
+  requires "libffi8- = "

++ libffi-3.2.1.git505.tar.xz -> libffi-3.3.git30.tar.xz ++
 39133 lines of diff (skipped)




commit gcc9 for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package gcc9 for openSUSE:Factory checked in 
at 2020-03-18 12:24:51

Comparing /work/SRC/openSUSE:Factory/gcc9 (Old)
 and  /work/SRC/openSUSE:Factory/.gcc9.new.3160 (New)


Package is "gcc9"

Wed Mar 18 12:24:51 2020 rev:13 rq:783281 version:9.2.1+git1192

Changes:

--- /work/SRC/openSUSE:Factory/gcc9/cross-aarch64-gcc9.changes  2020-03-04 
09:52:15.710318816 +0100
+++ /work/SRC/openSUSE:Factory/.gcc9.new.3160/cross-aarch64-gcc9.changes
2020-03-18 12:30:26.856387513 +0100
@@ -1,0 +2,12 @@
+Fri Mar  6 08:58:58 UTC 2020 - Richard Biener 
+
+- Update to releases/gcc-9 head (c5edde44f5b17b4891f17a63517f355b).
+  * Includes GCC 9.3.0 RC1
+
+---
+Mon Mar  2 08:33:11 UTC 2020 - Richard Biener 
+
+- Update to releases/gcc-9 head (eaaee438bf836c2c1ed3424ecbf85de3ed941e87).
+  * Includes fix for binutils version parsing [gcc#93965]
+
+---
cross-arm-gcc9.changes: same change
cross-arm-none-gcc9-bootstrap.changes: same change
cross-arm-none-gcc9.changes: same change
cross-avr-gcc9-bootstrap.changes: same change
cross-avr-gcc9.changes: same change
cross-epiphany-gcc9-bootstrap.changes: same change
cross-epiphany-gcc9.changes: same change
cross-hppa-gcc9.changes: same change
cross-i386-gcc9.changes: same change
cross-m68k-gcc9.changes: same change
cross-mips-gcc9.changes: same change
cross-nvptx-gcc9.changes: same change
cross-ppc64-gcc9.changes: same change
cross-ppc64le-gcc9.changes: same change
cross-riscv64-elf-gcc9-bootstrap.changes: same change
cross-riscv64-elf-gcc9.changes: same change
cross-riscv64-gcc9.changes: same change
cross-rx-gcc9-bootstrap.changes: same change
cross-rx-gcc9.changes: same change
cross-s390x-gcc9.changes: same change
cross-sparc-gcc9.changes: same change
cross-sparc64-gcc9.changes: same change
cross-x86_64-gcc9.changes: same change
gcc9-testresults.changes: same change
gcc9.changes: same change

Old:

  gcc-9.2.1+git1022.tar.xz

New:

  gcc-9.2.1+git1192.tar.xz



Other differences:
--
++ cross-aarch64-gcc9.spec ++
--- /var/tmp/diff_new_pack.OrowQb/_old  2020-03-18 12:37:07.812641118 +0100
+++ /var/tmp/diff_new_pack.OrowQb/_new  2020-03-18 12:37:07.816641120 +0100
@@ -114,7 +114,7 @@
 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
 
 URL:https://gcc.gnu.org/
-Version:9.2.1+git1022
+Version:9.2.1+git1192
 Release:0
 %define gcc_dir_version %(echo %version |  sed 's/+.*//' | cut -d '.' -f 1)
 %define gcc_snapshot_revision %(echo %version | sed 's/[3-9]\.[0-9]\.[0-6]//' 
| sed 's/+/-/')

cross-arm-gcc9.spec: same change
cross-arm-none-gcc9-bootstrap.spec: same change
cross-arm-none-gcc9.spec: same change
cross-avr-gcc9-bootstrap.spec: same change
cross-avr-gcc9.spec: same change
cross-epiphany-gcc9-bootstrap.spec: same change
cross-epiphany-gcc9.spec: same change
cross-hppa-gcc9.spec: same change
cross-i386-gcc9.spec: same change
cross-m68k-gcc9.spec: same change
cross-mips-gcc9.spec: same change
cross-nvptx-gcc9.spec: same change
cross-ppc64-gcc9.spec: same change
cross-ppc64le-gcc9.spec: same change
cross-riscv64-elf-gcc9-bootstrap.spec: same change
cross-riscv64-elf-gcc9.spec: same change
cross-riscv64-gcc9.spec: same change
cross-rx-gcc9-bootstrap.spec: same change
cross-rx-gcc9.spec: same change
cross-s390x-gcc9.spec: same change
cross-sparc-gcc9.spec: same change
cross-sparc64-gcc9.spec: same change
cross-x86_64-gcc9.spec: same change
gcc9-testresults.spec: same change
gcc9.spec: same change
++ gcc-9.2.1+git1022.tar.xz -> gcc-9.2.1+git1192.tar.xz ++
/work/SRC/openSUSE:Factory/gcc9/gcc-9.2.1+git1022.tar.xz 
/work/SRC/openSUSE:Factory/.gcc9.new.3160/gcc-9.2.1+git1192.tar.xz differ: char 
26, line 1

++ gcc.spec.in ++
--- /var/tmp/diff_new_pack.OrowQb/_old  2020-03-18 12:37:08.716641689 +0100
+++ /var/tmp/diff_new_pack.OrowQb/_new  2020-03-18 12:37:08.716641689 +0100
@@ -250,7 +250,7 @@
 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
 
 URL:  https://gcc.gnu.org/
-Version: 9.2.1+git1022
+Version: 9.2.1+git1192
 Release:  1
 %define gcc_dir_version %(echo %version |  sed 's/+.*//' | cut -d '.' -f 1)
 %define gcc_snapshot_revision %(echo %version | sed 's/[3-9]\.[0-9]\.[0-6]//' 
| sed 's/+/-/')




commit gcc10 for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package gcc10 for openSUSE:Factory checked 
in at 2020-03-18 12:23:55

Comparing /work/SRC/openSUSE:Factory/gcc10 (Old)
 and  /work/SRC/openSUSE:Factory/.gcc10.new.3160 (New)


Package is "gcc10"

Wed Mar 18 12:23:55 2020 rev:2 rq:781409 version:10.0.1+git175037

Changes:

--- /work/SRC/openSUSE:Factory/gcc10/cross-aarch64-gcc10.changes
2020-03-04 09:51:48.558310658 +0100
+++ /work/SRC/openSUSE:Factory/.gcc10.new.3160/cross-aarch64-gcc10.changes  
2020-03-18 12:26:00.456220322 +0100
@@ -1,0 +2,6 @@
+Mon Mar  2 10:16:06 UTC 2020 - Richard Biener 
+
+- Update to master head (778a77357cad11e8dd4c810544330af0fbe843b1).
+  * Includes fix for binutils version parsing [gcc#93965]
+
+---
cross-arm-gcc10.changes: same change
cross-arm-none-gcc10-bootstrap.changes: same change
cross-arm-none-gcc10.changes: same change
cross-avr-gcc10-bootstrap.changes: same change
cross-avr-gcc10.changes: same change
cross-epiphany-gcc10-bootstrap.changes: same change
cross-epiphany-gcc10.changes: same change
cross-hppa-gcc10.changes: same change
cross-i386-gcc10.changes: same change
cross-m68k-gcc10.changes: same change
cross-mips-gcc10.changes: same change
cross-nvptx-gcc10.changes: same change
cross-ppc64-gcc10.changes: same change
cross-ppc64le-gcc10.changes: same change
cross-riscv64-elf-gcc10-bootstrap.changes: same change
cross-riscv64-elf-gcc10.changes: same change
cross-riscv64-gcc10.changes: same change
cross-rx-gcc10-bootstrap.changes: same change
cross-rx-gcc10.changes: same change
cross-s390x-gcc10.changes: same change
cross-sparc-gcc10.changes: same change
cross-sparc64-gcc10.changes: same change
cross-x86_64-gcc10.changes: same change
gcc10-testresults.changes: same change
gcc10.changes: same change

Old:

  gcc-10.0.1+git174776.tar.xz

New:

  gcc-10.0.1+git175037.tar.xz



Other differences:
--
++ cross-aarch64-gcc10.spec ++
--- /var/tmp/diff_new_pack.9sznOh/_old  2020-03-18 12:29:51.788365504 +0100
+++ /var/tmp/diff_new_pack.9sznOh/_new  2020-03-18 12:29:51.788365504 +0100
@@ -114,7 +114,7 @@
 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
 
 URL:https://gcc.gnu.org/
-Version:10.0.1+git174776
+Version:10.0.1+git175037
 Release:0
 %define gcc_dir_version %(echo %version |  sed 's/+.*//' | cut -d '.' -f 1)
 %define gcc_snapshot_revision %(echo %version | sed 's/[3-9]\.[0-9]\.[0-6]//' 
| sed 's/+/-/')

cross-arm-gcc10.spec: same change
cross-arm-none-gcc10-bootstrap.spec: same change
cross-arm-none-gcc10.spec: same change
cross-avr-gcc10-bootstrap.spec: same change
cross-avr-gcc10.spec: same change
cross-epiphany-gcc10-bootstrap.spec: same change
cross-epiphany-gcc10.spec: same change
cross-hppa-gcc10.spec: same change
cross-i386-gcc10.spec: same change
cross-m68k-gcc10.spec: same change
cross-mips-gcc10.spec: same change
cross-nvptx-gcc10.spec: same change
cross-ppc64-gcc10.spec: same change
cross-ppc64le-gcc10.spec: same change
cross-riscv64-elf-gcc10-bootstrap.spec: same change
cross-riscv64-elf-gcc10.spec: same change
cross-riscv64-gcc10.spec: same change
cross-rx-gcc10-bootstrap.spec: same change
cross-rx-gcc10.spec: same change
cross-s390x-gcc10.spec: same change
cross-sparc-gcc10.spec: same change
cross-sparc64-gcc10.spec: same change
cross-x86_64-gcc10.spec: same change
gcc10-testresults.spec: same change
gcc10.spec: same change
++ gcc-10.0.1+git174776.tar.xz -> gcc-10.0.1+git175037.tar.xz ++
/work/SRC/openSUSE:Factory/gcc10/gcc-10.0.1+git174776.tar.xz 
/work/SRC/openSUSE:Factory/.gcc10.new.3160/gcc-10.0.1+git175037.tar.xz differ: 
char 26, line 1

++ gcc.spec.in ++
--- /var/tmp/diff_new_pack.9sznOh/_old  2020-03-18 12:29:52.312365832 +0100
+++ /var/tmp/diff_new_pack.9sznOh/_new  2020-03-18 12:29:52.312365832 +0100
@@ -253,7 +253,7 @@
 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
 
 URL:  https://gcc.gnu.org/
-Version: 10.0.1+git174776
+Version: 10.0.1+git175037
 Release:  1
 %define gcc_dir_version %(echo %version |  sed 's/+.*//' | cut -d '.' -f 1)
 %define gcc_snapshot_revision %(echo %version | sed 's/[3-9]\.[0-9]\.[0-6]//' 
| sed 's/+/-/')




commit post-build-checks for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package post-build-checks for 
openSUSE:Factory checked in at 2020-03-18 12:24:32

Comparing /work/SRC/openSUSE:Factory/post-build-checks (Old)
 and  /work/SRC/openSUSE:Factory/.post-build-checks.new.3160 (New)


Package is "post-build-checks"

Wed Mar 18 12:24:32 2020 rev:96 rq:781792 version:84.87+git20200305.61b5cdf

Changes:

--- /work/SRC/openSUSE:Factory/post-build-checks/post-build-checks.changes  
2020-01-10 17:47:41.242154855 +0100
+++ 
/work/SRC/openSUSE:Factory/.post-build-checks.new.3160/post-build-checks.changes
2020-03-18 12:30:15.524380401 +0100
@@ -1,0 +2,6 @@
+Thu Mar 05 09:57:18 UTC 2020 - lnus...@suse.de
+
+- Update to version 84.87+git20200305.61b5cdf:
+  * Fix ghost logic
+
+---

Old:

  post-build-checks-84.87+git20200110.2d02f07.tar.xz

New:

  post-build-checks-84.87+git20200305.61b5cdf.tar.xz



Other differences:
--
++ post-build-checks.spec ++
--- /var/tmp/diff_new_pack.fnPSA2/_old  2020-03-18 12:30:16.820381214 +0100
+++ /var/tmp/diff_new_pack.fnPSA2/_new  2020-03-18 12:30:16.820381214 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package post-build-checks
 #
-# Copyright (c) 2020 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,13 +16,13 @@
 #
 
 
-%define version_unconverted 84.87+git20200110.2d02f07
+%define version_unconverted 84.87+git20200305.61b5cdf
 
 Name:   post-build-checks
 Summary:post checks for build after rpms have been created
 License:GPL-2.0-or-later
 Group:  Development/Tools/Building
-Version:84.87+git20200110.2d02f07
+Version:84.87+git20200305.61b5cdf
 Release:0
 PreReq: aaa_base permissions sed
 Requires:   aaa_base-malloccheck

++ _servicedata ++
--- /var/tmp/diff_new_pack.fnPSA2/_old  2020-03-18 12:30:16.868381244 +0100
+++ /var/tmp/diff_new_pack.fnPSA2/_new  2020-03-18 12:30:16.868381244 +0100
@@ -1,5 +1,5 @@
 
   
 git://github.com/openSUSE/post-build-checks.git
-  f347f2e1ffb7a22e1959d7435439dda2525f5176
+  b14fe84733d2365bf456b34a61bd0535121ac51d
 
\ No newline at end of file

++ post-build-checks-84.87+git20200110.2d02f07.tar.xz -> 
post-build-checks-84.87+git20200305.61b5cdf.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/post-build-checks-84.87+git20200110.2d02f07/checks-data/findfileconflicts 
new/post-build-checks-84.87+git20200305.61b5cdf/checks-data/findfileconflicts
--- 
old/post-build-checks-84.87+git20200110.2d02f07/checks-data/findfileconflicts   
2020-01-10 12:43:37.0 +0100
+++ 
new/post-build-checks-84.87+git20200305.61b5cdf/checks-data/findfileconflicts   
2020-03-05 10:56:39.0 +0100
@@ -217,7 +217,7 @@
  $modes_ghost[$m] = $ff & 0100;
}
my $f = "$n/$bn";
-   if (($ff & 0100) != 0) {
+   if (($ff & 0100) == 0) {
  if (exists $files{$f}) {
$filesc{$f} ||= [ $files{$f} ];
push @{$filesc{$f}}, "$pkg/$m";




commit lapack for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package lapack for openSUSE:Factory checked 
in at 2020-03-18 12:23:21

Comparing /work/SRC/openSUSE:Factory/lapack (Old)
 and  /work/SRC/openSUSE:Factory/.lapack.new.3160 (New)


Package is "lapack"

Wed Mar 18 12:23:21 2020 rev:46 rq:785151 version:3.8.0

Changes:

--- /work/SRC/openSUSE:Factory/lapack/lapack.changes2019-09-05 
12:07:39.355882545 +0200
+++ /work/SRC/openSUSE:Factory/.lapack.new.3160/lapack.changes  2020-03-18 
12:25:55.992217520 +0100
@@ -1,0 +2,5 @@
+Fri Mar 13 14:58:33 UTC 2020 - Martin Liška 
+
+- Add -std=legacy in order to fix boo#1166619.
+
+---



Other differences:
--
++ lapack-man.spec ++
--- /var/tmp/diff_new_pack.nmnioy/_old  2020-03-18 12:25:57.484218456 +0100
+++ /var/tmp/diff_new_pack.nmnioy/_new  2020-03-18 12:25:57.488218459 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package lapack-man
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -23,7 +23,7 @@
 Summary:Manpages for LAPACK
 License:BSD-3-Clause
 Group:  Documentation/HTML
-Url:http://www.netlib.org/lapack/
+URL:http://www.netlib.org/lapack/
 Source0:http://www.netlib.org/lapack/%{_name}-%{version}.tgz
 BuildRequires:  doxygen >= 1.7
 Provides:   lapack-manpages = %{version}

++ lapack.spec ++
--- /var/tmp/diff_new_pack.nmnioy/_old  2020-03-18 12:25:57.504218468 +0100
+++ /var/tmp/diff_new_pack.nmnioy/_new  2020-03-18 12:25:57.504218468 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package lapack
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -22,7 +22,7 @@
 Summary:Linear Algebra Package
 License:BSD-3-Clause
 Group:  Development/Libraries/Parallel
-Url:http://www.netlib.org/lapack/
+URL:http://www.netlib.org/lapack/
 Source0:http://www.netlib.org/lapack/%{name}-%{version}.tar.gz
 Source1:lapack_testing.py
 Source99:   baselibs.conf
@@ -176,6 +176,7 @@
 
 %build
 %global _lto_cflags %{_lto_cflags} -ffat-lto-objects
+%global optflags %{optflags} -std=legacy
 case "$RPM_ARCH" in
 i[0-9]86) PRECFLAGS="-ffloat-store" ;;
 *)PRECFLAGS="" ;;




commit xfsprogs for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package xfsprogs for openSUSE:Factory 
checked in at 2020-03-18 12:22:01

Comparing /work/SRC/openSUSE:Factory/xfsprogs (Old)
 and  /work/SRC/openSUSE:Factory/.xfsprogs.new.3160 (New)


Package is "xfsprogs"

Wed Mar 18 12:22:01 2020 rev:59 rq:784964 version:5.5.0

Changes:

--- /work/SRC/openSUSE:Factory/xfsprogs/xfsprogs.changes2020-02-29 
21:21:16.142131139 +0100
+++ /work/SRC/openSUSE:Factory/.xfsprogs.new.3160/xfsprogs.changes  
2020-03-18 12:24:48.336175060 +0100
@@ -1,0 +2,14 @@
+Sat Mar 14 11:15:39 UTC 2020 - Anthony Iliopoulos 
+
+- update to v5.5.0:
+  * xfsprogs: actually check that writes succeeded
+  * mkfs.xfs: check root inode location
+  * mkfs.xfs: efficient block zeroing
+  * xfs_repair: fix broken unit conv. in dir invalidation
+  * xfs_repair: fix bad next_unlinked field
+  * xfs_repair: don't corrupt attr fork clearing forw/back
+  * xfs_repair: check root dir pointer before trashing it
+  * xfs_repair: try to fix sb_unit value from secondaries
+  * libxfs changes merged from kernel 5.5
+
+---

Old:

  xfsprogs-5.4.0.tar.sign
  xfsprogs-5.4.0.tar.xz

New:

  xfsprogs-5.5.0.tar.sign
  xfsprogs-5.5.0.tar.xz



Other differences:
--
++ xfsprogs.spec ++
--- /var/tmp/diff_new_pack.ktXFep/_old  2020-03-18 12:24:52.364177587 +0100
+++ /var/tmp/diff_new_pack.ktXFep/_new  2020-03-18 12:24:52.368177590 +0100
@@ -26,7 +26,7 @@
 %define libname libhandle1
 
 Name:   xfsprogs
-Version:5.4.0
+Version:5.5.0
 Release:0
 Summary:Utilities for managing the XFS file system
 License:GPL-2.0-or-later

++ xfsprogs-5.4.0.tar.xz -> xfsprogs-5.5.0.tar.xz ++
 37311 lines of diff (skipped)





commit dtc for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package dtc for openSUSE:Factory checked in 
at 2020-03-18 12:22:51

Comparing /work/SRC/openSUSE:Factory/dtc (Old)
 and  /work/SRC/openSUSE:Factory/.dtc.new.3160 (New)


Package is "dtc"

Wed Mar 18 12:22:51 2020 rev:36 rq:785089 version:1.6.0

Changes:

--- /work/SRC/openSUSE:Factory/dtc/dtc.changes  2020-01-27 00:20:39.977415528 
+0100
+++ /work/SRC/openSUSE:Factory/.dtc.new.3160/dtc.changes2020-03-18 
12:25:37.740206065 +0100
@@ -1,0 +2,6 @@
+Tue Mar 10 10:03:02 UTC 2020 - Paolo Stivanin 
+
+- Update to 1.6.0 (no changelog)
+- Removed dtc-no-common-conflict.patch
+
+---

Old:

  dtc-1.5.1.tar.gz
  dtc-1.5.1.tar.sign
  dtc-no-common-conflict.patch

New:

  dtc-1.6.0.tar.gz
  dtc-1.6.0.tar.sign



Other differences:
--
++ dtc.spec ++
--- /var/tmp/diff_new_pack.O83UWU/_old  2020-03-18 12:25:40.668207902 +0100
+++ /var/tmp/diff_new_pack.O83UWU/_new  2020-03-18 12:25:40.672207905 +0100
@@ -18,7 +18,7 @@
 
 %define sover 1
 Name:   dtc
-Version:1.5.1
+Version:1.6.0
 Release:0
 Summary:Device-tree compiler
 License:GPL-2.0-or-later
@@ -26,7 +26,6 @@
 Source0:
https://mirrors.edge.kernel.org/pub/software/utils/dtc/dtc-%{version}.tar.gz
 Source1:
https://mirrors.edge.kernel.org/pub/software/utils/dtc/dtc-%{version}.tar.sign
 Source2:baselibs.conf
-Patch0: dtc-no-common-conflict.patch
 BuildRequires:  bison
 BuildRequires:  flex
 BuildRequires:  libyaml-devel
@@ -72,7 +71,6 @@
 
 %prep
 %setup -q
-%patch0
 
 %build
 export EXTRA_CFLAGS="%{optflags}"
@@ -107,7 +105,7 @@
 %postun -n libfdt%{sover} -p /sbin/ldconfig
 
 %files -n libfdt%{sover}
-%{_libdir}/libfdt-1.5.0.so
+%{_libdir}/libfdt-1.6.0.so
 %{_libdir}/libfdt.so.*
 
 %files -n libfdt-devel

++ dtc-1.5.1.tar.gz -> dtc-1.6.0.tar.gz ++
 2733 lines of diff (skipped)




commit glibc for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package glibc for openSUSE:Factory checked 
in at 2020-03-18 12:17:49

Comparing /work/SRC/openSUSE:Factory/glibc (Old)
 and  /work/SRC/openSUSE:Factory/.glibc.new.3160 (New)


Package is "glibc"

Wed Mar 18 12:17:49 2020 rev:236 rq:784367 version:2.31

Changes:

--- /work/SRC/openSUSE:Factory/glibc/glibc.changes  2020-02-18 
15:18:51.552728065 +0100
+++ /work/SRC/openSUSE:Factory/.glibc.new.3160/glibc.changes2020-03-18 
12:23:25.276122932 +0100
@@ -1,0 +2,8 @@
+Thu Mar 12 10:21:15 UTC 2020 - Andreas Schwab 
+
+- riscv-syscall-clobber.patch: riscv: Avoid clobbering register parameters
+  in syscall
+- ldbl-96-rem-pio2l.patch: Avoid ldbl-96 stack corruption from range
+  reduction of pseudo-zero (CVE-2020-10029, bsc#1165784, BZ #25487)
+
+---

New:

  ldbl-96-rem-pio2l.patch
  riscv-syscall-clobber.patch



Other differences:
--
++ glibc.spec ++
--- /var/tmp/diff_new_pack.EeSNdq/_old  2020-03-18 12:23:45.124135387 +0100
+++ /var/tmp/diff_new_pack.EeSNdq/_new  2020-03-18 12:23:45.124135387 +0100
@@ -257,6 +257,10 @@
 ###
 # Patches from upstream
 ###
+# PATCH-FIX-UPSTREAM riscv: Avoid clobbering register parameters in syscall
+Patch1000:  riscv-syscall-clobber.patch
+# PATCH-FIX-UPSTREAM Avoid ldbl-96 stack corruption from range reduction of 
pseudo-zero (CVE-2020-10029, BZ #25487)
+Patch1001:  ldbl-96-rem-pio2l.patch
 
 ### 
 # Patches awaiting upstream approval
@@ -464,6 +468,9 @@
 %patch304 -p1
 %patch306 -p1
 
+%patch1000 -p1
+%patch1001 -p1
+
 %patch2000 -p1
 %patch2001 -p1
 %patch2002 -p1

++ _constraints ++
--- /var/tmp/diff_new_pack.EeSNdq/_old  2020-03-18 12:23:45.156135408 +0100
+++ /var/tmp/diff_new_pack.EeSNdq/_new  2020-03-18 12:23:45.160135411 +0100
@@ -2,12 +2,15 @@
 
   
 
-  glibc-testsuite
+  glibc:testsuite
 
 
   
1500
   
+  
+5600
+  
 
 xen
   


++ ldbl-96-rem-pio2l.patch ++
>From 9f997ceca28f0634ad78a1ca95b84265f7801ff4 Mon Sep 17 00:00:00 2001
From: Joseph Myers 
Date: Wed, 12 Feb 2020 23:31:56 +
Subject: [PATCH] Avoid ldbl-96 stack corruption from range reduction of
 pseudo-zero (bug 25487).

Bug 25487 reports stack corruption in ldbl-96 sinl on a pseudo-zero
argument (an representation where all the significand bits, including
the explicit high bit, are zero, but the exponent is not zero, which
is not a valid representation for the long double type).

Although this is not a valid long double representation, existing
practice in this area (see bug 4586, originally marked invalid but
subsequently fixed) is that we still seek to avoid invalid memory
accesses as a result, in case of programs that treat arbitrary binary
data as long double representations, although the invalid
representations of the ldbl-96 format do not need to be consistently
handled the same as any particular valid representation.

This patch makes the range reduction detect pseudo-zero and unnormal
representations that would otherwise go to __kernel_rem_pio2, and
returns a NaN for them instead of continuing with the range reduction
process.  (Pseudo-zero and unnormal representations whose unbiased
exponent is less than -1 have already been safely returned from the
function before this point without going through the rest of range
reduction.)  Pseudo-zero representations would previously result in
the value passed to __kernel_rem_pio2 being all-zero, which is
definitely unsafe; unnormal representations would previously result in
a value passed whose high bit is zero, which might well be unsafe
since that is not a form of input expected by __kernel_rem_pio2.

Tested for x86_64.

(cherry picked from commit 9333498794cde1d5cca518badf79533a24114b6f)
---
 NEWS   |  5 +++
 sysdeps/ieee754/ldbl-96/Makefile   |  3 +-
 sysdeps/ieee754/ldbl-96/e_rem_pio2l.c  | 12 +++
 sysdeps/ieee754/ldbl-96/test-sinl-pseudo.c | 41 ++
 4 files changed, 60 insertions(+), 1 deletion(-)
 create mode 100644 sysdeps/ieee754/ldbl-96/test-sinl-pseudo.c

Index: glibc-2.31/sysdeps/ieee754/ldbl-96/Makefile
===
--- glibc-2.31.orig/sysdeps/ieee754/ldbl-96/Makefile
+++ glibc-2.31/sysdeps/ieee754/ldbl-96/Makefile
@@ -17,5 +17,6 @@
 # .
 
 ifeq ($(subdir),math)
-tests += test-canonical-ldbl-96 test-totalorderl-ldbl-96
+tests += test-canonical-ldbl-96 test-totalorderl-ldbl-96 test-sinl-pseudo
+CFLAGS-test-sinl-pseudo.c += -fstack-protector-all
 endif
Index: glibc-2.31/sysdeps/ieee754/ldbl-96/e_rem_pio2l.c

commit chromium for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package chromium for openSUSE:Factory 
checked in at 2020-03-18 12:20:28

Comparing /work/SRC/openSUSE:Factory/chromium (Old)
 and  /work/SRC/openSUSE:Factory/.chromium.new.3160 (New)


Package is "chromium"

Wed Mar 18 12:20:28 2020 rev:248 rq:784928 version:80.0.3987.132

Changes:

--- /work/SRC/openSUSE:Factory/chromium/chromium.changes2020-03-06 
21:25:11.157478886 +0100
+++ /work/SRC/openSUSE:Factory/.chromium.new.3160/chromium.changes  
2020-03-18 12:24:08.592150116 +0100
@@ -1,0 +2,6 @@
+Sat Mar 14 09:18:06 UTC 2020 - Tomáš Chvátal 
+
+- Do not pull in python deps except interpreter, the bundles
+  are patched anwyays
+
+---



Other differences:
--
++ chromium.spec ++
--- /var/tmp/diff_new_pack.4WfxKP/_old  2020-03-18 12:24:31.064164220 +0100
+++ /var/tmp/diff_new_pack.4WfxKP/_new  2020-03-18 12:24:31.064164220 +0100
@@ -131,6 +131,7 @@
 BuildRequires:  pam-devel
 BuildRequires:  pkgconfig
 BuildRequires:  python
+BuildRequires:  python-xml
 BuildRequires:  snappy-devel
 BuildRequires:  update-desktop-files
 BuildRequires:  util-linux
@@ -241,10 +242,6 @@
 BuildRequires:  pkgconfig(libxml-2.0) >= 2.9.5
 %endif
 %if !%{with sle_bundles}
-BuildRequires:  python-beautifulsoup4
-BuildRequires:  python-html5lib
-BuildRequires:  python-simplejson
-BuildRequires:  python-xml
 BuildRequires:  yasm-devel
 BuildRequires:  pkgconfig(libwebp)
 BuildRequires:  pkgconfig(opus) >= 1.3.1
@@ -342,8 +339,6 @@
 third_party/catapult/common/py_vulcanize/third_party/rjsmin
 third_party/catapult/third_party/beautifulsoup4
 third_party/catapult/third_party/html5lib-python
-third_party/catapult/third_party/beautifulsoup4
-third_party/catapult/third_party/html5lib-python
 third_party/catapult/third_party/polymer
 third_party/catapult/third_party/six
 third_party/catapult/tracing/third_party/d3
@@ -488,9 +483,6 @@
 third_party/opus
 third_party/yasm
 third_party/simplejson
-third_party/catapult/third_party/beautifulsoup4
-third_party/catapult/third_party/html5lib-python
-third_party/catapult/third_party/six
 third_party/zlib
 )
 %endif




commit libidn2 for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package libidn2 for openSUSE:Factory checked 
in at 2020-03-18 12:17:24

Comparing /work/SRC/openSUSE:Factory/libidn2 (Old)
 and  /work/SRC/openSUSE:Factory/.libidn2.new.3160 (New)


Package is "libidn2"

Wed Mar 18 12:17:24 2020 rev:14 rq:784782 version:2.3.0

Changes:

--- /work/SRC/openSUSE:Factory/libidn2/libidn2.changes  2019-11-23 
23:29:02.162843198 +0100
+++ /work/SRC/openSUSE:Factory/.libidn2.new.3160/libidn2.changes
2020-03-18 12:23:07.088111517 +0100
@@ -1,0 +2,5 @@
+Sat Feb 22 19:14:28 UTC 2020 - Bjørn Lie 
+
+- No longer recommend -lang: supplements are in use.
+
+---



Other differences:
--
++ libidn2.spec ++
--- /var/tmp/diff_new_pack.hldFLc/_old  2020-03-18 12:23:12.292114783 +0100
+++ /var/tmp/diff_new_pack.hldFLc/_new  2020-03-18 12:23:12.292114783 +0100
@@ -41,7 +41,6 @@
 
 %package -n %{lname}
 Summary:Support for Internationalized Domain Names (IDN)
-Recommends: %{name}-lang = %{version}
 # for lang package
 Provides:   %{name} = %{version}
 





commit pam for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package pam for openSUSE:Factory checked in 
at 2020-03-18 12:16:59

Comparing /work/SRC/openSUSE:Factory/pam (Old)
 and  /work/SRC/openSUSE:Factory/.pam.new.3160 (New)


Package is "pam"

Wed Mar 18 12:16:59 2020 rev:99 rq:784597 version:1.3.1+git20190923.ea78d67

Changes:

--- /work/SRC/openSUSE:Factory/pam/pam.changes  2020-03-01 21:25:50.312291326 
+0100
+++ /work/SRC/openSUSE:Factory/.pam.new.3160/pam.changes2020-03-18 
12:22:25.220085241 +0100
@@ -1,0 +2,9 @@
+Thu Mar 12 16:01:46 UTC 2020 - Josef Möllers 
+
+- Removed pam_userdb from this package and moved to pam-modules.
+  This removed the requirement for libdb.
+  Also made "xz" required for all releases.
+  Remove limits for nproc from /etc/security/limits.conf
+  [bsc#1164562, bsc#1166510, bsc#1110700, pam.spec]
+
+---



Other differences:
--
++ pam.spec ++
--- /var/tmp/diff_new_pack.2qk51c/_old  2020-03-18 12:22:33.452090407 +0100
+++ /var/tmp/diff_new_pack.2qk51c/_new  2020-03-18 12:22:33.452090407 +0100
@@ -57,16 +57,14 @@
 BuildRequires:  bison
 BuildRequires:  cracklib-devel
 BuildRequires:  flex
-BuildRequires:  libdb-4_8-devel
 BuildRequires:  libtool
 # All login.defs variables require support from shadow side.
 # Upgrade this symbol version only if new variables appear!
 # Verify by shadow-login_defs-check.sh from shadow source package.
 Recommends: login_defs-support-for-pam >= 1.3.1
 Requires(post): permissions
-%if 0%{?suse_version} > 1320
-BuildRequires:  libdb-4_8-devel
 BuildRequires:  xz
+%if 0%{?suse_version} > 1320
 BuildRequires:  pkgconfig(libeconf)
 BuildRequires:  pkgconfig(libnsl)
 BuildRequires:  pkgconfig(libtirpc)
@@ -312,7 +310,6 @@
 /%{_lib}/security/pam_unix_auth.so
 /%{_lib}/security/pam_unix_passwd.so
 /%{_lib}/security/pam_unix_session.so
-/%{_lib}/security/pam_userdb.so
 /%{_lib}/security/pam_warn.so
 /%{_lib}/security/pam_wheel.so
 /%{_lib}/security/pam_xauth.so




commit MozillaFirefox for openSUSE:Factory

2020-03-18 Thread root
Hello community,

here is the log from the commit of package MozillaFirefox for openSUSE:Factory 
checked in at 2020-03-18 12:16:26

Comparing /work/SRC/openSUSE:Factory/MozillaFirefox (Old)
 and  /work/SRC/openSUSE:Factory/.MozillaFirefox.new.3160 (New)


Package is "MozillaFirefox"

Wed Mar 18 12:16:26 2020 rev:307 rq:784530 version:74.0

Changes:

--- /work/SRC/openSUSE:Factory/MozillaFirefox/MozillaFirefox.changes
2020-02-29 21:20:44.490068501 +0100
+++ /work/SRC/openSUSE:Factory/.MozillaFirefox.new.3160/MozillaFirefox.changes  
2020-03-18 12:16:41.571815559 +0100
@@ -1,0 +2,48 @@
+Sat Mar  7 08:51:06 UTC 2020 - Wolfgang Rosenauer 
+
+- Mozilla Firefox 74.0
+  * https://www.mozilla.org/en-US/firefox/74.0/releasenotes/
+  MFSA 2020-08 (bsc#1166238)
+  * CVE-2020-6805 (bmo#1610880)
+Use-after-free when removing data about origins
+  * CVE-2020-6806 (bmo#1612308)
+BodyStream::OnInputStreamReady was missing protections against
+state confusion
+  * CVE-2020-6807 (bmo#1614971)
+Use-after-free in cubeb during stream destruction
+  * CVE-2020-6808 (bmo#1247968)
+URL Spoofing via javascript: URL
+  * CVE-2020-6809 (bmo#1420296)
+Web Extensions with the all-urls permission could access local
+files
+  * CVE-2020-6810 (bmo#1432856)
+Focusing a popup while in fullscreen could have obscured the
+fullscreen notification
+  * CVE-2020-6811 (bmo#1607742)
+Devtools' 'Copy as cURL' feature did not fully escape
+website-controlled data, potentially leading to command injection
+  * CVE-2019-20503 (bmo#1613765)
+Out of bounds reads in sctp_load_addresses_from_init
+  * CVE-2020-6812 (bmo#1616661)
+The names of AirPods with personally identifiable information
+were exposed to websites with camera or microphone permission
+  * CVE-2020-6813 (bmo#1605814)
+@import statements in CSS could bypass the Content Security
+Policy nonce feature
+  * CVE-2020-6814 (bmo#1592078,bmo#1604847,bmo#1608256,bmo#1612636,
+bmo#1614339)
+Memory safety bugs fixed in Firefox 74 and Firefox ESR 68.6
+  * CVE-2020-6815 (bmo#1181957,bmo#1557732,bmo#1557739,bmo#1611457,
+bmo#1612431)
+Memory and script safety bugs fixed in Firefox 74
+- requires
+  * NSPR 4.25
+  * NSS 3.50
+  * rust-cbindgen 0.13.0
+- removed obsolete patches
+  mozilla-bmo1610814.patch
+  mozilla-cubeb-noreturn.patch
+- add mozilla-bmo1609538.patch to fix wayland issues with mutter 3.36
+  (bmo#1609538, boo#1166471)
+
+---

Old:

  firefox-73.0.1.source.tar.xz
  firefox-73.0.1.source.tar.xz.asc
  l10n-73.0.1.tar.xz
  mozilla-bmo1610814.patch
  mozilla-cubeb-noreturn.patch

New:

  firefox-74.0.source.tar.xz
  firefox-74.0.source.tar.xz.asc
  l10n-74.0.tar.xz
  mozilla-bmo1609538.patch



Other differences:
--
++ MozillaFirefox.spec ++
--- /var/tmp/diff_new_pack.q2qbDI/_old  2020-03-18 12:21:35.544054065 +0100
+++ /var/tmp/diff_new_pack.q2qbDI/_new  2020-03-18 12:21:35.544054065 +0100
@@ -18,9 +18,9 @@
 
 
 # changed with every update
-%define major  73
-%define mainver%major.0.1
-%define orig_version   73.0.1
+%define major  74
+%define mainver%major.0
+%define orig_version   74.0
 %define orig_suffix%{nil}
 %define update_channel release
 %define branding   1
@@ -83,15 +83,15 @@
 BuildRequires:  libnotify-devel
 BuildRequires:  libproxy-devel
 BuildRequires:  makeinfo
-BuildRequires:  mozilla-nspr-devel >= 4.24
-BuildRequires:  mozilla-nss-devel >= 3.49.2
+BuildRequires:  mozilla-nspr-devel >= 4.25
+BuildRequires:  mozilla-nss-devel >= 3.50
 BuildRequires:  nasm >= 2.13
 BuildRequires:  nodejs8 >= 8.11
 BuildRequires:  python-devel
 BuildRequires:  python2-xml
 BuildRequires:  python3 >= 3.5
 BuildRequires:  rust >= 1.39
-BuildRequires:  rust-cbindgen >= 0.12.0
+BuildRequires:  rust-cbindgen >= 0.13.0
 BuildRequires:  startup-notification-devel
 BuildRequires:  unzip
 BuildRequires:  update-desktop-files
@@ -169,7 +169,6 @@
 Patch3: mozilla-ntlm-full-path.patch
 Patch4: mozilla-aarch64-startup-crash.patch
 Patch5: mozilla-bmo1463035.patch
-Patch6: mozilla-cubeb-noreturn.patch
 Patch7: mozilla-fix-aarch64-libopus.patch
 Patch8: mozilla-disable-wasm-emulate-arm-unaligned-fp-access.patch
 Patch9: mozilla-s390-context.patch
@@ -186,7 +185,7 @@
 Patch20:mozilla-fix-top-level-asm.patch
 Patch21:mozilla-bmo1504834-part4.patch
 Patch22:mozilla-bmo849632.patch
-Patch23:mozilla-bmo1610814.patch
+Patch23:mozilla-bmo1609538.patch
 # Firefox/browser
 Patch101:   firefox-kde.patch
 Patch102:   firefox-branded-icons.patch
@@ -303,7 +302,6 @@
 %patch3 

commit 00Meta for openSUSE:Leap:15.1:Images

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 00Meta for openSUSE:Leap:15.1:Images 
checked in at 2020-03-18 09:15:54

Comparing /work/SRC/openSUSE:Leap:15.1:Images/00Meta (Old)
 and  /work/SRC/openSUSE:Leap:15.1:Images/.00Meta.new.3160 (New)


Package is "00Meta"

Wed Mar 18 09:15:54 2020 rev:324 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ version_snapshot ++
--- /var/tmp/diff_new_pack.lznfXM/_old  2020-03-18 09:15:57.396729889 +0100
+++ /var/tmp/diff_new_pack.lznfXM/_new  2020-03-18 09:15:57.412729899 +0100
@@ -1 +1 @@
-8.11.1
\ No newline at end of file
+8.11.2
\ No newline at end of file




commit 00Meta for openSUSE:Leap:15.2:PowerPC

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 00Meta for 
openSUSE:Leap:15.2:PowerPC checked in at 2020-03-18 07:32:13

Comparing /work/SRC/openSUSE:Leap:15.2:PowerPC/00Meta (Old)
 and  /work/SRC/openSUSE:Leap:15.2:PowerPC/.00Meta.new.3160 (New)


Package is "00Meta"

Wed Mar 18 07:32:13 2020 rev:105 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ version_totest ++
--- /var/tmp/diff_new_pack.DbBDd6/_old  2020-03-18 07:32:14.960903644 +0100
+++ /var/tmp/diff_new_pack.DbBDd6/_new  2020-03-18 07:32:14.960903644 +0100
@@ -1 +1 @@
-170.1
\ No newline at end of file
+171.1
\ No newline at end of file




commit 00Meta for openSUSE:Leap:15.2:Images

2020-03-18 Thread root
Hello community,

here is the log from the commit of package 00Meta for openSUSE:Leap:15.2:Images 
checked in at 2020-03-18 07:02:26

Comparing /work/SRC/openSUSE:Leap:15.2:Images/00Meta (Old)
 and  /work/SRC/openSUSE:Leap:15.2:Images/.00Meta.new.3160 (New)


Package is "00Meta"

Wed Mar 18 07:02:26 2020 rev:306 rq: version:unknown

Changes:

New Changes file:

NO CHANGES FILE!!!



Other differences:
--
++ version_totest ++
--- /var/tmp/diff_new_pack.PQUKGu/_old  2020-03-18 07:02:27.731785449 +0100
+++ /var/tmp/diff_new_pack.PQUKGu/_new  2020-03-18 07:02:27.731785449 +0100
@@ -1 +1 @@
-27.17
\ No newline at end of file
+27.18
\ No newline at end of file