commit digikam for openSUSE:Factory

2020-11-04 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2020-11-04 18:26:48

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.11331 (New)


Package is "digikam"

Wed Nov  4 18:26:48 2020 rev:192 rq:845791 version:7.1.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2020-09-09 
18:11:08.911701141 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.11331/digikam.changes   
2020-11-04 18:31:50.692220528 +0100
@@ -1,0 +2,13 @@
+Tue Nov  3 16:33:35 UTC 2020 - Christophe Giboudeaux 
+
+- Use cmake() style BuildRequires when possible.
+
+---
+Tue Nov  3 14:24:06 UTC 2020 - Stefan Brüns 
+
+- Remove several unused build dependencies (doxygen, graphviz,
+  all of boost but libboost_graph).
+- Remove __DATE_/__TIME__ mangling, handled by SOURCE_DATE_EPOCH.
+- Bump disk constraints, TW needs 9.3 GB currently.
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.VM6T7c/_old  2020-11-04 18:31:53.276214800 +0100
+++ /var/tmp/diff_new_pack.VM6T7c/_new  2020-11-04 18:31:53.280214790 +0100
@@ -18,6 +18,7 @@
 
 %define soversion 7
 %bcond_without lang
+%bcond_withapidocs
 Name:   digikam
 Version:7.1.0
 Release:0
@@ -30,44 +31,46 @@
 Patch0: 0001-Revert-Exiv2-is-now-released-with-exported-targets-u.patch
 BuildRequires:  QtAV-devel >= 1.12
 BuildRequires:  bison
-BuildRequires:  boost-devel
-BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  flex
-BuildRequires:  graphviz-devel
 BuildRequires:  hicolor-icon-theme
-BuildRequires:  kconfig-devel
-BuildRequires:  kcoreaddons-devel
-BuildRequires:  kdoctools-devel
-BuildRequires:  kfilemetadata5-devel
-BuildRequires:  ki18n-devel
-BuildRequires:  kiconthemes-devel
-BuildRequires:  kio-devel
-BuildRequires:  knotifications-devel
-BuildRequires:  knotifyconfig-devel
-BuildRequires:  kservice-devel
-BuildRequires:  kwindowsystem-devel
-BuildRequires:  kxmlgui-devel
 BuildRequires:  lensfun
 BuildRequires:  lensfun-devel
+BuildRequires:  libboost_graph-devel
 BuildRequires:  libeigen3-devel
 BuildRequires:  libexiv2-devel >= 0.26
 BuildRequires:  libexpat-devel
 BuildRequires:  libjpeg8-devel
-BuildRequires:  libksane-devel >= 15.12.0
 BuildRequires:  liblcms2-devel
 BuildRequires:  liblqr-devel
 BuildRequires:  libpng-devel
 BuildRequires:  libtiff-devel
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
-BuildRequires:  marble-devel
 BuildRequires:  opencv-devel
 BuildRequires:  pkgconfig
-BuildRequires:  solid-devel
-BuildRequires:  threadweaver-devel >= 5.5.0
 BuildRequires:  update-desktop-files
+%if %{with apidocs}
+BuildRequires:  doxygen
+BuildRequires:  graphviz-devel
+BuildRequires:  cmake(KF5DocTools)
+%endif
 BuildRequires:  cmake(KF5CalendarCore)
+BuildRequires:  cmake(KF5Config)
+BuildRequires:  cmake(KF5CoreAddons)
+BuildRequires:  cmake(KF5FileMetaData)
+BuildRequires:  cmake(KF5I18n)
+BuildRequires:  cmake(KF5IconThemes)
+BuildRequires:  cmake(KF5KIO)
+BuildRequires:  cmake(KF5Notifications)
+BuildRequires:  cmake(KF5NotifyConfig)
+BuildRequires:  cmake(KF5Sane)
+BuildRequires:  cmake(KF5Service)
+BuildRequires:  cmake(KF5Solid)
+BuildRequires:  cmake(KF5ThreadWeaver) >= 5.5.0
+BuildRequires:  cmake(KF5WindowSystem)
+BuildRequires:  cmake(KF5XmlGui)
+BuildRequires:  cmake(Marble)
 BuildRequires:  cmake(Qt5Concurrent)
 BuildRequires:  cmake(Qt5Core) >= 5.9.0
 BuildRequires:  cmake(Qt5DBus)
@@ -76,7 +79,6 @@
 BuildRequires:  cmake(Qt5OpenGL)
 BuildRequires:  cmake(Qt5PrintSupport)
 BuildRequires:  cmake(Qt5Sql)
-BuildRequires:  cmake(Qt5Test)
 BuildRequires:  cmake(Qt5Widgets)
 BuildRequires:  cmake(Qt5X11Extras)
 BuildRequires:  cmake(Qt5Xml)
@@ -111,7 +113,7 @@
 Obsoletes:  %{name}-doc < %{version}
 # QWebEngine is not available on ppc64
 %ifarch %{ix86} x86_64 %{arm} aarch64 mips mips64
-BuildRequires:  akonadi-contact-devel
+BuildRequires:  cmake(KF5AkonadiContact)
 BuildRequires:  cmake(Qt5WebEngineWidgets)
 %else
 %global qwebengine -DENABLE_QWEBENGINE:BOOL=OFF
@@ -174,16 +176,13 @@
 sed -i 's/set(DNN_DETECTION TRUE)/set(DNN_DETECTION FALSE)/' 
core/libs/facesengine/CMakeLists.txt
 %endif
 
-# Remove build time references so build-compare can do its work
-FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
-FAKE_BUILDTIME=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%H:%%M')
-sed -i "s/__DATE__/\"$FAKE_BUILDDATE\"/" 
core/app/utils/digikam_version.h.cmake.in
-sed -i "s/__DATE__/\"$FAKE_BUILDDATE\"/g" 

commit digikam for openSUSE:Factory

2020-09-09 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2020-09-09 18:05:24

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.3399 (New)


Package is "digikam"

Wed Sep  9 18:05:24 2020 rev:191 rq:833186 version:7.1.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2020-07-27 
17:39:23.810943297 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.3399/digikam.changes
2020-09-09 18:11:08.911701141 +0200
@@ -1,0 +2,14 @@
+Tue Sep  8 11:33:35 UTC 2020 - Wolfgang Bauer 
+
+- Update to 7.1.0
+  * https://www.digikam.org/news/2020-09-06-7.1.0_release_announcement/
+- New features (from NEWS):
+QueueManager: Add new tool to fix hot pixels from images.
+QueueManager: Add new tool to apply texture over images.
+Metadata: Better Exif and XMP metadata support with CR3 file
+  using libraw info parser.
+Metadata: Add support of IPTC strings encoded as UTF-8 imported
+  to the database.
+- 318 bugs fixed
+
+--

Old:

  digikam-7.0.0.tar.xz

New:

  digikam-7.1.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.1O8P3f/_old  2020-09-09 18:11:16.083707676 +0200
+++ /var/tmp/diff_new_pack.1O8P3f/_new  2020-09-09 18:11:16.087707680 +0200
@@ -19,7 +19,7 @@
 %define soversion 7
 %bcond_without lang
 Name:   digikam
-Version:7.0.0
+Version:7.1.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0-or-later

++ digikam-7.0.0.tar.xz -> digikam-7.1.0.tar.xz ++
/work/SRC/openSUSE:Factory/digikam/digikam-7.0.0.tar.xz 
/work/SRC/openSUSE:Factory/.digikam.new.3399/digikam-7.1.0.tar.xz differ: char 
26, line 1




commit digikam for openSUSE:Factory

2020-07-27 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2020-07-27 17:38:45

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.3592 (New)


Package is "digikam"

Mon Jul 27 17:38:45 2020 rev:190 rq:822749 version:7.0.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2020-07-24 
10:03:44.581846775 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.3592/digikam.changes
2020-07-27 17:39:23.810943297 +0200
@@ -1,0 +2,77 @@
+Sat Jul 25 06:33:55 UTC 2020 - Wolfgang Bauer 
+
+- Update to 7.0.0
+  * https://www.digikam.org/news/2020-07-19-7.0.0_release_announcement/
+- New features (from NEWS):
+FaceManagement: New Neural Network engine based on OpenCV Deep
+Learning module to detect and recognize faces.
+FaceManagement: Face Scan dialog contents is now simplified and
+embeded into left side-bar tab.
+SlideShow : Add new shuffle mode.
+HTMLGallery   : Add new theme "Html5Responsive".
+General   : Code compile with Qt5.15 framework.
+General   : All bundles have switched to last Qt 5.14.2 LTS.
+Linux and MacOS use QtWebEngine instead QtWebKit.
+General   : All bundles have switched to last KF5 5.70.0.
+Fix support for Gimp XCF files >= 2.10.
+General   : New FlatPak bundle processed by the KDE continuous
+integration stream.
+General   : New Plugin ImageMosaicWall to create an image based
+on a bunch of other photos.
+General   : Add Microsoft Visual C++ support and a Continuous
+Integration workflow to check code with this
+compiler.
+General   : Table-view is now able to show digiKam Tag-Paths
+properties.
+Metadata  : Add option to write geolocation information in file
+metadata.
+Metadata  : Add color label support for advanced metadata
+settings.
+Metadata  : Add Exif, Iptc, and Xmp read support for HEIF
+images.
+General   : Improved support for UNC network paths under
+Windows.
+General   : Improved support for Unicode paths under Windows.
+General   : Internal libheif updated to last stable 1.6.2 and
+internal libde265 updated to last stable 1.0.5.
+General   : Internal libraw updated to 0.20-RC2
+(https://www.libraw.org/news/libraw-0-20-rc2 ).
+New camera supported:
+Canon CR3, PowerShot G5 X Mark II,
+G7 X Mark III, SX70 HS, EOS R, EOS RP, EOS 90D,
+EOS 250D, EOS M6 Mark II, EOS M50, EOS M200,
+EOS 1DX Mark III (lossless files only)
+DJI Mavic Air, Air2, Osmo Action,
+FujiFilm Fujifilm compressed/16bit, GFX 100,
+X-A7, X-Pro3, X100V, X-T4, X-T200,
+GoPro Fusion, HERO5, HERO6, HERO7, HERO8,
+Hasselblad L1D-20c, X1D II 50C,
+Leica D-LUX7, Q-P, Q2, V-LUX5, C-Lux / CAM-DC25,
+SL2, M10 Monochrom,
+Nikon D780, Z50, P950,
+Olympus TG-6, E-M5 Mark III, E-PL10, E-M1 Mark III,
+Panasonic Panasonic 14-bit, DC-FZ1000 II, DC-G90,
+DC-S1, DC-S1R, DC-S1H, DC-TZ95,
+PhaseOne IQ4 150MP,
+Rapsberry Pi RAW+JPEG format,
+Ricoh GR III,
+Sony A7R IV, A9 II, ILCE-6100, ILCE-6600, RX0 II,
+RX100 VII,
+Zenit M,
+also multiple modern smartphones.
+
+- 761 bugs fixed
+- Drop patches merged upstream:
+  * fix-build-with-opencv-4.2.patch
+  * dlib-update-to-work-with-latest-version-of-OpenCV.patch
+  * Fix-build-with-Qt-5.15.patch
+- Drop 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch,
+  no longer necessary
+- Refresh patch:
+  * 0001-Revert-Exiv2-is-now-released-with-exported-targets-u.patch
+- Re-enable Faces engine DNN on ppc64le, it builds fine now
+- Switch back to old face detection engine when building with
+  opencv 3.3 (Leap 15.1/15.2), as the compilation fails otherwise
+- Drop conditionals for no longer supported openSUSE versions
+
+---

Old:

  0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
  Fix-build-with-Qt-5.15.patch
  digikam-6.4.0.tar.xz
  dlib-update-to-work-with-latest-version-of-OpenCV.patch
  fix-build-with-opencv-4.2.patch

New:

  digikam-7.0.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- 

commit digikam for openSUSE:Factory

2020-07-24 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2020-07-24 10:01:45

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.3592 (New)


Package is "digikam"

Fri Jul 24 10:01:45 2020 rev:189 rq:822276 version:6.4.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2020-07-21 
15:49:58.692265092 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.3592/digikam.changes
2020-07-24 10:03:44.581846775 +0200
@@ -1,0 +2,5 @@
+Wed Jul 22 12:44:20 UTC 2020 - Guillaume GARDET 
+
+- Update _constraints with latest disk value for all archs
+
+---



Other differences:
--
++ _constraints ++
--- /var/tmp/diff_new_pack.Lz3Fz9/_old  2020-07-24 10:03:46.317848100 +0200
+++ /var/tmp/diff_new_pack.Lz3Fz9/_new  2020-07-24 10:03:46.317848100 +0200
@@ -1,18 +1,7 @@
 
   
 
-  4500
+  8
 
   
-  
-
-  ppc64
-  ppc64le
-
-
-   
- 8000
-   
-
-  
 




commit digikam for openSUSE:Factory

2020-07-21 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2020-07-21 15:48:32

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.3592 (New)


Package is "digikam"

Tue Jul 21 15:48:32 2020 rev:188 rq:822014 version:6.4.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2020-06-06 
23:39:53.197006653 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.3592/digikam.changes
2020-07-21 15:49:58.692265092 +0200
@@ -1,0 +2,5 @@
+Mon Jul 20 14:35:59 UTC 2020 - Michel Normand 
+
+- increase min disk space for PowerPC from 6 to 8GB
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.gBWYQy/_old  2020-07-21 15:50:01.020267970 +0200
+++ /var/tmp/diff_new_pack.gBWYQy/_new  2020-07-21 15:50:01.024267976 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package digikam
 #
-# Copyright (c) 2020 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed

++ _constraints ++
--- /var/tmp/diff_new_pack.gBWYQy/_old  2020-07-21 15:50:01.060268020 +0200
+++ /var/tmp/diff_new_pack.gBWYQy/_new  2020-07-21 15:50:01.060268020 +0200
@@ -6,11 +6,12 @@
   
   
 
+  ppc64
   ppc64le
 
 

- 6000
+ 8000

 
   




commit digikam for openSUSE:Factory

2020-06-06 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2020-06-06 23:39:28

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.3606 (New)


Package is "digikam"

Sat Jun  6 23:39:28 2020 rev:187 rq:811909 version:6.4.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2020-01-12 
23:26:08.382855085 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new.3606/digikam.changes
2020-06-06 23:39:53.197006653 +0200
@@ -1,0 +2,6 @@
+Fri Jun  5 11:55:04 UTC 2020 - Wolfgang Bauer 
+
+- Add Fix-build-with-Qt-5.15.patch to fix build with Qt 5.15
+  (kde#421817)
+
+---

New:

  Fix-build-with-Qt-5.15.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.DHGgJp/_old  2020-06-06 23:39:55.857015001 +0200
+++ /var/tmp/diff_new_pack.DHGgJp/_new  2020-06-06 23:39:55.857015001 +0200
@@ -33,6 +33,8 @@
 # PATCH-FIX-UPSTREAM
 Patch2: fix-build-with-opencv-4.2.patch
 Patch3: dlib-update-to-work-with-latest-version-of-OpenCV.patch
+# PATCH-FIX-UPSTREAM
+Patch4: Fix-build-with-Qt-5.15.patch
 BuildRequires:  QtAV-devel >= 1.12
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -184,6 +186,7 @@
 %endif
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ Fix-build-with-Qt-5.15.patch ++
>From 9ef1670e7ea0852cdfb694dd4d839977305bd4a2 Mon Sep 17 00:00:00 2001
From: Gilles Caulier 
Date: Wed, 20 May 2020 13:05:55 +0200
Subject: fix broken compilation with Qt 5.15 CCBUGS: 421817

diff --git a/core/libs/dimg/filters/levels/histogrampainter.cpp 
b/core/libs/dimg/filters/levels/histogrampainter.cpp
index 241d5fc..f11ad4b 100644
--- a/core/libs/dimg/filters/levels/histogrampainter.cpp
+++ b/core/libs/dimg/filters/levels/histogrampainter.cpp
@@ -30,6 +30,7 @@
 // Qt includes
 
 #include 
+#include 
 
 // KDE includes
 
diff --git a/core/libs/dimg/filters/curves/curveswidget.cpp 
b/core/libs/dimg/filters/curves/curveswidget.cpp
index cbd..e8b2e1b 100644
--- a/core/libs/dimg/filters/curves/curveswidget.cpp
+++ b/core/libs/dimg/filters/curves/curveswidget.cpp
@@ -42,6 +42,7 @@
 #include 
 #include 
 #include 
+#include 
 
 // KDE includes
 
diff --git a/core/dplugins/generic/view/presentation/opengl/presentationgl.cpp 
b/core/dplugins/generic/view/presentation/opengl/presentationgl.cpp
index b376994..4d4dbfb 100644
--- a/core/dplugins/generic/view/presentation/opengl/presentationgl.cpp
+++ b/core/dplugins/generic/view/presentation/opengl/presentationgl.cpp
@@ -44,6 +44,8 @@
 #include 
 #include 
 #include 
+#include 
+#include 
 #include 
 #include 
 #include 



commit digikam for openSUSE:Factory

2020-01-12 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2020-01-12 23:24:08

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.6675 (New)


Package is "digikam"

Sun Jan 12 23:24:08 2020 rev:186 rq:763631 version:6.4.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2019-11-30 
10:38:22.724165002 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new.6675/digikam.changes
2020-01-12 23:26:08.382855085 +0100
@@ -1,0 +2,7 @@
+Sat Jan 11 22:09:41 UTC 2020 - Fabian Vogt 
+
+- Add patches to fix build with OpenCV >= 4.2 (boo#1160721):
+  * fix-build-with-opencv-4.2.patch
+  * dlib-update-to-work-with-latest-version-of-OpenCV.patch
+
+---

New:

  dlib-update-to-work-with-latest-version-of-OpenCV.patch
  fix-build-with-opencv-4.2.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.d93h9l/_old  2020-01-12 23:26:12.006856425 +0100
+++ /var/tmp/diff_new_pack.d93h9l/_new  2020-01-12 23:26:12.030856433 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package digikam
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -30,6 +30,9 @@
 Patch0: 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
 # PATCH-FIX-OPENSUSE -- Lower minimum exiv2 version to 0.26
 Patch1: 0001-Revert-Exiv2-is-now-released-with-exported-targets-u.patch
+# PATCH-FIX-UPSTREAM
+Patch2: fix-build-with-opencv-4.2.patch
+Patch3: dlib-update-to-work-with-latest-version-of-OpenCV.patch
 BuildRequires:  QtAV-devel >= 1.12
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -179,6 +182,8 @@
 # Leap 15 only has exiv2 0.26
 %patch1 -p1
 %endif
+%patch2 -p1
+%patch3 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ dlib-update-to-work-with-latest-version-of-OpenCV.patch ++
>From 34dc7303045877226ebdd6cd07ce6384c0881eb8 Mon Sep 17 00:00:00 2001
From: Davis King 
Date: Sun, 22 Dec 2019 07:52:08 -0500
Subject: [PATCH] Fix opencv version check to work on all opencv versions

Index: 
digikam-6.4.0/core/libs/facesengine/recognition/dlib-dnn/dnnface/dnn_base/cv_image.h
===
--- 
digikam-6.4.0.orig/core/libs/facesengine/recognition/dlib-dnn/dnnface/dnn_base/cv_image.h
+++ 
digikam-6.4.0/core/libs/facesengine/recognition/dlib-dnn/dnnface/dnn_base/cv_image.h
@@ -52,7 +52,16 @@ public:
  << "\n\t img.channels(): " << img.channels()
  << "\n\t img.pixel_traits::num: " << 
pixel_traits::num
  );
+// Note, do NOT use CV_VERSION_MAJOR because in OpenCV 2 CV_VERSION_MAJOR 
actually held
+// CV_VERSION_MINOR and instead they used CV_VERSION_EPOCH.  So for example, 
in OpenCV
+// 2.4.9.1 CV_VERSION_MAJOR==4 and CV_VERSION_EPOCH==2.  However, 
CV_MAJOR_VERSION has always
+// (seemingly) held the actual major version number, so we use that to test 
for the OpenCV major
+// version.
+#if CV_MAJOR_VERSION > 3
+   IplImage temp = cvIplImage(img);
+#else
 IplImage temp = img;
+#endif
 init();
 }
 
++ fix-build-with-opencv-4.2.patch ++
>From cff33fbc9c7c69f92be990cef0f19e63ac1f7654 Mon Sep 17 00:00:00 2001
From: Antonio Rojas 
Date: Sat, 21 Dec 2019 14:46:46 +0100
Subject: [PATCH] Fix build with opencv 4.2

Port away from old API which is removed in 4.2

Differential Revision: https://phabricator.kde.org/D26143
---
 .../facesengine/detection/opencv-face/opencvfacedetector_p.cpp  | 2 +-
 .../facesengine/detection/opencv-face/opencvfacedetector_p.h| 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Index: digikam-6.4.0/core/libs/facesengine/detection/opencvfacedetector.cpp
===
--- digikam-6.4.0.orig/core/libs/facesengine/detection/opencvfacedetector.cpp
+++ digikam-6.4.0/core/libs/facesengine/detection/opencvfacedetector.cpp
@@ -166,7 +166,7 @@ public:
  * of the region of interest of this cascade (still relative to whole 
image).
  * For frontal face cascades, returns the given parameter unchanged.
  */
-cv::Rect faceROI(const CvRect& faceRect) const
+cv::Rect faceROI(const cv::Rect& faceRect) const
 {
 return cv::Rect(lround(faceRect.x + roi.x()  * faceRect.width),
 

commit digikam for openSUSE:Factory

2019-11-30 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2019-11-30 10:37:12

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.26869 (New)


Package is "digikam"

Sat Nov 30 10:37:12 2019 rev:185 rq:750428 version:6.4.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2019-10-02 
14:55:45.115309018 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.26869/digikam.changes   
2019-11-30 10:38:22.724165002 +0100
@@ -1,0 +2,31 @@
+Thu Nov 21 21:38:08 UTC 2019 - wba...@tmo.at
+
+- Add patch to make it build with exiv2 0.26 on Leap 15:
+  * 0001-Revert-Exiv2-is-now-released-with-exported-targets-u.patch
+  (boo#1156937)
+- Update to latest upstream 6.4.0 source tarball
+
+---
+Sat Nov  9 23:41:23 UTC 2019 - wba...@tmo.at
+
+- Update to 6.4.0
+  * https://www.digikam.org/news/2019-11-09-6.4.0_release_announcement/
+- New features (from NEWS):
+General: new RawImport plugin interface to delegate Raw
+ decoding function to extra engine with ImageEditor.
+General: new DImg plugin interface to externalize image loaders
+ from core implementation.
+General: new HEIC image loader compatible with media generated
+ by Apple devices.
+Import : add new option to convert on the fly to HEIC lossless
+ format while downloading.
+ImageEditor: add new setting from setup dialog to select right Raw
+ Import plugin.
+ImageEditor: add new clone tool to fix artifacts on image.
+ImageEditor: add new tool to import RAW image using UFRaw.
+ImageEditor: add new tool to import RAW image using RawTherapee.
+ImageEditor: add new tool to import RAW image using DarkTable.
+BQM: add new tool to convert to HEIC format.
+- 75 bugs fixed
+
+---

Old:

  digikam-6.3.0.tar.xz

New:

  0001-Revert-Exiv2-is-now-released-with-exported-targets-u.patch
  digikam-6.4.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.9yTxXR/_old  2019-11-30 10:38:31.168163987 +0100
+++ /var/tmp/diff_new_pack.9yTxXR/_new  2019-11-30 10:38:31.172163987 +0100
@@ -19,15 +19,17 @@
 %define soversion 6
 %bcond_without lang
 Name:   digikam
-Version:6.3.0
+Version:6.4.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0-or-later
 Group:  Productivity/Graphics/Viewers
-URL:http://www.digikam.org/
-Source0:
http://download.kde.org/stable/%{name}/%{version}/%{name}-%{version}.tar.xz
+URL:https://www.digikam.org/
+Source0:
https://download.kde.org/stable/%{name}/%{version}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch 
-- The OpenGL slideshow depends on Desktop GL, see kde#383715
 Patch0: 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
+# PATCH-FIX-OPENSUSE -- Lower minimum exiv2 version to 0.26
+Patch1: 0001-Revert-Exiv2-is-now-released-with-exported-targets-u.patch
 BuildRequires:  QtAV-devel >= 1.12
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -173,6 +175,10 @@
 # Disable OpenGL slideshow on embedded platforms
 %patch0 -p1
 %endif
+%if 0%{?suse_version} <= 1500
+# Leap 15 only has exiv2 0.26
+%patch1 -p1
+%endif
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ 0001-Revert-Exiv2-is-now-released-with-exported-targets-u.patch ++
>From 64454b942be9c61f3c981f7a18a77b332944d58a Mon Sep 17 00:00:00 2001
From: Wolfgang Bauer 
Date: Tue, 12 Nov 2019 11:15:21 +0100
Subject: [PATCH] Revert "Exiv2 is now released with exported targets using
 cmake rules. No need to have a dedicated find exiv2 cmake script. Bump
 minimal version to 0.27.1"

This reverts commit 06e77271d72fe5e4abeb38641f3addc2cfbff126.

Fixes build on Leap 15.x which only have exiv2 0.26.
As there haven't been any changes other than to rely on the new cmake
files in exiv2 0.27, there should be no problems with the older version.
---
 core/CMakeLists.txt |  14 +--
 core/app/DigikamCoreTarget.cmake|   2 +-
 core/cmake/modules/FindExiv2.cmake  | 116 
 core/libs/metadataengine/CMakeLists.txt |  10 ++-
 4 files changed, 126 insertions(+), 16 deletions(-)
 create mode 100644 core/cmake/modules/FindExiv2.cmake

diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index e31e267772..d14364dc1e 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ 

commit digikam for openSUSE:Factory

2019-10-02 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2019-10-02 14:55:43

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.2352 (New)


Package is "digikam"

Wed Oct  2 14:55:43 2019 rev:184 rq:734483 version:6.3.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2019-09-18 
13:10:20.724703713 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.2352/digikam.changes
2019-10-02 14:55:45.115309018 +0200
@@ -1,0 +2,5 @@
+Tue Oct  1 13:07:53 UTC 2019 - Michel Normand 
+
+- Do not enable Faces Engine DNN for ppc64le to avoid build error
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.Qc2bOj/_old  2019-10-02 14:55:50.195295690 +0200
+++ /var/tmp/diff_new_pack.Qc2bOj/_new  2019-10-02 14:55:50.199295679 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -110,11 +110,15 @@
 Obsoletes:  %{name}-doc < %{version}
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %{ix86} x86_64 %{arm} aarch64 mips mips64
+%global qwebengine -DENABLE_QWEBENGINE:BOOL=ON
 BuildRequires:  akonadi-contact-devel
 BuildRequires:  pkgconfig(Qt5WebEngineWidgets)
 %else
 BuildRequires:  pkgconfig(Qt5WebKitWidgets)
 %endif
+%ifarch ppc64le
+%global facesengine -DENABLE_FACESENGINE_DNN:BOOL=OFF
+%endif
 %if 0%{?suse_version} < 1320
 # It does not build with the default compiler (GCC 4.8) on Leap 42.x
 BuildRequires:  gcc7-c++
@@ -183,11 +187,7 @@
 export CC=gcc-7
 export CXX=g++-7
 %endif
-%ifarch %{ix86} x86_64 %{arm} aarch64 mips mips64
-%cmake_kf5 -d build -- -DENABLE_APPSTYLES=ON -DENABLE_MEDIAPLAYER=ON 
-DENABLE_QWEBENGINE=ON
-%else
-%cmake_kf5 -d build -- -DENABLE_APPSTYLES=ON -DENABLE_MEDIAPLAYER=ON
-%endif
+%cmake_kf5 -d build -- -DENABLE_APPSTYLES=ON -DENABLE_MEDIAPLAYER=ON 
%{?qwebengine} %{?facesengine}
 %make_jobs VERBOSE=1
 
 %install




commit digikam for openSUSE:Factory

2019-09-18 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2019-09-18 13:09:51

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.7948 (New)


Package is "digikam"

Wed Sep 18 13:09:51 2019 rev:183 rq:731091 version:6.3.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2019-08-22 
10:53:54.805687477 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.7948/digikam.changes
2019-09-18 13:10:20.724703713 +0200
@@ -1,0 +2,13 @@
+Sun Sep 15 13:13:16 UTC 2019 - wba...@tmo.at
+
+- Update to 6.3.0
+  * https://www.digikam.org/news/2019-09-08-6.3.0_release_announcement/
+- New features (from NEWS):
+General: Internal Libraw updated to last stable 0.19.5.
+General: First version of exported DPlugin API for future
+ external contributions.
+ImageEditor: new external plugin based on GMicQt included in all
+ bundles (https://github.com/c-koi/gmic-qt)
+- 193 bugs fixed
+
+---

Old:

  digikam-6.2.0.tar.xz

New:

  digikam-6.3.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.oK3dCM/_old  2019-09-18 13:10:27.792702226 +0200
+++ /var/tmp/diff_new_pack.oK3dCM/_new  2019-09-18 13:10:27.796702225 +0200
@@ -19,7 +19,7 @@
 %define soversion 6
 %bcond_without lang
 Name:   digikam
-Version:6.2.0
+Version:6.3.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0-or-later
@@ -232,7 +232,9 @@
 
 %files devel
 %{_includedir}/digikam/
-%{_kf5_cmakedir}/digikam/
+%{_kf5_cmakedir}/DigikamCore/
+%{_kf5_cmakedir}/DigikamDatabase/
+%{_kf5_cmakedir}/DigikamGui/
 %{_kf5_libdir}/libdigikamcore.so
 %{_kf5_libdir}/libdigikamdatabase.so
 %{_kf5_libdir}/libdigikamgui.so

++ digikam-6.2.0.tar.xz -> digikam-6.3.0.tar.xz ++
/work/SRC/openSUSE:Factory/digikam/digikam-6.2.0.tar.xz 
/work/SRC/openSUSE:Factory/.digikam.new.7948/digikam-6.3.0.tar.xz differ: char 
15, line 1




commit digikam for openSUSE:Factory

2019-08-22 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2019-08-22 10:53:49

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.22127 (New)


Package is "digikam"

Thu Aug 22 10:53:49 2019 rev:182 rq:724968 version:6.2.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2019-08-09 
16:55:28.529438624 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.22127/digikam.changes   
2019-08-22 10:53:54.805687477 +0200
@@ -1,0 +2,7 @@
+Wed Aug 21 08:14:53 UTC 2019 - mvet...@suse.com
+
+- bsc#1144232 - Drop jasper dependency from Digikam:
+  Disable JPEG2000 support due to removal of jasper
+- Add BuildRequires libjpeg8 for regular JPEG support
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.8EhSDk/_old  2019-08-22 10:53:58.377686998 +0200
+++ /var/tmp/diff_new_pack.8EhSDk/_new  2019-08-22 10:53:58.377686998 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via https://bugs.opensuse.org/
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
 
@@ -53,7 +53,7 @@
 BuildRequires:  libeigen3-devel
 BuildRequires:  libexiv2-devel >= 0.26
 BuildRequires:  libexpat-devel
-BuildRequires:  libjasper-devel
+BuildRequires:  libjpeg8-devel
 BuildRequires:  libksane-devel >= 15.12.0
 BuildRequires:  liblcms2-devel
 BuildRequires:  liblqr-devel




commit digikam for openSUSE:Factory

2019-08-09 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2019-08-09 16:55:07

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.9556 (New)


Package is "digikam"

Fri Aug  9 16:55:07 2019 rev:181 rq:721993 version:6.2.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2019-05-02 
19:20:16.529737494 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.9556/digikam.changes
2019-08-09 16:55:28.529438624 +0200
@@ -1,0 +2,20 @@
+Mon Aug  5 15:19:28 UTC 2019 - wba...@tmo.at
+
+- Update to 6.2.0
+  * https://www.digikam.org/news/2019-08-04-6.2.0_release_announcement/
+- New features (from NEWS):
+IconView : HiDPI support for 4K screens.
+General  : Internal Libraw updated to last stable 0.19.3.
+   New camera supported:
+   Canon A560, FujiFilm X-T30, Nikon Coolpix A1000, Z6, Z7,
+   Olympus E-M1X, Sony ILCE-6400, Several dng files from
+   phones and drones.
+   Full camera List supported:
+   https://www.libraw.org/supported-cameras-snapshot-201903
+- 310 bugs fixed
+- Drop patches merged upstream:
+  * Fix-compilation-with-Qt-5.6.patch
+  * Fix-build-with-QtWebEngine-5.6.patch
+- Refresh 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
+
+---

Old:

  Fix-build-with-QtWebEngine-5.6.patch
  Fix-compilation-with-Qt-5.6.patch
  digikam-6.1.0.tar.xz

New:

  digikam-6.2.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.qMLOj5/_old  2019-08-09 16:55:33.485437436 +0200
+++ /var/tmp/diff_new_pack.qMLOj5/_new  2019-08-09 16:55:33.489437435 +0200
@@ -19,7 +19,7 @@
 %define soversion 6
 %bcond_without lang
 Name:   digikam
-Version:6.1.0
+Version:6.2.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0-or-later
@@ -28,10 +28,6 @@
 Source0:
http://download.kde.org/stable/%{name}/%{version}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch 
-- The OpenGL slideshow depends on Desktop GL, see kde#383715
 Patch0: 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
-# PATCH-FIX-UPSTREAM
-Patch1: Fix-compilation-with-Qt-5.6.patch
-# PATCH-FIX-UPSTREAM
-Patch2: Fix-build-with-QtWebEngine-5.6.patch
 BuildRequires:  QtAV-devel >= 1.12
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -173,8 +169,6 @@
 # Disable OpenGL slideshow on embedded platforms
 %patch0 -p1
 %endif
-%patch1 -p1
-%patch2 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch ++
--- /var/tmp/diff_new_pack.qMLOj5/_old  2019-08-09 16:55:33.501437432 +0200
+++ /var/tmp/diff_new_pack.qMLOj5/_new  2019-08-09 16:55:33.501437432 +0200
@@ -21,14 +21,14 @@
 index cd482ea..bc3772b 100644
 --- a/core/CMakeLists.txt
 +++ b/core/CMakeLists.txt
-@@ -318,7 +318,7 @@ find_package(Marble)
+@@ -323,7 +323,7 @@ find_package(Marble)
  find_package(PkgConfig)
  find_package(Jasper)   # For JPEG 2000 support.
  find_package(Eigen3)   # For Refocus tool.
 -find_package(OpenGL)   # For Presentation tool.
 +# find_package(OpenGL)   # For Presentation tool.
  
- find_package(ImageMagick COMPONENTS Magick++)  # For QImage loader fail 
back to ImageMagick codecs.
+ find_package(ImageMagick COMPONENTS Magick++ MagickCore)
  
 -- 
 2.14.0

++ digikam-6.1.0.tar.xz -> digikam-6.2.0.tar.xz ++
/work/SRC/openSUSE:Factory/digikam/digikam-6.1.0.tar.xz 
/work/SRC/openSUSE:Factory/.digikam.new.9556/digikam-6.2.0.tar.xz differ: char 
13, line 1




commit digikam for openSUSE:Factory

2019-05-02 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2019-05-02 19:20:04

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.5148 (New)


Package is "digikam"

Thu May  2 19:20:04 2019 rev:180 rq:699899 version:6.1.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2019-04-25 
16:20:33.626075329 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new.5148/digikam.changes
2019-05-02 19:20:16.529737494 +0200
@@ -1,0 +2,6 @@
+Mon Apr 29 08:37:34 UTC 2019 - wba...@tmo.at
+
+- Drop Lower-minimum-exiv2-version.patch, the latest digikam
+  version just crashes on start with exiv2-0.25 (kde#407022)
+
+---

Old:

  Lower-minimum-exiv2-version.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.lYYdoU/_old  2019-05-02 19:20:21.465746528 +0200
+++ /var/tmp/diff_new_pack.lYYdoU/_new  2019-05-02 19:20:21.465746528 +0200
@@ -28,12 +28,10 @@
 Source0:
http://download.kde.org/stable/%{name}/%{version}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch 
-- The OpenGL slideshow depends on Desktop GL, see kde#383715
 Patch0: 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
-# PATCH-FIX-OPENSUSE
-Patch1: Lower-minimum-exiv2-version.patch
 # PATCH-FIX-UPSTREAM
-Patch2: Fix-compilation-with-Qt-5.6.patch
+Patch1: Fix-compilation-with-Qt-5.6.patch
 # PATCH-FIX-UPSTREAM
-Patch3: Fix-build-with-QtWebEngine-5.6.patch
+Patch2: Fix-build-with-QtWebEngine-5.6.patch
 BuildRequires:  QtAV-devel >= 1.12
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -57,7 +55,7 @@
 BuildRequires:  lensfun
 BuildRequires:  lensfun-devel
 BuildRequires:  libeigen3-devel
-BuildRequires:  libexiv2-devel >= 0.25
+BuildRequires:  libexiv2-devel >= 0.26
 BuildRequires:  libexpat-devel
 BuildRequires:  libjasper-devel
 BuildRequires:  libksane-devel >= 15.12.0
@@ -175,11 +173,8 @@
 # Disable OpenGL slideshow on embedded platforms
 %patch0 -p1
 %endif
-%if 0%{?suse_version} < 1320
 %patch1 -p1
-%endif
 %patch2 -p1
-%patch3 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')




commit digikam for openSUSE:Factory

2019-04-25 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2019-04-25 16:20:20

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.5536 (New)


Package is "digikam"

Thu Apr 25 16:20:20 2019 rev:179 rq:697163 version:6.1.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2019-03-26 
15:38:53.752337132 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new.5536/digikam.changes
2019-04-25 16:20:33.626075329 +0200
@@ -1,0 +2,38 @@
+Tue Apr 16 10:00:11 UTC 2019 - wba...@tmo.at
+
+- Update to 6.1.0
+  * https://www.digikam.org/news/2019-04-14-6.1.0_release_announcement/
+- New features (from NEWS):
+General : New plugins interface for digiKam and Showfoto named
+  dplugins.
+General : All export tools become generic plugins and are
+  shared with Showfoto.
+General : Update internal libpgf to last 07193.
+General : Add compatiblity with OpenCV version 4.
+General : MacOS and AppImage bundles are now published with Qt
+  5.11.3.
+General : Add new optional configuration option to compile with
+  Faces Engine Neural Network.
+General : Add optional support to ImageMagick codecs to support
+  extra image formats as XCF, FITS, HEIC, etc.
+BQM : Add new advanced settings in resize tool.
+BQM : All Batch Queue Manager tools become Bqm plugins.
+Editor  : All Image Editor tools become Editor plugins and are
+  shared with Showfoto.
+Item View   : Add sort items by modification date.
+DPlugin : New plugin to copy items to a local storage.
+DPlugin : New plugin to set image as Linux desktop wallpaper.
+- 138 bugs fixed
+- Add digikam-devel subpackage
+- Add digikam-plugins subpackage that contains all the plugins
+- Move plugins' icons to the -plugins subpackage
+- Move enblend-enfuse and hugin Recommends to the -plugins package
+  as the functionality has been moved to the plugins
+- Add pkgconfig(Magic++) BuildRequires to enable the new
+  ImageMagick support
+- Add patches to fix build on Leap 42.3:
+  * Fix-compilation-with-Qt-5.6.patch
+  * Fix-build-with-QtWebEngine-5.6.patch
+- Refresh 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
+
+---

Old:

  digikam-6.0.0.tar.xz

New:

  Fix-build-with-QtWebEngine-5.6.patch
  Fix-compilation-with-Qt-5.6.patch
  digikam-6.1.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.pLHZim/_old  2019-04-25 16:20:40.942074034 +0200
+++ /var/tmp/diff_new_pack.pLHZim/_new  2019-04-25 16:20:40.942074034 +0200
@@ -19,7 +19,7 @@
 %define soversion 6
 %bcond_without lang
 Name:   digikam
-Version:6.0.0
+Version:6.1.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0-or-later
@@ -30,6 +30,10 @@
 Patch0: 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
 # PATCH-FIX-OPENSUSE
 Patch1: Lower-minimum-exiv2-version.patch
+# PATCH-FIX-UPSTREAM
+Patch2: Fix-compilation-with-Qt-5.6.patch
+# PATCH-FIX-UPSTREAM
+Patch3: Fix-build-with-QtWebEngine-5.6.patch
 BuildRequires:  QtAV-devel >= 1.12
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -83,16 +87,16 @@
 BuildRequires:  cmake(Qt5X11Extras)
 BuildRequires:  cmake(Qt5Xml)
 BuildRequires:  cmake(Qt5XmlPatterns)
+BuildRequires:  pkgconfig(Magick++)
 BuildRequires:  pkgconfig(libavcodec)
 BuildRequires:  pkgconfig(libavfilter)
 BuildRequires:  pkgconfig(libavformat)
 BuildRequires:  pkgconfig(libavutil)
 BuildRequires:  pkgconfig(libgphoto2) >= 2.4.0
 BuildRequires:  pkgconfig(libswscale)
+Requires:   %{name}-plugins
 Requires:   libQt5Sql5-sqlite
 Recommends: %{name}-lang
-Recommends: enblend-enfuse
-Recommends: hugin
 Recommends: marble
 Recommends: showfoto
 # Got merged into libimageeditor in 5.2.0
@@ -130,6 +134,23 @@
 that enables you to connect to your camera and preview, download, or
 delete your images, is provided.
 
+%package plugins
+Summary:DigiKam plugins
+Group:  Productivity/Graphics/Viewers
+Recommends: enblend-enfuse
+Recommends: hugin
+
+%description plugins
+Additional plugins for digiKam.
+
+%package devel
+Summary:DigiKam development files
+Group:  Development/Libraries/KDE
+Requires:   libdigikamcore%{soversion} = %{version}
+
+%description devel
+Development headers and libraries for digiKam.
+
 %package -n showfoto
 Summary:DigiKam: Showfoto
 Group:  Productivity/Graphics/Viewers
@@ -141,6 +162,7 @@
 %package -n libdigikamcore%{soversion}
 Summary:  

commit digikam for openSUSE:Factory

2019-03-26 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2019-03-26 15:38:37

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.25356 (New)


Package is "digikam"

Tue Mar 26 15:38:37 2019 rev:178 rq:679901 version:6.0.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2019-01-03 
18:09:43.391973554 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new.25356/digikam.changes   
2019-03-26 15:38:53.752337132 +0100
@@ -1,0 +2,101 @@
+Fri Feb 22 15:56:21 UTC 2019 - wba...@tmo.at
+
+- Update to 6.0.0
+  * https://www.digikam.org/news/2019-02-10-6.0.0_release_announcement/
+- New features (from NEWS):
+ImageEditor  : Add Web services Import and Export tools.
+Showfoto : Add Web services Import and Export tools.
+LightTable   : Add Web services Import and Export tools.
+Database : Similarity database has been moved to a dedicated file
+   to not bloat core database with computed finger-prints.
+   This will speed-up query in core database in case of
+   Similarity feature is used.
+Database : New video metadata parser based on ffmpeg to populate
+   database.
+Search   : Add video support to find files based on properties
+   registered on database.
+General  : Add new Exiv2 0.27 support.
+General  : Add new Lensfun 0.4 support.
+General  : Use DrMinGW has crash handler under Windows.
+General  : Port all export/import tool to OAuth2 authentification.
+General  : New tool to adjust quickly time and date information
+   from items. Tool will be available in AlbumView,
+   ImageEditor, LightTable, and Showfoto.
+General  : New function to group images by timelapse / burst
+General  : New tool to export to Pinterest social network.
+General  : New tool to export to OneDrive webservice.
+General  : New tool to export to Box webservice.
+General  : New tool to export to Ipfs webservice.
+General  : All bundles use last Lenfun 0.3.95 to process
+   automatic lens correction.
+General  : Add QWebEngine support.
+General  : Fix all Krazy static analyzer reports.
+General  : Update internal Libraw to last 0.19.2.
+   New camera supported:
+   * Apple: Phone 8, iPhone 8 plus, iPhone X
+   * BlackMagic: URSA Mini 4k, URSA Mini 4.6k, URSA Mini Pro 4.6k
+   * Canon: PowerShot A410, A540, D10, ELPH 130 IS, ELPH 160 IS,
+SD750, SX100 IS,SX130 IS, SX160 IS, SX510 HS,
+SX10 IS, IXUS 900Ti, PowerShot G1 X Mark III,
+G9 X Mark II, EOS 6D Mark II, EOS 77D, EOS 200D,
+EOS 800D, EOS M6, EOS M100
+   * Casio: EX-ZR4100/5100
+   * DJI: Phantom4 Pro/Pro+, Zenmuse X5, Zenmuse X5R
+   * FujiFilm: S6500fd, GFX 50S, X100f, X-A3, X-A5, X-A10, X-A20,
+   X-E3, X-H1, X-T20
+   * Hasselblad: H6D-100c, A6D-100c
+   * Huawei: P9 (EVA-L09/AL00), Honor6a, Honor9, Mate10 (BLA-L29)
+   * Leica: CL, M10, TL2
+   * LG: V20 (F800K), VS995
+   * Nikon: D850, D5600, D7500, Coolpix B700
+   * Olympus: E-PL9, E-M10 Mark III, TG-5
+   * OnePlus: A3303, A5000
+   * Panasonic: DMC-FZ45, DMC-FZ72, DC-FZ80/82, DC-G9 (std. res 
mode only),
+DC-GF10/GF90, DC-GH5, DC-GX9, DC-GX800/850/GF9,
+DMC-LX1, DC-ZS70 (DC-TZ90/91/92, DC-T93),
+DC-TZ100/101/ZS100, DC-TZ200/ZS200
+   * PARROT: Bebop 2, Bebop Drone
+   * Pentax: KP
+   * PhaseOne: IQ3 100MP Trichromatic
+   * Samsung: Galaxy Nexus, Galaxy S3, S6 (SM-G920F), S7, S7 Edge,
+  S8 (SM-G950U)
+   * Sony: A7R III, A9, DSC-RX0, DSC-RX10IV
+   * Yi: M1
+   * YUNEEC: CGO3, CGO3P
+   * Xiaoyi: YIAC3 (YI 4k)
+Collection   : Add tool button to update an existing collection to the new
+   drive or path.
+Tags : Add possibility to merge tags by drag & drop.
+IconView : Add capability to re-organize the contents manually.
+IconView : Add capability to separate the contents by month.
+HTML Gallery : New Vanilla theme to emulate export to HTML from Adobe 
LightRoom.
+HTML Gallery : New Blue Frame theme.
+HTML Gallery : New Kiosk-Mode theme.
+- 630 bugs fixed
+- Drop patches merged upstream:
+  * Add-QtWebEngine-support.patch
+  * fix-black-Welcome-page-by-clicking-on-a-link.patch
+  * add-support-for-Exiv2-0.27.patch
+  * be-compatible-with-backward-0.26.patch
+  * 

commit digikam for openSUSE:Factory

2019-01-03 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2019-01-03 18:09:41

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.28833 (New)


Package is "digikam"

Thu Jan  3 18:09:41 2019 rev:177 rq:662612 version:5.9.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-12-03 
10:12:46.043576973 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new.28833/digikam.changes   
2019-01-03 18:09:43.391973554 +0100
@@ -1,0 +2,11 @@
+Wed Jan  2 12:21:09 UTC 2019 - wba...@tmo.at
+
+- Add upstream git commits to fix build with exiv2-0.27:
+  * add-support-for-Exiv2-0.27.patch
+  * be-compatible-with-backward-0.26.patch
+  * adjust-find-cmake-script-to-exiv2-0.27-RC1.patch
+  * first-patch-to-be-compatible-with-Exiv2-0.27.patch
+  * f27ab9c1051bd0a0.patch
+  * fix-compile.patch
+
+---

New:

  add-support-for-Exiv2-0.27.patch
  adjust-find-cmake-script-to-exiv2-0.27-RC1.patch
  be-compatible-with-backward-0.26.patch
  f27ab9c1051bd0a0.patch
  first-patch-to-be-compatible-with-Exiv2-0.27.patch
  fix-compile.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.HsfYB4/_old  2019-01-03 18:09:46.743970144 +0100
+++ /var/tmp/diff_new_pack.HsfYB4/_new  2019-01-03 18:09:46.775970111 +0100
@@ -36,6 +36,13 @@
 Patch4: Add-QtWebEngine-support.patch
 # PATCH-FIX-UPSTREAM
 Patch5: fix-black-Welcome-page-by-clicking-on-a-link.patch
+# PATCH-FIX-UPSTREAM -- fix build with exiv2-0.27
+Patch6: add-support-for-Exiv2-0.27.patch
+Patch7: be-compatible-with-backward-0.26.patch
+Patch8: adjust-find-cmake-script-to-exiv2-0.27-RC1.patch
+Patch9: first-patch-to-be-compatible-with-Exiv2-0.27.patch
+Patch10:f27ab9c1051bd0a0.patch
+Patch11:fix-compile.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -192,6 +199,12 @@
 %endif
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ add-support-for-Exiv2-0.27.patch ++
>From cb808f574248a0c96894338fdcf03b12fbbc080d Mon Sep 17 00:00:00 2001
From: Gilles Caulier 
Date: Sun, 7 Oct 2018 10:17:30 +0200
Subject: add support of Exiv2 0.27

---
 core/cmake/modules/FindExiv2.cmake | 75 +++---
 1 file changed, 53 insertions(+), 22 deletions(-)

diff --git a/core/cmake/modules/FindExiv2.cmake 
b/core/cmake/modules/FindExiv2.cmake
index 1e971a3..02d2943 100644
--- a/core/cmake/modules/FindExiv2.cmake
+++ b/core/cmake/modules/FindExiv2.cmake
@@ -1,7 +1,7 @@
 # - Try to find the Exiv2 library
 #
 #  EXIV2_MIN_VERSION - You can set this variable to the minimum version you 
need
-#  before doing FIND_PACKAGE(Exiv2). The default is 0.15.
+#  before doing FIND_PACKAGE(Exiv2). The default is 0.26.
 #
 # Once done this will define
 #
@@ -11,34 +11,41 @@
 #  EXIV2_DEFINITIONS - Compiler switches required for using libexiv2
 #
 # The minimum required version of Exiv2 can be specified using the
-# standard syntax, e.g. find_package(Exiv2 0.17)
+# standard syntax, e.g. find_package(Exiv2 0.26)
 #
 # For compatibility, also the variable EXIV2_MIN_VERSION can be set to the 
minimum version
-# you need before doing FIND_PACKAGE(Exiv2). The default is 0.15.
+# you need before doing FIND_PACKAGE(Exiv2). The default is 0.26.
 #
 # Copyright (c) 2010,  Alexander Neundorf, 
-# Copyright (c) 2008-2017, Gilles Caulier, 
+# Copyright (c) 2008-2018, Gilles Caulier, 
 #
 # Redistribution and use is allowed according to the terms of the BSD license.
 # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
 
 # Support EXIV2_MIN_VERSION for compatibility:
+
 if(NOT Exiv2_FIND_VERSION)
-  set(Exiv2_FIND_VERSION "${EXIV2_MIN_VERSION}")
-endif(NOT Exiv2_FIND_VERSION)
 
-# the minimum version of exiv2 we require
+set(Exiv2_FIND_VERSION "${EXIV2_MIN_VERSION}")
+
+endif()
+
+# The minimum version of exiv2 we require
 if(NOT Exiv2_FIND_VERSION)
-  set(Exiv2_FIND_VERSION "0.15")
-endif(NOT Exiv2_FIND_VERSION)
 
-if (NOT WIN32)
+set(Exiv2_FIND_VERSION "0.26")
+
+endif()
+
+if(NOT WIN32)
+
# use pkg-config to get the directories and then use these values
# in the FIND_PATH() and FIND_LIBRARY() calls
find_package(PkgConfig)
pkg_check_modules(PC_EXIV2 QUIET exiv2)
set(EXIV2_DEFINITIONS 

commit digikam for openSUSE:Factory

2018-12-03 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-12-03 10:12:34

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new.19453 (New)


Package is "digikam"

Mon Dec  3 10:12:34 2018 rev:176 rq:653431 version:5.9.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-11-01 
14:45:38.802869858 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new.19453/digikam.changes   
2018-12-03 10:12:46.043576973 +0100
@@ -1,0 +2,7 @@
+Sat Dec  1 22:42:22 UTC 2018 - wba...@tmo.at
+
+- Add fix-black-Welcome-page-by-clicking-on-a-link.patch to fix
+  the Welcome page getting black when clicking on a link that opens
+  a new browser window (with QtWebEngine)
+
+---

New:

  fix-black-Welcome-page-by-clicking-on-a-link.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.3Tv8hW/_old  2018-12-03 10:12:49.175574067 +0100
+++ /var/tmp/diff_new_pack.3Tv8hW/_new  2018-12-03 10:12:49.179574063 +0100
@@ -34,6 +34,8 @@
 Patch3: Lower-minimum-exiv2-version.patch
 # PATCH-FEATURE-UPSTREAM
 Patch4: Add-QtWebEngine-support.patch
+# PATCH-FIX-UPSTREAM
+Patch5: fix-black-Welcome-page-by-clicking-on-a-link.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -189,6 +191,7 @@
 %patch3 -p1
 %endif
 %patch4 -p1
+%patch5 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ fix-black-Welcome-page-by-clicking-on-a-link.patch ++
>From 60721615dd9af2b81dacce06adaa7e31d56eee32 Mon Sep 17 00:00:00 2001
From: Maik Qualmann 
Date: Sat, 1 Dec 2018 16:34:41 +0100
Subject: fix black Welcome page by clicking on a link REVIEW: D17276

---
 core/app/views/welcomepageview_qwebengine.cpp | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/core/app/views/welcomepageview_qwebengine.cpp 
b/core/app/views/welcomepageview_qwebengine.cpp
index 2dfe2c6..d4ee8c5 100644
--- a/core/app/views/welcomepageview_qwebengine.cpp
+++ b/core/app/views/welcomepageview_qwebengine.cpp
@@ -115,7 +115,7 @@ WelcomePageView::~WelcomePageView()
 
 void WelcomePageView::slotUrlOpen(const QUrl& url)
 {
-WebBrowserDlg* const browser = new WebBrowserDlg(url, this);
+WebBrowserDlg* const browser = new WebBrowserDlg(url, 
qApp->activeWindow());
 browser->show();
 }
 
-- 
cgit v0.11.2




commit digikam for openSUSE:Factory

2018-11-02 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-11-01 14:45:33

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Thu Nov  1 14:45:33 2018 rev:175 rq:645877 version:5.9.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-10-31 
13:22:15.847011302 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-11-01 
14:45:38.802869858 +0100
@@ -1,0 +2,10 @@
+Wed Oct 31 16:48:54 UTC 2018 - wba...@tmo.at
+
+- Add Add-QtWebEngine-support.patch to allow building with
+  QtWebEngine instead of QtWebKit
+- Use QtWebEngine on platforms where it is available
+- Add some necessary build requirements to avoid relying on other
+  packages pulling them in
+- Remove unused libqca-qt5-devel BuildRequires
+
+---

New:

  Add-QtWebEngine-support.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.vlNPvd/_old  2018-11-01 14:45:41.250869608 +0100
+++ /var/tmp/diff_new_pack.vlNPvd/_new  2018-11-01 14:45:41.254869609 +0100
@@ -32,9 +32,14 @@
 Patch2: 0002-Revert-replace-obsolete-qSort-function.patch
 # PATCH-FIX-OPENSUSE
 Patch3: Lower-minimum-exiv2-version.patch
+# PATCH-FEATURE-UPSTREAM
+Patch4: Add-QtWebEngine-support.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
+BuildRequires:  pkgconfig(Qt5WebEngineWidgets)
+%else
+BuildRequires:  pkgconfig(Qt5WebKitWidgets)
 %endif
 BuildRequires:  QtAV-devel >= 1.12
 BuildRequires:  bison
@@ -44,9 +49,19 @@
 BuildRequires:  flex
 BuildRequires:  graphviz-devel
 BuildRequires:  gtk2-devel
+BuildRequires:  karchive-devel
+BuildRequires:  kconfig-devel
+BuildRequires:  kcoreaddons-devel
+BuildRequires:  kdoctools-devel
 BuildRequires:  kfilemetadata5-devel
 BuildRequires:  ki18n-devel
+BuildRequires:  kiconthemes-devel
+BuildRequires:  kio-devel
+BuildRequires:  knotifications-devel
 BuildRequires:  knotifyconfig-devel
+BuildRequires:  kservice-devel
+BuildRequires:  kwindowsystem-devel
+BuildRequires:  kxmlgui-devel
 BuildRequires:  lensfun
 BuildRequires:  lensfun-devel
 BuildRequires:  libeigen3-devel
@@ -63,23 +78,26 @@
 BuildRequires:  libmysqlclient-devel
 BuildRequires:  libmysqld-devel
 BuildRequires:  libpgf-devel
-BuildRequires:  libqca-qt5-devel
 BuildRequires:  libtiff-devel
 BuildRequires:  libusb-devel
 BuildRequires:  marble-devel
 BuildRequires:  mysql
 BuildRequires:  opencv-devel
+BuildRequires:  solid-devel
 BuildRequires:  threadweaver-devel >= 5.1.0
 BuildRequires:  update-desktop-files
 BuildRequires:  cmake(KF5CalendarCore)
 BuildRequires:  pkgconfig(Qt5Concurrent)
 BuildRequires:  pkgconfig(Qt5Core) >= 5.6.0
+BuildRequires:  pkgconfig(Qt5DBus)
+BuildRequires:  pkgconfig(Qt5Network)
 BuildRequires:  pkgconfig(Qt5OpenGL)
+BuildRequires:  pkgconfig(Qt5PrintSupport)
 BuildRequires:  pkgconfig(Qt5Sql)
 BuildRequires:  pkgconfig(Qt5Svg)
 BuildRequires:  pkgconfig(Qt5Test)
-BuildRequires:  pkgconfig(Qt5WebKitWidgets)
 BuildRequires:  pkgconfig(Qt5X11Extras)
+BuildRequires:  pkgconfig(Qt5Xml)
 BuildRequires:  pkgconfig(Qt5XmlPatterns)
 BuildRequires:  pkgconfig(libgphoto2) >= 2.4.0
 Requires:   kipi-plugins >= %{version}
@@ -170,6 +188,7 @@
 %patch2 -p1
 %patch3 -p1
 %endif
+%patch4 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
@@ -183,7 +202,11 @@
 rm -f po/*/kipiplugin_vkontakte.po
 
 %build
+%ifarch %ix86 x86_64 %arm aarch64 mips mips64
+%cmake_kf5 -d build -- -DENABLE_APPSTYLES=ON -DENABLE_MEDIAPLAYER=ON 
-DENABLE_QWEBENGINE=ON
+%else
 %cmake_kf5 -d build -- -DENABLE_APPSTYLES=ON -DENABLE_MEDIAPLAYER=ON
+%endif
 %make_jobs VERBOSE=1
 
 %install

++ Add-QtWebEngine-support.patch ++
 1727 lines (skipped)




commit digikam for openSUSE:Factory

2018-10-31 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-10-31 13:21:55

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Wed Oct 31 13:21:55 2018 rev:174 rq:645711 version:5.9.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-10-18 
15:40:11.334034335 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-10-31 
13:22:15.847011302 +0100
@@ -1,0 +2,11 @@
+Tue Oct 30 13:17:52 UTC 2018 - wba...@tmo.at
+
+- Add Lower-minimum-exiv2-version.patch to make it build on Leap
+  42.3
+- Remove some build requirements that are not used anymore since a
+  long time
+- Remove unnecessary ENABLE_OPENCV3 and ENABLE_MYSQLSUPPORT cmake
+  options, they are ON by default since 5.7.0
+- Remove obsolete ENABLE_LCMS2 option, LCMS2 is mandatory since 5.0
+
+---

New:

  Lower-minimum-exiv2-version.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.QlNSG3/_old  2018-10-31 13:22:18.315009007 +0100
+++ /var/tmp/diff_new_pack.QlNSG3/_new  2018-10-31 13:22:18.319009003 +0100
@@ -30,12 +30,13 @@
 Patch1: 0001-Revert-replace-obsolete-qSort-function.patch
 # PATCH-FIX-OPENSUSE
 Patch2: 0002-Revert-replace-obsolete-qSort-function.patch
+# PATCH-FIX-OPENSUSE
+Patch3: Lower-minimum-exiv2-version.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
 %endif
-BuildRequires:  QtAV-devel >= 1.11
-BuildRequires:  baloo5-devel
+BuildRequires:  QtAV-devel >= 1.12
 BuildRequires:  bison
 BuildRequires:  boost-devel
 BuildRequires:  doxygen
@@ -44,21 +45,16 @@
 BuildRequires:  graphviz-devel
 BuildRequires:  gtk2-devel
 BuildRequires:  kfilemetadata5-devel
-BuildRequires:  khtml-devel
 BuildRequires:  ki18n-devel
-BuildRequires:  kitemmodels-devel
 BuildRequires:  knotifyconfig-devel
 BuildRequires:  lensfun
 BuildRequires:  lensfun-devel
 BuildRequires:  libeigen3-devel
-BuildRequires:  libexiv2-devel >= 0.26
+BuildRequires:  libexiv2-devel >= 0.25
 BuildRequires:  libexpat-devel
 BuildRequires:  libgcrypt-devel
 BuildRequires:  libgpod-devel
 BuildRequires:  libjasper-devel
-BuildRequires:  libkdcraw-devel >= 15.12.0
-BuildRequires:  libkexiv2-devel >= 15.12.0
-BuildRequires:  libkgeomap-devel > 15.12.0
 BuildRequires:  libkipi-devel >= 16.04.0
 BuildRequires:  libksane-devel >= 15.12.0
 BuildRequires:  liblcms2-devel
@@ -172,6 +168,7 @@
 %if 0%{?suse_version} < 1320
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 %endif
 
 # Remove build time references so build-compare can do its work
@@ -186,14 +183,7 @@
 rm -f po/*/kipiplugin_vkontakte.po
 
 %build
-%if 0%{?suse_version} < 1320 && !0%{?is_opensuse}
-EXTRA_FLAGS="-DENABLE_LCMS2=OFF"
-%else
-EXTRA_FLAGS="-DENABLE_LCMS2=ON"
-%endif
-
-%cmake_kf5 -d build -- -DENABLE_APPSTYLES=ON -DENABLE_MYSQLSUPPORT=on 
-DENABLE_OPENCV3=ON -DENABLE_MEDIAPLAYER=ON
-
+%cmake_kf5 -d build -- -DENABLE_APPSTYLES=ON -DENABLE_MEDIAPLAYER=ON
 %make_jobs VERBOSE=1
 
 %install

++ Lower-minimum-exiv2-version.patch ++
>From c50103269935cf74beae646dd0da1c7ec003f430 Mon Sep 17 00:00:00 2001
From: Wolfgang Bauer 
Date: Tue, 30 Oct 2018 14:12:36 +0100
Subject: [PATCH] Lower minimum exiv2 version

Digikam compiles fine with exiv2 0.25 as well, so make it accept that
version to be able to build it on openSUSE Leap 42.3.
---
 core/CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 041865ffcc..4518ea1815 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -58,7 +58,7 @@ set(QT_MIN_VERSION   "5.6.0")
 set(KIPI_MIN_VERSION "5.0.0")
 set(KSANE_MIN_VERSION"5.0.0")
 set(LENSFUN_MIN_VERSION  "0.2.6.0")
-set(EXIV2_MIN_VERSION"0.26")
+set(EXIV2_MIN_VERSION"0.25")
 set(AKONADI_MIN_VERSION  "4.89.0")# Akonadi Contact dependency
 set(CALENDAR_MIN_VERSION "4.81.0")# Calendar Core dependency
 set(QTAV_MIN_VERSION "1.12.0")
-- 
2.16.4




commit digikam for openSUSE:Factory

2018-10-18 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-10-18 15:39:48

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Thu Oct 18 15:39:48 2018 rev:173 rq:642839 version:5.9.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-08-15 
10:36:33.304090461 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-10-18 
15:40:11.334034335 +0200
@@ -1,0 +2,5 @@
+Tue Oct 16 18:52:03 UTC 2018 - Fabian Vogt 
+
+- Disable libkvkontakte support, it's dead
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.gNbZis/_old  2018-10-18 15:40:15.754029320 +0200
+++ /var/tmp/diff_new_pack.gNbZis/_new  2018-10-18 15:40:15.758029315 +0200
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -61,7 +61,6 @@
 BuildRequires:  libkgeomap-devel > 15.12.0
 BuildRequires:  libkipi-devel >= 16.04.0
 BuildRequires:  libksane-devel >= 15.12.0
-BuildRequires:  libkvkontakte-devel
 BuildRequires:  liblcms2-devel
 BuildRequires:  liblqr-devel
 BuildRequires:  libmediawiki-devel
@@ -183,6 +182,9 @@
 sed -i "s/__DATE__/\"$FAKE_BUILDDATE\"/g" 
core/libs/dimg/filters/greycstoration/cimg/CImg.h
 sed -i "s/__TIME__/\"$FAKE_BUILDTIME\"/g" 
core/libs/dimg/filters/greycstoration/cimg/CImg.h
 
+# Workaround for kde#369517 - vkontakte installs translations even if not built
+rm -f po/*/kipiplugin_vkontakte.po
+
 %build
 %if 0%{?suse_version} < 1320 && !0%{?is_opensuse}
 EXTRA_FLAGS="-DENABLE_LCMS2=OFF"
@@ -211,7 +213,7 @@
 %find_lang %{name} --without-kde
 %find_lang kipiplugins kipiplugin.lang --without-kde
 
-for i in dropbox googleservices sendimages facebook flashexport flickr 
imageshack imgur kmlexport piwigo printimages rajce remotestorage sendimages 
smug vkontakte yandexfotki
+for i in dropbox googleservices sendimages facebook flashexport flickr 
imageshack imgur kmlexport piwigo printimages rajce remotestorage sendimages 
smug yandexfotki
 do
   %find_lang kipiplugin_$i kipiplugin.lang
 done




commit digikam for openSUSE:Factory

2018-08-15 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-08-15 10:36:29

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Wed Aug 15 10:36:29 2018 rev:172 rq:628957 version:5.9.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-03-28 
10:31:21.233105016 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-08-15 
10:36:33.304090461 +0200
@@ -1,0 +2,6 @@
+Mon Aug 13 09:00:10 UTC 2018 - fab...@ritter-vogt.de
+
+- Require libQt5Sql5-sqlite (boo#1095688)
+- Use %license
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.xgoVPq/_old  2018-08-15 10:36:35.816095040 +0200
+++ /var/tmp/diff_new_pack.xgoVPq/_new  2018-08-15 10:36:35.820095047 +0200
@@ -20,7 +20,7 @@
 Version:5.9.0
 Release:0
 Summary:A KDE Photo Manager
-License:GPL-2.0+
+License:GPL-2.0-or-later
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
@@ -34,6 +34,7 @@
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
 %endif
+BuildRequires:  QtAV-devel >= 1.11
 BuildRequires:  baloo5-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -53,7 +54,6 @@
 BuildRequires:  libexiv2-devel >= 0.26
 BuildRequires:  libexpat-devel
 BuildRequires:  libgcrypt-devel
-BuildRequires:  QtAV-devel >= 1.11
 BuildRequires:  libgpod-devel
 BuildRequires:  libjasper-devel
 BuildRequires:  libkdcraw-devel >= 15.12.0
@@ -88,6 +88,7 @@
 BuildRequires:  pkgconfig(Qt5XmlPatterns)
 BuildRequires:  pkgconfig(libgphoto2) >= 2.4.0
 Requires:   kipi-plugins >= %{version}
+Requires:   libQt5Sql5-sqlite
 Recommends: %{name}-doc
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -116,7 +117,7 @@
 
 %package doc
 Summary:Documentation of Digikam
-License:GFDL-1.2
+License:GFDL-1.2-only
 Group:  Documentation/HTML
 BuildArch:  noarch
 
@@ -125,7 +126,7 @@
 
 %package -n kipi-plugins
 Summary:KDE Plug-Ins for Image Manipulation
-License:GPL-2.0+
+License:GPL-2.0-or-later
 Group:  Productivity/Graphics/Other
 Recommends: ImageMagick
 Recommends: enblend-enfuse
@@ -144,7 +145,7 @@
 
 %package -n showfoto
 Summary:DigiKam: Showfoto
-License:GPL-2.0+
+License:GPL-2.0-or-later
 Group:  Productivity/Graphics/Viewers
 Supplements:%{name}
 
@@ -153,7 +154,7 @@
 
 %package -n libdigikamcore5
 Summary:The main digikam libraries
-License:GPL-2.0+
+License:GPL-2.0-or-later
 Group:  Development/Libraries/KDE
 
 %description -n libdigikamcore5
@@ -226,8 +227,6 @@
 %postun -n kipi-plugins -p /sbin/ldconfig
 
 %files
-%defattr(-,root,root,-)
-%doc 
core/{AUTHORS,COPYING,COPYING-CMAKE-SCRIPTS,COPYING.LIB,ChangeLog,NEWS,README.md}
 %{_bindir}/digikam
 %{_bindir}/digitaglinktree
 %{_bindir}/cleanup_digikamdb
@@ -245,7 +244,6 @@
 %_kf5_iconsdir/hicolor/*/apps/panorama.*
 
 %files -n showfoto
-%defattr(-,root,root)
 %{_bindir}/showfoto
 %{_kf5_applicationsdir}/org.kde.showfoto.desktop
 %_kf5_iconsdir/hicolor/*/apps/showfoto.*
@@ -254,22 +252,21 @@
 %{_kf5_appstreamdir}/org.kde.showfoto.appdata.xml
 
 %files -n libdigikamcore5
-%defattr(-,root,root)
+%license COPYING*
+%doc core/{AUTHORS,ChangeLog,NEWS,README.md}
 %{_libdir}/libdigikam*.so*
 
 %files doc
-%defattr(-,root,root,-)
-%doc doc/COPYING.DOC
+%license doc/COPYING.DOC
 %doc %{_mandir}/man1/cleanup_digikamdb.1%{ext_man}
 %doc %{_mandir}/man1/digitaglinktree.1%{ext_man}
 %doc %{_kf5_htmldir}/*/
 
 %files lang -f %{name}.lang
-%defattr(-,root,root,-)
 
 %files -n kipi-plugins
-%defattr(-,root,root,-)
-%doc 
extra/kipi-plugins/{AUTHORS,COPYING,COPYING-CMAKE-SCRIPTS,ChangeLog,NEWS,README,TODO}
+%license COPYING*
+%doc extra/kipi-plugins/{AUTHORS,ChangeLog,NEWS,README,TODO}
 %_libdir/libKF5kipiplugins.so*
 %{_kf5_plugindir}/kipiplugin_*.so
 %{_kf5_applicationsdir}/kipiplugins.desktop
@@ -279,6 +276,5 @@
 %{_kf5_kxmlguidir}/kipi/
 
 %files -n kipi-plugins-lang -f kipiplugin.lang
-%defattr(-,root,root,-)
 
 %changelog




commit digikam for openSUSE:Factory

2018-03-28 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-03-28 10:31:15

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Wed Mar 28 10:31:15 2018 rev:171 rq:591045 version:5.9.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-03-09 
10:46:21.883178000 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-03-28 
10:31:21.233105016 +0200
@@ -1,0 +2,23 @@
+Sat Mar 24 18:48:15 UTC 2018 - wba...@tmo.at
+
+- Update to 5.9.0:
+  * https://www.digikam.org/news/2018-03-25-5.9.0_release_announcement/
+- New features (from NEWS):
+General  : Libraw updated to last 0.18.8.
+- 45 bugs fixed
+- Drop upstream patches:
+  * fix-font-size-in-tooltips.patch
+  * digikam-5.8.0.fix-db-migration-0001.patch
+  * digikam-5.8.0.fix-db-migration-0002.patch
+  * digikam-5.8.0.fix-db-migration-0003.patch
+  * digikam-5.8.0.fix-db-migration-0004.patch
+  * update-internal-libraw-to-last-stable-0.18.7.patch
+  * update-internal-libraw-to-last-0.18.8.patch
+- Drop fix-italian-docs-with-older-kdoctools.patch, Leap 42.2 is no
+  longer supported
+- Don't try to delete libkvkontakte translations, they are no
+  longer installed (kde#369517)
+- Also don't try to delete *.a files and locale/x-test, no longer
+  necessary
+
+---

Old:

  digikam-5.8.0.fix-db-migration-0001.patch
  digikam-5.8.0.fix-db-migration-0002.patch
  digikam-5.8.0.fix-db-migration-0003.patch
  digikam-5.8.0.fix-db-migration-0004.patch
  digikam-5.8.0.tar.xz
  fix-font-size-in-tooltips.patch
  fix-italian-docs-with-older-kdoctools.patch
  update-internal-libraw-to-last-0.18.8.patch
  update-internal-libraw-to-last-stable-0.18.7.patch

New:

  digikam-5.9.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.3DSKWj/_old  2018-03-28 10:31:26.788905205 +0200
+++ /var/tmp/diff_new_pack.3DSKWj/_new  2018-03-28 10:31:26.792905062 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:5.8.0
+Version:5.9.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
@@ -30,21 +30,6 @@
 Patch1: 0001-Revert-replace-obsolete-qSort-function.patch
 # PATCH-FIX-OPENSUSE
 Patch2: 0002-Revert-replace-obsolete-qSort-function.patch
-# PATCH-FIX-OPENSUSE fix-italian-docs-with-older-kdoctools.patch -- fix build 
with the old kdoctools in Leap 42.2 that misses two necessary entities for 
italian
-Patch3: fix-italian-docs-with-older-kdoctools.patch
-# PATCH-FIX-UPSTREAM
-Patch4: fix-font-size-in-tooltips.patch
-# PATCH-FIX-UPSTREAM digikam-5.8.0.fix-db-migration-0001.patch -- fix MySQL DB 
migration issues (kde#388824, kde#388867, kde#388977)
-Patch5: digikam-5.8.0.fix-db-migration-0001.patch
-# PATCH-FIX-UPSTREAM
-Patch6: digikam-5.8.0.fix-db-migration-0002.patch
-# PATCH-FIX-UPSTREAM
-Patch7: digikam-5.8.0.fix-db-migration-0003.patch
-# PATCH-FIX-UPSTREAM
-Patch8: digikam-5.8.0.fix-db-migration-0004.patch
-# PATCH-FIX-UPSTREAM
-Patch9: update-internal-libraw-to-last-stable-0.18.7.patch
-Patch10:update-internal-libraw-to-last-0.18.8.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -187,23 +172,7 @@
 %if 0%{?suse_version} < 1320
 %patch1 -p1
 %patch2 -p1
-%if 0%{?sle_version} <= 120200
-%patch3 -p1
 %endif
-%endif
-%patch4 -p1
-
-# DB migration fixes
-cd core
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
-%patch8 -p1
-cd ..
-
-# update internal libraw to fix build in TW
-%patch9 -p1
-%patch10 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
@@ -213,9 +182,6 @@
 sed -i "s/__DATE__/\"$FAKE_BUILDDATE\"/g" 
core/libs/dimg/filters/greycstoration/cimg/CImg.h
 sed -i "s/__TIME__/\"$FAKE_BUILDTIME\"/g" 
core/libs/dimg/filters/greycstoration/cimg/CImg.h
 
-# Workaround for kde#369517 - vkontakte installs translations even if not built
-rm -f po/*/libkvkontakte.po
-
 %build
 %if 0%{?suse_version} < 1320 && !0%{?is_opensuse}
 EXTRA_FLAGS="-DENABLE_LCMS2=OFF"
@@ -236,10 +202,6 @@
 rm -f %{buildroot}%{_kf5_libdir}/libdigikamgui.so
 rm -f %{buildroot}%{_kf5_libdir}/libKF5kipiplugins.so
 
-# Not needed
-rm -fv %{buildroot}%{_kf5_libdir}/*.a
-rm -rf $RPM_BUILD_ROOT/usr/share/locale/x-test
-
 %if 0%{?suse_version}
 %suse_update_desktop_file -r org.kde.digikam Qt KDE Graphics Photography
 %suse_update_desktop_file -r org.kde.showfoto Qt KDE Graphics Photography


commit digikam for openSUSE:Factory

2018-03-09 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-03-09 10:46:17

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Fri Mar  9 10:46:17 2018 rev:170 rq:584415 version:5.8.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-02-12 
10:15:30.396874686 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-03-09 
10:46:21.883178000 +0100
@@ -1,0 +2,7 @@
+Wed Mar  7 17:01:45 UTC 2018 - wba...@tmo.at
+
+- Add upstream patches to fix build in Tumbleweed:
+  * update-internal-libraw-to-last-stable-0.18.7.patch
+  * update-internal-libraw-to-last-0.18.8.patch
+
+---

New:

  update-internal-libraw-to-last-0.18.8.patch
  update-internal-libraw-to-last-stable-0.18.7.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.TOLP1Y/_old  2018-03-09 10:46:24.567081327 +0100
+++ /var/tmp/diff_new_pack.TOLP1Y/_new  2018-03-09 10:46:24.575081038 +0100
@@ -42,6 +42,9 @@
 Patch7: digikam-5.8.0.fix-db-migration-0003.patch
 # PATCH-FIX-UPSTREAM
 Patch8: digikam-5.8.0.fix-db-migration-0004.patch
+# PATCH-FIX-UPSTREAM
+Patch9: update-internal-libraw-to-last-stable-0.18.7.patch
+Patch10:update-internal-libraw-to-last-0.18.8.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -198,6 +201,10 @@
 %patch8 -p1
 cd ..
 
+# update internal libraw to fix build in TW
+%patch9 -p1
+%patch10 -p1
+
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
 FAKE_BUILDTIME=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%H:%%M')

++ update-internal-libraw-to-last-0.18.8.patch ++
>From afa3af656f13854c5f9d11fd4066f597b5dbd5b5 Mon Sep 17 00:00:00 2001
From: Human Dynamo 
Date: Sat, 3 Mar 2018 22:47:47 +0100
Subject: update internal libraw to last 0.18.8

---
 NEWS   |   2 +-
 libs/rawengine/libraw/Changelog.txt|  14 ++
 libs/rawengine/libraw/internal/dcraw_common.cpp| 141 -
 .../libraw/internal/libraw_internal_funcs.h|   2 +-
 libs/rawengine/libraw/libraw/libraw_const.h|   5 +
 libs/rawengine/libraw/libraw/libraw_version.h  |   2 +-
 libs/rawengine/libraw/src/libraw_cxx.cpp   |  10 +-
 7 files changed, 113 insertions(+), 63 deletions(-)

diff --git a/libs/rawengine/libraw/Changelog.txt 
b/libs/rawengine/libraw/Changelog.txt
index c9fc520..08d6cbe 100644
--- a/core/libs/rawengine/libraw/Changelog.txt
+++ b/core/libs/rawengine/libraw/Changelog.txt
@@ -1,3 +1,17 @@
+2018-02-23  Alex Tutubalin 
+Secunia #81000: 
+Credit: Laurent Delosieres, Secunia Research at Flexera
+ * leaf_hdr_load_raw: check for image pointer for demosaiced raw
+ * NOKIARAW parser: check image dimensions readed from file
+ * quicktake_100_load_raw: check width/height limits
+ * LibRaw 0.18.8
+
+2018-01-29  Alex Tutubalin 
+ * Checks for width+left_margin/height+top_margin not larger than 64k
+ * LIBRAW_MAX_ALLOC_MB define limits maximum image/raw_image allocation
+   (default is 2048 so 2Gb per array)
+ * LibRaw::read_shorts item count is now unsigned
+
 2018-01-19  Alex Tutubalin 
 Secunia #79000: 
 Credit: Laurent Delosieres, Secunia Research at Flexera
diff --git a/libs/rawengine/libraw/internal/dcraw_common.cpp 
b/libs/rawengine/libraw/internal/dcraw_common.cpp
index 520d19a..cfb82a2 100644
--- a/core/libs/rawengine/libraw/internal/dcraw_common.cpp
+++ b/core/libs/rawengine/libraw/internal/dcraw_common.cpp
@@ -220,7 +220,7 @@ double CLASS getreal (int type)
   }
 }
 
-void CLASS read_shorts (ushort *pixel, int count)
+void CLASS read_shorts (ushort *pixel, unsigned count)
 {
   if (fread (pixel, 2, count, ifp) < count) derror();
   if ((order == 0x4949) == (ntohs(0x1234) == 0x1234))
@@ -2077,6 +2077,10 @@ void CLASS leaf_hdr_load_raw()
   unsigned tile=0, r, c, row, col;
 
   if (!filters) {
+#ifdef LIBRAW_LIBRARY_BUILD
+if(!image)
+  throw LIBRAW_EXCEPTION_IO_CORRUPT;
+#endif
 pixel = (ushort *) calloc (raw_width, sizeof *pixel);
 merror (pixel, "leaf_hdr_load_raw()");
   }
@@ -2606,7 +2610,11 @@ void CLASS quicktake_100_load_raw()
 654,665,676,687,698,710,721,732,743,754,766,777,788,799,810,822,833,844,
 855,866,878,889,900,911,922,933,945,956,967,978,989,1001,1012,1023 };
   int rb, row, col, sharp, val=0;
-
+#ifdef 

commit digikam for openSUSE:Factory

2018-02-12 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-02-12 10:15:27

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Mon Feb 12 10:15:27 2018 rev:169 rq:575308 version:5.8.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-02-09 
15:51:54.749982225 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-02-12 
10:15:30.396874686 +0100
@@ -1,0 +2,5 @@
+Fri Feb  9 21:06:44 UTC 2018 - stefan.bru...@rwth-aachen.de
+
+- Fix broken rebase of 
0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
+
+---



Other differences:
--
++ 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch ++
--- /var/tmp/diff_new_pack.SbzY3Q/_old  2018-02-12 10:15:34.452728531 +0100
+++ /var/tmp/diff_new_pack.SbzY3Q/_new  2018-02-12 10:15:34.452728531 +0100
@@ -23,7 +23,7 @@
 +++ b/core/CMakeLists.txt
 @@ -290,7 +290,7 @@ find_package(Marble)
  find_package(PkgConfig)
- find_package(Jasper)
+ find_package(Jasper)   # For JPEG 2000 support.
  find_package(Eigen3)   # For Refocus tool.
 -find_package(OpenGL)   # For Presentation tool.
 +# find_package(OpenGL)   # For Presentation tool.




commit digikam for openSUSE:Factory

2018-02-09 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-02-09 15:51:52

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Fri Feb  9 15:51:52 2018 rev:168 rq:574411 version:5.8.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-01-30 
15:42:56.186714767 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-02-09 
15:51:54.749982225 +0100
@@ -1,0 +2,13 @@
+Thu Feb  8 13:19:01 UTC 2018 - stefan.bru...@rwth-aachen.de
+
+- Drop xorg-x11-devel BuildRequires, all x11 dependencies are
+  via Qt and covered by the Qt5* BuildRequires
+- Drop BuildRequires on gphoto binary, the version is discovered
+  using pkgconfig now.
+
+---
+Thu Feb  8 13:08:46 UTC 2018 - stefan.bru...@rwth-aachen.de
+
+- Rebase 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.elXO5n/_old  2018-02-09 15:51:57.517882810 +0100
+++ /var/tmp/diff_new_pack.elXO5n/_new  2018-02-09 15:51:57.517882810 +0100
@@ -65,10 +65,7 @@
 BuildRequires:  libexiv2-devel >= 0.26
 BuildRequires:  libexpat-devel
 BuildRequires:  libgcrypt-devel
-BuildRequires:  libgphoto2-devel >= 2.4.0
-# It invokes "gphoto2" for determining the API version
 BuildRequires:  QtAV-devel >= 1.11
-BuildRequires:  gphoto
 BuildRequires:  libgpod-devel
 BuildRequires:  libjasper-devel
 BuildRequires:  libkdcraw-devel >= 15.12.0
@@ -91,7 +88,6 @@
 BuildRequires:  opencv-devel
 BuildRequires:  threadweaver-devel >= 5.1.0
 BuildRequires:  update-desktop-files
-BuildRequires:  xorg-x11-devel
 BuildRequires:  cmake(KF5CalendarCore)
 BuildRequires:  pkgconfig(Qt5Concurrent)
 BuildRequires:  pkgconfig(Qt5Core) >= 5.6.0
@@ -102,6 +98,7 @@
 BuildRequires:  pkgconfig(Qt5WebKitWidgets)
 BuildRequires:  pkgconfig(Qt5X11Extras)
 BuildRequires:  pkgconfig(Qt5XmlPatterns)
+BuildRequires:  pkgconfig(libgphoto2) >= 2.4.0
 Requires:   kipi-plugins >= %{version}
 Recommends: %{name}-doc
 Recommends: %{name}-lang

++ 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch ++
--- /var/tmp/diff_new_pack.elXO5n/_old  2018-02-09 15:51:57.537882092 +0100
+++ /var/tmp/diff_new_pack.elXO5n/_new  2018-02-09 15:51:57.537882092 +0100
@@ -21,7 +21,7 @@
 index cd482ea..bc3772b 100644
 --- a/core/CMakeLists.txt
 +++ b/core/CMakeLists.txt
-@@ -278,7 +278,7 @@ find_package(Marble)
+@@ -290,7 +290,7 @@ find_package(Marble)
  find_package(PkgConfig)
  find_package(Jasper)
  find_package(Eigen3)   # For Refocus tool.




commit digikam for openSUSE:Factory

2018-01-30 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-01-30 15:42:54

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Tue Jan 30 15:42:54 2018 rev:167 rq:570509 version:5.8.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-01-19 
11:54:16.244647811 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-01-30 
15:42:56.186714767 +0100
@@ -1,0 +2,9 @@
+Thu Jan 18 23:17:51 UTC 2018 - nico.kru...@gmail.com
+
+- Add digikam-5.8.0.fix-db-migration-0001.patch (adapted to 5.8.0),
+  digikam-5.8.0.fix-db-migration-0002.patch,
+  digikam-5.8.0.fix-db-migration-0003.patch, and
+  digikam-5.8.0.fix-db-migration-0004.patch to fix MySQL DB
+  migration issues (kde#388824, kde#388867, kde#388977)
+
+---

New:

  digikam-5.8.0.fix-db-migration-0001.patch
  digikam-5.8.0.fix-db-migration-0002.patch
  digikam-5.8.0.fix-db-migration-0003.patch
  digikam-5.8.0.fix-db-migration-0004.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.3AnAdP/_old  2018-01-30 15:43:00.006536439 +0100
+++ /var/tmp/diff_new_pack.3AnAdP/_new  2018-01-30 15:43:00.006536439 +0100
@@ -34,6 +34,14 @@
 Patch3: fix-italian-docs-with-older-kdoctools.patch
 # PATCH-FIX-UPSTREAM
 Patch4: fix-font-size-in-tooltips.patch
+# PATCH-FIX-UPSTREAM digikam-5.8.0.fix-db-migration-0001.patch -- fix MySQL DB 
migration issues (kde#388824, kde#388867, kde#388977)
+Patch5: digikam-5.8.0.fix-db-migration-0001.patch
+# PATCH-FIX-UPSTREAM
+Patch6: digikam-5.8.0.fix-db-migration-0002.patch
+# PATCH-FIX-UPSTREAM
+Patch7: digikam-5.8.0.fix-db-migration-0003.patch
+# PATCH-FIX-UPSTREAM
+Patch8: digikam-5.8.0.fix-db-migration-0004.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -185,6 +193,14 @@
 %endif
 %patch4 -p1
 
+# DB migration fixes
+cd core
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+cd ..
+
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
 FAKE_BUILDTIME=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%H:%%M')

++ digikam-5.8.0.fix-db-migration-0001.patch ++
>From 5893fde69518d70904d2b96e13800c7432b4e4c4 Mon Sep 17 00:00:00 2001
From: Maik Qualmann 
Date: Mon, 15 Jan 2018 20:24:41 +0100
Subject: fix schema update from V7/8 to V9 with temporary tables BUGS: 388977
 BUGS: 388867 BUGS: 388824 FIXED-IN: 5.9.0

---
 data/database/dbconfig.xml.cmake.in | 154 +---
 2 files changed, 124 insertions(+), 30 deletions(-)

diff --git a/data/database/dbconfig.xml.cmake.in 
b/data/database/dbconfig.xml.cmake.in
index a315361..2c5008f 100644
--- a/data/database/dbconfig.xml.cmake.in
+++ b/data/database/dbconfig.xml.cmake.in
@@ -1992,8 +1992,6 @@
 END IF;
 END;
 
-SET SESSION 
OLD_ALTER_TABLE=1;
-SET SESSION 
FOREIGN_KEY_CHECKS=0;
 DROP TRIGGER IF EXISTS 
delete_image;
 DROP TRIGGER IF EXISTS 
delete_tag;
 DROP TRIGGER IF EXISTS 
move_tagstree;
@@ -2064,85 +2062,181 @@
 ALTER TABLE TagProperties MODIFY 
COLUMN value LONGTEXT CHARACTER SET utf8 COLLATE utf8_general_ci;
 ALTER TABLE ImageTagProperties MODIFY 
COLUMN property TEXT CHARACTER SET utf8 COLLATE utf8_general_ci;
 ALTER TABLE ImageTagProperties MODIFY 
COLUMN value LONGTEXT CHARACTER SET utf8 COLLATE utf8_general_ci;
-ALTER IGNORE TABLE AlbumRoots
+
+RENAME TABLE AlbumRoots TO 
AlbumRoots_old;
+CREATE TABLE AlbumRoots LIKE 
AlbumRoots_old;
+ALTER TABLE AlbumRoots
 ADD UNIQUE (identifier(127), 
specificPath(128)),
 ENGINE InnoDB;
-ALTER IGNORE TABLE Albums
+INSERT IGNORE INTO AlbumRoots SELECT * 
FROM AlbumRoots_old;
+
+RENAME TABLE Albums TO 
Albums_old;
+CREATE TABLE Albums LIKE 
Albums_old;
+ALTER TABLE Albums
 ADD CONSTRAINT Albums_AlbumRoots 
FOREIGN KEY (albumRoot) REFERENCES AlbumRoots (id) ON DELETE CASCADE ON UPDATE 
CASCADE,
 ADD UNIQUE (albumRoot, 
relativePath(255)),
 

commit digikam for openSUSE:Factory

2018-01-19 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-01-19 11:53:49

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Fri Jan 19 11:53:49 2018 rev:166 rq:567200 version:5.8.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2018-01-17 
21:58:35.178440320 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-01-19 
11:54:16.244647811 +0100
@@ -1,0 +2,7 @@
+Wed Jan 17 18:50:08 UTC 2018 - wba...@tmo.at
+
+- Add fix-font-size-in-tooltips.patch to make tooltips respect the
+  configured font size (kde#337243)
+- Remove some no longer respected cmake options
+
+---

New:

  fix-font-size-in-tooltips.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.v5K16f/_old  2018-01-19 11:54:21.076420109 +0100
+++ /var/tmp/diff_new_pack.v5K16f/_new  2018-01-19 11:54:21.076420109 +0100
@@ -32,6 +32,8 @@
 Patch2: 0002-Revert-replace-obsolete-qSort-function.patch
 # PATCH-FIX-OPENSUSE fix-italian-docs-with-older-kdoctools.patch -- fix build 
with the old kdoctools in Leap 42.2 that misses two necessary entities for 
italian
 Patch3: fix-italian-docs-with-older-kdoctools.patch
+# PATCH-FIX-UPSTREAM
+Patch4: fix-font-size-in-tooltips.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -181,6 +183,7 @@
 %patch3 -p1
 %endif
 %endif
+%patch4 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
@@ -200,7 +203,7 @@
 EXTRA_FLAGS="-DENABLE_LCMS2=ON"
 %endif
 
-%cmake_kf5 -d build -- -DKFACE_EXTERNAL_FINDOPENCV:BOOL=TRUE 
-DENABLE_APPSTYLES=ON -DENABLE_MYSQLSUPPORT=on -DENABLE_KINOTIFY=ON 
-DENABLE_OPENCV3=ON -DENABLE_MEDIAPLAYER=ON
+%cmake_kf5 -d build -- -DENABLE_APPSTYLES=ON -DENABLE_MYSQLSUPPORT=on 
-DENABLE_OPENCV3=ON -DENABLE_MEDIAPLAYER=ON
 
 %make_jobs VERBOSE=1
 

++ fix-font-size-in-tooltips.patch ++
>From cdc4659165008995bc60d6ac6fabe482928b8aef Mon Sep 17 00:00:00 2001
From: Maik Qualmann 
Date: Wed, 17 Jan 2018 19:09:06 +0100
Subject: fix font size in the tooltips BUGS: 337243 FIXED-IN: 5.9.0

---
 NEWS   |  3 ++-
 libs/widgets/itemview/ditemtooltip.cpp | 41 ++
 2 files changed, 29 insertions(+), 15 deletions(-)

diff --git a/core/libs/widgets/itemview/ditemtooltip.cpp 
b/core/libs/widgets/itemview/ditemtooltip.cpp
index c375c53..ab932a7 100644
--- a/core/libs/widgets/itemview/ditemtooltip.cpp
+++ b/core/libs/widgets/itemview/ditemtooltip.cpp
@@ -52,33 +52,46 @@ namespace Digikam
 DToolTipStyleSheet::DToolTipStyleSheet(const QFont& font)
 : maxStringLength(30)
 {
-unavailable = i18n("unavailable");
+unavailable  = i18n("unavailable");
+
+QString fontSize = (font.pointSize() == -1) ? 
QString::fromUtf8("font-size: %1px;").arg(font.pixelSize())
+: 
QString::fromUtf8("font-size: %1pt;").arg(font.pointSize());
 
 tipHeader   = QLatin1String("");
 tipFooter   = QLatin1String("");
 
 headBeg = QString::fromLatin1(""
-  "")
+  "")
   .arg(qApp->palette().color(QPalette::Base).name())
   .arg(qApp->palette().color(QPalette::Text).name())
-  .arg(font.family());
-headEnd = QLatin1String("");
+  .arg(font.family())
+  .arg(fontSize);
+
+headEnd = QLatin1String("");
 
-cellBeg = QString::fromLatin1("")
+cellBeg = QString::fromLatin1("")
   .arg(qApp->palette().color(QPalette::ToolTipText).name())
-  .arg(font.family());
-cellMid = QString::fromLatin1("")
+  .arg(font.family())
+  .arg(fontSize);
+
+cellMid = QString::fromLatin1("")
   .arg(qApp->palette().color(QPalette::ToolTipText).name())
-  .arg(font.family());
-cellEnd = QLatin1String("");
+  .arg(font.family())
+  .arg(fontSize);
 
-cellSpecBeg = QString::fromLatin1("")
+cellEnd = QLatin1String("");
+
+cellSpecBeg = QString::fromLatin1("")
   .arg(qApp->palette().color(QPalette::ToolTipText).name())
-  .arg(font.family());
-cellSpecMid = QString::fromLatin1("")
+  

commit digikam for openSUSE:Factory

2018-01-17 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2018-01-17 21:57:12

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Wed Jan 17 21:57:12 2018 rev:165 rq:565891 version:5.8.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-12-10 
18:17:32.530916934 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2018-01-17 
21:58:35.178440320 +0100
@@ -1,0 +2,28 @@
+Mon Jan 15 19:33:44 UTC 2018 - wba...@tmo.at
+
+- Update to 5.8.0:
+  * https://www.digikam.org/news/2018-01-14-5.8.0_release_announcement/
+- New features (from NEWS):
+General  : Add support to OpenCV 3.4.x.
+General  : Updated internal Libraw to last 0.18.6.
+General  : New Upnp/Dlna media server to share collections on local 
network.
+Image Editor : New clone tool to replace old CImg in-painting tool.
+DropBox : tool ported AuthO2 API.
+
+- 231 bugs fixed
+- Remove unneeded libkface-devel build requirement, it's not used
+  anymore since over 2 years
+- Add 0001-Revert-replace-obsolete-qSort-function.patch and
+  0002-Revert-replace-obsolete-qSort-function.patch to fix build
+  with gcc 4.8 on Leap 42
+- Add fix-italian-docs-with-older-kdoctools.patch to make it build
+  on Leap 42.2
+- Pass --without-kde to %find_lang to prevent the docs being added
+  to the lang package, we have a separate docs subpackage
+  (it supports the KF5 docs location starting with rpm 4.14.0, and
+  that would break the build)
+- Drop upstream patches:
+  * Adapt-to-KCalCore-API-changes.patch
+  * fix-Qt-5.9.3-empty-album-problem.patch
+
+---

Old:

  Adapt-to-KCalCore-API-changes.patch
  digikam-5.7.0.tar.xz
  fix-Qt-5.9.3-empty-album-problem.patch

New:

  0001-Revert-replace-obsolete-qSort-function.patch
  0002-Revert-replace-obsolete-qSort-function.patch
  digikam-5.8.0.tar.xz
  fix-italian-docs-with-older-kdoctools.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.fXVXga/_old  2018-01-17 21:58:42.866079979 +0100
+++ /var/tmp/diff_new_pack.fXVXga/_new  2018-01-17 21:58:42.870079791 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package digikam
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:5.7.0
+Version:5.8.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
@@ -26,10 +26,12 @@
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch 
-- The OpenGL slideshow depends on Desktop GL, see kde#383715
 Patch0: 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
-# PATCH-FIX-UPSTREAM
-Patch1: Adapt-to-KCalCore-API-changes.patch
-# PATCH-FIX-UPSTREAM
-Patch2: fix-Qt-5.9.3-empty-album-problem.patch
+# PATCH-FIX-OPENSUSE
+Patch1: 0001-Revert-replace-obsolete-qSort-function.patch
+# PATCH-FIX-OPENSUSE
+Patch2: 0002-Revert-replace-obsolete-qSort-function.patch
+# PATCH-FIX-OPENSUSE fix-italian-docs-with-older-kdoctools.patch -- fix build 
with the old kdoctools in Leap 42.2 that misses two necessary entities for 
italian
+Patch3: fix-italian-docs-with-older-kdoctools.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -61,7 +63,6 @@
 BuildRequires:  libjasper-devel
 BuildRequires:  libkdcraw-devel >= 15.12.0
 BuildRequires:  libkexiv2-devel >= 15.12.0
-BuildRequires:  libkface-devel >= 15.12.0
 BuildRequires:  libkgeomap-devel > 15.12.0
 BuildRequires:  libkipi-devel >= 16.04.0
 BuildRequires:  libksane-devel >= 15.12.0
@@ -173,8 +174,13 @@
 # Disable OpenGL slideshow on embedded platforms
 %patch0 -p1
 %endif
+%if 0%{?suse_version} < 1320
 %patch1 -p1
 %patch2 -p1
+%if 0%{?sle_version} <= 120200
+%patch3 -p1
+%endif
+%endif
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
@@ -216,8 +222,8 @@
 %suse_update_desktop_file -r org.kde.showfoto Qt KDE Graphics Photography
 %endif
 
-%find_lang %{name}
-%find_lang kipiplugins kipiplugin.lang
+%find_lang %{name} --without-kde
+%find_lang kipiplugins kipiplugin.lang --without-kde
 
 for i in dropbox googleservices sendimages 

commit digikam for openSUSE:Factory

2017-12-10 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-12-10 18:17:29

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Sun Dec 10 18:17:29 2017 rev:164 rq:555601 version:5.7.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-11-23 
09:45:40.349758890 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-12-10 
18:17:32.530916934 +0100
@@ -1,0 +2,6 @@
+Fri Dec  8 19:48:19 UTC 2017 - wba...@tmo.at
+
+- Add fix-Qt-5.9.3-empty-album-problem.patch to fix albums showing
+  up empty with Qt 5.9.3 or higher (kde#387373)
+
+---

New:

  fix-Qt-5.9.3-empty-album-problem.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.5Kq3L8/_old  2017-12-10 18:17:36.554725278 +0100
+++ /var/tmp/diff_new_pack.5Kq3L8/_new  2017-12-10 18:17:36.558725087 +0100
@@ -28,6 +28,8 @@
 Patch0: 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
 # PATCH-FIX-UPSTREAM
 Patch1: Adapt-to-KCalCore-API-changes.patch
+# PATCH-FIX-UPSTREAM
+Patch2: fix-Qt-5.9.3-empty-album-problem.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -172,6 +174,7 @@
 %patch0 -p1
 %endif
 %patch1 -p1
+%patch2 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ fix-Qt-5.9.3-empty-album-problem.patch ++
>From 855ba5b7d4bc6337234720a72ea824ddd3b32e5b Mon Sep 17 00:00:00 2001
From: Maik Qualmann 
Date: Tue, 28 Nov 2017 21:29:00 +0100
Subject: try to fix the Qt-5.9.3 empty album problem CCBUGS: 387373

---
 core/libs/database/coredb/coredburl.cpp | 7 ++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/core/libs/database/coredb/coredburl.cpp 
b/core/libs/database/coredb/coredburl.cpp
index 2c0d0eb..b1bdf71 100644
--- a/core/libs/database/coredb/coredburl.cpp
+++ b/core/libs/database/coredb/coredburl.cpp
@@ -88,8 +88,13 @@ CoreDbUrl CoreDbUrl::fromAlbumAndName(const QString& name,
   const DbEngineParameters& parameters)
 {
 CoreDbUrl url;
+QString path(album);
 url.setScheme(QLatin1String("digikamalbums"));
-url.setPath(QLatin1Char('/') + album + QLatin1Char('/') + name);
+
+if (path != QLatin1String("/"))
+path += QLatin1Char('/');
+
+url.setPath(path + name);
 
 QUrlQuery q(url);
 q.addQueryItem(QLatin1String("albumRoot"),   
albumRoot.adjusted(QUrl::StripTrailingSlash).toLocalFile());
-- 
cgit v0.11.2




commit digikam for openSUSE:Factory

2017-11-23 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-11-23 09:45:25

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Thu Nov 23 09:45:25 2017 rev:163 rq:544531 version:5.7.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-10-13 
14:14:36.120148054 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-11-23 
09:45:40.349758890 +0100
@@ -1,0 +2,6 @@
+Wed Nov 22 11:51:13 UTC 2017 - wba...@tmo.at
+
+- Add Adapt-to-KCalCore-API-changes.patch to make it build with
+  KDE Applications 17.12
+
+---

New:

  Adapt-to-KCalCore-API-changes.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.fz5HMB/_old  2017-11-23 09:45:44.373612052 +0100
+++ /var/tmp/diff_new_pack.fz5HMB/_new  2017-11-23 09:45:44.377611906 +0100
@@ -26,6 +26,8 @@
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch 
-- The OpenGL slideshow depends on Desktop GL, see kde#383715
 Patch0: 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
+# PATCH-FIX-UPSTREAM
+Patch1: Adapt-to-KCalCore-API-changes.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -169,6 +171,7 @@
 # Disable OpenGL slideshow on embedded platforms
 %patch0 -p1
 %endif
+%patch1 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ Adapt-to-KCalCore-API-changes.patch ++
>From dad750fadc926b62603cc9d64009ee5072a46d97 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= 
Date: Wed, 13 Sep 2017 16:51:14 +0200
Subject: Adapt to KCalCore API changes

This change supports both old (pre-QDateTime) and new version.

Differential Revision: https://phabricator.kde.org/D7802
---
 core/CMakeLists.txt  |  3 +++
 core/app/utils/digikam_config.h.cmake.in |  3 +++
 core/utilities/assistants/calendar/print/calsettings.cpp | 14 ++
 3 files changed, 16 insertions(+), 4 deletions(-)

diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 3ad686d..e2f28a7 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -174,6 +174,9 @@ find_package(KF5 ${CALENDAR_MIN_VERSION} QUIET
  OPTIONAL_COMPONENTS
  CalendarCore   # For Calendar tool.
 )
+if ("${KF5CalendarCore_VERSION}" VERSION_GREATER 5.6.40)
+set(HAVE_KCALENDAR_QDATETIME TRUE)
+endif()
 
 if(ENABLE_AKONADICONTACTSUPPORT AND NOT KF5AkonadiContact_FOUND)
 set(ENABLE_KFILEMETADATASUPPORT OFF)
diff --git a/core/app/utils/digikam_config.h.cmake.in 
b/core/app/utils/digikam_config.h.cmake.in
index 8a2e8e5..ffd3a22 100644
--- a/core/app/utils/digikam_config.h.cmake.in
+++ b/core/app/utils/digikam_config.h.cmake.in
@@ -75,6 +75,9 @@
 /* Define to 1 if you have KCalendar core shared libraries installed */
 #cmakedefine HAVE_KCALENDAR 1
 
+/* Define to 1 if you have KCalendar core shared libraries with QDateTime 
support installed */
+#cmakedefine HAVE_KCALENDAR_QDATETIME 1
+
 /* Define to 1 if Panorama tool is supported */
 #cmakedefine HAVE_PANORAMA 1
 
diff --git a/core/utilities/assistants/calendar/print/calsettings.cpp 
b/core/utilities/assistants/calendar/print/calsettings.cpp
index 46e995d..c6554ef 100644
--- a/core/utilities/assistants/calendar/print/calsettings.cpp
+++ b/core/utilities/assistants/calendar/print/calsettings.cpp
@@ -290,7 +290,13 @@ void CalSettings::loadSpecial(const QUrl& url, const 
QColor& color)
 return;
 }
 
-KCalCore::MemoryCalendar::Ptr memCal(new 
KCalCore::MemoryCalendar(QString::fromLatin1("UTC")));
+#if HAVE_KCALENDAR_QDATETIME
+KCalCore::MemoryCalendar::Ptr memCal(new 
KCalCore::MemoryCalendar(QTimeZone::utc()));
+using DateTime = QDateTime;
+#else
+KCalCore::MemoryCalendar::Ptr memCal(new 
KCalCore::MemoryCalendar(QString::fromLatin1("UTC")));
+using DateTime = KDateTime;
+#endif
 KCalCore::FileStorage::Ptr fileStorage(new KCalCore::FileStorage(memCal, 
url.toLocalFile(), new KCalCore::ICalFormat));
 
 qCDebug(DIGIKAM_GENERAL_LOG) << "Loading calendar from file " << 
url.toLocalFile();
@@ -308,9 +314,9 @@ void CalSettings::loadSpecial(const QUrl& url, const 
QColor& color)
 qLast  = calSys.date(params.year + 1, 1, 1);
 qLast  = qLast.addDays(-1);
 
-KDateTime 

commit digikam for openSUSE:Factory

2017-10-13 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-10-13 14:14:34

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Fri Oct 13 14:14:34 2017 rev:162 rq:532996 version:5.7.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-09-14 
21:15:58.580151227 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-10-13 
14:14:36.120148054 +0200
@@ -1,0 +2,8 @@
+Thu Sep 14 23:47:03 UTC 2017 - stefan.bru...@rwth-aachen.de
+
+- Add 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
+  Disable OpenGL detection on embedded platforms (e.g. ARM)
+  Currently digikam depends on Desktop GL and fails to build when
+  using a Qt5OpenGL build with GLES, see kde#383715
+
+---

New:

  0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.w5T6nw/_old  2017-10-13 14:14:38.960023183 +0200
+++ /var/tmp/diff_new_pack.w5T6nw/_new  2017-10-13 14:14:38.960023183 +0200
@@ -24,6 +24,8 @@
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
+# PATCH-FIX-OPENSUSE 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch 
-- The OpenGL slideshow depends on Desktop GL, see kde#383715
+Patch0: 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -82,7 +84,6 @@
 BuildRequires:  pkgconfig(Qt5Sql)
 BuildRequires:  pkgconfig(Qt5Svg)
 BuildRequires:  pkgconfig(Qt5Test)
-BuildRequires:  pkgconfig(Qt5Test)
 BuildRequires:  pkgconfig(Qt5WebKitWidgets)
 BuildRequires:  pkgconfig(Qt5X11Extras)
 BuildRequires:  pkgconfig(Qt5XmlPatterns)
@@ -164,6 +165,10 @@
 
 %prep
 %setup -q -n %{name}-%{version}
+%ifarch %arm aarch64
+# Disable OpenGL slideshow on embedded platforms
+%patch0 -p1
+%endif
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch ++
>From ebce81931d04aefea31795cb4df3f552ba6d3f38 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Stefan=20Br=C3=BCns?= 
Date: Sun, 20 Aug 2017 16:49:50 +0200
Subject: [PATCH] Disable detection of OpenGL (for GLES platforms)
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

On embedded platforms, Qt5 is typically build using GLES. Unfortunately,
the OpenGL code in the presentation module uses the old desktop OpenGL
immediate mode style and thus fails to compile on GLES platforms.

Workaround for bug kde#383715

Signed-off-by: Stefan Brüns 
---
 core/CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index cd482ea..bc3772b 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -278,7 +278,7 @@ find_package(Marble)
 find_package(PkgConfig)
 find_package(Jasper)
 find_package(Eigen3)   # For Refocus tool.
-find_package(OpenGL)   # For Presentation tool.
+# find_package(OpenGL)   # For Presentation tool.
 
 # For Monitor Profiles management with LCMS
 find_package(X11)
-- 
2.14.0




commit digikam for openSUSE:Factory

2017-09-14 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-09-14 21:15:21

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Thu Sep 14 21:15:21 2017 rev:161 rq:525901 version:5.7.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-08-26 
11:52:53.658870347 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-09-14 
21:15:58.580151227 +0200
@@ -1,0 +2,34 @@
+Tue Sep 12 12:29:53 UTC 2017 - wba...@tmo.at
+
+- Update to 5.7.0:
+  * https://www.digikam.org/news/2017-09-11-5.7.0_release_announcement/
+- New features (from NEWS):
+General : Add online handbook reader not dependant of desktop.
+General : New tool to export albums by email.
+General : New tool to create advance print layout.
+General : Send by Mail tool can remove all metadata to attached items.
+General : Replaced the minimum and maximum similarity selection boxes in 
fuzzy
+  search, duplicates search and maintenance by a new, generic 
DIntRangeBox
+  which makes the look, feel and behavious consistent in all 
places.
+  Also, this makes redundant code obsolete and reduces the 
probability of bugs.
+PrintCreator: Add option to create printing from albums or images selection.
+PrintCreator: Add option to customize output image properties to render 
printing.
+PrintCreator: Tool is now multi-threaded to process images while preview and 
printing.
+ImageEditor : Add SendByMail and PrintCreator tools support.
+Showfoto: Add SendByMail and PrintCreator tools support.
+LightTable  : Add SendByMail and PrintCreator tools support.
+Panorama: Add Hugin 2017.0 support.
+Geolocation : Add new tool to export GPS trace to KML file from geolocation 
editor.
+
+- Many bugs fixed
+- Drop fix-build-cmake39.patch, now upstream
+- Drop find_libastro-qt5.patch, 42.1 is no longer supported and
+  its Qt5 is too old anyway
+- Drop unneeded exiv2 requirement, digikam uses libexiv2 only
+- Add libkvkontakte-devel and libmediawiki-devel build requirements
+  (both have been released as KF5 versions meanwhile) to enable the
+  corresponding kipi plugins
+- Build with opencv-devel instead of opencv-qt5-devel, the latter
+  doesn't exist any more
+  
+---

Old:

  digikam-5.6.0.tar.xz
  find_libastro-qt5.patch
  fix-build-cmake39.patch

New:

  digikam-5.7.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.RJRLK9/_old  2017-09-14 21:16:07.406908859 +0200
+++ /var/tmp/diff_new_pack.RJRLK9/_new  2017-09-14 21:16:07.406908859 +0200
@@ -17,17 +17,13 @@
 
 
 Name:   digikam
-Version:5.6.0
+Version:5.7.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
-# PATCH-FIX-OPENSUSE find_libastro-qt5.patch -- fix build of geolocation 
support in Leap 42.1
-Patch0: find_libastro-qt5.patch
-# PATCH-FIX-UPSTREAM
-Patch1: fix-build-cmake39.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -48,7 +44,7 @@
 BuildRequires:  lensfun
 BuildRequires:  lensfun-devel
 BuildRequires:  libeigen3-devel
-BuildRequires:  libexiv2-devel
+BuildRequires:  libexiv2-devel >= 0.26
 BuildRequires:  libexpat-devel
 BuildRequires:  libgcrypt-devel
 BuildRequires:  libgphoto2-devel >= 2.4.0
@@ -63,8 +59,10 @@
 BuildRequires:  libkgeomap-devel > 15.12.0
 BuildRequires:  libkipi-devel >= 16.04.0
 BuildRequires:  libksane-devel >= 15.12.0
+BuildRequires:  libkvkontakte-devel
 BuildRequires:  liblcms2-devel
 BuildRequires:  liblqr-devel
+BuildRequires:  libmediawiki-devel
 BuildRequires:  libmysqlclient-devel
 BuildRequires:  libmysqld-devel
 BuildRequires:  libpgf-devel
@@ -73,7 +71,7 @@
 BuildRequires:  libusb-devel
 BuildRequires:  marble-devel
 BuildRequires:  mysql
-BuildRequires:  opencv-qt5-devel
+BuildRequires:  opencv-devel
 BuildRequires:  threadweaver-devel >= 5.1.0
 BuildRequires:  update-desktop-files
 BuildRequires:  xorg-x11-devel
@@ -92,7 +90,6 @@
 Recommends: %{name}-doc
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-Requires:   exiv2 >= 0.25
 Recommends: marble
 Recommends: showfoto
 # Got merged into libimageeditor in 5.2.0
@@ -167,13 +164,6 @@
 
 %prep
 %setup -q -n %{name}-%{version}
-%if 0%{?is_opensuse} && 0%{?sle_version} 

commit digikam for openSUSE:Factory

2017-08-26 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-08-26 11:52:51

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Sat Aug 26 11:52:51 2017 rev:160 rq:518877 version:5.6.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-08-24 
18:31:18.103713803 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-08-26 
11:52:53.658870347 +0200
@@ -1,0 +2,6 @@
+Sat Aug 26 09:16:31 UTC 2017 - fab...@ritter-vogt.de
+
+- Add patch to fix build with cmake 3.9:
+  * fix-build-cmake39.patch
+
+---

New:

  fix-build-cmake39.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.PGkrxr/_old  2017-08-26 11:52:59.054110987 +0200
+++ /var/tmp/diff_new_pack.PGkrxr/_new  2017-08-26 11:52:59.086106483 +0200
@@ -26,6 +26,8 @@
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE find_libastro-qt5.patch -- fix build of geolocation 
support in Leap 42.1
 Patch0: find_libastro-qt5.patch
+# PATCH-FIX-UPSTREAM
+Patch1: fix-build-cmake39.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -76,8 +78,8 @@
 BuildRequires:  update-desktop-files
 BuildRequires:  xorg-x11-devel
 BuildRequires:  cmake(KF5CalendarCore)
-BuildRequires:  pkgconfig(Qt5Core) >= 5.6.0
 BuildRequires:  pkgconfig(Qt5Concurrent)
+BuildRequires:  pkgconfig(Qt5Core) >= 5.6.0
 BuildRequires:  pkgconfig(Qt5OpenGL)
 BuildRequires:  pkgconfig(Qt5Sql)
 BuildRequires:  pkgconfig(Qt5Svg)
@@ -169,6 +171,9 @@
 # we renamed libastro to libastro-qt5 in Leap 42.1, make FindMARBLE.cmake find 
it
 %patch0 -p1
 %endif
+pushd core
+%patch1 -p1
+popd
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ fix-build-cmake39.patch ++
 13337 lines (skipped)




commit digikam for openSUSE:Factory

2017-08-24 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-08-24 18:31:02

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Thu Aug 24 18:31:02 2017 rev:159 rq:506106 version:5.6.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-05-31 
12:20:30.173957305 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-08-24 
18:31:18.103713803 +0200
@@ -1,0 +2,45 @@
+Sun Jun 25 10:12:45 UTC 2017 - fab...@ritter-vogt.de
+
+- BuildRequire Qt >= 5.6.0
+
+---
+Thu Jun 22 14:30:33 UTC 2017 - wba...@tmo.at
+
+- Update to 5.6.0:
+  * https://www.digikam.org/news/2017-06-21-5.6.0-release-announcement/
+- New features (from NEWS):
+Database: We activated database shrinking for MySQL as part of
+  the maintenance since now we can test the affected
+  tables for integrity.
+Searches: Users can now restrict the results of fuzzy
+  image/drop/sketch search to be in specific albums.
+Searches: Users can now select both tags and albums in duplicates
+  search and restrict the set of images in which
+  duplicates are searched with logical operations (in
+  selected albums or/and tags, in selected albums but not
+  tags and vice versa and only in selected objects of
+  current tab)
+Searches: In extended search, the tags selection can also be
+  restricted such that images must be either tagged with
+  at least one of or with all selected tags.
+General : New tool to export Albums to static HTML gallery.
+General : New tool to export Albums to video diaporama.
+HTMLGallery : New "Elegant" theme using javascript to render image
+  as slideshow in web browser.
+HTMLGallery : New "SimpleRounded" theme that uses flat shapes with
+  rounded corners.
+HTMLGallery : New "BlueCurved" theme with a blue rubbon on the left
+  and an area for navigation arrows.
+HTMLGallery : Add option to generate a Gallery from a selection of
+  images instead an album list.
+ImageEditor : Add HTMLGallery, Calendar, ExpoBlending, VideSlideshow,
+  and Panorama tools support.
+Showfoto: Add HTMLGallery, Calendar, ExpoBlending, VideSlideshow,
+  and Panorama tools support.
+LightTable  : Add HTMLGallery, Calendar, ExpoBlending, VideSlideshow,
+  and Panorama tools support.
+
+- Many bugs fixed
+- Enable building docs again, the problems are fixed
+
+---

Old:

  digikam-5.5.0.tar.xz

New:

  digikam-5.6.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.9NjZOK/_old  2017-08-24 18:31:27.354410520 +0200
+++ /var/tmp/diff_new_pack.9NjZOK/_new  2017-08-24 18:31:27.362409393 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:5.5.0
+Version:5.6.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
@@ -76,6 +76,7 @@
 BuildRequires:  update-desktop-files
 BuildRequires:  xorg-x11-devel
 BuildRequires:  cmake(KF5CalendarCore)
+BuildRequires:  pkgconfig(Qt5Core) >= 5.6.0
 BuildRequires:  pkgconfig(Qt5Concurrent)
 BuildRequires:  pkgconfig(Qt5OpenGL)
 BuildRequires:  pkgconfig(Qt5Sql)
@@ -188,7 +189,7 @@
 EXTRA_FLAGS="-DENABLE_LCMS2=ON"
 %endif
 
-%cmake_kf5 -d build -- -DKFACE_EXTERNAL_FINDOPENCV:BOOL=TRUE 
-DENABLE_APPSTYLES=ON -DENABLE_MYSQLSUPPORT=on -DENABLE_KINOTIFY=ON 
-DENABLE_OPENCV3=ON -DENABLE_MEDIAPLAYER=ON -DDIGIKAMSC_COMPILE_DOC=OFF
+%cmake_kf5 -d build -- -DKFACE_EXTERNAL_FINDOPENCV:BOOL=TRUE 
-DENABLE_APPSTYLES=ON -DENABLE_MYSQLSUPPORT=on -DENABLE_KINOTIFY=ON 
-DENABLE_OPENCV3=ON -DENABLE_MEDIAPLAYER=ON
 
 %make_jobs VERBOSE=1
 
@@ -269,6 +270,7 @@
 %doc doc/COPYING.DOC
 %doc %{_mandir}/man1/cleanup_digikamdb.1%{ext_man}
 %doc %{_mandir}/man1/digitaglinktree.1%{ext_man}
+%doc %{_kf5_htmldir}/*/
 
 %files lang -f %{name}.lang
 %defattr(-,root,root,-)

++ digikam-5.5.0.tar.xz -> digikam-5.6.0.tar.xz ++
/work/SRC/openSUSE:Factory/digikam/digikam-5.5.0.tar.xz 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-5.6.0.tar.xz differ: char 27, 
line 1




commit digikam for openSUSE:Factory

2017-05-31 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-05-31 12:20:15

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Wed May 31 12:20:15 2017 rev:158 rq:499679 version:5.5.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-03-16 
09:51:26.910527077 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-05-31 
12:20:30.173957305 +0200
@@ -1,0 +2,6 @@
+Tue May 30 09:22:34 UTC 2017 - alarr...@suse.com
+
+- digikam now recommends marble in order for the geolocation widgets
+  to work by default.
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.HTL6P8/_old  2017-05-31 12:20:32.297657512 +0200
+++ /var/tmp/diff_new_pack.HTL6P8/_new  2017-05-31 12:20:32.297657512 +0200
@@ -90,6 +90,7 @@
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 Requires:   exiv2 >= 0.25
+Recommends: marble
 Recommends: showfoto
 # Got merged into libimageeditor in 5.2.0
 Provides:   %{name}-plugin-color = %{version}
@@ -129,7 +130,6 @@
 Recommends: enblend-enfuse
 Recommends: hugin
 Recommends: kipi-plugins-lang = %{version}
-Supplements:packageand(kipi-plugins:marble)
 Obsoletes:  kipi-plugins-acquireimage < %{version}
 Obsoletes:  kipi-plugins-geolocation < %{version}
 Obsoletes:  kipi-plugins5 < %{version}




commit digikam for openSUSE:Factory

2017-03-16 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-03-16 09:42:22

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Thu Mar 16 09:42:22 2017 rev:157 rq:479266 version:5.5.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-03-12 
19:59:58.199971615 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-03-16 
09:51:26.910527077 +0100
@@ -1,0 +2,32 @@
+Tue Mar 14 12:13:07 UTC 2017 - fab...@ritter-vogt.de
+
+- Update to 5.5.0:
+  * https://www.digikam.org/node/765
+- New features (from NEWS):
+Database: Add new options to ignore some kind of directories while 
scanning collections.
+Database: We introduced garbage collection for databases as maintenance 
stage. This stage removes stale image,
+  thumbnail and face entries gut does not shrink Databases 
automatically.
+Faces   : It is now possible to remove face tags from people sidebar but 
preserve them in tags sidebar.
+Faces   : Recognised but unconfirmed faces are now visible both in the 
recognised face tag and also in a special tag called Unconfirmed.
+Faces   : The list of proposed names for name assignment in people sidebar 
can now be reduced to face tags with a setup option.
+Faces   : Tags in tags sidebar can now be marked as face tags via context 
menu if they are not already.
+Maintenance : The maintenance now does not generate massive amounts of threads 
anymore. Instead, we use a queue based approach to
+  level the load on the CPUs more appropriate. This should improve 
the reactiveness during maintenance.
+Searches: Improved the exactness of similarity recognition for external 
images dropped in fuzzy search.
+Searches: Introduced a configurable lower bound for the minimum similarity 
in fuzzy and duplicates search.
+Searches: The results of duplicates searches can now be restricted. It is 
now possible to restrict the duplicates to the ones that
+  are in the same album as the reference image or in another 
album. This feature is also usable in maintenance.
+Searches: In duplicates view, the reference image is more clearly 
identified by the description reference image in the image information.
+BQM : Several usability improvements in Watermark tool.
+General : Unsharp Mask filter can now reduce color noise to process image 
in HSL color space.
+General : Update internal Libraw to 0.18.2 : new camera supported: Sigma 
Quattro H.
+  Fixed bug in exposure computation for Fuji camera. Fix wrong 
black level in Sony A350.
+  Fix Sony metadata parser. Fix Phase One decoding.
+
+- Many bugs fixed
+- Remove patches, now upstream:
+  * fix-build-with-ecm-5.31.patch
+  * hide-functions-that-are-no-longer-available.patch
+- Disable building docs, those are broken upstream (kde#377597)
+
+---

Old:

  digikam-5.4.0.tar.xz
  fix-build-with-ecm-5.31.patch
  hide-functions-that-are-no-longer-available.patch

New:

  digikam-5.5.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.7UHGC7/_old  2017-03-16 09:51:29.414172516 +0100
+++ /var/tmp/diff_new_pack.7UHGC7/_new  2017-03-16 09:51:29.418171949 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:5.4.0
+Version:5.5.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
@@ -26,10 +26,6 @@
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE find_libastro-qt5.patch -- fix build of geolocation 
support in Leap 42.1
 Patch0: find_libastro-qt5.patch
-# PATCH-FIX-UPSTREAM fix-build-with-ecm-5.31.patch -- fix build with 
-fno-operator-names as used by default by extra-cmake-modules 5.31.0
-Patch1: fix-build-with-ecm-5.31.patch
-# PATCH-FIX-UPSTREAM hide-functions-that-are-no-longer-available.patch -- hide 
functions that are no longer available in the current Google
-Patch2: hide-functions-that-are-no-longer-available.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -55,6 +51,7 @@
 BuildRequires:  libgcrypt-devel
 BuildRequires:  libgphoto2-devel >= 2.4.0
 # It invokes "gphoto2" for determining the API version
+BuildRequires:  QtAV-devel >= 1.11
 BuildRequires:  gphoto
 BuildRequires:  libgpod-devel
 BuildRequires:  libjasper-devel
@@ -75,7 +72,6 @@
 BuildRequires:  marble-devel
 BuildRequires:  mysql
 BuildRequires:  opencv-qt5-devel

commit digikam for openSUSE:Factory

2017-03-12 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-03-12 19:59:56

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Sun Mar 12 19:59:56 2017 rev:156 rq:462078 version:5.4.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-03-02 
19:36:25.343389450 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-03-12 
19:59:58.199971615 +0100
@@ -1,0 +2,6 @@
+Thu Mar  2 07:48:20 UTC 2017 - jsl...@suse.com
+
+- add hide-functions-that-are-no-longer-available.patch: hide functions
+  that are no longer available in the current Google (kde#376913)
+
+---

New:

  hide-functions-that-are-no-longer-available.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.qqkwJ1/_old  2017-03-12 20:00:00.287676210 +0100
+++ /var/tmp/diff_new_pack.qqkwJ1/_new  2017-03-12 20:00:00.291675644 +0100
@@ -28,6 +28,8 @@
 Patch0: find_libastro-qt5.patch
 # PATCH-FIX-UPSTREAM fix-build-with-ecm-5.31.patch -- fix build with 
-fno-operator-names as used by default by extra-cmake-modules 5.31.0
 Patch1: fix-build-with-ecm-5.31.patch
+# PATCH-FIX-UPSTREAM hide-functions-that-are-no-longer-available.patch -- hide 
functions that are no longer available in the current Google
+Patch2: hide-functions-that-are-no-longer-available.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -171,6 +173,9 @@
 %patch0 -p1
 %endif
 %patch1 -p1
+pushd extra/kipi-plugins
+%patch2 -p1
+popd
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ hide-functions-that-are-no-longer-available.patch ++
>From f1f3c15931dbc6b8e05451ba23508debac202d96 Mon Sep 17 00:00:00 2001
From: Maik Qualmann 
Date: Sun, 26 Feb 2017 11:24:25 +0100
Subject: hide functions that are no longer available in the current Google
 Data API V3 CCBUGS: 376913
Git-commit: f1f3c15931dbc6b8e05451ba23508debac202d96
References: kde#376913

---
 googleservices/gswidget.cpp | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/googleservices/gswidget.cpp b/googleservices/gswidget.cpp
index 149a6a5..fc89c9a 100644
--- a/googleservices/gswidget.cpp
+++ b/googleservices/gswidget.cpp
@@ -93,8 +93,10 @@ GoogleServicesWidget::GoogleServicesWidget(QWidget* const 
parent, KIPI::Interfac
 m_LeafBox->hide();
 break;
 default:
+getNewAlbmBtn()->hide();// Google has removed this function in 
the current API V3.
 getUploadBox()->hide();
 getSizeBox()->hide();
+m_LeafBox->hide();// Google has removed this function in the 
current API V3.
 break;
 }
 }
-- 
cgit v0.11.2




commit digikam for openSUSE:Factory

2017-03-02 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-03-02 19:36:24

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Thu Mar  2 19:36:24 2017 rev:155 rq:460533 version:5.4.0

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2017-02-03 
17:35:42.205666164 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-03-02 
19:36:25.343389450 +0100
@@ -1,0 +2,11 @@
+Sun Feb 26 13:00:27 UTC 2017 - tittiatc...@gmail.com
+
+- Drop the useless Buildrequires on soprano
+
+---
+Sun Feb 19 02:32:27 UTC 2017 - wba...@tmo.at
+
+- Added fix-build-with-ecm-5.31.patch to fix build with the latest
+  KDE Frameworks 5.31.0
+
+---

New:

  fix-build-with-ecm-5.31.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.Ayo6bh/_old  2017-03-02 19:36:28.614926491 +0100
+++ /var/tmp/diff_new_pack.Ayo6bh/_new  2017-03-02 19:36:28.614926491 +0100
@@ -26,6 +26,8 @@
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE find_libastro-qt5.patch -- fix build of geolocation 
support in Leap 42.1
 Patch0: find_libastro-qt5.patch
+# PATCH-FIX-UPSTREAM fix-build-with-ecm-5.31.patch -- fix build with 
-fno-operator-names as used by default by extra-cmake-modules 5.31.0
+Patch1: fix-build-with-ecm-5.31.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -72,7 +74,6 @@
 BuildRequires:  mysql
 BuildRequires:  opencv-qt5-devel
 BuildRequires:  QtAV-devel >= 1.11
-BuildRequires:  soprano-backend-redland
 BuildRequires:  threadweaver-devel >= 5.1.0
 BuildRequires:  update-desktop-files
 BuildRequires:  xorg-x11-devel
@@ -169,6 +170,7 @@
 # we renamed libastro to libastro-qt5 in Leap 42.1, make FindMARBLE.cmake find 
it
 %patch0 -p1
 %endif
+%patch1 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ fix-build-with-ecm-5.31.patch ++
>From 3793b47b6f57a627911bcce819b1ecc2dc9e422a Mon Sep 17 00:00:00 2001
From: Kevin Funk 
Date: Wed, 18 Jan 2017 13:34:55 +0100
Subject: Fix compilation with new KDECompilerSettings.cmake

---
 app/utils/libopencv.h.cmake.in | 4 ++--
 libs/database/CMakeLists.txt   | 3 +++
 libs/dimg/CMakeLists.txt   | 3 +++
 3 files changed, 8 insertions(+), 2 deletions(-)

diff --git a/core/app/utils/libopencv.h.cmake.in 
b/core/app/utils/libopencv.h.cmake.in
index cc58b7c..6abf642 100644
--- a/core/app/utils/libopencv.h.cmake.in
+++ b/core/app/utils/libopencv.h.cmake.in
@@ -27,7 +27,7 @@
 #define LIB_OPEN_CV_H
 
 // Pragma directives to reduce warnings from OpenCV header files.
-#if not defined(__APPLE__) && defined(__GNUC__)
+#if !defined(__APPLE__) && defined(__GNUC__)
 #pragma GCC diagnostic push
 #pragma GCC diagnostic ignored "-Wnon-virtual-dtor"
 #pragma GCC diagnostic ignored "-Woverloaded-virtual"
@@ -82,7 +82,7 @@
 #endif
 
 // Restore warnings
-#if not defined(__APPLE__) && defined(__GNUC__)
+#if !defined(__APPLE__) && defined(__GNUC__)
 #pragma GCC diagnostic pop
 #endif
 
diff --git a/core/libs/database/CMakeLists.txt 
b/core/libs/database/CMakeLists.txt
index c5d9c27..14a7180 100644
--- a/core/libs/database/CMakeLists.txt
+++ b/core/libs/database/CMakeLists.txt
@@ -10,6 +10,9 @@ if (POLICY CMP0063)
 cmake_policy(SET CMP0063 NEW)
 endif (POLICY CMP0063)
 
+# Boost uses operator names (and, not, ...)
+string(REPLACE "-fno-operator-names" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
+
 set(libdatabasecore_SRCS
 server/databaseserverstarter.cpp
 server/databaseservererror.cpp
diff --git a/core/libs/dimg/CMakeLists.txt b/core/libs/dimg/CMakeLists.txt
index 3bcada5..04a0a22 100644
--- a/core/libs/dimg/CMakeLists.txt
+++ b/core/libs/dimg/CMakeLists.txt
@@ -11,6 +11,9 @@ endif (POLICY CMP0063)
 
 kde_enable_exceptions()
 
+# Boost uses operator names (and, not, ...)
+string(REPLACE "-fno-operator-names" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
+
 set(libdimg_SRCS
 dimg.cpp
 drawdecoding.cpp
-- 
cgit v0.11.2

>From 86cd0d1d89c8b4d13f06dc8a353bdd99f13c4758 Mon Sep 17 00:00:00 2001
From: Gilles Caulier 
Date: Wed, 18 Jan 2017 10:13:20 +0100
Subject: Fix compilation with clang

---
 libs/database/imagehistory/imagehistorygraph_boost.h  | 4 ++--
 libs/dimg/filters/greycstoration/greycstorationfilter.cpp | 4 ++--
 

commit digikam for openSUSE:Factory

2017-02-03 Thread root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2017-01-27 11:08:58

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-11-10 
13:14:46.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2017-02-03 
17:35:42.205666164 +0100
@@ -1,0 +2,82 @@
+Wed Jan 11 08:18:59 UTC 2017 - nico.kru...@gmail.com
+
+- update to 5.4.0
+  digikam:
+- Searches: Improvements of duplicate searches to introduce a
+range of similarity of items.
+- Searches: Improvements of duplicate searches to be able to
+sort search albums list view by similary level.
+- Searches: Improvements of duplicate searches to permit
+multiple selection in search albums list view.
+- Searches: Improvements of fuzzy searches to permit fuzzy
+search on local images not present in the
+database via drag & drop.
+- Searches: Improvements of duplicate/fuzzy/sketch searches
+to permit sorting the resulting images in image
+view by similarity level.
+- Searches: Improvements of duplicate/fuzzy/sketch search
+results by showing the concrete similarity values
+in table view.
+- AlbumGUI: Improvements of grouped images to apply renaming,
+copying or metadata actions to all images.
+- General: Media player is now ported to QtAV instead
+Qt5Multimedia (http://www.qtav.org/).
+- General: Add support of animated GIF in preview mode.
+- SlideShow: Add video support.
+- Presentation: Add video support.
+- General: Update internal Libraw to last 0.18.
+- over 193 bugfixes, among them:
+  kde#366624, kde#372027, kde#372232, kde#294579, kde#307332,
+  kde#368762, kde#371543, kde#369051, kde#372217, kde#372362,
+  kde#372341, kde#372326, kde#372314, kde#372164, kde#372433,
+  kde#372442, kde#366567, kde#274360, kde#372380, kde#372484,
+  kde#372323, kde#372583, kde#372584, kde#372683, kde#372640,
+  kde#370150, kde#372672, kde#372722, kde#204006, kde#372312,
+  kde#366162, kde#261417, kde#354232, kde#372684, kde#372781,
+  kde#372831, kde#372872, kde#372859, kde#367611, kde#371899,
+  kde#363998, kde#361848, kde#330062, kde#372900, kde#372427,
+  kde#102500, kde#330064, kde#372628, kde#372540, kde#373003,
+  kde#370553, kde#372093, kde#352870, kde#373100, kde#334799,
+  kde#321145, kde#320628, kde#285910, kde#340609, kde#370744,
+  kde#339961, kde#312054, kde#373500, kde#362406, kde#301936,
+  kde#327244, kde#256179, kde#327391, kde#373272, kde#159824,
+  kde#372755, kde#366387, kde#348933, kde#330112, kde#222319,
+  kde#281718, kde#280755, kde#373715, kde#301029, kde#242799,
+  kde#260594, kde#230985, kde#151539, kde#332074, kde#336309,
+  kde#335996, kde#336594, kde#225731, kde#096133, kde#091538,
+  kde#151540, kde#372485, kde#370228, kde#216655, kde#248586,
+  kde#139690, kde#373606, kde#373954, kde#373754, kde#373562,
+  kde#374010, kde#339748, kde#337300, kde#349924, kde#292316,
+  kde#152522, kde#144078, kde#336791, kde#132369, kde#142051,
+  kde#340093, kde#335299, kde#147466, kde#187959, kde#330579,
+  kde#356939, kde#48, kde#320666, kde#302923, kde#374109,
+  kde#339027, kde#339092, kde#175626, kde#335885, kde#267992,
+  kde#235920, kde#294432, kde#264035, kde#369681, kde#369595,
+  kde#366440, kde#349929, kde#221690, kde#363116, kde#374071,
+  kde#313507, kde#353534, kde#097078, kde#096878, kde#119424,
+  kde#145228, kde#354867, kde#150076, kde#374135, kde#203714,
+  kde#374178, kde#374179, kde#370392, kde#372420, kde#366234,
+  kde#374185, kde#372481, kde#284780, kde#368124, kde#360155,
+  kde#374354, kde#360955, kde#371530, kde#365313, kde#366247,
+  kde#374326, kde#374327, kde#374413, kde#296580, kde#374428,
+  kde#340986, kde#339308, kde#321531, kde#372159, kde#357696,
+  kde#199608, kde#335915, kde#274893, kde#180701, kde#362300,
+  kde#358092, kde#288658, kde#352295, kde#36, kde#292230,
+  kde#220201, kde#374191, kde#344698, kde#335340, kde#335051,
+  kde#333737, kde#330848, kde#319702, kde#244789, kde#261914,
+  kde#323194, kde#261397, kde#323514
+  kipi-plugins:
+- kde#373434 - No exif data in pictures exported to Flickr.
+- kde#374242 - exported photos to Gphoto are rotated.
+- kde#374409 - Export to Flickr ignores EXIF Orientation.
+- kde#329309 - TIF files appear not in correct orientation in
+   Piwigo.
+- kde#374510 - Creating albums on flickr with 

commit digikam for openSUSE:Factory

2016-11-10 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-11-10 13:14:41

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-10-10 
16:16:08.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-11-10 
13:14:46.0 +0100
@@ -1,0 +2,7 @@
+Tue Nov  8 10:48:30 UTC 2016 - wba...@tmo.at
+
+- Update to Digikam v5.3.0: https://www.digikam.org/node/761
+  * bugfixes
+- Drop upstreamed patch migration_from_digikam4.diff
+
+---

Old:

  digikam-5.2.0.tar.xz
  migration_from_digikam4.diff

New:

  digikam-5.3.0.tar.xz



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.aBB3xg/_old  2016-11-10 13:14:52.0 +0100
+++ /var/tmp/diff_new_pack.aBB3xg/_new  2016-11-10 13:14:52.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:5.2.0
+Version:5.3.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
@@ -25,9 +25,7 @@
 Url:http://www.digikam.org/
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE find_libastro-qt5.patch -- fix build of geolocation 
support in Leap 42.1
-Patch2: find_libastro-qt5.patch
-# PATCH-FIX-UPSTREAM migration_from_digikam4.diff alarr...@suse.com kde#364258 
kde#357944 kde#368968 -- Migration wizard page to migrate configuration and db 
from digikam4
-Patch3: migration_from_digikam4.diff
+Patch0: find_libastro-qt5.patch
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -170,9 +168,8 @@
 %setup -q -n %{name}-%{version}
 %if 0%{?is_opensuse} && 0%{?sle_version} == 120100
 # we renamed libastro to libastro-qt5 in Leap 42.1, make FindMARBLE.cmake find 
it
-%patch2 -p1
+%patch0 -p1
 %endif
-%patch3 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ digikam-5.2.0.tar.xz -> digikam-5.3.0.tar.xz ++
/work/SRC/openSUSE:Factory/digikam/digikam-5.2.0.tar.xz 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-5.3.0.tar.xz differ: char 27, 
line 1




commit digikam for openSUSE:Factory

2016-10-10 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-10-10 16:16:08

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-10-03 
15:50:07.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-10-10 
16:16:08.0 +0200
@@ -1,0 +2,7 @@
+Mon Oct  3 16:27:33 UTC 2016 - alarr...@suse.com
+
+- Updated migration_from_digikam4.diff to migrate also the
+  geobookmarks.xml file from digikam4. This patch thus fixes
+  kde#364258, kde#357944 and kde#368968.
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.ACq4a5/_old  2016-10-10 16:16:15.0 +0200
+++ /var/tmp/diff_new_pack.ACq4a5/_new  2016-10-10 16:16:15.0 +0200
@@ -26,7 +26,7 @@
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE find_libastro-qt5.patch -- fix build of geolocation 
support in Leap 42.1
 Patch2: find_libastro-qt5.patch
-# PATCH-FIX-UPSTREAM migration_from_digikam4.diff alarr...@suse.com kde#364258 
-- Migration wizard page to migrate configuration and db from digikam4
+# PATCH-FIX-UPSTREAM migration_from_digikam4.diff alarr...@suse.com kde#364258 
kde#357944 kde#368968 -- Migration wizard page to migrate configuration and db 
from digikam4
 Patch3: migration_from_digikam4.diff
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64

++ migration_from_digikam4.diff ++
--- /var/tmp/diff_new_pack.ACq4a5/_old  2016-10-10 16:16:15.0 +0200
+++ /var/tmp/diff_new_pack.ACq4a5/_new  2016-10-10 16:16:15.0 +0200
@@ -111,7 +111,7 @@
 ===
 --- /dev/null
 +++ 
digikam-5.2.0/core/utilities/assistants/firstrun/migratefromdigikam4page.cpp
-@@ -0,0 +1,203 @@
+@@ -0,0 +1,220 @@
 +/* 
 + *
 + * This file is a part of digiKam project
@@ -255,7 +255,24 @@
 + qCDebug(DIGIKAM_GENERAL_LOG) << "Config file" << oldConfigFile 
<< "was migrated to" << newConfigLocation;
 + }
 + }
++  }
++
++  // Migrate $KDEHOME/share/apps/kipi/geobookmarks.xml to 
./.local/share/digikam/geobookmarks.xml
++  QString oldGeobookmarksFile = migration.locateLocal("data", 
QStringLiteral("kipi/geobookmarks.xml"));
++  const QString newGeobookmarksFile = 
QStandardPaths::writableLocation(QStandardPaths::DataLocation)
+++ QStringLiteral("/geobookmarks.xml");
++
++  if (QFile(newGeobookmarksFile).exists()) {
++ qCDebug(DIGIKAM_GENERAL_LOG) << newGeobookmarksFile << " already exists. 
Skipping";
++  } else {
++ QFileInfo fileInfo(newGeobookmarksFile);
++ QDir().mkpath(fileInfo.absolutePath());
 +
++ if (!oldGeobookmarksFile.isEmpty()) {
++ if (QFile(oldGeobookmarksFile).copy(newGeobookmarksFile)) {
++ qCDebug(DIGIKAM_GENERAL_LOG) << "Config file" << 
oldGeobookmarksFile << "was migrated to" << newGeobookmarksFile;
++ }
++ }
 +  }
 +
 +  // Fix albumroot identifier since digiKam 5 doesn't interpret correctly
@@ -402,7 +419,8 @@
 -#else
 -  // Linux settings place.
 -QLatin1String("~/.config/"), 
QLatin1String("~/.kde4/share/config")
- #endif
+-#endif
++#endif
 +#else // defined Q_OS_LINUX
 +"",
 +QLatin1String(digikam_version_short)




commit digikam for openSUSE:Factory

2016-10-03 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-10-03 15:50:02

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-09-30 
15:22:58.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-10-03 
15:50:07.0 +0200
@@ -1,0 +2,8 @@
+Mon Oct  3 07:55:43 UTC 2016 - alarr...@suse.com
+
+- Added migration_from_digikam4.diff to support migration of
+  settings and database from digikam4 the first time digikam5
+  is run by adding a migration page in the welcome wizard and
+  letting the user choose what to do (kde#364258).
+
+---

New:

  migration_from_digikam4.diff



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.FxSiih/_old  2016-10-03 15:50:11.0 +0200
+++ /var/tmp/diff_new_pack.FxSiih/_new  2016-10-03 15:50:11.0 +0200
@@ -26,6 +26,8 @@
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 # PATCH-FIX-OPENSUSE find_libastro-qt5.patch -- fix build of geolocation 
support in Leap 42.1
 Patch2: find_libastro-qt5.patch
+# PATCH-FIX-UPSTREAM migration_from_digikam4.diff alarr...@suse.com kde#364258 
-- Migration wizard page to migrate configuration and db from digikam4
+Patch3: migration_from_digikam4.diff
 #This pulls in QWebEngine, which is not available on ppc64
 %ifarch %ix86 x86_64 %arm aarch64 mips mips64
 BuildRequires:  akonadi-contact-devel
@@ -170,6 +172,7 @@
 # we renamed libastro to libastro-qt5 in Leap 42.1, make FindMARBLE.cmake find 
it
 %patch2 -p1
 %endif
+%patch3 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ migration_from_digikam4.diff ++
Index: digikam-5.2.0/core/utilities/assistants/firstrun/CMakeLists.txt
===
--- digikam-5.2.0.orig/core/utilities/assistants/firstrun/CMakeLists.txt
+++ digikam-5.2.0/core/utilities/assistants/firstrun/CMakeLists.txt
@@ -11,6 +11,7 @@ endif (POLICY CMP0063)
 
 set(libfirstrun_SRCS
 firstrundlg.cpp
+migratefromdigikam4page.cpp
 firstrundlgpage.cpp
 welcomepage.cpp
 collectionpage.cpp
@@ -26,6 +27,7 @@ set(libfirstrun_SRCS
 include_directories($
 
$
 $
+$
 
 $
 
$
Index: digikam-5.2.0/core/utilities/assistants/firstrun/firstrundlg.cpp
===
--- digikam-5.2.0.orig/core/utilities/assistants/firstrun/firstrundlg.cpp
+++ digikam-5.2.0/core/utilities/assistants/firstrun/firstrundlg.cpp
@@ -27,10 +27,15 @@
 
 #include 
 
+// KDE includes
+
+#include 
+
 // Local incudes
 
 #include "dxmlguiwindow.h"
 #include "welcomepage.h"
+#include "migratefromdigikam4page.h"
 #include "collectionpage.h"
 #include "databasepage.h"
 #include "rawpage.h"
@@ -49,6 +54,7 @@ public:
 
 Private() :
 welcomePage(0),
+migrateFromDigikam4Page(0),
 collectionPage(0),
 databasePage(0),
 rawPage(0),
@@ -61,6 +67,7 @@ public:
 }
 
 WelcomePage*welcomePage;
+MigrateFromDigikam4Page*migrateFromDigikam4Page;
 CollectionPage* collectionPage;
 DatabasePage*   databasePage;
 RawPage*rawPage;
@@ -82,7 +89,21 @@ FirstRunDlg::FirstRunDlg(QWidget* const
<< QWizard::NextButton
<< QWizard::FinishButton);
 
+bool migrateAvailable = false;
+
+#ifdef Q_OS_LINUX
+::Kdelibs4Migration migration;
+
+// If there's a digikamrc file in $KDEHOME/share/config,
+// then we create the migration page in the wizard
+migrateAvailable = !migration.locateLocal("config", 
QStringLiteral("digikamrc")).isEmpty();
+#endif
+
 d->welcomePage= new WelcomePage(this);// First assistant page
+
+if (migrateAvailable)
+   d->migrateFromDigikam4Page = new MigrateFromDigikam4Page(this);
+
 d->collectionPage = new CollectionPage(this);
 d->databasePage   = new 

commit digikam for openSUSE:Factory

2016-09-30 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-09-30 15:22:10

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-06-03 
16:38:01.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-09-30 
15:22:58.0 +0200
@@ -1,0 +2,79 @@
+Thu Sep 29 22:19:22 UTC 2016 - lbeltr...@kde.org
+
+- Workaround kde#369517 by removing libvkontakte translations
+  (not built but installed anyway) 
+
+---
+Tue Sep 27 11:42:16 UTC 2016 - lbeltr...@kde.org
+
+- Ensure akonadi-contact-devel is not pulled in for ppc64, as
+  QWebEngine is not available for that platform
+
+---
+Sun Sep 25 12:08:37 UTC 2016 - wba...@tmo.at
+
+- Don't disable building the documentation any more, kde#365135 is
+  fixed in 5.2.0
+
+---
+Sat Sep 24 10:09:11 UTC 2016 - fab...@ritter-vogt.de
+
+- Update to Digikam v5.2.0: https://www.digikam.org/node/758
+  * many bugfixes
+  * updated documentation
+
+- Remove build-32bits.patch again, fixed upstream
+- Add threadweaver and gphoto buildrequires
+- Enable appstyles to not force fusion style
+- Fix miscellaneous rpmlint warnings
+
+---
+Wed Aug 10 14:39:26 UTC 2016 - wba...@tmo.at
+
+- Add find_libastro-qt5.patch to fix build of geolocation support
+  in Leap 42.1
+
+---
+Wed Aug 10 08:56:28 UTC 2016 - fab...@ritter-vogt.de
+
+- Update to Digikam v5.1.0: https://www.digikam.org/node/756
+  * many bugfixes
+  * supports new RAW cameras
+
+- Add build-32bits.patch to fix build on 32-bit x86
+
+---
+Fri Jul 15 15:39:44 UTC 2016 - wba...@tmo.at
+
+- Enable mediaplayer (Qt5Multimedia support)
+
+---
+Wed Jul 13 09:30:19 UTC 2016 - tittiatc...@gmail.com
+
+- Drop unused build dependency on sqlite2
+- Obsolete the kipi-plugins5 package
+
+---
+Sun Jul 10 21:34:47 UTC 2016 - nico.kru...@gmail.com
+
+- raise dependency on libkipi version
+
+---
+Fri Jul  8 09:47:19 UTC 2016 - tittiatc...@gmail.com
+
+- Update to Digikam v5.0
+  * Now Qt5/KF5 based
+
+- Drop patches no longer required:
+  - fix_opencv3.patch
+  - digikam-4.14.0-lensfun-0.3.2.patch
+  - digikam-4.4.0.no-kdcraw.version-check.patch
+  - remove-gplv2-only.patch
+  - digikam-buildtime.patch
+
+- Drop library tarball, as we now depend on the external libraries
+  - digikam-libs.tar.bz2
+  
+- Disable documentation for now based on bko#365135
+
+---

Old:

  digikam-4.14.0-lensfun-0.3.2.patch
  digikam-4.14.0.tar.bz2
  digikam-4.4.0.no-kdcraw.version-check.patch
  digikam-buildtime.patch
  digikam-libs.tar.bz2
  fix_opencv3.patch
  remove-gplv2-only.patch

New:

  digikam-5.2.0.tar.xz
  find_libastro-qt5.patch



Other differences:
--
++ digikam.spec ++
 647 lines (skipped)
 between /work/SRC/openSUSE:Factory/digikam/digikam.spec
 and /work/SRC/openSUSE:Factory/.digikam.new/digikam.spec

++ find_libastro-qt5.patch ++
diff -urB digikam/core/cmake/modules/FindMarble.cmake 
new/core/cmake/modules/FindMarble.cmake
--- digikam/core/cmake/modules/FindMarble.cmake 2015-10-17 08:33:01.347270719 
+0200
+++ new/core/cmake/modules/FindMarble.cmake 2015-10-17 12:07:56.423127921 
+0200
@@ -19,7 +19,7 @@
 
 FIND_PATH( MARBLE_INCLUDE_DIR NAMES marble/MarbleModel.h )
 FIND_LIBRARY( MARBLE_LIBRARIES NAMES marblewidget-qt5 marblewidget-qt5d )
-FIND_LIBRARY( ASTRO_LIBRARIES NAMES astro astrod )
+FIND_LIBRARY( ASTRO_LIBRARIES NAMES astro-qt5 astro-qt5d )
 
 INCLUDE( FindPackageHandleStandardArgs )
 



commit digikam for openSUSE:Factory

2016-06-03 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-06-03 16:38:00

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-05-24 
09:34:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-06-03 
16:38:01.0 +0200
@@ -1,0 +2,5 @@
+Thu Jun  2 05:59:05 UTC 2016 - m...@suse.com
+
+- Bump libKF5Kipi version to libKF5Kipi31_0_0
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.QLv1qE/_old  2016-06-03 16:38:03.0 +0200
+++ /var/tmp/diff_new_pack.QLv1qE/_new  2016-06-03 16:38:03.0 +0200
@@ -239,7 +239,7 @@
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
 #Require the lib for the shared icons
-Requires:   libKF5Kipi30_0_0
+Requires:   libKF5Kipi31_0_0
 Recommends: marble-data
 Obsoletes:  libkdcraw23 < %{libversion}
 Provides:   libkdcraw23 = %{libversion}




commit digikam for openSUSE:Factory

2016-05-24 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-05-24 09:34:03

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-03-11 
09:37:36.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-05-24 
09:34:04.0 +0200
@@ -1,0 +2,6 @@
+Thu May 12 10:47:43 UTC 2016 - mathias.hom...@opensuse.org
+
+- Add patch digikam-4.14.0-lensfun-0.3.2.patch to make digikam
+  build with the latest lensfun version
+
+---

New:

  digikam-4.14.0-lensfun-0.3.2.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.Ba0uU1/_old  2016-05-24 09:34:06.0 +0200
+++ /var/tmp/diff_new_pack.Ba0uU1/_new  2016-05-24 09:34:06.0 +0200
@@ -35,6 +35,9 @@
 Patch6: digikam-4.4.0.no-kdcraw.version-check.patch
 # PATCH-FIX-OPENSUSE fix_opencv3.patch -- Fix the internal libkface to work 
with openCV version 3.0. This is based on upstream changes
 Patch100:   fix_opencv3.patch
+# PATCH: Building with lensfun 0.3.2
+Patch999:   digikam-4.14.0-lensfun-0.3.2.patch
+
 BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -268,6 +271,7 @@
 %patch3
 %patch6 -p1
 %patch100 -p1
+%patch999 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ digikam-4.14.0-lensfun-0.3.2.patch ++
diff -burNE digikam-4.14.0/core/libs/dimg/filters/lens/lensfuniface.h 
digikam-4.14.0_work/core/libs/dimg/filters/lens/lensfuniface.h
--- digikam-4.14.0/core/libs/dimg/filters/lens/lensfuniface.h   2015-10-13 
23:58:21.0 +0200
+++ digikam-4.14.0_work/core/libs/dimg/filters/lens/lensfuniface.h  
2016-05-12 10:35:13.461127704 +0200
@@ -24,10 +24,10 @@
 
 // Lib LensFun includes
 
-extern "C"
-{
+// extern "C"
+// {
 #include 
-}
+// }
 
 // local includes
 



commit digikam for openSUSE:Factory

2016-03-11 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-03-11 09:37:34

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-03-05 
11:21:31.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-03-11 
09:37:36.0 +0100
@@ -1,0 +2,5 @@
+Mon Mar  7 10:47:43 UTC 2016 - norm...@linux.vnet.ibm.com
+
+- add _constraints file to set min disk space for ppc64le build
+
+---

New:

  _constraints



Other differences:
--
++ _constraints ++

  

  4500

  
  

  ppc64le


   
 6000
   

  




commit digikam for openSUSE:Factory

2016-03-05 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-03-05 11:21:28

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-02-22 
10:10:05.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-03-05 
11:21:31.0 +0100
@@ -1,0 +2,6 @@
+Thu Mar  3 13:45:53 UTC 2016 - tittiatc...@gmail.com
+
+- Add fix_opencv3.patch in order to build the internal libkface 
+  with openCV 3.x
+
+---

New:

  fix_opencv3.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.f1Kc0n/_old  2016-03-05 11:21:33.0 +0100
+++ /var/tmp/diff_new_pack.f1Kc0n/_new  2016-03-05 11:21:33.0 +0100
@@ -33,6 +33,8 @@
 Patch3: remove-gplv2-only.patch
 # PATCH-FIX-UPSTREAM digikam-4.4.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
 Patch6: digikam-4.4.0.no-kdcraw.version-check.patch
+# PATCH-FIX-OPENSUSE fix_opencv3.patch -- Fix the internal libkface to work 
with openCV version 3.0. This is based on upstream changes
+Patch100:   fix_opencv3.patch
 BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -224,7 +226,6 @@
 Requires:   kipi-plugin-icons
 %endif
 
-
 %description -n kipi-plugins
 A set of plug-ins for the KDE KIPI interface, used by some KDE imaging
 applications.
@@ -266,6 +267,7 @@
 %patch0
 %patch3
 %patch6 -p1
+%patch100 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
@@ -289,7 +291,7 @@
 EXTRA_FLAGS+=" -DDIGIKAMSC_COMPILE_LIBKSANE=ON -DDIGIKAMSC_COMPILE_LIBKFACE=ON"
 EXTRA_FLAGS+=" -DDIGIKAMSC_COMPILE_LIBKGEOMAP=ON 
-DDIGIKAMSC_COMPILE_LIBMEDIAWIKI=ON"
 %endif
-%cmake_kde4 -d build -- -DENABLE_MYSQLSUPPORT=TRUE 
-DENABLE_INTERNALMYSQL=FALSE -DENABLE_KDEPIMLIBSSUPPORT=TRUE $EXTRA_FLAGS
+%cmake_kde4 -d build -- -DENABLE_OPENCV3=ON -DENABLE_MYSQLSUPPORT=TRUE 
-DENABLE_INTERNALMYSQL=FALSE -DENABLE_KDEPIMLIBSSUPPORT=TRUE $EXTRA_FLAGS 
 
 # there are files in there that are so heavy to the compiler, that one is 
enough
 %make_jobs VERBOSE=1

++ fix_opencv3.patch ++
diff -urNB a/extra/libkface/CMakeLists.txt b/extra/libkface/CMakeLists.txt
--- a/extra/libkface/CMakeLists.txt 2015-09-03 23:22:44.0 +0200
+++ b/extra/libkface/CMakeLists.txt 2016-03-04 07:53:19.390177947 +0100
@@ -29,8 +29,33 @@
 
 set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} 
${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
 
+# OpenCV detection
 include(MacroOpenCV)
-DETECT_OPENCV(2.4.9 core highgui objdetect contrib legacy imgproc)
+
+if(ENABLE_OPENCV3)
+
+set(OPENCV_MIN_VERSION "3.0.0")
+DETECT_OPENCV(${OPENCV_MIN_VERSION} core face highgui objdetect imgproc)
+
+if(${OpenCV_FOUND})
+if(${OpenCV_VERSION} VERSION_LESS 3.0.0)
+message(STATUS "ENABLE_OPENCV3 option is enabled and OpenCV < 
3.0.0 have been found. Disabled ENABLE_OPENCV3")
+set(OpenCV_FOUND FALSE)
+endif()
+endif()
+
+else()
+set(OPENCV_MIN_VERSION "2.4.9")
+DETECT_OPENCV(${OPENCV_MIN_VERSION} core highgui objdetect contrib legacy 
imgproc)
+
+if(${OpenCV_FOUND})
+if(${OpenCV_VERSION} VERSION_GREATER 2.4.99)
+message(STATUS "ENABLE_OPENCV3 option is disabled and OpenCV >= 
3.0.0 have been found. Enabled ENABLE_OPENCV3")
+set(OpenCV_FOUND FALSE)
+endif()
+endif()
+
+endif()
 
 include_directories(${OpenCV_INCLUDE_DIRS})
 
diff -urNB a/extra/libkface/libkface/CMakeLists.txt 
b/extra/libkface/libkface/CMakeLists.txt
--- a/extra/libkface/libkface/CMakeLists.txt2015-09-03 23:22:44.0 
+0200
+++ b/extra/libkface/libkface/CMakeLists.txt2016-03-04 08:17:38.604392033 
+0100
@@ -1,5 +1,5 @@
 #
-# Copyright (c) 2010-2014, Gilles Caulier, 
+# Copyright (c) 2010-2015, Gilles Caulier, 
 #
 # Redistribution and use is allowed according to the terms of the BSD license.
 # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
diff -urNB a/extra/libkface/libkface/detection/opencvfacedetector.cpp 
b/extra/libkface/libkface/detection/opencvfacedetector.cpp
--- a/extra/libkface/libkface/detection/opencvfacedetector.cpp  2015-09-03 
23:22:44.0 +0200
+++ b/extra/libkface/libkface/detection/opencvfacedetector.cpp  2016-03-04 
09:00:03.837203004 +0100
@@ -136,13 +136,14 @@
 
 cv::Size getOriginalWindowSize() const
 {
+#if OPENCV_VERSION <= OPENCV_MAKE_VERSION(2,4,99)
 // This is a 

commit digikam for openSUSE:Factory

2016-02-22 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-02-22 10:10:03

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-01-30 
11:31:46.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-02-22 
10:10:05.0 +0100
@@ -1,0 +2,34 @@
+Wed Feb 17 10:17:03 UTC 2016 - tittiatc...@gmail.com
+
+- Remove the kipi-plugin icons to enable co-installability with the 
+  kipi-plugins5 package. The required icons are now shipped in a 
+  seperate package kipi-plugin-icons, which is provided by the 
+  kipi-plugins5 package (boo#966939)
+
+---
+Wed Feb 10 08:17:03 UTC 2016 - tittiatc...@gmail.com
+
+- Drop the requires on digikam from the digikam-libs package. This 
+  would allow digikam-libs to replace the existing libkipi, libkexiv2,
+  etc without pulling in digikam/kipi-plugins (boo#965865)
+
+---
+Wed Feb  3 19:17:03 UTC 2016 - tittiatc...@gmail.com
+
+- Drop the BuildRequire on kdepimlibs4 for Factory
+
+- Make the dependency on marble-data from digikam-libs a recommends
+  to allow more flexibility for users
+
+---
+Sat Jan 30 22:18:07 UTC 2016 - wba...@tmo.at
+
+- Provide/Obsolete libkexiv2-11 instead of libkexiv2, that's the
+  actual name of the package
+
+---
+Sat Jan 30 14:39:32 UTC 2016 - wba...@tmo.at
+
+- Provide/Obsolete libkdcraw23 as well to prevent update problems
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.CwUTKD/_old  2016-02-22 10:10:07.0 +0100
+++ /var/tmp/diff_new_pack.CwUTKD/_new  2016-02-22 10:10:07.0 +0100
@@ -75,7 +75,9 @@
 BuildRequires:  libgpod-devel
 BuildRequires:  libjasper-devel
 BuildRequires:  libkde4-devel
+%if 0%{?suse_version} < 1320
 BuildRequires:  libkdepimlibs4-devel
+%endif
 %if 0%{?suse_version} > 1230
 BuildRequires:  libkqoauth-devel
 %endif
@@ -219,8 +221,10 @@
 %kde4_runtime_requires
 %if 0%{?suse_version} > 1320 || 0%{?suse_version} == 1315
 Requires:   digikam-libs
+Requires:   kipi-plugin-icons
 %endif
 
+
 %description -n kipi-plugins
 A set of plug-ins for the KDE KIPI interface, used by some KDE imaging
 applications.
@@ -230,12 +234,13 @@
 Summary:Libraries required to run digikam
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
-Requires:   %{name} = %{version}
 #Require the lib for the shared icons
 Requires:   libKF5Kipi30_0_0
-Requires:   marble-data
-Obsoletes:  libkexiv2 < %{libversion}
-Provides:   libkexiv2 = %{libversion}
+Recommends: marble-data
+Obsoletes:  libkdcraw23 < %{libversion}
+Provides:   libkdcraw23 = %{libversion}
+Obsoletes:  libkexiv2-11 < %{libversion}
+Provides:   libkexiv2-11 = %{libversion}
 Obsoletes:  libkface3 < %{libversion}
 Provides:   libkface3 = %{libversion}
 Obsoletes:  libkgeomap2 < %{libversion}
@@ -442,7 +447,11 @@
 %{_kde4_configkcfgdir}/photolayoutseditor.kcfg
 %dir %{_kde4_iconsdir}/hicolor/24x24/apps
 %{_kde4_iconsdir}/hicolor/*/actions/*.*
+%if 0%{?suse_version} > 1320 || 0%{?suse_version} == 1315
+%exclude %{_kde4_iconsdir}/hicolor/*/apps/kipi-*.*
+%else
 %{_kde4_iconsdir}/hicolor/*/apps/kipi-*.*
+%endif
 %exclude %{_kde4_iconsdir}/hicolor/*/apps/kipi-gpsimagetag.png
 %{_kde4_iconsdir}/hicolor/*/apps/photolayoutseditor.*
 %{_kde4_iconsdir}/hicolor/*/apps/rawconverter.*




commit digikam for openSUSE:Factory

2016-01-30 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-01-30 11:31:44

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2016-01-23 
01:13:31.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-01-30 
11:31:46.0 +0100
@@ -1,0 +2,14 @@
+Fri Jan 29 16:56:31 UTC 2016 - dims...@opensuse.org
+
+- Split out the five plugins that upstream ships with a
+  metainfo.xml file: color, decorate, enhance, fxfilters and
+  transform. All new subpackages for now supplement the main
+  package (which is equal to the main package recommending them).
+
+---
+Mon Jan 25 11:51:03 UTC 2016 - alarr...@suse.com
+
+- Add symlinks for solid actions so Plasma5 can use digikam to 
+  import images from the device notifier applet
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.YRvdY1/_old  2016-01-30 11:31:49.0 +0100
+++ /var/tmp/diff_new_pack.YRvdY1/_new  2016-01-30 11:31:49.0 +0100
@@ -20,6 +20,7 @@
 Version:4.14.0
 Release:0
 %define rversion 4.14.0
+%define libversion 15.12.0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
@@ -130,6 +131,54 @@
 %description doc
 This package contains the documentation for digikam
 
+# split out Image modification plugins. Upstream ships them with a
+# .metainfo.xml file, which is meant to list them as extensions in a
+# Software center. The ones we want installed by default we tag as 
Supplements(%{name}.
+%package plugin-color
+Summary:DigiKam: ImagePlugin-Color
+License:GPL-2.0+
+Group:  Productivity/Graphics/Viewers
+Supplements:%{name}
+
+%description plugin-color
+A tool to correct colors of image
+
+%package plugin-decorate
+Summary:DigiKam: ImagePlugin-Decorate
+License:GPL-2.0+
+Group:  Productivity/Graphics/Viewers
+Supplements:%{name}
+
+%description plugin-decorate
+A tool to decorate an image
+
+%package plugin-enhance
+Summary:DigiKam: ImagePlugin-Enhance
+License:GPL-2.0+
+Group:  Productivity/Graphics/Viewers
+Supplements:%{name}
+
+%description plugin-enhance
+digiKam plugin to enhance photographs
+
+%package plugin-fxfilters
+Summary:DigiKam: ImagePlugin-FxFilters
+License:GPL-2.0+
+Group:  Productivity/Graphics/Viewers
+Supplements:%{name}
+
+%description plugin-fxfilters
+Special effect filters plugin for digiKam
+
+%package plugin-transform
+Summary:DigiKam: ImagePlugin-Color
+License:GPL-2.0+
+Group:  Productivity/Graphics/Viewers
+Supplements:%{name}
+
+%description plugin-transform
+A tool to transform image geometry
+
 # split out acquireimage plugin in order to allow the main
 # kipi-plugins package to be included on livecd (acquireimage
 # requires sane-backends, which is blocked for livecd)
@@ -185,6 +234,18 @@
 #Require the lib for the shared icons
 Requires:   libKF5Kipi30_0_0
 Requires:   marble-data
+Obsoletes:  libkexiv2 < %{libversion}
+Provides:   libkexiv2 = %{libversion}
+Obsoletes:  libkface3 < %{libversion}
+Provides:   libkface3 = %{libversion}
+Obsoletes:  libkgeomap2 < %{libversion}
+Provides:   libkgeomap2 = %{libversion}
+Obsoletes:  libkipi11 < %{libversion}
+Provides:   libkipi11 = %{libversion}
+Obsoletes:  libksane0 < %{libversion}
+Provides:   libksane0 = %{libversion}
+Obsoletes:  libmediawiki1 < %{libversion}
+Provides:   libmediawiki1 = %{libversion}
 
 %description libs
 These are the libraries libkipi, libkdcraw, libkgeomap, libkexiv2, libksane 
and libkface which are 
@@ -274,6 +335,14 @@
 ln -s %{_kde4_iconsdir}/oxygen/scalable/apps/rawconverter.svgz
 popd
 
+# symlink solid actions into place known to Plasma 5, remove once digikam is 
KF5-based
+mkdir -p %{buildroot}%{_datadir}/solid/actions
+pushd %{buildroot}%{_kde4_appsdir}/solid/actions/
+for i in *.desktop; do
+ln -s %{_kde4_appsdir}/solid/actions/$i %{buildroot}%{_datadir}/solid/actions/
+done
+popd
+
 %fdupes -s %{buildroot}
 
 %kde_post_install
@@ -295,6 +364,9 @@
 %{_kde4_appsdir}/kconf_update/adjustlevelstool.upd
 %{_kde4_appsdir}/showfoto/
 %{_kde4_appsdir}/solid
+%dir %{_datadir}/solid
+%dir %{_datadir}/solid/actions
+%{_datadir}/solid/actions/*.desktop
 %{_kde4_bindir}/cleanup_digikamdb
 %{_kde4_bindir}/digikam
 %{_kde4_bindir}/digitaglinktree
@@ -305,7 

commit digikam for openSUSE:Factory

2016-01-22 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2016-01-23 01:13:29

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-11-04 
15:32:31.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2016-01-23 
01:13:31.0 +0100
@@ -1,0 +2,14 @@
+Sun Jan 10 15:17:03 UTC 2016 - tittiatc...@gmail.com
+
+- Add the file digikam-libs.tar.bz2 based on the Digikam 4.13.0 
+  source file. These are the libs that have moved to KF5 upstream, 
+  but digikam is still KDE4 based.
+  This should enable to build digikam until the KF5 based version 
+  is released
+
+---
+Fri Jan  1 22:10:37 UTC 2016 - nico.kru...@gmail.com
+
+- re-enable support for MediaWiki export in kipi-plugins
+
+---

New:

  digikam-libs.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.i3TeyH/_old  2016-01-23 01:13:33.0 +0100
+++ /var/tmp/diff_new_pack.i3TeyH/_new  2016-01-23 01:13:33.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package digikam
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -25,6 +25,7 @@
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{rversion}.tar.bz2
+Source1:digikam-libs.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
 # PATCH-FIX-OPENSUSE remove-gplv2-only.patch idoen...@suse.de bnc#711963 -- 
Remove GPLv2 only files from the build system
@@ -38,13 +39,27 @@
 BuildRequires:  fdupes
 BuildRequires:  flex
 BuildRequires:  gdk-pixbuf-devel
+%if 0%{?suse_version} <= 1310 || 0%{?suse_version} == 1320
+BuildRequires:  libkdcraw-devel
+BuildRequires:  libkexiv2-devel
+BuildRequires:  libkface-devel
 BuildRequires:  libkgeomap-devel
+BuildRequires:  libksane-devel
+BuildRequires:  libmediawiki-devel
+BuildRequires:  pkgconfig(libkipi) >= 2.0.0
+# libkgeomap package provides older lib with same so name.
+Requires:   libkgeomap2
+%else
+BuildRequires:  libexiv2-devel
+BuildRequires:  libmarblewidget-devel
+BuildRequires:  libraw-devel
+BuildRequires:  sane-backends-devel
+%endif
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
 %if 0%{?suse_version} > 1310
 BuildRequires:  baloo-devel
 %endif
-BuildRequires:  libkface-devel
 %if 0%{?suse_version} > 1310
 BuildRequires:  gstreamer-plugins-qt-devel
 %else
@@ -58,16 +73,12 @@
 BuildRequires:  libgphoto2-devel
 BuildRequires:  libgpod-devel
 BuildRequires:  libjasper-devel
-BuildRequires:  libkdcraw-devel
 BuildRequires:  libkde4-devel
 BuildRequires:  libkdepimlibs4-devel
-BuildRequires:  libkexiv2-devel
-BuildRequires:  pkgconfig(libkipi) >= 2.0.0
 %if 0%{?suse_version} > 1230
 BuildRequires:  libkqoauth-devel
 %endif
 BuildRequires:  libMagick++-devel
-BuildRequires:  libksane-devel
 BuildRequires:  libkvkontakte-devel
 %if 0%{?suse_version} < 1320 && !0%{?is_opensuse}
 # from 13.2 upwards, and also Leap 42.1 (1315 && is_opensuse) we prefer lcms2
@@ -93,13 +104,14 @@
 Requires:   kipi-plugins >= %{version}
 Requires:   libqt4-sql-mysql
 Requires:   libqt4-sql-sqlite
-# libkgeomap package provides older lib with same so name.
-Requires:   libkgeomap2
 Recommends: %{name}-doc
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %requires_gelibkipi8
 %kde4_runtime_requires
+%if 0%{?suse_version} > 1320 || 0%{?suse_version} == 1315
+Requires:   digikam-libs
+%endif
 
 %description
 digiKam is a simple digital photo management application for KDE, which
@@ -156,17 +168,35 @@
 Recommends: kipi-plugins-lang = %{version}
 Supplements:packageand(kipi-plugins:marble)
 %kde4_runtime_requires
+%if 0%{?suse_version} > 1320 || 0%{?suse_version} == 1315
+Requires:   digikam-libs
+%endif
 
 %description -n kipi-plugins
 A set of plug-ins for the KDE KIPI interface, used by some KDE imaging
 applications.
 
+%if 0%{?suse_version} > 1320 || 0%{?suse_version} == 1315
+%package libs
+Summary:Libraries required to run digikam
+License:GPL-2.0+
+Group:  Productivity/Graphics/Viewers
+Requires:   

commit digikam for openSUSE:Factory

2015-11-04 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-11-04 15:32:28

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-10-12 
10:01:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-11-04 
15:32:31.0 +0100
@@ -1,0 +2,51 @@
+Wed Oct 28 17:23:00 UTC 2015 - nico.kru...@gmail.com
+
+- update to 4.14.0
+  digikam:
+- General: Add support of OpenCV 3.x.
+- General: Overlay icons are resized accordingly with thumbnails sizes.
+- General: New Overlay icon to quickly show an image in full-screen.
+- General: Exiv2 mininum version bumped to 0.25 to prevent crash with
+   video files.
+- kde#349601 - digikam compile fine with OpenCV 2.X but not with 3.x.
+- kde#261568 - ICONVIEW: scale overlay action icons accordingly with
+   thumb size.
+- kde#336331 - Thumbnails size can not be changed in MapView mode.
+- kde#339082 - Allow a simpler way to place a photo in full-screen using
+   overlay.
+- kde#352338 - Digikam doesn't match Nikon lenses 35mm f/1.8G and
+   50mm f/1.8G.
+- kde#126149 - Album icon view stores both jpeg and raw (nef), handle
+   both as one.
+- kde#352919 - Crash on delete into image editor.
+- kde#341819 - Auto-creation of date-based sub-albums ignored.
+- kde#353155 - Apply face tags to multiple images.
+- kde#237719 - Color effects: Neon / Find edges don't take parameters
+   correctly.
+- kde#340373 - Crash on scanning video directory.
+- kde#285052 - SCAN: moving an album from one collection to another one
+   do not update information.
+- kde#353600 - Wrong date (1970-01-01) on rename during raw import from
+   Nikon D750.
+- kde#353614 - Crash shortly after opening application.
+- kde#141592 - Position of inserted text is not exact.
+- kde#353608 - The preview has blocky artifacts reminiscent of chroma
+   subsampling.
+- kde#286373 - DNG don't get filtered as raw (group of items relevant).
+- kde#181813 - digiKam text decoration font size problem.
+- kde#353815 - Using Batch Queue Manager to extract preview images loses
+   metadata.
+  kipi-plugins:
+- General: Add support of OpenCV 3.x
+- kde#306442 - digiKam 2.8 crash when opening geolocation plugin.
+- kde#352596 - Unable to upload large image to flickr even though I'm
+   resizing it.
+- kde#352621 - Export to facebook crashes.
+- kde#352862 - Photos are compressed when exported to picasa.
+- kde#352750 - Facebook export: Filename is used as Description.
+- remove digikam-4.6.0.install-libs-dev.patch (libs not packaged anymore)
+- remove digikam-4.8.0-libkgeomap-translations.tar.bz2 (libs not packaged
+  anymore)
+- remove support for MediaWiki export (libmediawiki not packaged anymore)
+
+---

Old:

  digikam-4.13.0.tar.bz2
  digikam-4.6.0.install-libs-dev.patch
  digikam-4.8.0-libkgeomap-translations.tar.bz2

New:

  digikam-4.14.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.oOrR2Z/_old  2015-11-04 15:32:35.0 +0100
+++ /var/tmp/diff_new_pack.oOrR2Z/_new  2015-11-04 15:32:35.0 +0100
@@ -17,24 +17,20 @@
 
 
 Name:   digikam
-Version:4.13.0
+Version:4.14.0
 Release:0
-%define rversion 4.13.0
+%define rversion 4.14.0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{rversion}.tar.bz2
-# libkgeomap translations from the 4.8.0 tarball (Missing in 4.9.0)
-Source2:digikam-4.8.0-libkgeomap-translations.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
 # PATCH-FIX-OPENSUSE remove-gplv2-only.patch idoen...@suse.de bnc#711963 -- 
Remove GPLv2 only files from the build system
 Patch3: remove-gplv2-only.patch
 # PATCH-FIX-UPSTREAM digikam-4.4.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
 Patch6: digikam-4.4.0.no-kdcraw.version-check.patch
-# PATCH-FIX-OPENSUSE digikam-4.6.0.install-libs-dev.patch nkru...@gmail.com -- 
install cmake module files and pkgconfig files of internally-built 

commit digikam for openSUSE:Factory

2015-10-12 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-10-12 10:01:30

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-09-17 
09:16:53.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-10-12 
10:01:37.0 +0200
@@ -1,0 +2,11 @@
+Sun Oct 11 12:55:49 UTC 2015 - hrvoje.sen...@gmail.com
+
+- Don't buildrequire marble-devel when libkgeomap isn't built
+
+---
+Tue Oct  6 13:44:26 UTC 2015 - dims...@opensuse.org
+
+- Align build of Leap 42.1 with the one in Tumbleweed (do not build
+  libkface3 and libkgeomap2).
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.eUVDvT/_old  2015-10-12 10:01:40.0 +0200
+++ /var/tmp/diff_new_pack.eUVDvT/_new  2015-10-12 10:01:40.0 +0200
@@ -44,7 +44,8 @@
 BuildRequires:  gdk-pixbuf-devel
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
-%if 0%{?suse_version} > 1320
+%if 0%{?suse_version} >= 1320 || 0%{?is_opensuse}
+# We want libkgeomap on openSUSE 13.2+ and Leap, which is 1315 && is_opensuse
 BuildRequires:  libkgeomap-devel
 %endif
 %if 0%{?suse_version} > 1310
@@ -77,7 +78,8 @@
 BuildRequires:  libMagick++-devel
 BuildRequires:  libksane-devel
 BuildRequires:  libkvkontakte-devel
-%if 0%{?suse_version} < 1320
+%if 0%{?suse_version} < 1320 && !0%{?is_opensuse}
+# from 13.2 upwards, and also Leap 42.1 (1315 && is_opensuse) we prefer lcms2
 BuildRequires:  liblcms-devel
 %else
 BuildRequires:  liblcms2-devel
@@ -88,7 +90,9 @@
 BuildRequires:  libqjson-devel
 BuildRequires:  libusb-1_0-devel
 BuildRequires:  libusb-compat-devel
+%if 0%{?suse_version} <= 1320 && !0%{?is_opensuse}
 BuildRequires:  marble-devel
+%endif
 BuildRequires:  opencv-devel >= 2.4.5
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(glu)
@@ -166,7 +170,8 @@
 A set of plug-ins for the KDE KIPI interface, used by some KDE imaging
 applications.
 
-%if 0%{?suse_version} <= 1320
+%if 0%{?suse_version} <= 1320 && !0%{?is_opensuse}
+# This is only being built up to 13.2 & SLE12, but NOT for Leap 42.1
 %package -n libkgeomap-devel
 Summary:Development files for libkgeomap
 License:GPL-2.0+
@@ -198,7 +203,8 @@
 This library is used by kipi-plugins, digiKam and other kipi host programs.
 %endif
 
-%if 0%{?suse_version} < 1320
+%if 0%{?suse_version} < 1320 && !0%{?is_opensuse}
+# This is built up to openSUSE 13.1 plus also SLE12
 %package -n libkface-devel
 Summary:Development files for libkface
 License:BSD-3-Clause and GPL-2.0+ and LGPL-2.1+ and MIT
@@ -248,14 +254,14 @@
 
 %lang_package -n kipi-plugins
 
-%if 0%{?suse_version} <= 1320
+%if 0%{?suse_version} <= 1320 && !0%{?is_opensuse}
 %lang_package -n libkgeomap
 %endif
 
 %prep
 %setup -q -n %{name}-%{rversion}
-%if 0%{?suse_version} <= 1320
-# Don't unpack the libkgeomap translations for Tumbleweed as that they are 
being delivered through kde-l10n
+%if 0%{?suse_version} <= 1320 && !0%{?is_opensuse}
+# Don't unpack the libkgeomap translations for Tumbleweed/Leap 42.1 as that 
they are being delivered through kde-l10n
 tar -xjf %{SOURCE2}
 %endif
 %patch0
@@ -275,12 +281,12 @@
 popd
 
 %build
-%if 0%{?suse_version} < 1320
+%if 0%{?suse_version} < 1320 && !0%{?is_opensuse}
 EXTRA_FLAGS="-DENABLE_LCMS2=OFF -DDIGIKAMSC_COMPILE_LIBKFACE=TRUE"
 %else
 EXTRA_FLAGS="-DENABLE_LCMS2=ON"
 %endif
-%if 0%{?suse_version} <= 1320
+%if 0%{?suse_version} <= 1320 && !0%{?is_opensuse}
 %cmake_kde4 -d build -- -DENABLE_MYSQLSUPPORT=TRUE 
-DENABLE_INTERNALMYSQL=FALSE -DENABLE_KDEPIMLIBSSUPPORT=TRUE 
-DDIGIKAMSC_COMPILE_LIBKGEOMAP=TRUE -DDIGIKAMSC_COMPILE_LIBMEDIAWIKI=TRUE 
$EXTRA_FLAGS
 %else
 %cmake_kde4 -d build -- -DENABLE_MYSQLSUPPORT=TRUE 
-DENABLE_INTERNALMYSQL=FALSE -DENABLE_KDEPIMLIBSSUPPORT=TRUE 
-DDIGIKAMSC_COMPILE_LIBMEDIAWIKI=TRUE $EXTRA_FLAGS
@@ -311,7 +317,7 @@
 
 %find_lang %{name}
 
-%if 0%{?suse_version} <= 1320
+%if 0%{?suse_version} <= 1320 && !0%{?is_opensuse}
 %find_lang libkgeomap libkgeomap.lang
 %endif
 
@@ -351,13 +357,13 @@
 
 %postun -n kipi-plugins -p /sbin/ldconfig
 
-%if 0%{?suse_version} <= 1320
+%if 0%{?suse_version} <= 1320 && !0%{?is_opensuse}
 %post -n libkgeomap2 -p /sbin/ldconfig
 
 %postun -n libkgeomap2 -p /sbin/ldconfig
 %endif
 
-%if 0%{?suse_version} < 1320
+%if 0%{?suse_version} < 1320 && !0%{?is_opensuse}
 %post -n libkface3 -p /sbin/ldconfig
 
 %postun -n libkface3 -p /sbin/ldconfig
@@ -463,7 +469,7 @@
 

commit digikam for openSUSE:Factory

2015-09-17 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-09-17 09:16:49

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is "digikam"

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-08-10 
09:15:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-09-17 
09:16:53.0 +0200
@@ -1,0 +2,254 @@
+Wed Sep  9 09:48:14 UTC 2015 - nico.kru...@gmail.com
+
+- update to 4.13.0
+  digikam:
+- kde#350915 - digiKam 4.11.0 fails to compile with jpeg-9a.
+- kde#343548 - Tag Manager crashes when adding a new tag.
+- kde#350541 - PNG alpha channel is ignored.
+- kde#229788 - digiKam crashes fetching pictures SD-Card.
+- kde#298265 - Embedded preview changes from full to reduced size
+   regardless album view settings.
+- kde#351142 - Add metadata tags support for video files time-stamp.
+- kde#334244 - Face tag zones are hidden after adding a new face.
+- kde#351243 - Table view click to select broken.
+- kde#350225 - Auto rename on import does not work for RAW images.
+- kde#346646 - Renaming works when downloading selected but settings are
+   ignored when importing new ones only.
+- kde#351245 - Unable to connect to mysql database, due to missing
+   'create trigger' while user has ALL privileges on
+   digikam DBs.
+- kde#351404 - Wrong country name in country list.
+- kde#351244 - Target album should be source album by default.
+- kde#349901 - Delete shortcut key needed and should be Apple+delete.
+- kde#349878 - digiKam Crashes when running maintenance.
+- kde#350930 - UI freeze when importing to remote storage.
+- kde#313390 - RAW images cannot be decoded if selected from within the
+   image editor.
+- kde#329873 - Crash during face detection.
+- kde#351241 - Table view shows wrong thumbnails.
+- kde#303545 - digiKam crash when importing photos from a camera.
+- kde#344521 - digiKam crashes when trying to define one more face.
+- kde#304952 - digiKam thumbnails don't load, even after rebuild
+   thumbnails and application crashes.
+- kde#341685 - Tags disappear on some photos after a few days.
+- kde#346070 - Crash during "maintenance".
+- kde#347348 - Moving a directory loses metadata in database associated
+   with .cr2 raw files.
+- kde#269634 - Crash when adding tags.
+- kde#311135 - digiKam crashed after saving a new version of a modified
+   picture.
+- kde#309058 - Database can't be synchronized with XMP sidecars.
+- kde#351679 - digiKam does not find album library.
+- kde#350885 - Grouping images via the thumbbar is possible, but they
+   disappear in digikam.
+- kde#352040 - Names for faces do not take non-ASCII characters.
+  kipi-plugins:
+- kde#280058 - No coordinates shown in GPSSync window when using sidecar
+   files.
+- Remove fix-crash-with-tags-manager-add-tag-with-null-parent.patch
+  (fixed upstream - boo#940857, kde#343548)
+
+---
+Fri Aug  7 17:15:47 UTC 2015 - nico.kru...@gmail.com
+
+- update to 4.12.0
+  digikam:
+- kde#349302 - Copy path to clipboard.
+- kde#339008 - digiKam crashed when opening import window.
+- kde#349280 - Crash when importing photos via MTP.
+- kde#330943 - New lens not detected.
+- kde#285521 - Search by time of day.
+- kde#269682 - digiKam crashes when selecting lens auto correction
+   (ResizeEvent relevant).
+- kde#317689 - Crash on selecting perspective tool (ResizeEvent relevant).
+- kde#320382 - Unable to crop due to image corruption into canvas with not
+   X11 based computers (ResizeEvent relevant).
+- kde#340389 - digiKam crashes while editing pictures for color balancing
+   on OSX.
+- kde#294793 - Refocus filter crashes with 16bit images.
+- kde#337324 - digiKam crashes when opening the import view via Import
+   "Add Images...".
+- kde#341356 - Not getting the new Versions of digiKam.
+- kde#342625 - Can't install digikam because py27-numpy refuses to
+   install.
+- kde#326580 - digiKam 3.5 corrupts JPG, TiFF, PNG images.
+- kde#349155 - digiKam does not work properly on OSX Yosemite.
+- kde#347289 - digiKam crashes while beginning correcting perspective.
+- kde#343948 - Crashes as soon as i try to import from USB3 attached flash
+   drive with images on.
+- kde#337537 - Crash on Import.
+- kde#321899 - Crash 

commit digikam for openSUSE:Factory

2015-08-10 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-08-10 09:15:25

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-08-02 
22:44:17.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-08-10 
09:15:31.0 +0200
@@ -1,0 +2,7 @@
+Fri Aug  7 06:23:24 UTC 2015 - wba...@tmo.at
+
+- Add fix-crash-with-tags-manager-add-tag-with-null-parent.patch:
+  fix crash with tag manager when adding tags with no parent tag
+  selected (boo#940857, kde#343548)
+
+---

New:

  fix-crash-with-tags-manager-add-tag-with-null-parent.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.lcEAVS/_old  2015-08-10 09:15:33.0 +0200
+++ /var/tmp/diff_new_pack.lcEAVS/_new  2015-08-10 09:15:33.0 +0200
@@ -35,6 +35,8 @@
 Patch6: digikam-4.4.0.no-kdcraw.version-check.patch
 # PATCH-FIX-OPENSUSE digikam-4.6.0.install-libs-dev.patch nkru...@gmail.com -- 
install cmake module files and pkgconfig files of internally-built libraries, 
too
 Patch7: digikam-4.6.0.install-libs-dev.patch
+# PATCH-FIX-UPSTREAM 
fix-crash-with-tags-manager-add-tag-with-null-parent.patch wba...@tmo.at 
boo#940857, kde#343548 -- fix crash with tag manager when adding tags with no 
parent tag selected
+Patch8: fix-crash-with-tags-manager-add-tag-with-null-parent.patch
 BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -262,6 +264,7 @@
 %patch3
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ fix-crash-with-tags-manager-add-tag-with-null-parent.patch ++
From: Veaceslav Munteanu veaceslav.muntean...@gmail.com
Date: Thu, 06 Aug 2015 18:50:00 +
Subject: fix crash with tags manager add tag with null parent BUG: 343548
X-Git-Url: 
http://quickgit.kde.org/?p=digikam.gita=commitdiffh=6eace137db05f0b5648bc34e0f690cf642c121db
---
fix crash with tags manager add tag with null parent BUG: 343548
---


--- a/core/app/tags/tagsmanager/tagsmanager.cpp
+++ b/core/app/tags/tagsmanager/tagsmanager.cpp
@@ -258,11 +258,16 @@
 
 void TagsManager::slotAddAction()
 {
-TAlbum* const parent = d-tagMngrView-currentAlbum();
+TAlbum*   parent = d-tagMngrView-currentAlbum();
 QString   title, icon;
 QKeySequence  ks;
 
-if (!TagEditDlg::tagCreate(kapp-activeWindow(), parent, title, icon, ks))
+if(!parent)
+{
+parent = 
static_castTAlbum*(d-tagMngrView-albumForIndex(d-tagMngrView-model()-index(0,0)));
+}
+
+if (!TagEditDlg::tagCreate(kapp-activeWindow(), parent, title, icon, ks))
 {
 return;
 }




commit digikam for openSUSE:Factory

2015-08-02 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-08-02 22:44:13

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-05-11 
19:32:41.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-08-02 
22:44:17.0 +0200
@@ -1,0 +2,186 @@
+Fri Jul 24 13:03:02 UTC 2015 - wba...@tmo.at
+
+- explicitly enable (external) mysql support, this is disabled by
+  default since 4.6.0
+
+---
+Sat Jun 27 09:29:33 UTC 2015 - nico.kru...@gmail.com
+
+- update to 4.11.0
+  digikam:
+- kde#342791 - Quality sorter does not honor album selection, scans
+   all albums instead.
+- kde#277024 - After running a batch process to change metadata, the
+   files halved in size.
+- kde#320466 - SCAN : after to run BQM a lot of files are missing in
+   icon-view.
+- kde#338765 - BQM Watermark tool : output files have reduced size
+   compared to original.
+- kde#343652 - Open with with Run in Terminal does not open a
+   Terminal.
+- kde#162950 - View albums thumbnail in icon-view with a special
+   frame as Dolphin.
+- kde#344608 - digiKam freezes for a second or three after rating
+   a raw photo.
+- kde#323458 - Removing all face tags doesn't work.
+- kde#335515 - Crash on Enhance - Noise Reduction.
+- kde#294217 - Make add face persistent, and add box by single click
+   instead of drawing.
+- kde#298929 - MAINTENANCE : cannot assign tags anymore.
+- kde#262171 - When attaching a name to a face in Preview mode, the
+   widget does not behave correctly.
+- kde#333955 - BQM: offer option to optimize jpg pics.
+- kde#165344 - Empty albums should not be included when sorting
+   albums by date.
+- kde#329138 - Convert to BW hangs when moving editor window to
+   other screen.
+- kde#347628 - Can't remove legend field when updating metadata.
+- kde#290930 - Cannot resize gamut diagram vertically, only
+   horizontally.
+- kde#266264 - Sidebar does not automatically resize to avoid
+   horizontal scrollbar.
+- kde#347728 - Build crashes when compiling libkdcraw with libraw
+   0.16.1.-76.1-x86_64.
+- kde#341266 - No preview available with Gphoto2 camera.
+- kde#309638 - Searching on technical images properties.
+- kde#342557 - No rule to make target /opt/local/lib/libkgeomap.dylib
+   in recent git distribution.
+- kde#244097 - When importing .NEF files, if highlights are rebuild,
+   auto-brightness has no effect.
+- kde#339612 - When adding label it moves files.
+- kde#181736 - New tool for Image Editor to delighting photo.
+- kde#196075 - Creating a quick-fix dialogue would give digiKam a
+   real edge.
+- kde#346877 - Cannot assign arrow keys as keyboard shortcut.
+- kde#336126 - Batch renaming is broken : file just renamed cannot
+   be found.
+- kde#195701 - Do not default to include subfolders/no possibility
+   to not include sub-folders.
+- kde#262499 - Cannot rename .AVI files.
+- kde#331194 - SCAN : prevent trailing white spaces in camera
+   model/maker names.
+- kde#326589 - When detect face with one folder limit and option skip
+   already scanned image, .avi and .move in other folder
+   are scanned too.
+- kde#337878 - THUMBBAR : item focus must stay in the middle.
+- kde#344952 - Keep selected image in thumbbar in the middle while
+   being in preview mode.
+- kde#348146 - kipi configuration module?
+- kde#332316 - Lens Auto-Correction should remember previously used
+   settings.
+- kde#333630 - Cannot search items with exposure times  30s or
+   focal lengths  1000mm.
+- kde#257679 - Build a PKG package for digiKam under MacOSX.
+- kde#348105 - TAGS MANAGER : Delete all unused tags.
+- kde#309243 - Reread metadata does not remove tags from database.
+- kde#348463 - First time, digiKam seems using more than one cpu.
+- kde#348586 - digiKam does not write description to XMP sidecar
+   file anymore.
+- kde#318319 - Extended files type mime supported into search tool.
+- kde#319921 - SCAN : Audio files are ignored.
+- kde#253622 - digikam editor cannot use unsharp mask with radius
+

commit digikam for openSUSE:Factory

2015-05-11 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-05-11 19:32:08

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-04-13 
20:29:23.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-05-11 
19:32:41.0 +0200
@@ -1,0 +2,6 @@
+Tue Apr 28 14:46:24 UTC 2015 - tittiatc...@gmail.com
+
+- For Tumbleweed start using the libkgeomap that is provide with
+  KDE Applications.
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.YvS9pG/_old  2015-05-11 19:32:43.0 +0200
+++ /var/tmp/diff_new_pack.YvS9pG/_new  2015-05-11 19:32:43.0 +0200
@@ -46,6 +46,9 @@
 BuildRequires:  gdk-pixbuf-devel
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
+%if 0%{?suse_version}  1320
+BuildRequires:  libkgeomap-devel
+%endif
 %if 0%{?suse_version}  1310
 BuildRequires:  baloo-devel
 %endif
@@ -165,6 +168,7 @@
 A set of plug-ins for the KDE KIPI interface, used by some KDE imaging
 applications.
 
+%if 0%{?suse_version} = 1320
 %package -n libkgeomap-devel
 Summary:Development files for libkgeomap
 License:GPL-2.0+
@@ -194,6 +198,7 @@
 - OpenstreetMap (via Marble)
 - GoogleMap
 This library is used by kipi-plugins, digiKam and other kipi host programs.
+%endif
 
 %if 0%{?suse_version}  1320
 %package -n libkface-devel
@@ -245,11 +250,16 @@
 
 %lang_package -n kipi-plugins
 
+%if 0%{?suse_version} = 1320
 %lang_package -n libkgeomap
+%endif
 
 %prep
 %setup -q -n %{name}-%{rversion}
+%if 0%{?suse_version} = 1320
+# Don't unpack the libkgeomap translations for Tumbleweed as that they are 
being delivered through kde-l10n
 tar -xjf %{SOURCE2}
+%endif
 %patch0
 %patch3
 %patch5
@@ -273,7 +283,11 @@
 %else
 EXTRA_FLAGS=-DENABLE_LCMS2=ON
 %endif
+%if 0%{?suse_version} = 1320
 %cmake_kde4 -d build -- -DENABLE_INTERNALMYSQL=FALSE 
-DENABLE_KDEPIMLIBSSUPPORT=TRUE -DDIGIKAMSC_COMPILE_LIBKGEOMAP=TRUE 
-DDIGIKAMSC_COMPILE_LIBMEDIAWIKI=TRUE $EXTRA_FLAGS
+%else
+%cmake_kde4 -d build -- -DENABLE_INTERNALMYSQL=FALSE 
-DENABLE_KDEPIMLIBSSUPPORT=TRUE -DDIGIKAMSC_COMPILE_LIBMEDIAWIKI=TRUE 
$EXTRA_FLAGS
+%endif
 
 # there are files in there that are so heavy to the compiler, that one is 
enough
 %make_jobs VERBOSE=1
@@ -300,7 +314,9 @@
 
 %find_lang %{name}
 
+%if 0%{?suse_version} = 1320
 %find_lang libkgeomap libkgeomap.lang
+%endif
 
 %if 0%{?kde_updatedapps}
 %find_lang libkipi libkipi.lang
@@ -338,9 +354,11 @@
 
 %postun -n kipi-plugins -p /sbin/ldconfig
 
+%if 0%{?suse_version} = 1320
 %post -n libkgeomap2 -p /sbin/ldconfig
 
 %postun -n libkgeomap2 -p /sbin/ldconfig
+%endif
 
 %if 0%{?suse_version}  1320
 %post -n libkface3 -p /sbin/ldconfig
@@ -450,6 +468,7 @@
 %{_kde4_modulesdir}/kipiplugin_gpssync.so
 %{_kde4_servicesdir}/kipiplugin_gpssync.desktop
 
+%if 0%{?suse_version} = 1320
 %files -n libkgeomap-devel
 %defattr(-,root,root,-)
 %doc 
extra/libkgeomap/{AUTHORS,COPYING,COPYING-CMAKE-SCRIPTS,COPYING.LIB,README,TODO}
@@ -465,6 +484,7 @@
 %defattr(-,root,root,-)
 %{_kde4_appsdir}/libkgeomap/
 %{_kde4_libdir}/libkgeomap.so.2*
+%endif
 
 %if 0%{?suse_version}  1320
 %files -n libkface3




commit digikam for openSUSE:Factory

2015-04-13 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-04-13 20:29:20

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-03-12 
16:37:08.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-04-13 
20:29:23.0 +0200
@@ -1,0 +2,55 @@
+Wed Apr  8 23:23:47 UTC 2015 - nico.kru...@gmail.com
+
+- update to 4.9.0
+  digikam:
+- kde#344484 - digiKam 4.8.0 compilation error : undefined
+   reference to `cv::Exception::Exception.
+- kde#203733 - Syncing EXIF Artist and Copyright fields with IPTC/XMP.
+- kde#338753 - Exif ImageDescription field is being used incorrectly.
+- kde#330224 - Add collection from network share is silently ignored.
+- kde#344699 - Maintenance is using the wrong face data management.
+- kde#342931 - Wrong apect ratio in item properties and in item view.
+- kde#344793 - Thumbnail-preview broken for tags and timeline.
+- kde#345025 - Wrong sql statement updating thumbnail modification date.
+- kde#327009 - Tags auto-completion suggestions list is cut off at
+   the right side.
+- kde#345168 - Crash when applying auto lens correction (chromatic
+   aberration).
+- kde#319383 - Crash while applying lensfun distortion correction.
+- kde#333540 - Random crashes on OpenSUSE 13.1.
+- kde#345387 - Lens auto-correction tools shows partial mathc for
+   canon 700d 18-135 is stm.
+- kde#345367 - The sideview containing the thumbnails is not updated
+   after deleting a photo.
+- kde#345187 - When naming unkown faces digikam only remembers typed
+   characters and not the selected name for the next face.
+- kde#326208 - When doing a face learning (erase data and rebuild),
+   Database is not erased and grow.
+- kde#323888 - Face recognition makes digikam fill all the available
+   memory (Qt SQlite plugin relevant).
+- kde#338176 - Face Recognition memory allocation crash application.
+- kde#339933 - ICONVIEW : Incorrect Image Aspect Ratio shown.
+- kde#344997 - 100% CPU - Hang for VERY long periods.
+- kde#344420 - Incomplete update of sidecar after renaming face tag.
+- kde#342788 - THUMBBAR : Sort order not in sync with pictures in
+  editor.
+- kde#337502 - THUMBBAR : no thumbs generated.
+- kde#345659 - Cannot shrink thumbnails panel.
+- kde#338230 - digiKam stops refreshing download progress after
+   de-selecting pictures.
+- kde#345648 - Progress bar disappeared while importing pictures
+   before importing finished.
+- kde#340139 - digiKam hangs after selecting folder with pictures.
+- kde#341772 - Re-read metadata when image file timestamp has changed.
+- kde#329433 - Manual adding of faces made easier.
+  kipi-plugins:
+- kde#310977 - Applying data (exif, iptc, xmp caption) in Edit all
+   Metadata window inconsistent - results in data loss.
+- kde#340330 - Deselecting Show tracks on map crashes the dialog.
+- kde#283504 - QJSon not optional.
+- kde#345802 - Html export does not longer export the description tag
+   to gallery.xml.
+- add digikam-4.8.0-libkgeomap-translations.tar.bz2 with libkgeomap
+  translations from 4.8.0 (missing in 4.9.0 tarball)
+
+---

Old:

  digikam-4.8.0.tar.bz2

New:

  digikam-4.8.0-libkgeomap-translations.tar.bz2
  digikam-4.9.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.rWwwgt/_old  2015-04-13 20:29:25.0 +0200
+++ /var/tmp/diff_new_pack.rWwwgt/_new  2015-04-13 20:29:25.0 +0200
@@ -17,14 +17,16 @@
 
 
 Name:   digikam
-Version:4.8.0
+Version:4.9.0
 Release:0
-%define rversion 4.8.0
+%define rversion 4.9.0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
 Source0:
http://download.kde.org/stable/%{name}/%{name}-%{rversion}.tar.bz2
+# libkgeomap translations from the 4.8.0 tarball (Missing in 4.9.0)
+Source2:digikam-4.8.0-libkgeomap-translations.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
 # PATCH-FIX-OPENSUSE remove-gplv2-only.patch idoen...@suse.de 

commit digikam for openSUSE:Factory

2015-03-12 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-03-12 16:37:04

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-01-25 
21:16:04.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-03-12 
16:37:08.0 +0100
@@ -1,0 +2,72 @@
+Mon Mar  9 23:30:06 UTC 2015 - nico.kru...@gmail.com
+
+- update to 4.8.0
+  digikam:
+- kde#343031 - Digikam won't start: *** Error in `digikam':
+   realloc(): invalid pointer: 0x00c14260 ***
+- kde#343548 - Tag Manager crashes when adding a new tag.
+- kde#337011 - Image Quality Sorter doesn't apply labels.
+- kde#318726 - Some BQM tools in a workflow don't restore (all)
+   parameters properly.
+- kde#342189 - BQM won't let me remove a tool unless I change it.
+- kde#332314 - Lens Auto-Correction seems to prefer makernotes over
+   Exif making fixing manual lenses impossible.
+- kde#343755 - Tags from Windows Photo Gallery sometimes ignored.
+- kde#341241 - digiKam crash during marking photos in Persons/Tags view
+- kde#344154 - digiKam sometimes shows the raw preview, sometimes the
+   JPEG preview, depending on the position of the stars.
+- kde#344156 - Use digiKam with your keyboard, delete the wrong photos.
+- kde#344155 - Rotating raw image sometimes results in the preview
+   showing the photo rotated in the opposite direction.
+  kipi-plugins:
+- kde#342194 - Geolocalisation not possible using google maps:
+   Malformated Url
+- kde#343777 - FindQtSoap.cmake doesn't find latest qtsoap built from
+   git code.
+- kde#308021 - digiKam crashes when making panorama / boost.
+
+---
+Wed Feb 18 19:55:54 UTC 2015 - nico.kru...@gmail.com
+
+- update to 4.7.0
+  digikam:
+- kde#341054 - No way to filter only files of a specific extension.
+- kde#342073 - The creation of the selection has a dysfunction after a
+   very fast mouse double click.
+- kde#342229 - Crash attempting to rotate empty (NULL) thumbnail.
+- kde#342293 - Each mouse right click creates a new Open With entry in the
+   context menu.
+- kde#342346 - Show only vendor specific meta data which is relevant.
+- kde#336127 - Rename pattern textbox not tall enough and uses hard-coded
+   font colors.
+- kde#342149 - Freezes when mousing over create tag from address book
+   in the right click tag menu.
+- kde#340384 - Segmentation fault when creating new album.
+- kde#338785 - digiKam face detection finds no faces.
+- kde#342602 - Restore toggle fit to window and last zoom in the image
+   editor.
+- kde#342708 - A little less image shift in the mouse over preview mode.
+- kde#342448 - Compile issues in origin/master Jan/2015.
+- kde#342931 - Wrong apect ratio in item properties and in item view.
+- kde#341821 - Cancel button in Import window does nothing.
+- kde#342273 - CANVAS : When using zoom +/- from the staus-bar are image
+artifacts is visible.
+- kde#343013 - CANVAS : on working with raw images marked square isn't
+crop accurate.
+- kde#343080 - Cannot find the right lensfun profile for RAW lens
+   correction.
+- kde#343221 - Softproofing in editor does not work anymore.
+- kde#342996 - Corrections for rename settings in images import.
+- kde#314441 - Rename settings while importing ignored.
+- kde#328541 - Cursor sometimes stays busy.
+- kde#342430 - When selecting a subset of images instead of all images to
+   download from camera, the numbering of the renamed images
+   adds the number of selected images to the sequence numbers.
+  kipi-plugins:
+- kde#342046 - In the export menu, Google Drive and Dropbox icons are huge,
+   filling almost all the screen.
+- kde#342857 - Changed files are not reported to host application.
+- kde#310580 - DNG Converter cannot save image if path have non-ascii
+   characters.
+
+---

Old:

  digikam-4.6.0.tar.bz2

New:

  digikam-4.8.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.bCMeZ7/_old  2015-03-12 16:37:09.0 +0100
+++ 

commit digikam for openSUSE:Factory

2015-01-25 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-01-25 21:16:03

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-01-22 
00:50:55.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-01-25 
21:16:04.0 +0100
@@ -1,0 +2,6 @@
+Sat Jan 24 15:44:27 UTC 2015 - adr...@suse.de
+
+- old libkgeomap package provides older lib with same so name, adding
+  an explizit requires
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.I9YYgT/_old  2015-01-25 21:16:06.0 +0100
+++ /var/tmp/diff_new_pack.I9YYgT/_new  2015-01-25 21:16:06.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package digikam
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -95,6 +95,8 @@
 Requires:   kipi-plugins = %{version}
 Requires:   libqt4-sql-mysql
 Requires:   libqt4-sql-sqlite
+# libkgeomap package provides older lib with same so name.
+Requires:   libkgeomap2
 Recommends: %{name}-doc
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2015-01-21 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-01-21 22:13:12

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2015-01-05 
04:43:06.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-01-22 
00:50:55.0 +0100
@@ -1,0 +2,6 @@
+Thu Jan 15 14:09:02 UTC 2015 - tittiatc...@gmail.com
+
+- libkface is now a separate package. Do not use the bundled 
+  version on opensUSE 13.2 and higher. 
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.WlUUzH/_old  2015-01-22 00:50:57.0 +0100
+++ /var/tmp/diff_new_pack.WlUUzH/_new  2015-01-22 00:50:57.0 +0100
@@ -48,6 +48,9 @@
 BuildRequires:  baloo-devel
 %endif
 %if 0%{?suse_version}  1310
+BuildRequires:  libkface-devel
+%endif
+%if 0%{?suse_version}  1310
 BuildRequires:  gstreamer-plugins-qt-devel
 %else
 BuildRequires:  gstreamer-0_10-plugins-qt-devel
@@ -188,6 +191,7 @@
 - GoogleMap
 This library is used by kipi-plugins, digiKam and other kipi host programs.
 
+%if 0%{?suse_version}  1320
 %package -n libkface-devel
 Summary:Development files for libkface
 License:BSD-3-Clause and GPL-2.0+ and LGPL-2.1+ and MIT
@@ -207,6 +211,7 @@
 %description -n libkface3
 Libkface is a Qt/C++ wrapper around LibFace to perform face recognition and
 detection over pictures.
+%endif
 
 %package -n libmediawiki1
 Summary:Interface for MediaWiki based web services
@@ -259,11 +264,12 @@
 
 %build
 %if 0%{?suse_version}  1320
-EXTRA_FLAGS=-DENABLE_LCMS2=OFF
+EXTRA_FLAGS=-DENABLE_LCMS2=OFF -DDIGIKAMSC_COMPILE_LIBKFACE=TRUE
 %else
 EXTRA_FLAGS=-DENABLE_LCMS2=ON
 %endif
-%cmake_kde4 -d build -- -DENABLE_INTERNALMYSQL=FALSE 
-DENABLE_KDEPIMLIBSSUPPORT=TRUE -DDIGIKAMSC_COMPILE_LIBKFACE=TRUE 
-DDIGIKAMSC_COMPILE_LIBKGEOMAP=TRUE -DDIGIKAMSC_COMPILE_LIBMEDIAWIKI=TRUE 
$EXTRA_FLAGS
+%cmake_kde4 -d build -- -DENABLE_INTERNALMYSQL=FALSE 
-DENABLE_KDEPIMLIBSSUPPORT=TRUE -DDIGIKAMSC_COMPILE_LIBKGEOMAP=TRUE 
-DDIGIKAMSC_COMPILE_LIBMEDIAWIKI=TRUE $EXTRA_FLAGS
+
 # there are files in there that are so heavy to the compiler, that one is 
enough
 %make_jobs VERBOSE=1
 
@@ -331,9 +337,11 @@
 
 %postun -n libkgeomap2 -p /sbin/ldconfig
 
+%if 0%{?suse_version}  1320
 %post -n libkface3 -p /sbin/ldconfig
 
 %postun -n libkface3 -p /sbin/ldconfig
+%endif
 
 %post -n libmediawiki1 -p /sbin/ldconfig
 
@@ -453,6 +461,7 @@
 %{_kde4_appsdir}/libkgeomap/
 %{_kde4_libdir}/libkgeomap.so.2*
 
+%if 0%{?suse_version}  1320
 %files -n libkface3
 %defattr(-,root,root,-)
 %{_kde4_appsdir}/libkface
@@ -466,6 +475,7 @@
 %{_kde4_libdir}/pkgconfig/libkface.pc
 %dir %{_kde4_libdir}/cmake/Kface-3.5.0/
 %{_kde4_libdir}/cmake/Kface-3.5.0/*.cmake
+%endif
 
 %files -n libmediawiki1
 %defattr(-,root,root,-)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2015-01-04 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2015-01-05 04:43:00

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2014-11-28 
08:47:16.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2015-01-05 
04:43:06.0 +0100
@@ -1,0 +2,65 @@
+Sat Jan  3 17:58:02 UTC 2015 - nico.kru...@gmail.com
+
+- update to 4.6.0
+  digikam:
+- Editor : Several fixes to complete image editor canvas port to Qt4 
model/view.
+- General: Better support of removable media and unvavailable items.
+- Import : Allow sub-subfolders auto creation while importing.
+- BQM: Allow to save/load Workflow from tools context menu.
+- kde#340811 - Wrap album caption.
+- kde#340278 - Please provide a windows build of 4.4.
+- kde#341031 - LibLqr detected during build but shown as not supported in
+   components information.
+- kde#340945 - libkgeomap, libmediawiki, libkvkontakte, libkface not found.
+- kde#338532 - Sidecar files are neither created nor updated under Windows.
+- kde#335661 - CANVAS : image is displayed with wrong magnification after
+crop.
+- kde#338996 - CANVAS : Selection coordinates/size do not show either
+during selection or update when using selection
+area adjust controls.
+- kde#339053 - Allow the usage of arrows to move in the photo sequence
+   when in preview.
+- kde#205776 - Option to load full image size in preview mode does not
+   only do what it says with RAW files.
+- kde#341306 - CANVAS: no Select All for the second time and selection
+   fixes after crop and auto crop.
+- kde#341298 - libkexiv2-4.14.3/libkexiv2/kexiv2exif.cpp:934: bad if test?
+- kde#341470 - Better speed after downloading many pictures with
+   auto-rotation/flip option.
+- kde#286611 - Tags are losts randomly when converting TIFF to PNG.
+- kde#320564 - CANVAS : full image dimensions not shown when not viewing
+at 100% zoom level.
+- kde#341053 - Text Filter broken.
+- kde#341566 - digiKam crashed after closing when BQM was used before.
+- kde#294602 - Sub sub-folders separated with '/' in file path cannot be
+   created with album selection dialog.
+- kde#339108 - Segfault trying to download photos.
+- kde#338367 - CANVAS : unable to zoom out to less than fit to window.
+- kde#341671 - IMPORT: Zoom Out and Zoom In button in preview mode working
+   not.
+- kde#338224 - Inconsistent Zoom to 100% shortcut behavior between
+   Preview Mode and Image Editor.
+- kde#263550 - CANVAS : image shifts position in mouse-over mode when
+changing between Before and After.
+- kde#333929 - Target ICC profile is common to all queues from BQM.
+- kde#323112 - Preview fails when importing images because digiKam uses a
+   wrong path with Gphoto2 camera
+- kde#331224 - Sync metadata eventually slow-down computer to unusable
+   state.
+- kde#338276 - CANVAS : mouse-over preview mode does not work.
+- kde#341825 - Rounding down zoom for fit to windows size and it will
+   never scroll bars be displayed.
+- kde#326796 - When returning from edit mode to preview mode, next image
+   not always loaded.
+- kde#341868 - View-Fit to Selection no centering the new selection.
+- kde#191494 - Support search in offline collections (e.g. removable
+   medias).
+  kipi-plugins:
+- kde#302306 HTML export crashes digiKam with floating cards theme.
+- kde#341379 Advanced slideshow crashes if it runs manually backwards.
+- drop digikam-4.5.0-reenable-libs.patch (use digikam 4.6.0 cmake options)
+- drop digikam_no_build_vkontakte.diff (replaced by patch below)
+- add digikam_no_local_vkontakte_cmake_modules.diff
+- add digikam-4.6.0.install-libs-dev.patch
+
+---

Old:

  digikam-4.5.0-reenable-libs.patch
  digikam-4.5.0.tar.bz2
  digikam_no_build_vkontakte.diff

New:

  digikam-4.6.0.install-libs-dev.patch
  digikam-4.6.0.tar.bz2
  digikam_no_local_vkontakte_cmake_modules.diff



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.KbURow/_old  2015-01-05 04:43:08.0 +0100
+++ 

commit digikam for openSUSE:Factory

2014-11-27 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2014-11-28 08:47:10

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2014-11-14 
09:18:37.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2014-11-28 
08:47:16.0 +0100
@@ -1,0 +2,44 @@
+Wed Nov 26 10:44:01 UTC 2014 - nico.kru...@gmail.com
+
+- add obsoletes for libkface2 and libkgeomap1
+
+---
+Sat Nov 22 01:41:03 UTC 2014 - nico.kru...@gmail.com
+
+- add digikam-4.5.0-reenable-libs.patch to use some internal
+  libraries not yet available as extra packages
+  (libkface, libkgeomap, libmediawiki)
+
+---
+Wed Nov 19 19:38:13 UTC 2014 - adr...@suse.de
+
+- update to 4.5.0
+  kde#172295 digiKam has a hard dependency on Jasper library
+  kde#267789 Make face detection (kface) and geo tagging (kmap) optional 
features
+  kde#306767 ICONVIEW : thumb focus is lost after renaming
+  kde#315574 CORE : bad performance when Tag-related Sidebars (Tag management 
/ Filter) are open
+  kde#326718 Clear text button on file rename does nothing
+  kde#326945 When build digikam from git and package libpgf is installed, no 
way to use internal digikam libpgf
+  kde#337422 EXIF thumbnail date information not updated when writing metadata 
to image
+  kde#337737 MYSQL : settings and installation windows freeze when valid 
mariadb/mysql db connection is available
+  kde#338407 Import not showing image thumbnails for certain Canon cameras
+  kde#339154 digiKam goes into infinite loop when working with tags/captions 
information tab templates
+  kde#339180 cmake and/or compiler pick up libkgeomap header files from 
previous version
+  kde#339524 Identity class miss d private container to improve binary 
compatibility
+  kde#339806 Compiler error: ambiguous reference to ratio variable
+  kde#339903 Select 'recent' albums containing MOV or .xcf(Gimp) files. 
Immediate crash occurs.
+  kde#340030 KIPI-plugins can not be deactivated on non-English locales
+  kde#340141 White Balance: Unable to specify exposure compensation  x.5
+  kde#340186 GROUP : Wallet icon for grouped photos is conceptually confusing
+  kde#340295 make fails on imagedescedittab.cpp has no member named 'textEdit'
+  kde#340439 No auto-rotation/flip Images after download
+  kde#340443 Advanced slideshow shows not all pictures under certain conditions
+  kde#340487 Add Album Category as a search criteria
+  kde#340581 Ratings with rating == 0 cannot be selected on the left sidebar
+  kde#340476 Floating Cards brings digiKam with non-English locales to crash 
and missing parameter text
+  kde#340811 Wrap album caption
+- remove upstream patches:
+  - kde#89156.patch
+  - digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch
+
+---

Old:

  digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch
  digikam-4.4.0.tar.bz2
  kde#89156.patch

New:

  digikam-4.5.0-reenable-libs.patch
  digikam-4.5.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.LgqWGW/_old  2014-11-28 08:47:18.0 +0100
+++ /var/tmp/diff_new_pack.LgqWGW/_new  2014-11-28 08:47:18.0 +0100
@@ -17,9 +17,9 @@
 
 
 Name:   digikam
-Version:4.4.0
+Version:4.5.0
 Release:0
-%define rversion 4.4.0
+%define rversion 4.5.0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
@@ -33,10 +33,8 @@
 Patch5: digikam_no_build_vkontakte.diff
 # PATCH-FIX-UPSTREAM digikam-4.4.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
 Patch6: digikam-4.4.0.no-kdcraw.version-check.patch
-# PATCH-FIX-UPSTREAM 
digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch -- fix 
libkexiv2 version for AltLangStrEdit::textEdit()
-Patch7: 
digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch
-# PATCH-FIX-UPSTREAM kde#89156.patch -- avoid deadlocks with external 
MySQL/MariaDB, kde#89156
-Patch8: kde#89156.patch
+# PATCH-FIX-OPENSUSE digikam-4.5.0-reenable-libs.patch nkru...@gmail.com -- 
use some of the internal libraries (libkface, libkgeomap, libmediawiki)
+Patch7: digikam-4.5.0-reenable-libs.patch
 BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -164,12 +162,12 @@
 Summary:Development files for libkgeomap

commit digikam for openSUSE:Factory

2014-11-14 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2014-11-14 09:18:31

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2014-10-19 
19:27:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2014-11-14 
09:18:37.0 +0100
@@ -1,0 +2,6 @@
+Mon Nov  3 13:47:10 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Added kde#89156.patch: avoid deadlocks with external MySQL/MariaDB,
+  kde#89156
+
+---

New:

  kde#89156.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.2NvzvM/_old  2014-11-14 09:18:38.0 +0100
+++ /var/tmp/diff_new_pack.2NvzvM/_new  2014-11-14 09:18:38.0 +0100
@@ -35,6 +35,8 @@
 Patch6: digikam-4.4.0.no-kdcraw.version-check.patch
 # PATCH-FIX-UPSTREAM 
digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch -- fix 
libkexiv2 version for AltLangStrEdit::textEdit()
 Patch7: 
digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch
+# PATCH-FIX-UPSTREAM kde#89156.patch -- avoid deadlocks with external 
MySQL/MariaDB, kde#89156
+Patch8: kde#89156.patch
 BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -241,6 +243,7 @@
 %patch5
 %patch6 -p1
 %patch7 -d core -p1
+%patch8 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ kde#89156.patch ++
From: Gilles Caulier caulier.gil...@gmail.com
Date: Tue, 28 Oct 2014 14:58:55 +
Subject: apply patch #89156
X-Git-Url: 
http://quickgit.kde.org/?p=digikam.gita=commitdiffh=f0400ec7e518e753e0c4ccab4eb2b8b022f91767
---
apply patch #89156
BUGS: 337737
FIXED-IN: 4.5.0
---


--- a/core/libs/widgets/common/databasewidget.cpp
+++ b/core/libs/widgets/common/databasewidget.cpp
@@ -172,30 +172,21 @@
   pbMySQL/b backend is a more robust 
solution especially for remote and shared database storage. 
   It is also more efficient to manage huge 
collection sizes. 
   Be careful: this one it is still in 
experimental stage./p));
+
 setDatabaseInputFields(DatabaseParameters::SQLiteDatabaseType());
 
 // 
-
-adjustSize();
-
-// 
-
-connect(databasePathEdit, SIGNAL(urlSelected(KUrl)),
-this, SLOT(slotChangeDatabasePath(KUrl)));
-
-connect(databasePathEdit, SIGNAL(textChanged(QString)),
-this, SLOT(slotDatabasePathEditedDelayed()));
 
 connect(databaseType, SIGNAL(currentIndexChanged(int)),
 this, SLOT(slotHandleDBTypeIndexChanged(int)));
 
+connect(checkDatabaseConnectionButton, SIGNAL(clicked()),
+this, SLOT(checkDatabaseConnection()));
+
 #ifdef HAVE_INTERNALMYSQL
 connect(internalServer, SIGNAL(stateChanged(int)),
 this, SLOT(slotHandleInternalServerCheckbox(int)));
 #endif // HAVE_INTERNALMYSQL
-
-connect(checkDatabaseConnectionButton, SIGNAL(clicked()),
-this, SLOT(checkDatabaseConnection()));
 }
 
 QString DatabaseWidget::currentDatabaseType() const
@@ -261,12 +252,24 @@
 d-databasePathLabel-setVisible(true);
 databasePathEdit-setVisible(true);
 d-expertSettings-setVisible(false);
+
+connect(databasePathEdit, SIGNAL(urlSelected(KUrl)),
+this, SLOT(slotChangeDatabasePath(KUrl)));
+
+connect(databasePathEdit, SIGNAL(textChanged(QString)),
+this, SLOT(slotDatabasePathEditedDelayed()));
 }
 else
 {
 d-databasePathLabel-setVisible(false);
 databasePathEdit-setVisible(false);
 d-expertSettings-setVisible(true);
+
+disconnect(databasePathEdit, SIGNAL(urlSelected(KUrl)),
+   this, SLOT(slotChangeDatabasePath(KUrl)));
+
+disconnect(databasePathEdit, SIGNAL(textChanged(QString)),
+   this, SLOT(slotDatabasePathEditedDelayed()));
 }
 
 adjustSize();
@@ -355,9 +358,9 @@
 
 password-setText(settings-getDatabasePassword());
 
-/* Now set the type according the database type from the settings.
- * If no item is found, ignore the setting.
- */
+// Now set the type according the database type from the settings.
+// If no item is found, ignore the setting.
+
 for (int i=0; idatabaseType-count(); ++i)
 

commit digikam for openSUSE:Factory

2014-10-19 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2014-10-19 19:27:42

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2014-10-17 
08:50:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2014-10-19 
19:27:46.0 +0200
@@ -1,0 +2,6 @@
+Thu Oct 16 16:24:52 UTC 2014 - nico.kru...@gmail.com
+
+- add digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch
+  (fixes builds with KDE 4.14.x)
+
+---

New:

  digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.WftGZb/_old  2014-10-19 19:27:48.0 +0200
+++ /var/tmp/diff_new_pack.WftGZb/_new  2014-10-19 19:27:48.0 +0200
@@ -33,6 +33,8 @@
 Patch5: digikam_no_build_vkontakte.diff
 # PATCH-FIX-UPSTREAM digikam-4.4.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
 Patch6: digikam-4.4.0.no-kdcraw.version-check.patch
+# PATCH-FIX-UPSTREAM 
digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch -- fix 
libkexiv2 version for AltLangStrEdit::textEdit()
+Patch7: 
digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch
 BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -238,6 +240,7 @@
 %patch3
 %patch5
 %patch6 -p1
+%patch7 -d core -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ digikam-4.4.0-fix-libkexiv2-version-for-AltLangStrEdit-textEdit.patch 
++
From f6945f23e0ed1e11f26e2c7e62b02baa8cfa640e Mon Sep 17 00:00:00 2001
From: Pino Toscano p...@kde.org
Date: Tue, 14 Oct 2014 22:26:19 +0200
Subject: [PATCH] fix libkexiv2 version for AltLangStrEdit::textEdit()

it is part of current libkexiv2/master only (i.e. post 4.14.x, which
is 2.3.x)
---
 libs/imageproperties/captionedit.cpp  | 2 +-
 libs/imageproperties/imagedescedittab.cpp | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/libs/imageproperties/captionedit.cpp 
b/libs/imageproperties/captionedit.cpp
index 88413fc..70bdb6d 100644
--- a/libs/imageproperties/captionedit.cpp
+++ b/libs/imageproperties/captionedit.cpp
@@ -202,7 +202,7 @@ void CaptionEdit::slotAuthorChanged(const QString text)
 
 MsgTextEdit* CaptionEdit::textEdit() const
 {
-#if KEXIV2_VERSION = 0x020302
+#if KEXIV2_VERSION = 0x020400
 return d-altLangStrEdit-textEdit();
 #else
 return 0;
diff --git a/libs/imageproperties/imagedescedittab.cpp 
b/libs/imageproperties/imagedescedittab.cpp
index ebfbae1..3d12777 100644
--- a/libs/imageproperties/imagedescedittab.cpp
+++ b/libs/imageproperties/imagedescedittab.cpp
@@ -429,7 +429,7 @@ ImageDescEditTab::ImageDescEditTab(QWidget* const parent)
 
 // Initialize -
 
-#if KEXIV2_VERSION = 0x020302
+#if KEXIV2_VERSION = 0x020400
 d-titleEdit-textEdit()-installEventFilter(this);
 d-captionsEdit-textEdit()-installEventFilter(this);
 #endif
@@ -532,7 +532,7 @@ void ImageDescEditTab::setFocusToNewTagEdit()
 void ImageDescEditTab::setFocusToTitlesEdit()
 {
 d-tabWidget-setCurrentIndex(Private::DESCRIPTIONS);
-#if KEXIV2_VERSION = 0x020302
+#if KEXIV2_VERSION = 0x020400
 d-titleEdit-textEdit()-setFocus();
 #endif
 }
@@ -540,7 +540,7 @@ void ImageDescEditTab::setFocusToTitlesEdit()
 void ImageDescEditTab::setFocusToCommentsEdit()
 {
 d-tabWidget-setCurrentIndex(Private::DESCRIPTIONS);
-#if KEXIV2_VERSION = 0x020302
+#if KEXIV2_VERSION = 0x020400
 d-captionsEdit-textEdit()-setFocus();
 #endif
 }
-- 
1.8.4.5

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2014-10-17 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2014-10-17 08:50:29

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2014-10-01 
11:22:06.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2014-10-17 
08:50:50.0 +0200
@@ -1,0 +2,38 @@
+Sun Oct 12 12:53:18 UTC 2014 - nico.kru...@gmail.com
+
+- Update to 4.4.0
+  digikam:
+- General   : Navigate between pictures using PageUp/PageDown is now
+  possible while editing properties through captions/tags
+  sidebar.
+- General   : New keyboard shortcuts to improve usability while photo
+  review (as to switch focus on text edit widget, or to
+  toogle tags view).
+- General   : New keyboard shortcut to switch on/off color managed
+  view for thumbnails and preview.
+- AlbumGUI  : Album preview can be displayed in tooltip.
+- SlideShow : Labels and Tags keyboard shortcuts can be used while
+  slideshow.
+- SlideShow : Support multi-monitors computer.
+- 50 fixed bugs
+  (kde#147175, kde#282900, kde#303179, kde#229930, kde#322053, kde#137320,
+   kde#110658, kde#224806, kde#309557, kde#201698, kde#211622, kde#131632,
+   kde#291695, kde#290928, kde#320304, kde#325580, kde#338485, kde#275381,
+   kde#144168, kde#268284, kde#152948, kde#313947, kde#282506, kde#309558,
+   kde#338509, kde#275077, kde#229680, kde#206546, kde#339074, kde#324287,
+   kde#313857, kde#312043, kde#242119, kde#339051, kde#163941, kde#339140,
+   kde#339144, kde#339210, kde#339341, kde#338629, kde#336333, kde#339173,
+   kde#339052, kde#171199, kde#257313, kde#338783, kde#337507, kde#339440,
+   kde#313855, kde#339227)
+  kipi-plugins:
+- PiwigoExport : Allow to upload videos (OGG, MP4 and WEBM) if the Piwigo
+ server accept them.
+- PiwigoExport : Remove the support of old Piwigo API (version  2.4).
+- 1 fixed bug (kde#337943)
+- swap digikam-3.0.0.no-kdcraw.version-check.patch for
+  digikam-4.4.0.no-kdcraw.version-check.patch
+- remove bug325580.patch (fixed upstream)
+- remove handle_right_libkexiv2_version.diff and
+  handle_right_libkexiv2_version2.diff (fixed upstream)
+
+---

Old:

  bug325580.patch
  digikam-3.0.0.no-kdcraw.version-check.patch
  digikam-4.3.0.tar.bz2
  handle_right_libkexiv2_version.diff
  handle_right_libkexiv2_version2.diff

New:

  digikam-4.4.0.no-kdcraw.version-check.patch
  digikam-4.4.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.Sz8b7U/_old  2014-10-17 08:50:53.0 +0200
+++ /var/tmp/diff_new_pack.Sz8b7U/_new  2014-10-17 08:50:53.0 +0200
@@ -17,9 +17,9 @@
 
 
 Name:   digikam
-Version:4.3.0
+Version:4.4.0
 Release:0
-%define rversion 4.3.0
+%define rversion 4.4.0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
@@ -31,14 +31,8 @@
 Patch3: remove-gplv2-only.patch
 # PATCH-FIX-OPENSUSE digikam_no_build_vkontakte.diff tittiatc...@gmail.com -- 
Don't build libvkontakte (use external one)
 Patch5: digikam_no_build_vkontakte.diff
-# PATCH-FIX-UPSTREAM digikam-3.0.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
-Patch6: digikam-3.0.0.no-kdcraw.version-check.patch
-# PATCH-FIX-UPSTREAM bug325580.patch -- Fix job reset when it's done : do not 
return directly is an error appera with a job, without to reset job.
-Patch7: bug325580.patch
-# PATCH-FIX-UPSTREAM handle_right_libkexiv2_version.diff
-Patch8: handle_right_libkexiv2_version.diff
-# PATCH-FIX-UPSTREAM handle_right_libkexiv2_version2.diff
-Patch9: handle_right_libkexiv2_version2.diff
+# PATCH-FIX-UPSTREAM digikam-4.4.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
+Patch6: digikam-4.4.0.no-kdcraw.version-check.patch
 BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -244,13 +238,10 @@
 %patch3
 %patch5
 %patch6 -p1
-%patch7 -p1
-%patch8 -p1
-%patch9 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
-sed -i s/__DATE__/\$FAKE_BUILDDATE\/ core/digikam/utils/version.h.cmake.in
+sed -i s/__DATE__/\$FAKE_BUILDDATE\/ core/app/utils/version.h.cmake.in
 sed -i 

commit digikam for openSUSE:Factory

2014-10-01 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2014-10-01 11:22:05

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2014-09-19 
13:55:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2014-10-01 
11:22:06.0 +0200
@@ -1,0 +2,13 @@
+Wed Sep 24 17:47:04 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Added handle_right_libkexiv2_version.diff and
+  handle_right_libkexiv2_version2.diff, kde#339144, bnc#898260
+
+---
+Tue Sep 23 15:55:06 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Add bug325580.patch: Fix job reset when it's done : do not return
+  directly is an error appera with a job, without to reset job.
+  kde#325580, kde#339210
+
+---

New:

  bug325580.patch
  handle_right_libkexiv2_version.diff
  handle_right_libkexiv2_version2.diff



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.7WWdxv/_old  2014-10-01 11:22:08.0 +0200
+++ /var/tmp/diff_new_pack.7WWdxv/_new  2014-10-01 11:22:08.0 +0200
@@ -33,6 +33,12 @@
 Patch5: digikam_no_build_vkontakte.diff
 # PATCH-FIX-UPSTREAM digikam-3.0.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
 Patch6: digikam-3.0.0.no-kdcraw.version-check.patch
+# PATCH-FIX-UPSTREAM bug325580.patch -- Fix job reset when it's done : do not 
return directly is an error appera with a job, without to reset job.
+Patch7: bug325580.patch
+# PATCH-FIX-UPSTREAM handle_right_libkexiv2_version.diff
+Patch8: handle_right_libkexiv2_version.diff
+# PATCH-FIX-UPSTREAM handle_right_libkexiv2_version2.diff
+Patch9: handle_right_libkexiv2_version2.diff
 BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -238,6 +244,9 @@
 %patch3
 %patch5
 %patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ bug325580.patch ++
commit d523a9768ab8276860c76e02b9d9b598a3d607f9
Author: Gilles Caulier caulier.gil...@gmail.com
Date:   Thu Sep 11 19:40:30 2014 +0200

Fix job reset when it's done : do not return directly is an error appera 
with a job, without to reset job.
Fix broken signal/slot connection.
BUGS: 325580
FIXED-IN: 4.4.0

diff --git a/digikam/album/albumlabelstreeview.cpp 
b/digikam/album/albumlabelstreeview.cpp
index 2e1ff30..2047cdf 100644
--- a/core/digikam/album/albumlabelstreeview.cpp
+++ b/core/digikam/album/albumlabelstreeview.cpp
@@ -934,7 +934,6 @@ void AlbumLabelsSearchHandler::slotResult(KJob* job)
 // Pop-up a message about the error.
 DNotificationWrapper(QString(), job-errorString(),
  DigikamApp::instance(), 
DigikamApp::instance()-windowTitle());
-return;
 }
 }
 
diff --git a/digikam/album/albummanager.cpp b/digikam/album/albummanager.cpp
index bd05e27..02452b0 100644
--- a/core/digikam/album/albummanager.cpp
+++ b/core/digikam/album/albummanager.cpp
@@ -2969,7 +2969,6 @@ void AlbumManager::slotAlbumsJobResult(KJob* job)
 // Pop-up a message about the error.
 DNotificationWrapper(QString(), job-errorString(),
  0, i18n(digiKam));
-return;
 }
 }
 
@@ -3000,7 +2999,6 @@ void AlbumManager::slotPeopleJobResult(KJob* job)
 // Pop-up a message about the error.
 DNotificationWrapper(QString(), job-errorString(),
  0, i18n(digiKam));
-return;
 }
 }
 
@@ -3044,7 +3042,6 @@ void AlbumManager::slotTagsJobResult(KJob* job)
 // Pop-up a message about the error.
 DNotificationWrapper(QString(), job-errorString(),
  0, i18n(digiKam));
-return;
 }
 }
 
@@ -3075,7 +3072,6 @@ void AlbumManager::slotDatesJobResult(KJob* job)
 // Pop-up a message about the error.
 DNotificationWrapper(QString(), job-errorString(),
  0, i18n(digiKam));
-return;
 }
 
 emit signalAllDAlbumsLoaded();
diff --git a/libs/models/imagealbummodel.cpp b/libs/models/imagealbummodel.cpp
index 7681fa3..5486b55 100644
--- a/core/libs/models/imagealbummodel.cpp
+++ b/core/libs/models/imagealbummodel.cpp
@@ -346,7 +346,6 @@ void ImageAlbumModel::slotResult(KJob* job)
 // Pop-up a message about the error.
 

commit digikam for openSUSE:Factory

2014-09-19 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2014-09-19 13:55:40

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2014-08-27 
22:18:27.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2014-09-19 
13:55:44.0 +0200
@@ -1,0 +2,20 @@
+Tue Sep 16 22:51:40 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 4.3.0
+  digikam:
+- Database : Nepomuk support have been replaced by
+ Baloo support
+- Map Searches : New option to display all non geolocated
+ images from collections.
+- General  : New notification event when kioslave
+ cannot be started.
+- General  : OSX event notifier is now used to
+ dispatch notifications.
+- AlbumGui : New Action To Exclude Items Without Rating
+ with items filter.
+  kipi-plugins:
+- ExpoBlending:  remove OPenMP dependency. Ported to QtConcurrentRun.
+- Panorama:  support next hugin version (2014.0).
+- Build with baloo support for 13.2+
+
+---

Old:

  digikam-4.2.0.tar.bz2

New:

  digikam-4.3.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.JyKYUB/_old  2014-09-19 13:55:47.0 +0200
+++ /var/tmp/diff_new_pack.JyKYUB/_new  2014-09-19 13:55:47.0 +0200
@@ -17,9 +17,9 @@
 
 
 Name:   digikam
-Version:4.2.0
+Version:4.3.0
 Release:0
-%define rversion 4.2.0
+%define rversion 4.3.0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
@@ -43,6 +43,9 @@
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
 %if 0%{?suse_version}  1310
+BuildRequires:  baloo-devel
+%endif
+%if 0%{?suse_version}  1310
 BuildRequires:  gstreamer-plugins-qt-devel
 %else
 BuildRequires:  gstreamer-0_10-plugins-qt-devel
@@ -356,6 +359,10 @@
 %{_kde4_modulesdir}/kio_digikamtags.so
 %{_kde4_servicesdir}/digikam*
 %{_kde4_servicetypesdir}/digikamimageplugin.desktop
+%dir %{_kde4_datadir}/appdata
+%{_kde4_datadir}/appdata/digikam.appdata.xml
+%{_kde4_datadir}/appdata/showfoto.appdata.xml
+%{_kde4_datadir}/appdata/digiKam-ImagePlugin*.metainfo.xml
 
 %files doc
 %defattr(-,root,root,-)

++ digikam-4.2.0.tar.bz2 - digikam-4.3.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-4.2.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-4.3.0.tar.bz2 differ: char 11, 
line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2014-08-27 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2014-08-27 22:18:16

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2014-07-02 
15:04:35.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2014-08-27 
22:18:27.0 +0200
@@ -1,0 +2,30 @@
+Tue Aug  5 14:08:33 UTC 2014 - nico.kru...@gmail.com
+
+- Update to 4.2.0
+  digikam:
+- AlbumGui : New view on left sidebar to search quickly items
+ with assigned Labels.
+ Details: 
http://mohamedanwer.wordpress.com/2014/07/17/the-great-merging-day/
+- AlbumGui : Tags view: add a new option to show items with
+ no tag.
+ Details: 
http://mohamedanwer.wordpress.com/2014/07/11/tags-left-sidebar-supports-new-action-now/
+- Geberal  : Add retina display support with preview and
+ editor canvas under OSX.
+- 16 fixed bugs
+  (kde#336851, kde#336650, kde#326019, kde#337231, kde#337392,
+   kde#262175, kde#262167, kde#286463, kde#337417, kde#160363,
+   kde#330976, kde#337507, kde#337688, kde#160363, kde#132827,
+   kde#337993)
+  kipi-plugins:
+- 4 fixed bugs (kde#313203, kde#334089, kde#336835, kde#256466)
+- adapt remove-gplv2-only.patch
+- dropped QtGstreamer-1.0.patch (added upstream)
+
+---
+Thu Jul 24 10:34:36 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Added QtGstreamer-1.0.patch to support QtGstreamer 1.x API (applied
+  on Factory/13.2 only)
+- Build with gstreamer-plugins-qt-devel for those openSUSE versions
+
+---

Old:

  digikam-4.1.0.tar.bz2

New:

  digikam-4.2.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.pn2qoz/_old  2014-08-27 22:18:31.0 +0200
+++ /var/tmp/diff_new_pack.pn2qoz/_new  2014-08-27 22:18:31.0 +0200
@@ -17,9 +17,9 @@
 
 
 Name:   digikam
-Version:4.1.0
+Version:4.2.0
 Release:0
-%define rversion 4.1.0
+%define rversion 4.2.0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
@@ -42,8 +42,9 @@
 BuildRequires:  gdk-pixbuf-devel
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
-# TODO bring gstreamer-plugins-qt back for 13.2+ once we have them with gst1.0
-%if 0%{?suse_version}  1320
+%if 0%{?suse_version}  1310
+BuildRequires:  gstreamer-plugins-qt-devel
+%else
 BuildRequires:  gstreamer-0_10-plugins-qt-devel
 %endif
 BuildRequires:  lensfun-devel
@@ -237,8 +238,8 @@
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
-sed -i s/__DATE__/\$FAKE_BUILDDATE\/ core/digikam/utils/version.h.cmake
-sed -i s/__DATE__/\$FAKE_BUILDDATE\/g 
extra/kipi-plugins/common/libkipiplugins/tools/kpversion.h.cmake
+sed -i s/__DATE__/\$FAKE_BUILDDATE\/ core/digikam/utils/version.h.cmake.in
+sed -i s/__DATE__/\$FAKE_BUILDDATE\/g 
extra/kipi-plugins/common/libkipiplugins/tools/kpversion.h.cmake.in
 
 pushd extra/kipi-plugins
 # Remove GPL-v2 only files
@@ -252,7 +253,7 @@
 %else
 EXTRA_FLAGS=-DENABLE_LCMS2=ON
 %endif
-%cmake_kde4 -d build -- -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=FALSE 
-DENABLE_INTERNALMYSQL=FALSE $EXTRA_FLAGS
+%cmake_kde4 -d build -- -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=FALSE 
-DENABLE_INTERNALMYSQL=FALSE -DENABLE_KDEPIMLIBSSUPPORT=TRUE $EXTRA_FLAGS
 # there are files in there that are so heavy to the compiler, that one is 
enough
 %make_jobs VERBOSE=1
 

++ digikam-4.1.0.tar.bz2 - digikam-4.2.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-4.1.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-4.2.0.tar.bz2 differ: char 11, 
line 1

++ remove-gplv2-only.patch ++
--- /var/tmp/diff_new_pack.pn2qoz/_old  2014-08-27 22:18:31.0 +0200
+++ /var/tmp/diff_new_pack.pn2qoz/_new  2014-08-27 22:18:31.0 +0200
@@ -1,12 +1,7 @@
-Index: extra/kipi-plugins/gpssync/CMakeLists.txt
-===
 extra/kipi-plugins/gpssync/CMakeLists.txt.orig
-+++ extra/kipi-plugins/gpssync/CMakeLists.txt
-@@ -34,10 +34,8 @@ SET(kipiplugin_gpssync_PART_SRCS
- 
- IF(KDE4_BUILD_TESTS)
- INCLUDE_DIRECTORIES(BEFORE ${CMAKE_CURRENT_SOURCE_DIR}/borrowed)
--ADD_DEFINITIONS(-DGPSSYNC_MODELTEST)
+--- extra/kipi-plugins/gpssync/CMakeLists.txt.orig 2014-08-05 
16:19:57.369791501 +0200
 

commit digikam for openSUSE:Factory

2014-07-02 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2014-07-02 15:04:31

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2014-05-26 
14:40:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2014-07-02 
15:04:35.0 +0200
@@ -1,0 +2,8 @@
+Mon Jun 30 18:24:44 UTC 2014 - adr...@suse.de
+
+- Update to 4.1.0
+  * Add Gelocation indicator over thumbnails when image has GPS coordinateds.
+  * Thumbnails from icon-view now support large resolution monitor (WQHD or 
4K). Thumbs size can be set until 512x512 px instead 256x256 px.
+  * many many bugfixes, see NEWS file for more details
+
+---

Old:

  digikam-4.0.0.tar.bz2

New:

  digikam-4.1.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.HzzJYg/_old  2014-07-02 15:04:38.0 +0200
+++ /var/tmp/diff_new_pack.HzzJYg/_new  2014-07-02 15:04:38.0 +0200
@@ -17,9 +17,9 @@
 
 
 Name:   digikam
-Version:4.0.0
+Version:4.1.0
 Release:0
-%define rversion 4.0.0
+%define rversion 4.1.0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
@@ -330,7 +330,7 @@
 
 %files
 %defattr(-,root,root,-)
-%doc 
core/{AUTHORS,COPYING,COPYING-CMAKE-SCRIPTS,COPYING.LIB,ChangeLog,NEWS,README,README.FACE,TODO,TODO.FACE,TODO.MYSQLPORT,TODO.TABLEVIEW}
+%doc 
core/{AUTHORS,COPYING,COPYING-CMAKE-SCRIPTS,COPYING.LIB,ChangeLog,NEWS,README,TODO,TODO.FACE,TODO.MYSQLPORT,TODO.TABLEVIEW}
 %{_kde4_applicationsdir}/digikam.desktop
 %{_kde4_applicationsdir}/showfoto.desktop
 %{_kde4_appsdir}/digikam/

++ digikam-3.0.0.no-kdcraw.version-check.patch ++
--- /var/tmp/diff_new_pack.HzzJYg/_old  2014-07-02 15:04:38.0 +0200
+++ /var/tmp/diff_new_pack.HzzJYg/_new  2014-07-02 15:04:38.0 +0200
@@ -1,7 +1,8 @@
-diff -U3 -dHrN digikam-3.0.0/core/CMakeLists.txt 
digikam-3.0.0.no-kdcraw.version-check/core/CMakeLists.txt
 digikam-3.0.0/core/CMakeLists.txt  2013-02-07 00:51:27.0 +0100
-+++ digikam-3.0.0.no-kdcraw.version-check/core/CMakeLists.txt  2013-02-11 
22:33:47.088164540 +0100
-@@ -199,21 +199,23 @@
+Index: digikam-4.1.0/core/CMakeLists.txt
+===
+--- digikam-4.1.0.orig/core/CMakeLists.txt
 digikam-4.1.0/core/CMakeLists.txt
+@@ -203,21 +203,23 @@ ENDIF (NOT OpenCV_INCLUDE_DIRS)
  
  # check the libkdcraw version
  
@@ -38,10 +39,11 @@
  
  # LCMS version 1 and 2 library handling
  # See B.K.O #294105
-diff -U3 -dHrN digikam-3.0.0/extra/kipi-plugins/CMakeLists.txt 
digikam-3.0.0.no-kdcraw.version-check/extra/kipi-plugins/CMakeLists.txt
 digikam-3.0.0/extra/kipi-plugins/CMakeLists.txt2013-02-07 
00:52:03.0 +0100
-+++ digikam-3.0.0.no-kdcraw.version-check/extra/kipi-plugins/CMakeLists.txt
2013-02-11 22:33:47.104155757 +0100
-@@ -131,21 +131,23 @@
+Index: digikam-4.1.0/extra/kipi-plugins/CMakeLists.txt
+===
+--- digikam-4.1.0.orig/extra/kipi-plugins/CMakeLists.txt
 digikam-4.1.0/extra/kipi-plugins/CMakeLists.txt
+@@ -139,21 +139,23 @@ FIND_PACKAGE(Kdcraw   RE
  
  # Check the libkdcraw version
  

++ digikam-4.0.0.tar.bz2 - digikam-4.1.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-4.0.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-4.1.0.tar.bz2 differ: char 11, 
line 1

++ digikam-buildtime.patch ++
--- /var/tmp/diff_new_pack.HzzJYg/_old  2014-07-02 15:04:38.0 +0200
+++ /var/tmp/diff_new_pack.HzzJYg/_new  2014-07-02 15:04:38.0 +0200
@@ -1,7 +1,7 @@
 Index: core/libs/3rdparty/cimg/CImg.h
 ===
 core/libs/3rdparty/cimg/CImg.h.orig2011-12-04 22:40:13.0 
+0100
-+++ core/libs/3rdparty/cimg/CImg.h 2011-12-12 10:45:04.129281874 +0100
+--- core/libs/3rdparty/cimg/CImg.h.orig
 core/libs/3rdparty/cimg/CImg.h
 @@ -5673,7 +5673,7 @@ namespace cimg_library {
  if (usage) {
cimg_std::fprintf(cimg_stdout,\n 
%s%s%s,cimg::t_red,cimg::basename(argv[0]),cimg::t_normal);

++ digikam_no_build_vkontakte.diff ++
--- /var/tmp/diff_new_pack.HzzJYg/_old  2014-07-02 15:04:38.0 +0200
+++ /var/tmp/diff_new_pack.HzzJYg/_new  2014-07-02 15:04:38.0 +0200
@@ -1,5 +1,7 @@
 CMakeLists.txt 2012-01-03 01:42:09.0 +0100
-+++ CMakeLists.txt 2012-01-05 

commit digikam for openSUSE:Factory

2014-05-26 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2014-05-26 14:40:25

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2014-05-10 
08:32:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2014-05-26 
14:40:38.0 +0200
@@ -1,0 +2,11 @@
+Tue May 20 12:32:42 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Build with lcm2 for openSUSE 13.2 and newer
+
+---
+Wed May 14 08:35:51 UTC 2014 - tittiatc...@gmail.com
+
+- Update to 4.0.0 final
+  * Final release. see NEWS file for more details
+
+---

Old:

  digikam-4.0.0-rc.tar.bz2

New:

  digikam-4.0.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.i8STlQ/_old  2014-05-26 14:40:46.0 +0200
+++ /var/tmp/diff_new_pack.i8STlQ/_new  2014-05-26 14:40:46.0 +0200
@@ -17,14 +17,14 @@
 
 
 Name:   digikam
-Version:4.0.0~rc
+Version:4.0.0
 Release:0
-%define rversion 4.0.0-rc
+%define rversion 4.0.0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
-Source0:
http://download.kde.org/unstable/%{name}/%{name}-%{rversion}.tar.bz2
+Source0:
http://download.kde.org/stable/%{name}/%{name}-%{rversion}.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
 # PATCH-FIX-OPENSUSE remove-gplv2-only.patch idoen...@suse.de bnc#711963 -- 
Remove GPLv2 only files from the build system
@@ -65,7 +65,11 @@
 BuildRequires:  libMagick++-devel
 BuildRequires:  libksane-devel
 BuildRequires:  libkvkontakte-devel
+%if 0%{?suse_version}  1320
 BuildRequires:  liblcms-devel
+%else
+BuildRequires:  liblcms2-devel
+%endif
 BuildRequires:  liblqr-devel
 BuildRequires:  libpgf-devel
 BuildRequires:  libqca2-devel
@@ -243,7 +247,12 @@
 popd
 
 %build
-%cmake_kde4 -d build -- -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=FALSE 
-DENABLE_INTERNALMYSQL=FALSE
+%if 0%{?suse_version}  1320
+EXTRA_FLAGS=-DENABLE_LCMS2=OFF
+%else
+EXTRA_FLAGS=-DENABLE_LCMS2=ON
+%endif
+%cmake_kde4 -d build -- -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=FALSE 
-DENABLE_INTERNALMYSQL=FALSE $EXTRA_FLAGS
 # there are files in there that are so heavy to the compiler, that one is 
enough
 %make_jobs VERBOSE=1
 

++ digikam-4.0.0-rc.tar.bz2 - digikam-4.0.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-4.0.0-rc.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-4.0.0.tar.bz2 differ: char 11, 
line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2014-04-23 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2014-04-23 17:31:45

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-10-29 
09:21:36.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2014-04-23 
17:31:48.0 +0200
@@ -1,0 +2,29 @@
+Mon Apr 21 00:35:31 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 4.0.0~beta4
+  digikam:
+- General  : New Tags Manager window for easy tags management.
+- General  : New images quality sorter tool, based on blur,
+ noise, and compression analysis.
+- General  : Multiple selection and multiple drag-n-drop
+ capabilities on Tags Manager and Tags View from sidebars.
+- General  : Drop of Qt3Support classes. Now digiKam is
+ pure Qt4 implementation.
+- Metadata : Support for writing face rectangles in Windows
+ Live Photo format.
+- Editor   : Port of canvas to Qt Model/view.
+- Showfoto : Port of Thumbbar to Qt Model/view.
+  kipi-plugins:
+- General:   New tool to export collection to Google Drive cloud service.
+- General:   New tool to export collection to DropBox cloud service.
+- MediaWiki: allow removal of metadata/GPS coordinates before uploading.
+- MediaWiki: graphical interface improvements.
+  * See NEWS file for more details
+- Drop rajceexport-stop-crashing-when-uploaded-nothing.patch, merged
+  upstream
+- Drop libsoprano-devel and shared-desktop-ontologies-devel BuildRequires
+- Disable gstreamer-0_10-plugins-qt-devel Buildrequires for 13.2+,
+  until we get qgstreamer with gstreamer 1.0 API support
+- Remove unused parts of the spec (UpdatedApps repo no longer exists)
+
+---

Old:

  digikam-3.5.0.tar.bz2
  rajceexport-stop-crashing-when-uploaded-nothing.patch

New:

  digikam-4.0.0-beta4.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.e78r5s/_old  2014-04-23 17:31:51.0 +0200
+++ /var/tmp/diff_new_pack.e78r5s/_new  2014-04-23 17:31:51.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package digikam
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,13 +17,14 @@
 
 
 Name:   digikam
-Version:3.5.0
+Version:4.0.0~beta4
 Release:0
+%define rversion 4.0.0-beta4
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
-Source0:
ftp://ftp.kde.org/pub/kde/stable/digikam/digikam-%{version}.tar.bz2
+Source0:
http://download.kde.org/unstable/%{name}/%{name}-%{rversion}.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
 # PATCH-FIX-OPENSUSE remove-gplv2-only.patch idoen...@suse.de bnc#711963 -- 
Remove GPLv2 only files from the build system
@@ -32,8 +33,6 @@
 Patch5: digikam_no_build_vkontakte.diff
 # PATCH-FIX-UPSTREAM digikam-3.0.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
 Patch6: digikam-3.0.0.no-kdcraw.version-check.patch
-# PATCH-FIX-UPSTREAM rajceexport-stop-crashing-when-uploaded-nothing.patch -- 
rajceexport: stop crashing when uploaded nothing
-Patch7: rajceexport-stop-crashing-when-uploaded-nothing.patch
 BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -41,7 +40,10 @@
 BuildRequires:  fdupes
 BuildRequires:  flex
 BuildRequires:  gdk-pixbuf-devel
+# TODO bring gstreamer-plugins-qt back for 13.2+ once we have them with gst1.0
+%if 0%{?suse_version}  1320
 BuildRequires:  gstreamer-0_10-plugins-qt-devel
+%endif
 BuildRequires:  lensfun-devel
 %if 0%{?suse_version}  1230
 BuildRequires:  libeigen3-devel
@@ -63,17 +65,13 @@
 BuildRequires:  libkvkontakte-devel
 BuildRequires:  liblcms-devel
 BuildRequires:  liblqr-devel
-%if 0%{?suse_version}  1220
 BuildRequires:  libpgf-devel
-%endif
 BuildRequires:  libqca2-devel
 BuildRequires:  libqjson-devel
-BuildRequires:  libsoprano-devel
 BuildRequires:  libusb-1_0-devel
 BuildRequires:  libusb-compat-devel
 BuildRequires:  marble-devel
 BuildRequires:  opencv-devel = 2.4.5
-BuildRequires:  shared-desktop-ontologies-devel
 

commit digikam for openSUSE:Factory

2013-10-29 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-10-29 09:21:35

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-10-18 
13:38:51.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-10-29 
09:21:36.0 +0100
@@ -1,0 +2,6 @@
+Sun Oct 27 23:15:14 UTC 2013 - hrvoje.sen...@gmail.com
+
+- BuildRequire pkgconfig(libkipi) = 2.0.0, instead of generic, and
+  unversioned libkipi-devel
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.pURyr9/_old  2013-10-29 09:21:37.0 +0100
+++ /var/tmp/diff_new_pack.pURyr9/_new  2013-10-29 09:21:37.0 +0100
@@ -54,7 +54,7 @@
 BuildRequires:  libkde4-devel
 BuildRequires:  libkdepimlibs4-devel
 BuildRequires:  libkexiv2-devel
-BuildRequires:  libkipi-devel
+BuildRequires:  pkgconfig(libkipi) = 2.0.0
 %if 0%{?suse_version}  1230
 BuildRequires:  libkqoauth-devel
 %endif

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2013-10-18 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-10-18 13:33:16

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-09-07 
07:31:53.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-10-18 
13:38:51.0 +0200
@@ -1,0 +2,20 @@
+Fri Oct 18 01:20:20 UTC 2013 - hrvoje.sen...@gmail.com
+
+- Bump minimal opencv-devel BuildRequires to 2.4.5 as per CMakeLists
+
+---
+Fri Oct 11 21:25:58 UTC 2013 - nico.kru...@gmail.com
+
+- Update to 3.5.0:
+  digikam:
+- General : new RAW cameras supported : Richon GR,
+Panasonic LF1, Canon EOS 70D, Sony RX100II,
+Sony RX1R, Olympus E-P5.
+- 5 fixed bugs
+  (kde#324349, kde#323648, kde#325111, kde#325264, kde#325309)
+  kipi-plugins:
+- Panorama: Autocrop. Cropping area defaults to the
+maximum inner rectangle of the panorama.
+- 1 fixed bug (kde#324239)
+
+---
@@ -4 +24 @@
-- Update to 3.4.0
+- Update to 3.4.0:

Old:

  digikam-3.4.0.tar.bz2

New:

  digikam-3.5.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.2LQOrt/_old  2013-10-18 13:38:54.0 +0200
+++ /var/tmp/diff_new_pack.2LQOrt/_new  2013-10-18 13:38:54.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:3.4.0
+Version:3.5.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
@@ -72,7 +72,7 @@
 BuildRequires:  libusb-1_0-devel
 BuildRequires:  libusb-compat-devel
 BuildRequires:  marble-devel
-BuildRequires:  opencv-devel
+BuildRequires:  opencv-devel = 2.4.5
 BuildRequires:  shared-desktop-ontologies-devel
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(glu)
@@ -248,8 +248,7 @@
 %build
 %if !0%{?kde_updatedapps}
 %if 0%{?suse_version} = 1310
-  
EXTRA_FLAGS=-DImageMagick_MagickCore_INCLUDE_DIR:PATH=%{_includedir}/ImageMagick-6
 \
-   
-DImageMagick_MagickCore_LIBRARY:FILEPATH=%{_libdir}/libMagickCore-6.Q8.so
+  EXTRA_FLAGS=
 %endif
 %cmake_kde4 -d build -- -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=FALSE 
-DENABLE_INTERNALMYSQL=FALSE $EXTRA_FLAGS
 %else

++ digikam-3.4.0.tar.bz2 - digikam-3.5.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-3.4.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-3.5.0.tar.bz2 differ: char 11, 
line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2013-09-06 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-09-07 07:31:50

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-08-30 
11:36:13.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-09-07 
07:31:53.0 +0200
@@ -1,0 +2,14 @@
+Fri Sep  6 15:42:33 UTC 2013 - dmitr...@opensuse.org
+
+- Update to 3.4.0
+  digikam
+- General : Add interroperabilty with Capture NX about
+Color Labels support.
+- MaintenanceTool : add new options to select Albums and Tags
+to process.
+- MaintenanceTool : add multi-threading and multi-core CPU
+support for Metadata Synchronizer, Thumbs
+Generator, and Fingerprint Generator tools.
+- 9 fixed bugs.
+
+---

Old:

  digikam-3.3.0.tar.bz2

New:

  digikam-3.4.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.qKgzgX/_old  2013-09-07 07:31:55.0 +0200
+++ /var/tmp/diff_new_pack.qKgzgX/_new  2013-09-07 07:31:55.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:3.3.0
+Version:3.4.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+

++ digikam-3.3.0.tar.bz2 - digikam-3.4.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-3.3.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-3.4.0.tar.bz2 differ: char 11, 
line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2013-08-30 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-08-30 11:36:12

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-08-16 
13:49:01.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-08-30 
11:36:13.0 +0200
@@ -1,0 +2,6 @@
+Wed Aug 28 16:47:36 UTC 2013 - hrvoje.sen...@gmail.com
+
+- Dropped desktop-files.diff, it's no longer needed and AcquireImages
+  is missing it's icon due to it (bnc#835989)
+
+---

Old:

  desktop-files.diff



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.6Dn2RD/_old  2013-08-30 11:36:15.0 +0200
+++ /var/tmp/diff_new_pack.6Dn2RD/_new  2013-08-30 11:36:15.0 +0200
@@ -26,8 +26,6 @@
 Source0:
ftp://ftp.kde.org/pub/kde/stable/digikam/digikam-%{version}.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
-# PATCH-FIX-OPENSUSE desktop-files.diff -- Remove Icon= entry (the icon is 
missing)
-Patch1: desktop-files.diff
 # PATCH-FIX-OPENSUSE remove-gplv2-only.patch idoen...@suse.de bnc#711963 -- 
Remove GPLv2 only files from the build system
 Patch3: remove-gplv2-only.patch
 # PATCH-FIX-OPENSUSE digikam_no_build_vkontakte.diff tittiatc...@gmail.com -- 
Don't build libvkontakte (use external one)
@@ -229,9 +227,6 @@
 %prep
 %setup -q
 %patch0
-pushd extra/kipi-plugins
-%patch1
-popd
 %patch3
 %patch5
 %patch6 -p1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2013-08-16 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-08-16 13:48:02

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-06-13 
16:38:56.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-08-16 
13:49:01.0 +0200
@@ -1,0 +2,25 @@
+Thu Aug 15 12:12:30 UTC 2013 - jsl...@suse.com
+
+- rajceexport-stop-crashing-when-uploaded-nothing.patch: rajceexport:
+  stop crashing when uploaded nothing (bnc#835021)
+
+---
+Tue Aug  6 11:20:50 UTC 2013 - nico.kru...@gmail.com
+
+- fix libkface package not named after .so name
+
+---
+Tue Aug  6 08:47:20 UTC 2013 - nico.kru...@gmail.com
+
+- Update to 3.3.0:
+  digikam:
+- Faces Managament: Better management of Picasa Face Tags
+import/export through metadata.
+- Faces Management: New Face Recognition engine based on
+OpenTLD.
+- 37 fixed bugs.
+  kipi-plugins:
+- 5 fixed bugs.
+- Drop patch included upstream: non-executable-script.patch
+
+---

Old:

  digikam-3.2.0.tar.bz2
  non-executable-script.patch

New:

  digikam-3.3.0.tar.bz2
  rajceexport-stop-crashing-when-uploaded-nothing.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.KG2Rv8/_old  2013-08-16 13:49:03.0 +0200
+++ /var/tmp/diff_new_pack.KG2Rv8/_new  2013-08-16 13:49:03.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:3.2.0
+Version:3.3.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
@@ -28,14 +28,14 @@
 Patch0: digikam-buildtime.patch
 # PATCH-FIX-OPENSUSE desktop-files.diff -- Remove Icon= entry (the icon is 
missing)
 Patch1: desktop-files.diff
-# PATCH-FIX-OPENSUSE non-executable-script.patch asterios.dra...@gmail.com -- 
Fix rpmlint warning non-executable-script
-Patch2: non-executable-script.patch
 # PATCH-FIX-OPENSUSE remove-gplv2-only.patch idoen...@suse.de bnc#711963 -- 
Remove GPLv2 only files from the build system
 Patch3: remove-gplv2-only.patch
 # PATCH-FIX-OPENSUSE digikam_no_build_vkontakte.diff tittiatc...@gmail.com -- 
Don't build libvkontakte (use external one)
 Patch5: digikam_no_build_vkontakte.diff
 # PATCH-FIX-UPSTREAM digikam-3.0.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
 Patch6: digikam-3.0.0.no-kdcraw.version-check.patch
+# PATCH-FIX-UPSTREAM rajceexport-stop-crashing-when-uploaded-nothing.patch -- 
rajceexport: stop crashing when uploaded nothing
+Patch7: rajceexport-stop-crashing-when-uploaded-nothing.patch
 BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -182,17 +182,17 @@
 Summary:Development files for libkface
 License:BSD-3-Clause and GPL-2.0+ and LGPL-2.1+ and MIT
 Group:  Development/Libraries/KDE
-Requires:   libkface1 = %{version}
+Requires:   libkface2 = %{version}
 
 %description -n libkface-devel
 This package contains development files for libkface.
 
-%package -n libkface1
+%package -n libkface2
 Summary:Wrapper around LibFace to perform face recognition and 
detection over pictures
 License:BSD-3-Clause and GPL-2.0+ and LGPL-2.1+ and MIT
 Group:  System/Libraries
 
-%description -n libkface1
+%description -n libkface2
 Libkface is a Qt/C++ wrapper around LibFace to perform face recognition and
 detection over pictures.
 
@@ -232,10 +232,12 @@
 pushd extra/kipi-plugins
 %patch1
 popd
-%patch2
 %patch3
 %patch5
 %patch6 -p1
+pushd extra/kipi-plugins
+%patch7 -p1
+popd
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
@@ -328,9 +330,9 @@
 
 %postun -n libkgeomap1 -p /sbin/ldconfig
 
-%post -n libkface1 -p /sbin/ldconfig
+%post -n libkface2 -p /sbin/ldconfig
 
-%postun -n libkface1 -p /sbin/ldconfig
+%postun -n libkface2 -p /sbin/ldconfig
 
 %post -n libmediawiki1 -p /sbin/ldconfig
 
@@ -399,11 +401,34 @@
 %{_kde4_bindir}/expoblending
 %{_kde4_bindir}/panoramagui
 %{_kde4_bindir}/photolayoutseditor
-%{_kde4_configkcfgdir}/PLEConfigSkeleton.kcfgc
-%dir %{_kde4_iconsdir}/hicolor/24x24/actions
+%{_kde4_configkcfgdir}/photolayoutseditor.kcfg
+%dir %{_kde4_iconsdir}/hicolor/24x24/apps
 %{_kde4_iconsdir}/hicolor/*/actions/*.*
-%exclude 

commit digikam for openSUSE:Factory

2013-06-13 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-06-13 16:38:55

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-06-11 
09:26:35.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-06-13 
16:38:56.0 +0200
@@ -1,0 +2,11 @@
+Mon Jun 10 19:37:07 UTC 2013 - asterios.dra...@gmail.com
+
+- Added libeigen3-devel and libkqoauth-devel as build requirements.
+- Replaced ImageMagick with ImageMagick-devel as build requirement (since
+  mogrify is no longer needed to fix the icon sizes).
+- Removed support for openSUSE = 11.4 for KDE:UpdatedApps (not needed).
+- Removed support for openSUSE 11.3.
+- Fix rawconverter icon links (links were pointing to rawconverter.* instead of
+  rawconverter.png or rawconverter.svgz).
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.A36LcG/_old  2013-06-13 16:38:57.0 +0200
+++ /var/tmp/diff_new_pack.A36LcG/_new  2013-06-13 16:38:57.0 +0200
@@ -36,14 +36,18 @@
 Patch5: digikam_no_build_vkontakte.diff
 # PATCH-FIX-UPSTREAM digikam-3.0.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
 Patch6: digikam-3.0.0.no-kdcraw.version-check.patch
-BuildRequires:  ImageMagick
+BuildRequires:  ImageMagick-devel
 BuildRequires:  bison
 BuildRequires:  boost-devel
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  flex
+BuildRequires:  gdk-pixbuf-devel
 BuildRequires:  gstreamer-0_10-plugins-qt-devel
 BuildRequires:  lensfun-devel
+%if 0%{?suse_version}  1230
+BuildRequires:  libeigen3-devel
+%endif
 BuildRequires:  libexpat-devel
 BuildRequires:  libgphoto2-devel
 BuildRequires:  libgpod-devel
@@ -51,24 +55,14 @@
 BuildRequires:  libkdcraw-devel
 BuildRequires:  libkde4-devel
 BuildRequires:  libkdepimlibs4-devel
-%if 0%{?kde_updatedapps}
-%if 0%{?suse_version} == 1140
-BuildRequires:  libexiv2-devel = 0.21
-BuildRequires:  sane-backends-devel
-%endif
-%if 0%{?suse_version}  1140
 BuildRequires:  libkexiv2-devel
 BuildRequires:  libkipi-devel
-BuildRequires:  libksane-devel
-BuildRequires:  libkvkontakte-devel
+%if 0%{?suse_version}  1230
+BuildRequires:  libkqoauth-devel
 %endif
-%else
-BuildRequires:  libkexiv2-devel
-BuildRequires:  libkipi-devel
+BuildRequires:  libMagick++-devel
 BuildRequires:  libksane-devel
 BuildRequires:  libkvkontakte-devel
-%endif
-BuildRequires:  libMagick++-devel
 BuildRequires:  liblcms-devel
 BuildRequires:  liblqr-devel
 %if 0%{?suse_version}  1220
@@ -83,11 +77,6 @@
 BuildRequires:  opencv-devel
 BuildRequires:  shared-desktop-ontologies-devel
 BuildRequires:  pkgconfig(glib-2.0)
-%if 0%{?suse_version} == 1130
-BuildRequires:  pkgconfig(gtk+-2.0)
-%else
-BuildRequires:  gdk-pixbuf-devel
-%endif
 BuildRequires:  pkgconfig(glu)
 %if 0%{?suse_version}
 BuildRequires:  update-desktop-files
@@ -286,10 +275,6 @@
 rm -f %{buildroot}%{_kde4_libdir}/libHUpnpAv.a
 rm -f %{buildroot}%{_kde4_libdir}/libQtSoap.a
 
-# Fix wrong-icon-size rpmlint warning
-mogrify -extent 64x64 -background transparent -gravity center 
%{buildroot}%{_kde4_iconsdir}/hicolor/64x64/actions/metadataedit.png
-mogrify -extent 128x128 -background transparent -gravity south 
%{buildroot}%{_kde4_iconsdir}/hicolor/128x128/actions/flash.png
-
 %if 0%{?suse_version}
 %suse_update_desktop_file -r %{name} Qt KDE Graphics Photography
 %suse_update_desktop_file -r showfoto Qt KDE Graphics Photography
@@ -317,12 +302,15 @@
 done
 
 # this allows the icon to be used as an application icon safely
-for res in 16x16 22x22 32x32 48x48 64x64 128x128 scalable
+for res in 16x16 22x22 32x32 48x48 64x64 128x128
 do
 pushd %{buildroot}%{_kde4_iconsdir}/hicolor/$res/apps/
-ln -s %{_kde4_iconsdir}/oxygen/$res/apps/rawconverter.*
+ln -s %{_kde4_iconsdir}/oxygen/$res/apps/rawconverter.png
 popd
 done
+pushd %{buildroot}%{_kde4_iconsdir}/hicolor/scalable/apps/
+ln -s %{_kde4_iconsdir}/oxygen/scalable/apps/rawconverter.svgz
+popd
 
 %fdupes -s %{buildroot}
 
@@ -350,7 +338,7 @@
 
 %files
 %defattr(-,root,root,-)
-%doc 
core/{AUTHORS,COPYING,COPYING.LIB,ChangeLog,NEWS,README,TODO,TODO.FACE,TODO.MYSQLPORT}
+%doc 
core/{AUTHORS,COPYING,COPYING-CMAKE-SCRIPTS,COPYING.LIB,ChangeLog,NEWS,README,README.FACE,TODO,TODO.FACE,TODO.MYSQLPORT,TODO.TABLEVIEW}
 %{_kde4_applicationsdir}/digikam.desktop
 %{_kde4_applicationsdir}/showfoto.desktop
 %{_kde4_appsdir}/digikam/
@@ -397,7 +385,7 @@
 
 %files -n kipi-plugins
 %defattr(-,root,root,-)
-%doc 

commit digikam for openSUSE:Factory

2013-06-11 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-06-11 06:06:44

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-05-16 
15:32:23.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-06-11 
09:26:35.0 +0200
@@ -1,0 +2,5 @@
+Sat Jun  1 19:31:46 UTC 2013 - hrvoje.sen...@gmail.com
+
+- Pass the correct ImageMagick cmake flag for = 13.1
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.DDDNjQ/_old  2013-06-11 09:26:36.0 +0200
+++ /var/tmp/diff_new_pack.DDDNjQ/_new  2013-06-11 09:26:36.0 +0200
@@ -261,12 +261,16 @@
 
 %build
 %if !0%{?kde_updatedapps}
-%cmake_kde4 -d build -- -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=FALSE 
-DENABLE_INTERNALMYSQL=FALSE
+%if 0%{?suse_version} = 1310
+  
EXTRA_FLAGS=-DImageMagick_MagickCore_INCLUDE_DIR:PATH=%{_includedir}/ImageMagick-6
 \
+   
-DImageMagick_MagickCore_LIBRARY:FILEPATH=%{_libdir}/libMagickCore-6.Q8.so
+%endif
+%cmake_kde4 -d build -- -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=FALSE 
-DENABLE_INTERNALMYSQL=FALSE $EXTRA_FLAGS
 %else
 %cmake_kde4 -d build -- -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=TRUE 
-DENABLE_INTERNALMYSQL=FALSE
 %endif
 # there are files in there that are so heavy to the compiler, that one is 
enough
-%{__make} -j1 VERBOSE=1
+%make_jobs VERBOSE=1
 
 %install
 %kde4_makeinstall -C build

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2013-05-16 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-05-16 15:32:18

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-04-29 
09:52:43.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-05-16 
15:32:23.0 +0200
@@ -1,0 +2,33 @@
+Tue May 14 21:53:56 UTC 2013 - hrvoje.sen...@gmail.com
+
+- Update to 3.2.0:
+  digikam:
+- General:  Remove internal clapack library code. 
+Set only an optional and external dependency to 
+eigen3.
+- General:  New tool to Auto-Crop image based on black hole 
+borders detection.
+- AlbumGUI: New Table-View view mode dedicated to show 
+album items in a list view.
+- AlbumGUI: New Aspect-Ratio information displayed in 
+icon-view and tooltips.
+- AlbumGUI: New filter based on Aspect-Ratio information.
+- Searches: New search tool to find images based on 
+Aspect-Ratio Information.
+- Searches: New search tool to find videos based on shot 
+properties.
+- 46 fixed bugs.
+  kipi-plugins:
+- FacebookExport: add new option to create private album.
+- JAlbumExport:   New too to export items to JAblum
+- 10 fixed bugs.
+- Drop patches included upstream: commit-006b3f4.diff and
+  digikam-patch78541.diff
+
+---
+Wed May  8 06:50:52 UTC 2013 - tittiatc...@gmail.com
+
+- Add patch commit-006b3f4.diff from upstream to build 
+  htmlexport again (bnc#816041)
+
+---

Old:

  digikam-3.1.0.tar.bz2
  digikam-patch78541.diff

New:

  digikam-3.2.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.Irf7Mn/_old  2013-05-16 15:32:24.0 +0200
+++ /var/tmp/diff_new_pack.Irf7Mn/_new  2013-05-16 15:32:24.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:3.1.0
+Version:3.2.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
@@ -36,8 +36,6 @@
 Patch5: digikam_no_build_vkontakte.diff
 # PATCH-FIX-UPSTREAM digikam-3.0.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
 Patch6: digikam-3.0.0.no-kdcraw.version-check.patch
-# PATCH-FIX-UPSTREAM digikam-patch78541.diff -- mmeis...@suse.com find devices 
by usb vendor and product id 
-Patch7: digikam-patch78541.diff
 BuildRequires:  ImageMagick
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -249,7 +247,6 @@
 %patch3
 %patch5
 %patch6 -p1
-%patch7 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
@@ -411,6 +408,7 @@
 %{_kde4_bindir}/panoramagui
 %{_kde4_bindir}/photolayoutseditor
 %{_kde4_configkcfgdir}/PLEConfigSkeleton.kcfgc
+%dir %{_kde4_iconsdir}/hicolor/24x24/actions
 %{_kde4_iconsdir}/hicolor/*/actions/*.*
 %exclude %{_kde4_iconsdir}/hicolor/*/actions/gpsimagetag.png
 %{_kde4_iconsdir}/hicolor/*/apps/dngconverter.*

++ digikam-3.0.0.no-kdcraw.version-check.patch ++
--- /var/tmp/diff_new_pack.Irf7Mn/_old  2013-05-16 15:32:24.0 +0200
+++ /var/tmp/diff_new_pack.Irf7Mn/_new  2013-05-16 15:32:24.0 +0200
@@ -76,5 +76,5 @@
 +# 
 +# ENDIF (KDCRAW_VERSION)
  
- # Optional depencies detection required by some plugins
+ # Optional dependencies detection required by some plugins
  MACRO_OPTIONAL_FIND_PACKAGE(EXPAT)   # 
For DNGConverter: XMP SDK need Expat library to compile.

++ digikam-3.1.0.tar.bz2 - digikam-3.2.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-3.1.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-3.2.0.tar.bz2 differ: char 11, 
line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2013-04-29 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-04-29 09:52:41

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-04-18 
10:14:06.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-04-29 
09:52:43.0 +0200
@@ -5 +5 @@
-  detection of certain cameras (bnc#814622, bko#311393)
+  detection of certain cameras (bnc#814622, kde#311393)
@@ -10 +10 @@
-- Update to 3.1.0:
+- Update to 3.1.0 (bnc#816693):



Other differences:
--
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2013-04-18 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-04-18 10:14:05

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-03-21 
10:38:12.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-04-18 
10:14:06.0 +0200
@@ -1,0 +2,6 @@
+Mon Apr 15 14:14:46 UTC 2013 - tittiatc...@gmail.com
+
+- Added patch digikam-patch78541.diff from upstream to fix 
+  detection of certain cameras (bnc#814622, bko#311393)
+
+---

New:

  digikam-patch78541.diff



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.HwmEoK/_old  2013-04-18 10:14:09.0 +0200
+++ /var/tmp/diff_new_pack.HwmEoK/_new  2013-04-18 10:14:09.0 +0200
@@ -36,6 +36,8 @@
 Patch5: digikam_no_build_vkontakte.diff
 # PATCH-FIX-UPSTREAM digikam-3.0.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
 Patch6: digikam-3.0.0.no-kdcraw.version-check.patch
+# PATCH-FIX-UPSTREAM digikam-patch78541.diff -- mmeis...@suse.com find devices 
by usb vendor and product id 
+Patch7: digikam-patch78541.diff
 BuildRequires:  ImageMagick
 BuildRequires:  bison
 BuildRequires:  boost-devel
@@ -247,6 +249,7 @@
 %patch3
 %patch5
 %patch6 -p1
+%patch7 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ digikam-patch78541.diff ++
commit 1f0dbbd3b3a6246e8c66b038a3f1e06af2f5ee11
Author: Gilles Caulier caulier.gil...@gmail.com
Date:   Mon Apr 1 14:59:20 2013 +0200

Apply patch #78541 from Marcus Meissner about to find devices by usb vendor 
and product id, also if libgphoto2
just finds them by interface class.
BUGS: 311393
FIXED-IN: 3.2.0

diff --git a/utilities/importui/backend/gpcamera.cpp 
b/utilities/importui/backend/gpcamera.cpp
index 708d424..a41dff1 100644
--- a/core/utilities/importui/backend/gpcamera.cpp
+++ b/core/utilities/importui/backend/gpcamera.cpp
@@ -1295,8 +1295,7 @@ bool GPCamera::uploadItem(const QString folder, const 
QString itemName, const
 #ifdef HAVE_GPHOTO2
 int errorCode;
 CameraFile* cfile = 0;
-
-errorCode = gp_file_new(cfile);
+errorCode = gp_file_new(cfile);
 
 if (errorCode != GP_OK)
 {
@@ -1599,11 +1598,10 @@ void GPCamera::getSupportedCameras(int count, 
QStringList clist)
 clist.clear();
 count = 0;
 
-CameraAbilitiesList* abilList = 0;
 CameraAbilities  abil;
+CameraAbilitiesList* abilList = 0;
 GPContext*   context  = 0;
-
-context = gp_context_new();
+context   = gp_context_new();
 
 gp_abilities_list_new(abilList);
 gp_abilities_list_load(abilList, context);
@@ -1661,7 +1659,7 @@ void GPCamera::getSupportedPorts(QStringList plist)
 {
 gp_port_info_list_get_info(list, i, info);
 #ifdef HAVE_GPHOTO25
-   char *xpath;
+char* xpath = 0;
 gp_port_info_get_name (info, xpath);
 plist.append(xpath);
 #else
@@ -1685,8 +1683,7 @@ void GPCamera::getCameraSupportedPorts(const QString 
model, QStringList plist)
 CameraAbilities  abilities;
 CameraAbilitiesList* abilList = 0;
 GPContext*   context  = 0;
-
-context = gp_context_new();
+context   = gp_context_new();
 
 gp_abilities_list_new(abilList);
 gp_abilities_list_load(abilList, context);
@@ -1719,8 +1716,8 @@ int GPCamera::autoDetect(QString model, QString port)
 GPPortInfoList*  infoList  = 0;
 const char*  camModel_ = 0, *camPort_ = 0;
 GPContext*   context   = 0;
+context= gp_context_new();
 
-context = gp_context_new();
 gp_list_new(camList);
 
 gp_abilities_list_new(abilList);
@@ -1789,8 +1786,9 @@ bool GPCamera::findConnectedUsbCamera(int vendorId, int 
productId, QString mode
 CameraList*  camList  = 0;
 bool success  = false;
 // get name and port of detected camera
-const char* model_str = 0, *port_str = 0;
-context = gp_context_new();
+const char* model_str = 0;
+const char* port_str  = 0;
+context   = gp_context_new();
 
 // get list of all ports
 gp_port_info_list_new(list);
@@ -1804,30 +1802,71 @@ bool GPCamera::findConnectedUsbCamera(int vendorId, int 
productId, QString mode
 gp_list_new 

commit digikam for openSUSE:Factory

2013-03-21 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-03-21 10:38:06

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-02-14 
20:35:54.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-03-21 
10:38:12.0 +0100
@@ -1,0 +2,11 @@
+Wed Mar 13 09:51:53 UTC 2013 - nico.kru...@gmail.com
+
+- Update to 3.1.0:
+  digikam:
+- General: Remove internal lqr-1 library code. Set only an
+   optional and external dependency.
+- 14 fixed bugs.
+  kipi-plugins:
+- 7 fixed bugs.
+
+---

Old:

  digikam-3.0.0.tar.bz2

New:

  digikam-3.1.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.PGLcmI/_old  2013-03-21 10:38:15.0 +0100
+++ /var/tmp/diff_new_pack.PGLcmI/_new  2013-03-21 10:38:15.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:3.0.0
+Version:3.1.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+

++ digikam-3.0.0.tar.bz2 - digikam-3.1.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-3.0.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-3.1.0.tar.bz2 differ: char 11, 
line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2013-02-14 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-02-14 20:35:52

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-02-12 
16:36:42.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-02-14 
20:35:54.0 +0100
@@ -1,0 +2,5 @@
+Wed Feb 13 21:54:09 UTC 2013 - wstephen...@suse.com
+
+- Remove spurious bison/flex dependencies
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.BOD2RB/_old  2013-02-14 20:35:58.0 +0100
+++ /var/tmp/diff_new_pack.BOD2RB/_new  2013-02-14 20:35:58.0 +0100
@@ -151,8 +151,6 @@
 License:GPL-2.0+
 Group:  Productivity/Graphics/Other
 Recommends: ImageMagick
-Recommends: bison
-Recommends: flex
 Recommends: enblend-enfuse
 Recommends: hugin
 Recommends: kipi-plugins-lang = %{version}

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2013-02-12 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-02-12 16:36:35

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2013-01-07 
10:59:17.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-02-12 
16:36:42.0 +0100
@@ -1,0 +2,19 @@
+Mon Feb 11 21:15:35 UTC 2013 - nico.kru...@gmail.com
+
+- Update to 3.0.0 (final):
+  digikam:
+- General: Remove internal LensFun library code and xml lens
+   database. Set only an optional and external
+   dependency to last 0.2.6 release.
+- BatchQueueManager: Add new tool to crop image.
+- 51 fixed bugs.
+  kipi-plugins:
+- Panorama: New parser using GNU Flex and GNU Bison instead of
+Boost::spirit
+- Panorama: Manual cropping of the final result
+- 10 fixed bugs.
+- drop fix-broken-icon-reference.diff (fixed upstream)
+- update digikam-3.0.0-rc.no-kdcraw.version-check.patch
+  (rename to digikam-3.0.0.no-kdcraw.version-check.patch)
+
+---

Old:

  digikam-3.0.0-rc.no-kdcraw.version-check.patch
  digikam-3.0.0-rc.tar.bz2
  fix-broken-icon-reference.diff

New:

  digikam-3.0.0.no-kdcraw.version-check.patch
  digikam-3.0.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.d6PE1p/_old  2013-02-12 16:36:46.0 +0100
+++ /var/tmp/diff_new_pack.d6PE1p/_new  2013-02-12 16:36:46.0 +0100
@@ -17,13 +17,13 @@
 
 
 Name:   digikam
-Version:2.9.95
+Version:3.0.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
-Source0:
ftp://ftp.kde.org/pub/kde/unstable/digikam/digikam-3.0.0-rc.tar.bz2
+Source0:
ftp://ftp.kde.org/pub/kde/stable/digikam/digikam-%{version}.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
 # PATCH-FIX-OPENSUSE desktop-files.diff -- Remove Icon= entry (the icon is 
missing)
@@ -32,16 +32,16 @@
 Patch2: non-executable-script.patch
 # PATCH-FIX-OPENSUSE remove-gplv2-only.patch idoen...@suse.de bnc#711963 -- 
Remove GPLv2 only files from the build system
 Patch3: remove-gplv2-only.patch
-# PATCH-FIX-OPENSUSE fix-broken-icon-reference.diff adr...@suse.de -- CHECK ON 
NEXT VERSION UPDATE: reference to missing icon
-Patch4: fix-broken-icon-reference.diff
 # PATCH-FIX-OPENSUSE digikam_no_build_vkontakte.diff tittiatc...@gmail.com -- 
Don't build libvkontakte (use external one)
 Patch5: digikam_no_build_vkontakte.diff
-# PATCH-FIX-UPSTREAM digikam-3.0.0-rc.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
-Patch6: digikam-3.0.0-rc.no-kdcraw.version-check.patch
+# PATCH-FIX-UPSTREAM digikam-3.0.0.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
+Patch6: digikam-3.0.0.no-kdcraw.version-check.patch
 BuildRequires:  ImageMagick
+BuildRequires:  bison
 BuildRequires:  boost-devel
 BuildRequires:  doxygen
 BuildRequires:  fdupes
+BuildRequires:  flex
 BuildRequires:  gstreamer-0_10-plugins-qt-devel
 BuildRequires:  lensfun-devel
 BuildRequires:  libexpat-devel
@@ -151,6 +151,8 @@
 License:GPL-2.0+
 Group:  Productivity/Graphics/Other
 Recommends: ImageMagick
+Recommends: bison
+Recommends: flex
 Recommends: enblend-enfuse
 Recommends: hugin
 Recommends: kipi-plugins-lang = %{version}
@@ -238,14 +240,13 @@
 %lang_package -n libkgeomap
 
 %prep
-%setup -q -n digikam-3.0.0-rc
+%setup -q
 %patch0
 pushd extra/kipi-plugins
 %patch1
 popd
 %patch2
 %patch3
-%patch4
 %patch5
 %patch6 -p1
 

++ digikam-3.0.0-rc.no-kdcraw.version-check.patch - 
digikam-3.0.0.no-kdcraw.version-check.patch ++
--- 
/work/SRC/openSUSE:Factory/digikam/digikam-3.0.0-rc.no-kdcraw.version-check.patch
   2013-01-07 10:59:15.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-3.0.0.no-kdcraw.version-check.patch
 2013-02-12 16:36:37.0 +0100
@@ -1,6 +1,6 @@
-diff -U3 -dHrN digikam-3.0.0-rc/core/CMakeLists.txt 
digikam-3.0.0-rc.no-kdcraw.version-check//core/CMakeLists.txt
 digikam-3.0.0-rc/core/CMakeLists.txt   2012-12-24 00:33:16.0 
+0100
-+++ digikam-3.0.0-rc.no-kdcraw.version-check//core/CMakeLists.txt  
2013-01-02 00:56:04.959176355 +0100
+diff -U3 -dHrN 

commit digikam for openSUSE:Factory

2013-01-07 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2013-01-07 10:59:10

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-12-07 
14:08:03.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2013-01-07 
10:59:17.0 +0100
@@ -1,0 +2,34 @@
+Sat Jan  5 18:46:30 UTC 2013 - toddrme2...@gmail.com
+
+- Link rawconverter icon to the hicolor theme so it can be safely
+  used as an application icon (needed by kphotoalbum)
+
+---
+Tue Jan  1 20:57:37 UTC 2013 - nico.kru...@gmail.com
+
+- Update to 3.0.0-rc:
+  digikam:
+- General: Add new Noise Estimation feature to Wavelets Noise
+   Reduction tools.
+- BatchQueueManager: Add Color Effect tool support.
+- BatchQueueManager: Multicore CPU support to process items
+ in parallel.
+- BatchQueueManager: Add Raw Demosaicing settings in Queue
+ Qettings.
+- BatchQueueManager: Add new behavior options about RAW file
+ loading (extract preview or perform
+ demosaicing).
+- BatchQueueManager: Add the capability to assign more than
+ one time a tool to a queue.
+- BatchQueueManager: Add the capability to put target file
+ processed from queue to source album.
+- BatchQueueManager: Add concept of Workflow dedicated to save
+ and restore between sessions Queue Settings
+ including Assigned Batch Tools list.
+- 18 fixed bugs.
+  kipi-plugins:
+- 2 fixed bugs.
+- Added patch (digikam-3.0.0-rc.no-kdcraw.version-check.patch) to 
+  temporarily disabled libkdcraw version check (does not work any more)
+
+---

Old:

  digikam-3.0.0-beta3.tar.bz2

New:

  digikam-3.0.0-rc.no-kdcraw.version-check.patch
  digikam-3.0.0-rc.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.frtwfP/_old  2013-01-07 10:59:19.0 +0100
+++ /var/tmp/diff_new_pack.frtwfP/_new  2013-01-07 10:59:19.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package digikam
 #
-# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,13 +17,13 @@
 
 
 Name:   digikam
-Version:2.9.83
+Version:2.9.95
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
-Source0:
ftp://ftp.kde.org/pub/kde/unstable/digikam/digikam-3.0.0-beta3.tar.bz2
+Source0:
ftp://ftp.kde.org/pub/kde/unstable/digikam/digikam-3.0.0-rc.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
 # PATCH-FIX-OPENSUSE desktop-files.diff -- Remove Icon= entry (the icon is 
missing)
@@ -36,6 +36,8 @@
 Patch4: fix-broken-icon-reference.diff
 # PATCH-FIX-OPENSUSE digikam_no_build_vkontakte.diff tittiatc...@gmail.com -- 
Don't build libvkontakte (use external one)
 Patch5: digikam_no_build_vkontakte.diff
+# PATCH-FIX-UPSTREAM digikam-3.0.0-rc.no-kdcraw.version-check.patch -- version 
check for libkdcraw currently broken
+Patch6: digikam-3.0.0-rc.no-kdcraw.version-check.patch
 BuildRequires:  ImageMagick
 BuildRequires:  boost-devel
 BuildRequires:  doxygen
@@ -236,7 +238,7 @@
 %lang_package -n libkgeomap
 
 %prep
-%setup -q -n digikam-3.0.0-beta3
+%setup -q -n digikam-3.0.0-rc
 %patch0
 pushd extra/kipi-plugins
 %patch1
@@ -245,6 +247,7 @@
 %patch3
 %patch4
 %patch5
+%patch6 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
@@ -259,13 +262,9 @@
 
 %build
 %if !0%{?kde_updatedapps}
-%cmake_kde4 -d build -- -DENABLE_INTERNALMYSQL=FALSE
+%cmake_kde4 -d build -- -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=FALSE 
-DENABLE_INTERNALMYSQL=FALSE
 %else
-%if 0%{?suse_version}  1210
-%cmake_kde4 -d build -- -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS:BOOL=1 
-DENABLE_INTERNALMYSQL=FALSE
-%else
-%cmake_kde4 -d build -- -DENABLE_INTERNALMYSQL=FALSE
-%endif

commit digikam for openSUSE:Factory

2012-12-07 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-12-07 14:07:59

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-11-12 
11:40:47.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-12-07 
14:08:03.0 +0100
@@ -1,0 +2,42 @@
+Tue Nov 27 11:51:07 UTC 2012 - nico.kru...@gmail.com
+
+- enabled compilation of the VideoSlideshow kipi plugin
+
+---
+Mon Nov 26 16:41:20 UTC 2012 - nico.kru...@gmail.com
+
+- Update to 3.0.0-beta3:
+  digikam:
+- Libkipi:
+  * All kipi-plugins actions can be pluged to tools bar.
+  * Usability improvements in plugins configuration dialog.
+- Libkdcraw:
+  * Update internal Libraw version 0.15.0 Alpha2 to support
+new RAW cameras :
+  * Adobe DNG: Fast Load and lossy-compressed DNG
+(LightRoom 4.x)
+  * Canon: G1 X, SX220 HS, EOS 5D Mark III, EOS 650D,
+   EOS 1D-X
+  * Casio: EX-Z8
+  * Fujifilm : X-S1, HS30EXR, X1-Pro
+  * Nikon: D4, D3200, D800, D800E
+  * Olympus  : E-M5
+  * Panasonic: DMC-GF5
+  * Samsung  : NX20, NX210, NX100, NX-1000
+  * Sigma: SD15,SD1, SD1 Merill, DP1, DP1S, DP1X, DP2,
+   DP2S, DP2X
+  * Sony : NEX-F3, SLT-A37, SLT-A57, DSC-RX100
+- ImportUI: Port icon-view to Qt4 model/View.
+- ImportUI: Labels and Tags pre-assignation.
+- ImportUI: Pipelined post download operations.
+- ImportUI: Preview items during downloading.
+- Metadata: Video files metadata support
+(through Exiv2 project).
+- 54 fixed bugs.
+  kipi-plugins:
+- General: New tool to export Collection to DLNA device.
+- General: New tool to make video slideshow.
+- General: Port all plugins to KDE XML-GUI framework.
+- 18 fixed bugs.
+
+---

Old:

  digikam-2.9.0.tar.bz2

New:

  digikam-3.0.0-beta3.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.veFDSd/_old  2012-12-07 14:08:05.0 +0100
+++ /var/tmp/diff_new_pack.veFDSd/_new  2012-12-07 14:08:05.0 +0100
@@ -17,13 +17,13 @@
 
 
 Name:   digikam
-Version:2.9.0
+Version:2.9.83
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
 Url:http://www.digikam.org/
-Source0:
ftp://ftp.kde.org/pub/kde/stable/digikam/digikam-%{version}.tar.bz2
+Source0:
ftp://ftp.kde.org/pub/kde/unstable/digikam/digikam-3.0.0-beta3.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
 # PATCH-FIX-OPENSUSE desktop-files.diff -- Remove Icon= entry (the icon is 
missing)
@@ -40,6 +40,7 @@
 BuildRequires:  boost-devel
 BuildRequires:  doxygen
 BuildRequires:  fdupes
+BuildRequires:  gstreamer-0_10-plugins-qt-devel
 BuildRequires:  lensfun-devel
 BuildRequires:  libexpat-devel
 BuildRequires:  libgphoto2-devel
@@ -65,6 +66,7 @@
 BuildRequires:  libksane-devel
 BuildRequires:  libkvkontakte-devel
 %endif
+BuildRequires:  libMagick++-devel
 BuildRequires:  liblcms-devel
 BuildRequires:  liblqr-devel
 %if 0%{?suse_version}  1220
@@ -234,7 +236,7 @@
 %lang_package -n libkgeomap
 
 %prep
-%setup -q
+%setup -q -n digikam-3.0.0-beta3
 %patch0
 pushd extra/kipi-plugins
 %patch1
@@ -278,6 +280,9 @@
 
 # Not needed
 rm -f %{buildroot}%{_kde4_libdir}/libPropertyBrowser.a
+rm -f %{buildroot}%{_kde4_libdir}/libHUpnp.a
+rm -f %{buildroot}%{_kde4_libdir}/libHUpnpAv.a
+rm -f %{buildroot}%{_kde4_libdir}/libQtSoap.a
 
 # Fix wrong-icon-size rpmlint warning
 mogrify -extent 64x64 -background transparent -gravity center 
%{buildroot}%{_kde4_iconsdir}/hicolor/64x64/actions/metadataedit.png
@@ -296,6 +301,12 @@
 
 %find_lang libkgeomap libkgeomap.lang
 
+%if 0%{?kde_updatedapps}  0%{?suse_version}  1210
+%find_lang libkipi libkipi.lang
+%else
+rm -f %{buildroot}/usr/share/locale/*/LC_MESSAGES/libkipi.mo
+%endif
+
 %find_lang kipiplugins kipiplugin.lang
 
 for l in acquireimages advancedslideshow batchprocessimages calendar 
dngconverter expoblending facebook flashexport flickrexport galleryexport 
gpssync htmlexport imageviewer ipodexport jpeglossless kioexportimport 
metadataedit picasawebexport piwigoexport printimages rawconverter 
removeredeyes sendimages shwup smug timeadjust;
@@ 

commit digikam for openSUSE:Factory

2012-11-12 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-11-12 11:40:46

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-10-29 
20:02:19.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-11-12 
11:40:47.0 +0100
@@ -1,0 +2,6 @@
+Sat Nov 10 17:58:38 UTC 2012 - asterios.dra...@gmail.com
+
+- Added libpgf-devel as build requirement (to be used instead of the bundled
+  copy).
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.Kfu024/_old  2012-11-12 11:40:50.0 +0100
+++ /var/tmp/diff_new_pack.Kfu024/_new  2012-11-12 11:40:50.0 +0100
@@ -67,6 +67,9 @@
 %endif
 BuildRequires:  liblcms-devel
 BuildRequires:  liblqr-devel
+%if 0%{?suse_version}  1220
+BuildRequires:  libpgf-devel
+%endif
 BuildRequires:  libqca2-devel
 BuildRequires:  libqjson-devel
 BuildRequires:  libsoprano-devel
@@ -266,9 +269,7 @@
 %{__make} -j1 VERBOSE=1
 
 %install
-cd build
-%kde4_makeinstall
-cd ..
+%kde4_makeinstall -C build
 
 # Not needed, the package doesn't actually provide any shared libraries
 rm -f %{buildroot}%{_kde4_libdir}/libdigikamcore.so

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2012-10-29 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-10-29 20:02:17

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-10-04 
19:36:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-10-29 
20:02:19.0 +0100
@@ -1,0 +2,6 @@
+Sun Oct 28 14:14:36 UTC 2012 - asterios.dra...@gmail.com
+
+- Added glu as build requirement (needed since it was split from Mesa in
+  Factory).
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.2Viks3/_old  2012-10-29 20:02:24.0 +0100
+++ /var/tmp/diff_new_pack.2Viks3/_new  2012-10-29 20:02:24.0 +0100
@@ -81,6 +81,7 @@
 %else
 BuildRequires:  gdk-pixbuf-devel
 %endif
+BuildRequires:  pkgconfig(glu)
 %if 0%{?suse_version}
 BuildRequires:  update-desktop-files
 %endif

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2012-10-04 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-10-04 19:36:40

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-09-26 
16:17:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-10-04 
19:36:42.0 +0200
@@ -1,0 +2,5 @@
+Wed Oct  3 21:01:03 UTC 2012 - raba...@opensuse.org
+
+- add BuildRequires:  libusb-compat-devel to fix gphoto2 deps
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.BQbxQC/_old  2012-10-04 19:36:44.0 +0200
+++ /var/tmp/diff_new_pack.BQbxQC/_new  2012-10-04 19:36:44.0 +0200
@@ -71,6 +71,7 @@
 BuildRequires:  libqjson-devel
 BuildRequires:  libsoprano-devel
 BuildRequires:  libusb-1_0-devel
+BuildRequires:  libusb-compat-devel
 BuildRequires:  marble-devel
 BuildRequires:  opencv-devel
 BuildRequires:  shared-desktop-ontologies-devel

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2012-09-12 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-09-13 00:01:52

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-08-28 
20:44:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-09-13 
00:01:56.0 +0200
@@ -1,0 +2,10 @@
+Tue Sep 11 03:32:40 UTC 2012 - m...@suse.com
+
+- Update to 2.9.0:
+  digikam:
+- CameraGUI : libgphoto 2.5.0 API support.
+- 9 fixed bugs.
+  kipi-plugins:
+- 2 fixed bugs.
+
+---

Old:

  digikam-2.8.0.tar.bz2

New:

  digikam-2.9.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.wqRzKP/_old  2012-09-13 00:02:00.0 +0200
+++ /var/tmp/diff_new_pack.wqRzKP/_new  2012-09-13 00:02:00.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:2.8.0
+Version:2.9.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+

++ digikam-2.8.0.tar.bz2 - digikam-2.9.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-2.8.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-2.9.0.tar.bz2 differ: char 11, 
line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2012-08-28 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-08-28 20:44:46

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-07-13 
11:30:53.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-08-28 
20:44:50.0 +0200
@@ -1,0 +2,11 @@
+Fri Aug 10 08:17:05 UTC 2012 - nico.kru...@gmail.com
+
+- Update to 2.8.0:
+  digikam:
+   - CameraGUI: Add option to execute script during items to download from 
camera.
+   - 22 fixed bugs.
+  kipi-plugins:
+   - MediaWiki: GUI improvmenets and new features to export items.
+   - 6 fixed bugs.
+
+---

Old:

  digikam-2.7.0.tar.bz2

New:

  digikam-2.8.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.3aMugO/_old  2012-08-28 20:44:53.0 +0200
+++ /var/tmp/diff_new_pack.3aMugO/_new  2012-08-28 20:44:53.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:2.7.0
+Version:2.8.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+

++ digikam-2.7.0.tar.bz2 - digikam-2.8.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-2.7.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-2.8.0.tar.bz2 differ: char 11, 
line 1

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2012-06-19 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-06-19 21:40:44

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-06-11 
07:30:52.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-06-19 
21:40:47.0 +0200
@@ -1,0 +2,5 @@
+Tue Jun 19 12:39:49 UTC 2012 - co...@suse.com
+
+- disable parallel build, it's too memory hungy for OBS workers
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.P69gn7/_old  2012-06-19 21:40:50.0 +0200
+++ /var/tmp/diff_new_pack.P69gn7/_new  2012-06-19 21:40:50.0 +0200
@@ -260,7 +260,8 @@
 %cmake_kde4 -d build -- -DENABLE_INTERNALMYSQL=FALSE
 %endif
 %endif
-%make_jobs
+# there are files in there that are so heavy to the compiler, that one is 
enough
+%{__make} -j1 VERBOSE=1
 
 %install
 cd build

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2012-06-10 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-06-11 07:30:49

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-05-03 
10:55:20.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-06-11 
07:30:52.0 +0200
@@ -1,0 +2,51 @@
+Thu Jun  7 21:47:46 UTC 2012 - asterios.dra...@gmail.com
+
+- Update to 2.6.0:
+  digikam:
+   - General: Add support of Little CMS version 2.
+   - General: New tool to run all maintenance process in background.
+   - General: Lprof 3rd party library have been removed from core
+ implementation.
+   - General: Thumbs/Preview for read-only files (as RAW) can be rotated
+ through a flag in thumbnails database.
+   - General: Add a Progress Manager as into Kontact to drive process running
+ in parallele.
+   - General: KIPI JPEGLossLess tool is now disabled in digiKam. A dedicated
+ solution is now implemented in digiKam core to rotate/flip image using
+ multithreading, parallelization, and image versioning.
+   - KipiInterface: Handle progress events from kipi tools through digiKam
+ Progress Manager.
+   - ImageEditor: Template Superimpose feature have been moved to
+ PhotoLayoutEditor kipi-plugin.
+   - ImageEditor: New film color negative inverter filter.
+   - 118 fixed bugs.
+  kipi-plugins:
+   - RAWConverter: Add progress management support, and parallelization of
+ tasks using ThreadWeaver.
+   - DNGConverter: Add progress management support, and parallelization of
+ tasks using ThreadWeaver.
+   - RedEyesRemoval: Add progress management support, and parallelization of
+ tasks using ThreadWeaver.
+   - TimeAdjust: Add items listview support, progress management support,
+ multithreading, and parallelization of tasks using ThreadWeaver.
+   - SendImages: Dialog Layout improvements, progress management support, and
+ parallelization of tasks using ThreadWeaver.
+   - PhotoLayoutEditor: Add SuperImpose Template support to compose fun frame,
+ post-card, etc... template file use SVG format.
+   - Panorama: Bugfix for binary detection on OSes different than Linux (fixes
+ the same issue with expoblending). Bugfix for the back button of the
+ assistant. First steps towards a cropping for target panorama.
+ Parallelization of tasks using ThreadWeaver.
+   - General: New tool to export items to ImageShack web service
+ (http://imageshack.us).
+   - General: New tool to export items to MediaWiki web service
+ (http://www.mediawiki.org).
+   - General: New tool to export items to Imgur web service (http://imgur.com).
+   - 49 fixed bugs.
+- Removed the following patches (fixed upstream):
+  - use_correct_libkipi.patch
+  - digikam-boost-1.48.patch
+  - digikam-gcc47.patch
+- Rebased fix-broken-icon-reference.diff patch to apply cleanly.
+
+---

Old:

  digikam-2.5.0.tar.bz2
  digikam-boost-1.48.patch
  digikam-gcc47.patch
  use_correct_libkipi.patch

New:

  digikam-2.6.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.DBwmtE/_old  2012-06-11 07:30:56.0 +0200
+++ /var/tmp/diff_new_pack.DBwmtE/_new  2012-06-11 07:30:56.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   digikam
-Version:2.5.0
+Version:2.6.0
 Release:0
 Summary:A KDE Photo Manager
 License:GPL-2.0+
@@ -26,22 +26,16 @@
 Source0:
http://sourceforge.net/projects/digikam/files/digikam/%{version}/digikam-%{version}.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
-# PATCH-FIX-UPSTREAM use_correct_libkipi.patch -- Only compile these classes 
when the latest libkipi (KDE 4.9) is used
-Patch1: use_correct_libkipi.patch
 # PATCH-FIX-OPENSUSE desktop-files.diff -- Remove Icon= entry (the icon is 
missing)
-Patch2: desktop-files.diff
+Patch1: desktop-files.diff
 # PATCH-FIX-OPENSUSE non-executable-script.patch asterios.dra...@gmail.com -- 
Fix rpmlint warning non-executable-script
-Patch3: non-executable-script.patch
+Patch2: non-executable-script.patch
 # PATCH-FIX-OPENSUSE remove-gplv2-only.patch idoen...@suse.de bnc#711963 -- 
Remove GPLv2 only files from the build system
-Patch4: remove-gplv2-only.patch
+Patch3: remove-gplv2-only.patch
 # PATCH-FIX-OPENSUSE fix-broken-icon-reference.diff adr...@suse.de -- 

commit digikam for openSUSE:Factory

2012-05-03 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-05-03 10:55:18

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-04-02 
19:54:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-05-03 
10:55:20.0 +0200
@@ -1,0 +2,5 @@
+Tue Apr 24 18:27:43 UTC 2012 - dims...@opensuse.org
+
+- Add digikam-gcc47.patch: Fix build with gcc 4.7.
+
+---

New:

  digikam-gcc47.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.o77n0t/_old  2012-05-03 10:55:22.0 +0200
+++ /var/tmp/diff_new_pack.o77n0t/_new  2012-05-03 10:55:22.0 +0200
@@ -40,6 +40,8 @@
 Patch6: digikam_no_build_vkontakte.diff
 # PATCH-FIX-UPSTREAM digikam-boost-1.48.patch idoen...@suse.de -- Compile with 
Boost 1.48+, upstream commit d18ea6da2d3e2359f411
 Patch7: digikam-boost-1.48.patch
+# PATCH-FIX-UPSTREAM digikam-gcc47.patch dims...@opensuse.org -- Fix build 
with gcc 4.7
+Patch8: digikam-gcc47.patch
 BuildRequires:  ImageMagick
 BuildRequires:  boost-devel
 BuildRequires:  doxygen
@@ -261,6 +263,7 @@
 %patch5
 %patch6 -p0
 %patch7 -p1
+%patch8 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ digikam-gcc47.patch ++
Index: digikam-2.5.0/core/utilities/cameragui/devices/gpcamera.cpp
===
--- digikam-2.5.0.orig/core/utilities/cameragui/devices/gpcamera.cpp
+++ digikam-2.5.0/core/utilities/cameragui/devices/gpcamera.cpp
@@ -34,6 +34,7 @@ extern C
 
 // C++ includes
 
+#include unistd.h
 #include cstdio
 #include iostream
 
Index: digikam-2.5.0/extra/kipi-plugins/printimages/wizard/wizard.cpp
===
--- digikam-2.5.0.orig/extra/kipi-plugins/printimages/wizard/wizard.cpp
+++ digikam-2.5.0/extra/kipi-plugins/printimages/wizard/wizard.cpp
@@ -88,7 +88,7 @@ public:
 WizardPage ( KAssistantDialog* dialog, const QString title )
 : QWidget ( dialog )
 {
-setupUi ( this );
+this-setupUi ( this );
 layout()-setMargin ( 0 );
 mPage = dialog-addPage ( this, title );
 }
Index: digikam-2.5.0/extra/kipi-plugins/htmlexport/wizard.cpp
===
--- digikam-2.5.0.orig/extra/kipi-plugins/htmlexport/wizard.cpp
+++ digikam-2.5.0/extra/kipi-plugins/htmlexport/wizard.cpp
@@ -78,7 +78,7 @@ class WizardPage : public QWidget, publi
 public:
 WizardPage(KAssistantDialog* dialog, const QString title)
 : QWidget(dialog) {
-setupUi(this);
+this-setupUi(this);
 layout()-setMargin(0);
 mPage = dialog-addPage(this, title);
 }
Index: digikam-2.5.0/core/libs/database/imagehistory/imagehistorygraph_boost.h
===
--- digikam-2.5.0.orig/core/libs/database/imagehistory/imagehistorygraph_boost.h
+++ digikam-2.5.0/core/libs/database/imagehistory/imagehistorygraph_boost.h
@@ -1362,7 +1362,7 @@ protected:
 template typename VertexType, typename GraphType
 void discover_vertex(VertexType u, const GraphType) const
 {
-record(u);
+this-record(u);
 }
 };
 
@@ -1373,7 +1373,7 @@ protected:
 template typename VertexType, typename GraphType
 void discover_vertex(VertexType u, const GraphType) const
 {
-record(u);
+this-record(u);
 }
 };
 
Index: digikam-2.5.0/core/digikam/album/albummanager.h
===
--- digikam-2.5.0.orig/core/digikam/album/albummanager.h
+++ digikam-2.5.0/core/digikam/album/albummanager.h
@@ -831,7 +831,7 @@ public:
 {
 foreach(T* t, list)
 {
-append(AlbumPointerT(t));
+this-append(AlbumPointerT(t));
 }
 return *this;
 }
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2012-04-02 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-04-02 19:53:35

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2012-02-08 
15:37:39.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-04-02 
19:54:22.0 +0200
@@ -1,0 +2,5 @@
+Mon Apr  2 08:48:32 UTC 2012 - idon...@suse.com
+
+- Add digikam-boost-1.48.patch to fix build with new boost 
+
+---

New:

  digikam-boost-1.48.patch



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.aKNPOY/_old  2012-04-02 19:54:29.0 +0200
+++ /var/tmp/diff_new_pack.aKNPOY/_new  2012-04-02 19:54:29.0 +0200
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   digikam
 Version:2.5.0
 Release:0
@@ -37,6 +38,8 @@
 Patch5: fix-broken-icon-reference.diff
 # PATCH-FIX-OPENSUSE digikam_no_build_vkontakte.diff tittiatc...@gmail.com -- 
Don't build libvkontakte (use external one)
 Patch6: digikam_no_build_vkontakte.diff
+# PATCH-FIX-UPSTREAM digikam-boost-1.48.patch idoen...@suse.de -- Compile with 
Boost 1.48+, upstream commit d18ea6da2d3e2359f411
+Patch7: digikam-boost-1.48.patch
 BuildRequires:  ImageMagick
 BuildRequires:  boost-devel
 BuildRequires:  doxygen
@@ -51,20 +54,20 @@
 BuildRequires:  libkdepimlibs4-devel
 %if 0%{?kde_updatedapps}
 %if 0%{?suse_version} == 1140
-BuildRequires:  sane-backends-devel
 BuildRequires:  libexiv2-devel = 0.21
+BuildRequires:  sane-backends-devel
 %endif
 %if 0%{?suse_version}  1140
-BuildRequires:  libkvkontakte-devel
 BuildRequires:  libkexiv2-devel
 BuildRequires:  libkipi-devel
 BuildRequires:  libksane-devel
+BuildRequires:  libkvkontakte-devel
 %endif
 %else
-BuildRequires:  libkvkontakte-devel
 BuildRequires:  libkexiv2-devel
 BuildRequires:  libkipi-devel
 BuildRequires:  libksane-devel
+BuildRequires:  libkvkontakte-devel
 %endif
 BuildRequires:  liblcms-devel
 BuildRequires:  liblqr-devel
@@ -86,8 +89,8 @@
 %endif
 Requires:   kipi-plugins = 2.5.0
 %requires_ge libkipi8
-Requires:   libqt4-sql-sqlite
 Requires:   libqt4-sql-mysql
+Requires:   libqt4-sql-sqlite
 Recommends: %{name}-doc
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -257,6 +260,7 @@
 %patch4
 %patch5
 %patch6 -p0
+%patch7 -p1
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')

++ digikam-boost-1.48.patch ++
commit d18ea6da2d3e2359f4113e83c3fd40c18a29ddab
Author: Gilles Caulier caulier.gil...@gmail.com
Date:   Fri Jan 6 11:23:48 2012 +0100

Apply patch #67483 from Jeremiah Willcock to compile fine digiKam boost 
graph interface with libboost 1.48
BUGS: 287772
CCBUGS: 26

diff --git a/core/libs/database/imagehistory/imagehistorygraph_boost.h 
b/core/libs/database/imagehistory/imagehistorygraph_boost.h
index 4017c4f..76c764a 100644
--- a/core/libs/database/imagehistory/imagehistorygraph_boost.h
+++ b/core/libs/database/imagehistory/imagehistorygraph_boost.h
@@ -1198,7 +1198,7 @@ protected:
 {
 boost::dag_shortest_paths(graph, v,
   // we provide a constant weight of 1
-  
weight_map(boost::ref_property_mapedge_t,int(weight)).
+  
weight_map(boost::ref_property_maptypename 
boost::graph_traitsGraphType::edge_descriptor,int(weight)).
   // Store distance and predecessors 
in QMaps, wrapped to serve as property maps
   
distance_map(VertexIntMapAdaptor(distances)).
   
predecessor_map(VertexVertexMapAdaptor(predecessors))
@@ -1218,7 +1218,7 @@ protected:
 {
 boost::dag_shortest_paths(graph, v,
   // we provide a constant weight of 1
-  
weight_map(boost::ref_property_mapedge_t,int(weight)).
+  
weight_map(boost::ref_property_maptypename 
boost::graph_traitsGraphType::edge_descriptor,int(weight)).
   // Invert the default compare 
method: With greater, we get the longest path
   

commit digikam for openSUSE:Factory

2012-02-08 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2012-02-08 15:37:30

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2011-12-14 
14:33:13.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2012-02-08 
15:37:39.0 +0100
@@ -1,0 +2,20 @@
+Fri Feb  3 09:56:22 UTC 2012 - tittiatc...@gmail.com
+
+- Correct the license of the Documentation subpackage to the 
+  GFDL-1.X license. 
+- Correct spec-file to autodetect the translations for the 
+  additional libraries
+
+---
+Fri Jan 13 09:50:17 UTC 2012 - tittiatc...@gmail.com
+
+- The digikam spec-file now builds all additional components 
+  (kipi-plugins, libmediawiki, libkface and libkgeomap)
+
+---
+Wed Jan  4 08:56:34 UTC 2012 - tittiatc...@gmail.com
+
+- Update to 2.5.0
+  * a bug-fix release, including a total of 101 fixed bugs.
+
+---

Old:

  digikam-2.4.1.tar.bz2
  digikam-external-libs.patch

New:

  desktop-files.diff
  digikam-2.5.0.tar.bz2
  digikam_no_build_vkontakte.diff
  fix-broken-icon-reference.diff
  non-executable-script.patch
  remove-gplv2-only.patch
  use_correct_libkipi.patch



Other differences:
--
++ digikam.spec ++
 651 lines (skipped)
 between /work/SRC/openSUSE:Factory/digikam/digikam.spec
 and /work/SRC/openSUSE:Factory/.digikam.new/digikam.spec

++ desktop-files.diff ++
--- acquireimages/scangui.desktop.sav
+++ acquireimages/scangui.desktop
@@ -54,7 +54,6 @@ GenericName[uk]=Отримання зо�
 GenericName[x-test]=xxAcquire Imagesxx
 GenericName[zh_CN]=图像捕获
 GenericName[zh_TW]=擷取影像
-Icon=scanner
 Name=AcquireImages
 Name[ast]=AcquireImages
 Name[bg]=Сканиране на снимки
++ digikam-2.4.1.tar.bz2 - digikam-2.5.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-2.4.1.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-2.5.0.tar.bz2 differ: char 11, 
line 1

++ digikam_no_build_vkontakte.diff ++
--- CMakeLists.txt  2012-01-03 01:42:09.0 +0100
+++ CMakeLists.txt  2012-01-05 13:49:28.920827859 +0100
@@ -70,7 +70,6 @@
 ${CMAKE_SOURCE_DIR}/extra/libkgeomap/cmake/modules
 ${CMAKE_SOURCE_DIR}/extra/libmediawiki/cmake/modules
 ${CMAKE_SOURCE_DIR}/extra/libkface/cmake/modules
-${CMAKE_SOURCE_DIR}/extra/libkvkontakte/cmake/modules
 ${CMAKE_SOURCE_DIR}/cmake/modules
 ${CMAKE_MODULE_PATH}
 )
@@ -85,7 +84,6 @@
 SET(KFACE_LOCAL_DIR extra/libkface)
 SET(KGEOMAP_LOCAL_DIR extra/libkgeomap)
 SET(MEDIAWIKI_LOCAL_DIR extra/libmediawiki)
-SET(LIBKVKONTAKTE_LOCAL_DIR extra/libkvkontakte)
 
 ADD_SUBDIRECTORY(extra)
 ADD_SUBDIRECTORY(core)
--- extra/CMakeLists.txt2012-01-03 01:31:52.0 +0100
+++ extra/CMakeLists.txt2012-01-05 13:49:38.665828606 +0100
@@ -33,7 +33,6 @@
 ENDIF()
 
 MACRO_OPTIONAL_ADD_SUBDIRECTORY(libmediawiki)
-MACRO_OPTIONAL_ADD_SUBDIRECTORY(libkvkontakte)
 
 ADD_SUBDIRECTORY(libkgeomap)
 ADD_SUBDIRECTORY(libkface)
++ fix-broken-icon-reference.diff ++
--- ./extra/kipi-plugins/panorama/plugin/panoramagui.desktop.orig   
2011-10-04 09:34:29.576552045 +0200
+++ ./extra/kipi-plugins/panorama/plugin/panoramagui.desktop2011-10-04 
09:35:16.838301132 +0200
@@ -57,7 +57,6 @@
 Name[x-test]=xxPanoramaxx
 Name[zh_TW]=Panorama
 StartupNotify=true
-Icon=layer-visible-on
 Terminal=false
 Type=Application
 X-DBUS-ServiceName=
++ non-executable-script.patch ++
--- extra/kipi-plugins/expoblending/plugin/expoblending.desktop.orig
2011-07-28 02:27:35.0 +0300
+++ extra/kipi-plugins/expoblending/plugin/expoblending.desktop 2011-08-08 
18:45:45.33070 +0300
@@ -1,4 +1,3 @@
-#!/usr/bin/env xdg-open
 [Desktop Entry]
 Categories=Qt;KDE;Graphics;
 Comment=A tool to blend bracketed images
--- extra/kipi-plugins/panorama/plugin/panoramagui.desktop.orig 2011-11-07 
09:50:25.0 +0200
+++ extra/kipi-plugins/panorama/plugin/panoramagui.desktop  2011-11-12 
22:14:39.80913 +0200
@@ -1,4 +1,3 @@
-#!/usr/bin/env xdg-open
 [Desktop Entry]
 Categories=Qt;KDE;Graphics;
 Comment=A tool to assemble images as a panorama
++ remove-gplv2-only.patch ++
Index: extra/kipi-plugins/gpssync/CMakeLists.txt
===
--- extra/kipi-plugins/gpssync/CMakeLists.txt.orig
+++ extra/kipi-plugins/gpssync/CMakeLists.txt
@@ -33,10 +33,8 @@ 

commit digikam for openSUSE:Factory

2011-12-14 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2011-12-14 14:33:09

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2011-11-16 
17:17:51.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2011-12-14 
14:33:13.0 +0100
@@ -1,0 +2,13 @@
+Mon Dec 12 09:32:52 UTC 2011 - co...@suse.com
+
+- update to 2.4.1
+  * a bug-fixes release, including a total of 25 fixed bugs. 
+  * histogram view from right sidebar have been improved for better
+ image analyse.
+
+---
+Mon Dec 12 08:59:11 UTC 2011 - co...@suse.com
+
+- require libkipi8 version build against, it changes ABI too often
+
+---

Old:

  digikam-2.3.0.tar.bz2

New:

  digikam-2.4.1.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.BJCebQ/_old  2011-12-14 14:33:17.0 +0100
+++ /var/tmp/diff_new_pack.BJCebQ/_new  2011-12-14 14:33:17.0 +0100
@@ -16,15 +16,14 @@
 #
 
 
-
 Name:   digikam
-Version:2.3.0
-Release:1
-License:GPL-2.0+
+Version:2.4.1
+Release:0
 Summary:A KDE Photo Manager
-Url:http://www.digikam.org/
+License:GPL-2.0+
 Group:  Productivity/Graphics/Viewers
-Source0:
http://sourceforge.net/projects/digikam/files/%{name}/%{version}/%{name}-%{version}.tar.bz2
+Url:http://www.digikam.org/
+Source0:
http://sourceforge.net/projects/digikam/files/digikam/%{version}/digikam-%{version}.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
 # PATCH-FIX-OPENSUSE digikam-external-libs.patch -- Compile with external libs
@@ -51,6 +50,7 @@
 BuildRequires:  update-desktop-files
 %endif
 Requires:   kipi-plugins = 2.1.0
+%requires_ge libkipi8
 Requires:   libqt4-sql-sqlite
 Requires:   libqt4-sql-mysql
 Recommends: %{name}-doc
@@ -104,9 +104,6 @@
 rm -f %{buildroot}%{_kde4_libdir}/libdigikamcore.so
 rm -f %{buildroot}%{_kde4_libdir}/libdigikamdatabase.so
 
-# Workaround kde#286034
-mv %{buildroot}%{_kde4_iconsdir}/oxygen %{buildroot}%{_kde4_iconsdir}/hicolor
-
 %if 0%{?suse_version}
 %suse_update_desktop_file -r %{name} Qt KDE Graphics Photography
 %suse_update_desktop_file -G Photo Editor -r showfoto Qt KDE Graphics 
Photography

++ digikam-2.3.0.tar.bz2 - digikam-2.4.1.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-2.3.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-2.4.1.tar.bz2 differ: char 11, 
line 1

++ digikam-buildtime.patch ++
--- /var/tmp/diff_new_pack.BJCebQ/_old  2011-12-14 14:33:17.0 +0100
+++ /var/tmp/diff_new_pack.BJCebQ/_new  2011-12-14 14:33:17.0 +0100
@@ -1,6 +1,8 @@
 core/libs/3rdparty/cimg/CImg.h.orig
-+++ core/libs/3rdparty/cimg/CImg.h
-@@ -5669,7 +5669,7 @@ namespace cimg_library {
+Index: core/libs/3rdparty/cimg/CImg.h
+===
+--- core/libs/3rdparty/cimg/CImg.h.orig2011-12-04 22:40:13.0 
+0100
 core/libs/3rdparty/cimg/CImg.h 2011-12-12 10:45:04.129281874 +0100
+@@ -5673,7 +5673,7 @@ namespace cimg_library {
  if (usage) {
cimg_std::fprintf(cimg_stdout,\n 
%s%s%s,cimg::t_red,cimg::basename(argv[0]),cimg::t_normal);
cimg_std::fprintf(cimg_stdout, : %s,usage);
@@ -9,7 +11,7 @@
  }
  if (defaut) cimg_std::fprintf(cimg_stdout,%s\n,defaut);
}
-@@ -5755,9 +5755,9 @@ namespace cimg_library {
+@@ -5759,9 +5759,9 @@ namespace cimg_library {
  **/
  inline void info() {
char tmp[1024] = { 0 };

++ digikam-external-libs.patch ++
--- /var/tmp/diff_new_pack.BJCebQ/_old  2011-12-14 14:33:17.0 +0100
+++ /var/tmp/diff_new_pack.BJCebQ/_new  2011-12-14 14:33:17.0 +0100
@@ -1,17 +1,17 @@
 Index: CMakeLists.txt
 ===
 CMakeLists.txt.orig
-+++ CMakeLists.txt
-@@ -74,12 +74,6 @@ IF(${DIGIKAMSC_USE_PRIVATE_KDEGRAPHICS})
+--- CMakeLists.txt.orig2011-12-04 22:41:31.0 +0100
 CMakeLists.txt 2011-12-12 10:45:50.716070335 +0100
+@@ -82,12 +82,6 @@ IF(${DIGIKAMSC_USE_PRIVATE_KDEGRAPHICS})
  SET(KSANE_LOCAL_DIR extra/libksane)
  ENDIF()
  
 -SET(KFACE_LOCAL_DIR extra/libkface)
 -SET(KGEOMAP_LOCAL_DIR extra/libkgeomap)
 

commit digikam for openSUSE:Factory

2011-11-16 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2011-11-16 17:17:41

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2011-11-08 
17:27:19.0 +0100
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2011-11-16 
17:17:51.0 +0100
@@ -1,0 +2,14 @@
+Tue Nov 15 18:36:36 UTC 2011 - ctri...@opensuse.org
+
+- Require libqt4-sql-sqlite and libqt4-sql-mysql (bnc#730111)
+
+---
+Sat Nov 12 23:08:30 UTC 2011 - asterios.dra...@gmail.com
+
+- Spec file updates:
+  * Removed %kde4_pimlibs_requires (fix for rpmlint warning
+suse-kde4-excessive-dependency).
+  * Don't install the libkgeomap translations (they belong to libkgeomap
+package).
+
+---



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.lNNLKq/_old  2011-11-16 17:17:55.0 +0100
+++ /var/tmp/diff_new_pack.lNNLKq/_new  2011-11-16 17:17:55.0 +0100
@@ -51,11 +51,12 @@
 BuildRequires:  update-desktop-files
 %endif
 Requires:   kipi-plugins = 2.1.0
+Requires:   libqt4-sql-sqlite
+Requires:   libqt4-sql-mysql
 Recommends: %{name}-doc
 Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %kde4_runtime_requires
-%kde4_pimlibs_requires
 
 %description
 digiKam is a simple digital photo management application for KDE, which
@@ -76,10 +77,13 @@
 %lang_package
 %prep
 %setup -q
-rm po/*/kipi*
 %patch0
 %patch1
 
+# Include only digikam translations
+find po -name kipiplugin_*.po | xargs rm
+find po -name libkgeomap.po | xargs rm
+
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
 sed -i s/__DATE__/\$FAKE_BUILDDATE\/ core/digikam/utils/version.h.cmake
@@ -93,6 +97,7 @@
 %kde4_makeinstall
 cd ..
 
+# Remove kipi-plugins docs (included in kipi-plugins package)
 rm -rf %{buildroot}%{_kde4_htmldir}/en/kipi-plugins
 
 # Not needed, the package doesn't actually provide any shared libraries
@@ -100,15 +105,17 @@
 rm -f %{buildroot}%{_kde4_libdir}/libdigikamdatabase.so
 
 # Workaround kde#286034
-mv %{buildroot}/usr/share/icons/oxygen %{buildroot}/usr/share/icons/hicolor
+mv %{buildroot}%{_kde4_iconsdir}/oxygen %{buildroot}%{_kde4_iconsdir}/hicolor
 
 %if 0%{?suse_version}
 %suse_update_desktop_file -r %{name} Qt KDE Graphics Photography
 %suse_update_desktop_file -G Photo Editor -r showfoto Qt KDE Graphics 
Photography
 %endif
 
-%find_lang %{name} --all-name
+%find_lang %{name}
+
 %fdupes -s %{buildroot}
+
 %kde_post_install
 
 %post   -p /sbin/ldconfig

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2011-11-08 Thread h_root
Hello community,

here is the log from the commit of package digikam for openSUSE:Factory checked 
in at 2011-11-08 17:25:52

Comparing /work/SRC/openSUSE:Factory/digikam (Old)
 and  /work/SRC/openSUSE:Factory/.digikam.new (New)


Package is digikam, Maintainer is kde-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/digikam/digikam.changes  2011-10-16 
12:43:52.0 +0200
+++ /work/SRC/openSUSE:Factory/.digikam.new/digikam.changes 2011-11-08 
17:27:19.0 +0100
@@ -1,0 +2,11 @@
+Tue Nov  8 11:03:03 UTC 2011 - idon...@suse.com
+
+- Workaround kde#286034 
+
+---
+Mon Nov  7 10:46:01 UTC 2011 - adr...@suse.de
+
+- update to version 2.3.0
+  * Bugfix release, please see included NEWS file for fixed bugs.
+
+---

Old:

  add_mimetype_bnc629393.diff
  digikam-2.2.0.tar.bz2

New:

  digikam-2.3.0.tar.bz2



Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.PSozJl/_old  2011-11-08 17:27:25.0 +0100
+++ /var/tmp/diff_new_pack.PSozJl/_new  2011-11-08 17:27:25.0 +0100
@@ -15,8 +15,10 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
+
 Name:   digikam
-Version:2.2.0
+Version:2.3.0
 Release:1
 License:GPL-2.0+
 Summary:A KDE Photo Manager
@@ -25,10 +27,8 @@
 Source0:
http://sourceforge.net/projects/digikam/files/%{name}/%{version}/%{name}-%{version}.tar.bz2
 # PATCH-FIX-OPENSUSE digikam-buildtime.patch -- Remove build time references 
so build-compare can do its work
 Patch0: digikam-buildtime.patch
-# PATCH-FIX-UPSTREAM add_mimetype_bnc629393.diff bnc#629393 kde#261627 
ctri...@gmx.net -- Add MimeTypes to desktop file for better integration in GNOME
-Patch1: add_mimetype_bnc629393.diff
 # PATCH-FIX-OPENSUSE digikam-external-libs.patch -- Compile with external libs
-Patch2: digikam-external-libs.patch
+Patch1: digikam-external-libs.patch
 BuildRequires:  boost-devel
 BuildRequires:  doxygen
 BuildRequires:  fdupes
@@ -79,7 +79,6 @@
 rm po/*/kipi*
 %patch0
 %patch1
-%patch2
 
 # Remove build time references so build-compare can do its work
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
@@ -100,6 +99,9 @@
 rm -f %{buildroot}%{_kde4_libdir}/libdigikamcore.so
 rm -f %{buildroot}%{_kde4_libdir}/libdigikamdatabase.so
 
+# Workaround kde#286034
+mv %{buildroot}/usr/share/icons/oxygen %{buildroot}/usr/share/icons/hicolor
+
 %if 0%{?suse_version}
 %suse_update_desktop_file -r %{name} Qt KDE Graphics Photography
 %suse_update_desktop_file -G Photo Editor -r showfoto Qt KDE Graphics 
Photography
@@ -110,6 +112,7 @@
 %kde_post_install
 
 %post   -p /sbin/ldconfig
+
 %postun -p /sbin/ldconfig
 
 %files

++ digikam-2.2.0.tar.bz2 - digikam-2.3.0.tar.bz2 ++
/work/SRC/openSUSE:Factory/digikam/digikam-2.2.0.tar.bz2 
/work/SRC/openSUSE:Factory/.digikam.new/digikam-2.3.0.tar.bz2 differ: char 11, 
line 1

++ digikam-external-libs.patch ++
--- /var/tmp/diff_new_pack.PSozJl/_old  2011-11-08 17:27:26.0 +0100
+++ /var/tmp/diff_new_pack.PSozJl/_new  2011-11-08 17:27:26.0 +0100
@@ -1,14 +1,16 @@
 CMakeLists.txt.orig2011-09-07 14:10:20.0 +0200
-+++ CMakeLists.txt 2011-09-09 15:30:52.649954215 +0200
-@@ -79,12 +79,7 @@
+Index: CMakeLists.txt
+===
+--- CMakeLists.txt.orig
 CMakeLists.txt
+@@ -74,12 +74,6 @@ IF(${DIGIKAMSC_USE_PRIVATE_KDEGRAPHICS})
  SET(KSANE_LOCAL_DIR extra/libksane)
  ENDIF()
  
 -SET(KFACE_LOCAL_DIR extra/libkface)
 -SET(KGEOMAP_LOCAL_DIR extra/libkgeomap)
 -SET(MEDIAWIKI_LOCAL_DIR extra/libmediawiki)
--SET(LIBKVKONTAKTE_LOCAL_DIR extra/libkvkontakte)
-
+-SET(KVKONTAKTE_LOCAL_DIR extra/libkvkontakte)
+-
 -ADD_SUBDIRECTORY(extra)
  ADD_SUBDIRECTORY(core)
  ADD_SUBDIRECTORY(doc)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit digikam for openSUSE:Factory

2011-10-16 Thread h_root

Hello community,

here is the log from the commit of package digikam for openSUSE:Factory
checked in at Sun Oct 16 12:42:42 CEST 2011.




--- openSUSE:Factory/digikam/digikam.changes2011-10-04 22:14:35.0 
+0200
+++ /mounts/work_src_done/STABLE/digikam/digikam.changes2011-10-14 
12:32:36.0 +0200
@@ -1,0 +2,6 @@
+Fri Oct 14 12:30:54 UTC 2011 - toddrme2...@gmail.com
+
+- Removed check for obsolete openSUSE version (fix for RPMLINT warning)
+- Cleaned up spec file formatting
+
+---

calling whatdependson for head-i586




Other differences:
--
++ digikam.spec ++
--- /var/tmp/diff_new_pack.eNjK4L/_old  2011-10-16 12:42:38.0 +0200
+++ /var/tmp/diff_new_pack.eNjK4L/_new  2011-10-16 12:42:38.0 +0200
@@ -15,8 +15,6 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   digikam
 Version:2.2.0
 Release:1
@@ -53,8 +51,8 @@
 BuildRequires:  update-desktop-files
 %endif
 Requires:   kipi-plugins = 2.1.0
-Recommends: %{name}-lang
 Recommends: %{name}-doc
+Recommends: %{name}-lang
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %kde4_runtime_requires
 %kde4_pimlibs_requires
@@ -70,9 +68,7 @@
 %package doc
 Summary:Documentation of Digikam
 Group:  Documentation/HTML
-%if %suse_version  1120
 BuildArch:  noarch
-%endif
 
 %description doc
 This package contains the documentation for digikam
@@ -110,13 +106,10 @@
 %endif
 
 %find_lang %{name} --all-name
-
 %fdupes -s %{buildroot}
-
 %kde_post_install
 
 %post -p /sbin/ldconfig
-
 %postun -p /sbin/ldconfig
 
 %files
@@ -124,27 +117,25 @@
 %doc core/AUTHORS core/COPYING core/COPYING.DOC core/COPYING.LIB
 %doc core/ChangeLog core/NEWS core/README core/TODO
 %doc core/TODO.FACE core/TODO.MYSQLPORT
+%{_kde4_applicationsdir}/digikam.desktop
+%{_kde4_applicationsdir}/showfoto.desktop
+%{_kde4_appsdir}/digikam/
+%{_kde4_appsdir}/showfoto/
+%{_kde4_appsdir}/solid
 %{_kde4_bindir}/cleanup_digikamdb
 %{_kde4_bindir}/digikam
 %{_kde4_bindir}/digitaglinktree
 %{_kde4_bindir}/showfoto
+%{_kde4_iconsdir}/hicolor/*/apps/digikam.*
+%{_kde4_iconsdir}/hicolor/*/apps/showfoto.*
+%{_kde4_libdir}/libdigikamcore.so.*
+%{_kde4_libdir}/libdigikamdatabase.so.*
 %{_kde4_modulesdir}/digikam*.so
 %{_kde4_modulesdir}/kio_digikamalbums.so
 %{_kde4_modulesdir}/kio_digikamdates.so
 %{_kde4_modulesdir}/kio_digikammapimages.so
 %{_kde4_modulesdir}/kio_digikamsearch.so
 %{_kde4_modulesdir}/kio_digikamtags.so
-%{_kde4_libdir}/libdigikamcore.so.*
-%{_kde4_libdir}/libdigikamdatabase.so.*
-%{_kde4_applicationsdir}/digikam.desktop
-%{_kde4_applicationsdir}/showfoto.desktop
-%{_kde4_iconsdir}/hicolor/*/apps/digikam.*
-%{_kde4_iconsdir}/hicolor/*/apps/showfoto.*
-%{_kde4_appsdir}/digikam/
-%{_kde4_appsdir}/showfoto/
-%dir %{_kde4_appsdir}/solid
-%dir %{_kde4_appsdir}/solid/actions
-%{_kde4_appsdir}/solid/actions/digikam-opencamera.desktop
 %{_kde4_servicesdir}/digikamalbums.protocol
 %{_kde4_servicesdir}/digikamdates.protocol
 %{_kde4_servicesdir}/digikamimageplugin_*.desktop
@@ -158,8 +149,8 @@
 %defattr(-,root,root,-)
 %doc %{_kde4_htmldir}/en/digikam/
 %doc %{_kde4_htmldir}/en/showfoto/
-%doc %{_mandir}/man1/digitaglinktree.1%{ext_man}
 %doc %{_mandir}/man1/cleanup_digikamdb.1%{ext_man}
+%doc %{_mandir}/man1/digitaglinktree.1%{ext_man}
 
 %files lang -f %{name}.lang
 %defattr(-,root,root,-)

++ digikam-external-libs.patch ++
--- /var/tmp/diff_new_pack.eNjK4L/_old  2011-10-16 12:42:39.0 +0200
+++ /var/tmp/diff_new_pack.eNjK4L/_new  2011-10-16 12:42:39.0 +0200
@@ -1,13 +1,13 @@
 --- CMakeLists.txt.orig2011-09-07 14:10:20.0 +0200
 +++ CMakeLists.txt 2011-09-09 15:30:52.649954215 +0200
-@@ -79,12 +79,8 @@
+@@ -79,12 +79,7 @@
  SET(KSANE_LOCAL_DIR extra/libksane)
  ENDIF()
  
 -SET(KFACE_LOCAL_DIR extra/libkface)
 -SET(KGEOMAP_LOCAL_DIR extra/libkgeomap)
 -SET(MEDIAWIKI_LOCAL_DIR extra/libmediawiki)
- SET(LIBKVKONTAKTE_LOCAL_DIR extra/libkvkontakte)
+-SET(LIBKVKONTAKTE_LOCAL_DIR extra/libkvkontakte)
 
 -ADD_SUBDIRECTORY(extra)
  ADD_SUBDIRECTORY(core)

continue with q...



Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



  1   2   >