commit epiphany-extensions for openSUSE:Factory

2013-02-11 Thread h_root
Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory checked in at 2013-02-11 10:59:37

Comparing /work/SRC/openSUSE:Factory/epiphany-extensions (Old)
 and  /work/SRC/openSUSE:Factory/.epiphany-extensions.new (New)


Package is epiphany-extensions, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/epiphany-extensions/epiphany-extensions.changes  
2012-10-11 10:42:06.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.epiphany-extensions.new/epiphany-extensions.changes 
2013-02-11 10:59:39.0 +0100
@@ -1,0 +2,6 @@
+Sun Feb 10 11:06:15 UTC 2013 - dims...@opensuse.org
+
+- Stop moving sr@Latn to sr@latin: our update-translation package
+  takes care of having the right languages.
+
+---



Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.S7NCcb/_old  2013-02-11 10:59:41.0 +0100
+++ /var/tmp/diff_new_pack.S7NCcb/_new  2013-02-11 10:59:41.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package epiphany-extensions
 #
-# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -64,8 +64,6 @@
 
 %install
 %makeinstall
-# Change sr@Latn to sr@latin
-mv %{buildroot}%{_datadir}/locale/sr@Latn 
%{buildroot}%{_datadir}/locale/sr@latin
 find %{buildroot} -type f -name *.la -delete -print
 %find_lang %{name} %{?no_lang_C}
 %find_lang %{name}-%{api_version} %{?no_lang_C} %{name}.lang


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit epiphany-extensions for openSUSE:Factory

2012-10-11 Thread h_root
Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory checked in at 2012-10-11 10:39:12

Comparing /work/SRC/openSUSE:Factory/epiphany-extensions (Old)
 and  /work/SRC/openSUSE:Factory/.epiphany-extensions.new (New)


Package is epiphany-extensions, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/epiphany-extensions/epiphany-extensions.changes  
2012-10-04 18:38:24.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.epiphany-extensions.new/epiphany-extensions.changes 
2012-10-11 10:42:06.0 +0200
@@ -1,0 +2,10 @@
+Fri Oct  5 08:27:59 UTC 2012 - dims...@opensuse.org
+
+- Update to version 3.6.0:
+  + Just a maintainance release to go with Epiphany 3.6.0.
+  + Updated translations.
+- Drop epiphany-extensions-bump35.patch: fixed upstream.
+- Drop gnome-common BuildRequires and call to gnome-autogen.sh, as
+  we don' carry an patches touching the buildsystem anymore.
+
+---

Old:

  epiphany-extensions-3.4.0.tar.xz
  epiphany-extensions-bump35.patch

New:

  epiphany-extensions-3.6.0.tar.xz



Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.zqIeyS/_old  2012-10-11 10:42:07.0 +0200
+++ /var/tmp/diff_new_pack.zqIeyS/_new  2012-10-11 10:42:07.0 +0200
@@ -17,15 +17,13 @@
 
 
 Name:   epiphany-extensions
-Version:3.4.0
+Version:3.6.0
 Release:0
 Summary:Extensions Collection for Epiphany
 License:GPL-2.0+ and LGPL-2.1+
 Group:  Productivity/Networking/Web/Browsers
 Url:http://www.gnome.org/projects/epiphany/
-Source: 
http://download.gnome.org/sources/epiphany-extensions/3.4/%{name}-%{version}.tar.xz
-# PATCH-FIX-UPSTREAM epiphany-extensions-bump35.patch dims...@opensuse.org -- 
Bump version and API support to 3.5. Taken from git.
-Patch0: epiphany-extensions-bump35.patch
+Source: 
http://download.gnome.org/sources/epiphany-extensions/3.6/%{name}-%{version}.tar.xz
 # PATCH-FIX-UPSTREAM epiphany-extensions-epi35api.patch bgo#681944 
dims...@opensuse.org -- Follow epiphany 3.5's API changes.
 Patch1: epiphany-extensions-epi35api.patch
 %define api_version %(pkg-config --variable extensionsdir 
%{_libdir}/pkgconfig/epiphany-*.pc | sed 
s,^%{_libdir}/epiphany/,,;s,/extensions$,,)
@@ -33,8 +31,6 @@
 BuildRequires:  epiphany-devel = 3.6
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-# Needed for patch0
-BuildRequires:  gnome-common
 BuildRequires:  gnome-doc-utils-devel
 BuildRequires:  intltool
 BuildRequires:  libwebkitgtk3-devel
@@ -55,13 +51,10 @@
 %lang_package
 %prep
 %setup -q
-%patch0 -p1
 %patch1 -p1
 translation-update-upstream
 
 %build
-# Needed for patch0
-NOCONFIGURE=1 gnome-autogen.sh
 %configure \
 --disable-static \
 --enable-compile-warnings=yes \

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit epiphany-extensions for openSUSE:Factory

2012-10-04 Thread h_root
Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory checked in at 2012-10-04 18:38:21

Comparing /work/SRC/openSUSE:Factory/epiphany-extensions (Old)
 and  /work/SRC/openSUSE:Factory/.epiphany-extensions.new (New)


Package is epiphany-extensions, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/epiphany-extensions/epiphany-extensions.changes  
2012-07-24 22:42:45.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.epiphany-extensions.new/epiphany-extensions.changes 
2012-10-04 18:38:24.0 +0200
@@ -1,0 +2,25 @@
+Sat Sep 29 21:15:06 UTC 2012 - dims...@opensuse.org
+
+- Disable HTML5Tube (remove from the list of enabled plugins): Due
+  to changes on the YouTube page, the plugin no longer manages to
+  parse for the required tags and never triggers. As YouTube is
+  actibely implementing HTML5 on their own, the plugin lost its
+  use over time.
+
+---
+Thu Sep 27 09:30:01 UTC 2012 - dims...@opensuse.org
+
+- Change epiphany-extensions-bump35.patch to recognize Epiphany
+  API Version 3.6 (configure check only).
+
+---
+Wed Aug 15 20:13:01 UTC 2012 - dims...@opensuse.org
+
+- Add epiphany-extensions-epi35api.patch: Adapt to epiphany 3.5's
+  API change.
+- Add epiphany-extensions-bump35.patch: Support building against
+  epiphany API version 3.5
+- Add gnome-common BuildRequires and call gnome-autogen.sh, as
+  above patch touches the build system.
+
+---

New:

  epiphany-extensions-bump35.patch
  epiphany-extensions-epi35api.patch



Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.d1M68Y/_old  2012-10-04 18:38:25.0 +0200
+++ /var/tmp/diff_new_pack.d1M68Y/_new  2012-10-04 18:38:25.0 +0200
@@ -20,16 +20,21 @@
 Version:3.4.0
 Release:0
 Summary:Extensions Collection for Epiphany
-License:GPL-2.0+ ; LGPL-2.1+
+License:GPL-2.0+ and LGPL-2.1+
 Group:  Productivity/Networking/Web/Browsers
 Url:http://www.gnome.org/projects/epiphany/
 Source: 
http://download.gnome.org/sources/epiphany-extensions/3.4/%{name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM epiphany-extensions-bump35.patch dims...@opensuse.org -- 
Bump version and API support to 3.5. Taken from git.
+Patch0: epiphany-extensions-bump35.patch
+# PATCH-FIX-UPSTREAM epiphany-extensions-epi35api.patch bgo#681944 
dims...@opensuse.org -- Follow epiphany 3.5's API changes.
+Patch1: epiphany-extensions-epi35api.patch
 %define api_version %(pkg-config --variable extensionsdir 
%{_libdir}/pkgconfig/epiphany-*.pc | sed 
s,^%{_libdir}/epiphany/,,;s,/extensions$,,)
 BuildRequires:  dbus-1-glib-devel
-BuildRequires:  epiphany
-BuildRequires:  epiphany-devel = 3.4
+BuildRequires:  epiphany-devel = 3.6
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
+# Needed for patch0
+BuildRequires:  gnome-common
 BuildRequires:  gnome-doc-utils-devel
 BuildRequires:  intltool
 BuildRequires:  libwebkitgtk3-devel
@@ -50,14 +55,18 @@
 %lang_package
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 translation-update-upstream
 
 %build
+# Needed for patch0
+NOCONFIGURE=1 gnome-autogen.sh
 %configure \
 --disable-static \
 --enable-compile-warnings=yes \
 --disable-scrollkeeper \
-
--with-extensions=actions,adblock,auto-reload,certificates,extensions-manager-ui,greasemonkey,html5tube,push-scroller,soup-fly,tab-key-tab-navigate,tab-states,rss
+
--with-extensions=actions,adblock,auto-reload,certificates,extensions-manager-ui,greasemonkey,push-scroller,soup-fly,tab-key-tab-navigate,tab-states,rss
 make %{?_smp_mflags} V=1
 
 %install


++ epiphany-extensions-bump35.patch ++
From d5bc835813617d8b3f6087784573d0526f226400 Mon Sep 17 00:00:00 2001
From: Xan Lopez x...@igalia.com
Date: Thu, 10 May 2012 17:31:29 +
Subject: Bump version to 3.5

---
diff --git a/configure.ac b/configure.ac
index 3ea6871..d7599c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@
 # 59 Temple Place, Suite 330, Boston, MA 02111-1307  USA
 
 m4_define([e_e_version_major],[3])
-m4_define([e_e_version_minor],[4])
+m4_define([e_e_version_minor],[5])
 m4_define([e_e_version_micro],[0])
 
m4_define([e_e_version],[e_e_version_major.e_e_version_minor.e_e_version_micro])
 
@@ -24,7 +24,7 @@ m4_define([e_e_branch],[trunk])
 
 AC_INIT([GNOME Web Browser 
Extensions],[e_e_version],[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany-extensions],[epiphany-extensions])
 
-EPIPHANY_API_VERSION=3.4
+EPIPHANY_API_VERSION=3.6
 
 

commit epiphany-extensions for openSUSE:Factory

2012-07-24 Thread h_root
Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory checked in at 2012-07-24 22:42:43

Comparing /work/SRC/openSUSE:Factory/epiphany-extensions (Old)
 and  /work/SRC/openSUSE:Factory/.epiphany-extensions.new (New)


Package is epiphany-extensions, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/epiphany-extensions/epiphany-extensions.changes  
2012-03-29 11:37:23.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.epiphany-extensions.new/epiphany-extensions.changes 
2012-07-24 22:42:45.0 +0200
@@ -1,0 +2,8 @@
+Mon Jul 23 20:02:35 UTC 2012 - dims...@opensuse.org
+
+- Pass --with-extensions to configure. The extensions enabled are
+  the default ones (as built without parameter) minus gestures.
+  The gestures plugin is broken after epiphany moved away from
+  regular menus. (bnc#772553, bgo#680481).
+
+---



Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.Cz7zaw/_old  2012-07-24 22:42:46.0 +0200
+++ /var/tmp/diff_new_pack.Cz7zaw/_new  2012-07-24 22:42:46.0 +0200
@@ -56,7 +56,8 @@
 %configure \
 --disable-static \
 --enable-compile-warnings=yes \
---disable-scrollkeeper
+--disable-scrollkeeper \
+
--with-extensions=actions,adblock,auto-reload,certificates,extensions-manager-ui,greasemonkey,html5tube,push-scroller,soup-fly,tab-key-tab-navigate,tab-states,rss
 make %{?_smp_mflags} V=1
 
 %install


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit epiphany-extensions for openSUSE:Factory

2012-03-29 Thread h_root
Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory checked in at 2012-03-29 11:37:21

Comparing /work/SRC/openSUSE:Factory/epiphany-extensions (Old)
 and  /work/SRC/openSUSE:Factory/.epiphany-extensions.new (New)


Package is epiphany-extensions, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/epiphany-extensions/epiphany-extensions.changes  
2012-03-02 13:47:36.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.epiphany-extensions.new/epiphany-extensions.changes 
2012-03-29 11:37:23.0 +0200
@@ -1,0 +2,8 @@
+Tue Mar 27 06:41:15 UTC 2012 - vu...@opensuse.org
+
+- Update to version 3.4.0:
+  + Build fix.
+  + Updated translations.
+- Drop epiphany-extensions-fix-help.patch: fixed upstream.
+
+---

Old:

  epiphany-extensions-3.3.90.tar.xz
  epiphany-extensions-fix-help.patch

New:

  epiphany-extensions-3.4.0.tar.xz



Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.zO9X69/_old  2012-03-29 11:37:24.0 +0200
+++ /var/tmp/diff_new_pack.zO9X69/_new  2012-03-29 11:37:24.0 +0200
@@ -17,19 +17,17 @@
 
 
 Name:   epiphany-extensions
-Version:3.3.90
+Version:3.4.0
 Release:0
 Summary:Extensions Collection for Epiphany
 License:GPL-2.0+ ; LGPL-2.1+
 Group:  Productivity/Networking/Web/Browsers
 Url:http://www.gnome.org/projects/epiphany/
-Source: 
http://download.gnome.org/sources/epiphany-extensions/3.3/%{name}-%{version}.tar.xz
-# PATCH-FIX-UPSTREAM epiphany-extensions-fix-help.patch bgo#670958 
vu...@opensuse.org -- Don't install broken symlink in help files
-Patch0: epiphany-extensions-fix-help.patch
+Source: 
http://download.gnome.org/sources/epiphany-extensions/3.4/%{name}-%{version}.tar.xz
 %define api_version %(pkg-config --variable extensionsdir 
%{_libdir}/pkgconfig/epiphany-*.pc | sed 
s,^%{_libdir}/epiphany/,,;s,/extensions$,,)
 BuildRequires:  dbus-1-glib-devel
 BuildRequires:  epiphany
-BuildRequires:  epiphany-devel = 3.2
+BuildRequires:  epiphany-devel = 3.4
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  gnome-doc-utils-devel
@@ -53,7 +51,6 @@
 %prep
 %setup -q
 translation-update-upstream
-%patch0 -p1
 
 %build
 %configure \

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit epiphany-extensions for openSUSE:Factory

2012-03-02 Thread h_root
Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory checked in at 2012-03-02 13:47:34

Comparing /work/SRC/openSUSE:Factory/epiphany-extensions (Old)
 and  /work/SRC/openSUSE:Factory/.epiphany-extensions.new (New)


Package is epiphany-extensions, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/epiphany-extensions/epiphany-extensions.changes  
2012-01-09 12:03:34.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.epiphany-extensions.new/epiphany-extensions.changes 
2012-03-02 13:47:36.0 +0100
@@ -1,0 +2,20 @@
+Tue Feb 28 10:38:11 UTC 2012 - vu...@opensuse.org
+
+- Add epiphany-extensions-fix-help.patch: fix installation of help
+  files, so we don't break the build of bundle-lang-gnome-extras.
+
+---
+Sat Feb 25 20:42:02 UTC 2012 - dims...@opensuse.org
+
+- Update to version 3.3.90:
+  + Completely new AdBlocker extension
+  + Updated all extensions for API and UI changes in Epiphany
+  + Disable certificates extension, it uses XUL and nobody had
+noticed
+  + Default to xz compression
+  + Updated translations.
+- Drop epiphany-extensions-ephy-3.3.patch: fixed upstream.
+- Remove gnome-common BuildRequires and call to gnome-autogen.sh,
+  as they were only needed for the patch above.
+
+---

Old:

  epiphany-extensions-3.2.0.tar.bz2
  epiphany-extensions-ephy-3.3.patch

New:

  epiphany-extensions-3.3.90.tar.xz
  epiphany-extensions-fix-help.patch



Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.iXmcu4/_old  2012-03-02 13:47:38.0 +0100
+++ /var/tmp/diff_new_pack.iXmcu4/_new  2012-03-02 13:47:38.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package epiphany-extensions
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,24 +15,23 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   epiphany-extensions
-Version:3.2.0
+Version:3.3.90
 Release:0
 Summary:Extensions Collection for Epiphany
 License:GPL-2.0+ ; LGPL-2.1+
 Group:  Productivity/Networking/Web/Browsers
 Url:http://www.gnome.org/projects/epiphany/
-Source: 
http://download.gnome.org/sources/epiphany-extensions/3.2/%{name}-%{version}.tar.bz2
-# PATCH-FIX-UPSTREAM epiphany-extensions-ephy-3.3.patch vu...@opensuse.org -- 
Build against ephy 3.3.x, taken from git
-Patch0: epiphany-extensions-ephy-3.3.patch
+Source: 
http://download.gnome.org/sources/epiphany-extensions/3.3/%{name}-%{version}.tar.xz
+# PATCH-FIX-UPSTREAM epiphany-extensions-fix-help.patch bgo#670958 
vu...@opensuse.org -- Don't install broken symlink in help files
+Patch0: epiphany-extensions-fix-help.patch
 %define api_version %(pkg-config --variable extensionsdir 
%{_libdir}/pkgconfig/epiphany-*.pc | sed 
s,^%{_libdir}/epiphany/,,;s,/extensions$,,)
 BuildRequires:  dbus-1-glib-devel
 BuildRequires:  epiphany
 BuildRequires:  epiphany-devel = 3.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-# needed for patch0
-BuildRequires:  gnome-common
 BuildRequires:  gnome-doc-utils-devel
 BuildRequires:  intltool
 BuildRequires:  libwebkitgtk3-devel
@@ -57,8 +56,6 @@
 %patch0 -p1
 
 %build
-# needed for patch0
-NOCONFIGURE=1 gnome-autogen.sh
 %configure \
 --disable-static \
 --enable-compile-warnings=yes \
@@ -91,7 +88,7 @@
 %dir %{_datadir}/omf/%{name}/
 %doc %{_datadir}/omf/%{name}/%{name}-C.omf
 %{_datadir}/epiphany-extensions/
-%{_datadir}/epiphany/icons/hicolor/*/status/*.*
+%{_datadir}/epiphany/icons/
 %{_datadir}/glib-2.0/schemas/org.gnome.epiphanyextensions.gschema.xml
 %{_libdir}/epiphany/%{api_version}/extensions/*.ephy-extension
 %{_libdir}/epiphany/%{api_version}/extensions/*.so

++ epiphany-extensions-fix-help.patch ++
commit 326209a2dc3a7aea0f5ef2cfc9c7ecd3055e8674
Author: Vincent Untz vu...@gnome.org
Date:   Tue Feb 28 11:35:28 2012 +0100

help: Stop referencing figures/epi-ext-adblocker.png file

It got removed with the move to the new adblocker extension.

https://bugzilla.gnome.org/show_bug.cgi?id=670958

Index: epiphany-extensions-3.3.90/help/Makefile.am
===
--- epiphany-extensions-3.3.90.orig/help/Makefile.am
+++ epiphany-extensions-3.3.90/help/Makefile.am
@@ -6,7 +6,6 @@ 

commit epiphany-extensions for openSUSE:Factory

2012-01-09 Thread h_root
Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory checked in at 2012-01-09 12:03:30

Comparing /work/SRC/openSUSE:Factory/epiphany-extensions (Old)
 and  /work/SRC/openSUSE:Factory/.epiphany-extensions.new (New)


Package is epiphany-extensions, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/epiphany-extensions/epiphany-extensions.changes  
2011-10-13 12:18:36.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.epiphany-extensions.new/epiphany-extensions.changes 
2012-01-09 12:03:34.0 +0100
@@ -1,0 +2,8 @@
+Wed Dec 21 13:20:49 UTC 2011 - vu...@opensuse.org
+
+- Add epiphany-extensions-ephy-3.3.patch: build against epiphany
+  3.3.x, taken from git.
+- Add gnome-common BuildRequires and call to gnome-autogen.sh,
+  needed for the above patch.
+
+---

New:

  epiphany-extensions-ephy-3.3.patch



Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.1jati3/_old  2012-01-09 12:03:35.0 +0100
+++ /var/tmp/diff_new_pack.1jati3/_new  2012-01-09 12:03:35.0 +0100
@@ -15,22 +15,24 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-
 Name:   epiphany-extensions
 Version:3.2.0
-Release:1
-License:GPL-2.0+ ; LGPL-2.1+
+Release:0
 Summary:Extensions Collection for Epiphany
-Url:http://www.gnome.org/projects/epiphany/
+License:GPL-2.0+ ; LGPL-2.1+
 Group:  Productivity/Networking/Web/Browsers
+Url:http://www.gnome.org/projects/epiphany/
 Source: 
http://download.gnome.org/sources/epiphany-extensions/3.2/%{name}-%{version}.tar.bz2
+# PATCH-FIX-UPSTREAM epiphany-extensions-ephy-3.3.patch vu...@opensuse.org -- 
Build against ephy 3.3.x, taken from git
+Patch0: epiphany-extensions-ephy-3.3.patch
 %define api_version %(pkg-config --variable extensionsdir 
%{_libdir}/pkgconfig/epiphany-*.pc | sed 
s,^%{_libdir}/epiphany/,,;s,/extensions$,,)
 BuildRequires:  dbus-1-glib-devel
 BuildRequires:  epiphany
 BuildRequires:  epiphany-devel = 3.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
+# needed for patch0
+BuildRequires:  gnome-common
 BuildRequires:  gnome-doc-utils-devel
 BuildRequires:  intltool
 BuildRequires:  libwebkitgtk3-devel
@@ -52,8 +54,11 @@
 %prep
 %setup -q
 translation-update-upstream
+%patch0 -p1
 
 %build
+# needed for patch0
+NOCONFIGURE=1 gnome-autogen.sh
 %configure \
 --disable-static \
 --enable-compile-warnings=yes \

++ epiphany-extensions-ephy-3.3.patch ++
From 81eb69151fa94eb9d6babc0b1ee36ea004df2f0b Mon Sep 17 00:00:00 2001
From: Diego Escalante Urrelo descala...@igalia.com
Date: Thu, 15 Dec 2011 09:07:40 +
Subject: configure: use Epiphany 3.3 API

---
diff --git a/configure.ac b/configure.ac
index d764e94..009ba4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,7 @@ m4_define([e_e_branch],[trunk])
 
 AC_INIT([GNOME Web Browser 
Extensions],[e_e_version],[http://bugzilla.gnome.org/enter_bug.cgi?product=epiphany-extensions],[epiphany-extensions])
 
-EPIPHANY_API_VERSION=3.2
+EPIPHANY_API_VERSION=3.3
 
 EPIPHANY_EXTENSIONS_MAJOR=e_e_version_major.e_e_version_minor
 AC_SUBST(EPIPHANY_EXTENSIONS_MAJOR)
--
cgit v0.9.0.2
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit epiphany-extensions for openSUSE:Factory

2011-10-13 Thread h_root

Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory
checked in at Thu Oct 13 12:18:36 CEST 2011.




--- openSUSE:Factory/epiphany-extensions/epiphany-extensions.changes
2011-10-06 16:01:54.0 +0200
+++ epiphany-extensions/epiphany-extensions.changes 2011-10-11 
08:46:40.0 +0200
@@ -1,0 +2,10 @@
+Sat Oct  8 22:04:05 CEST 2011 - zai...@opensuse.org
+
+- Update to version 3.2.0:
+  + Update soup-fly to not use deprecated GtkHBox and GtkVBox.
+  + Prevent a crash in the adblock extension.
+  + Updated translations.
+- Drop epiphany-extensions-ephy-3.2.patch and
+  epiphany-extensions-gtk-box.patch: fixed upstream.
+
+---

calling whatdependson for head-i586


Old:

  epiphany-extensions-3.0.0.tar.bz2
  epiphany-extensions-ephy-3.2.patch
  epiphany-extensions-gtk-box.patch

New:

  epiphany-extensions-3.2.0.tar.bz2



Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.3HgueA/_old  2011-10-13 12:18:32.0 +0200
+++ /var/tmp/diff_new_pack.3HgueA/_new  2011-10-13 12:18:32.0 +0200
@@ -18,17 +18,13 @@
 
 
 Name:   epiphany-extensions
-Version:3.0.0
-Release:2
+Version:3.2.0
+Release:1
 License:GPLv2+ ; LGPLv2.1+
 Summary:Extensions Collection for Epiphany
 Url:http://www.gnome.org/projects/epiphany/
 Group:  Productivity/Networking/Web/Browsers
-Source: 
ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/2.20/%{name}-%{version}.tar.bz2
-# PATCH-FIX-UPSTREAMM epiphany-extensions-gtk-box.patch bgo#654138 
vu...@opensuse.org -- Do not use deprecated api
-Patch0: epiphany-extensions-gtk-box.patch
-# PATCH-FIX-UPSTREAM epiphany-extensions-ephy-3.2.patch vu...@opensuse.org -- 
Build with epiphany 3.2; don't pach configure.ac since next version will get 
fixed anyway
-Patch1: epiphany-extensions-ephy-3.2.patch
+Source: 
http://download.gnome.org/sources/epiphany-extensions/3.2/%{name}-%{version}.tar.bz2
 %define api_version %(pkg-config --variable extensionsdir 
%{_libdir}/pkgconfig/epiphany-*.pc | sed 
s,^%{_libdir}/epiphany/,,;s,/extensions$,,)
 BuildRequires:  dbus-1-glib-devel
 BuildRequires:  epiphany
@@ -56,8 +52,6 @@
 %prep
 %setup -q
 translation-update-upstream
-%patch0 -p1
-%patch1 -p1
 
 %build
 %configure \

++ epiphany-extensions-3.0.0.tar.bz2 - epiphany-extensions-3.2.0.tar.bz2 
++
 25956 lines of diff (skipped)

continue with q...



Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit epiphany-extensions for openSUSE:Factory

2011-10-06 Thread h_root

Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory
checked in at Thu Oct 6 16:01:56 CEST 2011.




--- openSUSE:Factory/epiphany-extensions/epiphany-extensions.changes
2011-10-04 16:56:14.0 +0200
+++ epiphany-extensions/epiphany-extensions.changes 2011-10-05 
11:39:26.0 +0200
@@ -1,0 +2,6 @@
+Wed Oct  5 08:56:30 UTC 2011 - dims...@opensuse.org
+
+- Change epiphany-devel BuildRequires to = 3.2, as that's what
+  epiphany-extensions-ephy-3.2.patch introduces as dependency.
+
+---

calling whatdependson for head-i586




Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.q2ioaG/_old  2011-10-06 16:01:52.0 +0200
+++ /var/tmp/diff_new_pack.q2ioaG/_new  2011-10-06 16:01:52.0 +0200
@@ -32,7 +32,7 @@
 %define api_version %(pkg-config --variable extensionsdir 
%{_libdir}/pkgconfig/epiphany-*.pc | sed 
s,^%{_libdir}/epiphany/,,;s,/extensions$,,)
 BuildRequires:  dbus-1-glib-devel
 BuildRequires:  epiphany
-BuildRequires:  epiphany-devel = 2.29.0
+BuildRequires:  epiphany-devel = 3.2
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  gnome-doc-utils-devel

continue with q...



Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit epiphany-extensions for openSUSE:Factory

2011-07-11 Thread h_root

Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory
checked in at Mon Jul 11 12:20:50 CEST 2011.




--- GNOME/epiphany-extensions/epiphany-extensions.changes   2011-04-11 
10:22:29.0 +0200
+++ 
/mounts/work_src_done/STABLE/epiphany-extensions/epiphany-extensions.changes
2011-07-07 10:50:12.0 +0200
@@ -1,0 +2,6 @@
+Thu Jul  7 10:43:48 CEST 2011 - vu...@opensuse.org
+
+- Add epiphany-extensions-gtk-box.patch to fix build with GTK+
+  3.1.x.
+
+---

calling whatdependson for head-i586


New:

  epiphany-extensions-gtk-box.patch



Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.6pdSgV/_old  2011-07-11 12:20:30.0 +0200
+++ /var/tmp/diff_new_pack.6pdSgV/_new  2011-07-11 12:20:30.0 +0200
@@ -19,12 +19,14 @@
 
 Name:   epiphany-extensions
 Version:3.0.0
-Release:1
+Release:2
 License:GPLv2+ ; LGPLv2.1+
 Summary:Extensions Collection for Epiphany
 Url:http://www.gnome.org/projects/epiphany/
 Group:  Productivity/Networking/Web/Browsers
 Source: 
ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/2.20/%{name}-%{version}.tar.bz2
+# PATCH-FIX-UPSTREAMM epiphany-extensions-gtk-box.patch bgo#654138 
vu...@opensuse.org -- Do not use deprecated api
+Patch0: epiphany-extensions-gtk-box.patch
 %define api_version %(pkg-config --variable extensionsdir 
%{_libdir}/pkgconfig/epiphany-*.pc | sed 
s,^%{_libdir}/epiphany/,,;s,/extensions$,,)
 BuildRequires:  dbus-1-glib-devel
 BuildRequires:  epiphany
@@ -52,6 +54,7 @@
 %prep
 %setup -q
 translation-update-upstream
+%patch0 -p1
 
 %build
 %configure \

++ epiphany-extensions-gtk-box.patch ++
Index: epiphany-extensions-3.0.0/extensions/soup-fly/soup-fly.c
===
--- epiphany-extensions-3.0.0.orig/extensions/soup-fly/soup-fly.c
+++ epiphany-extensions-3.0.0/extensions/soup-fly/soup-fly.c
@@ -216,7 +216,7 @@ construct_ui (SoupFly *logger)
   GTK_POLICY_AUTOMATIC);
   gtk_container_add (GTK_CONTAINER (scrolled), treeview);
 
-  hbox = gtk_hbox_new (FALSE, 10);
+  hbox = gtk_box_new (GTK_ORIENTATION_HORIZONTAL, 10);
   button = gtk_button_new_with_label (_(Clear finished));
   g_signal_connect (button, clicked, G_CALLBACK (clear_button_clicked_cb), 
logger);
   gtk_container_add (GTK_CONTAINER (hbox), button);
@@ -226,7 +226,7 @@ construct_ui (SoupFly *logger)
   g_signal_connect (check_button, toggled, G_CALLBACK 
(check_button_toggled_cb), logger);
   gtk_container_add (GTK_CONTAINER (hbox), check_button);
 
-  vbox = gtk_vbox_new (FALSE, 10);
+  vbox = gtk_box_new (GTK_ORIENTATION_VERTICAL, 10);
   gtk_box_pack_start (GTK_BOX (vbox), scrolled, TRUE, TRUE, 0);
   gtk_box_pack_start (GTK_BOX (vbox), hbox, FALSE, TRUE, 0);
 





Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit epiphany-extensions for openSUSE:Factory

2011-05-05 Thread h_root

Hello community,

here is the log from the commit of package epiphany-extensions for 
openSUSE:Factory
checked in at Thu May 5 15:10:32 CEST 2011.




--- GNOME/epiphany-extensions/epiphany-extensions.changes   2011-02-13 
18:35:51.0 +0100
+++ 
/mounts/work_src_done/STABLE/epiphany-extensions/epiphany-extensions.changes
2011-04-11 10:22:29.0 +0200
@@ -1,0 +2,29 @@
+Mon Apr 11 08:21:48 UTC 2011 - fcro...@novell.com
+
+- Update to version 3.0.0:
+  + Fix build with epiphany 3.0.0.
+
+---
+Thu Mar 24 09:19:20 UTC 2011 - fcro...@novell.com
+
+- Update to version 2.91.92:
+  + Update greasemonkey extension for the removal of
+EphyEmbedPersist in Epiphany.
+
+---
+Fri Feb 25 14:06:14 UTC 2011 - fcro...@novell.com
+
+- Update to version 2.91.90:
+  + Update to use GTK+ 3.0.
+  + Remove gconf dependency.
+  + Remove tab-groups extension: Epiphany does it by default now.
+  + Temporarily disabled auto-scroller, it doesn't build with
+GTK+ 3.0.
+  + Updated translations.
+- Remove gconf2-devel BuildRequires.
+- Change libwebkitgtk-devel BuildRequires to libwebkitgtk3-devel.
+- Use %glib2_gsettings_schema_* macros.
+- Stop using --with-extensions in configure: some extensions don't
+  build anymore, and the default set is good enough for us.
+
+---

calling whatdependson for head-i586


Old:

  epiphany-extensions-2.32.0.tar.bz2

New:

  epiphany-extensions-3.0.0.tar.bz2



Other differences:
--
++ epiphany-extensions.spec ++
--- /var/tmp/diff_new_pack.MvVAxs/_old  2011-05-05 15:09:46.0 +0200
+++ /var/tmp/diff_new_pack.MvVAxs/_new  2011-05-05 15:09:46.0 +0200
@@ -18,8 +18,8 @@
 
 
 Name:   epiphany-extensions
-Version:2.32.0
-Release:3
+Version:3.0.0
+Release:1
 License:GPLv2+ ; LGPLv2.1+
 Summary:Extensions Collection for Epiphany
 Url:http://www.gnome.org/projects/epiphany/
@@ -31,10 +31,9 @@
 BuildRequires:  epiphany-devel = 2.29.0
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  gconf2-devel
 BuildRequires:  gnome-doc-utils-devel
 BuildRequires:  intltool
-BuildRequires:  libwebkitgtk-devel
+BuildRequires:  libwebkitgtk3-devel
 BuildRequires:  libxml2-python
 BuildRequires:  opensp-devel
 BuildRequires:  translation-update-upstream
@@ -43,6 +42,7 @@
 Provides:   epiphany-plugins = %{version}
 Obsoletes:  epiphany-plugins  %{version}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+%glib2_gsettings_schema_requires
 
 %description
 This package contains the following Epiphany extensions: Error Viewer
@@ -56,10 +56,9 @@
 %build
 %configure \
 --disable-static \
---with-extensions=all,greasemonkey,gestures,rss \
 --enable-compile-warnings=yes \
 --disable-scrollkeeper
-%__make %{?jobs:-j%jobs}
+%__make %{?jobs:-j%jobs} V=1
 
 %install
 %makeinstall
@@ -73,6 +72,12 @@
 %clean
 rm -rf %{buildroot}
 
+%post
+%glib2_gsettings_schema_post
+
+%postun
+%glib2_gsettings_schema_postun
+
 %files
 %defattr (-, root, root)
 %doc AUTHORS COPYING COPYING.README ChangeLog NEWS README TODO
@@ -85,7 +90,9 @@
 %doc %{_datadir}/omf/%{name}/%{name}-C.omf
 %{_datadir}/epiphany-extensions/
 %{_datadir}/epiphany/icons/hicolor/*/status/*.*
-%{_libdir}/epiphany/%{api_version}/extensions
+%{_datadir}/glib-2.0/schemas/org.gnome.epiphanyextensions.gschema.xml
+%{_libdir}/epiphany/%{api_version}/extensions/*.ephy-extension
+%{_libdir}/epiphany/%{api_version}/extensions/*.so
 
 %files lang -f %{name}.lang
 

++ epiphany-extensions-2.32.0.tar.bz2 - epiphany-extensions-3.0.0.tar.bz2 
++
 31269 lines of diff (skipped)






Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org