commit gwenhywfar for openSUSE:Factory

2020-11-02 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2020-11-02 09:43:51

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.3463 (New)


Package is "gwenhywfar"

Mon Nov  2 09:43:51 2020 rev:76 rq:845297 version:5.4.1

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2020-08-20 
22:34:20.336135951 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.3463/gwenhywfar.changes  
2020-11-02 09:44:24.941841504 +0100
@@ -1,0 +2,6 @@
+Sat Oct 31 20:27:10 UTC 2020 - Johannes Engel 
+
+- Update to 5.4.1
+  + Streamline openSSL integration
+
+---

Old:

  gwenhywfar-5.4.0.tar.gz

New:

  gwenhywfar-5.4.1.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.P2zHN4/_old  2020-11-02 09:44:25.813842341 +0100
+++ /var/tmp/diff_new_pack.P2zHN4/_new  2020-11-02 09:44:25.813842341 +0100
@@ -24,13 +24,14 @@
 %define _name gwenhywfar
 %bcond_with configure
 Name:   gwenhywfar
-Version:5.4.0
+Version:5.4.1
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/Libraries
 URL:https://www.aquamaniac.de/rdm/projects/gwenhywfar
-Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{_name}-%{_version}.tar.gz
+# The github mirror tarballs are unreliable
+Source: %{_name}-%{_version}.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 # For doc graphs

++ gwenhywfar-5.4.0.tar.gz -> gwenhywfar-5.4.1.tar.gz ++
 111019 lines of diff (skipped)




commit gwenhywfar for openSUSE:Factory

2020-08-20 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2020-08-20 22:33:56

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.3399 (New)


Package is "gwenhywfar"

Thu Aug 20 22:33:56 2020 rev:75 rq:828186 version:5.4.0

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2020-04-09 
23:15:17.830239033 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.3399/gwenhywfar.changes  
2020-08-20 22:34:20.336135951 +0200
@@ -1,0 +2,14 @@
+Tue Aug 18 20:27:25 UTC 2020 - Dirk Mueller 
+
+- replace tarball with upstream one so that download_files verfication
+  passes 
+
+---
+Wed Jul 29 12:58:41 UTC 2020 - Johannes Engel 
+
+- Update to 5.4.0
+  + Introduce more generic approach to XML using libxml2
+  + Straighten Qt dependencies
+  + Bugfixes
+
+---

Old:

  gwenhywfar-5.3.0.tar.gz

New:

  gwenhywfar-5.4.0.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.WEsUzq/_old  2020-08-20 22:34:21.448136471 +0200
+++ /var/tmp/diff_new_pack.WEsUzq/_new  2020-08-20 22:34:21.448136471 +0200
@@ -18,13 +18,13 @@
 
 %define libversion 79
 %define devversion 5
-%define devrelease 5.3
+%define devrelease 5.4
 # Beta does not mean "before release" but a release that is considered as beta:
 %define _version %{version}
 %define _name gwenhywfar
 %bcond_with configure
 Name:   gwenhywfar
-Version:5.3.0
+Version:5.4.0
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0-or-later AND LGPL-2.1-or-later

++ gwenhywfar-5.3.0.tar.gz -> gwenhywfar-5.4.0.tar.gz ++
 6040 lines of diff (skipped)




commit gwenhywfar for openSUSE:Factory

2020-04-09 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2020-04-09 23:15:16

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.3248 (New)


Package is "gwenhywfar"

Thu Apr  9 23:15:16 2020 rev:74 rq:792516 version:5.3.0

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2020-03-16 
10:18:58.251602694 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.3248/gwenhywfar.changes  
2020-04-09 23:15:17.830239033 +0200
@@ -1,0 +2,5 @@
+Wed Apr  8 07:15:21 UTC 2020 - Christophe Giboudeaux 
+
+- Update to 5.3.0. No changelog.
+
+---

Old:

  gwenhywfar-5.2.0.tar.gz

New:

  gwenhywfar-5.3.0.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.00qMD4/_old  2020-04-09 23:15:18.562239456 +0200
+++ /var/tmp/diff_new_pack.00qMD4/_new  2020-04-09 23:15:18.562239456 +0200
@@ -18,13 +18,13 @@
 
 %define libversion 79
 %define devversion 5
-%define devrelease 5.2
+%define devrelease 5.3
 # Beta does not mean "before release" but a release that is considered as beta:
 %define _version %{version}
 %define _name gwenhywfar
 %bcond_with configure
 Name:   gwenhywfar
-Version:5.2.0
+Version:5.3.0
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
@@ -249,7 +249,6 @@
 %license COPYING
 %doc AUTHORS NEWS README TODO
 %dir %{_datadir}/%{_name}/
-%{_datadir}/%{_name}/ca-bundle.crt
 %{_datadir}/%{_name}/dialogs/
 %dir %{_libdir}/%{_name}
 %dir %{_libdir}/%{_name}/plugins

++ gwenhywfar-5.2.0.tar.gz -> gwenhywfar-5.3.0.tar.gz ++
 2224 lines of diff (skipped)




commit gwenhywfar for openSUSE:Factory

2020-03-16 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2020-03-16 10:18:21

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.3160 (New)


Package is "gwenhywfar"

Mon Mar 16 10:18:21 2020 rev:73 rq:785001 version:5.2.0

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2020-01-27 
00:25:11.409574810 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.3160/gwenhywfar.changes  
2020-03-16 10:18:58.251602694 +0100
@@ -1,0 +2,5 @@
+Sat Mar 14 12:38:03 UTC 2020 - Christophe Giboudeaux 
+
+- Update to 5.2.0. No changelog.
+
+---

Old:

  gwenhywfar-5.1.2.tar.gz

New:

  gwenhywfar-5.2.0.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.i678P0/_old  2020-03-16 10:19:00.431603582 +0100
+++ /var/tmp/diff_new_pack.i678P0/_new  2020-03-16 10:19:00.435603584 +0100
@@ -18,13 +18,13 @@
 
 %define libversion 79
 %define devversion 5
-%define devrelease 5.1
+%define devrelease 5.2
 # Beta does not mean "before release" but a release that is considered as beta:
 %define _version %{version}
 %define _name gwenhywfar
 %bcond_with configure
 Name:   gwenhywfar
-Version:5.1.2
+Version:5.2.0
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
@@ -47,6 +47,7 @@
 BuildRequires:  cmake(Qt5Network)
 BuildRequires:  cmake(Qt5OpenGL)
 BuildRequires:  cmake(Qt5PrintSupport)
+BuildRequires:  cmake(Qt5LinguistTools)
 BuildRequires:  cmake(Qt5Sql)
 BuildRequires:  cmake(Qt5Test)
 BuildRequires:  cmake(Qt5Widgets)
@@ -113,20 +114,20 @@
 configuration files, reading and writing of XML files, and interprocess
 communication).
 
-%package -n libgwengui-cpp0
+%package -n libgwengui-cpp%{libversion}
 Summary:C++ interface for Gwenhywfar
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/Libraries
 
-%description -n libgwengui-cpp0
+%description -n libgwengui-cpp%{libversion}
 This package contains the C++ GUI interface for Gwenhywfar.
 
-%package -n libgwengui-gtk2-0
+%package -n libgwengui-gtk2-%{libversion}
 Summary:GTK+ 2 UI backend for Gwenhywfar
 License:LGPL-2.1-or-later
 Group:  System/Libraries
 
-%description -n libgwengui-gtk2-0
+%description -n libgwengui-gtk2-%{libversion}
 Gwenhywfar is a base library used to provide OS abstraction functions
 for Linux, FreeBSD, OpenBSD, NetBSD, and Windows. It also includes
 some often needed functions (for example, for handling and parsing of
@@ -135,12 +136,12 @@
 
 This package provides the GTK+ 2 implementation of the generic UI toolkit.
 
-%package -n libgwengui-gtk3-0
+%package -n libgwengui-gtk3-%{libversion}
 Summary:GTK+ 3 UI backend for Gwenhywfar
 License:LGPL-2.1-or-later
 Group:  System/Libraries
 
-%description -n libgwengui-gtk3-0
+%description -n libgwengui-gtk3-%{libversion}
 Gwenhywfar is a base library used to provide OS abstraction functions
 for Linux, FreeBSD, OpenBSD, NetBSD, and Windows. It also includes
 some often needed functions (for example, for handling and parsing of
@@ -149,14 +150,14 @@
 
 This package provides the GTK+ 3 implementation of the generic UI toolkit.
 
-%package -n libgwengui-qt5-0
+%package -n libgwengui-qt5-%{libversion}
 Summary:Qt5 UI backend for the gwenhywfar multi-platform helper library
 License:LGPL-2.1-or-later
 Group:  System/Libraries
 Provides:   libgwengui-qt4-0 = %{version}
 Obsoletes:  libgwengui-qt4-0 < %{version}
 
-%description -n libgwengui-qt5-0
+%description -n libgwengui-qt5-%{libversion}
 Gwenhywfar is a base library used to provide OS abstraction functions
 for Linux, FreeBSD, OpenBSD, NetBSD, and Windows. It also includes
 some often needed functions (for example, for handling and parsing of
@@ -165,12 +166,12 @@
 
 This package provides the Qt5 implementation of the generic UI toolkit.
 
-%package -n libgwengui-fox16-0
+%package -n libgwengui-fox16-%{libversion}
 Summary:FOX interface for Gwenhywfar
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/Libraries
 
-%description -n libgwengui-fox16-0
+%description -n libgwengui-fox16-%{libversion}
 This package contains the interface to the FOX toolkit
 for Gwenhywfar.
 
@@ -179,10 +180,10 @@
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/C and C++
 Requires:   glibc-devel
-Requires:   libgwengui-fox16-0 >= %{version}
-Requires:   libgwengui-gtk2-0 >= %{version}
-Requires:   libgwengui-gtk3-0 >= 

commit gwenhywfar for openSUSE:Factory

2020-01-26 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2020-01-27 00:24:44

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.26092 (New)


Package is "gwenhywfar"

Mon Jan 27 00:24:44 2020 rev:72 rq:767521 version:5.1.2

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2020-01-17 
16:04:54.656426528 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.26092/gwenhywfar.changes 
2020-01-27 00:25:11.409574810 +0100
@@ -1,0 +2,9 @@
+Thu Jan 23 16:27:48 UTC 2020 - Wolfgang Bauer 
+
+- Update to 5.1.2
+  + XML: Improved format of written XML documents, simplified code.
+  + DB: Fixed a bug in GWEN_DB_WriteVarValueToBuffer()
+Was not handling "name" as full path.
+  + Fixed a bug (created files had no file access rights: #178).
+
+---

Old:

  gwenhywfar-5.1.1.tar.gz

New:

  gwenhywfar-5.1.2.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.r9a65z/_old  2020-01-27 00:25:13.101575608 +0100
+++ /var/tmp/diff_new_pack.r9a65z/_new  2020-01-27 00:25:13.105575609 +0100
@@ -24,14 +24,13 @@
 %define _name gwenhywfar
 %bcond_with configure
 Name:   gwenhywfar
-Version:5.1.1
+Version:5.1.2
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/Libraries
 URL:https://www.aquamaniac.de/rdm/projects/gwenhywfar
-Source: 
https://www.aquamaniac.de/rdm/attachments/download/233/%{name}-%{version}.tar.gz
-#Source:
https://github.com/aqbanking/gwenhywfar/archive/%%{_version}.tar.gz#/%%{_name}-%%{_version}.tar.gz
+Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{_name}-%{_version}.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 # For doc graphs

++ gwenhywfar-5.1.1.tar.gz -> gwenhywfar-5.1.2.tar.gz ++
 110549 lines of diff (skipped)




commit gwenhywfar for openSUSE:Factory

2020-01-17 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2020-01-17 16:04:33

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.26092 (New)


Package is "gwenhywfar"

Fri Jan 17 16:04:33 2020 rev:71 rq:765275 version:5.1.1

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2019-12-02 
11:37:35.826451285 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.26092/gwenhywfar.changes 
2020-01-17 16:04:54.656426528 +0100
@@ -1,0 +2,11 @@
+Fri Jan 17 13:16:08 UTC 2020 - Christophe Giboudeaux 
+
+- Temporarily change the source URL until the tag is sync'ed to the github 
mirror.
+
+---
+Wed Jan 15 19:48:53 UTC 2020 - Johannes Engel 
+
+- Update to 5.1.1
+  + Bugfixes
+
+---

Old:

  gwenhywfar-4.99.25rc9.tar.gz

New:

  gwenhywfar-5.1.1.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.LJQpXF/_old  2020-01-17 16:04:56.636427465 +0100
+++ /var/tmp/diff_new_pack.LJQpXF/_new  2020-01-17 16:04:56.640427467 +0100
@@ -16,21 +16,22 @@
 #
 
 
-%define libversion 78
+%define libversion 79
 %define devversion 5
-%define devrelease 4.99
+%define devrelease 5.1
 # Beta does not mean "before release" but a release that is considered as beta:
-%define _version %{version}rc9
+%define _version %{version}
 %define _name gwenhywfar
 %bcond_with configure
 Name:   gwenhywfar
-Version:4.99.25
+Version:5.1.1
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/Libraries
 URL:https://www.aquamaniac.de/rdm/projects/gwenhywfar
-Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{_name}-%{_version}.tar.gz
+Source: 
https://www.aquamaniac.de/rdm/attachments/download/233/%{name}-%{version}.tar.gz
+#Source:
https://github.com/aqbanking/gwenhywfar/archive/%%{_version}.tar.gz#/%%{_name}-%%{_version}.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 # For doc graphs

++ gwenhywfar-4.99.25rc9.tar.gz -> gwenhywfar-5.1.1.tar.gz ++
 122115 lines of diff (skipped)




commit gwenhywfar for openSUSE:Factory

2019-12-02 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2019-12-02 11:32:00

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.4691 (New)


Package is "gwenhywfar"

Mon Dec  2 11:32:00 2019 rev:70 rq:752574 version:4.99.25

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2019-10-24 
23:11:16.612670231 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.4691/gwenhywfar.changes  
2019-12-02 11:37:35.826451285 +0100
@@ -1,0 +2,12 @@
+Wed Nov 27 21:59:40 UTC 2019 - Bjørn Lie 
+
+- Redownload tarball via osc service, upstream source have changed.
+
+---
+Mon Nov 11 20:38:31 UTC 2019 - Nico Kruber 
+
+- Update to 4.99.25rc9
+  + fixed crashes on Windows
+  + minor tweaks
+
+---

Old:

  gwenhywfar-4.99.22rc6.tar.gz

New:

  gwenhywfar-4.99.25rc9.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.Z3X3wE/_old  2019-12-02 11:37:36.862451503 +0100
+++ /var/tmp/diff_new_pack.Z3X3wE/_new  2019-12-02 11:37:36.862451503 +0100
@@ -20,11 +20,11 @@
 %define devversion 5
 %define devrelease 4.99
 # Beta does not mean "before release" but a release that is considered as beta:
-%define _version %{version}rc6
+%define _version %{version}rc9
 %define _name gwenhywfar
 %bcond_with configure
 Name:   gwenhywfar
-Version:4.99.22
+Version:4.99.25
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0-or-later AND LGPL-2.1-or-later

++ gwenhywfar-4.99.22rc6.tar.gz -> gwenhywfar-4.99.25rc9.tar.gz ++
 7929 lines of diff (skipped)




commit gwenhywfar for openSUSE:Factory

2019-10-24 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2019-10-24 23:11:11

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.2990 (New)


Package is "gwenhywfar"

Thu Oct 24 23:11:11 2019 rev:69 rq:742635 version:4.99.22

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2019-09-05 
12:41:50.319484940 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.2990/gwenhywfar.changes  
2019-10-24 23:11:16.612670231 +0200
@@ -2 +2 @@
-Wed Aug 28 06:22:19 UTC 2019 - Johannes Engel 
+Mon Oct 14 07:42:59 UTC 2019 - Nico Kruber 
@@ -4,2 +4,18 @@
-- Downgrade to 4.20.2 to enable aqbanking 5 builds
-  * Fix crash with FinTS
+- Update to 4.99.22rc6
+
+---
+Sat Sep 28 13:36:03 UTC 2019 - Johannes Engel 
+
+- Update to 4.99.19rc3
+  + Merge with gwenhywfar package
+
+---
+Tue Sep 24 22:49:26 UTC 2019 - Nico Kruber 
+
+- Update to 4.99.17rc1
+
+---
+Sat Sep 14 18:09:48 UTC 2019 - Johannes Engel 
+
+- Update to 4.99.15
+  + Fix issue with Postbank

Old:

  gwenhywfar-4.20.2.tar.gz

New:

  gwenhywfar-4.99.22rc6.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.LDzYOK/_old  2019-10-24 23:11:17.224670945 +0200
+++ /var/tmp/diff_new_pack.LDzYOK/_new  2019-10-24 23:11:17.228670950 +0200
@@ -15,20 +15,22 @@
 # Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
-%define libversion 60
-%define devversion 4
-%define devrelease 4.20
+
+%define libversion 78
+%define devversion 5
+%define devrelease 4.99
 # Beta does not mean "before release" but a release that is considered as beta:
-%define _version %{version}
+%define _version %{version}rc6
+%define _name gwenhywfar
 %bcond_with configure
 Name:   gwenhywfar
-Version:4.20.2
+Version:4.99.22
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/Libraries
 URL:https://www.aquamaniac.de/rdm/projects/gwenhywfar
-Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{name}-%{_version}.tar.gz
+Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{_name}-%{_version}.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 # For doc graphs
@@ -177,10 +179,10 @@
 License:LGPL-2.1-or-later
 Group:  Development/Libraries/C and C++
 Requires:   glibc-devel
-Requires:   libgwengui-fox16-0 = %{version}
-Requires:   libgwengui-gtk2-0 = %{version}
-Requires:   libgwengui-gtk3-0 = %{version}
-Requires:   libgwengui-qt5-0 = %{version}
+Requires:   libgwengui-fox16-0 >= %{version}
+Requires:   libgwengui-gtk2-0 >= %{version}
+Requires:   libgwengui-gtk3-0 >= %{version}
+Requires:   libgwengui-qt5-0 >= %{version}
 Requires:   libgwenhywfar%{libversion} = %{version}
 
 %description devel
@@ -193,7 +195,7 @@
 %lang_package
 
 %prep
-%setup -q -n %{name}-%{_version}
+%setup -q -n %{_name}-%{_version}
 
 %build
 export PATH=%{_libqt5_bindir}:$PATH
@@ -218,15 +220,16 @@
 %make_install install-srcdoc
 pushd %{buildroot}%{_docdir}/%{name}/api
 # we don't want another 'gwenhywfar' dir below docpath
-mv %{name}/* ./
-rm -rf %{name}
+mv %{_name}/* ./
+rm -rf %{_name}
 # remove empty files
 `find -maxdepth 1 -type f -empty -print0 | xargs -0 echo rm -f`
 popd
 find %{buildroot} -type f -name "*.la" -delete -print
-%find_lang %{name}
-%fdupes %{buildroot}%{_datadir}/%{name}/apidoc
+%find_lang %{_name}
+%fdupes %{buildroot}%{_datadir}/%{_name}/apidoc
 %fdupes %{buildroot}%{_libdir}/cmake
+%fdupes %{buildroot}%{_docdir}
 
 %post   -n libgwenhywfar%{libversion} -p /sbin/ldconfig
 %postun -n libgwenhywfar%{libversion} -p /sbin/ldconfig
@@ -244,12 +247,12 @@
 %files
 %license COPYING
 %doc AUTHORS NEWS README TODO
-%dir %{_datadir}/%{name}/
-%{_datadir}/%{name}/ca-bundle.crt
-%{_datadir}/%{name}/dialogs/
-%dir %{_libdir}/%{name}
-%dir %{_libdir}/%{name}/plugins
-%dir %{_libdir}/%{name}/plugins/%{libversion}
+%dir %{_datadir}/%{_name}/
+%{_datadir}/%{_name}/ca-bundle.crt
+%{_datadir}/%{_name}/dialogs/
+%dir %{_libdir}/%{_name}
+%dir %{_libdir}/%{_name}/plugins
+%dir %{_libdir}/%{_name}/plugins/%{libversion}
 %exclude %{_docdir}/%{name}/api
 
 %files tools
@@ -259,13 +262,13 @@
 %{_bindir}/typemaker
 %{_bindir}/typemaker2
 %{_bindir}/xmlmerge
-%{_datadir}/%{name}/typemaker2/

commit gwenhywfar for openSUSE:Factory

2019-09-05 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2019-09-05 12:41:47

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.7948 (New)


Package is "gwenhywfar"

Thu Sep  5 12:41:47 2019 rev:68 rq:728083 version:4.20.2

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2019-06-26 
11:44:26.834583423 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.7948/gwenhywfar.changes  
2019-09-05 12:41:50.319484940 +0200
@@ -1,0 +2,34 @@
+Wed Aug 28 06:22:19 UTC 2019 - Johannes Engel 
+
+- Downgrade to 4.20.2 to enable aqbanking 5 builds
+  * Fix crash with FinTS
+
+---
+Tue Apr 23 15:44:53 UTC 2019 - Michele Bologna 
+
+- Fixed typo in changelog file
+
+---
+Tue Apr 23 12:17:38 UTC 2019 - Jan Engelhardt 
+
+- Remove --with-pic which has no effect with --disable-static.
+- Redo summaries without em dashes.
+
+---
+Mon Mar 25 17:48:25 UTC 2019 - Christophe Giboudeaux 
+
+- Prepare the KDE4/Qt4 removal from factory.
+- Run spec-cleaner
+
+---
+Wed Jan 30 21:34:35 CET 2019 - sbra...@suse.com
+
+- Update to version 4.99.8 (beta) required by libchipcard-5.1.2:
+  * Generalization in the generic TLV to GWEN DB parser.
+  * Speedup of GWEN_Date_dup (about factor 16).
+  * Correctly read a UTF-8-encoded MT940 file.
+  * Updated Gwengui-Gtk3.
+  * API improvements.
+  * Other fixes.
+
+---

Old:

  gwenhywfar-4.20.1.tar.gz

New:

  gwenhywfar-4.20.2.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.N5gu3J/_old  2019-09-05 12:41:51.175484773 +0200
+++ /var/tmp/diff_new_pack.N5gu3J/_new  2019-09-05 12:41:51.179484772 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,26 +12,23 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
-%bcond_without qt4
+%define libversion 60
+%define devversion 4
+%define devrelease 4.20
+# Beta does not mean "before release" but a release that is considered as beta:
+%define _version %{version}
 %bcond_with configure
-%definelibname libgwenhywfar60
-%define devversion 4.20
 Name:   gwenhywfar
-Version:4.20.1
+Version:4.20.2
 Release:0
 Summary:Multiplatform helper library for other libraries
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/Libraries
-Url:http://www.aqbanking.de/
-Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
-%if !%{with configure}
-BuildRequires:  autoconf
-BuildRequires:  automake
-BuildRequires:  libtool
-%endif
+URL:https://www.aquamaniac.de/rdm/projects/gwenhywfar
+Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{name}-%{_version}.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 # For doc graphs
@@ -39,12 +36,8 @@
 BuildRequires:  graphviz-gd
 BuildRequires:  libgcrypt-devel >= 1.2.0
 BuildRequires:  libopenssl-devel
-%if %{with qt4}
-%if 0%{?suse_version} >= 1500
-#!BuildIgnore:  libopenssl-1_0_0-devel
-%endif
-BuildRequires:  libqt4-devel
-%endif
+BuildRequires:  pkgconfig
+BuildRequires:  xorg-x11-fonts
 BuildRequires:  cmake(Qt5Concurrent)
 BuildRequires:  cmake(Qt5Core)
 BuildRequires:  cmake(Qt5DBus)
@@ -56,16 +49,20 @@
 BuildRequires:  cmake(Qt5Test)
 BuildRequires:  cmake(Qt5Widgets)
 BuildRequires:  cmake(Qt5Xml)
+BuildRequires:  pkgconfig(gnutls) >= 2.9.8
+BuildRequires:  pkgconfig(gtk+-2.0) >= 2.17.5
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
+Recommends: libgwenhywfar%{libversion}
+%if !%{with configure}
+BuildRequires:  autoconf
+BuildRequires:  automake
+BuildRequires:  libtool
+%endif
 %if 0%{?fedora} == 15
 BuildRequires:  fox-devel >= 1.6
 %else
 BuildRequires:  fox16-devel
 %endif
-BuildRequires:  xorg-x11-fonts
-BuildRequires:  pkgconfig(gnutls) >= 2.9.8
-BuildRequires:  

commit gwenhywfar for openSUSE:Factory

2019-06-26 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2019-06-26 11:44:24

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.4615 (New)


Package is "gwenhywfar"

Wed Jun 26 11:44:24 2019 rev:67 rq: version:4.20.1

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2019-06-24 
21:51:44.816031033 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.4615/gwenhywfar.changes  
2019-06-26 11:44:26.834583423 +0200
@@ -2,28 +1,0 @@
-Tue Apr 23 15:44:53 UTC 2019 - Michele Bologna 
-
-- Fixed typo in changelog file
-

-Tue Apr 23 12:17:38 UTC 2019 - Jan Engelhardt 
-
-- Remove --with-pic which has no effect with --disable-static.
-- Redo summaries without em dashes.
-

-Mon Mar 25 17:48:25 UTC 2019 - Christophe Giboudeaux 
-
-- Prepare the KDE4/Qt4 removal from factory.
-- Run spec-cleaner
-

-Wed Jan 30 21:34:35 CET 2019 - sbra...@suse.com
-
-- Update to version 4.99.8 (beta) required by libchipcard-5.1.2:
-  * Generalization in the generic TLV to GWEN DB parser.
-  * Speedup of GWEN_Date_dup (about factor 16).
-  * Correctly read a UTF-8-encoded MT940 file.
-  * Updated Gwengui-Gtk3.
-  * API improvements.
-  * Other fixes.
-


Old:

  gwenhywfar-4.99.8beta.tar.gz

New:

  gwenhywfar-4.20.1.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.hMtvxf/_old  2019-06-26 11:44:27.258584081 +0200
+++ /var/tmp/diff_new_pack.hMtvxf/_new  2019-06-26 11:44:27.262584087 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,24 +12,26 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via https://bugs.opensuse.org/
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-%define libversion 78
-%define devversion 5
-%define devrelease 4.99
-# Beta does not mean "before release" but a release that is considered as beta:
-%define _version %{version}beta
+%bcond_without qt4
 %bcond_with configure
+%definelibname libgwenhywfar60
+%define devversion 4.20
 Name:   gwenhywfar
-Version:4.99.8
+Version:4.20.1
 Release:0
 Summary:Multiplatform helper library for other libraries
-License:GPL-2.0-or-later AND LGPL-2.1-or-later
+License:GPL-2.0+ and LGPL-2.1+
 Group:  System/Libraries
-URL:https://www.aquamaniac.de/rdm/projects/gwenhywfar
-Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{name}-%{_version}.tar.gz
+Url:http://www.aqbanking.de/
+Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
+%if !%{with configure}
+BuildRequires:  autoconf
+BuildRequires:  automake
+BuildRequires:  libtool
+%endif
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 # For doc graphs
@@ -37,8 +39,12 @@
 BuildRequires:  graphviz-gd
 BuildRequires:  libgcrypt-devel >= 1.2.0
 BuildRequires:  libopenssl-devel
-BuildRequires:  pkgconfig
-BuildRequires:  xorg-x11-fonts
+%if %{with qt4}
+%if 0%{?suse_version} >= 1500
+#!BuildIgnore:  libopenssl-1_0_0-devel
+%endif
+BuildRequires:  libqt4-devel
+%endif
 BuildRequires:  cmake(Qt5Concurrent)
 BuildRequires:  cmake(Qt5Core)
 BuildRequires:  cmake(Qt5DBus)
@@ -50,20 +56,16 @@
 BuildRequires:  cmake(Qt5Test)
 BuildRequires:  cmake(Qt5Widgets)
 BuildRequires:  cmake(Qt5Xml)
-BuildRequires:  pkgconfig(gnutls) >= 2.9.8
-BuildRequires:  pkgconfig(gtk+-2.0) >= 2.17.5
-BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
-Recommends: libgwenhywfar%{libversion}
-%if !%{with configure}
-BuildRequires:  autoconf
-BuildRequires:  automake
-BuildRequires:  libtool
-%endif
 %if 0%{?fedora} == 15
 BuildRequires:  fox-devel >= 1.6
 %else
 BuildRequires:  fox16-devel
 %endif
+BuildRequires:  xorg-x11-fonts
+BuildRequires:  pkgconfig(gnutls) >= 2.9.8
+BuildRequires:  pkgconfig(gtk+-2.0) >= 2.17.5
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
+Recommends: %{libname}
 
 %description
 Gwenhywfar is a base library used to provide OS abstraction functions
@@ -73,10 

commit gwenhywfar for openSUSE:Factory

2019-06-24 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2019-06-24 21:51:43

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.4615 (New)


Package is "gwenhywfar"

Mon Jun 24 21:51:43 2019 rev:66 rq:710681 version:4.99.8

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2019-04-25 
16:22:25.202054032 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.4615/gwenhywfar.changes  
2019-06-24 21:51:44.816031033 +0200
@@ -1,0 +2,28 @@
+Tue Apr 23 15:44:53 UTC 2019 - Michele Bologna 
+
+- Fixed typo in changelog file
+
+---
+Tue Apr 23 12:17:38 UTC 2019 - Jan Engelhardt 
+
+- Remove --with-pic which has no effect with --disable-static.
+- Redo summaries without em dashes.
+
+---
+Mon Mar 25 17:48:25 UTC 2019 - Christophe Giboudeaux 
+
+- Prepare the KDE4/Qt4 removal from factory.
+- Run spec-cleaner
+
+---
+Wed Jan 30 21:34:35 CET 2019 - sbra...@suse.com
+
+- Update to version 4.99.8 (beta) required by libchipcard-5.1.2:
+  * Generalization in the generic TLV to GWEN DB parser.
+  * Speedup of GWEN_Date_dup (about factor 16).
+  * Correctly read a UTF-8-encoded MT940 file.
+  * Updated Gwengui-Gtk3.
+  * API improvements.
+  * Other fixes.
+
+---

Old:

  gwenhywfar-4.20.1.tar.gz

New:

  gwenhywfar-4.99.8beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.p0Qjk5/_old  2019-06-24 21:51:45.548031603 +0200
+++ /var/tmp/diff_new_pack.p0Qjk5/_new  2019-06-24 21:51:45.548031603 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,26 +12,24 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
-%bcond_without qt4
+
+%define libversion 78
+%define devversion 5
+%define devrelease 4.99
+# Beta does not mean "before release" but a release that is considered as beta:
+%define _version %{version}beta
 %bcond_with configure
-%definelibname libgwenhywfar60
-%define devversion 4.20
 Name:   gwenhywfar
-Version:4.20.1
+Version:4.99.8
 Release:0
 Summary:Multiplatform helper library for other libraries
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/Libraries
-Url:http://www.aqbanking.de/
-Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
-%if !%{with configure}
-BuildRequires:  autoconf
-BuildRequires:  automake
-BuildRequires:  libtool
-%endif
+URL:https://www.aquamaniac.de/rdm/projects/gwenhywfar
+Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{name}-%{_version}.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 # For doc graphs
@@ -39,12 +37,8 @@
 BuildRequires:  graphviz-gd
 BuildRequires:  libgcrypt-devel >= 1.2.0
 BuildRequires:  libopenssl-devel
-%if %{with qt4}
-%if 0%{?suse_version} >= 1500
-#!BuildIgnore:  libopenssl-1_0_0-devel
-%endif
-BuildRequires:  libqt4-devel
-%endif
+BuildRequires:  pkgconfig
+BuildRequires:  xorg-x11-fonts
 BuildRequires:  cmake(Qt5Concurrent)
 BuildRequires:  cmake(Qt5Core)
 BuildRequires:  cmake(Qt5DBus)
@@ -56,16 +50,20 @@
 BuildRequires:  cmake(Qt5Test)
 BuildRequires:  cmake(Qt5Widgets)
 BuildRequires:  cmake(Qt5Xml)
+BuildRequires:  pkgconfig(gnutls) >= 2.9.8
+BuildRequires:  pkgconfig(gtk+-2.0) >= 2.17.5
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
+Recommends: libgwenhywfar%{libversion}
+%if !%{with configure}
+BuildRequires:  autoconf
+BuildRequires:  automake
+BuildRequires:  libtool
+%endif
 %if 0%{?fedora} == 15
 BuildRequires:  fox-devel >= 1.6
 %else
 BuildRequires:  fox16-devel
 %endif
-BuildRequires:  xorg-x11-fonts
-BuildRequires:  pkgconfig(gnutls) >= 2.9.8
-BuildRequires:  pkgconfig(gtk+-2.0) >= 2.17.5
-BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
-Recommends: %{libname}
 
 %description
 Gwenhywfar is a base library used to provide OS abstraction functions
@@ 

commit gwenhywfar for openSUSE:Factory

2019-04-25 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2019-04-25 16:22:21

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.5536 (New)


Package is "gwenhywfar"

Thu Apr 25 16:22:21 2019 rev:65 rq: version:4.20.1

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2019-04-24 
13:57:31.323983434 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.5536/gwenhywfar.changes  
2019-04-25 16:22:25.202054032 +0200
@@ -2,22 +1,0 @@
-Tue Apr 23 15:44:53 UTC 2019 - Michele Bologna 
-
-- Fixed typo in changelog file
-

-Mon Mar 25 17:48:25 UTC 2019 - Christophe Giboudeaux 
-
-- Prepare the KDE4/Qt4 removal from factory.
-- Run spec-cleaner
-

-Wed Jan 30 21:34:35 CET 2019 - sbra...@suse.com
-
-- Update to version 4.99.8 (beta) required by libchipcard-5.1.2:
-  * Generalization in the generic TLV to GWEN DB parser.
-  * Speedup of GWEN_Date_dup (about factor 16).
-  * Correctly read a UTF-8-encoded MT940 file.
-  * Updated Gwengui-Gtk3.
-  * API improvements.
-  * Other fixes.
-


Old:

  gwenhywfar-4.99.8beta.tar.gz

New:

  gwenhywfar-4.20.1.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.Tdfhhj/_old  2019-04-25 16:22:25.674053935 +0200
+++ /var/tmp/diff_new_pack.Tdfhhj/_new  2019-04-25 16:22:25.674053935 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,24 +12,26 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via https://bugs.opensuse.org/
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-
-%define libversion 78
-%define devversion 5
-%define devrelease 4.99
-# Beta does not mean "before release" but a release that is considered as beta:
-%define _version %{version}beta
+%bcond_without qt4
 %bcond_with configure
+%definelibname libgwenhywfar60
+%define devversion 4.20
 Name:   gwenhywfar
-Version:4.99.8
+Version:4.20.1
 Release:0
 Summary:Multiplatform helper library for other libraries
-License:GPL-2.0-or-later AND LGPL-2.1-or-later
+License:GPL-2.0+ and LGPL-2.1+
 Group:  System/Libraries
-URL:https://www.aquamaniac.de/rdm/projects/gwenhywfar
-Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{name}-%{_version}.tar.gz
+Url:http://www.aqbanking.de/
+Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
+%if !%{with configure}
+BuildRequires:  autoconf
+BuildRequires:  automake
+BuildRequires:  libtool
+%endif
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 # For doc graphs
@@ -37,8 +39,12 @@
 BuildRequires:  graphviz-gd
 BuildRequires:  libgcrypt-devel >= 1.2.0
 BuildRequires:  libopenssl-devel
-BuildRequires:  pkgconfig
-BuildRequires:  xorg-x11-fonts
+%if %{with qt4}
+%if 0%{?suse_version} >= 1500
+#!BuildIgnore:  libopenssl-1_0_0-devel
+%endif
+BuildRequires:  libqt4-devel
+%endif
 BuildRequires:  cmake(Qt5Concurrent)
 BuildRequires:  cmake(Qt5Core)
 BuildRequires:  cmake(Qt5DBus)
@@ -50,20 +56,16 @@
 BuildRequires:  cmake(Qt5Test)
 BuildRequires:  cmake(Qt5Widgets)
 BuildRequires:  cmake(Qt5Xml)
-BuildRequires:  pkgconfig(gnutls) >= 2.9.8
-BuildRequires:  pkgconfig(gtk+-2.0) >= 2.17.5
-BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
-Recommends: libgwenhywfar%{libversion}
-%if !%{with configure}
-BuildRequires:  autoconf
-BuildRequires:  automake
-BuildRequires:  libtool
-%endif
 %if 0%{?fedora} == 15
 BuildRequires:  fox-devel >= 1.6
 %else
 BuildRequires:  fox16-devel
 %endif
+BuildRequires:  xorg-x11-fonts
+BuildRequires:  pkgconfig(gnutls) >= 2.9.8
+BuildRequires:  pkgconfig(gtk+-2.0) >= 2.17.5
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
+Recommends: %{libname}
 
 %description
 Gwenhywfar is a base library used to provide OS abstraction functions
@@ -74,9 +76,9 @@
 
 %package tools
 Summary:Multiplatform Helper Library for Other Libraries - Tools
-License:GPL-2.0-or-later AND LGPL-2.1-or-later
+License:GPL-2.0+ and LGPL-2.1+
 Group:  

commit gwenhywfar for openSUSE:Factory

2019-04-24 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2019-04-24 13:57:26

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new.5536 (New)


Package is "gwenhywfar"

Wed Apr 24 13:57:26 2019 rev:64 rq:697221 version:4.99.8

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2018-06-08 
23:12:23.170736275 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new.5536/gwenhywfar.changes  
2019-04-24 13:57:31.323983434 +0200
@@ -1,0 +2,22 @@
+Tue Apr 23 15:44:53 UTC 2019 - Michele Bologna 
+
+- Fixed typo in changelog file
+
+---
+Mon Mar 25 17:48:25 UTC 2019 - Christophe Giboudeaux 
+
+- Prepare the KDE4/Qt4 removal from factory.
+- Run spec-cleaner
+
+---
+Wed Jan 30 21:34:35 CET 2019 - sbra...@suse.com
+
+- Update to version 4.99.8 (beta) required by libchipcard-5.1.2:
+  * Generalization in the generic TLV to GWEN DB parser.
+  * Speedup of GWEN_Date_dup (about factor 16).
+  * Correctly read a UTF-8-encoded MT940 file.
+  * Updated Gwengui-Gtk3.
+  * API improvements.
+  * Other fixes.
+
+---

Old:

  gwenhywfar-4.20.1.tar.gz

New:

  gwenhywfar-4.99.8beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.UaZRW4/_old  2019-04-24 13:57:31.967983030 +0200
+++ /var/tmp/diff_new_pack.UaZRW4/_new  2019-04-24 13:57:31.967983030 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,26 +12,24 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
-%bcond_without qt4
+
+%define libversion 78
+%define devversion 5
+%define devrelease 4.99
+# Beta does not mean "before release" but a release that is considered as beta:
+%define _version %{version}beta
 %bcond_with configure
-%definelibname libgwenhywfar60
-%define devversion 4.20
 Name:   gwenhywfar
-Version:4.20.1
+Version:4.99.8
 Release:0
 Summary:Multiplatform helper library for other libraries
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  System/Libraries
-Url:http://www.aqbanking.de/
-Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
-%if !%{with configure}
-BuildRequires:  autoconf
-BuildRequires:  automake
-BuildRequires:  libtool
-%endif
+URL:https://www.aquamaniac.de/rdm/projects/gwenhywfar
+Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{_version}.tar.gz#/%{name}-%{_version}.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 # For doc graphs
@@ -39,12 +37,8 @@
 BuildRequires:  graphviz-gd
 BuildRequires:  libgcrypt-devel >= 1.2.0
 BuildRequires:  libopenssl-devel
-%if %{with qt4}
-%if 0%{?suse_version} >= 1500
-#!BuildIgnore:  libopenssl-1_0_0-devel
-%endif
-BuildRequires:  libqt4-devel
-%endif
+BuildRequires:  pkgconfig
+BuildRequires:  xorg-x11-fonts
 BuildRequires:  cmake(Qt5Concurrent)
 BuildRequires:  cmake(Qt5Core)
 BuildRequires:  cmake(Qt5DBus)
@@ -56,16 +50,20 @@
 BuildRequires:  cmake(Qt5Test)
 BuildRequires:  cmake(Qt5Widgets)
 BuildRequires:  cmake(Qt5Xml)
+BuildRequires:  pkgconfig(gnutls) >= 2.9.8
+BuildRequires:  pkgconfig(gtk+-2.0) >= 2.17.5
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
+Recommends: libgwenhywfar%{libversion}
+%if !%{with configure}
+BuildRequires:  autoconf
+BuildRequires:  automake
+BuildRequires:  libtool
+%endif
 %if 0%{?fedora} == 15
 BuildRequires:  fox-devel >= 1.6
 %else
 BuildRequires:  fox16-devel
 %endif
-BuildRequires:  xorg-x11-fonts
-BuildRequires:  pkgconfig(gnutls) >= 2.9.8
-BuildRequires:  pkgconfig(gtk+-2.0) >= 2.17.5
-BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
-Recommends: %{libname}
 
 %description
 Gwenhywfar is a base library used to provide OS abstraction functions
@@ -76,9 +74,9 @@
 
 %package tools
 Summary:Multiplatform Helper Library for Other Libraries - Tools
-License:GPL-2.0+ and LGPL-2.1+
+License:GPL-2.0-or-later AND LGPL-2.1-or-later
 Group:  

commit gwenhywfar for openSUSE:Factory

2018-06-08 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2018-06-08 23:12:20

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is "gwenhywfar"

Fri Jun  8 23:12:20 2018 rev:63 rq:613230 version:4.20.1

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2017-12-22 
12:20:03.312237529 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2018-06-08 23:12:23.170736275 +0200
@@ -1,0 +2,26 @@
+Tue May 15 15:36:12 UTC 2018 - dims...@opensuse.org
+
+- Update to version 4.20.1:
+  + bgo#794707: Aqbanking combo boxes missing selection.
+  + Major speedup of GWEN_IdList64_AddId().
+  + Fix all Gtk3 deprecation warnings.
+
+---
+Thu Apr  5 01:14:17 UTC 2018 - luc1...@linuxmail.org
+
+- Update to version 4.20.0:
+  + Add a Gtk3 frontend.
+- Add:
+  + pkgconfig(gtk+-3.0) BuildRequires and libgwengui-gtk3
+subpackage following upstream changes.
+  + Conditionalized autoconf, automake and libtool BuildRequires
+along with autoreconf call to ease the switching between
+tarballs with or without configure script.
+  + Missing ldconfig post/postun scriptlets for libgwengui-qt5.
+- Drop standard BuilRoot tag definition: RPM already handles this
+  itself.
+- Delete redundant deprecated clean section.
+- Switch gnutls and gtk2 devel packages BuildRequires with their
+  respectives pkgconfig modules counterparts.
+
+---

Old:

  gwenhywfar-4.18.0.tar.gz

New:

  gwenhywfar-4.20.1.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.YAv3B0/_old  2018-06-08 23:12:23.926708977 +0200
+++ /var/tmp/diff_new_pack.YAv3B0/_new  2018-06-08 23:12:23.930708832 +0200
@@ -16,21 +16,27 @@
 #
 
 %bcond_without qt4
-
-%definelibversion  60
-%define devversion 4.18
+%bcond_with configure
+%definelibname libgwenhywfar60
+%define devversion 4.20
 Name:   gwenhywfar
-Version:4.18.0
+Version:4.20.1
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+
 Group:  System/Libraries
 Url:http://www.aqbanking.de/
-Source: %{name}-%{version}.tar.gz
+Source: 
https://github.com/aqbanking/gwenhywfar/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
+%if !%{with configure}
+BuildRequires:  autoconf
+BuildRequires:  automake
+BuildRequires:  libtool
+%endif
 BuildRequires:  doxygen
 BuildRequires:  fdupes
-BuildRequires:  gnutls-devel >= 3.0
-BuildRequires:  gtk2-devel >= 1.4
+# For doc graphs
+BuildRequires:  graphviz
+BuildRequires:  graphviz-gd
 BuildRequires:  libgcrypt-devel >= 1.2.0
 BuildRequires:  libopenssl-devel
 %if %{with qt4}
@@ -55,12 +61,11 @@
 %else
 BuildRequires:  fox16-devel
 %endif
-# For doc graphs
-BuildRequires:  graphviz
-BuildRequires:  graphviz-gd
 BuildRequires:  xorg-x11-fonts
-Recommends: lib%{name}%{libversion}
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+BuildRequires:  pkgconfig(gnutls) >= 2.9.8
+BuildRequires:  pkgconfig(gtk+-2.0) >= 2.17.5
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
+Recommends: %{libname}
 
 %description
 Gwenhywfar is a base library used to provide OS abstraction functions
@@ -73,7 +78,7 @@
 Summary:Multiplatform Helper Library for Other Libraries - Tools
 License:GPL-2.0+ and LGPL-2.1+
 Group:  System/Libraries
-Requires:   lib%{name}%{libversion} = %{version}
+Requires:   %{libname} = %{version}
 
 %description tools
 Gwenhywfar is a base library used to provide OS abstraction functions
@@ -82,27 +87,27 @@
 configuration files, reading and writing of XML files, and interprocess
 communication).
 
-%package -n lib%{name}%{libversion}-plugins
+%package -n %{libname}-plugins
 Summary:Multiplatform Helper Library for Other Libraries - Plugins
 License:LGPL-2.1+
 Group:  System/Libraries
 Requires:   %{name} = %{version}
 
-%description -n lib%{name}%{libversion}-plugins
+%description -n %{libname}-plugins
 Gwenhywfar is a base library used to provide OS abstraction functions
 for Linux, FreeBSD, OpenBSD, NetBSD, and Windows. It also includes
 some often needed functions (for example, for handling and parsing of
 configuration files, reading and writing of XML files, and interprocess
 communication).
 
-%package -n lib%{name}%{libversion}
+%package -n %{libname}
 Summary:Multiplatform Helper Library for Other Libraries
 License:LGPL-2.1+
 Group:  System/Libraries
 

commit gwenhywfar for openSUSE:Factory

2017-12-22 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2017-12-22 12:19:41

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is "gwenhywfar"

Fri Dec 22 12:19:41 2017 rev:62 rq:555987 version:4.18.0

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2017-12-03 
10:13:33.942673966 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2017-12-22 12:20:03.312237529 +0100
@@ -1,0 +2,14 @@
+Mon Dec 11 13:02:15 UTC 2017 - wba...@tmo.at
+
+- Re-enable Qt4 front-end, kmymoney still needs it for its kbanking
+  plugin
+- BuildIgnore libopenssl-1_0_0-devel to avoid openssl conflict on
+  Tumbleweed
+
+---
+Mon Dec  4 22:59:04 UTC 2017 - nico.kru...@gmail.com
+
+- Update to 4.18.0
+  + show SSL certificate hashes as MD5, SHA1, and SHA512
+
+---

Old:

  gwenhywfar-4.17.0.tar.gz

New:

  gwenhywfar-4.18.0.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.gwA0Tj/_old  2017-12-22 12:20:07.236046207 +0100
+++ /var/tmp/diff_new_pack.gwA0Tj/_new  2017-12-22 12:20:07.240046012 +0100
@@ -15,12 +15,12 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-%bcond_with qt4
+%bcond_without qt4
 
 %definelibversion  60
-%define devversion 4.17
+%define devversion 4.18
 Name:   gwenhywfar
-Version:4.17.0
+Version:4.18.0
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+
@@ -34,6 +34,9 @@
 BuildRequires:  libgcrypt-devel >= 1.2.0
 BuildRequires:  libopenssl-devel
 %if %{with qt4}
+%if 0%{?suse_version} >= 1500
+#!BuildIgnore:  libopenssl-1_0_0-devel
+%endif
 BuildRequires:  libqt4-devel
 %endif
 BuildRequires:  cmake(Qt5Concurrent)
@@ -201,8 +204,10 @@
--disable-static \
 %if %{with qt4}
--with-qt4-libs=%{_libdir} \
+   --with-guis="fox16 qt4 qt5 gtk2" \
+%else
+   --with-guis="fox16 qt5 gtk2" \
 %endif
-   --with-guis="fox16 %{?with qt4:qt4} qt5 gtk2" \
--with-plugins-cfgmgr=all \
--with-pic
 %__make %{?smp_mflags}

++ gwenhywfar-4.17.0.tar.gz -> gwenhywfar-4.18.0.tar.gz ++
 29772 lines of diff (skipped)




commit gwenhywfar for openSUSE:Factory

2017-12-03 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2017-12-03 10:13:28

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is "gwenhywfar"

Sun Dec  3 10:13:28 2017 rev:61 rq:547495 version:4.17.0

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2017-06-12 
15:35:53.999010859 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2017-12-03 10:13:33.942673966 +0100
@@ -1,0 +2,5 @@
+Mon Nov 27 10:00:09 UTC 2017 - dims...@opensuse.org
+
+- Conditionalize usage of qt4 libs
+
+---



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.8bMAbM/_old  2017-12-03 10:13:35.178629030 +0100
+++ /var/tmp/diff_new_pack.8bMAbM/_new  2017-12-03 10:13:35.178629030 +0100
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+%bcond_with qt4
 
 %definelibversion  60
 %define devversion 4.17
@@ -32,7 +33,9 @@
 BuildRequires:  gtk2-devel >= 1.4
 BuildRequires:  libgcrypt-devel >= 1.2.0
 BuildRequires:  libopenssl-devel
+%if %{with qt4}
 BuildRequires:  libqt4-devel
+%endif
 BuildRequires:  cmake(Qt5Concurrent)
 BuildRequires:  cmake(Qt5Core)
 BuildRequires:  cmake(Qt5DBus)
@@ -170,7 +173,9 @@
 Requires:   lib%{name}%{libversion} = %{version}
 Requires:   libgwengui-fox16-0 = %{version}
 Requires:   libgwengui-gtk2-0 = %{version}
+%if %{with qt4}
 Requires:   libgwengui-qt4-0 = %{version}
+%endif
 Requires:   libgwengui-qt5-0 = %{version}
 
 %description devel
@@ -194,8 +199,10 @@
--enable-full-doc\
--with-docpath=%{_docdir}/%{name}/api \
--disable-static \
+%if %{with qt4}
--with-qt4-libs=%{_libdir} \
-   --with-guis="fox16 qt4 qt5 gtk2" \
+%endif
+   --with-guis="fox16 %{?with qt4:qt4} qt5 gtk2" \
--with-plugins-cfgmgr=all \
--with-pic
 %__make %{?smp_mflags}
@@ -230,9 +237,11 @@
 
 %postun -n libgwengui-gtk2-0 -p /sbin/ldconfig
 
+%if %{with qt4}
 %post -n libgwengui-qt4-0 -p /sbin/ldconfig
 
 %postun -n libgwengui-qt4-0 -p /sbin/ldconfig
+%endif
 
 %post -n libgwengui-fox16-0 -p /sbin/ldconfig
 
@@ -275,9 +284,11 @@
 %defattr (-, root, root)
 %{_libdir}/libgwengui-gtk2.so.*
 
+%if %{with qt4}
 %files -n libgwengui-qt4-0
 %defattr (-, root, root)
 %{_libdir}/libgwengui-qt4.so.*
+%endif
 
 %files -n libgwengui-qt5-0
 %defattr (-, root, root)
@@ -297,13 +308,15 @@
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/%{name}.pc
 %{_libdir}/pkgconfig/gwengui-gtk2.pc
+%if %{with qt4}
 %{_libdir}/pkgconfig/gwengui-qt4.pc
+%{_libdir}/cmake/gwengui-qt4-%{devversion}
+%endif
 %{_libdir}/pkgconfig/gwengui-qt5.pc
 %{_libdir}/pkgconfig/gwengui-fox16.pc
 %dir %{_libdir}/cmake
 %{_libdir}/cmake/%{name}-%{devversion}
 %{_libdir}/cmake/gwengui-cpp-%{devversion}
-%{_libdir}/cmake/gwengui-qt4-%{devversion}
 %{_libdir}/cmake/gwengui-qt5-%{devversion}
 
 %files lang -f %{name}.lang




commit gwenhywfar for openSUSE:Factory

2017-06-12 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2017-06-12 15:35:40

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is "gwenhywfar"

Mon Jun 12 15:35:40 2017 rev:60 rq:503006 version:4.17.0

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2017-06-01 
16:35:03.651430998 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2017-06-12 15:35:53.999010859 +0200
@@ -1,0 +2,5 @@
+Sat Jun 10 11:17:28 UTC 2017 - wba...@tmo.at
+
+- Enable Qt5 front-end
+
+---



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.FddGjC/_old  2017-06-12 15:35:56.002728247 +0200
+++ /var/tmp/diff_new_pack.FddGjC/_new  2017-06-12 15:35:56.006727683 +0200
@@ -33,7 +33,17 @@
 BuildRequires:  libgcrypt-devel >= 1.2.0
 BuildRequires:  libopenssl-devel
 BuildRequires:  libqt4-devel
-#BuildRequires:  qt-devel
+BuildRequires:  cmake(Qt5Concurrent)
+BuildRequires:  cmake(Qt5Core)
+BuildRequires:  cmake(Qt5DBus)
+BuildRequires:  cmake(Qt5Gui)
+BuildRequires:  cmake(Qt5Network)
+BuildRequires:  cmake(Qt5OpenGL)
+BuildRequires:  cmake(Qt5PrintSupport)
+BuildRequires:  cmake(Qt5Sql)
+BuildRequires:  cmake(Qt5Test)
+BuildRequires:  cmake(Qt5Widgets)
+BuildRequires:  cmake(Qt5Xml)
 %if 0%{?fedora} == 15
 BuildRequires:  fox-devel >= 1.6
 %else
@@ -57,7 +67,7 @@
 Summary:Multiplatform Helper Library for Other Libraries - Tools
 License:GPL-2.0+ and LGPL-2.1+
 Group:  System/Libraries
-Requires:   libgwenhywfar60 = %{version}
+Requires:   lib%{name}%{libversion} = %{version}
 
 %description tools
 Gwenhywfar is a base library used to provide OS abstraction functions
@@ -129,6 +139,20 @@
 
 This package provides the Qt4 implementation of the generic UI toolkit.
 
+%package -n libgwengui-qt5-0
+Summary:Multiplatform Helper Library for Other Libraries -- Qt5 UI 
Backend
+License:LGPL-2.1+
+Group:  System/Libraries
+
+%description -n libgwengui-qt5-0
+Gwenhywfar is a base library used to provide OS abstraction functions
+for Linux, FreeBSD, OpenBSD, NetBSD, and Windows. It also includes
+some often needed functions (for example, for handling and parsing of
+configuration files, reading and writing of XML files, and interprocess
+communication).
+
+This package provides the Qt5 implementation of the generic UI toolkit.
+
 %package -n libgwengui-fox16-0
 Summary:FOX interface for Gwenhywfar
 License:GPL-2.0+ and LGPL-2.1+
@@ -147,6 +171,7 @@
 Requires:   libgwengui-fox16-0 = %{version}
 Requires:   libgwengui-gtk2-0 = %{version}
 Requires:   libgwengui-qt4-0 = %{version}
+Requires:   libgwengui-qt5-0 = %{version}
 
 %description devel
 Gwenhywfar is a base library used to provide OS abstraction functions
@@ -160,6 +185,7 @@
 %setup -q
 
 %build
+export PATH=%{_libqt5_bindir}:$PATH
 # quick fix for $CPP being unset and configure failing to handle include dirs 
properly
 CPP=`which cpp`
 export CPP
@@ -169,7 +195,7 @@
--with-docpath=%{_docdir}/%{name}/api \
--disable-static \
--with-qt4-libs=%{_libdir} \
-   --with-guis="fox16 qt4 gtk2" \
+   --with-guis="fox16 qt4 qt5 gtk2" \
--with-plugins-cfgmgr=all \
--with-pic
 %__make %{?smp_mflags}
@@ -253,6 +279,10 @@
 %defattr (-, root, root)
 %{_libdir}/libgwengui-qt4.so.*
 
+%files -n libgwengui-qt5-0
+%defattr (-, root, root)
+%{_libdir}/libgwengui-qt5.so.*
+
 %files -n libgwengui-fox16-0
 %defattr (-,root,root)
 %{_libdir}/libgwengui-fox16.so.*
@@ -268,11 +298,13 @@
 %{_libdir}/pkgconfig/%{name}.pc
 %{_libdir}/pkgconfig/gwengui-gtk2.pc
 %{_libdir}/pkgconfig/gwengui-qt4.pc
+%{_libdir}/pkgconfig/gwengui-qt5.pc
 %{_libdir}/pkgconfig/gwengui-fox16.pc
 %dir %{_libdir}/cmake
 %{_libdir}/cmake/%{name}-%{devversion}
 %{_libdir}/cmake/gwengui-cpp-%{devversion}
 %{_libdir}/cmake/gwengui-qt4-%{devversion}
+%{_libdir}/cmake/gwengui-qt5-%{devversion}
 
 %files lang -f %{name}.lang
 




commit gwenhywfar for openSUSE:Factory

2017-06-01 Thread root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2017-06-01 16:35:02

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is "gwenhywfar"

Thu Jun  1 16:35:02 2017 rev:59 rq:500337 version:4.17.0

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2016-10-18 
10:43:08.0 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2017-06-01 16:35:03.651430998 +0200
@@ -1,0 +2,6 @@
+Tue May 30 21:33:32 UTC 2017 - nico.kru...@gmail.com
+
+- Update to 4.17.0
+  + minor bugfixes
+
+---

Old:

  gwenhywfar-4.16.0beta.tar.gz

New:

  gwenhywfar-4.17.0.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.xWC3l7/_old  2017-06-01 16:35:04.535306318 +0200
+++ /var/tmp/diff_new_pack.xWC3l7/_new  2017-06-01 16:35:04.535306318 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,9 +17,9 @@
 
 
 %definelibversion  60
-%define devversion 4.16
+%define devversion 4.17
 Name:   gwenhywfar
-Version:4.16.0beta
+Version:4.17.0
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+

++ gwenhywfar-4.16.0beta.tar.gz -> gwenhywfar-4.17.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gwenhywfar-4.16.0beta/ChangeLog 
new/gwenhywfar-4.17.0/ChangeLog
--- old/gwenhywfar-4.16.0beta/ChangeLog 2016-10-12 18:57:44.0 +0200
+++ new/gwenhywfar-4.17.0/ChangeLog 2017-02-26 19:28:28.0 +0100
@@ -1,4 +1,16 @@
 --
+2017-02-26 19:28:36 +0100 Martin Preuss
+Prepared release 4.17.0stable.
+
+--
+2016-12-05 23:08:28 +0100 Martin Preuss
+Added debug function GWEN_Crypt_Token_KeyInfo_Dump (Holger Magnussen).
+
+--
+2016-10-27 22:17:10 +0200 Christian Stimming
+Minor improved error message output of date parsing.
+
+--
 2016-10-12 18:55:46 +0200 Martin Preuss
 Prepared release 4.16.0beta.
 
@@ -533,18 +545,3 @@
 --
 2014-07-25 23:42:21 +0200 Martin Preuss
 More work on generic parser.
-
---
-2014-07-11 23:12:10 + martin
-MultiCache: Added missing counter handling.
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2338 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2014-07-08 18:30:21 + martin
-Removed references to new g_parser from gwentest.c
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2337 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2014-07-08 12:43:31 + martin
-Fixed version string creation.
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2336 
70169cfe-8b10-0410-8925-dcb4b91034d8
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gwenhywfar-4.16.0beta/Makefile.in 
new/gwenhywfar-4.17.0/Makefile.in
--- old/gwenhywfar-4.16.0beta/Makefile.in   2016-10-12 18:55:40.0 
+0200
+++ new/gwenhywfar-4.17.0/Makefile.in   2017-02-26 19:26:26.0 +0100
@@ -1090,8 +1090,8 @@
@echo "This command is intended for maintainers to use"
@echo "it deletes files that may require special tools to rebuild."
-test -z "$(BUILT_SOURCES)" || rm -f $(BUILT_SOURCES)
-@IF_MAKE_I18N_FILES_FALSE@install-data-local:
 @IF_MAKE_I18N_FILES_FALSE@uninstall-local:
+@IF_MAKE_I18N_FILES_FALSE@install-data-local:
 clean: clean-recursive
 
 clean-am: clean-generic clean-libtool clean-local mostlyclean-am
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gwenhywfar-4.16.0beta/configure 
new/gwenhywfar-4.17.0/configure
--- old/gwenhywfar-4.16.0beta/configure 2016-10-12 18:55:46.0 +0200
+++ new/gwenhywfar-4.17.0/configure 2017-02-26 19:26:29.0 +0100
@@ -2888,10 +2888,10 @@
 # versions
 #
 

commit gwenhywfar for openSUSE:Factory

2016-10-18 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2016-10-18 10:43:06

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is "gwenhywfar"

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2016-09-12 
13:27:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2016-10-18 10:43:08.0 +0200
@@ -1,0 +2,6 @@
+Fri Oct 14 19:02:52 UTC 2016 - jcnen...@gmail.com
+
+- Update to 4.16.0
+  + Fix issues handling certificates
+
+---

Old:

  gwenhywfar-4.15.5beta.tar.gz

New:

  gwenhywfar-4.16.0beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.phjBUM/_old  2016-10-18 10:43:10.0 +0200
+++ /var/tmp/diff_new_pack.phjBUM/_new  2016-10-18 10:43:10.0 +0200
@@ -17,9 +17,9 @@
 
 
 %definelibversion  60
-%define devversion 4.15
+%define devversion 4.16
 Name:   gwenhywfar
-Version:4.15.5beta
+Version:4.16.0beta
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+
@@ -33,6 +33,7 @@
 BuildRequires:  libgcrypt-devel >= 1.2.0
 BuildRequires:  libopenssl-devel
 BuildRequires:  libqt4-devel
+#BuildRequires:  qt-devel
 %if 0%{?fedora} == 15
 BuildRequires:  fox-devel >= 1.6
 %else

++ gwenhywfar-4.15.5beta.tar.gz -> gwenhywfar-4.16.0beta.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gwenhywfar-4.15.5beta/ChangeLog 
new/gwenhywfar-4.16.0beta/ChangeLog
--- old/gwenhywfar-4.15.5beta/ChangeLog 2016-07-14 22:48:20.0 +0200
+++ new/gwenhywfar-4.16.0beta/ChangeLog 2016-10-12 18:57:44.0 +0200
@@ -1,4 +1,64 @@
 --
+2016-10-12 18:55:46 +0200 Martin Preuss
+Prepared release 4.16.0beta.
+
+--
+2016-10-12 18:51:33 +0200 Martin Preuss
+gct-tool: Added command "showpasswords"
+This command lists the passwords stored in a GWEN_PASSWD_STORE (which is used
+by AqFinance to store passwords).
+
+--
+2016-10-12 18:50:32 +0200 Martin Preuss
+Added function GWEN_PasswordStore_GetTokenList().
+This functions returns a list of tokens stored in a GWEN_PASSWD_STORE.
+
+--
+2016-10-07 21:03:35 +0200 Martin Preuss
+Prepared 4.15.6beta.
+
+--
+2016-10-07 21:03:17 +0200 Martin Preuss
+Improved readability slightly.
+
+--
+2016-08-27 21:13:19 +0200 Martin Preuss
+Test...
+
+--
+2016-08-27 00:34:20 +0200 Martin Preuss
+Test...
+
+--
+2016-07-28 00:05:46 +0200 Martin Preuss
+Fixed a typo.
+
+--
+2016-07-27 23:36:23 +0200 Martin Preuss
+Work on certificate handling for GNUTLS.
+- we no longer maintain our own certificate files
+- we now optionally try to find system-wide installed certificate
+  files in /etc/ssl/certs and in /usr/share/ca-certificates on non-win32
+  systems. There is currently no solution for the case when both approaches
+  fail. There is of course gnutls_certificate_set_x509_system_trust(), but
+  that is only available since 3.0.20 and doesn not always work as expected
+  (according to 
https://www.happyassassin.net/2015/01/12/a-note-about-ssltls-trusted-certificate-stores-and-platforms/)
+  Also, this doesn't work for precompiled and packaged binaries like those
+  of AqFinance, since the function uses those certificate files/dirs set at
+  compile-time of gnutls, and since the build system isn't necessarily the
+  target system, this approach might not always work.
+- removed configure option --enable-builtin-certs
+- added configure option --enable-system-certs
+
+--
+2016-07-27 23:30:00 +0200 Martin Preuss
+Added some stuff to TOD file to remember later...
+
+--
+2016-07-26 17:02:45 +0200 Martin Preuss
+Fixed a problem in as-scrub-include.m4 (patch by Thomas Baumgart from 
KMyMoney).
+
+--
 2016-07-14 22:01:52 +0200 Martin Preuss
 Prepared 

commit gwenhywfar for openSUSE:Factory

2016-09-12 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2016-09-12 13:27:29

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is "gwenhywfar"

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2016-05-02 
10:45:00.0 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2016-09-12 13:27:42.0 +0200
@@ -1,0 +2,12 @@
+Wed Sep  7 21:47:37 UTC 2016 - nico.kru...@gmail.com
+
+- quick fix for $CPP being unset and configure failing to handle
+  include dirs properly
+
+---
+Sun Aug 21 21:47:50 UTC 2016 - jcnen...@gmail.com
+
+- Update to 4.15.5beta
+  + Fix connections to buggy SSL servers
+
+---

Old:

  gwenhywfar-4.15.3.tar.gz

New:

  gwenhywfar-4.15.5beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.EHZovE/_old  2016-09-12 13:27:43.0 +0200
+++ /var/tmp/diff_new_pack.EHZovE/_new  2016-09-12 13:27:43.0 +0200
@@ -19,7 +19,7 @@
 %definelibversion  60
 %define devversion 4.15
 Name:   gwenhywfar
-Version:4.15.3
+Version:4.15.5beta
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+
@@ -159,6 +159,9 @@
 %setup -q
 
 %build
+# quick fix for $CPP being unset and configure failing to handle include dirs 
properly
+CPP=`which cpp`
+export CPP
 %configure\
--enable-release\
--enable-full-doc\




commit gwenhywfar for openSUSE:Factory

2016-05-02 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2016-05-02 10:44:55

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is "gwenhywfar"

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2016-01-15 
10:41:38.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2016-05-02 10:45:00.0 +0200
@@ -1,0 +2,9 @@
+Sat Apr 30 11:23:03 UTC 2016 - nico.kru...@gmail.com
+
+- Update to 4.15.3
+  + improve and simplify the TLS code
+  + fix an error in the message parser (MsgEngine) that caused
+problems with some special HBCI messages
+  + new (experimental) QT5 front-end (not enabled yet here)
+
+---

Old:

  gwenhywfar-4.15.2beta.tar.gz

New:

  gwenhywfar-4.15.3.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.9c4BTP/_old  2016-05-02 10:45:01.0 +0200
+++ /var/tmp/diff_new_pack.9c4BTP/_new  2016-05-02 10:45:01.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,7 +19,7 @@
 %definelibversion  60
 %define devversion 4.15
 Name:   gwenhywfar
-Version:4.15.2beta
+Version:4.15.3
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+
@@ -115,7 +115,7 @@
 This package provides the GTK+ implementation of the generic UI toolkit.
 
 %package -n libgwengui-qt4-0
-Summary:Multiplatform Helper Library for Other Libraries -- Qt UI 
Backend
+Summary:Multiplatform Helper Library for Other Libraries -- Qt4 UI 
Backend
 License:LGPL-2.1+
 Group:  System/Libraries
 
@@ -126,7 +126,7 @@
 configuration files, reading and writing of XML files, and interprocess
 communication).
 
-This package provides the Qt implementation of the generic UI toolkit.
+This package provides the Qt4 implementation of the generic UI toolkit.
 
 %package -n libgwengui-fox16-0
 Summary:FOX interface for Gwenhywfar
@@ -267,6 +267,7 @@
 %{_libdir}/pkgconfig/gwengui-fox16.pc
 %dir %{_libdir}/cmake
 %{_libdir}/cmake/%{name}-%{devversion}
+%{_libdir}/cmake/gwengui-cpp-%{devversion}
 %{_libdir}/cmake/gwengui-qt4-%{devversion}
 
 %files lang -f %{name}.lang

++ gwenhywfar-4.15.2beta.tar.gz -> gwenhywfar-4.15.3.tar.gz ++
 31742 lines of diff (skipped)




commit gwenhywfar for openSUSE:Factory

2016-01-15 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2016-01-15 10:41:37

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is "gwenhywfar"

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2015-11-22 
11:02:53.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2016-01-15 10:41:38.0 +0100
@@ -1,0 +2,7 @@
+Wed Jan 13 14:55:50 UTC 2016 - jcnen...@gmail.com
+
+- Update to 4.15.2beta
+  + Use new code for SSL connections to enable build with current
+GnuTLS versions. This obsoletes patch gwenhywfar-gnutls30.patch
+
+---

Old:

  gwenhywfar-4.14.0.tar.gz
  gwenhywfar-gnutls30.patch

New:

  gwenhywfar-4.15.2beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.zJT25I/_old  2016-01-15 10:41:39.0 +0100
+++ /var/tmp/diff_new_pack.zJT25I/_new  2016-01-15 10:41:39.0 +0100
@@ -17,17 +17,15 @@
 
 
 %definelibversion  60
-%define devversion 4.14
+%define devversion 4.15
 Name:   gwenhywfar
-Version:4.14.0
+Version:4.15.2beta
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+
 Group:  System/Libraries
 Url:http://www.aqbanking.de/
 Source: %{name}-%{version}.tar.gz
-# PATCH-FIX-UPSTREAM gwenhywfar-gnutls30.patch zai...@opensuse.org -- Fix 
build with gnutls30, patch taken from Arch linux.
-Patch0: gwenhywfar-gnutls30.patch
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  gnutls-devel >= 3.0
@@ -159,7 +157,6 @@
 %lang_package
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 %configure\




commit gwenhywfar for openSUSE:Factory

2015-11-22 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2015-11-22 11:00:52

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is "gwenhywfar"

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2015-04-27 
13:04:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2015-11-22 11:02:53.0 +0100
@@ -1,0 +2,20 @@
+Thu Nov  5 23:39:26 UTC 2015 - nico.kru...@gmail.com
+
+- Update to 4.14.0:
+  + Fix segfault on windows when using HBCI with keyfile.
+  + Major speedup of GWEN_Directory_GetMatchingFilesRecursively().
+  + Re-work Compiler Symbol Visibility Check.
+  + Drop unused autoconf variable gwen_enable_export.
+  + Fix symbol visibilty check for GCC 5.x.
+  + Revert "Turn compiler warning for implicit function declaration
+into error."
+  + Revert "Disable timestamps in HTML pages generated by Doxygen".
+  + Disable timestamps in HTML pages generated by Doxygen.
+  + typemaker2: Added support for _free-hooks, fixed many compiler
+warnings.
+  + API ADDITION: Added 2 more virtual functions to
+GWEN_MULTICACHE.
+  + Added functions
+GWEN_Param_List_Get/SetCurrentValueAsInt/Double.
+
+---

Old:

  gwenhywfar-4.13.1.tar.gz

New:

  gwenhywfar-4.14.0.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.XkprTq/_old  2015-11-22 11:02:54.0 +0100
+++ /var/tmp/diff_new_pack.XkprTq/_new  2015-11-22 11:02:54.0 +0100
@@ -17,9 +17,9 @@
 
 
 %definelibversion  60
-%define devversion 4.13
+%define devversion 4.14
 Name:   gwenhywfar
-Version:4.13.1
+Version:4.14.0
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+

++ gwenhywfar-4.13.1.tar.gz -> gwenhywfar-4.14.0.tar.gz ++
 2258 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/gwenhywfar-4.13.1/ChangeLog new/gwenhywfar-4.14.0/ChangeLog
--- old/gwenhywfar-4.13.1/ChangeLog 2015-01-03 23:47:33.0 +0100
+++ new/gwenhywfar-4.14.0/ChangeLog 2015-05-25 18:18:59.0 +0200
@@ -1,4 +1,82 @@
 --
+2015-05-25 18:18:53 +0200 Martin Preuss
+Prepared release 4.14.0.
+
+--
+2015-05-23 21:50:30 +0200 Christian Stimming
+Fix segfault on windows when using HBCI with keyfile.
+Reported by hbrunn on
+https://github.com/Gnucash/gnucash-on-windows/pull/5
+
+--
+2015-05-20 23:24:09 +0200 Martin Preuss
+Major speedup of GWEN_Directory_GetMatchingFilesRecursively().
+Don't check for duplicates when adding files or folders to the file/folder
+list. There should be no duplicate entries anyway inside a folder.
+
+--
+2015-05-17 10:22:06 +0200 Micha Lenk
+Re-work Compiler Symbol Visibility Check
+This was inspired by 
http://stackoverflow.com/questions/5987219/best-practices-for-probing-for-symbol-visibility-extensions-in-autoconf
+
+--
+2015-05-17 10:18:16 +0200 Micha Lenk
+Drop unused autoconf variable gwen_enable_export
+
+--
+2015-05-15 19:29:13 + Micha Lenk
+Fix symbol visibilty check for GCC 5.x
+GCC 5.x supports the -fvisibility=hidden flag too.
+
+--
+2015-05-14 10:20:12 +0200 Martin Preuss
+Revert "Turn compiler warning for implicit function declaration into error."
+This reverts commit 9c20b0998c5f5825ede38ff22eb1b5211eda8741 because
+"-Werror=implicit-function-declaration" doesn't exist on my
+target build system.
+
+--
+2015-05-04 00:00:03 +0200 Micha Lenk
+Revert "Disable timestamps in HTML pages generated by Doxygen"
+This reverts commit f340c4a44b4f8a5148b02be0598f2ab63c45e924.
+
+Debian's Doxygen as of version 1.8.9.1-3 will have this disabled by default, so
+this change is not needed anymore.
+

commit gwenhywfar for openSUSE:Factory

2015-04-27 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2015-04-27 13:04:35

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2015-02-05 
11:00:47.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2015-04-27 13:04:37.0 +0200
@@ -1,0 +2,6 @@
+Thu Apr 23 18:33:42 UTC 2015 - zai...@opensuse.org
+
+- Add gwenhywfar-gnutls30.patch: Fix build with gnutls30, patch
+  taken from Arch linux.
+
+---

New:

  gwenhywfar-gnutls30.patch



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.Zb31ex/_old  2015-04-27 13:04:38.0 +0200
+++ /var/tmp/diff_new_pack.Zb31ex/_new  2015-04-27 13:04:38.0 +0200
@@ -26,6 +26,8 @@
 Group:  System/Libraries
 Url:http://www.aqbanking.de/
 Source: %{name}-%{version}.tar.gz
+# PATCH-FIX-UPSTREAM gwenhywfar-gnutls30.patch zai...@opensuse.org -- Fix 
build with gnutls30, patch taken from Arch linux.
+Patch0: gwenhywfar-gnutls30.patch
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  gnutls-devel = 3.0
@@ -157,6 +159,7 @@
 %lang_package
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure\

++ gwenhywfar-gnutls30.patch ++
diff -wbBur gwenhywfar-4.13.1/src/sio/syncio_tls.c 
gwenhywfar-4.13.1.my/src/sio/syncio_tls.c
--- gwenhywfar-4.13.1/src/sio/syncio_tls.c  2014-10-12 17:12:22.0 
+0400
+++ gwenhywfar-4.13.1.my/src/sio/syncio_tls.c   2015-04-16 14:54:53.288513328 
+0300
@@ -350,7 +350,7 @@
   }
 
   /* set default priority */
-#if 1 /* old code */
+#if 0 /* old code */
   GWEN_Gui_ProgressLog(0, GWEN_LoggerLevel_Error, I18N(Using old SSL 
preparation code.));
   rv=gnutls_set_default_priority(xio-session);
   if (rv) {



commit gwenhywfar for openSUSE:Factory

2015-02-05 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2015-02-05 11:00:44

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2015-01-03 
22:01:39.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2015-02-05 11:00:47.0 +0100
@@ -1,0 +2,11 @@
+Fri Jan 30 13:28:41 UTC 2015 - zai...@opensuse.org
+
+- Update to version 4.13.1:
+  + Add function declaration that was missing in header, as
+discovered by the additional compiler option.
+  + Turn compiler warning for implicit function declaration into
+error.
+  + Fix function name for systems without langinfo.h but with
+localcharset.h.
+
+---

Old:

  gwenhywfar-4.13.0.tar.gz

New:

  gwenhywfar-4.13.1.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.Uvidn7/_old  2015-02-05 11:00:48.0 +0100
+++ /var/tmp/diff_new_pack.Uvidn7/_new  2015-02-05 11:00:48.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -19,7 +19,7 @@
 %definelibversion  60
 %define devversion 4.13
 Name:   gwenhywfar
-Version:4.13.0
+Version:4.13.1
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+

++ gwenhywfar-4.13.0.tar.gz - gwenhywfar-4.13.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gwenhywfar-4.13.0/ChangeLog 
new/gwenhywfar-4.13.1/ChangeLog
--- old/gwenhywfar-4.13.0/ChangeLog 2014-12-31 14:37:12.0 +0100
+++ new/gwenhywfar-4.13.1/ChangeLog 2015-01-03 23:47:33.0 +0100
@@ -1,4 +1,26 @@
 --
+2015-01-03 23:47:21 +0100 Martin Preuss
+Prepared release 4.13.1
+
+--
+2015-01-03 21:46:19 +0100 Christian Stimming
+Add function declaration that was missing in header, as discovered by the 
additional compiler option.
+
+--
+2015-01-03 21:45:56 +0100 Christian Stimming
+Turn compiler warning for implicit function declaration into error.
+This avoids running into the error of 769ab05bb3 again.
+
+--
+2015-01-03 21:42:31 +0100 Christian Stimming
+Fix function name for systems without langinfo.h but with localcharset.h
+This is a bugfix for 66521660959.
+
+--
+2015-01-02 21:31:10 +0100 Martin Preuss
+Prepared release 4.13.0
+
+--
 2014-12-29 07:54:55 +0100 Elias Oltmanns
 gui: Restore compilation without libiconv.
 
@@ -614,32 +636,3 @@
 
 
 git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2267 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2013-11-24 00:02:08 + martin
-Added explanation and changed gnutls version check.
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2266 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2013-11-23 12:04:15 + martin
-Fixed a typo, according to MK.
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2265 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2013-11-18 20:52:34 + martin
-Fix build issues with mingw with recent MinGW versions.
-Patch supplied by geert.
-
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2264 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2013-11-18 19:50:55 + martin
-Tried removing unsafe ciphers.
-Applied a modification of a patch submitted by MK.
-
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2263 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2013-10-28 20:16:04 + martin
-Added (deactivated) code to use ca-certificates from target system.
-git-svn-id: 

commit gwenhywfar for openSUSE:Factory

2015-01-03 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2015-01-03 22:01:18

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2014-04-26 
10:02:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2015-01-03 22:01:39.0 +0100
@@ -1,0 +2,6 @@
+Sat Jan  3 11:41:27 UTC 2015 - jcnen...@gmail.com
+
+- Update to version 4.13.0
+  + Some bugfixes, stable version
+
+---

Old:

  gwenhywfar-4.12.0beta.tar.gz

New:

  gwenhywfar-4.13.0.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.w5LOrh/_old  2015-01-03 22:01:40.0 +0100
+++ /var/tmp/diff_new_pack.w5LOrh/_new  2015-01-03 22:01:40.0 +0100
@@ -17,8 +17,9 @@
 
 
 %definelibversion  60
+%define devversion 4.13
 Name:   gwenhywfar
-Version:4.12.0beta
+Version:4.13.0
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+
@@ -264,6 +265,9 @@
 %{_libdir}/pkgconfig/gwengui-gtk2.pc
 %{_libdir}/pkgconfig/gwengui-qt4.pc
 %{_libdir}/pkgconfig/gwengui-fox16.pc
+%dir %{_libdir}/cmake
+%{_libdir}/cmake/%{name}-%{devversion}
+%{_libdir}/cmake/gwengui-qt4-%{devversion}
 
 %files lang -f %{name}.lang
 

++ gwenhywfar-4.12.0beta.tar.gz - gwenhywfar-4.13.0.tar.gz ++
 83830 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gwenhywfar for openSUSE:Factory

2014-04-26 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2014-04-26 10:02:21

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2014-03-04 
13:26:59.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2014-04-26 10:02:22.0 +0200
@@ -1,0 +2,6 @@
+Fri Apr 18 22:05:36 UTC 2014 - jcnen...@gmail.com
+
+- Update to version 4.12.0beta
+  + Fixes a bug in calculating quarter's beginning and end
+
+---

Old:

  gwenhywfar-4.11.0beta.tar.gz

New:

  gwenhywfar-4.12.0beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.840pf9/_old  2014-04-26 10:02:23.0 +0200
+++ /var/tmp/diff_new_pack.840pf9/_new  2014-04-26 10:02:23.0 +0200
@@ -18,7 +18,7 @@
 
 %definelibversion  60
 Name:   gwenhywfar
-Version:4.11.0beta
+Version:4.12.0beta
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+

++ gwenhywfar-4.11.0beta.tar.gz - gwenhywfar-4.12.0beta.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gwenhywfar-4.11.0beta/ChangeLog 
new/gwenhywfar-4.12.0beta/ChangeLog
--- old/gwenhywfar-4.11.0beta/ChangeLog 2014-03-02 15:52:43.0 +0100
+++ new/gwenhywfar-4.12.0beta/ChangeLog 2014-04-17 21:58:20.0 +0200
@@ -1,6 +1,43 @@
 --
-2014-03-02 15:52:35 +0100 Martin Preuss
+2014-04-17 21:58:14 +0200 Martin Preuss
+Prepared release 4.12.0beta.
+
+--
+2014-04-17 21:58:03 +0200 Martin Preuss
+Added function GWEN_Url_toUiShortString().
+
+--
+2014-04-15 21:42:11 + martin
+Fixed a bug in quarter year calculations.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2308 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2014-04-07 18:08:31 + martin
+Prepared release 4.11.1beta.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2307 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2014-04-06 08:40:58 + christian
+Fix GWEN_FORMAT macro: Empty macro must still consume the arguments, otherwise 
we get a syntax error.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2306 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2014-04-06 08:25:06 + christian
+Disable the __attribut__ format for mingw32 build.
+This broke the gnucash native mingw32 build, see
+https://github.com/Gnucash/gnucash/commit/4e5e0621322147ff6ada9d72ace36e213dec61c7
+
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2305 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2014-03-31 21:52:44 + martin
+Fixed a memory leak.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2304 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2014-03-31 21:52:22 + martin
 Prepared release 4.11.0beta.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2303 
70169cfe-8b10-0410-8925-dcb4b91034d8
 
 --
 2014-03-01 19:12:49 + martin
@@ -644,40 +681,3 @@
 2013-05-08 22:20:59 + martin
 Added callback functions for GWEN_MULTICACHE to GWEN_BUFFER.
 git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2211 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2013-05-08 22:20:54 + martin
-Only not to forget this...
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2210 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2013-05-08 20:50:05 + martin
-Started working on GWEN_MULTICACHE.
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2209 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2013-05-08 20:49:59 + martin
-GWEN_SLOT: Added attribute GWENHYWFAR_CB to slot callback.
-Adapted typemaker2 to reflect that change.
-
-git-svn-id: 

commit gwenhywfar for openSUSE:Factory

2014-03-04 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2014-03-04 13:26:58

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2014-02-18 
14:44:33.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2014-03-04 13:26:59.0 +0100
@@ -1,0 +2,6 @@
+Mon Mar  3 09:53:52 UTC 2014 - jcnen...@gmail.com
+
+- Update to version 4.11.0beta
+  + Bugfixes by Elias Oltmanns
+
+---

Old:

  gwenhywfar-4.10.0beta.tar.gz

New:

  gwenhywfar-4.11.0beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.bozawo/_old  2014-03-04 13:27:00.0 +0100
+++ /var/tmp/diff_new_pack.bozawo/_new  2014-03-04 13:27:00.0 +0100
@@ -18,7 +18,7 @@
 
 %definelibversion  60
 Name:   gwenhywfar
-Version:4.10.0beta
+Version:4.11.0beta
 Release:0
 Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+

++ gwenhywfar-4.10.0beta.tar.gz - gwenhywfar-4.11.0beta.tar.gz ++
 1839 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gwenhywfar for openSUSE:Factory

2014-02-18 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2014-02-18 14:44:31

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2014-01-14 
21:46:08.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2014-02-18 14:44:33.0 +0100
@@ -1,0 +2,9 @@
+Sun Feb  9 19:55:20 UTC 2014 - jcnen...@gmail.com
+
+- Update to version 4.10.0beta
+  + Add functions for individual plugin paths for other libraries
+- Create Fox16 GUI
+- Move documentation to separate package to enable multi-version
+  coexistence of the library
+
+---

Old:

  gwenhywfar-4.9.0beta.tar.gz

New:

  gwenhywfar-4.10.0beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.WLi1aP/_old  2014-02-18 14:44:34.0 +0100
+++ /var/tmp/diff_new_pack.WLi1aP/_new  2014-02-18 14:44:34.0 +0100
@@ -16,26 +16,32 @@
 #
 
 
+%definelibversion  60
 Name:   gwenhywfar
-Version:4.9.0beta
+Version:4.10.0beta
 Release:0
-Summary:Multiplatform Helper Library for Other Libraries
+Summary:Multiplatform helper library for other libraries
 License:GPL-2.0+ and LGPL-2.1+
 Group:  System/Libraries
 Url:http://www.aqbanking.de/
 Source: %{name}-%{version}.tar.gz
-#Source: 
http://www.aquamaniac.de/sites/download/download.php?package=01release=72file=01dummy=gwenhywfar-4.9.0beta.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
-BuildRequires:  gnutls-devel
-BuildRequires:  gtk2-devel
-BuildRequires:  libgcrypt-devel
+BuildRequires:  gnutls-devel = 3.0
+BuildRequires:  gtk2-devel = 1.4
+BuildRequires:  libgcrypt-devel = 1.2.0
 BuildRequires:  libopenssl-devel
 BuildRequires:  libqt4-devel
+%if 0%{?fedora} == 15
+BuildRequires:  fox-devel = 1.6
+%else
+BuildRequires:  fox16-devel
+%endif
 # For doc graphs
 BuildRequires:  graphviz
 BuildRequires:  graphviz-gd
 BuildRequires:  xorg-x11-fonts
+Recommends: lib%{name}%{libversion}
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -58,35 +64,41 @@
 configuration files, reading and writing of XML files, and interprocess
 communication).
 
-%package -n libgwenhywfar60-plugins
+%package -n lib%{name}%{libversion}-plugins
 Summary:Multiplatform Helper Library for Other Libraries - Plugins
 License:LGPL-2.1+
 Group:  System/Libraries
 Requires:   %{name} = %{version}
 
-%description -n libgwenhywfar60-plugins
+%description -n lib%{name}%{libversion}-plugins
 Gwenhywfar is a base library used to provide OS abstraction functions
 for Linux, FreeBSD, OpenBSD, NetBSD, and Windows. It also includes
 some often needed functions (for example, for handling and parsing of
 configuration files, reading and writing of XML files, and interprocess
 communication).
 
-%package -n libgwenhywfar60
+%package -n lib%{name}%{libversion}
 Summary:Multiplatform Helper Library for Other Libraries
 License:LGPL-2.1+
 Group:  System/Libraries
 Recommends: %{name}-lang
-# Needed to make lang package installable
-Provides:   %{name} = %{version}
-Recommends: libgwenhywfar60-plugins = %{version}
+Recommends: lib%{name}%{libversion}-plugins = %{version}
 
-%description -n libgwenhywfar60
+%description -n lib%{name}%{libversion}
 Gwenhywfar is a base library used to provide OS abstraction functions
 for Linux, FreeBSD, OpenBSD, NetBSD, and Windows. It also includes
 some often needed functions (for example, for handling and parsing of
 configuration files, reading and writing of XML files, and interprocess
 communication).
 
+%package -n libgwengui-cpp0
+Summary:C++ interface for Gwenhywfar
+License:GPL-2.0+ and LGPL-2.1+
+Group:  System/Libraries
+
+%description -n libgwengui-cpp0
+This package contains the C++ GUI interface for Gwenhywfar.
+
 %package -n libgwengui-gtk2-0
 Summary:Multiplatform Helper Library for Other Libraries -- GTK+ UI 
Backend
 License:LGPL-2.1+
@@ -115,14 +127,24 @@
 
 This package provides the Qt implementation of the generic UI toolkit.
 
+%package -n libgwengui-fox16-0
+Summary:FOX interface for Gwenhywfar
+License:GPL-2.0+ and LGPL-2.1+
+Group:  System/Libraries
+
+%description -n libgwengui-fox16-0
+This package contains the interface to the FOX toolkit
+for Gwenhywfar.
+
 %package devel
 Summary:Multi-Platform Helper Library for Other Libraries
 License: 

commit gwenhywfar for openSUSE:Factory

2014-01-14 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2014-01-14 21:46:06

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2013-11-01 
17:41:35.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2014-01-14 21:46:08.0 +0100
@@ -1,0 +2,9 @@
+Mon Jan  6 21:31:06 UTC 2014 - nico.kru...@gmail.com
+
+- Update to version 4.9.0beta:
+  + adds new code for cipher selection with SSL connections
+(still some problems with the Netbank, please report back)
+  + Netbank works setting the GWEN_TLS_CIPHER_PRIORITIES
+environment variable to NORMAL:-AES-256-CBC
+
+---

Old:

  gwenhywfar-4.8.0beta.tar.gz

New:

  gwenhywfar-4.9.0beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.YP4iyY/_old  2014-01-14 21:46:09.0 +0100
+++ /var/tmp/diff_new_pack.YP4iyY/_new  2014-01-14 21:46:09.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,14 @@
 
 
 Name:   gwenhywfar
-Version:4.8.0beta
+Version:4.9.0beta
 Release:0
 Summary:Multiplatform Helper Library for Other Libraries
 License:GPL-2.0+ and LGPL-2.1+
 Group:  System/Libraries
 Url:http://www.aqbanking.de/
 Source: %{name}-%{version}.tar.gz
-#Source:
http://www.aquamaniac.de/sites/download/download.php?package=01release=67file=01dummy=gwenhywfar-4.3.3.tar.gz
+#Source: 
http://www.aquamaniac.de/sites/download/download.php?package=01release=72file=01dummy=gwenhywfar-4.9.0beta.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  gnutls-devel

++ gwenhywfar-4.8.0beta.tar.gz - gwenhywfar-4.9.0beta.tar.gz ++
 31005 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gwenhywfar for openSUSE:Factory

2013-11-01 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2013-11-01 17:41:34

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2013-09-02 
16:49:26.0 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2013-11-01 17:41:35.0 +0100
@@ -1,0 +2,9 @@
+Wed Oct 23 14:42:06 UTC 2013 - nico.kru...@gmail.com
+
+- Update to version 4.8.0beta:
+  + new functions to work with dates (module GWEN_DATE,
+e.g.  GWEN_Date_GetLastHalfYearStart())
+  + fix some errors in the layout of the  FOX 1.6 GUI module.
+  + some improvements in typemaker2. 
+
+---

Old:

  gwenhywfar-4.7.0beta.tar.gz

New:

  gwenhywfar-4.8.0beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.LXT4h3/_old  2013-11-01 17:41:36.0 +0100
+++ /var/tmp/diff_new_pack.LXT4h3/_new  2013-11-01 17:41:36.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   gwenhywfar
-Version:4.7.0beta
+Version:4.8.0beta
 Release:0
 Summary:Multiplatform Helper Library for Other Libraries
 License:GPL-2.0+ and LGPL-2.1+

++ gwenhywfar-4.7.0beta.tar.gz - gwenhywfar-4.8.0beta.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gwenhywfar-4.7.0beta/ChangeLog 
new/gwenhywfar-4.8.0beta/ChangeLog
--- old/gwenhywfar-4.7.0beta/ChangeLog  2013-08-21 18:14:08.0 +0200
+++ new/gwenhywfar-4.8.0beta/ChangeLog  2013-10-22 20:24:13.0 +0200
@@ -1,4 +1,53 @@
 --
+2013-10-22 20:24:06 +0200 Martin Preuss
+Prepared release 4.8.0beta.
+
+--
+2013-10-22 20:20:59 +0200 Martin Preuss
+Fixed typos.
+
+--
+2013-10-04 21:12:34 + martin
+Filled gwen_bindata.tm2 with life.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2251 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2013-09-29 16:57:41 + martin
+Added function GWEN_StringList2_GetStringAt().
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2250 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2013-09-21 23:46:07 + martin
+Added some convenience functions to GWEN_DATE module.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2249 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2013-09-21 15:56:29 + martin
+Fixed typemaker2 bindings for GWEN_STRINGLIST2.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2248 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2013-09-21 15:41:17 + martin
+Make GWEN_StringList2 available to typemaker2.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2247 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2013-08-23 11:29:03 + martin
+Incremented version.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2246 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2013-08-23 11:27:45 + martin
+FOX16-GUI: Fixed some layout issues.
+FOX-Dialogs should now resize themselves to reasonable sizes, unless the
+dimensions are read from a configuration.
+
+FOX16_HtmlLabel now determines its size only once per text, if no special
+flags are given. This makes the behaviour more predictable.
+
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2245 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
 2013-08-21 15:44:54 + martin
 Prepared release 3.7.0beta.
 git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2244 
70169cfe-8b10-0410-8925-dcb4b91034d8
@@ -573,65 +622,3 @@
 2012-11-27 18:33:21 + martin
 Added an example for virtual functions.
 git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2154 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2012-10-30 10:02:53 + christian
-Fix mismatch of static attribute at declaration and definition of function.
-However, both static and also the GWENHYWFAR_CB macro is not yet
-used 

commit gwenhywfar for openSUSE:Factory

2013-09-02 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2013-09-02 16:49:24

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2013-03-08 
09:13:10.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2013-09-02 16:49:26.0 +0200
@@ -1,0 +2,23 @@
+Wed Aug 21 19:57:46 UTC 2013 - nico.kru...@gmail.com
+
+- Update to version 4.7.0beta:
+  + contains improvements if the TypeMaker2 tool
+  + fixes an error linking libgpg-error.so
+  + adds some functions to the GWEN_XML and GWEN_DATE modules
+used by the new AqBanking version 5.0.31beta
+  + Info: this is still beta because the MULTICACHE module is
+still work in progress
+
+---
+Sun Jun 23 11:09:55 UTC 2013 - nico.kru...@gmail.com
+
+- Update to version 4.6.0beta:
+  + adds a new module for cache handling and some widely used
+functionality
+  + major (internal) improvements to typemaker2
+  + complete German translation (thanks to Christian)
+- Update to version 4.5.0beta:
+  + adds some small changes for SEPA transactions needed by
+aqbanking
+
+---

Old:

  gwenhywfar-4.3.3.tar.gz

New:

  gwenhywfar-4.7.0beta.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.scb9EX/_old  2013-09-02 16:49:27.0 +0200
+++ /var/tmp/diff_new_pack.scb9EX/_new  2013-09-02 16:49:27.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gwenhywfar
-Version:4.3.3
+Version:4.7.0beta
 Release:0
 Summary:Multiplatform Helper Library for Other Libraries
 License:GPL-2.0+ and LGPL-2.1+
@@ -194,6 +194,7 @@
 %defattr (-, root, root)
 %doc AUTHORS COPYING ChangeLog NEWS README TODO
 %{_libdir}/libgwenhywfar.so.*
+%{_libdir}/libgwengui-cpp.so.*
 %dir %{_datadir}/gwenhywfar/
 %{_datadir}/gwenhywfar/ca-bundle.crt
 %{_datadir}/gwenhywfar/dialogs/

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gwenhywfar for openSUSE:Factory

2013-03-08 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2013-03-08 09:13:08

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2012-07-16 
09:21:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2013-03-08 09:13:10.0 +0100
@@ -1,0 +2,5 @@
+Sat Mar  2 08:18:17 UTC 2013 - co...@suse.com
+
+- update license to new format
+
+---



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.NHDH1S/_old  2013-03-08 09:13:11.0 +0100
+++ /var/tmp/diff_new_pack.NHDH1S/_new  2013-03-08 09:13:11.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,7 +20,7 @@
 Version:4.3.3
 Release:0
 Summary:Multiplatform Helper Library for Other Libraries
-License:GPL-2.0+ ; LGPL-2.1+
+License:GPL-2.0+ and LGPL-2.1+
 Group:  System/Libraries
 Url:http://www.aqbanking.de/
 Source: %{name}-%{version}.tar.gz
@@ -47,7 +47,7 @@
 
 %package tools
 Summary:Multiplatform Helper Library for Other Libraries - Tools
-License:GPL-2.0+ ; LGPL-2.1+
+License:GPL-2.0+ and LGPL-2.1+
 Group:  System/Libraries
 Requires:   libgwenhywfar60 = %{version}
 

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gwenhywfar for openSUSE:Factory

2012-07-16 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2012-07-16 09:21:02

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2012-05-21 
07:25:18.0 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2012-07-16 09:21:04.0 +0200
@@ -1,0 +2,6 @@
+Tue Jul  3 11:20:52 UTC 2012 - a...@suse.de
+
+- Change lang package Requires to Recommends since it is not
+  mandatory at runtime.
+
+---



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.6I2RAW/_old  2012-07-16 09:21:05.0 +0200
+++ /var/tmp/diff_new_pack.6I2RAW/_new  2012-07-16 09:21:05.0 +0200
@@ -75,7 +75,7 @@
 Summary:Multiplatform Helper Library for Other Libraries
 License:LGPL-2.1+
 Group:  System/Libraries
-Requires:   %{name}-lang = %{version}
+Recommends: %{name}-lang
 # Needed to make lang package installable
 Provides:   %{name} = %{version}
 Recommends: libgwenhywfar60-plugins = %{version}

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gwenhywfar for openSUSE:Factory

2012-05-20 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2012-05-21 07:25:13

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2012-03-17 
13:21:44.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2012-05-21 07:25:18.0 +0200
@@ -1,0 +2,7 @@
+Wed May  9 20:35:41 UTC 2012 - nico.laus.2...@gmx.de
+
+- Update to version 4.3.3:
+  + do not use the deprecated libgcrypt interface for RSA keys
+anymore (allows compilation with newer libgcrypt versions)
+
+---
@@ -21,2 +28,2 @@
-  + this version is needed for AqBanking's new support for the optical chipTAN
-method
+  + this version is needed for AqBanking's new support for the
+optical chipTAN method

Old:

  gwenhywfar-4.3.2.tar.gz

New:

  gwenhywfar-4.3.3.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.NsprwW/_old  2012-05-21 07:25:20.0 +0200
+++ /var/tmp/diff_new_pack.NsprwW/_new  2012-05-21 07:25:20.0 +0200
@@ -16,16 +16,15 @@
 #
 
 
-
 Name:   gwenhywfar
-Version:4.3.2
-Release:1
-License:GPL-2.0+ ; LGPL-2.1+
+Version:4.3.3
+Release:0
 Summary:Multiplatform Helper Library for Other Libraries
-Url:http://www.aqbanking.de/
+License:GPL-2.0+ ; LGPL-2.1+
 Group:  System/Libraries
+Url:http://www.aqbanking.de/
 Source: %{name}-%{version}.tar.gz
-#Source:
http://www.aquamaniac.de/sites/download/download.php?package=01release=66file=01dummy=gwenhywfar-4.3.2.tar.gz
+#Source:
http://www.aquamaniac.de/sites/download/download.php?package=01release=67file=01dummy=gwenhywfar-4.3.3.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  gnutls-devel
@@ -47,9 +46,9 @@
 communication).
 
 %package tools
+Summary:Multiplatform Helper Library for Other Libraries - Tools
 License:GPL-2.0+ ; LGPL-2.1+
 Group:  System/Libraries
-Summary:Multiplatform Helper Library for Other Libraries - Tools
 Requires:   libgwenhywfar60 = %{version}
 
 %description tools
@@ -60,9 +59,9 @@
 communication).
 
 %package -n libgwenhywfar60-plugins
+Summary:Multiplatform Helper Library for Other Libraries - Plugins
 License:LGPL-2.1+
 Group:  System/Libraries
-Summary:Multiplatform Helper Library for Other Libraries - Plugins
 Requires:   %{name} = %{version}
 
 %description -n libgwenhywfar60-plugins
@@ -73,9 +72,9 @@
 communication).
 
 %package -n libgwenhywfar60
+Summary:Multiplatform Helper Library for Other Libraries
 License:LGPL-2.1+
 Group:  System/Libraries
-Summary:Multiplatform Helper Library for Other Libraries
 Requires:   %{name}-lang = %{version}
 # Needed to make lang package installable
 Provides:   %{name} = %{version}
@@ -89,9 +88,9 @@
 communication).
 
 %package -n libgwengui-gtk2-0
+Summary:Multiplatform Helper Library for Other Libraries -- GTK+ UI 
Backend
 License:LGPL-2.1+
 Group:  System/Libraries
-Summary:Multiplatform Helper Library for Other Libraries -- GTK+ UI 
Backend
 
 %description -n libgwengui-gtk2-0
 Gwenhywfar is a base library used to provide OS abstraction functions
@@ -103,9 +102,9 @@
 This package provides the GTK+ implementation of the generic UI toolkit.
 
 %package -n libgwengui-qt4-0
+Summary:Multiplatform Helper Library for Other Libraries -- Qt UI 
Backend
 License:LGPL-2.1+
 Group:  System/Libraries
-Summary:Multiplatform Helper Library for Other Libraries -- Qt UI 
Backend
 
 %description -n libgwengui-qt4-0
 Gwenhywfar is a base library used to provide OS abstraction functions
@@ -117,13 +116,13 @@
 This package provides the Qt implementation of the generic UI toolkit.
 
 %package devel
+Summary:Multi-Platform Helper Library for Other Libraries
 License:LGPL-2.1+
 Group:  Development/Libraries/C and C++
-Summary:Multi-Platform Helper Library for Other Libraries
+Requires:   glibc-devel
 Requires:   libgwengui-gtk2-0 = %{version}
 Requires:   libgwengui-qt4-0 = %{version}
 Requires:   libgwenhywfar60 = %{version}
-Requires:   glibc-devel
 
 %description devel
 Gwenhywfar is a base library used to provide OS abstraction functions

++ gwenhywfar-4.3.2.tar.gz - gwenhywfar-4.3.3.tar.gz ++
 1739 lines of diff 

commit gwenhywfar for openSUSE:Factory

2012-03-17 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2012-03-17 13:21:42

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2012-01-11 
15:37:40.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2012-03-17 13:21:44.0 +0100
@@ -1,0 +2,6 @@
+Fri Mar  9 07:37:01 UTC 2012 - nico.laus.2...@gmx.de
+
+- Update to version 4.3.2:
+  + fixes network problems on Windows
+
+---

Old:

  gwenhywfar-4.3.1.tar.gz

New:

  gwenhywfar-4.3.2.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.q9VG7K/_old  2012-03-17 13:21:54.0 +0100
+++ /var/tmp/diff_new_pack.q9VG7K/_new  2012-03-17 13:21:54.0 +0100
@@ -18,14 +18,14 @@
 
 
 Name:   gwenhywfar
-Version:4.3.1
+Version:4.3.2
 Release:1
 License:GPL-2.0+ ; LGPL-2.1+
 Summary:Multiplatform Helper Library for Other Libraries
 Url:http://www.aqbanking.de/
 Group:  System/Libraries
 Source: %{name}-%{version}.tar.gz
-#Source:
http://www2.aquamaniac.de/sites/download/download.php?package=01release=65file=01dummy=gwenhywfar-4.3.1.tar.gz
+#Source:
http://www.aquamaniac.de/sites/download/download.php?package=01release=66file=01dummy=gwenhywfar-4.3.2.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  gnutls-devel

++ gwenhywfar-4.3.1.tar.gz - gwenhywfar-4.3.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/gwenhywfar-4.3.1/ChangeLog 
new/gwenhywfar-4.3.2/ChangeLog
--- old/gwenhywfar-4.3.1/ChangeLog  2011-12-17 17:33:46.0 +0100
+++ new/gwenhywfar-4.3.2/ChangeLog  2012-03-06 22:56:00.0 +0100
@@ -1,4 +1,29 @@
 --
+2012-03-06 21:55:57 + martin
+Prepared release 4.3.2.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2136 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2012-03-06 21:55:52 + martin
+Fixed a typo which could crash an application.
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2135 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2012-03-02 23:12:33 + martin
+Fixed a problem with GWEN_SYNCIO files on win32.
+Open files need to have the status connected, otherwise AqBanking's
+importers will bail out...
+
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2134 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
+2012-01-20 18:03:48 + martin
+Adapted to latest gcc.
+Idea provided by Bill Nottingham.
+
+git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2133 
70169cfe-8b10-0410-8925-dcb4b91034d8
+
+--
 2011-12-17 16:33:41 + martin
 Prepared 4.3.1.
 git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2132 
70169cfe-8b10-0410-8925-dcb4b91034d8
@@ -572,27 +597,3 @@
 2011-02-15 20:40:23 + martin
 Prepared release 4.0.6.
 git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2037 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2011-02-13 21:26:20 + martin
-Updated de.po.
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2036 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2011-02-13 21:26:17 + martin
-Adapted plugin description files to latest changes.
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2035 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2011-02-13 21:26:11 + martin
-Changed I18N handling for plugin description files.
-Now we use po4a to include translations for plugin descriptions in the
-standard *.po files.
-With this change all translation is now concentrated in the *.po files.
-
-git-svn-id: https://devel.aqbanking.de/svn/gwenhywfar/trunk@2034 
70169cfe-8b10-0410-8925-dcb4b91034d8
-
---
-2011-02-13 13:12:23 + martin
-Applied a patch by Thomas Baumgart to keep the focus chain intact in QT4 GUI
-git-svn-id: 

commit gwenhywfar for openSUSE:Factory

2012-01-11 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2012-01-11 15:36:36

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2011-12-25 
17:34:45.0 +0100
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2012-01-11 15:37:40.0 +0100
@@ -1,0 +2,5 @@
+Mon Jan  2 20:35:40 UTC 2012 - nico.laus.2...@gmx.de
+
+- included %{_datadir}/aclocal in the devel package
+
+---



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.whQqlT/_old  2012-01-11 15:37:45.0 +0100
+++ /var/tmp/diff_new_pack.whQqlT/_new  2012-01-11 15:37:45.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package gwenhywfar
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -213,6 +213,7 @@
 %files devel
 %defattr (-, root, root)
 %{_bindir}/gwenhywfar-config
+%dir %{_datadir}/aclocal
 %{_datadir}/aclocal/gwenhywfar.m4
 %doc %{_datadir}/gwenhywfar/apidoc/
 %{_includedir}/gwenhywfar4/

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gwenhywfar for openSUSE:Factory

2011-12-25 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2011-12-25 17:34:44

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar, Maintainer is gnome-maintain...@suse.de

Changes:

--- /work/SRC/openSUSE:Factory/gwenhywfar/gwenhywfar.changes2011-10-02 
10:12:34.0 +0200
+++ /work/SRC/openSUSE:Factory/.gwenhywfar.new/gwenhywfar.changes   
2011-12-25 17:34:45.0 +0100
@@ -1,0 +2,13 @@
+Tue Dec 20 08:39:50 UTC 2011 - nico.laus.2...@gmx.de
+
+- removed gwenhywfar-gnutls-3.0.3.patch (fixed upstream in 4.3.1)
+
+---
+Mon Dec 19 23:11:41 UTC 2011 - nico.laus.2...@gmx.de
+
+- Update to version 4.3.1:
+  + this version is needed for AqBanking's new support for the optical chipTAN
+method
+  + some improvements to the typemaker2 tool
+
+---

Old:

  gwenhywfar-4.3.0.tar.gz
  gwenhywfar-gnutls-3.0.3.patch

New:

  gwenhywfar-4.3.1.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.Fwo6LK/_old  2011-12-25 17:34:46.0 +0100
+++ /var/tmp/diff_new_pack.Fwo6LK/_new  2011-12-25 17:34:46.0 +0100
@@ -18,16 +18,14 @@
 
 
 Name:   gwenhywfar
-Version:4.3.0
+Version:4.3.1
 Release:1
 License:GPL-2.0+ ; LGPL-2.1+
 Summary:Multiplatform Helper Library for Other Libraries
 Url:http://www.aqbanking.de/
 Group:  System/Libraries
 Source: %{name}-%{version}.tar.gz
-#Source:
http://www2.aquamaniac.de/sites/download/download.php?package=01release=64file=01dummy=gwenhywfar-4.3.0.tar.gz
-# PATCH-FIX-UPSTREAM gwenhywfar-gnutls-3.0.3.patch vu...@opensuse.org -- Drop 
deprecated and unneeded call to gnutls_transport_set_lowat. Sent upstream by 
mail on 2011-09-28
-Patch0: gwenhywfar-gnutls-3.0.3.patch
+#Source:
http://www2.aquamaniac.de/sites/download/download.php?package=01release=65file=01dummy=gwenhywfar-4.3.1.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  gnutls-devel
@@ -137,7 +135,6 @@
 %lang_package
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 %configure\

++ gwenhywfar-4.3.0.tar.gz - gwenhywfar-4.3.1.tar.gz ++
 21853 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gwenhywfar for openSUSE:Factory

2011-12-06 Thread h_root
Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory 
checked in at 2011-12-06 18:17:43

Comparing /work/SRC/openSUSE:Factory/gwenhywfar (Old)
 and  /work/SRC/openSUSE:Factory/.gwenhywfar.new (New)


Package is gwenhywfar, Maintainer is gnome-maintain...@suse.de

Changes:




Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.Rz8m3s/_old  2011-12-06 18:27:56.0 +0100
+++ /var/tmp/diff_new_pack.Rz8m3s/_new  2011-12-06 18:27:56.0 +0100
@@ -20,7 +20,7 @@
 Name:   gwenhywfar
 Version:4.3.0
 Release:1
-License:GPL-2.0+; LGPL-2.1+
+License:GPL-2.0+ ; LGPL-2.1+
 Summary:Multiplatform Helper Library for Other Libraries
 Url:http://www.aqbanking.de/
 Group:  System/Libraries
@@ -49,7 +49,7 @@
 communication).
 
 %package tools
-License:GPL-2.0+; LGPL-2.1+
+License:GPL-2.0+ ; LGPL-2.1+
 Group:  System/Libraries
 Summary:Multiplatform Helper Library for Other Libraries - Tools
 Requires:   libgwenhywfar60 = %{version}

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit gwenhywfar for openSUSE:Factory

2011-08-12 Thread h_root

Hello community,

here is the log from the commit of package gwenhywfar for openSUSE:Factory
checked in at Fri Aug 12 16:44:49 CEST 2011.




--- gwenhywfar/gwenhywfar.changes   2011-06-11 23:09:11.0 +0200
+++ /mounts/work_src_done/STABLE/gwenhywfar/gwenhywfar.changes  2011-08-12 
13:39:23.0 +0200
@@ -1,0 +2,51 @@
+Fri Aug 12 11:37:22 UTC 2011 - dims...@opensuse.org
+
+- Add GPL-2.0+ tag to the main package and the tools subpackage, as
+  this is the correct license for the tools and related sources.
+  See also bnc#710065.
+
+---
+Tue Aug  2 09:33:34 CEST 2011 - dims...@opensuse.org
+
+- Update to version 4.2.1:
+  + Make QLabel in GUI wrap words.
+  + Relaxed http code.
+
+---
+Sat Jul 16 04:14:05 CEST 2011 - malcolmle...@opensuse.org
+
+- Update to version 4.2.0:
+  + Marked argument list of GWEN_StringList_new() as void.
+  + Added keyword void to functions with empty argument list.
+  + Let typemaker tools use void for empty argument lists in
+constructors.
+  + Added field CustomerId to GWEN_Crypt_Token_Context.
+  + Added function GWEN_DB_GetParentGroup().
+  + Added line for hasKeyNumber flag.
+  + Show customer if available.
+  + Added some tm2 files to ignore list.
+  + typemaker2: added type uint64_t.
+  + Improved and fixed GWEN_TLV, added functions
+GWEN_TLV_ReadHeader() and GWEN_TLV_WriteHeader().
+  + Started working on a simple archiver.
+  + Fixed a few bugs in new TLV code.
+  + Added tool gsa (Gwen's simple archiver).
+  + Improved HTTP handling:
+- added function GWEN_SyncIo_Http_RecvBodyToSio().
+- added function GWEN_HttpSession_RecvPacketToFile().
+  + Added function GWEN_Directory_GetAbsoluteFolderPath().
+  + Added convenience function GWEN_Sar_UnpackArchive().
+  + Added code and commands to sign a sar archive.
+  + Improved progress handling in network code.
+  + Fixed GWEN_MDigest__HashFileTree().
+  + Added missing include.
+  + Various bug fixes and code cleanup.
+- Update Url as Gwenhywfar is now being hosted at
+  http://www.aqbanking.de/.
+- Update spec file License field from LGPLv2.1+ to LGPL-2.1+ to
+  conform with spdx.org identifier.
+- Minor reformatting in spec file.
+- Remove service usage, following the new consensus on Factory
+  packaging.
+
+---

calling whatdependson for head-i586


Old:

  _service
  _service:recompress:download_url:gwenhywfar-4.1.0.tar.bz2

New:

  gwenhywfar-4.2.1.tar.gz



Other differences:
--
++ gwenhywfar.spec ++
--- /var/tmp/diff_new_pack.byeZoz/_old  2011-08-12 16:13:43.0 +0200
+++ /var/tmp/diff_new_pack.byeZoz/_new  2011-08-12 16:13:43.0 +0200
@@ -15,17 +15,17 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
 
 
 Name:   gwenhywfar
-Version:4.1.0
+Version:4.2.1
 Release:1
-Url:http://gwenhywfar.sourceforge.net/
-Group:  System/Libraries
-License:LGPLv2.1+
+License:GPL-2.0+; LGPL-2.1+
 Summary:Multiplatform Helper Library for Other Libraries
-Source: %{name}-%{version}.tar.bz2
+Url:http://www.aqbanking.de/
+Group:  System/Libraries
+Source: %{name}-%{version}.tar.gz
+#Source:
http://www2.aquamaniac.de/sites/download/download.php?package=01release=62file=01dummy=gwenhywfar-4.2.0.tar.gz
 BuildRequires:  doxygen
 BuildRequires:  fdupes
 BuildRequires:  gnutls-devel
@@ -47,7 +47,7 @@
 communication).
 
 %package tools
-License:LGPLv2.1+
+License:GPL-2.0+; LGPL-2.1+
 Group:  System/Libraries
 Summary:Multiplatform Helper Library for Other Libraries - Tools
 Requires:   libgwenhywfar60 = %{version}
@@ -60,7 +60,7 @@
 communication).
 
 %package -n libgwenhywfar60-plugins
-License:LGPLv2.1+
+License:LGPL-2.1+
 Group:  System/Libraries
 Summary:Multiplatform Helper Library for Other Libraries - Plugins
 Requires:   %{name} = %{version}
@@ -73,7 +73,7 @@
 communication).
 
 %package -n libgwenhywfar60
-License:LGPLv2.1+
+License:LGPL-2.1+
 Group:  System/Libraries
 Summary:Multiplatform Helper Library for Other Libraries
 Requires:   %{name}-lang = %{version}
@@ -89,7 +89,7 @@
 communication).
 
 %package -n libgwengui-gtk2-0
-License:LGPLv2.1+
+License:LGPL-2.1+
 Group:  System/Libraries
 Summary:Multiplatform Helper Library for Other Libraries -- GTK+ UI 
Backend
 
@@ -103,7 +103,7 @@
 This package provides the GTK+ implementation of the generic UI toolkit.
 
 %package -n libgwengui-qt4-0
-License:LGPLv2.1+
+License:LGPL-2.1+
 Group:  System/Libraries
 Summary: