commit plasma-nm for openSUSE:Factory

2015-01-03 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2015-01-03 22:02:18

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2014-12-06 
13:45:31.0 +0100
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2015-01-03 
22:02:21.0 +0100
@@ -1,0 +2,24 @@
+Fri Dec 12 11:54:55 UTC 2014 - tittiatc...@gmail.com
+
+- Update to 0.9.3.5
+  - Bugfix release
+   Summary of fixed issues:
+   bko#339652 – added missing IPv6 support for OpenVPN connections
+   bko#333752 – we moved code for checking your current download/upload
+to QML code
+   bko#329837 – during import of VPN connections we copied your 
+certificates automatically into your home directory, 
+now we are asking whether you want to copy them or 
+keep the path as it is
+   bko#340306 – fixed initialization of current download/upload 
+speed for mobile broadband connections
+   bko#338513, bko#338697, bko#339223 – many fixes in secret agent 
+(KWallet) initialization, also added migration for 
+your secrets from plain text files, we dropped their
+support in the previous version, and store them into
+KWallet or directly into NetworkManager.
+(boo#909683)
+
+- Drop 0001-Add-IPv6-tab-for-OpenVPN-connections.patch due to 
+  upstream inclusion
+---

Old:

  0001-Add-IPv6-tab-for-OpenVPN-connections.patch
  plasma-nm-0.9.3.4.tar.xz

New:

  plasma-nm-0.9.3.5.tar.xz



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.BvOVy4/_old  2015-01-03 22:02:22.0 +0100
+++ /var/tmp/diff_new_pack.BvOVy4/_new  2015-01-03 22:02:22.0 +0100
@@ -17,7 +17,7 @@
 
 
 Name:   plasma-nm
-Version:0.9.3.4
+Version:0.9.3.5
 Release:0
 Summary:Plasma applet written in QML for managing network connections
 License:GPL-2.0 or GPL-3.0
@@ -26,14 +26,11 @@
 Source: 
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 Source1:icon.tar.bz2
 Source2:01-plasma-nm.js
-# PATCH-FIX-UPSTREAM 0001-Add-IPv6-tab-for-OpenVPN-connections.patch
-Patch0: 0001-Add-IPv6-tab-for-OpenVPN-connections.patch
-# PATCH-FIX-UPSTREAM openconnect-7-support.patch
 Patch1: openconnect-7-support.patch
 BuildRequires:  NetworkManager-devel = 0.9.8.0
 BuildRequires:  fdupes
 BuildRequires:  libModemManagerQt-devel = 0.7.990
-BuildRequires:  libNetworkManagerQt-devel = 0.9.8.1
+BuildRequires:  libNetworkManagerQt-devel = 0.9.8.3
 BuildRequires:  libkde4-devel = 4.9.0
 BuildRequires:  mobile-broadband-provider-info
 %if 0%{?suse_version}  1230
@@ -160,7 +157,6 @@
 
 %prep
 %setup -qn %{name}-%{version} -a 1
-%patch0 -p1
 %patch1 -p1
 
 %build

++ plasma-nm-0.9.3.4.tar.xz - plasma-nm-0.9.3.5.tar.xz ++
 27962 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit plasma-nm for openSUSE:Factory

2014-12-06 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2014-12-06 13:45:39

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2014-08-11 
10:09:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2014-12-06 
13:45:31.0 +0100
@@ -1,0 +2,11 @@
+Fri Dec  5 20:54:55 UTC 2014 - tittiatc...@gmail.com
+
+- Added openconnect-7-support.patch to support newer openconnect
+  versions
+
+---
+Tue Oct  7 19:40:05 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Added 0001-Add-IPv6-tab-for-OpenVPN-connections.patch (kde#339652)
+
+---

New:

  0001-Add-IPv6-tab-for-OpenVPN-connections.patch
  openconnect-7-support.patch



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.NzbVWk/_old  2014-12-06 13:45:33.0 +0100
+++ /var/tmp/diff_new_pack.NzbVWk/_new  2014-12-06 13:45:33.0 +0100
@@ -26,6 +26,10 @@
 Source: 
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 Source1:icon.tar.bz2
 Source2:01-plasma-nm.js
+# PATCH-FIX-UPSTREAM 0001-Add-IPv6-tab-for-OpenVPN-connections.patch
+Patch0: 0001-Add-IPv6-tab-for-OpenVPN-connections.patch
+# PATCH-FIX-UPSTREAM openconnect-7-support.patch
+Patch1: openconnect-7-support.patch
 BuildRequires:  NetworkManager-devel = 0.9.8.0
 BuildRequires:  fdupes
 BuildRequires:  libModemManagerQt-devel = 0.7.990
@@ -156,6 +160,8 @@
 
 %prep
 %setup -qn %{name}-%{version} -a 1
+%patch0 -p1
+%patch1 -p1
 
 %build
   %cmake_kde4 -d build

++ 0001-Add-IPv6-tab-for-OpenVPN-connections.patch ++
From 26c1f5fa03491298fcee2a21e53522c2f3a01ea3 Mon Sep 17 00:00:00 2001
From: Jan Grulich jgrul...@redhat.com
Date: Mon, 6 Oct 2014 09:29:14 +0200
Subject: [PATCH 1/4] Add IPv6 tab for OpenVPN connections

BUG:339652
---
 libs/editor/connectiondetaileditor.cpp | 6 --
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/libs/editor/connectiondetaileditor.cpp 
b/libs/editor/connectiondetaileditor.cpp
index 066fccc..f626ec3 100644
--- a/libs/editor/connectiondetaileditor.cpp
+++ b/libs/editor/connectiondetaileditor.cpp
@@ -40,6 +40,7 @@
 #include settings/vlanwidget.h
 #include settings/wimaxwidget.h
 #include vpnuiplugin.h
+#include vpn/openvpn/nm-openvpn-service.h
 
 #include QDebug
 
@@ -269,6 +270,7 @@ void ConnectionDetailEditor::initTabs()
 const NetworkManager::ConnectionSettings::ConnectionType type = 
m_connection-connectionType();
 
 // setup the widget tabs
+QString serviceType;
 if (type == NetworkManager::ConnectionSettings::Wired) {
 WiredConnectionWidget * wiredWidget = new 
WiredConnectionWidget(m_connection-setting(NetworkManager::Setting::Wired), 
this);
 m_ui-tabWidget-addTab(wiredWidget, i18n(Wired));
@@ -325,7 +327,6 @@ void ConnectionDetailEditor::initTabs()
 if (!vpnSetting) {
 qDebug()  Missing VPN setting!;
 } else {
-QString serviceType;
 if (m_new  !m_vpnType.isEmpty()) {
 serviceType = m_vpnType;
 vpnSetting-setServiceType(serviceType);
@@ -366,7 +367,8 @@ void ConnectionDetailEditor::initTabs()
  || type == ConnectionSettings::Wimax
  || type == ConnectionSettings::Bond
  || type == ConnectionSettings::Bridge
- || type == ConnectionSettings::Vlan)  !isSlave()) {
+ || type == ConnectionSettings::Vlan
+ || (type == ConnectionSettings::Vpn  serviceType == 
QLatin1String(NM_DBUS_SERVICE_OPENVPN)))  !isSlave()) {
 IPv6Widget * ipv6Widget = new 
IPv6Widget(m_connection-setting(NetworkManager::Setting::Ipv6), this);
 m_ui-tabWidget-addTab(ipv6Widget, i18n(IPv6));
 }
-- 
2.1.1

++ openconnect-7-support.patch ++
commit 3e6585fa4dd2fb3d9b59c7704bd3d7ae5b2c4167
Author: David Woodhouse david.woodho...@intel.com
Date:   Wed Dec 3 15:10:44 2014 +0100

Update OpenConnect support for library version 5

String ownership rules are now very simple: the library never takes 
ownership
of a string it's passed. It always takes its *own* copy and is responsible
for freeing that. Mostly driven by Windows DLL Hell where it's painful to
allocate in one library and free in another because they might actually be
using different heaps.

Also adapt to the changes in server certificate hash handling. We are no
longer supposed to just compare strings, and must call the 

commit plasma-nm for openSUSE:Factory

2014-08-11 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2014-08-11 10:09:41

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2014-04-25 
11:35:06.0 +0200
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2014-08-11 
10:09:46.0 +0200
@@ -1,0 +2,9 @@
+Wed Aug  6 20:48:17 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 0.9.3.4
+  - Bugfix release
+  - Improved support for NetworkManager 0.9.10.0
+- Drop openconnect.patch, upstreamed
+- Adjust Source URL
+
+---

Old:

  openconnect.patch
  plasma-nm-0.9.3.3.tar.xz

New:

  plasma-nm-0.9.3.4.tar.xz



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.GUViXE/_old  2014-08-11 10:09:46.0 +0200
+++ /var/tmp/diff_new_pack.GUViXE/_new  2014-08-11 10:09:46.0 +0200
@@ -17,16 +17,15 @@
 
 
 Name:   plasma-nm
-Version:0.9.3.3
+Version:0.9.3.4
 Release:0
 Summary:Plasma applet written in QML for managing network connections
 License:GPL-2.0 or GPL-3.0
 Group:  System/GUI/KDE
 Url:https://projects.kde.org/projects/playground/network/plasma-nm
-Source0:
http://download.kde.org/unstable/%{name}/%{name}-%{version}.tar.xz
+Source: 
http://download.kde.org/stable/%{name}/%{name}-%{version}.tar.xz
 Source1:icon.tar.bz2
 Source2:01-plasma-nm.js
-Patch1: openconnect.patch
 BuildRequires:  NetworkManager-devel = 0.9.8.0
 BuildRequires:  fdupes
 BuildRequires:  libModemManagerQt-devel = 0.7.990
@@ -157,9 +156,6 @@
 
 %prep
 %setup -qn %{name}-%{version} -a 1
-%if 0%{?suse_version}  1310
-%patch1 -p1
-%endif
 
 %build
   %cmake_kde4 -d build

++ plasma-nm-0.9.3.3.tar.xz - plasma-nm-0.9.3.4.tar.xz ++
 283338 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit plasma-nm for openSUSE:Factory

2014-04-25 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2014-04-25 11:35:04

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2014-03-18 
17:16:48.0 +0100
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2014-04-25 
11:35:06.0 +0200
@@ -1,0 +2,5 @@
+Fri Apr 25 01:35:26 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Manually create lang package, so it can obsolete 
NetworkManager-kde4-libs-lang
+
+---



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.ZWIzQ1/_old  2014-04-25 11:35:06.0 +0200
+++ /var/tmp/diff_new_pack.ZWIzQ1/_new  2014-04-25 11:35:06.0 +0200
@@ -143,7 +143,18 @@
 %description pptp
 pptp plugin for plasma-nm components.
 
-%lang_package
+%package lang 
+Summary:Languages for package %{name}
+Group:  System/Localization
+Requires:   %{name} = %{version}
+Provides:   %{name}-lang-all = %{version}
+Obsoletes:  NetworkManager-kde4-libs-lang
+Supplements:packageand(bundle-lang-other:%{name})
+BuildArch:  noarch
+
+%description lang
+Provides translations to the package %{name}
+
 %prep
 %setup -qn %{name}-%{version} -a 1
 %if 0%{?suse_version}  1310

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit plasma-nm for openSUSE:Factory

2014-03-18 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2014-03-18 17:16:47

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2014-02-28 
19:17:07.0 +0100
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2014-03-18 
17:16:48.0 +0100
@@ -1,0 +2,5 @@
+Fri Mar 14 14:12:48 UTC 2014 - dmitr...@opensuse.org
+
+- Set language package as recommended
+
+---
@@ -6,0 +12,2 @@
+- Added openconnect.patch to make it build with the latest
+  openconnect version

New:

  openconnect.patch



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.bOIfnD/_old  2014-03-18 17:16:49.0 +0100
+++ /var/tmp/diff_new_pack.bOIfnD/_new  2014-03-18 17:16:49.0 +0100
@@ -26,6 +26,7 @@
 Source0:
http://download.kde.org/unstable/%{name}/%{name}-%{version}.tar.xz
 Source1:icon.tar.bz2
 Source2:01-plasma-nm.js
+Patch1: openconnect.patch
 BuildRequires:  NetworkManager-devel = 0.9.8.0
 BuildRequires:  fdupes
 BuildRequires:  libModemManagerQt-devel = 0.7.990
@@ -37,18 +38,12 @@
 %endif
 Provides:   NetworkManager-client
 Recommends: %{name}-pptp
-%if 0%{?suse_version}  1310
 Obsoletes:  NetworkManager-kde4-devel
 Obsoletes:  NetworkManager-kde4-libs
 Obsoletes:  NetworkManager-novellvpn-kde4
 Obsoletes:  plasmoid-networkmanagement
-%else
-Conflicts:  NetworkManager-kde4-devel
-Conflicts:  NetworkManager-kde4-libs
-Conflicts:  NetworkManager-novellvpn-kde4
-Conflicts:  plasmoid-networkmanagement
-%endif
 Requires:   mobile-broadband-provider-info
+Recommends: %{name}-lang = %{version}
 %kde4_runtime_requires
 
 %description
@@ -61,12 +56,8 @@
 Requires:   %{name} = %{version}
 Requires:   NetworkManager-openvpn
 Provides:   NetworkManager-openvpn-frontend
-%if 0%{?suse_version}  1310
 Supplements:packageand(%{name};NetworkManager-openvpn)
 Obsoletes:  NetworkManager-openvpn-kde4
-%else
-Conflicts:  NetworkManager-openvpn-kde4
-%endif
 %kde4_runtime_requires
 
 %description openvpn
@@ -78,12 +69,8 @@
 Requires:   %{name} = %{version}
 Requires:   NetworkManager-vpnc
 Provides:   NetworkManager-vpnc-frontend
-%if 0%{?suse_version}  1310
 Supplements:packageand(%{name};NetworkManager-vpnc)
 Obsoletes:  NetworkManager-vpnc-kde4
-%else
-Conflicts:  NetworkManager-vpnc-kde4
-%endif
 %kde4_runtime_requires
 
 %description vpnc
@@ -97,12 +84,8 @@
 Requires:   NetworkManager-openconnect
 Requires:   openconnect
 Provides:   NetworkManager-openconnect-frontend
-%if 0%{?suse_version}  1310
 Supplements:packageand(%{name};NetworkManager-openconnect;openconnect)
 Obsoletes:  NetworkManager-openconnect-kde4
-%else
-Conflicts:  NetworkManager-openconnect-kde4
-%endif
 %kde4_runtime_requires
 
 %description openconnect
@@ -153,12 +136,8 @@
 Requires:   %{name} = %{version}
 Requires:   NetworkManager-pptp
 Provides:   NetworkManager-pptp-frontend
-%if 0%{?suse_version}  1310
 Supplements:packageand(%{name};NetworkManager-pptp)
 Obsoletes:  NetworkManager-pptp-kde4
-%else
-Conflicts:  NetworkManager-pptp-kde4
-%endif
 %kde4_runtime_requires
 
 %description pptp
@@ -167,6 +146,9 @@
 %lang_package
 %prep
 %setup -qn %{name}-%{version} -a 1
+%if 0%{?suse_version}  1310
+%patch1 -p1
+%endif
 
 %build
   %cmake_kde4 -d build

++ openconnect.patch ++
diff --git a/vpn/openconnect/openconnectauth.cpp 
b/vpn/openconnect/openconnectauth.cpp
index 33e8c93..e2eb15a 100644
--- a/vpn/openconnect/openconnectauth.cpp
+++ b/vpn/openconnect/openconnectauth.cpp
@@ -414,7 +414,7 @@ void OpenconnectAuthWidget::processAuthForm(struct 
oc_auth_form *form)
 int passwordnumber = 0;
 bool focusSet = false;
 for (opt = form-opts; opt; opt = opt-next) {
-if (opt-type == OC_FORM_OPT_HIDDEN)
+if (opt-type == OC_FORM_OPT_HIDDEN || IGNORE_OPT(opt))
 continue;
 QLabel *text = new QLabel(this);
 text-setAlignment(Qt::AlignLeading|Qt::AlignLeft|Qt::AlignVCenter);
@@ -441,9 +441,20 @@ void OpenconnectAuthWidget::processAuthForm(struct 
oc_auth_form *form)
 KComboBox *cmb = new KComboBox(this);
 struct oc_form_opt_select *sopt = 
reinterpret_castoc_form_opt_select *(opt);
 for (int i = 0; i  sopt-nr_choices; i++) {
-cmb-addItem(QString::fromUtf8(sopt-choices[i].label), 
QString::fromUtf8(sopt-choices[i].name));
-if 

commit plasma-nm for openSUSE:Factory

2014-02-28 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2014-02-28 19:17:06

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2014-02-07 
10:27:27.0 +0100
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2014-02-28 
19:17:07.0 +0100
@@ -1,0 +2,7 @@
+Thu Feb 27 19:45:34 UTC 2014 - hrvoje.sen...@gmail.com
+
+- Update to 0.9.3.3
+  - Please see http://grulja.wordpress.com/2014/02/27/plasma-nm-is-finally-out/
+for more details
+
+---

Old:

  plasma-nm-0.9.3.2.tar.xz

New:

  plasma-nm-0.9.3.3.tar.xz



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.eq8aDS/_old  2014-02-28 19:17:08.0 +0100
+++ /var/tmp/diff_new_pack.eq8aDS/_new  2014-02-28 19:17:08.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package plasma-nm
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   plasma-nm
-Version:0.9.3.2
+Version:0.9.3.3
 Release:0
 Summary:Plasma applet written in QML for managing network connections
 License:GPL-2.0 or GPL-3.0
@@ -29,7 +29,7 @@
 BuildRequires:  NetworkManager-devel = 0.9.8.0
 BuildRequires:  fdupes
 BuildRequires:  libModemManagerQt-devel = 0.7.990
-BuildRequires:  libNetworkManagerQt-devel = 0.9.0
+BuildRequires:  libNetworkManagerQt-devel = 0.9.8.1
 BuildRequires:  libkde4-devel = 4.9.0
 BuildRequires:  mobile-broadband-provider-info
 %if 0%{?suse_version}  1230
@@ -212,7 +212,7 @@
 %{_kde4_appsdir}/plasma/plasmoids/org.kde.networkmanagement/
 %{_kde4_servicesdir}/plasma-applet-networkmanagement.desktop
 %{_kde4_modulesdir}/plugins/designer/plasmanetworkmanagementwidgets.so
-%{_kde4_appsdir}/desktoptheme/default/icons/plasma-networkmanagement.svgz
+%{_kde4_appsdir}/desktoptheme/default/icons/plasma-networkmanagement2.svgz
 %{_kde4_servicesdir}/networkmanagement_notifications.desktop
 %{_kde4_modulesdir}/networkmanagement_notifications.so
 %{_kde4_iconsdir}/hicolor/*/apps/*png

++ plasma-nm-0.9.3.2.tar.xz - plasma-nm-0.9.3.3.tar.xz ++
 120960 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit plasma-nm for openSUSE:Factory

2014-02-07 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2014-02-07 10:27:26

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2013-12-11 
14:32:24.0 +0100
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2014-02-07 
10:27:27.0 +0100
@@ -1,0 +2,6 @@
+Thu Feb 6 11:50:18 UTC 2014 - tittiatc...@gmail.com
+
+- Add mobile-broadband-provider-info as requirement (incl.
+   BuildRequire)
+
+---



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.QeYGm4/_old  2014-02-07 10:27:27.0 +0100
+++ /var/tmp/diff_new_pack.QeYGm4/_new  2014-02-07 10:27:27.0 +0100
@@ -31,6 +31,7 @@
 BuildRequires:  libModemManagerQt-devel = 0.7.990
 BuildRequires:  libNetworkManagerQt-devel = 0.9.0
 BuildRequires:  libkde4-devel = 4.9.0
+BuildRequires:  mobile-broadband-provider-info
 %if 0%{?suse_version}  1230
 BuildRequires:  pkgconfig(openconnect) = 4.00
 %endif
@@ -47,6 +48,7 @@
 Conflicts:  NetworkManager-novellvpn-kde4
 Conflicts:  plasmoid-networkmanagement
 %endif
+Requires:   mobile-broadband-provider-info
 %kde4_runtime_requires
 
 %description

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit plasma-nm for openSUSE:Factory

2013-12-11 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2013-12-11 14:32:23

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2013-10-23 
19:24:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2013-12-11 
14:32:24.0 +0100
@@ -1,0 +2,11 @@
+Tue Nov 26 00:16:26 UTC 2013 - hrvoje.sen...@gmail.com
+
+- Update to 0.9.3.2
+  - Bugfix release
+  - Improved support for HDPI displays
+  - For more details see:
+http://grulja.wordpress.com/2013/11/22/kde-pim-solid-sprint-report/
+- Droped plasma-nm-upstream-fixes.patch, included in this release
+- Bump libModemManagerQt-devel BuildRequires to = 0.7.990
+
+---

Old:

  plasma-nm-0.9.3.1.tar.xz
  plasma-nm-upstream-fixes.patch

New:

  plasma-nm-0.9.3.2.tar.xz



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.uoeAHG/_old  2013-12-11 14:32:24.0 +0100
+++ /var/tmp/diff_new_pack.uoeAHG/_new  2013-12-11 14:32:24.0 +0100
@@ -17,20 +17,18 @@
 
 
 Name:   plasma-nm
-Version:0.9.3.1
+Version:0.9.3.2
 Release:0
 Summary:Plasma applet written in QML for managing network connections
 License:GPL-2.0 or GPL-3.0
 Group:  System/GUI/KDE
 Url:https://projects.kde.org/projects/playground/network/plasma-nm
-Source0:
http://download.kde.org/unstable/plasma-nm/%{name}-%{version}.tar.xz
+Source0:
http://download.kde.org/unstable/%{name}/%{name}-%{version}.tar.xz
 Source1:icon.tar.bz2
 Source2:01-plasma-nm.js
-# PATCH-FIX-UPSTREAM  Upstream patches to fix the wrong icon when connected to 
VPN (jgrul...@redhat.com)
-Patch1: plasma-nm-upstream-fixes.patch
 BuildRequires:  NetworkManager-devel = 0.9.8.0
 BuildRequires:  fdupes
-BuildRequires:  libModemManagerQt-devel = 0.5.0
+BuildRequires:  libModemManagerQt-devel = 0.7.990
 BuildRequires:  libNetworkManagerQt-devel = 0.9.0
 BuildRequires:  libkde4-devel = 4.9.0
 %if 0%{?suse_version}  1230
@@ -167,7 +165,6 @@
 %lang_package
 %prep
 %setup -qn %{name}-%{version} -a 1
-%patch1 -p1
 
 %build
   %cmake_kde4 -d build
@@ -180,7 +177,7 @@
   %fdupes -s %{buildroot}
   mkdir -p %{buildroot}%{_kde4_iconsdir}/hicolor/32x32/apps/
   cp -r 
$RPM_BUILD_DIR/plasma-nm-%{version}/ox32-device-network-defaultroute.png 
%{buildroot}%{_kde4_iconsdir}/hicolor/32x32/apps/network-defaultroute.png
-  for translation in kcm_network kde-nm-connection-editor 
libplasmanetworkmanagement-editor plasma_applet_org.kde.networkmanagement 
plasmanetworkmanagement-kded; do
+  for translation in kde-nm-connection-editor 
libplasmanetworkmanagement-editor plasma_applet_org.kde.networkmanagement 
plasmanetworkmanagement-kded; do
%find_lang $translation %{name}.lang
   done
   for translation in l2tpui openconnectui openswanui openvpnui pptpui 
strongswanui vpncui; do

++ plasma-nm-0.9.3.1.tar.xz - plasma-nm-0.9.3.2.tar.xz ++
 87369 lines of diff (skipped)

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit plasma-nm for openSUSE:Factory

2013-10-23 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2013-10-23 19:24:46

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2013-10-17 
17:45:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2013-10-23 
19:24:47.0 +0200
@@ -1,0 +2,8 @@
+Wed Oct 23 09:34:18 UTC 2013 - tittiatc...@gmail.com
+
+- Add upstream patch plasma-nm-upstream-fixes.patch as requested
+  by Jan Grulich (author plasma-nm) to fix the VPN icon displayed
+  when connected to a VPN connection
+
+- Split out Strongswan plugin to its own sub-package. 
+---

New:

  plasma-nm-upstream-fixes.patch



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.dh1jDm/_old  2013-10-23 19:24:50.0 +0200
+++ /var/tmp/diff_new_pack.dh1jDm/_new  2013-10-23 19:24:50.0 +0200
@@ -26,6 +26,8 @@
 Source0:
http://download.kde.org/unstable/plasma-nm/%{name}-%{version}.tar.xz
 Source1:icon.tar.bz2
 Source2:01-plasma-nm.js
+# PATCH-FIX-UPSTREAM  Upstream patches to fix the wrong icon when connected to 
VPN (jgrul...@redhat.com)
+Patch1: plasma-nm-upstream-fixes.patch
 BuildRequires:  NetworkManager-devel = 0.9.8.0
 BuildRequires:  fdupes
 BuildRequires:  libModemManagerQt-devel = 0.5.0
@@ -92,10 +94,11 @@
 Summary:OpenConnect support for %{name}
 Group:  System/GUI/KDE
 Requires:   %{name} = %{version}
+Requires:   NetworkManager-openconnect
 Requires:   openconnect
 Provides:   NetworkManager-openconnect-frontend
 %if 0%{?suse_version}  1310
-Supplements:packageand(%{name};openconnect)
+Supplements:packageand(%{name};NetworkManager-openconnect;openconnect)
 Obsoletes:  NetworkManager-openconnect-kde4
 %else
 Conflicts:  NetworkManager-openconnect-kde4
@@ -119,6 +122,18 @@
 %description openswan
 Openswan plugin for plasma-nm components.
 
+%package strongswan
+Summary:Strongswan support for %{name}
+Group:  System/GUI/KDE
+Requires:   %{name} = %{version}
+Requires:   NetworkManager-strongswan
+Supplements:packageand(%{name};NetworkManager-strongswan)
+Provides:   NetworkManager-strongswan-frontend
+%kde4_runtime_requires
+
+%description strongswan
+Strongswan plugin for plasma-nm components.
+
 %package l2tp
 Summary:L2TP support for %{name}
 Group:  System/GUI/KDE
@@ -152,6 +167,7 @@
 %lang_package
 %prep
 %setup -qn %{name}-%{version} -a 1
+%patch1 -p1
 
 %build
   %cmake_kde4 -d build
@@ -173,7 +189,6 @@
   mkdir -p %{buildroot}%{_kde4_appsdir}/plasma-desktop/updates/
   install -m 0644 %{SOURCE2} 
%{buildroot}%{_kde4_appsdir}/plasma-desktop/updates/01-plasma-nm.js
   
-
 %files lang -f %{name}.lang
 
 %files
@@ -235,6 +250,10 @@
 %doc COPYING.LIB COPYING
 %{_kde4_modulesdir}/plasmanetworkmanagement_openswanui.so
 %{_kde4_servicesdir}/plasmanetworkmanagement_openswanui.desktop
+
+%files strongswan
+%defattr(-,root,root)
+%doc COPYING.LIB COPYING
 %{_kde4_modulesdir}/plasmanetworkmanagement_strongswanui.so
 %{_kde4_servicesdir}/plasmanetworkmanagement_strongswanui.desktop
 

++ plasma-nm-upstream-fixes.patch ++
diff --git a/applet/declarative/contents/ui/main.qml 
b/applet/declarative/contents/ui/main.qml
index 8ea88cc..aa81707 100644
--- a/applet/declarative/contents/ui/main.qml
+++ b/applet/declarative/contents/ui/main.qml
@@ -19,6 +19,7 @@
 */
 
 import QtQuick 1.1
+import org.kde.plasma.extras 0.1 as PlasmaExtras
 import org.kde.plasma.components 0.1 as PlasmaComponents
 import org.kde.plasma.core 0.1 as PlasmaCore
 import org.kde.networkmanagement 0.1 as PlasmaNM
@@ -77,16 +78,7 @@ Item {
 anchors.fill: parent
 }
 
-ListView {
-id: connectionView;
-
-property bool expandedItem: false;
-property string previouslyExpandedItem: ;
-
-property bool activeExpanded: true;
-property bool previousExpanded: true;
-property bool unknownExpanded: true;
-
+PlasmaExtras.ScrollArea {
 anchors {
 left: parent.left;
 right: parent.right;
@@ -95,50 +87,64 @@ Item {
 topMargin: padding.margins.top;
 bottomMargin: padding.margins.bottom
 }
-clip: true
-model: connectionSortModel;
-currentIndex: -1;
-interactive: true;
-boundsBehavior: Flickable.StopAtBounds;
-section.property: itemSection;
-section.delegate: SectionHeader {
-onHideSection: {
- 

commit plasma-nm for openSUSE:Factory

2013-10-17 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2013-10-17 14:25:43

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2013-10-06 
19:37:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2013-10-17 
17:45:04.0 +0200
@@ -1,0 +2,25 @@
+Tue Oct 15 13:09:15 UTC 2013 - tittiatc...@gmail.com
+
+- Update to 0.9.3.1
+  - plasma-nm is renamed to match the names from the old 
+networkmanagement applet (kded module, applet name etc.)
+  - visual changes
+ - different icons
+ - improved speed of animations
+ - applet is a little bit smaller
+  - improved notifications
+  - ModemManager support is optional
+  - StrongSwan VPN plugin
+  - closed bugs:
+- plasma-nm doesn't install icon network-defaultroute, which 
+  is need by kde-nm-connection-editor.desktop (bko#325783)
+- plasma crashes when a vpn connection is activated (bko#324016)
+- Crash when launching second user desktop (bko#324708)
+- Cannot add static routes on OpenVPN connections using the 
+  latest plasma-nm in Kubuntu Saucy (bko#325290)
+- WPA2 dialog blocks Plasma (bko#322192)
+- and a lot of unreported bugs and improvements 
+
+- Added 01-plasma-nm.js to add the plasmoid to the systray
+  automatically. This is required due to the renaming
+---

Old:

  plasma-nm-0.9.3.0.tar.xz

New:

  01-plasma-nm.js
  plasma-nm-0.9.3.1.tar.xz



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.Xb02FK/_old  2013-10-17 17:45:05.0 +0200
+++ /var/tmp/diff_new_pack.Xb02FK/_new  2013-10-17 17:45:05.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   plasma-nm
-Version:0.9.3.0
+Version:0.9.3.1
 Release:0
 Summary:Plasma applet written in QML for managing network connections
 License:GPL-2.0 or GPL-3.0
@@ -25,6 +25,7 @@
 Url:https://projects.kde.org/projects/playground/network/plasma-nm
 Source0:
http://download.kde.org/unstable/plasma-nm/%{name}-%{version}.tar.xz
 Source1:icon.tar.bz2
+Source2:01-plasma-nm.js
 BuildRequires:  NetworkManager-devel = 0.9.8.0
 BuildRequires:  fdupes
 BuildRequires:  libModemManagerQt-devel = 0.5.0
@@ -35,10 +36,17 @@
 %endif
 Provides:   NetworkManager-client
 Recommends: %{name}-pptp
+%if 0%{?suse_version}  1310
 Obsoletes:  NetworkManager-kde4-devel
 Obsoletes:  NetworkManager-kde4-libs
 Obsoletes:  NetworkManager-novellvpn-kde4
 Obsoletes:  plasmoid-networkmanagement
+%else
+Conflicts:  NetworkManager-kde4-devel
+Conflicts:  NetworkManager-kde4-libs
+Conflicts:  NetworkManager-novellvpn-kde4
+Conflicts:  plasmoid-networkmanagement
+%endif
 %kde4_runtime_requires
 
 %description
@@ -51,8 +59,12 @@
 Requires:   %{name} = %{version}
 Requires:   NetworkManager-openvpn
 Provides:   NetworkManager-openvpn-frontend
+%if 0%{?suse_version}  1310
 Supplements:packageand(%{name};NetworkManager-openvpn)
 Obsoletes:  NetworkManager-openvpn-kde4
+%else
+Conflicts:  NetworkManager-openvpn-kde4
+%endif
 %kde4_runtime_requires
 
 %description openvpn
@@ -64,8 +76,12 @@
 Requires:   %{name} = %{version}
 Requires:   NetworkManager-vpnc
 Provides:   NetworkManager-vpnc-frontend
+%if 0%{?suse_version}  1310
 Supplements:packageand(%{name};NetworkManager-vpnc)
 Obsoletes:  NetworkManager-vpnc-kde4
+%else
+Conflicts:  NetworkManager-vpnc-kde4
+%endif
 %kde4_runtime_requires
 
 %description vpnc
@@ -78,8 +94,12 @@
 Requires:   %{name} = %{version}
 Requires:   openconnect
 Provides:   NetworkManager-openconnect-frontend
+%if 0%{?suse_version}  1310
 Supplements:packageand(%{name};openconnect)
 Obsoletes:  NetworkManager-openconnect-kde4
+%else
+Conflicts:  NetworkManager-openconnect-kde4
+%endif
 %kde4_runtime_requires
 
 %description openconnect
@@ -118,8 +138,12 @@
 Requires:   %{name} = %{version}
 Requires:   NetworkManager-pptp
 Provides:   NetworkManager-pptp-frontend
+%if 0%{?suse_version}  1310
 Supplements:packageand(%{name};NetworkManager-pptp)
 Obsoletes:  NetworkManager-pptp-kde4
+%else
+Conflicts:  NetworkManager-pptp-kde4
+%endif
 %kde4_runtime_requires
 
 %description pptp
@@ -140,9 +164,15 @@
   %fdupes -s %{buildroot}
   mkdir -p %{buildroot}%{_kde4_iconsdir}/hicolor/32x32/apps/
   cp -r 
$RPM_BUILD_DIR/plasma-nm-%{version}/ox32-device-network-defaultroute.png 

commit plasma-nm for openSUSE:Factory

2013-10-06 Thread h_root
Hello community,

here is the log from the commit of package plasma-nm for openSUSE:Factory 
checked in at 2013-10-06 19:37:13

Comparing /work/SRC/openSUSE:Factory/plasma-nm (Old)
 and  /work/SRC/openSUSE:Factory/.plasma-nm.new (New)


Package is plasma-nm

Changes:

--- /work/SRC/openSUSE:Factory/plasma-nm/plasma-nm.changes  2013-09-23 
11:17:39.0 +0200
+++ /work/SRC/openSUSE:Factory/.plasma-nm.new/plasma-nm.changes 2013-10-06 
19:37:14.0 +0200
@@ -1,0 +2,6 @@
+Fri Oct  4 12:03:42 UTC 2013 - tittiatc...@gmail.com
+
+- Add Obosletes for the NetworkManager-kde4 packages as that 
+  NetworkManager-kde4 has been declared obsolete upstream
+
+---



Other differences:
--
++ plasma-nm.spec ++
--- /var/tmp/diff_new_pack.VCTG5W/_old  2013-10-06 19:37:14.0 +0200
+++ /var/tmp/diff_new_pack.VCTG5W/_new  2013-10-06 19:37:14.0 +0200
@@ -15,24 +15,30 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   plasma-nm
 Version:0.9.3.0
 Release:0
-License:GPL-2.0 or GPL-3.0
 Summary:Plasma applet written in QML for managing network connections
+License:GPL-2.0 or GPL-3.0
 Group:  System/GUI/KDE
 Url:https://projects.kde.org/projects/playground/network/plasma-nm
 Source0:
http://download.kde.org/unstable/plasma-nm/%{name}-%{version}.tar.xz
 Source1:icon.tar.bz2
+BuildRequires:  NetworkManager-devel = 0.9.8.0
 BuildRequires:  fdupes
 BuildRequires:  libModemManagerQt-devel = 0.5.0
 BuildRequires:  libNetworkManagerQt-devel = 0.9.0
 BuildRequires:  libkde4-devel = 4.9.0
-BuildRequires:  NetworkManager-devel = 0.9.8.0
 %if 0%{?suse_version}  1230
 BuildRequires:  pkgconfig(openconnect) = 4.00
 %endif
 Provides:   NetworkManager-client
+Recommends: %{name}-pptp
+Obsoletes:  NetworkManager-kde4-devel
+Obsoletes:  NetworkManager-kde4-libs
+Obsoletes:  NetworkManager-novellvpn-kde4
+Obsoletes:  plasmoid-networkmanagement
 %kde4_runtime_requires
 
 %description
@@ -41,9 +47,12 @@
 
 %package openvpn
 Summary:OpenVPN support for %{name}
+Group:  System/GUI/KDE
 Requires:   %{name} = %{version}
 Requires:   NetworkManager-openvpn
 Provides:   NetworkManager-openvpn-frontend
+Supplements:packageand(%{name};NetworkManager-openvpn)
+Obsoletes:  NetworkManager-openvpn-kde4
 %kde4_runtime_requires
 
 %description openvpn
@@ -51,9 +60,12 @@
 
 %package vpnc
 Summary:Vpnc support for %{name}
+Group:  System/GUI/KDE
 Requires:   %{name} = %{version}
 Requires:   NetworkManager-vpnc
 Provides:   NetworkManager-vpnc-frontend
+Supplements:packageand(%{name};NetworkManager-vpnc)
+Obsoletes:  NetworkManager-vpnc-kde4
 %kde4_runtime_requires
 
 %description vpnc
@@ -62,9 +74,12 @@
 %if 0%{?suse_version}  1230
 %package openconnect
 Summary:OpenConnect support for %{name}
+Group:  System/GUI/KDE
 Requires:   %{name} = %{version}
 Requires:   openconnect
 Provides:   NetworkManager-openconnect-frontend
+Supplements:packageand(%{name};openconnect)
+Obsoletes:  NetworkManager-openconnect-kde4
 %kde4_runtime_requires
 
 %description openconnect
@@ -73,9 +88,11 @@
 
 %package openswan
 Summary:Openswan support for %{name}
+Group:  System/GUI/KDE
 Requires:   %{name} = %{version}
 # NetworkManager-openswan is not in Factory
 #Requires:   NetworkManager-openswan
+#Supplements:packageand(%{name};NetworkManager-openswan)
 Provides:   NetworkManager-openswan-frontend
 %kde4_runtime_requires
 
@@ -84,9 +101,11 @@
 
 %package l2tp
 Summary:L2TP support for %{name}
+Group:  System/GUI/KDE
 Requires:   %{name} = %{version}
 # NetworkManager-l2tp is not in Factory
 #Requires:   NetworkManager-l2tp
+#Supplements:packageand(%{name};NetworkManager-l2tp)
 Provides:   NetworkManager-l2tp-frontend
 %kde4_runtime_requires
 
@@ -95,9 +114,12 @@
 
 %package pptp
 Summary:PPTP support for %{name}
+Group:  System/GUI/KDE
 Requires:   %{name} = %{version}
 Requires:   NetworkManager-pptp
 Provides:   NetworkManager-pptp-frontend
+Supplements:packageand(%{name};NetworkManager-pptp)
+Obsoletes:  NetworkManager-pptp-kde4
 %kde4_runtime_requires
 
 %description pptp

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org