commit pgadmin3 for openSUSE:Factory

2019-03-28 Thread root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2019-03-28 22:49:10

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new.25356 (New)


Package is "pgadmin3"

Thu Mar 28 22:49:10 2019 rev:4 rq:689277 version:1.22.2

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2018-03-31 
15:37:34.328199134 +0200
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new.25356/pgadmin3.changes 
2019-03-28 22:49:13.523048886 +0100
@@ -1,0 +2,5 @@
+Tue May 29 08:27:19 UTC 2018 - m...@pcvolkmer.de
+
+- Changed spec file to select dependencies for Leap 15.0
+
+---



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.uAlkmm/_old  2019-03-28 22:49:14.667048678 +0100
+++ /var/tmp/diff_new_pack.uAlkmm/_new  2019-03-28 22:49:14.683048675 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package pgadmin3
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -40,29 +40,36 @@
 BuildRequires:  automake
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
+%if 0%{?is_opensuse} > 0
 # We are not compatible with openssl1.1 changes
 # So we adopt Debian way, use libressl instead.
 BuildRequires:  libressl-devel
+%else
+BuildRequires:  openssl-devel
+%endif
 BuildRequires:  libtool
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
 BuildRequires:  libxslt-tools
-BuildRequires:  postgresql-devel
+BuildRequires:  postgresql-server-devel
 BuildRequires:  update-desktop-files
-%if 0%{?suse_version} <= 1315 || 0%{?sle_version} > 0
-# One day a brave soul will find how to build that on SLE
-#%%if 0%%{?sle_version} > 0
-#BuildRequires:  libwx_baseu-2_8-0-wxcontainer
-#BuildRequires:  wxWidgets-devel < 2.9
-#%%else
+# openSUSE before Leap 15
+%if 0%{?suse_version} <= 1315 && 0%{?is_opensuse} > 0
 BuildRequires:  wxWidgets
 BuildRequires:  wxWidgets-wxcontainer-devel
-#%%endif
 %define _use_internal_dependency_generator 0
 %define __find_requires %wx_requires
 %define WX_VER 2.8
-%else
-# Tumbleweed
+%endif
+# Tumbleweed or Leap 15 and later
+%if 0%{?suse_version} >= 1500 && 0%{?is_opensuse} > 0
+# nostl mandatory otherwise you get errors at compile and runtime
+# too much wxChar used
+%define WX_VER 3.0
+BuildRequires:  wxWidgets-3_0-nostl-devel
+%endif
+# SLE 15
+%if 0%{?suse_version} >= 1500 && 0%{?is_opensuse} == 0
 # nostl mandatory otherwise you get errors at compile and runtime
 # too much wxChar used
 %define WX_VER 3.0






commit pgadmin3 for openSUSE:Factory

2018-03-31 Thread root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2018-03-31 15:37:14

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is "pgadmin3"

Sat Mar 31 15:37:14 2018 rev:3 rq:592632 version:1.22.2

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2017-11-27 
22:17:37.328352922 +0100
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2018-03-31 
15:37:34.328199134 +0200
@@ -1,0 +2,6 @@
+Fri Mar 30 11:55:48 UTC 2018 - ralf.habac...@freenet.de
+
+- Added 0003-postgresql-8.3-support.patch to fix invalid
+  sql statement on accessing postgresql 8.3 database
+
+---

New:

  0003-postgresql-8.3-support.patch



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.D6zQWt/_old  2018-03-31 15:37:35.420159541 +0200
+++ /var/tmp/diff_new_pack.D6zQWt/_new  2018-03-31 15:37:35.424159395 +0200
@@ -35,6 +35,7 @@
 # 
https://bitbucket.org/openscg/pgadmin3-lts/commits/ea8a31af779b101248fc13242cb7a34e252cf49e
 # 
https://bitbucket.org/openscg/pgadmin3-lts/commits/1d65e012f7bb88d3b6c5a08946a2456617213c35
 Patch2: 0002-basic-support-postgresql10.patch
+Patch3: 0003-postgresql-8.3-support.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  fdupes
@@ -95,6 +96,7 @@
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 autoreconf -fiv
 
 sed -i 's/\r$//' LICENSE TODO CHANGELOG # remove wrong EOL

++ 0003-postgresql-8.3-support.patch ++
--- a/pgadmin/schema/pgColumn.cpp   2018-02-27 12:59:42.871950867 +0100
+++ b/pgadmin/schema/pgColumn.cpp   2018-02-27 13:00:15.491784358 +0100
@@ -568,7 +568,7 @@
// grab inherited tables with attibute names
pgSet *inhtables = database->ExecuteSet(
   wxT("SELECT\n")
-  wxT("array_to_string(array_agg(inhrelname), 
', ') inhrelname,\n")
+  wxT("array_to_string(array_agg(inhrelname), 
', ') AS inhrelname,\n")
   wxT("attrname\n")
   wxT("FROM\n")
   wxT("(SELECT\n")
--- a/pgadmin/schema/pgFunction.cpp 2018-02-27 13:10:04.0 +0100
+++ b/pgadmin/schema/pgFunction.cpp 2018-02-27 13:10:39.733120796 +0100
@@ -660,7 +660,7 @@
}
 
pgSet *functions;
-   if (obj->GetConnection()->GetIsGreenplum())
+   if (obj->GetConnection()->GetIsGreenplum() || 
!obj->GetConnection()->BackendMinimumVersion(9, 0))
{
// the Open Source version of Greenplum already has the 
pg_get_function_result() function,
// however the 4.3 stable release does not have this function





commit pgadmin3 for openSUSE:Factory

2017-11-27 Thread root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2017-11-27 22:17:36

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is "pgadmin3"

Mon Nov 27 22:17:36 2017 rev:2 rq:545683 version:1.22.2

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2017-11-23 
09:45:14.254711155 +0100
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2017-11-27 
22:17:37.328352922 +0100
@@ -1,0 +2,14 @@
+Sat Nov 25 12:43:22 UTC 2017 - br...@ioda-net.ch
+
+- Fix boo#1069822 Can't build with openssl 1.1
+  (Coming soon as default in Tumbleweed 201711*)
+  Adopt Debian way, by switching to libressl-devel. 
+
+---
+Fri Nov 24 18:37:57 UTC 2017 - br...@ioda-net.ch
+
+- Added path 0002-basic-support-postgresql10.patch inspired by 
+  openscg work on their fork pgadmin III LTS.
+  Connection to postgresql10 server is now possible. 
+
+---

New:

  0002-basic-support-postgresql10.patch



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.nQ1DdZ/_old  2017-11-27 22:17:38.328316627 +0100
+++ /var/tmp/diff_new_pack.nQ1DdZ/_new  2017-11-27 22:17:38.332316482 +0100
@@ -29,15 +29,23 @@
 Source4:
https://ftp.postgresql.org/pub/pgadmin/%{name}/v%{version}/src/pgadmin3-%{version}.tar.gz.sig
 # Limit to strict minimum the needed wxWidgets inspired by debian patches
 Patch0: wxWidget-limit-libs-used.patch
+# Fix row heights on hidpi screen
 Patch1: 0001-Set-row-heights-based-on-pixels-rather-than-points.patch
+# Add basic support for postgresql10 (Based on pgadmin3 lts by bigsql
+# 
https://bitbucket.org/openscg/pgadmin3-lts/commits/ea8a31af779b101248fc13242cb7a34e252cf49e
+# 
https://bitbucket.org/openscg/pgadmin3-lts/commits/1d65e012f7bb88d3b6c5a08946a2456617213c35
+Patch2: 0002-basic-support-postgresql10.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  fdupes
 BuildRequires:  gcc-c++
-BuildRequires:  libopenssl-devel
+# We are not compatible with openssl1.1 changes
+# So we adopt Debian way, use libressl instead.
+BuildRequires:  libressl-devel
 BuildRequires:  libtool
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
+BuildRequires:  libxslt-tools
 BuildRequires:  postgresql-devel
 BuildRequires:  update-desktop-files
 %if 0%{?suse_version} <= 1315 || 0%{?sle_version} > 0
@@ -86,6 +94,7 @@
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 autoreconf -fiv
 
 sed -i 's/\r$//' LICENSE TODO CHANGELOG # remove wrong EOL

++ 0002-basic-support-postgresql10.patch ++
diff -rup a/pgadmin/include/pgAdmin3.h b/pgadmin/include/pgAdmin3.h
--- a/pgadmin/include/pgAdmin3.h2017-11-24 17:56:53.943413312 +0100
+++ b/pgadmin/include/pgAdmin3.h2017-11-24 18:02:39.052637799 +0100
@@ -58,8 +58,8 @@
 // Supported server minimum and maximum values.
 const short SERVER_MIN_VERSION_N = 0x0804;
 const wxString SERVER_MIN_VERSION_T = wxT("8.4");
-const short SERVER_MAX_VERSION_N = 0x0906;
-const wxString SERVER_MAX_VERSION_T = wxT("9.6");
+const short SERVER_MAX_VERSION_N = 0x0A00;
+const wxString SERVER_MAX_VERSION_T = wxT("10.0");
 
 // Supported Greenplum Database and Greenplum HAWQ minimum and maximum values.
 const short GP_MIN_VERSION_N = 0x0802;
diff -rup a/pgadmin/schema/pgServer.cpp b/pgadmin/schema/pgServer.cpp
--- a/pgadmin/schema/pgServer.cpp   2017-11-24 17:56:53.983413455 +0100
+++ b/pgadmin/schema/pgServer.cpp   2017-11-24 18:55:43.102941932 +0100
@@ -905,13 +905,28 @@ int pgServer::Connect(frmMain *form, boo
if (conn->BackendMinimumVersion(8, 5))
{
sql += wxT(", CASE WHEN usesuper THEN 
pg_is_in_recovery() ELSE NULL END as inrecovery");
-   sql += wxT(", CASE WHEN usesuper THEN 
pg_last_xlog_receive_location() ELSE NULL END as receiveloc");
-   sql += wxT(", CASE WHEN usesuper THEN 
pg_last_xlog_replay_location() ELSE NULL END as replayloc");
+if (conn->BackendMinimumVersion(10, 0))
+   {
+   sql += wxT(", CASE WHEN usesuper THEN 
pg_last_wal_receive_lsn() ELSE NULL END as receiveloc");
+   sql += wxT(", CASE WHEN usesuper THEN 
pg_last_wal_replay_lsn() ELSE NULL END as replayloc");
+   }
+   else
+   {
+   sql += wxT(", CASE WHEN usesuper THEN 
pg_last_xlog_receive_location() ELSE NULL END as receiveloc");
+

commit pgadmin3 for openSUSE:Factory

2017-04-24 Thread root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2017-04-24 09:48:54

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is "pgadmin3"

Mon Apr 24 09:48:54 2017 rev:24 rq:489423 version:1.22.2

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2017-02-03 
18:55:20.362879618 +0100
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2017-04-24 
09:48:55.218798693 +0200
@@ -1,0 +2,6 @@
+Tue Apr 18 19:10:24 UTC 2017 - br...@ioda-net.ch
+
+- Add 0001-Set-row-heights-based-on-pixels-rather-than-points.patch
+  Fix control grid row on hidpi screen. 
+
+---

New:

  0001-Set-row-heights-based-on-pixels-rather-than-points.patch



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.ZAQKq8/_old  2017-04-24 09:48:56.230655581 +0200
+++ /var/tmp/diff_new_pack.ZAQKq8/_new  2017-04-24 09:48:56.234655015 +0200
@@ -29,6 +29,7 @@
 Source4:
http://ftp.postgresql.org/pub/pgadmin3/release/v%{version}/src/pgadmin3-%{version}.tar.gz.sig
 # Limit to strict minimum the needed wxWidgets inspired by debian patches
 Patch0: wxWidget-limit-libs-used.patch
+Patch1: 0001-Set-row-heights-based-on-pixels-rather-than-points.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  fdupes
@@ -84,6 +85,7 @@
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 autoreconf -fiv
 
 sed -i 's/\r$//' LICENSE TODO CHANGELOG # remove wrong EOL

++ 0001-Set-row-heights-based-on-pixels-rather-than-points.patch ++
>From aea3d062fe5ba992ddbf2ebd09654d3f105b01c7 Mon Sep 17 00:00:00 2001
From: Ryan Trinkle 
Date: Sun, 16 Apr 2017 16:20:16 -0400
Subject: [PATCH] Set row heights based on pixels rather than points

Previously, on a high-DPI display, rows in the ctlSQLGrid
would be too small by default.  Although the user can
manually adjust row heights, this is tedious and makes it
almost impossible to skim through data.  By calculating
the default row height based on pixels rather than points,
this is taken into account.

There are still some magic numbers here.  Using
GetPixelSize() alone seems to place the baseline of the
text at the bottom of the cell, cutting off any descenders
in the text.  To adjust for this, we add 20% of one line
height (experimentally determined).  Unfortunately, we
can't use wxDC::GetTextExtent, which would give us precise
results, because we don't have a wxDC at the time we're
setting these default heights.
---
 pgadmin/ctl/ctlSQLGrid.cpp | 16 
 1 file changed, 12 insertions(+), 4 deletions(-)

diff --git a/pgadmin/ctl/ctlSQLGrid.cpp b/pgadmin/ctl/ctlSQLGrid.cpp
index ac13bfed1..68e298dcd 100644
--- a/pgadmin/ctl/ctlSQLGrid.cpp
+++ b/pgadmin/ctl/ctlSQLGrid.cpp
@@ -15,6 +15,8 @@
 #include 
 #include 
 
+#include 
+
 #include "db/pgConn.h"
 #include "ctl/ctlSQLGrid.h"
 #include "utils/sysSettings.h"
@@ -48,8 +50,10 @@ ctlSQLGrid::ctlSQLGrid(wxWindow *parent, wxWindowID id, 
const wxPoint , cons
SetLabelFont(fntLabel);
SetColLabelAlignment(wxALIGN_LEFT, wxALIGN_CENTER);
SetRowLabelSize(50);
-   SetDefaultRowSize(fntCells.GetPointSize() * 2);
-   SetColLabelSize(fntLabel.GetPointSize() * 4);
+   int cellHeight = fntCells.GetPixelSize().GetHeight() * 1.2;
+   int rowLabelHeight = fntLabel.GetPixelSize().GetHeight() * 1.2;
+   SetDefaultRowSize(std::max(cellHeight, rowLabelHeight));
+   SetColLabelSize(fntLabel.GetPixelSize().GetHeight() * 2.2);
SetDefaultCellOverflow(false);
 
Connect(wxID_ANY, wxEVT_GRID_LABEL_LEFT_DCLICK, 
wxGridEventHandler(ctlSQLGrid::OnLabelDoubleClick));
@@ -85,8 +89,12 @@ void ctlSQLGrid::OnMouseWheel(wxMouseEvent )
}
SetLabelFont(fontlabel);
SetDefaultCellFont(fontcells);
-   SetColLabelSize(fontlabel.GetPointSize() * 4);
-   SetDefaultRowSize(fontcells.GetPointSize() * 2);
+   wxFont fntCells(settings->GetSQLFont());
+   wxFont fntLabel(settings->GetSystemFont());
+   int cellHeight = fntCells.GetPixelSize().GetHeight() * 1.2;
+   int rowLabelHeight = fntLabel.GetPixelSize().GetHeight() * 1.2;
+   SetDefaultRowSize(std::max(cellHeight, rowLabelHeight));
+   SetColLabelSize(fntLabel.GetPixelSize().GetHeight() * 2.2);
for (int index = 0; index < GetNumberCols(); index++)
SetColSize(index, -1);
ForceRefresh();
-- 
2.12.2






commit pgadmin3 for openSUSE:Factory

2017-02-03 Thread root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2017-02-02 15:42:41

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is "pgadmin3"

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2017-01-12 
15:58:37.019924385 +0100
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2017-02-03 
18:55:20.362879618 +0100
@@ -1,0 +2,14 @@
+Sun Jan 29 16:21:02 UTC 2017 - br...@ioda-net.ch
+
+- Packaging : 
+  + spec-clean minimal
+  + remove obsolete version sle and openSUSE
+  + globalize \r removal in css files
+  + use wxWidgets-3_0-nostl-devel to remove dependency of gst 0.10
+so use internal dependency generator on openSUSE > 1315
+  + Add WX_VER variable to build correctly
+  + Added patch wxWidget-limit-libs-used.patch to explicitely add
+the needed libs.
+  + Try to handle differents WX versions between openSUSE and SLE
+
+---

New:

  wxWidget-limit-libs-used.patch



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.mF7U8s/_old  2017-02-03 18:55:21.166766735 +0100
+++ /var/tmp/diff_new_pack.mF7U8s/_new  2017-02-03 18:55:21.166766735 +0100
@@ -17,48 +17,57 @@
 
 
 Name:   pgadmin3
+Version:1.22.2
+Release:0
 Summary:Management and Administration Tools for the PostgreSQL Database
 License:PostgreSQL
 Group:  Productivity/Databases/Tools
-Version:1.22.2
-Release:0
 Url:http://www.pgadmin.org/index.php
 Source0:
http://ftp.postgresql.org/pub/pgadmin3/release/v%{version}/src/pgadmin3-%{version}.tar.gz
 Source1:%name.desktop
 Source2:%name.png
 Source4:
http://ftp.postgresql.org/pub/pgadmin3/release/v%{version}/src/pgadmin3-%{version}.tar.gz.sig
+# Limit to strict minimum the needed wxWidgets inspired by debian patches
+Patch0: wxWidget-limit-libs-used.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
+BuildRequires:  fdupes
 BuildRequires:  gcc-c++
 BuildRequires:  libopenssl-devel
 BuildRequires:  libtool
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
 BuildRequires:  postgresql-devel
-#Documentation build, sles doesn't know python-Sphinx
-%if 0%{?suse_version} && 0%{?sles_version}
-#dummy
-%else
-BuildRequires:  python-Sphinx
-%endif
 BuildRequires:  update-desktop-files
-%if 0%{?suse_version} >= 1140
+%if 0%{?suse_version} <= 1315 || 0%{?sle_version} > 0
+# One day a brave soul will find how to build that on SLE
+#%%if 0%%{?sle_version} > 0
+#BuildRequires:  libwx_baseu-2_8-0-wxcontainer
+#BuildRequires:  wxWidgets-devel < 2.9
+#%%else
 BuildRequires:  wxWidgets
 BuildRequires:  wxWidgets-wxcontainer-devel
+#%%endif
 %define _use_internal_dependency_generator 0
 %define __find_requires %wx_requires
+%define WX_VER 2.8
 %else
-BuildRequires:  wxGTK-devel
+# Tumbleweed
+# nostl mandatory otherwise you get errors at compile and runtime
+# too much wxChar used
+%define WX_VER 3.0
+BuildRequires:  wxWidgets-3_0-nostl-devel
 %endif
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version} >= 1030
-BuildRequires:  fdupes
-%endif
-%if 0%{?sles_version} != 10 && 0%{?sles_version} != 9
-Suggests:   postgresql-server
+Requires:   libpq5 >= 9.3
 Recommends: %{name}-lang = %{version}
+Suggests:   postgresql-server
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+#Documentation build, sles doesn't know python-Sphinx
+%if 0%{?sle_version} > 0
+#dummy
+%else
+BuildRequires:  python-Sphinx
 %endif
-Requires:   libpq5 >= 9.3
 
 %description
 pgAdmin III is an administration and management tool for the PostgreSQL
@@ -71,33 +80,33 @@
 features and makes administration easy.
 
 %lang_package
+
 %prep
 %setup -q
+%patch0 -p1
+autoreconf -fiv
 
-%__sed -i 's/\r$//' LICENSE TODO CHANGELOG # remove wrong EOL
-%__sed -i 's/\r$//' docs/fr_FR/pgadmin3.css # remove wrong EOL
-%__sed -i 's/\r$//' docs/zh_CN/pgadmin3.css
-%__sed -i 's/\r$//' docs/zh_TW/pgadmin3.css
-%__sed -i 's/\r$//' docs/sl_SI/pgadmin3.css
+sed -i 's/\r$//' LICENSE TODO CHANGELOG # remove wrong EOL
+sed -i 's/\r$//' docs/*/pgadmin3.css # remove wrong EOL
 
-%__rm -f docs/en_US/pgadmin3.hhp.cached # zero-length
+rm -f docs/en_US/pgadmin3.hhp.cached # zero-length
 
 %build
 autoreconf -fiv
 export CXXFLAGS="%optflags -fno-delete-null-pointer-checks"
-%configure --enable-databasedesigner --disable-static
-%__make %{?_smp_mflags}
+%configure --enable-databasedesigner --disable-static 
--with-wx-version=%{WX_VER}
+make %{?_smp_mflags}
 
 %install
 
-%__make DESTDIR="%{buildroot}" STRIP=/bin/true 

commit pgadmin3 for openSUSE:Factory

2016-07-05 Thread h_root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2016-07-05 09:51:42

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is "pgadmin3"

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2016-03-17 
16:49:37.0 +0100
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2016-07-05 
09:51:44.0 +0200
@@ -1,0 +2,6 @@
+Fri Jul  1 17:22:14 UTC 2016 - martin.li...@suse.com
+
+- Add -fno-delete-null-pointer-checks to CXXFLAGS to workaround
+  boo#986857.
+
+---



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.CtblGo/_old  2016-07-05 09:51:45.0 +0200
+++ /var/tmp/diff_new_pack.CtblGo/_new  2016-07-05 09:51:45.0 +0200
@@ -84,6 +84,7 @@
 
 %build
 autoreconf -fiv
+export CXXFLAGS="%optflags -fno-delete-null-pointer-checks"
 %configure --enable-databasedesigner --disable-static
 %__make %{?_smp_mflags}
 






commit pgadmin3 for openSUSE:Factory

2016-03-19 Thread h_root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2016-03-17 16:36:13

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is "pgadmin3"

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2016-02-22 
08:58:22.0 +0100
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2016-03-17 
16:49:37.0 +0100
@@ -1,0 +2,16 @@
+Sun Feb 28 19:01:25 UTC 2016 - crrodrig...@opensuse.org
+
+- Update to version 1.22.1 
+* Don't barf when connecting to Greenplum or Greenplum· HAWQ
+* Fix selection of conversion functions in the CREATE CONVERSION dialogue.
+* Properly quote type names in the Type dialogue, and·ensure range 
+  information is displayed for existing types
+* Fix selection of cast functions in the Cast dialogue
+
+---
+Sun Feb 28 18:48:28 UTC 2016 - crrodrig...@opensuse.org
+
+- remove obsolete suse_version checks 
+- fix debuginfo generation.
+
+---

Old:

  pgadmin3-1.22.0.tar.gz
  pgadmin3-1.22.0.tar.gz.sig

New:

  pgadmin3-1.22.1.tar.gz
  pgadmin3-1.22.1.tar.gz.sig



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.X0QAkO/_old  2016-03-17 16:49:38.0 +0100
+++ /var/tmp/diff_new_pack.X0QAkO/_new  2016-03-17 16:49:38.0 +0100
@@ -20,7 +20,7 @@
 Summary:Management and Administration Tools for the PostgreSQL Database
 License:PostgreSQL
 Group:  Productivity/Databases/Tools
-Version:1.22.0
+Version:1.22.1
 Release:0
 Url:http://www.pgadmin.org/index.php
 Source0:
http://ftp.postgresql.org/pub/pgadmin3/release/v%{version}/src/pgadmin3-%{version}.tar.gz
@@ -83,24 +83,13 @@
 %__rm -f docs/en_US/pgadmin3.hhp.cached # zero-length
 
 %build
-
-%if 0%{?suse_version} > 1010
-  autoreconf -fiv
-%else
-  autoheader
-  autoconf
-%endif
-
-export CFLAGS="%optflags -fstack-protector"
-export CXXFLAGS="%optflags -fstack-protector"
-
+autoreconf -fiv
 %configure --enable-databasedesigner --disable-static
-
 %__make %{?_smp_mflags}
 
 %install
 
-%__make DESTDIR="%{buildroot}" install
+%__make DESTDIR="%{buildroot}" STRIP=/bin/true install
 %__install -D -m0644 "%{SOURCE2}" "%{buildroot}%{_datadir}/pixmaps/%{name}.png"
 
 # whatever that symlink is doing there...

++ pgadmin3-1.22.0.tar.gz -> pgadmin3-1.22.1.tar.gz ++
/work/SRC/openSUSE:Factory/pgadmin3/pgadmin3-1.22.0.tar.gz 
/work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3-1.22.1.tar.gz differ: char 5, 
line 1





commit pgadmin3 for openSUSE:Factory

2016-02-21 Thread h_root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2016-02-22 08:58:11

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is "pgadmin3"

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2015-10-20 
00:05:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2016-02-22 
08:58:22.0 +0100
@@ -1,0 +2,40 @@
+Tue Jan 26 22:31:30 UTC 2016 - ter...@gmail.com
+
+- update to 1.22.0
+  * Resolved an issue related to check options selection in the view
+properties dialog with the check option.
+  * Merged the libssh2 to the latest version.
+  * Properly detect serial columns as such when identifiers have been
+truncated.
+  * Fixes an issue related to the column inheritance information properly,
+when one (or, more) common columns are inherited from multiple tables.
+  * Ensure the correct syntax used for moving the objects from one
+tablespace to another.
+  * Ensure the correct line endings are used when copying from the SQL Pane
+  * Toolbar icons, and menu items for Commit and Rollback actions.
+  * Display the connection details for the current browser object in the
+status bar
+  * Fixed an issue related to different menus enabling in the Query Tool on
+Ubunutu unity. 
+  * Reset the position (x, y) for dialog(s), and frame(s) to 0 (if found
+negative), while saving its position and size.
+  * Fixes an issue identifying the return type to TABLE in some cases,
+using pg_get_function_result(..) for the same instead of format_type(..)
+  * Honour PGPASSFILE environment variable for saving, retrieving the
+password instead of always works with pgpass.conf (on windows)/.pgpass
+(on non-windows)
+  * Fix a segfault occurs while detecting transaction section requirement,
+when autocommit has been disabled.
+  * Format execution time in a more readable manner
+  * Improve sorting in Data editor
+  * Allow to format the selecte SQL using external tools in Query Editor
+  * Allow to set auto-commit mode to on/off in the query editor
+  * Do not try unlock the mutex, which was not owned by the thread, while
+creating the popup menu
+  * Set the focus on browser tree windows on startup
+  * Make the arrow key navigation consistent across all platform on the
+object browser tree
+  * Show indexes for the materialized views in Query pane
+  * Add support for searching materialized views in the
+
+---

Old:

  pgadmin3-1.20.0.tar.gz
  pgadmin3-1.20.0.tar.gz.sig

New:

  pgadmin3-1.22.0.tar.gz
  pgadmin3-1.22.0.tar.gz.sig



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.KfxqGE/_old  2016-02-22 08:58:24.0 +0100
+++ /var/tmp/diff_new_pack.KfxqGE/_new  2016-02-22 08:58:24.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package pgadmin3
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,7 +20,7 @@
 Summary:Management and Administration Tools for the PostgreSQL Database
 License:PostgreSQL
 Group:  Productivity/Databases/Tools
-Version:1.20.0
+Version:1.22.0
 Release:0
 Url:http://www.pgadmin.org/index.php
 Source0:
http://ftp.postgresql.org/pub/pgadmin3/release/v%{version}/src/pgadmin3-%{version}.tar.gz

++ pgadmin3-1.20.0.tar.gz -> pgadmin3-1.22.0.tar.gz ++
/work/SRC/openSUSE:Factory/pgadmin3/pgadmin3-1.20.0.tar.gz 
/work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3-1.22.0.tar.gz differ: char 5, 
line 1





commit pgadmin3 for openSUSE:Factory

2015-10-19 Thread h_root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2015-10-19 22:51:48

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is "pgadmin3"

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2015-08-13 
18:10:31.0 +0200
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2015-10-20 
00:05:37.0 +0200
@@ -1,0 +2,5 @@
+Fri Oct 16 08:01:38 UTC 2015 - jweberho...@weberhofer.at
+
+- Do not recommend but only suggest to install postgresql-server.
+
+---



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.mq6hYN/_old  2015-10-20 00:05:39.0 +0200
+++ /var/tmp/diff_new_pack.mq6hYN/_new  2015-10-20 00:05:39.0 +0200
@@ -55,7 +55,7 @@
 BuildRequires:  fdupes
 %endif
 %if 0%{?sles_version} != 10 && 0%{?sles_version} != 9
-Recommends: postgresql-server
+Suggests:   postgresql-server
 Recommends: %{name}-lang = %{version}
 %endif
 Requires:   libpq5 >= 9.3






commit pgadmin3 for openSUSE:Factory

2015-08-13 Thread h_root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2015-08-13 18:10:29

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is pgadmin3

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2015-01-29 
09:57:26.0 +0100
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2015-08-13 
18:10:31.0 +0200
@@ -1,0 +2,5 @@
+Wed Aug 12 11:34:20 UTC 2015 - mplus...@suse.com
+
+- Add explicit dependencies on autoconf and libtool
+
+---



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.wBz8Fl/_old  2015-08-13 18:10:32.0 +0200
+++ /var/tmp/diff_new_pack.wBz8Fl/_new  2015-08-13 18:10:32.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package pgadmin3
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -27,9 +27,11 @@
 Source1:%name.desktop
 Source2:%name.png
 Source4:
http://ftp.postgresql.org/pub/pgadmin3/release/v%{version}/src/pgadmin3-%{version}.tar.gz.sig
+BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  gcc-c++
 BuildRequires:  libopenssl-devel
+BuildRequires:  libtool
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
 BuildRequires:  postgresql-devel






commit pgadmin3 for openSUSE:Factory

2015-01-29 Thread h_root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2015-01-29 09:57:19

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is pgadmin3

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2014-02-03 
10:12:49.0 +0100
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2015-01-29 
09:57:26.0 +0100
@@ -1,0 +2,80 @@
+Wed Jan 28 13:39:40 UTC 2015 - ter...@gmail.com
+
+- update to 1.20.0
+  * Resolving the inconsistency of preservation of modified 
+information of the columns, while adding/editing a table from 
+the table dialog 
+  * Add missing nodes to graphical explain plan
+  * Fix the Resource Groups dialog - separated the statements, 
+which can not be ran in single transaction
+  * Support for Slony-I 2.2+ with PostgreSQL 9.3+
+  * Support smallserial columns in Edit Data Window
+  * Restore the user specified size on the grid (which contains the 
+result) in Query windows to fix an issue related to the column 
+size is too narrow on subsequent Explain execution
+  * Empty the Undo/Redo history everytime new file is opened
+  * Added accelerator F8 for 'Execute to file' in the Query window
+  * Beautify the query shown in the SQL pane for the functions 
+having multiple arguments by adding new lines with small 
+modification
+  * Check for the columnlist for the UPDATE OF syntax on trigger 
+also works with PPAS 9.5+
+  * Proper saving of columns width in the server status window
+  * CHECK OPTION is applicable to the views only, and not the 
+materialized views
+  * Prevent a crash during the update of the macro or favourite 
+list
+  * Allow quick injectection of favourites by name
+  * Fix handling of saving macros after pasting a query in the box
+  * Fix handling of char()[] columns in the Edit Grid
+  * Support the new check_option parameter of views
+  * Handle the 9.4 MOVE clause of ALTER TABLESPACE
+  * Add a new action menu to refresh a materialized view
+  * Support the new 9.4 columns in pg_stat_activity
+  * Save search options for next time
+  * Ensure Favourite queries are only saved when the OK button is 
+pressed
+  * Fix an issue refreshing functions in PPAS packages
+  * Improve handling of lost connections
+  * Allow searching for database objects by comment and definition 
+content
+  * Add support for Resource Groups in PPAS 9.4
+  * Add Save and Exit shortcut keys to the edit grid
+  * Enable backward search in SQL Box using Shift + F3
+  * Allow more flexible selection/deselection of rows and columns 
+in Edit Grid
+  * Allow more options with the plain backup.
+  * Use a much smarter auto-sizing algorithm for the columns in the 
+Query Tool output grid.
+  * Remember the last panel used on the Options dialogue, and 
+display the default panel if a group node is selected on the 
+tree
+  * Allow parallel dump with -j starting with 9.3
+
+- update to 1.18.2
+  * Fix SQL for GRANT on a sequence. Report from liuyuanyuan.
+  * Fix escape handling in pgpass files
+  * GQB forgot the materialized views.
+  * Don't set log_min_messages from the debugger
+  * Fix a crash on OSX when run explain through shortcut in query 
+editor, when mouse is over a existing shape, and popup, showing 
+the step information, is on
+  * Using the GetOid() function instead of GetLong() for Oid 
+columns
+  * Fix SQL comments for inherited columns.
+  * Flush the changes in the settings as soon as new server is 
+added
+  * Don't include obsolete config settings from = 8.3 in the 
+config editor unless running on an appropriate server.
+  * Ensure the Type dialogue detects name changes.
+  * Ensure report titles don't overflow the page width
+  * Ensure reports overflow the page width properly
+  * Add missing port option for SSH tunnels.
+  * Set 32bit PostgreSQL, EnterpriseDB PATH (in case - 64bit 
+respective applications not found, and 32bit(s) are available) 
+for 64bit pgAdmin III.
+  * Improved the debugger to work better with PPAS = 9.2
+  * Fix the handling of the Valid Until date/time on the role 
+dialogue on Mac.
+
+---

Old:

  pgadmin3-1.18.1.tar.gz
  pgadmin3-1.18.1.tar.gz.sig

New:

  pgadmin3-1.20.0.tar.gz
  pgadmin3-1.20.0.tar.gz.sig



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.IUdUy1/_old  2015-01-29 09:57:27.0 +0100
+++ /var/tmp/diff_new_pack.IUdUy1/_new  2015-01-29 09:57:27.0 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package pgadmin3
 #
-# Copyright (c) 2013 SUSE 

commit pgadmin3 for openSUSE:Factory

2014-02-03 Thread h_root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2014-02-03 10:12:48

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is pgadmin3

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2013-01-30 
09:35:32.0 +0100
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2014-02-03 
10:12:49.0 +0100
@@ -1,0 +2,127 @@
+Thu Dec 12 12:20:10 UTC 2013 - m...@suse.com
+
+- Remove broken and unneeded dependency on libecpg (bnc#854754).
+
+---
+Sat Oct 19 07:10:57 UTC 2013 - br...@ioda-net.ch
+
+- spec remove cleaning png2c (fixed in 1.18) 
+
+- update to 1.18.1
+  http://www.pgadmin.org/development/changelog.php
+  Date   Dev Ver Change details
+  -- --- --  --
+  2013-09-29 GL  1.18.1  Allow the dump of pgsomething schemas.
+  2013-09-26 DP  1.18.1  Prevent a crash on Windows when dropping a column or a
+   constraint on a table [Dhiraj Chawla]
+  2013-09-26 DP  1.18.1  Ensure DDLScript will work with Slony 2.2+ which has a
+   new SQL level API [Neel Patel]
+  2013-09-26 DP  1.18.1  Fix ordering of object types in the display options 
and
+   add Event Triggers which were missing [Dhiraj Chawla].
+  2013-09-21 AV  1.18.1  Ensure the debugger can cope with functions that have 
an
+   OUT parameter as the first.
+  2013-09-19 DP  1.18.1  Fix the quoting of user mapping objects [Dinesh Kumar]
+  2013-09-19 DP  1.18.1  Ensure that materialised views are available as 
targets
+   for synonyms [Neel Patel]
+  2013-09-19 DP  1.18.1  Fix the query used to find tables in a Slony 
+   replication set [Neel Patel]
+  2013-09-11 DP  1.18.1  Prevent a crash if a user starts an external process
+   such as a backup, and then immediately hits cancel
+   [Neel Patel].
+  2013-09-06 DP  1.18.1  Fix a memory leak in the Event Trigger code [Dinesh
+   Kumar].
+  2013-08-20 AV  1.18.0  Fix a layout bug in the graphical explain renderer 
that
+   could render nodes on top of each other.
+  2013-08-06 DP  1.18.0  Fix Slony's DDL Script support [Akshay Joshi].
+  2013-07-26 DP  1.18.0  Add support for Event Triggers in 9.3+ [Dinesh Kumar].
+  2013-07-22 DP  1.18.0  Avoid using a Help cache file that needs to be world
+   writeable, and ensure sed is happy when post-processing
+   helpfiles.
+  2013-07-22 DP  1.18.0  Fix the help path on the import dialogue and improve 
the
+   error handling [Akshay Joshi].
+  2013-07-22 DP  1.18.0  Fix path the the Search Objects help doc [Dhiraj 
Chawla].
+  2013-07-18 GL  1.18.0  Fix UTF-8 display for guru hints [Marek Cernocky].
+  2013-07-08 DP  1.18.0  Prevent a crash when creating a stored procedure in 
+   PPAS [Dinesh Kumar].
+  2013-06-19 GL  1.18.0  Disable the Favourites menu items if there is no
+   favourites file path (per a comment from Michael 
Shapiro).
+  2013-06-18 GL  1.18.0  Make No the default button on the Truncate 
confirmation
+   dialog (per request from Humberto Cereser Ibanez).
+  2013-06-18 DP  1.18.0  Support Materialized Views [Neel Patel].
+  2013-06-07 DP  1.18.0  Avoid a possible crash on Linux when using the 
+   Script options of the Query Tool [aditsu].
+  2013-05-26 DP  1.18.0  Fix comments on constraints [Thom Brown].
+  2013-05-26 DP  1.18.0  Fix schema prefixes in cast definitions in the 
browser.
+  2013-05-26 DP  1.18.0  Treat sequences as first class objects in the Grant
+   Wizard. Support USAGE and remove obsolete RULE 
+   permissions [Dhiraj Chawla].
+  2013-05-26 DP  1.18.0  Set the default backup type to Custom.
+  2013-05-21 DP  1.18.0  Improve the copy handling on the Edit Grid so that
+   it works more consistently and predictably.
+  2013-05-20 DP  1.18.0  Fix comments on columns.
+  2013-05-20 DP  1.18.0  Remove the Apply buttons from the function, view
+   package and external table dialogues. Their use is
+   discouraged, and the code is fragile, complex and 
+   very buggy.
+  2013-05-20 DP  1.18.0  Fix a crash that could occur if the browser fails to 
+   detect that an object has been changed by another
+   session.
+  2013-05-17 DP  1.18.0  Change the default SQL box font to a slightly smaller
+   size on GTK based 

commit pgadmin3 for openSUSE:Factory

2012-06-26 Thread h_root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2012-06-26 17:18:08

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is pgadmin3, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2011-12-05 
12:44:54.0 +0100
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2012-06-26 
17:18:11.0 +0200
@@ -1,0 +2,6 @@
+Sun Jun 24 16:52:10 UTC 2012 - pascal.ble...@opensuse.org
+
+- update to 1.14.3:
+  http://www.pgadmin.org/development/changelog.php
+
+---

Old:

  pgadmin3-1.14.0.tar.gz

New:

  pgadmin3-1.14.3.tar.gz



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.sYvlHJ/_old  2012-06-26 17:18:13.0 +0200
+++ /var/tmp/diff_new_pack.sYvlHJ/_new  2012-06-26 17:18:13.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package pgadmin3
 #
-# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,15 +15,15 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 Name:   pgadmin3
 Summary:Management and Administration Tools for the PostgreSQL Database
 License:PostgreSQL
 Group:  Productivity/Databases/Tools
-Version:1.14.0
+Version:1.14.3
 Release:0
 Url:http://www.pgadmin.org/index.php
-# 
http://wwwmaster.postgresql.org/download/mirrors-ftp/pgadmin3/release/v{version}/src/pgadmin3-%{version}.tar.gz
-Source0:pgadmin3-%{version}.tar.gz
+Source0:
http://ftp.postgresql.org/pub/pgadmin3/release/v%{version}/src/pgadmin3-%{version}.tar.gz
 Source1:%name.desktop
 Source2:%name.png
 BuildRequires:  automake

++ pgadmin3-1.14.0.tar.gz - pgadmin3-1.14.3.tar.gz ++
/work/SRC/openSUSE:Factory/pgadmin3/pgadmin3-1.14.0.tar.gz 
/work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3-1.14.3.tar.gz differ: char 5, 
line 1


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit pgadmin3 for openSUSE:Factory

2011-12-05 Thread h_root
Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory 
checked in at 2011-12-05 12:44:52

Comparing /work/SRC/openSUSE:Factory/pgadmin3 (Old)
 and  /work/SRC/openSUSE:Factory/.pgadmin3.new (New)


Package is pgadmin3, Maintainer is 

Changes:

--- /work/SRC/openSUSE:Factory/pgadmin3/pgadmin3.changes2011-09-26 
10:10:39.0 +0200
+++ /work/SRC/openSUSE:Factory/.pgadmin3.new/pgadmin3.changes   2011-12-05 
12:44:54.0 +0100
@@ -1,0 +2,5 @@
+Fri Dec  2 16:45:00 UTC 2011 - co...@suse.com
+
+- add automake as buildrequire to avoid implicit dependency
+
+---



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.VARowi/_old  2011-12-05 12:44:56.0 +0100
+++ /var/tmp/diff_new_pack.VARowi/_new  2011-12-05 12:44:56.0 +0100
@@ -15,23 +15,27 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-# norootforbuild
-
-
 Name:   pgadmin3
 Summary:Management and Administration Tools for the PostgreSQL Database
 License:PostgreSQL
 Group:  Productivity/Databases/Tools
 Version:1.14.0
-Release:1
+Release:0
 Url:http://www.pgadmin.org/index.php
 # 
http://wwwmaster.postgresql.org/download/mirrors-ftp/pgadmin3/release/v{version}/src/pgadmin3-%{version}.tar.gz
 Source0:  pgadmin3-%{version}.tar.gz
 Source1:  %name.desktop
 Source2:  %name.png
-BuildRequires:  gcc-c++ libopenssl-devel libxml2-devel libxslt-devel 
postgresql-devel update-desktop-files
+BuildRequires:  automake
+BuildRequires:  gcc-c++
+BuildRequires:  libopenssl-devel
+BuildRequires:  libxml2-devel
+BuildRequires:  libxslt-devel
+BuildRequires:  postgresql-devel
+BuildRequires:  update-desktop-files
 %if 0%{?suse_version} = 1140
-BuildRequires:  wxWidgets wxWidgets-wxcontainer-devel
+BuildRequires:  wxWidgets
+BuildRequires:  wxWidgets-wxcontainer-devel
 %define _use_internal_dependency_generator 0
 %define __find_requires %wx_requires
 %else
@@ -108,7 +112,6 @@
 done
 popd #%{buildroot}%{_datadir}/pgadmin3/docs
 
-
 %if 0%{?sles_version} == 10 || 0%{?sles_version} == 9
 %suse_update_desktop_file %{name} System Database
 %else
@@ -123,8 +126,10 @@
 %{?buildroot:%__rm -rf %{buildroot}}
 
 %if 0%{?sles_version} != 10  0%{?sles_version} != 9
+
 %files
 %else
+
 %files -f %{name}.lang
 %endif
 %defattr(-, root, root)
@@ -144,6 +149,7 @@
 %{_datadir}/pixmaps/%{name}.png
 
 %if 0%{?sles_version} != 10  0%{?sles_version} != 9
+
 %files lang -f %{name}.lang
 %defattr(-, root, root)
 %endif


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit pgadmin3 for openSUSE:Factory

2011-09-26 Thread h_root

Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory
checked in at Mon Sep 26 10:10:43 CEST 2011.




--- pgadmin3/pgadmin3.changes   2011-04-11 13:25:57.0 +0200
+++ /mounts/work_src_done/STABLE/pgadmin3/pgadmin3.changes  2011-09-16 
22:38:12.0 +0200
@@ -1,0 +2,6 @@
+Fri Sep 16 20:36:25 UTC 2011 - klaussfre...@gmail.com
+
+- update to upstream 1.14.0
+  * see http://www.pgadmin.org/development/changelog.php
+
+---
@@ -4,0 +11,5 @@
+
+---
+Mon Mar 28 15:49:37 UTC 2011 - klaussfre...@gmail.com
+
+- update to upstream git 2011-03-28

calling whatdependson for head-i586


Old:

  pgadmin3-1.12.1.tar.bz2
  pgadmin3-1.8.2-rpmoptflags.patch

New:

  pgadmin3-1.14.0.tar.gz



Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.DoS6vi/_old  2011-09-26 10:10:36.0 +0200
+++ /var/tmp/diff_new_pack.DoS6vi/_new  2011-09-26 10:10:36.0 +0200
@@ -22,14 +22,13 @@
 Summary:Management and Administration Tools for the PostgreSQL Database
 License:PostgreSQL
 Group:  Productivity/Databases/Tools
-Version:1.12.1
-Release:2
+Version:1.14.0
+Release:1
 Url:http://www.pgadmin.org/index.php
-# 
http://ftp.de.postgresql.org/packages/databases/PostgreSQL/pgadmin3/release/v%{version}/src/pgadmin3-%{version}.tar.gz
-Source0:pgadmin3-%{version}.tar.bz2
+# 
http://wwwmaster.postgresql.org/download/mirrors-ftp/pgadmin3/release/v{version}/src/pgadmin3-%{version}.tar.gz
+Source0:  pgadmin3-%{version}.tar.gz
 Source1:%name.desktop
 Source2:%name.png
-Recommends: postgresql-server
 BuildRequires:  gcc-c++ libopenssl-devel libxml2-devel libxslt-devel 
postgresql-devel update-desktop-files
 %if 0%{?suse_version} = 1140
 BuildRequires:  wxWidgets wxWidgets-wxcontainer-devel
@@ -39,11 +38,13 @@
 BuildRequires:  wxGTK-devel
 %endif
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-Patch1: pgadmin3-1.8.2-rpmoptflags.patch
 %if 0%{?suse_version} = 1030
 BuildRequires:  fdupes
 %endif
+%if 0%{?sles_version} != 10  0%{?sles_version} != 9
+Recommends:postgresql-server
 Recommends: %{name}-lang = %{version}
+%endif
 
 %description
 pgAdmin III is an administration and management tool for the PostgreSQL
@@ -58,21 +59,25 @@
 %lang_package
 %prep
 %setup -q
-%patch1
 
 %__sed -i 's/\r$//' LICENSE TODO CHANGELOG # remove wrong EOL
 %__sed -i 's/\r$//' docs/fr_FR/pgadmin3.{css,hhc,hhp} # remove wrong EOL
 
 %build
 
-autoreconf -fiv
+%if 0%{?suse_version}  1010
+  autoreconf -fiv
+%else
+  autoheader
+  autoconf
+%endif
 
 export CFLAGS=%optflags -fstack-protector
 export CXXFLAGS=%optflags -fstack-protector
 
 %configure --with-pic --disable-static
 
-%__make %{?jobs:-j%jobs}
+%__make %{?_smp_mflags}
 
 %install
 
@@ -82,6 +87,9 @@
 # whatever that symlink is doing there...
 %__rm %{buildroot}%{_datadir}/pgadmin3/i18n/wxstd.mo
 
+# png2c is an internal helper... why is it installed?
+%__rm %{buildroot}%{_bindir}/png2c
+
 # fix permissions
 find %{buildroot}%{_datadir}/pgadmin3/docs/ -type f -exec %__chmod 644 {} \;
 
@@ -100,7 +108,12 @@
 done
 popd #%{buildroot}%{_datadir}/pgadmin3/docs
 
+
+%if 0%{?sles_version} == 10 || 0%{?sles_version} == 9
+%suse_update_desktop_file %{name} System Database
+%else
 %suse_update_desktop_file -i %name System Database
+%endif
 
 %if 0%{?suse_version} = 1030
 %fdupes -s %{buildroot}%{_datadir}/pgadmin3
@@ -109,7 +122,11 @@
 %clean
 %{?buildroot:%__rm -rf %{buildroot}}
 
+%if 0%{?sles_version} != 10  0%{?sles_version} != 9
 %files
+%else
+%files -f %{name}.lang
+%endif
 %defattr(-, root, root)
 %doc BUGS CHANGELOG LICENSE README TODO
 %{_bindir}/pgadmin3
@@ -119,13 +136,16 @@
 %{_datadir}/pgadmin3/i18n/pgadmin3.lng
 %{_datadir}/pgadmin3/i18n/pg_settings.csv
 %dir %{_datadir}/pgadmin3/branding
+%dir %{_datadir}/pgadmin3/plugins.d
 %config(noreplace) %{_datadir}/pgadmin3/branding/branding.ini
-%config(noreplace) %{_datadir}/pgadmin3/plugins.ini
+%config(noreplace) %{_datadir}/pgadmin3/plugins.d/plugins.ini
 %config(noreplace) %{_datadir}/pgadmin3/settings.ini
 %{_datadir}/applications/%{name}.desktop
 %{_datadir}/pixmaps/%{name}.png
 
+%if 0%{?sles_version} != 10  0%{?sles_version} != 9
 %files lang -f %{name}.lang
 %defattr(-, root, root)
+%endif
 
 %changelog







Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit pgadmin3 for openSUSE:Factory

2011-04-14 Thread h_root

Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory
checked in at Thu Apr 14 14:42:35 CEST 2011.




--- pgadmin3/pgadmin3.changes   2011-03-01 18:22:03.0 +0100
+++ pgadmin3/pgadmin3.changes   2011-04-11 13:25:57.0 +0200
@@ -1,0 +2,5 @@
+Mon Apr 11 11:23:42 UTC 2011 - sasc...@suse.de
+
+- set license to 'PostgreSQL', fixes bnc#675943
+
+---

calling whatdependson for head-i586




Other differences:
--
++ pgadmin3.spec ++
--- /var/tmp/diff_new_pack.eBTPBe/_old  2011-04-14 14:41:25.0 +0200
+++ /var/tmp/diff_new_pack.eBTPBe/_new  2011-04-14 14:41:25.0 +0200
@@ -20,10 +20,10 @@
 
 Name:   pgadmin3
 Summary:Management and Administration Tools for the PostgreSQL Database
-License:Artistic
+License:PostgreSQL
 Group:  Productivity/Databases/Tools
 Version:1.12.1
-Release:1
+Release:2
 Url:http://www.pgadmin.org/index.php
 # 
http://ftp.de.postgresql.org/packages/databases/PostgreSQL/pgadmin3/release/v%{version}/src/pgadmin3-%{version}.tar.gz
 Source0:pgadmin3-%{version}.tar.bz2







Remember to have fun...

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit pgadmin3 for openSUSE:Factory

2011-03-02 Thread h_root

Hello community,

here is the log from the commit of package pgadmin3 for openSUSE:Factory
checked in at Wed Mar 2 10:20:10 CET 2011.




New Changes file:

--- /dev/null   2010-08-26 16:28:41.0 +0200
+++ /mounts/work_src_done/STABLE/pgadmin3/pgadmin3.changes  2011-03-01 
18:22:03.0 +0100
@@ -0,0 +1,119 @@
+---
+Tue Mar  1 17:21:38 UTC 2011 - mrueck...@suse.de
+
+- use wx_requires on 11.4 and newer
+
+---
+Thu Feb  3 18:56:27 UTC 2011 - sasc...@gmx.de
+
+- added dependency on wxWidgets for openSUSE-11.4 and greater
+
+---
+Wed Oct 27 03:06:27 UTC 2010 - ter...@gmail.com
+
+- update to 1.12.1:
+  * see http://www.pgadmin.org/development/changelog.php
+
+
+---
+Sun Aug  1 07:49:05 UTC 2010 - pascal.ble...@opensuse.org
+
+- update to 1.10.5:
+  * see http://www.pgadmin.org/development/changelog.php
+
+- splitted out I18N into -lang subpackage
+
+---
+Mon Jun  7 20:44:00 UTC 2010 - pascal.ble...@opensuse.org
+
+- update to 1.10.3:
+  * fix the quiet log query in the status server
+  * call Stored Procedures in EnterpriseDB in an anonymous block to prevent 
errors with out/inout parameters.
+  * fix an error when working with packages on EnterpriseDB in 'postgres' mode
+  * prevent a crash if the user cancels a restore operation
+  * fix the refresh of a dropped function
+  * fix to only show Storage value if the value is different from the type's 
default value
+  * fix uncalled attempt to change array data types in dlgColumn
+  * fix a crash that could occur if viewing a table with no rows in the Edit 
Grid
+  * fix a crash occuring when a function with a parameter with a default is 
selected
+  * don't offer debugging options to non-superusers on Postgres Plus Advanced 
Server  8.4 which doesn't have support for user debugging
+  * fix the saving and reverse engineering of parameters for database, table, 
and function
+  * specify the schema of the table/function to restore if pg_restore's 
release is 8.2 or later
+  * fix the reverse engineering of a rule
+  * fix the recent files, by notifying each frmQuery to update their recent 
files -- same support for macros and favourites
+  * fix the canvas resizing with really big table
+  * add the missing RULEs for VIEWs in SQL pane
+  * add groups in the owner combobox
+  * get back to the Properties tab when a user connects to a server
+  * fix the reverse engineering of a table when its columns have Storage or 
Statistics value
+  * correct reverse engineering of a function that RETURNS TABLE
+  * display the tablespace in the reverse-engineered SQL of the database
+  * make sure Use Replication is visible even with a big comment on an column
+  * prevent a crash on the GQB when someone right click to delete a join 
rather than properly select it
+  * make sure that Statistics tab doesn't show more databases than Properties 
tab
+  * warn the user if a file couldn't be opened because it contains invalid 
characters
+  * fix command line quoting for backup/restore
+  * avoid a crash when debugging NULL procedures
+
+---
+Fri Mar 12 08:51:32 UTC 2010 - pascal.ble...@opensuse.org
+
+- update to 1.10.2:
+  * correctly save the position of a pgFrame
+  * fix the reverse engineering of a function
+  * fix the xmlTextWriterEndDocument check when saving a favorite
+  * fix an SQL error when changing a parameter for a database, role/user and a 
function
+  * fix the display of a type with a specific typmod
+  * select the server choosen with the /s command-line argument.
+  * fix the call to the Slony-I storenode function
+  * fix display of the date/time chooser
+
+- changes from 1.10.1:
+  * replace Alt-F4 with Ctrl-Q and Ctrl-W
+  * prevent a crash if the edit grid is closed whilst it is loading data
+  * don't attempt to remove rows in the edit grid if the user presses the 
delete key when the delete button is disabled
+  * only offer valid server encodings for new databases
+  * fix an issue with the ordering of the mappings in a text search 
configuration
+  * fix a potential crash bug in the object browser
+  * reverse engineer empty (not NULL) ACLs correctly
+  * fix Greenplum support for column oriented partitions
+  * ensure function variables get reset if the function is modified
+  * fix cluster creation for Slony 2.0
+  * reverse engineer function defaults values correctly
+  * fix a potential crash in the edit grid
+  * fix domain creation/modification for domains in non-default schemas
+  * reverse engineer language privileges correctly
+  * get rid of No SQL query was generated. message dialog when no tables are 
selected in the GQB
+  * hints