commit python-oslo.messaging for openSUSE:Factory

2020-10-26 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2020-10-26 16:16:50

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new.3463 (New)


Package is "python-oslo.messaging"

Mon Oct 26 16:16:50 2020 rev:23 rq:841211 version:12.5.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2020-08-10 15:06:03.492255812 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new.3463/python-oslo.messaging.changes
2020-10-26 16:17:29.942992349 +0100
@@ -1,0 +2,29 @@
+Fri Oct  9 19:17:18 UTC 2020 - cloud-de...@suse.de
+
+- update to version 12.5.0
+  - Remove six usage
+  - Cancel consumer if queue down
+  - Remove the unused coding style modules
+  - Simplify tools/test-setup.sh
+  - Add release notes links to doc index
+  - Bump bandit version
+  - Remove monotonic usage
+  - Add py38 package metadata
+  - Fix pygments style
+  - tests: Resolves issues with kombu > 4.6.8
+  - Fix some typos
+  - Print warning message when connection running out
+  - Add Python3 victoria unit tests
+  - [goal] Migrate testing to ubuntu focal
+  - Add a ping endpoint to RPC dispatcher
+  - Catch ConnectionForced Exception
+  - Move legacy grenade jobs to Zuul v3
+  - Switch to newer openstackdocstheme and reno versions
+  - Update master for stable/ussuri
+  - Fix hacking min version to 3.0.1
+  - Imported Translations from Zanata
+  - Align contributing doc with oslo's policy
+  - Bump default tox env from py37 to py38
+  - Drop a python 2 exception management
+
+---

Old:

  oslo.messaging-12.1.2.tar.gz

New:

  oslo.messaging-12.5.0.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.1TIlKq/_old  2020-10-26 16:17:30.678992941 +0100
+++ /var/tmp/diff_new_pack.1TIlKq/_new  2020-10-26 16:17:30.682992944 +0100
@@ -17,15 +17,15 @@
 
 
 Name:   python-oslo.messaging
-Version:12.1.2
+Version:12.5.0
 Release:0
 Summary:OpenStack oslo.messaging library
 License:Apache-2.0
 Group:  Development/Languages/Python
 URL:https://launchpad.net/oslo.messaging
-Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-12.1.2.tar.gz
+Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-12.5.0.tar.gz
 BuildRequires:  openstack-macros
-BuildRequires:  python3-PyYAML >= 3.12
+BuildRequires:  python3-PyYAML >= 3.13
 BuildRequires:  python3-WebOb >= 1.7.1
 BuildRequires:  python3-amqp >= 2.5.2
 BuildRequires:  python3-cachetools >= 2.0.0
@@ -37,7 +37,7 @@
 BuildRequires:  python3-greenlet
 BuildRequires:  python3-kombu >= 4.6.6
 BuildRequires:  python3-mock
-BuildRequires:  python3-monotonic >= 0.6
+BuildRequires:  python3-monotonic
 BuildRequires:  python3-oslo.config >= 5.2.0
 BuildRequires:  python3-oslo.i18n
 BuildRequires:  python3-oslo.log >= 3.36.0
@@ -48,7 +48,7 @@
 BuildRequires:  python3-oslotest
 BuildRequires:  python3-pbr >= 2.0.0
 BuildRequires:  python3-pyngus
-BuildRequires:  python3-six >= 1.10.0
+BuildRequires:  python3-six
 BuildRequires:  python3-stestr
 BuildRequires:  python3-stevedore >= 1.20.0
 BuildRequires:  python3-testscenarios
@@ -62,7 +62,7 @@
 %package -n python3-oslo.messaging
 Summary:OpenStack oslo.messaging library
 Group:  Development/Languages/Python
-Requires:   python3-PyYAML >= 3.12
+Requires:   python3-PyYAML >= 3.13
 Requires:   python3-WebOb >= 1.7.1
 Requires:   python3-amqp >= 2.5.2
 Requires:   python3-cachetools >= 2.0.0
@@ -77,7 +77,7 @@
 Requires:   python3-oslo.serialization >= 2.18.0
 Requires:   python3-oslo.service >= 1.24.0
 Requires:   python3-oslo.utils >= 3.37.0
-Requires:   python3-six >= 1.10.0
+Requires:   python3-six
 Requires:   python3-stevedore >= 1.20.0
 %if 0%{?suse_version}
 Obsoletes:  python2-oslo.messaging < 12.0.0
@@ -101,7 +101,7 @@
 This package contains the documentation.
 
 %prep
-%autosetup -p1 -n oslo.messaging-12.1.2
+%autosetup -p1 -n oslo.messaging-12.5.0
 %py_req_cleanup
 
 %build

++ _service ++
--- /var/tmp/diff_new_pack.1TIlKq/_old  2020-10-26 16:17:30.706992964 +0100
+++ /var/tmp/diff_new_pack.1TIlKq/_new  2020-10-26 16:17:30.706992964 +0100
@@ -1,8 +1,8 @@
 
   
-https://opendev.org/openstack/rpm-packaging/raw/branch/stable/ussuri/openstack/oslo.messaging/oslo.messaging.spec.j2
+

commit python-oslo.messaging for openSUSE:Factory

2020-08-10 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2020-08-10 15:05:31

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new.3399 (New)


Package is "python-oslo.messaging"

Mon Aug 10 15:05:31 2020 rev:22 rq:825319 version:12.1.2

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2020-07-29 17:21:03.996589649 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new.3399/python-oslo.messaging.changes
2020-08-10 15:06:03.492255812 +0200
@@ -1,0 +2,11 @@
+Wed Aug  5 12:36:58 UTC 2020 - cloud-de...@suse.de
+
+- Proper fix for forever looping test (bsc#1163136) is the kombu change below
+- update to version 12.1.2
+  - tests: Resolves issues with kombu > 4.6.8
+  - Update .gitreview for stable/ussuri
+  - Update TOX/UPPER_CONSTRAINTS_FILE for stable/ussuri
+  - Simplify tools/test-setup.sh
+  - Print warning message when connection running out
+
+---

Old:

  oslo.messaging-12.1.0.tar.gz

New:

  oslo.messaging-12.1.2.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.NjiCUd/_old  2020-08-10 15:06:04.632256414 +0200
+++ /var/tmp/diff_new_pack.NjiCUd/_new  2020-08-10 15:06:04.636256416 +0200
@@ -17,13 +17,13 @@
 
 
 Name:   python-oslo.messaging
-Version:12.1.0
+Version:12.1.2
 Release:0
 Summary:OpenStack oslo.messaging library
 License:Apache-2.0
 Group:  Development/Languages/Python
 URL:https://launchpad.net/oslo.messaging
-Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-12.1.0.tar.gz
+Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-12.1.2.tar.gz
 BuildRequires:  openstack-macros
 BuildRequires:  python3-PyYAML >= 3.12
 BuildRequires:  python3-WebOb >= 1.7.1
@@ -101,16 +101,9 @@
 This package contains the documentation.
 
 %prep
-%autosetup -p1 -n oslo.messaging-12.1.0
+%autosetup -p1 -n oslo.messaging-12.1.2
 %py_req_cleanup
 
-%if !0%{?suse_version}
-# FIXME(jpena): since version 5.23.0, four tests in the amqp driver are
-# failing. Let's remove the tests for now, so we can build a package and
-# figure out whatis wrong.
-rm -f oslo_messaging/tests/drivers/test_amqp_driver.py
-%endif
-
 %build
 %py3_build
 
@@ -124,11 +117,11 @@
 
 %check
 # NOTE(jpena): we do not want to run functional tests, just unit tests
+# python3-pifpaf is not available in RDO, but loading functional tests would
+# fail without it
 rm -rf oslo_messaging/tests/functional
-# workaround test running forever until update to release with fix
-# https://review.opendev.org/#/c/742609/
-rm -f oslo_messaging/tests/drivers/test_impl_rabbit.py
-python3 -m stestr.cli run
+# 3 cyrus tests fail on rdo with time out
+python3 -m stestr.cli run --black-regex 
'^oslo_messaging.tests.(functional|drivers.test_amqp_driver.TestCyrusAuthentication.test_authentication_(ok|ignore_default_realm|default_realm))'
 
 %files -n python3-oslo.messaging
 %license LICENSE

++ oslo.messaging-12.1.0.tar.gz -> oslo.messaging-12.1.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.messaging-12.1.0/.zuul.yaml 
new/oslo.messaging-12.1.2/.zuul.yaml
--- old/oslo.messaging-12.1.0/.zuul.yaml2020-04-07 12:11:11.0 
+0200
+++ new/oslo.messaging-12.1.2/.zuul.yaml2020-08-03 16:09:27.0 
+0200
@@ -10,21 +10,21 @@
 parent: openstack-tox-py36
 vars:
   tox_envlist: py36-func-scenario02
-  bindep_profile: rabbit kafka
+  bindep_profile: rabbit kafka amqp1
 
 - job:
 name: oslo.messaging-tox-py36-func-scenario03
 parent: openstack-tox-py36
 vars:
   tox_envlist: py36-func-scenario03
-  bindep_profile: rabbit
+  bindep_profile: rabbit amqp1
 
 - job:
 name: oslo.messaging-tox-py36-func-scenario04
 parent: openstack-tox-py36
 vars:
   tox_envlist: py36-func-scenario04
-  bindep_profile: kafka
+  bindep_profile: kafka amqp1
 
 # Begin v3 native jobs
 # See https://docs.openstack.org/devstack/latest/
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.messaging-12.1.0/AUTHORS 
new/oslo.messaging-12.1.2/AUTHORS
--- old/oslo.messaging-12.1.0/AUTHORS   2020-04-07 12:12:21.0 +0200
+++ new/oslo.messaging-12.1.2/AUTHORS   2020-08-03 16:12:26.0 +0200
@@ -226,6 +226,7 @@
 pengyuesheng 
 ricolin 
 root 
+shenjiatong 
 sonu.kumar 
 tengqm 
 ting.wang 

commit python-oslo.messaging for openSUSE:Factory

2020-07-29 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2020-07-29 17:19:56

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new.3592 (New)


Package is "python-oslo.messaging"

Wed Jul 29 17:19:56 2020 rev:21 rq:823213 version:12.1.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2020-06-05 20:16:31.319048364 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new.3592/python-oslo.messaging.changes
2020-07-29 17:21:03.996589649 +0200
@@ -1,0 +2,6 @@
+Tue Jul 28 11:31:49 UTC 2020 - Jan Zerebecki 
+
+- as a workaround (bsc#1163136) disable test for rabbit until a release with
+  fix is available, otherwise build would loop forever
+
+---



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.OrwtSZ/_old  2020-07-29 17:21:05.688591105 +0200
+++ /var/tmp/diff_new_pack.OrwtSZ/_new  2020-07-29 17:21:05.692591108 +0200
@@ -125,6 +125,9 @@
 %check
 # NOTE(jpena): we do not want to run functional tests, just unit tests
 rm -rf oslo_messaging/tests/functional
+# workaround test running forever until update to release with fix
+# https://review.opendev.org/#/c/742609/
+rm -f oslo_messaging/tests/drivers/test_impl_rabbit.py
 python3 -m stestr.cli run
 
 %files -n python3-oslo.messaging




commit python-oslo.messaging for openSUSE:Factory

2020-06-05 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2020-06-05 20:14:38

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new.3606 (New)


Package is "python-oslo.messaging"

Fri Jun  5 20:14:38 2020 rev:20 rq:803593 version:12.1.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2020-03-24 22:32:48.305102903 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new.3606/python-oslo.messaging.changes
2020-06-05 20:16:31.319048364 +0200
@@ -1,0 +2,32 @@
+Tue May 12 09:45:06 UTC 2020 - cloud-de...@suse.de
+
+- update to version 12.1.0
+  - Update the constraints url
+  - Removed unused variable pools
+  - Update master for stable/train
+  - remove outdated header
+  - Make sure minimum amqp is 2.5.2
+  - Do not use threading.Event
+  - Align message serialization between drivers
+  - Ignore releasenote cache within git untracked files
+  - tox: Trivial cleanup
+  - tox: Keeping going with docs
+  - Migrate grenade jobs to py3
+  - Remove telemetry checks
+  - Revert "Add RPC incoming and reply log"
+  - Adding debug logs on AMQPListener poll
+  - Add support for kafka SSL autentication
+  - Switch to Ussuri jobs
+  - Add RPC incoming and reply log
+  - Remove the deprecated blocking executor
+  - Fix help text for heartbeat_in_pthread option
+  - Remove unused variable WAKE_UP
+  - Setup backend scenarios for functional tests
+  - Fix spacing in help message
+  - Update hacking for Python3
+  - Modify some comments to make them clickable
+  - Don't log NoSuchMethod for special non-existing methods
+  - [ussuri][goal] Drop python 2.7 support and testing
+  - reword releasenote for py27 support dropping
+
+---

Old:

  oslo.messaging-10.2.0.tar.gz

New:

  oslo.messaging-12.1.0.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.QOKmI5/_old  2020-06-05 20:16:32.707053471 +0200
+++ /var/tmp/diff_new_pack.QOKmI5/_new  2020-06-05 20:16:32.715053500 +0200
@@ -17,17 +17,17 @@
 
 
 Name:   python-oslo.messaging
-Version:10.2.0
+Version:12.1.0
 Release:0
 Summary:OpenStack oslo.messaging library
 License:Apache-2.0
 Group:  Development/Languages/Python
 URL:https://launchpad.net/oslo.messaging
-Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-10.2.0.tar.gz
+Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-12.1.0.tar.gz
 BuildRequires:  openstack-macros
 BuildRequires:  python3-PyYAML >= 3.12
 BuildRequires:  python3-WebOb >= 1.7.1
-BuildRequires:  python3-amqp >= 2.4.1
+BuildRequires:  python3-amqp >= 2.5.2
 BuildRequires:  python3-cachetools >= 2.0.0
 BuildRequires:  python3-confluent-kafka
 BuildRequires:  python3-debtcollector >= 1.2.0
@@ -35,7 +35,7 @@
 BuildRequires:  python3-fixtures
 BuildRequires:  python3-futurist >= 1.2.0
 BuildRequires:  python3-greenlet
-BuildRequires:  python3-kombu >= 4.6.1
+BuildRequires:  python3-kombu >= 4.6.6
 BuildRequires:  python3-mock
 BuildRequires:  python3-monotonic >= 0.6
 BuildRequires:  python3-oslo.config >= 5.2.0
@@ -44,7 +44,7 @@
 BuildRequires:  python3-oslo.middleware >= 3.31.0
 BuildRequires:  python3-oslo.serialization >= 2.18.0
 BuildRequires:  python3-oslo.service >= 1.24.0
-BuildRequires:  python3-oslo.utils >= 3.33.0
+BuildRequires:  python3-oslo.utils >= 3.37.0
 BuildRequires:  python3-oslotest
 BuildRequires:  python3-pbr >= 2.0.0
 BuildRequires:  python3-pyngus
@@ -64,19 +64,19 @@
 Group:  Development/Languages/Python
 Requires:   python3-PyYAML >= 3.12
 Requires:   python3-WebOb >= 1.7.1
-Requires:   python3-amqp >= 2.4.1
+Requires:   python3-amqp >= 2.5.2
 Requires:   python3-cachetools >= 2.0.0
 Requires:   python3-debtcollector >= 1.2.0
 Requires:   python3-futurist >= 1.2.0
 Requires:   python3-greenlet
-Requires:   python3-kombu >= 4.6.1
+Requires:   python3-kombu >= 4.6.6
 Requires:   python3-oslo.config >= 5.2.0
 Requires:   python3-oslo.i18n
 Requires:   python3-oslo.log >= 3.36.0
 Requires:   python3-oslo.middleware >= 3.31.0
 Requires:   python3-oslo.serialization >= 2.18.0
 Requires:   python3-oslo.service >= 1.24.0
-Requires:   python3-oslo.utils >= 3.33.0
+Requires:   python3-oslo.utils >= 3.37.0
 Requires:   python3-six >= 1.10.0
 Requires:   python3-stevedore >= 1.20.0
 %if 0%{?suse_version}
@@ -101,7 +101,7 @@
 This package contains the 

commit python-oslo.messaging for openSUSE:Factory

2020-03-24 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2020-03-24 22:32:47

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new.3160 (New)


Package is "python-oslo.messaging"

Tue Mar 24 22:32:47 2020 rev:19 rq:787445 version:10.2.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2020-02-18 10:41:42.197103391 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new.3160/python-oslo.messaging.changes
2020-03-24 22:32:48.305102903 +0100
@@ -1,0 +2,10 @@
+Mon Mar 23 12:19:43 UTC 2020 - Dirk Mueller 
+
+- add obsoletes
+
+---
+Sat Mar 14 12:04:03 UTC 2020 - Dirk Mueller 
+
+- switch to python 3.x only builds
+
+---



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.XCOAN3/_old  2020-03-24 22:32:49.173103325 +0100
+++ /var/tmp/diff_new_pack.XCOAN3/_new  2020-03-24 22:32:49.177103327 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-oslo.messaging
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -25,35 +25,6 @@
 URL:https://launchpad.net/oslo.messaging
 Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-10.2.0.tar.gz
 BuildRequires:  openstack-macros
-BuildRequires:  python2-PyYAML >= 3.12
-BuildRequires:  python2-WebOb >= 1.7.1
-BuildRequires:  python2-amqp >= 2.4.1
-BuildRequires:  python2-cachetools >= 2.0.0
-BuildRequires:  python2-confluent-kafka
-BuildRequires:  python2-debtcollector >= 1.2.0
-BuildRequires:  python2-eventlet
-BuildRequires:  python2-fixtures
-BuildRequires:  python2-futurist >= 1.2.0
-BuildRequires:  python2-greenlet
-BuildRequires:  python2-kombu >= 4.6.1
-BuildRequires:  python2-mock
-BuildRequires:  python2-monotonic >= 0.6
-BuildRequires:  python2-oslo.config >= 5.2.0
-BuildRequires:  python2-oslo.i18n
-BuildRequires:  python2-oslo.log >= 3.36.0
-BuildRequires:  python2-oslo.middleware >= 3.31.0
-BuildRequires:  python2-oslo.serialization >= 2.18.0
-BuildRequires:  python2-oslo.service >= 1.24.0
-BuildRequires:  python2-oslo.utils >= 3.33.0
-BuildRequires:  python2-oslotest
-BuildRequires:  python2-pbr >= 2.0.0
-BuildRequires:  python2-pifpaf
-BuildRequires:  python2-pyngus
-BuildRequires:  python2-six >= 1.10.0
-BuildRequires:  python2-stestr
-BuildRequires:  python2-stevedore >= 1.20.0
-BuildRequires:  python2-testscenarios
-BuildRequires:  python2-testtools
 BuildRequires:  python3-PyYAML >= 3.12
 BuildRequires:  python3-WebOb >= 1.7.1
 BuildRequires:  python3-amqp >= 2.4.1
@@ -66,6 +37,7 @@
 BuildRequires:  python3-greenlet
 BuildRequires:  python3-kombu >= 4.6.1
 BuildRequires:  python3-mock
+BuildRequires:  python3-monotonic >= 0.6
 BuildRequires:  python3-oslo.config >= 5.2.0
 BuildRequires:  python3-oslo.i18n
 BuildRequires:  python3-oslo.log >= 3.36.0
@@ -75,55 +47,55 @@
 BuildRequires:  python3-oslo.utils >= 3.33.0
 BuildRequires:  python3-oslotest
 BuildRequires:  python3-pbr >= 2.0.0
-BuildRequires:  python3-pifpaf
 BuildRequires:  python3-pyngus
 BuildRequires:  python3-six >= 1.10.0
 BuildRequires:  python3-stestr
 BuildRequires:  python3-stevedore >= 1.20.0
 BuildRequires:  python3-testscenarios
 BuildRequires:  python3-testtools
-Requires:   python-PyYAML >= 3.12
-Requires:   python-WebOb >= 1.7.1
-Requires:   python-amqp >= 2.4.1
-Requires:   python-cachetools >= 2.0.0
-Requires:   python-debtcollector >= 1.2.0
-Requires:   python-futurist >= 1.2.0
-Requires:   python-greenlet
-Requires:   python-kombu >= 4.6.1
-Requires:   python-oslo.config >= 5.2.0
-Requires:   python-oslo.i18n
-Requires:   python-oslo.log >= 3.36.0
-Requires:   python-oslo.middleware >= 3.31.0
-Requires:   python-oslo.serialization >= 2.18.0
-Requires:   python-oslo.service >= 1.24.0
-Requires:   python-oslo.utils >= 3.33.0
-Requires:   python-six >= 1.10.0
-Requires:   python-stevedore >= 1.20.0
 BuildArch:  noarch
-%ifpython2
-Requires:   python-monotonic >= 0.6
-%endif
+
+%description
+The Oslo messaging API supports RPC and notifications over a number
+of different messaging transports.
+
+%package -n python3-oslo.messaging
+Summary:OpenStack oslo.messaging library
+Group:  Development/Languages/Python
+Requires:   python3-PyYAML >= 

commit python-oslo.messaging for openSUSE:Factory

2020-02-18 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2020-02-18 10:41:22

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new.26092 (New)


Package is "python-oslo.messaging"

Tue Feb 18 10:41:22 2020 rev:18 rq:774915 version:10.2.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2019-05-03 22:42:27.827246168 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new.26092/python-oslo.messaging.changes
   2020-02-18 10:41:42.197103391 +0100
@@ -1,0 +2,40 @@
+Wed Oct  9 12:26:51 UTC 2019 - cloud-de...@suse.de
+
+- update to version 10.2.0
+  - Replace git.openstack.org URLs with opendev.org URLs
+  - doc: Cleanup admin docs
+  - Add Python 3 Train unit tests
+  - Support kafka message compression
+  - Introduce RabbitMQ driver documentation
+  - Download kafka from archive.apache.org
+  - Handle collections.abc deprecations
+  - Update master for stable/stein
+  - Use default exchange for direct messaging
+  - Add the "transport_options" parameter to the amqp1 and kafka drivers.
+  - Clarify the documentation for pooled Notification Listeners
+  - Add transport_options parameter
+  - Implement the transport options
+  - Dropping the py35 testing
+  - Consider the topic parameter as an array in client-notify
+  - Fix nits on kafka compression help text
+  - Add thread name to the RabbitMQ heartbeat thread
+  - Replace openstack.org git:// URLs with https://
+  - Update messaging intermediaries for amqp1 tests
+  - Remove log translation and i18n
+  - Retry to declare a queue after internal error
+  - Unmark RabbitMQ heartbeat as experimental
+  - Add help msg to payload for CLI notifier
+  - Blacklist sphinx 2.1.0 (autodoc bug)
+  - Handle unexpected failures during call monitor heartbeat
+  - Allow users run the rabbitmq heartbeat inside a standard pthread.
+  - Cap Bandit below 1.6.0 and update Sphinx requirement
+  - Implement mandatory flag for RabbitMQ driver
+  - Add the mandatory flag for direct send
+  - fix typos
+  - Explain why Listener connections cannot be pooled
+  - OpenDev Migration Patch
+  - Bump the openstackdocstheme extension to 1.20
+  - Fix switch connection destination when a rabbitmq cluster node disappear
+  - Correcting typo in acknowledge spelling
+
+---

Old:

  oslo.messaging-9.5.0.tar.gz

New:

  oslo.messaging-10.2.0.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.3law5x/_old  2020-02-18 10:41:43.869106802 +0100
+++ /var/tmp/diff_new_pack.3law5x/_new  2020-02-18 10:41:43.877106819 +0100
@@ -17,15 +17,14 @@
 
 
 Name:   python-oslo.messaging
-Version:9.5.0
+Version:10.2.0
 Release:0
 Summary:OpenStack oslo.messaging library
 License:Apache-2.0
 Group:  Development/Languages/Python
 URL:https://launchpad.net/oslo.messaging
-Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-9.5.0.tar.gz
+Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-10.2.0.tar.gz
 BuildRequires:  openstack-macros
-BuildRequires:  python-devel
 BuildRequires:  python2-PyYAML >= 3.12
 BuildRequires:  python2-WebOb >= 1.7.1
 BuildRequires:  python2-amqp >= 2.4.1
@@ -36,11 +35,11 @@
 BuildRequires:  python2-fixtures
 BuildRequires:  python2-futurist >= 1.2.0
 BuildRequires:  python2-greenlet
-BuildRequires:  python2-kombu >= 4.0.0
+BuildRequires:  python2-kombu >= 4.6.1
 BuildRequires:  python2-mock
 BuildRequires:  python2-monotonic >= 0.6
 BuildRequires:  python2-oslo.config >= 5.2.0
-BuildRequires:  python2-oslo.i18n >= 3.15.3
+BuildRequires:  python2-oslo.i18n
 BuildRequires:  python2-oslo.log >= 3.36.0
 BuildRequires:  python2-oslo.middleware >= 3.31.0
 BuildRequires:  python2-oslo.serialization >= 2.18.0
@@ -49,15 +48,10 @@
 BuildRequires:  python2-oslotest
 BuildRequires:  python2-pbr >= 2.0.0
 BuildRequires:  python2-pifpaf
-BuildRequires:  python2-pika
-BuildRequires:  python2-pika-pool
 BuildRequires:  python2-pyngus
-BuildRequires:  python2-python-subunit
-BuildRequires:  python2-redis
 BuildRequires:  python2-six >= 1.10.0
 BuildRequires:  python2-stestr
 BuildRequires:  python2-stevedore >= 1.20.0
-BuildRequires:  python2-tenacity
 BuildRequires:  python2-testscenarios
 BuildRequires:  python2-testtools
 BuildRequires:  python3-PyYAML >= 3.12
@@ -66,15 +60,14 @@
 BuildRequires:  python3-cachetools >= 2.0.0
 BuildRequires:  python3-confluent-kafka
 BuildRequires:  python3-debtcollector >= 

commit python-oslo.messaging for openSUSE:Factory

2019-05-03 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2019-05-03 22:42:26

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new.5148 (New)


Package is "python-oslo.messaging"

Fri May  3 22:42:26 2019 rev:17 rq:692859 version:9.5.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2018-09-07 15:38:58.602563650 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new.5148/python-oslo.messaging.changes
2019-05-03 22:42:27.827246168 +0200
@@ -1,0 +2,53 @@
+Mon Apr  8 11:37:20 UTC 2019 - cloud-de...@suse.de
+
+- update to version 9.5.0
+  - Use '/' for the vhost if the transport_url has no trailing '/'
+  - Use ensure_connection to prevent loss of connection error logs
+  - Add a test for rabbit URLs lacking terminating '/'
+  - Fix the coverage tox tests
+  - Update mailinglist from dev to discuss
+  - Change python3.5 job to python3.7 job on Stein+
+  - import zuul job settings from project-config
+  - Remove rabbit_durable_queues deprecated option
+  - Remove deprecated amqp1 options
+  - Fix oslo.messaging default transport
+  - Remove setting of DEVSTACK_GATE_EXERCISES
+  - Update reno for stable/rocky
+  - Remove default_{host,port} deprecated options
+  - add python 3.6 unit test job
+  - Allow transport_url initialization in ConfFixture constructor
+  - add lib-forward-testing-python3 test job
+  - Avoid unnecessary use of items()
+  - Issue blocking ACK for RPC requests from the consumer thread
+  - Don't use monotonic with Python >=3.3
+  - Remove the deprecated ZeroMQ driver
+  - Use default exchange for direct messaging
+  - always build universal wheels
+  - doc: Remove crud from conf.py file
+  - Refactor GetTransportSadPathTestCase
+  - Bump amqp requirement version to >= 2.4.0
+  - Avoid logging passwords on connection events
+  - Kafka driver deployment guide
+  - Remove rpc_backend and ConfFixture.transport_driver
+  - Switch driver to confluent-kafka client library
+  - Bump amqp requirement version to >=2.4.1
+  - Update hacking version
+  - Using pip as a python module
+  - Clean up .gitignore references to personal tools
+  - Mark telemetry tests nv and remove from gate
+  - Remove deprecated rabbit options
+  - add python 3.7 unit test job
+  - Add release note about deprecated option removals
+  - Use templates for cover and lower-constraints
+  - Call listener stop only if listener is initialized
+
+---
+Wed Mar  6 22:09:37 UTC 2019 - cloud-de...@suse.de
+
+- update to version 8.1.2
+  - Update UPPER_CONSTRAINTS_FILE for stable/rocky
+  - Avoid logging passwords on connection events
+  - Update .gitreview for stable/rocky
+  - import zuul job settings from project-config
+
+---

Old:

  oslo.messaging-8.1.0.tar.gz

New:

  oslo.messaging-9.5.0.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.jyUdMZ/_old  2019-05-03 22:42:28.247247052 +0200
+++ /var/tmp/diff_new_pack.jyUdMZ/_new  2019-05-03 22:42:28.251247060 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-oslo.messaging
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,30 +12,30 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
 Name:   python-oslo.messaging
-Version:8.1.0
+Version:9.5.0
 Release:0
 Summary:OpenStack oslo.messaging library
 License:Apache-2.0
 Group:  Development/Languages/Python
 URL:https://launchpad.net/oslo.messaging
-Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-8.1.0.tar.gz
+Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-9.5.0.tar.gz
 BuildRequires:  openstack-macros
 BuildRequires:  python-devel
 BuildRequires:  python2-PyYAML >= 3.12
 BuildRequires:  python2-WebOb >= 1.7.1
-BuildRequires:  python2-amqp >= 2.3.0
+BuildRequires:  python2-amqp >= 2.4.1
 BuildRequires:  python2-cachetools >= 2.0.0
+BuildRequires:  python2-confluent-kafka
 BuildRequires:  python2-debtcollector >= 1.2.0
 

commit python-oslo.messaging for openSUSE:Factory

2018-09-07 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2018-09-07 15:38:56

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Fri Sep  7 15:38:56 2018 rev:16 rq:633102 version:8.1.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2018-03-19 23:36:04.382342797 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2018-09-07 15:38:58.602563650 +0200
@@ -1,0 +2,57 @@
+Sat Sep  1 08:57:45 UTC 2018 - cloud-de...@suse.de
+
+- update to version 8.1.0
+  - Remove transport aliases support
+  - Update reno for stable/queens
+  - Add restart() method to DecayingTimer
+  - Move requirements for the optional drivers (amqp1, kafka)
+  - Update telemetry integration playbooks
+  - Switch from pip_missing_reqs to pip_check_reqs
+  - Imported Translations from Zanata
+  - update configuration for qdrouter v1.0.0
+  - Add release notes link to README
+  - py37: drop use of 'async' as parameter name
+  - py37: deal with Exception repr changes
+  - Add kafka config options for security (ssl/sasl)
+  - Remove the deprecated Pika driver
+  - Update kafka and dsvm jobs
+  - Zuul: Remove project name
+  - [rabbitmq] Implement active call monitoring
+  - Revert "rabbit: Don't prefetch when batch_size is set"
+  - Modify grammatical errors
+  - Add ZeroMQ deprecation release note
+  - remove zmq tests
+  - Add kafka for python 3 functional test
+  - Remove stale pip-missing-reqs tox test.
+  - Switch to stestr
+  - Add a skeleton for a v3-native devstack job
+  - Convert legacy zuul jobs to v3
+  - Remove fake_rabbit configuration option
+  - No longer allow redundant calls to server start()
+  - Trivial: Update pypi url to new url
+  - Fix debug log message - missing argument
+  - Add warning output if failed to rebuild exception when deserialize
+  - Add support for synchronous commit
+  - Fixed telemetry integration zuul jobs
+  - Follow the new PTI for document build
+  - Correct usage of transport_url in example
+  - Add rabbitmq-server for platform:rpm into bindep.txt
+  - Replace 'raise StopIteration' with 'return'
+  - Moving stestr to correct package order in test-requirements.txt
+  - Bump py-amqp to >= 2.3.0
+  - Restore devstack project name in amqp1 test
+  - Make oslo.messaging-devstack-amqp1 job non-voting
+  - set default python to python3
+  - fix tox python3 overrides
+  - Fix the bandit security linter test
+  - Add ConfFixture.transport_url
+  - Fix oslo messaging gating
+  - fix lower constraints and uncap eventlet
+  - Add heartbeat() method to RpcIncomingMessage
+  - Enable RPC call monitoring in AMQP 1.0 driver
+  - Do not access the connection's socket during error callback
+  - Mark the ZeroMQ driver deprecated
+  - Updated from global requirements
+  - add lower-constraints job
+
+---

Old:

  oslo.messaging-5.35.0.tar.gz

New:

  oslo.messaging-8.1.0.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.4xpiLz/_old  2018-09-07 15:38:59.742562426 +0200
+++ /var/tmp/diff_new_pack.4xpiLz/_new  2018-09-07 15:38:59.746562421 +0200
@@ -17,92 +17,139 @@
 
 
 Name:   python-oslo.messaging
-Version:5.35.0
+Version:8.1.0
 Release:0
 Summary:OpenStack oslo.messaging library
 License:Apache-2.0
 Group:  Development/Languages/Python
-Url:https://launchpad.net/oslo.messaging
-Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-5.35.0.tar.gz
+URL:https://launchpad.net/oslo.messaging
+Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-8.1.0.tar.gz
 BuildRequires:  openstack-macros
-BuildRequires:  python-PyYAML >= 3.10
-BuildRequires:  python-WebOb >= 1.7.1
-BuildRequires:  python-amqp >= 2.1.1
-BuildRequires:  python-cachetools >= 2.0.0
-BuildRequires:  python-debtcollector >= 1.2.0
 BuildRequires:  python-devel
-BuildRequires:  python-eventlet >= 0.18.2
-BuildRequires:  python-fixtures >= 3.0.0
-BuildRequires:  python-futures >= 3.0.0
-BuildRequires:  python-futurist >= 1.2.0
-BuildRequires:  python-greenlet >= 0.4.10
-BuildRequires:  python-kafka-python >= 1.3.1
-BuildRequires:  python-kombu >= 4.0.0
-BuildRequires:  python-mock >= 2.0.0
-BuildRequires:  python-monotonic >= 0.6
-BuildRequires:  python-oslo.config >= 5.1.0
-BuildRequires:  python-oslo.i18n >= 3.15.3
-BuildRequires:  python-oslo.log >= 3.36.0

commit python-oslo.messaging for openSUSE:Factory

2018-03-19 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2018-03-19 23:36:00

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Mon Mar 19 23:36:00 2018 rev:15 rq:583342 version:5.35.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2018-01-24 15:27:49.073901102 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2018-03-19 23:36:04.382342797 +0100
@@ -1,0 +2,5 @@
+Fri Feb 23 13:23:04 UTC 2018 - tbecht...@suse.com
+
+- Switch to stable/queens spec template
+
+---



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.eycN4I/_old  2018-03-19 23:36:05.006320288 +0100
+++ /var/tmp/diff_new_pack.eycN4I/_new  2018-03-19 23:36:05.006320288 +0100
@@ -40,14 +40,14 @@
 BuildRequires:  python-kombu >= 4.0.0
 BuildRequires:  python-mock >= 2.0.0
 BuildRequires:  python-monotonic >= 0.6
-BuildRequires:  python-oslo.config >= 4.6.0
+BuildRequires:  python-oslo.config >= 5.1.0
 BuildRequires:  python-oslo.i18n >= 3.15.3
-BuildRequires:  python-oslo.log >= 3.30.0
+BuildRequires:  python-oslo.log >= 3.36.0
 BuildRequires:  python-oslo.middleware >= 3.31.0
 BuildRequires:  python-oslo.serialization >= 2.18.0
 BuildRequires:  python-oslo.service >= 1.24.0
-BuildRequires:  python-oslo.utils >= 3.31.0
-BuildRequires:  python-oslotest >= 1.10.0
+BuildRequires:  python-oslo.utils >= 3.33.0
+BuildRequires:  python-oslotest >= 3.2.0
 BuildRequires:  python-pbr >= 2.0.0
 BuildRequires:  python-pifpaf >= 0.10.0
 BuildRequires:  python-pika >= 0.10.0
@@ -72,13 +72,13 @@
 Requires:   python-greenlet >= 0.4.10
 Requires:   python-kombu >= 4.0.0
 Requires:   python-monotonic >= 0.6
-Requires:   python-oslo.config >= 4.6.0
+Requires:   python-oslo.config >= 5.1.0
 Requires:   python-oslo.i18n >= 3.15.3
-Requires:   python-oslo.log >= 3.30.0
+Requires:   python-oslo.log >= 3.36.0
 Requires:   python-oslo.middleware >= 3.31.0
 Requires:   python-oslo.serialization >= 2.18.0
 Requires:   python-oslo.service >= 1.24.0
-Requires:   python-oslo.utils >= 3.31.0
+Requires:   python-oslo.utils >= 3.33.0
 Requires:   python-pika >= 0.10.0
 Requires:   python-pika-pool >= 0.1.3
 Requires:   python-six >= 1.10.0
@@ -94,7 +94,7 @@
 Summary:Documentation for OpenStack messaging library
 Group:  Development/Languages/Python
 BuildRequires:  python-Sphinx
-BuildRequires:  python-openstackdocstheme >= 1.17.0
+BuildRequires:  python-openstackdocstheme >= 1.18.1
 
 %description doc
 The Oslo messaging API supports RPC and notifications over a number

++ _service ++
--- /var/tmp/diff_new_pack.eycN4I/_old  2018-03-19 23:36:05.062318267 +0100
+++ /var/tmp/diff_new_pack.eycN4I/_new  2018-03-19 23:36:05.062318267 +0100
@@ -1,8 +1,8 @@
 
   
-https://raw.githubusercontent.com/openstack/rpm-packaging/master/openstack/oslo.messaging/oslo.messaging.spec.j2
+https://raw.githubusercontent.com/openstack/rpm-packaging/stable/queens/openstack/oslo.messaging/oslo.messaging.spec.j2
 python-oslo.messaging.spec
-https://raw.githubusercontent.com/openstack/rpm-packaging/master/requirements.txt
+https://raw.githubusercontent.com/openstack/rpm-packaging/stable/queens/requirements.txt
 cloud-de...@suse.de
 gh,openstack,oslo.messaging
   




commit python-oslo.messaging for openSUSE:Factory

2018-01-24 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2018-01-24 15:27:46

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Wed Jan 24 15:27:46 2018 rev:14 rq:567275 version:5.35.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2017-08-28 15:30:54.048893377 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2018-01-24 15:27:49.073901102 +0100
@@ -1,0 +2,61 @@
+Mon Jan 15 11:56:37 UTC 2018 - cloud-de...@suse.de
+
+- update to version 5.35.0
+  - Fix default value of RPC dispatcher access_policy
+  - Ensure RPC endpoint target attribute is correct
+  - Add support for virtual hosts
+  - Imported Translations from Zanata
+  - Flesh out transport_url help
+  - Avoid tox_install.sh for constraints support
+  - don't convert generator to list unless required
+  - Fix wrong transport warnings in functional tests
+  - Suppress excessive debug logs when consume rabbit
+  - Add zmq packages that are no longer in bindep-fallback
+  - Catch socket.timeout when doing heartbeat_check
+  - Add kafka driver vhost emulation
+  - Fix some reST field lists in docstrings
+  - Provide bindep_profile in openstack-tox job setup
+  - Fix typo in contributor docs title
+  - Remove pbr version from setup.py
+  - Prevent rabbit from raising unexpected exceptions
+  - Update links in README
+  - Fix use of print function on python3
+  - Warn when wrong transport instance is used
+  - Remove envelope argument from driver send() interface
+  - Remove stable/newton from zuul settings
+  - sort when using groupby
+  - Zuul: add file extension to playbook path
+  - fix 'configration' typo
+  - Update kafka functional test
+  - Move legacy zuulv3 tests into oslo.messaging repo
+  - Remove the test that counts kombu connect calls
+  - Class-level _exchanges in FakeExchangeManager
+  - Remove unnecessary setUp function in testcase
+  - Fix a typo
+  - Create doc/requirements.txt
+  - Update amqp 1.0 driver deployment guide
+  - Remove setting of version/release from releasenotes
+  - fix batch handling
+  - Update reno for stable/pike
+  - rabbitmq: don't wait for message ack/requeue
+  - Updated from global requirements
+  - Add licenses and remove unused import in doc/source/conf.py
+
+---
+Wed Nov 22 10:30:15 UTC 2017 - vu...@suse.com
+
+- Add 0001-Catch-socket.timeout-when-doing-heartbeat_check.patch:
+  fix a specific kind of reconnection error when rabbitmq node goes
+  down.
+
+---
+Thu Sep 28 06:51:46 UTC 2017 - cloud-de...@suse.de
+
+- update to version 5.30.1
+  - Add support for virtual hosts
+  - Updated from global requirements
+  - Update .gitreview for stable/pike
+  - Remove the test that counts kombu connect calls
+  - Update UPPER_CONSTRAINTS_FILE for stable/pike
+
+---

Old:

  oslo.messaging-5.30.0.tar.gz

New:

  oslo.messaging-5.35.0.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.TLr5Cp/_old  2018-01-24 15:27:49.757869113 +0100
+++ /var/tmp/diff_new_pack.TLr5Cp/_new  2018-01-24 15:27:49.761868925 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-oslo.messaging
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,73 +16,72 @@
 #
 
 
-%global sname oslo.messaging
 Name:   python-oslo.messaging
-Version:5.30.0
+Version:5.35.0
 Release:0
 Summary:OpenStack oslo.messaging library
 License:Apache-2.0
 Group:  Development/Languages/Python
-Url:https://launchpad.net/%{sname}
-Source0:
https://pypi.io/packages/source/o/%{sname}/%{sname}-%{version}.tar.gz
+Url:https://launchpad.net/oslo.messaging
+Source0:
https://files.pythonhosted.org/packages/source/o/oslo.messaging/oslo.messaging-5.35.0.tar.gz
 BuildRequires:  openstack-macros
-BuildRequires:  python-PyYAML >= 3.10.0
+BuildRequires:  python-PyYAML >= 3.10
 BuildRequires:  python-WebOb >= 1.7.1
-BuildRequires:  python-amqp >= 2.1.0
-BuildRequires:  python-cachetools >= 1.1.0
+BuildRequires:  python-amqp >= 2.1.1
+BuildRequires:  python-cachetools >= 2.0.0
 BuildRequires:  

commit python-oslo.messaging for openSUSE:Factory

2017-08-28 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2017-08-28 15:30:52

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Mon Aug 28 15:30:52 2017 rev:13 rq:514891 version:5.30.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2017-04-06 11:01:58.697041530 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2017-08-28 15:30:54.048893377 +0200
@@ -1,0 +2,82 @@
+Mon Aug  7 09:18:48 UTC 2017 - cloud-de...@suse.de
+
+- update to version 5.30.0
+  - support kombu4
+  - Fix type of the kafka_consumer_timeout option
+  - Remove self.mox
+  - Try to fix TestSerializer.test_call_serializer failed randomly
+  - drop topic keyword from Notifier
+  - Break user credentials from host at the rightmost '@'
+  - Fix simulator's use of Notifier - use 'topics' not 'topic'
+  - Enable some off-by-default checks
+  - rabbit: restore synchronous ack/requeue
+  - Refactor logic of getting exector's executor_thread_pool_size
+  - Fix aliases deprecation
+  - Fix releasenotes
+  - Deprecate username/password config options in favor of TRANSPORT_URL
+  - Fix html_last_updated_fmt for Python3.
+  - Trivial: Add executor 'threading' in docstring
+  - [Fix gate]Update test requirement
+  - serializer: remove deprecated RequestContextSerializer
+  - Disable AMQP 1.0 SSL unit tests
+  - Update reno for stable/ocata
+  - [zmq] Dummy add value aging mechanism
+  - Validate the transport url query string
+  - switch from oslosphinx to openstackdocstheme
+  - Return list of addresses for IPV4 and IPV6
+  - Deprecate parameter aliases
+  - Fix serializer tests
+  - Optimize the link address
+  - deprecated blocking executor
+  - rearrange content to fit the new standard layout
+  - Add kafka_driver directory
+  - Add missing {posargs:} to AMQP 1.0 functional tests
+  - Fix the typo
+  - Build universal wheels
+  - pbr.version.VersionInfo needs package name (oslo.xyz and not oslo_xyz)
+  - tox: Build docs with Python 2.7
+  - Fix rabbitmq driver with blocking executor
+  - Mark the Pika driver as deprecated
+  - Remove mox3 from test-requirements.txt
+  - [zmq] Dynamic connections send failure
+  - drivers: use common.ConfigOptsProxy everywhere
+  - kafka: Remove testing hack for kafka
+  - Allow checking if notifier is enabled
+  - Retry support for oslo_messaging_notifications driver
+  - [AMQP 1.0] Properly shut down test RPC server
+  - tests: fix MultiStrOpt value
+  - Mock 'oslo_messaging.notify._impl_routing.LOG' in notifier tests
+  - remove all kombu<4.0.0 workarounds
+  - [AMQP 1.0] Add default SASL realm setting
+  - kafka: fix python3 exception
+  - Remove usage of parameter enforce_type
+  - Add get_rpc_transport call
+  - Fix the amqp1 SSL test CA certificate
+  - Clean up the TransportURL documentation
+  - Add note for blocking executor deprecation
+  - [zmq] pass a dummy TransportURL to register_opts
+  - rabbit: make ack/requeue thread-safe
+  - [zmq] Update configurations documentation
+  - Add "ssl" option for amqp driver
+  - [zmq] Failure of dynamic connections fanout
+  - [AMQP 1.0] if RPC call is configured as presettled ignore acks
+  - Add HACKING.rst
+  - [zmq] Properly analyse `use_dynamic_connections` option
+  - Add monkey_patch to demo code.
+  - kafka: ensure topics are created
+  - Move decorator updated_kwarg_default_value to right place
+  - RabbitMQ: Standardize SSL parameter names
+  - Remove old messaging notify driver alias
+  - kafka: skip multiple servers tests
+  - update the docs url in the readme
+  - Fix notification tests not unmocking logging
+  - Use Sphinx 1.5 warning-is-error
+  - tests: don't run functional tests in parallel
+  - [zmq] Prevent access to rpc_response_timeout
+  - Update URLs in documents according to document migration
+  - Updated from global requirements
+  - Remove use of mox stubs
+  - Stop using oslotest.mockpatch
+  - Test:Use unittest.mock on Python 3
+
+---

Old:

  oslo.messaging-5.17.1.tar.gz

New:

  oslo.messaging-5.30.0.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.PKRfti/_old  2017-08-28 15:30:55.252724140 +0200
+++ /var/tmp/diff_new_pack.PKRfti/_new  2017-08-28 15:30:55.256723577 +0200
@@ -18,7 +18,7 @@
 
 %global sname oslo.messaging
 Name:   python-oslo.messaging
-Version:5.17.1
+Version:5.30.0
 Release:0
 Summary:OpenStack oslo.messaging library
 License:Apache-2.0
@@ 

commit python-oslo.messaging for openSUSE:Factory

2017-04-06 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2017-04-06 11:01:53

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Thu Apr  6 11:01:53 2017 rev:12 rq:482827 version:5.17.1

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2017-02-21 13:40:30.447596143 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2017-04-06 11:01:58.697041530 +0200
@@ -1,0 +2,8 @@
+Mon Mar 27 09:04:14 UTC 2017 - cloud-de...@suse.de
+
+- update to version 5.17.1:
+  - [zmq] Failure of dynamic connections fanout
+  - Update .gitreview for stable/ocata
+  - Return list of addresses for IPV4 and IPV6
+
+---

Old:

  oslo.messaging-5.17.0.tar.gz

New:

  oslo.messaging-5.17.1.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.9YTowC/_old  2017-04-06 11:01:59.404941479 +0200
+++ /var/tmp/diff_new_pack.9YTowC/_new  2017-04-06 11:01:59.408940914 +0200
@@ -18,7 +18,7 @@
 
 %global sname oslo.messaging
 Name:   python-oslo.messaging
-Version:5.17.0
+Version:5.17.1
 Release:0
 Summary:OpenStack oslo.messaging library
 License:Apache-2.0
@@ -37,7 +37,7 @@
 BuildRequires:  python-futures >= 3.0
 BuildRequires:  python-futurist >= 0.11.0
 BuildRequires:  python-greenlet >= 0.3.2
-BuildRequires:  python-kafka-python >= 0.9.5
+BuildRequires:  python-kafka-python >= 1.3.1
 BuildRequires:  python-kombu >= 3.0.25
 BuildRequires:  python-mock >= 2.0
 BuildRequires:  python-monotonic >= 0.6

++ oslo.messaging-5.17.0.tar.gz -> oslo.messaging-5.17.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.messaging-5.17.0/AUTHORS 
new/oslo.messaging-5.17.1/AUTHORS
--- old/oslo.messaging-5.17.0/AUTHORS   2017-01-18 15:10:27.0 +0100
+++ new/oslo.messaging-5.17.1/AUTHORS   2017-02-27 12:35:58.0 +0100
@@ -113,6 +113,7 @@
 Nikola Dipanov 
 Numan Siddique 
 Oleksii Zamiatin 
+OpenStack Release Bot 
 Oscar Huang 
 Paul Michali 
 Paul Vinciguerra 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.messaging-5.17.0/ChangeLog 
new/oslo.messaging-5.17.1/ChangeLog
--- old/oslo.messaging-5.17.0/ChangeLog 2017-01-18 15:10:27.0 +0100
+++ new/oslo.messaging-5.17.1/ChangeLog 2017-02-27 12:35:58.0 +0100
@@ -1,6 +1,13 @@
 CHANGES
 ===
 
+5.17.1
+--
+
+* Return list of addresses for IPV4 and IPV6
+* [zmq] Failure of dynamic connections fanout
+* Update .gitreview for stable/ocata
+
 5.17.0
 --
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.messaging-5.17.0/PKG-INFO 
new/oslo.messaging-5.17.1/PKG-INFO
--- old/oslo.messaging-5.17.0/PKG-INFO  2017-01-18 15:10:27.0 +0100
+++ new/oslo.messaging-5.17.1/PKG-INFO  2017-02-27 12:35:59.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: oslo.messaging
-Version: 5.17.0
+Version: 5.17.1
 Summary: Oslo Messaging API
 Home-page: http://docs.openstack.org/developer/oslo.messaging/
 Author: OpenStack
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/oslo.messaging-5.17.0/oslo.messaging.egg-info/PKG-INFO 
new/oslo.messaging-5.17.1/oslo.messaging.egg-info/PKG-INFO
--- old/oslo.messaging-5.17.0/oslo.messaging.egg-info/PKG-INFO  2017-01-18 
15:10:27.0 +0100
+++ new/oslo.messaging-5.17.1/oslo.messaging.egg-info/PKG-INFO  2017-02-27 
12:35:58.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: oslo.messaging
-Version: 5.17.0
+Version: 5.17.1
 Summary: Oslo Messaging API
 Home-page: http://docs.openstack.org/developer/oslo.messaging/
 Author: OpenStack
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/oslo.messaging-5.17.0/oslo.messaging.egg-info/pbr.json 
new/oslo.messaging-5.17.1/oslo.messaging.egg-info/pbr.json
--- old/oslo.messaging-5.17.0/oslo.messaging.egg-info/pbr.json  2017-01-18 
15:10:27.0 +0100
+++ new/oslo.messaging-5.17.1/oslo.messaging.egg-info/pbr.json  2017-02-27 
12:35:58.0 +0100
@@ -1 +1 @@
-{"is_release": true, "git_version": "8424dbc"}
\ No newline at end of file
+{"git_version": "28d5df8", "is_release": true}
\ No newline at end of 

commit python-oslo.messaging for openSUSE:Factory

2017-02-21 Thread root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2017-02-21 13:40:29

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2016-12-04 15:08:25.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2017-02-21 13:40:30.447596143 +0100
@@ -1,0 +2,138 @@
+Fri Feb 10 16:00:40 UTC 2017 - cloud-de...@suse.de
+
+- update to version 5.17.0:
+  - [zmq] Make ZMQ TCP keepalive options configurable
+  - tox: use already installed kafka if present
+  - [zmq] Refactor make `zmq_address.target_to_key` a universal method
+  - tests: remove useless debug
+  - kafka: remove no really implemented feature
+  - cast() and RPC replies should not block waiting for endpoint to ack
+  - kafka: return to poller when timeout is reach
+  - kafka separate unit/functionnal tests
+  - reject when skipping failed messages
+  - Remove the temporary hack in code
+  - Add Constraints support
+  - Show team and repo badges on README
+  - [zmq] Fix functional gates proxy/pub-sub
+  - [zmq] Dynamic connections failover
+  - Replace six.iteritems() with .items()
+  - Properly deserializes built-in exceptions
+  - modify the home-page info with the developer documentation
+  - [zmq] Add acks from proxy for PUB/SUB messages
+  - Remove references to Python 3.4
+  - kafka: timeout is in milliseconds
+  - [zmq] Fix py35 gate
+  - [AMQP 1.0] Setup the amqp1 test environment on ubuntu
+  - [zmq] Refactor consumers and incoming messages
+  - [zmq] Support py35 testenv
+  - Updated from global requirements
+  - eventlet is no more a hard dependency
+  - [zmq] Send immediate ack after message receiving
+  - [zmq] Don't fallback to topic if wrong server specified
+  - Replace 'the' with 'to' in docstring
+  - [simulator] Fix a message length generator usage
+  - [zmq] Redis TTL for values
+  - [document] The example which is written in the developer guide of
+  - Remove default=None when set value in Config
+  - [zmq] Fix zmq-specific f-tests from periodic hangs
+  - Using assertIsNone() instead of assertEqual(None)
+  - Avoid sending cast after server shutdown in functional test
+  - [doc] Fix three typos
+  - Set the valid choices for the rabbit login methods
+  - Removed redundant 'the'
+  - Remove ordering assumption from functional test
+  - [AMQP 1.0] Simplify the I/O event loop code
+  - [zmq] Make ThreadingPoller work with ZmqSocket
+  - tests: make rabbit failover failure more helpful
+  - [zmq] Routing table refactoring, dynamic direct connections
+  - Remove small job timeout
+  - [zmq] Remove unused methods from executors
+  - [AMQP 1.0] Resend messages that are released or modified
+  - Fix a docstring typo in impl_pika.py
+  - Use method fetch_current_thread_functor from oslo.utils
+  - [zmq] Use more stable configuration in voting job
+  - Register opts if we're going to check conf.transport_url in parse()
+  - [zmq] Fix non voting gate jobs
+  - [zmq] Refactor receivers
+  - Change assertTrue(isinstance()) by optimal assert
+  - [zmq] SUB-PUB local proxy
+  - Fix simulator bool command line args
+  - [zmq] Matchmaker redis available time
+  - [zmq] Fix TestZmqAckManager periodic failure
+  - [zmq] Restore static direct connections
+  - [zmq] Cleanup changes to zmq-specific f-tests
+  - [AMQP 1.0] Propagate authentication errors to caller
+  - [AMQP 1.0] Fix SSL client authentication
+  - [simulator] Automatic stopping of rpc-servers
+  - kafka: Don't hide unpack/unserialize exception
+  - rabbit: Don't prefetch when batch_size is set
+  - [zmq] Rename rpc_cast_timeout option
+  - gate: Remove useless files
+  - Remove nonexistent functions from documentation
+  - [zmq] Fix send_cast in AckManager
+  - Moving driver to new kafka-python version
+  - [kafka] invoke TypeError exception when 'listen()' method of KafkaDriver
+  - Fix consuming from unbound reply queue
+  - Replace mox with mock
+  - Update reno for stable/newton
+  - This patch cleans up the 'notification_listener.rst' documetion
+  - fix one typo
+  - Document the transport backend driver interface
+  - Add Documentation String for PikaDriver
+  - [AMQP 1.0] Avoid unnecessary thread switch on ack
+  - Fix whitespace formatting issue
+  - [AMQP 1.0] Update setup test environment dispatch router backend
+  - [zmq] Proxy has to skip broken multi-part message
+  - Allow dispatcher to restrict endpoint methods.
+  - kafka: disable batch for functional tests
+  - [zmq] Fix configuration for functional gate job
+  - kafka: Remove Producer singleton
+  - [zmq] Remove unnecessary subscriptions from 

commit python-oslo.messaging for openSUSE:Factory

2016-12-04 Thread h_root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2016-12-04 15:08:24

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2016-10-13 11:31:27.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2016-12-04 15:08:25.0 +0100
@@ -1,0 +2,15 @@
+Sat Dec  3 17:53:05 UTC 2016 - dmuel...@suse.com
+
+- update to 5.10.1:
+ * rabbit: on reconnect set socket timeout after channel is set
+ * Updated from global requirements
+ * rabbit: Avoid busy loop on epoll_wait with heartbeat+eventlet
+ * Fix consuming from unbound reply queue
+ * Update .gitreview for stable/newton
+
+---
+Fri Oct 14 13:56:23 UTC 2016 - tbecht...@suse.com
+
+- Switch to stable/newton in _service
+
+---

Old:

  oslo.messaging-5.10.0.tar.gz

New:

  oslo.messaging-5.10.1.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.ePLKFO/_old  2016-12-04 15:08:26.0 +0100
+++ /var/tmp/diff_new_pack.ePLKFO/_new  2016-12-04 15:08:26.0 +0100
@@ -18,7 +18,7 @@
 
 %global sname oslo.messaging
 Name:   python-oslo.messaging
-Version:5.10.0
+Version:5.10.1
 Release:0
 Summary:OpenStack oslo.messaging library
 License:Apache-2.0
@@ -45,7 +45,7 @@
 BuildRequires:  python-oslo.config >= 3.14.0
 BuildRequires:  python-oslo.context >= 2.9.0
 BuildRequires:  python-oslo.i18n >= 2.1.0
-BuildRequires:  python-oslo.log >= 3.11.0
+BuildRequires:  python-oslo.log >= 1.14.0
 BuildRequires:  python-oslo.middleware >= 3.0.0
 BuildRequires:  python-oslo.serialization >= 1.10.0
 BuildRequires:  python-oslo.service >= 1.10.0
@@ -76,7 +76,7 @@
 Requires:   python-oslo.config >= 3.14.0
 Requires:   python-oslo.context >= 2.9.0
 Requires:   python-oslo.i18n >= 2.1.0
-Requires:   python-oslo.log >= 3.11.0
+Requires:   python-oslo.log >= 1.14.0
 Requires:   python-oslo.middleware >= 3.0.0
 Requires:   python-oslo.serialization >= 1.10.0
 Requires:   python-oslo.service >= 1.10.0
@@ -96,7 +96,7 @@
 Summary:Documentation for OpenStack messaging library
 Group:  Development/Languages/Python
 BuildRequires:  python-Sphinx
-BuildRequires:  python-oslosphinx >= 4.7.0
+BuildRequires:  python-oslosphinx >= 2.5.0
 
 %description doc
 The Oslo messaging API supports RPC and notifications over a number

++ _service ++
--- /var/tmp/diff_new_pack.ePLKFO/_old  2016-12-04 15:08:26.0 +0100
+++ /var/tmp/diff_new_pack.ePLKFO/_new  2016-12-04 15:08:26.0 +0100
@@ -1,8 +1,8 @@
 
   
-https://raw.githubusercontent.com/openstack/rpm-packaging/master/openstack/oslo.messaging/oslo.messaging.spec.j2
+https://raw.githubusercontent.com/openstack/rpm-packaging/stable/newton/openstack/oslo.messaging/oslo.messaging.spec.j2
 python-oslo.messaging.spec
-https://raw.githubusercontent.com/openstack/rpm-packaging/master/global-requirements.txt
+https://raw.githubusercontent.com/openstack/rpm-packaging/stable/newton/global-requirements.txt
   
   
 enable

++ oslo.messaging-5.10.0.tar.gz -> oslo.messaging-5.10.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.messaging-5.10.0/ChangeLog 
new/oslo.messaging-5.10.1/ChangeLog
--- old/oslo.messaging-5.10.0/ChangeLog 2016-08-25 14:01:04.0 +0200
+++ new/oslo.messaging-5.10.1/ChangeLog 2016-11-22 12:50:55.0 +0100
@@ -1,6 +1,15 @@
 CHANGES
 ===
 
+5.10.1
+--
+
+* rabbit: on reconnect set socket timeout after channel is set
+* Updated from global requirements
+* rabbit: Avoid busy loop on epoll_wait with heartbeat+eventlet
+* Fix consuming from unbound reply queue
+* Update .gitreview for stable/newton
+
 5.10.0
 --
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.messaging-5.10.0/PKG-INFO 
new/oslo.messaging-5.10.1/PKG-INFO
--- old/oslo.messaging-5.10.0/PKG-INFO  2016-08-25 14:01:04.0 +0200
+++ new/oslo.messaging-5.10.1/PKG-INFO  2016-11-22 12:50:55.0 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: oslo.messaging
-Version: 5.10.0
+Version: 5.10.1
 Summary: Oslo Messaging API
 Home-page: https://wiki.openstack.org/wiki/Oslo#oslo.messaging
 Author: OpenStack
diff -urN '--exclude=CVS' 

commit python-oslo.messaging for openSUSE:Factory

2016-10-13 Thread h_root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2016-10-13 11:31:27

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2016-05-04 08:20:03.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2016-10-13 11:31:27.0 +0200
@@ -1,0 +2,177 @@
+Wed Oct  5 17:07:13 UTC 2016 - dmuel...@suse.com
+
+- sync global requirements
+
+---
+Wed Aug 31 13:11:55 UTC 2016 - tbecht...@suse.com
+
+- update to version 5.10.0
+  * [AMQP 1.0] Add configuration parameters for send message deadline
+  * [AMQP 1.0] Add acknowledge and requeue handling for incoming message
+  * [AMQP 1.0] small fixes to improve timer scalability
+  * Add warning when credential is not specified for each host
+  * Fix calculating of duration in simulator.py
+  * AMQP 1.0 Driver Architecture Overview Document
+  * Add the proper branch back to .gitreview
+  * [zmq] Implement retries for unacknowledged CASTs
+  * [zmq] Redis unavailability is not critical
+  * Move zmq driver options into its own group
+  * Add docstring for get_notification_transport
+  * Remove the max_send_retries option
+  * Fix a timer leak in the AMQP 1.0 driver
+  * Refactor link management to support link recovery
+  * Log a warning when connected to a routable message bus
+  * Fix the help info format
+  * [zmq] Discover new publisher proxy
+  * [AMQP 1.0] AMQP 1.0 Driver User Guide Document update
+  * [zmq] Use zmq.IMMEDIATE option for round-robin
+  * [zmq] Make zmq_immediate configurable
+  * Re-factor the AMQP 1.0 addressing semantics
+  * Set the default link property to allow message acks
+  * [AMQP 1.0] Add link credit configuration options
+  * Clean outdated docstring and comment
+  * [zmq] Host name and target in socket identity
+  * [AMQP 1.0] Cancel response treatment for detached link
+  * Updated from global requirements
+  * Refactor AMQP 1.0 command task to support timers
+
+---
+Tue Aug 30 16:20:46 UTC 2016 - tbecht...@suse.com
+
+- update to version 5.6.0
+  * Remove rabbitmq max_retries
+  * fix a typo in impl_rabbit.py
+  * Fix misstyping issue
+  * tests: allow to override the functionnal tests suite args
+  * Add Python 3.4 functional tests for AMQP 1.0 driver
+  * Imported Translations from Zanata
+  * [zmq] Merge publishers
+  * Remove discover from test-requirements
+  * Add deprecated relnote for max_retries rabbit configuration option
+  * [zmq] Add py34 configuration for functional tests
+  * Improve the impl_rabbit logging
+  * [zmq] Let proxy serve on a static port numbers
+  * notify: add a CLI tool to manually send notifications
+  * Add Python 3.5 classifier and venv
+  * Fix parameters of assertEqual are misplaced
+  * Properly cleanup listener and driver on simulator exit
+  * [zmq] Refactor publishers
+  * Config: no need to set default=None
+  * Introduce TTL for idle connections
+  * Fix pika functional tests
+  * [zmq] Use json/msgpack instead of pickle
+  * Replace assertEqual(None, *) with assertIsNone in tests
+  * [zmq] Additional configurations for f-tests
+  * Fix syntax error on notification listener docs
+  * tests: rabbitmq failover tests
+  * Delete fanout queues on gracefully shutdown
+  * Updated from global requirements
+
+---
+Wed Aug 10 14:37:47 UTC 2016 - tbecht...@suse.com
+
+- update to version 5.5.0
+  * [Trival] fix a typo nit
+  * [zmq] Fix backend router port for proxy.
+  * [zmq] Remove rpc_zmq_concurrency option
+  * Documents recommended executor
+  * [zmq] Remove redundant Envelope class
+  * [impl_rabbit] Remove deprecated get_expiration method
+  * [zmq] Periodic updates of endpoints connections
+  * [zmq] Fix message sending when using proxy and not using PUB/SUB
+  * Imported Translations from Zanata
+  * [AMQP 1.0] Randomize host list connection attempts
+  * Fix temporary problems with pika unit tests
+  * [zmq] Remove unused Request.close method
+  * Modify info of default_notification_exchange
+  * [zmq] Properly stop ZmqServer
+  * AMQP 1.0 - create only one Cyrus SASL configuration for the tests
+  * [zmq] Don't skip non-direct message types
+  * [zmq] Refactoring of zmq client
+  * Fix typo: 'olso' to 'oslo'
+  * Updated from global requirements
+  * Add query paramereters to TransportURL
+  * [zmq] Fix timeout in ThreadingPoller.poll
+
+---
+Mon Jul  4 

commit python-oslo.messaging for openSUSE:Factory

2016-05-04 Thread h_root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2016-05-04 08:20:01

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2015-10-30 13:42:07.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2016-05-04 08:20:03.0 +0200
@@ -1,0 +2,26 @@
+Mon Apr  4 11:29:25 UTC 2016 - tbecht...@suse.com
+
+- update to 4.6.1:
+  * Fix Break in Windows platforms
+  * Always delete exc_info tuple, even if reply fails
+  * Fail quickly if there on bad password
+  * Updated from global requirements
+  * Always set all socket timeouts
+- Adjust Requires
+
+---
+Wed Mar 16 11:15:06 UTC 2016 - tbecht...@suse.com
+
+- update to 4.5.1:
+  * Bump rabbit_transient_queues_ttl to 30 mins
+  * Fix Notification listener blocking behavior
+  * Update .gitreview for stable/mitaka
+- Adjust Requires
+
+---
+Sun Feb 28 13:17:45 UTC 2016 - dmuel...@suse.com
+
+- update to 4.5.0:
+  * too long to include, see included changes
+
+---

Old:

  oslo.messaging-2.5.0.tar.gz

New:

  oslo.messaging-4.6.1.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.jiumZT/_old  2016-05-04 08:20:04.0 +0200
+++ /var/tmp/diff_new_pack.jiumZT/_new  2016-05-04 08:20:04.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-oslo.messaging
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,8 +17,10 @@
 
 
 %define component oslo_messaging
+%define version_unconverted 4.6.1
+
 Name:   python-oslo.messaging
-Version:2.5.0
+Version:4.6.1
 Release:0
 Url:https://launchpad.net/oslo/
 Summary:OpenStack Messaging API
@@ -45,24 +47,27 @@
 BuildRequires:  python-six
 Requires:   python-PyYAML >= 3.1.0
 Requires:   python-WebOb >= 1.2.3
-Requires:   python-aioeventlet >= 0.4
 Requires:   python-amqp >= 1.4.0
 Requires:   python-cachetools >= 1.0.0
-Requires:   python-eventlet >= 0.17.4
-Requires:   python-futurist >= 0.1.2
+Requires:   python-debtcollector >= 1.2.0
+Requires:   python-eventlet >= 0.18.2
+Requires:   python-futures >= 3.0
+Requires:   python-futurist >= 0.11.0
 Requires:   python-greenlet >= 0.3.2
-Requires:   python-kombu >= 3.0.7
-Requires:   python-oslo.config >= 2.3.0
+Requires:   python-kombu >= 3.0.25
+Requires:   python-oslo.config >= 3.7.0
 Requires:   python-oslo.context >= 0.2.0
-Requires:   python-oslo.i18n >= 1.5.0
-Requires:   python-oslo.log >= 1.8.0
-Requires:   python-oslo.middleware >= 2.8.0
-Requires:   python-oslo.serialization >= 1.4.0
-Requires:   python-oslo.service >= 0.7.0
-Requires:   python-oslo.utils >= 2.0.0
+Requires:   python-oslo.i18n >= 2.1.0
+Requires:   python-oslo.log >= 1.14.0
+Requires:   python-oslo.middleware >= 3.0.0
+Requires:   python-oslo.serialization >= 1.10.0
+Requires:   python-oslo.service >= 1.0.0
+Requires:   python-oslo.utils >= 3.5.0
+Requires:   python-pika >= 0.10.0
+Requires:   python-pika-pool >= 0.1.3
+Requires:   python-retrying >= 1.2.3
 Requires:   python-six >= 1.9.0
 Requires:   python-stevedore >= 1.5.0
-Requires:   python-trollius >= 1.0
 %if 0%{?suse_version} && 0%{?suse_version} <= 1110
 %{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
 %else
@@ -107,7 +112,8 @@
 
 %install
 %{__python2} setup.py install --skip-build --root %{buildroot}
-
+# disabling git call for last modification date from git repo
+sed '/^html_last_updated_fmt.*/,/.)/ s/^/#/' -i doc/source/conf.py
 # generate html docs
 sphinx-build doc/source html
 # remove the sphinx-build leftovers
@@ -118,7 +124,7 @@
 %files
 %defattr(-,root,root,-)
 %doc LICENSE README.rst AUTHORS
-%{_bindir}/oslo-messaging-zmq-receiver
+%{_bindir}/oslo-messaging-zmq-broker
 %{python2_sitelib}/oslo_messaging
 %{python2_sitelib}/*.egg-info
 

++ oslo.messaging-2.5.0.tar.gz -> oslo.messaging-4.6.1.tar.gz ++

commit python-oslo.messaging for openSUSE:Factory

2015-10-30 Thread h_root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2015-10-30 13:42:06

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2015-09-02 07:54:02.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2015-10-30 13:42:07.0 +0100
@@ -1,0 +2,18 @@
+Sat Sep 19 06:33:11 UTC 2015 - tbecht...@suse.com
+
+- update to 2.5.0:
+  * Imported Translations from Transifex
+  * Update path to subunit2html in post_test_hook
+  * Fix typos in a document and a comment
+  * Updated from global requirements
+  * Imported Translations from Transifex
+  * Updated from global requirements
+  * Port the AMQP1 driver to new Pyngus SASL API
+  * Updated from global requirements
+  * Imported Translations from Transifex
+  * Updated from global requirements
+  * Add config options to the documentation
+  * Updated from global requirements
+- Adjust Requires according to requirements.txt
+
+---

Old:

  oslo.messaging-2.4.0.tar.gz

New:

  oslo.messaging-2.5.0.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.VGvh28/_old  2015-10-30 13:42:08.0 +0100
+++ /var/tmp/diff_new_pack.VGvh28/_new  2015-10-30 13:42:08.0 +0100
@@ -16,9 +16,9 @@
 #
 
 
-%define component oslo
+%define component oslo_messaging
 Name:   python-oslo.messaging
-Version:2.4.0
+Version:2.5.0
 Release:0
 Url:https://launchpad.net/oslo/
 Summary:OpenStack Messaging API
@@ -41,7 +41,7 @@
 BuildRequires:  python-oslo.utils
 BuildRequires:  python-oslosphinx
 BuildRequires:  python-pbr
-BuildRequires:  python-qpid
+##BuildRequires:  python-qpid
 BuildRequires:  python-six
 Requires:   python-PyYAML >= 3.1.0
 Requires:   python-WebOb >= 1.2.3
@@ -52,13 +52,13 @@
 Requires:   python-futurist >= 0.1.2
 Requires:   python-greenlet >= 0.3.2
 Requires:   python-kombu >= 3.0.7
-Requires:   python-oslo.config >= 2.1.0
+Requires:   python-oslo.config >= 2.3.0
 Requires:   python-oslo.context >= 0.2.0
 Requires:   python-oslo.i18n >= 1.5.0
 Requires:   python-oslo.log >= 1.8.0
-Requires:   python-oslo.middleware >= 2.4.0
+Requires:   python-oslo.middleware >= 2.8.0
 Requires:   python-oslo.serialization >= 1.4.0
-Requires:   python-oslo.service >= 0.6.0
+Requires:   python-oslo.service >= 0.7.0
 Requires:   python-oslo.utils >= 2.0.0
 Requires:   python-six >= 1.9.0
 Requires:   python-stevedore >= 1.5.0

++ oslo.messaging-2.4.0.tar.gz -> oslo.messaging-2.5.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.messaging-2.4.0/AUTHORS 
new/oslo.messaging-2.5.0/AUTHORS
--- old/oslo.messaging-2.4.0/AUTHORS2015-08-24 23:36:13.0 +0200
+++ new/oslo.messaging-2.5.0/AUTHORS2015-09-08 18:01:43.0 +0200
@@ -73,6 +73,7 @@
 Sergey Lukjanov 
 Sergey Vilgelm 
 Stanislav Kudriashev 
+Takashi NATSUME 
 Thomas Goirand 
 Thomas Herve 
 Victor Sergeyev 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.messaging-2.4.0/ChangeLog 
new/oslo.messaging-2.5.0/ChangeLog
--- old/oslo.messaging-2.4.0/ChangeLog  2015-08-24 23:36:13.0 +0200
+++ new/oslo.messaging-2.5.0/ChangeLog  2015-09-08 18:01:43.0 +0200
@@ -1,6 +1,22 @@
 CHANGES
 ===
 
+2.5.0
+-
+
+* Imported Translations from Transifex
+* Update path to subunit2html in post_test_hook
+* Fix typos in a document and a comment
+* Updated from global requirements
+* Imported Translations from Transifex
+* Updated from global requirements
+* Port the AMQP1 driver to new Pyngus SASL API
+* Updated from global requirements
+* Imported Translations from Transifex
+* Updated from global requirements
+* Add config options to the documentation
+* Updated from global requirements
+
 2.4.0
 -
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.messaging-2.4.0/PKG-INFO 
new/oslo.messaging-2.5.0/PKG-INFO
--- old/oslo.messaging-2.4.0/PKG-INFO   2015-08-24 23:36:14.0 +0200
+++ new/oslo.messaging-2.5.0/PKG-INFO   2015-09-08 18:01:44.0 +0200
@@ 

commit python-oslo.messaging for openSUSE:Factory

2015-09-01 Thread h_root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2015-09-02 07:54:01

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is "python-oslo.messaging"

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2015-08-27 08:55:16.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2015-09-02 07:54:02.0 +0200
@@ -1,0 +2,40 @@
+Thu Aug 27 14:40:11 UTC 2015 - tbecht...@suse.com
+
+- update to 2.4.0:
+  * Mask passwords when logging messages
+  * Updated from global requirements
+  * Use proper translating helper for logging
+  * Improve simulator.py
+  * Imported Translations from Transifex
+  * Added trace logging for debuggability
+  * Log warning instead of raising RuntimeError
+  * Updated from global requirements
+  * Replace 'M' with 'Mitaka'
+  * Fix message missing after duplicated message error
+  * Imported Translations from Transifex
+  * Fix BaseDriver.listen_for_notifications() signature
+  * Imported Translations from Transifex
+  * Updated from global requirements
+  * Imported Translations from Transifex
+  * Ensures that some assumptions are true
+  * Imported Translations from Transifex
+  * Updated from global requirements
+  * Fully use futurist code-base to abstract concurrent.futures away
+  * Imported Translations from Transifex
+  * Updated from global requirements
+  * add plugin documentation for executors and notifiers
+  * Allows to change defaults opts
+  * Allow a forward slash as a part of the user/password
+  * Update 'impl_eventlet' docstring to reflect actual impl
+  * Updated from global requirements
+  * tests: adjusts an expected time for gate
+  * Updated from global requirements
+  * Ensure callback variable capture + cleanup is done correctly
+  * Remove oslo namespace package
+  * Updated from global requirements
+  * Don't install pyngus on Python 3
+  * Fix amqp connection pool leak in ConnectionContext
+  * Executor docstring & attribute tweaks
+- Adjust Requires according to requirements.txt
+
+---

Old:

  oslo.messaging-1.17.1.tar.gz

New:

  oslo.messaging-2.4.0.tar.gz



Other differences:
--
++ python-oslo.messaging.spec ++
--- /var/tmp/diff_new_pack.O5hW1j/_old  2015-09-02 07:54:02.0 +0200
+++ /var/tmp/diff_new_pack.O5hW1j/_new  2015-09-02 07:54:02.0 +0200
@@ -18,7 +18,7 @@
 
 %define component oslo
 Name:   python-oslo.messaging
-Version:1.17.1
+Version:2.4.0
 Release:0
 Url:https://launchpad.net/oslo/
 Summary:OpenStack Messaging API
@@ -33,7 +33,6 @@
 BuildRequires:  python-devel
 BuildRequires:  python-eventlet
 BuildRequires:  python-fixtures
-BuildRequires:  python-futures
 BuildRequires:  python-kombu
 BuildRequires:  python-oslo.config
 BuildRequires:  python-oslo.context
@@ -45,20 +44,22 @@
 BuildRequires:  python-qpid
 BuildRequires:  python-six
 Requires:   python-PyYAML >= 3.1.0
+Requires:   python-WebOb >= 1.2.3
 Requires:   python-aioeventlet >= 0.4
 Requires:   python-amqp >= 1.4.0
 Requires:   python-cachetools >= 1.0.0
 Requires:   python-eventlet >= 0.17.4
-Requires:   python-futures >= 3.0
+Requires:   python-futurist >= 0.1.2
+Requires:   python-greenlet >= 0.3.2
 Requires:   python-kombu >= 3.0.7
-Requires:   python-oslo.config >= 1.11.0
+Requires:   python-oslo.config >= 2.1.0
 Requires:   python-oslo.context >= 0.2.0
 Requires:   python-oslo.i18n >= 1.5.0
-Requires:   python-oslo.log >= 1.2.0
-Requires:   python-oslo.middleware >= 1.2.0
+Requires:   python-oslo.log >= 1.8.0
+Requires:   python-oslo.middleware >= 2.4.0
 Requires:   python-oslo.serialization >= 1.4.0
-Requires:   python-oslo.service >= 0.1.0
-Requires:   python-oslo.utils >= 1.6.0
+Requires:   python-oslo.service >= 0.6.0
+Requires:   python-oslo.utils >= 2.0.0
 Requires:   python-six >= 1.9.0
 Requires:   python-stevedore >= 1.5.0
 Requires:   python-trollius >= 1.0
@@ -87,9 +88,9 @@
 Group:  System/Management
 Requires:   %{name} = %{version}
 Requires:   python-fixtures >= 1.3.1
-Requires:   python-mock >= 1.0.1
+Requires:   python-mock >= 1.2
 Requires:   python-mox3 >= 0.7.0
-Requires:   python-oslotest >= 1.5.1
+Requires:   python-oslotest >= 1.10.0
 Requires:   python-python-subunit >= 0.0.18
 Requires:   python-testrepository >= 0.0.18
 Requires:   python-testscenarios >= 

commit python-oslo.messaging for openSUSE:Factory

2015-08-27 Thread h_root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2015-08-27 08:55:14

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is python-oslo.messaging

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2014-04-20 11:36:14.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2015-08-27 08:55:16.0 +0200
@@ -2 +2 @@
-Fri Apr  4 13:15:19 UTC 2014 - dmuel...@suse.com
+Fri Jul 31 06:35:10 UTC 2015 - tbecht...@suse.com
@@ -4 +4 @@
-- add compat hacks  
+- Unify spec file #2
@@ -7 +7 @@
-Fri Apr  4 12:13:37 UTC 2014 - dmuel...@suse.com
+Wed Jul 29 10:32:25 UTC 2015 - tbecht...@suse.com
@@ -9 +9 @@
-- fix package requires 
+- Unify spec file. Use fedora compatible files macros
@@ -12 +12 @@
-Tue Apr  1 13:37:43 UTC 2014 - speili...@suse.com
+Mon Jul 20 22:11:59 UTC 2015 - dmuel...@suse.com
@@ -14 +14,602 @@
-- Update to version 1.3.0:
+- fix build/deps 
+
+---
+Sun Jul 19 06:32:58 UTC 2015 - dmuel...@suse.com
+
+- update to 1.17.1:
+  * Use the warn_eventlet_not_patched util function
+  * Drop use of 'oslo' namespace package
+  * Updated from global requirements
+  * Updated from global requirements
+  * Fix mock use for mock 1.1.0
+  * Make heartbeat the default
+  * Use oslo.log in the zmq receiver
+  * Imported Translations from Transifex
+  * Remove usage of contentmanager for executors
+  * Verify that version in 'prepare' is valid
+  * Don't reply when we known that client is gone
+  * Remove py26 artefacts from oslo.messaging code
+  * Remove 2.6 classifier
+  * Imported Translations from Transifex
+  * Add WebOb and greenlet to requirements
+  * Use ServiceBase from oslo.service as a parent class
+  * Manual update the requirements
+  * Deprecated impl_qpid
+  * Add a missed `raise` statement
+  * Remove qpid-config call
+  * Add tox target to find missing requirements
+  * Fix qpid's functional gate
+  * Imported Translations from Transifex
+
+---
+Wed Jun 24 07:10:51 UTC 2015 - tbecht...@suse.com
+
+- update to 1.15.0:
+  * Drop use of 'oslo' namespace package
+  * Use `inferred=True` by default
+  * Enable amqp's protocol unit tests everywhere
+  * Switch badges from 'pypip.in' to 'shields.io'
+  * Don't use devstack to setup our functional env
+  * Switch to warnings module instead of versionutils
+  * Updated from global requirements
+  * Get mox from mox3, not from six.moves
+  * rabbit: Add logging on blocked connection
+  * Provide better detection of failures during message send
+
+---
+Mon Jun 22 14:55:36 UTC 2015 - tbecht...@suse.com
+
+- update to 1.14.0:
+  * Reduce `magic` conf attribute usage
+  * Imported Translations from Transifex
+  * Remove leftover oslo.config reference
+  * replace rpc_response_timeout use in rabbit driver
+  * Enable `fanout_target` scenarios in test_impl_rabbit
+
+---
+Mon Jun  8 13:10:18 UTC 2015 - tbecht...@suse.com
+
+- update to 1.13.0:
+  * Ensure rpc_response_timeout is registered before using it
+  * Fix condition in _publish_and_retry_on_missing_exchange(
+  * Allow to remove second _send_reply() call
+  * Don't create a new channel in RabbitMQ Connection.reset()
+  * Imported Translations from Transifex
+  * Adding Publisher Acknowledgements/confirms
+  * Fix deprecated_group of rpc_conn_pool_size
+  * Refactor processing reply in ReplyWaiter
+  * rabbit: doc fixes
+  * consumer connections not closed properly
+  * rabbit: smart timeout on missing exchange
+  * rabbit: Fix message ttl not work
+  * rabbit: remove publisher classes
+  * rabbit: Set timeout on the underlying socket
+  * Remove stale copy of context.py
+  * Add one more functional test for MessagingTimeout
+  * Fix list_opts test to not check all deps
+  * make it possible to import amqp driver without dependencies
+  * Remove outdated release notes
+  * rabbit: smarter declaration of the notif. queue
+  * rabbit: redeclare consumers when ack/requeue fail
+  * Bump kombu and amqp requirements
+  * Updated from global requirements
+  * rabbit: fix exception path in queue redeclaration
+  * rabbit: fix consumers declaration
+  * rabbit: remove unused consumer interfaces
+  * rabbit: remove unused code
+  * rabbit: Remove unused stuffs from publisher
+  * Remove support for Python 3.3
+  * Updated from global requirements
+  * Add RequestContextSerializer
+  * Updated from global requirements
+  * rabbit: fixes a logging issue
+  * 

commit python-oslo.messaging for openSUSE:Factory

2014-04-05 Thread h_root
Hello community,

here is the log from the commit of package python-oslo.messaging for 
openSUSE:Factory checked in at 2014-04-06 07:15:46

Comparing /work/SRC/openSUSE:Factory/python-oslo.messaging (Old)
 and  /work/SRC/openSUSE:Factory/.python-oslo.messaging.new (New)


Package is python-oslo.messaging

Changes:

--- 
/work/SRC/openSUSE:Factory/python-oslo.messaging/python-oslo.messaging.changes  
2013-10-03 07:27:14.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.messaging.new/python-oslo.messaging.changes
 2014-04-06 07:15:47.0 +0200
@@ -1,0 +2,364 @@
+Tue Mar 18 12:05:22 UTC 2014 - dmuel...@suse.com
+
+- downgrade to 1.3.0a9 
+
+---
+Tue Mar 11 10:39:59 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a9.7.g5f5501f:
+  * Fixed spelling error - runnung to running
+  1.3.0a9
+  * Expose PublishErrorsHandler through oslo.messaging
+  * notify listener: document the metadata callback parameter
+  * Adds unit test cases to impl_qpid
+
+---
+Wed Mar  5 00:59:47 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a8.8.g543d5f0:
+  * Remove use of sslutils
+  1.3.0a8
+  * Do not leak _unique_id out of amqp drivers
+  * Slow down Kombu reconnect attempts
+  * Don't run python 3 tests by default
+  * Gracefully handle consumer cancel notifications
+
+---
+Tue Mar  4 00:59:15 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a7.32.g8cccf06:
+  * Add missing data into the notif. endpoint callback
+  * notification listener: add allow_requeue param
+  * Add multiple exchange per listerner in fake driver
+  * Allow to requeue the notification message
+
+---
+Sun Mar  2 00:42:56 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a7.27.g35f6d58:
+  * Updated from global requirements
+
+---
+Sat Mar  1 01:34:49 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a7.26.gfb453e4:
+  * Convert to oslo.test
+
+---
+Thu Feb 27 01:20:42 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a7.25.g7564e2c:
+  * User a more accurate max_delay for reconnects
+
+---
+Wed Feb 26 00:46:25 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a7.23.g9bf03ad:
+  * Add log_handler to oslo.messaging
+  * Add a link to the docs from the README
+  * Improve help strings
+
+---
+Tue Feb 25 00:40:23 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a7.17.g8a3744f:
+  * Pass the session to QpidMessage constructor
+  * Make the dispatcher responsible of the message ack
+
+---
+Wed Feb 19 01:19:20 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a7.15.g8a644c1:
+  * Don't reply to notification message
+
+---
+Tue Feb 18 01:27:53 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a7.14.g7473d18:
+  * Abstract the acknowledge layer of a message
+  * Implements notification listener and dispatcher
+
+---
+Sun Feb 16 00:54:12 UTC 2014 - cloud-de...@suse.de
+
+- Rebased patches:
+  + 0001-Switch-over-to-oslosphinx.patch dropped (merged upstream)
+
+---
+Sun Feb 16 00:54:11 UTC 2014 -  cloud-de...@suse.de
+
+- Update to version oslo.messaging-1.3.0a7.10.gde6d92f:
+  * Switch over to oslosphinx
+
+---
+Thu Feb 13 13:40:24 UTC 2014 - dmuel...@suse.com
+
+- added patches:
+  * 0001-Switch-over-to-oslosphinx.patch
+
+---
+Tue Feb 11 16:10:37 UTC 2014 - speili...@suse.com
+
+- Update to version oslo.messaging-1.3.0a7.9.g70dbe6a:
+  * Update ExpectedException handling
+  * Ignore any egg and egg-info directories
+  * Qpid: advance thru the list of brokers on reconnect
+  * RabbitMQ: advance thru the list of brokers on reconnect
+  1.3.0a7
+  * Make the dispatcher responsible to listen()
+  * Allow fake driver to consume multiple topics
+  * Allow different login methods to be used with kombu connections
+- Replace git_tarballs source service with download_files