commit python-zope.testrunner for openSUSE:Factory

2020-08-01 Thread root
Hello community,

here is the log from the commit of package python-zope.testrunner for 
openSUSE:Factory checked in at 2020-08-01 12:28:43

Comparing /work/SRC/openSUSE:Factory/python-zope.testrunner (Old)
 and  /work/SRC/openSUSE:Factory/.python-zope.testrunner.new.3592 (New)


Package is "python-zope.testrunner"

Sat Aug  1 12:28:43 2020 rev:13 rq:822035 version:5.2

Changes:

--- 
/work/SRC/openSUSE:Factory/python-zope.testrunner/python-zope.testrunner.changes
2019-11-22 10:20:13.817348467 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-zope.testrunner.new.3592/python-zope.testrunner.changes
  2020-08-01 12:28:59.598334087 +0200
@@ -1,0 +2,9 @@
+Tue Jul 21 08:53:11 UTC 2020 - Marketa Calabkova 
+
+- Update to 5.2
+  * Add support for Python 3.8.
+  * When a layer is run in a subprocess, read its stderr in a thread to avoid
+a deadlock if its stderr output (containing failing and erroring test IDs)
+overflows the capacity of a pipe
+
+---

Old:

  zope.testrunner-5.1.tar.gz

New:

  zope.testrunner-5.2.tar.gz



Other differences:
--
++ python-zope.testrunner.spec ++
--- /var/tmp/diff_new_pack.ymqfrW/_old  2020-08-01 12:29:02.870337150 +0200
+++ /var/tmp/diff_new_pack.ymqfrW/_new  2020-08-01 12:29:02.874337154 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-zope.testrunner
 #
-# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2020 SUSE LLC
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,7 +26,7 @@
 %bcond_with test
 %endif
 Name:   python-zope.testrunner
-Version:5.1
+Version:5.2
 Release:0
 Summary:Zope testrunner script
 License:ZPL-2.1

++ zope.testrunner-5.1.tar.gz -> zope.testrunner-5.2.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zope.testrunner-5.1/.travis.yml 
new/zope.testrunner-5.2/.travis.yml
--- old/zope.testrunner-5.1/.travis.yml 2019-10-19 11:47:21.0 +0200
+++ new/zope.testrunner-5.2/.travis.yml 2020-06-29 10:33:31.0 +0200
@@ -3,22 +3,10 @@
   - 2.7
   - 3.5
   - 3.6
+  - 3.7
+  - 3.8
   - pypy
   - pypy3
-matrix:
-include:
-- python: "3.7"
-  dist: xenial
-  env: SUBUNIT=true
-- python: "3.7"
-  dist: xenial
-  env: SUBUNIT=false
-- python: "3.8-dev"
-  dist: xenial
-  env: SUBUNIT=true
-- python: "3.8-dev"
-  dist: xenial
-  env: SUBUNIT=false
 env:
   - SUBUNIT=true
   - SUBUNIT=false
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zope.testrunner-5.1/CHANGES.rst 
new/zope.testrunner-5.2/CHANGES.rst
--- old/zope.testrunner-5.1/CHANGES.rst 2019-10-19 11:47:21.0 +0200
+++ new/zope.testrunner-5.2/CHANGES.rst 2020-06-29 10:33:31.0 +0200
@@ -2,6 +2,17 @@
  zope.testrunner Changelog
 ===
 
+5.2 (2020-06-29)
+
+
+- Add support for Python 3.8.
+
+- When a layer is run in a subprocess, read its stderr in a thread to avoid
+  a deadlock if its stderr output (containing failing and erroring test IDs)
+  overflows the capacity of a pipe (`#105
+  `_).
+
+
 5.1 (2019-10-19)
 
 
@@ -25,6 +36,7 @@
 
 - Drop support for Python 3.4.
 
+
 4.9.2 (2018-11-24)
 ==
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zope.testrunner-5.1/PKG-INFO 
new/zope.testrunner-5.2/PKG-INFO
--- old/zope.testrunner-5.1/PKG-INFO2019-10-19 11:47:21.0 +0200
+++ new/zope.testrunner-5.2/PKG-INFO2020-06-29 10:33:32.112758000 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 2.1
 Name: zope.testrunner
-Version: 5.1
+Version: 5.2
 Summary: Zope testrunner script.
 Home-page: https://github.com/zopefoundation/zope.testrunner
 Author: Zope Foundation and Contributors
@@ -186,6 +186,17 @@
  zope.testrunner Changelog
 ===
 
+5.2 (2020-06-29)
+
+
+- Add support for Python 3.8.
+
+- When a layer is run in a subprocess, read its stderr in a thread to 
avoid
+  a deadlock if its stderr output (containing failing and erroring 
test IDs)
+  overflows the capacity of a pipe (`#105
+  `_).
+
+
 5.1 (2019-10-19)
 
 
@@ -209,6 +220,7 @@
 

commit python-zope.testrunner for openSUSE:Factory

2019-11-22 Thread root
Hello community,

here is the log from the commit of package python-zope.testrunner for 
openSUSE:Factory checked in at 2019-11-22 10:20:12

Comparing /work/SRC/openSUSE:Factory/python-zope.testrunner (Old)
 and  /work/SRC/openSUSE:Factory/.python-zope.testrunner.new.26869 (New)


Package is "python-zope.testrunner"

Fri Nov 22 10:20:12 2019 rev:12 rq:745976 version:5.1

Changes:

--- 
/work/SRC/openSUSE:Factory/python-zope.testrunner/python-zope.testrunner.changes
2019-04-10 23:10:55.303955212 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-zope.testrunner.new.26869/python-zope.testrunner.changes
 2019-11-22 10:20:13.817348467 +0100
@@ -1,0 +2,9 @@
+Wed Oct 30 12:13:54 UTC 2019 - Tomáš Chvátal 
+
+- Update to 5.1:
+  * Recover more gracefully when layer setUp or tearDown fails, producing 
useful subunit output.
+  * Prevent a spurious warning from the --require-unique option if the 
--module option was not used.
+  * Add optional buffering of standard output and standard error during tests, 
requested via the --buffer option or enabled by default for subunit.
+  * Fix incorrect failure counts in per-layer summary output, broken in 4.0.1.
+
+---

Old:

  zope.testrunner-5.0.tar.gz

New:

  zope.testrunner-5.1.tar.gz



Other differences:
--
++ python-zope.testrunner.spec ++
--- /var/tmp/diff_new_pack.8wPrkq/_old  2019-11-22 10:20:14.269348350 +0100
+++ /var/tmp/diff_new_pack.8wPrkq/_new  2019-11-22 10:20:14.273348349 +0100
@@ -26,29 +26,27 @@
 %bcond_with test
 %endif
 Name:   python-zope.testrunner
-Version:5.0
+Version:5.1
 Release:0
 Summary:Zope testrunner script
 License:ZPL-2.1
-Group:  Development/Languages/Python
-URL:https://pypi.python.org/pypi/zope.testrunner
+URL:https://github.com/zopefoundation/zope.testrunner
 Source: 
https://files.pythonhosted.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.tar.gz
 BuildRequires:  %{python_module setuptools}
-# runtime requirements:
 BuildRequires:  %{python_module six}
 BuildRequires:  %{python_module zope.exceptions}
 BuildRequires:  %{python_module zope.interface}
-# Test requirements:
-%if %{with test}
-BuildRequires:  %{python_module zope.testing}
-BuildRequires:  %{python_module zope.testrunner = %{version}}
-%endif
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
 Requires:   python-six
 Requires:   python-zope.exceptions
 Requires:   python-zope.interface
 BuildArch:  noarch
+%if %{with test}
+BuildRequires:  %{python_module zope.testing}
+BuildRequires:  %{python_module zope.testrunner = %{version}}
+BuildRequires:  %{pythons}
+%endif
 %python_subpackages
 
 %description
@@ -82,7 +80,7 @@
 %python_uninstall_alternative zope-testrunner
 
 %files %{python_files}
-%license LICENSE.rst
+%license LICENSE.md
 %doc README.rst
 %python_alternative %{_bindir}/zope-testrunner
 %{python_sitelib}/*

++ zope.testrunner-5.0.tar.gz -> zope.testrunner-5.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zope.testrunner-5.0/.gitignore 
new/zope.testrunner-5.1/.gitignore
--- old/zope.testrunner-5.0/.gitignore  2019-03-19 08:17:18.0 +0100
+++ new/zope.testrunner-5.1/.gitignore  1970-01-01 01:00:00.0 +0100
@@ -1,15 +0,0 @@
-*.pyc
-__pycache__
-
-.installed.cfg
-bin/
-eggs/
-develop-eggs/
-*.egg-info/
-tags
-.tox
-parts/
-.coverage
-.coverage.*
-htmlcov/
-docs/_build/
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zope.testrunner-5.0/CHANGES.rst 
new/zope.testrunner-5.1/CHANGES.rst
--- old/zope.testrunner-5.0/CHANGES.rst 2019-03-19 08:17:18.0 +0100
+++ new/zope.testrunner-5.1/CHANGES.rst 2019-10-19 11:47:21.0 +0200
@@ -2,6 +2,21 @@
  zope.testrunner Changelog
 ===
 
+5.1 (2019-10-19)
+
+
+- Recover more gracefully when layer setUp or tearDown fails, producing
+  useful subunit output.
+
+- Prevent a spurious warning from the ``--require-unique`` option if the
+  ``--module`` option was not used.
+
+- Add optional buffering of standard output and standard error during tests,
+  requested via the ``--buffer`` option or enabled by default for subunit.
+
+- Fix incorrect failure counts in per-layer summary output, broken in 4.0.1.
+
+
 5.0 (2019-03-19)
 
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/zope.testrunner-5.0/LICENSE.md 
new/zope.testrunner-5.1/LICENSE.md
--- old/zope.testrunner-5.0/LICENSE.md  1970-01-01 01:00:00.0 +0100
+++ new/zope.testrunner-5.1/LICENSE.md  

commit python-zope.testrunner for openSUSE:Factory

2019-04-10 Thread root
Hello community,

here is the log from the commit of package python-zope.testrunner for 
openSUSE:Factory checked in at 2019-04-10 23:10:54

Comparing /work/SRC/openSUSE:Factory/python-zope.testrunner (Old)
 and  /work/SRC/openSUSE:Factory/.python-zope.testrunner.new.27019 (New)


Package is "python-zope.testrunner"

Wed Apr 10 23:10:54 2019 rev:11 rq:692309 version:5.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-zope.testrunner/python-zope.testrunner.changes
2018-12-13 19:46:48.116828646 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-zope.testrunner.new.27019/python-zope.testrunner.changes
 2019-04-10 23:10:55.303955212 +0200
@@ -1,0 +2,25 @@
+Mon Apr  8 13:02:40 UTC 2019 - Marketa Calabkova 
+
+- update to version 5.0
+  * Fix test failures and deprecation warnings occurring when 
+using Python 3.8a1.  
+  * Drop support for Python 3.4.
+  4.9*
+  * Fix AssertionError in _DummyThread.isAlive on Python 3.
+  * Drop support for Python 3.3.
+  * Add support for Python 3.7.
+  * Remove untested support for the --pychecker option.
+  * Update the command line interface to use argparse instead of 
+optparse.
+  * Use ipdb instead of pdb for post-mortem debugging if available.
+  * Add a –require-unique option to check for duplicate test IDs.
+  * Reintroduce optional support for subunit.
+  * Handle string in exception values when formatting chained 
+exceptions.
+  4.8*
+  * Enable DeprecationWarning earlier, when discovering test 
+modules.
+  * Automatically enable DeprecationWarning when running tests.
+- Launch tests using multibuild.
+
+---

Old:

  zope.testrunner-4.7.0.zip

New:

  _multibuild
  zope.testrunner-5.0.tar.gz



Other differences:
--
++ python-zope.testrunner.spec ++
--- /var/tmp/diff_new_pack.rDTp11/_old  2019-04-10 23:10:56.123956143 +0200
+++ /var/tmp/diff_new_pack.rDTp11/_new  2019-04-10 23:10:56.127956147 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-zope.testrunner
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,24 +17,34 @@
 
 
 %{?!python_module:%define python_module() python-%{**} python3-%{**}}
+%global flavor @BUILD_FLAVOR@%{nil}
+%if "%{flavor}" == "test"
+%define psuffix -test
+%bcond_without test
+%else
+%define psuffix %{nil}
+%bcond_with test
+%endif
 Name:   python-zope.testrunner
-Version:4.7.0
+Version:5.0
 Release:0
 Summary:Zope testrunner script
 License:ZPL-2.1
 Group:  Development/Languages/Python
 URL:https://pypi.python.org/pypi/zope.testrunner
-Source: 
https://files.pythonhosted.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.zip
+Source: 
https://files.pythonhosted.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.tar.gz
 BuildRequires:  %{python_module setuptools}
 # runtime requirements:
 BuildRequires:  %{python_module six}
 BuildRequires:  %{python_module zope.exceptions}
 BuildRequires:  %{python_module zope.interface}
 # Test requirements:
+%if %{with test}
 BuildRequires:  %{python_module zope.testing}
+BuildRequires:  %{python_module zope.testrunner = %{version}}
+%endif
 BuildRequires:  fdupes
 BuildRequires:  python-rpm-macros
-BuildRequires:  unzip
 Requires:   python-six
 Requires:   python-zope.exceptions
 Requires:   python-zope.interface
@@ -52,15 +62,19 @@
 %python_build
 
 %install
+%if !%{with test}
 %python_install
-%python_expand %fdupes -s %{buildroot}%{$python_sitelib}
+%python_expand %fdupes %{buildroot}%{$python_sitelib}
 
 %python_clone -a %{buildroot}%{_bindir}/zope-testrunner
+%endif
 
-# Can't seem to be able to run the tests with an uninstalled zope.testrunner
-#%%check
-#%%python_exec setup.py test
+%if %{with test}
+%check
+%python_exec setup.py test
+%endif
 
+%if !%{with test}
 %post
 %python_install_alternative zope-testrunner
 
@@ -72,5 +86,6 @@
 %doc README.rst
 %python_alternative %{_bindir}/zope-testrunner
 %{python_sitelib}/*
+%endif
 
 %changelog

++ _multibuild ++

  test




commit python-zope.testrunner for openSUSE:Factory

2018-12-13 Thread root
Hello community,

here is the log from the commit of package python-zope.testrunner for 
openSUSE:Factory checked in at 2018-12-13 19:46:42

Comparing /work/SRC/openSUSE:Factory/python-zope.testrunner (Old)
 and  /work/SRC/openSUSE:Factory/.python-zope.testrunner.new.28833 (New)


Package is "python-zope.testrunner"

Thu Dec 13 19:46:42 2018 rev:10 rq:654094 version:4.7.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-zope.testrunner/python-zope.testrunner.changes
2017-07-08 12:33:43.368180346 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-zope.testrunner.new.28833/python-zope.testrunner.changes
 2018-12-13 19:46:48.116828646 +0100
@@ -1,0 +2,5 @@
+Tue Dec  4 12:56:33 UTC 2018 - Matej Cepl 
+
+- Remove superfluous devel dependency for noarch package
+
+---



Other differences:
--
++ python-zope.testrunner.spec ++
--- /var/tmp/diff_new_pack.vWZ6Yj/_old  2018-12-13 19:46:48.720827862 +0100
+++ /var/tmp/diff_new_pack.vWZ6Yj/_new  2018-12-13 19:46:48.720827862 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-zope.testrunner
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -12,7 +12,7 @@
 # license that conforms to the Open Source Definition (Version 1.9)
 # published by the Open Source Initiative.
 
-# Please submit bugfixes or comments via http://bugs.opensuse.org/
+# Please submit bugfixes or comments via https://bugs.opensuse.org/
 #
 
 
@@ -23,9 +23,8 @@
 Summary:Zope testrunner script
 License:ZPL-2.1
 Group:  Development/Languages/Python
-Url:https://pypi.python.org/pypi/zope.testrunner
+URL:https://pypi.python.org/pypi/zope.testrunner
 Source: 
https://files.pythonhosted.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.zip
-BuildRequires:  %{python_module devel}
 BuildRequires:  %{python_module setuptools}
 # runtime requirements:
 BuildRequires:  %{python_module six}
@@ -39,7 +38,6 @@
 Requires:   python-six
 Requires:   python-zope.exceptions
 Requires:   python-zope.interface
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch
 %python_subpackages
 
@@ -70,8 +68,8 @@
 %python_uninstall_alternative zope-testrunner
 
 %files %{python_files}
-%defattr(-,root,root,-)
-%doc LICENSE.rst README.rst
+%license LICENSE.rst
+%doc README.rst
 %python_alternative %{_bindir}/zope-testrunner
 %{python_sitelib}/*
 





commit python-zope.testrunner for openSUSE:Factory

2017-07-08 Thread root
Hello community,

here is the log from the commit of package python-zope.testrunner for 
openSUSE:Factory checked in at 2017-07-08 12:33:42

Comparing /work/SRC/openSUSE:Factory/python-zope.testrunner (Old)
 and  /work/SRC/openSUSE:Factory/.python-zope.testrunner.new (New)


Package is "python-zope.testrunner"

Sat Jul  8 12:33:42 2017 rev:9 rq:507389 version:4.7.0

Changes:

--- 
/work/SRC/openSUSE:Factory/python-zope.testrunner/python-zope.testrunner.changes
2016-08-17 12:05:25.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-zope.testrunner.new/python-zope.testrunner.changes
   2017-07-08 12:33:43.368180346 +0200
@@ -1,0 +2,43 @@
+Thu Jun 29 19:43:55 UTC 2017 - aloi...@gmx.com
+
+- Added missing requires for update-alternatives
+
+---
+Fri Jun 23 09:19:42 UTC 2017 - aloi...@gmx.com
+
+- Update to 4.7.0
+  * Drop all support for ``subunit``.
+  4.6.0:
+  * Make the ``subunit`` support purely optional: applications
+which have been getting the dependencies via
+``zope.testrunner`` should either add
+``zope.testrunner[subunit]`` to their ``install_requires`` or
+else depend directly on ``python-subunit``.
+  * New option ``--ignore-new-thread=`` to suppress
+"New thread(s)" warnings.
+  * Support Python 3.6.
+  4.5.1:
+  * Fixed: Using the ``-j`` option to run tests in multiple
+processes caused tests that used the ``multiprocessing``
+package to hang (because the testrunner replaced ``sys.stdin``
+with an unclosable object).
+  * Drop conditional dependency on ``unittest2`` (redundant after
+dropping support for Python 2.6).
+  4.5.0:
+  * Stop tests for all layers when test fails/errors when started
+with -x/--stop-on-error
+(`#37 `_).
+  * Drop support for Python 2.6 and 3.2.
+  4.4.10:
+  * Add support for Python 3.5
+(`#31 `_).
+  * Insert extra paths (from ``--path``) to the front of sys.argv
+(`#32 `_).
+  4.4.9:
+  * When using ``-j``, parallelize all the tests, including the
+first test layer
+(`#28 `_).
+
+- Converted to single-spec
+
+---

Old:

  zope.testrunner-4.4.8.zip

New:

  zope.testrunner-4.7.0.zip



Other differences:
--
++ python-zope.testrunner.spec ++
--- /var/tmp/diff_new_pack.Hq5LCf/_old  2017-07-08 12:33:46.383754997 +0200
+++ /var/tmp/diff_new_pack.Hq5LCf/_new  2017-07-08 12:33:46.383754997 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-zope.testrunner
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,74 +16,63 @@
 #
 
 
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
 Name:   python-zope.testrunner
-Version:4.4.8
+Version:4.7.0
 Release:0
 Summary:Zope testrunner script
 License:ZPL-2.1
 Group:  Development/Languages/Python
-Url:http://pypi.python.org/pypi/zope.testrunner
-Source: 
https://pypi.python.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.zip
+Url:https://pypi.python.org/pypi/zope.testrunner
+Source: 
https://files.pythonhosted.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.zip
+BuildRequires:  %{python_module devel}
+BuildRequires:  %{python_module setuptools}
+# runtime requirements:
+BuildRequires:  %{python_module six}
+BuildRequires:  %{python_module zope.exceptions}
+BuildRequires:  %{python_module zope.interface}
+# Test requirements:
+BuildRequires:  %{python_module zope.testing}
 BuildRequires:  fdupes
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
+BuildRequires:  python-rpm-macros
 BuildRequires:  unzip
-# Test requirements:
-#BuildRequires:  python-python-subunit
-#BuildRequires:  python-unittest2
-#BuildRequires:  python-zope.testing
-# runtime requirements:
-BuildRequires:  python-six
-BuildRequires:  python-zope.exceptions
-BuildRequires:  python-zope.interface
 Requires:   python-six
 Requires:   python-zope.exceptions
 Requires:   python-zope.interface
-Requires(post): update-alternatives
-Requires(preun): update-alternatives
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?suse_version} && 0%{?suse_version} <= 1110

commit python-zope.testrunner for openSUSE:Factory

2016-08-17 Thread h_root
Hello community,

here is the log from the commit of package python-zope.testrunner for 
openSUSE:Factory checked in at 2016-08-17 12:05:24

Comparing /work/SRC/openSUSE:Factory/python-zope.testrunner (Old)
 and  /work/SRC/openSUSE:Factory/.python-zope.testrunner.new (New)


Package is "python-zope.testrunner"

Changes:

--- 
/work/SRC/openSUSE:Factory/python-zope.testrunner/python-zope.testrunner.changes
2014-11-18 22:46:06.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-zope.testrunner.new/python-zope.testrunner.changes
   2016-08-17 12:05:25.0 +0200
@@ -1,0 +2,35 @@
+Mon Aug 15 14:51:56 UTC 2016 - toddrme2...@gmail.com
+
+- Fix update-alternatives implementation.
+
+---
+Fri May 15 13:47:39 UTC 2015 - benoit.mo...@gmx.fr
+
+- update to version 4.4.8:
+  * Support skipped tests in subunit output
+  * More efficient test filtering
+- additional changes from version 4.4.7:
+  * Work around a bug in PyPy3’s curses module (#24).
+- additional changes from version 4.4.6:
+  * Restore support for instance-based test layers that regressed
+in 4.4.5 (#20).
+- additional changes from version 4.4.5:
+  * Sort related layers close to each other to reduce the number of
+unnecessary teardowns (fixes #14).
+  * Run the unit test layer first (fixes LP #497871).
+- additional changes from version 4.4.4:
+  * When looking for the right location of test code, start with
+longest location paths first. This fixes problems with nested
+code locations.
+- additional changes from version 4.4.3:
+  * Added support for Python 3.4.
+- additional changes from version 4.4.2:
+  * Drop support for Python 3.1.
+  * Fix post-mortem debugging when a non-printable exception
+happens (#8).
+- add runtime requirements python-six, python-zope.exceptions,
+  python-zope.interface
+- update the test requirements (still commented out, tests fail)
+- fix update-alternatives
+
+---

Old:

  zope.testrunner-4.4.1.zip

New:

  zope.testrunner-4.4.8.zip



Other differences:
--
++ python-zope.testrunner.spec ++
--- /var/tmp/diff_new_pack.8ewLUX/_old  2016-08-17 12:05:26.0 +0200
+++ /var/tmp/diff_new_pack.8ewLUX/_new  2016-08-17 12:05:26.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-zope.testrunner
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   python-zope.testrunner
-Version:4.4.1
+Version:4.4.8
 Release:0
 Summary:Zope testrunner script
 License:ZPL-2.1
@@ -30,13 +30,17 @@
 BuildRequires:  unzip
 # Test requirements:
 #BuildRequires:  python-python-subunit
-#BuildRequires:  python-six
-#BuildRequires:  python-testtools
 #BuildRequires:  python-unittest2
-#BuildRequires:  python-zope.interface
 #BuildRequires:  python-zope.testing
+# runtime requirements:
+BuildRequires:  python-six
+BuildRequires:  python-zope.exceptions
+BuildRequires:  python-zope.interface
+Requires:   python-six
+Requires:   python-zope.exceptions
+Requires:   python-zope.interface
 Requires(post): update-alternatives
-Requires(postun): update-alternatives
+Requires(preun): update-alternatives
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if 0%{?suse_version} && 0%{?suse_version} <= 1110
 %{!?python_sitelib: %global python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
@@ -56,32 +60,30 @@
 
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
-ln -s  %{_bindir}/zope-testrunner-%{py_ver} 
%{buildroot}%{_bindir}/zope-testrunner
+# for update-alternatives
+mkdir -p %{buildroot}%{_sysconfdir}/alternatives
+ln -s %{_sysconfdir}/alternatives/zope-testrunner 
%{buildroot}%{_bindir}/zope-testrunner
 # Remove duplicate files
 %fdupes -s %{buildroot}%{python_sitelib}
 
 #NOTE(saschpe): Check failing tests
-#%check
+#%%check
 #python setup.py test
 
-%pre
-# Since /usr/bin/pybabel became ghosted to be used with update-alternatives, 
we have to get rid
-# of the old binary resulting from the non-update-alternativies-ified package:
-[ -h %{_bindir}/zope-testrunner ] || rm -f %{_bindir}/zope-testrunner
-
 %post
-update-alternatives --install %{_bindir}/zope-testrunner zope-testrunner 
%{_bindir}/zope-testrunner-%{py_ver} 20
+%_sbindir/update-alternatives --install %{_bindir}/zope-testrunner 
zope-testrunner 

commit python-zope.testrunner for openSUSE:Factory

2013-11-14 Thread h_root
Hello community,

here is the log from the commit of package python-zope.testrunner for 
openSUSE:Factory checked in at 2013-11-15 08:38:21

Comparing /work/SRC/openSUSE:Factory/python-zope.testrunner (Old)
 and  /work/SRC/openSUSE:Factory/.python-zope.testrunner.new (New)


Package is python-zope.testrunner

Changes:

--- 
/work/SRC/openSUSE:Factory/python-zope.testrunner/python-zope.testrunner.changes
2013-11-14 08:43:55.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-zope.testrunner.new/python-zope.testrunner.changes
   2013-11-15 08:38:22.0 +0100
@@ -1,0 +2,5 @@
+Thu Nov 14 15:45:40 UTC 2013 - p.drou...@gmail.com
+
+- Add update-alternative support
+
+---



Other differences:
--
++ python-zope.testrunner.spec ++
--- /var/tmp/diff_new_pack.vgjUmj/_old  2013-11-15 08:38:22.0 +0100
+++ /var/tmp/diff_new_pack.vgjUmj/_new  2013-11-15 08:38:22.0 +0100
@@ -35,6 +35,8 @@
 #BuildRequires:  python-unittest2
 #BuildRequires:  python-zope.interface
 #BuildRequires:  python-zope.testing
+Requires(post): update-alternatives
+Requires(postun): update-alternatives
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if 0%{?suse_version}  0%{?suse_version} = 1110
 %{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
@@ -47,12 +49,14 @@
 
 %prep
 %setup -q -n zope.testrunner-%{version}
+sed -i s/zope-testrunner =/zope-testrunner-%{py_ver} =/ setup.py
 
 %build
 python setup.py build
 
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+ln -s  %{_bindir}/zope-testrunner-%{py_ver} 
%{buildroot}%{_bindir}/zope-testrunner
 # Remove duplicate files
 %fdupes -s %{buildroot}%{python_sitelib}
 
@@ -60,10 +64,25 @@
 #%check
 #python setup.py test
 
+%pre
+# Since /usr/bin/pybabel became ghosted to be used with update-alternatives, 
we have to get rid
+# of the old binary resulting from the non-update-alternativies-ified package:
+[[ ! -L %{_bindir}/zope-testrunner ]]  rm -f %{_bindir}/zope-testrunner
+exit 0
+
+%post
+update-alternatives --install %{_bindir}/zope-testrunner zope-testrunner 
%{_bindir}/zope-testrunner-%{py_ver} 20
+
+%preun
+if [ $1 -eq 0 ] ; then
+update-alternatives --remove zope-testrunner 
%{_bindir}/zope-testrunner-%{py_ver}
+fi
+
 %files
 %defattr(-,root,root,-)
 %doc LICENSE.rst README.rst
-%{_bindir}/zope-testrunner
+%ghost %{_bindir}/zope-testrunner
+%{_bindir}/zope-testrunner-%{py_ver}
 %{python_sitelib}/*
 
 %changelog


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-zope.testrunner for openSUSE:Factory

2013-11-13 Thread h_root
Hello community,

here is the log from the commit of package python-zope.testrunner for 
openSUSE:Factory checked in at 2013-11-14 08:43:53

Comparing /work/SRC/openSUSE:Factory/python-zope.testrunner (Old)
 and  /work/SRC/openSUSE:Factory/.python-zope.testrunner.new (New)


Package is python-zope.testrunner

Changes:

--- 
/work/SRC/openSUSE:Factory/python-zope.testrunner/python-zope.testrunner.changes
2013-10-25 11:37:10.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-zope.testrunner.new/python-zope.testrunner.changes
   2013-11-14 08:43:55.0 +0100
@@ -1,0 +2,23 @@
+Wed Nov 13 13:08:41 UTC 2013 - p.drou...@gmail.com
+
+- Update to version 4.4.1
+  + Updated boostrap.py to version 2.2.
+  + Fix nondeterministic test failures on Python 3.3
+  + Tear down layers after post_mortem debugging is finished.
+  + Fix tests that write to source directory, it might be read-only.
+- Changes from 4.4.0 
+  + Fix tests selection when the negative ! pattern is used several times
+(LP #1160965)
+  +  Moved tests into a 'tests' subpackage.
+  + Made python -m zope.testrunner work again.
+  + Support 'skip' feature of unittest2 (which became the new unittest in 
Python 2.7).
+  + Better diagnostics when communication with subprocess fails
+(https://github.com/zopefoundation/zope.testrunner/issues/5).
+  + Do not break subprocess execution when the test suite changes the working
+directory (https://github.com/zopefoundation/zope.testrunner/issues/6).
+  + Count test module import errors as errors (LP #1026576).
+- Add python-unittest2 and python-zope.interface commented BuildRequires;
+  these are new requirements for test but there are still broken
+- Add fdupes BuildRequires and use fdupes to remove duplicate files
+
+---

Old:

  zope.testrunner-4.3.3.zip

New:

  zope.testrunner-4.4.1.zip



Other differences:
--
++ python-zope.testrunner.spec ++
--- /var/tmp/diff_new_pack.ovu3wb/_old  2013-11-14 08:43:55.0 +0100
+++ /var/tmp/diff_new_pack.ovu3wb/_new  2013-11-14 08:43:55.0 +0100
@@ -17,13 +17,14 @@
 
 
 Name:   python-zope.testrunner
-Version:4.3.3
+Version:4.4.1
 Release:0
 Summary:Zope testrunner script
 License:ZPL-2.1
 Group:  Development/Languages/Python
 Url:http://pypi.python.org/pypi/zope.testrunner
-Source: 
http://pypi.python.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.zip
+Source: 
https://pypi.python.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.zip
+BuildRequires:  fdupes
 BuildRequires:  python-devel
 BuildRequires:  python-setuptools
 BuildRequires:  unzip
@@ -31,6 +32,8 @@
 #BuildRequires:  python-python-subunit
 #BuildRequires:  python-six
 #BuildRequires:  python-testtools
+#BuildRequires:  python-unittest2
+#BuildRequires:  python-zope.interface
 #BuildRequires:  python-zope.testing
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if 0%{?suse_version}  0%{?suse_version} = 1110
@@ -50,9 +53,11 @@
 
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+# Remove duplicate files
+%fdupes -s %{buildroot}%{python_sitelib}
 
 #NOTE(saschpe): Check failing tests
-#%%check
+#%check
 #python setup.py test
 
 %files

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-zope.testrunner for openSUSE:Factory

2013-10-25 Thread h_root
Hello community,

here is the log from the commit of package python-zope.testrunner for 
openSUSE:Factory checked in at 2013-10-25 11:37:09

Comparing /work/SRC/openSUSE:Factory/python-zope.testrunner (Old)
 and  /work/SRC/openSUSE:Factory/.python-zope.testrunner.new (New)


Package is python-zope.testrunner

Changes:

--- 
/work/SRC/openSUSE:Factory/python-zope.testrunner/python-zope.testrunner.changes
2013-03-18 07:14:22.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-zope.testrunner.new/python-zope.testrunner.changes
   2013-10-25 11:37:10.0 +0200
@@ -1,0 +2,5 @@
+Thu Oct 24 11:18:03 UTC 2013 - speili...@suse.com
+
+- Require python-setuptools instead of distribute (upstreams merged)
+
+---



Other differences:
--
++ python-zope.testrunner.spec ++
--- /var/tmp/diff_new_pack.i9n7n7/_old  2013-10-25 11:37:18.0 +0200
+++ /var/tmp/diff_new_pack.i9n7n7/_new  2013-10-25 11:37:18.0 +0200
@@ -13,21 +13,24 @@
 # published by the Open Source Initiative.
 
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
 
 
 Name:   python-zope.testrunner
 Version:4.3.3
 Release:0
-License:ZPL-2.1
 Summary:Zope testrunner script
-Url:http://pypi.python.org/pypi/zope.testrunner
+License:ZPL-2.1
 Group:  Development/Languages/Python
+Url:http://pypi.python.org/pypi/zope.testrunner
 Source: 
http://pypi.python.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.zip
 BuildRequires:  python-devel
-BuildRequires:  python-distribute
+BuildRequires:  python-setuptools
 BuildRequires:  unzip
 # Test requirements:
 #BuildRequires:  python-python-subunit
+#BuildRequires:  python-six
+#BuildRequires:  python-testtools
 #BuildRequires:  python-zope.testing
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 %if 0%{?suse_version}  0%{?suse_version} = 1110
@@ -48,7 +51,8 @@
 %install
 python setup.py install --prefix=%{_prefix} --root=%{buildroot}
 
-#%check
+#NOTE(saschpe): Check failing tests
+#%%check
 #python setup.py test
 
 %files


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org



commit python-zope.testrunner for openSUSE:Factory

2013-03-18 Thread h_root
Hello community,

here is the log from the commit of package python-zope.testrunner for 
openSUSE:Factory checked in at 2013-03-18 07:14:21

Comparing /work/SRC/openSUSE:Factory/python-zope.testrunner (Old)
 and  /work/SRC/openSUSE:Factory/.python-zope.testrunner.new (New)


Package is python-zope.testrunner, Maintainer is 

Changes:

New Changes file:

--- /dev/null   2013-02-26 18:15:11.936010755 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-zope.testrunner.new/python-zope.testrunner.changes
   2013-03-18 07:14:22.0 +0100
@@ -0,0 +1,5 @@
+---
+Fri Mar 15 14:03:51 UTC 2013 - speili...@suse.com
+
+- Initial version
+

New:

  python-zope.testrunner.changes
  python-zope.testrunner.spec
  zope.testrunner-4.3.3.zip



Other differences:
--
++ python-zope.testrunner.spec ++
#
# spec file for package python-zope.testrunner
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An Open Source License is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/


Name:   python-zope.testrunner
Version:4.3.3
Release:0
License:ZPL-2.1
Summary:Zope testrunner script
Url:http://pypi.python.org/pypi/zope.testrunner
Group:  Development/Languages/Python
Source: 
http://pypi.python.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.zip
BuildRequires:  python-devel
BuildRequires:  python-distribute
BuildRequires:  unzip
# Test requirements:
#BuildRequires:  python-python-subunit
#BuildRequires:  python-zope.testing
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version}  0%{?suse_version} = 1110
%{!?python_sitelib: %global python_sitelib %(python -c from 
distutils.sysconfig import get_python_lib; print get_python_lib())}
%else
BuildArch:  noarch
%endif

%description
This package provides a flexible test runner with layer support.

%prep
%setup -q -n zope.testrunner-%{version}

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}

#%check
#python setup.py test

%files
%defattr(-,root,root,-)
%doc LICENSE.rst README.rst
%{_bindir}/zope-testrunner
%{python_sitelib}/*

%changelog
-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org