Re: [OpenWrt-Devel] [PATCH] fix gnuplot compile error

2010-11-01 Thread Michael Büsch
On Mon, 2010-11-01 at 11:13 +0800, Xiangfu Liu wrote: 
 this patch add intl, iconv patch to TARGET FLAGS,
 add intl and iconv to DEPENDS.
 
 attach is the patch.

Thanks, applied.

-- 
Greetings Michael.

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] lm-sensors package upgrade

2010-11-01 Thread Luka Perkov
On Sun, Oct 31, 2010 at 11:48:39PM +0100, Michael Büsch wrote:
 PKG_BUILD_PARALLEL does nothing unless you use the default
 build macro, or PKG_JOBS.
 
 So you either want to $(call Build/Compile/Default) and set the
 appropriate MAKE_FLAGS, or add PKG_JOBS to your Build/Compile macro.
 
 I think you should use $(INSTALL_DIR) instead of mkdir -p.

Thank you for your comments. Resending fixed patch.

Signed-off-by: Luka Perkov  openwrt --to-- lukaperkov.net 
---

Index: lm-sensors/Makefile
===
--- lm-sensors/Makefile (revision 23647)
+++ lm-sensors/Makefile (working copy)
@@ -9,27 +9,27 @@
 
 PKG_NAME:=lm-sensors
 PKG_VERSION:=3.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=lm_sensors-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://dl.lm-sensors.org/lm-sensors/releases/
 PKG_MD5SUM:=829d88fb09d67723fbf42853eb84d1fd
-
+ 
 PKG_BUILD_DIR:=$(BUILD_DIR)/lm_sensors-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lm-sensors/Default
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=lm-sensors
   DEPENDS:=+sysfsutils
   URL:=http://www.lm-sensors.org/
 endef
 
 define Package/lm-sensors
   $(call Package/lm-sensors/Default)
-  TITLE+=(programs)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=lm-sensors
   DEPENDS+=+libsensors
 endef
 
@@ -37,7 +37,7 @@
   $(call Package/lm-sensors/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE+=libraries
+  TITLE:=libsensors
 endef
 
 define Package/lm-sensors/description
@@ -49,11 +49,12 @@
 endef
 
 define Package/lm-sensors/conffiles
-/etc/sensors.conf
+   /etc/sensors.conf
 endef
 
 define Build/Compile
-   $(MAKE) -C $(PKG_BUILD_DIR) \
+   $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+   $(TARGET_CONFIGURE_OPTS) \
KERNELVERSION=$(LINUX_VERSION) \
LINUX=$(LINUX_DIR) \
CC=$(TARGET_CC) \
@@ -63,6 +64,17 @@
user
 endef
 
+define Build/InstallDev
+   $(INSTALL_DIR) $(1)/usr/include/sensors
+   $(CP) \
+   $(PKG_BUILD_DIR)/lib/sensors.h \
+   $(1)/usr/include/sensors
+   $(INSTALL_DIR) $(1)/usr/lib
+   $(CP) \
+   $(PKG_BUILD_DIR)/lib/libsensors.{a,so*} \
+   $(1)/usr/lib/
+endef
+
 define Package/lm-sensors/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/prog/sensors/sensors $(1)/usr/sbin/
@@ -76,6 +88,5 @@
$(CP) $(PKG_BUILD_DIR)/lib/libsensors.so* $(1)/usr/lib/
 endef
 
-
 $(eval $(call BuildPackage,lm-sensors))
 $(eval $(call BuildPackage,libsensors))
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] [kirkwood-dockstar] minor fixes

2010-11-01 Thread Marcus Osdoba

Hi again,

The patches for the dockstar won't break history and they do not 
introduce new features, so they are quite harmless. Is there any chance 
to commit them to the current trunk?


So please find attached a simple patchset which solves some of the 
issues, I introduced in a forum thread: 
https://forum.openwrt.org/viewtopic.php?id=27043


SeagateDockstar - kirkwood derivative
- squashfs and overlay support (u-boot config)
- pad jffs2-128k to 128k (as the name implies)
- create proper squashfs image

I'm new here. Please let me know, how to speed up the process to commit 
these patches in mainline (and where they break your guidelines).


Is svn diff ok, or do you prefere git format-patch?

btw: mv_cesa should rely on crypto_aes like kmod-crypto-hw-padlock:
https://dev.openwrt.org/ticket/7643

Regards,
Ossy

this patch adds squashfs support to the feature list of the dockstar profile

Signed-off-by: marcus.osd...@googlemail.com
---
Index: target/linux/kirkwood/Makefile
===
--- target/linux/kirkwood/Makefile  (Revision 23697)
+++ target/linux/kirkwood/Makefile  (Arbeitskopie)
@@ -9,7 +9,7 @@
 ARCH:=arm
 BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
-FEATURES:=targz usb jffs2
+FEATURES:=targz usb jffs2 squashfs
 MAINTAINER:=Imre Kaloz ka...@openwrt.org
 
 LINUX_VERSION:=2.6.35.7

pad the kernel to 128k,
pad jffs2-128k really to 128k as the name implies,
create a plain padded squashfs (without uImage in front)
this does not break history, since the image WITH uImage 
in front is still created in parallel


Signed-off-by: marcus.osd...@googlemail.com
---
Index: target/linux/kirkwood/image/Makefile
===
--- target/linux/kirkwood/image/Makefile(Revision 23697)
+++ target/linux/kirkwood/image/Makefile(Arbeitskopie)
@@ -15,7 +15,7 @@
 
 define Image/BuildKernel
 # do mach-id fixup here, if needed
-   cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+   dd if=$(KDIR)/uImage of=$(BIN_DIR)/$(IMG_PREFIX)-uImage bs=128k 
conv=sync
 endef
 
 define Image/Build
@@ -27,15 +27,17 @@
 
 define Image/Build/jffs2-128k
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img 
\
-   bs=2048 conv=sync
+   bs=128k conv=sync
 endef
 
 define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+   dd if=$(KDIR)/root.$(1) bs=128k conv=sync \
+   of=$(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img
( \
dd if=$(KDIR)/uImage bs=4096k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
-   )  $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img
+   )  $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-uImage-$(1).img
 endef
 
 $(eval $(call BuildImage))

squashfs added as alternative to rootfstype, must be in order squashfs,jffs2
tested on dockstar with both jffs2 and squashfs - openwrt was started in both 
cases
without updating the bootparameters,

rename data to rootfs_data since squashfs-version needs to have some overlay;
unfortunatly, the jffs2 version creates an overlay, too...
maybe this is not desired, but the situtation is not worse than before, since
one has to update the bootparmeters for using squashfs and overlay on two 
places, now only one


Signed-off-by: marcus.osd...@googlemail.com
---
Index: package/uboot-kirkwood/files/include/configs/dockstar.h
===
--- package/uboot-kirkwood/files/include/configs/dockstar.h (Revision 23697)
+++ package/uboot-kirkwood/files/include/configs/dockstar.h (Arbeitskopie)
@@ -133,15 +133,18 @@
setenv bootargs ${x_bootargs} ${x_bootargs_root}; \
${x_bootcmd_usb}; bootm 0x640;
 
-#define CONFIG_MTDPARTSorion_nand:1M(u-boot),\
+#define CONFIG_MTDPARTS\
+   orion_nand:1M(u-boot), \
1...@1m(second_stage_u-boot), \
-   3...@2m(kernel),3...@5m(rootfs),2...@37m(data) rw\0
+   3...@2m(kernel), \
+   3...@5m(rootfs), \
+   2...@37m(rootfs_data)\0
 
 #define CONFIG_EXTRA_ENV_SETTINGS  x_bootargs=console\
=ttyS0,115200 mtdparts=CONFIG_MTDPARTS\
x_bootcmd_kernel=nand read 0x640 0x20 0x30\0 \
x_bootcmd_usb=usb start\0 \
-   x_bootargs_root=root=/dev/mtdblock3 rw rootfstype=jffs2\0
+   x_bootargs_root=root=/dev/mtdblock3 ro rootfstype=squashfs,jffs2\0
 
 /*
  * Size of malloc() pool

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [patch] n2n update to release 3875

2010-11-01 Thread Hanno Schupp
Anything wrong with this? I thought this was pretty trivial change.
Could this be released, if there is no issue, please?

On 29 October 2010 23:03, Hanno Schupp hanno.sch...@gmail.com wrote:
 Updating n2n to this release allows the inclusion of the mac address to the
 edge command, which in turns allows the linking of a dhcp server to the
 supernode, and thus IP address assignment.
 (For background see http://wiki.freifunk.net/N2n) Tested in bakfire, trunk
 brcm-2.4., ar71xx and atheros.
 Signed-off-by: hanno.sch...@gmail.com
 Index: Makefile
 ===
 --- Makefile (revision 23702)
 +++ Makefile (working copy)
 @@ -9,7 +9,7 @@

  PKG_BRANCH:=trunk
  PKG_SOURCE_URL:=https://svn.ntop.org/svn/ntop/trunk/n2n
 -PKG_REV:=3667
 +PKG_REV:=3875

  PKG_NAME:=n2n
  PKG_VERSION:=$(PKG_REV)

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [patch] n2n update to release 3875

2010-11-01 Thread Outback Dingo
has this not been committed ? ouch! ill look into it

On Mon, Nov 1, 2010 at 6:25 PM, Hanno Schupp hanno.sch...@gmail.com wrote:

 Anything wrong with this? I thought this was pretty trivial change.
 Could this be released, if there is no issue, please?

 On 29 October 2010 23:03, Hanno Schupp hanno.sch...@gmail.com wrote:
  Updating n2n to this release allows the inclusion of the mac address to
 the
  edge command, which in turns allows the linking of a dhcp server to the
  supernode, and thus IP address assignment.
  (For background see http://wiki.freifunk.net/N2n) Tested in bakfire,
 trunk
  brcm-2.4., ar71xx and atheros.
  Signed-off-by: hanno.sch...@gmail.com
  Index: Makefile
  ===
  --- Makefile (revision 23702)
  +++ Makefile (working copy)
  @@ -9,7 +9,7 @@
 
   PKG_BRANCH:=trunk
   PKG_SOURCE_URL:=https://svn.ntop.org/svn/ntop/trunk/n2n
  -PKG_REV:=3667
  +PKG_REV:=3875
 
   PKG_NAME:=n2n
   PKG_VERSION:=$(PKG_REV)
 
 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/mailman/listinfo/openwrt-devel

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel