Re: [OpenWrt-Devel] 6rd problem when setting up via DHCP due to typo

2013-06-28 Thread Steven Barth

Thanks for the report. It should be fixed now.

Steven
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCHv2][packages] protobuf-c: Also build protoc-c utility for host environment

2013-06-28 Thread Helmut Schaa

Signed-off-by: Helmut Schaa helmut.sc...@googlemail.com
---

Changes in v2:
Depend upon protobuf/host

 libs/protobuf-c/Makefile |5 +
 1 file changed, 5 insertions(+)

diff --git a/libs/protobuf-c/Makefile b/libs/protobuf-c/Makefile
index fd1e4f6..7a3c5d6 100644
--- a/libs/protobuf-c/Makefile
+++ b/libs/protobuf-c/Makefile
@@ -15,9 +15,12 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://protobuf-c.googlecode.com/files
 PKG_MD5SUM:=73ff0c8df50d2eee75269ad8f8c07dc8
 
+PKG_BUILD_DEPENDS:=protobuf/host
+
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/libprotobuf-c
   TITLE:=Protocol Buffers library
@@ -55,3 +58,5 @@ define Package/libprotobuf-c/install
 endef
 
 $(eval $(call BuildPackage,libprotobuf-c))
+$(eval $(call HostBuild))
+
-- 
1.7.10.4

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Fwd: [PATCH 1/2] [tinc] rename autocreated configdir

2013-06-28 Thread Christoph Kottke

hi,

i think tinc should have it's own config dir

christoph



From a7d2ac314b75f09af2baa66e5168b40152a5250a Mon Sep 17 00:00:00 2001
From: Christoph Kottke christoph.kot...@gmx.de
Date: Wed, 26 Jun 2013 12:54:45 +0200
Subject: [PATCH 1/2] [tinc] rename autocreated configdir


Signed-off-by: Christoph Kottke christoph.kot...@gmx.de
---
 net/tinc/Makefile |2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/tinc/Makefile b/net/tinc/Makefile
index b383365..576d034 100644
--- a/net/tinc/Makefile
+++ b/net/tinc/Makefile
@@ -47,7 +47,7 @@ define Package/tinc/install
$(INSTALL_BIN) files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
-   $(INSTALL_DIR) $(1)/etc/openvpn
+   $(INSTALL_DIR) $(1)/etc/tinc
$(INSTALL_DIR) $(1)/lib/upgrade/keep.d
$(INSTALL_DATA) files/tinc.upgrade $(1)/lib/upgrade/keep.d/tinc
 endef
-- 
1.7.10.4


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Fwd: [PATCH 2/2] [aprx] update to version 2.07 (svn539)

2013-06-28 Thread Christoph Kottke

hi,

aprx version update to 2.07

christoph



From 520eaaac8cad66abf3ab681c44710d90380f9118 Mon Sep 17 00:00:00 2001
From: Christoph Kottke christoph.kot...@gmx.de
Date: Fri, 28 Jun 2013 11:42:54 +0200
Subject: [PATCH 2/2] [aprx] update to version 2.07 (svn539)


Signed-off-by: Christoph Kottke christoph.kot...@gmx.de
---
 net/aprx/Makefile  |9 +
 net/aprx/patches/100-Makefile_in.patch |9 -
 2 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/net/aprx/Makefile b/net/aprx/Makefile
index 16e98ba..64c572f 100644
--- a/net/aprx/Makefile
+++ b/net/aprx/Makefile
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aprx
-PKG_REV:=421
-PKG_VERSION:=2.00_r$(PKG_REV)
-PKG_RELEASE:=3
+PKG_REV:=539
+PKG_VERSION:=2.07_r$(PKG_REV)
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://repo.ham.fi/svn/aprx/trunk/
@@ -23,7 +23,8 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aprx
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=APRS RX only I-gate
+  DEPENDS:=+libpthread
+  TITLE:=APRS iGate + digipeater software
   URL:=http://ham.zmailer.org/oh2mqk/aprx/
 endef
 
diff --git a/net/aprx/patches/100-Makefile_in.patch 
b/net/aprx/patches/100-Makefile_in.patch
index cb06f79..818f7c9 100644
--- a/net/aprx/patches/100-Makefile_in.patch
+++ b/net/aprx/patches/100-Makefile_in.patch
@@ -1,7 +1,6 @@
-diff -ruN aprx-2.00_r421.orig/Makefile.in aprx-2.00_r421/Makefile.in
 aprx-2.00_r421.orig/Makefile.in2010-06-19 15:13:47.0 +
-+++ aprx-2.00_r421/Makefile.in 2010-08-22 00:14:35.0 +
-@@ -27,8 +27,9 @@
+--- a/Makefile.in
 b/Makefile.in
+@@ -27,8 +27,9 @@ CC=  @CC@
  CFLAGS=   @CFLAGS@
  
  # Linker and flags
@@ -12,7 +11,7 @@ diff -ruN aprx-2.00_r421.orig/Makefile.in 
aprx-2.00_r421/Makefile.in
  
  INSTALL=  $(srcdir)/install-sh
  INSTALL_PROGRAM=$(INSTALL)  -m 755
-@@ -89,10 +90,10 @@
+@@ -91,10 +92,10 @@ profile:
  
  
  $(PROGAPRX):  $(OBJSAPRX) VERSION Makefile
-- 
1.7.10.4


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] network: update state file even when bringing down interfaces

2013-06-28 Thread Enrico Mioso
This patch makes the network status file in /tmp/ consistent, so that when an 
interface goes down, any script parsing the file can see it! This can be a 
pretty good alternative to json when you need a VERY small script.


Index: package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate
===
--- package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate 
(revision 37055)
+++ package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate 
(working copy)
@@ -6,3 +6,7 @@
uci_toggle_state network $INTERFACE ifname $DEVICE
}
 }
+
+[ ifdown = $ACTION ]  {
+   uci_toggle_state network $INTERFACE up 0
+}



___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH RESEND] network: update state file even when bringing down interfaces

2013-06-28 Thread Enrico Mioso
This patch makes the network status file in /tmp/ consistent, so that when an
interface goes down, any script parsing the file can see it! This can be a
pretty good alternative to json when you need a VERY small script.

Signed-off-by: Enrico Mioso mrkiko...@gmail.com



Index: package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate
=
--- package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate
(revision 37055)
+++ package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate
(working copy)
@@ -6,3 +6,7 @@
uci_toggle_state network $INTERFACE ifname $DEVICE
}
 }
+
+[ ifdown = $ACTION ]  {
+   uci_toggle_state network $INTERFACE up 0
+}




___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] unknown network field 'beacon_int and wpa_supplicant

2013-06-28 Thread cmsv
Info:
http://wiki.openwrt.org/doc/uci/wireless#wpa.enterprise.access.point


configuration:

/etc/config# cat wireless

config wifi-device 'radio0'
option type 'mac80211'
option phy 'phy0'
option hwmode '11ng'
option noscan '1'
option disabled '0'
option diversity '0'
option rxantenna '2'
option txantenna '2'
option txpower '20'
option beacon_int '1000'
option distance '2000'
list ht_capab 'RX-HT40-SGI'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option channel '1'
option country 'PT'
option htmode 'HT20'
option beacon_int '1000'

config wifi-iface
option device 'radio0'
option ifname 'wlan0'
option network 'lan'
option mode 'ap'
option ssid 'test.net'
option hidden '0'
option encryption 'none'


config wifi-iface
option device 'radio0'
option ifname 'adhoc0'
option network 'mesh'
option mode 'adhoc'
option bssid '02:16:e8:6a:0b:1e'
option ssid 'mesh.test'
option hidden '0'
option macfilter 'allow'
option encryption 'psk2'
option key '1234567890'

Problem:

wifi down
wifi up
command failed: Device or resource busy (-16)
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr 5f:e9:98:5c:3e:36 and ssid test.net

Successfully initialized wpa_supplicant
Line 12: unknown network field 'beacon_interval'.
Line 33: failed to parse network block.

Failed to read or parse configuration '/var/run/wpa_supplicant-adhoc0.conf'.
enable_mac80211(radio0): Failed to set up wpa_supplicant for interface
adhoc0


Details:

# cat /var/run/wpa_supplicant-adhoc0.conf
ctrl_interface=/var/run/wpa_supplicant-adhoc0
ap_scan=2
network={
mode=1
scan_ssid=0
ssid=mesh.test
bssid=02:16:c8:6e:0f:1e
key_mgmt=WPA-PSK
proto=RSN
frequency=2472
fixed_freq=1
beacon_interval=1000

htmode=HT20

psk=1234567890


Linux version 3.3.8 (cmsv@net) (gcc version 4.6.3 20120201 (prerelease)
(Linaro GCC 4.6-2012.02) ) #1 Thu Jun 27 22:23:26 EDT 2013
DISTRIB_ID=OpenWrt
DISTRIB_RELEASE=Attitude Adjustment
DISTRIB_REVISION=r37034
DISTRIB_CODENAME=attitude_adjustment
DISTRIB_TARGET=ar71xx/generic
DISTRIB_DESCRIPTION=OpenWrt Attitude Adjustment 12.09



Conclusion:
It does seem that wpa_supplicant is not compatible with option
beacon_int . However if i remove this option from the configuration or
specify it as option beacon_interval; then wpa_supplicant works for the
specified interface.

Is this a bug, incompatibility or something was not updated to work with
with wpa_supplicant ?

Also; will this option work if specified as beacon_interval in
/et/config/wireless ? The wiki describes it as
beacon_int






-- 





Site: http://wirelesspt.net
Mesh: http://tinyurl.com/wirelesspt
Admin: http://wirelesspt.net/wiki/Cmsv
Twitter: http://twitter.com/wirelesspt
Suporte técnico via sms: 91 19 11 798
Donativos/Paypal: http://tinyurl.com/doar-verba
Chave publica PGP/SSH: http://wirelesspt.net/arquivos/pk
Email assinado digitalmente pelo emissor assegurando autenticidade



0x782BF73E.asc
Description: application/pgp-keys


signature.asc
Description: OpenPGP digital signature
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] RE(5); Ivette67

2013-06-28 Thread Králik Barnabás


gift voucher No:5787276 
http://viavremya.com/aurenl.php?t=698832es=kralikba87
















Sent: 29.06.2013 3:08:12
*
From: Králik Barnabás 2013 ugn)ameritech- Terms and Privacy
  ___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] network: update state file even when bringing down interfaces

2013-06-28 Thread Daniel Dickinson
What happens if two or more hotplug events trigger essentially 
simultaneously (can happen)?  i.e. how do you prevent multiple processes 
writing out of order (i.e. order is not guaranteed)?


Regards,

Daniel

On 13-06-28 09:55 AM, Enrico Mioso wrote:
This patch makes the network status file in /tmp/ consistent, so that 
when an interface goes down, any script parsing the file can see it! 
This can be a pretty good alternative to json when you need a VERY 
small script.


Index: 
package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate

===
--- 
package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate 
(revision 37055)
+++ 
package/network/config/netifd/files/etc/hotplug.d/iface/00-netstate 
(working copy)

@@ -6,3 +6,7 @@
 uci_toggle_state network $INTERFACE ifname $DEVICE
 }
 }
+
+[ ifdown = $ACTION ]  {
+uci_toggle_state network $INTERFACE up 0
+}



___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


--
Daniel Dickinson PowerCloud Systems, Palo Alto, CA Senior Firmware 
Engineer (In Canada: Senior Firmware Analyst)

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel