[OpenWrt-Devel] [PATCH v3] lantiq: make zlib compression on ubifs the default for BTHOMEHUBV2B

2014-06-20 Thread Ben Mulvihill
On Fri, 2014-06-20 at 07:51 +0200, Ben Mulvihill wrote: On Thu, 2014-06-19 at 23:09 +0200, Ben Mulvihill wrote: Nand flash on the Home Hub 2B is 32M, so it makes sense at least for this board to use some sort of compression on ubifs. Of course anyone building trunk for themselves can

Re: [OpenWrt-Devel] WRT54GS v1.0 GPIO definitions in r41004

2014-06-20 Thread Rafał Miłecki
On 5 June 2014 19:20, Catalin Patulea c...@vv.carleton.ca wrote: Here is dmesg also: http://pastebin.com/ZHXdd3PK Note: [ 12.58] gpio-keys gpio-keys.0: unable to claim gpio 6, err=-16 [ 12.66] gpio-keys: probe of gpio-keys.0 failed with error -16 [ 12.90] leds-gpio: probe

[OpenWrt-Devel] mac filter on attitude_adjustment

2014-06-20 Thread bjzhougong
Dear Sir I use attitude_adjustment in WR703n, and find macfilter doesn't work. I get the latest AA from svn, and find there is any action in hostapd.sh but in my AA version, there is not any function about mac filter. Would you please tell me there is any patch on AA for mac filter, I want to

Re: [OpenWrt-Devel] WRT54GS v1.0 GPIO definitions in r41004

2014-06-20 Thread Rafał Miłecki
On 20 June 2014 08:28, Rafał Miłecki zaj...@gmail.com wrote: On 5 June 2014 19:20, Catalin Patulea c...@vv.carleton.ca wrote: Here is dmesg also: http://pastebin.com/ZHXdd3PK Note: [ 12.58] gpio-keys gpio-keys.0: unable to claim gpio 6, err=-16 [ 12.66] gpio-keys: probe of

Re: [OpenWrt-Devel] [PATCH v3] lantiq: make zlib compression on ubifs the default for BTHOMEHUBV2B

2014-06-20 Thread John Crispin
On 20/06/2014 08:26, Ben Mulvihill wrote: On Fri, 2014-06-20 at 07:51 +0200, Ben Mulvihill wrote: On Thu, 2014-06-19 at 23:09 +0200, Ben Mulvihill wrote: Nand flash on the Home Hub 2B is 32M, so it makes sense at least for this board to use some sort of compression on ubifs. Of course

[OpenWrt-Devel] [PATCH 5/5] Fix bug of GC in fd and timeout objects for lua binding.

2014-06-20 Thread xfguo
fd and timeout lua object has a __gc method in its metatable. After the object is freed and the another new object use the same reference in __uloop_cb and __uloop_fds, the new object will be freed by the old __gc of the old object when garbag collecting. Signed-off-by: Xiongfei(Alex) Guo

[OpenWrt-Devel] [PATCH 3/5] Support delete a fd event.

2014-06-20 Thread xfguo
When you call the fd_add, it will return an object with `delete` method. So you can delete that event if you want. Signed-off-by: Xiongfei(Alex) Guo xf...@credosemi.com --- examples/uloop-example.lua | 17 ++--- lua/uloop.c| 30 ++ 2 files

[OpenWrt-Devel] [PATCH 2/5] Added fd_add method for uloop lua binding.

2014-06-20 Thread xfguo
Use uloop.fd_add like this: local socket = require socket udp = socket.udp() uloop.fd_add( udp, -- socket function( -- callback function ufd,-- socket object when register the fd events -- uloop events. eg. uloop.ULOOP_READ . )

[OpenWrt-Devel] [PATCH 1/5] Fix stack overflow bug of uloop lua binding.

2014-06-20 Thread xfguo
The static variable `state` in `lua/uloop.c` should be clean after every callback. Signed-off-by: Xiongfei(Alex) Guo xf...@credosemi.com --- lua/uloop.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/lua/uloop.c b/lua/uloop.c index 51f53c2..5922e04 100644 --- a/lua/uloop.c +++

Re: [OpenWrt-Devel] [PATCH 1/5] Fix stack overflow bug of uloop lua binding.

2014-06-20 Thread John Crispin
On 20/06/2014 13:31, xf...@credosemi.com wrote: The static variable `state` in `lua/uloop.c` should be clean after every callback. Signed-off-by: Xiongfei(Alex) Guo xf...@credosemi.com --- Hi, just had a quick browse over the patches. looks good, the only nipick i have is this +static

[OpenWrt-Devel] [PATCH] kernel: mtd-partial_eraseblock_erase

2014-06-20 Thread Maciej Skrzypek
mtd: allow partial block erase This fixes error erasing partial mtd partition which does not start on eraseblock boundary and allows using fconfig to configure redboot on devices such as the Gateworks Cambria. Maciej Skrzypek Flytronic Index:

[OpenWrt-Devel] [PATCH] SysupgradeNAND: include rootfs-type in image name

2014-06-20 Thread Daniel Golle
so we can have images for different rootfs types, e.g. *-ubifs-sysupgrage.tar as well as *-squashfs-sysupgrade.tar. Also added quotes around pathnames. Signed-off-by: Daniel Golle dan...@makrotopia.org --- include/image.mk | 12 ++-- target/linux/ar71xx/image/Makefile

[OpenWrt-Devel] [PATCH v2 1/2] SysupgradeNAND: include rootfs-type in image name

2014-06-20 Thread Daniel Golle
also add quotes to paths Signed-off-by: Daniel Golle dan...@makrotopia.org --- v2: also change comment explaining parameters include/image.mk | 16 target/linux/ar71xx/image/Makefile | 2 +- 2 files changed, 9 insertions(+), 9 deletions(-) diff --git

[OpenWrt-Devel] [PATCH 2/2] procd: fix nand.sh kernel_length typo

2014-06-20 Thread Daniel Golle
sysupgrade otherwise skips kernel part on devices which got kernel in ubi due to kern_length being undefined, kernel_length is being used instead. Signed-off-by: Daniel Golle dan...@makrotopia.org --- package/system/procd/files/nand.sh | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)

Re: [OpenWrt-Devel] [PATCH 1/5] Fix stack overflow bug of uloop lua binding.

2014-06-20 Thread Xiongfei(Alex) GUO
Well, I agree with you about the api name. And, since we have done this, the fd:cancel should be renamed to fd:delete too. The code is: static const luaL_Reg ufd_m[] = { { cancel, ul_ufd_delete }, { NULL, NULL } }; On Fri, Jun 20, 2014 at 7:40 PM, John Crispin j...@phrozen.org

Re: [OpenWrt-Devel] WRT54GS v1.0 GPIO definitions in r41004

2014-06-20 Thread Catalin Patulea
On Fri, Jun 20, 2014 at 6:20 AM, Rafał Miłecki zaj...@gmail.com wrote: Your nvram has following entries: gpio6=adm_rc gpio5=adm_eedi gpio3=adm_eesk gpio2=adm_eecs Hauke: it seems nvram may be wrong there. According to the Catalin, reset button uses GPIO 6. On the other hand it seems

[OpenWrt-Devel] AA on brcm47xx: Unhandled kernel unaligned access

2014-06-20 Thread Nikolai Zhubr
Hello people, I have asus wl-500W router (http://wiki.openwrt.org/toh/asus/wl500w). It is also very similar to wl-500gp. Some few months ago I updated to 12.09. I can't recall now if it was backfire or kamikaze before, but I noticed 2 things immediately: 1. Maximum practically achievable

Re: [OpenWrt-Devel] AA on brcm47xx: Unhandled kernel unaligned access

2014-06-20 Thread Rafał Miłecki
On 20 June 2014 22:12, Nikolai Zhubr n-a-zh...@yandex.ru wrote: 2. At some point I get (on a serial link): [ 368.948000] sched: RT throttling activated [ 382.688000] Unhandled kernel unaligned access[#1]: trim [ 382.932000] Kernel panic - not syncing: Fatal exception in interrupt

Re: [OpenWrt-Devel] WRT54GS v1.0 GPIO definitions in r41004

2014-06-20 Thread Catalin Patulea
On Fri, Jun 20, 2014 at 3:20 PM, Catalin Patulea c...@vv.carleton.ca wrote: Hauke: it seems nvram may be wrong there. According to the Catalin, reset button uses GPIO 6. On the other hand it seems adm6996.c never really uses eerc. I modified adm6996.c to allow GPIO export and started

[OpenWrt-Devel] [PATCH] ar71xx: add support for the EnGenius ESR900

2014-06-20 Thread Forest Crossman
Signed-off-by: Forest Crossman cyro...@gmail.com --- package/base-files/files/lib/functions/system.sh | 1 + target/linux/ar71xx/base-files/etc/diag.sh | 3 + .../ar71xx/base-files/etc/uci-defaults/01_leds | 5 + .../ar71xx/base-files/etc/uci-defaults/02_network | 11 +