[OpenWrt-Devel] [PATCH 1/5] Fix stack overflow bug of uloop lua binding.

2014-06-20 Thread xfguo
The static variable `state` in `lua/uloop.c` should be clean after every callback. Signed-off-by: Xiongfei(Alex) Guo xf...@credosemi.com --- lua/uloop.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/lua/uloop.c b/lua/uloop.c index 51f53c2..5922e04 100644 --- a/lua/uloop.c +++

Re: [OpenWrt-Devel] [PATCH 1/5] Fix stack overflow bug of uloop lua binding.

2014-06-20 Thread John Crispin
On 20/06/2014 13:31, xf...@credosemi.com wrote: The static variable `state` in `lua/uloop.c` should be clean after every callback. Signed-off-by: Xiongfei(Alex) Guo xf...@credosemi.com --- Hi, just had a quick browse over the patches. looks good, the only nipick i have is this +static

Re: [OpenWrt-Devel] [PATCH 1/5] Fix stack overflow bug of uloop lua binding.

2014-06-20 Thread Xiongfei(Alex) GUO
Well, I agree with you about the api name. And, since we have done this, the fd:cancel should be renamed to fd:delete too. The code is: static const luaL_Reg ufd_m[] = { { cancel, ul_ufd_delete }, { NULL, NULL } }; On Fri, Jun 20, 2014 at 7:40 PM, John Crispin j...@phrozen.org