-------- Weitergeleitete Nachricht --------
Betreff: Re: [OpenWrt-Devel] 5GHz wifi is broken
Datum: Mon, 18 Feb 2019 21:13:58 +0100
Von: e9hack <e9h...@gmail.com>
An: Ben Greear <gree...@candelatech.com>

Hi,

this is my wireless configuration. I build hostapd with the internal radius 
server enabled and set the expected
configuration for the internal radius server for hostapd if config value for 
auth_server isn't given or empty.

config wifi-device 'radio0'
        option type 'mac80211'
        option channel 'auto'
        option channels '36-140'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option country 'DE'
        option disassoc_low_ack '0'
        option log_level '0'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
#       option encryption 'wpa2+ccmp'
        option encryption 'wpa3-mixed'
        option ssid 'Wxxxxxxb-radius'
        option ca_cert '/etc/certs/ca-d171225.crt'
        option server_cert '/etc/certs/crt-d170807.crt'
        option private_key '/etc/certs/key-d170807.key'
        option dh_file '/etc/certs/hostapd.dh4096.pem'
        option eap_user_file '/etc/config/haprad.eap_user'
        option network 'lan'
        option eapol_version '2'
        option ieee80211w '1'
        option wpa_group_rekey '3600'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Wxxxxxxb'
#       option encryption 'psk2+ccmp'
        option encryption 'sae-mixed'
        option wpa_psk_file '/etc/config/hostapd.wpa_psk'
        option disassoc_low_ack '0'
        option ieee80211w '1'
        option wpa_group_rekey '3600'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'Txxxxxx'
#       option encryption 'psk2+ccmp'
        option encryption 'sae-mixed'
        option key 'xxxxxxxxxxxxxxxxxxxxxxxx'
        option network 'tor'
        option macaddr '00:xx:xx:xx:xx:xx'
        option disassoc_low_ack '0'
        option ieee80211w '1'
        option wpa_group_rekey '3600'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/ahb:apb/18100000.wmac'
        option htmode 'HT40-'
        option country 'DE'
        option noscan '1'
        option log_level '3'
        option ht_coex '1'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option network 'lan'
#       option encryption 'wpa2+ccmp'
        option encryption 'wpa3-mixed'
        option ssid 'Wxxxxxxa-radius'
        option ca_cert '/etc/certs/ca-d171225.crt'
        option crl_file '/etc/certs/crl-d181127.pem'
        option check_crl '2'
        option server_cert '/etc/certs/crt-d170807.crt'
        option private_key '/etc/certs/key-d170807.key'
        option dh_file '/etc/certs/hostapd.dh4096.pem'
        option eap_user_file '/etc/config/haprad.eap_user'
        option eapol_version '2'
        option ieee80211w '1'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Wxxxxxxa'
#       option encryption 'psk2+ccmp'
        option encryption 'sae-mixed'
        option wpa_psk_file '/etc/config/hostapd.wpa_psk'
        option beacon_int '500'

config wifi-iface
        option device 'radio1'
        option network 'guest1'
        option mode 'ap'
        option ssid 'Wxxxxxxc'
#       option encryption 'psk2+ccmp'
        option encryption 'sae-mixed'
        option key 'xxxxxxxxxxxxxxxxxxxxxxxx'
        list maclist 'fc:xx:xx:xx:xx:xx'
        list maclist 'e8:xx:xx:xx:xx:xx'
        option macfilter 'deny'
        option ieee80211w '1'

config wifi-iface
        option device 'radio1'
        option network 'guest2'
        option mode 'ap'
        option ssid 'Wxxxxxxd'
#       option encryption 'psk2+ccmp'
        option encryption 'sae-mixed'
        option key 'xxxxxxxxxxxxxxxxxxxxxxxx'
        list maclist '8c:xx:xx:xx:xx:xx'
        option macfilter 'deny'
        option ieee80211w '1'

config wifi-iface
        option device 'radio1'
        option network 'Ixxxxx'
        option mode 'ap'
        option ssid 'The Internet of Shitty Things'
#       option encryption 'psk2+ccmp'
        option encryption 'sae-mixed'
        option key 'xxxxxxxxxxxxxxxxxxxxxxxx'
        option ieee80211w '1'
        option disassoc_low_ack '0'
        option max_inactivity '1800'

config wifi-iface
        option device 'radio1'
        option network 'radio'
        option mode 'ap'
        option ssid 'wxxxxx'
#       option encryption 'psk2+ccmp'
        option encryption 'sae-mixed'
        option key 'xxxxxxxxxxxxxxxxxxxxxxxx'
        option ieee80211w '1'
        list maclist '8c:xx:xx:xx:xx:xx'
        list maclist 'fc:xx:xx:xx:xx:xx'
        list maclist 'e8:xx:xx:xx:xx:xx'
        option macfilter 'deny'

config wifi-iface
        option device 'radio1'
        option network 'tor'
        option mode 'ap'
        option ssid 'Txxxxx'
#       option encryption 'psk2+ccmp'
        option encryption 'sae-mixed'
        option key 'xxxxxxxxxxxxxxxxxxxxxxxx'
        option macaddr '00:xx:xx:xx:xx:xx'
        option ieee80211w '1'

I did try to identify the commit where the issue does start:

...
curl: bump to 7.64.0                                    8 Feb 2019 08:37 +0100

LAST GOOD BUILD 8 Feb 2019 12:30 +0100

mac80211: rt2x00: remove patch causing low tx power     8 Feb 2019 13:13 +0100
...
glibc: update to latest 2.27 commit [BZ #24180]         9 Feb 2019 21:07 +0100

FIRST BAD BUILD 10 Feb 2019 09:30:00

tools/tar: Update to 1.31                               10 Feb 2019 20:47 +0100
...

I did do a checkout of the variants around my first bad build and build an 
image. I couldn't reproduce the issue again.
Then I did go forward by a few commits and did check the image again. The last 
commit without the issue is:

base-files: fix ucert verification                      12 Feb 2019 16:42 +0100

The issue starts with the openssl related commits, but I did check only the 
last one:

openssl: add package for openssl.cnf, misc changes      12 Feb 2019 22:24 +0100

I build 6 images from different commits till:

build: Honour NO_COLOR in include/scan.mk               17 Feb 2019 19:22 +0100

If the openssl stuff is included, than I get the issue. If the openssl stuff 
isn't included, my 5GHz WiFi does start.
I've another TP-Link router with an ath9k as 5Ghz Wifi. It is the WDR3600. The 
Wifi configuration is similar like my
Archer C7. I don't see this issue.

Regards,
Hartmut


Am 16.02.2019 um 22:42 schrieb Ben Greear:
> 
> 
> On 02/16/2019 01:36 PM, Christian Lamparter wrote:
>> Hello,
>>
>> On Thursday, February 14, 2019 6:43:26 PM CET e9hack wrote:
>>> a change somewhere between 8.Feb and 10.Feb breaks the usage of the 5GHz 
>>> WiFi on my Archer C7 router.
>>> I get the following entries in the log file:
>>>
>>> Firmware is:
>>> ath10k_pci 0000:00:00.0: firmware ver 10.1-ct-8x-__fW-022-1bbfa151 api 2 
>>> features
>>> wmi-10.x,has-wmi-mgmt-tx,mfp,txstatus-noack,wmi-10.x-CT,ratemask-CT,txrate-CT,get-temp-CT,tx-rc-CT,cust-stats-CT,retry-gt2-CT,txrate2-CT
>>>
>>> crc32 66e0dff7
>>>
>>> Thu Feb 14 18:27:01 2019 daemon.err hostapd: Failed to set beacon parameters
>>> Thu Feb 14 18:27:01 2019 daemon.err hostapd: Interface initialization failed
>>> Thu Feb 14 18:27:01 2019 daemon.notice hostapd: wlan0: interface state 
>>> DFS->DISABLED
>>> Thu Feb 14 18:27:01 2019 daemon.notice hostapd: wlan0: AP-DISABLED
>>> Thu Feb 14 18:27:01 2019 daemon.notice hostapd: wlan0: interface state 
>>> DISABLED->DISABLED
>>> Thu Feb 14 18:27:01 2019 daemon.notice hostapd: wlan0-2: AP-DISABLED
>>> Thu Feb 14 18:27:01 2019 daemon.notice hostapd: wlan0-2: 
>>> CTRL-EVENT-TERMINATING
>>> Thu Feb 14 18:27:01 2019 daemon.err hostapd: hostapd_free_hapd_data: 
>>> Interface wlan0-2 wasn't started
>>> Thu Feb 14 18:27:01 2019 daemon.notice hostapd: wlan0-1: AP-DISABLED
>>> Thu Feb 14 18:27:01 2019 daemon.notice hostapd: wlan0-1: 
>>> CTRL-EVENT-TERMINATING
>>> Thu Feb 14 18:27:01 2019 daemon.err hostapd: hostapd_free_hapd_data: 
>>> Interface wlan0-1 wasn't started
>>> Thu Feb 14 18:27:01 2019 daemon.notice hostapd: wlan0: AP-DISABLED
>>> Thu Feb 14 18:27:01 2019 daemon.notice hostapd: wlan0: 
>>> CTRL-EVENT-TERMINATING
>>> Thu Feb 14 18:27:01 2019 daemon.err hostapd: hostapd_free_hapd_data: 
>>> Interface wlan0 wasn't started
>>> Thu Feb 14 18:27:01 2019 daemon.notice hostapd: nl80211: deinit 
>>> ifname=wlan0 disabled_11b_rates=0
>>> Thu Feb 14 18:27:01 2019 kern.info kernel: [  162.919267] device wlan0 left 
>>> promiscuous mode
>>> Thu Feb 14 18:27:01 2019 kern.info kernel: [  162.923985] br-lan: port 
>>> 2(wlan0) entered disabled state
>>> Thu Feb 14 18:27:02 2019 daemon.notice hostapd: ELOOP: remaining socket: 
>>> sock=23 eloop_data=0x77f9cc40 user_data=0
>>> handler=0x556a2d91
>>> Thu Feb 14 18:27:02 2019 daemon.notice netifd: radio0 (2540): cat: can't 
>>> open '/var/run/wifi-phy0.pid': No such file or
>>> directory
>>> Thu Feb 14 18:27:02 2019 daemon.notice netifd: radio0 (2540): WARNING 
>>> (wireless_add_process): executable path
>>> /usr/sbin/hostapd does not match process  path (/proc/exe)
>>> Thu Feb 14 18:27:02 2019 daemon.notice netifd: radio0 (2540): Command 
>>> failed: Invalid argument
>>> Thu Feb 14 18:27:03 2019 kern.warn kernel: [  164.791404] ath10k_pci 
>>> 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127
>>> tid: 256
>>> Thu Feb 14 18:27:03 2019 kern.info kernel: [  164.808256] ath10k_pci 
>>> 0000:00:00.0: wmi print 'P 128 V 8 T 410'
>>> Thu Feb 14 18:27:03 2019 kern.info kernel: [  164.814618] ath10k_pci 
>>> 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt:
>>> 0 ct-sta: 0'
>>> Thu Feb 14 18:27:03 2019 kern.info kernel: [  164.822797] ath10k_pci 
>>> 0000:00:00.0: wmi print 'alloc rem: 24616 iram:
>>> 26584'
>>
>>> Thu Feb 14 18:27:03 2019 kern.warn kernel: [  164.900521] ath10k_pci 
>>> 0000:00:00.0: pdev param 0 not supported by
>>> firmware
>>> Thu Feb 14 18:27:03 2019 kern.info kernel: [  164.925384] IPv6: 
>>> ADDRCONF(NETDEV_UP): wlan0: link is not ready
>>> Thu Feb 14 18:27:04 2019 daemon.notice netifd: radio0 (2540): Cannot find 
>>> device "wlan0-1"
>>> Thu Feb 14 18:27:04 2019 daemon.notice netifd: radio0 (2540): Interface 1 
>>> setup failed: IFUP_ERROR
>>> Thu Feb 14 18:27:05 2019 daemon.notice netifd: radio0 (2540): Cannot find 
>>> device "wlan0-2"
>>> Thu Feb 14 18:27:05 2019 daemon.notice netifd: radio0 (2540): Interface 2 
>>> setup failed: IFUP_ERROR
>>> Thu Feb 14 18:27:05 2019 kern.info kernel: [  166.183839] br-lan: port 
>>> 2(wlan0) entered blocking state
>>> Thu Feb 14 18:27:05 2019 kern.info kernel: [  166.189311] br-lan: port 
>>> 2(wlan0) entered disabled state
>>> Thu Feb 14 18:27:05 2019 kern.info kernel: [  166.195048] device wlan0 
>>> entered promiscuous mode
>>
>> "between 8.Feb and 10.Feb"
>>
>> https://github.com/openwrt/openwrt/commits/master/package/kernel/ath10k-ct
>>
>> so maybe it was:
>>
>> https://github.com/openwrt/openwrt/commit/835fc08ae3fb9e27db0f095a10fbff24f87ee1a9
>> (Although, github says it was commited on the 11th)
>>
>> Can you please post your /etc/config/wireless and try to revert the patch to 
>> test if
>> this helps with the situation?
>>
>> If it is indeed the patch (and not a unsupported configuration):
>>
>> @Ben can you please take a peek into your wave-1 firmware and check if the
>> mgmt_rate WMI (WMI_10X_VDEV_PARAM_MGMT_RATE) is supported, or if there is
>> a bad interaction somewhere else?
>>
>> (This "pdev param 0 not supported by firmware" was mentioned in
>> https://bugs.openwrt.org/index.php?do=details&task_id=1920 so probably not 
>> the problem)
> 
> Hopefully the user can bisect to the exact bad commit, and then I'll be happy 
> to
> try to figure out what is the issue.
> 
> I have not made many changes to the wave-1 firmware recently.  I have some API
> to set the management rates, but not sure it uses the same API as whatever 
> that
> patch in question is using.
> 
> Thanks,
> Ben
> 
>>
>> Cheers,
>> Christian
>>
>>
> 


_______________________________________________
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel

Reply via email to