Re: [osg-users] Load uniform sampler2D in shader from .osg file

2009-03-06 Thread Joseba
Hi attach the full source code, perhaps someone can find a solution to this problem. I dont have any clue for solving it. Thanks, J. -- Read this topic online here: http://forum.openscenegraph.org/viewtopic.php?p=8022#8022 osgprerender.rar Description: Binary data

Re: [osg-users] Configuring OSG for stereo

2009-03-06 Thread Robert Osfield
HI Eric, The units are assumed to be meters, so please just convert your values to meters. Robert. On Thu, Mar 5, 2009 at 11:57 PM, Eric Heft osgfo...@tevs.eu wrote: What sets the 'depth' plane when using stereo? From the docs you have measured and entered values for the following in

Re: [osg-users] photos to be displayed in sequence

2009-03-06 Thread Robert Osfield
HI Salvatore, Basic maths tells us that you won't be able to fit all these photo's in memory. The only way you could do it is to page them. osg::ImageSequence does support paging, so add the filename rather than the image. Next up, tga won't be the best format for paging. A movie format would

Re: [osg-users] modifying vertexs

2009-03-06 Thread Robert Osfield
Hi Jim, I'm confused by your email and your code segment, so not really sure what to comment on. Robert. On Fri, Mar 6, 2009 at 2:56 AM, Jim Brooks jimbl...@gmail.com wrote: Found two different ways to tell OSG that vertexs were modified. Maybe these are circumventions that aren't proper (?).

Re: [osg-users] Anti-Aliasing and MultiSampling.

2009-03-06 Thread Ümit Uzun
Hi Robert, I mean, I have MFC control screen and in this control screen I have picture box which has small bounding size in this control screen. And I am rendering in it. While traits-samples is 4 rendering in picture control boundary, but when I set traits-samples to 16 rendering screen goes

[osg-users] (no subject)

2009-03-06 Thread andree gebert
Wanting to catch up with Stephen Northcottpom, no dramas! Stay connected to the people that matter most with a smarter inbox. Take a look http://au.docs.yahoo.com/mail/smarterinbox___ osg-users mailing list osg-users@lists.openscenegraph.org

[osg-users] Using GLObjectsVisitor with a pre-DrawCallback

2009-03-06 Thread alessandro terenzi
I'm trying to pre-load some models that need their texture to be rescaled. Looking at earlier post I saw suggestions about using a Camera pre-draw callback that uses the GLObjectsVisitor to compile everything...but I can't find out exactly how to do this. By now, here is what I did: 1) created a

[osg-users] BoundingSphere with radius 0

2009-03-06 Thread Martin
Hello, I have a little Subgraph with a MatrixTransform and a Node. Now I need the BoundingSphere. But when I do ... osg::BoundingSphere boundingSphere=matrixTransform-GetNode()-getBound(); double distance = boundingSphere._radius; ...than is the distance = 0, but I don't know why. What can be

Re: [osg-users] modifying vertexs

2009-03-06 Thread Brian R Hill
Jim, You are addressing three different things in your email, display lists, geometry changes, primitive count. Dirtying the display list simply regenerates the display list and if you've changed the verts, they will get compiled into the new display list. If they weren't changed, then they'd

Re: [osg-users] BoundingSphere with radius 0

2009-03-06 Thread Brian R Hill
Martin, My guess is that either the node doesn't have any geometry - try writing it out as an .osg file and look at it. Or, the subgraph hasn't been traversed and the bounds haven't been calculated yet. Search on computeboundvisitor (or something like that) and run that on your node to generate

Re: [osg-users] BoundingSphere with radius 0

2009-03-06 Thread Martin
I have a geometry. But I updated the matrix in a thread: osg::Matrix matrix = new osg::Matrix; ((::osg::MatrixTransform*)_root.get())-setMatrix(matrix); _root is my MatrixTransform. And when I remove the line with setMatrix it works fine. When I use setMatrix my radius is 0. [Crying or Very

Re: [osg-users] BoundingSphere with radius 0

2009-03-06 Thread Brian R Hill
Martin, Not sure what the problem is, maybe you thread is conflicting with the osg threads. You should only update the MatrixTransform during the update traversal - or sync your thread with the update. What you are doing - setting the MatrixTransform should just work. Try doing it as an update

Re: [osg-users] BoundingSphere with radius 0

2009-03-06 Thread Robert Osfield
HI Martin, Might I suggest you check the value of matrix, it might be that the scale is 0. Robert. On Fri, Mar 6, 2009 at 1:34 PM, Martin grosser.mar...@gmx.de wrote: I have a geometry. But I updated the matrix in a thread: osg::Matrix matrix = new osg::Matrix;

[osg-users] Non emissive ParticleSystem and lighting

2009-03-06 Thread Christophe.medard
A patch solution could be introduced to give the impression ambient lighting works onto Particle System. Into osgParticleSystem::update() method, after particles' update(dt) method call their _current_color are stepped. We could there re-touch the stepped color and darken it according to an

Re: [osg-users] modifying vertexs

2009-03-06 Thread Jim Brooks
. osg::ref_ptrosg::Vec3Array mVertexs; mDrawArray = new osg::DrawArrays(osg::PrimitiveSet::POINTS,0,0); // Modify vertex array (mVertexs is in app side). mVertexs-push_back( vertex ); // Tell OSG geometry was modified. mGeometry-setVertexArray( mVertexs.get() );

[osg-users] Help with adding a player model

2009-03-06 Thread Mark Yantek
Is there a tutorial some place that explains how to attach a player model to a camera? If not could someone push me in the right direction? I'm using OSG2.6.1 Thanks -Mark Yantek ___ osg-users mailing list osg-users@lists.openscenegraph.org

Re: [osg-users] osggis crash on attribute query

2009-03-06 Thread Jason Beverage
Hi, Does it work alright for you under 2.6? I'll try to take a look at it if I get a chance. Thanks! Jason On Thu, Mar 5, 2009 at 1:21 AM, legeochen legeoc...@gmail.com wrote: Hi all: I just recompiled my osggis with new release version 2.8 osg under my debian lenny. When I try

Re: [osg-users] Help with adding a player model

2009-03-06 Thread Robert Osfield
Hi Mark, On Fri, Mar 6, 2009 at 3:24 PM, Mark Yantek myan...@rscusa.com wrote: Is there a tutorial some place that explains how to attach a player model to a camera? If not could someone push me in the right direction? Not sure what you are looking for. Are you wanting the viewe'rs master

Re: [osg-users] Help with adding a player model

2009-03-06 Thread Mark Yantek
Hi Robert, I would like to an object in the scene to the follow the viewer's master camera, like in a Jet flight simulator. Thanks - Mark -Original Message- From: osg-users-boun...@lists.openscenegraph.org [mailto:osg-users-boun...@lists.openscenegraph.org] On Behalf Of Robert Osfield

Re: [osg-users] Help with adding a player model

2009-03-06 Thread Robert Osfield
Hi Mark, On Fri, Mar 6, 2009 at 4:34 PM, Mark Yantek myan...@rscusa.com wrote: I would like to an object in the scene to the follow the viewer's master camera, like in a Jet flight simulator. I don't know of tutorial to point you at that specifically does this, even with the extra info above

Re: [osg-users] [osgPlugins] osgExp for 3ds Max 2008

2009-03-06 Thread alessandro terenzi
Hi, I also tried OsgExp 0.9.5 but I have some problems when exporting particles. The preview works fine, but when I export a .ive and I try to open it with osgviewer I get the following error: *Unknown node identification in DataInputStream::readNode() osgviewer.exe: No data loaded* Any idea?

Re: [osg-users] Help with adding a player model

2009-03-06 Thread Mark Yantek
Robert, Sorry for my lack of clarity. I'm trying to have the camera locked on to a user controlled object. After rethinking this I can see the path I need to follow. In the example OSGSIMULATOR there is a plane with a camera following it. I just need to move user control from the camera to the

Re: [osg-users] Help with adding a player model

2009-03-06 Thread Robert Osfield
HI Mark, OK, I now understand better what you are trying to do. You can use a osgGA::NodeTrackerManipulator as per the osgsimulation example, or attach a CameraView node to the same subgraph as the object you want to follow that use a osgGA::CameraViewSwitchManipulator. Alternatively rather

Re: [osg-users] WPF and OpenGL popup window problem

2009-03-06 Thread Himar Carmona
Hi, i also use WPF, you are not the only one. The problem in WPF is surely the airspace. In WPF you can't have in the same window overlapping technologies. And if the window is a popup window, if it has transparency activated, you will also experiment the same problem (but this time it

Re: [osg-users] OSG 2.6.1 and VPB

2009-03-06 Thread Michael W. Hall
I appreciate the reply. I got OSG 2.6.1 and followed the info you provided to get the version of VPB that was was listed in the table to work with the version of OSG I have installed. It has been a while since I have played with it, but the both build and installed. When I try to run

Re: [osg-users] osggis crash on attribute query

2009-03-06 Thread legeochen
Hi, Yes, it works fine with osg 2.6, 2.7.5 etc. Thanks! cheers 2009/3/6 Jason Beverage jasonbever...@gmail.com Hi, Does it work alright for you under 2.6? I'll try to take a look at it if I get a chance. Thanks! Jason On Thu, Mar 5, 2009 at 1:21 AM, legeochen legeoc...@gmail.com