Re: [osg-users] Problem with statesets usage

2009-04-10 Thread Charbit Romain
@Jean-Sébastien : Thank you, I was just afraid of missing something here, but if it's the common usage, I'm fine with that. @Bryan : Sorry for the misunderstanding, but the OFF|OVERRIDE is on the real shader node , not the empty one. And it is still applied. -- Read this topic

Re: [osg-users] Build of svn head, OGR plugin issues

2009-04-10 Thread Robert Osfield
On Thu, Apr 9, 2009 at 7:52 PM, Paul Martz pma...@skew-matrix.com wrote: This was an issue on my end, sorry for posting. For the archives: CMAKE_OSX_ARCHITECTURE defaults to ppc;i386. I changes it to i386 to eliminate the problem. OK, I've hit problems with mixing ppc + i386 builds with

Re: [osg-users] Problem with statesets usage

2009-04-10 Thread Charbit Romain
Hi Robert, Thanks for the answer, I was wondering why, with any state attribute, the shader was still applied in the same way. Romain. Romain. -- Read this topic online here: http://forum.openscenegraph.org/viewtopic.php?p=10054#10054

Re: [osg-users] Problem with statesets usage

2009-04-10 Thread Romain Charbit
When I say shader, I mean Osg::Program. But a more precise explanation of my problem may be useful. So I have a node representing an industrial pipe, divided in two main parts: - a group with groups that contain the geometry of the Pipe cut into parts (generated with a spline) - a group that

Re: [osg-users] Problem with statesets usage

2009-04-10 Thread Robert Osfield
Hi Romain, On Fri, Apr 10, 2009 at 9:50 AM, Charbit Romain romain.char...@gmail.comwrote: Thanks for the answer, I was wondering why, with any state attribute, the shader was still applied in the same way. osg::Shaders are attached to a osg::Program, and osg::Program is a StateAttribute.

[osg-users] Working without PATH variables

2009-04-10 Thread Geoff
Hi guys, I've been spending a few days playing around with OSG in my spare time, and I'm wanting to try to put together a small project using it. I was just wondering, how would I go about creating a project that does -not- use PATH variables to find information? For example, to find the

Re: [osg-users] Working without PATH variables

2009-04-10 Thread Vincent Bourdier
Hi, The DLL under windows will be searched in two places : in the same directery where the .exe is, and in the path... so just put your dll in the same folder than the .exe and they will be found. Same thing for the data, use relative path from the exe path ... and you can find your datas easily.

Re: [osg-users] Working without PATH variables

2009-04-10 Thread Serge Lages
Hi, Are you working on Windows, Linux, Mac ? About the PATH variable, it can help to find plugins or data, but you can off course build an application with everything directly packaged where the PATH variable is not useful. We've made lots of OSG applications which self contains everything needed

Re: [osg-users] Build of svn head, OGR plugin issues

2009-04-10 Thread Ismail Pazarbasi
Hi Robert, although Apple doesn't sell PPC machines anymore, there are hardcore devs still using PPC. Mach-O binary can have all architectures you mentioned. Therefore, passing -arch i386 -arch x86_64 and so on should generate a binary that contains a Mach-O binary for all listed architecture.

Re: [osg-users] Blueberry3D high detail terrain solution for OpenSceneGraph

2009-04-10 Thread Enrico Raue
Hello everybody, There is a new video on-line. [/url] http://www.bionatics.com/Blueberry3DGallery.php?category=31id=12 You will see Blueberry3D unique management of leaf-level detail and planetary-level coverage making it possible to move seamlessly from a high-orbit view of the whole Earth

[osg-users] Control of the drawing order for transparent quad

2009-04-10 Thread Julien Valentin
Hello I'm developping quite simple volume rendering technic consisting of several textured quads aligned according viewpoint. As I havent the time to write a cool shader for this I have sample my volume according x,y,z and select the set of quad that fit to the viewpoint.. As quads are parallels,

Re: [osg-users] Build of svn head, OGR plugin issues

2009-04-10 Thread Robert Osfield
Hi Ismail, On Fri, Apr 10, 2009 at 1:13 PM, Ismail Pazarbasi pazarb...@gmail.comwrote: although Apple doesn't sell PPC machines anymore, there are hardcore devs still using PPC. Mach-O binary can have all architectures you mentioned. Therefore, passing -arch i386 -arch x86_64 and so on should

Re: [osg-users] Blueberry3D high detail terrain solution for OpenSceneGraph

2009-04-10 Thread Christian Buchner
Most Impressive. I would like to see this technology to get used in Flight Simulators Not the military and professional ones - but those that everyone can buy off the shelf at the local software store. Have the 3D buildings and trees been planted with an automated process or was this edited by

Re: [osg-users] Control of the drawing order for transparent quad

2009-04-10 Thread Robert Osfield
Hi Julien, Is there a reaspn why you can't just use the osgVolume library? Robert. On Fri, Apr 10, 2009 at 2:01 PM, Julien Valentin julienvalenti...@gmail.com wrote: Hello I'm developping quite simple volume rendering technic consisting of several textured quads aligned according

Re: [osg-users] Working without PATH variables

2009-04-10 Thread Geoff
Thankyou for the quick replies guys, I'll try those suggestions. As for what I'm working with, I usually develop on Windows, simply because I like VisualStudio as an IDE. My software is generally designed to work anywhere if I can wrangle it. Thanks again, - Geoffrey. -- Read

Re: [osg-users] osgmovie/ffmpeg plugin questions

2009-04-10 Thread Robert Osfield
Hi JS, I don't see any delay when I've been using the Linux webcam streaming. Stream over the http I did find a delay and I presume this was down the plugin/ffmpeg pulling down a block of data that it could then start processing. One thing you could look into syncronization between the audio and

Re: [osg-users] osgmovie/ffmpeg plugin questions

2009-04-10 Thread Jean-Sébastien Guay
Hi Robert, I don't see any delay when I've been using the Linux webcam streaming. Stream over the http I did find a delay and I presume this was down the plugin/ffmpeg pulling down a block of data that it could then start processing. Hmmm, perhaps that explains the fixed stream time as

Re: [osg-users] terrain vertexes for VPB geocentric database...

2009-04-10 Thread Tueller, Shayne R Civ USAF AFMC 519 SMXS/MXDEC
Jason and Paul, Thanks much for the information. Each tile having its own local transform certainly makes sense for precision purposes given the extent of the database as a whole. I believe transforming the vertex by the modelview matrix will move the vertex into eye-centric world space (i.e.

Re: [osg-users] osgmovie/ffmpeg plugin questions

2009-04-10 Thread Robert Osfield
Hi JS, On Fri, Apr 10, 2009 at 3:14 PM, Jean-Sébastien Guay jean-sebastien.g...@cm-labs.com wrote: Hmmm, perhaps that explains the fixed stream time as well? Perhaps when streaming from http it pulls down a fixed block of data and then stops... I've been trying to get streaming through rtsp

[osg-users] FOG: applying both kinds at the same time. How?

2009-04-10 Thread Allen Saucier
Hi, everyone!!javascript:emoticon(':)') I'm new to OSG and I am struggling with applying both linear and exponential types of fog. Would someone mind showing me what I'm doing wrong? Thx for the help! I really appreciate it. // Fog: Linear osg::ref_ptrosg::Fog m_ofgFogLinear = new

[osg-users] DBPager continuously reloading tiles

2009-04-10 Thread Evan Andersen
I'm working on an application which uses osgEarth to display terrain databases to users. I need the application to use as little CPU time as possible while still providing good user interaction, so I have set my viewer up so that it only renders when necessary. I keep a loop running that does

Re: [osg-users] DBPager continuously reloading tiles

2009-04-10 Thread Robert Osfield
Hi Evan, Which version of the OSG are you using? Robert. On Fri, Apr 10, 2009 at 6:07 PM, Evan Andersen andersen.e...@gmail.comwrote: I'm working on an application which uses osgEarth to display terrain databases to users. I need the application to use as little CPU time as possible while

Re: [osg-users] DBPager continuously reloading tiles

2009-04-10 Thread Evan Andersen
Sorry, I forgot to mention that. I'm using version 2.9.2 from the trunk. -Evan On Fri, Apr 10, 2009 at 11:28 AM, Robert Osfield robert.osfi...@gmail.comwrote: Hi Evan, Which version of the OSG are you using? Robert. On Fri, Apr 10, 2009 at 6:07 PM, Evan Andersen

Re: [osg-users] FOG: applying both kinds at the same time. How?

2009-04-10 Thread Tueller, Shayne R Civ USAF AFMC 519 SMXS/MXDEC
I'm not sure what you mean by enable. If OSG mimics OpenGL state in the way fog is done, exponential and linear fog modes are mutually exclusive. You can render with one or the other, but not both. I would think that OSG uses the same paradigm... -Shayne -Original Message- From:

Re: [osg-users] Build of svn head, OGR plugin issues

2009-04-10 Thread Stephan Huber
Robert Osfield schrieb: OK, I've hit problems with mixing ppc + i386 builds with i386 dependencies. How important is unified binaries to OSX dev these days? Could we default to just i386, or perhaps even 64bit? perhaps it's sufficient to compile the gdal-dependent stuff only for i386. gdal

Re: [osg-users] osgmovie/ffmpeg plugin questions

2009-04-10 Thread Jason Daly
Jean-Sébastien Guay wrote: Well, it's hard to get some technical info from what docs there seem to be. Things like what formats are supported read/write/readwrite, what the format strings are for av_find_input_format, etc. I needed to go to the code for those things (avformat/allformats.c).

Re: [osg-users] osgmovie/ffmpeg plugin questions

2009-04-10 Thread Jason Daly
Jean-Sébastien Guay wrote: Well, it's hard to get some technical info from what docs there seem to be. Things like what formats are supported read/write/readwrite, what the format strings are for av_find_input_format, etc. I needed to go to the code for those things (avformat/allformats.c).

Re: [osg-users] osgmovie/ffmpeg plugin questions

2009-04-10 Thread Jean-Sébastien Guay
Hi Jason, Try runing ffmpeg -formats. This shows the available formats and containers. On the left of each you'll see D for decode and E for encode. For the codecs it will also show A for audio and V for video. I don't remember what the last S and/or D stands for. Note that these are

Re: [osg-users] osgmovie/ffmpeg plugin questions

2009-04-10 Thread Jason Daly
Jean-Sébastien Guay wrote: Also, do you have any experience with the ffmpeg api itself? I'm wondering what kind of error handling there is, to be able to better recover from bad format errors or such. I have some, although I never got into live streaming like you're trying. Also, my

Re: [osg-users] osgmovie/ffmpeg plugin questions

2009-04-10 Thread Jean-Sébastien Guay
Hi Jason, Most of the av_* and avcodec_* functions return error codes. If the error code was negative, badness happened, and I bailed. That's about the limit of the error handling I've done. And that seems to be what the plugin currently does. If you actually examine the error codes, you

Re: [osg-users] Red, Green and Blue, now I've tried two!

2009-04-10 Thread Leif Delgass
On Thu, Apr 9, 2009 at 5:01 AM, Robert Osfield robert.osfi...@gmail.com wrote: Things aren't prefect though.   No Texture3D support, so volume rendering support fails.  There is also no PBuffer support.  No texture compression support either so standard VPB generated models just result in white

Re: [osg-users] vpbmaster vs osgdem

2009-04-10 Thread Gert van Maren
Hi Robert, jp, gbd pointed to crash in GDAL - sincos. I compiled GDAL 1.6.0 and presto... all good. Thanks for your help. Gert On Fri, 10 Apr 2009 00:56:59 +1200, osg-users-requ...@lists.openscenegraph.org wrote: Hi Gert, Could you run osgdem inside gdb i.e. gdb osgdem run

Re: [osg-users] vpbmaster vs osgdem

2009-04-10 Thread Mark Yantek
Gert, You might want to build the newest libgeotiff and libtiff before GDAL. I was getting tiffread errors until they were all updated. - Mark -Original Message- From: osg-users-boun...@lists.openscenegraph.org [mailto:osg-users-boun...@lists.openscenegraph.org] On Behalf Of Gert van

[osg-users] 3D HUD Elements

2009-04-10 Thread Martins Innus
Hello, I've got a HUD working great with an osg::Camera attached to the scenegraph like in the examples with the orthographic projection, POST_RENDER, etc. Now I want to add a simple 3D axis element, like they have in modeling software that spins around based on your view and am having some

Re: [osg-users] Build of svn head, OGR plugin issues

2009-04-10 Thread Robert Osfield
Hi Stephan, On Fri, Apr 10, 2009 at 6:55 PM, Stephan Huber ratzf...@digitalmind.dewrote: Robert Osfield schrieb: OK, I've hit problems with mixing ppc + i386 builds with i386 dependencies. How important is unified binaries to OSX dev these days? Could we default to just i386, or perhaps

Re: [osg-users] Red, Green and Blue, now I've tried two!

2009-04-10 Thread Robert Osfield
Hi Leif, Thanks for the pointers, when I get a chance I'll boot up the Intel box and have a bash. Robert. On Fri, Apr 10, 2009 at 8:51 PM, Leif Delgass ldelg...@gmail.com wrote: On Thu, Apr 9, 2009 at 5:01 AM, Robert Osfield robert.osfi...@gmail.com wrote: Things aren't prefect though.

Re: [osg-users] osgviewer error message

2009-04-10 Thread Michael Billingsley
I bought and installed a Quadro FX 570 today. I still get the same error message when I try to load using Quad_Buffer? I've got the most up to date driver? -- Read this topic online here: http://forum.openscenegraph.org/viewtopic.php?p=10104#10104

Re: [osg-users] osgviewer error message

2009-04-10 Thread Jean-Sébastien Guay
Hello Michael, I bought and installed a Quadro FX 570 today. I still get the same error message when I try to load using Quad_Buffer? I've got the most up to date driver? Look around in the driver options. I think quad buffer stereo needs to be enabled (and isn't by default). J-S --

[osg-users] OpenSceneGraph-2.8.1 release candidate one tagged

2009-04-10 Thread Robert Osfield
Hi All, I have just tagged the OpenSceneGraph-2.8.1-rc1, which is a bug/build fix release of OpenSceneGraph-2.8.0 that remains binary compatible with 2.8.0. I've put up a quick attempt and news item for it: http://www.openscenegraph.org/projects/osg/wiki/News/Press/OSG2.8.1 You can

Re: [osg-users] Control of the drawing order for transparent quad

2009-04-10 Thread Julien Valentin
About osgVolume I'm currently working on osg 2.6 then there wasn't the lattest progress on osgvolume...I will check out the 2.8 soon Thank for the advice ___ osg-users mailing list osg-users@lists.openscenegraph.org

Re: [osg-users] DBPager continuously reloading tiles

2009-04-10 Thread Jason Beverage
Hi Evan, What happens if you set the expiry frame to something like 10 and the expiry time to DBL_MAX? I haven't tried running the DatabasePager without non-continuous rendering, so I'm not sure how well it works. Jason On Fri, Apr 10, 2009 at 5:20 PM, Evan Andersen

[osg-users] ray tracing using OSG

2009-04-10 Thread ami guru
Hello Forum, I was wondering if there is anyone have done ray tracing using OSG. So far i have got from the forum Jean-Sébastien Guay did his Masters thesis on that domain and it would be really nice if he provide the link to the report, at least it would be a starting point for me. What do