Re: [osg-users] [vpb] Some questions about VPB and cloud of points

2009-08-27 Thread Andrea Martini
Hi, ... Thank you! Cheers, Andrea -- Read this topic online here: http://forum.openscenegraph.org/viewtopic.php?p=16766#16766 ___ osg-users mailing list osg-users@lists.openscenegraph.org

Re: [osg-users] [vpb] Some questions about VPB and cloud of points

2009-08-27 Thread Andrea Martini
Hi Jagovic, thank you for your suggestion. I've tried 3Dem ... but what i mean is to find a procedure that i can use to design and develop inside a software application (using technologies like osg, gdal, vpb, osgearth,...). So i can create and visualize automatically my row data. Using 3Dem,

Re: [osg-users] Paging strategies for road tiles

2009-08-27 Thread Björn Blissing
Hi Brian, Yes, my tiles are a lot larger than 2000 meter. The radius of the first tile is 9008.5 m, and the road segment contained in that segment is 18017 m. But should really the range value be connected to the tile size?? I my mind it should work in the way that if my eye point comes within

Re: [osg-users] texture to file

2009-08-27 Thread Peter Wraae Marino
Hi osgUsers, I'm still battling with the luminance texture to file. The problem is I need to save a texture with 32bit floating point value for each pixel in the texture as a file and load it in at a later time. (16bit can also be used if 32bit isn't supported). I have tried all these

Re: [osg-users] texture to file

2009-08-27 Thread J.P. Delport
What format are you trying to write the file to? How are you attaching the image to your camera? i.e. where are the luminance values coming from? jp Peter Wraae Marino wrote: Hi osgUsers, I'm still battling with the luminance texture to file. The problem is I need to save a texture with

[osg-users] [osgPlugins] Openflight 16.3 features

2009-08-27 Thread Terence Ou
Hi, If I am correct, the current openflight loader does not support the full features of 16.3, e.g. reflection map, etc? Are there any heads up regarding when these would be in or considerations for them to be supported by the loader any time soon? Thank you! Cheers, Terence

Re: [osg-users] texture to file

2009-08-27 Thread J.P. Delport
Hi, Peter Wraae Marino wrote: Hi osgUsers, I'm still battling with the luminance texture to file. The problem is I need to save a texture with 32bit floating point value for each pixel in the texture as a file and load it in at a later time. (16bit can also be used if 32bit isn't supported).

Re: [osg-users] texture to file

2009-08-27 Thread Peter Wraae Marino
Hi jp, If I was to post the entire render setup it would be so big.. but I'll try and break it up into pseudo form: -osg::Camera setSourceType GL_FLOAT -osg::Camera setInternalFormat GL_LUMINANCE32F_ARB -osg::Camera detaches osg::Camera::COLOR_BUFFER -osg::Camera attaches

[osg-users] Inverting X Axis and possible Multithreading Problem

2009-08-27 Thread David Goering
Hey, I have two problems I hope someone can help me with, I will describe my setup first and then my two questions. Setup: I am not entirely sure if this question belongs here or in the plugin section, but here it goes anyway |-) My setup is this: OSG 2.8.1 and running OSGART. I am using a

[osg-users] [Qt] Zbuffer errors while rotation

2009-08-27 Thread Loic Cayou
Hi all, I'm a real beginner on OSG and I want use it with Qt 4.5 on Win32. I have to export an activeX based on OSG (dev. with VS) on a Qt application. The main purpose it's to display an osg model, and to interactive with it (mouse and keyboard). I already use the adapterWidget class, that I

Re: [osg-users] texture to file

2009-08-27 Thread J.P. Delport
Hi, sorry, more questions... Peter Wraae Marino wrote: Hi jp, If I was to post the entire render setup it would be so big.. but I'll try and break it up into pseudo form: -osg::Camera setSourceType GL_FLOAT you mean you set this on the camera's attached texture? -osg::Camera

Re: [osg-users] texture to file

2009-08-27 Thread Engvall Åsa
Try to use m_rImage-setInternalTextureFormat(GL_LUMINANCE32F_ARB); Åsa -Ursprungligt meddelande- Från: osg-users-boun...@lists.openscenegraph.org [mailto:osg-users-boun...@lists.openscenegraph.org] För J.P. Delport Skickat: den 27 augusti 2009 10:50 Till: OpenSceneGraph Users Ämne:

Re: [osg-users] osgOcean application

2009-08-27 Thread Hou Xl
Hi,kim ,Jean-Sebastien Guay and others: I tried it as you said ,and disabled the default shader (which is enabled by default in oceanscene). void OceanScene::setUseDefaultSceneShader( bool enable ) { _enableDefaultShader = enable; } I also loaded the cessnafire.osg in osgOcean example,But it

Re: [osg-users] [osgPlugins] Openflight 16.3 features

2009-08-27 Thread Trajce Nikolov
that is a good question. might be worth of updating the flight importer Nick http://www.linkedin.com/in/tnikolov On Thu, Aug 27, 2009 at 9:51 AM, Terence Ou riv...@msn.com wrote: Hi, If I am correct, the current openflight loader does not support the full features of 16.3, e.g. reflection

Re: [osg-users] [osgPlugins] Openflight 16.3 features

2009-08-27 Thread Gordon Tomlinson
You could always add the features if you need them now Or fund Paul to update the loader __ Gordon Tomlinson gor...@gordontomlinson.com IM: gordon3db...@3dscenegraph.com www.vis-sim.com www.gordontomlinson.com

Re: [osg-users] Inverting X Axis and possible Multithreading Problem

2009-08-27 Thread Gordon Tomlinson
On your second problem, have you used your debugger and stepped through your code to see whats happening with the program when screen goes black ? Your really the only one that can answer this question as you have the problem, the source code and tools to step into and debug,

Re: [osg-users] Compress image

2009-08-27 Thread Ufuk
Hi Ulrich,the reason of the problem is not image or cimage. yes you are right they are different but i think i wrote it wrong here. anyway when i debug i saw that cImage resoultion did not change. but today i checked the code again and i saw that i wrote the code like:

Re: [osg-users] osg, Qt and python

2009-08-27 Thread Gerwin de Haan
Hi Martin, In osgswig, there is a small osgviewer example with python + Qt (pyQT, but should be API compatible with LGPL'ed PySide Qt bindings). My guess is that a C++ OSG app with a python+Qt frontend should be doable. Gerwin On Thu, Aug 27, 2009 at 5:56 AM, Martin Beckett m...@mgbeckett.com

Re: [osg-users] [3rdparty] Node Kits for Charts Graph

2009-08-27 Thread Job Mulder
Hi Paul, I would definitely like to try out your Edge node :) We're currently switching from WTL/Lumo3d to Qt/OSG and so we need to rewrite our graphs lib anyway. If we can do it in OSG instead of in plain old OpenGL we could probably even improve it. If you have something I can try out for

Re: [osg-users] Paging strategies for road tiles

2009-08-27 Thread Thrall, Bryan
Björn Blissing wrote on Thursday, August 27, 2009 2:32 AM: Hi Brian, Yes, my tiles are a lot larger than 2000 meter. The radius of the first tile is 9008.5 m, and the road segment contained in that segment is 18017 m. But should really the range value be connected to the tile size?? I my

Re: [osg-users] osg, Qt and python

2009-08-27 Thread Martin Beckett
Yes I was assuming all the OSG and 'heavy lifting' in C++ with just a python gui (and scripting) so no need for osg-swig. Martin -- Read this topic online here: http://forum.openscenegraph.org/viewtopic.php?p=16794#16794 ___

Re: [osg-users] [Qt] Zbuffer errors while rotation

2009-08-27 Thread Loic Cayou
Anyone have a solution, just a start of thing? :-* -- Read this topic online here: http://forum.openscenegraph.org/viewtopic.php?p=16796#16796 ___ osg-users mailing list osg-users@lists.openscenegraph.org

Re: [osg-users] [osgPlugins] Openflight 16.3 features

2009-08-27 Thread Jason Daly
Terence Ou wrote: Hi, If I am correct, the current openflight loader does not support the full features of 16.3, e.g. reflection map, etc? Are there any heads up regarding when these would be in or considerations for them to be supported by the loader any time soon? I just glanced at

Re: [osg-users] [Qt] Zbuffer errors while rotation

2009-08-27 Thread Jason Daly
Loic Cayou wrote: Hi all, I'm a real beginner on OSG and I want use it with Qt 4.5 on Win32. I have to export an activeX based on OSG (dev. with VS) on a Qt application. The main purpose it's to display an osg model, and to interactive with it (mouse and keyboard). I already use the

Re: [osg-users] [Qt] Zbuffer errors while rotation

2009-08-27 Thread Loic Cayou
Thanks for reply Jason Daly, I will try to use setProjectionMatrixAsPerspective with corrects values. -- Read this topic online here: http://forum.openscenegraph.org/viewtopic.php?p=16799#16799 ___ osg-users mailing list

Re: [osg-users] [vpb] Some questions about VPB and cloud of points

2009-08-27 Thread Chris 'Xenon' Hanson
Andrea Martini wrote: Hi Jagovic, thank you for your suggestion. I've tried 3Dem ... but what i mean is to find a procedure that i can use to design and develop inside a software application (using technologies like osg, gdal, vpb, osgearth,...). So i can create and visualize automatically

Re: [osg-users] [Qt] Zbuffer errors while rotation

2009-08-27 Thread Loic Cayou
Hum, it's seems it works better ! My model disappear with setProjectionMatrixAsPerspective, but I also a coordinate system wich it's displayed. And with it, the mouse interactive works perfectly (I mean left, right and middle clic). I really don't know why my model isn't visible...

Re: [osg-users] OSGViewer camera position and external data

2009-08-27 Thread Alex Malhao
Which values should go inside brackets of setHomePosition(...) ? Any example? -- Read this topic online here: http://forum.openscenegraph.org/viewtopic.php?p=16803#16803 ___ osg-users mailing list osg-users@lists.openscenegraph.org

Re: [osg-users] OSGViewer camera position and external data

2009-08-27 Thread Robert Osfield
On Thu, Aug 27, 2009 at 5:22 PM, Alex Malhaofranciskovi...@gmail.com wrote: Which values should go inside brackets of setHomePosition(...) ? Any example? I won't answer as it's clearly time you learned how to read the headers... as it's pretty clear what the values should be from the naming the

Re: [osg-users] [Qt] Zbuffer errors while rotation

2009-08-27 Thread Jason Daly
Loic Cayou wrote: Hum, it's seems it works better ! My model disappear with setProjectionMatrixAsPerspective, but I also a coordinate system wich it's displayed. And with it, the mouse interactive works perfectly (I mean left, right and middle clic). I really don't know why my model isn't

Re: [osg-users] OSGViewer camera position and external data

2009-08-27 Thread Alex Malhao
I suppose that: Code: osg::Vec3 LookFrom, LookAt, Up; LookFrom = osg::Vec3(10,0,1); LookAt = osg::Vec3(10,0,1); Up = osg::Vec3(0,0,1); viewer.setHomePosition( LookFrom, LookAt, Up ); viewer.home(); will do the job. No? -- Read this topic online here:

Re: [osg-users] ortho projection problem

2009-08-27 Thread Paul Martz
I don't see where you set the view matrix. It is likely pushing your quad out of your view volume. Another possible problem is that you are drawing into the xy plane. If you are setting a view matrix with z up, then you're looking edge-en at the primitive and it won't appear. If you're using

Re: [osg-users] OSGViewer camera position and external data

2009-08-27 Thread Robert Osfield
Hi Alex, On Thu, Aug 27, 2009 at 5:46 PM, Alex Malhaofranciskovi...@gmail.com wrote: I suppose that: Code: osg::Vec3 LookFrom, LookAt, Up; LookFrom = osg::Vec3(10,0,1); LookAt = osg::Vec3(10,0,1); Up = osg::Vec3(0,0,1); viewer.setHomePosition( LookFrom, LookAt, Up ); viewer.home();

Re: [osg-users] osgEphemeris building errors

2009-08-27 Thread Paul Martz
I have not compiled osgEphemeris, but based on my experience using VS, I believe the "see previous definition" message indicates you are #including some header files multiple times, and for some reason they are not wrapped with "#pragma once" (or an equivalent CPP trick). The "inconsistent

Re: [osg-users] OSGViewer camera position and external data

2009-08-27 Thread Alex Malhao
Yes, you were right, there was a part missing, my mistake. There is one other thing bothering me, I think you might help: I've compiled the openscenegraph source files (I already tried the new camera position, and it's working well). But, there is one thing that i don't know how to solve. When