Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-04-26 Thread Jaeyoung Haan
I'm trying to install OSG on my Mac OSX 10.5.6 in order to develop 3D 
simulation.
I'm not going to use Xcode.

I downloaded osg source codes thru svn 2.8.1 rc, installed Cmake,
and did ./configure and make.

But the following error occurred, and I could not figure it out.
Plz help me.


Code:

Scanning dependencies of target osgdb_iv
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ConvertToInventor.cpp.o
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ConvertFromInventor.cpp.o
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/GroupSoLOD.cpp.o
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/PendulumCallback.cpp.o
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ReaderWriterIV.cpp.o
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ShuttleCallback.cpp.o
Linking CXX shared module ../../../lib/osgPlugins-2.8.1/osgdb_iv.so
ld warning: in 
/Developer/SDKs/MacOSX10.5.sdk/Library/Frameworks//Inventor.framework/Inventor, 
file is not of required architecture
Undefined symbols for architecture ppc:
  SoNode::writeInstance(SoOutput*), referenced from:
  vtable for GroupSoLODin GroupSoLOD.cpp.o
  SoVRMLTexture::getClassTypeId(), referenced from:
  ConvertFromInventor::preVRMLAppearance(void*, SoCallbackAction*, SoNode 
const*)in ConvertFromInventor.cpp.o
  SoFieldData::~SoFieldData(), referenced from:
  GroupSoLOD::atexit_cleanup()   in GroupSoLOD.cpp.o



... hundreds lines of similar messages ...




SoGroup::replaceChild(int, SoNode*), referenced from:
  vtable for GroupSoLODin GroupSoLOD.cpp.o
  SoLOD::getClassTypeId(), referenced from:
  ConvertFromInventor::preGroup(void*, SoCallbackAction*, SoNode const*)in 
ConvertFromInventor.cpp.o
  ConvertFromInventor::postGroup(void*, SoCallbackAction*, SoNode const*)in 
ConvertFromInventor.cpp.o
  GroupSoLOD::initClass()  in GroupSoLOD.cpp.o
  SoMFUInt32::getClassTypeId(), referenced from:
  bool ivApplicateIntTypeSoMFUInt32, unsigned int(osg::Array const*, 
SoMFUInt32, int, int, int)in ConvertToInventor.cpp.o
  SoSphere::SoSphere(), referenced from:
  ConvertToInventor::processShapeDrawable(osg::ShapeDrawable const*, 
ConvertToInventor::InventorState*)::MyShapeVisitor::apply(osg::Sphere const)in 
ConvertToInventor.cpp.o
ld: symbol(s) not found for architecture ppc
collect2: ld returned 1 exit status
lipo: can't open input file: 
/var/folders/bf/bf+HkrbPFfGBxK0g6Fm5vE+++TI/-Tmp-//cc9Swfmi.out (No such file 
or directory)
make[2]: *** [lib/osgPlugins-2.8.1/osgdb_iv.so] Error 1
make[1]: *** [src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/all] Error 2
make: *** [all] Error 2


[/code]

--
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=10871#10871





___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-04-27 Thread Jaeyoung Haan
Thanks robertosfield, it works.

--
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=10925#10925





___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org