Re: [osg-users] Multipass (was: no subject)

2008-02-04 Thread Art Tevs
Hi, First, please put some subject to your post. Maybe take a look into osgPPU (http://projects.tevs.eu/osgppu) this is a nodekit which is what you looking for. It helps you to make multipass (render to texture and then as input to next texture) in a very simple way, without creating

Re: [osg-users] SSAO : Screen Space Ambient Occlusion

2008-02-25 Thread Art Tevs
Hi Adrian, I do not think that a nodekit just for this purpose is usefull or needed. This kind of screen space algorithms can be perfectly described by the osgPPU. I really like this kind of effects and it seems that it is very straight forward to implement. I will try to create a .ppu file

Re: [osg-users] Texture2DArray shows up black

2008-02-25 Thread Art Tevs
Hi Sean, as far as I see you have an error in your setup. This line: ref_ptrUniform texturesUniform = new Uniform(Uniform::FLOAT, textures, 1); must be replaced with something like this: ref_ptrUniform texturesUniform = new Uniform(Uniform::SAMPLER_2D_ARRAY, textures, 0); Try this out.

Re: [osg-users] ANN: OSG training in Paris

2008-03-03 Thread Art Tevs
Hi folks, since Paris is only 400km away from the place where I am living, I would also like to attend the drink session afterwards. Hence I would also like to know if there is such a session planned and if we are allowed to attend it? Best regards, Art --- Serge Lages [EMAIL PROTECTED]

Re: [osg-users] Using NodeMask...

2008-03-03 Thread Art Tevs
Hi Vincent, haven't you forgot to set all other nodes or at least the sibling nodes to the eartGroup with node mask (0x0). Otherwise the default mask is something like 0x. Hence with your current setup you still will be able to see all the nodes. Cheers, Art --- Vincent Bourdier

[osg-users] General Question about setAttribute and removeAttribute

2008-03-05 Thread Art Tevs
Hi folks, just some thoughts about texture attributes (or all other attributes in general): If we first setup a texture attribute on a StateSet, lets say for the texture unit 0. After some time we remove this attribute and assign it to texture unit 1. This would end up in the texture bounded

Re: [osg-users] General Question about setAttribute and removeAttribute

2008-03-05 Thread Art Tevs
, 2008 at 12:25 PM, Art Tevs [EMAIL PROTECTED] wrote: Hi folks, just some thoughts about texture attributes (or all other attributes in general): If we first setup a texture attribute on a StateSet, lets say for the texture unit 0. After some time we remove this attribute

Re: [osg-users] Warning on Add shader to the scene

2008-03-24 Thread Art Tevs
Hi Gordon, Mike, as I have posted already before (however my patch was not accepted ;-( , this warning comes from the geometry shader implementation. I do not remember the line correctly, but you have to change only one value in the constructor of the Program.cpp There is one geometry shader

Re: [osg-users] Warning on Add shader to the scene

2008-03-25 Thread Art Tevs
__ Self defence is not a function of learning tricks but is a function of how quickly and intensely one can arouse one's instinct for survival -Master Tambo Tetsura -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Art Tevs Sent

Re: [osg-users] Warning on Add shader to the scene

2008-03-25 Thread Art Tevs
, Mar 25, 2008 at 8:37 AM, Art Tevs [EMAIL PROTECTED] wrote: Hi Gordon, here change the line 99 in Program.cpp into this: _geometryVerticesOut(1), _geometryInputType(GL_TRIANGLES), or with other words just set the _geometryVerticesOut to 1 instead of 0. It should be 0 per

[osg-users] osgPPU-0.1 developer release

2008-03-27 Thread Art Tevs
Hi folks, I finally found some time and now there is a first developer release of osgPPU Nodekit (ok not directly a node kit, because not derived from a node, but this will follow ;-). Here is the homepage of the project: http://projects.tevs.eu/osgppu/wiki There are couple of example

Re: [osg-users] osgPPU-0.1 developer release

2008-03-27 Thread Art Tevs
Hi Jean, I can remove the pthread dependency, however they are needed for proper static linking. It seems that since osg depends on OpenThreads and OpenThreads depends on pthread, this pthread requirement is needed. However you are right. For dynamic linking I do not need the extra pthread

Re: [osg-users] osgPPU-0.1 developer release

2008-03-27 Thread Art Tevs
a downloadable zip file or something? When I try to check out the SVN version, I get this error: Error: Can't connect to host 'projects.tevs.eu': No connection could be made because the target machine actively refused it. Cheers, Morne On Thu, Mar 27, 2008 at 1:56 PM, Art Tevs [EMAIL

Re: [osg-users] osgPPU-0.1 developer release

2008-03-28 Thread Art Tevs
be made because the target machine actively refused it. Cheers, Morne On Thu, Mar 27, 2008 at 1:56 PM, Art Tevs [EMAIL PROTECTED] wrote: Hi folks, I finally found some time and now there is a first developer release of osgPPU Nodekit (ok not directly a node kit, because

Re: [osg-users] osgPPU-0.1 developer release

2008-03-28 Thread Art Tevs
Hi jean, Ah, I understand. Perhaps then you could put it in a section only for the static link projects, something like IF (!DYNAMIC_OSGPPU) LINK_EXTERNAL(${TARGET_TARGETNAME} pthread) ENDIF(!DYNAMIC_OSGPPU) instead of removing the line completely... (not sure if ! is right in

[osg-users] osg user meeting in Paris

2008-03-31 Thread Art Tevs
Hi folks, as far as we all already know there will be a training course in Paris from 25 to 30 April. However there were still no information if and where an official user meeting afterwards will take place. Hence couple of questions: 1. Will there be an official osg-user-meeting? 2. Which

Re: [osg-users] osg user meeting in Paris

2008-04-01 Thread Art Tevs
] [mailto:[EMAIL PROTECTED] On Behalf Of Art Tevs Sent: Monday, March 31, 2008 9:00 AM To: osg-users@lists.openscenegraph.org Subject: [osg-users] osg user meeting in Paris Hi folks, as far as we all already know there will be a training course in Paris from 25 to 30

Re: [osg-users] Multiple Render Targets - Request forComments/Testing

2008-04-01 Thread Art Tevs
Hi J.P. I am also using MRT, however completely without osg::Camera. However since I am working with FBOs directly I would prefer to have something like an extra StateAttribute or something which should setup the MRT. Or maybe the setDrawBuffers as an extra method in the FBO code. I think

Re: [osg-users] osg user meeting in Paris

2008-04-01 Thread Art Tevs
and showing our work (from 6pm to 8pm for example), and then go to a pub or a restaurant to continue talking in a better atmosphere. On Tue, Apr 1, 2008 at 10:35 AM, Art Tevs [EMAIL PROTECTED] wrote: Hmm,.. I should also say anything in french now, but I cann't ;-)... I would suggest

Re: [osg-users] Multiple Render Targets - Request forComments/Testing

2008-04-01 Thread Art Tevs
so can't really give too much insight based on experience so am all ears. Robert. On Tue, Apr 1, 2008 at 1:08 PM, Art Tevs [EMAIL PROTECTED] wrote: Hi J.P. I am also using MRT, however completely without osg::Camera. However since I am working with FBOs directly I would

Re: [osg-users] OSG user meeting in Paris - Monday 28 April

2008-04-02 Thread Art Tevs
Hi all, I will also be there. I would like to bring my cousin to that meeting too, so that he got idea of the osg and computer graphics at all. I hope this is ok?! Best regards, Art --- David Callu [EMAIL PROTECTED] schrieb: Hi all, I will come. Cheers David Callu 2008/4/1, Mike

Re: [osg-users] OSG user meeting in Paris - Monday 28 April

2008-04-02 Thread Art Tevs
Hi Serge, do your office provide parking capabilities? As far as I remember, it is not a good idea to travel through Paris by car (a lot of damages and streets are overfilled). Hence could you give me an adress of a safe park house in the near of your office or any subway station. I would then

Re: [osg-users] How to retrieve a U, V texture coordinate from a picking action ?

2008-04-10 Thread Art Tevs
Hi Jerome, what you want to do is not an easy task. However here is a simple todo list to achieve that: - find intersection of the ray and a triangle - the intersection computatiuon would give you back the barycentric coordinates of the intersection point in the triangle domain - use this

Re: [osg-users] Disapplying of StateAttributes

2008-04-15 Thread Art Tevs
modes or attributes are left on the stack once everything is popped off then default modes are used, and default constructed versions of the attributes are applied to restore OpenGL state back to defaults. Robert. On Tue, Apr 15, 2008 at 12:27 PM, Art Tevs [EMAIL PROTECTED] wrote: Hi

[osg-users] Cyclic graphs?!

2008-04-17 Thread Art Tevs
Hi folks, as far as I can see for now osg doesn't check if the given scene graph contains cycles. If one do this, then there is a seg fault, if my test were correct ;-) However imagine I have a situation, where I need to have a cycle in the graph. For example: A - /|\ / ||

Re: [osg-users] Cyclic graphs?!

2008-04-17 Thread Art Tevs
[EMAIL PROTECTED] schrieb: Art Tevs wrote: Hi folks, as far as I can see for now osg doesn't check if the given scene graph contains cycles. If one do this, then there is a seg fault, if my test were correct ;-) However imagine I have a situation, where I need to have a cycle

Re: [osg-users] Cyclic graphs?!

2008-04-17 Thread Art Tevs
Hi folks, Hmm, yeah it could be. However I haven't thought a lot of thread safety in a cyclic scene graph. Of course, for my purpose, I maybe would be able to redesign the problem and break the cycle in it or more or less leave with it by changing hte ::traverse() methods accordingly. However, I

[osg-users] Some optimization of glActiveTexture

2008-04-18 Thread Art Tevs
Hi Robert, there is currently some unoptimized code in the osg. If one do specify for example 10 texture attributes for a stateset like this: stateset-setTextureAttribute(i, new osg::Texture2D()); and after some time you remove this attributes, there is still an unneccessary call to

Re: [osg-users] List of add on packages

2008-04-22 Thread Art Tevs
Hi, Paul, to post something to the wiki one has to register somehow in the trac environment. How to do this? Best regards, Art --- Paul Martz [EMAIL PROTECTED] schrieb: Hi Kevin -- At the OpenSceneGraph Web site, select Community on the menu at the right. You will see that there are

Re: [osg-users] List of add on packages

2008-04-22 Thread Art Tevs
] On Behalf Of Art Tevs Sent: Tuesday, April 22, 2008 10:37 AM To: OpenSceneGraph Users Subject: Re: [osg-users] List of add on packages Hi, Paul, to post something to the wiki one has to register somehow in the trac environment. How to do this? Best regards, Art

Re: [osg-users] updating geometry and textures

2008-04-23 Thread Art Tevs
Hi, I think if you change your geometry on the fly, you have to call dirtyBound() of course. Otherwise the old bound can be used during the cull traversal and your node maybe culled. cheers, Art --- [EMAIL PROTECTED] schrieb: it seems now that the objects only dissapear at certain camera

[osg-users] Monday's User meeting in Paris

2008-04-30 Thread Art Tevs
Hi folks, I have updated the Community/Past Event webpage and placed a picture shooted in the pub after the official meeting time. I saw that somebody of you had shooted pictures during the meeting. It would be very nice if you could upload the images of the meeting to the same page?! Best

Re: [osg-users] Monday's User meeting in Paris

2008-04-30 Thread Art Tevs
and maybe write into some list (everything like this : second right in front - Michael Jakson) Best regards, Art Tevs J-S -- __ Jean-Sebastien Guay [EMAIL PROTECTED] http://www.cm-labs.com

Re: [osg-users] Monday's User meeting in Paris

2008-05-02 Thread Art Tevs
Tevs, Serge Lages (Tharsis) For the other ones, don't hesitate to post a note to share your contact. :) Cheers, On Wed, Apr 30, 2008 at 9:19 PM, Art Tevs [EMAIL PROTECTED] wrote: Hi Jean, Nice picture, any chance you can list the people who are in the photo? I am afraid, I

Re: [osg-users] Multiple projective texture passes?

2008-05-05 Thread Art Tevs
Hi Jason, I think, you do not need multiple cameras. If you have the projective matricies of each of the captured viewcamera, then you can just combine all the projective textures in one pass. Just pass all your matricies and corresponding textures to the shader and compute the average value. If

Re: [osg-users] Multiple projective texture passes?

2008-05-05 Thread Art Tevs
for having multiple transformation matrices without hard-coding the list of matrices? Thanks in advance, Art Tevs wrote: Hi Jason, I think, you do not need multiple cameras. If you have the projective matricies of each of the captured viewcamera, then you can just combine all the projective

[osg-users] Data of fresh textures - Bug/Features

2008-05-06 Thread Art Tevs
Hi folks, I think I've found an improvement or a possible bug for the textures in osg. If one do allocate empty textures (not from images) then the texture is created with glTexImageXD call and with 0 as pixel pointer. As per OpenGL 1.1 specification the texture is allocated but the data in the

Re: [osg-users] Data of fresh textures - Bug/Features

2008-05-07 Thread Art Tevs
in the previous state back) - if hardware do not support fbo, then do this in the image way, hence create temporary an array holding the default color value and upload it to the texture. This would be slower however will also work. Cheers, Art Robert. On Wed, May 7, 2008 at 12:17 AM, Art Tevs

Re: [osg-users] Multiple projective texture passes?

2008-05-07 Thread Art Tevs
between the various cameras projecting onto the scene. I've tried using NESTED_RENDER on the cameras, increasing the camera values with a static counter, but they still fight. How would I go about removing the flicker from the different camera passes? Thanks in advance, Art Tevs

Re: [osg-users] osgPPU upcoming v0.2 release - please test svn version

2008-05-07 Thread Art Tevs
!!! It seems that it is so easy!!! Maybe you could provide me with some example application which I could put to the library. In this way one can easy find out how to use this both libraries to achieve better looking rendering outputs ;-)) Cheers, Art On Wed, 2008-05-07 at 22:24 +0200, Art Tevs

Re: [osg-users] osgPPU upcoming v0.2 release - please test svnversion

2008-05-08 Thread Art Tevs
put to the library. In this way one can easy find out how to use this both libraries to achieve better looking rendering outputs ;-)) Cheers, Art On Wed, 2008-05-07 at 22:24 +0200, Art Tevs wrote: Hi folks, There is already couple of months since the last release version

Re: [osg-users] osgPPU upcoming v0.2 release - please test svn version

2008-05-08 Thread Art Tevs
Hi Robert, Jeremy, Robert I've changed your proposed cmake commandos to detect the osg version. I have attached a file with a macro which can be used to detect everything what osg offers. The main difference to your suggestion is, that it uses EXECUTE_PROCESS instead of EXEC_PROGRAM, which

Re: [osg-users] About the Warning: detected OpenGL error 'invalid value' after RenderBin::draw(, )

2008-05-08 Thread Art Tevs
Hi Franclin, this is maybe the same warning as we have very often since geometry shader support on that list. Try to correct the src/osg/Program.cpp file in the line 99 from _geometryVerticesOut(0),_geometryInputType(GL_TRIANGLES), to _geometryVerticesOut(1),_geometryInputType(GL_TRIANGLES),

Re: [osg-users] Make node transparent on the fly - osg::Depth state leakage?

2008-05-09 Thread Art Tevs
Hi Christian, The problem is that the osg::Depth state seems to leak out and affect every rendered node while the fade-out is in effect. After the node is removed from the scenegraph, everything is back to normal. This is sometimes a normal behaviour (as I shortly found out ;), because

Re: [osg-users] osgWidget 0.1.8 (pre-merge)

2008-05-13 Thread Art Tevs
Hi Jeremy, I wanted to try out your lib, but I have problems regarding to the cmake build system. First problem is, if you have osg installed not under standard directory. I have then manually to specify the cmake_include and cmake_lib paths. maybe you could take a look into CMake build system

[osg-users] osgPPU v0.2

2008-05-14 Thread Art Tevs
Hi folks, I am gladly to inform you that I have tagged the v0.2 of the osgPPU library. The list of all changes since the last tagged version is long. The main new features are: - Unit derived from osg::Node to allow simple graph structure to create new unit pipelines - Cycles in the graph are

Re: [osg-users] osgPPU v0.2

2008-05-14 Thread Art Tevs
at example/hdr/CMakeLists.txt:16(LINK_INTERNAL):Unknown CMake command LINK_INTERNAL Any suggestions? Thanks, Brian [EMAIL PROTECTED] wrote: - To: OpenSceneGraph Users osg-users@lists.openscenegraph.org From: Art Tevs [EMAIL PROTECTED] Sent by: [EMAIL

Re: [osg-users] Texture2DArray shows up black

2008-05-16 Thread Art Tevs
Hi Raul, have you tried the proposed changes by Sean (min/mag filters, at least 2 layers, ...)? Cheers, Art --- Rahul Jain [EMAIL PROTECTED] schrieb am Fr, 16.5.2008: Von: Rahul Jain [EMAIL PROTECTED] Betreff: Re: [osg-users] Texture2DArray shows up black An: OpenSceneGraph

Re: [osg-users] Texture2DArray shows up black

2008-05-16 Thread Art Tevs
] Betreff: Re: [osg-users] Texture2DArray shows up black An: [EMAIL PROTECTED], OpenSceneGraph Users osg-users@lists.openscenegraph.org Datum: Freitag, 16. Mai 2008, 21:26 Yes I did but no luck I tried the program sean sent also. RJ Art Tevs wrote: Hi Raul, have you tried the proposed

Re: [osg-users] Texture2DArray shows up black (WARN: A bug in implementation)

2008-05-17 Thread Art Tevs
. cheers RJ Art Tevs wrote: Hi Raul, is it possible, that you extract that peace of code and post it here. Maybe I would be able to find then the issue. On my side, texture arrays seems to work properly ;) Best regards, Art --- Rahul Jain [EMAIL PROTECTED] schrieb am Fr, 16.5.2008

Re: [osg-users] Texture2DArray shows up black (WARN: A bug in implementation)

2008-05-17 Thread Art Tevs
Datum: Samstag, 17. Mai 2008, 13:20 Thanks Art, I am looking forward for the patch and will definitely keep an eye on the osg-submissions list. cheers RJ Art Tevs wrote: Hi Raul, OK, I see the problem. In my case your code just work almost fine (I can see the loaded image). However I

Re: [osg-users] traverse

2008-05-19 Thread Art Tevs
Hi Валерa, As in my case, I always do just call setNumChildrenRequiringUpdateTraversal(1) somewhere during the initialization phase and this do force using update traversals. Just call it in the constructor of your MyClass class and this is fine. Best regards, Art (Артём) --- Валерий Быков

Re: [osg-users] FBO Rendering

2008-05-20 Thread Art Tevs
Hi Roman, 1) I can't use (or don't know) ping-pong rendering technique as described here http://www.m3xbox.com/GPU_blog/?m=200712 Because when I attach 2 textures to camera FBO in rendering loop camera render to 2 FBO but I need to change dynamically which draw buffer I need to

Re: [osg-users] osgPPU Performance

2008-05-21 Thread Art Tevs
Hi Brian, First I like to say osgPPU is really fantastic!!! yes, in deed ;-) I'm using osgPPU 0.2 on OSG 2.2. I had to add my own version of osg::Shader::readShadefFile to get it to compile/run on osg 2.2. So far so good. I can run the examples and I've created my own test

Re: [osg-users] osgPPU Performance

2008-05-21 Thread Art Tevs
::StatsHandler ); Brian BTW - I'm on Win XP with Nvidia Quadro FX 4600. [EMAIL PROTECTED] wrote: - To: OpenSceneGraph Users osg-users@lists.openscenegraph.org From: Art Tevs [EMAIL PROTECTED] Sent by: [EMAIL PROTECTED] Date: 05/21/2008 04:33PM Subject: Re: [osg-users] osgPPU

Re: [osg-users] Adding a shader cancels shadows!

2008-05-22 Thread Art Tevs
Hi Mail, as far as I know the osgShadow do use already shaders for its implementation. Hence if you add a shader you autmaticly cacnels the shadows. To solve that you could try to merge the osgShadow shader code and your own. However you have also to take care about all the uniforms which

Re: [osg-users] Rendering the scene multiple times with different shaders.

2008-05-22 Thread Art Tevs
Hi Viggo, I need to render the scene many times each frame. The first render is a normal one, so I need no change in textures, states or shaders. The second render is a multi target render. Here I need to change all the fragment shaders that my scene uses. Each shader need to output data

Re: [osg-users] empty geode + shader + uniform = bug ?

2008-05-22 Thread Art Tevs
Hi Stephane, Stephane, try to put an empty shader program on the cow, just like this: cow-getOrCreateStateSet()-setAttribute(new osg::Program(), osg::StateAttribute::ON); I think this could help you. And if not then just add an empty UniformList to the stateset of the cow. Best regards, Art

Re: [osg-users] empty geode + shader + uniform = bug ?

2008-05-23 Thread Art Tevs
and post a submission if I find the origin of the problem. Art Tevs a écrit : Have you tried, what I have proposed before? cheers, Art --- Stephane Lamoliatte [EMAIL PROTECTED] schrieb am Fr, 23.5.2008: Von: Stephane Lamoliatte [EMAIL PROTECTED] Betreff: Re: [osg-users

Re: [osg-users] empty geode + shader + uniform = bug ?

2008-05-23 Thread Art Tevs
Hi Robert, Stephane sorry a lot of text As replied in previous posts, their is a whole mechanism in osg::State for managing state, there is no need for a disapply as this automatically comes part of the package. OK, maybe I have to read through the complete osg code again and again.

Re: [osg-users] empty geode + shader + uniform = bug ?

2008-05-23 Thread Art Tevs
Hi folks, OK, I understand what Mike means by the baseline behaviour. And as you also wrote: the apply of the default setting is done by apply a default constructed StateAttribute this is exactly what I meant by a fresh state attribute. So we are speaking about the same things. If I would

Re: [osg-users] need some help on multi pass render

2008-06-23 Thread Art Tevs
Hi Benoit, I try to make a multi pass rendering in order to apply post effect after each pass. I try to have this pass order: camera1-RTT1-Quad-camera2-RTT2-Quad-camera3. Group* subgraph; Node* model; Geode quad1, quad2; each camera is use like :

Re: [osg-users] how can I render a video??

2008-06-23 Thread Art Tevs
Hi Martin, do you want to render your animation with 25FPS or do you want to show a running video as a textrue with 25FPS? What is the problem? Best regards, Art --- Martin Großer [EMAIL PROTECTED] schrieb am Mo, 23.6.2008: Von: Martin Großer [EMAIL PROTECTED] Betreff: [osg-users] how

Re: [osg-users] how can I render a video??

2008-06-23 Thread Art Tevs
I think there is no such node kit, because this is actually very simple thing to do. First take a look into the osgViewer::Viewer class, it provides you with some methods to setup your own time. Hence you just set on every new frame a new time, which is based on your desired fps. Second after

[osg-users] FOI Postmaster (hacked???)

2008-06-23 Thread Art Tevs
Hi folks, sorry, it seems there is something wrong with my email account. Every time I write something to the list my mails are forwarded to some Swedish Defence Research Agency, FOI I think I was hacked ;) I checked my mail settings and there is nothing suspicious. Maybe somebody of you

Re: [osg-users] FOI Postmaster (hacked???)

2008-06-23 Thread Art Tevs
to public mailing lists. Robert. On Mon, Jun 23, 2008 at 1:59 PM, Art Tevs [EMAIL PROTECTED] wrote: Hi folks, sorry, it seems there is something wrong with my email account. Every time I write something to the list my mails are forwarded to some Swedish Defence Research Agency, FOI I

Re: [osg-users] Outline technique that doesn't triple (or worse) my frame time?

2008-11-25 Thread Art Tevs
Hi Jean-Sebastian, I would propose to use post processing outline technique. I have no references how to do this, but here an idea how I think it could be implemented: 1) render selected object into a stencil texture (hence you got 1 where object is seen and 0 otherwise) 2) use a shader to

Re: [osg-users] CUDA + osg compilation issues???

2008-11-27 Thread Art Tevs
Users osg-users@lists.openscenegraph.org Datum: Donnerstag, 27. November 2008, 15:50 Art Tevs wrote: Hi folks, has anybody of you ever tried to compile .cu cuda-file with nvcc, which does include osg headers. Here is just a simple test case which doesn't compile for whatever reasons

[osg-users] CUDA + osg compilation issues???

2008-11-27 Thread Art Tevs
Hi folks, has anybody of you ever tried to compile .cu cuda-file with nvcc, which does include osg headers. Here is just a simple test case which doesn't compile for whatever reasons: #include stdio.h #include osg/State int main() { osg::State* test = new osg::State; printf(%d\n,

Re: [osg-users] CUDA + osg compilation issues???

2008-11-27 Thread Art Tevs
unsuccessful to find out what goes wrong there. I check out if it would be possible to generate a bug report, however requiring the whole osg/include directory just to regenerate a bug is somehow overblown ;( If somebody does know more, I would be very appreciated. Cheers art --- Art Tevs

Re: [osg-users] CUDA + osg compilation issues???

2008-11-27 Thread Art Tevs
, if the right people do react on this ;) Cheers, art --- Art Tevs [EMAIL PROTECTED] schrieb am Do, 27.11.2008: Von: Art Tevs [EMAIL PROTECTED] Betreff: Re: [osg-users] CUDA + osg compilation issues??? An: OpenSceneGraph Users osg-users@lists.openscenegraph.org Datum: Donnerstag, 27. November 2008, 16

[osg-users] Determine texture memory allocation size

2008-11-27 Thread Art Tevs
Hi, does anybody of you know if it is possible to determine the size of allocated bytes of texture in the memory (VRAM or just RAM if swapped). One can compute it by the internal texture format and data type, however I would be interested if there exists some opengl routine which do gives me

Re: [osg-users] Determine texture memory allocation size

2008-11-28 Thread Art Tevs
Hi Jean-Sebastian, this counter thing or other queries of texture memory require that one load/unload the texture to see the difference. However I would like to have a method similar to glGetTexParameter or so, which gives me direct result. As far as I was bale to find additional info there is

[osg-users] osgPPU and CUDA ;) !!!

2008-11-28 Thread Art Tevs
Hi folks, whoever is interested in a combination of CUDA and osgPPU is asked to test current svn version under the sandbox branch of osgPPU repository. The implementation depends on both patches, I have submitted before. As soon as this patches are either commited or rejected I will merge the

[osg-users] osg::Viewport doubles???

2008-11-30 Thread Art Tevs
Hi folks. Can somebody explain me what is actually the reason having double as type for the osg::Viewport variables (x, y, width and height)? We have now always to cast (static_cast) in the Viewport::apply method and if I need that values too, I have also to cast. I think this is an avoidable

Re: [osg-users] osg::Viewport doubles???

2008-11-30 Thread Art Tevs
be negligible given that you'll only be doing a once or twice a frame. Robert. On Sun, Nov 30, 2008 at 3:46 PM, Art Tevs [EMAIL PROTECTED] wrote: Hi folks. Can somebody explain me what is actually the reason having double as type for the osg::Viewport variables (x, y, width and height)? We

Re: [osg-users] osg::Viewport doubles???

2008-11-30 Thread Art Tevs
], OpenSceneGraph Users osg-users@lists.openscenegraph.org Datum: Sonntag, 30. November 2008, 17:17 Hi Art, On Sun, Nov 30, 2008 at 3:59 PM, Art Tevs [EMAIL PROTECTED] wrote: Shouldn't then the method, which scales the viewport, take care of casting? Because based on OpenGL Specification viewport

Re: [osg-users] osg::Viewport doubles???

2008-11-30 Thread Art Tevs
on a 32bit system. Even more; cuda compiled applications doesn't read out any nonsense values out of viewports anymore. Hence I propose to use floats there instead of doubles. Or maybe use doubles only if compiled for 64 bits. What do you think about that, Robert? Art --- Art Tevs [EMAIL

[osg-users] Siggraph Asia somebody there?

2008-12-02 Thread Art Tevs
Hi folks, will somebody of you be at the Siggraph Asia next week? cheers, Art ___ osg-users mailing list osg-users@lists.openscenegraph.org http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

Re: [osg-users] osgPPU v0.3 cycles problem

2008-12-17 Thread Art Tevs
Hi Alexandre, The problem is that from somewhere in the osg there is a node visitor running over the osgPPU pipeline which hasn't specified type. I would expect here to run the update visitor first, but there is some other visitor running, and I do not know which one ;(, because the visitor

Re: [osg-users] Unknown visitor running first and general visitor types

2008-12-17 Thread Art Tevs
Sorry, I have send the message before completing it: unsigned int osg::computeVisitorType(const std::string type_id) { return some_hash(type_id); } This would enable the possibility to check out which type of visitor is currently traversing the node. Also in future releases or in external

Re: [osg-users] Unknown visitor running first and general visitor types

2008-12-17 Thread Art Tevs
and more informative than the coming up with some hashmap scheme. Robert. On Wed, Dec 17, 2008 at 10:30 AM, Art Tevs stud_in...@yahoo.de wrote: Hi folks, It seems that in the current version of osg, there is some unknown node visitor running over all of my nodes. The node type does

[osg-users] Unknown visitor running first and general visitor types

2008-12-17 Thread Art Tevs
Hi folks, It seems that in the current version of osg, there is some unknown node visitor running over all of my nodes. The node type does return just NODE_VISITOR=0. Hence I do not see any way to find out, which type of visitor is traversing there. Currently there exists so many different

Re: [osg-users] osgPPU and change in colors

2008-12-19 Thread Art Tevs
Hi, I would suppose, that your lighting cnditions are different. It could be that in one case the scene is lit by some lights and in another case there is no lighting (no lights in use). Check it out. Cheers --- guher b gb...@yahoo.com schrieb am Fr, 19.12.2008: Von: guher b

[osg-users] ScreenSpaceAmbientOcclusion (SSAO) with osgPPU

2008-12-19 Thread Art Tevs
Hi folks, I have implemented a very simple (yeah it is just a real big faken) SSAO example with osgPPU. The example is build in the same way as Adrian's osgFX effect and is described here: http://mikepan.homeip.net/ssaowcn The current one computes the AO-term in multisampling way (hence in

[osg-users] Forum with Mailing list connection (Christmas Gift ; ) )

2008-12-22 Thread Art Tevs
Hi folks, I am glad to present a small christmas gift to the community. After two days and one night of hard work I was able to install, and configure a forum which has a direct connection to the mailing list. The forum software is phpBB2 with Mail2Forum MOD and a lot of modifications from my

Re: [osg-users] Forum with Mailing list connection (Christmas Gift ; ) )

2008-12-22 Thread Art Tevs
Thanks. :D Yes and the nice thing is - one can use both mailing list and the forum!!! I do like a forum more, because it is just a modern art to bring a community together, I think. For beginners it is also a very nice opportunity to have everything in one place in a sense they are familar

Re: [osg-users] Forum with Mailing list connection (Christmas Gift ; ) )

2008-12-22 Thread Art Tevs
Hi Robert, glad to hear that you also like it ;) The current script can handle either POP3 connections or direct MBox file parsing to get the emails from. I haven't cleaned up my mailbox since 2 months, hence I was able to import them ;) As to the mailman, with the current implementation it

Re: [osg-users] Forum with Mailing list connection (Christmas Gift ; ) )

2008-12-22 Thread Art Tevs
Oh yeah, I forgot, one of the main features one has to implement now is a scan of all old messages and compare the sender names with registered user names (of course real names of the users) so that users registering on the forum get links to their posts ;) -- Read this topic

Re: [osg-users] Forum with Mailing list connection (Christmas Gift ; ) )

2008-12-22 Thread Art Tevs
Yes, I know. The problem lies in the Mail2Forum script, which can connect only one to one, hence one forum/category to one mailinglist. Having a general mailing list which isn't splitted up into sublists would make it difficult to find out which messages belong into which cateogry on the

[osg-users] Reassigning of your mails to forum posts

2008-12-22 Thread Art Tevs
Ok folks, I do have a possibility to reassign your posts from the mailing list to your user registered at the forum. If you want your messages to be assigned to you back, you have to write me an email, like this: - Hey, could you please assign my messages to the user:

Re: [osg-users] Forum with Mailing list connection (Christmas Gift ; ) )

2008-12-22 Thread Art Tevs
The question is not if there are still such mail clients exists, it is more do you like to use mail clients? As for me I am working with OSG on three different machines, hence setting up mail client on each of this machine isn't that, that I really want to do (moving to GoogleMail or similar

Re: [osg-users] Forum with Mailing list connection (Christmas Gift ; ) )

2008-12-23 Thread Art Tevs
Hi Matthew, yes, this was the next step I was thinking about. However this need some non-trivial changes to the forum software to make it possible, hence this would take time... I think to do this in the following way: - User post to the forum under some category: CategoryA - I have a problem -

Re: [osg-users] Merry Christmas

2008-12-25 Thread Art Tevs
Yeah merry christmas and happy new year!!! P.S. After that post, I can be pretty sure, that UTF-8 support do work fine when moving a message from the list into the forum ;) -- Read this topic online here: http://osgforum.tevs.eu/viewtopic.php?p=3855#3855

Re: [osg-users] ScreenSpaceAmbientOcclusion (SSAO) with osgPPU

2008-12-28 Thread Art Tevs
Hi Oleg. Thanks for the info. I've changed the Base.cpp file. Hmm, you seems to be the first, who's compiler doesn't compile that file well ;) But nevermind, thanks again. Happy new year, art OpenSceneGraph Forum - http://osgforum.tevs.eu -- Read this

Re: [osg-users] Money!

2008-12-29 Thread Art Tevs
Yeah, however the ct' Magazin does not check if you work with OSG or not ;) You can ask Bob Kuehne, his company (as far as I know) does use OSG for their products. Maybe he can tell you more. -- Read this topic online here: http://osgforum.tevs.eu/viewtopic.php?p=3889#3889

Re: [osg-users] Set mouse position

2008-12-29 Thread Art Tevs
Hi Carlos, there exists a method to reset the mouse position. It is the osgGA::GUIActionAdapter::requestWarpPointer method. You get the action adapter in your callback method, where you capture the inputs (keyboard, mouse, ...). However be warned, when you call this method, your callback

[osg-users] [3rdparty] New years gift: Forum does now supports categories by subject filtering!

2008-12-29 Thread Art Tevs
Hi folks, again a new gift for the community, now for the new years celebration ;) I am happy to announce that our forum does now support multiple categories!!! Subjects of all messages coming from the mailing list will be scanned for specified prefixes and the message will be posted under the

Re: [osg-users] Warning level

2008-12-30 Thread Art Tevs
Hi all, some longer time ago there was a discussion about the warning levels. Robert wasn't happy about using very pendantic warning levels, since it could introduce more errors than we currently have. Maybe take a look into list archives. Hence I am not really sure that

Re: [osg-users] Forum with Mailing list connection (Christmas Gift ; ) )

2009-01-01 Thread Art Tevs
Hi Sukender, Sukender wrote: About the forum, why are the URLs masked with Only registered users can see links on this board when not logged in? I mean email adresses should be hidden (for harvesters), but why the links? I made this this way, so that potential spammers could see that

  1   2   3   4   5   >