Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-04-27 Thread Robert Osfield
Hi Jaeyong,

Sounds like you have Inventor installed on your system so the OSG's
Cmake build system is picking up on this and enabling the build of the
Inventor plugin (to be able to read .iv and .wrl files.)  Alas once
the build start going on this plugin it compiles by fails on link due
to the Inventor library itself not being built with the same processor
architectures supported by the OSG build.  This can happen if the 3rd
party library is built for just ppc or just 386, while the OSG by
default is building as a unified build with ppc and 386 paths.

To get things building you could either disable the building of the
Inventor plugin by running ccmake make and the scrolling down to the
inventor related env vars and resetting them, then pressing 'c' to
configure, and 'g' to generate the final build system, or disable the
build of both ppc and 386 architectures, again via cmake.

Robert.

On Sun, Apr 26, 2009 at 8:54 AM, Jaeyoung Haan unkno...@gmail.com wrote:
 I'm trying to install OSG on my Mac OSX 10.5.6 in order to develop 3D 
 simulation.
 I'm not going to use Xcode.

 I downloaded osg source codes thru svn 2.8.1 rc, installed Cmake,
 and did ./configure and make.

 But the following error occurred, and I could not figure it out.
 Plz help me.


 Code:

 Scanning dependencies of target osgdb_iv
 [ 80%] Building CXX object 
 src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ConvertToInventor.cpp.o
 [ 80%] Building CXX object 
 src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ConvertFromInventor.cpp.o
 [ 80%] Building CXX object 
 src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/GroupSoLOD.cpp.o
 [ 80%] Building CXX object 
 src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/PendulumCallback.cpp.o
 [ 80%] Building CXX object 
 src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ReaderWriterIV.cpp.o
 [ 80%] Building CXX object 
 src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ShuttleCallback.cpp.o
 Linking CXX shared module ../../../lib/osgPlugins-2.8.1/osgdb_iv.so
 ld warning: in 
 /Developer/SDKs/MacOSX10.5.sdk/Library/Frameworks//Inventor.framework/Inventor,
  file is not of required architecture
 Undefined symbols for architecture ppc:
  SoNode::writeInstance(SoOutput*), referenced from:
      vtable for GroupSoLODin GroupSoLOD.cpp.o
  SoVRMLTexture::getClassTypeId(), referenced from:
      ConvertFromInventor::preVRMLAppearance(void*, SoCallbackAction*, SoNode 
 const*)in ConvertFromInventor.cpp.o
  SoFieldData::~SoFieldData(), referenced from:
      GroupSoLOD::atexit_cleanup()       in GroupSoLOD.cpp.o



 ... hundreds lines of similar messages ...




 SoGroup::replaceChild(int, SoNode*), referenced from:
      vtable for GroupSoLODin GroupSoLOD.cpp.o
  SoLOD::getClassTypeId(), referenced from:
      ConvertFromInventor::preGroup(void*, SoCallbackAction*, SoNode const*)in 
 ConvertFromInventor.cpp.o
      ConvertFromInventor::postGroup(void*, SoCallbackAction*, SoNode 
 const*)in ConvertFromInventor.cpp.o
      GroupSoLOD::initClass()      in GroupSoLOD.cpp.o
  SoMFUInt32::getClassTypeId(), referenced from:
      bool ivApplicateIntTypeSoMFUInt32, unsigned int(osg::Array const*, 
 SoMFUInt32, int, int, int)in ConvertToInventor.cpp.o
  SoSphere::SoSphere(), referenced from:
      ConvertToInventor::processShapeDrawable(osg::ShapeDrawable const*, 
 ConvertToInventor::InventorState*)::MyShapeVisitor::apply(osg::Sphere 
 const)in ConvertToInventor.cpp.o
 ld: symbol(s) not found for architecture ppc
 collect2: ld returned 1 exit status
 lipo: can't open input file: 
 /var/folders/bf/bf+HkrbPFfGBxK0g6Fm5vE+++TI/-Tmp-//cc9Swfmi.out (No such file 
 or directory)
 make[2]: *** [lib/osgPlugins-2.8.1/osgdb_iv.so] Error 1
 make[1]: *** [src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/all] Error 2
 make: *** [all] Error 2


 [/code]

 --
 Read this topic online here:
 http://forum.openscenegraph.org/viewtopic.php?p=10871#10871





 ___
 osg-users mailing list
 osg-users@lists.openscenegraph.org
 http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-04-27 Thread Jaeyoung Haan
Thanks robertosfield, it works.

--
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=10925#10925





___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-04-26 Thread Jaeyoung Haan
I'm trying to install OSG on my Mac OSX 10.5.6 in order to develop 3D 
simulation.
I'm not going to use Xcode.

I downloaded osg source codes thru svn 2.8.1 rc, installed Cmake,
and did ./configure and make.

But the following error occurred, and I could not figure it out.
Plz help me.


Code:

Scanning dependencies of target osgdb_iv
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ConvertToInventor.cpp.o
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ConvertFromInventor.cpp.o
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/GroupSoLOD.cpp.o
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/PendulumCallback.cpp.o
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ReaderWriterIV.cpp.o
[ 80%] Building CXX object 
src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/ShuttleCallback.cpp.o
Linking CXX shared module ../../../lib/osgPlugins-2.8.1/osgdb_iv.so
ld warning: in 
/Developer/SDKs/MacOSX10.5.sdk/Library/Frameworks//Inventor.framework/Inventor, 
file is not of required architecture
Undefined symbols for architecture ppc:
  SoNode::writeInstance(SoOutput*), referenced from:
  vtable for GroupSoLODin GroupSoLOD.cpp.o
  SoVRMLTexture::getClassTypeId(), referenced from:
  ConvertFromInventor::preVRMLAppearance(void*, SoCallbackAction*, SoNode 
const*)in ConvertFromInventor.cpp.o
  SoFieldData::~SoFieldData(), referenced from:
  GroupSoLOD::atexit_cleanup()   in GroupSoLOD.cpp.o



... hundreds lines of similar messages ...




SoGroup::replaceChild(int, SoNode*), referenced from:
  vtable for GroupSoLODin GroupSoLOD.cpp.o
  SoLOD::getClassTypeId(), referenced from:
  ConvertFromInventor::preGroup(void*, SoCallbackAction*, SoNode const*)in 
ConvertFromInventor.cpp.o
  ConvertFromInventor::postGroup(void*, SoCallbackAction*, SoNode const*)in 
ConvertFromInventor.cpp.o
  GroupSoLOD::initClass()  in GroupSoLOD.cpp.o
  SoMFUInt32::getClassTypeId(), referenced from:
  bool ivApplicateIntTypeSoMFUInt32, unsigned int(osg::Array const*, 
SoMFUInt32, int, int, int)in ConvertToInventor.cpp.o
  SoSphere::SoSphere(), referenced from:
  ConvertToInventor::processShapeDrawable(osg::ShapeDrawable const*, 
ConvertToInventor::InventorState*)::MyShapeVisitor::apply(osg::Sphere const)in 
ConvertToInventor.cpp.o
ld: symbol(s) not found for architecture ppc
collect2: ld returned 1 exit status
lipo: can't open input file: 
/var/folders/bf/bf+HkrbPFfGBxK0g6Fm5vE+++TI/-Tmp-//cc9Swfmi.out (No such file 
or directory)
make[2]: *** [lib/osgPlugins-2.8.1/osgdb_iv.so] Error 1
make[1]: *** [src/osgPlugins/Inventor/CMakeFiles/osgdb_iv.dir/all] Error 2
make: *** [all] Error 2


[/code]

--
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=10871#10871





___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-19 Thread Robert Osfield
Hi John,

This does sounds like a CMake bug.  I wonder if reverting to old version of
CMake might help.

Robert.

On Wed, Mar 18, 2009 at 8:17 PM, john casu j...@chiraldynamics.com wrote:

 Robert,

 I put debugging messages in FindFreeType.cmake, and the behavior is as
 expected within that cmake file, i.e. FREETYPE_INCLUDE_DIRS gets set
 correctly.

 The issue, as far as I can tell, is why cmake on os/x either isn't
 exporting FREETYPE_INCLUDE_DIRS, or there's a typo somewhere outside that
 file so that the variable isn't getting picked up.

 I spent a little time trying to debug this, but I'm not really getting
 anywhere, given that I have little cmake experience.  But, everything does
 seem to be working as expected, so it's a little bit of a mystery.

 certainly, the code in Find3rdPartyDependencies.cmake doesn't seem to be
 traversed, and src/osgPlugins/freetype/CMakeLists.txt seems to be correct.

 Unfortunately, I don't have enough time, right now, to devote to debugging
 this in any depth.   And since I do have a workaround, I'm not blocked.

 --
 Read this topic online here:
 http://forum.openscenegraph.org/viewtopic.php?p=8734#8734





 ___
 osg-users mailing list
 osg-users@lists.openscenegraph.org
 http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-19 Thread Mattias Helsing
Hi John

I'm catching up with the list and just saw this. I'm not a mac user
but I recently made a submission in the Find3rdPartyDependencies.cmake
and freetype area that is in the osg-2.8 branch (not 2.8.0). As I
understand you have 2.8.0?

If you want to try it out I've attached the file

Mattias

On 3/19/09, Robert Osfield robert.osfi...@gmail.com wrote:
 Hi John,

 This does sounds like a CMake bug.  I wonder if reverting to old version of
 CMake might help.

 Robert.

 On Wed, Mar 18, 2009 at 8:17 PM, john casu j...@chiraldynamics.com wrote:

 Robert,

 I put debugging messages in FindFreeType.cmake, and the behavior is as
 expected within that cmake file, i.e. FREETYPE_INCLUDE_DIRS gets set
 correctly.

 The issue, as far as I can tell, is why cmake on os/x either isn't
 exporting FREETYPE_INCLUDE_DIRS, or there's a typo somewhere outside that
 file so that the variable isn't getting picked up.

 I spent a little time trying to debug this, but I'm not really getting
 anywhere, given that I have little cmake experience.  But, everything does
 seem to be working as expected, so it's a little bit of a mystery.

 certainly, the code in Find3rdPartyDependencies.cmake doesn't seem to be
 traversed, and src/osgPlugins/freetype/CMakeLists.txt seems to be correct.

 Unfortunately, I don't have enough time, right now, to devote to debugging
 this in any depth.   And since I do have a workaround, I'm not blocked.

 --
 Read this topic online here:
 http://forum.openscenegraph.org/viewtopic.php?p=8734#8734





 ___
 osg-users mailing list
 osg-users@lists.openscenegraph.org
 http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org




Find3rdPartyDependencies.cmake
Description: Binary data
___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-19 Thread Eric Sokolowsky
I  compiled svn with cmake 2.6.3 on OSX without difficulty, in a clean
directory, using all of the default settings, so I cannot confirm the
existence of this bug.

-Eric

On Mon, Mar 16, 2009 at 9:19 PM, john casu osgfo...@tevs.eu wrote:

 I'm trying to build the latest svn version of OSG 2.8.0 on OS/X, and I'm
 having a problem when building osgdb_freetype, specifically the header file
 ft2build.h cannot be located:
 Scanning dependencies of target osgdb_freetype
 [ 98%] Building CXX object
 src/osgPlugins/freetype/CMakeFiles/osgdb_freetype.dir/FreeTypeFont.cpp.o
 In file included from
 /Users/casuj/OpenSceneGraph/OpenSceneGraph-2.8.0-svn/src/osgPlugins/freetype/FreeTypeFont.cpp:14:
 /Users/casuj/OpenSceneGraph/OpenSceneGraph-2.8.0-svn/src/osgPlugins/freetype/FreeTypeFont.h:19:22:
 error: ft2build.h: No such file or directory
 /Users/casuj/OpenSceneGraph/OpenSceneGraph-2.8.0-svn/src/osgPlugins/freetype/FreeTypeFont.h:20:10:
 error: #include expects FILENAME or FILENAME

 However, CMakeCache.txt shows that this file has been located:
 enterprise:OpenSceneGraph-2.8.0-svn casuj$ fgrep FREETYPE CMakeCache.txt

 CMakeCache.txt:FREETYPE_INCLUDE_DIR_freetype2:PATH=/usr/local/include/freetype2
 CMakeCache.txt:FREETYPE_INCLUDE_DIR_ft2build:PATH=/usr/local/include
 CMakeCache.txt:FREETYPE_LIBRARY:FILEPATH=/usr/local/lib/libfreetype.dylib

 and the file itself does in fact exist:
 enterprise:OpenSceneGraph-2.8.0-svn casuj$ ls -l
 /usr/local/include/ft2build.h
 -rw-r--r--  1 root  admin  3890 Mar  5  2007 /usr/local/include/ft2build.h

 Can anyone shed light on how to workaround this ?

 Thanks,

 -john c.

 --
 Read this topic online here:
 http://forum.openscenegraph.org/viewtopic.php?p=8569#8569





 ___
 osg-users mailing list
 osg-users@lists.openscenegraph.org
 http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-19 Thread E. Wing
I don't know what the specific build issue is as I believe the local
FindFreeType.cmake module should be searched for first, but I thought I
would share some history.

Originally there was no FindFreeType.cmake module in CMake. I wrote the
original one for OpenSceneGraph and then submitted it to CMake. Quickly
after, the KDE people got mad at me because they had their own
FindFreetype.cmake module they were planning to submit which was not
completely compatible with ours. Mine was better because it didn't rely on
running freetype-config (bad for cross-compiling), and got the
capitalization of FreeType correct. But because KDE is bigger than
OpenSceneGraph, we lost.

There was a promise that they would take the better elements of mine (e.g.
no dependency on freetype-config) and duplicate variables to allow our stuff
to still work, but it could be that those variables have since been removed.
(I was told our variables would be considered deprecated.)


-Eric
___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-19 Thread john casu
fyi.. the command I used to grab the svn release was:

svn checkout http://www.openscenegraph.org/svn/osg/OpenSceneGraph/trunk 
OpenSceneGraph

I'm pretty certain it's the latest, as installing it creates a 
/usr/local/lib/osgPlugins-2.9.1 directory.

--
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=8815#8815





___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-18 Thread Robert Osfield
Hi John,

I'm afraid it's kinda difficult for me to help debug this remotely.
Changing the new of our FindFreeType.cmake so it's more distinct i.e.
something like FindOurFreeType.cmake might be sensible, or perhaps just
removing our local one completely so you can then rely upon the one in
Cmake.

Another thing to try would be adding the MESSAGE(..) macro into our
FindFreeType.cmake to track which variables are being set to what and which
script branches are being taken.  This might provide some clues to why
FREETYPE_INCLUDE_DIRS is not being defined.  Another change would be the
freetype plugins CMakeList.txt so that it uses the individual include
directories rather than FREETYPE_INCLUDE_DIRS.

Robert.

On Tue, Mar 17, 2009 at 6:27 PM, john casu osgfo...@tevs.eu wrote:

 the workaround of setting FREETYPE_FOUND to NO works, so CMake is
 definitely picking the local version of FindFreeType.cmake

 --
 Read this topic online here:
 http://forum.openscenegraph.org/viewtopic.php?p=8645#8645





 ___
 osg-users mailing list
 osg-users@lists.openscenegraph.org
 http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-18 Thread john casu
Robert,

I put debugging messages in FindFreeType.cmake, and the behavior is as expected 
within that cmake file, i.e. FREETYPE_INCLUDE_DIRS gets set correctly.

The issue, as far as I can tell, is why cmake on os/x either isn't exporting 
FREETYPE_INCLUDE_DIRS, or there's a typo somewhere outside that file so that 
the variable isn't getting picked up.

I spent a little time trying to debug this, but I'm not really getting 
anywhere, given that I have little cmake experience.  But, everything does seem 
to be working as expected, so it's a little bit of a mystery. 

certainly, the code in Find3rdPartyDependencies.cmake doesn't seem to be 
traversed, and src/osgPlugins/freetype/CMakeLists.txt seems to be correct.

Unfortunately, I don't have enough time, right now, to devote to debugging this 
in any depth.   And since I do have a workaround, I'm not blocked.

--
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=8734#8734





___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-17 Thread Robert Osfield
Hi John,

When I've built under OSX before I haven't had problems, but I haven't
personally built and installed freetype so this may be factor.   The
freetype plugin uses:

   INCLUDE_DIRECTORIES(${FREETYPE_INCLUDE_DIRS} )

Which suggests the entry in the OpenSceneGraph/FindFreeType.cmake

IF(FREETYPE_INCLUDE_DIR_ft2build AND FREETYPE_INCLUDE_DIR_freetype2)
  SET(FREETYPE_INCLUDE_DIRS
${FREETYPE_INCLUDE_DIR_ft2build};${FREETYPE_INCLUDE_DIR_freetype2})
ENDIF(FREETYPE_INCLUDE_DIR_ft2build AND FREETYPE_INCLUDE_DIR_freetype2)

Isn't successful for some reason.  Check you CMakeCache.txt for the
FREETYPE_INCLUDE_DIRS var.

Which version of CMake are you using?  Perhaps it has its own
FindFreeType.cmake that is taking precidence over ours and is not setting
the FREETYPE_INCLUDE_DIRS.

Robert.

On Tue, Mar 17, 2009 at 1:19 AM, john casu osgfo...@tevs.eu wrote:

 I'm trying to build the latest svn version of OSG 2.8.0 on OS/X, and I'm
 having a problem when building osgdb_freetype, specifically the header file
 ft2build.h cannot be located:
 Scanning dependencies of target osgdb_freetype
 [ 98%] Building CXX object
 src/osgPlugins/freetype/CMakeFiles/osgdb_freetype.dir/FreeTypeFont.cpp.o
 In file included from
 /Users/casuj/OpenSceneGraph/OpenSceneGraph-2.8.0-svn/src/osgPlugins/freetype/FreeTypeFont.cpp:14:
 /Users/casuj/OpenSceneGraph/OpenSceneGraph-2.8.0-svn/src/osgPlugins/freetype/FreeTypeFont.h:19:22:
 error: ft2build.h: No such file or directory
 /Users/casuj/OpenSceneGraph/OpenSceneGraph-2.8.0-svn/src/osgPlugins/freetype/FreeTypeFont.h:20:10:
 error: #include expects FILENAME or FILENAME

 However, CMakeCache.txt shows that this file has been located:
 enterprise:OpenSceneGraph-2.8.0-svn casuj$ fgrep FREETYPE CMakeCache.txt

 CMakeCache.txt:FREETYPE_INCLUDE_DIR_freetype2:PATH=/usr/local/include/freetype2
 CMakeCache.txt:FREETYPE_INCLUDE_DIR_ft2build:PATH=/usr/local/include
 CMakeCache.txt:FREETYPE_LIBRARY:FILEPATH=/usr/local/lib/libfreetype.dylib

 and the file itself does in fact exist:
 enterprise:OpenSceneGraph-2.8.0-svn casuj$ ls -l
 /usr/local/include/ft2build.h
 -rw-r--r--  1 root  admin  3890 Mar  5  2007 /usr/local/include/ft2build.h

 Can anyone shed light on how to workaround this ?

 Thanks,

 -john c.

 --
 Read this topic online here:
 http://forum.openscenegraph.org/viewtopic.php?p=8569#8569





 ___
 osg-users mailing list
 osg-users@lists.openscenegraph.org
 http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-17 Thread Robert Osfield
Hi John,

Could you check cmakes' Modules directory to see what it's providing for
FreeType, it could be that it doesn't provide the FREETYPE_INCLUDE_DIRS.

Robert.

On Tue, Mar 17, 2009 at 5:41 PM, john casu osgfo...@tevs.eu wrote:

 Robert,

 as you can see, from my original post, there's no FREETYPE_INCLUDE_DIRS
 defined in CMakeCache.txt, just the envvars for the two sub-paths, and the
 FREETYPE_LIBRARY envvar for the library.

 I'm using cmake 2.6.3, which is the most recent version.

 btw, I should point out that all I'm doing to build OSG is a vanilla
 ./configure ; make command, which is why I raised the issue. The freetype
 lib itself comes from OS/X 10.5.6 SDK/Xcode 3.1.2, which I'm guessing one
 needs to have installed to do the build to begin with.

 --
 Read this topic online here:
 http://forum.openscenegraph.org/viewtopic.php?p=8639#8639





 ___
 osg-users mailing list
 osg-users@lists.openscenegraph.org
 http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-17 Thread john casu
The system cmake file for FreeType on OS/X is /Applications/CMake\ 
2.6-3.app/Contents/share/cmake-2.6/Modules/FindFreetype.cmake 


and it does set the variables:

# set the user variables
IF(FREETYPE_INCLUDE_DIR_ft2build AND FREETYPE_INCLUDE_DIR_freetype2)
  SET(FREETYPE_INCLUDE_DIRS 
${FREETYPE_INCLUDE_DIR_ft2build};${FREETYPE_INCLUDE_DIR_freetype2})
ENDIF(FREETYPE_INCLUDE_DIR_ft2build AND FREETYPE_INCLUDE_DIR_freetype2)
SET(FREETYPE_LIBRARIES ${FREETYPE_LIBRARY})

# handle the QUIETLY and REQUIRED arguments and set FREETYPE_FOUND to TRUE if 
# all listed variables are TRUE
INCLUDE(FindPackageHandleStandardArgs)
FIND_PACKAGE_HANDLE_STANDARD_ARGS(Freetype  DEFAULT_MSG  FREETYPE_LIBRARY  
FREETYPE_INCLUDE_DIRS)

MARK_AS_ADVANCED(FREETYPE_LIBRARY FREETYPE_INCLUDE_DIR_freetype2 
FREETYPE_INCLUDE_DIR_ft2build)

That last MARK_AS_ADVANCED line looks hinky to me, btw.

I put in a quick disabling of freetype (setting FOUND_FREETYPE to NO) in the 
OSG version of this cmake file.  If it fails to build, then I'd venture a guess 
that cmake is grabbing it's own cmake file instead of the OSG version.

--
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=8643#8643





___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-17 Thread john casu
btw,  I just noticed, the spelling of the two files is different, where you 
guys capitalize the middle T.

The system file:  FindFreetype.cmake
OSG: FindFreeType.cmake

would that be a problem ??

--
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=8644#8644





___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


Re: [osg-users] [build] osgdb_freetype build problem on Mac OS/X 10.5.6

2009-03-17 Thread john casu
the workaround of setting FREETYPE_FOUND to NO works, so CMake is definitely 
picking the local version of FindFreeType.cmake

--
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=8645#8645





___
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org