Re: [Ovillo] Posición de background dependiente de otro div

2009-10-28 Por tema Rafael García Lepper
Hola,

Este comportamiento es correcto, en ingles lo llaman Collapsing margins y
no estoy seguro de la traducción correcta, aquí tienes el enlace en inglés
[1] donde explican los motivos y los casos en los que sucede, en ie es
diferente si tiene hasLayout [2] activado .

Se soluciona estableciendo un block formatting context[3] nuevo, como
puede ser un overflow (cualquiera distinto a visible), o un float.

Siento que todos los enlaces estén en inglés.

[1] http://www.w3.org/TR/CSS21/box.html#collapsing-margins
[2] http://www.satzansatz.de/cssd/onhavinglayout.html
[3] http://www.w3.org/TR/CSS21/visuren.html#block-formatting

Saludos

Rafa

biosfera  4
diseño y desarrollo web
http://www.biosfera4.com


Hernán Beati - SaberWeb.com.ar escribió:

 Hola a todos!
 Estoy tratando de entender un ejercicio al que no le encuentro una causa
 lógica:
 
 1) El body tiene aplicada una imagen de fondo en mosaico. Sin problemas
 hasta aquí.
 
 Luego hay dos divs:
 
 2) un div #contenedor con una imagen de fondo (unos planetas grandes)
 
 3) y otro div con textos dentro.
 
 Si aplico un margin-top (unos 200px en este caso) al div del TEXTO, la
 imagen del fondo DEL CONTENEDOR se mueve hacia abajo esos 200px, como si
 ese div percibiera que cambió la posición del div interno, y se
 reacomodara a él!
 
 Si le pongo overflow:auto al #contenedor se soluciona, el #contenedor
 sube y muestra la foto de fondo comenzando del borde superior de la
 pantalla, pero no entiendo por qué regla específica de CSS la ubicación
 DEL CONTENEDOR cambia si cambio el margen de OTRO div interno...
 
 La URL es:
 http://www.cursodecss.com.ar/index.html
 
 Desde ya, gracias por cualquier pista...
 
 Saludos!
 
 --
 Hernán Beati
 http://www.saberweb.com.ar
 ___
 Lista de distribución Ovillo
 Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
 Puedes modificar tus datos o desuscribirte en la siguiente dirección:
 http://lists.ovillo.org/mailman/listinfo/ovillo



___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo


Re: [Ovillo] [OT] spotify

2009-10-28 Por tema Ramon Vilar Gavaldà
Alguién ha cambiado el tema de esta lista y no me ha avisado? No iba
de HTML, CSS y cosas de esas raras?



2009/10/28 Toni Lara t...@pratbarrina.com:
 Julian, solo existe versión para Windows, pero puedes instalarla en
 Linux a traves del emulador Wine. Yo lo he probado y funciona correctamente.

 Saludos,

 En/na Julian Reyes ha escrit:
 ojala alguien pudiera puesto que actualmente estoy desde linux yel tuto
 de taringa es oara windows

 ___
 Lista de distribución Ovillo
 Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
 Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
 http://lists.ovillo.org/mailman/listinfo/ovillo


 ___
 Lista de distribución Ovillo
 Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
 Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
 http://lists.ovillo.org/mailman/listinfo/ovillo




-- 
Ramon Vilar Gavaldà - http://ramonvilar.facil.cat - http://blog.facilitant.net
Membre de FÀCIL - http://www.facil.cat
Membre de l'esplai SESA - http://www.esplaisesa.org
___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo


[Ovillo] [OT] No se cargan los ficheros javascript en el browser

2009-10-28 Por tema Phaseolus
Hola Ovillo.
Primero que todo disculpen el OT, pero ya no sé donde más preguntar y quizá
a alguno de uds le haya sucedido.

Tengo una aplicacion J2EE corriendo sobre Websphere 6.1 (WAS) con
JDK1.4.2_10 y pasa una cosa super extraña; los ficheros javascript se cargan
cuando se les da la gana por lo que a veces me dan errores de javascript al
no encontrar las funciones que estoy invocando, pero el htlm está perfecto,
es completamente válido, con todos sus tags correctamente cerrados y el tag
script apunta como es debido al fichero js.

Debido a que el protocolo HTTP es asíncrono y que es el browser quien
solicita los distintos elementos al servidor en base al html no me cabe en
la cabeza el porqué se comporta de esa forma aleatoria.
Como dato en mi ambiente local nunca he replicado dicho error (lo invoco
como http://localhost:9080/MiAppWeb ), sólo se da en ambientes de Calidad y
Producción, por lo que he pensado que pudiera ser el proxy de la LAN o algún
otro factor de red, pero no acabo de descubrir la causa y el cliente ya
comienza a echarme la culpa a mi, aún cuando mis contrapartes directas saben
que no es problema de la aplicación.

Cualquier idea es gratamente recibida.
Muchas gracias y saludos.
___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo


Re: [Ovillo] [OT] No se cargan los ficheros javascript en el browser

2009-10-28 Por tema Juan Rebollo
A bote pronto se me ocurre una cosa:

te cojes el Fiddler y ves si realmente se están haciendo las peticiones a 
los js y si se reciben.
Si la respuesta es negativa me temo que hay un bug en websphere. ¿Has 
probado con otro server para aplicaciones j2ee? La versión que tienes en 
local de websphere es la misma que en producción?

- Original Message - 
From: Phaseolus phaseol...@yahoo.es
To: Ovillo, la lista de CSS en castellano ovillo@lists.ovillo.org
Sent: Wednesday, October 28, 2009 2:32 PM
Subject: [Ovillo] [OT] No se cargan los ficheros javascript en el browser


Hola Ovillo.
Primero que todo disculpen el OT, pero ya no sé donde más preguntar y quizá
a alguno de uds le haya sucedido.

Tengo una aplicacion J2EE corriendo sobre Websphere 6.1 (WAS) con
JDK1.4.2_10 y pasa una cosa super extraña; los ficheros javascript se cargan
cuando se les da la gana por lo que a veces me dan errores de javascript al
no encontrar las funciones que estoy invocando, pero el htlm está perfecto,
es completamente válido, con todos sus tags correctamente cerrados y el tag
script apunta como es debido al fichero js.

Debido a que el protocolo HTTP es asíncrono y que es el browser quien
solicita los distintos elementos al servidor en base al html no me cabe en
la cabeza el porqué se comporta de esa forma aleatoria.
Como dato en mi ambiente local nunca he replicado dicho error (lo invoco
como http://localhost:9080/MiAppWeb ), sólo se da en ambientes de Calidad y
Producción, por lo que he pensado que pudiera ser el proxy de la LAN o algún
otro factor de red, pero no acabo de descubrir la causa y el cliente ya
comienza a echarme la culpa a mi, aún cuando mis contrapartes directas saben
que no es problema de la aplicación.

Cualquier idea es gratamente recibida.
Muchas gracias y saludos.
___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo

__ Información de ESET Smart Security, versión de la base de firmas 
de virus 4551 (20091028) __

ESET Smart Security ha comprobado este mensaje.

http://www.eset.com



___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo


Re: [Ovillo] [OT] No se cargan los ficheros javascript en el browser

2009-10-28 Por tema Alejandro Salamanca
Nunca tuve un problema de carga aleatorio. O apuntaba correctamente a 
los archivos .js o no lo hacía. En el último caso, obviamente no 
funcionaba. La llamada a los archivos es un tema http en la 
interpretación del cliente y no de la aplicación del servidor (a no ser 
claro, que ésta genere una mala referencia).

El problema surge cuando existe una referencia relativa desde el html 
pero que es ejecutada desde diferentes lugares (directorios en la 
aplicación) lo que hace que en algunas ejecuciones esta referencia sea 
válida y en otras no.

Las soluciones que se me ocurren (levantando el dedo al viento) son:
- Utilizar referencias absolutas
- Realizar cargas de n archivos javascript desde dentro de otro archivo 
javascript
- Revisar las rutas por defecto (donde se asume que son localhost) y 
cambiarlas (cablearlas) a las direcciones de calidad y producción según 
correspondan. A veces existe más de una ruta por defecto (que es la 
única que se cambia).
- Si los archivos javascript son dinámicos, revisar las reglas de su 
construcción y presentación y la forma de cacheo en el cliente y en el 
servidor
- rezar?

Saludos.



Phaseolus escribió:
 Hola Ovillo.
 Primero que todo disculpen el OT, pero ya no sé donde más preguntar y quizá
 a alguno de uds le haya sucedido.

 Tengo una aplicacion J2EE corriendo sobre Websphere 6.1 (WAS) con
 JDK1.4.2_10 y pasa una cosa super extraña; los ficheros javascript se cargan
 cuando se les da la gana por lo que a veces me dan errores de javascript al
 no encontrar las funciones que estoy invocando, pero el htlm está perfecto,
 es completamente válido, con todos sus tags correctamente cerrados y el tag
 script apunta como es debido al fichero js.

 Debido a que el protocolo HTTP es asíncrono y que es el browser quien
 solicita los distintos elementos al servidor en base al html no me cabe en
 la cabeza el porqué se comporta de esa forma aleatoria.
 Como dato en mi ambiente local nunca he replicado dicho error (lo invoco
 como http://localhost:9080/MiAppWeb ), sólo se da en ambientes de Calidad y
 Producción, por lo que he pensado que pudiera ser el proxy de la LAN o algún
 otro factor de red, pero no acabo de descubrir la causa y el cliente ya
 comienza a echarme la culpa a mi, aún cuando mis contrapartes directas saben
 que no es problema de la aplicación.

 Cualquier idea es gratamente recibida.
 Muchas gracias y saludos.
 ___
 Lista de distribución Ovillo
 Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
 Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
 http://lists.ovillo.org/mailman/listinfo/ovillo
   


-- 
Alejandro Salamanca
Gerente General
DEVENET SRL
alejan...@devenet.net
Cel. 591-2-70618872


DeveNet Srl - Software para Internet
Telf. 591-2-2117985
i...@devenet.net
Av. 20 de Octubre #2473 Edif. Topáter Piso 2, Of. 204
La Paz - Bolivia
www.devenet.net
www.lexivox.org
www.lexivox.com






___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo


Re: [Ovillo] Posición de background dependiente de otro div

2009-10-28 Por tema Ignacio Ricci
Si, yo también estaba al tanto del margin collapse, pero este es un caso
particular.

2009/10/28 Hernán Beati - SaberWeb.com.ar her...@saberweb.com.ar

 Rafael García Lepper escribió:
 
  Este comportamiento es correcto, en ingles lo llaman Collapsing margins
 y
  no estoy seguro de la traducción correcta, aquí tienes el enlace en
 inglés
  [1] donde explican los motivos y los casos en los que sucede, en ie es
  diferente si tiene hasLayout [2] activado .
 
  Se soluciona estableciendo un block formatting context[3] nuevo, como
  puede ser un overflow (cualquiera distinto a visible), o un float.
 

 Muchas gracias, Rafael!

 Conocía lo de los márgenes colapsables, pero no me imaginaba que esa era
 la causa en este caso (hasta ahora, relacionaba los márgenes colapsables
 con dos elementos consecutivos en donde el primero tuviera un margen
 inferior y el segundo un margen superior, en cuyo caso quedaba solo el
 mayor de los dos márgenes).

 Muchas gracias por las referencias y la claridad de la respuesta!

 P.D.: gracias también a Ignacio y Jimmy que aportaron lo suyo.

 Un saludo,

 --
 Hernán Beati
 http://www.saberweb.com.ar

 ___
 Lista de distribución Ovillo
 Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
 Puedes modificar tus datos o desuscribirte en la siguiente dirección:
 http://lists.ovillo.org/mailman/listinfo/ovillo




-- 
↓۝ Ignacio Ricci
www.ignacioricci.com
___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo

Re: [Ovillo] Posicionar imagen dentro de texto

2009-10-28 Por tema Ignacio Ricci
No entiendo la pregunta.

2009/10/28 santosvz santo...@graficssvz.com

 Hace tiempo que guarde un ejemplo de cómo colocar una imagen dentro de un
 texto, pero no la encuentro.
 Alguien tiene disponible la información. Ejemplo
 http://img26.xooimage.com/files/7/a/2/tuck1-14ab4e2.gif

 Por cierto que mi última consulta sobre float la resolvi a pesar de que
 lamentablemente no hubo un alma caritativa que colaborara en esta
 oportunidad.
 Aunque es posible que no explicara lo suficientemente bien para captar el
 problema.
  Un cordial saludo de SantosVZ



 ___
 Lista de distribución Ovillo
 Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
 Puedes modificar tus datos o desuscribirte en la siguiente dirección:
 http://lists.ovillo.org/mailman/listinfo/ovillo




-- 
↓۝ Ignacio Ricci
www.ignacioricci.com
___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo