Re: [Ovillo] Comportamiento extraño en Internet Expl orer (al menos en la versión 7.0)

2008-06-10 Por tema Victoria
El día 10 de junio de 2008 10:12, Miguel Gonzalez [EMAIL PROTECTED] escribió:


 Hola Jorge.

 ¿Has probado a dar estilo a esa primera letra utilizando la pseudo-clase
 first-letter?:


El único problema estará en cómo tratan los distintos navegadores ese
pseudo-elemento... es muy probable que ni los IE (al menos de 7 para abajo)
ni muchos otros lo muestren.

Una pena... pero aún no podemos utilizar el 100% de la potencia de CSS por
la mala implementación de los pseudo-elementos y algunos selectores.

Un saludo

Victoria
___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo


Re: [Ovillo] Comportamiento extraño en Internet Expl orer (al menos en la versión 7.0)

2008-06-10 Por tema Miguel Gonzalez

Victoria escribió:
 El único problema estará en cómo tratan los distintos navegadores ese
 pseudo-elemento... es muy probable que ni los IE (al menos de 7 para abajo)
 ni muchos otros lo muestren.

 Una pena... pero aún no podemos utilizar el 100% de la potencia de CSS por
 la mala implementación de los pseudo-elementos y algunos selectores.

En mi opinión, creo que debemos utilizar las posibilidades que nos 
ofrece el CSS siempre que sea posible y limitarnos a comprobar si en los 
navegadores antiguos la presentación es mínimamente aceptable.

Tengo la sensación que, a veces, hipotecamos nuestra capacidad de 
trabajo intentando que todas las páginas que desarrollamos se vean 
igual en todos los navegadores; aunque algunos de ellos tengan diez 
años de antigüedad.

¡Saludos!

Miguel González


___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo


Re: [Ovillo] Comportamiento extraño en Internet Expl orer (al menos en la versión 7.0)

2008-06-10 Por tema Victoria Gracia
Almorca escribió:
 El día 10 de junio de 2008 10:30, Victoria [EMAIL PROTECTED]
 escribió:

   
 El día 10 de junio de 2008 10:12, Miguel Gonzalez [EMAIL PROTECTED]
 escribió:

 
 Hola Jorge.

 ¿Has probado a dar estilo a esa primera letra utilizando la pseudo-clase
 first-letter?:

   
 El único problema estará en cómo tratan los distintos navegadores ese
 pseudo-elemento... es muy probable que ni los IE (al menos de 7 para abajo)
 ni muchos otros lo muestren.
 

 IE desde la versión 5.5 de Windows y la 5 de MAC soporta la propiedad
 :first-letter que, por cierto, es de CSS 2.1. No lo hace correctamente (
 http://www.webdevout.net/browser-support-css#css2pseudoelements) pero para
 la mayoría de casos seguro que vale.
   
 Una pena... pero aún no podemos utilizar el 100% de la potencia de CSS por
 la mala implementación de los pseudo-elementos y algunos selectores.
 

 El 99% del diseño se puede hacer solo con css, el problema es que los
 propios diseñadores muchas veces nos limitamos sin ni siquiera investigar
 soluciones y tiramos de javascript o de hack.
   

Yo estoy de acuerdo en utilizar las propiedades avanzadas que algunos 
navegadores no utilizan, pero sin necesidad de recurrir a hacks y similares.

Respecto al soporte del pseudo-elemento :first-letter encuentro:

* En IE hasta versión 7 incluida, y FF hasta versión 2 incluida
  ignoran la propiedad letter-spacing aplicada a este elemento
* En IE hasta versión 7 incluida:
  o Las comillas se tratan como puntuación mientras el resto de
caracteres se tratan como letras.
  o Incluye los marcadores de lista
  o la propiedad float no se aplica correctamente - sólo admite
el valor left y una vez aplicado no puede sobreescribirse
utilizando none en la hoja de estilo
  o Si se aplica a un elemento posicionado con has layout,
puede no mostrarse la caja de la primera línea
  o Algunos problemas extraños pueden ocurrir (ver
http://www.satzansatz.de/cssd/pseudocss.html)
* IE hasta versión 7 e incluida, FF hasta versión 2 incluida, y
  Opera 9 no mostrarán puntuación que se encuentre inmediatamente
  después del primer carácter en este pseudo-elemento
* Opera 9.2: el espacio en blanco se contará como carácter si sólo
  lo preceden caracteres de puntuación.
* IE 6, provoca errores si no está inmediatamente seguido de espacio
  en blanco
* IE hasta versión 6 incluida puede colgarse en algunas situaciones
  en las que se presente este pseudo-elemento y enlaces.

De hecho, el único navegador que lo implementa al 100% sin errores es Safari

Un saludo
___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo


[Ovillo] Comportamiento extraño en Internet Expl orer (al menos en la versión 7.0)

2008-06-09 Por tema Jorge
Hola [EMAIL PROTECTED],

Estoy haciendo una web y resulta que el I.E 7 (no probé con otros) no se 
comporta como debiera, como si lo hace Firefox. En concreto, pasa lo 
siguiente:

- En las página: 
http://portal.grancanaria.com/portal/seccion.bsb?codcontenido=20842codmenu=726 
y 
http://portal.grancanaria.com/portal/seccion.bsb?codcontenido=20844codmenu=727

1. Hay un enlace (REBICanarias) en un párrafo y tiene puesto una imagen de 
fondo alineada a la derecha, pero en I.E 7.0 no me la muestra.

2. La primera letra del primer párrafo, que tienen alineación justificada, 
tiene un tamaño mayor, maquetada mediante una etiqueta span (no puedo usar 
la propiedad css capitalize), para destacarla. Resulta que la primera linea 
pierde la justificación en I.E, cosa que no ocurre en FireFox.

- En la página 
http://portal.grancanaria.com/portal/buscador.bsb?query=canariastipo=sencillo 
hay un formulario con un campo de texto y un combo que debieran estar 
alineados horizontalmente, pero en I.E 7, el combo tiene está un pixel por 
encima, cuando no tiene nada que justifique ese comportamiento.

¿Sabéis porqué pasa esto y si es imprescindible tener una plantilla css 
específica para IE 7 para solucionarlo?

Muchas Gracias,
Jorge


PD: Si alguien me indicase una cabecera para la página estaría eternamente 
agradecido.



___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo


Re: [Ovillo] Comportamiento extraño en Internet Expl orer (al menos en la versión 7.0)

2008-06-09 Por tema Victoria Gracia
Jorge escribió:
 - En las página: 
 http://portal.grancanaria.com/portal/seccion.bsb?codcontenido=20842codmenu=726
  y 
 http://portal.grancanaria.com/portal/seccion.bsb?codcontenido=20844codmenu=727

 1. Hay un enlace (REBICanarias) en un párrafo y tiene puesto una imagen de 
 fondo alineada a la derecha, pero en I.E 7.0 no me la muestra.
   
¿Probaste sin englobar REBICanarias en abbr?
 2. La primera letra del primer párrafo, que tienen alineación justificada, 
 tiene un tamaño mayor, maquetada mediante una etiqueta span (no puedo usar 
 la propiedad css capitalize), para destacarla. Resulta que la primera linea 
 pierde la justificación en I.E, cosa que no ocurre en FireFox.
   
Explorer tiene un comportamiento erróneo con las alineaciones a menos 
que se trate de una única caja sin cajas anidadas. En tu caso estás 
utilizando 2 cajas, la de la primera letra y la del párrafo... se lía y 
no hay (que yo sepa) solución.
 - En la página 
 http://portal.grancanaria.com/portal/buscador.bsb?query=canariastipo=sencillo
  
 hay un formulario con un campo de texto y un combo que debieran estar 
 alineados horizontalmente, pero en I.E 7, el combo tiene está un pixel por 
 encima, cuando no tiene nada que justifique ese comportamiento.
   
Yo los veo alineados ¿?
 ¿Sabéis porqué pasa esto y si es imprescindible tener una plantilla css 
 específica para IE 7 para solucionarlo?
   
Un saludo

Victoria
___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo


Re: [Ovillo] Comportamiento extraño en Internet Expl orer (al menos en la versión 7.0)

2008-06-09 Por tema Jorge
¿Probaste sin englobar REBICanarias en abbr?

Re: Sí, y sigue igual


Explorer tiene un comportamiento erróneo con las alineaciones a menos
que se trate de una única caja sin cajas anidadas. En tu caso estás
utilizando 2 cajas, la de la primera letra y la del párrafo... se lía y
no hay (que yo sepa) solución.

Re: Si nadie tiene algo que objetar, tienes razon


Yo los veo alineados ¿?

Re: Te puedo asegurar que, al menos en IE 7, el combo está un pixel por 
encima


Muchas gracias por las respuetas,

Saludos

- Mensaje original - 
De: Victoria Gracia [EMAIL PROTECTED]
Para: Ovillo, la lista de CSS en castellano ovillo@lists.ovillo.org
Enviado: lunes, 09 de junio de 2008 19:01
Asunto: Re: [Ovillo] Comportamiento extraño en Internet Explorer (al menos 
en la versión 7.0)


Jorge escribió:
 - En las página:
 http://portal.grancanaria.com/portal/seccion.bsb?codcontenido=20842codmenu=726
  y
 http://portal.grancanaria.com/portal/seccion.bsb?codcontenido=20844codmenu=727

 1. Hay un enlace (REBICanarias) en un párrafo y tiene puesto una imagen de
 fondo alineada a la derecha, pero en I.E 7.0 no me la muestra.

¿Probaste sin englobar REBICanarias en abbr?
 2. La primera letra del primer párrafo, que tienen alineación justificada,
 tiene un tamaño mayor, maquetada mediante una etiqueta span (no puedo usar
 la propiedad css capitalize), para destacarla. Resulta que la primera 
 linea
 pierde la justificación en I.E, cosa que no ocurre en FireFox.

Explorer tiene un comportamiento erróneo con las alineaciones a menos
que se trate de una única caja sin cajas anidadas. En tu caso estás
utilizando 2 cajas, la de la primera letra y la del párrafo... se lía y
no hay (que yo sepa) solución.
 - En la página
 http://portal.grancanaria.com/portal/buscador.bsb?query=canariastipo=sencillo
 hay un formulario con un campo de texto y un combo que debieran estar
 alineados horizontalmente, pero en I.E 7, el combo tiene está un pixel por
 encima, cuando no tiene nada que justifique ese comportamiento.

Yo los veo alineados ¿?
 ¿Sabéis porqué pasa esto y si es imprescindible tener una plantilla css
 específica para IE 7 para solucionarlo?

Un saludo

Victoria
___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo

___
Lista de distribución Ovillo
Para escribir a la lista, envia un correo a Ovillo@lists.ovillo.org
Puedes modificar tus datos o desuscribirte en la siguiente dirección: 
http://lists.ovillo.org/mailman/listinfo/ovillo