Re: [ovs-dev] [PATCH] datapath-windows: Remove the workaround in NAT for TCP checksum

2017-10-16 Thread Alin Serdean
Applied to branch-2.8 as well. Thanks! > -Original Message- > From: Anand Kumar [mailto:kumaran...@vmware.com] > Sent: Monday, October 16, 2017 11:22 PM > To: Alin Serdean ; Sairam Venugopal > ; d...@openvswitch.org > Subject: Re:

Re: [ovs-dev] [PATCH] ovs-atomic: Add C++ compatible implementation.

2017-10-16 Thread Yi-Hung Wei
Thanks for the patch. I can verify that it works great with C++14 support. One minor problem is that it may run into some compiler errors if the C++ compiler does not support C++14 or the support is not enabled. There was a patch that hit similar issue: https://patchwork.ozlabs.org/patch/813112/

Re: [ovs-dev] [PATCH] unixctl: Give better error message for unknown commands.

2017-10-16 Thread Aaron Conole
Ben Pfaff writes: > Signed-off-by: Ben Pfaff > --- LGTM. Acked-by: Aaron Conole ___ dev mailing list d...@openvswitch.org https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Re: [ovs-dev] [PATCH] ovs-atmoic: Fix C++ compilation issue

2017-10-16 Thread Ben Pfaff
On Mon, Oct 16, 2017 at 11:43:13AM -0700, Yi-Hung Wei wrote: > The _Atomic keyword used in stdatomic.h is not supported in g++ [1]. > This patch adds additional checks that make g++ to use the right header file. > > [1]: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=60932 > > Fixes: 9c463631e8145

Re: [ovs-dev] [PATCH] datapath-windows: Remove the workaround in NAT for TCP checksum

2017-10-16 Thread Anand Kumar
Hi Alin, Thanks for applying the patch. Yes, we need this on branch 2.8 as well. Thanks, Anand Kumar On 10/16/17, 7:33 AM, "Alin Serdean" wrote: It looks good and I managed to test it, sorry for the delay. I had some issues while disabling the

Re: [ovs-dev] [PATCH] ovn pacemaker: Provide the option to configure inactivity probe value

2017-10-16 Thread Ben Pfaff
On Mon, Oct 16, 2017 at 10:58:43AM -0700, Ben Pfaff wrote: > On Mon, Oct 16, 2017 at 02:50:48PM +0530, Numan Siddique wrote: > > On Sat, Oct 14, 2017 at 2:56 AM, Ben Pfaff wrote: > > > > > On Fri, Oct 13, 2017 at 12:06:56PM -0400, Russell Bryant wrote: > > > > On Fri, Oct 13, 2017

[ovs-dev] [PATCH] ovs-atmoic: Fix C++ compilation issue

2017-10-16 Thread Yi-Hung Wei
The _Atomic keyword used in stdatomic.h is not supported in g++ [1]. This patch adds additional checks that make g++ to use the right header file. [1]: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=60932 Fixes: 9c463631e8145 ("ovs-atomic: Report error for contradictory configuration.")

Re: [ovs-dev] [PATCH] ovn pacemaker: Provide the option to configure inactivity probe value

2017-10-16 Thread Ben Pfaff
On Mon, Oct 16, 2017 at 02:50:48PM +0530, Numan Siddique wrote: > On Sat, Oct 14, 2017 at 2:56 AM, Ben Pfaff wrote: > > > On Fri, Oct 13, 2017 at 12:06:56PM -0400, Russell Bryant wrote: > > > On Fri, Oct 13, 2017 at 8:30 AM, Numan Siddique > > wrote: > > > >

Re: [ovs-dev] TOS for BFD packets

2017-10-16 Thread Ben Pfaff
On Mon, Oct 16, 2017 at 04:32:45PM +, Venkatesan Pradeep wrote: > BFD packets are being sent with tos = IPTOS_LOWDELAY | > IPTOS_THROUGHPUT which would put them in the best-effort class. It > would be better if we send with tos = IPTOS_PREC_INTERNETCONTROL so > that they can be appropriately

[ovs-dev] TOS for BFD packets

2017-10-16 Thread Venkatesan Pradeep
Hi, BFD packets are being sent with tos = IPTOS_LOWDELAY | IPTOS_THROUGHPUT which would put them in the best-effort class. It would be better if we send with tos = IPTOS_PREC_INTERNETCONTROL so that they can be appropriately prioritized in the network. Comments? Thanks, Pradeep

[ovs-dev] [PATCH v3 2/2] netdev-dpdk: Enable optional dequeue zero copy for vHost User

2017-10-16 Thread Ciara Loftus
Enabled per port like so: ovs-vsctl set Interface dpdkvhostuserclient0 options:dq-zero-copy=true The feature is disabled by default and can only be enabled/disabled when a vHost port is down. When packets from a vHost device with zero copy enabled are destined for a 'dpdk' port, the number of tx

[ovs-dev] [PATCH v3 0/2] vHost Dequeue Zero Copy

2017-10-16 Thread Ciara Loftus
This patch enables optional dequeue zero copy for vHost ports. This gives a performance increase for some use cases. I'm using the cover letter to report my results. vhost (vm1) -> vhost (vm2) Using testpmd to source (txonly) in vm1 and sink (rxonly) in vm2. 4C1Q 64B packets: 5.05Mpps -> 5.52Mpps

[ovs-dev] [PATCH v3 1/2] netdev-dpdk: Helper function for vHost device setup

2017-10-16 Thread Ciara Loftus
dpdkvhostuser and dpdkvhostuserclient ports share a lot of the same setup & configuration code. Create a common function they can share in order to remove some duplication of code. Signed-off-by: Ciara Loftus --- lib/netdev-dpdk.c | 113

Re: [ovs-dev] [PATCH] datapath-windows: Remove the workaround in NAT for TCP checksum

2017-10-16 Thread Alin Serdean
It looks good and I managed to test it, sorry for the delay. I had some issues while disabling the offloads on the hw adapter on Windows but that turned out to be a different issue. I applied it on master, but I would like to apply it on branch-2.8 as well. What do you think? Thanks, Alin. >

[ovs-dev] [PATCH 2/2] acinclude: Fix SKB_GSO_UDP check.

2017-10-16 Thread William Tu
The HAVE_SKB_GSO_UDP checks whether skbuff.h defines SKB_GSO_UDP. However, it falsely returns yes because it finds SKB_GSO_UDP_TUNNEL. Thus, add exact match "-w" option for the grep command. Fixes: ad283644f0e4 ("acinclude: Check for SKB_GSO_UDP") Signed-off-by: William Tu

[ovs-dev] [PATCH 1/2] acinclude: Add support for grep option.

2017-10-16 Thread William Tu
Allow to pass grep's option to OVS_GREP_IFELSE. One use case is to pass '-w' for exact match. Signed-off-by: William Tu --- acinclude.m4 | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/acinclude.m4 b/acinclude.m4 index

Re: [ovs-dev] [PATCH] datapath-windows: Remove the workaround in NAT for TCP checksum

2017-10-16 Thread aserdean
Thanks so much for the patch! Sorry for the long delay in testing. Acked-by: Alin Gabriel Serdean > -Original Message- > From: ovs-dev-boun...@openvswitch.org [mailto:ovs-dev- > boun...@openvswitch.org] On Behalf Of Anand Kumar > Sent: Saturday, September 16, 2017

Re: [ovs-dev] [PATCH v2] dpctl: manage ret value when dumping CT entries.

2017-10-16 Thread Fischetti, Antonio
Any comment on v2? Thanks, Antonio > -Original Message- > From: Fischetti, Antonio > Sent: Tuesday, September 26, 2017 10:45 AM > To: Fischetti, Antonio ; d...@openvswitch.org > Subject: RE: [ovs-dev] [PATCH v2] dpctl: manage ret value when dumping CT >

[ovs-dev] [PATCH net-next v12] openvswitch: enable NSH support

2017-10-16 Thread Yi Yang
v11->v12 - Fix missing changes old comments pointed out - Fix new comments for v11 v10->v11 - Fix the left three disputable comments for v9 but not fixed in v10. v9->v10 - Change struct ovs_key_nsh to struct ovs_nsh_key_base base; __be32 context[NSH_MD1_CONTEXT_SIZE]; - Fix

[ovs-dev] Bug#878757: Openvswitch must started before networking servise

2017-10-16 Thread Fedor Goncharov
Package: openvswitch-switch Version: 2.6.2~pre+git20161223-3 Priority: critical The Openvswitch daemon must be started before the network.service. Because when the initiation of the network started interfaces from the options should exist, or if you try to configure openvswitch in

[ovs-dev] [PATCH v6 5/5] netdev-dpdk: Rename dpdk_mp_put as dpdk_mp_free.

2017-10-16 Thread antonio . fischetti
For readability purposes dpdk_mp_put is renamed as dpdk_mp_free. Some other comments are also added to mempool functions. CC: Mark B Kavanagh CC: Darrell Ball CC: Ciara Loftus CC: Kevin Traynor CC: Aaron

[ovs-dev] [PATCH v6 4/5] netdev-dpdk: Reword mp_size as n_mbufs.

2017-10-16 Thread antonio . fischetti
For code readability purposes mp_size is renamed as n_mbufs in dpdk_mp structure. This parameter is passed to rte mempool creation functions and is meant to contain the number of elements inside the requested mempool. CC: Mark B Kavanagh CC: Ciara Loftus

[ovs-dev] [PATCH v6 3/5] netdev-dpdk: manage empty mempool names.

2017-10-16 Thread antonio . fischetti
In case a mempool name could not be generated log a message and return a null mempool pointer to the caller. CC: Mark B Kavanagh CC: Darrell Ball CC: Ciara Loftus CC: Kevin Traynor CC: Aaron Conole

[ovs-dev] [PATCH v6 0/5] netdev-dpdk: Fix mempool management and other cleanup.

2017-10-16 Thread antonio . fischetti
Patch #1 contains the fix. All other patches in this series are a clean up for code readability or small improvements. List of versions: - v6: patches #1 and #2 squashed into one. - Reworked to consider the latest comments. - tested the release of pre-existing mempools (reported

[ovs-dev] [PATCH v6 2/5] netdev-dpdk: skip init for existing mempools.

2017-10-16 Thread antonio . fischetti
Skip initialization of mempool packet areas if this was already done in a previous call to dpdk_mp_create. CC: Mark B Kavanagh CC: Darrell Ball CC: Ciara Loftus CC: Kevin Traynor CC: Aaron Conole

[ovs-dev] [PATCH v6 1/5] netdev-dpdk: fix management of pre-existing mempools.

2017-10-16 Thread antonio . fischetti
Fix issues on reconfiguration of pre-existing mempools. This patch avoids to call dpdk_mp_put() - and erroneously release the mempool - when it already exists. Create mempool names by considering also the NUMA socket number. So a name reflects what socket the mempool is allocated on. This change

Re: [ovs-dev] [PATCH RFC] netdev-dpdk: Allow specification of index for PCI devices

2017-10-16 Thread Loftus, Ciara
> > Hi Ciara, thanks for working on this patch. A few comments inline. Thanks for your review Ian. > > > Some NICs have only one PCI address associated with multiple ports. This > > patch extends the dpdk-devargs option's format to cater for such devices. > > Whereas before only one of N ports

Re: [ovs-dev] [PATCH v2 2/2] netdev-dpdk: Enable optional dequeue zero copy for vHost User

2017-10-16 Thread Loftus, Ciara
> > Thanks for the v2 Ciara. Comments inline. Thanks for your review Ian. Hope to send a v3 soon. Responses inline. Thanks, Ciara > > > > Enabled per port like so: > > ovs-vsctl set Interface dpdkvhostuserclient0 options:dq-zero-copy=true > > > > The feature is disabled by default and can

[ovs-dev] [PATCH v2] ovn pacemaker: Provide the option to configure inactivity probe value

2017-10-16 Thread nusiddiq
From: Numan Siddique In the case of OVN HA deployments with openstack, it has been noticed that the 5 seconds inactivity probe interval is not enough and ovsdb-servers do not get the echo reply back from the IDL clients and disconnects the connections. This patch -

Re: [ovs-dev] [PATCH] ovn pacemaker: Provide the option to configure inactivity probe value

2017-10-16 Thread Numan Siddique
On Sat, Oct 14, 2017 at 2:56 AM, Ben Pfaff wrote: > On Fri, Oct 13, 2017 at 12:06:56PM -0400, Russell Bryant wrote: > > On Fri, Oct 13, 2017 at 8:30 AM, Numan Siddique > wrote: > > > On Fri, Oct 13, 2017 at 6:05 AM, Andy Zhou wrote: > > > > >

Re: [ovs-dev] [PATCH] ovn pacemaker: Provide the option to configure inactivity probe value

2017-10-16 Thread Numan Siddique
On Fri, Oct 13, 2017 at 9:36 PM, Russell Bryant wrote: > On Fri, Oct 13, 2017 at 8:30 AM, Numan Siddique > wrote: > > On Fri, Oct 13, 2017 at 6:05 AM, Andy Zhou wrote: > > > >> Hi, Numan, > >> > >> I am curious why default 5 seconds

Re: [ovs-dev] [PATCH] ovn pacemaker: Provide the option to configure inactivity probe value

2017-10-16 Thread Numan Siddique
On Sat, Oct 14, 2017 at 2:56 AM, Ben Pfaff wrote: > On Fri, Oct 13, 2017 at 12:06:56PM -0400, Russell Bryant wrote: > > On Fri, Oct 13, 2017 at 8:30 AM, Numan Siddique > wrote: > > > On Fri, Oct 13, 2017 at 6:05 AM, Andy Zhou wrote: > > > > >