Re: [ovs-dev] [PATCH v5] Avoid dp_hash recirculation for balance-tcp bond selection mode

2019-08-09 Thread Matteo Croce
On Thu, Aug 8, 2019 at 10:57 AM Vishal Deep Ajmera wrote: > --- a/ofproto/bond.c > +++ b/ofproto/bond.c > @@ -1939,3 +1959,9 @@ bond_get_changed_active_slave(const char *name, struct > eth_addr *mac, > > return false; > } > + > +bool > +bond_get_cache_mode(const struct bond *bond) > +{ > +

Re: [ovs-dev] [PATCH v2 5/9] ofproto-dpif: Consume CT_Zone, and CT_Timeout_Policy tables

2019-08-09 Thread Justin Pettit
> On Aug 7, 2019, at 11:40 AM, Darrell Ball wrote: > > There are 3 behaviors with the patchset that are datapath specific > > 1/ Unwildcarding of commit flows with timeout policies > As we discussed, the userspace conntrack does not need to do this and > would not since it is suboptimal

Re: [ovs-dev] [PATCH ovn v2] ovn-northd: Add IGMP Relay support

2019-08-09 Thread Mark Michelson
Acked-by: Mark Michelson It looks good to me. I do have one question down below. On 8/9/19 5:54 AM, Dumitru Ceara wrote: Add a new configuration option 'mcast_relay' to the Logical_Router:options in the OVN Northbound database. If a router is configured with 'mcast_relay' enabled then

Re: [ovs-dev] [PATCH v2 8/9] ofproto-dpif-xlate: Translate timeout policy in ct action

2019-08-09 Thread Justin Pettit
> On Aug 1, 2019, at 3:07 PM, Yi-Hung Wei wrote: > > diff --git a/lib/dpif-provider.h b/lib/dpif-provider.h > index 79a2314500cf..57b32ccb610f 100644 > --- a/lib/dpif-provider.h > +++ b/lib/dpif-provider.h > @@ -536,6 +536,11 @@ struct dpif_class { >

Re: [ovs-dev] [PATCH ovn] ovn-northd: Clarify lsp's 'enabled' and 'up' column handling.

2019-08-09 Thread Justin Pettit
> On Aug 9, 2019, at 11:16 AM, Numan Siddique wrote: > >> On Fri, Aug 9, 2019 at 11:33 PM Justin Pettit wrote: >> Signed-off-by: Justin Pettit > > Thanks. This looks good to me. > > Acked-by: Numan Siddique Thanks. I pushed this to OVN master and OVS branch-2.12. --Justin

Re: [ovs-dev] [PATCH ovn] Add support for using OVN specific rundirs

2019-08-09 Thread 0-day Robot
Bleep bloop. Greetings Numan Siddique, I am a robot and I have tried out your patch. Thanks for your contribution. I encountered some error that I wasn't expecting. See the details below. checkpatch: WARNING: Line is 99 characters long (recommended limit is 79) #549 FILE:

Re: [ovs-dev] [PATCH v3] ovn-openstack.rst: Miscelaneous fixes.

2019-08-09 Thread Numan Siddique
On Thu, Aug 8, 2019 at 8:32 AM 0-day Robot wrote: > Bleep bloop. Greetings Flavio Fernandes, I am a robot and I have tried > out your patch. > Thanks for your contribution. > > I encountered some error that I wasn't expecting. See the details below. > > > checkpatch: > WARNING: Line is 99

[ovs-dev] [PATCH ovn] Add support for using OVN specific rundirs

2019-08-09 Thread nusiddiq
From: Numan Siddique Until now, OVN uses the openvswitch rundirs (rundir, logdir, etcdir). The commit [1] changed the package name from openvswitch to ovn, but it didn't take into the account the effects of it. When "make install" is run ovn-ctl utility is copied to /usr/local/share/ovn/scripts

Re: [ovs-dev] [PATCH ovn] ovn-northd: Clarify lsp's 'enabled' and 'up' column handling.

2019-08-09 Thread Numan Siddique
On Fri, Aug 9, 2019 at 11:33 PM Justin Pettit wrote: > Signed-off-by: Justin Pettit > Thanks. This looks good to me. Acked-by: Numan Siddique > --- > northd/ovn-northd.c | 8 ++-- > ovn-nb.xml | 1 + > 2 files changed, 7 insertions(+), 2 deletions(-) > > diff --git

Re: [ovs-dev] [PATCH] ovn-northd: Fix ARP respond flows flapping.

2019-08-09 Thread Justin Pettit
> On Aug 1, 2019, at 11:08 AM, Han Zhou wrote: > > > diff --git a/ovn/northd/ovn-northd.c b/ovn/northd/ovn-northd.c > > index eb6c47c..212aa88 100644 > > --- a/ovn/northd/ovn-northd.c > > +++ b/ovn/northd/ovn-northd.c > > @@ -3495,7 +3495,7 @@ lsp_is_enabled(const struct

[ovs-dev] [PATCH ovn] ovn-northd: Clarify lsp's 'enabled' and 'up' column handling.

2019-08-09 Thread Justin Pettit
Signed-off-by: Justin Pettit --- northd/ovn-northd.c | 8 ++-- ovn-nb.xml | 1 + 2 files changed, 7 insertions(+), 2 deletions(-) diff --git a/northd/ovn-northd.c b/northd/ovn-northd.c index e6953a405..e86134414 100644 --- a/northd/ovn-northd.c +++ b/northd/ovn-northd.c @@ -3488,16

Re: [ovs-dev] [PATCH 1/2] OVN: add meter support to trigger_event action

2019-08-09 Thread Lorenzo Bianconi
> > I noticed this patch introduced a memory leak since event->meter is > never freed. > > However, I can understand how this happened because currently everything > in ovnact_controller_event is being leaked. > ovnact_controller_event_free() should be calling free_gen_options(), but > it's not.

Re: [ovs-dev] [PATCH 1/1] Fixed memory leak in ovn-controller while handling port binding changes.

2019-08-09 Thread Justin Pettit
> On Aug 6, 2019, at 3:20 AM, Numan Siddique wrote: > > On Tue, Jul 23, 2019 at 4:47 PM Dumitru Ceara wrote: > >> On Tue, Jul 23, 2019 at 12:33 PM Damijan Skvarc >> wrote: >>> >>> Signed-off-by: Damijan Skvarc >> >> Looks good to me. Thanks! >> Acked-by: Dumitru Ceara >> > > Thank for

Re: [ovs-dev] [ovs-discuss] why action "meter" only can be specified once?

2019-08-09 Thread William Tu
On Mon, Aug 5, 2019 at 12:39 AM Yi Yang (杨燚)-云服务集团 wrote: > > Hi, all > > > > I was told meter only can be specified once, but actually there is such case > existing, i.e. multiple flows share a total bandwidth, but every flow also > has its own bandwidth limit, by two meters, we can not only

Re: [ovs-dev] [PATCH 2/2] OVN: northd: add rate limiting support for SB controller events

2019-08-09 Thread Mark Michelson
Acked-by: Mark Michelson On 8/1/19 5:56 AM, Lorenzo Bianconi wrote: Introduce the capability to associate a meter to each controller event type in order to not overload the pinctrl thread under heavy load. Each event type relies on a meter with a defined name: - empty_lb_backends: event-elb

Re: [ovs-dev] [PATCH 1/2] OVN: add meter support to trigger_event action

2019-08-09 Thread Mark Michelson
I noticed this patch introduced a memory leak since event->meter is never freed. However, I can understand how this happened because currently everything in ovnact_controller_event is being leaked. ovnact_controller_event_free() should be calling free_gen_options(), but it's not. And with

Re: [ovs-dev] [PATCH v3] vswitchd: Make packet-in controller queue size configurable

2019-08-09 Thread Mark Michelson
Acked-by: Mark Michelson On 8/2/19 4:29 AM, Dumitru Ceara wrote: The ofconn packet-in queue for packets that can't be immediately sent on the rconn connection was limited to 100 packets (hardcoded value). While increasing this limit is usually not recommended as it might create buffer bloat

Re: [ovs-dev] [PATCH] OVN: add missing checkpatch.py script

2019-08-09 Thread Mark Michelson
Oops, was going through the backlog and didn't see there was a V2 with commentary on it. On 8/9/19 11:05 AM, Mark Michelson wrote: Acked-by: Mark Michelson On 8/1/19 7:18 AM, Lorenzo Bianconi wrote: Signed-off-by: Lorenzo Bianconi ---   utilities/checkpatch.py | 1006

Re: [ovs-dev] [PATCH] OVN: add missing checkpatch.py script

2019-08-09 Thread Mark Michelson
Acked-by: Mark Michelson On 8/1/19 7:18 AM, Lorenzo Bianconi wrote: Signed-off-by: Lorenzo Bianconi --- utilities/checkpatch.py | 1006 +++ 1 file changed, 1006 insertions(+) create mode 100755 utilities/checkpatch.py diff --git

Re: [ovs-dev] [PATCH] checkpatch: Fix regexp for if, while, etc inside macros.

2019-08-09 Thread Aaron Conole
Ilya Maximets writes: > This allows to use a one-character expression inside the 'if' > statement and multiple spaces before the line continuation character. > > Fixes false positive in case like this: > > #define MACRO(ARG) \ > if (a) { \ > do_work(ARG); \ >

Re: [ovs-dev] Compiling ovs with dpdk on freebsd

2019-08-09 Thread Aaron Conole
Jeremy Plsek writes: > Hi Aaron, > > I'm trying to compile ovs (dpdk-latest) with dpdk on freebsd 11.2. > When I try to compile with it, it gives the error: > ../lib/netdev-dpdk.c:25:10: fatal error: linux/virtio_net.h: No such > file or directory > I'm guessing I'm missing a compile time option

Re: [ovs-dev] [PATCH branch-2.5] travis: Drop 2.6.32 kernel build.

2019-08-09 Thread Simon Horman
On Tue, Aug 06, 2019 at 04:06:02PM +0300, Ilya Maximets wrote: > gcc >= 5 can't build Linux kernel 2.6.32 and this will never > change because 2.6.32 is not supported for a last few years. > > TravsCI migrated to use Ubuntu Xenial by defualt with gcc 5 > installed. Dropping the 2.6.32 build item

Re: [ovs-dev] [PATCH 1/2] netdev-dpdk: Fix not reporting rx_oversize_errors in stats.

2019-08-09 Thread 0-day Robot
Bleep bloop. Greetings Ilya Maximets, I am a robot and I have tried out your patch. Thanks for your contribution. I encountered some error that I wasn't expecting. See the details below. checkpatch: ERROR: Inappropriate bracing around statement #131 FILE: lib/netdev-dpdk.c:2684: if

[ovs-dev] [PATCH 2/2] netdev-dpdk: Refactor vhost custom stats for extensibility.

2019-08-09 Thread Ilya Maximets
vHost interfaces currently has only one custom statistic, but there might be others in the near future. This refactoring makes the code work in the same way as it done for dpdk and afxdp stats to keep the common style over the different code places and makes it easily extensible for the new stats

[ovs-dev] [PATCH 1/2] netdev-dpdk: Fix not reporting rx_oversize_errors in stats.

2019-08-09 Thread Ilya Maximets
There is a big code duplication issue with DPDK xstats that led to missed "rx_oversize_errors" statistics. It's defined but not used. Fix that by actually using this stat along with code refactoring that will allow us to not make same mistakes in the future. Macro definitions are perfectly

[ovs-dev] [PATCH 0/2] netdev-dpdk: Stats fix and refactoring.

2019-08-09 Thread Ilya Maximets
Ilya Maximets (2): netdev-dpdk: Fix not reporting rx_oversize_errors in stats. netdev-dpdk: Refactor vhost custom stats for extensibility. lib/netdev-dpdk.c | 135 +++--- 1 file changed, 54 insertions(+), 81 deletions(-) -- 2.17.1

[ovs-dev] [PATCH] checkpatch: Fix regexp for if, while, etc inside macros.

2019-08-09 Thread Ilya Maximets
This allows to use a one-character expression inside the 'if' statement and multiple spaces before the line continuation character. Fixes false positive in case like this: #define MACRO(ARG) \ if (a) { \ do_work(ARG); \ } Fixes: 16770c6d9179 ("checkpatch:

Re: [ovs-dev] Travis build failures due to base image change to Xenial.

2019-08-09 Thread Ilya Maximets
On 01.08.2019 20:48, Aaron Conole wrote: > Ilya Maximets writes: > >> Hi, everyone. >> >> I'm trying to fix TravisCI build failures on older branches. Recently they >> started to change default images from Trusty to Xenial. Not all the >> repositories >> affected so far, but main openvswitch

Re: [ovs-dev] [PATCH v2 ovn] logical-fields: fix memory leak while initializing ovnfield_by_name

2019-08-09 Thread Ilya Maximets
On 09.08.2019 10:11, Damijan Skvarc wrote: > According to comments I have: > - renamed function name to be "paired" with ovn_destroy_ovnfields > - replaced 0/1 bool values with false/true > > Signed-off-by: Damijan Skvarc This patch named "fix memory leak ...", but I don't see any leaks fixed

[ovs-dev] [PATCH ovn v2] ovn-northd: Add IGMP Relay support

2019-08-09 Thread Dumitru Ceara
Add a new configuration option 'mcast_relay' to the Logical_Router:options in the OVN Northbound database. If a router is configured with 'mcast_relay' enabled then ovn-northd will install Logical_Flows to allow IP multicast traffic to be routed between Logical_Switches. The logical router will

Re: [ovs-dev] [PATCH v2 ovn] logical-fields: fix memory leak while initializing ovnfield_by_name

2019-08-09 Thread Ilya Maximets
On 09.08.2019 10:11, Damijan Skvarc wrote: > According to comments I have: > - renamed function name to be "paired" with ovn_destroy_ovnfields > - replaced 0/1 bool values with false/true > > Signed-off-by: Damijan Skvarc > --- > lib/logical-fields.c | 10 +- > 1 file changed, 5

Re: [ovs-dev] [PATCH v2 ovn] logical-fields: fix memory leak while initializing ovnfield_by_name

2019-08-09 Thread 0-day Robot
Bleep bloop. Greetings Damijan Skvarc, I am a robot and I have tried out your patch. Thanks for your contribution. I encountered some error that I wasn't expecting. See the details below. git-am: fatal: sha1 information is lacking or useless (lib/logical-fields.c). Repository lacks necessary

[ovs-dev] [PATCH v2 ovn] logical-fields: fix memory leak while initializing ovnfield_by_name

2019-08-09 Thread Damijan Skvarc
According to comments I have: - renamed function name to be "paired" with ovn_destroy_ovnfields - replaced 0/1 bool values with false/true Signed-off-by: Damijan Skvarc --- lib/logical-fields.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/lib/logical-fields.c