Re: [ovs-dev] [PATCH 12/25] netdev-offload-dpdk: Introduce map APIs for table id and miss context

2020-07-12 Thread Eli Britstein
On 7/11/2020 9:44 PM, William Tu wrote: On Mon, Jan 20, 2020 at 7:09 AM Eli Britstein wrote: Different vports are differentiated in HW by different tables, as in the SW model. As such we need to map to table ids. Also, as this offload involves multiple tables, a miss might occur in the

Re: [ovs-dev] [PATCH 14/25] netdev-offload-dpdk: Implement HW miss packet recover for vport

2020-07-12 Thread Eli Britstein
On 7/11/2020 9:36 PM, William Tu wrote: Hi Eli, Thanks for the patch, very interesting work. I'm trying to understand the patch. some questions below: On Mon, Jan 20, 2020 at 7:09 AM Eli Britstein wrote: A miss in virtual port offloads means the flow with tnl_pop was offloaded, but not the

Re: [ovs-dev] [PATCH 12/25] netdev-offload-dpdk: Introduce map APIs for table id and miss context

2020-07-12 Thread William Tu
On Sat, Jul 11, 2020 at 11:22 PM Eli Britstein wrote: > > > On 7/11/2020 9:44 PM, William Tu wrote: > > On Mon, Jan 20, 2020 at 7:09 AM Eli Britstein wrote: > >> Different vports are differentiated in HW by different tables, as in the > >> SW model. As such we need to map to table ids. Also, as

Re: [ovs-dev] We've messaged you a few days ago but...

2020-07-12 Thread A O L FOUNDATION via dev
Dear Lucky Donee, We've messaged you a few days ago but received no response from you.Your email address won a cash prize in the AOL Foundation email donation program. Below is your donation prize details; Batch Number: 932867447UKReference Number: 0144854866Serial Number:

[ovs-dev] [PATCH v6 1/8] dpif-netdev: Refactor dp_netdev_flow_offload_put()

2020-07-12 Thread Sriharsha Basavapatna via dev
This patch refactors dp_netdev_flow_offload_put() to prepare for changes to support partial action offload, in subsequent patches. - Move mark allocation code into a separate wrapper function, outside of dp_netdev_flow_offload_put() to improve readability and to facilitate more changes in

[ovs-dev] [PATCH v6 8/8] dpctl: update flow-dump output to reflect partial action offload

2020-07-12 Thread Sriharsha Basavapatna via dev
To identify flows that have actions partially offloaded, the dp and offloaded fields in the output of dpctl/flow-dump, are updated with the values: "dp:ovs,dpdk" and "offloaded:partial-action". Signed-off-by: Sriharsha Basavapatna --- lib/dpctl.c | 5 -

[ovs-dev] [PATCH v6 7/8] dpif-netdev: Support partial offload of POP_VLAN action

2020-07-12 Thread Sriharsha Basavapatna via dev
If the output-port is a vhost-user port and the action is POP_VLAN, offload the action on the ingress device if it is offload capable. Note: - With ingress partial action offload, the flow must be added to the mark-to-flow table. Otherwise, since the action (e.g, POP_VLAN) is already

[ovs-dev] [PATCH v6 0/8] netdev datapath: Partial action offload

2020-07-12 Thread Sriharsha Basavapatna via dev
Hi, This patchset extends the "Partial HW acceleration" mode to offload a part of the action processing to HW, instead of offloading just lookup (MARK/RSS), for "vhost-user" ports. This is referred to as "Partial Action Offload". This mode does not require SRIOV/switchdev configuration. In this

Re: [ovs-dev] [PATCH v6 5/8] dpif-netdev: Support partial-action-offload of VXLAN encap flow

2020-07-12 Thread 0-day Robot
Bleep bloop. Greetings Sriharsha Basavapatna, I am a robot and I have tried out your patch. Thanks for your contribution. I encountered some error that I wasn't expecting. See the details below. build: ^ lib/dpif-netdev.c:2670:37: note: in expansion of macro 'UUID_ARGS'

Re: [ovs-dev] [PATCH v5 0/7] netdev datapath: Partial action offload

2020-07-12 Thread Sriharsha Basavapatna via dev
Hi Ilya, Thanks for your comments, please see my response inline. On Fri, Jul 10, 2020 at 5:41 PM Ilya Maximets wrote: > > On 7/9/20 8:47 AM, Sriharsha Basavapatna via dev wrote: > > Hi, > > > > This patchset extends the "Partial HW acceleration" mode to offload a > > part of the action

[ovs-dev] [PATCH v6 2/8] netdev-dpdk: provide a function to identify dpdk-vhost netdevs

2020-07-12 Thread Sriharsha Basavapatna via dev
This patch adds a function to determine if a given netdev belongs to the dpdk-vhost class, using the netdev_class specific data. Reviewed-by: Hemal Shah Signed-off-by: Sriharsha Basavapatna --- lib/netdev-dpdk.c | 5 + lib/netdev-dpdk.h | 1 + 2 files changed, 6 insertions(+) diff --git

[ovs-dev] [PATCH v6 3/8] dpif-netdev: Skip encap action during datapath execution

2020-07-12 Thread Sriharsha Basavapatna via dev
In this patch we check if action processing (apart from OUTPUT action), should be skipped for a given dp_netdev_flow. Specifically, we check if the action is TNL_PUSH and if it has been offloaded to HW, then we do not push the tunnel header in SW. The datapath only executes the OUTPUT action. The

[ovs-dev] [PATCH v6 6/8] dpif-netdev: Support partial offload of PUSH_VLAN action

2020-07-12 Thread Sriharsha Basavapatna via dev
If the input-port is a vhost-user port and the action is PUSH_VLAN, offload the action on the egress device if it is offload capable. Signed-off-by: Sriharsha Basavapatna --- lib/dpif-netdev.c | 32 ++-- lib/dpif.c| 2 +-

[ovs-dev] [PATCH v6 4/8] dpif-netdev: Support flow_get() with partial-action-offload

2020-07-12 Thread Sriharsha Basavapatna via dev
For flows that offload partial actions in egress direction, provide the right netdev to fetch statistics. Reviewed-by: Hemal Shah Signed-off-by: Sriharsha Basavapatna --- lib/dpif-netdev.c | 10 -- 1 file changed, 8 insertions(+), 2 deletions(-) diff --git a/lib/dpif-netdev.c

[ovs-dev] [PATCH v6 5/8] dpif-netdev: Support partial-action-offload of VXLAN encap flow

2020-07-12 Thread Sriharsha Basavapatna via dev
In this patch, we support offloading of VXLAN_ENCAP action for a vhost-user port (aka "partial-action-offload"). At the time of offloading the flow, we determine if the flow can be offloaded to an egress device, if the input port is not offload capable such as a vhost-user port. We then offload

[ovs-dev] 答复: [PATCH v2 1/5] Fix dp_packet_set_size error for multi-seg mbuf

2020-07-12 Thread 杨燚
Flavio, thank you so much for reviewing, I'll fix them per your comments in next version. Some replies per your comments inline. -邮件原件- 发件人: dev [mailto:ovs-dev-boun...@openvswitch.org] 代表 Flavio Leitner 发送时间: 2020年7月11日 3:42 收件人: yang_y...@163.com 抄送: ovs-dev@openvswitch.org 主题: Re:

[ovs-dev] 答复: [PATCH v2 2/5] Enable VXLAN TSO for DPDK datapath

2020-07-12 Thread 杨燚
Flavio, thank you so much for reviewing again, I'll fix them in next version, detailed replies inline. Sorry for bad outlook email format, I only can use outlook. -邮件原件- 发件人: dev [mailto:ovs-dev-boun...@openvswitch.org] 代表 Flavio Leitner 发送时间: 2020年7月11日 4:51 收件人: yang_y...@163.com 抄送:

Re: [ovs-dev] [PATCH ovn v2] Fix the routing for external logical ports of bridged logical switches.

2020-07-12 Thread Ankur Sharma
Hi Numan, Thank you so much for the details. Following is my analysis on the feature: a. Port of type EXTERNAL means that we create a logical switch port in OVN without a VIF backing. b. i.e the physical port corresponding to external port is NOT behind OVN managed vswitch (for SRIOV specific