RE: Really auto autoloaded modules

2001-02-04 Thread Hildo . Biersma
"Dave" == Dave Storrs [EMAIL PROTECTED] writes: Dave When you want to install a new version, you simply prepend it Dave with its version number (or insert it at appropriate place). Dave The order is, of course, irrelevant...you can order it as 1.3, Dave 2.0, 1.0 if you want, but then 1.3

Re: RFC 328 (v1) Single quotes don't interpolate \' and \\

2000-09-30 Thread Hildo Biersma
Nicholas Clark wrote: What do you mean by "need"? Strings need to be able to contain single quotes, but single quotes are not the only way to build a string. Single and double quotes don't generate a different fundamental type; a double quoted string with no variable interpolation also

Re: RFC 288 (v1) First-Class CGI Support

2000-09-25 Thread Hildo Biersma
Perl6 RFC Librarian wrote: =head1 ABSTRACT Perl is frequently used in CGI environments. It should be as easy to write CGI programs with perl as it is to write commandline text filters. =head1 DESCRIPTION Tom Christiansen proposed this in his perl6storm message: =item

Re: RFC 223 (v1) Objects: Cuse invocant pragma

2000-09-16 Thread Hildo Biersma
John Porter wrote: Hildo Biersma wrote: I think such modules are a bad idea, because their functionality is typically restricted. Oh? Where do you get that idea? Think about it. If a module supports both an OO and a procedural interface, the procedural interface either requires

Re: RFC 241 (v1) Pseudo-hashes must die!

2000-09-16 Thread Hildo Biersma
=head1 ABSTRACT Pseudo-hashes and the associated fields pragma shoule be removed from Perl 6. A few counter points: Removal of pseudo-hashes should not stop us from using this (or a similar mechanism) under the covers in perl6 to implement strongly typed objects. AFAIK, most of the pain

Re: RFC 223 (v1) Objects: Cuse invocant pragma

2000-09-15 Thread Hildo Biersma
Nathan Wiger wrote: and this may, indeed, be sufficient. Remember, this still won't solve the problem of a module whose functions can handle both OO and function-oriented calls - and yes, I have many that do this. :-) I think such modules are a bad idea, because their functionality is

Re: Draft RFC: my Dog $spot is just an assertion

2000-09-13 Thread Hildo Biersma
Piers Cawley wrote: =head1 ABSTRACT The behaviour of the my Dog $spot syntax should simply be an assertion of the invariant: (!defined($spot) || (ref($spot) $spot-isa('Dog))) Apart from the buglet that Damian pointed out, agree. Instead of an implementation based on tie, I'd rather

Re: Draft RFC: new pragma: Cuse namespace

2000-09-13 Thread Hildo Biersma
Piers Cawley wrote: =head1 ABSTRACT Cmy Big::Long::Prefix::Class $object = Big::Long::Prefix::Class-Egtnew is a pain in the bum to type. We should replace this with use namespace 'Big::Long::Prefix'; my ::Class $object = ::Class-new; This is a bit dangerous, since we can get

Re: Draft RFC: new pragma: Cuse namespace

2000-09-13 Thread Hildo Biersma
Piers Cawley wrote: This is a bit dangerous, since we can get into ambiguities again. If I have A::B::C::Foo, A::B::C::Bar, X::Y::Z::Foo and X::Y::Z::Bar, I'd like to use shorthands for A::B::C's Foo and X::Y::Z's Bar at the same time. Well you can't. The patch that I pinched this

Re: RFC 171 (v1) my Dog $spot should call a constructor implicitly

2000-08-30 Thread Hildo Biersma
Jonathan Scott Duff wrote: On Tue, Aug 29, 2000 at 11:04:26PM -0400, Michael Maraist wrote: First greatly stylistic compatibilty. An inexperienced programmer would see: my Dog $spot = "Spot"; And become confused. It's totally unintuitive (at least so far as other mainstream OO

Re: RFC 128 (v1) Subroutines: Extend subroutine contexts to include name parameters and lazy arguments

2000-08-18 Thread Hildo Biersma
=head1 ABSTRACT This RFC proposes that subroutine argument context specifiers be extended in several ways, including allowing parameters to be typed and named, and that a syntax be provided for binding arguments to named parameters. I agree with most, if not all, of this RFC. =head3

Re: RFC 124 (v1) Sort order for any hash

2000-08-18 Thread Hildo Biersma
"David L. Nicol" wrote: Hildo Biersma wrote: =head1 ABSTRACT Herein a new syntax is introduced to specify a sort function for the keys of any hash. =head1 DESCRIPTION %professors{ $a-name cmp $b-name }; I feel the sort order should be

Re: RFC 114 (v1) Perl resource configuration

2000-08-17 Thread Hildo Biersma
Steve Simmons wrote: On Wed, Aug 16, 2000 at 08:03:31PM -, Perl6 RFC Librarian wrote: Perl should provide a mechanism to have common code autoloaded from a file. . . . A C/etc/perlrc file could be used to set system-wide defaults that the system administrator would like to

Re: RFC 114 (v1) Perl resource configuration

2000-08-17 Thread Hildo Biersma
=head1 DESCRIPTION Many other programs have so called "resource configuration" files (at least that's what I call them) that are loaded and interpretted upon program startup. Some example programs that have this ability include bash, mutt, and python. Perl should do the same. A

Re: RFC 84 (v1) Replace = (stringifying comma) with =

2000-08-11 Thread Hildo Biersma
=head1 TITLE Replace = (stringifying comma) with = (pair constructor) =head1 VERSION Maintainer: Damian Conway [EMAIL PROTECTED] Date: 10 August 2000 Version: 1 Mailing List: [EMAIL PROTECTED] Number: 84 I like this a lot, especially the way it deals with subroutine

Re: RFC 23 (v2) Higher order functions

2000-08-09 Thread Hildo Biersma
=head1 TITLE Higher order functions Sounds good. We should add this to the language. Oh boy, the tricks we can play with this... Hildo

Re: RFC 73 (v1) All Perl core functions should return ob

2000-08-09 Thread Hildo Biersma
=head1 TITLE All Perl core functions should return objects Yuck. Why not use the proposed want() and return hash-refs or slices, when appropriate. Hildo

Re: RFC 48 (v2) Objects should have builtin stringifying

2000-08-09 Thread Hildo Biersma
John Porter wrote: Michael Fowler wrote: I think a stringified reference is worth seeing, moreso than a simple undef, for debugging purposes if nothing else. I personally would like to have the stringification of refs be a symmetric operation, i.e. such a string should dwim in a ref

Re: RFC: println()

2000-08-08 Thread Hildo Biersma
Ed Mills wrote: I actually saw this in the newsgroups and thought it was a neat idea. What about println $textvar; instead of print "$textvar\n"; Ever so much easier to read and write, prints the arg and appends \n. This is probably what I disliked most about Pascal - it

Re: Things to remove

2000-08-08 Thread Hildo Biersma
Bennett Todd wrote: There are many intents and points to this project. As _I_ see them, they include, in no particular order: - cleaning up the language definition, where practical without losing the distinctive appeal of perl to happy perl programmers; - cleaning up the

Re: RFC 52 (v1) List context return from filesystem func

2000-08-07 Thread Hildo Biersma
Leon Brocard wrote: Perl6 RFC Librarian sent the following bits through the ether: affected files. I suggest that in a list context, they return the Inames of the Iunsuccessfully affected files. This seems the wrong way around to me. Surely it should instead return the name of the

Re: ISA number

2000-08-07 Thread Hildo Biersma
Peter Scott wrote: Have often wanted a way to tell whether a scalar was a number, and rolling a regex each time seemed wasteful given that Perl knew what it was anyway. So a user-friendly way to get at the SvIOK and SvNOK results would be great. The pedestrian way would be a builtin:

Re: New Group proposed: subs (was Re: named parameters)

2000-08-04 Thread Hildo Biersma
Damian Conway wrote: One of my many RFCs will include a proposal for a $SELF variable along those lines. Before it's too late - please, don't impose either '$self' or '$this', but make this a per-module choice. I deal with people of both these religions... Hildo

Re: try/catch (Was: Re: RFC: Modify open() and opendir() to return handles)

2000-08-04 Thread Hildo Biersma
Johan Vromans wrote: You missed the point. If you need 6+ lines of code for each elementary error check, this is what is going to happen (and it _does_ happen in almost every Java program I've seen): try { open file while read a record process its contents

Re: date interface (was Re: perl6 requirements, on bootstrap)

2000-08-03 Thread Hildo Biersma
Matt Sergeant wrote: [I might join perl6-language some day, but until then, please CC me on all Time::Object related messages] Original from="Bart Lateur" On Wed, 2 Aug 2000 08:14:22 +0100 (BST), Matt Sergeant wrote: I used to be a C programmer myself (well OK, I was a C++

Re: Reduce [was: Re: Random items (old p5p issues)]

2000-08-02 Thread Hildo Biersma
Tom Christiansen wrote: sub mapf(;\@\@\@\@\@\@\@\@\@) { Steal from lisp: map maap maaap mapp mappp maappp ... Should be feasible with an AUTOLOAD that takes a certain kind of regular expression... sub AUTOLOAD /^ma+p+$/ { } Some for the 'car' and