Re: RFC 66 (v1) Shell Style Redirection

2000-08-08 Thread Jon Ericson
Matthew Persico wrote: > Jon Ericson wrote: > > open(STDERR, ">&STDOUT) || die "Can't dup stdout: $!"; > > > > I don't find this hard to read or write. I think overloading < and > > > to do this would be confusing and rarely used. > > > > Au contraire - I'd use it in a heartbeat. Besides, I be

Re: RFC 14 (v2) Modify open() to support FileObjects and

2000-08-08 Thread Jon Ericson
Perl6 RFC Librarian wrote: > =head2 Extensible Class Bindings > > In addition to the standard file form, C can also now take an > optional class name from which to load the appropriate methods. This > gives us easy access to methods that open Directory, Socket, HTTP, FTP, > or other types of file

Re: RFC 66 (v1) Shell Style Redirection

2000-08-08 Thread Matthew Persico
Jon Ericson wrote: > > Perl6 RFC Librarian wrote: > > =head1 DESCRIPTION > > > > I think we've got file re-opening already, some how; this > > proposal overloads the less than and greater than operators > > in order that subsequent statements, > > particularly external routines that will be looki

Re: Treating filehandles like strings

2000-08-08 Thread Jonathan Scott Duff
On Tue, Aug 08, 2000 at 11:44:10PM +0200, Bart Lateur wrote: > On Tue, 8 Aug 2000 16:32:26 -0500, Jonathan Scott Duff wrote: > > >I sincerely hope you really mean "Let's make ``open() or die'' > >optional" Exceptions should be integrated into the language but Ye > >Olde "returns undef on error"

Re: Treating filehandles like strings

2000-08-08 Thread Bart Lateur
On Tue, 8 Aug 2000 16:32:26 -0500, Jonathan Scott Duff wrote: >I sincerely hope you really mean "Let's make ``open() or die'' >optional" Exceptions should be integrated into the language but Ye >Olde "returns undef on error" should still be available as well. > > > try { $fh = open("foo")

Re: Treating filehandles like strings

2000-08-08 Thread Jonathan Scott Duff
On Tue, Aug 08, 2000 at 10:51:25PM +0200, Bart Lateur wrote: > On Tue, 8 Aug 2000 15:12:27 -0400, Bennett Todd wrote: > >and I'll breathe a big sigh of relief when I > >can just add "use Fatal qw(:all);" to the top of all my perl scripts > >and forever more ditch all the " or die ..." clauses. >

Re: RFC 66 (v1) Shell Style Redirection

2000-08-08 Thread Jon Ericson
Perl6 RFC Librarian wrote: > =head1 DESCRIPTION > > I think we've got file re-opening already, some how; this > proposal overloads the less than and greater than operators > in order that subsequent statements, > particularly external routines that will be looking to > a file descriptor table for

Re: Treating filehandles like strings

2000-08-08 Thread Bart Lateur
On Tue, 8 Aug 2000 15:12:27 -0400, Bennett Todd wrote: >One of the most valuable features was that the very large majority >of the helper routines I used, were simply wrappers around the >standard facilities, that didn't require any error checking: the >routine succeeded, or it printed a suitable

RFC 51 (v2) Angle brackets should accept filenames a

2000-08-08 Thread Perl6 RFC Librarian
This and other RFCs are available on the web at http://dev.perl.org/rfc/ =head1 TITLE Angle brackets should accept filenames and lists =head1 VERSION Maintainer: Jon Ericson <[EMAIL PROTECTED]> Date: 8 August 2000 Version: 2 Mailing List: [EMAIL PROTECTED] Number: 51 =head1 ABSTRA

RFC 69 (v1) Standardize input record separator (for

2000-08-08 Thread Perl6 RFC Librarian
This and other RFCs are available on the web at http://dev.perl.org/rfc/ =head1 TITLE Standardize input record separator (for portability) =head1 VERSION Maintainer: N. Hao Ching <[EMAIL PROTECTED]> Date: 08 Aug 2000 Version: 1 Mailing List: [EMAIL PROTECTED] Number: 69 =head1 ABS

RFC 66 (v1) Shell Style Redirection

2000-08-08 Thread Perl6 RFC Librarian
This and other RFCs are available on the web at http://dev.perl.org/rfc/ =head1 TITLE Shell Style Redirection =head1 VERSION Maintainer: David Nicol <[EMAIL PROTECTED]> Date: 8 Aug 2000 Version: 1 Mailing List: [EMAIL PROTECTED] Number: 66 =head1 ABSTRACT The C pragma or a new C

Re: Treating filehandles like strings

2000-08-08 Thread Bennett Todd
2000-08-07-20:43:29 Nathan Wiger: > > I'd rather have a filehandle stringify to > > the filename instead. > > Great minds think alike. :-) I was actually going to add this to the new > version of the open() RFC as a possible use of RFC 49's > soon-to-be-renamed STRING method. > > Now I know I h

Re: Treating filehandles like strings

2000-08-08 Thread Jon Ericson
Hildo Biersma wrote: > Jon Ericson wrote: > > You misunderstand. I want to write this: > > > > open my $file, '/path/to/file' or die "can't open $file: $!"; > > # code passes > > # /path/to/file is removed by another process > > # dang! what file did I open? > > print "I opened $file\n"

Re: Treating filehandles like strings

2000-08-08 Thread Hildo Biersma
Jon Ericson wrote: > > You misunderstand. I want to write this: > > open my $file, '/path/to/file' or die "can't open $file: $!"; > # code passes > # /path/to/file is removed by another process > # dang! what file did I open? > print "I opened $file\n"; # ahh! that was it As cool as

Re: Treating filehandles like strings

2000-08-08 Thread Jon Ericson
Bart Lateur wrote: > On Mon, 07 Aug 2000 17:43:29 -0700, Nathan Wiger wrote: > >> I'd rather have a filehandle stringify to > >> the filename instead. > > > >Great minds think alike. :-) I was actually going to add this to the new > >version of the open() RFC as a possible use of RFC 49's > >soon-

Re: Treating filehandles like strings

2000-08-08 Thread Jonathan Scott Duff
On Tue, Aug 08, 2000 at 12:09:52PM +0200, Bart Lateur wrote: > On Mon, 07 Aug 2000 17:43:29 -0700, Nathan Wiger wrote: > > >> I'd rather have a filehandle stringify to > >> the filename instead. > > > >Great minds think alike. :-) I was actually going to add this to the new > >version of the open

Re: Treating filehandles like strings

2000-08-08 Thread Bart Lateur
On Mon, 07 Aug 2000 17:43:29 -0700, Nathan Wiger wrote: >> I'd rather have a filehandle stringify to >> the filename instead. > >Great minds think alike. :-) I was actually going to add this to the new >version of the open() RFC as a possible use of RFC 49's >soon-to-be-renamed STRING method. >