Re: RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-16 Thread Nathan Wiger
Graham Barr wrote: > > > Create a new handle, like $DEFOUT. Then there would be no need > for selectsaver either as you would do the equiv. of > > local($DEFOUT) = $newhandle; Just submitted an RFC on this exact idea. -Nate

Re: RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-16 Thread Graham Barr
On Wed, Aug 16, 2000 at 08:27:04PM +, Nick Ing-Simmons wrote: > Perl6 Rfc Librarian <[EMAIL PROTECTED]> writes: > > > >In addition, this RFC recommends deprecating select(), since it is no > >longer needed with the new fileobject approach described in RFC 14. > > > > > > $oldoutput = select(

Re: RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-16 Thread Nick Ing-Simmons
Nathan Wiger <[EMAIL PROTECTED]> writes: > >For other stuff, like print(), instead of using the "currently selected >filehandle", just always have it print to $STDOUT unless something's >specified. So: > > $oldstdout = $STDOUT; > $STDOUT = $myfileobject; > print "Hello, world!"; # always p

Re: RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-16 Thread Nick Ing-Simmons
Michael Fowler <[EMAIL PROTECTED]> writes: >On Sat, Aug 12, 2000 at 08:49:00AM -, Perl6 RFC Librarian wrote: >> In addition, this RFC recommends deprecating select(), since it is no >> longer needed with the new fileobject approach described in RFC 14. > >You should probably mention here that

Re: RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-16 Thread Nick Ing-Simmons
Perl6 Rfc Librarian <[EMAIL PROTECTED]> writes: > >In addition, this RFC recommends deprecating select(), since it is no >longer needed with the new fileobject approach described in RFC 14. > > > $oldoutput = select($newoutput); > >Can now be written simply as reassignments: > > $oldoutput = $

Re: RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-12 Thread Chris Nandor
At 9:45 -0700 2000.08.12, Nathan Wiger wrote: >For other stuff, like print(), instead of using the "currently selected >filehandle", just always have it print to $STDOUT unless something's >specified. So: > > $oldstdout = $STDOUT; > $STDOUT = $myfileobject; > print "Hello, world!"; # alway

Re: RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-12 Thread Chris Nandor
I am not on the list, I just read the RFC and was a bit troubled by the following: At 8:49 + 2000.08.12, Perl6 RFC Librarian wrote: >Also, select() is deprecated by this new approach and can be removed. >This code block: > > $oldoutput = select($newoutput); > >Can now be written simply as r

Re: RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-12 Thread Michael Fowler
On Sat, Aug 12, 2000 at 08:49:00AM -, Perl6 RFC Librarian wrote: > In addition, this RFC recommends deprecating select(), since it is no > longer needed with the new fileobject approach described in RFC 14. You should probably mention here that the single-arg form of select() is the one you'r

Re: RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-12 Thread Nathan Wiger
> >The rule is easier ("print always goes to $STDOUT, whatever that > >contains") and there's not select() overhead. Everything else should be > >object methods, making stuff clearer still. > > And it is also a pain in the butt. > > select *LOG; > do_stuff(); > > sub do_stuff { > pri

Re: RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-12 Thread Nathan Wiger
> That's no different than the current state of affairs. > >$oldoutput = *STDOUT; >*STDOUT = $filehandle; > > I don't see how select() is any less needed under this proposal than it is now. Perl 5 has the concept of a "currently selected filehandle". So, whatever is selected by select()

RFC 30 (v2) STDIN, STDOUT, and STDERR should be renamed

2000-08-12 Thread Perl6 RFC Librarian
This and other RFCs are available on the web at http://dev.perl.org/rfc/ =head1 TITLE STDIN, STDOUT, and STDERR should be renamed =head1 VERSION Maintainer: Nathan Wiger <[EMAIL PROTECTED]> Date: 04 Aug 2000 Last-Modified: 12 Aug 2000 Version: 2 Mailing List: [EMAIL PROTECTED] Nu