Re: [HACKERS] tap tests on older branches fail if concurrency is used

2017-06-07 Thread Craig Ringer
On 7 June 2017 at 13:39, Michael Paquier wrote: > On Thu, Jun 1, 2017 at 10:48 PM, Tom Lane wrote: >> Andres Freund writes: >>> when using >>> $ cat ~/.proverc >>> -j9 >>> some tests fail for me in 9.4 and 9.5. >> >> Weren't

Re: [HACKERS] tap tests on older branches fail if concurrency is used

2017-06-06 Thread Michael Paquier
On Thu, Jun 1, 2017 at 10:48 PM, Tom Lane wrote: > Andres Freund writes: >> when using >> $ cat ~/.proverc >> -j9 >> some tests fail for me in 9.4 and 9.5. > > Weren't there fixes specifically intended to make that safe, awhile ago? 60f826c has not been

Re: [HACKERS] tap tests on older branches fail if concurrency is used

2017-06-06 Thread Michael Paquier
On Wed, May 31, 2017 at 8:45 PM, Craig Ringer wrote: > On 1 June 2017 at 08:15, Andres Freund wrote: >> Hi, >> >> when using >> $ cat ~/.proverc >> -j9 >> >> some tests fail for me in 9.4 and 9.5. E.g. src/bin/script's tests >> yields a lot of fun

Re: [HACKERS] tap tests on older branches fail if concurrency is used

2017-06-01 Thread Tom Lane
Andres Freund writes: > when using > $ cat ~/.proverc > -j9 > some tests fail for me in 9.4 and 9.5. Weren't there fixes specifically intended to make that safe, awhile ago? regards, tom lane -- Sent via pgsql-hackers mailing list

Re: [HACKERS] tap tests on older branches fail if concurrency is used

2017-05-31 Thread Craig Ringer
On 1 June 2017 at 08:15, Andres Freund wrote: > Hi, > > when using > $ cat ~/.proverc > -j9 > > some tests fail for me in 9.4 and 9.5. E.g. src/bin/script's tests > yields a lot of fun like: > $ (cd ~/build/postgres/9.5-assert/vpath/src/bin/scripts/ && make check) > ... > #

Re: [HACKERS] tap tests on older branches fail if concurrency is used

2017-05-31 Thread Craig Ringer
On 1 June 2017 at 08:15, Andres Freund wrote: > Hi, > > when using > $ cat ~/.proverc > -j9 > > some tests fail for me in 9.4 and 9.5. E.g. src/bin/script's tests > yields a lot of fun like: > $ (cd ~/build/postgres/9.5-assert/vpath/src/bin/scripts/ && make check) > ... > #

[HACKERS] tap tests on older branches fail if concurrency is used

2017-05-31 Thread Andres Freund
Hi, when using $ cat ~/.proverc -j9 some tests fail for me in 9.4 and 9.5. E.g. src/bin/script's tests yields a lot of fun like: $ (cd ~/build/postgres/9.5-assert/vpath/src/bin/scripts/ && make check) ... # LOG: received immediate shutdown request # WARNING: terminating connection because of